GNOME 2.0 Desktop for the Solaris Operating Environment Troubleshooting Guide

Beta
Contents

Preface 7

1 Installation Problems 11
  1.1 Installation Log 11
  1.2 Installation Failed Error Message 12
  1.3 Uninstalling the GNOME 1.4 Desktop 12
  1.4 Uninstalling the GNOME 2.0 Desktop 12
  1.5 Installing the GNOME Desktop Without the Installer 13
  1.6 ScrollKeeper Fails After Installation 13

2 Startup Problems 15
  2.1 GNOME Desktop Menu Item Missing From Login Screen 15
  2.2 Startup Error Messages 16
  2.3 General Startup Problems 16

3 Window and Session Management Problems 19
  3.1 Window Manager Crashes 19
  3.2 Logging Out Without a Panel 19
  3.3 Applications Do Not Restore Properly 20
  3.4 Unexpected Window Behavior 20
  3.5 Unexpected Swing Behavior 21

4 General GNOME Desktop Problems 23
  4.1 Finding Out More 23
4.2 Which Version of the GNOME Desktop? 24
4.3 Displaying Developer Documentation in Netscape 4.x 24
4.4 General Error Messages 25
4.5 No Nautilus Viewer for File Type 25
4.6 Nautilus Crashes Or Freezes 26
4.7 Nautilus Slows the System 26
4.8 TIF Files Crash Panels 26
4.9 Finding Out About GConf 27
4.10 Conflicts With Screensavers 27
4.11 Selected Screen Does Not Display 28
4.12 Solaris Removable Media Manager 28

5 Problems With Specific Applications 29
5.1 Dynamically-Set Title Does Not Work 29
5.2 ScrollKeeper Options Not Fully Documented 31
5.3 Table of Contents is Empty in Help Page 32

6 Hardware Problems 33
6.1 Multihead Display 33
6.2 Sound Events Do Not Work 34
6.3 Configuring Your Mouse for x86 Systems 34
6.4 Running the GNOME Desktop on a Sun Ray Server 36
6.5 No Sound From Audio CD 36

7 Performance Enhancement 37
7.1 Adjust Nautilus Settings 37
7.2 Adjust Background Settings 38
7.3 Change Window Frame Theme 38
7.4 Reduce Applets 38
7.5 Transparent Terminals 39
7.6 Enable Wireframe Window Moves 39
7.7 Install mediaLib Libraries 39
7.8 Improving CDE Application Performance 40

8 Accessibility Problems 41
8.1 Keyboard Is Unresponsive 41
8.2 Numeric Keypad Is Unresponsive 42
8.3 System Beeps Continuously 42
8.4 System Beeps Incorrectly for Slow Keys 43
8.5 Mouse Keys Functionality 43

9 Localization and Internationalization Problems 45

9.1 Localized Locales 45
9.2 Problems That Affect All Locales 48
  9.2.1 Unlocalized Menu Items 48
  9.2.2 Warning Messages to Console 49
  9.2.3 Obsolete Topics In Online Help 49
  9.2.4 Multiple Trash Icons 49
  9.2.5 Dialogs and Panels Are Not Localized 49
  9.2.6 Cannot Open a File Created in a Different Locale 50
  9.2.7 Launching gmines Causes a Segmentation Fault 50
9.3 Problems That Affect European Locales 50
  9.3.1 OpenWindows Login Option Is Missing 51
  9.3.2 Start Menu Is Not Localized 51
  9.3.3 Characters Are Displayed Incorrectly in the XScreenSaver Properties Dialog 51
  9.3.4 Keyboard Shortcut Does Not Change Input Method Window 52
  9.3.5 Poor Font Quality in Terminal 52
  9.3.6 No Support for CP1251 and ANSI1251 Encoding 52
  9.3.7 Rasterization Problems in Russian Locale 53
  9.3.8 Help Appears Only in English 54
9.4 Problems That Affect Asian Locales 54
  9.4.1 Default Desktop Font Is Too Small Or Blank 55
  9.4.2 Special Fonts Are Missing in Chinese Locales 55
  9.4.3 GNOME Ghostscript Display 56
  9.4.4 Font Quality Is Poor 57
  9.4.5 Different Date Format in the Solaris Operating Environment 57
  9.4.6 Character Display Problem in GTK2+ Applications 57
  9.4.7 Printing Out From gedit in the Solaris 8 Operating Environment 58
  9.4.8 Cannot Print Japanese Characters With Default Font in gedit 58
  9.4.9 Cannot Open ISO-2022-JP Encoded File 58
  9.4.10 Localized Characters Do Not Display in gedit 59
  9.4.11 Poor Japanese Font Quality with Default Font in gedit 59
  9.4.12 Character Display Problem in Terminal 59
9.4.13 Core Dump When Copy or Link to File 60
9.4.14 Input Method Window Repeatedly Flushed 60
9.4.15 Japanese Locale Core Dump 60
9.4.16 GTK2+ Applications Freeze 61
9.5 Problems That Affect Complex-Text Locales 61
   9.5.1 Incomplete Support for Right-to-Left Languages 61

Index 63
Preface

The GNOME 2.0 Desktop for the Solaris Operating Environment Troubleshooting Guide describes known problems with the GNOME 2.0 Desktop for the Solaris™ 8 operating environment and the Solaris 9 operating environment. The guide provides workarounds for many of the known problems.

Who Should Use This Book

Different chapters in this manual provide information for the following users:

- Accessibility engineers and users with accessibility needs
- Developers
- End users
- Localization teams
- System Administrators

How This Book Is Organized

This guide is structured in the following way:

- Chapter 1 discusses problems and workarounds that system administrators and users might encounter when installing the desktop environment.
- Chapter 2 discusses problems that system administrators and users might encounter when they start up the desktop environment for the first time.
- Chapter 3 provides information for users about how to deal with window and session management problems in the desktop environment.
Chapter 4 provides information about general problems that users might have with the desktop environment.

Chapter 5 provides information about problems that users might have with GNOME applications.

Chapter 6 provides information about hardware problems that might affect your desktop environment.

Chapter 7 provides some tips for users about improving the performance of the desktop environment.

Chapter 8 provides information about how to deal with accessibility-related problems in the desktop environment.

Chapter 9 provides information for localization teams about how to deal with localization-related problems in the desktop environment.

Related Books
The following manuals are related to this guide.

- GNOME 2.0 Desktop for the Solaris Operating Environment Accessibility Guide
- GNOME 2.0 Desktop for the Solaris Operating Environment Installation Guide
- GNOME 2.0 Desktop for the Solaris Operating Environment Release Notes
- GNOME 2.0 Desktop for the Solaris Operating Environment System Administration Guide
- GNOME 2.0 Desktop for the Solaris Operating Environment User Guide

Accessing Sun Documentation Online
The docs.sun.comSM Web site enables you to access Sun technical documentation online. You can browse the docs.sun.com archive or search for a specific book title or subject. The URL is http://docs.sun.com
Ordering Sun Documentation

Sun Microsystems offers select product documentation in print. For a list of documents and how to order them, see “Buy printed documentation” at http://docs.sun.com.

Typographic Conventions

The following table describes the typographic changes used in this book.

**TABLE P–1 Typographic Conventions**

<table>
<thead>
<tr>
<th>Typeface or Symbol</th>
<th>Meaning</th>
<th>Example</th>
</tr>
</thead>
</table>
| AaBbCc123          | The names of commands, files, and directories; on-screen computer output | Edit your .login file.  
Use `ls -a` to list all files.  
machine_name% you have mail. |
| AaBbCc123          | What you type, contrasted with on-screen computer output | machine_name% su  
Password: |
| AaBbCc123          | Command-line placeholder: replace with a real name or value | To delete a file, type `rm filename`. |
| AaBbCc123          | Book titles, new words, or terms, or words to be emphasized. | Read Chapter 6 in User’s Guide.  
These are called class options.  
You must be root to do this. |

Shell Prompts in Command Examples

The following table shows the default system prompt and superuser prompt for the C shell, Bourne shell, and Korn shell.
<table>
<thead>
<tr>
<th>Shell</th>
<th>Prompt</th>
</tr>
</thead>
<tbody>
<tr>
<td>C shell prompt</td>
<td>machine_name%</td>
</tr>
<tr>
<td>C shell superuser prompt</td>
<td>machine_name#</td>
</tr>
<tr>
<td>Bourne shell and Korn shell prompt</td>
<td>$</td>
</tr>
<tr>
<td>Bourne shell and Korn shell superuser prompt</td>
<td>#</td>
</tr>
</tbody>
</table>
Installation Problems

This section provides tips about dealing with problems that arise when you install the GNOME 2.0 Desktop on the Solaris™ 8 operating environment or Solaris 9 operating environment.

- “1.1 Installation Log” on page 11
- “1.2 Installation Failed Error Message” on page 12
- “1.3 Uninstalling the GNOME 1.4 Desktop” on page 12
- “1.4 Uninstalling the GNOME 2.0 Desktop” on page 12
- “1.5 Installing the GNOME Desktop Without the Installer” on page 13
- “1.6 ScrollKeeper Fails After Installation” on page 13

### 1.1 Installation Log

<table>
<thead>
<tr>
<th>Problem</th>
<th>Where do I look for installation errors?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solution</td>
<td>The most recent GNOME 2.0 Desktop installation log is in the following location: /var/sadm/install/logs</td>
</tr>
</tbody>
</table>
1.2 Installation Failed Error Message

Problem  The installation fails with the following error message: pkgadd:
            ERROR: cppath(): unable to start

Solution  You are either using the wrong version of tar or the tar
           file is corrupt. You must use Solaris tar or GNU tar version 1.13 or
greater. If the tar file is corrupt, you must download the tar file
again.

1.3 Uninstalling the GNOME 1.4 Desktop

Problem  I already have the GNOME 1.4 Desktop on system. How do I
         uninstall the GNOME 1.4 Desktop?

Solution  Perform the following steps:
         1. Log into CDE as root.
         2. Open a terminal window.
         3. Type cd /var/sadm/prod
         4. Type java uninstall_gnome_1_4

         If you have already installed the GNOME 2.0 Desktop, you can
remove the GNOME 1.4 Desktop by logging in as root and running
the following command: /usr/sbin/remove-gnome -version
1.4

1.4 Uninstalling the GNOME 2.0 Desktop

Problem  How do I uninstall the GNOME 2.0 Desktop?
1. Log in as root.
2. Run the following command: `/usr/sbin/remove-gnome`

1.5 Installing the GNOME Desktop Without the Installer

How do I install the GNOME 2.0 Desktop without the GUI installer?

Solution
Run the alternative text-based install script. To do this you must first unpack the tar file to create a GNOME directory in your current directory. Then run the script which corresponds to your system architecture:

SPARC Architecture Edition: `./GNOME/sparc/pkgs/install`
x86: Architecture Edition: `./GNOME/i386/pkgs/install`

1.6 ScrollKeeper Fails After Installation

ScrollKeeper fails after Jumpstarts, upgrades and live upgrades.
Solution

ScrollKeeper fails due to software dependencies not being available. The workaround is as follows:

For all installations, upgrades and live upgrades that install directly into the root filesystem, the ScrollKeeper database is propagated during the installation, using a postinstall script provided with each package as required.

For all other installations that do not install into the root filesystem directory, the postinstall script does not propagate the ScrollKeeper database.

You must propagate the ScrollKeeper database manually when you log in for the first time. You need root access to perform this action. Execute the following commands in the C locale:

1. `su password`
2. `/usr/bin/scrollkeeper-rebuilddb`

In some cases, the location of `/usr/bin/scrollkeeper-rebuilddb` might be similar to the following:

`{INSTALL_ROOT}/usr/bin/scrollkeeper-rebuilddb`
Startup Problems

This section describes issues that might occur when you start up the GNOME 2.0 Desktop.

- “2.1 GNOME Desktop Menu Item Missing From Login Screen” on page 15
- “2.2 Startup Error Messages” on page 16
- “2.3 General Startup Problems” on page 16

2.1 GNOME Desktop Menu Item Missing From Login Screen

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
</table>
| A menu item for the GNOME 2.0 Desktop does not appear in the login screen. | GNOME dtlogin resource files are currently only installed for the C locale. To make the GNOME login option appear in other locales, you must copy this resource file to the correct directory for your locale. Use the following command to copy the dtlogin file: 

```
cp /usr/dt/config/C/Xresources.d/Xresources.Sun-gnome-2.0* /usr/dt/config/{your locale}/Xresources.d
```
| Future releases will include localized versions of this file. |
2.2 Startup Error Messages

Problem Where do I look for error messages if startup fails?
Solution The following files contain messages that might be helpful in diagnosing incorrect permissions, missing files and other problems.
- ~/.dt/startlog
- ~/.dt/startlog.old
- ~/.dt/startlog.older

To enable logging of more detailed information, edit ~/.dtprofile and remove the
dtstart_sessionlogfile=/dev/null line.

The session logs are placed in the following location:
~/.dt/sessionlogs/*

An alternative solution is to run gnome-session from a failsafe session, and read any error messages that appear.

2.3 General Startup Problems

Problem How do I fix general startup problems such as the following:
- The login process never gets past the black screen.
- Panels do not respond to my input.
- Icons do not display correctly.
- Panels do not appear.
- Error popups referring to missing files in /opt/gnome-2.0/share appear.
- The GNOME Menu icon appears in place of the correct icon.
- The desktop background image is an empty white space.
Solution

Perform the following steps:

1. Run the following cleanup script: /usr/bin/gnome-cleanup
2. Remove your session files from ~/.dt/sessions/gnome
3. Make sure you do not have anything in your .xinitrc file that conflicts with the GNOME 2.0 Desktop. If you are not sure, rename your ~/.xinitrc file to ~/.xinitrc.orig and try to login again.
4. Make sure your LD_LIBRARY_PATH does not point to a directory which contains incompatible versions of the GNOME libraries. The GNOME 2.0 Desktop does not require LD_LIBRARY_PATH to be set at all. If you must define this for other applications, try adding /usr/lib and /usr/sfw to the beginning of your LD_LIBRARY_PATH.
5. Kill the gconfd-2 process.
6. Run the following command: bonobo-slay
   Try to log in again.
Window and Session Management Problems

This section provides information about how to deal with window and session management problems in the GNOME 2.0 Desktop.

- “3.1 Window Manager Crashes” on page 19
- “3.2 Logging Out Without a Panel” on page 19
- “3.3 Applications Do Not Restore Properly” on page 20
- “3.4 Unexpected Window Behavior” on page 20
- “3.5 Unexpected Swing Behavior” on page 21

3.1 Window Manager Crashes

**Problem**
The Metacity window manager crashes, and the frames disappear from all windows.

**Solution**
Session manager automatically restarts the window manager. If this does not happen, log out and then log back in.

3.2 Logging Out Without a Panel

**Problem**
How do I log out if all my panels have disappeared?
Solution
1. Right-click on the desktop background to open the desktop background menu.
2. Select the menu item New Terminal.
3. Enter the following command in the new terminal:
   `gnome-session-save --kill`
4. If you still cannot log out, then run the following command:
   `pkill gnome-session`

3.3 Applications Do Not Restore Properly

Problem
When I logged out, I selected Save current setup, but some applications did not restore properly the next time I logged in.

Solution
The following applications have the following known problems:
- Terminal does not restore.
- Gedit restores to the upper left corner of the screen.

There are plans to fix these problems in a future release.

3.4 Unexpected Window Behavior

Problem
Some of my application windows appear above all desktop environment windows and do not restore properly or appear in the GNOME window list.

Solution
By default, many applications which are based on MainSoft libraries ignore the window manager and attempt to manage their own windows. Rational Rose and XML Professional Publisher are known to have this problem. To tell MainSoft-based applications to behave correctly, you must set the MWWM environment variable as follows:

`MWWM=allwm`
3.5 Unexpected Swing Behavior

Problem: Swing components prior to those included in Java™ 2 Platform Standard Edition V1.4 do not position, resize, or refresh consistently.

Solution: Perform the following steps:
1. Upgrade to Java 2 Platform Standard Edition V1.4 or later.
2. Ensure that your application is configured to use the Java 1.4 JVM.
CHAPTER 4

General GNOME Desktop Problems

This section provides information about how to deal with general problems in the GNOME 2.0 Desktop.

- “4.1 Finding Out More” on page 23
- “4.2 Which Version of the GNOME Desktop?” on page 24
- “4.3 Displaying Developer Documentation in Netscape 4.x” on page 24
- “4.4 General Error Messages” on page 25
- “4.5 No Nautilus Viewer for File Type” on page 25
- “4.6 Nautilus Crashes Or Freezes” on page 26
- “4.7 Nautilus Slows the System” on page 26
- “4.8 TIF Files Crash Panels” on page 26
- “4.9 Finding Out About GConf” on page 27
- “4.10 Conflicts With Screensavers” on page 27
- “4.11 Selected Screen Does Not Display” on page 28
- “4.12 Solaris Removable Media Manager” on page 28

4.1 Finding Out More

Problem  I am having a problem with the GNOME 2.0 Desktop. Where can I find more information?
4.2 Which Version of the GNOME Desktop?

Problem
How do I find which version of the GNOME Desktop is running?

Solution
Right click on a panel and select About GNOME.

4.3 Displaying Developer Documentation in Netscape 4.x

Problem
Developer documentation located in /usr/share/gnome/devel-doc does not display correctly in Netscape 4.x.

Solution
gtk-doc makes use of cascading stylesheets (CSS) which are not completely supported in Netscape 4.x. The following browsers support CSS fully:

- Netscape 6.x, and higher versions of Netscape
- Opera
- Galeon
- Mozilla
- Internet Explorer 5, and higher versions of Internet Explorer
4.4 General Error Messages

Problem
Where do I look for error messages when an application crashes or fails to run correctly?

Solution
Look in the following files:
- ~/.dt/errorlog
- ~/.dt/errorlog.old
- ~/.dt/errorlog.older
- ~/.dt/sessionlogs

You can also try running the application from a command line to see if any error message appear.

You can capture a core file from a GNOME-compliant application by running the application with the `--disable-crash-dialog` option or by setting the `GNOME_DISABLE_CRASH_DIALOG` environment variable to 1 before running the application.

4.5 No Nautilus Viewer for File Type

Problem
When I double-click on some file types in Nautilus, a dialog indicates that Nautilus has no installed viewer capable of displaying the file.

Solution
Perform the following steps:
1. Open the Applications menu.
2. Choose Desktop Preferences -> Advanced -> File Types and Programs.
3. Make sure the MIME type or extension for the file is associated with an application in the File Types and Programs dialog.
4. Make sure that the associated application is in your $PATH.
4.6 Nautilus Crashes Or Freezes

Problem: Nautilus crashes or freezes when an open browser window points to a bad NFS mount.

Solution: Run the following command: `pkill nautilus`

When Nautilus restarts, the bad NFS directory is not available. If you saved a session while Nautilus was pointing to a bad mount, remove your session files in `~/.dt/sessions/gnome`.

4.7 Nautilus Slows the System

Problem: Nautilus slows my system or freezes when searching for Trash on an NFS mounted volume.

Solution: Perform the following actions to prevent Nautilus from searching for trash on a NFS file systems:
1. Edit the following file:
   `/usr/share/gnome/nautilus/filesystem-attributes.xml`
2. Set the following entry:
   ```xml
   filesystem name="nfs" _default_volume_name="NFS Network Volume" trash="no"
   ```
3. Run the following command to restart Nautilus: `pkill nautilus`

4.8 TIF Files Crash Panels

Problem: My panels crash when I select a TIF image file in the panel properties background dialog.
Solution

To resolve this problem you must ensure that /usr/sfw/lib precedes /usr/openwin/lib in your LD_LIBRARY_PATH.

4.9 Finding Out About GConf

Problem
How do I find out about the GNOME 2.0 Configuration System (GConf)?

Solution
You can find more information about gconf at the following website: http://www.gnome.org/projects/gconf

The GNOME 2.0 Desktop for the Solaris Operating Environment System Administration Guide also has a chapter describing gconf functionality.

4.10 Conflicts With Screensavers

Problem
My screen lock preferences contain the following screensaver displays that can conflict with some frame buffer drivers:

- Insecure screen distortion screensaver displays
- Screensaver displays such as julia and penrose

These screensaver displays occasionally run when I select random screensaver.

Solution
You have an old ~/.xscreensaver file. Perform the following steps:

1. Remove the ~/.xscreensaver file.
2. Log out, then log in.

You can deselect screensaver displays that you do not need in the Display Modes tab of the screensaver properties dialog.
4.11 Selected Screen Does Not Display

Problem: I can configure the screensaver displays in the configuration panel, but when I preview the screensaver display, or specify a blank screen, my chosen screensaver display does not appear.

Solution: XScreenSaver only enables graphical screensaver displays on machines that are running DPMS (Display Power Management System). You can enable DPMS with the following command:

```
xset +dpms
```

Sun Ray™ clients do not run DPMS.

---

4.12 Solaris Removable Media Manager

Problem: Which operating environment do I need to install the Solaris Removable Media Manager?

Solution: Nautilus provides functionality similar to the Solaris Removable Media Manager. To avail of the Removable Media feature in the GNOME Desktop, the version of the operating environment must be Solaris 8 Update 1 or higher. Do not attempt to install this feature by installing a set of ad hoc patches.
Problems With Specific Applications

This section provides information about problems and associated workarounds for specific applications.

- “5.1 Dynamically-Set Title Does Not Work” on page 29
- “5.2 ScrollKeeper Options Not Fully Documented” on page 31
- “5.3 Table of Contents is Empty in Help Page” on page 32

5.1 Dynamically-Set Title Does Not Work

Problem

Bug ID 4855527, Terminal.

In the Editing profile window, Title and Command tab, the menu options for the drop-down menu Dynamically-set title do not work. Terminal uses the following bash shell environment variable to set the dynamically-set title and the shell prompt:

```
PROMPT_COMMAND=$'echo -ne \033[0;${USER}@${HOSTNAME}: ${PWD}\007'
PS1=$'\[\u@\h \W]\$ ' USER='id -un'
```

On Linux /etc/bashrc sets the required environment variables, but does not set these variables for the Solaris operating environment. Hence, the dynamically-set title and the shell prompt do not work in the Solaris operating environment.
Solution

As a workaround you can set the required environment variable by executing scripts for the various shells.

bash shell:

Set the following in `bashrc`:

```bash
case $TERM in
  xterm*)
    PS1="[\033\]0;\u@\h: \w\007\]bash\$ ">
  *)
    PS1="bash\$ "
  esac
```

(or)

```bash
USER=/usr/xpg4/bin/id -un'
export USER

PROMPT_COMMAND="echo -ne \"\033\]0;\${USER}@\${HOSTNAME}: \${PWD}\007\c\""
```

ksh shell:

Add the following in the `~.profile` file:

```bash
mycd () {
  cd \"\$@\"; echo \"\^"\[033\]0;\${USER}@\${HOSTNAME}: \${cwd}^Gcsh% \"
}
alias cd=mycd
```

csh shell:

Set the following in `cshrc`:

```bash
switch ($TERM)
  case ^xterm$:
    set host='hostname'
    alias cd 'cd \!'; echo ^"\[033\]0;\${user}@\${host}: \${cwd}^Gcsh% ^G'
  breaksw
default:
  set prompt='csh%'
  breaksw
endsw
```

The `^` and `^G` characters in the prompt string are single characters for ESC and BEL. You can enter these characters using Ctrl+v+ESC and Ctrl+v+g.
5.2 ScrollKeeper Options Not Fully Documented

Problem ScrollKeeper.

In the scrollkeeper-rebuild db man page, the -o and -p options are not fully documented.

Solution You do not need to use the -o and -p options to perform a standard setup of the ScrollKeeper database. These options are required only in the following situations:

- The ScrollKeeper database must be installed in a location other than the standard location. For example, setting up diskless clients.
  Use the -p path option to specify the location of the ScrollKeeper database, where path is an empty directory. The scrollkeeper-rebuild db command will not proceed if you specify a populated path for this option.

- The OMF files must be read from a location other than the standard location. The standard location for OMF files is specified in the /etc/scrollkeeper.conf file.
  Use the -o path option to specify the location of the OMF files. Specify the complete pathname, for example, /usr/share/omf. If you specify a partial pathname, for example, /usr/share, the scrollkeeper-rebuild db command will take a long time, produce many warnings, and may crash.

The following example shows how to use the -o and -p options to set up the ScrollKeeper database for diskless clients:

```bash
# scrollkeeper-rebuild db 
-p /export/root/clone/Solaris_9/\n sun4u/var/gnome/lib/scrollkeeper \n-o /export/exec/Solaris_9_sparc.all/\n/usr/share/omf
```
<table>
<thead>
<tr>
<th>Problem</th>
<th>Bug id 4875223.</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Table of Contents is missing from the first page in the GNOME Help browser.</td>
<td></td>
</tr>
</tbody>
</table>

| Solution | This is a ScrollKeeper issue. See “1.6 ScrollKeeper Fails After Installation” on page 13 for the workaround. |
CHAPTER 6

Hardware Problems

This section provides information about how to deal with hardware-related problems in the GNOME 2.0 Desktop.

- “6.1 Multihead Display” on page 33
- “6.2 Sound Events Do Not Work” on page 34
- “6.3 Configuring Your Mouse for x86 Systems” on page 34
- “6.4 Running the GNOME Desktop on a Sun Ray Server” on page 36
- “6.5 No Sound From Audio CD” on page 36

6.1 Multihead Display

Problem: My machine has more than one head. How do I display GNOME applications on the second head?

Solution: The GNOME Desktop installation process can detect machines with more than one head. Multihead displays should start automatically. You can also manually bring up an application on an alternate head by setting your $DISPLAY variable or launching the application with the --display=:0.n flag, where n is the display number.

If you use two identical frame buffers set for the same video depth, you can also modify /etc/dt/config/Xservers or /usr/dt/config/Xservers to run XSun in Xinerama mode. The GNOME Desktop then treats both video heads as a single logical display.
6.2 Sound Events Do Not Work

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
</table>
| Sound events do not work in Nautilus. | Perform the following steps:  
1. Open the Applications menu.  
2. Choose Desktop Preferences -> Sound.  
3. Select the following options:  
   - Enable sound server startup  
   - Sounds for events  
4. Hover the mouse pointer over file icons to listen to certain types of sound event in Nautilus.  
   All events are not yet enabled. |

6.3 Configuring Your Mouse for x86 Systems

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Neither a two-button mouse, nor a three-button mouse work correctly when the GNOME Desktop is running on the x86 architecture edition.</td>
<td></td>
</tr>
</tbody>
</table>
Solution

Many GNOME applications require a three-button mouse. You need to do the following:

- Three-button mouse: enable the third button.
- Two-button mouse: emulate a third button when you click on the two buttons simultaneously.

To enable a third mouse button, or emulate a three-button mouse, perform the following steps:
1. Choose Options -> Command Line Login from the login screen.
2. Press Return, then log in as root.
3. Type the following command: `kdmconfig`.
   The `kdmconfig` command launches the Solaris Device Configuration Assistant, which displays the current system configurations. The program only accepts keyboard input. Use the keys shown in Table 6-1 to navigate through the menus.
4. From the main window, select Change Pointing Device/Mouse.
5. Press F2 to open the next screen.
6. Select the appropriate mouse type or emulation.
7. Press F2 to return to the main screen. The Pointer Device should have visibly changed.
8. Press F2 to display a test screen.
9. Click Yes if the screen display is correct.
10. Type the following command to quit the console session: `Exit`.

The system should now be properly configured to use a three-button mouse.

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Down arrow</td>
<td>Moves the cursor down a menu.</td>
</tr>
<tr>
<td>Up arrow</td>
<td>Moves the cursor up a menu.</td>
</tr>
<tr>
<td>F2</td>
<td>Opens the next screen.</td>
</tr>
<tr>
<td>F3</td>
<td>Exits the program without saving.</td>
</tr>
<tr>
<td>Return</td>
<td>Selects an option.</td>
</tr>
</tbody>
</table>
6.4 Running the GNOME Desktop on a Sun Ray Server

Problem: How do I run the GNOME 2.0 Desktop on a Sun Ray thin client server?

Solution: Perform the following steps:
1. Install the GNOME Desktop in the normal way.
2. If the GNOME 2.0 option does not appear on the login screen of the Sun Ray client, choose Options -> Reset Login Screen.

6.5 No Sound From Audio CD

Problem: I do not hear any sound from my audio CD.

Solution: Perform the following steps:
1. Open the Applications menu.
2. Choose CDE Menu -> Applications -> Audio Control.
3. Select the Playback tab, then turn on one of the following devices that you want to listen to:
   - Built-in Speaker
   - Headphone
   - Line Out
4. Select the Record tab, then select Internal CD for the Master Input.
5. Adjust the monitor volume to a non-zero value.

You can now listen to CDs with the CD Player application.

Note – This procedure might not work on all Sun hardware and CD configurations.
Performance Enhancement

This section provides some tips on improving the performance of the GNOME 2.0 Desktop. You can find more detailed information about improving performance in the GNOME 2.0 Desktop for the Solaris Operating Environment System Administration Guide.

- “7.1 Adjust Nautilus Settings” on page 37
- “7.2 Adjust Background Settings” on page 38
- “7.3 Change Window Frame Theme” on page 38
- “7.4 Reduce Applets” on page 38
- “7.5 Transparent Terminals” on page 39
- “7.6 Enable Wireframe Window Moves” on page 39
- “7.7 Install mediaLib Libraries” on page 39
- “7.8 Improving CDE Application Performance” on page 40

7.1 Adjust Nautilus Settings

Tip You can improve the performance of the GNOME Desktop by optimizing the settings of the Nautilus window manager.

Action 1. Open a Nautilus window.
2. Choose Edit -> Preferences.
4. Make sure all options are set to Local File Only or Never.
7.2 Adjust Background Settings

Tip If you run the GNOME Desktop remotely over a slow network, you can adjust the desktop background settings to improve performance.

Action
1. Open the Applications menu.
2. Choose Desktop Preferences -> Background.
3. Click on the No Picture button.
4. Select Solid color in the Background Style drop-down list.

7.3 Change Window Frame Theme

Tip You can change your window frame theme to a more basic selection to improve performance.

Action
1. Open the Applications menu.
2. Choose Desktop Preferences -> Theme.
3. Click the Window Frames tab.
4. Select a basic theme, for example Atlanta.

7.4 Reduce Applets

Tip Reducing the number of applets in your panels can improve performance.

Action Remove applets from your panels that you are not using.
7.5 Transparent Terminals

Tip Using terminals with transparent backgrounds can affect the performance of the GNOME Desktop.

Action If your terminals have transparent backgrounds, then perform the following actions in a terminal:
1. Open the Edit menu.
2. Select Profiles.
3. Open the Effects tab.
4. Select the None (use solid color) option.

7.6 Enable Wireframe Window Moves

Tip You can improve performance by enabling windows to move in wireframe mode.

Action Run the following command:
```
gconftool-2 -s /apps/metacity/sun_extensions/wireframe_move_resize -t bool true
```

7.7 Install mediaLib Libraries

Tip The GNOME 2.0 Desktop includes support for the mediaLib™ libraries. Installing these libraries can noticeably improve the performance of the GNOME Desktop.

Action See the mediaLib website for information on installation of this package: http://www.sun.com/processors/vis/mlib.html
7.8 Improving CDE Application Performance

**Tip**
How do I improve the performance of CDE applications in the GNOME 2.0 Desktop?

**Action**
By default the following CDE programs are turned off when you log in to a GNOME Desktop session:

- **dtdbcache**
  dtdbcache sets up a cache to speed up CDE programs that use actions such as dtfile. If this cache is not set up, CDE applications that use actions run more slowly. To turn this feature back on, you can start this program manually or by launching the program from a startup script. Perform the following actions:
  1. Log in as root, then open the following file:
     /usr/dt/config/Xsession.Sun-gnome-2.0-fcs
  2. Delete the following line: export SDT_NO_DTDBCACHE="1"

- **ttsession**
  ttsession is the Tooltalk daemon. In CDE, this program is always launched when the user first logs in. In the GNOME 2.0 Desktop, this daemon is started automatically by the first program that makes use of Tooltalk. You can restore the CDE behavior by using a startup script. Perform the following actions:
  1. Log in as root, then open the following file:
     /usr/dt/config/Xsession.Sun-gnome-2.0-fcs
  2. Delete the following line: export SDT_NO_TOOLTALK="1"

- **dtappgather**
  dtappgather is a support program for the CDE Application Manager. Normally, you do not need to run this program in a GNOME Desktop session. However, if you want to run this program, then you can start dtappgather manually or by launching the program from a startup script. Perform the following actions:
  1. Log in as root, then open the following file:
     /usr/dt/config/Xsession.Sun-gnome-2.0-fcs
  2. Delete the following line: export SDT_NO_APPGATHER="1"
Accessibility Problems

This section provides information about how to deal with accessibility-related problems in the GNOME 2.0 Desktop.

- “8.1 Keyboard Is Unresponsive” on page 41
- “8.2 Numeric Keypad Is Unresponsive” on page 42
- “8.3 System Beeps Continuously” on page 42
- “8.4 System Beeps Incorrectly for Slow Keys” on page 43
- “8.5 Mouse Keys Functionality” on page 43

8.1 Keyboard Is Unresponsive

Problem The keyboard stops responding when I do the following:
1. Select the Enable Mouse Keys option in AccessX.
2. Select either Enable Bounce Keys or Enable Slow Keys.
3. Use the numeric keypad to move focus to the Testing Area text box.
4. Press 5 on the numeric keypad to click in the Testing Area text box.

The keyboard does not work in any application, such as Terminal, gedit, and so on.
Solution

Perform the following actions:
1. Select the **Enable Mouse Keys** option in AccessX.
2. Use Mouse Keys to enable the Bounce Keys feature.
3. Use the numeric keypad to move focus to the **Testing Area** text box.
4. Press 5 on the numeric keypad to click in the **Testing Area** text box.
5. Press 5 a second time in the **Testing Area** text box.
6. Type as normal using keyboard.

Perform the same sequence of actions for Slow Keys.

---

### 8.2 Numeric Keypad Is Unresponsive

**Problem**
The numeric keypad stops responding when I enable XKB on a Solaris 8 or a Solaris 9 system.

**Solution**
Use the numeric keys in the main part of the keyboard.

---

### 8.3 System Beeps Continuously

**Problem**
This problem is displayed on Sun Ray systems only.
The system beeps continuously when I do the following:

1. Select the **Enable keyboard accessibility** option in the **AccessX** dialog.
2. Select either of the following accessibility options:
   - **Enable Toggle Keys**
   - **Enable Sticky Keys and Beep when modifier is pressed**
3. Press a modifier key or press a toggle key.

**Solution**
To stop the beeps, you must log out and log in again. Then, perform the following actions in the **AccessX** dialog:

1. Deselect the **Enable Toggle Keys** option.
2. Deselect the **Beep when modifier is pressed** option for sticky keys.
8.4 System Beeps Incorrectly for Slow Keys

Problem

The Beep when key is rejected option for Slow Keys is not working correctly when I do the following:

- Select the Enable Slow Keys option in the AccessX dialog.
- Select the Beep when key is rejected option.
- Deselect the Beep when key is accepted option.
- Press-and-hold a key for the time specified in the Only accept keypress after spin box.
- Release the key. The system accepts the keypress but the system beeps when you release the key.

In this situation, the system should not beep when you release the key after a successful keypress.

Solution

Perform the following actions:

1. Deselect the Beep when key is rejected option.
2. Select the Beep when key is accepted option.

8.5 Mouse Keys Functionality

Problem

This problem is displayed on Sun Ray systems only.

When you enable the Mouse Keys feature, the 9 key on the numeric keypad should move the mouse pointer upwards and diagonally to the right. However, the 9 key moves the pointer straight upwards.

Solution

Press the 8 key to move the pointer upwards and press the 6 key to move the pointer to the right.
Localization and Internationalization Problems

This section provides information about how to deal with localization- and internationalization-related problems in the GNOME 2.0 Desktop.

- “9.1 Localized Locales” on page 45
- “9.2 Problems That Affect All Locales” on page 48
- “9.3 Problems That Affect European Locales” on page 50
- “9.4 Problems That Affect Asian Locales” on page 54
- “9.5 Problems That Affect Complex-Text Locales” on page 61

9.1 Localized Locales

Note – Arabic and Hebrew are not fully supported locales.

The GNOME 2.0 Desktop supports the locales listed in the following table.

<table>
<thead>
<tr>
<th>Language</th>
<th>Locale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arabic</td>
<td>ar</td>
</tr>
<tr>
<td></td>
<td>ar_EG.UTF-8</td>
</tr>
<tr>
<td>Brazilian Portuguese</td>
<td>pt_BR.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>pt_BR.UTF-8</td>
</tr>
<tr>
<td>Language</td>
<td>Locale</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Chinese, Simplified</td>
<td>zh</td>
</tr>
<tr>
<td></td>
<td>zh.GBK</td>
</tr>
<tr>
<td></td>
<td>zh.UTF-8</td>
</tr>
<tr>
<td></td>
<td>zh_CN.EUC</td>
</tr>
<tr>
<td></td>
<td>zh_CN.GB18030</td>
</tr>
<tr>
<td></td>
<td>zh_CN.GBK</td>
</tr>
<tr>
<td></td>
<td>zh_CN.UTF-8</td>
</tr>
<tr>
<td>Chinese, Traditional</td>
<td>zh_HK.BIG5HK</td>
</tr>
<tr>
<td></td>
<td>zh_HK.UTF-8</td>
</tr>
<tr>
<td></td>
<td>zh_TW</td>
</tr>
<tr>
<td></td>
<td>zh_TW.BIG5</td>
</tr>
<tr>
<td></td>
<td>zh_TW.EUC</td>
</tr>
<tr>
<td></td>
<td>zh_TW.UTF-8</td>
</tr>
<tr>
<td>English</td>
<td>Posix (C)</td>
</tr>
<tr>
<td></td>
<td>en_AU.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>en_CA.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>en_GB.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>en_GB.ISO8859-15</td>
</tr>
<tr>
<td></td>
<td>en_IE.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>en_IE.ISO8859-15</td>
</tr>
<tr>
<td></td>
<td>en_NZ.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>en_US.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>en_US.ISO8859-15</td>
</tr>
<tr>
<td></td>
<td>en_US.UTF-8</td>
</tr>
<tr>
<td>French</td>
<td>fr_FR.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>fr_FR.ISO8859-15</td>
</tr>
<tr>
<td></td>
<td>fr_FR.UTF-8</td>
</tr>
<tr>
<td>German</td>
<td>de_DE.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>de_DE.ISO8859-15</td>
</tr>
<tr>
<td></td>
<td>de_DE.UTF-8</td>
</tr>
<tr>
<td>Language</td>
<td>Locale</td>
</tr>
<tr>
<td>---------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>Hebrew</td>
<td>he</td>
</tr>
<tr>
<td></td>
<td>he_IL.UTF-8</td>
</tr>
<tr>
<td>Italian</td>
<td>it_IT.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>it_IT.ISO8859-15</td>
</tr>
<tr>
<td></td>
<td>it_IT.UTF-8</td>
</tr>
<tr>
<td>Japanese</td>
<td>ja</td>
</tr>
<tr>
<td></td>
<td>ja_JP.eucJP</td>
</tr>
<tr>
<td></td>
<td>ja_JP.PCK</td>
</tr>
<tr>
<td></td>
<td>ja_JP.UTF-8</td>
</tr>
<tr>
<td>Korean</td>
<td>ko</td>
</tr>
<tr>
<td></td>
<td>ko_KR.EUC</td>
</tr>
<tr>
<td></td>
<td>ko.UTF-8</td>
</tr>
<tr>
<td></td>
<td>ko_KR.UTF-8</td>
</tr>
<tr>
<td>Polish</td>
<td>pl_PL.ISO8859-2</td>
</tr>
<tr>
<td></td>
<td>pl_PL.UTF-8</td>
</tr>
<tr>
<td>Russian</td>
<td>ru_RU.ANSI1251</td>
</tr>
<tr>
<td></td>
<td>ru_RU.ISO8859-5</td>
</tr>
<tr>
<td></td>
<td>ru_RU.KOI8-R</td>
</tr>
<tr>
<td></td>
<td>ru_RU.UTF-8</td>
</tr>
<tr>
<td>Spanish</td>
<td>es_ES.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>es_ES.ISO8859-15</td>
</tr>
<tr>
<td></td>
<td>es_ES.UTF-8</td>
</tr>
<tr>
<td>Swedish</td>
<td>sv_SE.ISO8859-1</td>
</tr>
<tr>
<td></td>
<td>sv_SE.ISO8859-15</td>
</tr>
<tr>
<td></td>
<td>sv_SE.UTF-8</td>
</tr>
</tbody>
</table>
Note – Some locales provide limited support, as follows:

- ar, ar_EG.UTF-8: GNOME Desktop is not localized. Basic internationalization support only, with known problem. See “9.5.1 Incomplete Support for Right-to-Left Languages” on page 61.
- he, he_IL.UTF-8: GNOME Desktop is not localized. Basic internationalization support only, with known problem. See “9.5.1 Incomplete Support for Right-to-Left Languages” on page 61.
- ru_RU.ANSI1251: GNOME session is available, but GNOME Desktop is not supported.

9.2 Problems That Affect All Locales

The following problems affect all locales:

- “9.2.1 Unlocalized Menu Items” on page 48
- “9.2.2 Warning Messages to Console” on page 49
- “9.2.3 Obsolete Topics In Online Help” on page 49
- “9.2.4 Multiple Trash Icons” on page 49
- “9.2.5 Dialogs and Panels Are Not Localized” on page 49
- “9.2.6 Cannot Open a File Created in a Different Locale” on page 50
- “9.2.7 Launching gmines Causes a Segmentation Fault” on page 50

9.2.1 Unlocalized Menu Items

Problem

<table>
<thead>
<tr>
<th>Problem</th>
<th>Affects all locales.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio Control</td>
<td>The following menu items are unlocalized across all locales:</td>
</tr>
<tr>
<td>Media Player</td>
<td>- Audio Control</td>
</tr>
<tr>
<td></td>
<td>- Media Player</td>
</tr>
</tbody>
</table>

Solution

This problem will be fixed in a future release.
9.2.2 Warning Messages to Console

Problem
Bug ID 4818711, affects all locales.
When you launch GNOME applications from a terminal, you might occasionally see warning messages in the terminal window.

Solution
These warnings do not appear if you launch applications from the desktop environment menus. These warnings do not affect the functionality of the application.
This bug will be fixed in a future release of the GNOME Desktop.

9.2.3 Obsolete Topics In Online Help

Problem
Affects all locales.
Obsolete applications such as gweather and Stock Ticker are included in online Help.

Solution
Ignore Help for obsolete applications.

9.2.4 Multiple Trash Icons

Problem
Affects all locales.
When you switch languages using dtlogin, and you log in remotely, multiple Trash icons are shown on the desktop.

Solution
Perform the following steps:
- Open a terminal.
- Change to the .gnome-desktop directory:
  
  
  `cd .gnome-desktop`

- Remove unnecessary Trash files.

9.2.5 Dialogs and Panels Are Not Localized

Problem
Affects all locales.
A number of applications display unlocalized dialogs and panels.
9.2.6 Cannot Open a File Created in a Different Locale

Problem
Bug ID 4824884, affects all locales.
Nautilus may not open a file that was created in a different locale.

Solution
Log in to the locale in which the file was created, then open the file.

9.2.7 Launching gmines Causes a Segmentation Fault

Problem
Affects the gmines game in all locales.
If you install a language package, then gmines causes a segmentation fault the next time you try to launch the game.

Solution
Remove the following file to stop the game from freezing:
/usr/share/locale/[your-locale]/LC_MESSAGES/gnome-games.mo.
This action also removes the localization support for all games.
This problem will be fixed in a future release.

9.3 Problems That Affect European Locales

The following problems affect European locales:
- “9.3.1 OpenWindows Login Option Is Missing” on page 51
- “9.3.2 Start Menu Is Not Localized” on page 51
- “9.3.4 Keyboard Shortcut Does Not Change Input Method Window” on page 52
- “9.3.5 Poor Font Quality in Terminal” on page 52
- “9.3.6 No Support for CP1251 and ANSI1251 Encoding” on page 52
- “9.3.7 Rasterization Problems in Russian Locale” on page 53
9.3.1 OpenWindows Login Option Is Missing

Problem
Affects all European locales in the Solaris 8 operating environment. This is not a problem for the Solaris 9 operating environment.

When you install the GNOME 2.0 Desktop you might notice that OpenWindows is no longer present as a session option in the login screen.

Solution
Perform the following steps to restore the OpenWindows option to the login screen:
1. Log in as root.
2. Run the following command:
   ```
   cp /usr/dt/config/C/Xresources.d/Xresources.ow
   /usr/dt/config/locale/Xresources.d/Xresources.ow
   ```
   Where `locale` corresponds to the locale for which you wish to restore the OpenWindows login option.

9.3.2 Start Menu Is Not Localized

Problem
Affects the pt_BR.ISO8859-1 locale.

The Start menu is not localized.

Solution
This problem will be fixed in a future release.

9.3.3 Characters Are Displayed Incorrectly in the XScreenSaver Properties Dialog

Problem
Affects the pt_BR.ISO8859-1 and pt_BR.UTF-8 locales.

In the XScreenSaver Properties dialog, localization characters are missing. In the pt_BR.UTF-8 locale incorrect characters are displayed, for example Cyrillic characters.

Solution
This problem will be fixed in a future release.
9.3.4 Keyboard Shortcut Does Not Change Input Method Window

Problem: Affects Russian locales.
The keyboard shortcut Ctrl+Spacebar to select and change the input method window does not work on the x86 architecture edition of the Solaris operating environment.

Solution: Use the mouse to select and change the input method window.

9.3.5 Poor Font Quality in Terminal

Problem: Affects Russian locales.
The font quality is low for the Terminal application.

Solution: Perform the following steps:
1. Open a terminal, then choose Edit → Profiles.
2. Click on the Edit icon.
3. In the General tabbed section, deselect the check box Use the same font as other applications.
4. Click on the font selection bar.
5. Choose a suitable font from the Choose a terminal font dialog.

9.3.6 No Support for CP1251 and ANSI1251 Encoding

Problem: Affects Russian locales.
The pango X11 shaper in this release of the GNOME Desktop does not support CP1251 encoding. As a result, CP1251 or ANSI1251 encoded characters are displayed as zero-width or blank characters.
Use the following locales, which are supported by the pango X11 shaper, until CP1251 support is available:
- ru_RU.KOI8-R
- ru_RU.ISO8859-5
- ru_RU.UTF-8

You can use iconv conversion tables to re-encode CP1251 and ANSI1251 files. To encode a CP1251 or ANSI1251 file into a UTF-8 encoded file, in a terminal run the following command:

```
/usr/bin/iconv -f CP1251 -t UTF-8 CP1251 filename > UTF-8 filename. (man iconv)
```

### 9.3.7 Rasterization Problems in Russian Locale

#### Problem
Affects the ru_RU.KOI8-R locale.

In the Solaris 8 operating environment, x86 architecture edition, you might experience rasterization problems regarding the following Russian glyphs:
- 00F1
- 00FF
- 00DC

This problem affects both the Common Desktop Environment (CDE) and the GNOME Desktop.

#### Solution
You need to select specific fonts for use within the GNOME Desktop. Perform the following steps:

- Open a terminal and run the following command:
  ```
  gnome-font-properties
  ```
- Click on the Desktop font button in the Font Preferences dialog.
- In the Pick a Font dialog, specify a font from the following list:
  - application: medium, medium italic, bold, bold italic
  - arial: italic, bold, bold-italic
  - courier: italic, bold italic
  - fixed: medium
  - interface system: medium
  - monospace: normal
  - sans: italic, bold italic
  - times: italic, bold italic

This problem will be fixed in a future release.
9.3.8 Help Appears Only in English

Problem Bug id 4921134, affects the following locales:

- fr_BE.UTF-8
- es_AR.ISO8859-1
- es_BO.ISO8859-1
- es_CL.ISO8859-1
- es_CO.ISO8859-1
- es_CR.ISO8859-1
- es_EC.ISO8859-1
- es_GT.ISO8859-1
- es_MX.ISO8859-1
- es_NI.ISO8859-1
- es_PA.ISO8859-1
- es_PE.ISO8859-1
- es_PY.ISO8859-1
- es_SV.ISO8859-1
- es_UY.ISO8859-1
- es_VE.ISO8859-1

Solution Perform the following actions to resolve this issue:

- su password
- cd /usr/share/locale
- ln -s parent locale target locale
- Log out of your session.
- Log in again.

Applications should now appear in the target locale.

9.4 Problems That Affect Asian Locales

The following problems affect Asian locales:

- “9.4.1 Default Desktop Font Is Too Small Or Blank” on page 55
- “9.4.2 Special Fonts Are Missing in Chinese Locales” on page 55
- “9.4.3 GNOME Ghostscript Display” on page 56
- “9.4.4 Font Quality Is Poor” on page 57
- “9.4.5 Different Date Format in the Solaris Operating Environment” on page 57
- “9.4.6 Character Display Problem in GTK2+ Applications” on page 57
- “9.4.7 Printing Out From gedit in the Solaris 8 Operating Environment” on page 58
- “9.4.8 Cannot Print Japanese Characters With Default Font in gedit” on page 58
- “9.4.9 Cannot Open ISO–2022–JP Encoded File” on page 58
- “9.4.10 Localized Characters Do Not Display in gedit” on page 59
9.4.1 Default Desktop Font Is Too Small Or Blank

Problem
For example: bug ID 4805328, affects some locales, including Chinese locales.
Currently, you cannot set the default font for the GNOME Desktop for each locale. As a result, particularly if you are switching between locales, you might find that the default desktop font is either too small or is rendered blank.

Solution
To change the default desktop font, perform the following steps:
- Open a terminal and run the following command:
  `gnome-font-properties`
- Use the Font Preferences dialog to change font size to appropriate values. For example, in Chinese locales, you can set both Application font and Desktop font to Sans 13.

9.4.2 Special Fonts Are Missing in Chinese Locales

Problem
Bug ID 4821955, affects Traditional Chinese locales.
You cannot see the characters displayed with some special fonts such as bold fonts. As a result, some characters in the Yelp window appear to be missing.
You must change the pangox.alias file in
/etc/[zh_TW.EUC,zh_TW.BIG5,zh_TW.UTF-8,zh_HK.BIG5HK,zh_HK.UTF-8]. Perform the following steps:

1. Log in as root.
2. Change to the directory where the pangox.alias file is located for your locale. For example, for the zh_TW.BIG5 locale, run the following command:
   
   `cd /etc/pango/zh_TW.BIG5`

3. Run the following command:
   `cat pangox.alias | tr [A-Za-z] [a-z] > /tmp/pango`

4. Run the following command:
   `mv /tmp/pango pangox.alias`

5. If the directory /etc/pango/sparcv9/pango is on your system, change the pangox.alias files in the locale subdirectories in that directory, in the same way as for /etc/pango.

### 9.4.3 GNOME Ghostscript Display

**Problem**

Affects Asian and Japanese locales.

Characters with the Japanese Postscript font name are garbled when displayed in GNOME Ghostscript.

**Solution**

Perform the following steps:

1. Log in as root.
2. Run the following command: `cd /`
3. Run the following command: `mkdir /Resource`
4. Depending on the locale, run one of the following commands:
   - Simplified Chinese
   - Traditional Chinese
     `ln -s /usr/openwin/lib/locale/zh_TW/X11/Resource/CMap /Resource/CMap`
   - Japanese
     `ln -s /usr/openwin/lib/locale/ja/X11/Resource/CMap /Resource/CMap`
   - Korean
9.4.4 Font Quality Is Poor

Problem
Bug ID 4423759, affects Japanese locales in the Solaris 9 operating environment.

Solution
Perform the following steps:
- Open the Applications menu.
- Choose Desktop Preferences → Font.
- In the Font Preferences dialog, specify **hg gothic b** for both the application font and the desktop font.
- Select the appropriate font size, either 12 or 14, depending on your desktop resolution.

9.4.5 Different Date Format in the Solaris Operating Environment

Problem
Affects Japanese locales.
The date format is different in the Solaris operating environment.
There is no ‘(‘ and ‘)’ on the weekday format in the following locales:
- Solaris 8 operating environment: ja_JP.UTF-8
- Solaris 9 operating environment: ja_JP.eucJP, ja_JP.UTF-8

Solution
Not applicable.

9.4.6 Character Display Problem in GTK2+ Applications

Problem
Bug ID 4785550, affects the gedit application and other GTK2+ applications in Japanese locales.
Part of the IBM/NEC extended character and special characters are not displayed.

Solution
Known limitation.
9.4.7 Printing Out From gedit in the Solaris 8 Operating Environment

Problem
Affects Japanese locales.
You can preview JISX0212 in the gedit application, but you cannot print out JISX0212.

Solution
Solaris 8 operating environment: Known limitation.
Solaris 9 operating environment: Perform the following steps:
- Open the gedit application.
- Choose Edit → Preferences.
- Select Fonts from the Print category, in the Categories panel.
- For each print item, specify either of the following fonts:
  - HG-GothicB-Sun
  - HG-MinchoL-Sun

9.4.8 Cannot Print Japanese Characters With Default Font in gedit

Problem
Bug 4861491, affects Japanese locales.
When you use the default printer font in the gedit application, Japanese characters are not displayed in Print Preview and are not printed by printers.

Solution
Perform the following steps:
- Open the gedit application.
- Choose Edit → Preferences.
- Select Fonts from the Print category, in the Categories panel.
- For each print item, specify the HG-GothicB-Sun font.

9.4.9 Cannot Open ISO–2022–JP Encoded File

Problem
Bug ID 4826184, affects Japanese locales.

Solution
This problem will be fixed in a future release.
9.4.10 Localized Characters Do Not Display in gedit

Problem
For example: bug ID 4785550, affects Japanese locales.
Japanese characters do not display in the gedit application, when you select Courier as the default font.

Solution
Perform the following steps:
- Open the gedit application.
- Choose Edit → Preferences.
- Select Font & Colors in the Categories panel.
- Select the option Use default theme font.
This solution does not fix the problem that IBC/NEC extended character and special characters are not displayed in the Solaris 8 operating environment.

9.4.11 Poor Japanese Font Quality with Default Font in gedit

Problem
Bug ID 4869534, affects Japanese locales.
The Japanese font quality is poor in the gedit application, when you use the default font.

Solution
Perform the following steps:
- Open the gedit application.
- Choose Edit → Preferences.
- Select Font & Colors from the Editor category, in the Categories panel.
- Specify the hg gothic b font for the editor font.

9.4.12 Character Display Problem in Terminal

Problem
Affects Japanese locales.
In the Terminal application Preferences dialog, IBM/NEC extended character and special characters are not displayed when you select the option Use the same font as other applications.
Solution Perform the following steps:

- Open a terminal.
- Choose Edit → Current Profiles.
- In the Editing Profiles dialog, deselect the option Use the same font as other applications.
- Specify the font to be interface user.

9.4.13 Core Dump When Copy or Link to File

Problem Bug ID 4824884, affects Japanese locales.

A core dump sometimes occurs when you use Nautilus to copy or link to a file that was created in a different locale.

Solution Log in to the locale in which the file was created, then copy the file or create a link to the file.

9.4.14 Input Method Window Repeatedly Flushed

Problem Bug ID 4781611, affects the ja_JP.UTF-8 locale.

When there are multiple input contexts on the same top-level application window, the input method window is repeatedly flushed.

Solution This problem will be fixed in a future release.

9.4.15 Japanese Locale Core Dump

Problem Bug ID 4808468, affects the ja_JP.UTF-8 locale.

An application core dump occurs when you do the following:
1. Choose Unicode List → HIRAGANA from the IM status.
2. Close the application window.

Solution This problem will be fixed in a future release.
9.4.16 GTK2+ Applications Freeze

Problem
Bug ID 4820426, affects the ja_JP.UTF-8 locale.
GTK2+ applications freeze when you do the following:
1. Open a Lookup Choice window.
2. Press and hold the space key.

Solution
This problem will be fixed in a future release.

---

9.5 Problems That Affect Complex-Text Locales

The following problems affect complex—text locales:
- “9.5.1 Incomplete Support for Right-to-Left Languages” on page 61

9.5.1 Incomplete Support for Right-to-Left Languages

Problem
Affects Arabic and Hebrew.
Only partial support is available in the GNOME Desktop for right-to-left languages. Full support for right-to-left language printing and GUI widget mirroring is currently under development in the GNOME Desktop.

Solution
Arabic and Hebrew text input is supported in the GNOME 2.0 globalization release, with the exception of the Terminal application. If you have not installed any other language pack, and you want text input support, then install the following patches:

<table>
<thead>
<tr>
<th>SPARC Architecture Edition</th>
<th>x86 Architecture Edition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solaris 8 Operating Environment:</td>
<td>114485-01</td>
</tr>
<tr>
<td>Solaris 9 Operating Environment:</td>
<td>114274-02</td>
</tr>
</tbody>
</table>
Index

A
ANSI1251 encoding, no support for, 52
applets, reduce for performance, 38
application freeze, Japanese locales, 61
applications
  obsolete, 49
  restoring incorrectly, 20
Arabic, partial support for, 61
audio CDs, no sound from, 36

B
background, adjusting for performance, 38

c
C
CDE applications, improving performance of, 40
character display
  GTK2+ applications, 57
  in terminal, 59
Chinese
  small fonts, 55
  special fonts missing, 55
core dump
  Japanese locale, 60
CP1251 encoding, no support for, 52

d
D
date format, 57
defunct applications, in Help, 49
desktop background, no image, 16
dialogs, unlocalized, 49
display, multihead, 33
dynamically-set title, Terminal, 29

e
E
error message
  failed installation, 12
  startup, 16
error messages, general, 25
error messages, missing files, 16

f
F
file, cannot open, 50
font quality, poor, 57
fonts too small, various locales, 55
further information, 23

G
G
gconf, information about, 27
gedit
  localized characters do not display, 59
  printing problem in Solaris 8 OE, 58
  Gedit, restore problem with, 20, 38
general startup problems, 16
gnines, freeze, 50
GNOME 1.4 Desktop, uninstalling, 12
GNOME 2.0 Desktop, uninstalling, 12
GNOME Desktop menu item, missing from login screen, 15
GNOME Ghostscript, displaying Japanese files, 56
GTK2+ application freeze, 61
character display, 57

H
Hebrew, partial support for, 61

I
icons, not displaying, 16
input method window
flushing repeatedly, 60
unable to change with keyboard shortcut, 52
installation log, location, 11
installing, without the Installer, 13
ISO-2022–JP encoded files, do not open in gedit, 58

J
Japanese
application freeze, 61
character display in terminal, 59
characters do not display in gedit, 59
core dump, 60
date format, 57
displaying files in GNOME Ghostscript, 56
opening ISO-2022–JP files in gedit, 58
poor font quality, 57
window flushing, 60

K
keyboard, no response, 41

L
locales, localized, 45
localization
all locales, 48
Asian locales, 54
complex—text locales, 61
European locales, 50
log in, applications with restore problems, 20
logging out, sans panel, 19
login process, hanging, 16
login screen, GNOME Desktop menu item missing, 15

M
Main Menu, icon incorrect, 16
MainSoft, setting MWWM for, 20
mediaLib libraries, installing for performance, 39
menu items, unlocalized, 48
Metacity, crashes, 19
mouse, three-button configuration, 34
mouse keys, numeric key 9, 43
multihead display, 33
MWWM environment variable, setting for MainSoft, 20

N
Nautilus
adjusting for performance, 37
crashes or freezes, 26
nautilus, no viewer, 25
Nautilus slows the system, 26
Netscape 4.x, display problems, 24
numeric keypad, no response, 42

O
OpenWindows, login option missing, 51
panels, unlocalized, 49
panels, not appearing, 16
panels, not responding, 16

rasterization, Russian glyphs, 53
removable media manager, 28
Russian
  cannot change input method window, 52
  no support for CP1251/ANSI1251 encoding, 52
  poor font quality in terminal, 52
  rasterization of glyphs, 53

screensaver, does not display, 28
screensavers, conflicts with, 27
ScrollKeeper, fails after installation, 13
slow keys, beep when rejected option, 43
sound events, not working, 34
special fonts missing, Chinese locales, 55
Start menu, unlocalized, 51
startup problems, general, 16
Sun Ray server, running GNOME Desktop on, 36
swing, problems with, 21
system, continuous beeps, 42

Terminal, dynamically-set title options do not work, 29
terminal, poor font quality, 52
Terminal, restore problem with, 20, 38
terminals, adjusting for performance, 39
tif files, crash panels, 26
trash icons, multiple, 49

uninstalling
  GNOME 1.4 Desktop, 12
  GNOME 2.0 Desktop, 12
unlocalized menu items, 48

version, of GNOME Desktop, 24

warning messages, console, 49
window border theme, adjusting for performance, 38
window manager, crashes, 19
windows, unexpected behavior, 20
wireframe move mode, enabling for performance, 39