<table>
<thead>
<tr>
<th>Contents</th>
<th>page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>xxix</td>
</tr>
<tr>
<td><strong>1. Introduction to the Solaris User Environment</strong></td>
<td>1</td>
</tr>
<tr>
<td>Logging In and Logging Out</td>
<td>2</td>
</tr>
<tr>
<td>Logging In</td>
<td>2</td>
</tr>
<tr>
<td>Logging Out</td>
<td>4</td>
</tr>
<tr>
<td>Overview of the OpenWindows Environment</td>
<td>5</td>
</tr>
<tr>
<td>Windows and Icons</td>
<td>6</td>
</tr>
<tr>
<td>Closing a Window to an Icon</td>
<td>6</td>
</tr>
<tr>
<td>Opening an Icon to a Window</td>
<td>7</td>
</tr>
<tr>
<td>Mouse and Pointer</td>
<td>7</td>
</tr>
<tr>
<td>Versions of the Pointer</td>
<td>7</td>
</tr>
<tr>
<td>Using the Mouse Buttons</td>
<td>8</td>
</tr>
<tr>
<td>Pointer and Input Area</td>
<td>9</td>
</tr>
<tr>
<td>Pointer Jumping</td>
<td>10</td>
</tr>
<tr>
<td>Keyboard Equivalents</td>
<td>10</td>
</tr>
</tbody>
</table>
Menus and Pushpins ........................................ 12
Using the Workspace Menu .............................. 12
Using Submenus .......................................... 13
Pinning a Menu ............................................ 13
Using Window Menus .................................... 14
Using Window Menus .................................... 15
Choosing Menu Defaults ................................ 16
Changing the Menu Default ............................. 16
Window Controls .......................................... 17
Drag and Drop ............................................. 20
Positioning Windows and Pinned Menus ............ 25
Moving Multiple Windows .............................. 26
Moving a Window Front or Back ....................... 26
Moving Icons .............................................. 28
Resizing Windows ........................................ 28
Closing and Quitting Windows ......................... 29
Starting an Application .................................. 30
Elements of an Application’s Base Window ........ 31
Opening, Saving, Including and Attaching Files .... 31
Opening a Document .................................... 33
Saving a Document ...................................... 33
Introduction to the DeskSet Applications .......... 36
Starting DeskSet Applications ........................ 37
Working with Text ....................................... 39
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managing Your Files</td>
<td>40</td>
</tr>
<tr>
<td>Managing Your Time</td>
<td>42</td>
</tr>
<tr>
<td>Printing Your Documents</td>
<td>43</td>
</tr>
<tr>
<td>Communicating on the Network</td>
<td>44</td>
</tr>
<tr>
<td>Customizing the OpenWindows Environment</td>
<td>44</td>
</tr>
<tr>
<td>Hidden Files</td>
<td>44</td>
</tr>
<tr>
<td>Getting Help</td>
<td>45</td>
</tr>
<tr>
<td>Magnify Help</td>
<td>45</td>
</tr>
<tr>
<td>More Help</td>
<td>46</td>
</tr>
<tr>
<td>Dismissing a Help Window</td>
<td>46</td>
</tr>
<tr>
<td>No Help</td>
<td>47</td>
</tr>
<tr>
<td>Help Viewer</td>
<td>47</td>
</tr>
<tr>
<td>Desktop Introduction</td>
<td>47</td>
</tr>
<tr>
<td>Help on Help</td>
<td>49</td>
</tr>
<tr>
<td>Other Handbooks</td>
<td>50</td>
</tr>
<tr>
<td>Quick Access to Help Handbooks</td>
<td>51</td>
</tr>
<tr>
<td>Navigating through Handbooks</td>
<td>51</td>
</tr>
<tr>
<td>Closing the Help Viewer</td>
<td>55</td>
</tr>
<tr>
<td>Exiting the Help Viewer</td>
<td>56</td>
</tr>
<tr>
<td>On-line Documentation: AnswerBooks</td>
<td>56</td>
</tr>
<tr>
<td>2. File Manager</td>
<td>57</td>
</tr>
<tr>
<td>File Manager Icon</td>
<td>58</td>
</tr>
<tr>
<td>File Manager Base Windows</td>
<td>58</td>
</tr>
<tr>
<td>File Manager File Icons</td>
<td>59</td>
</tr>
</tbody>
</table>
Selecting File Manager Icons ....................... 61
Control Area Menus ................................ 62
File Menu ........................................... 62
View Menu ......................................... 63
Edit Menu .......................................... 64
Go To Menu and Text Field ....................... 64
Folder View ....................................... 65
Folder View Options ............................... 66
Path Pane ......................................... 70
Parts of the Path and Folder View ............... 70
Path that is Displayed ............................. 71
File Pane ......................................... 73
File Pane Pop-up Menu ............................ 73
Alternative Display Options ....................... 74
Large Icon View ................................. 74
Small Icon View .................................. 74
Icon By Name ...................................... 75
Icon By Type ....................................... 75
List By Name ...................................... 75
List By Size ........................................ 76
List By Date ....................................... 76
Opening Files ..................................... 76
Creating New Files and Folders ................ 77
Naming a Document or Folder .................... 78
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Moving and Copying Files</td>
<td>78</td>
</tr>
<tr>
<td>Using Cut, Copy, Paste</td>
<td>78</td>
</tr>
<tr>
<td>Using Drag and Drop in File Manager</td>
<td>79</td>
</tr>
<tr>
<td>Dragging and Dropping Between Tools</td>
<td>81</td>
</tr>
<tr>
<td>Transferring Files From Your System to Another</td>
<td>85</td>
</tr>
<tr>
<td>Printing Files</td>
<td>86</td>
</tr>
<tr>
<td>Finding Files and Folders</td>
<td>87</td>
</tr>
<tr>
<td>Using the Go To Text Field and Menu</td>
<td>87</td>
</tr>
<tr>
<td>Using Pattern Matching to Find Files</td>
<td>88</td>
</tr>
<tr>
<td>Pattern Matching in the Go To Text Field</td>
<td>88</td>
</tr>
<tr>
<td>Pattern Matching in the File Pane</td>
<td>89</td>
</tr>
<tr>
<td>Using the Find Pop-up Window</td>
<td>89</td>
</tr>
<tr>
<td>Finding Files With the Find Window</td>
<td>90</td>
</tr>
<tr>
<td>Using the Wastebasket</td>
<td>91</td>
</tr>
<tr>
<td>Creating a New Wastebasket</td>
<td>93</td>
</tr>
<tr>
<td>Linking Files</td>
<td>94</td>
</tr>
<tr>
<td>Creating a Link</td>
<td>94</td>
</tr>
<tr>
<td>Removing a Link</td>
<td>95</td>
</tr>
<tr>
<td>File and Folder Information</td>
<td>96</td>
</tr>
<tr>
<td>Changing Properties and Permissions</td>
<td>98</td>
</tr>
<tr>
<td>Customizing Your File Manager</td>
<td>98</td>
</tr>
<tr>
<td>General Defaults</td>
<td>100</td>
</tr>
<tr>
<td>New Folder Defaults</td>
<td>101</td>
</tr>
<tr>
<td>Current Folder Settings</td>
<td>108</td>
</tr>
</tbody>
</table>
Go To Menu Defaults. ........................................ 109
Custom Commands ........................................... 110
Advanced Settings .......................................... 112
Customizing Your File Manager Colors .................. 115
Using Floppy and CD Media ............................... 116
  Using a Floppy Disk with File Manager .................. 116
  Checking for a Floppy Disk .............................. 117
  Viewing a File from the Contents of a Floppy Disk or CD . 117
  Removing a Floppy Disk or CD from the Disk Drive .... 119
  Reformatting a Floppy Disk ............................. 119
  Unformatted Floppy ...................................... 121
  Unlabeled Floppy ........................................ 122
  Renaming a Floppy Disk ................................ 123
  Dragging and Dropping Files from Floppy Disk or CD to File Manager ........................................ 123
  Copying Files from Floppy Disk or CD to Floppy Disk ... 124

3. Text Editor .................................................. 125
  Text Editor Icon .......................................... 125
  Text Editor Base Window ................................ 126
  Text Editor Menus ........................................ 127
    Text Pane Pop-Up Menu ................................. 127
    File Menu ................................................ 127
    View Menu .............................................. 128
    Edit Menu ............................................. 130
Find Menu ........................................ 130
Extras Menu .................................... 133
Creating a New File ......................... 135
Working with an Existing File ............ 135
Saving the Existing File ..................... 135
Saving the Modified File as a New File . 136
Editing Files .................................... 136
Adding and Deleting Text .................. 137
Copying and Moving Text .................. 137
Tips on Cutting and Pasting ............... 138
Printing Text Editor Files .................. 139
Splitting Panes ............................... 139
Drag and Drop Feature ...................... 140
Dragging Selected Text from the Text Editor . 141
Dragging Complete Text Editor Files .... 142
Customizing Your Text Editor ............. 143
The .text_extras_menu File ................. 143
The .textswrc File ............................ 145
Format of the .textswrc File .............. 145
4. Multimedia Mail Tool ...................... 147
How Mail Tool Is Organized ............... 148
Header Window Icons ....................... 148
Mail Tool Header Window .................. 148
Mail Message Headers ...................... 149
Message Header Status Messages .......................... 150
Selecting Message Headers ................................. 150
Mail Tool Controls and Menus .............................. 150
File Menu ..................................................... 151
View Menu .................................................... 151
Edit Menu ..................................................... 152
Compose Menu ............................................... 152
Custom Mail Tool Buttons ................................. 153
Mail File Text Field and Menus ......................... 153
Pop-up Menus ............................................... 154
Mail Tool View Message Window ....................... 154
Using the Pushpin in the View Message Window ...... 155
Viewing the Next or Previous Message ................. 155
Viewing Messages With a Full Header .................. 156
Viewing Multiple Mail Messages ....................... 157
Mail Tool Compose Window ............................... 157
Reading Messages ........................................... 160
Printing Messages ........................................... 162
Printing Mail Messages Using Mail Tool ............... 162
Printing Mail Messages Using Print Tool ............... 163
Composing Messages ....................................... 164
Composing a New Message ............................... 164
Replying to a Message .................................... 166
Forwarding Messages to Third-Parties ................. 166
Using Templates ..................................................... 167
Using the Vacation Notifier ................................. 168
Deleting Messages ............................................. 170
Undeleting Messages ....................................... 170
Finding Messages .............................................. 171
Mail Tool Attachments ....................................... 173
Opening Mail Attachments ............................... 174
Opening Ordinary Attachments ..................... 174
Viewing Special Attachments ......................... 175
Sending Mail Attachments .............................. 176
Adding Mail Attachments ............................... 178
Renaming Mail Attachments .......................... 179
Moving Mail Attachments .............................. 180
Deleting Mail Attachments ............................ 182
Saving Changes for Mail Tool ......................... 182
Organizing Your Mail Messages ..................... 183
Mail File Menus ................................................. 185
Creating a New Mail File ............................... 186
Adding Messages to an Existing Mail File .......... 188
Viewing a Mail File ............................................ 189
Viewing a Mail File Using the Header Window Controls ... 189
Viewing a Mail File Using the Mail Files Window ... 189
Editing a Mail File (Emptying, Renaming, Deleting) .. 190
Sorting the Contents of a Mail File .................... 190
Loading Saved Messages Back into Mail Tool ........................................ 191
Loading a Message from the Mail Files Directory ................................ 191
Loading a Message from Another Directory ...................................... 191
Loading the In-Box ................................................................. 192
Using Drag and Drop with Mail Tool ................................................. 192
Dragging Mail to Other Applications ............................................... 192
Dropping Files onto the Mail Tool ....................................................... 194
Customizing Mail Tool .................................................................... 194
Header Window Properties ............................................................... 195
Message Window Properties ............................................................ 199
Compose Window Properties ............................................................. 200
Automatically Storing Copies of Messages You Send ......................... 205
Mail Filing Properties ..................................................................... 206
Saving Mail to Another Location ....................................................... 207
Template Properties ....................................................................... 210
Alias Properties .............................................................................. 212
Expert Properties ........................................................................... 214
5. Calendar Manager ........................................................................ 219
Calendar Manager Icons ................................................................. 220
Icons ............................................................................................. 220
Calendar Manager Base Window ....................................................... 220
Views by Day, Week, Month, and Year ............................................... 220
Calendar Manager Controls and Menus ............................................. 221
View Menu ..................................................................................... 222
Edit Menu .............................................................. 222
Browse Menu ......................................................... 223
Print Menu ............................................................ 223
Navigation Controls ................................................ 223
Resizing Your Calendar ............................................ 223
Calendar Views ....................................................... 224
Day View ............................................................... 224
Week View ............................................................ 225
Month View ........................................................... 226
Year View ............................................................. 227
Appointment List and To Do List Views ..................... 228
Displaying an Appointment or To Do List ................. 229
Edit Menu ............................................................. 229
Appointment Editor Options ..................................... 230
Scheduling Appointments and To Do Items ............... 233
Deleting an Appointment .......................................... 236
Editing an Appointment ........................................... 237
Appointment Reminders .......................................... 238
Finding a Calendar Appointment ............................... 239
Finding a Specific Calendar Date ............................... 240
Dragging an Appointment Message from Mail Tool .... 240
Multiple Calendars Base Window ............................. 242
Using Multiple Calendars ........................................ 242
Browsing a Single Remote Calendar ......................... 254
Browsing a Single Remote Calendar One-Time Only ........... 255
Setting the Calendar Manager Time Zone .................... 256
Customizing Your Calendar Manager ......................... 257
  Editor Defaults Properties ............................ 258
  Display Settings Properties ............................. 259
  Access List and Permissions Properties .................. 261
  Adding Users to the Access List ........................ 263
  Deleting Users from the Access List ....................... 264
  Changing the Access List ............................... 264
  Printer Settings Properties ............................. 264
  Date Format Properties ................................. 266
Printing Calendar Views .................................... 267
  Current View ........................................ 267
  Day View ........................................... 267
  Week View .......................................... 269
  Month View ......................................... 270
  Year View .......................................... 270
Printing Appointment and To Do Lists ......................... 272
Using Calendar Manager with Mail Tool ...................... 272
  Sending Appointment Mail from Calendar Manager ....... 272
  Creating an Appointment Message from Mail Tool ....... 272
Displaying the Calendar Manager Monthly Icon ............... 273
Accessing Your Calendar from a Shell Tool or Command Tool 274
6. Command Tool, Shell Tool, and Console Window ........... 275
Command Tool .................................................. 276
Command Tool Term Pane Menu .................... 277
Shell Tool ...................................................... 280
Shell Tool Term Pane Menu ............................. 282
Console .......................................................... 283
7. Clock ......................................................... 285
Clock Icon and Window ................................. 285
Customizing the Clock .................................... 286
Changing to a Digital-Style Clock Face ............. 288
Changing to a Roman-Style Clock Icon ............. 288
12-Hour or 24-Hour Clock ............................... 289
Displaying a Second Hand and the Date .......... 289
Changing the Time Zone .................................. 290
Using the Stopwatch ...................................... 292
Alarm Settings ............................................... 293
Clock Keyboard Accelerators ......................... 293
8. Calculator .................................................. 295
Calculator Icon and Base Window ................. 296
Modes of Operation ....................................... 296
Numeric Bases ............................................... 296
Display Notation .......................................... 298
Major Calculator Modes ................................. 299
Number Manipulation Functions ..................... 300
Miscellaneous Functions ............................... 302
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory Registers</td>
<td>303</td>
</tr>
<tr>
<td>User-Defined Functions</td>
<td>304</td>
</tr>
<tr>
<td>Performing Simple Calculations</td>
<td>304</td>
</tr>
<tr>
<td>Creating and Saving a Function</td>
<td>305</td>
</tr>
<tr>
<td>Financial Functions</td>
<td>306</td>
</tr>
<tr>
<td>Ctrm: Compounding Term</td>
<td>307</td>
</tr>
<tr>
<td>Ddb: Double-Declining Depreciation</td>
<td>308</td>
</tr>
<tr>
<td>Fv: Future Value</td>
<td>308</td>
</tr>
<tr>
<td>Pmt: Periodic Payment</td>
<td>309</td>
</tr>
<tr>
<td>Pv: Present Value</td>
<td>310</td>
</tr>
<tr>
<td>Rate: Periodic Interest Rate</td>
<td>310</td>
</tr>
<tr>
<td>Sln: Straight-line Depreciation</td>
<td>311</td>
</tr>
<tr>
<td>Syd: Sum-of-the-years’-digits Depreciation</td>
<td>312</td>
</tr>
<tr>
<td>Term: Payment Period</td>
<td>313</td>
</tr>
<tr>
<td>Logical Functions</td>
<td>313</td>
</tr>
<tr>
<td>Scientific Functions</td>
<td>314</td>
</tr>
<tr>
<td>Calculator Function Keys</td>
<td>316</td>
</tr>
<tr>
<td>Customizing Your Calculator</td>
<td>320</td>
</tr>
<tr>
<td>**9. **Performance Meter</td>
<td>323</td>
</tr>
<tr>
<td>Performance Meter Displays</td>
<td>323</td>
</tr>
<tr>
<td>Performance Meter Menu</td>
<td>325</td>
</tr>
<tr>
<td>Customizing Performance Meters</td>
<td>326</td>
</tr>
<tr>
<td>Performance Meter Monitors</td>
<td>327</td>
</tr>
<tr>
<td>Performance Meter Display Options</td>
<td>328</td>
</tr>
</tbody>
</table>
Performance Meter Machine ........................................ 329
Performance Meter Display and Sample Intervals .............. 329
Shortcuts .............................................................. 330

10. **Print Tool** ......................................................... 331
    Print Tool Icons....................................................... 331
    Print Tool Window.................................................... 332
    Printing Files .......................................................... 333
    Typing the Filename in the Print Window ......................... 334
    Dragging and Dropping the File .................................. 334
    Choosing Another Printer ......................................... 335
    Checking the Print Queue Status ................................ 336
    Stopping a Print Job ................................................. 337
    Changing Print Tool Properties ................................. 338
    Changing the Print Method in the Print Tool ................. 339
    Changing the Print Method with the Binder ................... 340
    Starting Print Tool from the Command Line ................. 340

11. **Audio Tool** ...................................................... 341
    About This Chapter ................................................ 341
    Audio Tool Capabilities ........................................... 341
    Required Accessories .............................................. 342
    Invoking Audio Tool ............................................... 342
    About Audio Tool’s Base Window ............................... 343
    Loading and Playing an Audio File ............................ 344
    Recording Sound .................................................. 345
Saving an Audio File .................................................. 347
Editing an Audio File ............................................. 348
Undoing an Edit .................................................... 349
Tips for Editing Audio Files .................................. 350
Sending a Voice Mail Message .............................. 350
Listening to a Voice Mail Message ......................... 352
Audio Tool Reference .......................................... 353
Base Window ......................................................... 353
Audio Tool Icon .................................................... 354
Display Canvas ....................................................... 354
Cursor and Pointer Location ............................... 354
Drag and Drop Target ......................................... 355
Level Meter .......................................................... 355
Status Information .............................................. 355
Rev (Reverse) Button ........................................... 356
Play Button .......................................................... 356
Fwd (Fast Forward) Button ............................... 357
Rec (Record)/Stop Button .................................. 357
File Menu ............................................................. 358
New ................................................................. 358
Open ................................................................. 361
Save ................................................................. 363
Save As............................................................... 364
Include.............................................................. 366
Edit Menu .................................................. 367
  Clear .................................................. 367
  Undo .................................................. 367
  Redo.................................................. 368
  Cut .................................................. 368
  Copy .................................................. 368
  Paste .................................................. 368
  Delete .............................................. 368
  Properties ....................................... 369
Edit Pop-Up Menu ..................................... 371
  Reset Pointer ..................................... 371
  Clear .................................................. 371
  Delete Unselected ................................. 371
  Delete All Silence ................................. 372
  Delete Silent Ends ............................... 372
  Select All ....................................... 372
Volume Menu ........................................... 372
  Play.................................................. 372
  Record.............................................. 373
Using the Audio Control Status Panel ................. 376
12. Tape Tool ............................................ 377
  Tape Tool Icon..................................... 377
  Tape Tool Window .................................. 378
Editing the List of Files in the Tape Contents Window .. 379
Reading Files from a Tape ........................................ 381
   Read Selected ................................................. 381
   Read Entire List .............................................. 381
   Read Entire Tape ............................................. 382
Copying (Writing) Files onto Tape .......................... 382
Checking the Tape Contents ................................ 383
Retrieving (Reading) Files from a Tape .................. 384
Customizing the Tape Tool ................................. 386

13. **Image Tool ........................................ 389**
   Image Tool Icon and Window ........................ 390
Opening Image Files and Documents .................. 391
   Viewing Single Page Images and Multiple Page Documents 391
   Formats that Image Tool Can Open .................. 391
   Opening Your File in a Specific Format .......... 393
Getting Information About Your Image ............... 395
Saving Image Files and Documents ................... 395
   Saving an Image ............................................ 395
   Save As ...................................................... 397
   Save Selection As ...................................... 398
   Save Page As Image ..................................... 399
Printing Images .............................................. 399
Using the Image Tool Palette ......................... 401
   Panning an Image .......................................... 402
   Selecting An Area to Be Saved ........................ 402
Contents

Flipping an Image ........................................... 403
Rotating an Image ........................................... 404
Zooming an Image ........................................... 405
Viewing Multiple Page Documents ....................... 406
Page Overview ............................................. 406
Page Viewing Controls ..................................... 407
Setting Image Tool Properties ............................ 408
Status Messages, Error Messages and Help ............. 409
Dragging and Dropping .................................... 409
Image Tool Controls and Menus ......................... 410
File Menu ................................................... 410
View Menu ................................................... 411
Edit Menu ................................................... 412
Some Standard Operations ............................... 412

14. Snapshot ................................................ 413
Snapshot Icon and Base Window ........................ 414
Snapshot Controls .......................................... 414
Snap Types ................................................... 414
Snap Delay .................................................... 415
Hiding the Snapshot Window During Capture ........... 415
Creating a Snapshot ........................................ 415
Snapping a Window ........................................ 415
Snapping a Region ......................................... 416
Snapping the Screen ....................................... 417
Viewing a Snapshot ................................................. 418
Loading a Snapshot .............................................. 418
Saving a Snapshot ............................................... 419
Printing a Snapshot ............................................ 419
15. Icon Editor ......................................................... 421
   Icon Editor Icon and Base Window ..................... 421
   Icon Editor Drawing Controls ......................... 422
   Adding Text to the Canvas ............................... 424
   Editing Images .................................................. 427
Filing Options ....................................................... 432
   Loading and Saving a File ................................. 432
   Saving a New Icon ........................................... 432
   Saving a Modified Icon .................................... 433
   Clearing the Canvas ......................................... 433
   Printing an Icon .............................................. 433
View Menu ......................................................... 434
   Grid Display .................................................... 435
Edit Menu .......................................................... 436
   Undo and Redo .................................................. 436
   Clear ............................................................ 436
   Cut, Copy, and Paste ....................................... 436
   Invert ......................................................... 437
Properties Menu .................................................. 437
   Icon Format .................................................... 437
Icon Size .......................................................... 438
Icon Editor Color Chooser Palette ..................... 439

16. **Binder** ...................................................... 441
   Binder Icon and Window .............................. 442
   Binder Control Area .................................. 442
   Binder Databases ..................................... 443
   Updating and Viewing Private Binder Entries .... 443
   Updating and Viewing System and Network Binder Entries 444
   Binder Properties ..................................... 446
   Icon Properties ........................................ 447
   File Type Properties ................................ 451
   Creating a New Binding ............................... 458
   Deleting a Binder Entry ............................. 462
   Changing a Binding ................................... 462
   Using the Color Chooser Palette with Binder .... 464

17. **Customizing the Solaris Environment** .............. 465
   Viewing Information About Your Workstation ..... 465
      Your Workstation Information .................. 466
      Networking Information ........................ 467
      System Memory Information .................... 467
      Solaris Information ................................ 468
   Using the Workspace Properties Window .......... 468
   Change Bars ............................................ 470
   Workspace Properties Window Buttons .......... 470
Setting the Active Window .......................... 488
Setting the Default Locations for Icons .......... 488
Changing Scrollbar Placement ...................... 489
Locale ............................................. 489

18. Utilities .......................................... 491
   Refresh ........................................... 491
   SPARC Reset Input ............................... 492
   Function Keys .................................. 492
   International Keyboard Support ............... 493
   Switching Between Virtual Keyboards .......... 494
   Window Controls ................................ 495
   Using Window Controls .......................... 496
   Save Workspace .................................. 497
   Lock Screen ..................................... 497
   Console ......................................... 498

19. Using the AnswerBook Software ............... 499
   The Contents of Your On-Line Library .......... 499
   AnswerBook Navigator and Viewer ............... 500
      Closing or Quitting the AnswerBook Navigator and Viewer 504
   Finding and Displaying a Document .............. 504
   Opening an AnswerBook .......................... 504
   Navigating Through Sets and Books in an AnswerBook .. 506
   Following Hypertext Cross-Reference Links ....... 508
   Searching with the Navigator ..................... 509

Contents xxxv
Print Tool Troubleshooting ........................................... 536
SnapShot Troubleshooting ............................................ 536
Tape Tool Troubleshooting ............................................ 537
OpenWindows Troubleshooting ....................................... 539
core Files ................................................................. 539
Blank Screen ............................................................... 540
SPARC Jumbled Text Characters ................................. 540
Problems with .xinitrc ...................................................... 540
Window Damage ............................................................ 541
Window Frozen when Opening an Application ............. 541
Window Does Not Accept Input ....................................... 541
Workspace Properties Troubleshooting .................. 542
B. Access for Users With Disabilities .................. 545
Starting AccessX .......................................................... 546
AccessX Windows .......................................................... 546
The AccessX Main Window ............................................. 547
Displaying the Status of Buttons and Keys ............... 547
Getting a Beep When a Feature is Turned On or Off ...... 548
Setting the Automatic Shutoff Timer ......................... 548
Getting On-Line Help ...................................................... 549
The Settings Window ...................................................... 549
Individual Features ......................................................... 551
StickyKeys ................................................................. 551
MouseKeys ................................................................. 552
ToggleKeys ........................................ 554
RepeatKeys ..................................... 555
SlowKeys ....................................... 556
BounceKeys .................................... 557
Keystrokes for AccessX Features ............. 558
Glossary ....................................... 559
Index .......................................... 577
Preface

This manual provides new and experienced users with the basic information needed to get started with the Solaris™ user environment (using OpenWindows™ and DeskSet™ applications). The Solaris user environment is based on the OPEN LOOK® Graphical User Interface. Additional topics covered here include how to modify the OpenWindows Workspace, how to access AnswerBook™ to view documents on-line, and troubleshooting.

Audience

This guide should help you become familiar with the basics of the OpenWindows environment and user interface concepts. The information in this guide should help you to perform basic OpenWindows tasks, such as:

• Displaying and choosing from the Workspace menu
• Moving an application icon
• Opening and closing an application icon
• Pinning and unpinning a pinnable window
• Displaying and choosing from an application’s File menu
• Choosing exclusive or non-exclusive choice items on a properties window
• Selecting items in a scrolling list
• Using scrollbars
• Selecting multiple objects
If you are not familiar with these operations, read Chapter 1, “Introduction to the Solaris User Environment” for information on how to use the mouse, icons, windows, and menus. The on-line tutorial *Introducing Your Desktop* also provides information about these OpenWindows elements.

Note that context-sensitive help is available for each application. Position the pointer over the item you want help with, and press the Help or F1 key, depending upon your keyboard. A pop-up window is displayed giving detailed information.

**Note** – Solaris supports SPARC, x86, and PowerPC machines, whose keyboards differ. Consequently, some keyboard equivalents of commands found in OpenWindows menus differ, according to keyboard.

For most keyboard equivalents, Solaris supports a Meta key combination that can be used on both platforms. See Chapter 1, “Introduction to the Solaris User Environment” for a list of command functions and their various keyboard equivalents.

---

**How this Guide is Organized**

This guide is divided into several major components:

- Introduction to OpenWindows, DeskSet, Workspace and on-line help concepts.
- Descriptions of the DeskSet applications. Each tool in the DeskSet has a separate chapter with descriptions of the tool’s windows, icon(s), controls, and special features, and step-by-step instructions for accomplishing various tasks. Each chapter concludes with a description of that tool’s properties that allow you to customize special features to your own preference. The more experienced you become, the more likely it is that you will want to customize features.
- Description of the Workspace properties and how to use them.
- A Troubleshooting section on the Solaris environment—OpenWindows, DeskSet, and the WorkSpace Properties.
- The AnswerBook appendix provides information on using AnswerBook.
- The Glossary entries define concepts that you may need to know as you become familiar with the Solaris user environment.
Conventions

The following conventions are used in this guide:

• Terms introduced for the first time, variables, and book titles are in *italic type*.

• Names of buttons, menu items, and settings have initial capitals (for example, Choose Print from the File menu).

• Text that you type is in Courier font.

• Text that appears on the screen, such as a file name, is in Courier font.

• Names of keys on the keyboard have initial capitals (for example, Press the Shift key). The key referred to as Return is labeled Enter on some keyboards.

• Names of mouse buttons are referred to by function, not by location, and are capitalized. For example, “Press SELECT” is used, not “Press left.” This convention is used because the mouse buttons are customizable, so the left mouse button might not be the SELECT button for everyone. See Chapter 17, “Customizing the Solaris Environment” and Chapter 18, “Utilities” to learn how to customize your mouse button function assignments.

![Diagram of mouse buttons]

**Figure P-1** Default Functions of the Mouse Buttons

For a three-button mouse, the default function assignments are:

• SELECT = the left mouse button

• ADJUST = the middle mouse button

• MENU = the right mouse button
For a two-button mouse, the default function assignments are:

• SELECT = the left mouse button
• MENU = the right mouse button

To use the ADJUST function on a two-button mouse, press and hold the keyboard Shift key and click the SELECT mouse button.

• When the entire menu is discussed, or when the default menu item is discussed, a default ring, surrounds the default item of the menu. By default clicking SELECT on a menu button displays the entire menu. You can change this default behavior so that (without displaying the menu) the default menu item is chosen. This book assumes you have this setting.

• Illustrations that depict screen images are meant to be representative. For example software version numbers are not shown in window headers.

• Open Windows menu commands carried out using keyboard equivalents (also called keyboard accelerators) are represented in this manual with the following convention: a dash ( - ) indicates that you press two keys at the same time.

For example, Ctrl-Alt means that you press and hold both the Control and Alt keys at the same time; Ctrl-Alt-c means that you press and hold Control and Alt at the same time and simultaneously type c.

• Keyboard equivalents are obtained by pressing the Meta key and one or more additional keys on the keyboard. On SPARC keyboards the Meta key is the <> key; on x86 and PowerPC keyboards the Meta key is obtained by pressing the Ctrl and Alt keys simultaneously (Ctrl-Alt). For more information on keyboard equivalents, see Chapter 1, “Introduction to the Solaris User Environment,” and Chapter 17, “Customizing the Solaris Environment.”

• This guide uses the following notation to describe choosing a menu option. For example: choose Workspace ➤ Programs.
Platform-Specific Conventions

The following symbols preceding a section or procedure title indicate that the section or procedure pertains only to the particular platform:

- **SPARC** Denotes a SPARC platform-specific section or procedure
- **x86** Denotes an x86 platform-specific section or procedure
- **PowerPC** Denotes a PowerPC platform-specific section or procedure

Platform-specific notes are indicated as follows:

**SPARC** – This note is specific to the SPARC platform.

**x86** – This note is specific to the x86 platform.

**PowerPC** – This note is specific to the PowerPC platform.

Platform-specific bullet items are indicated as follows:

- **SPARC**: This bullet is specific to the SPARC platform.
- **x86**: This bullet is specific to the x86 platform.
- **PowerPC**: This bullet is specific to the PowerPC platform.

If a code sample, table, or figure pertains to a specific platform, the name of the particular platform appears at the beginning of the title. For example:

- **Table 1-1** SPARC: Title Specific to SPARC Platform
- **Table 1-2** x86: Title Specific to x86 Platform
- **Table 1-3** PowerPC: Title Specific to PowerPC Platform
Other Books

For additional information, refer to the following Solaris books:

- Solaris Advanced User’s Guide
- SPARC: Installing Solaris Software
- x86: Installing Solaris Software
- System Administration Guide, Volume I
- System Administration Guide, Volume II
This chapter provides an introduction to the Solaris™ User environment, which consists of the OpenWindows environment, and the DeskSet applications. The DeskSet is a set of default programs — such as an electronic mail application and a text editor.

“Overview of the OpenWindows Environment” on page 5 describes the elements of your desktop environment (Workspace) and how to use them. “Introduction to the DeskSet Applications” on page 36 describes how to choose the right application for the task you need to accomplish. The third and forth major sections talk about using on-line Help and AnswerBook. You can choose the method of learning that is most comfortable for you.

Those who have had previous experience with OpenWindows may want to skip this introductory chapter and move on to the rest of the book where a chapter is devoted to each of the DeskSet applications and the Workspace Properties.
Logging In and Logging Out

Before you start, your system must be ready to use. Your system is ready to use when Solaris is fully installed, and the login prompt is on the screen. If Solaris is not installed, refer to the installation manual for your specific platform.

When you begin working on your system, you will need to log in. Logging in tells the system who you are and what you have permission to do. Likewise, when you finish, you will log out so that no one else can access your files without permission.

Logging In

Since more than one person can have an account on a single system, each user must log in using his or her own unique user name and password. Logging in indicates who is using the system and what files they can access.

To log in:

1. **Type your user name at the login prompt and press Return.**
   The user name tells the system who you are. Your user name should have been defined during installation. For more information, refer to the installation manual for your specific platform. The Solaris operating environment recognizes the difference between uppercase and lowercase letters, so make sure you type the user name using the correct case.

   The login prompt usually consists of your machine name (assigned as the Hostname during the installation) followed by the word `login:`, as shown in the example in Figure 1-1.

   ```
   genius login: johndoe
   ```

   *Figure 1-1*  The login: prompt
2. Type your password at the Password: prompt and press Return.
You do not see the characters on the screen as you type your password, as shown in the example in Figure 1-2.

```
genius login: johndoe
Password:
```

*Figure 1-2 The Password Prompt*

If you mistype the user name or password and have already pressed Return, the system asks you to start over with your user name. See the example in Figure 1-3.

```
genius login: johndoe
Password:
Login incorrect.
login:
```

*Figure 1-3 Log in again with your user name*

After you type your password, OpenWindows launches automatically (if a full installation was performed.)

---

**Note** – If OpenWindows does not launch automatically (for example, you may have OpenWindows configured differently), you can start OpenWindows manually. If you are unsure, contact your system administrator.

3. To start OpenWindows manually after you login, type `openwin` and press Return.
Logging Out

When you are done working on the system, you will need to log out. If you are sharing a system, this allows other people to log in to your computer under their own accounts.

To log out:

1. You must exit OpenWindows to log out. Press the MENU button and select Exit.
   A Notice appears asking you to confirm that you want to exit from OpenWindows.

2. SELECT Exit.
   Normally, when you exit OpenWindows, the system automatically logs you out. However, if it does not, go to Step 3.

3. Type exit (or logout) and press Return.
   The login: prompt appears, as shown in the example in Figure 1-4. Now another user can log in under their own account and use the system.

```
genius% johndoe
genius login:
```

Figure 1-4   Type Exit to Log Out
Overview of the OpenWindows Environment

When you start the Solaris software, you see the Workspace background on your screen, as well as the DeskTop Intro, described later in this chapter. The Workspace is the display area for objects such as windows, icons, and menus. Figure 1-5 shows a portion of the Workspace with several open application windows. Notice that the windows can overlap each other.

Figure 1-5  Partial View of the Workspace with Three Open Windows
You interact with the applications using the keyboard, the mouse, and an arrow on the Workspace, called a “pointer,” that moves in correspondence with the mouse.

Windows and Icons

Several default applications appear on the Workspace when you start the Solaris software. Each application runs in its own window. When you use the OpenWindows environment, you open the applications that you need. You can use several applications simultaneously, such as electronic mail, your daily calendar, and a text editor.

![Figure 1-6 Multimedia Mail Tool Header Window](image)

**Closing a Window to an Icon**

When a window is not in use, you can close it and keep it on the Workspace for further use. When closed, an application becomes an icon—a small symbol that represents the application. If you will not be using that application for some time, you can quit it entirely—which clears it from the Workspace—and start it again later. Figure 1-7 shows the icon for the Text Editor application. (Chapter 3, “Text Editor,” discusses Text Editor in more detail.)
Opening an Icon to a Window

You can open an application icon (into a window) from its closed icon by positioning the mouse pointer over the icon and pressing the MENU button and selecting Open from the Window menu, or by double-clicking SELECT. With double-clicking, the first click highlights a border around the icon, and the second click opens it into a window. For information on using the mouse, refer to “Mouse and Pointer” on page 7.

Mouse and Pointer

The easiest way to access the windows in the Workspace is to use your mouse—the small electronic device that sits on a pad next to your workstation. Notice that when you move the mouse, the pointer on the Workspace moves with you to a new location. Figure 1-8 shows the pointer moving across the Workspace.

Versions of the Pointer

The pointer changes shape to reflect current position and system activity. Figure 1-9 shows various pointer types.
Using the Mouse Buttons

The mouse buttons enable you to control the windows, icons, and menus on the Workspace. The terminology of the mouse and pointer is as follows:

- Mouse buttons are referred to by function. From left to right, on a three-button mouse, these are: SELECT, ADJUST, and MENU. A two-button mouse has only SELECT and MENU; ADJUST is performed by pressing the keyboard Shift key and clicking SELECT.

Figure 1-10 shows the function of each mouse button. Note that you can change this default arrangement. Chapter 17, “Customizing the Solaris Environment,” describes how to swap SELECT and MENU for left-handed use.

- You click a mouse button by pressing and releasing it quickly.
- You double-click a mouse button by clicking twice quickly (within approximately half a second or less) without moving the pointer.
• You click SELECT to choose an item.
• You click ADJUST to make a secondary choice or modify what you have chosen with SELECT.
• You press MENU (and hold) to make a choice from a menu. Throughout this text, “press” means to press and hold.
• You release the mouse button to initiate the action.
• You move the pointer by sliding the mouse with no buttons pressed.
• You drag the pointer by pressing a mouse button while sliding the mouse.

**Pointer and Input Area**

Because you can have several windows open on the Workspace at once, the OpenWindows environment must track which window is currently active. You can choose between two methods of notifying the window system of the currently active window or input area: Move Pointer and Click SELECT.

In Move Pointer mode, the window is activated when you move the pointer onto the window pane. In Click SELECT mode, you must also click SELECT in the window to designate that window as the input area.

The default mode is Click SELECT. See the section “Setting the Active Window” on page 488 for information on how to use the Workspace Properties window to change to Move Pointer mode.

The insert point in a text window changes in appearance depending upon whether that window is active or inactive. If the insert point is active it looks like a triangle. If it is inactive, it looks like a dimmed diamond, and you must move the pointer into the window, and, if in Click SELECT mode, click SELECT in that window’s work area to activate the insert point. When you begin typing, the text appears at the insert point. Figure 1-11 shows an insert point that is active, and one that is inactive.

![Active and Inactive Insert Points](1-11.png)
**Pointer Jumping**

In most cases, you move the pointer by moving the mouse. However, in some cases, the pointer moves for you and jumps directly to a specific place on the screen. This is called *pointer jumping*.

For example, if you apply a change to the Workspace Properties window, a pop-up window appears with a warning that this will change a file that you may have manually customized. The pop-up window asks if you want to make these changes, and the pointer jumps to the Yes button. You must click SELECT on one of the choices in the pop-up window before you can do anything else on the desktop.

**Keyboard Equivalents**

In some cases you can speed up command operations by using a sequence of keystrokes, called *keyboard accelerators*, that duplicate the operations of the mouse and menus, and of the pre-configured keyboard keys.

The following table lists several command operations and the keyboard equivalents for SPARC, x86, and PowerPC-based machines.

**Note** – The Meta key is the <> key on SPARC keyboards and is obtained on x86 and PowerPC keyboards by pressing Ctrl-Alt.

To carry out a keyboard accelerator operation, press and hold the first key (Meta or Control-Alt together) and type the second key. For example, to cut selected text, press and hold the Meta key and press x on a SPARC system; on an x86 system, press and hold Control and Alt together and press x simultaneously.
Table 1-1  Keyboard Accelerators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Keyboard Equivalent</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Again</td>
<td>Meta - a</td>
<td>Repeats the previous operation</td>
</tr>
<tr>
<td>Copy</td>
<td>Meta - c</td>
<td>Copies the selection to the clipboard</td>
</tr>
<tr>
<td>Cut</td>
<td>Meta - x</td>
<td>Cuts the selection and puts it on the clipboard</td>
</tr>
<tr>
<td>Find</td>
<td>Meta - f</td>
<td>Finds the selection to the right of the caret</td>
</tr>
<tr>
<td>Help</td>
<td>Help or F1</td>
<td>Displays a help window with context-sensitive help for the object at the pointer location</td>
</tr>
<tr>
<td>New</td>
<td>Meta - n</td>
<td>Loads a new file</td>
</tr>
<tr>
<td>Open (File)</td>
<td>Meta - o</td>
<td>Opens a file (for example, if you’ve highlighted a file icon in File Manager)</td>
</tr>
<tr>
<td>Open (Window)</td>
<td>Meta - w</td>
<td>Opens an icon or closes a window to an icon</td>
</tr>
<tr>
<td>Paste</td>
<td>Meta - v</td>
<td>Copies the clipboard selection to the insertion point</td>
</tr>
<tr>
<td>Print</td>
<td>Meta - p</td>
<td>Sends the file to the printer (for example, if you’ve highlighted a file icon in File Manager)</td>
</tr>
<tr>
<td>Props</td>
<td>Meta - i</td>
<td>Displays the property window for the application at the pointer location</td>
</tr>
<tr>
<td>Redo</td>
<td>Shift-Meta - p</td>
<td>Undoes an Undo</td>
</tr>
<tr>
<td>Save</td>
<td>Meta - s</td>
<td>Save the current file</td>
</tr>
<tr>
<td>Stop</td>
<td>Stop or Esc</td>
<td>Stops the current operation</td>
</tr>
<tr>
<td>Undo</td>
<td>Meta - u</td>
<td>Undoes the previous operation</td>
</tr>
</tbody>
</table>

Note – For instructions on remapping a SPARC or x86 keyboard, see the *Solaris Advanced User’s Guide.*
Menus and Pushpins

A menu lists the choices you can make from the Workspace or window. For instance, to start an application, you move the pointer to any location on the Workspace background and press the MENU button. This displays the Workspace menu, which includes Programs, Utilities, Properties, Workstation Info, Help, and the option to Exit the OpenWindows environment. Figure 1-12 shows the Workspace menu.

Using the Workspace Menu

There are two ways to display the Workspace menu.

- You can click the MENU mouse button quickly in the Workspace. The Workspace menu will pop up and stay up until you make a selection or dismiss the menu by clicking SELECT elsewhere.
- You can press and hold MENU in the Workspace to display the Workspace menu and then slide the pointer onto an item. With this method the Workspace menu is dismissed when you release the mouse button.
Using Submenus

When you display the Workspace menu, the first two items—Programs and Utilities—each have a hollow triangle next to them, pointing to the right. This means that there is a submenu of additional choices. To display a submenu, keep pressing MENU as you drag the pointer to the right at one of the arrows. Figure 1-13 shows the Programs submenu.

![Figure 1-13](programs_submenu.png)

Figure 1-13  Programs Submenu

If you continue to press MENU and drag to the right at Programs, the Programs submenus is displayed containing a list of default applications (called DeskSet) available for the OpenWindows environment. To choose an item from the Programs submenu, press MENU and drag the pointer over to your choice. When the choice is highlighted, release the mouse button. In a moment, the application you chose appears on the Workspace. At some point you may want to customize the order and entries on your programs menu. For information on how to do this refer to Chapter 17, “Customizing the Solaris Environment.”

Pinning a Menu

You can use the pushpin in the upper left corner of the menu to “pin” the Workspace menu to the Workspace and keep it there indefinitely. Note that these instructions apply to any menu or window with a pushpin.
Figure 1-14 shows the Workspace menu pinned to the Workspace.

![Figure 1-14 Menu Pinned to the Workspace](image)

To pin the menu, press MENU to display the Workspace menu and keep the button pressed down as you drag the pointer over the pushpin. The pushpin moves into the hole and the menu stays up.

**Choosing from a Pinned Menu**

To choose an item from a pinned menu, you position the pointer on the item and click SELECT.

**Dismissing a Pinned Menu**

To unpin a menu, just click SELECT on the pushpin again.

**Using Window Menus**

Windows can have three kinds of menus. Examples of each of the following menu types are shown in Figure 1-15.

- The Window menu that you access from an **abbreviated menu button** in the window header or from the window border.
- A button menu that you access from a menu button in the window **control area**—the portion of a window that contains menu buttons and other controls.
- A pop-up menu available from the window **pane** (the bordered area where window data are displayed).
Using Window Menus

To choose a menu item:

1. Position the pointer on one of the three window areas:
   - A window header’s abbreviated menu button (or the header itself)
   - A menu button
   - A window pane

2. Press MENU, and drag the pointer down to the right to highlight the item of your choice.

3. Release MENU.
Choosing Menu Defaults

Most of the menus in the Workspace and windows have default choices. A default menu item is usually the first item in the menu. It is encircled with a small black line. The default choice on the Workspace menu, as shown in Figure 1-16, is the Programs submenu.

![Default menu selection](image)

*Figure 1-16  Default Choice on the Workspace Menu*

All menus and submenus have default choices. The default choice under the Programs submenu is File Manager. When you choose Programs from the Workspace menu, the File Manager is displayed.

Changing the Menu Default

If you find that you often make a menu choice other than the default, you might want to define that item as the default choice. To change the default choice:

1. **Display the menu to be modified.**
   - Press MENU, and drag the pointer to display that menu.

2. **Position the pointer on the default choice and press MENU again.**

3. **Press the Control key on your keyboard while pressing MENU.**

4. **Drag the pointer up or down until the new default menu item is highlighted.**

5. **Release the Control key.**
6. **Release the mouse button.**
   When you click SELECT on that menu, your chosen application is the default.

**Window Controls**

The basic controls for an application are displayed in control areas within the base window. An application can have a single control area in a single base window, or may have additional control areas elsewhere in the base window or subwindows.

Figure 1-17 shows the variety of controls possible for window applications.
Scrollbars

Some windows contain scrollbars that enable you to scroll through lists or see previous commands. The Text Editor is an example of a scrolling window. By default, most scrollbars appear on the right side of scrolling windows, although you can move them to the left side. See Chapter 17, “Customizing the Solaris Environment,” for information.

You scroll up incrementally to view previous commands by placing the pointer on an up arrow in the Scrollbar elevator and clicking SELECT. You can scroll down again by placing the pointer on the down arrow and clicking SELECT. You can also press SELECT on the drag area and slide the elevator up or down. Figure 1-18 shows Command Tool’s scrollbar and its elements.

By contrast, the Shell Tool is a nonscrolling window. If you type a long series of command lines in a nonscrolling window, you cannot see lines that scroll above the top of the window.
Button Menus

Button Menus or Window buttons appear in the control areas of many applications. Some window buttons provide a single option, and others provide menus of choices. The Edit submenu in the Text Editor application, for instance, provides editing options for cutting, copying, and pasting text, as well as repeating or undoing an edit. Text Editor’s abbreviated menu button, in the upper left corner, displays options common to most DeskSet applications, such as Open/Close, and Quit. The Text Editor menu buttons are shown in Figure 1-19.

![Text Editor's Menu Buttons](image)

There are four buttons at the top of the Text Editor window, each with a hollow triangle pointing down, indicating that there are further menu choices beneath each button. You can see these choices by placing the pointer on one of the buttons and pressing MENU. The window buttons for all of the applications are discussed in their respective sections.
Drag and Drop

The OpenWindows drag and drop feature enables you to use your applications together. To send a file from one application to another, you drag a file (in icon form) from the first application and drop it on the second application icon or its drag and drop target—a small rectangle in the application window. (In most applications, the drag and drop target is in the upper right corner.)

An application’s drag and drop target is an empty rectangle if the application does not currently contain a file. When a file is opened from the application or dropped onto the drag and drop target, the target changes in appearance. Figure 1-20 shows an empty drag and drop target and one that contains a file.

![Drag and Drop Targets](image)

Figure 1-20 Drag and Drop Targets

Follow the steps below for any drag and drop operations:

1. **Select an object or objects to be dragged.**
   For example, you might want to select a set of files in the File Manager by pointing at the first file and clicking SELECT, and then clicking ADJUST on the additional files. Or you might want to select a section of text from the Text Editor by pressing SELECT at the start of the desired text, dragging through the text to be moved, and releasing SELECT.

   If you want to drag just one file or the contents of a drag and drop target, you can skip this first step.

2. **Initiate a move by pointing at a file glyph, the shaded area in a drag and drop target, or a selected object.** Then press SELECT and drag the pointer.
   If you want to copy the object instead of move it, you can do so by pressing the Control key on the keyboard before pressing SELECT. Keep the Control key held down until after the drag is initiated.
3. When the *hot spot* of the pointer (the tip of the pointer arrow) is at an appropriate place, drop the selection by releasing SELECT.

The selection is “dropped” at the new location. Depending on the object being dragged, the location can be an icon, a drag and drop target, the window of an application, the workspace background, or a text pane.

In many cases you do not need to worry about whether you need to move an object or copy it. Whenever you use drag and drop to move an object, the DeskSet applications attempt to do the right thing based on the operation. For example, if you move a file from the File Manager into the Wastebasket, it is actually moved to the Wastebasket. (That is, the file is removed from the original location.) On the other hand, if you move a file from the File Manager onto the Print Tool, the file is only copied. The original file remains in its original location.

If it is not obvious whether an object should be moved or copied, it is moved unless the Control key is held down while the drag is initiated.

The following paragraphs list some typical drag and drop operations between the DeskSet applications. See the chapter for each application for more information about how the application supports drag and drop operations.

File Manager glyphs can be dropped onto the following DeskSet applications:

- Mail Tool
- Wastebasket
- Print Tool
- Tape Tool
- Text Editor
- Icon Editor (if it is an icon file)
- Snapshot (if it is a raster or GIF file)
- Audio Tool (if it is an audio file)

Mail messages from the Mail Tool Header window can be dropped onto the following DeskSet applications:

- Text Editor
- Print Tool
- File Manager
- Wastebasket
- Calendar Manager (with specific format restrictions)
Mail Tool Attachments can be dropped onto these DeskSet applications:

- File Manager
- Wastebasket
- Print Tool
- Text Editor
- Image Tool
- Icon Editor (if it is an icon file)
- Snapshot (if it is a raster file)
- Audio Tool (if it is an audio file)

Text selections from Text Editor files can be dropped onto these applications:

- Mail Tool
- Text Editor
- Print Tool
- Calendar Manager (with specific format restrictions)
- Icon Editor (if it is an icon file)
- File Manager
- Wastebasket
- Command Tool

Text files from the Text Editor drag and drop target can be dropped onto these applications:

- File Manager
- Wastebasket
- Print Tool
- Mail Tool
- Calendar Manager (with specific format restrictions)
- Command Tool

If an error occurs during a drag and drop sequence, refer to Appendix A, “Solaris Troubleshooting.”

**Drag and Drop Examples**

Sometimes an application has a drag and drop target, typically located in the top right of an application’s control area. The drag and drop target is shown in Figure 1-21. Note that on a color workstation the drag and drop target will appear lightly shaded.
Figure 1-21 Drag and Drop Target

When you drop an object onto a drag and drop target, the object is loaded into the application, replacing whatever was currently loaded. For example, if you drop a file or text selection onto the Text Editor’s drag and drop target, the entire contents of the Text Editor are replaced by the dropped file or text.

Some drag and drop targets contain lines to indicate that the entire contents of the current application can be dragged out of the drop target. For example, when you drag the lined area from the Text Editor drag and drop target, the entire contents of the Text Editor are dragged.

Figure 1-22 Drag and Drop Target Containing a Draggable Object

You can sometimes drop an object directly into a pane that contains data in order to add the object instead of loading it. For example, you might want to drop text somewhere within a text pane to insert the dropped text into the existing text of the pane (instead of replacing the existing text, which would happen if you dropped the text on the drag and drop target). Another common example is to drop a file onto a folder in the File Manager to add that file to the folder.

There are many ways to drag and drop files among DeskSet Applications. The following are several examples.

- You can print a file by dragging it and dropping it onto the Print Tool icon or its drag and drop target. Figure 1-23 shows Print Tool’s drag and drop target. Chapter 10, “Print Tool,” discusses Print Tool in detail.
Figure 1-23  Print Tool’s Drag and Drop Target

- You can delete a file you no longer need by pressing SELECT on the file icon in File Manager or in the Attachments window of a Multimedia Mail Tool message, dragging it to the wastebasket icon, and releasing the mouse button.
- You can drag a text file, folder or other icons from File Manager and drop them on the Workspace to view it.
- You can drag files attached to a Multimedia Mail Tool message window and drop them onto the Workspace: the application with which the file was created (such as File Manager, Text Editor, Audio Tool, or Icon Editor) is invoked and the file is opened in the application window. Refer to Chapter 2, “File Manager”, or Chapter 4, “Multimedia Mail Tool” for more information about dragging and dropping with these tools.
Positioning Windows and Pinned Menus

You can position your windows and pinned menus anywhere on the Workspace, and can move a window or menu in front of other windows. To move a window to a new location on the Workspace:

1. **Move the pointer to the black line that surrounds an open window or pinned menu, and press SELECT.**
   Figure 1-24 shows the pointer on a window edge for repositioning.

   ![Press SELECT on the window outline](image)

   *Figure 1-24  Moving an Application Window*

2. **Drag the pointer across the Workspace to a new location.**
   A border box the size of the window moves with the pointer.

3. **Release SELECT.**
   The window appears in the new location.
Moving Multiple Windows

You can group windows together so that they move as a unit. For instance, you may want to arrange several windows on the Workspace in relationship to one another, and then move the whole arrangement to a new location.

One way to group several windows is to click SELECT on one of the windows and ADJUST on each additional window. Alternatively, you can drag the pointer across the Workspace to form a box around the windows you want to group. You can do this as follows:

1. Place the pointer in the Workspace at one corner of the set of windows you want to group.

2. Press SELECT and drag the pointer diagonally to the opposite corner of the group.
   This forms a rectangle around any windows and icons that are fully enclosed within the border box.

3. Release the mouse button.
   The items are selected as a unit.

4. Place the pointer on the edge of one of the grouped windows as described in the last section, “Positioning Windows and Pinned Menus,” press SELECT, and drag the pointer to a new location.
   The group of windows moves to the new location.

5. To un-group the applications, press SELECT anywhere on the Workspace.

Moving a Window Front or Back

To move a window in back of another window:

1. Move the pointer onto the header of the window you wish to move in back.

2. Press MENU, drag the pointer to highlight Back.
   Figure 1-25 shows the Back button highlighted on a Window menu.
3. Release MENU.
   That window moves to the rear.

**SPARC** – Alternatively, you can use the Front key on your keyboard, which toggles back/front depending on the location of the window. (If the window is in back and you position the pointer in that window and press the Front key, that window moves to the front. But if it is already in front, it moves in back.)
Moving Icons

You position icons in much the same way as you do windows and pinned menus. To move an icon to a new location, just move the pointer onto an icon, press SELECT, and drag the outline of the icon to a new location. When you release the mouse button, the icon appears in the new place. Figure 1-26 shows an icon and the outline that appears as it is moved.

Figure 1-26  Moving an Icon to a New Location

When you first start an application and then close it to an icon the icon appears in a default location. You can change the default locations by selecting Save WorkSpace from Utilities or with the Workspace Properties window. Chapter 17, “Customizing the Solaris Environment,” describes the Properties window.

Resizing Windows

The corners of windows are the handles you use for resizing. To resize a window:

1. Position the pointer on one of the window corners.
   The pointer turns into a tiny bull’s eye. This means that the pointer is in the correct location for resizing.

2. Press SELECT and drag the pointer to the desired size.
   An outline shows the size of the window.

3. Release SELECT.
   Figure 1-27 shows the pointer positioned on a window’s handle for resizing.
Closing and Quitting Windows

Each window has a Close option in its window menu. You can access this by placing the pointer in the header or on the window border, holding down the MENU mouse button, and highlighting Close, as shown in Figure 1-28.
When you release the mouse button, the window closes to its icon form. Alternatively, because Close is the default choice in the window menu, you can click SELECT on the abbreviated menu button in the window header.

The menu in the window header also includes a Quit option. To quit a window from the Workspace, move the pointer onto the header or the abbreviated menu button, press the MENU mouse button, and highlight Quit. When you release the mouse button the window is dismissed from the Workspace and the application quits.

**Starting an Application**

You start applications from the **Workspace menu**, which you display by placing the pointer in the Workspace and holding down the MENU button. To start an application of your choice, you drag the pointer to the right to display the Programs submenu, and then to the name of the application. When the name is highlighted, you release the mouse button. After a moment the application is displayed on the Workspace.
Elements of an Application’s Base Window

Some applications have one window, and others have one or more subwindows. The primary window that appears when you display an application is called a base window. Figure 1-29 shows the visual elements of a simple base window.

Opening, Saving, Including and Attaching Files

Once you begin working with the DeskSet applications, you will at sometime need to open, save (or rename), include, or attach a file (or document). There is a standard window that looks very similar from application to application for performing these tasks throughout the DeskSet applications. Once you learn the basic elements of this window, you can easily perform these tasks.

DeskSet applications that use this type of window include: Text Editor, Mail Tool, Command Tool, Shell Tool, Audio Tool, Image Tool, Snapshot, and Icon Editor.
Figure 1-30 shows an example of a standard Open window. This window looks very similar from application to application, except the window header reflects the current task. For example, you’ll see a reference to the application, such as Text: and the name of the task following it, like Open, Save, Save As, Include or Attach.

Note – You can use File Manager to keep track of documents and folders (directories and files). Refer to Chapter 2, “File Manager”, for information on how to use it.
Opening a Document

To open a document from an application:

1. **Choose Open from the File menu.**
   An Open window similar to the one in Figure 1-30, is displayed.

2. **Select the name of the folder from the scrolling list.**
   Click SELECT on the name of the folder, then click Open. Or, double-click on the name of the folder. If it is not displayed, double-click on “Go up one folder.” You may need to repeat this a few times.

3. **Choose the folder that contains the document you want to open.**
   The name of the folder must be displayed under Current Folder. To display the folder you can:
   a. Select the folder from the Go To menu by pressing MENU on Go To, then choosing the desired folder from the menu.
   or
   b. Type the path name of the folder in the Go To text field and press Return, or click SELECT on the Go To button.

4. When the scrolling list shows the contents of the folder, select the desired document and click SELECT on Open.
   You can also double-click on the name of the document.

**Note** – You can use the same steps as opening a document for including a file from Text Editor or Attaching a file from Mail Tool. The result will be an included or attached file (or document).

Saving a Document

You may need to save (or rename) a document in one of three stages:

- Saving a new and untitled document
- Saving an existing document
- Saving and renaming an existing document (Save as)
Saving a New and Untitled Document

The first time you work with a document (or file), you have to give it a name and save it to a particular location in your file system.

1. **Choose Save from the File menu.**
   Depending on the application you are working in, you see a Save window similar to the one in Figure 1-31.

   ![Figure 1-31 An example of the Save Window](image)

2. **Choose the folder location for saving the document.**
   The name of the folder must be displayed under Current Folder.
3. Select the name of the folder from the scrolling list.
   Click SELECT on the name of the folder and click Open, or, double-click on the name of the folder. If it is not displayed, double-click on “Go up one folder.” You may need to repeat this a few times.

   or

   a. Type the name of the folder in the Go To text field or click SELECT on the Go To button and press Return.

   b. Select the folder from the Go To menu: press MENU on Go To, then choose the desired folder from the menu.

4. Type a name for the document in the text field and SELECT Save.
   When the scrolling list shows the contents of the folder, type a document name and click SELECT on Save.

**Saving an Existing Document**

To save changes to the contents of an existing file:

♦ Choose Save from the File menu.
   The document is saved with the same name and in the same folder.

**Saving and Renaming an Existing Document**

The following procedure saves a file under a name:

1. Choose Save As from the File menu.
   Depending on the application you are working in, you see a Save As window similar to the one in Figure 1-31.

2. Choose the folder location for saving the document.
   The name of the folder must be displayed under Current Folder. To display the folder you can:
3. Select the name of the folder from the scrolling list.

   Click SELECT on the name of the folder, or, double-click on the name of the folder. If it is not displayed, double-click on “Go up one folder.” You may need to repeat this a few times.

   or

   a. Type the name of the folder in the Go To text field or click SELECT on the Go To button and press Return.

   b. Select the folder from the Go To menu: press MENU on Go To, then choose the desired folder from the menu.

4. Type a new name for the document in the text field and SELECT Save As.

   When the scrolling list shows the contents of the folder, type a document name and click SELECT on Save.

   **Note** – When you rename a document without making changes to it, you will have two versions of the document, one with the old name and one with the new name. If you work with a file on a daily basis, note the name of the one you are working with so as not to overwrite the wrong one when you save your work.

---

**Introduction to the DeskSet Applications**

DeskSet is the collection of applications which come with the Solaris software. The DeskSet applications are the default set available from the Workspace Programs submenu.

The following sections discuss the tasks you will most likely perform on a regular basis, and introduce the applications you need to accomplish those tasks. Each of the applications is discussed in detail in following chapters.

To start an application:

1. **Move the pointer onto the Workspace (the OpenWindows background).**

2. **Press (and hold) MENU.**

3. **When the Workspace menu is displayed, drag the pointer to display either the Programs or Utilities submenu.**
4. Drag the pointer down to highlight the application you would like to start.

When you release the mouse button, the application appears on the Workspace. Figure 1-32 shows an application being selected from the Program’s submenu.

![Figure 1-32 Choosing an Application](image)

Follow these instructions whenever you want to start a DeskSet application. The instructions from now on will say “choose Workspace ➤ Programs ➤ application” (where application is the appropriate application name).

**Starting DeskSet Applications**

You typically access DeskSet applications from the Programs submenu of the Workspace menu. You access the Workspace menu by pressing MENU with the pointer anywhere on the background of your DeskSet environment and off of all applications. When the DeskSet applications are installed on your system, they are automatically provided as items in the Programs submenu.

You can also start any of the DeskSet applications from a system prompt in a Command Tool or Shell Tool window by typing the file name. If you want to continue doing work in the Command or Shell Tool while the DeskSet
application is running, follow the application name with a space and the ampersand symbol (&). Table 1-1 shows what you should type to start each DeskSet application.

<table>
<thead>
<tr>
<th>Application Name</th>
<th>What you should Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AnswerBook</td>
<td>answerbook &amp;</td>
</tr>
<tr>
<td>Audio Tool</td>
<td>audiotool &amp;</td>
</tr>
<tr>
<td>Binder</td>
<td>binder &amp;</td>
</tr>
<tr>
<td>Calculator</td>
<td>calctool &amp;</td>
</tr>
<tr>
<td>Calendar Manager</td>
<td>cm &amp;</td>
</tr>
<tr>
<td>Clock</td>
<td>clock &amp;</td>
</tr>
<tr>
<td>Command Tool</td>
<td>cmdtool &amp;</td>
</tr>
<tr>
<td>Console</td>
<td>cmdtool -C &amp;</td>
</tr>
<tr>
<td>File Manager</td>
<td>filemgr &amp;</td>
</tr>
<tr>
<td>Icon Editor</td>
<td>iconedit &amp;</td>
</tr>
<tr>
<td>Image Tool</td>
<td>imagetool &amp;</td>
</tr>
<tr>
<td>Mail Tool</td>
<td>mailtool &amp;</td>
</tr>
<tr>
<td>Performance Meter</td>
<td>perfmeter &amp;</td>
</tr>
<tr>
<td>Print Tool</td>
<td>printtool &amp;</td>
</tr>
<tr>
<td>Shell Tool</td>
<td>shelltool &amp;</td>
</tr>
<tr>
<td>Snapshot</td>
<td>snapshot &amp;</td>
</tr>
<tr>
<td>Tape Tool</td>
<td>tapetool &amp;</td>
</tr>
<tr>
<td>Text Editor</td>
<td>textedit &amp;</td>
</tr>
</tbody>
</table>
Working with Text

The OpenWindows Text Editor is an application for working within documents and composing, editing, cutting, copying, and pasting text. Text Editor enables you to create and compose a new document or open (load) an existing document into the application for editing. You can also work with text using a command line editor (such as vi) in a Command Tool or Shell Tool. For information on using vi, refer to Solaris Advanced User’s Guide. Figure 1-33 shows the Text Editor application window.

Figure 1-33  Text Editor Application Window
Managing Your Files

The File Manager application provides a graphical display of the structure of the folders and documents (directories and files) in your file system. Each file appears as an icon, as shown in Figure 1-34.

![File Manager’s Base Window](image)

**Figure 1-34  File Manager’s Base Window**

**Opening a File in File Manager**

You can open a file or application displayed in the File Manager base window by pressing MENU on its icon and choosing Open. When you open a text file icon, for instance, a Text Editor application is started and the chosen file is opened in the Text Editor window.
**Viewing the Contents of a Folder in File Manager**

To look at the contents of a folder, you can press MENU on the icon and select Open, double-click SELECT on the folder icon or press SELECT on it, drag it into the Workspace, and release the mouse button. The icon opens into a window pane displaying the items in that folder.

**Moving Files in the File System**

You move files from one folder to another by selecting and dragging them with the pointer (for instance, from the top level of the home directory to a folder you have opened on the Workspace) or by cutting them from one folder, opening another folder, and pasting them there.

**Dragging and Dropping**

File Manager works interactively with the other DeskSet applications. For example, if you want to listen to an audio file, you can drag it from File Manager and drop it onto the Workspace.

To delete a file, you can drag it from its location to the Wastebasket icon. To send a file to the printer, you drag it and drop it on the Print Tool icon. To save a file or a set of files on a tape for other processing, you can drag files from File Manager to the Tape Tool application.
Managing Your Time

The OpenWindows environment provides an icon-based Clock program and an icon-based calendar, called Calendar Manager. Figure 1-35 shows the Calendar Manager base window.

Calendar Manager is an interactive application that lets you schedule your appointments and will send you messages about them on request. For instance, you can request that Calendar Manager beep or send an electronic mail message to your mailbox to remind you of important meetings, and you can check the calendars of others on your network.
Printing Your Documents

To print documents, you use Print Tool. Print Tool enables you to print documents from a variety of formats, including ASCII, troff, PostScript® text, and raster images. Figure 1-36 shows the Print Tool application window.

Figure 1-36  The Print Tool Application Window

To print a document, you can drag a file icon from File Manager and drop it on the Print Tool icon or on the open Print Tool drag and drop target. Another method is to type the file and pathname in the Print Tool text field and click SELECT on the Print button. You can also send messages and images to the printer from Multimedia Mail Tool and from Snapshot—an application that enables you to take pictures of windows and images on your workstation screen.
Communicating on the Network

Multimedia Mail Tool provides a convenient method of communicating with others electronically by sending and receiving messages, sound files, and other data files. It works together with the Calendar Manager application when you want to set up group meetings and send electronic notification and automatic reminder messages, and with Audio Tool when you want to send Voice Mail.

The Multimedia Mail Tool icon looks like a tiny in-box. The in-box is empty when there is no mail; it has stacked letters when the mail in the mailbox has been read, and overflowing letters when there is new mail. Figure 1-37 shows the Mail Tool icon in its different forms. The icon opens up into a base window for receiving, composing, and sending electronic mail messages.

![Mail Tool icons](image)

Figure 1-37  No Mail; New Mail; All Mail Read

Customizing the OpenWindows Environment

You can modify many aspects of the OpenWindows environment, including the fonts used in applications and menus, the distance you need to drag the pointer from a menu to open a submenu, and the window and menu colors. Additionally, if you are left-handed, you may want to remap the keys on the left and right panels of the keyboard for ease of use.

Chapter 17, “Customizing the Solaris Environment,” provides instructions for customizing the OpenWindows environment, including WorkSpace Properties, keyboard and mouse customization.

Hidden Files

Hidden files or “dot” files as they are sometimes called, are distinguished in your file system with a dot (.) in front of them. These files are normally not visible to you in your home directory and you should not change or delete these files unless you have specific knowledge about the file.
Getting Help

There are two kinds of on-line help available: Magnify Help™ for immediate assistance with an item in the OpenWindows environment, such as a menu or window element, and the help handbooks for quick reference on the elements and applications of the OpenWindows environment.

Note – The OpenWindows “more help” facility (Help Viewer) depends on the X11 window server. Therefore, it will not work with a non-OpenWindows server (for example, the MIT X11 server). In particular, clicking the More button within a Magnify Help window, or choosing Help from the Workspace menu fails, and the following error message is displayed on the console:

XView error: NULL pointer passed to xv_set
helpopen: Viewer could not display document: handbooks/...

Magnify Help

When you begin using the Solaris software, you will find that you can choose from a variety of windows and menus. When you need information on a particular window, menu, or object, Magnify Help enables you to get information quickly.

Follow these steps to get on-line help about a window or menu item:

1. Move the pointer to the item (such as a menu) that you want to know about.

2. Press the Help key on the keyboard.
   This is the F1 key on some systems. A help window pops up with information about that item.

Figure 1-38 shows a Magnify Help window.
Most items on the Workspace have associated help handbooks. When an associated handbook exists, a button labeled “More” appears at the bottom of the Magnify Help window. To see more help on that topic, click SELECT on the More button. Figure 1-39 shows a help window with a More button.

A pop-up window is dismissed when you close or quit the application. If you would like to close the Magnify Help window before you quit the application, you can click SELECT on the pushpin in the upper left corner of the Magnify Help window.
No Help

A small pop-up window appears if no Magnify Help is available, stating that there is no help for that item. The pointer jumps to the OK button, and you must click SELECT to continue.

Help Viewer

The help handbooks provide introductory information to guide you through the OpenWindows environment. These are presented in a concise format in the Help Viewer. The “Introducing Your Desktop” handbook is a tutorial that describes basic OpenWindows operations. The other handbooks provide task-oriented steps on individual topics. In addition, there is a handbook that describes how to navigate in the on-line help system. You can browse all of the handbooks in any order you choose.

Desktop Introduction

You can access the introductory handbook, “Introducing Your Desktop” from the Workspace menu, as follows:

1. Move the pointer onto the Workspace and press MENU.
   The Workspace menu appears, as shown in Figure 1-40.

![Workspace Menu](Figure 1-40 Workspace Menu)
2. Drag the pointer to choose Help. When you release the mouse button, the Help Viewer appears displaying a list of handbooks.

3. Double click SELECT on “Introducing Your Desktop”.
Figure 1-41 shows the Help Viewer selection.

![Help Viewer](image)

**Help Handbooks**

- Introducing Your Desktop
- About AnswerBooks
- About Audio Tool
- About Binder
- About Calculator
- About Calendar Manager

*Figure 1-41  Selecting Introducing Your Desktop*

The on-line tutorial, “Introducing Your Desktop,” opens in the Help Viewer, as shown in Figure 1-42.
Help on Help

You can view a description of how to navigate in the help system. Double-click SELECT on the “About Help” icon shown in Figure 1-42. (Alternatively, you can click SELECT once on the icon and then click SELECT on the View menu button.) This option is available from any help handbook. Note also that there is Magnify Help (described in “Magnify Help” on page 45) for each element on the Help Viewer.
Other Handbooks

You can access help handbooks that describe the DeskSet applications and the OpenWindows Workspace by following the steps below. Note, however, that if you are currently displaying the first page of any handbook, you can bypass these steps by double-clicking SELECT on the More Handbooks icon at the bottom of the Help Viewer.

To access the help handbooks at any time:

1. **Move the pointer onto the Workspace and press MENU.**
   The Workspace menu appears.

2. **Drag the pointer to choose Help.**
   When you release the mouse button, the Help Viewer displays the help handbook table of contents that lists handbooks, as shown in Figure 1-43.

![Figure 1-43  Help Viewer](image)
3. **Double-click SELECT on the topic of your choice.**
   The Help Viewer then displays the table of contents for the selected handbook.

**Quick Access to Help Handbooks**

You can accelerate access to a help handbook from any DeskSet application, icon, or menu by pressing Shift and Help (or F1) on your keyboard. As an example, position the pointer over an area of interest, such as the Mail Tool application window, and press Shift-Help. The Help Viewer appears on the Workspace, displaying the appropriate handbook, in this case “About Mail Tool.”

**Note** – On x86 and PowerPC machines, the Help key is the F1 key.

**Navigating through Handbooks**

When you display a particular handbook, you have several choices. You can:

1. Page through the handbook.
2. Double-click SELECT on a topic to access that information quickly.
3. Return to the table of contents of help handbooks.
4. Return to a handbook’s table of contents from within that handbook.

The following sections describe these operations.

**Paging through a Handbook**

The buttons at the top of the Help Viewer enable you to move backward or forward, page by page. Clicking SELECT on the Next Page and Previous Page buttons is equivalent to pressing the PgUp and PgDn buttons on your keyboard. Figure 1-44 shows the help handbook paging buttons.
The Go Back button gives you the option to go back to the last page viewed. Click SELECT on the Go Back button to return to wherever you were last. If you have viewed pages in various parts of a handbook or in different handbooks, you can retrace your steps by choosing Go Back as many times as necessary.

The paging features are also available from the Viewer menu, shown in Figure 1-45.
To use the Viewer menu:

1. **Position the pointer in the Help Viewer window and press MENU.**
   The Viewer Menu appears.

2. **Move the pointer to the pushpin and pin up the Viewer menu if you want to keep the menu up for repeated use.**
   When you release the mouse button, the menu remains.

3. **Click SELECT on a menu item to page down, page up, redisplay (refresh) the window, or go back to your last location.**
   Alternatively, if you have not pinned the menu, just choose a menu item using the MENU mouse button.

**Note** – As with any DeskSet application or pinned menu, you can move the Viewer menu by positioning the pointer on the menu outline, pressing SELECT and dragging the pointer to a new location.

**Using the Handbook Hypertext Links**

The help handbooks can be used in a non-linear fashion. When you see an outlined reference to more information, you can double-click SELECT on that portion of the text to go to the referenced location. The black outlines indicate hypertext links. From the main table of contents for the handbooks, you can access a handbook quickly by double-clicking SELECT on the handbook’s title. Within a given handbook, you can double-click SELECT on one of the links within that book to go to that topic. Figure 1-46 shows the hypertext links in the table of contents for the Calendar Manager help handbook.
Returning to a Handbook’s Table of Contents

When you have chosen a handbook, and selected a topic within that handbook, you can return to that handbook’s table of contents by double-clicking SELECT on the Table of Contents icon (see Figure 1-47) at the bottom of the handbook.

Figure 1-46  Table of Contents with Hypertext Links
Returning to the Main Table of Contents

To return to the main table of contents for all the help handbooks, navigate to the first page of the current handbook and double-click SELECT on the More Handbooks icon at the bottom of a page (shown in Figure 1-46).

Closing the Help Viewer

You can close the Help Viewer to an icon until you need it next. To close Help Viewer, click SELECT on the abbreviated menu button in the upper left corner of any handbook.

Figure 1-48 shows the Viewer icon.

Double-click SELECT on the Viewer icon when you want to open it again.
Exiting the Help Viewer

You can exit the Help Viewer from any location by choosing Quit from the Window menu.

Double-clicking SELECT on the Exit icon at the bottom of the page of Introducing Your Desktop handbook displays instructions for quitting the tutorial handbooks. Figure 1-49 shows the Exit icon.

![Exit Icon](image)

*Figure 1-49  The Exit Icon in Introducing Your Desktop*

On-line Documentation: AnswerBooks

As you use your system and its software, you can browse, search, bookmark, and print from manuals right on your screen in your own on-line Library. Your Library may contain one or more AnswerBooks, or collections of documents covering many topics.

For more information about AnswerBooks, see Chapter 19, “Using the AnswerBook Software.”

**Note** – To give you access to AnswerBooks, your administrator has to install and configure them for your use.

♦ To open your on-line Library, choose
  Workspace➤Programs➤AnswerBook.
File Manager

File Manager provides a graphical display of the UNIX file system, using icons that represent directories (folders), files (documents), and applications.

You can use File Manager to find, copy, move, open, close, delete, undelete, create, and print files. You can start applications from File Manager, and reorganize your file system by moving or copying files between folders. You can also use File Manager to link files and to transfer files to other machines.

In addition, the icons representing individual parts of the file system can be dragged out of the File Manager window onto the workspace or onto other DeskSet application icons or windows.

Note – Solaris supports SPARC, x86, and PowerPC-based machines, whose keyboards differ. Consequently, some keyboard equivalents of commands found in OpenWindows menus differ, according to keyboard.

For most keyboard equivalents, Solaris supports a Meta key combination that can be used on both platforms. See Chapter 1, “Introduction to the Solaris User Environment” for a list of command functions and their various keyboard equivalents.
File Manager Icon

The primary icon for File Manager looks like a file folder. The name of the current directory is displayed beneath the folder, as shown in Figure 2-1.

![File Manager Icon](image)

*Figure 2-1  File Manager Icon*

File Manager Base Windows

The primary File Manager base window displays your file system and allows you to manipulate it. The secondary base window is a Wastebasket that you can use to remove files from your file system. When you start File Manager, the Wastebasket window is normally started and displayed as an icon. The Wastebasket is described in the section “Using the Wastebasket” on page 91.

The primary File Manager window, shown in Figure 2-2, provides a set of controls that you can use to manipulate your file system. The window has a path pane that displays the file system hierarchy and a scrollable file pane that displays the contents of the open folder in the path. You can open many windows from within File Manager, and File Manager works the same way within each window.
The files in your file system, by default, are represented by three kinds of icons, which are similar to application icons on the workspace. Directories are displayed as folders. Files such as documents, graphic files, and spreadsheet files are displayed as dog-eared sheets of paper. Executable files (applications) are displayed as an application icon. Figure 2-3 shows these three file type icons.

*Figure 2-3  Three Types of File Icons*
File Manager checks the Binder database for information bound to each file being operated on. Every file displayed can have its own file type. Each file type can have its own icon, open method, and print method stored in the Binder database. When File Manager displays a folder, it gets the information from the Binder database on how to display and operate on each file.

When a file is not bound to a specific icon, its generic icon is displayed. In the example shown in Figure 2-4, the files are bound to different application types.

![Figure 2-4  Data File Icons that also Show the Application Type](image)

You can create your own images for files using the Icon Editor, and bind them to the File Manager data file icons using the Binder. See the chapters “Icon Editor” on page 421 and “Binder” on page 441 for more information.
Selecting File Manager Icons

In order to operate on File Manager icons, you first need to select them.

You select a File Manager folder icon in the path pane by moving the pointer onto it and clicking SELECT.

You select a single icon or group of icons in the file pane by clicking SELECT on the first icon and clicking ADJUST on each additional icon that you want to include in a group. Selected icons are highlighted. Exclude an icon by clicking ADJUST on an icon that is already selected.

You can select an adjacent group of icons by pressing SELECT to define one corner of a rectangle surrounding the group of files, dragging the pointer to the opposite corner, and releasing SELECT. You can select an additional group of icons using the same method with the ADJUST mouse button.

Double-Click Accelerators

You can double-click SELECT on any individual icon to open it. Double-clicking SELECT on any folder in the path pane or the file pane opens it and displays its contents in the file pane. Double-clicking SELECT on a data file starts the application for that data file and usually displays its data. Double-clicking SELECT on an application icon starts the application.

Panning Through the Tree and File Panes

A feature provided by File Manager is the ability to pan through file panes. This lets you scroll through the panes without using the scrollbars. Panning is like “gluing” the contents of a pane to the current pointer, so that when you move the pointer, the entire contents of the pane moves with it.

Note – On x86 and PowerPC machines, Meta is Ctrl-Alt.

You initiate panning by following these steps:

1. Move the pointer to the place where you want to start panning.
2. Press the Meta key on the keyboard, and then press SELECT.

When the pointer changes to the panning pointer (a curved arrow pointing down), release the Meta key.
3. Drag the pointer to a new location within the pane, and release SELECT. The contents of the pane move along with the pointer. Repeat these steps if necessary to reach the desired location.

Control Area Menus

The control area has four menu buttons: File, View, Edit, and Go To; Go To has a text field. This section shows each of these controls and provides a brief introduction to each of the items. Figure 2-5 shows the menu buttons within the File Manager control area.

File Menu

The File menu provides choices that you can use to perform filing functions.

- Use Open to open selected folders and files. Open is inactive unless you have made a selection in the file pane or path pane.
- Use Open in Editor to open the file in the Text Editor.
- Use Create Document to create a new document.
- Use Create Folder to create a new folder.
- Use Duplicate to create another version of the selected item(s).
- Use Print One to print your selection to your default printer. Print is inactive unless you have made a selection in the file pane.
- Use Print to print selected files using your own print method and specified printer. You can select the number of copies to print. Print is inactive unless you have made a selection in the file pane.
Use Find to display a pop-up window that you can use to find files. See “Using the Find Pop-up Window” on page 89 for more information.

Use Information to find out information about your file. See “File and Folder Information” on page 96 for more information.

Use Remote Copy to open a pop-up window for remote transfers. See “Transferring Files From Your System to Another” on page 85 for more information.

Use Custom Commands to run your own customized commands, or to pop-up a UNIX shell that you use like any other Shell Tool. See “Customizing Your File Manager” on page 98 for information.

Use Check for Floppy to bring up window, if floppy has been inserted.

Use Quit File Manager to quit the File Manager. This does preserve the way you had your icons set up in the window.

Note – The following two items are only visible if you are using a floppy disk.

Use Format Floppy to format a floppy in your disk drive. For more information, see “Using Floppy and CD Media” on page 116.

Use Rename Floppy to rename the floppy inserted into your disk drive. For more information, see “Renaming a Floppy Disk” on page 123.

View Menu

From the Base Window, the View button has a menu with choices for different ways to view the file system. These are Open Folder View, Large Icon View, Small Icon View, Icon By Name, Icon By Type, List by Name, List by Type, List by Size, List by Date, and Cleanup Selection. Refer to “Folder View” on page 65 for information on the Folder View. Otherwise, use these display options to choose how the contents of the file pane are displayed and sorted:

- Use Large Icon View for viewing icons at regular size. You can move these icons around in the file pane.
- Use Small Icon View for viewing icons at reduced size. You can move these icons around in the file pane.
- Use Icon by Name to sort the large icons alphabetically by name.
- Use Icon by Type to sort the icons in alphabetical groups by file type, with folders first, followed by files, then by applications.
• As a listing, to show you more information about each individual file.
  • Use List by Name to sort the files alphabetically.
  • Use List by Type to sort the files in alphabetical groups by file type, with folders first, followed by files, then by applications.
  • Use List by Size to sort the files by size, largest to smallest.
  • Use List by Date to sort the files from newest to oldest.
  • Use Cleanup Icons for putting all icon(s) in order to the nearest grid point. If icon(s) are selected, use Cleanup Selection for putting selections in order to nearest grid point. Each grid point is determined by the width of the largest name.

**Edit Menu**

Edit has a menu with options for editing.
  • Use Select All to select all the files in the file pane.
  • Use Cut to remove selected icons from a folder and place them on the clipboard. Cut is inactive unless you have made a selection in the File pane.
  • Use Copy to put a copy of selected icons on the clipboard. Copy is inactive unless you have made a selection in the File pane.
  • Use Link to link files together. See “Linking Files” on page 94.
  • Use Paste to paste the contents of the clipboard at the next available grid point in File Manager. Paste is inactive unless something is on the clipboard.
  • Use Delete/Destroy to remove selected file names from a folder, and place them in the Wastebasket or really delete them, depending on the File Manager Properties setting. See “Using the Wastebasket” on page 91 for information about the Wastebasket.
  • Use Properties to customize your File Manager. See “Customizing Your File Manager” on page 98 for information.

**Go To Menu and Text Field**

The Go To menu has choices (that can be set by you in properties) that allow you to quickly go back to your home directory or to other directories that you have recently accessed. You can also type the path name of a folder you want to go to in the Go To text field. See “Using the Go To Text Field and Menu” on page 87 for more information.
Folder View

Use Folder View to look at your folder hierarchy. The Folder View opens a separate window that displays only folders and shows how folders are stored in the hierarchy. You can open each of your folders into a separate window by selecting the folder and:

♦ Selecting View ➤Open Folder View.

Figure 2-6 shows a Folder View.

The hierarchical Folder View (tree structure) is another way of showing the UNIX file system. The analogy between the parts of a tree and the parts of the file system is often used when describing the UNIX file system. The Folder View can show all parts of the file system. Alternatively, you can use the Folder View to start at any directory or folder in the file system.
Root is the top directory in the file system. Under the root are various branches. For example, Figure 2-7 shows root and the branches that start with the directories /, home.

Along with the tree analogy, there is a parent/child analogy. The root directory is the parent directory. A subdirectory is also a parent directory when there are one or more subdirectories below it. Each subdirectory is a child of the parent directory that is above it.

The File menu from the Folder View has the following options: Open (Opens the children of the selected folder), Open Folder Window (Brings up the File Manager folder pane), Find, Information, Remote Copy, and Custom Commands.

The View menu from the Folder View has the following options:

• Use Show Horizontal/Vertical to change the view orientation from horizontal to vertical or visa versa.
• Use Show All Sub Folders to show all folders below the selected folder.
• Use Hide Sub Folders to “hide” all sub folders below the selection.
• Use Start Folder View Here to begin showing the folder view from the selected folder.
• Use Add Parent the parent of the folder selected folder.

Go To can be used the same way as described in “Go To Menu and Text Field” on page 64.

Folder View Options

The Folder View contains commands that you can use to “prune” the Folder (or tree) view so that it contains branches of the tree that are useful to you and hides other folders that you may not need to access.

If you frequently move or copy files between folders, you may find that using the Folder View allows you to perform more operations using drag and drop, since more folders can be displayed in the Folder View.
When you open the Folder View window, you can choose the following options:

- Hide Sub Folders
- Show All Sub Folders
- Begin Tree Here
- Add Tree’s Parent

Subfolders are folders that are farther down the tree than the current folder. Figure 2-7 shows a Folder View that contains most of the folders from the root directory downward.

![Figure 2-7 Example of a Folder View](image)

The following examples show a series of progressions, using each of the view modification commands from the Folder View.
Clicking SELECT on the home folder and choosing Hide Subfolders from the Folder View results in the display shown in Figure 2-8. Compare that display with the one shown in Figure 2-7.

![Figure 2-8 Example of Hiding Subfolders](image)

Choosing Show Subfolders from the (Folder View) View menu produces the display shown in Figure 2-9.
With the fish folder selected, choosing Begin Tree Here from the View menu changes the display as shown in Figure 2-10.
Choosing Add Tree’s Parent from the Folder View adds one folder farther up the path, and its subfolders, as shown in Figure 2-11.

![Figure 2-11 Example of Adding a Parent Folder](image)

**Path Pane**

The path pane shows your current location in your file system.

**Parts of the Path and Folder View**

The path displayed in the File Manager window shows only the folders for the directory and subdirectories that lead to the current folder, which is the folder that is open. Any folders below it in the tree are subfolders. An example of a path is given in the window in Figure 2-12, which shows the path for /root/hightide/egret.
When you start File Manager for the first time, it displays the path of the directory from which you started it. The next time you start File Manager, it remembers your last location before quitting, and you see the things the way you left them. If you choose File Manager from the Programs submenu, it displays the path for your home directory. The last folder in the chain is open, and its contents are displayed in the file pane, as shown in Figure 2-12.

Use the Open Folder item on the Path pane pop-up menu to open a selected folder.

♦ Display the Path pane pop-up menu by moving the pointer on the background of the Path pane and pressing MENU.

Once a folder has been selected in the Path Pane, all of the Base window commands are available to you except the following: Duplicate, Print One, Print, Format Disk, Rename Disk.

Path that is Displayed

Figure 2-12  A home Directory in the Path Pane
Figure 2-13 Example of a Horizontal Folder View (Tree Structure)

As you move around from folder to folder by double-clicking SELECT to open each one, Folder View expands to show subfolders and rearranges the other branches of the file system tree.

After you open a folder, an open folder icon indicates that the folder has been opened. For example, in Figure 2-13, the folder labelled home has been opened.

You can expand or reduce the number of folders in the Folder View by choosing View items from the Folder View menu: You can toggle between showing Horizontal and Vertical views, Show All Sub Folders, Hide Sub Folders, Start Folder View, and Add (the folder’s) Parent. Once you have chosen one of these items from the menu, File Manager remembers it. When you choose Folder View again, the view displayed is the last format that you chose for the Folder View. See “Customizing Your File Manager” on page 98 for examples of these other kinds of displays.
**File Pane**

The file pane displays the contents of the open folder in the path pane. When you first start File Manager, the file pane displays icons with names beneath them, as shown in Figure 2-14.

![Figure 2-14 Icons in the File Pane](image)

**File Pane Pop-up Menu**

To use the File Pane pop-up menu:

♦ Press MENU from within the File Pane.
Depending on whether you have a folder or file selected, all or some of the following options are available from this menu: Select All, Cut, Copy, Link, Paste, Delete, Print One, Print, Cleanup (Selection). For information on Cut, Copy, Paste and Delete refer to File Menu on page 62. For information on Link, refer to “Linking Files” on page 94. For information on Cleanup Selection, refer to “View Menu” on page 63.

Alternative Display Options

You can change the way icons are displayed in the file pane by choosing options from the View menu and you can change the default displays from the Properties window. See “Current Folder Settings” on page 108 or “New Folder Defaults” on page 101 for more information.

Large Icon View

Choosing Large Icon View from the View menu displays a list of standard-size icons with the name of the icon centered below it as shown in Figure 2-14. When application images are specified by the Binder, those images are displayed. You can move these icons around.

Note – Sorting large icons looses all position information for the large icon view.

Small Icon View

Choosing Small Icon View from the View menu displays a list of small sized icons with a name centered below it. The small icon show you whether each file is a folder, data file, or an executable program file. The small icons are shown in Figure 2-15.

Note – Small icons do not display custom icon images for files (as displayed in the Icon View modes).
Icon By Name

Choose Icon By Name if you want to view your icons as large icons ordered alphabetically.

Icon By Type

Choose Icon By Type if you have several different types of icons in one folder. The order of icons listed is folder, file (or document), and application or program.

List By Name

Choosing the List By Name option shows a list of icons and file names, as shown in Figure 2-16. You can select and operate on small icons in the same way as for standard-sized icons. These are listed as one entry per line. The default is icon, name, size, and date.

Figure 2-16  Example of a List Display

When using the View menu, you can choose to display additional information about each file such as the Date, Size, Owner, Group, Links, and Permissions. When displaying any of these file attributes, the display changes to show one item per line. For complete information on file information (or properties), refer to “File and Folder Information” on page 96. You choose the information
to display by changing the default settings from the Customize View window. See “New Folder Defaults” on page 101 or “Current Folder Settings” on page 108 for more information.

**List By Size**

Choose List By Size if you want to view your files from the largest file (in KB) to the smallest file.

**List By Date**

Choose List By Date if you want to view your files from the newest (date last modified) to the oldest date.

**Opening Files**

When you select and open a data file, the appropriate application is started and the data of the opened file is displayed in the application’s window. When you select and open an application or executable file, the application is started. Executable shell scripts display a Notice asking you if you want to start the script in a Shell Tool. You can change your properties to have your folders open into the same window or separate windows. For complete information on this refer to “General Defaults” on page 100.

From the file pane, you can open folders, files, and applications in the following ways:

- Dragging and dropping selected folders onto the workspace.
- Dragging and dropping selected files or applications onto the workspace, then using the menu or double-clicking SELECT on the icon or open window.
- Choose File ➤ Open or double-click SELECT on a data file or application icon.

**Note** – When you open a file or an application from File Manager, you cannot close or quit it by dragging it back onto File Manager. You quit any window or icon on the workspace by choosing Quit from the Window menu.
Creating New Files and Folders

You can create new files and folders in the file pane, which puts them in the folder where they are created.

To create a new file or folder, follow the steps below:

1. Check to be sure you are in the folder where you want to create the new file or folder.
   If necessary, select another folder and click Open.

2. Choose either Create Document or Create Folder from the File menu.
   An empty file called *NewDocument* (for a file) or *NewFolder* (for a folder) is created in the file pane. Subsequent new documents or folders are numbered in sequence. For example, if you create a file called *NewDocument* and a file with this name already exists, the new file will be called *NewDocument.1*. The next new document will be called *NewDocument.2*, and so forth. The name of the new document or folder is highlighted and underlined when it is first displayed, which means it is ready to be renamed. Figure 2-17 shows a new folder in the file pane.

![Figure 2-17  New Folder in the File Pane](image)
Naming a Document or Folder

When the name of a file or folder is highlighted and underlined, the name is an editable text field. You can change the name of any folder or file by clicking SELECT on its name to select it and display an editable text field. You can edit the contents of this text field in the same way you edit any other text field. When you have changed the file name, press Return or click SELECT on the background of the file pane. You can also change the name of a file using the Information popup window. See “File and Folder Information” on page 96 for more information.

Moving and Copying Files

You can move and copy icons that are displayed in the File pane using cut, copy, paste, choosing Duplicate from the File menu, or using the drag and drop operation.

Using Cut, Copy, Paste

You can move or copy files within File Manager using the Cut/Copy/Paste commands. Cut/Copy/Paste commands are provided on the Edit menu, the File Pane pop-up menu, and as function keys on the keyboard. Some keyboards will have Cut, Copy, and Paste keys; otherwise, you can use the keyboard equivalents described in Chapter 1, “Introduction to the Solaris User Environment.”

When you cut material, it is not deleted. It is put on a clipboard, where it is stored temporarily. Only one item or group of items is stored on the clipboard at a time.

Note – If you do another cut without using what is on the clipboard, the previous information is lost.

Moving or Copying Files and Folders Using Cut and Paste

To move or copy folders and files using the clipboard, follow these steps:
1. Select the file or files you want to copy or move.
   The icon is selected. If you want to move a group of files or folders, click ADJUST on individual icons to add them to the group. If the icon is already selected, clicking ADJUST deselects it, removing it from the group.

2. Choose Cut or Copy from the Edit menu.
   Use Cut, or Copy to copy a file. The file or files are moved or copied to the clipboard.
   If your keyboard has Cut and Copy keys, you can use them, or Meta-x (Cut) and Meta-c (Copy). (On x86 and PowerPC systems, Meta is Control-Alt.)
   An instruction message is displayed in the footer, as shown in Figure 2-18.

   ![Messages when Files are Cut to the Clipboard](image)

   Figure 2-18  Messages when Files are Cut to the Clipboard

3. Open the folder you want to receive the files.

4. Choose Paste from the Edit menu or the File Pane pop-up menu.
   If your keyboard has a Paste key, you can use that. You may also use Meta-v. (On x86 and PowerPC systems, Meta is Control-Alt.)

Using Drag and Drop in File Manager

You can use the drag and drop operation to copy and move files from the Folder View, path pane, or file pane to the following destinations:

- Any icon onto any folder icon in pathpane, file pane, or folder view
- Onto the background of any open File Manager file pane
- Onto the Wastebasket icon or window
- Onto the any folder icon on the workspace

You can use drag and drop between tools such as:

- Onto the Mail Tool Compose icon or window (attachment pane)
- Onto the Text Editor icon, text pane, or drop target
- Onto the icon or drop target of Print Tool, Tape Tool, Icon Editor, Snapshot, Audio Tool, or any other application supporting the drag and drop.
Moving or Copying Files and Folders Using Drag and Drop

To move or copy a file or folder into another folder within File Manager when both the source and destination icons are visible, follow these steps:

1. Select the file or folders that you want to move or copy.

2. To move, press SELECT on a selected file and drag the pointer onto the destination folder. To copy, press the Control key together with SELECT on a selected file, and drag the pointer onto the destination folder. The tip of the arrow defines the destination of the move operation.

3. Release SELECT.
   The file or folder is moved or copied to the new folder.

Dragging and Dropping a Document Icon onto the Workspace

You can drag and drop data file icons from File Manager onto the Workspace. When you drop the icon onto the workspace, it starts the appropriate application, and opens the file.

Dragging and Dropping a Folder onto the Workspace

You can drag and drop individual folders from File Manager onto the Workspace. When you drop the folder onto the workspace, it is opened, and the contents of the folder are displayed in a new window. If you switch frequently between directories, you can use this feature to display the contents of more than one folder at a time.

To drag and drop a folder onto the workspace, follow these steps:

1. Click SELECT on a folder to select it.

2. Press SELECT and drag the folder onto the workspace background.

3. Release SELECT.
   The window is opened, and the contents displayed, as shown in the example in Figure 2-19.
4. Close folder to an icon on the WorkSpace.

**Dragging and Dropping Between Tools**

You can use drag and drop in the following ways between tools.

**Dragging and Dropping a File onto another Application**

You can drag and drop a file onto another application outside of File Manager, regardless of whether the application is displayed as an icon or as an open window. If you drop a file with an inappropriate format onto a window or icon, the move or copy is not performed.

When you drop a file onto the drag and drop target or icon of an application, the file is loaded into the application. Follow these steps to load a file into another application:

1. In File Manager, click SELECT on the file icon that you want to load.
2. Drag the file onto the application icon or drag and drop target, and release SELECT.
   The file is loaded into the application. Note that when you drag and drop a file to an application outside of File Manager, the file is always copied. The original file remains in File Manager. For example, if you move a file from File Manager to Print Tool, the original file is not deleted after it is printed.

   If the application cannot accept the file format, the file is not loaded. When you drop an icon of an incompatible file type onto an open window, or when you drop an icon onto an inappropriate location, an error message is displayed in the footer of the destination window.

Dragging and Dropping Mail onto File Manager

When you receive a mail message, you can drag and drop individual mail attachments onto File Manager, or you can drag and drop the entire mail message onto File Manager. See “Mail Tool Attachments” on page 173 for information about mail attachments.

Copying Mail Attachments onto File Manager

When you receive a mail message that contains attachments, you can access the attachments by dragging and dropping any or all of them onto File Manager. The attachment files are then available for you to use just like any other File Manager file. You can drag and drop the attachments onto File Manager using the following steps:

1. Open both File Manager and Mail Tool.

2. Open the folder window in File Manager where you want to put the attachment(s).

3. In the Mail Tool application, click SELECT on the attachment that you want to move or copy. Click ADJUST on any additional attachments that you want to include.

4. Press SELECT and drag the pointer.
   A small glyph of the type of file being moved is displayed, as shown in Figure 2-20.
5. **Drag the pointer onto the File Manager file pane and release SELECT.**

The attachment appears in File Manager with its original name and data type.

**Copying Entire Mail Messages onto File Manager**

You can copy an entire mail message to File Manager, including all attachments. The message and attachments are then combined into one file. If you drag and drop a mail message onto File Manager that doesn’t have any attachments, the message is saved as a simple text file. To copy an entire mail message to File Manager, follow these steps:

1. **Open both File Manager and Mail Tool.**
2. Open the folder window in File Manager where you want to put the mail message(s).

3. In the Mail Tool application, click SELECT on the header of the mail message to be copied or moved.

4. Press SELECT and drag the pointer.
   A small mail file icon is displayed, as shown in Figure 2-21. You can release the Control key any time after the envelope is displayed.

![Figure 2-21 Dragging a Mail Message onto File Manager](image)

5. Drag the pointer onto the File Manager file pane and release SELECT.
   The first time you drag a mail message onto File Manager, the mail message appears in File Manager as a file called mailfile. If that file already exists, the mail message appears as mailfile0. If mailfile and mailfile0 already exist, the file is named mailfile1, and so forth.

   You can also drag and drop a mail message onto a mail file icon in File Manager to append the new message to an existing mail file.
Transferring Files From Your System to Another

To transfer files from your system to another system, follow these steps:

1. Display the Remote Copy popup by choosing Remote Copy from the File menu.
   If you have selected files, your host name (workstation or machine name) is displayed in the Source Machine Name text field, and the file names are displayed in the Pathname text field, as shown in Figure 2-22.

   **Figure 2-22  Remote Copy Pop-up Window**

   Source
   
   Where does the file you want to copy reside?
   
   **Machine Name:** river
   
   What is the pathname of the file to copy?
   
   **Pathname:** /high/dep/egret/Fish

   Destination
   
   Where do you want the file copied?
   
   **Machine Name:** celtic
   
   What is the final path name of the copied file?
   
   **Pathname:** /tmp

   [Copy File]  [Cancel]

2. Type the destination machine name in the Machine Name text field under Destination.

3. Type the pathname in the Path Name text field under Destination.
4. Click SELECT on Copy File to initiate the transfer.
   While the transfer is in process, the Copy button displays the standard busy pattern.

To transfer files from another system to your system, you must know the path and file name of the files you want to transfer. To transfer a file from a remote machine to your machine, follow these steps:

1. Type the name of the remote machine in the Source Machine text field.

2. Type the full path and file name of the file you want to transfer under Source in the Path Name text field.

3. Leave the Destination text fields blank, or type your machine name.

4. Type the path and file name for the file under Destination in the Path Name text field.

5. Click SELECT Copy File to start the transfer.
   The Copy button is dimmed until the transfer is complete. If there are problems with the transfer, error messages will appear in the footer of the current File Manager window.

6. Click SELECT on the Copy button to start the transfer.
   The Copy button is dimmed until the transfer is complete. If there are problems with the transfer, error messages appear in a pop-up window that explains the problem.

**Printing Files**

You can print files from File Manager in three ways:

- Select files in the file pane and drag and drop them onto the Print Tool application. Files are printed using the default print instructions bound to the icon in the Binder database. See Chapter 10, “Print Tool” for more information about using the Print Tool and Chapter 16, “Binder” for information about print bindings.

- Select files in the file pane and choose Print (or Print One) from the File menu or the File Pane pop-up menu. The Print (or Print One) item is inactive unless files are selected. Print One prints files using the print method in the Binder database, if it exists. Otherwise, Print prints files using the default print method from the File Manager Properties window. See
“Customizing Your File Manager” on page 98 for information about tool properties and the chapter Chapter 16, “Binder” for information about print bindings.

• Highlight the Print (or Print One) item from the File menu or the File Pane pop-up menu, drag right to display the Print submenu, and choose Print to display the Print Options window. This is useful when you want to print a file using a method other than the default print method, or if you want to print a file to a different printer. Figure 2-23 shows the Print window with an alternate printer specified in the text field. Specify $FILE$ where you want the file name to be in your print script.

![Print Popup Window](image)

**Figure 2-23**  Print Popup Window

**Finding Files and Folders**

File Manager provides three ways to locate folders and files:

• Go To text field and button
• Pattern matching with a string typed in the File Pane
• Find pop-up window

This section describes how to use these methods to find folders and files.

**Using the Go To Text Field and Menu**

The Go To menu includes a list of the folders that you have accessed since you started File Manager. Your home folder is the default item on this menu. The rest of the items on the menu show (a default of) ten of your most recently accessed folders. You can make the amount of items greater or smaller. You can change back to any of these folders by choosing the path to the folder from the Go To menu. You can also add your own items to the menu. For information on how to make these changes, refer to “Go To Menu Defaults” on page 109.
When you know the path of the folder you want to open or the path and file name of a file that you want to select, you can type the path or the path and file name in the Go To text field. Then either press Return or SELECT the Go To button.

When a path is typed, the folder specified is opened and its contents are displayed in the file pane. When a path and file name are typed, the specified folder is opened, its contents are displayed in the file pane, and the file is located, scrolled into view, and selected.

**Using Pattern Matching to Find Files**

You can use wildcard characters to select groups of related files in the currently displayed file pane by typing a pattern-matching sequence in the Go To text field or with the pointer anywhere in the File Pane.

**Pattern Matching in the Go To Text Field**

The star symbol (*) can be used to match any string, so typing *.rs in the Go To text field and either pressing Return or clicking SELECT on the Go To button will select all files ending in .rs. Figure 2-24 shows an example of a file pane with all *.rs files.

![File Manager: /hightide/e](image)

Contains 80 items

- basewindows
- cmappinitialsize.rs
- cmd
- cmaccesslist.rs
- cmbrowser2.rs
- cmdbybo

*Figure 2-24 Using Pattern Matching with Go To to Select Related Files*
Pattern Matching in the File Pane

You can also use pattern matching to find files by moving the pointer into the File Pane and typing the pattern that you want to match.

The pattern you type is displayed in the footer. As the pattern is typed, all the files starting with the current pattern are selected. For example, when you type c, the pattern is c*, and all the files starting with c are selected. If you then type h, the pattern becomes ch*, and only the files starting with ch are selected. If you then type a, the pattern becomes cha*, and the files starting with cha are selected, and so on. To finish the pattern, press Return. If there are no files that match the pattern, an error message appears in the footer.

Using the Find Pop-up Window

When you do not know or cannot remember the specific location of a folder or file, or when you want to locate a group of files according to specific criteria, use the Find pop-up window. To display the Find window, choose Find from the File menu. The Find pop-up window is displayed, as shown in Figure 2-25.
Finding Files With the Find Window

To find a specific file or group of files, you can fill in some or all of the text fields, according to the type of search you want to perform.

- Use the File Type setting to specify whether you want to search only folders, only files, only applications, only executable files or a combination. The mini-icons displayed in the File Type choice item are the same as the mini-icons used in the List by... displays, as shown in Figure 2-15.

- Use the Find files in and below folders text field to specify where in your file system you want to start the search. The search begins in the folder you specify in this text field, and includes all subfolders in that path.

- Use the Name text field to specify the file name or pattern you want to match. Use Included or Excluded to either include or exclude the pattern from the search.

- Use the Owner text field when you want to search for files by owner, or exclude a particular owner from the search.

- Use the Modified After or Modified Before text field, or both, to specify a time frame for the search. You must specify, as a minimum, the month and day for each of these text fields.

- Use the Search Files Containing String field when you want to find files with specific contents. For example, to find all files in which the DeskSet product is specifically named, you would type DeskSet in the text field. If you click SELECT to turn on the Ignore Case setting, all files with the word “DeskSet” will be listed in the scrolling list, regardless of how the word is capitalized.

When you have filled in the text fields, click SELECT on the Find button to start the search. Once you start a search, the Stop button is activated. You can stop the search at any time by clicking SELECT on the Stop button.

When the search is completed, all files that match the pattern are displayed in the scrolling list at the bottom of the Find window. If you have more than one field filled out on the Find window, a file must match the information in all of these fields for it be listed. Figure 2-26 shows an example of a file content pattern matching search. File Manager found 37 files containing the specified string. (Seven of the files found are shown in the figure, the rest are scrolled out of view.)
You can select and open one file at a time from the Find window scrolling list. To select a file, move the pointer onto the line and click SELECT. The line is highlighted, and the Open button is activated. To open the highlighted file, click SELECT on the Open button.

**Using the Wastebasket**

The Wastebasket is a temporary storage area for files that you want to discard and that you probably will delete from your file system. When you start File Manager, the Wastebasket is automatically created and displayed as an icon. You can move the Wastebasket anywhere you want on the workspace.

When the Wastebasket is empty, the icon shows an empty wastebasket. After you have put a file in the Wastebasket, the Wastebasket icon’s appearance is changed to remind you that at least one file is there. Figure 2-27 shows the Wastebasket icon when empty and when there are one or more files in it.
You can move folders and files to the Wastebasket by selecting them and dragging and dropping them onto the Wastebasket icon or window, or by choosing Delete from the Edit menu.

Files that you put in the Wastebasket are stored in a .wastebasket folder in your home directory.

You can view the contents of the Wastebasket by opening the Wastebasket icon. A window is displayed with a scrolling pane that shows you the files you have moved to the Wastebasket. Figure 2-28 shows an example of the Wastebasket window.

The Wastebasket window has View, Edit, and Empty Waste functions available. To access the Wastebasket pop-up menu, move the pointer anywhere in the Wastebasket window and press MENU. You can use the Wastebasket pop-up menu to do the following:
• Use Empty Wastebasket to delete all the files in the Wastebasket. This option is inactive if the Wastebasket is already empty.

**Caution** – You cannot recover any files that you delete/destroy with Empty Waste or Empty Wastebasket on the File pane menu.

• Use Select All to select and highlight all the files in the Wastebasket. This option is inactive if the Wastebasket is empty.

• Use Destroy to delete all the selected files in the Wastebasket. This option is inactive if no files in the Wastebasket are selected.

• Use Undelete to restore the selected files in the Wastebasket. The files are automatically moved back to their original locations. This option is inactive if the Wastebasket is empty.

If you quit File Manager and restart it, the new File Manager will not remember the original locations of files in the Wastebasket. If you choose Undelete in this case, File Manager sends the message *Original location for <file> not saved -- please restore manually.* See “Moving or Copying Files and Folders Using Cut and Paste” on page 78 or “Moving or Copying Files and Folders Using Drag and Drop” on page 80 for information about how to move the file out of the Wastebasket and back into the desired folder.

• Use Cut to move the selected files from the Wastebasket to the clipboard. This option is inactive if no files in the Wastebasket are selected.

• Use Copy to copy the selected files from the Wastebasket to the clipboard. This option is inactive if no files in the Wastebasket are selected.

• Use Paste to move the contents of the clipboard into the Wastebasket.

**Creating a New Wastebasket**

If you quit the Wastebasket window, you can create a new one by following these steps:

1. **Make sure the File Manager Tool General Defaults Properties Edit Menu item is “Delete”**.
   The “Delete” option is the default setting. See “Customizing Your File Manager” on page 98 for information about setting the File Manager Tool Properties.
2. In File Manager, select a folder or file that you want to put into the Wastebasket.

3. Choose Delete from the Edit menu or the File Pane pop-up menu.
   A new Wastebasket is created to contain the files you selected.

**Linking Files**

A link is a symbolic connection or pointer to a single file that allows you to access it from more than one directory. You can set up a link to a file in a restricted directory, allowing access to the file without providing access to the directory.

The Link option on the Edit menu runs the standard `ln` operating system command. A symbolic link is created when you link files between directories. When you link files in the same directory, a symbolic link is created. Refer to the `man` page for `ln` for a complete description.

For example, if you have a file named `Marlin` in a folder called `Fish`, you can link it to another folder called `SwordFish`. Once the link is established, you can access `Marlin` from either folder. `Marlin` has not been copied into `SwordFish`; it has been linked with a pointer from one folder to another.

Any editing changes you make to a file with links are reflected in all of the folders, since there is really only one file, not multiple copies of it.

To use a linked file, you can drag and drop its icon from any folder that the file is linked to.

**Creating a Link**

To link files to folders, follow these steps:

1. Select the file (or files) you want to link.

2. Choose Link from the Edit menu or popup file pane menu.
   An instructional message is displayed in the footer, as shown in Figure 2-29, telling you how to proceed.

   ![Figure 2-29 Instruction Message after a Link is Initiated](image-url)
3. Open the folder you want to link the file to.

4. Choose Paste from the Edit menu or the File Pane pop-up menu, or press the Paste key on the keyboard.
   The file icon is displayed in the file pane and a message confirming the link is displayed in the File Manager footer.

Link information is displayed as part of the properties of the file, as shown in the example in Figure 2-30. See “File and Folder Information” on page 96 for more information about file properties.

![Figure 2-30](image-url)  
**Figure 2-30**  Links Displayed as Part of the File Type Properties.

**Removing a Link**

You can remove a link by selecting the file and choosing Delete from the Edit menu or the File Pane menu. Removing a link does not remove the original file.

If you remove the original file without also deleting the link, the icon for the link changes to display a broken chain. In the example shown in Figure 2-31, the original file named *aliases* has been deleted, but the linked file remains.

![Figure 2-31](image-url)  
**Figure 2-31**  A Broken Link
File and Folder Information

Each folder, file and application in your file system has the following information (also known as properties) associated with it:

- Name
- Ownership
- Group
- Permissions (read, write, execute)

You can display these properties for an individual selected file choosing Information from the File menu. You can change these properties if you own the file and have the correct permissions set.

The File Information window also displays the following about each file:

- File Size in bytes
- File Type
- Date the file was last modified
- Date the file was last accessed
- File Permissions and Information—Owner, Group, World, Owner name, and Group name

These (more advanced) topics can be accessed by pressing the plus button at the lower right corner of the Information window. Once the information is displayed, you can “hide” it by pressing the minus sign at the lower right corner.

- Method to open file
- Method to print file
- Mount point
- Mounted from
- Free space

Figure 2-32 shows an example of a File Properties window.
Figure 2-32  Example of a File Properties Window

To display the Information window, select a file or a group of files and choose Information from the File menu.

If the Information window is already showing when you select a new file, the File Properties information is updated to reflect the properties of the new file.

If you select more than one file, the Information window shows those properties that the selected files can share. The document names and specific document information are not displayed. You can change the permissions for the group of selected files to be the same by clicking SELECT on the Permissions check boxes and then clicking SELECT on the Apply button.
Changing Properties and Permissions

Every file and directory has a security system organized around permissions. Permissions determine which users can read a file, write to (or change) it, or execute it (applications are executed). You must own the file to change its permissions. Users are categorized as owner, group, and world.

- Owner designates the owner of the file.
- Group designates the name of a specified group that can access the file.
- World allows access to anyone on your network.

You can change file properties for any file you own (as long as you have permission to make modifications in the folder containing the file). If you do not own the file, the write permissions determine whether you can access a file to change it.

To change file properties, type new information in the text fields of the Information window. Click SELECT on a check box to either add or remove a check.

When you have changed the properties, click SELECT on the Apply button to apply them. The changes take effect immediately.

You can change common properties on more than one file in the same manner.

Customizing Your File Manager

You can customize your File Manager from the Properties menu in the following ways:

- Customize General Defaults such as open a new folder into a different window, view the Folder View horizontally (or vertically), change the Wastebasket to delete or destroy or change the default document name.
- Customize New Folder Defaults
- Customize Current Folder Settings
- Customize the Go To menu
- Create your own custom commands and add them to the Custom Commands submenu that you access from the File menu.
- Customize Advanced settings such as print method, default editor, how you view floppies and so forth.
These methods are described in the sections that follow.

♦ You can access the Properties by choosing Edit ➤ Properties. The different properties categories are shown in Figure 2-33.

![Figure 2-33 File Manager Properties Menu](image)

In addition, you can customize your File Manager (and other DeskSet applications) with items such as font type and size that can be set in the Workspace Properties menu. See “Using the Workspace Properties Window” on page 468 for more information.
General Defaults

To change the General Default Properties:

♦ Choose Properties ➤ General Defaults from Category.

The General Defaults Properties window is shown in Figure 2-34.

![General Defaults Properties Window](image)

- Use Open Folder any time you open a folder. You can set the folder to open it into the same window as your existing folders or have the folder open into a new window each time.
- Use Folder View to lay out your folder structure horizontally or vertically.
- Use Edit Menu item to change the Delete option (default) on the Edit menu. Delete means delete to Waste window (where files can be recovered, if necessary.) Destroy means files cannot be recovered. Whatever you set for delete or destroy is reflected in the Edit menu. The Delete/Destroy setting allows you to choose whether File Manager deletes files by moving them to the Wastebasket, or destroys them. See “Using the Wastebasket” on page 91 for more information. If you choose Destroy, files are not moved to the wastebasket and are not recoverable once you delete them. On the other hand, you never need to empty the wastebasket if you choose the Destroy option.
Note – If you choose the Destroy option (and selected Save as Defaults), this state is saved when you quit File Manager. Therefore, the next time you start up the File Manager application, the Wastebasket will not be created because Destroy is on.

• Use Default Document Name to change the default name of a new document. This is the name you see when you create a new document.

**New Folder Defaults**

You can change the default for the way new files or folders are displayed in the file pane using the New Folder Defaults, shown in Figure 2-35. To display this window, choose New Folder Defaults from the Properties Category.

♦ Choose Properties ➤ New Folder Defaults from Category.

The New Folder Defaults Properties window is shown in Figure 2-35.

![Figure 2-35 New Folder Defaults Window](image-url)
**Default Name**

The current default name (when a new folder is created) is NewFolder. You can change this to anything you like.

**Longest Name**

The Longest Name field allows you to choose how many characters (based on the average width of the characters) of each file name are displayed in the file pane of File Manager. You can type any number from 0 to 255.

**Note** – The number of characters actually displayed for each file name may vary when using variable-width fonts because the width is calculated based on the width of the average character in the font.

Names that do not fit within the specified length are followed by a “greater than” sign (>) to show that the complete name is not displayed. Figure 2-36 shows an example of the file pane with shorter file names set.

![File Pane with Shorter File Names Specified](image)

If you want to see the complete file name, you can click SELECT on the name. In this example, the file .ab_cardca> is selected, and the full name is displayed in an editable text field, as shown in the example in Figure 2-37.
The Icon Layout setting determines whether files in the file pane are listed in rows (horizontally) or columns (vertically). The default is row order. For example, if files are sorted alphabetically by Name in rows, they are listed in from left to right, with the first files on the top row, then the second row, and so on. If files are sorted alphabetically by Name in columns, they are listed from top to bottom, with the first files in the left column, then the second column, etc. Figure 2-38 shows files sorted by Name in rows, and Figure 2-39 shows the same files sorted in columns.
Sort By Options

The Sort By Options allow you to choose how the files in the file pane are sorted. You can choose any of the following settings:

- Name, to sort the files alphabetically
- Type, to sort the files in alphabetical groups by file type, with folders first, followed by files, then by applications
- Size, to sort the files by size, largest to smallest
- Date, to sort the files in reverse chronological order (newest to oldest)
Hidden Files

The Hidden Files settings allow you to choose whether or not to display hidden system files (or dot files as they are sometimes called). Hidden files are usually system or configuration files, and the filename is preceded by a dot (.). Figure 2-40 shows an example of a listing with hidden files displayed.

![Figure 2-40 File Pane with Hidden Files (dot files) Visible](image)

Display Files As

Display Files as lets you determine the default way to display your files in the file pane. You can choose any of the following settings:

- **Icon**, to help you identify each file by type
- **List**, to display more files in the pane and to show you more information about each individual file, determined by the List Options. Displaying more files is true only if no list options are set.
- **Content**, to display a preview of the contents of icon and raster files. All other files are displayed as icons.

File Manager
Show in List

The Properties window option Show in List allow you to choose how much information is displayed when you display the contents of the file pane as a list with mini-icons as shown in Figure 2-41.

The list options in Show in List are nonexclusive settings. You can choose none, some, or all of the options. To set an option, click SELECT to toggle it from off to on, or from on to off. (Chosen options have a thickened border on monochrome monitors.) Figure 2-41 shows an example of a list display when all of the options are chosen.

View Contents As

View Contents as lets you determine the type of files that you want to display a preview of when the Display Mode is Content.
View By Content

When your file system contains icon and raster files created by applications, such as Icon Editor and Snapshot, you can display an image of the contents of the file in place of the standard data file icon. The images are displayed to scale in a 64-by-64 pixel square.

Choosing Content as your default Display Mode in the New Folder Defaults window displays the contents of black-and-white and color icons, rasters, X bitmap files, or any combination of these. Folders, applications, and other files are displayed as icons. Figure 2-42 is an example of a Contents file display.

Note – Choosing to display the contents of icon and raster files can delay the reading and displaying of other types of files and folders since File Manager must perform some additional processing to provide the preview.
You can select any or all of the options, as follows:

- Monochrome Icons, to preview black-and-white Sun icons
- Monochrome Images, to preview black-and-white Sun raster and X Bitmap images
- Color Icons, to preview XPM files

**Current Folder Settings**

This allows you to change the settings of the current folder. These settings are identical to the property settings that can be set for a new folder except there is no Default Name field. For complete information on these settings, refer to “New Folder Defaults” on page 101.

![Current Folder Settings Menu](image)

*Figure 2-43  Current Folder Settings Menu*

**Note** – The Current Folder Settings window displays the same information for the active (selected) folder window only. You can use this to change the settings for the designated active window.
Go To Menu Defaults

This allows you to change the defaults of the Go To menu. You can set the Go To menu properties to show a trail of the directory paths you last visited, and you can set up special paths to directories that you visit often. The Go To menu has several sections divided by spaces. Typically, you see a default label for home (a label for your home directory pathname), application specific defaults that include Waste and Folder View, then the paths to the directories you last visited.

![Go To Menu Defaults Diagram](image)

**Figure 2-44** The Go To Menu Defaults

- Use Pathname and the Add Item button to add another pathname to the default Go To menu. This can be in addition to your home directory pathname. If you add a pathname without a label, then the entire pathname is displayed in the Go To menu.

- Use Menu Label to create a new name for the specified pathname. You can add it to the Go To Menu Items scrolling list. This is useful if the pathname specified is long.
• Use the Edit button to cut; copy; paste—an item before, after, on top or on bottom of another item; delete an item in the Go To Menu Items default scrolling list.

• Use Display: Folders to indicate how many of the last folders visited should display by default in the Go To menu.

Custom Commands

The Custom Commands window allows you to create and store commonly used operating system commands. Once you have added the commands to the menu, you can use them at any time by choosing them from the Custom Commands submenu from the File menu.

Creating Custom Commands

Choose Custom Commands category from the Properties menu, as shown in Figure 2-45. You use this window to add often-used UNIX commands to your Custom Commands menu. You can even create a command that lets you specify different options every time the command is chosen.

**Note** – The Custom Command feature assumes that you have some working knowledge of the UNIX operating system. If you are not familiar with UNIX or have problems, you might want to have your system administrator help you create any desired custom commands.
The scrolling list shows your current custom commands. You use this window to add, delete, and change the order of your custom commands.

Follow the steps below to add a new custom command to the Custom Commands Menu Items scroll box. Follow the examples to add a custom command to search for a particular text string in the selected files or folders.

1. **Type the actual UNIX command in the UNIX Command text field.**
   You can add $FILE or $ARG to the command to represent the currently selected file or special arguments (options) that you can specify at the time you choose the command.
   
   In this example, type `grep $ARG $FILE` in the UNIX command text field.

2. **Type the name of the command that you want to appear in the Menu Label text field.**
   This Menu Label does not have to be the actual UNIX command. You may want the command to be something more descriptive.
   
   In this example, type `String Search`.

3. **Add the item.**
4. To prompt for command options, (that is, if you are using $ARG in the UNIX command), choose Yes on the Prompt Window setting, then type the prompt label into the first line of the Prompt text field.

If you use a prompt window, when the custom command is chosen from the Custom Commands menu a window is displayed with the prompt label. You use this pop-up window to type the command options.

In this example, choose Yes on the Prompt Window setting and type Search For: in the Prompt text field. When your custom command is chosen from the Custom Commands window, a window is displayed in which you can specify the text that you want to search for.

5. If your custom command will create any output, choose Yes on the Output Window setting.

This causes an output window to be displayed when the custom command is chosen, where you can see the result of your command.

In this example, you want to choose Yes on the Output Window. Then when you choose the new custom command from the Custom Commands menu, a window will be displayed that lists the places the text string is found.

6. Click SELECT on Apply to add the new command to the Custom Commands scrolling list.

To use the item, select the folders and files where you want to search for text, choose the String Search command from the Custom Commands submenu, and type the text string to search for in the window that is displayed. Press RETURN to quit or SELECT Quit from the output window.

Advanced Settings

You can change the way File Manager behaves and the way it presents certain information by changing controls in the Advanced Settings window. To display the Advanced Settings window, choose Advanced Settings from Category.

The File Manager Tool Properties window is shown in Figure 2-46.
Print Method

The Print Method text field allows you to specify a default UNIX print script for files that are printed from File Manager that do not have a print method defined in the Binder database. The print script shown in Figure 2-46 prints your files in landscape mode on your default printer, using the mp PostScript pretty printer. If you want to change the print script, make sure to type $FILE in the script where the file name should be inserted.

Figure 2-46  Tool Properties Window
View Filter Pattern

The View Filter Pattern text field allows you to specify that only files of a certain type are displayed in the file pane of File Manager. In the example shown in Figure 2-47, the filter pattern *.rs shows only the raster files in a directory, even though other files are there. Note that the header of the window shows you what filter pattern is set.

![Figure 2-47 File Pane with a *.rs Filter Pattern Set](image)

Default Editor

- Use Default Editor to specify what default editor File Manager uses to display the text of files that are not specifically bound to another application. If you click SELECT on Other, a text field is displayed in which you can type the name of a different text editor application. If you specify a different text editor that does not display its own window, you must specify that a Shell Tool is started before the text editor.

Note – Running command line programs, such as rm or rlogin, without specifying a Shell Tool to run the program in can lead to unpredictable File Manager behavior. Unless a program starts with its own window (such as textedit or mailtool), prepend shelltool to the program in the Default Editor text field, as shown in Figure 2-45.
Update File System

You can set the number of seconds that File Manager checks to see if any items were added or deleted.

Follow Symbolic Links

If Symbolic Links is set to No (the default), you see filenames just as you typed them. For example, in the Go To field. If Symbolic Links is set to Yes, you see links made across file systems.

Open File Manager Window

Automatically opens the CD window of the CD that has been inserted.

Use Generic Icons

When you insert a Floppy or CD, it can take some time for the icons to display. If it is not important to you what the icons look like, and/or if you want them to display quickly, you can set Yes and a generic representation of the icon is displayed and is much quicker time.

Customizing Your File Manager Colors

There are two ways to change the File Manager color scheme, as follows:

- To change the colors in the tree and file panes, use the `-fg` and `-bg` command line flags to specify different colors for your foreground (characters) and background. For example, if you want the tree and file panes to have blue characters on a gray background, try starting File Manager in a Command Tool or Shell Tool by typing the following:

  ```
  filemgr -fg 0 0 255 -bg 127 127 127 &
  ```

  Each trio of numbers represents red, green, and blue intensities from 0 to 255.

  Alternatively, you can specify the actual names of colors instead of the trio of numbers, as follows:

  ```
  filemgr -fg blue -bg gray50 &
  ```
To see the available list of color names, look at the file 
/usr/openwin/lib/rgb.txt.

• If you do not like the colors of the icons displayed in File Manager, use the Binder with its Color Chooser to change the colors to your liking. See “Changing a Binding” on page 462 of the chapter “Binder” for information.

File Manager first looks for entries in the Binder database to determine colors of the icons it displays. If File Manager cannot make contact with the Binder database, it issues a warning message, and then uses the colors set up via X resources, described in the filemgr manual page.

Using Floppy and CD Media

File Manager allows you to use removable media such as Floppy Disks or CD-ROM (Compact disk, read-only memory) on the WorkSpace. You can view your Floppy disks or CDs if you:

• have a system with at least (1) floppy drive or (1) CD-ROM drive and are running Solaris 2.4

Refer to the documentation that came with your computer for information on how to insert a floppy disk or CD into the drive.

Using a Floppy Disk with File Manager

The following explains what to do with your floppy disk once you have inserted it into your drive. You may encounter these cases when you insert a Floppy disk:

• The disk is formatted and labeled. In this case you see the window as shown in Figure 2-48. You can begin using the information on your disk.

• The disk is unformatted. Refer to “Reformatting a Floppy Disk” on page 119 for information on formatting a disk.

• The disk is formatted and may contain data. If the data is in Macintosh™ format or unknown to this system, you may see the a popup as shown in Figure 2-53.
Checking for a Floppy Disk

1. Insert your floppy disk into the disk drive on (or attached to) your computer.

2. Select Check For Floppy from the File Menu.

If you inserted a formatted, labeled disk, you can move on to “Viewing a File from the Contents of a Floppy Disk or CD” on page 117.

Note – You do not have to check for CDs.

Viewing a File from the Contents of a Floppy Disk or CD

Once the File Manager window is displayed, you can view the contents of your floppy disk or CD.

Figure 2-48  The File Manager Floppy Disk Window
1. If necessary, scroll through the contents of floppy disk or CD until you find the file you want to view.

2. Select the file or folder to be viewed.

3. Choose File ➤ Open.

You can now use File Manager windows and menus. If you close the window to an icon you see the following for floppy or CD as in Figure 2-50.

Figure 2-50  The Floppy Disk and CD icons
Removing a Floppy Disk or CD from the Disk Drive

1. From the floppy or CD window Select the Eject Disk Button.
2. Remove the disk or CD from the drive when it is ejected.
   The drive is now free.

Note – On x86 or PowerPC machines, you must physically remove floppies by hand. After selecting the Eject Disk button, you will see a pop-up window telling you that you may manually eject the floppy. Do not remove the floppy without selecting Eject Disk first. If you do, the system will display a pop-up window telling you to reinsert the floppy. Reinsert it, select Eject Disk, and remove the floppy.

Ejecting Unrecognized Data Format CDs

To eject a CD that has an unrecognized data format (such as audio files):

1. Open a Command Tool or Shell Tool.
2. At the prompt type:
   eject cdrom
   Your disk should now be ejected from the drive.

Reformatting a Floppy Disk

If you are using a diskette for the first time or if you want to format your diskette, perform the following steps.

1. Insert the floppy disk.
2. Select Check For Floppy from the File Menu.

Note – If you inserted a correctly formatted disk, you see the window on the WorkSpace as shown in Figure 2-48.

If the diskette is not formatted, you see the window in Figure 2-51 on page 120.
3. Choose Format Floppy from the File menu.
   Make sure the floppy window is active.

   ![Format Floppy Window]

   **Figure 2-51** The Floppy Format Disk Window

   If you choose to Format the disk, this is your last chance to Cancel.

4. Click Format Disk.

   When the initialization has been complete, you see the File Manager window
   on the WorkSpace as shown in Figure 2-48.
Unformatted Floppy

If you inserted an unformatted floppy disk, the following popup displays:

![Unformatted Floppy Popup](image)

**Figure 2-52 Unformatted Floppy Popup**

You can choose to:

- format the disk, refer to “Reformatting a Floppy Disk” on page 119 for information on reformatting the disk.
  
  or

- cancel the operation and dismiss the popup.
  
  or

- cancel the operation and eject the floppy.

**Note** – Macintosh, Sun TAR and Sun BAR formats are not recognized.
Unlabeled Floppy

If you inserted a floppy disk that is unlabeled, that is there is data on the disk but is not a recognized format, the following message displays:

![Unlabeled Floppy Popup](image)

Figure 2-53  Unlabeled (Unknown Data) Floppy Popup

You can choose to:

- format the disk, refer to Reformatting a Floppy Disk on page 119 for information on reformatting the disk.
- cancel the operation and dismiss the popup.
- cancel the operation and eject the floppy.
Renaming a Floppy Disk

There are times when you would like to change the name of your disk.

1. Insert the disk to be renamed.
2. Select Check For Floppy from the File Menu.
3. Choose Rename Disk from the File menu.
   You see the rename disk window.

   ![](floppy_rename_disk.png)

   **Figure 2-54** The Floppy Rename Disk Window

4. Type a new name for the disk.
   You type over the existing disk name and it disappears when you have finished typing.

5. SELECT the Rename Disk button.
   The disk is now ready to be used or ejected.

Dragging and Dropping Files from Floppy Disk or CD to File Manager

1. Open the floppy disk or CD into a window.
2. Select the file or folder icon and drag it from one window to the other.
   For information on dragging and dropping, refer to Chapter 1, “Introduction to the Solaris User Environment.” The file is now copied to File Manager.
Copying Files from Floppy Disk or CD to Floppy Disk

You can copy files from a floppy disk (or CD) to another floppy disk.

1. Insert the floppy or CD that contains the files to be copied.
2. Select all files to be copied.
3. Copy the selected files to a folder in a File Manager window.
4. Remove that floppy.
5. Insert a new floppy.
6. Copy the folder to the newly inserted floppy.
Text Editor

The Text Editor is an interactive ASCII text editor. It allows you to create new files and modify existing files.

This chapter describes how to use the Text Editor. You do not need to know any special editing commands because the editing commands are available from the base window. The editing functions provided in this DeskSet application are also available in the text editing panes of the Console and the Command Tool, and in the View and Compose windows of the Mail Tool.

♦ To open the Text Editor window, choose Workspace ➤ Programs ➤ Text Editor.

Text Editor Icon

The Text Editor icon shows you as much as it can of the beginning of the file name. When the file has been edited and you have not saved the changes, the file name is preceded by a right-angle bracket (>). When there is no file or when you have created a new file but have not saved it, the icon displays the words NO FILE. Figure 3-1 shows an example of three Text Editor icons. The one on the left contains a file named example. The one in the middle contains a file named example that has been edited but not saved. The one on the right contains either no file at all or a file that has never been saved.

Figure 3-1 Text Editor Icons
Text Editor Base Window

The Text Editor base window, shown in Figure 3-2, has a control area and a text pane that you use to compose and edit your text message. The header of the Text Editor window displays the name of the file you are editing (or the word NONE when you have not assigned a name to the file), and shows you the directory where the file is located. When you have made editing changes, the word “edited” is displayed in parentheses following the file name.

Use the text pane to compose and edit your text. To begin, click SELECT in the text pane and begin typing. For information on adding, modifying, or deleting text, see the section Working with Text in Chapter 1, “Introduction to the Solaris User Environment.” To copy and move text, use the Cut/Copy/Paste functions from the Edit menu or from the keyboard.

Note – Solaris supports SPARC, x86, and PowerPC-based machines. Command functions and their corresponding keyboard equivalents may differ on each machine. For a full table of these equivalents, see Chapter 1, “Introduction to the Solaris User Environment.”

Figure 3-2  Text Editor Base Window
Text Editor Menus

The control area of the Text Editor has File, View, Edit, and Find buttons. These menu buttons are included as menu items in the Text pane pop-up menu.

Text Pane Pop-Up Menu

You display the Text Pane pop-up menu by moving the pointer anywhere onto the Text pane and pressing MENU. (The Text Pane pop-up menu is also provided in the text editing panes of the Console, Command Tool, and Mail Tool applications.)

The commands for each of the items in Text Pane pop-up menu operate in the same way as the controls in the Text Editor window, described in the following sections. An additional item on the Text Pane pop-up menu, called Extras, is also described later in this chapter.

File Menu

The File menu contains items that you can use to open, save, save as, include and empty the document for your text files. For complete information on opening and saving files, refer to “Opening, Saving, Including and Attaching Files” in Chapter 1, “Introduction to the Solaris User Environment.”

Include File

Use the include file to include an existing file into a new text file.

1. Use the Include File item of the File menu to display the Text: Include window.

2. Locate and include your file.
   Include your file in the same manner you would open or save a file. For detailed information on choosing a file to open or save, refer to Chapter 1, “Introduction to the Solaris User Environment.”

Empty Document

Use the Empty Document item of the File menu to clear the contents of the text pane. If you have made editing changes and have not saved them, a Notice is displayed asking you to confirm or cancel the operation.
View Menu

Use the View menu item to control the position of the cursor and the way the line wrap is used.

Select Line at Number

Use the Select Line at Number item to display the Text: Line Number window, shown in Figure 3-3. Type the number of the line that you want selected, and click SELECT on the Select Line at Number button. The text on the specified line is selected, and the insert point is moved to the end of the selected text.

![Text: Line Number Pop-up Window](image)

Figure 3-3  Text: Line Number Pop-up Window

What Line Number?

Use the What Line Number? item of the View menu to locate the line number where the selected text begins. The line number is displayed in a Notice. When there is no current selection in the Text Editor window, the Notice displays an error message instead of a line number.

Show Caret at Top

Use the Show Caret at Top item of the View menu to scroll the document so the line currently containing the caret is the third line from the top of the text pane.

Change Line Wrap

The Change Line Wrap submenu provides three choices for line wrapping: word, character, and clip lines. The text shown in Figure 3-4 is wrapped at a character, so words are broken at the end of lines.
The most commonly used wrapping method is to wrap at the end of words. The text shown in Figure 3-5 is wrapped at the end of words.
If you choose Clip Lines, the beginning of each line that ends with a Return is displayed. In Figure 3-6 each line represents a paragraph because there are no carriage returns embedded in the lines. Only carriage returns are at the end of each paragraph. That is,

Figure 3-6  Clipped Lines

**Edit Menu**

The Edit menu provides standard editing functions, as follows:

- **Again** repeats the last editing action.
- **Undo** undoes the last editing action or all editing actions, depending on which item you choose from the Undo submenu.
- **Copy** stores a copy of the selected text on the clipboard. Only one selection at a time can be stored on the clipboard. If something is already on the clipboard and you do a Copy or Cut, the contents of the clipboard are overwritten with the new information.
- **Paste** inserts the contents of the clipboard at the insertion point.
- **Cut** removes the selected text and stores it on the clipboard. Only one selection can be stored on the clipboard at a time.

**Find Menu**

The Find menu items help you to search for specific text strings, special characters, and delimiters to find a text string and replace it with another.
Text: Find and Replace

Use Find and Replace to find specific text and replace it through the Text: Find and Replace window. If you have a current selection, it is automatically displayed in the Find text field, as shown in the example in Figure 3-7.

Figure 3-7  Text: Find and Replace Pop-up Window

To find a text string and select it, type the text in the Find field and click SELECT on the Find button. Click SELECT on the Find button again to find and select the next occurrence of the text string.

To replace the current selection with a text string, type the text in the Replace field and click SELECT on the Replace button. You can use the Replace button together with the Find button to find a string and then replace it with another, or separately to replace highlighted text. You can replace a string with nothing by leaving the Replace text field blank.

If you want to find a text string that contains tabs or carriage returns, select the text containing tabs or carriage returns in the text pane before you display the Text: Find and Replace window. You cannot type carriage returns or tabs directly in the Find or Replace text fields.

The buttons at the bottom of the Find and Replace window combine the find and replace operations, allowing you to quickly do any of these combinations:

- Use the Find then Replace button to find the text string in the Find text field, and then immediately replace it with the text string in the Replace text field.
- Use the Replace then Find button to replace the currently selected text with the text string in the Replace text field, and then immediately find the next occurrence of the Find text string.
- Use the Replace All button to replace all occurrences of the Find text string with the Replace text string.
You can specify whether you want the find and replace operations to apply to all of the text, or to restrict the operation to the text between the insert point and the end of the document. Use the abbreviated menu button at the lower right corner of the window to select either All Text or To End. The current setting is listed to the right of the abbreviated menu button, as shown in Figure 3-7.

**Find Selection**

Use Find Selection on the Find menu to search the file for another occurrence of the text string that is highlighted as the current selection. You can search forward or backward from the insert point by choosing Forward or Backward from the Find Selection submenu.

**Find Marked Text**

Use Find Marked Text on the Find menu to highlight text between a matched set of delimiters provided as options in the Text: Find Marked Text window, shown in Figure 3-8.

![Figure 3-8 Text: Find Marked Text Pop-up Window](image)

You can search and highlight text for any of the matched delimiters provided as choices in the Text:Find Marked Text pop-up window. Click SELECT on one of the sets of delimiters, and then click SELECT on the Find Pair button. Use the Backward or Forward choice to direct the search either backward or forward from the current insertion point. If you have nested delimiters, such as matched parentheses in a program’s code, you can use the Expand choice to select text outward from the current insertion point to the next outer pair of specified delimiters.
To surround the selected text with the selected delimiters, click SELECT on the Insert Pair button. To delete a matched pair of delimiters from the selected text, click SELECT on the Remove Pair button.

**Replace Field**

The Text Editor pane recognizes any text between the characters `|>` and `<|` as a text field. You can search forward through the text from the insert point to find and select each field using the Replace `|>`field`<|` item of the Find menu. The Replace `|>`field`<|` submenu provides three options: Expand, Next, and Previous:

- When the caret in the Text Editor pane is between field delimiters, choose Expand to search in both directions and select the entire field and its delimiters.
- Use Next to search forward from the insert point and select the next field.
- Use Previous to search backward from the insert point and select the previous field.

**Extras Menu**

There is an additional item on the Text Pane pop-up menu, called Extras, that is not a button in the Control area (as File, View, Edit, and Find are). This menu contains some useful filters to format the selected text. You can customize the Extras menu and define your own set of filters available from the Extras menu. See “Customizing Your Text Editor” on page 143 for information about how to define your own set of filters. This section describes the default Extras menu.

**Format**

Choose Format to reformat selected long lines of text into physical lines of no more than 72 characters. This is useful, for example, when reading mail with lines longer than the width of the window. Formatting text before printing is also useful to make sure the lines will not be truncated by the printer.

Format uses the UNIX `fmt` command. It does not split words between lines, and it preserves blank lines and the spacing between words.

**Note** – Format (and `fmt`) work only on lines of no more than 1024 characters.
Capitalize

Use Capitalize on the Extras menu to capitalize selected text.

- The first item on the Capitalize submenu, abcd->ABCD, capitalizes every letter of the selected text.
- The second item on the Capitalize submenu, ABCD->abcd, turns all the letters of the selected text into lower case.
- The last item of the Capitalize submenu, abcd->Abcd, capitalizes the first letter of every selected word. Uppercase letters within a word are not changed.

Shift Lines

Choose the Shift Lines item to insert or remove a Tab character at the beginning of each line in the selected text. Use the Shift Lines submenu to specify whether to shift right or left. Shift right inserts a Tab character, and shift left removes a Tab character.

Pretty-print C

This item uses the UNIX indent command to format C program listings. It formats the selection according to standard specifications, or to the specifications of the .indent.pro file if you have one.

Insert Brackets

You can use the Insert Brackets item to quickly insert any of the following type of brackets around the selected text, depending on which item you choose from the Insert Brackets submenu: ( ), [ ], { }, or " ".

Remove Brackets

Choose the Remove Brackets item to remove any of the following types of brackets around the selected text, depending on what item you choose from the Remove Brackets submenu: ( ), [ ], { }, or " ".
Creating a New File

To create a new file with Text Editor:

1. Choose Workspace ➤ Programs ➤ Text Editor and type a line in the Text Editor window field, such as:
   This is a test file.

2. Press MENU on the File menu button, and select Save.
   You see the Text:Save window.

3. Save the file.
   For complete information on saving a file, refer to Chapter 1, “Introduction to the Solaris User Environment.”

Working with an Existing File

You can open (load) any standard ASCII text file into the Text Editor and then modify the current file, or change the name of the file to create a new file, which leaves the original file intact. To load a file from your file system into Text Editor:

1. Choose File ➤ Open from the Text Editor control area.
   You see the Text:Open window.

2. Select and open the file.
   The file you have specified is displayed in the Text Editor window. For complete information on opening a file, refer to Chapter 1, “Introduction to the Solaris User Environment.”

Saving the Existing File

You can now edit the existing file and either save your changes in that file, or save it as a new file. To modify the file, see the section, “Editing Files” on page 136. To save the changes to the existing file, do the following:

♦ Choose File ➤ Save from the Text Editor control area.
   The file is automatically saved.

   Because UNIX does not allow two documents with the same name in one directory, when you make a copy of a document in the same directory the original file is automatically saved to a backup file and renamed with a
% suffix. For instance, a file named messages would automatically be renamed messages%. The next save overwrites the existing backup file rather than creating a second backup. Figure 3-9 shows the two files displayed as icons in File Manager.

![Figure 3-9 Edited File and Backup File with a % Suffix](image)

**Note** – If you do not want to retain the original, delete the file with the % suffix by pressing SELECT on the icon in File Manager and dragging it to the Wastebasket.

### Saving the Modified File as a New File

To keep the original file intact and create a new file with the modifications, do the following:

1. **Choose File ➤ Save As.**  
   You see the Text:Save As window.

2. **Name and save the new file.**  
   The file is stored in the designated directory and file. For complete information on saving a file, refer to Chapter 1, “Introduction to the Solaris User Environment.”

### Editing Files

Using Text Editor, you can add and delete text from a file, copy text from one location to be pasted in another, and search for text strings in a file.
Adding and Deleting Text

You can add new text to a file by placing the insert point anywhere in the file (click SELECT in the desired location) and typing the new text there. Likewise, you can delete characters by placing the text caret at the end of the character string you want to delete, and backspacing over those characters.

Another way to delete a character string is to cut it. This places the text string in a system clipboard, and if you want you can paste it elsewhere. To cut and paste a text string, do the following:

1. Click SELECT to the left of the first character in the string that you would like to cut.
2. Click ADJUST to the right of the last character in the string.
   The text string is highlighted.
3. Press MENU to display the window pane's pop-up menu, drag the pointer down to highlight Edit, and to the right to highlight Cut.
   The text string is placed in the system clipboard. (Alternatively you can use the Cut button on the keyboard, if there is one, or Meta-x.)
4. Move the pointer to the destination where you would like to paste the text string and click SELECT to position the caret there.
5. Press MENU to display the window pane's pop-up menu, drag the pointer down to highlight Edit, and to the right to highlight Paste.
   The text string appears in the new location. (Alternatively, you can use the Paste button on the keyboard, if there is one, or Meta-v.)

Copying and Moving Text

To copy a section of text, you highlight the line of text using SELECT and ADJUST, as follows:

1. Click SELECT to the left of the first character in the string that you would like to copy.
2. Click ADJUST to the right of the last character in the string.
   The text string is highlighted.
3. Press MENU to display the window pane’s pop-up menu, drag the pointer down to highlight Edit, and to the right to highlight Copy.

The text string is placed in the system clipboard. Figure 3-10 shows the Edit menu. (Alternatively, you can use the Copy button on the keyboard, if there is one, or Meta-c.)

![Edit Menu](image)

Figure 3-10  Edit Menu

4. Move the pointer to the place where you want to insert the text and click SELECT to set the insert point.

5. Choose Paste from the Edit menu or press the Paste key on the keyboard.

To move text, the steps are similar, except that you choose Cut instead of Copy, and the selected text is removed from its original location.

Paste the text in a new location by clicking SELECT once on the destination point, and then choosing Paste from the Edit submenu in the Text Pane menu. (Alternatively, you can press the Paste button on the keyboard, if there is one, or Meta-v.)

**Tips on Cutting and Pasting**

- For some it is more convenient to use the Cut and Paste buttons on the keyboard rather than the Edit menu.

**Note** – x86 and PowerPC keyboards do not have Cut, Copy, and Paste keys. Use Ctrl-Alt-x, Ctrl-Alt-c, and Ctrl-Alt-v respectively.

- Clicking SELECT twice on a word highlights that word for cutting or copying.
- Clicking SELECT three times on a text line highlights the whole line for cutting or copying.
• Clicking SELECT four times anywhere in the file highlights the entire contents of the document.

Printing Text Editor Files

Before printing a Text Editor file, you may need to choose Format from the Extras menu to reformat selected long lines of text into physical lines of no more than 72 characters. A line of text is defined as ending with a carriage return. The Text Editor wraps a long line into several displayed lines, so what looks like several lines on your screen may actually just be one long line.

You print Text Editor files by dragging and dropping the file onto the Print Tool application. To drag the entire Text Editor file, press SELECT on the text glyph inside the drag and drop target, drag the pointer to the Print Tool icon or drag and drop target, and release SELECT. The drag and drop target is the small shaded box in the upper right corner of the Text Editor or the upper left corner of the Print Tool.

You can also print Text Editor files the same way you print any file with the File Manager. Save your Text Editor file using one of the methods described in the section “File Menu” on page 127. Then select the file in the File Manager, and drag and drop it onto the Print Tool or choose Print File from the File Manager’s File menu. See “Printing Files” on page 86 for more information about printing files from the File Manager.

Splitting Panes

The Text Editor pane can be split into two or more panes so that you can view and edit different parts of the document at the same time. The document itself is not split, so any editing changes you make in one view are reflected in other views as well. To split the Text Editor pane:

1. Move the pointer to the top cable anchor of the vertical scrollbar and press SELECT.

2. Drag the pointer downward into the pane.
   A horizontal line is displayed from the left edge of the pane to the center of the cable anchor to show where the split will occur.

3. Release SELECT.
   The pane is now split into two panes, as shown in Figure 3-11.
Alternatively, you can move the pointer into the scrollbar at the place you want to split the views, press MENU to display the scrollbar menu, and choose Split View.

One way to remove a split pane is to move the pointer to the top cable anchor in the pane you want to remove and press SELECT. Then drag the pointer down until the top and bottom cable anchors overlap, and release SELECT. Another method is to move the pointer to the place in the scrollbar where the views are split, press MENU to display the Scrollbar menu, and choose Join Views.

**Drag and Drop Feature**

Drag and drop is a method of moving files or selected text into and out of the Text Editor using only your mouse. Refer to Chapter 1, “Introduction to the Solaris User Environment,” for an overview of the drag and drop feature.

To load a file (overwriting any existing text), you can drag and drop a text file onto the Text Editor drag and drop target or icon.

To insert text within a Text Editor file, you can drag and drop a file or selected text to the spot in the text pane where you want the text inserted.
You can drag and drop either selected text or the entire Text Editor file to any location in the DeskSet environment that accepts ASCII text. The following sections describe two different ways to drag and drop from the Text Editor application.

**Dragging Selected Text from the Text Editor**

To drag a copy of selected text from the Text Editor:

1. **Select the text to be copied.**
   If you want to copy the entire file, quadruple-click SELECT, or drag from the drag and drop target as described in the next section.

2. **Press the Control key on the keyboard and click SELECT.**
   Once you have clicked SELECT you can release the Control key. Pressing the Control key assures that the text is copied instead of moved. If you don’t press the Control key first, the text being dragged will be cut from the original text.

3. **Drag the pointer a short distance.**
   A text duplicate pointer is displayed, as shown in Figure 3-12, with the first few characters of the selected text displayed inside the rectangle.

4. **Drag the pointer to the destination or the text and release SELECT.**

![Figure 3-12 Dragging a Copy of Text Editor Text](image-url)
Dragging Complete Text Editor Files

Text Editor files can be dragged and dropped onto any place in the DeskSet environment that accepts ASCII files. This operation is always done as a copy. To drag a complete Text Editor file:

1. Press SELECT on the text glyph inside the drag and drop target.
   The text glyph is the figure inside the drag and drop target that represents the entire text file.

2. Drag the pointer a short distance.
   A text file move pointer is displayed, as shown in Figure 3-13.

   ![Figure 3-13 Dragging a Text Editor File](Image)

3. Drag the pointer to the destination of the text and release SELECT.
Customizing Your Text Editor

There are two files used by the Text Editor that you can modify to customize the Extras submenu of the Text Pane pop-up menu and to specify function key mappings. This section describes these two files.

The .text_extras_menu File

You can customize the Extras menu to include your own commands by modifying the file .text_extras_menu. By default (and depending on how your system is configured), the Text Editor uses the information found in the file /usr/openwin/lib/locale/<locale>xview/.text_extras_menu. <locale> is a subdirectory that contains locale specific text files. The default is “C”, but may vary depending on the country locale. You can create your own copy of this file and tell the Text Editor to use it instead of the default in either of the following two ways:

- Change the value of the .Xdefaults parameter text.extrasMenuFilename or Text.ExtrasMenuFilename to the path and file name of your customized file. See the manual page for XView for information about the .Xdefaults file.

- Set the environment variable EXTRASMENU to the desired file name.

If you specify both options, the .Xdefaults parameter will be used.

The standard Extras menu file is /usr/openwin/lib/locale/C/xview/.text_extras_menu and is shown in Figure 3-14. It will give you ideas about how to implement your own extras menu file. Once you’ve created a custom file and indicated where to find it using one of the previous methods, you can make changes to the file and see them immediately implemented in the Extras menu. These changes also affect other text panes in DeskSet applications, such as the Mail Tool Compose window.
Figure 3-14  Extras Menu File in /usr/lib/.text_extras_menu

The name of each Extras menu item is surrounded by double quotation marks. Each submenu begins with a MENU statement and ends with an END statement.

To include a backslash (\) character in the .text_extras_menu file—as in the troff inline font specifications \fB and \fP—you need to use four backslash characters; for example:

insert_brackets \\\fB \\\fP

Alternatively, you can use quotes in place of one pair of brackets; for example:

insert_brackets "\\fB "\\fP"
The .textswrc File

You can associate filters (programs or routines) with unused function keys by modifying your own copy of the file .textswrc. When a text selection has been made and a function key pressed, the selected text is piped through the filter assigned to that key. The output is then piped back into the text at the caret, replacing the text that was selected.

If you want to specify your own set of bindings of filter keys to function keys, you must copy the file /usr/lib/.textswrc to a file called .textswrc in your home directory. The Text Editor reads the file .textswrc from your home directory, if the file exists.

Format of the .textswrc File

List the sample file /usr/lib/.textswrc to see an example of filters used with a right-handed keyboard. You can copy this file into your home directory, then modify it by adding filter bindings to unused function keys.

Here is the basic format of each .textswrc file entry:

    key-name      FILTER
    command-line

A function is assigned to one of the function keys by including a statement like the following in your .textswrc file:

    /*
     * Note that:
     * insert_brackets /* */ does NOT work
     * double quotes are needed
     */
    KEY_TOP(10) FILTER
    insert_brackets "/* " " */"

This example shows how to include C language comment markers around a piece of text. You could enter this example into your .textswrc file, and save the file. Then, to use this added function, start up a new Text Editor application. Changes to your .textswrc file are only effective when you
bring up a new Text Editor. Then select the text and press the key. The text will be replaced with a copy of itself surrounded with "/*" and "*/". Note the C-like syntax of comments in the .textswrc file.

When defining a filter in the .textswrc file, remember that the filter must appear in a directory accessible by your search path. If the command is not found, or if there is some other failure in the invocation of the filter, no change occurs in the document.
Multimedia Mail Tool lets you communicate with other people on the network. You can write, send, and receive electronic mail. When you receive an electronic mail ("email") message, you can act upon it in various ways:

- Save the message as a file anywhere in your file system
- Delete the message
- Reply to the sender
- Forward the message to another recipient along with your own message
- Print the message

You can send and receive attachments: audio files, image files, document files, executable files, or any other files.

Using drag and drop, Multimedia Mail Tool works in combination with File Manager, Text Editor, AudioTool, Calendar Manager, and other applications to provide an integrated workspace environment.

For brevity, Multimedia Mail Tool is referred to simply as Mail Tool throughout the rest of this document.

♦ To open Mail Tool, choose Workspace ➤ Programs ➤ Mail Tool.
How Mail Tool Is Organized

Mail Tool has three key windows:

- The Header window is a base window that lists mail messages that you have received.
- The View Message window is a pop-up window where you read your messages.
- The Compose window is a base window for responding to messages or writing new messages.

Each of these windows is described in detail later in this chapter.

Header Window Icons

The primary Mail Tool icon, for the Header window that shows you incoming mail messages, looks like a standard office In-Box. When you don’t have any mail, the In-Box on the icon is empty. When you have mail that has all been read, the In-Box contains a neatly stacked set of envelopes. When new mail arrives, envelopes are placed in the In-Box with the stamped and addressed side showing. Figure 4-1 shows these views of the mailbox icon.

![Figure 4-1 Mail Tool Header Window Icons](image)

The Mail Tool Compose window can also be closed to an icon. See “Mail Tool Compose Window” on page 157 for a description and picture of the Compose window icons.

Mail Tool Header Window

The window shown in Figure 4-2, provides a set of controls with which you access other parts of the Mail Tool application, display a list of your electronic mail messages, and see the status of your mail messages.
By default, this window shows you a scrolling list of the mail messages in your In-Box. Each line in the scrolling list of the window represents a single electronic mail message, and is called the header for the mail message.

![Mail Tool - /usr/mail/egret](image)

Figure 4-2  Primary Mail Tool Header Window

**Mail Message Headers**

Each message header has six fields or columns of information, as follows:

- The first field shows you the status of the mail message:
  - An arrow points to **current messages** (messages currently displayed).
  - An N shows you that the message is **new**.
  - A U shows that a message is **unread**, that is, it has been saved without having been read.
  - A blank is displayed after you have **viewed** the message.
  - A diamond indicates that the message contains **attachments**.
- The second field contains a **message number** that is automatically assigned to messages by the Mail Tool in the order in which they are loaded.
- The third field contains the mail address of the **sender** of the message.
• The fourth field contains the day, date, and time the message was received. If the message is over 11 months old, the year is shown instead of the time.

• The fifth field tells you how big the message is. The first number tells you the number of lines in the message, and the second number tells you the number of characters. These numbers include the number of lines and characters of the full message header, as well as the text of the message.

• The sixth field contains the subject of the message when the person who sent the message provides a subject line.

Message Header Status Messages

Status messages are displayed at the right side of the footer. These messages tell you how many messages are in your mail file, how many new messages you have, and how many you have currently deleted. In Figure 4-2, the status message tells you there are 4 items, 4 new messages, and 0 deleted messages.

Selecting Message Headers

You can select each message header by moving the pointer onto the line and clicking SELECT. A selected header has a box around it. To select additional messages, move the pointer into the line and click ADJUST. If a message is already selected, clicking ADJUST deselects it.

You can select all the messages sent by or to a particular person or alias, and/or about a particular subject by using the Mail Tool Find feature.

Mail Tool Controls and Menus

The control area, shown in Figure 4-3, has three groups of controls.

Figure 4-3  Mail Tool Control Area
The first four buttons in the top row are the standard Mail Tool menu buttons. The first four buttons in the bottom row are user-defined accelerator buttons, which you can customize to represent any of the items available from the standard menus. The items at the right side of the control area are the Mail File controls. These include the Mail File abbreviated menu button and text field, and the Mail File Move, Copy, and Load menu buttons.

The following sections provide a brief description of each of these controls.

**File Menu**

The File menu has choices that you use to organize mail messages, print them, or commit changes (such as deleting and sequentially renumbering messages).

- Use Load In-Box to load and view messages from your In-Box. This is how you return to the default mail view after you are done viewing a different mail file. It is also how you can get your new mail in between mail delivery intervals. See “Organizing Your Mail Messages” on page 183 for more information about mail files.

- Use Print to print the selected messages. See “Printing Messages” on page 162 for more information about printing.

- Use Save Changes to incorporate changes. See “Saving Changes for Mail Tool” on page 182 for more information.

- Use Done to incorporate changes and to close Mail Tool to an icon.

- Use Mail Files to display a window that helps you organize your mail messages into separate mail files. See “Organizing Your Mail Messages” on page 183 for more information about mail files.

The default item of the File Menu is Load In-Box. Selecting this loads your inbox.

**View Menu**

The View menu has choices for different ways to view messages and move between them, and for finding particular mail messages.

- Use Messages to view messages with an abbreviated or full header.

- Use Previous or Next to view the message before or after the current message.
• Use Sort By to sort messages in your In-Box or mail files. See “Sorting the Contents of a Mail File” on page 190 for more information.

• Use Find to find messages in your In-Box or mail file by sender, recipient, and/or by subject. See “Saving Changes for Mail Tool” on page 182.

See “Mail Tool View Message Window” on page 154 for more information about the first three items on the View menu.

The default item of the View menu is Next. When you select Next, the next message is displayed.

**Edit Menu**

The Edit menu has choices for editing and deleting mail messages and configuring your Mail Tool from the Mail Tool Properties window.

• Use Cut and Copy to put selected messages onto the clipboard. You can then paste these messages from the clipboard into other windows using the Text Pane menu. These options are dimmed if you do not have any selected messages.

• Use Delete to delete selected messages. This option is dimmed if you do not have any selected messages, or are not currently viewing any.

• Use Undelete to restore deleted messages. When you save your Mail Tool changes, deleted messages are really deleted, and can no longer be restored. The Undelete option is dimmed if you do not have any deleted messages.

• Use Properties to customize your Mail Tool. See “Customizing Mail Tool” on page 194 for information about Mail Tool properties.

The default item of the Edit menu is Delete. When you choose Delete, the currently selected messages are deleted or the currently viewed messages are deleted if no messages are selected.

**Compose Menu**

The Compose menu has choices for opening Compose windows from which you can write and send mail messages.

• Use New to open a new Compose window.
• Use Reply to open a Compose window to respond to a selected message. See “Replying to a Message” on page 166 for more information.

• Use Forward to open a Compose window that includes the selected message for forwarding. If the message has attachments, the attachments are also included in the forwarded message.

• Use Vacation to initiate or stop an automatic response to incoming messages when you are away from your mail. See “Using the Vacation Notifier” on page 168 for more information about Vacation options.

The default item of the Compose menu is New. When you choose New, a new Compose window is opened.

**Custom Mail Tool Buttons**

The first four buttons on the second row of the control area are custom Mail Tool buttons. You can change these buttons to be any of the items on the File, View, Edit, or Compose menus.

The default items of the custom buttons are Done (from the File menu), Next (from the View menu), Delete (from the Edit menu), and Reply (from the Compose menu). See “Header Window Properties” on page 195 for information about how to change the items on these custom buttons.

**Mail File Text Field and Menus**

You use the Mail File text field and abbreviated menu button to create and view mail files, and to store messages into mail files. You use the abbreviated menu button to choose from all your available mail files. See “Mail File Menus” on page 185 for information on creating and viewing mail files.

Use the last three buttons on the second row of the control area to move or copy selected messages into a mail file, or to view (load) a different mail file. Each of these buttons displays a menu of the most recently used mail files. You can customize this menu to always include particular mail files. See “Mail File Menus” on page 185 for information on creating and viewing mail files. See “Mail Filing Properties” on page 206 for information about customizing your mail file menus.
Pop-up Menus

A pop-up menu in the Header pane, called Messages, contains a subset of controls from the File, View, Edit, and Compose menus. Display this menu by moving the pointer anywhere in the Header window pane and pressing the MENU button. Each item on the Messages pop-up menu works the same way as it does when you choose the same item from a menu button.

The text editing panes in the View Message and Compose windows contain a pop-up menu with the standard editing commands from the Text Editor. For a description of the text editing commands, see the chapter “Text Editor” on page 125.

Mail Tool View Message Window

To view a message, double-click SELECT on the header for the message that you want to display. Alternatively, you can SELECT the message header, and then choose Messages from the View menu.

A View Message pop-up window is displayed showing the text of the selected message with an abbreviated message header, as shown in Figure 4-4.

![View Message Window](image)

Figure 4-4  View Message Window
The number of the displayed message is always shown in the header of the View Message window (Message 2 in Figure 4-4).

Once you have displayed a message in a View Message window, any “New” or “Unread” flags on the message header are cleared, whether or not you have actually read the message.

The View Message window uses the standard text editing pane and pop-up menu. You can edit the text in the View Message pane. If you have made editing changes to the message, a Notice (asking if you want to save the changes), is displayed when you change messages or dismiss the window.

The View Message window can be split into two or more panes to view and edit different parts of the mail message at the same time. See Chapter 3, “Text Editor” for more information.

If the message you are viewing contains attachments, a separate attachment area is displayed at the bottom of the View Message window. See “Mail Tool Attachments” on page 173 for information about mail attachments.

**Using the Pushpin in the View Message Window**

The View Message window has a pushpin that you can use to pin the window to the workspace if you want to keep a message (or several messages) visible.

If you do not pin the View Message window, it is reused for subsequent mail messages that you view. If you do pin the View Message window, a new View Message window will be displayed for the next message you view, and you can display multiple View Message windows at the same time.

**Viewing the Next or Previous Message**

You can view the next message by clicking SELECT on the View button, then on the Next button. If the View Message window is displayed but not pinned, the next message is displayed in the existing View Message window.

**Note** – You must display the View menu and choose Next. Also note that the Next button is a custom button, and may not be available on the header control area if you have changed the value of this custom button.
To display the previous message, choose Previous from the View menu. You can also use the up and down arrow keys on your keyboard to display the previous and next messages. The Mail Tool Header window must be the currently active window for this to work.

Alternatively, you can always view any message by double-clicking SELECT on the desired message header.

**Viewing Messages With a Full Header**

Mail Tool messages are normally displayed with an abbreviated header. To display a message with the full message header, select the desired message header and choose Full Header from the Messages submenu of the View menu. Figure 4-5 shows an example of a full message header.

![Mail Tool: View Message 7](image)

```
From: maria@celtic Thu Feb 18 11:50 PST 1983
Return-Path: celtic@sun.com
Received: from celtic.eng.sun.com by relay.eng.sun.com (5.6/SMD-S/4.1)
Id: 62732562 Thu, 10 Feb 93 11:36:10 PST
Received: by celtic.eng.sun.com (4.1/SDE-3.1)
Id: 62732562 Thu, 10 Feb 93 11:36:10 PST
Date: Thu, 10 Feb 93 11:36:10 PST
From: maria@celtic (Maria A. Chereno)
Message-Id: <6273256266.AA4215@celtic.eng.sun.com>
To: oeg abundant
Subject: Project Schedule
Content-Type: text/plain
In-Reply-To: 75
Status: RO
Content-Length: 2010

Here's the latest Project Schedule.

```

**Figure 4-5** Full Message Header

The contents of the abbreviated header are determined by the Hide items on the Message Window Properties scrolling list. All mail headers are displayed except those listed in the Hide scrolling list. See “Message Window Properties” on page 199 for information about customizing your default abbreviated header with the Hide scrolling list.
Viewing Multiple Mail Messages

If you select multiple mail messages and display them by choosing Messages from the View menu, a View Message window is opened for each message, layered one on top of another in numerical order (not in the order that you selected them).

Another way to view multiple mail messages is to pin an existing View window, and then double-click SELECT on another mail message header. The new message will be displayed in a new View window.

Mail Tool Compose Window

Any time you choose an item from the Compose menu (except for Vacation), a Compose Message window is opened. (The Compose Message window is simply referred to as the Compose window in the rest of this document.) A Compose window operates independently from the Mail Tool Header window. You can close an opened Compose window to an icon for later use, or keep a Compose window open while the primary Mail Tool Header window is closed to an icon. The Compose window icon shows an unsealed envelope, a sheet of paper, and a label indicating the recipient of the message if the recipient has been specified. Figure 4-6 shows these views of the Compose icon.

![Compose Window Icon](Figure 4-6)

You can open as many Compose windows as you like at one time, while replying to or composing several messages concurrently. The Compose window is shown in Figure 4-7.
The Compose window has its own set of controls that you use to create and send mail messages:

- The Include menu button provides choices to include selected messages as part of the message you are composing. It also provides you with a set of templates for creating different types of messages. See "Template Properties" on page 210 for more information about templates. If you are not going to include any attachments, you can use the Include menu to turn off the Attachments pane at the bottom of the Compose Window, allowing recipients to see more of the mail message.

- The Deliver menu button provides choices for how the Compose window behaves once the message is sent.

- The Header menu button provides choices for the number and type of text fields that make up the message header. The default choice is Bcc, which allows you to add or delete the blind carbon copy (a copy of the message is sent to another recipient without the original recipient knowing) field to the message header. You can add other fields to this menu with the Custom Fields scrolling list in the Compose Window Properties sheet. See "Compose Window Properties" on page 200 for more information. The Aliases item brings up the Alias properties window.
• The Clear button clears the contents of the window. Your message is saved in the file `dead.letter` whenever you use the Clear button or the Clear message item from the Compose window’s Deliver menu. See the man page for `mailx(1)` for information about `dead.letter` and the “save” variable.

• The Attach menu button brings up Voice, which accesses AudioTool and allows you to compose a voice message. See Chapter 11, “Audio Tool” for information about Audio Tool. It also brings up Appt, an appointment editor window for creating appointments to be used with Calendar Manager. For information on how to do this, refer to Chapter 5, “Calendar Manager.”

• The Log check box determines whether or not the mail you are composing is recorded in a file. You specify the file where messages are recorded using the Mail Tool Properties window. See “Compose Window Properties” on page 200 for more information.

  The Log check box does not appear on the Compose window if you have not specified a log file name with the Compose Window properties.

• The To, Subject, and Cc text fields are used to type the email addresses of the recipients, the subject of the message, and the email addresses for those to receive copies of the message, respectively.

• The text pane of the Compose window is used to type the text of the message you want to send. The text pane uses the standard text editing conventions available from the Text Editor. See the chapter “Text Editor” on page 125 for more information about editing.

• The Attachments pane at the bottom of the Compose window is used to add attachments to your mail. Attachments can be any kind of file, and can be used to send images, voice mail, documents that retain their word-processor file formats, Calendar Manager appointments, and so forth. See “Mail Tool Attachments” on page 173 for information about mail attachments.
Reading Messages

You can tell you have new mail in two ways:

- If Mail Tool is closed, the Mail Tool icon shows the status. An overflowing in-box means you have new mail.
- If Mail Tool is open, new message headers, preceded by “N” (for New) are displayed in the Header window. Additionally, a counter in the lower right corner tracks the number of new messages.

To read a message, double-click SELECT on the message header.

The header you select is outlined, as shown in Figure 4-9, and the View Message window displays the message.
Figure 4-9  Message Headers in the Mail Tool Window

To read a message:

1. If Mail Tool is closed, double-click SELECT on icon.
   The Header window is displayed.

2. Double-click SELECT on the header of the message you want to read.
   The message is displayed in the View Message window.
Printing Messages

You can print your mail messages using either Mail Tool or Print Tool.

Printing Mail Messages Using Mail Tool

To print your messages from Mail Tool, select the headers for the messages you want to print, and choose Print from the File menu. Figure 4-10 shows these steps.

![Figure 4-10 Printing Multiple Mail Messages](image)

The messages are printed using the print script specified in the Message Window Properties sheet. See “Message Window Properties” on page 199.

If a message has attachments, the attachments are not printed. A message is printed that tells you how many attachments the message has.

To print an attachment, open the attachment and print it using the attachment’s application, or drag the attachment to the Print Tool.
Printing Mail Messages Using Print Tool

You can use Print Tool to print your mail messages using these steps:

1. **With both Mail Tool and Print Tool running, select the headers for the messages you want to print.**

2. **Press SELECT and drag the headers until the hot spot of the pointer is on the Print Tool drag and drop target.**
   The drag and drop target is the box in the upper left corner of the Print Tool window.

   The pointer changes to a document glyph if you are dragging one mail header to indicate that what is being dragged is document. The pointer changes to three document glyphs if you are dragging several mail headers. In the example shown in Figure 4-11, two files have been selected for printing.

3. **Release SELECT to drop the headers.**
   Messages are displayed in the footer of the Print Tool window displaying the printing status.
If a selected mail message has attachments, and the message is dropped on the Print Tool, the attachments are not printed. A message is printed that tells how many attachments are with the message. To print an attachment, open the attachment and print it using the attachment’s application, or drag just the attachment to the Print Tool.

**Composing Messages**

Your email address is typically your login ID and your machine’s host name, combined like this: name@host. If there is more than one domain on your network, you may need to append a domain name to the address as well. For instance, the name would appear in this format: name@host.domain. Check with your system administrator to make certain.

Others on your network will typically have the same address format. When you are certain of your email address, try sending a test message to yourself.

**Composing a New Message**

To compose a new message:

1. **In the Header window control area, click SELECT on Compose.**
   The Compose Message window is displayed.

2. **Click SELECT on the To text field, and fill in the message header information.**
   - Press Return as you complete each line
   - In the To and Cc text fields, separate multiple email addresses with a comma, a space, or both. For example:
     here@machine, there@elsewhere, outside@somewhere
   a. **Type the topic in the Subject text field, and press Return.**
   b. **If desired, type email addresses of carbon copy recipients in the Cc text field.**
      Separate the addresses with a comma, a space, or both.

3. **Move to the Text pane either by pressing Return or clicking SELECT in the Text pane.**
   The dimmed insert point darkens to indicate it is active.
4. Type your message.
   The Compose window Text pane uses standard text editing functions.

   Figure 4-12 shows a sample message.

   ![Figure 4-12 Addressing a Message](image)

   To include an attachment, see “Sending Mail Attachments” on page 176.

5. To send the message, click SELECT on Deliver.
   The message is delivered, and the Compose window closes.
Replying to a Message

Replying to a message is similar to composing a message.

1. In the Header window control area, press MENU on Reply.

2. Choose the appropriate item for your recipient(s).
The Compose Message window is displayed. Note the following:
   - The To and Subject text fields are filled out.
   - A copy of the original message is included only if you chose Reply To Sender, Include or Reply To All, Include.

3. Type or edit your message and its header, and send the message.
   Refer to the section “Composing Messages” on page 164.

Forwarding Messages to Third-Parties

You can forward a message to another person in two ways, depending on where you start from:
- Forwarding a message from the Header window.
- Including a message from the Compose Message window.

Forwarding a Message

To forward a message from the Header window:

1. Select the message(s) you want to forward.
   - Click SELECT on the first message header.
   - Click ADJUST on additional message headers.

2. Choose Forward from the Compose menu.
The Compose Message window is displayed. Note the following:
   - The Subject text field is filled in. You need to fill in the other To text field, and if desired, the Cc text field.
   - The Text pane displays the original message.
   - The Attachments pane includes any attachments to the original message.

3. Type your message, and send the entire new message.
   Refer to the section “Composing Messages” on page 164.
Including a Message

To include a message from the Compose window.

1. Compose your message.

2. In the Header window, click SELECT on the header of the message(s) you want to include.

3. In the Compose window, choose Bracketed or Indented (as you prefer) from the Include menu.
   
   Your choice determines the formatting of the original message:
   
   - Bracketed labels the beginning and end of the message.
   - Indented indents each line of the message and marks each line with a greater-than sign (>).

4. To send the message, click SELECT on Deliver.

Using Templates

A template is a file you can include in a mail message that contains text you frequently use when composing messages. Mail Tool allows you to create your own template files. You might, for example, want to create a standard table format for status report information or a standard signature and closing message. See “Template Properties” on page 210 for information about how to create and store templates. When you have created a template file and added it to Mail Tool, it is displayed as an item on the Templates submenu. The menu in the left margin shows a Templates submenu with three templates.

The default Templates submenu contains only the Calendar template. The Calendar template creates messages in a form that Calendar Manager interprets when the message header is dragged and dropped onto the Calendar Manager. See the chapter “Calendar Manager” on page 219 for more information.

Any template available from the Templates submenu can be added to a message at any time while you are composing it. When you choose the item from the Include menu, the template is inserted at the caret location.

Figure 4-13 shows an example of a signature template.
Using the Vacation Notifier

When you are away from your office, you can use the Vacation notifier on the Compose menu to automatically respond to each email message you receive. Mail Tool provides you with a generic message form that you can edit and customize to suit your individual needs. Figure 4-14 shows the Vacation Setup pop-up window with the generic message. Choose the Start/Change item on the Vacation submenu to display the Vacation Setup window.

You can edit this message in the same way you edit messages in the Compose window. The string $SUBJECT in the message text automatically extracts the subject from the message being responded to, and includes it in the reply.
message. The Precedence:junk line tells the mail delivery agent to set this mail to a lower priority and not to return any error messages to this mail message. Figure 4-15 shows an example of a vacation message that has been customized.

![Figure 4-15  Modified Vacation Message](image)

To start the vacation message, click SELECT on the Start button. The word “Vacation” is displayed in the header of the Mail Tool window to remind you that the vacation notifier is turned on.

While the vacation notifier is turned on, incoming mail messages are stored in your In-Box and are readily available when you return to the office. When the vacation notifier is turned on, it replies to each person who sends mail to you. Each sender receives a reply from the vacation notifier, but it replies to the same sender only once in each seven day period.

If your name is listed in a public alias and a message is sent to the alias, the vacation notifier does not respond to the sender of that message. The vacation notifier will respond to names included as part of a private alias. See “Alias Properties” on page 212 for information about mail aliases.

Once you have activated the vacation notifier, the Stop item on the Vacation submenu is also activated. To stop the vacation notifier and remove the word “Vacation” from the header, choose Stop from the Vacation submenu.
Deleting Messages

It is a good idea to periodically delete obsolete messages from your In-Box. To delete one or more mail messages, select the message headers that you want to delete, then choose Delete from the Edit menu. The selected mail messages are deleted from the display, and the status message in the footer updates to reflect the current state of your In-Box, as shown in the example in Figure 4-16.

Undeleting Messages

As long as you do not incorporate changes to Mail Tool by switching to another Mail File or by choosing either Save Changes or Done from the File menu, your deleted messages remain available and you can “Undelete” them.

When there are no deleted messages available, the Undelete item on the File menu is inactive.

To undelete the message most recently deleted, choose Undelete from the Edit menu.

To undelete a different message, or to undelete more than one message at a time, choose From List on the Undelete submenu to display the Undelete window. The Undelete window contains a scrolling list of messages that you
have deleted since you last incorporated changes in Mail Tool. Select the headers of the messages that you want to undelete, then click SELECT on the Undelete button.

To save your undeleted messages in your Inbox, click SELECT on Done in the Mail Tool Message window control area, or choose Save Changes on the File menu.

Finding Messages

To find messages, you can search your In-Box or mail files for messages with a particular subject, messages that have been sent to or from a specific person, or both. You can use this feature to find one particular message, or to find a group of messages. For example, if you come back from vacation and find a lot of mail messages about a topic you are not interested in, you can find all the messages about that subject and quickly delete them.

To find a message, first display the Find pop-up window by choosing Find from the View menu. The Find pop-up window is displayed, as shown in Figure 4-17.

You can search for messages based on the mail header’s From field, To field, Cc field, or Subject field, or by any combination of these fields. The Search text fields are case-insensitive and match partial words and phrases. You do not need to type a complete sender name, and you can use keywords to match subjects. For example, typing the name robles in the From text field will find messages sent by robles@oak as well as manual.robles.
To search for messages by sender, type the sender name in the From text field. Clicking SELECT on the Find Forward button selects the next message header with the sender name you specify. Clicking SELECT on the Find Backward button selects the previous message header. Clicking SELECT on the Select All button selects all message headers with the sender name. A message is displayed in the footer of the Find Messages window telling you how many messages are selected.

If you want to find mail sent to a person or alias either directly or by Cc list, type the name in the To/Cc field. If you only want to find mail sent directly to a person or alias (but not carbon copied), type the name in the To field. If you only want to find mail carbon copied to a person or alias (but not sent directly), type the name in the Cc field.

To search for messages by subject, type a word or phrase in the Subject text field.

To search for messages by sender, receiver, and by subject, type the appropriate information in each text field and click SELECT on one of the buttons at the bottom of the Find window. Only mail messages that satisfy all the conditions will be found.

Clicking SELECT on Clear removes all the text typed in the Find Messages window text fields.
Mail Tool Attachments

A mail message can contain attachments, which are files of any type in their own file formats. For example, a mail message might contain an image attachment and an audio attachment, providing an illustration and voice mail.

When a message contains attachments, the View Message pop-up window displays a separate Attachments pane at the bottom, as shown in Figure 4-18.

![Figure 4-18 View Message Pop-up Window with Attachments](image)

You can move attachments to the File Manager or any other application that accepts files of the attachment’s file type. You can also open the attachments without moving them out of the Mail Tool. You can add new attachments to a mail message, delete attachments, or rename them.
Opening Mail Attachments

There are two groups of mail attachments:

- Ordinary attachments, which are bound to their applications. You open them (and their applications) directly from the Attachments pane. For example, Calendar Manager appointments, mail messages, icons and images, voicemail, and executable files.

- Special attachments, which are not bound to their application. You cannot open these files directly from the Attachments pane. For example, specially-formatted text files created with desktop publishing software.

Note – If there are more attachments than can be displayed in one row, you need to scroll down with the Attachments pane scrollbar to see all the files.

Opening Ordinary Attachments

To open most attachments:

♦ Double-click SELECT on an icon in the Attachments pane.
  “Launching...” appears in the message area beneath the Attachments pane, and in a moment the application opens, and the file is displayed.

Caution – When starting an executable from the Mail Tool Attachments pane, you receive a warning message asking if you want to run the executable program or cancel. Before you click SELECT on “Run it,” make sure you know what the outcome will be and that the sender is someone you trust. Executables such as shell scripts can be used to perform operations on the files in your file system.

Figure 4-19 shows a mail message with a voice mail attachment opened up in the AudioTool application. See the chapter “Audio Tool” on page 341 for information about using AudioTool to listen to the message.
Viewing Special Attachments

You will need access (on your system or file server) to the software used to create the attachment. Also, you probably need to be running the same version of the software. If you do not have access to the correct software, you might want to request that the sender convert the file into PostScript format and resend the file.

To view specially-formatted text files:

1. **Copy the attachment into File Manager.**
   See “Moving Mail Attachments” on page 180.

2. **Open the file from the application in which the file was created.**
   Consult the user manual that came with the application for details.
Sending Mail Attachments

To include attachments in a mail message you are composing, select the file icons that you want to include from the File Manager, and drag and drop them onto the Attachments pane of the Compose window. You can also drag and drop files or data from the Text Editor or any other application that supports drag and drop.

Alternatively, you can use the Attachments pane Add Attachments popup to include attachments in your message, as described in “Adding Mail Attachments” on page 178.

Follow these steps to drag and drop a file from the File Manager onto Mail Tool to be included in a mail message:

1. Open the File Manager application and the Mail Tool Compose window of the message you are sending.
   If the Attachments pane is not showing at the bottom of the Compose window, choose Show Attachments from the Compose window Include menu.

2. In the File Manager, click SELECT on the file that you want to include as a mail attachment.
   Click ADJUST on any additional files that you want to include.

3. Press SELECT on one of the highlighted files, and drag the pointer to the Attachments pane of the Compose window, as shown in Figure 4-20.
   The pointer changes while the file is being dragged.
4. Release SELECT.

The file is displayed in the Attachments pane as an icon, and will be included as part of the mail message.

**Note** – If you drag and drop a file onto the text area of the Compose window, the file is included in the text as ASCII text. Some types of files, such as binary program files, are unreadable in the text pane. If you want to include the file as a separate attachment in its native format, make sure to drag and drop the file onto the Attachments pane.

If you drag data that is not a file onto the Attachments pane, the name of the icon that appears in the Attachments pane is the data type. For example, if you want to drag and drop the text in the Text Editor pane, you can press SELECT on the drag and drop target that appears in the Text Editor header, drag the pointer to the Compose window Attachments pane, and release SELECT. The new icon in the Attachments pane is named “default.”

---

Figure 4-20  Selecting a File for dragging onto the Compose Window Attachments Pane
Adding Mail Attachments

You can add new mail attachments to a message using drag and drop, as described in the previous section, or the Add Attachment pop-up window.

**Note** – Keep in mind that when you add attachments to a mail message, it is easy to construct very large messages without realizing it.

To add a new mail attachment using the Add Attachment popup window, follow these steps:

1. **Choose Add from the File menu at the top of the Attachments pane.**
   The Add Attachment popup window is displayed.

2. **Select the directory name of the file to be attached.**
   Alternatively, you can type the path in the Go To text field.

3. **Click SELECT on the Add button,** as shown in Figure 4-21.

---

**Figure 4-21** Adding an Attachment with the Add Attachment Popup Window
The file is added to the mail message attachment pane, as shown in Figure 4-22.

![Figure 4-22 Attachment Added to a Mail Message Attachment Pane](image)

**Renaming Mail Attachments**

Follow these steps to rename a mail attachment in the View Message or Compose window Attachments pane:

1. **Select the attachment that you want to rename.**
   You can only rename one attachment at a time.

2. **Choose Rename from the Edit menu at the top of the Attachments pane.**
   The Rename Attachment popup window is displayed.

3. **In the Rename Attachment popup window, type the new attachment name in the Name text field and click select on the Rename button, as shown in Figure 4-23.**
   The attachment in the Attachments pane is renamed.
Figure 4-23  Renaming an Attachment in the Rename Attachment Popup Window

Note – The name of an attachment should never contain the slash (/) character. This can cause confusion between file and directory names.

Moving Mail Attachments

You can drag and drop attachments to the File Manager, or any other application that accepts files of the attachment’s file type. See “Using Drag and Drop with Mail Tool” on page 192 for more information.

Alternatively, you can use the Attachment pane’s controls to copy an attachment to a directory:

1. In the Attachments pane, click SELECT on the attachment to be copied. The file is highlighted.

2. In the control area of the Attachments pane, choose Save As from the File menu. You see the Mail Tool: Save Attachment As popup window, as shown in Figure 4-24.
a. Select the directory and filename to be moved. Alternatively, you can type the directory name in the Directory text field.

b. Click SELECT on the Save button.
A copy of the file is stored in the specified directory, with the file name derived from the name of the attachment.
Deleting Mail Attachments

To delete attachments from a message in the View or Compose window, select the attachment or attachments you want to delete and choose Delete from the Edit button in the control area of the Attachments pane.

Use the Undelete item to restore the most recently deleted attachment. This item is grayed out if there are currently no deleted attachments.

Saving Changes for Mail Tool

To improve system performance, Mail Tool does not automatically save changes that you make when you close it to an icon. Messages that you have deleted remain available to you when you open the Mail Tool Header window.

To free up disk space and keep your mail box a manageable size, it is a good idea to periodically delete obsolete messages and save changes.

You save changes using either Save Changes or Done from the File menu.

- Use Save Changes to commit changes and incorporate new mail without closing the primary Mail Tool Header window.
- Use Done to commit changes, close the primary Mail Tool Header window to an icon, and incorporate new mail the next time you open the icon. Using Done leaves Mail Tool in a condition that lets you read mail using another mail program without creating conflicts in the mail spooling files.

Mail Tool automatically checks and incorporates new mail messages using a time period specified from the Mail Tool Properties window. If you have a long time period set and want to see if you have new mail, you can use Load In-Box from the File menu. Choosing either Save Changes or Done also checks for new mail messages. See “Customizing Mail Tool” on page 194 for more information about Mail Tool properties.

When you quit the Mail Tool application, a Notice is displayed, as shown in Figure 4-25, asking you whether you want to save changes, quit without saving changes, or cancel the quit notice.
Choosing Save Changes commits the changes and quits Mail Tool. Choosing Discard Changes discards changes, reincorporating any deleted messages as part of the In-Box, and quits Mail Tool. Choosing Cancel cancels the quit operation, and leaves Mail Tool running.

Organizing Your Mail Messages

A convenient way to organize your mail is to group related messages together in a mail file. A mail file is a file that can contain multiple mail messages. If you view a mail file outside of Mail Tool, it looks like a single file with multiple mail messages appended to one another. When you view a mail file using Mail Tool, each separate message header is displayed in the header pane, and you can view, edit, delete, and respond to each message individually.

You can use the Mail Files pop-up window to create, delete, and rename mail files and subdirectories of mail files, to add messages to mail files, or to view mail files. To display the Mail Files window, shown in Figure 4-26, choose Mail Files from the File Menu.
Figure 4-26  Mail Files Window

The Mail Files popup window contains a scrolling list of all your mail files (or mailfolders). There are three groups of entries listed in the mailfolder scrolling list, as follows:

- Double-click SELECT on that entry to display the mail files up one directory level.
- The next entries in the mailfolder scrolling list are your subdirectories (or folders) of mail files. You can double-click SELECT on these entries to display the mail files of each subdirectory.
- The last entries in the mailfolder scrolling list are the regular mail files that you can load or save messages to.

You specify the directory where the mail files reside in your file structure using the Mail Filing category in the Properties window. See “Mail Filing Properties” on page 206 for more information. Any mail files that you create in this directory are displayed as items in the Mail File menu on the Header window control area (described in the section “Mail File Menus” on page 185). The default mail file directory is your home directory. If you want to specify a different directory, it’s a good idea to do so before you create new mail files.

In addition to using the Mail Files window, you can also create new mail files, add messages to mail files, or view a mail file using the Mail File menu and the Move, Copy, and Load menus on the Mail Tool Header window control area. These menus are described in the next section.
Mail File Menus

The Mail File menu of the Header window contains a list of files and subdirectories in your mail file directory, as shown in Figure 4-27. Use this menu as an easy way to fill in the name of a mail file in the Mail File text field.

![Figure 4-27 Mail File Menu Showing Mail Files and Subdirectories of Mail Files](image)

As you access a mail file, it is added to the Move, Copy, and Load menus of the Header window. Each of these three menus contains an identical list of recently accessed mail files. The first item on each menu is the entry in the Mail File text field. If no entry is in the text field, the first item is called Entry, and is dimmed. Figure 4-28 shows a Copy menu after several mail files have been accessed, and when there is an entry in the Mail File text field.

![Figure 4-28 Copy Menu with the Most Recently Accessed Mail Files](image)
If you have a set of mail files that you want to always appear on the Move, Copy, and Load menus, you can specify these files in the Mail Filing category of the Properties window. You can also control the maximum height of these menus. See “Mail Filing Properties” on page 206 for information.

Creating a New Mail File

You can create a new mail file using only the controls on the Header window, or using the Mail Files popup window.

Creating a New Mail File Using the Header Window Controls

Follow these steps to create a new mail file using only the Header window controls:

1. Select one or more messages to move or copy to the new mail file.

2. Type the name of the new mail file in the Mail File text field on the Header window, and then click SELECT on the Move or Copy button. When you just type a file name, such as projectreports, Mail Tool puts the mail file in the Mail File directory that you specify from the Mail Filing Properties window. Alternatively, you can type a complete path name, such as /home/username/projects/projectreports, to put the mail file somewhere else in your file structure, or you can type a relative path name, such as projects/projectreports, to put the mail file in a subdirectory of your Mail File directory.

   The new mail file becomes the first and default item of the Move, Copy, and Load menus.

3. Click SELECT on the Move or Copy button.

   The new mail file is created, the selected messages are moved to the new file, and a message is displayed in the footer of the Header window.

Creating a New Mail File Using the Mail Files Popup Window

Follow these steps to create a new mail file using the Mail Files popup window:

1. Choose Mail Files from the File menu to display the Mail Files popup window.
2. **Type the name of the new mail file in the Name text field.**
   For example, type `projectreports` to create a project report mail file, as shown in Figure 4-29.

![Figure 4-29](image)

Figure 4-29  New Mail File Typed in the Mail Files Name Field

You can also type the name of a new mail file subdirectory if you’d like to create a subdirectory of mail files.

If you already have a subdirectory where you want to put the new mail file, you can type a relative path name in the Name field, starting with the subdirectory. For example, type `projects/projectreports` to create a mail file in the subdirectory called `projects`. Alternatively, you can double-click SELECT on the `projects` subdirectory in the scrolling list to display that mail directory, and then type the name of the new mail file in the Name field.

3. **Choose Mail File or Directory from the Create menu to create the new mail file or subdirectory.**
Adding Messages to an Existing Mail File

You can add messages to an existing mail file using only the controls on the Header window, or using the Mail Files pop-up window. Both of these methods are described in the following sections.

Adding Messages to a Mail File Using the Header Window Controls

Follow these steps to add messages to a mail file using only the controls on the Header window:

1. Select the mail headers that you want to move or copy to the mail file.
2. Move or copy the selected messages to an existing or new mail file as follows:
   a. If the desired mail file already exists and is listed in the Move and Copy menus, simply choose the mail file from the Move or Copy menu.
   b. If the desired mail file already exists but is not listed on the Move and Copy menus, choose the desired mail file from the Mail File menu, and then click SELECT on the Move or Copy button.
      The new mail file becomes the first and default item of the Move, Copy, and Load menus.

Adding Messages to a Mail File Using the Mail Files Popup Window

Follow these steps to add messages to a mail file using the Mail Files window:

1. Select the headers of the mail messages that you want to move or copy.
2. Choose Mail Files from the File menu to display the Mail Files window.
3. Select a mail file in the Mail Files window scrolling list.
   If the desired mail file is in a subdirectory, double-click SELECT on the subdirectory to display its contents in the scrolling list.
4. Choose Move Message into Mail File or Copy Message into Mail File from the Save menu.
   The selected messages are moved or copied to the selected mail file.
Viewing a Mail File

You can view the messages stored in a mail file using either the Mail Files window or the Load menu of the Mail Tool Header window. Once the mail file is loaded, you access the messages of the mail file exactly the same way as you access the messages of your In-Box.

To return to the In-Box after you are done viewing a mail file, choose Load In-Box from the File menu.

Viewing a Mail File Using the Header Window Controls

Follow these steps to view the messages in a mail file using the Header window controls:

1. If the desired mail file is not already on the Load menu, choose the desired mail file from the Mail File menu. Alternatively, you can type the name of the mail file in the Mail File text field.

2. Choose the mail file from the Load menu on the Mail Tool Header window. If the desired mail file is listed in the Mail File text field, you can just click SELECT on the Load button.

Viewing a Mail File Using the Mail Files Window

Follow these steps to view mail file messages using the Mail Files window:

1. Choose Mail Files from the File menu to display the Mail Files popup window.

2. Select the mail file that you want to view on the Mail Files popup window scrolling list. If the desired mail file is in a subdirectory, double-click SELECT on the subdirectory to display its contents in the scrolling list.

3. Choose Mail File from the Load menu. The mail file is loaded into the Mail Tool Header window. Alternatively, you can just double-click SELECT on the mail file in the Mail Files scrolling list to load that mail file.
Editing a Mail File (Emptying, Renaming, Deleting)

You can empty a mail file, rename it, or delete it with the Edit menu of the Mail Files window.

To empty, rename, or delete a mail file, you first need to select the mail file in the scrolling list on the Mail Files window. If the mail file is in a subdirectory below the one displayed on the scrolling list, double-click SELECT on that subdirectory to display it. If the mail file is in a directory higher up from the one displayed in the scrolling list, double-click SELECT on the .. (Go up one folder) folder item until the mail file is in the scrolling list. When the mail file is in the scrolling list, click SELECT on the mail file to select it.

To delete a mail file, select the mail file in the Mail Files scrolling list, then choose Delete from the Edit menu. Mail Tool will give you a notice asking you to confirm that you really want to delete the mail file.

To empty a mail file, select the mail file in the Mail Files scrolling list, then choose Empty from the Edit menu. Mail Tool will give you a notice asking you to confirm that you really want to empty the mail file.

To rename a mail file, select the mail file in the Mail Files scrolling list, type the new name in the Name field, and then choose Rename from the Edit menu.

Sorting the Contents of a Mail File

You can sort items in your In-Box or the currently viewed mail file by choosing an item from the Sort By submenu of the Header window View menu:

- Sort by time and date of receipt, placing the most recently received messages at the bottom.
- Sort alphabetically by name of sender. This is useful for grouping together all the messages from a particular person.
- Sort alphabetically by subject of mail, to group together all the messages about a particular subject.
- Sort by the size of mail messages, from smallest to largest.
• Sort by the “read” status of the mail. This puts the messages you have read first, the unread messages next, and the new messages last. This is useful to group together all your unread mail after you have read your messages in a non-sequential order.
• Sort by the message numbers.

Loading Saved Messages Back into Mail Tool

You can load saved messages back into the Mail Tool base window and view them as you would new mail messages. When you load previously saved messages, they temporarily replace the current messages contained in your in-box.

Loading a Message from the Mail Files Directory

If the message you want to view is in the default Folder directory:

1. Press MENU on the abbreviated menu button to the left of the Mail File text field.
   A menu pops up listing the messages in the Folder directory.
2. Drag the pointer to the message you want to load, highlight it, and release MENU.
3. Choose Load.
   All messages saved to that file appear in the Mail Tool base window as separate messages, just as they did when first received in the In-Box.

Loading a Message from Another Directory

To load a message saved to another directory:

1. In the Mail Tool base window, type the path to the message file in the text field.
   Use the same path that you used to store it initially.
2. Choose Load.
   All messages saved to that file name appear in the Mail Tool base window as separate messages, just as they did when first received in the In-Box.
Alternatively, you can drag a file of saved mail from File Manager and drop it onto the Mail Tool base window. The message or messages in that file will appear in the base window just as they did when you first received them. This method is especially helpful if you have forgotten the path to the file.

**Loading the In-Box**

To reload your In-Box messages:

♦ **In the Header window, choose Load In-Box from the File menu.**
  All of the message headers in the In-Box are again displayed in the Mail Tool Header window.

**Using Drag and Drop with Mail Tool**

You can use the OpenWindows drag and drop capability to drag mail messages out to other applications, and to drop information from other applications onto your Compose window to be included as text or as a separate attachment. This section gives an overview of the ways you can use drag and drop with Mail Tool and the other DeskSet applications described in this guide.

**Dragging Mail to Other Applications**

You can select single or multiple headers in the Mail Tool window and drag them to other DeskSet applications. When you drag a mail header, the entire mail message is moved along with it, including any mail attachments.

You can also select single or multiple mail attachments and move just the attachments to other applications.

**Dragging Message Headers to Other Applications**

You can drag and drop message headers onto the File Manager, Text Editor, Print Tool, Calendar Manager, or any other application that accepts files via drag and drop.
To drag and drop a copy of a mail message, select the message header, then drag the pointer to the destination. A small Text file glyph moves with the pointer to show that you are dragging a Text file, as shown in the example in Figure 4-30. When you select multiple message headers, a group of Text glyphs is dragged with the pointer.

Figure 4-30  Dragging a Copy of a Message Header

You can schedule appointments in Calendar Manager by using the Appointment Editor Attachment. See the Chapter 5, “Calendar Manager” for more information.
Dragging Attachments to Other Applications

You can drag individual attachments onto the following destinations:

- File Manager
- Print Tool (See “Printing Mail Messages Using Print Tool” on page 163.)
- Any application that accepts drag and drop data of the attachment’s file type. For example, you can drag audio attachments onto AudioTool, Icon Editor attachments onto Icon Editor, ASCII attachments onto Text Editor, and so forth.
- A Calendar Manager appointment attachment to Calendar Manager.

To drag and drop attachments onto other applications, follow these steps:

1. Click SELECT on the attachment to be copied.
   Click ADJUST on any additional attachments that you want to drag at the same time.

2. Press SELECT on one of the highlighted attachments, drag the pointer to the destination, and release SELECT.

Dropping Files onto the Mail Tool

The Mail Tool Compose and View windows accept dropped files from the File Manager and Text Editor in the text panes. The Compose and View windows accept dropped files of any type in the Attachments pane. See the section “Sending Mail Attachments” on page 176 for more information.

The Header window pane accepts dropped mail files. When you drop a mail file onto the Header pane, it is loaded into the Mail Tool and becomes the current mail file.

Customizing Mail Tool

You can customize the properties of Mail Tool from the Mail Tool Properties window. Display this window by choosing Properties from the Edit menu.

The Properties window has seven categories: Header Window, Message Window, Compose Window, Mail Filing, Template, Alias and Expert properties.
To display a particular category of properties, choose the category from the Category menu located at the top of the Properties window. When you release MENU, the contents of the Properties window shows the properties you can set for that category. The new properties take effect immediately in most cases. In a few cases (such as number of Headers to display in the Header Window Properties), you must quit and restart Mail Tool before the changes take effect.

You must apply changed properties for each category by clicking SELECT on the Apply button.

**Header Window Properties**

The Header Window properties are shown in Figure 4-31 and described in the following sections. After you change any of the Header Window properties, click SELECT on the Apply button to apply them to the Mail Tool application.

![Header Window Properties](Figure 4-31 Header Window Properties)
Mail Arrival Properties

Use the Retrieve Every field to determine how often new mail is retrieved. The default value is 300 seconds, or 5 minutes. You can retrieve mail at any time between this interval by choosing Load In-Box or Save Changes from the File Menu.

Use the Signal With fields to determine how Mail Tool signals new incoming mail. The Beep setting causes Mail Tool to beep the specified number of times. The Flash setting causes the icon to flash or the Header window to flash, depending on whether the Mail Tool is closed to an icon or open.

Mail Tool Window Size

Use the Display Headers field to determine how many headers are displayed in your primary Mail Tool Header window. You can increase the setting to display more headers at one time, or decrease the setting to display fewer headers to make the Header window smaller.

Use the Display Characters field to determine the width of all Mail Tool panels and windows.

After you make changes to the Display fields, you need to quit the Mail Tool application and restart it in order to see the change.

Delivery Properties

If you want Mail Tool to automatically display the headers for incoming mail messages, check the Automatically Display Headers option. If you do not choose this option, Mail Tool does not display headers for incoming messages unless you specifically request them by choosing Load In-Box or Save Changes from the File menu.

If the Show “To: recipient” ... option is checked, the Mail Tool header of a message sent by you will display the recipient of the message instead of your mail address.
Mail Tool Custom Buttons

The first four buttons on the second row of the Mail Tool Header window are custom buttons. You can change the value of these buttons to be any of the items from the File, View, Edit, or Compose menus. If there are items on these menus that you use very frequently, you can change your custom buttons to activate those commands.

- The Custom Buttons choices indicate the current value of the four custom buttons. You select one of these choices to change the value of that custom button.
- The Command setting shows you the command of the currently selected button, that is, what the button does.
- The Command menu button provides a menu of all of the available commands from the File, View, Edit, and Compose menus.
- The Label text field determines what the custom button says. Usually this is the same as the command, but it doesn’t have to be. Sometimes the command is too long to fit in the button, so the Label might be an abbreviation of the actual command.

To change the value of a custom button, follow the steps below.

1. Select the Custom Buttons choice that you want to change.
   The first choice represents the first button on the second row of the Header window, the second choice represents the second button, and so on.

2. Choose the desired command from the Command menu shown in Figure 4-32.
   The first column in the Command menu displays all the choices available from the Mail Tool File menu, the second column displays the choices from the View menu, the third displays the choices from the Edit menu, and the last column displays the choices from the Compose menu.
3. If you want to select a new label to go with the selected command, type a new label. Try to keep the label as small as possible in order to keep the custom button to a reasonable size.

4. Click SELECT on Apply to change the custom button in the primary Mail Tool Header window. The custom button on the Mail Tool Header window is changed to the new label and command. Figure 4-33 shows the Header window with the second custom button changed to Print.
Message Window Properties

You use the Message Window Properties to specify the number of lines in the View Message pop-up window text pane, a different print script for printing messages, and the headers that are not displayed when viewing a message with abbreviated headers.

To see the Message Window Properties, shown in Figure 4-34, choose Message Window from the Category menu at the top of the Properties popup window.

![Figure 4-34 Message Window Properties](image)

- The Display field determines the number of Lines of Text displayed in each View Message or Compose window text pane. After you make a change and click SELECT on the Apply button, you will need to quit the Mail Tool and start it again for this change to take effect.
The Print Script field determines the script used to print your messages via the Print item on the File menu or the header pane pop-up menu. The default print script is `lp -s`.

The Hide scrolling list determines which headers are not displayed when you view your messages with abbreviated headers. You can add any header to this list by typing the header in the Header Field text field, and clicking SELECT on the Add button.

Use the Add menu to place the header either before or after the currently selected header. Use the Delete button to delete the currently selected header, and use the Change button to change the currently selected header to the text typed in the Header Field text field.

Some of the headers that you might commonly want to hide are displayed in the scrolling list in Figure 4-34. You can add any header to the Hide list that you see when viewing messages. You can type the header in any case. For example, adding the header “content-length” hides the headers “Content-Length”, “content-length”, “CONTENT-LENGTH”, and so forth.

When you have changed Message Window properties, click SELECT on the Apply button. The Print Script and Hide property settings become effective immediately.

**Compose Window Properties**

You use the Compose Window Properties category to customize items on the Compose window. To see the Compose Window Properties, shown in Figure 4-35, choose Compose Window from the Category menu at the top of the Properties popup window.
Included Text Marker

Use the Included Text Marker field to specify the characters that precede each line of an included text message. The default value is “>”. This puts the right-arrow character at the start of the included message when you choose Indented from the compose window Include menu. Tabs are not accepted as an indent character (but spaces are). Figure 4-36 shows the Compose window with an included message indented with “>”.

Note – The right angle bracket is at the start of the included message when you select Reply to Sender, Include or Reply to All, or Include from the compose menu in the Header window.
Figure 4-36 An Indented Included Message

Logged Messages File for Outgoing Mail

If you want to log outgoing mail messages in a file, type the name of the desired log file in the Logged Messages File text field of the Compose Window Properties Category. If a log file name is specified, a Log check box appears on the Compose window, as shown in Figure 4-36 above. When the Log option is checked on your Compose window, the message is logged in the log file when it is sent.

Use the Log all messages setting on the Compose Window Properties Category to determine whether the Log checkbox on the Compose window is checked by default.

Viewing the File of Logged Messages

To view the messages you have logged, do the following:

1. In the Mail Tool base window, type the name of the file in which you have logged your messages in the text field.
   Using the example above, for instance, you would type ~/.record.
2. **Click SELECT on the Load button.**
   The messages you have logged will appear in your Mail Tool Base window (in place of the current mail messages), and each has the message header.

**Request Confirmations**

If the Request Confirmations setting is checked, a Notice is displayed in the following cases:

- When you have text or attachments in the Compose window, and you select Clear on the Compose window control panel, a message is displayed asking if you really want to clear the Compose window.

- When you have text or attachments in the Compose window, and you quit the Compose window, a confirmation message is displayed asking if you really want to quit.

- When you have made changes to a message in the View window, and you then display a new message, unpin the View window, or receive new incoming mail, a message is displayed asking if you want to save the changes.

**Caution** – If the Request Confirmations setting is not checked, any editing changes in the View window are automatically incorporated without notification. If you remove or change the From header of a message. The message that lost the From header will appear to be lost. You can find it appended to the previous message.

**Show Attachment List**

By default, a Compose window includes a pane at the bottom of the text area where you can add attachments to your message. If you never or rarely use attachments, you can turn off the Attachments pane for new Compose windows. Use the Show Attachment List setting of the Compose Window Properties Category to determine if the Attachments pane is shown by default.

If you turn off the default Show Attachments List setting, you can display the Attachments pane on an as-needed basis by choosing Show Attachments from the Include menu of the Compose window.
Compose Window Custom Header Fields

The header of your Compose window always has To, Subject, and Cc fields. In addition, Bcc is available via the Header menu. You can add custom headers to the Header menu by adding them to the Custom Fields scrolling list on the Compose Window Properties category.

Some useful headers that you might want to use are the following:

- **Precedence: junk** — If the mail system cannot send a message with this header, the message will not be “bounced” back to you. This is handy if you are sending out a message to a large alias, and you do not wish to receive notices whenever the message cannot be delivered to an individual.

- **Reply-To: email address** — When you reply to a message with this header, the reply is sent to the email address in the Reply-To: header field (instead of being sent to the sender of the message).

- **Return-Receipt-To: email address** — When you send a message with this header, you will receive a “Return Receipt” from the mail system when the message is successfully delivered.

To create a custom header field, follow these steps:

1. **Type the label for the field in the Header Field line of the Properties window.**
   Do not type a colon following the label. The colon is automatically provided by Mail Tool.

2. **If you want the field to be filled in with a default value, type this value in the Default Value field.**

3. **Choose either Before or After from the Add menu to add the new header field to the scrolling list.**

4. **To apply the change to Mail Tool, click SELECT on the Compose Window Properties Apply button.**

5. **To include the new header field in a mail message, choose the item from the Compose window Header menu, as shown in the menu at the left.**
   Figure 4-37 shows an example of a custom header field added to the Compose window.
Automatically Storing Copies of Messages You Send

You can set up Mail Tool so that you record a copy of each email message you send. To do this, follow these steps:

1. **From the Mail Tool base window, choose Edit ➤ Properties.**
   A Properties window appears.

2. **In the Properties window, position the pointer on the abbreviated menu button labeled Category, and choose the Compose Window category.**
   The properties choices for the Compose Window appear in the Properties window.

3. **In the text field labeled Logged Messages File, type the name of a file in which you would like to log copies of your mail messages.**
   For instance, to save the mail in an invisible file in your home directory, you could name the file \$HOME/.mail.save.

**Note** – \$HOME is a variable that points to your home directory. You can also use the tilde (~) symbol to indicate your home directory.
4. Click SELECT on the Apply button at the bottom of the Properties window.

Now, when you send a message, a copy is logged in the file you created; additional messages you send are appended to the end of the file.

**Mail Filing Properties**

You use the Mail Filing Properties category to choose where your mail files are stored, and to customize the Move, Copy, and Load menus of the Mail Tool Header window. To see the Mail Filing Properties, shown in Figure 4-38, choose Mail Filing from the Category menu at the top of the Properties popup window.

![Mail Filing Properties](image)

*Figure 4-38  Mail Filing Properties*
Mail File Directory

Use the Mail File Directory text field to specify the directory where mail files are stored when you move or copy messages from your In-Box to mail files. For example, you might want to name the directory mail, maildir, or mail_files. Unless a full path name is specified, the directory is considered a subdirectory of your home directory. If the directory name you specify does not exist, a Notice is displayed asking if you want to create the directory when you click SELECT on the Apply button. See “Organizing Your Mail Messages” on page 183 for more information about using the Mail File directory.

Mail File Move, Copy, and Load Menus

The Move, Copy, and Load menus on the Mail Tool Header window display up to 10 of the most recently accessed mail files. You can change the maximum number of files on the menus with the Display Up To setting of the Mail Filing Properties category. Click SELECT on Apply after changing the setting. When you start up a new Mail Tool application, the Move, Copy, and Load menus are empty. Mail files are added to these menus as you access the mail files. You can specify mail files that you always want to appear at the top of these menus by adding them to the Move, Copy, Load Menus scrolling list. You can add any mail file to this list by typing the name of the mail file in the Permanent File text field, and clicking SELECT on the Add button.

Use the Add menu to place the mail file either before or after the currently selected mail file. Use the Delete button to delete the currently selected mail file, and use the Change button to change the currently selected mail file to the mail file typed in the Permanent File text field. See “Organizing Your Mail Messages” on page 183 for more information about using mail files.

When you have changed Mail Filing properties, click SELECT on the Apply button.

Saving Mail to Another Location

You can save mail to any location in your file system by typing in an absolute pathname. This means that the location you specify is an exact location within your file system rather than one that is relative to the Folders directory.
Saving to an Absolute Path in Your Home Directory

To save mail to an absolute location in your home directory, you can precede the path with the variable $HOME, or with the tilde (~) on your keyboard, followed by your user account name (or that of another user’s home directory where you have write permission). The tilde indicates the top level of your home directory.

To save a mail message in a location under your home directory, follow the instructions in the section “Saving Mail to the New Default Location” on page 210, but use the form in one of the examples below to type the path on the Mail File text field:

```
~username/Subdirectory/filename

$HOME/username/Subdirectory/filename
```

When you choose Move or Copy, the chosen mail file in your mailbox is stored in a file named filename in a subdirectory named Subdirectory under your home directory.

Saving to an Absolute Path Relative to the Root Directory

To save a mail message to an absolute location starting from the top level directory in your file system, you use a slash (/) to indicate the root directory, and follow that with an absolute path.

To save a mail message in a location under your root directory, follow the instructions in the section “Creating a New Mail File” on page 186, but use the following form on the Mail File text field:

```
/Subdirectory/filename
```

where / is the root directory, and Subdirectory is an existing directory under root.

For example, you could type:

```
/tmp/myfile
```

The /tmp directory is a directory that contains some system files.
Caution – You should only use the /tmp directory for temporary file storage. When you reboot your system, these files will be purged.

When you choose Move or Copy, the chosen mail file in your mailbox is stored in a file named myfile in the subdirectory named tmp under the root directory.

Modifying the Default Location

Using Mail Tool’s Properties window, you can permanently change the default location for your saved mail. For instance, you could change the name of the Folders directory, or you could save your mail to a location directly relative to your home directory.

To change the default location for your saved mail, follow these steps:

1. From the Mail Tool base window’s control area, choose Edit ➤ Properties. The Mail Tool Properties window appears.


3. Double-click SELECT on the word Folders on the text field. Folders is highlighted, for example.

4. Choose the default location for your saved mail:
   a. To change the name of the Folders directory type in a new name, such as Mail.
   b. To save mail directly under your home directory, type:

      $HOME

      This will expand to the actual path name of your home directory.

5. Click SELECT on the Apply button. A pop-up message asks if $HOME should be expanded to the path name of your home directory.

6. Click SELECT on the Expand String button. The Properties window is dismissed.
Saving Mail to the New Default Location

Saving mail messages to the new default that you have specified is just like saving mail to the Folders directory. To save mail, do the following:

1. **Type the file name, or a subdirectory name and then the file name, on the text field in the Mail Tool base window.**
   Note that if you have changed the default location to your home directory there is no need to type a tilde to specify your home directory as the destination.

2. **Click SELECT on the message you want to save.**

3. **Choose Move or Copy.**

The chosen mail message is saved to the directory name of your choice under your home directory (e.g. the directory name you substituted for Folders, the top level of your home directory, or a specified subdirectory).

Template Properties

Mail Tool allows you to create your own template files containing text that you frequently use for composing messages. Each template is an individual file that you create outside of Mail Tool, using any editor such as Text Editor or vi.

You can add a created template to Mail Tool using the Template Properties category, shown in Figure 4-39. Display the Template properties by choosing Template from the Category menu at the top of the Properties popup window.
To add a template to the Include Templates submenu of the Compose window, follow these steps:

1. Type the name of the template in the Name field on the Properties window.
2. Type the path and name of the file containing the template in the File field.
3. Choose Before or After from the Add menu.
4. Click SELECT on the Apply button.

The items in the scrolling list are added to the Templates submenu of the Compose window Include menu.

A Calendar template is automatically provided when you have no other templates installed. Otherwise, if you want to use the Calendar template you must add it to the Template menu yourself following the steps above. Your template can contain text to be included in a message, and it can also include header information. If you include header information, make sure that there...
are no lines in the template file before the header lines. Figure 4-40 shows an example of a template that contains both header information and text. Make sure there is at least one blank line between the header lines and the message text.

<table>
<thead>
<tr>
<th>To: mail-team</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subject: Staff meeting</td>
</tr>
<tr>
<td>It’s time for our staff meeting....</td>
</tr>
</tbody>
</table>

*Figure 4-40  Contents of a Template File with Text and Header Information*

To use a template, choose the item from the Templates submenu of the Compose window Include menu. The text from the template file is then displayed in the Compose text pane. If your template contains headers, the headers in the Compose window are automatically filled out.

To delete a template name, click SELECT on the name in the scrolling list of the Template Properties window, click SELECT on the Delete button, then click SELECT on the Apply button.

To change a template, click SELECT on the item in the Template Properties window scrolling list, type the new values in the Name and File text fields, click SELECT on the Change button, then click SELECT on Apply.

**Alias Properties**

You can create your own distribution lists containing groups of user names. Then, instead of typing a distribution list of many names, you can type the single name that you specify as the name of the alias in the To text field.

There are two kinds of distribution lists, or aliases, you can create:

- Private aliases that only you can use.
- Aliases in your `/etc/aliases` file that anyone can use. See “Creating and Using Public Aliases in `/etc/aliases`” on page 214 for information about this kind of alias.

You use the Alias Properties category, shown in Figure 4-41, to create your own private distribution list aliases. Display the Alias properties by choosing Alias from the Category menu at the top of the Properties window.
To add a private distribution list alias, follow these steps:

1. **Type the name of the alias in the Alias text field.**
   In Figure 4-41, the alias name is docgroup.

2. **In the Addresses field, type the email address of each person in the distribution list.**
   Separate each name by either a comma, a space, or both.

3. **Click SELECT on the Add button.**
   The item is added to the scrolling list in alphabetical order.

4. **Click SELECT on the Apply button.**
   The items in the scrolling list are added to your private aliases.

To use the alias, simply type the name of the alias (for example, docgroup) in the To, Cc, or Bcc line of the Compose Messages window. The names you typed in the field are expanded and included as part of the outgoing message. Use the Delete button to delete the currently selected alias, and use the Change button to change the currently selected alias to the text typed in the Alias Field text field.
Creating and Using Public Aliases in /etc/aliases

To create an alias that anyone can use, you must have root access to your system. Edit your /etc/aliases file using any text editor. Under the Local Aliases category, on a separate line, type aliasname:username,username. Separate each item with a comma and end the group with a Return. You can include a space after each comma, if desired.

Figure 4-42 shows an example of an alias group in /etc/aliases.

```
friends:albertmonkey, gene@sigoird, fred@skyhigh
```

To use the alias, type the name of the alias in the To, Cc, or Bcc line of the Compose Messages window. The names you typed in the field are not expanded as part of the outgoing message. The alias group itself is displayed as the user name when the message is received. To use an alias on someone else’s system, type the alias name, @, and their machine name in the To, Cc, or Bcc line of the Compose Messages window. For example, someone else could send mail to the “friends” alias in the example by typing friends@castle, because the “friends” alias is on the machine “castle”.

Expert Properties

You use the Expert Properties category to set some advanced mail defaults that are provided for mailx(1) compatibility. To see the expert default settings, shown in Figure 4-43, choose Expert from the Category menu at the top of the Properties popup window.
The expert settings determine what happens when you choose Reply to All or Reply to All, Include from the Compose menu.

These settings only apply when your email address appears in the To or Cc list of the message you are replying to.

The following sections describe what happens when these settings are checked or not checked. Only the names listed in parentheses are used below when referring to the options. That is, the options are called "metoo", "allnet", and use network aware mail file locking. These are the names used in the .mailrc file, as described in the mailx(1) manual page.
When Metoo is Checked

When the metoo option is checked, and your email address appears in the To or Cc field when you do a Reply to All, you will receive the reply. Your mail address is recognized in all forms that include your login address, such as yourname@machine and yourname@host. Where machine is the name of your machine and host is the name of any host that is not your machine.

For example, suppose you Reply to All to a message with the following header:

From: salmon@sea Fri Aug 23 10:36:21 1991
To: yourname@machine, yourname@host, tuna@ocean

Your reply will include the following To line:

To: yourname@machine, yourname@host, tuna@ocean, salmon@sea

When Metoo is Not Checked

If the metoo option is not checked, the message header of your reply depends on the allnet option. The allnet option determines whether your mail address is recognized in all forms that include your login address, or only in the form yourname@machine.

Note – The allnet option only has an effect when the metoo option is not checked.

When Allnet is Checked and Metoo is Not Checked

If the allnet option is checked and the metoo option is not checked, and you do a Reply to All, your address is not included in any form in the To or Cc fields of your reply.

For example, suppose you receive a message with this header:

From: salmon@sea Fri Aug 23 10:36:21 1991
To: yourname@machine, yourname@host, tuna@ocean

The To field of your reply would look like this:

To: tuna@ocean, salmon@sea
When Neither Allnet Nor Metoo is Checked

When neither the allnet nor the metoo options are checked, your email address is only included in the To and Cc fields of a Reply to All in the form yourname@host.

For example, suppose you receive a message with this header:

From: salmon@sea Fri Aug 23 10:36:21 1991
To: yourname@machine, yourname@host, tuna@ocean

The To field of your reply would look like this:

To: yourname@host, tuna@ocean, salmon@sea

When Use Network Aware Mail File Locking is Checked

Mail Tool tries to prevent two different instances of Mail Tool from opening the same mail file at the same time. By default, a technique that successfully detects this access when both Mail Tools and the file are all on the same machine.

As an option you can use a network aware locking protocol that uses ToolTalk® to coordinate the Mail Tools. This ensures consistency if running MailTool from more than one machine, or if mail files are accessed over the network.

Mail Tool can only change this option when first opening a mail file. If you change this option when a mail file is open you are given three choices:

- You can save the current mail file and reopen it, making the new locking technique take effect immediately.
- You can continue editing the current mail file. The new locking technique will take effect the next time you open a mail file.
- You can abort the apply and return to editing the property sheet.
Calendar Manager

Calendar Manager is an appointment and resource scheduling tool. Calendar Manager can help you schedule and keep track of your daily appointments. Upon request, Calendar Manager can send you reminders in advance of your appointments.

Your system must be set with the accurate date and time for you to receive these advance notices when you need them. Additionally, you must keep Calendar Manager running on your system—open or in icon form—for this message system to work properly. With Calendar Manager, you can:

• Display appointments and To Do items for a day, week, month, or year at a glance
• Schedule a single or repeating event
• Provide reminders of events
• Access, browse, and edit the calendar appointments of other users who have given you permission to do so
• Browse calendars of many users at one time in order to find meeting times available to everyone
• Schedule appointments for several users at one time
• Send mail to other users notifying them of new appointments
• Print high-quality calendar output for reference
To open Calendar Manager, choose Workspace ➤ Programs ➤ Calendar Manager. Calendar Manager opens to icon form.

Calendar Manager Icons

Calendar Manager provides different ways to view your calendar. You can view your schedule a day, week, month, or year at a time. You can also view a daily, weekly, monthly, or yearly list of appointments or To Do items. This section describes all the ways you can view the calendar.

Icons

When Calendar Manager is displayed as an icon, it shows the current date, as shown in Figure 5-1.

![Calendar Manager Icon](image)

Figure 5-1 Calendar Manager Icon

Calendar Manager Base Window

Views by Day, Week, Month, and Year

To view the full calendar, double-click SELECT on the calendar icon. Calendar Manager opens up into a full-sized window containing the current month. Figure 5-2 shows the Calendar Manager window. Note that one appointment is displayed for each line, and the text for the appointments is clipped to fit the size of the date box.
The default Calendar Manager display is the current month at a glance, which shows appointment scheduling for a one-month period. (You can, however, change the default from the Properties window.)

The current day is automatically selected when you open the Calendar Manager window. The selected day has a double border. On color workstations, the inside border is the color of your Windows, as determined by the Workspace Properties Color category. In Figure 5-2, August 6th is the selected day. You can select any other day by pointing to the day and clicking SELECT.

**Calendar Manager Controls and Menus**

There are four menu buttons at the top of the Calendar Manager window: View, Edit, Browse, and Print and three Navigation Controls. The related menu functions are listed here.
View Menu

The View menu allows you to alternate between day, week, month, and year views; change time zones; locate an appointment; and go directly to a selected date.

- Day displays a view of the currently selected day, list of scheduled appointments for the day, and a daily To Do list.
- Week displays a mini view of the current week, list of scheduled weekly appointments, and weekly To Do list items.
- Month displays a full month view with the current date highlighted, a list of scheduled monthly appointments, and a monthly To Do list.
- Year displays a view of the current year, a list of appointments scheduled throughout the year, and a yearly To Do list.
- Time Zone lets you change your time zone to another time zone, and allows you to view another user’s calendar in their native time zone.
- Find lets you search for an appointment. See the section “Finding a Calendar Appointment” on page 239.
- Go To allows you to search through your entire calendar for a specific date. For complete information refer to “Finding a Calendar Appointment” on page 239.

The View menu allows you to change the view. For information on displaying more detail as well as displaying past, present, and future time, see “Resizing Your Calendar” on page 223 and “Navigation Controls” on page 223.

For information on using appointment and To Do lists, see “Displaying an Appointment or To Do List” on page 229.

Edit Menu

The Edit menu items have the following functions:

- Appointment allows you to schedule appointments and To Do items. The Appointment Editor pop-up window is displayed.
- Properties lets you customize various features of the Calendar Manager, including settings for the appointment and calendar display, date format, printing, and security access.
Browse Menu

The Browse menu allows you to view Multiple calendars: browse a single Calendar; set up the Browse list and the Browse menu pulldown which allows quick access to a calendar. For more information refer to “Multiple Calendars Base Window” on page 242.

Print Menu

The print menu allows you to print the currently selected view as well as Day, Week, Month, Year views and corresponding Appointment and To Do lists.

Navigation Controls

![Prev Today Next]

*Figure 5-3  The Calendar Navigation Controls*

The right side of the control area has three buttons for changing to past, present, or future views:

- Prev displays the previous day, week, month, or year.
- Today displays a view that contains the current date.
- Next displays tomorrow or the upcoming week, month, or year.

Resizing Your Calendar

For all views and lists, the Calendar Manager window has resize corners that you can use to change its size to see greater detail. For information on resizing, see “Resizing Windows” on page 28.

- To display more information on each line, use one of the resize corners to stretch the window horizontally.
- To increase the number of lines for appointments, use one of the resize corners to stretch the window vertically.
Calendar Views

The following sections describe the views you can choose from the View menu: Day, Week, Month, and Year.

Day View

The day-at-a-glance view is useful when you have many appointments scheduled for a single day.

To change the view in the Calendar Manager window so that it displays appointments for one day, choose View ➤ Day.

The view in the Calendar Manager window changes to display the currently selected day. If the current view is the year view, the day displayed is the first day of the currently selected month. Figure 5-4 shows an example of the day view.

Figure 5-4  Day View
If the current view is the week view, an accelerated way to change to the day display is to move the pointer into the date box at the top of the day you want to view and click SELECT.

You can set the range of hours that are displayed for the day view from the Properties window. See “Customizing Your Calendar Manager” on page 257 for more information.

You can also display a daily list of Appointments or To Do items. Displaying these lists next to the day view is particularly useful because Appointments and To Do items without times associated with them do not appear on the regular day view. See the section “Appointment List and To Do List Views” on page 228 for more information.

**Week View**

- To change the view in the Calendar Manager window so that it displays appointments for one week, choose View ➤ Week.

The view in the Calendar Manager window changes to display the week containing the current date, as shown in Figure 5-5. The chart in the lower left corner of the window shows you the blocks of time allocated for appointments during the week. The darkly shaded area indicates overlapping appointments.

You can also display a weekly list of Appointments or To Do items. See the section “Appointment List and To Do List Views” on page 228.

You can also display to the Day View by selecting the date header in the Week View.
To change the View in the Calendar Manager window so that is displays appointments for a month, choose View ➤ Month.

Alternatively, from the Month view, place the pointer over the number for an individual day and click SELECT to change the view to the week containing that day. Make sure to click SELECT directly on the number of the day within Month view. Clicking SELECT anywhere else on the day just selects that day. When you click SELECT directly on the number of a day, the entire week containing that day is highlighted when the SELECT button is down, and the view changes to the Week view when the SELECT button is released.

You can also display a monthly list of Appointments or To Do items. See “Appointment List and To Do List Views” on page 228 for more information.
Year View

Diamond To change the view in the Calendar Manager window so that it displays the calendar for the current year, choose View ➤ Year.

The view in the Calendar Manager window changes to display the current year. Figure 5-6 shows the Calendar Manager window with a year display.

You can also display a monthly list of Appointments or To Do items. See “Appointment List and To Do List Views” on page 228.
Appointment List and To Do List Views

In addition to displaying your schedule for a day, week, month, or year, you can also display separate windows of lists of all the Appointments and To Do items for a particular day, week, month, or year. (The appointments and To Do items also appear on your base window schedule.) Figure 5-7 shows a day view displayed along with the Appointment and To Do lists for that day.

An Appointment List displays all the appointments for a particular time period, while a To Do list displays all the To Do items for a particular time period. To help you keep track of tasks that need to be done, the To Do list includes check boxes where you can check off an item when you have completed it. To check off a To Do item, click SELECT on the check box of the completed list item. To erase a check mark, click SELECT on the check box containing the check mark.

An appointment, such as a meeting, typically has a time associated with it, but it doesn’t have to. A To Do item, such as “Create status report,” typically does not have a time associated with it, but you can give it a time if you want to. It’s
entirely up to you which items on your calendar are Appointments and which are To Do items. See “Edit Menu” on page 229 for information about creating and changing calendar items.

**Displaying an Appointment or To Do List**

To display an Appointment List or To Do list, follow these steps:

1. **Select or view the day, week, month, or year that you want to display a list for.**

2. **Choose Appt List or To Do List from any of the View submenus.**
   A pop-up window with the selected list appears next to the Calendar Manager base window.

**Edit Menu**

You schedule Appointments and To Do items from the Appointment Editor pop-up window. You can display the Appointment Editor window by selecting a day and choosing Appointment from the Edit menu.

Alternatively, you can double-click SELECT on an hour (for Day view) or a day (for Week or Month view) to display the Appointment Editor.

The Appointment Editor window automatically displays the selected day and lists scheduled appointments in the scrolling list, as shown in Figure 5-8.
Appointment Editor Options

The Appointment Editor window contains the following controls:

- A Date field that automatically displays the selected date. You can type in another date to schedule additional appointments. You can change the format of the Date field with the Calendar Manager Properties window. See “Date Format Properties” on page 266 for more information.

- A Start and Stop set of controls that you use to set the time of the appointment. You can either use the time menu or type in a number in the text fields.

The time menu is available through the Start and Stop abbreviated menu buttons. The choice of times on this menu is determined by the Day Bounds settings from the Properties window. See “Customizing Your Calendar Manager” on page 257 for more information.

Figure 5-8  Appointment Editor Pop-up Window
When you set a start time, the stop time is automatically set to one hour later. If the appointment is longer than an hour, you can set a new stop time by choosing a time from the time menu or by typing a time in the text field.

The last choices on the time menu are No Time and All Day. Use No Time if you don’t want a time associated with an appointment. When you choose All Day, the appointment is set for 12:00 a.m. to 11:59 p.m. This is useful for appointments that refer to the entire day, such as “Vacation Day.”

- A What field in which you type information about the appointment or To Do item. The first line of this field is displayed in the Day, Week, and Month views, so the first line should describe the appointment. You can also include details about the appointment, such as the appointment place, a brief meeting agenda, or a reminder to bring something to the appointment.

- A scrolling list that displays existing appointments for the selected date.

- An Appt/To Do setting, that lets you choose whether the item is to be considered an Appointment or a To Do item. See “Displaying an Appointment or To Do List” on page 229 for more information.

- Calendars and Insert access tells you what permissions you have for the selected calendar. See “Customizing Your Calendar Manager” on page 257.

- A setting called Privacy Setting, which lets you create a private appointment. If you select the options: Show Time Only or Show Time and Text (only the time of the appointment and what fields are displayed) or Show Nothing (nothing from the appointment is displayed). If you select Show Nothing the appointment, including the appointment time, is completely hidden from everyone else. You can change the default in the Properties menu. Refer to “Customizing Your Calendar Manager” on page 257.

**Caution** – If you create a Show Nothing appointment by using the Privacy setting, nobody else will be aware that you have an appointment scheduled in that time slot when they browse your calendar. There is a possibility that someone else will schedule another appointment for you in that time slot because they cannot see that time slot filled when using Multiple Calendars. (See “Multiple Calendars Base Window” on page 242 for information.)
• Alarm controls determine how you are reminded of an appointment. You can use as many of the alarm controls as you like for each appointment. Each alarm setting allows you set an advance alarm in intervals of minutes, hours, or days, by using the abbreviated menu buttons and typing a number in the text field.

The Beep and Flash settings cause the Calendar Manager icon to beep and flash if it is closed. The Calendar Manager window itself will beep and flash if it is open. If you choose PopUp, at the time specified for PopUp the appointment Reminder window is displayed, showing the appointment information. Choosing the Mail setting automatically mails a reminder to the email addresses you type into the Mail To text field.

• Repeat controls specify the following: if the appointment is individual, Daily, Weekly, Every Two-Weeks, Monthly By Date (this is the date of the appointment such as the first or the fifteenth of the month), Monthly By Weekday (this is the weekday of the appointment such as every third Tuesday of the month), Yearly, Monday thru Friday, Mon., Wed., Fri., Tuesday-Thursday, or repeat the appointment for a set amount of days, weeks or months (Repeat Every...). When an appointment repeats, use the For: field to set the number of times the appointment is repeated during the day, week or month. You can also set a limit on the amount of day(s), week(s), or month(s) it is repeated.

• You can drag and drop appointments from Mail Tool onto the Appointment Editor.

You can change the default settings for the Appointment Editor window from the Calendar Manager Properties window. See “Customizing Your Calendar Manager” on page 257 for more information about properties.

Use the set of buttons at the bottom of the default Appointment Editor window to create and edit appointments. For information about using the Insert, Delete, Change, and Reset buttons, see the sections “Scheduling Appointments and To Do Items” on page 233, “Deleting an Appointment” on page 236,”and “Editing an Appointment” on page 237.
Scheduling Appointments and To Do Items

To schedule an appointment on your calendar, do the following:

1. **Double-click SELECT on the day you would like to schedule an appointment.**
   This opens an Appointment Editor window, shown in Figure 5-9.

![Figure 5-9 Calendar Manager Appointment Window](image)

2. **If the commitment is a task rather than an appointment click SELECT on the To Do box.**
   The Appt (appointment) box is selected by default.

You may enter a To Do item with or without an associated time.
3. To set the time, move the pointer onto the Start abbreviated menu button and press MENU to display a menu from which you can choose times. The hours displayed on this menu are determined by the setting of day boundaries from the Properties window.

Each hour item has a submenu with 00, 15, 30, and 45 minute items.

Highlight the time you want and release MENU to enter the time in the text field. When you choose a time from the menu, the correct a.m. or p.m. setting is automatically chosen for you. If you choose the menu item None, no time is associated with the appointment. If you choose All Day, the appointment is set from 12:00 a.m. to 11:59 p.m.

Alternatively, you type a time in the Start text field. If necessary, click SELECT on the PM setting.

The time in the Stop text field is automatically set to one hour later than the time in the Start text field.

4. To change the duration for the appointment from the default of one hour, move the pointer onto the Stop menu button and press MENU to display the time menu as described in Step 2. Alternatively, you can type a time in the Stop text field. If necessary, click SELECT on the PM setting.

5. If the appointment is one that is repeated on a regular basis, choose the appropriate Repeat setting from the menu displayed through the Repeat abbreviated menu button.

You can use the Repeat menu to choose a variety of intervals. These are outlined in the “Appointment Editor Options” on page 230. When Repeat is set to One Time, the For text field is inactive and is dimmed to show you that it will not accept input. When you choose a repeating appointment, the For text field and abbreviated menu button are active and the units are displayed in the text field.

You use the For menu and text field to choose the time frame you want the appointment to repeat. For example, you may know that a weekly meeting will be scheduled for the next ten weeks.

The default number in the For text field usually sets the appointment to repeat for a year. For example, the default number is 365 when the repeat interval is Daily, or 52 when the repeat interval is Weekly. The default number for the
Yearly setting is two years. If you want the appointment to repeat indefinitely, you can choose forever from the For menu or type the word “forever” in the text field.

6. **Choose a Privacy setting, if applicable.**
   If this is a private appointment that you do not want anyone to view, you can use the abbreviated menu button from the Privacy field to select Show Time Only or Show Nothing about the appointment. For complete information refer to “Appointment Editor Options” on page 230.

7. **Choose the way you want to be reminded of this appointment.**
   You can set none, some, or all of the Alarm options. Beep and Flash cause the Calendar Manager icon to beep and flash if it is closed. The Calendar Manager window itself will beep and flash if it is open. If you choose PopUp, at the time specified for PopUp the appointment Reminder window is displayed showing the appointment information. Figure 5-10 shows an example of the Reminder pop-up window.

![Reminder Pop-up Window](image)

<table>
<thead>
<tr>
<th>Date</th>
<th>Time</th>
<th>Location</th>
<th>Event Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>5/7/91</td>
<td>3:45 to 4:45</td>
<td>Bldg 5, Bradbury Conf Rm</td>
<td>Take Design Committee for status presentation</td>
</tr>
</tbody>
</table>

Choosing the Mail setting automatically mails a reminder to the email addresses you type into the To text field.

8. **Change the Alarm times, if necessary by typing a new number into the appropriate text field.**
   Decimals and fractions are not accepted formats.

   You can also change the default Alarm times from the Properties window. See “Customizing Your Calendar Manager” on page 257 for information.
9. When you have entered all the information for the appointment, click **SELECT** on the Insert button.
The appointment is added to the scrolling list in the Appointment Editor window and to the Calendar Manager window.

If you want to enter appointments for another day, double-click **SELECT** on the new day in the Calendar Manager window or type a new date in the Date field.

**Deleting an Appointment**

To delete an existing Appointment or To Do item, follow these steps:

1. **Select a date and display the Appointment Editor pop-up window.**

2. **Select the appointment in the scrolling list that you want to delete.**
The appointment is highlighted, as shown in Figure 5-11, the appointment information is displayed in the Appointment Editor fields, and the author of the appointment is displayed in the footer.

![Figure 5-11 Appointment Editor Window with a Highlighted Appointment](image)

---

---
3. Click SELECT on the Delete button at the bottom of the Appointment Editor window.
   The appointment is deleted from both the scrolling list and the Calendar Manager window.

If you try to delete a repeating appointment, a Notice is displayed, as shown in Figure 5-12, allowing you to delete the appointment for the selected date only, for (forward) future dates, all dates, or to cancel the operation.

![Notice for Repeating Events](image)

**Figure 5-12** Notice for Repeating Events

**Editing an Appointment**

To edit an existing Appointment or To Do item, follow these steps:

1. Select a date and display the Appointment Editor window.
2. Select the appointment in the scrolling list that you want to edit.
3. Change the information in the Appointment Editor window to reflect the new information for the appointment.
4. Click SELECT on the Change button at the bottom of the Appointment Editor window.

If you change a repeating appointment, a Notice is displayed allowing you to change the appointment for the selected appointment only, for all future appointments in the repeating series, for all scheduled appointments, or to cancel the operation.
Appointment Reminders

You may want to receive a reminder before a scheduled appointment. You can make your system beep, flash, or send you an electronic mail message, or you can set your calendar to display a pop-up window containing the appointment details. You can also choose some combination of those events.

To receive a reminder, do the following:

1. Begin a new appointment, or edit an existing appointment in the Appointment Editor.

2. Click SELECT on the button or buttons for the Alarm reminders you would like to receive before that appointment.
   The buttons you choose are highlighted. Figure 5-13 shows the appointment reminders when they have been selected.

3. If needed, change the default advance warning times, as follows:
   a. Click SELECT to the right of the time and press the Backspace key on your keyboard to delete the default time.
b. Type in the desired time.

4. Add mail addresses to the Mail To text field, as needed.
   By default, your own mail address appears on the text field. If you add more
   addresses, the names will scroll out of sight. You can scroll them back into
   view using the arrow keys on your keyboard.

5. Save the appointment, in one of the following ways.
   a. If you are changing an existing appointment, press the Change button
      to enter your modifications.
   b. If you are creating a new appointment with reminders, press Insert to
      enter your new appointment.

Finding a Calendar Appointment

If you want to find an appointment, but you can’t remember exactly when it
was scheduled, you can use the Calendar Manager Find feature.

♦ To display the Find window, choose View ➤ Find.

From the Find window type the appointment you want to search for in the text
field. The Find window contains a text field where you type in the
appointment that you want to search for. The text that you type can be any
part of the appointment description, and can be in upper or lower case. For
example, Figure 5-14 shows a Find window with the word “Dentist” typed in
the Match Appt text field. This will find the next appointment with the word
“dentist” (upper or lower case) in the What field, including “Dentist
appointment”, “See the dentist”, “DENTIST”, “Pay dentist bill”, and so forth.

![Calendar Manager Find Window](image)

Figure 5-14  Calendar Manager Find Window
Use the Months text field and increment/decrement buttons to specify the number of months that you want to search for an appointment, starting with the currently displayed month. Clicking SELECT on Find Forward searches forward for the number of months specified, and clicking SELECT on Find Backward searches backward for that number of months.

Finding a Specific Calendar Date

Sometimes you may need to look at or “go to” a specific date very quickly. Instead of using the navigator buttons to do this, you can use the Go To function.

1. Choose View ➤ GoTo.
   You see the Go To Date window.

2. Type the exact date on the Date: line, and SELECT the GoTo button.
   The date must be in the format specified in the Date Format Properties. Depending on the view selected, the day is shown or highlighted.

Dragging an Appointment Message from Mail Tool

When you receive a mail message that has an appointment icon attached to it, or a mail reminder generated by another Calendar Manager application, you can drag and drop the message (or appointment icon) onto Calendar Manager to schedule your appointment by following these steps:

1. Open the Mail Tool window that displays your mail message headers.

2. Point to the header and click SELECT to select it.
3. Press the SELECT mouse button and drag the pointer a short distance. The pointer changes to the duplicate pointer, and a small envelope representing the mail message is displayed, as shown in Figure 5-15.

![Figure 5-15 Dragging a Mail Message](image1.jpg)

4. Drag the envelope onto the Calendar Manager. You can drop it onto the Calendar Manager icon or anywhere on the open Calendar Manager window.

5. Release SELECT. When the appointment has been successfully scheduled, a message is displayed in the footer of the Calendar Manager window. Figure 5-16 shows an example of such a message.

![Figure 5-16 Example of a Message for a Scheduled Appointment](image2.jpg)

For complete information on the appointment icon, refer to Chapter 4, “Multimedia Mail Tool.” If the appointment is in a format that Calendar Manager cannot understand, a Notice is displayed informing you that the appointment cannot be scheduled.
Multiple Calendars Base Window

Calendar Manager allows you to access the calendars of other users if you are included on their Access List. This convenient feature allows you and your coworkers to coordinate scheduling of appointments. You can use the Show Multiple Calendars menu item to overlay the calendars of many users at one time in order to find the best time to schedule a meeting. Once you have found a convenient meeting time, you can schedule the meeting in everyone’s calendar, and/or send each user mail about the new appointment.

You can also see all the public appointments on another user’s calendar, and insert, delete, or change existing appointments, as long as you have the appropriate access list permissions. See “Access List and Permissions Properties” on page 261 for information about creating the access list for your personal calendar.

Using Multiple Calendars

The Show Multiple Calendars menu item allows you to view many people’s calendars overlaid onto the same display at one time. It lets you see how many and which users are busy during any particular hour, and quickly tells you if there is a time slot in which all the users are free. If there is not a time slot when all the users are free, you can determine a time when the majority or a particular subset of users are available. This makes it much easier to figure out the best time for a meeting.

Once you have figured out the best time for a meeting, you can schedule the appointment for all the users who have given you Insert access to their calendars. In addition, you can send mail to the meeting participants in a format that the users can drag from the Mail Tool and drop onto their Calendar Manager in order to schedule the appointment themselves.

Multiple Calendars Window

You access Multiple Calendars by choosing Show Multiple Calendars from the Browse menu. This displays the Multiple Calendars window. Figure 5-17 displays the Multiple Calendars icon and the default window with one calendar displayed. Using Show Multiple Calendars to display multiple calendars is described later in this section.
The Multiple Calendars window has the following controls:

- Schedule, Mail, and Go To buttons that you use to schedule appointments for many users at once, mail information about new appointments, and change the display of Multiple Calendars to show a different week or month.
- Scrolling list of calendars available to be browsed
- Setup menu button from which you type the user names (login and system name) of the calendars that you want to add to the browser scrolling list
- Multiple Calendars display, on which any number of calendars can be overlaid to show a composite schedule
In Figure 5-17 there is one calendar displayed. A footer message tells you how many calendars are being displayed at any time.

The gray areas of the calendar display indicate the times that the selected user has scheduled an appointment. If several calendars are being displayed, the gray blocks have varying shades. Darker blocks indicate more existing appointments during that time slot. (There are only up to three shades of gray, so a time slot with four existing appointments will not appear any darker than a time slot with three appointments.) The white areas indicate times in which none of the selected users are busy.

Figure 5-18 shows Multiple Calendars with five calendars displayed. The calendars displayed are those of the five users selected in the scrolling list. The unshaded white area on Monday at 11:00 indicates that this is a time when the five selected users are all available.

Figure 5-18  Multiple Calendars with Five Calendars Displayed
One hour in the Multiple Calendars display has a double border. On color workstations, the inside border is the color of your Windows, as determined by the Workspace Properties Color category. This indicates the selected time.

Every user who has an appointment scheduled during the selected time has a clock symbol to the left of their name in the scrolling list. You can use these clock symbols to see who is busy during a desired time slot. For example, if you have to schedule a meeting and there is no time that everyone is available, you can use the check mark display to find out who is scheduled during a time slot for which only one person is busy.

The selected time in Figure 5-18 is Tuesday at 11:00. You can see by the check marks in the scrolling list that users hamilton@artemis and patten@phosphor both have appointments scheduled on Tuesday at 11:00 a.m.

Adding a Calendar to Multiple Calendars and the Browse Menu

The scrolling list of the Multiple Calendars displays all the calendars that are available to be browsed. The Browse menu (from the Browse button of the Calendar Manager control panel) is also made up of this same list of calendars. In order to browse a calendar, you must first add it to the Multiple Calendars scrolling list.

New calendars are displayed on the Browse menu in the order you enter them in the Multiple Calendars scrolling list. This list can be sorted alphabetically after adding the name to the list.

To add calendars to the browse list and menu follow these steps:

1. **If the Multiple Calendars window is not currently displayed, choose Browse ➤ Setup Menu.**
   - If the Multiple Calendars window is displayed, click SELECT on the Setup Menu... button. You see the Setup Menu window.
2. In the User Name text field, type the calendar address of the user whose calendar you want to add.

The calendar address is the user’s login name, followed by @, followed by the user’s host machine name. For example, the calendar address mariac@celtic is in the Calendar field of Figure 5-19.

If you are using the NIS or DNS system, which uses the concept of domains, make sure you are either browsing a calendar in your domain, or that you specify the remote domain.

For example, if you are trying to browse the calendar for user egret in your own domain, the correct calendar address is egret@host. However, if egret is in another domain, the calendar address needs to be in the format egret@host.domain.

3. Select Add Name to add the name.

If you enter an invalid host name or an invalid user name, while attempting to browse, you see an “Unable to access Calendar” error message.
Note – To improve system and network performance, Calendar Manager does not confirm that the user name is valid or that you have browse permission for that calendar when you enter the user name in the scrolling list. Calendar Manager does this checking when you select the calendar in the Multiple Calendars scrolling list, or when you choose the calendar from the Browse menu.

4. Click Apply.

Deleting/Removing a Calendar from Multiple Calendars and the Browse Menu

To delete a calendar from your Multiple Calendars scrolling list and from your Browse menu, follow these steps:

1. Choose Setup Menu from the Browse Menu pulldown or Setup Menu from the Multiple Calendars window.

2. Select each calendar that you want to delete in the Browse Menu Items scrolling list.

3. Choose Remove from the Setup menu to delete all the selected names in the scrolling list.

Note – You cannot delete your calendar name or “initial calendar view”.

4. Click Apply.

Selecting a Week to Browse

When you display the Multiple Calendars window, the week shown in the Multi-Browser calendar display is determined as follows:

- If the current view is the Day view or Month view, the week containing the currently selected day is displayed.
- If the current view is the Week view, the current week is displayed.
- If the current view is the Year view, the first week of the currently selected month is displayed.
To change the week displayed in Multiple Calendars, use the Go To menu and text field.

To display a specific week, type a date during the desired week in the Go To text field, and click SELECT on the GoTo button. Type the date using the format set on the Date Format Properties window. The default format is MM/DD/YY. See the section “Date Format Properties” on page 266 for more information.

You can also use the items of the Go To menu to change the Multiple Calendars week display, as follows:
- Choose Prev Week or Next Week to display the previous or next week.
- Choose This Week to display the week of the day currently selected in the Calendar Manager base window.
- Choose Prev Month or Next Month to display a week one month before or after the current Multiple Calendars week.

**Finding a Time Slot for a New Appointment for Many Users**

If you want to schedule a meeting or other appointment that involves many users, follow these steps:

1. **Choose Multiple Calendars from the Browse menu, if the Multiple Calendars window is not currently displayed.**

2. **Add the calendars to the Multiple Calendars scrolling list for all the meeting participants.**
   See “Adding a Calendar to Multiple Calendars and the Browse Menu” on page 245 for information.

3. **Select all the calendars of the meeting participants by clicking SELECT on each user’s calendar in the scrolling list.**
   Each selected calendar is overlaid in the Multiple Calendars display area.

4. **If the week you want is not currently displayed, use the Go To menu or text field to display the desired week.**
   See “Selecting a Week to Browse” on page 247 for more information.
5. When all calendars are selected and overlaid, find an unshaded block of time for the meeting.

This represents a time when everyone is available. For example, in Figure 5-20 all selected calendars have an open time slot on Tuesday from 1:00 to 2:00 and from 3:00 to 5:00.

*Figure 5-20*  Multiple Calendars window with Five Users Selected
6. If there is not a large enough available time slot for all the selected calendars, select a time slot that is lightly shaded and look at the clock(s) in the scrolling list to see who has a time conflict.
Keep trying this until you find a time slot with the least number of conflicts, or where only the people who don’t have to be at the meeting have conflicts.

Alternatively, you can deselect the calendar of a user who does not have to be at the meeting by clicking SELECT on that calendar in the scrolling list. The Multiple Calendars display is then updated, and you may now be able to find an available time slot.

Scheduling Appointments for a Group of Users

Once you have found a good time for a new appointment for many users, you can use the Appointment Editor to schedule the appointment in the calendars of all users who have given you Insert access.

For complete information on scheduling an appointment with the CM Appointment Editor see “Appointment Editor Options” on page 230.

Note – If a question mark “?” appears in the Calendars Insert Access field it means that the user you are trying to access is running an older version of Calendar Manager. You may or may not have access to this user’s calendar, and you can determine this by attempting to access the calendar.

The Appointments scrolling list on the CM Appointment Editor displays appointments for all of the calendars selected in the Calendars scrolling list, at the time selected in the Multiple Calendars window. When you select an appointment on the Appointments scrolling list, the appointment information is displayed in the CM Appointment Editor fields, and the Calendars scrolling list is updated to display only the owner of the appointment.

To schedule an appointment for a group of users at one time, follow these steps:

1. Use Show Multiple Calendars to find a time slot for the new appointment.
   If you are unsure how to do this, see the section “Finding a Time Slot for a New Appointment for Many Users” on page 248 for complete information.
2. Move the pointer to the block of time that you want to schedule the appointment for and click SELECT. The selected time must be for one hour in the Multiple Calendars display, but you can change the time or duration when you schedule the appointment.

3. Click SELECT on Multiple Calendars Schedule. Alternatively, you can just double-click SELECT on the block of time in step 2. The CM Appointment Editor is shown in Figure 5-21 on page 251.

![CM Appointment Editor](image)

**Figure 5-21** CM Appointment Editor

The CM Appointment Editor is displayed. The selected date and time are filled in and the selected calendars are listed on the Calendars scrolling list. If you have Insert Access to any of these calendars, that calendar is
automatically selected. If any of the selected calendars has an appointment at the selected time, that appointment is added to the Appointments scrolling list.

If you change the time or selected calendars in the Multiple Calendars window, that information is automatically updated in the CM Appointment Editor window.

Sending Mail about Appointments from Multiple Calendars

You can use the Multiple Calendars Mail facility to send mail about an appointment to other users. The mail is sent with an appointment icon that, for easy scheduling, can be dragged and dropped on the Calendar Manager main window. See “Using Calendar Manager with Mail Tool” on page 272 for information about using drag and drop with Mail Tool to schedule Calendar Manager appointments.

This feature is particularly useful when you have used the Multiple Calendars to schedule a new appointment. After scheduling the appointment, you may want to send mail about the appointment to all the participants. In addition, there may be users who have not given you Insert access to their calendar, in which case you can send them mail and let them schedule the appointment themselves.

To use the Multiple Calendars mail feature:

♦ Click SELECT on the Mail button at the top of the Multiple Calendars window.

This displays a Mail Tool Compose window that contains an appointment icon in the attachment area. Refer to “Using Calendar Manager with Mail Tool” on page 272 for more information. See “Mail Tool Compose Window” on page 157 in Chapter 4, “Multimedia Mail Tool” for information about creating and sending mail.

If you have calendars selected in the Multiple Calendars scrolling list, the Mail Tool Compose window displayed by the Mail button is automatically addressed to those users. The subject field is “Meeting”.

The Calendar Manager appointment icon in the Compose window attachments area is automatically filled out with the appropriate date and time, as follows:
• If the Appointment Editor window is or has been displayed, the Date, Start, End, and What fields are included with the appointment attachment with the corresponding fields from the most recent session of the Appointment Editor. For complete information on using the Appointment Editor, refer to “Appointment Editor Options” on page 230.

• If the Mail Tool Compose window is displayed before the Appointment Editor window is displayed, the Date, Start, and End fields are included in the appointment attachment with the date and time of the currently selected time in the Multiple Calendars display.

You can change any of the information that is automatically filled out, and add more information. Figure 5-22 shows the Mail Tool Compose window displayed when the Mail button is selected from the Multiple Calendars window. Attaching the appointment saves your changes.

Figure 5-22  Multiple Calendars Compose Message Window
Browsing a Single Remote Calendar

Once a calendar has been added to the Browse menu, you can display and/or edit the appointments for that user (depending on the access permissions that user has given you) by choosing the calendar from the Browse menu.

If Calendar Manager cannot find the user name or access the appointments for that user, the error message Unable to access user@machine... is displayed in the footer of the Calendar Manager window. The appropriate user and machine names are displayed in the error message.

If Calendar Manager can access the user’s appointments, they are displayed in the window, and the name of the user is shown in the header. If you do not have browse access for that user you cannot see or edit their appointments, but you can see blocks of scheduled time as shown in Figure 5-23.

To change back to your own calendar, choose your user name from the Browse menu.
Browsing a Single Remote Calendar One-Time Only

Sometimes you may need to browse a single user’s calendar just for a certain appointment only. It does not make sense to add this user to your list of frequently browsed calendars. To show a single calendar one-time only:

1. Choose Browse ➤ Show Calendar.
   You see the Show Calendar window.

2. Type the user’s name for the calendar to be displayed in the User Name: text field, and select Show.
   Depending on which view is displayed, you see the calendar of the user name you entered. Figure 5-24 shows a calendar selected from the Show Calendar window.

![Figure 5-24  A One-Time Selected Calendar](image-url)
Setting the Calendar Manager Time Zone

When you browse another calendar, Calendar Manager automatically adjusts the times to your time zone. For example, if you are on the west coast of the United States, and you are browsing the calendar of someone on the East Coast, a 9:00 a.m. appointment will appear as 6:00 a.m. to you.

This is an important feature when using Multiple Calendars because it assures that all calendars are synchronized. If you are just browsing a single calendar, however, you might want to view the appointments in their native time zone. You can do this easily by using Time Zone from the View menu to change your time zone to that of the calendar you are browsing. If you change your time zone to something other than your own, the name of the time zone is displayed in the right side of the footer of the Calendar Manager base window. Figure 5-25 shows the Time Zone menu with US Mountain Time selected.

Note – If you change your time zone in order to browse another calendar, make sure to change it back to your native time zone when you are done. This is important in order to keep your appointment times synchronized with each other and your system. You can change back to your native time zone by selecting Time Zone from the View menu.

Figure 5-25  A portion of the Time Zone Menu
Customizing Your Calendar Manager

You can customize the following parts of Calendar Manager from the Properties window:

- Editor Defaults, for the Appointment Editor pop-up window
- Display Settings, to specify default display options
- Access List and Permissions, to specify security access defaults
- Printer Settings, to specify default print options
- Date Formats, to specify the format for the date on the Appointment Editor

The Properties window has five separate displays (selected from the category field) that you use to modify the five different sets of properties.

To display the Properties window:

♦ Choose Edit ➤ Properties

or move the pointer into the control area or pane of the Calendar Manager window and press the Properties key (L3) on the keyboard to display the Properties window, shown in Figure 5-26.
To display a particular category of properties:

♦ Choose the item from the Category menu at the top of the Properties window.

When you release MENU, the contents of the Properties window show the properties you can set for that category.

When you have changed properties, you must apply them by clicking SELECT on the Apply button. This only applies the properties currently displayed. To change properties of a different category, display the new category, change the desired settings, and click SELECT on the Apply button again.

Alternatively, you can click SELECT on the Reset button to reset all the options to be the same as they were since the last time you applied changes. Click SELECT on the Defaults button to reset all the options to their default settings.

**Editor Defaults Properties**

The Editor Defaults properties, shown in Figure 5-27, specify the defaults for the Appointment Editor pop-up window. When you set the editor defaults from the Properties window, they are automatically set each time you display the Appointment Editor window. The Mail To text field determines who receives reminder mail when you use the Mail Alarm.

![Figure 5-27 Editor Defaults Properties](image-url)
To change the defaults:

1. Click SELECT on the settings you want to change.

2. Click SELECT in the text field and type a new number.
   Use the abbreviated menu buttons to indicate minutes, hours, or days.
   Figure 5-27 shows an example of the Alarms with Beep, Flash, and PopUp set. You can change the default Privacy setting to Show Time Only or Show Nothing.

When you click SELECT on the Apply button, the new defaults become effective immediately. Changing the Alarm settings does not affect any appointments that have already been scheduled using the old default choices.

Display Settings Properties

The Display Settings controls, shown in Figure 5-28, specify the location of the default user calendar; the boundary times for the day; 12 or 24-hour time display; the default calendar view and the initial calendar to be viewed in the Calendar Manager window. To display this set of controls, choose Display Settings from the Category menu.

![Figure 5-28 Display Settings Properties](image-url)
Changing the User Calendar Location

You can change user calendar location by specifying a different machine name. Just type the machine name. The new user calendar location becomes the first name (or default) in the Browse menu pulldown. Any properties applied are added to the new calendar.

Changing Day Boundaries

You can specify the range of hours for your workday using the Day Boundaries sliders shown in Figure 5-28. This determines the hours displayed by Calendar Manager in these places:

- Calendar Manager Day view
- Week chart in the Calendar Manager Week view
- Multiple Calendars display
- Start and End time menus in the Appointment Editor window

The current value of the day boundaries is displayed to the right of each slider. To change the setting, follow these steps:

1. **Move the pointer to the slider drag box and press SELECT.**
2. **Drag the pointer to the left or to the right.**
   Note that the time changes as you drag the slider.
3. **When the time you want is displayed, release SELECT.**
   Alternatively, you can move the pointer onto the slider bar to the left or right of the drag box and click SELECT to change the time hour by hour.
   You cannot set a day boundary that ends before it begins. When the values overlap, the drag boxes are synchronized and move together so that the end time is always at least one hour after the start time.
4. **When you have set the day boundaries, click SELECT on the Apply button to record them.**
   Your new boundaries are now in effect.
Changing the Hour Display

You can specify the way hours are displayed with the Hour Display setting on the Properties window. The default setting is 12 Hour, which displays the hours from 1:00 to 12:00, with an “a.m.” or “p.m.” extension. You can use the 24-Hour setting to display the hours in 24-hour time. An appointment that goes from 11:30 am to 1:00 pm with the 12-Hour setting will go from 1130 to 1300 with the 24-Hour setting.

To change the hour display, click SELECT on the setting you want and then click SELECT on the Apply button. The change takes effect immediately.

Changing the Default View

You can set the default view of the Calendar Manager window to Year, Month, Week, or Day using the Default View settings on the Properties window. After you have changed the default view, click SELECT on the Apply button. The changes take effect immediately.

Changing the Initial Calendar View

You can specify the default calendar (initial calendar to be viewed) with the Initial Calendar View text field, the first time Calendar Manager is started.

After you have changed the calendar view, click SELECT on the Apply button. The changes take effect immediately.

Access List and Permissions Properties

Calendar Manager allows you to browse the appointments of others, as well as allowing other users to browse your appointments. See “Multiple Calendars Base Window” on page 242 for more information about browsing.

The Access List and Permissions properties let you specify who may browse, insert, delete or change your appointments.

The default access list, shown in Figure 5-29, gives all users permission to browse your calendar.

♦ To display the Access List controls, choose the Access List and Permissions item from the Category menu.
The scrolling list displays everyone who has access to your calendar. The entry “world” means everyone who is using the DeskSet environment. The default is that the world has Browse access permissions. If you delete the world entry, only the users you specifically add will be able to access your appointments.

To the right of each name in the scrolling list are letters indicating the permissions that user has. The available permissions are:

- “B” for Browse, meaning the user can read your appointments.
- “I” for Insert, meaning the user can add new appointments in your calendar.
- “D” for Delete, meaning the user can delete existing appointments from your calendar.

If you give more permissions to the world than you give to an individual, that individual will still have the world permissions. For example, if you give a user named Jim permission to browse your calendar, but the world has permission to browse and insert, Jim will inherit the world permissions and will be able to insert appointments as well as browse your calendar.
To give someone the ability to edit or change appointments, you must give them both Insert and Delete permissions. That person then has full permissions to insert new appointments, and delete or modify existing appointments they own. After you have entered the list of users, you can sort the list alphabetically using the sort list button.

**Adding Users to the Access List**

To add a user, follow these steps:

1. **In the User Name text field, type the email address of the user you want to add.**
   
   Names in the access list can either be in the form `name@host` or simply `name`. Note that if you just specify the user name, you are giving access to any user on your network with that name.

   If you are using the NIS or DNS system, which uses the concept of domains, make sure names on the access list do not use the format `name@domain` or `name@host.domain`. Just use `name@host`.

2. **Select the permissions you want to give the user.**

3. **To add the name, enter a name in the User Name: text field, choose Add Name, as shown in Figure 5-30.**

   ![Figure 5-30 Adding a Name to the Access List](image)
4. Click SELECT on the Apply button to record the changes.

Deleting Users from the Access List

To delete a user from the access list, select the user name in the scrolling list, choose Remove from the Properties menu or the scrolling list pop-up menu, and click SELECT on the Apply button to record the changes.

Changing the Access List

To change the existing permissions for a user already on the Access List, follow these steps:

1. Click SELECT on the user name in the scrolling list.
   If you want to change several users at one time, click SELECT on each additional user name you want to change.

2. Select the new permissions you want to give the user.
   In Figure 5-30, Browse and Insert are selected to replace the existing permission of Insert for salmon@sea.

3. Click SELECT on Add Name from the Calendar menu or the scrolling list pane menu.
   Add Name is used to add a new user, and it’s also used to change the access permissions of an existing user.

4. Click SELECT on the Apply button to record the changes.

Printer Settings Properties

You can set printing options from the Printer Settings Properties window.

♦ To display this set of controls, choose the Printer Settings item from the Calendar Manager Properties window Category menu.

Figure 5-31 shows the default settings for the Printer Settings window.
You can specify the following options from the Printer Options window:

- Destination of the printed output (Printer or File)
- Printer name and printer options, or file destination and file name
  
  If the Destination is Printer, as in Figure 5-31, a field called Options is displayed. You can type in UNIX print options in this field to customize your printer option defaults.

  If the Destination is File, the Printer and Options fields are replaced by Directory and File fields. Use these fields to type in the directory and file name of the file that you want to print to.

- Width and height of the printed image
- Left and bottom margins (position)
- Number of units that print
The “unit” is the number of calendar views to print: day, week, month, or year. When a day view is printed, the unit is Days, and so on. The selected unit always begins the sequence. For example, if February 13th is selected, and the number of units is three, then February 13th, 14th and 15th are printed.

- Number of copies to print
- Whether or not to include appointments created for Privacy Type (Show Time and Text, Show Time Only, Show Nothing) on the printed output

When you’re done choosing your Printer Settings, click SELECT on the Apply button to record the changes.

**Date Format Properties**

The Date Format properties, shown in Figure 5-32, determine how the date is displayed in the Appointment Editor window, in the Go To text field of the Multiple Calendars window, and in the Browser Editor window.

♦ To display this set of controls, choose the Date Format item from the Calendar Manager Properties window Category menu.
The Date Ordering item determines the order in which the month, day, and year appear in the various date fields. The Date Separator item determines what character separates each element of the date.

To change the defaults, click SELECT on the settings you want. When you click SELECT on Apply, the new date format becomes effective immediately.

Figure 5-33 shows the Appointment Editor with the DD|MM|YY date ordering and the / date separator.

![Appointment Editor with an Alternate Date Format](image)

**Printing Calendar Views**

Calendar Manager provides high-quality printed output for day, week, month, and year views, as well as daily, weekly, monthly, or yearly appointment and To Do lists. You set the printer name and options from the Printer Settings Property window described in “Printer Settings Properties” on page 264. You use the Print menu to print specific views, appointment lists, and To Do lists.

**Current View**

This allows you to print the view you have selected.

**Day View**

- **To print the Day view for the current day, choose Day from the Print menu.**

To print appointments for a day other than the current one, move the pointer onto the day you want to print and click SELECT. Then choose Day from the Print menu. The schedule for the day is printed in the format shown in Figure 5-34.
You can also print a daily list of Appointments or To Do items. See “Printing Appointment and To Do Lists” on page 272 for more information.
**Week View**

♦ To print the Week view for the current week, choose Week from the Print menu.

Appointments for the week are printed in the format shown in Figure 5-35. Note that all the information about an appointment is printed, not just the first line.

![Week View](image)

*Figure 5-35  Printed Week View*

You can also print a weekly list of Appointments or To Do items. See “Printing Appointment and To Do Lists” on page 272 for more information.
Month View

♦ To print the Month view for the current month, choose Month from the Print menu.

Appointments for the month are printed in the format shown in Figure 5-36.

![February 1993 Calendar](image)

*Figure 5-36  Printed Month View*

You can also print a monthly list of Appointments or To Do items. See “Printing Appointment and To Do Lists” on page 272 for more information.

Year View

♦ To print the currently displayed year, choose Year from the Print menu.
You can print a standard view of the year, shown in Figure 5-37, or a schedule view of the year, Yr view (Alt), as shown in Figure 5-38. These figures were printed using a height and width of 2.5 inches on the Print Properties window.
Printing Appointment and To Do Lists

In addition to printing the schedule for a day, week, month, or year, you can print any Appointment or To Do list. To print an Appointment list or To Do list, follow these steps:

1. Select the day that you want to print a list for, or a day in the week, month, or year that you want to print a list for.
2. Choose the list that you want to print from any of the Print submenus.

Using Calendar Manager with Mail Tool

You can enter appointments into Calendar Manager from Mail Tool by dragging and dropping a Calendar Manager appointment attachment, if it is included in the attachment area of the mail message. You can create a mail message with the appropriate format by using the Mail pop-up window in Multiple Calendars. Or create a Calendar Manager appointment that can be attached in the attachment area of a mail message by:

♦ Selecting Attach ➤ Appt... from the Compose window in Mail Tool.

Sending Appointment Mail from Calendar Manager

The easiest way to generate a message about an appointment is to use the Mail feature of Multiple Calendars. This will automatically generate a compose window with an appointment icon attached. See “Sending Mail about Appointments from Multiple Calendars” on page 252 for information about this feature.

Creating an Appointment Message from Mail Tool

Mail Tool provides a template that you can use to create mail messages in the format that Calendar Manager can accept. See “Template Properties” on page 210 in Chapter 4, “Multimedia Mail Tool for more information about Mail Tool template. The section, “Mail Tool Template for Calendar Manager Messages” on page 273 shows the Appointment window. If all the information you need has not automatically been filled in, add it at this time. This works just like the appointment editor. For information on the appointment editor, see “Appointment Editor Options” on page 230. You can however, drag and
drop from the appointment panel (using the drag and drop target) to a Calendar Manager canvas. You can drop another appointment icon onto the drop target of the appointment panel and the fields are automatically filled in. RESET returns you to the last appointment attached.

**Figure 5-39** Mail Tool Template for Calendar Manager Messages

### Displaying the Calendar Manager Monthly Icon

If you want your Calendar Manager icon to display the entire current month with the current date highlighted, as shown in Figure 5-40, you can start Calendar Manager from a Command Tool or Shell Tool by typing `cm -i 2 &`. 

**Figure 5-40** Alternate Calendar Manager Icon
Accessing Your Calendar from a Shell Tool or Command Tool

There are three Calendar Manager programs that you can run from a Shell Tool or Command Tool in order to view, insert, or delete appointments. This may be useful, for example, if you are logging into your machine from a remote destination and are therefore unable to run the Calendar Manager window-based application. These programs are called cm_lookup, cm_insert, and cm_delete.

Use cm_lookup to display your appointments for the current day. You can use command line options to specify the calendar that you want to see, a different date, or an alternate view (such as week or month). See the cm_lookup man page for more information.

Use cm_delete to delete your appointments. You are shown a list of your appointments for the current day, and you are prompted for the number of the appointments that you want to delete. You can also use command line options to specify the calendar, date, and view. See the man page for cm_delete for more information.

Use cm_insert to add new appointments to your calendar. You can use command line arguments to specify the calendar, date, start and end times, and a description of the new appointment. See the man page for cm_insert for more information.
This chapter provides information about the Command Tool, Shell Tool, and Console Window (or Console). These tools are essentially the same application, but display different default pane pop-up menus. The Command Tool is an enhanced Shell Tool.

Command Tool and Shell Tool are standard OpenWindows shells, or terminal emulators, that interpret commands typed in UNIX. When you use one of these applications it is as if you are working at a terminal, rather than in a complex networked windowing environment. The advantage is that you can display many other windows and continue running other applications at the same time.

These tools are useful if you need to:

- Read reference manual pages
- Use a command line editor such as vi
- Invoke special processes and applications not available from the Workspace menu

The Console is a special Command Tool designated for displaying error and system messages sent by the SunOS operating system, the OpenWindows environment, and some applications.
Command Tool

Command Tool provides a scrolling pane that acts as an editable command interpreter and can also provide a standard text editing pane. It can be used for a variety of tasks, including moving around in your file system, composing and editing files, and communicating with the operating system.

To open a Command Tool, choose Workspace ➤ Programs ➤ Command Tool.

Figure 6-1 shows an open Command Tool window. The Command Tool icon looks the same as the Shell Tool icon shown in Figure 6-4.

A Command Tool window has a header with a Window menu button, a Window menu, resize corners, a scrollbar, and a text/terminal emulator pane.

For more information on these elements, refer Chapter 1, “Introduction to the Solaris User Environment.”
Command Tool Term Pane Menu

In a Command Tool, the Term Pane pop-up menu has the Edit, Find, and Extras items of the standard text editing pop-up menu (described in Chapter 3, “Text Editor”), plus three additional items: the History, File Editor, and Scrolling submenus. Move the pointer anywhere onto the Command Tool pane and press MENU to display the Term Pane menu.

History Submenu

The History of a Command Tool is a log of all the characters displayed. You can access this log by scrolling the Term Pane with the scrollbar or by saving the log to a file. This may be useful, for example, if you have performed a complicated sequence of operations that you want to save or send as part of a mail message for troubleshooting or debugging. The History submenu provides options to modify the history log.

The Mode setting determines whether the history log is Editable within the Command Tool, or Read Only. If you set the mode to Read Only in order to protect against accidental changes, you can still save the log to a file and edit that file using the File Editor option described in the next section. If the mode is editable, you can edit text anywhere in the Term Pane and use the editing items on the Term Pane menu. See Chapter 3, “Text Editor” for information on the editing functions.

♦ Choose Store log as new file to save the current history log to a file.
   When you choose this option, the Text: Save As window is displayed. For complete information on saving files refer to Chapter 1, “Introduction to the Solaris User Environment.”

You can treat this new file as you would any other text file. You can edit it and save it again or drag and drop it from the File Manager onto a Mail Tool Compose or Text Editor window.

♦ Choose Clear log to clear the current history log.
   This resets the Command Tool history log as if you just started the Command Tool application. (This does not change the output of the UNIX history command.)
File Editor Submenu

The items on the File Editor submenu determine whether a Text Editor Pane is displayed. When you enable the File Editor, the Command Tool is split into two panes: a Command Tool pane and a Text Editor pane. The Text Editor pane is described in Chapter 3, “Text Editor.” Figure 6-2 shows a Command Tool with the File Editor enabled.

![Figure 6-2 Command Tool with the File Editor](image)

Scrolling Submenu

The choice from the Scrolling submenu of the Command Tool Term Pane menu determines whether a scrollbar is displayed. When you disable scrolling, the Command Tool acts like a Shell Tool.

Typing Commands in Command Tool

You can access all of the files and directories in your file system from the Command Tool. Use of the Command Tool requires familiarity with the operating system and with your file system.
In the sample session that follows, the `cd` command changes directories to your home directory, the `mkdir` command creates a new directory there, and the `cp` command copies that directory to a new directory with a different name. You execute each command when you press Return at the end of the command line.

```
example% cd (Press Return)
example% mkdir Directory1 (Press Return)
example% cp -r Directory1 Directory2 (Press Return)
```

**Viewing Your Command History**

The Command Tool is a scrolling window. The scrollbar at the side of the window enables you to go back and view commands that are no longer visible in the window. You can scroll back to see the commands typed during the entire life of the window.

**Editing the Command Line**

In the Command Tool, the command line can be edited. You can move the pointer to any location on the command that you have typed and click SELECT to position the insert point there. You can then type in that location or erase the previously typed characters and retype that portion of the command. Figure 6-3 shows the insert point.
Editing Text with Command Tool

Command Tool can be used as a Text Editor window at any time. The advantage to this is that you do not need to know a command line editor such as vi. To enable the Command Tool text editing window, move the pointer onto the window pane, press the MENU button, drag the pointer down to highlight File Editor, and then to the right to highlight Enable. The Command Tool pane splits in two; the top pane remains as Command Tool, while the bottom pane becomes a Text Editor.

See the “Text Editor” section for an introduction to the commands in the Command Tool File Editor.

♦ To return to the basic Command Tool, position the pointer in the top pane and choose File Editor ➤ Disable.

Shell Tool

Like Command Tool, Shell Tool is a window that you use to communicate with the operating system, or to move around in your file system and compose and edit files by command line. You can use Shell Tool for shells or other programs that employ a standard teletype (TTY) interface.

The basic differences between Command Tool and Shell Tool are:

• Command Tool is a scrolling window by default.
• Shell Tool cannot be converted into a File Editor.
• Their default pane menus.

♦ To open a Shell Tool window, choose Workspace ➤ Programs ➤ Shell Tool.

Note – Open as many Shell Tools as you need, but remember that as you add more applications to the Workspace, you may compromise system performance.

Figure 6-4 shows the Shell Tool icon and Figure 6-5 shows an open Shell Tool window.
A Shell Tool window has a header with a Window menu button, a Window menu, resize corners, and a terminal emulator pane. A Shell Tool window does not have a scrollbar at start up, but you can enable scrolling if desired. The insert point is shown by a block cursor. When the insert point is not in the Shell Tool, the block cursor is displayed as an outline of the block cursor. Editing is limited to the end of the current line. For example, you can only delete characters on the current line. Once you press Return, the characters on the line are interpreted as a command. If you are not familiar with these window elements, refer to Chapter 1, “Introduction to the Solaris User Environment.”
Shell Tool Term Pane Menu

♦ To display the Shell Tool terminal emulator pane menu, move the pointer anywhere into the Shell Tool pane and press MENU.

♦ Choose Enable Page Mode to display only one page or pane of text at a time, just as the UNIX more command does.

The pointer changes to a stop sign when the window fills up, as shown in Figure 6-6.

![Figure 6-6  Shell Tool Stop Sign Pointer](image)

Instead of displaying continuing text in the window, the display stops so that you can look at it as long as you like. The Enable Page Mode item on the Term Pane pop-up menu changes to Continue when there is more information that you can display.

♦ When you want to see the next pane, press any key or choose Continue from the Term Pane menu.

When there is no more data to display, the first item of the Term Pane menu changes to Disable Page Mode, which switches the display out of page mode.

♦ Use the Copy item to copy highlighted text from the Shell Tool window to the clipboard.

When there is text on the clipboard, you can use the Paste item to insert the contents of the clipboard at the insert point.

The Enable Scrolling item on the Term Pane menu can be used to turn the Shell Tool into a Command Tool. When you choose Enable Scrolling, the name stripe at the top of the Shell Tool still says “shelltool”, but the application acts like a Command Tool. See the section, “Command Tool” on page 276, for details.
Console

The Console is a special Command Tool window that is used to display error and system messages for the SunOS operating system, the OpenWindows environment, and some applications. You can recognize a Console window by the term (CONSOLE) in the Command Tool header.

If you do not have a Console window, messages are displayed in large type at the bottom of the screen. To clear such messages, choose Refresh from the Workspace menu. Always have one (and only one) Console window running. If you have more than one Console window running, messages are displayed in the most recently opened Console window. You may miss important system messages if you have more than one Console window running and do not look for messages in the newest one, or if you have opened a new Console window and then quit the most recently opened one.
Clock

The Clock application displays the current time in a window or icon. The current time can be displayed in either an analog or digital form, for any time zone around the world. The Clock application can also be used as a stopwatch or alarm clock.

The Clock relies on the date and time being correctly set. If you have not yet set the date and time on your system, refer to the manual page for date.

This chapter describes how to use and customize the Clock.

To display the Clock, choose Workspace ➤ Programs ➤ Clock.

Clock Icon and Window

The clock icon displays an analog clock with or without roman numerals, as shown in the examples in Figure 7-1. See the section “Customizing the Clock” on page 286 for information about how to display a Roman clock icon.

Figure 7-1 Clock Icons (Analog and Roman)
When you open the Clock icon, the clock is displayed in the pane of a base window, as shown in Figure 7-2. The current time zone is displayed beneath the clock if it is not the local time zone.

![Figure 7-2 Clock Window](image)

The Clock window has a header and resize corners. You can use the resize corners to change the area of the window, making the clock larger or smaller. You can also disable the header. See the manual page for `clock` for information about this and other customization features.

**Customizing the Clock**

You can customize the Clock using the settings in the Clock Properties window.

1. **Open the Clock if it is in icon form.**
2. **Display the Clock Properties window:**
   a. Move the pointer into the Clock pane.
   b. **Press MENU to display the Clock menu.**
      The Clock menu, shown in Figure 7-3, is displayed.

![Figure 7-3 Clock Pop-up Menu](image)
c. Choose Properties from the Clock menu.
   The Clock Properties window, shown in Figure 7-4, is displayed.

<table>
<thead>
<tr>
<th>Clock Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clock Face:</td>
</tr>
<tr>
<td>Icon display:</td>
</tr>
<tr>
<td>Digital display:</td>
</tr>
<tr>
<td>Display options:</td>
</tr>
<tr>
<td>Timezone:</td>
</tr>
<tr>
<td>Stopwatch:</td>
</tr>
<tr>
<td>Alarm: Hr:</td>
</tr>
<tr>
<td>Alarm command:</td>
</tr>
<tr>
<td>Repeat:</td>
</tr>
<tr>
<td>Hourly command:</td>
</tr>
</tbody>
</table>

Figure 7-4  Clock Properties Window

3. Change the settings, as desired.
   The settings are described in the following sections.
   • If you are dissatisfied with your changes, revert to previous settings by clicking SELECT on Reset.
   • If you want the new settings to become the default every time you start a new Clock, click SELECT on Save as Defaults.

4. Click SELECT on Apply.
   The new settings take effect immediately.
Changing to a Digital-Style Clock Face

The Clock face and icon are displayed in analog style, by default. To change the Clock face to digital display, click SELECT on the digital box in the Properties window, and then click SELECT on the Apply button. The digital style clock is shown in Figure 7-5.

![Digital-Style Clock Face](Figure 7-5)

Changing to a Roman-Style Clock Icon

To change the icon style from basic analog to Roman, click SELECT on the roman box, and then click SELECT on the Apply button. Both styles are shown in Figure 7-6.

Note – There is no digital-style icon option.

![Analog and Roman Icon Styles](Figure 7-6)
12-Hour or 24-Hour Clock

If you change the face style to digital, you also have the option of a 12-hour or 24-hour clock. The default is a 12-hour Clock, which has an A.M. or a P.M. printed next to it. The 24-hour Clock uses military time. For instance, 1:00 P.M. is displayed as 13:00. Figure 7-7 shows both the 12-hour and the 24-hour clocks.

![Figure 7-7 12-Hour and 24-Hour Clocks](image)

Displaying a Second Hand and the Date

If you select the Seconds display option, a second hand appears on the analog-style clock face and icon, and moves like the second hand on a physical analog clock. The digital-style clock face displays the passing seconds digitally.

Figure 7-8 shows both the 12-hour and the 24-hour clock faces with the Seconds option selected.

![Figure 7-8 Seconds Option on 12-Hour and 24-Hour Clocks](image)
Choose the Date option on the Props window if you would like to display the date at the bottom of the Clock window, as shown in Figure 7-9.

Figure 7-9  Date in the Digital Clock Face

Changing the Time Zone

You can display the current time in a different time zone using the Time zone option. The default is local. To choose a new time zone:

1. Open the Properties window, if not already opened.
   This is described in the section “Customizing the Clock” on page 286.

2. Click SELECT on the other option in the Timezone category, as shown in Figure 7-10.
   An abbreviated menu button appears.

   Figure 7-10  Timezone Category

3. Press MENU on the abbreviated menu button, drag the pointer to the desired time zone, and release.
   Figure 7-11 shows the list of time zones. Note that countries with more than one time zone have submenus containing the time zones for that country.
4. Click **SELECT** on the **Apply** button.

   The time for that zone then appears on the clock face or icon.
Using the Stopwatch

To use the stopwatch:

1. **Open the Clock if it is in icon form.**

2. With the pointer on the Clock, press MENU and choose Properties from the Clock menu.

3. **Select digital box for the Clock Face style.**
   The stopwatch also works in analog style, but it does not display the time in numerical form, so is less suited to use as a stopwatch.

4. **Click SELECT on the Stopwatch reset box, as shown in Figure 7-12.**
   The clock face changes to a timer, with 00 hours, 00 minutes, and 00 seconds.

   ![Stopwatch reset](Figure 7-12  Resetting the Stopwatch)

5. **Click SELECT on the Stopwatch start box when you want to begin timing.**
   The Clock begins clocking seconds as shown in Figure 7-13.

   ![Stopwatch start](Figure 7-13  Stopwatch in the Digital Display)

6. **Click SELECT on the Stopwatch stop box when the timing period is over.**

7. Click SELECT on the start box again if you want to resume timing.
8. Click SELECT on the reset box if you want the next timing session to begin with zero time.

9. Click SELECT on none to return to the regular Clock.

**Alarm Settings**

♦ To set the alarm, choose Properties ➤ Clock menu.

Use the Alarm Hr and Min settings to specify the time for an alarm. Use the Alarm command text field to type in the command that you’d like to take place at the alarm time. If you don’t specify a command, the Clock application will beep. For example, if your workstation has audio capabilities you can set the Clock to create a cuckoo sound with the following Alarm command:

```bash
sh -c “cat /usr/demo/SOUND/sounds/cuckoo.au > /dev/audio”
```

Use the Repeat settings to specify whether the alarm should happen just one time, or every day at the given time. The alarm will not occur if the Repeat setting is none.

If you want a command to take place hourly, type that command in the Hourly command text field. Clock processes this command as hourly and alarm commands, for example, $HOME/clock.hourly.

**Clock Keyboard Accelerators**

You can change many of the Clock settings without using the Properties window by moving the pointer anywhere within the open Clock window and typing the following keyboard accelerators:

- Type 1 to set the 12-hour display mode if the current Clock is digital.
- Type 2 to set the 24-hour display mode if the current Clock is digital.
- Type c to toggle the Clock face between analog and digital displays.
- Type d to toggle the Date display on and off.
- Type i to toggle the icon face between analog and Roman.
- Type s to toggle the seconds display on and off.
• Type S to set the stopwatch. Type S again to start the stopwatch. Type S a third time to stop the stopwatch. You can then type S to reset the stopwatch again, and so on.
• Type c when you want to reset the Clock to the normal clock display.
• Type t to toggle the time zone between local and other. You must have a valid Other time zone set on the Properties window for this to work.

Note that you can have more than one Clock running at a time. This is useful if you want one clock to display the time and another to display the Stopwatch.
The DeskSet Calculator is a scientific and financial calculator designed to perform a variety of mathematical functions. It operates in much the same way as many hand-held calculators. There are financial, logical, and scientific modes. You can store numbers in ten different memory registers and retrieve and replace them easily. In addition, you can store up to 10 of your own functions and constants in menus.

The Calculator displays numbers in fixed-point notation and decimal base, but you can change it to display numbers in engineering or scientific notation, and in binary, octal, or hexadecimal base.

This chapter describes how to use the Calculator. You can use Calculator with a mouse, as you do other OpenWindows applications, or without a mouse, as you would a physical hand-held calculator. With the mouse, you click SELECT on the Calculator buttons; otherwise, you use the keyboard.

♦ To open the Calculator application, choose Workspace ➤ Programs ➤ Calculator.
Calculator Icon and Base Window

The Calculator icon and base window are shown in Figure 8-1. The base window has six rows of eight buttons. Click SELECT on a button to activate it.

![Calculator Icon and Base Window](image)

The Calculator base window is resizable by using the resize corners (it might take a few seconds to redisplay when it’s resized).

Modes of Operation

The Calculator has various modes of operation. The area below the window header displays the current number, followed by a mode line that displays the current mode settings.

Numeric Bases

You can set the numeric bases to Binary, Octal, Decimal, or Hexadecimal using the Base key pop-up menu, as shown in Figure 8-2. Press MENU on the Base key to display the menu.
The current base setting is shown as the first item in the mode line. In Figure 8-2, “DEC” indicates Decimal base.

Up to 40 digits can be entered for each number, regardless of the base. If you need to enter a larger or smaller number, use the Exp key as discussed under “Number Manipulation Functions” on page 300. The numeric keypad changes to display only those numbers appropriate to the current base mode. Inappropriate numbers are dimmed out. For example, in Figure 8-2 the hexadecimal letter keys (A-F) are dimmed. The numeric base in that figure is decimal, so the hexadecimal letters are not valid or accessible.

- Choosing Binary displays the digits 0 and 1 on the numeric keypad.
- Choosing Octal displays the digits 0 through 7.
- Choosing Decimal displays the digits 0 through 9.
- Choosing Hexadecimal displays the digits 0 through 9 and also activates the alphabetic keys at the top of the numeric keypad.

Figure 8-3 shows the keypads for both Binary and Hexadecimal numeric bases.
Display Notation

You can choose to display Calculator results in Fixed point, Engineering, or Scientific notation by using the Disp (Display) key menu shown in Figure 8-4. Press MENU on the Disp key to display the menu.

The current display notation is displayed as the third item in the mode line. In Figure 8-4, the mode line shows FIX, indicating Fixed Point notation. When the current display notation is Engineering, ENG appears on the mode line. When the current notation is Scientific, SCI is displayed.

When the current notation is Fixed Point, the Calculator will revert to Scientific notation if a number is larger than the display will allow.
**Major Calculator Modes**

There are four major Calculator modes that determine the available functions:

- Basic
- Financial
- Logical
- Scientific

You can choose these four modes using the Mode pop-up menu shown in Figure 8-5. Press MENU on the Mode key to display the menu. The default mode is Basic mode, which uses the standard keys on the Calculator window. The other three modes have extra buttons that appear in a pop-up window. For information on these modes, see “Financial Functions” on page 306, “Logical Functions” on page 313, and “Scientific Functions” on page 314.

![Mode Pop-up Menu](image)
The current major mode is displayed on the mode line underneath and slightly to the left of the number display. In Figure 8-5, BASIC is listed as the current mode.

**Number Manipulation Functions**

The Calculator has 12 number manipulation functions, as shown in Figure 8-7.
• Int returns the integer portion of the currently displayed value.
• Frac returns the fractional portion of the currently displayed value.
• Abs returns the absolute value of the currently displayed value.
• +/- changes the arithmetic sign of the currently displayed value or of an exponent being entered with the Exp key.
• 1/x returns the value of 1 divided by the currently displayed value.
• x^2 returns the square of the currently displayed value.
• % calculates the percentage of the currently displayed value specified by the next value entered. For example, to find 75% of 40, enter 40, click SELECT on %, enter 75, then click SELECT on =. The Calculator returns the result, 30.
• Sqrt returns the square root of the currently displayed value.
• Parentheses give a calculation arithmetic precedence. All calculations within parentheses are calculated first. Parentheses can be nested. The result of an operation containing parentheses is not performed until the last parenthesis is matched.
• Exp starts exponential input. Any number entered after you choose Exp is taken to be the exponent portion of this number. The numbers entered before the Exp key are taken to be the mantissa. If no numerical input has occurred when the Exp key is entered, a mantissa of 1.0 is assumed. You can use the +/- key after entering the exponent to change its arithmetic sign.
• Asc displays the ASCII value of a character in the appropriate numeric base. Clicking on the Asc key displays a small pop-up window. Type the character that you want an ASCII equivalent for in the Character text field of the Get ASCII window, and then click SELECT on the ASCII button. The ASCII equivalent becomes the current value in the Calculator base window.
Miscellaneous Functions

The Calculator has five miscellaneous functions, shown in Figure 8-8.

- Clear (Clr) clears the current value from the display.
- Backspace (Bsp) deletes the rightmost character of the current display and recalculates its value.
- Keys changes the display of the Calculator keys to show the keyboard equivalents of each Calculator key for mouseless operation of the Calculator. See the section “Calculator Function Keys” on page 316, or the calctool manual page, for more information about the Calculator keyboard mapping.
- Accuracy (Acc) chooses the number of digits of precision used in the calculator display. This key has a pop-up menu associated with it, which lets you specify 0 through 9 radix places. The default value is 2 radix places.
- Quit quits the Calculator.
**Memory Registers**

The Calculator has 10 memory registers that you can access using the keys shown in Figure 8-9.

- Memory (Mem) displays a pop-up window showing the values of the 10 memory registers in the current base to the current accuracy.
- Store (Sto) stores the current value in the memory register that you choose from the Store pop-up menu.
- Recall (Rcl) retrieves a value from the memory register that you choose from the Recall pop-up menu.
- Register Exchange (Exch) exchanges the contents of the current display with the current value in the memory register that you choose from the Exch key pop-up menu.

♦ To display the Exch, Sto, and Rcl pop-up menus, press MENU on the buttons.
User-Defined Functions

The Calculator allows you to enter your own set of constants and to define your own functions through the Con and Fun keys shown in Figure 8-10.

![Figure 8-10 User-defined Function Keys](image)

Each of these keys has a menu associated with it, which you display by pressing MENU on the key. Choosing the first item from the menu displays a window that lets you enter the value of a constant or a function, and associate a name with that value. The numbers you enter are stored in a .calctoolrc file in your home directory.

Once you have entered the new value, the new value and its name are displayed in the pop-up menu associated with that Calculator key. To use the constant or function value, choose the desired item from the pop-up menu.

Performing Simple Calculations

Calculations are performed from left to right, with no arithmetic precedence. For example, 2+3*4=20. You need parentheses, available on the Calculator base window, to establish correct arithmetic precedence. For example, 2+(3*4)=14.

To perform a numerical operation, such as adding two numbers together:

1. Click SELECT on the first digit, for example, 7.
   The number is entered in the display at the upper right corner of the Calculator. In Figure 8-1 the number 0.00 is displayed.
2. Click SELECT on the operation you want to perform, for example, +.

3. Click SELECT on the number you want to add to the first number, for example, 6.
   The number is displayed in the numeric display area.

4. Click SELECT on the = sign.
   The result, 13 in this example, is displayed in the numeric display area.

Alternatively, you can use the keyboard to enter numbers and simple functions. You can also use the Copy key to store the numeric display to the clipboard, and the Paste key to retrieve the contents of the clipboard. If you want to copy just a portion of the numeric display, use the SELECT and ADJUST mouse buttons to define the portion of the numeric display to copy.

If an operation needing more than one input is partially complete, the pending operation is displayed on the line beneath the current number as a reminder.

**Creating and Saving a Function**

Note that when you enter a value for a new function, you must type the keyboard equivalents in the Value field. To display the keyboard equivalents for each Calculator key, click SELECT on the Keys button.

The following example describes how to create and save a function that adds together two numbers taken from memory registers, and stores the result in another memory register.

1. Choose Enter Function from the Fun key menu.
   The Enter Function pop-up window is displayed.

2. Type in the number of the function you wish to add or replace in the Function No: field.
   The function number must be in the range 0 through 9.

3. Type a function name in the Description field, for example, addition.
4. **Type a function into the Value field.**
   To add the numbers in Memory Registers 1 and 2, and store the sum in Register 5, type \( R1 + R2 = S5 \). \( R \) means “Retrieve register 1,” \( R2 \) means “Retrieve register 2,” and \( S5 \) means “Store into register 5.” See Table 8-1 at the end of this chapter for the keyboard equivalents (such as \( R \) and \( S \)) that you can use when creating your functions.

When you create your own functions, if you want to use a function from one of the function windows (that is, the Financial, Logical, or Scientific windows), make sure to include a command to change modes. For example, if you want to retrieve the contents of memory register 3 and get the factorial value of it, \( R3! \) will not work, because you need to change to Scientific mode before retrieving the factorial. Instead, use \( R3Ms!Mb \). This function translates correctly to “Retrieve the contents of memory register 3, change mode to Scientific mode, get the factorial value, and change mode back to Basic mode.”

5. **Click SELECT on the Enter Function button to store the new function in your .calctoolrc file and add it to the Functions menu.**

To use the new function, choose it from the Functions menu.

When creating functions, remember that calculations are performed from left to right, with no arithmetic precedence. For example, the calculation \( 2 + 3 \times 4 \) as performed by the DeskSet Calculator gives a result of 20. The same equation performed with canonical arithmetic precedence would give a result of 14. This can be achieved with the Calculator by using parentheses: \( 2 + (3 \times 4) \)

### Financial Functions

The Calculator has the financial functions shown in Figure 8-11. Choose Financial from the Mode key pop-up menu to display the Financial Mode window.
The financial functions retrieve needed information from the memory registers. For example, in order to determine the amount of an installment payment, the Calculator needs to know the amount of the loan, the interest rate, and the term of the loan. You must store this information in the appropriate registers before you click SELECT on the financial function button. See “Memory Registers” on page 303 to learn how to store numbers in the registers.

The following function descriptions include information about what the Calculator expects to find in each register for each function, plus examples of how to use each function.

**Ctm: Compounding Term**

Use Ctm to compute the number of compounding periods it will take an investment of present value to grow to a future value, earning a fixed interest rate per compounding period. Store the following numbers in the memory registers:

- Register 0: Periodic interest rate
- Register 1: Future value of the investment
- Register 2: Present value of the investment

**Ctm Example:**

You have just deposited $8,000 in an account that pays an annual interest rate of 9%, compounded monthly. You want to determine how long it will take to double you investment.

- Register 0: 0.01 (interest rate = 9% / 12)
- Register 1: 16000 (future value)
- Register 2: 8000  (present value)
Clicking SELECT on Ctrm returns 92.77, which tells you that it would take 92.77 months, or almost eight years, to double your $8,000.

**Ddb: Double-Declining Depreciation**

Use Ddb to compute the depreciation allowance on an asset for a specified period of time, using the double-declining balance method. Store the following information in the memory registers:

- Register 0: Amount paid for asset
- Register 1: Salvage value of asset at end of life
- Register 2: Useful life of an asset
- Register 3: Time period for depreciation allowance

**Ddb Example:**

You have purchased an office machine for $8,000. The useful life of this machine is six years. The salvage value after six years is $900. You want to compute the depreciate expense for the fourth year, using the double-declining balance method.

Memory register usage:

- Register 0: 8000 (amount paid for asset)
- Register 1: 900 (value of asset at end of its life)
- Register 2: 6 (useful life of the asset)
- Register 3: 4 (time period for depreciation allowance)

Clicking SELECT on Ddb returns 790.12, which tells you that the depreciation expense for the fourth year will be $790.12.

**Fv: Future Value**

Use Fv to determine the future value of an investment. The Calculator computes the future value based on a series of equal payments, earning a periodic interest rate over the number of payment periods in a term. The memory registers need to contain the following numbers:

- Register 0: Amount of each payment
- Register 1: Interest rate
- Register 2: Number of payments
Fv Example:
You plan to deposit $4,000 each year for the next 20 years into a bank account. The account is paying 8% interest, compounded annually. Interest is paid on the last day of each year. You want to compute the value of your account in 20 years. You make each year’s contribution on the last day of the year.

Memory register usage:
- Register 0: 4000 (periodic payment)
- Register 1: 0.08 (periodic interest rate is 8%)
- Register 2: 20 (number of periods)

Clicking SELECT on Fv returns 183047.86, the value of your account in dollars at the end of 20 years.

Pmt: Periodic Payment
Use Pmt to compute the amount of the periodic payment of a loan. Most installment loans are computed like ordinary annuities, in that payments are made at the end of each payment period. Store the following information in the memory registers:
- Register 0: Principal or amount of the loan
- Register 1: Periodic interest rate of the loan
- Register 2: Term, or number of payments

Pmt Example:
You are considering taking out a $120,000 mortgage for 30 years at an annual interest rate of 11.0%. You want to determine your monthly repayment.

Memory register usage:
- Register 0: 120000 (principal).
- Register 1: 0.00916 (periodic interest rate is 11.0% / 12)
- Register 2: 360 (term - 30 x 12)

Clicking SELECT on Pmt returns 1142.06, the value in dollars of your monthly repayment.
**Pv: Present Value**

Use Pv to determine the present value of an investment. The Calculator computes the present value based on a series of equal payments discounted at a periodic interest rate over the number of periods in the term. The following information is retrieved from the memory registers:

- Register 0: Amount of each payment
- Register 1: Periodic interest rate
- Register 2: Term, or number of payments

**Pv Example:**

You have just won a million dollars. The prize is awarded in 20 annual payments of $50,000 each (a total of $1,000,000 over 20 years). Annual payments are received at the end of each year. You are given the option of receiving a single lump-sum payment of $400,000 instead of the million dollars annuity. You want to find out which option is worth more in today's dollars.

If you were to accept the annual payments of $50,000, you assume that you would invest the money at a rate of 9%, compounded annually.

Memory register usage:

- Register 0: 50000 (periodic payment).
- Register 1: 0.09 (periodic interest rate is 9%)
- Register 2: 20 (term)

Clicking SELECT on Pv returns a value of 456427.28, which tells you that the $1,000,000 paid over 20 years is worth $456,427 in present dollars. Based on your assumptions, the lump-sum payment of $400,000 is worth less than the million-dollar ordinary annuity, in present dollars (before taxes).

**Rate: Periodic Interest Rate**

Use Rate to compute the periodic interest rate. It returns the periodic interest necessary for a present value to grow to a future value over the specified number of compounding periods in the term. Store the following information in the memory registers:

- Register 0: Future value
- Register 1: Present value
- Register 2: Term, or number of compounding periods
Rate Example:
You have invested $20,000 in a bond. The bond matures in five years and has a maturity value of $30,000. Interest is compounded monthly. You want to determine the periodic interest rate for this investment.

Note – Before entering the information into the memory registers, choose 5 radix places from the Acc (accuracy) key pop-up menu to produce more accurate results.

Memory register usage:
- Register 0: 30000 (future value)
- Register 1: 20000 (present value)
- Register 2: 60 (term - 5 x 12)

Clicking SELECT on Rate returns 0.0678, which tells you that the periodic (monthly) interest rate is 0.678%, under 1% per month. To determine the annual rate, multiply the above formula by 12, which yields a result of 8.14%.

Sln: Straight-line Depreciation
Use Sln to compute the straight-line depreciation of an asset for one period. The straight-line method of depreciation divides the depreciable cost (actual cost minus salvage value) evenly over the useful life of an asset. The useful life is the number of periods, typically years, over which an asset is depreciated. Use the memory registers to store the following information:
- Register 0: Cost of the asset
- Register 1: Salvage value of the asset
- Register 2: Useful life of the asset

Sln Example:
You have purchased an office machine for $8,000. The useful life of this machine is six years, and the salvage value in eight years will be $900. You want to compute yearly depreciation expense, using the straight-line method.
Memory register usage:

- Register 0: 8000 (cost of the asset)
- Register 1: 900 (salvage value of the asset)
- Register 2: 6 (useful life of the asset)

Clicking SELECT on Sln returns 1183.33, the yearly dollar depreciation allowance.

**Syd: Sum-of-the-years’-digits Depreciation**

Use Syd to compute the sum-of-the-years’-digits depreciation. This method of depreciation accelerates the rate of depreciation so that more depreciation expense occurs in earlier periods than in later ones. The depreciable cost is the actual cost minus salvage value. The useful life is the number of periods, typically years, over which an asset is depreciated. Store the following information in the memory registers:

- Register 0: Cost of the asset
- Register 1: Salvage value of the asset
- Register 2: Useful life of the asset
- Register 3: Period for which depreciation is computed

**Syd Example:**

You have just purchased an office machine for $8,000. The useful life of this machine is six years, and the salvage value after eight years will be $900. You want to compute the depreciation expense for the fourth year, using the sum-of-the-years’-digits method.

Memory register usage:

- Register 0: 8000 (cost of the asset)
- Register 1: 900 (salvage value of the asset)
- Register 2: 6 (useful life of the asset)
- Register 3: 4 (period for which depreciation is computed)

Clicking SELECT on Syd returns 1014.29, the dollar depreciation allowance for the fourth year.
Term: Payment Period

Use Term to compute the number of payment periods in the term of an ordinary annuity necessary to accumulate a future value earning a specified periodic interest rate. Store the following information in the memory registers:

- Register 0: Amount of each periodic payment
- Register 1: Future value
- Register 2: Periodic interest rate

Term Example:
You deposit $1,800 at the end of each year into a bank account. Your account earns 11% a year, compounded annually. You want to determine how long it will take to accumulate $120,000.

Memory register usage:

- Register 0 - 1800  (periodic payment)
- Register 1 - 120000 (future value)
- Register 2 - 0.11  (periodic interest rate is 11%)

Clicking SELECT on Term returns 20.32, the number of years it will take to accumulate $120,000 in your account.

Logical Functions

The Calculator has the logical functions shown in Figure 8-12. This pop-up window is displayed when you choose Logical from the Mode key pop-up menu.

![Logical Functions](Figure 8-12)
• Use < to shift the displayed value, treated as a 32 bit integer, to the left. This key has a pop-up menu. The number of places to shift can be selected from this menu, and ranges from 1 through 15.

• Use > to shift the displayed value, treated as a 32 bit integer, to the right. This key has a pop-up menu. The number of places to shift can be selected from this menu, and ranges from 1 through 15.

• Use &16 to truncate the current display to a 16-bit integer.

• Use &32 to truncate the current display to a 32-bit integer.

• Use Or to perform a logical OR operation on the last number and the next number entered, treating both numbers as 32-bit integers.

• Use And to perform a logical AND operation on the last number and the next number entered, treating both numbers as 32-bit integers.

• Use Not to perform a logical NOT operation on the currently displayed value.

• Use Xor to perform a logical XOR operation on the last number and the next number entered, treating both numbers as 32-bit integers.

• Use Xnor to perform a logical XNOR operation on the last number and the next number entered, treating both numbers as 32-bit integers.

Scientific Functions

The Calculator has the scientific functions shown in Figure 8-13. This window is displayed when you choose Scientific from the Mode key pop-up menu.

![Figure 8-13 Scientific Functions](image)

• Press MENU pm the Trig key to access a pop-up menu to set the trigonometric base to Degrees, Radians, or Gradients. The current trigonometric base is indicated by the second item on the mode line.
• Use Hyp as a toggle for setting or unsetting the hyperbolic function flag. This flag affects SIN, COS, and TAN functions. When this flag is set, the word HYP appears on the mode line beneath the numeric display.

• Use Inv as a toggle for setting or unsetting the inverse function flag. This flag affects SIN, COS, and TAN trigonometric functions. When this flag is set, the word INV appears on the mode line beneath the numeric display.

• Use \( e^x \) to return \( e \) raised to the power of the currently displayed value.

• Use \( 10^x \) to return 10 raised to the power of the currently displayed value.

• Use \( y^x \) to raise the last number entered to the power of the next number.

• Use \( x! \) to return the factorial of the currently displayed value. The factorial function only works for positive integers.

• Use Cos to return the trigonometric cosine, arc cosine, hyperbolic cosine, or inverse hyperbolic cosine of the current value, depending on the settings of the hyperbolic and inverse function toggles. (See Hyp and Inv listed previously.) The result is displayed in the current trigonometric base.

• Use Sin to return the trigonometric sine, arc sine, hyperbolic sine, or inverse hyperbolic sine of the current value, depending on the settings of the hyperbolic and inverse function toggles. (See Hyp and Inv.) The result is displayed in the current trigonometric base (degrees, radians, or gradients).

• Use Tan to return the trigonometric tangent, arc tangent, hyperbolic tangent, or inverse hyperbolic tangent of the current value, depending on the settings of the hyperbolic and inverse function toggles. (See Hyp and Inv.) The result is displayed in the current trigonometric base (degrees, radians, or gradients).

• Use Ln to return the natural logarithm of the currently displayed value.

• Use Log to return the base 10 logarithm of the currently displayed value.

• Use Rand to return a random number between 0.0 and 1.0.

Click SELECT on the Set Default button to make your Appearance, Base, Mode, Display, Accuracy, Contents, Functions, and Style settings the default every time you start a new Calculator.
### Calculator Function Keys

Every function in the Calculator application has a keyboard equivalent associated with it. Table 8-1 lists each Calculator function with its keyboard equivalent. See the manual page for `calctool` for a more complete description of each function. The manual page for `calctool` also lists Calculator command line options and various resources that can be set in your `.Xdefaults` or `.desksetdefaults` files.

Keyboard equivalents listed in brackets indicate a choice of options. For example, the keyboard equivalent for the Disp function is D [e, f, s]. This means that you can enter De, Df, or Ds. Similarly, the Exch function keyboard equivalent is F [0-9], which means you can enter F0, F1, F2, etc. through F9.

*Table 8-1  Calculator Function Keyboard Equivalents (1 of 5)*

<table>
<thead>
<tr>
<th>Number Manipulation Operators</th>
<th>Function</th>
<th>Keyboard Equivalent</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Int</td>
<td>Control-i</td>
<td>Integer portion of current entry</td>
</tr>
<tr>
<td></td>
<td>Frac</td>
<td>Control-f</td>
<td>Fractional portion of entry</td>
</tr>
<tr>
<td></td>
<td>Abs</td>
<td>Control-u</td>
<td>Absolute value of current entry</td>
</tr>
<tr>
<td></td>
<td>+/-</td>
<td>C</td>
<td>Change arithmetic sign</td>
</tr>
<tr>
<td></td>
<td>1/x</td>
<td>r</td>
<td>1 divided by current entry</td>
</tr>
<tr>
<td></td>
<td>x^2</td>
<td>@</td>
<td>Square of current entry</td>
</tr>
<tr>
<td></td>
<td>%</td>
<td>%</td>
<td>Percentage using current entry and next entry</td>
</tr>
<tr>
<td></td>
<td>Sqrt</td>
<td>s</td>
<td>Square root</td>
</tr>
<tr>
<td></td>
<td>Asc</td>
<td>Control-a char</td>
<td>Displays ASCII value of character typed after Control-a</td>
</tr>
</tbody>
</table>

### Menu Operators

| Menu Operators | Base | B [b,o,d,h] | Change the base to binary [b], octal [o], decimal [d], or hexadecimal [h] |

---

*Solaris User’s Guide—September 1995*
Table 8-1  Calculator Function Keyboard Equivalents (2 of 5)

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard Equivalent</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disp</td>
<td>D [e,f,s]</td>
<td>Change display mode to engineering [e], fixed point [f], or scientific [s]</td>
</tr>
<tr>
<td>Mode</td>
<td>M [b,f,l,s]</td>
<td>Change calculator mode to default basic mode [b], or to financial [f], logical [l], or scientific [s] mode</td>
</tr>
<tr>
<td>Acc</td>
<td>A[0-9]</td>
<td>Set display accuracy to 0 through 9 significant digits</td>
</tr>
<tr>
<td>Con</td>
<td># [0-9] (defaults)</td>
<td>Display a constant value. The constants are labeled from 0 through 9 and can be defined by entries in the .calctoolrc file. Default values are: 0 - 0.621 (kms per hour / mph) 1 - 1.41421 (square root of 2) 2 - 2.71828 (e) 3 - 3.14159 (pi) 4 - 2.54 (cms / inch) 5 - 57.2958 (degrees in radian) 6 - 1048576.0 (2 to power of 20) 7 - 0.0353 (gms / oz) 8 - 0.948 (kilojoules / thermals) 9 - 0.0610 (cubic cms / cubic in)</td>
</tr>
<tr>
<td>Fun</td>
<td>F[0-9]</td>
<td>Execute a function. There are 10 functions, labeled 0 through 9, taken from .calctoolrc.</td>
</tr>
</tbody>
</table>
### Table 8-1  Calculator Function Keyboard Equivalents (3 of 5)

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard Equivalent</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rcl</td>
<td>R[0-9]</td>
<td>Retrieve value in memory register. There are 10 memory registers, labeled 0 through 9</td>
</tr>
<tr>
<td>Sto</td>
<td>S[0-9]</td>
<td>Store value in memory register 0 through 9</td>
</tr>
<tr>
<td>Exch</td>
<td>X[0-9]</td>
<td>Exchange current entry with contents of memory register 0 through 9</td>
</tr>
<tr>
<td>Clr</td>
<td>Delete</td>
<td>Clear calculator display</td>
</tr>
<tr>
<td>Bsp</td>
<td>Back Space</td>
<td>Delete rightmost character and recalculate</td>
</tr>
<tr>
<td>(and)</td>
<td>(and)</td>
<td>Set arithmetic precedence</td>
</tr>
<tr>
<td>Exp</td>
<td>E</td>
<td>Turn current entry into scientific notation mantissa. Next entry becomes exponent.</td>
</tr>
<tr>
<td>Keys</td>
<td>k</td>
<td>Toggle labels on calculator buttons between mouse and keyboard equivalents</td>
</tr>
<tr>
<td>Mem</td>
<td>m</td>
<td>Display window showing 10 memory register values</td>
</tr>
<tr>
<td>Quit</td>
<td>q or Q</td>
<td>Exit Calculator</td>
</tr>
<tr>
<td>Ctrm</td>
<td>Control-t</td>
<td>Compounding term</td>
</tr>
<tr>
<td>Ddb</td>
<td>Control-d</td>
<td>Double-declining depreciation</td>
</tr>
<tr>
<td>Fv</td>
<td>v</td>
<td>Future value</td>
</tr>
<tr>
<td>Pmt</td>
<td>P</td>
<td>Periodic payment</td>
</tr>
<tr>
<td>Pv</td>
<td>p</td>
<td>Present value</td>
</tr>
<tr>
<td>Rate</td>
<td>Control-r</td>
<td>Periodic interest rate</td>
</tr>
<tr>
<td>Sln</td>
<td>Control-s</td>
<td>Straight-line depreciation</td>
</tr>
<tr>
<td>Function</td>
<td>Keyboard Equivalent</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>---------------------</td>
<td>---------------------------------------</td>
</tr>
<tr>
<td>Syd</td>
<td>Control-y</td>
<td>Sum-of-the-years’-digits depreciation</td>
</tr>
<tr>
<td>Term</td>
<td>T</td>
<td>Payment period</td>
</tr>
<tr>
<td>&lt;</td>
<td>&lt;</td>
<td>Shift current entry left</td>
</tr>
<tr>
<td>&gt;</td>
<td>&gt;</td>
<td>Shift current entry right</td>
</tr>
<tr>
<td>&amp;16</td>
<td>[</td>
<td>Truncate to 16-bit unsigned integer</td>
</tr>
<tr>
<td>&amp;32</td>
<td>]</td>
<td>Truncate to 32 bit unsigned integer</td>
</tr>
<tr>
<td>Or</td>
<td></td>
<td></td>
</tr>
<tr>
<td>And</td>
<td>&amp;</td>
<td>Logical AND of current and next entries</td>
</tr>
<tr>
<td>Not</td>
<td>~</td>
<td>Logical NOT of current entry</td>
</tr>
<tr>
<td>Xor</td>
<td>^</td>
<td>Logical XOR or current and next entries</td>
</tr>
<tr>
<td>Xnor</td>
<td>n</td>
<td>Logical XNOR of current and next entries</td>
</tr>
<tr>
<td>Trig</td>
<td>T[d,g,r]</td>
<td>Set trigonometrical base to degrees [d], gradians [g], or radians [r]</td>
</tr>
<tr>
<td>Hyp</td>
<td>h</td>
<td>Toggle hyperbolic function indicator</td>
</tr>
<tr>
<td>Inv</td>
<td>i</td>
<td>Toggle inverse function indicator</td>
</tr>
<tr>
<td>e^x</td>
<td>{</td>
<td>e raised to the power of current entry</td>
</tr>
<tr>
<td>10^x</td>
<td>}</td>
<td>10 raised to the power of current entry</td>
</tr>
</tbody>
</table>

Logical Mode Operations

Scientific Mode Operations
Customizing Your Calculator

Use the Calculator Properties window to customize the look and layout of your Calculator. To display the Properties window, place the pointer anywhere in the Calculator application:

♦ Press MENU, Choose Properties from the Calculator pop-up menu, and release MENU.

The Properties window is shown in Figure 8-14.

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard Equivalent</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>y^x</td>
<td>y</td>
<td>Current entry raised to power of next entry</td>
</tr>
<tr>
<td>x!</td>
<td>!</td>
<td>Factorial of current entry</td>
</tr>
<tr>
<td>Cos</td>
<td>Control-c</td>
<td>Cosine of current entry</td>
</tr>
<tr>
<td>Sin</td>
<td>Control-s</td>
<td>Sine of current entry</td>
</tr>
<tr>
<td>Tan</td>
<td>Control-t</td>
<td>Tangent of current entry</td>
</tr>
<tr>
<td>Ln</td>
<td>N</td>
<td>Natural logarithm of current entry</td>
</tr>
<tr>
<td>Log</td>
<td>G</td>
<td>Base 10 logarithm of current entry</td>
</tr>
<tr>
<td>Rand</td>
<td>?</td>
<td>Random number from 0.0 through 1.0</td>
</tr>
</tbody>
</table>
• Use the Appearance setting to determine if your Calculator is displayed with two- or three-dimensional buttons. The default is two-dimensional for performance reasons.

• Use the Display setting to determine if your Calculator is shown in black-and-white or color. Color is applicable only on machines that support it.

• Use the Style setting to determine the layout of the Calculator. The default layout is with the number keys on the left. If you choose the right-handed Style setting and click SELECT on Apply or Save as Defaults, the Calculator will be laid out with the number keys on the right, as shown in Figure 8-15.

Figure 8-14  Calculator Properties Window
Click SELECT on the Save as Defaults button to make your Appearance, Base, Mode, Display, Accuracy, Contents, Functions, and Style settings the default every time you start a new Calculator.
The Performance Meter, designed to meet application developer needs, allows you to monitor many aspects of system performance, such as processor performance, network performance, and I/O performance.

You can use a single Performance Meter to monitor different factors one at a time, or you can use several meters to monitor separate factors simultaneously. However, running a number of Performance Meters simultaneously degrades system performance.

♦ To start Performance Meter, choose Workspace ➤ Programs ➤ Performance Meter.

The Performance Meter icon is shown in Figure 9-1.

![Performance Meter Icon](image)

Figure 9-1  Performance Meter Icon

**Performance Meter Displays**

There are two types of display for the Performance Meter: dial and graph. The dial display, shown in Figure 9-2, is a speedometer-like dial with two needles.
The needles move as system conditions change. The short needle, or hour hand, tracks average performance over a 20-second interval, and the long one, or minute hand, tracks current performance over a 2-second interval. The display is updated every two seconds. You can change these default interval times from the Performance Meter Properties window. See “Customizing Performance Meters” on page 326 for information about setting Performance Meter properties.

The name of the performance option being measured is displayed in the lower left corner of the window. Its maximum value is shown in the lower right corner. For example, if the Performance Meter measures percentage, the long hand pointing straight up would indicate 50 percent.

You can use the Performance Meter Properties window to change the display to a graph. See “Performance Meter Display Options” on page 328. With a graph display, performance data is shown as a strip chart. Figure 9-3 shows an example of the Performance Meter window with a graph display.

The graph can be a line graph, as shown in Figure 9-3, or a solid graph. See “Performance Meter Display Options” on page 328 for information about displaying a solid graph.

The window has resize corners that you can use to change the area of the window when you are displaying a graph. A resized Performance Meter window is shown in Figure 9-4.
Figure 9-4  Resized Performance Meter Window

If there is not enough room to display all the text associated with a graph, as much of the text is displayed as possible, and the last character is a “-“. This indicates that you should resize the window to be wider in order to see all the text.

Performance Meter Menu

You can change the performance value to be monitored in a Performance Meter window by choosing an item from the Performance Meter pop-up menu shown in Figure 9-5. To display this pop-up menu, move the pointer to anywhere in the Performance Meter window and press MENU.

Figure 9-5  The Performance Meter Pop-up Menu

Here are the performance values you can display:

• Show cpu monitors the percent of CPU being used.
• Show packets monitors the number of Ethernet packets per second.
• Show page monitors the paging activity in pages per second.
• Show swap monitors the number of jobs swapped per second.
• Show interrupts monitors the number of device interrupts per second.
• Show disk monitors disk traffic in transfers per second.
• Show context monitors the number of context switches per second.
• Show load monitors the average number of runnable processes over the last minute.
• Show collisions monitors the number of collisions per second detected on the Ethernet.
• Show errors monitors the number of errors per second on receiving packets.

If the Performance Meter is displaying just one graph or dial when you choose an option from the pop-up menu, that graph is replaced with the new selection. If the Performance Meter is displaying more than one graph or dial, the new one is added to the display.

Customizing Performance Meters

You can customize many aspects of the Performance Meter from the Properties window shown in Figure 9-6. Choose Properties from the Performance Meter pop-up menu to display the Properties window, or move the pointer anywhere into the Performance Meter window and press the Props key on your keyboard.
Performance Meter Monitors

Selecting one or more of the Monitor settings and clicking SELECT on the Apply button changes the display to show performance of the selected item or items. If more than one Monitor setting is selected, the Performance Meter displays all of the selected dials or graphs at the same time. Figure 9-7 shows three aspects of system performance being monitored at the same time.

The Direction setting determines whether multiple monitors are displayed side-by-side (horizontally), or stacked on top of each other (vertically). In Figure 9-7, the Direction setting is horizontal. In Figure 9-8, the Direction setting is vertical.
Figure 9-8  Performance Monitor with Vertical Displays

Note that the performance meter does not try to fit multiple graphs in the window based on the shape of the window. It always uses the Direction setting to determine if the graphs are displayed horizontally or stacked vertically. For example, if you have a vertical display like the one in Figure 9-8, resizing the window to be short and wide (as in Figure 9-7) does not change the Direction display to be horizontal.

Performance Meter Display Options

As discussed earlier, you can monitor system performance with either dial or graph displays. Use the Display setting of the Performance Meter Properties window to choose Dial or Graph displays. Remember to click SELECT on Apply to change the display in this session only, or click SELECT on Set Default to make the selected display your default every time you start the Performance Meter.

If you choose Graph, the Graph Type setting is activated on the Properties window. Choose Line to display a single line graph, and choose Solid to display a solid graph. Figure 9-9 shows a Performance Meter with a line graph on the left, and a solid graph on the right.

Figure 9-9  Line Graph and Solid Graph Displays
**Performance Meter Machine**

You can monitor performance for your own system or for another system on the network. To monitor a remote system, follow these steps:

1. **Click SELECT on the Remote Machine setting of the Performance Meter Properties window.**
   The Machine name text field is activated.

2. **Type the name of the machine you want to monitor in the text field.**

3. **Click SELECT on the Apply or Set Default button.**
   The Performance Meter displays the name of the remote system at the bottom of the pane under the name of the value you are monitoring, as shown in Figure 9-10. Click SELECT on Set Default to make the remote system the default monitored system every time you run the Performance Meter.

![Figure 9-10 Monitoring a Remote Machine](image)

To change back to your system, click SELECT on Local, then click SELECT on the Apply or Set Default button.

**Performance Meter Display and Sample Intervals**

You can change the Sample Time (the frequency that the meters are updated) and the units measured by the hour and minute hands on the dial display with the Sample time, Hour hand, and Minute hand settings. The default is for the hour hand to show a sample over a 20-second interval and the minute hand the average over a 2-second interval. If you change the values in these fields, remember to click SELECT on the Apply or Set Default button to record the changes.
If you’d like to save and examine individual samples, check the Log Samples checkbox on the Properties window. This activates the Filename text field. Samples are saved in the file typed in the Filename text field. If no file name is specified, samples are saved in a file in your home directory called
`perfmeter.logXXX`, where `XXX` is replaced by a unique identifier.

Do not specify the same file name for more than one Performance Meter at the same time. Either specify a different file name for each sample file, or do not specify any file name at all and let the Performance Meter construct unique file names.

**Caution** – Do not leave the Performance Meter running for a long time with Log Samples on. The file with the samples will keep getting larger until your system runs out of disk space on the file’s partition.

**Shortcuts**

The Performance Meter has keyboard accelerators that you can use to quickly toggle property settings without using the Properties window. To use these keyboard accelerators, move the pointer anywhere into the Performance Monitor window and type the letter as follows:

- Type `d` to toggle the Direction setting. If multiple monitors are displayed vertically, they will be changed to a horizontal display, and vice-versa.
- Type `g` to toggle the Display setting between the Dial and Graph display.
- Type `q` to quit the Performance Meter application.
- Type `s` to toggle a graph display style between Line and Solid graphs.
- Type `t` to toggle the Machine setting between Local and Remote.
Print Tool

The Print Tool DeskSet application provides an easy way to print files. Print Tool provides a graphical user interface to the UNIX printing functions.

This chapter describes the functions of the Print Tool. For information about UNIX printing functions, see System Administration Guide, Volume II or the Solaris Advanced User’s Guide.

♦ To start Print Tool, choose Workspace ➤ Programs ➤ Print Tool.

Print Tool Icons

You can print files by dragging and dropping files from the File Manager or a header attachment from the Mail Tool onto the Print Tool icon, which is shown in Figure 10-1.

Figure 10-1 Print Tool Icon-Before and During Printing
The name of the current printer is displayed at the bottom of the Print Tool icon. When a file is dragged and dropped onto the Print Tool, the footer of the open Print Tool window displays the name of the file being printed and may also display error messages. You can drag and drop files to be printed onto the drop target of the Print Tool window and onto the Print Tool icon.

Print Tool Window

You can perform the following operations from the Print Tool window, as shown in Figure 10-2:

- Print files using the Filename text field and the Print button.
- Print files by dragging and dropping files from other applications.
- Specify the number of copies to print.
- Specify a header page.
- Choose which of the available printers to use.
- Use the Information button to view information about each printer, if set up by system administrator.
- Specify an executable print command or print script for use with the file to be printed.
- Display print queue status.
- Stop printing job(s) in this print queue.
- Change printer property information such as including a header page, notification of job completion, overriding a default print method.
Printing Files

There are two ways to print files:

- By typing the filename in the Print Tool window
- By dragging and dropping

With both methods, status messages are displayed in the footer of the Print Tool window. The following sequence of messages is typical (each time you start a print job or change printers):

**Figure 10-2  Print Tool Window**
1. Printing `<filename>`
   This flashes for a short time before displaying:

2. no entries
   You see no entries once all the job(s) have been completed.

If the properties have been set, the Print Tool window flashes and beeps, when all printing jobs have been completed.

If you want to print a file with a format other than the default, you need to supply an alternative print method. Refer to “Changing the Print Method in the Print Tool” on page 339 for information on these procedures.

Typing the Filename in the Print Window

To print by typing the file name in the Print Tool window:

1. **Type the file’s full path name in the Filename text field.**
   If the file is in your home directory, just type the filename. Otherwise, start the path name from your home directory and include each subdirectory in the path to the file in the form: `directory1/directory2/filename`.

2. **Click SELECT on the Print button.**

Dragging and Dropping the File

When you drag a file from another application, you can drop it onto either the Print Tool icon or the drop target of the Print Tool window.

To print a file by dragging and dropping:

1. **Display the item you want to print.**
   For example:
   - A file in the File Manager window
   - A mail message in Mail Tool
   - An attachment in a Mail Tool message

2. **Drag the icon or message header to either the Print Tool icon or the drop target in the Print Tool window.**
   To drag more than one file, click ADJUST on additional files.
3. Release the mouse button to drop the file.
   Printing should begin.

![Figure 10-3 Dropping a File on the Print Tool Drop Target](image)

Choosing Another Printer

When the Print Tool window is open, the list of available printers is shown in the scrolling list for Printer. The list is alphabetical with the default printer highlighted and located at the top of the list, if it exists. If a default printer does not exist, the first printer in the list is highlighted.

To choose another printer, follow these steps:

1. **Scroll down the list until the printer you want to use is visible.**
2. Select the printer name.
   The printer must be available. For information on adding a printer, refer to
   System Administration Guide, Volume II.

   The printer you chose is selected, as shown in the example in Figure 10-3.

Checking the Print Queue Status

To check the status of your print jobs, click SELECT on the Status button near
the bottom of the Print Tool window. The scrolling status window lists by job,
size (in KB), and time all of your files or jobs (for the selected printer) in the
print queue as shown in Figure 10-4.

![Print Tool window](image)

Figure 10-4  Example of Entries in the Print Queue
Each entry in the print queue is identified by Job, Size (in KB), and Time. The Job category shows a unique job number for each file in the queue. It is also helpful to know the size of a print job. Time shows the time the job was submitted. Figure 10-4 shows that the job ranked first will take longer to print than the following job, because it is larger in size.

**Stopping a Print Job**

You can stop one or more of your jobs in the queue. To stop your job(s) in the queue, do the following:

1. Click SELECT on the Status button to display the jobs in the print queue.
2. Move the pointer onto the job you want to cancel, and click SELECT. To stop more than one job, point to the additional jobs and click SELECT. The Stop printing button is enabled once a job is selected.
3. Click SELECT on the Stop Printing button, shown in Figure 10-5.

![Figure 10-5  Stopping a Print Job](image)

**Note** – When you stop printing one or more print jobs, the Print Tool remains busy and does not accept further input until the printer acknowledges the request. Depending on the number of jobs selected and the status of the printer queue, it may take several minutes for the printer to respond to your request.
Changing Print Tool Properties

The Print Tool properties window allows you to change certain of functions of Print Tool.

♦ Click SELECT on the Properties button from the Print Tool window.

The Print Tool Properties window is shown in Figure 10-6.

The following properties can be set from the Print Tool Properties window:

• Use the Header Page setting to indicate whether or not your jobs should print with a header (or banner) page. The Header Page setting on the Print Tool window overrides the setting made here.

You can turn the header page on or off for an individual job from the Print Tool window, without going back and forth to the Print Tool: Properties window. A check in the checkbox box indicates that the default is to print a header page with each job.

• Use the Notify when ALL jobs done setting to beep and/or flash you when all of the print jobs you sent to the queue have printed.

• Use the Override Default Print Method to use your own print method next time you start Print Tool. For more information on using your own print method, refer to “Changing the Print Method in the Print Tool” on page 339.
Changing the Print Method in the Print Tool

Note – Depending upon your installation, certain printer filter programs should have been installed for the printers you use by the system administrator. If no print filters are installed, your print job will not be printed. Check with your system administrator for the filter programs installed for your printer, or for a complete listing of print filters available and information about the lpfilter command, refer to System Administration Guide, Volume II.

The Override default print method option allows you to use alternate (command line) print methods within Print Tool. If you need to print a file with another print method (such as troff), you need to override the default print method. You must also use the following environment variables (listed here with their meaning):

$FILE=Name of your file
$PRINTER/$LPDEST=Printer name
$COPIES=Number of copies to be printed
$HEADER=Print header page with job

You can type any command line print method, including UNIX pipes and shell scripts. The print method must be an executable command in your path. For example, if you want to pretty-print a C source file using the vgrind command, you would follow these steps:

1. Click SELECT on the Properties button.
2. Click the Override Default Print Method checkbox, and press Apply.
3. In the Print Method text field, type:
   
   vgrind $FILE | dpost | lp -d$PRINTER -n$COPIES -Tpostscript

4. Type the name of the file in the File text field, or drag and drop the file to be printed onto the Print Tool icon or drag and drop target.

Note – The SunOS 5.X print system does not recognize the type of the file to be printed. You must supply the appropriate filter for the file type when using an alternate print method. Otherwise, the file will be printed as a plain ASCII file.

Print Tool
Changing the Print Method with the Binder

You can use the Binder application to view or change the print method bound to specific types of files. This information is stored in the non-ASCII file called cetables in the /usr/openwin/lib/cetables directory and can be viewed using Binder. Once you use Binder to customize this file, the information is stored as .cetables directory in your home directory. For complete information on using Binder, refer to Chapter 16, “Binder.”

Starting Print Tool from the Command Line

When started from the command line, Print Tool looks at the following to determine the default printer:

1. If the Print Tool was started in a Shell Tool or Command Tool, and the printer was specified with the -P command line argument, Print Tool uses that printer as the default. For example, the printer named mimeo is the default if Print Tool is started by typing printtool -P mimeo.

2. If a printer was not specified with a command line argument, Print Tool looks for the environment variable $PRINTER (or $LPDEST, if the $PRINTER environment variable has not been set). If this environment variable is set, the printer it specifies becomes the Print Tool default.

3. If neither a command line argument was specified, nor the $PRINTER (or $LPDEST) environment variable was set, Print Tool automatically selects the name of your system default printer.

All printers that are available to you are listed on the Printer scroll list. Printers are in separate directories under /etc/lp/printers. If you need to add or delete printers to your system configuration, you must use the admin tool. See System Administration Guide, Volume I and System Administration Guide, Volume II for more information.
Audio Tool

Audio Tool is an application that is used to record, play, and edit audio files. Audio Tool works in conjunction with the Audio Control application, which controls and configures the desktop’s audio capabilities. Audio Tool also works with Multimedia Mail Tool to provide the audio capabilities for composing, sending, and receiving Multimedia Mail.

About This Chapter

The first part of this chapter explains how to perform common Audio Tool tasks, such as playing, recording, editing, and saving audio files. The rest of the chapter, which is in a reference format, contains detailed descriptions of Audio Tool’s base window and the File, Edit, and Volume menus. Refer to these reference sections for more information about a particular button or menu option.

Audio Tool Capabilities

Before using Audio Tool, make sure that your machine supports, at a minimum, basic (monaural) audio capabilities and that a speaker and microphone are installed. Refer to your system’s documentation for this information.

Many computers support stereo and higher-quality audio, such as CD and DAT quality. Audio Tool automatically recognizes the capabilities of the computer’s audio devices. Therefore, the features of Audio Tool that you can
use depend on your particular system configuration. This chapter describes all of the features and controls of Audio Tool. However, if your computer supports only monaural audio, you will not see some controls, such as a balance slider.

**Required Accessories**

For recording (creating) voice audio files, use the microphone that is shipped with your computer or a commercial-variety microphone. Connect the microphone to your computer’s microphone jack.

You can listen to audio output in one of these ways; either from your computer’s speaker, or headphones, or from externally powered speakers connected to the speaker output.

**Invoking Audio Tool**

You can invoke Audio Tool in several ways:

- from the desktop menu by choosing Workspace ➤ Programs ➤ Audio Tool...
- from the Mail Tool by choosing Attach ➤ Voice... from the Compose window
- from an audio file attachment to a mail message by double-clicking SELECT on the audio file glyph
- from the File Manager by double-clicking SELECT on an audio file glyph
- from the command line with the `audiotool` command

Refer to the `audiotool(1)` manual page for information about the Audio Tool command’s syntax.
About Audio Tool’s Base Window

The Audio Tool base window, shown in Figure 11-1, contains all of the controls needed to play, record, and edit a sound file.

Figure 11-1  Audio Tool Base Window

The top center of the Audio Tool window displays the name of a sound file along with the file’s status.

Three menu buttons are located near the top of the window (File, Edit, and Volume). Use these buttons to edit audio files and the audio configuration parameters, such as play and record volume. The four buttons located near the bottom of the window (Rev, Play, Fwd, and Rec) function like buttons on a tape recorder.
Loading and Playing an Audio File

To load and play an audio file, do the following:

1. **With the pointer inside Audio Tool, choose File ➤ Open....**
   The Audio Tool: Open window is displayed, as shown in Figure 11-2.

![Figure 11-2 Open Window](image)

2. **Double-click SELECT on the directory that contains the audio file you want to hear.**
3. **Click SELECT on the name of the audio file.**
4. **Click SELECT on the Open button.**
   The audio file appears in Audio Tool’s base window.
5. Press MENU on the Volume button and choose Play...
The Audio Control: Play window appears (Figure 11-3).

![Audio Control: Play Window](image)

**Note** – Depending on the audio capabilities of your computer, you may or may not see all of the choices shown in the figure (e.g., if your computer does not support stereo, the balance slider is not displayed)

6. Click SELECT on the Play button in Audio Tool’s base window.

7. To adjust the volume, press SELECT on the Play Volume: slider in the Audio Control: Play window and move the slider left (to lower the volume) or right (to raise the volume).

Note that you can choose just a small segment of the sound file to be played. To do this, click SELECT on the location in the recording where you want to start, and click ADJUST at the end of the segment that you want to hear.

**Recording Sound**

To record an audio file, do the following:

1. If you’re recording from a microphone, place the microphone near the sound source.

2. Press MENU on the Volume button and choose Record...
   The Audio Control: Record window appears (Figure 11-4).
3. In the Audio Control: Record window, select a source; either click SELECT on the Microphone button or on the Line In button.

4. Click SELECT on the Auto-Adjust button, and speak into the microphone for three to five seconds. Or, play a selection from the sound source that’s connected to your audio hardware’s “line in.” Auto adjust automatically sets the recording level. You can also move the Record Volume: slider to adjust the recording level manually.

5. Click SELECT on the Rec button in Audio Tool’s base window. The Rec button changes to Stop, as shown in Figure 11-5.

6. Begin speaking into the microphone or playing the music (or other sound source).

Figure 11-4  Audio Control: Record Window

Figure 11-5  Record Button Changed to Stop
7. **When you have finished recording, click SELECT on the Stop button.**
   If you make a mistake, you can either choose File ➤ New (which cannot be undone) to clear all the sound data and start over, or you can edit the sound later. Refer to “Editing an Audio File” on page 348 for information on how to do this.

**Saving an Audio File**

To save your file, do the following:

1. **Choose File ➤ Save As...**
   The Audio Tool: Save As window appears, as shown in Figure 11-6.

   ![Figure 11-6 Saving a File in the Save As Window](Image)

   **Use the scrollbar to choose a directory**

2. **Double-click SELECT on the directory destination for the file from the scrolling directory list.**

3. **Type the file name in the Save As text field.**
4. Click MENU on the Format: menu button to choose an appropriate format.
   The current format is displayed next to the menu button.

5. Click MENU on the Compress: menu button to make a compression choice.
   The current compression setting is displayed next to the menu button.

6. Click SELECT on the Save button.
   The file you named is saved in the selected directory.

   You can cancel a file-save operation by clicking SELECT on the Cancel button in the Save As window. Or, you can press the keyboard’s Stop key while the mouse cursor is in Audio Tool’s base window.

   To update the file that is being edited, follow the previous steps to modify the file, then choose File ➤ Save from Audio Tool’s base window.

**Editing an Audio File**

Because you can see an audio file graphically, you can determine which portions are sound and which are silence. This feature allows you to edit audio files such as voice messages. For instance, you might want to edit out long pauses (silence) between sentences or phrases. To modify the sound file, you edit the audio file as you would edit a text file in Text Editor, using cut, copy, and paste commands from the Edit menu.

To cut a portion of sound from one location and paste it in another, do the following:

1. **Click SELECT at the beginning of the sound portion you want to cut.**

2. **Click ADJUST at the end of the portion you want to cut.**
   
   Or, instead of steps 1 and 2, position the hairline cursor at the beginning of the sound portion, hold down the SELECT mouse button, and drag the pointer to the end of the portion.

   That portion is highlighted, as shown in Figure 11-7.
3. Choose Edit ➤ Cut.  
   That portion is removed to the clipboard.

4. Click SELECT on the destination point for the portion of sound you cut.

5. Choose Edit ➤ Paste.  
   The cut portion of sound is pasted into the new location, as shown in Figure 11-8.

*Undoing an Edit*

♦ You can undo the last edit you made by choosing Edit ➤ Undo.
Tips for Editing Audio Files

- In the display canvas, the granularity of selections is based on pixel width, which depends on the length of the file that is loaded. You can stretch Audio Tool’s base window to see more detail when you are selecting segments.

- You may find it useful to use multiple Audio Tools. For example, you can edit a small region of a large file by selecting a segment that is somewhat larger than the region and copying the segment to another Audio Tool display canvas. Then, you can easily edit the segment in the other Audio Tool by stretching the tool to provide better pixel resolution. When you’re finished editing, you can copy the edited region back into the original Audio Tool.

- You can also use multiple Audio Tools to assemble an audio track from multiple sources.

Sending a Voice Mail Message

You can create an audio file from Mail Tool by selecting Attach ➤ Voice... in the Mail Tool Compose window. The audio file you create is automatically bound to Audio Tool and to an audio file glyph. The glyph is automatically attached to an electronic mail message when you notify the application that you have finished recording. The mail recipient can hear the contents of the audio file by double-clicking SELECT on the audio attachment glyph from Mail Tool. Refer to Chapter 4, “Multimedia Mail Tool” for information on using Mail Tool.

To record an audio file and attach it to a mail message, do the following:

1. Click SELECT on the Compose button in the Mail Tool control area, and address the mail.

2. Click SELECT on the Attach... ➤ Voice... button in the Mail Tool Compose window control area.

   The Audio Tool window appears, as shown in Figure 11-9. Note that the mail button labeled “Done” appears only when Audio Tool is invoked from the Mail Tool Attach button.
3. Record your voice message as described in the section, “Recording Sound” on page 345.

4. Make any editing changes, as described in the section, “Editing an Audio File” on page 348.

5. Click SELECT on the Done button.

   The audio attachment glyph appears in the Attachments window (Figure 11-10).

   Note also that if you have a pre-recorded message in Audio Tool that you want to attach to a mail message, you can drag the file’s glyph from Audio Tool’s drag and drop target to the Compose window’s Attachments subwindow.
6. If needed, type in an additional message in the Compose text region.
7. Click SELECT on the Deliver button in the Mail Tool Compose window.

Listening to a Voice Mail Message

If you have a machine equipped with a built-in speaker or an attached speaker, you can listen to the audio file by doing the following:

1. Open Mail Tool.
2. Double-click SELECT on the message header containing the attached audio file in the Mail Tool base window.
   The mail message containing the file is displayed in the View Message window.
3. Double-click SELECT on the audio attachment glyph in the view window Attachments area.
   The audio file opens and begins playing.
Audio Tool Reference

This part of the chapter provides information about Audio Tool’s File, Edit, and Volume menus.

Base Window

The Audio Tool base window, shown in Figure 11-11, contains all of the controls needed to play, record, and edit a sound file.
Audio Tool Icon

When you iconize the Audio Tool base window, you’ll see the icon shown in Figure 11-12. Double click SELECT on the icon to restore the window.

![Audio Tool Icon](image)

Figure 11-12 Audio Tool Icon

Display Canvas

The display canvas provides a region for the graphic representation of audio data. Sound data is represented graphically as a box. Silence is represented as a thin horizontal line.

Sound and silence data can be selected using the SELECT and ADJUST mouse buttons. An entire sound or silence segment is selected by double-clicking SELECT in the segment. Using ADJUST extends the selection to segment boundaries or to the hairline cursor position. Triple-click SELECT to select the entire audio file. (Audio selection in Audio Tool follows the same general conventions that are used for text selection throughout the Open Windows environment.)

In Figure 11-11, the selected audio data includes both sound and silence. Once a segment has been selected, clicking SELECT on Play activates only that selection.

Selected data can be dragged and dropped into other applications, such as Mail Tool and File Manager, or other invocations of Audio Tool. Using multiple Audio Tool windows enables you to assemble audio data from multiple files or break large files into smaller sections. Audio attachments to a mail file are discussed earlier in this chapter, as well as in the Mail Tool chapter.

Cursor and Pointer Location

Cursor and Pointer locations are displayed in the upper right corner of the Audio Tool window with time offset of \((MM:SS.d)\), where \(MM\) is minutes, \(SS\) is seconds, and \(d\) is tenths of seconds. Whenever the mouse position marker is
moved into the display canvas (and when a file is loaded) the marker is shown as a thin vertical line (hairline cursor), and its location is displayed as a time offset. In Figure 11-11, the cursor is located near the beginning of the audio file, location 0:01.4.

The Play/Record pointer information shows the location of the play/record position pointer in the display canvas. The position pointer marks the data that is currently being played, recorded, or where playing or recording will begin when the Play or Rec button is pressed. It also marks where include, drag and drop, and paste operations will occur. Clicking SELECT while the cursor is in the canvas moves the pointer to the hairline cursor location.

**Drag and Drop Target**

The drag and drop target is where you can drop sound data into or drag sound data out of Audio Tool. For example, you can drag and drop sound data to and from the File Manager. Sound data dropped on the drag and drop target replaces any data in the display canvas.

Press SELECT on the drag and drop target and drag out of the target to copy the current audio file to another application.

When sound data is dropped directly into the display canvas, the data is inserted at the play position pointer location. If data is selected (highlighted) in the display canvas, the insertion occurs at that specific location, replacing the selected data.

**Level Meter**

The level meter, which looks like an LED indicator, is active during play and record. On color monitors, the indicators are green and red. During recording, there should generally be 5-to-7 green LEDs displayed. If the red LEDs are lit all of the time, the recording level is too high.

**Status Information**

The lower left corner of the Audio Tool window is the status message display area. If any status information or error messages occur while using Audio Tool, the information is displayed here. For example, the current audio format is displayed there.
The lower right corner of the Audio Tool window displays the length of a recorded file (e.g., Length: 0:08.5). Whenever a sound segment is selected in the display canvas, brackets appear indicating the length of the selection (e.g., Length: 0:08.5 [0:00.9]). These brackets also appear when recording is initiated, and display the length of the newly recorded data (which is updated periodically).

**Rev (Reverse) Button**

This button controls the backward movement of the play position pointer. Click SELECT on the Rev button to move the play position pointer backward.

If there is no selection in the canvas, clicking SELECT on the Rev button causes the pointer to jump backward, segment by segment, until it reaches the beginning of the file. (A segment is the start of a sound “box” in the display canvas.)

If there is a selection, the pointer’s movement is constrained to the selection.

Hold down SELECT on the Rev button to play the selection in reverse at an accelerated speed until you release SELECT or until the play position pointer reaches the beginning of the selection.

**Play Button**

This button controls the playing of an audio file. If you’ve selected part of an audio file, only that part of the file is played. Otherwise, the entire file is played.

Click SELECT on the Play button to start playing from the current play position pointer location to the end of the selection or file. If the play position pointer is at the end of a selection or file, clicking SELECT on the Play button moves the pointer to the beginning of the selection or file before playing starts. Once selected, this button changes from Play to Stop, so to stop playing, click SELECT on the Stop button.

If Auto Play on Selection in Audio Tool: Properties options is set “on,” playing starts automatically whenever you make a selection.
**Fwd (Fast Forward) Button**

This button controls the forward movement of the play position pointer. Click SELECT on the Fwd button to move the play position pointer forward.

If there is no selection in the canvas, clicking SELECT on the Fwd button causes the pointer to jump forward, segment by segment, until it reaches the end of the file.

If there is a selection, the pointer’s movement is constrained to the selection.

Hold down SELECT on the Fwd button to play the selection at an accelerated speed until you release SELECT or until the play position pointer reaches the end of the selection.

**Rec (Record)/Stop Button**

This button controls the starting and stopping of recording. Click SELECT on the Rec button to start recording at the current play position pointer location.

Recorded audio data is inserted into the sound file at the play position pointer. The existing data is moved forward in the file—it is not overwritten. However, if a sound segment is selected when record is activated, the selected segment is cut from the audio file and placed on the clipboard.

Once selected, this button changes from Record to Stop, so to stop recording, click SELECT on the Stop button.

You can click SELECT on New from the File menu to delete the current sound and record from scratch.

*Note* – Clicking SELECT on the Play button during a recording session causes the recording to stop and the segment that was just recorded to be automatically selected and played back.
File Menu

Items on the File menu handle opening, including, and saving files. Click MENU on the File button to display the File menu.

Whenever a command cannot be performed, the corresponding menu item is dimmed. For example, Save is dimmed when there is no new data to be saved.

New

Use the New menu to clear the current audio file or select a new audio data format. Press MENU on New and drag to the right to display a pop-up menu with format choices. (If you click SELECT on New, the display canvas is cleared and retains the current format.) The selected audio format stays in effect until the next New operation (or other operation that loads a new audio file, such as Open). When recording a new file, you have the option of saving in the current format or in a new format.

If there is an unsaved sound file in the display canvas, a confirmation message appears, saying that the file is modified and asking if you want to discard the edited data. Click SELECT on the Continue button to clear the display canvas and begin recording. The confirmation message can be disabled in the Edit ➤ Properties... window.

You cannot undo a New operation.

Audio Format Choices

Click SELECT on the format of your choice. You can retain the current format or choose one of the standard formats—Voice, CD, or DAT. (If an audio format is not supported by the audio hardware, the corresponding menu item is disabled.) User defined formats may also be included and you can choose New Format... to define a new format.
Audio Tool

New Format...

Click SELECT on the New Format... choice in the New menu to select, create, or edit the characteristics of a recording format. The Audio Tool: New Format window, shown in Figure 11-13, is displayed.

![Audio Tool: New Format Window](image)

**Encoding:**

Open this menu with a MENU click to select a type of encoding. Then, click SELECT on your choice of 8-bit µ-law, 8-bit A-law, or 16-bit linear. The 16-bit linear encoding provides better accuracy (signal-to-noise ratio) than the two 8-bit encodings. However, the 16-bit linear encoding requires twice the storage capacity. Stereo audio data must use 16-bit linear encoding to play on a machine with stereo capability.

**Sample Rate:**

Open this menu with a MENU click to select a sample rate. Higher sample rates provide better high-frequency response (at the cost of larger file sizes). Click SELECT on your choice.

**Channels:**

Open this menu with a MENU click and click SELECT on your choice of channels (mono or stereo).

**New Format Button**

Click SELECT on the New Format button to clear the current audio file and reset the data format to match the currently selected audio format.
Reset Button
Click SELECT on the Reset button to restore the panel so that it displays the current audio format.

+ Button
Click SELECT on the + button in the New Format window to display an extended window, shown in Figure 11-14. The Format scrolling list displays the formats available to you. Note that formats are stored on a per-user basis, so that the formats listed (other than the standard Voice, CD, and DAT) have been created under your user name.

Note – Audio formats and preferences are stored in the $HOME/.audiorc file (where $HOME is the name of your home directory).

You can use the New Format window to name a format type to appear in the New and Save As... menus. You can also use this window to add, change, or delete an audio format.

Click SELECT the – button to close the extended part of the New Format window.

![Figure 11-14 New Format Window Extensions](image)

To create a new format:

1. Select the new format’s encoding, sample rate, and number of channels from the lefthand part of the window.

2. Type the new format’s name in the Name: field.
3. **Click SELECT on the Add button.**
   The new format is added to the bottom of the list. To add the new format elsewhere, click MENU on Add and choose Before, After, Top, or Bottom. The new format will appear in the list of formats.

**Open...**

Open... enables you to open a directory or file. Click SELECT on the Open... menu item to display the Audio Tool: Open window, shown in Figure 11-15. This window contains a “browser” that can be used to locate particular directories within a file system.

![Audio Tool: Open Window](image)

*Figure 11-15 Audio Tool: Open Window*

**Go To:**

To change directories, type the pathname of the new directory in the Go To: field, then click SELECT on the Go To: button or press Return. Notice that if you click MENU on the Go To: button, a directory stack is displayed that includes the recently visited directories, as well as the directories specified in the AUDIOPATH environment variable.
Path Scrolling List

The scrolling list displays the names of directories and files. Double-click SELECT on the first item in the scrolling list to move to the parent directory. Double-click SELECT on any of the directories in the scrolling list (indicated by folder icons) to change the current directory.

All Files Button and Audio Files Button

If you click SELECT on the All Files button, the path scrolling list displays the names of all directories and files. However, non-audio files are dimmed and cannot be loaded.

If you click SELECT on the Audio Files button, the scrolling list displays the names of audio files only; other file types are omitted from the display.

Open Button

Click SELECT on this button to open the specified audio file and load it into Audio Tool’s display canvas. If the selected item is a directory, click SELECT to open the directory.

You can also open a sound file by following these steps.

1. Scroll to the directory that contains the specific file.
2. Double-click SELECT on the directory.
3. Double-click SELECT on the audio file icon glyph.
   The specified file is loaded into the display canvas.

Note – If the audio hardware of your computer does not support the audio format of a file that you’re trying to open, Audio Tool displays the conversion pop-up shown in Figure 11-16.
The audio file format is incompatible with the audio device. You may:
- Convert to a playable format and load as a new file,
- Load the file as is (play and record will be disabled), or
- Cancel this operation.

Figure 11-16 File Conversion Pop-Up

Click SELECT on the Convert button to convert the file into a format that is supported by your computer’s hardware. Click SELECT on the Load button to load the file into Audio Tool’s canvas. If you load the file, you will not be able to play it. However, you can perform editing operations on the file (such as cutting and pasting segments) and save the result into a new format.

**Cancel Button**

Click SELECT this button to close the Open window.

If you open a compressed audio file, the conversion can take a long time. The Cancel button remains active and can be used to cancel the in-progress load conversion.

**Save**

Save enables you to save changes made to the current audio file. Click SELECT on the Save menu item to save the file.

If a file has been named and previously saved, clicking SELECT on Save replaces the old copy with the current version.

If the audio data has not been saved previously, or has not yet been edited, the Audio Tool: Save As window is displayed. The Save item is dimmed if no audio file is loaded (following a New operation, for example) or if the audio file has not been edited since a previous Save.
Save As...

Save As... enables you to save a copy of the current sound file to a new file. Click SELECT on the Save As... menu item to display the Audio Tool: Save As window (Figure 11-17). To save a file, enter its name into the Save As field and click SELECT on the Save button.

![Figure 11-17 Audio Tool: Save As Window](image)

The Go To: button and field, Current Folder: field, scrolling list, All Files and Audio Files buttons, and the Cancel button work the same as their counterparts in the Open window. The Save As window has additional items that the Open window does not have. Use the Format: and Compress: menus to save an audio file in different formats.
Format:

Click MENU on the Format button to display the list of formats. The standard formats are Current, Voice, DAT, or CD. Click SELECT on Current Format to match the format that is being used in the display canvas.

In the list of formats, click SELECT on New Format... to display the Audio Tool: Save Format window (Figure 11-18). Use the selections in this window to save the audio data in a different format. The buttons in the window work the same as the buttons in the Audio Tool: New Format window (described on page 359).

![Audio Tool: Save Format Window](image)

Figure 11-18 Audio Tool: Save Format Window

Compress:

Click MENU on the Compress button to display a list of compression techniques. The choices are:

- None—no compression. This choice provides the best audio quality, loads and saves files the fastest, but consumes the most disk space.
- 4-bit G.721 ADPCM—2:1 compression. This is a good choice for voice files and adequate for music. It uses 50% less disk space than no compression.
- 3-bit G.723 ADPCM—8:3 compression. This is an adequate choice for voice files, but may be unacceptable for some music. It uses 62.5% less space than no compression.

If the size of a file is a concern, choose compression. If loading time is a concern, choose no compression. A compressed file uses less disk space but requires additional loading time because it must be decompressed before it is used. Also, if you choose to compress a file, the audio encoding specified by
New Format... is ignored. When you load a compressed file, the format may change from its previous choice (e.g., if you compress an A-law file and reload, the file format changes to µ-law).

**File Size:**

The File Size field displays the storage requirements of the file (when Audio Tool writes it to disk) and the amount of free disk space that you have available in the file system that contains the selected folder.

**Open Folder**

Click SELECT on the Open Folder button to open a folder that you have selected in the file scrolling list.

**Cancel Button**

Click SELECT on the Cancel button to close the Save As window.

If you save a compressed audio file, the conversion can take a long time. The Cancel button remains active and can be used to cancel the in-progress save conversion.

**Save Button**

Click SELECT on this button to save the specified audio file. If the file selection is not made, this button is dimmed.

**Include...**

Include... enables you to insert audio data from another file into the current file. Click SELECT on the Include... menu item to display the Audio Tool: Include window. This window is similar to the Open window shown in Figure 11-15 on page 361, with the Include button replacing the Open button, and the addition of the Open Folder button. Choose the file you want to include, then click SELECT on the Include button to insert the selected file into the display canvas at the play position pointer. Note that if the file selection is not made, the Include button is dimmed.
**Note** – You can include only files whose formats match the current audio format. All other files are dimmed (if All Files is selected) or are removed from the scrolling list (if Audio Files is selected).

---

**Edit Menu**

The commands on the Edit menu are common to most DeskSet tools. Click MENU on the Edit button to display the Edit menu.

Whenever a command cannot be performed, the corresponding menu item is dimmed. For example, Undo is dimmed when there are no editing operations to undo.

**Clear**

The Clear command removes the current sound data from the display canvas. Click SELECT on Clear when you want to delete all the data in the canvas.

**Note** – The clear operation does not change the name of the file that’s being edited. Take care not to accidentally save an empty canvas to an audio file.

The clear operation can be undone, and the audio data is retained so that it can be used by a Redo operation. However, since newly recorded data consumes space in the temp file directory, you might consider using the File ➤ New operation. This operation, which cannot be undone, recovers the unused space in the filesystem.

**Undo**

The Undo command reverses the effects of the last editing command issued. Click MENU on Undo to display the Undo submenu, which has the following options:

- Last Edit—Restores the previous data prior to the last change. This is the default action for Undo.
- All Edits—Restores all edited changes to their state as of the last time the audio file was saved, loaded, or cleared.
Redo

The Redo command restores the effects of the Undo command. Click MENU on Redo to display the Redo submenu, which has the following options:

- Last Undo—Restores the previously revised data. This is the default action for Redo.
- All Undos—Restores all edited changes.

Making edits to the audio buffer clears any subsequent editing history in the redo list.

Cut

The Cut command removes the current selection from your sound file and places it on the clipboard. Click SELECT on Cut to cut the selection.

Copy

The Copy command copies the current selection to the clipboard, without modifying the original sound file. Click SELECT on Copy to copy the selection.

Paste

The Paste command pastes data currently stored on the clipboard into the current audio file at the location specified by the play position pointer. For example, after doing a Cut or Copy, the next step is often to paste the stored data to some new location. Click SELECT on Paste to paste the selection.

Delete

The Delete command removes the current selection from the sound file, without modifying the contents of the clipboard. Use Delete instead of Cut when something is on the clipboard that should not be overwritten or when you are sure you do not want to use the selection again.
Click MENU on Delete to display the Delete submenu with the following options:

- **Selection**—This is the default, which deletes the current audio selection.
- **Unselected**—This option deletes everything that is *not* selected. This enables you to select the part of an audio segment that you want, then delete the parts that you don’t want.
- **All Silence**—This option deletes all silent segments, which are indicated by horizontal lines. This is useful, for example, when you are sending or storing voice mail.
- **Silent Ends**—This option deletes only the silent segments at the beginning and end of the file. This enables you to remove a pause that occurs between the time you press the Rec button and start talking, or the pause between the time that you stop talking and press the Stop button.

**Properties**

Properties... enables you to modify the functionality of Audio Tool. Click SELECT on this menu item to display the Audio Tool: Properties window, shown in Figure 11-19.

![Figure 11-19 Audio Tool: Properties Window](image)

*Figure 11-19 Audio Tool: Properties Window*
The controls on the Audio Tool: Properties window are described in the following paragraphs.

- **Auto Play on Load:** Causes Audio Tool to begin playing files as soon as they are loaded or dragged and dropped onto the drop target.

- **Auto Play on Selection:** Causes selections to be played immediately after a selection is made. This option can be useful when you are working on a specific editing task because the entire selection replays each time that you make or change a selection.

- **Confirm on New/Load:** Causes a confirmation message to be displayed if a file contains unsaved data when a New or Load operation is performed.

- **Silence Detection:** Turns silence detection ON or OFF. If this option is turned off, no silence detection occurs and the entire audio file is displayed as a single sound segment. Turning off this option speeds up the time it takes to load an audio file.

  **Note** – Silence detection is automatically suppressed for audio file formats that have a sample rate greater than 16kHz, regardless of the silence detection setting in the Edit ➤ Properties... window.

- **Silence Threshold:** Changes the parameters for silence detection. Moving the slider to the left increases the sensitivity to short pauses. This should increase the number of sound and silence segments. Moving the slider to the right decreases the sensitivity to short pauses. This should decrease the number of segments.

- **Temp file directory:** This displays the name of the directory where temporary sound files are placed. All newly recorded data is stored in this directory until the data is saved.

  **Note** – Recorded audio can quickly use up disk space. Set the temp file directory to a file system that contains adequate disk space. Also, if you are using high sampling rates (e.g., CD or DAT format), you may have difficulty recording to a remotely mounted temp file system.
In addition, there are two buttons at the bottom of the Properties window, Apply and Reset. Use these buttons as follows:

- Click SELECT on Apply to apply all changes made in the Properties window.
- Click SELECT on Reset to restore all parameters to their original value, as set by the last Apply operation.

**Edit Pop-Up Menu**

A pop-up menu with commonly-used audio editing commands is available when you click MENU in the display canvas (Figure 11-20). Note that many of these choices also appear in the Edit menu under Clear and Delete.

![Figure 11-20 Edit Pop-Up Menu](image)

**Reset Pointer**

This command clears the current selection and places the pointer at the beginning of the file.

**Clear**

This command removes the current sound data from the display canvas.

**Delete Unselected**

This command deletes everything in the display canvas that is *not* selected.
Delete All Silence

This command deletes all silent segments (which are indicated by horizontal lines).

Delete Silent Ends

This command deletes only the silent segments at the beginning and end of the file.

Select All

This command selects all of the audio data in the display canvas. This is the same as triple-clicking SELECT in the display canvas.

Volume Menu

The Volume menu has options for controlling play volume and recording level. These functions are part of Audio Control—a separate application that cooperates with Audio Tool. Click MENU on Volume to display these options.

Play...

Play... controls audio output. Click SELECT on Play... to display the Audio Control: Play window, shown in Figure 11-21. The controls on this panel affect the entire desktop audio environment.

\[
\begin{array}{c|c|c|c}
\hline
\text{Speaker} & \text{Headphone} & \text{Line Out} & \text{Record} \\
\hline
\text{Play Volume:} & & & \\
\text{Balance:} & \text{Left} & \text{Right} & \\
\hline
\end{array}
\]

*Figure 11-21 Audio Control: Play Window*

**Note** – Depending on the audio capabilities of your computer, you may or may not see all of the choices shown in the figure (e.g., if your computer does not support stereo, the balance slider is not displayed)
Speaker, Headphone, and Line Out Buttons

Click SELECT on these buttons to select audio output devices.

The buttons that are available depend on your hardware configuration. For example, some configurations support only speakers and headphones. Other configurations support all three devices, and some configurations allow you to select more than one device at a time. Also, some configurations recognize whether a plug has been inserted into a jack. In these configurations, the corresponding button is dimmed when no plug is inserted into a jack.

Play Volume

This slider controls the audio output volume. You can also type in a volume level (0-100).

Balance

If your computer has stereo capability, use the Balance slider to adjust the balance. The slider has a “detent” at the 50-50 balance point.

Record...

This button displays the Audio Control: Record window, which is described in “Record...” on page 373.

Mute

This button mutes the audio output to the selected devices. The audio file or selected audio segment continues to play. Click SELECT on the button to turn off muting so that you can hear the audio. Audio Tool turns muting off when you adjust the play volume.

Record...

Record... controls the adjustment of volume gain during recording. Click SELECT on Record... to display the Audio Control: Record window, shown in Figure 11-22.
Note – If recording difficulty is experienced with a commercial microphone, use an external pre-amp to boost the recording gain level.

![Audio Control: Record Window](Figure 11-22 Audio Control: Record Window)

**Microphone and Line In Buttons**

Click SELECT on one of these buttons to select an audio input device (if they are supported by your hardware configuration).

**Record Volume:**

This slider controls the recording volume gain. You can also type in a volume level (0-100).

**Balance:**

If your computer has stereo capability, you can use the Balance slider to adjust the balance. The slider has a “detent” at the 50-50 balance point. Typically, you’ll only want to change the record balance if your audio inputs are not at the same level.

Before adjusting the record balance, make sure that the play balance is calibrated for your output configuration. You can do this by using the Audio Tool: Save As window to convert a monaural file to stereo and then adjusting the play balance until the left and right speakers produce the same output level.
Once the play balance is calibrated, you can record a segment of audio data and play it back to determine if the record balance is correct.

**Note** – On systems that support the monitor function, the record balance may not affect the monitor output. To determine the actual effect of record-balance changes, you must record and play back a sample of stereo audio.

**Monitor Volume:**

This slider controls the volume of the audio input signal that is channeled through the output port. (You can also type in a monitor-volume level (0-100).) This is useful when an audio source, such as a CD player or tape deck, is connected to the selected input jack. By adjusting the monitor volume, the audio input is heard without having to record any data.

**Auto-Adjust Button**

This button enables you to automatically set the optimum recording level. This is recommended before a recording session begins or whenever the microphone is moved or the input source is changed.

Click SELECT on Auto-Adjust to initiate scanning of the input sound data to determine its loudness. The current level of the input signal is examined and, if necessary, minor adjustments are made to set a Record level. If no signal is found, the Record level jumps to the maximum, then automatically adjusts down until the optimal level is achieved. An LED-like input level meter displays the sound level. During the auto-adjust operation, no data is recorded. The auto-adjust procedure continues until a satisfactory level has been maintained for three to five seconds.

To adjust the level of your voice, talk into the microphone in a normal speaking voice. Speak continuously during the entire time (for instance, counting) until the auto-adjust operation ends. If the input signal does not register on the level meter, check the ON/OFF switch on the microphone or replace the microphone battery.

You should also use the auto-adjust operation to set the optimal recording level for input sources connected directly to the microphone jack, such as a CD player or tape deck. For best results, play the loudest section of your audio...
source during the auto-adjust operation. You can use the Monitor Volume to listen to the source while you are setting the volume level (as well as while you are recording).

**Note** – If you cannot achieve a satisfactory signal level with a commercial microphone, it may be necessary to speak closer to the microphone, or to obtain a microphone preamplifier.

### Using the Audio Control Status Panel

The Audio Control application includes a status window that displays the current state of the audio device. The status window provides information that can be useful for debugging audio applications and for determining whether applications are holding an audio device open.

To display the status window (Figure 11-23), click MENU in the background of the Audio Control: Play or Audio Control: Record windows, then click SELECT on the Status... button. The check boxes display the status of the tool. (The check boxes are informational; you cannot modify them.)

Click SELECT on the Status Change button to cause the displays to be updated only when one of the status items changes. Click SELECT on the Continuous button to cause the displays to be updated continuously. Refer to the audio(7) manual page for a description of status indicators.

![Audio Control: Status Window](image)

*Figure 11-23 Audio Control: Status Window*
Tape Tool

Tape Tool enables you to copy files and directories onto a tape cartridge. You may need to do this to make backup copies or to archive files that you want to retain but that you do not need on a regular basis. Or, you may need to copy files or directories onto tape in order to pass them on to someone else with a compatible system who can then extract them from the tape.

Tape Tool provides a user interface to the UNIX tar tape archiving and retrieval functions. Refer to the manual page for tar for more detailed information.

Note – Tape Tool is not intended to be an all-purpose system backup tool. It cannot read tapes that have been written using the cpio command.

To open Tape Tool, choose Workspace ➤ Programs ➤ Tape Tool.

Tape Tool Icon

The Tape Tool icon has an image of a tape cartridge, as shown in Figure 12-1.
You can select files and folders from the File Manager to be archived on tape. You can drag and drop them as a group or individually onto the Tape Tool icon or onto the open Tape Tool window to accumulate a list of files to be written to a tape or archive file.

**Tape Tool Window**

The Tape Tool base window is shown in Figure 12-2.

You can perform the following operations from the Tape Tool window:

- List the files from a streaming tape cartridge or archive file that have been archived using the `tar` command.
- Read some or all of the files from the tape or archive file into the directory that you specify.
- Write specific files or directories that you specify onto a streaming tape cartridge or into an archive file.
- Display a window in which you set the properties for the `tar` command from the Tape Tool Properties window.
The control area provides controls for listing, reading to tape, writing from tape, and setting Tape Tool properties.

Use the File To Write button and text field to type in the names of files that you want to write to tape. The scrolling list displays a list of the files you specify by typing file names or by dragging and dropping icons from the File Manager.

If files were archived without a path name or with a relative path name, you can specify in the Destination field where those files are put in your file system when they are read from the tape. The default destination is your current working directory.

If the files on a tape have a complete path name (absolute path name), the files are always put in the directory specified on the tape, regardless of what you type in the Destination field. To strip files of their absolute path name when you archive them, set the Strip Path option in the Tape Tool Properties window to All and click SELECT on the Apply button.

Each of the Tape Tool operations is described in more detail in the following sections.

**Editing the List of Files in the Tape Contents Window**

Once the files are listed (by pressing the List button) in the Tape Contents window, you can retrieve all of the files in the list, retrieve specific selected files, or edit the list to remove files you do not want to retrieve.

The Tape Contents window has a Read Functions pop-up menu, shown in Figure 12-3. To display this menu, move the pointer into the Tape Contents window and press MENU.
Figure 12-3  Read Functions Pop-up Menu in the Tape Contents Window

Select All from the Read Functions menu selects all files on the tape.

You can edit a group of files by clicking SELECT on the name of each file that you want to delete. Clicking SELECT on a selected file deselects it. Files such as group, licenses, and passwd are highlighted, as shown in Figure 12-4.

Figure 12-4  Selected Files to Read (group, licenses, and passwd)

Delete Selected from the Read Functions pop-up menu removes these files from the list. Choose Select All and then Delete Selected from the pop-up menu to delete all the files from the list.

To restore an accidentally deleted file, add it back to the list by typing the file name in the File To Read text field, then press the Return key or click SELECT on the File To Read button.

These functions prepare the scrolling list for an operation from the Read menu described in the next section.
Reading Files from a Tape

The Read menu, available from the Read button at the top of the Tape Tool base window, has three options to read files from the tape or archive files to the directory specified in the Tape Tool window.

Caution – When you read files that have a path name in front of them (an absolute path name), as shown in the Tape Contents list, that path name is always used as the destination.

If the files are not preceded by a file name, the directory you specify in the Destination text field is used as the destination.

Read Selected

When you have listed the contents of a tape and selected all or some of the files, choosing Selected from the Read menu copies the specified files to the destination directory shown in the control area.

When you have not listed the contents of a tape, choosing Selected displays the Tape Contents window without a listing. If you know the names of specific files that you want to retrieve, you can type a name in the File To Read text field, then press the Return key or click SELECT on the File To Read button to add them to the list.

Read Entire List

When you have listed the files from a tape, choosing Entire List from the Read menu reads the entire list of files from the Tape Contents window.

When you have not listed the contents of a tape, choosing Entire List displays the Tape Contents window without a listing.

While the files are being read, messages are displayed in the footer of the Tape Tool window showing you the percentage of files that have been read. As the files are read, they are removed from the Tape Contents window. When the process is complete, a message is displayed in the footer of the Tape Tool window telling you how many files were read.
If there are a large number of files, it may take several minutes for the files to be copied to your system.

**Read Entire Tape**

Choosing Entire Tape from the Read menu copies all of the files on the tape to the destination directory without displaying the Tape Contents window.

**Copying (Writing) Files onto Tape**

To copy (write) one or more files or directories onto a tape cartridge:

1. Click SELECT on the Props button to display the Tape Tool Properties window and confirm that you have the correct options set.
   You should check the Tape Tool Properties window each time you write files to a tape, since the settings are not saved if you quit Tape Tool and start it up again.

2. Check the tape to be sure that it is not write-protected.

3. Insert a blank tape into your tape drive.
   Alternatively, you can use a tape containing data that are no longer needed.

   **Caution** – Any data on the tape will be overwritten by the new data.

4. Click SELECT on the files or directories in a File Manager file pane that you want to copy onto tape.
   Use ADJUST to select additional files or directories.

5. Drag and drop the files onto the Tape Tool drag and drop target and release.
   Press SELECT and use the pointer to move the file or directory icon across the Workspace to the Tape Tool target.

   Alternatively, you can type the name of a directory or of an individual file in the File To Write text field and then press the Return key or click SELECT on the File To Write button. The files or directories you have chosen are listed in the Tape Tool window pane, as shown in the example in Figure 12-5.
   When you see the directory in the scroll box, select it.
Figure 12-5  Files to be Copied to Tape

6. **Click SELECT on the Write button in the Tape Tool window.**
   The file listing is cleared from the window pane when the copy is complete.

Because the files are copied, the original data remain on your system. If you are archiving the files to free up disk space, you then need to delete the files from your system. Before removing the files, refer to, “Checking the Tape Contents” on page 383.

**Checking the Tape Contents**

Before deleting the backup files from your system, make certain that the copy occurred. At any time, you can list the files on a tape as follows:

1. **Insert the tape into the tape drive.**

2. **Click SELECT on the List button in the Tape Tool base window.**
   In a few moments, the contents of the tape are listed in the Tape Contents window pane. Messages in the footer tell you how many files have been found.
Retrieving (Reading) Files from a Tape

The following three sections describe three methods of retrieving (reading) files from a tape. The method you choose depends upon whether you want to retrieve a small portion of the files, a large portion, or all of the files from the tape.

Retrieving a Portion of the Files from a Tape

To retrieve a particular portion of the archived files from a tape cartridge (providing they were initially archived with the SunOS `tar` command, or through Tape Tool), follow these steps:

1. Click SELECT on the Props button to display the Tape Tool Properties window and confirm that you have the correct options set. You may want to check the Tape Tool Properties window each time you retrieve files, since the settings are not saved if you quit Tape Tool and start it up again.

2. Insert the tape into the tape drive.

3. Click SELECT on the List button in the Tape Tool window. A Tape Contents window displays listing the files on the tape. If there are a large number of files, it may take several minutes for the listing to be complete. Figure 12-6 shows a list of files in Tape Tool’s scrolling window.

Figure 12-6  File Listing from a Tape Showing Two Files Selected
4. Click SELECT on the files you want to retrieve from the list.

5. **Type the destination path, if necessary.**
   If you want the destination path to be somewhere other than the path you specified when the files were written (copied) to the tape, type it in the Destination text field.

6. **Choose Read ➤ Selected from the Tape Tool base window.**
   Alternatively, because the Selected option is the default, you can just click SELECT on the Read menu button.

---

**Retrieving Most of the Files from a Tape**

If you have a long list of files, and you want to retrieve all but a few of them:

1. Click SELECT on the Props button to display the Tape Tool Properties window and confirm that you have the correct options set.
   You may want to check the Tape Tool Properties window each time you retrieve files, since the settings are not saved if you quit Tape Tool and start it up again.

2. Insert the tape into the tape drive.

3. Click SELECT on the List button in the Tape Tool base window.

4. **Deselect the files you do not want in the Tape Contents window.**
   Click SELECT on those files that you do not want to include in the file extraction.

5. **Choose Delete ➤ Selected from the Tape Contents window Read Functions menu.**
   The files you have selected are removed from the list.

6. **Choose Read ➤ Entire List from the Tape Tool base window.**
   The files remaining in the list are extracted from the tape.

If you have archived a group of files, you can retrieve the whole group or just a few of them. Unless you removed or changed the path names of the files when you archived them, they are automatically restored to their original directories. (If you have removed or changed the path names, then the files are restored to the new paths with which you archived them.)
Retrieving All Files from a Tape

If you want to retrieve everything on the tape and do not want to list the contents first:

1. Click SELECT on the Props button to display the Tape Tool Properties window and confirm that you have the correct options set. You may want to check the Tape Tool Properties window each time you retrieve files, since the settings are not saved if you quit Tape Tool and start it up again.

2. Insert the tape in the tape drive.

3. Choose Read ➤ Entire Tape. The contents of the entire tape are copied onto your system.

Customizing the Tape Tool

Before you read to or write from a tape or archive file, you may want to confirm that the properties you want to use are set correctly, as shown in Figure 12-7.

♦ To display the Properties window, click SELECT on the Props button.
Figure 12-7  Tape Tool Properties Window

- Device text field identifies the tape drive to your system. The most common device numbers for a tape drive are /dev/rmt/0mb (m is for medium density) and /dev/rmt/0lb (l is for low density). Alternatively, you can specify a file name in this field if you wish to read or write files to and from one big archive file instead of a tape.

- Host Name text field identifies the name of the workstation where the reading or archiving of files is to take place. The default value is your local host name.

- Write sets none, some, or all of the options listed here:
  - No SCCS excludes all SCCS directories.
  - No SCCS+ excludes all SCCS directories, files with a suffix .o, and files named errs, core, and a.out.
  - Block I/O specifies a blocking factor for better throughput. When you click SELECT on this setting, a text field is displayed in which you can type the blocking factor you want Tape Tool to use.
  - Sym Links follows symbolic links as if they were normal files.
  - Show Errs displays error messages if all links to archived files cannot be resolved.
• Suppress suppresses information showing owner and file modes.

• Strip Path settings determine whether selected files are stripped completely of their path names, use complete path names, or use a specific path name. When you click SELECT on Pattern, a text field is displayed in which you can type the name of a path to use for all the files.

• Read sets none, some, or all of the options listed here:
  • No Check ignores directory checksum errors.
  • Mod Time prevents Tape Tool from resetting the modification time of files that it reads from the tape.
  • Orig Mode restores the named files to their original mode, ignoring the default umask setting of 2.

• Other sets none, one, or both of the following options for both read and write operations:
  • Err Exit exits the operation as soon as an error is encountered.
  • Exclude to specifies a file name that contains a list of files and/or directories that you want to exclude from reading from the tape. This item can be useful when the tape contains many files and you want to retrieve all but a few of them.

When you have set the options you want, click SELECT on the Apply button to apply the changes. These options will remain in effect until you quit the Tape Tool application.
Image Tool

Image Tool is an application that you can use to view multiple page documents (such as PostScript files) and single page image files (such as Sun Raster). You can also use it to manipulate or translate a file. Image Tool works with other DeskSet applications such as Mail Tool and Snapshot.

Image Tool is the default viewer for Mail Tool, so if you receive (and open) an attached multiple page document (for example), Mail Tool launches Image Tool to display the attachment. Once you have taken a picture of an image with Snapshot, you can view it, manipulate it, or print it using Image Tool. For complete information on Snapshot, refer to Chapter 14, “Snapshot.”

Image Tool works with color and monochrome monitors. Color monitors vary in their ability to display color, so Image Tool adapts color images to suit the type of monitor. Monochrome monitors display all images in black and white. Color monitors may display images in fewer colors than the original. For example, a 24-bit image appears on an 8-bit color monitor as an 8-bit color image.

This Chapter describes how to use Image Tool to:

- Open an image or document for viewing
- Save an image file (in the same or different format)
- Print an image or document
- Use the Image Tool palette to manipulate a document

To open Image Tool, choose Workspace ➤ Programs ➤ Image Tool.
Image Tool Icon and Window

The Image Tool icon is shown in Figure 13-1, and the Image Tool View window is shown in Figure 13-2. The icon includes a file name if the View window contains an image.

Figure 13-1  The Image Tool Icon

Figure 13-2  Image Tool Base Window
Opening Image Files and Documents

There are several ways to open (or display) an image for viewing, depending on your starting point:

♦ **Open an image by selecting File ➤ Open.**

♦ **In Mail Tool, open an attached image file or multiple page document.**

♦ **Drag and drop a file from another application to the Image Tool View window.**

♦ **In Snapshot, after an image has been snapped, choose the View option.**

Once Image Tool is launched from Mail Tool or Snapshot you don’t have to open Image Tool again to view other images.

Viewing Single Page Images and Multiple Page Documents

If the image you opened is a single page image, the View window resizes to the size of the image (unless the image extends beyond the size of the screen.)

You can now save your image as described in “Saving an Image” on page 395, print your image as described in “Printing Images” on page 399, or use the palette with your image as described in “Using the Image Tool Palette” on page 401.

If your document is a multiple page document, refer to “Viewing Multiple Page Documents” on page 406.

Formats that Image Tool Can Open

Table 13-1 lists the file formats that Image Tool can open along with recommended file name extensions. These extensions may help you recognize file formats.

**Note** – PostScript file formats are for PostScript and Encapsulated PostScript File (EPSF) documents. For simplicity, in the rest of this chapter the term *PostScript* includes EPSF.
<table>
<thead>
<tr>
<th>File Format</th>
<th>File Name Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Encapsulated PostScript File</td>
<td>.ps, .eps, .epsf</td>
</tr>
<tr>
<td>PostScript</td>
<td>.ps</td>
</tr>
<tr>
<td>3 Portable Graymap</td>
<td>.rgb3</td>
</tr>
<tr>
<td>Abekas YUV</td>
<td>.yuv</td>
</tr>
<tr>
<td>Andrew Toolkit</td>
<td>.atk</td>
</tr>
<tr>
<td>Atari Compressed</td>
<td>.spc</td>
</tr>
<tr>
<td>Atari Uncompressed Spectrum</td>
<td>.spu</td>
</tr>
<tr>
<td>Atari Degas 1</td>
<td>.pi1</td>
</tr>
<tr>
<td>Atari Degas 3</td>
<td>.pi3</td>
</tr>
<tr>
<td>AutoCAD Slide</td>
<td>.sld</td>
</tr>
<tr>
<td>Benet Yee Face File</td>
<td>.ybm</td>
</tr>
<tr>
<td>CMU Window Manager</td>
<td>.cmu</td>
</tr>
<tr>
<td>FITS</td>
<td>.fits</td>
</tr>
<tr>
<td>GEM</td>
<td>.img</td>
</tr>
<tr>
<td>GIF</td>
<td>.gif, .GIF</td>
</tr>
<tr>
<td>Gould Scanner</td>
<td>.gould</td>
</tr>
<tr>
<td>Group 3 Fax</td>
<td>.g3</td>
</tr>
<tr>
<td>HIPS</td>
<td>.hips</td>
</tr>
<tr>
<td>IFF ILBM</td>
<td>.ilbm</td>
</tr>
<tr>
<td>HP PaintJet</td>
<td>.pj</td>
</tr>
<tr>
<td>JFIF (JPEG)</td>
<td>.jpg, .jpeg, .JPG, .JPEG</td>
</tr>
<tr>
<td>Lisp Machine Bit-Array</td>
<td>.lispm</td>
</tr>
<tr>
<td>MGR</td>
<td>.mgr</td>
</tr>
<tr>
<td>MTV/PRT Ray-Tracer</td>
<td>.mtv</td>
</tr>
<tr>
<td>MacPaint</td>
<td>.mac</td>
</tr>
<tr>
<td>PBM</td>
<td>.pbm</td>
</tr>
<tr>
<td>PC Paintbrush</td>
<td>.pcx</td>
</tr>
<tr>
<td>PGM</td>
<td>.pgm</td>
</tr>
<tr>
<td>PICT</td>
<td>.pict</td>
</tr>
<tr>
<td>PPM</td>
<td>.ppm</td>
</tr>
<tr>
<td>QRT Ray-Tracer</td>
<td>.qrt</td>
</tr>
</tbody>
</table>
Opening Your File in a Specific Format

If Image Tool cannot recognize the file format you want to open, you may need to specify the format, as described in the following section. To do so:

1. **Choose File ➤ Open As.**
   The Open As window displays, as shown in Figure 13-3, with the current folder location and document file type.

---

**Table 13-1  Image Tool File Formats and Extensions (Continued)**

<table>
<thead>
<tr>
<th>File Format</th>
<th>File Name Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Raw Grayscale</td>
<td>.rawg</td>
</tr>
<tr>
<td>Raw RGB</td>
<td>.raw</td>
</tr>
<tr>
<td>Sun Icon</td>
<td>.icon</td>
</tr>
<tr>
<td>Sun Raster</td>
<td>.im1 (monochrome)</td>
</tr>
<tr>
<td></td>
<td>.im8 (8-bit color)</td>
</tr>
<tr>
<td></td>
<td>.im24 (24-bit color)</td>
</tr>
<tr>
<td></td>
<td>.im32 (32-bit color)</td>
</tr>
<tr>
<td></td>
<td>.rs</td>
</tr>
<tr>
<td>TIFF</td>
<td>.tif, .tiff, .TIF, .TIFF</td>
</tr>
<tr>
<td>TrueVision Targa</td>
<td>.tga</td>
</tr>
<tr>
<td>Usenix FaceSaver</td>
<td>.fs</td>
</tr>
<tr>
<td>X Bitmap</td>
<td>.xbm</td>
</tr>
<tr>
<td>X11 Window Dump</td>
<td>.xwd</td>
</tr>
<tr>
<td>XPM</td>
<td>.xpm</td>
</tr>
<tr>
<td>Xerox Doodle Brush</td>
<td>.brush</td>
</tr>
<tr>
<td>Xim</td>
<td>.xim</td>
</tr>
</tbody>
</table>
2. Select a file type from File Format.
   Table 13-1 on page 392 shows the possible file extensions and list of file formats Image Tool can open.

3. Select a file from the scrolling list.

4. Click Open.
   Your file or document is opened in the View Window. The palette is automatically displayed when your file is opened. If you do not want to automatically display the palette, refer to “Setting Image Tool Properties” on page 408.
Getting Information About Your Image

Image Tool provides the following information about the currently opened file: height, width, colors, or size. To view this information:

♦ Select View ➤ Image Info.
The Image Information window displays as shown in Figure 13-4.

![Image Information Window](image)

<table>
<thead>
<tr>
<th>Image Tool: Image Information</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Height:</strong> 1.6 in / 4.2 cm / 136 pix</td>
</tr>
<tr>
<td><strong>Width:</strong> 3.5 in / 8.8 cm / 287 pix</td>
</tr>
<tr>
<td><strong>Colors:</strong> N/A</td>
</tr>
<tr>
<td><strong>File Size:</strong> 3.7 KBytes</td>
</tr>
<tr>
<td><strong>File Format:</strong> Sun Raster</td>
</tr>
</tbody>
</table>

Figure 13-4  Image Information Window

Saving Image Files and Documents

Saving an Image

There are several options for saving files, but normally only one or two choices are available. For complete information on standard file saving methods, refer to Chapter 1, “Introduction to the Solaris User Environment.”

♦ To save a raster image or multiple page document and keep the current file name, directory, and attributes, choose Save from the File menu.

♦ To save an image (whole or in part) and change the file name directory, or attributes, choose one of the Save As command items:
  • Save As applies to the entire image
  • Save Selection As applies to a region that you defined using the Selector tool.
• Save Page As Image applies only to a single page of a multiple page document.

If the file format for the opened file is not supported, the Save button is dimmed and unavailable. Figure 13-5, shows the Image Tool Save As window.

![Image Tool: Save As Window](image-url)

**Figure 13-5  Image Tool Save As Window**
You can change the settings for:

- File Format: EPSF, GIF, JFIF (JPEG), PostScript, Sun Raster, or TIFF
- Compression:
  - None
  - UNIX — Standard UNIX file compression utility, available for (EPSF), PostScript, Sun Raster, and TIFF formats
  - Encoded run length — Available for Sun Raster
  - LZW — Available for TIFF files
  - JPEG — Available for JFIF files

Available compression methods depend upon selected format. Compression saves disk space.
- Colors: Choose from Black and White, 256, Millions.

**Note** – The number of colors stored in GIF is at most 256. JFIF stores them in true color (millions).

**Save As**

To save a file or document as one of the available formats:

1. **Choose File ➤ Save As.**
2. **Type a new name and extension for the file, if necessary.**
3. **Select a new file format.**

Image Tool can save files in the following formats:

- PostScript
- EPSF
- GIF
- JFIF (JPEG)
- Sun Raster
- TIFF
4. **Select a Compression method, if applicable.**
   The following compression methods are available:
   - None
   - UNIX —Standard UNIX file compression utility, available for (ESPF), PostScript, Sun Raster, and TIFF formats
   - Encoded run length—Available for Sun Raster
   - LZW—Available for TIFF files
   - JPEG—Available for JFIF files

   Available compression methods depend upon selected format. Compression saves disk space.

5. **Select a color attribute, if applicable.**
   Available color attributes are: Black and White, 256, Millions.

6. **Select Save.**

   *Save Selection As*

   Save Selection As is available once you have defined an area with the Selector tool on the palette. For information on using the palette, refer to “Using the Image Tool Palette” on page 401. To save a portion of the image:

   1. **Open the image.**
      For information on opening an image, refer to “Opening Image Files and Documents” on page 391.

   2. **Select a portion of the image to be saved.**
      For information on using the selector tool to select a portion of the image, refer to “Selecting An Area to Be Saved” on page 402.

   3. **Select File ➤ Save Selection As.**
      Saving a selection is the same as using Save as. Refer to “Save As” on page 397 for complete information.
Save Page As Image

You may want to save a single page from a multiple page document. To do this you need to:

1. **Open the multiple page document.**
   Refer to “Opening Image Files and Documents” on page 391, for complete information. Save Page as Image is only used for multiple page documents.

2. **Navigate to the page to be saved.**
   For information on selecting a page, refer to “Viewing Multiple Page Documents” on page 406.

3. **Select File ➤ Save Page As Image.**
   Saving a single page of a multiple page document is exactly like any other type of save. Refer to “Save As” on page 397 for complete information.

Printing Images

You can print your image without verifying the print settings or you can check or change settings before printing. Previewing images before printing them saves paper and trips to the printer. Especially if you have scaled an image to a larger size.

**Printing with Current Settings**

- ♦ **Select File ➤ Print One from the current file menu.**
  Image Tool uses Print Window settings to print one copy.

**Previewing Before Printing**

1. **Choose Print Preview from the File menu.**
   The Print Preview window displays a reduced image with dotted lines representing page boundaries. The page boundaries are determined by the Page Size setting in the Printer window.

2. **Click SELECT on Cancel or Print.**
   Cancel dismisses the window, and Print displays the Print window.
Printing after Checking or Changing Settings

You can verify printer settings and start the printing job from the Print window.

1. **Choose Print from the File menu, or click SELECT on Print in the Print Preview window.**
   
The Print window, shown in Figure 13-6, is displayed.

2. **Change settings, if desired.**
   
   If you change Page Size, Image Size, Image Orientation, or Image Position, you may want to preview the image before printing.
3. Choose Print to start printing or Cancel to dismiss the window.
   A very large raster image may be larger than a single sheet of paper. If so, the entire image is printed on multiple pages.

   **Note** – PostScript pages are printed as bitmapped images (if printed on single pages).

### Using the Image Tool Palette

Image Tool’s Palette, shown in Figure 13-7, is useful for simple changes to an image.

- **Use Pan** to move the contents of the View window with the hand.
- **Use Selector** to save an area of the View window as a new image.
- **Flips the image left to right or top to bottom.**
- **Rotates an image right or left by degrees**
- **Zoom reduces or enlarges the image by value entered in % field**
- **Cancels any unsaved changes and reverts to the last saved version**

![Image Tool Palette](image)

Figure 13-7  Image Tool Palette

1. **Choose Palette from the Edit menu.**

2. **Modify the image.**
   You can modify the image by panning; using the selector; or by flipping, rotating or zooming it. Refer to “Panning an Image” on page 402; “Selecting An Area to Be Saved” on page 402; “Flipping an Image” on page 403; “Rotating an Image” on page 404; or “Zooming an Image” on page 405.
Panning an Image

To move the image within the View window, choose the Pan tool. The pointer changes to a hand until you choose another action. Figure 13-7 on page 401 shows the pan icon as a hand.

Selecting An Area to Be Saved

To select an area of an image to be saved:

1. Choose the Selector tool.
2. Outline the new view by pressing SELECT in one corner of the new view and dragging to the opposite corner.
3. Release SELECT.

You can save the selected view as a new image. Figure 13-8 shows the selector icon and selection made from the View window. For information on saving your file, refer to “Save As” on page 397.

Figure 13-8  Selector icon and selected item
Flipping an Image

To display a mirror image, use the Flip tools. You can flip horizontally and vertically. Figure 13-9 shows the Flip icon and the result of flipping the image upside down.

Figure 13-9  Flip Icon and Flipped Image
Rotating an Image

♦ To rotate the image with the Rotate tool, first enter the number of degrees to be applied in the text field next to the buttons. You can type the value, use the abbreviated menu buttons, or use the sliders. Figure 13-10 on page 404, shows the rotate icon and an image that has been rotated 90 degrees.

Figure 13-10 Rotate Icon and Rotated Image
Zooming an Image

♦ To change the size of the image with the Zoom tool, first enter a value in the text field next to the buttons.
You can type the value, use the abbreviated menu buttons, or use the sliders. Figure 13-11 on page 405 shows the Zoom icon and an image that has been enlarged by 25%.

Figure 13-11 Zoom Icon and Enlarged Image

♦ To cancel unsatisfactory changes:
  • For the most recent single change (panning, flipping, rotating, or zooming), choose Undo from the Edit menu.
  • For multiple changes, click SELECT on Revert. This restores the last saved version of the image.
Viewing Multiple Page Documents

When you open a multiple page document (such as a PostScript file), Image Tool offers several options to help you navigate the document. For example, once a multiple page document has been opened for viewing, the Page Up and Page Down buttons are enabled and you can use them to move through the document page by page.

Page Overview

Use Page Overview to display a window with a scrollable list of thumbnail renderings of each page and controls for viewing specific pages. To open:

♦ **Select View ➤ Page Overview.**

Figure 13-12 on page 406 shows the Page Overview window.

![Figure 13-12 Page Overview Window](image-url)
Page Viewing Controls

Choose View ➤ Page Viewing Controls.

Use Page Viewing Controls to set the viewing orientation to portrait (vertical) or landscape (horizontal); page display order (first page first or last page first); and page size of a multiple page document.

The page size options are:

- 8.5x11 (Letter)
- 8.5x14 (Legal)
- 11x14 (Ledger)
- 29.7x42cm (A3)
- 21x29.7cm (A4)
- 17.6x25cm (B5)

Figure 13-13 on page 407 shows the Page Viewing Controls.

<table>
<thead>
<tr>
<th>Orientation: Portrait</th>
<th>Landscape</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order: First Page First</td>
<td>Last Page First</td>
</tr>
<tr>
<td>Size: 8.5x11 in (Letter)</td>
<td>8.5x14 in (Legal)</td>
</tr>
</tbody>
</table>

Figure 13-13 Page Viewing Controls
Setting Image Tool Properties

The Properties window lets you choose your preferences for display characteristics. Depending on the hardware capabilities of your display, the properties window may have different choices under View Image In.

1. Choose Properties from the Edit menu. The Properties window, shown in Figure 13-14, is displayed.

![Image Tool Properties Window](image)

- **View Image In:** Can set the view for an image in gray scale or color.
- **Colors:** Select the number of colors used for rendering images.
- **Display Palette:** Selecting this automatically displays the palette when an image is opened in the View window.

2. Change the settings, as desired. The View Image In and Colors settings work together to produce an optimal display of color and color depth, based on your monitor’s color capabilities.

3. Choose Apply to implement the new settings or Reset to discard the changes. These changes take effect the next time Image Tool is started.
Status Messages, Error Messages and Help

The footer of the Image Tool base window displays two kinds of messages:

• Status messages (on the right) describe multiple pages. For example, page 1 of 5.

• Error messages (on the left). (Conditions that require decisions on your part are displayed in pop-up notices.)

• You can get information on how to use Help from Chapter 1, “Introduction to the Solaris User Environment.” Magnify Help and the Help Button are also available to you.

Dragging and Dropping

You can drag files from the following tools and drop them onto Image Tool’s drag and drop target:

• File Manager
• Mail Tool
• Snapshot

If Image Tool is already open, dragging and dropping replaces any images already displayed. You can drag images from Image Tool and drop them onto the following tools:

• File Manager
• Mail Tool
• Print Tool

For information on how to drag and drop, see Chapter 1, “Introduction to the Solaris User Environment.”
Image Tool Controls and Menus

The Image Tool control area has three menu buttons (File, View, and Edit) and a Help button. The Help button opens the On-Line Help Handbook for Image Tool. The File, View, and Edit menus are described in the following sections.

File Menu

The File menu contains items for opening, saving, and printing images. Image Tool conforms to standard file choosing methods. All items on the File menu, except Save and Print One, display pinnable pop-up windows. The choices you can make depend on the type of file you are working with—multiple page or single page images.

The functions of each item are:

- Open displays a window from which you choose the file for the image you want to open.
- Open As displays a window from which you choose the file and file format for the image you want to open.
- Save displays a window from which you can save the currently displayed image to a file.
- Save As displays a window from which you choose the type, format, folder, and name of a file for saving the currently displayed image. Use this option when you want to convert an image to a different file format and file type.
- Save Selection As saves the selected area to a new image file. This option is active when an area of the View window has been selected with the Selector tool from the palette.
- Save Page As Image displays a window from which you can save the currently displayed page of a multiple page document as a new image file.
- Print One uses the current settings of the Print window to print a single copy of the currently displayed image or page.
- Print Preview displays the Print Preview window that shows how the contents of the View window will appear when printed. The Print Preview window uses dotted lines to depict the boundaries of the printed page. You can control which area of the image gets printed by dragging the image within the dotted lines.
• Print displays the Print window that contains these options for controlling how the contents of the View window are printed:
  • Copies (number of)
  • Header Page (whether one should be printed)
  • Printer (which device)
  • Page Size (Letter, Legal, Ledger, A3, A4, B5)
  • Page Range (for multiple page documents)
  • Image Size (scaling)
  • Image Orientation (Portrait or Landscape)
  • Image Position (centered or specify margins)

**View Menu**

The View menu contains image information, page overview and multiple page options.

The functions of each item are:

• Image Info displays a window that contains the following information about the currently displayed image or page:
  • Height and Width
  • Number of colors (depth)
  • File size
  • File Format

• Page Overview Available only for multiple page documents, this option displays a window with a scrollable list of thumbnail renderings of each page and controls for viewing specific pages.

• Page Viewing Controls sets these viewing controls for multiple page documents:
  • Page orientation
  • Page display Order
  • Page size

**Note** – The page size setting affects only the view, not printing.
Edit Menu

The Edit menu contains the following items:

• Undo undoes the last usage of these tools from the palette—Flip, Rotate, Pan, or Zoom.
• Palette contains the Pan, Rotate, Selector, Flip, and Zoom.
• Properties displays the Properties window where you can set—
  • If images are viewed in color or gray scale.
  • The number of colors used for rendering images.
  • If the palette is automatically displayed when an image is opened.

Some Standard Operations

The following chart summarizes standard Image Tool operations.

<table>
<thead>
<tr>
<th>To:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Image Tool from the workspace</td>
<td>Choose Workspace ➤ Programs ➤ Image Tool.</td>
</tr>
<tr>
<td>Open Image Tool from its icon</td>
<td>Double-click SELECT on the Image Tool icon.</td>
</tr>
<tr>
<td>Display an image</td>
<td>Choose Open from the File menu.</td>
</tr>
<tr>
<td>Save a raster image</td>
<td>Choose Save from the File menu.</td>
</tr>
<tr>
<td>Close the Image Tool window</td>
<td>Click SELECT on the window menu button in the upper left corner.</td>
</tr>
<tr>
<td>Quit from the Image Tool icon</td>
<td>Press MENU on the icon, then choose Exit from the menu.</td>
</tr>
<tr>
<td>Quit from the Image Tool window</td>
<td>Press MENU on the window menu button in the upper left corner, then choose Exit from the menu.</td>
</tr>
</tbody>
</table>
The Snapshot application allows you to take black-and-white (or grayscale) and color snapshots of regions, windows, or the entire computer screen. These pictures are called raster images and can be stored as *raster* files, with a `.rs` file extension. These pictures are called raster images because they are taken from the screen, which is defined by a grid called a raster.

When you use Snapshot on a black-and-white monitor, the snapshots created are always black and white. When you take snapshots on a color monitor, the snapshots are usually in color. On some color monitors you can run OpenWindows and the DeskSet in black-and-white, in which case the snapshots created are black-and-white.

Snapshot works together with Image Tool to allow you to view and manipulate your raster images. For complete information, refer to Chapter 13, “Image Tool.”

You can take pictures of the entire screen, of any rectangular region of the screen you define, or of any window or window pane on the screen.

♦ To open the Snapshot application, choose Workspace ➤ Programs ➤ Snapshot.
Snapshot Icon and Base Window

The Snapshot icon is an image of a camera, as shown in Figure 14-1.

Figure 14-1  Snapshot Icon

The Snapshot base window, shown in Figure 14-2, contains all the controls you need to take snapshots.

Figure 14-2  Snapshot Base Window

Snapshot Controls

Snap Types

Snapshot provides you with three options for creating snapshots:

- Use the Snap Type: Window setting to snap an entire window.
- Use the Snap Type: Region setting to snap a region you define.
- Use the Snap Type: Screen setting to snap the entire screen.
Note – Snapshot does not capture the screen pointer.

Snap Delay
Snapshot has a timer that you can use to set the number of seconds between the time you initiate the snapshot and the time it is taken. This delay setting is especially useful if you are taking snapshots of a menu that you must display after you start taking a snap. Once a number of seconds is selected, the Beep During Countdown option becomes available. Selecting this option turns on a beep countdown timer that sounds until the snap is taken.

Hiding the Snapshot Window During Capture
Sometimes you may want to take a snapshot of a large portion of the screen or of the entire workspace without showing the Snapshot window. In such cases, click SELECT on the Hide Window During Capture setting to remove the Snapshot window from the screen while the snapshot is in progress.

When the Hide Window During Capture setting is on, Snapshot automatically adjusts the Snap Delay setting to eight seconds. This is to guarantee that there will be enough time to remove the Snapshot window before the snapshot is taken. Remember to reset the Snap Delay setting after you turn off the Hide Snapshot During Capture setting.

Creating a Snapshot
This section describes how to create a snapshot of a window, region, or screen. Remember to save your snapshot afterwards.

Snapping a Window
You can take snapshots of windows and icons following these steps:

1. Make sure the window or icon you want to snap is completely visible.
   If the window or icon to be snapped is partially obscured by overlapping windows, the overlapping windows are included in the snapshot.

2. Click SELECT on the Snap Type Window setting.
3. Set the Snap Delay and Beep During Countdown settings if you want to use them.

4. If you want to hide Snapshot during the capture operation, click SELECT on the Hide Window During Capture setting.

5. Click SELECT on the Snap button.
The Snap button displays the standard busy pattern and a message is displayed in the footer.

6. Move the pointer into the header of the window you want to snap and click SELECT to start the snapshot.
To cancel the operation, click either the ADJUST or MENU mouse buttons. When the pointer is anywhere in the window, the entire window is snapped, including the header and footer.

When the snapshot is complete, a message is displayed in the footer of the Snapshot window telling you that the Snap succeeded. You can now save or view your snapshot. For information on saving your snapshot, refer to Chapter 1, “Introduction to the Solaris User Environment. For information on viewing your image with Image Tool, refer to Chapter 13, “Image Tool.”

**Snapping a Region**

You can take snapshots of any rectangular area that you specify using the Snap Region setting. The following example shows how to take a snapshot of a region.

1. **Set up the region on your screen that you want to snap.**
For example, to take a snapshot of the menu for the Command Tool pane, open a Command Tool window. Make sure the Command Tool pane is not obscured by overlapping windows. Decide where in the Command Tool window you want to put the menu, then display the menu to determine what size region you need to define. This is also helpful if you need to show a submenu.

2. **Click SELECT on the Snap Type Region setting.**
3. If necessary, set the Snap Delay timer and turn on the Beep During Countdown setting.
   This is necessary if you want to change something about the region after you initiate the snapshot. For example, if you want to snap a pop-up menu, you need to set the timer in order to have time to display the menu or submenu.

4. Click SELECT on the Snap button.
   The Snap button displays the standard busy pattern and a message is displayed in the footer. (You may not be able to see the entire message. The message informs you to use SELECT to position the rectangle, ADJUST to snap the image, and MENU to cancel the snapshot.)

5. Move the pointer to one corner of the region and click SELECT to define that corner. Move the pointer and click SELECT again on the opposite corner to define a rectangular region.
   Alternatively, you can press SELECT to define the first corner, drag the pointer to the second corner, then release SELECT to define region.
   A bounding box is displayed. You can adjust the size of the bounding box by moving the pointer and clicking SELECT at a different place.

6. When the region is defined, click ADJUST to take the snapshot or start the timer.
   If you are using the Snap Delay timer to take a snapshot of a pop-up menu, move the pointer into the defined region and press MENU to display the pop-up menu while the timer is beeping. Leave the menu up until the snapshot is complete. When the timer beeper stops, and the message is displayed, the snapshot is complete.

   For information on saving your snapshot, refer to Chapter 1, “Introduction to the Solaris User Environment.” For information on viewing your image with Image Tool, refer to Chapter 13, “Image Tool.”

**Snapping the Screen**

You can take snapshots of the entire screen following these steps:

1. Make sure the screen is set up in the configuration you want.

2. Click SELECT on the Snap Type Screen setting.
3. Click SELECT on Hide Window During Capture unless you want the Snapshot window as part of the screen shot.

4. Set the Snap Delay and Beep During Countdown if you want to use them.

5. Click SELECT on the Snap button.
   - If you set the Hide Window During Capture setting, the Snapshot window is removed from the display and is redisplayed when the snapshot is complete.
   - For information on saving your snapshot, refer to Chapter 1, “Introduction to the Solaris User Environment.” For information on viewing your image with Image Tool, refer to Chapter 13, “Image Tool.”

### Viewing a Snapshot

To view a snapshot:

- **Click SELECT on the View button.**
  - A status message: **Starting Image Tool** is displayed in the lower left corner of the window. This launches Image Tool. Image Tool can provide more functionality for working with your image. For complete information on Image Tool, refer to Chapter 13, “Image Tool.” If you want to look at another snapshot, it is displayed in place of the previous one in Image Tool.

### Loading a Snapshot

Use one of these methods to load a raster file or GIF image file:

- **Click SELECT on the Load button.**
  - You see the Open window. For complete information on loading a file, refer to Chapter 1, “Introduction to the Solaris User Environment.”

  or

- **Drag and drop a file onto the Snapshot drop target.**

  If the image file is compressed, Snapshot automatically uncompresses it for you.
Saving a Snapshot

Use one of these methods to save a snapshot:

♦ **Click SELECT on Save.**

You see the Save window, and the Save window shows the default file named `snapshot.rs`. For complete information on saving a file, refer to Chapter 1, “Introduction to the Solaris User Environment.” You can override the defaults by starting Snapshot in a Command Tool or Shell Tool and using command line options described in the snapshot manual page.

or

♦ **Drag and drop a snapshot into a File Manager folder, and assign it a meaningful name.**

If the drag and drop target in the Snapshot window is filled with gray, a snapshot ready to be dragged. The snapshot is saved in the File Manager as a file called `raster`.

For both methods, snapshots are always saved as raster files. It is a good idea to use `.rs` or some other common suffix for raster file names to make it easier to remember the file type and to manage them as a group.

**Note** – If you save your snapshot from Snapshot, your image is saved in raster format (in black-and-white or color format, depending how you ran Snapshot). If you save your snapshot in Image Tool, you can use any of the six formats available. For complete information on Image Tool, refer to Chapter 13, “Image Tool.”

Printing a Snapshot

To print a snapshot:

♦ **Choose Print Snap from the Print menu.**

You see the `printing...` status message displayed in the lower left corner of the window. Once the snapshot has printed you see `Print Complete`.

**Note** – You can also use Image Tool to print your snapshot. For complete information on Image Tool refer to Chapter 13, “Image Tool.”
The Icon Editor allows you to create your own black-and-white or color icon images. You can display your icon images in the File Manager by binding them to applications and data files using the Binder. Programmers can use the Icon Editor to create application cursors, glyphs, and icons, and save them in a format for inclusion into a C program.

To open Icon Editor, choose Workspace ➤ Programs ➤ Icon Editor.

Icon Editor Icon and Base Window

The Icon Editor icon is shown in Figure 15-1.

![Icon Editor](image)

Figure 15-1  The Icon Editor Icon

When you start the Icon Editor, the base window is displayed, as shown in Figure 15-2.
The Icon Editor controls are described in the following sections.

**Icon Editor Drawing Controls**

The controls that you use to draw an image in the canvas appear to the left of the preview area, and are shown in Figure 15-3.
This section describes the Icon Editor drawing control menus and buttons.

**Drawing Mode Choices**

To draw an icon, choose a drawing mode from the choices in Figure 15-4.

The Mode choice items function as follows:

- **Choose Point** to insert one black pixel at a time in the canvas. To draw a point, move the pointer to the desired position in the canvas and click SELECT. You can continuously hold down SELECT and move the pointer to create a freehand drawing. When you lift your finger from the mouse button, you end one drawing segment. When you continue this process, you begin a new drawing segment. Undo here only removes the last drawing segment. You can also point to a black or color pixel and click ADJUST to turn the pixel from black to white.

- **Choose Line** to draw a line that is 1-pixel wide. To draw a line, position the pointer at one end of the line, press SELECT, drag the pointer to the other end of the line, and release SELECT.
Choose Square to draw open or filled squares or rectangles using any of the fill patterns described in the section “Fill Choices” on page 430. (The fill patterns are active only when the Draw option is a fillable shape, such as a square, circle, or ellipse.) Position the pointer at one corner of the square, press SELECT, drag the pointer to the opposite corner of the square or rectangle, and release SELECT.

Choose Circle to draw open or filled circles using any of the fill patterns. Position the pointer at the center of the circle and press SELECT, drag the pointer to any point to the outside radius of the circle, and release SELECT.

Choose Ellipse to draw open or filled ellipses. Position the pointer at the center of the ellipse and press SELECT, drag the pointer to the outside radius of the ellipse, and release SELECT. If you define a horizontal or vertical line, the ellipse is interpreted as a straight line.

Choosing Text (abc) displays a pop-up window, shown in Figure 15-5, that allows you to type text that is associated with the icon.

Adding Text to the Canvas

To add text to the canvas, follow these steps:

1. Click SELECT on the Text drawing mode option. This displays the Text pop-up window.

2. Choose the font you want to use from the Font menu.
3. Choose the text weight, style, and size from the relevant menus. The items on the Weight, Style, and Size menus depend on the font that you have chosen. For example, some fonts may have many available choices for size, while others only have one default choice.

4. Type the text you want in the Text field.

5. When you have typed the text in the text field, insert it in the icon by moving the pointer onto the desired spot on the canvas and pressing SELECT.

A rectangle is displayed that shows you the size of the text to be inserted, as shown in the example in Figure 15-6. You can move the rectangle anywhere within the canvas to position it as long as you continue to press SELECT.

![Figure 15-6 Adding Text to Your Icon](image)
6. Drag the pointer to position the rectangle, and when it is positioned correctly, release SELECT.

The text is added to the canvas, as shown in the example in Figure 15-7.

![Figure 15-7  Text Added to an Icon](image)

Once you have added text to the canvas, you can edit it as you would any other part of the image:

- Choose Region (the rectangle within a rectangle) to define a rectangular region on the canvas and move, flip, or rotate it by clicking SELECT on any of the Move buttons.
Choose Erase to erase any pixels on the canvas by moving the cursor onto the canvas, clicking SELECT, and dragging the eraser cursor over the areas you want to erase. Only the pixel under the front tip of the eraser is actually erased.

**Editing Images**

At any time, you can:

- **Undo the last change or addition you made by choosing Edit ➤ Undo from the control area.**
  
  The remaining editing commands in the Edit menu behave the same as those in a Text Editor window.

**Cutting a Portion of an Image**

To cut a portion of the drawing, create a rectangular outline around the area to be cut. To do this:

1. **Click SELECT on the rectangular icon next to the oval in the control area.**
   
   This enables you to define a region to cut.

   ![Region Selection Rectangle](image)

   *Figure 15-8  Region Selection Rectangle*

2. **Position the pointer on the canvas window at one corner of the portion to cut, press SELECT and drag the pointer diagonally to the opposite corner, then release the mouse button.**
   
   Figure 15-9 shows how the area to be cut is surrounded by a rectangular region.
3. Choose Edit ➤ Cut.
This cuts the outlined portion of the image and places it in a system clipboard. You can then paste it elsewhere, if needed. Figure 15-10 shows the icon image with the portion cut away.
Erase

The small rectangular object next to the abc button on the Icon Editor control area is an eraser. The icon for the eraser is shown in Figure 15-11.

To erase a portion of an image:

1. Click SELECT on the eraser icon.
2. Move the pointer to the area in the canvas window that you want to erase.
3. Press SELECT and drag the pointer over the area you want to erase.
   If you lift your finger from the mouse button frequently to end the current
   input segment, you can undo the last segment at any time without losing all
   of the changes you’ve made. You can undo the last input (erase) you made
   at any time by choosing Undo from the Edit menu, or from the pop-up
   menu in the Icon Editor window pane (canvas).

**Fill Choices**

The Fill choices, shown in Figure 15-12, allow you to choose an outline or one
of 10 fill patterns for drawing squares, circles, or ellipses. This menu is only
active when the current mode is a fillable shape (square, circle, or ellipse).

![Fill Choices Image]

*Figure 15-12  The Icon Editor Fill Choices*

The first fill choice, an open square, draws an outline of the chosen shape,
using a 1-pixel wide black pattern. The other fill choices represent patterns,
from white to black, that you can use to fill the square, circle, or ellipse modes.

**Icon Editor Color Controls**

You can create color or black-and-white icons by choosing Color or B&W, as
shown in Figure 15-13. Color is not available if your workstation is
black-and-white.

![Color Choices Image]

*Figure 15-13 Icon Editor Color Choice*

When the Color choice is selected, you can draw using black, white, or any of
the colors provided on the Color Chooser window. You display the Color
Chooser with the Palette button on the Icon Editor header. When you select a
color from the Color Chooser, the cursor changes to that color as a reminder of your current color choice. See the section “Icon Editor Color Chooser Palette” on page 439 for information about using color.

When the B&W choice is selected, only the colors black-and-white are available. The Palette button on the Icon Editor header changes to a Black or White choice setting. When Black is selected, your icon is drawn with a black pen. When White is selected, your icon is drawn with a white pen.

If the icon you are creating is currently in color when you select B&W, the icon becomes black-and-white.

**Caution** – If you change your icon from color to black-and-white, the colors will not be restored when you switch back to color. If you inadvertently switch from color to black-and-white, use the Undo item on the Edit menu to restore the color.

**Move Buttons**

Use the move buttons (the arrows shown in Figure 15-14) to adjust the position of the drawing on the canvas, or to move a region within the canvas. To move a selected region, click SELECT on one of the left, right, up, or down arrow buttons to move the region one pixel in the designated direction. If no region is selected, the entire drawing is moved.

![Figure 15-14 Icon Editor Move Buttons](image)

**Note** – If you move or rotate part of the image off the canvas, the pixels are cropped from the image and are not restored when you move the image in the opposite direction. Use the Undo item on the Edit menu to restore the image.
To move a region:

1. **Choose Region from the Mode choices.**
   Region is the last item on the top row of the Mode choices.

2. **Move the pointer to the corner of the region you want to move and press SELECT.**

3. **Drag the pointer to define the region and release SELECT.**

4. **Click SELECT on one of the arrow buttons to move the region one pixel in the designated direction.**
   You can repeat this operation as often as you like.

The fifth and sixth buttons shown in Figure 15-14 flip the selected region from left to right or top to bottom. If no region is selected, the entire image on the canvas is flipped. The right two buttons shown in Figure 15-14 rotate the region or the image 90 degrees in the direction of the arrow.

### Filing Options

You use the File menu to load, save, and print icons.

#### Loading and Saving a File

For information on loading and saving files, refer to Chapter 1, “Introduction to the Solaris User Environment.”

#### Saving a New Icon

If you have drawn a new icon image, you can save it to a new file as follows:

1. **Choose File ➤ Save As.**
   You see the Save As window.

2. **Save the file.**
   For complete information on saving a file, refer to Chapter 1, “Introduction to the Solaris User Environment.”
Saving a Modified Icon

If you have modified an existing icon image, you can save it to a new file, which preserves the original image, or save it to the same file. For complete information on saving files, refer to Chapter 1, “Introduction to the Solaris User Environment.”

The formats available for saving an icon are the following:

- If your icon is in color, it will be saved as a color X pixmap image. This type of icon might be used for some XView applications.
- If your icon is black-and-white, you can use the Save menu to choose among saving the icon as a regular Xview icon, as an X bitmap, or as a Monochrome X pixmap image. Save the icon as an Xview icon if you want to display your icon in the File Manager by binding it to an application or data file using the Binder. See Chapter 16, “Binder” for more information. Save the icon as an X bitmap if you want to include it in a C program.

If a file of the same name already exists, a Notice is displayed asking you whether you want to overwrite the existing file or cancel the operation.

Clearing the Canvas

♦ To clear the canvas for another drawing, choose Edit Clear.

Printing an Icon

Use the Print window, shown in Figure 15-15, to print icon files. This window displays when you choose Print from the File menu.
You can specify the following options from the Icon Editor Print window:

- Destination of the printed output (Printer or File)
- Printer name and printer options, or file destination and file name

If the Destination is Printer, as in Figure 15-15, a field called Options is displayed. You can type in UNIX commands in this field to customize your printer option defaults.

- Width and height of the printed image
- Left and bottom margins of the printed image
- Number of copies to print

When you’ve chosen your Printer Settings, click SELECT on the Print button to print the icon.

**View Menu**

The View menu provides the option to display a Grid on the canvas.
**Grid Display**

Choose Grid On (or just click SELECT on the View button) to display a 4-pixel grid for the canvas. The grid is useful for aligning and centering all or parts of the icon.

When the grid is turned on, the View menu item changes to Grid Off. Therefore, you can toggle the grid on and off by clicking SELECT on the View button.

Figure 15-16 shows an example with the grid turned on.

![Grid Display Example](image)

*Figure 15-16 Grid Turned On*
Edit Menu

The Edit menu provides standard editing options, as described in the following sections. The items on the Edit menu are also available on the pop-up menu in the Icon Editor canvas pane.

Undo and Redo

You can undo up to seven of your last actions by choosing Undo from the Edit menu. After choosing Undo, you can then choose Redo to repeat the original action, which restores the canvas to its condition before you chose Undo. You never need to worry about what an action will do to your icon because of this feature. If you don’t like the results, simply use Undo and Redo to restore the icon to the way you like it best.

Each time you Undo an action, that action becomes available to you as a Redo action (up to a maximum of seven actions). Each Redo performs the most recent Undo action. The number of Undo actions and Redo actions that are available to you at any time is displayed in the Icon Editor footer.

Clear

You can clear the canvas by choosing Clear from the Edit menu. No warning notice is displayed. If you change your mind, choose Undo from the Edit menu.

Cut, Copy, and Paste

You can use the Cut, Copy, and Paste items to move and copy regions of your icon, or the entire icon.

When you choose Cut on the Edit menu, the current region is removed from the icon and put on the clipboard. If you don’t have a region currently defined, the entire icon is deleted and put on the clipboard.

To define a region, choose the Region drawing mode, move the pointer to the canvas where you want to start the region, press SELECT, drag the pointer to the opposite corner of the desired region, and release SELECT. The region is displayed by a dashed-line border. The lines of the border appear to be blinking, like the lighted sign of a theater marquee.
When you choose Copy on the Edit menu, the current region is copied to the clipboard but is not removed from the icon. If you don’t have a region currently defined, the entire icon is copied to the clipboard.

Before choosing Paste on the Edit menu, define the region where you want to paste the contents of the clipboard. When you choose Paste on the Edit menu, the contents of the clipboard are copied to the icon, placed so that the upper left corner of the clipboard contents matches the upper left corner of the current region.

If you choose Paste from the keyboard (depending on your keyboard type), the contents of the clipboard are placed so that the upper left corner of the image goes to the position of the mouse.

**Invert**

Choose the Invert item on the Edit menu when you have a black-and-white icon to change black pixels to white, and vice-versa, in your current region. If you do not have a region selected, Invert works on the entire icon. If your icon is color, the Invert item is dimmed and unavailable.

**Properties Menu**

The Properties menu provides options to change the icon format and size.

**Icon Format**

Use the Format item to specify the default format for the icon to be saved in. After you select a format, that format will be used when you choose Save on the File menu. That format also becomes the default item of the Save menu on the File pop-up window. See “Loading and Saving a File” on page 432 for more information.

The following icon formats are available:

- If your icon is in color, it can be saved as a color X pixmap image. This type of icon might be used for some XView applications.

- If your icon is black-and-white, it can be saved as a regular Xview icon, as an X bitmap, or as a Monochrome X pixmap image. Save the icon as an Xview icon if you want to display your icon in the File Manager by binding
it to an application or data file using the Binder. See Chapter 16, “Binder” for more information. Save the icon as an X bitmap if you want to include it in a C program. A monochrome X pixmap image might be used for some XView applications.

**Icon Size**

The Size item provides five standard icon image sizes:

- 16 by 16 pixels (typical cursor size)
- 32 by 32 pixels (the required size for File Manager data file icons)
- 48 by 48 pixels
- 64 by 64 pixels (typical application icon size)
- 128 by 128 pixels

If you change the size of the canvas when an icon file is loaded, the file is read from the upper left corner. Larger images are cropped to fit the existing size of the canvas. In the example shown in Figure 15-17, the canvas with the *cat.icon* file has been resized to 32 by 32 (XView format) pixels.
Icon Editor Color Chooser Palette

You can create a multi color icon if you have a color workstation. You can save the color icon as a color X Pixmap file to be used with your own X applications. If you are using the Icon Editor to create new icons for File Manager, you should create black-and-white icons. You can use the Binder to specify foreground and background colors for your File Manager icons.

If you want to create a color icon, select the Color choice in the Icon Editor drawing controls area, as described in the section “Icon Editor Color Controls” on page 430. When you are creating a color icon, the rightmost button in the Icon Editor header is labeled Palette. (When you are creating a black-and-white icon, this button is replaced with a Black or White choice setting.) Click SELECT on the Palette button to display the Color Chooser, shown in Figure 15-18, which you can use to specify the color to draw with.
The current color that the Icon Editor will use for drawing is displayed in the upper left corner of the palette shown in Figure 15-18.

To use any of the colors displayed in the Color Chooser palette for the Icon Editor:

1. **Click SELECT on the desired color in the Color Chooser palette.**
   The selected color is highlighted and displayed in the Color Chooser preview area. The preview area is the large square at the left of the palette.

2. **Click SELECT on the Apply button to record the color change.**

3. **Move the pointer back to the Icon Editor to draw your icon with the chosen color.**
   The color of the pointer changes to the selected color you are drawing with.
The Binder application allows you to bind icons, colors, applications, open methods and print methods to files. A binding is a connection between file types and elements such as applications to be started when a file is opened, print scripts, or icons that the File Manager, Print Tool, Mail Tool, and other DeskSet applications use to display and operate on files. Audio Tool sound files are also bound.

Because the DeskSet applications come with a default set of bindings, most DeskSet users will not need to use the Binder application. You may want to use the Binder, however, to customize your DeskSet applications. For example, you use the Binder if you want to change the way particular files are displayed in the File Manager or other DeskSet applications, or if you want to change the application used to open or print a file.

Programmers who want to integrate applications into the DeskSet should see the Desktop Integration Guide for programmer information about the Binder database.

If you are not a programmer working on the integration of applications into the DeskSet, this chapter provides all the information you need to know about the Binder and the underlying Binder database.

♦ To open the Binder application, choose Workspace ➤ Programs ➤ Binder.
Binder Icon and Window

The Binder icon and base window are shown in Figure 16-1.

![Binder Icon and Base Window](image)

**Binder Control Area**

Use the buttons in the Binder control area as follows:

- Save saves your changes to the Binder database. Save replaces the standard File menu button because it is the only file operation used by the Binder.
- View determines which Binder entries you want to display. See the following section, “Binder Databases” on page 443 for more information.
• Undo undoes the last operation. The operations that are undoable are the buttons at the bottom of the base window: New, Duplicate, and Delete. If no editing operations have been made since the Binder was started or since the last Save, the Undo button is dimmed and unavailable. Undo replaces the standard Edit menu button because it is the only Edit function used by the Binder.

• Props displays the properties of a Binder entry. There are two components for each Binder entry: the Icon properties that determine how a file is displayed and operated on by the DeskSet applications, and the File Type properties that determine which files are bound to the Icon properties. See the section “Binder Properties” on page 446 for more information.

Binder Databases

The scrolling list in the Binder base window displays the bindings stored in three different databases: a network database, a system database, and a private user database. These are the Binder databases used by all applications in the DeskSet environment to determine how to display, print, and open any file.

The network database consists of the Binder entries shared by many workstations across a network. The system database consists of the Binder entries shared by multiple users on one workstation. Your private database consists of the Binder entries that apply only to you.

Updating and Viewing Private Binder Entries

If you start Binder from the Workspace menu, or from the command line without any command-line options, you can save only the changes to your private user database. Most users will run the Binder application this way.

The first time you run the Binder application, all your bindings will be system or network entries. If you want to customize a system or network entry, you can copy it to your user database, and then modify the user entry. When you add a new binding, it will be added as a private entry.

A message in the footer of the Binder window tells you whether the currently selected entry is a Read-Only Entry. These are the system and network entries that you normally cannot modify. These entries can be duplicated into your private database and then modified. Refer to “Updating and Viewing System and Network Binder Entries” on page 444 for more information.
Use the items on the View menu to determine the Binder entries displayed in the base window scrolling list, as follows:

- Choose All Entries to display a merged list of all the private, system, and network entries. If you copy a system or network entry to your private user database, only your private version of the entry is displayed in the merged list.
- Choose Shared Entries to display all the system and network entries.
- Choose Personal Entries to display only your private user entries.

**Updating and Viewing System and Network Binder Entries**

If you want to modify your system bindings, you must become root and start Binder by typing `binder -system` in a Shell Tool or Command Tool.

In order to modify the network bindings, you need to have root access on your OpenWindows server workstation, and you need to start Binder by typing `binder -network` in a Shell Tool or Command Tool.

If you cannot start the Binder as root, you probably need to restart OpenWindows with the `noauth` option. To do this, exit the window system and type `openwin -noauth` at the console.

The entries on the View menu have a different meaning if you are running the Binder with the command-line options listed previously.

If you run the Binder with the `-system` option, all new entries are added to your system database. In this case you use the View menu as follows:

- Choose All Entries to display a merged list of all the system and network entries. If you copy a network entry to the system database, only the system version of the entry is displayed in the merged list.
- Choose Shared Entries to display only the network entries.
- Choose Local Entries to display only the system entries.

If you run the Binder with the `-network` option, all new entries are added to the network database. In this case the View menu is dimmed and unavailable. Only the network entries are displayed.
To modify entries for local use on your machine, you need to copy them from the system and network databases into your private database. To copy an entry to your database, first scroll through the list of Binder entries in the Binder base window until you see the one you want to modify.

1. **Click SELECT on the Binder entry you want to modify.**
   A rectangle appears around the chosen entry. The example in Figure 16-2 is the icon for the Mail Tool application.

![Binder Entry List](image)

*Figure 16-2  Choosing the Mail Tool Icon Entry*

2. **Click SELECT on the Duplicate button.**
   The entry is copied into your private database.

3. **Choose View ➤ Personal Entries.**
   The view changes to your personal database, listing the newly copied entry and any others that you may have. The copied entry has the temporary name `unnamed_1`.

   Figure 16-3 shows a private Binder database with the newly copied entry.
Figure 16-3 Private Binder Database

**Note** – If you run Binder as root *without* the `-system` or `-network` command-line options listed above, you will only be able to modify the personal Binder entries for user “root.” Make sure to use the command-line options if you want to modify the system or network entries.

Binder Properties

When you want to modify or add new bindings, use the Props menu or the Props keyboard key to display the Properties window. You fill in or change the information on these properties windows to specify your bindings.

There are two categories of Binder properties: Icon properties and File Type properties. These categories are described in the following sections.

The Apply and Reset buttons at the bottom of the Properties window apply or reset the changes made to both categories, Icon and File Type, at the same time. If you want to make both Icon and File Type changes, you only need to click SELECT on Apply once, after you have finished making both sets of changes.
Icon Properties

The Icon Properties window displays all the information used by DeskSet applications to display and operate on files. The icon properties determine how files of a particular type are displayed by DeskSet applications (such as File Manager), and what happens when files of that type are opened or printed.

You display the Icon Properties window by selecting an entry in the base window scrolling list and choosing Icon from the Props menu. The default Icon Properties window shows only the information needed to display a type of files, as shown in Figure 16-4.

Figure 16-4  Default Icon Properties Window

You can click SELECT on the plus sign (+) button at the lower right of the window to expand the window to display the full set of properties, including information needed to open and print a class of files, as shown in Figure 16-5.
You can shrink the window back down to the smaller size by clicking SELECT on the minus sign (-) button at the bottom of the expanded window.

This section describes the fields in the expanded Icon Properties window.

**Icon and Binder Entry Name**

The Icon field shows the current icon and Binder database entry name. Use the text field to modify the entry name, and use the following fields to modify the appearance of the icon. Double-click SELECT on the temporary unique name to the right of the icon to modify the icon.

**Image File**

The Image File text field displays the path of the 32 by 32 pixel (XView format) icon that is bound to the current Binder entry. The icon is displayed in the base window scrolling list and the Icon field. This is the same icon displayed by the File Manager, Mail Tool, and other applications in the DeskSet environment.

**Mask File**

The Mask File text field displays the path of an icon color mask. A color mask defines the region of the icon to which the background color is applied. You can think of this as a stencil cut out overlaid on top of your icon before the background color is applied to the icon. If no icon mask file is specified, the entire icon is colored with the background color.
The icon mask does not have to be a 32 by 32 (XView format) pixel icon. If it is larger, only the first 32 by 32 (XView format) pixels in the top left corner of the icon are used.

For example, Figure 16-6 shows the icon and the icon mask for the printtool-prog Binder entry. The image on the left is the icon image, and determines what is outlined in the foreground color. The image on the right is the icon mask, and determines the area of the icon colored with the background color.

Figure 16-6  The printtool-prog Icon and printtool-prog Icon Mask

Image File and Mask File Line

These text lines specify the path (directory location) to the icon and the icon’s mask—a stencil of the image that determines the area of the icon colored with the background color. To modify the current icon in its appearance on the workspace, do not modify these paths.

Foregr (Foreground) Color

The foreground color is the color that the icon itself is drawn (icon outline) within the File Manager and other DeskSet applications. If no value is given for this field, the foreground color is black.

If you want to pick a new foreground color, click SELECT on the window button to the right of the Foregr Color text field to invoke the Color Chooser application. See “Using the Color Chooser Palette with Binder” on page 464 for more information.

Alternatively, you can type three numbers in the Foregr Color text field to indicate the amount each of red, green, and blue in the foreground color. Color saturation values range from 0 through 255. For example, 255 0 0 represents a bright, solid red color.
Backgr (Background) Color

The background color is the color the icon is colored within (the lines of the icon) the File Manager and other DeskSet applications. If no value is given for this field, the background color is white.

If you want to pick a new background color, click SELECT on the button to the right of the Backgr Color text field to invoke the Color Chooser. See the section “Using the Color Chooser Palette with Binder” on page 464 for more information.

Alternatively, you can type three numbers in the Backgr Color text field to indicate the amount of red, green, and blue, respectively, of the background color. Color saturation values range from 0 through 255. For example, 0 255 0 represents a bright, solid green color.

Application

The Application text field defines the application that is invoked whenever any file defined by the current binding is opened in File Manager or other applications in the DeskSet environment. This text field is on the expanded portion of the Icon Properties window.

Note – If there is a ToolTalk™ method available, applications do not use this field. Refer to the Desktop Integration Guide.

Print Method

The Print Method defines how a file is printed in the DeskSet environment. If no Print Method is specified, the default print method of the application the file is being printed from is used. This field is on the expanded portion of the Icon Properties window.
Note – DeskSet applications such as File Manager and Print Tool expect print methods to be in this format:

```
cat $FILE | (pipe1) | (pipe2) ...
```

Defining a print method of another type may produce unexpected results with the deskset tools. See also Chapter 10, “Print Tool,” for information on overriding a default Print Method.

**File Type Properties**

You use the File Type Properties window to define the set of files that are bound to the icon, colors, and applications defined in the Icon Properties window.

You display the File Type properties by choosing File Types from the Props menu or the Category choice on the Properties window. The default File Type Properties window is shown in Figure 16-7.

![Figure 16-7  Default File Type Properties window](image)

You can click SELECT on the plus sign (+) button to expand the window to display the full set of properties, including information needed to identify a class of files, as shown in Figure 16-8.

![Figure 16-8 Expanded File Type Properties window](image)

You can shrink the window back down to the smaller size by clicking SELECT on the minus sign (-) button at the bottom of the expanded window.

This section describes the fields in the File Type Properties window.

**File Type Scrolling List**

Each entry in the File Type scrolling list defines how a file, or a group of files, is recognized by DeskSet applications. You can think of each entry in the File Type scrolling list as a class of files, which may consist of one file or many files. Each class of files in this scrolling list (each File Type entry) is bound to the Icon properties of the current Binder entry.
**Note** – If you have two identical File Type entries in your Binder database, only the first one that the Binder reads is used. The first Binder entry to use the File Type entry is *not* necessarily the first Binder entry in the Binder base window scrolling list.

**Pattern Text Field**

Use the Pattern text field beneath the scrolling list to modify the name of a File Type entry. If the files are to be identified by a pattern, this pattern must be the name of the Binding entry. If the currently selected File Type is identified by Content, the Pattern text field is dimmed and unavailable.

When there are no items selected on the scrolling list, you can type a pattern into the Pattern text field and press Return to create a new File Type entry.

**File Type Properties Window Buttons**

You SELECT the buttons to the right of the File Type scrolling list to create and delete File Type entries, and to move them to and from a clipboard, as follows:

- **New** creates a new File Type entry. The name of the first new entry is `unnamed_1`. If you create another new entry without renaming the first, it is called `unnamed_2`, etc.

  To change the name of a File Type entry, type a new name in the Pattern text field and press Return. If you want to identify a set of files by a pattern, you must type the actual pattern in the Pattern text field. If you want to identify a set of files by content, the name of the File Type entry can be anything.

- **Cut** removes the currently selected File Type entry from the current Binder entry (the entry selected in the base window scrolling list), and to move it to the clipboard. If the current Binder entry is a read-only entry, the Cut button is inactive.

- **Copy** copies the currently selected File Type entry to the clipboard.

- **Paste** adds the File Type entry that is on the clipboard to the current Binder entry. The Paste button is inactive if there is nothing on the clipboard.

- **Delete** removes the File Type entry from the current Binder entry. The Delete button is inactive if the current Binder entry is a read-only entry. Note that deleting a Binder entry does *not* delete its File Type entry.
You use the Apply and Reset buttons at the bottom of the File Type Properties window to apply your File Type and Icon Properties changes to the current Binder entry, or to reset all the changes you’ve made since the last Apply.

**Identify Choice Item**

The Identify choice item determines how the current class of files (the selected File Type entry) is recognized by DeskSet applications, such as the File Manager. A class of files is recognized either by Name or by Content, as defined in the following sections:

**Identify By Name**

If the Identify choice is by Name, files are recognized by the pattern in the Pattern text field. In this case, the Pattern is often the name of an application. For example, Figure 16-9 shows the clock File Type entry that is bound to the clock-prog Binder entry. Any file called clock will be displayed by the File Manager with the clock icon and colors displayed in the base window scrolling list. (The icon and colors are defined by the clock-prog Icon properties.)

![Figure 16-9 Clock File Type Entry](image-url)
When the Identify choice is “by Name” and the Pattern text field contains an asterisk (*), the asterisk in the Pattern means “match any file name here.” For example, the File Type Entry *.ps, shown in Figure 16-10, matches all files that end with .ps. These files are PostScript files, and are displayed in the DeskSet with the postscript-file icon displayed in the Binder base window scrolling list.

Figure 16-10 The *.ps File Type Entry

An exception to the rule about matching the pattern with the file name occurs with the Binder entries default-app, default-dir, and default-doc. The File Manager application uses these entries to determine the bindings for its default application files, directories (folders), and documents. The File Type patterns for these bindings are default|app, default|dir, and default|doc. You will never, however, actually find a file called default|app, default|dir, or default|doc. See “Changing a Binding” on page 462 for information about how to change these default File Manager bindings.
Identify by Content

If the Identify choice is by Content, files are recognized by matching file contents instead of the file name. When you choose by Content, the four fields underneath the Identify setting become active. These fields define what the file contents should be to define files of the current File Type, as follows:

- **Tag Offset** determines the starting position in the file (counting from 0) where the contents should be matched. The default value is 0, meaning “match the contents starting at the very first character of the file.” A Byte Offset of 1 would start matching the contents at the second character of the file, and so on.

- **Tag Type** determines the type of value that is to be matched in the file contents: Byte, Short, Long, or String. Most files are ASCII files consisting of the String data type (that is, words and characters that you can type). A Byte type is a one-byte numerical value, a Short is a two-byte numerical value, and a Long is a four-byte numerical value.

- **Tag Value** determines what to look for in the file contents. This value must be of the type defined in the Tag Type setting.

- **Tag Mask** is an optional field that you can use to define a *mask* value for Byte, Short, or Long data types. If a mask value is defined, a logical AND operation is performed on the Tag Type in the file being bound and the Tag Mask to determine the match value (the contents to be matched). If that value matches the Tag Value, then the file is bound. This field is primarily intended for programmers developing applications to be integrated into the DeskSet environment.

See the `magic` manual page for advanced information about the Tag Type, Tag Mask, and Tag Value fields.
Figure 16-11 shows that PostScript files can be recognized by the string “%!” at the beginning of the file (Tag Offset = 0, Tag Type = String, Tag Value =%!)

Note that PostScript files can also be recognized by files ending with .ps, as described previously in the section “Identify By Name.”

![Diagram of Binder Entry]

**Figure 16-11 The postscript-file Content File Type Entry**

Figure 16-12 shows the sun-raster File Type entry. This class of files is defined as all files starting with the Long value 0x59a66a95.
Creating a New Binding

The following steps explain how to create a new binding. The example binds the cat icon described in Chapter 15, “Icon Editor” to the cat program file in your /bin directory.

1. If an icon does not exist for the new binding, use the Icon Editor to create a 32 by 32 (XView format) pixel icon.
   See Chapter 15, “Icon Editor” for instructions.

   The icon for the binding is the icon displayed by the File Manager, Mail Tool, and other applications in the DeskSet environment.

   If you want to color only part of the icon when it is displayed in the File Manager or other DeskSet applications, use the Icon Editor to create a 32 by 32 (XView format) pixel icon mask, which defines the area of the icon to be colored. See “Mask File” on page 448 for information about icon masks.

2. Click SELECT on the New button at the bottom of the base window.
   A new entry is automatically created called unnamed_1, and the Binder Properties window is displayed showing the Icon category, as shown in Figure 16-13. If an entry called unnamed_1 already exists, the new entry is called unnamed_2, and so forth.
3. Replace the name in the Icon text field of the Properties window with the name you want for the new Binder entry.
   In this example, type `cat_prog` in the Icon text field.

4. Type the path and file name of a 32 by 32 (XView format) pixel icon in the Image File text field.
   In this example, type the path and name of the cat icon created in Step 1.

5. If you want to specify a color mask for the icon, type the path and file name of the icon mask in the Mask File text field.
   An icon mask defines the area of the icon to be colored when the icon is displayed in the File Manager or other DeskSet applications. See the section “Mask File” on page 448 for more information.
   If you don’t specify an icon mask file, the entire icon image will be colored with the background color.
6. Specify the foreground and background colors for the icon by typing RGB (red/green/blue) values in the text fields, or by using the Color Chooser. The foreground color is the color the icon is drawn with when it is displayed by the File Manager or other DeskSet applications. See the section “Foregr (Foreground) Color” on page 449 for more information.

The background color is the color the icon is filled with when it is displayed by the File Manager or other DeskSet applications. If you have specified an icon mask file, the background color is only filled in the mask area. See the section “Backgr (Background) Color” on page 450 for more information.

You use the Color Chooser to specify colors by clicking SELECT on the Foreground Color or Background Color menu buttons, located to the right of the Foregr and Backgr text fields. See “Using the Color Chooser Palette with Binder” on page 464 for information about using the Color Chooser.

7. If desired, type an Application or Print Method, or both, in the text fields of the expanded Properties window.

If your Properties window is not expanded, click SELECT on the plus sign (+) button at the bottom right corner of the Properties window to display the Application and Print Method text fields.

The Application defines the application that is invoked whenever any file bound to this set of properties is opened in File Manager, Mail Tool, or other applications in the DeskSet environment. The default application is textedit.

The Print Method defines how a file bound to this set of properties is printed in the DeskSet environment. If you do not specify a Print Method, the print method of the application the file is being printed from is used.

8. Choose File Types on the Properties window Category choice item to display the File Type properties.

The File Type properties determine the set of files that are bound to the Icon properties that you just specified.
9. **Type the new File Type entry name in the Pattern text field and press Return.**
   In this example, type `cat` in the Pattern text field.

   If you are going to recognize files by Pattern, the Pattern text field must contain the pattern to be matched, such as `cat` in this example. If you are going to recognize files by Content, the Pattern text field can be anything that distinguishes this type of file.

10. **Move the pointer to the Identify choice item on the expanded properties window, and click SELECT on “by Name” or “by Content” to specify how you want to recognize files.**
    In this example, click SELECT on “by Name” to match the file named `cat`.

    If you select “by Content,” the last four Type Information fields become active. You then need to specify the Tag Offset, Tag Type, and Tag Value to be used to recognize files by content. You can also specify a Tag Mask, if desired. See the section “Identify by Content” on page 456 for more information about the Content fields.

11. **If you want to specify more files to be bound to the Icon properties, repeat steps 9 and 10.**

12. **Click SELECT on the Apply button to apply the Icon and File Type properties to your new Binder entry.**

13. **Click SELECT on the Save button at the top of the Binder base window to save the new Binder entry in your personal database.**
    If you are running the Binder as root with the special options to update the system or network entries, the new entry is added to the appropriate database. See the section “Binder Databases” on page 443 for information about the three different Binder databases.

**Note** – The DeskSet applications will *not* recognize the new binding until you have saved it by clicking SELECT on the Save button. You must also restart the application.

Figure 16-14 shows the new bound image after quitting File Manager and starting it again.
Deleting a Binder Entry

To delete a Binder entry, select the entry in the Binder base window scrolling list, and click SELECT on the Delete button. Then click SELECT on the Save button. The Delete button is dimmed and inactive if the currently selected entry is a read-only entry.

Note – When you delete a Binder entry, the File Type entry associated with it is not deleted. If you want to delete the File Type entry, make sure to delete it from the File Type scrolling list before you delete the Binder entry.

To delete the File Type entry, select the Binder entry in the base window scrolling list, display the File Type Properties window, select the File Type in the File Types scrolling list, and click SELECT on the Properties window Delete button.

Changing a Binding

To change a binding:

1. Select the entry in the Binder base window scrolling list.

2. Modify the Icon and File Type properties fields that you want to change. Make sure to click SELECT on the Apply and Save buttons to apply your Properties changes and then save them to the Binder database.
If the binding that you want to change is a read-only entry, you can select the entry and then click SELECT on the Duplicate button to make a private copy of the entry. You can then modify your private copy of the Binder entry.

For example, suppose you want to change the color that File Manager uses to display folders. Follow these steps:

1. Select the entry default-dir in the Binder base window scrolling list. The footer message in the bottom right corner of the Binder indicates that this is a read-only entry.

2. Click SELECT on the Duplicate button to copy the entry to your user database. A new Binder entry is created called unnamed_1, with all the same Icon properties as the original default-dir Binder entry. You can modify this new user entry.

3. Rename the new Binder entry default-dir. This will put an entry called default-dir in your personal user Binder database. This personal entry will override the System or Network entry of the same name.

**Note** – If you later create a second user entry called default-dir, only the entry created first will be recognized.

4. Change the background color to the new desired color. You can either type in new RGB (red/green/blue) values in the Backgr Color text field, or click SELECT on the Backgr Color window button to display the Color Chooser. See the sections “Backgr (Background) Color” on page 450 and “Using the Color Chooser Palette with Binder” on page 464 for more information.

5. Click SELECT on the Apply button. This updates the Icon name and color in the new Binder entry.

6. Click SELECT on the Save button. This updates your database to include the new Binder entry.

Now when you view the merged Binder databases (the All option of the View menu), your user entry will replace the System or Network entry of the same name. If you want to use the System or Network entry again,
simply delete the User entry. The next time you start a new File Manager application, the color specified in your new user Entry will be used to display folders.

**Using the Color Chooser Palette with Binder**

You can use the Color Chooser with the Binder to specify foreground and background colors for the icons displayed by the File Manager or other DeskSet applications.

To use the Color Chooser to select Foreground or Background icon colors, click SELECT on the Foregr Color or Backgr Color menu button. (These are the buttons to the right of the text fields.) The Color Chooser is then displayed, as shown in Figure 16-15.

![Color Chooser for Binder’s Foreground Color](image)

The icon image with the current Foreground and Background colors is displayed in the upper left corner of the palette shown in Figure 16-15 above.

To use a color displayed in the Color Chooser palette:

1. **Click SELECT on the desired color in the Color Chooser palette.**
   The selected color is highlighted and displayed in the Color Chooser preview area. The preview area is the large square at the left of the palette.

2. **Click SELECT on the Apply button to record the color change.**
Customizing the Solaris Environment

You can customize many aspects of the Workspace environment to suit your needs. For instance, you can use the Workspace Properties window to change the colors of the Workspace and windows, and modify the location of the window scrollbars and how the mouse buttons and pointer behave. This chapter discusses these and other methods of customizing your OpenWindows environment.

Viewing Information About Your Workstation

As things change within your operating environment, or if changes are made to your system, you may be asked for certain basic information about your system. This information can also be helpful to a system administrator if you are having system problems.

Some basic information about your workstation can be found on the Workstation Information window, shown in Figure 17-1.

♦ To open the Workspace Information window, choose Workspace ➤ Workstation Info.
Figure 17-1  Workstation Information Window

Basic information available to you from the Workstation Information window is as follows:

Your Workstation Information

The following information tells you the name and type of workstation you have or are using.

Workstation Name

This is also known as the machine name or host name. It is the unique name you or your system administrator gave to the machine you are using. This is usually not the same name as your user name or login name. This is the machine name that other users see over the network, such as from electronic mail.

Workstation Type

This is usually the product name (or type) for your workstation. It may reflect the model number of the workstation.
Networking Information

These three items provide some networking information.

HostID
A unique CPU number assigned to your machine. This is sometimes used for licensing software.

Internet Address
Your unique machine address that allows other machines to talk to your machine over the network.

Network Domain
Name of the (NIS) domain to which your machine belongs. Contains password information and other network machine addresses.

System Memory Information

These three items provide some simple information on how the system is using memory.

Physical Memory (RAM)
This tells you how much Random Access Memory (RAM) is installed.

Virtual Memory (Swap)
The amount of swap space on the hard disk.

Virtual Memory In Use
If the number on the slide bar gets close to 100%, contact a System Administrator for adjustment.
Solaris Information

These two items tell you version and release numbers with the Solaris 2.4 release.

Operating System

The version and release number of the operating system your workstation is running.

Window System

The name and version number of the window system that your workstation is running.

Using the Workspace Properties Window

Here is an overview of the Workspace Properties window categories. They are discussed in detail in this chapter. Depending on the hardware capabilities of your display, the Workspace Properties window categories may have different choices available to you.

- **Color** allows you to change the foreground and background color of windows, data areas, and the Workspace.
- **Font** allows you to choose the style and scale (size) of text in window titles, menus, buttons, and other system elements.
- **Keyboard** allows you to turn on or off the clicking of keys, repetition of a character when its key remains pressed, and keyboard equivalents of mouse actions.
- **Mouse** allows you to control mouse behavior in relation to pointer speed, movement, and placement; multiple click intervals; and button order for right- and left-handed users.
- **Menu** allows you to specify how quickly a submenu is displayed based on how far the mouse is dragged to the right. Some menu characteristics are determined by mouse actions. You can also choose whether to display the menu when you click SELECT on a menu button or to carry out the default command without displaying the menu.
• Programs menu allows you to rearrange items on the Programs menu (displayed by choosing Programs from the Workspace menu). You can also add and delete items.

• Miscellaneous category has several settings:
  • Screen saver protects your screen life when the computer is not in use. You can turn it on or off, and set the timeout.
  • Beeping alerts you to various conditions. You can turn it on or off, or turn it on for notices only.
  • Set Active window selection allows you to activate a window either by moving the pointer into the window or by clicking in the desired window. Only one window can be active at a time.
  • Icon and scrollbar allow you to choose where to place icons and scrollbars.
  • Locale allows you to select settings appropriate for your language and cultural notation.

All of these items can be set through the Workspace Properties window.

1. To open the Workspace Properties window, choose Workspace ➤ Properties.

Depending on the hardware capabilities of your display, the Workspace Properties window categories may have different choices available to you. You choose the category you want to change from the Category menu.

2. To view the Category menu, position the pointer on the Category menu button and press MENU.

Figure 17-2 shows the Category menu.
Figure 17-2  Category Menu

Change Bars

As you change settings, a vertical change bar is displayed to the left of the setting you have altered since the last time changes were implemented. This visual cue helps you track your changes.

Workspace Properties Window Buttons

The Workspace Properties window has three buttons:

- *Reset to Standard* displays (but does not implement) the system default settings—that is, the settings determined by your system administrator. Change bars mark your previously-applied nonstandard settings.
- *Reset* ignores any changes and immediately reverts to previously-applied settings.
• Apply implements changes. Most changes take place immediately, while others do not take place until you open a new application or restart the OpenWindows software.

**Note** – To change settings in more than one category, be sure to select Apply before continuing to the next category. Unlike previous versions, this version of OpenWindows software treats changes to each category separately.

### Setting Colors

Depending on the hardware capabilities of your display, the Workspace Properties window categories may have different choices available to you. When you open the Workspace Properties window, color appears as the first property you can customize. Figure 17-3 shows the Color category in the Workspace Properties window.

![Workspace Color Category](image)

*Figure 17-3  Workspace Color Category*
To modify colors:

1. **Click SELECT on the button for the item you want to change.**
   Each button (Windows Foreground, Windows Background, Data Areas Foreground, and so on) has a corresponding pop-up window that displays a color palette for that item. Figure 17-3 shows a color palette. (Note that for the purpose of this document, the color choices have been replaced with patterns.)

2. **Point to a new color on the palette and click SELECT.**
   The preview area at the bottom of the Workspace Properties window, as shown in Figure 17-4, shows a sample of your color choices.

3. **If you are not satisfied with the new color, select another color from the palette, or create a custom color.**
   To create a custom color:
   
   a. **Click SELECT on Custom on the palette.**
      The palette is replaced with sliders for Hue, Saturation, and Brightness, as shown in Figure 17-5. (Note that for the purpose of this document, the color choices have been replaced with patterns.)
b. Move the sliders as you watch the preview area.
   The sliders let you control three characteristics:
   • Hue is a color from a range of colors—red, orange, yellow, green, blue,
     indigo, violet and magenta.
   • Saturation is the deepness, or richness, of a color.
   • Brightness is the amount of light that is filtered into a color.

4. To change additional foreground or background colors, repeat the
   previous three steps.
   A palette for each foreground and background color is pinned to the
   Workspace.

5. When the colors suit you, click SELECT on Apply.
   The changes occur immediately on the Workspace, in the Workspace menu,
   and in the window frames of any applications open on the Workspace.
   Depending on your system configuration, application control areas in open
   windows use the previous color until you quit and restart the application(s).
Customizing Fonts

OpenWindows DeskSet applications are set up with default fonts that appear on all items, such as icons, menus, and windows. Normally, you do not need to customize the style or point size of these fonts. However, if you would like to increase or decrease the size of the default, or if you are partial to a particular font, it is possible to change the default font style and size for the system font from the Fonts category.

The following sections on fonts describe two methods of customizing fonts: a basic method of changing the *scale* of the font (which also affects the window scale), and a method of changing the *font style*. The first method simply increases or decreases the font size (to small, large, or extra large) and its window size, while the second provides greater flexibility in defining the style.

Choosing a Font Scale

The scale allows you to choose from four font sizes for windows. You can change the default so that all applications subsequently open in the size you specify. Note that when you scale the font, the window scales with it.

You can choose from these four sizes:

- small
- medium (the default)
- large
- extra large

**Note** – Not all fonts styles and sizes appear on the screen satisfactorily. If the size is too large, some items, such as menu buttons, may be obscured.

Specifying the Font Style

Default fonts include:

- Windows: Lucida Sans in 12 point (medium)
- Window headers: Lucida Sans Bold
- Text subwindows: Lucida Sans Typewriter

If you prefer, you can specify another font style and size.
To select a different typeface:

1. **Select a typeface from the scrolling list.**
   A sample of the typeface is displayed in the preview area. If you are not satisfied, select another typeface.

2. **Click SELECT on Apply.**

**Listing the Available Fonts**

When the Standard selection is chosen, you can scroll through all of the typefaces installed with OPEN LOOK style, the Custom Selection refers to all fonts available on your system.

*Note* – The list generated from xlsfonts is very long; there are over 400 fonts available. If the listing on your screen does not contain the expected number of fonts, check with your system administrator. It is possible that a subset of the available fonts was installed.

**Previewing Selected Font Settings**

You can look at the selected typeface and scale settings in the Preview box. This shows you how text appears in:

- **Control settings**—places like buttons and text fields (scrolling lists) in your window system.
- **Control labels**—places like captions.
- **Data areas**—places like text in the Text Editor window.

**Keyboard Menu Equivalents**

You can turn on or turn off the keyboard accelerator keys. This means that the keyboard character of the acceleration shows up in the following:

- **Application + Window** — means in all applications that use them and in Open Windows menus
- **Application Only** — means only OPEN LOOK applications that use them
- **None** — means will not show up in any OPEN LOOK application
This is a standard set of tasks (within a DeskSet application) that can be “accelerated” from the keyboard by using keyboard shortcuts. These will be visible from the pull-down menus, and can be configured on or off from the Workspace Properties menu. Keyboard accelerators are active for only the windows that are active. If you need to turn these off, you can select None from Keyboard Menu Equivalents from the Keyboard Properties. The following table outlines the keyboard shortcuts and their functions.

Note – The Meta key is the <> key on SPARC keyboards; on x86 and PowerPC keyboards Meta is obtained by pressing Ctrl-Alt.

Table Legend

The following table uses these abbreviations:

• FM = File Manager
• CM = Calendar Manager
• MT = Mail Tool
• TE = Text Editor
• SS = Snapshot
• IE = Icon Editor
• B = Binder
• PT = Print Tool
• IT = Image Tool
• AT = Audio Tool
• X = Accelerated Menu Item
• = no relevant menu item
• btn = relevant item is a button (no accelerator)
• Meta = use the Meta key (<> or Ctrl-Alt) on your keyboard
• Accel = Keys to press in this order to invoke the accelerator

<table>
<thead>
<tr>
<th>Accel</th>
<th>FM</th>
<th>CM</th>
<th>MT</th>
<th>TE</th>
<th>SS</th>
<th>IE</th>
<th>B</th>
<th>PT</th>
<th>IT</th>
<th>AT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Meta - c</td>
<td>X</td>
<td>-</td>
<td>X</td>
<td>X</td>
<td>-</td>
<td>X</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Cut</td>
<td>Meta - x</td>
<td>X</td>
<td>-</td>
<td>X</td>
<td>X</td>
<td>-</td>
<td>X</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Find</td>
<td>Meta - f</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>New</td>
<td>Meta - n</td>
<td>X</td>
<td>-</td>
<td>X</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Open</td>
<td>Meta - o</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>btn</td>
<td>X</td>
<td>-</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
Other Keyboard Options

Other keyboard options you can control are:

- **Key Click** sounds a click with each depression of a key.
- **Key Repeat** means when a key is depressed and held, the key will type multiple characters until released. With this setting turned on, a single character is typed, when it is off, multiple characters are displayed.

Modified Use of the Keyboard and Mouse

This section lists accelerator key commands that you can substitute for mouse and menu operations. Accelerator keys help you use the interface efficiently by performing operations that normally require several mouse actions. This is especially useful to those who prefer the use of the keyboard over the use of the mouse, but can be helpful to anyone who wants to increase efficiency through fewer hand movements away from the keyboard.

Keyboard Accelerators

The following sections describe basic editing operations, navigating your way through files and windows, and opening menus without using the mouse buttons.
For a list of commands, such as Cut and Paste, and their keyboard equivalents, see Chapter 1, “Introduction to the Solaris User Environment.” For instructions on remapping a SPARC or x86 keyboard, see the Solaris Advanced User’s Guide.

Note – The commands for navigating in text files pertain to the Text Editor application window.

### Erase Functions

**Table 17-2** Commands that Erase Characters, Words, or Lines

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backspace</td>
<td>Erases character to the left of the insert point</td>
</tr>
<tr>
<td>Shift-Backspace</td>
<td>Erases character to the right of the insert point</td>
</tr>
<tr>
<td>Control-w</td>
<td>Erases word to the left of the insert point</td>
</tr>
<tr>
<td>Control-Shift-w</td>
<td>Erases word to the right of the insert point</td>
</tr>
<tr>
<td>Control-u</td>
<td>Erases to the beginning of the line</td>
</tr>
<tr>
<td>Control-Shift-u</td>
<td>Erases to the end of the line</td>
</tr>
</tbody>
</table>

### Move Caret Functions

**Table 17-3** Commands that Move the Caret Within Text

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control-b or Left Arrow</td>
<td>Moves the caret one character to the left</td>
</tr>
<tr>
<td>Control-f or Right Arrow</td>
<td>Moves the caret one character to the right</td>
</tr>
<tr>
<td>Control-Shift-b</td>
<td>Moves the caret one word to the right</td>
</tr>
<tr>
<td>Control-</td>
<td>Moves the caret one word to the left</td>
</tr>
<tr>
<td>Control-.</td>
<td>Moves the caret to the end of the word</td>
</tr>
<tr>
<td>Control-a</td>
<td>Moves the caret to the start of line</td>
</tr>
<tr>
<td>Control-e</td>
<td>Moves the caret to the end of the line</td>
</tr>
<tr>
<td>Control-p or Up Arrow</td>
<td>Moves the caret up one line, maintaining column position</td>
</tr>
<tr>
<td>Control-n or Down Arrow</td>
<td>Moves the caret down one line, maintaining column position</td>
</tr>
</tbody>
</table>
Control-Return, End: Moves the caret to the end of text
Control-Shift-Return or Home: Moves the caret to the beginning of text
Page Up: Moves caret up one pane
Page Down: Moves caret down one pane

**Keyboard Mouse Equivalents**

The following keyboard accelerators require that you use mouseless mode. You can set this from the Properties menu:

1. **Select either Basic or All Functions from the Keyboard Mouse Equivalent.**
2. **Press SELECT on Apply.**

**Global Navigation Functions**

*Table 17-4 Commands for Navigating About the Workspace*

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt-w</td>
<td>Moves focus to the next window within the current application</td>
</tr>
<tr>
<td>Shift-Alt-w</td>
<td>Moves focus to the previous window within the current application</td>
</tr>
<tr>
<td>Alt-n</td>
<td>Moves focus to the next application</td>
</tr>
<tr>
<td>Shift-Alt-n</td>
<td>Moves focus to the previous application</td>
</tr>
<tr>
<td>Shift-Alt-m</td>
<td>Displays Workspace menu</td>
</tr>
</tbody>
</table>

**Local Navigation Commands**

*Table 17-5 Commands that Manipulate Base Windows or Pop-Up Windows*

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt-m</td>
<td>Displays window menu</td>
</tr>
<tr>
<td>Alt-F5</td>
<td>Moves window to back</td>
</tr>
<tr>
<td>Alt-F6</td>
<td>Enables you to move window with arrow keys</td>
</tr>
<tr>
<td>Alt-F7</td>
<td>Enables you to resize window with arrow keys</td>
</tr>
<tr>
<td>Alt-F8</td>
<td>Refreshes window</td>
</tr>
</tbody>
</table>
Table 17-6 Commands that Manipulate Base Windows Only

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt-F2</td>
<td>Opens the icon at the pointer location or closes the window at the pointer location</td>
</tr>
<tr>
<td>Alt-F3</td>
<td>Resizes window to full size or reduces it to default size</td>
</tr>
<tr>
<td>Alt-F9</td>
<td>Quits application</td>
</tr>
</tbody>
</table>

Table 17-7 Commands that Manipulate Pop-Up Window Menus

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt-F2</td>
<td>Dismisses or cancels pop-up menu</td>
</tr>
<tr>
<td>Alt-F10</td>
<td>Indicates owner of pop-up menu</td>
</tr>
</tbody>
</table>

**Mouse**

You may want to change the way your mouse behaves within the Workspace.

![Mouse Properties](image)

Figure 17-6  Mouse Properties
You can change the following settings from the Mouse Properties:

- **Mouse Acceleration** is the speed at which the mouse moves.
- **Mouse Threshold** defines how far (measured in pixels) does the mouse move before acceleration begins.
- **Multi-Click Interval** specifies the time, in tenths of a second, that differentiates a double-click from two single clicks.
- **Mouse Button Order** changes the order of the mouse button functions.
- **Pointer Jumping** defines a specific way in which the pointer can move in relation to scrolling a window or a pop-up menu.

### Multi-Click Interval

Use the Multi-click Interval setting to specify how many tenths of a second can elapse between successive clicks on a mouse button before the first click is ignored. This affects how quickly you must double-click the SELECT button, for instance, when you want to open an application window from an icon.

To set the multi-click interval, drag the slider with the pointer. After you make your changes in the mouse settings window, click SELECT on the Apply button to store the new settings.

Depending upon your system configuration, changes to the Scrollbar Pointer Jumping and Pop-up Pointer Jumping options do not take place in existing application windows, but in those that you open from the Workspace menu after the change was applied. The Multi-Click Interval option takes effect immediately in all applications.

### Mouse Button Order

The default positions of the buttons on both the two and three button mouse are labeled from left to right. Often left-handed user prefers to reconfigure the buttons so they are more suited for left-handed use. Figure 17-7 shows the default functions of the buttons for both mice.
Figure 17-7  Default Functions of the Mouse Buttons for Right-hand Use

Figure 17-8 shows the functions of the mouse buttons after changing the order for left-handed use. Now when the right mouse button is pressed, SELECT is activated, and when the left button is pressed, MENU is activated.

Figure 17-8  Functions of the Mouse Buttons for Left-hand Use

After you have made these changes in the mouse settings window, click SELECT on the Apply button to store the new settings.

Mouse Pointer Jumping

The Mouse Property contains Pointer Jumping controls for scrollbars and pop-up windows. Each of these defines a specific way in which the pointer can move in relation to scrolling in a window or a pop-up menu.
Customizing Scrollbar Pointer Jumping

Use the Pointer Jumping Scrollbar check box to specify whether or not you want the pointer to move along with the scrollbar elevator during scrolling actions. When the box is checked, as in Figure 17-6 on page 480, pointer jumping is enabled.

When the box is not checked, pointer jumping is disabled, and the pointer remains in a fixed position as the scrollbar elevator moves. Note that if you position the pointer above or below the elevator and click SELECT several times, the elevator catches up with the pointer, and you must move the pointer to continue scrolling in the same direction.

Customizing Pop-up Pointer Jumping

Use the Pointer Jumping Pop-up check box to specify whether or not you want the pointer to jump into a pop-up window automatically when it comes up.

If this setting is checked, when a pop-up window with a notice is displayed, the pointer jumps to the default button (that is, your anticipated choice). For example, when you choose Exit from the Workspace menu, a notice asks your to confirm that you want to leave the window system. The notice has two buttons: Exit and Cancel. The pointer jumps to Cancel when the notice window is displayed. (The pointer “jumps” so quickly that you see no movement.) In Figure 17-6 on page 480, this option is on.

When the box is not checked, the pointer does not jump to the default button in the pop-up window but remains where it was when the pop-up window appeared. Move the pointer onto the appropriate button and click SELECT.

To turn off the pop-up pointer jumping, click SELECT on the check mark. The check mark disappears and the option is turned off.
Menu

Setting the Drag-Right Distance of Menus

The “drag-right distance” is the distance that you must move the pointer to the right before a menu is displayed. This distance is measured on the screen in pixels, or “picture elements,” whose number corresponds to the resolution of the monitor. To modify the drag-right distance, follow these steps:

1. In the Workspace Properties window, press MENU on the Category menu button and choose Menus.
   Figure 17-9 shows the Menus category defaults.

2. Move the slider to the desired distance.
   The distance from the left of the slider is the actual drag-right distance that will take effect on your screen.

3. Click SELECT on Apply to make the change take effect.
Customizing Menu Operation

Use the Menus category of the Workspace Properties window to change how you operate menus. It determines whether the default menu item is chosen automatically when you click SELECT on a menu button or the menu is presented for you to make a choice. In previous versions of the Deskset, the default behavior was equivalent to the Selects Default Item setting. This meant that the default menu item is automatically chosen when you click SELECT on the menu.

The alternate choice, Displays Menu, sets the SELECT button just to display the menu. You then need to click the SELECT button again to choose a menu item.

Programs Menu

You can add items to your Programs menu, remove items, or change their order. Follow these steps:

1. SELECT an item in the list that is adjacent to desired location of the new item.
   This highlights the approximate location of the new item.
2. Type a name for the item in the Label: field.
3. Type the full path name to the command or program to be executed in the Command: field.
4. SELECT Paste Before or Paste After.
   - Paste Before places the new item above the highlighted item.
   - Paste After places the new item below the highlighted item.
   - If no item is highlighted, the new item is added at the top or bottom of the list.
5. SELECT Apply.
   The new label for the command is now displayed in the list.

The button functionality is as follows:

- Change allows you to change the command or label to associate with label shown.
- Add allows you to add new label/command.
• **Cut/Copy** allows you to cut or copy an item.
• **Paste Before/Paste After** allows you to paste a label/command before or after a selected label.
• **Delete** allows you to delete label/command.
• **Make Default** allows you to make currently selected item the default item on the Programs menu.

### Miscellaneous

The following Workspace items can be customized from Miscellaneous:

• Screensaver on/off
• Screensaver timeout
• When to beep
• Beep duration
• Focus policy
• Icon location
• Scrollbar placement

To customize these settings, choose the Miscellaneous category from the Workspace Properties menu. Figure 17-10 shows the Miscellaneous category.
**Setting the Screensaver Feature**

The *screensaver* feature makes the screen go blank after a period of no use. This option is turned off by default, but you can enable it.

To turn on the screensaver:

1. Press SELECT on Auto.
2. Type the number of minutes before it is enabled. The default is five minutes.
3. Press SELECT on Apply.

   Your changes now apply.

**Returning to the Desktop**

If you have set the screensaver option and your screen turns blank, you can restore your desktop by moving the mouse in any direction. Although input from any keyboard key or mouse button will restore your screen, it is advised...
that you move the mouse instead. This is because pressing a key creates system input. This means, as an example, that if the pointer is positioned in a text file, you may insert a character in the text.

### Setting the System Beep

Use the Beep setting to specify whether your system beeps for all application-generated beep actions (errors, messages in your Console, and so on), only when a notice is displayed, or never. Figure 17-10 on page 487 shows the beep settings. To customize the system beeps, click SELECT on the chosen beep setting in the Miscellaneous category of the Workspace Properties.

You can move the slider from Beep Duration to increase the length of time the system beeps.

### Setting the Active Window

Use the Set Active Window setting to specify whether you must click SELECT on the window to change input focus, or whether you simply move the pointer into the window to specify that window as the active input area. The active input area is where you enter text, whether in a text pane of a base window or a text field of a window control area. The two choices, Click Mouse and Move Pointer, are also called Click-to-Type and Focus-Follow-Pointer. In Figure 17-10 on page 487, the Click Mouse choice is selected.

The default is Click Mouse. The Click Mouse option requires that when you move the pointer from one window to another, you must click SELECT before you can type any text into the window.

If you choose the Move Pointer option, you don’t need to click in the window to make it active and ready for input. The presence of the pointer within the boundaries of the window tells the current window that now it is the focus of the user’s attention.

To change the setting, click SELECT on the setting you prefer.

### Setting the Default Locations for Icons

You can change the default location where icons appear in the Workspace when they are closed from windows. The OpenWindows default location for icons is on the bottom edge of the Workspace.
To change the default locations of icons:

1. **In the Workspace Properties window, press MENU on the Category menu button and choose Miscellaneous.**

2. **Click Select on the appropriate button.**
   You can specify any of the four edges of the Workspace as the default location for icons.

3. **Click SELECT on Apply.**
   Changes to the Icons setting take effect immediately. That is, icons for applications that are on the Workspace or are subsequently opened are located in the newly specified location. Icons for applications started from the command line with an explicit icon location appear in the specified location.

**Changing Scrollbar Placement**

Use the Scrollbar Placement setting to specify whether scrollbars are displayed at the right or the left side of the pane. This setting applies to all scrollable application windows on the Workspace. In Figure 17-10 on page 487 the default option, Right, is selected.

To set the location of the scrollbars on the left side, click SELECT on the Left button.

**Note** – Scrollbar changes do not affect applications that are already on the Workspace.

After you make your choices for system beep, input area, and scrollbar placement, click SELECT on Apply to store the changes. Changes made to the Miscellaneous category take place immediately after you apply them.

**Locale**

The Locale category of the Workspace Properties window provides users with a mechanism for specifying an input language and display language, as well as time, date, and numeric formats for a specific locale. Figure 17-11 shows the Locale category in the Workspace Properties window.
Figure 17-11 Locale Category in the Workspace Properties Window

If your system has a Solaris localization installed, such as Japanese Solaris, German Solaris, or French Solaris, you have access to locales in addition to the basic U.S.A. locale. If you do not have a Solaris localization installed, U.S.A. (English) is the only available locale. The following is a description of each of the choices in the Properties window:

- **Basic Locale**: is the name of the country or native language of the user interface. Specific setting choices vary depending on the basic locale setting.
- **Display Locale**: specifies the language in which messages, menu labels, button labels, help files, and so forth are displayed.
- **Input Locale**: specifies the language to be input.
- **Time Format**: specifies the format for the time and date.
- **Numeric Format**: defines the numeric format or placement of the comma or decimal point.

**Note** – For systems that allow locale specifications, changes apply when you start a new application. The changes do not affect applications already running.
In addition to the applications under Programs, the Workspace menu has several important utilities. This chapter discusses each of the utilities in the order they appear in the menu.

♦ To use a utility, choose Workspace ➤ Utilities and select a submenu.

Note – Solaris supports both SPARC and x86 or PowerPC-based machines, whose keyboards differ. Consequently, some keyboard equivalents of commands found in OpenWindows menus differ, according to keyboard.

For most keyboard equivalents, Solaris supports a Meta key combination that can be used on both platforms. See Chapter 1, “Introduction to the Solaris User Environment” for a list of command functions and their various keyboard equivalents.

Refresh

Sometimes an application prints characters outside of a particular window, or leaves artifacts—lines or other remnants from the window—when it is cleared from the Workspace. This is sometimes called “window damage.” To clear these artifacts, you refresh the Workspace. This causes the entire screen, and all your applications and icons to be repainted.

♦ To refresh the Workspace, choose Workspace ➤ Utilities ➤ Refresh. After a few moments, the artifacts are cleared from the Workspace.
SPARC Reset Input

If you are running several types of applications at once (particularly if you are using SunView applications simultaneously with OpenWindows applications), you may occasionally find that characters you type in a window are garbled. This is because of an inherent incompatibility between the way the applications handle the keyboard.

♦ The Reset Input utility corrects the problem. If the problem occurs, choose Workspace ➤ Utilities ➤ Reset Input.

Note – This function applies only to SPARC-based machines.

Function Keys

This utility was implemented in compliance with OPEN LOOK functional specifications, and is provided for use by application developers and for users to program their function keys. It is not supported by the default DeskSet applications at this time.

The OpenWindows Function Keys utility is a dynamic on-screen version of the function keys on the keyboard. (Note that this feature is currently supported on Type-4 keyboards only.) The function keys on the on-screen utility display the functions of the current application, providing that application has function keys support. Otherwise the keys are blank. The key labels are automatically updated when the pointer is moved to another application.

Because the Function Keys panel is equivalent to the function keys on your keyboard, you can choose items from the on-screen function keys (by clicking SELECT on the appropriate key) or from the keyboard itself.

♦ To display the Function Keys utility window, choose Workspace ➤ Utilities ➤ Function Keys.
   When you release the mouse button, the Function Keys pop-up window is displayed at the bottom of the screen.

Note – You must have the Click Select (or “click-to-type”) option set for the Function Keys utility to work properly. See Chapter 17, “Customizing the Solaris Environment,” for information regarding this option.
Figure 18-1 shows the Function Keys window. In this example, the function keys have been programmed to modify colors on the workspace.

**International Keyboard Support**

A range of international keyboards are available through the Function Keys utility’s multiple language support feature. This feature displays an on-screen keyboard with keys that correspond to those on the physical keyboard. When you display one of the international keyboards through a DeskSet or other XView application, the keys you type on your physical keyboard remap to the international characters, and those characters appear in the text region of the XView application window.

To display the keyboard of your choice:

1. **Choose Workspace ➤ Utilities ➤ Function Keys.**
2. Pin the Function Keys window to the workspace.
3. Click SELECT in an XView application window, such as a Command Tool, in which you would like to use a set of international characters.
4. Press the Language key on your keyboard, and continue to press it until instructed to release it.
   This key is labeled PrSc, or Print Screen.

   Each of the function keys labels displays one of the international languages that the virtual keyboard supports, as shown in Figure 18-2.
5. Click SELECT on More to cycle through the available character sets.

6. Click SELECT on the button for the language you would like to use.

7. Click SELECT on the Show button.
   The virtual keyboard for that language appears on the workspace. The French keyboard is shown in Figure 18-3.

![Figure 18-3 French Virtual Keyboard](image)

8. Pin the keyboard window.

9. Click SELECT on the Set button in the Function Keys window.

10. Release the language button.

11. Begin typing in the XView application window from which you opened the keyboard.
    The characters you type appear in the chosen character set.

**Switching Between Virtual Keyboards**

You can access a few characters or symbols from another language or alternate character sets interactively, and then return to typing with your usual character set. For example, you might want to type a few Greek characters inside a document that is in English. To change to a different character set and back again:

1. Open the document and enter the text in your local language.

2. When you want to switch languages, press and hold the Language key.
   This key is labeled R2 or Print Screen.
3. In the Function Keys window, click SELECT on the button for the language to which you want to change temporarily. Continue to press the Language key.

4. Type in the characters you want to add. These characters appear in the document in the language you have chosen.

5. Release the Language key. Anything you type now appears in your local language.

**Window Controls**

The Window Controls menu items cover basic window operations, such as opening, closing, and resizing windows behind other windows. This utility is especially useful for performing operations on multiple windows or icons simultaneously.

♦ To open Window Controls, choose Workspace ➤ Utilities ➤ Window Controls.

Figure 18-4 shows the Window Controls utility.

Since Window Controls is a submenu. To make use of this utility, it is usually best pinning the workspace.
Using Window Controls

The items in the Window Controls submenu correspond to items in the base Window menu that you pull down from the header of an application window. Any choice you make in the Window Controls submenu—such as Quit—affects the currently selected window or windows.

The following examples illustrate the use of window controls on a group of selected windows or icons. To select multiple windows, either click SELECT on one window and ADJUST on additional windows (or icons), or position the pointer on the workspace near the applications you want to group, press SELECT, and drag the pointer diagonally across the workspace to create a rectangle around the series of windows. Any windows or icons completely inside the rectangle formed by the dragging motion are included in the group.

Opening a Group of Applications from Icons

To open a number of applications at once, select the group of icons (using one of the methods described above) and then choose Open/Close from the Window Controls menu. Similarly, you can close a group of applications to their icon form without having to close each one individually.

Resizing a Group of Applications or Icons

To increase the size of several applications on the workspace, select the group of windows and choose Full/Restore Size from the Window Controls submenu. This operation increases the size of the selected application windows to the full height of the screen.

Choosing Full/Restore Size in the Window Controls submenu a second time (without deselecting any of the windows) decreases the size of each of the windows in the group to its former size.

Moving a Group of Applications to the Back

Selecting a group of windows quickly and moving them behind another window. To do this, select the group you want to move to the back and choose Back from the Window Controls submenu.
Quit a Group of Windows

You can quit a number of applications at once by selecting the group of windows or icons and choosing Quit from the Window Controls submenu.

Save Workspace

When you have applications you want to display on the workspace on a regular basis, you may want to save the workspace layout. This means applications will display when you exit the Solaris environment and enter again. You can save the workspace as often as you like—whenever you develop a new arrangement.

To save the Workspace, first arrange your icons and windows in the locations you want them to remain, and close any windows that you want to be closed to icons whenever you start the OpenWindows software. Now choose Workspace ➤ Utilities ➤ Save Workspace.

In a few moments, a notice informs you that the Workspace layout has been saved. You must click SELECT on the OK button to continue.

Lock Screen

The Lock Screen utility covers the Workspace and the objects in it with a moving pattern. This provides a certain amount of security for your system when you are away from your desk. Additionally, it prevents the electron beam inside the monitor from burning an image into the internal phosphorescent coating. This can happen if the beam is allowed to fire at one location for an extended period of time. For information on setting the screensaver feature refer to Chapter 17, “Customizing the Solaris Environment.”

When your screen is locked, the OpenWindows software continues running even though the workspace cannot be viewed. Applications that were running continue running, and any processes currently underway continue. When you unlock your screen, the workspace is exactly as it was when you locked it.

♦ To engage the Lock Screen utility, choose Workspace ➤ Utilities ➤ Lock Screen.
In a moment, a moving pattern appears on a black background over the workspace. To unlock your screen again, press any key on your keyboard, or any button on your mouse. Type your password and press Return to display the workspace.

**Console**

The Console is the small window that normally appears in the upper left corner of the workspace when you start up the OpenWindows software. Its primary use is to display messages from your system and server. You can only have one Console running, and you should keep it open at all times for important messages. Figure 18-5 shows the Console window.

![Console Window](image)

*Figure 18-5 Console Window*

- **If you do not have a Console, you can open one by choosing Workspace ➤ Utilities ➤ Console.**
  
  When the Console appears, resize it so that it is just large enough to print about four or five message lines, and move it to one corner of your screen.

You can scroll up and down through the messages that appear in your Console by placing the pointer on one of the scrollbar arrows (up or down) and clicking SELECT.
Using the AnswerBook Software

The AnswerBook Navigator and Viewer are a pair of windows for browsing, searching, bookmarking, and printing on-line document collections, also known as an AnswerBook.

To start the AnswerBook Navigator to see AnswerBook products that may be available to you:

♦ Choose Workspace ➤ Programs ➤ AnswerBook.

Note – AnswerBooks are available to you if your system or site administrator has installed them and configured them for your use.

The Contents of Your On-Line Library

When the AnswerBook Navigator opens, it displays the contents of your on-line Library. Your on-line Library may contain the Solaris 2.5 User AnswerBook, a collection of basic manuals to help get you started using your Sun system. Your library may also contain more than one AnswerBook, provided that:

• Your system/site administrator has installed them and configured them for your use, and
• You or your administrator has included them in your Library (see “Modifying Your Library” on page 519).
AnswerBook Navigator and Viewer

Together the AnswerBook Navigator and Viewer give you access to your Library. You locate what you want to read in the Navigator, and then read it in the Viewer, where it appears page for page as it would in a printed book.

Figure 19-1 Documentation in the Navigator and Viewer
The AnswerBook Navigator acts as a kind of remote control for the Viewer. Using the controls in the Navigator, you locate the information you want and display it in the Viewer.

The Navigator provides three ways of finding on-line information:

- In Contents mode you can select an AnswerBook, and then browse through it, opening and closing books, chapters, and sections, as needed.
- In Search mode you can enter a search phrase describing what you’re looking for, and the Navigator displays a list of documents found, ranked by relevance.
- In Bookmarks mode, you can go directly to pages where you previously created electronic bookmarks and edit them.

![Figure 19-2  AnswerBook Navigator in Contents Mode](image-url)

The three Navigator modes

- Contents
- Search
- Bookmarks

Click SELECT on a mode to change the functioning of the window.
Use the AnswerBook Navigator window to:

- Search for topics of interest
- Modify your Library (by adding or removing an available AnswerBook)
- Select and open an AnswerBook
- Select topics for display in the Viewer
- Browse through tables of contents
- Leave bookmarks and comments on pages within a Library

Figure 19-3  AnswerBook Navigator Functions
Use the AnswerBook Viewer to read the documents you select in the Navigator and to print them. You can read pages sequentially or follow hypertext cross-reference links from topic to topic.

![Figure 19-4 AnswerBook Viewer Functions](image)

In this example, the output from the `date` command is redirected to a new file called `sample.file`. Next, the contents of `sample.file` are displayed with the `more` command:

```
$ more sample.file
Mon Feb 3 13:56:28 1995
```

As you can see, the contents of `sample.file` now contain the output from the `date` command. (See Chapter 3, "Working with Files and Directories," for information on the `more` command.)

Sometimes you may want to redirect the output of one command as input to another command. A set of commands string together in this fashion is called a **pipeline**. The symbol for this type of redirection is a vertical bar (|) called a **pipe**.

For example, instead of saving the output of a command to a file, you may want to direct it as input to the command for printing (`lp`) by using the pipe symbol (|) to send the output from the `date` command directly to the printer. You would enter the following:

```
$ date | lp
```

This would print the results of the `date` command. (See "Submitting Print Requests to the Default Printer" in Chapter 6, "Using Printers," for information on using the `lp` command to print files.)

The command redirection examples shown here are quite simple, but when you learn more advanced commands, you will find that there are many uses for piping and redirection.

---

**Figure 19-4  AnswerBook Viewer Functions**
Closing or Quitting the AnswerBook Navigator and Viewer

You can close the Navigator and Viewer windows separately. The closed Navigator and Viewer windows are represented by the icons in Figure 19-5.

![Navigator and Viewer Icons](image)

Figure 19-5  AnswerBook Navigator and Viewer Icons

Close each window by choosing Close from its window menu or by pressing the Open key on your keyboard (which toggles Open/Close).

You can quit each window, or its icon, by choosing Quit from its window menu. When you quit the Navigator, you quit both the Navigator and the Viewer; quitting the Viewer quits only the Viewer.

You can also use the keyboard equivalents that apply to all DeskSet applications to close or quit the Navigator and Viewer. For more information, see Chapter 17, “Customizing the Solaris Environment.”

Finding and Displaying a Document

The default mode in the AnswerBook Navigator is Contents. In Contents mode, the Navigator has two panes: Location and Contents. Initially, the Location pane lists your Library, and the lower Contents pane lists the AnswerBook sets in the Library.

Opening an AnswerBook

To see more of the contents of an AnswerBook:

♦ In the lower Contents pane, double-click SELECT on a bold AnswerBook title.

The title expands to show more contents.
Double-click SELECT to open (expand) the book’s contents

Expanded book contents appear here

Figure 19-6  Opening (Expanding) a Title in the Navigator
Navigating Through Sets and Books in an AnswerBook

With the AnswerBook contents expanded, you can browse its sets and books. Some books appear in more than one set.

To expand any boldface listing, double-click SELECT on it. When you do so, the listing expands to show more of its contents.

![Figure 19-7 Expanding the Contents of a Book in the AnswerBook Navigator]

With each expansion, the Contents list grows to reflect deeper levels of the documentation—sets, books, chapters, and headings. For example, if you double-click on a set title, the title moves up into the Location pane, and the list of books contained in that set is displayed in the Contents pane below.

When you double-click SELECT on any listing at or below the book level, the first page of that topic or document opens in the AnswerBook Viewer.
To display entries that have scrolled out of sight, use the scrollbar or Scrolling List menu (displayed by pressing MENU) in either pane to locate it, as shown in Figure 19-8.

Figure 19-8  Scrolling in the Location or Contents Pane

**Viewing a Book**

In the AnswerBook Viewer, you can turn the pages of a book, chapter, or section almost as if you were reading a printed book. You can also follow hypertext cross-reference links between sections, chapters, and books.

**Turning Pages**

To turn pages, click SELECT on the page-turning buttons at the top of the AnswerBook Viewer, or click SELECT on the Go Back button to retrace your steps successively, page by page. See Figure 19-4.

**Keyboard Shortcuts**

You can use keyboard shortcuts for the paging commands.

- **PgUp** works like the previous-page button.
- **PgDn** works like the next-page button.
- **Undo** works like the Go Back button.
- **Home** displays the first page of the chapter you’re in. If you’re already at the first page of a chapter, Home displays the first page of the previous chapter.
- **End** displays the first page of the next chapter.

**Checking Your Location in the AnswerBook**

Choose Page Info from the View button menu in the Viewer to look up the origin of the page currently on display. The Page Info window, shown in Figure 19-9, is displayed.
Following Hypertext Cross-Reference Links

Hypertext cross-reference links appear as text boxed with a thin outline.

For information about booting or halting a workstation over a network, see System and Network Administration.

You can follow hypertext cross-reference links within or between books. The quickest way to follow a cross-reference link is to double-click SELECT on the boxed link. Or, you can click SELECT on the hypertext link, then press MENU on the View button and choose Follow Link, as shown in Figure 19-11.
Note – If, when you attempt to follow a link, you see the message, “Can’t follow hypertext link” at the bottom of the Viewer window, probably the link points to a document that is not in any of the currently selected AnswerBooks in the Library. See “Modifying Your Library” on page 519.

**Searching with the Navigator**

In Search mode, the Navigator can match your requests by searching through the text and titles of all documents you have included in your Library. You can enter search phrases in your own words, and enhance your searches (see “Advanced Search Techniques” on page 513).
To change to Search mode, click SELECT on the Search setting in the control area.

To search for a topic of interest:

1. **Begin a search by typing a search phrase**—a word, phrase, or sentence—in the pane marked “Search Library For.”
   Type any text up to 1024 characters including spaces and punctuation. Edit the search phrase as you would in any text window.

2. **To start the search, press Return at the end of the search phrase.**
   Or, you can click SELECT on the Start Search button.
When the search is complete, relevant topics are listed in the Documents Found pane. The topics are coded with squares, starting with black (most relevant) to white (least relevant), with shades of gray in between.

Figure 19-13 shows the result of a search. Each item points to a location in the Library where a document that matches your request was found.

To see a topic found in the search:

3. Double-click SELECT on an item in the Documents Found pane. That page is then displayed in the Viewer.

Scroll the list in the Documents Found pane of the Navigator to see more items in the list.
Reusing and Changing Search Phrases

Your search phrases dating from the last time you started the Navigator are saved so you can reuse them. You can reuse a search phrase as is, or you can edit it before starting a new search. Click SELECT on the Previous Searches button. The Previous Searches window is displayed.

![Figure 19-14 Previous Searches Window](image1)

Your search phrases are listed with the most recent at bottom. You can copy and paste a phrase from the Previous Searches window into the Search For pane. Press Return or click SELECT on the Start Search button.

Customizing Searches

To change search settings, click SELECT on the Search Settings button. In the Search Settings window you can specify various options to control the results of your searches.

![Figure 19-15 Search Settings Window](image2)
Search Library by: Text and Titles searches all text included in your Library, while Titles Only searches only book and chapter titles, and section and subsection headings.

Sort Findings by: Relevance Only simply lists all documents found in order of relevance, regardless of the books they appear in. Relevance and Book means the documents found will be listed grouped by book, with topics within a given book listed by relevance.

Limit Findings to: Click SELECT to increase or decrease the default number of 30 findings per search.

Click SELECT on Apply to preserve your settings, or click SELECT on Reset to undo your choices and restore the previous ones.

Advanced Search Techniques

To make your searches more precise and more productive, you can:

• Restrict (modify) the contents of your Library to constrain the scope of the search.
• Choose the search setting “Titles Only” to search through book, chapter, and section titles rather than searching through the full text of documents.
• Use special characters to mark your search phrases for literal, suffix-expansion, and “nearness” matching.

Scoping the Search by Modifying the Library Contents

By adding or removing an AnswerBook from your Library, you can widen or narrow the scope of your search. See “Modifying Your Library” on page 519.

Titles Only Searches

The Titles Only option restricts searches to book titles and chapter and section headings. This search method is useful if you already know terms used in the titles or headings of documents you are looking for.
Using Special Characters in Search Phrases

By adding special characters—quotation marks, parentheses, and asterisks—to your search phrases, you can make searching more precise. You can combine the characters to further refine your search.

Quotation Marks: Searching for Literal Phrases

Place the search phrase between double quotation marks to find documents that contain that literal phrase. For example, the search phrase “reading mail” finds documents containing that phrase. On the other hand, if you type reading mail, you will find documents containing one or both words.

Parentheses: Searching for Words in Proximity

Place words between parentheses to find documents with those words in proximity to each other. For example, the search phrase (reading mail) will find all documents that have “reading” and “mail” within a few lines of each other, in either order.

Asterisks and Hyphens: Searching for Variations on a Word

Place an asterisk at the end of a word to match all possible endings of the word. For example, the search phrase chang* will expand to “change,” “changed,” “changes,” “changing,” and so on.

If you do not know whether a term is one word, two words, or hyphenated in the documentation, you can insert the hyphen to look for all three forms. For example, to search for “mail tool,” “mailtool,” and “mail-tool,” type mail-tool in the Search For pane.

Connecting Punctuation

Words connected by punctuation other than a hyphen are treated character for character as literal phrases, for example: /usr/local/bin, win_client_data, and in.rlogind.
Combining Advanced Search Techniques

You can combine any or all of the above search techniques to further refine your search. For example:

“chang* mail-tool” finds documents containing literal phrases such as “change mailtool,” “change mail tool,” “change mail tool,” “change mail-tool,” “changing mailtool,” “changing mail tool,” “changing mail-tool,” and so on.

“display button” viewer searches for “display button” and “viewer” in proximity to each other.

Using Bookmarks Mode

Placing bookmarks helps you relocate pages of interest quickly. You can also use bookmarks to annotate a page with your comments. Note that bookmarks do not appear on the marked pages. When you put the Navigator in Bookmarks mode, you’ll see a list of all the bookmarks you’ve created to date.

You can create a bookmark in any Navigator mode, but you must change the Navigator to Bookmarks mode if you want to read, edit, or delete bookmarks or print or display bookmarked pages. See “Viewing and Editing Your Bookmarks” on page 516.

Creating a New Bookmark

To create a new bookmark for the page currently displayed in the Viewer, click SELECT on the New Bookmark button at the top of the Navigator.

![New Bookmark Window](Figure 19-16 New Bookmark Window)
In the New Bookmark window, the text at the top specifies the current page. You can edit the text in the “Bookmark for” field, which is used in the Existing Bookmarks list when the Navigator is in Bookmarks mode. You can also type an annotation in the Comment pane.

Click SELECT on the Create button to create the new bookmark. Or, if you decide not to create a bookmark, dismiss the New Bookmark window.

**Viewing and Editing Your Bookmarks**

To see your list of bookmarks, click SELECT on Bookmarks.

*Figure 19-17 AnswerBook Navigator in Bookmarks Mode*
The Bookmarks list shows the Bookmark titles listed under the associated AnswerBook. To see the comment for a particular bookmark, select (highlight) it in the Bookmarks list.

**Editing a Bookmark**

You can edit a bookmark directly in the Bookmarks list. When you’re done, save the bookmark changes.

**Deleting a Bookmark**

To delete a bookmark, select it and then click on the Delete Bookmark button. The Navigator asks for your confirmation before deleting. Note that you cannot undelete a deleted bookmark.

**Accessing a Bookmarked Page**

Bookmarks serve as links to pages you’ve marked in the AnswerBook Viewer. Double-click SELECT on a bookmark to display the bookmarked page.
Figure 19-18 Using a Bookmark to Go to a Page in the Viewer
Modifying Your Library

You can add AnswerBooks to your Library, provided they have been installed and configured for your use. You can also remove AnswerBooks from your Library to constrain browsing and searching.

*Note* – The *System Administration Guide, Volume I* provides information for system administrators on how to make an AnswerBook available to users.

1. Click SELECT on the Modify Library button at the top of the Navigator.

![Modify Library button](image)

*Figure 19-19 Modifying the Contents of Your Library*

The AnswerBook browser opens and displays a list of available AnswerBook products.
2. Click SELECT on each AnswerBook you want to add.
   A check mark appears next to each title you select. To deselect (uncheck) an AnswerBook, click SELECT on it again. If an AnswerBook title is not checked, it means it is not included in your Library.

When you’re ready, save your selections.

3. Click on Apply.
   This updates the Library to include each newly selected AnswerBook.

Any AnswerBook you add to the Library will be included in the Navigator Contents listing and in your searches.

Note – If you deselect AnswerBooks to constrain searching, don’t forget to reselect those AnswerBooks for future browsing.

Customizing the Viewer

The View button menu provides two options for setting the display magnification of the Viewer page. Press MENU on the View button to see these menu options: Standard Magnification and Custom Magnification.
**Magnifying the Viewer**

Standard Magnification is the magnification determined by the publisher of the documents—that is, the default. You can set other magnification values by choosing Custom Magnification. This opens the Custom Magnification window.

![Custom Magnification Window](image)

**Figure 19-21 Custom Magnification Window**

1. **Drag the slider to the desired value.**
   Press SELECT on the slider control as you move it. The amount of magnification is specified in the Magnification Percentage field.

2. **Click SELECT on Apply.**
   This puts the new page magnification into effect.

   Clicking SELECT on Reset reverts to the previous setting. Single clicks on the left or right of the slider cause one-percent increments up or down the scale.

**Printing**

Use the Print button in the Viewer when you want to print books, chapters, sections, subsections, or single pages.

In the Print window that is displayed, you can choose printing options (Figure 19-22). The default printing option is Current Viewer Page, which prints just the page you see in the Viewer.
Figure 19-22 Print Window

Choose the item you want to print

Scroll up or down to set the number of copies (between 1 and 10)

Choose a printer

Print a printer or create a PostScript file

The number of copies multiplied by the number of pages in the document

Choose print order to suit your printer

Start printing

Print Choices:

- Desktop Reference
- AudioTool

Copies: 1

Total Pages to Print: 16

Destination: Printer

Printer: pubs

Print Order: First Page First, Last Page First

Print
Solaris Troubleshooting

This appendix provides help with some of the problems you may experience when using Solaris. It is recommended that you read this entire appendix for information on these problems. The troubleshooting sections in this appendix are listed by DeskSet, OpenWindows and Workspace Properties categories and are in alphabetical order within each category for ease of reference.

Some of the information in this troubleshooting section requires a basic understanding of the UNIX operating system. If you do not understand how to diagnose or correct problems related to the UNIX operating system, see your system administrator or someone who is familiar with UNIX for assistance.

DeskSet Troubleshooting

This section provides information about tools in the DeskSet.

Binder Troubleshooting

You can only run one Binder at a time because your user database locks while the Binder is running. If you cannot start up the Binder, and you receive a message in your console telling you that you do not have permission to write to your user database, it’s probably because you have another Binder currently running.

If a File Type entry that you think is associated with a Binder entry is not showing up, it’s probably because the Binder read in a duplicate of that File Type entry before it read the Binder entry in question. When there are...
duplicate File Type entries, the Binder only uses the first one it reads. The first File Type entry that the Binder reads does not necessarily correspond to the first Binder entry in the base window scrolling list. Therefore, you should use caution when using the Copy button to copy a File Type entry. If a File Type entry does not show up for a particular Binder entry, try to find and delete the duplicate File Type entry.

Calculator Troubleshooting

If the Calculator detects an error, such as division by zero, the word Error is displayed. The Calculator must then be cleared with the Clr key before any further calculations can take place.

Calendar Manager Troubleshooting

This section describes basic Calendar Manager troubleshooting.

RPC Problems and Calendar Manager Installation

The Calendar Manager consists of two parts:

- A database manager, called rpc.cmsd (Calendar Manager service), that maintains the information for the Calendar Manager
- The Calendar Manager application itself, called cm

The Calendar Manager application cannot function without the Calendar Manager service.

If your Calendar Manager does not display appointments, or if you get RPC timeout messages in the console window, rpc.cmsd may not be running. To check your configuration, use these steps:

1. **Open a Command Tool or Shell Tool.**
   See Chapter 6, “Command Tool, Shell Tool, and Console Window” for information about the Command and Shell Tools.

2. **At the system prompt type** `ps -e | grep rpc.cmsd` **and press Return.**
   This asks for a listing of all processes containing the string rpc.cmsd.
3. Look at the listing displayed in the window.
   Figure A-1 shows a listing that contains the Calendar Manager service process. You can ignore the entry `grep rpc.cmsd` in your ps listing.

   ![](ps_listing.png)

   `Figure A-1   A ps Listing Showing the rpc.cmsd Process`

   If you do not have an `rpc.cmsd` process running, follow these steps:

   **Note** – If you have a Calendar Manager application running, quit the Calendar Manager by choosing Quit from the Window menu.

1. Become root.
2. At the system prompt, type `vi /etc/inetd.CONF`
3. Look for the entry: `Rpc.cmsd`
   Make sure the pathname specified is correct and that an `Rpc.cmsd` entry exists in the specified pathname. If not, change the path to point to where the `Rpc.cmsd` exists. Then view the pid of `inetd` by typing:
   ```
   ps -e | grep inetd
   ```
   Then reread the `inetd.CONF` file by typing:
   ```
   kill -1 inetd-pid
   ```
4. Restart Calendar Manager.
5. To make sure that the Calendar Manager Service is now running, type `ps -e | grep rpc.cmsd` and press Return.

   **Upgrading SunOS and Calendar Manager**

   If you are upgrading the SunOS, you need to back up the following directory, to preserve the information there:

   `/var/spool/calendar`
Use whatever backup medium is available to you, and restore the directory when the operating system upgrade is complete.

**Missing Calendar Data or NO NAME in Header**

If your appointments are not displayed, make sure you have run the installation script, as necessary. See “RPC Problems and Calendar Manager Installation” on page 524 for information. Before trying the following procedure, try restarting Calendar Manager first.

If your appointments are still not displayed, and you see the string NO NAME in your Calendar Manager header, the permissions are probably wrong for the /usr/spool/calendar directory and files. Make sure they are exactly as described in the following steps.

1. **Type** `ls -lsa /usr/spool`, and check the permissions for the directory /usr/spool/calendar.
   The permissions need to be exactly: `drwxrwsrwt`. This should be owned by daemon in the daemon group. (Get help from your system administrator to change the permissions, if necessary.)

2. **To check the permissions of your calendar database, type:**
   `ls -lsa /usr/spool/calendar/callog.<username>.
   Substitute your user name in place of <username>. For example, type `ls -lsa /usr/spool/calendar/callog.egret`. The permissions need to be exactly: `-r--rw----`. Also, this file needs to be owned by the user and in the daemon group.

**Remote Access Problems**

There are two basic symptoms of remote Calendar Manager access problems:

- You try to browse a remote calendar where you think you have Browse access, and all you can see are appointment times.

- You try to insert, delete, or change an appointment on a remote calendar where you think you have access, and Calendar Manager gives you an Access Denied... error message in the footer of the Appointment Editor.

There are three things you can check to try to fix these access problems:
1. If you are using the NIS or DNS system, which uses the concept of mail domains, make sure you are trying to browse a calendar in your domain or that you have specified the domain in your browse list. For example, if you are trying to browse the calendar of user Rob in your domain, you can simply specify Rob@host. If you are in a domain called Eng, and Rob is in a domain called Corp, you need to specify rob@host.Corp in your browse list.

2. Make sure that the owner of the remote calendar has really given you Browse, Insert, and/or Delete access. In order for the access to occur, make sure both of these conditions are met:
   a. Names in the access list must take the form user@host or just user. (Note that if the name in the access list is just user, access is given to anyone on your network with that user name.) If you are using the NIS or DNS system, make sure your name in the access list is not listed in the form user@domain or user@name.domain.
   b. The owner of the calendar must remember to click SELECT on the Apply button on the Access List and Permissions Properties window. Check the user ID and group ID on both your workstation and the remote workstation. The user ID and group ID must be the same in both locations.

3. Determine your user ID and group ID on each workstation as follows:
   a. Look for your password entry in the file /etc passwd. If you have an entry in this file, the user ID is the third field (the number between the second and third colons). The group ID is the fourth field (the number between the third and fourth colons). For example, if the entry for user Egret in the /etc/passwd file is:

      egret:X4y8r2Bg:3286:10:& West:/home/egret/:/bin/csh

   the user ID for user Egret is 3286, and the group ID is 10. The values of the user ID and group ID should be between 0 and 32767.
b. If you are using the NIS system, and you do not have an entry in the file /etc/passwd and the last line of /etc/passwd starts with a ‘+’, check for an entry in the NIS passwd entries. To determine your NIS user entry, type ypmatch username passwd in a Command Tool or Shell Tool. For example, to find the NIS password entry for user Egret, type:

ypmatch egret passwd

If the system responds with a user entry, the user ID is the third field, and the group ID is the fourth field.

Adding a Second Calendar on your Workstation

If you’d like to add a second calendar on your workstation, you need to create a dummy user for that calendar. For example, you might want to add a second calendar for appointments for your entire work group.

To create the dummy user and new calendar, use the following steps. These steps assume a basic understanding of UNIX system administration, so you may need to get some assistance. This assumes you are root.

1. Add a dummy entry in the /etc/passwd file of the workstation where you want to create the second calendar. You need to specify a name, a dummy user ID, and so forth.

2. Bring down the cm and rpc.cmsd processes.

3. Log in as the new dummy user, and start a new Calendar Manager.

4. Edit the access list and permissions for your group.

5. Add the calendar name to the browse list.

6. Log out, and log back in with your own login. You can now browse the new calendar.

Sharing Calendars Across Workstations

If you move around from workstation to workstation, and you want to always be able to access your real Calendar, you need to have Calendar Manager running on each workstation. Use the following steps to set up access to your calendar from multiple workstations:
1. On your primary workstation, give full access list permissions to your calendars at the remote workstations.
   For example, suppose user Egret has his real calendar on the workstation named “work”, and also accounts and calendars on remote workstations named “sea” and “ocean”. He would add egret@sea and egret@ocean to his calendar access list, and give these users full Browse, Insert, and Delete permissions. See the section Chapter 5, “Calendar Manager”, for instructions.

2. When you are logged in at the remote workstations, browse your real calendar.
   Since you have full access permissions, you can read all your appointments, change your appointments, and so forth.

   In the previous example, when Egret is logged in to “sea” or “ocean” he can browse the calendar egret@work to access his real calendar.

Note – Do not mount the /usr/spool/calendar directory from a remote disk. Doing so may result in loss of Calendar data.

Running Different Versions of OpenWindows and Calendar Manager

If you run an older version of OpenWindows after running the current version of OpenWindows, the older version of Calendar Manager will not be able to read your appointment data file. To avoid this problem, back up the following file before starting the current version of Calendar Manager:

/usr/spool/calendar/callog.<user>

Before you return to an older version of Calendar Manager, restore your old file making sure you maintain the permissions on the directory and file. If you browse a calendar that is running a different version from your own, it should work.
Clock Troubleshooting

Displaying seconds for the clock may have a negative effect on system performance.

If your Workspace color is black, your clock is invisible when it is an icon on the Workspace. See the man page for clock to learn how to have the clock icon painted with the Window Background color instead of the Workspace color.

Drag and Drop Troubleshooting

The section describes some of the error messages you may get while attempting a drag and drop from one deskset application to another.

Drag and Drop: Timed Out

This can occur if the server is unable to connect with the receiving application within a certain time. The default timeout value for an XView application is three seconds.

You can change this value by adding a line to your ~/.Xdefaults file. If you wanted to change this to five seconds, add the line:

```
Selection.Timeout 5
```

to ~/.Xdefaults file and then type xrdb ~/.Xdefaults from a command line to setup the server with the new timeout value.

Drag and Drop: Illegal Target

The receiving application does not support drag and drop operations.

This message may also appear if the receiving application’s drag and drop targets are not responding to the sender. If this is the case, restarting the receiving application may clear up the problem.

Drag and Drop: Root Window

The dragged object was dropped onto the root window. Normally, this is considered an error by the sending application, though File Manager assumes in this case that the item is to be opened.
Drag and Drop: Failed
An unknown, internal error occurred while trying to establish a drag and drop connection.

DND: Bad Time
An unknown, internal error occurred while trying to establish a drag and drop connection. Try the drag and drop operation again.

File Manager Troubleshooting
This section describes the solutions to common File Manager questions and problems.

Cannot Format a Floppy Using the File Manager Format Option
If you try to format a floppy using Format from the File Manager File menu and it does not work, your system may not be set up to run the format program. Contact your system administrator for assistance.

Custom Icons Not Displayed
If you think you changed a file’s icon with the Binder, but you do not see the change in the File Manager, make sure that you restarted the File Manager after you saved the Binder changes. If you have already restarted the File Manager, recheck your changes with the Binder. Make sure the entry you changed was saved to your user database with the Binder Save button. Also, make sure the file displayed really falls into the class of files changed with the Binder.

If your File Manager displays only the three generic types of icons (folders, applications, and documents), the File Manager was unable to connect with the Binder database. Check your Console window for error messages indicating where the problem occurred.
Deleting Floppy and CD Windows

If you delete a window for a floppy disk or CD, you can bring it back by selecting them from the Go To menu button. They are always displayed within the application specific section of the Go To menu. For information on using the Go To menu refer to Chapter 2, “File Manager.”

Drag and Drop Problems

If you use File Manager to drag and drop a file to another application, but you get the error message drag and drop: illegal target in the File Manager footer, the file was dropped in a place that does not recognize the file type or that does not support drop operations.

File Manager Does Not Display Some or All of Your Files

If files you expect to see in the file pane are not being displayed, make sure you have not specified a view filter pattern from the File Manager Properties window which can suppress the display of those files. When a filter is specified, it is always displayed in the header of the File Manager window. To clear this up try selecting View ➤ Icon by Name.

Remote File Copy Problems

If you have trouble transferring files between remote systems, you may not have the correct permissions to access the file, directory, or system, or the remote system may not be accessible through the network. Contact the person who owns the files (or the person who asked you to transfer the files) to change permissions so the transfer will work. To find out if the remote system is available on your network, contact your system administrator.

View By Content Takes Too Much Time

When the File Manager is viewing files by content, it needs to read and compress the first screen of files so they can be displayed. For Sun icons, X Bitmap, and X Pixmap files, this should work fairly quickly. However, compressing large Sun raster images can take some time. Therefore, if you only
need to look at icon files, be sure to only have Monochrome Icons and Color Icons set on the Properties: Current Folder or New Folder window for the Files to View setting.

**Image Tool Troubleshooting**

If you try to run Image Tool and you receive the following message:

```bash
ld.so.1: imagetool: can't find file libxil.so.1
Killed
```

You need to have the XIL packages installed. Contact your system administrator for assistance.

**Mail Tool Troubleshooting**

If you run multiple versions of mail programs, Mail Tool may become confused about the state of your In-Box. If Mail Tool takes a long time to open the In-Box, it’s possible that a Mail Tool lock file needs to be removed. If there is not enough disk space for the Save Changes operation, you will need to remove messages from the current mail file. This section describes how to recognize and correct these problems. In addition, it describes where you can find your Mail Tool In-Box and where you can find mail messages you were composing that were cleared or lost during a Mail Tool or window system crash.

**Running Multiple Versions of Mail**

If you run multiple versions of Mail Tool at the same time (or the Mail Tool application and the Mail program), you may receive notices from your Mail Tool application advising you to Save Changes or Quit one of the Mail Tool applications. This is because both versions try to modify your In-Box. Follow the instructions of the notices to avoid creating confusion about the state of your In-Box.

If you did not choose Done or Save Changes in the Mail Tool application before running another Mail Tool application or the Mail program, a notice instructs you to quit your Mail Tool application. If you did save your changes, you will be given a choice to either quit the Mail Tool application or Save Changes to keep it in its original state.

---

**Solaris Troubleshooting** 533
You can avoid having to quit your Mail Tool application by getting into the habit of choosing Done from the File menu at the end of each day, or when it is likely that you will be logging into your machine and reading mail from a remote location.

If you forget to choose Done, and you remotely log into your machine to read mail, you can tell Mail Tool to choose Done by following these steps:

1. From a Shell Tool prompt type `ps -e | grep mailtool` and press Return.
   The listing should look like the one shown in Figure A-2.

   ![Figure A-2](image)

2. Look in the left-hand column of the listing for mailtool (not the listing for `grep mailtool`) to find the process number (PID).
   The process number is the first number on each line.

3. Type `kill -USR1 PID` and press Return.
   In the example above, the process number is 1431, so you would type: 
   `kill -USR1 1431`

4. Read your mail as you usually do from the remote location.
   The next time you open your Mail Tool, the changes you make to your In-Box from the remote location are incorporated and recorded as part of the Mail Tool.

Caution – The steps above only work with the DeskSet Mail Tool application. Using these steps for other versions of Mail Tool kills Mail Tool.
Mail Tool Lock File

The Mail utility uses a lock file to prevent two or more processes from altering your mail spool file at the same time. If Mail Tool quits unexpectedly, the lock file may be left behind.

If Mail Tool takes a long time to open the In-Box, either when you specifically request it or when you open Mail Tool after you have chosen Done from the File menu, check for a lock file. Look in the directory /var/mail for a file named username.lock, where username is your login name.

To remove the file, from a system prompt type:

    rm /var/mail/username.lock

For example, if your username is “mary”, you would type:

    rm /var/mail/mary.lock

Alternatively, you can find the lock file in the File Manager, and drag it to the Wastebasket to delete it.

Mail Tool In-Box Location

The default location for the Mail Tool In-Box is /var/mail/username. If the environment variable $MAIL exists, Mail Tool uses its value as the In-Box location.

Recovering Messages Being Composed

If you are in the middle of composing a mail message when your Mail Tool application or your window system crashes, you can recover a copy of the message from the file dead.letter in your home directory minus the last 80 edits, that is the application keeps track of the number of edits and files saves every 80 edits. So the most edits lost would be the last 80.

Your message is also saved in the file dead.letter whenever you click SELECT on the Clear button in the Compose window or choose Clear message from the Compose window’s Deliver menu.

See the man page for mail for information about dead.letter and the save variable.
“Save Changes” Runs Out of Disk Space

If you try to save changes, by selecting Save Changes or Done from the File menu, or by switching mail folders, and Mail Tool warns that it has run out of disk space, you must remove messages from the current mail file to make it small enough to save.

You can remove messages by deleting or moving them. Removing larger messages helps the most. You can find the largest messages by choosing Size from the Sort By submenu of the View menu.

Files Too Large for the Mail Tool Attachment Window

Mail Tool may run out of swap space if you drag-and-drop a file that is too large into MailTool Attachment window. You can remedy this by increasing your swap space.

Print Tool Troubleshooting

If a file has an inappropriate print script in the binder database (this is not an ASCII file and the possible location is /usr/openwin/lib/cetables), the Print Tool may hang when you use it to print that file. The print script may be missing the $FILE, $PRINTER, or $COPIES variable. See Chapter 16, “Binder”, for information about how to change print scripts using the Binder.

If you print a file and the appropriate filter is not available on the printer, you will receive an error message.

SnapShot Troubleshooting

A potential problem with Snapshot is creating a raster file that has the wrong dimensions for use with another application. This is described in the following section.

Using Snapshot Files with Other Applications

If you experience difficulty in using Snapshot files with other applications, it may be because you are trying to incorporate a snapshot from a grayscale or color monitor into an application that can only handle black-and-white images.
Raster files have three dimensions: height, width, and depth. Black-and-white raster files are 1-bit deep. Grayscale and color raster files are usually 8-bits deep. True color raster files are 24-bits deep. If you take a snapshot on a 4-bit screen, it is saved as an 8-bit raster file.

You can see the depth of a raster file by typing `file rasterfilename` in a Shell Tool or Command Tool prompt, or by selecting the file from the File Manager and displaying the Information window. In the example shown in Figure A-3, the listing shows the file properties for all files ending in .rs. As you can see from the listing, there is one 8-bit raster file (snapshot.rs) and the rest are 1-bit files.

Figure A-3  Example of a File Command Listing

The best way to convert an image to the same depth as your monitor is to use Image Tool. You can take the snapshot, View it, and use Save as to select b&w as the number of colors. Refer to Chapter 13, “Image Tool.”

Tape Tool Troubleshooting

This section describes some common problems you may encounter with the Tape Tool, and it offers possible solutions.

Checksum Errors

If you receive a checksum error when reading files from a tar tape, there may be a mismatch between the block size on the tape and the block size you specify.
To correct the block size, choose Block I/O from the Tape Tool Properties window. In the text field that appears, type the correct block size (the one from the tape).

Files Not Written to Specified Directory

If you retrieve files from a tape and they are not copied to the destination directory you specify, list the contents of the tape to see if the file names are preceded by an absolute path name. When you retrieve files that have an absolute path name, that path is used as the destination directory.

Tape Drive Not Recognized

Tape device names are not automatically included in your system configuration unless a tape drive is hooked up at the time of installation.

If you add a tape driver after the initial system installation but did not reboot your system afterwards, you will get this error message. To reconfigure your system to include the new tape device name, shut down your system and reboot with the following flags:

**SPARC** At the ok prompt type:

```
boot -r
```

**x86** At the boot > prompt type:

```
b -r
```

**PowerPC** At the ok prompt type:

```
boot -r
```

The new tape drive will appear in `/dev/rmt`.  


OpenWindows Troubleshooting

You may occasionally receive an error message or encounter some of the following problems described here. This section offers some possible solutions to these described problems.

1. OpenWindows startup fails, and you receive this error message:

   /usr/openwin/bin/openwin command not found

If you receive this error message, you need to check to make certain that OPENWINHOME is properly set to point to the location in which the OpenWindows software was installed. Refer to Chapter 17, “Customizing the Solaris Environment,” in your installation manual for assistance in setting up your environment.

2. The OpenWindows software starts up but some or all of the applications are not available.

   If you experience this problem, you need to make certain that your path is set such that /usr/openwin/bin precedes the rest of your path entry.

core Files

Occasionally, you may find that a process or application fails, leaving a file named “core” in the directory from which you began the process. A core file can take up a lot of disk space, so it is a good idea to provide information to your system administrator regarding the failed program and the location of the core file for analysis, and, once it is analyzed, delete it.

If you are not certain what process or application failed, open a shell window, and do the following at your system prompt, substituting your directory name for core.directory:

   example% cd core.directory  (Change directory to the location of the core file.)
   example% file core

You will receive a message in that shell that tells you the origin of the core file. Provide this information to your system administrator.
Those with knowledge of the operating system software may want to analyze the core file on their own. Information regarding two basic debugging tools is available in the man pages for adb and dbx.

**Blank Screen**

If you have set the screensaver option (described in Chapter 17, “Customizing the Solaris Environment”) and your screen turns blank, you can restore your desktop by moving the mouse in any direction. Although input from any keyboard key or mouse button will restore your screen, it is advised that you move the mouse instead. This is because pressing a key creates system input which means, as an example, that if the pointer is positioned in a text file, you may insert a character in the text.

**SPARC Jumbled Text Characters**

If you are running applications of several different types (SunView and OpenWindows applications, for instance), the characters you type in a window may occasionally appear jumbled.

To solve this problem, place the pointer in the workspace background, and choose Workspace ➤ Utilities ➤ Reset Input.

*Note* – This section applies only to SPARC-based machines.

**Problems with .xinitrc**

If you have an .xinitrc file in your home directory and you are seeing problems with applications that rely on global OpenWindows resource settings, one method of troubleshooting is to rename the file to .xinitrc.orig and restart OpenWindows.

If this solves your problem, you need to either merge changes between the system version (located in /usr/openwin/lib/Xinitrc) and your .xinitrc or remove it if it is no longer needed.
Window Damage

According to other windows—sometimes remain on a window when overlapping windows are cleared away. This is known as window damage. To redraw the screen, choose Workspace ➤ Utilities ➤ Refresh. Momentarily, the artifacts will be cleared.

If the damage occurs to one application window only, you can refresh that application window by choosing Refresh from the pop-up menu in that window’s header.

Window Frozen when Opening an Application

If you opened an application from the command line in a Shell Tool or Command Tool window, as in the example below, you may find that your window freezes up.

example% cmdtool

The best way to open any DeskSet or other XView application on the command line is to append the command with the ampersand (&). For example:

example% cmdtool &

This starts the application “in the background” so that the parent window from which you started the application is free for further use.

Window Does Not Accept Input

If you position your pointer in a text window (such as in Text Editor or the Mail Tool Compose subwindow), and when you begin typing the text you type does not appear in the window, it is likely that the window is inactive, and you must click SELECT in the window to activate it.

Note that the insert point in a text window changes in appearance depending upon whether that window is active or inactive. If the insert point is active it looks like a triangle. If it is inactive, it looks like a dimmed diamond. Figure 19-23 shows an insert point that is active, and one that is inactive.
You can modify your Workspace Properties so that a window’s input area automatically becomes active when you move the pointer into it, enabling you to bypass the step of clicking SELECT in the window. This works for the base window—an application’s main window—but in some cases, such as the Mail Tool’s Compose subwindow, you always need to click SELECT in the window to activate it. See Chapter 17, “Customizing the Solaris Environment,” for more information.

**Workspace Properties Troubleshooting**

These are problems you can experience while using the Workspace Properties.

**Property Settings Are Not Preserved Across Sessions**

This is due to an obsolete .xinitrc file. For more information, refer to “Problems with .xinitrc” on page 540.

**Colors Settings Are Not Taking Effect**

If changes you made for the window foreground, data area foreground and background, then it might mean that XView doesn’t respond to these resources yet.

Try to set window.color.foreground and window.color.background in $HOME/.Xdefaults manually for XView applications.

**Message Regarding Colormap Usage**

From the Color Properties, if you receive a message about colormap usage and the program can’t continue, it might mean the colormap is full.

Try to exit the application(s) that make heavy use of colormap resources, restart the Properties and try again.
Fonts Extend Beyond Button Boundaries, Layouts Appear Misaligned

Some programs don’t properly handle all font scales.

Icon Backgrounds Don’t Match Workspace Pattern

XView applications control the icons, they don’t use bitmaps.

Color Category Missing

Color settings availability is dependant on hardware.

Accented Characters Do Not Appear in C Locale

The C locale does not support 8-bit characters (that is, G1 set or right-hand side of the ISO 8859-1 character set, such as characters with diaereses). Use the en_US locale to display 8-bit characters in the English language environment.

To empower the en_US locale you can pull down the Workspace Properties menu, under the category “Localization” select en_US.

Alternatively, if you are a Bourne Shell user you can add the following to your ~/.profile file:

```
LANG=en_US; export LANG
```

If you are a C-shell user you can add the following to your ~/.login file:

```
setenv LANG en_US
```
Many users with disabilities have trouble using the standard keyboard and mouse on computers. They may find it difficult or impossible to hold down two keys at once (to type capital letters or control characters), or to use a mouse, or type accurately.

AccessX is an extension to OpenWindows that makes it easier for people with disabilities to use a keyboard and to move a pointer around their screen. With AccessX running, you can:

• Keep the Control, Shift, Alt, and Meta keys pressed and active while you press another key, enabling you to type capital letters, Control-C, Alt-M, and so forth. (See “StickyKeys” on page 551.)

Note – Not all keyboards have all these keys. On some keyboards, for example, the Meta key is replaced by Control-Alt.

• Use the numeric keypad to emulate the mouse. You can move a pointer around the screen and perform mouse button actions (for instance, double-clicking), all from the keyboard. (See “MouseKeys” on page 552.)

• Make the computer beep when certain keys are activated or deactivated; people with limited vision can then tell whether, for example, the Caps Lock key is on. (See “ToggleKeys” on page 554.)

• Prevent a key from repeating if you have trouble releasing it quickly. (See “RepeatKeys” on page 555.)
• Prevent a key that you hit accidentally from inputting to the system. (See “SlowKeys” on page 556.)

• Make a key accept input as intended, even if you are unable to hold the key down steadily. (See “BounceKeys” on page 557.)

Starting AccessX

AccessX is an extension to OpenWindows.

To start OpenWindows with the AccessX extension, type

    openwin -accessx

This enables you to activate and deactivate AccessX features both with buttons in AccessX windows and with certain keystroke combinations. For example, you can turn StickyKeys on and off by pressing the Shift key five times.

Alternately, you can start OpenWindows without the -accessx option. You still have the full AccessX functionality; however, you can’t use the special keystroke sequences to turn features on or off. You must use buttons in AccessX windows instead.

The -accessx option does not affect the use of other OpenWindows options.

(If OpenWindows comes up automatically, from your . or .login file, you may want to add the -accessx option to the line that calls OpenWindows.)

AccessX Windows

If you’ve brought up OpenWindows, and no AccessX windows are already up on your screen, type accessx & in a command window.

If you’re running AccessX and want to have AccessX windows come up automatically when you start OpenWindows, choose Save Workspace from the Utilities submenu of the main (background) OpenWindows menu.
**The AccessX Main Window**

After you type `accessx &`, this window appears:

![Figure B-1 The AccessX Main Window](image)

**Displaying the Status of Buttons and Keys**

From the Status menu, you can display two windows that show the status of mouse buttons and certain keys. The StickyKey status window indicates if a key such as Control or Shift is pressed; the MouseKeys status window does the same for mouse buttons.

To open the Status menu, either use the MENU mouse button, or press the F10 key and the letter `s`. Use the arrow keys to move through the menu.
Note – If you’re using StickyKeys or MouseKeys, it’s a good idea to display the status window for that feature. Otherwise, you may encounter unexpected behavior that can be very confusing. In StickyKeys, for example, if the Control key is “locked” down, pressing the letter c sends a Control-C to the computer. The StickyKeys status window reminds you that Control is active.

Getting a Beep When a Feature is Turned On or Off

The main window has a check box labeled “Sound when features turned On/Off.” (See Figure B-1.) If you check this box, any time a feature such as StickyKeys or SlowKeys is activated or deactivated, the computer beeps.

Setting the Automatic Shutoff Timer

If you share your computer with someone who doesn’t use AccessX, you may want to have AccessX turn itself off automatically if the machine isn’t used for a certain period of time. That way, neither you nor the person who uses your machine after you has to remember to shut off AccessX.

To activate this timeout, check the “Off after time out (min)” check box. (See Figure B-1.) Move the associated slider to set the amount of time AccessX should wait without input before disabling itself. You can set this time to be anywhere from zero to six minutes.
Getting On-Line Help

AccessX has several help windows; choose the subject that interests you from the main window’s Help menu. To open this menu, either use the MENU mouse button, or press F10 and the letter h. Use the arrow keys to move through the menu.

![The Help Menu](accessx.png)

Figure B-3  The Help Menu

The Settings Window

Click the Settings button in the AccessX main window to display the Settings window. This window displays adjustable parameters for various AccessX features. These parameters are discussed in the section covering each individual feature.
### Figure B-4   The AccessX Settings Window

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>StickyKeys</td>
<td>Sound when modifier pressed</td>
</tr>
<tr>
<td></td>
<td>Turn off when two modifiers pressed at once</td>
</tr>
<tr>
<td>MouseKeys</td>
<td>Maximum pointer speed (pixels/sec) 610</td>
</tr>
<tr>
<td></td>
<td>&quot;Ramp-up&quot; time to maximum speed</td>
</tr>
<tr>
<td>RepeatKeys</td>
<td>Repeat delay (sec) 1.0</td>
</tr>
<tr>
<td></td>
<td>Repeat rate (keys/sec) 1.0</td>
</tr>
<tr>
<td>SlowKeys</td>
<td>Sound when key is pressed ☑ pressed ☑ accepted</td>
</tr>
<tr>
<td></td>
<td>Acceptance delay (sec) 1.0</td>
</tr>
<tr>
<td>BounceKeys</td>
<td>debounce time (sec) 0</td>
</tr>
<tr>
<td>Features Test Area</td>
<td>Try out features by typing here</td>
</tr>
<tr>
<td></td>
<td>Reset all settings to last-saved values</td>
</tr>
<tr>
<td></td>
<td>Save changes for this session</td>
</tr>
<tr>
<td></td>
<td>OK, Reset, Cancel, Help</td>
</tr>
</tbody>
</table>

- Beep when Shift, Alt, and so on, is latched or locked
- Disable StickyKeys by pressing two modifiers
- Time a key must be pressed before input starts
- How fast a key repeats
- Length of time a key must be pressed
- Try out features by typing here
- Cancel all changes
- Get help
**Individual Features**

**StickyKeys**

Many people with disabilities have trouble holding down two keys at once, making combinations like Control-D or Shift-Mouse-Click difficult. When StickyKeys is turned on, *modifier keys* (generally, Shift, Alt, Control, and Meta) stay active while you type another key or click a mouse button.

**Turning StickyKeys On and Off**

There are four ways to turn StickyKeys off:

- Check the StickyKeys check box in the AccessX main window.
- Press the Shift key five times in succession (valid only if you’ve started OpenWindows with the `-accessx` option).
- Press a modifier and any other key — for example, Shift-x or Control-Shift (valid only if you’ve started OpenWindows with the `-accessx` option).
- Press two modifier keys at once (see under “StickyKeys Settings”).

**Latching and Locking**

Sticky keys may be either *latched* or *locked*:

- You *latch* a modifier key by pressing it once.
  
  A latched key stays active until a non-modifier key is pressed. Suppose that, with StickyKeys on, you press the Control key. It will stay “pressed” while you press the l key, giving you Control-L. Once you press l, Control is “released.”

- You *lock* a modifier key by pressing it twice in succession.

  The key stays locked until you press it again. For example, suppose you want to enter

  \[ : \text{WR} \]

  In this case, you would press Shift twice to lock it. Then you’d press the colon key and the letters w and r. To unlock Shift, press it again.
You can bring up a Status window to see which keys are latched or locked. (See “Displaying the Status of Buttons and Keys” on page 547.)

**StickyKeys Settings**

**Getting a Beep Whenever a Modifier is Pressed**

You can have your computer beep every time you press a modifier key (with StickyKeys on). Since pressing these keys latches, locks, or releases them, a beep can be a useful reminder that you’ve enabled or disabled a modifier. (It’s easy to forget this in the course of normal typing.)

To enable this setting, check the “Sound when modifier pressed” check box in the Settings window. (See Figure B-4.)

**Turning StickyKeys Off by Pressing Two Modifiers at Once**

When you check this box (in the Settings window), you allow yourself to turn off StickyKeys by pressing two modifiers at once (such as Control and Shift). Some people find this easier than clicking with a mouse or pressing Shift five times.

**MouseKeys**

If you have trouble using a mouse, use MouseKeys to make the numeric keypad on your keyboard emulate mouse actions. You can move the pointer around your screen, as you would with a mouse, and click or press mouse buttons.

**Turning MouseKeys On and Off**

There are two ways to turn MouseKeys on and off:

- Check the MouseKeys check box on the AccessX main window
- Press the Alt, Shift, and Num Lock keys at once. (Valid only if you’ve started OpenWindows with the `-accessx` option.)
Keyboard Emulations of Mouse Actions

When MouseKeys is turned on, the keys on the numeric pad have three different kinds of functions:

- Keys 1-4 and 6-9 move the pointer around the screen.
- The 5, + (plus), 0 (zero) and . (decimal point) keys simulate mouse button clicks and presses.
- The /(slash), * (multiply), and - (minus) keys switch the keyboard mapping between various mouse buttons.

You can bring up a Status window to see which mouse keys are currently pressed.

Note: Your keyboard (and mouse) may differ.

Figure B-5  Mouse Button Equivalents for a Numeric Keypad
MouseKeys Settings

Changing the Maximum Speed of the Pointer
If you have trouble moving the pointer with the accuracy you want, you can slow it down. To change how fast the pointer moves, check the box marked “Max. pointer speed (pix/sec).” (See Figure B-4.) Adjust its slider bar to the speed that you want. The speed is in pixels/ per second, and can range from 10 up to 1000.1

Setting the “Ramp-Up” Speed for the Pointer
You can set how fast the pointer reaches its maximum speed (when MouseKeys is set). To do this, adjust the slider marked “Time to max speed” (see Figure B-4.) This way, you can be more deliberate in moving the pointer. You can set the mouse to take up to four seconds to reach full speed.

ToggleKeys

Many keyboards have indicator lights (LEDs) that light up when certain keys are active. An example of this is the Caps Lock key. When Caps Lock is pressed, its indicator light goes on.

For people with no or little eyesight, these indicator lights are of limited use. The ToggleKeys feature serves as the aural equivalent of such a light. When you make Num Lock, Caps Lock, or Scroll Lock active, the computer beeps once. When you deactivate the key, the computer beeps twice.

Turning ToggleKeys On and Off
Check the ToggleKeys check box in the AccessX main window to turn this feature on and off.

---

1. Limits on pointer speed apply only when MouseKeys is turned on.
RepeatKeys

Some users with limited motor abilities have a hard time taking their finger (or mouth stick) off keys quickly. As a result, for example, they sometimes type kkkkkkk when they mean to type k. With RepeatKeys on, a key must be held down for a certain length of time before it starts to repeat.

Turning RepeatKeys On and Off

There are two ways to turn RepeatKeys on and off:

• Check the RepeatKeys check box in the AccessX main window.
• Hold down the Shift key (either one) for eight seconds.

The computer beeps at four seconds to let you know that you’re turning this feature on or off. (Valid only if you’ve started OpenWindows with the -accessx option.)

Note – Holding down the Shift key for eight seconds also turns on SlowKeys.

RepeatKeys Settings

Delaying the Onset of Repetition

You can set the amount of time you want a key to be pressed before it begins repeating. This interval can be anywhere from a tenth of a second up to ten seconds. To set this parameter, move the “Delay until repeat” slider (see Figure B-4) to the number of seconds you want keys to wait before repeating.

Setting the Rate of Repeating

You can also set the repeat rate. The repeat rate represents how many times a pressed key will repeat per second. The rate ranges from 0.1 (that is, ten seconds per key) to 10 (that is, ten keys per second). The higher you set this value, the faster the key repeats. Set this to a low value to keep a pressed key from repeating, or from repeating too quickly.

Move the “Repeat rate” slider to the value you want. (See Figure B-4.)
**SlowKeys**

Users who have trouble typing often hit the wrong key, or keys, while trying to type. They may, for example, hit r while reaching to type t. When SlowKeys is turned on, only keys that are held down for a minimum, specified time will be accepted as input. Keys that are hit inadvertently will not register.

**Note** – Both SlowKeys and BounceKeys cannot be active at once.

**Turning SlowKeys On and Off**

Turn SlowKeys on and off in either of these ways:

- Check the SlowKeys check box on the AccessX main window
- Hold either Shift key down for at least eight seconds. The machine will beep at four seconds to let you know you’re turning this feature on or off. (Valid only if you’ve started OpenWindows with the `-accessx` option.)

**Note** – Holding down the Shift key for eight seconds also turns on RepeatKeys.

**SlowKeys Settings**

**Setting the Notification Style**

You may want to be notified of a key’s status while SlowKeys is active. That way you don’t have to guess whether you’ve held the key down long enough for it to be accepted.

There are two check boxes (“pressed” and “accepted”) in the Settings window for setting how you want to be notified of a key’s status when SlowKeys is in effect. By checking these boxes, you can have your machine beep:

- When a key is initially pressed
- When the key-press is accepted
- Both when the key is first pressed and when the key-press is accepted
- Not at all
Setting the Acceptance Delay

The acceptance delay is the interval between when you first press a key and when it transmits input. You can set this with the “Acceptance delay (sec)” slider located in the Settings window. (See Figure B-4.) This delay can range from zero to five seconds.

BounceKeys

BounceKeys aids people who have trouble holding down a key, or who tend to hit a key repeatedly when they mean to press it only once. BounceKeys sets the window system to ignore rapid, repeated pressings of a single key.

Note – Both SlowKeys and BounceKeys cannot be active at once.

Turning BounceKeys On and Off

To turn BounceKeys on and off, check the BounceKeys check box on the AccessX main window.

BounceKey Settings

Setting the Debounce Time

The Debounce Time is the interval that must pass before a second pressing of a key is accepted.

You can set this interval with the “Debounce time (sec)” slider. (See Figure B-4.) This delay can range from zero to five seconds.
Keystrokes for AccessX Features

Table B-1 shows the various AccessX features and their associated keystrokes. You must start OpenWindows with the -accessx option to use these keystrokes.

Table B-1  Features and Their Keystrokes

<table>
<thead>
<tr>
<th>Feature</th>
<th>Keystroke</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn StickyKeys on or off.</td>
<td>Press Shift five times.</td>
</tr>
<tr>
<td>Turn StickyKeys off.</td>
<td>Press any two modifiers (e.g., Shift and Alt) at once. Note: You must turn this ability on from the Settings menu.</td>
</tr>
<tr>
<td>Turn MouseKeys on or off.</td>
<td>Alt - Shift - Num Lock</td>
</tr>
<tr>
<td>Move the pointer (when MouseKeys is turned on).</td>
<td>1-4, 6-9 keys on the numeric keypad</td>
</tr>
<tr>
<td>MouseKeys</td>
<td></td>
</tr>
<tr>
<td>Click</td>
<td>5</td>
</tr>
<tr>
<td>Double-click</td>
<td>0</td>
</tr>
<tr>
<td>Press</td>
<td>.</td>
</tr>
<tr>
<td>Release</td>
<td>+</td>
</tr>
<tr>
<td>SELECT (mb1)</td>
<td>/</td>
</tr>
<tr>
<td>ADJUST (mb2)</td>
<td>*</td>
</tr>
<tr>
<td>MENU (mb3)</td>
<td>-</td>
</tr>
<tr>
<td>Turn RepeatKeys on or off.</td>
<td>Hold down Shift for eight seconds (beeps at four seconds)</td>
</tr>
<tr>
<td>Turn SlowKeys on or off.</td>
<td>Hold down Shift for eight seconds (beeps at four seconds)</td>
</tr>
</tbody>
</table>
Abbreviated menu button

A menu button that is displayed as a small square with a hollow triangle inside the border. The triangle points downward when the menu is displayed below the menu button, and to the right when the menu is displayed to the right. Abbreviated menu buttons function just like menu buttons.

ADJUST mouse button

The middle mouse button on a three-button mouse, which is used to adjust (extend or reduce) the selection. On a two-button mouse ADJUST is obtained by simultaneously pressing the SELECT mouse button and the Shift key on the keyboard.

Application

A tool, program, or window that provides the user with particular capabilities, such as sending electronic mail, printing files, or interacting with the operating system.

ASCII

American Standard Code for Information Interchange. A standard data transmission code used to achieve compatibility between data devices. ASCII text is plain text that contains no formatting information (such as font style, size, etc.).
Background

An underlying area on which objects, such as controls and windows, are displayed.

Base window

The primary window for an application.

Basic pointer

An arrow pointing northwest that shows the mouse position on the Workspace.

Border box

The outline of a window or icon that is displayed while you move windows and icons by dragging.

Bounding box

A rectangle displayed on the screen to define a region for selection.

Buffer

An area of memory used for the temporary storage of data as it is being transferred from one location to another.

Button

A one-choice element of a control area or a menu. Buttons are used to execute commands (command button), display pop-up windows (window button), and display menus (menu button).

Button menu

A menu that is displayed when the pointer is on a menu button and you press the MENU mouse button.
Cable

A cable on the scrollbar that represents the total size of the data you can view in the pane. The elevator moves up and down the cable to show the position of the view into the data.

Cable anchor

The button at each end of the scrollbar cable.

Calendar Manager

A DeskSet application supplied with the OpenWindows software package. The Calendar Manager enables you to schedule appointments and reminders for any future date and time.

Caret

A marker that indicates the insert point in windows that accept keyboard input. An active caret (ready for text input) is a solid triangle that may blink. An inactive caret is a dimmed diamond.

Change bars

Vertical lines on the left side of property window panes that show that a setting has been modified but not applied.

Check boxes

A nonexclusive setting that shows a check mark in a square box when the setting is chosen.

Click

To press a mouse button once and release it without moving the pointer.

Click-to-Type

Another term for the Click SELECT Input Area property (see Workspace Properties window) that requires you to click the SELECT mouse button in a window pane to activate that window’s input area. Contrast with Move Pointer, definition 2.
### Clipboard

A system buffer that provides the means for keeping track of data that is cut or copied. The Paste key is used to insert information from the clipboard into a pane. *See also Buffer.*

### Clock

1. The central timing device in a computer. 2. A DeskSet application (which can be opened from the Workspace Programs submenu) used to show local or international time.

### Color map

An index of colors, implemented by an application. When the application is opened, its color map is loaded into the hardware, and for each color used an index number tells the hardware what color to display.

### Command button

A button that is used to execute application commands (*see Button*).

### Command Tool

A window tool that provides a shell environment within a window that scrolls both forward and backward, with use of a scrollbar. *See Shell Tool.*

### Command window

A pop-up window that is used to execute application commands or set parameters.

### Completion message

A status message in the footer of a window.

### Console

The controlling terminal of a computer system that displays system messages.

### Control area

An unbordered region of a window where controls such as buttons, settings, and text fields are displayed.
Controls

Objects in a control area, a pane, or on a menu that are used to perform an action. Controls include buttons, items on menus, exclusive and nonexclusive settings, sliders, gauges, text fields, and check boxes. See also Dimmed controls.

Current item

An active item in a scrolling list.

Cut

To remove a selected object (or objects) from a window and store it on the clipboard.

Default

1. The specified choice in a menu that is activated if the user clicks SELECT on the menu instead of choosing an item with the MENU mouse button.
2. A choice or set of choices in a program, provided automatically if no other choices are specified by the user.

DeskSet

A default set of productivity applications supplied with the OpenWindows software package. File Manager, Calendar Manager, and Mail Tool are examples of DeskSet applications.

Dimmed controls

A control that is inactive. Its representation on a control area or menu is dimmed to show that it cannot accept input from the mouse or the keyboard.

Directory

A division or level in a hierarchical file storage system that contains files and, optionally, other directories.

Double-click

Pressing a mouse button twice rapidly as an accelerator that performs a specific function without using a menu.

Drag

To press and hold down any mouse button while moving the pointer—and the object under the pointer—on the screen.
Drag and drop

An operation with the mouse and pointer used to select data within one application and copy or move it to another location in that or some other application.

Drag area

The area in the middle of the scrollbar elevator or slider.

Dragging modifiers

Keys on the keyboard that modify dragging actions when they are pressed in conjunction with a mouse button.

Electronic mail

A facility that enables the exchange of information addressed to a particular individual, or a group, using computer communications facilities.

Elevator

The part of the scrollbar that has up and down arrows and a drag area. The elevator rides the scrollbar cable and shows the position of the view in the pane relative to the total data available.

End boxes

Small rectangular buttons on a slider that are used to set the minimum or maximum setting.

Exclusive setting

A control that is used for mutually exclusive settings and is shown by touching rectangles. The chosen setting is shown with a bold border around it.

File

A collection of data stored on a disk and assigned a name.

File Manager

A DeskSet application that provides access to the file system through graphical icons that represent various file types. File Manager can be used to load, store, and browse through files from the Workspace and from within an application.
File server

A sophisticated form of disk server that maintains a complete logical file system. Networked computers you can independently access information on the file server. Contrast this hardware term with the software term window server.

File system

In the case of the SunOS system software, a tree-structured network of files and directories through which you can move to access the various files.

Footer

The bottom area of a window. The footer is used by an application for information and error messages.

Foreground

The controls and the pane of a window.

Full size

To increase the size of a window to its maximum as determined by the application. Full Size is an item on the window menu that allows you to perform that function. After you make a window full size, the label in the item toggles to Restore Size.

Glyph

A picture or graphical representation of an object.

Grab handles

The graphical shapes marking the edges of a window. Using the mouse and pointer, you can grab the grab handles of the window to stretch or reduce its size.

Header

The band across the top of every window. Each header has a centered title. Base windows have a Window menu button on the left; pop-up windows have a pushpin on the left.
Help

An OPEN LOOK UI implementation that provides on-screen help for each element in a window. The application provides help for application functions and elements. The Help function is available from the keyboard by pressing Help or F1, depending upon your keyboard.

Highlighting

A visual indication that an object is in a special state. In monochrome implementations the visual indication is reverse video (white type on black). In color implementations, highlighting color is a slightly darker shade of the window color.

Hypertext

The name given to the ability to programmatically link two separate text nodes (locations). When positioned at a hypertext node, you can go to the other node by clicking the SELECT mouse button.

Icon

A small pictorial representation of a base window. Displaying objects as icons conserves screen real estate while keeping the window available for easy access.

Input area

The place on the screen that accepts keyboard input. In click-to-type mode, click SELECT to set the insert point in the input area. In Move Pointer mode, move the pointer into pane; the area is then ready for input.

Insert point

The specific location in the input area where keyboard input is entered. When the user sets the insert point, an active caret is displayed.

Keyboard accelerator

A key or sequence of keys on the keyboard that quickly perform specific menu or application functions without using a menu.

Locale

A set of conventions that are unique to a geographical area and/or language.
Localization
The process of establishing information within a computer system that is specific to the operation of particular native languages, local customs, and character sets.

man page
Another word for a reference manual page, an on-line resource for information about tools, programs, commands, and applications.

Menu
A rectangle containing a group of controls. Menus are displayed in two ways: from a menu button with choices appropriate to the menu button label (button menu) and from any place on the screen that is not a control (pop-up menu). The pop-up menu displays choices appropriate to the pointer location.

Menu button
A multiple-choice control. A menu button always has a menu mark and is used to display a menu.

Menu item
An item on a menu with a menu mark pointing to the right that is used to display a submenu.

Menu mark
A hollow triangle in the border of a button or following a menu item that has a submenu attached to it. The triangle points to where the menu or submenu is displayed.

MENU mouse button
The right mouse button that is used to display menus. (Unless you have switched the order of the buttons with xmodmap, in which case MENU and SELECT are swapped.)

Message
Information generated by an application that informs you about the status of a process.
Mouse

An electronic or mechanical device that is used to select and manipulate information on a computer screen.

Move

To remove selected text or graphics from a window and put it on the clipboard. Also, to change the location of selected windows, icons, text, or graphics by dragging to a new location.

Network

A system of interconnected computer workstations and servers.

Nonexclusive setting

A list of nonexclusive choices indicated by separated rectangles. The chosen settings are surrounded by a bold border.

Notice

Window that is displayed when an application generates warning and error messages that require an action before you can proceed. A Notice blocks input to the system until you click on one of its buttons.

Numeric field

A text input field, with increment and decrement buttons, that is used for numeric input.

OPEN LOOK

1. A registered trademark of AT&T.
2. The graphical user interface specification upon which the OpenWindows design is based.

Palette

A set of coordinated colors provided for defining the color of the Workspace, window background, selection, and caret.
Pane
A bordered rectangle in a window where the application displays its data.

Paste
To insert data from the clipboard into a window. Selected data is placed on the clipboard with the Copy or Cut key.

Path name
An identifier for the position of a file or directory within the file system. For instance, if the location of OPENWINHOME is /usr/local/bin, then /usr/local/bin is the path name.

Pinned menu
A menu that has its pushpin pushed in. A pinned menu is a pop-up window that remains on the Workspace until you dismiss it by clicking SELECT on the pushpin.

Pixel
An abbreviation for “picture element,” the smallest unit that can be displayed on a computer screen.

Pointer
Any graphic representation of the location of the input focus on the screen.

Pointer jumping
When the pointer automatically moves to a specific location, such as to a pop-up window.

Pop-up menu
A menu accessed by pressing the MENU mouse button on any area of the Workspace that is not a control. The menu that is displayed depends on the location of the mouse pointer.
**Pop-up window**

A window that is displayed to perform a specific function and is then dismissed. Command windows, property windows, help windows and Notices are all pop-up windows.

**Pop-up window menu**

The window menu that is displayed when you press the MENU mouse button in a window.

**PostScript**

A programming language used to produce text and graphics on a printer or display, originated by Adobe Systems.

**Press**

To push and hold a mouse button.

**Prompt**

The location at which you enter commands. This is often the machine’s host name, followed by a percent sign, such as:

```
example%
```

When you are in “superuser” mode, the percent sign changes to a pound sign:

```
example#
```

If the window server is not running, there is one prompt on the screen. If the window server is running, you can access the prompt by opening any terminal emulator window, such as a Shell Tool or Command Tool.

**Properties**

Characteristics of an object that you can customize, such as the color of a window. The OpenWindows Properties Window is available from the Workspace menu.

**Property window**

A pop-up window that is used to set properties associated with an object, an application, or a window.
Pushpin

Used to keep a menu, property window, or command window displayed on the screen.

Raster file

A data file containing an image composed of an array of picture elements (pixels) composed of consecutive lines, similar to the scans on a television screen.

Reference manual page

See man page.

Refresh

The process of redisplaying the information on a display screen. Refresh, an option on the Utilities submenu of the Workspace menu, should be used if there are spurious characters or artifacts from dismissed windows on the Workspace.

Release

To stop pressing a mouse button.

Resize corner

Areas that provide an unconstrained resizing of the boundaries of the window, without changing the scale of the contents of the window. Only windows that can be resized have resize corners. See grab handles.

Root window

The highest level window in the window system.

Screensaver

A utility that blanks the display screen after a predetermined length of time. The screensaver feature reduces image burns on the display screen. You move the mouse on its pad to clear the screensaver and return to the Workspace.

Scrollbar

A control that is used to move the view of the data displayed in the pane.
Scrollbar menu

A pop-up menu associated with each scrollbar that is used to reposition the data in the pane.

Scrolling

Moving through data that cannot be viewed entirely in a pane.

Scrolling button

An abbreviated button, with a solid triangular arrowhead inside the border, that is used for scrolling.

Scrolling list

A pane containing a list of items. The list can be read-only or it can be edited.

SELECT mouse button

The left mouse button which is used to choose objects, set the insert point, manipulate controls, and drag objects. (Unless you have switched the order of the buttons with \texttt{xmodmap}, in which case SELECT and MENU are swapped.)

Server

1. In a computer network, a unit that provides a specific service (such as data storage and compute services) to network users.
2. A program that provides input and display services for window system client applications. \textit{See} File server and Window server.

Settings

Controls for choosing predetermined values (see Exclusive setting and Nonexclusive setting).
Shell Tool
A window tool that provides a shell environment within a forward scrolling window only. See Command Tool.

Shrink
To resize a window so that its area is reduced.

Slider
A control used to set a value and give a visual indication of the setting.

Magnify Help
A brief message pertaining to the object under the pointer when the user presses the Help key.

Status message
Information generated by an application that informs you about the progress of a process.

Submenu
A menu that displays additional choices under a menu item on a menu.

Text duplicate pointer
The pointer that is displayed when you duplicate text directly by dragging.

Text field
An area in a window into which you type text from the keyboard.

Text move pointer
The pointer that is displayed when you move text directly by dragging.

Text region
A multi-line area in a window into which you type text from the keyboard.
**Tool**  
An application or utility program used to enhance productivity on the Sun Workstation.

**Undo**  
To return an object to its state before you performed the last operation. The number of levels of undo are determined by the application.

**Wastebasket**  
A DeskSet tool that is bound to the File Manager application and is used as a temporary repository for deleted files.

**Window**  
A rectangle containing application elements. *See also* Base window and Pop-up window.

**Window border**  
The part of the window, including the header, footer, and sides of the window, that you can use to select a window, set the input area, move by dragging, and display the window menu.

**Window button**  
A button that is used to display a window containing additional controls.

**Window manager**  
The window manager is a special program that handles the arrangement of windows on the screen. It allows you to open, close, move, and resize windows. It also provides facilities, such as the Workspace menu, for starting and stopping application programs.

**Window menu**  
The menu that is accessed from the background of a window. Pop-up windows have a window menu with slightly different choices than those of the base Window menu.
**Window menu button**

The abbreviated menu button that is always displayed at the left of the header in each base window and can be used to execute the default setting on the window menu (by clicking the SELECT mouse button) and to display the window menu (by pressing the MENU mouse button).

**Window server**

The program that coordinates output from application programs and input you provide through the mouse and the keyboard to display windows on your screen. The window server is the foundation for the OpenWindows environment. It is the X Window System server (Version 11, Release 5-X11R5) with a Display PostScript™ (DPS) imaging system extension. It implements a client-server model of window systems.

**Workspace**

The background screen area on which windows and icons are displayed.

**Workspace menu**

The menu from which the DeskSet applications and utilities can be opened.

**Workspace Properties window**

The Property window accessed from the Workspace menu through which you customize the Workspace environment.

**.Xdefaults file**

An OpenWindows file in the your home directory that stores the current properties of the Workspace. These properties include the color of the Workspace and windows, the locations of icons, and so on. The .Xdefaults file can be edited either with the Workspace Properties window available from the Workspace menu, or directly edited using a text editor.
Index

Symbols
% Calculator key, 301
&16 Calculator key, 314
&32 Calculator key, 314
( Calculator key, 301
) Calculator key, 301
*, wildcard search, 88
+/- Calculator key, 301
< Calculator key, 314
> Calculator key, 314

Numerics
1/x Calculator key, 301
10^x Calculator key, 315

A
Abbreviated Header, Mail Tool, 156
Abs Calculator key, 301
absolute value, 301
Acc Calculator key, 302
accelerator keys, 477
accented characters, 543
Access List and Permissions properties, 261
AccessX, 545 to 558
automatic shut-off, 548
beeping on locked keys, 554
BounceKeys, 557
controlling repeat behavior of keys, 555
holding a key down, 551
ignore multiple key presses, 557
initial delay of repeating keys, 555
keyboard equivalent of mouse buttons, 552
keystrokes for features, 558
latching and locking keys, 551
main window, 547
MouseKeys, 552
pressing two keys at once, 551
preventing accidental input, 556
RepeatKeys, 555
setting rate of repeating keys, 555
Settings window, 549
SlowKeys, 556
sound when feature enabled/disabled, 548
starting, 546
StickyKeys, 551
ToggleKeys, 554
accidental input, preventing, 556
Accuracy (Acc key), Calculator, 302
Add Tree’s Parent, File Manager, 67
adding and deleting text, 137
ADJUST mouse button, 8
Again operation, keyboard equivalent, 11
Again, Edit menu, 130
Alarm controls, Calendar Manager, 232, 235
alarm, Clock, 293
aliases
    local, 214
    private, 212
All Entries, Binder, 444
allnet, Mail Tool, 215
And Calculator key, 314
AND, logical, 314
AnswerBook
    bookmarks, 515
    searching, 509
application
    default, 13
    See also applications by their respective names, 36
    starting, 36
application icon, File Manager, 59
Application text field, Binder, 450
appointment
    reminders, 238
    scheduling, 233
appointment list
    Calendar Manager, 228
appointments
    Appointment Editor, 229
    pop-up window, 230
    deleting, 236
    editing, 237
    finding, 239
    repeating, 234
    scheduling, 229
Appt/ToDo, Calendar Manager, 231
arc cosine function, Calculator, 315
arc sine function, Calculator, 315
arc tangent function, Calculator, 315
arithmetic precedence, 301
Asc Calculator key, 301
ASCII, 301
ASCII text editor, 125
attached file
    caution about executables, 174
attachments, Mail Tool, 149, 173
    adding, 178
    attachments pane, 159
    deleting, 182
    drag and drop, 194
    moving, 180
    opening, 174
    printing, 162
    renaming, 179
    sending, 176
Audio Control
    Auto-Adjust button, 375
    Play window, 372
    Record window, 373
Audio Tool, 341 to 376
    Auto play on load, 370
    Auto play on selection, 370
    Confirm on new/load, 370
    converting audio files, 362
    cursor location, 354
    deleting, 349
    drag and drop target, 355
    drag and drop to Mail Tool, 351
    Edit menu, 367
    editing an audio file, 348
    file conversion window, 362
    File menu, 358
    Fwd (fast forward) button, 357
    inserting audio data, 366
    loading a file, 361
    loading an audio file, 344
    Open window
        illustration, 361
    Play button, 356
    play position pointer, 355
    playing an audio file, 344
    pointer location, 354
    Rec (record/stop) button, 357
    recording sound with, 345
    Rev (reverse) button, 356
    saving an audio file, 347, 363
sending voice mail, 350
Silence detection, 370
Silence threshold, 370
sound segments, 356
status information, 355
stop (Play) button, 356
stop (Rec) button, 357
Temp file directory, 370
Auto play on load, Audio Tool, 370
Auto play on selection, Audio Tool, 370
Auto-Adjust button, Audio Control, 375
automatic shut-off for AccessX, 548
Automatically Display Headers, 196

B
Background Color, Binder, 450
background color, Binder, 450
Backspace, Calculator, 302
base window, 31
  Audio Tool, 343, 353
  Binder, 442
  Calculator, 296
  Clock, 286
  Command Tool, 276
  features, 17
  File Manager, 58
  Icon Editor, 421
  Performance Meter, 324
  Print Tool, 332
  Shell Tool, 280
  Snapshot, 414
  Tape Tool, 378
  Text Editor, 126
Bcc, Mail Tool, 158
Beep setting, Calendar Manager, 232, 235
beep when modifier key is pressed
  (AccessX), 552
beeping on locked keys, 554
Begin Tree Here, File Manager, 67
Binder, 441
  All Entries, 444
  background color, 450
  base window, 442
  bindings, 441
    changing, 462
    creating, 458
    deleting, 462
  Color Chooser, 464
database, 443
entries
  network, 444
  private, 443
  system, 444
Entry Types, 443
icon, 442
Icon field, 448
image file, 448
image mask, 448
Local Entries, 444
Mask File, 448
open application, 450
Pattern, 453
print method, 450
properties, 446
  File Type properties, 451
  Icon properties, 447
Save button, 442
Shared Entries, 444
tag mask, 456
tag offset, 456
tag type, 456
tag value, 456
troubleshooting
can’t start Binder as root, 444
View button, 442
binding, 441
blank screen, 540
Block I/O, Tape Tool, 387
bookmark, creating, 515
BounceKeys, 557
  set the debounce time, 557
bringing up AccessX, 546
Browse menu, 254
browse menu
  deleting a user, 247
browser calendars
  adding users, 245
adding users to the access list, 263
changing access list, 264
deleting users from access list, 264
browsing calendars, 242
browsing remote calendars, 254
Bsp Calculator key, 302

C

calctool man page, 316
.calctoolrc file, 304
Calculator, 295
.calctoolrc file, 304
accuracy
Acc key, 302
base window, 296
basic keys
%, 301
+/-, 301
1/x, 301
Abs, 301
Acc, 302
Asc, 301
Base, 296 to 298
Bsp, 302
Clr, 302
Con, 304
Disp, 298
Exch, 303
Exp, 301
Frac, 301
Fun, 304
Int, 301
Keys, 302
Mem, 303
Mode, 299
parentheses, 301
Quit, 302
Rcl, 303
Sqrt, 301
Sto, 303
x^2, 301
financial keys
Ctrm, 307
Ddb, 308
Fv, 308
Pmt, 309
Pv, 310
Rate, 310
Sln, 311
Syd, 312
Term, 313
function keys, 316
functions
user defined, 304
icon, 296
keyboard equivalents, 305, 316
keyboard mapping, 302
logical keys
&16, 314
&32, 314
< (shift left), 314
> (shift right), 314
And, 314
Not, 314
Or, 314
Xnor, 314
Xor, 314
memory registers, 303
miscellaneous functions, 302
modes, 296
basic, 299
financial, 305
logical, 313
scientific, 314
performing calculations, 304
scientific keys
10^x, 315
Cos, 315
e^x, 315
Hyp, 315
Inv, 315
Ln, 315
Log, 315
Rand, 315
Sin, 315
Tan, 315
Trig, 314
x!, 315
y^x, 315
specifying precedence, 304
troubleshooting, 524
user defined functions, 304

Calendar, 220

Calendar Manager
introduction, 42
Alarm options, 235
Appointment Editor, 229
Alarm controls, 232
appointments scrolling list, 231
Appt/ToDo setting, 231
Date field, 230
My Eyes Only, 231
Repeat controls, 232
Start field, 230
What field, 231

appointments
appointment list, 228
appointment template, 272
deleting, 236
editing, 237
finding, 239
scheduling, 229
scheduling appointments for multiple calendars, 248, 250

base window elements, 233
browse access list
adding calendars, 263
changing, 264
deleting calendars, 264
Browse menu, 254
adding a calendar, 245
deleting a calendar, 247
browsing remote calendars, 242, 254
current day, 221
date formats, 266
day boundaries, 260
drag and drop, 240, 272
Icons, 220
icons, 220
Multi-Browser
Goto button, 243
Mail button, 243
multi calendar display, 243
Schedule button, 243
scheduling appointments, 248
scrolling browse list, 243
selecting a week to browse, 247
navigation controls, 223
permissions, 262
printer settings, 264
properties, 257

Access List and Permissions properties, 261
Category menu, 258
Date Format properties, 266
day boundaries, 260
Default View, 261
Display Settings properties, 259
Editor Defaults properties, 258
hour display, 261
Printer Settings properties, 264
reminders
Beep, 232, 235
Flash, 232, 235
Mail, 232, 235
PopUp, 232, 235
scheduling appointments, 233
time zone, 256
ToDo list, 228
views
appointment list view, 228
day view, 224
ToDo list view, 228
week view, 225
year view, 227
Calendar template, 167, 211
Capitalize, Text Editor, 134
caret, 9
Cc, Mail Tool, 159
change arithmetic sign, 301
Change Line Wrap, 128
changing
appointments, 237
binding, 462
day boundaries, 259
changing default menu item, 16
changing ramp-up speed of pointer, 554
characters, accented, 543
characters, jumbled, 540
checksum, 388
checksum error, 537
Circle, Icon Editor, 424
Clear log, 277
Clear log, Command Tool, 277
Clear, Calculator, 302
Clear, Icon Editor, 436
Clear, Mail Tool, 159
Click ADJUST, definition, 9
Click SELECT, definition, 9
click, definition, 8
clicking mouse buttons, how to set time-out period, 481
Click-to-Type, 488
Clip Lines, Text Editor, 130
clipboard, 130
clipboard, File Manager, 78
Clock, 285
Alarm settings, 293
base window, 286
changing timezone, 290
customizing, 286
icon, 285
keyboard accelerators, 293
properties, 287
troubleshooting, 530
closing
Help Viewer, 55
Navigator, 504
Viewer, 504
window, 29
Clr Calculator key, 302
cm_delete, 274
cm_insert, 274
cm_lookup, 274
Cmd Modes submenu, 278
collisions, 326
color
brightness, 473
hue, 473
in Workspace and windows, 471
saturation, 473
Color Chooser, Binder, 464
Color Chooser, Icon Editor, 439
color X pixmap image, 433, 437
command interpreter, 276
Command Tool, 276
Clear log, 277
editing command line, 279
File Editor menu, 278
History, 277
icon, 276
Mode Setting, 277
pop-up menu, 277
Scrolling menu, 278
Store log, 277
term pane menu, 277
troubleshooting, 283
Compose menu
Mail Tool, 152
composing email, 164, 165
compounding periods, 307
Con calculator key, 304
Confirm on new/load, Audio Tool, 370
Console, 283, 498
constants, Calculator, 304
context switches, 326
control area, 17
Copy operation, keyboard equivalent, 11
Copy, Edit menu, 130
copying
from clipboard, keyboard equivalent, 11
to clipboard, keyboard equivalent, 11
files, 64, 78
keyboard equivalent for, 11
mail messagesMail Tool
messages
copying, 152
text, 137
your email messages, 205
copying files
cut and paste, 78
core file, 539
Cos Calculator key, 315
COS, cosine function, Calculator, 315
cpio command, 377
Create Folder, 62
creating
  binding, 458
  calculator functions, 306
  links, 94
  local aliases, 214
  mail files, 186
  mail messages, 152
  new files, 77
  snapshot, 415
  templates, 167, 210
  text, 127
  text file, 135
cropping an image
  Image Tool, 402
cross-reference links, 508
Ctrm Calculator key, 307
current folder, File Manager, 70
Custom Buttons, Mail Tool, 197
Custom Commands, File Manager, 63, 110
custom field, 204
customizing
  Calculator, 320
  Clock, 286
  clock
    time zone, 290
  default menu item, 16
  File Manager, 98
  font scale, 474
  fonts, 474
  interval between mouse clicks, 481
  Mail Tool, 194
  mouse
    click time-out, 481
    press (whether menu selection is automatic), 485
  Performance Meter, 326
  pointer jumping, 483
  scrollbars, 489
  Text Editor, 143
  type styles, 474
  Viewer, 520
  Workspace, 468
customizing your Text Editor, 143
Cut operation, keyboard equivalent, 11
Cut, Edit menu, 130
Cut, File Manager, 64
cutting and pasting text, 138
D
data file, 59
Date field in Calendar Manager, 230
Date Format properties, 266
day boundaries, 259
day view, 224
  printing, 267
day view, Calendar Manager, 224
Ddb Calculator key, 308
dead.letter file, 535
debounce time, 557
default
  how to change on a menu, 16
  locations of icons, 488
  menu choice, 16
    how to change, 16
default ring on menus, xxxii
default view of Calendar Manager, 261
default|app Binder entry, 455
default|dir Binder entry, 455
default|doc Binder entry, 455
Degrees, 314
delete
  data, from sound file, 349
  drag and drop method, 24
  file, in Text Editor, 136
  text, in Text Editor, 136
Delete method, File Manager, 100
deleting
  appointments, 236
  binding, 462
  files, 64, 91
  mail messages, 152
  messages, 170
Deliver, Mail Tool, 158
depreciation allowance, 308
DeskSet applications
   introduction, 36
   starting, 37
.desksetdefaults file, 316
Destination field, Tape Tool, 379
Destination Machine, 86
Destination Path, 86
Device field, Tape Tool, 387
Disable Page Mode, 282
disabled users, interface for, 545
disabled users, see also handicapped users and AccessX, 545
disk traffic, 326
Display Characters, Mail Tool, 196
Display Headers, Mail Tool, 196
Display Lines of Text, Mail Tool, 199
Display Settings, Calendar Manager properties, 259
displaying
   property window, keyboard equivalent, 11
displaying files, File Manager, 65, 108
Done, Mail Tool, 151, 182
Dot files, File Manager, 105
double-click, definition, 8
drag and drop, 20
   Audio Tool, 355
   Calendar Manager, 272
   File Manager, 79, 94
   File Manager to Mail Tool, 176
   File Manager to Print Tool, 86
   File Manager to Tape Tool, 378
   from Audio Tool to Mail Tool, 351
   from File Manager to Print Tool icon, 334
   from File Manager to Tape Tool, 382
   from Text Editor, 136
mail attachments, 176, 178, 180, 194
   mail onto File Manager, 82
   mail to Calendar Manager, 240
   mail to Print Tool, 163
Mail Tool, 192, 272
Print Tool, 331
problems, 532
Tape Tool, 378
target, 20
Text Editor, 140, 142
Text Editor to Mail Tool, 177
Text Editor to Print Tool, 139
drag area, on scrollbar, 18
drag, definition, 9
dragging and dropping
   Image Tool, 409
   drag-right distance, 484
E
e^x Calculator key, 315
Edit, 367
Edit menu
   Audio Tool, 367
   Binder, 443
   File Manager, 64
   Icon Editor, 436
   Mail Tool, 152
   Text Editor, 130
edit menu
   Image Tool, 412
editing
   appointments, 237
   audio file, 348
   command line in Command Tool, 279
   list files, 379
   Mail Tool properties, 205
text file, 136
Editor Defaults, Calendar Manager, 258, 266
editors
   Text Editor, 39
   vi, 39
   Ellipse, Icon Editor, 424
   Empty Document, Text Editor, 127
   Empty Wastebasket, 93
Enable Page Mode, 282
ENG (engineering display notation),
Calculator, 298
Enter Function, 305, 306
Erase, Icon Editor, 427
Err Exit, Tape Tool, 388
error messages
  Image Tool, 409
Error, calculator, 524
/etc/aliases file, 212
Exch Calculator key, 303
Exclude, Tape Tool, 388
Exp Calculator key, 301
exponential calculator function, 315
exponents, 301
extracting files from tape, 384
Extras menu, 133

F
factorial calculator function, 315
File, 358
file
  copying onto tape, 382
  creating, in Text Editor, 135
  editing, in Text Editor, 136
  extracting from tape, 384
  saving, in Text Editor, 135
  viewing
    in Text Editor, 135
    saved mail messages, 202
file and folder properties, File Manager
group, 96
name, 96
ownership, 96
permissions, 96, 98
File Editor menu, Command Tool, 278
File Manager, 57
  introduction, 40
  base window, 58
  clipboard, 78
  copying files, 64, 78
    cut and paste, 78
    creating folders, 62
  creating new files, 77
  current folder, 70
  Custom Commands, 110
  customizing, 98
  Delete Method, 100
deleting files, 58, 64, 91, 93
displaying files, 58, 63, 65, 70, 108
  by Content, 107
double-click accelerators, 61
drag and drop, 79
Edit menu, 64
Empty Wastebasket, 93
File menu, 62
file pane, 58, 73
file properties
group, 96
name, 96
owner, 96
permissions, 96, 98
Find pop-up window, 89
finding files, 63, 87, 90
Hidden files, 105
icon, 58
icons, 59
  applications, 59
data file, 59
  folder, 59
linking files, 57, 94
Longest File Name, 102
moving data files to workspace, 80
moving files, 78
  cut and paste, 78
  moving files to a folder, 80
  moving files to another
    application, 81
  moving folder to workspace, 80
  naming a document or folder, 78
opening files, 62, 76
path display, 70
path pane, 58
path that is displayed, 71
printing files, 62, 86
properties, 93, 96, 112, 114
  changing file properties, 98
  date modified, 96
  file and folder properties, 96
File Properties window, 96
  folder, 96
  Tool Properties, 112 to 114
  Tool Properties Window, 112
removing files, 58, 91
renaming files, 78
Select All, 64
selecting files, 61
subfolders, 70
transferring files, 57
transferring files, 86
tree display, 65
troubleshooting, 531
copying files on remote
  systems, 532
drag and drop error, 532
files not displayed, 532
icons not displayed, 531
view By Content takes too
  long, 532
using Goto, 88
  View Filter Pattern, 114
  View menu, 63
  Wastebasket, 91
File menu
  Audio Tool, 358
  Binder, 442
  File Manager, 62
  Icon Editor, 432
  Mail Tool, 151
  Text Editor, 127
file menu
  Image Tool, 410
file pane, File Manager, 58, 73
File Properties window, 96
file properties, File Manager
date accessed, 96
date modified, 96
file type, 96
free space, 96
mount point, 96
mounted from, 96
open method, 96
print method, 96
file system, 40
File to Write button, Tape Tool, 379
File Type Properties, Binder, 451
files
deleing, 91
linking, 94
loading new, keyboard equivalent, 11
opening
  keyboard equivalent, 11
saving, keyboard equivalent, 11
Fill menu, Icon Editor, 430
financial functions, 306
Find and Replace pop-up window, 131
Find Marked Text item, Text Editor, 132
Find menu, Text Editor, 130
Find operation, keyboard equivalent, 11
Find pop-up window, 171
Find pop-up window, File Manager, 89
Find Selection, Text Editor, 132
Find, File Manager, 63
finding
  appointments, 239
  files, 87, 90
  mail messages, 171
FIX (fixed point display notation),
  Calculator, 298
Flash setting, Calendar Manager, 232, 235
flipping an image
  Image Tool, 403
Focus-Follow-Pointer, 488
folder, 59
fonts
  changing default, 474
  customizing, 474
  listing, 475
  scale, 474
Foreground Color, Binder, 449
format lines of text, Text Editor, 133
Forward, Mail Tool, 153
Frac Calculator key, 301
Full Header, Mail Tool, 156
Fun calculator key, 304
Function Keys utility, 492
functions
  financial, 306
  logical, 313
  miscellaneous Calculator, 302
  scientific, 314
  user defined Calculator, 304
future value of investment, 308
Fv Calculator key, 308
Fwd (fast forward) button, Audio Tool, 357
G
  Goto text field, 88
  Gradients, Calculator, 314
  Grid Display, Icon Editor, 435
  group
    change file properties, File Manager, 98
H
  handicapped users
    avoiding unintentional input, 556, 557
    controlling key repeat behavior, 555
    getting a beep for locked keys, 554
    ignoring inadvertant key presses, 556, 557
    pressing two keys at once, 551
    using keys to mimic the mouse, 552
  handicapped users, see also AccessX, 545
  handicapped users, interface for, 545
  Header menu button, Mail Tool, 158
  help
    closing Help Viewer, 55
    handbooks, 45
    keyboard equivalent for, 11
    magnify, 45
    paging through handbook, 51
    using hypertext in handbooks, 53
  Help button
    Image Tool, 409
  Hidden Files, File Manager, 105
  Hide Snapshot During Capture, 415
  Hide Subfolders, File Manager, 67
  Hide, Mail Tool, 156, 200
  History, Command Tool, 277
  $HOME variable, 205, 208
  Host Name, Tape Tool, 387
  hot spot, 21
  Hyp Calculator key, 315
  hyperbolic cosine function, Calculator, 315
  hyperbolic function flag, Calculator, 315
  hyperbolic sine function, Calculator, 315
  hyperbolic tangent, 315
  hypertext links, 508
I
  icon
    introduction, 6
    default location, 488
    application, 59
    Binder, 442
    Calculator, 296
    Calendar Manager, 220
    Clock, 285
    Command Tool, 276
    data file, 59
    File Manager, 58
    folder, 59
    Icon Editor, 421
    Mail Tool, 44
    Mail Tool, Compose window, 157
    Mail Tool, Header window, 148
    moving, 28
    Navigator, 504
    Performance Meter, 323
    Print Tool, 331
    Shell Tool, 280
    Snapshot, 414
    Tape Tool, 377
    Text Editor, 125
    Viewer, 504
    Icon Editor, 421
    adding text to canvas, 424
base window, 422
canvas, 422
clearing the canvas, 436
Color Chooser, 439
color controls, 430
color X pixmap, 433
control area, 422
drawing controls, 422, 423
drawing mode, 423
circle, 424
eclipse, 424
erase, 427
line, 423
point, 423
region, 426
square, 424
text, 424
editing icon, 427
erasing in drawing canvas, 429
fill choices, 430
formats, 433, 437
color X pixmap, 437
Monochrome X pixmap, 433, 437
X bitmap, 433, 437
Xview icon, 433, 437
grid, 435
icon, 421
icon size, 437, 438
Invert, 437
menus
Edit menu, 436
Properties menu, 437
View menu, 434
move buttons, 431
preview area, 422
printing, 433
icons, keyboard equivalents, 11
ignore multiple key presses, 557
Image File, Binder, 448
Image Tool, 389
controls, 410
cropping, 402
dragging and dropping, 409
edit menu, 412
file menu, 410
flipping, 403
formats, 391
help button, 409
icon, 390
information, 395
multiple page documents, 406
open as, 394
opening an image, 391
palette, 401
panning, 402
printing, 399
properties, 408
rotating, 404
save as, 397
save page as Image, 399
save selection as, 398
saving an image, 395
standard operations, 412
view menu, 411
View window, 390
zooming, 405
image tool, 389
Include File, Text Editor, 127
Include, Mail Tool, 158
input area
click SELECT before typing, 488
definition, 9
Focus-Follow-Pointer, 488
Insert, 134
Insert Brackets, Text Editor, 134
insert point, 9
Int Calculator key, 301
integer, 301
international keyboard, 493
Introducing Your Sun Desktop tutorial, xxx
Inv Calculator key, 315
inverse function flag, 315
inverse hyperbolic cosine function, Calculator, 315
inverse hyperbolic sine function, Calculator, 315
inverse hyperbolic tangent, 315
Invert, Icon Editor, 437
J
jumbled characters, 540

K
keyboard
  erase functions, 478
  international, 493
  move caret functions, 478
  navigation commands, 479
  remapping, 478
keyboard accelerators
  Clock, 293
  Performance Meter, 330
keyboard access for handicapped
  users, 545
keyboard equivalents
  Calculator, 305, 316
keyboard equivalents (accelerators)
  (OpenWindows), 10 to 11
keyboard equivalents of mouse
  buttons, 552
Keys, 302
keys
  accelerator, 477
  controlling repeat behavior, 555
  ignore multiple presses, 557
  latching and locking, 551
  modifier, 551
  rate of repeat, 555
keystrokes for AccessX features, 558

L
latching keys (AccessX), 551
left-handed use
  of mouse buttons, 481
Line, Icon Editor, 423
link, 94
  creating, 94
  removing, 95
linking files, File Manager, 57, 94
links, 508
list files, Tape Tool, 378
Ln Calculator key, 315
ln command, 94
Load In-Box, 151, 182
loading a file
  Audio Tool, 361
  Icon Editor, 432
loading a file, in Text Editor, 135
loading new files, keyboard
  equivalent, 11
Local Entries
  Binder, 444
localization, 489
Lock Screen utility, 497
locking keys (AccessX), 551
Log Calculator key, 315
Log Samples, Performance Meter, 330
Log, Mail Tool, 159
logarithm
  base 10, 315
  natural, 315
logical functions, 306, 313
logical mode, 313
logical shift left, 314
Longest File Name, File Manager, 102

M
Magnify button, 521
Magnify help, 45
Mail File Directory, 207
Mail File menu, 185
Mail File text field, 153
Mail Files menu item, 151
Mail setting, Calendar Manager, 232, 235
Mail Tool, 147
  introduction, 44
  attachments, 149, 173
  adding, 178
  attachments pane, 159
  deleting, 182
  drag and drop, 194
moving, 180
doing, 174
printing, 162
renaming, 179
sending, 176
Show Attachment List, 203
committing changes, 182
composing messages, 164, 165
custom buttons, 151, 153, 197
custom header fields, 204
customizing, 194
drag and drop, 163, 176, 180, 192, 194, 272
headers
Reply-To header, 204
Return-Receipt-To, 204
icons, 148, 157
In-Box location, 535
loading In-Box, 192
lock file, 535
Mail File menu, 153
mail files, 183
adding messages to, 188
creating, 186
deleting, 190
emptying, 190
Mail File directory, 207
Mail File menu, 185
Mail File text field, 153
Mail Files menu item, 151
Mail Files window, 183
renaming, 190
sorting, 190
viewing, 189
menus
Compose menu, 152
Copy menu, 185, 207
Edit menu, 152
File menu, 151
Load menu, 185, 207
Messages menu, 154
Move menu, 185, 207
View menu, 151
message headers, 149, 156
messages
creating, 152
deleting, 152, 170
finding, 171
forwarding, 153
organizing, 183
printing, 162
recovery, 535
replying, 153
undeleting, 152, 170
viewing, 154, 155, 156, 157
Precedence junk headers, 204
printing messages, 162
properties, 194, 205
Alias properties, 212
allnet, 215
Automatically Display Headers, 196
Category menu, 195
Compose Window properties, 200
Custom Buttons, 197
custom header fields, 204
delivery properties, 196
Display Characters, 196
Display Headers, 196
Display Lines of Text, 199
Expert properties, 214
Header Window, 195
Hide, 200
Ignore host name in address, 215
Include me when I "Reply to All", 215
mail arrival properties, 196
Mail Filing properties, 206
Message Window properties, 199
metoo, 215
Move, Copy, Load menus, 207
Print Script, 200
Retrieve Every, 196
Show "To recipient", 196
Show Attachment List, 203
Signal With, 196
template properties, 210
reading messages, 167
running multiple versions of Mail Tool, 533
saving changes, 182
templates, 167
troubleshooting, 533
  running out of disk space, 536
Vacation, 153
vacation notifier, 168
viewing saved messages, 202
Voice button, 159
windows
  Compose window, 157
  customizing window size, 196
  Find window, 171
  Mail File windows, 189
  Mail Files window, 184, 186, 188
  Properties window, 194
  Vacation Setup window, 168
  View Message window, 154
Mail Tool, templates, 210
.mailrc file, 215
man page
  adb(1), 540
date(1), 285
.dbx(1), 540
Mask File, Binder, 448
Mem Calculator key, 303
memory registers, Calculator, 303
Memory, Calculator, 303
menu
  introduction, 12
  button, 14
  changing default choice, 16
  default choice, 16
  Programs, 13
  secondary, 13
  window, 14
  Workspace, 12
    customizing, 16
MENU mouse button, 8
menu, Workspace, 37
menus, xxx
message header, 156
  selecting, 150
Messages, 151
Meta key, 10
metoo, Mail Tool, 215
miscellaneous Calculator functions, 302
Mod Time, Tape Tool, 388
Mode setting, Command Tool, 277
Mode, on History menu, 277
modifier keys, 551
modifying OpenWindows defaults, 468
Monitor settings, Performance Meter, 327
Monochrome X pixmap image, 433, 437
month view
  printing, 270
more command, 282
mouse, xxx
  introduction, 7
  buttons
    SELECT, ADJUST, MENU, 8
  customizing click time-out, 481
  customizing press (whether menu
    selection is automatic), 485
  how to use, 8
  keyboard substitution, 477
  remapping for left-handed users, 481
mouse access for handicapped users, 545
MouseKeys, 552
  change maximum speed of
    pointer, 554
  changing ramp-up speed, 554
  keyboard equivalents, 553
move buttons, Icon Editor, 431
move, definition, 9
moving
  data files to workspace, File
    Manager, 80
  files, 78
  files to a folder, File Manager, 80
  files to another application, File
    Manager, 81
  folder to workspace, File Manager, 80
moving files
  cut and paste, 78
moving icons, 28
moving windows, 25
multi-click timeout, 481
My Eyes Only, Calendar Manager, 231

N
Name, calculator function, 305
naming document or folder, File Manager, 78
natural logarithm calculator function, 315
Navigator
  closing, 504
  icon, 504
  modes
    Bookmarks, 515
    Search, 509
  quitting, 504
New operation, keyboard equivalent, 11
New, Mail Tool, 152
NewDocument, File Manager, 77
NewFolder, File Manager, 77
Next, Mail Tool, 151
No Check, Tape Tool, 388
No SCCS+, Tape Tool, 387
No SCCS, Tape Tool, 387
noauth OpenWindows option, 444
Not Calculator key, 314
NOT, logical, 314
number bases, 296
  Binary, 297
  Decimal, 297
  Hexadecimal, 297
  Octal, 297

O
octal (base number mode), Calculator, 297
on-line help, 45
open
  icon into a window, 7
text file, 135
Open File operation, keyboard equivalent, 11
OPEN LOOK, xxix
Open Window operation, keyboard equivalent, 11
Open window, Audio Tool, 361
opening files, 62
  keyboard equivalent, 11
folders, 62
Image Tool files, 391
opening files, File Manager, 76
OpenWindows
  keyboard equivalents (accelerators), 10 to 11
  overview of features, 5
  reducing use of mouse, 477
Or Calculator key, 314
OR, logical, 314
organizing mail messages, 183
Orig Mode, Tape Tool, 388
owner
  change file properties, File Manager, 98

P
page overview
  Image Tool, 406
page viewing controls
  Image Tool, 407
Palette
  Image Tool, 401
pane
  terminal emulator, 281
text editing, 154
panes, splitting, 139
Panning
  Image Tool, 402
parent directory, 66
parentheses, Calculator, 301
password, 3
Paste operation, keyboard equivalent, 11
Paste, Edit menu, 130
Paste, File Manager, 64
Path Commands menu, File Manager, 71
Index

path pane, File Manager, 58, 70
path, File Manager, 70
Pattern, Binder, 453
pattern-matching, 88
percentage, 301
Performance Meter, 323
    customizing, 326
displays, 328
dial, 324
icon, 323
keyboard accelerators, 330
Log Samples, 330
monitoring remote machine, 329
monitors, 327
needles, 324
Properties window, 327
Sample Time, 329
Show collisions, 326
Show context, 326
Show cpu, 325
Show disk, 326
Show errors, 326
Show interrupts, 326
Show load, 326
Show packets, 325
Show page, 326
Show swap, 326
performing calculations, Calculator, 304
periodic interest rate, 310
periodic payment calculation, 309
permissions
    files and folders, 96, 98
group, 98
owner, 98
world, 98
Play button, Audio Tool, 356
Play window, Audio Control, 372
playing sound, with Audio Tool, 344
+/- Calculator key, 301
Pmt Calculator key, 309
Point, Icon Editor, 423
pointer
    introduction, 7
    and input area, 488
    change speed of, 554
drag distance, 484
jumping, 10
list of types, 7
movement on scrollbar, 483
on pop-up windows, 483
pointer speed
    changing, 554
    changing ramp up, 554
pop-up menu, 277
PopUp setting, Calendar Manager, 232, 235
pop-up window menu, 14
PowerPC machines
    OpenWindows keyboard equivalents (accelerators), 10 to 11
Precedence junk header, Mail Tool, 204
present value calculations, 310
Press MENU, definition, 9
Pretty-print C code, 134
Previous, Mail Tool, 151
Print Method, Binder, 450
Print operation, keyboard equivalent, 11
Print Script, Mail Tool, 200
Print Tool, 331
    introduction, 43
    base window, 332
drag and drop, 331, 335
features, 43
how to stop a print job, 337
icon, 331
printer
    choosing, 335
default, 340
queue status, 336
status messages, 333
troubleshooting, 536
Printer Settings, Calendar Manager, 264
printing, 86
day view, 267
drag and drop, 163, 331
File Manager, 62, 86
icons, 433
keyboard equivalent for, 11
mail messages, 151, 162
mail messages with Print Tool, 335
month view, 270
queue status, 336
Text Editor files, 139
week view, 269
year view, 270
Printing Images, 399
program names, 37
Programs menu, 13
Programs submenu, 37
programs, See application
prompt, 18
properties
Binder, 443, 446
Calculator, 320
Calendar Manager, 257
changing file properties, File
Manager, 98
day boundaries, 259
default view, 261
file and folder, File Manager, 96
for the Workspace, 468
Icon Editor, 437
Image Tool, 408
Mail Tool, 152, 194
Performance Meter, 326, 327
Tape Tool, 379
template, 210
property window, displaying, keyboard
equivalent, 11
Props operation, keyboard equivalent, 11
pushpin, 14
Pv Calculator key, 310

Q
Quit Calculator key, 302
quitting
Help Viewer, 56
Navigator, 504
Viewer, 504
window, 29

R
Radians, Calculator, 314
Rand Calculator key, 315
random number calculator function, 315
Rate Calculator key, 310
Rcl Calculator key, 303
Read Entire List, Tape Tool, 381
Read Entire Tape, Tape Tool, 382
read files from tape, 381
read files, Tape Tool, 378
Read Selected, Tape Tool, 381
Read settings, Tape Tool, 388
reading email, 167
Rec (record/stop) button, Audio Tool, 357
Recall, Calculator, 303
Record window, Audio Control, 373
recording sound, with Audio Tool, 345
Redo operation, keyboard equivalent, 11
Refresh utility, 491
Region, Icon Editor, 426
Register Exchange, Calculator, 303
registers, Calculator memory, 303
release (mouse button), definition, 9
remainder, 301
remapping, keyboards, 478
Remote Copy pop-up window, 85
Remote Copy, File Manager, 63
Remove, 134
Remove Brackets, Text Editor, 134
removing links, 95
renaming files, File Manager, 78
repeat appointments, 234
Repeat field, Calendar Manager, 232
repeating
operations, keyboard equivalent, 11
RepeatKeys, 555
rate of repeating, 555
setting initial delay, 555
Replace text, Text Editor, 133
Reply, Mail Tool, 153
Reply-To header, Mail Tool, 204
resizing windows manually, 28
Retrieve Every, Mail Tool, 196
Return-Receipt-To header, Mail Tool, 204
Rev (reverse) button, Audio Tool, 356
Root, 66
rotating an image
Image Tool, 404

S
Sample Time, Performance Meter, 329
Save Changes, 151
Save Changes, Mail Tool, 182
Save operation, keyboard equivalent, 11
Save Workspace utility, 497
saving
Audio Tool files, 347, 363
Image Tool files, 395
keyboard equivalent for, 11
Mail Tool changes, 182
text file, 135
SCI (scientific display notation),
Calculator, 298
scientific functions, 314
screen
blank, 540
how to lock, 497
how to unlock, 498
scrollbar
and pointer movement, 483
elements of, 18
modifying location, 489
Scrolling submenu, Command Tool, 278
searching
in the Navigator, 509
SELECT, xxxi
Select All, File Manager files, 64
Select Line at Number, Text Editor, 128
SELECT mouse button, 8
selecting
message header, 150
Sending Messages, 183
settings for AccessX, 549
Shared Entries, Binder, 444
Shell Tool, 280
base window, 280
Disable Page Mode, 282
Enable Page Mode, 282
icon, 280
stop sign pointer, 282
term pane menu, 282
Shift Lines, Text Editor, 134
shift right, 314
Show “To recipient”, Mail Tool, 196
Show All Subfolders, File Manager, 67
Show Attachment List, 203
Show Attachment List, Mail Tool, 203
Show Caret at Top, Text Editor, 128
Show collisions, Performance Meter, 326
Show context, Performance Meter, 326
Show cpu, Performance Meter, 325
Show disk, Performance Meter, 326
Show errors, Performance Meter, 326
Show Errs, Tape Tool, 387
Show interrupts, Performance Meter, 326
Show load, Performance Meter, 326
Show packets, Performance Meter, 325
Show page, Performance Meter, 326
Show swap, Performance Meter, 326
shut-off (AccessX), 548
Signal With, Mail Tool, 196
Silence detection, Audio Tool, 370
Silence threshold, Audio Tool, 370
Sin Calculator key, 315
SIN, sine function, Calculator, 315
size of windows, modifying, 28
Sln Calculator key, 311
SlowKeys, 556
setting notification parameters, 556
setting the acceptance delay, 557
Snap Type, 414
Snapshot, 414
base window, 414
capturing screen pointer, 415
creating a snapshot, 415
Hide Window During Capture, 415
icon, 414
Snap Delay, 415
snapping a region, 416
snapping the screen, 417
snapping window, 415
timer, 415
troubleshooting, 536
types, 414
viewing, 418
Sort By, Mail Tool, 152
sorting
mail files, 190
SPARC machines
OpenWindows keyboard equivalents
(accelerators), 10 to 11
speed of pointer
changing, 554
changing ramp up, 554
splitting panes, 139
splitting text panes, 139
Sqr Calculator key, 301
square root, 301
Square, Icon Editor, 424
*, wildcard search, 88
Start field, Calendar Manager, 230
starting
an application, 13, 36
starting AccessX, 546
starting applications, 37
starting the vacation notifier, 169
status messages
Image Tool, 409
status, print queue, 336
StickyKeys, 551
disable by pressing two modifier keys, 552
sound when modifier key is pressed, 552
Sto Calculator key, 303
stop (Play) button, Audio Tool, 356
stop (Rec) button, Audio Tool, 357
Stop operation
keyboard equivalent, 11
stop sign pointer, Shell Tool, 282
stopping the vacation notifier, 169
stopwatch, 292
Store log as new file, 277
Store log, Command Tool, 277
Store, Calculator, 303
straight-line depreciation, 311
Strip Path, Tape Tool, 379, 388
subfolders, File Manager, 70
Subject field of mail header, 159
submenu, 13
sum-of-the-years'-digits depreciation, 312
Suppress, Tape Tool, 388
Syd Calculator key, 312
Sym Links, Tape Tool, 387
symbolic links, Tape Tool, 387

T
Tag Mask, 456
Tag Offset, 456
Tag Type, 456
Tag Value, 456
Tan Calculator key, 315
TAN, tangent function, Calculator, 315
Tape Tool
introduction, 377
adding a file to write, 379
base window, 378
copying files onto tape, 382
destination, 379
drag and drop, 378
drag and drop from File Manager, 382
extracting files from tape, 384
File to Write button, 379
Host Name, 387
icon, 377
list files, 378
   editing, 379
   properties, 379, 386
read files, 378, 381
Read menu, 381
reading files from tape, 381
Strip Path option, 379
tape device, 387
troubleshooting, 537
Write settings, 387
writing files to tape, 378, 382
tar command, 377
telnet (tty) interface, 280
Temp file directory, Audio Tool, 370
templates, 167
   Calendar template, 272
   creating, 167, 210
   properties, 210
   using, 167, 210
Templates submenu, Mail Tool, 167
10^x Calculator key, 315
Term Calculator key, 313
terminal emulator pane, 281
Text
   Find and Replace, 131
text
   adding and deleting, 137
   copying, 137
   cutting and pasting, 138
text editing panes, 154
Text Editor, 125
   introduction, 39
   base window, 126
   Change Line Wrap, 128
   Clip Lines, 130
   control area, 126
   creating a text file, 135
   customizing, 143
   drag and drop, 139, 140
   editing a text file, 136
emptying document, 127
File menu, 127
Find and Replace window, 131
Find Marked Text, 132
Find Selection, 132
icon, 125
Include File menu item, 127
loading a text file, 135
menus
   Edit menu, 130
   Extras menu, 133
   Find menu, 130
   View menu, 128
printing files, 139
Select Line at Number, 128
shifting lines, 134
Show Caret at Top, 128
splitting panes, 139
text
   capitalizing, 134
   creating, 127
   finding, 132
   format, 133
   inserting brackets, 134
   removing brackets, 134
   replacing, 133
text pane, 126
   What Line Number?, 128
text pane, 126
Text, creating in Icon Editor, 424
text/terminal emulator pane, 276
.text Extras menu file, 143, 144
.textswrc file, 145
time zone
   Calendar Manager, 256
timezone, on clock display, 290
To field in mail header, 159
ToDo list
   Calendar Manager, 228
ToggleKeys, 554
transfer files, File Manager, 86
transferring files, File Manager, 57
tree, File Manager, 70
Trig Calculator key, 314
trigonometric base, 314
trigonometric functions, 314
troubleshooting
  Calculator, 524
  Clock, 530
  Command Tool, 283
  File Manager, 531
  Mail Tool, 533
  Print Tool, 536
  Snapshot, 536
  Tape Tool, 537
truncate calculations, 314
tty interface, 280
type styles, customizing, 474

U
umask, Tape Tool, 388
undeleting
  messages, 152, 170
Undo
  Icon Editor, 436
Undo operation, keyboard equivalent, 11
Undo, Edit menu, 130
undoing undo
  keyboard equivalent, 11
unlocking your screen, 498
user defined functions, Calculator, 304
user name, 2
username.lock, 535
using
  local aliases, 214
  templates, 167, 210
/var/openwin
  error message, 539

V
vacation notifier, 168
  starting, 169
  stopping, 169
Vacation, Mail Tool, 153
Value, calculator function, 306
/var/spool/mail file, 535
vi editor, 39
View Filter Pattern, File Manager, 114
View menu
  Binder, 444
  File Manager, 63
  Icon Editor, 434
  Mail Tool, 151
  Text Editor, 128
view menu
  Image Tool, 411
View Message window, Mail Tool, 155
Viewer
  closing, 504
  customizing, 520
  functions, 503
  icon, 504
  links, 508
  Magnify button, 521
  printing a document, 521
  quitting, 504
viewing
  mail, 154
  snapshots, 418
viewing mail
  multiple messages, 157
  next message, 155
  previous message, 155
  with full header, 156
Voice button, Mail Tool, 159
voice mail
  listening to, 352
  sending, 350

W
Wastebasket, 24, 91
  creating new, 93
  .wastebasket, 92
week view
  printing, 269
week view, Calendar Manager, 225
What field in Calendar Manager, 231
What Line Number?, Text Editor, 128
wildcard search, 88
window, 6
troduction, 5
base, 31
buttons, 19
click SELECT before typing (click-to-type mode), 488
closing and quitting, 29
fixing display, 541
menu, 14
move pointer to type, 488
moving front or back, 26
pane, 14
prompt, 18
repositioning, 25
resizing manually, 28
snapshots, 415
window controls, 17
Window Controls utility, 495
windows, xxx
closing to icons, keyboard equivalent, 11
opening icons, keyboard equivalent, 11
Workspace
definition, 5
how to save setup, 497
menu
how to display, 12
Properties, 468
icon locations, 488
menu drag distance, 484
Workspace menu, 37
world
change file permissions, File Manager, 98
world Calendar Manager permissions, 262
wrap
change line wrap, 128
character, 129
clip lines, 130
word, 129
Write settings, Tape Tool, 387
writing files to tape, 378, 382

X
X bitmap, 433, 437
x! Calculator key, 315
x^2 Calculator key, 301
x86-based machines
OpenWindows keyboard equivalents (accelerators), 10 to 11
.Xdefaults file, 143, 316
Xnor Calculator key, 314
XNOR, logical, 314
Xor Calculator key, 314
XOR, logical, 314
Xview icon, 433, 437

Y
y^x Calculator key, 315
year view
printing, 270
year view, Calendar Manager, 227

Z
zooming an image
Image Tool, 405