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CHAPTER 1

Introduction

This chapter gives an overview of the RAID Manager storage management software,

the hardware and software requirements, and steps you must take before installing

the software.

■ About this Guide—page 1-1

■ About this Software—page 1-2

■ Understanding the Restrictions—page 1-3

■ Hardware and Software Requirements—page 1-6

■ Selecting the Correct Installation Procedure—page 1-8

Note – See “Common Definitions” in the User Guide for an explanation of important

RAID Manager terms.

About this Guide

The Sun™ StorEdge™ RAID Manager 6.2 Installation and Support Guide for Windows NT
provides installation and setup information for RAID Manager software version 6.2

in a Microsoft Windows NT environment. After you install the RAID Module

hardware, you should use this Installation and Support Guide to do the following:

■ Determine the hardware and software required to install the RAID Manager

software

■ Install the software

■ Set up software parameters

■ Identify storage management features unique to the NT operating system

■ Troubleshoot the installation and NT operation
1-1



After you install and set up the software, refer to the Sun StorEdge RAID Manager
User Guide for further information about using the software and maintaining the

RAID Modules.

Note – Some procedures in that book may be affected by information given in this

book (for example, see the information in this guide on creating and deleting LUNs).

About this Software

The software supports the following new/enhanced features:

■ Dynamic Expansion Capabilities. The Modify Group/LUN feature in the

Configuration application allows you to change the RAID Level, add more

capacity to drive groups, restore data storage space, and change the LUNs’

segment size.

Note – The new dynamic capacity options require controller firmware level 3.0 or

higher.

■ Performance Monitor. This new feature in the Status application allows you to

monitor I/O activity on selected controllers and LUNs for a selected RAID

Module while it is in use. This allows you to gather information that may be

useful in evaluating system performance and determining possible methods for

improvement.

■ Weekly auto parity check.

Additionally, the software continues to support the features from the 6.01 version:

■ Support of new configuration. In addition to the single host connection into the

RAID Modules, we now support an independent controller configuration (two

different SCSI hosts, each connected to a different one of two controllers in the

same RAID Module). See the User Guide for more details.

■ RAID Module selection enhancements (included in a new Select Module
option):

■ Support for assigning a user-supplied name to a RAID Module and also

providing comments for easier identification.

■ Ability to easily remove a RAID Module and its association to the storage

management software.

■ A RAID Module selection window that allows you to select a RAID Module

before you enter an application.
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■ A Find feature to easily select a RAID Module from a list.

■ Additional battery management functions via the raidutil command line. (For

more information, read the raidutil help file.)

■ Additional failure types detected and appropriate recovery procedures added in
the Recovery Guru .

■ Several enhancements to caching features:

■ The write caching operating status is now displayed in the caching parameters

option and in Module Profile → LUNs to let you know when write caching

has been enabled but is currently not active.

■ Module Profile → Controllers now includes the microprocessor cache

size of the controller.

■ Support for Windows NT Server 4.0 and Windows NT 4.0 Enterprise Edition.

Understanding the Restrictions

Note – Be sure to read the Release Notes: Sun StorEdge RAID Manager 6.2 for Windows
NT and any readme file on the installation media. They may contain important

information that was not available at the time this Installation and Support Guide was

prepared.
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Restrictions for Windows NT

TABLE 1-1 Windows NT Restrictions and Notes (1 of 3)

Restriction/Note Application Workaround

The storage management

software is not certified for use

with the 2.x version drivers for

the Adaptec host adapter.

The Adaptec driver 1.25c is

unreliable in the event a cable is

pulled.

Installation

and Setup

If you are using the Adaptec host adapters, use only

the models and drivers described in Appendix A

“Specifications”.

If you have a data path problem and find a cable

disconnected, reconnect it and run Recovery
Guru/Health Check . If the data path problem is

still reported, you may have to restart the operating

system.

The SymArray driver must be

loaded before the Windows NT

SCSI class driver or RDAC will

not work.

Installation

and Setup

None. The installation procedure sets up the

SymArray driver to load before the native NT SCSI

class driver. This is necessary to provide RDAC

protection in the event of a connection failure. Note

that this means that internal SCSI drives appear

after RAID Module drives in the Disk Administrator

utility. Also, “sticky” drive letters must be assigned

before the storage management software is loaded.

Care must be taken when using applications that

expect the internal SCSI drives to be mapped first

(see also “Accessing Raw Partitions” on page 6-5). If

you require that the NT SCSI driver be loaded first,

RDAC must be disabled.

If you want to use a RAID

Module as a boot device (that is,

install the Windows NT operating

system and the storage

management software on LUN 0

of the RAID Module), you must

prepare the host machine to boot

from the module before installing

any software.

Note: The storage

management software

has been tested with the

RAID Module as the boot

device only for a single

host-RAID Module

configuration.

Installation

and Setup

Follow the guidelines in Chapter 3 “Installing the

Boot Device on a RAID Module”.

Caution: If you use the RAID

Module as a boot device, you must

never delete LUN 0 or use File →
Reset Configuration
(Configuration application) or

you will lose your boot device and

operating system.
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RDAC failover does not work

during system dump if the

dump/swap device is a RAID

Module LUN different from the

LUN used for the boot device.

Installation

and Setup

Do not create a RAID Module LUN having only

dump/swap areas. It is acceptable to put the dump/

swap area on the same LUN as the boot device.

Do not use Microsoft’s Network

Monitor service with the storage

management software.

Monitoring the network

connections with this service can

result in problems, such as blue

screens.

Installation

and Setup

If you have the Network Monitor service installed,

stop it before using the storage management

software:

1. Select Control Panel → Services .

2. Highlight the Network Monitor service.

3. Select Stop .

The raidutil command does

not always generate an error

message when an operation fails.

For example, using raidutil
-R to reset the controller battery

age fails if LUN 0 has not been

created; however, there is no error

message.

General Anytime you use raidutil to perform an

operation, it is a good idea to verify that the

operation was completed successfully. For example,

after creating LUNs, you might want to use the lad
command to verify your configuration.

TABLE 1-1 Windows NT Restrictions and Notes (2 of 3)

Restriction/Note Application Workaround
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Hardware and Software Requirements

Before installing the storage management software, make sure that you have the

following components installed:

■ Hardware Configuration—page 1-7

■ Operating System—page 1-7

■ Host Adapters—page 1-7

■ Checking the Hardware—page 1-7

You can not reliably change font

size in the storage management

software’s displays.

General None.

Selecting certain operations may

result in an error message

indicating that I/Os were

occurring or filesystems were

present on the selected RAID

Module.

This occurs when a second

application/option requests

exclusive access to LUNs and

Windows NT drive letters that are

already locked by another

operation.

Configuration,

Recovery,

Maintenance/

Tuning

1. Wait for any operation that requires exclusive

access to finish before performing another

operation on the affected RAID Module or drive

group/LUNs.

2. If no other storage management operations are

running, then some other Windows NT

application may be using/displaying the drive

letters. If you suspect this is the case, close other

Windows NT applications, such as File Manager,

then reselect the storage management software

and try the operation again.

Operations requiring exclusive access include:

Delete for LUNs and File → Reset
Configuration (Configuration); formatting a LUN

with Options → Manual Recovery → Logical
Units (Recovery); and Firmware Upgrade →
Offline method (Maintenance/Tuning).

When creating or deleting LUNs,

or using File → Reset
Configuration , the Windows

NT host requires a restart in order

to see the configuration changes

properly.

Configuration Restart the host system anytime you create or delete

drive groups/LUNs.

TABLE 1-1 Windows NT Restrictions and Notes (3 of 3)

Restriction/Note Application Workaround
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Hardware Configuration

The following hardware is required:

■ At least an 800 x 600 resolution graphics card and mouse.

■ RAID Modules with Series 3 controller(s) (see Appendix A “Specifications” for a

list of supported controllers and firmware requirements).

■ A minimum controller firmware version depending on your controller model (see

TABLE A-3 on page A-3 for a list of firmware levels).

■ One or two host machines with a Host-RAID Module configuration supported by

this software (see “Host-RAID Module Configurations” on page A-1 for

information about supported configurations).

Operating System

Windows NT Server 4.0 operating system with Microsoft Service Pack 3 installed on

one of the following:

■ The host machines connected via SCSI cable to the RAID Modules, or

■ LUN 0 of a RAID Module if you want to use the module as a boot device. This

involves preparing the host system to boot from the RAID Module and installing

all your software.

Note – This software was tested with, and requires, Microsoft Service Pack 3.

Host Adapters

See “SCSI Host Adapters and Driver Revisions” on page A-2 for a list of the host

adapters tested with this software.

Checking the Hardware

Use the following checklist to make sure that the RAID Modules have been

connected correctly to your host system. If necessary, refer to the documentation

supplied with your RAID Module:

■ Are all cable connections correct and secure?

■ Is the termination correct and secure?
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■ Are the host-side IDs set properly? Each controller in each RAID Module must

have a unique host-side ID (that is, no two devices on the same SCSI Bus can have

the same host-side ID).

Tip – For the greatest level of I/O path protection, provide each controller in a

RAID Module with its own data path connection (that is, cable and host adapter)

into the host system.

Continue with the next section, “Selecting the Correct Installation Procedure”.

Selecting the Correct Installation
Procedure

The procedure you need to use to install the storage management software depends

upon your system’s configuration.

If You Want To: See

Install the software on a standard, Host-RAID

Module configuration.

Chapter 2 “Installing the Software on a

Standard Configuration”.

Install the software and make the RAID

Module the boot device.

Chapter 3 “Installing the Boot Device

on a RAID Module”.
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CHAPTER 2

Installing the Software on a
Standard Configuration

This chapter describes how to install or upgrade the storage management software

on a standard configuration (single host or independent controller configuration).

■ Where to Start—page 2-1

■ Upgrading from a Previous Installation—page 2-2

■ Assigning Drive Letters—page 2-3

■ Installing the Storage Management Software—page 2-5

Where to Start

Note – After you install and set up the software, refer to the Sun StorEdge RAID
Manager User Guide for further information about using the software and

maintaining the RAID Modules.

Are you upgrading from a previous version of the storage management software?

No Yes

Go to “Assigning Drive Letters” on

page 2-3.

Continue with the next section, “Upgrading

from a Previous Installation”.
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Upgrading from a Previous Installation

If you are upgrading from a previous version of storage management software, read

the following notes and use the current version of the storage management software

to perform the tasks given in TABLE 2-1 on page 2-3.

Note – rmparams and rmscript.bat files — During the upgrade/installation

procedure, your current rmparams and rmscript.bat files will be saved as

rmparams.ori and rmscript.ori . You can refer to these old files after installation

to determine if you want to customize the new files with any changes you may have

made. See “Changing the rmparams File” on page 5-6 and “Setting up Scriptable

Notification Options” on page 5-8. Do not copy the old files over the new; doing so

may destroy new parameters or script that was installed with the new version.

Upgrading from RAID Manager 6.00 — If you are upgrading from RAID Manager

6.00, the RAID Module numbers/names will change. Any labels that you have

placed on your RAID Modules will not correspond to the list of modules in the new

version of this software. In this new version, the module name is derived from the

name of the host machine where the storage management software is installed.

RAID Manager 6.00 labeled the modules “RAID Module XX”; the new version labels

them “hostname_XXX”. For example, if the host machine running this software is

called “sonne,” a module connected to the host would be named “sonne_XXX” (see

“Module Names” on page 6-2).
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Assigning Drive Letters

To ensure RDAC functionality, the installation procedure loads the SymArray driver

before the native NT class driver. However, this means that the system will see the

RAID Module’s LUNs first, before it sees any local SCSI drives, and will assign drive

letters accordingly. Therefore, before you install this software, you must have “sticky”

drive letters assigned to your existing local drives.

Tip – The storage management software can not be installed unless drive letters are

assigned to existing drives.

TABLE 2-1 Upgrading the Storage Management Software (Standard Installation)

Task to Perform Why Perform This Task?

1. From any RAID Manager application, select File →
Save Module Profile .

2. Make sure that All information types is selected,

and select OK.

Tip: Be sure to save this information file to the

same disk drive where the storage management

software is installed (such as, c:\ ). However,

you should place it in a different directory than

the software’s installation, so that this file is not

removed during the installation procedure.

To retain a copy of your current configuration

for each RAID Module and the current

module names. This copy can be used for

reference, but cannot be used to

automatically reload the configuration.

3. Exit the storage management software completely,

making sure the previous version is not currently open

or running.

To avoid problems with overwriting or

deleting old files during installation.

4. Continue with “Installing the Storage Management

Software” on page 2-5.

To upgrade to the new version.
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Use the following procedure to assign “sticky” drive letters:

1. Start Disk Administrator (select Start → Programs → Administrative Tools
→ Disk Administrator ) and view the disk configuration on your system. Check
the number of partitions.

2. If you have at least two partitions (the boot partition and one other partition) and
both of the following conditions apply:

■ The last partition you created was created with Disk Administrator, and

■ The partition has a drive letter assigned and has a status of “Unknown” or has

a file system on it (that is, it has a status other than “Unformatted”).

You are finished with this procedure; continue with “Installing the Storage

Management Software” on page 2-5. If both conditions do not apply, proceed to

Step 3.

3. Create a new partition.

a. Select a drive containing some free disk space.

b. Select Partition → Create . The partition is created (a drive letter is

assigned and the partition status is “Unformatted”).

c. Select Partition → Commit Changes Now. The partition status changes to

“Unknown,” and sticky drive letters are assigned to all your existing

partitions.

4. Continue with the next section, “Installing the Storage Management Software”.

If you have 2 or more partitions: If you have only one partition:

Go to Step 2. Go to Step 3.
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Installing the Storage Management
Software

Use the following procedure to install the storage management software in a

standard configuration.

Tip – You must have administrator privileges to access this software. This

installation procedure requires a restart of the operating system. Therefore, make

sure that other users are not on the system while you are installing this software.

If you are using the independent controller configuration, you must perform this

procedure on both hosts.

In the following examples, c: is designated as your boot drive and d: is designated

as the CD-ROM device drive. Be sure to select the correct drives for your system.

1. Insert the Installation CD into your CD-ROM drive.

2. To begin the installation program:

a. Select Start → Settings → Control Panel → Add/Remove Programs .

b. Select Install and follow the instructions on the screen.

c. Select Browse to find the drive containing the CD you are installing.

d. When you see d:\Raidmgr\setup.exe , select Finish .

3. Follow the instructions on the screen to complete the installation procedure.

Tip – During installation, you will be prompted to define the directory path where

you want this software installed; the default path is \program files\Raidmgr on

your boot drive. If you are defining your own directory path, do not use special

characters (such as #, $, or +) for the directory name. For the purpose of providing

examples of the installation requirements, this Installation Guide will refer to the

default directory on drive c: .
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4. When installation is completed, remove the CD and restart the system.

Note – If you are not using the A3x00 or A1000 as a boot device, the SCSI BIOS

must be disabled. Refer to your adapter’s Installation Manual for information about

disabling the BIOS.

5. Verify that the storage management software is installed and the Disk Array
Monitor service is running:

a. Select Start → Programs . Raid Manager should appear in the list.

b. Select Start → Settings → Control Panel → Services . The Disk
Array Monitor should be running if this service’s status is Started.

c. Select Close to exit this dialog box.

6. Continue with Chapter 4 “Initial Startup Procedures”.
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CHAPTER 3

Installing the Boot Device on a RAID
Module

This chapter describes how to install or upgrade the storage management software

on a RAID Module boot device.

■ Where to Start—page 3-1

■ Upgrading from a Previous Installation—page 3-1

■ Preparing the New Installation—page 3-3

■ Installing the Storage Management Software—page 3-6

Where to Start

Are you upgrading from a previous version of the storage management software?

Upgrading from a Previous Installation

If you are upgrading from a previous version of storage management software, read

the following notes and use the current version of the storage management software

to perform the tasks given in TABLE 3-1 on page 3-2.

No Yes

Go to “Preparing the New Installation” on

page 3-3.

Continue with the next section, “Upgrading

from a Previous Installation”.
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Note – rmparams and rmscript.bat files — During the upgrade/installation

procedure, your current rmparams and rmscript.bat files will be saved as

rmparams.ori and rmscript.ori . You can refer to these old files after installation

to determine if you want to customize the new files with any changes you may have

made. See “Changing the rmparams File” on page 5-6 and “Setting up Scriptable

Notification Options” on page 5-8. Do not copy the old files over the new; doing so

may destroy new parameters or script that was installed with the new version.

Upgrading from RAID Manager 6.00 — If you are upgrading from RAID Manager

6.00, the RAID Module numbers/names will change. Any labels that you have

placed on your RAID Modules will not correspond to the list of modules in the new

version of this software. In this new version, the module name is derived from the

name of the host machine where the storage management software is installed.

RAID Manager 6.00 labeled the modules “RAID Module XX”; the new version labels

them “hostname_XXX”. For example, if the host machine running this software is

called “sonne,” a module connected to the host would be named “sonne_XXX” (see

“Module Names” on page 6-2).

TABLE 3-1 Upgrading The Storage Management Software (Boot Device Installation)

Task to Perform Why Perform This Task?

1. From any RAID Manager application, select File →
Save Module Profile .

2. Make sure that All information types is selected,

and select OK.

Tip: Be sure to save this information file to the

same disk drive where the storage management

software is installed (such as, c:\ ). However, you

should place it in a different directory than the

software’s installation, so that this file is not

removed during the installation procedure.

To retain a copy of your current configuration

for each RAID Module and the current

module names. This copy can be used for

reference, but cannot be used to

automatically reload the configuration.

3. Exit the storage management software completely,

making sure the previous version is not currently open

or running.

To avoid problems with overwriting or

deleting old files during installation.

4. Continue with “Installing the Storage Management

Software” on page 3-6.

To upgrade to the new version using the

existing RAID Module boot device.
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Preparing the New Installation

If you want to use the RAID Module as a boot device (that is, install the Windows

NT operating system and the storage management software on LUN 0 of the RAID

Module), you must prepare the module and the host machine before installing any

software. Use the following guidelines along with the appropriate host machine

documentation.

If you need more information about RAID Modules, drive groups, or logical units,

see the “Common Definitions” section in the User Guide or the Online Help glossary.

Caution – If the RAID Module you want to assign as a boot device has a single-

controller, dual controllers on the same host bus, or an independent controller

configuration, you do not have RDAC failover protection. If the boot-path controller

fails or has connection problems, it could result in the loss of your boot device. For

this reason, you should not use a controller with any of these configurations as a

boot device.

Also, if you use the RAID Module as a boot device, you must never delete LUN 0 or

use Reset Configuration (in the Configuration application) or you will lose

your boot device and operating system.

In the independent controller configuration, only one host machine can boot because

only one controller will own LUN 0.

Tip – See “Boot Device Host Adapters” on page A-2 for a list of the host adapters

that support RAID Modules as boot devices.

You must have administrator privileges to access this software. This installation

procedure requires a restart of the operating system. Therefore, make sure that other

users are not on the system while you are installing this software.

You must use LUN 0 as the boot device because the boot device must be the first

logical device the Windows NT system sees. In addition, the host machine names

drive c: as the first device it sees at startup (boot).

For best results, make sure that LUN 0 is a RAID Level 1, 3, or 5 LUN to ensure data

protection for the drive group.
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Prepare the RAID Module

1. Using RAID configuration software (such as RAID Manager for DOS), configure
LUN 0 on the RAID Module, or verify that your module’s current configuration (or
factory default configuration) for LUN 0 will be sufficient.

For Windows NT, LUN 0 needs to be a maximum of 4 GB, or you must use Windows

NT (during its installation) to create a partition no larger than 4 GB on the LUN.

2. Make sure that there is at least one other configured LUN on the RAID Module. If
not, use DRM to create one (you will need an additional LUN to assign drive
letters later in the installation procedure).

3. Continue with the next section, “Prepare the Host Machine”.

Prepare the Host Machine

1. Consult your host system and host adapter documentation for detailed
procedures. Make sure that the first host adapter with enabled BIOS is connected
to the default boot path and that the next host adapter with enabled BIOS is
connected to the alternate boot path.

Tip – You should begin the Windows NT installation in the next step from floppy

diskette because you may need to manually install drivers for your host adapters

during the installation process.

2. On the host machine, install the Windows NT operating system, and follow the
setup procedures provided on screen. (See “Operating System” on page 1-7 and
“SCSI Host Adapters and Driver Revisions” on page A-2 for information about
the Service Pack and host adapter drivers used for testing.)

After the installation is completed, Windows NT automatically shuts down and

restarts.

3. From the root directory, view the Windows NT boot.ini file to verify that the
default ARC (Advanced RISC Computing) name entry begins with a “multi ”
designator. You should see an entry similar to the following example:

multi(0)disk(0)rdisk(0)partition(1)\WINNT=”Windows NT Server Version
4.00”

Note – If you do not see the multi designator, return to Step 1 of this procedure to

verify that the BIOS is enabled properly.

4. Continue with the next section, “Assigning Drive Letters”.
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Assigning Drive Letters

To ensure RDAC functionality, the installation procedure loads the SymArray driver

before the native NT class driver. However, this means that the system will see the

RAID Module’s LUNs first, before it sees any local SCSI drives, and will assign drive

letters accordingly. Therefore, before you install this software, you must have “sticky”

drive letters assigned to your existing local drives.

Tip – The storage management software can not be installed unless drive letters are

assigned to existing drives.

Use the following procedure to assign “sticky” drive letters:

1. Start Disk Administrator (select Start → Programs → Administrative Tools
→ Disk Administrator ), and view the disk configuration on your system.
Check the number of partitions.

2. If you have at least two partitions (the boot partition and one other partition) and
both of the following conditions apply:

■ The last partition you created was created with Disk Administrator, and

■ The partition has a drive letter assigned and has a status of “Unknown” or has

a file system on it (that is, it has a status other than “Unformatted”).

You are finished with this procedure; continue with “Installing the Storage

Management Software” on page 3-6. If both conditions do not apply, proceed to

Step 3.

3. Create a new partition (either on a local drive or on a RAID Module LUN).

a. Select a drive containing some free disk space.

b. Select Partition → Create . The partition is created (a drive letter is

assigned and the partition status is “Unformatted”).

c. Select Partition → Commit Changes Now. The partition status changes to

“Unknown,” and sticky drive letters are assigned to all your existing

partitions.

4. Continue with the next section, “Installing the Storage Management Software”.

If you have 2 or more partitions: If you have only one partition:

Go to Step 2. Go to Step 3.
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Installing the Storage Management
Software

Note – In the following examples, c: is designated as your boot drive and d: is

designated as the CD-ROM device drive. Be sure to select the correct drives for your

system.

1. Insert the Installation CD into your CD-ROM drive.

2. To begin the installation program:

a. Select Start → Settings → Control Panel → Add/Remove Programs .

b. Select Install and follow the instructions on the screen.

c. When you see d:\Raidmgr\setup.exe , select Finish .

3. Follow the instructions on the screen to complete the installation procedure.

Tip – During installation, you will be prompted to define the directory path where

you want this software installed; the default path is \program file\Raidmgr on

your boot drive. If you are defining your own directory path, do not use special

characters (such as #, $, or +) for the directory name. For the purpose of providing

examples of the installation requirements, this Installation Guide will refer to the

default directory on drive c: .

4. When installation is completed, remove the CD and restart the system.

5. Verify that the storage management software is installed and the Disk Array
Monitor service is running:

a. Select Start → Programs . Raid Manager should appear in the list.

b. Select Start → Settings → Control Panel → Services . The Disk
Array Monitor should be running if this service’s status is Started.
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6. Are you using a single-controller or independent controller RAID Module as the
boot device?

Testing Controller Failover

Caution – Do not perform the procedure in this section if you have used a single-

controller or independent controller RAID Module as the boot device. Failing the

controller in these configurations will cause you to lose your boot device. For this

reason, these configurations are not recommended for using a module as boot

device. If you are using one of these configurations, skip this section and go to

Chapter 4 “Initial Startup Procedures”.

With the storage management software installed, verify that the alternate boot path

works in a controller failover scenario. For best results, make sure that there is no

I/O going to the boot module during this procedure.

Note – For more complete information about the fail-over procedure described here,

see the Recovery chapter in the User Guide.

1. Select Start → Programs → Raid Manager .

2. Select the Recovery application.

3. Select the RAID Module that you created as the boot device.

4. Select Recovery Guru/Health Check to verify that the RAID Module is
Optimal (that is, it has no component or data path problems).

Tip – If you see any Failure type reported, select Show Procedure and follow the

instructions provided to correct the problem. When the problem is corrected, select

Recovery Guru/Health Check again to verify the module is now Optimal.

5. Select Options → Manual Recovery → Controller Pairs .

6. Highlight the controller you created as the default boot path device and select
Place Offline .

No Yes

Continue with the next section, “Testing

Controller Failover”.

Go to Chapter 4 “Initial Startup

Procedures”.
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7. When the controller is Offline, select Recovery Guru/Health Check . You
should see an Offline Controller for the module. Do not fix the problem at this
time.

8. Exit the storage management software.

9. Shut down and restart Windows NT.

10. Do you see the boot menu when the operating system restarts?

11. Does the Windows NT system restart?

12. Start the storage management software.

13. Select the Recovery application.

14. Select the RAID Module you created as the boot device, and select Recovery
Guru/Health Check . You should see an Offline Controller for the module.

15. Select Show Procedure and follow the instructions provided.

16. When the recovery procedure is completed, select Recovery Guru/Health
Check again to verify that the module is now Optimal.

17. Select the Maintenance/Tuning application.

18. Select the RAID Module that you created as the boot device, and then select LUN
Balancing . Verify that the default boot-path controller owns LUN 0. If it does
not, change the ownership now (see the “Balancing LUNs” section in the User
Guide for more information).

19. Continue with Chapter 4 “Initial Startup Procedures”.

No Yes

Return to Step 1 in “Prepare the Host

Machine” on page 3-4 to verify the host

adapter’s BIOS is properly enabled.

Select the default boot path and continue

with Step 11.

No Yes

There is a problem with the boot.ini file

entry. Return to Step 1 in “Prepare the Host

Machine” on page 3-4 and consult your

Microsoft documentation.

Continue with Step 12 to restore the default

boot path controller.
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CHAPTER 4

Initial Startup Procedures

This chapter contains the following procedures to ensure that the storage

management software operates properly and to determine if your system

configuration meets your needs:

■ Starting the Software—page 4-1

■ Setting up Independent Controllers—page 4-2

■ Assigning Names to the Modules—page 4-3

■ Verifying and Upgrading the Controller Firmware—page 4-3

■ Setting the NVSRAM Values—page 4-8

■ Running the Recovery Guru/Health Check—page 4-9

■ Determining the Current Configuration—page 4-13

■ Determining whether any Changes are Necessary—page 4-18

■ Configuring RAID Modules—page 4-22

■ What’s Next?—page 4-23

Starting the Software

Tip – You must have administrator privileges to access this software.

1. Start Windows NT if it is not already running.

2. Start the RAID Manager software. Select Start → Programs → Raid Manager .

3. The application names appear under Raid Manager: Configuration ,
Maintenance and Tuning , Recovery , and Status . For a description of some
key terms used in the applications, see the “Common Definitions” section in the
User Guide or the Online Help glossary.
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4. Do your modules have an Independent Controller configuration?

For a definition of the Independent Controller configuration, see “Host-RAID

Module Configurations” on page A-1.

Setting up Independent Controllers

If your RAID Modules are using an Independent Controller configuration, you need

to perform the procedure below to indicate the configuration to the storage

management software.

1. Start any storage management software application.

2. When the Module Selection screen appears, highlight the module that has
independent controllers, and select Edit.

3. Click the box next to “Independent Controllers?” and select OK.

You return to the main Module Selection screen, and the “Indep. Cntrls?” column

now says Yes.

4. Assign names to the modules, if desired, and add any comments (such as location
details or other unique information to further clarify the module name).

Note – If you upgraded the storage management software from version 6.00, the

RAID Module names may have changed from RAID Module XX to hostname_XXX.

Using the Module Profile you saved at the beginning of the upgrade installation

process, reassign the original names, if desired.

5. Repeat this procedure for all modules using this configuration.

6. Continue with “Verifying and Upgrading the Controller Firmware” on page 4-3.

No Yes

Go to “Assigning Names to the Modules”

on page 4-3.

Continue with the next section, “Setting up

Independent Controllers”.
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Assigning Names to the Modules

The installation procedure assigns default names to each RAID Module (in the form

hostname_XXX). You can assign other names to the modules, if desired, to aid in

identifying them.

Note – If you upgraded the storage management software from version 6.00, the

RAID Module names may have changed from RAID Module XX to hostname_XXX.

Using the Module Profile you saved, reassign the original names, if desired.

If you do not want to assign names to the modules at this time, continue with the

next section, “Verifying and Upgrading the Controller Firmware”. Otherwise,

perform the following procedure:

1. Start any storage management software application.

2. When the Module Selection screen appears, highlight the module that has
independent controllers, and select Edit .

3. Assign a name to the module and add any comments (such as location details or
other unique information to further clarify the module name).

4. Perform this procedure on each RAID Module that you want to assign a name to.

5. Continue with the next section, “Verifying and Upgrading the Controller
Firmware”.

Verifying and Upgrading the Controller
Firmware

Note – The most recent controller firmware version and NVSRAM file are

documented in “Latest Versions” on page A-3. If your RAID Modules do not contain

the most recent version of controller firmware, you will need to download the

correct firmware version and new NVSRAM file to the RAID Module controllers

(including any previously installed RAID Modules).
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Use the following procedures to determine the current firmware level and to

download new firmware, if necessary.

Verifying the Controller Firmware Version

Note – If your RAID Modules have an Independent Controller configuration, be

sure to perform these steps from each host machine. In addition, be sure to check the

firmware level on all RAID Modules attached to the host system.

You can quickly see what controller firmware version a RAID Module’s controllers

have by using Module Profile:

1. Start the Configuration application.

The Module Selection screen appears. If you have more than one RAID Module

connected to your host system, each RAID Module appears in the list.

2. Select the RAID Module you want to check, then select Module Profile →
Controllers .

3. Verify that the firmware level is the most recent version. (See “Firmware
Specifications” on page A-3 for a list of the firmware levels and controllers
supported by this software.)

4. Select OKwhen finished viewing.

5. Check all the RAID Modules on your system.

6. Do all the controllers on your system have the required version of firmware?

7. Close all windows.

No Yes

You must upgrade to the most recent

version immediately. Continue with the

next section, “Upgrading the Controller

Firmware Version”.

Go to “Setting the NVSRAM Values” on

page 4-8.
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Upgrading the Controller Firmware Version

Note – For complete details on the Firmware Upgrade option, see the “Upgrading

Controller Firmware” procedure in the Maintenance/Tuning Chapter of the User
Guide.

Perform the following steps to download new controller firmware:

1. Copy the firmware files, the fwcompat.def file, and the NVSRAM files to the
\program files\Raidmgr\lib directory.

2. Determine whether you can upgrade the firmware using the Online (RAID
Module receiving I/O) or Offline (RAID Module not receiving I/O) method.

Note – If you need to download an NVSRAM file, you must use the Offline method

(because you will have to restart the RAID Module before the new settings take

effect). You must also use the Offline method if your RAID Modules have an

Independent Controller configuration.

If you must use the Offline method, make sure that you stop all I/O to the

controllers you are going to upgrade.

3. Start the Maintenance and Tuning application.

4. Select the RAID Module containing the controllers you want to upgrade. Select
All RAID Modules to download firmware to all controllers in all RAID
Modules.

5. Click on the Firmware Upgrade button or select Options → Firmware
Upgrade from the pull-down menus.

6. Read the Important Notes screen and then select OK.

7. A screen appears asking you to select the Online or Offline procedure. Select
either:

■ Online – to upgrade firmware while the selected RAID Module receives I/O.

■ Offline – to upgrade firmware when the selected RAID Module is not receiving

I/O.

8. After selecting Online or Offline , the screen displays “Verifying the controller
state” while the software checks the selected RAID Modules for restrictions based
on the type of firmware upgrade you selected. If there are no restrictions, a screen
like FIGURE 4-1 is displayed.
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FIGURE 4-1 Firmware Upgrade Screen

9. If you need to download both new NVSRAM files and upgraded firmware files,
you must download the NVSRAM files first, before downloading the new
firmware files. Depending on your needs, do one of the following:

Download an NVSRAM file? Download upgraded controller firmware?

Type its complete path information (see

“Latest Versions” on page A-3) in the Path

box and then select OK. Go to Step 11.

Continue with Step 10.

Click here to begin the download
after you have selected the firmware
files to load or entered the name of
the NVSRAM file in the path box.

Click here to cancel without
downloading any new files.

This screen displays the
compatible firmware files
found by fwcompat.def .
That program checks the
default subdirectory for files.
Highlight the version level
you want to download.

The path is updated to show
the files currently selected in
the Compatible
Files/Versions display. You
can also enter file names
here to download additional
files (such as an NVSRAM
file).

This display shows the controllers in the selected RAID Modules and their current firmware levels.
Make sure that both controllers are highlighted here if you want to download firmware to both
controllers.
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10. Highlight the firmware version level that you want to download and then select
OK.

You either receive notification that a problem occurred, or you have a final

confirmation that the upgrade process is about to begin.

11. Select OKand follow the upgrade progress. The upgrade will take approximately
5 minutes, although the Status bar may show 100% almost immediately.

Tip – Do not select any other options or exit the Maintenance/Tuning application

until the upgrade process is complete. You can, however, monitor the upgrade

progress.

A histogram for the selected RAID Module indicates the download progress of the

NVSRAM or firmware files. This graphic shows the amount of progress as a

percentage and starts over at 0% for each file, if you have more than one. If you

selected All RAID Modules, the module number is updated as each module begins

its upgrade process.

When the NVSRAM download or the firmware upgrade is finished, you see a

summary report indicating whether the upgrade was Successful or Failed. TABLE 4-1

shows the information this screen displays.

Note – If you selected All RAID Modules, it is possible that the upgrade was

successful for some modules, but not for others. The final summary report should

indicate which modules were not successful and give an appropriate cause. For

more information, see the User Guide.

12. After the download is completed, select OKto return to the Maintenance/ Tuning
screen.

TABLE 4-1 Firmware Confirmation Screen Elements

Screen Element Description

Summary Report for Files Lists the files used to upgrade the firmware. These are the files loaded in the

Path line when you selected files at the Compatible Files/Versions screen

(FIGURE 4-1 on page 4-6).

RAID Module Identifies the specific RAID Module.

Download Status Indicates whether the download process completed successfully. The status

will be either “Successful” or “Failed” (with a reason why the upgrade was

unsuccessful). See the User Guide if there are any Failed download statuses.
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13. Did you download an NVSRAM file or new firmware?

14. At the command line, type:

nvutil -vf

This utility checks and corrects any settings on all controllers in your RAID Modules

to ensure that certain settings in the NVSRAM are setup correctly for this software.

15. Establish the new NVSRAM settings:

■ If the RAID Module contains the boot device, you must shut down the system

and then turn the power to the RAID Module off and then on again to establish

the new NVSRAM settings.

■ Otherwise, turn the power to the RAID Module off and then on again to establish

the new NVSRAM settings.

16. Go back to Step 9 and download any new firmware files.

End of Procedure

Setting the NVSRAM Values

If the following condition applies, you need to change NVSRAM settings so that the

RAID Modules perform correctly on your configuration:

■ Your RAID Modules are not connected to a network

If your RAID Modules do not need updating, continue with the next section,

“Running the Recovery Guru/Health Check”. Otherwise, perform the following

procedure:

1. Determine which .def file you need to use.

The .def files are located in \program files\Raidmgr\lib directory. At this

time, you need to use:

■ networkoff.def — If the RAID Module has no network connections.

New Firmware NVSRAM file

You are finished with this procedure.

Continue with the next section, “Setting the

NVSRAM Values” on page 4-8

Continue with Step 14.
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Note – You will see other .def files in the directory. These files can be used to

restore the original NVSRAM settings.

2. From the command line, enter:

nvutil -vf def_file_name

where def_file_name is the name of the required .def file (determined in Step 1).

3. Turn the power to the RAID Module off and then on again to establish the new
NVSRAM settings.

4. Perform this procedure from each host attached to an affected RAID Module.

5. Continue with the next section, “Running the Recovery Guru/Health Check”.

Running the Recovery Guru/Health
Check

Use the following steps to ensure that all of the RAID Modules attached to your host

system are operational.

Note – Be sure to perform this step from each host machine if you are using the

Independent Controller configuration.

Use the following procedure to run the Recovery Guru/Health Check .

1. Start the Recovery application.

2. Select All RAID Modules to check all of the modules on your system.

3. A screen like FIGURE 4-2 is displayed.
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FIGURE 4-2 Recovery Main Screen

4. Click on the Recovery Guru/Health Check button or select Options →
Recovery Guru from the pull-down menus. The software checks all selected
modules for non-optimal statuses.

5. Were non-optimal statuses (exceptions) found?

No Yes

You are finished with this procedure.

Continue with the next section,

“Determining the Current Configuration”

on page 4-13.

A screen like FIGURE 4-3 is displayed.

Continue with Step 6.

Click here to start the
Recovery Guru/Health
Check on the selected
modules. Alternately, you can
select Options → Recovery
Guru .
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FIGURE 4-3 Recovery Screen/Exceptions Found

6. Highlight the first exception and click on Show Procedure for recommendations
on how to fix the problem (see FIGURE 4-4).

Click here to display information about the highlighted failure. This
information includes recovery information. See FIGURE 4-4 on
page 4-12 for a sample screen.

This area displays the results of
the check. If a non-optimal
status is found, highlight the line
and click Show Procedure for
recovery information

Click here for help.
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FIGURE 4-4 Recovery Procedure Screen

7. Print out the procedure, if desired.

8. Follow the procedure given to recover from the component failure.

9. Reselect Recovery Guru/Health Check .

10. Repeats Step 5 through Step 9 until all RAID Modules are Optimal.

11. Continue with the next section, “Determining the Current Configuration”.

The first part of this area gives detailed
status information about the failure. In
this case, the message indicates that
drive [1,0] has failed. A hot spare drive
has taken over for the failed drive and is
currently reconstructing. LUNs 0 and 3
are affected by this failure.

Select File here to print the information displayed in
the procedure screen, or to set up the printer before
printing. Select Edit to copy text to the clipboard.

The rest of this area gives information
about the cause of the failure and how
to recover from it. Read the instructions
carefully. If necessary, print them out by
selecting File → Print Topic from
the pull-down menus.

In this case, there is no action to take
until the reconstruction is finished. Then
you should run Health Check again for
information about replacing the failed
drive.

Although this looks like a standard Help
screen, these buttons are grayed out.
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Determining the Current Configuration

Now that you have successfully installed the software, you need to use it to identify

each RAID Module connected to your host system and determine the module’s

current configuration (number of drives, number of controllers, logical units, etc.).

Tip – Most RAID Modules come pre-configured with logical units already defined.

This logical unit configuration may or may not work for your particular

environment.

Be sure to perform this step from each host machine if using the Independent

Controller configuration.

The RAID Manager software has assigned a number for each RAID Module

connected to your host system. These designations are shown in the RAID Module

selection list near the top of each application’s screen (see FIGURE 4-5 on page 4-14).

Perform the following steps for each RAID Module to identify the module and

determine its current configuration. If you need a definition of a Drive Group, RAID

Module, or Logical Unit, see the “Common Definitions” section in the User Guide or

the Online Help glossary.

1. Use the following steps to view the current drive groups and logical units in a
RAID Module.

a. Select the Configuration application.

The Module Selection screen appears. If you have more than one RAID Module

connected to your host system, each RAID Module appears in the list.

b. Highlight the first RAID Module in the list, and select OK.

The main Configuration screen is displayed (see FIGURE 4-5). TABLE 4-2 on

page 4-14 describes the items in the display.
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FIGURE 4-5 Main Configuration Screen

TABLE 4-2 Configuration Display Columns (1 of 2)

Column Heading Explanation

Group/Ctl The controller (A or B) or drive group.

Drives The number of drives in the drive group.

Total (MB) The total capacity of the drive group, after accounting for RAID level.

Remaining (MB) The total capacity remaining in the drive group.

LUN The logical units (LUNs) in the drive group.

This is the currently
selected RAID Module.

This shows the RAID Module as a directory tree structure. At the top is
the RAID Module, followed by the controllers, then the drive groups owned
by the controller, and finally the logical units and drives in that drive group.
Clicking on the different structures changes the display on the right of the
screen.

This gives information
about the drive groups
and logical units in the
RAID Module. The
items displayed here
depend on what is
highlighted in the
directory tree display to
the left.

See TABLE 4-2 for a
description of the
elements in the display.

Shown currently is the
master display that is
presented when the
RAID Module itself is
selected.

These buttons may be active or grayed out,
depending on what RAID Module structure
is currently highlighted in the directory tree.
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c. View the current drive groups and logical units.

As you highlight an element in the Module Information display on the left of

the screen, the display on the right changes to show those elements. You cannot
select or highlight any item in right side of the display; it is information only.

2. Use the following steps to physically locate and label a RAID Module.

a. Click on the Locate Module button, select Module → Locate from the pull-

down menus, or right-click on a module or group item in the Module tree (if in

the Configuration application).

b. Click Start on the Locate Module screen. The activity lights flash on the drive

canisters in this module. Remember that the RAID Module is the entire unit
and not a particular set of drives.

c. Physically locate the RAID Module with the flashing activity lights.

d. Once you have identified the RAID Module, place a sticker label on it for

future reference.

The label should correspond to the name of the RAID Module (for example,

hostname_001, hostname_002, etc.).

e. Click Stop to stop the flashing of the activity lights.

Tip – It is very important that you save the profile of each RAID Module during

initial installation and any time you change your configuration. You can use this

information as a reference if you need to perform any recovery or maintenance tasks.

See Step 3.

Name/ID The name or ID of the controller, logical unit, or drive, depending on the display.

• Controller and logical unit names are assigned by the operating system and

can’t be changed.

• Drive IDs are the channel number and SCSI ID of the drives.

RAID Level The RAID level of the logical unit.

Capacity (MB) The capacity of the logical unit.

Status The current status of the logical unit. If a status other than Optimal appears here,

run Recovery Guru/Health Check to determine what the problem is, and, if

necessary, what action to take.

TABLE 4-2 Configuration Display Columns (2 of 2)

Column Heading Explanation
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3. Use the following steps to save and print a RAID Module’s profile information.

a. Select the desired RAID Module and then select File → Save Module
Profile .

A screen shows the different types of information you can save.

b. Make sure that All is selected (all of the buttons should be selected), and select

OKto save all of the types of information.

A screen display prompts you to enter a filename.

c. Enter an appropriate path and filename on the Selection line, and select OK.

The information is saved to the path and filename you specified.

d. Print the Module Profile information you saved in Step c using your host

system's printer utility.

4. Use the following steps to view a RAID Module’s profile. (Optional)

a. Select the desired RAID Module and then select Module → Profile .

A summary information screen appears (see FIGURE 4-6) showing information

about the controllers, drives, and logical units in the RAID Module.

b. Select Controllers , Drives , or LUNs for more detailed information about

these components.

c. Select OKto exit the profile information.
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FIGURE 4-6 Main Module Profile Screen

5. Use the following steps to view details on specific drives in a drive group.
(Optional)

a. Highlight the drive group or individual drives you want to locate.

b. Click on the List/Locate Drives button or select Options →
List/Locate drives from the pull-down menus.

c. Use the drive location information [x,y] provided in the list to physically locate

individual drives in the module.

[x,y] corresponds the channel number and SCSI ID of the specified drive in the

RAID Module. You can also select Locate to flash the drive’s activity lights in

the RAID Module.

d. Select OKto exit the drive information.

6. Repeat Step 1 through Step 3 (and Step 4 through Step 5, if desired) for each
RAID Module connected to your host system.

You should have enough information to understand the configuration for each RAID

Module.

Click here to view detailed
information about the
module controllers.

Click here to view detailed
information about the
module drives.

Click here to view detailed
information about the
module logical units.

Click here to exit this screen

This display gives information about the selected
module.
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7. Continue with the next section, “Determining whether any Changes are
Necessary”.

Determining whether any Changes are
Necessary

In the previous section (“Determining the Current Configuration”) you should have

performed the following tasks for each RAID Module connected to your host

system:

Now, you can determine whether you need to make any changes to the

configuration to meet the requirements of your environment.

Reviewed each module's current configuration (controllers, drives,

and logical units/drive groups).

Step 1 on page 4-13.

Identified each RAID Module using Locate Module , and then

placed a sticker label on it.

Step 2 on page 4-15.

Saved the Module Profile information to a file using File →
Save Module Profile , and then printed the information.

Step 3 on page 4-16.
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1. Use TABLE 4-3 and the Module Profile information you saved and printed to assist
you in determining whether any changes are necessary.

TABLE 4-3 Possible Parameters to Change (1 of 3)

Parameter Description Why Change? For More Details,

General Parameters

Controller Mode Applicable controller

modes are single active,

active/passive, or

active/active.

If you have an

active/passive controller

pair, you should consider

changing it to

active/active for best

performance.

• See the

Maintenance/Tuning

chapter in the User Guide.

• Use the Online help for

the

Maintenance/Tuning
application.

Auto Parity

Check/Repair

An automatic parity

check/repair process runs

each day or once a week at

a specific time.

Default is auto parity

disabled.

If you want to enable the

check/repair or change

the time when it runs.

Hot Spare Drives A hot spare drive is a drive

that acts as a standby in

case a drive fails in a RAID

1, 3, or 5 logical unit.

The hot spare adds another

level of redundancy to your

RAID Module.

If you want to create new

or additional hot spare

drives for added

protection.

• See the Configuration

chapter in the User Guide.

• Use the Online help for

the Configuration
application.

Polling Interval The array monitor checks

the RAID Modules

periodically looking for

events and failures.

The default is to check

every 5 minutes.

If you want to increase or

decrease the frequency of

the polling interval. If you

have a lot of modules,

you may need to increase

this interval because the

amount of time needed to

check and return results

can increase.

• See the Status chapter in

the User Guide.

• Use the Online help for

the Status application.
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Logical Unit Parameters

RAID Level Specifies how the data is

striped across the drive and

whether or not the drive

group has redundancy.

If the current RAID Level

is not appropriate for

your environment, or if

you need to change the

number of drives.

• See the Configuration

chapter in the User Guide.

• Use the Online help for

the Configuration
application.

Segment Size Specifies in 512-byte blocks

how much data is written to

one drive before data is

written to another drive in

the group.

If the segment size is not

appropriate for your

environment.

LUN Capacity Specifies in megabytes (MB)

how much capacity is

available on the logical unit.

If you want to increase

the capacity of the LUN.

Note: You will

have to delete the

LUN and recreate

it.

Number of

Drives in the

Drive Group

Specifies the number of

drives in the drive group.

Adding drives increases the

drive group’s capacity, but

not the capacity of the

LUNs within the drive

group.

If you want to add drives

to the drive group.

Note: You can

not reduce the

number of drives

in a drive group;

to reduce the

number of drives,

you must delete

the LUNs and

then recreate

them.

• See the Configuration

chapter in the User Guide.

• Use the Online help for

the Configuration
application.

TABLE 4-3 Possible Parameters to Change (2 of 3)

Parameter Description Why Change? For More Details,
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2. Continue with the next section, “Configuring RAID Modules”.

Caching

Parameters

Specifies the caching

parameters for each logical

unit.

If you want to enable or

disable any of these

parameters.

• If you are creating new
logical units, see the

Configuration chapter in

the User Guide or use the

Online help.

• To change caching

parameters on existing
logical units, see the

Maintenance/Tuning

chapter in the User Guide
or use the Online help.

LUN Assignment

and LUN

Balancing

Determines which

controller owns which

logical units or drive

groups.

To reassign or balance the

logical units and drive

groups between

controllers in an

active/active controller

pair.

• If you are creating new
logical units, see the

Configuration chapter in

the User Guide or use the

Online help.

• To change LUN

Assignments on existing
logical units, see the

Maintenance/Tuning

chapter in the User Guide
or use the Online help.

Reconstruction

Rate

Determines how quickly

reconstruction occurs on a

logical unit when a failed

drive is replaced.

To increase or decrease

the reconstruction

performance.

• See the Maintenance/

Tuning chapter in the User
Guide.

• Use the Online help for

the

Maintenance/Tuning
application.

TABLE 4-3 Possible Parameters to Change (3 of 3)

Parameter Description Why Change? For More Details,
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Configuring RAID Modules

Perform the following procedures to change the logical unit/drive group

configuration of your RAID Modules.

Configuring Logical Units on Your RAID Module

Use the Configuration application of the storage management software to view

the current logical unit configuration and to make any necessary changes.

Note – Refer to the User Guide for detailed information about using the

Configuration application. Also, you can make configuration changes after

completing the installation process. You don’t have to make all your changes now.

1. Select Start → Programs → Raid Manager → Configuration .

The main Configuration screen is displayed.

2. Set up the logical units with the desired drives, RAID Levels and parameters.

Tip – In Windows NT, you are limited to creating 8 LUNs. In addition, by default

the software is limited to 16 RAID controllers. If you have more than 16 controllers

attached to the host system, configure 16 controllers now, and then see “Controller

Limits” on page 5-1 after you complete the installation procedure for information

about customizing the installation to access the additional controllers.

Note – If you add, change, or delete logical units, you will need to restart your

system.

3. Continue with the next section, “Partitioning Logical Units and Assigning Drive
Letters”.

Partitioning Logical Units and Assigning Drive Letters

1. Use the Windows NT Disk Administrator to partition the logical units and assign
drive letters. Refer to your Windows NT Online help for further details.

2. Continue with the next section, “What’s Next?”.
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What’s Next?

Now that you have successfully completed the installation of the software, do one of

the following, as applicable:

■ If you want to set up SNMP notification or make other changes to support the

software, go to Chapter 5 “Customizing the Installation”.

■ Refer to the User Guide for detailed information about how to use each

application. For information specific to the NT operating system, refer to

Chapter 6 “Operating System Support” of this Installation and Support Guide.

■ For troubleshooting tips on common problems that you may encounter as you use

this software with the Windows NT operating environment go to Chapter 7

“Troubleshooting”.
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CHAPTER 5

Customizing the Installation

This chapter describes how to customize your software installation.

■ Controller Limits—page 5-1

■ Disabling the Module Selection Screen—page 5-2

■ Setting up SNMP Notification—page 5-2

■ Changing the rmparams File—page 5-6

■ Setting up Scriptable Notification Options—page 5-8

Controller Limits

Note – In order to change the number of available controllers, you must edit the

\program files\Raidmgr\rmparams file. Read this section and the “Disabling

the Module Selection Screen” and “Setting up SNMP Notification” sections in this

chapter before modifying the rmparams file so that you can make all your

rmparams changes at the same time.

At installation, the storage management software is limited to 16 RAID controllers.

This limit is determined by the System_MaxControllers parameter setting in the

rmparams file. If your system has more than 16 RAID controllers, you will need to

change the parameter in the rmparams file to reflect the actual value (see “Changing

the rmparams File” on page 5-6).
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Disabling the Module Selection Screen

Note – In order to disable the Module Selection screen, you must edit the

\program files\Raidmgr\rmparams file. Read this section and the “Controller

Limits” and “Setting up SNMP Notification” sections in this chapter before

modifying the rmparams file so that you can make all your rmparams changes at

the same time).

By default, the Module Selection screen is displayed every time you start a storage

management application. See the “Selecting A Module” section in the User Guide for

information about this screen.

If you want to disable this screen, you must change the System_DefaultModuleSelect

parameter in the rmparams file (see “Changing the rmparams File” on page 5-6).

Setting up SNMP Notification

Enabling SNMP Notification

Note – In order to enable or disable the SNMP notification option, you must edit the

\program files\Raidmgr\rmparams file. Read this section and the “Controller

Limits” and “Disabling the Module Selection Screen” sections in this chapter before

modifying the rmparams file so that you can make all your rmparams changes at

the same time).

This software can provide remote notification of RAID events to a designated

Network Management Station (NMS) using Simple Network Management Protocol

(SNMP) traps.
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Use the following procedure to set up the NMS, to enable or disable this notification

option for each host, and to understand the contents of an SNMP trap message.

1. Set up the NMS. You only need to set up your designated NMS once. Use the
following procedure to compile this software’s Management Information Base
(MIB) into your NMS.

Note – The MIB was written to standard version 1 SNMP syntax. It was designed

specifically for the RAID Manager software. It is not applicable to other vendors'

RAID products.

a. Copy the \program files\Raidmgr\rm6traps.mib file to the network

management station.

b. Follow the steps required by your specific network management station to

compile the MIB.

Note – For details on the required steps, consult your network administrator or the

documentation specific to the NMS product you are using.

2. Make sure that the host system is connected to the network with the NMS station.

3. Enable this notification on your host. You must edit three parameters in the
\program files\Raidmgr\rmparams file so that the software will know where
to direct the SNMP trap messages when a RAID Event occurs (see “Changing the
rmparams File” on page 5-6).

4. Save the rmparams file and copy it to the backup directory. It is critical that you
have a backup copy of this file.
Chapter 5 Customizing the Installation 5-3



Contents of an SNMP Trap Message

Refer to TABLE 5-1 for a description of the contents of an SNMP trap message.

Tip – If the trap type is anything other than informational, you should use the

Status or Recovery applications to get more information or specific instructions

on how to remedy the problem. Do not remove the SNMP message until the problem

has been corrected since most trap notifications associated with this software are not

persistent.

TABLE 5-1 Contents of an SNMP Trap Message

Item Description

Host IP Address The standard IP address dot notation for the host where the RAID Module is

attached.

Host Name The text name assigned to the host.

Trap Type There are four trap types:

• Informational — No failure has occurred. Information is provided that an

event, such as a logical unit creation, has occurred.

• Degraded Array — A subsystem component failure has occurred. The

module is still operational but now lacks redundancy in some area (for example, a

drive failure resulting in a degraded logical unit, a power supply failure, or a

failure of one controller in a controller pair).

• Failed Array — A failure has occurred that leaves a module or logical unit

unable to communicate. (For example, a failure of the controller in a single-

controller RAID Module or a multiple drive failure resulting in a dead logical

unit.)

• Critical — This is a small category of failures that may require timely

intervention to correct. (For example, the two-minute warning from an

uninterruptible power supply or a warning that write-back cache has been

disabled due to a low battery.)

Affected RAID Module Indicates which RAID Module had the event (for example, sonne_001).

Condition Description A brief description of the event.
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Disabling SNMP

Perform the following steps to disable this notification on your host and stop this

software from sending SNMP traps:

1. In the \program files\Raidmgr\rmparams file, change the value of the
SNMP_Action_Number line to 0 (see “Changing the rmparams File” on page 5-6).

2. Save the rmparams file and copy it to the backup directory. It is critical that you
have a backup copy of this file.

End of Procedure
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Changing the rmparams File

The \program files\Raidmgr\rmparams file stores several configurable options

available through this software. TABLE 5-2 on page 5-7 shows a list of the parameters

in the file that you may need to change.

Tip – Before you edit the rmparams file, make sure that you read the “Controller

Limits”, “Disabling the Module Selection Screen”, and “Setting up SNMP

Notification” sections in this chapter. Decide which of these parameters you want to

change and make all the changes at the same time.

If you installed an upgrade of the storage management software, you may want to

refer to the rmparams.ori file to determine if you want to make additional

customized changes to the new file. Remember, the new file contains new

parameters for this version, so do not replace it with the old file.

Most of the options in the rmparams file (other than the ones shown in TABLE 5-2 on

page 5-7) should not be changed except through the graphical user interface (GUI).

For more information about the rmparams file, read the text file about rmparams .

From the installation directory, type:

help rmparams

Because of the critical nature of the rmparams file, you should make a backup copy

of the file in a directory other than the installation directory before you modify the

current file. If this file becomes corrupted or missing, you should copy the backup

rmparams file to the installation directory to resume normal operation. Furthermore,

if you make any changes to this file directly or use the options in the GUI that write

to this file (such as log settings), always copy the new version of the file to the

backup directory once you are sure that the changes work.
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TABLE 5-2 Changeable Parameters in the rmparams File

Description When To Change How To Change

SNMP_Target_IP_Address=xxx.xx.xx.xx

Provides the SNMP IP Address for

remote notification.

If you want to enable

SNMP.

Change this value to the dotted

notation IP address of the network

management system where the MIB has

been compiled.

On most systems, this IP address can

also be a dotted notation multicast

address or broadcast address.

SNMP_Community_Name=NONE

Provides the community name to

be used for SNMP remote

notification.

If you want to enable

SNMP.

Add the community name.

The most commonly used community

name is public; however, your network

environment may require another

name.

SNMP_Action_Number=0

Indicates the SNMP trap

notification option you want to

use.

If you want to enable

SNMP.

Change this value to either 1 or 2.

1 will send SNMP traps to the

designated NMS station. 2 means that

all the relevant data is written to the

file trap.dat .

Tip: Setting this parameter to

0 will completely disable the

SNMP option.

System_DefaultModuleSelect=TRUE

Determines whether or not the

Module Selection screen is

displayed each time you open an

application.

If you want to disable the

Module Selection screen

(see “Disabling the Module

Selection Screen” on

page 5-2).

Change TRUE to FALSE.

System_MaxControllers=16

Determines the maximum number

of RAID Controllers supported by

this software.

If you have more than 16

RAID Controllers (see

“Controller Limits” on

page 5-1).

Change the 16 to the appropriate

number.
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1. Before making any changes to the rmparams file for the first time, save the
original file and copy it to the backup directory.

2. Make any necessary changes to the rmparams file using TABLE 5-2 as a guide.

3. Save the rmparams file, and copy it to the backup directory.

End of Procedure

Setting up Scriptable Notification
Options

The rmscript.bat file is accessed by the Status monitor and automatic parity

check whenever these utilities find an exception. By default, no action is taken;

however, you can edit this file to specify a set of actions to take when an error is

found.

For example, if you want to install third-party notification software to perform

various events (such as, faxing or paging), you would add the appropriate script for

each event near the end of this file (making sure the del %1 remains the last line in

the file). Consult the third-party’s software documentation for specific details.

Note – If you installed an upgrade of the storage management software, you may

want to refer to the rmscript.ori file to determine if you want to make additional

customized changes to the new file. Remember, the new file contains new script for

this version, so you must not replace it with the old file.

For more information, read the text file about rmscript.bat . From the storage

management software’s installation directory, type:

help rmscript
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CHAPTER 6

Operating System Support

This section contains information related to operating this software with the

Windows NT operating environment.

■ Operating System Information—page 6-1

■ Command Line Interface—page 6-7

■ Adding New RAID Modules to the Configuration—page 6-8

■ Uninstalling the Storage Management Software—page 6-8

Operating System Information

This section contains information about storage management software elements

unique to the Windows NT operating system. See “Understanding the Restrictions”

on page 1-3 for other important notes about using this software in an NT

environment.

■ Number of LUNs—page 6-2

■ Module Names—page 6-2

■ Controller/LUN Names—page 6-2

■ Redundant Controller Support (RDAC)—page 6-3

■ Creating Logical Units—page 6-5

■ Deleting Logical Units—page 6-5

■ Accessing Raw Partitions—page 6-5

■ The Background Monitor—page 6-6
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Number of LUNs

There are two limits on the number of logical units you can have.

■ Your host adapter has a maximum number of LUNs it can support. Consult your

host adapter documentation for more information.

■ Windows NT limits the maximum number of logical units (LUNs) per RAID

Module to eight (8) (whether the module has a single controller or redundant

controllers). Therefore, if you have a RAID Module with two active controllers,

the total number of LUNs between them cannot be more than eight.

Module Names

By default, module names are assigned in the order in which the system detects the

module. The default name displayed is derived from the name of the host machine

where the storage management software is installed (for example, hostname_001,

hostname_002, and so on).

The controllers and logical units within the module have unique device names. See

the next section, “Controller/LUN Names” for more information.

Controller/LUN Names

The storage management software uses device names in the form Drive#, where # is

a device number, to identify controllers and logical units (LUNs). These device

names appear in various screen displays, usually related to a controller’s

identification.

Note – These names do not match the disk# used in the Disk Administrator utility,

which represents configured logical units and corresponding filesystems.

The device numbers are assigned on a per-controller basis, eight to a controller,

representing the maximum number of LUNs allowed on a RAID Module in

Windows NT. The device numbers assigned to a controller depend (in descending

order) on the port, path, and SCSI ID of the controller.

For example, assume RAID Module 1 has only one controller: controller A (port 0,

path 1, SCSI ID 3). RAID Module 2 has two active controllers on different ports:

controller A (port 0, path 1, SCSI ID 2) and controller B (port 1, path 0, SCSI ID 1).

Device numbers are assigned to these controllers in groups of eight in the order they

are detected on the system:
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■ RAID Module 2, controller A (port 0, path 1, SCSI ID 2) uses device names Drive0

through Drive7. The controller is Drive0.

■ RAID Module 1, controller A (port 0, path 1, SCSI ID 3) uses device names Drive8

through Drive15. The controller is Drive8.

■ RAID Module 2, controller B (port 1, path 0, SCSI ID 1) uses device names

Drive16 through Drive23. The controller is Drive16.

Within the numbers assigned to a controller, the controller itself always uses the

lowest assigned number. The lowest numbered logical unit also uses this number.

After that, logical units are assigned device names sequentially, even if the logical

unit doesn’t exist. For example, if a controller is assigned device names Drive8

through Drive15, and contains logical units 0, 3, 4, and 6, the following device

names are used:

Note – In a redundant controller configuration, a maximum of 8 LUNs can exist

between the two controllers, even though 16 numbers are available.

Redundant Controller Support (RDAC)

The storage management software supports redundant controllers on a Windows NT

system using the Redundant Disk Array Controller (RDAC) driver. The RDAC

driver is part of the storage management software package and is installed

automatically.

For RAID Modules with redundant controllers, this host-based driver manages the

I/O data paths. If a component on the data path (cable, controller, host adapter, etc.)

fails and the host loses communication with a controller, the RDAC driver

automatically reroutes all I/O operations to the other controller.

FIGURE 6-1 on page 6-4 illustrates how RDAC provides this redundancy when the

host application generates a request for I/O to Controller A, but Controller A fails.

Use the information in the Legend to follow the I/O data path.

Module Element Device Name

Controller Drive8

LUN 0 Drive8

LUN 3 Drive11

LUN 4 Drive12

LUN 6 Drive14
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For more information about the redundant controller feature, see the User Guide.

FIGURE 6-1 Example of RDAC I/O Data Path Redundancy

Legend:

1. I/O request fails.

2. Failed I/O goes back to RDAC driver.

3. RDAC driver performs failover and transfers logical units to other controller

(controller B).

4. RDAC driver resends I/O request back down to controller B, where it is serviced.

(The host application is unaware of the transactions that have taken place to

complete the I/O.)
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Creating Logical Units

After creating logical units (LUNs) using the Configuration application, you have

to add them to the operating system. See your Windows NT documentation for

details on adding a drive. Remember each logical unit (not a drive group) is seen by

the operating system as one drive.

Note – You must restart Windows NT in order for it to recognize any configuration

changes (such as LUN creations and deletions).

Deleting Logical Units

Caution – If you are using the RAID Module as a boot device (Chapter 3), do not
delete LUN 0 or use File → Reset Configuration ; if you do, you will lose your

boot device!

Before deleting LUNs with this software or using File → Reset Configuration ,

you should stop I/Os to the affected RAID Module and then use the Disk

Administrator utility to delete any partitions and deassign drive letters associated

with those LUNs. If you do not do this first, registry information will be corrupted.

Note – You must restart Windows NT in order for it to recognize any configuration

changes (such as LUN creations and deletions).

Accessing Raw Partitions

Many database applications address raw partitions for their data. In the Disk

Administrator utility, the partition information for raw partitions is shown as

“Unknown.”

Caution – The order of these partitions could be rearranged, possibly causing data

corruption, whenever a dead LUN is present and the system is rebooted without

first restoring the LUN. (To Windows NT, rebooting with a dead LUN present is the

same as removing a physical drive and booting).
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Data corruption occurs because the raw partition's namespace in the registry that the

application is addressing has now been changed/moved. The application, however,

will continue to write to that partition/device as though it were the correct one. The

work-around for this is to be sure that all LUNs are Optimal and fully reconstructed

before running any utilities that re-address the raw partition namespaces

(rearranging their order in Disk Administrator).

The Background Monitor

The storage management software has a background monitor that automatically

polls all RAID Modules and checks for problems/events at a specified interval. If

any problems or events are detected, the information is written to the default log

file. This becomes an historical record of past component failures, general status

changes, and configuration changes.

The polling interval can be changed from the default of every five minutes. For best

results, use the default value or smaller to ensure that you are notified about

problems/events as close as possible to when they occur.

Caution – Setting this value too small could cause the check to affect system I/O

performance. However, setting this value too large could cause delayed notification

of serious problems.

Stopping the Disk Array Monitor Service

Caution – You should only stop this monitoring service if you are specifically

instructed to do so by the Recovery Guru , the troubleshooting documentation, or

your Customer Services Representative. However, doing so means that none of the

RAID Modules connected to the host will be checked during this time. Be sure to

restart the monitor when instructed.

1. Select Start → Settings → Control Panel → Services .

2. Highlight the Disk Array Monitor service.

3. Select Stop . When the status changes to Stopped, close the Services application.
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Starting the Disk Array Monitor Service

This background monitor automatically starts when you run the storage

management software. However, it will be necessary to manually start this process if

you have stopped it for some reason.

1. Select Start → Settings → Control Panel → Services .

2. Highlight the Disk Array Monitor service.

3. Select Start . When the status changes to Started, close the Services application.

When you have manually stopped the background monitor, you have not been

monitoring for some period of time. We recommend that you run Recovery Guru/
Heath Check to make sure that no problems have occurred while you had the Disk

Array Monitor stopped.

Command Line Interface

Although you can perform most necessary storage management tasks through the

storage management software’s graphical user interface there is a also a command

line interface that allows you to perform some of these tasks through the DOS

command line. For a list of these commands and their uses, see the “Command Line

Interface” chapter in the User Guide.

To access the help files for these utilities, type help filename from the command line

in the installation directory. For example, to read the file on the drivutil program,

from the installation directory, type:

help drivutil
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Adding New RAID Modules to the
Configuration

If you need to add new RAID Modules to your system after installing the storage

management software, use the following procedure to be sure that the storage

management software recognizes the new module and that the new module’s

configuration meets your needs.

1. Physically connect the RAID Module to your system. Consult the appropriate
hardware documentation for this procedure.

2. Close all open applications and restart Windows NT.

3. Go to Chapter 4 “Initial Startup Procedures to perform the following steps:

■ “Verifying and Upgrading the Controller Firmware” on page 4-3.

■ “Running the Recovery Guru/Health Check” on page 4-9.

■ “Determining the Current Configuration” on page 4-13.

■ “Determining whether any Changes are Necessary” on page 4-18.

■ “Configuring RAID Modules” on page 4-22.

Uninstalling the Storage Management
Software

If you are upgrading the storage management software, you do not need to use this

procedure first. The previous version’s files are removed or overwritten as needed.

Use the following procedure only if you want to remove the storage management

software from your system.

Tip – This procedure requires that you shutdown and restart the operating system.

Therefore, close all other applications and make sure that other users are not on the

system while you are uninstalling this software.
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1. If you do not intend to reinstall this software and you are not removing your
RAID Module from the system, you may need to download your original
NVSRAM file to restore your controllers’ configuration.

a. As a precautionary measure, you should begin the uninstall process by running
nvutil and executing rdacoff.def . This will ensure that the LUN
configurations residing on the A3x00 or A1000 will remain intact in the event
that you later reinstall the storage management software.

b. Obtain a copy of the correct NVSRAM values from your Customer Services
Representative (it will be part of the controller firmware’s release media).

c. Download the new NVSRAM values to the controllers in your RAID Modules
using the fwutil command-line utility.

d. If you set NVSRAM parameters during installation with the networkoff.def
file (see “Setting the NVSRAM Values” on page 4-8), you may want to run
networkon.def to restore these settings to their original values.

Caution – Do not restart the storage management software again after performing

Step 1, or the software will reset the NVSRAM values it needs to operate.

2. Select Start → Settings → Control Panel → Add/Remove Programs and
then scroll the list to find Raid Manager .

3. With Raid Manager highlighted, select Add/Remove .

4. At the “Uninstall software” screen, select Yes .

You will see screens indicating that this program is removing the appropriate

service, registry information, and files.

5. At the “Uninstall Complete” screen, select OKto shutdown and restart the
Windows NT system.

End of Procedure
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CHAPTER 7

Troubleshooting

This chapter describes the restrictions that apply when using this software and gives

information to help you solve problems that may occur. The last section gives

important information you may need when replacing failed controllers.

■ Introduction—page 7-1

■ Replacing Controllers—page 7-18

Introduction

The troubleshooting tables that follow provide probable cause and action to take for

specific problems you may have as you use the storage management software with

the Windows NT operating system.

Tip – If you cannot find the problem you are looking for, read the Release Notes: Sun
StorEdge RAID Manager 6.2 for Windows NT and consult the Online Help for

additional troubleshooting information. Also, see “Understanding the Restrictions”

on page 1-3 for additional information.
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Locating Solutions

To quickly find the solution you are looking for, use the following tables to locate the

problem you are having. It is possible for an entry to appear in more than one table:

■ “Category” — organizes problems into general use or specific option groups

(page 7-2).

■ “Component Search” — organizes problems by hardware components, such as

controllers, drives, modules, etc. (page 7-3).

■ “Application Search” — organizes problems for each storage management

application, including a group for options common to all applications (page 7-5).

■ “Software Search” — organizes problems by operating system, storage

management software, or command-line utility (page 7-7).

Category

TABLE 7-1 groups problems into sections for general use or specific options.

TABLE 7-1 Troubleshooting Entries Organized by Category

Category See Page

• “Configuration Application Problems” • page 7-8

• “Firmware Upgrade Problems” • page 7-9

• “General Problems” • page 7-10

• “Recovery Guru/Health Check Problems” • page 7-14
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Component Search

TABLE 7-2 organizes individual problems by hardware components (such as

controllers, drives, LUNs, RAID Modules, and so on).

TABLE 7-2 Troubleshooting Entries Organized by Component (1 of 2)

Component Problem See Details On

Batteries Age did not reset for both controllers page 7-12

Controllers Failed during alternate replacement page 7-10

Firmware upgrade failed page 7-9

LUN creation error after deleting all LUNs or

using Reset Configuration
page 7-8

Not visible to storage management software page 7-11

Not visible to either operating system or storage

management software

page 7-11

Passive, no LUNs owned after replacement page 7-17

Fans Failure detected after replacement page 7-14

Drives Activity lights don’t flash (Configuration →
List/Locate Drives )

page 7-8

All drives failed in a drive group page 7-17

Failed status, but LUN is Optimal page 7-15

Fault light comes on after replacing failed drive page 7-15

Fault lights lit (drives continue to fail) page 7-15

Missing information in Manual Recovery →
Drives screen

page 7-17

Number of drives incomplete or wrong during

LUN creation

page 7-8

Removed drive; no failure reported page 7-14

Status other than Optimal page 7-16
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LUNs Error message during LUN creation after deleting

all LUNs or using Reset Configuration

page 7-8

Less capacity shows than selected during

configuration

page 7-8

Missing information in Manual Recovery →
LUNs screen

page 7-18

Not visible to storage management software page 7-11

Number of drives incomplete or wrong during

LUN creation

page 7-8

Optimal LUN status with failed drives page 7-15

Reconstructing status appears, but no drives

replaced

page 7-16

Status other than Optimal page 7-16

Status remains Reconstructing page 7-17

RAID Modules Failure detected after replacing fan or power

supply

page 7-14

Listed after being removed page 7-12

Not visible to either operating system or storage

management software

page 7-11

Status other than Optimal page 7-13

Status doesn’t update after a recovery procedure page 7-18

Power Supplies Failure detected after replacement page 7-14

TABLE 7-2 Troubleshooting Entries Organized by Component (2 of 2)

Component Problem See Details On
7-4 RAID Manager 6.2 Installation & Support Guide for Windows NT • September 1998



Application Search

TABLE 7-3 organizes individual problems for each storage management application,

including a group for options common to all applications.

TABLE 7-3 Troubleshooting Entries Organized by Application (1 of 2)

Application Problem See Details On

common to any RAID

Manager application

Can’t select some options page 7-12

“Cannot secure access to LUNs” message page 7-13

Select Module lists a RAID Module removed

from the system

page 7-12

Status doesn’t update after a recovery

procedure

page 7-18

Configuration Less capacity shows than selected during

configuration

page 7-8

List/Locate Drives doesn’t work page 7-8

LUN creation error after deleting all LUNs

or using Reset Configuration
page 7-8

Number of drives incomplete or wrong

during LUN creation

page 7-8

Reset Configuration doesn’t work page 7-8

Status Reconstructing status appears, but no drives

replaced

page 7-16

Status remains Reconstructing page 7-17
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Recovery All drives failed in a drive group page 7-17

Controller mode is Passive, no LUNs owned

after replacement

page 7-17

Drive fault lights lit (drives continue to fail) page 7-15

Drive status other than Optimal page 7-15

Failed status, but LUN is Optimal page 7-15

Fault light comes on after replacing failed

drive

page 7-15

Failure detected after replacing fan or power

supply

page 7-14

LUN status other than Optimal page 7-16

Missing information in Manual Recovery
→ Drives screen

page 7-17

Missing information in Manual Recovery
→ Logical Units screen

page 7-18

Reconstructing status appears, but no drives

replaced

page 7-16

Recovery Guru takes a long time page 7-14

Removed drive; but Recovery Guru
doesn’t report a failure

page 7-14

Status doesn’t update after a recovery

procedure

page 7-18

Status other than Optimal page 7-13

Status remains Reconstructing page 7-17

Maintenance/Tuning Controller mode is Passive, no LUNs owned

after replacement

page 7-17

Firmware upgrade failed page 7-9

TABLE 7-3 Troubleshooting Entries Organized by Application (2 of 2)

Application Problem See Details On
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Software Search

TABLE 7-4 organizes individual problems by operating system, storage management

software, and command-line utility.

TABLE 7-4 Troubleshooting Entries Organized by Software

Software Problem See Details On

Storage Management “Cannot secure access to LUNs” message page 7-13

Can’t select some options page 7-12

Can’t start the software page 7-10

Controllers/LUNs not visible page 7-11

Controllers/RAID Modules not visible page 7-11

Failure detected after replacing fan or power

supply

page 7-14

“Not all files removed” message when

uninstalling the software

page 7-10

RAID Module listed after being removed page 7-12

Windows NT Controllers/RAID Modules not visible page 7-11

Command Line Batch file commands fail page 7-10

Battery age doesn’t reset for both controllers page 7-12
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Configuration Application Problems

This section describes problems that you may have as you use options in the

Configuration Application.

TABLE 7-5 Configuration Application Changes Troubleshooting

Number of Drives field (in the main Create LUN screen) show less than the number of drives in the unassigned drive group.

Cause: There could be failed or unresponsive drives in the unassigned drive group. Failed drives are not

available for configuration; therefore, they are not displayed in this list.

Less capacity shows than I selected during configuration.

When using 5 or more drives to create a LUN, you could see a capacity slightly less than you selected during

configuration; for example, you see 1.97 GB instead of 2 GB on a RAID 5, 9-drive LUN. This can occur

because the capacity you select is based on stripe size, which depends on segment size times the number of

drives.

List/Locate Drives → Locate doesn’t work.

Action: It is not possible to flash the drive activity lights for a particular drive group if any of the drives has

a status other than Optimal. For an explanation of possible drive statuses and recommended action to take,

see the Online help.

Cause: Use Module Profile to verify that all drives are Optimal and try again. If any of the drives are not

Optimal, select Recovery Guru\Health Check (in the Recovery application) to correct the problem.

Reset Configuration doesn’t work.

Caution: Any time you use Reset Configuration , you will lose all data on your
drives. Only select this option as a last resort if your configuration is inaccessible or you

want to start over. You will need to use Create LUN to re-configure your drive

groups/LUNs.

Cause: If this software detects any drives as removed or unresponsive, Reset Configuration will not

work. Also, if the selected RAID Module has an Independent Controller configuration, this option is grayed

out.

Action: Use Module Profile to verify that all drives are Optimal and that the controller is not in an

Independent Controller configuration (neither controller is marked Inaccessible). Try File → Reset
Configuration again.

LUN Creation error message is displayed after deleting all LUNs or using File → Reset Configuration .

Cause: Most likely the controller has 256 MB cache and requires a reset after deleting all LUNs/drive groups

before re-creating new LUNs/drive groups.

Action: Turn off power to the affected RAID Module. Turn the power back on and try the LUN creation

procedure again.
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Firmware Upgrade Problems

This section describes problems that you may have while upgrading firmware.

TABLE 7-6 Controller Firmware Upgrade Troubleshooting

Firmware upgrade does not complete successfully.

Cause: This should not happen unless you try to perform some other activity on the module while

upgrading controller firmware.

Note: If you are upgrading firmware to a redundant controller pair, the progress bar

reaches 50% very quickly after downloading a file to the first controller. However, it may

take another couple of minutes to reach 100% if it is downloading to a second controller in

the module. Do not assume the controller has hung unless the firmware upgrade has not

completed after ten minutes or so.

Action:
• To avoid this problem, wait for the controller firmware upgrade to be completed before selecting any other

option or exiting the Maintenance/Tuning application.

• If it occurs, turn off power to the RAID Module and turn it back on; then, immediately try to upgrade the

firmware again.

Tip: If you are not upgrading the firmware again immediately, check the firmware version

of the module’s controllers using Module Profile . The controller firmware could be in an

unusable state if some files completed the download process before the controller hung. In

this case, your module will not perform properly until the firmware is upgraded.
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General Problems

This section describes general problems that you could have in any RAID Manager

application.

TABLE 7-7 Troubleshooting Generally Applicable to all Applications (1 of 4)

Can’t start the software.

Cause: If the software does not load when you try to start it, the rmparams file may be corrupted or

missing from the installation directory (\program files\Raidmgr ).

Action: You may want to view the Windows NT Event Log (“Applications” log). This log might contain

specific information about missing files and/or executables.

1. Start Windows NT and try to start the software again. (See “Starting the Software” on page 4-1 if you

need more information about starting this software.)

2. If you had previously saved a backup rmparams file, copy it to the installation directory (default is

\program files\Raidmgr – be sure to select the appropriate directory on your system) and try to start

the software again.

Tip: The rmparams file is required for normal operation of this software’s applications.

Therefore, it is strongly advised that if you make any changes to this file, you should make

a backup by copying the edited file to another directory.

3. If you still cannot start the software, run the clean.bat -all script to delete certain .mnf , mutex , and

lock files that are associated with RAID Manager and could be hiding information from this software.

4. If you still cannot start the software, reinstall the software.

Controller failed while bringing its alternate Online.

Cause: You have a RAID Module with two controllers, one is Offline and the other is Online (Optimal).

When you bring the offline controller online, you could see the alternate controller Fail or go Offline.

Action: Bring the newly failed controller Online using the same procedure.

While uninstalling this software, “not all files were removed” message is displayed.

Cause: If you see this message after performing the uninstall procedure (page 6-8), the auto parity

check/repair service was probably running. The software has been successfully uninstalled; however, there

may be some files that were not removed from the installation directory.

Action: Delete any remaining files from the installation directory, then delete the directory.

Commands run in a batch file fail unexpectedly.

Cause: Utility commands such as fwutil or rdacutil -u that require a controller reboot may return

before the controller is ready to accept commands. If the next command is executed before the controller is

ready to accept commands, the controller will return an error status.

Action: Include a delay command in the batch file to allow enough time for the controller to finish its

action.
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Some controllers/logical units are not visible to the storage management software, but are visible to the host.

Cause: It is possible that controllers or logical units might not be visible to the storage management

software, but will remain visible to Windows NT. Any time an operation is being performed that requires

exclusive access to the logical units (LUNs), these LUNs may not appear on the screen except in the

application where the operation was initiated.

The software uses a file (\program files\Raidmgr\lunlocks ) to hide these LUNs from the other

applications, so that no other operations can be performed on them until the current operation is complete.

For example, if you started a format in the Recovery application, these LUNs show a “Formatting” status

in Recovery , but may not appear in any other application. Operations that require exclusive access include

Delete for LUNs and File → Reset Configuration (Configuration application); formatting a LUN

with Options → Manual Recovery → Logical Units (Recovery application); and Firmware
Upgrade → Offline method (Maintenance/Tuning application).

Should the utility/application holding the LUN lock come to an abnormal termination, these LUNs may

remain hidden from the other applications.

Action:
1. Wait for the operation to be completed, or perform operations on a different RAID Module.

2. If you still do not see controllers or LUNs that you know exist, do the following:

• Close all your applications and exit the storage management software completely.

• Run the clean.bat -all script to delete certain .mnf , mutex , and lock files that are associated with

RAID Manager and could be hiding information from this software.

3. Restart the application where you had the problem and verify that the controller/LUNs are now visible.

Some controllers/RAID Modules are not visible at all

Cause: If controllers or RAID Modules are not displayed and you know they exist, there could be some

faulty connection between the RAID Module and the host adapter/network card. It also possible that the

storage management software or your operating system doesn’t recognize the devices yet. Less likely, the

NVSRAM settings for the module’s controllers may not be set properly to run this software. Normally, these

settings are changed automatically during installation and any incorrect settings are detected and corrected

by the software.

Action:
1. Verify there is no problem on the data path:

• Check the interface cables and host-side IDs of the controllers. If they appear OK, turn off power to the

module, and turn it back on.

• Check the I/O connection cables for bent pins in the connectors, for connectors that are not on straight, or

for cables that are kinked or crimped. Select Recovery Guru/Health Check and follow the recovery

procedures for any component problem detected.

2. If you have replaced or added controllers/RAID Modules after installing this software, be sure to follow

the procedures for your operating system to recognize the new devices (see your operating system

documentation).

3. If you see a message (on the console) that incorrect NVSRAM settings have been fixed, immediately

restart the RAID Module so that the new settings can take effect. If you suspect that the NVSRAM

settings for the module’s controllers may not be set properly to run this software, use RAID Manager For

DOS to verify your NVSRAM settings or call your Customer Services Representative.

TABLE 7-7 Troubleshooting Generally Applicable to all Applications (2 of 4)
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A RAID Module that I have removed from my system is still listed.

Cause: The storage management software does not automatically remove modules from configuration; thus,

a module you remove will continue to be listed in the RAID Module Selection box and the Module Selection

screen.

Action: If you wish to remove a RAID Module, do the following:

1. Physically remove the module from your host system.

2. Choose Select Module .

3. Highlight the module you wish to remove.

4. Select Remove. The RAID Module no longer appears in the Module Selection screen or the RAID Module

Selection Box.

I cannot select some options.

Cause: Some options are grayed out or are unavailable because:

• The selected RAID Module does not support that option.

• The controller firmware version does not support that option.

• The option cannot be performed for the item you selected.

• The option is not active until you select some item.
• The option is no longer applicable because a maximum has been reached.

Action: Recheck your selection and try again.

For more specific information, see the Procedures section in the User Guide that describes the particular

option, or consult Online Help, “Why Are Some Options Grayed Out?”

Battery age did not reset for both controllers.

Cause: When using raidutil to reset a battery’s age, this command affects only one controller at a time.

Action: Perform the battery reset command (with raidutil ) for each controller in a RAID Module as

needed. For details, read the raidutil help file. From the storage management software’s installation

directory, type:

help raidutil

TABLE 7-7 Troubleshooting Generally Applicable to all Applications (3 of 4)
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“Cannot secure access to the LUNs” message is displayed (operations won’t run for a selected RAID Module).

Cause: Most likely a second application has requested exclusive access to the selected RAID Module when

some other application has already secured access. Many operations require exclusive access to the affected

drive group/LUNs until the operation is completed; this software “locks” these components to secure this

access. Also, if the affected LUNs are under some other software’s control, the storage management software

cannot gain exclusive access. Either this message is displayed, or the second request is denied and you see

an error message indicating that the module has I/Os occurring or that filesystems are present.

Operations requiring exclusive access include: Delete for LUNs and File → Reset Configuration
(Configuration application); formatting a LUN with Options → Manual Recovery → Logical
Units (Recovery application); and Firmware Upgrade → Offline method (Maintenance/Tuning
application).

Action:
1. Wait for any operation that has secured exclusive access to the LUNs to be completed before performing

another operation on the same RAID Module.

2. If no other storage management software operations are running, and you think another application may

be accessing the LUNs (from your operating system or third-party software), close the other application

and then reselect the storage management software and try again.

Component/module status other than Optimal.

Cause: Statuses other than Optimal can indicate many things and usually warrant attention because the

module is not operating in a normal condition. The most common causes are:

• At least one drive has failed.

• A drive has been replaced and is reconstructing.

• A logical unit is formatting.

• A controller has been placed offline or has failed.

• A module component (such as a power supply or fan) had failed.

Action: For Failed or Offline drives, Dead or Degraded logical units, or Dead controllers (or Offline

controllers that you did not place offline), select Recovery Guru/Health Check and follow the step-by-

step procedure it provides. For an explanation of the possible drive, LUN, or controller statuses and any

recommended action to take, see the Online help.

Tip: Do not rely only on logical unit (LUN) status information to determine if a recovery

procedure is necessary. For example, if you have hot spares configured for a RAID Module

and a drive fails, the hot spare takes over for the failed drive. Therefore, you have an

Optimal LUN with a failed drive. Depending on how many hot spares you have configured

for the module, you can have multiple failed drives and still have an Optimal LUN or only

a Degraded LUN.

TABLE 7-7 Troubleshooting Generally Applicable to all Applications (4 of 4)
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Recovery Guru/Health Check Problems

This section describes problems that you may have while using the Recovery
Guru/Health Check or the Manual Recovery options in the Recovery
application.

TABLE 7-8 Recovery Guru/Health Check Troubleshooting (1 of 5)

Recovery Guru/Health Check results take a long time to display.

Cause: Normally you see Recovery Guru/Health Check ’s results in a few seconds. However, if you

have selected All RAID Modules or there are I/O operations running, you might notice a delay. Also,

there could be instances where an unresponsive component or other status change affects the controller's

ability to provide a result in Recovery Guru/Health Check , although such occurrences are rare.

Action: If you experience long delays in performing Recovery Guru/Health Check , you might try

checking one RAID Module at a time or selecting Recovery Guru/Health Check at a time of low system

I/O.

Note: A background check occurs at regular intervals for all RAID Modules (results are

logged to Message Log); the default setting is five minutes. You can change the frequency of

this check by using Options → Log Settings .

Recovery Guru/Health Check doesn’t report a drive failure when I remove a drive.

If there is no I/O occurring for that drive, Recovery Guru/Health Check reports an Unresponsive Drive.

If there is I/O occurring, the controller will fail the drive (and Recovery Guru/Health Check reports

this, too).

Caution: You should never remove drives from a module unless the controller has

marked them as failed. Doing so could result in data loss for the affected logical

unit/drive group. If you suspect problems with a drive, it is best to select

Recovery Guru/Health Check and follow the instructions provided.

Software detects a failure even after I replaced a fan or power supply (recover from a Module Component Failure).

Cause: The software continues to report the condition as a failure for approximately ten minutes after

replacing a fan or power supply due to the controller’s polling interval.

Action: Wait for the controller to poll the module (default is ten minutes) after performing this recovery

procedure before re-selecting Recovery Guru .
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Drive status other than Optimal.

Cause: You have a Failed, Offline, or Replaced drive (which is reconstructing), or a logical unit is being

formatted. For an explanation of possible drive statuses and any recommended action to take, see the Online

help.

Action: For Failed or Offline drives, select Recovery Guru/Health Check and follow the step-by-step

procedures provided. No action is required if the drives are Replaced or the LUN is Reconstructing or

Formatting. However, if the drives remain Replaced and the LUN status was Dead, Recovery
Guru/Health Check may report the RAID Module as Optimal. If this occurs, you need to manually begin

the format process for the LUN/drive group (Options → Manual Recovery → LUNs → Format ).

Drives continue to fail (fault lights lit).

Caution: It is possible that a drive channel has failed. A drive channel failure is

indicated when all the drives on the same channel are Failed and/or Unresponsive.

Depending how the logical units have been configured across these drives, the

status of the logical units may be Dead, Degraded, or Optimal (if hot spare drives

are in use).

Action: Select Recovery Guru/Health Check and follow the step-by-step procedure given.

Drive fault light came on after I replaced a failed drive.

Cause: This light may come on momentarily when a drive in a RAID 1, 3, or 5 LUN begins reconstruction.

Action: Wait a few minutes for the fault light to go off and the drive activity lights to begin flashing

steadily. This indicates that reconstruction is occurring. The drive’s status changes to Replaced and the

logical unit’s status changes to Reconstructing.

However, if the fault remains on, select Recovery Guru/Health Check and follow the procedure

provided.

Failed Drive status appears, but logical unit status is still Optimal.

Cause: A drive on the logical unit has failed and a hot spare has taken over for it.

Note: To see if a hot spare is being used, use List/Locate Drives in the

Configuration application. The hot spare’s drive status is either In Use or Standby (not

being used).

Action: Select Recovery Guru/Health Check and follow the procedure provided.

TABLE 7-8 Recovery Guru/Health Check Troubleshooting (2 of 5)
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Logical unit status other than Optimal.

Cause: You have a Failed drive or a Replaced drive which is reconstructing, a logical unit is being

formatted, or the LUN is Inaccessible because it is owned by the other controller (possible if the RAID

Module has an Independent Controller configuration). For an explanation of possible logical unit statuses

and any recommended action to take, see the Online Help.

Action: For Dead or Degraded logical units, select Recovery Guru/Health Check and follow the step-

by-step procedures it provides for restoring the logical units. However, if the drives remain Replaced and the

LUN status was Dead, Recovery Guru may report the RAID Module as Optimal. If this occurs, you need

to manually begin the format process for the LUN/drive group (Options → Manual Recovery → LUNs
→ Format ).

LUN status changed to Reconstructing, but no drives have been replaced.

Cause: A hot spare has taken over for a failed drive and the data is being reconstructed on it. The logical

unit’s status returns to Optimal as soon as reconstruction is completed.

TABLE 7-8 Recovery Guru/Health Check Troubleshooting (3 of 5)
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LUN status doesn’t change from Reconstructing.

Caution: This could occur after a Manual Recovery task is completed,

especially LUN Reconstruction, or because data was reconstructed on a hot spare

(the hot spare drive becomes In Use, the LUN status changes to Reconstructing, but

may not return to Optimal when reconstruction is completed).

Tip: If reconstruction was interrupted on a hot spare drive because another drive failed in

the same drive group/LUN, the LUN is probably Dead (with two Failed drives) and you

have lost data. You should select Recovery Guru\Health Check and follow the

procedure provided to replace the newly failed drive.

Action: Wait for the background monitor to run (default is five minutes) and to update the status, or
To update immediately, do one of the following:

• Re-select the RAID Module.

• Exit and re-enter the application.

All Drives in a Drive Group fail.

Cause: If all the drives in a configured drive group fail and are then physically replaced, Recovery
Guru/Health Check will still show the replaced drives as failed. Their status is not upgraded to Replaced,

although the LUN status will show Dead LUN.

Action: In this case, follow the Recovery Guru\Health Check procedure to reformat the LUNs in the

drive group.

Tip: If you turn the power to the RAID Module off and then on again, the LUNs in the

drive group are deleted, and the replaced drives are returned to the unassigned drive

group, still failed. Follow the procedure given in Health Check to recreate the deleted

LUNs.

Controller mode is Passive and it doesn’t own any LUNs after replacing a Failed controller.

Cause: After using Recovery Guru to replace the failed controller and Options → Manual Recovery →
Controller Pairs to place it back Online, the controller is Optimal but in the Passive mode rather than

Active. This is most likely to occur for controller B.

Action: With the newly replaced controller Optimal, use Controller Mode → Change To
Active/Active (Maintenance/Tuning application) to make the controller Active. You can either

redistribute drive groups/LUNs during this mode change, or later you can use LUN Balancing
(Maintenance/Tuning application) to assign specific drive group/LUNs to each active controller.

Information is missing in the Options → Manual Recovery → Drives screen.

Cause: The drives for the selected RAID Module are unassigned (that is, they are not part of a configured

drive group). For these drives, there is no LUN, RAID Level, or logical unit status to report. However, you

should still see information for the drives’ location and status.

Action: Select another module, or use the Configuration application to create logical units using those

unassigned drives.

TABLE 7-8 Recovery Guru/Health Check Troubleshooting (4 of 5)
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Replacing Controllers

Use Recovery Guru/Health Check (Recovery application) to diagnose and

correct problems with your RAID Module components. If you are replacing a failed

controller and experience problems, use the following procedures as recommended:

■ Problems Bringing the New Controller Online—page 7-18

■ Incompatible Firmware Detected—page 7-18

Problems Bringing the New Controller Online

You have replaced a controller and saw a message while trying to bring the new

controller Online that told you to check your controller connections and, if still

having problems, to consult this section.

The recommended procedure is to contact your Customer Services Representative.

Incompatible Firmware Detected

You have replaced a controller and saw a message after the new controller was

brought Online telling you that incompatible firmware has been detected and to

consult this section.

The recommended procedure is to contact your Customer Services Representative.

No LUN information appears in the Options → Manual Recovery → Logical Units screen.

Cause: There are no configured logical units for the selected RAID Module (that is, all the drives are

unassigned). There is no LUN, drive group, RAID Level, or logical unit status to report.

Action: Select another module, or use the Configuration application to create logical units using those

unassigned drives.

Component status isn’t updated after a recovery procedure has been performed.

Cause: A configuration change may not be detected yet. For example, a drive is failed, then replaced and its

status becomes Replaced, but does not return to Optimal after reconstruction is completed.

Action: Try selecting a different RAID Module, then switching back and re-selecting Options → Manual
Recovery , or exit, then reselect the Recovery application.

TABLE 7-8 Recovery Guru/Health Check Troubleshooting (5 of 5)
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APPENDIX A

Specifications

This appendix describes the configuration specifications for this software.

■ Hardware Specifications—page A-1

■ Firmware Specifications—page A-3

Hardware Specifications

Host-RAID Module Configurations

The following Host-RAID Module configurations are supported.

■ Single-Host Configuration — One host machine is connected by two SCSI Buses

to each controller in a RAID Module.

■ Independent Controller Configuration — Two host machines are connected to a

dual-controller RAID Module. One host machine is connected by a SCSI Bus to

one controller, and a second host machine is connected by another SCSI Bus to the

other controller.

Note – For an explanation of a RAID Module, see the “Common Definitions”

section in the User Guide or the Online Help glossary. For more information on the

types of Host-RAID Module configurations supported by the storage management

software, see the “Module Configurations” section in the User Guide.
A-1



Host Adapter Information

For the latest information on supported host adapters, drivers, installation

procedures, and so on, consult the readme file in the \hba folder on the installation

CD.

SCSI Host Adapters and Driver Revisions

The following SCSI host adapters have been tested with the storage management

software:

Boot Device Host Adapters

The SYM22802, Adaptec 2944W, and Adaptec 2944UW host adapters have been

tested with RAID Module boot devices.

TABLE A-1 Tested Adapters, BIOS Revisions, and Driver Revisions

Adapter BIOS Revision Driver Revision

SYM22802 Dual Ultra-Wide Differential V4.0 PCI SCSI BIOS FLINT 4.05.00

Adaptec 2944W 1.25 through 1.32 4.0 from Microsoft

Service Pack 3

Adaptec 2944UW 1.25 through 1.32 4.0 from Microsoft

Service Pack 3
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Firmware Specifications

Latest Versions

TABLE A-2 documents the most recent controller firmware version and the location

(on the RAID Manager CD) of the most recent NVSRAM file.

Controller Firmware Requirements

TABLE A-3 shows the controller firmware levels for the RAID Module controllers that

support the storage management software.

TABLE A-2 Latest Firmware and NVSRAM File Versions

Firmware version 3.0

NVSRAM file Firmware/sie3621F.dl on the RAID Manager CD

TABLE A-3 Controller Firmware Requirements

Controller Type Required Firmware Level

3201 2.04.20; does not support 3.0

3620, 3622 2.05.04 or later; does not support 3.0

3240, 3621 2.05.04, 3.0, or later
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Upgrade Notes
■ If you are upgrading to firmware level 3.0, you may need to upgrade to an

intermediate level first.

Note – This software’s CD contains firmware versions 2.04.04, 2.05.04, and 3.0

(appware and bootware).

■ Note that firmware level 3.0 or higher is required for some storage management

features documented in the User Guide; these features are not available on

controllers that do not support firmware level 3.0.

TABLE A-4 Controller Firmware Upgrade

If you have this firmware version: You should upgrade:

2.05.04 to 2.05.05 directly to 3.0 on both controllers

2.04.04 to 2.05.03 • to 2.05.04

• then 3.0

2.04.03 • to 2.04.04

• then 2.05.04

• then 3.0
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Index
A
Adaptec driver restrictions 1-4
Adding RAID Modules 6-8
Administrator privileges 2-5, 3-3
ARC name entry 3-4
arraymon.exe

see Disk array monitor

Auto parity check/repair

described 4-19

B
Background monitor 6-6

see also Disk array monitor

Batch file

delay command 7-10
fails unexpectedly 7-10

Battery age reset 7-12
restriction 1-5
troubleshooting 7-12

Battery management 1-3
BIOS

enabling for boot device 3-4
Blank screen

manual recovery

drives 7-17
logical units 7-18

Boot device 1-4, 1-7
BIOS enabled 3-4
dump/swap device and 1-5
firmware download 4-8
host adapters A-2
host system preparation 3-4
LUN 0 and 1-4, 3-3, 6-5
RAID levels to use 3-3
RAID module preparation 3-3, 3-4
reset configuration and 1-4, 3-3, 6-5
SCSI 1-4
size required 3-4
testing controller failover 3-7
upgrading software on 3-1

boot.ini file 3-4, 3-8

C
Cables

checking 1-7, 7-11
Cannot secure access to LUNs message 7-13
Capacity

less than expected 7-8
Channel failure 7-15
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Checking

cable connections 1-7
cables 7-11
disk array monitor 2-6, 3-6
hardware and software 1-6
module status 4-9

checking the hardware 1-8
clean.bat script

when to use 7-10, 7-11
Command line commands

fwutil 7-10
lad 1-5
nvutil 4-8, 4-9
raidutil 1-5, 7-12
rdacutil 7-10

Command line interface

help files for 6-7
Component failures

unexpected 7-14
Component status

unexpected 7-18
Configuration

adding RAID Modules 6-8
changing parameters 4-19
determining

controller firmware version 4-4
current setup 4-13
when to change 4-18

hardware 1-7
host-RAID Module types A-1
NVSRAM values for 4-8
resetting 1-4, 3-3, 7-8
single controller 3-3, 3-7
types supported A-1

Configuration application

List/Locate, Locate won’t work 7-8
main screen illustrated 4-14
reset won’t work 7-8
restrictions 1-6
starting 4-13

troubleshooting 7-8
Controllers

can’t bring online 7-18
firmware mismatch 7-18
firmware supported A-3
firmware upgrade 4-3
host-side ID 7-11
incompatible software 7-18
mode

passive after replacing 7-17
names 6-2
not Active after replacing 7-17
not visible 7-11
not visible on screen 7-11
number of allowed 4-22, 5-1

changing 5-7
replacing 7-18

can’t bring online 7-18
resetting battery age 7-12
supported 1-7
testing failover 3-7
troubleshooting 7-10
see also Firmware

Creating logical units

see Logical unit, creating

D
Database applications 6-5
Deleting logical units

see Logical unit, deleting

Device name

defined 6-2
Directory

installation naming restriction 2-5, 3-6
Disk Administrator utility

deleting LUNs and 6-5
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Disk array monitor

checking 2-6, 3-6
starting 6-7
stopping 6-6, 7-10
see also Background monitor

Drive letters

assigning 1-4, 2-3, 3-5, 4-22
Driver revisions A-2
Drivers

Adaptec restrictions 1-4
information on A-2
NT class 1-4, 2-4, 3-5
RDAC 6-3
symarray 1-4, 2-4, 3-5

Drives

assigning letters to 1-4, 2-3, 3-5, 4-22
failed 7-8
failures

all in drive group 7-17
keep failing 7-15

fault light on 7-15
number for drive group

unexpected 7-8
removing 7-14

Recovery guru 7-14
status

non-optimal 7-15
unresponsive 7-8, 7-14

drivutil command

help file for 6-7
Dump/swap device 1-5

E
Editing module name and comments 4-2, 4-3
Error messages

see Messages

Exclusive access 7-11, 7-13

F
Failed drives 7-8

all in drive group 7-17
Fans

replacing 7-14
Fault light

drives 7-15
Files

batch, failed 7-10
boot.ini 3-4, 3-8
clean.bat 7-10, 7-11
fwcompat.def 4-5
lunlocks 7-11
see Command line interface

see also rmparams file

see also rmscript.bat

Firmware

default directory 4-5
mismatch detected 7-18
mismatch or incompatible software 7-18
upgrading 4-3

from 2.04.03 A-4
from 2.04.04 A-4
progress of 4-7
required 1-7
unsuccessful 7-9

version 3.0 features A-4
versions supported A-3
viewing version level 4-4

Font size 1-6
fwcompat.def file 4-5
fwutil command

restriction 7-10
see also Command line commands

G
Graphics card 1-7
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H
Hardware

checking 1-7
host adapters A-2
requirements 1-6
supported A-1

Health check

how long it takes 7-14
running a 4-9
see also Recovery Guru

Host adapter 1-7
Adaptec restrictions 1-4
BIOS

enabling for boot device 3-4
boot device A-2
information on A-2
LUN limit 6-2
SCSI A-2

Host-RAID Module configuration types

defined A-1
Host-side ID 1-8

check if controller/RAID Module not visible 7-
11

Hot spare

described 4-19
in use 7-16
logical unit status and 7-15
troubleshooting 7-17

I
Incompatible software detected 7-18
Independent Controller configuration

Offline method required for firmware upgrade

4-5
Independent controller configuration 1-2

boot device and 3-3, 3-7
defined A-1
firmware downloads and 4-4

indicating 4-2
installing software on 2-1
recovery guru and 4-9

Installation

default directory 2-5, 3-6
directory naming restriction 2-5, 3-6
preparation for 1-6
storage management software 2-5

standard configuration 2-1
uninstalling 6-8

Installation and support guide

description 1-1

L
lad command 1-5
List/Locate Drives

locate won’t work 7-8
Logical unit

cannot secure access message 7-13
capacity

less than expected 7-8
changing parameters 4-19
creating 1-6, 4-22
deleting 1-6, 4-22, 6-5
limits per host adapter 6-2
limits per module 4-22, 6-2
names 6-2
not visible to software 7-11
parameters 4-20, 7-8
restart required 6-5
status

non-optimal 7-13, 7-16
remains at Reconstructing 7-17
shows Reconstructing 7-16

LUN 0

battery age reset and 1-5
boot device and 1-4, 3-3
deleting 6-5

lunlocks file 7-11
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M
Maintenance/Tuning application 3-8

restrictions 1-6
Manual recovery

drives

blank screen 7-17
logical units

blank screen 7-18
Message log 6-6
Messages

cannot secure access to LUNs 7-13
non-optimal Health Check results 4-9
not all files removed 7-10
see also Trap messages

MIB file 5-2
Mismatch firmware detected 7-18
Module profile

main screen illustrated 4-17
saving 2-3, 3-2

Module selection screen 1-2, 4-2, 4-3, 4-4, 4-13
defined 5-2
disabling 5-2, 5-7

Module status

non-optimal 7-13
unexpected 7-18

Mouse 1-7
Multi designator 3-4

N
NMS

see SNMP

Not all files removed message during uninstall 7-
10

Notification

see rmscript.bat

see SNMP

NT class driver 1-4, 2-4, 3-5
Number of drives

limitation 7-8

NVSRAM

default directory 4-5
downloading 4-3
incorrect settings 7-11
restoring original settings 4-9, 6-9
setting 4-8, 7-11
uninstalling the software and 6-8, 6-9

nvutil command 4-8, 4-9
see also Command line commands

O
Online help 3-3

P
Parameters

changing configuration 4-19
changing in rmparams file 5-7
described for SNMP 5-7
logical unit 4-19
polling interval 6-6

Parity check/repair

default auto setting 4-19
Polling interval 6-6
Power supplies

replacing 7-14

R
Raid array monitor

stopping and restarting 7-11
RAID Manager

upgrading from 2-2, 3-2
RAID Manager for DOS 7-11

when to use 3-4
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RAID Module

adding new 6-8, 7-11
boot device 1-4, 1-7

preparation 3-4
set-up 3-3

can’t access 1-6
checking cables 1-7
checking status 4-9
configurations supported A-1
configuring 4-22
editing name and comments 1-2, 4-2, 4-3
identifying configuration 1-2, 4-13
independent controllers and 4-2
LUN limit 6-2
naming scheme 2-2, 3-2, 4-2, 4-3
not visible on screen 7-11
removing configuration 7-12
saving profile 2-3, 3-2
upgrade installation and 2-2, 3-2

raidutil command 1-3
restriction 1-5
see also Command line commands

Raw partitions 6-5
RDAC

boot device and 3-3
defined 6-3
dump/swap device and 1-5
illustrated 6-4
independent controller configuration and 3-3
single controller configuration and 3-3
symarray driver and 1-4, 2-4, 3-5
testing failover 3-7

rdacutil command

restriction 7-10
see also Command line commands

Reconstruction

drive fault light 7-15
Recovery application 3-8

restrictions 1-6

Recovery guru 3-7, 3-8, 7-11, 7-16, 7-17
independent controllers and 4-9
removing modules 7-12
takes a long time 7-14
troubleshooting 7-14

Reset configuration 7-8
boot device and 1-4, 3-3, 6-5
doesn’t work 7-8

Restart

when required 4-8, 4-9, 6-5
Restrictions

Adaptec drivers 1-4
batch file failed 7-10
can’t see controllers 7-11
cannot secure access to LUNs 7-13
configuration changes 1-6
database applications and 6-6
drive letters assigned 2-3, 3-5
LUN limits 4-22, 6-2
LUNs not visible 7-11
number of controllers 4-22, 5-1
software and operating system 1-3

rmparams file

backup copy 5-6, 7-10
changeable parameters 5-7
changing 5-6
help file for 5-6
missing 7-10
upgrade installation and 2-2, 3-2

rmscript.bat

help file for 5-8
scriptable notification 5-8
upgrade installation and 2-2, 3-2
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S
Screen illustrations

configuration application 4-14
exceptions found 4-11
firmware upgrade 4-6
Module Profile 4-17
recovery main screen 4-10
recovery procedure screen 4-12

Scriptable notification

see rmscript.bat

SCSI 1-7, 1-8
boot device on 1-4
host adapters A-2

SCSI ID

see Host-side ID 1-8
Select Module

screen display parameter 5-7
Service pack 1-7
Simple network management protocol

see SNMP

Single controller configuration

boot device 3-3
boot device and 3-7

Single-host configuration

defined A-1
installing software on 2-1

SNMP

disabling 5-5
enabling 5-2
MIB file and 5-2
parameters described 5-7
set up NMS 5-2
trap messages

contents 5-4
Software

background monitor 6-6
can’t view LUNs 7-11
customizing 5-1
doesn’t start 7-10
exclusive access required 7-11, 7-13

features 1-2
incompatible versions detected 7-18
installing 2-5, 3-6
options grayed out 7-12
required firmware A-4
requirements 1-6
restrictions 1-3
starting 4-1
uninstalling 6-8
upgrading

boot device 3-1
pre-installation tasks 2-3, 3-1, 3-2

Special characters

restriction 2-5, 3-6
Starting storage management software 4-1
Status

non-optimal 7-15
unexpected 7-18

Symarray driver 1-4, 2-4, 3-5

T
Trap messages

contents 5-4
see also SNMP

Troubleshooting

Configuration application 7-8
failed drives 7-15
general for all applications 7-10
List/Locate won’t work 7-8
locating solutions 7-2
replacing controllers 7-18

can’t bring online 7-18
firmware mismatch 7-18
incompatible software 7-18

resetting battery age 7-12
second controller fails 7-10
uninstalling 7-10
Windows NT 7-1
Index 7



U
Unassigned drives

failed 7-8
Understanding module names 4-2, 4-3
Uninstalling

not all files removed message 7-10
NVSRAM and 6-9
procedures 6-8

Unresponsive drives 7-8, 7-14
Upgrading

firmware 4-5
module name changes 3-2
pre-installation tasks 2-3, 3-1, 3-2
software

boot device 3-1
standard installation 2-2

User Guide 3-3
when to use 1-2, 4-23

Utilities

see Command line interface

W
Windows NT

arc name entry 3-4
boot.ini file 3-4, 3-8
creating LUNs and 4-22, 6-5
deleting LUNs and 4-22, 6-5
device names on 6-2
Disk Administrator utility 6-5
drive letters locked 1-6
event log 7-10
font size 1-6
LUN limits 4-22, 6-2
module names on 6-2
multi designator 3-4
NT class driver 1-4, 2-4, 3-5
privileges required 2-5, 3-3
restrictions 1-3

service pack required 1-7
support for 6-1
symarray driver and 2-4, 3-5
troubleshooting 7-1
versions supported 1-3, 1-7
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	a. Select Start Æ Programs. Raid Manager should appear in the list.
	b. Select Start Æ Settings Æ Control Panel Æ Services. The Disk Array Monitor should be running i...

	6. Are you using a single-controller or independent controller RAID Module as the boot device?
	Testing Controller Failover
	1. Select Start Æ Programs Æ Raid Manager.
	2. Select the Recovery application.
	3. Select the RAID Module that you created as the boot device.
	4. Select Recovery Guru/Health Check to verify that the RAID Module is Optimal (that is, it has n...
	5. Select Options Æ Manual Recovery Æ Controller Pairs.
	6. Highlight the controller you created as the default boot path device and select Place Offline.
	7. When the controller is Offline, select Recovery Guru/Health Check. You should see an Offline C...
	8. Exit the storage management software.
	9. Shut down and restart Windows NT.
	10. Do you see the boot menu when the operating system restarts?
	11. Does the Windows NT system restart?
	12. Start the storage management software.
	13. Select the Recovery application.
	14. Select the RAID Module you created as the boot device, and select Recovery Guru/Health Check....
	15. Select Show Procedure and follow the instructions provided.
	16. When the recovery procedure is completed, select Recovery Guru/Health Check again to verify t...
	17. Select the Maintenance/Tuning application.
	18. Select the RAID Module that you created as the boot device, and then select LUN Balancing. Ve...
	19. Continue with Chapter�4 “Initial Startup Procedures”.
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	Initial Startup Procedures


	Starting the Software
	1. Start Windows NT if it is not already running.
	2. Start the RAID Manager software. Select Start Æ Programs Æ Raid Manager.
	3. The application names appear under Raid Manager: Configuration, Maintenance and Tuning, Recove...
	4. Do your modules have an Independent Controller configuration?
	Setting up Independent Controllers
	1. Start any storage management software application.
	2. When the Module Selection screen appears, highlight the module that has independent controller...
	3. Click the box next to “Independent Controllers?” and select OK.
	4. Assign names to the modules, if desired, and add any comments (such as location details or oth...
	5. Repeat this procedure for all modules using this configuration.
	6. Continue with “Verifying and Upgrading the Controller Firmware” on page�4�3.


	Assigning Names to the Modules
	1. Start any storage management software application.
	2. When the Module Selection screen appears, highlight the module that has independent controller...
	3. Assign a name to the module and add any comments (such as location details or other unique inf...
	4. Perform this procedure on each RAID Module that you want to assign a name to.
	5. Continue with the next section, “Verifying and Upgrading the Controller Firmware”.

	Verifying and Upgrading the Controller Firmware
	Verifying the Controller Firmware Version
	1. Start the Configuration application.
	2. Select the RAID Module you want to check, then select Module Profile Æ Controllers.
	3. Verify that the firmware level is the most recent version. (See “Firmware Specifications” on p...
	4. Select OK when finished viewing.
	5. Check all the RAID Modules on your system.
	6. Do all the controllers on your system have the required version of firmware?
	7. Close all windows.

	Upgrading the Controller Firmware Version
	1. Copy the firmware files, the fwcompat.def file, and the NVSRAM files to the \program files\Rai...
	2. Determine whether you can upgrade the firmware using the Online (RAID Module receiving I/O) or...
	3. Start the Maintenance and Tuning application.
	4. Select the RAID Module containing the controllers you want to upgrade. Select All RAID Modules...
	5. Click on the Firmware Upgrade button or select Options Æ Firmware Upgrade from the pull-down m...
	6. Read the Important Notes screen and then select OK.
	7. A screen appears asking you to select the Online or Offline procedure. Select either:
	8. After selecting Online or Offline, the screen displays “Verifying the controller state” while ...
	FIGURE�4�1 Firmware Upgrade Screen

	9. If you need to download both new NVSRAM files and upgraded firmware files, you must download t...
	10. Highlight the firmware version level that you want to download and then select OK.
	11. Select OK and follow the upgrade progress. The upgrade will take approximately 5 minutes, alt...
	TABLE�4�1 Firmware Confirmation Screen Elements

	12. After the download is completed, select OK to return to the Maintenance/ Tuning screen.
	13. Did you download an NVSRAM file or new firmware?
	14. At the command line, type:
	15. Establish the new NVSRAM settings:
	16. Go back to Step�9 and download any new firmware files.


	Setting the NVSRAM Values
	1. Determine which .def file you need to use.
	2. From the command line, enter:
	3. Turn the power to the RAID Module off and then on again to establish the new NVSRAM settings.
	4. Perform this procedure from each host attached to an affected RAID Module.
	5. Continue with the next section, “Running the Recovery Guru/Health Check”.

	Running the Recovery Guru/Health Check
	1. Start the Recovery application.
	2. Select All RAID Modules to check all of the modules on your system.
	3. A screen like FIGURE�4�2 is displayed.
	FIGURE�4�2 Recovery Main Screen

	4. Click on the Recovery Guru/Health Check button or select Options Æ Recovery Guru from the pull...
	5. Were non-optimal statuses (exceptions) found?
	FIGURE�4�3 Recovery Screen/Exceptions Found

	6. Highlight the first exception and click on Show Procedure for recommendations on how to fix th...
	FIGURE�4�4 Recovery Procedure Screen

	7. Print out the procedure, if desired.
	8. Follow the procedure given to recover from the component failure.
	9. Reselect Recovery Guru/Health Check.
	10. Repeats Step�5 through Step�9 until all RAID Modules are Optimal.
	11. Continue with the next section, “Determining the Current Configuration”.

	Determining the Current Configuration
	1. Use the following steps to view the current drive groups and logical units in a RAID Module.
	a. Select the Configuration application.
	b. Highlight the first RAID Module in the list, and select OK.
	FIGURE�4�5 Main Configuration Screen
	TABLE�4�2 Configuration Display Columns (1 of 2)

	c. View the current drive groups and logical units.

	2. Use the following steps to physically locate and label a RAID Module.
	a. Click on the Locate Module button, select Module Æ Locate from the pull- down menus, or right-...
	b. Click Start on the Locate Module screen. The activity lights flash on the drive canisters in t...
	c. Physically locate the RAID Module with the flashing activity lights.
	d. Once you have identified the RAID Module, place a sticker label on it for future reference.
	e. Click Stop to stop the flashing of the activity lights.

	3. Use the following steps to save and print a RAID Module’s profile information.
	a. Select the desired RAID Module and then select File Æ Save Module Profile.
	b. Make sure that All is selected (all of the buttons should be selected), and select OK to save ...
	c. Enter an appropriate path and filename on the Selection line, and select OK.
	d. Print the Module Profile information you saved in Step�c using your host system's printer util...

	4. Use the following steps to view a RAID Module’s profile. (Optional)
	a. Select the desired RAID Module and then select Module Æ Profile.
	b. Select Controllers, Drives, or LUNs for more detailed information about these components.
	c. Select OK to exit the profile information.
	FIGURE�4�6 Main Module Profile Screen


	5. Use the following steps to view details on specific drives in a drive group. (Optional)
	a. Highlight the drive group or individual drives you want to locate.
	b. Click on the List/Locate Drives button or select Options Æ List/Locate drives from the pull-do...
	c. Use the drive location information [x,y] provided in the list to physically locate individual ...
	d. Select OK to exit the drive information.

	6. Repeat Step�1 through Step�3 (and Step�4 through Step�5, if desired) for each RAID Module conn...
	7. Continue with the next section, “Determining whether any Changes are Necessary”.

	Determining whether any Changes are Necessary
	1. Use TABLE�4�3 and the Module Profile information you saved and printed to assist you in determ...
	TABLE�4�3 Possible Parameters to Change (1 of 3)

	2. Continue with the next section, “Configuring RAID Modules”.

	Configuring RAID Modules
	Configuring Logical Units on Your RAID Module
	1. Select Start Æ Programs Æ Raid Manager Æ Configuration.
	2. Set up the logical units with the desired drives, RAID Levels and parameters.
	3. Continue with the next section, “Partitioning Logical Units and Assigning Drive Letters”.

	Partitioning Logical Units and Assigning Drive Letters
	1. Use the Windows NT Disk Administrator to partition the logical units and assign drive letters....
	2. Continue with the next section, “What’s Next?”.


	What’s Next?
	5
	Customizing the Installation

	Controller Limits
	Disabling the Module Selection Screen
	Setting up SNMP Notification
	Enabling SNMP Notification
	1. Set up the NMS. You only need to set up your designated NMS once. Use the following procedure ...
	a. Copy the \program files\Raidmgr\rm6traps.mib file to the network management station.
	b. Follow the steps required by your specific network management station to compile the MIB.

	2. Make sure that the host system is connected to the network with the NMS station.
	3. Enable this notification on your host. You must edit three parameters in the \program files\Ra...
	4. Save the rmparams file and copy it to the backup directory. It is critical that you have a bac...

	Contents of an SNMP Trap Message
	TABLE�5�1 Contents of an SNMP Trap Message �

	Disabling SNMP
	1. In the \program files\Raidmgr\rmparams file, change the value of the SNMP_Action_Number line t...
	2. Save the rmparams file and copy it to the backup directory. It is critical that you have a bac...


	Changing the rmparams File
	TABLE�5�2 Changeable Parameters in the rmparams File �
	1. Before making any changes to the rmparams file for the first time, save the original file and ...
	2. Make any necessary changes to the rmparams file using TABLE�5�2 as a guide.
	3. Save the rmparams file, and copy it to the backup directory.

	Setting up Scriptable Notification Options
	6
	Operating System Support

	Operating System Information
	Number of LUNs
	Module Names
	Controller/LUN Names
	Redundant Controller Support (RDAC)
	FIGURE�6�1 Example of RDAC I/O Data Path Redundancy
	1. I/O request fails.
	2. Failed I/O goes back to RDAC driver.
	3. RDAC driver performs failover and transfers logical units to other controller (controller B).
	4. RDAC driver resends I/O request back down to controller B, where it is serviced. (The host app...

	Creating Logical Units
	Deleting Logical Units
	Accessing Raw Partitions
	The Background Monitor
	Stopping the Disk Array Monitor Service
	1. Select Start Æ Settings Æ Control Panel Æ Services.
	2. Highlight the Disk Array Monitor service.
	3. Select Stop. When the status changes to Stopped, close the Services application.

	Starting the Disk Array Monitor Service
	1. Select Start Æ Settings Æ Control Panel Æ Services.
	2. Highlight the Disk Array Monitor service.
	3. Select Start. When the status changes to Started, close the Services application.



	Command Line Interface
	Adding New RAID Modules to the Configuration
	1. Physically connect the RAID Module to your system. Consult the appropriate hardware documentat...
	2. Close all open applications and restart Windows NT.
	3. Go to Chapter�4 “Initial Startup Procedures to perform the following steps:

	Uninstalling the Storage Management Software
	1. If you do not intend to reinstall this software and you are not removing your RAID Module from...
	a. As a precautionary measure, you should begin the uninstall process by running nvutil and execu...
	b. Obtain a copy of the correct NVSRAM values from your Customer Services Representative (it will...
	c. Download the new NVSRAM values to the controllers in your RAID Modules using the fwutil comman...
	d. If you set NVSRAM parameters during installation with the networkoff.def file (see “Setting th...

	2. Select Start Æ Settings Æ Control Panel Æ Add/Remove Programs and then scroll the list to find...
	3. With Raid Manager highlighted, select Add/Remove.
	4. At the “Uninstall software” screen, select Yes.
	5. At the “Uninstall Complete” screen, select OK to shutdown and restart the Windows NT system.
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	Troubleshooting

	Introduction
	Locating Solutions
	Category
	TABLE�7�1 Troubleshooting Entries Organized by Category

	Component Search
	TABLE�7�2 Troubleshooting Entries Organized by Component (1 of 2)

	Application Search
	TABLE�7�3 Troubleshooting Entries Organized by Application (1 of 2)

	Software Search
	TABLE�7�4 Troubleshooting Entries Organized by Software �


	Configuration Application Problems
	TABLE�7�5 Configuration Application Changes Troubleshooting �

	Firmware Upgrade Problems
	TABLE�7�6 Controller Firmware Upgrade Troubleshooting �

	General Problems
	TABLE�7�7 Troubleshooting Generally Applicable to all Applications (1 of 4)
	1. Start Windows NT and try to start the software again. (See “Starting the Software” on page�4�1...
	2. If you had previously saved a backup rmparams file, copy it to the installation directory (def...
	3. If you still cannot start the software, run the clean.bat -all script to delete certain .mnf, ...
	4. If you still cannot start the software, reinstall the software.
	1. Wait for the operation to be completed, or perform operations on a different RAID Module.
	2. If you still do not see controllers or LUNs that you know exist, do the following:
	3. Restart the application where you had the problem and verify that the controller/LUNs are now ...
	1. Verify there is no problem on the data path:
	2. If you have replaced or added controllers/RAID Modules after installing this software, be sure...
	3. If you see a message (on the console) that incorrect NVSRAM settings have been fixed, immediat...
	1. Physically remove the module from your host system.
	2. Choose Select Module.
	3. Highlight the module you wish to remove.
	4. Select Remove. The RAID Module no longer appears in the Module Selection screen or the RAID Mo...
	1. Wait for any operation that has secured exclusive access to the LUNs to be completed before pe...
	2. If no other storage management software operations are running, and you think another applicat...


	Recovery Guru/Health Check Problems
	TABLE�7�8 Recovery Guru/Health Check Troubleshooting (1 of 5)


	Replacing Controllers
	Problems Bringing the New Controller Online
	Incompatible Firmware Detected
	A
	Specifications
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