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Preface

GNOME 2.0 Desktop for the Solaris Operating Environment User Guide describes how to
use the GNOME Desktop.

Who Should Use This Book
This book is for users who plan to use the GNOME 2.0 Desktop as the default desktop
environment.

Before You Read This Book
Before you read this book, you should ensure that you have some familiarity with the
following topics:

� Three-button mouse devices
� Graphical user interfaces
� Command line interfaces
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How This Book Is Organized
This book is organized as follows:

� Part I introduces the core GNOME Desktop components. This part also provides
information that helps you to start working with the desktop environment.

� Part II describes how to configure the desktop environment.
� Glossary is a list of terms used in this book, and definitions of the terms.

Related Documents
The following manuals are related to this guide:

� GNOME 2.0 Desktop for the Solaris Operating Environment Accessibility Guide

� GNOME 2.0 Desktop for the Solaris Operating Environment Installation Guide

� GNOME 2.0 Desktop for the Solaris Operating Environment Release Notes

� GNOME 2.0 Desktop for the Solaris Operating Environment System Administration
Guide

� GNOME 2.0 Desktop for the Solaris Operating Environment Troubleshooting Guide

Accessing Sun Documentation Online
The docs.sun.comSM Web site enables you to access Sun technical documentation
online. You can browse the docs.sun.com archive or search for a specific book title or
subject. The URL is http://docs.sun.com.

Ordering Sun Documentation
Sun Microsystems offers select product documentation in print. For a list of
documents and how to order them, see “Buy printed documentation” at
http://docs.sun.com.
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Typographic Conventions
The following table describes the typographic changes used in this book.

TABLE P–1 Typographic Conventions

Typeface or Symbol Meaning Example

AaBbCc123 The names of commands, files, and
directories; on-screen computer output

Edit your .login file.

Use ls -a to list all files.

machine_name% you have
mail.

AaBbCc123 What you type, contrasted with
on-screen computer output

machine_name% su

Password:

AaBbCc123 Command-line placeholder: replace with
a real name or value

To delete a file, type rm
filename.

AaBbCc123 Book titles, new words, or terms, or
words to be emphasized.

Read Chapter 6 in User’s Guide.

These are called class options.

You must be root to do this.

Shell Prompts in Command Examples
The following table shows the default system prompt and superuser prompt for the C
shell, Bourne shell, and Korn shell.

TABLE P–2 Shell Prompts

Shell Prompt

C shell prompt machine_name%

C shell superuser prompt machine_name#

Bourne shell and Korn shell prompt $

Bourne shell and Korn shell superuser prompt #

Preface 13
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PART I

A Tour of the GNOME Desktop

This section introduces the core GNOME Desktop components. This section also
provides information that helps you to start working with the desktop environment. A
desktop environment is a windows-based environment for users. The desktop
environment is the sum of all the parts of your working environment. The desktop
environment is very configurable, therefore this section covers the main functional
possibilities of the desktop environment features. If you want to find out how to
implement the various configuration possibilities that are mentioned in this section,
see Customizing Your GNOME Desktop. The chapters in this section are as follows:

� Basic Skills

Read this chapter to find out about mouse usage, shortcut keys, basic window
skills, and basic dialog skills.

� Overview of the GNOME Desktop

Read this chapter for an introduction to the major components and functions of the
desktop environment. If you do not read anything else in this manual, read this
chapter.

� GNOME Desktop Sessions

Read this chapter for information about how to start, manage, and end GNOME
Desktop sessions.

� Working With Panels

Read this chapter to find out more about using panels. Panels are a key component
of the GNOME Desktop. This chapter tells you how to use the different parts of
your panels, and how to invoke the available functions of the desktop environment
using panels.

� Working With Menus

Read this chapter to find out more about using menus.
� Working With Windows

Read this chapter to find out more about using windows. This chapter describes
basic windows functions such as moving and resizing. This chapter also describes
the controls that you use with windows.
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� Nautilus File Manager

Read this chapter to find out more about the Nautilus file manager. This chapter
describes how to use Nautilus to work with your file system. This chapter also
describes how to customize Nautilus.

� Using Your Desktop

Read this chapter to find out more about using the desktop. The desktop is the part
of the desktop environment where there are no interface graphical items, such as
panels and windows. This chapter describes how to use the desktop to start
applications, and open your files and folders. The chapter also describes how to
use Trash from the desktop, how to use the Desktop menu, and how to customize
the desktop.
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CHAPTER 1

Basic Skills

This chapter introduces you to the basic skills that you need to work with the GNOME
Desktop.

� “Mouse Skills” on page 17
� “Keyboard Skills” on page 21
� “Using Windows” on page 25

Mouse Skills
Even if you are very familiar with mouse devices, you should still familiarize yourself
with the button conventions and action terminology used in this manual. This section
also describes the mouse pointers.

Mouse Button Conventions
All the instructions in this manual are for the following types of mouse devices:

� Devices that are configured for right-hand users.

� Three button devices. If you have a two-button mouse device, then you press the
two buttons simultaneously to simulate the effect of a middle mouse button.

The mouse button conventions used in this manual are as follows:
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Mouse Button Definition

Left mouse button The button on the left side of a mouse device configured
for normal right-hand use.

Middle mouse button The middle button of a mouse device configured for
normal right-hand use.

Right mouse button The button on the right side of a mouse device configured
for normal right-hand use.

To reverse the handedness of your mouse device, choose Applications → Desktop
Preferences → Mouse, then select the options that you require. If you do reverse the
handedness of your mouse device, then you must reverse the mouse button
conventions used in this manual.

Mouse Actions
The following table describes the actions that you can perform with the mouse:

Mouse Button Usage

Left mouse button Use to perform the following actions:
� Select text.
� Choose items.
� Drag items.

Middle mouse button Use to perform the following actions:
� Paste text.
� Move items.

Right mouse button Opens a menu for the selected object, if a menu applies.

For example, if you want to copy text then perform the following steps:

1. Select the text with the left mouse button.
2. Move the mouse pointer to the location where you want to copy the text.
3. Click on the middle mouse button.

You can also right-click on the desktop to open the Desktop menu.
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Mouse Action Terminology
The conventions used in this manual to describe actions that you take with the mouse
are as follows:

Action Definition

Click Press and release the left mouse button, without moving
the mouse.

Click-and-hold Press and do not release the left mouse button.

Left-click Same as click. Left-click clarifies the action when there
might be confusion with right-click.

Middle-click Press and release the middle mouse button, without
moving the mouse.

Right-click Press and release the right mouse button, without moving
the mouse.

Double-click Press and release the left mouse button twice in rapid
succession without moving the mouse.

Drag Click-and-hold a mouse button, then move an object. For
example, you can drag a window or an icon. The left and
middle mouse buttons can perform drag actions.

Drag-and-drop Click-and-hold a mouse button, then move an object. For
example, you can drag-and-drop a window or an icon.
Release the mouse button to place the object in a new
location.

Grab Point to an item that you can move, and click-and-hold on
the mouse button. For example, you can grab the titlebar of
a window, then drag the window to a new location.

Mouse Pointers
As you use the mouse, the appearance of the mouse pointer can change. The
appearance of the pointer can provide feedback about a particular operation, location,
or state. The following table lists and describes some of the mouse pointers.
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Pointer Associated Action Description

Point to an item, choose a menu
item

Normal pointer. The pointer that
appears during normal use of the
mouse.

Drag-and-drop Move pointer. Indicates that when
you drop the object, the object is
moved from the old location to the
new location.

Drag-and-drop Copy pointer. Indicates that when
you drop the object, a copy of the
object is created where you drop
the object.

Drag-and-drop Symbolic link pointer. Indicates
that when you drop the object, a
symbolic link to the object is created
where you drop the object. A
symbolic link is a special type of
file that points to another file or
folder.

Drag-and-drop Ask pointer. Indicates that when
you drop the object, a menu opens.
You can choose to move or copy
the object, or to create a symbolic
link to the object.

Drag-and-drop Not available pointer. Indicates that
you cannot drop the object at the
current location.

Move panel object Move panel object pointer.
Indicates that you have selected a
panel object to move.

Resize window horizontally Horizontal resize pointer. Indicates
that you have selected a vertical
window border to resize the
window horizontally.

Resize window vertically Vertical resize pointer. Indicates
that you have selected a horizontal
window border to resize the
window vertically.
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Pointer Associated Action Description

Resize window horizontally and
vertically

Corner resize pointer. Indicates that
you have selected a corner of a
window border to resize the
window horizontally and vertically.

Resize window pane or resize table
column

Window pane or table column
resize pointer. Indicates that you
have selected a column in a table to
resize.

Keyboard Skills
For almost every task that you can perform with the mouse, you can use the keyboard
to perform the same task. Shortcut keys are keys that provide you with a quick way to
perform a task.

You can use shortcut keys to perform desktop tasks and to work with interface items
such as panels and windows. You can also use shortcut keys in applications. To
customize your shortcut keys, choose Applications → Desktop Preferences →
Keyboard Shortcuts.

You can also modify your desktop environment preferences to use keyboard
accessibility features.

The following sections describe the shortcut keys that you can use.

Desktop Environment Shortcut Keys
Desktop environment shortcut keys enable you to use the keyboard to perform
desktop environment tasks. The following table lists some desktop environment
shortcut keys:

Default Shortcut Keys Function

Alt + F1 Opens the GNOME Menu.

Alt + F2 Displays the Run Program dialog.

Print Screen Takes a screenshot.

Alt + Print Screen Takes a screenshot of the window that has focus.
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Default Shortcut Keys Function

Ctrl + Alt + right arrow Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow Switches to the workspace below the current workspace.

Ctrl + Alt + d Minimizes all windows, and gives focus to the desktop.

F1 Starts the online help browser, and displays appropriate
online help.

Window Shortcut Keys
Window shortcut keys enable you to use the keyboard to perform window tasks. The
following table lists some window shortcut keys:

Default Shortcut Keys Function

Alt + Tab Switches between windows. When you use these shortcut
keys, a list of windows that you can select is displayed.
Release the keys to select a window.

Alt + Esc Switches between windows. Release the keys to select a
window.

F10 Opens the first menu on the left side of the menubar.

Alt + spacebar Opens the Window Menu.

Arrow keys Moves the focus between items in a menu.

Return Chooses a menu item.

Esc Closes an open menu.

Ctrl + Alt + right arrow Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow Switches to the workspace below the current workspace.

Ctrl + Alt + d Minimizes all windows, and gives focus to the desktop.
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Panel Shortcut Keys
Panel shortcut keys enable you to use the keyboard to perform panel tasks. The
following table lists panel shortcut keys:

Default Shortcut Keys Function

Ctrl + Alt + Tab Switches the focus between the panels and the desktop. When
you use these shortcut keys, a list of items that you can select is
displayed. Release the keys to select an item.

Ctrl + Alt + Esc Switches the focus between the panels and the desktop. Release
the keys to select an item.

Ctrl + F10 Opens the popup menu for the selected panel.

Tab Switches the focus between objects on a panel.

Return Chooses the selected panel object or menu item.

Shift + F10 Opens the popup menu for the selected panel object.

Arrow keys Moves the focus between items in a menu. Moves the focus
between interface items in an applet also.

Esc Closes an open menu.

F10 Opens the Applications menu on the Menu Panel, if the Menu
Panel is selected.

Application Shortcut Keys
Application shortcut keys enable you to perform application tasks. You can use
shortcut keys to perform application tasks more quickly than if you use a mouse. The
following table lists some application shortcut keys:

Shortcut Keys Command

Ctrl + N New

Ctrl + X Cut

Ctrl + C Copy

Ctrl + V Paste

Ctrl + Z Undo

Ctrl + S Save
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Shortcut Keys Command

Ctrl + Q Quit

Access Keys
A menubar is a bar at the top of a window that contains the menus for the application.
An access key is an underlined letter in a menubar, menu, or dialog that you can use to
perform an action. On a menubar, the access key for each menu is underlined.

To open a menu, press Alt, then press the access key. In the menu, the access key for
each menu item is underlined. To choose a menu item, press the access key for the
menu item. The following table shows example access keys from the Text Editor
application:

Access Keys Function

Alt + F Opens the File menu.

N Chooses the New item on the File menu.

You can also use access keys to access elements in a dialog. In a dialog, one letter in
most dialog elements is underlined. To access a particular dialog element, press Alt,
then press the access key. The following table shows an example access key from the
Preferences dialog in the Text Editor application:

Access Key Function

Alt + U Gives focus to the Use default theme font
check box.

You can use also other keys to navigate within a window or dialog.

Key Function

Tab Moves the focus from element to element in a window or
dialog.
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Key Function

Arrow keys Use the arrow keys to perform the following actions:
� In a menubar, move the focus from one menu to the

next menu. In an open menu, move the focus from one
menu item to the next menu item.

� Move the focus from one option to the next option to
make your selection, for example, within a group of
radio buttons in a dialog.

� Change the value that a spin box displays.

Using Windows
This section provides information on how to use windows.

To Resize Panes
Some windows contain more than one pane. A pane is a subdivision of a window. For
example, the file manager window contains a side pane and a view pane. A window
that contains panes has a resize handle on the edge between the panes. To resize the
pane, grab the resize handle, then drag the edge to the size you require.

Using Tables
Some windows contain information that is organized in a table. This section describes
how to work with tables.

To change the width of a column, drag one of the vertical edges of the column.

In some tables, you can sort the information by a particular column. To sort
information in a table, click on the heading on top of the column by which you want
to sort the information. An up arrow is displayed in the column heading by which the
table is sorted. The following figure shows the up arrow.

To reverse the sort order, click on the column heading again. The up arrow changes to
a down arrow. The down arrow indicates that the information in the column is sorted
in reverse order.
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In some tables, you can select multiple items. The following table describes how to
select items in tables.

Task Action

Select an item Click on the item.

Select a group of contiguous
items

Press-and-hold Shift. Click on the first item in the group,
then click on the last item in the group.

Select multiple items Press-and-hold Ctrl. Click on the items that you want to
select.
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CHAPTER 2

Overview of the GNOME Desktop

This chapter introduces you to the features and main components of the GNOME
Desktop. Before you start to use the desktop environment, read this chapter to
familiarize yourself with the various features, and how the main components work.
The desktop environment is very configurable, so this chapter describes the typical
default configuration.

� “Introducing Desktop Environment Components” on page 27
� “Panels” on page 30
� “Menus” on page 33
� “Windows in the Desktop Environment” on page 34
� “Workspaces” on page 36
� “Nautilus File Manager” on page 37
� “Desktop and Desktop Objects” on page 39
� “Start Here Location” on page 40
� “Desktop Environment Preferences” on page 41
� “Applications” on page 42
� “To Find Out More” on page 43

Introducing Desktop Environment
Components
When you start a desktop environment session for the first time, you should see a
default startup screen, with panels, windows, and various icons. Figure 2–1 shows a
typical desktop environment.
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FIGURE 2–1 A Typical Desktop Environment

The major components of the desktop environment are as follows:

� Panels

Panels are areas in your desktop environment from which you can access all of
your system applications and menus. Panels are very configurable. A particularly
important panel in Figure 2–1 is the Menu Panel. The Menu Panel stretches the full
width of the top edge of the screen. The Menu Panel includes two special menus,
as follows:

� Applications menu: Contains all applications and configuration tools. This
menu also includes the file manager and the help browser. To start the file
manager, choose Home Folder from the Applications menu.

� Actions menu: Contains various commands that perform desktop environment
functions, for example Search for Files and Log Out.
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Click on the icon at the extreme right of the Menu Panel to display a list of all open
windows.

� Menus

You can access all desktop environment functions through menus. The Menu Panel
contains menus, so you can use a combination of menus and panels to perform
your tasks. You can use the Applications menu and the Actions menu to access
almost all of the standard applications, commands, and configuration options.

You can also access almost all of the standard applications, commands, and
configuration options from the GNOME Menu. You can access the items in the
Applications and Actions menus from the GNOME Menu. You can add the
GNOME Menu as a button to your panels.

� Windows

You can display many windows at the same time. You can run different
applications in each window. The window manager provides frames and buttons
for windows. The window manager enables you to perform standard actions such
as move, close, and resize windows.

� Workspaces

You can subdivide your desktop environment into separate workspaces. A
workspace is a discrete area in your desktop environment in which you can work.
You can specify the number of workspaces in your desktop environment. You can
switch to a different workspace, but you can only display one workspace at a time.

� Nautilus file manager

The Nautilus file manager provides an integrated access point to your files and
applications. You can display the contents of your files within a Nautilus window,
or open the files in the appropriate application from Nautilus. You can use the file
manager to manage your files and folders.

� Desktop

The desktop lies behind all of the other components in the desktop environment.
The desktop is an active component of the user interface. You can place objects on
the desktop to quickly access your files and directories, or to start applications that
you use often. You can also right-click on the desktop background to open a menu.

� Start Here location

The Start Here location provides an access point to some of the key features of the
desktop environment. You can access your GNOME applications and configuration
tools from the Start Here location. You can also access programs that enable you to
configure your system as a server, and to choose other system settings.

� Desktop environment preferences

The desktop environment contains dedicated preference tools. Each tool controls a
particular part of the behavior of the desktop environment. To start a preference
tool, choose Applications → Desktop Preferences. Choose the item that you want to
configure from the submenus.
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The most powerful features of the desktop environment are the high degree of
configurability and the multiple ways that you can perform tasks.

The desktop environment provides interoperability of the desktop environment
components. Usually, you can perform the same action in several different ways. For
example, you can start applications from panels, from menus, or from the desktop.

Your system administrator can make configuration changes to suit your needs, so that
the desktop environment might not be exactly the same as described in this chapter.
Nevertheless, this chapter provides a useful quick guide to how to work with the
desktop environment.

Panels
You can add or delete panels at any time. When you start a session for the first time,
the desktop environment usually contains at least two panels, as follows:

� Menu Panel
� Edge panel at the bottom of the screen

You can perform the following actions with panels:

� Create panels.
� Delete panels.
� Hide panels.
� Add objects to panels.
� Manipulate panel objects.

To Create Panels
To create a panel follow these steps:

1. Right-click on a vacant space on any panel, then choose New Panel.

2. Choose the type of panel that you want to create from the submenu. The panel is
added to the desktop environment.

You can create as many panels as you want. However, you can only create one Menu
Panel. You can create different types of panel to fit your own requirements. You can
customize the behavior and appearance of your panels. For example, you can change
the background of your panels.

To Delete Panels
To delete a panel, right-click on the panel then choose Delete This Panel.
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To Hide Panels
Except for the Menu Panel, panels can have hide buttons at each end of the panel. You
click on the hide buttons to hide or show the panel.

To Add Objects to Panels
A panel can hold several types of objects. The panel in Figure 2–2 contains each type
of panel object.

FIGURE 2–2 A Panel With Various Panel Objects

You can add any of the following objects to all types of panels:

� Applets

Applets are small, interactive applications that reside within a panel, for example
CD Player in Figure 2–2. Each applet has a simple user interface that you can
operate with the mouse or keyboard. The following applets appear in your panels
by default:

� Window List: Displays a button for each window that is open. You can click on
a window list button to minimize and restore windows. By default, Window
List appears in the edge panel at the bottom of the screen.

� Workspace Switcher: Displays a visual representation of your workspaces. You
can use Workspace Switcher to switch between workspaces. By default,
Workspace Switcher appears in the edge panel at the bottom of the screen.

To add an applet to a panel, right-click on a vacant space on the panel, then choose
Add to Panel. Choose the applet that you require from one of the following
submenus:

� Accessories
� Amusements
� Internet
� Multimedia
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� Utility
� Launchers

A launcher starts a particular application, executes a command, or opens a file. The
calculator icon in Figure 2–2 is a launcher for the Calculator application. A launcher
can reside in a panel or in a menu. Click on the launcher to perform the action that
is associated with the launcher.

You can create your own launchers for applications. For example, you can create a
launcher for a word processor application that you use frequently, and place the
launcher in a panel for convenient access. To add a new launcher to a panel,
right-click on a vacant space on the panel, then choose Add to Panel → Launcher.

Alternatively, to add a launcher from a menu, right-click on a vacant space on the
panel, then choose Add to Panel → Launcher from menu. Choose the launcher to
add from the submenus.

� Menus

You can access all desktop environment functions through menus. The default
panels contain menus, so you can use a combination of menus and panels to
perform your tasks. To open a menu from a panel, click on the icon that represents
the menu. To open a menu from the Menu Panel, click on the text that represents
the menu.

Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu. The icon in Figure 2–2 is the icon
that is displayed when you add the Desktop Preferences menu to a panel.

You can also add the GNOME Menu to any of your panels. To add the GNOME
Menu to a panel, right-click on a vacant space on the panel, then choose Add to
Panel → GNOME Menu.

� Drawers

Drawers are sliding extensions to a panel that you can open or close from a drawer
icon, as shown in Figure 2–2. Drawers can help you to organize your work when
you run a lot of applications simultaneously. You can place all the same functional
elements in a drawer that you can put in any other type of panel.

To add a drawer to a panel, right-click on a vacant space on the panel, then choose
Add to Panel → Drawer.

To open a drawer click on the drawer. To close a drawer click on the drawer again.
� Lock button and Log Out button

The Lock button enables you to lock your screen. The lock icon in Figure 2–2 is the
Lock button. The Log Out button enables you to end your session.

To add the buttons to a panel, right-click on a vacant space on the panel, then
choose Add to Panel. You can then choose the button you require.
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To Manipulate Panel Objects
You can manipulate panel objects in the following ways:

� Move objects within a panel, or to another panel.

You can move any object to another location in the panel. You can also move an
object from one panel to another panel. Use the middle mouse button to drag the
panel object to the new location.

� Copy menu items to a panel.

Drag the item from the menu to the panel. Alternatively, if the menu item is a
launcher right-click on the menu item, then choose Add this launcher to panel.

Menus
You can access all desktop environment functions through menus. Your default panels
contain menus, so you can use a combination of menus and panels to perform your
tasks. The Menu Panel contains Applications and Actions menus. You can also add the
GNOME Menu to your panels.

You can use the Applications menu and the Actions menu to access almost all of the
standard applications, commands, and configuration options. You can also access the
items in the Applications and Actions menus from the GNOME Menu. The items in
the Actions menu are at the top level of the GNOME Menu.

To add a GNOME Menu to a panel, right-click on the panel then choose Add to Panel
→ GNOME Menu. The GNOME Menu is represented by a stylized footprint, as
follows:

Click on the GNOME Menu button on a panel to open the GNOME Menu.

You can add as many additional menus as you want to any of your panels. To open a
menu that you add to a panel, click on the menu icon on the panel. You can perform
other actions on your menus, such as copy menu items to panels.
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Windows in the Desktop Environment
You can display many windows at the same time in your desktop environment. Each
window has a frame. The window frame contains active control elements that you can
use to work with the window.

Types of Windows
The desktop environment features the following types of window:

� Application windows

When you run an application, a frame usually borders the window. The top edge
of the application window contains a titlebar. The titlebar contains buttons that you
can use to work with the window. The buttons in an application window frame
enable you to perform actions such as open the Window Menu, or close the
window. The Window Menu provides commands that you can perform on the
window.

� Dialog windows

Dialog windows are associated with interactive processes. A dialog window
consists of the window frame, and a single interactive pane that provides
information and controls for the user. This manual refers to the interactive part of a
dialog window as a dialog. The frame of a dialog window contains buttons that
enable you to open the Window Menu, or to close the dialog window.

To Manipulate Windows
You use the frame of an application window or dialog window to perform various
actions with the window. Most of the control elements are located on the top edge of
the window frame. Figure 2–3 shows the top edge of a frame for a typical application
window.

34 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



FIGURE 2–3 Top Edge of Frame for a Typical Application Window

The active control elements of the window frame are as follows:

Control Element Description

Window Menu button Click on the Window Menu button to open the
Window Menu.

Titlebar You can use the titlebar to move and shade the
window.

Minimize button Click on the Minimize button to minimize the
window.

Maximize button You can use the Maximize button to maximize and
restore the window.

To maximize a window click on the Maximize button.
To restore the window click on the Maximize button
again.

Close Window button Click on the Close Window button to close the
window.

Border Right-click on the border to open the Window Menu.

To change the size of windows grab the border of the window, but not the titlebar.
Drag the border until the window is the size that you require.

To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.

You can use the following elements to give focus to a window:
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Element Action

Mouse Click on the window, if the window is visible.

Shortcut keys Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.

Window List Click on the button that represents the window in Window
List.

Workspace Switcher Click on the window that you want to give focus to in the
Workspace Switcher display.

Workspaces
You can display many windows at the same time in your desktop environment. Your
windows are displayed in subdivisions of your desktop environment that are called
workspaces. A workspace is a discrete area in which you can work.

Every workspace contains the same desktop, the same panels, and the same menus.
However, you can run different applications, and open different windows in each
workspace. You can display only one workspace at a time ion your desktop
environment but you can have windows open in other workspaces.

Workspaces enable you to organize your desktop environment when you run many
applications at the same time. When your current workspace becomes crowded with
windows, you can move your work to another workspace. You can also switch to
another workspace then start more applications.

Workspaces are displayed in the Workspace Switcher applet. In Figure 2–4, Workspace
Switcher contains four workspaces. The first three workspaces contain open windows.
The last workspace does not contain currently active windows.

FIGURE 2–4 Workspaces Displayed in Workspace Switcher

To Switch Between Workspaces
You can switch between workspaces in the following ways:

� In Workspace Switcher, click on the workspace where you want to work.
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� Press Ctrl + Alt + right arrow to switch to the workspace on the right of the current
workspace.

� Press Ctrl + Alt + left arrow to switch to the workspace on the left of the current
workspace.

To Add Workspaces
To add workspaces to your desktop environment, right-click on the Workspace
Switcher applet, then choose Preferences. The Workspace Switcher Preferences dialog
is displayed. Use the Number of workspaces spin box to specify the number of
workspaces that you require.

Nautilus File Manager
The Nautilus file manager provides an integrated access point to your files,
applications, and FTP sites. To open a Nautilus window, choose Applications → Home
Folder. The following figure shows a Nautilus window that displays the contents of a
folder.
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A Nautilus window contains the following panes:

Side pane Enables you to navigate through your files. This pane also displays
information about the current file or folder. The side pane is on the left
side of the window.

View pane Displays the contents of files and folders. The view pane is on the right
side of the window.

Nautilus enables you to do the following:

� View files and folders

You can view your files and folders as icons or as a list. You can view the contents
of some types of file within a Nautilus window. Alternatively, you can open the
files in the appropriate application from Nautilus.

� Manage your files and folders

38 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



You can use Nautilus to create, move, copy, rename, and remove files and folders.

� Run scripts

You can run scripts from Nautilus, and you can select files and folders on which to
run your scripts.

� Customize your files and folders

You can add emblems to your files and folders to indicate particular states. For
example, you can add an Important emblem to a file to indicate that the file is
important. You can also customize folders in the following ways:

� Add a note to a folder.
� Specify a custom background pattern for a folder.
� Specify a zoom setting for a folder.

Nautilus also creates the desktop.

To Open Files From the File Manager
To navigate to the folder where the file that you want to open resides, double-click on
the folder icons in the view pane. When the file that you want to open is displayed,
double-click on the file icon to open the file.

To Move Files Between Folders
You can move files between folders by opening two or more Nautilus windows. Open
a different folder in each window, then drag the files from one window to the other.

Desktop and Desktop Objects
The desktop is an active component of the desktop. You can use the desktop to
perform the following actions:

� Start your applications, and open your files and folders.

You can add desktop objects for convenient access to the files, folders, and
applications that you use frequently. For example, you add a launcher for an
application that you use often.

� Open the Desktop menu.
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Right-click on the desktop to open the Desktop menu. You can use the Desktop
menu to perform actions on the desktop.

The file manager manages the desktop.

To Open Desktop Objects
To open an object from the desktop, double-click on the object. You can set your
preferences in a file manager window so that you click once on an object to execute the
default action.

To Add Objects to the Desktop
You can add desktop objects for convenient access to files, folders, and applications
that you use frequently. You can add objects to your desktop in the following ways:

� Use the Desktop menu to add a launcher to the desktop.

� Drag an object from a file manager window to the desktop. For example, you can
create a symbolic link to a file that you use often, then drag the link to your
desktop. The icon for the link is moved to the desktop. To open the file,
double-click on the icon. You can also drag files and folders to the desktop.

� Drag an application launcher from a menu to the desktop. For example, you can
open a menu that contains a launcher for an application that you use often, then
drag the launcher to your desktop.

Start Here Location

The Start Here location enables you to access the following functions:

� Applications
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Double-click on Applications to access your key GNOME applications. You can
also access the Applications menu through the GNOME Menu and the Menu
Panel.

� Desktop Preferences

Double-click on Desktop Preferences to customize your desktop environment.

� Programs that enable you to configure your system as a server, and to choose other
system settings.

You can access the Start Here location in the following ways:

� From a Nautilus window

Choose Go → Start Here. The contents of the Start Here location are displayed in
the window.

� From the desktop

Double-click on the Start Here object on the desktop. The contents of the Start
Here location are displayed in a file manager window.

Desktop Environment Preferences
You can use desktop environment preference tools to configure almost every feature of
the desktop environment. Each tool controls a particular part of the behavior of the
desktop environment. For example, you can use a preference tool to select a theme for
your desktop environment. A theme is a group of coordinated settings that specify the
visual appearance of a part of your interface.

For convenience, the tools are grouped under the following headings:

� Basic
� Accessibility
� Advanced

You can open your desktop environment preference tools in either of the following
ways:

� Choose Applications → Desktop Preferences. Choose the item that you require
from the submenus.

� Double-click on the Start Here object on the desktop. A file manager window
opens at the Start Here location. Double-click on the Desktop Preferences object in
the file manager window to display the preference tools. Double-click on the item
that you require.
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Applications
The applications that are provided with the GNOME Desktop share several
characteristics. For example, the applications have a consistent look-and-feel. The
applications share characteristics because the applications use the same programming
libraries. An application that uses the standard GNOME programming libraries is
called a GNOME-compliant application. For example, Nautilus and the gedit text editor
are GNOME-compliant applications.

GNOME provides libraries in addition to the libraries provided by your operating
system. The libraries enable GNOME to run your existing applications as well as
GNOME-compliant applications. For example, if your operating system is
UNIX-based, you can run your current X11 applications and Motif applications from
the GNOME Desktop.

Some of the features of GNOME-compliant applications are as follows:

� Consistent look-and-feel

GNOME-compliant applications have a consistent look-and-feel.
GNOME-compliant applications use the look-and-feel settings that you specify in
the preference tools. You can use the following tools to change the look-and-feel of
your GNOME-compliant applications:

� Applications → Desktop Preferences → Menus & Toolbars
� Applications → Desktop Preferences → Theme

� Menubars, toolbars, and statusbars

Most GNOME-compliant applications have a menubar, a toolbar, and a statusbar.
The menubar always contains a File menu and a Help menu. The File menu always
contains an Quit menu item, and the Help menu always contains an About menu
item.

A toolbar is a bar that appears under the menubar. A toolbar contains buttons for
the most commonly-used commands. A statusbar is a bar at the bottom of a
window that provides information about the current state of what you are viewing
in the window. GNOME-compliant applications might also contains other bars. For
example, Nautilus contains a location bar.

Some of the bars in GNOME-compliant applications are detachable. That is, the bar
has a handle that you can grab then drag the bar to another location. You can drag
the bar to snap to another side of the window, or to another part of the desktop
environment. For example, you can detach the menubar, toolbar, and location bar
in the file manager.

� Default shortcut keys
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GNOME-compliant applications use the same shortcut keys to perform the same
actions. For example, to quit a GNOME-compliant application, press Ctrl + Q. To
undo an action in a GNOME-compliant application, press Ctrl + Z.

� Drag-and-drop

GNOME-compliant applications use the same protocol to implement
drag-and-drop operations. Therefore, GNOME-compliant applications provide
consistent feedback when you drag-and-drop items.

The use of the same protocol also enables GNOME-compliant applications to
interoperate in a sophisticated manner. For example, GNOME-compliant
applications recognize the format of the items that you drag. When you drag a
HTML file from a Nautilus window to a web browser, the file is displayed in
HTML format in the browser. However, when you drag the HTML file to a text
editor, the file is displayed in plain text format in the text editor.

To Find Out More
The desktop environment provides help if you want to find out more about the
following areas:

� Desktop environment topics
� Applets
� Applications

To Find Out More About Desktop Environment
Topics
You can find out more about particular desktop environment topics in the integrated
Yelp help system. To start the Yelp help system, choose Applications → Help.

To Find Out More About Applets
To find out more about a specific applet, right-click on the applet, then choose Help.
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To Find Out More About Applications
To find out more about a specific application, start the application, then choose Help
→ Contents. Alternatively, start the application then press F1.
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CHAPTER 3

GNOME Desktop Sessions

This chapter provides the information you need to start, manage, and end a GNOME
Desktop session.

� “Starting a Session” on page 45
� “To Lock Your Screen” on page 46
� “Managing the Session” on page 47
� “Ending a Session” on page 49

Starting a Session
A session occurs between the time that you log in to the desktop environment and the
time that you log out. The login screen, displayed by the Login Manager, is your
gateway to the desktop environment. The login screen provides fields for you to enter
your username and password. The Options menu on the login screen lists your login
options, for example you can select the language of your session.

You start a session when you log in. The session manager starts after the Login
Manager authenticates your username and password. The session manager enables
you to manage the session. For example, you can save the state of your most recent
session and return to that session the next time that you log in. The session manager
saves and restores the following:

� The appearance and behavior settings, for example fonts, colors, and mouse
settings.

� The applications that you were running, for example file manager and text editor
windows. You cannot save and restore applications that the session manager does
not manage. For example, if you start the vi editor from the command line in a
terminal window, session manager cannot restore your editing session.
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To Log in to a Session
To log in to a session, perform the following actions.

1. Choose Options → Session. Choose the GNOME Desktop from the list of available
desktop environments.

2. Enter your login name in the field on the Login Manager dialog, then click OK.

3. Enter your password in the field on the Login Manager dialog, then click OK.

When you log in successfully, the session manager starts a session. If this is the first
time you log in, then the session manager starts a new session. If you have logged in
before, then the session manager restores your previous session.

To Start a Session in a Different Language
To start a session in a different language, perform the following actions.

1. On the login dialog, choose Options → Session. Choose the GNOME Desktop from
the list of available desktop environments.

2. On the login dialog, choose Options → Language.

3. Choose the language group that includes the language that you want.

4. Choose a language.

5. Log in.

Your system administrator sets the default language for your system. The Options
menu on the Login Manager dialog enables you to access other languages. When you
choose a language in the Options menu, your system sets the LANG variable for your
session. The system restores the default language at the end of the session.

To Lock Your Screen

To lock the screen, perform one of the following actions:

� Choose Actions → Lock Screen.
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� If the Lock button is present on a panel, click on the Lock button.

To add the Lock button to a panel, right-click on the panel. Choose Add to Panel →
Lock button.

When you lock your screen, the screensaver starts. To unlock the screen, move your
mouse to display the locked screen dialog. Enter your username and password in the
locked screen dialog, then press Return.

Note – To lock your screen correctly, you must have a screensaver enabled.

Managing the Session
To configure the session management of the desktop environment, choose
Applications → Desktop Preferences → Advanced → Sessions. The Sessions
preference tool recognizes the following types of application:

� Applications that are session-managed. When you save the settings for your
session, the session manager saves all of the session-managed applications. If you
log out, then log in again, the session manager automatically starts the
session-managed applications.

� Applications that are not session-managed. When you save the settings for your
session, the session manager does not save any applications that are not
session-managed. If you log out, then log in again, the session manager does not
start non-session-managed applications. You must start the application manually.
Alternatively, you can use the Sessions preference tool to specify
non-session-managed applications that you want to automatically start.

Defining Session Behavior When You Log In and
Log Out
To set how a session behaves when you log in and log out, choose Applications →
Desktop Preferences → Advanced → Sessions. Make the changes you require in the
Session Options tabbed section. For example, you can select to display a splash screen
when you log in.
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To Use Startup Applications
You can configure your sessions to start with applications that are not
session-managed. To configure non-session-managed startup applications, choose
Applications → Desktop Preferences → Advanced → Sessions. Use the Startup
Programs tabbed section to add, edit, and delete applications. If you save your
settings and log out, the next time that you log in, the startup applications start
automatically.

To Browse Applications in the Current Session
To browse the applications in the current session, choose Applications → Desktop
Preferences → Advanced → Sessions. The Current Session tabbed section lists the
following:

� All GNOME applications that are currently running, that can connect to the session
manager, and that can save the state of the application.

� All desktop preference tools that can connect to the session manager, and that can
save the state of the tool.

You can use the Current Session tabbed section to perform a limited number of
actions on the session properties of an application or preference tool. For example, you
can edit the startup order, and restart style of any GNOME application or preference
tool that is in the list.

To Save Session Settings
To save your session settings, perform the following steps:

1. Configure your session to automatically save settings when you end the session. To
configure your session, choose Applications → Desktop Preferences → Advanced
→ Sessions. The Sessions preference tool starts. Select the Automatically save
changes to session option on the Session Options tabbed section.

2. End your session.

If you do not select the Automatically save changes to session option, when you log
out, a dialog asks if you want to save your current settings. To save your settings,
select the option, then continue to log out.
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Ending a Session

To end your session, close all your currently active processes, then perform one of the
following actions:

� Choose Actions → Log Out.
� Open the GNOME Menu, then choose Log Out.
� Click on the Log Out button.

Before you end a session, you might want to save your current settings so that you can
restore the session later. During the logout process, a dialog asks if you want to save
your current settings. In the Sessions preference tool, you can select an option to
automatically save your current settings.
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CHAPTER 4

Working With Panels

The information in this chapter describes how to use panels.

� “Introducing Panels” on page 51
� “Managing Your Panels” on page 53
� “Panel Objects” on page 59
� “Launchers” on page 63
� “Menus” on page 67
� “Applets” on page 61
� “Drawers” on page 68
� “Log Out Button” on page 71
� “Lock Button” on page 71

Introducing Panels
A panel is an area in your desktop environment from which you can run applications
and applets, and perform other tasks. When you start a session for the first time, the
desktop environment contains the following panels:

� Menu Panel
� Edge panel at the bottom of the screen

The following sections describe these panels.

Menu Panel
The Menu Panel stretches the full length of the top edge of your screen. The Menu
Panel includes textual rather than graphical menus. Figure 4–1 shows the Menu Panel.
Your system administrator might have set your default Menu Panel according to your
local requirements, so you might see a slightly different Menu Panel.
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FIGURE 4–1 Typical Menu Panel

The typical Menu Panel contains the following objects:

Object Description

Applications menu The Applications menu contains the standard GNOME
applications.

Actions menu The Actions menu provides commands that enable you to
perform desktop tasks.

Home folder launcher Click on this launcher to open your home folder in a Nautilus
file manager window.

Terminal launcher Click on this launcher to start the Terminal application. Terminal
provides access to a UNIX command line.

Volume Control applet Volume Control enables you to control the volume of the speaker
on your system.

Clock applet Clock shows the current time. Click on the time readout to
display a menu of clock commands.

Window list icon The window list is a list of all your open windows. To give focus
to a window, click on the icon at the extreme right of the Menu
Panel, then choose the window.

Unlike other types of panel, you can only have one Menu Panel at a time on your
desktop.

Bottom Edge Panel
On startup, an edge panel stretches the full length of the bottom edge of the screen.
Figure 4–2 shows a typical bottom edge panel. Your system administrator might have
set your default bottom edge panel according to your local requirements, so you might
see a slightly different bottom edge panel.

FIGURE 4–2 Typical Bottom Edge Panel

The bottom edge panel contains the following applets:
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� Window List: Displays a button for each window that is open. Window List
enables you to minimize and restore windows.

� Workspace Switcher: Enables you to navigate between your workspaces.

You can change the behavior and appearance of your bottom edge panel to suit your
requirements. You can also add or remove objects from your bottom edge panel. You
can create multiple panels, and choose different properties, objects, and backgrounds
for each panel. You can also hide panels.

Managing Your Panels
The following sections describe how to manage your panels.

To Add a New Panel
You can add different types of panels to your desktop environment. Table 4–1 lists the
types of panel that you can add, and their characteristics.

TABLE 4–1 Types of Panel

Panel Type Snap Behavior Size

Corner Panel Snaps to one of the edges of the
screen, but can only snap to the
center or the corner of the edge.

Stretches as much as required to
display the objects on the panel.

Edge Panel Snaps to one of the edges of the
screen. The startup panel at the
bottom of the screen is an example
of an edge panel.

Stretches the full length of the
edge that the panel snaps to.

Floating Panel Does not snap to anything. You
can place a floating panel
anywhere in your desktop
environment.

Stretches as much as required to
display the objects on the panel.

Sliding Panel Snaps to one of the edges of the
screen, can snap to any point on
the edge.

Stretches as much as required to
display the objects on the panel.
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TABLE 4–1 Types of Panel (Continued)
Panel Type Snap Behavior Size

Menu Panel Snaps to the top edge of the
screen. You cannot move the
Menu Panel.

Stretches the full length of the top
edge of the screen. You can only
have one Menu Panel in your
desktop environment.

To add a panel perform the following steps:

1. Right-click on a vacant space on any panel, then choose New Panel.

2. Choose the type of panel that you want to add. The new panel is added to your
desktop environment. The new panel contains no objects, except for a Menu Panel.

You can customize the new panel to suit your preferences.

To Interact With a Panel
To interact with a panel, you must left-click, middle-click, or right-click on a vacant
space on the panel. You can also middle-click or right-click on one of the hide buttons
to select the panel, if the panel has no vacant space. If the hide buttons are not visible
on a panel, modify the properties of the panel so that the hide buttons are visible.

You use the mouse buttons to interact with a panel in the following ways:

Middle-click Enables you to grab a panel, then drag the panel to a new location.

Right-click Opens the panel popup menu.

To Move a Panel
You can move panels to different locations. To move a panel, middle-click and hold on
any vacant space on the panel, then drag the panel to the new location.

When you drag a floating panel, the panel follows the mouse pointer. The panel does
not snap to any part of the desktop environment. When you drag a corner panel, an
edge panel, or a sliding panel, the panel snaps to the edge of the screen.

Note – You cannot move the Menu Panel.
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To Hide a Panel
You can hide or show panels, except for the Menu Panel. To hide a panel, use a hide
button. If the hide buttons are not visible on a panel, modify the panel properties so
that the hide buttons are visible.

Hide buttons are at either end of a panel. The hide buttons contain an optional arrow
icon. The following illustration shows hide buttons.

To hide a panel, click on one of the hide buttons. The panel reduces in the direction of
the arrow on the hide button. The hide button at the other end of the panel remains
visible.

To show a hidden panel again, click on the visible hide button. The panel expands in
the direction of the arrow on the hide button. Both hide buttons are now visible.

You can set a panel to autohide. When you set autohide, the panel hides automatically
when the mouse is not pointing to the panel. The panel reappears when you point to
the part of the screen where the panel resides. To set your panel to autohide, modify
the properties of the panel.

Note – On a corner panel, the behavior of the hide buttons is slightly different. If the
panel is in one of the corners of the screen, you can use the hide buttons as follows:

� To hide the panel, click the hide button that is closest to the edge of the screen, as
normal.

� To move the panel to the opposite corner of the screen, click the hide button that is
farthest from the edge of the screen.

To Modify Panel Properties
To modify preferences for all panels, choose Applications → Desktop Preferences →
Advanced → Panel, then make the changes that you require. For example, you can
specify various settings related to the appearance and behavior of panel objects.

You can also modify properties for each individual panel. You can change the features
for each panel, such as the type of the panel, the hide behavior, and the visual
appearance.
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Note – You cannot modify properties for the Menu Panel.

To modify the properties of a panel perform the following steps:

1. Right-click on a vacant space on the panel, then choose Properties to display the
Panel Properties dialog. The following figure shows the Panel Properties dialog
for the edge panel at the bottom of your screen.

The Panel Properties dialog contains the following tabbed sections:

� Panel-type Panel
� Background

2. To modify panel size, position, and hiding properties, click on the Panel-type Panel
tab. The following table describes the dialog elements on the Panel-type Panel
tabbed section:

Dialog Element Description

Position Select the position of the panel on your screen. Click on the
required position for the panel.

Size Select the size of the panel.

Orient horizontally Floating panel only. Select this option to display the panel
horizontally.
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Dialog Element Description

Orient vertically Floating panel only. Select this option to display the panel
vertically.

Horizontal offset Floating panel only. Use the spin box to specify the distance of
the panel from the left edge of the screen.

Vertical offset Floating panel only. Use the spin box to specify the distance of
the panel from the top edge of the screen.

Screen edge offset Sliding panel only. Use this spin box to specify the distance
between your panel and the edge of the screen, in pixels.

Autohide Select this option to enable autohide.

Show hide buttons Select this option to display hide buttons on your panel.

Arrows on hide button Select this option to display arrows on the hide buttons, if the
hide button is enabled.

3. To modify the panel background, click on the Background tab. The Background
tabbed section contains the following elements:

Dialog Element Description

Background Type Choose the type of background for the panel. The choices are as
follows:
� Default: The default background type. The standard

background depends on the settings in Applications →
Desktop Preferences → Theme.

� Color: Enables you to choose a color for the panel
background.

� Image: Enables you to choose an image for the panel
background.

Background Color If Background Type is Color, click on the Color to use button to
display the color selector dialog. Choose the color that you
require from the color selector dialog.
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Dialog Element Description

Image If Background Type is Image, choose the image to use on the
background of the panel. Specify the following settings for the
image background:

Do not scale image to fit Select this option to tile the
background image to fit the panel
background.

Scale image Select this option to scale the
background image to fit the panel
background. The width-to-height
ratio of the image is retained.

Stretch image Select this option to stretch the
background image to fit the panel
background. The width-to-height
ratio of the image is not retained.

Rotate image for vertical
panels

Select this option to rotate the
background image on a vertical
panel.

You can also drag a color or image on to a panel to set the color or image as the
background of the panel. For more information, see “To Drag a Color or Image to
the Background of a Panel” on page 58.

4. Click Close to close the Panel Properties dialog.

To Drag a Color or Image to the Background of a
Panel
You can drag a color or image on to a panel to set the color or image as the
background of the panel. You can drag a color or image from many applications. For
example, you can drag a color from the Nautilus file manager to a panel to set the
color as the background of the panel. You can also drag a color from any color selector
dialog.

You can drag an image to a panel to set the image as the background of the panel. You
can also drag pattern images from the Nautilus file manager application to set the
background of the panel.

To Delete a Panel
To delete a panel from your desktop environment, right-click on the panel that you
want to delete, then choose Delete This Panel.
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Note – You must always have at least one panel in your desktop environment. If you
have only one panel in your desktop environment, you cannot delete that panel.

Panel Objects
This section describes the objects that you can add to your panels, and use from your
panels.

Interacting With Panel Objects
You use the mouse buttons to interact with a panel object in the following ways:

Left-click Launches the panel object.

Middle-click Enables you to grab an object, then drag the object to a new location.

Right-click Opens the panel object popup menu.

You interact with applet panel objects in a different way. For more information, see “To
Select an Applet” on page 62.

To Add an Object to a Panel
You can add an object to a panel in several ways, as follows:

� From the panel popup menu

Right-click on a vacant space on a panel to open the panel popup menu. The panel
popup menu contains an Add to Panel submenu. The Add to Panel submenu
enables you to add the following objects to your panels:

� Accessory applets
� Amusement applets
� Internet applets
� Multimedia applets
� Utility applets
� Launchers
� Launchers from menus
� GNOME Menu
� Drawers
� Log Out button
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� Lock button

� From any menu

When you right-click on a launcher in any menu, a popup menu for the launcher
opens. You can use this popup menu to add the launcher to a panel.

You can also drag menus, launchers, and applets from menus to panels.

� From the file manager

Each launcher and applet corresponds to a .desktop file. You can drag the
.desktop file on to your panels to add the launcher or applet to the panel.

Each menu corresponds to a directory. You can drag the directory on to your panels
to add the directory to the panel as a menu object.

To Modify the Properties of an Object
Some panel objects have a set of associated properties. The properties are different for
each type of object. The properties specify details such as the following:

� The command that starts a launcher application.
� The location of the source files for a menu.
� The icon that represents the object.

To modify the properties of an object perform the following steps:

1. Right-click on the object to open the panel object popup menu, as shown in Figure
4–3.

FIGURE 4–3 Panel Object Popup Menu

2. Choose Properties. Use the Properties dialog to modify the properties as required.
The properties in the Properties dialog depend on which object you select in step 1.

3. Click OK to apply the changes, then close the Properties dialog.

To Move a Panel Object
You can move panel objects within a panel, and from one panel to another panel. You
can also move objects between panels and drawers.
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To move a panel object, middle-click and hold on the object and drag the object to a
new location. When you release the middle mouse button, the object anchors at the
new location.

Alternatively, you can use the panel object popup menu to move an object, as follows:

1. Right-click on the object, then choose Move.

2. Point to the new location for the object, then click any mouse button to anchor the
object to the new location. This location can be on any panel that is currently in
your desktop environment.

Movement of a panel object affects the position of other objects on the panel. To
control how objects move on a panel, you can specify a movement mode. To specify
the movement mode, press one of the following keys as you move the panel object:

Key Movement Mode Description

No key Switched movement The object swaps places with other panel objects.
Switched movement is the default movement
mode.

Alt key Free movement The object jumps over other panel objects into the
next vacant space on the panel.

Shift key Push movement The object pushes other panel objects further
along the panel.

To Remove a Panel Object
To remove an object from a panel right-click on the object to open the panel object
popup menu, then choose Remove From Panel.

Applets
An applet is a small application whose user interface resides within a panel. You use
the applet panel object to interact with the applet. For example, the following figure
shows the following applets, from left to right:

� Window List: Displays the windows currently open on your system.

� CD Player: Enables you to control the compact disc player on your system.

� Volume Control: Enables you to control the volume of the speaker on your system.
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To Add an Applet to a Panel
You can add an applet to a panel from the panel popup menu. Right-click on any
vacant space on the panel to open the panel popup menu. Choose Add to Panel, then
choose the applet that you want to add from one of the following submenus:

� Accessories
� Amusements
� Internet
� Multimedia
� Utility

Alternatively, drag the applet from the submenu on to the panel.

To Select an Applet
To modify the properties of an applet, you must first right-click on the applet to
display the panel object popup menu. To move an applet, you must middle-click on
the applet.

Some restrictions apply on where you can click on an applet in order to display the
panel object popup menu, or to move the applet, as follows:

� Some applets have popup menus of applet-specific commands that open when you
right-click on particular parts of the applet. For example, the Window List applet
has a vertical handle on the left side, and buttons that represent your windows on
the right side. To open the panel object popup menu for the Window List applet,
you must right-click on the handle. If you right-click on a button on the right side,
a popup menu for the button opens.

� Some applets have areas that you cannot use to select the applet. For example, the
Command Line applet has a field in which you enter commands. You cannot
middle-click or right-click on this field to select the applet. Instead, middle-click or
right-click on another part of the applet.

To Modify Preferences for an Applet
To modify the preferences for an applet perform the following steps:
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1. Right-click on the applet, then choose Preferences. Use the Preferences dialog to
modify the preferences as required. The preferences for applets vary depending on
the applet.

2. Click Close to close the Preferences dialog.

Launchers
When you click on a launcher, you initiate one of the following actions:

� Start a particular application.
� Execute a command.
� Open a folder in a file manager window.
� Open a browser at a particular Uniform Resource Locator (URL). A URL is the

address of a particular location on the Web.

You can find launchers in the following places in the desktop environment:

� Panels: On panels, launchers are represented by icons.
� Menus: On menus, launchers are represented by menu items. The menu items

usually have an icon beside the menu item.
� Desktop: On the desktop, launchers are represented by icons.

You can modify the properties of a launcher. For example, the properties of a launcher
include the name of the launcher, the icon that represents the launcher, and how the
launcher runs.

To Add a Launcher to a Panel
You can add a launcher to a panel in one of the following ways:

� From the panel popup menu

To create a new launcher, right-click on any vacant space on the panel, then choose
Add to Panel → Launcher. A Create Launcher dialog is displayed. For more
information on how to complete this dialog, see “To Create a Launcher With the
Create Launcher Dialog” on page 64.

Alternatively, to add an existing launcher to the panel, choose Add to Panel →
Launcher from menu from the panel popup menu. Choose the launcher that you
want to add from the menu.

� From any menu

To add a launcher to a panel from any menu, perform one of the following steps:
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� Open the menu that contains the launcher from the panel where you want the
launcher to reside. Right-click on the title of the launcher. Choose Add this
launcher to panel.

� Open a menu that contains the launcher. Drag the launcher on to the panel.

� From the file manager

To add a launcher to a panel from the file manager, find the .desktop file for the
launcher in your file system. To add the launcher drag the .desktop file to the
panel.

To Create a Launcher With the Create Launcher
Dialog
To create a launcher with the Create Launcher dialog perform the following steps:

1. Right-click on any part of a panel to open the panel popup menu. Choose Add to
Panel → Launcher to display the Create Launcher dialog. The dialog displays the
Basic tabbed section.

2. Enter the properties of the launcher in the dialog. The following table describes the
dialog elements on the Basic tabbed section:

64 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



Dialog Element Description

Name Use this text box to specify the name of the launcher. You can use
the Advanced tab to add translations of the name. This name is
the name that appears when you add the launcher to a menu or to
the desktop.

Generic name Use this text box to specify the class of application to which the
launcher belongs. For example, you might type Text Editor in
this text box for a gedit launcher. You can use the Advanced tab to
add translations of the generic name.

Comment Use this text box to specify a short description of the launcher.
The comment is displayed as a tooltip when you point to the
launcher icon on the panel. You can use the Advanced tabbed
section to add translations of the comment.

Command Use this field to specify a command to execute when you click on
the launcher.

Type Use this drop-down combination box to specify the type of
launcher. Select from the following:
� Application: Select this option to create a launcher that starts

an application.
� Link: Select this option to create a launcher that links to a file,

folder, or FTP site.

Icon Choose an icon to represent the launcher. To choose an icon, click
on the No Icon button. An icon selector dialog is displayed.
Choose an icon from the dialog. Alternatively, to choose an icon
from another directory, click Browse. When you choose an icon,
click OK.

Run in Terminal Select this option to run the application or command in a terminal
window. Choose this option for an application or command that
does not create a window in which to run.

3. To set advanced properties for the launcher, click on the Advanced tab. The
Launcher Properties dialog displays the Advanced tabbed section.
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4. Enter the advanced properties of the launcher in the dialog. The following table
describes the dialog elements on the top part of the Advanced tabbed section:

Dialog Element Description

Try this before using Enter a command here to check before starting the launcher.
If the command is executable and is in your path, the
launcher appears on the panel.

Documentation Enter the path to the help file for the launcher. If you enter a
path in this field, a Help on launcher-name Application menu
item is displayed on the popup menu for the launcher.

5. You can also add a translation of the Name, Generic name, and Comment fields
from the Basic tabbed section. To add a translation, enter the details of the
translation in the Name/Comment translations table as follows:

Field Description

First field Enter the two-letter code for the language for which you want to add a
translation.

Second field Enter the translation of the Name of the launcher.

Third field Enter the translation of the Generic name of the launcher.

Fourth field Enter the translation for the Comment for the launcher.

Then click on the Add/Set button.
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To edit a translation, select the translation. The translated text appears in the lower
part of this dialog. Edit the fields as required, then click on the Add/Set button.

To remove a translation, select the translation, then click on the Remove button.

6. To create the launcher and close the Launcher Properties dialog, click OK.

To Modify the Properties of a Launcher
To modify the properties of a launcher perform the following steps:

1. Right-click on the launcher to open the panel object popup menu.

2. Choose Properties. Use the Launcher Properties dialog to modify the properties as
required. For more information on the Launcher Properties dialog, see “To Create
a Launcher With the Create Launcher Dialog” on page 64.

3. Click Close to close the Launcher Properties dialog.

Menus
You can add the following types of menu to your panels:

� System menus: System menus contain the standard applications and tools that you
can use in your desktop environment. The Applications menu and Actions menu
are system menus. To add a system menu to a panel, right-click on a launcher in
the menu, then choose Entire menu → Add this as menu to panel.

� GNOME Menu: You can access almost all of the standard applications, commands,
and configuration options from the GNOME Menu. To add a GNOME Menu to a
panel, right-click on any vacant space on the panel, then choose Add to Panel →
GNOME Menu. You can add as many GNOME Menu objects to your panels as you
want. By default, the GNOME Menu is represented on panels by a stylized
footprint icon, as follows:

Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu or drawer. Figure 4–4 shows how
menus typically appear on panels.
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FIGURE 4–4 Typical Menu Objects on a Panel

Drawers
A drawer is an extension of a panel. You can open and close a drawer in the same way
that you can show and hide a panel. A drawer can contain all panel objects, including
launchers, menus, applets, other panel objects, and other drawers. When you open a
drawer, you can use the objects in the same way that you use objects on a panel.

The following figure shows an open drawer that contains two panel objects.

The arrow on the drawer icon indicates that the icon represents a drawer or menu.

You can add, move, and remove objects from drawers in the same way that you add,
move, and remove objects from panels.

To Open and Close a Drawer
To open a drawer, click on the drawer object in a panel. You can close a drawer in the
following ways:

� Click on the drawer.
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� Click on the drawer hide button.

To Add a Drawer to a Panel
You can add a drawer to a panel in the following ways:

� From the panel popup menu

Right-click on any vacant space on the panel, then choose Add to Panel → Drawer.

� From any menu

You can add a menu as a drawer object to a panel.

To add a menu as a drawer to a panel, open the menu from the panel. Right-click
on any launcher in the menu, then choose Entire menu → Add this as drawer to
panel.

To Add an Object to a Drawer
You add an object to a drawer in the same way that you add objects to panels. For
more information, see “To Add an Object to a Panel” on page 59.

To Modify Drawer Properties
To modify preferences for all panels and drawers, choose Applications → Desktop
Preferences → Advanced → Panel, then make the changes that you require. For
example, you can select various options related to the appearance and behavior of
objects on panels and drawers. You can also select options that relate to drawers only.
For example, you can select an option to close your drawers when you click on a
launcher in the drawer.

You can also modify other properties for each individual drawer. You can change
features for each drawer, such as the visual appearance of the drawer and whether the
drawer has hide buttons.

To modify properties for a drawer perform the following steps:

1. Right-click on the drawer, then choose Properties to display the Panel Properties
dialog. The dialog displays the Drawer tabbed section.
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2. Select the properties for the drawer in the dialog. The following table describes the
elements on the Drawer tabbed section:

Dialog Element Description

Size Select the size of the drawer.

Tooltip/Name Use this text box to specify a name for the drawer. The name
appears as a tooltip when you point at the drawer on the panel.

Icon Choose an icon to represent the drawer. Click on the Icon
button to display an icon selector dialog. Choose an icon from
the dialog. Alternatively, click Browse to choose an icon from
another directory. When you choose an icon, click OK.

Enable hide button Select this option to display a hide button when the drawer
opens.

Enable hide button
arrow

Select this option to display an arrow on the hide button if the
hide button is enabled.

3. You can use the Background tabbed section to set the background for the drawer.
For information on how to complete the Background tabbed section, see the step
on this topic in “To Modify Panel Properties” on page 55. You can also drag a color
or image on to a drawer to set the color or image as the background of the drawer.
For more information, see “To Drag a Color or Image to the Background of a
Panel” on page 58.

4. Click Close to close the Panel Properties dialog.
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Log Out Button

The Log Out button begins the process to log out of a GNOME session.

To add a Log Out button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Log Out Button. To log out of your session or shut down your
system, click on the Log Out button.

Lock Button

The Lock button locks your screen and activates your screensaver. To access your
session again, you must enter your password. To lock your screen correctly, you must
have a screensaver enabled.

To add a Lock button to a panel, right-click on any vacant space on the panel. Choose
Add to Panel → Lock Button.

Right-click on the Lock button to open a menu of screensaver-related commands.
Table 4–2 describes the commands that are available from the menu.

TABLE 4–2 Lock Screen Menu Items

Menu Item Function

Activate Screensaver Activates the screensaver immediately, but does not
lock the screen.
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TABLE 4–2 Lock Screen Menu Items (Continued)
Menu Item Function

Lock Screen Locks the screen immediately. This command
performs the same function as when you click on the
Lock button.

Kill Screensaver Daemon Terminates the screensaver process. After you
terminate the screensaver process, you cannot lock
your screen.

Restart Screensaver Daemon Terminates and restarts the screensaver process. Use
this command after you change your password.
When you restart the screensaver process, use your
new password with the screensaver.

Properties Displays an XScreenSaver dialog that you can use to
configure the screensaver.
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CHAPTER 5

Working With Menus

This chapter describes how to use menus in the GNOME Desktop.

� “Introduction to Menus” on page 73
� “Menu Features” on page 74
� “Applications Menu” on page 76
� “Actions Menu” on page 76
� “GNOME Menu” on page 79

Introduction to Menus
You can access all desktop environment functions through menus. The Menu Panel
contains menus, so you can use a combination of menus and panels to perform your
tasks. You can perform various actions on your menus, such as copy menu items to
panels.

You can access the following menus in your desktop environment:

� Applications menu: You can access many of your applications, commands, and
configuration options from the Applications menu. You can also access the desktop
environment preference tools from the Applications menu.

� Actions menu: You can access various commands that enable you to perform
desktop environment tasks from the Actions menu. For example, you can start the
Search Tool application, or log out of the desktop environment.

� GNOME Menu: You can also access the items in the Applications and Actions
menus from the GNOME Menu. You can have many GNOME Menu buttons in
your panels.

You can also right-click on the desktop to open the Desktop menu. The Desktop menu
enables you to perform desktop-related tasks.
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All of these menus provide you with multiple ways to perform your tasks, and enable
you to work in the way that you prefer.

Menu Features
Menus can contain the following items:

� Submenus
� Launchers or menu items

An arrow to the right of an item in a menu indicates that the item is a submenu. When
you point to the submenu, the submenu opens. You can choose items from the
submenu.

When you choose a launcher, the launcher starts an application or runs a command.
You can also right-click on a launcher to open a popup menu. The popup menu
enables you to add the item to a panel, and perform other tasks. For more information
on the popup menu, see the next section.

You can change the theme for your session to change how all your menus look. To
change the theme, choose Applications → Desktop Preferences → Theme.

Menu Item Popup Menu
Items in menus have an associated popup menu that enables you to perform tasks
related to the item. When you right-click on an item in a menu, the popup menu for
the item opens. The popup menu also contains a submenu that allows you to perform
menu-related tasks.

You can use the menu item popup menu to perform the following tasks:

� Add menu items as launchers to panels.

� Remove items from menus.

� Open the Run Program dialog with the menu item command in the dialog.

� Add menus to panels. You can add a menu as a menu object or as a drawer object.

� Add new items to menus.

� Change the properties of submenus and menu items.

Figure 5–1 shows the popup menu.
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FIGURE 5–1 Menu Item Popup Menu

Table 5–1 describes menu item popup menus.

TABLE 5–1 Menu Item Popup Menus

Item Description

Add this launcher to panel Adds the launcher to the panel from which you open
the menu.

Remove this item Removes the launcher from the menu.

Put into run dialog Displays the Run Program dialog with the command
from the Command field of the launcher in the
command field on the Run Program dialog.

Help on application-name Opens the online help for the application.

Properties Displays a dialog that enables you to edit the
properties of the launcher.

Entire menu → Add this as drawer to
panel

Adds the submenu as a drawer to the panel from
which you open the menu.

Entire menu → Add this as menu to
panel

Adds the submenu as a menu object to the panel
from which you open the menu.

Entire menu → Add new item to this
menu

Enables you to add an item to the submenu.

Entire menu → Properties Displays a dialog that enables you to edit the
properties of the submenu.
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Applications Menu
The Applications menu contains a hierarchy of submenus, from which you can start
the standard GNOME applications and preference tools. The Applications menu
contains the Desktop Preferences menu. You can use the Desktop Preferences menu to
start the preference tools. The Applications menu also includes the file manager and
the help browser.

The Applications menu resides in the following places:

� Menu Panel
� Start Here location in Nautilus
� GNOME Menu

Actions Menu
The Actions menu contains various commands that enable you to perform desktop
environment tasks. Table 5–2 describes the commands in the Actions menu.

TABLE 5–2 Actions Menu Commands

Menu Item Function

Run Program Opens the Run Program dialog. Use the Run Program
dialog to run commands. For more information, see
“Using the Run Program Dialog” on page 77.

Search for Files Starts the Search Tool application. For more information,
see the Search Tool manual.

Screenshot Takes a screenshot of the full screen, and opens the
Screenshot dialog. Use the Screenshot dialog to save the
screenshot.

Lock Screen Locks your screen.

Log Out Logs you out of the current session.

The Actions menu resides in the following places:

� Menu Panel.
� GNOME Menu. The items in the Actions menu are at the top level of the GNOME

Menu.
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Using the Run Program Dialog
The Run Program dialog gives you access to the command line. When you run a
command in the Run Program dialog, you cannot receive output from the command.

To run a command from the command line perform the following steps:

1. Display the Run Program dialog. You can display the Run Program dialog in any
of the following ways:

� From the Menu Panel

Choose Actions → Run Program.
� From the GNOME Menu

Open the GNOME Menu, then choose Run Program.
� Use shortcut keys

The default shortcut keys to display the Run Program dialog are Alt + F2. You
can change the shortcut keys that display the Run Program dialog in the
Keyboard Shortcuts preference tool. To change the shortcut keys, choose
Applications → Desktop Preferences → Keyboard Shortcuts.

� From a menu item popup menu

Right-click on an item in a menu, then choose Put into run dialog from the
popup menu. The Run Program dialog opens with the command from the
menu in the command field. The Run Program dialog is displayed.

2. Enter the command that you want to run in the blank field. Alternatively, to choose a
command that you ran previously, click the down arrow button beside the command
field, then choose the command to run.

Alternatively, click on the Known Applications button to display a list of available
applications.

You can also use the Append File button to choose a file to append to the command
line. For example, you can enter emacs as the command, then choose a file to edit.
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Select the Run in terminal option to run the application or command in a terminal
window. Choose this option for an application or command that does not create a
window in which to run.

3. Click on the Run button on the Run Program dialog.

To Take a Screenshot
You can take a screenshot in any of the following ways:

� Use the Actions menu

To take a screenshot of the entire screen, choose Actions → Screenshot. A
Screenshot dialog is displayed. To save the screenshot, select the Save screenshot
to file option. Enter the path and filename for the screenshot in the drop-down
combination box. Alternatively, to save the screenshot to another directory, click
Browse. When you select a directory, click OK.

You can also save the screenshot to the desktop. To save the screenshot to the
desktop, select the Save screenshot to desktop option.

� Use shortcut keys

To take a screenshot, use the following shortcut keys:

Default Shortcut Keys Function

Print Screen Takes a screenshot of the entire screen, and displays the
Screenshot dialog. Use the Screenshot dialog to save the
screenshot.

Alt + Print Screen Takes a screenshot of the window that has focus, and
displays the Screenshot dialog. Use the Screenshot
dialog to save the screenshot.

You can use the Keyboard Shortcuts preference tool to modify the default shortcut
keys.

� Use a command

You can use the gnome-panel-screenshot command to take a screenshot. The
gnome-panel-screenshot command takes a screenshot of the entire screen, and
displays the Screenshot dialog. Use the Screenshot dialog to save the screenshot.

You can also use options on the gnome-panel-screenshot command as
follows:
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Option Function

--window Takes a screenshot of the window that has focus, and
displays the Screenshot dialog. Use the Screenshot
dialog to save the screenshot.

--delay=seconds Takes a screenshot after the specified number of seconds,
and displays the Screenshot dialog. Use the Screenshot
dialog to save the screenshot.

--help Displays the options for the command.

GNOME Menu

You can access almost all of the standard applications, commands, and configuration
options from the GNOME Menu.

The GNOME Menu provides the following top-level menus and special menu items:

� Applications: Contains all applications and preference tools. This menu also
includes the file manager and the help browser.

� Actions: Contains commands that enable you to perform desktop environment
tasks, for example the Lock Screen and Log Out commands. The items in the
Actions menu are at the top level of the GNOME Menu.

You can add GNOME Menu buttons to your panels. By default, the GNOME Menu is
represented on panels by a stylized footprint icon, as follows:
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To Open the GNOME Menu
You can open the GNOME Menu in the following ways:

� From a panel with a GNOME Menu

Click on the GNOME Menu.
� Use shortcut keys

You can use shortcut keys to open the GNOME Menu. When you use shortcut keys
to open the GNOME Menu, the GNOME Menu appears at the mouse pointer.

The default shortcut keys to open the GNOME Menu are Alt + F1. To change the
shortcut keys that open the GNOME Menu, choose Applications → Desktop
Preferences → Keyboard Shortcuts.

To Add a GNOME Menu to a Panel
You can add as many GNOME Menu buttons as you want to your panels. To add a
GNOME Menu to a panel, right-click on any vacant space on the panel. Choose Add
to Panel → GNOME Menu.

Customizing Your Menus
You can modify the contents of the following menus:

� Applications menu
� Desktop Preferences menu

You use the following desktop environment components to customize menus:

� Menus on panels
� Nautilus file manager

When you use panels to customize your menus, you use the menu item popup menu.
For more information, see “Menu Item Popup Menu” on page 74.

When you use Nautilus to customize your menus, you must access the Applications
menu or the Desktop Preferences menu from within Nautilus. To access the
Applications menu or the Desktop Preferences menu, open a Nautilus window.
Choose Go → Start Here. Double-click on the Applications object or on the Desktop
Preferences object. For more information on Nautilus, see Nautilus File Manager.
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To Add a Menu
To add a menu, perform the following steps:

1. In a Nautilus window, access the location where you want to add the menu. For
example, to add a menu to the Applications menu, choose Go → Start Here, then
double-click on the Applications object.

2. Choose File → New Folder. An untitled folder is added to the view pane. The name
of the folder is selected.

3. Type a name for the folder, then press Return.

The next time that you log out then log in again, the menu is in the assigned location.

To Add a Launcher to a Menu
To add a launcher to a menu, perform the following steps:

1. Right-click on any item in the menu to which you want to add the launcher.

2. Choose Entire menu → Add new item to this menu. A Create Launcher dialog is
displayed.

3. Enter the properties of the launcher in the Create Launcher dialog. For more
information on the elements in the Create Launcher dialog, see Working With
Panels.

4. Click OK.

To Add a Launcher to an Empty Menu
To add a launcher to an empty menu, perform the following steps:

1. Open a Nautilus window, then choose Go → Start Here. Alternatively, double-click
on the Start Here object on the desktop. The Start Here location is displayed.

2. In the Nautilus window, double-click on the object that represents the menu to
which you want to add the launcher.

3. Choose File → New Launcher. A Create Launcher dialog is displayed.

4. Enter the properties of the launcher in the Create Launcher dialog. For more
information on the elements in the Create Launcher dialog, see Working With
Panels.

5. Click OK.

To Copy a Launcher to a Menu
To copy an existing launcher to a menu, perform the following steps:
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1. In a Nautilus window, access the location from which you want to copy the
launcher. For example, to copy a launcher from the Applications menu, choose Go
→ Start Here, then double-click on the Applications object.

2. Select the launcher that you want to copy, then choose Edit → Copy File.

3. In a Nautilus window, access the location to which you want to copy the launcher.

4. Choose Edit → Paste Files. The launcher is added to the new location.

Alternatively, you can drag the launcher from one location to another.

The next time that you log out then log in again, the launcher is in the new menu
location.

To Edit the Properties of a Menu
To edit the properties of a menu, perform the following steps:

1. Right-click on any item in the menu that you want to edit.

2. Choose Entire menu → Properties. A Launcher Properties dialog is displayed.

3. Modify the properties of the menu in the Launcher Properties dialog. For more
information on the elements in the Launcher Properties dialog, see Working With
Panels.

4. Click OK.

To Edit a Menu Item
To edit a menu item, perform the following steps:

1. Right-click on the item that you want to edit.

2. Choose Properties. A Launcher Properties dialog is displayed.

3. Modify the properties of the launcher in the Launcher Properties dialog. For more
information on the elements in the Launcher Properties dialog, see Working With
Panels.

4. Click OK.

To Delete an Item from a Menu
To delete an item from a menu, use the menu item popup menu. To delete an item
from a menu, perform the following steps:

1. Right-click on the item that you want to delete.
2. Choose Remove this item.
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CHAPTER 6

Working With Windows

The information in this chapter describes how to use windows in the desktop
environment. You can use several types of window manager with the GNOME
Desktop, for example, Metacity and Sawfish. Many of the functions in Metacity are
also available in Sawfish. This chapter describes the functions that are associated with
the Metacity window manager.

� “Windows and Workspaces” on page 83
� “Types of Window” on page 84
� “Menus and Applets for Working With Windows and Workspaces” on page 87
� “Manipulating Windows” on page 92
� “Manipulating Workspaces” on page 95

Windows and Workspaces
You can display many windows at the same time in your desktop environment. Your
windows are displayed in subdivisions of your desktop environment that are called
workspaces. A workspace is a discrete area in which you can work. Every workspace
in your desktop environment contains the same desktop, the same panels, and the
same menus. However, you can run different applications, and open different
windows in each workspace. You can display only one workspace at a time in your
desktop environment but you can have windows open in other workspaces.

The Workspace Switcher applet displays a visual representation of your windows and
workspaces, as show in Figure 6–1.
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FIGURE 6–1 Workspace Switcher Applet

You can add workspaces at any time. To add workspaces to your desktop
environment, right-click on the Workspace Switcher applet, then choose Preferences.
The Workspace Switcher Preferences dialog is displayed. Use the Number of
workspaces spin box to specify the number of workspaces you require.

Window Manager Behavior
A window manager controls how windows appear and behave. The window manager
manages where your windows are located, which window has focus, and the theme of
the frame on the windows. The window frame contains buttons that enable you to
perform standard actions such as moving, closing, and resizing windows.

You can configure some window manager settings in the Window Focus preference
tool. This manual describes the functions that are associated with the default
configuration of the Metacity window manager. The default configuration is specified
in the Window Focus preference tool. This manual also describes the default functions
of the Crux theme.

Types of Window
The desktop environment features the following types of windows:

� Application windows

When you start an application, an application window opens. The window
manager applies a frame to the application window. By default, the top edge of the
application window contains a titlebar. The titlebar contains buttons that you can
use to work with the window. The buttons in an application window frame enable
you to perform actions such as open the Window Menu, or close the window. The
Window Menu provides a number of actions that you can perform on the window.

The following figure shows a typical application window.
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� Dialog windows

A dialog window is a popup window in which you enter information or
commands. The dialog appears within a window frame.

You can use the top edge of the frame to work with the window. For example, you
can use the titlebar to move the dialog. The frame also contains buttons that enable
you to do the following:

� Open the Window Menu
� Close the dialog window

Typically, you open a dialog window from an application window. When you open
a dialog window, the window is usually raised and has focus. Some dialog
windows do not allow you to use the application until you close the dialog.

The following figure shows a typical dialog window.
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Window Frames
A window frame is a border around a window. The window frame contains a titlebar.
The titlebar contains buttons that you can use to work with the window.

Themes
You can apply several themes to your window frames. The theme determines how the
frame looks. To choose a theme for all your window frames, choose Applications →
Desktop Preferences → Theme.

The default theme is Crux. This manual describes the functions that are associated
with the Crux theme.

Control Elements
You can use the window frame to perform various actions with the window. In
particular, the titlebar contains various buttons. The following figure shows the
titlebar of an application window:

Dialog windows also contain some of the window frame control elements. Table 6–1
describes the active control elements on window frames, from left to right.

TABLE 6–1 Window Frame Control Elements

Control Element Description

Window Menu button Click on the button to open the Window Menu.
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TABLE 6–1 Window Frame Control Elements (Continued)
Control Element Description

Titlebar You can use the titlebar to perform the following
actions:
� To give focus to the window click on the titlebar.
� To move the window grab the titlebar and drag the

window to the new location.
� To shade the window, double-click on the titlebar.

To unshade the window, double-click on the
titlebar again.

Minimize button Click on the Minimize button to minimize the
window.

Maximize button Click on the Maximize button to maximize the
window.

Close Window button Click on the Close Window button to close the
window.

Border The border around the window. Use the border to
perform the following actions:
� To resize the window grab the border and drag the

border to the new size.
� To open the Window Menu, right-click on the

border.

Window contents The area inside the window frame. Use the window
contents to perform the following actions:
� To move a window, press-and-hold Alt, click in the

window contents, then drag the window to the
new location.

� To resize a window, press-and-hold Alt, then
middle-click near the corner you want to resize. To
resize the window, drag from the corner on which
you middle-clicked.

� To open the Window Menu, press-and-hold Alt,
then right-click in the window contents.

Menus and Applets for Working With
Windows and Workspaces
This section describes the menus and applets that you can use to work with windows
and workspaces.
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Window Menu

The Window Menu is a menu of commands that you can use to perform actions on
your windows. To open the Window Menu perform one of the following actions:

� Click on the Window Menu button on the window that you want to work with.
� Press Alt + spacebar.
� Press-and-hold Alt, then right-click on any part of the window that you want to

work with.

Table 6–2 describes the commands and submenus in the Window Menu.

TABLE 6–2 Window Menu Commands and Submenus

Menu Item Function

Minimize Minimizes the window.

Maximize or Unmaximize Maximizes the window. If the window is already maximized,
choose Unmaximize to restore the window to its previous size.

Shade or Unshade Shades the window. If the window is already shaded, choose
Unshade to restore the window to its previous size.

Move Enables you to use the arrow keys to move the window.

Resize Enables you to use the arrow keys to resize the window.

Close Closes the window.

Put on All Workspaces or
Only on This Workspace

Puts the window on all of your workspaces. If the window is
already on all of your workspaces, choose Only on This
Workspace to put the window on the current workspace only.

Move to workspace-name or
Only on workspace-name

Moves the window to the workspace that you choose. If the
window is on all of your workspaces, choose Only on
workspace-name to put the window on the workspace that you
want.
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Window List Applet
Window List displays a button for each application window that is open. You can use
the Window List to perform the following tasks:

� To minimize a window

Click on the button that represents the window.

� To restore a minimized window

Click on the button that represents the window.

� To give focus to a window

Click on the button that represents the window.

When you open an application window, Window List displays a button that
represents the window. The window list buttons show which application windows are
open. You can view which windows are open even if some windows are minimized,
or other windows overlap a window. Window List can display buttons for the
windows in your current workspace, or in all workspaces. To select this option, you
must change the preferences of Window List.

You can also right-click on a window list button to open the Window Menu for the
window that the button represents. When you open the Window Menu from Window
List, the Window Menu does not contain the workspace commands. For more
information on the Window Menu commands, see “Window Menu” on page 88.

Figure 6–2 shows Window List when the following windows are open:

� gedit
� Dictionary
� GHex
� GNOME Terminal

FIGURE 6–2 Window List Applet

The buttons in the applet show the status of your windows. Table 6–3 explains the
information that the window list buttons provide about the window. The examples in
Table 6–3 refer to Figure 6–2.

TABLE 6–3 Window Status Information on Window List Buttons

State Indicates Example

Button is pressed in. The window has focus. gedit
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TABLE 6–3 Window Status Information on Window List Buttons (Continued)
State Indicates Example

Square brackets around
window title.

The window is minimized. [Dictionary]

Button is not pressed in, no
square brackets around title.

The window is displayed, and
is not minimized.

ghex

Numeral on button, in
parentheses.

The button represents a group
of buttons.

Gnome-terminal (3)

Grouping Buttons
Window List can group the buttons that represent windows in the same class under
one window list button. The Gnome-terminal button in Figure 6–2 is an example of a
button that represents a group of buttons. The following figure shows an example of
Window List with a button group open:

To open a list of the windows in a group, click on the window list button that
represents the group. You can click on the items in the list to give focus to windows,
minimize windows, and restore windows.

To open the Window Menu for a window in a button group, right-click on the window
list button that represents the group. A list of the windows in the group is displayed.
To open the Window Menu for a window in the group, click on the item in the list.
When you open the Window Menu from the Window List, the Window Menu does
not contain the workspace commands. For more information on the Window Menu
commands, see “Window Menu” on page 88.

Workspace Switcher Applet
Workspace Switcher displays a visual representation of your workspaces, as shown in
Figure 6–3. Figure 6–3 shows the applet when the GNOME session contains four
workspaces. Your workspaces appear as buttons on the applet. The background of the
button in the applet that represents the current workspace is highlighted. The current
workspace in Figure 6–3 is the workspace at the left of the applet. To switch to another
workspace, click on the workspace in the applet.
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FIGURE 6–3 Workspace Switcher Applet

Workspace Switcher also displays the application windows and dialogs that are open
in your workspaces.

The applet displays the workspaces in order from left to right across the rows of the
applet. In Figure 6–3, the applet is set up to display the workspaces in one row. You
can specify the number of rows in which your workspaces are displayed in Workspace
Switcher. You can also change the default behavior of the applet to display the names
of your workspaces in the applet.

Using the Menu Panel to Work With Windows
From the Menu Panel, you can view a list of all windows that are currently open. You
can also choose a window to give focus to. To view the window list, click on the icon
at the extreme right of the Menu Panel. The following figure shows an example of the
window list that is displayed from the Menu Panel:

When the focus changes, the icon that you click on to display the window list changes.
The icon represents the window that currently has focus. To give focus to a window,
choose that window from the window list.

The window list lists the windows in all workspaces. The windows in all workspaces
other than the current workspace, are listed under a separator line.

You cannot move the icon at the extreme right of the Menu Panel.
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Manipulating Windows
This section describes how to manipulate windows.

To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.

You can use the following elements to give focus to a window:

Element Action

Mouse Click on the window, if the window is visible.

Shortcut keys Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.

Window List Click on the button that represents the window in Window
List.

Workspace Switcher Click on the window that you want to give focus to in the
Workspace Switcher display. If you click on a window in
another workspace, Workspace Switcher switches to the new
workspace, and gives focus to the window.

Menu Panel Click on the icon at the extreme right of the Menu Panel. A list
of your open windows is displayed. Choose the window from
the list.

To Minimize a Window
To minimize a window perform one of the following actions:

� Click on the Minimize button on the window frame.
� Open the Window Menu, then choose Minimize.
� If the window has focus, click on the button that represents the window in

Window List. If the window does not have focus, click twice on the button that
represents the window.

� Right-click on the button that represents the window in Window List, then choose
Minimize from the popup menu.

92 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



To Maximize a Window
When you maximize a window, the window expands as much as possible. To
maximize a window perform one of the following actions:

� To maximize the window, click on the Maximize button on the window frame.
Alternatively, open the Window Menu, then choose Maximize.

� Right-click on the button that represents the window in Window List, then choose
Maximize from the Window Menu.

To Restore a Window
To restore a maximized window perform one of the following actions:

� Click on the Maximize button on the window frame.
� Open the Window Menu. Choose Unmaximize.
� Right-click on the button that represents the window in Window List to open the

Window Menu. Choose Unmaximize.

To restore a minimized window, click on the button that represents the window in
Window List.

To Close a Window
To close a window perform one of the following actions:

� Click on the Close Window button on the window frame.
� Open the Window Menu. Choose Close.
� Right-click on the button that represents the window in Window List, then choose

Close from the Window Menu.

If you have unsaved data in the window, you are prompted to save your data.

To Resize a Window
To resize a window perform one of the following actions:

� Point to a corner of the window. The mouse pointer changes to indicate that you
can resize the window. Grab the corner and drag the window to the new size.

� Right-click on the button that represents the window in Window List. Choose
Resize from the Window Menu. Use the arrow keys to resize the window.

� Press-and-hold Alt, then middle-click near the corner that you want to resize. The
mouse pointer changes to indicate that you can resize from the corner. To resize the
window, drag from the corner on which you middle-clicked.
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� To resize a window horizontally point to one of the vertical edges of the window.
The mouse pointer changes to indicate that you can resize the window. Grab the
edge and drag the window to the new size.

� To resize a window vertically point to the bottom edge of the window. The mouse
pointer changes to indicate that you can resize the window. Grab the edge and
drag the window to the new size.

Note – You cannot resize some dialog windows. Also, some application windows have
a minimum size below which you cannot reduce the window.

To Move a Window
To move a window perform one of the following actions:

� Grab the titlebar of the window and drag the window to the new location.
� Press-and-hold Alt, then drag the window to the new location.
� Open the Window Menu, then choose Move. Use the arrow keys to move the

window to the new location.
� Right-click on the button that represents the window in Window List, then choose

Move from the Window Menu. Use the arrow keys to move the window to the new
location.

To Shade a Window
You can shade and unshade windows, as follows:

Shade Reduce the window so that only the titlebar is visible.

Unshade Switch a window from a shaded state so that the full window is
displayed.

To shade a window perform one of the following actions:

� Double-click on the titlebar of the window. To unshade the window, double-click
on the titlebar again.

� Open the Window Menu. Choose Shade. To unshade the window, choose Unshade.

� Right-click on the button that represents the window in Window List, then choose
Shade from the Window Menu. To unshade the window, choose Unshade.

94 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



To Put a Window on All Workspaces
To put a window in all workspaces, open the Window Menu. Choose Put on All
Workspaces. To set the window to appear only in the current workspace, choose Only
on This Workspace.

To Move a Window to Another Workspace
You can move a window to another workspace in either of the following ways:

� Use Workspace Switcher

In the Workspace Switcher display, drag the window to the workspace you require.

� Use the Window Menu

Open the Window Menu. To move the window to the next workspace choose
Move to workspace-name.

Manipulating Workspaces
This section describes how to manipulate workspaces.

To Switch Between Workspaces
You can switch between workspaces in any of the following ways:

� Use Workspace Switcher

Click on the workspace that you want to switch to in Workspace Switcher.

� Use shortcut keys

The default shortcut keys to switch between the workspaces are as follows:

Default Shortcut Keys Function

Ctrl + Alt + right arrow Selects the workspace to the right.

Ctrl + Alt + left arrow Selects the workspace to the left.
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To Add Workspaces
To add workspaces to your desktop environment, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed.
Use the Number of workspaces spin box to specify the number of workspaces you
require. Workspace Switcher adds new workspaces at the end of the workspace list.

To Name Workspaces
The default names of your workspaces are Workspace 1, Workspace 2, Workspace
3, and so on. To assign names to your workspaces, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed.
Use the Workspaces list box to specify the names of your workspaces. Select a
workspace, then type the new name for the workspace.

To Delete Workspaces
When you delete a workspace the windows in the workspace are moved to another
workspace, and the empty workspace is deleted.

To delete workspaces from your desktop environment, right-click on Workspace
Switcher, then choose Preferences. The Workspace Switcher Preferences dialog is
displayed. Use the Number of workspaces spin box to specify the number of
workspaces you require. Workspace Switcher deletes workspaces from the end of the
workspace list.
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CHAPTER 7

Nautilus File Manager

This chapter describes how to use the Nautilus file manager.

� “Introduction to Nautilus File Manager” on page 97
� “Nautilus Windows” on page 98
� “Navigating Your Computer” on page 104
� “Managing Your Files and Folders” on page 112
� “Running Scripts From Nautilus” on page 119
� “Modifying the Appearance of Files and Folders” on page 120
� “Assigning Actions to Files” on page 127
� “Customizing Nautilus” on page 128
� “Using Removable Media” on page 141

Introduction to Nautilus File Manager
The Nautilus file manager provides an integrated access point to your files and
applications. Nautilus enables you to do the following:

� Display your files and folders.
� Manage your files and folders.
� Run scripts.
� Customize your files and folders.

Nautilus also manages the desktop. The desktop lies behind all of the other
components in your desktop environment. The desktop is an active component of the
user interface.

Nautilus windows enable you to display and manage your files and folders. You can
open a Nautilus window in any of the following ways:

� Double-click on the Home object on the desktop.
� Choose Applications → Home Folder.
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� Right-click on the desktop to open the Desktop menu. Choose New Window.

The Nautilus window displays the contents of your home location in the view pane.

Nautilus Windows
Nautilus windows enable you to display and manage your files and folders. Figure
7–1 shows a Nautilus window that displays the contents of a folder.
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FIGURE 7–1 Contents of a Folder in a Nautilus Window

Table 7–1 describes the components of Nautilus windows.

TABLE 7–1 Nautilus Window Components

Component Description

Menubar Contains menus that you use to perform tasks in Nautilus.

Toolbar Contains buttons that you use to perform tasks in Nautilus.
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TABLE 7–1 Nautilus Window Components (Continued)
Component Description

Location bar Contains the following elements:
� Location field or Go To field: Enables you to specify a file,

folder, or URL that you want to display.
� Zoom buttons: Enable you to change the size of items in the

view pane.
� View as drop-down list: Enables you to choose how to display

items in your view pane.

Side pane Performs the following functions:
� Enables you to navigate through your files.
� Displays information about the current file or folder.

Tabs Click on a tab to open a tabbed pane. The side pane contains the
following tabbed panes:
� History
� Notes
� Tree

View pane Displays the contents of the following:
� Particular types of files
� Folders
� FTP sites

Resize handle Grab this handle, then drag to resize the side pane and the view
pane.

Statusbar Displays status information.

You can also open a popup menu from Nautilus windows. To open this popup menu
right-click in a Nautilus window. The items in this menu depend on where you
right-click. For example, when you right-click on a file or folder, you can choose items
related to the file or folder. When you right-click on the background of a view pane,
you can choose items related to the display of items in the view pane.

View Pane
The view pane can display the contents of the following:

� Particular types of files
� Folders
� FTP sites

Nautilus contains viewer components that enable you to display particular types of file
in the view pane. For example, you can use an image viewer to display Portable
Network Graphics (PNG) files in the view pane. The following figure shows a PNG
file displayed in the view pane.

100 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



Displaying a file in the view pane provides the following benefits:

� Uses less system resources than when you launch an application.
� Takes less time than when you launch an application.

However, you cannot edit a file in the view pane.

Nautilus also includes views that enable you to display the contents of your folders in
different ways. For example, you can display the contents of a folder in the following
types of view:

� Icon view: Displays the items in the folder as icons.
� List view: Displays the items in the folder as a list.

Use the View menu to choose how to display a folder. For more information on views,
see “Using Views to Display Your Files and Folders” on page 122.

Side Pane
The side pane can contain the following elements:

� An icon that represents the current file or current folder. The side pane also
contains information about the current file or current folder.

� Tabbed panes that enable you to navigate through your files.
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� If a file is displayed in the view pane, buttons appear in the side pane. The buttons
enable you to perform actions on a file, other than the default action.

Tabbed Panes
The side pane can contain the following tabbed panes:

� History

Contains a history list of files, folders, and FTP sites that you have recently visited.

� Notes

Enables you to add notes to your folders.

� Tree

Displays a hierarchical representation of your file system. You can use the Tree
tabbed pane to navigate through your files.

Table 7–2 describes how to work with tabbed panes.

TABLE 7–2 Tabbed Pane Tasks

Task Action

Open a tabbed pane. Click on the tab.

Close a tabbed pane. Click on the tab.

Remove a tab from the side
pane.

Right-click in the side pane, then choose the tab that you
want to remove from the menu.

Add a tab to the side pane. Right-click in the side pane, then choose the tab that you
want to add from the menu.

Icons and Emblems
In icon view, Nautilus displays your files and folders as icons. You can add emblems
to your file icons and folder icons. An emblem is a small icon that you can add to an
item to visually mark the item. For example, to mark a file as important, you can add
an Important emblem to the file icon to create the following visual effect:
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For more information on how to add an emblem to an icon, see “To Add an Emblem
to a File or Folder” on page 120.

The following table describes the structure of the file icon:

Component Description

Emblem. This emblem is the Important emblem.

Icon that represents the file. This icon contains a preview of
the contents of the file.

Icon caption. You can modify what items of information are
displayed in the icon caption.

Nautilus includes default emblems for the following types of item:

� Symbolic links

� Items for which you have the following permissions:

� Read permission only
� No read permission and no write permission

The default emblems change depending on your theme. The following table shows the
default emblems for the Default theme.
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Default Emblem Description

Symbolic link

Read permission only

No read permission and no write permission

Navigating Your Computer
Each Nautilus window displays the contents of a single file, folder, or FTP site. This
section describes the following:

� How to display items in Nautilus windows.
� How to open files from Nautilus windows.
� How to navigate the files and folders in your file system.
� How to navigate to FTP sites.

To Display Your Home Location

To display your home location, perform one of the following actions:

� Double-click on the Home object on the desktop.
� On a Nautilus window, choose Go → Home.
� On a Nautilus window, click on the Home toolbar button.

The Nautilus window displays the contents of your home location. To reload the
display, click on the Reload button.
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To Display a Folder
You can display the contents of a folder in any of the following ways:

� Double-click on the folder in the view pane.

� In the Location field, type the path of the folder that you want to display, then
press Return. The Location field includes an autocomplete feature. As you type a
path, Nautilus reads your file system. When you type enough characters to
uniquely identify a directory, Nautilus completes the name of the directory in the
Location field.

� Use the Tree tabbed pane. For more information, see “Using the Tree Tabbed Pane”
on page 105.

� Use the Back toolbar button and the Forward toolbar button to browse through
your navigation history.

To change to the folder that is one level above the current folder, choose Go → Up.
Alternatively, click on the Up toolbar button.

To reload the display, click on the Reload button.

If you cannot find the folder that you want to display, you can use Search Tool. To start
Search Tool, choose Actions → Search for Files.

Using the Tree Tabbed Pane
The Tree tabbed pane displays a hierarchical representation of your file system. The
Tree tabbed pane provides a convenient way to navigate your file system. By default,
the Tree tabbed pane is not displayed in your side pane. To add the Tree tabbed pane
to the side pane, right-click in the side pane, then choose Tree from the popup menu.

The following figure shows the Tree tabbed pane.
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In the Tree tabbed pane, folders are represented as follows:

Folder State Graphic Representation

Closed folder Right arrow

Open folder Down arrow

Table 7–3 describes the tasks that you can perform with the Tree tabbed pane, and
how to perform the tasks.

TABLE 7–3 Tree Tabbed Pane Tasks

Task Action

Open the Tree tabbed pane. Click on the Tree tab.

Close the Tree tabbed pane. Click on the Tree tab.

Open a folder in the Tree tabbed pane. Click on the arrow next to the folder in the
Tree tabbed pane.
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TABLE 7–3 Tree Tabbed Pane Tasks (Continued)
Task Action

Close a folder in the Tree tabbed pane. Click on the arrow next to the folder in the
Tree tabbed pane.

Display the contents of a folder in the view
pane.

Select the folder in the Tree tabbed pane.

Display the contents of a file in the view pane. Select the file in the Tree tabbed pane.

You can set your preferences so that the Tree tabbed pane does not display files. For
more information, see “To Set Side Pane Preferences” on page 137.

Opening Files
When you open a file, Nautilus performs the default action for that file type. The
default action can be one of the following:

� Use a viewer component to display the file in the view pane.
� Launch an application that opens the file.

Nautilus checks the contents of a file to determine the type of a file. If the first lines do
not determine the type of the file, then Nautilus checks the file extension.

If you cannot find the file that you want to open, you can use Search Tool. To start
Search Tool, choose Actions → Search for Files.

Viewing Files in the View Pane
Nautilus contains viewer components that enable you to display particular types of
file in the view pane. For example, you can display the following types of files in the
view pane:

� Plain text files
� Portable Network Graphics (PNG) files
� Joint Photographic Experts Group (JPEG) files

To reload the contents of the view pane, choose View → Reload. To stop loading an
item in the view pane, choose View → Stop.

When you display a file in the view pane, the viewer component might add menu
items to the Nautilus menus. The menu items relate to the file type that is displayed.
For example, when you display a PNG file, the View menu contains Interpolation,
Dither, and other submenus.

Also, when you display some types of file in the view pane, you can use the Nautilus
zoom buttons to change the size of the item.
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To Execute the Default Action
To execute the default action for a file, double-click on the file. For example, if the
default action for plain text documents is to display the file in a text viewer. In this
case, you can double-click on the file to display the file in a text viewer.

You can set your Nautilus preferences so that you click once on a file to execute the
default action. For more information, see “To Set Icon and List Views Preferences”
on page 134.

To Execute Non-Default Actions Using the Open With
Submenu
To execute actions other than the default action for a file, perform the following steps:

1. In the view pane, select the file that you want to perform an action on. Choose File
→ Open With. The Open With submenu opens. The items in this submenu
correspond to the contents of the following parts of the File Types and Programs
preference tool:

� Default action drop-down list in the Edit file type dialog
� Viewer Component drop-down list in the Edit file type dialog

2. Choose an action from the Open With submenu.

To Execute Other Actions When Displaying a File
When you display a file in the view pane, the side pane might contain buttons. Figure
7–2 shows the side pane when a text file is displayed in the view pane.
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FIGURE 7–2 Side Pane When a File is Displayed in the View Pane

The buttons represent any actions that are defined in the File Types and Programs
preference tool. The actions are defined in the Default action drop-down list in the
Edit file type dialog in the File Types and Programs preference tool. Click on a button
to execute an action. For example, if an action defined for plain text documents is to
open the file in gedit. If this action is defined, an Open with gedit button is displayed
in the side pane. To open the file in the gedit application, click on the Open with gedit
button.

Note – A button that represents the action does not appear in the side pane if the
actions are excluded in either of the following dialogs:

� Open with Other Application
� Open with Other Viewer

Using the Start Here Location

The Start Here location enables you to access the following functions:
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� Applications

Double-click on Applications to access your key GNOME applications. You can
also access the Applications menu through the GNOME Menu and the Menu
Panel.

� Desktop Preferences

Double-click on Desktop Preferences to customize your desktop environment. You
can also access the desktop environment preference tools through the Applications
menu.

� Programs that enable you to configure your system as a server, and to choose other
system settings.

You can access the Start Here location in the following ways:

� From a Nautilus window

Choose Go → Start Here. The contents of the Start Here location are displayed in
the window.

� From the desktop

Double-click on the Start Here object on the desktop. The contents of the Start
Here location are displayed in a Nautilus window.

To Access FTP Sites
You can use Nautilus to access FTP sites. To access an FTP site, enter the URL for the
site in the field on the location bar, then press Return. The contents of the site are
displayed in the view pane. To copy a file from the FTP site, drag the file to the new
location.

To access an FTP site that requires a username and password, you can enter the URL
in the following form:

ftp://username:password@hostname.domain

To reload the FTP site in the view pane, choose View → Reload. To stop loading the
FTP site, choose View → Stop.

Using Your Navigation History
Nautilus maintains a history list of files, folders, and FTP sites. You can use the history
list to navigate to files, folders, and FTP sites that you have recently visited. Your
history list contains the last ten items that you viewed. The following sections describe
how to navigate your history list.

To clear your history list choose Go → Clear History.

110 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



To Navigate Your History List Using the Go Menu
To display a list of previously-viewed items, choose the Go menu. Your history list is
displayed in the lower part of the Go menu. To open an item in your history list,
choose the item from the Go menu.

To Navigate Your History List Using the Toolbar
To use the toolbar to navigate your history list, perform one of the following actions:

� To open the previous file, folder, or URL in your history list, click on the Back
toolbar button.

� To open the next file, folder, or URL in your history list, click on the Forward
toolbar button.

� To display a list of previously-viewed items, click on the down arrow to the right
of the Back toolbar button. To open an item from this list, click on the item.

� To display a list of items that you viewed after you viewed the current item, click
on the down arrow to the right of the Forward toolbar button. To open an item
from this list, click on the item.

To Navigate Your History List Using the History Tabbed
Pane
To display the History tabbed pane, click on the History tab in the side pane. The
History tabbed pane displays a list of your previously-viewed items.
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To display an item from your history list in the view pane, click on the item in the
History tabbed pane.

To Bookmark Your Favorite Locations
To access an item in your bookmarks, choose the item from the Bookmarks menu. You
can add your favorite locations to your Bookmarks menu. You can add bookmarks to
files and folders in your file system, or to FTP sites.

To Add a Bookmark
To add a bookmark, display the item that you want to bookmark in the view pane.
Choose Bookmarks → Add Bookmark.

To Edit a Bookmark
To edit your bookmarks perform the following steps:

1. Choose Bookmarks → Edit Bookmarks. An Edit Bookmarks dialog is displayed.

2. To edit a bookmark, select the bookmark on the left side of the Edit Bookmarks
dialog. Edit the details for the bookmark on the right side of the Edit Bookmarks
dialog, as follows:

Dialog Element Description

Name Use this text box to specify the name that identifies the bookmark
in the Bookmarks menu.

Location Use this field to specify the location of the bookmark.

3. To delete a bookmark, select the bookmark on the left side of the dialog. Click
Delete.

Managing Your Files and Folders
This section describes how to work with your files and folders.
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Drag-and-Drop in Nautilus
You can use drag-and-drop to perform several tasks in Nautilus. When you
drag-and-drop, the mouse pointer provides feedback about the task that you perform.
Table 7–4 describes the tasks that you can perform with drag-and-drop. The table also
shows the mouse pointers that appear when you drag-and-drop.

TABLE 7–4 Drag-and-Drop in Nautilus

Task Action Mouse Pointer

Move an item Drag the item to the new location.

Copy an item Grab the item, then press-and-hold Ctrl. Drag the item
to the new location.

Create a symbolic
link to an item

Grab the item, then press-and-hold Ctrl + Shift. Drag
the item to the location where you want the symbolic
link to reside.

Ask what to do
with the item you
drag

Grab the item, then press-and-hold Alt. Drag the item
to the location where you want the item to reside.
Release the mouse button. A popup menu appears.
Choose one of the following items from the popup
menu:
� Move here

Moves the item to the location.
� Copy here

Copies the item to the location.
� Link here

Creates a symbolic link to the item at the location.
� Set as Background

If the item is an image, sets the image to be the
background wallpaper. You can use this command
to set the desktop background and the view pane
background.

� Cancel
Cancels the drag-and-drop operation.

To Select Files and Folders
You can select files and folders in several ways in Nautilus. Table 7–5 describes how to
select items in Nautilus windows and on the Nautilus desktop.
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TABLE 7–5 Selecting Items in Nautilus

Task Action

Select an item Click on the item.

Select a group of contiguous
items

In icon view, drag around the files that you want to select.

In list view, press-and-hold Shift. Click on the first item in
the group, then click on the last item in the group.

Select multiple items Press-and-hold Ctrl. Click on the items that you want to
select.

Alternatively, press-and-hold Ctrl, then drag around the
files that you want to select.

Select all items in a folder Choose Edit → Select All Files.

To perform the default action on an item, double-click on the item. You can set your
Nautilus preferences so that you work with Nautilus as follows:

� Click once on a file to execute the default action.
� Point to an item to select the item.

For more information, see “To Set Icon and List Views Preferences” on page 134.

To Move a File or Folder
The following sections describe the ways you can move a file or folder.

Drag to the New Location in a View Pane
To drag a file or folder to a new location in a view pane, perform the following steps:

1. Open a Nautilus window. Choose File → New Window to open a second Nautilus
window.

2. In one window, select the folder from which you want to move the file or folder. In
the other window, select the folder to which you want to move the file or folder.

3. Drag the file or folder that you want to move to the new location in the other
window.

To move the file or folder to a folder that is one level below the current location, do
not open a new window. Instead, drag the file or folder to the new location in the
same window.
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Cut and Paste to the New Location
You can cut a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to move, then choose Edit → Cut File.

2. Open the folder to which you want to move the file or folder, then choose Edit →
Paste Files.

To Copy a File or Folder
The following sections describe the ways you can copy a file or folder.

Drag to the New Location in a View Pane
To copy a file or folder perform the following steps:

1. Open a Nautilus window. Choose File → New Window to open a second Nautilus
window.

2. In one window, select the folder from which you want to copy the file or folder. In
the other window, select the folder to which you want to copy the file or folder.

3. Grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to the new
location in the other window.

To copy the file or folder to a folder that is one level below the current location, do not
open a new window. Instead, grab the file or folder, then press-and-hold Ctrl. Drag the
file or folder to the new location in the same window.

Copy and Paste to the New Location
You can copy a file or folder and paste the file or folder into another folder, as follows:

1. Select the file or folder that you want to copy, then choose Edit → Copy File.

2. Open the folder to which you want to copy the file or folder, then choose Edit →
Paste Files.

To Duplicate a File or Folder
To create a copy of a file or folder in the current folder perform the following steps:

1. Select the file or folder that you want to duplicate in the view pane.

2. Choose Edit → Duplicate. Alternatively, right-click on the file or folder in the view
pane, then choose Duplicate.
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A copy of the file or folder appears in the current folder.

To Create a Folder
To create a folder perform the following steps:

1. Select the folder where you want to create the new folder.

2. Choose File → New Folder. Alternatively, right-click on the background of the view
pane, then choose New Folder.

An untitled folder is added to the view pane. The name of the folder is selected.

3. Type a name for the folder, then press Return.

To Rename a File or Folder
To rename a file or folder perform the following steps:

1. Select the file or folder that you want to rename in the view pane.

2. Choose Edit → Rename. Alternatively, right-click on the file or folder in the view
pane, then choose Rename.

The name of the file or folder is selected.

3. Type a new name for the file or folder, then press Return.

To Move a File or Folder to Trash
To move a file or folder to Trash perform the following steps:

1. Select the file or folder that you want to move to Trash in the view pane.

2. Choose Edit → Move to Trash. Alternatively, right-click on the file or folder in the
view pane, then choose Move to Trash.

Alternatively, you can drag the file or folder from the view pane to the Trash object on
the desktop.

To Delete a File or Folder
When you delete a file or folder, the file or folder is not moved to Trash, but is deleted
from your file system immediately. The Delete menu item is only available if you
select the Include a Delete command that bypasses Trash option in the Preferences
dialog.

To delete a file or folder perform the following steps:
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1. Select the file or folder that you want to delete in the view pane.

2. Choose Edit → Delete. Alternatively, right-click on the file or folder in the view
pane, then choose Delete.

To Create a Symbolic Link to a File or Folder
A symbolic link is a special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the file or folder to
which the symbolic link points. However, when you delete a symbolic link, you delete
the link file, not the file to which the symbolic link points.

To create a symbolic link to a file or folder, select the file or folder to which you want
to create a link. Choose Edit → Make Link. A link to the file or folder is added to the
current folder.

Alternatively, grab the item to which you want to create a link, then press-and-hold
Ctrl + Shift. Drag the item to the location where you want to place the link.

By default, Nautilus adds an emblem to symbolic links.

To Change Permissions
To change the permissions on a file or folder perform the following steps:

1. Select the file or folder that you want to change.

2. Choose File → Properties. A properties dialog is displayed.

3. Click on the Permissions tab. In the Permissions tabbed section, use the
drop-down lists and check boxes to change the permissions for the file or folder.

4. Click Close to close the properties dialog.

Using Trash

You can move the following items to Trash:

� Files
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� Folders
� Desktop objects

If you need to retrieve a file from Trash, you can display Trash and move the file out
of Trash. When you empty Trash, you delete the contents of Trash permanently.

To Display Trash
You can display the contents of Trash in the following ways:

� From a Nautilus window

Choose Go → Trash. The contents of Trash are displayed in the window.

� From the desktop

Double-click on the Trash object on the desktop.

To Empty Trash
You can empty the contents of Trash in the following ways:

� From a Nautilus window

Choose File → Empty Trash.

� From the desktop

Right-click on the Trash object, then choose Empty Trash.

Adding Notes to Folders
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You can use the Notes tab to add a note to a folder. To add a note to a folder perform
the following steps:

1. Display the folder in the view pane.

2. Click on the Notes tab to open the Notes tabbed pane. The Notes tabbed pane
opens.

3. Type the note in the Notes tabbed pane.

Running Scripts From Nautilus
Nautilus includes a special folder where you can store your scripts. When you add an
executable file to this folder, the file is added to the Scripts submenu. To run a script
choose File → Scripts, then choose the script that you want to run from the submenu.

To run a script on a particular file, select the file in the view pane. Choose File →
Scripts, then choose the script that you want to run on the file from the submenu. You
can also select multiple files to run your scripts on.

To view the contents of your scripts folder, choose File → Scripts → Open Scripts
Folder.
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Modifying the Appearance of Files and
Folders
Nautilus enables you to modify the appearance of your files and folders in several
ways, as described in the following sections.

To Add an Emblem to a File or Folder
To add an emblem to an item perform the following steps:

1. Select the item to which you want to add an emblem.

2. Right-click on the item, then choose Properties. A properties dialog is displayed.

3. Click on the Emblems tab to display the Emblems tabbed section.

4. Select the emblem to add to the item.

5. Click Close to close the properties dialog.

To Modify the Icon for a File or Folder
To change the icon that represents an individual file or folder, perform the following
steps:
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1. Select the file or folder that you want to change.

2. Choose File → Properties. A properties dialog is displayed.

3. On the Basic tabbed section, click on the Select Custom Icon button. A Select an
icon dialog is displayed.

4. Use the Select an icon dialog to choose the icon to represent the file or folder.

5. Click Close to close the properties dialog.

To change the icon that represents a file type, use the File Types and Programs
preference tool. To open the File Types and Programs preference tool, choose
Applications → Desktop Preferences → Advanced → File Types and Programs.

To restore an icon from a custom icon to the default icon specified in the File Types
and Programs preference tool, right-click on the icon then choose Remove Custom
Icon. Alternatively, click on the Remove Custom Icon button on the Properties dialog.

To Change the Size of Items in a View
You can change the size of items in a view. You can change the size if the view
displays a file or a folder. You can change the size of items in a view in the following
ways:

� To enlarge the size of items in a view, choose View → Zoom In.
� To reduce the size of items in a view, choose View → Zoom Out.
� To return items in a view to the normal size, choose View → Normal Size.

You can also use the zoom buttons on the location bar to change the size of items in a
view. Table 7–6 describes how to use the zoom buttons.

TABLE 7–6 Zoom Buttons

Button Button Name Description

Zoom Out button Click on this button to reduce the size of
items in a view.

Normal Size button Click on this button to return items in a
view to normal size.
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TABLE 7–6 Zoom Buttons (Continued)
Button Button Name Description

Zoom In button Click on this button to enlarge the size of
items in a view.

Nautilus remembers the size of items in a particular folder. The next time that you
display the folder, the items are displayed in the size that you selected. In other words,
when you change the size of items in a folder, you customize the folder to display the
items at that size. To return the size of the items to the default size specified in your
preferences, choose View → Reset View to Defaults.

Using Views to Display Your Files and Folders
Nautilus provides several ways to display the contents of your files. Nautilus includes
viewer components that enable you to display particular types of file in the view pane.
For example, you can use a web page viewer to display HTML files in the view pane.
You can use a text viewer to view plain text files in the view pane.

You can also use Nautilus to open a file in an appropriate application. For more
information, see “Opening Files” on page 107.

Nautilus includes views that enable you to display the contents of your folders in
different ways. For example, you can display the contents of a folder in the following
types of view:

� Icon view

Displays the items in the folder as icons. Figure 7–1 shows a folder displayed in
icon view.

� List view

Displays the items in the folder as a list. Figure 7–3 shows a folder displayed in list
view.
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FIGURE 7–3 Nautilus Window in List View

Use the View menu to choose how to display a file or folder. You can also use the
View as drop-down list to choose how to display a file or folder. When you display a
folder, you can specify how you want to arrange or sort items in the folder. You can
modify the size of the items in the view pane. The following sections describe how to
work with icon view, list view, and views of files.

To Choose a View in Which to Display a File or Folder
Choose the type of view in which to display the contents of a file or folder from the
View menu.

Alternatively, to choose a view, choose View → View as. Select the view that you want
to use from the Open with Other Viewer dialog, then click on the Choose button.

You can also choose the type of view from the View as drop-down list. The View as
drop-down list is located at the right side of the location bar.
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You can display different folders in different views. Nautilus remembers the view that
you choose for a particular folder. The next time that you display the folder, Nautilus
displays the folder in that view. To return the view for the folder to the default view
specified in your preferences, choose View → Reset View to Defaults.

To Arrange Your Files in Icon View
When you display the contents of a folder in icon view, you can specify how to
arrange the items in the folder. To specify how to arrange items in icon view, choose
View → Arrange Items. The Arrange Items submenu contains the following sections:

� The top section contains an option that enables you to arrange your files manually.

� The middle section contains options that enable you to sort your files
automatically.

� The bottom section contains options that enable you to modify how your files are
arranged.

Choose the appropriate options from the submenu, as described in the following table:

Option Description

Manually Select this option to arrange the items manually. To arrange the
items manually, drag the items to the location you require within
the view pane.

By Name Select this option to sort the items alphabetically by name. The
order of the items is not case sensitive. If Nautilus is set to display
hidden files, the hidden files are shown last.

By Size Select this option to sort the items by size, with the largest item
first. When you sort items by size, the folders are sorted by the
number of items in the folder. The folders are not sorted by the
total size of the items in the folder.

By Type Select this option to sort the items alphabetically by object type.
The items are sorted alphabetically by the description of their
MIME type in the File Types and Programs preference tool. The
MIME type identifies the format of a file, and enables applications
to read the file. For example, an email application can use the
image/png MIME type to detect that a PNG file is attached to an
email.

By Modification Date Select this option to sort the items by the date the items were last
modified. The most recently modified item is first.

By Emblems Select this option to sort the items by any emblems that are added
to the items. The items are sorted alphabetically by emblem name.
Items that do not have emblems are last.
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Option Description

Compact Layout Select this option to arrange the items so that the items are closer
to each other.

Reversed Order Select this option to reverse the order of the option by which you
sort the items. For example, if you sort the items by name, select
the Reversed Order option to sort the items in reverse alphabetical
order.

Nautilus remembers how you arrange the items in a particular folder. The next time
that you display the folder, the items are arranged in the way that you selected. In
other words, when you specify how to arrange the items in a folder, you customize the
folder to display the items in that way. To return the arrangement settings of the folder
to the default arrangement settings specified in your preferences, choose View →
Reset View to Defaults.

To Stretch an Icon in Icon View
In icon view, you can change the size of the icon that represents an item that is
displayed. To change the size of an item in icon view, perform the following steps:

1. Right-click on the item that you want to resize, then choose Stretch Icon. A
rectangle appears around the item, with a handle at each corner.

2. Grab one of the handles, then drag the icon to the size that you want.

To return the icon to the original size, right-click on the icon, then choose Restore
Icon’s Original Size.

You can also stretch icons on the desktop.

To Modify the Behavior of a View
You can modify the behavior of a view in the following ways:

� Specify that the view is the default view for a particular file or folder.
� Specify that the view is the default view for a file type or all folders.
� Specify that the view is an item in the View as submenu for a particular file or

folder.
� Specify that the view is an item in the View as submenu for all of a particular file

type or for all folders.
� Specify that the view is not an item in the View as submenu for a particular file or

folder.

To modify the behavior of a view perform the following steps:

1. Choose View → View as. An Open with Other Viewer dialog is displayed.
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2. Select the view that you want to modify from the table in the dialog.

3. Click on the Modify button. A Modify dialog is displayed. The following table
describes the options on the Modify dialog:

Option Description

Include in the menu for
item-name items

Select this option to include the view in the View as
submenu for this type of item.

Use as default for item-name
items

Select this option to use the view as the default for this
type of item.

Include in the menu for
item-name only

Select this option to include the view in the View as
submenu for this item only.

Use as default for item-name
only

Select this option to use the view as the default for this
item only.

Don’t include in the menu for
item-name items

Select this option to exclude the view from the View as
submenu for this type of item.

4. Click OK, then click Cancel to close the Open with Other Viewer dialog.

Note – You can also modify the actions that are associated with a file type in the File
Types and Programs preference tool. To open the File Types and Programs preference
tool, click on the Go There button.
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Assigning Actions to Files
When you open a file, Nautilus performs the default action for that file type. The File
Types and Programs preference tool contains a table of file types, their associated file
extensions, and their default actions. This table specifies what happens when you
double-click on a file in Nautilus.

You can also use Nautilus to modify the actions that are associated with a particular
file or file type.

You can use the File Types and Programs preference tool to perform the following
tasks:

� Specify the default action for a file type. You can also change the default action for
a file type in Nautilus.

� Associate a file type with one or more applications. The default action might
specify to open the file in an application that is associated with the file type.

� Associate a file type with one or more viewers. The default action might specify to
open the file in a viewer that is associated with the file type.

� Associate a file extension with a MIME type. The MIME type specifies the format
of the file so that Internet browsers and email applications can read the file.

To Modify Actions
You can modify the actions associated with a file or file type. You can do the following:

� Specify that the action is the default action for a particular file.
� Specify that the action is the default action for a particular file type.
� Specify that the action is an item in the Open With submenu for a particular file.
� Specify that the action is an item in the Open With submenu for a particular file

type.
� Specify that the action is not an item in the Open With submenu for a particular file

type.

To modify the actions associated with a file or file type, perform the following steps:

1. In the view pane, select the file for which you want to modify an action. If you
want to modify an action associated with a file type, select a file of that type.

2. Choose File → Open With. Perform either of the following steps:

� Choose Other Application. An Open with Other Application dialog is
displayed.

� Choose Other Viewer. A Open with Other Viewer dialog is displayed.
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3. From the table in the dialog, select the application or viewer for which you want to
modify the behavior.

4. Click on the Modify button. A Modify dialog is displayed. The following table
describes the options on the Modify dialog:

Option Description

Include in the menu for
file-type items

Select this option to include the application or viewer in
the Open With submenu for this file type.

Use as default for file-type
items

Select this option to use the application or viewer as the
default action for this file type.

Include in the menu for
filename only

Select this option to include the application or viewer in
the Open With submenu for this file, and not for other
files of this type.

Use as default for filename only Select this option to use the application or viewer as the
default action for this file, and not for other files of this
type.

Don’t include in the menu for
file-type items

Select this option to exclude the application or viewer
from the Open With submenu for this file type.

5. Click OK, then click Cancel to close the dialog.

Note – You can also modify the actions that are associated with a file type in the File
Types and Programs preference tool. To open the File Types and Programs preference
tool, click on the Go There button.

Customizing Nautilus
You can customize Nautilus to suit your requirements and preferences. This section
describes how to customize Nautilus.

Setting Your Preferences
Use the Preferences dialog to set preferences for the Nautilus windows and desktop.
To display the Preferences dialog, choose Edit → Preferences.

You can set preferences in the following categories:
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� The default settings for views.
� The appearance of the Nautilus windows and desktop.
� The behavior and visible components of new Nautilus windows.
� The behavior of the desktop and Trash.
� The behavior of items in icon views and list views.
� The information that is displayed in icon captions.
� Items that are displayed in the side pane.
� Performance options to improve the performance of Nautilus.

To Set View Preferences
You can specify a default view, and default settings for icon views and list views. To
specify your default view settings for Nautilus windows, choose Edit → Preferences.
Choose Views from the Preferences dialog.

Table 7–7 lists the view settings that you can modify. The Preferences dialog contains
an Icon View Defaults group box and a List View Defaults group box. The group
boxes contain mostly the same dialog elements. Each dialog element is described once
in Table 7–7.
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TABLE 7–7 View Preferences

Dialog Element Description

View new folders using Select the default view for folders. When you open a folder,
the folder is displayed in the view that you select.

Arrange Items Select the characteristic by which you want to sort the items
in folders that are displayed in this view.

Default zoom level Select the default zoom level for folders that are displayed
in this view. The zoom level specifies the size of items in a
view.

Sort in reverse Select this option if you want to reverse the order by which
items are sorted in this view. If you select this option, the
order of the characteristic you select in Arrange Items is
reversed. For example, if you select By Name from the
Arrange Items drop-down list. You can select the Sort in
reversed order option to sort the items in reverse
alphabetical order.

Use compact layout Icon view only. Select this option to arrange the items so
that the items in the folder are closer to each other.

To Select a Nautilus Theme
Nautilus includes themes that you can use to change the look-and-feel of the Nautilus
windows and the desktop. To set your preferences for the font and theme of the
Nautilus windows and desktop, choose Edit → Preferences. Choose Appearance from
the Preferences dialog.
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Table 7–8 lists the font and theme settings that you can modify.

TABLE 7–8 Appearance Preferences

Dialog Element Description

Nautilus Themes To change your Nautilus theme, choose a theme from the
list.

Add Theme To add a new Nautilus theme, click on the Add New Theme
button. A dialog is displayed. Use the dialog to find the new
theme.

To Set Preferences for New Windows
To set your preferences for new Nautilus windows, choose Edit → Preferences. Choose
Windows from the Preferences dialog.
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Table 7–9 lists the window settings that you can modify.

TABLE 7–9 New Window Preferences

Option Description

Open each file or folder in a
separate window

Select this option to open a new window when you open a
file or folder.

Display side pane Select this option to display a side pane in new windows.

Display toolbar Select this option to display a toolbar in new windows.

Display location bar Select this option to display a location bar in new windows.

Display statusbar Select this option to display a statusbar in new windows.

To Set Desktop and Trash Preferences
To set your preferences for the Nautilus desktop and Trash, choose Edit →
Preferences. Choose Desktop & Trash from the Preferences dialog.
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Table 7–10 lists the desktop and Trash settings that you can modify.

TABLE 7–10 Windows and Desktop Preferences

Option Description

Use Nautilus to draw the
desktop

Select this option to use Nautilus to manage your desktop. If
you do not use Nautilus to manage your desktop, you
cannot do the following:
� Use the Desktop menu.
� Use Nautilus to change the pattern or color of the

desktop background.
� Use the Nautilus Home launcher and Trash launcher.

The Home launcher and Trash launcher are not
displayed on the desktop.

Use your home folder as the
desktop

Select this option to use your home directory as the desktop
directory, instead of the default directory. If you select this
option, the contents of your home directory are displayed as
desktop objects.

Ask before emptying the Trash
or deleting files

Select this option to display a confirmation message before
Trash is emptied, or files are deleted.
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TABLE 7–10 Windows and Desktop Preferences (Continued)
Option Description

Include a Delete command that
bypasses Trash

Select this option to add a Delete menu item to the
following menus:
� The Edit menu.
� The popup menu that is displayed when you right-click

on a file, folder, or desktop object.

When you select an item then choose the Delete menu item,
the item is deleted from your file system immediately.

To Set Icon and List Views Preferences
To set your preferences for items in icon views and list views, choose Edit →
Preferences. Choose Icon & List Views from the Preferences dialog.

Table 7–11 lists the settings that you can modify for items in icon views and list views.

TABLE 7–11 Icon and List Views Preferences

Option Description

Activate items with a single
click

Select this option to perform the default action for an item
when you click on the item. When this option is selected,
and you point to an item, the title of the item is underlined.
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TABLE 7–11 Icon and List Views Preferences (Continued)
Option Description

Activate items with a double
click

Select this option to perform the default action for an item
when you double-click on the item.

Execute files when they are
clicked

Select this option to run an executable file when you choose
the executable file. An executable file is a text file that can
execute, that is, a shell script.

Display files when they are
clicked

Select this option to display the contents of an executable
file when you choose the executable file.

Ask each time Select this option to display a dialog when you choose an
executable file. The dialog asks whether you want to execute
the file or display the file.

Hidden files Select this option to display hidden files in the view pane.
The first character in a hidden file name is a period (.).

Backup files Select this option to display backup files in the view pane.
The last character in a backup file name is a tilde (~).

Special flags in Properties
dialog

Select this option to show the following special flags in the
Permissions tab on a properties dialog:
� Set User ID
� Set Group ID
� Sticky

Folders before files Select this option to list folders before files when you sort a
folder.

To Set Icon Captions Preferences
An icon caption displays the name of a file or folder in an icon view. The icon caption
also includes three additional items of information on the file or folder. The additional
information is displayed after the file name. Normally only one item of information is
visible, but when you zoom in on an icon, more of the information is displayed. You
can modify what additional information is displayed in icon captions.

To set your preferences for icon captions, choose Edit → Preferences. Choose Icon
Captions from the Preferences dialog.
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Select the items of information that you want to display in the icon caption from the
three drop-down lists. Select the first item from the first drop-down list, select the
second item from the second drop-down list, and so on. The following table describes
the items of information that you can select:

Information Description

Size Choose this option to display the size of the item.

Type Choose this option to display the description of the MIME
type of the item from the File Types and Programs
preference tool.

Date modified Choose this option to display the last modification date of
the item.

Date changed Choose this option to display the last modification date of
the inode of the item. An inode is a data structure that
contains information about individual files in UNIX file
systems. Each file has one inode. An inode contains the
node, type, owner, and location of a file.

Date accessed Choose this option to display the date that the item was last
accessed.

Owner Choose this option to display the owner of the item.
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Information Description

Group Choose this option to display the group to which the owner
of the item belongs.

Permissions Choose this option to display the permissions of the item as
three sets of three characters, for example -rwxrw-r--.

Octal permissions Choose this option to display the permissions of the item in
octal notation, for example 764.

MIME type Choose this option to display the MIME type of the item.

None Choose this option to display no information for the item.

To Set Side Pane Preferences
To set your preferences for the side pane, choose Edit → Preferences. Choose Side
Panes from the Preferences dialog.

Table 7–12 lists the side pane settings that you can modify.

TABLE 7–12 Side Pane Preferences

Option Description

History Select this option to display the History tab in the side pane.
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TABLE 7–12 Side Pane Preferences (Continued)
Option Description

Notes Select this option to display the Notes tab in the side pane.

Tree Select this option to display the Tree tab in the side pane.

Show folders only Select this option to display only folders in the Tree tabbed
pane.

To Set Performance Preferences
Some Nautilus features can affect the speed with which Nautilus responds to your
requests. You can modify the behavior of some of these features to improve the speed
of Nautilus. For each performance preference, you can select one of the options
described in the following table:

Option Description

Always Performs the action for both local files, and files on other file
systems.

Local File Only Performs the action for local files only.

Never Never performs the action.

To set your performance preferences, choose Edit → Preferences. Choose Performance
from the Preferences dialog.
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Table 7–13 lists the performance settings that you can modify.

TABLE 7–13 Performance Preferences

Dialog Element Description

Show Text in Icons Select an option to specify when to preview the content of
text files in the icon that represents the file.

Show Number of Items in
Folders

Select an option to specify when to show the number of
items in folders.

Show Thumbnails for Image
Files

Select an option to specify when to show thumbnails of
image files. Nautilus stores the thumbnail files for each
folder in a .thumbnails directory that is one level below
the folder.

Do not make thumbnails for files larger than: Specify the
maximum file size for files for which Nautilus creates a
thumbnail.

Preview Sound Files Select an option to specify when to preview sound files.

Changing Backgrounds
Nautilus includes backgrounds that you can use to change the look-and-feel of the
following screen components:

� Nautilus desktop
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� Side pane
� View pane
� Panels, except for the Menu Panel

To change the background of a screen component perform the following steps:

1. Choose Edit → Backgrounds and Emblems. The Backgrounds and Emblems
dialog is displayed.

2. To display a list of patterns that you can use on the background, click on the
Patterns button. To display a list of the colors that you can use on the background,
click on the Colors button.

3. To change the background to a pattern, drag the pattern to the screen component.
To change the background to a color, drag the color to the screen component.

4. Click Close to close the dialog.

Alternatively, you can right-click on the background of the side pane and the view
pane, then choose Change Background. The Backgrounds and Emblems dialog is
displayed. To reset the pane background to the default background, right-click on the
background of the pane, then choose Use Default Background.

When you change the background of the side pane or the view pane of a particular
folder, Nautilus remembers the background that you chose. The next time that you
display the folder, the background that you selected is displayed. In other words,
when you change the background of a folder, you customize the folder to display the
background.

To Add a Pattern
To add a pattern to the patterns that you can use on your screen components, choose
Edit → Backgrounds and Emblems. Click on the Patterns button, then click on the Add
New Pattern button. A dialog is displayed. Use the dialog to find the new pattern.
Click OK to add the new pattern to the Backgrounds and Emblems dialog.

To Add a Color
To add a color to the colors that you can use on your screen components, choose Edit
→ Backgrounds and Emblems. Click on the Colors button, then click on the Add New
Color button. A color selector dialog is displayed. Use the color wheel or the sliders to
choose the color. Click OK to add the new color to the Backgrounds and Emblems
dialog.

To Show and Hide Window Components
You can show and hide Nautilus window components as follows:
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� To hide the side pane, choose View → Side Pane. To display the side pane again,
choose View → Side Pane again.

� To hide the toolbar, choose View → Toolbar. To display the toolbar again, choose
View → Toolbar again.

� To hide the location bar, choose View → Location Bar. To display the location bar
again, choose View → Location Bar again.

� To hide the statusbar, choose View → Statusbar. To display the statusbar again,
choose View → Statusbar again.

� To remove a tab from the side pane, right-click in the side pane. Choose the tab that
you want to remove from the popup menu. To add the tab to the side pane again,
choose the tab from the popup menu again.

Using Removable Media
Nautilus supports the following removable media:

� Floppy diskette
� CD-ROM
� Iomega Zip disk
� Iomega Jaz disk
� Digital Video Disc (DVD)

When Nautilus detects a new media, an object for the media is added to the desktop.
You can display the contents of the media in a Nautilus window. You can
drag-and-drop files and folders between removable media.

You can protect media, and format media. You can also create slices on Zip and Jaz
media. A slice is a partition of a disk. An object for each slice appears on the desktop.

Note – Removable media works on Solaris 9 only.

To Display Media Contents
You can display media contents in any of the following ways:

� Double-click on the object that represents the media on the desktop.
� Right-click on the object that represents the media on the desktop, then choose

Open.

A Nautilus window displays the contents of the media. To reload the display, click on
the Reload button.
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To Display Media Properties
To display the properties of removable media, right-click on the object that represents
the media on the desktop, then choose Media Properties. A Media Properties dialog is
displayed.

To view general information on the media, select the Information option. The
following table describes the information dialog elements on the Media Properties
dialog:

Dialog Element Description

Alias Displays the name of the media.

Product Id Displays the media type.

Write Protect Indicates whether the media is write-protected.

Password Protect Indicates whether the media is password-protected.

File System Displays the file system in which the media is formatted.

Mount Point Displays the file system location where the device is
attached.

Total Capacity Displays the total amount of storage space on the media.

To view the amount of used storage space and available storage space on the media,
select the Floating Capacities option. The storage space details are displayed on the
Media Properties dialog.
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To Format Media
To format media is to prepare the media for use with a particular file system. When
you format media, you overwrite any existing information on the media. You can
format the following media:

� Floppy diskette
� Zip disk
� Jaz disk

To format media, perform the following steps:

1. Right-click on the object that represents the media on the desktop, then choose
Format. A Media Format dialog is displayed.

2. Select your format options in the Media Format dialog. The following table
describes the elements on the dialog:

Dialog Element Description

Quick Format Select this option to format without certification, or with
limited certification of certain tracks on the media.

Long Format Select this option to perform a complete format. For some
devices this might include certification of whole media by
the drive.
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Dialog Element Description

File System Type Select the type of file system in which you want to format
the media. Select from the following options:
� PCFS (DOS): Select this option if you want to use the

media on an MS-DOS operating system.
� UFS (UNIX): Select this option if you want to use the

media on a UNIX operating system.
� UDFS (UNIX): Select this option if you want to format

the media in Universal Disk File System (UDFS).
� NEC (DOS): Select this option if you want to format

the media in the NEC file system.

Volume Label Type a name for the media in the text box.

Slice Editor Click on this button if you want to slice a Zip disk or Jaz
disk. This button is only available if you select UFS in the
File System Type drop-down list. For more information,
see the next section.

3. Click Format to format the media.

To Create Slices
You can only modify or delete slices as part of the format process. You can slice the
following media:

� Zip disk
� Jaz disk

You cannot create more than seven slices on a media. In the slice creation process, an
additional backup slice is created. The additional slice always takes the numeric
identifier 2. Slice 2 exists for system purposes only. Slice 0 must always use the UFS
file system.

To slice a Zip disk or Jaz disk manually perform the following steps:

1. Right-click on the object that represents the media on the desktop, then choose
Format.

2. Select your format options in the Media Format dialog. You can only create slices
on media if you select UFS in the File System Type drop-down list. For more
information on format options, see the previous section.

3. Click on the Slice Editor button. The Slice Editor dialog is displayed.
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4. To create slices automatically, click on the AutoSlice button. A dialog is displayed.
Type the number of slices that you want on the media. Click OK. Slices are created
in approximately equal sizes on the media.

5. To create a slice manually, enter your slice options in the Slice Editor dialog, then
click on the New button. The following table describes the elements on the dialog:

Dialog Element Description

Slices table Displays the slices that are currently on the media.

Delete To delete a slice, select the slice in the Slices table, then
click Delete.

Size Type the size that you require for the slice.

Size units drop-down list Select the units in which you want to display the size of
slices.

Start To edit a slice, type the numeric identifier for the slice in
this text box.

Prevent Overlaps Select this option to prevent slices overlapping each other.

Tags Select a tag for the slice. The tags in the drop-down list are
labels that describe typical uses of slices.

File System Select the file system for the slice. You can select either
UFS or UDFS file systems. Slice 0 must be in UFS file
system.
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Dialog Element Description

Flags Select the flags that you want to apply to the slice. Select
from the following options:
� Read: Select this option to make the slice readable.
� Write: Select this option to make the slice writable.
� Mountable: Select this option to enable the slice to be

mounted. To mount media is to make the file system of
the media available for access. When you mount
media, the file system of the media is attached as a
subdirectory to your file system.

6. To edit a slice, enter your slice options in the Slice Editor dialog, then click on the
Change button.

7. Click OK to close the Slice Editor dialog.

To Protect Media
You can protect removable media from write operations, or from read operations and
write operations. You can protect media with or without a password. You can protect
the following types of media:

� Jaz disk
� Zip disk

To view the protection of media, right-click on the object that represents the media on
the desktop, then choose Media Properties.

Nautilus recognizes the protection on media. Nautilus displays emblems on the
desktop objects that represent the media, to indicate the type of protection that
applies. Nautilus also recognizes if a floppy diskette is write-protected.

To protect media from write actions, right-click on the object that represents the media
on the desktop. Choose Write Protect.

To protect media from read actions and write actions, perform the following steps:

1. Right-click on the object that represents the media on the desktop, then choose
Read Write Protect. A protection dialog is displayed.
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2. Select one of the following options from the dialog:

Dialog Element Description

Disable Protection Select this option to remove protection from the media. If
the media is protected by a password, a Password dialog
is displayed. Type the password in the Password field,
then click OK.

This option is only available if the media is protected.

Write Protect Without
Password

Select this option to protect the media from write
operations, without a password.

Write Protect With Password Select this option to protect the media from write
operations, with a password.

Read-Write Protect With
Password

Select this option to protect the media from read
operations and from write operations, with a password.

3. Click OK.

If you selected the Write Protect With Password option, or the Read-Write Protect
With Password option, the Media Password Entry dialog is displayed. Type the
password for the media, then type the password again to verify the password.
Click OK to set the password.

To change the password for media, you must first disable the protection on the
media, then apply the new password protection to the media.

To disable protection of media, right-click on the object that represents the media on
the desktop. Choose Disable Protection.

To Eject Media
To eject media, right-click on the media object on the desktop, then choose Eject. If the
drive for the media is a motorized drive, the media is ejected from the drive. If the
drive for the media is not a motorized drive, a message is displayed when you can
manually eject the media.
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When you use the Eject command to eject media, the media is automatically
unmounted.
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CHAPTER 8

Using Your Desktop

By default, the Nautilus file manager manages your desktop. If you do not use
Nautilus to manage your desktop, ignore this chapter. This chapter describes how to
use the Nautilus desktop.

� “Introduction to the Desktop” on page 149
� “Desktop Objects” on page 151
� “Using Trash on the Desktop” on page 155
� “Using the Desktop Menu” on page 157
� “Changing the Pattern or Color of the Desktop” on page 158

Introduction to the Desktop
The desktop lies behind all of the other components in your desktop environment. The
desktop is an active component of the user interface. You can perform the following
tasks from your desktop:

� Start your applications, and open your files and folders.

You can add desktop objects for convenient access to files, folders, and applications
that you use frequently. For example, you can add an application launcher to the
desktop. You can create a symbolic link to a file that you use often, then add this
link to your desktop. You can also store files and folders on the desktop.

� Open the Desktop menu.

Right-click on the desktop to open the Desktop menu. You can use the Desktop
menu to perform actions on the desktop.

� Work with Trash.

You can move objects to Trash and empty your Trash.
� Customize your desktop background.

You can customize the pattern or color of the desktop background.
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By default, your desktop contains three objects.

FIGURE 8–1 Desktop with Default Objects

Table 8–1 describes the functions of the default objects on the desktop.

TABLE 8–1 Functions of Default Desktop Objects

Object Component Function

Home Opens a Nautilus window, and displays
your home location in the view pane.
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TABLE 8–1 Functions of Default Desktop Objects (Continued)
Object Component Function

Start Here Provides an access point to some of the key
features of the GNOME Desktop.

GNOME Overview Opens a help browser window, and
displays overview information about the
GNOME Desktop.

Trash Opens a Nautilus window, and displays
your Trash in the view pane.

Desktop Objects
A desktop object is an icon on your desktop that you can use to open your files,
folders, and applications. All objects on your desktop reside in the desktop directory.
When you move objects to the desktop, the objects are moved to this directory. You
can also use your home directory as the desktop directory.

By default, your desktop contains three objects. You can also add objects to your
desktop to provide convenient access to files, folders, and applications that you use
frequently. For example, you can add a launcher to your desktop to enable you to
open a particular application that you use often.

Table 8–2 describes the types of object that you can add to your desktop.
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TABLE 8–2 Types of Desktop Objects

Object Type Description

Symbolic link A symbolic link is an object that points to another file or folder.
When you choose a symbolic link from the desktop, the file or
folder that the symbolic link points to is opened. You can move
or copy a symbolic link to the desktop.

You can identify symbolic links by the default arrow emblem
that appears on all symbolic links.

Launcher You can add the following types of launcher to the desktop:
� Application: Starts a particular application.
� Link: Links to a particular file, folder, or URL.

File You can add files to your desktop. Files on your desktop reside
in your desktop directory.

Folder You can move folders to your desktop, and you can create
folders on your desktop. Folders on your desktop reside in your
desktop directory.

You can modify desktop objects in the following ways:

� View the properties of the object.
� Rename the object.
� Change the permissions of the object.
� Change the icon that represents the object.
� Resize the icon that represents the object.
� Add an emblem to the object.

The following sections describe how to work with objects on the desktop.

To Select Objects on the Desktop
To select an object on the desktop, click on the object. To select multiple objects,
press-and-hold Ctrl, then click on the objects that you want to select.

You can also select an area on the desktop to select all objects within that area.
Click-and-hold on the desktop, then drag over the area that contains the objects that
you want to select. When you click-and-hold then drag, a grey rectangle appears to
mark the area that you select.

To select multiple areas, press-and-hold Ctrl, then drag over the areas that you want to
select.
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To Open an Object from the Desktop
To open an object from the desktop, double-click on the object. Alternatively,
right-click on the object, then choose Open. When you open on an object, the default
action for the object executes. For example, if the object is a text file, the text file opens
in a Nautilus window. The default actions for file types are specified in the File Types
and Programs preference tool.

To execute an action other than the default action for an object, right-click on the
object, then choose Open With. Choose an action from the Open With submenu.

The items in the Open With submenu correspond to the contents of the following parts
of the File Types and Programs preference tool:

� Default action drop-down list in the Edit file type dialog
� Viewer Component drop-down list in the Edit file type dialog

You can set your preferences in a Nautilus window so that you click once on a file to
execute the default action.

To Add a Launcher to the Desktop
A desktop launcher can start an application or link to a particular file, folder, or FTP
site.

To add a launcher to your desktop, perform the following steps:

1. Right-click on the desktop, then choose New Launcher. A Create Launcher dialog
is displayed.

2. For information on how to enter the properties of the launcher in the Create
Launcher dialog, see Working With Panels.

The command that you enter for the launcher is the command that is executed
when you use the desktop object. The following table shows some sample
commands and the actions that the commands perform.

Sample Command Action

gedit Starts the gedit application.

gedit /user123/loremipsum.txt Opens the file /user123/loremipsum.txt
in the gedit application.

nautilus /user123/Projects Opens the folder /user123/Projects in a
Nautilus window.
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To Add a Symbolic Link to the Desktop
You can create symbolic links on your desktop to perform the following actions:

� Open a particular file in a particular application.
� Open a particular folder in a Nautilus window.
� Run a binary file or a script.

To create a symbolic link on the desktop, perform the following steps:

1. Display the file or folder for which you want to create a symbolic link in a Nautilus
window.

2. Create a symbolic link to the file or folder. To create a symbolic link to a file or
folder, select the file or folder to which you want to create a link. Choose Edit →
Make Link. A link to the file or folder is added to the current folder. You can
identify symbolic links by the default arrow emblem that appears on all symbolic
links. The following figure shows a symbolic link to a file:

3. Drag the symbolic link to the desktop. The icon for the object is moved to the
desktop.

Adding a File or Folder to the Desktop
The following sections describe how you can add file objects and folder objects to the
desktop.

To Move a File or Folder to the Desktop
You can move a file or folder from a Nautilus window to the desktop. To move a file
or folder to the desktop, perform the following steps:

1. Open a Nautilus window.

2. In the view pane, display the file or folder that you want to move.

3. Drag the file or folder to the desktop. The icon for the file or folder is moved to the
desktop. The file or folder is moved to your desktop directory.

Alternatively, select the file or folder, then choose Edit → Cut Files. Right-click on
any desktop object, then choose Paste Files.
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To Copy a File or Folder to the Desktop
You can copy a file or folder from a Nautilus window to the desktop. To copy a file or
folder to the desktop, perform the following steps:

1. Open a Nautilus window.

2. In the view pane, display the file or folder that you want to move.

3. Press-and-hold Ctrl, then drag the file or folder to the desktop. An icon for the file
or folder is added to the desktop. The file or folder is copied to your desktop
directory.

Alternatively, select the file or folder, then choose Edit → Copy Files. Right-click on
any desktop object, then choose Paste Files.

To Create a Folder Object on the Desktop
To create a folder object, right-click on the desktop to open the Desktop menu. Choose
New Folder. An untitled folder is added to the desktop. Type the name of the new
folder, then press Return. The folder is displayed with the new name. The new folder
resides in your desktop directory.

To Remove an Object from the Desktop
To remove an object from the desktop, right-click on the object, then choose Move to
Trash. Alternatively, drag the object to Trash.

To Delete an Object from the Desktop
When you delete an object from the desktop, the object is not moved to Trash, but is
immediately deleted from the desktop. The Delete menu item is only available if you
select the Include a Delete command that bypasses Trash option in the Nautilus
Preferences dialog.

To delete an object from the desktop right-click on the object, then choose Delete.

Using Trash on the Desktop
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You can move the following items to Trash:

� Files
� Folders
� Desktop objects

If you need to retrieve a file from Trash, you can view Trash and move the file out of
Trash. When you empty Trash, you delete the items in Trash permanently.

To Display Trash
You can display the contents of Trash in the following ways:

� From the desktop

Double-click on the Trash object on the desktop. The contents of Trash are
displayed in a Nautilus window.

� From a Nautilus window

Choose Go → Trash. The contents of Trash are displayed in the window.

To Empty Trash
You can empty the contents of Trash in the following ways:

� From the desktop

Right-click on the Trash object, then choose Empty Trash.

� From a Nautilus window

Choose File → Empty Trash.
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Using the Desktop Menu

To open the Desktop menu, right-click on a vacant space on the desktop. You can use
the Desktop menu to perform actions on the desktop.

Table 8–3 describes the items in the Desktop menu.

TABLE 8–3 Items on the Desktop Menu

Menu Item Function

New Window Opens a new Nautilus window that displays your home
location.

New Folder Creates a new folder object on your desktop. The folder is
created in your desktop directory.

New Terminal Starts a GNOME Terminal.

New Launcher Creates a launcher on your desktop. For more information,
see “To Add a Launcher to the Desktop” on page 153.

Scripts Opens a submenu of scripts that you can run.

Clean Up By Name Arranges the objects on the desktop alphabetically by name.

Cut Files Deletes the selected file or files from the folder or desktop,
and places the file or files in buffer.

Copy Files Copies the selected file or files from the folder or desktop,
and places the file or files in buffer.

Paste Files Puts the file or files in the buffer into the selected folder or
the desktop.

Disks Enables you to mount diskettes and other removable media.
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TABLE 8–3 Items on the Desktop Menu (Continued)
Menu Item Function

Change Desktop Background Starts the Background preference tool to enable you to
change the desktop background.

Use Default Background Resets the desktop background to the last pattern that you
chose from the Backgrounds and Emblems dialog. You can
access the Backgrounds and Emblems dialog from Nautilus
windows.

Changing the Pattern or Color of the
Desktop
You can change the pattern or color of the desktop background to suit your
preferences. Nautilus includes background patterns and colors that you can use to
change the look-and-feel of the desktop background.

You can change the pattern or color of the desktop background in any of the following
ways:

� Drag a pattern or color from another window or dialog to the desktop.

If your desktop background is a color, you can create a gradient effect from a color
into the desktop background color. A gradient effect is a visual effect where one
color blends gradually into another color. To create a gradient effect on your
desktop background, drag a color to one of the edges of the screen. The color
blends from the edge to which you drag the color, to the opposite edge of the
screen.

Before you drag a color to a screen edge, check if there is an edge panel on the
screen edge. If there is an edge panel on the screen edge, you must hide the panel
before you drag the color.

� Use the Background preference tool.
� Choose a pattern or color for the background from the Backgrounds and Emblems

dialog. To change the pattern or color of the desktop background, perform the
following steps:

1. Open a Nautilus window.

2. Choose Edit → Backgrounds and Emblems. The Backgrounds and Emblems
dialog is displayed.

3. To display a list of patterns that you can use, click on the Patterns button. To
display a list of the colors that you can use, click on the Colors button.
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4. To change the desktop background to a pattern, drag the pattern to the desktop
background. To change the desktop background to a color, drag the color to the
desktop background.

5. Click Close to close the dialog.
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PART II

Customizing Your GNOME Desktop

You can customize many of the characteristics of your desktop environment. The
customization of each aspect of the desktop is controlled by a dedicated software tool
that is called a desktop environment preference tool. For convenience, the preference
tools are grouped under the following headings:

� Basic
� Accessibility
� Advanced

You can open your preference tools in either of the following ways:

� Choose Applications → Desktop Preferences. Choose the tool that you require from
the submenus.

� Double-click on the Start Here object on the desktop. A Nautilus window opens at
the Start Here location. Double-click on the Preferences object in the Nautilus
window to display your preference tools. Double-click on the tool that you require.

This section describes how to configure the desktop environment in the following
chapters.

� Using the Basic Preference Tools

Read this chapter to find out how to customize your desktop background, and how
to configure your keyboard settings and your mouse settings. This chapter also
describes how to configure shortcut keys, how to set your sound preferences, and
how to configure your network proxy. This chapter also contains information on
how to customize your screensaver, how to choose a theme and fonts for your
desktop, and how to customize your application menubars and toolbars. This
chapter also describes how to customize window focus behavior.

� Using the Advanced Preference Tools

This chapter describes how to configure file types, your preferred applications, and
your panels. This chapter also contains information on how to customize your
sessions and startup programs.

� Using the Accessibility Preference Tools
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Read this chapter to find out how to use the accessibility features of the desktop
environment. This chapter describes how to use the keyboard accessibility features.
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CHAPTER 9

Using the Basic Preference Tools

The basic preference tools enable you to customize your desktop background, and to
configure your keyboard settings and your mouse settings. You can use the basic
preference tools to configure shortcut keys, to set your sound preferences, and to
configure your network proxy. You can also use the basic preference tools to customize
your screensaver, choose a theme and fonts for your desktop, and to customize your
application menubars and toolbars. You can also customize window focus behavior.

This chapter describes how to use the basic preference tools to customize your
desktop.

� “Opening a Basic Preference Tool” on page 163
� “Customizing the Desktop Background” on page 164
� “Choosing Default Fonts” on page 166
� “Configuring Keyboard Settings” on page 167
� “Customizing Keyboard Shortcuts” on page 169
� “Customizing Menus and Toolbars in Applications” on page 170
� “Configuring Mouse Settings” on page 172
� “Configuring Network Proxy Settings” on page 175
� “Setting Screensaver Preferences” on page 176
� “Setting Sound Preferences” on page 179
� “Setting Themes in the Desktop Environment” on page 182
� “Customizing Window Focus” on page 184

Opening a Basic Preference Tool
You can open one of the basic preference tools in either of the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences. Choose the preference tool that you
require from the submenu. The dialog for the tool is displayed.
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� From the Start Here location

Open a Nautilus window, then choose Go → Start Here. Alternatively, double-click
on the Start Here object on the desktop. The Start Here location is displayed.
Double-click on the Desktop Preferences object in the Nautilus window to display
your preference tools.

Double-click on the tool that you require. The dialog for the tool is displayed.

Customizing the Desktop Background
The desktop background is the image or color that is applied to your desktop. You can
customize the desktop background in the following ways:

� Select an image for the desktop background. The image is superimposed on the
desktop background color. The desktop background color is visible if you select a
transparent image, or if the image does not cover the entire desktop.

� Select a color for the desktop background. You can select a solid color, or create a
gradient effect with two colors. A gradient effect is a visual effect where one color
blends gradually into another color.

You can also change the appearance of your desktop background from within the
Nautilus file manager.
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FIGURE 9–1 Desktop Background Preference Tool

Table 9–1 lists the background settings that you can configure.

TABLE 9–1 Settings for Desktop Background

Element Function

Select picture Choose an image to display on the desktop. To choose an image,
click on the Select picture button. An image selector dialog is
displayed. Use the dialog to choose an image. When you choose an
image, click OK.

Picture Options To specify how to display the image, select one of the following
options:
� Wallpaper: Repeats the image to cover the desktop.
� Centered: Displays the image in the middle of the desktop.
� Scaled: Enlarges the image until the image meets the screen

edges, and maintains the relative dimensions of the image.
� Stretched: Enlarges the image to cover the desktop, and does

not maintain the relative dimensions of the image.
� No Picture: Displays no image.
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TABLE 9–1 Settings for Desktop Background (Continued)
Element Function

Background Style To specify a color scheme, use the options in the Background Style
drop-down list, and the color selector buttons.

You can specify a color scheme in one of the following ways:
� Choose Solid color from the Background Style drop-down list

to specify a single color for the desktop background.
To choose the color that you require, click on the Color button.
The Pick a Color dialog is displayed. Choose a color, then click
OK.

� Choose Horizontal gradient from the Background Style
drop-down list. This option creates a gradient effect from the
left screen edge to the right screen edge.
Click on the Left Color button to display the Pick a Color
dialog. Choose the color that you want to appear at the left
edge.
Click on the Right Color button. Choose the color that you want
to appear at the right edge.

� Choose Vertical gradient from the Background Style
drop-down list. This creates a gradient effect from the top screen
edge to the bottom screen edge.
Click on the Top Color button to display the Pick a Color
dialog. Choose the color that you want to appear at the top
edge.
Click on the Bottom Color button. Choose the color that you
want to appear at the bottom edge.

Choosing Default Fonts
Use the Font preference tool to select the fonts to use on in your applications and on
the desktop.

FIGURE 9–2 Font Preference Tool

Table 9–2 lists the font settings that you can configure.
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TABLE 9–2 Settings for Fonts

Option Function

Application font Click on the font selector button to select a font to use in your
applications.

Desktop font Click on the font selector button to select a font to use on your
desktop only.

Configuring Keyboard Settings
Use the Keyboard preference tool to select the autorepeat settings for your keyboard,
and to configure the sound events that are associated with the keyboard.

You can customize the settings for the Keyboard preference tool in the following
functional areas:

� Keyboard
� Sound

Keyboard Settings
Use the Keyboard tabbed section to set general keyboard preferences. To start the
Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility
button.

FIGURE 9–3 Keyboard Tabbed Section in Keyboard Preference Tool

Table 9–3 lists the keyboard settings that you can configure.
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TABLE 9–3 Settings for Keyboard

Option Function

Keyboard repeats when
key is held down

Select this option to enable keyboard repeat. If keyboard repeat is
enabled, when you press-and-hold a key, the action associated
with the key is performed repeatedly. For example, if you
press-and-hold a character key, the character is typed repeatedly.

Delay Select the delay from the time you press a key to the time that the
action repeats.

Speed Select the speed at which the action is repeated.

Blinks in text boxes and
fields

Select this option to enable the cursor to blink in fields and text
boxes.

Speed Use the slider to specify the speed at which the cursor blinks in
fields and text boxes.

Sound Settings
Use the Sound tabbed section to set your preferences for keyboard sound.

FIGURE 9–4 Sound Tabbed Section in Keyboard Preference Tool

Some applications play a bell sound to indicate a keyboard input error. Use the
options in the Sound tabbed section to configure the bell sound. Table 9–4 lists the
keyboard sound settings that you can configure.
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TABLE 9–4 Settings for Keyboard Sound

Option Function

Off Select this option to disable the keyboard bell.

Beep Select this option to enable the keyboard bell.

Customizing Keyboard Shortcuts
A keyboard shortcut is a key or combination of keys that provides an alternative to
standard ways of performing an action.

Use the Keyboard Shortcuts preference tool to display the default keyboard shortcuts.
You can customize the default keyboard shortcuts to your requirements.

You can also create hot keys. Hot keys are keyboard shortcuts that start applications.

FIGURE 9–5 Keyboard Shortcuts Preference Tool

Table 9–5 lists the keyboard shortcut settings that you can customize.
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TABLE 9–5 Default Settings for Keyboard Shortcuts

Option Function

Text editing shortcuts Select one of the following settings:
� Default: Use this setting for standard shortcut keys.
� Emacs: Use this setting for Emacs shortcut keys.

Desktop shortcuts This table lists actions and the shortcut keys that are
associated with each action.

To change the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press the keys that you want to associate with the
action.

To disable the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press Back Space.

Custom Shortcuts To add a hot key, perform the following steps:
1. Click New. A Custom Binding dialog is displayed.

Enter the command to associate with the hot key in the
New Command field. Alternatively, to browse for the
command, click on the Browse button. When you have
selected the command, click OK. The command is
added to the Custom Shortcuts section of the Desktop
shortcuts table.

2. Click in the Shortcut column of the command in the
Custom bindings section of the Desktop shortcuts
table. Press the key or key combination that you want
to associate with the command.

To edit a hot key, select the hot key in the Custom
Shortcuts section of the Desktop shortcuts table, then click
Edit. Edit the command in the Custom Binding dialog.

To remove a hot key, select the hot key in the Custom
Shortcuts section of the Desktop shortcuts table, then click
Delete.

Customizing Menus and Toolbars in
Applications
You can use the Menus & Toolbars preference tool to customize the appearance of
menus, menubars, and toolbars for GNOME-compliant applications.
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FIGURE 9–6 Menus and Toolbars Preference Tool

Table 9–6 lists the menu and toolbar settings that you can customize for
GNOME-compliant applications.

TABLE 9–6 Settings for Customizing Applications

Option Function

Button Labels Choose one of the following options to specify what to display on
the toolbars in your GNOME-compliant applications:
� Text Below Icons: Select this option to display toolbars with text

as well as an icon on each button.
� Text Beside Icons: Select this option to display toolbars with an

icon only on each button, and with text on the most important
buttons.

� Icons Only: Select this option to display toolbars with an icon
only on each button.

� Text Only: Select this option to display toolbars with text only
on each button.

Toolbars can be
detached and moved
around

Select this option if you want to move toolbars from application
windows to any location on the screen. If you select this option,
handles are displayed on the left side of the toolbars in your
applications. To move a toolbar, click-and-hold on the handle, then
drag the toolbar to the new location.

Show icons in menus Select this option to display an icon beside each item in a menu.
Some menu items do not have an icon.
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Configuring Mouse Settings
Use the Mouse preference tool to configure your mouse for right-hand use or for
left-hand use. You can also specify the speed and sensitivity of mouse movement.

You can customize the settings for the Mouse preference tool in the following
functional areas:

� Buttons
� Cursors
� Motion

Buttons Settings
Use the Buttons tabbed section to specify whether the mouse buttons are configured
for left-hand use. You can also specify the delay between clicks for a double-click.

FIGURE 9–7 Buttons Tabbed Section in the Mouse Preference Tool

Table 9–7 lists the mouse button settings that you can configure.
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TABLE 9–7 Settings for Mouse Buttons

Option Function

Left-handed mouse Select this option to configure your mouse for left-hand use.
When you configure your mouse for left-hand use, the functions
of the left mouse button and the right mouse button are swapped.

Delay Use the slider to specify the amount of time that can pass between
clicks when you double-click. If the interval between the first and
second clicks exceeds the time that is specified here, the action is
not interpreted as a double-click.

Pointer Settings
Use the Cursors tabbed section to set your mouse pointer preferences.

FIGURE 9–8 Cursors Tabbed Section in the Mouse Preference Tool

Table 9–8 lists the mouse pointer settings that you can configure.

TABLE 9–8 Settings for Mouse Pointers

Option Function

Cursor Theme Select the mouse pointer theme that you
require from the list box.
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TABLE 9–8 Settings for Mouse Pointers (Continued)
Option Function

Show position of cursor when the Control
key is pressed

Select this option to enable a mouse pointer
animation when you press and release Ctrl.
This feature can assist you to locate the mouse
pointer.

Motion Settings
Use the Motion tabbed section to set your preferences for mouse movement.

FIGURE 9–9 Motion Tabbed Section in the Mouse Preference Tool

Table 9–9 lists the mouse motion settings that you can configure.

TABLE 9–9 Settings for Mouse Motion

Setting Function

Acceleration Use the slider to specify the speed at which your mouse pointer
moves on your screen when you move your mouse.

Sensitivity Use the slider to specify how sensitive your mouse pointer is to
movements of your mouse.

Threshold Use the slider to specify the distance that you must move an item
before the move action is interpreted as a drag-and-drop action.
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Configuring Network Proxy Settings
The Network Proxy preference tool enables you to configure how your system
connects to networks. You can configure the desktop environment to connect to a
proxy server, and specify the details of the proxy server. A proxy server is a server that
intercepts requests to another server, and fulfills the request itself, if it can. You can
enter the Domain Name Service (DNS) name or the Internet Protocol (IP) address of
the proxy server. A DNS name is a unique alphabetic identifier for a computer on a
network. An IP address is a unique numeric identifier for a computer on a network.

FIGURE 9–10 Network Proxy Preference Tool

Table 9–10 lists the network proxy settings that you can configure.

TABLE 9–10 Network Proxy Settings

Option Function

Use HTTP Proxy Select this option to use a proxy server for the HTTP service.

Location Enter the DNS name, or the IP address of the proxy server
to use when you request a HTTP service.

Port Enter the port number of the HTTP service on the proxy
server.

Proxy requires username and
password

Select this option if the proxy server requires a username
and password.

Save username and password to
disk

Select this option to save the username and password.

Username Enter your username for the proxy server.

Password Enter your password for the proxy server.
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Setting Screensaver Preferences
A screensaver is an application that you can use to replace the image on your screen
when the screen is not in use. You can use screensavers in the following ways:

� Activate after a specified period of idle time.
� Activate when you lock your screen.
� Manage power used by your monitor when your system is idle.

You can customize the settings for the Mouse preference tool in the following
functional areas:

� Display Modes
� Advanced

Display Modes Settings
Use the Display Modes tabbed section to set display mode preferences.

FIGURE 9–11 Display Modes Tabbed Section in the Screensaver Preference Tool

Table 9–11 lists the display mode settings that you can configure.
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TABLE 9–11 Settings for Screensaver Display Mode

Setting Function

Mode Use the drop-down list to specify the behavior of the
screensaver application. Select from the following options:
� Disable Screen Saver: Select this option if you do not

want to use the screensaver application.
� Blank Screen Only: Select this option if you want your

screen to become blank when your screen locks.
� Only One Screen Saver: Select this option if you want

to display a single screensaver display from the display
list when your screen locks.

� Random Screen Saver: Select this option if you want to
display a random selection of screensaver displays from
the screensaver display list when your screen locks.

Display list Select the screensaver display that you require from the list.

Blank After Specify how long to wait after the last use of the mouse or
keyboard, to activate the screensaver.

Cycle After Specify how long to show a particular screensaver display
before the next display.

Lock Screen After Select this option if you want the screen to lock after the
screensaver is activated. Use the spin box to specify the
delay between the activation of the screensaver and when
the screen locks.

Preview Click on this button to preview the screensaver display that
is selected in the screensaver display list. To stop the
preview, press any key or click a mouse button.

Settings Click on this button to display the options for the
screensaver display that is selected in the screensaver
display list.

Advanced Settings
Use the Advanced tabbed section to set advanced screensaver preferences.
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FIGURE 9–12 Advanced Tabbed Section in the Screensaver Preference Tool

Table 9–12 lists the advanced screensaver settings that you can configure.

TABLE 9–12 Advanced Screensaver Settings

Setting Function

Grab Desktop Images Some screensavers can take a screenshot of your screen,
then manipulate the screenshot to create your
screensaver display. Select this option to enable
screensavers to take a screenshot of your screen.

Grab Video Frames Some screensavers can capture a frame of video, then
manipulate the captured image to create your
screensaver display. If your system has a video capture
card, select this option to enable screensavers to capture
a frame of video.

Choose Random Image Select this option to enable screensavers to use images
from a directory that you select. Type the path for the
directory in the field. Alternatively, click Browse to
display a dialog from which you can select a directory.

Verbose Dialognostics Select this option if you want to display screensaver
diagnostic information.

Display Subprocess Errors Select this option if you want to display errors related
to screensaver subprocesses on screen.

Display Splash Screen at Startup Select this option to if you want Xscreensaver to
display a splash dialog when Xscreensaver starts.
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TABLE 9–12 Advanced Screensaver Settings (Continued)
Setting Function

Power Management Enabled Select this option to enable power management of your
monitor. Power management can reduce energy
consumption by your monitor when you are not using
the monitor.

Standby After Specify how long to wait to put the monitor in standby
mode. When the monitor is in standby mode, the
screen is black.

Suspend After Specify how long to wait to put the monitor in
power-saving mode.

Off After Specify how long to wait to switch off monitor.

Install Colormap Select this option to install a private colormap when the
screensaver is active. Use of a private colormap might
improve the quality of the color in particular
screensaver displays.

Fade to Black When Blanking Select this option if you want your display to fade to
black when the screensaver activates.

Fade from Black When Unblanking Select this option if you want your display to fade from
black to the screen contents when the screensaver stops.

Fade Duration Specify how long to take to fade to black when the
screensaver activates.

Setting Sound Preferences
The Sound preference tool enables you to control when the GNOME sound server
starts. You can also specify which sounds to play when particular events occur.

You can customize the settings for the Sound preference tool in the following
functional areas:

� General
� Sound Events

General Settings
Use the General tabbed section of the Sound preference tool to specify when to launch
the GNOME sound server. You can also enable sound event functions.
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FIGURE 9–13 General Tabbed Section in the Sound Preference Tool

Table 9–13 lists the general sound settings that you can configure.

TABLE 9–13 Settings for Sound

Option Function

Enable sound server
startup

Select this option to start the GNOME sound server when you
start a GNOME session. When the sound server is active, the
desktop environment can play sounds.

Sounds for events Select this option to play sounds when particular events occur in
your desktop environment . You can select this option only if the
Enable sound server startup option is selected.

Sound Event Settings
Use the Sound Events tabbed section of the Sound preference tool to associate
particular sounds with particular events.

Note – You must select the Enable sound server startup option, and the Sounds for
events option before you can access the Sound Events tabbed section.
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FIGURE 9–14 Sound Events Tabbed Section in the Sound Preference Tool

Table 9–14 lists the sound events settings that you can configure.

TABLE 9–14 Settings for Sound Events

Option Function

Sounds table Use the Sounds table to associate particular sounds with
particular events.

The Event column displays a hierarchical list of events that can
occur. To expand a category of events, click on the right arrow
beside a category of events.

The File to play column lists the sound file that plays when the
event occurs.

Play Click on this button to play the sound file that is associated with
the selected event.

Sound file drop-down
combination box, Browse

To associate a sound with an event, select the event in the Sounds
table. Enter the name of the sound file that you want to associate
with the selected event in the drop-down combination box.
Alternatively, click Browse to display a Select sound file dialog.
Use the dialog to specify the sound file that you want to associate
with the selected event.

Note – You can only associate sound files in .wav format with
events.
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Setting Themes in the Desktop
Environment
Use the Theme preference tool to select a theme for your desktop environment and for
your window frames. You can customize the settings for the Theme preference tool in
the following functional areas:

� Widget Theme
� Window Frames

The desktop environment theme and the window frame theme are not the only
themes that determine the appearance of your desktop environment. For example,
Nautilus includes themes that you can use to change the look-and-feel of the Nautilus
windows and the desktop.

Desktop Environment Theme Settings
Use the Widget Theme tabbed section of the Theme preference tool to select a theme
for your desktop environment. Your desktop environment theme specifies the visual
appearance of your panels, menus, and applets. The desktop environment theme also
specifies the appearance of GNOME-compliant application interface items. For
example, the theme affects the appearance of buttons, scrollbars, check boxes, and so
on.

You can choose from the list of available themes, or you can install new themes. The
list of available desktop environment themes includes several themes for users with
accessibility requirements.
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FIGURE 9–15 Widget Theme Tabbed Section in the Theme Preference Tool

Table 9–15 lists the desktop environment theme settings that you can configure.

TABLE 9–15 Settings for Desktop Environment Themes

Option Function

Available themes Select the theme that you require from the list box.

Install new theme You can add a theme to the list of available themes. The
new theme must be an uncompressed folder.

To add a theme to the list of available themes, click on
the Install new theme button. A dialog is displayed.
Enter the location of the theme folder in the drop-down
combination box. Alternatively, to browse for the folder,
click on the Browse button. When you have selected the
folder, click OK.

You can find many GTK themes on the Internet.

Go to theme folder Click on this button to open a file manager window on
the default theme folder. You can delete themes from
the file manager window.

Window Frame Settings
Use the Window Frames tabbed section of the Theme preference tool to select a theme
for your window frames. You can choose from the list of available themes, or you can
install new themes. The list of available window frame themes includes several
themes for users with accessibility requirements.
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FIGURE 9–16 Window Frames Tabbed Section in the Theme Preference Tool

Table 9–16 lists the window frame theme settings that you can configure.

TABLE 9–16 Settings for Window Frame Themes

Option Function

Available themes Select the theme that you require from the list box.

Install new theme You can add a theme to the list of available themes. The
new theme must be an uncompressed folder.

To add a theme to the list of available themes, click on
the Install new theme button. A dialog is displayed.
Enter the location of the theme folder in the drop-down
combination box. Alternatively, to browse for the folder,
click on the Browse button. When you have selected the
folder, click OK.

Go to theme folder Click on this button to open a file manager window on
the default theme folder. You can delete themes from
the file manager window.

Customizing Window Focus
Use the Window Focus preference tool to customize window focus behavior for your
desktop environment.
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FIGURE 9–17 Window Focus Preference Tool

Table 9–17 lists the window focus settings that you can customize.

TABLE 9–17 Settings for Window Focus

Option Function

Click to give focus Select this option to give focus to a window when you click on the
window. The window retains focus until you click on another
window.

Point to give focus Select this option to give focus to a window when you point to the
window. The window retains focus until you point to another
window.

Raise window on focus Select this option if you want your windows to be raised when the
windows receive focus.
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CHAPTER 10

Using the Advanced Preference Tools

The Advanced preference tools enable you to customize the behavior and appearance
of your applications, panels, and other user interface items. You can use the Advanced
preference tools to configure file types, your default applications, and your panels.
You can also use the Advanced tools to customize your sessions and startup
programs. This chapter describes how to use the Advanced tools to customize your
desktop environment.

� “Opening an Advanced Preference Tool” on page 187
� “Configuring a CD Database” on page 188
� “Configuring File Types and Programs” on page 190
� “Customizing Your Panels” on page 193
� “Choosing Your Preferred Applications” on page 194
� “Configuring Sessions” on page 197

Opening an Advanced Preference Tool
You can open an Advanced preference tool in either of the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences → Advanced. Choose the tool that
you require from the submenu. The dialog for the tool is displayed.

� From the Start Here location

Open a Nautilus window, then choose Go → Start Here. Alternatively, double-click
on the Start Here object on the desktop. The Start Here location is displayed.
Double-click on the Desktop Preferences object in the Nautilus window, then
double-click on the Advanced folder. The Advanced preference tools are
displayed.
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Double-click on the tool that you require. The dialog for the tool is displayed.

Configuring a CD Database
The CD Database preference tool enables you to configure a CD database that your
system can query. A CD database contains information about CDs, such as the name of
the artist, the title, and the track list. When an application plays a CD, the application
can query the CD database about the CD, then display the information.
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FIGURE 10–1 CD Database Preference Tool

Table 10–1 describes the elements on the CD Database preference tool.

TABLE 10–1 Settings for CD Database

Element Description

Send no info Select this option if you do not want to send any information to the
CD database server.

Send real info Select this option to send your name and hostname information to
the CD database server.

Send other info Select this option to send another name and hostname to the CD
database server. Enter the name in the Name field. Enter the
hostname in the Hostname field.

FreeDB round robin
server

FreeDB is a CD database. The FreeDB round robin server is a
load-sharing configuration of FreeDB servers. Select this option to
access the FreeDB CD database from this server.

Other FreeDB server Select this option to access the FreeDB CD database from another
server. Select the server that you require from the server table.

Update server list Click on this button to update the list of available FreeDB servers in
the server table.
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TABLE 10–1 Settings for CD Database (Continued)
Element Description

Other server Select this option to use another CD database. Enter the name of the
server on which the database resides in the Hostname field. Enter
the port number on which you can access the database in the Port
field.

Configuring File Types and Programs
Use the File Types and Programs preference tool to specify how files of various types
are created, displayed, and edited. For example, you can specify that if a file is a plain
text file, the file is launched in a text editor.

Nautilus and other GNOME applications check the contents of a file to determine the
type of a file. If the first lines do not determine the type of the file, then the application
checks the file extension.

FIGURE 10–2 File Types and Programs Preference Tool

Table 10–2 describes the elements on the File Types and Programs preference tool.
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TABLE 10–2 Elements on File Types and Programs Preference Tool

Element Description

Table To view the contents of a category of file types, click on the right
arrow next to the category name. The category expands, and
displays a description of each file type, and the file extension that is
associated with the file type.

To select a file type that you want to work with, click on the file
type.

Add File Type Click on this button to add a file type. For more information, see
“To Add a File Type” on page 191.

Add Service Click on this button to add a service. For more information, see “To
Add a Service” on page 192.

Edit To edit a file type, a service, or a file type category, select the item
that you want to edit, then click Edit.

Remove To remove a file type or a service, select the item that you want to
remove, then click Remove.

To Add a File Type
To add a file type, perform the following steps:

1. Choose Applications → Desktop Preferences → Advanced → File Types and
Programs to start the File Types and Programs preference tool.

2. Click on the Add file type button. The Add file type dialog is displayed.

3. Enter the properties of the file type in the dialog. The following table describes the
dialog elements on the Add file type dialog:

Option Function

No Icon Choose an icon to represent the file type. To choose an
icon, click on the No Icon button. An icon selector
dialog is displayed. Choose an icon from the dialog.
Alternatively, to choose an icon from another directory,
click Browse. When you choose an icon, click OK.

Description Type a description of the file type.

MIME Type Enter the MIME type for this type of file.
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Option Function

Category Enter the category to which you want the file type to
belong in the File Types and Programs preference tool.
Click on the Choose to choose a category from the
Choose a file category dialog.

Filename Extensions Enter the filename extensions to associate with the file
type. Enter a filename extension in the field on the left
side, then press Return. To delete a filename extension,
select the filename extension in the field on the right
side, then click on the Remove button.

Viewer Component Information to be supplied in a future release.

Default action Information to be supplied in a future release.

Program to Run Specify a program to associate with the file type. Enter
the command to start the program in this field.
Alternatively, to choose a command that you entered
previously, click the down arrow button, then choose
the command to run.

You can also use the Browse button to choose a
command to run.

Run in Terminal Select this option to run the program in a terminal
window. Choose this option for a program that does not
create a window in which to run.

4. Click OK.

To Add a Service
To add a service, perform the following steps:

1. Choose Applications → Desktop Preferences → Advanced → File Types and
Programs to start the File Types and Programs preference tool.

2. Click on the Add service button. The Add service dialog is displayed.

3. Enter the properties of the service in the dialog. The following table describes the
dialog elements on the Add service dialog:

Option Function

Description Type a description of the service.

Protocol Enter the protocol for the service.

192 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



Option Function

Program Specify the program to associate with the service.
Enter the command to start the program in this
field. Alternatively, to choose a command that you
entered previously, click the down arrow button,
then choose the command to run.

You can also use the Browse button to choose a
command to run.

Run in Terminal Select this option to run the program in a terminal
window. Choose this option for a program that does
not create a window in which to run.

4. Click OK.

Customizing Your Panels
The Panel preference tool enables you to configure the behavior of panels. Any
changes that you make with the Panel preference tool affect all of your panels.

FIGURE 10–3 Panel Preference Tool

TABLE 10–3 Settings for Panels

Setting Function

Close drawer when launcher is clicked Select this option if you want a drawer on a
panel to close when you choose a launcher in
the drawer.

Animation Select this option if you want your panels to
show and to hide in an animated style.
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TABLE 10–3 Settings for Panels (Continued)
Setting Function

Animation speed Select the speed of the panel animation from
the drop-down list.

Choosing Your Preferred Applications
Use the Preferred Applications preference tool to specify the applications that you
want the desktop environment to use when the desktop environment starts an
application for you. For example, you can specify Xterm as your preferred terminal
application. When you open the Desktop menu then choose New Terminal, Xterm
starts.

You can customize the settings for the Preferred Applications preference tool in the
following functional areas.

� Web Browser
� Text Editor
� Terminal

Web Browser Settings
Use the Web Browser tabbed section to configure your preferred web browser. The
preferred web browser opens when you click on a URL. For example, the preferred
web browser opens when you select a URL in an application, or when you select a
URL launcher on the desktop.

FIGURE 10–4 Web Browser Tabbed Section in the Preferred Applications Preference Tool

Table 10–4 lists the preferred web browser settings that you can configure.

194 GNOME 2.0 Desktop for the Solaris Operating Environment User Guide • July 2003



TABLE 10–4 Settings for Preferred Web Browser

Option Function

Select a Web Browser Select this option if you want to use a standard web browser. Use
the drop-down combination box to select your preferred web
browser.

Custom Web Browser Select this option if you want to use a custom web browser.

Command Enter the command to execute to start the custom web browser. To
enable the browser to display a URL that you click on, include
“%s” after the command.

Start in Terminal Select this option to run the command in a terminal window. Select
this option for a browser that does not create a window in which to
run.

Text Editor Settings
Use the Text Editor tabbed section to configure your preferred text editor.

FIGURE 10–5 Text Editor Tabbed Section in the Preferred Applications Preference Tool

Table 10–5 lists the preferred text editor settings that you can configure.

TABLE 10–5 Settings for Preferred Text Editor

Option Function

Select an Editor Select this option if you want to use a standard text editor. Use the
drop-down combination box to specify your preferred text editor.
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TABLE 10–5 Settings for Preferred Text Editor (Continued)
Option Function

Custom Editor Select this option if you want to use a custom text editor. A Custom
Editor Properties dialog is displayed.
� Name: Type the name of the custom text editor.
� Command: Enter the command to execute to start the custom

text editor.
� This application can open multiple files: Select this option if

the default text editor can open multiple files.
� This application needs to be run in a shell: Select this option to

run the command in a terminal window. Select this option for
an editor that does not create a window in which to run.

After you specify a custom text editor, you can click on the
Properties button to display the Custom Editor Properties dialog.
You can use the dialog to modify the properties of the custom text
editor.

Use this editor to open
text files in the file
manager

Select this option if you want the file manager to start the custom
text editor to display text files.

Terminal Settings
Use the Terminal tabbed section to configure your preferred terminal.

FIGURE 10–6 Terminal Tabbed Section in the Preferred Applications Preference Tool

Table 10–6 lists the preferred terminal settings that you can configure.
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TABLE 10–6 Settings for Preferred Terminal

Option Function

Select a Terminal Select this option if you want to use a standard terminal. Use the
drop-down combination box to specify your preferred terminal.

Custom Terminal Select this option if you want to use a custom terminal.

Command Enter the command to execute to start the custom terminal.

Exec Flag Enter the exec option to use with the command.

Configuring Sessions
The Sessions preference tool enables you to manage your sessions. You can set session
preferences, and specify which applications to start when you start a session. You can
configure sessions to save the state of applications in your desktop environment, and
to restore the state when you start another session. You can also use this preference
tool to manage multiple GNOME sessions.

You can customize the settings for sessions and startup applications in the following
functional areas:

� Session Options
� Current Session
� Startup Programs

Setting Session Options
Use the Session Options tabbed section to manage multiple sessions, and to set
preferences for the current session.
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FIGURE 10–7 Session Options Tabbed Section in the Sessions Preference Tool

Table 10–7 lists the session options settings that you can configure.

TABLE 10–7 Settings for Session Options

Option Function

Show splash screen on
login

Select this option to display a splash screen when you start a
session.

Prompt on logout Select this option to display a confirmation dialog when you end a
session.

Automatically save
changes to session

Select this option if you want the session manager to save the
current state of your session. The session manager saves the
session-managed applications that are open, and the settings
associated with the session-managed applications. The next time
that you start a session, the applications start automatically, with
the saved settings.

If you do not select this option, when you end you session the
Logout Confirmation dialog displays a Save current setup option.

Sessions Use this area of the dialog to manage multiple sessions in the
desktop environment, as follows:
� To create a new session, click on the Add button. The Add a

new session dialog is displayed. Use this dialog to specify a
name for your session.

� To change the name of a session, select the session in the
Choose Current Session table. Click on the Edit button. The
Edit session name dialog is displayed. Type a new name for
your session.

� To delete a session, select the session in the Choose Current
Session table. Click on the Delete button.
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Setting Session Properties
Use the Current Session tabbed section to specify startup order values, and to choose
restart styles for the session-managed applications in your current session.

FIGURE 10–8 Current Session Tabbed Section in the Sessions Preference Tool

Table 10–8 lists the session properties that you can configure.

TABLE 10–8 Session Properties

Option Function

Order The Order setting specifies the order in which the session manager
starts session-managed startup applications. The session manager
starts applications with lower order values first. The default value is
50.

To specify the startup order of an application, select the application
in the table. Use the Order spin box to specify the startup order
value.

Chapter 10 • Using the Advanced Preference Tools 199



TABLE 10–8 Session Properties (Continued)
Option Function

Style The Style setting determines the restart style of an application. To
select a restart style for an application, select the application in the
table, then choose one of the following styles:
� Normal

Starts automatically when you start a GNOME session. Use the
kill command to terminate applications with this restart style
during a session.

� Restart
Restarts automatically whenever you close or terminate the
application. Choose this style for an application if the
application must run continuously during your session. To
terminate an application with this restart style, select the
application in the table, then click on the Remove button.

� Trash
Does not start when you start a GNOME session.

� Settings
Starts automatically when you start a session. Applications with
this style usually have a low startup order, and store your
configuration settings for GNOME and session-managed
applications.

Remove Click on the Remove button to delete the selected application from
the list. The application is removed from the session manager, and
closed. Application that you delete are not started the next time that
you start a session.

Apply Click on the Apply button to apply changes to the startup order and
the restart style.

Configuring Startup Applications
Use the Startup Programs tabbed section of the Sessions preference tool to specify
non-session-managed startup applications. Startup applications are applications that
start automatically when you start a session. You specify the commands that run the
non-session-managed applications in the Startup Programs tabbed section. The
commands execute automatically when you log in.

You can also start session-managed applications automatically. For more information,
see “Setting Session Options” on page 197.
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FIGURE 10–9 Startup Programs Tabbed Section in the Sessions Preference Tool

Table 10–9 lists the startup applications settings that you can configure.

TABLE 10–9 Settings for Startup Programs

Option Function

Additional startup
programs

Use this table to manage non-session-managed startup applications
as follows:
� To add a startup application, click on the Add button. The Add

Startup Program dialog is displayed. Enter the command to
start the application in the Startup Command field.
If you specify more than one startup application, use the
Priority spin box to specify the startup order of the each
application. The startup order is the order in which you want
the startup applications to start.

� To edit a startup application, select the startup application, then
click on the Edit button. The Edit Startup Program dialog is
displayed. Use the dialog to modify the command and the
startup order for the startup application.

� To delete a startup application, select the startup application,
then click on the Delete button.
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CHAPTER 11

Using the Accessibility Preference
Tools

This chapter describes how to use the Accessibility preference tools to customize the
accessibility features of your desktop environment.

� “Opening an Accessibility Tool” on page 203
� “Configuring Keyboard Accessibility Options” on page 204

Opening an Accessibility Tool
You can open an Accessibility preference tool in the following ways:

� From the Desktop Preferences menu

Choose Applications → Desktop Preferences → Accessibility. Choose the preference
tool that you require from the submenu. The dialog for the tool is displayed.

� From the Start Here location

Open a Nautilus window, then choose Go → Start Here. Alternatively, double-click
on the Start Here object on the desktop. The Start Here location is displayed.
Double-click on the Desktop Preferences object in the Nautilus window, then
double-click on the Accessibility folder.
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Configuring Keyboard Accessibility
Options
Use the Keyboard accessibility preference tool to set the keyboard accessibility
preferences. The Keyboard accessibility preference tool is also known as AccessX.
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FIGURE 11–1 Keyboard Accessibility Preference Tool

Table 11–1 lists the keyboard accessibility settings that you can modify.

TABLE 11–1 Keyboard Accessibility Settings

Option Function

Enable keyboard
accessibility

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.

Beep when
enabling/disabling
keyboard accessibility
features

Select this option for an audible indication when a feature such as
sticky keys or slow keys is activated, or deactivated.
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TABLE 11–1 Keyboard Accessibility Settings (Continued)
Option Function

Disable if unused for Select this option to deactivate keyboard accessibility preferences if
the keyboard is not used for a specified period of time. Use the slider
to specify the number of seconds of keyboard idle time required
before the system disables the keyboard accessibility preferences.
When the specified number of seconds elapses, the following
keyboard accessibility preferences are disabled:
� Bounce keys
� Mouse keys
� Slow keys
� Sticky keys
� Toggle keys

Enable Mouse Keys Select this option to make the numeric keypad emulate mouse
actions. You can specify the following mouse key settings:
� Maximum pointer speed: Use this setting to specify the

maximum speed that the pointer moves across the screen.
� Time to accelerate to maximum speed: Use this setting to specify

the duration of the acceleration time of the pointer.
� Start moving this long after keypress: Use this setting to specify

the period of time that must pass after a keypress before the
pointer moves.

Enable Slow Keys Select this option to control the period of time that you must
press-and-hold a key before acceptance. You can specify the following
slow keys settings:
� Only accept keypress after: Use this setting to specify the period

of time that you must press-and-hold a key before acceptance.
� Beep when key is pressed: Select this option for an audible

indication of a keypress.
� Beep when key is accepted: Select this option for an audible

indication of key acceptance.
� Beep when key is rejected: Select this option for an audible

indication of key rejection.

Enable Bounce Keys Select this option to accept a key input and to control the key repeat
characteristics of the keyboard. You can specify the following bounce
keys settings:
� Ignore keypresses within: Use this setting to specify the interval

to wait after the first keypress before the automatic repeat of a
pressed key.

� Beep when key is rejected: Select this option for an audible
indication of key rejection.
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TABLE 11–1 Keyboard Accessibility Settings (Continued)
Option Function

Enable Sticky Keys Select this option to perform multiple simultaneous keypress
operations by pressing the keys in sequence. You can specify the
following sticky keys settings:
� Beep when modifier is pressed: Select this option for an audible

indication when you press a modifier key.
� Turn off Sticky Keys when two keys pressed simultaneously:

Select this option to specify that when you press two keys
simultaneously, you can no longer press keys in sequence to
perform multiple simultaneous keypresses.

Toggle and Repeat
Keys

Select this option for an audible indication of a toggle keypress. You
hear one beep when a toggle key is turned on. You hear two beeps
when a toggle key is turned off.

Testing Area The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the test
area to test the effect of your settings.

Import CDE AccessX
file

Click on this button to import a CDE AccessX configuration file.

For more information on configuring keyboard accessibility preferences, see GNOME
2.0 Desktop for the Solaris Operating Environment Accessibility Guide.
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Glossary

applet An applet is a small, interactive application that resides within a panel,
for example the CD Player. Each applet has a simple user interface that
you can operate with the mouse or keyboard.

desktop The part of the desktop environment where there are no interface
graphical items, such as panels and windows.

desktop background The image or color that is applied to your desktop.

desktop object An icon on your desktop that you can use to open your files, folders,
and applications. You can use desktop objects to provide convenient
access to files, folders, and applications that you use frequently.

desktop environment A windows-based environment for users. The desktop environment is
the sum of all the parts of your working environment. The desktop
environment includes all of your panels and windows, the desktop,
and all of your workspaces.

DNS name A unique alphabetic identifier for a computer on a network.

drawer A drawer is a sliding extension to a panel that you can open or close
from a drawer icon.

format To format media is to prepare the media for use with a particular file
system. When you format media, you overwrite any existing
information on the media.

GNOME-compliant
application

An application that uses the standard GNOME programming libraries
is called a GNOME-compliant application. For example, Nautilus and
gedit are GNOME-compliant applications.

hot key Hot keys are keyboard shortcuts that start applications.

inode A data structure that contains information about individual files in
UNIX file systems. Each file has one inode. An inode contains the
node, type, owner, and location of a file.

IP address A unique numeric identifier for a computer on a network.
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keyboard shortcut A keyboard shortcut is a key or combination of keys that provides an
alternative to standard ways of performing an action.

launcher A launcher starts a particular application, executes a command, or
opens a file. A launcher can reside in a panel or in a menu.

menubar A menubar is a bar at the top of an application window that contains
the menus for the application.

MIME type A Multipurpose Internet Mail Extension (MIME) type identifies the
format of a file. The MIME type enables applications to read the file.
For example, an email application can use the image/png MIME type
to detect that a Portable Networks Graphic (PNG) file is attached to an
email.

mount To mount is to make a file system available for access. When you
mount a file system, the file system is attached as a subdirectory to
your file system.

pane A pane is a subdivision of a window. For example, the Nautilus
window contains a side pane and a view pane.

preference tool A dedicated software tool that controls a particular part of the
behavior of the desktop environment.

shortcut keys Shortcut keys are keystrokes that provide a quick way to perform an
action.

slice A partition of a disk. You can create slices on your Zip and Jaz media.
An object for each slice appears on the desktop.

stacking order The stacking order is the order in which windows are stacked on top
of each other on your screen.

statusbar A statusbar is a bar at the bottom of a window that provides
information about the current state of what you are viewing in the
window.

symbolic link A special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the
file or folder to which the symbolic link points.

toolbar A toolbar is a bar that contains buttons for the most commonly-used
commands in an application. Typically, a toolbar appears under a
menubar.

Uniform Resource
Locator

A Uniform Resource Locator (URL) is the address of a particular
location on the Web.

view A Nautilus component that enables you to display a folder in a
particular way. For example, Nautilus contains an icon view which
enables you to display the contents of a folder as icons. Nautilus also
contains a list view which enables you to display the contents of a
folder as a list.
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viewer component A Nautilus component that enables you to display a particular type of
file in the view pane. A viewer component might add menu items that
are relevant to the file type to the Nautilus menus. A viewer
component might also enable you to use the Nautilus zoom buttons to
change the size of the item in the view pane.

workspace A workspace is a discrete space in your desktop environment in which
you can work.
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Index

A
access keys, 24
accessibility

bounce keys, 206
configuring keyboard, 204
mouse keys, 206
slow keys, 206
sticky keys, 207
toggle keys, 207

AccessX, See preference tools, Keyboard
Accessibility

applets
adding to panel, 62
getting help, 43
introduction, 61
modifying preferences, 62
overview, 31
selecting, 62
Window List, 89
Workspace Switcher, 90

applications
help, 44
overview, 42

B
backgrounds

adding colors, 140
adding patterns, 140
changing desktop background, 158
changing screen component, 139
customizing desktop background, 164

basic skills
keyboard skills, 21
mouse skills, 17
using windows, 25

bottom edge panel
default contents, 52
introduction, 52

C
closing windows, 93

D
default applications, See preferred applications
desktop

adding a file or folder to, 154
adding launchers, 153
adding symbolic links, 154
changing pattern or color of

background, 158
copying a file or folder to, 155
creating a folder on, 155
customizing background, 164
deleting an object from, 155
desktop objects, 151
introduction, 149
moving a file or folder to, 154
opening objects, 153
overview, 39
preferences, 132
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desktop (Continued)
removing an object from, 155
selecting objects, 152
using Desktop menu, 157
using Trash, 155

desktop environment components,
introducing, 27

desktop environment preference tools, See
preference tools

Desktop menu
description, 157
illustration, 157

desktop objects
deleting, 155
files and folders, 154
launchers, 153
opening, 153
removing, 155
selecting, 152
symbolic links, 154

drawers
adding objects to, 69
adding to panel, 69
closing, 68
modifying properties, 69
opening, 68

E
emblems, See file manager
events, associating sounds with, 179

F
file manager

assigning actions to files, 127
bookmarks, 112
changing backgrounds, 139
changing permissions, 117
copying files and folders, 115
creating folders, 116
creating symbolic link, 117
customizing, 128
deleting files or folders, 116
displaying folders, 105
drag-and-drop, 113

file manager (Continued)
duplicating files and folders, 115
emblems

adding, 120
introduction, 102

executing default actions for files, 108
executing non-default actions for files, 108
executing other actions for files, 108
FTP sites

See FTP sites
Home location

See Home location
icon view

arranging files in, 124
illustration, 99
preferences, 134

icons
caption preferences, 135
introduction, 102
modifying, 120
stretching, 125

introduction, 97
list view

illustration, 122
preferences, 134

managing files and folders, 112
modifying actions, 127
modifying appearance of files and

folders, 120
moving files and folders, 114
navigating, 104
navigating history list, 110
opening files, 107
overview, 37
preferences

desktop, 132
icon and list views, 134
icon captions, 135
introduction, 128
new windows, 131
performance, 138
side pane, 137
theme, 130
Trash, 132
views, 129

renaming folders, 116
running scripts, 119
selecting files and folders, 113
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file manager (Continued)
side pane

introduction, 101
preferences, 137

Start Here location
See Start Here location

tabbed panes
History, 111
introduction, 102
Notes, 119
Tree, 105

Trash
See Trash

view pane
See view pane

viewing files in view pane, 107
views

choosing, 123
introduction, 122
modifying behavior, 125
preferences, 134

window components, showing and
hiding, 140

windows, 98
zooming in and out, 121

file types
adding, 191
configuring, 190
editing, 191

focus, giving to a window, 92
fonts

applications, 166
desktop, 166

FTP sites, accessing, 110

G
GNOME Menu

adding to panel, 80
introduction, 79
opening, 80

Gtk+ themes, See themes

H
help

applets, 43
applications, 44
desktop environment topics, 43
how to find, 43
starting help system, 43

Home location, displaying, 104
hot keys, configuring, 169

K
keyboard

basic skills, 21
configuring accessibility options, 204
configuring general preferences, 167
configuring sound preferences, 168

keyboard shortcuts, configuring, 169

L
language, starting session in different, 46
launchers

adding to panel, 63, 75
modifying properties, 67

Lock button, 46, 71
locking screen, 46, 71
Log Out button, 71
logging in, 46
logging out, 49

M
maximizing windows, 93
menu item popup menu

description, 74
illustration, 75

Menu Panel
default contents, 52
introduction, 51
window list icon, 52, 91
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menus
Actions menu, 76
adding, 81
adding launchers to, 81
adding to panel, 67, 75
Applications menu, 76
copying launchers to, 81
customizing, 80
deleting menu items, 82
Desktop menu, 157
editing menu items, 82
editing properties, 82
features, 74
GNOME Menu

See GNOME Menu
in applications, customizing

appearance, 170
introduction, 73
menu item popup menu, 74
overview, 33
Window Menu, 88

Metacity window manager, See window
manager

minimizing, windows, 92
mouse

action terminology, 19
actions, 18
basic skills, 17
button conventions, 17
configuring, 172
pointers, 19

moving windows, 94

N
Nautilus desktop, See desktop
Nautilus file manager, See file manager
network proxy, setting preferences, 175
notes, adding to folders, 119

P
panel object popup menu, illustration, 60
panel objects

adding, 59

panel objects (Continued)
applets

See applets
drawers

See drawers
interacting with, 59
launchers

See launchers
Lock button, 71
Log Out button, 71
menus, 67
modifying properties, 60
moving, 60
removing, 61

panels
adding new, 53
bottom edge panel

See bottom edge panel
changing background, 58
customizing behavior and appearance, 193
deleting, 58
hiding, 55
interacting with, 54
introduction, 51
managing, 53
Menu Panel

See Menu Panel
modifying properties, 55
moving, 54
overview, 30
panel objects

See panel objects
panes, resizing, 25
partitions, See slices
pointers, See mouse pointers
preference tools

Background, 164
CD Database, 188
File Types and Programs, 190
Font, 166
Keyboard, 167
Keyboard Accessibility, 204
Keyboard Shortcuts, 169
Menus & Toolbars, 170
Mouse, 172
Network Proxy, 175
overview, 41
Panel, 193
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preference tools (Continued)
Preferred Applications, 194
Screensaver, 176
Sessions, 47, 197
Sound, 179
Theme, 182
Window Focus, 184

preferences, file manager, See file manager
preferences

preferred applications
terminal, 196
text editor, 195
web browser, 194

proxy, setting preferences, 175

R
removable media

creating slices, 144
displaying contents, 141
displaying properties, 142
ejecting, 147
formatting, 143
introduction, 141
protecting, 146

resizing windows, 93
restoring, windows, 93
Run Program dialog, using, 77

S
screensaver, setting preferences, 176
screenshots, taking, 78
scripts, running from file manager, 119
services

adding, 192
editing, 191

sessions
browsing applications, 48
configuring screensaver, 176
different language, starting in, 46
ending, 49
locking screen, 46
logging in, 46
logging out, 49
login behavior, 47

sessions (Continued)
logout behavior, 47
managing, 47
preferences, 197
saving settings, 48
setting options, 197
setting properties, 199
starting, 45
using startup applications, 48

shading windows, 94
shortcut keys

application, 23
configuring, 169
desktop environment, 21
panel, 23
window, 22

side pane, See file manager
slices, removable media, 144
sound

associating events with sounds, 179
configuring keyboard preferences, 168
setting preferences, 179

sound server, 179
Start Here location

overview, 40
using, 109

startup applications
customizing, 197
non-session-managed, 48, 200
session-managed, 47, 198, 199

startup programs, See startup applications

T
tabbed panes, See file manager
tables, using, 25
terminal, preferred application, 196
text editor, preferred application, 195
themes

Nautilus, 130
setting desktop environment themes, 182
setting window frame themes, 182

toolbars, customizing appearance, 170
Trash

displaying, 118, 156
emptying, 118, 156
introduction, 117

Index 217



Trash (Continued)
moving files or folders to, 116
preferences, 132
using on desktop, 155

Tree tabbed pane, using, 105

V
view pane

introduction, 100
viewing files in, 107

viewer components, 100, 107, 122

W
web browser, preferred application, 194
Window List applet

grouping buttons, 90
introduction, 89
window status information, 89

window lists
Menu Panel, 91
Window List applet, 89

window manager, customizing, 184
windows

applets and menus for working with, 87
closing, 93
frame control elements, 86
frames, 86
giving focus to, 92
introduction, 83
manipulating, 92
maximizing, 93
minimizing, 92
moving, 94
moving to another workspace, 95
overview, 34
putting on all workspaces, 95
resizing, 93
resizing panes, 25
restoring, 93
setting frame themes, 182
shading, 94
themes, 86
types of, 84
using tables, 25

windows (Continued)
Window List applet

See Window List applet
window managers, 84
Window Menu, 88

workspaces
adding, 96
deleting, 96
introduction, 83
manipulating, 95
moving windows to, 95
naming, 96
overview, 36
specifying number of, 37
switching between, 36, 95
Workspace Switcher applet, 90

X
XScreenSaver, See screensaver
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