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About This Book

The Solstice AdminSuite 2.1 User’s Guide provides product overview, task, and
reference information for Solstice™ AdminSuite™ 2.1 (Motif® version), a suite of
graphical user interface tools used to perform system administration tasks in
the Solaris™ software environment.

Who Should Use This Book
This book is intended for experienced and junior administrators who need
information on using the Solstice AdminSuite software to perform
administrative tasks such as setting up and modifying users, groups, servers,
printers, clients, modems, or terminals.

This book assumes that you are familiar with the mouse-use terminology such
as Select (click on an item once) and Choose (click on a menu button and slide
the cursor to the item you would like to choose).

Before You Use This Product
To use this product, you should be familiar with UNIX® system software
concepts, the network configuration of your site, and your site policies for
security.
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How This Book Is Organized
This book has three parts:

• Part 1 – Solstice AdminSuite Overview
Provides overview information on the Solstice AdminSuite software.

• Part 2 – Using Solstice AdminSuite Tools
Provides task-specific information needed to use the Solstice AdminSuite
software.

• Part 3 – Solstice AdminSuite 2.1 Reference
Provides reference information about each tool’s commands, menu, and
windows.

What Typographic Changes Mean
The following table describes the typographic changes used in this book.

Table P-1 Typographic Conventions

Typeface or
Symbol Meaning Example

AaBbCc123 The names of commands,
files, and directories;
on-screen computer output

Edit your .login  file.
Use ls -a  to list all files.
machine_name% You have mail.

AaBbCc123 What you type, contrasted
with on-screen computer
output

machine_name% su
Password:

AaBbCc123 Command-line placeholder:
replace with a real name or
value

To delete a file, type rm filename.

AaBbCc123 Book titles, new words or
terms, or words to be
emphasized

Read Chapter 6 in User’s Guide.
These are called class options.
You must be root to do this.
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Shell Prompts in Command Examples
The following table shows the default system prompt and root prompt for the
C shell, Bourne shell, and Korn shell.

Table P-2 Shell Prompts

Shell Prompt

C shell prompt machine_name%

C shell superuser prompt machine_name#

Bourne shell and Korn shell
prompt

$

Bourne shell and Korn shell
superuser prompt

#
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Part 1 — Solstice AdminSuite Overview

This part provides an overview of the Solstice AdminSuite software and
contains these chapters.

Introduction
An introduction to the Solstice AdminSuite product.

Using Solstice AdminSuite in a Name Service Environment
Information on how to use the Solstice AdminSuite software in a name
service environment .

Security
Discussion on security issues and suggestions on how to use the Solstice
AdminSuite software in a manner that conforms to your site security
policies.

1

2

3
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 Introduction 1

Solstice AdminSuite is a collection of graphical user interfaces used to perform
administrative tasks such as managing users, groups, hosts, administrative
data in system files, printers, and serial port software.

This is a list of the overview information in this chapter.

When to Use Solstice AdminSuite page 2

Benefits of Solstice AdminSuite page 2

Solstice AdminSuite Applications page 3

Requirements for Using Solstice AdminSuite page 3

Starting Solstice AdminSuite page 5

Using Admin Help page 6
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When to Use Solstice AdminSuite
Solstice AdminSuite applications enable you to manage:

• Important system database files such as aliases  and netmasks

• User account information including tasks such as adding users, modifying
password aging features, and removing user account information

• Group information

• Terminal and modem setup

• Diskless and dataless client setup

• Print server and print client setup

These tasks can be done on local and remote systems if the right access has
been set up. See Chapter 2, “Using Solstice AdminSuite in a Name Service
Environment,” for information on controlling access to the Solstice AdminSuite
software.

Benefits of Solstice AdminSuite
Using the Solstice AdminSuite graphical user interface to perform the
administration tasks has these benefits:

• The application programs are faster than using numerous Solaris commands
to perform the same tasks.

• System files are updated automatically without the risk of making errors by
editing important system files manually.
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Solstice AdminSuite Applications
The Solstice AdminSuite software provides the applications listed in Table 1-1.

Requirements for Using Solstice AdminSuite
To use the Solstice AdminSuite software you must have:

• A bit-mapped display monitor – The Solstice AdminSuite software can be
used only on a system where the console is a bit-mapped screen such as a
standard display monitor that comes with a Sun® workstation.

If you want to perform administration tasks on a system with an ASCII
terminal as the console, use Solaris commands.

• OpenWindows™ software.

Table 1-1 Solstice AdminSuite Applications

This Application Helps You Manage ... Described In ...

Database Manager Network-related system files such as aliases  and
netmasks

Chapter 7, “Managing Network
Service Files with Database
Manager”

Group Manager UNIX group information Chapter 5, “Managing Users
With User Manager and Group
Manager”

Host Manager System information and server support for diskless and
dataless systems

Chapter 6, “Managing Server
and Client Support With Host
Manager”

Serial Port Manager Serial port software for terminals and modems Chapter 8, “Managing Terminals
and Modems with Serial Port
Manager”

User Account Manager User account information Chapter 5, “Managing Users
With User Manager and Group
Manager”

Printer Manager Printer software for print servers and clients Chapter 9, “Setting Up SunSoft
Print Client Software With
Printer Manager”
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• Root privilege or membership in the sysadmin group (group 14) and the
required access privileges for managing the NIS or NIS+ database. See
Chapter 2, “Using Solstice AdminSuite in a Name Service Environment,” for
more information.

You should use the Solstice AdminSuite software as a regular user who has
membership in the sysadmin group rather than as root.
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Starting Solstice AdminSuite
The Solstice Launcher is used to start the Solstice AdminSuite applications. Start
the Solstice Launcher from an OpenWindows or Motif CDE window as
follows:

You can also start the Solstice Launcher with the -display  option to remotely
display on a bit-mapped screen.

Launching Applications From the Solstice Launcher
• Click on an icon in the Launcher to start an application tool.

You can also use the Tab key to move from icon to icon, and press the Space
bar to start an application tool.

• Close the Launcher (and each application) to an icon by clicking on the
Window menu in the top left corner of each application’s main window.

See Chapter 4, “Using the Solstice Launcher,” for more information about
using the Launcher.

$ solstice &
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Using Admin Help
An important part of the Solstice AdminSuite software is a Help utility called
Admin Help. Admin Help provides detailed information about Solstice
AdminSuite applications and their functions.

• To access Admin Help from a Solstice AdminSuite application’s main
window, select “About xx Manager...” from the Help menu.
The Admin Help window for that application is displayed.

• To access the online help from a Solstice AdminSuite application’s command
window, click on the Help button.
The Admin Help window is displayed.

The titles displayed in the top window pane identify the list of topics available
for each level of help.

The text displayed in the bottom window pane describes information about
using the current menu or command.

Use the scrollbars to the right of each pane to scroll through the help
information displayed.
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On the left side of the Admin Help window are buttons used to find
information and navigate through the help system. The buttons are described
in Table 1-2.

Table 1-2 Admin Help Buttons

Button Use Notes

Topics Displays a list of overview
topics

Click on a title in the top window pane to
view the accompanying help text.

How To Displays a list of step-by-
step procedures

Click on a title in the top window pane to
view the accompanying help text.

Reference Displays a list of more
detailed information

Click on a title in the top window pane to
view the accompanying help text.

Previous Returns to the last
accessed help text

The help viewer automatically returns to
the previous help selection.

Done Exits the help system The Admin Help system is closed.



8 Solstice AdminSuite 2.1 User’s Guide—November 1995

1



9

Using Solstice AdminSuite in a
Name Service Environment 2

Solstice AdminSuite can be used in different name service environments. When
you use each application, you specify the name service environment data you
wish to modify with the application.

This is a list of the topics and step-by-step instructions in this chapter.

Selecting a Name Service Environment page 10

Using Solstice AdminSuite in a Name Service Environment page 11
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Name Service Environment
Solstice AdminSuite can be used to manage information on the local system or
across the network using a name service. The sources of information that can
be managed by Solstice AdminSuite are described in Table 2-1.

See “Using Solstice AdminSuite in a Name Service Environment” for
information on using Solstice AdminSuite with or without a name service
environment.

Selecting a Name Service Environment
After you start Solstice AdminSuite and click on an application icon, a window
is displayed prompting you to select a name service. Select the name service
that is appropriate for your environment.

Table 2-1 Available Name Services

 Name Service Select This Name Service To Manage ...

 NIS+ NIS+ table information. This requires sysadmin group (group 14)
membership and the appropriate ownership and permission on
the NIS+ tables to be modified.

 NIS NIS map information. You must be a member of the sysadmin
group and have explicit permissions on the NIS master server to
update the maps. This means an entry for your host name and
user name must reside in root’s .rhosts  file on the NIS master
server.

 None The /etc  files on the local system. You must be root or a member
of the sysadmin group on the local system. The local system
(identified in the Host: field on the Load window) is selected by
default.
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This example is from Group Manager’s Load window.

Note – The NIS and NIS+ environments are not available for Serial Port
Manager.

Using Solstice AdminSuite in a Name Service Environment
The following procedures describe how to use Solstice AdminSuite in each
name service environment.

In the NIS+ Environment

The requirements for viewing and modifying NIS+ table information are:

• Membership in the UNIX group, sysadmin, which allows use of Solstice
AdminSuite applications.

• Membership in the NIS+ admin group

• Modify permissions on the NIS+ tables to be managed. These permissions
are usually given to the NIS+ group members. See NIS+ and FNS
Administration Guide for information on adding users to a NIS+ group.

▼ How to Add a User to the Sysadmin Group

1. Verify that the prerequisites described in Chapter 1, “Introduction” are
met.

2. Log in as an authorized user to a host in the NIS+ domain.

Name Service Menu
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3. Type solstice &  in a Shell or Command Tool window.
The Solstice Launcher is displayed.

4. Click on the Group Manager icon.
The Group Manager Load window is displayed.

5. Select the NIS+ name service.

6. Click on OK.
The Group Manager main window is displayed.

7. Click on the sysadmin group in the main window.

8. Select Modify from the Edit Menu.
The Modify window is displayed.

9. Add a comma-separated list of members to the Members List text box.
The list must not contain spaces.

10. Click on OK.

In the NIS Environment

The requirements for viewing and modifying NIS map information are:

• Membership in the UNIX group, sysadmin, which provides use of Solstice
AdminSuite applications

• An entry for your host name and user name in root’s .rhosts  file on the
NIS master server

• Running ypbind  with the -broadcast  option, which is the default form, if
you want to manage NIS map information in domains other than your own.

▼ How to Add a User to the Sysadmin Group

1. Verify that the prerequisites described in Chapter 1, “Introduction” are
met.

2. Log in as root on the NIS master server.
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3. Edit the /etc/group  file.
Add a comma-separated list of members to the sysadmin group.

4. Remake the NIS maps.

Note – Depending on the size of the NIS maps, it may take several minutes or
several hours to update the maps and propagate the changes throughout the
network.

5. Create a .rhosts  entry in the root (/ ) directory on the NIS master server
for users authorized to modify NIS maps. Use the following format:

host-name user-name

▼ How to Use Solstice AdminSuite Without a Name Service

 Use this procedure if you will use Solstice AdminSuite on the local system
only.

1. Become root on your system.

2. Edit the /etc/group  file.
Add a comma-separated list of members to the sysadmin group.

sysadmin::14: user-name, user-name, user-name

# cd /var/yp
# make group

sysadmin::14: user-name, user-name, user-name
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 Security 3

An important part of using the Solstice AdminSuite software is understanding
its security features and setting up security policies to protect your
administrative data.

This is a list of the topics and step-by-step instructions in this chapter.

 Security Information
Solstice AdminSuite uses the distributed system administration daemon
(sadmind ) to carry out security tasks when you perform administrative tasks
across the network. The sadmind  daemon executes the request on the server
on behalf of the client process and controls who can access Solstice
AdminSuite.

Administering security involves authentication of the user ID (UID) and
authorization of permissions.

• Authentication means that the sadmind  daemon must verify the identity of
the client making the request before the sadmind  daemon can execute the
request.

Security Information page 15

Creating a Security Policy page 19
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• Authorization means that sadmind  verifies that the authenticated user has
permission to execute Solstice AdminSuite on the server. After the client
identity is verified, sadmind  uses the client identity to perform
authorization checks.

If you have permission to use Solstice AdminSuite, you also need to have
create, delete, or modify permission before you can change an NIS+ file. See
NIS+ and DNS Setup and Configuration Guide for a description of NIS+
security.

User and group identities are used for authorization checking as follows:

• Root identity – The root identity has privileges (to access and update data)
only on the local system. If the server is the local system (in other words, if
the user has logged in as root on the server), the user will be allowed to
perform Solstice AdminSuite functions on the server under the root identity.

• User ID – A regular user can only view, but not change, information using
Solstice AdminSuite.

• User ID who is a member of sysadmin group (group 14) – Solstice
AdminSuite permissions are granted to users who are members of the
sysadmin group (group 14). This means that a user modifying
administration data must be a member of the sysadmin group on the system
where the task is being executed.

Security Levels

Each request to change administration data contains a set of credentials with a
user ID and a set of group IDs to which the user belongs. The server uses these
credentials to perform identity and permission checks. Three levels of
authentication security are available.
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The security levels are described in Table 3-1.

Note – Level 1 is the default security used by sadmind .

Changing the Security Level

You can change the security level from Level 1 to Level 2 by editing the
/etc/inetd.conf  file on each system, and adding the –S 2  option to the
sadmind  entry. If you do this, make sure that the servers on the domain are set
up to use DES security.

Table 3-1 Solstice AdminSuite Security Levels

Level Level Name Description

0 NONE No identity checking is done by the server. All user IDs are
set to the nobody  identity. This level is used mostly for
testing.

1 SYS The server accepts the original user and group identities from
the client system and uses them as the identities for the
authorization checks. There is no checking to be sure that the
user ID of the client represents the same user on the server
system. That is, it is assumed the administrator has made the
user IDs and group IDs consistent on all systems in the
network. Checks are made to see if the client has permission
to execute the request.

2 DES Credentials are validated using DES authentication, and
checks are made to be sure that the client has permission to
execute the request. The user and group identities are
obtained from files on the server system by mapping the
user’s DES network identity to a local user ID and set of
group IDs. The file used depends on which name service is
selected on the server system. This level provides the most
secure environment for performing administrative tasks and
requires that a publickey  entry exists for all server systems
where the sadmind  daemon is running, and for all users
accessing the tools.
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You do not need to maintain the same level of security on all systems in the
network. You can run some systems, such as file servers requiring strict
security, at security Level 2, while running other systems at the default Level 1
security.

See the description of how to set up security for NIS+ in NIS+ and FNS
Administration Guide.

Name Service Information

The sadmind  daemon uses information held by the name service. The three
sources of information are:

• Files in the /etc  directory such as passwd , group , and shadow, referred to
as the keyword files

• The NIS name service referred to as the keyword nis

• The NIS+ name service referred to as the keyword nisplus

On each system, the /etc/nsswitch.conf  file lists several administrative
files, followed by a list of one or more keywords that represent the name
services to be searched for information. If more than one keyword is listed,
they are searched in the order given. For example, the entry

group: files nisplus

indicates that the security mechanism looks first in the local /etc/group  file
for an entry. If the entry exists, the security mechanism uses the information in
this entry. If the entry doesn’t exist, the NIS+ group  file is searched.

By default, systems running the Solaris 2.4 and Solaris 2.5 OS release have an
entry for the sysadmin group in the local /etc/group  file. If you want to set
up your system to use network-wide information, do not add members to the
sysadmin group on the local system. Instead, update the sysadmin entry found
in the group table stored in the name service.

When running under Level 2 security, the security mechanisms use the
public/private key information. Make sure that the entry for publickey  is
followed by either nis  or nisplus  (depending on which name service you are
using), and remove the files  designation. See NIS+ and FNS Administration
Guide for more information about the nsswitch.conf  file.
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Creating a Security Policy
Consider the following when creating a security policy for using Solstice
AdminSuite in a name service environment.

• Determine how much trust is needed.

If your network is secure and you do not need to use authentication
security, you can use Solstice AdminSuite applications with the default
Level 1 security.

If you need to enforce a higher level of security, you can set the security
level of sadmind  to Level 2. Level 2 security is primarily used with the
NIS+ name service.

• Determine which name service will be used.

The name service determines where the security methods get information
about user and group identities. The name services are designated in the
/etc/nsswitch.conf  file (see “Name Service Information” on page 18).

• Decide which users have access to Solstice AdminSuite.

Decide which users will perform administrative functions over the network
with Solstice AdminSuite. List these users as members of the sysadmin
group accessed by the server system, as defined in the
/etc/nsswitch.conf  configuration file. The sysadmin group must be
accessible from each system where administration data will be updated by
Solstice AdminSuite. The sysadmin group can be established locally on each
system or can be used globally within a name service domain, depending
upon the policy established by the administrator.

• Determine global and local policies.

The global policy affects all hosts in the network. For example, you can add
members to the sysadmin group in the NIS or NIS+ group  file. Members of
this group will have permission to perform administrative tasks on all
server systems that list the network name service as the primary source of
information. The name services are listed in the /etc/nsswitch.conf  file.
For more information about the nsswitch.conf  file, see “Name Service
Information” on page 18.
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A user can establish a local policy that is different from the global policy by
creating a sysadmin group in the local /etc/group  file and listing the users
who have access to the local system. The members of this group will have
permission to manipulate or run Solstice AdminSuite methods on the user’s
local system.

• Set up permissions for NIS+ management.

You need the proper permissions when using Solstice AdminSuite to modify
or update the NIS+ files. In addition to the permissions required by Solstice
AdminSuite, the NIS+ security mechanisms impose their own set of access
permissions. The NIS+ security mechanisms are described in NIS+ and FNS
Administration Guide.

• Set up access for NIS management.

In addition to the permissions required by Solstice AdminSuite, a user must
have a .rhosts  entry on the NIS master server to modify the NIS files.



Part 2 —  Using Solstice AdminSuite
Tools

This part provides instructions for how to use the Solstice Launcher and the
individual Solstice AdminSuite applications. This part contains these chapters.

Using the Solstice Launcher
Provides instructions on  how to start the Solstice Launcher  and add
applications to the launcher.

Managing Users With User Manager and Group Manager
Provides instructions for how to create and manage user information  with
User Manager and Group Manager.

Managing Server and Client Support With Host Manager
Provides instructions for how to set up a system with Host Manager. Also
describes how to add diskless and dataless client support to a server.

Managing Network Service Files with Database Manager
Provides instructions for how to manage network service files with Database
Manager.

Managing Terminals and Modems with Serial Port Manager
Provides instructions for setting up the serial port software to work with
terminals and modems with the Serial Port Manager.

Setting Up SunSoft Print Client Software With Printer Manager
Provides instructions for how to set up  print servers and print clients with
Printer Manager.

4

5

6

7

8

9
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Using the Solstice Launcher 4

The Solstice Launcher provides access to the Solstice product family of
administration tools. The tools that appear in the Launcher depend on what
Solstice products you have installed on your system.

This is a list of the topics and step-by-step instructions in this chapter.

Starting the Solstice Launcher page 24

How to Privately Register Applications in the Solstice Launcher page 26

How to Remove a Privately Registered Application page 27

How to Globally Register Applications in the Solstice Launcher page 30

How to Remove a Globally Registered Application page 31

How to Customize Application Properties in the Solstice Launcher page 32

How to Modify Properties of a Locally Registered Application page 34

How to Use the File Selection Window page 35
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Starting the Solstice Launcher
Start the Solstice Launcher from a window as follows:

The Solstice Launcher is displayed.

The Solstice Launcher menus are described in Table 4-1.

$ solstice &

Table 4-1 Solstice Launcher Menus

Use This Menu ... To Access This Command ... That Performs This Function ...

Launcher Add Applications Adds and registers applications with the Launcher.

Properties Provides ability to show, hide, or remove applications in the
Launcher; reorder the icons; change the Launcher window width;
modify application properties; add applications

Exit Stops running the Solstice Launcher. Does not affect open or
iconified applications.

Help Check Help Access the Help system.
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Registering Applications in the Solstice Launcher
Applications that display in the Solstice Launcher are registered. This means
that you can add and remove applications, including custom applications, to
and from the Launcher main window.

Applications are registered in three ways:

• Private registry – Registered applications are private to the user.
Applications are registered privately with the Add Application command
from the Launcher menu. See “How to Privately Register Applications in
the Solstice Launcher” on page 26 for instructions on registering
applications privately.

Privately registered applications can be added, removed, and their
properties can be modified from the Solstice Launcher.

• Local registry – Registered applications are local to the system. Applications
registered locally are available to all local users of the system. Applications
can only be registered locally with the /usr/snadm/bin/soladdapp
command. See “How to Locally Register Applications in the Solstice
Launcher” on page 27 for information on using the soladdapp  command to
register applications locally.

Locally registered applications can only be added or removed using the
soladdapp  and soldelapp  commands. Their properties cannot be
modified from the Solstice Launcher.

• Global registry – Registered applications are shared by all local and remote
users using the Solstice Launcher in a particular /opt  directory.
Applications can only be registered globally with the
/usr/snadm/bin/soladdapp  command.
See “How to Globally Register Applications in the Solstice Launcher” on
page 30 for information on using the soladdapp  command to register
applications globally.

Globally registered applications can only be added or removed using the
soladdapp  and soldelapp  commands. Their properties cannot be
modified from the Solstice Launcher.

If the user has a local registry file, and both a local registry and global registry
file are in place, then the applications from all files are displayed.
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▼ How to Privately Register Applications in the Solstice Launcher

The following procedure describes how to privately register applications in the
$HOME/.solstice_registry  file.

1. Select Add Application from the Launcher menu.

2. Enter the following application information in the Add Application
window.

a. Identify the application name in the Name text box.
This name is displayed in the Launcher window.

b. Identify the application path name in the Application Path text box.
If you are not sure of the application path name, click on the ... box,
which displays the Application Path Selection window. See “How to Use
the File Selection Window” on page 35 for information on using this
window.

c. Identify any command-line arguments for the application in the
Arguments text box.
These arguments are passed to the application when it is started.

d. Identify the application icon path name in the Icon Path text box.
If you are not sure of the icon path name, click on the ... box, which
displays the Application Path Selection window. See “How to Use the
File Selection Window” on page 35 for information on using this
window.

3. Click on Register to add the application.

Example

The following example registers an application called Disk Manager.
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▼ How to Remove a Privately Registered Application

1. Select Properties from the Launcher menu.
 The Properties window is displayed.

2. Select an application from the Hide or Show lists.

3. Click on the Remove button in the Properties window.

4. Click on OK.

▼ How to Locally Register Applications in the Solstice Launcher

1. Become root.

2. Register an application with the soladdapp  command.

In this command,

# /usr/snadm/bin/soladdapp \
           -r /etc/.solstice_registry \
           -n “ Tool Name” \
           -i /opt/pkgname/etc/tool.icon \
           -e /opt/pkgname/bin/command

args

/usr/snadm/bin/soladdapp Is the Solstice command for registering
applications.

-r /etc/.solstice_registry Specifies the path name of the Solstice local
registry file.

-n  “ Tool Name” Specifies the name of the tool to be registered.

-i /opt/pkgname/etc/tool.icon Specifies the path name of the tool icon.

-e /opt/pkgname/bin/command Specifies the path name of the tool executable.

args Specifies optional arguments to use with the
executable
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Example

The following example uses the soldaddapp  command to locally  register an
application called Disk Manager.

# /usr/snadm/bin/soladdapp \

-r /etc/.solstice_registry \
-n “Disk Manager” \
-i /opt/SUNWdsk/etc/diskmgr.xpm \

      -e /opt/SUNWdsk/bin/diskmgr
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▼ How to Remove a Locally Registered Application

1. Become root.

2. Remove an application with the soldelapp  command.

In this command,

Example

The following example uses the soldelapp  command to remove an
application called Disk Manager.

# /usr/snadm/bin/soldelapp \
           -r /etc/.solstice_registry \
           -n “ Tool Name”

/usr/snadm/bin/soldelapp Is the Solstice command for removing
applications from the local registry file.

-r /etc/.solstice_registry Specifies the path name of the Solstice local
registry file.

-n  “ Tool Name” Specifies the name of the tool to be removed.

# /usr/snadm/bin/soldelapp \

-r /etc/.solstice_registry \
      -n “Disk Manager”
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▼ How to Globally Register Applications in the Solstice Launcher

1. Become root.

2. Register an application with the soladdapp  command.

In this command,

Example

The following example uses the soldaddapp  command to globally register an
application called Disk Manager.

# /usr/snadm/bin/soladdapp \
           -r /opt/SUNWadm/etc/.solstice_registry \
           -n “ Tool Name” \
           -i /opt/pkgname/etc/tool.icon \
           -e /opt/pkgname/bin/command

args

/usr/snadm/bin/soladdapp Is the Solstice command for registering
applications.

-r /opt/SUNWadm/etc
/.solstice_registry

Specifies the path name of the Solstice global
registry file.

-n  “ Tool Name” Specifies the name of the tool to be registered.

-i /opt/pkgname/etc/tool.icon Specifies the path name of the tool icon.

-e /opt/pkgname/bin/command Specifies the path name of the tool executable.

args Specifies optional arguments to use with the
executable

# /usr/snadm/bin/soladdapp \

-r /opt/SUNWadm/etc/.solstice_registry \
-n “Disk Manager” \
-i /opt/SUNWdsk/etc/diskmgr.xpm \

      -e /opt/SUNWdsk/bin/diskmgr
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▼ How to Remove a Globally Registered Application

1. Become root.

2. Remove an application with the soldelapp  command.

In this command,

Example

The following example uses the soldelapp  command to remove an
application called Disk Manager.

# /usr/snadm/bin/soldelapp \
           -r /opt/SUNWadm/etc/.solstice_registry \
           -n “ Tool Name”

/usr/snadm/bin/soldelapp Is the Solstice command for removing
applications from the global registry file.

-r /opt/SUNWadm/etc/
.solstice_registry

Specifies the path name of the Solstice global
registry file.

-n  “ Tool Name” Specifies the name of the tool to be removed.

# /usr/snadm/bin/soldelapp \

-r /opt/SUNWadm/etc/.solstice_registry \
      -n “Disk Manager”
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Customizing the Solstice Launcher

▼ How to Customize Application Properties in the Solstice Launcher

1. Select Properties from the Launcher menu.
 The Properties window is displayed.

2. Use the Hide/Show buttons to disable or enable the display of
applications in the Launcher window.

a. Select an application from the Show list and click on the Hide button
to hide an application.
The application is moved to the Hide list.

b. Select an application from the Hide list and click on the Show button
to show an application.
The application is moved to the Show list.

c. Click on OK when you are finished moving applications to and from
the Show and Hide lists.

3. Use the Remove button to remove an application from a local registry file.
See “How to Remove a Privately Registered Application” on page 27 for
information on removing a locally registered application.

4. Click on the Add Application button to add an application to the
Launcher window.
The Add Application window is displayed. This window is equivalent to
the Add Application command from the Launcher menu.

See “How to Privately Register Applications in the Solstice Launcher” on
page 26 for information on adding applications to the Launcher.

5. If you select an application from the Hide or Show lists and click on the
Application Properties button, the Application Properties window is
displayed.
See “How to Modify Properties of a Locally Registered Application” on
page 34 for information on modifying the properties of a locally registered
application.

6. Change how the tool icons are displayed in the Launcher window.

a. Select an application in the Show list and click on the Up or Down
arrow under Icon Order to change the location of an icon.
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b. Use the up/down arrows under Launcher Width to indicate the number
of columns that will display in the Launcher window.

7.  If you increase the number of icons to be wider than the width of the
Launcher window, use the scrollbar at the bottom of the Launcher to view
any icons that moved off the window.

8. Click on OK.

Example

The following example shows that Database Manager has been moved to the
Hide list. This means it will not be displayed in the Solstice Launcher.
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Customizing Locally Registered Applications in the Solstice Launcher
Locally registered applications can be customized in the following ways:

• Applications can be hidden or redisplayed by using the Hide/Show feature.

• The number of columns in the Launcher window can be expanded and
contracted, which affects how the applications are displayed.

• The application icons can be moved up or down to change the order in
which the application icons are displayed.

See “How to Customize Application Properties in the Solstice Launcher” on
page 32 for more information on customizing applications.

▼ How to Modify Properties of a Locally Registered Application

1. Select Properties from the Launcher menu.
The Properties window is displayed.

2. Select an application from the Hide or Show lists.

3. Click on the Application Properties button.
The Application Properties window is displayed.

4. Modify the following application properties:

a. The application name in the Name text box.

Note –  The application name must be changed in order for any application
properties changes to be successful.

b. The application path name in the Application Path text box.
If you are not sure of the application path name, click on the ... box,
which displays the Application Path Selection window. See “How to Use
the File Selection Window” on page 35 for information on using this
window.

c. Any command-line arguments to the application in the Arguments text
box.
These arguments are passed to the application when it is started.
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d. The icon path name in the Icon Path text box.
If you are not sure of the icon path name, click on the ... box, which
displays the Application Path Selection window. See “How to Use the
File Selection Window” on page 35 for information on using this
window.

5.  Click on Register.

Example

The following example provides an alternative executable and icon for Host
Manager.

▼ How to Use the File Selection Window

1. Use the Filter text box in the Application Path Selection window to
specify a path name using a regular expression, such as the wildcard
character (*).
When a new value is entered, the Directories and File lists are updated
appropriately.

2. Select a file name from the Files list to update the Open File text box.

3. Click on OK to place the Open File text box value into the field from
which the File Selection window was invoked.

The application file name is displayed in the Application Path text box in
the Application window.
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Example

The following example of the Application Path Selection window uses a filter
to search the /opt/SUNWadm/2.1/bin  directory for application tool
executables, which are displayed under the Files list.
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Managing Users With User
Manager and Group Manager 5

This chapter describes how to manage user accounts using two applications
within the Solstice AdminSuite software:

• Group Manager, a graphical user interface for managing group information

• User Manager, a graphical user interface used to manage user account
information

This is a list of the step-by-step instructions in this chapter.

See Chapter 11, “Group Manager Reference,” and Chapter 12, “User Manager
Reference,” for additional information on each tool’s menus and menu
commands.

How to Start Group Manager page 39

How to Add a Group page 41

How to Start User Manager page 42

How to Set Up User Account Defaults page 44

How to Add a New User Account page 45

How to Copy an Existing User Account page 47

How to Modify a Group page 49

How to Delete a Group page 50

How to Modify a User Account page 51

How to Delete a User Account page 53
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Setting Up User Accounts

Table 5-1 Task Map: Setting Up User Accounts

Activity Description For Instructions, Go To

Add Groups Optional. To help administer users, add groups by
choosing Add from the Group Manager’s Edit menu. This
is usually a one-time task.

▼ How to Add a Group page 41

Set User Account
Defaults

Optional. Before you add several user accounts, set up
defaults for the User Manager by choosing Set Defaults
from the User Manager’s Edit menu. Setting up defaults
can increase the consistency and efficiency of adding user
accounts.

▼ How to Set Up User
Account Defaults

page 44

Add a User
Account

Add a New User Account
Add a user account by choosing Add from the User
Manager’s Edit menu.

▼ How to Add a New
User Account

page 45

Copy an Existing User Account
Copy an existing user account by choosing Copy from the
User Manager’s Edit menu. This is useful if you need to add
a user account that is similar to an existing user account.

▼ How to Copy an
Existing User
Account

page 47
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▼ How to Start Group Manager

1. Verify that the prerequisites described in Chapter 1, “Introduction” are
met.

2. Start the Solstice Launcher.

The Solstice Launcher is displayed.

3. Click on the Group Manager icon.

The Load window is displayed.

4. Select the name service used in your network.

5. Check that the domain or host name is correct.
If not, type the name of the domain or host you need to access.

6. Click on OK.
The Group Manager main window is displayed.

$ solstice &
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Example of the Group Manager Main Window
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▼ How to Add a Group

1. Start Group Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Group Manager” on page 39 for more information.

2. Choose Add from the Edit menu on the Group Manager main window.
The Add window is displayed. If you need information to complete a field,
click on the Help button to see field definitions for this window.

3. Type the name of the new group in the Group Name text box.

4. Type the group ID for the new group in the Group ID text box.
The group ID should be unique.

5. (Optional) Type user names in the Members List text box.
The list of users will be added to the group. User names must be separated
by commas.

6. Click on OK.
The list of groups displayed in the Group Manager main window is updated
to include the new group.

Example of Completed Add Window

The following example adds a group named users  that has a group ID of 100.
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▼ How to Start User Manager

1. Verify that the prerequisites described in Chapter 1, “Introduction” are
met.

2. Start the Solstice Launcher.

The Solstice Launcher is displayed.

3. Click on the User Manager icon from the Solstice Launcher.

The Load window is displayed.

4. Select the name service used in your network.

5. Check that the domain or host name is correct.
If not, type the name of the domain or host you need to access.

6. Click on OK.
The User Manager main window is displayed.

$ solstice &
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Example of the User Manager Main Window
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▼ How to Set Up User Account Defaults

1. Start User Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start User Manager” on page 42 for more information.

2. Choose Set Defaults from the Edit menu.
The Set Add Defaults window is displayed.

3. Fill in the Set Add Defaults window.
The defaults you select will be the initial defaults values in the Add
window. If you need information to complete a field, click on the Help
button to see field definitions for this window.

You can set the following defaults:
• Primary and Secondary Groups
• Login Shell
• Password Policy
• Creating a Home Directory
• Home Directory Server
• Skeleton Path (Path to User Initialization Files)
• Using AutoFS (AutoHome Setup)
• Permissions in Home Directory
• Mail Server

4. Click on OK.
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▼ How to Add a New User Account

1. Start User Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start User Manager” on page 42.

2. Choose Add from the Edit menu.
The Add window is displayed.

3. Fill in the Add window.
If you need information to complete a field, click on the Help button to see
field definitions for this window.

4. Click on OK.
The list of user accounts displayed in the User Manager main window is
updated to include the new user account.
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Example of Completed Add Window

The server where the home
directory is located.

The path (on the system run-
ning User Manager) from which
to copy user initialization files
into the user’s home directory.
You can also specify an auto-
mounted path to user initializa-
tion files on another system.
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▼ How to Copy an Existing User Account

1. Start User Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start User Manager” on page 42.

2. Select a user account entry to copy from the main window.

3. Choose Copy from the Edit menu.
The Copy window is displayed with the following fields copied from the
selected user account:

• Primary Group
• Secondary Groups
• Comment
• Login Shell
• Path
• Server
• Skeleton Path

4. Fill in the fields in the Copy window.

If you need information to complete a field, click on the Help button to see
field definitions for this window.

5. Click on OK.
The list of user accounts displayed in the User Manager main window is
updated to include the new user account.
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Maintaining User Accounts

Table 5-2 Task Map: Maintaining User Accounts

Activity Description For Instructions, Go To

Modify a Group Modify a group’s name or the users in a group by
choosing Modify from the Group Manager’s Edit menu.

▼ How to Modify a
Group

page 49

Delete a Group Delete a group by choosing Delete from the Group
Manager’s Edit menu.

▼ How to Delete a
Group

page 50

Modify a User
Account

If a user account needs to be changed, modify the user
account by choosing Modify from the User Manager’s
Edit menu.

▼ How to Modify a
User Account

page 51

Delete a User
Account

Delete a user account by choosing Modify from the User
Manager’s Edit menu.

▼ How to Delete a
User Account

page 53
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▼ How to Modify a Group

1. Start Group Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Group Manager” on page 39 for more information.

2. Select the group entry to modify from the Group Manager main window.

3. Choose Modify from the Edit menu.
The Modify window is displayed containing the selected group entry.

4. Either modify the group’s name or the users in the group.
User names must be separated by commas. If you need information to
complete a field, click on the Help button to see field definitions for this
window.

5. Click on OK.
The group information displayed in the main window is updated.

Example of Completed Modify Window
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▼ How to Delete a Group

1. Start Group Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Group Manager” on page 39 for more information.

2. Select the group entry you want to delete from the Group Manager main
window.

3. Choose Delete from the Edit menu.
A window is displayed asking you to confirm the deletion.

4. Click on OK.
The group entry is deleted from the Group Manager main window.
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▼ How to Modify a User Account

1. Start User Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start User Manager” on page 42 for more information.

2. Select the user account entry to modify from the User Manager main
window.

3. Choose Modify from the Edit menu.
The Modify window is displayed containing the selected user account entry.

4. Modify the user account.
If you need information to complete a field, click on the Help button to see
field definitions for this window.

5. Click on OK.

Verification

Double-click on the modified user acount entry in the User Manager main
window to verify that the modifications were made. Click on cancel to close
the window without making any modifications.
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Example of Completed Modify Window

The following example adds the lp  secondary group membership to the
rimmer  user account.
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▼ How to Delete a User Account

1. Start User Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start User Manager” on page 42 for more information.

2. Select the user account entry to remove from the main window.

3. Choose Delete from the Edit menu.
The Delete window is displayed to confirm the removal of the user account.

4. (Optional) Click on the check box to delete the user’s home directory and
its contents.

5. (Optional) Click on the check box to delete the user’s mailbox and its
contents.

6. Click on OK when you are ready to delete the user account.
The user account entry is deleted from the User Manager main window.

Example of Delete Window
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Managing Server and Client
Support With Host Manager 6

This chapter describes how to set up and maintain server and client support
using the Solstice Host Manager.

This is a list of the step-by-step instructions in this chapter.

See Chapter 13, “Host Manager Reference,” for additional information on each
Host Manager’s menus and menu commands.

How to Start Host Manager page 66

How to Update System Types page 68

How to Set Defaults for Adding Support page 68

How to Add Support for a Standalone System or OS Server page 69

How to Convert a Standalone System to an OS Server page 72

How to Add SunOS 4.x OS Services to an OS Server page 74

How to Add Solaris 2.x OS Services to an OS Server page 80

How to Add Support for a Diskless Client page 82

How to Add Support for a Dataless Client page 85

How to Modify Support for a System page 89

How to Delete Support for a System page 89
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What Are Servers and Clients
Systems on the network can usually be described as one of the following:

• Server – A system that provides a services to other systems in its network.
There are file servers, boot servers, database servers, license servers, print
servers, installation servers, and even servers for particular applications.
This chapter uses the term server to mean a system that provides file
systems and installation software for other systems on the network.

• Client – A system that uses remote services from a server. Some clients have
limited disk storage capacity, or perhaps none at all, and they have to rely
on remote file systems from a server to function. Diskless and dataless
clients are examples of this type of client.

Other clients may use remote services (such as installation software) from a
server, but they don’t rely on a server to function. A standalone system,
which has its own hard disk containing the root (/ ), /usr , and /home  file
systems and swap space, is a good example of this type of client.

What Does Support Mean
Providing support for a system means providing software and services to help
another system function. Support can include:

• Making a system known to the network (i.e., host name and ethernet
address information)

• Providing installation services to remotely boot and install a system

• Providing operating system (OS) services to a system with limited or no
disk space
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Overview of System Types
System types are basically defined by how they access the root (/) and /usr
file systems, including the swap area. For example, standalone and server
systems mount these file systems from a local disk, while diskless and dataless
clients mount the file systems remotely, relying on servers to provide these
services. Table 6-1 lists these and other differences for each system type.

Table 6-1 System Type Overview

System Type Local File Systems
Local
Swap?

Remote File
Systems Network Use

Relative
Performance

Server root (/ )
/usr
/home
/opt
/export/home
/export/root

Yes – none – high high

Standalone System root (/ )
/usr
/export/home

Yes – none – low high

Dataless Client root (/ ) Yes /usr
/home

medium medium

Diskless Client – none – No root (/ )
swap
/usr
/home

high low
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Servers

A server system has the following file systems:

• The root (/ ) and /usr  file systems, plus swap space.

• The /export , /export/swap , and /export/home  file systems, which
support client systems and provide home directories for users.

• The /opt  directory or file system for storing application software.

Servers can also contain the following software to support other systems:

• Operating system (OS) services for diskless and dataless clients that want to
run a different release or are a different platform than the server.

• Solaris CD image and boot software for networked systems to perform
remote installations.

• JumpStart directory for networked systems to perform custom JumpStart
installations.

Standalone Systems

A networked standalone system can share information with other systems in the
network, but it could continue to function if detached from the network.

A standalone system can function autonomously because it has its own hard
disk containing the root (/ ), /usr , and /home  file systems and swap space. The
standalone system thus has local access to operating system software,
executables, virtual memory space, and user-created files.

Note that a standalone system requires sufficient disk space to hold the four
necessary file systems.

A non-networked standalone system is a standalone system with all the
characteristics listed above except that is not connected to a network.

Diskless Clients

A diskless client has no disk and depends on a server for all its software and
storage area. A diskless client remotely mounts its root (/ ), /usr , and /home
file systems from a server.
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A diskless client generates significant network traffic due to its continual need
to procure operating system software and virtual memory space from across
the network. A diskless client cannot operate if it is detached from the network
or if its server malfunctions.

Dataless Clients

A dataless client has local storage for its root (/ ) file system and swap space.
The dataless client cannot function if detached from the network, because its
executables (/usr ) and user files (/home ) are located across the network on the
disk of a server.

Note – SunSoft plans to remove support for dataless clients after Solaris 2.5.
You can add this system type now using Host Manager, but in future releases
of the Solaris operating environment you will need to choose a different type.

A dataless client places far less demand on the server and the network than a
diskless client does. Because dataless clients require less network access, a
server can accommodate many more dataless clients than it can diskless
clients.

Dataless clients are less expensive to manage than standalone systems. Also,
the user files of all the dataless clients are stored centrally (on a server) and can
be backed up and administered centrally.

What You Can Do With Host Manager
Host Manager is a graphical user interface that enables you to add and
maintain server and client support on a network. With a name service like
NIS+, you can manage system information in a centralized manner so that
important system information, such as host names, do not have to be
duplicated on every system in the network.

Host Manager enables you to:

• Add and Modify System Support
• Update System Types
• Convert System Types
• Add OS Services
• Set up remote installation services
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• Queue Tasks

Add and Modify System Support

Host Manager enables you to add and modify support for the following
system types:

• Solaris Diskless
• Solaris Dataless
• Solaris Standalone
• Solaris OS Server

Table 6-2 describes the server-client configurations that are supported by the
Solstice AdminSuite 2.1 release of Host Manager.

Note – The SunOS 4.x release is supported on SPARC systems based on the
Sun4c and Sun4m platform groups only. SunSoft plans to remove support for
the SunOS 4.x release in a later version of the Solstice AdminSuite software.

Update System Types

Host Manager cannot recognize all previously added system types until you
use the Update System Types option from the File menu. This option will
probe client systems and identify their system types. Host Manager will mark
systems as generic  if they are not running the Solaris software or if they use
local or loghost entries.

Table 6-2 Supported Server-Client Configurations

Client

SunOS 4.x Solaris 2.3 Solaris 2.4 Solaris 2.5

SPARC x86 SPARC x86 SPARC x86 SPARC

Solaris 2.3 x86 - - - - - - -

SPARC Yes - Yes Yes Yes Yes Yes

Server Solaris 2.4 x86 Yes - Yes Yes Yes Yes Yes

SPARC Yes - Yes Yes Yes Yes Yes

Solaris 2.5 x86 Yes - Yes Yes Yes Yes Yes

SPARC Yes - Yes Yes Yes Yes Yes
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Note – Previously added systems running Solaris 2.5 must also have the
Solstice AdminSuite software installed for Host Manager to update their
system type.

The system type information is stored in the bootparams  file in the local /etc
files or a name service database. Host Manager will either modify an existing
bootparams  entry or add a new one such as the following for a Solaris
standalone system named mars :

mars boottype=:st

Convert System Types

Host Manager enables you to convert one system type to another. Currently,
you can only convert:

• A generic system to a standalone system

• A standalone system to an OS server

You can add Solaris 2.x OS services during the standalone system to OS server
conversion.

Add OS Services

A Solaris OS server is a server that provides operating system (OS) services to
support diskless or dataless clients. By using Host Manager, you can add
support for an OS server or convert a standalone system to an OS server.

By default, an OS server can support clients that are the same platform group
and require the same Solaris release as the OS server. To support clients of a
different platform group or clients that require a different Solaris release than
the OS server, you must add the particular OS service to the OS server. You
must have the appropriate Solaris CD image to add OS services.

For example, if you have a OS server running Solaris 2.5 and you want it to
support diskless clients running Solaris 2.4, you must add Solaris 2.4 OS
services to the OS server. You would also have to add services to a SPARC OS
server if you want it to support x86 diskless clients running Solaris 2.4. In this
example, both the server and client are running the same Solaris release, but
they are different platform groups.
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Note – Although Host Manager enables you to add support for diskless and
dataless clients running the Sun4.x release, you cannot add SunOS 4.x OS
services using Host Manager. You must use the install4x  command to add
OS services to an OS server and then use Host Manager to add support for the
SunOS 4.x client.

Set Up Remote Installation Services

Host Manager enables you to set up systems to provide Solaris 2.x installation
services for other systems on the network. You can set up the following types
of installation services on a system:

• An install server – A system on the network that provides a Solaris CD
image (either from a CD-ROM drive or the copy on the hard disk) for other
systems to install from.

• A boot server – A system that provides boot information to other systems
on the network. The boot server and the install server are usually the same
system.

• A profile server – A system that contains Jumpstart files for systems to
perform a custom JumpStart installation.

Note – A boot server and install server are typically the same system.
However, if the system to be installed is on a different subnet than the install
server, a boot server is required on that subnet.

Queue  Tasks

Host Manager enables you to queue tasks such as converting system types and
adding OS services. Since these tasks may require several minutes to process,
Host Manager enables you to set up tasks to be performed without requiring
you to wait for each task to be completed. After setting up the tasks, choose
Save Changes from File menu. Host Manager’s progress is displayed in the
message bar located at the bottom of the window as each task is processed.
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What You Can’t Do With Host Manager
Table 6-3 shows the limitations of Host Manager and their suggested
workarounds.

Table 6-3 Host Manager Limitations and Workarounds

Limitation Workaround

Host Manager cannot automatically
recognize all previously added system
types.

Use the Update System Type option from
the File menu. This option will probe
systems on the network and identify their
system types.

Host Manager cannot add or maintain
AutoClient systems.

Use the Solstice AutoClient Manager to
create and maintain AutoClient systems.
AutoClient Manager is provided with the
Solstice AutoClient product.

Host Manager can’t add SunOS 4.x
services to an OS server.

Mount a SunOS 4.x CD image and add OS
services by using the install4x
command.

Host Manager can’t provide remote
installations services for SunOS 4.x
systems.

Install SunOS 4.x systems from the local
CD-ROM drive.

Host Manager does not enable you to
add multiple host entries for a system
with the same Ethernet address
(needed for servers with multiple
Ethernet interfaces, also known as
multi-homed hosts).

Use command-line equivalents to enter the
host information into the name service.

Host Manager does not enable you to
convert a generic system type to a
server system type.

Convert the generic system to a standalone
system type first.
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Adding Server and Client Support

Table 6-4 Task Map: Adding Server and Client Support

Activity Description For Instructions, Go To

Update System
Types

Optional. Make sure Host Manager recognizes all the
previously added system types. This is usually a one-
time task before using the AdminSuite 2.1 Host Manager
for the first time.

▼ How to Update
System Types

page 68

Set Defaults for
Adding Support

Optional. Before you add support for several clients, set
up defaults for the Add window by choosing Set Defaults
from the Host Manager’s Edit menu. Setting up defaults
can increase the consistency and efficiency of adding
support for systems.

▼ How to Set Defaults
for Adding Support

page 68

Add Support for a
Standalone

System

Add Support for a Standalone System
Add support for a standalone system by choosing Add
from the Host Manager’s Edit menu. Once in the Add
window, choose Standalone System from the System
Type menu.

▼ How to Add
Support for a
Standalone System
or OS Server

page 69

Add Support for an
OS Server

Add Support for an OS Server
Add support for an OS server by choosing Add from the
Host Manager’s Edit menu. Once in the Add window,
choose OS Server from the System Type menu.

▼ How to Add
Support for a
Standalone System
or OS Server

page 69

Convert a Standalone System to an OS Server
Convert a standalone system to an OS server by
choosing Convert from the Host Manager’s Edit menu.
You can add Solaris 2.x OS services during the
conversion.

▼ How to Convert a
Standalone System
to an OS Server

page 72
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Add OS Services
to an OS Server

Add SunOS 4.x OS Services
If you need to add support for SunOS 4.x diskless or
dataless clients, an OS server must have the
appropriate SunOS 4.x services added.

▼ How to Add SunOS
4.x OS Services to
an OS Server

page 74

Add Solaris 2.x OS Services
If you need to add support for Solaris 2.x diskless or
dataless clients, an OS server must have the
appropriate Solaris 2.x services added.

▼ How to Add Solaris
2.x OS Services to
an OS Server

page 80

Add Support for
Diskless or

Dataless Clients

Add Support for a Diskless Client
Add support for a diskless client by choosing Add from
the Host Manager’s Edit menu. Once in the Add window,
choose diskless client from the System Type menu.

▼ How to Add
Support for a
Diskless Client

page 82

Add Support for a Dataless Client
Add support for a dataless client by choosing Add from
the Host Manager’s Edit menu. Once in the Add window,
choose dataless client from the System Type menu.

▼ How to Add
Support for a
Dataless Client

page 85

Table 6-4 Task Map: Adding Server and Client Support (Continued)

Activity Description For Instructions, Go To
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▼ How to Start Host Manager

1. Verify that the prerequisites described in Chapter 1, “Introduction” are
met.

2. Start the Solstice Launcher.

The Solstice Launcher is displayed.

3. Click on the Host Manager icon.

The Load window is displayed.

4. Select the name service used in your network.

5. Check that the domain or host name is correct.
If not, type the domain or host name you need to access.

6. Click on OK.
The Host Manager main window is displayed.

$ solstice &
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Example of a Host Manager Main Window
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▼ How to Update System Types

This procedure converts system types that are identified as unknown.

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Select Update System Types from the File menu on the Host Manager
Window.
The Update Systems Types window is displayed.

3. Click on Update to identify unknown system types.

▼ How to Set Defaults for Adding Support

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Choose Set Defaults from the Edit menu.
The Set Add Defaults window is displayed.

3. Fill in the Set Add Defaults window.
The defaults you select will be the initial defaults values in the Add
window. If you need information to complete a field, click on the Help
button to see field definitions for this window.

4. Click on OK.
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▼ How to Add Support for a Standalone System or OS Server

The high-level steps in this procedure are:

• Add system information about the system
• (Optional) Set up remote install capabilities for the system
• (Optional) Install the system

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Select Add from the Edit menu on the Host Manager window.
The Add window is displayed.

3. Fill in the system information, selecting Solaris Standalone or OS Server
as the system type.
The system information includes all the fields from the host name through
the time zone. If you need information to complete a field, click on the Help
button to see field definitions for this window.

4. If you want to set up remote install capabilities for the system, continue
to Step 5. If not, skip to Step 10.

5. Click on Enable Remote Install.

6. Select an Install Server.
The Install Server defaults to the current host. Select Other from the Install
Server menu to specify another host as the install server.
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7. Click on Set Media Path to identify the path to the Solaris CD image on
the install server.

8. Select the system’s architecture type and OS release from the OS Release
menu.
The architecture type must match the system’s architecture and the OS
release should match the Solaris release you want to remotely install on the
system.

9. If necessary, specify a boot server or profile server.
To specify another server other than the default, select Other from the menu.
Select a Profile Server from the Profile Server pull-down menu. You must
also specify a path to the boot software on the boot server or the custom
JumpStart directory on the profile server.

10. Click on OK on the Add window.

11. Select Save Changes from the File menu to add support for the standalone
system or OS server.
The standalone system or OS server is displayed in the Host Manager main
window.

12. (Optional) Boot and install the standalone system or OS server.
For more information about booting and installing, see SPARC: Installing
Solaris Software for SPARC systems or x86: Installing Solaris Software for x86
systems.

If You Are Using ... And ... Then Enter the Path ...

The Solaris CD as the
Solaris CD image

The Solaris CD is
managed by Volume
Management

/cdrom/cdrom0/s0  or
/cdrom/cdrom0/s2  on
SPARC systems,
/cdrom/cdrom0  on x86
systems

The Solaris CD is not
managed by Volume
Management

Where you mounted the
Solaris CD

A copy of the Solaris CD on
the Install Server’s hard
disk (by using
setup_install_server )

Where you specified
setup_install_server
 to copy the Solaris CD
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Note – If you are installing an OS server, you must allocate space in /export
and /export/swap  for the desired number of clients.

Example of Completed Add Window for a Standalone System
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Where to Go From Here

If you want to add OS services after you install an OS server, see “How to Add
Solaris 2.x OS Services to an OS Server” on page 80.

▼ How to Convert a Standalone System to an OS Server

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Select a standalone system host entry from Host Manager’s main window.

3. Select Convert to OS Server from the Edit menu.
The Convert window is displayed, and the selected standalone system is
displayed in the host name field.

4. Click on the Add button in the OS Services window to add services.

5. Click on Set Media Path to identify the path to the Solaris CD image from
which to add the client services.
The Install Server defaults to the current host. Select Other from the Install
Server menu to specify another host as the install server.

6. Specify the type of services you want to add and click on Add.

7. Click on OK on the Convert window.

If You Are Using ... And ... Then Enter the Path ...

The Solaris CD as the
Solaris CD image

The Solaris CD is
managed by Volume
Management

/cdrom/cdrom0/s0  or
/cdrom/cdrom0/s2  on
SPARC systems,
/cdrom/cdrom0  on x86
systems

The Solaris CD is not
managed by Volume
Management

Where you mounted the
Solaris CD

A copy of the Solaris CD on
the Install Server’s hard
disk (by using
setup_install_server )

Where you specified
setup_install_server
to copy the Solaris CD



Managing Server and Client Support With Host Manager 73

6

8. Select Save Changes from the File menu to convert the standalone system
to an OS Server.
The converted standalone systems are displayed as OS servers in the Host
Manager main window.

Example of Completed Convert Window
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▼ How to Add SunOS 4.x OS Services to an OS Server

Note – SunSoft plans to remove support for the SunOS 4.x release in a later
version of the Solstice AdminSuite software.

The high-level steps in this procedure are:

• Determine the OS server to which you want to add SunOS 4.x OS services
for diskless and dataless clients

• Verify that the SunOS 4.x heterogeneous install software is installed
• Install the required SunOS 4.x release software (install4x  command)

1. Log in as root on the OS server to which you want to add SunOS 4.x OS
services for diskless and dataless clients.

2. Verify that the SunOS 4.x heterogeneous install software is installed.

If the package information is displayed, proceed to Step 7. If not, go to the
next step.

3. Insert the Solaris 2.x CD into your CD-ROM drive.
This step assumes that your system is running Volume Management.

Note – Use the Solaris 2.x CD that matches the Solaris 2.x release that is
installed on the OS server. For example, use the Solaris 2.4 11/94 CD if the OS
server is running the Solaris 2.4 11/94 release.

To access the SunOS 4.x CD from another system running either the Solaris
2.x release or the SunOS 4.x release, see “Setting Up the CD-ROM Drive for
install4x ” in the Solaris 1.x to 2.x Transition Guide.

4. Change directory to the location of the software.

# pkginfo SUNWhinst

# cd /cdrom/cdrom0/s0/Solaris_2. x
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5. Install the SunOS 4.x heterogeneous install software.

6. Eject the Solaris 2.x CD.

7. Insert the SunOS 4.x release CD into your CD-ROM drive.
This step assumes that your system is running Volume Management, and
the CD-ROM drive is directly attached to the server. Volume Management
automatically mounts the CD directory on /cdrom/volume1/s0.

# pkgadd -d ‘pwd‘ SUNWhinst

# cd
# eject cd
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8. Start the SunOS 4.x release software installation program.

The main menu is displayed.

# /usr/sbin/install4x -m /cdrom/volume1/s0 -e /export

                         *** 4.1* Install Main Menu ***

     Choose an Architecture (then select modules to load):

                                          Modules
                                     Loaded    Selected
     [a] sun4.sun4c.sunos.4.1.2         0          0
     [b] sun4.sun4.sunos.4.1.2          0          0
     [c] sun4.sun4m.sunos.4.1.2         0          0

   or begin the loading process for all selected modules:

     [L] Load selected modules

   or abort without loading any modules:

     [Q] Quit without loading                               +-------------------+
                                                            | Disk Usage:       |
   Type any bracketed letter to select that function.       |       0K Selected |
                                                            |   53634K Free     |
   Type ? for help.                                         +-------------------+
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9. On the main menu, specify the architecture you want to support by typing
the associated character that is shown in brackets.
The Module Selection menu is displayed.

10. Select modules to load by typing the associated character that is shown in
brackets.
The Module Selection screen readily enables you to pick groups of modules
to be loaded. When you enter a 1, it marks all required modules for loading.
When you enter a 2, it marks all recommended modules. When you enter a
3, it marks all commonly loaded modules. When you enter a 4, it marks all
optional modules. When you enter a 5, it marks all modules shown on the
Module Selection screen.

Select sun4.sun4c.sunos.4.1.2 modules:
  +[a] R proto root................240K  |  [o]   User_Diag................6352K
  +[b] R usr.....................26240K  |  [p]   Manual...................7456K
  +[c] R Kvm......................4832K  | +[q] D TLI........................48K
  +[d] R Install...................936K  |  [r] D RFS.......................912K
   [e] D Networking...............1040K  |  [s] D Debugging................2928K
   [f] D System_V.................4008K  |  [t]   SunView_Programmers......1840K
   [g] D Sys......................5288K  |  [u]   Shlib_Custom.............1376K
   [h] C SunView_Users............2664K  |  [v]   Graphics.................1784K
   [i]   SunView_Demo..............512K  | +[w]   uucp......................608K
  +[j]   Text......................712K  | +[x]   Games....................3136K
   [k]   Demo.....................4264K  |  [y]   Versatec.................5960K
   [l] C OpenWindows_Users.......25936K  |  [z]   Security..................312K
   [m] C OpenWindows_Demo.........4288K  |  [A]   OpenWindows_Programmers.10200K
   [n] C OpenWindows_Fonts........7840K  |

Module     + = already loaded        R = Required     C= Common
Legend:   ** = selected for loading  D = Desirable    Others are optional

Select [a-A] or a Quick-Pick Option:                       +-------------------+
    [1] All Required Modules     [4] All Optional Modules  | Disk Usage:       |
    [2] All Desirable  Modules   [5] All Modules           |       0K Selected |
    [3] All Common Modules                                 |   53634K Free     |
 or [D] (done) to return to the main screen                +-------------------+
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11. Return to the main menu by typing D.
The main menu is displayed.

12. Type L to install the software.
The modules you previously selected are installed.

13. After the modules are installed, press any key to return to the main menu.
The loaded modules are displayed in the main menu.

14. If you want to add support for other architectures, repeat Step 9 through
Step 12. Otherwise, type Q to exit.

                         *** 4.1* Install Main Menu ***

     Choose an Architecture (then select modules to load):

                                          Modules
                                     Loaded    Selected
     [a] sun4.sun4c.sunos.4.1.2         0          4
     [b] sun4.sun4.sunos.4.1.2          0          3
     [c] sun4.sun4m.sunos.4.1.2         0          1

   or begin the loading process for all selected modules:

     [L] Load selected modules

   or abort without loading any modules:

     [Q] Quit without loading                               +-------------------+
                                                            | Disk Usage:       |
   Type any bracketed letter to select that function.       |       0K Selected |
                                                            |   53634K Free     |
   Type ? for help.                                         +-------------------+

Installing module ‘proto root’ [size: 248K]
        in directory /export/exec/proto.root.sunos.4.1.2 ...

Updating server databases ...

Press any key to continue:
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Where to Go From Here

If you want to add SunOS 4.x support for a diskless client, see “How to Add
Support for a Diskless Client” on page 82. If you want to add SunOS 4.x
support for a dataless client, see “How to Add Support for a Dataless Client”
on page 85.
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▼ How to Add Solaris 2.x OS Services to an OS Server

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Select an OS server to modify from the Host Manager main window.

3. Select Modify from the Edit menu on the Host Manager window.
The Modify window is displayed.

4. Click on the Add button in the OS Services window to add services.

5. Click on Set Media Path to identify the path to the Solaris CD image from
which to add the client services.
The Install Server defaults to the current host. Select Other from the Install
Server menu to specify another host as the install server.

6. Specify the type of services you want to add and click on Add.

7. Click on OK on the Add window.

8. Select Save Changes from the File menu to add services.

If You Are Using ... And ... Then Enter the Path ...

The Solaris CD as the
Solaris CD image

The Solaris CD is
managed by Volume
Management

/cdrom/cdrom0/s0  or
/cdrom/cdrom0/s2  on
SPARC systems,
/cdrom/cdrom0  on x86
systems

The Solaris CD is not
managed by Volume
Management

Where you mounted the
Solaris CD

A copy of the Solaris CD on
the Install Server’s hard
disk (by using
setup_install_server )

Where you specified
setup_install_server
to copy the Solaris CD
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Example of Completed Add OS Services Window

List of OS services
for each platform,
platform group, and
OS Release
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▼ How to Add Support for a Diskless Client

The high-level steps in this procedure are:

• Add system information about the diskless client
• Select OS services for the diskless client
• Boot the diskless client

Note – This procedure assumes the system providing the services (the file
server) has already been configured as an OS server with the /export  and
/export/swap  file systems already created.

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Select Add from the Edit menu on the Host Manager main window.
The Add window is displayed.

3. Fill in the system information, selecting Solaris Diskless as the system
type.
The system information includes all the fields from the host name through
the timezone. If you need information to complete a field, click on the Help
button to see field definitions for this window.

4. Select a File Server.
The File Server defaults to the current host. Select Other from the Install
Server menu to specify another host as the install server.

5. Select the client’s architecture type and the OS release from the OS
Release menu.
The architecture type must match the diskless client’s architecture and the
OS release should match the Solaris release you want diskless client to run.

6. Identify the system’s root path, swap path, and swap size.

7. Click on OK on the Add window.

8. Select Save Changes from the File menu to add support for the diskless
client.
The diskless client is displayed in the Host Manager main window. It takes
several minutes to add the diskless client support, particularly to create the
system’s root and swap areas.
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9. (If necessary) Start the appropriate client daemons on the file server after
the system information has been added successfully.

10. Boot the diskless client.

11. Provide the following system configuration information for the diskless
client during the initial boot process, if prompted.
• Geographic region
• Time zone
• Date and time

12. Create a root password when prompted.

# /etc/init.d/nfs.server start

ok boot net
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Example of Completed Add Window for a Diskless Client
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▼ How to Add Support for a Dataless Client

The high-level steps in this procedure are:

• Add system information about the dataless client
• Select OS services for the dataless client
• (Optional) Set up remote install capabilities for the dataless client
• (Optional) Boot and install the dataless client

Note – This procedure assumes the system providing the services (the file
server) has already been configured as an OS server.

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Select Add from the Edit menu on the Host Manager main window.
The Add window is displayed.

3. Fill in the system information, selecting Solaris Dataless as the system
type.
The system information includes all the fields from the host name through
the time zone. If you need information to complete a field, click on the Help
button to see field definitions for this window.

4. Select a File Server.
The File Server defaults to the current host. Select Other from the Install
Server menu to specify another host as the install server.

5. Select the system’s architecture type and OS release from OS Release
menu.
The architecture type must match the dataless client’s architecture and the
OS release should match the Solaris release you want the dataless client to
run.

6. If you want to set up remote install capabilities for the system, continue
to Step 7. If not, skip to Step 11.

7. Click on Enable Remote Install.

8. Select an Install Server.
The Install Server defaults to the current host. Select Other from the Install
Server menu to specify another host as the install server.
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9. Click on Set Media Path to identify the path to the Solaris CD image on
the install server.

Note – The path to the Solaris CD image must be the same release that you
specified in the OS Release menu.

10. If necessary, specify a boot server or profile server.
To specify another server other than the default, select Other from the menu.
Select a Profile Server from the Profile Server pull-down menu. You must
also specify a path to the boot software on the boot server or the custom
JumpStart directory on the profile server.

11. Click on OK on the Add window.

12. Select Save Changes from the File menu to add support for the dataless
client.
The dataless client is displayed in the Host Manager main window.

13. (Optional) Boot and install the dataless client.
For more information about booting and installing, see SPARC: Installing
Solaris Software for SPARC systems or x86: Installing Solaris Software for x86
systems.

If You Are Using ... And ... Then Enter the Path ...

The Solaris CD as the
Solaris CD image

The Solaris CD is
managed by Volume
Management

/cdrom/cdrom0/s0  or
/cdrom/cdrom0/s2  on
SPARC systems,
/cdrom/cdrom0  on x86
systems

The Solaris CD is not
managed by Volume
Management

Where you mounted the
Solaris CD

A copy of the Solaris CD on
the Install Server’s hard
disk (by using
setup_install_server )

Where you specified
setup_install_server
to copy the Solaris CD
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Example of Completed Add Window for a Dataless Client
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Maintaining Server and Client Support

Table 6-5 Task Map: Maintaining Server and Client Support

Activity Description For Instructions, Go To

Modify Support for
a System

Modify support for a system by choosing Modify from
the Host Manager’s Edit menu.

▼ How to Modify
Support for a
System

page 89

Delete Support for a
System

Delete support for a system by choosing Delete from
the Host Manager’s Edit menu.

▼ How to Delete
Support for a
System

page 89
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▼ How to Modify Support for a System

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Select a system entry to modify from the Host Manager main window.

3. Choose Modify from the Edit menu.
The Modify window contains the selected system entry.

4. Modify support for the system.
If you need information to change a field, click on the Help button to see
field definitions for this window.

5. Click on OK on the Modify window.

6. Select Save Changes from the File menu to modify support for the system.

▼ How to Delete Support for a System

1. Start Host Manager from the Solstice Launcher and select the name
service, if not done already.
See “How to Start Host Manager” on page 66 for more information.

2. Select a system entry to delete from the Host Manager main window.

3. Select Delete from the Edit menu.
A window is displayed asking you to confirm the deletion.

4. Click on OK.

5. Select Save Changes from the File menu to delete support for the system.
The system entry is deleted from the Host Manager main window.
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Managing Network Service Files
with Database Manager 7

This chapter describes how to manage network services by using Database
Manager, a graphical user interface within the Solstice AdminSuite software
used to manage network-related system files.

This is a list of the step-by-step instructions in this chapter.

See Chapter 14, “Database Manager Reference,” for additional information on
Database Manager’s menus and menu commands.

How to Start Database Manager page 93

How to Add a System File Entry page 95

How to Modify a System File Entry page 96

How to Delete a System File Entry page 97
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Overview of Database Manager
Database Manager is primarily used to manage the network-related system
files since other tools are used to manage user, client system, serial ports, and
printer-related files.

Using Database Manager to add an entry to a system file usually managed by
another tool can save time. For example, Host Manager requires you to enter
the Ethernet address when adding a standalone system even though you may
want to use this system for remote copy and login only. However, the Ethernet
address is not required when you use Database Manager to update the hosts
file.

Caution – It is important that you do not bypass critical information when
providing services to users and client systems. Use caution when using
Database Manager to update system files normally managed by other tools.!
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Managing Network Services Files
The following section describes how to use Database Manager to manage
network services files.

▼ How to Start Database Manager

1. Verify that the steps described in Chapter 1, “Introduction” are met.

2. Type solstice &  from a Command or Shell tool prompt and press
Return.
The Solstice Launcher is displayed.

3. Click the Database Manager icon.
The Load Database window is displayed.

4. Select the name service used in your network.

5. Check that the domain or host name is correct.
If not, type the domain or host name you need to access.

6. Select the file you want to display.
Select the aliases  file, for example.

7. Click on OK.
The Database Manager main window is displayed with the file contents
displayed.
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Example

This example shows that the aliases  file has been selected and displayed.
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▼ How to Add a System File Entry

1. Start Database Manager from the Solstice Launcher, select the name
service, and the system file to be displayed, if not done already.
See the procedure on page 93 for information about starting Database
Manager.

2. Select Add from the Edit menu in the Database Manager main window.
The Add window is displayed.

3. Fill out the Add window.
If you need information to complete a field, click on the Help button to see
field definitions for the system file.

4. Click on OK.

Verification

Verify that the entry has been added by locating the new entry in the Database
Manager’s main window.

Example

The following is an example a completed Add window where a mail alias has
been added to the aliases  file.
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▼ How to Modify a System File Entry

Caution – Notify users before you modify their work environment.

1. Start Database Manager from the Solstice Launcher and select the name
service, if not done already.
See the procedure on page 93 for information about starting Database
Manager.

2. Select a system file to modify in the Database Manager main window.

3. Select Modify from the Edit menu.
The Modify window is displayed.

4. Fill out the Modify window.
If you need information to modify a field, click on the Help button to see
field definitions for the system file.

5. Click on OK when finished.

Verification

Verify that the entry has been modified by locating the entry in the Database
Manager’s main window.

Example

The following is an example of the Modify window and a selected system file
entry.

!
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▼ How to Delete a System File Entry

1. Start Database Manager from the Solstice Launcher and select the name
service, if not done already.
See the procedure on page 93 for information about starting Database
Manager.

2. Select an alias entry to delete in the Database Manager main window.

3. Select Delete from the Edit menu.
A window is displayed asking you to confirm the deletion.

4. Click on OK if you really want to delete the system file entry.

Verification

Verify that the system file has been updated in the Database Manager’s main
window.

Example

The following is an example of a Database Manager Delete verification
window.
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Managing Terminals and Modems
with Serial Port Manager 8

Modems and terminals provide both local and remote access to system and
network resources. Maintaining this access with Serial Port Manager, a
graphical user interface within the Solstice AdminSuite software, is an
important responsibility of a system administrator.

This is a list of the step-by-step instructions in this chapter.

See Chapter 15, “Serial Port Manager Reference,” for additional information on
Serial Port Manager’s menus and menu commands.

How to Start Serial Port Manager page 103

How to Add a Terminal page 104

How to Add a Modem page 105

How to Initialize a Port Without Configuring page 107

How to Disable a Port page 107

How to Delete a Port Service page 108
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Overview
Serial Port Manager is a Solstice AdminSuite application used for adding and
maintaining port services for terminals and modems.

The Serial Port Manager configures the serial port software to work with
terminals and modems by calling the pmadm command and supplying the
appropriate information. It features:

• Displays of serial port information
• Templates for common terminal and modem configurations
• Multiple port setup, modification, or deletion

Terminal and Modem Template Default Values

Table 8-1 shows the default values that the Terminal – Hardwired template
provides.

Table 8-1 Terminal – Hardwired Default Values

Detail Item Default Value

Basic Port —

Service Enabled

Baud Rate 9600

Terminal Type tvi925

More Option: Initialize Only no

Option: Bidirectional no

Option: Software Carrier yes

Login Prompt login:

Comment Terminal – Hardwired

Service Tag —

Port Monitor Tag zsmon

Expert Create utmp  Entry yes

Connect on Carrier no

Service /usr/bin/login

Streams Modules ldterm,ttcompat
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The modem templates provides the following default values.

Timeout (secs) Never

Table 8-2 Modem Default Values

Detail Item Modem – Dial In Only Modem – Dial Out Only Modem – Bidirectional

Basic Port — — —

Service Enabled Enabled Enabled

Baud Rate 9600 9600 9600

Terminal type — — —

More Option: Initialize Only yes no no

Option: Bidirectional no no yes

Option: Software
Carrier

no no no

Login Prompt login: login: login:

Comment Modem – Dial-In Only Modem – Dial-Out Only Modem – Bidirectional

Service Tag — — —

Port Monitor Tag zsmon zsmon zsmon

Expert Create utmp  entry yes yes yes

Connect on Carrier no no no

Service /usr/bin/login /usr/bin/login /usr/sbin/login

Streams Modules ldterm,ttcompat ldterm,ttcompat ldterm,ttcompat

Timeout (secs) Never Never Never

Table 8-1 Terminal – Hardwired Default Values (Continued)

Detail Item Default Value
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The Initialize Only – No Connection template provides the following default
values.

Table 8-3 Initialize Only – No Connection Default Values

Detail Item Default Value

Basic Port —

Service Enabled

Baud Rate 9600

Terminal Type —

More Option: Initialize Only yes

Option: Bidirectional no

Option: Software Carrier no

Login Prompt login:

Comment Initialize Only – No Connection

Service Tag —

Port Monitor Tag zsmon

Expert Create utmp  entry yes

Connect on Carrier no

Service /usr/bin/login

Streams Modules ldterm,ttcompat

Timeout (secs) Never
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▼ How to Start Serial Port Manager

1. Verify that the prerequisite steps described in Chapter 1, “Introduction”
are met.

2. Type solstice &  from a Command or Shell Tool prompt and press
Return.

3. Click the Serial Port Manager icon.
The Serial Port Manager main window is displayed.

4. (Optional) Choose Host from the View menu.

a. Select the host you wish to access using Serial Port Manager.
You can also type in the name of the host in the selection field.

b. Click on OK to access the host using Serial Port Manager.
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▼ How to Add a Terminal

1. Start Serial Port Manager from the Solstice Launcher, if not done already.
See the procedure on page 103 for information about starting Serial Port
Manager.

2. Select the port or ports that will be used with a terminal in the Serial Port
Manager main window.

3. Choose Modify from the Edit menu.
The Modify window is displayed in the Basic Detail mode. (For additional
details, click on More or Expert.)

4. Choose Terminal – Hardwired from the Template menu.

5. Change values of template entries if desired.

6. Click on OK to configure the port.
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▼ How to Add a Modem

1. Start Serial Port Manager from the Solstice Launcher, if not done already.
See the procedure on page 103 for information about starting Serial Port
Manager.

2. Select the port or ports that will be used with a modem from the Serial
Port Manager main window.

3. Choose Modify from the Edit menu.
The Modify window appears in the Basic Detail mode. (For additional
details, select either the More or Expert Detail modes.)

4. Choose the modem configuration from the Template menu that meets or
most closely matches your modem service.
The modem template choices are described here.

See the modem configuration template table on page 101 for the default
values of each template. If a UUCP service will be used to dial in to your
modem on a Solaris 2.x system, see “How to Configure a Modem for Use
With UUCP” on page 106 for the rest of the procedure.

5. Change values of template entries if desired.

6. Click on OK to configure the port.

Table 8-4 Modem Templates

Modem Configuration Description

Modem – Dial In Only Users may dial in to the modem but cannot dial out.

Modem – Dial Out Only Users may dial out from the modem but cannot dial in.

Modem – Bidirectional Users may either dial in or out from the modem.
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▼ How to Configure a Modem for Use With UUCP

UUCP sends information using seven bits and even parity. Solaris software
modem configurations use eight bits and no parity for internationalization
purposes. To set up your modem service to work with UUCP, follow these
instructions.

1. Start Serial Port Manager from the Solstice Launcher, if not done already.
See the procedure on page 103 for information about starting Serial Port
Manager.

2. From the Serial Port Manager main window, select the port or ports that
will be used with a modem.

3. Choose Modify Service from the Edit menu.
The Modify Service window appears in the Basic Detail mode. (For
additional details, select either the More or Expert Detail modes.)

4. Choose the modem configuration from the Template menu that meets or
most closely matches your modem service.

5. Select Other from the Baud Rate menu.

6. Enter a baud rate value from the /etc/ttydefs  file that provides seven
bit, even parity service and click on OK.

In this example, the 9600E baud rate was selected. This provides a service
with a 9600 baud rate, seven bits, and even parity.

7. Change values of other template entries if desired.

8. Click on OK to configure the port.
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▼ How to Initialize a Port Without Configuring

1. Start Serial Port Manager from the Solstice Launcher , if not done already.
See the procedure on page 103 for information about starting Serial Port
Manager.

2. Choose Modify from the Edit menu.
The Modify window appears in the Basic Detail mode. See Table 8-3 on
page 102 for default values of the Basic, More, or Export Detail modes.

3. Choose Initialize Only – No Connection from the Template menu.

4. Click on OK to initialize the port.

▼ How to Disable a Port

1. Start Serial Port Manager from the Solstice Launcher, if not done already.
See “How to Start Serial Port Manager” on page 103 for information about
starting Serial Port Manager.

2. Select the port or ports that you want to disable from the Serial Port
Manager main window.

3. Choose Modify from the Edit menu.

4. Select the Service Enable item in the Modify window to disable the port.
The other items in the Modify window will turn gray when the port service
is disabled.

5. Click on OK to disable the port.
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▼ How to Delete a Port Service

1. Start Serial Port Manager from the Solstice Launcher, if not done already.
See the procedure on page 103 for information about starting Serial Port
Manager.

2. Select the port or ports with a service you want to delete from the Serial
Port Manager main window.

3. Choose Delete from the Edit menu. A window is displayed asking you to
confirm that the service should be deleted.

4. Click on OK when you are ready to delete the service.
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Setting Up SunSoft Print Client
Software With Printer Manager 9

This chapter provides the procedures for setting up and managing the SunSoft
print client software by using the Printer Manager application, a graphical user
interface within the Solstice AdminSuite software.

This is a list of the step-by-step instructions in this chapter.

Note – The Printer Manager tasks are only part of what you need to know to
effectively set up and manage the SunSoft print client software. The Solstice
AdminSuite 2.1 Print Administration Guide provides an overview that helps you
understand the SunSoft print process. It also contains task information about
converting the configuration information for existing printers and copying the
information to SunSoft print clients.

How to Start Printer Manager page 111

How to Install a Printer page 113

How to Add Access to a Printer page 116

How to Modify Printer Information page 119

How to Delete Access to a Printer page 122

How to Delete a Printer From a Print Server (If No Name Service) page 123

How to Find a Printer Entry page 124
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For high-level information on print administration, see Chapter 16, “Printer
Manager Reference.” For step-by-step instructions on administering printing,
see the System Administration Guide, Volume II.

You can set up printing by using LP print service commands instead of Printer
Manager. For detailed examples, see the System Administration Guide, Volume II.

Setting Up and Managing SunSoft Print Client Software
Table 9-1 gives you an overview of the tasks for using Printer Manager to set
up and manage printing services with the SunSoft print client software.

Table 9-1 Task Map: Setting Up and Managing SunSoft Print Client Software

Activity Description For Instructions, Go To

Install a Printer on
a Print Server

Install a Printer
Install a printer on the system to which it is attached. This
procedure tells the system about the printer so the system
can act as a print server. If you use a name service, this
task also makes the printer available to all SunSoft print
clients.

▼ How to Install a
Printer

page 113

Give Print Clients
Access to a Printer

Add Access to a Printer
Give SunSoft print clients access to a printer that is
installed on a print server.

▼ How to Add Access
to a Printer

page 116

Modify Existing
Information for a

Printer

Modify Printer Information
Modify the current configuration information for a printer.

▼ How to Modify
Printer Information

page 119
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Starting Printer Manager
You use Printer Manager to complete all the tasks necessary to set up and
maintain the SunSoft print client software, so the first thing to do is start the
Printer Manager application with Solstice AdminSuite.

▼ How to Start Printer Manager

1. Verify that the following prerequisites are met. To use the Solstice
AdminSuite software, you must have:
• A bit-mapped display monitor. The Solstice AdminSuite software can be

used only on a system with a console that is a bit-mapped screen such as
a standard display monitor that comes with a Sun workstation.
If you want to perform administration tasks on a system with an ASCII
terminal as the console, use Solaris commands instead.

• OpenWindows software. Start this software with the following command:

• Membership in the sysadmin group (Group 14).

Delete Access to a
Printer

Delete Access to a Printer
Delete access to a printer from the NIS or NIS+ master file
or from each specified print client’s
/etc/printers.conf  file if you do not use a name
service.

▼ How to Delete
Access to a Printer

page 122

Delete a Printer From a Print Server
Delete a printer from the print server’s
/etc/printers.conf  file. This step applies only if you
are not using a name service.

▼ How to Delete a
Printer From a Print
Server (If No Name
Service)

page 123

Find a Printer
Entry in the

Scrolling List

Find a Printer Entry
Find the entry for a printer in the scrolling list of printers in
the Printer Manager main window.

▼ How to Find a
Printer Entry

page 124

$ /usr/openwin/bin/openwin

Table 9-1 Task Map: Setting Up and Managing SunSoft Print Client Software
(Continued)



112 Solstice AdminSuite 2.1 User’s Guide—November 1995

9

• The required access privileges for managing the NIS or NIS+ database. If
your name service is NIS+, you must be a member of the NIS+ admin
group.

• Federated Naming Service (FNS) software.
• If your name service is NIS+, you must initialize the NIS+ namespace to

use FNS by entering the following command:

This command creates the organization context and default subcontexts for
an existing NIS+ domain. It also creates NIS+ tables and directories in the
NIS+ hierarchy.

2. Log in as yourself.
You should use the Solstice AdminSuite software as a regular user who has
membership in the sysadmin group rather than as root.

3. Start the Solstice Launcher.

The Solstice Launcher window is displayed.

4. Click on the Printer Manager icon to start the application.

The Load window is displayed as an overlay on the Printer Manager main
window.

5. Select the name service used in your network.
Choices are: NIS+, NIS, or None.

6. Check that the domain or host name is correct.
If not, type the name of the domain or host name you need to access.

$ fncreate -t org org//

$ solstice &
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7. Click on OK.
The Printer Manager main window is displayed by itself after you click on
OK.

Installing a Printer
When you use Printer Manager to install a printer on a system, you define the
characteristics of the printer and identify the users who are permitted to access
it. The system on which you install the printer becomes the print server.

Installing a printer means something different depending on whether you use
a name service.

▼ How to Install a Printer

1. Connect the printer to a system and turn on the power to the printer.
Consult the printer vendor’s installation documentation for information
about the hardware switches and cabling requirements.

2. Start Printer Manager.
When you log in:

• If your name service is NIS or NIS+, you can log in on any system on the
network because you’ll be able to specify the system on which you are
installing the printer.

• If you are not using a name service, you can log in on any system on the
network and change the host name in the Load window to the name of the
system to which you attached the printer.

For detailed information about starting Printer Manager, see the procedure
on page 111.

If You ... Then Printer Manager ...

Use a name service Adds the printer in the NIS or NIS+ master file, and
the printer is available to all SunSoft print clients.

Don’t use a name service Adds the printer in the print server’s configuration
files only, and print clients do not know about the
printer.
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3. Select Install Printer from the Edit menu.
The Install Printer window is displayed.

4. Fill in the window.
If you need information to complete a field, click on the Help button to see
field definitions for this window.

5. Click on OK.
If you are using NIS or NIS+, the printer is entered in the name service
master file and all SunSoft print clients have access to it. The printer is also
entered in the print server’s /etc/printers.conf  file and /etc/lp
directory.

If you are not using a name service, the printer is entered in the print
server’s /etc/printers.conf  file and /etc/lp  directory.

Verification

Verify that the printer has been installed by checking for the new printer entry
in the Printer Manager main window.
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Example of a Completed Install Printer Window

This example shows the Install Printer window when Printer Manager was
loaded with a name service. If you use a name service, you can specify any
system on the network as the print server in this window.

If you are not using a name service, the Print Server field displays the host
name you specified in the Load window, and you cannot change the name of
the print server in this window.
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Adding Access to a Printer
When you give a system access to a printer that is attached to a print server,
that system becomes a print client. You may not need to add access for SunSoft
print clients depending on whether you installed the printer through Printer
Manager and whether you use a name service.

▼ How to Add Access to a Printer

1. Start Printer Manager.
You can add access to a printer from any system on the network.

• If you use a name service, you don’t need to specify print clients. You add
access to the printer for all SunSoft print clients on the network.

• If you don’t use a name service, you will be able to specify the print
clients to be given printer access.

For detailed information about starting Printer Manager, see the procedure
on page 111.

If You Installed the Printer
Through ... Then ...

Printer Manager and you have
a name service

The printer is already available to all SunSoft print
clients. You don’t need to add access to the printer.

Printer Manager and you
don’t have a name service

You need to add access to the printer for SunSoft
print clients.

UNIX commands and you
have a name service

Unless you converted information for this printer
from a SunOS 5.x or 4.x system and loaded NIS or
NIS+, the printer is not listed in the name service.
You need to add access to the printer so it will be
entered in the name service and made available to
all SunSoft print clients.

UNIX commands and you
don’t have a name service

Unless you converted information for this printer
from a SunOS 5.x or 4.x system and copied the
master /etc/printers.conf  file to print clients,
you need to add access for SunSoft print clients. (If a
print client had access previously, that access has
been erased.)
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2. Select Add Access to Printer from the Edit menu.
The Add Access to Printer window is displayed.

3. Fill in the window.
If you need information to complete a field, click on the Help button to see
field definitions for this window.

4. Click on OK.
If your name service is NIS or NIS+, the printer is entered in the name
service master file and all SunSoft print clients have access to it.

If your name service is None, the printer is entered in the
/etc/printers.conf  file of each print client you specified.

Verification

Verify that the access has been added by submitting a print request from the
print client and checking the printer for output.
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Example of a Completed Add Access to Printer Window

In this example, the network does not use a name service, so the window
contains the Print Clients field. This field enables you to specify the print
clients to be given access to the specified printer. If the name service is NIS or
NIS+, the window does not contain the Print Clients field.
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Modifying Printer Information
After you’ve installed a printer through Printer Manager, you can modify some
of the information originally entered. You can also set two additional options
that control the printer’s ability to accept and process print requests.

The Modify window of Printer Manager has two versions. On the short
version, you can change only the printer description and whether the printer is
set up as the default printer. You’ll see the short window if:

• You don’t use a name service and the printer is not local to the print server.

• You are not a member of the sysadmin group (Group 14), regardless of your
name service selection.

• The print server does not have the Solstice AdminSuite software.

Otherwise, you’ll get the long version of the window, where you can change
more information and set the options for accepting and processing print
requests.

Note – You can’t change certain printer information even on the long version
of the window. If you need to change the printer name, print server, or printer
type, you’ll have to delete the printer and reinstall it. For these procedures, see
“Deleting Access to a Printer” on page 122 and “Installing a Printer” on
page 113.

▼ How to Modify Printer Information

1. Start Printer Manager.
You can log in on any system on the network. For detailed information
about starting Printer Manager, see the procedure on page 111.

2. Select the printer that you want to modify from the scrolling list in the
Printer Manager main window.

3. Select Modify from the Edit menu or double-click on the printer in the
scrolling list.
The short version or the long version of the Modify window is displayed.
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4. Fill in the window.
If you need information to complete a field, click on the Help button to see
field definitions for this window.

5. Click on OK.

Verification

Verify that the printer information has been changed by reloading Printer
Manager and checking for your changes, as follows:

1. Select Load from the File menu.
The Load window is displayed.

2. Leave the settings as they are, and click on OK.
The Printer Manager main window is displayed.

3. Select the printer you just modified from the scrolling list in the Printer
Manager main window.

4. Select Modify from the Edit menu.
The Modify window is displayed.

5. Check to see if your changes to the printer information are displayed.
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Example of a Completed Modify Window

This example shows the long version of the Modify window. The short version
contains only four fields—it displays the printer name and print server, and
enables you to change the printer description and default printer selection.
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Deleting Access to a Printer
The only way to change the name, print server, or printer type originally
assigned to a printer is to delete the printer and reinstall it using new
information.

If you need to move, replace, or reinstall a printer with new information, you
should first make sure that all the print requests in the printer’s queue are
printed or moved to another printer. You must also delete print clients’ access
to the printer and delete the printer from the print server before you physically
detach the printer from the print server.

If your name service is NIS or NIS+, you delete access to a printer and delete
the printer from the print server at the same time.

If you are not using a name service, you must first delete access to a printer for
each print client and then delete the printer from the print server as a separate
task.

▼ How to Delete Access to a Printer

1. Start Printer Manager.
You can log in on any system on the network to delete access to a printer.

• If your name service is NIS or NIS+, you won’t need to specify print
clients. You delete access to the printer for all SunSoft print clients on the
network and delete the printer from the print server at the same time.

• If you are not using a name service, you can log in on any system on the
network and change the host name to the name of the print client for
which you want to delete printer access.

For detailed information about starting Printer Manager, see the procedure
on page 111.

2. Select the printer for which you want to delete access from the scrolling
list in the Printer Manager main window.

3. Select Delete from the Edit menu.
The Warning window is displayed. It contains a prompt asking you to verify
that you really want to delete the printer.
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4. Click on OK.
If your name service is NIS or NIS+, the printer is deleted from the name
service master file and access is removed for all print clients. The printer is
also deleted from the print server’s /etc/printers.conf  file and
/etc/lp  directory.

If you are not using a name service, the printer is deleted only from this
print client’s /etc/printers.conf  file. You must repeat steps 1 through 4
to delete access to the printer for other SunSoft print clients.

Verification

If your name service is NIS or NIS+, verify that the printer has been deleted
from the name service by making sure that the printer is not listed in the
Printer Manager main window.

If you are not using a name service, verify that the print client’s access has
been deleted by making sure that the printer is not listed in the Printer
Manager main window.

▼ How to Delete a Printer From a Print Server (If No Name Service)

1. Start Printer Manager.
You can log in on any system on the network to delete a printer from a print
server. Select None as the name service and change the host name to the
name of the print server.

For detailed information about starting Printer Manager, see the procedure
on page 111.

2. Select the printer to be deleted from the scrolling list in the Printer
Manager main window.

3. Select Delete from the Edit menu.
The Warning window is displayed. It contains a prompt asking you to verify
that you really want to delete the printer.
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4. Click on OK.

The printer is deleted from the print server’s /etc/printers.conf  file
and /etc/lp  directory.

Verification

Verify that the printer has been deleted from the print server by making sure
that the printer is not listed in the Printer Manager main window.

Finding a Printer Entry
If your site has many printers, you’ll have a long list of printer entries in the
Printer Manager main window. The Find window helps you search for a
specific printer quickly and accurately.

▼ How to Find a Printer Entry

1. Start Printer Manager.
You can log in on any system on the network. For detailed information
about starting Printer Manager, see “How to Start Printer Manager” on
page 111.

2. Select Find from the View menu.
The Find window is displayed.

3. Type the complete printer name if you know it. Otherwise, type a partial
printer name and use asterisks as wildcard characters.
For example, you might type sat*  if you’re not sure whether the printer
name is satellite  or saturn .

4. Click on OK.
If you typed a complete printer name, the entry for that printer is
highlighted.

If you typed a partial printer name with a wildcard, the first printer entry
that matches your search string is highlighted. Using the above example
where you typed sat* , the satellite  entry would be highlighted.
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5. (Optional) If you typed a partial printer name with a wildcard, click the
Apply button to find the next printer entry that matches your search
string.

Verification

Verify that you have found the correct printer by checking the information in
the highlighted entry in the Printer Manager main window.

Example of a Completed Find Window

Where to Go From Here
After you have set up the systems at your site to use the SunSoft print client
software, users may also want to set up their ~/.printers  home directory to
contain custom printer aliases.

For step-by-step instructions on these tasks, see the Solstice AdminSuite 2.1 Print
Administration Guide in the Solstice AdminSuite AnswerBook.
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Part 3 —  Solstice AdminSuite 2.1
Reference

This part provides reference information on the Solstice Launcher and the
individual Solstice AdminSuite applications. This part contains these chapters.

General Solstice AdminSuite Tool Reference
Provides reference information on items that appear in all Solstice
AdminSuite applications.

Group Manager Reference
Provides reference information on the Group Manager application.

User Manager Reference
Provides reference information on the User Account Manager application.

Host Manager Reference
Provides reference information on the Host Manager application.

Database Manager Reference
Provides reference information on the Database Manager application.

Serial Port Manager Reference
Provides reference information on the Serial Port Manager application.

Printer Manager Reference
Provides reference information on the Printer  Manager application.
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General Solstice AdminSuite Tool
Reference 10

This chapter contains reference information for items found in all tools within
the Solstice AdminSuite software.

This is a list of the reference information in this chapter.

Main Windows page 130

Filtering Entries page 131

Typing in Text Boxes page 132

Buttons page 132
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Main Windows
Each application has a main (or base) window that looks similar to the
Database Manager main window.

The main window contains two areas: a menu bar and a display area.

The menu bar usually contains four menus: File, Edit, View, and Help.

Menu Bar

Display Area
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Filtering Entries
Each of the administration applications (except Host Manager, Serial Port
Manager, and Printer Manager) provides a means of filtering entries if you do
not want to see all of the entries in a system file. You can specify a filter by
clicking on the Filter menu. For example:

Table 10-1 describes the different filtering commands.

After you have selected a name service and a method for filtering entries that
are displayed, click on OK. The tool’s main window is displayed.

Table 10-1 Filtering Commands

Use This Command ... To ...

All Display all file entries. This is the default setting.

Specify Specify a text string that displayed file entries must match.
Specifying wildcards is acceptable. This option is helpful if
you want to focus on a small number of entries.

None Turn off file entry display. This is helpful if you only want to
add new entries and have no interest in viewing existing
entries.

Filtering Commands
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Typing in Text Boxes
The Add window from Group Manager illustrates the text boxes used for
typing text in a tool window.

Caution – Do not press Return when finished typing in a text box. Pressing
Return is the same as clicking on OK and may result in an incomplete entry.
Use the mouse pointer or the Tab key to select a new text box.

Buttons
The Add window shown also illustrates some of the buttons used in the
application windows. Table 10-2 describes when to use each button.

Table 10-2 Solstice AdminSuite Buttons

This Button ... Is Used To ...

OK Complete a task so that it can be processed. The window is
closed after the task is completed.

Apply Complete a task but leave the window open. (Not available on
all windows.)

Reset Erase any text entered in a field and revert to original contents.

Cancel Cancel the task and close the window.

Help Access the help system.

!
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Group Manager Reference 11

This chapter provides reference information for Group Manager, a graphical
interface used to manage groups.

This is a list of the reference information in this chapter.

Using Group Manager page 134

Files Modified by Group Manager page 137
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Using Group Manager

When to Use Group Manager

Group Manager can be used to display, add, modify, and delete groups in the
NIS or NIS+ name service environment or on a local or remote system (/etc
files).

Requirements for Using Group Manager

The requirements for using Group Manager are:

• A bit-mapped display monitor
• Ability to use the OpenWindows environment
• Required access privileges as described in Chapter 1, “Introduction”

Where to Find Specific Task Information

Table 11-1 contains references for Group Manager tasks.

Table 11-1 Group Manager Task References

Task Location

How to Start Group Manager page 39

How to Add a Group page 41

How to Modify a Group page 49

How to Delete a Group page 50
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Window, Menu, and Command Descriptions
The following section describes Group Manager’s windows, menus, and
commands.

Group Manager Main Window

The Group Manager main window is displayed after you click on the Group
Manager icon on the Solstice Launcher. The main window contains the File,
Edit, View and Help menus. The existing group entries are displayed.

Group Manager File Menu

The File Menu enables you to load group entries and exit Group Manager.

Load Window

When you start Group Manager or select Load from the File menu, the Load
window is displayed. This window is used to select:

• The appropriate name service for your environment. See Chapter 2, “Using
Solstice AdminSuite in a Name Service Environment,” for information on
selecting a name service.

• The amount of group information to be displayed in the Group Manager
main window.

After you have selected a name service and a method for filtering the group
entries that are displayed, click on OK. The group information is loaded and
the Group Manager main window is displayed.

Exit Command

The Exit command enables you to exit Group Manager.
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Group Manager Edit Menu

The Edit Menu enables you to add, modify, and delete groups.

Add Window

The Add window enables you to create a new group. Enter the new group
name, the new group ID, and a list of group members in the text boxes
displayed.

Modify Window

The Modify window enables you to change the group’s name or the users in
the group. You cannot change the group ID.

Delete Window

The Delete window enables you to delete a group.

Group Manager View Menu

The View menu enables you to find and sort group entries.

Find Window

The Find window enables you to search for a group entry. This feature is useful
when searching for a particular group in a large list of group entries, which is
usually the case in a large NIS or NIS+ environment.

You can search by group name, and you can use wildcards to match text
strings. The specified group entry is highlighted in the main window, if found.

Sort By Command

The Sort By command enables you to sort the list of groups by group name,
group ID, or members list. The default display is sorted by group name.
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Rebuild List Command

The Rebuild List command enables you to reload all current group entries in
the selected name service.

Group Manager Help Menu

The Help menu enables you to access the online help that describes Group
Manager functions and requirements. See “Using Admin Help” on page 6 for
more information.

Files Modified by Group Manager
Table 11-2 lists the files Group Manager modifies depending on what name
service you selected.

Table 11-2 Files Modified by Group Manager

If the Name Service You Selected Is ... Then Group Manager Modifies The ...

NIS or NIS+ Name service’s group  file

None /etc/group  file
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User Manager Reference 12

This chapter provides reference information for User Manager, a graphical
interface used to manage user accounts.

This is a list of the reference information in this chapter.

Using User Manager page 140

Window, Menu, and Command Descriptions page 141

Files Modified by User Manager page 144
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Using User Manager

When to Use User Manager

User Manager can be used to perform the following tasks:

• Add, modify, and delete user account entries in the NIS or NIS+ name
service environment or on a local or remote system (/etc  files)

• Copy user account information to facilitate the creation of user accounts
with similar characteristics

• Modify user account information such as adding password aging features

Requirements for Using User Manager

The requirements for using User Manager are:

• A bit-mapped display monitor
• Ability to use the OpenWindows environment
• Required access privileges as described in Chapter 1, “Introduction.”

Where to Find Specific Task Information

Table 12-1 contains references for User Manager tasks.

Table 12-1 User Account Task References

Task Location

How to Start User Manager page 42

How to Set Up User Account Defaults page 44

How to Add a New User Account page 45

How to Copy an Existing User Account page 47

How to Modify a User Account page 51

How to Delete a User Account page 53
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Window, Menu, and Command Descriptions

User Manager Main Window

The User Manager main window is displayed after you click the User Manager
icon on the Solstice Launcher and select a name service. The main window
contains the File, Edit, View and Help menus. The existing user account entries
are also displayed.

User Manager File Menu

The File menu enables you to load user account entries and exit User Manager.

Load Window

When you start User Manager or choose Load from the File menu, the Load
window is displayed. This window is used to select:

• The appropriate name service for your environment. See Chapter 2, “Using
Solstice AdminSuite in a Name Service Environment” for information on
selecting a name service.

• The amount of user information to be displayed in the User Manager main
window.

After you have selected a name service and a method for filtering the user
entries that are displayed, click on OK. The user account information is loaded
and the User Manager main window is displayed.

Exit Command

The Exit command enables you to exit User Manager.

User Manager Edit Menu

The Edit Menu enables you to add, copy, modify, and delete user accounts. It
also provides a command to set defaults for adding user accounts.



142 Solstice AdminSuite 2.1 User’s Guide—November 1995

12

Add Window

The Add window enables you to add a user account. The password aging
features in the Account Security section on the Add window will not appear if
you are adding the user to the NIS password database.

Modify Window

The Modify window enables you to modify selected user account information
such as the account security features. The Modify window cannot be used to
change the user ID. Instead, select Delete from the Edit menu to delete the user
account, and then re-add the user account with the new user ID.

Copy Window

The Copy window enables you to create a user account by copying selected
information from an existing user account. This feature is useful when you
need to create several similar user accounts.

The display information is copied from the existing user account. These values
may require editing for the new account. The user name, user ID, and
password are not copied because they should be unique.

Set Defaults Window

The Set Defaults window enables you to modify the default values in the Add
window. This can increase the consistency and efficiency of adding new user
accounts.

Delete Window

The Delete window enables you to delete an existing user account. Clicking on
the Delete home directory and Delete mailbox buttons removes the user’s
home directory and mailbox contents. User Manager does not remove files
belonging to the user that are stored in other locations.
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User Manager View Menu

The View Menu enables you to find and sort user account entries.

Find Window

The Find window enables you to search for a user account entry. This feature is
useful when searching for a particular user account in a large list of user
account entries, which is usually the case in a large NIS or NIS+ environment.

You can search by user name, user ID, or comment, but not by combinations of
the items. You can use wildcards to match text strings. The specified user
account entry is highlighted in the main window, if found.

Sort By Command

The Sort By command enables you to sort the user account entries by user
name, user ID, or comment. The default display is sorted by user name.

Rebuild List Command

The Rebuild List command enables you to reload all current user account
entries in the selected name service.

User Manager Help Menu

The Help menu enables you to access the online help that describes User
Manager functions and requirements. See “Using Admin Help” on page 6 for
more information.
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Files Modified by User Manager
Table 12-2 describes the system files that are modified by User Manager.

Table 12-2 Files Modified by User Manager

System File Description

auto_home An indirect automounter map containing entries that enable
client systems to mount their home directories automatically

group A file containing UNIX group entries recognized on the local
system or in a name service

passwd A file containing user account entries such as user name,
user ID, group ID, and home directory

shadow A file containing user password entries in encrypted form
and password aging information

/var/mail/$USER A file used to store the user’s e-mail

/etc/aliases Afile used to store mail addresses for the user

cred.org_dir A NIS+ table used to store the user’s DES and LOCAL
credentials
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Host Manager Reference 13

This chapter provides reference information for Host Manager, a graphical
interface used to manage server and client support.

This is a list of the reference information in this chapter.

Using Host Manager page 146

Window, Menu, and Command Descriptions page 147

Files Modified by Host Manager page 151
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Using Host Manager

When to Use Host Manager

Host Manager can be used to perform the following tasks:

• Add, modify, and delete support for hosts in the NIS or NIS+ name service
environment or on a local or remote system

• Provide support for standalone, diskless, dataless, and OS Server system
types

• Add client services for diskless and dataless systems

• Add remote installation support for standalone, dataless, and OS Server
system types

• Update unknown system types and convert generic system types to
standalone systems or OS servers

Requirements for Using Host Manager

The requirements for using Host Manager are:

• A bit-mapped display monitor
• Ability to use the OpenWindows environment
• Required access privileges as described in Chapter 1, “Introduction”

Where to Find Specific Task Information

Table 13-1 contains references for Host Manager tasks.

Table 13-1 Host Manager Task References

Task Location

How to Start Host Manager page 66

How to Add Support for a Standalone System or OS Server page 69

How to Add Support for a Diskless Client page 82

How to Add Support for a Dataless Client page 85
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Window, Menu, and Command Descriptions

Host Manager Main Window

The Host Manager main window is displayed after you click the Host Manager
icon on the Solstice Launcher and select a name service. The main window
contains the File, Edit, View and Help menus. The existing host entries are also
displayed.

Host Manager File Menu

The File Menu enables you to load host entries and exit Host Manager. It also
enables you to save changes and update system types.

Load Window

When you start Host Manager or select Load command from the File menu, the
Load window is displayed. This window is used to select the appropriate
name service for your environment. See Chapter 2, “Using Solstice AdminSuite
in a Name Service Environment,” for information on selecting a name service.

After you have selected a name service, click on OK. The host information is
loaded and the Host Manager main window is displayed.

Save Changes Command

The Save Changes command applies the pending host information changes
shown at the bottom of the main window.

How to Add Solaris 2.x OS Services to an OS Server page 80

How to Convert a Standalone System to an OS Server page 72

How to Delete Support for a System page 89

Table 13-1 Host Manager Task References (Continued)

Task Location
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Update System Types Command

The Update System Types command converts unknown system types to
known system types.

Note – This needs to be done on existing systems that have not been added by
the Solstice AdminSuite Host Manager.

Exit Command

The Exit command enables you to exit Host Manager.

Host Manager Edit Menu

The Edit Menu enables you to add, copy, modify, and delete support for a host.

Add Window

The Add window enables you to add support for a host. You will see different
fields depending on which system type (standalone, diskless, dataless, OS
Server) you select.

The following windows will display if you select Other from one of the server
menus in the Add window.

• Specify File Server Window
• Specify Install Server Window
• Specify Profile Server Window

These windows enable you to specify a different server.

Modify Window

The Modify window enables you to change support for an existing host.

Convert Command

The Convert command enables you to convert generic systems to standalone
systems or OS servers.
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Revert Command

The Revert command cancels the pending changes for one or more selected
host entries and reverts them to their last saved values.

Select All Command

The Select All command selects all the host entries in the main window for
batch updates.

Set Defaults Window

The Set Defaults window enables you to modify the default values in the Add
window. This can increase the consistency and efficiency of adding support for
new hosts.

Delete Window

The Delete window enables you to delete a host entry. A window is displayed
asking you to confirm the deletion.

Host Manager View Menu

The View Menu enables you to display only the hosts entries you want to see
in the main window. It also enables you to find, filter, sort, and customize host
entries.

Show Command

The Show command enables you to display only the host entries that you have
changed, only the host entries based on the current filter you have set, or all
host entries. Host Manager displays all host entries by default.

Find Window

The Find window enables you to search for a host entry. This feature is useful
when searching for a particular host in a large list of host entries, which is
usually the case in a large NIS or NIS+ environment.
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You can search by host name, and you can use wildcards to match text strings.
The first entry that matches the text string is highlighted in the main window,
if found.

Set Filter Window

The Set Filter window enables you to filter host entries based on host name,
type, IP address, etc. This means that only the host entries that match the filter
are displayed in the main display area.

You can use the Show command to turn off the filter and display all host
entries.

Sort By Command

The Sort By command enables you to sort host entries by name, type, or IP
address.

Customize Window

The Customize window enables you to choose the type of host information
you want to display for the host entries in the main window. For example, you
can choose to display or not to display IP addresses for the host entries.

Errors Command

The Errors command enables you to view any error messages that were
displayed during a Save Changes operation.

Host Manager Help Menu

The Help menu enables you to access the online help that describes Host
Manager functions and requirements. See “Using Admin Help” on page 6 for
more information.
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Files Modified by Host Manager
This table describes the system files modified by Host Manager.

System File Description

bootparams A file listing the file server that provides the client’s
root and swap areas

/etc/dfs/dfstab A file containing a series of share  commands that
make file resources available to the client system

ethers A file containing the client’s Ethernet address

hosts A file containing the client’s host name and associated
IP address

timezone A file containing the client’s time zone

/export/root/
hostname/etc/vfstab

A file containing the client’s file system entries to
mount at boot time

/tftpboot A directory containing SPARC diskless client booting
information

/rplboot A directory containing x86 diskless client booting
information

/etc/inetd.conf A system file that starts the tftp  and rpl  diskless boot
daemons
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Database Manager Reference 14

This chapter provides reference information for Database Manager, a graphical
interface used to manage network-related system files.

This is a list of the reference information in this chapter.

Using Database Manager page 154

Window, Menu, and Command Descriptions page 155

Files Modified by Database Manager page 157
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Using Database Manager

When to Use Database Manager

Database Manager can be used to perform the following tasks:

• Manage network-related system files in the NIS or NIS+ name service
environment or on a local or remote system (/etc  files)

• Provide search capabilities and syntax checking on network-related system
files

Note – Even though Database Manager allows you to manage all
network-related system files, you should manage some of the system files only
by their primary Solstice AdminSuite applications. However, you can still use
Database Manager to view the system files. Table 14-3 on page 158 lists the
system files that you should manage with Database Manager and the other
Solstice AdminSuite applications.

Requirements for Using Database Manager

The requirements for using Database Manager are:

• A bit-mapped display monitor
• Ability to use the OpenWindows environment
• Required access privileges as described in Chapter 1, “Introduction”

Where to Find Information on Specific Tasks

Table 14-1 contains references for Database Manager tasks.

Table 14-1 Database Manager Task References

Task Location

How to Start Database Manager page 93

How to Add a System File Entry page 95

How to Modify a System File Entry page 96

How to Delete a System File Entry page 97
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Window, Menu, and Command Descriptions
The following section describes Database Manager’s windows, menus, and
commands.

Database Manager Main Window

The Database Manager main window is displayed after you click the Database
Manager icon on the Solstice Launcher and select a name service and system
file. The main window contains four menus: File, Edit, View, and Help. The
selected system file contents are displayed.

Database Manager File Menu

The File Menu enables you to load system file entries and exit Database
Manager.

Load Window

When you start Database Manager or select Load from the File menu, the load
window is displayed. This window is used to select the appropriate name
service for your environment. See Chapter 2, “Using Solstice AdminSuite in a
Name Service Environment,” for information on selecting a name service.

After you have selected a name service, select the system file and click on OK.
The selected system file is loaded and the Database Manager main window is
displayed.

Exit Command

The Exit command enables you to exit Database Manager.

Database Manager Edit Menu

The Edit Menu enables you to add, copy, modify, and delete system file entries.
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Add Window

The Add window enables you to add an entry to a system file. For example,
you can create a new alias in the aliases  file.

Caution – Using the Modify or Delete commands may inadvertently affect a
user account or client system. Use User Account Manager if you are modifying
or removing user account information. If you are modifying information about
a diskless or dataless client, use Host Manager to remove and then re-add the
client information.

Modify Window

The Modify window enables you to modify an entry in a system file. For
example, you can modify an alias in the aliases  file by adding or removing
user names from the members list in the Expansion text box. You cannot
modify the alias name.

If part of an entry is not modifiable using Database Manager, remove the entry
and re-add it.

Delete Window

The delete window enables you to delete an entry from a file. A window is
displayed asking you to confirm the deletion.

Database Manager View Menu

The View menu contains commands to find and sort system file entries.

Filter Command

The Filter command enables you to filter entries in a system file if you select
the Specify option. This means that only the system entries that match the filter
text string are displayed in the main display area.

The All option enables you to remove the filter to redisplay all entries. All is
the default setting.

!
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Find Window

The Find window enables you to find a specific entry in a large system file. You
can use wildcards to match text strings. The first entry that matches the text
string is highlighted in the main window, if found.

Sort By Command

The Sort By command enables you to sort the system file by its different fields
or categories of information. For example, the networks  file can be sorted by:

• Net Name
• Net Number
• Comment

Database Manager Help Menu

The Help menu enables you to access the online help that describes Database
Manager functions and requirements. See “Using Admin Help” on page 6 for
more information.

Files Modified by Database Manager
The network-related system files that can be modified with Database Manager
are described in Table 14-2.

Table 14-2 Files Modified by Database Manager

System File Description

aliases Aliases in ASCII format for the local host. Or, if it is a NIS+
or NIS file, aliases available for use across the network.

auto.home  (NIS) or
auto_home  (NIS+)

Entries for client systems to mount their home directories
automatically; an indirect automounter map.

bootparams Entries client systems need to boot from the network.

ethers Ethernet addresses of network client systems.

hosts Entries for systems on the network and their associated IP
addresses.

locale The default locales used by network clients.
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Some of the system files should be managed by their primary Solstice
AdminSuite applications, which are summarized in Table 14-3.

netgroup Entries for netgroups, a group of systems granted identical
access to network resources for security and organizational
reasons.

netmasks Network mask values used to implement IP subnetting.

networks Information about available networks.

protocols Information about Internet protocols used in your network.

rpc Entries for available RPC services (by name) and their
associated program numbers and aliases.

services Information about network services and their “well-known”
port numbers.

timezone Entries for systems and their geographic region and time
zone used at installation.

Table 14-3 System Files and Their Primary Management Tools

System File Should be Managed By ...

aliases , locale , netgroup , netmasks ,
networks , protocols , rpc , and services

Database Manager

auto_home , passwd , group User Account Manager

group Group Manager

bootparams , ethers , hosts , and timezone Host Manager

Table 14-2 Files Modified by Database Manager (Continued)

System File Description
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Serial Port Manager Reference 15

This chapter provides reference information for the Serial Port Manager.

Use this table to find information about specific Serial Port Manager features.

Using Serial Port Manager page 160

Window, Menu, and Command Descriptions page 161

Files Modified by Serial Port Manager page 163
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Using Serial Port Manager

When to Use Serial Port Manager

Use Serial Port Manager to configure serial port software for use with
terminals or modems. You can use Serial Port Manager to configure one or
more ports on a local or remote system.

With Serial Port Manager, you can

• Add a service
• Modify a service
• Initialize a port without configuring the service
• Disable a service
• Delete a service

Requirements for Using Serial Port Manager

The requirements for using Serial Port Manager are:

• A bit-mapped display monitor
• Ability to use the OpenWindows environment
• Required access privileges as described in Chapter 1, “Introduction”

Alternative to Using Serial Port Manager

When you configure a serial port for use with a modem or terminal, you have
a choice between two tools:

• Service Access Facility – a collection of background processes and
administrative commands used from the command line to configure and
administer port services and monitors.

• Serial Port Manager – a Solstice AdminSuite application that provides a
graphical user interface and the functionality of the Service Access Facility’s
pmadm command, a port monitor administration command.
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Where to Find Specific Task Information

This table contains references for Serial Port Manager tasks.

Window, Menu, and Command Descriptions

Serial Port Manager Main Window

The Serial Port Manager main window lists the existing services that have been
configured on your system. It also contains four menus: File, Edit, View, and
Help.

Serial Port Manager File Menu

The File menu enables you to exit Serial Port Manager.

Serial Port Manager Edit Menu

The Edit menu enables you to configure and delete serial port services.

Modify Window

The Modify window enables you to modify an existing service or configure a
new service. If you need information to complete a field, click on the Help
button to see field definitions for this window. If you need information about
the menus, click on the Help button to see menu descriptions.

Table 15-1 Serial Port Manager Task References

Task Location

How to Start Serial Port Manager page 103

How to Add a Terminal page 104

How to Add a Modem page 105

How to Initialize a Port Without Configuring page 107

How to Disable a Port page 107

How to Delete a Port Service page 108
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Template Menu
The template menu provides a list of templates that help you quickly initialize
a port or set up port services for terminals and modems. Choose the template
that most closely matches the port configuration you want. You can then
change the values in the Modify window to meet your needs.

Baud Rate Menu
The baud rate menu provides a list of common baud rates. These entries are
also listed in the /etc/ttydefs  file. To specify a baud rate not listed, choose
Other and enter a value from the /etc/ttydefs  file.

Port Monitor Tag Menu
The port monitor tag menu lists the default tag—zsmon—and Other. To specify
a tag other than zsmon, choose Other.

Timeout Menu
The timeout menu provides a list of common timeout parameters. If no input
data is received within the timeout parameter, the port will be closed.

Delete Window

The delete window enables you to delete a service. A window is displayed
asking you to confirm the deletion.

Serial Port Manager View Menu

Hosts Window

The Hosts window enables you to configure the port service on a remote
system if you have administration privileges for that system. See Chapter 2,
“Using Solstice AdminSuite in a Name Service Environment,” for more
information on Solstice AdminSuite security.
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Serial Port Manager Help Menu

The Help menu enables you to access the online help that describes Serial Port
Manager functions and requirements. See “Using Admin Help” on page 6 for
more information.

Files Modified by Serial Port Manager
This table describes the files that are modified by Serial Port Manager.

Table 15-2 Files Modified by Serial Port Manager

System File Description

/etc/saf/_sactab The Service Access Facility’s administrative file that
contains configuration data for the port monitors it
controls

/etc/saf/ pmtag/_pmtab The port monitor’s administrative file that contains
port monitor-specific configuration data for the
services it provides

/var/saf/pmtag/log The port monitor’s log file logging service states:
successful initialization, failure, enabled, or disabled
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Printer Manager Reference 16

This chapter provides reference information for Printer Manager, a graphical
user interface used to set up and maintain the SunSoft print client software.

This is a list of the reference information in this chapter.

Using Printer Manager page 166

Window, Menu, and Command Descriptions page 167

Files Modified by Printer Manager page 170
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Using Printer Manager

When to Use Printer Manager

Printer Manager can be used to perform the following tasks:

• Install or remove a printer on a system
• Add or delete access to a printer
• Modify printer configuration information
• Find printer entries in a list of all printers on the network

Requirements for Using Printer Manager

The requirements for using Printer Manager are:

• A bit-mapped display monitor
• Ability to use the OpenWindows environment
• Required access privileges as described in Chapter 1, “Introduction”

Where to Find Specific Task Information

The task information for using Printer Manager is contained in Chapter 9,
“Setting Up SunSoft Print Client Software With Printer Manager.” This chapter
contains step-by-step instructions for performing the tasks referenced in
Table 16-1..

Table 16-1 Printer Manager Task References

Task Location

How to Start Printer Manager page 111

How to Install a Printer page 113

How to Add Access to a Printer page 116

How to Modify Printer Information page 119

How to Delete Access to a Printer page 122

How to Delete a Printer From a Print Server (If No Name Service) page 123

How to Find a Printer Entry page 124
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Window, Menu, and Command Descriptions
The following section describes Printer Manager’s windows, menus, and
commands.

Printer Manager Main Window

The Printer Manager main window is displayed after you click on the Printer
Manager icon in the Solstice Launcher and complete the Load window. The
main window contains the File, Edit, View, and Help menus. A scrolling list of
the printers on your network is also displayed.

Printer Manager File Menu

The File Menu enables you to load system file entries and exit Printer Manager.

Load Window

When you start Printer Manager or select Load from the File menu, the Load
window is displayed. This window is used to select:

• The appropriate name service for your environment. See Chapter 2, “Using
Solstice AdminSuite in a Name Service Environment” for information on
selecting a name service.

• The domain in which to manage printers. If you select None for the name
service, you must specify a system's host name instead of a domain name.

After you have selected a name service and a domain or host name, click on
OK. The name service and domain or host information is loaded and the
Printer Manager main window is displayed.

Exit Command

The Exit command enables you to exit Printer Manager.
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Printer Manager Edit Menu

The Edit menu enables you to add access to a printer, install a printer, modify
printer information, delete access to a printer, and find printer entries in the
scrolling list.

Add Access to Printer Window

The Add Access to Printer window enables you to give print clients access to a
remote printer.

Install Printer Window

The Install Printer window enables you to install a printer on a system.

Modify Window

The Modify window enables you to modify the existing information for a
printer. Depending on the printer entry you select, you are able to modify a
printer that you have:

• Installed on a system by using Printer Manager (long window)
• Added access to (short window)

Delete Window

The Delete window is a pop-up window to confirm that you want to delete
access to the selected printer.
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Printer Manager View Menu

The View menu enables you to find printer entries.

Find Window

The Find window enables you to easily locate a specific printer in the Printer
Manager main window. This is useful if the main window contains numerous
printer entries.

Printer Manager Help Menu

The Help menu enables you to access the online help that describes Printer
Manager functions and requirements. See “Using Admin Help” on page 6 for
more information.
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Files Modified by Printer Manager
Table 16-2 describes the SunSoft and Solaris system files that are modified by
Printer Manager.

Table 16-2 Files Modified by Printer Manager

System File Description

/etc/printers.conf A file containing printer configuration information
for SunSoft print client operation

printers.conf.byname An NIS map that contains printer configuration
information for SunSoft print client operation

fns.ctx_dir An NIS+ map that contains printer configuration
information for SunSoft print client operation and
other information

/etc/lp/printers/ printer/* A Solaris file containing LP printer configuration
information

/etc/lp/interfaces/ printer A Solaris shell script used to communicate with a
local printer

/etc/lp/default A Solaris file containing the name of the LP system
default printer

/etc/lp/filter.table A Solaris lookup table containing the configured
LP filters

/etc/lp/Systems A Solaris file containing a list of remote systems
for Solaris LP

/etc/saf/sactab A Solaris file containing service access facility
configuration

/etc/saf/tcp_pmtab A Solaris file containing port monitor
configuration
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sadmind
A distributed system administration daemon that carries out security tasks
when administrative tasks are performed across the network.

aliases  file

A file containing mail aliases, which are names that represent distribution lists
of users.

auto_home  (or auto.home ) file
An indirect automounter map that contains entries enabling client systems to
mount their home directories automatically. It is primarily accessed using User
Manager.

baud rate
The switching speed of a line, which is the number of changes in the electrical
state of the line per second. At low speeds, baud rate is equivalent to bits
transmitted per second. At higher speeds, the bits transmitted per second is
greater than the baud rate because one baud can be made to represent more
than one bit.

Berkeley Software Distribution (BSD)
One of two major “flavors” of the UNIX operating system, the other being
System V. SunOS operating system releases before SunOS 5.0 (Solaris 2.0) are
BSD.
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bootparams file
A file containing entries that are used to enable client systems to boot from the
network.

content type
Specified when you add support for a local printer. Identifies the particular
formats of files that can be printed. Supported content types are: PS
(PostScript), ASCII, simple, or any.

Database Manager
One of Solstice AdminSuite’s applications used to manage
network-related system files such as aliases  and netmasks .

dataless client
A system with a monitor and keyboard, CPU and memory, Ethernet hardware,
and small local disk for the swap area and the root (/ ) file system. This system
gets it other file resources from a server on the network.

default
An assumed value, or an action taken automatically unless you specify
otherwise.

device
A hardware component, such as a printer or disk drive, acting as a unit to
perform a specific function.

diskless client
A system with a monitor and keyboard, CPU and memory, and Ethernet
hardware. This system gets it file resources and swap space from a server on a
network.

Ethernet address
A system’s hardware address. The Ethernet address can be displayed using the
banner  command from the PROM level.

ethers  file
A file containing Ethernet addresses of network client systems.

file server
A system that shares file resources and disk storage space for network clients.

file system
A hierarchy of files and directories in the Solaris operating environment.
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group
A collection of users who share files and other system resources. Each user
belongs to a primary group (listed in the user’s passwd  entry), and optionally,
one or more secondary groups.

group  file
A file containing entries for UNIX groups. The group  file is accessed from
Group Manager.

group ID (GID)
A group identification number used by the system to identify a user’s primary
group. Group ID numbers for users usually range from 100 to 60000.

Group Manager
One of Solstice AdminSuite’s applications used to manage group information
in the group  file.

hardwired
Refers to a device such as a terminal that is physically connected to the local
system.

Host Manager
One of Solstice AdminSuite’s applications used to manage network client
services.

host name
A unique name that identifies a system.

initialization files
Special files run automatically when you log in. When an account is created
and you specified a skeleton path, User Manager copies generic versions of the
initialization files into the user’s home directory. You can then edit the copies
as needed to customize each user’s environment.

IP address
A system’s unique network address.

launcher
See Solstice AdminSuite Launcher.

local printer
A printer physically connected to the local system.

locale  file
A file containing the default locales used by network clients.
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media server
A system that shares a CD-ROM device for remote installation of software.

modem

A data communication device that translates, or modulates, digital information
into an analog signal that can be transmitted via phone lines.

name service
Method by which system information is maintained in the network. There are
three selections in Solstice AdminSuite: NIS, NIS+, and None.

• NIS – Name service shipped with the SunOS 4.1.x operating system
(Solaris 1). Designated systems, called NIS servers, contain maps that store
information about the network, its clients, and its users.

• NIS+ – Name service shipped with the Solaris software. Making use of true
databases (instead of two-column maps that simply associate one variable
with another), NIS+ stores more information than NIS.

• None – Method for administrators of networks that do not use a network
name service; administrators usually select one system on the network on
which to maintain a master copy of the /etc  configuration files.

name service domain
A group of systems and the information served to those systems.

netgroup  file
A file containing entries for netgroups, a group of systems granted identical
access to network resources for security and organizational reasons.

netmasks file
A file containing network mask values used to implement IP subnetting.

network client
A system that uses remote resources from a server.

Modem ModemSystem SystemPhone

Digital signal

Analog signal

Lines 21
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networks file
A file containing information about available networks.

nsswitch.conf
A file that contains an entry for each system file and a corresponding name
service source to search for the system file information. The name service
sources are designated as keywords— nis , nisplus , or files . If more than
one name service source is listed, they are searched in the order given.

OpenWindows
A windowing system based on the OPEN LOOK graphical user interface.

parallel port
A port that transfers one or more bytes simultaneously over multiple lines. See
also serial port.

passwd  file
A file that contains user account information such as user name, user ID, group
ID, and home directory. User Manager accesses this file.

password status
Characteristics associated with a user’s password. User Manager’s Add User
window has a password status menu that enables you to control user
password characteristics. The choices are:

• Normal password – Sets a password for the user.
• Cleared until first login – Prompts user for a password on first login.
• Account is locked – Disables account. Account can be unlocked by

assigning a new password. This type of account allows a user to own files
but not log in.

• No password—setuid only – Disables the ability to directly log in to the
account. This allows programs such as lp  or uucp  to run under an account,
without allowing a user to log in.

permissions
A set of attributes that determines which users have access to read, write, and
execute a file or directory’s contents.

port

A channel through which a device communicates with the operating system.
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port monitor

A program that continuously “watches out” for requests to log in, or requests
to access printers or files.

When a port monitor detects a request, it sets the parameters required to
establish communication between the operating system and the device
requesting service. Then the port monitor transfers control to other processes
that provide the services needed.

primary group
A user’s default group, which determines the group ownership on a file the
user creates, or is allowed to access, if already created. Membership in this
group is defined by the group identifier listed in the user’s entry in the passwd
file.

print client
A system that uses a print server for printing files.

print server
A system that has a printer physically connected to it and the appropriate
software configured to print both local and remote print requests.

Printer Manager
One of the Solstice AdminSuite’s applications used to manage local and remote
printer setup.

printer name
A unique name, with a maximum of 14 characters, for a printer.

printer type
The terminfo  database entry that contains the control sequences that
initialize the printer.

PROM
A programmable read-only memory chip with a program called the monitor
that runs a quick self-test procedure and checks such things as the hardware
and memory on the system. If no errors are found, the system begins the
automatic boot process.

PROM prompt
The prompt displayed when the system halts; either > or ok .

protocols file
A file containing information about Internet protocols used in your network.
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remote printer
A printer connected to a remote system such as a print server.

root
A user who has access to all parts of the system. This is usually the system
administrator. Also known as superuser.

rpc file
A file containing entries for available Remote Procedure Call (RPC) services
(by name) and their associated program numbers and aliases.

secondary group
Membership in this group is defined by the group identifier listed in the group
file with a list of users as members.

serial port

A port which transmits a byte of information bit-by-bit over a single line using
a standard communications protocol such as RS-423. See also parallel port.

Serial Port Manager
One of the Solstice AdminSuite’s applications used to manage serial devices.

services file
A file containing information about network services and their “well-known”
port numbers.

shadow  file
A file containing encrypted user passwords and password aging information.
Accessed using User Manager.

shell
A command-line interpreter program that accepts and executes commands that
you type. There are several varieties of shell programs, and three are included
in the Solaris software: Bourne, Korn, and C.

skeleton path
A prototype directory containing start up files. See also initialization files.

Solstice AdminSuite
A graphical user interface used to perform administrative tasks such as
managing users, groups, hosts, printers, and serial devices.

Solstice Launcher
The base window of the interface, used to start the other application tools.
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standalone system

A standalone system has a monitor and keyboard, CPU and memory,
approximately 200 megabytes of disk space, and usually a backup device. It
may or may not be connected to a network.

superuser
A user who has access to all parts of the system. This is usually the system
administrator. Also known as root.

sysadmin group
The UNIX group whose members belong to the sysadmin group (Group 14).
Members of the sysadmin group can use Solstice AdminSuite’s applications
locally or remotely.

system default (printer)
The printer your print requests will be sent to if you do not specify a printer.

system files
Files that contain important system administration information such as user
accounts, passwords, and groups. These files are contained on the local system
in the /etc  directory, or in the NIS or NIS+ database on a name server.

System V
One of two major “flavors” of the UNIX operating system, the other being
BSD. The SunOS 5.0 operating system (Solaris 2.0) and subsequent releases are
System V.

terminal

An input/output device that usually has a keyboard for input and a video
screen or printer for output. Terminal, however, is often used as a shorthand
for alphanumeric terminal, which is a serial port device capable of displaying
only letters, numbers, and other characters such as those produced by a
typewriter.

timezone file
A file containing entries for systems and their geographic region and time
zone.

user account
A record of essential user information stored on the system. You must have a
user account to access a system.
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user ID (UID)
A number used by the operating system to identify a user. User ID numbers
for users usually range from 100 to 60000.

user name
The name, assigned to an individual user, that controls access to a system.

User Manager
One of the Solstice AdminSuite’s applications used to manage user account
information.

utmp  entry
A entry made in the /var/adm/utmp  file when a user logs in and out of the
system.

workspace
The background screen area on which windows and icons are displayed.

ypbind
An NIS daemon process that runs on all client systems and allows the client to
communicate with an NIS server.

zsmon
Sun’s naming convention for the port monitor that monitors a system’s two
serial ports. It is derived from the Zilog serial communications driver.
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Index

A
access

setting up for NIS, 20
to printers

adding, 116
deleting, 122

Add Access to Printer window, 117, 168
Add Application window, 32
Add option (Edit menu)

Group Manager, 41
Host Manager, 69
User Manager, 45 to 46

Add window
Database Manager, 95, 156
Group Manager, 136
Host Manager, 69, 70, 71, 84, 87, 148
User Manager, 45, 46, 142

adding
access to a printer, 116
applications

in global register, 27, 30
in local register, 26
in Solstice Launcher window, 32

client support, 64
groups, 41
modems, 105
server support, 64

Solaris 2.x OS services to OS
servers, 80

standalone system information, 80
SunOS 4.x services to OS servers, 74
support

for dataless clients, 85
for diskless clients, 82
for OS servers, 69
for standalone systems, 69

system file entry, 95
terminals, 104
user accounts, 45 to 46
users in sysadmin group

in NIS environment, 12
in NIS+ environment, 11
without a name service, 13

Admin Help, 6
buttons, 7

AdminSuite, See Solstice AdminSuite
aliases  file, 157
Application Path Selection window, 35
Application Properties window, 34
application properties, customizing, 32
application tools

filtering entries, 131
general reference, 129 to 132

applications
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customizing, locally registered, 34 to
36

of Solstice AdminSuite, 3
registering in Solstice Launcher, 25 to

31
removing

from global registry, 29, 31
from local registry, 27

architecture type
for dataless clients, 85
for diskless clients, 82
for standalone systems, 70
selecting when adding Solaris 4.x OS

services, 77
ASCII terminal, 3
authenticating user ID, 15
authentication security, 15

levels of, 16
authorizing permissions, 15
auto_home  file, 144
AutoClient systems

adding and maintaining, 63

B
baud rate for modems, 106
Baud Rate menu (Serial Port

Manager), 162
bidirectional modem template, 101
bit-mapped display monitor, 3
boot servers

defined, 62
for dataless clients, 86
for OS servers, 70
for standalone systems, 70

boot software, 58
booting

dataless clients, 86
diskless clients, 83

bootparams  file, 151, 157
buttons (Solstice AdminSuite), 132

C
CD image, See Solaris CD image
changing, See modifying, 49
clients

See also diskless clients, dataless
clients

defined, 56
support for, 55 to 89

maintaining, 88 to 89
commands

filtering, 131
install4.x , 76
pmadm, 160
soladdapp , 25, 27, 29, 30, 31

configuration information for diskless
clients, 83

configuring
modems, 106
ports, 104, 105, 106

conventions, typographic, xvi
Convert command (Host Manager), 148
Convert to OS Server option (Host

Manager Edit menu), 72
Convert window (Host Manager), 72
converting standalone systems, 72
Copy option (User Manager Edit

menu), 47
Copy window (User Manager), 142
copying user accounts, 47
credentials for security levels, 16
Customize window (Host Manager), 150
customizing

locally registered applications, 34 to
36

Solstice Launcher, 32 to 33

D
daemons

client, 83
sadmind , 15

Database Manager
about using, 154
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Add window, 95, 156
advanced uses, 92
Delete window, 156
Edit menu, 155
Exit command, 155
files modified by, 157
Filter command, 156
Find window, 157
Help menu, 157
Load window, 155
main window, 93, 155
Modify window, 96, 156
requirements for using, 154
Sort By command, 157
starting, 95
View menu, 156

dataless clients, 59
adding services for, 74
adding support for, 85
booting, 86
compared to other systems, 57
discontinuation of support for, 59
operating system services for, 58, 61

default printer, setting
with Printer Manager, 114 to 115

defaults
for adding system support, 68
for user accounts, 44
modem, 101
terminal, 100

Delete option (Edit menu)
Group Manager, 50
User Manager, 53

Delete window
Database Manager, 156
Group Manager, 136
Host Manager, 149
Printer Manager, 168
Serial Port Manager, 162
User Manager, 142

deleting
access to printers, 122
groups, 50
port services, 108
printers from print servers

for NIS or NIS+, 122
if no name service, 123

support for a system, 89
system file entry, 97
user accounts, 53
user home directories, 53
user mailboxes, 53

dial-in only modem template, 101
dial-out only modem template, 101
disabling ports, 107
diskless clients, 58

adding support for, 74, 82
booting, 83
compared to other systems, 57
operating system services for, 58, 61

E
/etc/lp  directory

when printer is added in, 114
when printer is deleted from, 123, 124

/etc/printers.conf  file
of print client, 123
of print server, 114, 123
when printer is added in, 114
when printer is deleted from, 123, 124

Edit menu
Database Manager, 155

Add option, 95
Delete option, 97
Modify option, 96

Group Manager, 136
Add option, 41
Delete option, 50
Modify option, 49

Host Manager, 148
Add option, 69, 82, 85
Modify option, 49, 80, 89
Set Defaults option, 68

Printer Manager, 168
Add Access to Printer

option, 117
Delete option, 122, 123
Install Printer option, 114
Modify option, 119



184 Solstice AdminSuite 2.1 User’s Guide—November 1995

Serial Port Manager, 161
Delete option, 108
Modify option, 104, 105, 107
Modify Service option, 106

User Manager, 141
Add option, 45 to 46
Copy option, 47
Delete option, 53
Modify option, 51
Set Defaults option, 44

Errors command (Host Manager), 150
/etc  files

as source of name service
information, 18

modified by Group Manager, 137
modified by Printer Manager, 170

/etc/group  file, 13
/etc/saf/ pmtag/_pmtab  file, 163
/etc/saf/_sactab  file, 163
ethers  file, 157
/export  file systems, 58
/export/root/ hostname/etc/vfstab

file, 151

F
Federated Naming Service, used with

NIS+, 112
File menu

Group Manager, 135
Host Manager, 147

Save Changes option, 82
Update System Types option, 68

Printer Manager, 167
Serial Port Manager, 161
User Manager, 141

File Selection window, 35
file servers

for dataless clients, 85
for diskless clients, 82

Filter command (Database Manager), 156
Filter menu, 131
filtering commands, 131

Find option (Printer Manager View
menu), 124

Find window
Database Manager, 157
Group Manager, 136
Host Manager, 149
Printer Manager, 124, 169
User Manager, 143

finding a printer entry, 124

G
global registry, 25
global security policy, 19
group 14

membership required in, 4
permissions granted to, 16

group  file, 144
group ID, 41
Group Manager

about using, 134
Add window, 41, 136
adding users in sysadmin group, 12
defined, 37
Delete option (Edit menu), 50
Delete window, 136
Edit menu, 136
Exit command, 135
File menu, 135
files modified by, 137
Find window, 136
Help menu, 137
Load window, 135
main window, 39, 40, 135
Modify option (Edit menu), 49
Modify window, 49, 136
prerequisites for using, 39
Rebuild List command, 137
requirements for using, 134
Sort By command, 136
starting, 39 to 40
tasks

for maintaining user
accounts, 48

for setting up user accounts, 38
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View menu, 136
groups

adding, 41
changing name of, 49
deleting, 50
modifying, 49
naming, 41

H
Help menu

Database Manager, 157
Group Manager, 137
Host Manager, 150
Printer Manager, 169
Serial Port Manager, 163
User Manager, 143

Help utility, 6
Hide list, moving applications to or

from, 32
Host Manager, 55 to 89

Add window, 70, 71, 84, 87, 148
Convert command, 148
Convert window, 72
Customize window, 150
Delete option (Edit menu), 89
Delete window, 149
Edit menu, 148
Errors command, 150
Exit command, 148
File menu, 147
files modified by, 151
Find window, 149
Help menu, 150
limitations of, 63
Load window, 147
main window, 66, 67, 147
Modify window, 81, 89, 148
Revert command, 149
Save Changes command, 147
Select All command, 149
Set Add Defaults window, 68
Set Defaults option (Edit menu), 68
Set Defaults window, 149
Set Filter window, 150

Show command, 149
Sort By command, 150
starting, 66
tasks

available in, 59 to 60
for adding server/client

support, 64
for maintaining server/client

support, 88
Update System Types command, 148
Update System Types menu, 68
Update System Types option (File

menu), 68
View menu, 149

hosts  file, 151, 157
Hosts window

Serial Port Manager, 162

I
icons

path name, 35
tool, 32

Initialize Only - No Connection
template, 102

initializing ports, 107
Install main menu, 76
Install Printer window, 114, 168
install servers

defined, 62
for adding Solaris 2.x OS services, 80
for dataless clients, 85
selecting, 69

install4x  command, 76 to 78
installation services, 56
installing printer, 113

J
JumpStart installation, 58, 62

K
keyword files, 18
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L
local security policy, 19
locale  file, 157
locally registered applications,

customizing, 34 to 36

M
mailboxes (user), deleting contents of, 53
main window, 130

Database Manager, 155
Group Manager, 135
Host Manager, 147
Printer Manager, 167
Serial Port Manager, 161
User Manager, 141

maintaining
client support, 88 to 89
server support, 88 to 89

managing
client support, 55 to 89
modems, 99 to 108
network service files, 91 to 97
server support, 55 to 89
terminals, 99 to 108
user accounts, 37 to 53

Members List
creating for a group, 41
for sysadmin group, 12

menu bars, 130
modems

adding, 105
configuring, 106
managing, 99 to 108
template, 100, 101

Modify option (Edit menu)
Database Manager, 96
Group Manager, 49
Host Manager, 49, 80, 89
Serial Port Manager, 104, 105
User Manager, 51

modify permissions for NIS+ tables, 11
Modify Service option (Serial Port

Manager Edit menu), 106

Modify Service window (Serial Port
Manager), 106

Modify window
Database Manager, 96, 156
Group Manager, 49, 136
Host Manager, 81, 89, 148
Printer Manager, 119, 168
Serial Port Manager, 104, 105, 107,

161
User Manager, 51, 52, 142

modifying
group name, 49
groups, 49
locally registered application, 34
printer configuration

information, 119
support for systems, 89
system file entry, 96
user accounts, 51

Module Selection menu, 77
monitor, requirements for, 3

N
name service

See alsoNIS, NIS+
information used by sadmind

daemon, 18
selecting, 10
using Solstice AdminSuite with, 9 to

13
netgroup  file, 158
netmasks  file, 158
network service files, managing, 91 to 97
network services, 56
networks  file, 158
NIS

access privileges required for, 4, 112
adding users in sysadmin group, 12
keyword, 18
map information, requirements for

using, 12
maps, remaking, 13
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not available for Serial Port
Manager, 11

setting up access for, 20
using with Solstice AdminSuite, 10
when printer is added in, 113, 114, 117
when printer is deleted from, 123

NIS+
access privileges required for, 4, 112
adding users in sysadmin group, 11
admin group, membership in, 112
keyword, 18
not available for Serial Port

Manager, 11
permissions, setting up, 20
security for, 18
tables, requirements for using, 11
using with Solstice AdminSuite, 10
when printer is added in, 113, 114, 117
when printer is deleted from, 123

None
adding users in sysadmin group, 13
printer added in client’s /etc

files, 117
printer added in server’s /etc

files, 113, 114
printer deleted from client’s /etc

files, 123
printer deleted from server’s /etc

files, 124

O
OpenWindows, 3, 5
operating system services, 56, 61
/opt  directory, 58
OS servers

adding
SunOS 4.x OS services to, 74

adding support for, 69
converting standalone systems to, 72

OS Services window, 72

P
parity for modems, 106

passwd  file, 144
permissions

authorization of, 15
for NIS+ management, 20
for NIS+ tables, 11

pmadm command, 160
Port Monitor Tag menu (Serial Port

Monitor), 162
port services, deleting, 108
ports

configuring, 104, 105, 106
disabling, 107
initializing, 107

print clients, access to printers, 116
print servers

managing, 110 to 125
setting up, 113

printer
adding access to, 116
deleting access to, 122
installing, 113
modifying configuration for, 119

printer configuration information,
modifying, 119

printer entry, finding, 124
Printer Manager

about using, 166
Add Access to Printer window, 117,

168
Delete window, 168
Edit menu, 168
Exit command, 167
File menu, 167
files modified by, 170
Find window, 124, 169
Help menu, 169
Install Printer window, 114, 168
Load window, 112, 167
main window, 112, 167
Modify window, 119, 168
requirements for using, 166
starting, 111
View menu, 169

profile servers
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defined, 62
for dataless clients, 86
for OS servers, 70
for standalone systems, 70

prompts in command examples, xvii
protocols  file, 158

R
Rebuild List command

Group Manager, 137
User Manager, 143

registering applications in Solstice
Launcher, 25 to 31

registry
global, 25

adding applications in, 30
removing applications from, 31

local
adding applications in, 27 to 28
removing applications from, 29

private
adding applications in, 26
removing applications from, 27

remaking NIS maps, 13
remote booting, 56
remote installation, 62

not available for SunOS 4.x, 63
removing applications

from global registry, 29, 31
from local registry, 27

requirements
for using AdminSuite, 3
for using Group Manager, 134
for using NIS map information, 12
for using NIS+ table information, 11

Revert command (Host Manager), 149
.rhosts  file, entry required for NIS, 12
root file system

for dataless clients, 59
for diskless clients, 58
for servers, 58
for standalone systems, 58

root password, creating for diskless
clients, 83

root path
specifying for diskless clients, 82

root privilege, 4
security for, 16
using sysadmin group privileges

instead, 112
root .rhosts  file, 12
rpc  file, 158

S
sadmind  daemon, 15

name service information used by, 18
Save Changes command

Host Manager, 147
searching for

group information, 136
host entries, 149
system file information, 157
user account information, 143

security, 15 to 20
levels of, 16 to 18

changing, 17 to 18
policy, 19 to 20

Select All command (Host Manager), 149
selecting a name service, 10
Serial Port Manager

about using, 160
alternative to using, 160
Baud Rate menu, 162
Delete window, 162
description of, 100
Edit menu, 161
File menu, 161
files modified by, 163
Help menu, 163
Hosts window, 162
main window, 103, 161
Modify Service window, 106
Modify window, 104, 105, 107, 161
Port Monitor Tag menu, 162
requirements for using, 160
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starting, 103
Template menu, 104, 162
Timeout menu, 162
View menu, 162

servers, 55 to 89
boot, 62
compared to other systems, 57
defined, 56
file systems of, 58
install, 62
profile, 62
software to support other systems, 58
support for, 55 to 89

maintaining, 88 to 89
Service Access Facility, 160
services  file, 158
Set Add Defaults window

Host Manager, 68
User Manager, 44

Set Defaults option (Edit menu)
Host Manager, 68
User Manager, 44

Set Defaults window
Host Manager, 149
User Manager, 142

Set Filter window (Host Manager), 150
shadow  file, 144
Show command

Host Manager, 149
Show list, moving applications to or

from, 32
soladdapp  command, 25

globally registering applications
with, 27, 30

removing globally registered
applications with, 29, 31

Solaris 2.x OS services, adding to OS
servers, 80

Solaris CD image, 58
setting path

for dataless clients, 86
for OS servers, 70
for standalone systems, 70

when adding Solaris 2.x OS
services, 80

when converting standalone to
OS server, 72

Solaris OS server, 61
Solstice AdminSuite

application tools, 129 to 132
applications, 3
benefits of using, 2
buttons, 132
description of, 1
Help utility, 6
knowledge required to use, xv
launcher, 5
main windows, 130
menu bars, 130
NIS environment, 12 to 13
NIS+ environment, 11 to 12
prerequisites for running, 3
security, 15 to 20

levels of, 16 to 18
policy, 19 to 20

starting, 5
tasks available in, 2
text boxes, 132
using with name service, 9 to 13
using without name service, 13

Solstice Launcher, 5, 23 to 36
customizing, 32 to 33
menus, 24
registering applications in, 25 to 31
starting, 24

Sort By command
Database Manager, 157
Group Manager, 136
Host Manager, 150
User Manager, 143

standalone systems
adding support for, 69
compared to other systems, 57
converting to OS servers, 72
networked, 58

starting
Database Manager, 95
Group Manager, 39 to 40
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Host Manager, 66
Printer Manager, 111
Serial Port Manager, 103
Solstice AdminSuite, 5
Solstice Launcher, 24
User Manager, 42

SunOS 4.x OS services, 63
adding, 74

support for systems
adding

for dataless clients, 85
for diskless clients, 82
for OS servers, 69
for standalone systems, 69

defined, 56
deleting, 89
modifying, 89
setting defaults, 68

swap path for diskless clients, 82
swap size for diskless clients, 82
swap space, 58

for dataless clients, 59
sysadmin group

adding users
in name service, 18
in NIS environment, 12
in NIS+ environment, 11
without a name service, 13

membership required in, 4, 11, 12
permissions granted to, 16

system file entry
adding, 95
deleting, 97
modifying, 96

system information
adding, 69
specifying for diskless clients, 82

system types, 57, 60
updating, 68

T
Template menu (Serial Port

Manager), 104, 162

templates
modems, 101
terminal, 100

Terminal-Hardwired template, 100
terminals

adding, 104
managing, 99 to 108
template, 100

text boxes, 132
/tftpboot  directory, 151
Timeout menu (Serial Port Manager), 162
timezone  file, 151, 158
tool icons, customizing, 32
typographic conventions, xvi

U
UID, See user ID
Update System Types command

Host Manager, 148
Update System Types option (Host

Manager File menu), 60, 68
updating system types, 68
user accounts, 37 to 53

adding, 45 to 46
copying, 47
deleting, 53
maintaining, 48 to 53
managing, 37 to 53
modifying, 51
setting defaults for, 44

user home directories, deleting, 53
user ID

authentication of, 15
security authorization by, 16

user mailboxes, deleting, 53
User Manager

about using, 140
Add option (Edit menu), 45 to 46
Add window, 45, 46, 142
Copy option (Edit menu), 47
Copy window, 142
defined, 37
Delete option (Edit menu), 53
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Delete window, 142
Edit menu, 141

Delete option, 53
Modify option, 51

Exit command, 141
File menu, 141
files modified by, 144
Find window, 143
Help menu, 143
Load window, 141
main window, 42, 43, 141
Modify window, 51, 52, 142
prerequisites for using, 42
Rebuilt List command, 143
requirements for using, 140
Set Add Defaults window, 44
Set Defaults option (Edit menu), 44
Set Defaults window, 142
Sort By command, 143
starting, 42
View menu, 143

/usr  file system, 58

V
/var/saf/ pmtag /_pmtab/log  file, 163
View menu

Database Manager, 156
Group Manager, 136
Host Manager, 149
Printer Manager, 169

Find option, 124
Serial Port Manager, 162
User Manager, 143

Volume Management, 74, 75
and CD image software, 80

Y
ypbind , running with -broadcast

option, 12
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