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Preface

iPlanet UDS provides a platform-specific installation program to install Express on 
each iPlanet UDS node type. The installation programs and the iPlanet UDS source 
files they install are included with the Express CD.

This Express Installation Guide provides instructions for:

• installing Express Release 5 for the first time onto your existing iPlanet UDS 
Release 5 installation

• upgrading to Express Release 5

This preface contains the following sections:

• “Product Name Change” on page 7

• “Audience for This Guide” on page 8

• “Text Conventions” on page 8

• “Other Documentation Resources” on page 9

• “iPlanet UDS Example Programs” on page 10

• “Viewing and Searching PDF Files” on page 11

Product Name Change
Forte 4GL has been renamed the iPlanet Unified Development Server. You will see 
full references to this name, as well as the abbreviations iPlanet UDS and UDS.
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Audience for This Guide
This manual is intended for the engineer responsible for installing Express.

Organization of This Guide
The following table briefly describes the contents of this guide:

Text Conventions
This section provides information about the conventions used in this document.

Chapter Description

“Installing Express” Provides instructions for installing Express.

Format Description

italics Italicized text is used to designate a document title, for 
emphasis, or for a word or phrase being introduced.

monospace Monospace text represents example code, commands that you 
enter on the command line, directory, file, or path names, 
error message text, class names, method names (including all 
elements in the signature), package names, reserved words, 
and URLs.

ALL CAPS Text in all capitals represents environment variables 
(FORTE_ROOT) or acronyms (UDS, JSP, iMQ).

Uppercase text can also represent a constant. Type uppercase 
text exactly as shown.

Key+Key Simultaneous keystrokes are joined with a plus sign: Ctrl+A 
means press both keys simultaneously.

Key-Key Consecutive keystrokes are joined with a hyphen: Esc-S 
means press the Esc key, release it, then press the S key.
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Other Documentation Resources
In addition to this guide, there are additional documentation resources, which are 
listed in the following sections. The documentation for all iPlanet UDS products 
(including Express, WebEnterprise, and WebEnterprise Designer) can be found on 
the iPlanet UDS Documentation CD. Be sure to read “Viewing and Searching PDF 
Files” on page 11 to learn how to view and search the documentation on the iPlanet 
UDS Documentation CD.

iPlanet UDS documentation can also be found online at 
http://docs.iplanet.com/docs/manuals/uds.html. 

The titles of the iPlanet UDS documentation are listed in the following sections.

iPlanet UDS Documentation
• A Guide to the iPlanet UDS Workshops

• Accessing Databases

• Building International Applications

• Escript and System Agent Reference Guide

• Fscript Reference Guide

• Getting Started With iPlanet UDS

• Integrating with External Systems

• iPlanet UDS Java Interoperability Guide

• iPlanet UDS Programming Guide

• iPlanet UDS System Installation Guide

• iPlanet UDS System Management Guide

• Programming with System Agents

• TOOL Reference Guide

• Using iPlanet UDS for OS/390

http://docs.iplanet.com/docs/manuals/uds.html
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Express Documentation
• A Guide to Express

• Customizing Express Applications

• Express Installation Guide

WebEnterprise and WebEnterprise Designer 
Documentation
• A Guide to WebEnterprise

• Customizing WebEnterprise Designer Applications

• Getting Started with WebEnterprise Designer

• WebEnterprise Installation Guide

Online Help
When you are using an iPlanet UDS development application, press the F1 key or 
use the Help menu to display online help. The help files are also available at the 
following location in your iPlanet UDS distribution: 
FORTE_ROOT/userapp/forte/cln/*.hlp.

When you are using a script utility, such as Fscript or Escript, type help from the 
script shell for a description of all commands, or help <command> for help on a 
specific command.

iPlanet UDS Example Programs
A set of example programs is shipped with the iPlanet UDS product. The examples 
are located in subdirectories under $FORTE_ROOT/install/examples. The files 
containing the examples have a .pex suffix. You can search for TOOL commands 
or anything of special interest with operating system commands. The .pex files are 
text files, so it is safe to edit them, though you should only change private copies of 
the files. 
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Viewing and Searching PDF Files
You can view and search iPlanet UDS documentation PDF files directly from the 
documentation CD-ROM, store them locally on your computer, or store them on a 
server for multiuser network access. 

➤ To copy the documentation to a client or server

1. Copy the doc directory and its contents from the CD-ROM to the client or 
server hard disk.

You can specify any convenient location for the doc directory; the location is 
not dependent on the iPlanet UDS distribution.

2. Set up a directory structure that keeps the udsdoc.pdf and the uds directory in 
the same relative location.

The directory structure must be preserved to use the Acrobat search feature.

➤ To view and search the documentation

1. Open the file udsdoc.pdf, located in the doc directory.

2. Click the Search button at the bottom of the page or select Edit > Search > 
Query.

NOTE You need Acrobat Reader 4.0+ to view and print the files. Acrobat 
Reader with Search is recommended and is available as a free 
download from http://www.adobe.com. If you do not use Acrobat 
Reader with Search, you can only view and print files; you cannot 
search across the collection of files.

NOTE To uninstall the documentation, delete the doc directory.

http://www.adobe.com
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3. Enter the word or text string you are looking for in the Find Results Containing 
Text field of the Adobe Acrobat Search dialog box, and click Search.

A Search Results window displays the documents that contain the desired text. 
If more than one document from the collection contains the desired text, they 
are ranked for relevancy.

4. Click the document title with the highest relevance (usually the first one in the 
list or with a solid-filled icon) to display the document.

All occurrences of the word or phrase on a page are highlighted. 

5. Click the buttons on the Acrobat Reader toolbar or use shortcut keys to 
navigate through the search results, as shown in the following table:

To return to the udsdoc.pdf file, click the Homepage bookmark at the top of 
the bookmarks list.

6. To revisit the query results, click the Results button at the bottom of the 
udsdoc.pdf home page or select Edit > Search > Results.

NOTE For details on how to expand or limit a search query using 
wild-card characters and operators, see the Adobe Acrobat 
Help.

Toolbar Button Keyboard Command

Next Highlight Ctrl+]

Previous Highlight Ctrl+[

Next Document Ctrl+Shift+]
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Installing Express

The Express software comes on the Express CD. You will need a CD-ROM drive 
accessible to your target installation node to install Express from the CD.

To install Express, you must already have installed iPlanet UDS System Software 
on your target node. The Express installer programs will not execute on machines 
without an installation of the iPlanet UDS system software.

For a list of platforms that the iPlanet UDS system software supports, see the 
platform matrix at http://www.forte.com/support/platforms.html.

If you are upgrading Express, see “Upgrading Express” on page 16.

Understanding the Express Directory Structure
The figure below shows a typical iPlanet UDS System Software directory structure. 
The FORTE_ROOT structure includes a userapp directory, where the Express 
installer places Express files. In the userapp directory, the Express installer creates 
an express directory. Within the express directory, the installer creates a clx 
directory, representing the compatibility level of the Express installation, and 
containing the Express image repositories.

The Express installer adds a compatibility level directory for each successive 
version of Express you install, rather than replacing existing directories. This way, 
you can refer to a prior Express release when necessary. For example, when you 
install Express for the first time, the installer creates a cl0 directory; when you 
install a succeeding version of Express, the installer creates a cl1 compatibility level 
directory, and then a cl2 directory, and so on.

http://www.forte.com/support/platforms.html
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Figure 1 Typical iPlanet UDS System Software Directory Structure with Express

Express Directories

Express compatibility
level directories—cl1, cl2, etc.

Directory for Express messages

sysdata
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Installing Express for the First Time
You install Express from the Express CD. The Express CD provides the Express 
software for every platform iPlanet UDS supports. The CD meets the ISO 9660 
standard, meaning that it is readable on UNIX, OpenVMS, and Windows 
platforms.

The CD contains platform-specific installation programs. Each directory on the 
Express CD, as shown in Figure 1 on page 14, contains the Express software and 
installer for its respective platform. The ALL_UNIX directory, for example, contains 
the Express software and installer for all the UNIX platforms iPlanet UDS 
supports.

UNIX

➤ To install Express on a UNIX node

1. Mount the Express CD.

2. Set your current directory to the ALL_UNIX directory on the CD.

Depending on your platform, the directory or command names may be in 
upper or lower case.

3. Type the following command.

./exinstal.sh

This starts the Express installer for UNIX, which prompts you through the 
Express installation process.

Windows

➤ To install Express on a Windows node

1. Mount the Express CD.

2. From the Program Manager, select File > Run.

This raises the Run dialog box.

3. Type the following command in the Run dialog box and click OK.

F:\PC_NT\SETUP
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VAX/OpenVMS or Alpha/OpenVMS

➤ To install Express on a VAX/OpenVMS or an Alpha/OpenVMS node

1. Mount the Express CD.

Running the following DCL script will assist with the mount command for the 
CD-ROM.

2. Start the Express installer, VMSINSTAL, using FTEXP as the saveset name.

Take the following commands as an example. For VAX/OpenVMS:.

$ SYS$UPDATE:VMSINSTAL FTEXP CD_ROM_device_name: [VAX_VMS]

For Alpha/OpenVMS:

$ SYS$UPDATE:VMSINSTAL FTEXP CD_ROM_device_name: [AXP_VMS]

Upgrading Express
When you conduct an Express installation atop an existing version of Express, the 
installer upgrades the installation. The Express installer upgrades an Express 
installation in part by integrating new versions of the following projects into the 
system baseline of your development repository:

• AppModel

• ExpressDBBrowser

$! Forte_CD.com:
$!   Mount a Forte software distribution CD-ROM on an
$!   OpenVMS node without specifying the volume name.
$! usage:
$!   @Forte_CD device_name 
$! example:
$!   @FORTE_CD DKA600: 
$!
$ devnam = f$getdvi(p1,"DEVNAM")
$ mount/noassist/override=identification ’devnam’
$ volume = f$getdvi(devnam,"VOLNAM")
$ dismount ’devnam’
$ mount/system/media=cdrom/undefined_fat=(FIXED:NONE:32256) -
 ’devnam’ ’EXPRESS’ cd
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• ExpressDomains

• ExpressServices

• ExpressWindows

Starting Express Release 5 with Non-Release 5 
Projects
You may have Express projects in your workspace that are not Express Release 5
projects if:

• you created projects with iPlanet UDS before using Express

• you created projects with earlier releases of Express

In these cases, you must upgrade your workspace and your repository. 

Upgrading Your Repository

➤ To upgrade your repository

1. Start the Express Release 5 application.

Express prompts you with the following dialog:

CAUTION To integrate these projects, the installer must check out all the classes 
in each of the projects listed above. If you have any classes in these 
projects checked out already, then the upgrade procedure will fail. 
You must undo the checkouts for all classes in the projects before 
starting the upgrade procedure.
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2. Click Yes to tell Express to proceed with the upgrade. 

Express then prompts you with another dialog:

3. Click Yes to tell Express to proceed with upgrading the repository.

Progress messages appear until the upgrade is complete.

Updating Your Workspace
If you share with others a repository of Express projects created with earlier 
releases of Express, and someone in your group has already upgraded it to Release 
5, you need only update your own workspace.

➤ To determine whether you need to update your workspace

1. Start the Express Release 5 application.

2. Choose the File > Open Workspace command.

If your workspace needs updating, Express prompts you with the following 
dialog:

3. Click OK to close the window.

➤ To update your workspace

1. In the Repository Workspace, choose File > Update Workspace command.
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