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Introduction

Welcome to Netshare and the Web Publisher applet. This User’s Guide 
documents Netshare, which allows individuals to have their own home sites on 
an iPlanet Web Server, and Web Publisher, which provides web publishing 
features for server clients. 
Computer System Requirements
Web Publisher needs specific software and hardware. 

Before you can install the Web Publisher control panel, you must be using a 
web browser that supports frames, Java, and JavaScript:

• Netscape Navigator 4.61 or 4.7

• Microsoft Internet Explorer 4.0 or higher

In addition, your computer must use one of these operating systems:

• For the Windows platform, use one of the following:

• Windows NT version 4.0 running Service Pack 5

• For the Macintosh PowerPC platform, use System 7.0 or later.

• For the Unix platform, use one of the following:

• Sun Solaris 2.6 or later

• Hewlett-Packard HPUX 11.0 or later
  Introduction 7



Contacting Technical Support
• IBM AIX 4.3.3 or later

• Compaq Tru64 UNIX 4.0d or later

Contacting Technical Support
For Technical Support assistance, please see the Technical Support Page at 
http://www.iplanet.com.
8 Installation and Migration Guide



C h a p t e r

1
Using Netshare
iPlanet Web Server clients can use Netshare to collaborate on projects by 
directly accessing, editing, and managing files on remote servers. Netshare, 
through its many services, provides sophisticated features for server clients, 
such as file management, editing and publishing, and access to Web Publisher 
features such as search and access control. 

Netshare provides you with a personal home page for storing, sharing, and 
managing their server documents. From your home page, you can also obtain 
information about how you are defined in the server’s user directory, such as 
your name, password, and telephone extension. 

This chapter discusses these topics:

• Using Your Netshare

• Customizing Your Netshare Home Page

Using Your Netshare
As a Netshare end user, you have your own personal home page that provides 
easy access to iPlanet Web Server user services, such as Web Publisher and 
search. You also have one or more personal Netshare home directories that 
Chapter 1, Using Netshare 9



Using Your Netshare
you can use for publishing documents that you want to store on the server. 
You can direct other users to this directory as a central repository of your server 
documents. 

This section discusses these topics:

• Displaying Your Home Page

• Controlling Access to Your Home Page

• Linking to Other Services

Displaying Your Home Page

To display your default Netshare home page, type in this URL: 

            http://<yourServer>/netshare/<yourUserID>

For example, for the user JDoe on the server Markets, you'd enter this URL: 

            http://Markets/netshare/JDoe

Another method for displaying your home page is to list of all Netshare users 
on your server by typing this URL and clicking on the link listed for your 
Netshare directory: 

            http://<yourServer>/netshare

Note It's a good idea to create a bookmark to your Netshare home page so you don't 
have to type the URL again each time you want to locate it. 

Controlling Access to Your Home Page

When your server administrator creates a Netshare home directory for your user 
ID, you are assigned as its owner and are the only one who can write to the 
directory. Other users can read your files, but cannot make any changes to 
them unless you explicitly provide such access permissions. 

This means that if you access another user’s Netshare folder (http://
<yourServer>/netshare), you can look at the contents of their home directory, 
but you cannot modify their files or folders unless they have explicitly set the 
access permissions to permit this. 
10 Netshare and Web Publisher User’s Guide



Using Your Netshare
If you are part of a group for which a Netshare has been created, you and all 
other members of the group have permission to modify the files and folders in 
the group’s Netshare directory. However, only the user designated as the owner 
by the server administrator can modify the access control rules for the group’s 
directory. 

Linking to Other Services

Your default Netshare home page displays a set of links that allow you to 
access many server functions, most of which operate on your home directory 
and the files it contains. 

Publishing:

• Web Publisher—You can have direct access to the files and folders in your 
home directory. 

• Access control—You can restrict access to your home directory. 

• Search—You can search on any collection set up for your server. 

• User information—You can review and modify your user information. 

• Help—You can look at Netshare online help. 

Some functions open a new browser window, others use the right frame to 
display their information. If you want to return to the original content of your 
right frame, click the Reload button in your browser. 

Web Publisher

When you click this link, the Web Publisher applet starts up. Because you 
launch it from your Netshare home page, Web Publisher displays all your 
Netshare files and folders. Initially, the list includes the default set of HTML files 
that are used to construct your home page, but you can add other files and 
folders as your needs dictate. 
Chapter 1, Using Netshare 11



Customizing Your Netshare Home Page
Access Control

When you click this link, the server displays the access control interface. This 
allows you to set the access control for the file currently displayed in the right 
frame. 

Search

When you click this link, the server’s search function starts up. This allows you 
to search on any collection (database of searchable data) that has been created 
for your server. This includes the default web publishing collection, which 
allows you to access the complete set of server files and folders for which you 
have access permission. 

User Info

When you click this link, the server displays a predefined subset of the 
information stored on the server for your user ID. Typically, this includes your 
name, password, and extension. You can use this form to change your server 
password. 

User’s Guide

When you click this link, the online help system is displayed. 

Customizing Your Netshare Home Page
By default, your Netshare home page displays the netshare.html file in the 
right frame. Initially this HTML file contains mostly text and a few sample links, 
but you or your server administrator can revise this file as desired to contain 
other text, graphics, links, and other HTML elements. 

This file is the starting point for a your workspace on the remote server and is 
what other users first see when they access your home page. As the owner of 
the home page, you or your server administrator may want to provide some 
explanation of what other files, folders, and services are available through the 
home page and display some navigational links to route other users through 
the site. 
12 Netshare and Web Publisher User’s Guide



Customizing Your Netshare Home Page
This is the default set of files that is installed in a Netshare home directory: 

• netshare.html - The default text that appears in the right frame.

• banner.html - The banner across the top.

• home.html - The frameset itself.

• menu.html - The set of links in the left frame.

• test1.html - A sample file.

• test2.html - A sample file.
Chapter 1, Using Netshare 13
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C h a p t e r

2
About Web Server Publishing
Web Publisher is a Java applet that runs on your local desktop and interacts 
with files managed by iPlanet Web Server. With Web Publisher, you can 
directly access, edit, and manage documents stored on remote servers. 
Members of workgroups can seamlessly collaborate on project content from 
their desktops. Web Publisher allows you to publish a document to the appro-
priate web server with the click of a button, without using ftp commands or 
other complex interfaces.

This chapter introduces these features of Web Publisher and provides an 
overview of web server publishing:

• File Management

• Editing and Publishing

• Search

• Controlling Access
Chapter 2, About Web Server Publishing 15



File Management
File Management
Web Publisher allows you to manage remote server files and folders. You have 
easy access to the server’s files and folders through a hierarchical list in the 
Web Publisher file management window. You can copy, move, rename, and 
delete files and directories. You can also download server files to your local 
system and upload your local files to the server. 

Each file and folder on the server has a set of properties that describe 
information about a file such as its filename, owner, lock status, size, and 
creation date, and this information is updated whenever the file is edited or 
added to the server. 

You can perform a search on any of these file properties. For example, you can 
search for all files that belong to a certain author, for all the locked files, or for 
any file with a particular string in the title field.

Editing and Publishing
With Web Publisher, you can edit server files in a variety of different formats, 
automatically launching the application associated with the file, such as 
Netscape Composer for HTML files, Adobe Acrobat for PDF files, and Microsoft 
Excel for spreadsheet files. 

You can configure Web Publisher to associate an editor program with a specific 
file type. For example, if you edit an HTML file or an ASCII file, Web Publisher 
defaults to opening the file in a Netscape HTML editor. If you edit a non-HTML 
file, Web Publisher launches the application associated with that file type. For 
example, if Microsoft Excel is associated with files that use the .xls extension, 
when you edit such files, Microsoft Excel is launched and you can work in 
Excel, saving the file as usual when you are done making changes.

When you edit a server file, Web Publisher places a small pen icon next to it in 
the Web Publisher applet window. During the edit, the file is in an “edit state,” 
which locks it so that other users cannot write to it, although they can still 
browse it. To make your new changes publicly available to other users on the 
server, you must publish the edited file back to the server. This updates the 
server file and makes it available to other users again. 
16 Netshare and Web Publisher User’s Guide



Search
As part of the process of publishing an edited file back to the web server, Web 
Publisher performs these tasks:

• unlocks the file

• updates the server file, making the revised file available for other users

• updates the file’s properties, such as a new modification date

• updates the file’s properties and content for searching

Search
With Web Publisher, you can search through the contents and file properties of 
documents on a remote server. For example, you can search for documents 
created after a certain date or for documents that contain the word web. 

For more information about the Web Publisher search function, see Chapter 6, 
“Using Search.”

Controlling Access
Web Publisher lets you control access to your Web Publisher files and folders. 
You can permit different users to have different types of access to your files and 
folders (for example, allowing one user only to read files, while another user 
can write or delete your files). You can define which documents an agent can 
monitor and you can restrict which documents you can search through.

For more information about setting access permissions, see Chapter 7, 
“Controlling Access.”
Chapter 2, About Web Server Publishing 17
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C h a p t e r

3
Installing and Configuring
Web Publisher is a Java applet that provides convenient client access to web 
server publishing. The default installation of iPlanet Web Server includes the 
Web Publisher applet with a home page. 

This chapter discusses some basic information about installing and configuring 
Web Publisher and describes issues specific to the version of Netscape 
Navigator you are using. The chapter includes these sections:

• The Web Publisher Home Page

• The Web Publisher Console Window

• Configuring Web Publisher

• User Access Requirements

• For Communicator and Composer Users

• For Internet Explorer Users

There is an optional plug-in for users of the Netscape Composer component of 
Netscape Communicator that enhances Composer’s editing and publishing 
capabilities to provide more seamless client access to server documents and 
folders.
Chapter 3, Installing and Configuring 19



The Web Publisher Home Page
The Web Publisher Home Page
The Web Publisher home page is included as part of the default iPlanet Web 
Server installation. From this page, you can launch Web Publisher, define the 
web publishing document directory, download the plug-ins appropriate for 
your system, and access online help.

To locate the Web Publisher home page, type in this URL: 

http://yourServer/publisher

This displays the Web Publisher home page, which has a Start Web Publisher 
button as well as useful links: one for downloading the plug-in and several for 
accessing the online help system. After installing the plug-in for your system, 
you can start Web Publisher from this page. 

When you launch Web Publisher, you need to identify which document 
directory you want it to use. By default, Web Publisher has the primary 
document directory as its scope. You can change this to point at a different 
folder on your server by choosing one from the drop-down list or by directly 
typing in the folder you want to use. Whichever folder you enter becomes 
added to the drop-down list for your future convenience. The list can hold 10 
folders. If you add additional folders, the first ones you entered are deleted 
from the list.

The Web Publisher Console Window
When you start up Web Publisher, a special Web Publisher browser window 
appears on your screen, as shown in Figure 3.1, that provides a Java 
environment for Web Publisher. This browser window must remain open in 
order for you to be able to run Web Publisher.
20 Netshare and Web Publisher User’s Guide



Configuring Web Publisher
Figure 3.1  The Web Publisher console window

Configuring Web Publisher
There are two configuration files that determine how Web Publisher works. 
One file, editor.txt, associates file types with applications that are to be 
launched when you open a file for editing. The other, nswppref.txt, stores 
information about your Web Publisher session such as your user name, 
window size, user preferences, and files being edited. These files are stored 
locally in your system in the folder that contains your Netscape Navigator 
program. For example, for a Windows user it might be in C:\Program 
Files\Netscape\Navigator. Typically, users do not need to modify these 
files. There are, however, some circumstances when you may want to make 
changes to these files. 

This section discusses these topics:

• The Editor Preferences File

• The Web Publisher Preferences File

The Editor Preferences File

Web Publisher allows you to associate a particular application with a given file 
type. When you edit a file, Web Publisher launches its associated application, 
which could be MS Word, MW Excel, Netscape Navigator’s HTML Editor, or 
some other program.
Chapter 3, Installing and Configuring 21



Configuring Web Publisher
The editor.txt file identifies which programs Web Publisher should use to 
edit files in different formats. By default there are entries in the editor 
preferences file to open HTML files in the editor part of your Netscape 
program, but you can add as many as you need to edit each of the different file 
types you work with. For example, if you have MS Word documents or GIF 
graphic files, you can edit them in MS Word or PaintShop Pro, respectively. 

You can edit the file by using the Editors popup dialog box available through 
the Preferences command on the Edit menu. This command displays a dialog 
box listing your editor preferences, which initially includes entries for HTML 
files with the html and htm extensions.

To add other entries, follow these steps:

1. Click the Add New button. The Set Editor Program dialog box is displayed.

2. Enter the file extension for the given file type, either without or without the 
preceding period. That is, you could type doc or .doc to define an editor 
for word processing documents. 

3. Enter the exact line of code to launch the editor. In many cases this will 
simply be the full pathname for the executable program file. For example:

C:\msoffice\winword\winword.exe

In other cases, you may need to enter a command that includes arguments 
or options. You can use the %f symbolic name to insert the file’s name into 
the command line, or %u to include the server URL.

4. Click the option “Use Communicator to edit directly on the server” if you do 
not want to create a temporary copy of the edited file on your local system 
during the editing process. 

The Web Publisher Preferences File

The nswppref.txt file defines your Web Publisher session. There are many 
program details listed in the file that define internal configurations, such as the 
size of applet window, and there are others you access from the Preferences 
command on the Edit menu. Normally you do not need to make any 
modifications to this file.
22 Netshare and Web Publisher User’s Guide



User Access Requirements
There is one situation in which you might need to manually change to this file. 
This occurs when an unexpected file is listed in the Publish All Edited Files 
dialog box. This might happen, which may happen when a user manually 
unlocks an “in edit” file through the Properties page. 

User Access Requirements
In order to use Web Publisher, you must be defined as a valid user with basic 
read or read-write permissions for iPlanet Web Server. See your server 
administrator if you have any questions about your user privileges. 

The default access control for iPlanet Web Server is to permit any defined user 
to have write privileges to the server’s files. Your server administrator can adjust 
this for a specific server. You can also adjust this for individual files and folders 
that you own by using Web Publisher’s access control function. See Chapter 7, 
“Controlling Access,” for more information.

For Communicator and Composer Users
This section applies to Web Publisher users who are using Netscape Communi-
cator and its Composer component. The section discusses these topics:

• Enabling Java

• Installing the Composer Plug-in

• Java Security Certificates

• Page Services Menu Command

• Using a Locally Installed Applet

Enabling Java

Web Publisher requires that you have Java enabled in your browser in order for 
the applet to run. To enable Java in the Netscape Navigator component of 
Netscape Communicator, do the following:
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For Communicator and Composer Users
1. From the Edit menu, choose Preferences.

2. Select the Advanced set of preferences.

3. Click Enable Java. 

Installing the Composer Plug-in

With the Composer plug-in, you can seamlessly edit and publish files on 
remote web servers. This is an optional plug-in that adds special web 
publishing capabilities to the editing and publishing functions. It also adds the 
Web Publisher Lock and Unlock menu commands to the Tools menu, which 
allows Composer users to lock and unlock remote files. In this way, you can 
perform web server publishing directly from the Communicator software on 
your local desktop.

The instructions listed here for installing the Composer plug-in assume that 
your Netscape Communicator installation is in the default directory. For 
example, on a typical Windows system, the default document directory would 
be:

C:\Program Files\Netscape\Navigator

If you are using a different directory, be sure to adjust the paths as you install 
the plug-in.

To install the Composer plug-in, go to the Web Publisher home page, as 
described in “The Web Publisher Home Page,” and follow the instructions there 
to download the plug-in. When you have installed the plug-in, you must restart 
Communicator to use the web publishing features in Composer. 

Java Security Certificates

Web Publisher is a signed applet that requires users to grant access through a 
Java Security certificate. The first time you attempt a Web Publisher operation 
that accesses local files, a series of windows are displayed that allow you grant 
or deny access to the applet.
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For Communicator and Composer Users
If you check the box to “Remember this decision each time I start 
Communicator,” the Java security checking is handled afterwards in the 
background for you. 

Page Services Menu Command

If you are browsing a server document in the Navigator component of Netscape 
Communicator, you can quickly access the file’s web publishing information in 
the Web Publisher Services page by using the page services menu command.

To do this, follow these steps:

1. Open a server document in the Netscape Navigator browser window.

2. From the View menu, choose the page services command.

The Web Publisher Services form is displayed, providing the Properties page 
for the document you are browsing. You can use any of these web publishing 
features:

• search

• access control

• online help

• the Web Publisher applet (this launches it if you haven’t already)

Using a Locally Installed Applet

You can set your server to use a copy of the Web Publisher applet that has 
been installed on your local machine. This can significantly improve the 
applet’s performance. 

To do this, follow these steps:

1. Go to the Web Publisher home page, at http://<server>/publisher.

2. In the center section, entitled “Netscape Communicator Users,” click the 
link for the Smart Update to download a local version of the applet.
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For Internet Explorer Users
3. On the Smart Update page, click the “Local Web Publisher” link at the 
bottom of the page. This installs a local version of the applet.

4. To set this version to be the default applet, click the “Use Local Version” 
button.

For Internet Explorer Users
This section applies to those Web Publisher users who are using Microsoft 
Internet Explorer. The section discusses these topics:

• Enabling Java

• Java Security Certificates

Enabling Java

Web Publisher requires that you have Java enabled in your browser in order for 
the applet to run. To enable Java in Internet Explorer, do the following:

1. From the View menu, choose Internet Options.

2. Select the Advanced tab.

3. Click JIT Compiler Enabled to allow Internet Explorer to create all Java 
applets automatically by using its internal compiler.

Java Security Certificates

Web Publisher is a signed applet that requires users to grant access through a 
Java Security certificate. The first time you attempt a Web Publisher operation 
that accesses local files, a series of pages are displayed that allow you grant or 
deny access to the applet.
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4
Web Publisher QuickStart
Web Publisher lets server clients directly access, edit, and manage files and 
folders on remote servers. In this way, multiple users can collaborate on shared 
workgroup web server documents from their desktops. 

This chapter focuses on a few of the most common tasks to get you up and 
running as quickly as possible. Other chapters describe the Web Publisher 
services and menu commands in detail. This chapter discusses these topics:

• Using the Web Publisher Interface

• Editing a Server File

• Adding a New File to the Server

• Viewing a File’s Information

The search and access control components of Web Publisher are discussed in 
other chapters. For search, see Chapter 6, “Using Search.” For access control, 
see Chapter 7, “Controlling Access.” 

Note Web Publisher provides many internal and automatic features such as file 
reindexing and state checking. If you use your local file management tools to 
manipulate files and folders in the document directory defined for Web 
Publisher, you may get inconsistent and unexpected results. 
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Using the Web Publisher Interface
When you start up Web Publisher, you see the server documents and folders 
displayed in a window that hierarchically lists all files and folders, as shown in 
Figure 4.1. There are several icons that provide information about a given file 
or folder. 

Figure 4.1  The Web Publisher window 
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Web Publisher Icons

As files undergo different operations, Web Publisher displays different icons in 
the Web Publisher window. Files that you have edited but haven’t yet 
published have a distinctive pen icon. Locked files also have special icons that 
differ depending on whether you or another user is the lock owner. Table 4.1 
shows the icons and their meanings. 

When a file that is being edited is published back to the server, the pen icon 
disappears. Likewise, when files that have been locked are unlocked, the lock 
icon or the circle icon disappears.

Sorting the Listed Files and Folders

You can choose to sort the files and folders in different ascending or 
descending sort sequences: by name, modification date, or size. 

To sort the files, click the heading for the column you want to sort by. 
Alternately, you can go to the View menu and choose the Sort command, 
selecting the appropriate sort sequence from the submenu (name, date, or 
size).

Table 4.1 File icons for different operations

Operation Icon

(no operation)

edited by you

locked by you

locked by another user
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Keyboard Shortcuts

Web Publisher uses many standard keyboard actions:

• If you double-click a file, it opens in a web browser window.

• If you double-click a folder, it opens (or closes if already open). 

• If you click the small plus or minus sign in the list next to a folder, it opens 
(or closes if already open).

• You can select a file or folder and move it to a new location by using the 
drag-and-drop method.

• You can select a file or folder and make a copy of it in a new location by 
pressing the Control key while you use the drag-and-drop method.

• You may sometimes need to move the cursor on the screen to refresh an 
hourglass cursor, updating it to an arrow cursor once more.

Toolbar Shortcuts

At the top of the Web Publisher file management window, the toolbar presents 
seven buttons as shortcuts for the most commonly used Web Publisher 
commands, as shown in Figure 4.2. The complete set of menu commands are 
described in Chapter 5, “Services and Menus.” 

Figure 4.2  The toolbar 

You can select a file or folder and use a toolbar button to execute a Web 
Publisher command. From left, the icons are:

• Open folder: opens the selected folder.

• New folder: creates a new folder within the selected directory.

• Browse file: opens the selected file in a web browser window.
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• Edit file: opens the selected file in an editor window.

• Publish file: allows you to publish an edited file back to the server. 

• Information: opens the Web Publisher Services page, displaying information 
about the selected file or folder.

• Search: launches the Web Publisher search interface.

Editing a Server File
This section describes how to edit a file stored on a remote web server and 
publish the modified file back to the server so that it is available for other users. 
When you edit a file, it becomes locked to other users until you have published 
it. 

With Web Publisher, you can edit any unlocked file that you have read and 
write permission for. Members of a workgroup often need to be able to make 
changes to shared files on a remote server as they collaborate on a project. 

To edit a file:

1. Select an unlocked file.

2. Click the Edit toolbar button. 

3. Click OK to launch the file’s editor application and begin editing the file. 

Depending on how your editor.txt file is set up, this command may launch 
Netscape Navigator’s HTML editor, Adobe Acrobat, Microsoft Word or Excel, 
a simple text editor, or another application that you have associated with 
this particular file’s format. See Chapter 3, “Installing and Configuring” for 
more information about setting up file editors. 

4. When you have made your changes, save the file in the editor application. 
If you are using the HTML editor in Netscape Navigator 3.01, do not use its 
Publish command. 
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The newly edited file is not available on the server for other users until you 
publish it. To publish an edited file to the server:

1. Select the edited file.

2. From the File menu, choose the Publish an Edited File command. The 
Publish File dialog box appears.

3. Click OK to publish the file.

The edited file is again available on the server and Web Publisher unlocks the 
file.

Adding a New File to the Server
Another common task is to add a new file to the server by uploading a local 
file. Whether the file is an application, a word processing document, a PDF file, 
a spreadsheet, or an HTML file—you can add it to the server with Web 
Publisher. 
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To move one of your local files onto the server, do the following:

1. In the Web Publisher window, select the folder where you want to place 
your new file. 

2. From the File menu, choose the Upload to Server menu command. The 
Upload File or Folder dialog box appears.

3. In the Upload Local File or Folder field, type the full pathname of your local 
file. If you are using Communicator, you can click the Browse button to 
look for the file on your local system.

4. Your destination folder’s pathname appears in the To Server File or Folder 
field. You can also change the destination that appears. 

5. You can lock a file when you put it on the server by checking the “Lock 
files after upload” option. The default is not to lock files.

6. Click Upload to add your local file to the server.

7. A dialog box is displayed asking you to update the file properties for this 
file. Click OK to go to the Web Publisher Services page with the Properties 
for this file.

Viewing a File’s Information
You can view a file’s default and custom properties from the Web Publisher 
Services page. 
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Figure 4.3  The Web Publisher Services page 

File Properties

There are two types of file properties: default and custom properties. Each Web 
Publisher file has a set of default properties, and these are displayed when you 
click the Properties link. You can only modify the owner of a file, and then 
only if you are the assigned owner or the file has no owner. Your server 
administrator can also define some custom properties and these are displayed 
when you click the Custom Properties link. You can enter your own values for 
any property that has been designated as modifiable by your server 
administrator.

Default Properties

To see the default properties, follow these steps:

1. Select a file from the Web Publisher window.

2. Click the Information toolbar button or choose the Properties command 
from the View menu. The Web Publisher Services form is displayed with the 
file’s properties page visible.
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3. If the file’s properties are not visible, click the Properties link to display 
them.

Files have the set of default properties listed here. Folders have only two 
modifiable properties, Description and Owner, and four read-only properties: 
Filename, URL, Size, and Modified. Also see Chapter 5, “Services and Menus,” 
for information about properties.

• Owner—The user name assigned to the file. Only owners can modify this 
field. If a file has no owner, anyone can define themselves as owner. See 
Chapter 7, “Access Control,” for more information about file ownership.

• Title: The HTML title, as tagged with the HTML tag of <TITLE>. This 
property is only available when the file’s content is made searchable.

• Author: The file’s author, as tagged with the HTML tag of <META 
NAME="Author">. This property is only available when the file’s content 
is made searchable.

• Description—A description for the file, as tagged with the HTML tag of 
<META NAME="Description">. This property is only available when 
the file’s content is made searchable.

• Lock-Status—The current lock status for the file. If a file is locked, only the 
lock owner can unlock it. 

• Lock-Owner—The user name for the user that locked the file. Only the lock 
owner can unlock a file.

• Filename—The name of the file. 

• Path—The relative filename for the file. This is the filename without the 
root directory. 

• URL—The file’s full pathname. 

• Size—The size, in bytes, of the file. 

• Created—The date when the file was created.

• Modified—The date when the file was last modified.

• Searchable Contents—A flag indicating whether or not the contents are 
searchable. The default is Yes. 
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You can perform a search on any property as well as on any searchable file 
contents. For example, you can search for all files that belong to a certain 
author, for all the locked files, or for any file with a particular string in the title 
field. For more information about doing searches, see Chapter 6, “Using 
Search.” 

Custom Properties

To see the default properties, follow these steps:

1. Select a file from the Web Publisher window.

2. Click the Information toolbar button or choose the Properties command 
from the View menu. The Web Publisher Services form is displayed with the 
file’s properties page visible.

3. Click the Custom Properties link. A list of properties with their current 
values is displayed.
36 Netshare and Web Publisher User’s Guide



C h a p t e r

5
Services and Menus
Web Publisher provides many sophisticated file management functions. There 
are two ways to access this functionality: through links and buttons on the Web 
Publisher Services page and through the Web Publisher menu commands. 

This chapter describes the Web Publisher Services page and then the menus, 
with each command described in the order in which it appears on the menu: 

• Web Publisher Services Page

• The File Menu

• The Edit menu

• The View Menu

• The Help Menu

The functional areas of search and access control are described in separate 
chapters. For text search, see Chapter 6, “Using Search.” For access control, see 
Chapter 7, “Controlling Access.” 
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Web Publisher Services Page
The Web Publisher Services page provides many file management functions in 
a single form plus providing direct access to access control, search, and help. 
This section describes the functions and services available from this page. 

To display the Web Publisher Services page, do the following:

1. Select a file or folder in the Web Publisher window.

2. Click the Information toolbar button or choose Properties from the View 
menu. The Web Publisher Services page is displayed with the file’s 
properties visible.

Note Users of Netscape Communicator can choose the Page Services command from 
the Communicator’s View menu to display the Web Publisher Services page for 
the file currently being browsed. 

Figure 5.1  The Web Publisher Services page 
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Properties

Web Publisher files and folders have a set of default properties that describe 
many of their attributes. For example, when a file was created, who the lock 
owner is, and what its URL is. 

To access the properties for a file or folder from Web Publisher, do the 
following:

1. Select the file or folder in the Web Publisher window.

2. Click the Information toolbar button or choose Properties from the View 
menu. The Web Publisher Services page is displayed with the file’s 
properties visible.

To access the properties for a file or folder through the Web Publisher Services 
page, do the following:

1. Click the Properties link. The Web Publisher Services window appears with 
the file or folder properties in the right frame.

Figure 5.2  The Properties for a file 

Files have the set of default properties listed here. Folders have only two 
modifiable properties, Description and Owner, and four read-only properties: 
Filename, URL, Size, and Modified.
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• Owner—The user name assigned to the file. Only owners can modify this 
field. If a file has no owner, anyone can define themselves as owner. See 
Chapter 7, “Access Control,” for more information about file ownership.

• Title: The HTML title, as tagged with the HTML tag of <TITLE>. This 
property is only available when the file’s content is made searchable.

• Author: The file’s author, as tagged with the HTML tag of <META 
NAME="Author">. This property is only available when the file’s content 
is made searchable.

• Description—A description for the file, as tagged with the HTML tag of 
<META NAME="Description">. This property is only available when 
the file’s content is made searchable.

• Lock-Status—The current lock status for the file. If a file is locked, only the 
lock owner can unlock it. 

Note If a file is in an “edit” state, it is displayed as locked. Do not unlock it from this 
form because although the file would now appear as no longer locked or in an 
“edit” state, it still must be published (with the Publish All Edited Files 
command) before it is available to other users.

• Lock-Owner—The user name for the user that locked the file. Only the lock 
owner can unlock a file.

• Filename—The name of the file. 

• Path—The relative filename for the file. This is the filename without the 
root directory. 

• URL—The file’s full pathname. 

• Size—The size, in bytes, of the file. 

• Created—The date when the file was created.

• Modified—The date when the file was last modified.

• Searchable Contents—A flag indicating whether or not the contents are 
searchable. The default is Yes. If set to No, you can make the contents 
searchable by clicking the “Make contents searchable” checkbox. After you 
click Modify, the file contents are available for searching.
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If set to Yes, you can make contents no longer searchable by clicking the 
checkbox. After you click Modify, the file contents are no longer available 
for searching.

You can perform a search on any property as well as on any searchable file 
contents. For example, you can search for all files that belong to a certain 
author, for all the locked files, or for any file with a particular string in the title 
field. For more information about doing searches, see Chapter 6, “Using 
Search.” 

Modifying a File’s Properties

You can change some properties for a file or folder. You can assign yourself as 
owner of a file or folder that has no owner or you can reassign ownership for 
files and folders that you own, you can lock an unlocked file or you can unlock 
files that you have locked, and you can make the file’s contents searchable or 
unsearchable. You can enter new values for title, author, and description, and 
Web Publisher will use your new values instead of those defined in the file.

To modify these fields, follow these steps:

1. Type in your new data and click any checkbox option you want to change.

2. Click Modify to change the existing property value, or click Reset to revert 
to the original value.

This function reindexes the selected file, updating the searchable properties 
(and file contents if that option is chosen). 

Custom Properties

Your server administrator can create additional custom properties for the web 
publishing collection. Once he or she has created them, these properties are 
included whenever a file that is part of the web publishing collection is 
indexed. Such properties are user-modifiable and Web Publisher uses any 
values you input instead of the original value in the file once you make 
changes. The indexing process makes these custom properties available to you 
for viewing and searching. 
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Figure 5.3  Custom properties 

Note If a file has not been indexed since the adding of the custom property, the 
property is not viewable. Custom properties are not available until a file has 
been reindexed. 

To view the custom properties for a file, do the following:

1. Access the Web Publisher Services page through one of the methods 
described in “Web Publisher Services Page.”

2. Click the Custom Properties link. This displays a list of the custom 
properties that were defined by the server administrator at the time this file 
was last indexed. 

Web Publisher Button

This button is useful for users of Netscape Communicator who have accessed 
the Web Publisher Services page through the page services item on the 
Communicator’s View menu. When you click this button, a new Web Publisher 
applet is launched.

Access Control Button

When you click this button, the access control page is displayed. See Chapter 7, 
“Controlling Access” for more information about access control.
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Search Button

When you click this button, the Search page is displayed. See Chapter 6, “Using 
Search” for more information about performing searches.

Help Button

When you click this button, the online help file containing information for this 
screen is displayed. This help file also contains information about the menu 
commands in Web Publisher.

The File Menu
The File menu provides menu commands that allow you to manage server 
folders, edit and publish files, and upload and download files and folders. 

Creating a New Folder

The Web Publisher allows you to create new folder on the server. Because this 
writes a new file to the server, you must have write permission in order to do 
this. Web Publisher prompts you for your password to authorize the operation. 

To create a new folder on the server file system:

1. Select the existing folder that is to contain the new folder. You can choose 
the primary document directory, or root.

2. From the File menu, choose New Folder or click the New Folder toolbar 
button. The Create New Folder dialog box appears with your folder 
displayed in the Make Folder In field. If you chose to make the folder at the 
root directory, the field is left blank.

3. Type the name for your new folder in the New Folder’s Name field. Do not 
begin with a "/" or use spaces or apostrophes in the name.
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4. Click Create to create the folder, or click Cancel to close the window and 
leave the server files untouched.

You cannot create a new folder with the same name as a folder that already 
exists in that directory on your server. If you try, you get an error message and 
the operations fails.

Opening an Existing Folder

The Web Publisher allows you to open an existing folder on the server, which 
implicitly reloads the current server data for this folder.

To open a folder on the server file system:

1. Select the existing folder to open. 

2. From the File menu, choose Open Folder or click the Open Folder toolbar 
button. 

The folder is displayed in the Web Publisher window as open, with its files and 
subfolders visible.

Browsing a File

You can browse many types of server files in your web browser. HTML files are 
displayed as is. PDF, email, and news files are displayed as plain text in your 
browser. Files in other format, such Microsoft Word and Excel can be viewed in 
their original format if you have a helper application defined for your browser. 
If you don’t, the web browser prompts you to identify which application should 
be used. 

To view the contents of a file on the server:

1. Select the file.

2. From the File menu, choose Open File in Browser or click the Browse 
toolbar button.

The file is displayed in a web browser window. 
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Editing a File

You can edit unlocked files, or files that you locked, if you have write access 
permission for the files. Web Publisher puts the file into an “edit state,” locking 
out other users so that they cannot edit your file until you have published it 
back to the server. 

Depending on what your editor preferences are, this command launches 
Netscape Navigator’s HTML editor, Netscape Composer, Adobe Acrobat, 
Microsoft Word or Excel, a simple text editor, or some other application that 
you have associated with this particular file’s format. If you do not define an 
editor program for a given file type, Web Publisher displays an Editor 
Launching Error when you open the file for editing. 

To edit a file in Web Publisher:

1. In the Web Publisher window, select the file you want to edit.

2. From the File menu, choose Open File in Editor to launch the file’s editor 
application and begin editing the file.

3. When you finish modifying the file, save it in the application and return to 
the Web Publisher window.

To edit a file in Netscape Composer:

1. From Netscape Navigator’s File menu, use the Open File command to select 
the server file for editing in Composer by entering the file’s URL. This 
causes Web Publisher to lock the file so other users cannot edit it simulta-
neously.

2. In Composer, edit the file as usual.

3. When you finish modifying the file, use the Composer’s Publish command 
to put it back on the server.

Canceling an Edit

You can cancel an edit operation before you save your changes in the editor 
application, while the file is still in an “in edit” state, so that your file is 
unlocked and remains unchanged on the server. 
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To cancel an edit:

1. From the File menu, choose Cancel Editing File.

2. The Cancel File Edit dialog box appears. Click Yes to confirm that you want 
to cancel the edit.

Publishing Edited Files

An edited file is not available for others to modify until it has been published 
back to the server. Until it is published, it is in an edit state, which locks out 
other users. The properties and content of new HTML files are automatically 
indexed during the publishing operation, making them available for searching. 
If you are publishing a revised existing file, the publishing operation reindexes 
the file’s properties (and contents, if that option is selected on the Properties 
page). 

Note If a file was manually locked before you edited it, publishing the file releases 
the manual lock as well as the implicit editing lock.

Publishing an Edited File 

When you finish editing a file and save it, the new version is still not available 
on the server for other users until you publish it. You can only publish your 
own edited files. When you publish a file that does not have an owner, you are 
assigned as the file’s owner. 

To publish an edited file to the server:

1. In the Web Publisher window, select the edited file.

2. From the File menu, choose Publish An Edited File, or click the Publish 
toolbar button. The Publish File dialog box appears with your file’s name in 
the Publish File field.
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Figure 5.4  Publish an Edited File dialog box 

3. Click Publish to publish the file.

The edited file is again available on the server.

Note If you are using Netscape Composer, when you complete your changes, use 
the Composer’s Publish command to restore it to the server. This causes Web 
Publisher to unlock the implicit edit lock on the file. 

Publishing all Edited Files

When you finish editing a file and save it, the new version is still not available 
on the server for other users until you publish it. If you have edited more than 
one file for a given server, you can publish them all simultaneously rather than 
publish each file separately. If you have only edited one file, this function is 
disabled.

When you publish a file that does not have an owner, you are assigned as the 
file’s owner.

To publish all edited files to the server:

1. From the File menu, choose Publish All Edited Files. The Publish All Edited 
Files dialog box appears with a list of all files in the “edit” state.

2. Click Publish to publish the files.

The edited files are again available on the server.
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Uploading to Your Server

You can put a file or folder from your local system onto the server, making it 
available for other users. Whether a file is an application, a word processing 
document, a PDF file, a spreadsheet, or HTML file—you can upload it to the 
server with Web Publisher. 

The properties and content of new HTML files are automatically indexed during 
the upload, making them available for searching. If you are uploading a revised 
existing file, uploading reindexes the file’s properties (and contents, if that 
option is selected on the Properties page). 

You can add a file or folder to an existing folder and set it to be locked or 
unlocked. When uploading a folder to the server, you can also upload its 
subfolders. 

You can establish a default upload directory on your local system that becomes 
the location where Web Publisher expects your local files to be found. To do 
this, you define a local directory for uploading and downloading as described 
in “User Preferences.” 

To upload a file:

1. In the Web Publisher window, select the file that you want to replace or 
update or select the folder that is to contain the new file.

2. From the File menu, choose Upload to Server. The Upload File or Folder 
dialog box appears.

Figure 5.5  Upload dialog box 

3. In the Upload Local File or Folder field, type the full pathname of your local 
file. If you have defined a default upload folder, the folder’s name is already 
displayed. 
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Note: If you upload a folder and files with the same names as those already 
existing on the server, Web Publisher overwrites the existing folder and 
files.

4. Your destination folder’s pathname appears in the To Server File or Folder 
field. You can also change the destination that appears. 

5. You can lock a file when you put it on the server by checking the “Lock 
files after upload” option. The default is not to lock files.

6. Click Upload to add your local file to the server. 

7. A dialog box is displayed asking you to update the file properties for this 
file. Click OK to go to the Web Publisher Services page with the Properties 
for this file.

To upload a folder (for Communicator users only):

1. In the Web Publisher window, select the folder that you want to replace or 
update or that is to contain the newly uploaded folder.

2. From the File menu, choose Upload to Server. The Upload File or Folder 
dialog box appears.

3. In the Upload Local File or Folder field, type the full pathname of your local 
folder. If you have defined a default upload folder, the folder’s name is 
already displayed. An alternative is to click the Browse button to find it on 
your local system.

4. To upload your folder’s subfolders, check the Include Subfolders checkbox. 
The default is not to upload subfolders.

Note: If you upload a folder and files with the same names as those already 
existing on the server, Web Publisher overwrites the existing folder and 
files.

5. Your destination folder’s pathname appears in the To Server File or Folder 
field. You can also change the destination that appears. 

6. You can lock the folder’s files when you put them on the server by 
checking the “Lock files after upload” option. The default is not to lock files.
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7. Click Upload to add your local folder to the server. A dialog box is 
displayed giving you a summary of the completion status for the uploaded 
folders and files.

8. A dialog box is displayed asking you to update the properties for this 
folder. Click OK to go to the Web Publisher Services page with the 
Properties for this folder.

Downloading From the Server

You can download a file or a folder from the server to your local system. You 
can choose to also download the subfolders within the folder you want to 
download and you can choose to lock the server files that you are 
downloading. 

You can establish a default download directory on your local system that 
becomes the location where Web Publisher places your downloaded files. To 
do this, you set a user preference as described in “User Preferences.” 

• When you download a file or folder with the Lock Server Files option set, 
the server files are locked so that other users can no longer edit the original 
server file. 

• You cannot download locked or edited files as Lock for Editing unless you 
are the owner of the file. 

To download a file or folder

1. In the Web Publisher window, select the file or folder you want to 
download.

2. From the File menu, choose Download From Server. 

For files, the Download File dialog box appears with the name of the 
selected file in the Download Server File field. 
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Figure 5.6  Download file dialog box 

For folders, the Download Folder dialog box appears with the name of the 
selected folder in the Download Server Folder field. 

Figure 5.7  Download dialog box 

3. For folders, you can check the Include Subfolders option to also download 
any subfolders within the selected folder.

4. Type the download destination in the To Local File (for files) or To Local 
Folder (for folders) field. If you have defined a default download folder, the 
folder’s name is already displayed. For files, you can type in a different 
filename to rename the file as part of the download operation. 

5. You can place a lock on the server files you are downloading by choosing 
the Lock Server Files option. The default is not to lock files.

6. Click Download to download a server file or folder to your local system. 
For folders, a dialog box is displayed giving you a summary of the 
completion status for the downloaded folders and files.

Note You can also “download” a file from the server to your local drive by opening 
the file in a web browser and using the Save As menu command from the 
Navigator’s File menu. Saving a file in this manner is not recommended because 
it skips the automatic link management and indexing functions that are 
provided by Web Publisher. Files saved in this way require manual intervention 
to update their links and to index their contents and properties. 
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Exiting from Web Publisher

You can exit from Web Publisher at any time. To relaunch Web Publisher, you 
must return to the Web Publisher home page. See the section “The Web 
Publisher Home Page” in Chapter 3, “Installing and Configuring” for 
information about the home page. 

The Edit menu
The Edit menu provides menu commands that allow you to lock and unlock 
files; copy, move, rename, and delete files and folders; and set user 
preferences. 

Locking and Unlocking a File

Once you have locked a file, other users cannot move, rename, delete, or edit it 
until you unlock it. You can manually lock a file when you do not want other 
users to have access to it. You can also direct Web Publisher to lock files that 
you are downloading. 

You can unlock any file that you locked or any file that you downloaded with 
the Lock Server Files option checked. You cannot lock a folder.

Note You can unlock a file that is being edited by another user, but you are strongly 
recommended not to do this. If you do, Web Publisher continues to list the file 
as a file that needs to be published even though the pen icon is removed from 
the Web Publisher window. 

Locking a File

You can lock any file, including those owned by another user. If you lock a 
file, the file is displayed in the Web Publisher Services page with you as the 
lock owner and only you can unlock it.
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To manually lock a file: 

1. In the Web Publisher window, select the file you want to lock.

2. From the Edit menu, choose Lock. If you did not set a user preference to 
confirm locking operations, the file is locked at this point.

3. If you have set the user preference to request lock confirmations, the Lock 
File dialog box appears with your file’s name in the Lock File field.

4. Click the Lock button to lock the file.

Note Communicator users with the Composer plug-in can also manually lock a 
server file from the Composer application on their local system by using Lock 
from the Web Publisher command on the Tools menu.

Unlocking a File

If you locked a file, you can unlock it. The server administrator is also 
authorized to unlock a file that you have locked. 

To unlock a file:

1. In the Web Publisher window, select the file you want to unlock.

2. From the Edit menu, choose Unlock. If you did not set a user preference to 
confirm unlocking operations, the file is unlocked at this point.

3. If you have set the user preference to request unlock confirmations, the 
Unlock File dialog box appears with your file’s name in the Unlock File 
field.

4. Click the Lock button to unlock the file.

Note Communicator users with the Composer plug-in can also manually unlock a 
server file from the Composer application on their local system by using Unlock 
from the Web Publisher command on the Tools menu.
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Copying Files and Folders

You can copy locked and unlocked files and folders. You need read and write 
permission for all the files and folders within a folder in order to be permitted 
to copy the folder. You are assigned as the owner of the new folders and files.

Copying a File

When you copy a file, you become the owner of the copied file. You can copy 
locked and unlocked files. 

To copy a file:

1. Select the file in the Web Publisher window.

2. From the Edit menu, choose Copy to (or use the Control key and then drag-
and-drop method to copy the file into a new location). The Copy File or 
Folder dialog box appears with the name of the selected file in the Copy 
File or Folder field. 

Figure 5.8  Copy dialog box 

3. Enter the filename for the new copy in the To File or Folder field (if you 
used the drag-and-drop method the file in step 2, this field is already filled 
in).

4. Click Copy to copy the file.

Copying a Folder

When you copy a folder, all the files and folders within it are copied and you 
become the owner of the new files and folders. 
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To copy a folder:

1. Select the folder in the Web Publisher window.

2. From the Edit menu, choose Copy to (or use the Control key + drag-and-
drop method to copy the folder in a new location). The Copy File dialog 
box appears with the name of the selected folder in the Copy file field. 

3. Enter the path for the new copy of the folder in the To file field (if you used 
the drag-and-drop method the file in step 2, this field is already filled in).

4. Click Copy to copy the folder and its files.

Moving Files and Folders

You can move unlocked server files and folders. Moving requests are subject to 
access control restrictions for the specified folder or file that you wish to move. 
If you want to prevent other users from moving your folders and files, you can 
use the access control function to limit the Delete access right to yourself. See 
Chapter 7, “Controlling Access,” for more information about access control. 

Moving a File

You can move an unlocked file if you have delete privileges for the file. You 
cannot move a locked or unpublished file. When you move a file that has no 
owner, you are assigned as the owner of the file. If the file already has an 
owner, the ownership is not changed.

To move a file:

1. Select the file in the Web Publisher window.

2. From the Edit menu, choose the Move to command (or use the drag-and-
drop method to drag the file to its new location). The Move File or Folder 
dialog box appears with the name of the selected file in the Move File or 
Folder field. 
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Figure 5.9  Move dialog box 

3. Enter the name of the folder that is to contain the moved file in the Within 
Folder field (if you used the drag-and-drop method the file in step 2, this 
field is already filled in). Do not type in a filename.

4. Click Move to move the file.

Moving a Folder

You can move a folder if you have read-write privileges for the folder and all 
the files within it. You cannot move a folder if there is any locked or unpub-
lished file within the folder. When you move a folder and files that are not yet 
assigned any owner, you are assigned as the owner of the folder and its files. If 
the folder and files already have an owner, the ownership is not changed.

To move a folder:

1. Select the folder in the Web Publisher window.

2. From the Edit menu, choose Move to command (or use the drag-and-drop 
method to drag the file to its new location). The Move File dialog box 
appears with the name of the selected folder in the Move file field. 

3. Enter the new path for the folder in the To dir field (if you used the drag-
and-drop method the file in step 2, this field is already filled in).

4. Click Move to move the folder and its files.

Renaming Files and Folders

You can rename unlocked server files and folders. Renaming requests are 
subject to access control restrictions for the specified folder or file that you wish 
to rename. If you want to prevent other users from renaming your folders and 
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files, you can use the access control function to limit the Delete access right to 
yourself. See Chapter 7, “Controlling Access,” for more information about 
access control. 

Renaming a File

You can rename an unlocked file within a folder if you have read-write privi-
leges for the file. You cannot rename locked or unpublished files. When you 
move a file that has no owner, you are assigned as the owner of the file. If the 
file already has an owner, the ownership is not changed.

To rename a file:

1. Select the file in the Web Publisher window.

2. From the Edit menu, choose Rename. The Rename File dialog box appears 
with the name of the selected file in the Rename file field.

Figure 5.10  Rename dialog box 

3. Enter the new name for the file in the To Name field. Do not type in the 
file’s path. That is, type newIndex.html, not /docs/newIndex.html.

4. Click Rename to rename the file.

Renaming a Folder

You can rename a folder if you have read-write privileges for the folder and all 
the files within it. You cannot rename a folder if there is any locked or unpub-
lished file within the folder.When you rename a folder and files that are not yet 
assigned any owner, you are assigned as the owner of the folder and its files. If 
the folder and files already have an owner, the ownership is not changed. 

To rename a folder:
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1. From the Edit menu, choose Rename. The Rename File dialog box appears 
with the name of the selected folder in the Rename file field.

2. Enter the new folder name for the folder in the To Name field. Do not type 
in any additional pathname information. That is, type Project-X, rather 
than /docs/Project-X.

3. Click Rename to rename the folder.

Deleting Files and Folders

You can delete unlocked files and folders on the server. Once you delete a file, 
it is no longer searchable. Delete requests are subject to access control restric-
tions for the specified folder or file that you wish to delete. If you want to 
prevent other users from deleting your folders and files, you can use the access 
control function to limit the Delete access right to yourself. See Chapter 5, 
“Services and Menus,” for more information about access control.

You can set a user preference to request confirmation of delete operations. This 
is the default and is the recommended method. See “User Preferences” for more 
information.

Deleting a File

You can delete an unlocked file if you have delete permission for the file. You 
cannot delete locked or unpublished files. Once you delete a file, you can no 
longer search on its properties or contents. 

To delete a file:

1. Select the file in the Web Publisher window.

2. From the Edit menu, choose Delete or press the Delete key. If you did not 
set a user preference to confirm deletions, the file is deleted at this point.

3. If you have set the user preference to request delete confirmations, the 
Delete File or Folder dialog box appears with your file’s name in the Delete 
File or Folder field.
58 Netshare and Web Publisher User’s Guide



The Edit menu
Figure 5.11  Delete confirmation dialog box 

4. Click Delete to delete the file or Cancel to close the window and leave the 
server file untouched. 

Deleting a Folder

You can delete a folder if you have delete permission for the folder and for 
every file within the folder. You cannot delete a folder if there is any locked or 
unpublished file within the folder.

To delete a folder:

1. Select the folder in the Web Publisher window.

2. From the Edit menu, choose Delete or press the Delete key. If you did not 
set a user preference to confirm deletions, the folder is deleted at this point.

3. If you have set the user preference to request delete confirmations, the 
Delete File or Folder dialog box appears with your folder’s name in the 
Delete File or Folder field. 

4. Click Delete to delete the folder or Cancel to close the window and leave 
the server folders untouched. 

Note Your server administrator cannot restore deleted folders. However, when you 
restore a file that was inside a folder that has also been deleted, Web Publisher 
recreates the same folder structure for your file as you had before you deleted 
it. This may mean that one or more folders must be created to replicate the 
path structure. These folders will have the same names as the deleted folders, 
but will be empty. 
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User Preferences

You can set several preferences for Web Publisher: user name, operations to 
confirm, display font, and which local folders to use for uploading, 
downloading, and storing “in edit” files. These are stored in the 
nswppref.txt file in your Navigator’s WebPub folder along with some other 
settings that Web Publisher sets for you internally. Communicator users can 
also set their editor preferences from this menu. See the section, “The Web 
Publisher Preferences File,” for more information about this file.

User Name Preference

The User Name Preference dialog box lets you enter a new user name for Web 
Publisher. Many Web Publisher operations depend on the user’s name to 
identify the owner or lock owner for a file. 

You can check a checkbox that allows you to set this name as the default 
name, which means that Web Publisher does not require you to input your user 
name each time you launch Web Publisher. If you want to be prompted for a 
user name whenever you start up Web Publisher, do not check the default 
name checkbox. 

If you leave the user name field blank, you are prompted for user name and 
password rather than just the password when you execute an operation that 
requires authorization. 

You must use a username that is valid for your server. See your server adminis-
trator for more information, if necessary. Actions that require a authorization 
include editing, uploading, copying, moving, and renaming files as well 
creating a new folder on the server. 

Figure 5.12  The user name preference dialog box 
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Operations to Confirm

The Operations to Confirm dialog box lets you to direct Web Publisher to ask 
for confirmation whenever you use the drag-and-drop method to copy or move 
files or folders, or whenever you delete, lock, or unlock files or folders. Without 
these options checked, Web Publisher immediately performs the action without 
giving you a second chance to revisit your decision.

Figure 5.13  The confirm operations dialog box 

Directories

The Local Folder Preferences dialog box allows you to set two types of folder 
preferences: for uploading or downloading files and for storing “in edit” files. 

You can set a preference for which local folder is to serve as the source folder 
for upload operations and as the destination location for downloads. You need 
to enter the full physical path, For example, C:\Projects\TempDir. 

You can also set a preference for which local folder to use for files during 
editing, that is, as the temporary storage folder for files in an “in edit” state. 
Unless you are using Netscape Composer to edit your HTML files and you have 
set your editor preference to edit directly on the server, files being edited are 
temporarily copied to your local system. Once you publish the file, the 
temporary “in edit” file is deleted from your local system.

You cannot change your local folder preferences while a file is still in an edit 
state. You must publish all edited files before you can change a directory 
preference.

Note For Windows systems that require 8.3 file notation, you must use pathnames 
with this notation for your directory preferences. Because it occurs so 
frequently, Web Publisher handles one case for you automatically: If the folder 
you want to use for files during editing has Program Files as part of its 
pathname, Web Publisher translates it to Progra~1 for you.
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Figure 5.14  The local folder preferences dialog box 

Font

The Font Chooser dialog box lets you define the font, font size, and font style 
to display in the window. Fonts in other windows and dialog boxes are not 
modifiable. 

To close this dialog box, you must click the button in the top left corner. 
Clicking the Set button does not make the dialog box disappear. 

Figure 5.15  The font chooser dialog box 

Editors

The Editor Preferences dialog box lists the defined editor applications that have 
been associated with specific file types. The default is to list the Composer 
component of Netscape Communicator as the HTML editor of choice.
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Figure 5.16  The editor preferences 

If you want to associate another editor program with a specific file type, you 
can use the Set Editor Program dialog box to enter the file extension for the file 
and indicate the executable program file.

Figure 5.17  The set editor program preferences dialog box

The View Menu
The View menu provides several commands for viewing or redisplaying Web 
Publisher data. The first command, Properties, displays the Web Publisher 
Services page, which is the main page for viewing data about your files and 
folders. From this page, you can check links and view any custom properties 
that have been defined.

The other View menu commands let you to change the sort sequence for the 
contents of the window, to reload and refresh the window data, and to show or 
hide the Web Publisher toolbar.
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Properties

To view a file’s properties through the Web Publisher Services page, do the 
following:

1. Select the file.

2. From the View menu, choose Properties or click the Information toolbar 
button. The Web Publisher Services window appears. See “Properties” 
earlier in this chapter and “File Properties” on page 34 in Chapter 4, “Web 
Publisher QuickStart” for more information.

Sorting Files and Folders

You can choose to sort the files and folders in various different sort sequences. 
There are two ways to do this:

• From the View menu, choose Sort By and choose the appropriate sort 
sequence from the submenu (Name, Date, or Size). 

• Alternatively, you can click the heading above the name, date, or size 
columns to resort the files and folders displayed in the window.

Redrawing the Window

You can choose to redraw the Web Publisher window to resolve display 
problems you may have with the current image of the window.

To redraw the window, do this:

1. From the View menu, choose Redraw Window.
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Reloading the Window

You can reload the Web Publisher window to ensure that the window displays 
the latest set of files and their current status from the server. This ensures that 
you have all the current file management changes. In particular, this is useful to 
update the displayed owner and lock status of a file.

To reload the window, do this:

1. From the View menu, choose Reload Window.

Showing the Toolbar

You can toggle the toolbar on and off: 

• To show the toolbar, from the View menu, choose Show Toolbar

• To hide the toolbar, from the View menu, choose Hide Toolbar.

The Help Menu
The Help menu has two items to provide assistance for Web Publisher and to 
provide some basic product information. 

Web Publisher Help

You can access the Web Publisher User’s Guide to get additional information 
about how to install the product, to find out more details about the Web 
Publisher functions and services, and to learn about using text search and 
access control. 

To access the User’s Guide, do the following:

1. From the Help menu, choose the Web Publisher Help command. 
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2. This opens up a new web browser with the table of contents. You can 
navigate the User’s Guide files by clicking on the topics you are interested 
in and then going back and forward as usual.

About

You can access some basic information about Web Publisher, including the 
product’s current version number, by viewing the About box for the product.

To access the About box, do the following:

1. From the Help menu, choose the About command.
66 Netshare and Web Publisher User’s Guide



C h a p t e r

6
Using Search
The Web Publisher search function provides you with the ability to search the 
file information and contents of documents on a remote server. The server 
indexes the files so that you can use your web browser to view the documents 
that are found for your search. 

This chapter discusses these topics:

• Preparing Data for Searching

• Performing a Search: The Basics

• Using the Query Operators

Preparing Data for Searching
To enable searching capability on your server, the server administrator begins 
by identifying the documents that you want to be able to search. Before you 
can execute searches, you need a database of searchable data against which 
you can target your searches. Your server administrator has to create a 
document information database, called a collection, that indexes and stores the 
content and file properties for each of the documents you want to be able to 
search. 
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In the case of Web Publisher, there is a default web publishing collection that 
contains all the documents that you have published, uploaded, or otherwise 
manipulated through Web Publisher. Your server administrator can also do 
bulk indexing of web publishing data for you, for example, by indexing all the 
documents in the document directory defined for Web Publisher.

Collections contain such information as the format of the documents, the 
language they are in, their searchable attributes, the number of documents in 
the collection, the collection’s status, and a brief description of the collection. 
For more details, see the section “Displaying Collection Contents.”

This section discusses these topics:

• About Collection Attributes

• META-Tagged Attributes

About Collection Attributes

Certain file formats have a default set of attributes that are indexed for files of 
that type, as shown in Table 6.1. Note that ASCII files have no default attributes. 

Table 6.1 The default attributes indexed for each file format

File format Attribute Type Description

ASCII - - -

HTML Title text The user-defined title of the file.

SourceType text The original format of the document.

NEWS From text The source userID of the news item.

 Subject text The text from the subject field of the news item. 

Keywords text Any keywords defined for the news item

Date date The date the news item was created.

EMAIL From text The source userID of the email.

 To text The destination userID of the email.

Subject text The text from the email’s subject field. 

Date date The date the email was created.
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META-Tagged Attributes

By default, HTML collections only have Title and SourceType attributes, 
but they can be set up to also permit searching and sorting by up to 30 file 
attributes tagged with the HTML <META> tag. 

For example, a document could have these META-tagged attributes:

<META NAME="Writer" CONTENT="J. S. Smith">
<META NAME="PubDate" CONTENT="07-24-00">
<META NAME="Product" CONTENT="Communicator">

If this document had been indexed with its META tags extracted, you could 
search it for specific values in the writer, publication date, or product fields. For 
example, you could enter this query: Writer <contains> Smith or 
PubDate > 1/1/00.

PDF InstanceID text An internal ID number.

 PermanentID text An internal ID number.

 NumPages integer The number of pages in the document.

 DirID text The directory where the PDF file exists.

FTS_ModificationDate date The document’s last modification date.

FTS_CreationDate date The document’s creation date.

WXEVersion integer The version of Adobe Word Finder used to extract 
the text from the PDF document.

 FileName text The Adobe filename specification.

 FTS_Title text The document’s title.

 FTS_Subject text The document’s subject.

 FTS_Author text The document’s author.

 FTS_Creator text The document’s creator.

 FTS_Producer text The document’s producer.

FTS_Keywords text The document’s keywords.

PageMap text The page map, describing the word instances for 
the page.

Table 6.1 The default attributes indexed for each file format
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Note Any attribute values in META-tagged fields are text strings only, which means 
that dates and numbers are sorted as text, not as dates or numbers. Also, illegal 
HTML characters in a META-tagged attribute are replaced with a hyphen.

Performing a Search: The Basics
Users are primarily concerned with querying the data in the search collections 
and getting a list of documents in return. The default installation of the iPlanet 
Web server includes a set of search query and result pages to allow users a 
quick and easy way of doing searches.

You can search through server documents for a specific word or attribute value, 
obtaining a set of search results that list all documents that match the query. 
You can then select a document from the list to browse it in its entirety. This 
provides easy access to server content.

There are four parts to text searching:

• making a query—you enter your search criteria.

• displaying search results—the server displays a list of the documents that 
match your criteria.

• viewing a document—you can view a specific highlighted document from 
the search results list.

• viewing the contents of a document information collection—you can look 
at the information that is maintained for each of your collections. 

This section discusses these topics:

• Creating a Search Query

• Getting Search Results

• Displaying Collection Contents
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Creating a Search Query

There are three default search query pages: standard and advanced HTML 
forms and a Java-based guided applet. 

On the standard search form, you select a collection to search against and type 
in a word or phrase to search for using the query language operators. 

On the advanced HTML form, you have the additional options of selecting 
multiple collections to search through, establishing a sort sequence for the 
results, and defining how many documents are to be displayed on a page at a 
time (clicking the Prev and Next arrows moves you through the pages of 
results). 

In the guided Java-based search applet, the applet uses several drop-down lists 
to guide you through constructing a query. You must have Java enabled for 
your browser to use this applet.

This section discusses these topics:

• The Standard Search Query Form

• The Advanced HTML Search Query Page

• The Guided Search Applet

The Standard Search Query Form

You can perform two types of searches from the standard search query form. 
To search the server collections, follow these steps:

1. Type this URL in the location field in your web browser:

http://yourServer/search
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Figure 6.1  The standard search query page 

2. In the search query page that appears, choose the collection you want to 
search through from the drop-down list in the “Search in” field. 

3. Enter the word or phrase for your search query in the For field. You can 
create complex queries by combining operators. See “Query Operators: a 
Reference” for details about the search operators.

4. Click the Search button to execute your query.

You can also search the world wide web instead of your individual server. to 
do that, use the “Search the Web” box and press Search.

The Advanced HTML Search Query Page

You can choose to use the advanced HTML search form, which helps you 
construct the query. This form is especially useful if you want to search through 
more than one collection or that produces results sorted by a specific attribute 
value.

To access advanced HTML search through the standard search query page, 
follow these steps:
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1. Go to the standard search query page by typing this URL in the location 
field in your web browser:

http://yourServer/search

2. Disable Java for your browser. To do this, use the Advanced option 
preferences menu command. 

3. Click Guided Search on the standard search form to display the advanced 
HTML query page.

Figure 6.2  The advanced HTML search query page 

4. In the For field, type in the word or phrase you want to search for. You can 
create complex queries by combining operators. See “Query Operators: a 
Reference” for details about the search operators.

5. You can type in one or more attributes to sort the results by. The default is 
an ascending sort order, but you can indicate a descending sort order with a 
minus, as in -Pubdate. (See “Sorting the Results” for more information 
about sorting).

6. Depending on how many fields are listed for each document in the search 
results page or how many you want to see at a time, you can expand or 
limit the number of matching documents you want the search to return at a 
time. The Prev and Next buttons allow you access to additional pages of 
documents if there are too many to fit on a page at once.
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7. Use the drop-down list in the Search In field to choose the collection you 
want to search through. You can select more than one collection by holding 
down the Control key as you click on another collection. All collections in a 
query must be in the same language.

8. Click the Search button to execute your query.

The Guided Search Applet

You can choose to use the Java-based guided search interface, which helps you 
construct the query. This is especially useful if you want to build a query that 
has several parts, say searching for a word in the documents’ content as well as 
a specific attribute value.

Note Make sure Java is enabled for your browser. To do this, use the Languages 
option preferences menu command.

Note Attributes for link management and agent services are listed, but these are no 
longer used in Web Publisher 4.x, so they will not produce useful results.

To access guided search from the standard search query page, follow these 
steps:

1. Obtain the standard search query page by using this URL:

http://yourServer/search

2. Click Guided Search on the standard search page to display the guided 
Java-based query page.

Figure 6.3  The guided search query applet 
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3. Choose the collection you want to search through from the drop-down list 
in the Search In field.

4. Use the For drop-down list to select the type of element you wish to search 
for. In this example, choose Words.

5. In the blank text field, type in the word you want to search for. See “Query 
Operators: a Reference” for details about the search operators.

6. Click Add Line to add the first part of the query. The word appears in the 
large text display box at the bottom of the form.

7. To add to your query, choose another element from the drop-down list. In 
this example, choose Attribute. 

8. A new drop-down list appears on the right side of the form, listing all 
attributes that are available for the chosen collection. Choose the attribute 
you want to search against.

9. From the drop-down list above the text input field, choose a query operator 
(Contains, Starts, Ends, Matches, Has a substring) or logical operator (=, <, 
>, <=, >=) for your query.

10. In the blank text field, type in the attribute value you want to search for.

11. Click Add Line to add another line for your query. You can click Undo Line 
to remove the last line you added or Clear to remove the entire query.

12. Click the Search button to execute the search.

Getting Search Results

There are two standard types of search results: a list of all documents that 
match the search criteria and the text of a single document that you selected 
from the list of matching documents.

This section discusses these topics:

• Access Permission Checking

• Listing Matched Documents
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• Sorting the Results

• Displaying a Document

Access Permission Checking

Which documents you get for your search results depend on the access control 
rules set for each of the documents and collections involved. The server does 
an access check when you perform these actions:

• searching on the Web Publishing collection only, not as part of a multi-
collection search

• searching on any collection other than the Web Publishing collection, singly 
or as part of a multi-collection search

• clicking on the URL for a document listed as part of the search results

• clicking on the link, which may be a graphical element, that displays the 
document with the search query word or phrase in highlighted text. 

If the server encounters an access control rule that restricts your access to a 
document that matches your query, the document is not listed as part of the 
search results. If you do not have permission to view a document listed in the 
search results, the server does not display it.

Listing Matched Documents

In the default installation of the iPlanet Web Server, when you execute a search 
from either the simple or advanced search query pages, you obtain a list of the 
documents that match your search criteria. The list gives some standard 
information about each file, depending on the collection’s format. For example, 
the default results page for email collections give subject, to, from, and date for 
each entry and news collections give subject, from, and date for each entry. 
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Figure 6.4  Sample search results 

The kind of file format in the collection indicates which default attributes are 
available for searching. See “About Collection Attributes” and Table 6.1 for 
information about the attributes for each format. 

For entries resulting from a search that checks for comparative proximity of 
words to each other or for the exactness of the match, the file’s ranking can be 
provided by showing a score. 

If there are more matching documents than can fit on a page, click Next to see 
the next batch. You can always execute a new search by entering new query 
data and clicking Search.

Sorting the Results

By default, or if you don’t enter anything in the Sort By field on the advanced 
HTML query page, all documents matching the search are output according to 
their relevance ranking (for queries that consider this) or their position in the 
server file database (for other queries).
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If you enter an attribute name in the Sort By field, the documents are displayed 
in an ascending sort sequence. You can list the documents in a descending sort 
sequence by adding a minus sign (-) prefix to the attribute, as in -keywords 
or -title. You can do a multiple sort, by typing in more than one field, as in 
Author,-PubDate. 

In a short query, sort order usually isn’t critical, but in queries that result in a 
great many matches, you may want to set a sort value in order to obtain useful 
search results. Note, however, using a special sort sequence may impact the 
search’s performance. 

Note Attribute values in META-tagged fields are text strings, which means that dates 
and numbers are sorted as text, not as dates or numbers. To convert the value 
into a date or number, you can create a new property in the Web 
Publishing|Add Custom Property form and check the box that marks this 
property as a META-tagged attribute. 

Displaying a Document

In the default installation of iPlanet Web Server, when you obtain a list of the 
documents that match your search criteria, you can select a single document to 
display in your web browser. The browser can display the original document or 
you can choose to display the document with additional formatting so that your 
search query word or phrase is highlighted with such text attributes as color, 
boldface, or blinking.

To view the original document, click on the hypertext link containing the 
document’s URL. In the case of documents that have been converted into 
HTML, the URL points you to the original document. Clicking on this link 
spawns an external viewer to display the document in its original format.

To view a highlighted document, click on the graphical element next to the 
document’s entry in the search results. 

Displaying Collection Contents

You can display the contents of your collection database to see which attributes 
are set for each collection. Your server administrator may have defined some 
collections as non-displayable, in which case they are not included in the 
output. The collection contents typically include these items:
78 Netshare and Web Publisher User’s Guide



Using the Query Operators
• collection name, label, and description

• collection format

• number of attributes in the collection and a list of their names

• number of documents in the collection

• collection size and status

• language and character set

• input and output date formats

To display your collection database contents, type this line in the web 
browser’s URL location field (be sure not to include any spaces):

http://yourServer/search?NS-search-page=c

Using the Query Operators
To perform an effective search, you need to know how to use the query 
operators. You can only do Boolean searches, so all the subsequent 
information is based on Boolean search rules. 

Note The query language is not case-sensitive. The examples use uppercase for 
clarity only.

The search engine interprets the search query based on a set of syntax rules. 
For example, by entering the word region, the actual word region and all its 
stemmed variations (such as regions and regional) are found. The search results 
are ranked for “importance,” which means how close the matched word comes 
to the originally input search criteria. In the example above, region would rank 
higher than any of the stemmed variants. 

Not all queries rank their results. For example, queries that check whether a 
given string matches the value in a field cannot perform a comparison: either 
the string matches the value or it doesn’t. The same is true for checking 
whether a string is contained in a field, or begins or ends a field. 

This section discusses these topics:

• Default Assumptions
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• Search Rules

• Determining Which Operators to Use

• Query Operators: a Reference

• Using Wildcards

Default Assumptions

The search query language has some implicit defaults and assumptions that 
dictate how it interprets your input. In some cases, you can circumvent the 
defaults, but here is how the search engine decides what you want as the 
search results:

<STEM>—Search finds all documents that contain any stemmed variant of the 
search word or phrase. The search engine looks at the meaning of the word, 
not just its spelling. For example, if you want to search on plan, the results 
would include documents that contain planning and plans, but not those that 
contain plane or planet.

<MANY>—Search considers how often the search word or phrase appear in the 
found documents and ranks the results for frequency (or relevancy). 

<PHRASE>—Search considers words separated by spaces to be part of a 
phrase. For example, Monterey otter is interpreted as a phrase and both must be 
present and together to be found. Such a search would not find documents 
containing sea otter or Monterey Bay.

Note In any case where it’s not clear that two words are to be considered as a 
phrase, you can use parentheses for clarity. For example, 
<PHRASE> (rise "and" fall).

OR—Search considers each word or phrase in the query separated by a comma 
to be optional, although at least one must be present. In effect, this is an 
implicit OR operation. For example, Monterey, otter is interpreted as searching 
for documents that contain either Monterey or otter. Note that angle brackets 
are not required for OR.
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Search Rules

To create complex searches, you can combine query operators, manipulate the 
query syntax, and include wildcard characters.

This section discusses these topics:

• Angle Brackets

• Combining Operators

• Using Query Operators as Search Words

• Canceling Stemming

• Modifying Operators

Angle Brackets

With the exception of the AND, OR, NOT, and the date and numeric comparison 
operators, you need to enclose query operators in angle brackets, as in 
<CONTAINS> and <WILDCARD>.

Combining Operators

You can combine several query operators into a single query to obtain precise 
results. For example, you can input the following query to limit your search to 
those documents that have Bay and Monterey but to exclude those that 
mention Aquarium

Monterey AND Bay NOT <CONTAINS> Aquarium 

You can achieve even greater precision by including some implicit phrases, as 
in the following query that finds documents that refer to the Monterey Bay 
Aquarium by its full name and also mention otters but do not refer to shark:

Monterey Bay Aquarium AND otter AND NOT shark 
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Using Query Operators as Search Words

You can use any of the query operators as a search word, but you must enclose 
the word in quotation marks. For example, you could search for documents 
about the ebb and flow of the tides with the following query:

<CONTAINS> ebb "and" flow

Canceling Stemming

You can cancel the implicit stemming by using quotation marks around a word. 
For example, you can be exact by using a query such as this:

"plan" 

This search only results in documents that contain the exact word plan. It 
ignores documents with plans or planning.

Modifying Operators

You can use AND, OR, and NOT to modify other operators. For example, you 
may want to exclude documents with titles that contain the phrase theme park. 
A query such as this would solve this problem:

Title NOT <CONTAINS> theme park 
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Determining Which Operators to Use 

Use the following reference to help determine which operators to use. Note 
that the query language is not case-sensitive, so <starts> and <STARTS> are 
equivalent. This document uses uppercase for clarity only.

Table 6.1 Deciding which operator to use

Type of Search Valid Operators Examples

Finding documents by date or 
numeric value comparison.

is equal to (=),
greater than (>),
greater than or equal to 
(>=),
less than (<),
less than or equal to (<=)

DATE >= 06-30-99

Finds documents created on or after 
June 30, 1999.

Finding words or phrases in 
specific document fields or in 
specific locations in the field.

<STARTS>,
<CONTAINS>,
<ENDS>,
is equal to (=)

Title <STARTS> Help 

Finds documents with titles that start 
with Help.

Finding two or more words in a 
document.

AND,
<NEAR/1>

specifications AND review 

Finds documents that contain both 
specifications and review.
Chapter 6, Using Search 83



Using the Query Operators
Query Operators: a Reference

The following table describes some commonly used operators and provides 
examples of how to use each one. All are relevance ranked except where 
explicitly noted.

Table 6.2 Query language operators

Operator Description Examples

AND Adds mandatory criteria to the search. 
Finds documents that have all of the 
specified words.

Antarctica AND mountain climb

Finds only documents containing both 
Antarctica and mountain climb plus all 
the stemmed variants, such as mountain 
climbing.

<CONTAINS> Finds documents containing the 
specified words in a document field. The 
words must be in the exact same 
sequential and contiguous order.

You can use wildcards. Only 
alphanumeric values.

Does not rank documents for relevance.

Title <CONTAINS> higher profit

Finds documents containing the phrase 
higher profit in the title. Ignores documents 
with profits higher in the title.

<ENDS> Finds documents in which a document 
field ends with a certain string of 
characters.

Does not rank documents for relevance.

Title <ENDS> draft

Finds documents with titles ending in 
draft.

equals (=) Finds documents in which a document 
field matches a specific date or numeric 
value.

Created = 6-30-99

Finds documents created on June 30, 1999.

greater than (>) Finds documents in which a document 
field is greater than a specific date or 
numeric value.

Created > 6-30-99

Finds documents created after June 30, 
1999.

greater than or 
equal to (>=)

Finds documents in which a document 
field is greater than or equal to a specific 
date or numeric value.

Created >= 6-30-99

Finds documents created on or after June 
30, 1999.
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less than (<) Finds documents in which a document 
field is less than a specific date or 
numeric value.

Created < 6-30-99

Finds documents created before June 30, 
1999.

less than or equal 
to (<=)

Finds documents in which a document 
field is less than or equal to a specific 
date or numeric value.

Created <= 6-30-99

Finds documents created on or before June 
30, 1999.

<MATCHES> Finds documents in which a string in a 
document field matches the character 
string you specify.

Ignores documents that contain partial 
matches.

Does not rank documents for relevance.

<MATCHES> employee

Finds documents containing employee or 
any of its stemmed variants such as 
employees.

<NEAR> Finds documents that contain the 
specified words. The closer the terms are 
to each other in the document, the 
higher the document’s score.

stock <NEAR> purchase

Finds any document containing both stock 
and purchase, but gives a higher score to a 
document that has stock purchase than to 
one that has purchase supplies and stock 
up.

<NEAR/N> Finds documents in which two or more 
specified words are within N number of 
words from each other. N can be an 
integer up to 1000. Also ranks the 
documents for relevance based on the 
words’ proximity to each other.

stock <NEAR/1> purchase

Finds documents containing the phrases 
stock purchase and purchase stock.

Ignores documents containing phrases like 
purchase supplies and stock up because 
stock and purchase do not appear next to 
each other.

When N is 2 or greater, finds documents 
that contain the words within the range 
and gives a higher score for documents 
which have the words closer together.

Table 6.2 Query language operators

Operator Description Examples
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NOT Finds documents that do not contain a 
specific word or phrase.

Note: You can use NOT to modify the OR 
or the AND operator.

surf AND NOT beach

Finds documents containing the word surf 
but not the word beach.

OR Adds optional criteria to the search. 
Finds any document that contains at 
least one of the search values.

apples OR oranges

Finds documents containing either apples 
or oranges.

<PHRASE> Finds documents that contain the 
specified phrase. A phrase is a grouping 
of two or more words that occur in a 
specific order.

<PHRASE> (rise "and" fall) 

Finds documents that include the entire 
phrase rise and fall. The and is in quotes 
to force the search to interpret it as a literal, 
not as an operator.

<STARTS> Finds documents in which a document 
field starts with a certain string of 
characters.

Does not rank documents for relevance.

Title <STARTS> Corp

Finds documents with titles starting with 
Corp, such as Corporate and Corporation.

<STEM> 
(English only)

Finds documents that contain the 
specified word and its variants.

<STEM> plan

Finds documents that contain plan, plans, 
planned, planning, and other variants with 
the same meaning stem. Ignores similarly 
spelled words such as planet and plane 
that don’t come from the same stem.

<SUBSTRING> Finds documents in which part or all of a 
string in a document field matches the 
character string you specify.

Similar to <MATCHES>, but can match 
on a partial string.

Does not work with wildcards.

Does not rank documents for relevance.

<SUBSTRING> employ

Finds documents that can match on all or 
part of employ, so it can succeed with ploy. 

Note: This works with literals only. If you 
input web*, the asterisk does not work as 
a wildcard, so the search succeeds only 
with the exact “web*” string. 

Table 6.2 Query language operators

Operator Description Examples
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Using Wildcards 

You can use wildcards to obtain special results. For example, you can find 
documents that contain words that have similar spellings but are not stemmed 
variants. For example, plan stems into plans and planning but not plane or 
planet. With wildcards, you can find all of these words.

<WILDCARD> Finds documents that contain the 
wildcard characters in the search string. 
You can use this to get words that have 
some similar spellings but which would 
not be found by stemming the word.

Some characters, such as * and ?, 
automatically indicate a wildcard-based 
search, so you don’t have to include the 
word <WILDCARD>.

<WILDCARD> plan*

Finds documents that contain plan, plane, 
and planet as well as any word that begins 
with plan, such as planned, plans, and 
planetopolis.

See the next section for more details and 
examples.

<WORD> Finds documents that contain the 
specified word.

<WORD> theme

Finds documents that contain theme, 
thematic, themes, and other words that 
stem from theme.

Table 6.2 Query language operators

Operator Description Examples
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Some characters, such as * and ?, automatically indicate a wildcard-based search 
and do not require you to use the <WILDCARD>operator as part of the 
expression.

Table 6.3 Wildcard operators

Character Description

* Specifies 0 or more alphanumeric characters. For example, air* finds 
documents that contain air, airline, and airhead. 

Cannot use this wildcard as the first character in an expression. 

This wildcard is ignored in a set of ([ ]) or in an alternative pattern ({ }). 

With this wildcard, the <WILDCARD> operator is implicit.

? Specifies a single alphanumeric character, although you can use more 
than one ? to indicate multiple characters. For example, ?at finds 
documents that contain cat and hat, while ??at finds documents that 
contain that and chat.

This wildcard is ignored in a set of ([ ]) or in an alternative pattern ({ }).

With this wildcard, the <WILDCARD> operator is implicit.

{} An alternative pattern that specifies a series of patterns, one for each 
pattern separated by commas. For example,
<WILDCARD> ‘Chat{s, ting, ty}‘  
finds documents that contain chats, chatting, and chatty.

You must enclose the entire string in back quotes and you cannot have 
any embedded spaces.

[ ] A set that specifies a series of characters that can be 
used to find a match. For example, 
<WILDCARD> ‘[chp]at‘ 
finds documents that contain cat, hat, and pat.

You must enclose the entire string in back quotes and you cannot have 
any embedded spaces.
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Wildcards as Literals

Sometimes you may want to search on characters that are normally used as 
wildcards, such as the *or? expression. To use a wildcard as a literal, you 
must precede it with a backslash. In the case of asterisks, you must use two 
backslashes. For example, to search on a magazine with a title of Zine***, you 
would type:

<WILDCARD>Zine\\*\\*\\*

Several characters have special meaning for the search engine and require you 
to use back quotes to be interpreted as literals. The special search characters 
are listed here: 

• comma ,

• left and right parentheses ( )

• double quotation mark "

• backslash \

• at sign @

• left curly brace {

• left bracket [

• back quote ‘ (Note: You can only search on back quotes as literals if your 
server administrator has set this up.)

^ Specifies one or more characters to exclude from a set. For example, 
<WILDCARD> ‘C[^io]t‘  finds documents that contain cat and cut, 
but not cot.

The caret (^) must be the first character after the left bracket.

- Specifies a range of characters in a set. For example, <WILDCARD> 
‘Ch[a-j]t‘  finds documents that contain any four-letter word from 
chat to chjt. 

Table 6.3 Wildcard operators

Character Description
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For example, to search for the string "a{b", you would type

<WILDCARD>‘a{b‘

For another example, if you wanted to search on the string "c‘t", which contains 
a back quote, you would type 

<WILDCARD>‘c‘‘t‘
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7
Controlling Access
You can control who accesses your Web Publisher documents and directories 
and what operations different users or different groups of users can perform 
upon them. You can completely prohibit access to a file or folder or you can 
restrict access to certain authenticated users.

Note You can display or modify access control only for your own files or folders. If 
you want to define the access permissions for a file or folder that has no 
owner, you must first go to the Web Publisher Services page and use the 
Properties form to assign ownership to yourself. See the section, “Ownership of 
Files and Folders,” for more information about this topic.

Access control is based on a hierarchy of rules that specify certain restrictions. 
A set of rules is called an access control list (ACL). The access control hierarchy 
is based on the URL Path or file path, with ACL rules cascading from the top 
down through each progressively lower layer of directories and subdirectories 
until it reaches the file. When a request for access is made, the server goes in 
turn through each rule, continuing until it encounters a rule that prevents it 
from continuing or comes to the last rule for that resource.

This chapter discusses these topics:

• User Authentication

• Web Publisher Access Permissions

• Ownership of Files and Folders
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• Setting Access: An Example

• Access Control: The Details

• The Access Control Window

• Additional Options

User Authentication
You identify yourself by entering your user name and password in a dialog box 
or by using a client certificate installed in your web browser, such as Netscape 
Navigator or Netscape Communicator. 

If your server isn’t handling authentication for you with certificates, you must 
be defined in the server’s users and groups database, which can be either a file 
stored on the web server computer or an LDAP server on a remote computer 
(for example, a computer running Netscape Directory Server). 

When you attempt to access a file or directory that has User-Group 
authentication, the web browser displays a dialog box asking you to enter your 
user name and password. Figure 7.1 shows the default iPlanet Web Server 
authentication dialog box.

Figure 7.1  The authentication dialog box.

After entering the information, you are either allowed to access the file or 
directory listing requested or you are denied access. You can be denied access 
because you are not in the Users and Groups database, and are therefore 
unknown to the server, or because you have been specifically denied access in 
an access control rule.
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Web Publisher Access Permissions
Web Publisher has many operations that are restricted to the broad category of 
valid server user. Many ACL rules, such as that for agents services, simply 
require a user to be valid for the server. That is, users who are defined in the 
server’s users database. 

When you start Web Publisher, you are immediately prompted with the user 
name authorization dialog box. You can leave this blank and operate as an 
anonymous user, but as soon as you attempt to perform an operation restricted 
to a valid user, you are again prompted for your user name. At this point, you 
are also asked to enter your password, and only authenticated users can 
continue with the operation.

Ownership of Files and Folders
Web Publisher files and folders can be owned by individual users. Only the 
owner of a file or folder can define its access control definitions or reassign its 
ownership. If a file or folder has no owner, no one can modify its access 
control. As discussed in the sections “Setting Access: An Example” and “Setting 
Users and Groups,” you can define an access control definition that restricts 
certain operations to the user who is the current owner of a file or folder, even 
when ownership is reassigned.

Your server administrator can do a bulk ownership assignment for you, you can 
assign ownership for an individual file or folder through the Web Publisher 
properties page, or you can become the owner of a file or folder as a result of 
an automatic assignment by Web Publisher when you perform certain actions.

Note Locked files have a lock owner, which is not the same as being the file’s owner. 
All a lock owner owns is the lock placed on a file. Only they can unlock their 
lock, with one exception: the server administrator can unlock any file lock.

Manually Assigning Ownership 

You can use the properties page that is part of the Web Publisher Services form 
to manually assign ownership of a file or folder. You an only modify the Owner 
property is two cases:
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• You own the file or folder.

• The file or folder has no owner.

In the first case, if you are the owner of a file or folder, you can reassign its 
ownership to another user. Once you give away ownership, you no longer 
have any owner privileges. Only the new owner can modify the Owner field 
and the access control from then on.

In the second case, if there is no owner yet, you can make yourself or another 
user the owner. As with the previous case, if you make another user the owner, 
you lose your ability to modify the Owner field or the access control from then 
on.

Automatic Assignment

When you use certain operations on files or folders without an owner, Web 
Publisher automatically assigns you as the owner. If a file or folder already has 
an owner, Web Publisher does not reassign ownership. When you perform one 
of these operations on a folder, you are also assigned as owner to all its files.

Web Pub operations that assign ownership to files or folders that have no 
owner:

• copy (ownership is assigned to the newly copied files and folders, not the 
originals)

• move 

• rename

• upload 

• edit (although ownership has little effect until you unlock the file by 
publishing it)
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Setting Access: An Example
You can restrict access to the files and folder that you own. This section takes 
you through an example of restricting access to the owner of a file. In the 
example, the chosen file is the index.html file for the default document 
directory. The steps given are the same ones you would use for defining access 
control rules for any file or folder. 

1. Select the index.html file in the Web Publisher applet window.

2. At this point, there are three ways to obtain the access control interface 
from Web Publisher:

• From the Services menu, choose Access Control.

• Click the Information toolbar button to display the Web Publisher Services 
page, and then click the Access Control button.

• In the URL field of your browser, type in the following URL:

http://yourServer/oneacl/index.html

The access control window divides into two frames that you use to set the 
access control rules. If the file or folder has no access control, the top frame 
is initially empty. 

3. Click New Line to get a new default rule. Leave this unchanged. The default 
rule that you begin with denies everyone everything. Once you’ve done 
this, you can expand the access to include specified users and groups, as in 
the next step.

4. Click New Line again to get another default ACL rule as the bottom row of 
the table. You can use the up and down arrows in the left column to move 
a rule, if needed.
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Figure 7.2  A sample ACL for the owner of a file 

5. You can allow access to this file by clicking the Deny link in the Action 
column. The bottom frame now displays the Allow/Deny form. See the 
section See “Setting Actions” for more details.

6. Click Allow and then click Update to return to the top frame with the new 
data.

7. You can allow access to a specific user by clicking the Anyone link in the 
Users/Groups column. The bottom frame now displays the User/Group 
form. By default, there is no authentication, meaning anyone can access the 
resource. See “Setting Users and Groups” for more details.

8. You can restrict access to a computer or network by clicking the Anyplace 
link in the From Host column. See “Specifying Host Names and IP 
Addresses” for more details on how to use this advanced option.

9. You can restrict access to certain operations by clicking the All link in the 
Rights column. The bottom frame now displays the Access Rights form. By 
default, the user has access to all operations. See “Setting Rights” for more 
details.

To restrict the rule to all except write and delete operations, uncheck these 
two checkboxes, and then click Update to return to the top frame with the 
new data.

10. Add another new line, this time allowing the owner to have write and 
delete access as well. Complete steps 4-6. 
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Then to restrict access to the owner of a file, type owner in the User field 
under “Authenticated People Only,” and then click Update to return to the 
top frame with the new data. 

11. In most cases, this is all you need to do to define an ACL for your file, so 
click Submit to set up this ACL for your index.html file. See “Additional 
Options” for details about other options you can use.

If you click Revert, the server removes any changes you made to the rules 
from the time you first opened the two-frame window. Be cautious when 
using Revert because you can’t restore your edits. In most cases, it is safer 
to delete the rule lines individually by clicking the Trash can icon on the 
end of each line.

Access Control: The Details
The Web Publisher access control interface allows a wide and flexible range of 
access definitions. The interface has two frames, with the top part displaying 
the ACL rules that are being updated with new or modified data from the 
several different forms that are shown in the bottom part. The top frame has 
several icons and checkboxes that you can use to customize your access 
control. 

Setting Actions

You can specify the action the server takes when a request matches the access-
control rule. 

• Allow means the users or computers can access the requested resource.

• Deny means the users or computers cannot access the resource.

Setting Users and Groups

You can restrict access to your file or folder based on the user who is making 
the access request. With user and group authentication, users are prompted to 
enter a user name and password before they can access the resource specified 
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in the access-control rule. The web server uses a list of users and groups to 
determine access rights for the user requesting a resource. This information is 
stored either in a database on the web server computer or in an LDAP server 
such as Netscape Directory Server.

You can allow or deny access to everyone in the database, or you can allow or 
deny specific people by using wildcard patterns or lists of users or groups. You 
need to use a person’s user name as defined to the server, not their actual 
name. For example, you could restrict access to JSmith only, or to the owner of 
a file, or to anyone who’s name begins with the letter s (by entering the 
wildcard pattern s*).

When you click the Users/Groups link, a form appears in the bottom frame. 
The following list describes the options in the form:

• Anyone (No Authentication) is the default and means anyone can access the 
resource without having to enter a user name or password. However, the 
user might be denied access based on other settings, such as host name or 
IP address.

• Authenticated people only means all users requesting the resource have to 
enter a valid user name and password before gaining access to the 
resource.

• All in the authentication database matches any user who has an entry in the 
database. 

• Only the following people lets you specify certain users and groups to 
match. You can list the users and groups of users individually by separating 
the entries with commas. Or, you can enter a wildcard pattern, such as 
*Smith.

• Group matches all users in the groups you specify. 

• User matches the individual users you specify. If you want to restrict 
access to owners, enter owner here.

• Prompt for authentication lets you customize the message that appears in 
the authentication dialog box. The default text, “Enterprise Server” is shown 
in figure. Depending on the operating system, the user sees about the first 
40 characters of the prompt. 
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• Netscape Navigator and Netscape Communicator cache the user name and 
password. This means that while you continue to use the same browser, 
you do not have to reenter your user name and password. 

• Authentication Methods specifies the method the server uses when getting 
authentication information from the client. Do not change this setting 
without consulting with your server administrator. 

• Authentication Database lets you select a database that the server uses to 
authenticate users. Do not change this setting without consulting with your 
server administrator.

Setting Rights

You can set access rights to your Web Publisher files and directories. That is, in 
addition to allowing or denying all access rights, you can specify a rule that 
allows or denies partial access rights. For example, you can give people read-
only access rights to your files, so they can browse a file but cannot edit it. 

When you create an access-control rule, the default access rights are set to all 
access rights. To change access rights, click the Rights link in the top frame, and 
then check or uncheck the access rights you want to set for a particular rule. 
The following list describes each access right you can check:

• Read access lets a user view a file.

• Write access lets a user change a file’s content or properties.

• Execute access applies to server-side applications, such as CGI programs 
and Java applets.

• Delete access means a user can delete, move, or rename a file or directory. 

• List access means the user can get a list of the files in a folder. If this is not 
checked, the user cannot open the folder in the Web Publisher window.

• Info access maps to the HTTP Options method.
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The Access Control Window
There are some special graphical elements in the ACL window that help you 
rearrange and delete individual rules. There is also a checkbox that allows you 
to redefine what users see when they are denied access to a resource. 

Moving Rules Up and Down

Rules are applied in the order in which the server encounters them. Once you 
define a rule, you can use the arrows on the left of each rule to rearrange the 
sequence of rules for a resource. This is especially useful when you want to 
temporarily define an absolute rule that blocks access to later rules. By moving 
the rule up in the sequence, you don’t need to delete the rule and recreate it 
later. Just place it below the absolute rule, and the server never checks it.

Deleting ACL Rules

When you uncheck the “Access control is on” option, you are prompted to 
confirm if you want to erase records in the ACL file. When you click OK, the 
server deletes the entire set of access control rules for that resource.

A less drastic way of deleting an access control rule is to click the Trash can 
icon at the end of each line to delete a single rule.

Response When Access is Denied

You can choose the response a user sees when denied access. You can vary 
the message for each file or folder. By default, the user is sent a message that 
says the file wasn’t found (the HTTP error message 404 Not Found is also sent). 
In general, do not change this setting without consulting with your server 
administrator. 
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To change the message that is sent for a particular resource when access is 
denied:

1. In the top frame, click the link called “Response when denied.” The Access 
Deny Response form is displayed in the lower frame with the default option 
set.

2. Click the radio button labeled “Respond with the following url.”

3. In the text field, type the URL for the file (text or HTML) in your server’s 
document root that you want to send to users when they are denied access. 
Make sure the file doesn’t contain references to other files (such as style 
sheets) or images because they won’t be sent. 

4. Click Update to return to the top form.

5. Click Submit to set this response as part of the access control rule.

Note Make sure any users who get the response file have access to that file. That is, 
if you have access control on the response file and the user is denied access to 
both the original resource and the response file, the server sends the default 
denied response.

Additional Options
Most users do not need the additional ACL features described in this section, 
but there may be cases where you need these features to provide the desired 
level of control for a file or folder. For example, you may need special 
restrictions on personnel directories in the HR group or confidential files 
belonging to the CEO of a company.

Using the Continue Option

By default, an access control rule has the Continue option checked. This allows 
lower-level files and folders to have their own ACL rules, which can contradict 
already defined ACL rules. For example, even though an earlier ACL rule allows 
anyone to read all files in a directory, you can define a rule for your files in this 
directory that denies access to everyone but yourself. 
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You could, however, set an ACL rule for a folder that prevents its files from 
having ACL rules that defined access in a different way. This is referred to as 
absolute control, and you set this option by unchecking the Continue 
checkbox. When the server evaluates the access control rules for a resource, it 
stops whenever it encounters a rule that does not have Continue checked. 

For example, suppose someone requests the following file:

http://www.mozilla.com/docs/Project-X/presentation.html

The server checks all ACL rules that affect the object. First it checks any overall 
permissions for the server, then it checks the permissions for the /docs 
directory and then those for the /Project-X subdirectory. The server 
continues checking ACL rules until it reaches the ACL for the requested URL (in 
this case, the file presentation.html) or until it reaches an ACL rule that 
has the Continue option unchecked. 

Once an absolute rule is encountered, the ACL defined as of that point is the 
only operative access control rule. You cannot define less restrictive rules for 
files or folders at lower levels of the document tree.

Specifying Host Names and IP Addresses

Although you probably won’t need to do this, you can limit access to files and 
folders by making them available only to people using specific computers. You 
can use wildcard patterns to specify multiple computers or entire networks. If 
you want to use this feature, you must have DNS running in your network and 
your computer must be configured to use it.

Note It’s possible for more than one person to have access to a particular computer. 
For this reason, Host-IP authentication is most effective when combined with 
User-Group authentication. If both methods of authentication are used, the end 
user has to enter a user name and password before getting access.

You specify this restriction by using wildcard patterns that match the 
computers’ host names or IP addresses. For example, to allow or deny all 
computers in a specific domain, you would enter a wildcard pattern that 
matches all hosts from that domain, such as *.netscape.com. 

To specify a host name or IP address, follow these steps:
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1. Click the Anyplace link in the From Host column in the top part of the ACL 
form. The From Host form is displayed in the bottom frame. 

2. In one of the fields under the Only From option, type a wildcard pattern or 
a comma-separated list of hostnames or IP addresses. 

3. Click Update to return to the top part of the ACL form with the new or 
modified data.

4. Click Submit to modify the access control rule.

Restricting by hostname is more flexible than by IP address—if a user’s IP 
address changes, you won’t have to update this list. Restricting by IP address, 
however, is more reliable—if a DNS lookup fails for a connected client, 
hostname restriction cannot be used. 

The hostname and IP addresses should be specified with a wildcard pattern or 
a comma-separated list. The wildcard notations you can use are specialized; 
you can only use the *. 

For IP addresses, the * must replace an entire byte in the address. That is, 
198.95.251.* is acceptable, but 198.95.251.3* is not. When the * 
appears in an IP address, it must be the right-most character. For example, 
198.* is acceptable, but 198.*.251.30 is not.

For hostnames, the * must also replace an entire component of the name. That 
is, *.netscape.com is acceptable, but *sers.netscape.com is not. When 
the * appears in a hostname, it must be the left-most character. For example, 
*.netscape.com is acceptable, but users.*.com is not.
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