Signed Patches Release Notes for PatchPro 2.2

Chapter 2 Installation Issues With Solaris Patch Management Tools

This chapter describes problems that relate to the installation of the Solaris patch management tool, PatchPro 2.2 and Patch Manager Base 1.0.1.

patchadd -p Displays PatchArrElem Error on Solaris 8 Systems


/usr/sbin/patchadd[177]: PatchArrElem: subscript out of range
Description:

This message appears when you run the patchadd -p command on a Solaris 8 system.

Workaround:

You can ignore this message.

To avoid seeing this message, apply patch 108987-13 to your Solaris 8 system.

  1. Become superuser.

  2. Download the patch to your system from the SunSolveSM Patch Portal.

  3. Use the unzip command to expand the patch from the ZIP archive.


    # unzip 108987-13.zip
    
  4. Change to the patch directory.


    # cd 108987-13
    
  5. Apply the patch.


    # patchadd `pwd`
    

Setup of Patch Management Tool Fails to Complete Successfully


The following files are already installed on the system and are being used
by another package:

/etc <attribute change only>

Installation of <SUNWppcfg> was suspended (interaction required).
Description:

The patch tool setup script did not complete successfully.

Cause:

The owner or permissions on the /etc directory have changed.

Workaround:

Perform one of the following workarounds:

  • Set the owner, group, and permissions of the /etc directory to be root, sys, and 0755, respectively.

  • Change the value of the conflict parameter in the /var/sadm/install/admin/default file to be ask or nocheck.

Installation of PatchPro Hangs When the /opt Directory Is Full (4872810)


Installing supporting packages...
ufs: NOTICE: alloc: /opt: file system full
mkdir: "/opt/SUNWapcy": No space left on device
mkdir: "/opt/SUNWsdb": No space left on device
mkdir: "/opt/SUNWppro": No space left on device
Description:

Error messages such as these appear while you attempt to install PatchPro on your system. Then, the installation hangs.

Cause:

During the installation of PatchPro, /opt runs out of disk space.

Workaround:

Before you install PatchPro, ensure that /opt contains at least 5 Mbytes of available disk space.

Problem Detected During the PatchPro Initialization Process


Problem detected during PatchPro initialization process. Please check the
log file.
Exiting.
Description:

A problem occurred during the installation of PatchPro.

Workaround:

Check the PatchPro log file for errors. By default, the PatchPro log is the system log (syslog).