Signed Patches Release Notes for PatchPro 2.2

smpatch download Cannot Download Patches Listed by smpatch analyze (4888232)


(ERROR) => com.sun.patchpro.server.ServerPatchServiceProvider@7918f0 
<=Patch cannot be found by server
Description:

This message might appear when you run the smpatch download command in an effort to download a patch supplied by the smpatch analyze command.

Cause:

smpatch analyze lists all possible patches recommended for your system, including contract patches. The error indicates one of the following:

  • Cause 1 – You do not have a Sun service contract. Without a service contract, you are not permitted to access contract patches.

  • Cause 2 – You have a Sun service contract, but you have not configured your patch management environment to access contract patches.

Workaround:

Resolve this problem by doing one of the following:

  • If you do not want to access contract patches, you can ignore this error message.

  • If you want to access the contract patches, do one of the following:

    • For Cause 1, sign up for a Sun service contract so that you can access these patches.

    • For Cause 2, configure your patch management environment so you can access contract patches. See “How to Configure Your System to Access Contract Patches” in the Signed Patches Administration Guide for PatchPro 2.2.