Signed Patches Release Notes for PatchPro 2.2

PatchPro Cannot Reach the Internet

This message appears when you try to use PatchPro:


Downloader.getResponseCode() : IOException [URL with server]/patchprodb.zip
Description:

This message indicates that PatchPro is incapable of reaching the Internet.

Cause:

The following are possible causes:

  • Cause 1 – Your system must get through a proxy to access the Internet, and the proxy has not been entered properly.

  • Cause 2 – The proxy is entered correctly, but the proxy requires a password.

  • Cause 3 – All the settings are correct, but the firewall prohibits access through HTTP (port 80) or HTTPS (port 443).

  • Cause 4 – Network failure.

Workaround:

Resolve this problem by doing one of the following:

  • For Cause 1, double-check the host name and port of your proxy, and inform PatchPro by typing the following:


    # /opt/SUNWppro/bin/pprosetup -x proxy_host:proxy_port
    
  • For Cause 2, create a password for the proxy user. See the description of the -U option in the pprosetup(1M) man page.

  • For Cause 3, contact your system administrator about unblocking those ports.

  • For Cause 4, contact your network administrator about the network outage.

Your institution might have a firewall that blocks HTTPS (port 443). Check this with your system administrator.

If you still cannot contact the Internet, you can perform a test. Download wget from http://sunfreeware.com and type:


# wget https://patchpro.sun.com/apache_pb.gif
  • If you get a picture of a feather, then your system does not have a proxy and the problem you are seeing with PatchPro is related to something else.

  • If you do not see the feather, then your browser knows something that nothing else does.

    You might be able to figure out how to get PatchPro through your firewall by reviewing your browser's preferences.