Sun Patch Manager 2.0 Administration Guide for the Solaris 8 Operating System

AppendixA Troubleshooting (Reference)

This appendix describes common problems that you might encounter when using Patch Manager to analyze systems to determine the list of appropriate patches, download the patches to the system, and apply the patches.

Additional troubleshooting information about Sun Patch Manager 2.0 might appear in the Sun Patch Manager 2.0 Release Notes for the Solaris 8 Operating System.

Cannot Update Patches Due to Network or Server Failures

Description:

When running the smpatch update command, any of the following errors appear:


Cannot connect to retrieve patchdb: Connection refused

Or:


Cannot connect to retrieve patchdb: Connection timed out

Or:


Unknown host (host-name) connecting to http://host-name/
Cause:

This problem might be caused by a network failure between the client and the patch server, or the patch server is down.

Workaround:

Ensure that patchpro.patch.source points to a valid patch source.

Check the condition of the network.

  • If your patch management environment includes a local patch server, ensure that it is up and running.

  • If the problem is between your system and Sun, wait for the issue to be resolved.