Sun Patch Manager 2.0 Administration Guide for the Solaris 9 Operating System

General Errors

Cannot Update Patches Due to Network or Server Failures

Description:

When running the smpatch update command, any of the following errors appear:


Cannot connect to retrieve patchdb: Connection refused

Or:


Cannot connect to retrieve patchdb: Connection timed out

Or:


Unknown host (host-name) connecting to http://host-name/
Cause:

This problem might be caused by a network failure between the client and the patch server, or the patch server is down.

Workaround:

Ensure that patchpro.patch.source points to a valid patch source.

Check the condition of the network.

  • If your patch management environment includes a local patch server, ensure that it is up and running.

  • If the problem is between your system and Sun, wait for the issue to be resolved.

Solaris WBEM Services Are Unavailable When Using smpatch in Remote Mode

Description:

When running smpatch in remote mode or trying to restart the Solaris WBEM services, the following error messages appear:


# smpatch analyze -u root
Authenticating as user: root

Type /? for help, pressing <enter> accepts the default
denoted by [ ]
Please enter a string value for: password :: root-password
There is no Solaris Management Console Server running on
pserver2.
# /etc/init.d/init.wbem status
Solaris Management Console server not running on port 898.
# /etc/init.d/init.wbem start
# /etc/init.d/init.wbem status
Solaris Management Console server not running on port 898.
Workaround:

Manually stop the Solaris WBEM services before restarting them.


# /etc/init.d/init.wbem stop
# /etc/init.d/init.wbem start
# /etc/init.d/init.wbem status
Solaris Management Console server version 2.1.0 running on
port 898.