Sun Patch Manager 2.0 Administration Guide for the Solaris 9 Operating System

Local Patch Server Errors

CannotConnectException Error Returned for HTTP 500

Description:

The following error message appears when you run the smpatch analyze in remote mode against a local patch server:


# smpatch analyze -u root
Authenticating as user: root

Type /? for help, pressing <enter> accepts the default
denoted by [ ]
Please enter a string value for: password ::  root-password
Loading Tool: com.sun.admin.patchmgr.cli.PatchMgrCli from
pserver-2
Login to pserver-2 as user root was successful.
Download of com.sun.admin.patchmgr.cli.PatchMgrCli from
pserver-2 was successful.
Assessing patches for machine pserver-2. Please wait...
Patch analysis failed. 
com.sun.patchpro.util.CannotConnectException:
Cannot connect to retrieve patchprodb.zip: Server returned
HTTP response code: 500 for URL:
http://pserver-1:3816/solaris/.
Cause:

You might see this error message if one of the following situations occur:

  • One of the servers in the local patch server chain is down.

  • The web proxy of the local patch server is not configured to reach the Internet.

  • The local patch server is pointing to a bad patch source.

Workaround:

Address these issues by doing the following:

  • If one of the local patch servers in the chain is down, log in to that patch server and restart the web services.


    # patchsvr stop
    Shutting down Local Patch Server
    # patchsvr start
    Starting Local Patch Server
  • If the web proxy is not configured to reach the Internet, ensure that the host name of the web proxy and the port number are correctly specified.


    # patchsvr stop
    Shutting down Local Patch Server
    # patchsvr setup -x web-proxy-host:port
    # patchsvr start
    Starting Local Patch Server
  • If the specified patch source is bad, check the value.


    # patchsvr setup -l
    
    • If the value is correct, see if one of the other two problems is the cause of the analysis failure. A valid patch source is a URL that begins with the http:// or file:/ notation. The URL of a local patch server must terminate with a slash, such as http://patchserver:3816/solaris/.

    • If the value is incorrect, correct the patch source value.


      # patchsvr setup -p patch-source-url
      

Cannot Download Patches From a Patch CD Mounted on a Local Patch Server

Description:

You configure a local patch server to obtain patches from a CD mounted on the local patch server. When you attempt to download patches from the CD, you see the following error message:


Downloading the recommended patches for machine
host-name. Please wait...
Could not download patch. Error occurred while processing
the download for this patch, patch-id,
into /var/sadm/spool directory.
Error: No such file or directory.
Workaround:

Ensure that Solaris Volume Manager is running properly on the local patch server. If it is not, type:


# /etc/init.d/volmgt stop
# /etc/init.d/volmgt start
# smpatch download

Local Patch Server Ignores Your Configuration Changes

Description:

You attempt to change the configuration settings of your local patch server, but the changes are not reflected.

Workaround:

Stop and restart the local patch server.


# patchsvr stop
Shutting down Local Patch Server
# patchsvr start
Starting Local Patch Server

Local Patch Server Does Not Work Properly

Description:

You encounter other problems while using a patch management environment with one or more local patch servers.

Workaround:

Do the following:

  1. Verify that the client system's configuration settings are correct.


    # smpatch get
    
  2. Verify that the local patch server's configuration settings are correct.


    # patchsvr setup -l
    
  3. View the /var/patchsvr/logs/catalina.out and /var/patchsvr/logs/localhost_log.date.txt log files on the local patch server.

  4. View the system log file /var/adm/messages on the client system.

  5. Run the snoop command on the client system or on the local patch server to see if the data is being downloaded from the local patch server to the client.