Message Reference

DocuMaker RP Errors

Number:
DM

System Errors

Number:


1 - 99 Messages

1

Wrong object type for requested operation

Explanation

Programmer Response

2

Invalid object handle was passed

Explanation

Programmer Response

3

Initialization has already been performed

Explanation

Programmer Response

4

Necessary initialization must first be performed

Explanation

Programmer Response

5

No objects available for requested operation

Explanation

Programmer Response

6

Object has no associated GUI window frame handle

Explanation

Programmer Response

7

Failure to bind to an object by name

Explanation

Programmer Response

8

Object is not in sync with related objects

Explanation

Programmer Response

9

Requested GUI operation failed

Explanation

Programmer Response

10

Unable to load/create FAP object

Explanation

Programmer Response

11

Unable to open/create FAP object

Explanation

Programmer Response

12

Unable to read/load from FAP object

Explanation

Programmer Response

13

Unable to write/output to FAP object

Explanation

Programmer Response

14

Unable to close/terminate FAP object

Explanation

Programmer Response

15

Version number is not in sync

Explanation

Programmer Response

16

This function requires third party software. Please refer to your documentation.

Explanation

Programmer Response

17

UTLLoadLibrary error. Cannot load %s (%s).Error: %s

Explanation

Programmer Response

18

Printer configuration mismatch: <PRTTYPE:%s> MODULE=%s PRINTFUNC=%s

Explanation

Programmer Response

36

list of text is NULL

Explanation

Programmer Response

37

field textmerge handle is NULL

Explanation

Programmer Response

38

font list is empty

Explanation

Programmer Response

39

cannot locate font

Explanation

Programmer Response

40

** Parent handle mismatch:%n object : %lx %ld%n objparent: %lx %ld%n parent : %lx %ld%n

Explanation

Programmer Response

41

%t%t%t%t%t%tFAP_OBJFIELD:%lx %s Flag %lx Scope %ld Top %ld Left %ld Bottom %ld Right %ld

Explanation

Programmer Response

42

%t%t%t%t%t%tFAP_OBJTEXTMER:%lx %s Flag %lx Top %ld Left %ld Bottom %ld Right %ld

Explanation

Programmer Response

43

checkstack:%s (%ld)%n lowest=%ld current=%ld highest=%ld range=%ld

Explanation

Programmer Response

44

FAP Not Open

Explanation

Programmer Response

45

FAP Append Error

Explanation

Programmer Response

46

Cannot load bitmap on this or later page(s) %s

Explanation

Programmer Response

47

Page %ld

Explanation

Programmer Response

48

Load failure on %s

Explanation

Programmer Response

49

Printer configuration is incomplete: <PRINTER> TYPE=

Explanation

Programmer Response

50

Printer configuration is incomplete: <%s> MODULE=

Explanation

Programmer Response

51

Printer configuration is incomplete: <%s> PRINTFUNC=

Explanation

Programmer Response

52

Failure to open device %s%nError number=%d%n%s

Explanation

Programmer Response

53

Failure to write to device %s%nError number=%d%n%s

Explanation

Programmer Response

57

Error in %s: Unable to %s.%n

Explanation

Programmer Response

58

Error in %s: Unable to %s(pRPS,<%s>,<%s>).%n

Explanation

Programmer Response

59

Error in %s: Unable to %s(%s,,,,,).%n

Explanation

Programmer Response

60

Error in %s: Unable to %s(pRPS,<%s>).%n

Explanation

Programmer Response

61

Error in %s: Unable to %s(<%s>, pRPS).%n

Explanation

Programmer Response

62

Error in DSLoadDefTable(): Definition File Name is blank.%n

Explanation

Programmer Response

63

Error in DSLoadDefTable(): Unable to open definition file %s.%n

Explanation

Programmer Response

64

Error in DSLoadDefTable(): Data definition file contains illegal syntax, possible pre release 8.0 version.%n

Explanation

Programmer Response

65

Error in DSAddFieldRule(): Format mask (Field.FmtMask) has too many chars. Maximum chars allowed is %s. Processing will continue with truncated FmtMask.%n%n

Explanation

Programmer Response

66

Error in DSAddImageField(pRPS,<%s>): Global field rules have not been added.%n

Explanation

Programmer Response

67

Error in DSAddImageField(pRPS,<%s>): Unable to GetFieldRule(). Check field rule file for field:<%s>.%n

Explanation

Programmer Response


100 - 199 Messages

128

EMS

Explanation

Programmer Response

129

EMS hardware

Explanation

Programmer Response

130

Bad EMS handle

Explanation

Programmer Response

131

No EMS handles

Explanation

Programmer Response

132

Page handle

Explanation

Programmer Response

133

Page range

Explanation

Programmer Response

134

No driver

Explanation

Programmer Response

135

Wrong version

Explanation

Programmer Response

136

Not installed

Explanation

Programmer Response

137

Too big

Explanation

Programmer Response

138

No pages

Explanation

Programmer Response

139

Heap full

Explanation

Programmer Response

140

Handles full

Explanation

Programmer Response

141

Locks full

Explanation

Programmer Response

142

Not locked

Explanation

Programmer Response

143

Not found

Explanation

Programmer Response

144

Bad handle

Explanation

Programmer Response

145

Disk write

Explanation

Programmer Response

146

Disk read

Explanation

Programmer Response

147

Disk file

Explanation

Programmer Response

148

Bad parameter

Explanation

Programmer Response

149

General

Explanation

Programmer Response

150

VMMInitSys:err=%lx

Explanation

Programmer Response

151

VMMInitSys:zero returned

Explanation

Programmer Response

152

VMMInitSys: Another application running

Explanation

Programmer Response

153

Number of allocs: %lu frees: %lu%n

Explanation

Programmer Response

154

VMMIntegrity:Begin:lstH=%lx IntegCount=%lu

Explanation

Programmer Response

155

VMMIntegrity:Test VMMNextElem

Explanation

Programmer Response

156

VMMIntegrity:OVERRUN: direction=%lx IntegListH=%lx IntegElemH=%lx IntegCurH=%lx IntegNxtH=%lx prvH=%lx IntegIndex=%lu%n

Explanation

Programmer Response

157

VMMIntegrity:Test VMMPrevElem

Explanation

Programmer Response

158

VMMIntegrity:UNDERRUN: direction=%ld IntegListH=%lx IntegElemH=%lx IntegCurH=%lx IntegNxtH=%lx prvH=%lx IntegIndex=%lu

Explanation

Programmer Response

159

VMMIntegrity:End:status=%ld

Explanation

Programmer Response

160

VMMIntegrity:_LockFail: direction=%ld IntegListH=%lx memH=%lx IntegElemH=%lx IntegCurH=%lx IntegNxtH=%lx prvH=%lx IntegIndex=%lu

Explanation

Programmer Response

161

VMMIntegrity:_BadHandle: direction=%ld IntegListH=%lx memH=%lx IntegElemH=%lx IntegCurH=%lx IntegNxtH=%lx prvH=%lx IntegIndex=%lu


200 - 299 Messages


300 - 399 Messages


400 - 499 Messages

400

To include DAL Scripts in report, Variable Fields must also be selected!

Explanation

Programmer Response

426

Cannot load file %1

Explanation

Programmer Response

427

Cannot unload FIB file %1

Explanation

Programmer Response

428

No variable fields in file %1%nFIB File is not created

Explanation

Programmer Response

429

Cannot convert. File %1 already exists.

Explanation

Programmer Response

430

Cannot load FXR file %1%2%3

Explanation

Programmer Response

431

Cannot load file %1%2.FAP

Explanation

Programmer Response

432

OVL Compile failure on %1

Explanation

Programmer Response

433

TRN Compile failure on %1

Explanation

Programmer Response

434

DSK Compile failure on %1

Explanation

Programmer Response

435

Cannot load file %1%2.FM2

Explanation

Programmer Response

436

Cannot load file %1%2.FIB

Explanation

Programmer Response

437

Cannot convert. File %1%2.FAP already exists.

Explanation

Programmer Response

438

Cannot unload file %1%2.FAP

Explanation

Programmer Response

439

Cannot convert file %1

Explanation

Programmer Response

440

Cannot open file %1

Explanation

Programmer Response

441

Cannot load FIB file %1%2

Explanation

Programmer Response

442

Open PCL Error - %1

Explanation

Programmer Response

443

Memory Allocation Error for ImgPtr

Explanation

Programmer Response

444

Memory Allocation Error for TextPtr

Explanation

Programmer Response

445

Cannot convert. File %1%2.AFP already exists.

Explanation

Programmer Response

446

AFP Compile failure on %1

Explanation

Programmer Response

447

Cannot format text merge file %1

Explanation

Programmer Response

456

Cannot load file %1%2.OVL

Explanation

Programmer Response

457

Cannot load file %1%2.DOC

Explanation

Programmer Response

458

Cannot load file %1%2.RTF

Explanation

Programmer Response

459

Unable to load file '%1'.%n

Explanation

Programmer Response

460

Unable to unload file '%1'.%n

Explanation

Programmer Response

461

Destination file already exists: '%1'.%n

Explanation

Programmer Response

462

Could not load library: '%1'

Explanation

Programmer Response

463

Could not get function addr: '%1'

Explanation

Programmer Response

466

Errors converting FAP to MET, for description %nof the error use Conversion/Read Log File

Explanation

Programmer Response

467

Please select a valid FXR file.


500 - 599 Messages

500

Error: Missing user info file in INI.%n

Explanation

Programmer Response

502

From user %1%nWarning !!!%nUser maintenance in progress !%n

Explanation

Programmer Response

504

Error getting users list%nfrom file: %1.%n

Explanation

Programmer Response

505

A user ID is required.%n

Explanation

Programmer Response

506

User ID entered is not unique.%n

Explanation

Programmer Response

507

Password does not match Verify Password.%n

Explanation

Programmer Response

509

Error updating user: %1.%n

Explanation

Programmer Response

511

The specified user access level is not correct.%nEnter a value between %1 - 9.

Explanation

Programmer Response

512

You cannot assign an access level less than your own (%1).

Explanation

Programmer Response

513

You have an invalid user access level value.%nModifying user information will not be permitted.

Explanation

Programmer Response

514

Error: Cannot open user database: %1.%n

Explanation

Programmer Response

515

Error: Cannot release currently logged on user.

Explanation

Programmer Response

516

Error: Cannot delete currently logged on user.

Explanation

Programmer Response

518

Warning: The user you have chosen to delete may be actively using the program. %n%nDo you wish to continue with deleting the user's record?

Explanation

Programmer Response

519

Error sending messages%nFile: %1.%n

Explanation

Programmer Response

554

Error in user code in INI file%nLine: %1


600 - 699 Messages


700 - 799 Messages

734

Error initializing file. File cannot be processed.

Explanation

Programmer Response

735

Error opening file. Error code is %1.%n

Explanation

Programmer Response

736

File name must have an extension of %1. Or omit extension entirely.%n

Explanation

Programmer Response

766

Error initializing file. File cannot be processed.

Explanation

Programmer Response

767

Error opening file. Error code is %1.%n

Explanation

Programmer Response

768

ERROR: File name must have an extension of %1. Or omit extension entirely.%n


1000 - 1099 Messages

1027

One of the two errors: %n(1) (UserID ornd Password) isre wrong. %n(2) (UserID ornd Password) isre requires.


1800 - 1899 Messages

1841

Cannot Load Image:%n%1%n

Explanation

Programmer Response

1843

This formset is incomplete, and will not work correctly.%nAre you sure you want to save it?

Explanation

Programmer Response

1846

Save failed.%nFile may not be writable.%n

Explanation

Programmer Response

1847

Cannot Open File:%n%1%n

Explanation

Programmer Response

1848

Error saving file:%n%1%n

Explanation

Programmer Response

1849

The file has been saved, but is incomplete and may not work properly.%nFor errors see log file:%n%1

Explanation

Programmer Response

1851

An error occurred while loading the file.

Explanation

Programmer Response

1852

Load Recipient Table%nThe file does not exist.%nCreate it?

Explanation

Programmer Response

1853

The recipient file contained %1 entry that didn't match the formset.%nIt has been discarded.

Explanation

Programmer Response

1856

You have given custom rule data, but no custom rule.%nContinue?

Explanation

Programmer Response

1857

Error: Required field:<Copy Count> is blank.

Explanation

Programmer Response

1858

Error: One of the following fields must have data:%nTransaction Code%nSearch Mask (Counter)%nSearch Mask (True/False)%nCustom Rule Name

Explanation

Programmer Response

1859

Warning: One of the following fields usually should have data:%n Transaction Code%n Search Mask (Counter)%n Search Mask (True/False)%n Custom Rule Name%nDo you wish to create a 'blank' entry?

Explanation

Programmer Response

1862

Cannot load %1.%nIt may not be accessible or may not be a valid form definition file.

Explanation

Programmer Response

1863

Cannot load %1.%n

Explanation

Programmer Response

1865

You have to create a form for group (%1)(%2)

Explanation

Programmer Response

1866

Multiple forms within the Group (%1)(%2) are named (%3). Forms within a group must have unique names.

Explanation

Programmer Response

1867

You have to create a recipient for image (%1)

Explanation

Programmer Response

1868

Please select an object type.

Explanation

Programmer Response

1870

Please enter valid image name.

Explanation

Programmer Response

1897

The recipient file contained %1 or more entries that didn't match the formset.%nThey have been discarded.

Explanation

Programmer Response

1898

%1 not found.


2000 - 2099 Messages

2022

Failure to load %1

Explanation

Programmer Response

2031

Error creating main window: %1%n

Explanation

Programmer Response

2032

Cannot load menu file%n


2200 - 2299 Messages

2275

Failure to load module

Explanation

Programmer Response

2276

Failure to locate function

Explanation

Programmer Response

2277

Format %s requires at least %d characters, but the field length is only %d character(s)

Explanation

Programmer Response

2283

No item selected.

Explanation

Programmer Response

2287

GenFDBRpt() failure using %1 for %2%n

Explanation

Programmer Response

2288

Field Database report failed: %1

Explanation

Programmer Response

2290

%1 is not a Field Database file.


2300 - 2399 Messages

2376

Error converting

Explanation

Programmer Response

2377

is probably an old format!

Explanation

Programmer Response

2378

Record already exists for %1: %2, %3: %4 %5

Explanation

Programmer Response

2381

Source name is required. Choose 'yes' to enter source name or 'no' to delete record.

Explanation

Programmer Response

2382

Unable to open data dictionary.%n File name is %1.%n

Explanation

Programmer Response

2383

Unable to allocate list memory.%n

Explanation

Programmer Response

2384

ftell() error.%n File name is %1.%n

Explanation

Programmer Response

2385

Error encountered loading file. Line in error is%n%1%n

Explanation

Programmer Response

2386

List of rules could not be opened.%nFile name is %1.%n

Explanation

Programmer Response

2387

Virtual memory error.%nCannot create list.%n

Explanation

Programmer Response

2389

Help record not found

Explanation

Programmer Response

2390

%nWinGetLastError %1

Explanation

Programmer Response

2392

No item selected.

Explanation

Programmer Response

2394

GenXDBRpt() failure using %1 for %2%n

Explanation

Programmer Response

2395

Data Dictionary report failed: %1

Explanation

Programmer Response

2397

%1 is not a Data Dictionary file.


2500 - 2599 Messages

2516

Failure to load module

Explanation

Programmer Response

2517

Failure to locate function

Explanation

Programmer Response

2520

Duplicate form rule encountered!%n

Explanation

Programmer Response

2521

Error encountered while updating form rule.%n

Explanation

Programmer Response

2522

Error encountered while inserting form rule.%n

Explanation

Programmer Response

2524

List of rules could not be opened.%nFile name is %1.%n

Explanation

Programmer Response

2525

Virtual memory error.%nCannot create list.%n

Explanation

Programmer Response

2526

Unable to create help instance

Explanation

Programmer Response

2527

%1 does not already have a DDT file.%nInformation will be generated from image only.

Explanation

Programmer Response

2528

Insufficient memory to load file. The first line not to be loaded is the following:%n%1%n

Explanation

Programmer Response

2529

Cannot load : %1%nCaused DosLoadModule failure for: %2%nError: %3

Explanation

Programmer Response

2530

Cannot Query Address of: %1%nFor Module: %2%nError: %3

Explanation

Programmer Response

2531

Can only use DDT files in directory: %1%n

Explanation

Programmer Response

2532

Error encountered loading file. Line in error is%n%1%n

Explanation

Programmer Response

2533

No entry in initialization file for path to place DDT files%n

Explanation

Programmer Response

2534

Unable to open file to print report.%n File name is %1.%n

Explanation

Programmer Response

2535

Can't generate report, possibly because file is unnamed.

Explanation

Programmer Response

2538

Insufficient memory to analyze fields in image.%n

Explanation

Programmer Response

2539

Unknown error encountered while analyzing fields in image.%n

Explanation

Programmer Response

2542

Duplicate destination field name encountered!%nName: %1%n

Explanation

Programmer Response

2543

Error encountered while updating DDT data for field.%n

Explanation

Programmer Response

2544

Error encountered while inserting DDT data for field.%n

Explanation

Programmer Response

2546

Error encountered while copying DDT data for field.%n

Explanation

Programmer Response

2549

Destination Field Name is required.%n

Explanation

Programmer Response

2550

Rule is required.%n

Explanation

Programmer Response

2551

Rule Data cannot contain semicolons.%n

Explanation

Programmer Response

2552

%1 is required.%n

Explanation

Programmer Response

2553

GUI failure: %1

Explanation

Programmer Response

2554

Error! Could not create file %1.%n

Explanation

Programmer Response

2561

A Rules Editor window is already open.

Explanation

Programmer Response

2562

You must select (or insert) a row first.

Explanation

Programmer Response

2564

Invalid field characters: \ ; and " are not valid.%n

Explanation

Programmer Response

2566

No item selected.

Explanation

Programmer Response

2567

Error. Unable to RPSetErrorProc.

Explanation

Programmer Response

2568

Error encountered in reading the Translat.ini file.

Explanation

Programmer Response

2569

%1

Explanation

Programmer Response

2570

Error. Unable to ErrRegisterTokenData.

Explanation

Programmer Response

2571

File %1 is readonly, you would not be able to save it.

Explanation

Programmer Response

2572

You have entered a value greater than 65535. Please enter a value between 0 and 65535.%n


2600 - 2699 Messages

2660

No files of the requested type are available in %1.

Explanation

Programmer Response

2662

An error occurred getting the file.

Explanation

Programmer Response

2673

The extraction failed.

Explanation

Programmer Response

2675

%1%nDoes not exist.%nCreate a new library file?

Explanation

Programmer Response

2677

An error occurred in adding the file.

Explanation

Programmer Response

2678

Invalid date. Please, enter date in the range: 01/01/1800 - 12/31/3000

Explanation

Programmer Response

2679

The file already exists in the library file. Adding it again will increment the version by 1.

Explanation

Programmer Response

2680

GenLMGRpt() failure using %1 for %2%n

Explanation

Programmer Response

2682

Library File Report failed: %1


3000 - 3099 Messages

3003

Failure to load module

Explanation

Programmer Response

3004

Failure to locate function

Explanation

Programmer Response

3005

Format %1 requires at least %2 characters, but the field length is only %3 character(s). Do you want to automatically increase the field length?

Explanation

Programmer Response

3006

The font ID %1 is invalid. Please enter another ID.

Explanation

Programmer Response

3007

'%1' duplicates an existing variable field name. Please change it to a unique name.

Explanation

Programmer Response

3008

Fields must be Contiguous.

Explanation

Programmer Response

3009

Field length required.

Explanation

Programmer Response

3010

Multiline text fields cannot be placed within a text area.

Explanation

Programmer Response

3011

Table only fields require table information.

Explanation

Programmer Response

3012

The field length is invalid for this barcode. Do you want the length automatically changed to %1?

Explanation

Programmer Response

3014

Grid increments of 0.000 have been specified. These settings will result in the grid not displaying.

Explanation

Programmer Response

3017

You have entered a length greater than 1024. Please enter a length between 1 and 1024

Explanation

Programmer Response

3018

Numeric format %1 is invalid. Please enter another format

Explanation

Programmer Response

3019

You have entered a value greater than 65535. Please enter a value between 0 and 65535


3300 - 3399 Messages

3380

The font ID %1 is invalid. Please enter another ID.

Explanation

Programmer Response

3381

Objects are out of bounds. Do you want to stop and correct the chart ?

Explanation

Programmer Response

3382

Some objects on the chart contain invalid font IDs. Continue to exit ?

Explanation

Programmer Response

3383

Series name is not set for one or more series.

Explanation

Programmer Response

3384

Some Series names are not unique.

Explanation

Programmer Response

3394

No matches were found.

Explanation

Programmer Response

3395

No more matches were found.

Explanation

Programmer Response

3398

There is no series information setup for this chart. All options in the series dialog are now disabled.

Explanation

Programmer Response

3399

Dashed line requires data in the length field.


3400 - 3499 Messages

3400

Dashed line requires data in the space field.

Explanation

Programmer Response

3406

Unknown problem:

Explanation

Programmer Response

3407

Couldn't find the dictionary %1

Explanation

Programmer Response

3408

Open dictionary %1 failed, rc=%2 (@%3 %4)


3500 - 3599 Messages

3500

Sign on data is incorrect or %nmail system failed to start.

Explanation

Programmer Response

3502

Receive failed to complete successfully.

Explanation

Programmer Response

3503

File transfer via attachment.

Explanation

Programmer Response

3504

Send failed to complete successfully.

Explanation

Programmer Response

3505

[Mail] MailType not defined in INI file.

Explanation

Programmer Response

3506

[MailType] Module not defined in INI file.

Explanation

Programmer Response

3507

[MailType] Module: Library failed to load.

Explanation

Programmer Response

3508

[MailType] MailFunc not defined in INI file.

Explanation

Programmer Response

3509

[MailType] MailFunc: Function cannot be located.

Explanation

Programmer Response

3510

Mail system not started successfully.

Explanation

Programmer Response

3511

Email Print failed.

Explanation

Programmer Response

3512

Email Print: No output file.


4800 - 4899 Messages

4801

No Menu


5200 - 5299 Messages

5222

Requested information not yet found. Continue searching?

Explanation

Programmer Response

5229

WIP sort information has not been defined.

Explanation

Programmer Response

5231

FORMSETID is required and is not defined in the DFD file.%n%1

Explanation

Programmer Response

5299

Invalid time


5300 - 5399 Messages

5300

Statement:%n----------%n%1%n----------%nError %2%3 at line %4 column %5%n%6%nAt %7

Explanation

Programmer Response

5301

Invalid date

Explanation

Programmer Response

5302

Bar code requires %ld characters

Explanation

Programmer Response

5303

Invalid bar code

Explanation

Programmer Response

5304

Invalid input data

Explanation

Programmer Response

5305

Invalid numeric format

Explanation

Programmer Response

5306

Input value too big

Explanation

Programmer Response

5307

Error at position

Explanation

Programmer Response

5308

Field: %1%nInput: %2%nFormat: %3%n%4%5

Explanation

Programmer Response

5310

Failure to load module: %1

Explanation

Programmer Response

5311

Failure to locate function: %1

Explanation

Programmer Response

5312

Help record not found

Explanation

Programmer Response

5313

Load failure on %1

Explanation

Programmer Response

5317

No entry fields

Explanation

Programmer Response

5318

View only mode: %1

Explanation

Programmer Response

5319

Field:%1 Length:%2 Font:%3

Explanation

Programmer Response

5320

Required entry

Explanation

Programmer Response

5324

Using incorrect language

Explanation

Programmer Response

5325

*Hidden form: select to load.

Explanation

Programmer Response

5326

Input: %1%nPlease select a value from the table


5400 - 5499 Messages

5400

%1%nThis session may contain an active program. Ending the session will discard any unsaved data. Do You want to end it ?

Explanation

Programmer Response

5401

Error: %1 Cannot execute: %2%nDosStartSession Error Loading: %3

Explanation

Programmer Response

5402

Error...Cannot Load Module: %1%nUTLLoadLibrary Error

Explanation

Programmer Response

5403

Cannot Query Address of: %1%nUTLQueryProcAddr Error: %2

Explanation

Programmer Response

5404

Cannot Query Address of: %1%nDosQueryProcAddr Error: %2

Explanation

Programmer Response

5406

Too many points. Unable to allocate memory

Explanation

Programmer Response

5409

Platform error:%n FAP Error code=%1%n %2%n %3

Explanation

Programmer Response

5410

Platform error:%n %1

Explanation

Programmer Response

5411

GUI Error code=0x%1

Explanation

Programmer Response

5412

!!! Bad VMM handle !!!%n!!! Aborting program !!!%nVMM Error code=%1%n %2%n %3

Explanation

Programmer Response

5413

Please select a library.

Explanation

Programmer Response

5414

Are you sure that you want to delete it?

Explanation

Programmer Response

5415

Error Found in Resource Library Paths. Continue?

Explanation

Programmer Response

5416

Name the library before exiting dialog.

Explanation

Programmer Response

5417

FormLib and Form7x are set to the same path. Some data files will be overwritten unless one of the directories is changed.

Explanation

Programmer Response

5418

Could not find the XrfFile in the DefLib directory. Continue?

Explanation

Programmer Response

5419

%1 already exists. Do you want to overwrite existing file?

Explanation

Programmer Response

5420

DC already exists

Explanation

Programmer Response

5421

Error

Explanation

Programmer Response

5422

Error while printing:%nError code=%1%n %2%n %3%nDo you want to continue?

Explanation

Programmer Response

5423

The file you are saving contains multiple pages. Your 7x file name is limited to the first 6 characters. You may want to verify this 6 characters file name is unique.

Explanation

Programmer Response

5424

File %1 already exists. Do you want to overwrite it ?

Explanation

Programmer Response

5425

Select name for new file

Explanation

Programmer Response

5426

Error in font set %1

Explanation

Programmer Response

5427

PM failure on %1%nLast PM error=0x%2

Explanation

Programmer Response

5428

Are you sure you want to Remove a Custom Color?

Explanation

Programmer Response

5439

%1 already exists and is read only. You must pick another file.

Explanation

Programmer Response

5455

Loader error:%n FAP Error code=%1%n %2%n %3Continue?

Explanation

Programmer Response

5456

Initialization failed.

Explanation

Programmer Response

5457

Failed to create main window.

Explanation

Programmer Response

5458

Cannot open input file.

Explanation

Programmer Response

5459

Cannot open output file.

Explanation

Programmer Response

5460

Cannot run Color dialog.

Explanation

Programmer Response

5461

Cannot get HPS for window.

Explanation

Programmer Response

5462

Failed to load help manager.

Explanation

Programmer Response

5463

Failed to load string.

Explanation

Programmer Response

5464

Failed to open printer.

Explanation

Programmer Response

5465

Failed to display help panel.

Explanation

Programmer Response

5466

Cannot load Exit List processor.

Explanation

Programmer Response

5467

Printer initialization failed.

Explanation

Programmer Response

5469

Error while printing. Printing aborted.

Explanation

Programmer Response

5470

Failed to Undo.

Explanation

Programmer Response

5471

Error getting file information.

Explanation

Programmer Response

5472

Not enough memory.

Explanation

Programmer Response

5473

Error reading file.

Explanation

Programmer Response

5474

Error writing file.

Explanation

Programmer Response

5475

Cannot load fonts.

Explanation

Programmer Response

5476

Error obtaining printer page information.


5600 - 5699 Messages

5601

Error initializing file. File cannot be processed.

Explanation

Programmer Response

5602

Error opening file. Error code is %1.%n

Explanation

Programmer Response

5603

File name must have an extension of %1. Or omit extension entirely.%n

Explanation

Programmer Response

5604

Entry selection error.%nAn entry has not been selected.

Explanation

Programmer Response

5605

Dynamic link library for table entry view not found.%n

Explanation

Programmer Response

5606

File not found. Create file %1?%n

Explanation

Programmer Response

5607

Are you sure you want to delete table %1 and all its entries?%n

Explanation

Programmer Response

5608

Error deleting table. Return code is %1.%n

Explanation

Programmer Response

5609

A table has not been selected.

Explanation

Programmer Response

5610

Error encountered trying to read database. Error code is %1

Explanation

Programmer Response

5611

Error deleting entry. Return code is %1.%n

Explanation

Programmer Response

5612

An entry has not been selected.

Explanation

Programmer Response

5613

Entry name is required

Explanation

Programmer Response

5614

An entry record with this name already exists.%nDo you want to overwrite it?

Explanation

Programmer Response

5615

Error processing record. Error code = %1%n

Explanation

Programmer Response

5617

Key length must be between 1 and %1 inclusive.%n

Explanation

Programmer Response

5618

Description length must be between 1 and %1 inclusive.%n

Explanation

Programmer Response

5619

Changing to a shorter description length may result in the loss of data.

Explanation

Programmer Response

5620

Table name is invalid

Explanation

Programmer Response

5621

Changing to a shorter key length may result in duplicate keys and make some entries inaccessible.

Explanation

Programmer Response

5623

New table already exists.

Explanation

Programmer Response

5624

Are you sure you want to merge table %1 into table %2?%n All duplicate entries in table %3 will be deleted.

Explanation

Programmer Response

5625

Error reading table %1. Error code is %2.

Explanation

Programmer Response

5626

Error processing record. Return code is %1.%n

Explanation

Programmer Response

5627

Are you sure you want to delete entry %1 in table %2?%n

Explanation

Programmer Response

5629

GenTableRpt() failure using %1 for %2%n

Explanation

Programmer Response

5631

Table report failed: %1

Explanation

Programmer Response

5634

Table file %1 is in an older format. Would you like to convert it?


5800 - 5899 Messages

5803

A text area that can span pages must be named.%nRequired field: Name

Explanation

Programmer Response

5804

The width of the text area has been changed.%nWould you like to have the columns automatically adjusted?

Explanation

Programmer Response

5805

The horizontal and/or vertical line widths are set to zero.%n%nWould you like to turn off the drawing of the edges with zero widths?

Explanation

Programmer Response

5806

Width is required.

Explanation

Programmer Response

5807

Height is required.

Explanation

Programmer Response

5808

TXM Window Class Registration Error

Explanation

Programmer Response

5809

Error Accessing the Module Handle

Explanation

Programmer Response

5810

Can not create the txm window

Explanation

Programmer Response

5811

The sum of column and margin widths does not match the total size of the text area. The text area may not display/print correctly.%nContinue?

Explanation

Programmer Response

5812

The line after the last column will be removed.

Explanation

Programmer Response

5815

Unable to Create the Display Context.

Explanation

Programmer Response

5816

Unable to Create the Presentation Space.

Explanation

Programmer Response

5817

Failure to load module: %1

Explanation

Programmer Response

5818

Failure to locate function: %1

Explanation

Programmer Response

5819

Cannot load file %1

Explanation

Programmer Response

5821

Default tab stop cannot exceed text area width of %1 %2.

Explanation

Programmer Response

5823

Not all of the text had a bold version of font available.

Explanation

Programmer Response

5824

Not all of the text had an italic version of font available.

Explanation

Programmer Response

5828

Multiline text fields cannot be placed within a text area.

Explanation

Programmer Response

5835

Editor menu specified in the INI failed to load.%n[TXMMENU=%1]%nContinuing with the default menu.


5900 - 5999 Messages

5900

Userinfo file cannot be opened.

Explanation

Programmer Response

5903

Invalid user ID specified in INI.

Explanation

Programmer Response

5905

Invalid User Password.

Explanation

Programmer Response

5906

Invalid User ID.

Explanation

Programmer Response

5907

A User ID is required.


6000 - 6099 Messages

6006

Can not find any match in this table.

Explanation

Programmer Response

6007

No more occurrences appear in this table.


6100 - 6199 Messages

6100

Missing Archive procedure definition in INI.%n

Explanation

Programmer Response

6102

Missing Archive Status Code in INI.%n

Explanation

Programmer Response

6103

Failed to archive.

Explanation

Programmer Response

6104

Option %1 in INI group %2 not found.%n

Explanation

Programmer Response

6108

Failed to delete WIP record.%n

Explanation

Programmer Response

6109

Option DefLib in INI group MasterResource not found.%n

Explanation

Programmer Response

6110

Option AppIdxDfd in INI group ArcRet not found.%n

Explanation

Programmer Response

6111

Missing CAR file name in INI.%n

Explanation

Programmer Response

6112

Failed to init DB archive.%n

Explanation

Programmer Response

6113

Missing Archive procedure definition in INI.%n

Explanation

Programmer Response

6114

Failed to init archive.%n

Explanation

Programmer Response

6115

Failed to init CAR file.%n

Explanation

Programmer Response

6116

Error StartArc DAT File: %1%n

Explanation

Programmer Response

6117

Error EndArc DAT File: %1%n

Explanation

Programmer Response

6118

Error Arc DAT File: %1%n

Explanation

Programmer Response

6119

Error StartArc POL File: %1%n

Explanation

Programmer Response

6120

Error Arc POL File: %1%n

Explanation

Programmer Response

6121

Error EndArc POL File: %1%n

Explanation

Programmer Response

6122

Unable to INIFirstInitValue(<AfeWip2ArchiveRecord>,NULL,,).%n

Explanation

Programmer Response

6123

Error in ini group:<AfeWip2ArchiveRecord> option:<%1>. Value:<%2> does not exist as a field in the wip dfd file.%n

Explanation

Programmer Response

6124

Error in ini group:<AfeWip2ArchiveRecord> option:<%1>. Option:<%2> does not exist as a field in the archive dfd file.%n

Explanation

Programmer Response

6126

Cannot complete !!!%nRequired fields are empty.

Explanation

Programmer Response

6128

Error: Invalid transaction found in Selective Import Driver File

Explanation

Programmer Response

6129

Form %1 is not repeatable.

Explanation

Programmer Response

6130

%1 %2 is not defined.%nNo additional forms can be provided.

Explanation

Programmer Response

6131

Unable to load %1

Explanation

Programmer Response

6132

Cannot append data record

Explanation

Programmer Response

6133

Form %1 is not repeatable.

Explanation

Programmer Response

6134

Number of WIP processed was %1

Explanation

Programmer Response

6135

Warning!%nForm %1 is required.%nDefaulting copy count to 1.

Explanation

Programmer Response

6136

No forms selected.

Explanation

Programmer Response

6137

No entry forms selected.

Explanation

Programmer Response

6139

DSLoadNAFormset fail.%nFile: %1%nError: %2

Explanation

Programmer Response

6140

Error saving POL file %1%n

Explanation

Programmer Response

6141

Error saving DAT file: %1

Explanation

Programmer Response

6142

Error saving PKG file: %1

Explanation

Programmer Response

6143

Warning !!!%nFailed to load %1.%n

Explanation

Programmer Response

6144

You do not have permission to delete with this userID: %1.

Explanation

Programmer Response

6145

Missing INI file...program will terminate.%n

Explanation

Programmer Response

6146

Failed to initialize desktop.%n

Explanation

Programmer Response

6147

Error: Missing Userinfo file in INI.%n

Explanation

Programmer Response

6148

WipPath INI option not found.%n

Explanation

If you encouter this error trying to open a document for Documange Workstation, it means that fsiuser.ini that the environment variable FSIPath points to is incorrect. The system updates [CONFIG:xxx] in the fsiuser.ini with the value in the CONFIG tag in the XML header of the DPA file for the document.

Programmer Response

Open the fsiuser.ini that the environment variable FSIPath points to and search for the control group

[ WipData ].

Make sure that Path option points to a vaild path.

For example:

If the fsiuser.ini contains

[ WipData ]

File = wip

Path = [CONFIG:test] WIPPath =

make sure that the following control group and options are defined

[ CONFIGURATIONS ]

CONFIG = test

[ CONFIG:test ]

ARCPath = c:\fap\mstrres\test\arc\

CARPath = c:\fap\mstrres\test\arc\

DefLib = c:\fap\mstrres\test\deflib\

FntFile = rel95sm.FNT

FontLib = c:\fap\mstrres\test\fntlib\

FormDef = FORM.DAT

FormLib = c:\fap\mstrres\test\forms\

HelpLib = c:\fap\mstrres\test\arc\

TableLib = c:\fap\mstrres\test\arc\

WIPPath = c:\fap\mstrres\test\arc\

XrfFile = rel95sm

see also "How do you use FSIPath?" in faq_book.pdf (FAQ Guide)

6149

Missing Wip File in INI.%n

Explanation

Programmer Response

6150

[AFEProcedures] Security procedure is not defined%nor cannot be located!

Explanation

Programmer Response

6151

Unable to INIGetInitValue(,<ArcRet>,<AppIdx>).%n

Explanation

Programmer Response

6153

Failure to open device %1

Explanation

Programmer Response

6154

Failure to close device %1

Explanation

Programmer Response

6156

Failure to write to device %1

Explanation

Programmer Response

6158

The archive file %1.CAR will be moved to optical storage

Explanation

Programmer Response

6159

Retrieve.%nToo many transactions selected.%nChange INI Option 'LBLimit'

Explanation

Programmer Response

6160

DosCopy Error, return code = %1

Explanation

Programmer Response

6161

DosDelete Error, return code = %1

Explanation

Programmer Response

6162

DosFindFirst Error, return code = %1

Explanation

Programmer Response

6164

flipvol = %1%nvolume size = %2%ndisk_freespace = %3%nuser_freespace = %4

Explanation

Programmer Response

6167

Failed to initialize archive.%n

Explanation

Programmer Response

6168

Failed to pack file %1%n

Explanation

Programmer Response

6169

Failed to pack image %1%n

Explanation

Programmer Response

6170

Failed to terminate archive%n

Explanation

Programmer Response

6171

Failed to retrieve file %1%n

Explanation

Programmer Response

6172

Failed to load WIP record from file.%n%1%n

Explanation

Programmer Response

6173

Failed to append WIP record %1.%n

Explanation

Programmer Response

6174

Failed to retrieve image %1.%n

Explanation

Programmer Response

6178

Failed to unload WIP record.%n

Explanation

Programmer Response

6181

Error: %1 Cannot execute: %2%n%nDosStartSession Error Loading: %3

Explanation

Programmer Response

6186

Failed to retrieve DAT.%n

Explanation

Programmer Response

CARPath = .\arc\

Potentially the carpath option is incorrect.

6187

Failed to retrieve POL.%n

Explanation

Programmer Response

CARPath = .\arc\

Potentially the carpath option is incorrect.

6188

Failed to init retrieve.%n

Explanation

Programmer Response

<ArcRet>

Catalog =.\arc\catalog

Error may occur if the path or file name is incorrect in this INI control group.

6189

Error loading archive index DFD file <%1>. Tip: Check library setup ARCPath and DefLib. Also ini option <ArcRet> AppIdxDfd.

Explanation

Programmer Response

6190

Unable to INIGetInitValue(,<AfeArchiveDisplay>,<RunDate>).%n

Explanation

Programmer Response

6191

Error in ini group <ArcRet> option <Key1>.%nValue <%1> does not exist in archive index DFD file.%n

Explanation

Programmer Response

6192

Error in ini group <ArcRet> option <Key2>.%nValue <%1> does not exist in archive index DFD file.%n

Explanation

Programmer Response

6193

Error in ini group <ArcRet> option <KeyID>.%nValue <%1> does not exist in archive index DFD file.%n

Explanation

Programmer Response

6194

Warning: Field:<RunDate> is not defined in the archive dfd file. The RunDate filtering is disabled.%n

Explanation

Programmer Response

6195

Retrieve.%nDBOpen failed.%n

Explanation

Programmer Response

6196

Too many transactions with this key.%nYou will see the first %d only

Explanation

Programmer Response

6197

Retrieve.

No transactions with this key.

Explanation

Troubleshooting: Review ExactMatch

Programmer Response

6198

Retrieve.

Too many transactions selected.%nChange INI Option 'LBLimit'

Explanation

Programmer Response

6199

Unable to INIFirstInitValue(,<AfeArchiveDisplay>,<Field>).%n


6200 - 6299 Messages

6200

Error in ini group <AfeArchiveDisplay>, option <Field>.%nIni value <%1> requires two fields (comma delimited).

Explanation

Programmer Response

6201

Error in ini group <AfeArchiveDisplay>, option <Field>.%nIni value <%1> is not in archive index dfd file.

Explanation

Programmer Response

6202

Unable to INIFirstInitValue(,<ArcRet>,<AppIdx>).

Explanation

Programmer Response

6203

Cannot pack database when users are%nlogged on.

Explanation

Programmer Response

6205

DSLoadNAFormset fail.%nFile: %1%nError: %2

Explanation

Programmer Response

6206

You must have at least one recipient selected!

Explanation

Programmer Response

6207

Missing 'CompanyLibName' under Environment INI group.

Explanation

Programmer Response

6208

ERROR: Invalid transaction in Driver list%n%1

Explanation

Programmer Response

6209

No entries for User ID %1 appear in Driver List

Explanation

Programmer Response

6210

ERROR: Sharing violation opening %1

Explanation

Programmer Response

6211

ERROR: Too many files open.

Explanation

Programmer Response

6212

ERROR: File not found opening %1

Explanation

Programmer Response

6213

ERROR: Unspecified Error opening file %1

Explanation

Programmer Response

6214

ERROR: In %1 line # %2 %n%3

Explanation

Programmer Response

6215

ERROR: In %1 line # %2 User ID too long

Explanation

Programmer Response

6216

ERROR: Out of memory in %1 line # %2

Explanation

Programmer Response

6217

ERROR: %1 is empty

Explanation

Programmer Response

6218

ERROR: Filename <%1> is too long to be a valid DOS file name.

Explanation

Programmer Response

6219

ERROR: Filename <%1> extenstion <%2> is too long to be a valid DOS file name.

Explanation

Programmer Response

6220

ERROR: Adding import file to list%n %1

Explanation

Programmer Response

6225

Transaction Function Returned Error

Explanation

Programmer Response

6226

Error in transaction code in INI file%nLine: %1

Explanation

Programmer Response

6227

Error:%n%1%n

The system cannot find the patch specified.

Explanation

Programmer Response

Ensure the wip directory exists.

Ensure the INI control group and options are correct.

<wip>

Path

File

Even though the error occurs during archive retrieval you must have a valid Wip directory and ini statements because the system will attempt to write temp files there.

6229

AFEDATA WIP record not defined.

Explanation

Programmer Response

6230

Transaction Code is missing in WIP.

Explanation

Programmer Response

6231

%1 is missing in WIP record.

Explanation

Programmer Response

6232

WIP Status Code is not coded in INI.

Explanation

Programmer Response

6233

NEW Record Type is not coded in INI.

Explanation

Programmer Response

6234

%1 is not unique.

Explanation

Programmer Response

6237

WIPAppend fail.%n File: %1

Explanation

Programmer Response

6238

Error StartArc PKG File: %1%n

Explanation

Programmer Response

6239

Error Arc PKG File: %1%n

Explanation

Programmer Response

6240

Error EndArc PKG File: %1%n

Explanation

Programmer Response

6241

Error StartArc PKG File Contents: %1%n

Explanation

Programmer Response

6242

Error Arc PKG File Contents: %1%n

Explanation

Programmer Response

6243

Error EndArc PKG File Contents: %1%n

Explanation

Programmer Response

6244

Failed to retrieve PKG.%n

Explanation

Programmer Response

6245

Failed to retrieve PKG contents.%n

Explanation

Programmer Response

6246

Unable to logoff current user: (%1).

Explanation

Programmer Response

6247

Failed to open routing slips table.%n File: %1

Explanation

Programmer Response

6248

New routing slip could not be added to slips table.

Explanation

Programmer Response

6249

Unknown error%n %1

Explanation

Programmer Response

6250

No car path specified in INI file%n %1

Explanation

Programmer Response

6251

No optical drive specified in INI file%n %1

Explanation

Programmer Response

6252

Car file size could not be calculated%n %1

Explanation

Programmer Response

6253

No maximum car file size specified in INI file%n %1

Explanation

Programmer Response

6254

Car file larger than maximum specified in INI file%n %1

Explanation

Programmer Response

6255

No volumes found on optical drive%n %1

Explanation

Programmer Response

6256

All mounted volumes are full%n %1

Explanation

Programmer Response

6257

No Catalog specified in INI file%n %1

Explanation

Programmer Response

6258

Error opening catalog file%n %1

Explanation

Programmer Response

6259

Error closing catalog file%n %1

Explanation

Programmer Response

6260

Error updating catalog file%n %1

Explanation

Programmer Response

6261

Error deleting car file from fixed disk%n %1

Explanation

Programmer Response

6262

Error copying car file from fixed to optical drive%n %1

Explanation

Programmer Response

6263

Invalid operation%n %1

Explanation

Programmer Response

6264

Extended attributes could not be obtained for volume%n %1

Explanation

Programmer Response

6265

Element insertion into VMM list failed%n %1

Explanation

Programmer Response

6266

Postponing this round of AutoSave.

Explanation

Programmer Response

6268

Error in ini group:<AFEFormset2Archive> option:<%1>. Value:<%2> does not exist as a field in the archive dfd file.%n

Explanation

Programmer Response

6269

Unable to lock WIP Database file. %nSome else may have exculsive right to it.


6300 - 6399 Messages

6305

Path %1 can't be accessed

Explanation

Programmer Response

6311

Page insertion failed

Explanation

Programmer Response

6312

Dialog could not be loaded

Explanation

Programmer Response

6313

Set bitmap failed

Explanation

Programmer Response

6314

Set text for tab failed

Explanation

Programmer Response

6315

Insert status line failed

Explanation

Programmer Response

6316

Associate dialog with page failed

Explanation

Programmer Response

6317

Unable to create button: %1

Explanation

Programmer Response

6318

Select a path to save 7.x files to:

Explanation

Programmer Response

6325

GUIDrawBitmap:BitBlt failure

Explanation

Programmer Response

6347

You have entered an illegal character in a numeric only field. Please correct the entry before continuing.

Explanation

Programmer Response

6348

A field requiring input has been left blank. Please ensure that all fields are given values.

Explanation

Programmer Response

6349

Spin Button Edit Not Created

Explanation

Programmer Response

6350

Spin Button Up-Down Not Created

Explanation

Programmer Response

6352

The name you have chosen already exists.%nPlease choose another.

Explanation

Programmer Response

6370

Caution: This process will physically remove the deleted records.%n

Explanation

Programmer Response

6371

File: %1%n is in use or is missing.%n

Explanation

Programmer Response

6372

Unable to allocate memory.%n

Explanation

Programmer Response

6378

%1 is an invalid user

Explanation

Programmer Response

6392

Problems with the DATABASE. %nCould not create new UNIQUE file and ID.

Explanation

Programmer Response

6398

Autosave detected an unsaved file from previous work. %nDo you want to load this file.


6400 - 6499 Messages

6400

Error initializing file. File cannot be processed.

Explanation

Programmer Response

6401

File not found.%nCreate file %1?%n

Explanation

Programmer Response

6402

Error creating file. Error code is %1.%n

Explanation

Programmer Response

6403

DLL Load Error%nDynamic link library for ddtmap tool not found.%n

Explanation

Programmer Response

6404

Error opening file. Error code is %1.%n

Explanation

Programmer Response

6405

File name must have an extension of %1. Or omit extension entirely.%n

Explanation

Programmer Response

6406

MLM_SETIMPORTEXPORT Error%nError encountered while displaying text

Explanation

Programmer Response

6407

Are you sure you want to delete help record %1?%n

Explanation

Programmer Response

6408

Error deleting record. Error code is %1.%n

Explanation

Programmer Response

6409

Help selection error%nA help record has not been selected.

Explanation

Programmer Response

6410

Error retrieving help record. Record could not be found.

Explanation

Programmer Response

6411

Data entry error%nA help key cannot be empty

Explanation

Programmer Response

6412

A help record with this key already exists.%nDo you want to overwrite it?

Explanation

Programmer Response

6413

Error processing record. Error code = %1%n

Explanation

Programmer Response

6415

Error retrieving record number for duplicated key. Error code is %1%n.

Explanation

Programmer Response

6417

GenHelpRpt() failure using %1 for %2%n

Explanation

Programmer Response

6419

Help report failed: %1


6500 - 6599 Messages

6506

Failure to load module

Explanation

Programmer Response

6507

Failure to locate function

Explanation

Programmer Response

6508

Format %s requires at least %d characters, but the field length is only %d character(s)

Explanation

Programmer Response

6548

There is an autosave file for this image, which may indicate that the image wasn't saved correctly due to some kind of failure. %nWould you like to open the autosave file instead?

Explanation

Programmer Response

6549

Changes to this file will be lost.%nAre you sure you want to unlock it?

Explanation

Programmer Response

6550

Compile failure on %1%2%3

Explanation

Programmer Response

6551

Update Image History cancelled. %nDo you want to cancel save/check-in as well?

Explanation

Programmer Response

6552

Unload failure on %1%2%3

Explanation

Programmer Response

6553

Failure to load module: %1

Explanation

Programmer Response

6554

Failure to locate function: %1


6600 - 6699 Messages

6616

The save process could not be completed because an error occurred

Explanation

Programmer Response

6626

The color, font, or vertical positions of the selected labels are not consistent. Some of this information will be lost if you convert them into a single label.%n%nWould you rather convert them into a text area?

Explanation

Programmer Response

6627

Memory allocation failed.

Explanation

Programmer Response

6631

Your current changes will be lost and the image data will revert to the version most recently saved.

Explanation

Programmer Response

6634

An error occurred creating the color table.

Explanation

Programmer Response

6635

You have already defined the maximum amount of colors. The color currently selected will be replaced with your newly defined color. Do you want to proceed?

Explanation

Programmer Response

6636

You have already defined the maximum amount of colors. To define a new color now, you must first select one of your previously defined colors. The new color will replace the color that you select.

Explanation

Programmer Response

6637

Default colors can not be replaced. You are only allowed to replace the colors that you have defined.

Explanation

Programmer Response

6638

Please enter a value between 0 and 255.

Explanation

Programmer Response

6639

This will reset your color palette to only the default colors. You will lose any colors you have already defined. Do you want to continue?

Explanation

Programmer Response

6642

You have entered an illegal character in a numeric only field. Please correct the entry before continuing.

Explanation

Programmer Response

6643

A field requiring input has been left blank. Please ensure that all fields are given values.

Explanation

Programmer Response

6644

'%s' duplicates an existing variable field name. Please change it to a unique name.

Explanation

Programmer Response

6647

The font ID %1 is invalid. Please enter another ID.

Explanation

Programmer Response

6649

%1 objects on the image contain invalid font IDs. These objects will not display until the IDs are corrected.%n%nCorrect IDs now ?

Explanation

Programmer Response

6651

A horizontal grid increment of 0.000 has been specified. This setting will result in the grid not displaying.

Explanation

Programmer Response

6652

A vertical grid increment of 0.000 has been specified. This setting will result in the grid not displaying.

Explanation

Programmer Response

6653

Grid increments of 0.000 have been specified for both grids. These settings will result in the grids not displaying.

Explanation

Programmer Response

6654

A horizontal line weight of 0.000 has been specified. Do you want to use %1 units instead?

Explanation

Programmer Response

6655

A vertical line weight of 0.000 has been specified. Do you want to use %1 units instead?

Explanation

Programmer Response

6656

Invalid bar code.%nCode must have a value.

Explanation

Programmer Response

6657

Invalid Bar code.%nError at position %1

Explanation

Programmer Response

6671

Warning: Object(s) are outside of boundary.

Explanation

Programmer Response

6682

Dashed line requires data in the length field.

Explanation

Programmer Response

6683

Dashed line requires data in the space field.

Explanation

Programmer Response

6685

You have opened a Read Only file! You will not be allowed to edit this file.

Explanation

Programmer Response

6686

There are %1 object(s) out of bounds on this page. %n%2 Do you want to stop and correct the out of bounds objects?

Explanation

Programmer Response

6689

There are %1 object(s) out of bounds on this page. %2%n Do you want to cancel this change?

Explanation

Programmer Response

6692

Font %1 is invalid

Explanation

Programmer Response

6695

Application Error

Explanation

Programmer Response

6697

%nReturn Code = %1, Module = %2

Explanation

Programmer Response

6698

, Line Number = %1

Explanation

Programmer Response

6699

Can't open file %1%nError: %2


6700 - 6799 Messages

6711

Only %1 copies were made within the page boundry.

Explanation

Programmer Response

6712

Unload to %1 failed

Explanation

Programmer Response

6715

Image check failed: %1

Explanation

Programmer Response

6716

DosQueryModuleHandle(%1,...) returned %2

Explanation

Programmer Response

6717

Unload to %1 failed

Explanation

Programmer Response

6719

Spell check cancelled. %nDo you want to cancel save/check-in as well?

Explanation

Programmer Response

6725

GenFormRpt() failure using %1 for %2%n

Explanation

Programmer Response

6727

Image report failed: %1

Explanation

Programmer Response

6731

Warning: One or more objects can not be converted to text. Continue??


6800 - 6899 Messages

6803

Failure to load module

Explanation

Programmer Response

6804

Failure to locate function

Explanation

Programmer Response

6805

Format %s requires at least %d characters, but the field length is only %d character(s)

Explanation

Programmer Response

6806

Failure to load module: %1

Explanation

Programmer Response

6807

Failure to locate function: %1

Explanation

Programmer Response

6808

Changes to this file will be lost.%nAre you sure you want to unlock it?

Explanation

Programmer Response

6809

Unload failure on %1%2%3

Explanation

Programmer Response

6810

Rotation names must be unique.

Explanation

Programmer Response

6811

Can't open file %1%n

Explanation

Programmer Response

6823

Save failed! Do you want to continue to exit?

Explanation

Programmer Response

6824

You have opened a Read Only file! You will not be able to edit this file.

Explanation

Programmer Response

6825

The string is empty. Please enter at least one character.


8900 - 8999 Messages

8903

Invalid import file

Explanation

Programmer Response

8904

Invalid file name.%n[%1] FILE = %2%n

Explanation

Programmer Response

8905

No successful imports

Explanation

Programmer Response

8908

Function [%1] has already been installed.%n

Explanation

Programmer Response

8909

INI option [%1] Path=%nor %nINI option [%2] File=%nmust be defined.

Explanation

Programmer Response

8910

Unable to create import list.

Explanation

Programmer Response

8911

Unable to add to import list.

Explanation

Programmer Response

8912

Function [%1] has been requested but%nhas not been initialized.%n

Explanation

Programmer Response

8913

Cannot allocate import structure%n

Explanation

Programmer Response

8914

[%1] Status Code=%2 is not defined or is not valid.

Explanation

Programmer Response

8915

[%1] Record Type=%2 is not defined or is not valid.

Explanation

Programmer Response

8917

[%1] Transaction Code=%2 is not defined or is not valid.

Explanation

Programmer Response

8918

Formset number %1 failed to import.%nDo you want to skip this formset and continue importing?

Explanation

Programmer Response

8919

INI function [AFEProcedures] FormDescProc failed to load

Explanation

Programmer Response

8921

File already exists.%nAre you sure you want to overwrite it ?

Explanation

Programmer Response

8922

Failed to write to export file.

Explanation

Programmer Response

8923

Failed to write to export file.%nDo you want to try again?

Explanation

Programmer Response

8924

A begin and end value must be provided.

Explanation

Programmer Response

8925

The begin and end values must be of equal length.

Explanation

Programmer Response

8926

The non-key portion of the value is not numeric.

Explanation

Programmer Response

8927

The second value must be greater or%nequal to the start value.

Explanation

Programmer Response

8928

The difference between the values is two large.

Explanation

Programmer Response

8929

Unable to add keys to table.

Explanation

Programmer Response

8930

Unable to retrieve a key from the table.

Explanation

Programmer Response

8931

Unable to count available remaining keys.

Explanation

Programmer Response

8932

This key is assigned to another user or%nthe table entry cannot be released.

Explanation

Programmer Response

8933

This key entry cannot be removed or%nis assigned to another user.

Explanation

Programmer Response

8934

This key is already assigned.%nPlease select a different key.

Explanation

Programmer Response

8935

This key assignment cannot be updated%nin the table.

Explanation

Programmer Response

8936

The automatic key table cannot be created or opened.

Explanation

Programmer Response

8937

The output buffer size is not large enough%nto receive key assignment.

Explanation

Programmer Response

8938

This key has already been assigned.

Explanation

Programmer Response

8939

This key was not assigned for use.

Explanation

Programmer Response

8940

Changes to %1 are not currently permitted.

Explanation

Programmer Response

8941

Warning:%nRemaining keys = %1.

Explanation

Programmer Response

8942

The current ID is from the table.%nDelete this entry and select another?

Explanation

Programmer Response

8943

Cannot create bitmap list

Explanation

Programmer Response

8944

Cannot create FAP bitmap

Explanation

Programmer Response

8945

Cannot load bitmap %1

Explanation

Programmer Response

8949

Import Error: Empty file.

Explanation

Programmer Response

8950

Import Error: No formset header.

Explanation

Programmer Response

8951

Import Error: Bad formset header: Must have at least Group1, Group2, and Key.

Explanation

Programmer Response

8952

Import Error: Unable to create group %1 %2.

Explanation

Programmer Response

8953

Import Error: Invalid Transaction code: %1.

Explanation

Programmer Response

8954

Import Error: Bad NA line: Must have at least Group1, Group2, and Key.

Explanation

Programmer Response

8955

Import Error: No form name provided.

Explanation

Programmer Response

8956

Import Error: Unable to create form %1.

Explanation

Programmer Response

8957

Import Error: Unable to create image %1.


10100 - 10199 Messages

10190

Unknown FAP error


10600 - 10699 Messages

10608

Report view load failure on:%n%1


11000 - 11099 Messages

11041

No printers that generate PFM files defined for selected fonts

Explanation

Programmer Response

11042

PFM file %1 already exists.%nOverwrite?

Explanation

Programmer Response

11043

Select INI file for PFM entries

Explanation

Programmer Response

11044

Load TrueType Font File

Explanation

Programmer Response

11051

Load AFP code page File

Explanation

Programmer Response

11060

Font ID %1 is already in font list.%nOverwrite?

Explanation

Programmer Response

11070

The font ID %1 already exists. Please enter another ID between 1 and 32767.

Explanation

Programmer Response

11071

The font ID %1 is invalid. Please enter another ID between 1 and 32767.

Explanation

Programmer Response

11072

%1%nError in converting font%n%2

Explanation

Programmer Response

11073

Load failure on: %1

Explanation

Programmer Response

11074

%1%nLoad failure on: %2%3%4

Explanation

Programmer Response

11075

%1%n Error in importing font: %n%2; %n

Explanation

Programmer Response

11076

%1%nLoad failure on: %2%3%4%nCaused by:%n%5

Explanation

Programmer Response

11080

Failure saving %1

Explanation

Programmer Response

11082

Failure generating %1%2%3

Explanation

Programmer Response

11096

Load Xerox metacode Font File


11100 - 11100 Messages

11100 - 11199 Messages

11102

Error: Missing USERINFO file in INI.%n


11200 - 11299 Messages

11270

Could not create window

Explanation

Programmer Response

11271

Could not set up import/export buffer

Explanation

Programmer Response

11272

%1 has not changed

Explanation

Programmer Response

11273

%1 has been changed. Do you want to save it?

Explanation

Programmer Response

11274

Cannot open %1

Explanation

Programmer Response

11275

Cannot create %1

Explanation

Programmer Response

11276

Cannot write to %1

Explanation

Programmer Response

11278

%1 is too large to be edited

Explanation

Programmer Response

11279

Cannot allocate memory buffer


14200 - 14299 Messages

14267

Invalid File Save Name

Explanation

Programmer Response

14277

Cannot give a file the same name as an open file.%nType a different name for the file you want to save.


14500 - 14599 Messages

14501

Invalid parameters passed to %1 API.

Explanation

Programmer Response

14502

Call to %1 failed. Reason: %2

Explanation

Programmer Response

14505

Error. No DAL script setting in INI file.

Explanation

Programmer Response

14506

Operation - %1 - was not successful.

Explanation

Programmer Response

14508

Caution: You are about to delete record(s) from your WIP. %nAre you sure this is what you want to do?

Explanation

Programmer Response

14509

Can not find field name for column %1. %nHint, check your AFEArchiveDisplay group in your INI.

Explanation

Programmer Response

14510

Dynamic query of one or more functions from %1 failed.

Explanation

Programmer Response

14511

Cannot logoff current user. %nPlease close all other DAP applications.

Explanation

Programmer Response

14514

Could not load DLL.


DM1000 - DM1099 Messages

DM1002

msg Cannot locate INI group, <group>, with option, option.

Explanation

The INI group, <group>, does not contain the option, option. The message, msg, contains more specific information about what process was trying to use this INI option.

Programmer Response

Examine msg and add the INI option, option, under the specified group. If option is blank, the error may be due to there being a blank line at the end of the EXTRACT file.


DM10000 - DM10099 Messages

DM10003

Error in RULStandardFieldProc(): Unable to FAPSetFieldText(,<OutBuff>,).

Explanation

Programmer Response

DM10004

Error in RULStandardFieldProc(): Unable to FAPFieldBarcode (pRPS->CurrentFapFieldH).

Explanation

Programmer Response

DM10005

Warning in RULStandardFieldProc(): Bar code FIELDFORMAT(pRPS->CurrentFapFieldH)==0. Processing will continue...

Explanation

Programmer Response

DM10007

Error in RULStandardFieldProc(): Unable to FAPUpdateBarcodeData(,<Buff>).

Explanation

Programmer Response

DM10008

Warning in RULStandardFieldProc(): Warning since field rule (fap) field:<DestField> data is blank and field rule Flag1 (required) is 'Y'. Field is required because field rule Flag1 == 'Y'. Image:<Image>.

Explanation

Programmer Response

DM10009

Error in RULStandardFieldProc(): Field rule (fap) field:<DestField> data is blank and field rule Flag2 (host required) is 'Y'. Image:<Image>

Explanation

The function, RulStandardFieldProc, found that the data for image field (xxxxx, yyyyy respectively) was blank and its 'host required flag' was set 'On'. Therefore, the transaction was assigned to the Error batch. The image and field names are specified in the Image and DestField portion of the message.

Programmer Response

Verify that the ' host required flag ' is required to being set ' On' for the image field. If so, view that extract file and determine if the data is only missing for this transaction or for all transactions.

See the online Rules Reference, Assigning Field Rules section, for information on the different types of image field rule flags.

DM10010

Warning in RULStandardFieldProc(): Field rule (fap) field:<DestField> data is blank and field rule Flag3 (operator required) is 'Y'. Image:<Image>

Explanation

The function, RulStandardFieldProc, found that the data for image field (xxxxx, yyyyy respectively) was blank and its ' OperatorRequired flag ' was set 'On'. Therefore, the transaction will be assigned to the WIP batch. The image and field name are specified in the Image and DestField portion of the message.

Programmer Response

Verify that the 'OperatorRequired flag' is required for the image field. If so, use PPS to fill in the missing data.

See the online Rules Reference, Assigning Field Rules section, for information on the different types of image field rule flags.

DM10011

Warning in RULStandardFieldProc(): Field rule (fap) field:<DestField> data is blank and field rule Flag4 (optionally required) is 'Y'. Image:<Image>

Explanation

The function, RulStandardFieldProc, found that the data for image field (xxxxx, yyyyy respectively) was blank and its ' EitherRequired flag ' was set 'On'. Therefore, the transaction will be assigned to the WIP batch. The image and field name are specified in the Image and DestField portion of the message.

Programmer Response

Verify that the ' EitherRequired flag ' is required for the image field. If so, use PPS to fill in the missing data.

See the online Rules Reference, Assigning Field Rules section, for information on the different types of image field rule flags.

DM10012

Warning in RULStandardFieldProc(): Unable to WriteNALine(,<OutBuff>,,). Image:<Image>. Processing will continue.

Explanation

Programmer Response

DM10013

Warning in RULStandardFieldProc(): Field rule (fap) field <DestField> exceeded destination length. Form: <Form> Image: <Image>. Processing will continue.

Explanation

The field rule being executed creates output that exceeded the length of the destination field. The image and field that has the problem is specified by the DestField and Image portion of the message.

Programmer Response

Increase the destination field length or decrease the output length specified in the field rule DDT.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the field rule being executed.

DM10014

Error in Globalfld(): Unable to FORMSETFIELDDDICT().

Explanation

The function, FormSetFieldDDict, returned a null pointer to the Data Dictionary which caused an error to be returned to GlobalFld.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10015

Error in Globalfld(): Unable to UTLLoadLibrary(<Field>).

Explanation

The function, UTLLoadLibrary, could not load the XDB.DFB file and returned an error to GlobalFld.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10016

Error in Globalfld(): Unable to UTLQueryProcAddr(,<Field>).

Explanation

The function, UTLQueryProcAddr, could not get the field, XDBGetDDTRec, and returned an error to GlobalFld.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10017

Warning in Globalfld(): Unable to XDBGetDDTRec(). Image <Image>, Field <Name>. Record not retrieved.

Explanation

The function, XDBGetDDTRec, could not retrieve the DDT record for the image and field specified in the <Image> and <Name>portion of the message .

Programmer Response

Verify that the XDB files exists in your DefLib subdirectory. If not, you will have to create them. See the online DocuCreate User Guide for the creation and usage of the XDB data base.

DM10018

Error in Globalfld(): Unable to RPLocateFieldRule(). Image <Image>, Field <Name>.

Explanation

The function, RPLocateFieldRule, could not locate the rule (xxxxx) for image (yyyyy) and returned an error to GlobalFld. The rule and image name are specified in the Name and Image portion of the message.

Programmer Response

The rule specified in the XDB.DFB file is spelled incorrectly, use the DAP Dictionary Editor to update the rule for the field. If the rule is a custom rule, check the path that points to the executables modules.

DM10019

Error in Globalfld(): Unable to <Name>(). Image <Image>.

Explanation

The rule defined in the XDB.DFB file for the image specified in the Image portion of the message does not have any rule parameters defined.

Programmer Response

Use the DAP Dictionary Editor to add mask and data field parameters to the rule for the field that has the problem.

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10520: Error in <MOVE_IT>: Empty RuleParms in fmt (GENGetRecord).

DM10019: Error in Globalfld(): Unable to <MOVE_IT>(). Image <q1addr>.

See the online Rules Reference for the correct format of the mask and data field parameters for the rule.

DM10020

Error in Globalfld(): Unable to FAPDDictAdd(). Image<Image>, Field rule (fap) field <Field>. <Buff>

Explanation

The function, FAPDDictAdd, could not a record to the Data Dictionary and returned an error message to GlobalFld.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10021

Error in Dictionary(): Unable to UTLQueryProcAddr(,<Field>).

Explanation

Programmer Response

DM10022

Error in Dictionary(): Unable to XDBTermXDB(). <Buff>

Explanation

The function, XDBTerm, could not delete the XDB dictionary file during termination of the GENData execution step and returned an error to Dictionary.

Programmer Response

  1. If you did not use the GlobalFld rule anywhere in your Master Source Library (MRL), then delete the Dictionary rule from the AFGJOB.JDT.
  2. If you did use the GlobalFld rule in your MRL, re-execute the GENData step. If the error re-occurs, please save your MRL and contact DocuCorp Support Services.

DM10023

Error in justfld() : MODE token not found in data parameter.

Explanation

The Mode parameter for the JustFld rule is missing. Mode is a required parameter for the JustFld rule.

Programmer Response

See the online Rules Reference for the correct format of the Mask and Data field parameters for the JustFld rule.

DM10024

Error in justfld() : Token specified without data parameter.

Explanation

One of the JustFld rule parameters or sub parameters are missing information.

Programmer Response

See the online Rules Reference for the correct format of the Mask and Data field parameters and sub parameters for the JustFld rule.

DM10025

Error in RULStandardFieldProc(): Unable to RULUpdateFieldText(,<OutBuff>,).

Explanation

Programmer Response

DM10026

Warning in RULUpdateFieldText(): Unable to FMTValBarcode(<OutBuff>,<Buff>,<Format>) returned FmtErr. Processing will continue...

Explanation

Programmer Response

DM10027

Error in Globalfld(): Globalfld is defined in XDB.DBF. Check with Dictionary Editor.

Explanation

You have specified the GlobalFld rule to be executed for the field in the XDB.DBF file . This rule is not valid in the XDB.DBF.

Programmer Response

Use the DAP Dictionary Editor to update the rule for the field.

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10027: Error in Globalfld(): Globalfld is defined in XDB.DBF. Check with Dictionary Editor.

DM12051: Error in RPProcessOneField(): Unable to <GLOBALFLD>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <Addr1>.

Processing will NOT continue for image <q1addr>.

See INI group:< GenDataStopOn > option: FieldErrors.

DM10028

Error in UnderlineField(): Unable to GENLoadGlobalFonts(pRPS).

Explanation

Programmer Response

DM10029

Warning Field <Field> was not found in the master.ddt.

Explanation

The field the specified in the < Field >( ) portion of the message could not be found in the Master.DDT

Programmer Response

Add the field the specified in the < Field >( ) portion of the message to the Master.DDT or to the image DDT.

DM10030

Warning Field <Field> uses master.ddt but master.ddt was not loaded.

Explanation

The field specified in the message uses the master.ddt which has not been loaded.

Programmer Response

Verify that the:

1. command ;LoadDDTDefs;1;; exists in your AFGJob.JDT, if not, add it.

2. AFGJOB name in the INI group < Data > matches the one stored in

subdirectory.

DM10035

DM10035 Warning in PaginationSplit(): The first image <UK160252> defined to the page does not fit on the page.

Explanation

The "DM10035 Warning in PaginationSplit()" appears to occur as a result of calling the PaginateAndPropagate rule.

When an image is a custom size, the PaginationSplit code determines the page size by looking at the form that the image belongs to (this is also what our print drivers do).

If the form's page size was set to Letter, then the 12x9 image would not fit on the page.

The only page sizes we support currently are Letter (8.5x11), Legal (8.5x14), A4(8.26x11.69), and Executive (7.25x10.5). None of these are big enough to hold a 12x9 custom size image.

We are adding additional paper sizes in release 11.0.

Although 12 x 9 is not one of the new paper sizes Docucorp will support, there will be paper sizes large enough to hold a 12 x 9 image.

Programmer Response

DM10040

Error in RULServerJobProc(): IDS server not running or IDS RPDCheckRPRun rule not started.

Explanation

Generally, Documaker RP uses the AFGJOB.JDT rule: RULStandardJobProc(): for its processes.

To have Docupresentment (IDS) run the Documaker RP Rules processor programs, you must substitute the RULServerJobProc(): rule for the RULStandardJobProc(): rule.

Tip 1:

If you attempt to run Documaker RP by itself or without starting the IDS server to run RP; you will receive error DM10040 when using RULServerJobProc() instead of RULStandardJobProc():

Tip 2:

You may have started the IDS server to run Documaker RP but your INI configuration is not correct. In this case you will receive error DM10040. For example the RPDCheckRPRun rule must be defined in the docserv.ini file.

Tip 3:

Windows 32 bit implementation for IDS and RP:

If your IDS server is running, and your AFGJOB.JDT file option is set to use the RULServerJobProc() rule, and you docserv.ini file is properly configured to use the RPDCheckRPRun rule; then please refer to the IDS SDK manual for trouble shooting tips for error RPD0007 .

Tip 4:

Unix implementation for IDS and RP:

If your IDS server is running, and your AFGJOB.JDT file option is set to use the RULServerJobProc() rule, and you docserv.ini file is properly configured to use the RPDCheckRPRun rule; ensure the rpdrunrp file has been erased. On a Unix system this file is the physical representation of the semaphore in memory. This file is used by RP to know that IDS will be running a job. Also remove the srvcache files if they exist. Then please refer to the IDS SDK manual for trouble shooting tips for error RPD0007 .

Programmer Response

DM10063

DM10063: Error (or Warning): No eligible DDT file for:<CO;LOB;Form name>. Image<image name>.

Rule<RULStandardImageProc>.

Explanation

This error appears when you are not using Library Manager and the DDT file cannot be found. If the ErrorOnMissingFile option is set to No, this message is a warning.

Programmer Response

This message appears when you are not using Library Manager and the DDT file was not found in DDTLib or DEFLib.

DM10086

DM10086: Warning: DDT file found but not effective for:<CO;LOB;Form name>. Image<image name>.

Rule<RULStandardImageProc>.

Explanation

This warning appears when you use Library Manager with stringent checking and the WarnOnMissingFile option is set to Yes. The warning tells you a DDT file was found, but it is not yet effective.

Programmer Response

This warning is generated when the file is found in Library Manager but it is not yet effective, and stringent checking is being used.

DM10087

DM10087: Warning: DDT file found but expired for:<CO;LOB;Form name>. Image<image name>. Rule<RULStandardImageProc>.

Explanation

This warning appears when you use Library Manager with stringent checking and the WarnOnMissingFile option is set to Yes. The warning tells you a DDT file was found, but it has expired.

Programmer Response

This warning is generated when the file is found in Library Manager but it is expired, and stringent checking is being used.

DM10088

DM10088: Error (or Warning): DDT file not found in version control for:<CO;LOB;Form name>. Image<image

name>. Rule<RULStandardImageProc>.

Explanation

This error appears when you use Library Manager with stringent checking and no version of the file is found in the library. If the ErrorOnMissingFile option is set to No, this message is a warning.

Programmer Response

This message appears when you are not using Library Manager and the DDT file was not found in DDTLib or DEFLib.

DM10089

DM10089: Error (or Warning): DDT file not found by original loader for:<CO;LOB;Form name>. Image<image

name>. Rule<RULStandardImageProc>.

Explanation

This error appears when you use Library Manager without stringent checking and no version of the file is found in the library or on disk. If the ErrorOnMissingFile option is set to No, this message is a warning.

Programmer Response

This message appears when no versions of the file are found in Library Manager and stringent checking is not in effect.


DM10100 - DM10199 Messages

DM10100

Error in RestartJob(): Unable to GENRestartTrn(pRPS).

Explanation

The function, GENRestartTrn, encountered a problem and returned an error to RestartJob.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10127: Error in GENRestartTrn(): Unable to DBOpen(NewTrnFileH,'w').

DM10100: Error in RestartJob(): Unable to GENRestartTrn(pRPS).

DM10101

Error in RestartJob(): Unable to GenGetTrnFileH(pRPS).

Explanation

The function, GenGetTrnFileH, could not find the pointer to the TrnFile file and returned an error to RestartJob.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10102

Error in RestartJob(): Unable to GenGetNewTrnFileH(pRPS).

Explanation

The function, GenGetTrnFileH, could not find the pointer to the NewTrn file and returned an error to RestartJob.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10103

Error in RestartJob(): Unable to INIGetInitValue(<Data>,<RcbDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, RCBDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10104

Error in RestartJob(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10105

Error in RestartJob(): Unable to DBInitDB().

Explanation

The function, DBInitDB, encountered a problem and returned an error to RestartJob.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10106

Error in RestartJob(): Unable to RCBInit(<AbsFName>, AsciiDBHandlerH).

Explanation

The function, RCBInit, could not locate/initialize the file, xxxxx, and returned an error to RestartJob. The file, xxxxx, is specified in the <AbsFName> portion of the message.

Programmer Response

Verify that the file exists in the specified subdirectory. If the file exists in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

DM10107

Error in RestartJob(): Unable to INIGetInitValue(<Data>,<NaFile>,,).

Explanation

The INI Group, < Data >, and the Option, NAFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10108

Error in RestartJob(): Unable to fopen(<NAFile>,'w').

Explanation

The fopen function could not open in write mode the NAFile file.

Programmer Response

Verify that the file exists in the specified subdirectory. If the file exists in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10109

Error in RestartJob(): Unable to INIGetInitValue(<Data>,<PolFile>,,).

Explanation

The INI Group, < Data >, and the Option, POLFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10110

Error in RestartJob(): Unable to fopen(<POLFile>,'w').

Explanation

The fopen function could not open the POLFile file in write mode..

Programmer Response

Verify that the file exists in the specified subdirectory. If the file exists in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10111

Error in RestartJob(): Unable to RCBReOpenPrintBatchFiles(pRPS).

Explanation

The function, RCBReOpenPrintBatchFiles, encountered a problem and returned an error to RestartJob.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<Cannot open file.

Permission denied>, code:<13>, code:<13>, msg<.\Batch\RegBat>.

DM10135: Error in RCBRestartBatch(): Unable to DBopen(RCBFileH, ) for write.

DM10141: Error in RCBOpenPrintBatchFiles(): Unable to VMMAppendElem().

DM10111: Error in RestartJob(): Unable to RCBReOpenPrintBatchFiles(pRPS).

DM10112

Error in RestartJob(): Unable to RCBGetPrintBatchHdl().

Explanation

The function, RCBGetPrintBatchHdl, encountered a problem and returned an error to RestartJob.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10113

Error in RestartJob(): Unable to remove <RSTFile>.

Explanation

The file, RstFile, could not be deleted which caused RestartJob to output this message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10114

Error in RULCheckTransaction(): Unable to fopen(<RSTFile)>,'w').

Explanation

The fopen function could not open the RSTFile file in write mode.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10115

Error in RULCheckTransaction(): GenGetTrnFileH(pRPS).

Explanation

The function, GenGetTrnFileH, could not find a pointer to the TrnFile file and returned an error to RULCheckTransaction.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10116

Error in RULCheckTransaction(): GenGetNewTrnFileH(pRPS).

Explanation

The function, GenGetNewTrnFileH, could not find a pointer to the NewTrn file and returned an error to RULCheckTrnsaction.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10117

Error in RULCheckTransaction(): Unable to RCBGetPrintBatchHdl().

Explanation

The function, RCBGetPrintBatchHdl, could not find a pointer to the PrintBatch file and returned an error to RULCheckTrnsaction.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10118

Error in GENRestartTrn(): Unable to DBInitDB().

Explanation

The function, DBInitDB, encountered a problem and returned an error to GENRestartTrn.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10119

Error in GENRestartTrn(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10120

Error in GENRestartTrn(): Unable to INIGetInitValue(<Data>,<TrnDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, TrnDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10121

Error in GENRestartTrn(): Unable to DBQueryFormatInfo(<File>).

Explanation

The function, DBQueryFormatInfo, encountered a problem with the file, xxxxx, and returned an error to GENRestartTrn. The file, xxxxx, is specified in the <File> portion of the message.

Programmer Response

Verify that the file exists in the specified subdirectory. If the file exists, then verify that the file name matches the one in the subdirectory and the name specified in the INI group < Data >.

DM10122

Error in GENRestartTrn(): Unable to MakeGvmVarsForDfd(pRPS,AsciiTrnDfdFileH).

Explanation

The function, MakeGvmVarsForDfd, could not create global variables for the TrnFile DFD and returned an error to GENRestartTrn.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10123

Warning in GENRestartTrn(): Unable to INIGetInitValue(<Data>,<DataPath>,,).

Explanation

The INI Group, < Data >, and the Option, DataPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10124

Error in GENRestartTrn(): Unable to INIGetInitValue(<Data>,<NewTrn>,,).

Explanation

The INI Group, < Data >, and the Option, NewTrn, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10125

Error in GENRestartTrn(): Unable to DBInitializeFile(ASCII,<Buff>,AsciiTrnDfdFileH).

Explanation

The function, DBInitializeFile, encountered a problem trying to initialize the file, xxxxx, and returned an error to GENRestartTrn. The file, xxxxx, is specified in the Buff portion of the error message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10126

Error in GENRestartTrn(): Unable to DBAllocateStructMemory().

Explanation

The function, DBAllocateStructMemory, encountered a problem trying to allocate memory and returned an error to GENRestartTrn.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10127

Error in GENRestartTrn(): Unable to DBOpen(NewTrnFileH,'w').

Explanation

The function, DBOpen, could not open the NewTrn file and returned an error to GENRestartTrn.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

DM10128

Error in GENRestartTrn(): Alternate function failed to allocate TrnBuffer

Explanation

A problem was encountered trying to allocate memory for TrnBuffer which caused this error message to occur.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10129

Error in GENRestartTrn(): Unable to INIGetInitValue(<Data>,<TrnFile>,,).

Explanation

The INI Group, < Data >, and the Option, TrnFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10130

Error in GENRestartTrn(): Unable to DBInitializeFile(ASCII,<File>,).

Explanation

The function, DBInitializedFile, could not initialize the file xxxxx and returned an error to GENRestartTrn. The file, xxxxx, is specified in the <File> portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10131

Error in GENRestartTrn(): Unable to DBAllocateStructMemory(AsciiTrnDfdFileH,TrnBufferSize).

Explanation

The function, DBAllocateStructMemory, could not allocate memory and returned an error to GENRestartTrn.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10132

Error in GENRestartTrn(): Unable to DBOpen(TrnFileH,'r').

Explanation

The function, DBOpen, could not open for read mode the TrnFile file and returned an error to GENRestartTrn.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10133

Error in RCBRestartBatch(): NULL pointer passed to RCBInitBatch.

Explanation

A null pointer was passed to the function, RCBInitBatch, which returned an error to RCBRestartBatch.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10134

Error in RCBRestartBatch(): Unable to to DBInitializeFile(ASCII,<Name>,,).

Explanation

The function, DBInitializeFile, could not initialize the file, xxxxx, and returned an error to RCBRestartBatch. The file, xxxxx, is specified in the <Name> portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10135

Error in RCBRestartBatch(): Unable to DBopen(RCBFileH, ) for write.

Explanation

The function, DBopen, could not open for write mode the print batch file and returned an error to RCBRestartBatch.

Programmer Response

Verify that the file exists in the expected subdirectory. If not, you must re-run the GENData step.

Also verify that the files' attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10136

Error in RCBReOpenPrintBatchFiles(): AliasPrintBatches specified, but ini option < Data > < BatchTable > not found.

Explanation

Programmer Response

DM10137

Error in RCBReOpenPrintBatchFiles(): Unable to RCBInitBatch(Buff,MODE_WRITE).

Explanation

The function, RCBInitBatch, could not initialize for write mode the file, xxxxx, and returned an error to RCBReOpenPrintBatchFiles. The file, xxxxx, is specified in the Buff portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10138

Error in RCBOpenPrintBatchFiles(): Unable to RCBRestartBatch().

Explanation

The function, RCBRestartBatch, can not append new data to the VMM element list and returned an error to RCBReOpenPrintBatchFiles.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10139

Error in RCBOpenPrintBatchFiles(): Unable to INIFirstInitValue(Print_Batches,NULL,,).

Explanation

The function, INIFirstInitValue, could not find any INI options in the INI group < Print_Batches > and returned an error to RCBReOpenPrintBatchFiles.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10140

Error in RCBOpenPrintBatchFiles(): Unable to INIGetInitValue(<Print_Batches>,<Buff>,,).

Explanation

The INI Group, < Print_Batches >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10141

Error in RCBOpenPrintBatchFiles(): Unable to VMMAppendElem(,,).

Explanation

The function, VMMAppendElem, encountered a problem trying to append an element and returned an error to RCBOpenPrintBatchFiles.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<Cannot open file.

Permission denied>, code:<13>, code:<13>, msg<.\Batch\RegBat>.

DM10135: Error in RCBRestartBatch(): Unable to DBopen(RCBFileH, ) for write.

DM10141: Error in RCBOpenPrintBatchFiles(): Unable to VMMAppendElem().

Also verify that the INI group < Print_Batches > exists in the INI files.

DM10142

Warning Fap Field Missing <Field>.

Explanation

Programmer Response

DM10143

Warning Unable to create GVMField <Field>.

Explanation

Programmer Response

DM10144

Warning FapField data corrupt <Field.>

Explanation

Programmer Response

DM10145

Error in RULCreateGUID(). This rule is not supported for the platform you are using. Supported platforms include platforms.

Explanation

Programmer Response

DM10146

Error in RULCreateGUID(): Syntax error in rule parameters. Rule parameters should include two comma delimited field names.

Explanation

Programmer Response

DM10147

Error in RULCreateGUID(): Field FIELD is not a present in the TRNDFDFL.DFD or in RCBDFDFL.DFD file.

Explanation

Programmer Response

DM10148

Error in RULCreateGUID(): Field FIELD is not correct type or not correct length in the TRNDFDFL.DFD or in RCBDFDFL.DFD file. Internal type should be CHAR_ARRAY and length should be at least 32

Explanation

Programmer Response

DM10149

Error in RULCreateGUID(): API call to API failed.

Explanation

Programmer Response

DM10150

Error in SetAddr3(): Invalid RuleParms for SetAddr3:<Parms>. Data field requires 2 items (Key,FParm).

Explanation

The SetAddr3 rule has an invalid set of parameters in the DDT data field. The existing parameters are specified in the Parms field portion of the message. The DDT data field requires two items; search key and paired-address elements.

Programmer Response

See the online Rules Reference for the correct format of the Mask and Data field parameters for the SetAddr3 rule.

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10150: Error in SetAddr3(): Invalid RuleParms for SetAddr3:

<11,INSADRREC>. Data field requires 2 items (Key,FParm).

DM12051: Error in RPProcessOneField(): Unable to <SETADDR3>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField

(pRPS) <FIELD1>. Processing will NOT continue for image <q1addr>.

See INI group: < GenDataStopOn > option: FieldErrors.

DM10151

Error in SetAddr3(): Unable to compressln().

Explanation

The function, compressin, failed trying to compress the spaces in a line and returned an error to SetAddr.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services

DM10152

Error in MapFromImportData (noopimp) Image image field field: INDEX option specified incorrectly. Found <option>. Format is INDEX(option) where option is Form, Img, ImgFSet, Fld, FldSet, or a contant number.

Explanation

The Index option for the rule MapFromImportData is specified incorrectly. See the error message fields, image and option respectively, for the index option currently specified in the rule and image name that has the problem.

Programmer Response

Valid index options for the rule MapFromImportData are as follows.

  • Form
  • Img
  • ImgFSet
  • Fld
  • FldSet
  • Form+Img
  • Form+Fld
  • constant number.

See the online Rules Reference for the correct format of the parameters for the MapFromImportData rule.

DM10153

Error in MapFromImportData (noopimp) Image image field field: Unknown INDEX option <option> specified. Format is INDEX(option) where option is FORM, IMG, IMGFSET, FLD, FLDSET, or a contant number.

Explanation

The Index option for the rule MapFromImportData contains an invalid keyword. See the error message fields, image and option respectively, for the index option currently specified in the rule and image name that has the problem.

Programmer Response

Valid index options for the rule MapFromImportData are as follows.

  • Form
  • Img
  • ImgFSet
  • Fld
  • FldSet
  • Form+Img
  • Form+Fld
  • constant number.

See the online Rules Reference for the correct format of the parameters for the MapFromImportData rule.

DM10154

Error in MapFromImportData (noopimp) Image image field field: INDEX option <option> is specified more than once or conflicts with another token. Valid combinations are FORM+IMG,FORM+FLD.

Explanation

The Index option for the rule MapFromImportData is specified more than once or conflicts with another token. See the error message fields, image and option respectively, for the index option currently specified in the rule and image name that has the problem.

Programmer Response

Valid index options for the rule MapFromImportData are as follows.

  • Form
  • Img
  • ImgFSet
  • Fld
  • FldSet
  • Form+Img
  • Form+Fld
  • constant number.

See the online Rules Reference for the correct format of the parameters for the MapFromImportData rule.

DM10155

Error in MapFromImportData (noopimp) Image image field field: Calculated INDEX value <value> cannot be converted to a dictionary instance.

Explanation

Programmer Response

DM10156

Error in <&Rule&>: Empty Rules Parameters. Image: <&Image&>

Explanation

This message is generated in RULSpanAndFill and RULConcatField if the parameters supplied to the rule are empty.

Programmer Response

DM10157

Error in <&Rule&>: <&Field&> is an invalid field. Image: <&Image&>

Explanation

This message is returned from a rule when a field supplied as a parameter to that rule can not be located.

Programmer Response

DM10158

Warning: Too Many Rule Parameters in <&Rule&>. Image: <&Image&>

Explanation

This warning message is returned from RULSpanAndFill when too many parameters are supplied. The rule continues, ignoring the extra parameters.

Programmer Response

DM10159

Error in <&Rule&>: Not Enough Rule Parameters. Image: <&Image&>

Explanation

This error message is returned when not all of the required parameters for a given rule are supplied in the rule parameters.

Programmer Response

DM10160

Error in <&Rule&>: Fields must be different. Image: <&Image&>

Explanation

This message is returned when 2 or more of the fields supplied to RULSpanAndFill are the same field.

Programmer Response

DM10161

Error in <&Rule&>: FAPSpanField Failed with an unspecified error. Image: <&Image&>

Explanation

This message is returned by RULSpanAndFill when FAPSpanAndFill has aborted abnormally.

Programmer Response

DM10162

Error in <&Rule&>: Check rule parameters. A fixed field parameter must be delcared prior to any movement ones. Image: <&Image&> Parameters: <&Parms&>

Explanation

This message is returned from RULConcatField when the first field supplied in the rule parameters is not the fixed field.

Programmer Response

DM10163

Error in <&Rule&>: FAPConcatField Failed with an unspecified error. Image: <&Image&>

Explanation

This message is returned from RULConcatFields when FAPConcatField aborts abnormally.

Programmer Response

DM10164

Error in <Func>(): Unable to GENRestartTrn(pRPS).\n

Explanation

Programmer Response

DM10165

Error in <Func>(): Unable to GenGetTrnFileH(pRPS).\n

Explanation

Programmer Response

DM10166

Error in <Func>(): Unable to GenGetNewTrnFileH(pRPS).\n

Explanation

Programmer Response

DM10167

Error in <Func>(): Unable to INIGetInitValue(<Data>,<RcbDfdFile>,,).\n

Explanation

Programmer Response

DM10168

Error in <Func>(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).\n

Explanation

Programmer Response

DM10169

Error in <Func>(): Unable to DBInitDB().\n

Explanation

Programmer Response

DM10170

Error in <Func>(): Unable to RCBInit(<AbsFName>, AsciiDBHandlerH).\n

Explanation

Programmer Response

DM10171

Error in <Func>(): Unable to INIGetInitValue(<Group>,<Option>,,).\n

Explanation

Programmer Response

DM10172

Error in <Func>(): Unable to fopen(<NAFile>,'w').\n

Explanation

Programmer Response

DM10173

Error in <Func>(): Unable to INIGetInitValue(<Data>,<PolFile>,,).\n

Explanation

Programmer Response

DM10174

Error in <Func>(): Unable to fopen(<POLFile>,'w').\n

Explanation

Programmer Response

DM10175

Error in <Func>(): Unable to RCBReOpenPrintBatchFiles(pRPS).\n

Explanation

Programmer Response

DM10176

Error in <Func>(): Unable to RCBGetPrintBatchHdl().\n

Explanation

Programmer Response

DM10177

Error in <Func>(): Unable to <UTLLibFunc>(WIPOS2).\n

DM10177: Error in <MergeWIP>(): Unable to <UTLLoadLibrary>(WIPOS2).

Explanation

Troubleshooting: Does WIPW32.DLL exist? Is it possible that it was accidentally deleted?

Programmer Response

WIPW32.DLL was not found. Re-installing the application may fix this problem.

DM10178

Error in <Func>(): Unable to find function <WIPFunc>.\n

Explanation

Programmer Response

DM10179

Error in <Func>(): Unable to create WIP list.\n

Explanation

Programmer Response

DM10180

Error in <Func>(): Unable to get WIP list.\n

Explanation

Programmer Response

DM10181

Error in <Func>(): Unable to <function>.\n

Explanation

Programmer Response

DM10182

Error in RULWIPTransactions(): Unable to SetOffsets(pRPS).\n

Explanation

Programmer Response

DM10190

;RemoveWhiteSpace;PAGE1_FIELD, PAGE1_FIELD2, PAGE1_FIELD3,FAGE1_Field4/NoWarning;

Explanation

Programmer Response

You can use theNoWarning paragmeter with the RemoveWhiteSpace rule to limit error messages. Previously, if the system could not loacate the field listed for RemoveWhiteSpace rule, you got an error message. The system now issues a warning.


DM10200 - DM10299 Messages

DM10200

Msg: Box<Parm1>. Image<image> Parms<parms>

Explanation

Programmer Response

DM10201

Error: Image <image> does not contain a box.

Explanation

Programmer Response

DM10202

Error in Name: Unable to find box for Box option.

Explanation

The function, GroupEnd, did not find a box in the image being processed.

Programmer Response

A box must exists in the image which have the GroupBegin;Box rule defined in the < Image Rules > group.

See the online Rules Reference for the correct format of the parameters for the GroupBegin;Box rule.

DM10203

Error in Name: Image <image> does not support nested columns.

Explanation

Programmer Response

DM10204

Error in Name: Image <image> has invalid PARAMETER BALANCED(),COLCOUNT(??),COLWIDTH(??),COLSEPARATION(??)

Explanation

Programmer Response

DM10205

Error in Name: Image <image> is missing number of columns for ColCount(??).

Explanation

Programmer Response

DM10206

Error in Name: Image <image> is missing dimension for ColWidth(??).

Explanation

Programmer Response

DM10207

Error in Name: Image <image> is missing amount of separation for ColSeparation(??).

Explanation

Programmer Response

DM10208

Error in Name: Image <image> has invalid PARAMETER--COLCOUNT(??)

Explanation

Programmer Response

DM10209

Warning: Images have GroupBegin without GroupEnd; Parm elements still in stack

Explanation

There are xxxxx GroupBegin rules that do not have a corresponding GroupEnd rules within the same transaction. There are xxxxx elements still on the stack that have not been processed. The number, xxxxx, is specified in the Parm portion of the message.

Programmer Response

Verify that all GroupBegin rules have corresponding GroupEnd rules triggered for the transaction.

DM10210

Error in LoadRcpTbl(): Unable to LoadCachedTable

Explanation

The function, LoadCachedTable, could not load the cached SetRcpTb.dat table and returned an error to LoadRcpTbl.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10211

Error in LoadRcpTbl(): pRPS->RecipientListH == VMMNULLHANDLE.

Explanation

The function, LoadRcpTbl, had a null pointer to Recipient List for the current GroupName1 and GroupName2 being processed and returned an error to LoadRcpTbl.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10212

Error in LoadRcpTbl(): Unable to VMMAppendElem(,,).

Explanation

The function, VMMAppendElem, could not append a recipient data element to the recipient list for the current GroupName1 and GroupName2 being processed and returned an error to LoadRcpTbl.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10213

Error in Name: Unable to find INI value MasterResource, TablePath.

Explanation

The function, RulLoadTables, could not find the INI option, TablePath in the INI control group, < MasterResource >.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference.

DM10214

Error in Name: Unable To INIGetValueByHandle <value>.

Explanation

The function, INIGetValueByHandle, could not obtain the INI option value for the INI option name specified in the value portion of the message in the INI control group, < Look_Up Tables >.

Programmer Response

Verify that the INI options for the INI control group, Look_Up Tables, are defined correctly. For more information on INI Options, refer to the online INI Reference Guide.

DM10215

Error in Name: Unable to VMMAppendElem(listH, <value>,).

Explanation

The function, VMMAppendElem, could not append a record from the table to the linked list and returned an error to RulLoadTables. The record data to be appended is specified in the value portion of the message. The record is from a table specified in an INI option in the INI control group, < Look_Up >.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10216

Error in Name: Unable to create a GVM variable named <var>. It must already exist for some reason.

Explanation

The function, GVMCreateVariable, could not create a GVM named variable. The variable name is specified in the var portion of the message. The GVM variable name already exists. The GVM variable name trying to be created is define in an INI option in the INI control group, < Look_Up Tables >.

Programmer Response

Scan your FSISYS.INI, FSIUser.INI, and AFGJOB.JDT for the GVM variable name. Change one of the GVM variable names to something else.

DM10217

Error in Name: Unable to add data to a GVM variable named <var>.

Explanation

The function, GVMCreateData, could not add data to the GVM named variable specified in the var portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10218

Error in Name: Unable to get data from GVM variable named <var>.

Explanation

The function, GVMGetDataPtr, could not obtain data from the GVM named variable specified in the var portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10219

Error in Name: Unable to destroy list for table <var>.

Explanation

The function, VMMDestroyList, could not destroy the linked list for the table specified in the var portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10220

Error in Name: Invalid queue name: <parms>

Explanation

Programmer Response

DM10221

Warning in Name: Unable to get element from QueueNode list.

Explanation

Programmer Response

DM10222

Warning in Name: Unable to process function func

Explanation

Programmer Response

DM10223

Error in Name(): Unable to create VMM batch list.

Explanation

Programmer Response

DM10224

Error in Name(): Unable to append VMM batch list.

Explanation

Programmer Response

DM10225

Warning in Name: Invalid INI parameter <group> key = value

Explanation

Programmer Response

DM10226

Error in Name(): Unable to get element from Batch_Recip list.

Explanation

Programmer Response

DM10227

Error in Name: \tUnable to create batch-recipient list hBatchList.

Explanation

Programmer Response

DM10228

Error: Unable to add base rule to "BaseFormsetRulesH".

Explanation

Programmer Response

DM10229

Error in Name()...BuildBatchName(): Literal with unbalanced quotes. <text>

Explanation

Programmer Response

DM10230

Error in CreateBatchName(): Invalid parameter. Expected a '(' after 'Dict'.

Explanation

Programmer Response

DM10231

Error in Name()...BuildBatchName(): Invalid Search_Mask DataOffset,DataLen segment. <value>

Explanation

Programmer Response

DM10232

Error: The print batch Name is not defined. Name should be listed under < PRINT_BATCHES > defining the output batch file.

Explanation

Programmer Response

DM10233

Error in BuildExcludeList: Unable to VMMCreateList() for ExcludeListH.

Explanation

Programmer Response

DM10234

Error in BuildExcludeList: Unable to INIGetInitValue(<group>, <key>,,).

Explanation

The INI Group, < xxxxx >, and the Option, yyyyy, could not be found in the INI file. The group xxxxx and option yyyyy are specified in the group and key portion of the message

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10235

Error in RULNestedOverflowProc(): Unable to ulOverFlow().

Explanation

Programmer Response

DM10236

Error in ulOverFlow(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10237

Error in ulOverFlow(): Unable to INIGetDefInitValue(<Data>,<OverflowFile>,,,).

Explanation

Programmer Response

DM10238

Error in ulOverflow(): Unable to ulLoadOverFlowList.

Explanation

Programmer Response

DM10239

Error in ulLoadOverFlowList(): NULL Overflow file name passed in.

Explanation

Programmer Response

DM10240

Error in ulLoadOverFlowList(): Unable to open OverFlow file <file>.

Explanation

Programmer Response

DM10241

*** Redirected for ERROR handling ***

*** Review error file for reasons ***

Explanation

This LogFile message indicates that during GENData processing a field was found with blank data and its ' Host ' flag was set 'on'. This caused the transaction to be assigned (redirected) to the Error batch

Programmer Response

Search in the ErrFile file for the transaction ID from the LogFile message (DM11190). After finding the transaction ID in the ErrFile; start at error message DM13025 for the transaction and follow the message chain up to locate a message that describes the error in more detail.

Example: LogFile messages

*** Redirected for ERROR handling ***

*** Review error file for reasons ***

--> Processing: CH34567-SAM-LB1--T1 (message DM11190)

Example: ErrFile messages

Transaction: CH34567

Symbol: SCO

Module: M1

State: GA

Company Name (after ini conversion): SAM

Line of Business (after ini conversion): LB1

Trans Type: T1

Run Date: 9950315

----------------------------------

DM10009: Error in RULStandardFieldProc(): Field rule (fap) field:<Town and State>

data is blank and field rule Flag2 (host required) is 'Y'. Image:<QMDCFL>

DM13025: Warning in RCBSendToErrBatch(): Transaction is being assigned to the Error

batch.

DM10242

*** Redirected for MANUAL handling *** *** Review WIP Status ***

Explanation

This LogFile message indicates that during GENData processing a field was found with blank data and its ' OperatorRequired or EitherRequired ' flag was set 'on'. This caused the transaction to be assigned (redirected) to the WIP batch

Programmer Response

Search in the ErrFile file for the transaction ID from the LogFile message (DM11190). After finding the transaction ID in the ErrFile; start at warning message DM13027 for the transaction and follow the message chain up to locate a message that describes the warning in more detail.

Example: LogFile messages

*** Redirected for MANUAL handling ***

*** Review WIP status ***

--> Processing: MO34567-SAM-LB1--T1 (message DM11190)

Example: ErrFile messages

Transaction: MOCH34567

Symbol: SCO

Module: M1

State: GA

Company Name (after ini conversion): SAM

Line of Business (after ini conversion): LB1

Trans Type: T1

Run Date: 9950315

----------------------------------

DM10010: Warning in RULStandardFieldProc(): Field rule (fap) field:<FORM LINE2>

data is blank and field rule Flag3 (operator required) is 'Y'. Image:<QMDC3>

DM13027: Warning in RCBSendToManualBatch(): Transaction is being assigned to the

Manual batch.

DM10243

****** Transaction TranID has been skipped.

Explanation

Programmer Response

DM10244

Lead-List-Follow Nested Overflow Method is being used

Explanation

Programmer Response

DM10245

Num images inserted

Explanation

Programmer Response

DM10246

Lead-List-Follow Nested Overflow Method has completed successfully

Explanation

Programmer Response

DM10247

OverFlow file file loaded

Explanation

Programmer Response

DM10248

Error in FOLLOW image info on line line. (FOLLOW image info will be ignored) format: format

Explanation

Programmer Response

DM10249

error in line line of OverFlow file (line will be ignored) line=Parm1 format: format

Explanation

Programmer Response

DM10250

Error in Rule: Invalid date:<Date>.

Explanation

Programmer Response

DM10251

Warning in Name: Image<image> Field<DestFieldName> The defined field offset is less than 0 and will not return data.

Explanation

Programmer Response

DM10252

Warning in Name: Image<image> Field<DestFieldName> The defined field offset is 0. Offset 1 will be used.

Explanation

The field offset value is zero or not present for the rule in the image for the field specified in the message.

Programmer Response

Set the field offset value to ' 1 ' for the rule in the image for the field specified in the message.

Example:

DM10252: Warning in MOVE_IT: Image<q1addr> Field<SEND COPY TO:> The defined field

offset is 0. Offset 1 will be used.

Existing DDT for the field 'SEND COPY TO'.

;0;1;SEND COPY TO:;0;1;SEND COPY TO:;0;15;;move_it;11,HEADERREC;N;N;N;N;;;;

Change it to the following using the Image Editor Edit DDT properties tab

for the field.

;0;1;SEND COPY TO:;1;1;SEND COPY TO:;0;15;;move_it;11,HEADERREC;N;N;N;N;;;;

DM10253

Warning in Name: Image<image> Field<DestFieldName> The defined field length is less than 1 and will return not data.

Explanation

Programmer Response

DM10254

Error in MessageFromExtr(): Field<Field> on Image<image> is not a Multiline text variable field.

Explanation

Programmer Response

DM10255

Warning: Warning in RULPaginateGroup: unable to RULGetGroupEnd(). Standard pagination will be used.

Explanation

The RulPaginateGroup function could not execute for some reason, so standard pagination will be used.

Programmer Response

Verify if you are using the ResetImageDimensions rule, if so, verify that the parameters are correctly defined.

See the onlineRules Reference for the correct format of the parameters for the ResetImageDimensions rule.

DM10256

Error in AppendGblToExtr(): Unable to VMMMalloc() for extract file buffer.

Explanation

Programmer Response

DM10257

Error in AppendGblToExtr(): Inconsistent type for global variable <GLBVar>.

Explanation

Programmer Response

DM10258

Error in AppendGblToExtr(): Global variable <GLBVar> exceeds maximum length. Check MaxExtRecLen in INI group <TRN_FILE>.

Explanation

Programmer Response

DM10259

Error: Error in RULImportFile(): ImportFile() failed for file <ImpFile>.

Explanation

The function, ImportFile, could not import/read the file specified in the ImpFile portion of the message and returned an error to RulImportFile.

Programmer Response

This message maybe output due to a problem with one of three different rules that could be defined in your AFGJOB.JDT.

· RulImportFile

· RulImportNAPOLFile

· RulImportNAPOLExtract

Verify that the file exists in the path/subdirectory specified in the parameter field of the rule specified in the AFGJOB.JDT. If the file exists in the specified path/subdirectory, then verify that the file name matches the one specified in the rule.

See the online Rules Reference for the correct format of the parameters for the RulImportFile, RulImportNAPOLFile, and RulImportNAPOLExtract rules.

DM10260

Error: Error in ImportExtract(): ImportExtract() failed for extract file <ExtFile>.

Explanation

The function, ImportExtract, failed to import data from the extract failed specified in the ExtrFile portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10261

Error: Error in ImportFile(): Unable to import data from file.

Explanation

The function, ImportFile, was unable to import data from the import file.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10262

Error: Error in ImportExtract(): Unable to import data from file.

Explanation

The function, ImportExtract, was unable to import data from the extract file.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10263

Error: Error in EXTNextBuffer(): Extract list handle is VMMNULLHANDLE.

Explanation

The function, EXTNextBuffer, was passed an invalid pointer (null) to the next record in the extract list.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10264

Error: Error in EXTNextBuffer(): Unable to get data from extract list element.

Explanation

The function, EXTNextBuffer, was unable to get data from the next element in the extract list.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10265

Error: Error in EXTFirstBuffer(): Extract list handle is VMMNULLHANDLE.

Explanation

The function, EXTFirstBuffer, was passed an invalid pointer (null) to the extract list that was to be read.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10266

Error: Error in EXTFirstBuffer(): Unable to get data from extract list element.

Explanation

The function, EXTFirstBuffer, was unable to get data from the first element in the extract list.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10267

Error: Error in IMPOpenBuffer(): Unable to open import file <&file&>.

Explanation

The function, IMPOpenBuffer, was unable to open the import file specified in the file portion of the message.

Programmer Response

Verify that you have defined the path and import file name correctly in the option parameter of the rule in the AFGJOB.JDT. See the online Rules Reference for the correct format of the parameters for the ImportNAPOLFile or ImportFile rule.

Verify that the file exists in the specified subdirectory. If the file exists, then verify that the file name matches the one in the subdirectory and in the option parameter of the rule.

DM10268

Error: Error in IMPFirstBuffer(): Import file pointer is invalid.

Explanation

The function, IMPFirstBuffer, was passed an invalid pointer (null) to the import file.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10269

Error: Error in IMPFirstBuffer(): Unable to get first line from import file.

Explanation

The function, IMPFirstBuffer, was unable to read (fgets) the first line from the import file.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10270

Error: Error in IMPNextBuffer(): Import file pointer is invalid.

Explanation

The function, IMPNextBuffer, was passed an invalid pointer (Null) to the next line (record) in the import file.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10271

Error: Error in IMPNextBuffer(): Unable to get next line from import file.

Explanation

The function, IMPNextBuffer, was unable to get data from the next record in the import file.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10272

Error: Error in ImportFile(): Unable to get import file name. Bad parameters <Parms>.

Explanation

The function, RulImportFile, could not import the specified file name. There is a problem with the parameters specified on the rule in the AFGJOB.JDT.

Programmer Response

Verify that you have defined the option parameters correctly on the rule in the AFGJOB.JDT. See the online Rules Reference for the correct format of the parameters for the ImportNAPOLFile or ImportFile rule.

Verify that the import file exists in the specified subdirectory. If the file exists, then verify that the file name matches the one in the subdirectory and the one specified in the rule parameters.

DM10273

Error: Error in FindImportFileName(): Data field <Buff> requires 3 items (FmtMask Offset,Size). PUT A SPACE BETWEEN FmtMask AND Offset!!!

Explanation

The option parameter, SCH for the rule ImportNAPOLFile or ImportFile did not have the required number of input items. The option parameter existing on the current rule is specified in the Buff portion of the message.

Programmer Response

Verify that you have defined the option parameters correctly on the rule in the AFGJOB.JDT. See the online Rules Reference for the correct format of the parameters for the ImportNAPOLFile or ImportFile rule.

DM10274

Error: Error in findImportFileName(): Unable to GENGetRecord(pRPS->ExtractListH,<Pointer>,).

Explanation

The function, GENGetRecord, could not find a record in the import file that matched the search mask specified in the rule’s option parameter. The search mask is specified in the Pointer portion of the message

Programmer Response

Verify that the search mask is defined correctly in the SCH option parameter for the ImportNAPOLFile or ImportFile rule defined in the AFGJOB.JDT file.

Verify that the search mask (offset and mask) is defined in the import file and is at the correct offset. Plus the mask matches the correct character case (all upper, all lower, or mixed case) specified in the rule option parameter and the import record.

DM10275

Error: Error in findImportFileName(): Unable to GVMGetDataPtr(,<VarName>,,,,).

Explanation

The function, GVMGetDataPtr, could not find the global variable specified in the VarName portion of the message and returned an error to FindImportFileName.

Programmer Response

Verify that you have defined the GVM option parameter correctly on the rule in the AFGJOB.JDT. See the online Rules Reference for the correct format of the parameters for the ImportNAPOLFile or ImportFile rule.

Verify that you have defined the GVM variable in the INI control group, < GentrnDummyFields > in the INI file.

DM10276

Error: Error in findImportFileName(): Unable to INIGetInitValue(<grp>,<opt>,,).

Explanation

The INI Group, < xxxxx >, and the Option, yyyyy, could not be found in the INI file. The group and option are specified in the grp and opt portion of the message

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10277

Error in GeneralDal(): Unable to GetFieldRuleData().

Explanation

Programmer Response

This information is only output to the LogFile when the INI group, < DAL_Rule >, and option Debug_DAL = Yes is present in the INI file. The default for this INI group/option is No.

DM10278

Error in GeneralDal(): Unable to ScanString(pRPS,<Script>,IF_PRE_SCAN).

Explanation

Programmer Response

This information is only output to the LogFile when the INI group, < DAL_Rule >, and option Debug_DAL = Yes is present in the INI file. The default for this INI group/option is No.

DM10279

Info in GeneralDal(): Data to be passed to DALRunScript: <Script>.

Explanation

This LogFile message allows the user to view the data to be passed by the DAL rule to the DALRunScript function. The data is specified in the Script portion of the message.

Programmer Response

This LogFile message allows the user to view the data to be passed by the DAL rule to the DALRunScriptfunction.

This information is only output to the LogFile when the INI group, < DAL_Rule >, and option Debug_DAL = Yes is present in the INI file. The default for this INI group/option is No.

For more information on INI Options, refer to the online INI Reference Guide.

DM10280

Error in GeneralDal(): Unable to DALRunScript(NULL,<Script>,,,).

Explanation

The function, DALRunScript, could not complete the parsing of the DAL script specified in the Script portion of the message and returned an error to GeneralDAL.

Programmer Response

Review the DAL script contained in the DAL rule. Check for the following

items that could cause the script to have invalid syntax.

- missing colons between commands.

- missing parentheses

- incorrect abbreviations for the DAL commands

-

This message is one in a group of related messages. Follow the message chain up to

locate a message that describes the error in more detail.

Example:

DM12042: Error in RPDALErrorNotify(): DAL library error: script:<>, lineno:<1>,

col:<82>, errnum:<13>, token:<End>, msg:<Invalid expression syntax>.

DM10553: Error in GeneralDAL(): Unable to DALRunScript(NULL,,,,).

See the online DAL Reference for the correct syntax for the DAL commands.

This information is only output to the LogFile when the INI group, < DAL_Rule >, and option Debug_DAL = Yes is present in the INI file. The default for this INI group/option is No.

DM10281

Info in GeneralDal(): Result from running DALRunScript: <Result>.

Explanation

This LogFile message displays the value which resulted from the DAL script execution. The value is specified in the Result portion of the message.

Programmer Response

This LogFile message displays the value that resulted from executing the DAL script specified in the DAL rule.

This information is only output to the LogFile when the INI group, < DAL_Rule >, and option Debug_DAL = Yes is present in the INI file. The default for this INI group/option is No.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DAL rule.

For more information on INI Options, refer to the online INI Reference Guide.

DM10282

Error: An unexpected error occurred - encountered a GroupBegin <&Image&> that does not specified a GroupEnd image.

Explanation

There are more Beings than Ends or vice versa and one of the group is a Pagination Group.

Programmer Response

Check to make sure that you have a corresponding GroupEnd to every GroupBegin you have

DM10284

Info in GeneralDal(): Condition data: <Script>.

Explanation

This LogFile message displays the condition data in the DAL rule. The condition data is specified in the Script portion of the message.

Programmer Response

This LogFile message allows the user to view the condition data in the DAL rule.

This information is only output to the LogFile when the INI group, < DAL_Rule >, and option Debug_DAL = Yes is present in the INI file. The default for this INI group/option is No.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DAL rule.

For more information on INI Options, refer to the online INI Reference Guide.

DM10285

Info in GeneralDal(): Nothing returned from DALRunScript. Skipping field.

Explanation

The function, DALRunScript, did not return any data from the execution of the DAL script, therefore it returned an error to GeneralDAL.

Programmer Response

Re-view the DAL script for errors or invalid syntax.

This message is only output to the LogFile when the INI group, < DAL_Rule >, and option Debug_DAL = Yes is present in the INI file. The default for this INI group/option is No.

DM10286

Info in GeneralDal(): pRPS

Explanation

This LogFile message displays the value, xxxxx, that was placed in the output buffer specified in the DAL rule. The value is specified in the OutBuffer portion of the message.

Programmer Response

This LogFile message displays the value that was placed in the output buffer specified in the DAL rule.

This information is only output to the LogFile when the INI group, < DAL_Rule >, and option Debug_DAL = Yes is present in the INI file. The default for this INI group/option is No.

DM10292

Error in <ImportXMLExtract()>: Unable to <DXMLoadXMLRecs()>.

Explanation

Programmer Response

The next error you will receive is the error for the DOCC start or root tag. This is because Authentic requires that a schema file be referenced so that edits are done correctly and that the elements are written to the XML output file correctly. Once again, if you are 100% sure you are done with the edits, please change this line to the following.

<DOCC xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="C:\CPV6.2\Common+GL+CP.XSD"> Change to <DOCC>

DM10293

Error in <BuildTranRecs>: Unable to <DXMLoadXMLRecs()>. Skip Transaction# <2>. Warning: the specific info you may see may not be the infor for the error transaction. It may be the info on the last complete transaction.

Explanation

Programmer Response

Problem in loading the XML file. Syntax error.


DM10300 - DM10399 Messages

DM10300

Error: Unknown parameter <Parm1>.

Explanation

Programmer Response

DM10301

Error: Parameter error in left cord <Parm1>.

Explanation

One of the coordinate subparameter(s) is in error or missing in the Cord parameter of the OMR_Marks rule.

Programmer Response

Correct or add the missing coordinate subparameter(s) in the Cord parameter of the OMR_Marks rule. See the online Rules Reference for a description of the parameters for the OMR_Marks rule.

DM10302

Error: Parameter error in right cord <Parm1>.

Explanation

Programmer Response

DM10303

Error: Unknown Parm1 parameter <Parm2>.

Explanation

Programmer Response

DM10304

Error: Invalid Parm1 parameter <Parm2>.

Explanation

Programmer Response

DM10305

Warning: Condition cond could not be evaluated. OMR will not be printed.

Explanation

Programmer Response

DM10306

Warning: Condition cond could not be loaded. OMR will not be printed.

Explanation

Programmer Response

DM10307

Warning: Condition cond could not be compiled. OMR will not be printed.

Explanation

Programmer Response

DM10308

Warning: Condition cond not found. OMR will not be printed.

Explanation

Programmer Response

DM10309

Error in ParseComment(): Failed to locate global variable Parm1.

Explanation

Programmer Response

DM10310

Error in ParseComment(): Failed to parse AFP comment Parm1.

Explanation

Programmer Response

DM10311

Error in Name: Failed to GENGetGlbDataPtr(AFP2UPDATA,NULL).

Explanation

Programmer Response

DM10312

Error in Name: Failed to Create OMR marks List.

Explanation

Programmer Response

DM10313

Error in Name: Failed to append OMR parameter from < OMR_PARAMS > group in the fsisys.ini.

Explanation

Programmer Response

DM10314

Warning in Name: Could Not ParseComment(pRPS,Parm1,,).

Explanation

Programmer Response

DM10315

Error in Name: Could Not Get Page numbers.

Explanation

Programmer Response

DM10316

Error GetVars(): Could not GVMGetDataPtr() for RCB variable 'Parm1'.

Explanation

Programmer Response

DM10317

Error: Unbalanced parentheses.

Explanation

Programmer Response

DM10318

Error in Parm1: Unable to create a linked list.<parms>.

Explanation

The function, VMMCreateList, could not create a memory list for the INI option name specified in the parms portion of the message and returned an error to RulLoadTables. The INI control group name is specified in the Name portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM10319

Error in LoadDataDictionary(): Unable to find INI group < DataDictionary >, and option, ' Name '.

Explanation

Programmer Response

DM10320

Error in LoadDataDictionary(): Unable to find INI value ' MasterResource ', ' TableLib '.

Explanation

Programmer Response

DM10321

Error in LoadDataDictionary(): Unable to open file, "file", specified under group < DataDictionary > and option, "Name"

Explanation

Programmer Response

DM10322

Error: Line line, Unable to identify the statement <buff>.

Explanation

Programmer Response

DM10323

Error: Line line, imcomplete statement. The '>' is expected. <buff>

Explanation

Programmer Response

DM10324

Error: Line line, Unable to define the statement for <Records> or <Variables>. <buff>

Explanation

Programmer Response

DM10325

Error: Line line, '=' sign is missing. <buff>

Explanation

Programmer Response

DM10326

Error: Unable to find global variable <Parm1>.

Explanation

Programmer Response

DM10327

Error: Line line, Duplicated for name of record. <buff>

Explanation

Programmer Response

DM10328

Error: Unable to create a list in LoadDataDictionary().

Explanation

Programmer Response

DM10329

Error: Line line, No values are assigned. <buff>

Explanation

Programmer Response

DM10330

Error: Unable to append a value of Parm1 into a list.

Explanation

Programmer Response

DM10331

Error: Line line, a '(' is expected. <buff>

Explanation

Programmer Response

DM10332

Error: Line line, Invalid name of Record. <buff>

Explanation

Programmer Response

DM10333

Error: Line line, No search mask provided. <buff>

Explanation

Programmer Response

DM10334

Error: Unable to append a structure into a list.

Explanation

Programmer Response

DM10335

Error: Unable to append to a list.

Explanation

Programmer Response

DM10336

Error: During Data Dictionary Compilation: undefined function call encountered. Equation<Parm1>.

Explanation

Programmer Response

DM10337

Error: Variable <Parm1> not found in Data Dictionary.

Explanation

Programmer Response

DM10338

Error: Variable <Parm1> not valid data type for RPN function.

Explanation

Programmer Response

DM10339

Error: Invalid input date format mask.

Explanation

Programmer Response

DM10340

Error: Unable to append a value of Date Input Format into a list.

Explanation

Programmer Response

DM10341

Error: Invalid output date format mask.

Explanation

Programmer Response

DM10342

Error: Unable to append a value of Date Output Format into a list.

Explanation

Programmer Response

DM10343

Error: Invalid language date format mask.

Explanation

Programmer Response

DM10344

Error: Unable to append a value of Date Lang Format into a list.

Explanation

Programmer Response

DM10345

Error: Invalid keyword in the date format mask. <Parm1>

Explanation

Programmer Response

DM10346

Error: Language not supported <Parm1>.

Explanation

Programmer Response

DM10347

Error: Line line, Duplicated name under <Records> statement. <buff>

Explanation

Programmer Response

DM10348

Error: Line line, Invalid keyword or statement in the data dictionary file. <buff>

Explanation

Programmer Response

DM10349

Error: Line line, Invalid keyword or statement. The 'Parm1' is expected. <buff>

Explanation

Programmer Response

DM10350

Error: Line line, Unable to find the name of record. <buff>

Explanation

Programmer Response

DM10351

Error: Line line, Invalid Parm1 value. <buff>

Explanation

Programmer Response

DM10352

Error: Line line, Rule(Parm1) is Invalid or not registered. <buff>

Explanation

Programmer Response

DM10353

Error: Parsing the data format information <buff> for variable <Parm1>.

Explanation

Programmer Response

DM10354

Error: The 'RECORD' and the 'GVM' parameters are mutually exclusive.

Explanation

Programmer Response

DM10355

Error in PopObject(): Attempt to pop from an empty stack.

Explanation

Programmer Response

DM10356

Error adding two dates.

Explanation

Programmer Response

DM10357

Error: Cannot add a Date and Double type.

Explanation

Programmer Response

DM10358

Error subtracting two dates.

Explanation

Programmer Response

DM10359

Error: Cannot subtract a Date and Double type.

Explanation

Programmer Response

DM10360

Error: Cannot multiply a Date type.

Explanation

Programmer Response

DM10361

Warning: During Data Dictionary evaluation a division by zero was encountered.

Explanation

Programmer Response

DM10362

Error: Cannot Parm1 a Date type.

Explanation

Programmer Response

DM10363

Error: Cannot Parm1 a Date and Double type.

Explanation

Programmer Response

DM10364

Error: No date input format.

Explanation

Programmer Response

DM10365

Error: Found an unsupported Input format <format>.

Explanation

Programmer Response

DM10366

Error: The date <date> is invalid with format <format>.

Explanation

Programmer Response

DM10367

Warning: No Date data found on extract for <Parm1>.

Explanation

Programmer Response

DM10368

Error: Parsing date for data dictionary variable <Parm1>.

Explanation

Programmer Response

DM10369

Error: During RPN processing for data dictionary variable <Parm1>.

Explanation

Programmer Response

DM10370

Error: Variable has invalid Parm1data at offset<offset>. Value <buff>

Explanation

Programmer Response

DM10371

Error occurred during RPN processing.

Explanation

Programmer Response

DM10372

Error: Variable <Parm1>

Explanation

Programmer Response

DM10373

Error: Bad Output format parameter <Parm1>.

Explanation

Programmer Response

DM10374

Error: Found an unsupported Output format <format>.

Explanation

Programmer Response

DM10375

Error: No data TYPE provided, therefore a default format routine can not be selected. An explicit format rule was not provide either so the data can not be formatted. A data type should be provided for variable <Parm1>

Explanation

Programmer Response

DM10376

Error: Field rules can only be applied to Data Dictionary variables defined on extract records. Variable <Parm1> is not on a record.

Explanation

Programmer Response

DM10377

Error: Unable to create a list for a temporary extract list.

Explanation

Programmer Response

DM10378

Error: Unable to Load Data Dictionary.

Explanation

Programmer Response

DM10379

Error in data dictionary. No record description provided for record <record>.

Explanation

Programmer Response

DM10380

Error in data dictionary. Record <record> is not defined as a REPEATING type.

Explanation

Programmer Response

DM10381

Error: Bad Data Dictionary parameter.

Explanation

Programmer Response

DM10382

Error: No variable value assigned for "Parm1".

Explanation

Programmer Response

DM10383

Error: Missing record pointer names.

Explanation

Programmer Response

DM10384

Error in Name: Image <image> Parameters <parms>.

Explanation

Programmer Response

DM10385

Error: No record name provide in parameters.

Explanation

Programmer Response

DM10386

Error: Record <record> is not defined in the data dictionary.

Explanation

Programmer Response

DM10387

Error: Condition <cond> is not defined in the condition table.

Explanation

Programmer Response

DM10388

Error: Missing rule parameters.

Explanation

Programmer Response

DM10389

Error: Failed parameter parsing.

Explanation

Programmer Response

DM10390

Error in Name: Missing variable names in Data section.

Explanation

Programmer Response

DM10391

Error in Name: Image<image> Field<field> Unable to retrieve data for <parms>.

Explanation

Programmer Response

DM10392

Warning: During Data Dictionary evaluation of square root a negative number was encountered.

Explanation

Programmer Response

DM10393

Error: Unable to find the message with key, "key".

Explanation

Programmer Response

DM10394

Error: Unable to parse for text associated to key, "key".

Explanation

Programmer Response

DM10395

Error: No variable name to be assigned.

Explanation

Programmer Response

DM10396

Error: Invalid parameter(s) in <TAB:,,,>.

Explanation

Programmer Response

DM10397

Error in AddMsgsToTextArea: Unable to append a font ID into a list.

Explanation

Programmer Response

DM10398

Error: Invalid spacing value.

Explanation

Programmer Response

DM10399

Error in AddMsgsToTextArea: Unable to append a spacing info to a list.


DM10400 - DM10499 Messages

DM10400

Error: Invalid Tag or Message syntax.

Explanation

Programmer Response

DM10401

Error in Field: Could not add message to field. Key<key>.

Explanation

Programmer Response

DM10402

Error in Field: Unknown element type in message text list.

Explanation

Programmer Response

DM10403

Error in Field: Invalid <Parm1> parameter in the RuleParms.

Explanation

Programmer Response

DM10404

Error in Field: Unbalanced parentheses. Field <DestField>.

Explanation

Programmer Response

DM10405

Error in Field: Unknown parameter in field rule. Field <DestField>.

Explanation

Programmer Response

DM10406

Error in Field: Unable to find INI value under <Messages>, "value".

Explanation

Programmer Response

DM10407

Error in Field: Unable to open message database assigned under <Keyed Files>, MessageDataBase.

Explanation

Programmer Response

DM10408

Warning: Language code code was not found in the data dictionary.

Explanation

Programmer Response

DM10409

Error: No variable defined or value found for Parm1.

Explanation

The input parameters to the rule which has the problem are not defined or valid.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the rule, image and field that has the problem.

Example:

DM10409: Error: No variable defined or value found for MSGGI.

DM12051: Error in RPProcessOneField(): Unable to <MESSAGEFROMEXTR>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <MESSAGE>.

Processing will NOT continue for image <QAIMSGOP>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask

and Data field parameters for the rule which has the problem..

DM10410

Error in Field: Unknown parameter at ImageDim() in field rule. Field <DestField>.

Explanation

Programmer Response

DM10411

Error in Field: Image<image> Could not parse RuleParms<parms>.

Explanation

Programmer Response

DM10412

Error in Field: Image<image> Field<DestField> Record <rec> is not defined in the data dictionary.

Explanation

Programmer Response

DM10413

Error in Field: Image<image> Field<DestField> Condition <cond> is not defined in the condition table.

Explanation

Programmer Response

DM10414

Error: Unable to parse the text <text>.

Explanation

Programmer Response

DM10415

Error in Field: Could not add message to field. message<Parm1>.

Explanation

Programmer Response

DM10416

Warning in Name: The first image<image> defined to the page does not fit on the page. The top of the footer is at top and the bottom of the image is at bottom.

Explanation

Programmer Response

DM10417

Error in Name: Unable to load fap for image image.

Explanation

Programmer Response

DM10418

Error in Name: Unable to propogate field data.

Explanation

Programmer Response

DM10419

Warning in Name: The first image<image> defined to the page does not fit on the page.

Explanation

Programmer Response

DM10420

Warning in Name: The first image<image> defined to the page does not fit on the page. The right margin is at right and the right edge of the image is at Parm1.

Explanation

Programmer Response

DM10421

Warning in Name: Parameter missing. Should be like: Parm1.

Explanation

Programmer Response

DM10422

Warning in Name: Unable to add function MoveToPage to PaginationQueue.

Explanation

Programmer Response

DM10423

Warning in Name: Unable to queue request to the Post Pagination Queue.

Explanation

Programmer Response

DM10424

Warning in Name: Unable to create invalid image list.

Explanation

Programmer Response

DM10425

Warning in Name: Unable to add image to invalid list.

Explanation

Programmer Response

DM10426

Warning in Name: Unable to add function to PostPagination queue.

Explanation

Programmer Response

DM10427

Warning in Name: Unable to add orphans to orphans list.

Explanation

Programmer Response

DM10428

Error: Fail to process Store. Command should be in the format Store(<VAR>). Command=Parm1.

Explanation

Programmer Response

DM10429

Error: Fail to func for ghImgCoordsHashList during ulStoreCoords().

Explanation

Programmer Response

DM10430

Error: Fail to allocate memory for pstImgCoords during ulStoreCoords().

Explanation

Programmer Response

DM10431

Error: Fail to VMMInsertHashElem with key key during ulStoreCoords().

Explanation

Programmer Response

DM10432

Error: Invalid coordinate specification Parm1 in image.

Explanation

The image coordinate specification is invalid or misspelled in the SetOrigin rule for an image.

Programmer Response

View and correct the image coordinate specification using the Image Editor Format | Image Properties | Image Rule tab. For rules help, select the rule and press the Explain button which will take to Help Topic: Rules Help screen.

DM10433

Error: Fail to find Parm1 in ulFindCoord(). ghImgCoordsHashList has no elements.

Explanation

Programmer Response

DM10434

Error: Improper coordinate string Parm1 in image image.

Explanation

Programmer Response

DM10435

Error: Fail to find Parm1 in ulFindCoord(). Check coordinate specification Parm2 in image - was Parm1 previously stored?

Explanation

Programmer Response

DM10436

Error: Improper coordinate specifcation Parm1 found during ulGetCoord.

Explanation

Programmer Response

DM10437

Error: Fail to save coordinates. Parms=Parms.

Explanation

Programmer Response

DM10438

Error: Fail to process command. Parms=Parms.

Explanation

Programmer Response

DM10439

Error in SetOrigin. Rule Parms Parms are incorrect.

Explanation

The parameter(s) associated with the SetOrigin rule are incorrect.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10432: Error: Invalid coordinate specification Re in q1addr.

DM10439: Error in SetOrigin. Rule Parms are incorrect.

DM10440

Error in Image Level Rule IncOvRealRecs(): Invalid number of rule parameters.

Explanation

Programmer Response

DM10441

Error in Image Level Rule IncOvRealRecs(): The third rule parameter <Parm1> is invalid.

Explanation

Programmer Response

DM10442

Error in Image Level Rule IncOvRealRecs(): Unable to VMMCreateList()

Explanation

Programmer Response

DM10443

Error in Image Level Rule IncOvRealRecs(): Unable to run IncRealRecsUsed()

Explanation

Programmer Response

DM10444

Error in RULSetRecipFromImage(): Image: <image>: Unable to func.

Explanation

Programmer Response

DM10445

Error in RULSetRecipFromImage(): Image: <image>: Unable to DSDelZeroCopyForms(..., <group1>, <group2>, <group3>, 0L).

Explanation

Programmer Response

DM10446

Error in Name: Unable to RCTLoadSetRecipientTable(pRPS).

Explanation

Programmer Response

DM10447

Error in Name: Unable to add extract driven images.

Explanation

Programmer Response

DM10448

Error in Name: Invalid rule parameters <parms>. Data field requires 2 items (OptionX,OptionY).

Explanation

Programmer Response

DM10449

Warning in Name: Parameter <parms> Could not find image <image> on the current page .

Explanation

Programmer Response

DM10450

Warning in Name: Origin for image <image> was never set.

Explanation

Programmer Response

DM10451

Error in Name: Invalid parameter:<parms>.

Explanation

The ResetImageDimensions rule has an invalid parameter defined. The parameter is specified in the <parms> portion of the message.

Programmer Response

See the online Rules Reference for the correct format of the parameters for the ResetImageDimensions rule.

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10451: Error in RESETIMAGEDIMENSIONS: Invalid parameter:<MinHeigh>.

DM12086: Error in RPDoImageRules(): Unable to <RESETIMAGEDIMENSIONS>().

DM12077: Error in RPProcessOneImage(): Unable to RPDoImageRules(pRPS, RP_PRE_PROC_B).

DM12082: Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <QAIMSGOP>.

Skipping the rest of the Images for this Form.

See INI group:< GenDataStopOn > option:ImageErrors.

DM10452

Error: Unbalanced quotes in quoted string <Parm1>.

Explanation

Programmer Response

DM10453

Error: Variable name too long <Parm1>.

Explanation

Programmer Response

DM10454

Error: Unable to identify operand <Parm1>.

Explanation

Programmer Response

DM10455

Error: Unable to identify relational operator <Parm1>.

Explanation

Programmer Response

DM10456

Error: Invalid condition expression.

Explanation

Programmer Response

DM10457

Error: Unbalanced parentheses in expression <Parm1>.

Explanation

Programmer Response

DM10458

Error: Record <rec> not found.

Explanation

Programmer Response

DM10459

Error: Condition <cond> not found.

Explanation

Programmer Response

DM10460

Error: Unable to find INI value group, key.

Explanation

Programmer Response

DM10461

Error <Name>: Unable to fopen(<file>, 'r'). text

Explanation

The function, fopen, failed to open the file specified in the file portion of the message for read mode. The fopen error code is specified in the text portion of the message.

Programmer Response

Verify that the file name specified in thefile portion of the message exist. If it does, verify that the path specified in the INI option in the INI control group, < Look_Up > is correctly defined.

DM10462

Error: Null variable handle in Condition API.

Explanation

Programmer Response

DM10463

Error: Unknown Variable Type in Condition API.

Explanation

Programmer Response

DM10464

Error: Incompatible Variable Types in Condition API.

Explanation

Programmer Response

DM10465

Error: Evaluating the expression <cond>.

Explanation

Programmer Response

DM10466

Error: Unable to add base rule <Rule>to Parm1 rule list.

Explanation

Rule will be replace with the name of the rule that failed to be registered.

Parm1 will be replaced with the internal name of the rule list intended as a destination for the new rule. The possible values are: Base, Transaction, Image, and Field.

For instance, suppose the message reads: Error: Unable to add base rule <MyRule> to Transaction rule list. In this case, it means the rule called MyRule could not be added to the Transaction (Base Form Set) rules list.

Receiving this message probably means the application has run out of memory or has encountered an unrecoverable internal error.

Programmer Response

Try removing the transaction that generates the error from the run to determine if the transaction itself is the problem. If it is not isolated to a single transaction, the only additional solution may be to make more memory available to the application.

If a single transaction seems to be the culprit, then subsequent error messages may reveal the underlying rules which instigated the failure.

DM10467

Error in CreateHashTableOfQueues: Unable to create Queue Table.

Explanation

Programmer Response

DM10468

Error in CreateHashTableOfQueues: Unable to Hash Queue Table.

Explanation

Programmer Response

DM10469

Error in RULLocateTableQueue: Hashed Queue Table has not been initialized.

Explanation

Programmer Response

DM10470

Error in RULAddToQueue: Queue ID Name: <Parm1>, Entry Name: <Parm2>.

Explanation

Programmer Response

DM10471

Error in Field: Image<image> Field<DestField> Unbalanced parentheses in Parm2 string <Parm1>.

Explanation

Programmer Response

DM10472

Error in Field: Image<image> Field<DestField> Unable to aquire data for mask <parms>.

Explanation

Programmer Response

DM10473

Error in Field: Image<image> Field<DestField> Unable to format for output.

Explanation

Output could not be formatted for the rule in the image for the field specified in the <Field>, <Image>, and <DestField> portion of the message, which caused an error to be returned to the calling function.

Programmer Response

This message is one in a group of related messages. Follow the message chain up and down to locate a message that describes the error in more detail plus the rule, image, and field that had the problem.

Example:

Error: Failed to parse the output Size and Percision. <C>.

DM10473: Error in MOVENUM: Image<q1gdbd> Field<PREM BASIS 1> Unable to format

for output.

Use the Image Editor Field Properties/Edit DDT window to correct/update the parameters

for the rule. For rule help, select the rule and press the Explain Rule button which

will take to Help Topic: Rules Help screen.

See the Rules Reference for the correct format of the mask

and data parameters for the rule MNumExt..

DM10474

Error in RULCreateField(): Unable to FAPCreateField(pRPS->CurrentFapImageH,VMMNULLHANDLE,<DestField>,FALSE).

Explanation

Programmer Response

DM10475

Error in Name: Unable to get the address of the lookup table from variable Parm1. Tip: Insure that you have Parm1 defined under LOOKUP_TABLES.

Explanation

Programmer Response

DM10476

Error in Name: No valid Data in the Lookup Table for key(key)

Explanation

Programmer Response

DM10477

Error in Name: Key (key) not found in Table (Parm1)

Explanation

Programmer Response

DM10478

Error in Name: Image<image> Field<DestField> Missing variable names in Data section.

Explanation

Programmer Response

DM10479

Error in Name: Image<image> Field<DestField> Missing format mask.

Explanation

Programmer Response

DM10480

Error in Name: Image<image> Field<DestField>. Failed to parse the output Size and Precision. <buff>.

Explanation

Check the output Size and Percision parameters for the rule in the field/image/destination field name as specified in the <Name>, <Image>, and <DestField> portion of the message.

Programmer Response

Correct the output size and percision parameters for the rule referenced by the field/image/destination field name specified in the message.

Use the Image Editor Field Properties | Edit DDT window to correct/update the

parameters for the rule in the Mask field. For rule help, select the rule and press

the Explain Rule button which will take to Help Topic: Rules Help screen.

This message is one in a group of related messages. Follow the message chain up to

locate a message that describes the error in more detail.

Example:

Error: Failed to parse the output Size and Percision. <C>.

DM10473: Error in MOVENUM: Image<q1gdbd> Field<PREM BASIS 1> Unable to format

for output.

DM10481

Error in Name: Image<image> Field<DestField>. Bad or missing Output format <buff>.

Explanation

Programmer Response

DM10482

Error in Name: Image<image> Field<DestField>\. Fail to format the numeric value<Parm1>.

Explanation

Programmer Response

DM10483

Error in Name: Image<image> Field<DestField> Missing search mask in Data section.

Explanation

Programmer Response

DM10484

Error in Name: Image<image> Field<DestField> Missing field name in Data section.

Explanation

Programmer Response

DM10485

Error in Name: Image<image> Field<DestField> Value of field <parms> is not all numeric <buff>.

Explanation

Programmer Response

DM10486

Error: Parm1 name not defined or provided in the parameters.

Explanation

Programmer Response

DM10487

Error in Name: Unmatched paren in Rule Parm Parm1.

Explanation

The specified rule has an unmatched pair of parenthesis for one of its parameter(s). The rule and parameter name specified in the <Name> and <Parm>portion of the message.

Programmer Response

See the online Rules Reference for the correct format of the Mask and Data field parameters for the rule specified in the <Name> portion of the message.

DM10488

Error in Name: Unable to perform function <func>. This group rule may not have been registered.

Explanation

The GroupBegin rule could not execute the group function specified in the <func> portion of the message.

Programmer Response

Verify that the function specified in the <func> portion of the message is a valid or spelled correctly for the GroupBegin rule. See the online Rules Reference for the correct definition for all functions,

parameters and sub parameters for the GroupBegin rule.

DM10489

Error in Name: No group function was specified. (Parm1).

Explanation

Programmer Response

DM10490

Error in Name: Unable to add element to the Group Stack.

Explanation

Programmer Response

DM10491

Warning in RULSetGroupOptions(): There is no corresponding Group rule.

Explanation

Programmer Response

DM10492

Error: Invalid parameters. Can not be header and footer.

Explanation

Programmer Response

DM10493

Msg: StayTogether<Begin>. Parms<parms> Image<image>.

Explanation

Programmer Response

DM10494

Msg: StayTogether<End>. Parms<parms>.

Explanation

Programmer Response

DM10495

Error: The Parm1 image is missing. Therefore it cannot StayTogether.

Explanation

Programmer Response

DM10496

Error: The Parm1 image is the image list itself. Therefore it cannot StayTogether.

Explanation

Programmer Response

DM10497

Warning: The begin image<image> and the end image<image2> are not on the same page. Therefore they cannot StayTogether.

Explanation

Programmer Response

DM10498

Msg: StayTogether<End>. Begin image<image> handle<Parm1> list<Parm2> End image<image2> handle<Parm3> list<Parm4>.

Explanation

Programmer Response

DM10499

Msg: StayTogether<End>. Parm Image<image> Cord(Parm1,Parm2,Parm3,Parm4).


DM10500 - DM10599 Messages

DM10500

Error in EjectPage(): Unable to RPDoImageRulePostProcs(pRPS).

Explanation

Programmer Response

DM10501

Error in EjectPage(): Unable to RPDoImageRulePreProcs(pRPS).

Explanation

Programmer Response

DM10502

Warning in powtype(): Sent to Manual Batch since rule 'powtype' or 'KickToWip' was indicated for field:<DestField> Image:<Image>

Explanation

The field rule, PowType or KickToWip, was executed for the image and field specified in the DestField and Image portion of the message. In addition, the field's DDT required field flags had the Operator flag set to ' On '.

Programmer Response

This is a GENData informative message.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the PowType or KickToWip rule.

See the online DocuMaker RP System Reference for a description of the DDT required field flags.

DM10503

Error in tbllkup(): Unable to GENGetGlbData('TbllstH',,).

Explanation

Programmer Response

DM10504

Error in tbllkup(): Lookup list handle is invalid.

Explanation

Programmer Response

DM10505

Error in tbllkup(): Empty RuleParms for tbllkup.

Explanation

The TblLkUp function detected that its data field parameters are missing.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM10505: Error in TblLkUp(): Empty RuleParms for TblLkUp.

DM12051: Error in RPProcessOneField(): Unable to <TBLLKUP>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField

(pRPS) <TableLookup>. Processing will not continue for image

<q1ruldmo>. See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of

the Data field parameters for the TblLkUp rule.

DM10506

Error in tbllkup(): Invalid RuleParms for tbllkup:<Parms>. Data field requires 4 items (Key,FParm,Key,FParm).

Explanation

The TblLkUp rule requires four sets of data field parameters. The current data field parameters for the rule are specified in the <Parm> portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM10506: Error in TblLkUp(): Invalid RuleParms for TblLkUp:

<11,HEADERREC>. Data field requires 4 items

(Key,FParm,Key,FParm).

DM12051: Error in RPProcessOneField(): Unable to <TBLLKUP>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField

(pRPS) <TableLookup. Processing will NOT continue for image

<q1ruldmo>. See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of

the Data field parameters for the TblLkUp rule.

DM10507

Error in tbllkup(): Invalid number of parms in Data element.

Explanation

The data field parameters for the rule TblLkUp contains an invalid number of parameters.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM10507: Error in TblLkUp(): Invalid number of parms in Data element.

DM12051: Error in RPProcessOneField(): Unable to <TBLLKUP>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <TableLookup>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that one of the paired parameters are not missing the second value.

See the online Rules Reference for the correct format of the Data field

parameters for the TblLkUp rule.

DM10508

Error in tbllkup(): Invalid number of parms in Data element.

Explanation

Programmer Response

DM10509

Error in tbllkup(): Invalid number of parms in Data element.

Explanation

The data field parameters for the rule TblLkUp contains an invalid number of parameters.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM10509: Error in TblLkUp(): Invalid number of parms in Data element

DM12051: Error in RPProcessOneField(): Unable to <TBLLKUP>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <TableLookup>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of

the Data field parameters for the TblLkUp rule.

DM10510

Error in tbllkup(): Unable to GENGetFieldDataExt(,,,).

Explanation

Programmer Response

DM10511

Error in tbllkup(): Invalid number of parms in Data element.

Explanation

Programmer Response

DM10512

Error in tbllkup(): Unable to compressln(,).

Explanation

Programmer Response

DM10513

Error in setaddr(): Empty RuleParms for setaddr.

Explanation

The SetAddr rule is missing both of the required two items in the DDT data field.

Programmer Response

See the online Rules Reference for the correct format of the Mask and Data field parameters for the SetAddr rule.

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10513: Error in SetAddr(): Empty RuleParms for SetAddr.

DM12051: Error in RPProcessOneField(): Unable to <SETADDR>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <ADDR3>.

Processing will NOT continue for image <q1addr>. See INI group:

< GenDataStopOn > option: FieldErrors.

DM10514

Error in setaddr(): Invalid RuleParms for rule setaddr:<Parms>. Data field requires 2 items (Key,FParm).

Explanation

The SetAddr rule data field parameters are invalid. The data field requires two sets of paired parameters.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image, and field that has the problem.

Example:

DM10514: Error in SetAddr(): Invalid RuleParms for rule SetAddr:<11,INSADRREC>.

Data field requires two items (Key,FParm).

DM12051: Error in RPProcessOneField(): Unable to <SETADDR>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<ADDRESS LINE1>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask

and Data field parameters for the SetAddr rule.

DM10515

Error in setaddr(): Invalid number of parms in Data element.

Explanation

The second part of data field parameters for the SetAddr rule has an invalid number of parameters. The parameters should be paired address information definitions; offset and length of data.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image, and field that has the problem.

Example:

DM10515: Error in SetAddr(): Invalid number of parms in Data element.

DM12051: Error in RPProcessOneField(): Unable to <SETADDR>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<ADDRESS LINE1>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the SetAddr rule.

DM10516

Error in setaddr(): Unable to compressln().

Explanation

The function, compressin, failed trying to compress the spaces in a line and returned an error to SetAddr.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services

DM10517

Error in setaddr(): Invalid number of parms in Data element.

Explanation

The second part of data field parameters for the SetAddr rule has an invalid number of parameters. The parameters should be paired address information definitions; offset and length of data.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10515: Error in SetAddr(): Invalid number of parms in Data element.

DM12051: Error in RPProcessOneField(): Unable to <SETADDR>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<ADDRESS LINE1>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors

DM10518

Error in setaddr(): Mask is invalid for rule. (setaddr).

Explanation

The SetAddr rule Mask parameter is invalid. The only vaild parameter is 'F' , 'N', or a blank.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image, and field that has the problem. Message DM12048 contains the name of the field and image that has the problem

Example:

DM10518: Error in SetAddr(): Mask is invalid for rule. (SetAddr).

DM12051: Error in RPProcessOneField(): Unable to <SETADDR>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<ADDRESS LINE1>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the SetAddr rule.

DM10519

Error in hardexst(): Empty RuleParms in fmt (GENGetRecord).

Explanation

The HardExst rule is missing its required parameter.

Programmer Response

See the online Rules Reference for the required data parameter for the HardExst rule.

DM10520

Error in move_it(): Empty RuleParms in fmt (GENGetRecord).

Explanation

The Move_It function detected that the search mask parameters for finding the extract record do not exists.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the rule, image, and field that has the problem.

Example:

DM10520: Error in Move_It(): Empty RuleParms in fmt (GENGetRecord).

DM10522: Error in MoveNum(): Unable to Move_It().

DM12051: Error in RPProcessOneField(): Unable to <MOVENUM>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<PREMIUM LINE1>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the rule that has the problem.

DM10521

Error in move_it(): Unable to RunUsrFunc().

Explanation

Programmer Response

DM10522

Error in movenum(): Unable to move_it().

Explanation

The Move_It function detected an error and returned to MoveNum function.

Programmer Response

This message is one in a group of related messages. Follow the message chain up and down to locate a message that describes the error in more detail plus the rule, image, and field that has the problem.

Example:

DM10520: Error in Move_It(): Empty RuleParms in fmt (GENGetRecord).

DM10522: Error in MoveNum(): Unable to Move_It().

DM12051: Error in RPProcessOneField(): Unable to <MOVENUM>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<PREMIUM LINE1>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the MoveNum rule.

DM10523

Error in ovprint(): Invalid RuleParms for ovprint:<Parms>. Data field requires 2 items (form,sym).

Explanation

Programmer Response

DM10524

Error in tbltext(): Empty RuleParms in fmt (GENGetRecord).

Explanation

The data field parameters (search mask) for the rule TblText are missing.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM10524: Error in TblText(): Empty RuleParms in fmt (GENGetRecord).

DM12051: Error in RPProcessOneField(): Unable to <TBLTEXT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <TEXTTABLE>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Data field

parameters for the TblText rule.

DM10525

Error in tbltext(): Unable to GENGetGlbData('TXTLst',,).

Explanation

The function, GENGetGlbData, could not found the global variable TXTLst and returned an error to TblText.

Programmer Response

Verify that the AFGJOB.JDT has the following commands:

1. ;LoadTextTbl;1;;

2. ;CreateGlbVar;1;TXTLst,PVOID;

This message is one in a group of related messages. Follow the message

chain down to locate a message that identifies the image and field that

has the problem.

Example:

DM10525: Error in TblText(): Unable to GENGetGlbData('TXTLst',,).

DM12051: Error in RPProcessOneField(): Unable to <TBLTEXT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<CLASSIFICATN 1>. Processing will NOT continue for image <q1gdbd>.

See INI group:< GenDataStopOn > option: FieldErrors.

DM10526

Error in tbltext(): No tables have been loaded. Hint: base rule LoadTextTbl may not be in the job file.

Explanation

During processing of the rule, TblText, it was determined that the TextTbl file had not been loaded.

Programmer Response

Verify that the AFGJOB.JDT contains the following commands:

1. ;LoadTextTbl;1;;

2. ;CreateGlbVar;1;TXTLst,PVOID;

DM10527

Error in datefmt(): Unable to GENFmtDate(<Buff>,,).

Explanation

The function, GENFmtDate, could not format the date specified in the <Buffer> portion of the message and returned an error to DateFmt.

Programmer Response

This message is one in a group of related messages. Follow the message chain up and down to locate a message that describes the error in more detail

Example:

DM11073: Error in GENFmtDate(): Unknown date format specified.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<030199>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EXPIRE DATE>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the mask

and data parameters for the rule DateFmt.

DM10528

Error in rundate(): Unable to GENGetGlbData('RunDate',,).

Explanation

Programmer Response

DM10529

Error in rundate(): Unable to GENFmtDate(<RunDate>,,).

Explanation

Programmer Response

DM10530

Error in strngfmt(): Unable to GENFmtString(<Buff>,,pRPS->Field.FmtMask).

Explanation

The function, GenFmtString, detected a problem trying to format the string specified in the <Buff> portion of the message and returned an error to StrngFmt.

Programmer Response

This message is one in a group of related messages. Follow the message chain up and down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM11017: Error in GENFmtString(): Invalid format <> passed, data value missing.

DM10530: Error in StrngFmt(): Unable to GENFmtString(<000666666600000444>

,,pRPS->Field.FmtMask).

DM12051: Error in RPProcessOneField(): Unable to <STRNGFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <AGENT NBR>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the StrngFmt rule.

DM10531

Error in setstate(): Unable to GENTranslateStateCode(<Buff>,).

Explanation

The function, GENTranslateStateCode, detected the invalid ISO code specified in the <Buff> portion of the message and returned an error to SetState.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM10531: Error in SetState(): Unable to GENTranslateStateCode(<it>,).

DM12051: Error in RPProcessOneField(): Unable to <SETSTATE>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <SETSTATEFIELD>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors

See the online Rules Reference for the supported ISO codes for the

SetState rule.

DM10532

Error in runuser(): Empty RuleParms in fmt (GENGetRecord).

Explanation

Programmer Response

DM10533

Error in runuser(): Rule requires overflow user function. <Parms>.

Explanation

Programmer Response

DM10534

Error in runuser(): Unable to SetUsrFuncParms(pRPS->Field, parms). Invalid User Func parms in field rule data <Parms>.

Explanation

Programmer Response

DM10535

Error in runuser(): Unable to GetUsrFuncData(parms,num).

Explanation

Programmer Response

DM10536

Error in lookup(): Missing Key offset in lookup.

Explanation

Programmer Response

DM10537

Error in lookup(): Missing Data offset in lookup.

Explanation

Your are missing the Data Offset parameter from the data field for the rule Look_Up.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10537: Error in LookUp(): Missing Data offset in LookUp.

DM12051: Error in RPProcessOneField(): Unable to <LOOKUP>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<LOOK_UP>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors

See the online Rules Reference for the correct format of the data

parameters in the rule Look_Up.

DM10538

Error in lookup(): Missing Data length in lookup.

Explanation

You are missing the Data Length parameter from the data field for the rule Look_Up.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10538: Error in LookUp(): Missing Data length in LookUp.

DM12051: Error in RPProcessOneField(): Unable to <LOOKUP>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<LOOK_UP>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors

See the online Rules Reference for the correct format of the data

parameters in the rule Look_Up..

DM10539

Error in movtbl(): Empty RuleParms for movtbl.

Explanation

The MovTbl function detected that the search mask parameters for finding the extract record do not exists.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image, and field that has the problem.

Example:

DM10539: Error in MovTbl(): Empty RuleParms for MovTbl.

DM12051: Error in RPProcessOneField(): Unable to <MOVTBL>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<CLASSNUM1>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters in the MovTbl rule.

DM10540

Error in movtbl(): Unable to GENGetGlbData('TblLstH',,).

Explanation

Programmer Response

DM10541

Error in movtbl(): No tables have been loaded. Hint: base rule LoadTblFiles may not be in the job file.

Explanation

During processing of the rule, MovTbl, it was determined that the TblFile file had not been loaded.

Programmer Response

Verify that the AFGJOB.JDT contains the following commands:

1. ;LoadTblFiles;1;;

2. ;CreateGlbVar;1;TblLstH,PVOID;

DM10542

Error in concatl(): Invalid RuleParms for concat:<Parms>. Data field requires 2 items (Key,FParm).

Explanation

The rule, ConCat, requires a minimum of two paired parameters.

1. Search mask offset and search mask.

2. Text string offset and length.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM10542: Error in ConCat(): Invalid RuleParms for ConCat:<11,PRODADREC>.

Data field requires 2 items (Key,FParm).

DM12051: Error in RPProcessOneField(): Unable to <CONCAT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<AGENT ADD1>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format for Data field

parameters in the ConCat rule..

DM10543

Error in concat(): Invalid number of parms in Data element.

Explanation

An invalid number of parameters were specified in the Data field for the rule ConCat.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image, and field with the problem.

Example:

DM10543: Error in ConCat(): Invalid number of parms in Data element.

DM12051: Error in RPProcessOneField(): Unable to <CONCAT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<INSURED NAME>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format for data field parameters in the rule ConCat.

DM10544

Error in moveext(): Bad or missing External Record for move_it external.

Explanation

The function, Move_It, could not find the extract record from which to extract data and returned an error to MoveExt.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10544: Error in MoveExt(): Bad or missing External Record for Move_It external.

DM12051: Error in RPProcessOneField(): Unable to <MOVEEXT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<MOVE IF EXISTS>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

DM12083: Error in RPProcessOneImage(): Unable to RPProcessFields(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS)

<q1ruldmo>. Skipping the rest of the Images for this form.

See INI group:< GenDataStopOn > option:ImageErrors.

Verify that the data field parameters exists and are defined correctly.

See the online Rules Reference for the correct format of the Data field

parameters for the MoveExt rule.

DM10545

Error in mnumext(): Bad or missing External Record for movenum external.

Explanation

Programmer Response

DM10546

Error in RunUsrFunc(): Unable to SetUsrFuncParms(pRPS->Field,parms). Invalid User Func parms in field rule data <Parms>.

Explanation

In base code, the '@" symbol is reserved for User Functions. For example: @getRecsUsed.

R&D advises that the following symbols should not be used: '@' and '?'

Note: The '@' symbol appears to be a universal character for XML.

Programmer Response

TIP: If you were to use the '@" symbol in your MoveNum Rule, base code would expect a user function to be defined following the symbol. If that is not the case, you could get the following errors reported in the error file:

DM11127: Error in SetUsrFuncParms(): Invalid number of parameters.

DM10546: Error in RunUsrFunc(): Unable to SetUsrFuncParms(&pRPS->Field,parms). Invalid User Func parms in field rule data <1,DOCUMENT[@TYPE="DocuCorp Universal" and @VERSION="5.0"]/DOCSET/TRANSACTIONID[@NAME="KEYID"]>.

DM10547

Error in RunUsrFunc(): Unable to GetUsrFuncData(parms,UsrRetVal).

Explanation

Programmer Response

DM10548

Error in setaddr2(): Invalid RuleParms for setaddr2:<Parms>. Data field requires 2 items (Key,FParm).

Explanation

The SetAddr2 DDT data field parameters are invalid. The data field requires two sets of paired parameters. The current DDT data field parameters are specified in the <Parm> portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image, and field that has the problem.

Example:

DM10548: Error in SetAddr2(): Invalid RuleParms for SetAddr2:<11,INSADRREC>.

Data field requires 2 items (Key,FParm).

DM12051: Error in RPProcessOneField(): Unable to <SETADDR2>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <altaddr1>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the SetAddr2 rule.

DM10549

Error in setaddr2(): Unable to compressln().

Explanation

The function, compressin, failed trying to compress the spaces in a line and returned an error to SetAddr2.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services

DM10550

Error in GeneralIf(): Unable to GetFieldRuleData().

Explanation

Programmer Response

DM10551

Error in GeneralIf(): Unable to ScanString(pRPS,<Script>,IF_PRE_SCAN).

Explanation

Programmer Response

DM10552

Info in GeneralIf(): Data to be passed to DALRunScript: <Script>.

Explanation

This LogFile message allows the user to view the data to be passed to DALRunScript. The data is specified in the Script portion of the message.

Programmer Response

This LogFile message allows the user to view the data to be passed to DALRunScript.

This information is only output to the LogFile when the INI group, < If_Rule >, and option Debug_If = Yes is present in the INI file. The default for this INI group/option is No.

For more information on INI Options, refer to the online INI Reference Guide.

DM10553

Error in GeneralIf(): Unable to DALRunScript(NULL,<Script>,,,).

Explanation

The function, DALRunScript, could not complete the parsing of the DAL script specified in the Script portion of the message and returned an error to GeneralIf.

Programmer Response

Review the DAL script contained in the If rule. Check for the following

items that could cause the script to have invalid syntax.

- missing colons between commands.

- missing parentheses

- incorrect abbreviations for a DAL command

This message is one in a group of related messages. Follow the message chain up to

locate a message that describes the error in more detail.

Example:

DM12042: Error in RPDALErrorNotify(): DAL library error: script:<>, lineno:<1>,

col:<82>, errnum:<13>, token:<End>, msg:<Invalid expression syntax>.

DM10553: Error in GeneralIf(): Unable to DALRunScript(NULL,,,,).

DM10554

Info in GeneralIf(): Result from running DALRunScript: <Result>.

Explanation

This LogFile message displays to the user the value, xxxxx, which resulted from running the DAL script.. The value is specified in the Result portion of the message.

Programmer Response

This LogFile message displays to the user the value, xxxxx, that resulted from executing the DAL script specified in the If rule.

This information is only output to the LogFile when the INI group, < If_Rule >, and option Debug_If = Yes is present in the INI file. The default for this INI group/option is No.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the If rule.

For more information on INI Options, refer to the online INI Reference Guide.

DM10555

Error in GeneralIf(): Unable to ScanString(pRPS,<Result>,IF_PRE_SCAN).

Explanation

Programmer Response

DM10556

Error in GeneralIf(): Unable to PerformFunction(pRPS,<Result>,iFunction).

Explanation

Programmer Response

DM10557

Error in GetFieldRuleData(): Unable to fopen(<File>,'r').

Explanation

The fopen function could not open for read mode the file, File, as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10558

Error in GetFieldRuleData(): Condition exceeds buffer length.

Explanation

Programmer Response

Use the statement CALL("logo.dal") instead of &logo.dal in your DDT file.

DM10559

Warning in GetData() from ScanString() from GeneralIf(): Unable to GENGetRecord(). Image <Image>, Field<Field>, Record<Record>, Occurance<Occurance>).

Explanation

This warning message was issued by the function, GENGetRecord, which could not find a record/occurrence in the transaction (being processed) that matched the search mask in the DAL script being executed. The image and field that contain the DAL script are specified in the Image and Field portion of the message. The search mask and occurrence number are specified in the Record and Occurrence portion of the message.

Programmer Response

Verify that the search mask in the DAL script matches the one in the expected record of the transaction. If not, correct the search mask.

Verify that the transaction has the same number of record/occurrences that match the search mask in the rule.

DM10560

Error in ovpgnum(): Invalid RuleParms for ovpgnum:<Parms>. Data field requires 2 items (form,sym).

Explanation

Programmer Response

DM10561

Error in ovpgnum2(): Call of ovpgnum from ovpgnum2 failed.

Explanation

Programmer Response

DM10562

Error in DateDiff(): Invalid parms for DateDiff. Data field requires 4 items (szSearch,iOffset,iLen,iFormat).

Explanation

A DateDiff rule has an invalid number of parameters. The data field requires 4 parameters separated by commas.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10562: Error in DateDiff(): Invalid parms for DateDiff. Data field requires 4 items

(szSearch,&iOffset,&iLen,&iFormat).

DM12051: Error in RPProcessOneField(): Unable to <DATEDIFF>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<NET DAYS>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask

and Data field parameters for the DateDiff rule.

DM10563

Error in DateDiff(): Unable to GENGetFieldDataExt(,,,).

Explanation

Programmer Response

DM10564

Error in DateDiff(): Unable to GEN_DATE_ConvertDate(<Date>,,<Format>).

Explanation

The function, GEN_Date_ConvertData, could not convert the date using the date format passed by DateDiff and returned an error to DateDiff. The date and format are specified in the <Date> and <Format> portion of the message.

The only valid formats that can be used in the RuleData field of the DateDiff rule are: 1, 7, 10, and 11.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to identifies the image and field that has the problem.

Example:

DM10564: Error in DateDiff(): Unable to GEN_DATE_ConvertDate(<030198>,,<9.8>).

DM12051: Error in RPProcessOneField(): Unable to <DATEDIFF>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<NET DAYS>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct FormatMask

and RuleData parameters for the DateDiff rule.

DM10565

Error in DateDiff(): Invalid format mask for DateDiff. Mask field requires 3 items seperated by spaces (iLeftSize,szSeparator,iRightSize).

Explanation

A DateDiff rule has an invalid format mask. The mask field requires 3 parameters separated by spaces.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM10565: Error in DateDiff(): Invalid format mask for DateDiff. Mask field requires

3 items separated by spaces (&iLeftSize,szSeparator,&iRightSize).

DM12051: Error in RPProcessOneField(): Unable to <DATEDIFF>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<NET DAYS>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask

and Data field parameters for the DateDiff rule.

DM10566

Error in DateDiff(): Invalid output format specified.

Explanation

An invalid output format was specified in the DateDiff rule. Only valid output format supported in the FormatMask field of the DateDiff rule is '1'.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image and field that has the problem.

Example:

DM10566: Error in DateDiff(): Invalid output format specified.

DM12051: Error in RPProcessOneField(): Unable to <DATEDIFF>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<NET DAYS>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct FormatMask

and RuleData parameters for the DateDiff rule.

DM10567

Error in compbin(): Illegal syntax, no length specified for offset <Offset>.

Explanation

No length was specified for the offset parameter in the rule CompBin.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifes image, and field with the problem.

Example:

DM10567: Error in CompBin(): Illegal syntax, no length specified for offset <104>.

DM12051: Error in RPProcessOneField(): Unable to <COMPBIN>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<COMPARE AND RETURN>. Processing will NOT continue for image

<q1ruldmo>. See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask

and Data field parameters for the CompBin rule.

DM10568

Error in compbin(): Unable to movenum(pRPS,msg).

Explanation

The rule, MoveNum, detected a problem iwith the parameters/data passed to it by the rule CompBin

Programmer Response

This message is one in a group of related messages. Follow the message chain up and down to locate a message that describes the error in more detail plus the image and field with the problem.

Example:

Error: Failed to parse the output Size and Percision. <>.

DM10473: Error in COMPBIN: Image<q1ruldmo> Field<COMPARE AND RETURN>

Unable to format for output.

DM10568: Error in CompBin(): Unable to MoveNum(pRPS,msg).

DM12051: Error in RPProcessOneField(): Unable to <COMPBIN>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<COMPARE AND RETURN>. Processing will NOT continue for image

<q1ruldmo>. See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask

and Data field parameters for the CompBin rule.

DM10569

Error in Function(): Invalid arguments.

Explanation

Programmer Response

DM10570

Error in compbin(): <Message>.

Explanation

Incorrect number of paired parameters defined for the rule CompBin.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field name that has the problem.

Example:

DM10570: Error in CompBin(): <==> incorrect parameters for field rule compbin.>.

DM12051: Error in RPProcessOneField(): Unable to <COMPBIN>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<COMPARE AND RETURN>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

DM12083: Error in RPProcessOneImage(): Unable to RPProcessFields(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS)

<q1ruldmo>. Skipping the rest of the Images for this form. See INI group:

< GenDataStopOn > option:ImageErrors.

See the online Rules Reference for the correct format of the Mask

and Data field parameters for the CompBin rule.

DM10571

Error in Rule(): Invalid or missing parameters for rule.

Explanation

The rule specified in the <Rule> portion of the message has invalid or missing parameters.

Programmer Response

See the online Rules Reference for the correct parameters for the rule specified in the <Rule> portion of the message.

DM10572

Error in Rule(): Empty RuleParms for rule.

Explanation

Programmer Response

DM10573

Error in Rule(): Invalid number of parms in Data element.

Explanation

The second part of data field parameters for the SetAddr2 rule has an invalid number of parameters. The parameters should be paired address information definitions; offset and length of data.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image, and field that has the problem.

Example:

DM10573: Error in setaddr2(): Invalid number of parms in Data element.

DM12051: Error in RPProcessOneField(): Unable to <SETADDR2>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <altaddr1>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the SetAddr2 rule.

DM10574

Error in Rule(): Mask is invalid for rule.

Explanation

The SetAddr2 rule mask field parameter is invalid. The only vaild parameter is 'F' or a blank.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image, and field that has the problem.

Example:

DM10574: Error in setaddr2(): Mask is invalid for rule.

DM12051: Error in RPProcessOneField(): Unable to <SETADDR2>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <altaddr1>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the SetAddr2 rule.

DM10575

Error in Function(): Invalid format mask.

Explanation

The function specified in the <Function> portion of the message has an invalid mask field parameter.

Programmer Response

See the online Rules Reference for the correct format of the Mask and Data field parameters for the rule specified in the <Function> portion of the message.

DM10576

Error in RCTSetRecipsFromTable(): Initial trigger for form <Form> contains a subordinate flag 'S', trigger cannot be subordinate to itself.

Explanation

Programmer Response

DM10577

Error in RCTSetRecipsFromTable :: failed to create image list.

Explanation

Programmer Response

DM10578

Error in RCTSetRecipsFromTable :: failed to initialize image hash list

Explanation

Programmer Response

DM10579

Error in RCTSetImageRecipCpyCnts(): Unable to GENAddFormToSet(pRPS,pRPS->CurrentFapFormsetH,<Form>,<GrpName1>,<GrpName2>,<GrpName3>,).

Explanation

Programmer Response

DM10580

Error in RCTSetRecipsFromTable(): Unable to GENAddFormToSet(pRPS,pRPS->CurrentFapFormsetH,<Form>,<GrpName1>,<GrpName2>,<GrpName3>,).

Explanation

Programmer Response

DM10581

Error in RCTSetRecipsFromTable :: RCTAddHashElem failed

Explanation

Programmer Response

DM10582

Error in RCTSetRecipsFromTable(): Unable to DSInsImgInSet(,,,,Form:<Form>,Image:<Image>,0).

Explanation

Programmer Response

DM10583

Error in RCTSetImageRecipCpyCnts(): Unable to GENAddFormToSet(pRPS,pRPS->CurrentFapFormsetH,<Form>,<GrpName1>,<GrpName2>,<GrpName3>,).

Explanation

Programmer Response

DM10584

Error in RCTSetRecipsFromTable(): Unable to DSDupImageInPlace(ImageH).

Explanation

Programmer Response

DM10585

Error in RCTSetRecipsFromTable(): Unable to FAPSplitPage(ImageH,NULL).

Explanation

Programmer Response

DM10586

Warning in RCTSetRecipsFromTable(): Initial trigger for form <Form> contains a"Same Form" flag, the flag will be ignored.

Explanation

Programmer Response

DM10587

Error in RCTSetRecipsFromTable(): Unable to GENAddFormToSet(pRPS,pRPS->CurrentFapFormsetH,<Form>,<GrpName1>,<GrpName2>,<GrpName3>,).

Explanation

The function, GENAddFormToSet, encountered an error trying to reference a form from group1/group2 in the form.dat and returned a error to RCTSetRecipFromTable. The form, group1, and group2 names are specified in the <Form>, <GrpName1>< and <GrpName1> portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain up and down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11075: Error in GENAddFormToSet(): pRPS->FormDatH == VMMNULLHANDLE.

Tip #1: Does base rules file have ;BuildMasterFormList;;4; as an entry?

DM10587: Error in RCTSetRecipsFromTable(): Unable to GENAddFormToSet

(pRPS,pRPS->CurrentFapFormsetH,<DEC PAGE>,<SAMPCO>,<LB1>,<>,).

Verify that the command ;BuildFormList;2;; exists in the in the AFGJOB.JDT.

DM10588

Error in RCTSetRecipsFromTable : RCTUpdateImageHashList failed

Explanation

Programmer Response

DM10589

Error in RCTSetRecipsFromTable(): Unable to FAPLocateGlbRecip(pRPS->CurrentFapFormsetH,<RecipName>). Compare SETRCPDAT Form:<Form> Image:<Image> Recipient:<RecipName> to INI group RECIP_NAMES.

Explanation

Programmer Response

DM10590

Error in RCTSetRecipsFromTable(): Unable to DSSetFormRecipsCopyCnt(InsertedFormH,NULL,<RecipName>,<CCount>).

Explanation

Programmer Response

DM10591

Error in RCTLoadSetRecipientTable(): pRPS->RecipientListH == VMMNULLHANDLE.

Explanation

Programmer Response

DM10592

Error in RCTLoadSetRecipientTable(): Unable to fseek(pRPS->fpSetRecipientFile, 0L, SEEK_SET).

Explanation

Programmer Response

DM10593

Error in RCTLoadSetRecipientTable(): Error parsing set recipient table, line number <TblLineNo>. ",

Explanation

Programmer Response

DM10594

Error in RCTLoadSetRecipientTable(): Unable to RCTGetFunctionPtr(pRPS,,<Function>).

Explanation

Programmer Response

DM10595

Error in RCTLoadSetRecipientTable(): pRPS->RecipientListH == VMMNULLHANDLE.

Explanation

Programmer Response

DM10596

Error in RCTLoadSetRecipientTable(): Error parsing set recipient table, line number <TblLineNo>.

Explanation

Programmer Response

DM10597

Error in RCTLoadSetRecipientTable(): Unable to RCTGetFunctionPtr(pRPS,,<Function>).

Explanation

Programmer Response

DM10598

Error in RCTLoadSetRecipientTable(): Unable to VMMAppendElem(,,).

Explanation

Programmer Response

DM10599

Error in RCTSaveSetRecipientTable(): Unable to write data.


DM10600 - DM10699 Messages

DM10600

Error in RCTSetImageRecipCpyCnts(): Unable to FAPLocateGlbRecip(pRPS->CurrentFapFormsetH,<RecipName>). Compare SETRCPDAT Form:<Form> Image:<Image> Recipient:<RecipName> to INI group RECIP_NAMES.

Explanation

Programmer Response

DM10601

Error in RCTSetImageRecipCpyCnts(): Unable to DSSetImageRecipsCopyCnt(InsertedImage,<RecipName>,<CCount>) Form:<Form> Image:<Image>.

Explanation

Programmer Response

DM10602

Warning in BaseInit1(): Unable to INIGetInitValue(<Data>,<DataPath>,,).

Explanation

The INI Group, < Data >, and the Option, DataPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10603

Error in BaseInit1(): Unable to GLBGetPtrFAPBaseH().

Explanation

Programmer Response

DM10604

Error in BaseInit1(): Unable to INIGetInitValue(<MasterResource>,<FormLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, FormLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10605

Error in BaseInit1(): Unable to INIGetInitValue(<Control>,<ImageExt>,,).

Explanation

The INI Group, < Control >, and the Option, ImageExt, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10606

Error in BaseInit1(): Unable to INIGetInitValue(<Control>,<LogoExt>,,).

Explanation

The INI Group, < Control >, and the Option, LogoExt, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10607

Error in BaseInit1(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10608

Error in BaseInit1(): Unable to INIGetInitValue(<Data>,<SetRcpTb>,,).

Explanation

The INI Group, < Data >, and the Option, SetRcpTb, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10609

Error in BaseInit1(): Unable to fopen(<AbsFName>,'r').

Explanation

The fopen function could not open for read mode the file, AbsFName, as specified in the error message.

Programmer Response

Verify that the file exist in the expected path/subdirectory. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10610

Error in BaseInit1(): Unable to INIGetInitValue(<Data>,<ExtrFile>,,).

Explanation

The INI Group, < Data >, and the Option, ExtrFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10611

Error in BaseInit1(): Unable to EXTInitXtr() for extract file:<ExtFile>.

Explanation

The function, EXTInitXtr, returned an error that caused this message to be output.

Programmer Response

Verify that the file exists in the expected subdirectory. Check the INI option, ExtrFile = , in the control group < Data >. If the file exists in the specified path/subdirectory, then verify that the file name matches the one in the INI option.

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11084: Error in EXTInitXtr(): Unable to GENOpenExtFile(<.\import\combfile>,).

DM10611: Error in BaseInit1(): Unable to EXTInitXtr() for extract file:

<.\import\combfile>.

DM10612

Error in BaseInit1(): Unable to INIGetInitValue(<Data>,<DbLogFile>,,).

Explanation

The INI Group, < Data >, and the Option, DbLogFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10613

Error in BaseInit1(): Unable to GENInitTrn(pRPS).

Explanation

The function, GENInitTrn(pRPS), returned an error to BaseInit.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11144: Error in GENInitTrn(): Unable to INIGetInitValue(<Data>,<NewTrn>,,).

DM10613: Error in BaseInit1(): Unable to GENInitTrn(pRPS).

DM10614

Error in BaseInit1(): Unable to INIGetInitValue(<Data>,<RcbDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, RcbDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10615

Error in BaseInit1(): Unable to DBInitDB().

Explanation

Programmer Response

DM10616

Error in BaseInit1(): Unable to RCBInit(<AbsFName>, AsciiDBHandlerH).

Explanation

The function, RCBInt, returned an error to BaseInit.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM13001: Error in RCBInit(): Unable to DBQueryFormatInfo(<.\deflib\RcbDfdFl.Dfd>).

DM10616: Error in BaseInit1(): Unable to RCBInit(<.\deflib\RcbDfdFl.Dfd>,

AsciiDBHandlerH).

Note: Verify that the file exist in the specified subdirectory. If the file exist,

then verify that the file name matches the one in the subdirectory and in the

INI group < Data >.

DM10617

Error in BaseInit1(): Unable to INIGetInitValue(<Data>,<NaFile>,,).

Explanation

The INI Group, < Data >, and the Option, NaFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10618

Error in BaseInit1(): Unable to fopen(<NAFile>,'w').

Explanation

The fopen function could not open the NAFile file for write mode and returned an error to BaseInit.

Programmer Response

Verify that the NAFile attributes have not been set to read, compressed, or sytem. If so, delete the NAFile and re-execute GENDATA step. If the problem still exists, save the Master Resource Library and submit to DAP support as a PCR.

DM10619

Error in BaseInit1(): Unable to INIGetInitValue(<Data>,<PolFile>,,).

Explanation

The INI Group, < Data >, and the Option, PolFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10620

Error in BaseInit1(): Unable to fopen(<POLFile>,'w').

Explanation

The fopen function could not open the POLFile file for write mode and returned an error to BaseInit.

Programmer Response

Verify that the POLFile attributes have not been set to read, compressed, or sytem. If so, delete the POLFile and

re-execute GENDATA step. If the problem still exists, save the Master Resource Library and submit to DAP support as a PCR.

DM10621

Error in BaseInit1(): Unable to DALInitialize().

Explanation

Programmer Response

DM10622

Error in BaseInit1(): Unable to GENInitDAL().

Explanation

Programmer Response

DM10623

Error in InitOvFlw(): Unable to InitOverFlow().

Explanation

Programmer Response

DM10624

Error in SetOvFlwSym(): Invalid RuleParms for SetOvFlwSym: <Parms>.

Explanation

Programmer Response

DM10625

Error in SetOvFlwSym(): Unable to add Overflow symbol: <Parms>.

Explanation

Programmer Response

DM10626

Error in BaseInit1(): Unable to RCBOpenPrintBatchFile(pRPS).

Explanation

The function, RCBOpenPrintBatchFile, returned an error to BaseInit.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM13018: Error in RCBOpenPrintBatchFiles(): Unable to INIFirstInitValue

(Print_Batches,NULL,,).

DM10626: Error in BaseInit1(): Unable to RCBOpenPrintBatchFile(pRPS).

DM10627

Error in SetOvFlwSym(): Overflow not initialized.

Explanation

The overflow symbols were not initialized via the base rules in the AFGJOB.JDT.

Programmer Response

Add the command ;InitOvFlw;1;; to your AFGJOB.JDT.

DM10628

Error in LoadTextTbl(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10629

Error in LoadTextTbl(): Unable to INIGetInitValue(<Data>,<TextTbl>,,).

Explanation

The INI Group, < Data >, and the Option, TextTbl, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10630

Error in LoadTextTbl(): Unable to GENGetGlbDataPtr('TXTLst', NULL).

Explanation

The function, GENGetGlbDataPtr, could not find a pointer to the global variable TxtLst and returned an error to LoadTextTbl.

Programmer Response

Verify that the AFGJOB.JDT contains the following commands:

1. ;CreateGlbVar;1;TXTLst,PVOID;

2. ;LoadTextTbl;1;;

DM10631

Error in LoadTextTbl(): Unable to GENGetGlbData('TXTLst',,).

Explanation

Programmer Response

DM10632

Error in LoadTextTbl(): TXTLst == VMMNULLHANDLE. Unable to GENLoadTextTable(<Table>).

Explanation

The function, GENLoadTextTable, could not find/open the TextTbl file in the specified subdirectory and returned an error to LoadTexTTbl.

Programmer Response

Verify that the file exist in the specified subdirectory. If the file exist in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

This message is one in a group of related messages. Follow the message chain up

to locate a message that describes the error in more detail.

Example:

DM11135: Error in GENLoadTextTable(): Unable to fopen(<.\deflib\TextTbl.Dat>, 'r').

DM10632: Error in LoadTextTbl(): TXTLst == VMMNULLHANDLE. Unable to

GENLoadTextTable(<.\deflib\TextTbl.Dat>).

DM10633

Error in LoadTextTbl(): Unable to GENGetGlbData('TXTLst',,).

Explanation

Programmer Response

DM10634

Error in LoadTextTbl(): Unable to GENGetGlbDataPtr('TXTLst').

Explanation

Programmer Response

DM10635

Error in LoadTblFiles(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file..

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10636

Error in LoadTblFiles(): Unable to INIGetInitValue(<Data>,<TblFile>,,).

Explanation

The INI Group, < Data >, and the Option, TblFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10637

Error in LoadTblFiles(): Unable to ReadDataTables(pRPS,<Table>)

Explanation

The function, ReadDataTables, could not find or open the TblFile file in the specified subdirectory and returned an error to LoadTblFiles.

Programmer Response

Verify that the file exist in the specified subdirectory. If the file exist in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10676: Error in ReadDataTables(): Unable to fopen(<.\deflib\TblFile.Dat>,'r').

DM10637: Error in LoadTblFiles(): Unable to ReadDataTables(pRPS,

<.\deflib\TblFile.Dat>)

DM10638

Error in LoadTblFiles(): Unable to GENGetGlbDataPtr('TblLstH',NULL).

Explanation

The function, GENGetGlbDataPtr, could not find a pointer to the global variable TblLstH and returned an error to LoadTblFiles.

Programmer Response

Verify that the AFGJOB.JDT contains the following commands:

1. ;CreateGlbVar;1;TblLstH,PVOID;

2. ;LoadTblFiles;1;;

DM10639

Error in LoadTblFiles(): Unable to GENGetGlbData('TblLstH',).

Explanation

Programmer Response

DM10640

Error in LoadTblFiles(): Unable to GENGetGlbDataPtr('TblLstH').

Explanation

Programmer Response

DM10641

Error in CreateGlbVar(): Invalid RuleParms in CreateGlbVar: <Parms> Data field requires at least 2 items (VariableName,VariableType,<VariableLen>).

Explanation

The AFGJOB.JDT rule CreateGlbVar requires an minimum of two parameters.

Programmer Response

See the Rules Reference for the parameters required by the CreateGlbVar rule.

DM10642

Error in CreateGlbVar(): Unable to GetGVMType(<VarType>). Invalid variable type for VariableName <VarName>.

Explanation

Programmer Response

DM10643

Error in CreateGlbVar(): Unable to GVMCreateVariable(<VarName>, GVM_SHORT).

Explanation

Programmer Response

DM10644

Error in CreateGlbVar(): Unable to GVMCreateData(,<VarName>,,,).

Explanation

Programmer Response

DM10645

Error in CreateGlbVar(): Unable to GVMCreateVariable(<VarName>, GVM_LONG).

Explanation

Programmer Response

DM10646

Error in CreateGlbVar(): Unable to GVMCreateData(,<VarName>,,,).

Explanation

Programmer Response

DM10647

Error in CreateGlbVar(): Empty szVarLen for CreateGlbVar.

Explanation

Programmer Response

DM10648

Error in CreateGlbVar(): Variable length must be greater than 0.

Explanation

Programmer Response

DM10649

Error in CreateGlbVar(): Unable to GVMCreateVariable(<VarName>, GVM_CHAR_ARRAY).

Explanation

Programmer Response

DM10650

Error in CreateGlbVar(): Unable to GVMCreateData(,<VarName>,,,).

Explanation

Programmer Response

DM10651

Error in CreateGlbVar(): Unable to GVMGetDataPtr(,<VarName>,,,,).

Explanation

Programmer Response

DM10652

Error in CreateGlbVar(): Unable to GVMCreateVariable(<VarName>, GVM_FLOAT).

Explanation

Programmer Response

DM10653

Error in CreateGlbVar(): Unable to GVMCreateData(,<VarName>,,,).

Explanation

Programmer Response

DM10654

Error in CreateGlbVar(): Unable to GVMCreateVariable(<VarName>, GVM_DOUBLE).

Explanation

Programmer Response

DM10655

Error in CreateGlbVar(): Unable to GVMCreateData(,<VarName>,,,).

Explanation

Programmer Response

DM10656

Error in CreateGlbVar(): Unable to GVMCreateVariable(<VarName>, GVM_LONG_DOUBLE).

Explanation

Programmer Response

DM10657

Error in CreateGlbVar(): Unable to GVMCreateData(,<VarName>,,,).

Explanation

Programmer Response

DM10658

Error in CreateGlbVar(): Unable to GVMCreateVariable(<VarName>, GVM_PVOID).

Explanation

Programmer Response

DM10659

Error in CreateGlbVar(): Unable to GVMCreateData(,<VarName>,,,).

Explanation

Programmer Response

DM10660

Error in CreateGlbVar(): Invalid RuleParms for CreateGlbVar:<Parms>. Data field requires 1 items (szVarName).

Explanation

Programmer Response

DM10661

Error in CreateGlbVar(): Unable to GVMDeleteVariable(,<VarName>).

Explanation

Programmer Response

DM10662

Error in SetErrBatch(): Empty RuleParms in SetErrBatch.

Explanation

Programmer Response

DM10663

Error in SetPowTypeBatch(): Empty RuleParms in SetPowTypeBatch.

Explanation

Programmer Response

DM10664

Error in LoadMasterFieldRules(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10665

Error in LoadMasterFieldRules(): Unable to DSLoadFieldRules(,<Name>).

Explanation

The DSLoadFieldRules function could not load the DDT file referenced by ddt_filename.

Programmer Response

Most likely cause is that the referenced DDT file name indicated does not exist. Check that the file exists. If, for example, the value of ddt_filename is <DEFLIB\master.ddt>, determine what the path value of DEFLIB is set to (in the INI file) and make sure the file named master.ddt is in that path.

Verify that the command ;JobInit1;1;; exists in the AFGJOB.JDT.

DM10666

Error in SetErrHdr(): Unable to GVMCreateVariable('errhdrlist',).

Explanation

Programmer Response

DM10667

Error in SetErrHdr(): Unable to VMMCreateList().

Explanation

Programmer Response

DM10668

Error in SetErrHdr(): Unable to GVMCreateData(,,,,).

Explanation

Programmer Response

DM10669

Error in SetErrHdr(): Unable to VMMAppendElem(hList,<Buff>,).

Explanation

Programmer Response

DM10670

Error in LoadListFromTable(): Invalid RuleParms in LoadListFromTable:<Parms>. Data field requires 3 items (GvmListName IniTableOption CommentCharacter).

Explanation

Programmer Response

DM10671

Error in LoadListFromTable(): Unable to GEN_TABUTIL_LoadListFromTable(<Option>,<Comment>).

Explanation

Programmer Response

DM10672

Error in LoadListFromTable(): Unable to GVMCreateVariable(<Buff>, GVM_PVOID).

Explanation

Programmer Response

DM10673

Error in LoadListFromTable(): Unable to GVMCreateData(,,,,).

Explanation

Programmer Response

DM10674

Error in LoadListFromTable(): Invalid RuleParms in LoadListFromTable:<Parms>. Data field requires 3 items (GvmListName IniTableOption CommentCharacter).

Explanation

Programmer Response

DM10675

Error in ReadDataTables(): Unable to VMMCreateList().

Explanation

Programmer Response

DM10676

Error in ReadDataTables(): Unable to fopen(<Name>,'r').

Explanation

The fopen function could not find or open the file specified in the error message and returned an error to ReadDataTables.

Programmer Response

Verify that the file exist in the specified subdirectory. If the file exist in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

DM10677

Error in ReadDataTables(): Unable to fopen(<Table>, 'r').

Explanation

The fopen function could not find or open the table file name specified in the <Tabe> portion of the message and returned an error to ReadDataTables.

Programmer Response

Verify that the table file exists in the specified subdirectory. If the table exists in the specified subdirectory, then verify that the table name matches the one defined in the TblFile.

DM10678

Error in ReadDataTables(): Unable to VMMAppendElem(DataTblH,<Buff>,).

Explanation

Programmer Response

DM10679

Error in BuildMasterFormList(): Unable to INIGetInitValue('MasterResource','DefLib',,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10680

Error in BuildMasterFormList(): Unable to INIGetInitValue('MasterResource','FormDef',,).

Explanation

The INI Group, < MasterResource >, and the Option, FormDef, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10681

Error in BuildMasterFormList(): Unable to fopen(<Temp>,'r').

Explanation

The fopen function could not find or open the file specified in the error message and returned an error to BuildMasterFormList.

Programmer Response

Verify that the file exist in the specified subdirectory. If the file exist in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

DM10682

Error in BuildMasterFormList(): Unable to VMMCreateList() for pRPS->FormDatH.

Explanation

Programmer Response

DM10683

Error in BuildMasterFormList(): Unable to VMMInsOrdElem(pRPS->FormDatH,<Buff>,,).

Explanation

Programmer Response

DM10684

Error in FormDatCompareFunction(): pszEnda or pszEndb is null.

Explanation

Programmer Response

DM10685

Warning in RULStandardFieldProc(): Unable to FMTValBarcode(<OutBuff>,<Buff>,<Format>) returned FmtErr. Processing will continue...

Explanation

Programmer Response

DM10686

Error in RULStandardTransactionProc(): Unable to GENGetNextTrnSet().

Explanation

Programmer Response

DM10687

Error in RULStandardTransactionProc(): Unable to SetOffsets(pRPS).

Explanation

Programmer Response

DM10688

Error in RULStandardTransactionProc(): Unable to PurgeOutput(pRPS).

Explanation

Programmer Response

DM10689

Error in RULStandardTransactionProc(): Unable to GENUpdateTrnRec().

Explanation

Programmer Response

DM10690

Error in RULStandardTransactionProc(): Unable to RULUpdateRecips().

Explanation

The rule RULUpdateRecips returned an error to the function RULStandardTransactionProc.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10749: Error in RULUpdateRecips(): Unable to RCBMatchRecipient(<INSURED>).

Tip: Check base rules file for this recipient in rule IfRecipUsed.

DM10690: Error in RULStandardTransactionProc(): Unable to RULUpdateRecips().

DM10691

WARNING: YOU ARE RUNNING IN TEST MODE!!! --> See INI group < Test > for details.

Explanation

Programmer Response

DM10692

Error in LoadExtractData(): Unable to EXTLoadXtrRecs().

Explanation

Programmer Response

DM10693

Error in GetGroupName1(): Data field <Buff> requires 3 items (FmtMask Offset,Size). PUT A SPACE BETWEEN FmtMask AND Offset!!!

Explanation

Programmer Response

DM10694

Error in GetGroupName1(): Unable to GENGetRecord(pRPS->ExtractListH,<Pointer>,).

Explanation

The function, GENGetRecord, encountered an problem and returned an error to GetGroupName1.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail.

Example:

DM10694: Error in GetGroupName1(): Unable to GENGetRecord

(pRPS->ExtractListH,<11,HEADERREC>,).

DM12018: Error in RPDoBaseFormsetRulesForward(): Unable to <GETCO>().

1. Verify the correctness of the parameters associated with the GetCo command in the AFGJOB.JDT.

See the Rules Reference for the required parameters for the command GetCo.

2. Verify that the command ;LoadExtractData;;; exists in the AFGJOB.JDT

DM10695

Error in GetGroupName1(): Unable to INIGetInitValue(<Key1Table>,<GrpName1>,,).

Explanation

The INI Group, < Key1Table >, and the Option, GrpName1, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10696

Error in GetGroupName2(): Data field <Buff> requires 3 items (FmtMask Offset,Size). PUT A SPACE BETWEEN FmtMask AND Offset!

Explanation

Programmer Response

DM10697

Error in GetGroupName2(): Unable to GENGetRecord(pRPS->ExtractListH,<%s>,).

Explanation

The function, GENGetRecord, encountered an problem processing the parameters associated with the GetLOB command and returned an error to GetGroupName2.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail.

Example:

DM10697: Error in GetGroupName2(): Unable to GENGetRecord(pRPS->ExtractListH,<%s>,).

DM12018: Error in RPDoBaseFormsetRulesForward(): Unable to <GETLOB>().

Verify the correctness of the parameters associated with the GetLOB command in the AFGJOB.JDT. See the online Rules Reference for the required parameters for the command GetLOB.

DM10698

Error in GetGroupName2(): Unable to INIGetInitValue(<Key2Table>,<GrpName2>,,).

Explanation

The INI Group, < Key2Table >, and the Option, GrpName2, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10699

Error in &function&(): Unable to FAPCreateFormset(,,<Buff>).

Explanation

The function, FAPCreateFormset, was passed an invalid parameter or failed to create a new form set and returned an error to the function specified in the function portion of the message. The form set name is specified in the Buff portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.


DM10700 - DM10799 Messages

DM10700

Error in BuildFormList(): Unable to RCBUpdateGlbRecips(pRPS).

Explanation

The function, RCBUpdateGlbRecips, encountered a problem with the INI group < Recip_Names > and returned an error to BuildFormList.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM13021: Error in RCBUpdateGlbRecips(): Value of INI group:'RECIP_NAMES' option:*

should not be blank.

DM10700: Error in BuildFormList(): Unable to RCBUpdateGlbRecips(pRPS).

DM10701

Error in BuildFormList(): Unable to FAPFlushFormset().

Explanation

Programmer Response

DM10702

Warning in BuildFormList(): No extract records. VMMCountList(pRPS->ExtractListH) = 0. Processing will continue.

Explanation

The BuildFormList function did not find any extract records to process for the formset.

Programmer Response

If you are executing Batch single-step mode processing; verify that the rule, NoGenTrnTransactionProc exists in the AFGJOB.JDT.

DM10703

Error in LoadRcpTbl(): Unable to RCTLoadSetRecipientTable(pRPS).

Explanation

Programmer Response

DM10704

Error in RunSetRcpTbl(): Unable to RCTSetRecipsFromTable().

Explanation

The function, RCTSetRecipFromTable, returned an error to RunSetRcpTbl.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11075: Error in GENAddFormToSet(): pRPS->FormDatH == VMMNULLHANDLE.

Tip #1: Does base rules file have ;BuildMasterFormList;1;4; as an entry?

DM10587: Error in RCTSetRecipsFromTable(): Unable to GENAddFormToSet

(pRPS,pRPS->CurrentFapFormsetH,<DEC PAGE>,<SAMPCO>,<LB1>,<>,).

DM10704: Error in RunSetRcpTbl(): Unable to RCTSetRecipsFromTable().

DM10705

Error in RunSetRcpTbl(): Unable to DSDelZeroCopyForms(pRPS->CurrentFapFormsetH,<GrpName1>,<GrpName2>,(GrpName3),0L).

Explanation

Programmer Response

DM10706

Error in UpdatePOLFile(): Unable to FAPPaginateForm(formH).

Explanation

Programmer Response

DM10707

Error in UpdatePOLFile(): Unable to RULLoadImage() for <Image>.

Explanation

Programmer Response

DM10708

Error in UpdatePOLFile(): Unable to FAPPropogateFormFields(formH).

Explanation

Programmer Response

DM10709

Error in UpdatePOLFile(): Unable to DSBuildPOLDocSet().

Explanation

An error occurred while writing to the POLFILE file. This file is named using the INI option <Data> PolFile=. Two of the errors that the DM10709 error normally indicates are 1) the file you are writing to is out of space or 2) a record you are writing is too long for the pre-defined record length of the file (this latter error usually occurs only on OS/390).

Programmer Response

The DM10709 message might be accompanied by one or more DM12041 messages in the ERRFILE. If so, see the DM12041 error message for a more detailed explanation on the cause of the problem. Otherwise, if running on OS/390 (MVS or z/OS), check your job log for an abend code. The GENDATA program may have abended with a B37, D37, or E37 code because the POLFILE was running out of space. To resolve this abend error, increase the SPACE parameters for the POLFILE in the GENDATA execution step of your JCL.

DM10710

Error in UpdatePOLFile(): Unable to GENUpdateTrnRec().

Explanation

Programmer Response

DM10711

Error in UpdatePOLFile(): Unable to RULUpdateRecips().

Explanation

Programmer Response

DM10712

Error in PaginateAndPropogate :: Unable to FAPPaginateForm(formH).

Explanation

Programmer Response

DM10713

Error in PaginateAndPropogate :: Unable to RULLoadImage() for <Image>.

Explanation

Programmer Response

DM10714

Error in PaginateAndPropogate :: Unable to FAPPropogateFormFields( formH ).

Explanation

Programmer Response

DM10715

Error in WriteOutput(): Unable to DSBuildPOLDocSet().

Explanation

Programmer Response

DM10716

Error in WriteOutput(): Unable to GENUpdateTrnRec().

Explanation

Programmer Response

DM10717

Error in AssignToBatch(): Invalid print batch <Buff>.

Explanation

Programmer Response

DM10718

Error in DumpExtractListToFile(): Empty RuleParms in DumpExtractListToFile.

Explanation

Programmer Response

DM10719

Error in DumpExtractListToFile(): Unable to fopen(<Name>,'w').

Explanation

The fopen function could not open in write mode the file Name as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10720

Error in DumpExtractListToFile(): Empty RuleParms in DumpExtractListToFile.

Explanation

Missing a parameter(s) from the rule DumpExtracListToFile in the AFGJOB.JDT.

Programmer Response

Check the parameters specified on the DumpExtracListToFile rule in the AFGJOB.JDT.

The rule, DumpExtracListToFile, requires two parameters.

1. FileName The filename where the extract list is to be dumped.

2. Flag Y = append the extract data to the existing file;

N = write the extract data to an empty file (overwrite existing

contents).

DM10721

Error in DumpExtractListToFile(): Unable to DumpVmmListToFile(pRPS,pRPS->ExtractListH,<Name>,<Flag>).

Explanation

Programmer Response

DM10722

Error in AssignBatWithTbl(): Unable to fopen(<Name>,<r>).

Explanation

The fopen function could not open in read mode the file Name as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10723

Error in AssignBatWithTbl(): Unable to CheckRecipients(pRPS,pRPS->Base,<RP_PRE_PROC_A>,<Parms>).

Explanation

Programmer Response

DM10724

Error in AssignBatWithTbl(): Unable to VMMCreateList().

Explanation

Programmer Response

DM10725

Error in AssignBatWithTbl(): Data field <Buff> requires 3 items (BatchName,SearchMask,RecipName).

Explanation

Programmer Response

DM10726

Error in AssignBatWithTbl(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM10727

Error in AssignBatWithTbl(): No default batch specified in batch assignment file.

Explanation

Programmer Response

DM10728

Error in AssignBatWithTbl(): Unable to GetRecipients(pRPS,<Parms>,<List>).

Explanation

Programmer Response

DM10729

Error in AppendGblToExtr(): Empty RuleParms in AppendGblToExtr.

Explanation

Programmer Response

DM10730

Error in AppendGblToExtr(): Unable to GVMGetDataPtr(VMMNULLHANDLE,<Temp>,,,,).

Explanation

Programmer Response

DM10731

Error in SetRecipCopyCount(): Empty RuleParms in SetRecipCopyCount.

Explanation

Programmer Response

DM10732

Error in SetRecipCopyCount(): Empty RuleParms in SetRecipCopyCount.

Explanation

Programmer Response

DM10733

Error in SetRecipCopyCount2(): Empty RuleParms in SetRecipCopyCount2.

Explanation

Programmer Response

DM10734

Error in SetRecipCopyCount2(): Empty RuleParms in SetRecipCopyCount2.

Explanation

Programmer Response

DM10735

Error in Ext2Gvm(): Empty RuleParms in Ext2Gvm.

Explanation

Programmer Response

DM10736

Error in Ext2Gvm(): Empty RuleParms in Ext2Gvm.

Explanation

Programmer Response

DM10737

Error in Ext2Gvm(): Empty RuleParms in Ext2Gvm.

Explanation

Programmer Response

DM10738

Error in Ext2Gvm(): Unable to GENGetRecord(pRPS,pRPS->ExtractListH,<12,INSNAMREC>,0).

Explanation

When executing the rule, Ext2GVM, a record could not be found in the transaction being processed that matches the search mask indicated in the error message field <Mask>.

Programmer Response

Verify that the transaction being processed does not contain a record that matches the search mask.

Tip

If each transaction will not have a record that matches the search mask defined in the Ext2GVM rule, then use the SuppressFlag on the Ext2GVM rule.

Example: ;Ext2GVM;;11,Rec 40,10,S;

1. Check the extract file to make sure that the search criteria is correct. In our example, the search criteria should have been

<11,INSNAMREC>.

2. If you want to suppress the error message, please apply "S" flag to this rule. Refer to "Rule Reference" book.

DM10739

Error in Ext2Gvm(): Unable to GENGetGlbDataPtr(<Pointer>, NULL).

Explanation

Programmer Response

DM10740

Error in DumpExtList(): Unable to DumpList(pRPS,<Parms>).

Explanation

Programmer Response

DM10741

Error in RULUpdateRecips(): Unable to GENGetGlbDataPtr('RCBPrtFlag',).

Explanation

The problem is in the RCBDFDFL.DFD file, which is missing this field RCBPrtFlag.

The problem is in the RCBDFDFL.DFD file, which is missing or mispelled. There are four required fields that must be correctly defined in the RCBDFDFL.DFD file: RCBZip RCBPrtFlag, RCBError, RCBRcpCode.

You may revie the sample master resource libraries for examples of how to define these variables.

Programmer Response

DM10742

Error in RULUpdateRecips(): Unable to GENGetGlbDataPtr('RCBError',).

Explanation

The problem is in the RCBDFDFL.DFD file, which is missing this field RCBError .

The problem is in the RCBDFDFL.DFD file, which is missing or mispelled. There are four required fields that must be correctly defined in the RCBDFDFL.DFD file: RCBZip RCBPrtFlag, RCBError, RCBRcpCode.

You may revie the sample master resource libraries for examples of how to define these variables.

Programmer Response

DM10743

Error in RULUpdateRecips(): Unable to VMMCreateList() for outlistH.

Explanation

Programmer Response

DM10744

Error in RULUpdateRecips(): Unable to VMMInsOrdElem(outlistH,,,).

Explanation

Programmer Response

DM10745

Error in RULUpdateRecips(): GlobalRecip.code:<Code> is invalid for GlobalRecip.name:<Name>. You may be flushing too much of the formset.

Explanation

Programmer Response

DM10746

Error in RULUpdateRecips(): Unable to GENGetGlbDataPtr('RCBRcpCode',).

Explanation

The problem is in the RCBDFDFL.DFD file, which is missing this field RCBRcpCode.

The problem is in the RCBDFDFL.DFD file, which is missing or mispelled. There are four required fields that must be correctly defined in the RCBDFDFL.DFD file: RCBZip RCBPrtFlag, RCBError, RCBRcpCode.

You may revie the sample master resource libraries for examples of how to define these variables.

Programmer Response

DM10747

Error in RULUpdateRecips(): Unable to RCBMatchPrintBatch('ERROR').

Explanation

The INI Group, < Print_Batches >, and the Option, Error, could not be found in the INI file

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

In addition, check for the presents of other related INI groups and options.

Example:

< Print_Batches >

Error = Error.bch

< Error >

Printer = Printer4

< Printer4 >

Port = .\data\ErrorBat

< PrinterInfo >

Printer = Printer4

DM10748

Error in RULUpdateRecips(): Unable to RCBMatchPrintBatch('MANUAL').

Explanation

Programmer Response

Tip: Check the Print_Batches group. You must define the batches used in this group to avoid this error.

For example:

<Print_Batches>

Manual = manual.bch

DM10749

Error in RULUpdateRecips(): Unable to RCBMatchRecipient(<Name>). Tip: Check base rules file for this recipient in rule IfRecipUsed.

Explanation

The function, RCBMatchRecipient, could not match the recipient name in the INI group < Recip_Names > with the one on the IfRecipUsed rule in the AFGJOB.JDT and returned an error to RULUpdateRecips.

Programmer Response

Verify that the recipient name(s) used on the IfRecipUsed rule(s) in the AFGJOB.JDT match those in the INI group < Recip_Names > in the INI file.

Tip: In the event you use the BatchingByRecipINI rule, check the AFGJDT file to ensure the BatchingByRecipINI rule is listed after the RunSetRcpTbl rule.

DM10750

Error in RULUpdateRecips(): Unable to RCBAddRec(fp) to print batch file.

Explanation

Programmer Response

DM10751

Error in RULUpdateRecips(): Unable to GENGetGlbDataPtr('RCBPrtFlag',).

Explanation

Programmer Response

DM10752

Error in RULUpdateRecips(): Unable to GENGetGlbDataPtr('RCBError',).

Explanation

Programmer Response

DM10753

Error in RULWriteBCHRec(): GlobalRecip code:<Code> is invalid for GlobalRecip:<Name>. You may be flushing too much of the formset.

Explanation

Programmer Response

DM10754

Error in RULWriteBCHRec(): Unable to GENGetGlbDataPtr('RCBRcpCode',).

Explanation

Programmer Response

DM10755

Error in RULUpdateRecips(): Unable to RCBMatchPrintBatch('ERROR').

Explanation

Programmer Response

DM10756

Error in RULUpdateRecips(): Unable to RCBMatchPrintBatch('MANUAL').

Explanation

Programmer Response

DM10757

Error in RULUpdateRecips(): Unable to RCBMatchRecipient(<Name>). Tip: Check base rules file for this recipient in rule IfRecipUsed.

Explanation

Programmer Response

DM10758

Error in RULUpdateRecips(): Unable to RCBAddRec(fp) to print batch file.

Explanation

Programmer Response

DM10759

Error in DumpVmmListToFile(): Unable to fopen(<Name>,<Buff>).

Explanation

The fopen function could not open for xxxxx mode the file yyyyy. The file name and mode, respectively, are specified in Nameand Buff of the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10760

Error in DumpVmmListToFile(): Unable to VMMMalloc()(Length).

Explanation

Programmer Response

DM10761

Error in DumpVmmListToFile(): Unable to fwrite(<Buff>, 1, ElemLen, pFile).

Explanation

Programmer Response

DM10762

Error in GetRecipients(): Data field <Data> requires 3 items (Condition,RecipTRUE,RecipFALSE).

Explanation

Programmer Response

DM10763

Error in GetRecipients(): Data field <Temp> requires 3 items (Condition,RecipTRUE,RecipFALSE).

Explanation

Programmer Response

DM10764

Error in CheckRecipients(): Data field <Data> requires 3 items (?,RecipTRUE,RecipFALSE).

Explanation

Programmer Response

DM10765

Error in CheckRecipients(): Data field <Temp> requires 3 items (?,RecipTRUE,RecipFALSE).

Explanation

Programmer Response

DM10766

Error in CheckRecipients(): Unable to INIGetInitValue(<RECIP_NAMES>,<Temp>,,).

Explanation

The INI Group, < Recip_Names >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Temp portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10767

Error in DumpList(): Unable to fopen(<Name>,'w').

Explanation

The fopen function could not open for write mode the file Name as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM10768

Error in DumpList(): Unable to VMMMalloc()(Length).

Explanation

Programmer Response

DM10769

Error in RULUpdatePrintRequestRow(): Unable to GENUpdatePrintRequestRow(pRPS,<Code>).

Explanation

Programmer Response

DM10770

Error in ResetOvFlw(): Unable to ResetOverflow().

Explanation

Programmer Response

DM10771

Error in PurgeOutput(): Unable to DSUnloadNAFormset(,,).

Explanation

An error occurred while writing to the NAFILE file. This file is named using the INI option <Data> NaFile=. Two of the errors that the DM10771 error normally indicates are 1) the file you are writing to is out of space or 2) a record you are writing is too long for the pre-defined record length of the file (this latter error usually occurs only on OS/390).

Programmer Response

The DM10771 message should be accompanied by one or more DM12041 messages in the ERRFILE. See the DM12041 error message for a more detailed explanation on the cause of the problem.

DM10772

Error in SetOffsets(): Unable to ftell(pRPS->fpNAFile).

Explanation

The user has reached the 2 GB limit for the offset value to the NAFILE.

Programmer Response

DM10773

Error in SetOffsets(): Unable to ftell(pRPS->fpPOLFile).

Explanation

Programmer Response

DM10774

*** Redirected for ERROR handling *** *** Review error file for reasons ***.

Explanation

Programmer Response

DM10775

*** Redirected for MANUAL handling *** *** Review WIP Status ***

Explanation

Programmer Response

DM10776

Transaction: ID-GrpName1-GrpName2-GrpName3-Buff.

Explanation

Programmer Response

DM10777

RULAllocDebug Buff number of allocs Temp number of free's CCount new max Data.

Explanation

This LogFile message informs the user that the function (xxxxx) during processing allocated (yyyyy) bytes of memory, freed (zzzzz) bytes of memory, and has nnnnn bytes still allocated. The function name (xxxxx), allocated bytes (yyyyy), freed bytes (zzzzz), and remaining allocated bytes (nnnnn) are specified in the Buff, Temp, CCoun , and Data portions of the message.

Programmer Response

This is a LogFile message is use can be used to find cumulative memory allocations, not reported as leaks.

This information is only output to the LogFile when the rule AllocDebug is included in the AFGJOB.JDT.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the AllocDebug rule.

DM10778

Error in srchloop(): Parameter error.

Explanation

Programmer Response

DM10779

Error in srchloop(): Parameter error.

Explanation

Programmer Response

DM10780

Error in srchloop(): Unable to GENGetRecord(,,).

Explanation

Programmer Response

DM10781

Error in srchloop(): Unable to get loop count.

Explanation

Programmer Response

DM10782

Error in facdtl_1(): Invalid arguments.

Explanation

Programmer Response

DM10783

Error in facdt_1(): Unable to VMMCreateList().

Explanation

Programmer Response

DM10784

Warning in facdtl_1(): A previous transaction failed to complete processing. Previous transaction's data destroyed. New data will be created anyway. Processing will continue.

Explanation

Programmer Response

DM10785

Error in facdtl_1(): Unable to GVMCreateVariable(<List>, GVM_PVOID).

Explanation

Programmer Response

DM10786

Error in facdtl_1(): Unable to GVMCreateData(,<%s>,,,).

Explanation

Programmer Response

DM10787

Error in facdtl_2(): Invalid arguments.

Explanation

Programmer Response

DM10788

Error in facdtl_2(): Unable to VMMCreateList().

Explanation

Programmer Response

DM10789

Warning in facdtl_2(): A previous transaction failed to complete processing. Previous transaction's data destroyed. New data will be created anyway. Processing will continue.

Explanation

Programmer Response

DM10790

Error in facdtl_2(): Unable to GVMCreateVariable(<List>, GVM_PVOID).

Explanation

Programmer Response

DM10791

Error in facdtl_2(): Unable to GVMCreateData(, <%s>,,,).

Explanation

Programmer Response

DM10792

Error in recipif(): Unable to GeneralIf(). Image <Image>.

Explanation

Programmer Response

DM10793

Error in RULStandardImageProc(): Unable to SetNextImage(pRPS).

Explanation

Programmer Response

DM10794

Error in RULStandardImageProc(): Unable to DSLoadDefTable(pRPS,FIELD_TABLE_TYPE,<Name>).

Explanation

The function, DSLoadDefTable(pRPS,FIELD_TABLE_TYPE, could not find or open the file specified in the < Name >( ) portion of the message and returned an error to RULStandardImageProc().

Programmer Response

Verify that the file exist in the specified path/subdirectory. If the file exist in the specified path/subdirectory, then verify that the file name matches the one in the subdirectory and in the error message.

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs():

Unable to open definition file .\ddtlib\q1snam.DDT.>.

DM10794: Error in RULStandardImageProc(): Unable to DSLoadDefTable

(pRPS,FIELD_TABLE_TYPE, <.\ddtlib\q1snam.DDT>).

DM10795

Error in RULStandardImageProc(): Unable to RULLoadImage(pRPS).

Explanation

The function, RULLoadImage, was unable to load an image and return an error to RULStandardImageProc.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10802: Error in RULLoadImage(): Unable to FAPLoadImage(ImageH,<.\q1snam.FAP>,

FAPImageLoader(), OBJ_FIELDS).

DM10795: Error in RULStandardImageProc(): Unable to RULLoadImage(pRPS).

DM10796

Error in RULStandardImageProc(): Unable to RULMultiPageCheck(pRPS) for image <Image>.

Explanation

Programmer Response

DM10797

&Type& in SetNextImage(): No forms for current transaction. FAPTotalForms(pRPS->CurrentFapFormsetH) < 1). Processing will continue.

Explanation

No forms or images were triggered for the current transation.

This can be a Warning or Error depending on the ErrorFormsetEmpty INI option in the GenDataStopOn group.

Programmer Response

Verify that the:

1. command ;LoadRcpTbl;;; exists in the AFGJOB.JDT.

2. command ;RunSetRcpTbl;;; exists in the AFGJOB.JDT.

DM10798

Error in SetNextImage(): Unable to WriteNALine(,POL_ENDFORM,,).

Explanation

Programmer Response

DM10799

Error in SetNextImage(): CheckForEjectPage returned failure.


DM10800 - DM10899 Messages

DM10800

Error in SetNextImage(): Unable to WriteNALine(,POL_ENDFORM,,).

Explanation

Programmer Response

DM10801

Error in SetNextImage(): Unable to WriteNALine(,,POL_ENDFORM,,).

Explanation

Programmer Response

DM10802

Error in RULLoadImage(): Unable to FAPLoadImage(ImageH,<Image>, FAPImageLoader(), OBJ_FIELDS).

Explanation

The function, FAPLoadImage, could not find or load the image specified in the <Image> portion of the message and returned an error to RULLoadImage.

Programmer Response

Verify that the image file exist in the subdirectory specified by the INI group/option; < MasterResource > FormLib =.

If the file exist in the specified subdirectory, then verify that the file name extension matches one the

INI group < Data > ImageExt =.

Verify that the subdirectory name specified by the INI group/option; < MasterResource > FormLib = matches the one created in the MRL.

DM10803

Error in LoadFieldRuleData(): Unable to RULLoadImage(pRPS).

Explanation

Programmer Response

DM10804

Error in RULCreateField(): Unable to FAPCreateField(pRPS->CurrentFapImageH,VMMNULLHANDLE,<Name>,FALSE).

Explanation

Programmer Response

DM10805

Error in CheckForEjectPage(): The Multipage image <Image> must have the EjectPage rule included in its ddt file for each instance of an image, except the last.

Explanation

Programmer Response

DM10806

File Name does not use fixed record format.

Explanation

Programmer Response

DM10807

File Name does not use variable record format.

Explanation

Programmer Response

DM10808

File Name does not use standard record format.

Explanation

Programmer Response

DM10809

File Name does not use spanned record format.

Explanation

Programmer Response

DM10810

File Name does not use undefined record format.

Explanation

Programmer Response

DM10811

File Name is not blocked.

Explanation

Programmer Response

DM10812

File Name is not a VSAM file.

Explanation

Programmer Response

DM10813

File Name is not a KSDS VSAM file.

Explanation

Programmer Response

DM10814

File Name is not a KSDS PATH VSAM file.

Explanation

Programmer Response

DM10815

File Name is not an ESDS VSAM file.

Explanation

Programmer Response

DM10816

File Name is not an ESDS PATH VSAM file.

Explanation

Programmer Response

DM10817

File Name is not an RSDS VSAM file.

Explanation

Programmer Response

DM10818

Info in GeneralIf(): Condition data: <Script>.

Explanation

This LogFile message displays the condition data in the If rule. The condition data are specified in the Script portion of the message.

Programmer Response

This LogFilemessage allows the user to view the condition data in the If rule.

This information is only output to the LogFile when the INI group, < If_Rule >, and option Debug_If = Yes is present in the INI file. The default for this INI group/option is No.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the If rule.

For more information on INI Options, refer to the online INI Reference Guide.

DM10819

Info in GeneralIf(): Nothing returned from DALRunScript. Skipping field.

Explanation

The DAL script that was executed did not return a value to the GeneralIf rule.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Info in GeneralIf(): Condition data: <X=' '::if (X = ' ' AND X != ' ')::

return("^" & 1 & "^")::else return::End>.

Info in GeneralIf(): Data to be passed to DALRunScript: <X=' '::

if (X = ' ' AND X != ' ')::return("^" & 1 & "^")::else return::End>.

Info in DebugDAL(): Filename:<> Lineno:<1> Token:<X>

Info in DebugDAL(): Filename:<> Lineno:<1> Token:<if>

Info in DebugDAL(): Filename:<> Lineno:<1> Token:<return>

Info in GeneralIf(): Result from running DALRunScript: <>.

Info in GeneralIf(): Nothing returned from DALRunScript. Skipping field.

Review the DAL script to determine why data was not returned from DALRunScript.

Modify the script as necessary.

DM10820

Info in GeneralIf(): pRPS->OutBuff:<OutBuff>.

Explanation

This LogFile message displays the value, xxxxx, that was placed in the output buffer specified in the If rule. The value is specified in the OutBuffer portion of the message.

Programmer Response

This LogFile message allows the user to view the value, xxxxx, that was placed in the output buffer specified in the If rule.

This information is only output to the LogFile when the INI group, < If_Rule >, and option Debug_If = Yes is present in the INI file. The default for this INI group/option is No.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the If rule.

For more information on INI Options, refer to the online INI Reference Guide.

DM10821

Info in DebugDAL(): Filename:<Name> Lineno:<LineNo> Token:<Tok>

Explanation

This LogFile message informs the user which file (xxxxx), line number (nnnnn), and token (yyyyy) were processed. The file name, line number, and token parameters are specified in the Name, Name, and Name portions of the message.

Programmer Response

This LogFile message allows the user to view which DAL statement(s) in theIf rule were executed. Useful information if the DAL script has an error.

This information is only output to the LogFile when the INI group, < If_Rule >, and option Debug_If = Yes is present in the INI file. The default for this INI group/option is No.

See the online DAL Reference Guide for the correct field parameters for the DAL rules.

For more information on INI Options, refer to the online INI Reference Guide.

DM10822

Error in CheckImageLoaded(): Unable to RULLoadlmage() for <Image>

Explanation

The function, RulLoadImage could not find/load the image specified in the <Image> portion of the message and returned an error to CheckImageLoaded.

Programmer Response

Verify that the image exists in the specified subdirectory. If the image exists in the specified subdirectory, then verify that the image name matches the one being referenced.

This message is one in a group of related messages. Follow the message chain up and down to locate a message that provides the path from which the rule CheckImageLoaded is trying to load the image.

Example:

DM10802: Error in RULLoadImage(): Unable to FAPLoadImage(ImageH,

<.\forms\q1ruldmo.FAP>, FAPImageLoader(), OBJ_FIELDS).

DM10822: Error in CheckImageLoaded(): Unable to RULLoadlmage() for <q1ruldmo>

DM10823

Error in TextMergeParagraph(): Unable to CheckImageLoaded().

Explanation

The function, CheckImageLoaded, encountered a problem and returned an error to TexMergeParagraph.

Programmer Response

This message is one in a group of related messages. Follow the message chain up and down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM10802: Error in RULLoadImage(): Unable to FAPLoadImage(ImageH,

<.\forms\q1vrfl.FAP>, FAPImageLoader(), OBJ_FIELDS).

DM10822: Error in CheckImageLoaded(): Unable to RULLoadlmage() for <q1vrfl>

DM10823: Error in TextMergeParagraph(): Unable to CheckImageLoaded().

Verify that the image exists in the subdirectory that contain your images.

If the image exists, then verify that the image name matches the one being

specified in the error message.

DM10824

Error in TextMergeParagraph(): Unable to GENLoadGlobalFonts(pRPS).

Explanation

The function, GENLoadGlobalFonts could not load one of the global fonts and returned an error to TextMergeParagraph.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11112: Error in GenLoadGlobalFonts(): Unable to INIGetInitValue('Control','XrfExt').

DM10824: Error in TextMergeParagraph(): Unable to GENLoadGlobalFonts(pRPS).

DM10825

Warning in TextMergeParagraph(): Rule used in image that does not have any text areas. Image name is <Image>. Processing will continue

Explanation

The TextMergeParagraph image level rule was used in the image indicated by imagename. Since the image does not contain any text areas, TextMergeParagraph will not perform any processing.

If this rule is applied to a Multipage image but not all pages of this image contain a text area, the warning will be generated for all pages that do not contain a text area.

Programmer Response

Use the Image Editor to edit the DDT for the image and remove the TextMergeParagraph rule.

Generally speaking, it is not a good idea to put a text area in a Multipage image. But if the user must do so, use the Image Editor to add a dummy text area to all pages in the Multipage image.

DM10826

Warning in TextMergeParagraph(): Attempting to use a text merge area that can grow, on the image <Image> which cannot grow. Processing will continue.

Explanation

The image specified in the <Image> portion of the message is attempting to use a text merge area that can grow but the text area sizing property is not set to 'Can grow and shrink'.

Programmer Response

Use the Image Editor Text Area Properties window to set the text area sizing flag to 'Can grow and shrink'.

DM10827

Error in WriteEOFM(): Unable to WriteNALine(,POL_ENDFORM,,).

Explanation

Programmer Response

DM10828

Error in SetOrigin(): Invalid RuleParms for SetOrigin:<Parms>. Data field requires 2 items (OptionX,OptionY).

Explanation

The data field parameters for the SetOrigin rule are invalid. The data field requires two parameters. The current parameters are specified in the <Parm> portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM10828: Error in SetOrigin(): Invalid RuleParms for SetOrigin:<Rel+0>.

Data field requires two items (OptionX,OptionY).

DM12086: Error in RPDoImageRules(): Unable to <SETORIGIN>().

DM12077: Error in RPProcessOneImage(): Unable to RPDoImageRules(pRPS, RP_PRE_PROC_B).

DM12082: Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <q1addr>.

Skipping the rest of the Images for this form.

See INI group:< GenDataStopOn > option:ImageErrors.

See the Rules Reference for the correct format of the Data field

parameters for the SetOrigin rule

DM10829

Error in SetImageDimensions(): Invalid RuleParms for SetImageDimensions:<Parms>. Data field requires 8 items (PaperSize, Orientation, Height, Width, TopMargin, LeftMargin, BottomMargin, RightMargin. See FAPPAGEDIM stuct in FAPDEF.H).

Explanation

Missing the correct number of parameters for the rule SetImageDimensions .

Programmer Response

This message is one in a group of related messages. Follow the message chain Down to locate a message that identifies the image which has the problem.

Example:

DM10829: Error in SetImageDimensions(): Invalid RuleParms for SetImageDimensions:

<0,4080,8400,0,0,0,0>. Data field requires 8 items (PaperSize, Orientation,

Height, Width, TopMargin, LeftMargin, BottomMargin, RightMargin.

See FAPPAGEDIM stucture in FAPDEF.H).

DM12086: Error in RPDoImageRules(): Unable to <SETIMAGEDIMENSIONS>().

DM12077: Error in RPProcessOneImage(): Unable to RPDoImageRules(pRPS, RP_PRE_PROC_B).

DM12082: Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <q1addr>.

Skipping the rest of the Images for this form. See INI group:

< GenDataStopOn > option:ImageErrors.

Steps to correct problem.

1. Delete the SetImageDimensions rule from the specified image DDT then:

2. Open the image in the Image Editor.

3. Create a variable field on the image and click on the Edit DDT tab of the Field

Properties window.

4. Click on OK (closing the field properties window).

5. Delete the created variable field.

6. Save the image and DDT which will recreate the SetImageDimensions rule in the

image's DDT.

DM10830

Error in IncOvSym(): Invalid RuleParms for IncOvSym:<Parms>. Data field requires 2 items (sym,image).

Explanation

Missing the correct number of parameters for the rule SetImageDimensions .

Programmer Response

This message is one in a group of related messages. Follow the message chain Down to locate a message that identifies the image which has the problem.

Example:

DM10830: Error in IncOvSym(): Invalid RuleParms for IncOvSym:<CGDECBDOVF>.

Data field requires 2 items (sym,image).

DM12086: Error in RPDoImageRules(): Unable to <INCOVSYM>().

DM12080: Error in RPDoCurImagePostProcs(): Unable to RPDoImageRules

(pRPS, RP_POST_PROC_B).

DM12084: Error in RPProcessOneImage(): Unable to RPDoCurImagePostProcs(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <q1gdbd>.

Skipping the rest of the Images for this form. See INI group:

< GenDataStopOn > option:ImageErrors.

Add the missing parameter using the Image Editor Format | Image Properties | Image

Rule window. For rule help, select the rule and press the Explain button which will

take to Help Topic: Rules Help screen.

DM10831

Error in IncOvSym(): Unable to IncOvVar(<Image>, <Buff>).

Explanation

The function, IncOvVar, encountered an error while trying to process the parameters passed by the IncOvSym rule. The parameters are defined in the <Image> and <Buffer> portion of the message .

Programmer Response

1. If the form specified in the error message exist; then goto Step 3.

2. If not, the search the DDT's for field(s) that use the IncOvSym rule

and the parameters identified in the error message.

3. Using the Image Editor Format/Image Properties/Image Rules window, view the

IncOvSym rule parameters in the data field. Check for correct order of the

parameters and their spelling.

Reference the Rules Reference for information on the IncOvSym rule

and overflow symbol definiton.

DM10832

Error in ResetOvSym(): Invalid RuleParms for ResetOvSym:<Parms>. Data field requires 2 items (sym,image).

Explanation

Programmer Response

DM10833

Error in PopNodeFromList(): Empty RuleParms for PopNodeFromList.

Explanation

Programmer Response

DM10834

Error in CreateGraphSeries(): To few parameters in user data.

Explanation

Programmer Response

DM10835

Error in CreateChartSeries(): Unable to CheckImageLoaded(pRPS->CurrentFapImageH, RP_PRE_PROC_B).

Explanation

Programmer Response

DM10836

Warning in CreateChartSeries(): Unable to FAPFindChartByName(pRPS->CurrentFapImageH,<Name>).

Explanation

The function, FAPFindChartByName, could not find the image specified in the <Name> portion of the message and returned an warning to CreateChartSeries.

Programmer Response

Search the DDT files for the image name specified in the <Name> portion of the message.

Verify that the image exists in the subdirectory containing Images. If the image exists in the specified subdirectory, then verify that the image name matches the one defined in the Chart field of the CreateChartSeries rule(s).

DM10837

Error in CreateChartSeries(): Unable to FAPAddChartSeries(hChart,0,<Name>).

Explanation

Programmer Response

DM10838

Error in CreateChartSeries(): Unable to SetSeriesAttributes(hChart,hSeries,<%d>).

Explanation

Programmer Response

DM10839

Error in CreateChartSeries(): Failure to sscanf(pToken, %d,%d, FieldOffset, FieldLength).

Explanation

Incorrect number of paired parameters specified in the DataDefinitions field for the rule CreateChartSeries.

Programmer Response

See the Rules Reference for the correct format of the DataDefinitions parameters for the rule CreateChartSeries.

DM10840

Error in CreateChartSeries(): Unable to DALValidNumber(<Data>,<>,<>). ",

Explanation

Programmer Response

DM10841

Error in CreateChartSeries(): Failure to FAPAddSDataToChart(hChart, SData, 0).

Explanation

Programmer Response

DM10842

Error in CreateChartSeries(): Failure to GENGetFieldDataExt(pRPS,<Length>,<Offset>,<Buff>,hExtRecord 0).

Explanation

Programmer Response

DM10843

Error in PurgeChartSeries(): Unable to CheckImageLoaded(pRPS->CurrentFapImageH, RP_PRE_PROC_B).

Explanation

Programmer Response

DM10844

Warning in FieldVarsToChartSeries(): Unable to FAPLocateImageField(<Image>,<Data>).

Explanation

Programmer Response

DM10845

Error in PurgeChartSeries(): Unable to FAPDestroySeries().

Explanation

Programmer Response

DM10846

Error in FieldVarsToChartSeries(): Unable to CheckImageLoaded(pRPS->CurrentFapImageH, RP_PRE_PROC_B).

Explanation

Programmer Response

DM10847

Error in FieldVarsToChartSeries(): Unable to FAPLocateImageField(<Image>,<Name>).

Explanation

Programmer Response

DM10848

Error in FieldVarsToChartSeries(): Unable to DALValidNumber(<Data>,<>,<>).

Explanation

Programmer Response

DM10849

Error in FieldVarsToChartSeries(): Unable to FAPDestroySeries().

Explanation

Programmer Response

DM10850

Error in CreateGraphSeries(): Unable to CheckImageLoaded(pRPS->CurrentFapImageH, RP_PRE_PROC_B).

Explanation

The function, CheckImageLoaded, encountered a problem and returned an error to CreateGraphSeries.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail plus the image that has the problem.

Example:

DM10802: Error in RULLoadImage(): Unable to FAPLoadImage(ImageH,

<.\forms\q1cht.FAP>, FAPImageLoader(), OBJ_FIELDS).

DM10822: Error in CheckImageLoaded(): Unable to RULLoadlmage() for <q1cht>

DM10850: Error in CreateGraphSeries(): Unable to CheckImageLoaded(pRPS->

CurrentFapImageH, RP_PRE_PROC_B).

Verify that the image exists in the subdirectory that contains your images. If the

image exists, then verify that the image name matches the one being referenced.

DM10851

Warning in DeleteDefaultSeriesData(): Unable to FAPFindChartByName(<>,<Name>).

Explanation

The function, FAPFindChartByName, could not find the image specified in the <Name> portion of the message and returned a warning to DeletDefaultSeriesData.

Programmer Response

Search the DDT files for the image name specified in the <Name> portion of the message.

Verify that the image exists in the subdirectory containing your Images. If the image exists, then verify that the image name matches the one defined in the Chart field of the B>DeleteDefaultSeriesData rule(s).

DM10852

Error in DeleteDefaultSeriesData(): Unable to FAPFindChartByName(<>,<Name>).

Explanation

The function, FAPFindChartByName, could not find the image specified in the <Name> portion of the message and returned an error to DeletDefaultSeriesData.

Programmer Response

Search the DDT files for the image name specified in the <Name> portion of the message.

Verify that the image exists in the subdirectory containing your Images. If the image exists, then verify that the image name matches the one defined in the Chart field of the DeleteDefaultSeriesData rule(s).

DM10853

Error in DeleteDefaultSeriesData(): Unable to FAPFindChartSeries(<>,<Name>).

Explanation

The function, FAPFindChartSeries, could not find the name for the series that the data was to be added to in a CreateChartSeries rule and returned an error to DeleteDefaultSeriesData. The series name is specified in the <Name> portion of the message .

Programmer Response

The series name(s) found in DeletedFaultSeriesData rule(s) must match a name(s) found in the series parameter of the CreateChartSeries rule(s).

DM10854

Error in RULRegisterStandardRules(): Unable to RPRegisterBaseRule(pRPS,Parms,<Name>).

Explanation

Programmer Response

DM10855

Error in RULRegisterStandardRules(): Unable to RPRegisterImageRule(pRPS,Parms,<Name>).

Explanation

Programmer Response

DM10856

Error in RULRegisterStandardRules(): Unable to RPRegisterFieldRule(pRPS,Parms,<Name>).

Explanation

Programmer Response

DM10857

Error in RULRegisterStandardRules(): Unable to RPRegisterRecipRule(pRPS,Parms,<Name>).

Explanation

Programmer Response

DM10858

Version:<String> Date:<Date> Time:<Time>

Explanation

This LogFile message is output when the execution steps GENTran, GENData, GENPrint, GENWip, and GENArc start. The version, date, and time parameters are specified in the String, Date, and Time portions of the message .

Programmer Response

This is a LogFile informative message.

DM10859

Transaction Log Report - System timestamp: Time

Explanation

This LogFile message is output when the execution steps GENTrn, GENData, GENPrint, GENWip, and GENArc start. The abbreviated day of the week, month, day, time, and year are specified in the Time portion of the message.

Programmer Response

This is a LogFile informative message .

DM10860

Warning : Unable to INIGetInitValue(<MasterResource>,<CompLib>,,).

Explanation

Gendata has determined that the INI option < MasterResource > CompLibFap does not exist in the INI file.

Programmer Response

For optimal performance, you should specify:

<RunMode> CompLibFap = Yes

Add the indicated INI option to the indicated INI group. For more information

on INI Options, refer to the online INI Reference Guide.

DM10861

Warning : Not using compiled FAP's. Check INI option <RunMode> CompiledFAP =

Explanation

For optimal performance, you should specify:

<RunMode> CompLibFap = Yes

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10862

Warning : LoadCordFAP is set to Yes, this option should be set to No for optimal performance. Check INI option <RunMode> LoadCordFAP =

Explanation

Gendata has determined that the INI option:

<RunMode> LoadCordFAP=Yes

is set to Yes. This causes Gendata to load all FAPs that are used into memory.

Programmer Response

For optimal performance, you should specify:

<RunMode> LoadCordFAP=No

Setting LoadCordFAP to No will prevent Gendata from loading all FAPs into memory, thus saving processor time.

DM10863

Error in RULRegisterStandardRules(): Unable to RPRegisterOMRRule(pRPS,Parms,<Name>).

Explanation

Programmer Response

DM10864

Error in RULRegisterStandardRules(): Unable to RPRegisterGroupRule(pRPS,Parms,<Name>).

Explanation

Programmer Response

DM10865

Warning in Image<Image>, Field<Field>. The DestLen is smaller than SrcLen. Check DestFieldName<DFName>.

Explanation

Programmer Response

DM10866

Error in RCTLoadSetRecipientTable(): Unable to VMMAppendElem(,,).

Explanation

Programmer Response

DM10867

Error in List: Unable to create Image List.

Explanation

Programmer Response

DM10868

Error in RULRegisterBaseRule: Unable to register Image Ext List Deletion.

Explanation

Programmer Response

DM10869

Error <Name>: Invalid value given for "Parameter".

Explanation

Programmer Response

DM10870

Error: Unbalanced parenthesis in Parameter parameter.

Explanation

The sub parameterparameter group specified in the <Parameter> portion of the message has unbalanced parenthesis.

Programmer Response

See the online Rules Reference for the correct format of the parameters and sub parameters for the GroupBegin rule.

DM10871

Error in FieldName: Invalid value given for Parameter.

Explanation

Programmer Response

DM10872

Error: Invalid rule parameter <Parameter>.

Explanation

Programmer Response

DM10873

Error: Could not locate the field proc.

Explanation

Programmer Response

DM10874

Error in Field: There is a formset error and the global fonts can not be loaded.

Explanation

Programmer Response

DM10875

Error in Field: Unable to Load Global Fonts.

Explanation

Programmer Response

DM10876

Error: Font ID <FontID> could not be found.

Explanation

Programmer Response

DM10877

Error in VerticalPaginateLists(): Unable to FAPDuplicateImage.

Explanation

Programmer Response

DM10878

Error <Field>: Could not RULLoadImage.

Explanation

Programmer Response

DM10879

Error in <FieldName> for field <DestField>: There is no List group defined. This rule requires a GroupBegin;List image level rule.

Explanation

Programmer Response

DM10880

Error in FieldName for field <DestField>: Unable to create field extension list handle for image extensions list.

Explanation

Programmer Response

DM10881

Error in FieldName for field <DestField>: Unable to create image extentions element.

Explanation

Programmer Response

DM10882

Error in FieldName for field <DestField>: Unable to create field extentions element.

Explanation

Programmer Response

DM10883

Error in FieldName for field <DestField>: Unbalanced parenthesis <Parms>.

Explanation

Programmer Response

DM10884

Error in FieldName for field <DestField>: Invalid value given for Parameter.

Explanation

The BldGrpList rule detected an error parsing its parameter and it stopped processing data for the field. The field and parameter which has the problem is specified in the <DestField> and <Parmeters> portion of the message.

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all list functions, parameters and sub parameters for the BldGrpList rule.

DM10885

Error in FieldName for field <DestField>: Unbalanced parenthesis in Parameter parameter<Parms>.

Explanation

The specified parameter for the field has a set of unbalanced parenthesis. The field name and parameter are specified in the <DestField> and <Parameter> portion of the message .

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10886

Error in FieldName for field <DestField>: Invalid rule parameter <Parms>.

Explanation

The specified rule parameter for the field is invalid. The field name and rule parameter are specified in the <DestField> and <Parms> portion of the message .

Error in FieldName for field <DestField>: Invalid rule parameter <Parms>.

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10887

Error in FieldName for field <DestField>: No data collection function was specified <Parms>.

Explanation

No data collection function was specified for the parameter for the field. The field name and parameter are specified in the <DestField> and <Parms> portion of the message .

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10888

Error in FieldName for field <DestField>: Unable to locate list rule <Rule>. This rule may not be registered.

Explanation

The BldGrpList function specified in the <Rule> portion of the message could not be located. This rule may not be registered. The field that has the problem is specified in the <DestField> portion of the message.

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10889

Error in FieldName for field <DestField>: No data format rule was specified <Parms>.

Explanation

No data format was specified for the rule parameter specified in the <Parms> portion of the message. The field that has the problem is specified in the <DestField> portion of the message.

Error in FieldName for field <DestField>: No data format rule was specified <Parms>.

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10890

Error in FieldName for field <DestField>: Unable to locate field rule <Rule>. This rule may not be registered.

Explanation

The BldGrpList rule detected an error parsing its parameter and it stopped processing data for the field. The field and rule parameter which has the problem is specified in the <DestField> and <Rule> portion of the message.

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10891

Error in FieldName for field <DestField>: Could not collect data for field.

Explanation

The BldGrpList rule could not obtain data for the field, thus it stopped processing data for the field. The field which has the problem is specified in the <DestField> portion of the message.

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10892

Error in list rule Rule for field <DestField>: No array definition provided.

Explanation

The list function for the BldGrpList rule for the specificed field does not have any array definitions defined. The list function and field name are specified in the <Rule> and <DestField> portion of the message.

Programmer Response

Verify that the BldGrpList list function rule plus its parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all list functions, parameters and sub parameters for the BldGrpList rule.

DM10893

Error in list rule Rule for field <DestField>: Incorrect parms <Parms>.

Explanation

The list function for the BldGrpList rule for the specificed field has invalid parameter definitions defined. The list function, field name, and parameters are specified in the <Rule>, <DestField>, and <Parms> portion of the message.

Programmer Response

Verify that the BldGrpList rule list function plus its parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10894

Error in list rule Rule for field <DestField>: Incorrect parms <Parms>. Found invalid field lengths.

Explanation

The list rule for the parameter for the field has an incorrect definition for its parameters. The rule, field, and parameter names are specified in the <Rule>, <DestField>, and <ParmsRule> portion of the message.

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10895

Error: Unable to retrieve data with search key <Key> at offset <Offset> for length <Length>.

Explanation

The BldGrpList function could not retrieve data with the specified search key, offset, and length. The search key, offset, and length are specified in the <Key>, <Offset>, and <Length> portion of the message.

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

Verify that the search key, offset, and length are valid for the data in the transaction record(s).

DM10896

Error in list rule Rule for field <DestField>: Unable to create Data List.

Explanation

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10897

Error in list rule Rule for field <DestField>: Unable to add data to Data List.

Explanation

Programmer Response

Verify that all of the BldGrpList rule parameters and sub parameters are correctly defined. See the online Rules Reference for the correct definition for all parameters and sub parameters for the BldGrpList rule.

DM10898

Error in RULRegisterListRule(): Function address is NULL.

Explanation

Programmer Response

DM10899

Error in RULRegisterListRule(): Function name is NULL.


DM10900 - DM10999 Messages

DM10900

Error in RULRegisterListRule(): Unable to create hash table.

Explanation

Programmer Response

DM10901

Error in RULRegisterListRule(): Unable to VMMInsertHashElem().

Explanation

Programmer Response

DM10902

Error: List level rule not specified.

Explanation

Programmer Response

DM10903

Error: Unable to locate the list level rule <Rule>. This list rule may not have been registered.

Explanation

Programmer Response

DM10904

Error in list rule MultiOccur for field <DestField>: No field definition provided.

Explanation

Programmer Response

DM10905

Error in RULRegisterGrplRules(): Unable to Func(pRPS,,<Rule>).

Explanation

Programmer Response

DM10906

Error in RULSuperDate (FieldName): Missing Format Mask

Explanation

Programmer Response

DM10907

Error in RULSuperDate (FieldName): Input format Format does not match input string Outbuff.

Explanation

Programmer Response

DM10908

Error in Name: <GENGetRecord> failed when getting handle of the Account record.

Explanation

Programmer Response

DM10909

Error in Name: <GENGetFieldDataExt> failed when retrieving CD-FORMAT-ID.

Explanation

Programmer Response

DM10910

Error in Name: Empty RuleParms. Expected parameters would be like: <Usage;2;63,02 13,4 63,07 91,3 94,12 7;>.

Explanation

Programmer Response

DM10911

Error in Name: Wrong # of parameters: <Parm1> <Parm2> <Parm3> <Parm4> <Parm5> <MaxLine>

Explanation

Programmer Response

DM10912

Error in Name: Wrong offset or length of usage Parm1.

Explanation

Programmer Response

DM10913

Error in Name: <GENGetRecord> failed on get handle of the Account record.

Explanation

Programmer Response

DM10914

Error in Name: <GENGetFieldDataExt> failed when retrieving company code on account TranID.

Explanation

Programmer Response

DM10915

Error in Name: <GENGetRecord> failed on account TranID.

Explanation

Programmer Response

DM10916

Error in Name: <GENGetFieldDataExt> failed when retrieving the usage Parm1 on account TranID.

Explanation

Programmer Response

DM10917

Warning in Name: Lookup key <key> not found in Usage table.

Explanation

Programmer Response

DM10918

Error in Name: <VMMAppendElem> failed on account TranID.

Explanation

Programmer Response

DM10919

Error in Name: Empty RuleParms. Expected parameters would be like: <Trig;2;63,02 13,4 68,3 63,03 65,2 102,12;>

Explanation

Programmer Response

DM10920

Error in Name: Wrong # of parameters:<Parm1> <Parm2> Expected parameters would be like: <Trig;2;63,02 13,4 68,3 63,03 65,2 102,12 61,09;>

Explanation

Programmer Response

DM10921

Error in Name: Wrong offset or length of bill format code.

Explanation

Programmer Response

DM10922

Error in Name: Wrong offset or length of company code.

Explanation

Programmer Response

DM10923

Error in Name: Wrong offset or length of Type of History to be Displayed.

Explanation

Programmer Response

DM10924

Error in Name: Wrong offset or length of Actual KWH Curr.

Explanation

Programmer Response

DM10925

Error in Name: <GENGetFieldDataExt> failed when retrieving bill format code on account TranID.

Explanation

Programmer Response

DM10926

Error in Name: <GENGetFieldDataExt> failed when retrieving type of history to be displayed for TranID.

Explanation

Programmer Response

DM10927

Error in Name: CD-HIST-FORMAT is not 'target' on account TranID. CD-HIST-FORMAT = <format>

Explanation

Programmer Response

DM10928

Error in Name: CD-HIST-FORMAT is equal to <format>.

Explanation

Programmer Response

DM10929

Error in Name: CD-BILL-FORM = <format> must be equal to '01' or '02' on account TranID.

Explanation

Programmer Response

DM10930

Error in Name: <GENGetFieldDataExt> failed when retrieving Parm1 on account TranID.

Explanation

Programmer Response

DM10931

Error in Trig(): Fail to append form triggered to extract list

Explanation

Programmer Response

DM10932

Error in GetCompCode: <VMMLocateOrdElem> failed locating: Group

Explanation

Programmer Response

DM10933

Error in Name: Empty RuleParms. Expect parameters would be like: <;61,03 61,23 1,4 7;>

Explanation

Programmer Response

DM10934

Error in Name: Wrong # of parameters:<Parm1> <Parm2> <Parm3> Expect parameters would be like: <;61,03 61,23 1,4 7;>

Explanation

Programmer Response

DM10935

Error in Name: Can't create sort list. Transaction failed.

Explanation

Programmer Response

DM10936

Error in Name: Can't get handle of the METER record.

Explanation

Programmer Response

DM10937

Error in Name: Unable to retrieve Parm1. Transaction failed.

Explanation

Programmer Response

DM10938

Warning in Name: Lookup key <key> not found in Tariff table.

Explanation

Programmer Response

DM10939

Warning in Name: Lookup key <key> not found in Rdgtype table.

Explanation

Programmer Response

DM10940

Error in Name: Can not append record to VMM sorting list.

Explanation

Programmer Response

DM10941

Error in Name: Failed to sort the VMM sorting list

Explanation

Programmer Response

DM10942

Warning in Name: GENFmtDate failure on field field in '03' \tMeter record for input data formatted as <format>. Data should be in YYYY-MM-DD format.

Explanation

Programmer Response

DM10943

Error in Name: <VMMAppendElem> failed in account TranID.

Explanation

Programmer Response

DM10944

Error in Name: Invalid RuleParms.

Explanation

Programmer Response

DM10945

Error in Name: Wrong offset or length for the source field.

Explanation

Programmer Response

DM10946

Error in Name: <function> failed on account TranID.

Explanation

Programmer Response

DM10947

Error in NoGenTrnTransactionProc(): Unable to function(pRPS).

Explanation

The function, xxxxx, encountered a problem and returned an error to NoGenTrnTransactionProc. The function, xxxxx, is specified in the <function> portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10971: Error in RULGetDocSetNames(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName2>,,).

DM10954: Error in RULLoadXtrRecs(): Unable to RULGetDocSetNames(pRPS).

DM13025: Warning in RCBSendToErrBatch(): Transaction is being assigned to the

Error batch.

DM10947: Error in NoGenTrnTransactionProc(): Unable to RULLoadXtrRecs(pRPS).

DM10948

Error in RULTransactionProc(): Unable to function(pRPS).

Explanation

Programmer Response

DM10949

Error in RULLoadXtrRecs(): pRPS->ExtractListH == VMMNULLHANDLE.

Explanation

Programmer Response

DM10950

Error in RULLoadXtrRecs(): Alternate function failed to load records.

Explanation

Programmer Response

DM10951

Error in RULLoadXtrRecs(): Extract file pointer pRPS->fpExtractFile == NULL.

Explanation

Programmer Response

DM10952

Error in RULLoadXtrRecs(): Unable to VMMMalloc() for extract file buffer.

Explanation

Programmer Response

DM10953

Error in RULLoadXtrRecs(): Unable to UpdateExtractFieldData(pRPS,ExtractBuffFirst).

Explanation

Programmer Response

DM10954

Error in RULLoadXtrRecs(): Unable to function(pRPS).

Explanation

The function, xxxxx, encountered a problem and returned an error to RulLoadXtrRecs. The function, xxxxx, is specified in the <function> portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10971: Error in RULGetDocSetNames(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName1>,,).

DM10954: Error in RULLoadXtrRecs(): Unable to RULGetDocSetNames(pRPS).

DM10955

Error in RULAddExtrToList(): Unable to add an extract record to the extract list.

Explanation

Programmer Response

DM10956

Error in RULInitXtr(): Unable to VMMCreateList() for ExtractFieldListH).

Explanation

Programmer Response

DM10957

Error in RULInitXtr(): Unable to function(pRPS).

Explanation

The function, LoadDummyFields, encountered a problem and returned an error to RulInitXtr.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10959: Error in LoadDummyFields(): Unable to GENGetGlbDataPtr(,NULL).

Tip: Make sure fields defined in < GentrnDummyFields > group are fields

defined in the Trn DFD file.

DM10957: Error in RULInitXtr(): Unable to LoadDummyFields(pRPS).

DM10958

Error in LoadDummyFields(): Unable to INIGetInitValue(<GentrnDummyFields>,<Buff>,,).

Explanation

The INI Group, < GENTrnDummyFields >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10959

Error in LoadDummyFields(): Unable to GENGetGlbDataPtr(<Buff>,NULL). Tip: Make sure fields defined in < GentrnDummyFields > group are fields defined in the trn dfd file.

Explanation

The function, GENGetGlbDataPtr, could not find the INI option specified in the <Buff> portion of the message in the INI file and returned an error to LoadDummyFields.

Programmer Response

Verify that fields defined in < GentrnDummyFields > group are fields defined in the TrnDFDFl file. In addition, verify that the INI group, < Group1 > exists in the INI file.

For more information on INI Options, refer to the online INI Reference Guide.

DM10960

Error in RULBuildExtractFieldList(): Unable to INIFirstInitValue(<TRN_FIELDS>,NULL,,).

Explanation

The function, INIFirstInitValue, could not locate the first INI option in the INI group, < Trn_Fields >, and returned an error to RulBuildExtracFieldList.

Programmer Response

Verify that the INI group, < Trn_Fields >, exists in the INI file. Add the indicated INI group and its option(s) to the INI file. For more information on INI Options, refer to the online INI Reference Guide.

DM10961

Error in RULBuildExtractFieldList(): Unable to INIGetInitValue(<TRN_FIELDS>,<Buff>,,).

Explanation

The INI Group, < TRN_Fields >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message .

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10962

Error in RULBuildExtractFieldList(): Unable to GENGetGlbDataPtr(<Buff>,NULL). Tip: Make sure fields defined in INI group < TRN_FIELDS > are fields defined in the trn dfd file.

Explanation

Programmer Response

DM10963

Warning: The length of token <token> defined in INI is larger than its DFD defined equivelent, data will be truncated.

Explanation

Programmer Response

DM10964

Error in RULBuildExtractFieldList(): Unable to VMMAppendElem(ExtractFieldListH,,).

Explanation

Programmer Response

DM10965

Error in UpdateExtractFieldData(): An extract record is too short to obtain a field value from, for the field <field> defined in the INI group TRN_FIELDS. Tip: Make sure there are no blank records within or on the end of the extract data file.

Explanation

Programmer Response

DM10966

Warning in UpdateExtractFieldData(): Unable to format the data field. Check the field <field> defined in the INI group TRN_FIELDS.

Explanation

The function, UpdateExtractFieldData, could not format the content of the field specified in the field portion of the message.

Programmer Response

Verify that the field definition in the INI group, < Trn_Fields > is defined correctly (length and format) when compared to the content of the extract record.

DM10967

Warning in UpdateExtractFieldData(): The length of token <RunDate> defined in INI is larger than its DFD defined equivelent, data will be truncated.

Explanation

Programmer Response

DM10968

Error in RULExtKeyFieldsMatch(): Unable to sscanf(<Buff>,,,,).

Explanation

Programmer Response

DM10969

Error in Name: Unable to write the recipient batches.

Explanation

Programmer Response

DM10970

Error in Name: Unable to PurgeOutput(pRPS).

Explanation

Programmer Response

DM10971

Error in RULGetDocSetNames(): Unable to INIGetInitValue(<DocSetNames>,<Parm1>,,).

Explanation

The INI Group, < DocSetNames >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Name portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10972

Error in RULGetDocSetNames(): Unable to GENGetGlbDataPtr(<Parm1>,). Tip: Does < DocSetNames > ini value:<Parm1> exist in the trn or rcb dfd file?

Explanation

Programmer Response

DM10973

Error in RULGetDocSetNames(): Unable to INIGetInitValue(<table>,,<Group>,).

Explanation

The INI Group, < xxxxx >, and the Option, yyyyy, could not be found in the INI file. The group and option are specified in the table and group portion of the message

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM10974

Warning in RULSetRecipFromImage(): Image: <image>: Unable to func() for image call levels.

Explanation

Programmer Response

DM10975

Warning in RULSetRecipFromImage(): Image: <image>: Call level of level exceeded. Generated formset not added.

Explanation

Programmer Response

DM10976

Error in RULSetRecipFromImage(): Image: <image>: Unable to FAPCreateFormset(,,<TEMPSET>).

Explanation

Programmer Response

DM10977

Warning in RULSetRecipFromImage(): Image: <image>: Unable to create macro context.

Explanation

Programmer Response

DM10978

Error in RULSetRecipFromImage(): Image: <image>: At least one key value must be given.

Explanation

Programmer Response

DM10979

Error in RULSetRecipFromImage(): Image: <image>: Parameter error; Key values must not be the same as the current transaction.

Explanation

Programmer Response

DM10980

Error in Name : Unable to create a formset.

Explanation

Programmer Response

DM10981

Error in Name : Unable to create hash list.

Explanation

Programmer Response

DM10982

Error in Name : Hash list failed to init.

Explanation

Programmer Response

DM10983

Warning in RCTSetRecipsFromTable(): Initial trigger for form <form> contains a subordinate flag, the flag will be ignored.

Explanation

Programmer Response

DM10984

Error in Name: Unable to add form to formset.

Explanation

Programmer Response

DM10985

Error in Name: Unable to update form hash table.

Explanation

Programmer Response

DM10986

Error in Name: Image <image> is not in Form<form>.

Explanation

Programmer Response

DM10987

Error in Name: Failed to set copy cound on Image <image>.

Explanation

Programmer Response

DM10988

Error in Name: Image<image> duplication failed.

Explanation

Programmer Response

DM10989

Error in Name: Page split failed.

Explanation

Programmer Response

DM10990

Error: Invalid rule parameter. The 'Parm1' is expected. Parms

Explanation

Programmer Response

DM10991

Error: Unknown rule parameter <Parm1>.

Explanation

Programmer Response

DM10992

Error in LoadCachedTable(): Unable to fseek(pRPS->fpSetRecipientFile, 0L, SEEK_SET).

Explanation

Programmer Response

DM10993

Error in LoadCachedTable(): Error parsing set recipient table, line number = <line>.

Explanation

Programmer Response

DM10994

Error in LoadCachedTable(): Unable to RPLocateRecipRule(pRPS,,<func>).

Explanation

Programmer Response

DM10995

Error in LoadCachedTable(): Max Recip Table Ertries exceeded

Explanation

Programmer Response

DM10996

Error: Could not GVM variable <Parms>

Explanation

The OMR mark function could not find the GVM variable specified in the <Parms> portion of the message.

Programmer Response

Correct the GVM name specified in the RuleParms parameter of the OMR_Marks rule. See the online Rules Reference for a description of the parameters for the OMR_Marks rule.

DM10997

Error: VOID is an unsupported type, global variable <Parms>.

Explanation

Programmer Response

DM10998

Error: Unsupported type, global variable <Parms>.

Explanation

Programmer Response

DM10999

Error: ZIPCODE must be a charactor type, global variable <Parms>.


DM11000 - DM11099 Messages

DM11001

Error in CharPop(): Attempt to pop from an empty stack.

Explanation

Programmer Response

DM11002

Error in DoublePop(): Attempt to pop from an empty stack.

Explanation

Programmer Response

DM11003

Error in GENCalc(): NULL pointers not allowed.

Explanation

Programmer Response

DM11004

Error in GENCalc(): Invalid operator.

Explanation

Programmer Response

DM11005

Error in GENCalc(): Unknown operator.

Explanation

Programmer Response

DM11006

Error in GENCalc(): Parentheses don't match.

Explanation

Programmer Response

DM11007

Warning in GENParseFIELDRULE(): The destination field name <Name> will be ignored, the ultimate field name <Buff> will be used so it is best to leave this field blank and let it default.

Explanation

Programmer Response

DM11008

Error in GEN_DATE_ConvertDate(): Invalid input format.

Explanation

Programmer Response

DM11009

Error in GEN_DATE_FormatToIntermediate(): Invalid pointers.

Explanation

Programmer Response

DM11010

Error in GEN_DATE_FormatToIntermediate(): Invalid input data/format <Buff/Temp>.

Explanation

The function, GEN_Date_IntermediateToFormat, could not convert the input data using the format passed by DateDiff and returned an error.. The format is specified in the <Buffer> and <Temp>portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to identifies the image and field that has the problem.

Example:

DM11010: Error in GEN_DATE_FormatToIntermediate(): Invalid input data/format <030198/7>.

DM10564: Error in DateDiff(): Unable to GEN_DATE_ConvertDate(<030198>,,<7.8>).

DM12051: Error in RPProcessOneField(): Unable to <DATEDIFF>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<NET DAYS>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct FormatMask

and RuleData parameters for the rule DateDiff

DM11011

Error in GEN_DATE_FormatToIntermediate(): Invalid input format <Temp>, format unsupported.

Explanation

Programmer Response

DM11012

Error in GEN_DATE_IntermediateToFormat(): Invalid output data/format <Buff/Temp>.

Explanation

The function, GEN_Date_IntermediateToFormat, could not convert the output data using the format passed by DateDiff and returned an error.. The format is specified in the <Buffer> and <Temp>portion of the message.

The only valid formats that can be used in the RuleData field of the rule DateDiff are: 1,7, 10, and 11.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to identifies the image and field that has the problem.

Example:

DM11012: Error in GEN_DATE_IntermediateToFormat(): Invalid output data/format </8>.

DM10564: Error in DateDiff(): Unable to GEN_DATE_ConvertDate(<030198>,,<9.8>).

DM12051: Error in RPProcessOneField(): Unable to <DATEDIFF>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<NET DAYS>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct FormatMask

and RuleData field parameters for the DateDiff rule.

DM11013

Error in GEN_DATE_IntermediateToFormat(): Invalid output format <Buff>, format unsupported.

Explanation

Programmer Response

DM11014

Error in GENGetFieldData(): Unable to get ElemPtr Handle.

Explanation

Programmer Response

DM11015

Error in GENGetFieldDataExt(): Unable to get ElemPtr Handle.

Explanation

Programmer Response

DM11016

Error in GENFmtString(): Invalid parameters passed.

Explanation

Programmer Response

DM11017

Error in GENFmtString(): Invalid format <Buff> passed, data value missing.

Explanation

The format mask to be used to format the string is invalid or missing. The format mask passed to GENFmtString is specified in the <Buff> portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM11017: Error in GENFmtString(): Invalid format <> passed, data value missing.

DM10530: Error in StrngFmt(): Unable to GENFmtString(<000666666600000444>

,,pRPS->Field.FmtMask).

DM12051: Error in RPProcessOneField(): Unable to <STRNGFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <AGENT NBR>.

Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the online Rules Reference for the correct format of the Mask and

Data field parameters for the StrngFmt rule.

DM11018

Error in GENVal_Num_Format(): Requested buffer length too big.

Explanation

Programmer Response

DM11019

Error in GENVal_Num_Format(): Bad format:incorrect length.

Explanation

Programmer Response

DM11020

Error in GENVal_Num_Format(): Bad format:$ can't follow anything.

Explanation

Programmer Response

DM11021

Error in GENVal_Num_Format(): Bad format:*.

Explanation

Programmer Response

DM11022

Error in GENVal_Num_Format(): Bad format:Z's can't follow 9.

Explanation

Programmer Response

DM11023

Error in GENVal_Num_Format(): Bad format:Unknown data.

Explanation

Programmer Response

DM11024

Error in GENVal_Num_Format(): Bad format:digit expected.

Explanation

Programmer Response

DM11025

Error in GENVal_Num_Format(): Bad format:space expected.

Explanation

Programmer Response

DM11026

Error in GENVal_Num_Format(): More than one decimal is invalid.

Explanation

Programmer Response

DM11027

Error in GENVal_Num_Format(): Multiple decimal points.

Explanation

Programmer Response

DM11028

Error in GENVal_Num_Format(): Too many leading signs.

Explanation

Programmer Response

DM11029

Error in GENVal_Num_Format(): Bad format:Unknown data encountered.

Explanation

Programmer Response

DM11030

Error in GENVal_Num_Format(): Integer portion too big.

Explanation

Programmer Response

DM11031

Error in GENVal_Num_Format(): Too many digits.

Explanation

Programmer Response

DM11032

Error in GENFmtDate(): Format 1:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 1 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11033

Error in GENFmtDate(): Format 2:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 2 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11034

Error in GENFmtDate(): Format 3:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 3 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11035

Error in GENFmtDate(): Format 4:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 4 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11036

Error in GENFmtDate(): Format 5:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 5 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11037

Error in GENFmtDate(): Format 6:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 6 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11038

Error in GENFmtDate(): Format 7:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 7 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11039

Error in GENFmtDate(): Format 8:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 8 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11040

Error in GENFmtDate(): Format 9:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 9 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11041

Error in GENFmtDate(): Format 10:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 10 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11042

Error in GENFmtDate(): Format 11:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 11 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11043

Error in GENFmtDate(): Format 12:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 12 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11044

Error in GENFmtDate(): Format 13:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 13 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11045

Error in GENFmtDate(): Format 14:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 14 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction record field.

See the Rules Reference for the correct date format mask values for the rule DateFmt.

DM11046

Error in GENFmtDate(): Format 15:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 15 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date

in the transaction record field.

See the Rules Reference for the correct date format mask values for the

rule DateFmt.

DM11047

Error in GENFmtDate(): Format 16:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 16 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction

record field.

See the Rules Reference for the correct date format mask values for the

rule DateFmt.

DM11048

Error in GENFmtDate(): Format 17:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 17 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction

record field.

See the Rules Reference for the correct date format mask values for the

rule DateFmt.

DM11049

Error in GENFmtDate(): Format 18:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 18 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction

record field.

See the Rules Reference for the correct date format mask values for the

rule DateFmt.

DM11050

Error in GENFmtDate(): Format 19:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, detected an invalid month, day, or year in the date being processed based on Format 19 date definition.

Programmer Response

This message is one in a group of related messages. Follow the message chain down to locate a message that describes the error in more detail plus the image and field that has the problem.

Example:

DM11039: Error in GENFmtDate(): Format 8:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<130198>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EFFECT DATE>. Processing will NOT continue for image <q1mdc1>.

See INI group:< GenDataStopOn > option: FieldErrors.

Verify that you have selected the date format which matches the date in the transaction

record field.

See the Rules Reference for the correct date format mask values for the

rule DateFmt.

DM11051

Error in GENFmtDate(): Format 15:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (15) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11051: Error in GENFmtDate(): Format 15:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11052

Error in GENFmtDate(): Format 14:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (14) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11052: Error in GENFmtDate(): Format 14:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11053

Error in GENFmtDate(): Format 16:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (16) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11053: Error in GENFmtDate(): Format 16:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11054

Error in GENFmtDate(): Format 17:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (17) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11054: Error in GENFmtDate(): Format 17:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11055

Error in GENFmtDate(): Format 18:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (18) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11055: Error in GENFmtDate(): Format 18:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11056

Error in GENFmtDate(): Format 19:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (19) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11056: Error in GENFmtDate(): Format 19:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11057

Error in GENFmtDate(): Format 20 is an invalid format specifier.

Explanation

Programmer Response

DM11058

Error in GENFmtDate(): Format 20:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (20) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11058: Error in GENFmtDate(): Format 20:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11059

Error in GENFmtDate(): Format 20:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (20) because the data in the transaction record contains an invalid month, day or year.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11059: Error in GENFmtDate(): Format 20:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<2013-13-12>,,).

DM11060

Error in GENFmtDate(): Format 21:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (21) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11060: Error in GENFmtDate(): Format 21:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11061

Error in GENFmtDate(): Format 21:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (21) because the data in the transaction record contains an invalid month, day or year.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11061: Error in GENFmtDate(): Format 21:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<2013-13-12>,,).

DM11062

Error in GENFmtDate(): Format 22:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (22) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11062: Error in GENFmtDate(): Format 22:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11063

Error in GENFmtDate(): Format 22:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (22) because the data in the transaction record contains an invalid month, day or year.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11063: Error in GENFmtDate(): Format 22:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<2013-13-12>,,).

DM11064

Error in GENFmtDate(): Format 23:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (23) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11064: Error in GENFmtDate(): Format 23:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11065

Error in GENFmtDate(): Format 23:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (23) because the data in the transaction record contains an invalid month, day or year.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11065: Error in GENFmtDate(): Format 23:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<2013-13-12>,,).

DM11066

Error in GENFmtDate(): Format 24:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (24) because the data in the transaction record contains an invalid month, day or year.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11066: Error in GENFmtDate(): Format 24:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<2013-13-12>,,).

DM11067

Error in GENFmtDate(): Format 25:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (25) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11067: Error in GENFmtDate(): Format 25:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11068

Error in GENFmtDate(): Format 25:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (25) because the data in the transaction record contains an invalid month, day or year.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11068: Error in GENFmtDate(): Format 25:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<2013-13-12>,,).

DM11069

Error in GENFmtDate(): Format 26:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (26) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11069: Error in GENFmtDate(): Format 26:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11070

Error in GENFmtDate(): Format 26:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (26) because the data in the transaction record contains an invalid month, day or year.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11070: Error in GENFmtDate(): Format 26:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<2013-13-12>,,).

DM11071

Error in GENFmtDate(): Format 27:Date does not conform to the input format.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (27) because the data in the transaction record does not conform to the specified date format.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11071: Error in GENFmtDate(): Format 27:Date does not conform to the input format.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<13-13-12>,,).

DM11072

Error in GENFmtDate(): Format 27:Date contains invalid month, day or year.

Explanation

The function, GENFmtDate, could not format the input data into the desired date format (27) because the data in the transaction record contains an invalid month, day or year.

Programmer Response

Verify that the date format specified in the DateFmt rule matches the source field in the transaction record.

See the online Rules Reference for the correct format of the Mask and Data field parameters for the DateFmt rule plus the different date format supported..

This message is one in a group of related messages. Follow the message chain down to message DM10527 to view the data from the transaction record the function is trying to format into the specified date format.

Example:

DM11072: Error in GENFmtDate(): Format 27:Date contains an invalid month, day or year.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<2013-13-12>,,).

DM11073

Error in GENFmtDate(): Unknown date format specifier.

Explanation

An invalid date format was specified in the mask field for the rule DateFmt.

Programmer Response

This message is one in a group of related messages. Follow the message chain upand down to locate a message that describes the error in more detail.

Example:

DM11073: Error in GENFmtDate(): Unknown date format specified.

DM10527: Error in DateFmt(): Unable to GENFmtDate(<030199>,,).

DM12051: Error in RPProcessOneField(): Unable to <DATEFMT>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS)

<EXPIRE DATE>. Processing will NOT continue for image <q1ruldmo>.

See INI group:< GenDataStopOn > option: FieldErrors.

See the Rules Reference for the data formats supported by the

DateFmt rule.

DM11074

Error in GENFmtDate(): No date data to format.

Explanation

Programmer Response

DM11075

Error in GENAddFormToSet(): pRPS->FormDatH == VMMNULLHANDLE. Tip #1: Does base rules file have ;BuildMasterFormList;1;4; as an entry?

Explanation

The function, GENAddFormToSet returned an error because the pointer FormDatH == VMMNULLHANDLE.

Programmer Response

Add the command ;BuildMasterFormList;;4; to the in the AFGJOB.JDT.

DM11076

Error in GENAddFormToSet(): Unable to VMMLocateOrdElem(pRPS->FormDatH,<Line>,).

Explanation

Programmer Response

DM11077

Error in GENAddFormToSet(): Unable to DSLoadFormDataLine(FormsetH,0,<GrpName1>,<GrpName2>,<GrpName3>,TRUE,<Name>,<Line>,0,FormH).

Explanation

The function, DSLoadFormDataLine, encountered a problem trying to add a form to the formset and returned an error to GENAddFormToSet.

Programmer Response

Verify that the command ;BuildFormList;;; is in the AFGJOB.JDT.

DM11078

Error in GENAddFormAfterForm(): Unable to DSGetFormHandle(,<GrpName1>,<GrpName2>,<GrpName3>,<Name>,1).

Explanation

Programmer Response

DM11079

Error in GENAddFormAfterForm(): Unable to GENAddFormToSet(pRPS,pRPS->CurrentFapFormsetH,<Name>,<GrpName1>,<GrpName2>,<GrpName3>,FormH).

Explanation

Programmer Response

DM11080

Error in GENAddFormAfterForm(): Unable to set copy count for error form.

Explanation

Programmer Response

DM11081

Error in EXTInitXtr(): Unable to INIGetInitValue(<TRN_FILE>, <MaxExtRecLen>,,).

Explanation

The INI Group, < Trn_File >, and the Option, MaxExtRecLen, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11082

Error in EXTInitXtr(): Unable to VMMMalloc() for extract file reader.

Explanation

Programmer Response

DM11083

Error in EXTInitXtr(): Alternate function failed to initialize

Explanation

Programmer Response

DM11084

Error in EXTInitXtr(): Unable to GENOpenExtFile(<File>,).

Explanation

The function, GENOpenExtFile, could not open for read mode the file specified in the File portion of the message and returned an error to EXTInitXtr.

Programmer Response

Verify that the file exists in the expected subdirectory. Check the INI option, ExtrFile = , in the control group < Data >. If the file exists in the specified path/subdirectory, then verify that the file name matches the one in the INI option.

DM11085

Error in EXTInitXtr(): Unable to GENCopyTrnFieldKeys(<pRPS>).

Explanation

Programmer Response

DM11086

Error in EXTTermXtr(): Alternate function failed to terminate.

Explanation

Programmer Response

DM11087

Error in EXTTermXtr(): Unable to fclose() the extract file.

Explanation

Programmer Response

DM11088

Error in EXTLoadXtrRecs(): pRPS->ExtractListH == VMMNULLHANDLE.

Explanation

Programmer Response

DM11089

Error in EXTLoadXtrRecs(): Alternate function failed to load records.

Explanation

Programmer Response

DM11090

Error in EXTLoadXtrRecs(): Extract file pointer pRPS->fpExtractFile == NULL.

Explanation

Programmer Response

DM11091

Error in EXTLoadXtrRecs(): Unable to GENGetGlbDataPtr(X_Offset).

Explanation

Programmer Response

DM11092

Error in EXTLoadXtrRecs(): Unable to read (fseek(pRPS->fpExtractFile,<Buff>,SEEK_SET) extract file.

Explanation

Programmer Response

DM11093

Error in EXTLoadXtrRecs(): Unable to VMMAppendElem() for extract data.

Explanation

Programmer Response

DM11094

Error in WriteExtractRecord(): Extract data record buffer is empty.

Explanation

Programmer Response

DM11095

Error in WriteExtractRecord(): Unable to fwrite() binary extract record.

Explanation

Programmer Response

DM11096

Error in WriteExtractRecord(): Unable to fprintf() ascii (cr-lf) extract record.

Explanation

Programmer Response

DM11097

Error in MakeGvmVarsForDfd(): Unable to CreateGvmVar(<Name>,<Type>,).

Explanation

Programmer Response

DM11098

Error in CreateGvmVar(): Unable to GVMCreateVariable(<Name>, GVM_SHORT).

Explanation

Programmer Response

DM11099

Error in CreateGvmVar(): Unable to GVMCreateData(,<Name>, sizeof(short),,).


DM11100 - DM11199 Messages

DM11100

Error in CreateGvmVar(): Unable to GVMCreateVariable(<Name>, GVM_LONG).

Explanation

Programmer Response

DM11101

Error in CreateGvmVar(): Unable to GVMCreateData(,<Name>, sizeof(long),,).

Explanation

Programmer Response

DM11102

Error in CreateGvmVar(): Unable to GVMCreateVariable(<Name>, GVM_CHAR_ARRAY).

Explanation

Programmer Response

DM11103

Error in CreateGvmVar(): Unable to GVMCreateData(,<Name>, ,,,).

Explanation

Programmer Response

DM11104

Error in CreateGVMVar(): Unable to GVMGetDataPtr(,<Name>,,,,).

Explanation

Programmer Response

DM11105

Error in CreateGVMVar(): Unable to GVMCreateVariable(<Name>, GVM_CHAR_ARRAY).

Explanation

Programmer Response

DM11106

Error in CreateGVMVar(): Unable to GVMCreateVariable(<Name>, GVM_DOUBLE).

Explanation

Programmer Response

DM11107

Error in CreateGVMVar(): Unable to GVMCreateData(,<Name>, sizeof(double),,).

Explanation

Programmer Response

DM11108

Error in CreateGVMVar(): Unable to GVMCreateVariable(<Name>, GVM_LONG_DOUBLE).

Explanation

Programmer Response

DM11109

Error in CreateGVMVar(): Unkown variable type.

Explanation

Programmer Response

DM11110

Error in GENLoadGlobalFonts(): Unable to INIGetInitValue('MasterResource','DefLib',,).

Explanation

The INI Group, < Master Resource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11111

Error in GENLoadGlobalFonts(): Unable to INIGetInitValue('MasterResource','XrfFile',,).

Explanation

The INI Group, < Master Resource >, and the Option, XrfFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11112

Error in GENLoadGlobalFonts(): Unable to INIGetInitValue('Control','XrfExt',,).

Explanation

The INI Group, < Control >, and the Option, XrfFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11113

Error in GENLoadGlobalFonts(): Unable to FAPLoadGlobalFonts(pRPS->CurrentFapFormsetH,<Path>,<File>,<Ext>).

Explanation

The function, FAPLoadGlobalFonts(pRPS), could not find or load the file specified in the <Path>,<File>,<Ext> portion of the message and returned an error to GENLoadGlobalFonts().

Programmer Response

Verify that the file exists in the specified path/subdirectory. If the file exists in the specified path/subdirectory, then verify that the file name matches the one in the subdirectory and in the error message.

Also verify that the subdirectory exists.

Also check the file name. You should not include the file name extension with this option.

For example:

< MasterResource >

XrfFile = rel102sm.fxr

This option generates an error:

DM11113: Error in GENLoadGlobalFonts(): Unable to FAPLoadGlobalFonts(pRPS->CurrentFapFormsetH,<.\deflib\>,<rel102sm.fxr>,<.FXR>).

This is the correct option:

< MasterResource >

XrfFile = rel102sm

Review XrfFile for more details about the INI option.

DM11114

Error in AddMacro(): NULL Name passed.

Explanation

Programmer Response

DM11115

Error in AddMacro(): Invalid MacroFunc. ,

Explanation

Programmer Response

DM11116

Error in EvaluateMacro(): NULL Name passed.

Explanation

Programmer Response

DM11117

Error in EvaluateMacro(): No match found for function <Name>.

Explanation

Programmer Response

DM11118

Error in EvaluateMacro(): FuncSym failed.

Explanation

Programmer Response

DM11119

Error in WriteNALine(): pRPS->CurrentFapFieldH == VMMNULLHANDLE.

Explanation

Programmer Response

DM11120

Error in WriteNALine(): Unable to DSUnloadNAFieldRecord(,<Data>,,).

Explanation

Programmer Response

DM11121

Error in WriteNALine(): Unable to DSUnloadNAFieldRecord(,<Data>,,).

Explanation

Programmer Response

DM11122

Error in WriteNALine(): Unable to flush file.

Explanation

Programmer Response

DM11123

Error in GetUsrFuncData(): Unable to GetFuncPtr(,<Name>).

Explanation

Programmer Response

DM11124

Error in GetFuncPtr(funcname): funcname == NULL.

Explanation

Programmer Response

DM11125

Error in GetFuncPtr(funcname): funcname is empty.

Explanation

Programmer Response

DM11126

Error in GetFuncPtr(funcname): funcname <Name> is not in UsrParm array.

Explanation

Programmer Response

DM11127

Error in SetUsrFuncParms(): Invalid number of parameters.

Explanation

In base code, the '@" symbol is reserved for User Functions. For example: @getRecsUsed.

R&D advises that the following symbols should not be used: '@' and '?'

Note: The '@' symbol appears to be a universal character for XML.

Programmer Response

TIP: If you were to use the '@" symbol in your MoveNum Rule, base code would expect a user function to be defined following the symbol. If that is not the case, you could get the following errors reported in the error file:

DM11127: Error in SetUsrFuncParms(): Invalid number of parameters.

DM10546: Error in RunUsrFunc(): Unable to SetUsrFuncParms(&pRPS->Field,parms). Invalid User Func parms in field rule data <1,DOCUMENT[@TYPE="DocuCorp Universal" and @VERSION="5.0"]/DOCSET/TRANSACTIONID[@NAME="KEYID"]>.

DM11128

Error in InitOverFlow(): Unable to VMMCreateList().

Explanation

Programmer Response

DM11129

Error in ResetOverFlow(): Overflow List not valid. ,

Explanation

Programmer Response

DM11130

Error in SetOvTtlRecs(): Unable to GetOvSymHdl(OvLst,<Form>,<Buff>). ",

Explanation

Programmer Response

DM11131

Error in IncOvVar(): Unable to GetOvSymHdl(OvLst,<Form>,<Buff>).

Explanation

The function, GetOvSymHdl, encountered an error while trying to process the parameters passed by the IncOvSym rule. The parameters are defined in the <Form> and <Buffer> portion of the message .

Programmer Response

  1. If the form specified in the error message exists; then goto Step 3.
  2. If not, search the DDT's for field(s) that use the IncOvSym rule and the overflow parameters identified in the error message.
  3. Using the Image Editor Format/Image Properties/Image Rules window, view the IncOvSym rule parameters in the data field. Check for correct order of the parameters and their spelling.

Reference the Rules Reference for information on the IncOvSym rule and overflow symbol definiton.

DM11132

Error in InsOvFlwFms(): Unable to DSGetFormHandle(hSet,<GrpName1>,<GrpName2>,<GrpName3>,<Name>,1).

Explanation

Programmer Response

DM11133

Error in InsOvFlwFms(): Unable to DSGetFormHandle(hSet,<GrpName1>,<GrpName2>,<GrpName3>,<Name>,1).

Explanation

Programmer Response

DM11134

Error in InsOvFlwFms(): Unable to GENAddFormToSet(pRPS,pRPS->CurrentFapFormsetH,<Name>,<GrpName1>,<GrpName2>,<GrpName3>,FormH).

Explanation

Programmer Response

DM11135

Error in GENLoadTextTable(): Unable to fopen(<File>, 'r').

Explanation

The fopen function could not find or open the file specified in the error message.

Programmer Response

Verify that the file exist in the specified subdirectory. If the file exist in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

DM11136

Error in GENLoadTextTable(): Unable to VMMCreateList(). ,

Explanation

Programmer Response

DM11137

Error in GENLoadTextTable(): Unable to VMMAppendElem(,,).

Explanation

Programmer Response

DM11138

Error in GENInitTrn(): Unable to DBInitDB().

Explanation

Programmer Response

DM11139

Error in GENInitTrn(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11140

Error in GENInitTrn(): Unable to INIGetInitValue(<Data>,<TrnDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, TrnDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11141

Error in GENInitTrn(): Unable to DBQueryFormatInfo(<File>).

Explanation

The function, DBQueryFormatInfo, could not locate the file specified in the File portion of the message and returned an error to GENInitTrn.

Programmer Response

Verify that the file exists in the specified subdirectory. If the file exists, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

DM11142

Error in GENInitTrn(): Unable to MakeGvmVarsForDfd(pRPS,AsciiTrnDfdFileH).

Explanation

Programmer Response

DM11143

Warning in GENInitTrn(): Unable to INIGetInitValue(<Data>,<DataPath>,,).

Explanation

The INI Group, < Data >, and the Option, DataPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11144

Error in GENInitTrn(): Unable to INIGetInitValue(<Data>,<NewTrn>,,).

Explanation

The INI Group, < Data >, and the Option, NewTrn, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11145

Error in GENInitTrn(): Unable to DBInitializeFile(ASCII,<Buff>,AsciiTrnDfdFileH).

Explanation

Programmer Response

DM11146

Error in GENInitTrn(): Unable to DBAllocateStructMemory().

Explanation

Programmer Response

DM11147

Error in GENInitTrn(): Unable to DBOpen(NewTrnFileH,'w').

Explanation

The function, DBOpen, could not open the NewTrn file for write-mode and returned an error to GENInitTrn.

Programmer Response

Verify that the NewTrn file exists in the subdirectory specified by the INI < Data > control group and NewTrn = option.

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<Cannot open file. No such

file or directory>, code:<2>, code:<2>, msg<.\data ewTrn.dat>.

DM11147: Error in GENInitTrn(): Unable to DBOpen(NewTrnFileH,'w').

DM11148

Error in GENInitTrn(): Alternate function failed to allocate TrnBuffer

Explanation

Programmer Response

DM11149

Error in GENInitTrn(): Unable to INIGetInitValue(<Data>,<TrnFile>,,).

Explanation

The INI Group, < Data >, and the Option, TrnFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11150

Error in GENInitTrn(): Unable to DBInitializeFile(ASCII,<File>,).

Explanation

Programmer Response

DM11151

Error in GENInitTrn(): Unable to DBAllocateStructMemory(AsciiTrnDfdFileH,TrnBufferSize).

Explanation

Programmer Response

DM11152

Error in GENInitTrn(): Unable to DBOpen(TrnFileH,'r').

Explanation

The function, DBOpen, could not find/open the TrnFile and returned an error to GENInitTrn.

Programmer Response

If executing Batch two-step or single-step mode processing, verify that the INI file has the following setting:

< Data >

TrnFile = .\NUL

DM11153

Error in GENGetNextTrnSet(): Alternate function failed to return record.

Explanation

Programmer Response

DM11154

Error in GENGetNextTrnSet(): TrnFileH == VMMNULLHANDLE.

Explanation

Programmer Response

DM11155

Warning in GENGetNextTrnSet(): Transaction trigger file is empty.

Explanation

Programmer Response

DM11156

Error in GENGetNextTrnSet(): Unable to DBGetNextRecord().

Explanation

Programmer Response

DM11157

Error in GENGetNextTrnSet(): Unable to GENParseRecord(<Buff>,AsciiTrnDfdFileH).

Explanation

Programmer Response

DM11158

Error in GENGetNextTrnSet(): Unable to GENGetDocSetNames(pRPS).

Explanation

Programmer Response

DM11159

Error in GENGetNextTrnSet(): Unable to GENShowDocSetNames(pRPS).

Explanation

Programmer Response

DM11160

Error in GENGetTrnRec(): TrnFileH == VMMNULLHANDLE.

Explanation

Programmer Response

DM11161

Error in GENGetTrnRec(): Unable to DBSeekToRecord().

Explanation

Programmer Response

DM11162

Error in GENGetTrnRec(): Unable to GENParseRecord(<%s>,AsciiTrnDfdFileH).

Explanation

Programmer Response

DM11163

Error in GENUpdateTrnRec(): Unable to GENGetGlbDataPtr('NA_Offset', NULL).

Explanation

Programmer Response

DM11164

Error in GENUpdateTrnRec(): Unable to GENGetGlbDataPtr('POL_Offset', NULL).

Explanation

Programmer Response

DM11165

Error in GENWriteRec(): FieldListH == VMMNULLHANDLE.

Explanation

Programmer Response

DM11166

Error in GENWriteRec(): Unable to GENGetGlobalDataPtr(<Name>,).

Explanation

Programmer Response

DM11167

Error in GENWriteRec(): Unable to DBPutFieldData(DfdH,<Buff>,<Name>,<Data>,).

Explanation

Programmer Response

DM11168

Error in GENWriteRec(): Unable to DBAdd(FileH,<Buff>,).

Explanation

Programmer Response

DM11169

Error in GENParseRecord(): FieldListH == VMMNULLHANDLE.

Explanation

Programmer Response

DM11170

Error in GENParseRecord(): Unable to DBGetFieldDataPtr(DFDFileH,<Buff>,<Name>).

Explanation

Programmer Response

DM11171

Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,<GroupName1>,,).

Explanation

The function, GENGetDocSetName, detected a problem and returned an error to GENGetDocSetNames.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName1>).

DM11176: Error in GENGetDocSetNames(): Unable to GENGetDocSetName (<DocSetNames>,

<TransactionType>).

DM11172

Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,<GroupName2>,,).

Explanation

The function, GENGetDocSetName, detected a problem and returned an error to GENGetDocSetNames.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName2>).

DM11176: Error in GENGetDocSetNames(): Unable to GENGetDocSetName (<DocSetNames>,

<GroupName2>).

DM11173

Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,<GroupName3>,,).

Explanation

The function, GENGetDocSetName, detected a problem and returned an error to GENGetDocSetNames.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName3>).

DM11176: Error in GENGetDocSetNames(): Unable to GENGetDocSetName (<DocSetNames>,

<GroupName3>).

DM11174

Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,<FormName>,,).

Explanation

The function, GENGetDocSetName, detected a problem and returned an error to GENGetDocSetNames.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<FormName>).

DM11176: Error in GENGetDocSetNames(): Unable to GENGetDocSetName (<DocSetNames>,

<FormName>).

DM11175

Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,<TransactionId>,,).

Explanation

The function, GENGetDocSetName, detected a problem and returned an error to GENGetDocSetNames.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<TransactionID>).

DM11176: Error in GENGetDocSetNames(): Unable to GENGetDocSetName (<DocSetNames>,

<TransactionID>).

DM11176

Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,<TransactionType>,,).

Explanation

The function, GENGetDocSetName, detected a problem and returned an error to GENGetDocSetNames.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<TransactionType>).

DM11176: Error in GENGetDocSetNames(): Unable to GENGetDocSetName (<DocSetNames>,

<TransactionType>).

DM11177

Error in GENConvertGroupNameValuesShortToLong(): Unable to INIGetInitValue(<DocSetNames>,<GroupName1>,,).

Explanation

The INI Group, < DocSetNames >, and the Option, GroupName1, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11178

Error in GENConvertGroupNameValuesShortToLong(): Unable to GENGetGlbDataPtr(<Buff>,). Tip: Does < DocSetNames > ini value:<Name> exist in the trn or rcb dfd file?

Explanation

Programmer Response

DM11179

Error in GENConvertGroupNameValuesShortToLong(): Unable to INIGetInitValue('Key1Table',<Buff>,,). DocSetNamesValue=Name.

Explanation

The INI Group, < Key1Table >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11180

Error in GENConvertGroupNameValuesShortToLong(): Unable to INIGetInitValue(<DocSetNames>,<GroupName2>,,).

Explanation

The INI Group, < DocSetNames >, and the Option, GroupName2, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11181

Error in GENConvertGroupNameValuesShortToLong(): Unable to INIGetInitValue('Key2Table',<Buff>,,). DocSetNamesValue=Name.

Explanation

The INI Group, < Key2Table >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11182

Error in GENConvertGroupNameValuesShortToLong(): Unable to INIGetInitValue(<DocSetNames>,<GroupName3>,,).

Explanation

The INI Group, < DocSetNames >, and the Option, GroupName3, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11183

Error in GENConvertGroupNameValuesShortToLong(): Unable to INIGetInitValue('Key3Table',<Buff>,,). DocSetNamesValue=Name.

Explanation

The INI Group, < Key3Table >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11184

Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,<Name>,,).

Explanation

The INI Group, < DocSetNames >, and the Option, xxxxx, could not be found in the INI file. XXXXX is specified in the <Name> portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11185

Error in GENGetDocSetName(): Unable to GENGetGlbDataPtr(<Buff>,). Tip: Does < DocSetNames > ini value:<Name> exist in the trn or rcb dfd file?

Explanation

The function, GENGetGlbDataPtr, could not find a reference to the field name specified in the <Buffer> portion of the message and returned an error to GENGetDocSetName.

Programmer Response

Verify that the < DocSetNames > INI value (specified in the <Name> portion of the message) exists in the TRN or RCB DFD file. In addition, verify that the spelling of the value name(s) match.

DM11186

Error in GENCopyTrnFieldKeys(): Unable to INIGetInitValue(<TRN_FIELDS>,<Buff>,,).

Explanation

The INI Group, < Trn_Fields >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11187

Error in GENCopyTrnFieldKeys(): Unable to sscanf(<Buff>,,,,).

Explanation

Generally, this error occurs when the system cannot find the transaction field options defined in the Trn_Fields Group. These options should match all fields in the TRNDFDFL.dfd.

TIP: You must define the offset and position for the transaction file fields even if you import data via the standard V2 import file. The JOBINIT1 rule will not execute without this data and you will receive this and other error messages.

Programmer Response

Sample Support Question: Is there a way to process a V2 file in RP without defining the offset and position for the tran fields since they are semicolon delimited in header record of the V2 file? Attached are the fsisys and afgjob files.

< TRN_FIELDS >

MBG = 2,4,N

Cabinet = 7,5,N

PolicyNumber = 14,16,N

PolicyCompany = 32,2,N

TransactionType = 34,1,N

DM11188

Error in GENCopyTrnFieldKeys(): Unable to INIPutInitValue(<ExtractKeyField>,<Key>,,).

Explanation

Programmer Response

DM11189

Error in GENExtKeyFieldsMatch(): Unable to sscanf(<Buff>,,,,).

Explanation

Programmer Response

DM11190

--> Processing: ID-GrpName1-GrpName2-GrpName3-Buff

Explanation

This LogFile message is output for each transaction that is processed. The ID, GrpName1, GrpName2, GroupName3, and Buff parameters specified in the message, identifies the transaction ID being processed plus the Key1, Key2, Key3 and transaction code(s) associated with the transaction.

Programmer Response

See the online DocuMaker RP System Reference Manual for a discussion on usage of the GroupNames, ID, and transactions codes

DM11191

Error in StrRightJustify(): Source length is greater than buffer size.

Explanation

Programmer Response

DM11192

Error in compressln(): Source length is greater than buffer size.

Explanation

Programmer Response

DM11193

Error in GEN_STRUTIL_WrapBuffIntoList(): Unable to VMMCreateList().

Explanation

Programmer Response

DM11194

Error in GEN_STRUTIL_WrapBuffIntoList(): Unable to VMMMalloc()(iMaxLineLen + 1 + 40).

Explanation

Programmer Response

DM11195

Error in GEN_STRUTIL_WrapBuffIntoList(): Unable to VMMMalloc()(strlen(psBuffer) + 1).

Explanation

Programmer Response

DM11196

Error in GEN_STRUTIL_WrapBuffIntoList(): Unable to VMMAppendElem(,,).

Explanation

Programmer Response

DM11197

Error in GEN_STRUTIL_BreakString(): Unable to malloc(strlen(pszSegment2) + 1).

Explanation

Programmer Response

DM11198

Error in GEN_STRUTIL_StrInDelimitedStr(): Invalid NULL pointers passed in.

Explanation

Programmer Response

DM11199

Error in GEN_STRUTIL_StrInDelimitedStr(): Unable to VMMalloc()(strlen(pszSelimitedStr) +1).


DM11200 - DM11299 Messages

DM11200

Error in GEN_TABUTIL_LoadListFromTable(): Unable to INIGetInitValue(<Data>,<TablesPath>,,).

Explanation

The INI Group, < Data >, and the Option, TablesPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11201

Error in GEN_TABUTIL_LoadListFromTable(): Unable to INIGetInitValue(<Data>,<Buff>,,).

Explanation

The INI Group, < Data >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message .

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11202

Error in GEN_TABUTIL_LoadListFromTable(): Unable to fopen(<Name>, 'r').

Explanation

The fopen function could not open for read mode the file, Name, as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM11203

Error in GEN_TABUTIL_LoadListFromTable(): Unable to VMMCreateList().

Explanation

Programmer Response

DM11204

Error in GEN_TABUTIL_LoadListFromTable(): Unable to VMMAppendElem(,,,).

Explanation

Programmer Response

DM11205

Error in GEN_NUMUTIL_FormatNumber(): Invalid input data pointer.

Explanation

Programmer Response

DM11206

Error in GEN_NUMUTIL_FormatNumber(): Bad or missing input format.

Explanation

Programmer Response

DM11207

Error in GEN_NUMUTIL_FormatNumber(): Bad or missing input format.

Explanation

Programmer Response

DM11208

Error in GEN_NUMUTIL_FormatNumber(): Bad or missing output format.

Explanation

Programmer Response

DM11209

Warning in GEN_NUMUTIL_FormatNumber(): Output format field length is larger than destination length, destination length will take precedence.

Explanation

Programmer Response

DM11210

Error in GEN_NUMUTIL_FormatNumber(): strtod( Pointer ) overflow

Explanation

Programmer Response

DM11211

Error in GEN_NUMUTIL_FormatNumber(): Bad equation.

Explanation

Programmer Response

DM11212

Processing: TransactionId-GroupName1-GroupName2-GroupName3-TransactionType.

Explanation

A header message output to the LogFile during GENData processing.

Programmer Response

This LogFile header is output prior to listing all transactions that are processed during the execution of the GENData step.

DM11213

Error in GENLoadGlobalFonts(): Unable to INIGetInitValue('MasterResource','DefLib',,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM11214

Warning- Invalid Format Mask: Image <Image>, Field <Field>, FmtMask <Mask>, Flag <Flag>. Data not formatted.

Explanation

Programmer Response

DM11215

Error in GENLoadGlobalFonts(): Formset not found. Check if fonts are loaded too early.

Explanation

Programmer Response

DM11216

Error in SetOvRealRecs(): Unable to GetOvSymHdl(OvLst,<Form>,<Buff>). ",

Explanation

The function, SetOvRealRecs, encountered an error while trying to process the overflow parameters passed by the @GetRecUsed function. The parameters are defined in the <Form> and <Buffer> portion of the message .

Programmer Response

  1. If the form specified in the error message exists; then goto Step 3.
  2. If not, search the DDT's for field(s) that use the @GetRecUsed function and the parameters identified in the error message.
  3. Using the Image Editor Format | Field Properties | Edit DDT window, view the @GetRecUsed function parameters in the data field. Check for correct order of the parameters and their spelling.

Reference the Rules Reference for information on the @GetRecUsed function and overflow symbol definiton.

DM11217

Warning in GENExtKeyFieldsMatch(): Extract Key Field value offset <offset> or length <length> is being ignored.

Explanation

Programmer Response

DM11218

&E&: Error in &func&: &Name& does not exist as a &type& variable and is referenced by the ini setting <&Group&> &option& = &value&. Check &filename&.

Explanation

Examples of 11218:

DM11218: Error in GENMapRecordFromINI: KEY1 does not exists as a GVM variable and is referenced by the ini setting <Trigger2Archive> Company = KEY1; ;%-30.30s. Check settings.

DM11218: Error in GENMapRecrodFromINI: COMPANY does not exists as a DFD variable and is referenced by the ini setting <Trigger2Archive> Company = KEY1; ;%-30.30s. Check APPIDX.DFD.

As you can see, this error might refer to either a missing GVM variable or to a misnamed DFD variable. When it is a DFD variable, I hope to name the DFD file at the end.

As a resolution to both situations, the first thing to do is check the spelling. Letter case is not important, but spelling is. For a GVM error, it is possible that they forgot to create the GVM in their AFGJOB. For a DFD, it is possible that they did not pick a field named in the DFD.

Programmer Response

Programmer Notes: 4/19/2002: Each of these errors (11218, 11219, 11220) is currently related to the function GENMapRecordFromINI. However, I made the function name a parameter in case I can reuse the errors somewhere else.

Group, option, and value tokens will be replace with information obtained from the INI file.

Example.

[Trigger2Archive]

Company = KEY1; ;%-30.30s

Where Group is “Trigger2Archive”.

Option is “Company”.

Value is “KEY1; ;%-30.30s”.

The GENMapRecordFromINI function is going to be used to map and optionally reformat data from GVM into record variables defined by DFDs. The mapping control is defined in the INI file.

DM11219

&E&: Warning in &func&: Format conversion of &name& using the ini setting <&Group&> &option& = &value& failed. Check your format settings. Processing will continue...

Explanation

Example of 11219:

DM11219: Warning in GENMapRecordFromINI: Format conversion of KEY1 using the ini setting <Trigger2Archive> Company = KEY1; ;%-30.30s. Check your format settings. Processing will continue...

This warning means that the data in the named GVM variable could not be formatted in the manner specified. To resolve, you first have to verify that the variable has the format that you think it does and that you have specified your format parameters correctly in the Ini option. It is also possible that the data in the GVM variable is invalid and simply cannot be converted as requested.

Programmer Response

DM11220

&E&: Error in &func&: Assignment of data to the record field &Name& failed. Check the definition of this field <&filename&>.

Explanation

Example of 11220:

DM11220: Error in GENMapRecordFromINI: Assignment of data to the record field COMPANY failed. Check the definition of this field <APPIDX.DFD>.

Basically, this means that we could not assign data into the field named. Possible reasons this might occur are that the field is not of the correct type for the data being mapped, or the definition in the DFD is invalid for some other reason.

Programmer Response

DM11225

&E&: Error in &func&: Unable to insert a banner form. Invalid ;key1;key2;formname; <&key1&;&key2&;&formname&>

Explanation

When the INI entry for BatchBannerBeginForm has incorrect syntax, the form can not be added and as a result the DAL Script does not get executed.

Programmer Response

Ex:

BatchBannerBeginForm = BANNER

Instead of

BatchBannerBeginForm = ;BANNER;BATCH;BATCH BANNER;


DM12000 - DM12099 Messages

DM12001

Error in RPProcessBases(): Unable to RPProcessOneBase(pRPS). Skipping the rest of the Bases for this batch run. See INI group:< GenDataStopOn > option:BaseErrors.

Explanation

The RPProcessOneBase function returned an error to the RPProcessBases function. The remainder of the Base rules are skipped because the INI option <GendataStopOn> BaseErrors was found set to "Yes".

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10605: Error in BaseInit1(): Unable to INIGetInitValue(<Control>,<ImageExt>,,).

DM12007: Error in RPDoBaseRulesForward(): Unable to <JOBINIT1>().

DM12003: Error in RPProcessOneBase(): Unable to RPDoBaseRulesForward

(pRPS, RP_PRE_PROC_B).

DM12001: Error in RPProcessBases(): Unable to RPProcessOneBase(pRPS). Skipping

the rest of the Bases for this batch run. See INI group:

< GenDataStopOn > option:BaseErrors.

DM12002

Error in RPProcessBases(): Unable to RPProcessOneBase(pRPS). Processing will continue. See INI group:< GenDataStopOn > option:BaseErrors.

Explanation

Programmer Response

DM12003

Error in RPProcessOneBase(): Unable to RPDoBaseRulesForward(pRPS, RP_PRE_PROC_B).

Explanation

The function, RPDoBaseRulesForward, returned an error to RPProcessOneBase.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10605: Error in BaseInit1(): Unable to INIGetInitValue(<Control>,<ImageExt>,,).

DM12007: Error in RPDoBaseRulesForward(): Unable to <JOBINIT1>().

DM12003: Error in RPProcessOneBase(): Unable to RPDoBaseRulesForward

(pRPS, RP_PRE_PROC_B).

DM12004

Error in RPProcessOneBase(): Unable to RPProcessTransactions(pRPS).

Explanation

Gendata received an error executing the function RPProcessOneBase and will skip the remainder of the transactions because the INI value <GenDataStopOn> TransactionErrors is set to Yes.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\dsldddt.c

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs():

Unable to open definition file .\ddtlib\q1snam.DDT.>.

DM10794: Error in RULStandardImageProc(): Unable to DSLoadDefTable

(pRPS,FIELD_TABLE_TYPE, <.\ddtlib\q1snam.DDT>).

DM12023: Error in RPDoBaseImageRulesForward(): Unable to <StandardImageProc>().

DM12076: Error in RPProcessOneImage(): Unable to RPDoBaseImageRulesForward(pRPS,

RP_PRE_PROC_A).

DM12082: Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <q1snam>.

Skipping the rest of the Images for this Form. See INI group:< GenDataStopOn >

option:ImageErrors.

DM12067: Error in RPProcessOneTransaction(): Unable to RPProcessImages(pRPS).

DM12064: Error in RPProcessTransactions(): Unable to RPProcessOneTransaction(pRPS).

Skipping the rest of the Transactions for this Base. See INI group:

< GenDataStopOn > option:TransactionErrors.

DM12004: Error in RPProcessOneBase(): Unable to RPProcessTransactions(pRPS).

DM12005

Error in RPProcessOneBase(): Unable to RPDoBaseRulesReverse(pRPS, RP_POST_PROC_B).

Explanation

Programmer Response

DM12006

Error in RPLocateBaseRule(): Unable to VMMLocateHashElem(,<Name>,). ...this base rule may not have been registered.

Explanation

The function, VMMLocateHashElem, could not locate the rule specified in the <Name> portion of the message and returned an error to RPLocateBaseRule.

Programmer Response

Verify the spelling of the rule, if incorrect, correct it in the AFGJOB.JDT. See the Rules Reference for the correct spelling of rules plus which rules are valid .

DM12007

Error in RPDoBaseRulesForward(): Unable to <Name>().

Explanation

The function specified in the " Unable to <Name>(). " part of the message returned an error to RPDoBaseRulesForward.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10605: Error in BaseInit1(): Unable to INIGetInitValue(<Control>,<ImageExt>,,).

DM12007: Error in RPDoBaseRulesForward(): Unable to <JOBINIT1>().

DM12008

Error in RPLocateBaseRule(): Unable to VMMLocateHashElem(,<Name>,). ...this base rule may not have been registered.

Explanation

Programmer Response

DM12009

Error in RPDoBaseRulesReverse(): Unable to <Name>().

Explanation

Programmer Response

DM12010

Error in DSAddBaseRule(): Unable to FSIParseLine(<Buff>,,,,,).

Explanation

Programmer Response

DM12011

Error in DSAddBaseRule(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM12012

Error in RPLocateBaseRule(): Unable to VMMLocateHashElem(,<Name>,). ...this base rule may not have been registered.

Explanation

The function, VMMLocateHashElem, could not locate the rule specified in the <Name> portion of the message and returned an error to RPLocateBaseRule.

Programmer Response

Verify the spelling of the rule, if incorrect, correct it in the AFGJOB.JDT. See the Rules Reference for the correct spelling of rules plus which rules are valid .

DM12013

Error in RPDoBaseRulesForward(): Unable to <Name>().

Explanation

Programmer Response

DM12014

Error in RPDoBaseFieldRulesReverse(): Unable to <Name>().

Explanation

Programmer Response

DM12015

Error in DSAddBaseFieldRule(): Unable to FSIParseLine(<Buff>,,,,,).

Explanation

Programmer Response

DM12016

Error in DSAddBaseFieldRule(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM12017

Error in RPDoBaseFormsetRulesForward(): Unable to RPLocateBaseRule(pRPS,<Name>).

Explanation

The function, RPLocateBaseRule, could not locate the rule specified in the <Name> portion of the message and returned an error to RPDocBaseFormsetRulesForward.

Programmer Response

Verify the spelling of the rule, if incorrect, correct it in the AFGJOB.JDT. See the Rules Reference for the correct spelling of rules plus which rules are valid .

DM12018

Error in RPDoBaseFormsetRulesForward(): Unable to <Name>().

Explanation

The function specified in the Unable to <Name> portion of the message and returned an error to RPDoBaseRulesForward.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM13021: Error in RCBUpdateGlbRecips(): Value of INI group:'RECIP_NAMES' option:*

should not be blank.

DM10700: Error in BuildFormList(): Unable to RCBUpdateGlbRecips(pRPS).

DM12018: Error in RPDoBaseFormsetRulesForward(): Unable to <BUILDFORMLIST>().

DM12019

Error in DSAddBaseImageRule(): Unable to RPLocateBaseRule(pRPS, <Name>).

Explanation

Programmer Response

DM12020

Error in DSAddBaseFormsetRule(): Unable to FSIParseLine(<Buff>,,,,,).

Explanation

Programmer Response

DM12021

Error in DSAddBaseFormsetRule(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM12022

Error in RPLocateBaseRule(): Unable to VMMLocateHashElem(,<Name>,). ...this base rule may not have been registered.

Explanation

The function, VMMLocateHashElem, could not locate the rule specified in the <Name> portion of the message and returned an error to RPLocateBaseRule.

Programmer Response

Verify the spelling of the rule, if incorrect, correct it in the AFGJOB.JDT. See the Rules Reference for the correct spelling of rules plus which rules are valid .

DM12023

Error in RPDoBaseImageRulesForward(): Unable to <Name>().

Explanation

The function specified in the Unable to < Name > portion of the message and returned an error to RPDoBaseRulesForward.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs():

Unable to open definition file .\ddtlib\q1snam.DDT.>.

DM10794: Error in RULStandardImageProc(): Unable to DSLoadDefTable

(pRPS,FIELD_TABLE_TYPE,<.\ddtlib\q1snam.DDT>).

DM12023: Error in RPDoBaseImageRulesForward(): Unable to <STANDARDIMAGEPROC>().

DM12025

Error in RPDoBaseImageRulesReverse(): Unable to <Name>().

Explanation

Programmer Response

DM12026

Error in DSAddBaseImageRule(): Unable to FSIParseLine(<Buff>,,,,,).

Explanation

Programmer Response

DM12027

Error in DSAddBaseImageRule(): Unable to VMMAppendElem().

Explanation

The function, RPProcessBases, returned an error to RPRun.

Programmer Response

DM12028

Error in DSLoadDefTable(): Definition File Name is blank.

Explanation

Programmer Response

DM12029

Error in DSLoadDefTable(): Unable to open definition file <File>.

Explanation

Programmer Response

DM12030

Error in DSLoadDefTable(): Unable to DoDataLine(pRPS,<Num>,<Buff>).

Explanation

Programmer Response

DM12031

Error in DSLoadDefTable(): Data definition file contains illegal syntax, possible pre release 8.0 version.

Explanation

Programmer Response

DM12032

Error in DSLoadDefTable(): Unable to RPAddRuleFileToPool(pRPS,<File>).

Explanation

Programmer Response

DM12033

Error in DoDataLine(): Unable to DSAddBaseRule(pRPS, <Buff>).

Explanation

Programmer Response

DM12034

Error in DoDataLine(): Unable to DSAddBaseFormsetRule(pRPS, <Buff>).

Explanation

Programmer Response

DM12035

Error in DoDataLine(): Unable to DSAddBaseImageRule(pRPS, <Buff>).

Explanation

Programmer Response

DM12036

Error in DoDataLine(): Unable to DSAddBaseFieldRule(pRPS, <Buff>).

Explanation

Programmer Response

DM12037

Error in DoDataLine(): Unable to DSAddImageRule(pRPS, <Buff>).

Explanation

Programmer Response

DM12038

Error in DoDataLine(): Unable to DSAddImageField(pRPS, <Buff>).

Explanation

Programmer Response

DM12039

Error in DoDataLine(): Unable to DSAddFieldRule(<Buff>, pRPS).

Explanation

Programmer Response

DM12040

Error in DoDataLine(): Unable to DSAddFieldRule(pRPS, <Buff>).

Explanation

Programmer Response

DM12041

-->Transaction: ID Error in RPFAPErrorNotify(): FAP library error: area:<Area>, code:<Code1>, code:<Code1>, msg<Buff>.

Explanation

The DM12041 message is a general purpose error message that is issued when Documaker errors are detected. This message should be followed, in the ERRFILE, by additional DM##### error messages. Often times, the DM##### message that follows the DM12041 message will provide information that will help you to narrow down the nature of the error.

Programmer Response

In the examples below, if you don't see the exact DM12041 error message, look up the DM##### error message that follows the DM12041 message. This message should provide information to help you narrow down the nature of the error. For example, in the ERRFILE message list directly below, there are two DM12041 messages followed by a DM10771 message. In this case, you would look up the DM10771 error message. Note that the error messages become more generalized, and probably less helpful, as you move down the list.

DM12041: Error : FAP library error: Transaction:<5234567>, area:<QAREL.V102.SOURCE(DSLOADNA)

code1:<-1>, code2:<0>

msg:<FAP Append Error>.

DM12041: Error : FAP library error: Transaction:<5234567>, area:<QAREL.V102.SOURCE(DSLOADNA)

code1:<92>, code2:<0>

msg:<EDC5092I An I/O abend was trapped.>.

DM10771: Error in PurgeOutput(): Unable to DSUnloadNAFormset(,,).

...

DM16010: Error in RunGenData(): Unable to RPRun(, <DD:DEFLIB(AfgJob)>).

Example: 1.

Caused by the command ;JobInit1;1;; missing in the AFGJOB.JDT

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\dsldddt.c

Aug 4 2000 22:20:00

400.101.017

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSAddFieldRules: Unable to DSLoadDDT(pRPS,<FIELD_TABLE_TYPE>,<master.ddt>).

Example: 2.

NewTrn file missing or name spelled incorrect.

Error in RPFAPErrorNotify(): FAP library error: area:<Cannot open file. No such file

or directory>,code:<2>, code:<2>, msg<.\data ewTrn.da>.

Example: 3.

INI group(s), < DBHandler:ODBC > and/or < DBTable:ODBC >, plus options missings

or ODBC drive not initialized in the Control Panel | ODBC Data Source window.

Error in RPFAPErrorNotify(): FAP library error: area:<ODBC Error>, code:<0>, code:<0>,

msg<IM002 0 [Microsoft][ODBC Driver Manager] Data source name not found and no

default driver specified

DM12041: Error : FAP library error: Transaction:<>, area:<ODBC Error>

code1:<0>, code2:<0>

msg:<IM002 0 [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

>. Troubleshooting Ensure there are no spaces in the control group name. Specifically, [DBHandler:ODBC] and NOT [DBHandler: ODBC]

Review Server for accuracy.

DM12041: Error : FAP library error: Transaction:<>, area:<ODBC Error>

code1:<911>, code2:<911>

msg:<S1009 911 [Microsoft][ODBC SQL Server Driver][SQL Server]Attempt to locate entry in Sysdatabases for database 'q' by name failed - no entry found under that name. Make sure that name is entered properly.

Review Qualifier for accuracy.

Example: 4.

Path to FontLib missing in INI file

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\pclfont.c

Aug 7 2000 14:44:26

400.101.017

PCLFontHandler>, code:<11>, code:<11>, msg<Failure to find font .\deflib\FPTIBF.PCL>.

Example 5:

DM12041: Error : FAP library error: Transaction:<>, area:<..\C\pclfont.c

Apr 11 2002 13:40:23

400.101.020

PCLFontHandler>

code1:<11>, code2:<0>

msg:<Failure to find font .\fntlib\FPUNBD.PCL>.

Troubleshooting Tip:

For Genprint:

When the system attempts to download fonts, here is what happens:

The system will find the FXR file (generally in the defib directory), then attempt to find the fonts.

The system first looks for the fonts in the INI file Fontlib directory. If you do not define the fontlib option, the system will then look in the INI file deflib directory for the fonts.

Tip: You must define either or both the Fontlib and Deflib options with valid paths in the INI file.

Otherwise, the system will return an error DM12041.

Review DownLoadFonts for accuracy.

Review FontLib for accuracy.

Review Deflib for accuracy.

Example: 6.

BuildFormList command missing from the AFGJOB.JDT

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\dsgetset.c

Aug 4 2000 22:19:54

400.101.017

DSLoadFormDataLine>, code:<2>, code:<2>, msg<Invalid object handle was passed>.

Example 7:

DM12041: Error : FAP library error: Transaction:<>, area:<Cannot open file. No such file or directory>

code1:<2>, code2:<2>

msg:<\\Fsisrv09\Mstrres\RP10\data\NUL>.

Review Data Control Group option: TrnFile for troubleshooting steps.

The TrnFile option should include a full path and file name (.\NUL).

Example 8:

DAL statement in the named DAL script failed to return a value. Determine why a value was not returned or if the requested process is valid in GenPrint.

DM12041: Error : FAP library error: Transaction:<>, area:<..\C\genbannr.c,Jun 17 2004 21:29:41,400.110.002,GENDALErrorNotify>

code1:<0>, code2:<0>

msg:<Script: c:\docucorp\DocuMakerRP\mstrres\InsCtr\Deflib\Archive_Name.dal

Line: 6 Col: 33 Err: 15 Token: ) Msg: No result value returned>.

Example 9:

DM12041: Error : FAP library error: Transaction:<1234567>, area:<QAREL.V102.SOURCE(DSLOADNA),Dec 17 2004 18:38:01,400.102.036,DSNoFlushAppendBuffer>

code1:<-1>, code2:<0>

msg:<FAP Append Error>.

DM12041: Error : FAP library error: Transaction:<1234567>, area:<QAREL.V102.SOURCE(DSLOADNA),Dec 17 2004 18:38:01,400.102.036,DSNoFlushAppendBuffer>

code1:<3>, code2:<0>

msg:<EDC5003I Truncation of a record occurred during an I/O operation.>.

Truncation of a record occurred while writing to the NAFILE in the GENDATA run. This error usually only occurs on the OS/390 (MVS or z/OS) platform. To see which line is being truncated, look at the next to last record in the NAFILE after GENDATA has ended with the truncation error. To resolve this error, either increase the LRECL for the NAFILE in the GENDATA execution step of your JCL or shorten the truncated record in the FAP file (by redesigning the FAP).

Example 10:

DM12041: Error : FAP library error: Transaction:<5234567>, area:<QAREL.V102.SOURCE(DSLOADNA),Dec 17 2004 18:38:01,400.102.036,DSNoFlushAppendBuffer>

code1:<-1>, code2:<0>

msg:<FAP Append Error>.

DM12041: Error : FAP library error: Transaction:<5234567>, area:<QAREL.V102.SOURCE(DSLOADNA),Dec 17 2004 18:38:01,400.102.036,DSNoFlushAppendBuffer>

code1:<92>, code2:<0>

msg:<EDC5092I An I/O abend was trapped.>.

If running on Windows or Unix, make sure the disk drive is not full. If running on OS/390 (MVS or z/OS), check your job log for an abend code. The GENDATA program may have abended with a B37, D37, or E37 code because the NAFILE was running out of space. To resolve this abend error, increase the SPACE parameters for the NAFILE in the GENDATA execution step of your JCL.

DM12041: Error : FAP library error: Transaction:<>, area:<CARExtractDataRecs>

code1:<3>, code2:<0>

msg:<Error: Unknown compression method.

>.

The error message "Error: Unknown compression method." will be emitted if retrieving data from archive or Library Manager with unsupported compression method for the current Documaker version. This message might be received, for example, if you insert resources into a Library using Documaker version 11.0 and try to retrieve, or check out, those resources using Documaker version 10.2 or 10.3.

DM12042

Error in RPDALErrorNotify(): DAL library error: script:<Script>, lineno:<Line>, col:<Col>, errnum:<Err>, token:<Token>, msg:<Buff>.

Explanation

The DAL library encountered an invalid syntax expression (Buff) and an error was returned to RPDALErrorNotify. The problem is in the DAL script (Script) at line (lineno), and column number (Col), which caused error number (errnum) trying to process token (Token). The items in parenthesis are the parameter portions of the message.

Programmer Response

Review the DAL script contained in the DAL rule. Check for the following

items that could cause the script to have invalid syntax.

-Missing colons between commands.

-Missing parentheses

-Invalid command abbreviation

-

See the online DAL Reference Guide for the correct syntax for the DAL commands.

DM12043

Error in RPWriteErrHeader(): Unable to retrieve data. "

Explanation

Programmer Response

DM12044

Error in RPWriteErrHeader(): Unable to RPParseErrHeader(pRPS,<Err>,<Data>).

Explanation

Programmer Response

DM12045

Error in RPParseErrHeader(): Invalid format string <Buff>.

Explanation

Programmer Response

DM12046

Error in RPParseErrHeader(): Invalid TEXT string for rule seterrhdr.

Explanation

Programmer Response

DM12047

Message No Longer Used. Formerly RPProcessFields().

Explanation

Programmer Response

DM12048

Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <Name>. Processing will Buff continue for image <Image>. See INI group:< GenDataStopOn > option: FieldErrors.

Explanation

The function, RPProcessOneField, encountered an error trying to process the rule in the field on the image (as specified in the <Name> and <Image> portion of the message). Processing will not continue and an error will be returned to RPPrecessFields.

Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <Name>. Processing will Buff continue for image <Image>.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error: Failed to parse the output Size and Percision. <C>.

DM10473: Error in MOVENUM: Image<q1gdbd> Field<PREM BASIS 1> Unable to format for

output.

DM12051: Error in RPProcessOneField(): Unable to <MOVENUM>().

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <PREM BASIS 1>.

Processing will NOT continue for image <q1gdbd>. See INI group:

< GenDataStopOn > option: FieldErrors.

DM12049

Error in RPProcessOneField(): Unable to RPDoBaseFieldRulesForward(pRPS, RP_PRE_PROC_A).

Explanation

Programmer Response

DM12050

Error in RPProcessOneField(): Unable to RPLocateFieldRule(pRPS, <Name>).

Explanation

The function, RPLocateFieldRule, could not execute the rule specified in the < Name >( ) portion of the message and returned an error to RPProcessOneField.

Programmer Response

The rule specified in the message is spelled incorrect or can not be found. Verify the spelling of the rule name, if incorrect, use the Image Editor | Field Properties | Edit DDTtab to update the field rule.

This message is one in a group of related messages. Follow the message chain down to locate a message that identifies the image/field that has the error..

Example:

DM12050: Error in RPProcessOneField(): Unable to RPLocateFieldRule(pRPS, <MOVE_>).

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <SEND COPY TO:>

Processing will NOT continue for image <q1addr>. See INI group:

< GenDataStopOn > option: FieldErrors.

DM12051

Error in RPProcessOneField(): Unable to <Name>().

Explanation

An error occurred trying to process the rule specified in the <Name> portion of the message and returned an error to RPProcessOneField.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error: Failed to parse the output Size and Percision. <C>.

DM10473: Error in MOVENUM: Image<q1gdbd> Field<PREM BASIS 1> Unable to format

for output.

DM12051: Error in RPProcessOneField(): Unable to <MOVENUM>().

DM12052

Error in RPProcessOneField(): Unable to RPDoBaseFieldRulesReverse(pRPS, RP_POST_PROC_A).

Explanation

Programmer Response

DM12053

Error in DSAddFieldRule(): Unable to FSIParseLine(<Buff>,...).

Explanation

Programmer Response

DM12054

Error in DSAddFieldRule(): Format mask (Field.FmtMask) has too many chars. Maximum chars allowed is Buff. Processing will continue with truncated FmtMask.

Explanation

Programmer Response

DM12055

Error in DSAddFieldRule(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM12056

Error in DSAddImageField(): Unable to FSIParseLine(<Buff>,...).

Explanation

Programmer Response

DM12057

Error in DSAddImageField(pRPS,<Buff>): Global field rules have not been added.

Explanation

Programmer Response

DM12058

Error in DSAddImageField(pRPS,<Buff>): Unable to GetFieldRule(). Check field rule file for field:<Buff>.

Explanation

Programmer Response

DM12059

Error in DSAddImageField(pRPS,<Buff>): Unable to VMMAppendElem().

Explanation

Programmer Response

DM12060

Error in DSLoadFieldRules(): Unable to DSLoadDefTable(pRPS,FIELD_TABLE_TYPE,<File>,).

Explanation

Programmer Response

DM12061

Error in DSLoadFieldRules(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM12062

Error in DSLoadFieldRules(): Unable to VMMCreateList().

Explanation

Programmer Response

DM12063

Error in DSLoadFieldRules(): Unable to VMMInsertHashElem().

Explanation

Programmer Response

DM12064

Error in RPProcessTransactions(): Unable to RPProcessOneTransaction(pRPS). Skipping the rest of the Transactions for this Base. See INI group:< GenDataStopOn > option:TransactionErrors.

Explanation

Gendata received an error executing the function RPProcessOneTransaction and will skip the remainder of the transactions because the INI value <GenDataStopOn> TransactionErrors is set to Yes.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\dsldddt.c

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs(): Unable to open

definition file .\ddtlib\q1snam.DDT.>.

DM10794: Error in RULStandardImageProc(): Unable to DSLoadDefTable(pRPS,FIELD_TABLE_TYPE,

<.\ddtlib\q1snam.DDT>).

DM12023: Error in RPDoBaseImageRulesForward(): Unable to <STANDARDIMAGEPROC>().

DM12076: Error in RPProcessOneImage(): Unable to RPDoBaseImageRulesForward(pRPS,

RP_PRE_PROC_A).

DM12082: Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <q1snam>.

Skipping the rest of the Images for this Form. See INI group:< GenDataStopOn >

option:ImageErrors.

DM12067: Error in RPProcessOneTransaction(): Unable to RPProcessImages(pRPS).

DM12064: Error in RPProcessTransactions(): Unable to RPProcessOneTransaction(pRPS).

Skipping the rest of the Transactions for this Base. See INI group:< GenDataStopOn >

option:TransactionErrors.

DM12065

Error in RPProcessTransactions(): Unable to RPProcessOneTransaction(pRPS). Processing will continue. See INI group:< GenDataStopOn > option:TransactionErrors.

Explanation

Programmer Response

DM12066

Error in RPProcessOneTransaction(): Unable to RPDoBaseFormsetRulesForward(pRPS, RP_PRE_PROC_A).

Explanation

The function, RPDoBaseFormsetRulesForward, return an error to RPProcessOneTransaction.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM13021: Error in RCBUpdateGlbRecips(): Value of INI group:'RECIP_NAMES' option:* should not be

blank.

DM10700: Error in BuildFormList(): Unable to RCBUpdateGlbRecips(pRPS).

DM12018: Error in RPDoBaseFormsetRulesForward(): Unable to <BUILDFORMLIST>().

DM12066: Error in RPProcessOneTransaction(): Unable to RPDoBaseFormsetRulesForward(pRPS,

RP_PRE_PROC_A).

DM12067

Error in RPProcessOneTransaction(): Unable to RPProcessImages(pRPS).

Explanation

The function, RPProcessImages(pRPS), returned an error to RPProcessOneTransaction( ).

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\dsldddt.c

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs(): Unable to open

definition file .\ddtlib\q1snam.DDT.>.

DM10794: Error in RULStandardImageProc(): Unable to DSLoadDefTable(pRPS,FIELD_TABLE_TYPE,

<.\ddtlib\q1snam.DDT>).

DM12023: Error in RPDoBaseImageRulesForward(): Unable to <STANDARDIMAGEPROC>().

DM12076: Error in RPProcessOneImage(): Unable to RPDoBaseImageRulesForward(pRPS,

RP_PRE_PROC_A).

DM12082: Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <q1snam>.

Skipping the rest of the Images for this Form. See INI group:< GenDataStopOn >

option:ImageErrors.

DM12067: Error in RPProcessOneTransaction(): Unable to RPProcessImages(pRPS).

DM12068

Error in RPProcessOneTransaction(): Unable to RPDoBaseFormsetRulesReverse(pRPS, RP_POST_PROC_A).

Explanation

The RPDoBaseFormsetRulesReverse function returned an error to the RPProcessOneTransaction.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM13025: Warning in RCBSendToErrBatch(): The transaction is being assigned to the

error batch.

DM10747: Error in RULUpdateRecips(): Unable to RCBMatchPrintBatch('ERROR').

DM10690: Error in RULStandardTransactionProc(): Unable to RULUpdateRecips().

DM12149: Error in RPDoBaseFormsetRulesReverse(): Unable to <RulStandardTransactionProc>().

DM12068: Error in RPProcessOneTransaction(): Unable to RPDoBaseFormsetRulesReverse

pRPS, RP_POST_PROC_A).

DM12069

Error in RPLoadDLL(): Unable to INIGetInitValue('DLL',<Name>,,).

Explanation

The INI Group, < DLL >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Name portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM12070

Error in RPLoadDLL(): Unable to UTLLoadLibrary(<File>).

Explanation

Programmer Response

DM12071

Error in RPLoadDLL(): Unable to VMMInsOrdElem().

Explanation

Programmer Response

DM12072

Error in RPGetProcAddr(): Unable to VMMFindOrdElem(, <Name>,,,,,,).

Explanation

Programmer Response

DM12073

Error in RPGetProcAddr(): Unable to UTLQueryProcAddr(,<Buff>).

Explanation

Programmer Response

DM12074

Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <Image>. Skipping the rest of the Images for this Form. See INI group:< GenDataStopOn > option:ImageErrors.

Explanation

The function, RPProcessOneImage(pRPS), could not process the image specified in the < Name > portion of the message and returned an error to RPProcessImages().

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs(): Unable

to open definition file .\ddtlib\q1snam.DDT.>.

DM10794: Error in RULStandardImageProc(): Unable to DSLoadDefTable

(pRPS,FIELD_TABLE_TYPE, <.\ddtlib\q1snam.DDT>).

DM12023: Error in RPDoBaseImageRulesForward(): Unable to <STANDARDIMAGEPROC>().

DM12076: Error in RPProcessOneImage(): Unable to RPDoBaseImageRulesForward(pRPS,

RP_PRE_PROC_A).

DM12082: Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

DM12074: Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <q1snam>.

Skipping the rest of the Images for this Form. See INI group:

< GenDataStopOn > option:ImageErrors.

DM12075

Error in RPProcessImages(): Unable to RPProcessOneImage(pRPS) <Image>. Processing will continue for form <Form>. See INI group:< GenDataStopOn > option:ImageErrors.

Explanation

Programmer Response

DM12076

Error in RPProcessOneImage(): Unable to RPDoBaseImageRulesForward(pRPS, RP_PRE_PROC_A).

Explanation

The function specified in the Unable to < Name >( ) portion of the message returned an error to RPProcessOneImage().

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs(): Unable

to open definition file .\ddtlib\q1snam.DDT.>.

DM10794: Error in RULStandardImageProc(): Unable toDSLoadDefTable(pRPS,Field_Table_Type,

<.\ddtlib\q1snam.DDT>).

DM12023: Error in RPDoBaseImageRulesForward(): Unable to <STANDARDIMAGEPROC>().

DM12076: Error in RPProcessOneImage(): Unable to RPDoBaseImageRulesForward

(pRPS, RP_PRE_PROC_A).

DM12077

Error in RPProcessOneImage(): Unable to RPDoImageRules(pRPS, RP_PRE_PROC_B).

Explanation

The function, RPDoImageRules, returned an error to RPProcessOneImage.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11112: Error in GENLoadGlobalFonts(): Unable to INIGetInitValue('Control','XrfExt',,).

DM10824: Error in TextMergeParagraph(): Unable to GENLoadGlobalFonts(pRPS).

DM12086: Error in RPDoImageRules(): Unable to <TEXTMERGEPARAGRAPH>().

DM12077: Error in RPProcessOneImage(): Unable to RPDoImageRules(pRPS, RP_PRE_PROC_B).

DM12078

Error in RPProcessOneImage(): Unable to RPDoBaseImageRulesForward(pRPS, RP_PRE_PROC_C).

Explanation

Programmer Response

DM12079

Error in RPDoCurImagePostProcs(): Unable to RPDoBaseImageRulesReverse(pRPS, RP_POST_PROC_C).

Explanation

Programmer Response

DM12080

Error in RPDoCurImagePostProcs(): Unable to RPDoImageRules(pRPS, RP_POST_PROC_B).

Explanation

The function, RPDoImageRules, returned an error to RPDoCurImagePostProcs.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11131: Error in IncOvVar(): Unable to GetOvSymHdl(OvLst,<1GDBD>,<CGDECBDOVF>).

DM10831: Error in IncOvSym(): Unable to IncOvVar(<1GDBD>, <CGDECBDOVF>).

DM12086: Error in RPDoImageRules(): Unable to <INCOVSYM>().

DM12080: Error in RPDoCurImagePostProcs(): Unable to RPDoImageRules

(pRPS, RP_POST_PROC_B).

DM12081

Error in RPDoCurImagePostProcs(): Unable to RPDoBaseImageRulesReverse(pRPS, RP_POST_PROC_A).

Explanation

Programmer Response

DM12082

Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

Explanation

The function specified in the Unable to < Name >( ) portion of the message returned an error to RPProcessOneImage().

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs(): Unable

to open definition file .\ddtlib\q1snam.DDT.>.

DM10794: Error in RULStandardImageProc(): Unable to DSLoadDefTable(pRPS,Field_Table_Type,

<.\ddtlib\q1snam.DDT>).

DM12023: Error in RPDoBaseImageRulesForward(): Unable to <STANDARDIMAGEPROC>().

DM12076: Error in RPProcessOneImage(): Unable to RPDoBaseImageRulesForward(pRPS,

RP_PRE_PROC_A).

DM12082: Error in RPProcessOneImage(): Unable to RPDoCurImagePreProcs(pRPS).

DM12083

Error in RPProcessOneImage(): Unable to RPProcessFields(pRPS).

Explanation

The function, RPProcessFields, returned an error to RPProcessOneImage.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM12050: Error in RPProcessOneField(): Unable to RPLocateFieldRule(pRPS, <MOVE_>).

DM12048: Error in RPProcessFields(): Unable to RPProcessOneField(pRPS) <SEND COPY TO:>

Processing will NOT continue for image <q1addr>. See INI group:

< GenDataStopOn > option: FieldErrors.

DM12083: Error in RPProcessOneImage(): Unable to RPProcessFields(pRPS).

DM12084

Error in RPProcessOneImage(): Unable to RPDoCurImagePostProcs(pRPS).

Explanation

The function, RPDoCurImagePostProcs, returned an error to RPProcessOneImage.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11131: Error in IncOvVar(): Unable to GetOvSymHdl(OvLst,<1GDBD>,<CGDECBDOVF>).

DM10831: Error in IncOvSym(): Unable to IncOvVar(<1GDBD>, <CGDECBDOVF>).

DM12086: Error in RPDoImageRules(): Unable to <INCOVSYM>().

DM12080: Error in RPDoCurImagePostProcs(): Unable to RPDoImageRules

(pRPS, RP_POST_PROC_B).

DM12084: Error in RPProcessOneImage(): Unable to RPDoCurImagePostProcs(pRPS).

DM12085

Error in RPLocateImageRule(): Unable to VMMLocateHashElem(,<Name>,). ...this image rule may not have been registered for image <Image>.

Explanation

The function, VMMLocateHashElem, could not locate the rule used in the image (specified in the <Name> and <Image> portion of the message) and returned an error to RPLocateImageRule.

Programmer Response

Verify that the rule is spelled correctly. If spelled correctly, verify that you are using the required CUSLib for the project's master resource library.

DM12086

Error in RPDoImageRules(): Unable to <Name>().

Explanation

The function specified in the Name> portion of the message returned an error to RPDoImageRules().

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11112: Error in GENLoadGlobalFonts(): Unable to INIGetInitValue('Control','XrfExt',,).

DM10824: Error in TextMergeParagraph(): Unable to GENLoadGlobalFonts(pRPS).

DM12086: Error in RPDoImageRules(): Unable to <TextMergeParagraph>().

DM12087

Error in DSAddImageRule(): Unable to FSIParseLine(<>,,,,,).

Explanation

Programmer Response

DM12088

Error in DSAddImageRule(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM12089

Error in RPSetLogProc(): Unable to (func)(pRPS, INIT_USER_PROC, <Buff>, <Buffer>).

Explanation

Programmer Response

DM12090

Error in RPSetDisplayProc(): Unable to (func)(pRPS, INIT_USER_PROC, 0L, NULL).

Explanation

Programmer Response

DM12091

Error in RPAddRuleFileToPool(): Definition file deffile is empty.

Explanation

Programmer Response

DM12092

Error in RPAddRuleFileToPool(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM12093

Error in RPGetFromRuleFilePool(pRPS,deffile): deffile is empty.

Explanation

Programmer Response

DM12094

Error in RPRegisterBaseRule(): basefunc is NULL.

Explanation

Programmer Response

DM12095

Error in RPRegisterBaseRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12096

Error in RPRegisterBaseRule(): Unable to RPInitRuleLists(RP_RULEBUCKETS).

Explanation

Programmer Response

DM12097

Error in RPRegisterBaseRule(): Unable to VMMInsertHashElem().

Explanation

Programmer Response

DM12098

Error in RPRegisterImageRule(): imagefunc is NULL.

Explanation

Programmer Response

DM12099

Error in RPRegisterImageRule(): pszRuleName is NULL.


DM12100 - DM12199 Messages

DM12100

Error in RPRegisterImageRule(): Unable to RPInitRuleLists(RP_RULEBUCKETS).

Explanation

Programmer Response

DM12101

Error in RPRegisterImageRule(): Unable to VMMInsertHashElem().

Explanation

Programmer Response

DM12102

Error in RPRegisterFieldRule(): fieldfunc is NULL.

Explanation

Programmer Response

DM12103

Error in RPRegisterFieldRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12104

Error in RPRegisterFieldRule(): Unable to RPInitRuleLists(RP_RULEBUCKETS).

Explanation

Programmer Response

DM12105

Error in RPRegisterFieldRule(): Unable to VMMInsertHashElem().

Explanation

Programmer Response

DM12106

Error in RPRegisterRecipRule(): rcpfunc is NULL.

Explanation

Programmer Response

DM12107

Error in RPRegisterRecipRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12108

Error in RPRegisterRecipRule(): Unable to RPInitRuleLists(RP_RULEBUCKETS).

Explanation

Programmer Response

DM12109

Error in RPRegisterRecipRule(): Unable to VMMInsertHashElem().

Explanation

Programmer Response

DM12110

Error in RPUnRegisterBaseRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12111

Error in RPUnRegisterBaseRule(): No rules have been registered.

Explanation

Programmer Response

DM12112

Error in RPUnRegisterBaseRule(): Unable to VMMLocateHashElem(,<Name>,). VMMNULLHANDLE was returned .

Explanation

Programmer Response

DM12113

Error in RPUnRegisterBaseRule(): Unable to VMMLocateHashElem(,<Name>,). ...this base rule may not have been registered.

Explanation

Programmer Response

DM12114

Error in RPUnRegisterBaseRule(): Unable to VMMLocateHashElem(,<Name>,). ...this base rule may not have been registered.

Explanation

Programmer Response

DM12115

Error in RPUnRegisterImageRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12116

Error in RPUnRegisterImageRule(): No rules have been registered.

Explanation

Programmer Response

DM12117

Error in RPUnRegisterImageRule(): Unable to VMMLocateHashElem(,<Name>,). VMMNULLHANDLE was returned .

Explanation

Programmer Response

DM12118

Error in RPUnRegisterImageRule(): Unable to VMMLocateHashElem(,<Name>,). ...this image rule may not have been registered.

Explanation

Programmer Response

DM12119

Error in RPUnRegisterFieldRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12120

Error in RPUnRegisterFieldRule(): No rules have been registered.

Explanation

Programmer Response

DM12121

Error in RPUnRegisterFieldRule(): Unable to VMMLocateHashElem(,<Name>,). VMMNULLHANDLE was returned .

Explanation

Programmer Response

DM12122

Error in RPUnRegisterFieldRule(): Unable to VMMLocateHashElem(,<Name>,). ...this field rule may not have been registered.

Explanation

Programmer Response

DM12123

Error in RPUnRegisterRecipRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12124

Error in RPRun(): Unable to RPLoadDLL().

Explanation

Programmer Response

DM12125

Error in RPRun(): BaseFile is NULL

Explanation

Programmer Response

DM12126

Error in RPRun(): Unable to DSLoadDefTable(,,<File>,).

Explanation

The function, DSLoadDefTable could load or open the file specified in the error message.

Programmer Response

Verify that the file exist in the specified subdirectory. If the file exist in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\dsldddt.c

Jun 30 2000 09:44:58

400.101.017

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs(): Unable to open definition file .\deflib\AfgJob.Jdt.>.

DM12126: Error in RPRun(): Unable to DSLoadDefTable(,,<.\deflib\AfgJob.Jdt>,).

DM12127

Error in RPRun(): Unable to RPProcessBases(pRPS).

Explanation

The RPProcessBases function returned an error to the RPRun function.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10605: Error in BaseInit1(): Unable to INIGetInitValue(<Control>,<ImageExt>,,).

DM12007: Error in RPDoBaseRulesForward(): Unable to <JOBINIT1>().

DM12003: Error in RPProcessOneBase(): Unable to RPDoBaseRulesForward(pRPS, RP_PRE_PROC_B).

DM12001: Error in RPProcessBases(): Unable to RPProcessOneBase(pRPS). Skipping the rest of the

Bases for this batch run. See INI group: < GenDataStopOn > option:BaseErrors.

DM12127: Error in RPRun(): Unable to RPProcessBases(pRPS).

DM12128

Error in RPUnRegisterRecipRule(): No rules have been registered.

Explanation

Programmer Response

DM12129

Error in RPUnRegisterRecipRule(): Unable to VMMLocateHashElem(,<Name>,). VMMNULLHANDLE was returned.

Explanation

Programmer Response

DM12130

Error in RPUnRegisterRecipRule(): Unable to VMMLocateHashElem(,<Name>,). ...this field rule may not have been registered.

Explanation

Programmer Response

DM12131

Error in RPLocateBaseRule(): pszRuleName == NULL.

Explanation

Programmer Response

DM12132

Error in RPLocateBaseRule(): Unable to RPRegisterBaseRule(,<Name>).

Explanation

Programmer Response

DM12133

Error in RPLocateBaseRule(): Unable to RPGetProcAddr(,<Name>,).

Explanation

Programmer Response

DM12134

Error in RPLocateImageRule(): pszRuleName == NULL.

Explanation

Programmer Response

DM12135

Error in RPLocateImageRule(): Unable to RPRegisterImageRule(,<Name>).

Explanation

Programmer Response

DM12136

Error in RPLocateImageRule(): Unable to RPGetProcAddr: <Name>.

Explanation

Programmer Response

DM12137

Error in RPLocateFieldRule(): pszRuleName == NULL.

Explanation

Programmer Response

DM12138

Error in RPLocateFieldRule(pRPS, <Name>): No field rules are registered.

Explanation

A prior called process failed to execute to requested action.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

EXAMPLE 1:

DM12041: Error : FAP library error: Transaction:<>, area:<..\C\genbannr.c,Jun 17 2004 21:29:41,400.110.002,GENDALErrorNotify> code1:<0>, code2:<0>

msg:<Script: c:\docucorp\DocuMakerRP\mstrres\InsCtr\Deflib\FaxEml_Name.dal

Line: 10 Col: 56 Err: 15 Token: ) Msg: No result value returned>.

DM12139

Error in RPLocateFieldRule(): Unable to RPRegisterFieldRule(,<Name>).

Explanation

Programmer Response

DM12140

Error in RPLocateFieldRule(): Unable to RPGetProcAddr: <Name>.

Explanation

Programmer Response

DM12141

Error in RPLocateRecipRule(): pszRuleName == NULL.

Explanation

Programmer Response

DM12142

Error in RPLocateRecipRule(pRPS, <Name>): No field rules are registered.

Explanation

Programmer Response

DM12143

Error in RPLocateRecipRule(): Unable to RPRegisterRecipRule(,<Name>).

Explanation

Programmer Response

DM12144

Error in RPLocateRecipRule(): Unable to RPGetProcAddr: <Name>.

Explanation

Programmer Response

DM12145

In RPRun: Caching Num .DDT files

Explanation

This LogFile message informs the user how many DDT files GENData cached in memory.

Programmer Response

A LogFile informative message.

DM12146

Object use statistics. -------------------------- Type Num --------------------------

Explanation

A header message output to the LogFile by GENData.

Programmer Response

A LogFile header message created during the GENData step..

DM12147

NameNum

Explanation

Programmer Response

DM12148

Error in RPDoBaseFormsetRulesReverse(): Unable to RPLocateBaseRule(pRPS,<Name>).

Explanation

Programmer Response

DM12149

Error in RPDoBaseFormsetRulesReverse(): Unable to <Name>().

Explanation

The function, Name, returned an error to the function RPDoBaseFormsetRulesReverse.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM13025: Warning in RCBSendToErrBatch(): The transaction is being assigned to

the error batch.

DM10747: Error in RULUpdateRecips(): Unable to RCBMatchPrintBatch('ERROR').

DM10690: Error in RULStandardTransactionProc(): Unable to RULUpdateRecips().

DM12149: Error in RPDoBaseFormsetRulesReverse(): Unable to <RulStandardTransactionProc>().

If executing Batch single-step mode processing, check to see if the rule BatchingByRecipINI or BatchByPageCount exists in the AFGJOB.JDT.

DM12150

Error in RPRegisterOMRRule(): OMRfunc is NULL.

Explanation

Programmer Response

DM12151

Error in RPRegisterOMRRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12152

Error in RPRegisterOMRRule(): Unable to RPInitRuleLists(RP_RULEBUCKETS).

Explanation

Programmer Response

DM12153

Error in RPRegisterOMRRule(): Unable to VMMInsertHashElem().

Explanation

Programmer Response

DM12154

Error in RPUnRegisterOMRRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12155

Error in RPUnRegisterOMRRule(): No rules have been registered.

Explanation

Programmer Response

DM12156

Error in RPUnRegisterOMRRule(): Unable to VMMLocateHashElem(,<Name>,). VMMNULLHANDLE was returned.

Explanation

Programmer Response

DM12157

Error in RPUnRegisterOMRRule(): Unable to VMMLocateHashElem(,<Name>,). ...this field rule may not have been registered.

Explanation

Programmer Response

DM12158

Error in RPLocateOMRRule(): pszRuleName == NULL.

Explanation

Programmer Response

DM12159

Error in RPLocateOMRRule(pRPS, <Name>): No OMR rules are registered.

Explanation

Programmer Response

DM12160

Error in RPLocateOMRRule(): Unable to RPRegisterOMRRule(,<Name>).

Explanation

Programmer Response

DM12161

Error in RPLocateOMRRule(): Unable to RPGetProcAddr: <Name>.

Explanation

Programmer Response

DM12162

Error in RPRegisterGroupRule(): groupfunc is NULL.

Explanation

Programmer Response

DM12163

Error in RPRegisterGroupRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12164

Error in RPRegisterGroupRule(): Unable to RPInitRuleLists(RP_RULEBUCKETS).

Explanation

Programmer Response

DM12165

Error in RPRegisterGroupRule(): Unable to VMMInsertHashElem().

Explanation

Programmer Response

DM12166

Error in RPUnRegisterGroupRule(): pszRuleName is NULL.

Explanation

Programmer Response

DM12167

Error in RPUnRegisterGroupRule(): No rules have been registered.

Explanation

Programmer Response

DM12168

Error in RPUnRegisterGroupRule(): Unable to VMMLocateHashElem(,<Name>,). VMMNULLHANDLE was returned.

Explanation

Programmer Response

DM12169

Error in RPUnRegisterGroupRule(): Unable to VMMLocateHashElem(,<Name>,). ...this field rule may not have been registered.

Explanation

Programmer Response

DM12170

Error in RPLocateGroupRule(): pszRuleName == NULL.

Explanation

Programmer Response

DM12171

Error in RPLocateGroupRule(pRPS, <Name>): No Group rules are registered.

Explanation

Programmer Response

DM12172

Error in RPLocateGroupRule(): Unable to RPRegisterGroupRule(,<Name>).

Explanation

Programmer Response

DM12173

Error in RPLocateGroupRule(): Unable to RPGetProcAddr: <Name>.


DM13000 - DM13099 Messages

DM13001

Error in RCBInit(): Unable to DBQueryFormatInfo(<Name>).

Explanation

The function, DBQueryFormatInfo, returned an error to RCBInit.

Programmer Response

Verify that the file exist in the specified subdirectory. If the file exist in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

DM13002

Error in RCBInit(): Unable to DBAllocateStructMemory(RCBDFDFileH,).

Explanation

Programmer Response

DM13003

Error in RCBInit(): Unable to MakeGvmVarsForDfd(RCBDFDFileH).

Explanation

Programmer Response

DM13004

Error in RCBInitBatch(): NULL pointer passed to RCBInitBatch.

Explanation

Programmer Response

DM13005

Error in RCBInitBatch(): Unable to to DBInitializeFile(ASCII,<Name>,,).

Explanation

The function, DBInitializeFile, was unable to initialize the batch file name specified in the <Name> portion of the message and returned an error to RCBInitBatch.

Programmer Response

Verify that the rule InitPageBatchedJob exists in the AFGJOB.JDT.

DM13006

Error in RCBInitBatch(): Unable to DBopen(RCBFileH, ) for write.

Explanation

Programmer Response

DM13007

Error in RCBInitBatch(): Unable to DBopen(RCBFileH, ) for read.

Explanation

Programmer Response

DM13008

Error in RCBGetNextRcpRec(): Input RCP file is not open.

Explanation

Programmer Response

DM13009

Error in RCBGetNextRcpRec(): Unable to DBGetNextRecord(RCBFileH,,).

Explanation

The INI Group, < Print_Batches >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the <Name> portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM13010

Error in RCBGetNextRcpRec(): Unable to GENParseRecord(,RCBDFDFileH).

Explanation

Programmer Response

DM13011

Error in RCBGetFirstRcpSetRec(): RCB file is not open.

Explanation

Programmer Response

DM13012

Error in RCBGetNextRcpRec(): Unable to DBGetNextRecord(RCBFileH,,).

Explanation

Programmer Response

DM13013

Error in RCBGetNextRcpSetRec(): Unable to GENParseRecord(<Buff>,).

Explanation

Programmer Response

DM13014

Error in RCBTermBatch(): RCB file is not open.

Explanation

Programmer Response

DM13015

Error in RCBOpenPrintBatchFiles(): AliasPrintBatches specified, but ini option < Data > < BatchTable > not found.

Explanation

Programmer Response

DM13016

Error in RCBOpenPrintBatchFiles(): Unable to RCBInitBatch(Buff,MODE_WRITE).

Explanation

Programmer Response

DM13017

Error in RCBOpenPrintBatchFiles(): Unable to VMMAppendElem(,,).

Explanation

Programmer Response

DM13018

Error in RCBOpenPrintBatchFiles(): Unable to INIFirstInitValue(Print_Batches,NULL,,).

Explanation

The function, INIFirsInitValue, returned an error to RCBOpenPrintBatchFiles

Programmer Response

Verify that the INI group, < Print_Batches > exist in the INI. The < Print_Batches > group is required for GENData processing.

For more information on INI Groups and Options, refer to the online INI Reference Guide.

DM13019

Error in RCBOpenPrintBatchFiles(): Unable to INIGetInitValue(<Print_Batches>,<Buff>,,).

Explanation

The INI Group, < Print_Batches >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Buff portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM13020

Error in RCBUpdateGlbRecips(): Unable to INIFirstInitValue('RECIP_NAMES',NULL,,).

Explanation

The function, INIFirstInitValue, could not locate the first INI option in the INI group, < Recip_Names >, and returned an error to RCBUpdateGlbRecips.

Programmer Response

Verify that the INI group, < Recip_Names >, exists in the INI file. Add the indicated INI group and its option(s) to the INI file. For more information on INI Options, refer to the online INI Reference Guide.

DM13021

Error in RCBUpdateGlbRecips(): Value of INI group:'RECIP_NAMES' option:Buff should not be blank.

Explanation

The INI option specified in the < Buffer >( ) portion of the message should not be blank.

Programmer Response

Check the INI options defined in the INI group < Recip_Names > for proper definition. For more information on INI Options, refer to the online INI Reference Guide.

If the options are correct, check below the group for comment line(s) that do not start with ' ; '.

DM13022

Error in RCBUpdateGlbRecips(): Unable to DSLoadGlbRecip(,,).

Explanation

Programmer Response

DM13023

Warning in RCBSendToErrBatch(): Unable to assign transaction to the Error batch. The SentToManualBatch field is not defined in the TrnDfdFile.

Explanation

Programmer Response

DM13024

Warning in RCBSendToErrBatch(): Transaction assignment is being changed from the Manual batch to the Error batch.

Explanation

Programmer Response

DM13025

Warning in RCBSendToErrBatch(): Transaction is being assigned to the Error batch.

Explanation

GENData found a field, while processing a transaction, whose data was blank (missing) and it's field 'HostRequired' flag was set 'On'. The transaction is being assigned to the Error batch.

Programmer Response

This warning message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11216: Error in SetOvRealRecs(): Unable to GetOvSymHdl(OvLst,<CGDECBDOVF/11>

,<CLSSCDREC>).

DM13025: Warning in RCBSendToErrBatch(): The transaction is being assigned to the

error batch.

DM13026

Warning in RCBSendToManualBatch(): Unable to assign transaction to the Manual batch. The SentToManualBatch field is not defined in the TrnDfdFile.

Explanation

Programmer Response

DM13027

Warning in RCBSendToManualBatch(): Transaction is being assigned to the Manual batch.

Explanation

GENData found a field, while processing a transaction, whose data was blank (missing) and its field 'OperatorRequired or EitherRequired' flag was set 'On' . The transaction was assigned to the WIP batch.

Programmer Response

This warning message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM10010: Warning in RULStandardFieldProc(): Field rule (fap) field:<Form Line2>

data is blank and field rule Flag3 (operator required) is 'Y'. Image:<QMDC3>

DM13027: Warning in RCBSendToManualBatch(): Transaction is being assigned to the

Manual batch.

DM13028

Warning in RCBMapFromINI(): Cannot locate form named in RecipMap2GVM processing continuing. \n

Explanation

The from listed in the INI group RecipMap2GVM could not be located in the formset.

Programmer Response

DM13029

Warning in RCBMapFromINI(): Cannot locate image named in RecipMap2GVM INI Group. \n

Explanation

The image listed in the INI group RecipMap2GVM could not be found in the formset.

Programmer Response

DM13030

Error in RCBMapFromINI(): GVM varible <&gvm&> not found. \n

Explanation

The GVM variable listed in the INI Group RecipMap2GVM could not be located.

Programmer Response

DM13031

Error in RCBMapFromINI(): Field <&field&> requested without image. \n

Explanation

A field was specified in the INI group RecipMap2GVM without a valid image being also specified.

Programmer Response

DM13032

Error in RCBMapFromINI(): Field <&field&> was not found on image <&image&> for recipient <&recip&>. \n

Explanation

The field listed in the INI group RecipMap2GVM was not found on the image specified for the current recipient.

Programmer Response

DM13033

Error in RCBMapFromINI(): Required value missing for GVM Variable <&gvm&>.\n

Explanation

The field listed for the GVM Variable in the INI group RecipMap2GVM contained no data.


DM14000 - DM14099 Messages

DM14001

Error in A2WInit(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DelLib, could not be found in the INI file.

Programmer Response

DM14002

Error in A2WInit(): Unable to DBInitDB((FAPDBINSTALLER)ASCInstallHandler).

Explanation

Programmer Response

DM14003

Error in A2WInit(): Unable to INIGetInitValue(<Data>,<RcbDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, RCBDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM14004

Error in A2WInit(): Unable to RCBInit(pRPS,<File>,DBHandler).

Explanation

Programmer Response

DM14005

Error in A2WInit(): Unable to RCBInitBatch(pRPS,<Name>,MODE_READ).

Explanation

Programmer Response

DM14006

Error in A2WGetFirst(): Unable to RCBGetNextRcpRec(). Tip: MANUAL batch may be empty.

Explanation

Programmer Response

DM14007

Error in A2WGetFirst(): Unable to A2WSetupCurrentRecord().

Explanation

The function, A2WSetupCurrentRecord, detected a problem and returned an error to A2WGetFirst.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName1>).

DM11171: Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,

<GroupName1>).

DM14014: Error in A2WSetupCurrentRecord(): Unable to GENGetDocSetNames(pRPS).

DM14007: Error in A2WGetFirst(): Unable to A2WSetupCurrentRecord().

DM14008

Error in A2WGetNext(): Unable to A2WSeekToNextNAOffset().

Explanation

Programmer Response

DM14009

Error in A2WGetFNext(): Unable to A2WSetupCurrentRecord().

Explanation

Programmer Response

DM14010

Error in A2WSeekToNextNAOffset(): Unable to RCBGetNextRcpRec(pRPS).

Explanation

Programmer Response

DM14011

Error in A2WSeekToNextNAOffset(): Unable to GENGetGblData('NA_Offset',,).

Explanation

Programmer Response

DM14012

Error in A2WSetupCurrentRecord(): Unable to GENGetGblData('NA_Offset',,).

Explanation

Programmer Response

DM14013

Error in A2WSetupCurrentRecord(): Unable to GENGetGblData('POL_Offset',,).

Explanation

Programmer Response

DM14014

Error in A2WSetupCurrentRecord(): Unable to GENGetDocSetNames(pRPS).

Explanation

The function, GENGetDocSetNames, detected a problem and returned an error to A2WSetup.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName1>).

DM11171: Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,

<GroupName1>).

DM14014: Error in A2WSetupCurrentRecord(): Unable to GENGetDocSetNames(pRPS).

DM14015

Error in A2WSetupCurrentRecord(): Unable to GENShowDocSetNames(pRPS).

Explanation

Programmer Response

DM14016

Error in A2WSetupCurrentRecord(): Unable to INIFirstInitValue(<Trigger2Wip>,NULL,,).

Explanation

The INI Group, < Trigger2WIP>, and the Option(s) could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM14017

Error in A2WSetupCurrentRecord(): Unable to WIPGetFieldDataPtr(VMMNULLHANDLE,wip,<File> Tip: Ini value:<Name> for group:<Trigger2Wip> and option:<Buff> is not a field in the wip dfd file.

Explanation

The function, WIPGetFieldDataPtr, detected a problem and returned an error to A2WSetupCurrentRecord. The INI vaule xxxxx for group < Trigger2Wip > and option zzzzz are not a fields in the WIP DFD file. The content of xxxxx and zzzzz respectively are specified in the <Name> and <Buff> portion of the message.

Programmer Response

1. <Trigger2Wip>

Verify if the INI value xxxxx for group:<Trigger2Wip> and option zzzzz are not a fields in the WIP DFD file.

Review WipDfdFile for accuracy.

The content of xxxxx and zzzzz respectively are specified in the <Name> and

<Buff> portion of the message.

2. Verify that the INI group < Trn_Fields > exists in the INI file.

DM14018

Error in A2WSetupCurrentRecord(): Ini option:<Name> for group:<Trigger2Wip> is not a field in the manual recipient batch dfd file.

Explanation

Programmer Response

DM14019

Error in A2WSetupCurrentRecord(): Unable to WIPSetFieldData(VMMNULLHANDLE,wip,<Data>,<Name>).

Explanation

Programmer Response

Please check < Trigger2WIP > control group.

Make sure left-hand side options match fields defined in rcbdfdfl.dfd and right-hand side values match fields defined in wip.dfd.

If the error message is returned while Genarc is run, check the field RUNDATE in appidx.dfd and make sure that it's INT_TYPE and INT_LENGTH is defined as follows:

< FIELD:RunDate >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 8


DM15000 - DM15099 Message

DM15000 - DM15099 Messages

DM15001

Error in RunGenTrn(): Unable to RPSetLogProc().

Explanation

Programmer Response

DM15002

Error in RunGenTrn(): Unable to RPSetDisplayProc().

Explanation

Programmer Response

DM15003

Error in RunGenTrn(): Unable to INIGetInitValue(<TRN_FILE>,<MaxExtRecLen>,,).

Explanation

The INI Group, <TRN_File>, and the Option, MaxExtRecLen, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15004

Warning in RunGenTrn(): Unable to INIGetInitValue(<Data>,<DataPath>,,).

Explanation

The INI Group, <Data>, and the Option, DataPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15005

Error in RunGenTrn(): Unable to INIGetInitValue(<Data>,<ExtrFile>,,).

Explanation

The INI Group, <Data>, and the Option, ExtrFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15006

Error in RunGenTrn(): Unable to VMMCreateList() for ExcludeListH.

Explanation

Programmer Response

DM15007

Warning in RunGenTrn(). Unable to BuildExcludeList(pRPS).

Explanation

The BuildExcludeList function returned a warning to RunGenTrn.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM15027: Error in BuildExcludeList(): Unable to INIGetInitValue(<MasterResource>,

<DefLibPath>,,).

DM15007: Warning in RunGenTrn(). Unable to BuildExcludeList(pRPS).

DM15008

Error in RunGenTrn(): Unable to FilterExtrFile(pRPS).

Explanation

Programmer Response

DM15009

Error in RunGenTrn(): Unable to GENCopyTrnFieldKeys(pRPS).

Explanation

Programmer Response

DM15010

Error in RunGenTrn(): Unable to InitTrnProcess(pRPS).

Explanation

The InitTrnProcess function returned an error to RunGenTrn.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM15016: Error in InitTrnProcess(): Unable to INIGetInitValue(<MasterResource>,

<DefLib>,,).

DM15010: Error in RunGenTrn(): Unable to InitTrnProcess(pRPS).

DM15011

Error in RunGenTrn(): Unable to BuildTrnRecs(pRPS).

Explanation

The BuildTrnRecs function returned an error to RunGenTrn.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM15032: Error in BuildExtractFieldList(): Unable to INIFirstInitValue(<TRN_FIELDS>,NULL,,).

DM15039: Error in BuildTrnRecs(): Unable to BuildExtractFieldList(pRPS).

DM15011: Error in RunGenTrn(): Unable to BuildTrnRecs(pRPS).

DM15012

Error in RunGenTrn(): Unable to TermTrnProcess().

Explanation

Programmer Response

DM15013

Error in RunGenTrn(): Unable to DBTerm().

Explanation

Programmer Response

DM15014

Error in InitTrnProcess(): Unable to DBInitDB().

Explanation

Programmer Response

DM15015

Warning in InitTrnProcess(): Unable to INIGetInitValue(<Data>,<TrnDfdFile>,,).

Explanation

The INI Group, <Data>, and the Option, TrnDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15016

Error in InitTrnProcess(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, <MasterResource>, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15017

Error in InitTrnProcess(): Unable to INIGetInitValue(<Data>,<TrnDfdFile>,,).

Explanation

The INI Group, <Data>, and the Option, TrnDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15018

Error in InitTrnProcess(): Unable to DBQueryFormatInfo(<File>).

Explanation

Programmer Response

DM15019

Error in InitTrnProcess(): Unable to MakeGvmVarsForDfd(pRPS,AsciiTrnDfdFileH).

Explanation

Programmer Response

DM15020

Error in InitTrnProcess(): Unable to LoadDummyFields().

Explanation

Programmer Response

DM15021

Error in InitTrnProcess(): Unable to INIGetInitValue(<Data>,<TrnFile>,,).

Explanation

The INI Group, <Data>, and the Option, TrnFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15022

Error in InitTrnProcess(): Unable to DBInitializeFile(ASCII,<File>,AsciiTrnDfdFileH).

Explanation

Programmer Response

DM15023

Error in InitTrnProcess(): Unable to DBAllocateStructMemory().

Explanation

Programmer Response

DM15024

Error in InitTrnProcess(): Unable to DBOpen(TrnFileH, ).

Explanation

Programmer Response

DM15025

Error in InitTrnProcess(): Unable to GENOpenExtFile(<File>,MODE_READ).

Explanation

GenTrn initialization processing could not find or open the extract file.

Programmer Response

The Extract file is not in correct subdirectory as specified by the INI options; the software logic defaults its search to the current directory.

Or the extract file name is spelled incorrectly; check the name of the file in its specified directory and in the INI group <Data>, option ExtrFile.

DM15026

Error in InitTrnProcess(): Unable to CreateLists(pRPS).

Explanation

Programmer Response

DM15027

Error in BuildExcludeList(): Unable to INIGetInitValue(<MasterResource>,<DefLibPath>,,).

Explanation

The INI Group, <MasterResource>, and the Option, DefLibPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15028

Error in BuildExcludeList(): Unable to INIGetInitValue(<Data>,<Exclude>,,).

Explanation

The INI Group, <Data>, and the Option, Exclude, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15029

Warning in BuildExcludeList(): Unable to fopen(<Buff>,'r').

Explanation

The function, BuildExcludeList could not find/open the indicated file in the specified subdirectory.

Programmer Response

Verify that the indicated file exist in the specified subdirectory. If file is not required, then eliminate the INI option reference (to said file) from the INI group, Data. For more information on INI Options, refer to the online INI Reference Guide.

DM15030

Error in FilterExtrFile(): Unable to VMMMalloc()(GENGetMaxExtRecLen()+1).

Explanation

Programmer Response

DM15031

Error in FilterExtrFile(): Unable to GENOpenExtFile(<File>,MODE_READ).

Explanation

Programmer Response

DM15032

Error in BuildExtractFieldList(): Unable to INIFirstInitValue(<TRN_FIELDS>,NULL,,).

Explanation

The BuildExtractFieldList function could not find the INI group TRN_Fields.

Programmer Response

Add the INI group, TRN_Fields, to your FSISYS.INI. The TRN_Fields associates a field in the Transaction DFD File, TRNDFDFL (on the left) with an offset and length of the field in the EXTRACT file (on the right).

Example:

< TRN_FIELDS >

Symbol = 1,3,N

PolicyNum = 4,7,N

Module = 38,2,N

DM15033

Error in BuildExtractFieldList(): Unable to INIGetInitValue(<TRN_FIELDS>,<Buffer>,,).

Explanation

The INI Group, < Trn_Fields >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Name portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15034

Error in BuildExtractFieldList(): Unable to VMMAppendElem(ExtractFieldListH,,).

Explanation

Programmer Response

DM15035

Error in UpdateExtractFieldData(): Unable to GENGetGlbDataPtr(<Name>,NULL). Tip: Make sure fields defined in INI group < TRN_FIELDS > are fields defined in the trn dfd file.

Explanation

For each INI option defined in the <TRN_Fields> group, there must be a FieldName option defined in the <Fields> group in the TRNDFDFile.

Programmer Response

Compare the TRN_Fields INI options with the definitions in the TRNDFDFile and add any missing fields.

Example: The option <Symbol> was missing in the TRNDFDFile.

DM15035: Error in UpdateExtractFieldData(): Unable to GENGetGlbDataPtr(<Symbol>,NULL).

Tip: Make sure fields defined in INI group < TRN_FIELDS > are fields defined in the trn dfd file.

DM15036

Error in UpdateExtractFieldData(): An extract record is too short to obtain a field value from, for the field <Name> defined in the INI group TRN_FIELDS. Tip: Make sure there are no blank records within or on the end of the extract data file.

Explanation

The < Trn_Fields > INI control group has a field, xxxxx, whose offset or offset plus field length is greater than the extract record length. The field is specified in the Name portion of the message.

Programmer Response

Verify that you have defined the field offset(s) and length(s) correctly in the < Trn_Fields > INI control group.

Verify that you have set the < Trn_File > INI control group MaxExtRecLen option to the maximum transaction record length.

DM15037

Warning in RunGenTrn(): The length of token <Name> defined in INI is larger than its DFD defined equivelent, data will be truncated.

Explanation

Programmer Response

DM15038

Error in BuildTrnRecs(): Unable to VMMMalloc()(GENGetMaxExtRecLen()+1).

Explanation

Programmer Response

DM15039

Error in BuildTrnRecs(): Unable to BuildExtractFieldList(pRPS).

Explanation

The BuildExtractFieldList function returned an error to BuildTrnRecs.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM15032: Error in BuildExtractFieldList(): Unable to INIFirstInitValue

(<Trn_Fields>,Null).

DM15039: Error in BuildTrnRecs(): Unable to BuildExtractFieldList(pRPS).

DM15040

Error in BuildTrnRecs(): Unable to ftell(fpIN) for extract file.

Explanation

GENTRN was not able to establish an offset value into the EXTRACT file.

Programmer Response

If running on MVS, OS390 or z/OS and using VSAM for the EXTRACT file, make sure that you have specified the INI option:

< TRN_FILE >

BinaryExt = Yes

DM15041

Error in BuildTrnRecs(): Unable to GENGetGlbDataPtr('X_Offset',NULL).

Explanation

Programmer Response

DM15042

Error in BuildTrnRecs(): Unable to UpdateExtractFieldData(pRPS,ExtBuff).

Explanation

The function, UpdateExtractFieldData, returned an error to BuildTrnRecs.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM15035: Error in UpdateExtractFieldData(): Unable to GENGetGlbDataPtr

(<Symbol>,Null).

Tip: Make sure fields defined in INI group < Trn_Fields > are fields defined

in the trn dfd file.

DM15042: Error in BuildTrnRecs(): Unable to UpdateExtractFieldData(pRPS,ExtBuff).

DM15043

Error in BuildTrnRecs(): Unable to GENConvertGroupNameValuesShorttoLong(pRPS).

Explanation

Programmer Response

DM15044

Error in BuildTrnRecs(): Unable to GENGetDocSetNames(pRPS).

Explanation

The BuildTrnRecs function could not locate one of the required INI group/options. Required INI group/options have been omitted from the INI.

  • < DocSetNames >
  • < Key1Table >
  • < Key2Table >
  • < Key3Table >

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error: Required INI definition omitted.

Cannot locate INI group <DocSetNames> with value GroupName1= defined.

DM15044: Error in BuildTrnRecs(): Unable to GENGetDocSetNames(pRPS).

Example: The MaxExtRecLen option in the INI group,< Trn_File >, is defined

incorrectly

Error: Required INI definition omitted.

Cannot locate INI group <Key1Table> with value 8 1= defined.

DM15044: Error in BuildTrnRecs(): Unable to GENGetDocSetNames(pRPS).

DM15045

Error in BuildTrnRecs(): Unable to GENShowDocSetNames(pRPS).

Explanation

Programmer Response

DM15046

Error in BuildTrnRecs(): Unable to GENGetGlbDataPtr('PKG_Offset',NULL).

Explanation

Programmer Response

DM15047

Error in BuildTrnRecs(): Unable to GENWriteRec(pRPS,TrnFileH,AsciiTrnDfdFileH,TrnBuffer,TrnBufferSize).

Explanation

Programmer Response

DM15048

Error in BuildTrnRecs(): Unable to ftell(fpIN) for extract file.

Explanation

Programmer Response

DM15049

Error in BuildTrnRecs(): Unable to GENGetGlbDataPtr('X_Offset',NULL).

Explanation

Programmer Response

DM15050

Error in BuildTrnRecs(): Unable to WriteSTATRecs(pRPS).

Explanation

Programmer Response

DM15051

Warning in RunGenTrn(). No transaction trigger records were created, possible cause is empty extract data file.

Explanation

Required INI definition(s) have been omitted from the FSISys.INI.

Programmer Response

Check to see if the INI group/options,ExtractKeyField, is missing from the FSISys.INI.

Example:

< ExtractKeyField >

Key = 4,7

SearchMask = 11,HEADERREC

DM15052

Error in CreateLists(): Unable to VMMCreateList() for ExtractFieldListH).

Explanation

Programmer Response

DM15053

Error in LoadDummyFields(): Unable to INIGetInitValue(<GentrnDummyFields>,<Buff>,,).

Explanation

The INI Group, < GENTrnDummyFields >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Name portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM15054

Error in LoadDummyFields(): Unable to GENGetGlbDataPtr(<Buff>,NULL). Tip: Make sure fields defined in < GentrnDummyFields > group are fields defined in the trn dfd file.

Explanation

Programmer Response

DM15055

Number of records filtered: Buff.

Explanation

Programmer Response

DM15056

Filtered ExtractRecord (Buff) matching: Mask.

Explanation

This LogFile message informs the user that transaction, xxxxx, in the extract file was not processed because it’s mask, yyyyy, matches one found in the exclude file(s). The transaction and mask are specified in the Buff and Mask portions of the message.

Programmer Response

This is a LogFile informative message. Reference the INI group < Data > and option Exclude in the online INI Reference Guide.

DM15057

All records from extract file were filtered. Extract file now has 0 length. Empty extract file after filter.

Explanation

Programmer Response

DM15058

Buff

Explanation

Programmer Response

DM15059

Warning in UpdateExtractFieldData(): Unable to format the data field. Check the field <Name> defined in INI group <TRN_FIELDS>.

Explanation

Programmer Response

DM15060

Extract filename specified = <file>.

Explanation

Programmer Response

DM15066

Error in &function&: Unable to LBYInitializeLoaders(). The system is configured to use Library Manager but the library could not be initialized. Verify that the library is specified correctly in the INI file and is accessible.

Explanation

The call to LBYInitializeLoaders failed in the function (GenTrn.c, GenData.c, or GenPrint/PrintEnv.c). The usual reason that LBYInitializeLoaders fails is that the library is stored in a DBMS(DB2, Oracle, or SQL Server) and the DBMS or the database within the DBMS is not accessible.

Programmer Response

Verify that the DBMS or the database within the DBMS used by the MRL is up and running. If not, please re-initialize the DBMS or the database within the DBMS.


DM16000 - DM16099 Messages

DM16001

Gendata: Caching Buff .FAP files.

Explanation

Informs the user how many FAP files were cached in memory.

Programmer Response

This message is no longer output by GENData. It has been replaced the following message from FAPFile.c.

Example:

FAP Caching Stats:

Method : LFUO

Size : 100

Hits : 12 = 55%

Misses : 10 = 45%

Total : 22

Purges : 0

DM16002

Error in GenArcInit(): Unable to DBInitDB(ASCInstallHandler).

Explanation

Programmer Response

DM16003

Error in GenArcInit(): Unable to DBInitDB(DB2InstallHandler, ' DB2 ').

Explanation

Programmer Response

DM16004

Error in RunGenData(): Unable to RPSetLogProc(pRPS, RPStandardLogProc).

Explanation

Programmer Response

DM16005

Error in RunGenData(): Unable to RPSetDisplayProc(pRPS, RPStandardDisplayProc).

Explanation

Programmer Response

DM16006

Error in RunGenData(): Unable to RPRegisterStandardRules(pRPS).

Explanation

Programmer Response

DM16007

Error in RunGenData(): Unable to CUSRegisterCustomRules(pRPS).

Explanation

Programmer Response

DM16008

Error in RunGenData(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM16009

Error in RunGenData(): Unable to INIGetInitValue(<Data>,<AfgJobFile>,,).

Explanation

The INI Group, <Data>, and the Option, AFGJobFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM16010

Error in RunGenData(): Unable to RPRun(, <File>).

Explanation

The function, RPRun, returned an error to RunGENData.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\dsldddt.c

Jun 30 2000 09:44:58

400.101.017

DSLoadDDTRecs>, code:<65535>, code:<65535>, msg<Error in DSLoadDDTRecs():

Unable to open definition file .\deflib\AfgJob.Jdt.>.

DM12126: Error in RPRun(): Unable to DSLoadDefTable(,,<.\deflib\AfgJob.Jdt>,).

DM16010: Error in RunGenData(): Unable to RPRun(, <.\deflib\AfgJob.Jdt>).


DM17000 - DM17099 Messages

DM17001

Error in SortFormsForRecip(): Unable to INIGetInitValue(<SORT_FORMS>,<TABLENAME>,,).

Explanation

The INI Group, < Sort_Forms >, and the Option, TableName, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17002

Error in SortFormsForRecip(): Unable to ReadTableFile(hSortList,<Name>).

Explanation

Programmer Response

DM17003

Error in SortFormsForRecip(): pszCurrRecip == NULL.

Explanation

Programmer Response

DM17004

Error in SortFormsForRecip(): Unable to SortCurrRcpForms(formsetH,hSortList,<Buff>).

Explanation

Programmer Response

DM17005

Error in ReadTableFile(): hFile == NULL.

Explanation

Programmer Response

DM17006

Error in SortCurrRcpForms(): hSortItem == NULL.

Explanation

Programmer Response

DM17007

Warning: Document <Name>, Description <Script>.

Explanation

Programmer Response

DM17008

Recipient <Name> has no matching recipient codes in sort table.

Explanation

Programmer Response

DM17009

Info in RunGenPrint(): Print option PRTOPT_FILTERRECIP is turned ON.

Explanation

An information message which informs you that filtering of recipient data is turned ' ON '.

Programmer Response

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17010

Info in RunGenPrint(): Print option PRTOPT_PRTALLRECIPS is turned ON.

Explanation

An information message which informs you that the PRTOPT_PRTALLRECIPS flag is turned ' ON '.

Programmer Response

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17011

Info in RunGenPrint(): Print option PRTOPT_SENDFONTS is turned ON.

Explanation

An information message which informs you that enabling of downloading of fonts is set to ' Yes ' for the printer type selected in the INI file.

Programmer Response

SendFonts enabling is controlled by the INI option, DownLoadFonts, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = PCL

< PrtType:PCL >

DownLoadFonts = Yes, Enabled

For more information on INI Options, refer to the online INI Reference.

nThis option is for debugging purposes and

should normally be set to NO.

DM17012

Info in RunGenPrint(): Print option PRTOPT_PERMFONTS is turned ON.

Explanation

Programmer Response

DM17013

Info in RunGenPrint(): INI option (<Print>CompileInStream) is obsolete.

Explanation

Programmer Response

DM17014

Info in RunGenPrint(): INI option (<Print>SendOverlay) is obsolete.

Explanation

Programmer Response

DM17015

Info in RunGenPrint(): INI option (<Print>SendColor) is obsolete.

Explanation

Programmer Response

DM17016

Info in RunGenPrint(): Print option PRTOPT_COMPILEINSTREAM is turned ON.

Explanation

An information message which informs you that CompileInStream is set to ' Yes '.

Programmer Response

CompileInStream enabling is controlled by the INI option, CompileInStream, in the INI group < Printer >.

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17017

Info in RunGenPrint(): Print option PRTOPT_COMPILEINSTREAM is turned OFF.

Explanation

An information message which informs you that CompileInStream is set to ' No '.

Programmer Response

CompileInStream disabling is controlled by the INI option, CompileInStream, in the INI group < Printer >.

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17018

Info in RunGenPrint(): Print option PRTOPT_SENDOVERLAY is turned ON.

Explanation

An information message which informs you that enabling of SendOverlays is set to ' Yes ' for the printer type selected in the INI file.

Programmer Response

SendOverlays enabling is controlled by the INI option, SendOverlays, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

SendOverlays = Yes, Enabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17019

Info in RunGenPrint(): Print option PRTOPT_SENDOVERLAY is turned OFF.

Explanation

An information message which informs you that enabling of SendOverlays is set to ' No ' for the printer type selected in the INI file.

Programmer Response

SendOverlays disabling is controlled by the INI option, SendOverlays, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

SendOverlays = No, Disabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17020

Info in RunGenPrint(): Print option PRTOPT_SENDCOLOR is turned ON.

Explanation

An information message which informs you that enabling of SendColor is set to ' Yes ' for the printer type selected in the INI file.

Programmer Response

SendColor enabling is controlled by the INI option, SendColor, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

SendColor = Yes, Enabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17021

Info in RunGenPrint(): Print option PRTOPT_SENDCOLOR is turned OFF.

Explanation

An information message which informs you that enabling of SendColor is set to ' No ' for the printer type selected in the INI file.

Programmer Response

SendColor disabling is controlled by the INI option, SendColor, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

SendColor = No, Disabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17022

Info in RunGenPrint(): Print option PRTOPT_PAGENUMBERS is turned ON.

Explanation

An information message which informs you that enabling of PageNumbers is set to ' Yes ' for the printer type selected in the INI file.

Programmer Response

PageNumbers enabling is controlled by the INI option, PageNumbersr, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

PageNumbers = Yes, Enabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17023

Info in RunGenPrint(): Print option PRTOPT_PAGENUMBERS is turned OFF.

Explanation

An information message which informs you that enabling of PageNumbers is set to ' No ' for the printer type selected in the INI file.

Programmer Response

PageNumbers disabling is controlled by the INI option, PageNumbersr, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

PageNumbers = No, Disabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM17024

Processing Batch:<Name> File:<File> Port:<Port>.

Explanation

The LogFile message informs the user that GENPrint or APLPrint processed the following transactions for the print batch (xxxxx) located in subdirectory file (yyyyy) and output the print data to the file, zzzzz. The parameters xxxxx, yyyyy, and zzzzz, respectively, are specified in Name, File, and Port portion of the message.

Programmer Response

A GENPrint and APLPrint informative message.

DM17025

Num records processed in Buff batch.

Explanation

This LogFile message informs the user how many records (nnnnn) were processed for the print batch, xxxxx, during GENPrint or ALPPrint execution. The number of records and print batch name are specified in the Num and Buff portion of the message.

Programmer Response

A GENPrint and ALPPrint informative message.

DM17026

Info in AddAdditionalField(): Added additional field.

Explanation

The function, InitPrintEnv, encountered an problem and returned an error to RunGenPrint.

Programmer Response

This message is one in a group of related messages. Follow the message chain up and down to locate a message that describes the error in more detail plus identifies the image and field that has the problem.

Example:

DM17104: Error in LoadFileInfo(): Unable to INIGetInitValue(MasterResource, DefLib).

DM17076: Error in InitPrintEnv(): Unable to LoadFileInfo(pRPS).

DM17029: Error in RunGenPrint(): Unable to InitPrintEnv().

DM17027

Error in RunGenPrint(): Unable to RPSetLogProc(pRPS, RPStandardLogProc).

Explanation

Programmer Response

DM17028

Error in RunGenPrint(): Unable to RPSetDisplayProc(pRPS, RPStandardDisplayProc).

Explanation

Programmer Response

DM17029

Error in RunGenPrint(): Unable to InitPrintEnv().

Explanation

The function, InitPrintEnv, encountered a problem and returned an error to RunGenPrint.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail..

Example:

DM17080: Error in InitPrintEnv(): Unable to INIGetInitValue('Control','ImageExt',,).

DM17029: Error in RunGenPrint(): Unable to InitPrintEnv().

DM17030

Error in RunGenPrint(): Unable to OpenDataFiles(pRPS).

Explanation

GenPrint could not open a data file.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example: 1

DM12041: Error : FAP library error: Transaction:<>, area:<..\C\genbannr.c,Jun 17 2004 21:29:41,400.110.002,GENDALErrorNotify> code1:<0>, code2:<0>

msg:<Script: c:\docucorp\DocuMakerRP\mstrres\InsCtr\Deflib\FaxEml_Name.dal

Line: 10 Col: 56 Err: 15 Token: ) Msg: No result value returned>.

DM17038: Error in OpenDataFiles(): Unable to fopen(<c:\docucorp\DocuMakerRP\Processing\Insctr\data\_20040618_nafile.dat>,'r').

DM17031

Error in RunGenPrint(): Unable to FAPCreateFormset().

Explanation

Programmer Response

DM17032

Error in RunGenPrint(): Unable to FAPLoadGlobalFonts(DocSet,<Path>,<File>,<Ext>).

Explanation

Programmer Response

DM17033

Error in RunGenPrint(): Unable to FAPFlushFormset(Docset,OBJ_ALL ~OBJ_FONTS).

Explanation

Programmer Response

DM17034

Error in RunGenPrint(): Unable to ProcessBatches(pRPS).

Explanation

The function, ProcessBatches, encountered a problem and returned an error to RunGENPrint.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName1>).

DM11171: Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,

<GroupName1>,,).

DM17051: Error in ProcessRcpRecs(): Unable to GENGetDocSetNames(pRPS) for batch

<Batch1>.

DM17048: Error in ProcessBatches(): Unable to ProcessRcpRecs(pRPS, & LocalRcp).

DM17034: Error in RunGenPrint(): Unable to ProcessBatches(pRPS).

DM17035

Error in OpenDataFiles(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17036

Warning in OpenDataFiles(): Unable to INIGetInitValue(<Data>,<DataPath>,,).

Explanation

The INI Group, < Data >, and the Option, DataPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17037

Error in OpenDataFiles(): Unable to INIGetInitValue(<Data>,<NaFile>,,).

Explanation

The INI Group, < Data >, and the Option, NAFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17038

Error in OpenDataFiles(): Unable to fopen(<File>,'r').

DM17038: Error in OpenDataFiles(): Unable to open(<c:\docucorp\DocuMakerRP\Processing\Insctr\data\_20040618_nafile.dat>,'r').

Explanation

The fopen function could not find or open the file specified in the File portion of the message and returned an error to OpenDataFiles.

Programmer Response

1. Verify that the file specified in the File portion of the message exists in the

INI Group < Data >option DataPath = subdirectory.

2. Verify the option DataPath exists in the INI Group < Data >.

3. This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

DM17039

Error in OpenDataFiles(): Unable to INIGetInitValue(<Data>,<PolFile>,,).

Explanation

The INI Group, < Data >, and the Option, POLFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17040

Error in OpenDataFiles(): Unable to fopen(<File>,'r').

Explanation

The fopen function could not open for read modethe file, Name, as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM17041

Error in OpenDataFiles(): Unable to INIGetInitValue(<Data>,<DbLogFile>,,).

Explanation

The INI Group, < Data >, and the Option, DbLogFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17042

Error in OpenDataFiles(): Unable to DBInitDB().

Explanation

Programmer Response

DM17043

Error in OpenDataFiles(): Unable to INIGetInitValue(<Data>,<TrnDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, TrnDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17044

Error in OpenDataFiles(): Unable to INIGetInitValue(<Data>,<RcbDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, RCBDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17045

Error in OpenDataFiles(): Unable to RCBinit(NULL,<Name>,InstallH).

Explanation

Programmer Response

DM17046

Error in RCBOpenPrintBatchFiles(): AliasPrintBatches specified, but ini option < Data > < BatchTable > not found.

Explanation

Programmer Response

DM17047

Error in ProcessBatches(): Unable to RCBInitBatch(NULL,<File>,MODE_WRITE+1).

Explanation

Programmer Response

DM17048

Error in ProcessBatches(): Unable to ProcessRcpRecs(pRPS, LocalRcp).

Explanation

The function, ProcessPcpRecs, encountered a problem and returned an error to ProcessBatches.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName1>).

DM11171: Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,

<GroupName1>,,).

DM17051: Error in ProcessRcpRecs(): Unable to GENGetDocSetNames(pRPS) for batch

<Batch1>.

DM17048: Error in ProcessBatches(): Unable to ProcessRcpRecs(pRPS, & LocalRcp).

DM17049

Error in ProcessRcpRecs(): Printer not found for batch <Buff>. Missing ini group: <Name>, Unable to VMMElemHandle(PrinterListH,Index,Found).

Explanation

Programmer Response

DM17050

Error in ProcessRcpRecs(): Unable to GENGetRecipientSet(pRPS,RecNo) with batch <Buff>.

Explanation

The function, GENGetRecipientSet, could not find the record number for the batch specified in the <Buff> portion of the message and returned an error to ProcessRcpRecs.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM17071: Error in GENGetRecipientSet(): Unable to locate INI group:RECIP_NAMES,

value:<001>. Unable to VMMLocateOrdElem(RecipTbl,<001>,& found).

DM17050: Error in ProcessRcpRecs(): Unable to GENGetRecipientSet(pRPS,&RecNo)

with batch <Batch1>.

DM17051

Error in ProcessRcpRecs(): Unable to GENGetDocSetNames(pRPS) for batch <Buff>.

Explanation

The function, GENGetDocSetNames, could not find the batch specified in the <Buff> portion of the message and returned an error to ProcessRcpRecs.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName1>).

DM11171: Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,

<GroupName1>,,).

DM17051: Error in ProcessRcpRecs(): Unable to GENGetDocSetNames(pRPS) for batch

<Batch1>.

DM17052

Error in ProcessRcpRecs(): Unable to GENShowDocSetNames(pRPS) for batch <Buff>.

Explanation

Programmer Response

DM17053

Error in ProcessRcpRecs(): Unable to ProcessData(pRPS,LocalPrtInfo) for batch <Buff>.

Explanation

The function, ProcessData, detected a problem and returned an error to ProcessRcpRecs.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM17059: Error in ProcessData(): Unable to DSMergeNAFormset

(DocSet,pRPS->fpNAFile,NAOffset,). Object Name:<q1fl2a>

DM17053: Error in ProcessRcpRecs(): Unable to ProcessData(pRPS,&LocalPrtInfo) for

batch <Batch1>.

DM17054

Error in ProcessRcpRecs(): Unable to CloseOutput(LocalPrtInfo) for batch <Buff>.

Explanation

Programmer Response

DM17055

Error in ProcessData(): Unable to GENGetGlbData('POL_Offset',,).

Explanation

Programmer Response

DM17056

Error in ProcessData(): Unable to GENGetGlbData('NA_Offset',,).

Explanation

Programmer Response

DM17057

Error in ProcessData(): Unable to DSGetDocumentSet(DocSet,0,NULL,NULL,NULL,TRUE,FALSE,NULL,pRPS->fpPOLFile,POLOfset,,).

Explanation

Programmer Response

DM17058

Error in ProcessData(): Unable to FAPFlushFormset(DocSet,OBJ_ALL ~OBJ_FONTS).

Explanation

Programmer Response

DM17059

Error in ProcessData(): Unable to DSMergeNAFormset(DocSet,pRPS->fpNAFile,NAOffset,). Object Name:<Buff>.

Explanation

The function, DSMergeNAFormset, detected a problem with the POLFile for the object name specified in the <Buff> portion of the message and returned an error to ProcessData.

Programmer Response

The POLFile has been corrupted, please re-execute the GENDATA step. If the problem can be re-created, save the Master Resource Library and submit to DAP support as a problem.

DM17060

Error in ProcessData(): Unable to FAPFlushFormset().

Explanation

Programmer Response

DM17061

Error in ProcessData(): Unable to PRTPrint(DocSet,,,,,).

Explanation

The function, PRTStdOutputFunc, failed trying to open a device and returned an error to ProcessData.

Programmer Response

Verify that no other application has the device/file open. If so, close the application and re-run GENPrint.

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<..\C\prtmain.c

Sep 24 2000 14:31:34

400.101.017

PRTStdOutputFunc>, code:<11>, code:<11>, msg<Failure to open device .

\Print\RegPrt

Error number = 13

Permission denied>.

DM17061: Error in ProcessData(): Unable to PRTPrint(DocSet,,,,,).

DM17062

Error in ProcessData(): Unable to FAPFlushFormset(DocSet,).

Explanation

Programmer Response

DM17063

Error in ProcessData(): Unable to FAPFlushFormset(DocSet,).

Explanation

Programmer Response

DM17064

Error in AddAdditionalField(): Could not create field.

Explanation

Programmer Response

DM17065

Warning in GENGetRecipientSet(): Buff batch is empty, Unable to RCBGetFirstRcpSetRec(NULL).

Explanation

This warning message informs you that GENPrint did not process any output for the recipient specified in the <Buff> portion of the message.

Programmer Response

DM17066

Error in GENGetRecipientSet(): Failed to get Num record from Buff batch.

Explanation

Programmer Response

DM17067

Error in GENGetRecipientSet(): Unable to GENGetGblData('RCBRcpCode',,).

Explanation

The function, GENGetGblData, could not locate the RCBRcpCode in the RCBDFDFL.DFD file and returned an error to GENGetRecipientSet.

Programmer Response

Verify that the RCBDFDFL.DFD definition is correctly defined. Check that the FieldName RCBRcpCode is present and defined correctly.

DM17068

Error in GENGetRecipientSet(): RecipCode == NULL.

Explanation

Programmer Response

DM17069

Error in GENGetRecipientSet(): RecipCode:<Code> is invalid for record:<Num> of batch:<Buff>.

Explanation

The function, GENGetRecipientSet, detected that the RecipCode is invalid for record X for batch Y. The record number and batch name, respectively, are specified in the <Num> and <Buffe> portion of the message .

Programmer Response

Verify that the RCBDFDFL.DFD file definition is correctly defined. Check that the FieldName(s) NA_Offset and POL_Offset are present and defined correctly.

DM17070

Error in GENGetRecipientSet(): RecipTblTbl == VMMNULLHANDLE.

Explanation

Programmer Response

DM17071

Error in GENGetRecipientSet(): Unable to locate INI group:RECIP_NAMES, value:<Code>. Unable to VMMLocateOrdElem(RecipTbl,<Buff>,found).

Explanation

The function, VMMLocateOrdElem, could not find the an INI option for the recipient batch yyyyy in the INI Group < RECIP_NAMES > and returned an error to LoadRecipInfo. The INI options, xxxxx, is specified in the <Code> portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17072

Error in GENGetRecipientSet(): Unable to PRTQueueRecipient(<File>,<Name>,<Buff>). recip code:<Code>.

Explanation

Programmer Response

DM17073

Error in GENGetRecipientSet(): Unable to RCBGetNextRcpSetRec(NULL).

Explanation

Programmer Response

DM17074

Unable to install callback function: <Name>.

Explanation

Programmer Response

DM17075

Callback function: <Name> is already active

Explanation

Programmer Response

DM17076

Error in InitPrintEnv(): Unable to LoadFileInfo(pRPS).

Explanation

The function, LoadFileInfo, could not find needed information and returned an error to InitPrintEnv.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM17104: Error in LoadFileInfo(): Unable to INIGetInitValue(MasterResource, DefLib).

DM17076: Error in InitPrintEnv(): Unable to LoadFileInfo(pRPS).

DM17077

Error in InitPrintEnv(): Unable to LoadPrinterInfo(pRPS).

Explanation

The function, LoadPrinterInfo, could not find needed information and returned an error to InitPrintEnv.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM17093: Error in LoadPrinterInfo(): Unable to INIFirstInitValue(<Printer1>,<Port>,,).

DM17077: Error in InitPrintEnv(): Unable to LoadPrinterInfo(pRPS).

DM17078

Error in InitPrintEnv(): Unable to LoadRecipInfo(pRPS).

Explanation

The function, LoadRecipInfo, could not find needed information and returned an error to InitPrintEnv.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM17098: Error in LoadRecipInfo(): Unable to INIFirstInitValue(<Batch1>,<Printer>).

DM17078: Error in InitPrintEnv(): Unable to LoadRecipInfo(pRPS).

DM17079

Error in InitPrintEnv(): Unable to INIGetInitValue('MasterResource','FormLib',,).

Explanation

The INI Group, < MasterResource >, and the Option, FormLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17080

Error in InitPrintEnv(): Unable to INIGetInitValue('Control','ImageExt',,).

Explanation

The INI Group, < Control >, and the Option, ImageExt, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17081

Error in InitPrintEnv(): Unable to INIGetInitValue('Control','LogoExt',,).

Explanation

The INI Group, <Control>, and the Option, LogoExt, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17082

Error in GenArcInit(): Unable to DBInitDB(ASCInstallHandler).

Explanation

Programmer Response

DM17083

Error in GenArcInit(): Unable to DBInitDB(DB2InstallHandler,'DB2').

Explanation

Programmer Response

DM17084

Error in InitPrintEnv(): Unable to PRTInitPrinterSpecs().

Explanation

Programmer Response

DM17085

Error in InitPrintEnv(): Unable to GVMCreateVariable('NA_Offset',GVM_LONG).

Explanation

Programmer Response

DM17086

Error in InitPrintEnv(): Unable to GVMCreateData(VMMNULLHANDLE,'NA_Offset',,,).

Explanation

Programmer Response

DM17087

Error in InitPrintEnv(): Unable to GVMCreateVariable('POL_Offset',GVM_LONG).

Explanation

Programmer Response

DM17088

Error in InitPrintEnv(): Unable to GVMCreateData(VMMNULLHANDLE,'NA_Offset',,,).

Explanation

Programmer Response

DM17089

Error in InitPrintEnv(): Unable to INIGetInitValue(<Data>,<DefLib>,,).

Explanation

The INI Group, < Data >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17090

Error in InitPrintEnv(): Unable to INIGetInitValue(<Data>,<RcbDfdFile>,,).

Explanation

he INI Group, < Data >, and the Option, RCBDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17091

Error in LoadPrinterInfo(): Unable to VMMCreateList().

Explanation

Programmer Response

DM17092

Error in LoadPrinterInfo(): Unable to INIFirstInitValue(<PrinterInfo>,<Printer>,,).

Explanation

The INI Group, < PrinterInfo >, and the Option, Printer, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17093

Error in LoadPrinterInfo(): Unable to INIGetInitValue(<ID>,<PORT>,,).

Explanation

The function, PrintEnv, in GENPRINT or AplLib could not find the INI Group, <xxxxx>, and the Option, Port in the INI file. The INI Group name, xxxxx, is specified in the <ID> portion of the message

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17094

Error in LoadPrinterInfo(): Unable to VMMInsOrdElem(PrinterListH, PrinterInfo,,).

Explanation

Programmer Response

DM17095

Error in LoadRecipInfo(): Unable to VMMCreateList().

Explanation

Programmer Response

DM17096

Error in LoadRecipInfo(): Unable to INIFirstInitValue(Print_Batches,NULL,,).

Explanation

The INI Group, <Print_Batches>, could not be found in the INI file.

Programmer Response

Add the indicated INI Group, < Print_Batches > and Option(s). For more information on INI Options, refer to the online INI Reference Guide.

DM17097

Error in LoadRecipInfo(): Unable to INIGetInitValue(<Print_Batches>,<Buff>,,).

Explanation

The INI Group, < Print_Batches >, and the Option, xxxxx, could not be found in the INI file. The option xxxxx is specified in the Name portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17098

Error in LoadRecipInfo(): Unable to INIFirstInitValue(<Name>,<Printer>,,).

Explanation

The function, PrintEnv, in GENPRINT or AplLib could not find the INI Group, <xxxxx>, and the Option, Printer in the INI file. The INI Group name, xxxxx, is specified in the <Name> portion of the message.

Programmer Response

Add the indicated INI Group specified in the <Name> portion of the message and its Option(s). For more information on INI Options, refer to the online INI Reference Guide.

DM17099

Error in LoadRecipInfo(): Unable to VMMFindOrdElem(PrinterListH, <ID>,,,,,). Printer: <Name>.

Explanation

The function, VMMFindOrdElem, could not find the INI option Printer = xxxxx for the recipient batch, yyyyy, in the INI Group, < PrinterInfo > in the INI file and returned an error to LoadRecipInfo. The INI options, xxxxx and yyyyy (respectivlely), are specified in the <ID> and <Name> portion of the message.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

Example:

< Print_Batches >

Batch1 = Batch1.dat

< Batch1 >

Printer = Printer1

< PrinterInfo >

Printer = (Printer1 is not present or spelled incorrectly)


DM17100 - DM17199 Messages

DM17100

Error in LoadRecipInfo(): RecipInfo.PrinterCnt is not less than MAX_PRINTERS. Check the # of printers assigned to Name.

Explanation

Programmer Response

DM17101

Error in LoadRecipInfo(): Unable to VMMAppendElem(). RecipInfo.Name:<Name>.

Explanation

Programmer Response

DM17102

Error in LoadRecipInfo(): Unable to LoadRecipList(pRPS).

Explanation

The function, LoadRecipList, detected a problem and returned an error to LoadRecipInfo.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM17108: Error in LoadRecipList(): Unable to INIFirstInitValue(<Recip_Names>,Null).

DM17102: Error in LoadRecipInfo(): Unable to LoadRecipList(pRPS).

DM17103

Error in LoadFileInfo(): Unable to INIGetInitValue('MasterResource','FormLib',,).

Explanation

The function, PrintEnv, in GENPRINT or AplLib could not find the INI Group, <MasterResource>, and the Option, FormLib, in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17104

Error in LoadFileInfo(): Unable to INIGetInitValue('MasterResource','DefLib',,).

Explanation

The function, PrintEnv, in GENPRINT or AplLib could not find the INI Group, <MasterResource>, and the Option, DefLib, in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17105

Error in LoadFileInfo(): Unable to INIGetInitValue('MasterResource','XrfFile',,).

Explanation

The function, PrintEnv, in GENPRINT or AplLib could not find the INI Group, <MasterResource>, and the Option, XrtFile, in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17106

Error in LoadFileInfo(): Unable to INIGetInitValue('Control','XrfExt',,).

Explanation

The INI Group, <Control>, and the Option, XrfExt, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17107

Error in LoadRecipList(): Unable to VMMCreateList().

Explanation

Programmer Response

DM17108

Error in LoadRecipList(): Unable to INIFirstInitValue(<RECIP_NAMES>,NULL,,).

Explanation

The INI Group and options, < Recip_Names >, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM17109

Error in LoadRecipList(): Unable to INIFirstInitValue(<RECIP_NAMES>,<Buff>,,).

Explanation

Programmer Response

DM17110

Error in LoadRecipList(): INI group:RECIP_NAMES, option:<Buff>, value:<Buffer> must be a 3 digit number.

Explanation

Programmer Response

DM17111

Error in LoadRecipList(): Unable to VMMInsOrdElem(Table,,,).

Explanation

Programmer Response

DM17112

Error in CreateDFDVariables(): Unable to DBQueryFormInfo(<File>).

Explanation

The function, DBQueryFormInfo, could not find/load the file specified in the <File> portion of the message and returned an error to CreateDFDVariables.

Programmer Response

Verify that the file exist in the specified path/subdirectory. If the file exist in the specified path/subdirectory, then verify that the file name matches the one in the subdirectory and in the error message.

Also verify that the subdirectory exist.

DM17113

Error in CreateDFDVariables(): Unable to MakeGvmVarsForDfd(NULL,DFDFileH).

Explanation

Programmer Response

DM17114

Skipping Batch:<Buff> per inclusion in the ExcludeBatch INI group.

Explanation

Programmer Response

DM17115

Warning : DownLoadFAP is set to Yes, this option should be set to No for optimal performance. Check the < RunMode > control group, <DownLoadFap option.

Explanation

The INI option DownLoadFAP is set to Yes in the INI control group < RunMode >.

Programmer Response

In order to have optimal performance in Batch processing, the INI option DownLoadFAP should be set to No in the INI control group < RunMode >.

For more information on INI Options, refer to the online INI Reference Guide.


DM18000 - DM18099 Messages

DM18001

Error in RunGenArc(): Unable to RPSetLogProc(pRPS, RPStandardLogProc).

Explanation

Programmer Response

DM18002

Error in RunGenArc(): Unable to RPSetDisplayProc(pRPS, RPStandardDisplayProc).

Explanation

Programmer Response

DM18003

Error in RunGenArc(): Unable to VMMCreateList().

Explanation

Programmer Response

DM18004

Error in RunGenArc(): Unable to GenArcInit(pRPS).

Explanation

The function, GenArcInit, returned an error to RunGenArc.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM18011: Error in GenArcInit(): Unable to INIGetInitValue(<ArcRet>,<CarPath>,,).

DM18004: Error in RunGenArc(): Unable to GenArcInit(pRPS).

Verify that the INI group < ArcRet > exist in the INI file.

DM18005

Error in RunGenArc(): Unable to GenArcOpenFiles(pRPS).

Explanation

The function, GenArcOpenFiles, returned an error to RunGenArc.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM18017: Error in GenArcOpenInput(): Unable to INIGetInitValue(<MasterResource>,

<DefLib>,,).

DM18005: Error in RunGenArc(): Unable to GenArcOpenFiles(pRPS).

DM18006

Error in RunGenArc(): Unable to CUSRegisterCustomRules(pRPS).

Explanation

Programmer Response

DM18007

Error in RunGenArc(): Unable to GenArcArchive(pRPS).

Explanation

The function, GenArcArchive, returned an error to RunGenArc.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Review the INI Control Group ArcRet and Option CarPath for accuracy.

Review the INI control group <ArcRet> and option <CARFile> for accuracy.

Example:

DM18032: Error in GenArcOpenFiles(): Unable to GenArcGetIndexName().

DM18007: Error in RunGenArc(): Unable to GenArcArchive(pRPS).

DM18008

Error in GenArcInit(): Unable to DBInitDB(ASCInstallHandler).

Explanation

Programmer Response

DM18009

Error in GenArcInit(): Unable to DBInitDB(DB2InstallHandler,"DB2").

Explanation

Programmer Response

DM18010

Error in GenArcInit(): Unable to DBInitDB(ORAInstallHandler,"ORA").

Explanation

Programmer Response

DM18011

Error in GenArcInit(): Unable to INIGetInitValue(<ArcRet>,<CarPath>,,).

Explanation

The function, GenArcInit, could not find the INI group/option, < ArcRet > CarPath .

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

Review the INI Control Group <ArcRet> and option <CarPath> for accuracy.

DM18012

Error in GenArcInit(): Unable to INIGetInitValue(<ArcRet>,<Catalog>,,).

Explanation

The function, GenArcInit, could not find the INI group/option, < ArcRet > Catalog .

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM18013

Error in GenArcInit(): Unable to INIGetCurrContext.

Explanation

Programmer Response

DM18014

Error in GenArcInit(): Unable to INILoadFile( <INI> ).

Explanation

The function, GenArcInit, could not load the INI file specified in the < INI > portion of the message.

Programmer Response

QA TIPS:

Scenario 1:

The <Trigger2Archive> group and option cannot be located in fsisys.ini.

Faparc.ini has been phased out. But for backward compatibility, Genarc tried to look faparc.ini for this group and option.

Solution: define

< Trigger2Archive >

Rundate = Rundate

and

other user-defined fields

in the fsisys.ini

Scenario 2: You are missing some of the required INI options in the < ArcRet > group. Options to check for are: AppIDXDFD, AppIDX, Catalog, and TempIDX. For more information on INI Options, refer to the online INI Reference Guide.

DM18015

Error in GenArcInit(): Unable to INIMerge( <CurrINIH>, <ArcINIH> ).

Explanation

Programmer Response

DM18016

Error in GenArcInit(): Unable to INIGetInitValue(<Trigger2Archive>,<RunDate>,,). Tip: <RunDate> is a required field for retrieval.

Explanation

The function, INIGetLinitValue, could not find the specified INI group/option in the INI file and returned an error to GenArchInit.

Programmer Response

Add the indicated INI group and option to the INI file. For more information on INI Options, refer to the online INI Reference Guide.

DM18017

Error in GenArcOpenInput(): Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResoure >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

Verify that your path is pointing to the correct INI file.

DM18018

Error in GenArcOpenInput(): Unable to INIGetInitValue(<Data>,<NaFile>,,).

Explanation

The INI Group, < Data >, and the Option, NaFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM18019

Error in GenArcOpenFiles(): Unable to fopen(<File>,'r').

Explanation

The fopen function could not find or open the NAFile and returned an error to GenArcOpenFiles.

Programmer Response

Verify the path for the NAFile file plus check the spelling of the file name in the INI < Date > group and subdirectory.

DM18020

Error in GenArcOpenFiles(): Unable to INIGetInitValue(<Data>,<PolFile>,,).

Explanation

The INI Group, < Data >, and the Option, POLFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM18021

Error in GenArcOpenFiles(): Unable to fopen(<File>,'r').

Explanation

The fopen function could not find or open the POLFile and returned an error to GenArcOpenFiles.

Programmer Response

Verify the path for the POLFile file plus check the spelling of the file name in the INI < Date > group and subdirectory.

DM18022

Error in GenArcOpenFiles(): Unable to INIGetInitValue(<Data>,<TrnDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, TrnDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM18023

Error in GenArcOpenFiles(): Unable to DBQueryFormatInfo(<Name>).

Explanation

The function, DBQueryFormatInfo, returned an error to GenArcOpenFiles.

Programmer Response

Verify the path for the TrnDFDFl file plus check the spelling of the file name in the INI < Date > group.

DM18024

Error in GenArcOpenFiles(): Unable to INIGetInitValue(<Data>,<NewTrn>,,).

Explanation

The INI Group, < Data >, and the Option, NewTrn, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM18025

Error in GenArcOpenFiles(): Unable to DBPrepareFile(<ASCII>,<Name>,<File>).

Explanation

Programmer Response

DM18026

Error in GenArcOpenFiles(): Unable to MakeGvmVarsForDfd(pRPS,pNewTrn->hNewTrnDfd).

Explanation

Programmer Response

DM18027

Error in GenArcOpenFiles(): Unable to DBAllocateStructMemory().

Explanation

Programmer Response

DM18028

Error in GenArcOpenFiles(): Unable to DBOpen(hNewTrn, DB_READ).

Explanation

The function DBOpen could not find or open the NewTrn file and returned an error to GenArcOpenFiles.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<Cannot open file. No such file or

directory>, code:<2>, code:<2>, msg<.\data ewTrn.da>.

DM18028: Error in GenArcOpenFiles(): Unable to DBOpen(hNewTrn, DB_READ).

Verify the path for the NewTrn file plus check the spelling of the file name in the

INI < Date > group.

DM18029

Error in GenArcOpenFiles(): DBQueryFormatInfo failed on <Dfd>.

Explanation

The function, DBQueryFormatiInfo, failed trying to format information that is contained in the AppIDX.DFD and return an error to GenArcOpenFiles.

Programmer Response

Verify that the AppIDX.DFD file exist. If the file exist, then verify that the file name matches the one in the subdirectory and in the INI group < ArcRet >.

Verify that the INI option, AppIDXDFD exist in the INI group < ArcRet >. For more information on INI Options, refer to the online INI Reference Guide.

DM18030

Error in GenArcArchive(): Unable to GENParseRecord(<Buffer>,hNewTrnDfd).

Explanation

Programmer Response

DM18031

Error in GenArcArchive(): Unable to GENGetDocSetNames(pRPS).

Explanation

The function, GENGetDocSetNames, returned an error to GenArcArchive.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11185: Error in GENGetDocSetName(): Unable to GENGetGlbDataPtr(<Company>,).

Tip: Does < DocSetNames > ini value:<Company> exist in the trn or rcb dfd file?

DM11171: Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,

<GroupName1>,,).

DM18031: Error in GenArcArchive(): Unable to GENGetDocSetNames(pRPS).

DM18032

Error in GenArcOpenFiles(): Unable to GenArcGetIndexName().

Explanation

The function, GenArcGetIndexName, could not find or obtain the index name and returned an error message to GenArcOpenFiles.

Programmer Response

Verify that the INI option AppIDX exist in the INI group < ArcRet >.

DM18033

Error in GenArcOpenFiles(): Unable to GenArcGetCarFileName().

Explanation

Programmer Response

DM18034

Error in GenArcArchive(): Unable to ArcInitArchive(<Name>,<>).

Explanation

The function, ArcInitArchive was unable to initiate archive for carfile speicifed in the <Name> portion of the message and returned an error to GenArchive.

Programmer Response

Verify that the subdirectory specified in the INI option CarPath of the INI group < ArcRet > exists. Also verify that the name specified matches.

Tip: Another item to check: Make sure that any field name used in appidx.dfd does not exceed the Codebase/xBase limit of 10 characters.

DM18035

Error in GenArcArchive(): Unable to GENShowDocSetNames(pRPS).

Explanation

Programmer Response

DM18036

Error in GenArcArchive(): Unable to GenArcConvertRecord(pRPS).

Explanation

The function, GenArcConverRecord, encountered a problem and returned an error to GenArcArchive.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM18045: Error in GenArcConvertRecord(): Error in the INI control group:

<Trigger2Archive> option: <RunDate>. Value:<RunDat> is not a field in the trn DFD file.

DM18036: Error in GenArcArchive(): Unable to GenArcConvertRecord(pRPS).

DM18037

Error in GenArcArchive(): Unable to GenArcCompressFiles(pRPS).

Explanation

Programmer Response

DM18038

Error in GenArcArchive(): Unable to DBAdd(hTempIdxFile,NewTrnFileRecord,ArcIdxRecordSize).

Explanation

The function, DBAdd was not able to add information to the TempIDX file and returned an error to GenArcArchive.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM18055: Error in GenArcOpenFiles(): Unable to INIGetInitValue(<ArcRet>,<TempIdx>,,).

DM18038: Error in GenArcArchive(): Unable to DBAdd(hTempIdxFile,NewTrnFileRecord,

ArcIdxRecordSize).

DM18039

Error in GenArcArchive(): Unable to GenArcEndCompress.

Explanation

Programmer Response

DM18040

Error in GenArcGetIndexName(): User Index name function failed

Explanation

Programmer Response

DM18041

Error in GenArcGetCarFileName(): User Carfile name function failed.

Explanation

Programmer Response

DM18042

Error in GenArcArchive(): Unable to DBAdd(hArcIdxFile,ArcIdxRecord,ArcIdxRecordSize).

Explanation

The error message indicates the archive index file may be corrupt.

The Xbase archive consists of the appidx.mdx (index) and appidx.dbf (compressed data) files generally stored in the master resource library (MRL) \arc directory.

Proposed Action: Backup the archive files and reindex the Appidx file.

The docutoolbox / command line utilies book (dtb_book.pdf) located on the DOSS Support site has details to help backup files and reindex files.

Programmer Response

DM18043

Error in GenArcConvertRecord(): Unable to INIFirstInitValue(<Trigger2Archive>,NULL,,).

Explanation

Ensure the Rundate field is defined as CHAR_ARRAY in the Trndfdfl.dfd file.

Rundate INT_TYPE= NOT_PRESENT should be CHAR_ARRAY

INT_LENGTH = 0 should be INT_LENGTH = 8

Programmer Response

DM18044

Error in GenArcConvertRecord(): Error in ini group:<Trigger2Archive>. Option:<PolicyNumber> is not a field in the archive index dfd file.

Explanation

QA Tip: The maximum supported field name length is 10 characters for Codebase (xbase) archives.

The field name PolicyNum , can contain 10 characters. If you have more than 10 characters please shorten it to 10.

.

Programmer Response

DM18045

Error in GenArcConvertRecord(): Error in ini group:<Trigger2Archive> option:<Buff>. Value:<Value> is not a field in the trn dfd file.

Explanation

In the INI group < Trigger2Archive > the option/value (specified respectively in the <Option>and <Value> portion of the message) is not a field in the TrnDFD file.

Programmer Response

Verify that the value name in the INI group/option and the TrnDFD file are spelled the same.

Add the value name and definition to the TrnDFD file if it is missing.

Example:

< FIELDS >

FIELDNAME = value name

< FIELD:value name >

value name definition

...

For more information on DFD File Format, refer to the online DocuMaker RP System

Reference Manual.

DM18046

Error in GenArcCompressFiles(): Unable to fseek(pRPS->fpNAFile, <Num>, SEEK_SET).

Explanation

Programmer Response

DM18047

Error in GenArcCompressFiles(): Unable to fseek(pRPS->fpPOLFile, <Num>, SEEK_SET).

Explanation

Programmer Response

DM18048

Error in GenArcCompressFiles(): Unable to ARCStartArchive(ArcIdxRecord,sz,).

Explanation

Programmer Response

DM18049

Error in GenArcCompressFiles(): Unable to ARCArchive(pRPS->fpNAFile,<Num>,POL_ENDDOCSET).

Explanation

Programmer Response

DM18050

Error in GenArcCompressFiles(): Unable to ARCEndArchiveDoc().

Explanation

Programmer Response

DM18051

Error in GenArcCompressFiles(): Unable to ARCStartArchive(NULL,0,).

Explanation

Programmer Response

DM18052

Error in GenArcCompressFiles(): Unable to ARCArchive(pRPS->fpPOLFile,<Num>,POL_ENDDOCSET).

Explanation

Programmer Response

DM18053

Error in GenArcCompressFiles(): Unable to ARCEndArchive().

Explanation

Programmer Response

DM18054

Error in GenArcOpenFiles(): Unable to DBCreate(hArcIdxFile).

Explanation

Programmer Response

DM18055

Error in GenArcOpenFiles(): Unable to INIGetInitValue(<ArcRet>,<TempIdx>,,).

Explanation

The INI Option, TempIDX, could not be found in the INI Group < ArcRet >.

Programmer Response

Add the indicated INI TempIDX option to the INI group < ArcRet >. For more information on INI Options, refer to the online INI Reference Guide.

DM18056

Error in GenArcOpenFiles(): Unable to DBCreate(hTempIdxFile).

Explanation

Programmer Response

DM18057

Warning in GENArcArchive(): NewTrn file is empty - no transactions to archive.

Explanation

NewTrn file is empty - no transactions to archive.

Programmer Response

Re-run the GENData step and check for any error messages. If error messages exist, correct them.

DM18058

Error in GenArcInit(): Unable to DBInitDB(Handler,Name).

Explanation

Programmer Response

DM18059

Error in GenArcInitRestart(): Restart table is not specified. Check INI option <ArcRet> RestartTable = .

Explanation

When archiving to a database which can roll back some transactions in case of error, restart table is required to store the information which will be needed for the next Genarc run.

Programmer Response

Make sure that < ArcRect > RestartTable = tablename is defined in fsiuser.ini.

For example:

< ArcRet >

RestartTable = restart

DM18060

Error in GenArcOpenInput(): Unable to GenArcInitRestart().

Explanation

The function, DBInitializeFile, could not initialize GenArc Restart and returned an error to GenArcOpenInput.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<ODBC Error>, code:<-1013>,

code:<4294966283>, msg<08001 -1013 [IBM][CLI Driver] SQL1013N

The database alias name or database name "RPARC" could not be found. SQLSTATE=42705>.

DM18062: Error in GenArcInitRestart(): Unable to DBInitializeFile(CB5,RP2RSTAR,...).

DM18060: Error in GenArcOpenInput(): Unable to GenArcInitRestart().

DM18061

Error in GenArcInitRestart(): Unable to DBSetFormatInfo().

Explanation

Programmer Response

DM18062

Error in GenArcInitRestart(): Unable to DBInitializeFile(DBName,File,...).

Explanation

The function, DBInitializeFile, could not initialize the data base file or table specified in the File portion of the message and returned an error to GenArcInitRestart.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<ODBC Error>, code:<-1013>,

code:<4294966283>, msg<08001 -1013 [IBM][CLI Driver] SQL1013N

The database alias name or database name "RPARC" could not be found. SQLSTATE=42705>.

DM18062: Error in GenArcInitRestart(): Unable to DBInitializeFile(CB5,RP2RSTAR,...).

DM18063

Error in GenArcInitRestart(): Unable to DBOpen(File,...).

Explanation

Programmer Response

DM18064

Error in GenArcArchive(): Unable to DBUpdate(...) restart table.

Explanation

Programmer Response

DM18065

Error in GenArcInitRestart(): Unable to DBAdd(...) a record to restart table. Job ID is JOBID

Explanation

Programmer Response

DM18066

Error in GenArcCloseInput(): Unable to DBUpdate(...) restart table with success status code. Job ID is JOBID

Explanation

Genarc cannot update the field JOBID in restart table.

Programmer Response

Make sure that <DBTable:Restart> control group in fsiuser.ini.

For example:

<DBTable:Restart>

DBHandler = DB2

or

<DBTable:Restart>

DBHandler = ODBC

Dependent on which driver that you use.

DM18067

Error in GenArcInitRestart(): Unable to DBLocate(...) record in restart table. Job ID is JOBID

Explanation

Programmer Response

DM18068

Error in GenArcSetRestart(): Cannot locate the record specified as a restart point, the input data files are not the same.

Explanation

Programmer Response

DM18069

Error in GenArcArchive(): Unable to GenArcSetRestart().

Explanation

Programmer Response

DM18070

Error in GenArcUnloadIndex(): Unable to DBAdd(...) a record to export index file.

Explanation

Programmer Response

DM18071

Warning in GenArcArchive(): INI option <ArcRet> Catalog = is not specified. CATALOG usage is disabled. CATALOG is required for concurrent archive runs.

Explanation

Programmer Response

You can get rid of this warning by defining < ArcRet > catalog = catalog.


DM19000 - DM19099 Messages

DM19001

Error in RunGenWip(): Unable to RPSetLogProc(pRPS, RPStandardLogProc).

Explanation

Programmer Response

DM19002

Error in RunGenWip(): Unable to RPSetDisplayProc(pRPS, RPStandardDisplayProc).

Explanation

Programmer Response

DM19003

Error in RunGenWip(): Unable to DBInit().

Explanation

Programmer Response

DM19004

Error in RunGenWip(): Unable to DBInitDB(CBDBSysInit).

Explanation

Programmer Response

DM19005

Error in RunGenWip(): Unable to AWInit(pRPS).

Explanation

The function, AWInit, detected a problem and returned an error to AWInit.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail..

Example:

DM19013: Error in AWInit(): Unable to fopen(<.\Data aFile.dat>,'r').

DM19005: Error in RunGenWip(): Unable to AWInit(pRPS).

DM19006

Error in RunGenWip(): Unable to AWStartConvert(pRPS).

Explanation

The function, AWStartConvert, detected a problem and returned an error to RunGenWip.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM19023: Error in AWStartConvert(): Unable to INIGetInitValue(<MasterResource>,

<FormLib>).

DM19006: Error in RunGenWip(): Unable to AWStartConvert(pRPS).

DM19007

Error in RunGenWip(): Unable to AWTrnTerm(pRPS).

Explanation

Programmer Response

DM19008

Error in AWInit(): Unable to INIGetInitValue(<Data>,<DataPath>,,).

Explanation

The INI Group, < Data >, and the Option, DataPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19009

Error in AWInit(): Unable to INIGetInitValue(<WipData>,<Path>,,).

Explanation

The INI Group, < WIPData >, and the Option, Path, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19010

Error in AWInit(): Unable to INIGetInitValue(<WipData>,<File>,,).

Explanation

The INI Group, < WIPData >, and the Option, File, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19011

Error in AWInit(): Unable to WIPInit(<Name>).

Explanation

The function, WIPInit, detected a problem and returned an error to AWInit.

Programmer Response

If this problem occurs, verify that the INI option DefLib exists in the INI group MasterResource.

DM19012

Error in AWInit(): Unable to INIGetInitValue(<Data>,<NaFile>,,).

Explanation

The INI Group, < Data >, and the Option, NAFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19013

Error in AWInit(): Unable to fopen(<File>,'r').

Explanation

The fopen function could not find or open the NAFile for read mode and returned an error to AWInit.

Programmer Response

Verify that the file exists in the specified subdirectory. If the file exists in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

Review DataPath for accuracy.

If the file does not exists, re-execute the GENDATA step.

DM19014

Error in AWInit(): Unable to INIGetInitValue(<Data>,<PolFile>,,).

Explanation

The INI Group, < Data >, and the Option, POLFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19015

Error in AWInit(): Unable to fopen(<File>,'r').

Explanation

The fopen function could not find or open the POLFile for read mode and returned an error to AWInit.

Programmer Response

Verify that the file exists in the specified subdirectory. If the file exists in the specified subdirectory, then verify that the file name matches the one in the subdirectory and in the INI group < Data >.

If the file does not exists, re-execute the GENDATA step.

DM19016

Error in AWInit(): Unable to AWGetFunc(pRPS, <TrnLib>,<InitFunc>).

Explanation

The function, AWGetFunc, could not find the INI option InitFunc in the INI group < TrnLib > and returned an error to AWInit.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19017

Error in AWInit(): Unable to AWGetFunc(pRPS, <TrnLib>,<TermFunc>).

Explanation

The function, AWGetFunc, could not find the INI option TermFunc in the INI group < TrnLib > and returned an error to AWInit.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19018

Error in AWInit(): Unable to AWGetFunc(pRPS, <TrnLib>,<GetFirst>).

Explanation

The function, AWGetFunc, could not find the INI option GetFirst in the INI group < TrnLib > and returned an error to AWInit.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19019

Error in AWInit(): Unable to AWGetFunc(pRPS, <TrnLib>,<GetNext>).

Explanation

The function, AWGetFunc, could not find the INI option GetNext in the INI group < TrnLib > and returned an error to AWInit.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19020

Error in AWInit(): Unable to INIGetInitValue(<Data>,<WipBatch>,,).

Explanation

The INI Group, < Data >, and the Option, WIPBatch, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19021

Error in AWInit(): Unable to AWTrnInit(pRPS, <Name>).

Explanation

The function, AWTrnInit, detected a problem trying to initialize the file specified in the <Name> portion of the message and returned an error to AWInit.

Programmer Response

Verify that the INI option, RCBDFDFile exists the INI group < Data >.

DM19022

Warning in AWInit(): Unable to INIGetInitValue(<Afg2Wip>,<UserID>,,). Using 'FORMAKER' user id.

Explanation

The INI Group, < AFGWIP>, and the Option, UserID , could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19023

Error in AWStartConvert(): Unable to INIGetInitValue(<MasterResource>,<FormLib>,,).

Explanation

The INI Group, < MasterResource>, and the Option, FormLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19024

Error in AWStartConvert(): Unable to INIGetInitValue(<Control>,<ImageExt>,,).

Explanation

The INI Group, < Control >, and the Option, ImageExt , could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19025

Error in AWStartConvert(): Unable to INIGetInitValue(<Control>,<LogoExt>,,).

Explanation

The INI Group, < Control >, and the Option, LogoExt, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19026

Error in AWStartConvert(): Unable to WIPAllocateRecord().

Explanation

Programmer Response

DM19027

Error in AWStartConvert(): Unable to AWTrnGetFirst(pRPS,Wip).

Explanation

The function, AWTrnGetFirst, detected a problem and returned an error to AWStartConvert.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11184: Error in GENGetDocSetName(): Unable to INIGetInitValue(<DocSetNames>,

<GroupName1>).

DM11171: Error in GENGetDocSetNames(): Unable to GENGetDocSetName(<DocSetNames>,

<GroupName1>).

DM14014: Error in A2WSetupCurrentRecord(): Unable to GENGetDocSetNames(pRPS).

DM14007: Error in A2WGetFirst(): Unable to A2WSetupCurrentRecord().

DM19027: Error in AWStartConvert(): Unable to AWTrnGetFirst(pRPS,Wip).

DM19028

Error in AWStartConvert(): Unable to GenWipGetNext(pRPS,Wip).

Explanation

Programmer Response

DM19029

Error in AWStartConvert(): Unable to FAPCreateFormset(FAPBase(),VMMNULLHANDLE,NULL).

Explanation

Programmer Response

DM19030

Error in AWStartConvert(): Unable to DSGetDocumentSet(FormsetH,OBJ_ALL,NULL,NULL,NULL,TRUE,TRUE,NULL,pRPS->fpPOLFile,<Buff>,'\\ENDFORM\\','\\ENDDOCSET\\'). Processing will continue…

Explanation

Programmer Response

DM19031

Error in AWStartConvert(): Unable to DSMergeNAFormset(FormsetH,pRPS->fpNAFile,<Buff>,OBJ_ALL(~OBJ_HEADER). Processing will continue…

Explanation

Programmer Response

DM19032

Error in AWStartConvert(): Unable to WIPGetUniqueFileName(<File>,<ID>).

Explanation

Programmer Response

DM19033

Error in AWStartConvert(): Unable to fopen(<File>,'w'). Processing will continue…

Explanation

The fopen function could not open for write mode the file, Name, as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM19034

Error in AWStartConvert(): Unable to DSUnloadNAFormset(FormsetH,fp,<ID>). Processing will continue…

Explanation

Programmer Response

DM19035

Error in AWStartConvert(): Unable to fopen(<File>,'w'). Processing will continue…

Explanation

The fopen function could not open for write mode the file, Name, as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM19036

Error in AWStartConvert(): Unable to DSBuildPOLDocSet(FormsetH,NULL,NULL,NULL,fp,<ID>,TRUE,0L). Processing will continue…

Explanation

Programmer Response

DM19037

Error in AWStartConvert(): Unable to WIPAppend(<Name>, Wip). Processing will continue…

Explanation

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM12041: Error : FAP library error: Transaction:<>, area:<CREATETIME>

code1:<-210>, code2:<4294967086>

msg:<Unrecognized Field Name>.

DM19037: Error in AWStartConvert(): Unable to WIPAppend(<.\wip\wip>, Wip). Processing will continue...

Programmer Response

If you add a new field to wip.dfd, you must remove the old wip.dbf and wip.mdx before you can run Genwip with the new wip.dfd.

DM19038

Error in GenWipGetNext(): Unable to AWTrnGetNext(pRPS,Wip).

Explanation

Programmer Response

DM19039

Error in AWGetFunc(): Unable to INIGetInitValue(<Group>,<Value>,,).

Explanation

The INI Group, < Group >, and the Option, Value, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM19040

Error in AWGetFunc(): Unable to strstr(<File>,'->'). See ini file group:<Group> option:<Value>.

Explanation

Programmer Response

DM19041

Error in AWGetFunc(): Unable to UTLLoadLibrary(<Buff>). See ini file group:<Group> option:<Value>.

Explanation

Programmer Response

DM19042

Error in AWGetFunc(): Unable to UTLQueryProcAddr(,<Ptr>). See ini file group:<Group> option:<Buff>.

Explanation

Programmer Response

DM19043

Warning in GENWIP: Manual entry file <File> is missing or empty.

Explanation

This warning message informs you that the Manual Entry file specified in the <File> portion of the message is missing or empty.

Programmer Response

Means that no transactions were Kicked to WIP during the execution of GENDATA step.

OK, if you were not expecting any transactions to be Kicked to WIP.

If you were expecting transactions to be Kicked to WIP, then you need to investigate.


DM20000 - DM20099 Message

DM20000 - DM20099 Messages

DM20001

Error in TextMerge(): Unable to FAPLoadImage(,,,).

Explanation

Programmer Response

DM20002

Error in TextMerge(): Unable to FAPLocateField(,<Name>).

Explanation

Programmer Response

DM20003

Error in MoveDate(): Unable to FAPLocateField(,<Name>).

Explanation

Programmer Response

DM20004

Error in MoveCityStateZip4(): Unable to sscanf(pRPS->Field.RuleParms:<Parms>).

Explanation

Programmer Response

DM20005

Error in MoveCityStateZip4(): Unable to GENGetRecord(pRPS,pRPS->ExtractListH,<Buff>,1).

Explanation

Programmer Response

DM20006

Error in MoveCityStateZip4(): Illegal Table Entry:<Parms>. Unable to GENGetFieldDataExt(pRPS,<Buff>,<Buffer>,,).

Explanation

Programmer Response

DM20007

Error in MoveBarcode(): Unable FAPUpdateBarcodeData(hBarcode,<Buff>).

Explanation

Programmer Response

DM20008

Error in MoveBarcode(): Unable to DSUnloadNABarcode(,,,).

Explanation

Programmer Response

DM20009

Error in DefAppendBuffer(): Unable to WriteNALine(pRPS,<Buff>,0,'Z').

Explanation

Programmer Response

DM20010

Error in SetMacroValue(): Data field <Buff> requires 2 items (MacroName,Value).

Explanation

Programmer Response

DM20011

Error in SetMacroValue(): Invalid MacroName:<Name>. RuleParms 1st parm.

Explanation

Programmer Response

DM20012

Error in IncMacroValue(): Data field <Buff> requires 3 items (MacroName,Value,PreOrPost).

Explanation

Programmer Response

DM20013

Error in SetMacroValue(): Invalid MacroName:<Name>. RuleParms 1st parm.

Explanation

Programmer Response

DM20014

Error in AddImgAfterCurImg(): Data field <Parms> requires 5 items (Company,Lob,FormName,ImageName,SearchMask).

Explanation

Programmer Response

DM20015

Error in AddImgAfterCurImg(): Unable to FAPCreateFormset(,,<TempFapFormset>).

Explanation

Programmer Response

DM20016

Error in AddImgAfterCurImg(): Unable to FAPFlushFormset().

Explanation

Programmer Response

DM20017

Error in AddImgAfterCurImg(): Unable to GENAddFormToSet(pRPS,TempFapFormsetH,<Name>,<Buff>,<LOB>,NULL,hForm).

Explanation

Programmer Response

DM20018

Error in AddImgAfterCurImg(): Unable to FAPDuplicateImage() Image:<Name>.

Explanation

Programmer Response

DM20019

Error in AddImgAfterCurImg(): Unable to DSSetImageRecipsCopyuCnt(hDuplicateImg,NULL,1) Image:<Name>.

Explanation

Programmer Response

DM20020

Error in AddImgIfNextIsSame(): Unable to parse rule parameters Parms.

Explanation

Programmer Response

DM20021

Error in AddImgIfNextIsSame(): Unable to AddImgAfterCurrent(pRPS,<Buff>,<LOB>,<Form>,<Name>).

Explanation

Programmer Response

DM20022

Error in AddImgIfNextIsDiff(): Unable to parse rule parameters Parms.

Explanation

Programmer Response

DM20023

Error in AddImgIfNextIsDiff(): Unable to add image Name.

Explanation

Programmer Response

DM20024

Error in AddImgAfterCurrent(): Unable to FAPCreateFormset(,,<TempFapFormset>).

Explanation

Programmer Response

DM20025

Error in AddImgAfterCurrent(): Unable to FAPFlushFormset().

Explanation

Programmer Response

DM20026

Error in AddImgAfterCurrent(): Unable to GENAddFormToSet(pRPS,TempFapFormset,<Name>,<Buff>,<LOB>,NULL,hForm).

Explanation

Programmer Response

DM20027

Error in AddImgAfterCurrent(): Unable to FAPDuplicateImage() Image:<Name>.

Explanation

Programmer Response

DM20028

Error in AddImgAfterCurrent(): Unable to DSSetImageRecipsCopyuCnt(hDuplicateImg,NULL,1) Image:<Name>.

Explanation

Programmer Response

DM20029

Error in SetChartAxisLabels(): Unable to CheckImageLoaded(pRPS->CurrentFapImageH, RP_PRE_PROC_B).

Explanation

Programmer Response

DM20030

Error in SetChartAxisLabels(): Unable to FAPFindChartByName(pRPS->CurrentFapImageH, Name).

Explanation

Programmer Response

DM20031

Warning in Image rule SetChartAxisLabels(): The number of fields to be used as labels exceeds series data, label Tok will be ignored.

Explanation

Programmer Response

DM20032

Error in SetChartAxisLabels(): Unable to FAPLocateImageField(<Image>,<Name>).

Explanation

Programmer Response

DM20033

Warning in Image rule SetChartAxisLabels(): The number of fields to be used as labels is fewer than series data, a null label will be created.

Explanation

Programmer Response

DM20034

Error in SetChartAxisLabels(): Unable to VMMAppendElem().

Explanation

Programmer Response

DM20035

Error in CUS_DATE_FormatToIntermediate(): Invalid input data/format <Input/Buff>.

Explanation

Programmer Response

DM20036

Error in CUS_DATE_FormatToIntermediate(): Invalid month <Month> in input data/format <Invalid/Buff>.

Explanation

Programmer Response

DM20037

Error in CUS_DATE_FormatToIntermediate(): Invalid year <Date> in input data/format <Invalid/Buff>.

Explanation

Programmer Response

DM20038

Error in CUS_DATE_FormatToIntermediate(): Invalid input format <Buff>, format unsupported.

Explanation

Programmer Response

DM20039

Error in CUS_DATE_IntermediateToFormat(): Invalid output data/format <Invalid/Buff>.

Explanation

Programmer Response

DM20040

Error in CUS_DATE_FormatToIntermediate(): Invalid output format <Buff>, format unsupported.

Explanation

Programmer Response

DM20041

Illegal table entry specified for base rule ImageRemover. Table Entry: <Table>. Bad offset,len specified: <Buff>.

Explanation

Programmer Response

DM20042

Illegal table entry specified for base rule ImageRemover. Table Entry: <Table>. Unable to get data at offset,len specified: <Buff>.

Explanation

Programmer Response

DM20043

Illegal table entry specified for base rule ImageRemover. Table Entry: <Table>. Bad comp value specified: <Value>.

Explanation

Programmer Response

DM20044

Illegal table entry specified for base rule ImageRemover. Table Entry: <Table>. Unable to retrieve comp value specified: <Value>.

Explanation

Programmer Response

DM20045

Illegal table entry specified for base rule ImageRemover. Table Entry: <Table>. comp code not supported: <Value>.

Explanation

Programmer Response

DM20046

Illegal table entry specified for base rule ImageRemover. Table Entry: <Table>.

Explanation

Programmer Response

DM20047

Error in LoadFieldVars(): Unable to properly parse TMVARSUB.

Explanation

Programmer Response

DM20048

Error in LoadFieldVars(): Unable to create GVM variable named Name.

Explanation

Programmer Response

DM20049

Error in LoadFieldVars(): Unable to create store data Temp in a GVM variable named Name.

Explanation

Programmer Response

DM20050

Error in LoadGlobalFonts(): Unable to find DefLib in MasterResource group in INI.

Explanation

Programmer Response

DM20051

Error in LoadGlobalFonts(): Unable to find XrfFile in MasterResource group in INI.

Explanation

Programmer Response

DM20052

Error in LoadGlobalFonts(): Unable to find XrfExt in MasterResource group in INI.

Explanation

Programmer Response

DM20053

Error in LoadGlobalFonts(): Unable to GENLoadGlobalFonts(pRPS).

Explanation

Programmer Response

DM20054

Error in ChubbCreateMacros(): Unable to create macro CNTR1.

Explanation

Programmer Response

DM20055

Error in ChubbCreateMacros(): Unable to create macro CNTR2.

Explanation

Programmer Response

DM20056

Error in ChubbCreateMacros(): Unable to create macro CNTR3.

Explanation

Programmer Response

DM20057

Error in ChubbCreateMacros(): Unable to create macro CNTR4.

Explanation

Programmer Response

DM20058

Error in ChubbCreateMacros(): Unable to create macro CNTR5.

Explanation

Programmer Response

DM20059

Error in tLookupOnTable(): Unable to GENGetGlbData('TblLstH',,).

Explanation

Programmer Response

DM20060

Error in tLookupOnTable(): ((LookupLstH = TblLstH) == VMMNULLHANDLE).

Explanation

Programmer Response

DM20061

Error in tLookupOnTable(): Unable to GENGetRecord(pRPS,LookupLstH,<Key>,RecNum).

Explanation

Programmer Response

DM20062

Error in CUSInitPrint :: Failed to create global variable ' RULPRT '.

Explanation

Programmer Response

DM20063

Error in CUSInitPrint :: Failed to instantiate ' RULPRT ' global variable.

Explanation

Programmer Response

DM20064

Error in CUSInitPrint :: Failed to locate global variable ' RULPRT '.

Explanation

Programmer Response

DM20065

Error in CUSInitPrint :: Failed to load print file information.

Explanation

The function, LoadPrintrInfo, returned an error to CUSInitPrint.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM20088: Error in LoadPrinterInfo :: Failed to locate INI group <PrinterInfo>

option <Printer>

DM20065: Error in CUSInitPrint :: Failed to load print file information.

Check the indicated INI options to the indicated INI group(s) in the above message.

For more information on INI Options, refer to the online INI Reference Guide.

DM20066

Error in CUSInitPrint :: Failed to load batch file information.

Explanation

Batch file information could not be found in or loaded from the INI file

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM20096: Error in LoadBatchInfo :: Failed to locate INI group <Batch1>

option <Printer>

DM20066: Error in CUSInitPrint :: Failed to load batch file information.

Check the indicated INI options to the indicated INI group(s) in the above message.

For more information on INI Options, refer to the online INI Reference Guide.

DM20067

Error in CUSInitPrint :: Failed to load recipient list.

Explanation

The recipient list information could not be found in or loaded from the INI file.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM20101: Error in LoadRecipList(): Unable to INIFirstInitValue(<RECIP_NAMES>,NULL,,).

DM20067: Error in CUSInitPrint :: Failed to load recipient list.

Check the indicated INI options to the indicated INI group(s) in the above message.

For more information on INI Options, refer to the online INI Reference Guide.

DM20068

Error in CUSInitPrint :: Unable to PRTInitPrinterSpecs().

Explanation

Programmer Response

DM20069

Error in CUSInitPrint :: Unable to RCBUpdateGlbRecips(pRPS).

Explanation

Programmer Response

DM20070

Error in CUSInitPrint :: Unable to GENLoadGlobalFonts(pRPS).

Explanation

The function, GENLoadGlobalFonts(pRPS), returned an error to CUSInitPrint.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM11111: Error in GENLoadGlobalFonts(): Unable to INIGetInitValue

('MasterResource','XrfFile',,).

DM20070: Error in CUSInitPrint :: Unable to GENLoadGlobalFonts(pRPS).

Check the indicated INI options to the indicated INI group(s) in the above message.

For more information on INI Options, refer to the online INI Reference Guide.

DM20071

Error in CUSInitPrint :: Failed to retrieve ' RULPRT ' global data.

Explanation

Programmer Response

DM20072

Error in GetRCBRec :: Failed to retrieve ' RULPRT ' global data.

Explanation

Programmer Response

DM20073

Error in GetRCBRec :: Failed to obtain batch handle.

Explanation

Programmer Response

DM20074

Error in GetRCBRec :: Failed to initialize batch <File>.

Explanation

The function, GetRCBRec, failed to initialize the batch file specified in the <File> portion of the message.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

DM13005: Error in RCBInitBatch(): Unable to to DBInitializeFile(ASCII,

<.\Batch\RegBat>,,).

DM20074: Error in GetRCBRec :: Failed to initialize batch <.\Batch\RegBat>

DM20075

Error in GetRCBRec :: Unable to RCBInitBatch( NULL, <File>,MODE_WRITE+1).

Explanation

Programmer Response

DM20076

Error in GetRCBRec ::: Unable to GetRecipientSet.

Explanation

Programmer Response

DM20077

Error in PrintFormset :: pRPS->CurrentFapFormsetH == VMMNULLHANDLE.

Explanation

Programmer Response

DM20078

Error in PrintFormset :: Unable to VMMCreateList() for outlistH.

Explanation

Programmer Response

DM20079

Error in PrintFormset :: Unable to VMMInsOrdElem(outlistH,,,).

Explanation

Programmer Response

DM20080

Error in PrintFormset :: GlobalRecip.code:<Code> is invalid for GlobalRecip.name:<Name>. You may be flushing too much of the formset.

Explanation

Programmer Response

DM20081

Error in PrintFormset :: Failed to locate ' RULPRT ' global data.

Explanation

The function, PrintFormset, failed to locate the GVM variable RULPRT.

Programmer Response

Verify that the job level rule, InitPrint, exists in your AFGJOB.JDT. This rule is required for Batch single-step mode processing.

See the online Rules Reference for the format of the InitPrint rule plus a description of Batch single-step mode processing.

DM20082

Error in PrintFormset :: RecipTblH == VMMNULLHANDLE.

Explanation

Programmer Response

DM20083

Error in PrintFormset :: Unable to locate INI group:RECIP_NAMES, value:<Code>. Unable to VMMLocateOrdElem(RecipTbl,<Buff>,found).

Explanation

Programmer Response

DM20084

Error in PrintFormset :: Unable to locate batch <Batch> in batchlist.

Explanation

Programmer Response

DM20085

Error in PrintFormset :: Unable to PRTQueueRecipient(<Table>,<Name>,<Buff>). recip code:<Code>.

Explanation

Programmer Response

DM20086

Error in LoadPrinterInfo :: NULL pointer passed for pRulPrtInfo.

Explanation

Programmer Response

DM20087

Error in LoadPrinterInfo :: Failed to create print file list.

Explanation

Programmer Response

DM20088

Error in LoadPrinterInfo :: Failed to locate INI group <PrinterInfo> option <Printer>.

Explanation

The function, LoadPrinterInfo, could not find the INI group, PrinterInfo in the INI file.

Programmer Response

Add the < PrinterInfo > group and options to the INI file. For more information on INI Groups and Options, refer to the online INI Reference Guide.

DM20089

Error in LoadPrinterInfo :: Failed to locate INI group <Name> option <PORT>.

Explanation

The function, LoadPrintInfo, could not find the INI group specified in the < Name > portion of the message in the INI file.

Programmer Response

Add the indicated INI group and options to the INI file. For more information on INI Group and Options, refer to the online INI Reference Guide.

DM20090

Error in LoadPrinterInfo :: Failed to insert into printer file list.

Explanation

Programmer Response

DM20091

Error in LoadBatchInfo :: NULL value passed for pRulPrtInfo.

Explanation

Programmer Response

DM20092

Error in LoadBatchInfo :: Failed to create batch list.

Explanation

Programmer Response

DM20093

Error in LoadBatchInfo :: Failed to locate INI group <Print_Batches>.

Explanation

The function, LoadBatchInfo, failed to locate the INI group < Print_Batches > in the INI file.

Programmer Response

Add the indicated INI group and options to the INI file.. For more information on INI Options, refer to the online INI Reference Guide.

DM20094

Error in LoadBatchInfo :: Failed to locate INI group <Print_Batches> option <Buff>.

Explanation

Programmer Response

DM20095

Error in LoadBatchInfo :: Failed to create list of printers for batch <Name>.

Explanation

Programmer Response

DM20096

Error in LoadBatchInfo :: Failed to locate INI group <Name> option <Printer>.

Explanation

The INI Group, specified in the < Name > portion of the message and the Option, Printer, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20097

Error in LoadBatchInfo :: Failed to locate printer <Name> for batch <Batch> in printer list.

Explanation

The function, LoadBatchInfo, failed to find an INI option Printer = xxxxx in the control group < PrinterInfo > for the batch specified in the <Batch> portion of the message. The printer xxxxx is specified in the <Name> portion of the message.

Programmer Response

Verify that the printer names specified in the INI control group < PrinterInfo > match those specified in < Print_Batches >.

Example:

< Print_Batches >

Default = .\Batch\Default

< Default >

Printer = DEFLTPRT

< PrinterInfo >

Printer = DEFLTPRT

For more information on INI Options, refer to the online INI Reference Guide.

DM20098

Error in LoadBatchInfo :: Failed to append <Name> to batch <Batch> printer list.

Explanation

Programmer Response

DM20099

Error in LoadBatchInfo :: Failed to append batch <Batch> to batch list.


DM20100 - DM20199 Messages

DM20100

Error in LoadRecipList(): Unable to VMMCreateList().

Explanation

Programmer Response

DM20101

Error in LoadRecipList(): Unable to INIFirstInitValue(<RECIP_NAMES>,NULL,,).

Explanation

The INI Group, < Recip_Names >, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20102

Error in LoadRecipList(): Unable to INIFirstInitValue(<RECIP_NAMES>,<Buff>,,).

Explanation

Programmer Response

DM20103

Error in LoadRecipList(): INI group:RECIP_NAMES, option:<Buff>, value:<Value> must be a 3 digit number.

Explanation

Programmer Response

DM20104

Error in LoadRecipList(): Unable to VMMInsOrdElem(Table,,,).

Explanation

Programmer Response

DM20105

Error in ProcessRecord :: Failed to retrieve "RULPRT"global data

Explanation

The function, ProcessRecord, had a null pointer to a structure that contained information about the Batch List, Current Batch, Printer File list, and Recipant Table.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENPrint step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20106

Error in ProcessRecord :: Total pages for batch Name does not agree with pages per print file value Total Page Count = Pages Printer Count = Buff Pages Per Print File = File

Explanation

The function, ProcessRecord, has detected a discrepancy between the total page count, number output to the printer, and number of pages per print file. The total page count, printer count, and pages per print file are specified, respectively, in the Pages, Buff, and File portion of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENPrint step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20107

Error in ProcessRecord :: Unable to GENGetDocSetNames(pRPS).

Explanation

The function, GENGetDocSetNames, failed trying to retrieve the DocSetNames values and returned an error to ProcesseRecord.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENData and GENPrint steps. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20108

Error in ProcessRecord :: Unable to GENShowDocSetNames(pRPS).

Explanation

The function, GENShowDocSetNames, failed and returned an error to ProcessRecord.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENPrint step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20109

Error in ProcessRecord :: Unable to ProcessData(pRPS,LocalPrtInfo).

Explanation

The function, ProcessData, failed and returned an error to ProcessRecord.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENPrint step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20110

Error in ProcessData :: Unable to GENGetGlbData('POL_Offset',,).

Explanation

Programmer Response

DM20111

Error in ProcessData :: Unable to GENGetGlbData('NA_Offset',,).

Explanation

Programmer Response

DM20112

Error in ProcessData :: Unable to FAPFlushFormset( DocSet,).

Explanation

Programmer Response

DM20113

Error in ProcessData :: Unable to DSGetDocumentSet(DocSet,0,NULL,NULL,NULL,TRUE,FALSE,NULL,pRPS->fpPOLFile,POLOfset,,).

Explanation

Programmer Response

DM20114

Error in ProcessData :: Unable to FAPFlushFormset(DocSet,OBJ_ALL ~OBJ_FONTS).

Explanation

Programmer Response

DM20115

Error in ProcessData :: Unable to DSMergeNAFormset(DocSet,pRPS->fpNAFile,NAOffset,). Object Name:<Buff>

Explanation

Programmer Response

DM20116

Error in ProcessData :: Unable to FAPFlushFormset().

Explanation

Programmer Response

DM20117

Error in PrintData :: Unable to PRTPrint(DocSet,,,,,).

Explanation

Programmer Response

DM20118

Error in PrintData :: Unable to FAPFlushFormset(DocSet,).

Explanation

Programmer Response

DM20119

Error in RULInitPageCounter :: INI group < TWOUP >, option "CounterTBL" not found

Explanation

Programmer Response

DM20120

Error in RULInitPageCounter :: DBInitializeFile( <Name>, <Table>, <0xBuff> ) failed

Explanation

Programmer Response

DM20121

Error in RULInitPageCounter :: DBOpen( <Table>, DB_READWRITE | DB_TRUNCATE_IF_EXISTS ) failed.

Explanation

The function, DBOpen, could not open or locate the file specified in the <Table> portion of the message and returned an error to RULInitPageCounter.

Programmer Response

Verify that the file name exists in the subdirectory specified in the <Table> portion of the message.

Also, verify that the rule PageBatchStage1InitTerm exists in the AFGJOB.JDT.

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<Cannot open file.

No such file or directory>, code:<2>, code:<2>, msg<.\Data\Counter.tbl>.

DM20121: Error in RULInitPageCounter :: DBOpen( <.\Data\Counter.tbl>,

DB_READWRITE | DB_TRUNCATE_IF_EXISTS ) failed

DM20122

Error in RULInitPageCounter :: Unable to allocate memory for counter table entry

Explanation

Programmer Response

DM20123

Error in RULInitPageCounter :: Batch <Name>, present in the page counter table, was not found in the batch list

Explanation

Programmer Response

DM20124

Warning in GetRecipientSet :: Batch <Name> is empty. Unable to retrieve first recipient record.

Explanation

Programmer Response

DM20125

Error in GetRecipientSet :: Failed to get record Buff from batch Name.

Explanation

Programmer Response

DM20126

Error in GetRecipientSet :: Failed to locate global variable "RCBRcpCode"

Explanation

Programmer Response

DM20127

Error in GetRecipientSet :: Recipient Code is NULL.

Explanation

Programmer Response

DM20128

Error in GetRecipientSet :: RecipCode:<Code> is invalid for record:<Buff> of batch:<Name>

Explanation

Programmer Response

DM20129

Error in GetRecipientSet :: Invalid (NULL) recipient table.

Explanation

Programmer Response

DM20130

Error in GetRecipientSet :: Unable to locate recipient code Code in recipient table

Explanation

Programmer Response

DM20131

Error in GetRecipientSet :: Unable to queue recipient - (<Name>,<Print>,<Buff>). recip code <Code>.

Explanation

Programmer Response

DM20132

Error in AddAdditionalField(): Could not create field.

Explanation

Programmer Response

DM20133

Error in CUSInitMerge :: Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20134

Error in CUSInitMerge :: Unable to INIGetInitValue(<Data>,<RcbDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, RCBDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20135

Error in CUSInitMerge :: DBInitDB("ASCII") failed.

Explanation

Programmer Response

DM20136

Error in CUSInitMerge :: RCBInit failed

Explanation

Programmer Response

DM20137

Error in CUSInitMerge :: Failed to create GVM variables for DFD file File

Explanation

Programmer Response

DM20138

Error in CUSInitMerge :: Failed to create "AFPCOMMENTL" global variable

Explanation

Programmer Response

DM20139

Error in CUSInitMerge :: Failed to instantiate global variable "AFP2UPDATA"

Explanation

Programmer Response

DM20140

Error in CUSInitMerge :: Failed to create "AFPCOMMENTL" global variable

Explanation

Programmer Response

DM20141

Error in CUSInitMerge :: Failed to instantiate global variable "AFP2UPDATA"

Explanation

Programmer Response

DM20142

Error in CUSInitMerge :: Failed to allocate comment buffer

Explanation

Programmer Response

DM20143

Error in CUSInitMerge :: Failed to allocate comment buffer

Explanation

Programmer Response

DM20144

Error in CUSInitMerge :: Failed to create AFP record list

Explanation

Programmer Response

DM20145

Error in CUSInitMerge :: Failed to create AFP font list

Explanation

Programmer Response

DM20146

Error in CUSInitMerge :: Failed to create global variable "AFP2UPDATA"

Explanation

Programmer Response

DM20147

Error in CUSInitMerge :: Failed to instantiate global variable "AFP2UPDATA"

Explanation

Programmer Response

DM20148

Error in CUSInitMerge :: Failed to load printer list

Explanation

Programmer Response

DM20149

Error in CUSInitMerge :: Failed to load batch information

Explanation

Programmer Response

DM20150

Error in CUSInitPrint :: Failed to create global variable "RULPRT"

Explanation

Programmer Response

DM20151

Error in CUSInitPrint :: Failed to instantiate "RULPRT" global variable

Explanation

Programmer Response

DM20152

Error in CUSInitPrint :: Failed to create global variable "2UPPRINTFLAG"

Explanation

Programmer Response

DM20153

Error in CUSInitPrint :: Failed to instantiate "2UPPRINTFLAG" global variable

Explanation

Programmer Response

DM20154

Error in CUSInitMerge :: Failed to locate global variable "AFP2UPDATA"

Explanation

Programmer Response

DM20155

Error in CUSInitMerge :: Failed to locate global variable "RULPRT"

Explanation

Programmer Response

DM20156

Error in CUSMergeAFP :: Failed to locate global variable ' AFP2UPDATA '.

Explanation

The CUSMergeAFP function could not locate the global variable ' AFP2UpData '.

Programmer Response

Verify that the rule InitMerge exists the the AFGJOB.JDT in the 3rd step of 2-up AFP Batch processing.

DM20157

Error in CUSMergeAFP :: Failed to locate global variable 'RULPRT'.

Explanation

Programmer Response

DM20158

Error in CUSInitMerge :: Failed to open input file File.

Explanation

Programmer Response

DM20159

Error in CUSMergeAFP :: AFPPairsRead failed.

Explanation

Programmer Response

DM20160

Error in CUSMergeAFP :: AFP2UpRead failed.

Explanation

Programmer Response

DM20161

Error in CUSMergeAFP :: Failed to locate global variable 'AFPCOMMENTL'.

Explanation

Programmer Response

DM20162

Error in CUSMergeAFP :: Failed to convert comment record to internal format.

Explanation

Programmer Response

DM20163

Error in CUSMergeAFP :: Failed to locate global variable 'AFPCOMMENTR'.

Explanation

Programmer Response

DM20164

Error in CUSMergeAFP :: Failed to convert comment record to internal format.

Explanation

Programmer Response

DM20165

Error in CUSMergeAFP :: Failed to locate global variable '2UPPRINTFLAG'.

Explanation

Programmer Response

DM20166

Error in CUSMergeAFP :: Failed to locate global variable 'AFP2UPDATA'.

Explanation

Programmer Response

DM20167

Error in CUSMergeAFP :: Failed to locate global variable 'RULPRT'.

Explanation

Programmer Response

DM20168

Error in CUSMergeAFP :: Can not write page - No current batch.

Explanation

Programmer Response

DM20169

Error in CUSInitMerge :: Failed to locate INI group <Name> option <FinalPrinter>.

Explanation

Programmer Response

DM20170

Error in CUSInitMerge :: Failed to locate printer <Name> for batch <Batch> in printer list.

Explanation

Programmer Response

DM20171

Error in CUSInitMerge :: Failed to open output file File.

Explanation

Programmer Response

DM20172

Error in CUSInitMerge :: Failed to open output file File.

Explanation

Programmer Response

DM20173

Error in CUSMergeAFP :: AFP2UpWrite failed.

Explanation

Programmer Response

DM20174

Error in PageBatchStage1InitTerm :: RCBGetPrintBatchHdl() failed. Be sure that RCBOpenPrintBatchFiles has been called.

Explanation

The function, RCBGetPrintBatchHdl, was passed a null pointer to the print batch causing it to fail and return an error to PageBatchStage1InitTerm.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20175

Error in PageBatchStage1InitTerm :: Failed to locate INI group <Batch> option <PageRange>.

Explanation

Programmer Response

DM20176

Error in PageBatchStage1InitTerm :: Invalid syntax for INI group <Batch> option <PageRange>.

Explanation

The function, PageBatchStage1InitTerm, detected invalid syntax for the first parameter of the PageRange option in the INI group specified in the Batch portion of the message.

Programmer Response

The INI option, PageRange, has two parameters; minimum and a maximum number of pages separated by a comma. The default for the minimum number of pages is zero. Maximum default is infinite. For more information on PageRange INI option, refer to the online INI Reference.

Example:

DM20176: Error in PageBatchStage1InitTerm : Invalid syntax for the print batch INI

control group <Agent>, option <PageRange>.

< Print_Batches >

Agent = .\Batch\Agent

< Agent >

PageRange = 0 missing a comma

DM20177

Error in PageBatchStage1InitTerm :: Invalid syntax for INI group <Batch> option <PageRange>.

Explanation

The function, PageBatchStage1InitTerm, detected invalid syntax for the second parameter of the PageRange option in the INI group specified in the Batch portion of the message.

Programmer Response

The INI option, PageRange, has two parameters; minimum and a maximum number of pages separated by a comma. The default for the minimum number of pages is zero. Maximum default is infinite. For more information on PageRange INI option, refer to the online INI Reference.

Example:

DM20177: Error in PageBatchStage1InitTerm : Invalid syntax for the print batch INI

control group <Agent>, option <PageRange>.

< Print_Batches >

Agent = .\Batch\Agent

< Agent >

PageRange = 0,q invalid value for second parameter; must be a number

DM20178

Error in PageBatchStage1InitTerm :: Invalid syntax for INI group <Batch> option <PageRange>.

Explanation

The function, PageBatchStage1InitTerm, detected invalid syntax for the second parameter of the PageRange option in the print batch INI control group specified by the Batch portion of the message.

Programmer Response

The INI option, PageRange, has two parameters; minimum and a maximum number of pages separated by a comma. The default for the minimum number of pages is zero. Maximum default is infinite. For more information on PageRange INI option, refer to the online INI Reference.

Example:

DM20178: Error in PageBatchStage1InitTerm : Invalid syntax for the print batch INI

control group <Agent>, option <PageRange>.

< Print_Batches >

Agent = .\Batch\Agent

< Agent >

PageRange = 0,q

DM20179

Error in PageBatchStage1InitTerm :: Failed to allocate list memory.

Explanation

The function, VMMCreateList, failed to allocate memory and returned a null pointer to PageBatchStage1InitTerm

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20180

Error in PageBatchStage1InitTerm :: Failed to create 'CUSRCBLIST' global data.

Explanation

The function, GVMCreateVariable, did not create the CusRCBList data global variable

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20181

Error in PageBatchStage1InitTerm :: Failed to instantiate 'CUSRCBLIST' global data.

Explanation

The function, GVMCreateData, did not create the CusRCBList global data.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20182

Error in PageBatchStage1InitTerm :: Failed to locate 'CUSRCBLIST' global data. Last transaction can not be written.

Explanation

The function, GENGetGlbDataPtr, could not locate the CusRCBList global data

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20183

Error in PageBatchStage1InitTerm :: Invalid parameter syntax. Last transaction can not be written.

Explanation

The MMField parameter in the PageBatchStage1InitTerm rule is missing an equal sign.

Programmer Response

The PageBatchStage1InitTerm parameter format is MMField = name. See the online Rules Reference for the correct format of the MMField parameter for the PageBatchStae1InitTerm rule.

DM20184

Error in PageBatchStage1InitTerm :: Invalid parameter <Parms>. Last transaction can not be written.

Explanation

The PageBatchStae1InitTerm rule parameter field has an invalid mnemonic in it. The data presently in the parameter field is in the Parms section of the message.

Programmer Response

The only valid parameter mnemonic for PageBatchStae1InitTerm rule is MMField . See the online Rules Reference for the correct format of the MMField parameter for the PageBatchStae1InitTerm rule.

DM20185

Error in PageBatchStage1InitTerm :: Field <Temp> specified in 'MMFIELD' parameter was not found. Last transaction can not be written.

Explanation

The function, GENGetGlbDataPtr, could not find the field name specified in the MMField parameter. The field name is specified in the Temp portion of the message.

Programmer Response

Verify that the field name is defined in the RCBDFDFL.DFD file. If so, verify that the spelling of the field name compares correctly.

DM20186

Error in PageBatchStage1InitTerm :: Failed to write last transaction.

Explanation

The function, BatchByPageCount, failed to write the last transaction and returned an error to PageBatchStage1InitTerm

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20187

Error in PageBatchStage1InitTerm :: INI group < TWOUP >, option 'CounterTBL' not found.

Explanation

The CounterTBL INI option in the < TwoUp > INI control group was not found.

Programmer Response

You must create a < TwoUp > INI control group that contains the CounterTbl option. The CounterTbl option specifes the file name for the table that contains recipient batch page counts. For more information on this INI Option, refer to the online INI Reference and the online RP System Reference section on Handling 2-up Printing.

DM20188

Error in PageBatchStage1InitTerm :: DBInitializeFile( <Name>, <Table>, <0xCounter> ) failed.

Explanation

The function, DBInitializeFile, could not initialize the database name, table, and counter and returned an error to PageBatchStage1InitTerm. The database name, table, and counter are specified (respectively) in the Name, Table, and Counter portions of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20189

Error in PageBatchStage1InitTerm :: DBOpen( <Table>, DB_READWRITE | DB_TRUNCATE_IF_EXISTS ) failed.

Explanation

The function, DBOpen, failed trying to open the table specified in the Table portion of the message and returned an error to PageBatchStage1InitTerm.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20190

Error in PageBatchStage1InitTerm :: Unable to allocate memory for counter table entry.

Explanation

The function, DBAllocateStructMemory, was unable to allocate memory for the counter table entry and returned an error to PageBatchStage1InitTerm.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20191

Error in PageBatchStage1InitTerm :: DBAdd( <0xTable>, <0xPointer>, Counter ) failed on batch Name.

Explanation

The function, DBAdd, failed trying to add information to table xxxxx counter yyyyy for batch zzzzz. The table, counter, and batch names (respectively) are specified in the Table, Counter, and Batch portions of the message.

Programmer Response

This error should not occur under normal conditions. If it does occur, re-execute the GENDATA step. If the error re-occurs, please save your Master Source Library (MRL) and contact DocuCorp Support Services.

DM20192

Error in CreateRecordList :: RCB field NA_Offset not found.

Explanation

Programmer Response

DM20193

Error in CreateRecordList :: RCB field POL_Offset not found.

Explanation

Programmer Response

DM20194

Error in CreateRecordList :: PageBatchStage1InitTerm has not been called.

Explanation

Programmer Response

DM20195

Error in CreateRecordList :: Failed to set recipient page counts.

Explanation

Programmer Response

DM20196

Error in CreateRecordList :: RCB field TotPage not found.

Explanation

Programmer Response

DM20197

Error in CreateRecordList :: RCB field NA_Offset not found.

Explanation

Programmer Response

DM20198

Error in CreateRecordList :: RCB field POL_Offset not found.

Explanation

Programmer Response

DM20199

Error in CreateRecordList :: RULWriteBCHRec failed.


DM20200 - DM20299 Messages

DM20200

Error in CreateRecordList :: Failed to retrieve "CUSRCBLIST" global data. Has the PageBatchStage1InitTerm rule been called?

Explanation

Programmer Response

DM20201

Error in CreateRecordList :: Cannot locate batch <Batch>.

Explanation

Programmer Response

DM20202

Error in CreateRecordList :: Unable to GENGetGlbDataPtr( "RCBPrtFlag",).

Explanation

Programmer Response

DM20203

Error in CreateRecordList :: Unable to GENGetGlbDataPtr( "RCBError",).

Explanation

Programmer Response

DM20204

Error in CreateRecordList :: GlobalRecip code:<Code> is invalid for GlobalRecip:<Name>. You may be flushing too much of the formset.

Explanation

Programmer Response

DM20205

Error in CreateRecordList :: Unable to GENGetGlbDataPtr( "RCBRcpCode",).

Explanation

Programmer Response

DM20206

Error in CreateRecordList :: Failed to retrieve RCB record buffer.

Explanation

Programmer Response

DM20207

Error in BatchByPageCount :: PageBatchStage1InitTerm has not been called.

Explanation

Programmer Response

DM20208

Error in BatchByPageCount :: Failed to locate "CUSRCBLIST" global data.

Explanation

Programmer Response

DM20209

Error in BatchByPageCount :: Invalid parameter syntax.

Explanation

Programmer Response

DM20210

Error in BatchByPageCount :: Invalid parameter <Parms>.

Explanation

Programmer Response

DM20211

Error in BatchByPageCount :: Field <Temp> specified in "MMFIELD" parameter was not found.

Explanation

Programmer Response

DM20212

Error in BatchByPageCount :: Failed to retrieve RCB file format information.

Explanation

Programmer Response

DM20213

Error in BatchByPageCount :: Field <Temp> specified in "MMFIELD" parameter was not found.

Explanation

Programmer Response

DM20214

Error in BatchByPageCount :: Failed to locate batch for page count <Buff>.

Explanation

The function, BatchByPageCount, failed to locate a print batch which allowed a page count equal to or greater than the count specified in the Buff portion of the message.

Programmer Response

Increase the INI option PageRange in the INI batch print control group.

Example:

DM20214: Error in BatchByPageCount :: Failed to locate batch for page

count <15>

< Print_Batches >

REGBAT = .\Batch\REGBAT

< RegBat > batch print control group

PageRange = 1, 10

DM20215

Error in BatchByPageCount :: Failed to locate "TotPage" field in recipient batch record.

Explanation

Programmer Response

DM20216

Error in BatchByPageCount :: Failed to add record to batch <Name>.

Explanation

Programmer Response

DM20217

Error in BatchByPageCount :: Failed to retrieve RCB file format information.

Explanation

Programmer Response

DM20218

Error in CUSInitPageBatchedJob :: Failed to locate <MasterResource> <FormLib> INI option.

Explanation

Programmer Response

DM20219

Error in CUSInitPageBatchedJob :: Failed to locate <Control> <ImageExt> INI option.

Explanation

Programmer Response

DM20220

Error in CUSInitPageBatchedJob :: Failed to locate <Control> <LogoExt> INI option.

Explanation

Programmer Response

DM20221

Error in CUSInitPageBatchedJob :: CUSInitPageBatchedFiles failed.

Explanation

Programmer Response

DM20222

Error in CUSInitPageBatchedJob :: Failed to create global variable RULPRT.

Explanation

Programmer Response

DM20223

Error in CUSInitPageBatchedJob :: Failed to instantiate RULPRT global variable.

Explanation

Programmer Response

DM20224

Error in CUSInitPageBatchedJob :: Failed to locate global variable RULPRT.

Explanation

Programmer Response

DM20225

Error in CUSInitPageBatchedJob :: Failed to initialize list of page counts.

Explanation

The function, CUSInitPageBatchedJob, failed to initialize the page count information.

Programmer Response

This message is one in a group of related messages. Follow the message chain up to locate a message that describes the error in more detail.

Example:

Error in RPFAPErrorNotify(): FAP library error: area:<Cannot open file.

No such file or directory>, code:<2>, code:<2>, msg<.\Data\Counter.tbl>.

DM20121: Error in RULInitPageCounter :: DBOpen( <.\Data\Counter.tbl>,

DB_READWRITE | DB_TRUNCATE_IF_EXISTS ) failed

DM20225: Error in CUSInitPageBatchedJob :: Failed to initialize list of page counts

DM20226

Warning in CUSInitPageBatchedFiles :: Unable to INIGetInitValue(<Data>,<DataPath>,,).

Explanation

The INI Group, < Data >, and the Option, DataPath, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20227

Error in CUSInitPageBatchedFiles :: Unable to INIGetInitValue(<MasterResource>,<DefLib>,,).

Explanation

The INI Group, < MasterResource >, and the Option, DefLib, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20228

Error in CUSInitPageBatchedFiles :: Unable to INIGetInitValue(<Data>,<DbLogFile>,,).

Explanation

The INI Group, < Data >, and the Option, DbLogFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20229

Error in CUSInitPageBatchedFiles :: Unable to INIGetInitValue(<Data>,<RcbDfdFile>,,).

Explanation

The INI Group, < Data >, and the Option, RCBDFDFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20230

Error in CUSInitPageBatchedFiles :: DBInitDB("ASCII") failed.

Explanation

Programmer Response

DM20231

Error in CUSInitPageBatchedFiles :: RCBInit( <Buff>, <File>, <Temp> ) failed.

Explanation

Programmer Response

DM20232

Error in CUSInitPageBatchedFiles :: Unable to INIGetInitValue(<Data>,<NaFile>,,).

Explanation

The INI Group, < Data >, and the Option, NAFile, could not be found in the INI file.

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20233

Error in CUSInitPageBatchedFiles :: Unable to fopen(<File>,'r').

Explanation

The fopen function could not open for read mode the file, Name, as specified in the error message.

Programmer Response

Verify that the file exists in the expected subdirectory. If the file exists in the expected subdirectory, then verify that the file name matches the one in the subdirectory and in the error message. Also verify that the files’ attribute flags are not set incorrectly (i.e. system, read only, and/or compressed).

DM20234

Error in CUSInitPageBatchedFiles :: Unable to INIGetInitValue(<Data>,<PolFile>,,).

Explanation

The INI Group, < Data >, and the Option, POLFile, could not be found in the INI file

Programmer Response

Add the indicated INI option to the indicated INI group. For more information on INI Options, refer to the online INI Reference Guide.

DM20235

Error in GetCallbackFunctionPointer :: Callback function <Name> not found.

Explanation

Programmer Response

DM20236

Error in CUSAddTextLabel :: Failed to locate global variable 'AFP2UPDATA'.

Explanation

Programmer Response

DM20237

Error in CUSAddTextLabel :: Missing rule parameters.

Explanation

The rule AddTextLabel is missing parameters.

Programmer Response

See the online Rules Reference for the correct format of the parameters for the AddTextLabel rule.

DM20238

Error in CUSAddTextLabel :: Invalid parameter syntax at Parms.

Explanation

The function, CUSAddTextLabel, has detected invalid parameter syntax in the rule AddTextLabel. The parameter syntax that is invalid is specified in the <Parms> portion of the message.

Programmer Response

See the online Rules Reference for the correct syntax of the parameters for the AddTexLabel rule.

DM20239

Error in CUSAddTextLabel :: Failed to locate font Font.

Explanation

The function, CUSAddTextLabel, failed to locate the font specified in the rule AddTextLabel. The font is specified in the <Font> portion of the message.

Programmer Response

Verify that the rule MergeAFP exists in the AFGJOB.JDT in the 3rd step of 2-up AFP Batch processing. Also, verify that the font is specified on the AddTextLabel rule.

See the online Rules Reference for the correct format of the parameters for the AddTexLabel rule.

DM20240

Error in CUSAddLine :: Missing rule parameters.

Explanation

The rule AddLine is missing parameters.

Programmer Response

See the online Rules Reference for the correct format of the parameters for the AddLine rule.

DM20241

Error in CUSAddLine :: Invalid parameter syntax at Parms.

Explanation

The syntax for the rule AddLine is invalid.

Programmer Response

See the online Rules Reference for the correct format of the parameters for the AddLine rule.

DM20242

Error in ParseCommentExample :: Failed to retrieve global variable 'AFP2UPDATA'.

Explanation

Programmer Response

DM20243

Error in CUSAddTextLabel :: Failed to locate global variable 'AFPCOMMENTL'.

Explanation

Programmer Response

DM20244

Error in CUSAddTextLabel :: Failed to parse AFP comment record.

Explanation

Programmer Response

DM20245

Error in CUSAddTextLabel :: Failed to locate global variable 'AFPCOMMENTR'.

Explanation

Programmer Response

DM20246

Info in CUSInitPrint :: Print option PRTOPT_FILTERRECIP is turned ON.

Explanation

An information message, which informs you that filtering of recipient data, is turned ' ON'.

Programmer Response

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20247

Info in CUSInitPrint :: Print option PRTOPT_PRTALLRECIPS is turned ON.

Explanation

An information message that informs you that the PRTOPT_PRTALLRECIPS flag is turned ' ON '.

Programmer Response

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20248

Info in CUSInitPrint :: Print option PRTOPT_SENDFONTS is turned ON.

Explanation

An information message that informs you that enabling of downloading of fonts is set to ' Yes ' for the printer type selected in the INI file.

Programmer Response

SendFonts enabling is controlled by the INI option, DownLoadFonts, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = PCL

< PrtType:PCL >

DownLoadFonts = Yes, Enabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20249

Info in CUSInitPrint :: Print option PRTOPT_PERMFONTS is turned ON.

Explanation

Programmer Response

DM20250

Info in CUSInitPrint :: INI option (<Print>CompileInStream) is obsolete.

Explanation

Programmer Response

DM20251

Info in CUSInitPrint :: INI option (<Print>SendOverlay) is obsolete.

Explanation

Programmer Response

DM20252

Info in CUSInitPrint :: INI option (<Print>SendColor) is obsolete.

Explanation

Programmer Response

DM20253

Info in CUSInitPrint :: Print option PRTOPT_COMPILEINSTREAM is turned ON.

Explanation

An information message that informs you that CompileInStream is set to ' Yes '.

Programmer Response

CompileInStream enabling is controlled by the INI option, CompileInStream, in the INI group < Printer >.

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20254

Info in CUSInitPrint :: Print option PRTOPT_COMPILEINSTREAM is turned OFF.

Explanation

An information message that informs you that CompileInStream is set to ' No '.

Programmer Response

CompileInStream disabling is controlled by the INI option, CompileInStream, in the INI control group < Printer >.

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20255

Info in CUSInitPrint :: Print option PRTOPT_SENDOVERLAY is turned ON.

Explanation

An information message that informs you that enabling of SendOverlays is set to ' Yes ' for the printer type selected in the INI file.

Programmer Response

SendOverlays enabling is controlled by the INI option, SendOverlays, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

SendOverlays = Yes, Enabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20256

Info in CUSInitPrint :: Print option PRTOPT_SENDOVERLAY is turned OFF.

Explanation

An information message that informs you that enabling of SendOverlays is set to ' No ' for the printer type selected in the INI file.

Programmer Response

SendOverlays disabling is controlled by the INI option, SendOverlays, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

SendOverlays = No, Disabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20257

Info in CUSInitPrint :: Print option PRTOPT_SENDCOLOR is turned ON.

Explanation

An information message that informs you that enabling of SendColor is set to ' Yes ' for the printer type selected in the INI file.

Programmer Response

SendColor enabling is controlled by the INI option, SendColor, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

SendColor = Yes, Enabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20258

Info in CUSInitPrint :: Print option PRTOPT_SENDCOLOR is turned OFF.

Explanation

An information message that informs you that enabling of SendColor is set to ' No ' for the printer type selected in the INI file

Programmer Response

SendColor disabling is controlled by the INI option, SendColor, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

SendColor = No, Disabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20259

Info in CUSInitPrint :: Print option PRTOPT_PAGENUMBERS is turned ON.

Explanation

An information message that informs you that enabling of PageNumbers is set to ' Yes ' for the printer type selected in the INI file.

Programmer Response

PageNumbers enabling is controlled by the INI option, PageNumbersr, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

PageNumbers = Yes, Enabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20260

Info in CUSInitPrint :: Print option PRTOPT_PAGENUMBERS is turned OFF.

Explanation

An information message that informs you that enabling of PageNumbers is set to ' No ' for the printer type selected in the INI file.

Programmer Response

PageNumbers disabling is controlled by the INI option, PageNumbersr, in the INI group < PrtType:xxx >. XXX is a printer mnemonic defined in the INI control group < Printer > option PrtType = .

Example:

< Printer >

PrtType = XER

< PrtType:XER >

PageNumbers = No, Disabled

For more information on INI Options, refer to the online INI Reference.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control >.

DM20261

Processing Batch:<Name> File:<File> Port:<Print>.

Explanation

This informative message is output to the online during GENPrint processing. It informs you which batch (xxxxx) and batch file (yyyyy) name has been processed, plus the port name (zzzzz) the output data was written too. The batch, batch file, and port names are specified, respectively, in the Name, File, and Print portion of the message.

Programmer Response

This is a GENPrint informative message.

DM20262

Skipping Batch:<Buff> per inclusion in the ExcludeBatch INI group.

Explanation

The batch (specified in the Buff portion of the message) was exclude from print ready files when GENPrint was executed, because it was defined in the < ExcludeBatch > INI control group.

Programmer Response

This message is a GENPrint informative message.

DM20263

Num records processed in Name batch.

Explanation

This message informs you about the number of records processed by GENPrint for the current batch. The number of records and current batch name are specified, respectively, in the Num and Name portion of the message.

Programmer Response

This is a GENPrint informative message.

DM20264

Info in AddAdditionalField(): Added additional field.

Explanation

Programmer Response

DM20265

WARNING :: INI group <DEBUG_SWITCHES> option <ENABLE_DEBUG_OPTIONS> is set to YES. This option is for debugging purposes and should normally be set to NO.

Explanation

A GenData message that informs you that the INI control group, < Debug_Switches > has the INI option Dbg_PageBatch included in it and the option is set to Yes.

Programmer Response

This INI option is for debugging purposes only and should be removed or set to No. The INI default is No.

This message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group

< Control >.

DM20266

Information from PageBatchStage1InitTerm :: Batch <Name> page range set to <Min-Max>.

Explanation

This GenData message displays the present settings for the INI option PageRange minimum and maximum parameters for the print batch. The print batch name, minimum and maximum page range values are specified, respectively, in the Name, Min, and Max portion of the message.

Programmer Response

This debug message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control > and INI control group, < Debug_Switches > has the INI option Dbg_PageBatch set to Yes.

Example:

DM20266: Information from PageBatchStage1InitTerm :: Batch <Agent> page range

set to < 0-10>.

< Print_Batches >

Agent = .\Batch\Agent

< Agent >

PageRange = 0,10

For more information on INI Options, refer to the online INI Reference.

DM20267

Information in PageBatchStage1InitTerm :: Batch <Name> contain <Buff> pages.

Explanation

This GenData message informs you how many pages are contained in the print batch. The print batch name and number of pages are specified, respectively, in the Name and Buff portion of the message

Programmer Response

This debug message is output to the LogFile file when the INI option LogTransactions = Yes is present in the INI group < Control > and INI control group, < Debug_Switches > has the INI option Dbg_PageBatch set to Yes.

For more information on INI Options, refer to the online INI Reference.

DM20268

Information in BatchByPageCount :: Current value of MMFIELD parameter <Temp> is <Field>.

Explanation

Programmer Response

DM20269

Information in BatchByPageCount :: Previous value of MMFIELD parameter <Temp> is <Field>.

Explanation

Programmer Response

DM20270

Error in RULRegisterCustomRules(): Unable to RPRegisterBaseRule(pRPS,Buff,<Name>).

Explanation

Programmer Response

DM20271

Error in RULRegisterCustomRules(): Unable to RPRegisterImageRule(pRPS,Buff,<Name>).

Explanation

Programmer Response

DM20272

Error in RULRegisterCustomRules(): Unable to RPRegisterFieldRule(pRPS,Buff,<Name>).

Explanation

Programmer Response

DM20273

Error in RULRegisterCustomRules(): Unable to RPRegisterRecipRule(pRPS,Buff,<Name>).

Explanation

Programmer Response

DM20274

Error in GENMoveIt(): Empty Key parms in fmt (GENGetRecord).

Explanation

Programmer Response

DM20275

Error in GENMoveIt(): Unable to RunUsrFunc().

Explanation

Programmer Response

DM20276

Error in GENMoveIt(): Unable to GENGetFieldData(pRPS,,<Buff>).

Explanation

Programmer Response

DM20277

Warning in FormsetMail(): Email Address not found in Transaction<Accnt>.

Explanation

Programmer Response

DM20278

Error in MultiFileMail(): INI value EMAIL:MailFileLog not found.

Explanation

Programmer Response

DM20279

Error in MultiFileMail(): INI value EMAIL:UniqueFile not found.

Explanation

Programmer Response

DM20280

Error in CUSInitMerge :: Failed to create global variable <Name>.

Explanation

Programmer Response

DM20281

Warning in CUSErrorProc(): Setting option FieldErrors = No in INI Group <GenDataStopOn>.

Explanation

Programmer Response

DM20282

Error in (CUSLIB)CUSLoadImageTiff. To few parameters in user data.

Explanation

Programmer Response

DM20283

Error in (CUSLIB)CUSLoadImageTiff. Unable to RunUsrFunc.

Explanation

Programmer Response

DM20284

Error in (CUSLIB)CUSLoadImageTiff. No record for <RecLabel> Label found.

Explanation

Programmer Response

DM20289

Error in &rule&: Field<&Field&> on Image<&image&> is not a Multiline text variable field.\n

Explanation

Programmer Response

DM20290

Error in &rule&: Unable to GetFormEntry for <&key1&;&key2&;&formname&>. Image<&image&>.

Explanation

Test explanation

Programmer Response

DM20291

Error in &rule&: Unable to FAPCreateFormset(). Image<&image&>\n

Explanation

Programmer Response

DM20292

Error in &rule&: Unable to DSLoadFormDataLine(FormsetH,0,<&GrpName1&>,<&GrpName2&>,<&GrpName3&>,TRUE,<&Name&>,<&Line&>,0,FormH).\n

Explanation

Warning :: INI group <DEBUG_SWITCHES> option <DEBUG_GROUP_RULE> is set to YES.

This option is for debugging purposes and should normally be set to NO.

Programmer Response

The information you get back is such as the name of the begin and end image of the group, the rule parameter that is used, and if this is a nested group, whether this group is a master group. The info is written to the logfile.dat.

DM20293

Error in &Rule&: Unable to PopulateFieldFromForm. Image<&image&>\n


DM20300 - DM20399 Messages

DM20307

Error in RULStandardFieldProc(): pRPS->CurrentFapFieldH == VMMNULLHANDLE. Field rule (fap) field:<DestField>, Rule<FieldName>.

Explanation

Programmer Response

DM20308

Error in RULStandardFieldProc(): Unable to FAPSetFieldData(,<OutBuff>,).

Explanation

Programmer Response

DM20319

Error in GroupBegin(): There are more Begin Groups than there are End Groups.

The Group started on Image <imagename> was never ended

Explanation

GroupBegin and GroupEnd rules work in pair to process a group of images. The GroupBegin rule that is applied to the beginning DDT file does not have a corresponding GroupEnd rule in the other ending DDT file.

Programmer Response

Locate the DDT file that matches the ending image of this group of images in the form.dat and add the GroupEnd rule to it.

DM20322

Error in SetOverflowPaperTray: <&FormName&> has a value equals to <&Value&>. The only legal values are: tray1, tray2, tray3, tray4, tray5, tray6, tray7, tray8, or tray9.

Explanation

The RP AFGJOB.JDT form set level (2) rule, SetOverflowPaperTray, was passed an invalid value for the printer tray parameter.

Programmer Response

Correct the printer tray value specified in the INI control group, < OverflowPaperTray >, option, FormName in your FSISYS or FSIUSER file.

DM20354

Error in SetOverflowPaperTray: No forms in the formset.

Explanation

No forms were triggered for the current transaction being processed. The RP rule, SetOverflowPaperTray, issues an error message so the user may terminate job processing based on the settings in the INI control group, < GenDataStopOn >. RP only issues a warning message when no forms were triggered for the current transaction.

Programmer Response

Determine why no forms were triggered for the current transaction and correct the problem.

When no forms are triggered for a transaction, the RP messages output are as follows:

DM10797: Warning in SetNextImage(): No forms for current transaction. FAPTotalForms(pRPS->CurrentFapFormsetH) < 1). Processing will continue.

DM20354: Error in SetOverflowPaperTray: No forms in the formset.

DM20369

Error in SetOrigin: Multiple SetOrigins using the same form name are detected. This image <ImageA> was previously set using <Abs+600,Abs+1200,Form1>.

Explanation

Programmer Response

Only one SetOrigin with the same form name should be listed. If you intend to use this SetOrigin <Abs+0,Abs+2400,Form1>, remove the previous SetOrigin.

DM20370

Error in SetOrigin: Origin for image <ImageA> was previously set using <Abs+600,Abs+2400>.

Explanation

Programmer Response

If you're using multiple SetOrigins for this image, the default, a SetOrigin without a form name should be listed last.

DM20371

Error in SetOrigin: Multiple SetOrigins are detected. This image <ImageA> was previously set using <Abs+600,Abs+2400>.

Explanation

Programmer Response

If you intend to use this SetOrigin <Abs+600,Abs+1200>, remove the previous SetOrigin.

DM20373

Error in FormDescription(): Unable to FAPFindImageFields. A variable field that has a name beginning with "FORM DESC LINE" cannot be found in this formset.

Explanation

The system generates this error when the rule FormDescription is set up to be run in the afgjob.jdt and the required field that has a name beginning with "FORM DESC LINE" cannot be found in the formset.


DM30000 - DM30099 Messages

DM30000

Warning in msgFunc(): INI Group <msgGroup> contains Option <msgOption> with invalid Value <msgValue>. Value set to <msgValue2>.

Explanation

Programmer Response

DM30001

Error in FilterExtrFile(): Unable to GENOpenExtFile(<File>,MODE_WRITE).

Explanation

Programmer Response

DM30033

Warning in <&Rule&>(): Error parsing rule parameters. Image<&image&> Parm<&parms&>

PCR # 16949 & 17082

Explanation

When parsing the specified image rule, <&Rule&>, incorrect parameter definition(s) , <&parms&>, weres detected for image, <&image&>.

Programmer Response

Correct the image rule parameter definition(s) for the specified image.

See the online Rules Reference, Image and Field Rules, section for the correct parameter definitions..

Example

DM30033: Warning in <SETORIGIN>(): Error parsing rule parameters. Image<CA20759L> Parm<ABS+0>

DM30046

<mtype>: Field <field_name> on Image <image_name> has Font ID = 0. The field may have been included incorrectly or the FAP has not been updated to include the field's definition.

Explanation

If the INI group < RunMode > option, CheckZeroFontID, is set to ‘Yes, Error, or Warning’ and GenData encounters a field with no font ID assigned; the Warning/Error message DM30046 will be generated. This means the some unusual situation has occurred; like the field was defined via an import method but not actually defined on the FAP file where it resides. Or the font ID in the specified image/field is set to zero.

In either message, the values, field_name and image_name, reflects the appropriate field name and image name. mtype reflects the type of message generated: Error or Warning.

Programmer Response

Check the specified image/field name and if the font ID is zero, enter the desired font ID. If the field is not defined on the specified image name, then define the appropriate field or notify the appropriate individual that the XML import file contains field data that does not exist on said image.


DM100000 Message

DM100000

Message