Archive Settings


Archive plugin functions
         Next Topic

Archive plugin functions.

[ ArcRet ]

    • PlugInFunc
    • PlugInMod


Command Line Utilities

Each Utility is described in detail in the command line utility book. Otherwise known as Documaker Development Tools book.

[ ArcRet ]

    • MergeLog


Common to all Archive

Common settings for all archive including Docupresentment.

[ Archival ]

    • ArchiveMem

[ ArcRet ]

    • AppIdx
    • AppIdxDfd
    • ARCPath
    • CARFile
    • CARMaxFileSize
    • CARPath
    • CATALOG
    • CatalogDfd
    • TEMPIDX

[ Debug_Switches ]

    • ArcLib
    • CarLib

[ VerifyKeyID ]

    • OnCreate
    • OnUpdate
    • Script


GenArc

Genarc rules processor (batch) archive settings

[ Archival ]

    • CaseSensitiveKeys
    • UseRestartTable

[ ArcRet ]

    • RestartTable

[ Debug_Switches ]

    • Debug_GenArc

[ GenArcStopOn ]

    • DBErrors

[ Trigger2Archive ]

    • Company
    • DAPDate
    • RunDate


Workstation Archive

Workstation (GUI) Archive settings

[ AfeProcedures ]

    • AFEWIP2ArchiveRecord
    • Archive

[ AfeWip2ArchiveRecord ]

    • ARCKEY

[ Archival ]

    • MODE

[ Complete ]

    • Archive


Workstation Archive Retrieval

Workstation Archive Retrieval settings

[ ArcRet ]

    • ActiveFieldHighlight
    • Arrangement
    • AutoAcceptSingleMatch
    • ClearPosSetFlag
    • DefaultRecipView
    • DisplayAllEntryFormPages
    • ExactMatch
    • HideKey1
    • HideKey2
    • HideKeyID
    • KeepFiles
    • LBLIMIT
    • SkipHiddenFields
    • TabNextPage
    • TransferKey1
    • TransferKey2
    • TransferKeyID

[ DlgTitles ]

    • RetOptionsDlgTitle
    • RetrieveDlgTitle
    • RetrOptionsOnlyEntry
    • RetrOptionsPrintOnly
    • RetrOptionsStackOnly

[ FormSelection ]

    • RetrieveVersionInfo

[ Group1 ]

    • Title1
    • Title2
    • Title3
    • Title4
    • Title5
    • Title6
    • Title7


Workstation Print System

[ ArcRet ]

    • PrintReprinted

[ BatchPrint ]

    • ArchiveSpaceNeeded
    • AutoStart
    • NoBatchSupport
    • Path
    • PreLoadRequired
    • Program
    • SpaceNeeded
    • SpoolDrive


Arcsplit Settings

Archive Split settings

[ ArcSplit ]

    • ArcSplitConfig
    • DefConfig

[ ArcSplitConfig:XXX ]

    • AllowChanges
    • CARFileSize
    • DALScript
    • EnableCARFileSize
    • OverrideDateRange
    • OverWriteFiles
    • PurgeRecords
    • RecordsToProcess
    • RecordsToSkip
    • RunDALScript
    • SearchDateBy
    • SplitAppIdx
    • SplitCARFile
    • SplitCatalog
    • SplitDays
    • SplitFromDate
    • SplitToDate


Common Settings

Common to All GUI Products

Miscellaneous control options

Print


Common to All GUI Products

Common Documaker system settings

[ Control ]

    • ActiveFieldBackColor
    • ActiveFieldColor
    • ActualSize
    • Arrangement
    • AutoFocus
    • AutoKeyIdWarnCount
    • AutoPopupTableOnly
    • ChartLegendIconSize
    • FitToWidth
    • FitToWindow
    • ForceTableOnlySelection
    • LimitPageBreak
    • Mobius
    • TemplateUseReplaceChar
    • Title
    • Zoom
    • ZoomDiv
    • ZoomMulti

[ DataDictionary ]

    • Name

[ FormDescTable ]

    • BoldKey2
    • ColumnFormat
    • ExcludedForm
    • ExcludedGroup
    • FILE
    • IncludeDuplicateForms
    • IncludeFormDesc
    • IncludeFormName
    • IncludeKey2
    • IncludeKEY2Name
    • KEY2PostInc
    • KEY2Prefix
    • KEY2PreInc
    • Script
    • StartFromFirstForm
    • TABLE
    • UseDefaultIfMissing

[ Language ]

    • Locale

[ Loader:DOC ]

    • Desc
    • Ext
    • Func
    • Module

[ Loader:MOBIUS ]

    • Desc
    • Func
    • Module

[ Loaders ]

    • Loader

[ Menu ]

    • File
    • TXMMenu

[ SignOn ]

    • UserID

[ Spell ]

    • AlwaysSuggest
    • ApostropheSeparator
    • CaseSensitive
    • FixedDialogPos
    • HyphenSeparator
    • IgnoreCappedWords
    • IgnoreMixedCase
    • IgnoreMixedDigits
    • MainDicts
    • PhoneticSugg
    • ReportMixedCase
    • SplitWords
    • SuggestDepth
    • SuggestSplit
    • TypographicalSugg
    • UserDict

[ TimerFuncs ]

    • 01
    • 02

[ UserInfo ]

    • Encrypt
    • File
    • ImportBadReportTo
    • Path
    • SupportSuperUser
    • SuppressDeleteDialog


Miscellaneous control options

These options are common to all Documaker modules. These options are common to all Documaker modules.

[ Banner ]

    • Banner
    • Enabled
    • FIELD
    • FilterRecips
    • NAME
    • SIZE

[ Control ]

    • CacheFAPFiles
    • CacheMethod
    • FilterRecip
    • FirstPieSliceAngle
    • ImageFormat
    • LightShade
    • SuppressAssign
    • TemplateNumber
    • UseBaseDef

[ CST_EntryFormSet_Funcs ]

    • 01

[ DAL ]

    • EXT

[ DALFunctions ]

    • KeyWord

[ DALLibraries ]

    • CompileWhenLoaded
    • LIB

[ Data ]

    • TraceFile

[ Debug_Switches ]

    • DALLib
    • Debug_DAL_Rules
    • DumpDAL
    • DXMLIB
    • EPT_Debug
    • MSM_Debug
    • Show_Debug_Options

[ DocSetNames ]

    • Description
    • FormName
    • FSITemp
    • GroupName1
    • GroupName2
    • GroupName3
    • TransactionId
    • TransactionType

[ Formats ]

    • DateFormat
    • TimeFormat

[ FormDescription ]

    • Script

[ INIGroup ]

    • Option1

[ Key1Table ]

    • value_in_data

[ Key2Table ]

    • value_in_data

[ Key3Table ]

    • value_in_data

[ Keyed Files ]

    • MessageDataBase

[ Messages ]

    • Cache
    • DefaultLangCode
    • GroupingFlag
    • MaxMsgLength
    • SecondLanguageCode

[ MultiDataDict ]

    • File

[ OpenUser ]

    • INOPENUSER

[ RecordDictionary ]

    • Name

[ Sort_Forms ]

    • TableName

[ Tables ]

    • Conditions
    • NewFormatOnly
    • OldFormatOnly
    • PATH
    • RECIPIENT

[ XMLTags2GVM ]

    • GVM


Print

The FAPARC.INI file is one of the initialization (INI) files used by the DAP system to set system parameters and to enable or disable system features. The FAPARC.INI file is optional. You do not have to use it and you can delete it from your system if you first copy all of the control goups in the FAPARC.INI file to either the FSISYS.INI or FSIUSER.INI file. If, however, you want to store your archive INI options separately, use the FAPARC.INI file.

[ CodePage ]

    • Char

[ CodePages ]

    • CodePage

[ OMR_Params ]

    • Mark

[ Printer ]

    • PageNumberFormat

[ Printers ]

    • PrtType

[ PrtType:XXX ]

    • Module
    • OverlayExt


Database Settings

Archive and WIP database option settings

Archive & WIP SQL

Archive DB2 Native

Archive Documanage

Archive ODBC compliant

Database Handlers


Archive & WIP SQL

Archive & WIP SQL settings

[ DBTable:WIP ]

    • DBHandler
    • UniqueTag


Archive DB2 Native

Archive DB2 Native settings

[ DBHandler:DB2 ]

    • BindFile
    • CurrentSQLID


Archive Documanage

Archive Documanage

[ DBHandler:DMIA ]

    • Cabinet
    • Class
    • Debug
    • Domain
    • Passwd
    • RPCHost
    • UserID

[ DBHandler:PO ]

    • Cabinet
    • Class
    • Domain
    • PassWord
    • UserID

[ DBTable:Appidx ]

    • DBHandler

[ DMIA:Documanage_cabinet_name ]

    • FileType
    • FolderBy
    • NameDocBy
    • StackedDPA

[ PO:ARCCAB ]

    • FileType
    • FolderBy
    • NameDocBy

[ PO:PROD ]

    • FileType
    • FolderBy
    • ForceFolderUpdate
    • NameDocBy

[ PODocument2Field ]

    • CreateTime

[ POField2Document ]

    • AddedOn


Archive ODBC compliant

Archive ODBC compliant common settings

[ ArcRet ]

    • CARFileDFD
    • CommitEvery
    • RestartDFD

[ DB2_FileConvert ]

    • Catalog

[ DBTable:Appidx ]

    • DefaultTag

[ ODBC_FileConvert ]

    • Catalog

[ ORA_FileConvert ]

    • Catalog


Database Handlers

Common Database Handlers

[ Data ]

    • DBLogFile

[ DBHandler:ASCII ]

    • Class
    • Description
    • InstallFunc
    • InstallMod

[ DBHandler:CB5 ]

    • Class
    • Description
    • InstallFunc
    • InstallMod
    • LockAttempts

[ DBHandler:DB2 ]

    • Class
    • Connect
    • ConnectionTimer
    • CreateIndex
    • CreateTable
    • CurrentPackageSet
    • Database
    • Debug
    • InstallFunc
    • InstallMod
    • NoCreateIndex
    • NoCreateTable
    • Passwd
    • UniqueTable
    • Userid

[ DBHandler:DMS ]

    • Class

[ DBHandler:MEM ]

    • Class

[ DBHandler:ODBC ]

    • AlwaysSQLPrepare
    • BlobSupportForDB2ODBC
    • Class
    • ConnectionTimer
    • CreateIndex
    • CreateTable
    • Debug
    • InstallFunc
    • InstallMod
    • Passwd
    • Qualifier
    • Server
    • Userid

[ DBHandler:ORA ]

    • Class
    • ConnectionTimer
    • CreateIndex
    • CreateTable
    • Database
    • Debug
    • Passwd
    • UserID

[ DBHandler:xxx ]

    • Class
    • ConnectionTimer
    • CreateIndex
    • CreateTable
    • Debug
    • InstallFunc
    • InstallMod
    • Passwd
    • UserID

[ DBTable:xxx ]

    • DBHandler
    • DefaultTag
    • Persistent
    • UniqueTag

[ Debug_Switches ]

    • DBLib

[ ODBC_FieldConvert ]

    • AlwaysSQLPrepare
    • CREATETIME
    • CURRUSER
    • DESC
    • INUSE
    • KEY1
    • KEY2
    • KEY3
    • Message
    • MODIFYTIME
    • STATUSCODE
    • TRANCODE


Development Tool Settings

Documaker Studio Tools

Legacy Development Tools


Documaker Studio Tools

[ BitmapLoaders ]

[ CompuSet ]

[ Control ]

  • CenterFormTitles
  • CreateMode
  • HorizontalRuler
  • Margins
  • ModePointers
  • Normalize
  • PromptImageInfo
  • TXMRulers
  • TXMStatusLine
  • TXMTitleBar
  • TXMToolBar

[ Conversion ]

[ DDTResource ]

[ FixOptions ]

[ FMRes ]

[ FontFamilyMatching ]

[ FormSize ]

[ LibraryManager ]

[ Loader:FAP ]

[ Loader:xxx ]

[ Margins ]

[ Menu ]

[ Paper ]

[ PRTType:AFP ]

[ PrtType:XER ]

[ RTFFontMap ]

[ RTFImport ]

[ TimerFuncs ]

[ UnLoader:FAP ]

[ UnLoaders ]

[ WorkArea ]

[ XDB Editor ]


Legacy Development Tools

[ Control ]

  • AutoSave
  • AutoSaveTime
  • ChkSpellWhenExit
  • ConfirmApplExit
  • ConfirmFormExit
  • ConfirmObjDelete
  • ConfirmRevert
  • ConfirmSaveChanges
  • ConfirmUndo
  • CrossHairs
  • GuideBoxes
  • ZoomMult

[ DefaultBarCode ]

[ DefaultBitmap ]

[ DefaultBookmark ]

[ DefaultBox ]

[ DefaultGuideBox ]

[ DefaultIndex ]

[ DefaultLine ]

[ DefaultNote ]

[ DefaultShading ]

[ DefaultTextArea ]

[ DefaultTextLabel ]

[ DefaultVarField ]

[ DefaultVector ]

[ Help ]

[ HorizontalRuler ]

[ IMGFileList ]

[ VerticalRuler ]


Workstation Settings

Dialog Selections

Processing System


Dialog Selections

Entry system settings to modify screen attributes

[ Complete ]

  • Print
  • SuppressDialog

[ Control ]

  • DoFormsSelection
  • HideFormSelImport
  • HideFormSelRetrieve

[ DlgTitles ]

[ FormSelection ]

[ StartUp ]


Processing System

The Processing System is also known as the Entry System, PPS, or AFEMAIN. Sometimes it might be referred to simply as AFE (which stands for Advanced Forms Entry).

[ AfeArchiveDisplay ]

[ AFEDSProcedures ]

[ AfeLog ]

[ AfeLog_Fields ]

[ AfeLog_Format ]

[ AfeLog_List ]

[ AfeProcedures ]

[ ArcRet ]

  • DisplayOnlyEntry
  • DisplayPrintOnly

[ AssignUserList ]

[ AutoAssign ]

[ AutoFields ]

[ AutoReturn ]

[ BatchPrint ]

  • Select_Recipient

[ Bookmark ]

[ Company_Table ]

[ Control ]

  • ActivateFirstField
  • ActiveFieldHighlight
  • AllowMultiPrint
  • BatchOnComplete
  • CaseSensitiveKeys
  • CheckInArc
  • DateFmt2To4Year
  • DefaultPrint
  • DispFields
  • DisplayAllEntryFormPages
  • DisplayOnlyEntry
  • DisplayPrintOnly
  • DoFormDescLines
  • DosImageOptionsOnly
  • EntryErrorBeep
  • EntryMode
  • FixedPosFields
  • HiddenGroupPrefix
  • ImmediateOnComplete
  • LoadPrintOnly
  • Maximized
  • NoLoadFormList
  • NoTitleBar
  • Print
  • PrintDraft
  • PrintNotifyText
  • R_Option
  • ReceiveMailMsgCount
  • ReceiveMailOnWipList
  • RequiredFields
  • ShowEffectiveDate
  • ShowNotes
  • ValidateTableOnlyKey

[ Debug_Switches ]

  • CSTSyncFiles

[ EntryOptions ]

[ Environment ]

[ FormSelection ]

[ HorizontalRuler ]

[ Language ]

[ Mail ]

[ MailType:MSM ]

[ MailType:XXX ]

[ Personal ]

[ RacLib ]

[ Record_Type ]

[ Sort ]

[ Sort_Menu ]

[ Status_CD ]

[ User_StatusCD ]

[ VerticalRuler ]

[ WIPFilter ]


Import and Export Settings

Export

Import

Import and Export


Export

Export settings for standard Documaker import export file (V2), XML, Document Set (nafile and polfie)

[ BatchPrint ]

  • BatchExport

[ Complete ]

  • ArchiveExport
  • Export
  • ExportOnComplete

[ Control ]

  • ExportOnComplete

[ ExpFile_CD ]

[ ExportFormats ]

[ ExportWithXSL ]

[ MultiExportList ]


Import

Import settings for standard Documaker import export file (V2), XML, Document Set (nafile and polfie)

[ AutoImport ]

[ AutoImportXML ]

[ Environment ]

  • CompanyLibName

[ FDBEditor ]

[ ImpFile ]

[ ImpFile_CD ]

[ Import_Data ]

[ ImportExtract ]

[ ImportFile ]

[ ImportFormats ]

[ ImportFromArchive ]


Import and Export

Settings affecting both import and export functionality.

[ ImpExpCombined ]

[ XML_Imp_Exp ]


Library Settings

Documanage Library

Common Library Setup

Documanage Library


Common Library Setup

Library

[ DBTable:LBYD ]

[ Debug_Switches ]

  • LBYLib

[ Library:LBYI ]

[ LibraryManager ]

[ LMGLIB ]


Documanage Library

[ DBHandler:LBYSETUP ]

[ DBTable:LBYCAB ]


Library Project Management

Library Project Management (LPM) is an optional feature of Documaker Studio and Library Manager. LPM provides a pre-defined “best practice” for managing the development and distribution of library resources related to a project.

There are two main elements of LPM:

  • The Project Status Report
    The Project Status Report shows the project status, and can be organized by tier or resource name within project.

  • The Project Manager
    The Project Manager provides a central facility for creating new projects and modifying the state of project resources.

    Users specify a library (tier), a project, and a role (if they are eligible for more than one role) and the Project Manager provides a filtered list of the matching resources for that project that require action by that role. Users quickly navigate through the list and choose the appropriate action to perform.

The project status is defined by the overall state of the entire set of library resources assigned to that project, across all of the various library tiers defined by the workspace.

During the development process, LPM is used to organize library resources by project, and advance the resources through the tiers by managing the state of the library resource.

The state of a given library resource is defined by three library properties:

  • Tier
  • Mode
  • Status

Tiers

Tiers reflect the different stages of resource development. The tier of a library represents a separate physical library repository corresponding to a logical phase in the development process. Starting in V11.3, when a new library is created (or identified) within a workspace, the library must be assigned to a tier. LPM defines five library tiers:

Development | DEV | resources are created and modified
Unit Test | UNIT | testing of individual resources as a unit
System Test | SYST | integration testing of all resources
Model Office | MODL | final user acceptance testing
Production | PROD |

Mode is the type of task or activity that is needed (or already underway) to be performed on a resource, and is parallel to the role of the individual that will perform the work.

Roles and Modes

LPM defines four roles:

Developer | A developer on the project, able to create and check in new resources, or check out and update existing resources.
Tester | A tester on the project, either in unit testing, system testing, or user acceptance testing (model office).
Reviewer | A reviewer of the development or testing efforts, either in unit testing, system testing, or user acceptance testing (model office).
Administrator | A project administrator, able to promote resources to the next tier.

Note: The utility program LBYPROC can also act as the project administrator and perform necessary promotions for projects.)

Individuals may be assigned any combination of roles using the user security settings.

Role and mode are in parallel and LPM defines four parallel modes:

Development | Development work is needed or in process.
Testing | Testing is needed or in process, either in unit test, system test, or model office.
Review | Review needed or in process, either in development, unit test, system test, or model office
Administration | Ready for promotion to the next tier.
Production | The final mode, no further action is permitted using LPM

Resource State

The state (tier, mode, and status) of a library resource is changed to a new state via an action. Actions that can be performed are specific to a mode and role. LPM defines these actions:

  • Check out (development)
  • Check in (development)
  • Unlock (development)
  • Address (development)
  • Submit (development)
  • Pass (test)
  • Fail (test)
  • Approve (review)
  • Reject (review)
  • Promote (administration)

After an action has been performed, the state of the resource is changed, and the new status of the resource is changed to reflect that action. Status, therefore, always reflects the most recent action. LPM defines these statuses, reflecting the matching actions:

  • Checked out (development)
  • Checked in (development)
  • Unlock (nothing after an unlock – the row is deleted) (development)
  • Addressed (development)
  • Submitted (development)
  • Passed (test)
  • Failed (test)
  • Approved (review)
  • Rejected (review)
  • Promoted (administration)

Examples of the typical development flow:

A developer (role=Developer) creates a new resource and performs the “check in” action on the resource. Using Project Manager, the developer submits the checked-in resource for review and approval. The resource then has the new state:

Tier = Development

Mode = Review

Status = Submitted

A reviewer (role=Reviewer) uses the Project Manager and looks for resources of state “Development-Review-Submitted” and reviews those resources. The reviewer is limited to three actions:

- Next (skip the resource for now)

- Approve (looks good)

- Reject (needs further work)

If the reviewer approves the resource, the state becomes:

Tier = Development

Mode = Administration (ready for the administrator to promote)

Status = Approved

If the reviewer rejects the resource, the state becomes:

Tier = Development

Mode = Development

Status = Rejected

The developer looks for resources that have been rejected or failed, checks the latest revision out to correct the issue. During the subsequent pass through the project resources, the developer marks the flagged revision as addressed using the address action, and re-submits the changes for review using the submit action.

Using Tiers

Tiers reflect the different stages of resource development. Studio defines five categories of tiers:

  • Development (DEV)
  • Unit Test (UNIT)
  • System Test (SYST)
  • Model Office (MODL)
  • Production (PROD)

You do not have to use every category. For instance, you could skip Model Office or Unit Test, though we recommend that you thoroughly test resources before you place them into production.

You can create as many tiers within each category as you want. Within each category, however, you can only designate one tier as the primary (001) tier for that category.

Initial resource creation is done in the first Development tier. When you feel those resources are ready for testing, you promote them to the Unit Test category. From there a tester decides if the resources pass or fail. If the resources fail, the developer would check out the resources in the apprpriate Development tier and make changes. Development (DEV) Model Office (MODL) Production (PROD) System Test (SYST) Unit Test (UNIT) Promote Fail Promote Fail Promote Fail Deploy Development (DEV) 003 - Analysis 002 - Design 001 - Build2

When the resources pass the first level of testing, you promote them to the System Test category. From System Test, you would typically promote the resources to a pre-production category, called Model Office. Once the resources pass the testing done in the Model Office category, you can deploy them into the Production category.

Development (DEV)

003 - Analysis

002 - Design

001 - Build

When you change tiers, you are indicating that you want to change your focus into a new library. When you work within that tier, Studio shows you only those resources that have been promoted to that level. The idea is that you should be able to test resources at each level to make sure only those resources that should are promoted forward. This is typically accomplished by using the Mode and Status library record members as promotion criteria.


Print Settings

Common to all Batch Printer Types

Common to all GUI Printer Types

AFP Printer INI Options

EPT Printer INI Options

GDI Printer INI Options

GenPrint printer Options

GUI Print Options

HTML Printer INI Options

MDR Printer INI Options

Metacode Printer INI Options

PCL Printer INI Options

PDF Printer INI Options

Printing to RTF

PST Printer INI Options

PXL Printer INI Options

XML Printer INI Options

VIPP Printer INI Options


AFP Printer INI Options

You define the necessary printer options for the system to produce AFP data streams. These options specify how the system creates AFP output. Most of the AFP-related options are found in a PrtType:xxx control group, where xxx indicates the different printer types. PrtType:AFP is a common control group name used to contain AFP settings. The most common AFP printer options are shown below (default values are bold):

AFP PRINTER RESOURCES

FormDef

The system uses copy groups from its own FormDef named F1FMMST.DAT. Each copy group in a FormDef contains information about paper size, duplex, tray selection, jog, orientation, and so on. The FormDef must be available to PSF to print AFP data streams. You can use the AFPFMDEF utility to create or modify the FormDef. Fonts AFP fonts are designed solely for AFP printers. For more information about fonts, see the chapter entitled Working with Fonts in the DocuMaker RP System Reference. In IBM AFP terminology, a font is described by three components: CODED FONT.A coded font file contains references to specific character set and specific code page. Coded font files always begin with the letter X, such as X0DATIN8. CODE PAGE. In IBM AFP terminology, a code page file maps code points to an AFP character name in a character set file. Code page files always begin with the letter T, such as T1DOC037. CHARACTER SET. A character set file contains the bitmap image of each character in the character set. Character set files always begins with the letter C (such as C0FATIN8.240 or C0FATIN8.300). The character set file name extension (240 or 300) indicates whether the bitmap images are drawn at 240 or 300 dots per inch. AGFA fonts licensed for use and distribution with Documaker, fonts from the Agfa Division of Miles Inc. The system includes both 240 and 300 dpi AFP fonts.

Overlays
Use the FAP2OVL utility to create AFP overlays from FAP files. The OVLCOMP utility also lets you create AFP overlays from FAP files. These overlays must be available to PSF to print AFP data streams when the SendOverlays option is set to Yes.

Page segments

Use the LOG2PSEG utility to create AFP page segments from logos (LOG files). These page segments must be available to PSF to print AFP data streams.

NOTE: For information on these and other system utilities, see the Utilities Reference Guide.

AFP TROUBLESHOOTING

Floating image limitations

The system lets you compose a page from several images. The system also lets you create overlays for these images. There is one limitation when you print these imageson a landscape page. Overlays on a landscape page can only be placed vertically on the page. Overlays on a landscape page cannot be placed horizontally on the page. This means, in your SetOrigin rule, you cannot specify any non-zero, positive number for the X-relative displacement. Create your FAPs accordingly, keeping in mind that they can be moved down but not across. This limitation exists only for AFP overlays, and only in landscape mode. Another type of error can occur if the overlay for a custom-sized image is too small for the objects (text, lines, logos, and so on) contained in it. If the AFP overlay's page size is too small, objects may be clipped to the page size, or objects may be printed as a solid black rectangle, or objects may cause an error message to be printed. The Image Editor contains an Auto-size option which you can use to make sure the custom-sized image is large enough to contain all objects placed in it. Use this feature to prevent custom page size problems. Finally, if you create a custom-sized page, be aware of any conflict between page orientation and the form orientation. If the form orientation is not the same as the page orientation, the page will not print according to the page orientation, but will follow the form's orientation.

NOTE: This happens only in case of custom size pages. Standard size pages obey the page orientation.

Multipage FAP limitation

There is a problem when a landscape, multipage FAP has different page sizes on each page. All pages of a multipage FAP file should be the same size. As a workaround, use the Image Editor to correct the page sizes. To do so, choose the Page Properties option from the Format menu and press Ok on the Page Properties window. After saving the FAP file, you can then generate proper AFP overlays. Printing rotated variable fields Here is a list of field options you can specify in the NAFILE.DAT file:

Option | Description
E | Error
M | Manual
P | Protected
G | Global scope (entire form set)
F | Form Scope
H | Hidden field - a dummy field, not displayed or printed
N | Nonprintable field (displayed, not printed)
C | Send-copy-to field (receives current recipient name at print time)
9 | Rotated 90 degrees
8 | Rotated 180 degrees
7 | Rotated 270 degrees

Some of these options require the FAP field attributes to be available at runtime, since the DDT file does not include the necessary information. Use the CheckImageLoaded rule to make sure this information is available.

AFP 240 dpi print problems

Due to differences in resolution on 240 and 300 dpi printers, a text string may print with slightly different lengths. One example where this may be noticeable is when the text is printed inside of a boxed region. Another example where this may be noticeable is when a text area contains an embedded variable field. To minimize the print differences between 240 and 300 dpi printing, use the SplitText option. Make sure these options are in your printer PrtType:xxx control group:

< PrtType:AFP >

SplitText = Yes/No (default is No)

SplitPercent = # (% of space-width as max rounding error)

Resolution = # (default is 300)

If you set the SplitText option to Yes, each text string is checked to see if it needs to be split into sections for printing. The SplitPercent value helps determine when a text string must be split into sections for printing. The SplitPercent option sets the percentage of the width of the space character to use as the maximum amount of rounding error that can accumulate in a string before it is broken into sections. The SplitPercent value is from zero (0) to 100. Do not enter a value greater than 100. For example, if you set the SplitPercent option to 75, the string is broken into sections if the accumulated rounding error is greater than 75% of the width of the space character. This value is set to 50 by default.

NOTE: Using 50 as the SplitPercent value is a good trade-off between the appearance and the performance impact on the GenPrint program and print spool size. Setting the SplitPercent option to a smaller value gives you a more accurate printout but slows the GenPrint program, increases the size of the print spool, and increases the amount of time it takes to print.

The Resolution option determines the rounding error. Most FXRs are built using 300 dpi fonts. This causes rounding errors when the FXR is used for printing to a 240 dpi printer. If you omit the Resolution option, the system uses the default setting of 300. You need to know whether the FXR you are using was built by importing 300 dpi fonts or 240 dpi fonts. The standard FXRs are built using 300 dpi fonts. When an FXR is built using 300 dpi fonts, there are rounding errors when printing to a 240 dpi printer. Here are some examples of options to use in different situations:

  • If your font cross-reference (FXR) file was built from 300 dpi fonts and your printer resolution is 240 dpi, set the options as shown here:

< PrtType:AFP >

SplitText = Yes

SplitPercent = 50

Resolution = 240

  • If your font cross-reference file was built from 240 dpi fonts and your printer resolution is 300 dpi, set the options as shown here:

< PrtType:AFP >

SplitText = Yes

SplitPercent = 50

Resolution = 300

  • If your font cross-reference file was built from 300 dpi fonts and your printer resolution is 300 dpi, you do not need to set the SplitText option.
  • If your font cross-reference file was built from 240 dpi fonts and your printer resolution is 240 dpi, you do not need to set the SplitText option.

[ Added_Fonts ]

    • FontName

[ PrtType:AFP ]

[ RunMode ]

    • LoadFAPBitmap

[ TwoUp ]


BPD Printer INI Options

[ PrtType:BPD ]


Common to all Batch Printer Types

[ BatchingByRecip ]

[ DefaultFields ]

[ Error ]

[ Manual ]

[ Print ]

[ Print_Batches ]

[ Printer ]

[ PrinterInfo ]

[ RunMode ]

  • AliasPrintBatches
  • ChkDstLenExceeded
  • DownLoadFAP
  • SendOverlays


Common to all GUI Printer Types

[ OverflowPaperTray ]

[ PrtType:XXX ]

AdjLeftMargin

AllRecipients

Device

MultipleCopies

PrePrintedPaper

PrintViewOnly

SelectRecipients

TemplateFields


EPT Printer INI Options

[ PrtType:EPT ]


GDI Printer INI Options

USING THE GDI PRINT DRIVER

The Documaker Graphics Device Interface (GDI) print driver provides many opportunities for Windows platform users. For example, by using a GDI driver, you can now fax, since fax drivers can be installed into Windows as a GDI Windows printer driver. Also, printing using GDI lets you print to printers that do not support any of the printer languages the system supports, such as inkjet printers. To make this driver even more useful, it includes the ability to scale output, which lets you shrink the printed output to the size of the paper. The advantages of using the Graphics Device Interface (GDI) include:

  • Ability to print to any printer attached via a Windows print driver
  • Ability to print to any fax machine attached via a Windows print driver
  • Ability to print edge to edge forms to any printer attached via a Windows print driver

The disadvantages of using the Graphics Device Interface (GDI) include:

  • Print quality is often poorer
  • Inability to print a mixture of portrait and landscape forms
  • Inability to print a mixture of simplex and duplex forms

How it works

Most Windows applications print using the Windows GDI application programming interface. Essentially, the application uses commands similar to display commands to send print commands to the operating system. Windows, in turn, sends the commands to the currently installed Windows printer driver.

NOTE: Printer manufacturers provide Windows printer drivers for their printers. These come on install disks from the manufacturer, or sometimes ship with Windows itself. Other types of drivers (such as fax drivers) can be installed as Windows printer drivers.

When a Windows program talks to the operating system using GDI, printer commands are not emitted in the native language of the printer by the program. The program prints to Windows, and Windows then prints to the installed printer driver. The printer driver then produces the native printer language commands, including the bitmap font definitions. If the printer driver belongs to a PCL printer, the print driver issues PCL commands, including fonts. In contrast, our PCL printer modules produce the PCL commands and fonts. When you use Documaker's GDI driver, a Windows print driver provided for the printer produces the PCL commands and fonts, as it sees fit. Windows print drivers create bitmap fonts from the TrueType fonts used to display the text. Windows print drivers use these bitmap fonts to try to make the printed output look like what appears on the screen.

Understanding the System

In Documaker implementations, users typically decide what fonts they want to use and then install those fonts on the production printer. Documaker tries to make the screen look like the printed output, not the other way around. Information from the production printer fonts is loaded into the font cross-reference file. The system uses this information to try to represent the printer fonts on screen. The system can also convert production printer fonts into PCL bitmap fonts. The PCL fonts the system produces look like the fonts used on your production printer. GDI print quality, by definition, is based on the fonts used for display. The attributes which describe fonts in the font cross-reference file determine which screen fonts are used. The screen fonts used determine what you see on the screen and how GDI printed output will look. So, the key to improving GDI print is to improve the fonts used in the display system. Some of this can be improved by making sure the font's character widths and family name is correct. There are INI options for improving the screen font substitutions, if names cannot be matched up. For the best results, you should use exact matching screen fonts. The system comes with a set of TrueType fonts that match the printer fonts included with the system. Install and use these fonts for best results.

NOTE: If you are instead working backward from existing production fonts, as is often the case, either an approximation must take place, or you have to find screen fonts built from the printer fonts.

GDI PRINTER DRIVER INI OPTIONS

You define the necessary printer options to print using the GDI printer driver. These options specify GDI output and are located in a PrtType:xxx control group, such as PrtType:GDI. Common GDI options are shown below, with default values in bold:

[ HP LaserJet 4050 Series PS ]

    • FullSupport

[ PrtType:GDI ]


GenPrint printer options

[ Debug_Switches ]

    • Rundate

[ Fix_Batches ]

[ Print ]

    • CallbackFunc
    • MultiFileLog

[ Printer ]

[ PrinterInfo ]

[ VSAM ]

    • VSAMNA
    • VSAMRCPTB


GUI Print Options

[ Print_To_Folder ]

    • Example_Folder
    • Sample_Folder
    • Test_Folder


HTML Printer INI Options

[ PrtType:HTML ]


MDR Printer INI Options

[ PrtType:MDR ]


Metacode Printer INI Options

METACODE PRINTERS

The Metacode language is the native mode language for Xerox 4000 and 9000 series printers. This language is superior to printing using line data with Xerox Laser Printing Systems (LPS). The advantages of using Metacode over line data printing include support for portrait and landscape text on the same page, support for different fonts on the same line, precise text positioning, and text justification. In addition, Metacode lets you merge multiple forms onto a single page.

METACODE PRINTER RESOURCES

A number of resources are used in the printing process. These resources generally reside on the printer's disk drive.

Fonts

Xerox fonts are ASCII fonts. Xerox fonts are not scalable and do not rotate. There is one font file for each rotation and different files are required for different sizes. The file extension is FNT and file names are up to six characters long. AGFA Fonts licensed for use and distribution with Documaker systems, from the Agfa Division of Miles Inc. Xerox fonts for all four rotations are included.

Forms

Xerox forms are precompiled electronic files containing static text, boxes, logos, and so on, ready to be merged with variable data. Forms always have the extension FRM. Like fonts, the maximum file name is six characters. You use the FAP2FRM utility to create Xerox forms from FAP files.

Images

Xerox images are large bitmaps or raster patterns that are stored in a special file format. These images are merged onto the forms which are then merged with the variable data. The file extension is IMG and the maximum file name is six characters.

NOTE:You must install a GVG hardware card on the printer to print IMG files. You can use the LOG2IMG utility to create Xerox images from LOG files.

Logos

Logos are small bitmaps stored in a different format than IMG files. Extension is LGO and the file name is six characters long. You can only use Xerox logos inside a FRM file. You cannot invoke them directly in the data stream.

NOTE:These LGO files are quite different than LOG files used in the system's Logo Manager—even though both are called logo files. The system does not use Xerox logo files.

JSL Settings

The system does not require you to use a special JSL on your printer to print its Metacode output. The Xerox Metacode printer driver is configurable based on options to produce Metacode which match your existing JSL settings. Several of these options are based on the comparable parameter values in the settings of the printer's JSL. A JSL may contain many JDLs from which to choose, or there may be multiple JSLs compiled into multiple JDLs. A portion of a JDL may look like the following:

CBA: JDL;

T1: TABLE CONSTANT=X'121212121212121212';

T2: TABLE CONSTANT=X'13131313131313131313';

T3: TABLE CONSTANT=X'FFFF26FFFF';

C1: CRITERIA CONSTANT=(0,9,EQ,T1);

C2: CRITERIA CONSTANT=(0,10,EQ,T2);

C3: CRITERIA CONSTANT=(1,5,EQ,T3);

VOLUME HOST=IBMONL;

LINE DATA=(0,255);

IDEN PRE=A'@@@DJDE',

OFF=0,

SKIP=8;

ROFFSET TEST=C1;

RSTACK TEST=C2,DELIMITER=YES,PRINT=NONE;

RPAGE TEST=C3,SIDE=NUFRONT,WHEN=NOW;

## 8.5 x 11 job

USA1: JDE; ( JOB can be used in place of JDE )

OUTPUT PAPERSIZE=USLETTER;

## 8.5 x 14 job

META: JOB;

VOLUME CODE=NONE

## Default job

DFLT: JDE;

VOLUME CODE=EBCDIC

END;

METACODE LIMITATIONS

Xerox images

The maximum number of images and inline graphics per page is 16.

HMI support

HMI (horizontal motion index) is supported for zero (0) and 270 degree rotated text on portrait forms only. HMI combines separate text labels which are positioned on the same line and which use the same font into a single Metacode record. FAP files with justified paragraphs can benefit from this feature. Use the FAP2MET utility to implement HMI into pre-compiled MET files.

Changing the paper size on the 4235 printer

You can not easily change paper sizes in one job. Each job is controlled by a JDE. If you need to pull paper from bins of different sizes, you have to call a different JDE each time you change from one paper size to another. This is similar to STAPLE support. There is no code to invoke different JDEs for change of paper size.

Xerox forms

If a Xerox form (FRM file) contains more than 48 blocks (each block is 512 bytes), your printer may not have enough memory to print it. The CD (Character Dispatcher) memory is divided into three regions. The first region loads all fonts used on a page. The second region is used for TL/DLs which contain inline Metacode (may only be variable data if you use an FRM). The third region loads the TL/DLs from an FRM file, if one is being used for the page. If you have version 2 of the printer software, your printer supports eight TL/DL buffers of 3K each (same as 48 blocks of 512 bytes each) for inline Metacode. With version 3.5 of the printer software, the limit was increased to 16 buffers of 3K each.

NOTE: Internal testing shows that with version 3.5, TL/DLs from FRMs (the third region of CD memory) are still limited to 8 TL/DL buffers of 3K each (same as 48 blocks of 512 bytes each).

Typically, Xerox 9700 and 9790 printers still have the older release installed. If so, you may want to upgrade to version 3.5. The Xerox 4000 series printers (4050, 4850, and so on) always come with version 3.5 or higher. When you are not using FRM files in a print stream, the system does not use the CD memory reserved for FRM files.

METACODE TROUBLESHOOTING

Unexpected color output

Even though you set the SendColor option set to No, you still get color output when printing. This occurs when:

  • You specified "Print in color" for some elements of the FAP file
  • You precompiled the FAP files with the /C option on FAP2MET
  • A "SUB INK" command was issued on the printer

If ink substitution occurred because of an operator command, such as SUB INK BLUE (or RED or GREEN), the colored components of the precompiled MET file will be brought in with color attribute turned on and printed with color. This happens regardless of how you set the SendColor option. To print in black and white, either re-run the FAP2MET utility with no /C flag, or use the END command to cancel ink substitution on the printer.

Unexpected black and white output

Even though you set the SendColor option to Yes, you still get black and white output when printing. Use this checklist to make sure you have done everything to print in color:

  • Make sure you specified ,"Print in color" for the color elements in your FAP file, such as text, shaded areas, lines, and so on.
  • Make sure you precompiled the FAP files with the /C option on FAP2MET;
  • If you are using precompiled FAP files, make sure you compiled those FAPs using the FAP2CFA utility.
  • Make sure you run the GenPrint program with the SendColor option set to Yes.

Highlight color should match the PrinterInk option

The PrinterInk option causes a DJDE ILIST command which specifies the highlight color to use. If a different highlight color is installed on the printer, the printer follows the procedure specified in the ABNORMAL statement in the JDL and JDE loaded. The ABNORMAL procedure specifies whether the job should continue, abort, or stop. If no ABNORMAL procedure is declared, the default is for the printer to stop so a new ink cartridge can be loaded. Besides the ABNORMAL statement, the printer operator can override the ink setting using the SUB command (for example, SUB INK BLUE or SUB INK CURRENT).

Printing rotated variable fields

Here is a list of field options you can specify in the NAFILE.DAT file:

Option | Description
E | Error
M | Manual
P | Protected
G | Global scope (entire form set)
F | Form Scope
H | Hidden field - a dummy field, not displayed or printed
N | Nonprintable field (displayed, not printed)
C | Send-copy-to field (receives current recipient name at print time)
9 | Rotated 90 degrees
8 | Rotated 180 degrees
7 | Rotated 270 degrees

Some of these options require the FAP field attributes to be available at runtime, since the DDT file does not include the necessary information. Use the CheckImageLoaded rule to make sure this information is available.

Multipage images

When you use multipage FAP files (images) and pre-compiled MET files, you must use the EjectPage rule. This rule enables the printing of multipage images. Here are the steps to apply the rule:

  1. Open the FAP file in the Image Editor
  2. Select Format, Image Properties and then click the Load DDT button.

The Image Editor detects that the image contains multiple pages and inserts into the DDT file as many EjectPage rules as there are pages.

NOTE:You must have a variable field on each page. The variable field can be a dummy field that is hidden.

When you implement multipage FAP files and pre-compiled MET files, keep these requirements in mind:

  • Only multipage FAP files are applicable.
  • Multipage FAP files cannot be mixed with single page FAP files on the same form. The system cannot easily determine the page number in this case.
  • The multipage FAP file came from the Image Editor and therefore there is only one image per page, hence, each page on the form has an image list that contains one and only one image.
  • The index of the page on which that image resides within that form is the number of the page.
  • Multipage images can be duplexed by setting the form to either Front (long edge binding) or Short bind (short edge binding). Internally created images will be set to Rolling for the remaining pages.

Operator command, FEED, causes duplex problems

If you enter an operator command to specify an input tray--because for instance, one paper tray is empty and while you refill it you want the printing to continue using another tray--you can no longer select trays from DJDEs in the job stream. Instead, you will get messages which tell you tray selection was suspended by an operator override. All paper feed from that point forward, will be from the tray specified in the operator command. This can cause duplex jobs to print incorrectly if you have completed printing on a front page and the next page should print from a different tray. To correct this situation, enter a FEED=MAIN command. This command tells the printer to switch to tray 1 and enables tray selection through DJDE commands so the next paper selection command is obeyed.

Logo orientation

To print a portrait image which contains a logo on a landscape form using pre-compiled MET files, set the LoadFAPBitmap option to Yes. This is necessary because the logo name must change from the portrait (zero degrees) name to the landscape (270 degrees) name.

Line density errors

As the speed of the printer increases, there is less and less time available to the character dispatcher to form the scan line and send it to the image generator. Here is some information on how this affects the various Xerox printers:

  • Since the 4135 printer is the fastest of the Xerox printers using the older CD/IG, the chances of running out of time and causing a line density error are greatest with this model.
  • The Xerox 4050 and 4850 printers are too slow for this to be a problem. These printers allow more fetches from the font memory per scan line.
  • The Xerox 4635 printer's image generation modpree has been revamped to such an extent that Xerox almost guarantees there will never be a line density exceeded error on a 4635 printer.
  • The 4235 printer is slow and works quite differently than the centralized printers.
  • If a job works fine on a 9790 printer but fails on a 4135, the number of character fetches is likely on the borderline of failure.

If you experience line density problems, check your FAP files for the following:

  • Text superimposed on shaded areas.
  • Large number of text lines with small fonts.
  • Large number of horizontal lines whose thickness is measured in an odd number of dots. If you change the thickness of a horizontal line from three dots to two or four dots (0.01" to .006666" or 0.013333" --24 FAP units to 16 or 32 FAP units), it reduces the character count from two to one. The Xerox line drawing font has three horizontal line drawing characters which specify lines with thicknesses of two, four, and eight dots (.006666", .013333" and .0 26666" or 16, 32, and 64 FAP units). Odd thicknesses require the printer to overlay or overlap multiple lines.
  • Large number of small boxes, many of which have common boundaries. On paper it looks like one line. Actually, there may be two or more character fetches for the same black dots. Create these kinds of boxes by drawing lines rather than boxes.

Output data length validation

Metacode printer JSL specifies the length of data that can be received. This data length must match the value output into the Metacode print stream. You specify the data length in the JSL as shown here:

LINE DATA = (0,213)

You specify the data length in the PrtType:XER control group in the FSISYS.INI file, as shown here:

< PrtType:XER>

JDLData = 0,213

In this example, the JSL specifies a maximum data length of 213, so the INI option has a matching value. The maximum length value is also used in the Metacode print driver to make sure no more than the specified amount of data is output in any Metacode record. If the amount of data to be emitted in the record exceeds this amount, an error message such as the following appears:

Record Length 214 is too long - maximum length is 213.

NOTE: Under MVS, Metacode output files are VB datasets. The JCL specifies a maximum length of a record (LRECL). If an attempt is made to write a record longer than the LRECL value, the write will fail and an error message appears. Be advised that under MVS, with VB datasets, the LRECL size includes a 4-byte record length, known as the RDW. The RDW is implicitly added to the front of each variable length record. Therefore, you shopred set the LRECL value for the Metacode output dataset to a number equal to the JSL maximum length plus four to account for the RDW bytes at the front of the record. For the above example, set the LRECL of the Metacode output file to 217.

Using Xerox Forms (FRMs)

The system lets you use Xerox form (FRM) resources when you print to Xerox Metacode printers. FRMs are printer resident resources that contain static fprel-page images. The system can use FRMs during the print process. You can convert frequently used static fprel-page images into FRMs using the FAP2FRM utility. To indicate an image is resident on the printer as a FRM file, use the Form Set Manager. The Printer Resident field indicates the image is a pre-compiled resource resident on the printer —as opposed to a pre-compiled resource that needs to be downloaded to the printer. For more information on the Form Set Manager and the Printer Resident field, see the DocuCreate User's Guide. Here are some guidelines for using Xerox forms (FRMs):

  • Create one FAP file per page. If there is a text area, do not put variable data within the text area.
  • The image size must be one of the standard sizes, such as US Letter, Legal, A4, or Executive.
  • Because Xerox printers can only accept file names up to six characters in length, the image name can be up to six character long. If, however, the image is a mpreti-page FAP file, the name can consist of no more than four characters to accommodate the two-character number added by the FAP2FRM utility. Here are some examples:

TEST01.FRM for the first page, TEST02.FRM for the second, and so on.

  • Use the FAP2FRM utility to convert FAP files into FRM files. For multipage FAP files, create multiple FRM files. The names are appended with two-digit numeric suffixes.
  • On workstations, store the FRM files in the same directory as the FAP files. On MVS, keep them in a PDS attached to the PFRMLIB DD name. On AS400 systems, use the FRMFile option in the Data control group to specify where the FRM files are stored.
  • Use the Printer Resident field in the Form Set Manager to markindividual forms as printer resident. After you do this, the FORM.DAT file contains the V image option which indicates the image is resident on the printer. When you run the GenPrint program, a DJDE FORMS=fname command is inserted for the corresponding images. The remainder of the images are printed by inline Metacode, possibly using precompiled MET files.
  • Install the FRM files on the Xerox printer using the XERDNLD utility. Copy the respreting *.DAT files to the printer. To make sure the forms are installed on the printer, use the SAMPLE console command to print the form files.

BARRWRAP

The BARRWRAP utility converts Metacode output from JES2 format into BARR format. The BARR interface attachment for Metacode printers requires that the Metacode print stream files contain BARR specific information. The BARRWRAP utility adds this information to an existing Metacode print stream file, which lets you print the output file via the BARR interface. After you run the utility on a Metacode file, 76 1A FF 00 is added at the beginning of the file. This tells BARR the file is a Metacode file. A byte denoting the record length is also added at the beginning and end of each record in the file. Use this utility when you test the GenPrint program on MVS. If the MVS system is not directly channel-attached to the Xerox printer, you must download the print streams to an OS\2 system—use no ASCII translation, but do use CRLF. Then, using BARRWRAP, the print stream is packaged to successfprely pass through BARR/SPOOL.

NOTE: Occasionally, the binary data contained in a Metacode file has a sequence of hex bytes (x'0D0A') which copred be misinterpreted as a carriage return/line feed. This is true particprearly for charts and other inline graphics. Convert such data streams using the BARRWRAP utility on the MVS platform before you download them with the no ASCII and no CRLF binary) options.

Transferring Files from Xerox Format Floppies

Resources saved on a 5 1/4-inch floppy, using FLOPPY SAVE file.ext, are saved in a special Xerox format. For use in the system, or for transferring to a 4235 printer, you must convert these resources into DOS format. You can use the following software packages to perform this required conversion:

  • FloppyCopy by Lytrod Software -- Inexpensive, easy to use
  • Elixir -- More expensive, but includes additional features.
  • LaserLinx -- No longer marketed.

Inline graphic logo performance and print quality

Logos at 75, 100, or 150 dpi, printed using inline graphics, are scaled by the printer to their proper size and printed as 300 dpi bitmaps. Because fewer dots are used at these lower dpi settings, you may notice some loss of detail in the printed output and effects such as:

  • Arcs and circles are less precise
  • The lines used in a logo are thicker

Test logos printed as inline graphics to see if the loss of detail is acceptable. In general, horizontal and vertical lines scale with little or no loss of precision. Arcs and diagonal lines may lose some detail. To avoid scaling inline graphic logos, use the Logo Manager to scale your logos to 300 dpi. Most logos are normally 300 dpi and most logos are not printed as inline graphics. For more information about the Logo Manager, see the DocuCreate Users Guide.

[ CommonFonts ]

[ PrtType:XER ]

[ VSAM ]

    • METVSAM


MPM INI Options

[ PrtType:MPM ]


PCL Printer INI Options

Printing under Windows NT

Windows NT does not recognize printer ports such as LPT1. Change the PrtType control group in the FSIUSER.INI file to reflect the print server name and print device. Here is an example:

[ PrtType:PCL ]

Device = \\FSISRV03\\OPTRA1

Using High-Capacity Trays 3 and 4 on HP 5SI Printers

The system defines document attributes in a device-independent fashion. In prior versions, PCL support was based on options available to PCL 5 and similarly configured printers. The newer HP 5SI printer offers additional capabilities which depend upon (at least somewhat) commands that exist in PCL 6. To add to the confusion, HP is not always consistent with its own terminology. Here is how the system treated PCL in prior versions:

System term | PCL command | PCL term | HP 4 term | HP 4si term | HP 5si term
Tray 1 (Main) | ~&l1H | Tray 2 (upper) | PC Tray | Upper tray | Tray 2 (upper drawer)
Tray 2 (Aux) | ~&l4H | Tray 3 (lower) | MP | Lower tray | Tray 3 (lower drawer)
Tray 3 (Man) | ~&l2H | Manual feed | Tray 1 | Manual feed | Tray 1 (manual side feed)
Tray 4 (Env) | ~&l3H | Envelope feed | Tray 1 | Manual feed | Tray 1 (manual side feed)
n/a | ~&l5H | HCI, first tray | >LC Tray | n/a | First tray of HCI
n/a | ~l20H | HCI,second tray | n/a | n/a | Second tray of HCI

The terms for the current version are shown below, with changes highlighted:

System term | PCL command | PCL term | HP 4 term | HP 4si term | HP 5si term
Tray 1 (Main) | ~&l1H | Tray 2 (upper) | PC tray | Upper tray | Tray 2 (upper drawer)
Tray 2 (Aux) | ~&l4H | Tray 3 (lower) | MP | Lower tray | Tray 3 (lower drawer)
Tray 3 (Man) | ~&l5H | HCI, first tray | LC Tray | n/a | First tray of HCI
Tray 4 (Env) | ~l20H | HCI,second tray | n/a | n/a | Second tray of HCI

The command ~&l5H (first high-capacity tray) is supported by PCL 5, but the hardware is not typically found on HP printers. The command ~&l20H requires PCL 6. You can use these INI options:

[ PrtType:PCL ]

Tray1 = pcl command sequence (default is ~&l1H)

Tray2 = pcl command sequence (default is ~&l4H)

Tray3 = pcl command sequence (default is ~&l5H)

Tray4 = pcl command sequence (default is ~&l20H)

If you depend on the prior sequence, you can return to the original operation by specifying:

[ PrtType:PCL ]

Tray3=~&l2H

Tray4=~&l3H

NOTE:
The tilde (~) represents the escape character and is translated internally. The third character in each sequence shown is a lowercase L.

Using a staple attachment

In your PCL printer group, usually PrtType:PCL, add the StapleBin option to use a staple attachment on your PCL printer. Set the StapleBin option to the PCL printer escape sequence that selects the output bin which contains the staple attachment. Use a tilde (~) in place of the binary escape character. Here is an example:

~&l2G (tilde, ampersand, lower case l, 2, upper case G)

This example shows the escape sequence used to select an optional lower (rear) output bin that may have a staple attachment. Check with your printer manual for the escape sequence you should use. The OutputBin option should contain the printer escape sequence needed to select the normal output bin (for non-stapled forms). Using the OutputBin option is not necessary unless you notice the non-stapled forms are being sent to the wrong output bin. This INI option is only necessary when you have both stapled and non-stapled forms in the same print batch.

PCL PRINTER RESOURCES

A number of resources are used in the printing process. These resources reside in directories specified in the MasterResource control group.

Fonts

The system supports PCL bitmap fonts. These fonts reside in the directory specified in the FontLib option in the MasterResource control group when you set the DownLoadFonts option to Yes. The system includes utilities for creating PCL fonts from PostScript, TrueType, Xerox, or AFP fonts.

Overlays

Use the OVLCOMP utility to create PCL overlays from FAP files. These overlays must reside in the directory specified in the OverlayPath option in the MasterResource control group when you set the SendOverlays option to Yes.

[ PrtType:PCL ]


PDF Printer INI Options

CREATING PDFFILES

NOTE: When you use Acrobat Reader to view a PDF document, you do not have to do anything to make it download a page at a time. Acrobat Reader and the web server handle this for you. If you want the entire PDF document to continue downloading in the background while you view the first page in Acrobat Reader, choose File, General Preferences and select the Allow Background Download of Entire File option.

PDF support is a part of the Internet Document Server, which in turn is part of the DocuManage line of products. Please see the Internet Document Server Guide for more information on PDF support.

[ PrtType:PDF ]


Printing to RTF

This section describes the options normally associated with printing to a Rich Text Format file (RTF). This is a format designed by Microsoft and supported by Word as well as several other editors or viewers.

[ Added_Fonts ]

[ PrtType:RTF ]

[ WordDateFormats ]

[ WordTimeFormats ]


PST Printer INI Options

POSTSCRIPT INI OPTIONS

You must define the necessary printer related options for the GenPrint program to produce PostScript output. These options specify PostScript output and are located in a PrtType:xxx control group, such as PrtType:PST. Common PostScript printer options are shown below, with default values in bold:

Printing under Windows NT

Windows NT does not recognize printer ports such as LPT1. Change the PrtType control group in the FSIUSER.INI file to reflect the print server name and print device. Here is an example:

[ PrtType:PST ]

Device = \\FSISRV03\\OPTRA1

POSTSCRIPT PRINTER RESOURCES

A number of resources participate in the total printing process. They reside in directories specified in the MasterResource control group.

Fonts

The system supports PostScript Type 1 fonts. These fonts must reside in the directory specified in the FontLib option in the MasterResource control group when the DownLoadFonts option is set to Yes.

Overlays

Use the OVLCOMP utility to create PostScript overlays from FAP files. These overlays must reside in the directory specified in the OverlayPath option in the MasterResource control group when the SendOverlays option is set to Yes.

PostScript PrinterDefinition (PPD) Files

A PostScript Printer Definition (PPD) file is supplied with a PostScript printer. This file contains information about printer-specific features. If the PrinterModel option contains the name of a PPD file, this file must be in the directory specified in the DefLib option in the FMRES control group.

[ PrtType:PST ]


PXL Printer INI Options

PCL 6 (Unicode Support)

[ PrtType:PXL ]


VIPP Printer INI Options

What is VIPP?

Variable Data Intelligent PostScript PrintWare (VIPP) was created by Xerox in the early 1990s to enable high-performance variable data printing on PostScript devices. VIPP is based on PostScript and works by extending the PostScript programming language. VIPP can be used on any PostScript compatible printer, including Xerox and third-party network, workgroup, and production devices that have been licensed for VIPP.

Which printers support VIPP?

VIPP is supported on these devices: DocuPrint NPS (monochrome and color) DocuPrint N-series DocuSP controllers, including iGen3 DocuColor, EFI and Creo controllers, (including iGen3) The Documaker VIPP print driver requires that you have VIPP version 5.3 or later installed on your printer’s controller.

NOTE: Contact your local Xerox representative to see if your specific printer supports VIPP and to obtain VIPP licensing and installation of the latest VIPP version. In order to use the Documaker VIPP print driver, any supported device must have a local file system that you can access in order to transfer resource files. Check with your local Xerox representative for any limitations or considerations when using VIPP on your specific printer. For example, Docucolor systems may have limited or no support for stapling, duplexing, and paper tray (media) selection.

VIPP Overview

The Documaker VIPP print driver produces native mode VIPP output. Native mode refers to files composed solely of VIPP commands. VIPP commands are used to place text, lines, boxes, shades, and graphics directly on the page. Native mode is the default VIPP mode. A VIPP print job can refer to external resource files such as fonts, TIFF and JPEG graphics files, and page overlays (segments). VIPP provides a mechanism called VIPP Projects that all you to manage all of the resources needed for a VIPP print job. VIPP Projects allow you to organize the resources of a job under a single name (the project) and group the jobs by family (the folder). A folder is a collection of projects that share some common features. For example, you may decide to create one folder for each customer, each division, or each line of business. Within each folder, you could define multiple projects. A folder can contain common resources (company logo, standard boilerplate page segments, etc.) that are shared by the projects within the folder. The projects will contain resources that are unique to the project. You can also have resources that global across all projects and folders. Having multiple folders and projects provide a great deal of flexibility in how you organize and share your resources. Folders and projects can even provide the logical grouping of the physical resources used by the job at one or more steps during in the job life cycle (development, testing, production, etc.)

This is a sample structure:

Folder A – Dallas Division

Project 1

Project 2

Project 3

Folder B – Atlanta Division

Project 1

Project 2

Project 3

Folder C – Silver Springs Division

Project 1

Project 2

Project 3

VIPP Resource Files

The resource files referenced by a Documaker VIPP job are:

  • Pictures (images) in TIFF or JPEG format
  • Overlays (segments) in VIPP format
  • PostScript Fonts
  • Font encoding tables

NOTE: All VIPP resource files stored on the VIPP console that are referenced by a Documaker VIPP job must have lower case filenames.

Converting Documaker Logos into VIPP Image Files

VIPP supports bitmap files in TIFF and JPEG format. The Documaker VIPP print driver assumes that mono-color (1 bit per pixel) logos have been converted into TIFF format and Multicolor (more than 1 bit per pixel) logos have been converted into JPEG format. Scanned images are usually converted into multicolor logos even though the images may appear to be black and white. It is important to know whether a Documaker logo is mono-color or multicolor so that you will know whether to convert it to a TIFF file (mono-color) or a JPEG file (multicolor). One way to determine if a logo is mono-color or multicolor logo is to look at the first line of a Documaker logo file in a text editor. The first line of a Documaker logo file might look something like this:

3301,2551,0319,300,1,0," "," "," "," ",2

Here is what each value represents:

3301 – Number of rows of bitmap data

2551 – Number of bits per row

0319 – Not used

300 - Resolution (dpi)

1 - Number of bits per pixel

0 - Compression type

" " - 0 degree filename

" " - 90 degree filename

" " - 180 degree filename

" " - 270 degree filename

2 - Number of palettes

If the 5th field contains a “1” (or if there is no 5th field), then the bitmap is a mono-color bitmap. For multicolor bitmaps, expects to see a value of 4, 8, or 24. Documaker logos produced with earlier releases may not have all of the fields listed above.

There are a number of methods to convert your mono-color (1 bit per pixel) logos into TIFF files.

  1. The Logo Editor has a /File/Save As… menu item. On the Save As dialog, select “TIFF files (*.tif)” in the “Save as type” field
  2. Use the Conversion Wizard in Documaker Studio (select /Manage/Conversion from the main menu)
  3. Use the Docucreate application (select /File/Convert/Logos… from the main menu)
  4. Use the command line utility called LOG2TIFW.EXE. See the Docutoolbox Reference manual for details.

There are a number of methods to convert your multicolor (more than 1 bit per pixel) logos into JPEG files

  1. The Logo Editor has a /File/Save As… menu item. On the Save As dialog, select “JPG files (*.jpg)” in the “Save as type” field
  2. Use the Conversion Wizard in Documaker Studio (select /Manage/Conversion from the main menu)
  3. Use the Docucreate application (select /File/Convert/Logos… from the main menu)
  4. Use the command line utility called LOG2JPGW.EXE. See the Docutoolbox Reference manual for details.

NOTE: All VIPP resource files stored on the VIPP console that are referenced by a Documaker VIPP job must have lower case filenames. It is usually easier to make sure the resource filenames are lower case before they are transferred to the Unix workstation console attached to the VIPP printer.

Converting Documaker FAP files into VIPP Segment Files

VIPP supports pre-compiled printer overlays (called segments). A segment is a VIPP native mode or a PostScript fragment intended to be reproduced once or several times at specific locations on one or more pages. You can use the OVLCOMP command line utility to convert Documaker FAP files into VIPP segment files.

OVLCOMP /I=fapfile /X=fxrfile /L=VPPW32 /F=VPPPrint /U=VPP /C

/I=fapfile = .fap file (omit extension) ==> .fap

/X=fxrfile = .fxr file (omit extension) ==> .fxr

(produces .fnt if /I= is omitted)

/L=PRTdll = VPPW32

/F=PRTfunc = VPPPrint

/U=Printer = type of printer (default PCL)

/C use color

all switches are optional and case-insensitive

You will need a FSISYS.INI file in the directory that you run OVLCOMP (OVLCOMPW.EXE) from. Within the FSISYS.INI file, you should have a VIPP printer group defined. For example, below is a subset of the INI settings you might find in a VIPP printer group.

< PrtType:VPP >

Module = VPPW32

OverlayExt = .seg

PrintFunc = VPPPrint

SendOverlays = Yes,Enabled

You can specify the overlay (segment) extension you wish to use by having an OverlayExt = INI setting in your VIPP printer group and telling OVLCOMP the name of your VIPP printer group (/U=VPP). You should use the same OverlayExt = INI setting in your VIPP printer group when producing a VIPP print stream that uses overlays (segments). If you omit the OverlayExt INI setting, the default file extension for an overlay is .ovl.

NOTE: All VIPP resource files stored on the VIPP console that are referenced by a Documaker VIPP job must have lower case filenames. It is usually easier to make sure the resource filenames are lower case before they are transferred to the Unix workstation console attached to the VIPP printer.

VIPP Fonts

VIPP supports PostScript fonts as VIPP resources. While VIPP supports any font type (Type 1, Type 3, and composite) supported by the PostScript interpreter, Documaker only supports Type 1 PostScript fonts. The PostScript fonts you plan on using must be defined in your font cross-reference (FXR) file.

If you are using a base FXR file like REL103.FXR or REL110.FXR, then the base PostScript fonts are already setup for you in the FXR file. The same PostScript fonts used for printing with the Documaker PostScript print driver are also used with the Doucmaker VIPP print driver.

If you are using a custom FXR file and you have not setup your FXR file for printing PostScript, then you will need to add the PostScript fonts to your FXR file. You can use the Import feature in the Font Manager to import PostScript fonts into your FXR file. The primary fields used by the PostScript and VIPP print drivers are the Codepage field on the Dimensions tab, and the Font File, Font Name, and Char Set ID fields in the PostScript section of the Printers tab.


XML Printer INI options

[ PrtType:XMP ]


XPS Printer INI Options

[ PrtType:XPS ]


XXX Printer INI options

[ PrtType:XXX ]


Resource Path Setup

Configuration


Configuration

[ Config:XXX ]

[ Configurations ]

[ Control ]

  • ImageExt
  • LogoExt
  • XrfExt

[ Environment ]

  • FSISYSINI
  • FSITEMP

[ INIFiles ]

[ Language ]

[ MasterResource ]

[ Resources ]


Rules Processing Settings

Gendata or Common to RP

Gentrn


Gendata or Common to RP

Rules Processing System Options

[ Control ]

    • ErrorFileDateStamp
    • FlushLogFile
    • ImmediateTranslate
    • LimitDDTs
    • LogCaching
    • LogEnabled
    • LogFileDateStamp
    • LogINIFileNames
    • LogINIOptions
    • LogToConsole
    • LogTransactions
    • NewlineEscape
    • RuleFilePool
    • SortedSetRcp

[ Data ]

[ DDTResource ]

[ Debug_Switches ]

[ DLL ]

[ Error2Manual ]

[ ExtractKeyField ]

[ FixOffsets ]

[ FixOptions ]

    • UseXDBRule

[ Gendata ]

[ GenDataStopOn ]

[ MasterResource ]

    • DALTriggers

[ PrintFormset ]

[ RecipMap2GVM ]

[ Records ]

[ Restart ]

[ RunMode ]

    • CompiledFAP
    • FlushDALSymbols
    • LoadCordFAP
    • MasterDDTNotInLibrary
    • MergedDDTs
    • NAUnload

[ SymLookup ]

[ TransactionRecord ]

[ VSAM ]

    • DDTVSAM
    • JDTVSAM


Gentrn

Processing transaction extract file options.

[ ExtractFile ]

[ GenTranStopOn ]

[ GentrnDummyFields ]

[ RunMode ]

  • OpSystem
  • XMLExtract
  • XMLFileExtract
  • XMLFileExtractName

[ Trn_Fields ]

[ Trn_File ]


WIP Settings

Common WIP

GenWip

Workstation WIP


Common WIP

[ WipData ]

  • File
  • Key1
  • Key2
  • KeyId
  • MaxWIPRecords
  • Path
  • WIPDFDFile


GenWip

[ AFG2WIP ]

[ Trigger2Wip ]

[ TrnLib ]


Workstation WIP

[ AfeProcedures ]

    • AFEArchive2WIPRecord

[ AfeWipDisplay ]

[ AllowTransEdits ]

[ ArcRet ]

    • KeepCreateTime

[ Complete ]

    • Delete

[ CompressWIPFiles ]

[ Control ]

    • MaxPOLLineLength
    • NoKey2Changes
    • WIPListMaxRecords

[ Email ]

[ Transactions ]

[ WipData ]


INI Group Reference


Accessibility

Version 11.4 includes enhancements to Documaker Workstation which make it more accessible to all users. These changes include.

  • When selecting entries from a table, the title of the table now includes the name of the table and a field prompt, if specified. If no field prompt was specified when the form was created, the title of the table remains as in prior versions and is based on the name of the file and table.

  • You can now specify table column headings in multiple languages, such as English and French. For more information, see Specifying Column Headings on page 2.

  • The system now includes a title over the Key and Description and it also identifies the data in the rows as sets of keys and descriptions.

  • The system now includes the words Error, Warning, Alert, or Notification in message window titles to provide more information the user.

  • The system can emit a beep when you try to enter invalid data, such as when you try to type letters into a numeric only field. You use the EntryErrorBeep option in the Control group to turn this option on or off. To enhance this existing capability, you can use the new EntryErrorPopup and EntryErrorBeep options in the Accessibility

Accessibility Options

  • EntryErrorBeep
  • EntryErrorPopup


EntryErrorBeep

[Accessibility]
EntryErrorBeep

EntryErrorBeep

If the EntryErrorBeep option = Yes, a warning beeps when the user types an invalid character into the field.

[ Accessibility ]

EntryErrorBeep = Yes

Parameter

Description

Boolean (Yes)

Enter Yes if you want the system to emit a beep when the user makes an entry error. Enter No if you do not want the system to emit a beep. The default is No.

If you set this option to No and set the EntryErrorPopup option to Yes, the system displays a warning message to alert the user of an entry error.

Remarks

The system can emit a beep when you try to enter invalid data, such as when you try to type letters into a numeric only field. You use the EntryErrorBeep option in the Control group to turn this option on or off. To enhance this existing capability, you can use the new EntryErrorPopup and EntryErrorBeep options in the Accessibility

NOTE: If either of the EntryErrorBeep options in the Control and Accessibility control groups is set to Yes, the system will emit a beep and will not display a warning message.

Example

<Accessibility>

EntryErrorBeep = Yes

Available

Release | 11.4
Patch |

See Also

<Control>

EntryErrorBeep


EntryErrorPopup

[Accessibility]
EntryErrorPopup

EntryErrorPopup

[ Accessibility ]

EntryErrorPopup = Yes

Parameter

Description

Boolean (Yes)

Enter Yes if you want the system to display a warning message to alert the user of an entry error. This can be important when you have hearing-impaired entry personnel.

Keep in mind that if you want the system to display a warning message, you must also set the EntryErrorBeep options in both the Control and Accessibility control groups to No.

The default is no.

Remarks

The system now includes the words Error, Warning, Alert, or Notification in message window titles to provide more information the user.

Note: If any EntryErrorBeep option is set on, the system will beep rather than display a message window. If you want a message window ensure that both the Control and Accessibility groups EntryErrorBeep option are set to No.

Example

<Accessibility>

EntryErrorPopup = Yes

Available

Release | 11.4
Patch |

See Also

<Accessibility>

EntryErrorBeep

<Control>

EntryErrorBeep


ShowFieldToolTip

[Accessibility]
ShowFieldToolTip

ShowFieldToolTip

[ Accessibility ]

ShowFieldToolTip = Yes

Parameter | Description
Boolean (Yes) | (Optional) Enter Yes to tell the system to display the tool tip when the user hovers the mouse over a field. The default is No.

Remarks

The system now provides a mouse-over tool tip for fields with field prompt information. The field prompt information appears in the tool tip when you hover the mouse over a field. You can use the ShowFieldToolTip option to turn on or off the display of tool tips.

Example

<Accessibility>

ShowToolTip = Yes

Available

Release | 11.4
Patch |

See Also

<Accessibility>

EntryErrorBeep

<Control>

EntryErrorBeep


Added_Fonts

Remarks

Use this FSISYS.INI control group to add fonts to the AFP output file for text label records which may be added during the merge process in the bill printing utility.

Note

The Key option was designed to replace SearchMask.

Either the Key option or the SearchMask option is required.

If Key is not suitable for your extrfile, then use SearchMask.

It is recommended you use the Key option. If you choose to use the SearchMask option ensure you comment out the Key option.

Example

< Added_Fonts >

FontName = XOFATINO

FontName = XOFAUNN-

Added_Fonts Options

  • FontName


FontName

[Added_Fonts]
FontName

FontName

LBYSETUP is a user defined name for this DBHandler.

[ Added_Fonts]

FontName = Edit

Parameter | Description
value | You can optionally create the ADDED_FONTS control group.

This option may be required in order for the feature to function.

Remarks

You can optionally create the ADDED_FONTS control group. The options in this group specify additional fonts to add to the AFP output file for text label records which may be added during the merge process. Each option takes the form:

FontName = <font name>

Here is an example:

< ADDED_FONTS >

FontName = X0FATIN0

FontName = X0FAUNN8

This tells the system to include the fonts X0FATIN0 and X0FAUNN8 in the final output file, regardless of whether they are present in the input files.

Example

< ADDED_FONTS >

FontName = X0FATIN0

FontName = X0FAUNN8

Available

Release | 10.0
Patch |


AfeArchiveDisplay

Remarks

Defines which fields from the archive application index file will be displayed in the DocuMaker Workstation Retrieval list window.

Example

< AfeArchiveDisplay >

FIELD = Company,%-9.9s,Co. Name

FIELD = Lob,%-4.4s,LOB

FIELD = PolicyNum,%-10.10s,Policy No

RUNDATE = %m/%d/%y,Run Date

AfeArchiveDisplay Options

  • Field
  • RunDate


Field

[AfeArchiveDisplay]
Field

Field

[ AfeArchiveDisplay]

Field = Edit

Parameter | Description
Edit |

Remarks

Use this FSISYS.INI control group to define which fields from the archive application index file will be displayed in the Retrieval list window. The syntax for AFEArchiveDisplay options is:

FIELD = FieldName,FORMAT,Heading

There are three major components of the option definition.

The FieldName is the column name from the Archive table row (DFD data file definition).

The FORMAT specifies how the data should be interpreted and represented. Format string options are described below.

The Heading identifies the text that should appear as the column title for display. If this value is omitted, the column heading will default to the column name.

Example

< AfeArchiveDisplay >

FIELD = Company,%-9.9s,Co. Name

FIELD = Lob,%-4.4s,LOB

FIELD = PolicyNum,%-10.10s,Policy No

FIELD = ACCTNUM,%-22.22s,Test Case ID

FIELD = VERSNO,%-9.9s,Version #

FIELD = FEATDES,%-60.60s,Description

Format strings

For strings data, the format definition looks like this:

%[flag][width][.precision]s

The percent sign (%) must be first and the ‘s’ must be last. In between, you have some ability to control the display of the string data.

Flag: Optionally include a minus (-) to cause the text to be left-aligned within the width specified later. The default is that the text will display right-aligned.

Width: Define the minimum number of characters for the output value. If the column data is less than the specified width, blanks are added to the left or the right of the values — depending on whether the - flag (for left alignment) is specified — until the minimum width is reached.

Precision: Define the maximum number of characters to use from the input value. The precision count must be preceded with the decimal (period).

It is required that you define both width and precision values to allow the system to determine the required column size internal record layout. Omitting these values may cause erroneous column data to display or even program failure.

Examples:

FIELD = DESC,%-30.20s,Description

FIELD = DESC,%30.20s,Desc2

First notice the width value (30) was specified larger than the precision value (20). This causes the content display to be padded with 10 extra spaces. Next notice the first item defined the (-) flag to indicate left alignment, while the second did not.

FIELD = DESC,%-30.11s,Desc3

FIELD = DESC,%30.11s,Desc4

Similar to the previous examples, except this one truncates that data by specifying a precision value that is shorter than the actual column length.

Format dates

If the format area starts with a (capital) letter ‘D’, this indicates that the column data is in a supported date format that can be redisplayed in an alternate date format. If the column data is not using one of the specified layouts, then you can only use the string format described earlier.

  • YYYYMMDD formatted data can be displayed in an alternate method by specifying another ‘D’ followed by any combination of the flags shown in the Date format options table below. (Note that this date format does not have any time values to format.)

You may separate the date format components with any character except a comma. (The comma is used to determine where the heading portion of the declaration is specified and cannot appear in the format.) The maximum length of the generated date text should not exceed 50 characters.

Examples:

FIELD = Rundate,DD%m/%d/%Y,Date

FIELD = Rundate,DD%d-%m-%y,Date2

FIELD = Rundate,DD%m %d %Y,Date3

FIELD = Rundate,DD%Y,Date4

Remember the first ‘D’ following the comma indicates that you wish to reformat a date value. The second ‘D’ denotes that the column data is currently stored in YYYYMMDD format.

In the example results, note that the second column specifies the year format in lowercase(%y) and therefore displays a 2-digit year. Note that you can rearrange the components of the date in whatever order you choose or even omit components as done in the Date4 column.

  • “HexTime” format is an internal Documaker format that stores an eight-character hexadecimal number usually containing both date and time values. See this illustration of HexTime displayed as a string versus the date defined within.

HexTime format is indicated by following the ‘D’ with the letter ‘X’. The format options are specified in the same way as the YYYYMMDD example above, but remember that your HexTime values may actually include time components as well. The Date format options table below shows the available date and time options.

You may separate the date and time format components with any character except a comma. (The comma is used to determine where the heading portion of the declaration is specified and cannot appear in the format.) The maximum length of the generated date/time text should not exceed 50 characters.

Examples:

FIELD = CreateTime,DX%m/%d/%Y,Date

FIELD = CreateTime,DX%w=%A,Day

FIELD = CreateTime,DX%I:%M%:%S% %p,Time

Note from this example that a HexTime value may contain both the time and date and you can show whatever content you choose.

  • If your database column is stored using the standard ODBC date/time format you may specify ‘T’ as the date indicator following the ‘D’.

As with the other date types above, the format components can be found in the Date format options table below.

You may separate the date and time format components with any character except a comma. (The comma is used to determine where the heading portion of the declaration is specified and cannot appear in the format.) The maximum length of the generated date/time text should not exceed 50 characters.

Examples:

FIELD = DBTime,DT%H:%M%:%S% %m-%d-%Y,Time Stamp

Date format options table

%m | month number (01-12)
%d | day of month (01-31)
%y | year in 2 digits (e.g. 11 instead of 2011)
%Y | year in 4 digits (e.g. 2011)
%A | weekday name (in English) e.g. Monday, Tuesday…
%B | month name (in English) e.g. January, February…
%b | month name abbreviated (in English) e.g. Jan, Feb, Mar…
%j | day number of the year (001-366)
%w | weekday number (0=Sunday, 1=Monday… 6=Saturday)
%H | hour of 24 hour clock (00-23)
%I | hour of 12 hour clock (01-12)
%M | minute (00-59)
%S | second (00-59)
%p | AM/PM indicator

Available

Release | _______
Patch |


RunDate

[AfeArchiveDisplay]
RunDate

RunDate

[ AfeArchiveDisplay]

RunDate = %m/%d/%y,Run Date

Parameter | Description
Edit | Default value is: %m/%d/%y,Run Date

Remarks

The RUNDATE option defines the run date display. The syntax for this option is RUNDATE = FORMAT. FORMAT is the format string for strftime function.

Example

< AfeArchiveDisplay >

RUNDATE = %m/%d/%y,Run Date

Available

Release | _______
Patch |


AFEDSProcedures

Remarks

Use this FSISYS.INI control group for NA, POL and PKG data in non-archive mode. Each option is a DLL and function name for loading and unloading data files.

Example

< AFEDSProcedures >

Append = AFEW32->AFEAppendBuffer

Close = AFEW32->AFECloseBuffer

Create = AFEW32->AFECreateBuffer

First = AFEW32->AFEFirstBuffer

Next = AFEW32->AFENextBuffer

Open = AFEW32->AFEOpenBuffer

AFEDSProcedures Options

  • Append
  • Close
  • Create
  • First
  • Next
  • Open


Append

[AFEDSProcedures]
Append

Append

[ AFEDSProcedures]

Append = AFEW32->AFEAppendBuffer

Parameter

Description

DLL->FunctionName

The append function name

Values can be

  • AFEW32->AFEAppendBuffer

Default value is: AFEW32->AFEAppendBuffer

Remarks

This INI option calls the function that appends a buffer of data to the current file that was opened by a call to CREATE.

Example

< AFEDSProcedures >

Append = AFEW32->AFEAppendBuffer

Available

Release | _______
Patch |

Used By

AFELIB


Close

[AFEDSProcedures]
Close

Close

[ AFEDSProcedures]

Close = AFEW32->AFECloseBuffer

Parameter

Description

DLL->FunctionName

The close function name

Values can be

  • AFEW32->AFECloseBuffer

Default value is: AFEW32->AFECloseBuffer

Remarks

This option calls the function that closes the current file that was opened with the OPEN or CREATE function.

Example

< AFEDSProcedures >

Close = AFEW32->AFECloseBuffer

Available

Release | _______
Patch |

Used By

AFELIB


Create

[AFEDSProcedures]
Create

Create

[ AFEDSProcedures]

Create = AFEW32->AFECreateBuffer

Parameter

Description

DLL->FunctionName

The create function name

Values can be

  • AFEW32->AFECreateBuffer

Default value is: AFEW32->AFECreateBuffer

Remarks

This option calls the function that creates a new file or truncates an existing file for writing.

Example

< AFEDSProcedures >

Create = AFEW32->AFECreateBuffer

Available

Release | _______
Patch |

Used By

AFELIB


First

[AFEDSProcedures]
First

First

[ AFEDSProcedures]

First = AFEW32->AFEFirstBuffer

Parameter

Description

DLL->FunctionName

The first record function name

Values can be

  • AFEW32->AFEFirstBuffer

Default value is: AFEW32->AFEFirstBuffer

Remarks

This option calls the function that returns the first buffer of data from the current file that was opened by a call to OPEN.

Example

< AFEDSProcedures >

First = AFEW32->AFEFirstBuffer

Available

Release | _______
Patch |

Used By

AFELIB


Next

[AFEDSProcedures]
Next

Next

[ AFEDSProcedures]

Next = AFEW32->AFENextBuffer

Parameter

Description

DLL->FunctionName

The next record function name

Values can be

  • AFEW32->AFENextBuffer

Default value is: AFEW32->AFENextBuffer

Remarks

This option calls the function that returns the next buffer of data from the current file that was opened by a call to OPEN.

Example

< AFEDSProcedures >

Next = AFEW32->AFENextBuffer

Available

Release | _______
Patch |

Used By

AFELIB


Open

[AFEDSProcedures]
Open

Open

[ AFEDSProcedures]

Open = AFEW32->AFEOpenBuffer

Parameter

Description

DLL->FunctionName

The open function name

Values can be

  • AFEW32->AFEOpenBuffer

Default value is: AFEW32->AFEOpenBuffer

Remarks

This option calls the function that opens an existing file for reading.

Example

< AFEDSProcedures >

Open = AFEW32->AFEOpenBuffer

Available

Release | _______
Patch |

Used By

AFELIB


AfeLog

Remarks

This FSIUSER.INI control group lets you customize the transaction log to track Processing System activities within a company library. All INI values for the transaction log have default settings so you do not have to have this INI control group unless you want to modify the transaction log.

See the Documaker RP WS System Supervisor Guide for more information about the Transaction Log Options.

Transaction Log Options

These INI options may be used to enable or disable certain log entries. In the following table, the default settings are indicated by the example and do not need to be written to the INI file.

The only options to include in the INI file are to handle the required exceptions. To enable an option that is OFF by default, include the specified number followed by the Yes indicator. To disable an option that is ON by default, include the specified number followed by the No indicator. The text before each entry identifies the type of log event.

Type of Log Event | Option
ACTION_CREATE | 1 = Yes (Default = Yes)
ACTION_UPDATE | 2 = Yes (Default = No)
ACTION_DELETE | 3 = Yes (Default = Yes)
ACTION_SAVE | 4 = Yes (Default = Yes)
ACTION_COMPLETE | 5 = Yes (Default = Yes)
ACTION_RECEIVE | 6 = Yes (Default = Yes)
ACTION_SENDCC | 7 = Yes (Default = Yes)
ACTION_SENDTO | 8 = Yes (Default = Yes)
ACTION_ASSIGN | 9 = Yes (Default = Yes)
ACTION_ARCHIVE | 10 = Yes (Default = Yes)
ACTION_PRINT | 11 = Yes (Default = Yes)
ACTION_STATUS | 12 = Yes (Default = Yes)
ACTION_NOSAVE | 13 = No (Default = No)
ACTION_RETRIEVE | 14 = No (Default = No)
ACTION_ABORT | 15 = Yes (Default = Yes)

AfeLog Options

  • FILE
  • PATH


FILE

[AfeLog]
FILE

FILE

[ AfeLog]

FILE = File

Parameter | Description
Name | Log file name

Remarks

The transaction log (LOG.DAT) is located in the WIP directory by default. Use the File option if you want to change the location of the log database. You may enter the path in the FILE option or you may include the PATH statement below. If you enter a filename but no directory path in either the FILE or PATH option, the file will be located in the current working directory.

Available

Release | _______
Patch |


PATH

[AfeLog]
PATH

PATH

[ AfeLog]

PATH = Path

Parameter | Description
path | path for log file

Remarks

If a path is provided in the FILE option, this will override any path specified in the PATH option. If you enter a filename but no directory path is specified in either the FILE or PATH options, the file will most likely be located in the current working directory.

Available

Release | _______
Patch |


AfeLog_Fields

Remarks

Use this FSIUSER.INI group to make changes to transaction log fields. You cannot view the transaction log; it must be printed. The AfeLog_Fields options are default options and entries in the INI file should only be to modify the transaction log.

The Processing System lets you use all available INI built-in functions as data. INI built-in functions retrieve data dependent INI values. When a program gets an INI value, it gets the value returned by the built-in function instead of ~FUNCTION.

AfeLog_Fields Options

  • FORM DATE
  • LOGTITLE
  • PAGE
  • RANGE FROM DATE
  • RANGE TO DATE


FORM DATE

[AfeLog_Fields]
FORM DATE

FORM DATE

[ AfeLog_Fields]

FORM DATE =

Remarks

The FORM DATE option dates the printed transaction log with the current date.

Available

Release | _______
Patch |


LOGTITLE

[AfeLog_Fields]
LOGTITLE

LOGTITLE

[ AfeLog_Fields]

LOGTITLE = Edit

Parameter | Description
Title | Tile for form

Remarks

This option value defines the name to be printed at the top of the form when the transaction log file is printed.

Available

Release | _______
Patch |


PAGE

[AfeLog_Fields]
PAGE

PAGE

This option numbers the transaction log pages.

[ AfeLog_Fields]

PAGE = Edit

Parameter | Description
Edit |

Available

Release | _______
Patch |


RANGE FROM DATE

[AfeLog_Fields]
RANGE FROM DATE

RANGE FROM DATE

[ AfeLog_Fields]

RANGE FROM DATE = Edit

Parameter | Description
Value |

Remarks

This option returns the value entered in the From field of the Print Log File window. It is the start date for the time range you want to set.

Example

< AfeLog_Fields >

Range From Date =

Available

Release | _______
Patch |


RANGE TO DATE

[AfeLog_Fields]
RANGE TO DATE

RANGE TO DATE

[ AfeLog_Fields]

RANGE TO DATE =

Remarks

This option returns the value entered in the To field of the Print Log File window. It is the end date for the time range you want to set.

Example

< AfeLog_Fields >

RANGE TO DATE =

Available

Release | _______
Patch |


AfeLog_Format

Remarks

This FSIUSER.INI group defines the transaction log format. The transaction log cannot be viewed within the Processing System; it is must be printed for review. Options in this group are default options and only need to be entered in the INI file to modify the default value.

AfeLog_Format Options

  • DateFormat
  • Form


DateFormat

[AfeLog_Format]
DateFormat

DateFormat

The DateFormat option defines the date format for the transaction log.

[ AfeLog_Format]

DateFormat =

Available

Release | _______
Patch |


Form

[AfeLog_Format]
Form

Form

The Form option specifies the name of the transaction log form to be printed.

[ AfeLog_Format]

Form =

Available

Release | _______
Patch |


AfeLog_List

Remarks

This FSIUSER.INI group defines how each user action gets logged into the transaction file. The transaction log file (LOG.DAT) is located in the same subdirectory as the WIP.DBF file and keeps track of all Processing System activities performed during a specified time range.

The AfeLog_List options are default options and INI entries should only be made to modify the transaction log file.

The Processing System lets you use all available INI built-in functions as data. INI built-in functions retrieve data dependent INI values. When a program gets an INI value, it gets the value returned by the built-in function instead of ~FUNCTION.

AfeLog_List Options

  • ACTION
  • DATE
  • KEY1
  • KEY2
  • KEYID
  • TIME
  • USERID


ACTION

[AfeLog_List]
ACTION

ACTION

[ AfeLog_List]

ACTION =

Remarks

The ACTION option returns the current action, such as Create, Update, Delete, Save, Complete, etc. This value will appear in the transaction log as the action performed on a specific form set.

Example

< AfeLog_List >

Action

Available

Release | _______
Patch |


DATE

[AfeLog_List]
DATE

DATE

[ AfeLog_List]

DATE = Edit

Parameter | Description
Edit |

Remarks

The DATE option returns the current date. The DATE option format is defined in the INI value < Formats > DateFormat =. The default format is MM/DD/YY. The date will appear in the transaction log as the date an action was performed.

Example

< AfeLog_List >

DATE =

Available

Release | _______
Patch |


KEY1

[AfeLog_List]
KEY1

KEY1

[ AfeLog_List]

KEY1 =

Remarks

This KEY1 option returns the KEY1 field value from the WIP structure (company), or if found, the matching values from < Company_Table > INI control group. This value will appear in the transaction log as the company associated with the form set.

Example

< AfeLog_List >

KEY1 =

Available

Release | _______
Patch |


KEY2

[AfeLog_List]
KEY2

KEY2

[ AfeLog_List]

KEY2 =

Remarks

The KEY2 option returns the KEY2 field value from the WIP structure (line of business). This value will appear in the transaction log as the line of business (General Liability, Property, Inland Marine, etc.) associated with the form set.

Example

< AfeLog_List >

KEY2 =

Available

Release | _______
Patch |


KEYID

[AfeLog_List]
KEYID

KEYID

[ AfeLog_List]

KEYID =

Remarks

This KEYID option returns the KEYID field value from the WIP structure (Policy Number). This value will appear in the transaction log as the user defined policy number associated with the form set.

Example

< AfeLog_List >

KEYID =

Available

Release | _______
Patch |


TIME

[AfeLog_List]
TIME

TIME

[ AfeLog_List]

TIME = Edit

Parameter | Description
Edit |

Remarks

This option returns the current time. The TIME format is defined in the INI value, < Formats> TimeFormat =. The default format is HH:MM:SS in 12 hour format. The time will appear in the transaction log as the time an action was performed.

Example

[ AfeLog_List]

TIME =

Available

Release | _______
Patch |


USERID

[AfeLog_List]
USERID

USERID

This option returns the user ID of the current user.

[ AfeLog_List]

USERID =

Remarks

The UserID option returns the USERID field value from the WIP structure (USER ID). This value will appear in the transaction log as the user who performed the action.

Example

< AfeLog_List >

USERID =

Available

Release | _______
Patch |


AfeProcedures

Remarks

The AfeLog_List options are default options and INI entries should only be made to modify the transaction log file.

Note

Format for AFEProcedures entries is:

AfeProcedure = DLL->FuncName

Example

< AfeProcedures >

Archive = AFEW32->AFEWip2ArchiveRecord

AutoKeyID = TRNW32->TRNAutoKeyIDUsrFunc

BannerProc = TRNW32->TRNSetBannerFormInfo

Button1 = AFEW32->AFEPersonalEdit

Button2 = TRNW32->TRNAutoNextKey

Button3 = TSTW32->UserTest

CheckUserEntry = TRNW32->TRNCheckUserEntry

Complete = DLL->FuncName

EntryFormset = DLL->FuncName

FormDescProc = TRNW32->TRNFormDescTable

INDEXNAME = CUSW32->CUSGetArcIdxName

Init = DLL->FuncName

Parse = DLL->FuncName

PreEdit = TRNW32->TRNPreEdit

PostEdit = TRNW32->TRNPostEdit

Security = AFEW32->AFESecurityFunc

Term = DLL->FuncName

WindowProc = DLL->FuncName

AFEArchive2WIPRecord = AFEW32->AFEConvertArc2WipRecord

AFEWIP2ArchiveRecord = AFEW32->AFEConvertWip2ArcRecord

AfeProcedures Options

  • AFEArchive2WIPRecord
  • AfeCompressWIPFunc
  • AFEWIP2ArchiveRecord
  • Archive
  • AutoKeyID
  • BannerProc
  • Button1
  • Button2
  • Button3
  • CheckDupForm
  • CheckUserEntry
  • Complete
  • DupForm
  • EntryFormset
  • FormDescProc
  • INDEXNAME
  • Init
  • Parse
  • PostEdit
  • PreEdit
  • Security
  • Term
  • UniqueSeed
  • WindowProc


AFEArchive2WIPRecord

[AfeProcedures]
AFEArchive2WIPRecord

AFEArchive2WIPRecord

[ AfeProcedures]

AFEArchive2WIPRecord = Edit

Parameter | Description
DLL->FunctionName | Archive to WIP function name

Remarks

The AfeArchive2WIPRecord option specifies the DLL and the function to call to convert the data from Archive into the corresponding WIP record. The default value for the procedure when not defined in the INI files is AFEW32->AFEArchive2WipRecord.

Example

< AfeProcedures >

AFEArchive2WIPRecord = AFEW32->AFEConvertArc2WipRecord

Available

Release | _______
Patch |

Used By

AFELIB


AfeCompressWIPFunc

[AfeProcedures]
AfeCompressWIPFunc

AfeCompressWIPFunc

WIP compression provides another way to store WIP.

[ AfeProcedures]

AfeCompressWIPFunc =

Parameter | Description
value | WIP compression provides another way to store WIP.

NOTE: For Rel 11.1 Patch 25 and newer, do not specify the function in the INI file.
This function has been replaced by
[ Wipdata ]
CompressWip = Yes.

Remarks

This method uses the same storage format as the email attachment. It saves each WIP form set as a single compressed file rather than the two or more current WIP files, such as *.dat; *.pol, *.pkg.

To use WIP compression, you must add these INI options:

[ AfeProcedures ]

AfeCompressWipFunc = AFEW32->AFEPackWipFilesFunc

[ CompressWipFiles ]

Extension = CWP

Since the default extension is CWP, the extension is not required in the example above. You must add the extension if you want to use an extension other than CWP. The benefit is that only one smaller file per form set will be kept in the network WIP directory, which conserves disk space.

NOTE: If you are using compressed mode, you can work with compressed and noncompressed form sets. In standard mode, you can only work with noncompressed form sets. Your system supervisor can, however, switch modes at any time.

Changing to the WIP compressed mode does not delete existing WIP files from the WIP directory.

Example

< AfeProcedures >

AfeCompressWipFunc = AFEW32->AFEPackWipFilesFunc

Available

Release | 10.0
Patch |


AFEWIP2ArchiveRecord

[AfeProcedures]
AFEWIP2ArchiveRecord

AFEWIP2ArchiveRecord

[ AfeProcedures]

AFEWIP2ArchiveRecord =

Remarks

The AfeWIP2ArchiveRecord option specifies the DLL and the function to call to convert a WIP record to an archive record. The default value for the procedure when not defined in the INI files is AFEW32->AFEWip2ArchiveRecord.

Example

< AfeProcedures >

AFEWIP2ArchiveRecord = AFEW32->AFEConvertWip2ArcRecord

Available

Release | _______
Patch |


Archive

[AfeProcedures]
Archive

Archive

Defines the DLL and the function to call when converting a WIP record into an archive record.

[ AfeProcedures]

Archive = Edit

Parameter | Description
DLL->FunctionName | Archive function name

Remarks

The standard DLL is AFEW32 and the standard function is called AFEWip2ArchiveRecord.

Example

< AfeProcedures >

Archive = AFEW32->AFEWip2ArchiveRecord

Available

Release | _______
Patch |

Used By

AFELIB


AutoKeyID

[AfeProcedures]
AutoKeyID

AutoKeyID

The AutoKeyID option defines the DLL and the function to call for automatic policy numbering.

[ AfeProcedures]

AutoKeyID =

Parameter | Description
value | The AutoKeyID option defines the DLL and the function to call for automatic policy numbering.

Remarks

TRNAutoKeyIDUsrFunc is the base supported installable procedure which can be used to return sequential numbers generated in a table via another function. Custom versions of this function can return any value that satisfies the KEYID requirements.

In addition to the following restrictions on KeyID values, you can now make sure that data entered conforms to a specific alpha and numeric format. For instance, KeyIDs can be: limited by the use of the AutoKeyID table (only accepts KeyIDs listed in the table), limited as to whether there can be duplicates in WIP and/or Archive, converted to uppercase (if the CaseSensitiveKeys option is set to No), limited to the length defined in the database. (A standard WIP file allows 20 characters for the KeyID.)

NOTE: KeyIDs are typically used as the policy, document, or form set number.

With version 10.2, you can now use the VerifyKeyID hook to call a DAL script. Within the DAL script, the verification can be constant, or provide exceptions based on the Key1 (Company), Key2 (Line of Business), or the transaction code currently selected.

All the relevant WIP record information taken from the Form Selection window is available to the DAL script for examination. Simply use the available DAL functions like WIPKeyID, WIPKey1, or WIPFld.

NOTE: The script can retrieve WIP values, but not change them.

You must handle any error messages using the MSG function. To install the KeyID validation hook, include these INI options.

< AFEProcedures >

AutoKeyID = TRNW32->TRNVerifyKeyID

< VerifyKeyID >

Script = KeyID.DAL

OnCreate = Yes

OnUpdate = No

Now you can use multiple AutoKeyIDs. To set this up, modify your INI files as shown here:

< AFEProcedures >

AutoKeyID = TRNW32->TRNMultipleAutoKeyID [MultiAutoKeyID]

AutoKeyID = TRNW32->TRNAutoKeyIDUsrFunc

AutoKeyID = TRNW32->TRNVerifyKeyID

Example

< AfeProcedures >

AutoKeyID = TRNW32->TRNAutoKeyIDUsrFunc

AutoKeyID = TRNW32->TRNMultipleAutoKeyID [MultiAutoKeyID]

AutoKeyID = TRNW32->TRNAutoKeyIDUsrFunc

AutoKeyID = TRNW32->TRNVerifyKeyID

Available

Release | 10.1
Patch | 345

Used By

AFELIB


BannerProc

[AfeProcedures]
BannerProc

BannerProc

The BannerProc option identifies the DLL and the function to call for creating a banner page.

[ AfeProcedures]

BannerProc = Edit

Parameter | Description
DLL->FunctionName | banner function name

Remarks

In addition to filling the banner page, the standard function will search the remaining form set and fill in the field information on any PULL forms defined. A PULL form indicates that an external form should be included in the form set. When the form set is printed, a separate page is printed for each PULL form and usually indicates what form should replace that page.

Example

< AfeProcedures >

BannerProc = TRNW32->TRNSetBannerFormInfo

Available

Release | _______
Patch |

Used By

AFELIB


Button1

[AfeProcedures]
Button1

Button1

Custom button hook.

[ AfeProcedures]

Button1 =

Parameter | Description
Edit | The Button1 option identifies the DLL and function for the personal forms list field on the Forms Selection window.

Remarks

The Button1 option identifies the DLL and function for the personal forms list field on the Forms Selection window.

To activate the personal forms list feature enter the following INI value:

< AFEProcedures >

Button1 = AFEW32->AFEPersonalEdit

If Button1 is already in use, the option can be attached to Button2 or Button3.

Once activated, this button will appear on the Forms Selection window (just above the forms list). By default the button text will read, "Personal". This can be customized via the following INI option.

< DLGTitles >

Personal = ~text

The value text can be any text, however the the size of the button is fixed and will not accommodate long descriptions. Note, unlike menus, the tilde character (~) is optionally used to indicate that the next character is the accelerator for the button.

Now you can view all Key2 items on the Personal Forms List. For example, in insurance implementations, the Key2 field typically indicates the line of business. By adding the following option, the system shows you all of your forms or all lines of business:

< AFEProcedures >

Button1 = AFEW32->AFENewPersonalDlg

For example, if you have three lines of business (General Liability, Property, and Inland Marine), this option lets you select forms from a list that shows all lines of business instead of only seeing one line of business at a time.

Example

< AfeProcedures >

Button1 = AFEW32->AFEPersonalEdit

Or

< AfeProcedures >

Button1 = AFEW32->AFENewPersonalDlg

Available

Release | _______
Patch |

Used By

AFELIB


Button2

[AfeProcedures]
Button2

Button2

Custom button hook.

[ AfeProcedures]

Button2 =

Remarks

Custom button hook. This option enables the NEXT button on the Form Selection window.

If you need to make the system release a KEYID and assign to a form another KEYID from the database table

(POLNUMBR), you can do this via this Button INI option. You may need release or reassign a KEYID if either of these situations occurs:

The data entry user cannot click OK on the Form Selection window because the system displayed a "not unique" message as it tried to create the WIP.

WIP was created with a manual KEYID and now the data entry user wants to retrieve a KEYID from the automatic table.

Adding this INI file option:

[ AFEProcedures ]

BUTTON# = TRNW32->TRNAutoNextKey

turns on a button normally hidden on the Form Selection window. If you have already activated BUTTON1, substitute BUTTON2 or BUTTON3.

Once activated, when the data entry user presses NEXT, the system determines if the KEYID currently in use came from the database table. If it did not come from that table, the system returns a KEYID from the database table for the user to use.

If the current KEYID was assigned to the data entry user from the database table, the system displays a message which asks if it should remove the KEYID from the database table. If the user clicks YES, the system deletes the current KEYID and retrieves a new KEYID from the database table. If the user clicks NO, the system leaves the current KEYID in the field.

Example

< AfeProcedures >

Button2 = TRNW32->TRNAutoNextKey

Available

Release | _______
Patch |


Button3

[AfeProcedures]
Button3

Button3

Custom button hook.

[ AfeProcedures]

Button3 =

Parameter | Description
Edit | TSTW32->UserTest is a test function exported from the specified DLL that conforms to the FAPUSER prototype.

Remarks

There are three user definable buttons, Button1, Button2, Button3. There is really no difference between them as far as the program is concerned. The user would use the INI to associate the "custom" function with each button. The custom function must conform to the FAPUSER prototype. The TSTW32->UserTest function is a mechanism conforming to the FAPUSER prototype for testing the hooks, prior to production. This function may be used to test that a hook is activating properly by displaying a dialog containing some of the information passed to the function. However, please note that this function has no idea what it should do with any messages passed to it and always returns SUCCESS.

Example

< AfeProcedures >

Button3 = TSTW32->UserTest

Available

Release | _______
Patch |


CheckDupForm

[AfeProcedures]
CheckDupForm

CheckDupForm

You can now register function hooks to control the Duplicate button on the Form Selection window.

[ AfeProcedures]

CheckDupForm =

Parameter | Description
value | You can now register function hooks to control the Duplicate button on the Form Selection window.

Remarks

These new INI options:

< AFEProcedures >

DupForm = DLL->Function

CheckDupForm = DLL->Function

Provide new hooks which you can use to register functions for the Duplicate button on the Form Selection window.

The DUPFORM hook, which you cannot override, uses this prototype. This function displays messages used to indicate the success or failure of the duplication.

The CHECKDUPFORM hook returns True or False to indicate if the form can be duplicated.

The Form Selection window now calls AFECallCheckDupFormHook at the appropriate places to determine whether the button should be active. It also calls AFECallDupFormHook to do the actual duplication.

Example

< AFEProcedures >

CheckDupForm = DLL->Function

Available

Release | 10.1
Patch |


CheckUserEntry

[AfeProcedures]
CheckUserEntry

CheckUserEntry

[ AfeProcedures]

CheckUserEntry =

Parameter | Description
Edit | This option identifies the DLL and the function to call to check form set data before a new WIP entry can be created.

Remarks

This option identifies the DLL and the function to call to check form set data before a new WIP entry can be created.

Example

< AfeProcedures >

CheckUserEntry = TRNW32->TRNCheckUserEntry

Available

Release | _______
Patch |


Complete

[AfeProcedures]
Complete

Complete

This option identifies the DLL and the function to call to when the user selects the Complete option.

[ AfeProcedures]

Complete = Edit

Parameter | Description
Edit | This option identifies the DLL and the function to call to when the user selects the Complete option.

Remarks

The formset should be examined for valid entries and upon a successful field check, the Complete Formset dialog is presented that lets the user optionally print, export and archive the form set. This option lets customized features be added to the Complete action.

Example

< AfeProcedures >

Complete = DLL->FuncName

Available

Release | _______
Patch |


DupForm

[AfeProcedures]
DupForm

DupForm

You can now register function hooks to control the Duplicate button on the Form Selection window.

[ AfeProcedures]

DupForm =

Parameter | Description
value | You can now register function hooks to control the Duplicate button on the Form Selection window.

Remarks

These new INI options:

< AFEProcedures >

DupForm = DLL->Function

CheckDupForm = DLL->Function

Provide new hooks which you can use to register functions for the Duplicate button on the Form Selection window.

The DUPFORM hook, which you cannot override, uses this prototype. This function displays messages used to indicate the success or failure of the duplication.

The CHECKDUPFORM hook returns True or False to indicate if the form can be duplicated.

The Form Selection window now calls AFECallCheckDupFormHook at the appropriate places to determine whether the button should be active. It also calls AFECallDupFormHook to do the actual duplication.

Example

< AFEProcedures >

DupForm = DLL->Function

Available

Release | 10.1
Patch |


EntryFormset

[AfeProcedures]
EntryFormset

EntryFormset

Now you can call multiple EntryFormset hooks.

[ AfeProcedures]

EntryFormset =

Parameter | Description
value | Now you can call multiple EntryFormset hooks.

Remarks

Before, you could define only one hook. Now you can use an approach similar to that used for CSTW32- >CSTInitFuncs which lets you call a series of additional hook functions.

< AFEProcedures >

EntryFormset = CSTW32->CSTMultiEntryFormsetHooks

< CST_EntryFormSet_Funcs >

01 = MYDLL->MyEntryFormsetFunc

02 = YOURDLL->YourEntryFormsetFunc

All messages normally passed to the hook are passed to all hooks listed under the new INI group. If any hook function does not return success, the process ends and an error is returned to the calling process.

EntryFormset = WXMW32->WXMEntryHookExtXMLLoad (if you set AFEProcedures up as a hook, you must also set up several other ini options. See:

< XML_IMP_EXP >

DSIUseNTUserID =

DSIVARS =

DSIIgnoreTimeoutError =

DSIAttachedVarFile =

DSIImportLevel =

DSITimeout =

DSIReqType =

DSIRecordDFD =

Example

< AFEProcedures >

EntryFormset = CSTW32->CSTMultiEntryFormsetHooks

EntryFormset = WXMW32->WXMEntryHookExtXMLLoad

Available

Release | 10.1
Patch | 170


FormDescProc

[AfeProcedures]
FormDescProc

FormDescProc

Use this INI option to identify a customized Form Description Line function.

[ AfeProcedures]

FormDescProc = Edit

Parameter | Description
Edit | Use this INI option to identify a customized Form Description Line function.

Remarks

The format for this option is:

FormDescProc = module->funcname

The module equates to a DLL name (i.e. TRNW32) and the funcname is the name of the exported function within that DLL. An incorrect DLL or function name will cause an error message to display and the resulting output will return to the default method of using the information provided in the Form set definition file (form.dat, .BDF, .GRP, or .FOR).

One customized Form Description Line function is included in the base product. This function tells the system to look up each form name in a specified table and return the form name and description found in that table. When you use this table description method, the text items printed come from the matching table entries. Use the following INI setting to configure this feature:

< AFEProcedures >

FormDescProc = TRNW32->TRNFormDescTable

Additionally you must make the following entries in the FormDescTable control group:

< FormDescTable >

FILE = tablefilename

TABLE = tablename

IncludeFormName = Yes

Include KEY2Name = No

Example

< AfeProcedures >

FormDescProc = TRNW32->TRNFormDescTable

Available

Release | _______
Patch |


INDEXNAME

[AfeProcedures]
INDEXNAME

INDEXNAME

[ AfeProcedures]

INDEXNAME = Edit

Parameter | Description
Edit |

Remarks

This option identifies the DLL and the function to call to return the index file name used for archiving (or retrieving) a specific WIP record. A standard function, CUSGetArcIdxName is provided as a basis for defining custom index names. No default value is assumed for this option.

Example

< AfeProcedures >

INDEXNAME = CUSW32->CUSGetArcIdxName

Available

Release | _______
Patch |


Init

[AfeProcedures]
Init

Init

This option names the DLL and function to call any time the INI settings are loaded.

[ AfeProcedures]

Init = Edit

Parameter | Description
Edit | This option names the DLL and function to call any time the INI settings are loaded.

Remarks

Usually this occurs at program startup and when Master Resources are changed.

When printing the form set from any option other than the Complete option, the form pages include Draft in the SendCopyTo field. You should modify your FSIUSER.INI or FSISYS.INI file to include these options.

To print Draft on forms, add these options:

< AfeProcedures >

INIT = CSTW32->CSTInitImageHandler

< Control >

PrintDraft = Yes

The PrintDraft option tells the system to print Draft in the SendCopyTo field instead of the recipient name for normal WIP print. If you print from the Complete window, the system includes the normal recipient names.

Example

< AfeProcedures >

Init = DLL->FuncName

Available

Release | 10.1
Patch |


Parse

[AfeProcedures]
Parse

Parse

[ AfeProcedures]

Parse = Edit

Parameter | Description
Edit | The Parse option names the DLL and function to call to allow the command line parameters to be parsed and used in custom code or base code.

Remarks

The Parse option names the DLL and function to call to allow the command line parameters to be parsed and used in custom code or base code. Base code recognizes the command line parameters offered by the base system only. But custom code will have to check for custom parameters. The actual values can be found in AFEData->argv. With this function system values can be changed based on parameter values.

Example

< AfeProcedures >

Parse = DLL->FuncName

Available

Release | _______
Patch |


PostEdit

[AfeProcedures]
PostEdit

PostEdit

[ AfeProcedures]

PostEdit = Edit

Parameter | Description
Edit | The PostEdit option names the DLL and the function to call before a form set is saved (unloaded), assigned to another user, completed, or deleted.

Remarks

The PostEdit option names the DLL and the function to call before a form set is saved (unloaded), assigned to another user, completed, or deleted.

Example

< AfeProcedures >

PostEdit = TRNW32->TRNPostEdit

Available

Release | _______
Patch |


PreEdit

[AfeProcedures]
PreEdit

PreEdit

[ AfeProcedures]

PreEdit = Edit

Parameter | Description
Edit | The PreEdit option names the DLL and the function to call after a form set has been loaded successfully and before Entry can begin.

Remarks

The PreEdit option names the DLL and the function to call after a form set has been loaded successfully and before Entry can begin.

Example

< AfeProcedures >

PreEdit = TRNW32->TRNPreEdit

Available

Release | _______
Patch |


Security

[AfeProcedures]
Security

Security

[ AfeProcedures]

Security =

Parameter | Description
value | CSTW32->CSTUserFromNT

Remarks

If you are using Windows security and you want to use your Windows user ID to automatically log onto the system, do so by adding this function in the FSIUSER.INI file:

< AFEProcedures >

Security = CSTW32->CSTUserFromNT

Microsoft does not require you to use the security features in Windows 95/98, but does require you use the security features in Windows NT/2000. Keep in mind * Documaker Workstation user IDs cannot be more than eight characters in length.

Windows IDs can be longer than eight characters. This means that Documaker Workstation only uses the first eight characters of your Windows user ID.

* Use the UserInfo database to assign Report To chains so you are not limited to your own WIP. Otherwise, you might not be able to view the WIP of subordinates.

NOTE: If you have overridden the login hook with custom code, you may be able to provide the Report To chain via some other mechanism. If, however, you want Documaker Workstation to handle it, use the UserInfo database.

Example

< AFEProcedures >

Security = CSTW32->CSTUserFromNT

Available

Release | 10.0
Patch | 241

Used By

AFEMAIN


Term

[AfeProcedures]
Term

Term

The Term option specifies the DLL and the function to call when the Entry System is exiting.

[ AfeProcedures]

Term = Edit

Parameter | Description
Edit | The Term option specifies the DLL and the function to call when the Entry System is exiting.

Remarks

A custom function should release any resources or memory that were allocated during program execution when this function is called.

Example

< AfeProcedures >

Term = DLL->FuncName

Available

Release | _______
Patch |


UniqueSeed

[AfeProcedures]
UniqueSeed

UniqueSeed

[ AfeProcedures]

UniqueSeed = Edit

Parameter | Description
value |

Remarks

This feature lets you control who can re-seed the UNIQUE.* files. These files contain the last number for the WIP file that was created. Whenever a WIP file is created, a number is generated to uniquely identify it to make sure no WIP file is overwritten.

If these files are corrupted, the next user to work with WIP is automatically given an opportunity to re-seed these files. The new UniqueSeed function lets you specify who has rights to do this. To use this new function, add the following line to your INI files:

< AFEProcedures >

UniqueSeed = AFEW32->AFERestrictedUniqueSeed

Example

< AFEProcedures >

UniqueSeed = AFEW32->AFERestrictedUniqueSeed

Available

Release | 10.1
Patch |


WindowProc

[AfeProcedures]
WindowProc

WindowProc

[ AfeProcedures]

WindowProc = Edit

Parameter | Description
Edit | This option names the DLL and function to call to have a procedure intercept messages that arrive at the main application window procedure.

Remarks

This option names the DLL and function to call to have a procedure intercept messages that arrive at the main application window procedure.

Example

< AfeProcedures >

WindowProc = DLL->FuncName

Available

Release | _______
Patch |


AfeWip2ArchiveRecord

Remarks

The AFEWip2ArchiveRecord control group is used by the AFEWip2ArchiveRecord function to copy the data from the WIP record to the Archive Record. In other words, the option in the AFEWip2ArchiveRecord control group determines the mapping of the WIP record information to the Archive Record information, by using the following equation:

Archive Field Name = WIP Field Name

Where ARCHIVE FIELD NAME is the actual field name from archive DFD file (APPIDX.DFD) and WIP FIELD NAME is the field name from WIP file. The WIP FIELD NAME is the default column name for the WIP record if the user is not using an external DFD. For example:

Company = Key1

This means that data from WIP record field "Key1" would be copied into archive record field "Company", where Company must be defined in the archive DFD file. If the WIP field you are mapping is a HexTime format field - this would be CREATETIME or MODIFYTIME - you can optionally have the mapping translate the date value to a YYYYMMDD format. You do this by specifying ",X" after the WIP field name. For example:

RUNDATE = CREATETIME,X

This will map the RUNDATE column in the Archive application index (APPIDX) with a YYYYMMDD format date.

Specifying the 'X' parameter is the indication that you want this date translation. Without the 'X' parameter, the data is mapped to be identical to the original field value.

The default WIP field names are:

KEY1 (Key1 is generally used as Company)

KEY2 (Key2 is generally used as Line of business)

KEYID (KeyID is generally used as Policy Number for Insurance)

RECTYPE

CREATETIME

ORIGUSER

CURRUSER

MODIFYTIME

FORMSETID (FORMSETID is used to name the NA and POL files for the WIP record)

TRANCODE

STATUSCODE

FROMUSER

FROMTIME

TOUSER

TOTIME

DESC

INUSE

ARCKEY (ARCKEY is required for archives to Documanage database)

APPDATA (APPDATA is generally used as RunDate)

Example

< AfeWip2ArchiveRecord >

Company = KEY1

LOB = KEY2

PolicyNum = KEYID

RUNDATE = APPDATA

ARCKEY = ARCKEY

AfeWip2ArchiveRecord Options

  • ARCKEY


ARCKEY

[AfeWip2ArchiveRecord]
ARCKEY

ARCKEY

[ AfeWip2ArchiveRecord]

ARCKEY =

Parameter | Description
value | This determines the mapping of the WIP record information to the Archive Record information. It may or may not be included, depending upon the WIP and Archive database definitions.

Remarks

This determines the mapping of the WIP record information to the Archive Record information. It may or may not be included. This field is the archive key. It must be in both the APPIDX.DFD and CARFILE.DFD files. Required in the table under Documanage.

The name is the default column name for the WIP record if the user is not using an external DFD. On the right side of the equal sign, you would name the Archive (APPIDX) column that is to receive the corresponding WIP column of information.

Example

< AfeWip2ArchiveRecord >

ARCKEY = ARCKEY

Available

Release | _______
Patch |


AfeWipDisplay

AfeWipDisplay Options

  • AllSelect
  • Field


AllSelect

[AfeWipDisplay]
AllSelect

AllSelect

[ AfeWipDisplay]

AllSelect = No

Parameter | Description
AllSelect | Default value is: No

Remarks

Defaults to No, enabled. This is the "All" checkbox that appears in the bottom corner of some WIP dialogs that allows multiple recipients.

This INI option defines two items: If the box should be checked or not checked by default (NO = not checked, YES = checked) and if the dialog checkbox should appear at all (Enabled = show the box--this is the default if not specified. Hidden = don't show the box. Disabled = show the box, but don't allow the user to change the value.) You can use any combination of Yes/No with Hidden/Disabled/Enabled separated via comma. Ex. No,Hidden (This prevents the user from seeing the option on the dialog).

To remove the All field, change the AllSelect option from Yes to No, as shown here:

< AFEWIPDisplay >

AllSelect = No

Keep in mind that if you change the AllSelect option to No, the All field will not appear on other WIP List windows, including the following:

* WIP List - Batch Print

* WIP List - Assign

* WIP List - View Batch Queue

* WIP List - Manual Archive

* WIP List - Status

* WIP List - Change in Use

* WIP List - Send

Example

< AfeWipDisplay >

AllSelect = No,Hidden

Available

Release | _______
Patch |


Field

[AfeWipDisplay]
Field

Field

Example

< AFEWIPDisplay >

Field = KeyID,%-20.20s,KeyID;55

Field = CreateTime,DX%m/%d/%Y,Create Time;35

Field = StatusCode,%-1.2s;ST

Field = EffDate,%-10.10s,Eff Date;50

FIELD = FieldName,FORMAT,Heading;Width

There are 4 major components of the option definition.

The FieldName is the column name from the Archive table row (DFD data file definition).

The FORMAT specifies how the data should be interpreted and represented. Format string options are described below.

The Heading identifies the text that should appear as the column title for display. If this value is omitted, the column heading will default to the column name.

The Width value is an override to any calculated width that the system makes based upon your format string. In other words, if you would like to ensure the column is always a fixed size - whether larger or smaller than that calculated for your format string - you can enter that value here. The width values is specified in display units and not number of characters. The actual size of a display unit could change depending upon the resolution of the display monitor.

Format strings

For strings data, the format definition looks like this:

%[flag][width][.precision]s

The percent sign (%) must be first and the ‘s’ must be last. In between, you have some ability to control the display of the string data.

Flag: Optionally include a minus (-) to cause the text to be left-aligned within the width specified later. The default is that the text will display right-aligned.

Width: Define the minimum number of characters for the output value. If the column data is less than the specified width, blanks are added to the left or the right of the values — depending on whether the - flag (for left alignment) is specified — until the minimum width is reached.

Precision: Define the maximum number of characters to use from the input value. The precision count must be preceded with the decimal (period).

It is required that you define both width and precision values to allow the system to determine the required column size internal record layout. Omitting these values may cause erroneous column data to display or even program failure.

Examples:

FIELD = DESC,%-30.20s,Description

FIELD = DESC,%30.20s,Desc2

First notice the width value (30) was specified larger than the precision value (20). This causes the content display to be padded with 10 extra spaces. Next notice the first item defined the (-) flag to indicate left alignment, while the second did not.

FIELD = DESC,%-30.11s,Desc3

FIELD = DESC,%30.11s,Desc4

Similar to the previous examples, except this one truncates that data by specifying a precision value that is shorter than the actual column length.

Format dates

If the format area starts with a (capital) letter ‘D’, this indicates that the column data is in a supported date format that can be redisplayed in an alternate date format. If the column data is not using one of the specified layouts, then you can only use the string format described earlier.

  • YYYYMMDD formatted data can be displayed in an alternate method by specifying another ‘D’ followed by any combination of the flags shown in the Date format options table below. (Note that this date format does not have any time values to format.)

You may separate the date format components with any character except a comma. (The comma is used to determine where the heading portion of the declaration is specified and cannot appear in the format.) The maximum length of the generated date text should not exceed 50 characters.

Examples:

FIELD = Rundate,DD%m/%d/%Y,Date

FIELD = Rundate,DD%d-%m-%y,Date2

FIELD = Rundate,DD%m %d %Y,Date3

FIELD = Rundate,DD%Y,Date4

Remember the first ‘D’ following the comma indicates that you wish to reformat a date value. The second ‘D’ denotes that the column data is currently stored in YYYYMMDD format.

In the example results, note that the second column specifies the year format in lowercase(%y) and therefore displays a 2-digit year. Note that you can rearrange the components of the date in whatever order you choose or even omit components as done in the Date4 column.

  • “HexTime” format is an internal Documaker format that stores an eight-character hexadecimal number usually containing both date and time values. See this illustration of HexTime displayed as a string versus the date defined within.

HexTime format is indicated by following the ‘D’ with the letter ‘X’. The format options are specified in the same way as the YYYYMMDD example above, but remember that your HexTime values may actually include time components as well. The Date format options table below shows the available date and time options.

You may separate the date and time format components with any character except a comma. (The comma is used to determine where the heading portion of the declaration is specified and cannot appear in the format.) The maximum length of the generated date/time text should not exceed 50 characters.

Examples:

FIELD = CreateTime,DX%m/%d/%Y,Date

FIELD = CreateTime,DX%w=%A,Day

FIELD = CreateTime,DX%I:%M%:%S% %p,Time

Note from this example that a HexTime value may contain both the time and date and you can show whatever content you choose.

  • If your database column is stored using the standard ODBC date/time format you may specify ‘T’ as the date indicator following the ‘D’.

As with the other date types above, the format components can be found in the Date format options table below.

You may separate the date and time format components with any character except a comma. (The comma is used to determine where the heading portion of the declaration is specified and cannot appear in the format.) The maximum length of the generated date/time text should not exceed 50 characters.

Examples:

FIELD = DBTime,DT%H:%M%:%S% %m-%d-%Y,Time Stamp

Date format options table

%m | month number (01-12)
%d | day of month (01-31)
%y | year in 2 digits (e.g. 11 instead of 2011)
%Y | year in 4 digits (e.g. 2011)
%A | weekday name (in English) e.g. Monday, Tuesday…
%B | month name (in English) e.g. January, February…
%b | month name abbreviated (in English) e.g. Jan, Feb, Mar…
%j | day number of the year (001-366)
%w | weekday number (0=Sunday, 1=Monday… 6=Saturday)
%H | hour of 24 hour clock (00-23)
%I | hour of 12 hour clock (01-12)
%M | minute (00-59)
%S | second (00-59)
%p | AM/PM indicator

Available

Release | 10.1
Patch | 448


AFG2WIP

Remarks

The UserID is used in the WIP process. The WIP.DBF file will contain this ID in the CURRUSER field. To subsequently view transactions in WIP, your login ID, stored in the UserInfo.dbf file, must include the Wip.dbf CURRUSER field data.

Example

< AFG2WIP >

StatusCode = WIP

RecordType = NEW

UserID = SKIPPER

AFG2WIP Options

  • RecordType
  • StatusCode
  • USERID


RecordType

[AFG2WIP]
RecordType

RecordType

[ AFG2WIP]

RecordType =

Remarks

These options show the defaults used if the Trigger2WIP control group does not override the variables:

Example

< AFG2WIP >

RecordType = NEW

Available

Release | 10.0
Patch | 135


StatusCode

[AFG2WIP]
StatusCode

StatusCode

[ AFG2WIP]

StatusCode =

Remarks

These options show the defaults used if the Trigger2WIP control group does not override the variables:

Example

< AFG2WIP >

StatusCode = WIP

Available

Release | 10.1
Patch | 135


USERID

[AFG2WIP]
USERID

USERID

[ AFG2WIP]

USERID =

Remarks

If this INI group and/or option is not present in the INI file the system will default to FORMAKER. The system will also generate a warning message:

Example

< AFG2WIP >

UserID = SKIPPER

Note

DM19022

Available

Release | 10.1
Patch | 135


AFP

Remarks

AFP Options

  • DoubleOutputRes
  • OutputHalfRes
  • MultiLinesPerCommand
  • SuppressZeroData
  • TrimWhiteSpace


DoubleOutputRes

[AFP]
DoubleOutputRes

DoubleOutputRes

Parameter | Description
Boolean (No) | Yes or No Default value is: No

Remarks

This option can help reduce the amount of data emitted when printing inline graphics (LOG files). Does not change the bitmap loaded from the graphic, but would tell the printer to double its resolution when printed. This lets the system to use graphics that are half the resolution of the printer. Be aware that not all AFP printers will support this setting.

Example

< AFP >

DoubleOutputRes = Yes

Available

Release

Patch


OutputHalfRes

[AFP]
OutputHalfRes

OutputHalfRes

Parameter | Description
Boolean (No) | Yes or No Default value is: No

Remarks

This option can help reduce the amount of data emitted when printing inline graphics (LOG files). Scales the bitmap loaded from the graphic to half resolution in memory before writing the output. Be aware that not all AFP printers will support this setting.

Example

< AFP >

OutputHalfRes = Yes

Available

Release

Patch


MultiLinesPerCommand

[AFP]
MultiLinesPerCommand

MultiLinesPerCommand

Parameter | Description
Boolean (No) | Yes or No Default value is: No

Remarks

This option can help reduce the amount of data emitted when printing inline graphics (LOG files). This option will combine AFP commands into fewer records (if possible) when printing the bitmap. You cannot use this option with the SuppressZeroData option. Be aware that not all AFP printers will support this setting.

Example

< AFP >

MultiLinesPerCommand = Yes

Available

Release

Patch


SuppressZeroData

[AFP]
SuppressZeroData

SuppressZeroData

Parameter | Description
Boolean (No) | Yes or No Default value is: No

Remarks

This option can help reduce the amount of data emitted when printing inline graphics (LOG files). This option suppresses bitmap data containing a series of zeros (white space in the bitmap). Be aware that not all AFP printers will support this setting.

Example

< AFP >

SuppressZeroData = Yes

Available

Release

Patch


TrimWhiteSpace

[AFP]
TrimWhiteSpace

TrimWhiteSpace

Parameter | Description
Boolean (No) | Yes or No Default value is: No

Remarks

This option can help reduce the amount of data emitted when printing inline graphics (LOG files). This option suppresses bitmap data containing zeros (white space) at the right edge of the bitmap. Be aware that not all AFP printers will support this setting.

Example

< AFP >

TrimWhiteSpace = Yes

Available

Release

Patch


AllowTransEdits

Remarks

This feature was added because some users would like to be able to change existing Quote transactions to New Business and assign a new policy number into the KEYID field.

There are three fields that can be activated when editing existing WIP records with certain Transaction Codes. The left sides of the equations name these fields: KEYID (Policy number), TRANSACTION (TransCode), and KEY2 (LOB).

The right side of each equation lists each Transaction Code that should let the user edit that field. Notice in the KEY2 example that multiple Codes are separated by semicolons. (In reality, there is no need to include the example KEY2 line in any INI file. This definition represents the default behavior of KEY2.) The KEY2 field behavior is only changed if the "NoKey2Changes" option in the <Control> group, is set to TRUE.

When editing WIP records, the fields of any record that were created with a Transaction Code listed by that field name can be "edited" on the Form Selection dialog. With the exception of the KEY2 edit feature (<Control> NoKey2Changes = FALSE) introduced in version -.5, the default behavior of the program will be to protect the Transaction Code and KEYID fields in all other circumstances.

Example

< AllowTransEdits >

Transaction =

KEY1 =

KEY2 =

KEYID =

AllowTransEdits Options

  • KEY1
  • KEY2
  • KEYID
  • Transaction


KEY1

[AllowTransEdits]
KEY1

KEY1

[ AllowTransEdits]

KEY1 =

This option may be required in order for the feature to function.

Remarks

Normally during WIP Edit, the Key1 field cannot be edited. Use this option to identify which Transaction types should allow the field to be edited. The setting must specify the transaction code from the INI file and more than one code can be specified when separated by commas.

Example

< AllowTransEdits >

KEY1 =

Available

Release | _______
Patch |


KEY2

[AllowTransEdits]
KEY2

KEY2

Use this option to identify which Transaction types should allow the field to be edited.

[ AllowTransEdits]

KEY2 = Edit

Parameter | Description
value |

This option may be required in order for the feature to function.

Remarks

Normally during WIP Edit, the Key2 field can be edited. Use this option to identify which Transaction types should allow the field to be edited. Each type must specify the transaction code from the INI file and more than one code can be specified if separated by commas.

Note

Notice in the example that multiple Codes are sepa

Example

< AllowTransEdits >

KEY2=

Available

Release | _______
Patch |

Used By

AFELIB


KEYID

[AllowTransEdits]
KEYID

KEYID

Use the KEYID (policy number) option to specify which transaction codes will let the user edit the Policy Number field.

[ AllowTransEdits]

KEYID = Edit

Parameter | Description
value |

This option may be required in order for the feature to function.

Remarks

Normally during WIP Edit, the KeyID field cannot be edited. Use this option to identify which Transaction types should allow the field to be edited. Each type must specify the transaction code from the INI file and more than one code can be specified if separated by commas.

Example

< AllowTransEdits >

KEYID=

Available

Release | _______
Patch |


Transaction

[AllowTransEdits]
Transaction

Transaction

Use this option to specify which transaction codes will let the user edit the Transaction field of the Form Selection window.

[ AllowTransEdits]

Transaction =

This option may be required in order for the feature to function.

Remarks

Normally during WIP Edit, the Transaction field cannot be edited. Use this option to identify which Transaction types should allow the field to be edited. The setting must specify the transaction code from the INI file and more than one code can be specified when separated by commas.

Example

< AllowTransEdits >

Transaction =

Available

Release | _______
Patch |

Used By

AFELIB


Archival

Remarks

Use the Archival FSISYS.INI control group to define the Processing System archive mode. The Processing System offers two archive options: Automatic and Manual. Automatic archive sends policies to Archive immediately after printing. Manual archive requires that the user archive policies through a menu selection. You cannot edit a policy after it is archived. The Archive check box on the Complete window is always disabled; it exists only to remind users which archive mode they are using.

Example

< Archival >

ArchiveMem = No

; MODE = MANUAL

MODE = AUTO

Archival Options

  • ArchiveMem
  • CaseSensitiveKeys
  • MODE
  • UseRestartTable


ArchiveMem

[Archival]
ArchiveMem

ArchiveMem

1286 New Interfaces for DMILIB

[ Archival]

ArchiveMem = No

Parameter | Description
Boolean (No) | Yes or No (default) Default value is: No

Remarks

Set this option value to "Yes" to archive to a database (such as DB2) as an alternative to archiving to flat files. If this option is set to Yes, the system will look for DBTable:xxx groups. The default for this option is "No."

Note: Database archive files cannot be moved to optical drives and should not be used for permanent legal copies.

Example

< Archival >

ArchiveMem = No

Available

Release | 10.0
Patch |


CaseSensitiveKeys

[Archival]
CaseSensitiveKeys

CaseSensitiveKeys

[ Archival]

CaseSensitiveKeys = No

Parameter | Description
boolean (No) | Default value is: No

Remarks

If you desire case sensitive keys, the system now provides an option that preserves the case entered for the values: Key1, Key2, and KeyID.

By default, the system converts the values entered for Key1, Key2, and KeyID parameters to uppercase when it archives a record. It does this to reduce the amount of time it takes to find a record during a search. You can, however, use the CaseSensitiveKeys option to preserve the entered case of the Key1, Key2, and KeyID values.

For example, this option

< Archival >

CaseSensitiveKeys = Yes

Tells the system to preserve the entered case for the Key1, Key2, and KeyID parameters. If you enter No or omit the CaseSensitiveKeys option, the system converts the values for these options to uppercase before it archives the record.

Note: In Documaker Workstation, the option, CaseSensitiveKeys = Yes, must be placed in the Control group if you desire to preserve the entered case for Key1, Key2, and KeyID.

Example

< Archival >

CaseSensitiveKeys = Yes

Available

Release | 10.2
Patch | 2

Used By

GENARC, RULLIB


MODE

[Archival]
MODE

MODE

Use the Archival FSISYS.INI control group to define the Processing System archive mode.

[ Archival]

MODE = Edit

Parameter | Description
Edit |

Remarks

The archive mode can be either automatic or manual:

AUTO = Policy archived immediately after printing. Policies sent to Batch Print Queue are archived after printing.

MANUAL = User manually archives policy through the menu selection WIP, Manual Archive.

Example

< Archival >

Mode = Auto

Available

Release | _______
Patch |


UseRestartTable

[Archival]
UseRestartTable

UseRestartTable

This option works with ArchiveMem option.

[ Archival]

UseRestartTable = Yes

Parameter | Description
Boolean (Yes) | Yes (default ) or No Default value is: Yes

Remarks

It will have effect only if ArchiveMem is set to Yes. Set this option value to "No" to archive to DocuManage since there is no support for rollback.

Example

< Archival >

UseRestartTable = No

Available

Release | _______
Patch |


ArcRet

Remarks

This group defines filenames and locations of files for archive and retrieval, sets archive and retrieval parameters, configures retrieval window options.

The values for table names in this group cannot exceed - characters. To specify a table name with a length greater than - characters use the appropriate FileConvert group (e.g. < DB2_FileConvert > , <ODBC_FileConvert>, etc.) to map the - character name here with a longer (up to 1- characters) name.

Note

The values for table names in this group cannot exceed - characters. To specify a table name with a length greater than - characters use the appropriate FileConvert group (e.g. < DB2_FileConvert > , <ODBC_FileConvert>, etc.) to map the - character name here with a longer (up to 1- characters) name.

Example

< ARCRET >

Arrangement = Stack

AppIdxDfd = DefLib\AppIdx.Dfd

AppIdx = ARC\APPIDX

ARCPath = <CONFIG:SAMPCO> ARCPath =

CARFILE = ARCHIVE

CARPath = <CONFIG:SAMPCO> CARPath =

CATALOG = ARC\CATALOG

DisplayOnlyEntry = No

DisplayPrintOnly = No

ExactMatch = No

KeepFiles = No

KEY1 = KEY1

KEY2 = KEY2

KEYID = KEYID

LBLIMIT = 500

TEMPIDX = ARC\TEMP

ShowKays = No

TransferKey1 = Yes

TransferKey2 = Yes

TransferKeyID = Yes

ArcRet Options

  • ActiveFieldHighlight
  • AppIdx
  • AppIdxDfd
  • ARCPath
  • Arrangement
  • AutoAcceptSingleMatch
  • CARFile
  • CARFileDFD
  • CARMaxFileSize
  • CARPath
  • CATALOG
  • CatalogDfd
  • ClearPosSetFlag
  • CommitEvery
  • DefaultRecipView
  • DisplayAllEntryFormPages
  • DisplayOnlyEntry
  • DisplayPrintOnly
  • ExactMatch
  • HideKey1
  • HideKey2
  • HideKeyID
  • KeepCreateTime
  • KeepFiles
  • LBLIMIT
  • MergeLog
  • PlugInFunc
  • PlugInMod
  • PrintReprinted
  • RestartDFD
  • RestartTable
  • SkipHiddenFields
  • TabNextPage
  • TEMPIDX
  • TransferKey1
  • TransferKey2
  • TransferKeyID


ActiveFieldHighlight

[ArcRet]
ActiveFieldHighlight

ActiveFieldHighlight

[ ArcRet]

ActiveFieldHighlight = Yes

Parameter | Description
boolean (Yes) | Default value is: Yes

Remarks

The default is Yes. To make Archive Retrieval act differently than other modes (WIP), set the following option:

< ArcRet >

ActiveFieldHighlight = No

Example

< ArcRet >

ActiveFieldHighlight = No

Available

Release | 10.1
Patch |


AppIdx

[ArcRet]
AppIdx

AppIdx

Name of the table that will contain the application index information.

[ ArcRet]

AppIdx = File

Parameter | Description
appidx_table_name | The index table file name

This option may be required in order for the feature to function.

Remarks

You must specify the full path for this option.

The APPIDX option defines the directory path and the file name of the Application Index File. You can use multiple Application Index Files to increase system performance. Add APPIDX entries to the ArcRet control group. Each entry specifies a distinct Application Index file.

To add another APPIDX to the ArcRet group, you must enter the second application index file first. For example, to add APPIDX2 to the group, you would enter the following:

< ArcRet >

APPIDX = ..\MSTRRES\SAMPCO\ARC\APPIDX2

APPIDX = ..\MSTRRES\SAMPCO\ARC\APPIDX

The system will use the first APPIDX record in the INI file, so if APPIDX2 is to be the new application index file, it must be listed first. Furthermore, the first APPIDX.DBF file will probably be moved to another disk drive (such as H: in the OTHERIDX directory).

Note

DM18032

Example

< ArcRet >

AppIdx = ..\ARC\APPIDX

Available

Release | 10.0
Patch |

Used By

AFEMAIN, ARCSPLIT, GENARC


AppIdxDfd

[ArcRet]
AppIdxDfd

AppIdxDfd

Name of the application index dfd file.

[ ArcRet]

AppIdxDfd = File

Parameter | Description
appidxdfd_filename | The index dfd file name

Remarks

AppIdxDfd specifies the directory and filename of the application index data format definition (DFD) file.

The application index dfd file is usually in the DEFLIB directory.

If you define this option the system will use this path and file name.

If you include the file name and omit the path, the path will default to deflib directory to find the named file.

If the path and file is not defined, the default will be to find the Appidx.dfd file where the Appidx option path is set.

Example

< ArcRet >

AppIdxDfd = ..\Deflib\APPIDX.DFD

Available

Release | 10.0
Patch |

Used By

AFEMAIN, GENARC


ARCPath

[ArcRet]
ARCPath

ARCPath

ARCPath defines the directory path of the archive index file.

[ ArcRet]

ARCPath = Path

Parameter | Description
value | ARCPath defines the directory path of the archive index file.

Example

< ARCRET >

ARCPath = <Config:SAMPCO> ARCPath =

Available

Release | _______
Patch |


Arrangement

[ArcRet]
Arrangement

Arrangement

Arrangement controls the default display of policies retrieved from Archive.

[ ArcRet]

Arrangement = Stack

Parameter

Description

Arrangment

This defines how the windows will be arranged for archive retrieval

Values can be

  • Stack
  • Stack Only
  • Tile
  • Cascade

Default value is: Stack

Remarks

Policy retrieval is more efficient in stack mode and forms are displayed one at a time. If the value of Arrangement = StackOnly, the display options (stack, cascade, and tile), are disabled in the retrieval window.

Example

<ArcRet>

Arrangement = Stack

Available

Release | _______
Patch |


AutoAcceptSingleMatch

[ArcRet]
AutoAcceptSingleMatch

AutoAcceptSingleMatch

The ArcRet group contains information about the files (or table names) used for archive.

[ ArcRet]

AutoAcceptSingleMatch =

Parameter | Description
value | value

Remarks

The values for table names in this group cannot exceed 8 characters. To specify a table name with a length greater

than 8 characters use the appropriate FileConvert group (e.g. < DB2_FileConvert > , <ODBC_FileConvert>, etc.) to

map the 8 character name here with a longer (up to 18 characters) name.

Example

< ArcRet >

AutoAcceptSingleMatch =

Available

Release | _______
Patch |


CARFile

[ArcRet]
CARFile

CARFile

Name of the table that will contain the archive data.

[ ArcRet]

CARFile = File

Parameter | Description
archive_table_name | The archive file name

Remarks

CARFILE indicates the file name of the current compressed archive file.

For a flat file archive, this option is not required. The system will default to:

CARFile = ~HEXTIME

If you use databases other than flat files to store your archives, you are required to include this option in your INI file. The value will be the table name where you store your archives.

Note: Do not put file extension

Note

DM18007

Example

< ArcRet >

CARFile = ARCHIVE

Available

Release | 10.0
Patch |

Used By

AFEMAIN, GENARC


CARFileDFD

[ArcRet]
CARFileDFD

CARFileDFD

This option specifies the name of the CAR file DFD (Data Format Definition) file.

[ ArcRet]

CARFileDFD = File

Parameter | Description
value | The CARFileDFD option supports full path such as .\deflib\odbc\carfile.dfd. If you omit the path, the system defaults to the path defined in the DefLib option in the MasterResource control group.

Remarks

The CARFileDFD option supports full path such as .\deflib\odbc\carfile.dfd. If you omit the path, the system defaults to the path defined in the DefLib option in the MasterResource control group.

This file defines the layout of the CAR file provided that it is written in DB format; however, if a CAR file DFD is not specified, there is a default CAR file format that consists of the following:

- header information

- index information

- compressed NA information

- header information

- compressed POL information.

NOTE: For non XBASE implementations this is a required entry. I.E. you must have this option for DB archives.

Example

< ArcRet >

CARFileDFD = carfile.dfd

Available

Release | _______
Patch |


CARMaxFileSize

[ArcRet]
CARMaxFileSize

CARMaxFileSize

[ ArcRet]

CARMaxFileSize =

Parameter | Description
number | maximum byte size of CAR file

Remarks

CARMaxFileSize is the maximum byte size of the compressed archive (CAR) file. If an existing CAR file reaches the specified value, the system automatically creates a new compressed archive file .If no value is specified in this option, the system defaults to a CarMaxFileSize of 1.4 mb.

Example

<ArcRet>

CARMaxFileSize = 1000000

Note: Do not use commas in the number.

List 1 million as 1000000 not 1,000,000

Available

Release | _______
Patch |

Used By

GENARC


CARPath

[ArcRet]
CARPath

CARPath

The path name for the archive file (CARFile()).

[ ArcRet]

CARPath = Path

Parameter | Description
path_name | The archive file path.

This option may be required in order for the feature to function.

Remarks

This is a required entry regardless of the database repository for your archives.

CARPath defines the directory path of the compressed archive files. If this option is not present in your INI file or on your system menu unless you have the applicable system equipment it will cause an Error in GenArcInit() (DM18011).

Note

DM18011

Example

< ArcRet >

CarPath = ..\ARC\

Available

Release | _______
Patch |

Used By

AFEMAIN, GENARC


CATALOG

[ArcRet]
CATALOG

CATALOG

The name of the table that will contain the CATALOG information.

[ ArcRet]

CATALOG = File

Parameter | Description
catalog_table_name | The catalog table name.

This option may be required in order for the feature to function.

Remarks

You must specify the full path for this option. CATALOG is the file name, including the path, of the "Catalog" archive database.

Example

< ArcRet >

CATALOG = ..\ARC\CATALOG

Available

Release | 10.0
Patch |

Used By

AFEMAIN, GENARC


CatalogDfd

[ArcRet]
CatalogDfd

CatalogDfd

[ ArcRet]

CatalogDfd =

Parameter | Description
value | The catalog file can have a DFD (Data Format Definition) file to define the layout of the Catalog file; however, if one is not specified, there is a default Catalog file format.

Remarks

The catalog file can have a DFD (Data Format Definition) file to define the layout of the Catalog file; however, if one is not specified there is a default Catalog file format.

Most archive systems use the default catalog file format.

Example

< ARCRET >

CatalogDfd = file name

Available

Release | _______
Patch |


ClearPosSetFlag

[ArcRet]
ClearPosSetFlag

ClearPosSetFlag

Option for very old archive users where formset image origins of 0,0 should be considered unspecified.

[ ArcRet]

ClearPosSetFlag =

Remarks

There was a period of time after the invention of the "Same Page" flag and prior to release version 9.0, where Genprint would append Same Page images that specified a Y origin of 0 to the bottom of the prior image -- effectively ignoring 0 as a valid Y origin. This was (and is) a similar behavior to that still used in AFEMAIN / Documaker Workstation when creating new formsets, because the Form set definition file (form.dat, .BDF, .GRP, or .FOR) does not have "Set Origin" type information.

For these users that generated archives in Batch, it is necessary to offer a means to display the retrieved formsets in the manner they were printed. This INI option will cause AFEMAIN / Documaker Workstation to ignore the "PosSet" flag, which normally indicates that the image had a specific position declared in the NA file.

Users that fall into this category must also realize that they cannot use 0 as a Y origin in Batch and therefore should specify an origin or 1 or greater for Same Page images.

Example

< ARCRET >

ClearPostSetFlag =

Available

Release | _______
Patch |


CommitEvery

[ArcRet]
CommitEvery

CommitEvery

Number of transaction to wait to commit updates.

[ ArcRet]

CommitEvery =

Parameter | Description
n | Number of transactions to wait to commit updates to tables.

Remarks

Tells GENARC to commit updates to all GENARC-related tables every n transactions.

There is no need to set the UseRestartTable option (in the Archival control group) to Yes since it is the default.

Optionally, you can set how many numbers of transactions to wait to commit updates to tables instead of 10 that is the default value.

Example

< ArcRet >

CommitEvery = 25

Available

Release | 10.0
Patch |


DefaultRecipView

[ArcRet]
DefaultRecipView

DefaultRecipView

Name(s) of the default recipient(s) to view in archive retrieval.

[ ArcRet]

DefaultRecipView =

Parameter | Description
recipient_list | Name(s) of Recip(s).

Remarks

The default view can have one or more recipients. Seperate the recipients with commas.

Example

< ArcRet >

DefaultRecipView = INSURED,AGENT

Available

Release | _______
Patch |


DisplayAllEntryFormPages

[ArcRet]
DisplayAllEntryFormPages

DisplayAllEntryFormPages

Lets you display all pages of a form set marked as Entry or Entry and Print during Entry or Retrieval.

[ ArcRet]

DisplayAllEntryFormPages = No

Parameter | Description
Boolean (No) | Lets you display all pages of a form set marked as Entry or Entry and Print during Entry or Retrieval. Default value is: No

Remarks

By default, the system only displays forms which require data entry. The DisplayPrintOnly option tells the system not to display forms which do not require data entry.

If, however, you set the DisplayPrintOnly option to Yes, the system will display all pages with viewable information, or print-only forms.

Furthermore, you can set the DisplayAllEntryFormPages option to Yes to tell the system to display all forms designated as Entry or Entry and Print in the Form set definition file (form.dat, .BDF, .GRP, or .FOR):

< Control > or < ArcRet >

DisplayAllEntryFormPages = No

The default is No. Assigning these options under the Control group affects Entry mode. Assigning the options under the ArcRet control group affects Archive/Retrieval mode.

NOTE: If the DisplayPrintOnly option is set to Yes but is not in the appropriate group, the system ignores this option.

If you set the DisplayPrintOnly option to No and the DisplayAllEntryFormPages to Yes, the system only displays forms designated for entry. The system will, however, load all of the form pages regardless of whether a page contains entry fields. Keep in mind the system starts with the first form that contains an entry field. It does not necessarily begin with the first page of a form or the first form in the form set. To override this behavior and cause the first page of a form to be the initial page, even when it does not contain entry fields, set the following option to No.

< Control >

ActivateFirstField = No

This option defaults to Yes which tells the system to display the first form with an active entry field. If you set the ActivateFirstField option to No, the system displays the first viewable page of a form set. Keep in mind that viewable pages are determined by the DisplayPrintOnly or the DisplayAllEntryFormPages option.

Example

< ArcRet >

DisplayAllEntryFormPages = Yes

Available

Release | 10.1
Patch |


DisplayOnlyEntry

[ArcRet]
DisplayOnlyEntry

DisplayOnlyEntry

This option controls the Display Only Forms with Variable Data checkbox in the Retrieval Options window.

[ ArcRet]

DisplayOnlyEntry =

Parameter | Description
value | value

Remarks

The default value for this option is "No" (the box is not checked, and all forms are displayed). To select the checkbox by default and display only forms with variable data fields, set this value to "Yes".

Example

< ARCRET >

DisplayOnlyEntry =

Available

Release | _______
Patch |


DisplayPrintOnly

[ArcRet]
DisplayPrintOnly

DisplayPrintOnly

This option controls the Display Print Only Forms checkbox in the Retrieval Options window.

[ ArcRet]

DisplayPrintOnly = No

Parameter | Description
Boolean (No) | This option controls the Display Print Only Forms checkbox in the Retrieval Options window. Default value is: No

Remarks

The default value for this option is "No" (the box is not checked and all forms are displayed). To select the checkbox by default and display print only forms, set this value to "Yes."

By default, the system only displays forms which require data entry. The DisplayPrintOnly option tells the system not to display forms which do not require data entry:

< Control > or < ArcRet >

DisplayPrintOnly = No

If, however, you set the DisplayPrintOnly option to Yes, the system will display all pages with viewable information, or print-only forms.

Example

< ArcRet >

DisplayPrintOnly = No

Available

Release | _______
Patch |


ExactMatch

[ArcRet]
ExactMatch

ExactMatch

[ ArcRet]

ExactMatch = Yes

Parameter | Description
Boolean (Yes) | Yes (Default to Yes) or No Default value is: Yes

Remarks

Use exact match option to determine whether you need to specify the full or partial key values to retrieve an archived transactions.

You must specify the entire exact key when trying to retrieve an archived transaction if the ExactMatch option is set to yes.

The ExactMatch option controls policy retrieval when using keyfield searches in the Retrieval window. If ExactMatch = No, the system retrieves all policies beginning with the keyfield string entered.

If ExactMatch = Yes, the system only retrieves policies matching the exact keyfield string entered.

An exact match will return the transaction, A partial match will return a list of eligible transactions.

NOTE - Troubleshooting: You may receive an error message No transactions with this key when you attempt to retrieve an archived transaction from Documaker WS for RP.

This results when your appidx.dfd file field EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

You should change this field's value to be EXT_TYPE = CHAR_ARRAY

Example

<ArcRet>

ExactMatch = No

Available

Release | _______
Patch |

Used By

AFEMAIN


HideKey1

[ArcRet]
HideKey1

HideKey1

[ ArcRet]

HideKey1 = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

If you turn on this option, the Key1 field and prompt will not display on the Retrieve Document window in Documaker Workstation.

Example

< ARCRET >

HideKey1 = Yes

Available

Release | _______
Patch |


HideKey2

[ArcRet]
HideKey2

HideKey2

[ ArcRet]

HideKey2 = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

If you turn on this option, the Key2 field and prompt will not display on the Retrieve Document window in Documaker Workstation.

Example

<ArcRet>

HideKey2 = No

Available

Release | 10.2
Patch | 2

Used By

AFEMAIN


HideKeyID

[ArcRet]
HideKeyID

HideKeyID

[ ArcRet]

HideKeyID = No

Parameter | Description
boolean | Default value is: No

Remarks

If you turn on this option, the KeyID field and prompt will not display on the Retrieve Document window in Documaker Workstation.

Example

<ArcRet>

HideKeyID = Yes

Available

Release | 10.2
Patch | 2

Used By

AFEMAIN


KeepCreateTime

[ArcRet]
KeepCreateTime

KeepCreateTime

[ ArcRet]

KeepCreateTime = No

Parameter | Description
boolean (No) | You can use the new KeepCreateTime option to tell the system you want to preserve the CreateTime field value when it creates a new form set based on a document retrieved from archive. Default value is: No

Remarks

You can use the new KeepCreateTime option to tell the system you want to preserve the CreateTime field value when it creates a new form set based on a document retrieved from archive.

Typically, when you create a new WIP Entry it has a create time that reflects when the form set was actually created. If, however, the form set was created from an archived document and you want to preserve the

CreateTime from the archived document, add this option.

The default is No which tells the system to give the new form set a new create time. Enter Yes to tell the system to instead use the entry in the CreateTime field from the archive record.

Example

< ArcRet >

KeepCreateTime = Yes

Available

Release | 10.2
Patch |


KeepFiles

[ArcRet]
KeepFiles

KeepFiles

The KeepFiles option set to yes keeps the nafiles and polfiles after decompressing from CARfiles during archive retrieval.

[ ArcRet]

KeepFiles = No

Parameter | Description
Boolean (No) | Yes, No Default value is: No

Remarks

The KeepFiles option determines whether Retrieval keeps files after decompressing them from the CAR (compressed archive) file. Set this option to "Yes" to keep the files.

Example

< ArcRet >

KeepFiles = No (No is the default)

Available

Release | _______
Patch |

Used By

AFEMAIN


LBLIMIT

[ArcRet]
LBLIMIT

LBLIMIT

LBLIMIT specifies the maximum number of accessible items in a retrieval list.

[ ArcRet]

LBLIMIT = Spin

Parameter | Description
LBLIMIT | LBLIMIT specifies the maximum number of accessible items in a retrieval list.

Example

< ARCRET >

LBLIMIT = 500

Available

Release | _______
Patch |


MergeLog

[ArcRet]
MergeLog

MergeLog

The name of the log file. The default is Arcmerg.LOG. The utility creates this file in the Data directory.

[ ArcRet]

MergeLog = ARCMERG.LOG

Parameter | Description
value | Use this utility to combine two archives that have the same DFD files for the archive index, catalog, and CAR file. Default value is: ARCMERG.LOG

Remarks

ARCMERGE Use this utility to combine two archives that have the same DFD files for the archive index, catalog, and CAR file.

This utility can take a secondary archive and merge it into the main archive.

Run this utility from your master archive environment. The ArcMerge utility uses the FSIUSER.INI and FSISYS.INI files, along with your resources. You can include these additional INI options in the FSIUSER.INI file to specify the names of the split archive files/tables.

Example

< ArcRet >

MergeLog =

Available

Release | 10.1
Patch |


PlugInFunc

[ArcRet]
PlugInFunc

PlugInFunc

The PlugInFunc option defines the function name of a plug-in compatible function.

[ ArcRet]

PlugInFunc =

Parameter | Description
value | The PlugInFunc option defines the function name of a plug-in compatible function.

Remarks

You can define up to five plug-in functions which will be executed in the order they are defined in the INI file. If no functions are defined, the utility displays this message:

Warning: No plug-ins loaded.

NOTE: The ARCRET utility will continue to run even if no plug-in functions are defined. Plug-in functions must conform to a specific prototype and will be passed specific information about the files to process. You can also use the DLL->FunctionName method for naming plug-ins. This lets you keep plug-ins in multiple DLL files. Here is an example:

PlugInFunc = DLL->FunctionName

If the option does not contain the "->" to indicate a DLL name is specified, the system assumes it should use the PlugInMod option to locate the DLL for this function.

Example

< ArcRet >

PlugInFunc = Function

PlugInFunc = Function2

PlugInFunc = Function3

PlugInFunc = Function4

PlugInFunc = Function5

Available

Release | _______
Patch |


PlugInMod

[ArcRet]
PlugInMod

PlugInMod

The PlugInMod option defines the DLL file that contains the functions you want to use.

[ ArcRet]

PlugInMod = File

Parameter | Description
value | The PlugInMod option defines the DLL file that contains the functions you want to use.

Example

< ArcRet >

PlugInMod = NAME.DLL

Available

Release | _______
Patch |


PrintReprinted

[ArcRet]
PrintReprinted

PrintReprinted

[ ArcRet]

PrintReprinted = No

Parameter | Description
Boolean (No) | The PrintReprinted option tells the system to include the word Reprinted in the SendCopyTo field when printing from an archived form set. Default value is: No

Remarks

To print Reprinted on forms, add these options:

< AfeProcedures >

INIT = CSTW32->CSTInitImageHandler

< ArcRet >

PrintReprinted = Yes

The PrintReprinted option tells the system to include the word Reprinted in the SendCopyTo field when printing from an archived form set.

Example

< ArcRet >

PrintReprinted = Yes

Available

Release | 10.1
Patch |


RestartDFD

[ArcRet]
RestartDFD

RestartDFD

The RestartDFD option supports full path such as .\deflib\odbc\restart.dfd. If you omit the path, the system defaults.

[ ArcRet]

RestartDFD =

Parameter | Description
value | The RestartDFD option supports full path such as .\deflib\odbc\restart.dfd. If you omit the path, the system defaults to the path defined in the DefLib option in the MasterResource control group.

Example

< ArcRet >

RestartDFD = restart.dfd

Available

Release | _______
Patch |


RestartTable

[ArcRet]
RestartTable

RestartTable

Name of the table that will contain the RESTART information.

[ ArcRet]

RestartTable =

Parameter | Description
tempidx_table_name | Restart name.

This option may be required in order for the feature to function.

Remarks

This INI option was added to make GENARC restartable so that transactions would not be archived twice even if GENARC was run twice. Enter the name of the GENARC restart table for this option. There is no default for this option and if it is not specified, GENARC will exit with an error. This table will be created by GENARC if the value for < DBHandler:DB2 > CreateTable = Yes. If CreateTable = No, the user will have to create this table manually.

Example

< ArcRet >

RestartTable = RESTART

Available

Release | 10.0
Patch |


SkipHiddenFields

[ArcRet]
SkipHiddenFields

SkipHiddenFields

Tabbing will skip hidden fields when viewing archived (read-only) formsets.

[ ArcRet]

SkipHiddenFields = Yes

Parameter | Description
boolean (Yes) | Y es | No Default value is: Yes

Remarks

Hidden fields are often used to collect information during entry, but tabbing through those fields when viewing the achive is considered a nuisance. This INI option will disable hidden fields from "popping-up" during the tabbing process when the formset is for viewing only. An exception will be made for hidden fields embedded in text areas. These fields will continue to display at the embedded location in the text area.

Example

< ARCRET >

SkipHiddenFields = Yes

Available

Release | _______
Patch |

Used By

AFELIB


TabNextPage

[ArcRet]
TabNextPage

TabNextPage

You can configure the TAB key to move from page to page during archive view mode.

[ ArcRet]

TabNextPage = Yes

Parameter | Description
Boolean (Yes) | You can configure the TAB key to move from page to page during archive view mode. Default value is: Yes

Remarks

Lets you use the TAB key to move from page to page during archive view mode, as opposed to using TAB to move from field to field.

Example

< ArcRec >

TabNextPage = Yes

Available

Release | _______
Patch |


TEMPIDX

[ArcRet]
TEMPIDX

TEMPIDX

Name of the table that will contain the TEMPIDX information.

[ ArcRet]

TEMPIDX = File

Parameter | Description
tempidx_table_name | Tempidx name.

This option may be required in order for the feature to function.

Remarks

This is a required option for an Xbase index.

It is not a required entry for other database indexes.

Example

< ArcRet >

TEMPIDX = ..\ARC\TEMP

Available

Release | _______
Patch |

Used By

GENARC


TransferKey1

[ArcRet]
TransferKey1

TransferKey1

TransferKey1 configures the File, New and the File, Retrieve options.

[ ArcRet]

TransferKey1 =

Remarks

In versions prior to 9.7, the File, New, Retrieve option passes information from the Form Selection window to

preselect Retrieve window records. When the Archive index implementation differs from these

default settings, the passed information results in a "none found" message that you must first

eliminate before continuing the retrieval process.

In version 9.7, the INI options specifying KEY1, KEY2, and KEYID can be used during the retrieval process, as follows:

< ArcRet >

TransferKey1 = Yes/No

TransferKey2 = Yes/No

TransferKeyID = Yes/No

The default settings should be "Yes" to maintain compatibility with existing implementations.

Example

< ARCRET >

TransferKey1 =

Available

Release | _______
Patch |


TransferKey2

[ArcRet]
TransferKey2

TransferKey2

TransferKey2 configures the File, New and the File, Retrieve options.

[ ArcRet]

TransferKey2 =

Remarks

In versions prior to 9.7, the File, New, Retrieve option passes information from the Form Selection window to

preselect Retrieve window records. When the Archive index implementation differs from these

default settings, the passed information results in a "none found" message that you must first

eliminate before continuing the retrieval process.

In version 9.7, the INI options specifying KEY1, KEY2, and KEYID can be used during the retrieval process, as follows:

< ArcRet >

TransferKey1 = Yes/No

TransferKey2 = Yes/No

TransferKeyID = Yes/No

The default settings should be "Yes" to maintain compatibility with existing implementations.

Example

< ARCRET >

TransferKey2 =

Available

Release | _______
Patch |


TransferKeyID

[ArcRet]
TransferKeyID

TransferKeyID

TransferKeyID configures the File, New and the File, Retrieve options.

[ ArcRet]

TransferKeyID =

Remarks

In versions prior to 9.7, the File, New, Retrieve option passes information from the Form Selection window to

preselect Retrieve window records. When the Archive index implementation differs from these

default settings, the passed information results in a "none found" message that you must first

eliminate before continuing the retrieval process.

In version 9.7, the INI options specifying KEY1, KEY2, and KEYID can be used during the retrieval process, as follows:

< ArcRet >

TransferKey1 = Yes/No

TransferKey2 = Yes/No

TransferKeyID = Yes/No

The default settings should be "Yes" to maintain compatibility with existing implementations.

Example

< ARCRET >

TransferKeyID =

Available

Release | _______
Patch |


ArcSplit

ArcSplit Options

  • ArcSplitConfig
  • DefConfig


ArcSplitConfig

[ArcSplit]
ArcSplitConfig

ArcSplitConfig

Lets you assign a name to your archive split settings.

[ ArcSplit]

ArcSplitConfig =

Parameter | Description
value | Lets you assign a name to your archive split settings. You can create as many ArcSplitConfig options as you need. Each of group of settings represents a control group with individual options.

Remarks

You can create as many ArcSplitConfig options as you need. Each group of settings represents a control group with individual options. Below is an example of a setting named TEST1.

The value of this option must match with the configuration name of the ArcSplitConfig:xxx INI group (where xxx is the configuration name).

If you use the ARCSPLIT utility, you must specify this INI option and the /SET command line parameter.

Example

< ArcSplit >

ArcSplitConfig = TEST1

Available

Release | _______
Patch |


DefConfig

[ArcSplit]
DefConfig

DefConfig

If you set up multiple ArcSplitConfig options, use this option to designate a default.

[ ArcSplit]

DefConfig =

Parameter | Description
value | If you set up multiple ArcSplitConfig options, use this option to designate a default. If you set up multiple ArcSplitConfig options, use this option to designate a default.

Remarks

If you set up multiple ArcSplitConfig options, use this option to designate a default. If you omit this option, the utility uses Test1 as the default.

The value of this option must be defined with the ArcSplitConfig option in the ArcSplit group.

For the ARCSPLIT utility, if you define the DefConfig option and omit the /SET parameter, the utility uses the DefConfig option to look for the ARCSPLIT configuration settings.

Example

< ArcSplit >

DefConfig =

Available

Release | _______
Patch |


ArcSplitConfig:XXX

ArcSplitConfig:
XXX

Remarks

Use the ArcSplitConfig:xxx (where xxx = the configuration name) control group to set up the settings to be used by the split archive tool to split the archive files. You can name the configuration name anything you like up to 256 characters, as long as it matches the value of the ArcSplitConfig option in the ArcSplit control group. You can have multiple ArcSplitConfig:xxx groups for various split archive configurations.

The split archive tool is available in Documaker Workstation, by choosing Tools, Database Maintenance and then Archive Maintenance. You would need the following entries in your men.res in order to get the access to the Split Archive window:

POPUP "&Database Maintenance" 294 "DataBase Maintenance"

MENUITEM "&Archive Maintenance…" 9299 "AGIW32->AGISplitArchive" "Archive split" 9

You can also run the ArcSplit command line utility to split the archive file. Many of the INI options in the ArcSplitConfig:xxx control group can be substituted with the command line parameters, if you desire. However, certain INI options are required to be present in the INI file that you use with the ArcSplit utility.

Here is an example of the INI options are required for the command line utility.

< ARCRET >

APPIDX = arc\appidx.dbf

ARCPath = arc\

CARFILE = archive

CARPath = arc\

CATALOG = arc\catalog

< ArcSplit >

ArcSplitConfig = MyArcSplit

< ArcSplitConfig:MyArcSplit >

splitAppidx = .\arc1\APPIDX1.dbf

splitCarFile = .\arc1\ARCHIVE1.CAR

splitCatalog = .\arc1\CATALOG1.dbf

Example

< ArcSplit >

ArcSplitConfig = MyArcSplit

< ArcSplitConfig:MyArcSplit >

CarFileSize = 2

DalScript =

EnableCarFileSize = Yes

OverRideDateRange = No

OverWriteFiles = Yes

PurgeRecords = Yes

RecordsToProcess = 110000

RecordsToSkip = 1

RunDalScript = No

SearchDateBy = RunDate

splitAppidx = .\arc1\APPIDX1.DBF

splitCarFile = .\arc1\ARCHIVE1.CAR

splitCatalog = .\arc1\CATALOG1.DBF

SplitDays = 120

SplitFromDate = 01/01/2000

SplitToDate = 12/31/2002

ArcSplitConfig:XXX Options

  • AllowChanges
  • CARFileSize
  • DALScript
  • EnableCARFileSize
  • OverrideDateRange
  • OverWriteFiles
  • PurgeRecords
  • RecordsToProcess
  • RecordsToSkip
  • RunDALScript
  • SearchDateBy
  • SplitAppIdx
  • SplitCARFile
  • SplitCatalog
  • SplitDays
  • SplitFromDate
  • SplitToDate


AllowChanges

[ArcSplitConfig:XXX]
AllowChanges

AllowChanges

This option lets you enable or disable the "Save settings" button on the Split Archive window in Documaker Workstation.

[ ArcSplitConfig:XXX]

AllowChanges = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Set the AllowChanges option to Yes to enable the "Save settings" button on the Split Archive window in Documaker Workstation so that you can save the Split Archive settings to the current configuration or to a new configuration. If you set the PurgeRecords option to Yes, then the "Save settings" button is automatically enabled, even if you set this option to No. The default value of this option is No.

If you have PurgeRecords = Yes in the ArcSplitConfig:xxx (where xxx is the Split Archive configuration name), it means that the AllowChanges option is virtually set to Yes, even if you do not have the AllowChanges option in the INI file. If you change the PurgeRecords option to No by unchecking the "Delete split records" checkbox on the Split Archive window and then save the settings, the system will insert an entry of AllowChanges = Yes to the INI file so that the "Save settings" button will remain enabled.

Example

< ArcSplitConfig:xxx >

PurgeRecords = No

AllowChanges = Yes

Available

Release | _______
Patch |


CARFileSize

[ArcSplitConfig:XXX]
CARFileSize

CARFileSize

CARFileSize option in the ArcSplitConfig:xxx (where xxx = the name of the configuration) is to limit the size of the CAR files.

[ ArcSplitConfig:XXX]

CARFileSize = 0

Parameter | Description
Spin | Default value is: 0

Remarks

You can limit the size of the CAR files created when you split an archive file using the Documaker Workstation. To use this feature you must set the split file size at a minimum of 100KB or a maximum of 1.4GB, and set the EnableCarFileSize to Yes. Because the minimum size is 100KB, it does not mean that ArcSplit will not create a file of a size less than the minimum. It is only saying that, if you are using this feature, you can not set the value to a size less than 100KB. The maximum 1.4GB will be the maximum size ArcSplit will create any new split file, even if this feature was not used.

In the ARCSPLIT utility, you can use either the /L command line parameter or the INI options to set the limit for the new CAR files the utility creates. In Documaker Workstation, you can enter the file size limit on the Split Archive window.

Use the following INI options to enable this feature:

< ArcSplitConfig:xxx >

CARFileSize = 1

EnableCARFileSize = Yes

Entering 1 in the CARFileSize field indicates 100KB. The range is between 1 and 14,000 (i.e. 100KG to 1,400,000KB). If the value of this option equals to zero, the system will ignore the option.

Example

< ArcSplitConfig:xxx >

CARFileSize = 25

EnableCARFileSize = Yes

Available

Release | 10.2
Patch | 143

Used By

AGILIB, ARCLIB, ARCSPLIT, ASPLIB, RCLIB


DALScript

[ArcSplitConfig:XXX]
DALScript

DALScript

Enter the name of the DAL script you want to run.

[ ArcSplitConfig:XXX]

DALScript =

Parameter | Description
value | Enter the name of the DAL script you want to run. Use the RunDALScript option to tell the utility if it should run the DAL script you specify with this option.

Remarks

Use the RunDALScript option to tell the utility if it should run the DAL script you specify with this option.

Example

< ArcSplitConfig:TEST1 >

DALScript =

Available

Release | _______
Patch |


EnableCARFileSize

[ArcSplitConfig:XXX]
EnableCARFileSize

EnableCARFileSize

Use this option to enable or disable the Car file size field on the Split Archive window in Documaker Workstation.

[ ArcSplitConfig:XXX]

EnableCARFileSize = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

You can limit the size of the CAR files created when you split an archive file using the ARCSPLIT utility or Documaker Workstation.

Use the EnableCARFileSize option to enable or disable the Car file size field on the Split Archive window in Documaker Workstation.

Here is an example:

< ArcSplitConfig:xxx >

CARFileSize = 200

EnableCARFileSize = Yes

The EnableCARFileSize option must set to Yes if you want to limit the Car file size with the CarFileSize option. The default is No.

In the ARCSPLIT utility, you can use either the /L command line parameter or the INI options to set the limit for the new CAR files the utility creates. If you use the INI options, you must have the EnableCARFileSize = Yes besides the CARFileSize option in the INI file that you use with the ArcSplit utility.

Example

< ArcSplitConfig:xxx >

CARFileSize = 200

EnableCARFileSize = Yes

Available

Release | 10.2
Patch | 143

Used By

AGILIB, ARCLIB, ARCSPLIT, ASPLIB, RCLIB


OverrideDateRange

[ArcSplitConfig:XXX]
OverrideDateRange

OverrideDateRange

Set the OverRideDate Range option to Yes to by-pass the date range requirement when splitting an archive.

[ ArcSplitConfig:XXX]

OverrideDateRange = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

You can override the required date range when splitting an archive via Documaker Workstation or the ARCSPLIT utility. In Documaker Workstation, the Split Archive window lets you choose whether to activate this feature. When using the ARCSPLIT utility, you can use either the /O command line parameter or the OverRideDateRange option to turn it on.

To by-pass the date range requirement, add this INI setting:

< ArcSplitConfig:xxx >

OverrideDateRange = Yes

Example

< ArcSplitConfig:xxx >

OverrideDateRange = Yes

Available

Release | 10.2
Patch | 143

Used By

AGILIB, ARCLIB, ARCSPLIT, ASPLIB, RCLIB


OverWriteFiles

[ArcSplitConfig:XXX]
OverWriteFiles

OverWriteFiles

Use the OverWriteFiles option to tell ArcSplit whether the new split archive files overwrite the old split archive files.

[ ArcSplitConfig:XXX]

OverWriteFiles = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Set the OverWriteFiles option to Yes if you want the new split archive files overwrite the old split archive files. The default is No, not to overwrite the old archive files.

If you use Documaker Workstation, you can set this option by checking or unchecking the Overwrite Existing Files box on the Split Archive window. If you use the ARCSPLIT utility, you can use either the /D command line parameter or this INI option.

Example

< ArcSplitConfig:xxx >

OverWriteFiles = Yes

Available

Release | _______
Patch |


PurgeRecords

[ArcSplitConfig:XXX]
PurgeRecords

PurgeRecords

This option tells ArcSplit whether the split records should be deleted from the source archive files after the split.

[ ArcSplitConfig:XXX]

PurgeRecords = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Set the PurgeRecords option to Yes if you want the split records removed from the source archive files after the split. The default is No, not to delete the split records from the source archive files.

If you use Documaker Workstation, you can set this setting by checking or unchecking the "Delete split records" checkbox on the Split Archive window. However, you must have either AllowChanges = Yes or PurgeRecords = Yes in the ArcSplitConfig:xxx (where xxx is the Split Archive configuration name) INI group to activate the "Delete split records" checkbox for entry. If you have the PurgeRecords = Yes in your INI file, the "Delete split records" checkbox will be automatically checked.

If you use the ARCSPLIT utility, you can use either the /P command line parameter or this INI option.

Example

< ArcSplitConfig:xxx >

PurgeRecords = Yes

Available

Release | _______
Patch |


RecordsToProcess

[ArcSplitConfig:XXX]
RecordsToProcess

RecordsToProcess

Enter the number of records to process.

[ ArcSplitConfig:XXX]

RecordsToProcess =

Parameter | Description
value | Enter the number of records to process. Use this option if you have a very large archive and you want to limit the number of records processed at one time.

Remarks

Use this option if you have a very large archive and you want to limit the number of records processed at one time.

Example

< ArcSplitConfig:TEST1 >

RecordsToProcess = 200

Available

Release | _______
Patch |


RecordsToSkip

[ArcSplitConfig:XXX]
RecordsToSkip

RecordsToSkip

Enter the number of the record the utility to process first. If you omit this option, the utility starts with the first record.

[ ArcSplitConfig:XXX]

RecordsToSkip =

Parameter | Description
value | Enter the number of the record the utility to process first. If you omit this option, the utility starts with the first record.

Example

< ArcSplitConfig:TEST1 >

RecordsToSkip = 4

Available

Release | _______
Patch |


RunDALScript

[ArcSplitConfig:XXX]
RunDALScript

RunDALScript

Enter Yes if you want the utility to run the DAL script you specified with the DALScript option.

[ ArcSplitConfig:XXX]

RunDALScript = Yes

Parameter | Description
Boolean (Yes) | Enter Yes if you want the utility to run the DAL script you specified with the DALScript option. Default value is: Yes

Example

< ArcSplitConfig:TEST1 >

RunDALScript =

Available

Release | _______
Patch |


SearchDateBy

[ArcSplitConfig:XXX]
SearchDateBy

SearchDateBy

Enter RunDate to search the records based on the RunDate. The default is ArchivedDate.

[ ArcSplitConfig:XXX]

SearchDateBy = ArchivedDate

Parameter | Description
value | Enter RunDate to search the records based on the RunDate. The default is ArchivedDate. Default value is: ArchivedDate

Example

< ArcSplitConfig:TEST1 >

SearchDateBy =

Available

Release | _______
Patch |


SplitAppIdx

[ArcSplitConfig:XXX]
SplitAppIdx

SplitAppIdx

Enter the name for the newly split IDX file. The default is APPIDX1.

[ ArcSplitConfig:XXX]

SplitAppIdx = APPIDX1

Parameter | Description
value | Enter the name for the newly split IDX file. The default is APPIDX1. Default value is: APPIDX1

Remarks

The SplitAddpIdx option specifies the file name and path of the newly split archive application index file. You can use a relative path or an absolute path. The default is ARC1\AppIdx1.DBF.

If you use Documaker Workstation, you can set up this setting on the Split Archive window. If you use the ARCSPLIT utility, you must specify this INI option and the /NSIF command line parameter.

Example

< ArcSplitConfig:TEST1 >

SplitAppIdx = AppIdx1

Available

Release | _______
Patch |


SplitCARFile

[ArcSplitConfig:XXX]
SplitCARFile

SplitCARFile

Enter the name for the newly split CAR file. The default is ARCHIVE1.

[ ArcSplitConfig:XXX]

SplitCARFile = ARCHIVE1

Parameter | Description
value | Enter the name for the newly split CAR file. The default is ARCHIVE1. Default value is: ARCHIVE1

Remarks

The SplitCarFile option specifies the file name and path of the newly split archive application index file. You can use a relative path or an absolute path. The default is ARC1\Archive1.CAR.

If you use Documaker Workstation, you can set up this setting on the Split Archive window. If you use the ARCSPLIT utility, you must specify this INI option and the /NSCF command line parameter.

Example

< ArcSplitConfig:TEST1 >

SplitCARFile = Archive1

Available

Release | _______
Patch |


SplitCatalog

[ArcSplitConfig:XXX]
SplitCatalog

SplitCatalog

Enter the name for the newly split catalog file. The default is CATALOG1.

[ ArcSplitConfig:XXX]

SplitCatalog = CATALOG1

Parameter | Description
value | Enter the name for the newly split catalog file. The default is CATALOG1. Default value is: CATALOG1

Remarks

The SplitCatalog option specifies the file name and path of the newly split archive application index file. You can use a relative path or an absolute path. The default is ARC1\Catalog1.DBF.

If you use Documaker Workstation, you can set up this setting on the Split Archive window. If you use the ARCSPLIT utility, you must specify this INI option and the /NCF command line parameter.

Example

< ArcSplitConfig:TEST1 >

SplitCatalog = Catalog1

Available

Release | _______
Patch |


SplitDays

[ArcSplitConfig:XXX]
SplitDays

SplitDays

Enter the number of days you want the utility to add to the start date to determine the end date.

[ ArcSplitConfig:XXX]

SplitDays = Edit

Parameter | Description
value | Enter the number of days you want the utility to add to the start date to determine the end date. The utility then splits the archive between the start and end dates.

Remarks

The utility then splits the archive between the start and end dates.

Example

< ArcSplitConfig:TEST1 >

SplitDays =

Available

Release | _______
Patch |


SplitFromDate

[ArcSplitConfig:XXX]
SplitFromDate

SplitFromDate

Enter the date on which you want the split to begin.

[ ArcSplitConfig:XXX]

SplitFromDate = Edit

Parameter | Description
value | Enter the date on which you want the split to begin. The default is the current date. The format is mm/dd/yyyy.

Remarks

The default is the current date. The format is mm/dd/yyyy.

Example

< ArcSplitConfig:TEST1 >

SplitFromDate = mm/dd/yyyy

Available

Release | _______
Patch |


SplitToDate

[ArcSplitConfig:XXX]
SplitToDate

SplitToDate

Enter the date on which you want the split to end.

[ ArcSplitConfig:XXX]

SplitToDate = Edit

Parameter | Description
value | Enter the date on which you want the split to end. The default is the current date. The format is mm/dd/yyyy.

Remarks

The default is the current date. The format is mm/dd/yyyy.

Example

< ArcSplitConfig:TEST1 >

SplitToDate = mm/dd/yyyy

Available

Release | _______
Patch |


AssignUserList

Remarks

UserID

AssignUserList Options

  • UserID


UserID

[AssignUserList]
UserID

UserID

You can now set up the system to present only a subset of all users for selection during assignment.

[ AssignUserList]

UserID =

Parameter | Description
value | You can now set up the system to present only a subset of all users for selection during assignment.

Remarks

The base system shows you all users when you assign a form set. By turning on this feature, you can define the users you want to appear on the Assign window, limiting the choices to only the appropriate ones.

Example

[AssignUserList]

UserID = ;TOM;Thomas;

UserID = ;ROB;Robert;

UserID = ;JOHN;Jonathan;

UserID = ;SMITH;Samuel;

UserID = ;FORMAKER;FORMAKER;

Available

Release | 10.0
Patch |


AutoAssign

Remarks

The Processing System allows users to be mapped to other users for automatic and enforced assignment, controlled by the INI file.

[AutoAssign]

User1 = User2

User2 = User3

Where you are naming the USERID of the "From" user on the left and the "To" USERID on the right.

We check for the AutoAssign group. If found, the current user's ID would be compared to the left column. If found, the ID on the right would automatically become the next assignee without further intervention.

If AutoAssign is not in effect or the current user's ID is not specified in the list, the normal "Choose a User ID" dialog is presented for selection.

AutoAssign Options

  • User1
  • User2


User1

[AutoAssign]
User1

User1

You can now map users to other users so form sets can be automatically assigned by the system.

[ AutoAssign]

User1 =

Parameter | Description
value | You can now map users to other users so form sets can be automatically assigned by the system.

Remarks

All the user has to do is select the Assign option while the form set is open and the system takes care of making the assignment. To set up this feature, you use these INI options in the AutoAssign control group:

[AutoAssign]

User1 = User2

User2 = User3

This example tells the system that form sets from User1 are always assigned to User2. Form sets from User2 are always assigned to User3. The From user is listed on the left and the To user is listed on the right. When you use this features, the system does not display the Choose a User ID window during the assignment.

Example

< AutoAssign >

User1 = User2

Available

Release | 10.0
Patch |


User2

[AutoAssign]
User2

User2

You can now map users to other users so form sets can be automatically assigned by the system.

[ AutoAssign]

User2 =

Parameter | Description
value | You can now map users to other users so form sets can be automatically assigned by the system.

Remarks

All the user has to do is select the Assign option while the form set is open and the system takes care of making the assignment. To set up this feature, you use these INI options in the AutoAssign control group:

[AutoAssign]

User1 = User2

User2 = User3

This example tells the system that form sets from User1 are always assigned to User2. Form sets from User2 are always assigned to User3. The From user is listed on the left and the To user is listed on the right. When you use this features, the system does not display the Choose a User ID window during the assignment.

Example

< AutoAssign >

User2 = User3

Available

Release | 10.0
Patch |


AutoFields

Remarks

The FSIUSER.INI AutoFields control group prefills specified fields within form sets with user defined data.

AutoFields options have the following syntax:

FIELD NAME = DATA

The FIELD NAME is the form set field name. DATA is user defined data appearing in the field.

The Processing System lets you use all available INI built in functions as data. INI built in functions retrieve data dependent INI values. When a program gets an INI value, it gets the value returned by the built in function instead of ~FUNCTION.

The following table lists and describes the INI built in functions:

INI Built In Description

Functions

~KEYID Returns KEYID field value from WIP structure

~KEY1 Returns KEY1 field value from WIP structure (Company), or if found, matching values from

[Company_Table] INI control group

~KEY2 Returns KEY2 field value from WIP structure (Line of Business)

~DATE Returns current date

~TIME Returns current time

~USERID Returns user ID of current user

~ACTION Returns current action, such as Create, Update, Delete, Save, Complete, and so on.

AutoFields Options

  • AccountNum
  • CARRIER
  • COMPANY
  • DATE
  • LOB
  • POLICY NBR


AccountNum

[AutoFields]
AccountNum

AccountNum

[ AutoFields]

AccountNum =

Parameter | Description
KeyID |

Example

< AutoFields >

AccountNum = ~KEYID

Available

Release | _______
Patch |


CARRIER

[AutoFields]
CARRIER

CARRIER

The FSISYS.INI AutoFields control group prefills specified fields within form sets with user defined data.

[ AutoFields]

CARRIER =

Remarks

Refer to the Remarks for the < AutoFields > INI control group for detail information.

For example:

< AutoFields >

Carrier = ~KEY1

This option returns the KEY1 field value from the WIP structure (Company), or if found, matching values from the <Company_Table> INI control group.

Example

< AutoFields >

Carrier = ~KEY1

Available

Release | _______
Patch |


COMPANY

[AutoFields]
COMPANY

COMPANY

[ AutoFields]

COMPANY =

Remarks

Refer to the Remarks for the < AutoFields > INI control group for the detail information.

For example:

< AutoFields >

Company = ~KEY1

The COMPANY option returns the KEY1 field value from the WIP structure (Company), or if found, matching values from the <Company_Table> INI control group.

Example

< AutoFields >

Company = ~KEY1

Available

Release | _______
Patch |


DATE

[AutoFields]
DATE

DATE

[ AutoFields]

DATE =

Remarks

Refer to the Remarks for the < AutoFields > INI control group for the detail information.

For example:

< AutoFields >

Date = ~Date

The DATE option returns the current date (the format is defined in the value < Formats > DateFormat =). The default format is MM/DD/YY.

Example

< AutoFields >

Date = ~Date

Available

Release | _______
Patch |


LOB

[AutoFields]
LOB

LOB

[ AutoFields]

LOB =

Remarks

Refer to the Remarks for the < AutoFields > INI control group for the detail information.

For example:

< AutoFields >

LOB = ~KEY2

The LOB option returns the KEY2 field value from the WIP structure (Line of Business).

Example

< AutoFields >

LOB = ~KEY2

Available

Release | _______
Patch |


POLICY NBR

[AutoFields] POLICY
NBR

POLICY NBR

[ AutoFields]

POLICY NBR =

Remarks

Refer to the Remarks for the < AutoFields > INI control group for the detail information.

For example:

< AutoFields >

POLICY NBR = ~KEYID

The POLICY NBR option returns the KEYID field value from the WIP structure(policy number).

Example

< AutoFields >

POLICY NBR = ~KEYID

Available

Release | _______
Patch |


AutoImport

Remarks

You can use the new AutoImport option to send most error messages to a log file instead of having them displayed on screen. Keep in mind that unless you periodically check the trace file for errors, you will not know errors are occurring.

Example

< AutoImport >

SuppressAllMessages = Yes

AutoImport Options

  • CompleteOnSuccess
  • DeleteOnFail
  • DeleteOnSuccess
  • Description
  • EDIT
  • EXT
  • FILE
  • MATCH
  • PATH
  • RecordType
  • StatusCode
  • SuppressAllMessages
  • TransactionCode


CompleteOnSuccess

[AutoImport]
CompleteOnSuccess

CompleteOnSuccess

1006 EXPORTING FILES CREATED BY AUTOIMPORT, AUTOPRINT, OR AUTOARCHIVE

[ AutoImport]

CompleteOnSuccess = No

Parameter | Description
Boolean (No) | When using AutoImport, AutoPrint, and AutoArchive, you can now have the system automatically export the resulting file to another system. Default value is: No

Remarks

When using AutoImport, AutoPrint, and AutoArchive, you can now have the system automatically export the resulting file to another system.

NOTE: If you specify an alternate name for your AutoImport control group, add this new option under that control group name.

The default for this option is No, which tells the system not to automatically export the file once the transactions have been processed. Use these Complete control group options to automate the window:

< Complete >

PrintOnComplete = Yes

ExportOnComplete = Yes

ArchiveOnComplete = Yes

SuppressDialog = Yes

Set up the ExpFile_CD control group up to automatically complete.

< ExpFile_CD >

File = EXPORT

EXT = .OUT

SuppressDlg = Yes

AppendedExport = Yes

NOTE: When operating in this manner, the first export function in your list is the one the system uses. Make sure you only have one export format defined, such as the ExportFormats control group, or define the default option so it appears at the top of the list.

Example

< AutoImport >

CompleteOnSuccess = Yes

Available

Release | 10.1
Patch |


DeleteOnFail

[AutoImport]
DeleteOnFail

DeleteOnFail

Prior to import, each file is renamed to match the WIP NA and POL file created for the form set.

[ AutoImport]

DeleteOnFail = Yes

Parameter | Description
boolean | Prior to import, each file is renamed to match the WIP NA and POL file created for the form set. Default value is: Yes

Remarks

The DeleteOnSuccess option will delete files that are successfully imported. This option defaults on (Yes). If the user wants to retain the import files, the DeleteOnSuccess option should be turned off (No).

Use this FSISYS.INI group to enable the automatic WIP import feature in the Processing System. Automatic WIP Import automatically identifies and imports data for user form selection or it can import data files directly into the WIP database without user intervention. This feature is a timed service function to be called through TMRLIB and must be registered via an INI option in the TIMERFUNCS control group.

Example

< AUTOIMPORT >

DeleteOnFail = No

Available

Release | _______
Patch |


DeleteOnSuccess

[AutoImport]
DeleteOnSuccess

DeleteOnSuccess

Prior to import, each file is renamed to match the WIP NA and POL file created for the form set.

[ AutoImport]

DeleteOnSuccess = Yes

Parameter | Description
Boolean (Yes) | Prior to import, each file is renamed to match the WIP NA and POL file created for the form set. Default value is: Yes

Remarks

The DeleteOnSuccess option will delete files that are successfully imported. This option defaults on (Yes). If the user wants to retain the import files, the DeleteOnSuccess option should be turned off (No).

NOTE: The file is not renamed to the original name to prevent attempts to import the file a second time. It will be up to the user (or someone from user's organization) to periodically move or delete files if this option is not activated.

Example

< AUTOIMPORT >

DeleteOnSuccess = Yes

Available

Release | _______
Patch |


Description

[AutoImport]
Description

Description

If the imported file does not specify a WIP Description, the Description option will set it to the value specified.

[ AutoImport]

Description = Imported

Parameter | Description
value | If the imported file does not specify a WIP Description, the Description option will set it to the value specified. Default value is: Imported

Remarks

Imported is the default text value for this option.

Example

< AUTOIMPORT >

Description = Imported

Available

Release | _______
Patch |


EDIT

[AutoImport]
EDIT

EDIT

The EDIT option determines whether import files are saved directly to WIP without user interaction.

[ AutoImport]

EDIT = No

Parameter | Description
boolean | The EDIT option determines whether import files are saved directly to WIP without user interaction. Default value is: No

Remarks

By default this option is off. If this option is enabled (YES), then the user must complete the Forms Selection dialog before the import is considered successful.

When activated, this option is only recognized when no form set is currently loaded (Desktop is closed) and the user is not engaged with a menu option or dialog.

The user can override much of the imported information on the Forms Selection window. If the user changes the KEY1 (company) value on this dialog, the imported data will be lost.

When the user accepts the dialog (after any changes), the system will assume the import was successful. Aborting the Forms Selection dialog will cause the import to fail.

Subsequently, the import file will be renamed to .BAD (or deleted if the DeleteOnFail option is activated).

Note: If the program is minimized when an import file is located and the EDIT option is active, the program window will be restored automatically before the Forms Selection dialog appears

Example

< AUTOIMPORT >

EDIT = No

Available

Release | _______
Patch |


EXT

[AutoImport]
EXT

EXT

This option specifies what file extension import files will use.

[ AutoImport]

EXT = .DAT

Parameter | Description
value | This option specifies what file extension import files will use. Default value is: .DAT

Remarks

If the FILE option is not used, or if that value does not specify an extension, the EXT option will specify the import file extension.

The EXT option defaults to .DAT. It is not recommended that you use the extension .BAD because this may conflict with import files that fail to import properly. Non-successful import files are renamed to .BAD. Likewise, an extension consisting of a single period (dot) should not be used because this may conflict with the multi-user capability in a networked environment.

Example

< AUTOIMPORT >

EXT = .DAT

Available

Release | _______
Patch |


FILE

[AutoImport]
FILE

FILE

If the FILE option is defined, it specifies that only a file with the given name is to be located and imported.

[ AutoImport]

FILE = .DAT

Parameter | Description
value | If the FILE option is defined, it specifies that only a file with the given name is to be located and imported. Default value is: .DAT

Remarks

If FILE is omitted, import files are assumed to match the query created by combining MATCH and EXT.

If the FILE option is defined without a path, the PATH variable is combined with this option to locate the specified file. If the extension is omitted from the file name specified, the extension specified by EXT (.DAT) will be assumed.

Example

< AUTOIMPORT >

FILE =

Available

Release | _______
Patch |


MATCH

[AutoImport]
MATCH

MATCH

MATCH is combined with EXT to create a search pattern for import files when the FILE option is not specified.

[ AutoImport]

MATCH = *

Parameter | Description
value | MATCH is combined with EXT to create a search pattern for import files when the FILE option is not specified. Default value is: *

Remarks

The search will occur in the directory specified by the PATH option.

This option defaults to the DOS wildcard asterisk (*), which means that any file name with the appropriate extension is a match. This option can be set to any valid DOS file name search value.

Example

< AUTOIMPORT >

MATCH = *

Available

Release | _______
Patch |


PATH

[AutoImport]
PATH

PATH

This option identifies the path that should be periodically checked for import data files.

[ AutoImport]

PATH = *.DAT

Parameter | Description
value | This option identifies the path that should be periodically checked for import data files. Default value is: *.DAT

Remarks

It is assumed that the path is accurate and that the user has access to it.

If the option FILE is not specified, the function will scan the specified directory at the timed interval for a file matching the query created by combining MATCH and EXT. By default this will be *.DAT. Only one file (if found) is imported during each timed interval.

If the option FILE is specified without a path, the PATH variable is combined with that option to locate the specified file.

A PATH or FILE option must be defined or the auto-import service function will not initialize.

Example

< AUTOIMPORT >

PATH =

Available

Release | _______
Patch |


RecordType

[AutoImport]
RecordType

RecordType

If the imported file does not specify a WIP RecordType, this option sets it to the value specified.

[ AutoImport]

RecordType = NEW

Parameter | Description
value | If the imported file does not specify a WIP RecordType, this option sets it to the value specified. Default value is: NEW

Remarks

The record type is verified with those specified in the INI file. The default value for this option is NEW.

Example

< AUTOIMPORT >

RecordType = NEW

Available

Release | _______
Patch |


StatusCode

[AutoImport]
StatusCode

StatusCode

If the imported file does not specify a WIP StatusCode, the StatusCode option will set it to the value specified.

[ AutoImport]

StatusCode =

Parameter | Description
value | If the imported file does not specify a WIP StatusCode, the StatusCode option will set it to the value specified.

Remarks

The status code must match a valid one identified in the INI file. The default StatusCode value is WIP.

By setting the WIP StatusCode, the user controls whether the form set is identified as "true" work-in-process (which must be completed), or marked with some other status (such as BatchPrint).

Example

< AUTOIMPORT >

StatusCode = WIP

Available

Release | _______
Patch |


SuppressAllMessages

[AutoImport]
SuppressAllMessages

SuppressAllMessages

[ AutoImport]

SuppressAllMessages =

Parameter | Description
value | You can use the new AutoImport option to send most error messages to a log file instead of having them displayed on screen

Remarks

You can use the new AutoImport option to send most error messages to a log file instead of having them displayed on screen. Keep in mind that unless you periodically check the trace file for errors, you will not know errors are occurring.

Example

< AutoImport >

SuppressAllMessages = Yes

Available

Release | 10.1
Patch | 354


TransactionCode

[AutoImport]
TransactionCode

TransactionCode

This option will set the transaction code value if the imported file does not specify a WIP TransactionCode.

[ AutoImport]

TransactionCode = NB

Parameter | Description
value | This option will set the transaction code value if the imported file does not specify a WIP TransactionCode. Default value is: NB

Remarks

The default value for this option is NB (New Business). The transaction code is verified with those specified in the INI file.

Example

< AUTOIMPORT >

TransactionCode = NB


AutoImportXML

Remarks

You can automatically import an XML file, in the expected format as described in the documentation, into Documaker Workstation. To use this feature, you should know how to use the Timer function.

The group name "AutoImportXML" is the default name, and it can be named some thing you like as long as it is defined in the TimerFuncs group. Besides, you may have multiple groups for automatic import of XML files. Below is an example of two import options in the TimerFuncs group. There may be occasions when you want to import data from more than one directory. For example, you may have one directory set up for form sets with a WIP status code and another directory for form sets with a BatchPrint status code. To handle these requirements, you can define more than one group settings in your INI file, as shown here:

< TimerFuncs >

01 =;0;0;300;WXMW32->WXMAutoImportXML;

02 =;0;0;300;WXMW32->WXMAutoImportXML; \AUTOBATCHXML

In this example, the first option points to the default control group, which is AutoImportXML. The second option points to the alternate control group, AutoBatchXML.

Each of these option can contain different function calls which determine the behavior of the import function. Also, the flags (STATE, URGENCY, and SECONDS), indicated by 0;0;300, do not have to be the same. Please refer to the TimerFuncs group for more information on how to set up the timer.

Example

< AutoImportXML >

Path = \data\

File =

Match = *

Ext = .XML

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

AutoImportXML Options

  • DeleteOnFail
  • DeleteOnSuccess
  • Description
  • Edit
  • Ext
  • File
  • KeyID
  • Match
  • Path
  • RecordType
  • StatusCode
  • SuppressAllMessages
  • TransactionCode


DeleteOnFail

[AutoImportXML] DeleteOnFail

DeleteOnFail

Use this option to delete the import file if it fails to import.

[ AutoImportXML]

DeleteOnFail = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The default is No. The system will rename the import file with an extension BAD. Enter Yes if you want to delete the import file if it fails to import.

Example

< AutoImportXML >

Path = \data\

File =

Match = *

Ext = .XML

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


DeleteOnSuccess

[AutoImportXML] DeleteOnSuccess

DeleteOnSuccess

Use this option to delete the import file after it has been imported.

[ AutoImportXML]

DeleteOnSuccess = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

The default is Yes. If you want to keep the file, enter No. The system renames the file using a randomly-generated name.

Example

< AutoImportXML >

Path = \data\

File =

Match = *

Ext = .XML

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


Description

[AutoImportXML] Description

Description

Use this option to specify the WIP description.

[ AutoImportXML]

Description = Imported

Parameter | Description
Edit | Default value is: Imported

Remarks

If the imported file has a WIP description, the system ignores this option.

If you omit this option and the imported file description field is blank, the default is imported.

Example

< AutoImportXML >

Path = \data\

File =

Match = *

Ext = .XML

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


Edit

[AutoImportXML] Edit

Edit

Use this option to tell the system whether to open the form set created by the imported file for data entry.

[ AutoImportXML]

Edit = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

By default, this option is set to No. This means the system saves import files directly to WIP without any data entry. A Yes value for this option opens the form set created by the imported file, for data entry.

Example

< AutoImportXML >

Path = \data\

File =

Match = *

Ext = .XML

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


Ext

[AutoImportXML] Ext

Ext

Use this option to specify the file extension the import file should have.

[ AutoImportXML]

Ext = XML

Parameter | Description
Edit | Default value is: XML

Remarks

If the file extension is not specified with the File option, it defaults to XML or it may be specified with the Ext option.

Here is an example:

<AutoImportXML>

File = .\xmlfiles\MyWip

Ext = WXM

If the File option is not defined, then the Path option is required. The system scans the directory specified with the Path option for any matched file with the extension specified in the Ext option (or default XML). The Match option defines the pattern matching (default * for all files).

Here is an example:

<AutoImportXML>

Path = .\xmlfiles

Match = GA????

Ext = WXM

Avoid using .BAD as an extension, because unsuccessful import files are renamed with that as the extension. Also, do not use a single period because it can conflict with multi-user capabilities in a network environment.

Example

< AutoImportXML >

Path = .\WipXml

Ext = WXM

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


File

[AutoImportXML] File

File

Use this option to specify the file name that should be imported by the system.

[ AutoImportXML]

File = File

Parameter | Description
File |

Remarks

You may specify the path, file and extension names with the File option.

Here is an example:

<AutoImportXML>

File = c:\mstrres\sampco\xmlfiles\MyWIP.xml

If the file extension is not specified with the File option, it defaults to XML or it may be specified with the Ext option.

Here is an example:

<AutoImportXML>

File = .\xmlfiles\MyWip

Ext = WXM

If the File option is not defined, then the Path option is required. The system scans the directory specified with the Path option for any matched file with the extension specified in the Ext option (or default XML). The Match option defines the pattern matching (default * for all files).

Here is an example:

<AutoImportXML>

Path = .\xmlfiles

Match = GA????

Ext = WXM

Example

< AutoImportXML >

File = c:\mstrres\sampco\xmlfiles\MyWIP

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


KeyID

[AutoImportXML] KeyID

KeyID

Use this option to supply a value for the KeyID, if the imported file did not have one.

[ AutoImportXML]

KeyID = XMLImported

Parameter | Description
Edit | Default value is: XMLImported

Remarks

The default value for this option is XMLImported. Use the ~FORMSETID function to assign a random ID to the imported formset to avoid the duplicate ID error.

Example

< AutoImportXML >

Path = \data\

Match = *

Ext = XML

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


Match

[AutoImportXML] Match

Match

Use this option with the Path and Ext options to locate import files when the File option is not defined.

[ AutoImportXML]

Match = *

Parameter | Description
Edit | Default value is: *

Remarks

The system searches the directory specified in the Path option. The default is an asterisk (*), which is the DOS wildcard. All valid DOS file name searches can be performed with this option.

Example

< AutoImportXML >

Path = \data\

Match = Wip*

Ext = XML

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


Path

[AutoImportXML] Path

Path

This option tells the system what directory the import files are in.

[ AutoImportXML]

Path = Path

Parameter | Description
Path |

Remarks

If the File option is not defined, then the Path option is required. The system scans the directory specified with the Path option for any matched file with the extension specified in the Ext option (or default XML). The Match option defines the pattern matching (default * for all files).

Here is an example:

<AutoImportXML>

Path = .\xmlfiles

Match = GA????

Ext = WXM

Make sure the path specified by this option is valid and the user has access to it.

Example

< AutoImportXML >

Path = \data\

Match = Wip???

Ext = XML

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


RecordType

[AutoImportXML] RecordType

RecordType

If the imported file does not contain a WIP record type, you can use this option to specify the value for the record type.

[ AutoImportXML]

RecordType = New

Parameter | Description
Edit | Default value is: New

Remarks

The system checks the record type with those listed in the INI file. The default is New.

Example

< AutoImportXML >

Path = \data\

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


StatusCode

[AutoImportXML] StatusCode

StatusCode

Use this option to specify the WIP status code.

[ AutoImportXML]

StatusCode = WIP

Parameter | Description
Edit | Default value is: WIP

Remarks

If the imported file had a WIP status code, the system ignores this option. If you omit this option and the imported file status code field is blank, the default is WIP. The system checks the status codes in the INI file with the one given for a valid code. By setting the status code to WIP, then you can verify whether the form set is a work-in-process, or whether the form set needs to be marked with some other status code, such as Batch Print.

Example

< AutoImportXML >

Path = \data\

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


SuppressAllMessages

[AutoImportXML] SuppressAllMessages

SuppressAllMessages

Use this option to suppress all messages. The default is No.

[ AutoImportXML]

SuppressAllMessages = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< AutoImportXML >

Path = \data\

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


TransactionCode

[AutoImportXML] TransactionCode

TransactionCode

[ AutoImportXML]

TransactionCode = NB

Parameter | Description
Edit | Default value is: NB

Remarks

If the imported file does not contain a WIP transaction code, you can use this option to specify the value for the transaction code.

If the imported file contains a WIP transaction code, this INI option is ignore. If the imported file does not contain a WIP transaction code, then this INI option is used. The default is NB (New Business).

Example

< AutoImportXML >

Path = \data\

DeleteOnSuccess = Yes

DeleteOnFail = No

TransactionCode = NB

Description = XMLImported

StatusCode = WIP

RecordType = NEW

Edit = No

KeyID = ~FORMSETID

SuppressAllMessages= Yes

Available

Release | 10.2
Patch | 22


AutoReturn

Remarks

The AutoReturn INI control group allows the user to return to the previous selection dialog after viewing or editing a formset. The dialog will redisplay in a state similar to that established when prior selection was made.

The AutoReturn feature has the capability of being enabled or disabled through INI settings. By default each setting is NO (disabled).

INI Settings:

[ AutoReturn ]

FormSelection = yes or no

FormsetRetrieve = yes or no

WipEdit=yes or no

Each option is separate and applies to a different dialog.

Example

To set feature, use these INI options:

< AutoReturn >

FormSelection = Yes/No

FormsetRetrieve = Yes/No

WIPEdit=Yes/No

Example

To set feature, use these INI options:

< AutoReturn >

FormSelection = Yes/No

FormsetRetrieve = Yes/No

WIPEdit=Yes/No

AutoReturn Options

  • FormSelection
  • FormsetRetrieve
  • WipEdit


FormSelection

[AutoReturn]
FormSelection

FormSelection

[ AutoReturn]

FormSelection = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The FormSelection option can be used to enable automatically returning to the formset creation window. If the user created the formset from the Form Selection dialog, when that formset is closed, the Form Selection dialog will reappear with the prior selection already in place.

If the user cancels from a dialog that supports the AutoReturn feature, the settings are cleared and the program will return to the main application window and await another user menu selection.

Example

< AutoReturn >

FormSelection = Yes/No

Available

Release | 10.0
Patch |


FormsetRetrieve

[AutoReturn]
FormsetRetrieve

FormsetRetrieve

[ AutoReturn]

FormsetRetrieve = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The FormsetRetrieve option will enable returning to the Retrieve Formset (from Archive) dialog. The dialog fields will be set to the same values as those used for the former selection.

If the user cancels from a dialog that supports the AutoReturn feature, the settings are cleared and the program will return to the main application window and await another user menu selection.

Example

< AutoReturn >

FormsetRetrieve = Yes/No

Available

Release | 10.0
Patch |


WipEdit

[AutoReturn]
WipEdit

WipEdit

[ AutoReturn]

WipEdit = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The WIPEdit option will enable returning to the WIP Dialog screen used to make the prior selection. The state of the dialog will be similar to that used to make the former selection.

If the user cancels from a dialog that supports the AutoReturn feature, the settings are cleared and the program will return to the main application window and await another user menu selection.

Example

< AutoReturn >

WipEdit = Yes/No

Available

Release | 10.0
Patch |


Banner

Remarks

The FSIUSER.INI BANNER control group determines and configures the printing of policy banner pages. The Processing System prints a banner page for every recipient in a form set.

The form that is printed as the banner page depends on the existence of pull forms in the form set. If there is at least one pull form in the form set then the PFORM form is printed. If there are no pull forms, then the BANNER form is printed. FAP files for the PFORM and BANNER files should be in the FORMS subdirectory for the standard configuration. There are no default values for the Banner control group.

Banner Options

  • Banner
  • Enabled
  • FIELD
  • FilterRecips
  • NAME
  • SIZE


[Banner]
Banner

Banner

This option is the default to provide legacy support. You can override the FAP name using this option.

[ Banner]

Banner = File

Parameter | Description
value | This option is the default to provide legacy support. You can, however, override the FAP name using this option.

Example

< Banner >

Banner = FAPName

Available

Release | 10.1
Patch |


Enabled

[Banner]
Enabled

Enabled

[ Banner]

Enabled = No

Parameter | Description
boolean (No) | The Enabled=Yes option is provided so you do not have to define the Name option and therefore will use the Banner option by default. The default is No. Default value is: No

Remarks

The Enabled=Yes option is provided so you do not have to define the Name option and therefore will use the Banner option by default. The default is No.

Example

< Banner >

Enabled = Yes

Available

Release | 10.1
Patch |


FIELD

[Banner]
FIELD

FIELD

NAME defines the FAP file to print as the bookmark page.

[ Banner]

FIELD = Edit

Parameter | Description
Edit |

Remarks

FIELD is the name of the field from the form set to print on the form. You can have a number of semicolon delimited field names in this INI value. The system uses the first entry in an option line that contains data.

This FSISYS.INI control group determines and configures the printing of policy banner pages. The Processing System prints a banner page for every recipient in a form set. The form that is printed as the banner page depends on the existence of pull forms in the form set. If there is at least one pull form in the form set then the PFORM form is printed. If there are no pull forms, then the BANNER form is printed. The PFORM and BANNER files should be in the FORMS subdirectory for the standard configuration. There are no default values for the Banner control group.

When you renew a policy you retrieve the original policy from archive and then assign it a new policy number on the Forms Selection window. You can add a field to the banner page that automatically displays the previous policy number.

To do this, create a field on the banner page (i.e. FAP file) called, for example, PRVPOL. In your INI file, include the new field in the Banner control group, as shown here:

< Banner >

Field = PRVPOL

Field = POLICY NBR

Field = INSURED NAME

Name = PFORM

Size =

Note: You must list the Field options in the same order as they appear on the banner page.

Be sure to include the following INI option:

< AFEProcedures >

BannerProc = TRNw32->TRNSetBannerFormInfo

Also you must enter the following line in the FormSelection group of the INI file:

< FormSelection >

OriginalKeyID = PRVPOL

Example

< Banner >

Field = PRVPOL

Field = POLICY NBR

Field = INSURED NAME

Name = PFORM

Available

Release | 11.0
Patch |

Used By

TRNLIB


FilterRecips

[Banner]
FilterRecips

FilterRecips

Use this option to name the recipients that should receive banner pages.

[ Banner]

FilterRecips = Edit

Parameter | Description
value | Use this option to name the recipients that should receive banner pages.

Remarks

If not defined, all recipients will receive a banner page. If you name more than one recipient, separate the names with a semicolon.

Example

< Banner >

FilterRecips = recip;recip;recip;

Available

Release | 10.1
Patch |


NAME

[Banner]
NAME

NAME

The Name option specifies the name of the FAP file to print as the banner page.

[ Banner]

NAME =

Remarks

The actual form that gets printed as the banner page depends on the existence of pull forms in the form set. If you set the value NAME = PFORM then if there is at least one pull form in the form set, the PFORM form is printed. If there are no pull forms in the form set, then the BANNER form is printed.

Available

Release | _______
Patch |


SIZE

[Banner]
SIZE

SIZE

SIZE specifies the paper used for printing: L = Letter size (default) G = Legal size

[ Banner]

SIZE = List

Parameter

Description

List

Values can be

  • L - Letter Size
  • G - Legal Size

Available

Release | _______
Patch |


BatchingByRecip

BatchingByRecip Options

  • Batch_Recip_Def


Batch_Recip_Def

[BatchingByRecip]
Batch_Recip_Def

Batch_Recip_Def

Use this FSISYS.INI control group to send transactions to a batch you specify based on data in the extract file.

[ BatchingByRecip]

Batch_Recip_Def =

Parameter | Description
value |

Remarks

Batch_Recip_Def = default:"ERROR"

This option tells the system that any output which has not already been sent to a batch by one of the other Batch_Recip_Def options should be placed in the ERROR batch. You must set up the ERROR batch in the RECIP_NAMES INI control group and you must also set up the batch name under the Print_Batches control group.

Batch_Recip_Def = 4,1234567;"BATCH1";INSURED

This option tells the system to place into BATCH1 any output which goes to the INSURED recipient and has 1234567 (the data in the extract file you want the system to search for) beginning at position 4 (the position in the extract file at which the search begins) in the extract file. The recipient must be set up in the RECIP_NAMES control group and the batch must be defined in the Print_Batches group.

Batch_Recip_Def = true;"BATCH2";INSURED

This option tells the system to place all recipients named INSURED into BATCH2. You must set up the recipient under the RECIP_NAMES group and BATCH2 under the Print_Batches group.

Batch_Recip_Def = true;"BATCH3";COMPANY | true;"BATCH2";AGENT

This option statement tells the system the place all recipients names INSURED into BATCH2. You must set up the recipients under the RECIP_NAMES group and batches under the Print_Batches group.

Example

< BatchingByRecip >

Batch_Recip_Def = 01,BillHead;"P_Batch1";Customer

Batch_Recip_Def = 01,BillHead;"P_Batch2";Company

Batch_Recip_Def = 01,BillHead;"P_Batch3";Other

Batch_Recip_Def = default;ERROR

Available

Release | _______
Patch |


BatchPrint

BatchPrint Options

  • ArchiveSpaceNeeded
  • AutoStart
  • BatchExport
  • NoBatchSupport
  • Path
  • PreLoadRequired
  • Program
  • Select_Recipient
  • SpaceNeeded
  • SpoolDrive


ArchiveSpaceNeeded

[BatchPrint]
ArchiveSpaceNeeded

ArchiveSpaceNeeded

This option defines how much available space (in bytes) the archive drive should have when archiving.

[ BatchPrint]

ArchiveSpaceNeeded =

Parameter | Description
value |

Remarks

If the drive specified by SpoolDrive does not have enough space, Print Server waits and continues to check for available disk space. If this parameter is missing, no disk space checking is provided.

Example

< BatchPrint >

ArchiveSpaceNeeded = 5000000

Available

Release | _______
Patch |


AutoStart

[BatchPrint]
AutoStart
AutoStart

AutoStart configures an OS/2 workstation to print in the background.

[ BatchPrint]

AutoStart = No

Parameter | Description
Boolean (No) | AutoStart configures an OS/2 workstation to print in the background. Default value is: No

Remarks

Set this value to "Yes" to start Print Server in the background. Set this value to "No" to send the print request to the currently running Print Server.

Example

< BatchPrint >

AutoStart = No

Available

Release | _______
Patch |


BatchExport

[BatchPrint]
BatchExport

BatchExport

[ BatchPrint]

BatchExport =

Remarks

This feature lets you batch export during a batch print process. For example, if you are processing insurance policies, this lets you batch export all of the policies after they have been completed.

NOTE: If you complete a policy without sending it to the batch print queue, do not use this feature. This feature is only intended for Documaker Workstation users.

You have to either batch print from the Complete window to send a policy to the batch print queue or set up your INI options to automatically send policies to the batch print queue. During the printing of the policies from the batch print queue, INI options trigger the batch export. The batch export only works with these export functions:

01 = ;TD;Token Data; TRNW32->TRNExport;

05 = ;V2;Standard Export; TRNw32->TRNExportV2;

Use these INI options:

< BatchPrint >

BatchExport = Yes; TRNW32->TRNExportV2

< ExpFile_CD >

Ext = .OUT

File = ~KeyID

Path = ~Key1

AppendedExport = Yes

SuppressDlg = Yes

CreateDirectory = Yes

To use this feature, first set up your INI file to include the desired export function. Be sure to include the File, Path, and CreateDirectory options with the appropriate settings. You may want to include a tilde (~) before the file name and path and use a field name from the WIP index. You may also want to use a field name with unique data to avoid any conflicts with other file names.

The example shown here uses the KEYID (policy number), which should be unique when creating a New Business, but may not be for an Endorsement, Renewal, or Quote.

You can also use the path to group policies into categories like company name, and so on. If the directory or path does not exist, you can have the system automatically create it by setting the CreateDirectory option to Yes.

NOTE: You do not have to include a tilde (~) in front of the file name and path. If you omit the tilde, policies will be appended, one after another, in the same file. If the policy number is the same as the file name, the system assumes you are using unique file names. In that case, policies with transaction colde NB (New Business), overwrite the existing file. This is done to avoid exporting New Business policies with the same policy number.

Available

Release | 10.3
Patch |


NoBatchSupport

[BatchPrint]
NoBatchSupport

NoBatchSupport

1153 Printing By Transaction

[ BatchPrint]

NoBatchSupport =

Parameter | Description
value | Now you can generate separate files for each transaction when you choose PDF or RTF from WIP or batch print.

Remarks

Now you can generate separate files for each transaction when you choose PDF or RTF from WIP or batch print.

NoBatchSupport indicates the named PrtType items, separated by semicolon, it does not support batch transactions and requires special handling.

The system names the files by appending a rolling number at the end of the name that starts the process and is displayed on the Print window. This is handled automatically, you do not have to set any INI options to get the WIP, Batch Print option to work as long as your PrtType names are PrtType:PDF for PDF and PrtType:RTF for RTF.

There are several INI options you can use to override the default naming process and also name other print drivers that require this unique handling.

< BatchPrint >

NoBatchSupport = PDF;RTF

PreLoadRequired= PDF

These are the default settings and cannot be overridden. However, you can specify other PrtType print driver definitions you want to fall into these same categories.

Also, you can name PrtType specific items under the BatchPrint control group to override the normal Device naming option. For instance,

< BatchPrint >

PDF = ~HEXTIME .PDF

RTF = ~HEXTIME -~KeyID .RTF

Any batch print that is sent to PrtType:PDF (picking PDF on the Print window) will now override the name and store the current hexadecimal date and time, such as BCF09CA4.PDF, which is an eight-character name, as the name of each transaction's output.

Also, you can combine INI built-in calls as shown in the RTF example. Here any WIP/Batch Print sent to RTF will name the files using the HEXTIME and the KeyID from the WIP transaction. This will result in names similar to this: BCF099A4-123456.RTF Note that you must leave a space after the built-in INI function name for it to work

properly, however that space will not appear in the resulting output name.

Example

< BatchPrint >

NoBatchSupport = PDF;RTF

Available

Release | 10.1
Patch | 145


Path

[BatchPrint]
Path

Path

Path specifies the full path to the batch queue.

[ BatchPrint]

Path = Path

Parameter | Description
value | Path specifies the full path to the batch queue.

Remarks

All workstations using the same Print Server must reference the same directory.

Example

< BatchPrint >

Path = K:\FAPDEMO\BATCH

Available

Release | _______
Patch |


PreLoadRequired

[BatchPrint]
PreLoadRequired

PreLoadRequired

1153 Printing by Transaction

[ BatchPrint]

PreLoadRequired =

Parameter | Description
value | This lets you specify all the PrtType items, separated by semicolon, that should be forced to load the form set prior to the starting print. Most print drivers do not require this, but some, such as PDF, do. should be forced to load the form set prior to the starting print.

Remarks

This lets you specify all the PrtType items, separated by semicolon, that should be forced to load the form set prior to the starting print. Most print drivers do not require this, but some, such as PDF, do.

Most print drivers do not require this, but some, such as PDF, do.

Example

< BatchPrint >

PreLoadRequired= PDF

Available

Release | 10.1
Patch | 145


Program

[BatchPrint]
Program

Program

The Program option specifies the name of the Print Server executable module. Do not change this setting.

[ BatchPrint]

Program = PRSRVW32.EXE

Parameter | Description
value | Program= PRSRVW32.EXE The Program option specifies the name of the Print Server executable module. Do not change this setting. Default value is: PRSRVW32.EXE

This option may be required in order for the feature to function.

Remarks

Program= PRSRVW32.EXE

Do not change this setting.

Example

< BatchPrint >

Program = PRSRVW32.EXE

Available

Release | _______
Patch |


Select_Recipient

[BatchPrint]
Select_Recipient

Select_Recipient

[ BatchPrint]

Select_Recipient = Edit

Parameter | Description
value |

Remarks

You can limit WIP and batch print to include specific recipients. If, for instance, you need to print specific recipients and those recipients are present, you can print that recipient’s copy of the document. Regardless of whether anything actually prints, the document is then treated as though it did print and you continue to the next step of the completion process. The next step is usually automatic archiving or staged for manual archival, depending on your system’s configuration.

To do this, add this INI option to the BatchPrint control group:

< BatchPrint >

Select_Recipient = value1,value2,value3, ...

You can specify any number of recipients. Just separate the recipients using commas or semicolons. Space characters are not a valid separators because recipient names can contain spaces. The system removes leading and trailing spaces from recipient names.

During the batch print process, the system loads each selected transaction to see if it includes any of the specified recipients. If so, those recipients will print. If the document does not include any of the requested recipients, the system skips the print process for that transaction and continues through the workflow as though it had printed.

The Print Selection window shows the list of recipients you specified in the Select_Recipient option. Check the All Recipients option to indicate you want to have the recipients in the INI file printed. Keep in mind the All Recipients option does not mean the system will print all of the legitimate recipients in the documents.

You can turn off the All Recipients option on the Print Selection window and further limit the recipients.

Example

< BatchPrint >

Select_Recipient = value1,value2,value3, ...

Available

Release | 10.1
Patch | 345


SpaceNeeded

[BatchPrint]
SpaceNeeded

SpaceNeeded

This option defines how much available space (in bytes) the spool drive should have when printing.

[ BatchPrint]

SpaceNeeded =

Parameter | Description
value | This option defines how much available space (in bytes) the spool drive should have when printing.

Remarks

If the drive specified by SpoolDrive does not have enough space, Print Server waits and continues to check for available disk space. If this parameter is missing, no disk space checking is provided.

Example

< BatchPrint >

SpaceNeeded = 5000000

Available

Release | _______
Patch |


SpoolDrive

[BatchPrint]
SpoolDrive

SpoolDrive

This option identifies the drive where the network spooler is located.

[ BatchPrint]

SpoolDrive =

Parameter | Description
value | This option identifies the drive where the network spooler is located.

Remarks

This parameter enables checking for available disk space.

Example

< BatchPrint >

SpoolDrive = P

Available

Release | _______
Patch |


BitmapLoaders

BitmapLoaders Options

  • BitmapLoader
  • Dynamic
  • PDFImportDPI
  • WMFImportDPI
  • VectorGraphicImportDPI


BitmapLoader

[BitmapLoaders]
BitmapLoader

BitmapLoader

[ BitmapLoaders]

BitmapLoader =

Example

< BitmapLoaders >

BitmapLoader = TIFF

Available

Release | _______
Patch |


Dynamic

[BitmapLoaders]
Dynamic

Dynamic

You can use INI options to specify alternate bitmap loaders, registered by type.

[ BitmapLoaders]

Dynamic = YN

Parameter | Description
boolean (No) | value set to NO for platforms which use static linkage (eg. MVS) platforms which use static linkage (eg. MVS)

Remarks

These options are read and used by the LOGInstallBitmapLoaders API. This LOGLIB function collects the attributes from the INI options and then invokes lower-level FAPLIB functions to register the loaders and establish the attributes.

In the BitmapLoaders group, the Dynamic option must be set to No for platforms which use static linkage (eg. MVS).

Example

< BitmapLoaders >

Dynamic = No

Available

Release | 9.7
Patch |


PDFImportDPI

[BitmapLoaders]
PDFImportDPI

You can use INI options to specify the resolution used when importing PDF files.

[ BitmapLoaders]

PDFImportDPI = value

Parameter | Description
value | Set this to the resolution that PDF files should be imported. The default value is 100.

Remarks

This option controls the resolution at which the PDF pages will be imported. The default is 100. Increasing this number slows the import and increases output file size.

Example

[ BitmapLoaders ]

PDFImportDPI = 192

Available

Release | 11.3
Patch |


WMFImportDPI

[BitmapLoaders]
WMFImportDPI

You can use INI options to specify the resolution used when importing WMF (Windows Metafile) graphic files using the AddMultiPageBitmap rule.

[ BitmapLoaders ]

WMFImportDPI = value

Parameter | Description
value | Enter the DPI (dots per inch) at which the WMF file will be rendered into raster format. The default is 100. The maximum DPI is 2400.

Remarks

This option controls the resolution at which the WMF graphic files will be imported. The default is 100. Increasing this number slows the import and increases output file size.

Example

[ BitmapLoaders ]

WMFImportDPI = 192

See Also

<BitmapLoaders>

PDFImportDPI

VectorGraphicImportDPI

Available

Release | 11.5
Patch |


VectorGraphicImportDPI

[BitmapLoaders]
VectorGraphicImportDPI

You can use INI options to specify the resolution used when importing graphic files (other than PDF and WMF files) using the AddMultiPageBitmap rule.

[ BitmapLoaders]

VectorGraphicImportDPI = value

Parameter | Description
value | Enter the DPI (dots per inch) at which graphic files (other than PDF and WMF files) will be rendered into vector format. The default is 100. The maximum DPI is 2400.

Remarks

This option controls the resolution at which the graphic files will be imported. The default is 100. Increasing this number slows the import and increases output file size.

Example

[ BitmapLoaders ]

VectorGraphicImportDPI = 192

See Also

<BitmapLoaders>

PDFImportDPI

WMFImportDPI

Available

Release | 11.5
Patch |


Booklets

Booklets

< Print >

Booklet =

Parameter | Description
Name of the booklet group | This option identifies the available booklet groups

Remarks

You can use Documaker Server to print booklets. A booklet is a 2-up duplex print format that can be stapled in the middle and folded to form a small book. Although the system does not impose a size limit, there is a practical limit on the number of pages that can be affixed in this manner. The system lets you customize the paper size, cover sheets, a custom blank page, and different size and tray selections for the cover sheet and booklet pages.

Example

< Booklets >

Booklet = MyBooklet

< Booklet:MyBooklet >

BookletPapersize =

BookletTray =

RightGutter =

BlankPage =

CoverSheet =

CoverFrontOut =

CoverFrontIn =

CoverBackOut =

CoverBackIn =

CoverTray =

Available

Release | Rel 11.5
Patch |


Booklet

Booklet

[ Print]

Booklet =

Parameter | Description
Name of the booklet group | This option identifies the booklet option to be used.

Remarks

You can use Documaker Server to print booklets. A booklet is a 2-up duplex print format that can be stapled in the middle and folded to form a small book. Although the system does not impose a size limit, there is a practical limit on the number of pages that can be affixed in this manner. The system lets you customize the paper size, cover sheets, a custom blank page, and different size and tray selections for the cover sheet and booklet pages.

Example

< Print >

Booklet = MyBooklet

< Booklets >

Booklet = MyBooklet

< Booklet:MyBooklet >

BookletPapersize =

BookletTray =

RightGutter =

BlankPage =

CoverSheet =

CoverFrontOut =

CoverFrontIn =

CoverBackOut =

CoverBackIn =

CoverTray =

Available

Release | Rel 11.5
Patch |


Booklet:NameOfBooklet

Booklet Options

  • BookletPapersize
  • BookletTray
  • RightGutter
  • BlankPage
  • CoverFrontOut
  • CoverFrontIn
  • CoverBackOut
  • CoverBackIn
  • CoverTray


BookletPapersize

[Booklet:NameOfBooklet]
BookletPapersize

[ Booklet:NameOfBooklet ]

BookletPapersize =

Parameter | Description
Paper size | Enter the paper size. The default is 11 x 17


BookletTray

[Booklet:NameOfBooklet]
BookletTray

[ Booklet:NameOfBooklet ]

BookletTray =

Parameter | Description
Booklet Tray | Entry the tray code for the booklet pages (non-cover), the default is 1


RightGutter

[Booklet:NameOfBooklet]
RightGutter

[ Booklet:NameOfBooklet ]

RightGutter =

Parameter | Description
Right Gutter | Specify the right shift past mid-point, in FAP units (2400 per inch). This right shift accommodates booklet thickness as pages are added to the booklet.


BlankPage

[Booklet:NameOfBooklet]
BlankPage

[ Booklet:NameOfBooklet ]

BlankPage =

Parameter | Description
Blank Page | Enter the name of the FAP file you want to use as a blank page. The system inserts blank pages as needed. This option just lets you specify a FAP file you want to be used in place of a blank page.


CoverFrontOut

[Booklet:NameOfBooklet]
CoverFrontOut

[ Booklet:NameOfBooklet ]

CoverFrontOut =

Parameter | Description
CoverFrontOut | Enter the name of the FAP file you want to use as the outside front cover.


CoverFrontIn

[Booklet:NameOfBooklet]
CoverFrontIn

[ Booklet:NameOfBooklet ]

CoverFrontIn =

Parameter | Description
CoverFrontIn | Enter the name of the FAP file you want to use as the inside front cover.


CoverBackOut

[Booklet:NameOfBooklet]
CoverBackOut

[ Booklet:NameOfBooklet ]

CoverBackOut =

Parameter | Description
CoverBackOut | Enter the name of the FAP file you want to use as the outside back cover.


CoverBackIn

[Booklet:NameOfBooklet]
CoverBackIn

[ Booklet:NameOfBooklet ]

CoverBackIn =

Parameter | Description
CoverBackIn | Enter the name of the FAP file you want to use as the inside back cover.


CoverTray

[ Booklet:NameOfBooklet ]

CoverTray =

Parameter | Description
CoverTray | Enter the tray ID for the cover sheet. The default is one (1).


Bookmark

Remarks

The FSIUSER.INI BOOKMARK control group configures the printing of form set bookmark pages. Bookmark pages are instruction pages within the form set. A bookmark page contains the message: "Insert form .... here," where the form number replaces the ellipsis. Use Bookmark pages if your company uses pull forms. The FAP file for the bookmark page must be in the FORMS subdirectory.

Bookmark Options

  • Name
  • Size


Name

[Bookmark]
Name

Name

NAME is the FAP file to print as the bookmark page.

[ Bookmark]

Name = File

Parameter | Description
File |

Remarks

Use the FSISYS.INI BOOKMARK control group to configure the printing of form set bookmark pages.

Bookmark pages are instruction pages within the form set. A bookmark page contains the message: "Insert form .... here," where the form number replaces the ellipsis. Use Bookmark pages if your company uses pull forms.

Example

< BOOKMARK >

NAME = STD80

Available

Release | _______
Patch |


Size

[Bookmark]
Size

Size

SIZE specifies the paper used for printing: L = Letter size (default) G = Legal size

[ Bookmark]

Size = L = Letter Size

Parameter

Description

List

Values can be

  • L - Letter Size
  • G - Legal Size

Default value is: L = Letter Size

Example

< BOOKMARK >

SIZE = L

Available

Release | _______
Patch |


CodePage

Remarks

The CODEPAGE.INI file is one of the initialization (INI) files used by the Documaker system to set system parameters and to enable or disable system features.

The CODEPAGE.INI file contains information about characters in various code pages.

Note an example of the codepage.ini is in the RPEX1 sample MRL.

The CODEPAGE.INI file contains these control groups:

Group Description

CODEPAGES Defines code pages

CODEPAGE Defines characters in code pages

Note

Use this CODEPAGE.INI group to specify character names and their associated code points in the different code pages listed in the first group.

Example

<CODEPAGE>

Char = SP010000, space, 32, 32, 32, 32

Char = SP020000, exclam, 33, 33, 33, 33

Char = SP040000, quotedbl, 34, 34, 34, 34

(lines omitted for brevity)

Char = LA160000, Acircumflex, 194,132,1-2, 0

Char = LA150000, acircumflex, 226,131,131,131

(etc.)

CodePage Considerations:

The CODEPAGE.INI file is one of the initialization (INI) files used bythe DAP system to set system parameters and to enable or disable system features.

The CODEPAGE.INI file contains information about characters in variouscode pages.

CodePage Options

  • Char


Char

[CodePage]
Char

Char

[ CodePage]

Char = Edit, Edit, Edit, Spin, Spin, Spin, Spin

Parameter | Description
AFPName | Name of the character when printing to an AFP printer.
PSTName | Name of the character when printing to a PostScript printer.
TTName | Name of the character when printing to a TrueType printer (not currently supported).
num1 | Code points for code pages specified in the CODEPAGES control group. In the example CODEPAGES group, this parameter defines the 1004.
num2 | Code points for code pages specified in the CODEPAGES control group. In the example CODEPAGES group, this parameter defines the 863.
num3 | Code points for code pages specified in the CODEPAGES control group. In the example CODEPAGES group, this parameter defines the 850.
num4 | Code points for code pages specified in the CODEPAGES control group. In the example CODEPAGES group, this parameter defines the 437.

Remarks

Use this CODEPAGE.INI group to specify character names and their associated code points in the different code pages listed in the first group.

Use the Char (character) option to specify character names and their associated code points in the different code pages listed in the CODEPAGES control group. Two sample character entries appear below:

<CODEPAGE>

Char = SP010000, space, 32, 32, 32, 32

Char = LA160000, Acircumflex, 194,132,182, 0

The first column is the name of the character when printing to an AFP printer. The second column is the name of the character when printing to a PostScript printer. The third column is the name of the character when printing to a TrueType printer (not currently supported). The remaining columns correspond to the code points for the code pages specified in the CODEPAGES control group. In the example CODEPAGES group, we have 4 code pages specified: 1004, 863, 850, and 437. Therefore, the last four columns represent code points for code pages 1004, 863, 850, and 437 respectively.

For example, the first char defined (the space character) has the following attributes:

Char = SP010000, space, 32, 32, 32, 32

AFP name = SP010000

PostScript name = space

TrueType name = (blank, not used)

1004 code point = 32

863 code point = 32

850 code point = 32

437 code point = 32

where as the A-Circumflex ( Â ) character has the following attributes:

Char = LA160000, Acircumflex, 194,132,182, 0

AFP name = LA160000

PostScript name = Acircumflex

TrueType name = (blank, not used)

1004 code point = 194

863 code point = 132

850 code point = 182

437 code point = 0 (not defined for this code page)

Therefore, if you were to convert a text file built using code page 863 (Canadian French) to code page 1004 (ANSI/FormMaker standard), any space characters would remain unchanged but any A-Circumflex ( Â ) characters would change from a 132 to a 194 code point.

Example

<CODEPAGE>

Char = SP010000, space, 32, 32, 32, 32

Char = SP020000, exclam, 33, 33, 33, 33

Char = SP040000, quotedbl, 34, 34, 34, 34

(lines omitted for brevity)

Char = LA160000, Acircumflex, 194,132,182, 0

Char = LA150000, acircumflex, 226,131,131,131

(etc.)

Available

Release | _______
Patch |


CodePages

Remarks

The CODEPAGE.INI file is one of the initialization (INI) files used by the Documaker system to set system parameters and to enable or disable system features.

The CODEPAGE.INI file contains information about characters in various code pages.

Note an example of the codepage.ini is in the RPEX1 sample MRL.

The CODEPAGE.INI file contains these control groups:

Group Description

CODEPAGES Defines code pages

CODEPAGE Defines characters in code pages

Example

<CODEPAGES>

CODEPAGE = 1004,W1

CODEPAGE = -63,CF

CODEPAGE = -50,PM

CODEPAGE = 437,PC

CodePage Considerations

The CODEPAGE.INI file is one of the initialization (INI) files used bythe DAP system to set system parameters and to enable or disable systemfeatures.

The CODEPAGE.INI file contains information about characters in variouscode pages.

CodePages Options

  • CodePage


CodePage

[CodePages]
CodePage

CodePage

The CODEPAGE option specifies an OS/2 code page.

[ CodePages]

CodePage = Edit, Edit

Parameter | Description
codepage | Code page number.
charSet | Internal character set name.

Remarks

The code page is OS/2 Code Page 1004. The two character abbreviation following the OS/2 code page number specifies an internal character set name used by some FormMaker font conversion utilities.

Example

<CODEPAGES>

CODEPAGE = 1004,W1

Available

Release | _______
Patch |


CommonFonts:XXX

Remarks

Use the CommontFonts control group to set up the common fonts to be used for normalized Metacode files. To use the feature of the normalized Metacode files, you would also need to set up the Normalize option in the Control group, and the PrtType control group with the class of XER. Please refer to Control group and PrtType:XER group for detailed information.

When creating normalized files, you can now use the CommonFonts INI option to specify more than one common font list in your INI file. Before this enhancement, the INI file only contained one generic common fonts list, as shown here:

< CommonFonts >

Name1 = font1

Name2 = font2

Name3 = font3

Name4 = font4

Names = 4

Now you can specify multiple common fonts lists via your printer control groups. For instance, if you are generating a normalized Metacode file, you would select a printer control group that contained a CommonFonts option that pointed to a common font list.

NOTE: If you do not specify a CommonFonts option in a printer control group, the system uses the information in the generic CommonFonts control group, as before.

In Studio, if you have different FXR files for each Common Fonts List group be sure to check out the Business Definition (BDF) file from the library and change the FXR file to match the FXR file for the Common Fonts List group being used. Otherwise, you may not be able to generate the normalized Metacode file.

To change FXR files in Studio, first select Manage, Application, Definition to check out the BDF file. Then change the FXR File Name option. You will need full access rights to do this.

CommonFonts Options

  • Name1


Name1

[CommonFonts]
Name1

Name1

[ CommonFonts]

Name1 =

Parameter | Description
value | To create normalized Metacode, Documerge and Printcommander users output Metacode files which have a common fonts list. This list includes all available fonts, not just those used on the form.

Remarks

To create normalized Metacode, Documerge and Printcommander users output Metacode files which have a common fonts list. This helps some Metacode printers print jobs at their highest rated speed.

Anytime you create normalized Metacode, be sure to create a common fonts list in your INI file by adding the CommonFonts control group, as shown here:

< CommonFonts >

Name1 = FORMSX

Name2 = FXCONB

Name3 = FXTIBF

Name4 = FXTIBJ

Name5 = FXTII0

. . .

Name34 = FXTIB0

Name35 = FXTIN0

Names = 35

Now you can specify multiple common fonts lists via your printer control groups. For instance, if you are generating a normalized Metacode file, you would select a printer control group that contained a CommonFonts option that pointed to a common font list.

< PrtType:XER >

CommonFonts = StatementCF

< PrtType:DP180 >

CommonFonts = PolicyCF

< CommonFonts:StatementCF >

Name1 = font1

Name2 = font2

...

< CommonFonts:PolicyCF >

Name1 = font1

Name2 = font2

...

< CommonFonts >

Name1 = font1

Name2 = font2

...

NOTE: If you do not specify a CommonFonts option in a printer control group, the system uses the information in the generic CommonFonts control group, as before.

In Studio, if you have different FXR files for each Common Fonts List group be sure to check out the Business Definition (BDF) file from the library and change the FXR file to match the FXR file for the Common Fonts List group being used. Otherwise, you may not be able to generate the normalized Metacode file.

To change FXR files in Studio, first select Manage, Application, Definition to check out the BDF file. Then change the FXR File Name option. You will need full access rights to do this.

You cannot skip a number (Name1, Name2, Name3, and so on) and the Names option at the end of the control group must equal the total in the list, as shown above. If, for instance, you had the following:

Name35 = FXTIB0

Name36 = FXTIN0

Names = 35

The font specified in the Name36 option would not be included in the normalized file. If you omit from the CommonFonts control group any of the fonts on the form you are converting to normalized Metacode, the system stops and displays a font validation error.

Be sure to include the FORMSX font. This is the standard Metacode business graphics font which is required for printing lines, boxes, and shading. Include it in your font list even if you do not plan to print graphical characters.

NOTE: In addition to setting up a common fonts list in the INI file, you must also make sure your font cross-reference file (FXR) is correct. For instance, every font being used should be in the FXR. For best results, every font listed in the common fonts list should be in the FXR.

Limitations

Keep in mind:

  • There is no support for text areas with embedded fields and charts, because these features are not supported by Documerge.
  • You can not mix using logos as fonts or as images. All logos must be represented as either fonts or images.
  • Only BSPD tags are supported in the normalized Metacode conversion.

To create a normalized Metacode file in Image Editor, follow these steps:

1. Select the Tools, Convert option and then select Normalized Metacode.

To open a normalized Metacode file in Image Editor, follow these steps:

1. Select the File, Open option and then select Normalized Metacode in the Files Of Type Picklist.

2. Select the file you want to open and click Ok. The image appears.

Once the image appears, you manipulate it just as you would a regular FAP file. For instance, you can save it as a FAP or normalized Metacode file, change it, or print it to any printer you have set up.

For DmStudio:

To create a normalized Metacode file in DmStudio Images:

1. Select Tools, Normalize option

To open a normalized Metacode file In DmStudio Images:

1. File, Open

2. Click Browse button

3. Change Files of Type to Normalized Metacode

4. Browse to the normalized file(s) you wish to open.

Example

< CommonFonts >

Name1 = FORMSX

Name2 = FXCONB

Name3 = FXTIBF

Name4 = FXTIBJ

Name5 = FXTII0

Available

Release | 10.2
Patch |


Company_Table

Remarks

The FSIUSER.INI Company_Table control group lets you designate the company name

that appears on the printed form. The company option syntax is:

COMPANY = COMPANY NAME

COMPANY is the company name exactly as it appears in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). COMPANY NAME is the company name as it appears on the printed forms.

Company_Table Options

  • Company


Company

[Company_Table]
Company

Company

[ Company_Table]

Company =

Remarks

The option name is user definable. Please refer to the Remarks under the [ Company_Table ] control group for details.

Example

< Company_Table >

Company =

Available

Release | _______
Patch |


CompatibilityOptions


Complete

Remarks

Use this FSIUSER.INI control group to define options in the Entry module's Complete Formset window. Prior to version 9.7, the Entry module-s Complete option performed several tasks when chosen. However, none of these options (except Export) could be omitted or configured in another manner. Version 9.7 lets you configure and split the Print/Export/Archive/Delete functionality into component steps, so you can include or exclude steps. There are four basic steps in the Complete function:

- Printing - immediate, batch, or none

- Export

- Archiving

- Deleting record

These options are turned on or off using FSISYS.INI or FSIUSER.INI definitions. If you want to hide or disable an option, include the comma before the appropriate keyword.

Complete Options

  • Archive
  • ArchiveExport
  • Delete
  • Export
  • ExportOnComplete
  • ExportOrigStatus
  • Print
  • SuppressDialog


Archive

[Complete]
Archive

Archive

The archive option controls the Archive field in the complete Formset window.

[ Complete]

Archive = Yes

Parameter | Description
Boolean (Yes) | The archive option controls the Archive field in the complete Formset window. This option is on by default. Default value is: Yes

Remarks

This option is on by default. When turned off, the Archive field is hidden. In addition, if turned off (and the WIP is not in "route"), the Mode indicator will be blank.

NOTE: This control has never been accessible by the user, and no new INI option is provided to hide the option other than to turn off Archive entirely.

Example

< Complete >

Archive = Yes

Available

Release | _______
Patch |


ArchiveExport

[Complete]
ArchiveExport

ArchiveExport

You can have the system export a form set when it manually archives the form set.

[ Complete]

ArchiveExport =

Parameter | Description
value | 1253 Exporting When Manually Archiving Now you can have the system export a form set when it manually archives the form set.

Remarks

Using INI options, you can make the system wait until archive is about to occur before it exports the form set. This makes sure the exported data accurately represents the archived document.

The system checks the ArchiveExport option to determine which export routine you want to use. It then loads the form set into memory. This is necessary for the export function, but not for archival.

NOTE: Using the ArchiveExport method does not affect the export feature on the Complete window. This is a separate export from the one started there.

The export function is called before the archival functions are called. This way, if an error occurs during the export, the archival process stops and returns the error. The form set is still in WIP, so you can correct the error.

To use this feature, include the ArchiveExport option in the Complete control group, as shown in this example:

< Complete >

ArchiveExport = DLL->FunctionName;SourceINI;DestINI;

The ArchiveExport option identifies the DLL and name of the export function you want to use. The export function does not have to be defined in the ExportFormats control group. Define the export function name the same way you define other entry hooks a DLL name followed by the name of the name of a function to dynamically call to do the export. Here is an example:

< Complete >

ArchiveExport = TRNW32->TRNExportV2;Export2;ExpFile_CD;

To handle different export options used when called in this manner, you can include two optional parameters after the export function name. Separate the parameters with semicolons. Each parameter names an INI control group that contain various options.

The first or source control group (Export2 in the example) specifies the INI control group which contains alternative INI options you want to apply to the second INI control group (ExpFile_CD in the example). The second or destination control group should be the control group normally associated with the export function you want to use.

In the example above, the system copies the INI settings found under the Export2 control group to the ExpFile_CD control group. The standard V2 export function then uses the ExpFile_CD control group to find its options.

Example

< Complete >

ArchiveExport = DLL->FunctionName;SourceINI;DestINI;

Available

Release | 10.1
Patch | 345


Delete

[Complete]
Delete

Delete

This step is now optional when archive is disabled.

[ Complete]

Delete = Yes

Parameter | Description
boolean (Yes) | This step is now optional when archive is disabled. The option is YES (enabled) by default. Default value is: Yes

Remarks

When archiving is enabled, the WIP record (and associated files in the WIP directory) are removed upon success. This option only has meaning when Archive has been disabled. There are no corresponding window controls affected by this option.

The option is YES (enabled) by default. When a WIP transaction is completed, normally it would be archived. If Archive is disabled, the WIP record (and associated files in the WIP directory) are deleted when the form set is completed, unless the Delete option is also turned off.

If you use this option, you must periodically purge the completed WIP items manually or via some other process.

If a user does not want to archive or delete the WIP records, this is permitted. When doing so, a status change is indicated in the WIP record that has been completed. Status codes are specified via INI group <STATUS_CD> definitions. Version 9.7 supports a new option under this group for COMPLETE. By default we define:

<STATUS_CD>

COMPLETE = C

Note: If you turn off the Archive and Delete options in the <COMPLETE> group, this option alters the status of completed records to prevent the WIP records from being available for edit or print again.

Example

< Complete >

Delete = Yes

Available

Release | 10.1
Patch |


Export

[Complete]
Export

Export

This Export option controls the Export field in the Complete Formset window.

[ Complete]

Export = YN

Parameter | Description
Boolean (Yes) | Yes or No; Default is Yes

Remarks

This option is on by default. When turned off, the Export field and Export list are hidden. Version 9.5 supported the following INI option which you can use to control whether the Export field is initially checked, disabled, and/or hidden.

<COMPLETE>

ExportOnComplete = No[Yes], Hidden, Disabled

This option still applies, however in version 9.7, if the Export field is not checked but is turned off or hidden, the Export list will also be hidden since it is not possible for a user to make such a selection.

Example

<COMPLETE>

Export = Yes

Available

Release | _______
Patch |

Used By

AFEMAIN


ExportOnComplete

[Complete]
ExportOnComplete

ExportOnComplete

[ Complete]

ExportOnComplete = No

Parameter | Description
value | Default value is: No

Remarks

The ExportOnComplete option supported by Version 9.5 controls whether the Export field in the Complete Formset window is initialized.

This option still applies in version 9.7, however, if the export field is not checked but is turned off or hidden, the Export list will also be hidden since it is not possible for a user to make such a selection.

Example

<COMPLETE>

ExportOnComplete = No, Hidden, Disabled

Available

Release | 10.1
Patch |

Used By

AFEMAIN


ExportOrigStatus

[Complete]
ExportOrigStatus

ExportOrigStatus

Saves and exports original option.

[ Complete]

ExportOrigStatus =

Parameter | Description
value | value

Available

Release | 9.6
Patch |


Print

[Complete]
Print

Print

The Print option controls the Print field in the Complete Formset window.

[ Complete]

Print = YN

Parameter | Description
Boolean (Yes) | Yes or No; Default is Yes

Remarks

This option is on by default. If you set it to No, then all of the print controls are hidden from view on the Complete window. In addition, you can now configure the individual print options (Immediate or Batch), hiding or protecting these options so entry users cannot change them.

For more information on these options, see:

<CONTROL>

PrintOnComplete

BatchOnComplete

ImmediateOnComplete

Example

<COMPLETE>

Print = Yes

Available

Release | _______
Patch |

Used By

AFEMAIN


SuppressDialog

[Complete]
SuppressDialog

SuppressDialog

This option, if set to Yes, suppresses the Complete Formset dialog and instead displays an OK message when the user selects.

[ Complete]

SuppressDialog = No

Parameter | Description
Boolean | Default value is: No

Example

< Complete >

SuppressDialog = No

Available

Release | 10.1
Patch |

Used By

AFEMAIN


CompressWIPFiles

CompressWIPFiles Options

  • Extension


Extension

[CompressWIPFiles]
Extension

Extension

WIP compression provides another way to store WIP.

[ CompressWIPFiles]

Extension =

Parameter | Description
value | WIP compression provides another way to store WIP.

Remarks

This method uses the same storage format as the email attachment. It saves each WIP form set as a single

compressed file rather than the two or more current WIP files, such as *.dat; *.pol, *.pkg.

To use WIP compression, you must add these INI options:

[ AfeProcedures ]

AfeCompressWipFunc = AFEW32->AFEPackWipFilesFunc

[ CompressWipFiles ]

Extension = CWP

Since the default extension is CWP, the extension is not required in the example above. You must add the extension if you want to use an extension other than CWP. The benefit is that only one smaller file per form set will be kept in the network WIP directory, which conserves disk space.

NOTE: If you are using compressed mode, you can work with compressed and noncompressed form sets. In standard mode, you can only work with noncompressed form sets. Your system supervisor can, however, switch modes at any time.

Changing to the WIP compressed mode does not delete existing WIP files from the WIP directory.

Example

< CompressWipFiles >

Extension = CWP

Available

Release | 10.0
Patch |


CompuSet

Remarks

You have three ways to convert Document Sciences CompuSet scripts into Documaker section (FAP) files:

(1) Use the CSET2FAP utility (i.e. CS2FPW32.EXE) for batch conversions,

(2) Use Documaker Studio's Conversion wizard to convert the file, or

(3) Configure your INI file to load CompuSet scripts directly into Image Editor

The CompuSet group lets you specify the settings used by the CompuSet converter.

NOTE: The full set of CompuSet logic has not yet been implemented, but the converter should greatly reduce the work necessary in converting a Document Sciences resource base into a Documaker resource base. Support is currently provided (at least partially) for these commands: BD, BL, BOX, CB, CC, COLOR, CP, CW, DL, EL, F, HR, JU, LT, NL, NP, NPR, PA, PD, PT, PW, QL, QR, SK, SP, T, TABC, TABJ, TABL, TABR, UL, and VR.

The Documaker system can use the same font files as the Document Sciences system. To enable this, first copy the font files into your Documaker Metacode resource directory. This is the same place the Metacode fonts provided by Documaker are located. Then use Font Manager to import the fonts. Specify the name of the new font cross-reference (FXR) file in the XRFFile option of the MasterResource control group.

The CompuSet converter uses these INI options:

< CompuSet >

MasterStyles =

Config =

ExtremeLogging =

< MasterResource >

DefLib =

< Config:XXX >

XRFFile =

If you use Documaker Studio's Conversion wizard, you can specify the Style, Configuration and the XFR files within the wizard without the INI settings. If you use the command line utility, you can supply the Style and Configuration file names and turn on Logging via the command line parameters (i.e. /S=<file>, /C=<file>, and /L) without the INI settings. If you use Image Editor, then you must set up the CompuSet control group and the following INI options:

< Loaders >

Loader = xxx (Note: xxx is the loader name)

< Loader:xxx >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

Please refer to the Loader:xxx group for more information.

To open a CompuSet script file in Image Editor, choose File, Open, and select Compuset files (*.TXT) in the Files of Type field. Image Editor filters the file list to show only files with the extension TXT (case insensitive). Highlight a CompuSet script file and click Open.

NOTE: Because the conversion support is not complete for all CompuSet commands, you may receive some error messages.

If you have fonts you use as logos, you must first convert them to LOG files. Then, enter the root file name for each logo in the LOGO.DAT file. The LOGO.DAT file should reside in the current working directory. The LOGO.DAT file is a semicolon-delimited text file that names the various rotations of logo fonts and it should look similar to this:

[file name for 0° rotation];[file name for 90° rotation];[file name

for 180°rotation];[file name for 270° rotation];

Any of the rotations can be left out, but you must include the semicolon as a delimiter.

NOTE: The logo fonts should not be present in the FXR since the converter uses not finding a font as a trigger to look for a logo.

Example

< CompuSet>

Config = c:\compuset\x9700.cnf

MasterStyles = c:\compuset\midtest.sty

ExtremeLogging = T

< Loader:CompuSet >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loaders >

Loader = Compuset

CompuSet Options

  • Config
  • ExtremeLogging
  • MasterStyles


Config

[CompuSet]
Config

Config

[ CompuSet]

Config = File

Parameter | Description
File |

Remarks

The Config option lets you specify the path and name of the file that contains logical and machine font definitions and the font files in which they are located. You can use relative path (e.g. Config = x9700.cnf) or absolute path (e.g. Config = c:\Msttres\x9700.cnf).

If you use the command line utility, the command line parameter /C= overrides the Config= INI option.

Example

< CompuSet>

Config = x9700.cnf

MasterStyles = midtest.sty

ExtremeLogging = T

< Loader:CompuSet >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loaders >

Loader = Compuset

Available

Release | 11.0
Patch |


ExtremeLogging

[CompuSet]
ExtremeLogging

ExtremeLogging

[ CompuSet]

ExtremeLogging = YN

Parameter | Description
Boolean (No) |

Remarks

Set the ExtremeLogging option to T or True to view all of the debug information when creating a FAP file from a Document Sciences file. The system defaults to F or False. If you use the CSET2FAP utility (i.e. CS2FPW32.EXE), you can use /L command line parameter to turn on this setting.

Example

< CompuSet>

Config=c:\compuset\x9700.cnf

MasterStyles=c:\compuset\midtest.sty

ExtremeLogging = T

< Loader:CompuSet >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loaders >

Loader = Compuset

Available

Release | 11.0
Patch |


MasterStyles

[CompuSet]
MasterStyles

MasterStyles

The MasterStyles option lets you specify the global styles definition file name.

[ CompuSet]

MasterStyles = File

Parameter | Description
File |

Remarks

The MasterStyles option lets you specify the global styles definition file path and name. You can use relative path (e.g. MasterStyles = midtest.sty) or absolute path (e.g. MasterStyles = c:\Msttres\midtest.sty).

If you use the command line utility, the command line parameter /S= overrides the MasterStyles= INI option.

Example

< CompuSet>

Config=c:\compuset\x9700.cnf

MasterStyles=c:\compuset\midtest.sty

ExtremeLogging = T

< Loader:CompuSet >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loaders >

Loader = Compuset

Available

Release | 11.0
Patch |


Configurations

Configurations Options

  • Config


Config

[Configurations]
Config

Config

The CONFIG option defines the name of the company master resource library.

[ Configurations]

Config = Edit

Parameter | Description
Library Name | master resource library name

Remarks

The libraries named in the CONFIGURATIONS control group are the libraries that will appear on the Resource Path Setup Screen in Documaker Studio or in the Setup Master Resource Libraries window in Documaker Workstation or Docucreate system. Details for the library are listed in the <CONFIG:xxx > control group (xxx being the library name).

Note: If there is more than one resource library, the user should always use the Reourse Path Setup screen in Documaker Studio or the Setup Master Resource Libraries window in Documaker Workstation or Docucreate system to make changes to the libraries.

Example

<Configurations>

CONFIG = Sampco

CONFIG = RPEX1

CONFIG = HP Internal Fonts

Available

Release | _______
Patch |

Used By

AFEMAIN


Config:XXX

Config:
XXX

Remarks

The FSIUSER.INI CONFIG:xxx control group (where xxx is the library name) lists the file names and directory paths you specified for your resource library during setup. If you divide your master resource library into smaller, separate libraries, the system creates a new control group for each library.

Note: In the RP and Documaker Processing and Development Systems, you can use the File, Library Setup option to enter this information.

Config:XXX Options

  • ARCPath
  • BaseDef
  • CARPath
  • DALFile
  • Deflib
  • FntFile
  • FontLib
  • Form7x
  • FormDef
  • FormLib
  • FormsetTrigger
  • HelpLib
  • LogoFile
  • LbyScriptLib
  • TableLib
  • WIPPath
  • XrfFile


ARCPath

[Config:XXX]
ARCPath

ARCPath

ARCPath is the directory path of the archived files.

[ Config:XXX]

ARCPath = Path

Parameter | Description
Path |

Remarks

The FSIUSER.INI CONFIG:xxx control group (where xxx is the library name) lists the file names and directory paths you specified for your resource library during setup. If you divide your master resource library into smaller, separate libraries, the system creates a new control group for each library.

Note: In the RP and DAP Processing and Development Systems, you can use the File, Library Setup option to enter this information.

Available

Release | _______
Patch |


BaseDef

[Config:XXX]
BaseDef

BaseDef

BaseDef is the file name of the list of form definition files.

[ Config:XXX]

BaseDef = File

Parameter | Description
File |

Available

Release | _______
Patch |


CARPath

[Config:XXX]
CARPath

CARPath

CarPath specifies the directory path of the compressed archive files.

[ Config:XXX]

CARPath = Path

Parameter | Description
Path |

Remarks

This option lets you define the Path for the CarFile, which is the compressed archive file.

Example

< Config:XXX >

CARPath =

Available

Release | _______
Patch |


DALFile

[Config:XXX]
DALFile

DALFile

The DALFile option specifies the directory path of library DAL files.

[ Config:XXX]

DALFile = File

Parameter | Description
File |

Available

Release | _______
Patch |


Deflib

[Config:XXX]
Deflib

Deflib

[ Config:XXX]

Deflib = Path

Parameter | Description
Path |

Remarks

DefLib names the directory path of Form set definition file and FXR files (default location of font files).

Available

Release | _______
Patch |


FntFile

[Config:XXX]
FntFile

FntFile

FntFile is the file name of the downloadable font spool file.

[ Config:XXX]

FntFile = File

Parameter | Description
File |

Available

Release | _______
Patch |


FontLib

[Config:XXX]
FontLib

FontLib

FontLib specifies the directory path of font files if the location is different from the DefLib option.

[ Config:XXX]

FontLib = Path

Parameter | Description
Path |

Available

Release | _______
Patch |


Form7x

[Config:XXX]
Form7x

Form7x

The Development System uses the Form7x option to determine where to store FAP files created in version 7.0 format.

[ Config:XXX]

Form7x = Path

Parameter | Description
Path |

Available

Release | _______
Patch |


FormDef

[Config:XXX]
FormDef

FormDef

FormDef is the file name of the form set definition file.

[ Config:XXX]

FormDef = File

Parameter | Description
File |

Remarks

The Form set definition file (form.dat, .BDF, .GRP, or .FOR) specifies the forms currently being used in the system. This file, also known as the Form Set Definition Table, contains information about the KEY field plus information about each image in the form, its recipients, and the form set itself.

Available

Release | _______
Patch |


FormLib

[Config:XXX]
FormLib

FormLib

FormLib specifies the directory path of library forms and logos.

[ Config:XXX]

FormLib = Path

Parameter | Description
Path |

Available

Release | _______
Patch |


FormsetTrigger

[Config:XXX]
FormsetTrigger

FormsetTrigger

This option specifies the name of the form set trigger file.

[ Config:XXX]

FormsetTrigger = File

Parameter | Description
File |

Remarks

The form set trigger file is used with the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to build form sets and to specify recipient batches given specific transaction types and other dependent conditions. It is also used to describe overflow conditions.

Available

Release | _______
Patch |


HelpLib

[Config:XXX]
HelpLib

HelpLib

HelpLib is the directory path of the form related help information.

[ Config:XXX]

HelpLib = Path

Parameter | Description
Path |

Available

Release | _______
Patch |


LbyScriptLib

LbyScriptLib

[ MasterResource]

LbyScriptLib = Path

Parameter | Description
value |

Remarks

This option defines the location of Library Script files for Documaker Studio.

Example

< MasterResource >

LbyScriptLib = <Config:xxx> LbyScriptLib =

Available

Release | 11.4
Patch |


LogoFile

[Config:XXX]
LogoFile

LogoFile

LogoFile defines the directory path of library logo files.

[ Config:XXX]

LogoFile = File

Parameter | Description
File |

Available

Release | _______
Patch |


TableLib

[Config:XXX]
TableLib

TableLib

The TableLib option is the directory path of the form related table information.

[ Config:XXX]

TableLib = Path

Parameter | Description
Path |

Available

Release | _______
Patch |


WIPPath

[Config:XXX]
WIPPath

WIPPath

WIPPath defines the directory path of the WIP database and all data files saved to WIP.

[ Config:XXX]

WIPPath = Path

Parameter | Description
Path |

Available

Release | _______
Patch |


XrfFile

[Config:XXX]
XrfFile

XrfFile

The XRF File option is the name of the font cross reference file.

[ Config:XXX]

XrfFile = File

Parameter | Description
File |

Available

Release | _______
Patch |


Control

Example

< Control >

Arrangement = Stack

AutoFocus = Yes

CacheFAPFiles = 100

CacheMethod = LFUO

CaseSensitiveKeys = No

CheckInArc = Yes

DispFields = No

DisplayPrintOnly = No

DoFormDescLines = Yes

DoFormSelection = Yes

FitToWidth = Yes

FlushLogFile = Yes

ImageExt = .FAP

ImageFormat = ASC

LogCaching = Yes

LogEnabled = Yes

LogoExt = .LOG

LogToConsole = Yes

LogTransactions = Yes

Maximized = Yes

NoLoadFormList = No

NoTitleBar = No

R_Option = Not Required

RuleFilePool = 100

Title = FAP Entry

WIPListMaxRecords = 100

XrfExt = .FXR

ZoomDiv = 1

ZoomMult = 1

Control Options

  • ActivateFirstField
  • ActiveFieldBackColor
  • ActiveFieldColor
  • ActiveFieldHighlight
  • ActualSize
  • AllowMultiPrint
  • Arrangement
  • AutoFocus
  • AutoIncreaseOffsetLengths
  • AutoKeyIdWarnCount
  • AutoPopupTableOnly
  • AutoSave
  • AutoSaveTime
  • BatchOnComplete
  • CacheFAPFiles
  • CacheFORFiles
  • CacheLogoFiles
  • CacheMethod
  • CaseSensitiveKeys
  • CenterFormTitles
  • ChartLegendIconSize
  • CheckInArc
  • ChkSpellWhenExit
  • CompressMethod
  • CompressLevel
  • ConfirmApplExit
  • ConfirmFormExit
  • ConfirmObjDelete
  • ConfirmRevert
  • ConfirmSaveChanges
  • ConfirmUndo
  • CreateMode
  • CrossHairs
  • DateFmt2To4Year
  • DefaultFieldColor
  • DefaultPlaceColor
  • DefaultPrint
  • DispFields
  • DisplayAllEntryFormPages
  • DisplayOnlyEntry
  • DisplayPrintOnly
  • DoFormDescLines
  • DoFormsSelection
  • DosImageOptionsOnly
  • EntryErrorBeep
  • EntryMode
  • ErrorFileDateStamp
  • ExportOnComplete
  • FilterRecip
  • FirstPieSliceAngle
  • FitToWidth
  • FitToWindow
  • FixedPosFields
  • FlushLogFile
  • ForceTableOnlySelection
  • GuideBoxes
  • HiddenGroupPrefix
  • HideFormSelImport
  • HideFormSelRetrieve
  • HorizontalRuler
  • ImageExt
  • ImageFormat
  • ImmediateOnComplete
  • ImmediateTranslate
  • LightShade
  • LimitDDTs
  • LimitPageBreak
  • LoadPrintOnly
  • LogCaching
  • LogEnabled
  • LogFileDateStamp
  • LogINIFileNames
  • LogINIOptions
  • LogoExt
  • LogToConsole
  • LogTransactions
  • Margins
  • Maximized
  • MaxPOLLineLength
  • Mobius
  • ModePointers
  • NewlineEscape
  • NoKey2Changes
  • NoLoadFormList
  • Normalize
  • NormalizeXER
  • NoTitleBar
  • Print
  • PrintDraft
  • PrintNotifyText
  • PrintOnComplete
  • PromptImageInfo
  • R_Option
  • ReceiveMailMsgCount
  • ReceiveMailOnWipList
  • RequiredFields
  • RuleFilePool
  • ShowEffectiveDate
  • ShowNotes
  • SkipAFEEligibleCheck
  • SortedSetRcp
  • SuppressAssign
  • TemplateDelimiters
  • TemplateNumber
  • TemplateUseReplaceChar
  • TemplateWithName
  • Title
  • TXMRulers
  • TXMStatusLine
  • TXMTitleBar
  • TXMToolBar
  • UseBaseDef
  • ValidateTableOnlyKey
  • WIPListMaxRecords
  • XrfExt
  • Zoom
  • ZoomDiv
  • ZoomMult
  • ZoomMulti


ActivateFirstField

[Control]
ActivateFirstField

ActivateFirstField

Lets you configure the system so users can begin entry on a page that has no variable fields.

[ Control]

ActivateFirstField = Yes

Parameter | Description
Boolean (Yes) | Lets you configure the system so users can begin entry on a page that has no variable fields. Default value is: Yes

Remarks

Normally users begin entry on the first page with editable fields.

To cause the first page of a form to be the initial page, even when it does not contain entry fields, set the following option to No.

< Control >

ActivateFirstField = No

This field defaults to Yes which tells the system to display the first form with an active entry field. If you set the ActivateFirstField option to No, the system displays the first viewable page of a form set. Keep in mind that viewable pages are determined by the DisplayPrintOnly or the DisplayAllEntryFormPages option.

To override this behavior and cause the first page of a form to be the initial page, even when it does not contain entry fields, set the following option to No.

This field defaults to Yes which tells the system to display the first form with an active entry field. If you set the ActivateFirstField option to No, the system displays the first viewable page of a form set. Keep in mind that viewable pages are determined by the DisplayPrintOnly or the DisplayAllEntryFormPages option.

Example

< Control >

ActivateFirstField = No

Available

Release | 10.1
Patch |


ActiveFieldBackColor

[Control]
ActiveFieldBackColor

ActiveFieldBackColor

The back color in the field you are working in. UNIX only.

[ Control]

ActiveFieldBackColor = Color

Parameter | Description
Color |

Example

< Control >

ActiveFieldBackColor = 1

Available

Release | _______
Patch |


ActiveFieldColor

[Control]
ActiveFieldColor

ActiveFieldColor

[ Control]

ActiveFieldColor = Color

Parameter | Description
Color |

Example

< Control >

ActiveFieldColor = 0

Available

Release | _______
Patch |


ActiveFieldHighlight

[Control]
ActiveFieldHighlight

ActiveFieldHighlight

Lets you turn on or off the active field highlighting for WIP and archive retrieval.

[ Control]

ActiveFieldHighlight = Yes

Parameter | Description
boolean (Yes) | Lets you turn on or off the active field highlighting for WIP and archive retrieval. Default value is: Yes

Remarks

The default is to highlight the fields, as in WIP mode.

Setting this option determines whether or not the system highlights the active field on a form.

< Control >

ActiveFieldHighlight = Yes or No

The default is Yes.

Example

< Control >

ActiveFieldHighlight = No

Available

Release | 10.0
Patch |


ActualSize

[Control]
ActualSize

ActualSize

Use ActualSize, FitToWidth, FitToWindow, and Zoom to setup the default zoom settings in Documaker Workstation and Image Editor.

[ Control]

ActualSize = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The following INI option sets the default zoom setting to "Actual Size."

< Control >

ActualSize = Yes

The following INI options set the default zoom setting to "FitToWidth" (i.e. to display the full width of the image in the system window. This lets you see the full width of an image if it is larger than your window).

< Control >

ActualSize = No

The following INI options set the default zoom setting to "FitToWindow" (i.e. to display the entire image in an active window. This lets you see the image from top to bottom as a whole unit on the screen.)

< Control >

ActualSize = No

FitToWidth = No

FitToWindow = Yes

The following INI options set the default zoom setting to "Zoom %."

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

ZoomMult =

ZoomDiv =

If you use Image Editor, you can set up the default zoom settings by selecting Options, Editor Properties, Zoom tab.

Example

< Control >

ActualSize = Yes

Available

Release | _______
Patch |


AllowMultiPrint

[Control]
AllowMultiPrint

AllowMultiPrint

The AllowMultiPrint option lets users complete a form set and keep it in WIP if the option is set to Yes.

[ Control]

AllowMultiPrint = No

Parameter | Description
Boolean (No) | Yes or No (default) Default value is: No

Example

< Control >

AllowMultiPrint = Yes

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


Arrangement

[Control]
Arrangement

Arrangement

Arrangement specifies the default arrangement of form windows (Cascade, Stack, Stack-only, or Tile).

[ Control]

Arrangement = LimitList

Parameter

Description

value

Cascade, Stack, Stack-only, or Tile

Values can be

  • Cascade
  • Stack
  • Stack-only
  • Tile

Remarks

This option sets Stack as the default display mode for images in the Image Editor. The user can still select cascade or tile from the Window menu options.

Example

<Control>

Arrangement = Stack

Available

Release | _______
Patch |

Used By

AFEMAIN, IMGED


AutoFocus

[Control]
AutoFocus

AutoFocus

[ Control]

AutoFocus = YN

Parameter | Description
Boolean | Yes or No

Remarks

AutoFocus appears under the Options menu in the Entry System. With AutoFocus active, the system always displays the active field within the viewing screen. To activate AutoFocus by default, set this option to Yes. Users can still deselect Autofocus from the Entry System menu.

Available

Release | _______
Patch |

Used By

AFEMAIN


AutoIncreaseOffsetLengths

[Control]
AutoIncreaseOffsetLengths

AutoIncreaseOffsetLengths

[ Control]

AutoIncreaseOffsetLengths = Yes

Parameter | Description
Boolean (Yes) | The lengths of the X_Offset, NA_Offset, and POL_Offset fields utilized in Batch processing will be automatically increased to a length (usually 19) that will support large (> 2 gig) files offsets.

The TRNFILE, NEWTRN, and Recipient Batch files all require these fields to be defined. If set to No, the lengths of these fields remain set to the value specified in the appropriate DFD file.

Example

< Control >

AutoIncreaseOffsetLengths = No

Available

Release | 12.1
Patch |


AutoKeyIdWarnCount

[Control]
AutoKeyIdWarnCount

AutoKeyIdWarnCount

This option is set to a numeric threshold value to alert the user when applicable automatic policy numbers run low.

[ Control]

AutoKeyIdWarnCount = Spin

Parameter | Description
Spin |

Remarks

If this INI option is used, a warning message is generated when the number of available policy numbers reaches the threshold value of the statement; otherwise, no warning is issued until policy numbers have run out. If you omit this option, the system warns the user when he or she assigns the last number in the database table. If you do not generate a new set of KEYIDs, the system ignores any subsequent attempt to retrieve a KEYID from the database table. The user will not see another message. If you do not want to receive any warning messages about the lack of KEYIDs, set this option to 0. The maximum value is 1000.

Example

< Control >

AutoKeyIDWarnCount = 0

Available

Release | _______
Patch |


AutoPopupTableOnly

[Control]
AutoPopupTableOnly

AutoPopupTableOnly

[ Control]

AutoPopupTableOnly = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

By default, the AutoPopupTableOnly option is set to Yes. This means table-only fields will pop up automatically if they are empty, and not archive mode, and the table is defined. To stop table-only fields from automatically popping up, set this option to No.

Example

<Control>

AutoPopupTableOnly = Yes

Available

Release | _______
Patch |


AutoSave

[Control]
AutoSave

AutoSave

Set this option value to Yes to have images saved automatically in the Image Editor.

[ Control]

AutoSave = YN

Parameter | Description
Boolean | Set this option value to Yes to have images saved automatically in the Image Editor. Save option may be set on the Save tab of the Editor Properties window.

Remarks

Save option may be set on the Save tab of the Editor Properties window.

Example

< Control >

AutoSave = No

Available

Release | _______
Patch |


AutoSaveTime

[Control]
AutoSaveTime

AutoSaveTime

Tells the system the interval at which to perform an autosave of the fap file.

[ Control]

AutoSaveTime = Spin

Parameter | Description
Spin |

Remarks

Values are 1, 2, 3, 4, 5 for 1 minute, 2 minutes, etc.

Example

< Control >

AutoSaveTime = 5

Available

Release | 11
Patch |


BatchOnComplete

[Control]
BatchOnComplete

BatchOnComplete

The BatchOnComplete option affects the Batch print option on the Complete Formset window.

[ Control]

BatchOnComplete = No

Parameter | Description
value | Default value is: No

Remarks

It can be hidden or disabled from change and can be initially checked or not checked. The system determines the default setting for this option by examining the <CONTROL> DefaultPrint option. If this option indicates BATCH, then the batch option is enabled by default but will be changed if the BatchOnComplete option has a different setting. The format for the BatchOnComplete option is:

<CONTROL>

BatchOnComplete = No[Yes], Hidden, Disabled

If both the Batch and Immediate options are checked on or off, Immediate becomes the default. If, however, one option is turned off and the other is turned on, the enabled (on) option becomes the default, regardless of the INI setting. As always, when batch print is selected, the WIP transaction is not archived or deleted until that process is complete.

Example

<CONTROL>

BatchOnComplete = No[Yes], Hidden, Disabled

Available

Release | _______
Patch |


CacheFAPFiles

[Control]
CacheFAPFiles

CacheFAPFiles

Number of FAP files to cache.

[ Control]

CacheFAPFiles = 100

Parameter | Description
value | Number of FAP files to cache Default value is: 100

Remarks

The CacheFAPFiles option specifies the number of frequently used FAPs to keep available for re-use without reloading them from disk.

Use the cache feature for FAP, DDT, and PMET files if the number of these files is over 100. It will reduce the number of times the system has to open and close these files.

Here is an example of where you set the cache:

< Control >

CacheFAPFiles =100(Default is 100)

RuleFilePool = 100(Default is 100)

Caching pre-compiled Metacode files (PMETs) has a big effect on the GenPrint program. Here is an example of where you can set the cache for pre-compiled Metacode files:

<PRTType:XER>

CacheFiles = 100 (Default is 100)

InitFunc = XERInit

TermFunc = XERTerm

NOTE: You must include the InitFunc and TermFunc options in the PRTType:XER control group to enable caching.

Example

< Control >

CacheFAPFiles = 200

Available

Release | 10.0
Patch |

Used By

GENARC, GENDATA, GENPRINT


CacheFORFiles

[Control]
CacheFORFiles

CacheFORFiles

Number of FOR files to cache.

[ Control]

CacheFAPFiles = 100

Parameter | Description
value | Number of FOR files to cache Default value is: 100

Remarks

The CacheFORFiles option specifies the number of frequently used FORs to keep available for re-use without reloading them from disk.

Here is an example of where you set the cache:

< Control >

CacheFORFiles =100(Default is 100)

RuleFilePool = 100(Default is 100)

Caching pre-compiled Metacode files (PMETs) has a big effect on the GenPrint program. Here is an example of where you can set the cache for pre-compiled Metacode files:

<PRTType:XER>

CacheFiles = 100 (Default is 100)

InitFunc = XERInit

TermFunc = XERTerm

NOTE: You must include the InitFunc and TermFunc options in the PRTType:XER control group to enable caching.

Example

< Control >

CacheFORFiles = 200

Available

Release | 11.4
Patch |

Used By

GENARC, GENDATA, GENPRINT


CacheLogoFiles

[CONTROL]
CacheLogoFiles

CacheLogoFiles

Number of LOG files to cache.

[ Control]

CacheLogoFiles = 100

Parameter | Description
value | Number of LOG files to cache Default value is: 100

Remarks

The CacheLOGFiles option specifies the number of frequently used logos to keep available for re-use without reloading them from disk.

Here is an example of where you set the cache:

< Control >

CacheLOGFiles =100(Default is 100)

RuleFilePool = 100(Default is 100)

Caching pre-compiled Metacode files (PMETs) has a big effect on the GenPrint program. Here is an example of where you can set the cache for pre-compiled Metacode files:

<PRTType:XER>

CacheFiles = 100 (Default is 100)

InitFunc = XERInit

TermFunc = XERTerm

NOTE: You must include the InitFunc and TermFunc options in the PRTType:XER control group to enable caching.

Example

< Control >

CacheFORFiles = 200

Available

Release | 11.4
Patch |

Used By

GENARC, GENDATA, GENPRINT


CacheMethod

[Control]
CacheMethod

CacheMethod

Indicates which type of caching method (or algorithm) to use.

[ Control]

CacheMethod = List

Parameter

Description

value

LFUO | LFU | LRU

Values can be

  • LFUO
  • LFU
  • LRU

Remarks

Caching attempts to keep frequently and/or recently used objects in memory so that if these objects are needed again they can be retrieved quickly without the need to read them from disk. The values below indicate which caching method to use to determine which object to purge from the cache when the cache is full and another item needs to be added.

LFUO - Least Frequently Used Optimized

LFU - Least Frequently Used

LRU - Least Recently Used

Caching statistics for FAP files, DDT files and Xerox resources such as pre-compiled Metacode files (PMETs) and forms (FRMs) are collected and can be placed in the LOGFILE.DAT file. These statistics show how many files are being cached and how many cache hits, misses, and purges occurred.

Example

< Control >

CacheMethod = LFUO

Available

Release | 10.1
Patch |

Used By

GENARC, GENDATA, GENPRINT


CaseSensitiveKeys

[Control]
CaseSensitiveKeys

CaseSensitiveKeys

[ Control]

CaseSensitiveKeys = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

If the CaseSensitiveKeys option is set to No, the Documaker Workstation will store the data for the key fields (i.e. Company, LOB,and Policy or Account #) in the WIP and/or Archive Index file in uppercase when the formset is saved and/or completed, and the system will ignore the case of the search keys when searching in the Archive Index file for formset retrieval. If set to Yes, the system will store the data for the key fields in the WIP and/or Archive Index file in the case as they are entered and will do a case sensitive search in the Archive Index file for archive retrieval. The default is NO.

The Documaker Rules Processing System (single step GenData or GenArc) is using the CaseSensitiveKeys option under the Archival control group instead.

Example

< Control >

CaseSensitiveKeys = No

Available

Release | _______
Patch |

Used By

AFEMAIN, CSTLIB, DPRLIB, RACLIB, TRNLIB, XMPLIB


CenterFormTitles

[Control]
CenterFormTitles

CenterFormTitles

[ Control]

CenterFormTitles = No

Parameter | Description
boolean (No) | Default value is: No

Remarks

The ability to override the default windows behavior and center the titles on dialogs was added to Development Tools as well as the Documaker Workstation.

In order to center your titles for the Development Tools modules, you would need to add the following INI option to the [Control] group in your fapcomp.ini:

[Control]

CenterFormTitles = Yes/No

The default is to left justify the form titles.

Example

< Control >

CenterFormTitles = Yes/No

Available

Release | 10.0
Patch |


ChartLegendIconSize

[Control]
ChartLegendIconSize

ChartLegendIconSize

You can use the ChartLegendIconSize option to override the default size of chart legend icons.

[ Control]

ChartLegendIconSize =

Parameter | Description
value | You can use the ChartLegendIconSize option to override the default size of chart legend icons.

Remarks

Specify the width and height (200,200) in FAP units and separate them with a comma. Line icons are not affected.

Example

< Control >

ChartLegendIconSize = 200,200

Available

Release | 10.2
Patch |


CheckInArc

[Control]
CheckInArc

CheckInArc

The CheckInArc option checks whether the policy number entered is unique in the archive index.

[ Control]

CheckInArc = No

Parameter | Description
Boolean (No) | If the CheckInArc option is defined as Yes, the clashing record may have been located in the archive file. Default value is: No

Remarks

If the CheckInArc option is defined as Yes, the clashing record may have been located in the archive file.

Example

< Control >

CheckInArc = Yes

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


ChkSpellWhenExit

[Control]
ChkSpellWhenExit

ChkSpellWhenExit

[ Control]

ChkSpellWhenExit = LimitList

Parameter

Description

LimitList

Values can be

  • 1 - Spell check on Save
  • 2 - Grammar Check on Save
  • 3 - Spell and Grammar Check on Save

Remarks

1 - only "Spell Check on Save" is on\enabled

2 - only "Grammar Check on Save" is on\enabled

3 - both "Spell Check on Save" and "Grammar Check on Save" are on\enabled

Each time you save your work, the system will display the Spell Check window and\or Grammar Check on Save where you can choose to spell check and\or grammar check the entire document, a single image, or Cancel the spell check and\or grammar check.

Example

<Control>

ChkSpellWhenExit = 3

Available

Release | _______
Patch |


CompressMethod

[Control]
CompressMethod

To change the default compression method for Archive.

[ Control]

CompressMethod = Default

Parameter

Description

Method

Can be one of the following

  • lzss
  • None
  • Default

Remarks

To change the default compression method for Archive.

Example

< Control >

CompressMethod = lzss

Available

Release | 11.0
Patch |


CompressLevel

[Control]
CompressLevel

To change the default compression level for Archive.

[ Control]

CompressLevel = 5

Parameter | Description
number | Compression level can be -1 through 9. The system default is -1.

Remarks

The compression level must be -1 which is the system default, or between 0 and 9: 1 gives best speed, 9 gives best compression, 0 gives no compression at all (the input data is simply copied a block at a time). The -1 requests a default compromise between speed and compression (currently equivalent to level 6).

Currenly this option is supported only when the compress method is set to the system default.

Example

< Control >

CompressLevel = 5

Available

Release | 11.0
Patch |


ConfirmApplExit

[Control]
ConfirmApplExit

ConfirmApplExit

The Confirm Application Exit option, if set to Yes, displays a confirm exit message when exiting the Image Editor.

[ Control]

ConfirmApplExit = YN

Parameter | Description
Boolean | The Confirm Application Exit option, if set to Yes, displays a confirm exit message when exiting the Image Editor. This option can also be selected from the Confirm tab of the Editor Properties window in the Image Editor.

Remarks

This option can also be selected from the Confirm tab of the Editor Properties window in the Image Editor.

Example

< Control >

ConfirmApplExit = No

Available

Release | _______
Patch |


ConfirmFormExit

[Control]
ConfirmFormExit

ConfirmFormExit

Set this option to Yes to display an exit confirmation message when closing a FAP file in the Image Editor.

[ Control]

ConfirmFormExit = YN

Parameter | Description
YN |

Remarks

This option can also be selected from the Confirm tab of the Editor Properties window of the Image Editor.

Example

< Control >

ConfirmFormExit = Yes

Available

Release | _______
Patch |


ConfirmObjDelete

[Control]
ConfirmObjDelete

ConfirmObjDelete

If ConfirmObjDelete = Yes, a confirmation message is displayed whenever the user deletes an object from an image.

[ Control]

ConfirmObjDelete = YN

Parameter | Description
YN |

Remarks

This option can also be selected from the Confirm tab of the Editor Properties window of the Image Editor.

Example

< Control >

ConfirmObjDelete = Yes

Available

Release | _______
Patch |


ConfirmRevert

[Control]
ConfirmRevert

ConfirmRevert

This option displays a confirmation message when the user wishes to revert the image to a former version.

[ Control]

ConfirmRevert = YN

Parameter | Description
YN |

Example

< Control >

ConfirmRevert = Yes

Available

Release | _______
Patch |


ConfirmSaveChanges

[Control]
ConfirmSaveChanges

ConfirmSaveChanges

Set this option value to Yes to have the system display a message asking the user to confirm the Save command.

[ Control]

ConfirmSaveChanges = YN

Parameter | Description
YN |

Remarks

This option can also be set from the Confirm tab of the Editor Properties window of the Image Editor.

Example

< Control >

ConfirmSaveChanges = Yes

Available

Release | _______
Patch |


ConfirmUndo

[Control]
ConfirmUndo

ConfirmUndo

This option, if set to Yes, will display a message asking users to confirm their desire to undo an action.

[ Control]

ConfirmUndo = YN

Parameter | Description
YN |

Remarks

This option can also be set from the Confirm tab of the Editor Properties window of Image Editor.

Example

< Control >

ConfirmUndo = Yes

Available

Release | _______
Patch |


CreateMode

[Control]
CreateMode

CreateMode

[ Control]

CreateMode = List

Parameter

Description

List

Values can be

  • 1 - Create One item
  • 2 - Continuous Create

Remarks

When Autocreate is off, CreateMode does not appear in fapcomp.ini file.

When Autocreate is on, CreateMode=2 is the setting in fapcomp.ini file.

CreateMode = 1 means creating one item then stop.

CreateMode = 2 means continuous create - stay in creation mode for the type of object you chose.

Example

<Control>

CreateMode = 2

Available

Release | _______
Patch |


CrossHairs

[Control]
CrossHairs

CrossHairs

Use this option to control the default display of crosshairs in the Image Editor window.

[ Control]

CrossHairs = YN

Parameter | Description
YN |

Remarks

Set this value to Yes to have the crosshairs displayed by default. The user can still use View, Options to hide the crosshairs.

Example

< Control >

CrossHairs = Yes

Available

Release | _______
Patch |


DateFmt2To4Year

[Control]
DateFmt2To4Year

DateFmt2To4Year

[ Control]

DateFmt2To4Year = Spin

Parameter | Description
Spin | Has the range of 0 (min) to 99 (max).

Remarks

The DateFmt2To4Year option lets you specify a "cutoff year" for 2 to 4 character year conversions when using the datefmt rule. All 2 to 4 character year conversions will be performed on the following basis by default:

If year >= 50, it becomes 19##

If year < 50, it becomes 20##

However, the cutoff year, which defaults to 50, may be changed via the DateFmt2To4Year setting, as follows:

<Control>

DateFmt2To4Year = xx

xx is a any integer from 0 to 99 that represents the cutoff year.

If the year is >= the cutoff year, it becomes 19xx.

If the year is < the cutoff year, it becomes 20xx.

Example

< Control >

DateFmt2To4Year = 99

Available

Release | _______
Patch |


DefaultFieldColor

[Control]
DefaultFieldColor

DefaultFieldColor

[ Control]

DefaultFieldColor =

Remarks

New INI options are supported to allow the user control over the default field color shown during data entry in the Workstation/PPS product. Normally, fields that did not specify a specific color have always defaulted to show in red. Now, there are two new INI options that can control the default field color.

These two INI options can be used to configure how you want the fields location to display before and after data is assigned. Without these options defined, the field color continues to default to Red.

[Control]

DefaultFieldColor = (255,0,0,0)

DefaultPlaceColor = (255,0,0,0)

These options specify a color using a RGB (red-green-blue) configuration followed by a control byte.

Each color value is a number between 0 and 255 to assign the intensity of that color. Normally, the control byte will always be zero. The combination of RGB values is used to achieve the final color shown on the display monitor.

DefaultFieldColor is the option that will define what color to use to show data locations on the images.

DefaultPlaceColor is an option that will allow you to show the field placeholders (for fields that have no data assigned) in another color. If DefaultPlaceColor is not specified, the placeholder color will be the same as the DefaultFieldColor.

Note, if you fail to use the RGB structure as defined and simply specify a long numeric value, we will assume that represents a single (resolved) color value. For instance DefaultFieldColor = 16711680 is the resolved value for Red.

Also note that these INI options only affect those fields using the "default" field color. If the field color is overridden at the field level, or at the image level (for all fields on the image), these values will not apply.

Example

< Control >

DefaultFieldColor = (255,0,0,0)

DefaultPlaceColor = (255,0,0,0)

Available

Release | 10.3
Patch | 65


DefaultPlaceColor

[Control]
DefaultPlaceColor

DefaultPlaceColor

[ Control]

DefaultPlaceColor =

Remarks

New INI options are supported to allow the user control over the default field color shown during data entry in the Workstation/PPS product. Normally, fields that did not specify a specific color have always defaulted to show in red. Now, there are two new INI options that can control the default field color.

These two INI options can be used to configure how you want the fields location to display before and after data is assigned. Without these options defined, the field color continues to default to Red.

[Control]

DefaultFieldColor = (255,0,0,0)

DefaultPlaceColor = (255,0,0,0)

These options specify a color using a RGB (red-green-blue) configuration followed by a control byte.

Each color value is a number between 0 and 255 to assign the intensity of that color. Normally, the control byte will always be zero. The combination of RGB values is used to achieve the final color shown on the display monitor.

DefaultFieldColor is the option that will define what color to use to show data locations on the images.

DefaultPlaceColor is an option that will allow you to show the field placeholders (for fields that have no data assigned) in another color. If DefaultPlaceColor is not specified, the placeholder color will be the same as the DefaultFieldColor.

Note, if you fail to use the RGB structure as defined and simply specify a long numeric value, we will assume that represents a single (resolved) color value. For instance DefaultFieldColor = 16711680 is the resolved value for Red.

Also note that these INI options only affect those fields using the "default" field color. If the field color is overridden at the field level, or at the image level (for all fields on the image), these values will not apply.

Example

< Control >

DefaultFieldColor = (255,0,0,0)

DefaultPlaceColor = (255,0,0,0)

Available

Release | 10.3
Patch | 65


DefaultPrint

[Control]
DefaultPrint

DefaultPrint

This option controls the Batch Print radio button in the Entry System's Complete Formset window.

[ Control]

DefaultPrint =

Remarks

If this option value is DefaultPrint = Batch, then the Batch Print button is selected by default in the Complete window. Any other value (or no INI entry) will select the Immediate Print button.

Available

Release | _______
Patch |


DispFields

[Control]
DispFields

DispFields

The DispFields option determines whether field templates are displayed by default.

[ Control]

DispFields = No

Parameter | Description
Boolean (No) | Yes or No; Default is No Default value is: No

Remarks

Field templating is when form set fields display Xs rather than data or an empty field. DispFields is a yes/no option with the default being No. The standard system setup has a menu option in the MEN.RES file so users can turn field templates on while viewing the form set.

Example

< Control >

DispFields = Yes

Available

Release | _______
Patch |


DisplayAllEntryFormPages

[Control]
DisplayAllEntryFormPages

DisplayAllEntryFormPages

Lets you display all pages of a form set marked as Entry or Entry and Print during Entry or Retrieval.

[ Control]

DisplayAllEntryFormPages = No

Parameter | Description
boolean (No) | Lets you display all pages of a form set marked as Entry or Entry and Print during Entry or Retrieval. Default value is: No

Remarks

By default, the system only displays forms which require data entry. The DisplayPrintOnly option tells the system not to display forms which do not require data entry:

< Control > or < ArcRet >

DisplayPrintOnly = No

If, however, you set the DisplayPrintOnly option to Yes, the system will display all pages with viewable information, or print-only forms.

Furthermore, you can set the DisplayAllEntryFormPages option to Yes to tell the system to display all forms designated as Entry or Entry and Print in the Form set definition file (form.dat, .BDF, .GRP, or .FOR):

< Control > or < ArcRet >

DisplayAllEntryFormPages = No

Example

< Control >

DisplayAllEntryFormPages = Yes

Available

Release | 10.1
Patch |


DisplayOnlyEntry

[Control]
DisplayOnlyEntry

DisplayOnlyEntry

Set the DisplayOnlyEntry option to Yes to display only forms with fields that accept data entry. The default is No.

[ Control]

DisplayOnlyEntry = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

This setting displays only forms containing variable data. The system will omit reference forms.

Example

< Control >

DisplayOnlyEntry = No

Available

Release | _______
Patch |


DisplayPrintOnly

[Control]
DisplayPrintOnly

DisplayPrintOnly

DisplayPrintOnly will cause the images to load into memory, and display in Entry.

[ Control]

DisplayPrintOnly = No

Parameter | Description
Boolean (No) | Yes or No; default is No Default value is: No

Remarks

Note: The default for both LoadPrintOnly and DisplayPrintOnly is No.

DisplayPrintOnly works like LoadPrintOnly except you also see the forms in Entry. The DisplayPrintOnly option overrides the LoadPrintOnly option settings.

The DisplayPrintOnly or LoadPrintOnly options are necessary to make certain print drivers work, like PDF print, because they need all image objects to be loaded before printing can start.

If you wish to not display those forms in Entry use LoadPrintOnly instead.

"In order to print PDF from Documaker Workstation, you'll need to force "print only" forms to load.

This is necessary because the PDF driver needs to know up front all of the pages that will be printed.

Normally, Documaker Workstation will load "print only" forms in the middle of the printing process.

This will cause the PDF driver to print pages that were not defined at the beginning of the print process and will create an invalid PDF file.

You can force Documaker Workstation to load the "print only" forms by adding the following INI setting to the Control group in the FSISYS.INI file:

[ Control ]

LoadPrintOnly = Yes

Example

<Control>

DisplayPrintOnly = Yes

Available

Release | _______
Patch |

Used By

AFEMAIN


DoFormDescLines

[Control]
DoFormDescLines

DoFormDescLines

Use this option to enable/disable form description lines.

[ Control]

DoFormDescLines = Yes

Parameter | Description
Boolean (Yes) | Yes (default) or No Default value is: Yes

Remarks

This yes/no option enables the Form Description Line feature which lets users include a form which contains descriptions of the other forms included in a form set. This option is set to Yes by default so users do not have to include this option in the INI file. The only reason to disable this option is if you intend to have fields with names which begin with FORM DESC LINE but you do not want those fields to be treated as form description lines.

Example

< Control >

DoFormDescLines = Yes

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT


DoFormsSelection

[Control]
DoFormsSelection

DoFormsSelection

[ Control]

DoFormsSelection = No

Parameter | Description
Boolean (No) | Yes, or No (default) Default value is: No

Remarks

The DoFormsSelection option lets the user skip the Form Selection window and go from the WIP list into the Entry System. This option only works in the WIP display mode. The DoFormsSelection is a yes/no option. The default value is No.

Example

< Control >

DoFormsSelection = Yes

You must run the entry system in the wip mode for this option to work.

For example,

c:\fap\mstrres\sampco\> c:\fap\dll\afemnw32.exe /mode=wip

Available

Release | _______
Patch |

Used By

AFEMAIN


DosImageOptionsOnly

[Control]
DosImageOptionsOnly

DosImageOptionsOnly

[ Control]

DosImageOptionsOnly =

Parameter | Description
value | value

Available

Release | _______
Patch |

Used By

FDTLIB


EntryErrorBeep

[Control]
EntryErrorBeep

EntryErrorBeep

If the EntryErrorBeep option = Yes, a warning beeps when the user types an invalid character into the field.

[ Control]

EntryErrorBeep = Yes

Parameter | Description
Boolean (Yes) | Yes (default), No Default value is: Yes

Remarks

The default is yes.

Example

<Control>

EntryErrorBeep option = Yes

Available

Release | _______
Patch |


EntryMode

[Control]
EntryMode

EntryMode

Lets you define a default edit mode, such as WIP or Retrieve, in the INI file.

[ Control]

EntryMode = Edit

Parameter | Description
Edit | Lets you define a default edit mode, such as WIP or Retrieve, in the INI file.

Remarks

This option allows a default edit "mode" (like MODE=WIP, or MODE=RETRIEVE) to be defined in the INI file. This will not require the command-line parameter be set.

[Control]

EntryMode=WIP, or RETRIEVE.

WIP mode means that only the "manual entry" fields are editable. RETRIEVE mode means no fields are editable. Omitting the option or defining an incorrect value will default to normal Edit mode.

Example

< Control >

EntryMode = WIP or Retrieve

Available

Release | 10.1
Patch |


ErrorFileDateStamp

[Control]
ErrorFileDateStamp

ErrorFileDateStamp

Enables the user to disable date stamps in the Batch Processing Error and Log files.

[ Control]

ErrorFileDateStamp = Yes

Parameter | Description
boolean | Enables the user to disable date stamps in the Batch Processing Error and Log files. Default value is: Yes

Remarks

To disable date stamps in the Batch Processing Error and Log files, add the following INI settings:

< Control >

ErrorFileDateStamp = No

LogFileDateStamp = No

If omitted or set to Yes, the Batch Processing Error and Log files will contain date stamp information.

Default is Yes.

Entering No to turn off these options can be of use when regression testing.

Example

< Control >

ErrorFileDateStamp = No

Available

Release | 10.0
Patch | 423


ExportOnComplete

[Control]
ExportOnComplete

ExportOnComplete

This option controls the Export option on the Complete window.

[ Control]

ExportOnComplete = No

Parameter | Description
Value | Default value is: No

Remarks

By default, the check box is enabled and visible on the Complete window. The default is No (unchecked). If you set this option to Yes, the system checks the Export option on the Complete window.

Optionally, you can hide or disable the control so the user cannot change the setting. Hide the option by including, hidden after the entry, as shown below:

ExportOnComplete = Yes,hidden

To let the user see the option, but not change it, include, disabled after the entry:

ExportOnComplete = Yes,disabled

Available

Release | _______
Patch |


FilterRecip

[Control]
FilterRecip

FilterRecip

[ Control]

FilterRecip =

Parameter | Description
value | value

Example

< Control >

FilterRecip =

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


FirstPieSliceAngle

[Control]
FirstPieSliceAngle

FirstPieSliceAngle

The angle degree on a pie chart with values from 0 to 359.

[ Control]

FirstPieSliceAngle = Spin

Parameter | Description
value | The angle degree on a pie chart with values from 0 to 359.

Remarks

Lets you specify the angle at which you want the system to start drawing slices in a pie chart.

If you omit this option, the system draws the first slice at zero (0) degrees.

Example

[ Control ]

FirstPieSliceAngle = XXX

Available

Release | 10.1
Patch |


FitToWidth

[Control]
FitToWidth

FitToWidth

ActualSize, FidToWidth, FitToWindow, and Zoom setup the default zoom settings in Documaker Workstation and Image Editor.

[ Control]

FitToWidth = No

Parameter | Description
boolean (No) | Default value is: No

Remarks

The following INI option sets the default zoom setting to "Actual Size."

< Control >

ActualSize = Yes

The following INI options set the default zoom setting to "FitToWidth" (i.e. to display the full width of the image in the system window. This lets you see the full width of an image if it is larger than your window).

< Control >

ActualSize = No

The following INI options set the default zoom setting to "FitToWindow" (i.e. to display the entire image in an active window. This lets you see the image from top to bottom as a whole unit on the screen.)

< Control >

ActualSize = No

FitToWidth = No

FitToWindow = Yes

The following INI options set the default zoom setting to "Zoom %."

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

ZoomMult =

ZoomDiv =

If you use Image Editor, you can set up the default zoom settings by selecting Options, Editor Properties, Zoom tab.

Example

< Control >

ActualSize = No

FitToWidth = No

Available

Release | _______
Patch |


FitToWindow

[Control]
FitToWindow

FitToWindow

[ Control]

FitToWindow = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Use ActualSize, FidToWidth, FitToWindow, and Zoom options to setup the default zoom settings in Documaker Workstation and Image Editor.

The following INI option sets the default zoom setting to "Actual Size."

< Control >

ActualSize = Yes

The following INI options set the default zoom setting to "FitToWidth" (i.e. to display the full width of the image in the system window. This lets you see the full width of an image if it is larger than your window).

< Control >

ActualSize = No

The following INI options set the default zoom setting to "FitToWindow" (i.e. to display the entire image in an active window. This lets you see the image from top to bottom as a whole unit on the screen.)

< Control >

ActualSize = No

FitToWidth = No

FitToWindow = Yes

The following INI options set the default zoom setting to "Zoom %."

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

ZoomMult =

ZoomDiv =

If you use Image Editor, you can set up the default zoom settings by selecting Options, Editor Properties, Zoom tab.

Example

< Control >

ActualSize = No

FitToWidth = No

FitToWindow = Yes

Available

Release | _______
Patch |


FixedPosFields

[Control]
FixedPosFields

FixedPosFields

[ Control]

FixedPosFields = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

FixedPosFields controls whether the fixed edit data entry box appears by default on the Processing System's Entry window:

Yes = System displays the data entry box by default.

No = System defaults to the type on form style of data entry.

You can use the Processing System's Options, Fixed Edits option to change this setting for a specific data entry session.

Example

< Control >

FixedPosFields = No

Available

Release | _______
Patch |


FlushLogFile

[Control]
FlushLogFile

FlushLogFile

This option clears the log file.

[ Control]

FlushLogFile = YN

Parameter | Description
Boolean |

Example

< Control >

FlushLogFile =

Available

Release | _______
Patch |


ForceTableOnlySelection

[Control]
ForceTableOnlySelection

ForceTableOnlySelection

To protect a field from changes.

[ Control]

ForceTableOnlySelection = Yes

Parameter | Description
boolean | To protect a field from changes. Default value is: Yes

Remarks

With this option set to Yes, the only way a user can manually change the value is by selecting from a table.

NOTE: This affects the edit field on the image and not the Table window.

Example

< Control >

ForceTableOnlySelection = Yes

Available

Release | 10.1
Patch |


GuideBoxes

[Control]
GuideBoxes

GuideBoxes

This option will select the view variable fields option by default in the View, Options menu in Image Editor.

[ Control]

GuideBoxes = YN

Parameter | Description
Boolean |

Example

< Control >

GuideBoxes = Yes

Available

Release | _______
Patch |


HiddenGroupPrefix

[Control]
HiddenGroupPrefix

HiddenGroupPrefix

Lets you hide certain form groups.

[ Control]

HiddenGroupPrefix =

Remarks

For example, you could use this option if you have worksheet-style form sets and want to block from view certain forms that must be in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). Now, any group (Key1 = Company, or Key2 = LOB) in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) that begins with the prefix you define in the HiddenGroupPrefix option will not appear as a selection in the Key1 (Company) or Key2 (LOB) fields on the Form Selection window.

Keep in mind...

* To hide a company (Key1) or line of business (Key2), you must mark every line which includes that company's (or line of business) name with .H. or whatever hidden group prefix you are using. Only marking the first line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) will not work. The system does not carry the hidden flag through subsequent lines.

* You can access images which have a hidden flag using the AddImage DAL function. This is the only way you can display these images. For more information on this function, see the DAL Reference.

For example, some worksheet-style form set implementations are set up to block from view certain forms that must be in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). To specify, enter the prefix to use for a hidden group. Leaving the option blank overrides the default prefix of .H. (period H period) and makes all forms visible.

Any group (Key1 = Company, or Key2 = LOB) in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) that begins with a special prefix will not appear as a selection in the Key1 (Company) or Key2 (LOB) fields on the Form Selection window.

Available

Release | 10.1
Patch |


HideFormSelImport

[Control]
HideFormSelImport

HideFormSelImport

[ Control]

HideFormSelImport = YN

Parameter | Description
Boolean |

Example

< Control >

HideFormSelImport =

Available

Release | _______
Patch |

Used By

AFEMAIN


HideFormSelRetrieve

[Control]
HideFormSelRetrieve

HideFormSelRetrieve

The HideFormSelRetrieve option lets you hide the Retrieve button on the Form Selection window.

[ Control]

HideFormSelRetrieve = No

Parameter | Description
Boolean (No) | Yes, No Default value is: No

Remarks

The format for this option is:

[Control]

HideFormSelRetrieve = Yes

When the above definition is absent, the button appears as normal. Existing users will not see any change unless they add this setting.

Example

< Control >

HideFormSelRetrieve = Yes

Available

Release | _______
Patch |

Used By

AFEMAIN


HorizontalRuler

[Control]
HorizontalRuler

HorizontalRuler

This option sets the default value for the Show Horizontal Ruler checkbox in the View Properties window of the Image Editor.

[ Control]

HorizontalRuler = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Set the option value to Yes to select the checkbox by default.

Example

< Control >

HorizontalRuler = Yes

Available

Release | _______
Patch |


ImageExt

[Control]
ImageExt

ImageExt

Defines the form extension names. ImageExt defines the extension of ASC files (forms).

[ Control]

ImageExt = Edit

Parameter | Description
.fap | Form file name extension

This option may be required in order for the feature to function.

Remarks

Troubleshooting:

If < Control > ImageExt = .fap cannot be located, Genwip produces error (DM19024). This is a required entry. This system does not default to .fap

Specifies the type of image file.

Note

DM19024

Example

< Control >

ImageExt = .fap

Available

Release | _______
Patch |

Used By

AFEMAIN, GENWIP


ImageFormat

[Control]
ImageFormat

ImageFormat

The ImageFormat option defines the file format for image (FAP) files.

[ Control]

ImageFormat = Edit

Parameter | Description
Edit |

Available

Release | _______
Patch |


ImmediateOnComplete

[Control]
ImmediateOnComplete

ImmediateOnComplete

The ImmediateOnComplete option affects the Immediate print option in the Complete Formset window.

[ Control]

ImmediateOnComplete = No

Parameter | Description
value | Default value is: No

Remarks

It, too, can be hidden or disabled from change and can be initially checked or not checked. The format for the ImmediateOnComplete option is:

<CONTROL>

ImmediateOnComplete = Yes[No], Hidden, Disabled

Like the BatchOnComplete option, the system determines the default for this setting based on what is defined in the <CONTROL> DefaultPrint option, but will be overridden if the ImmediateOnComplete option has a different value.

If both the Batch and Immediate options are checked on or off, Immediate becomes the default. If, however, one option is turned off and the other is turned on, the enabled (on) option becomes the default, regardless of the INI setting.

Prior to these changes, when the Print option was checked on or off by the user, the radio buttons were enabled or disabled. However, now only the options that were initially enabled (not turned off by using the disabled or hidden INI option) will be affected by this operation. As always, when batch print is selected, the WIP transaction is not archived or deleted until that process is complete.

Example

< Control >

ImmediateOnComplete = Yes

Available

Release | _______
Patch |


ImmediateTranslate

[Control]
ImmediateTranslate

ImmediateTranslate

This option makes error translation in the Batch Processing System a manual process.

[ Control]

ImmediateTranslate = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

(see Appendix C of the Documaker Rules Processing System Guide) to translate the error messages; it will not occur automatically at the end of processing.

By default, the GenTrn program deletes the old message file at the beginning of its execution and starts a new file with output information. All other programs, such as GenData, GenWIP, and so on, append information to the end of the message file created by the GenTrn program.

The default translation options are set so the log and error files are created after each system program executes. You can, however, set the ImmediateTranslate option to No to delay the translation process until all system programs finish processing at the end of the batch process.

Once processing stops, you can then use the TRANSLAT utility to translate the messages. By delaying the translation process and only executing it once per batch cycle, you can reduce job output time.

NOTE: If you set the ImmediateTranslate option to No, the system will not create the ERRFILE.DAT file.

On MVS, if you set the following INI option the system makes error translation a manual process. This means you must run the TRANSLAT utility. The system will not do the translation automatically when one of the system programs finish.

< Control >

ImmediateTranslate = No

Also, since you are running the programs as separate jobs, in separate directories, you should delete the MESSAGE.DAT file each time before you run the program. Deleting only the ERRFILE and LOGFILE will not help.

For information about the TRANSLAT utility, see the Docutoolbox Reference.

Example

< Control >

ImmediateTranslate = No

Available

Release | _______
Patch |


LightShade

[Control]
LightShade

LightShade

[ Control]

LightShade =

Parameter | Description
value | value

Example

< Control >

LightShade =

Available

Release | _______
Patch |

Used By

GFELIB


LimitDDTs

[Control]
LimitDDTs

LimitDDTs

The system now presumes that all images have DDT files.

[ Control]

LimitDDTs = YN

Parameter | Description
Boolean | The system now presumes that all images have DDT files. Previously, the system only tried to load the DDT file if the image was specified as Entry and Print.

Remarks

This change was implemented because users seldom create full page images and the system was, in effect, forcing you to choose Entry and Print for images that were really just for print or entry. You had to do this for these smaller images to get a DDT file so you could execute the SetOrigin rule. If you want to make the system work as it has in the past, only loading DDT files for images specified as Entry and Print, include this INI option:

< Control >

LimitDDTs = Yes

For instance, you may want to include this option if you have legacy master resource libraries (MRLs) which include images that do not have DDT files.

Example

< Control >

LimitDDTs = Yes

Available

Release | 10.2
Patch |


LimitPageBreak

[Control]
LimitPageBreak

LimitPageBreak

You can disable the page break option and the CTRL+ENTER key when a text area field does not have the proper options set.

[ Control]

LimitPageBreak = YN

Parameter | Description
Boolean | You can disable the page break option and the CTRL+ENTER key when a text area field does not have the proper options set, such as Can Grow, Can Span, Tab Stops, and Paragraph.

Remarks

You can place this option in the FAPCOMP.INI, FSISYS.INI, or FSIUSER.INI file.

Use the LimitPageBreak option to turn off the option to insert a page break (Insert, Break, Page Break) when a fixed size text area does not have the Span Pages option set:

< Control >

LimitPageBreak = Yes

Keep in mind that if the Can Grow option is set, meaning the text area does not have a fixed size, adding a page break simply starts a new page but does not push the remaining items onto that page. This INI option also disables the CTRL+ENTER shortcut.

Example

< Control >

LimitPageBreak = Yes

Available

Release | 10.1
Patch | 215


LoadPrintOnly

[Control]
LoadPrintOnly

LoadPrintOnly

LoadPrintOnly will cause the images to load into memory, but not display.

[ Control]

LoadPrintOnly = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

This is necessary to make certain print drivers work, like PDF print, because they need all image objects to be loaded before printing can start.

If you wish to display those forms in Entry use DisplayPrintOnly instead.

Note: The default for both LoadPrintONly and DisplayPrintOnly is No.

"In order to print PDF from Documaker Workstation, you'll need to force "print only" forms to load.

This is necessary because the PDF driver needs to know up front all of the pages that will be printed.

Normally, Documaker Workstation will load "print only" forms in the middle of the printing process.

This will cause the PDF driver to print pages that were not defined at the beginning of the print process and will create an invalid PDF file.

You can force Documaker Workstation to load the "print only" forms by adding the following INI setting to the Control group in the FSISYS.INI file:

[ Control ]

LoadPrintOnly = Yes

You can add tables of contents, lists of figures, or indexes to your form sets. This makes it easier for users to navigate through the various forms. To use this feature, you need to:

* Add a table of contents (or list of figures or index) object to your form set. You can place this object on a new form or wherever you want the system to create the table of contents. Use the Insert, Indexes and Tables option in Image Editor to add a table of contents object.

* Add bookmarks to the FAP files that comprise the form set. These bookmarks define the text you want to print in the table of contents. You can define a level number which determines the formatting to use (like ToC1, ToC2, and so on).

* Set the PrintPageNumbers option to yes to turn on page numbering.

NOTE: If you have print only forms, also use the LoadPrintOnly option to make sure those pages are included in the numbering. Here is an example:

< Control >

LoadPrintOnly = Yes

This makes sure all forms are loaded, not just ones which require data entry.

Use the Insert, Bookmark option in Image Editor to add bookmarks. The Bookmark window appears. An index marker lets you add a main entry and subentry which can be sorted in alphabetical order. Indexes are sorted by main, sub, text, page number, and coordinate. Other types of markers are sorted by page number and coordinate.

The coordinates define where the marker is generated. You must size the table based on how large you want it to be. The system will create additional pages when necessary, but the table will not flow dynamically.

Use the Insert, Index and Tables option to define the index, table of contents, or list of figures. The Index and Tables window appears.

Levels are paragraph formats you can use to control appearance. For a table of contents, the system matches the level number of the bookmark to the level paragraph format. For Indexes, it uses the first three formats defined for the index. For a list of figures, it uses the first format defined for the figure.

When you create a list of figures, you can define the prefix text to display and print. For a list of figures, the system generates prefix text, figure number, and a colon, before the text and page number. Here is an example:

Chart 1: Current Utility usage

Chart 2: Average usage

When you choose index, you can set the number of columns and the gap between columns. Additionally, you can specify the language locale for sorting purposes. This feature supports Unicode text.

NOTE: To use this feature, all images must be loaded before the print operation

executes. Otherwise, the system will not have all the content available and will

not be able to create a complete table of contents, list of figures, or index.

Since some print drivers do not force the loading of all images until necessary, this means you may have to include an additional INI option. For Documaker Workstation, you would include this option:

< Control >

LoadPrintOnly = Yes

For Documaker RP (GenPrint), you would include this option:

< RunMode >

DownloadFAP = Yes

Example

<Control>

LoadPrintOnly = Yes

Available

Release | _______
Patch |

Used By

AFEMAIN


LogCaching

[Control]
LogCaching

LogCaching

Indicates whether to write Caching statistics to the LogFile.

[ Control]

LogCaching = Yes

Parameter | Description
Boolean (Yes) | Yes | No Default value is: Yes

Remarks

Caching statistics report on the effectiveness of caching objects such as FAPs, DDTs, Xerox PMETs and Xerox FRMs. The LogFile is pointed to by the <Data> LogFile option.

Yes - write Cache statistics to the LogFile.

No - do not write Cache statistics to the LogFile.

Enter No if you do not want the system to log caching statistics. The default is Yes.

Example

< Control >

LogCaching = Yes

Available

Release | 10.1
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


LogEnabled

[Control]
LogEnabled

LogEnabled

Prints a log File.

[ Control]

LogEnabled = YN

Parameter | Description
Boolean | value

Example

< Control >

LogEnabled = Yes

Available

Release | 10.0
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


LogFileDateStamp

[Control]
LogFileDateStamp

LogFileDateStamp

Enables the user to disable date stamps in the Batch Processing Error and Log files.

[ Control]

LogFileDateStamp = Yes

Parameter | Description
Boolean (Yes) | Enables the user to disable date stamps in the Batch Processing Error and Log files. Default value is: Yes

Remarks

To disable date stamps in the Batch Processing Error and Log files, add the following INI settings:

< Control >

ErrorFileDateStamp = No

LogFileDateStamp = No

If omitted or set to Yes, the Batch Processing Error and Log files will contain date stamp information.

Default is Yes.

Entering No to turn off these options can be of use when regression testing.

Example

< Control >

LogFileDateStamp = No

Available

Release | 10.0
Patch | 423


LogINIFileNames

[Control]
LogINIFileNames

LogINIFileNames

Logs the names of the INI files loaded at initialization time to the LOGFILE.

[ Control]

LogINIFileNames = Yes

Parameter | Description
value | Yes | No Default value is: Yes

Remarks

Set LogINIFileNames = Yes to cause the program that is running (e.g. Gentrn, Gendata, Genprint) to write the names of the INI files that are loaded at initialization time to the LOGFILE. Set LogINIFileNames = No to prevent the logging of the names of the INI files to the LOGFILE.

Note: the INI option < Control > LogTransactions turns Logging on or off.

505 LOGGING INI FILES AND OPTIONS USED

By default, the GenTrn, GenData, GenPrint, and GenArc programs now log the INI files being used. This tells you which files were used and if they were opened successfully. To turn off the logging of INI file names in the LOGFILE, make the following change in your INI files:

< Control >

LogINIFileNames = No

Example

< Control >

LogINIFileNames = Yes

Available

Release | 10.1
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


LogINIOptions

[Control]
LogINIOptions

LogINIOptions

Logs the names of the INI files loaded at initialization time to the LOGFILE.

[ Control]

LogINIOptions = No

Parameter | Description
boolean | Logs the names of the INI files loaded at initialization time to the LOGFILE. Default value is: No

Remarks

Set LogINIFileNames = Yes to cause the program that is running (e.g. Gentrn, Gendata, Genprint) to write the names of the INI files that are loaded at initialization time to the LOGFILE. Set LogINIFileNames = No to prevent the logging of the names of the INI files to the LOGFILE.

Note: the INI option < Control > LogTransactions turns Logging on or off.

505 LOGGING INI FILES AND OPTIONS USED

You can also log which INI options are being used. This feature is turned off by default. To turn on the logging of INI options, use this INI option:

< Control >

LogINIOptions = Yes

You can also use the /L command line parameter to log the INI options being used. For example, if you are running on a Windows 32-bit system, you would use this command to tell the GenData program to log the INI options used to the LOGFILE:

gendaw32 /L

Example

[ Control ]

LogINIOptions = Yes

Available

Release | _______
Patch |


LogoExt

[Control]
LogoExt

LogoExt

Defines the logo extension names.

[ Control]

LogoExt = Edit

Parameter | Description
.log | logo file name extension

This option may be required in order for the feature to function.

Example

< Control >

LogoExt = .log

Available

Release | _______
Patch |

Used By

AFEMAIN, GENWIP


LogToConsole

[Control]
LogToConsole

LogToConsole

Indicates whether to write Processing messages to the Console.

[ Control]

LogToConsole = Yes

Parameter | Description
Value | Yes | No or Value Default value is: Yes As of 11.3 you can also enter a value into this INI option to limit the number of messages that go to the console by that number.

Remarks

If there are many errors and warnings, these files that log the errors and warnings can become very large, especially the MESSAGE.DAT file. It's a good idea to periodically review the warnings and errors to see if there are any changes you can make to remove them. The fewer messages the system has to process, the better the performance.

You can also change your INI settings to turn off some of the system's logging features. This will also improve performance-just make sure you have evaluated the messages first. For example you can make the following changes in the Control control group:

<Control>

LogTransactions = No (eliminates the LOGFILE.DAT file)

LogToConsole = No (eliminates messages which appear on the screen)

These INI options default to Yes.

There is, however, no way to suppress creating the MSGFile. The MSGFile is deleted automatically when the GenTrn program runs. The GenData and the GenPrint programs append errors and warnings to the file. So it gets larger and larger if you do not run the GenTrn program often or if you do not remove the file between runs. For best performance, evaluate the errors and warnings to see if there are any changes you need to make in the files, then purge the MSGFile, and go for a clean run, beginning with the GenTrn program.

As of 11.3 LogToConsole will accept a number value as well. Entering a number value into this INI option will limit the number of messages sent to the console by that number. A typical value would be 1000.

Example

< Control >

LogToConsole = Yes

OR

< Control >

LogToConsole = 1000

Available

Release | 10.0
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


LogTransactions

[Control]
LogTransactions

LogTransactions

Indicates whether to write Processing messages to the LogFile.

[ Control]

LogTransactions = Yes

Parameter | Description
Boolean | Yes | No Default value is: Yes

Remarks

If there are many errors and warnings, these files that log the errors and warnings can become very large, especially the MESSAGE.DAT file. It's a good idea to periodically review the warnings and errors to see if there are any changes you can make to remove them. The fewer messages the system has to process, the better the performance.

You can also change your INI settings to turn off some of the system's logging features. This will also improve performance-just make sure you have evaluated the messages first. For example you can make the following changes in the Control control group:

<Control>

LogTransactions = No (eliminates the LOGFILE.DAT file)

LogToConsole = No (eliminates messages which appear on the screen)

These INI options default to Yes.

There is, however, no way to suppress creating the MSGFile. The MSGFile is deleted automatically when the GenTrn program runs. The GenData and the GenPrint programs append errors and warnings to the file. So it gets larger and larger if you do not run the GenTrn program often or if you do not remove the file between runs. For best performance, evaluate the errors and warnings to see if there are any changes you need to make in the files, then purge the MSGFile, and go for a clean run, beginning with the GenTrn program.

Example

< Control >

LogTransactions = Yes

Available

Release | 10.0
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


Margins

[Control]
Margins

Margins

The Margins option sets the default value for the Show Margins checkbox in the View Properties window of the Image Editor.

[ Control]

Margins = YN

Parameter | Description
Boolean |

Remarks

Set the option value to Yes to display the margins by default. The user can deselect this option using View, Options to display the View Properties window.

Example

< Control >

Margins = Yes

Available

Release | _______
Patch |


Maximized

[Control]
Maximized

Maximized

The Maximized option determines the size of the Entry start up window (for maximized). The default is No.

[ Control]

Maximized = No

Parameter | Description
Boolean (No) | Yes, No (default) Default value is: No

Example

<Control>

Maximized = Yes

Available

Release | _______
Patch |

Used By

AFEMAIN


MaxPOLLineLength

[Control]
MaxPOLLineLength

MaxPOLLineLength

This option defines the maximum number of characters in the POL File.

[ Control]

MaxPOLLineLength = 255

Parameter | Description
value | Default value is: 255

Remarks

Lets you control the output line length when writing out the POL file records. The default is 255. You can set it to shorter lengths when you are testing to view the file in a text editor.

To define the length, choose a length between 40 to 4000 bytes. If the MaxPolLineLength falls out of this range, the system will default to 40 if shorter or 4000 if longer.

Example

< Control >

MaxPOLLineLength = 255

Available

Release | 10.1
Patch |


Mobius

[Control]
Mobius

Mobius

[ Control]

Mobius = Edit

Parameter | Description
Edit |

Remarks

You can read Metacode print streams retrieved from a Mobius archive. For instance, you can now use Mobius to archive Metacode print streams, then use Docupresentment to retrieve the archived Metacode print streams and produce PDF files. You can also open Mobius files in Image Editor.

NOTE: Mobius Metacode files do not, however, appear on the list of most recently opened files at the bottom of the File menu in Image Editor.

The archived Metacode print streams can be retrieved using Mobius: ViewDirect APIs. The ViewDirect APIs communicate with the Mainframe Mobius Archive via TCP/IP. If you license the Mobius' ViewDirect APIs, you can write a custom rule to retrieve your archived Metacode print streams.

Metacode print streams retrieved from a Mobius archive have a special record blocking scheme and use special comment records to indicate the fonts used in the document.

As with support for loading other Metacode print streams, you must have a Xerox printer control group which defines the options required by the print stream, such as DJDEIden, DJDEOffset, and so on.

NOTE: The Mobius Metacode loader now performs its operations quicker and with better coding. This makes the output easier to read and use.

To specify a Mobius Metacode print stream, the OutMode option in the Xerox printer control group must be set to MOBIUS. The OutMode option tells the Metacode loader to expect the special record blocking scheme and to expect special comment records which indicate the fonts used in the document.

Mobius Metacode support is available in both Image Editor and the MRG2FAP utility. Include these options in your FAPCOMP.INI file for Image Editor or FSISYS.INI for MRG2FAP.

< PrtType:XER >

OutMode = Mobius

< Loader:Mobius >

Desc = Mobius Metacode Files (*.met)

Func = XERLoadMobius

Module = XERW32

< Loaders >

Loader = Mobius

< Control >

Mobius = XER

Where XER is the printer group that contains the Mobius Metacode information.

To us the Mobius Metacode loader in Docupresentment, use the MTCLoadFormset rule. To specify Mobius Metacode print stream instead of a Documerge print stream, set the OutMode option in the Xerox printer control group to MOBIUS.

Example

< Control >

Mobius = XER

Available

Release | 10.2
Patch | 66


ModePointers

[Control]
ModePointers

ModePointers

This option sets the default value for the Mode Indicators field in the View Properties window of Image Editor.

[ Control]

ModePointers = YN

Parameter | Description
Boolean |

Remarks

Set this value to Yes to select the checkbox by default.

Example

< Control >

ModePointers = Yes

Available

Release | _______
Patch |


NewlineEscape

[Control]
NewlineEscape

NewlineEscape

[ Control]

NewlineEscape = \n

Parameter | Description
Edit | Default value is: \n

Remarks

Feature 1482 added an INI option for you to override the normal escape sequence to indicate a new line (new paragraph) in data mapped to a multi-line text field. The default escape sequence is \n.

You can enter up to 30 characters.To include the escape sequence in the data without translation, it must begin with a backslash. For instance, \\n is required to include the text \n in the resulting data.

Keep in mind that if you make the escape sequence too common (such as a single letter), you may end up with incorrectly formatted data.

Example

< Control >

NewlineEscape = \\n

Available

Release | 10.2
Patch | 106

Used By

CORBLIB, RULLIB


NoKey2Changes

[Control]
NoKey2Changes

NoKey2Changes

[ Control]

NoKey2Changes = YN

Parameter | Description
Boolean |

Remarks

Use this option to prevent the user from change Key2 selections when Retrieve or Import is used to create the form set, and when editing WIP.

This option determines whether the user can modify the KEY2 (LOB) field in existing WIP. The default value is FALSE (to allow KEY2 changes). To prevent the modification of KEY2 on existing WIP, set the option value to TRUE.

Example

< Control >

NoKey2Changes = Yes

Available

Release | _______
Patch |

Used By

AFEMAIN


NoLoadFormList

[Control]
NoLoadFormList

NoLoadFormList

Tells the system not to load the FormList.

[ Control]

NoLoadFormList = YN

Parameter | Description
Boolean |

Example

< Control >

NoLoadFormList =

Available

Release | _______
Patch |


Normalize

[Control]
Normalize

Normalize

Feature 1179, 1438, 1443 Using Normalized AFP Files. This feature lets Documerge users view and edit forms.

[ Control]

Normalize =

Parameter | Description
value |

Remarks

You can open and create normalized AFP and Metacode files in Documaker Studio, Image Editor and Form Set Manager. Normalized files have been prepared and formatted to contain comment records and text commands necessary for Documerge to use the file as a form template.

For instance, you can open normalized AFP or Metacode files in Documaker Studio, Image Editor and then view, change, and print those files. You can even save the file as a FAP or a normalized file. This lets you incorporate normalized files into the entire form set cycle.

This feature is available on all Windows 32-bit platforms that support the Documaker Studio, Image Editor and Form Set Manager. To set up this feature, you must add the Normalize option in the Control group to your INI file. Here is an example:

< Control >

Normalize = Norm

Specify the PrtType control group you want the system to use when it normalizes the files. For instance, if you create a control group called PrtType:Norm to contain the option you want the system to use when it normalizes AFP or MET files, enter Norm. If the control group you specify is missing or is not an AFP or XER printer group (Class=AFP or XER), you will receive errors. Note that typically, the Class option is not set in the INI file. The Class name is normally derived from the first three letters of the Module option. If the Module is not AFPPRT or XERW32, and you want the system to think the control group is an AFP or XER print group, you must set the Class option to AFP or XER.

Here is an example:

< PrtType:Norm >

Class = AFP

Module = AFPPRT

PrintFunc = AFPPrint

Or

< PrtType:Norm >

Class = XER

CodeDef = DCASCII9

DJDEIden = A'@@@DJDE'

DJDEOffset = 0

DJDESkip = 8

JDEName = DFLT

JDLCode = NONE

JDLData = 0,255

JDLHost = IBMONL

JDLName = DFAULT

JDLRStack = 0,10,EQ,X'13131313131313131313'

Module = XERW32

PrintFunc = XERPrint

OutMode = MRG4

Setting up these INI options enables the FAP to normalized AFP or Metacode option in the Print File Type drop-down list in the Conversion Manager of Documaker Studio, and the normalized AFP or Metacode option in Image Editor's Tools, Conversion, Normalize option, the Documerge tab of Image Editor's Object Properties window, and the Documerge options in the Field Database Editor.

The Normalize option adds these columns to the Field Database Editor: Delete, Replacement Character, Line End Character, Generate, Multidata, and Mandatory. There are drop down lists for you to use to choose the appropriate type for Delete, Replacement Character, and Multidata.

If converting FAP to a normalized Metacode file, be sure that the CodeDef and OutMode options in the PrtType control group are set up correctly. Additionally, you would need to setup the CommonFonts control group to define the common fonts to be used for the normalized Metacode files. Please refer to the CommonFonts group and PrtType:XER group for detailed information.

Normalized AFP or Metacode files have the same file extension as regular AFP or Metacode files, so setting up a distinct destination, defined with the EDLLIB option in the MasterResource group is a good way to separate the two types of files.

Example

< Control >

Normalize = Norm

Available

Release | 10.2
Patch |


NormalizeXER

[Control]
NormalizeXER

NormalizeXER

[ Control]

NormalizeXER =

Parameter | Description
value |

Remarks

You can open and create normalized Metacode files in Documaker Studio, Image Editor and Form Set Manager. Normalized files have been prepared and formatted to contain comment records and text commands necessary for Documerge to use the file as a form template.

For instance, you can open normalized Metacode files in Documaker Studio, Image Editor and then view, change, and print those files. You can even save the file as a FAP or a normalized file. This lets you incorporate normalized files into the entire form set cycle.

This feature is available on all Windows 32-bit platforms that support the Documaker Studio, Image Editor and Form Set Manager. To set up this feature, you must add the Normalize option in the Control group to your INI file. Here is an example:

< Control >

NormalizeXER = Norm

Specify the PrtType control group you want the system to use when it normalizes the files. For instance, if you create a control group called PrtType:Norm to contain the option you want the system to use when it normalizes MET files, enter Norm. If the control group you specify is missing or is not an XER printer group (Class=XER), you will receive errors. Note that typically, the Class option is not set in the INI file. The Class name is normally derived from the first three letters of the Module option. If the Module is not XERW32, and you want the system to think the control group is an XER print group, you must set the Class option to XER.

Here is an example:

< PrtType:Norm >

Class = XER

CodeDef = DCASCII9

DJDEIden = A'@@@DJDE'

DJDEOffset = 0

DJDESkip = 8

JDEName = DFLT

JDLCode = NONE

JDLData = 0,255

JDLHost = IBMONL

JDLName = DFAULT

JDLRStack = 0,10,EQ,X'13131313131313131313'

Module = XERW32

PrintFunc = XERPrint

OutMode = MRG4

Setting up these INI options enables the FAP to normalized Metacode option in the Print File Type drop-down list in the Conversion Manager of Documaker Studio, and the normalized Metacode option in Image Editor's Tools, Conversion, Normalize option, the Documerge tab of Image Editor's Object Properties window, and the Documerge options in the Field Database Editor.

The Normalize option adds these columns to the Field Database Editor: Delete, Replacement Character, Line End Character, Generate, Multidata, and Mandatory. There are drop down lists for you to use to choose the appropriate type for Delete, Replacement Character, and Multidata.

If converting FAP to a normalized Metacode file, be sure that the CodeDef and OutMode options in the PrtType control group are set up correctly. Additionally, you would need to setup the CommonFonts control group to define the common fonts to be used for the normalized Metacode files. Please refer to the CommonFonts group and PrtType:XER group for detailed information.

Normalized Metacode files have the same file extension as regular Metacode files, so setting up a distinct destination, defined with the EDLLIB option in the MasterResource group is a good way to separate the two types of files.

If the NormalizeXER setting is not found in the Control INI group, the metacode print driver will use the Normalize setting instead.

Example

< Control >

NormalizeXER = Norm

Available

Release

Patch


NoTitleBar

[Control]
NoTitleBar

NoTitleBar

This option determines whether the title bar is hidden for the Entry system main window: Yes = title bar is hidden

[ Control]

NoTitleBar = YN

Parameter | Description
Boolean |

Available

Release | _______
Patch |

Used By

AFEMAIN


Print

[Control]
Print

Print

Print determines whether the Print field is initially checked on the Complete Formset window.

[ Control]

Print = YesNoHide

Parameter | Description
value |

Remarks

The format for this option is:

<CONTROL>

Print = Yes[No], Hidden, Disabled

If Yes, the available options are enabled. If No, the options are disabled.

Note: If you set this option to No and you also hide it, the result is the same as turning off the Print option using the following INI setting:

< Complete >

Print = No

Example

< CONTROL >

Print = Yes[No], Hidden, Disabled

Available

Release | _______
Patch |


PrintDraft

[Control]
PrintDraft

PrintDraft

[ Control]

PrintDraft = No

Parameter | Description
boolean | Yes | No | True | False Default value is: No

Remarks

When printing the form set from any option other than the Complete option, the form pages include Draft in the SendCopyTo field. You should modify your FSIUSER.INI or FSISYS.INI file to include these options.

To print Draft on forms, add these options:

< AfeProcedures >

INIT = CSTW32->CSTInitImageHandler

< Control >

PrintDraft = Yes

The PrintDraft option tells the system to print Draft in the SendCopyTo field instead of the recipient name for normal WIP print. If you print from the Complete window, the system includes the normal recipient names.

Example

< Control >

PrintDraft = Yes

Available

Release | 10.1
Patch |


PrintNotifyText

[Control]
PrintNotifyText

PrintNotifyText

Displaying the Form Description on the Print Notification Window

[ Control]

PrintNotifyText = Name

Parameter | Description
value | Default value is: Name

Remarks

To have the system show the form description instead of the form name on the Printing in Progress window, set this INI option:

[Control]

PrintNotifyText = Description/Name (default is Name)

The system looks in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) for the form description data instead of the form name and displays the form description name when you are printing form sets, if you set this option to Description. This applies to both the Processing System and the Development System.

Example

< Control >

PrintNotifyText = Description/Name (default is Name)

Available

Release | 10.0
Patch |


PrintOnComplete

[Control]
PrintOnComplete

PrintOnComplete

The PrintOnComplete option affects the print option in the Complete Formset window.

[ Control]

PrintOnComplete = Yes

Parameter | Description
value | Default value is: Yes

Remarks

This option determines the initial setting of the "Print" option on the Complete dialog. If the option is checked, the Complete process will include a final print of the transaction. When the option is not checked, print will not occur.

The format for the PrintOnComplete option is:

<CONTROL>

PrintOnComplete = Yes[No], Hidden, Disabled

If the Hidden attribute is applied, the user will not be able to change the see the checkbox and therefore cannot change the setting. Similarly, the Disabled attribute will prevent the user from changing the setting of the checkbox, but does allow the user to see the state.

Example

< Control >

PrintOnComplete = Yes

Available

Release | _______
Patch |


PromptImageInfo

[Control]
PromptImageInfo

PromptImageInfo

[ Control]

PromptImageInfo = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

This option, if set to Yes, selects the Prompt For Image Information checkbox on the Save tab of the Editor Properties window in Image Editor by default.

Example

< Control >

PromptImageInfo = Yes

Available

Release | _______
Patch |


ReceiveMailMsgCount

[Control]
ReceiveMailMsgCount

ReceiveMailMsgCount

[ Control]

ReceiveMailMsgCount = YN

Parameter | Description
Boolean |

Remarks

The ReceiveMailMsgCount controls message notification of emails received:

Yes = System sends user message stating email is received.

No = No message is sent stating user received email.

Available

Release | _______
Patch |


ReceiveMailOnWipList

[Control]
ReceiveMailOnWipList

ReceiveMailOnWipList

[ Control]

ReceiveMailOnWipList = YN

Parameter | Description
Boolean |

Remarks

The ReceiveMailOnWipList option controls whether the user automatically receives mail directly into the WIP List, or must manually retrieve mail:

Yes = Automatically receive documents into WIP.

No = Manually receive documents into WIP. The user must select the WIP, Receive option from the menu or click the Receive toolbar icon.

Example

< Control >

ReceiveMailOnWipList = Yes

Available

Release | _______
Patch |


RequiredFields

[Control]
RequiredFields

RequiredFields

The RequiredFields option if set toYes, displays an error message if required fields are empty on a complete form set.

[ Control]

RequiredFields = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The user must complete this field during entry. You must also add the following option to the user's FSISYS.INI file:

< Control >

RequiredFields = Yes

Example

< Control >

RequiredFields = Yes

Available

Release | _______
Patch |


RuleFilePool

[Control]
RuleFilePool

RuleFilePool

Number of DDT files to cache.

[ Control]

RuleFilePool = 100

Parameter | Description
value | Number of DDT files to cache Default value is: 100

Remarks

The RuleFilePool option specifies the number of frequently used DDT files to keep available for re-use without reloading them from disk. The format for this option is:

< Control >

RuleFilePool = 100

Use the cache feature for FAP, DDT, and PMET files if the number of these files is over 100. It will reduce the number of times the system has to open and close these files. Here is an example of where you set the cache:

< Control >

CacheFAPFiles =100(Default is 100)

RuleFilePool = 100(Default is 100)

Caching pre-compiled Metacode files (PMETs) has a big effect on the GenPrint program. Here is an example of where you can set the cache for pre-compiled Metacode files:

<PRTType:XER>

CacheFiles = 100 (Default is 100)

InitFunc = XERInit

TermFunc = XERTerm

NOTE: You must include the InitFunc and TermFunc options in the PRTType:XER control group to enable caching.

Example

< Control >

RuleFilePool = 200

Available

Release | 10.0
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


R_Option

[Control]
R_Option

R_Option

This applies to Documaker Workstation Only

[ Control]

R_Option = LimitList

Parameter

Description

LimitList

Values can be

  • NotRequired
  • Required

Remarks

The R_Option determines whether the user can deselect required forms:

Not Required = the user can deselect required forms

Required = the user has to select all required forms

An error message is displayed if this option value is Required and the user attempts to deselect a required form.

Available

Release | _______
Patch |


ShowEffectiveDate

[Control]
ShowEffectiveDate

ShowEffectiveDate

Feature 1380 Now you can create form sets with postdated dates.

[ Control]

ShowEffectiveDate = YN

Parameter | Description
Boolean |

Remarks

Using the new Effective Date field on the Forms Selection window, you can now select the effective date for a new form set.

You can turn on this capability using the ShowEffectiveDate option, as shown here:

< Control >

ShowEffectiveDate = Yes

If you omit this option or set it to No, the system uses the current date as the effective date when it creates a new form set.

Available

Release | 10.1
Patch | 459


ShowNotes

[Control]
ShowNotes

ShowNotes

10.2 Feature 1243 DISPLAYING NOTES You can now use sticky notes to provide information about a field on a form.

[ Control]

ShowNotes = No

Parameter | Description
Boolean (No) | Yes or No. The default is No. Default value is: No

Remarks

You add these note objects to the image using the Image Editor. Then position the note next to the field.

In Entry or when using the Data Entry Check option in the Image Editor, when you position your cursor over the sticky note icon, the system displays the contents of the note in a tooltip-style window. When you move the cursor again, the note disappears. To enable this option in the Entry module, add the new ShowNotes INI option to your FSISYS.INI file:

< Control >

ShowNotes = Yes

The default is No.

In Entry, you can also turn on or off the display of notes from a menu. To add this option to your menu, add the Show Notes line to your MEN.RES file:

...

MENUITEM "Show &Notes" 1086 "NULL" "NULL"

...

1086 is the reserved menu ID for the Show Notes option. The menu option is automatically available when you use the Data Entry Check option in the Image Editor.

NOTE: You cannot embed note objects within text area objects for use with paragraph assembly. TERSUB only imports information stored in the first text area in the image. Objects defined outside the text area are ignored.

Example

< Control >

ShowNotes = Yes

Available

Release | 10.1
Patch | 324

Used By

AFEMAIN


SkipAFEEligibleCheck

[Control]
SkipAFEEligibleCheck

SkipAFEEligibleCheck

[ Control]

SkipAFEEligibleCheck = Yes

Parameter | Description
Boolean (Yes) | Yes or No. The default is No. Default value is: No

Remarks

Use this option to skip Form and Group eligibility checks. This can speed up the time it takes to open the Form Selection dialog in Entry.

Example

< Control >

SkipAFEEligibleCheck = Yes

Available

Release | 12.0
Patch | NA

Used By

AFEMAIN


SortedSetRcp

[Control]
SortedSetRcp

SortedSetRcp

The SortedSetRcp option specifies whether the triggers table is sorted.

[ Control]

SortedSetRcp = YN

Parameter | Description
Boolean | Yes, No

Remarks

The format for this option is:

< Control >

SortedSetRcp = Yes

In the traditional base triggers logic, if the triggers table is sorted, this option can enable better performance during the triggering operations.

Example

< Control >

SortedSetRcp = Yes

Available

Release | _______
Patch |

Used By

GENDATA


SuppressAssign

[Control]
SuppressAssign

SuppressAssign

[ Control]

SuppressAssign = YN

Parameter | Description
Boolean | value

Example

< Control >

SuppressAssign = Yes

Available

Release | _______
Patch |

Used By

AFELIB


TemplateDelimiters

[Control]
TemplateDelimiters

TemplateDelimiters

[Control]

TemplateNumber = ??

Parameter | Description
Characters | Characters used to delimit field names when printing templates. The default is square brackets. [field]

Remarks

To change the characters used to delimit the edges of the field define this option where the value is a 2 character string representing the left and right delimiters, respectively.

Example

< Control >

TemplateDelimiters = <>

Available

Release | 12.1
Patch |


TemplateNumber

[Control]
TemplateNumber

TemplateNumber

Enter Yes to see numbers on multi-line text field templates.

[ Control]

TemplateNumber =

Parameter | Description
Boolean | Enter Yes to see numbers on multi-line text field templates.

Remarks

When you enter Yes, the first few replacement characters of each row are replaced by the line numbers, so the character counts will not be exact.

Example

< Control >

TemplateNumber = Yes

Available

Release | 10.2
Patch |


TemplateUseReplaceChar

[Control]
TemplateUseReplaceChar

TemplateUseReplaceChar

You can choose to see the row number of the multi-line text fields.

[Control]

TemplateUseReplaceChar =

Parameter | Description
value | You can choose to see the row number of the multi-line text fields. The default is to see the first few replacement characters in the row.

Remarks

The default is to see the first few replacement characters in the row. Place these options in the FAPCOMP.INI file:

< Control >

TemplateUseReplaceChar =

TemplateNumber =

In addition to displaying and being able to change the number of columns and rows on the Documerge tab in Image Editor, you can use these INI options to specify the replacement character for the tag field. The default is X.

Enter Yes to see the BPSD character instead of X, which is the default.

Please note that the calculation of the width to display for each field is based on the character width of the letter X. If you choose to view the replacement characters, the exact number of characters may not appear in each row.

Wider replacement characters may mean fewer characters per row appear. Narrower characters may mean more

characters appear.

Keep in mind that this only affects the display the number of replacement characters per row is still contained in the

document used by Documerge.

Displaying either the X or the replacement character simply gives you an idea of how much space you have on the document before it processed by Documerge and merged with live data.

Example

< Control >

TemplateUseReplaceChar =

Available

Release | 10.2
Patch |


TemplateWithName

[Control]
TemplateWithName

TemplateWithName

[Control]

TemplateWithName = Yes

Parameter | Description
Boolean | Enter No to override the default template with field name behavior.

Remarks

Enter No to see X's as field templates rather than field names enclosed in square brackets.

Example

< Control >

TemplateWithName = Yes

Available

Release | 12.1
Patch |


Title

[Control]
Title

Title

This option assigns the title to the Image Editor window.

[ Control]

Title = Edit

Parameter | Description
Edit |

Example

< Control >

Title = Image Editor

Available

Release | _______
Patch |


TXMRulers

[Control]
TXMRulers

TXMRulers

[ Control]

TXMRulers = Yes

Parameter | Description
boolean | Default value is: Yes

Remarks

Use this INI option to tell Documaker Studio or Image Editor whether you want to show the Rulers in the Text Area Editor. If you are using Image Editor, you can specify this setting by choosing Options, Default Properties, and then the Text Area tab. The default is Yes.

Example

<Control>

TXMRulers = No

Available

Release | _______
Patch |


TXMStatusLine

[Control]
TXMStatusLine

TXMStatusLine

[ Control]

TXMStatusLine = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Use this INI option to tell Documaker Studio or Image Editor whether you want to show the Status Line in the Text Area Editor. If you are using Image Editor, you can specify this setting by choosing Options, Default Properties, and then the Text Area tab. The default is Yes.

Example

<Control>

TXMStatusLine = No

Available

Release | _______
Patch |


TXMTitleBar

[Control]
TXMTitleBar

TXMTitleBar

[ Control]

TXMTitleBar = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Use this INI option to tell Documaker Studio or Image Editor whether you want to show the Title Bar in the Text Area Editor. If you are using Image Editor, you can specify this setting by choosing Options, Default Properties, and then the Text Area tab. The default is No.

Example

<Control>

TXMTitleBar = Yes

Available

Release | _______
Patch |


TXMToolBar

[Control]
TXMToolBar

TXMToolBar

[ Control]

TXMToolBar = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Use this INI option to tell Documaker Studio or Image Editor whether you want to show the Toolbar in the Text Area Editor. If you are using Image Editor, you can specify this setting by choosing Options, Default Properties, and then the Text Area tab. The default is Yes.

Example

<Control>

TXMToolBar = No

Available

Release | _______
Patch |


UseBaseDef

[Control]
UseBaseDef

UseBaseDef

Set to Yes if you intend to use a BASEDEF defined within the MasterResource group.

[ Control]

UseBaseDef = No

Parameter | Description
boolean | Set to Yes if you intend to use a BASEDEF defined within the MasterResource group. When this option is set to NO (or not defined at all) the BASEDEF ini option is ignored. Default value is: No

Remarks

Special Note: Starting in 10.3, BASEDEF will always be used and the INI option will not be valid.

Example

< Control >

UseBaseDef = Yes

Available

Release | _______
Patch |


ValidateTableOnlyKey

[Control]
ValidateTableOnlyKey

ValidateTableOnlyKey

Lets you force data entry users to enter valid key entries in table-only variable fields.

[ Control]

ValidateTableOnlyKey = No or False

Parameter | Description
boolean (No) | Lets you force data entry users to enter valid key entries in table-only variable fields. Only when you have the INI option set to YES and only when the Table-Only field is returning the "Key" value (Not Description, or Key+Desc) will we validate that the user actually picked a value from the table. In all other circumstances, it is permissible for the user to type their own value. Default value is: No or False

Remarks

Lets you force data entry users to enter valid key entries in table-only variable fields. If the user enters a value that is not a valid table key, the system displays a message asking the user to select a value from the table.

This only works on fields declared as Table-Only and which return the Key only Value from the table. This option has no affect if the field returns Description only, Key+Description, or Description+Key.

Keep in mind that the system only validates the field when the field is edited. This validation, like all other format validations, is not checked when you use the RequiredFields option in the Control group.

Example

< Control >

ValidateTableOnlyKey =

Available

Release | 10.1
Patch |


WIPListMaxRecords

[Control]
WIPListMaxRecords

WIPListMaxRecords

[ Control]

WIPListMaxRecords = Spin

Parameter | Description
Spin |

Remarks

This option specifies the maximum number of items appearing in the WIP list.

Example

< Control >

WIPListMaxRecords = 20

Available

Release | _______
Patch |


XrfExt

[Control]
XrfExt

XrfExt

XrfExt defines the extension of font cross reference files.

[ Control]

XrfExt =

Available

Release | _______
Patch |


Zoom

[Control]
Zoom

Zoom

ActualSize, FidToWidth, FitToWindow, and Zoom setup the default zoom settings in Documaker Workstation and Image Editor.

[ Control]

Zoom = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The following INI option sets the default zoom setting to "Actual Size."

< Control >

ActualSize = Yes

The following INI options set the default zoom setting to "FitToWidth" (i.e. to display the full width of the image in the system window. This lets you see the full width of an image if it is larger than your window).

< Control >

ActualSize = No

The following INI options set the default zoom setting to "FitToWindow" (i.e. to display the entire image in an active window. This lets you see the image from top to bottom as a whole unit on the screen.)

< Control >

ActualSize = No

FitToWidth = No

FitToWindow = Yes

The following INI options set the default zoom setting to "Zoom %."

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

ZoomMult =

ZoomDiv =

If you use Image Editor, you can set up the default zoom settings by selecting Options, Editor Properties, Zoom tab.

Example

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

ZoomMult = 1414

ZoomDiv = 1000

Available

Release | _______
Patch |


ZoomDiv

[Control]
ZoomDiv

ZoomDiv

Use ActualSize, FidToWidth, Zoom, ZoomMult and ZoomDiv to setup the default zoom % in Documaker Workstation and Image Editor.

[ Control]

ZoomDiv = 1 if using Zoom %

Parameter | Description
Spin | Default value is: 1 if using Zoom %

Remarks

The values of the ZoomMult and ZoomDiv options are integers.

The following is how these two INI options are used to determine the Zoom %:

Zoom % = Square power of (ZoomMult divided by ZoomDiv)

The square power is needed because the area = height * width (e.g. if we say “increase it by 2”, actually the area is increased 4 times = 2 for height * 2 for width = 4.)

For example:

ZoomMult = 1414

ZoomDiv = 1000

Zoom % = (1414/1000) * (1414/1000) = 1.414 * 1.414 = 1.99936 = 200%

Or

ZoomMult = 2

ZoomDiv = 1

Zoom % = (2/1) * (2/1) = 4 = 400%

Set up the following INI options to tell the system to use the ZoomMult and ZoomDiv options (i.e. Zoom %).

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

If you use Image Editor, you can set up the default zoom settings by selecting Options, Editor Properties, Zoom tab.

Example

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

ZoomMult = 1414

ZoomDiv = 1000

Available

Release | _______
Patch |


ZoomMult

[Control]
ZoomMult

ZoomMult

[ Control]

ZoomMult =

Available

Release | _______
Patch |


ZoomMulti

[Control]
ZoomMulti

ZoomMulti

Use ActualSize, FidToWidth, Zoom, ZoomMult and ZoomDiv to setup the default zoom % in Documaker Workstation and Image Editor.

[ Control]

ZoomMulti = 1 if using Zoom %

Parameter | Description
Spin | Default value is: 1 if using Zoom %

Remarks

The values of the ZoomMult and ZoomDiv options are integers.

The following is how these two INI options are used to determine the Zoom %:

Zoom % = Square power of (ZoomMult divided by ZoomDiv)

The square power is needed because the area = height * width (e.g. if we say “increase it by 2”, actually the area is increased 4 times = 2 for height * 2 for width = 4.)

For example:

ZoomMult = 1414

ZoomDiv = 1000

Zoom % = (1414/1000) * (1414/1000) = 1.414 * 1.414 = 1.99936 = 200%

Or

ZoomMult = 2

ZoomDiv = 1

Zoom % = (2/1) * (2/1) = 4 = 400%

Set up the following INI options to tell the system to use the ZoomMult and ZoomDiv options (i.e. Zoom %).

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

If you use Image Editor, you can set up the default zoom settings by selecting Options, Editor Properties, Zoom tab.

Example

< Control >

ActualSize = No

FitToWidth = No

Zoom = Yes

ZoomMult = 1414

ZoomDiv = 1000

Available

Release | _______
Patch |


Conversion

Conversion Options

  • FIXFAP


FIXFAP

[Conversion]
FIXFAP

FIXFAP

Use this FAPCOMP.INI control group to specify the output location for files processed using the File, Conversion Setup option.

[ Conversion]

FIXFAP = Path

Parameter | Description
Path |

Remarks

The FIXFAP setting specifies where you want the system to place converted FAPs after you convert them using the File, Convert, Multiple FAPs option from the DAP Development System menu.

Example

< Conversion >

FIXFAP =

Available

Release | _______
Patch |


CST_EntryFormSet_Funcs

Remarks

Before, you could define only one hook, now you can use an approach similar to that used for CSTW32->CSTInitFuncs which lets you call a series of additional hook functions.

Here is an example of how you would do this:

< AFEProcedures >

EntryFormset = CSTW32->CSTMultiEntryFormsetHooks

< CST_EntryFormSet_Funcs >

01 = MYDLL->MyEntryFormsetFunc

02 = YOURDLL->YourEntryFormsetFunc

All messages normally passed to the hook are passed to all hooks listed under the new INI group. If any hook function does not return success, the process ends and an error is returned to the calling process.

Example

< CST_EntryFormSet_Funcs >

01 = MYDLL->MyEntryFormsetFunc

02 = YOURDLL->YourEntryFormsetFunc

CST_EntryFormSet_Funcs Options

  • 01


01

[CST_EntryFormSet_Funcs]
01

01

[ CST_EntryFormSet_Funcs]

01 = Edit

Parameter | Description
value |

Remarks

Please refer to the Remarks under [CST_EntryFormSet_Funcs] control group for details.

Example

< CST_EntryFormSet_Funcs >

01 = MYDLL->MyEntryFormsetFunc

Available

Release | 10.2
Patch |


DAL

DAL Options

  • EXT


EXT

[DAL]
EXT

EXT

EXT defines the file extension to be used for DAL functions.

[ DAL]

EXT = Edit

Parameter | Description
Edit | The file extension to use when DAL scripts are referenced and the extension is not present in the script reference.

Remarks

Use this FSISYS.INI and FAPCOMP.INI control group to define DAL functions. The file extension to use when DAL scripts are referenced and the extension is not present in the script reference.

Example

< DAL >

EXT = .DAL

Available

Release | _______
Patch |


DALFunctions

Remarks

Use this INI control group to register any number of DAL functions. Once registered, DAL will automatically call a routine each time a script reference to the routine's name is encountered.

It is possible to override an existing built-in routine by registering another one with the same name. The routines named in these INI options are registered after the internal built-in functions. When a keyword is registered a second time, the latter registration will override the first.

The format for this option is:

< DALFunctions >

KeyWord = DLL->FuncName1

KeyWord2 = DLL->FuncName2

The example above demonstrates INI registration of two DAL functions, and to assign the DAL functions to the DAL keywords. Any number of functions can be registered in this manner.

The value to the left of the equal sign represents the DAL verb or keyword, that will be used in DAL scripts when the specified function should be called. Valid DAL keywords may not contain a space. Some special symbols are permitted but not mathematical symbols or parentheses. Case is not important on DAL keywords. After the equal sign, the standard DLL->FuncName convention is used to name a DLL to load and an exported function to call. Remember that case is usually important when naming DLL exported functions.

The routines named in these INI options are registered after the internal "built-in" functions. When a keyword is registered a second time, the latter registration will override the first. This makes it possible to substitute your own functionality for internally defined DAL functions and procedures.

Example

< DALFunctions >

KeyWord = DLL->FuncName1

KeyWord2 = DLL->FuncName2

DALFunctions Options

  • KeyWord


KeyWord

[DALFunctions]
KeyWord

KeyWord

[ DALFunctions]

KeyWord =

Parameter | Description
value | Use this FSISYS.INI control group to register DAL functions.

Remarks

Please refer to the Remarks under < DALFunctions > control group for details.

Example

< DALFunctions >

KeyWord = DLL->FuncName1

Available

Release | _______
Patch |


DALLibraries

DALLibraries Options

  • CompileWhenLoaded
  • LIB


CompileWhenLoaded

[DALLibraries]
CompileWhenLoaded

CompileWhenLoaded

[ DALLibraries]

CompileWhenLoaded = YN

Parameter | Description
Boolean |

Remarks

Use this option to tell the system whether to automatically compile the DAL scripts when loaded.

Example

<DALLibraries>

CompileWhenLoaded = Yes

Available

Release | _______
Patch |


LIB

[DALLibraries]
LIB

LIB

[ DALLibraries]

LIB =

Parameter | Description
value |

Remarks

This option tells the system to automatically load the DAL subroutine libraries. Loading multiple DAL libraries is supported. You may use this option with the banner processing feature in GenPrint as follows:

First, specify a DAL script that runs at the start of each transaction. The DAL script calls the AddBlankPages function. This tells the system to convert each transaction to a fully duplexed form set with blank pages added as needed.

Here is an example of the INI settings you would need:

< Printer >

EnableTransBanner = True

TransBannerBeginScript = PreBatch

< DALLibraries >

LIB = BANNER

The BANNER.DAL file is shown as below:

BeginSub PreBatch

AddBlankPages()

EndSub

Example

< DALLibraries >

LIB = BANNER

LIB = crxpress.dal

LIB = common.dal

Available

Release | 10.2
Patch |


Data

Remarks

The < Data > group specifies the names of various files written to and read from while running Documaker.

Message files (MSG) , Error and Log files. Also Nafile, NewTrn, and PolFile, and TrnFile.

Example

< Data >

AfgJobFile = afgjob.jdt

DataPath = .\data\

DBLogFile = dblogfile.dat

ErrFile = errfile.dat

Exclude = exclude.dat

ExtrFile = extrfile.dat

LogFile = logfile.dat

Manual = manual.dat

MsgFile = msgfile.dat

NaFile = nafile.dat

NewTrn = newtrn.dat

PolFile = polfile.dat

RcbDFDFile = rcbdfdfl.dfd

SetRcpTb = setrcptb.dat

TblFile = tblfile.dat

TextTbl = texttbl.dat

TraceFile = trace.dat

TranslationFile = translat.ini

TrnDFDFile = trndfdfl.dfd

TrnFile = trnfile.dat

Wipbatch = manual.dat

Data Options

  • AfgJobFile
  • BatchTable
  • DataPath
  • Db2TrnDfd
  • DBLogFile
  • ErrFile
  • Exclude
  • Extrfile
  • LogFile
  • Manual
  • MsgFile
  • NAFile
  • NewTrn
  • POLFile
  • RcbDFDFile
  • SetRcpTb
  • TblFile
  • TextTbl
  • TraceFile
  • TranslationFile
  • TrnDFDFile
  • TrnFile
  • Wipbatch


AfgJobFile

[Data]
AfgJobFile

AfgJobFile

Name of the AfgJobFile (also known as the Job Definition Table - JDT)

[ Data]

AfgJobFile = Edit

Parameter | Description
name | Name of the AfgJobFile (a.k.a. JDT)

Remarks

The AfgJobFile option specifies the name of the Job Definition Table (JDT) file. The JDT is used to drive the DocuMaker Rules Processor. The search order for the JDT file goes as follows: 1. If the AfgJobFile specifies a fully-qualified filename, that fully-qualified filename is searched for. 2. AfgJobFile is searched for in the DEFLIB (see <MasterResource> DEFLIB= option).

MVS Note:

If the <VSAM> JDTVSAM= option is specified, the indicated VSAM file is searched. DocuMaker expects to locate records in the JDTVSAM file that contain a key matching the AfgJobFile filename, minus the extension (e.g. &quot;AFGJOB&quot;).

Example

< Data >

AfgJobFile = afgjob.jdt

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


BatchTable

[Data]
BatchTable

BatchTable

Use this option to specify a file in which users of the batch system can group all of their print batches (.BCH files).

[ Data]

BatchTable = Path

Parameter | Description
BatchTable = tablename |

Remarks

If a path is not specified here, the option DATAPATH in the <DATA> group will be used. Additionally, to enable the group batch print feature, you must make the following entry in the FSISYS.INI RUNMODE control group:

< RUNMODE >

AliasPrintBatches = Yes

Example

< DATA >

BatchTable = tablename

Available

Release | _______
Patch |


DataPath

[Data]
DataPath

DataPath

Defines the paths for all the files mentioned in this control group. Ex. NaFile, PolFile, TrnFile,.

[ Data]

DataPath =

Parameter | Description
location | Location of DataPath

This option may be required in order for the feature to function.

Note

DM19013

Example

< Data >

DataPath = .\data\

Available

Release | 10.0
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


Db2TrnDfd

[Data]
Db2TrnDfd

Db2TrnDfd

This option specifies the name of the DB2 transaction file DFD.

[ Data]

Db2TrnDfd = File

Parameter | Description
Db2TrnFl.Dfd |

Remarks

Data format definition (DFD) files define to the system the database file formats of the files generated by the system.

Example

< Data >

Db2TrnDfd = Db2TrnFl.Dfd

Available

Release | _______
Patch |


DBLogFile

[Data]
DBLogFile

DBLogFile

[ Data]

DBLogFile =

Parameter | Description
name | Name of the DBLogFile

Remarks

(optional) DB log file name and path. If you omit the path, the PrintPath attachment variable is used. If the PrintPath was omitted, the system uses the PrintPath defined in the IDSServer control group. If the file name is omitted, the system creates a 46-byte unique file name.

Example

< Data >

DBLogFile = dblogfile.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


ErrFile

[Data]
ErrFile

ErrFile

Name of the ERRFILE.

[ Data]

ErrFile =

Parameter | Description
name | Name of the ErrFile

Remarks

Warning and Error messages are written to the ErrFile by processes such as Gentrn, Gendata, Genprint, Genarc.

Example

< Data >

ErrFile = errfile.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


Exclude

[Data]
Exclude

Exclude

Name of the Exclude file. This option is for the personal computer platform only.

[ Data]

Exclude = File

Parameter | Description
name | Name of the Exclude file

Remarks

It names the temporary extract file which is created when you run the GenTrn program with filtering on. At the end of the filtering process, the temporary extract file contains all of the original extract records except those which match the filtering criteria.

Example

< Data >

Exclude = exclude.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


Extrfile

[Data]
Extrfile

Extrfile

Name of the Extract file.

[ Data]

Extrfile =

Parameter | Description
name | Name of the Extract file

Remarks

The value of this option is the path and the file name of the extract file. If the path is not specified, the system will use the directory defined with the < Data > Datapath INI option. You can use a complete directory path (for example: \input\extract.dat) or a path relative to the current working directory (for examaple: ..\input\extract.dat).

There are two different modes in which an extract file can be used:

(A) Extract file has the actual data. The system supports the text file and XML file types for the extract file. If your extract file is in the XML file format, be sure to set the following INI option to tell the system that you are using the XML file:

< RunMode >

XMLExtract = Yes

(B) The Extract file has a pointer to the file that contains the real data. This feature is supported only if the extract file is in the XML file type. You would need the XMLFileExtract form set level (level 2) rule in your AFGJOB.JDT file for this feature to work. Please refer to the "Rules Reference" book for the detailed information regarding the XMLFileExtract rule. Additionally, in the RunMode control group, be sure to set these INI options, for example:

< RunMode >

XMLExtract = Yes

XMLFileExtract = Yes

XMLFileExtractName = SCH=1,XML 20,60

Set the XMLFileExtract option to Yes to tell the system your extract file contains a list of pointers pointing to the XML file to be processed. Use the XMLFileExtractName option to tell the system how to find your XML file. Enter the method you use to point to your XML file. This should be exactly the same as how you would set up the rule parameter for the XMLFileExtract rule in your AFGJOB.JDTfile.

The actual data on the extract file is read by the Gentrn and Gendata processes and merged into Forms.

Example

< Data >

ExtrFile = extrfile.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


LogFile

[Data]
LogFile

LogFile

Name of the Log file.

[ Data]

LogFile =

Parameter | Description
name | Name of the Log file

Remarks

Logging messages are written to the LogFile by processes such as Gentrn, Gendata, Genprint and Genarc. Logging can be turned on or off by setting the <Control> LogTransactions option to Yes or No.

Example

< Data >

LogFile = logfile.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


Manual

[Data]
Manual

Manual

Name of the Manual file.

[ Data]

Manual =

Parameter | Description
name | Name of the Manual file

Example

< Data >

Manual = manual.dat

Available

Release | _______
Patch |

Used By

GENDATA, GENPRINT, GENWIP


MsgFile

[Data]
MsgFile

MsgFile

Name of the Message file.

[ Data]

MsgFile =

Parameter | Description
name | Name of the Message file

Remarks

The MsgFile is an intermediate file. Processes such as Gentrn, Gendata, Genprint and Genarc first write warning and error messages to the MsgFile in a tokenized format. Just before terminating, a process such as Gentrn will &quot;translate&quot; the tokenized messages in the MsgFile into readable Warning and Error messages and write those messages to the ErrFile. This translation process uses the Translation file specified in the <Data> TranslationFile= INI option.

Example

< Data >

MsgFile = msgfile.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


NAFile

[Data]
NAFile

NAFile

Name of the NA file.

[ Data]

NAFile =

Parameter | Description
name | Name of the NA file

This option may be required in order for the feature to function.

Remarks

The NAFile is written to by the Gendata process and is read from by the Genprint, Genwip and Genarc processes.

To indicate that the NAFile is a VSAM file, use the <VSAM> NAFile= INI option.

Example

< Data >

NAFile = nafile.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


NewTrn

[Data]
NewTrn

NewTrn

Name of the NewTrn file.

[ Data]

NewTrn =

Parameter | Description
name | Name of the NewTrn file

This option may be required in order for the feature to function.

Remarks

The NewTrn file is written to by the Gendata process and is read from by the Genprint, Genwip and Genarc processes.

Example

< Data >

NewTrn = newtrn.dat

Available

Release | 10.0
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


POLFile

[Data]
POLFile

POLFile

Name of the POL file.

[ Data]

POLFile =

Parameter | Description
name | Name of the POL file

Remarks

The POLFile is written to by the Gendata process and is read from by the Genprint, Genwip and Genarc processes. To indicate that the POLFile is a VSAM file, use the <VSAM> NAFile= INI option (NAFile and POLFile work together as a pair).

Example

< Data >

POLFile = polfile.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


RcbDFDFile

[Data]
RcbDFDFile

RcbDFDFile

Name of the Recipient Batch DFD file.

[ Data]

RcbDFDFile =

Parameter | Description
name | Name of the Recipient Batch DFD file

This option may be required in order for the feature to function.

Remarks

The Recipient Batch DFD file describes the record layout of the Recipient Batch files. These files are written to by the Gendata process and read by the Genprint process.

Example

< Data >

RcbDFDFile = rcbdfdfl.dfd

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


SetRcpTb

[Data]
SetRcpTb

SetRcpTb

Name of the Set Recipient Table.

[ Data]

SetRcpTb =

Parameter | Description
name | Name of the Set Recipient Table

Remarks

The Set Recipient Table is created by the FormSet Editor to indicate when (and how many) forms / images are triggered to be added to a document set. Gendata reads the Set Recipient Table

Example

< Data >

SetRcpTb = setrcptb.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


TblFile

[Data]
TblFile

TblFile

Name of the Table file.

[ Data]

TblFile = File

Parameter | Description
name | Name of the Table file

Remarks

This option names the tables list file which is used by batch processing to load text tables during processing.

Example

< Data >

TblFile = tblfile.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


TextTbl

[Data]
TextTbl

TextTbl

Name of the Text Table file.

[ Data]

TextTbl = File

Parameter | Description
name | Name of the Text Table file

Remarks

This option is used by the Batch Processing System to load all specified text tables into the text table list for use by field level rules. TextTbl names the table to be loaded.

Example

< Data >

TextTbl = texttbl.dat

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


TraceFile

[Data]
TraceFile

TraceFile

Use the TraceFile option to define the debug output file name.

[ Data]

TraceFile = Trace

Parameter | Description
File | Default value is: Trace

Remarks

DBLib-related trace (or log) messages have been expanded upon and are now written to the trace file. The name of the trace file defaults to "trace" but you can set it to another file name using the TraceFile option.

Note: In release 10.2, DBLib-related logging messages were written to the file indicated by this option:

< Data >

DBLogFile = (file name)

The default is DBLOGFLE.DAT.

Keep in mind, all types of tracing, including DBLib tracing, slow performance. You should only activate DBLib tracing during development and testing or if requested by support personnel.

In the Rules Processor, the Trace file for DBLIB log messages is the default logging file. You can activate DBLib tracing by specifying these INI options in the FSISYS.INI file:

< Debug_Switches >

Enable_Debug_Options = Yes

DBLib = Yes

In IDS, the default logging file is the DPRTRC.LOG file DBLIB log messages. You can enter the INI options in the DAP.INI file or the MRL-specific INI file.

Additionally this INI option can be used along with other debug switches such as DXMLib, DumpDAL, etc.

Example

< Data >

TraceFile = Trace.txt

Available

Release | 10.3
Patch | 70


TranslationFile

[Data]
TranslationFile

TranslationFile

Name of the Translation file.

[ Data]

TranslationFile =

Parameter | Description
name | Name of the Translation file

Remarks

The Translation file is used to translate tokenized Warning and Error messages in the MSGFile to the ERRFile. Processes such as Gentrn, Gendata, Genprint and Genarc use the Translation file.

Example

< Data >

TranslationFile = translat.ini

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


TrnDFDFile

[Data]
TrnDFDFile

TrnDFDFile

Name of TrnFile DFD file.

[ Data]

TrnDFDFile =

Parameter | Description
name | Name of TrnFile DFD file

Remarks

The TrnDFDFile describes the record layout of both the TrnFile and NewTrn files.

The same DFD defines both the TRNFILE (generated by GenTrn and read by GenData) and the NEWTRN file (written by GenData and read by GenWIP and GenARC). The DFD is identified by the INI option.

Example

< Data >

TrnDFDFile = trndfdfl.dfd

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


TrnFile

[Data]
TrnFile

TrnFile

Name of the TrnFile.

[ Data]

TrnFile =

Parameter | Description
name | Name or Path and Name of the TrnFile

Remarks

The TrnFile is created only by the Gentrn process.

For the standard rules processor three step process: (GenTrn, GenData, GenPrint) the TrnFile will be produced after running the GenTrn process. The TrnFile will contain 1 record for each transaction; that is found in the customer Extract file (ExtrFile). The record layout of the TrnFile is described by the DFD file indicated by the TrnDFDFile INI option. The Gendata process reads the TrnFile.

For other rules processor modes, for example the two step (GenData and Genprint) processes, the TrnFile will not be produced.

In these cases, you still enter a value for this option. However, the value will be set to .\NUL

Note: The TrnFile option supports a full path including the file name.

This is important because the full path and file name will be used in place of the DataPath location.

For Documaker Server RP or Documaker rules processor, the DataPath file option can accept and use UNC names.

This is true for most Data Control group options including TrnFile.

However, when you use Docupresentment (IDS) to run the rules processor (which must run in one step mode), the DataPath file option will not support UNC names in conjunction with a NUL value in the TrnFile option field.

So, you would want to specify the full path and file name as (.\NUL) whenever you wish to use a NUL value and the DataPath uses an UNC name.

Note

DM11152; DM12041

Example

Three Step Rules Processor: (GenTrn, GenData, GenPrint):

< Data >

TrnFile = trnfile.dat

Or,

Two Step Rules Processor: (GenData, GenPrint):

One Step Rules Processor: (GenData):

< Data >

TrnFile = .\NUL

Available

Release | 10.0
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


Wipbatch

[Data]
Wipbatch

Wipbatch

Name of the Wipbatch file.

[ Data]

Wipbatch = File

Parameter | Description
name | Name of the Wipbatch file

Remarks

This option specifies the file GenWip uses to place form sets with incomplete data into WIP so that a data entry operator can complete data entry.

Example

< Data >

Wipbatch = manual

Available

Release | _______
Patch |

Used By

GENWIP


DataDictionary

DataDictionary Options

  • Name


Name

[DataDictionary]
Name

Name

Name of DataDictionary file.

[ DataDictionary]

Name =

Parameter | Description
name | The name of the data dictionary file must be defined in the DataDictionary control group

Remarks

The name of the data dictionary file must be defined in the DataDictionary control group

Example

< DataDictionary >

Name = DataDict

Available

Release | 10.0
Patch |


DB2_FileConvert

Remarks

This control group is used to map the table names defined in the DBTable:tablename or ArcRet control group (e.g. APPIDX, CATALOG, etc.) to the "real" DB2 table names as it exists on the database management system. The table names defined in the DBTable: control group may not exceed eight characters. However, for DB2, the "real" table name can be up to 18 characters long. If the "real" table names are not longer than eight characters, you do not need to make any entries in the DB2_FileConvert control group. If this is not specified, the table name defined in the DBTable or ArcRet control group is used.

Example 1:

[DB2_FileConvert]

APPIDX = DAP100_APP_R1

The option on the left (APPIDX) is the value associated with the corresponding option in the ArcRet control group. The value on the right (DAP100_APP_R1) is the name of the DB2 table as it exists in the DB2 subsystem.

Example 2:

[DB2_FileConvert]

LBYI = DAP110_LBYI

The option on the left (LBYI) is the table name used in the DBTable:LBYI control group. The value on the right (DAP110_LBYI) is the name of the DB2 table as it exists in the DB2 subsystem.

Example

< DB2_FileConvert >

APPIDX = FSIV100_APP_R1

ARCHIVE = FSIV100_ARC_R1

CATALOG = FSIV100_CAT_R1

RESTART = FSIV100_RES_R1

LBYI = DAP110_LBYI

LBYD = DAP110_LBYD

DB2_FileConvert Options

  • Catalog


Catalog

[DB2_FileConvert]
Catalog

Catalog

[ DB2_FileConvert]

Catalog =

Parameter | Description
Edit | DB2 Catalog Table name

Remarks

Please refer to the Remarks under the <DB2_FileConvert> control group for detailed information.

Available

Release | _______
Patch |


DBHandler:ASCII

DBHandler:
ASCII

DBHandler:ASCII Options

  • Class
  • Description
  • InstallFunc
  • InstallMod


Class

[DBHandler:ASCII]
Class

Class

[ DBHandler:ASCII]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • ASCII

Remarks

This option lets you specify ASCII as the class of the Database Handler.

Example

< DBHandler:ASCII >

Class = ASCII

Available

Release | _______
Patch |


Description

[DBHandler:ASCII]
Description

Description

[ DBHandler:ASCII]

Description = Edit

Parameter | Description
Edit |

Remarks

This option lets you specify the description of the Database Handler

Example

< DBHandler:ASCII >

Description = ASCII database handler

Available

Release | _______
Patch |


InstallFunc

[DBHandler:ASCII]
InstallFunc

InstallFunc

This option names the function call to load the ASCII Database Handler.

[ DBHandler:ASCII]

InstallFunc =

Parameter | Description
value |

Example

< DBHandler:ASCII >

InstallFunc = ASCInstallHandler

Available

Release | _______
Patch |


InstallMod

[DBHandler:ASCII]
InstallMod

InstallMod

This option names the DLL where the ASCII database handler install function is located.

[ DBHandler:ASCII]

InstallMod = File

Parameter | Description
File | This option names the DLL where the ASCII database handler install function is located.

Example

< DBHandler:ASCII >

InstallMod = ASCW32

Available

Release | _______
Patch |


DBHandler:CB5

DBHandler:
CB5

DBHandler:CB5 Options

  • Class
  • Description
  • InstallFunc
  • InstallMod
  • LockAttempts


Class

[DBHandler:CB5]
Class

Class

This option lets you specify codebase as the class of the Database Handler.

[ DBHandler:CB5]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • CB5

Example

< DBHandler:CB5 >

Class = CB5

Available

Release | _______
Patch |


Description

[DBHandler:CB5]
Description

Description

This option lets you specify the description of the Database Handler.

[ DBHandler:CB5]

Description = Edit

Parameter | Description
Edit |

Example

< DBHandler:CB5 >

Description = CB5 database handler

Available

Release | _______
Patch |


InstallFunc

[DBHandler:CB5]
InstallFunc

InstallFunc

This option names the function call to load codebase as the Database Handler.

[ DBHandler:CB5]

InstallFunc =

Parameter | Description
value |

Example

< DBHandler:CB5 >

InstallFunc = CBDBSysInit

Available

Release | _______
Patch |


InstallMod

[DBHandler:CB5]
InstallMod

InstallMod

This option names the DLL where the codebase database handler install function is located.

[ DBHandler:CB5]

InstallMod = File

Parameter | Description
value | This option names the DLL where the codebase database handler install function is located.

Example

< DBHandler:CB5 >

InstallMod = DB5W32

Available

Release | _______
Patch |


LockAttempts

[DBHandler:CB5]
LockAttempts

LockAttempts

Lets you specify the number of times the system will try to obtain a lock on a CodeBase data file. The default is 600.

[ DBHandler:CB5]

LockAttempts = 600

Parameter | Description
value | Lets you specify the number of times the system will try to obtain a lock on a CodeBase data file. The default is 600. Default value is: 600

Remarks

Since the system retries every second, the default is approximately five minutes of wait time. In a normal network environment, the time required to obtain a lock on a given file is usually negligible.

Normally, you would only need to modify this option if you are using the system on a wide area network (WAN) where file access times are affected.

NOTE: This option affects all CodeBase files.

Example

< DBHandler:CB5 >

LockAttempts =

Available

Release | 10.1
Patch |


DBHandler:DB2

DBHandler:
DB2

Example

< DBHandler:DB2 >

BindFile = .\..\dll\db2lib.bnd

Connect = Yes

CreateIndex = No

CreateTable = No

Database = ARCDB

Debug = Yes

Userid = UserId

Passwd = Password

DBHandler:DB2 Options

  • BindFile
  • Class
  • Connect
  • ConnectionTimer
  • CreateIndex
  • CreateTable
  • CurrentPackageSet
  • CurrentSQLID
  • Database
  • Debug
  • InstallFunc
  • InstallMod
  • NoCreateIndex
  • NoCreateTable
  • Passwd
  • UniqueTable
  • Userid


BindFile

[DBHandler:DB2]
BindFile

BindFile

Enter the name and path of the DB2LIB.BND file. This option names the database library Bind file.

[ DBHandler:DB2]

BindFile =

Parameter | Description
file name | name of DB2 Bind File

Remarks

This FSISYS.INI control group (where xxx represents the name of the database) designates the database that will be used for accessing the tables used during the GenArc process.

Example

< DBHandler:DB2 >

BindFile = .\..\dll\db2lib.bnd

< DBHandler:xxx >

Bindfile = e:\fap95W32\dll\filename.bnd

Available

Release | _______
Patch |


Class

[DBHandler:DB2]
Class

Class

This option lets you specify DB2 as the class of the Database Handler.

[ DBHandler:DB2]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • DB2

Example

< DBHandler:DB2 >

Class = DB2

Available

Release | _______
Patch |


Connect

[DBHandler:DB2]
Connect

Connect

[ DBHandler:DB2]

Connect = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Example

< DBHandler:DB2 >

Connect = Yes

Available

Release | _______
Patch |


ConnectionTimer

[DBHandler:DB2]
ConnectionTimer

ConnectionTimer

[ DBHandler:DB2]

ConnectionTimer = Spin

Parameter | Description
Spin |

Remarks

You can use the ConnectionTimer option with DB2, which lets you disconnect and then reconnect a DB2 server in a specific time range when running on IDS. Here is an example of how you could set this up:

< DBHandler:DB2 >

ConnectionTimer = (number of seconds)

This database handler maintains a countdown timer based on this INI setting that begins with the start of each requested task (query, select, etc.) that it performs. This countdown timer is reset at the end of each successful task. If the countdown is reached before subsequent tasks are requested then the handler refreshes the connection before proceeding. This is useful to avoid problems where systems (such as firewalls, DBMS server, OS, etc.) are configured to terminate connections after a known interval of time of inactivity.

Also, the DB2 handler now returns a specific error code if there is a communication error and the DAP Bridge will force IDS to restart in case this error is detected. For instance, in the DAP/Documaker world, if you are writing custom code you can check for: DB_ERROR_CONNECTION_FAILURE returned by DBGetLastError()

If found, it means the DB2 connection failed. The DAP bridge checks this value and causes IDS to restart. There are no INI settings for this part of the feature.

NOTE: Only specific error codes are being expected, so some communication errors might not be detected.

Example

< DBHandler:DB2 >

ConnectionTimer = 1000

Available

Release | 10.2
Patch | 128


CreateIndex

[DBHandler:DB2]
CreateIndex

CreateIndex

Indicates whether or not to allow the Documaker application to create an Index, if the Index does not already exist.

[ DBHandler:DB2]

CreateIndex = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< DBHandler:DB2 >

CreateIndex = No

Available

Release | 10.0
Patch |


CreateTable

[DBHandler:DB2]
CreateTable

CreateTable

Indicates whether or not to allow the Documaker application to create a Table, if the Table does not already exist.

[ DBHandler:DB2]

CreateTable = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Enter Yes so DB2 will create the table if it does not exist.

Example

< DBHandler:DB2 >

CreateTable = No

Available

Release | 10.0
Patch |


CurrentPackageSet

[DBHandler:DB2]
CurrentPackageSet

CurrentPackageSet

[ DBHandler:DB2]

CurrentPackageSet = NULLID

Parameter | Description
Edit | Default value is: NULLID

Remarks

CurrentPackageSet = collection_id where collection_id is the name of the Package that was listed when the Bind was performed for the Plan.

Use the CurrentPackageSet option to direct DB2 to select the DB2 package (usually called DB2LIB) that is associated with the indicated collection id. The collection_id is the value that was used for the COLLECTION parameter (if specified) when the DB2LIB package was bound to DB2. The collecton_id defaults to NULLID so the DB2LIB.BND bind file can be bound to a Collection called NULLID.

Example

<DBHandler:DB2>

CurrentPackageSet = JTH

Available

Release | 10.2
Patch | 102

Used By

DB2LIB


CurrentSQLID

[DBHandler:DB2]
CurrentSQLID

CurrentSQLID

Use the SQLID command line option to tell the GenArc program to perform a SET CURRENTSQLID=SQLID at initialization time.

[ DBHandler:DB2]

CurrentSQLID =

Parameter | Description
value | Use the SQLID command line option to tell the GenArc program to perform a SET CURRENTSQLID=SQLID at initialization time.

Remarks

You can also specify the SQLID option in the INI file as shown below:

< DBHANDLER:DB2 >

CurrentSQLID = xxxxxxxx

Example

< DBHANDLER:DB2 >

CurrentSQLID = xxxxxxxx

Available

Release | 10.0
Patch |


Database

[DBHandler:DB2]
Database

Database

[ DBHandler:DB2]

Database =

Parameter | Description
name | name of DB2 Database

Example

< DBHandler:DB2 >

Database = ARCDB

Available

Release | _______
Patch |


Debug

[DBHandler:DB2]
Debug

Debug

Indicates whether DB2 statements should be traced and written to the Trace file.

[ DBHandler:DB2]

Debug = No

Parameter | Description
boolean | Yes | No Default value is: No

Example

< DBHandler:DB2 >

Debug = Yes

Available

Release | _______
Patch |


InstallFunc

[DBHandler:DB2]
InstallFunc

InstallFunc

This option names the function call to load DB2 as the Database Handler.

[ DBHandler:DB2]

InstallFunc =

Parameter | Description
value | This option names the function call to load DB2 as the Database Handler.

Example

< DBHandler:DB2 >

InstallFunc = DB2InstallHandler

Available

Release | _______
Patch |


InstallMod

[DBHandler:DB2]
InstallMod

InstallMod

This option names the DLL where the DB2 install function is located.

[ DBHandler:DB2]

InstallMod = File

Parameter | Description
value | This option names the DLL where the DB2 install function is located.

Example

< DBHandler:DB2 >

InstallMod = DB2W32

Available

Release | _______
Patch |


NoCreateIndex

[DBHandler:DB2]
NoCreateIndex

NoCreateIndex

[ DBHandler:DB2]

NoCreateIndex = Yes

Parameter | Description
boolean (yes) | This option indicates whether indexes are to be created for the APPIDS DB2 table if the APPIDX (DFD) file contains KEYS information. Default value is: Yes

Remarks

This option indicates whether indexes are to be created for the APPIDS DB2 table if the APPIDX (DFD) file contains KEYS information. Option values are:

NoCreateIndex = No to create the DB2 indexes.

NoCreateIndex = Yes not to create the DB2 indexes.

Example

< DBHandler:DB2 >

NoCreateIndex = No

Available

Release | _______
Patch |


NoCreateTable

[DBHandler:DB2]
NoCreateTable

NoCreateTable

[ DBHandler:DB2]

NoCreateTable = No

Parameter | Description
Boolean | This option indicates whether DB2 tables that are used during the GenArc process can be created by GenArc or whether they must be created prior to running. Default value is: No

Remarks

This option indicates whether DB2 tables that are used during run time can be created by the Documaker application or whether they must be created prior to running. Option values are:

NoCreateTable = No to create the DB2 tables.

NoCreateTable = Yes not to create the DB2 tables.

Example

< DBHandler:DB2 >

NoCreateTable = No

Available

Release | _______
Patch |


Passwd

[DBHandler:DB2]
Passwd

Passwd

Specifies the Password to use with the Userid specified above when the Documaker application issues the DB2 Connect.

[ DBHandler:DB2]

Passwd =

Parameter | Description
passwd | Password to use for DB2 Connect

Remarks

If not specified, the DB2 Connect does not pass a Password.

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the

~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Example

< DBHandler:DB2 >

Passwd = Password

Available

Release | 10.0
Patch |


UniqueTable

[DBHandler:DB2]
UniqueTable

UniqueTable

This option names the table used for retrieving the current timestamp.

[ DBHandler:DB2]

UniqueTable = File

Parameter | Description
File | This option names the table used for retrieving the current timestamp.

Remarks

This table is a one column, one row table created by the user. If a table is not created by the user, the DB2

library will use SYSTABLES. If the UniqueTable= statement is in the INI file, the table must be present or you will get an error.

Example

< DBHandler:DB2 >

UniqueTable = Tablename

Available

Release | _______
Patch |


Userid

[DBHandler:DB2]
Userid

Userid

Specifies the Userid to use when the Documaker application issues the DB2 Connect.

[ DBHandler:DB2]

Userid =

Remarks

If not specified, the DB2 Connect does not pass a Userid.

Example

< DBHandler:DB2 >

Userid = UserId

Available

Release | 10.0
Patch |


DBHandler:DMIA

DBHandler:
DMIA

DBHandler:DMIA Options

  • Cabinet
  • Class
  • Debug
  • Domain
  • Passwd
  • RPCHost
  • UserID


Cabinet

[DBHandler:DMIA]
Cabinet

Cabinet

1286 New Interfaces for DMILIB

[ DBHandler:DMIA]

Cabinet = Edit

Parameter | Description
Edit |

Remarks

This release includes a new Documanage API. In version 10.3, DMILIB implements an archive interface and a Library Manager interface. You must modify your FSIUSER.INI options, where LBYCAB is the cabinet for Library Manager in Documanage and ARCCAB is the cabinet for Archive in Documanage.

DMILIB implements an archive interface and a Library Manager interface to Documanage.

You access the Library Manager interface using the DBHandler:DMIL control group. The system now uses a different Documanage line-of-business table and a different Documanage Category Document Extended Property setup is required.

< DBHandler:DMIA > is not backward compatible with < DBHandler:PO >. For DM Studio customers, you must use < DBHandler:DMIA > instead of < DBHandler:PO >, and you have to manually make the change to your INI file.

Example

< DBHandler:DMIA >

Cabinet = your_documanage_server_archive_cabinet_name

Available

Release | 11.0
Patch |


Class

[DBHandler:DMIA]
Class

Class

This option lets you specify Documanage Archive Datavase as the class of the Database Handler.

[ DBHandler:DMIA]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • DMIA

Example

< DBHandler:DMIA >

Class = DMIA

Available

Release | _______
Patch |


Debug

[DBHandler:DMIA]
Debug

Debug

1286 New Interfaces for DMILIB

[ DBHandler:DMIA]

Debug = Edit

Parameter | Description
Edit |

Remarks

This release includes a new Documanage API. In version 10.3, DMILIB implements an archive interface and a Library Manager interface. You must modify your FSIUSER.INI options, where LBYCAB is the cabinet for Library Manager in Documanage and ARCCAB is the cabinet for Archive in Documanage.

DMILIB implements an archive interface and a Library Manager interface to Documanage.

You access the Library Manager interface using the DBHandler:DMIL control group. The system now uses a different Documanage line-of-business table and a different Documanage Category Document Extended Property setup is required.

Example

< DBHandler:DMIA >

Debug = MAX ; optional debugging

Available

Release | 11.0
Patch |


Domain

[DBHandler:DMIA]
Domain

Domain

1286 New Interfaces for DMILIB

[ DBHandler:DMIA]

Domain = Edit

Parameter | Description
Edit |

Remarks

This release includes a new Documanage API. In version 10.3, DMILIB implements an archive interface and a Library Manager interface. You must modify your FSIUSER.INI options, where LBYCAB is the cabinet for Library Manager in Documanage and ARCCAB is the cabinet for Archive in Documanage.

DMILIB implements an archive interface and a Library Manager interface to Documanage.

You access the Library Manager interface using the DBHandler:DMIL control group. The system now uses a different Documanage line-of-business table and a different Documanage Category Document Extended Property setup is required.

Example

< DBHandler:DMIA >

Domain = your_domain

Available

Release | 11.0
Patch |


Passwd

[DBHandler:DMIA]
Passwd

Passwd

1286 New Interfaces for DMILIB

[ DBHandler:DMIA]

Passwd = Edit

Parameter | Description
Edit |

Remarks

This release includes a new Documanage API. In version 10.3, DMILIB implements an archive interface and a Library Manager interface. You must modify your FSIUSER.INI options, where LBYCAB is the cabinet for Library Manager in Documanage and ARCCAB is the cabinet for Archive in Documanage.

DMILIB implements an archive interface and a Library Manager interface to Documanage.

You access the Library Manager interface using the DBHandler:DMIL control group. The system now uses a different Documanage line-of-business table and a different Documanage Category Document Extended Property setup is required.

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the

~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Example

< DBHandler:DMIA >

Passwd = your_domain_password

Available

Release | 11.0
Patch |


RPCHost

[DBHandler:DMIA]
RPCHost

RPCHost

Feature 1286 New Interfaces for DMILIB

[ DBHandler:DMIA]

RPCHost = Edit

Parameter | Description
Edit |

Remarks

The new Library Manager interface is accessed using the < DBHandler:DMIL > INI option and has been changed in setup from the RP 10.2 interface in that a different Documanage Line-Of-Business table and different Documanage Category Document Extended Property setup is required.

The following is an example of a fsiuser.ini that shows the options used for both Archive using the ARCCAB cabinet in Documanage and for Library Manager using the LBYCAB cabinet in Documanage. This example has Library Manager turned-on for FAPs, LOGOs, and DDTs.

This release includes a new Documanage API. In version 10.3, DMILIB implements an archive interface and a Library Manager interface. You must modify your FSIUSER.INI options, where LBYCAB is the cabinet for Library Manager in Documanage and ARCCAB is the cabinet for Archive in Documanage.

DMILIB implements an archive interface and a Library Manager interface to Documanage.

You access the Library Manager interface using the DBHandler:DMIL control group. The system now uses a different Documanage line-of-business table and a different Documanage Category Document Extended Property setup is required.

< ArcRet >

Arrangement = Stack

AppIdxDfd = .\deflib\documanage\appidx.dfd

AppIdx = appidx

CarfileDfd = .\deflib\documanage\carfile.dfd

CARFILE = archive

CARPath = <CONFIG:Batch Processing> CARPath =

ARCPath = <CONFIG:Batch Processing> ARCPath =

; CATALOG = .\arc\catalog

ExactMatch = No

Key1 = Company

Key2 = Lob

KeyId = PolicyNum

LBLIMIT = 500

TEMPIDX = .\arc\temp

< CONFIG:Batch Processing >

ARCPath = .\arc

BaseDef =

CARPath = .\arc

CompLib = .\complib

DefLib = .\deflib

FntFile = rel95sm.fnt

FontLib = ..\fmres\deflib

Form7x =

FormDef = form.dat

FormLib = .\forms

FormsetTrigger = setrcptb.dat

HelpLib = .\help

TableLib = .\table;

WIPPath = .\wip

WIPPath = wip

XrfFile = rel95sm

; DALFile = LBYCAB

DDTFile = LBYCAB

DDTLib = LBYCAB

FormFile = LBYCAB

FormLib = LBYCAB

LogoFile = LBYCAB

LbyLib = LBYCAB

< Archival >

ArchiveMem = Yes

UseRestartTable = No

< MasterResource >

BaseDef = <CONFIG:Batch Processing> BaseDef =

CompLib = <CONFIG:Batch Processing> CompLib =

DalFile = <CONFIG:Batch Processing> DalFile =

DefLib = <CONFIG:Batch Processing> DefLib =

FntFile = <CONFIG:Batch Processing> FntFile =

FontLib = <CONFIG:Batch Processing> FontLib =

Form7x = <CONFIG:Batch Processing> Form7x =

FormDef = <CONFIG:Batch Processing> FormDef =

FormFile = <CONFIG:Batch Processing> FormFile =

FormLib = <CONFIG:Batch Processing> FormLib =

FormsetTrigger = <CONFIG:Batch Processing> FormsetTrigger =

HelpLib = <CONFIG:Batch Processing> HelpLib =

LogoFile = <CONFIG:Batch Processing> LogoFile =

TableLib = <CONFIG:Batch Processing> TableLib =

XrfFile = <CONFIG:Batch Processing> XrfFile =

DALFile = <CONFIG:Batch Processing> DALFile =

DDTLib = <CONFIG:Batch Processing> DDTLib =

DDTFile = <CONFIG:Batch Processing> DDTFile =

LbyLib = <CONFIG:Batch Processing> LbyLib =

< DBHandler:DMIA >

Userid = sbrown

Password = 1z2x3c4v

Cabinet = ARCCAB

Domain = DOCUMENT

Debug = MAX

< DBHandler:LBYSETUP >

CLASS = DMIL

Userid = your_documanage_userid

Password = your_documanage_password

Domain = DOCUMENT

Debug = MAX

< DBTable:LBYCAB >

DBHandler = LBYSETUP

SelfIndex = Yes

< DMIA:ARCCAB >

FileType = DAP

; FolderBy = KEY1,KEY2,KEYID

; NameDocBy = KEY1,KEYID,TRANCODE

FolderBy = Company,Lob,PolicyNum

NameDocBy = ARCKEY

< DBTable:archive >

DBHandler = DMIA

< DBTable:appidx >

DBHandler = DMIA

Example

< DBHandler:DMIA >

Userid = sbrown

Password = 1z2x3c4v

Cabinet = ARCCAB

Domain = DOCUMENT

Debug = MAX

< DBHandler:DMIA >

RPCHost = your_documanage_server_name_or_IP_address

UserID = your_domain_userID

Password = your_domain_password

Cabinet = your_documanage_server_archive_cabinet_name

Domain = your_domain

Debug = MAX ; optional debugging

Available

Release | 11.0
Patch |


UserID

[DBHandler:DMIA]
UserID

UserID

1286 New Interfaces for DMILIB

[ DBHandler:DMIA]

UserID = Edit

Parameter | Description
Edit |

Remarks

This release includes a new Documanage API. In version 10.3, DMILIB implements an archive interface and a Library Manager interface. You must modify your FSIUSER.INI options, where LBYCAB is the cabinet for Library Manager in Documanage and ARCCAB is the cabinet for Archive in Documanage.

DMILIB implements an archive interface and a Library Manager interface to Documanage.

You access the Library Manager interface using the DBHandler:DMIL control group. The system now uses a different Documanage line-of-business table and a different Documanage Category Document Extended Property setup is required.

Example

< DBHandler:DMIA >

UserID = your_domain_userID

Available

Release | 11.0
Patch |


DBHandler:DMS

DBHandler:
DMS

DBHandler:DMS Options

  • Class


Class

[DBHandler:DMS]
Class

Class

[ DBHandler:DMS]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • DMS

Remarks

This option lets you specify DMS as the class of the Database Handler.

Example

< DBHandler:DMS >

Class = DMS

Available

Release | _______
Patch |


DBHandler:LBYSETUP

DBHandler:
LBYSETUP

DBHandler:LBYSETUP Options

  • Class
  • Debug
  • Domain
  • Passwd
  • RPCHost
  • UserID


Class

[DBHandler:LBYSETUP]
Class

Class

This option must set to DMIL in order to use Documanage library.

[ DBHandler:LBYSETUP]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • DMIL

Example

[ DBHandler:LBYSETUP ]

Class = DMIL

Available

Release | _______
Patch |


Debug

[DBHandler:LBYSETUP]
Debug

Debug

[ DBHandler:LBYSETUP]

Debug =

Available

Release | _______
Patch |


Domain

[DBHandler:LBYSETUP]
Domain

Domain

[ DBHandler:LBYSETUP]

Domain =

Available

Release | _______
Patch |


Passwd

[DBHandler:LBYSETUP]
Passwd

Passwd

[ DBHandler:LBYSETUP]

Passwd =

Remarks

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the

~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn

control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Available

Release | _______
Patch |


RPCHost

[DBHandler:LBYSETUP]
RPCHost

RPCHost

[ DBHandler:LBYSETUP]

RPCHost =

Available

Release | _______
Patch |


UserID

[DBHandler:LBYSETUP]
UserID

UserID

[ DBHandler:LBYSETUP]

UserID =

Available

Release | _______
Patch |


DBHandler:MEM

DBHandler:
MEM

Remarks

"MEM" or "Memory" is the system defined name for the DB handler to handle the in-memory database. You can define the database handler name any thing you like. If you use a user defined name, you would need to use the INI entry of Class = MEM or Class = Memory to tell the system that this is a in-memory database.

Here is an example:

<DBHandler:MyDBHDLR>

Class = MEM

Example

< DBHandler:DALDB >

Class = MEM

DBHandler:MEM Options

  • Class


Class

[DBHandler:MEM]
Class

Class

Use the Class option to specify the class of the database handler.

[ DBHandler:MEM]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • MEM - In-memory database handler

Remarks

"MEM" or "Memory" is the system defined name for the DB handler to handle the in-memory database. You can define the database handler name any thing you like. If you use a user defined name, you would need to use the INI entry of Class = MEM or Class = Memory to tell the system that this is a in-memory database.

Example

<DBHandler:DALDB>

Class = MEM

Available

Release | _______
Patch |


DBHandler:ODBC

DBHandler:
ODBC

Remarks

This INI group enables the Documaker products to write or access data with an ODBC compliant database.

DBHandler:ODBC Options

  • AlwaysSQLPrepare
  • BlobSupportForDB2ODBC
  • Class
  • ConnectionTimer
  • CreateIndex
  • CreateTable
  • Debug
  • InstallFunc
  • InstallMod
  • Passwd
  • Qualifier
  • Server
  • Userid


AlwaysSQLPrepare

[DBHandler:ODBC]
AlwaysSQLPrepare

AlwaysSQLPrepare

Add the AlwaysSQLPrepare option to make sure the ODBC driver always performs the _SQLPrepare() function.

[ DBHandler:ODBC]

AlwaysSQLPrepare = No

Parameter | Description
boolean | Add the AlwaysSQLPrepare option to make sure the ODBC driver always performs the _SQLPrepare() function. Default value is: No

Remarks

Omitting this option can get the S1010 0 [Oracle][ODBC]Function sequence error.

This will be needed for some databases, but not all. It is safer to ALWAYS define it.

Example

< DBHandler:ODBC >

AlwaysSQLPrepare = Yes

Available

Release | _______
Patch |


BlobSupportForDB2ODBC

[DBHandler:ODBC]
BlobSupportForDB2ODBC

BlobSupportForDB2ODBC

To allow the BLOB type for CARDATA column in archive table when using ODBC For DB2.

[ DBHandler:ODBC]

BlobSupportForDB2ODBC = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Omitting this option can cause error:

<22001 -99999 [IBM][CLI Driver] CLI0109E String data right truncation. SQLSTATE=22001 when archiving (using GenArc or AFEMAIN) to DB2 using ODBC driver, or

<22001 -99999 [IBM][CLI Driver] CLI0109E String data right truncation. SQLSTATE=22001 when archiving to SQL Server using ODBC driver..

This will be needed for DB2 databases.

Example

< DBHandler:ODBC >

BlobSupportForDB2ODBC = Yes

Available

Release | 10.1
Patch | 137


Class

[DBHandler:ODBC]
Class

Class

This option lets you specify ODBC as the class of the Database Handler.

[ DBHandler:ODBC]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • ODBC

Example

< DBHandler:ODBC >

Class = ODBC

Available

Release | _______
Patch |


ConnectionTimer

[DBHandler:ODBC]
ConnectionTimer

ConnectionTimer

1364 ODBC DRIVER ENHANCEMENTS

[ DBHandler:ODBC]

ConnectionTimer = Spin

Parameter | Description
Spin |

Remarks

Now you can make the ODBC driver disconnect and connect again after it has been idle for specified time. To specify the time periods (number of seconds), use this INI option:

< DBHandler:ODBC >

ConnectionTimer = 300

This database handler maintains a countdown timer based on this INI setting that begins with the start of each requested task (query, select, etc.) that it performs. This countdown timer is reset at the end of each successful task. If the countdown is reached before subsequent tasks are requested then the handler refreshes the connection before proceeding. This is useful to avoid problems where systems (such as firewalls, DBMS server, OS, etc.) are configured to terminate connections after a known interval of time of inactivity.

Also, the ODBC driver now return a specific error code if there is a communication error and the DAP Bridge will force IDS to restart in case this error is detected. For instance, in the DAP/Documaker world, if you are writing custom code you can check for: DB_ERROR_CONNECTION_FAILURE returned by DBGetLastError()

If found, it means the ODBC connection failed. The DAP bridge checks this value and causes IDS to restart. There are no INI settings for this part of the feature.

NOTE: Only specific error codes are being expected, so some communication errors might not be detected.

Example

< DBHandler:ODBC >

ConnectionTimer = 300

Available

Release | 10.1
Patch | 455


CreateIndex

[DBHandler:ODBC]
CreateIndex

CreateIndex

Only necessary in 10.1 when allowing s to create the table.

[ DBHandler:ODBC]

CreateIndex = No

Parameter | Description
Boolean | Set the CreateIndex option to No. It is up to the DBA to configure the index for these SQL tables to fine-tune database performance or set the constraint. Default value is: No

Remarks

Set the CreateIndex option to No. It is up to the DBA to configure the index for these SQL tables to fine-tune database performance or set the constraint.

Example

< DBHandler:ODBC >

CreateIndex = No

Available

Release | 10.0
Patch |


CreateTable

[DBHandler:ODBC]
CreateTable

CreateTable

Define the DBHandler:ODBC control group to enable the ODBC driver.

[ DBHandler:ODBC]

CreateTable = Yes

Parameter | Description
Boolean | If the database administrator (DBA) decides to create the SQL tables in advance, set the CreateTable option to No. Otherwise, set it to Yes and the system will create the tables as needed. Default value is: Yes

Remarks

If the database administrator (DBA) decides to create the SQL tables in advance, set the CreateTable option to No. Otherwise, set it to Yes and the system created the tables as needed.

Example

< DBHandler:ODBC >

CreateTable = Yes

Available

Release | 10.0
Patch |


Debug

[DBHandler:ODBC]
Debug

Debug

Debug - causes activity/status information to be written to the trace file.

[ DBHandler:ODBC]

Debug = No

Parameter | Description
boolean (No) | The Debug option defaults to No. Default value is: No

Remarks

The Debug option defaults to No. This option can be useful when working with DAL database functions.

Example

< DBHandler:ODBC >

Debug = Yes

Available

Release | 10.0
Patch |


InstallFunc

[DBHandler:ODBC]
InstallFunc

InstallFunc

This option names the function call to load DB2 as the Database Handler.

[ DBHandler:ODBC]

InstallFunc =

Parameter | Description
value | This option names the function call to load DB2 as the Database Handler.

Example

< DBHandler:ODBC>

InstallFunc = SQInstallHandler

Available

Release | _______
Patch |


InstallMod

[DBHandler:ODBC]
InstallMod

InstallMod

This option names the DLL where the DB2 install function is located.

[ DBHandler:ODBC]

InstallMod = File

Parameter | Description
value | This option names the DLL where the DB2 install function is located.

Example

< DBHandler:ODBC>

InstallMod = SQW32

Available

Release | _______
Patch |


Passwd

[DBHandler:ODBC]
Passwd

Passwd

[ DBHandler:ODBC]

Passwd =

Parameter | Description
value | Enter the value defined in the ODBC configuration.

Remarks

Enter the value defined in the ODBC configuration.

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the

~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Example

< DBHandler:ODBC >

Passwd = password (if required)

Available

Release | 10.0
Patch |


Qualifier

[DBHandler:ODBC]
Qualifier

Qualifier

This option defines the actual database name.

[ DBHandler:ODBC]

Qualifier =

Parameter | Description
value | Use the Qualifier option to point to the database name if it differs from the default database in the Windows ODBC configuration.

Remarks

Use the Qualifier option to point to the database name if it differs from the default database in the Windows ODBC configuration.

Example

<DBHandler:ODBC>

Qualifier = master

Available

Release | 10.0
Patch |

Used By

AFEMAIN, GENARC


Server

[DBHandler:ODBC]
Server

Server

Server option defines the DSN: Data Source Name

[ DBHandler:ODBC]

Server =

Parameter | Description
value | Use the Server option to point to the data source name (DSN).

This option may be required in order for the feature to function.

Remarks

Use the Server option to point to the data source name (DSN).

FDT2DB Use this utility to convert a master resource library (MRL) into a database file for use with TransAll. The utility uses the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to convert resources into a database file, with tables for the library, form group keys, global recipients, form groups, forms, images, linked recipients, and fields. Rules are not converted.

The utility will read an entire MRL, but if the resource is not listed in the Form set definition file (form.dat, .BDF, .GRP, or .FOR), the utility will not convert it. You can run this utility multiple times.

Use the following INI option to specify the database file you want to use.

< DBHandler:ODBC >

Server =

The Server option is required. If you do omit it, no database is created. If there are no tables set up in the database, the utility uses the default table DFDs.

Example

<DBHandler:ODBC>

Server = MS SQL Server (ServerName)

Available

Release | 10.0
Patch |

Used By

AFEMAIN, GENARC


Userid

[DBHandler:ODBC]
Userid

Userid

[ DBHandler:ODBC]

Userid =

Parameter | Description
value | Enter the value defined in the ODBC configuration.

Remarks

Enter the value defined in the ODBC configuration.

Example

< DBHandler:ODBC >

UserID = sa (id)

Available

Release | 10.0
Patch |


DBHandler:ORA

DBHandler:
ORA

Remarks

Use DBHandler:ORA group to configure the settings for the Oracle database handler. "ORA" is the system defined name for the Oracle database handler. The system accepts the system defined name only for the Oracle native database handler.

Example

< DBHandler:ORA >

Connect = Yes

ConnectionTimer = 1000

CreateIndex = Yes

CreateTable = Yes

Database = Arc_110

Debug = No

Passwd = Az2090

UserID = Atlanta

TNSName = DM_110

DBHandler:ORA Options

  • Class
  • ConnectionTimer
  • CreateIndex
  • CreateTable
  • Database
  • Debug
  • Passwd
  • UserID


Class

[DBHandler:ORA]
Class

Class

This option lets you specify Oracle database as the class of the Database Handler.

[ DBHandler:ORA]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • ORA

Example

< DBHandler:ORA >

Class = ORA

Available

Release | _______
Patch |


ConnectionTimer

[DBHandler:ORA]
ConnectionTimer

ConnectionTimer

[ DBHandler:ORA]

ConnectionTimer = Spin

Parameter | Description
Spin |

Remarks

You can use the ConnectionTimer option with Oracle, which lets you disconnect and then reconnect an Oracle server in a specific time range when running on IDS. Here is an example of how you could set this up:

< DBHandler:ORA >

ConnectionTimer = (number of seconds)

This database handler maintains a countdown timer based on this INI setting that begins with the start of each requested task (query, select, etc.) that it performs. This countdown timer is reset at the end of each successful task. If the countdown is reached before subsequent tasks are requested then the handler refreshes the connection before proceeding. This is useful to avoid problems where systems (such as firewalls, DBMS server, OS, etc.) are configured to terminate connections after a known interval of time of inactivity.

Also, the Oracle handler now returns a specific error code if there is a communication error and the DAP Bridge will force IDS to restart in case this error is detected. For instance, in the DAP/Documaker world, if you are writing custom code you can check for: DB_ERROR_CONNECTION_FAILURE returned by DBGetLastError()

If found, it means the Oracle connection failed. The DAP bridge checks this value and causes IDS to restart. There are no INI settings for this part of the feature.

NOTE: Only specific error codes are being expected, so some communication errors might not be detected.

Example

< DBHandler:ORA >

ConnectionTimer = 1000

Available

Release | 10.2
Patch | 128


CreateIndex

[DBHandler:ORA]
CreateIndex

CreateIndex

[ DBHandler:ORA]

CreateIndex = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

It is up to the DBA to configure the index for the Oracle tables to fine-tune database performance or set the constraint. The default is No.

Note: CreateIndex = No is same as the older option of NoCreateIndex = Yes.

Example

<DBHandler:ORA>

Passwd = Wx2910

UserID = FAPGrp

Database = DM_110

CreateTable = Yes

CreateIndex = No

Available

Release | _______
Patch |


CreateTable

[DBHandler:ORA]
CreateTable

CreateTable

This option tells the system that if a table needed does not exist at run time, it should create it.

[ DBHandler:ORA]

CreateTable = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Enter Yes so Oracle will create the table if it does not exist. The default is Yes.

Note: CreateTable = No is same as the older option of NoCreateTable = Yes.

Example

<DBHandler:ORA>

Passwd = Wx2910

UserID = FAPGrp

Database = DM_110

CreateTable = Yes

Available

Release | _______
Patch |


Database

[DBHandler:ORA]
Database

Database

The Database option specifies the Oracle database name to be connected.

[ DBHandler:ORA]

Database = Edit

Parameter | Description
Edit |

Example

<DBHandler:ORA>

Passwd = Wx2910

UserID = FAPGrp

Database = DM_110

Available

Release | _______
Patch |


Debug

[DBHandler:ORA]
Debug

Debug

The Debug option let you tell the system whether the Oracle statements should be traced and written to the Trace file.

[ DBHandler:ORA]

Debug = No

Parameter | Description
Boolean (No) | Default value is: No

Example

<DBHandler:ORA>

Debug = Yes

Available

Release | _______
Patch |


Passwd

[DBHandler:ORA]
Passwd

Passwd

Specifies the Password to use with the specified Userid when the Documaker application issues the Oracle Connect.

[ DBHandler:ORA]

Passwd = Edit

Parameter | Description
Edit |

Remarks

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the

~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Example

<DBHandler:ORA>

UserID = Atlanta

Passwd = Az2090

Available

Release | _______
Patch |


UserID

[DBHandler:ORA]
UserID

UserID

Specifies the Userid to use when the Documaker application issues the Oracle Connect.

[ DBHandler:ORA]

UserID = Edit

Parameter | Description
Edit |

Example

< DBHandler:ORA >

UserID = Atlanta

Passwd = Az2090

Available

Release | _______
Patch |


DBHandler:PO

DBHandler:
PO

DBHandler:PO Options

  • Cabinet
  • Class
  • Domain
  • PassWord
  • UserID


Cabinet

[DBHandler:PO]
Cabinet

Cabinet

This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

[ DBHandler:PO]

Cabinet =

Parameter | Description
Edit | This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

Remarks

422 USING DOCUMANAGE WITH GENARC

Set up DocuManage Administrator in this order:

Map to Database

Business Tables

Cabinets

Document Types

Authorities

The Cabinet option contains all of the fields in all tables. You would use the Domain option if you are executing AFEMNW32 or GENACW32 in a different domain than the server machine.

Here are the options for the cabinet:

< PO:ARCCAB >

FileType = dap

FolderBy = KEY1,KEY2,KEYID

NameDocBy = KEY1,KEYID,TRANCODE

The version 10.3 Features and Enhancements Guide stated in the feature 1286 discussion that DMILIB implements an Archive interface and a Library Manager interface to Documanage.

For version 10.3, the GenArc program works with DBHandler:PO, but the version 11.0 GenArc program does not. If you import a version 10.3 master resource library (MRL) into DM Studio, Studio will not convert these options. You will have to manually change the INI file settings.

Example

< DBHandler:PO >

UserID = EZPOWER

PassWord = EZPOWER

Cabinet = ARCCAB

Domain = FSI

Available

Release | 10.1
Patch |


Class

[DBHandler:PO]
Class

Class

[ DBHandler:PO]

Class = LimitList

Parameter

Description

LimitList

Values can be

  • PO

Remarks

This option lets you specify Documanage archive database (PO) as the class of the Database Handler. (Note: DMIA is the newer Documanage archive database handler.)

Example

< DBHandler:PO >

Class = PO

Available

Release | _______
Patch |


Domain

[DBHandler:PO]
Domain

Domain

This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

[ DBHandler:PO]

Domain =

Parameter | Description
value | This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

Remarks

422 USING DOCUMANAGE WITH GENARC

Set up DocuManage Administrator in this order:

Map to Database

Business Tables

Cabinets

Document Types

Authorities

The Cabinet option contains all of the fields in all tables. You would use the Domain option if you are executing AFEMNW32 or GENACW32 in a different domain than the server machine.

Here are the options for the cabinet:

< PO:ARCCAB >

FileType = dap

FolderBy = KEY1,KEY2,KEYID

NameDocBy = KEY1,KEYID,TRANCODE

Example

< DBHandler:PO >

UserID = EZPOWER

PassWord = EZPOWER

Cabinet = ARCCAB

Domain = FSI

Available

Release | 10.1
Patch |


PassWord

[DBHandler:PO]
PassWord

PassWord

This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

[ DBHandler:PO]

PassWord =

Parameter | Description
Edit | This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

Remarks

422 USING DOCUMANAGE WITH GENARC

Set up DocuManage Administrator in this order:

Map to Database

Business Tables

Cabinets

Document Types

Authorities

The Cabinet option contains all of the fields in all tables. You would use the Domain option if you are executing AFEMNW32 or GENACW32 in a different domain than the server machine.

Here are the options for the cabinet:

< PO:ARCCAB >

FileType = dap

FolderBy = KEY1,KEY2,KEYID

NameDocBy = KEY1,KEYID,TRANCODE

Example

< DBHandler:PO >

UserID = EZPOWER

PassWord = EZPOWER

Cabinet = ARCCAB

Domain = FSI

Available

Release | 10.1
Patch |


UserID

[DBHandler:PO]
UserID

UserID

This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

[ DBHandler:PO]

UserID =

Parameter | Description
Edit | This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

Remarks

422 USING DOCUMANAGE WITH GENARC

Set up DocuManage Administrator in this order:

Map to Database

Business Tables

Cabinets

Document Types

Authorities

The Cabinet option contains all of the fields in all tables. You would use the Domain option if you are executing AFEMNW32 or GENACW32 in a different domain than the server machine.

Here are the options for the cabinet:

< PO:ARCCAB >

FileType = dap

FolderBy = KEY1,KEY2,KEYID

NameDocBy = KEY1,KEYID,TRANCODE

Example

< DBHandler:PO >

UserID = EZPOWER

PassWord = EZPOWER

Cabinet = ARCCAB

Domain = FSI

Available

Release | 10.1
Patch |


DBHandler:xxx

DBHandler:
xxx

Remarks

Use DBHandler:xxx group (where xxx = the database handler name) to configure the settings for the database handler. You can define the database handler name as any thing you like (except for DB2 or ORA), or you can use the system defined name as listed below:

ASCII | ASCII database handler
CB5 | Codebase database handler
DB2 | DB2 native database handler
DMIA | Documanage archive database handler
DMIL | Documanage library database handler
DMS | Documanage archive and library plug-in database handler
MEM | In-memory database handler (Note: Memory is another system defined name.)
PO | Older version of Documanage archive database handler
ODBC | ODBC compliant DBMS database handler (e.g. SQL database, DB2 via ODBC, or Oracle via ODBC)
ORA | Oracle native database handler

Note: The system accepts only the system defined name "DB2" or "ORA" for the DB2 or Oracle native database handler.

If you use a user defined name, you would need to use the Class= option to tell the system what the database handler is. The system defined class names are identical to the system defined database handler names.

If you use a system defined database handler name or set the Class to a system defined class of database, then you do not need to specify the InstallMod nor InstallFunc options unless you want to use a customized installed module and a customized installed function for the database handler.

Example

< DBHandler:MYDBHDLR >

Class = ODBC

ConnectionTimer = 1000

CreateIndex = No

CreateTable = Yes

Debug = No

DBHandler:xxx Options

  • Class
  • ConnectionTimer
  • CreateIndex
  • CreateTable
  • Debug
  • InstallFunc
  • InstallMod
  • Passwd
  • UserID


Class

[DBHandler:xxx]
Class

Class

This option lets you specify the class of the Database Handler.

[ DBHandler:xxx]

Class = List

Parameter

Description

List

Values can be

  • ASCII - ASCII database handler
  • CB5 - Codebase database handler
  • DB2 - DB2 native database handler
  • DMIA - Documanage archive database handler
  • DMIL - Documanage library database handler
  • DMS - Documanage plug-in database handler
  • MEM - In-memory database handler
  • PO - Old Documanage archive database handler
  • ODBC - ODBC compliant DBMS database handler (e.g.SQL)
  • ORA - Oracle native database handler

Remarks

If you do not use the system defined DB handler name, you would need to use the Class= option to tell the system what the database handler is.

If you use the system defined DB handler name, the Class option defaults to the DB handler name.

Note: The system accepts only the system defined name "DB2" or "ORA" for the DB2 or Oracle native database handler.

Example

<DBHandler:xxx>

Class = ODBC

Available

Release | _______
Patch |


ConnectionTimer

[DBHandler:xxx]
ConnectionTimer

ConnectionTimer

[ DBHandler:xxx]

ConnectionTimer = Spin

Parameter | Description
Spin |

Remarks

You can use the ConnectionTimer option with DBMS (i.e. SQL, DB2 or Oracle), which lets you disconnect and then reconnect a DBMS server in a specific time range when running on IDS. Here is an example of how you could set this up:

< DBHandler:xxx >

ConnectionTimer = (number of seconds)

The database handler maintains a countdown timer based on this INI setting that begins with the start of each requested task (query, select, etc.) that it performs. This countdown timer is reset at the end of each successful task. If the countdown is reached before subsequent tasks are requested then the handler refreshes the connection before proceeding. This is useful to avoid problems where systems (such as firewalls, DBMS server, OS, etc.) are configured to terminate connections after a known interval of time of inactivity.

Also, the database handler now returns a specific error code if there is a communication error and the DAP Bridge will force IDS to restart in case this error is detected. For instance, in the DAP/Documaker world, if you are writing custom code you can check for: DB_ERROR_CONNECTION_FAILURE returned by DBGetLastError()

If found, it means the DBMS connection failed. The DAP bridge checks this value and causes IDS to restart. There are no INI settings for this part of the feature.

NOTE: Only specific error codes are being expected, so some communication errors might not be detected.

Example

< DBHandler:xxx >

ConnectionTimer = 1000

Available

Release | 10.2
Patch | 128


CreateIndex

[DBHandler:xxx]
CreateIndex

CreateIndex

[ DBHandler:xxx]

CreateIndex = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

It is up to the DBA to configure the index for the DBMS (i.e. SQL, DB2 or Oracle) tables to fine-tune database performance or set the constraint. The default is No.

Note: CreateIndex = No is same as the older option of NoCreateIndex = Yes.

Example

<DBHandler:xxx>

Class = DB2

CreateIndex = No

CreateTable = Yes

Database = DM_110

Available

Release | _______
Patch |


CreateTable

[DBHandler:xxx]
CreateTable

CreateTable

This option tells the system that if a table needed does not exist at run time, it should create it.

[ DBHandler:xxx]

CreateTable = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Enter Yes so DBMS (i.e. SQL, DB2 or Oracle) driver will create the table if it does not exist. The default is Yes.

Note: CreateTable = No is same as the older option of NoCreateTable = Yes.

Example

<DBHandler:xxx>

Class = ODBC

CreateTable = Yes

Passwd = Wx2910

UserID = FAPGrp

Available

Release | _______
Patch |


Debug

[DBHandler:xxx]
Debug

Debug

This option lets you tell the system whether the DBMS or Documanage statements should be traced and written to the Trace file.

[ DBHandler:xxx]

Debug = No

Parameter

Description

LimitList

Values can be

  • Yes - Turn on normal debug
  • No - Turn off debug
  • Max - Turn on extended debug

Default value is: No

Remarks

If you are using Documanage database handler (i.e. DMIA, DMIL, DMS, or PO), you can set the debug option to Max for the extended debug.

Example

<DBHandler:xxx>

Debug = Yes

Available

Release | _______
Patch |


InstallFunc

[DBHandler:xxx]
InstallFunc

InstallFunc

This option lets you specify the Installed Function of the Database Handler.

[ DBHandler:xxx]

InstallFunc = Edit

Parameter | Description
Edit |

Remarks

If you use a system defined database handler name or set the Class to a system defined class of database, then you do not need to specify the InstallMod nor InstallFunc options unless you want to use a customized installed module and a customized installed function for the database handler.

The default value of the InstallFunc option, depending on the type of database handler, is as follows:

ASCInstallHandler for ASCII

CBDBSysInit for CB5

DB2InstallHandler for DB2

DMIAInstallHandler for DMIA

DMILInstallHandler for DMIL

DMSInstallHandler for DMS

MDBInstallHandler for MEM or Memory

POInstallHandler for PO

SQInstallHandler for ODBC

Example

< DBHandler:DMDB >

Class = ODBC

InstallMod = SQW32

InstallFunc = SQInstallHandler

Available

Release | _______
Patch |


InstallMod

[DBHandler:xxx]
InstallMod

InstallMod

This option lets you specify the Installed Module of the Database Handler.

[ DBHandler:xxx]

InstallMod = Edit

Parameter | Description
Edit |

Remarks

If you use a system defined database handler name or set the Class to a system defined type of database, then you do not need to specify the InstallMod nor InstallFunc options unless you want to use a customized installed module and a customized installed function for the database handler.

The default value of the InstallMod option, depending on the type of the database, is as follows:

ASCW32 for ASCII

DB5W32 for CB5

DB2W32 for DB2

DMIW32 for DMIA or DMIL

DMSW32 for PO or DMS

MDBW32 for MEM or Memory

SQW32 for ODBC

Example

< DBHandler:DMDB >

Class = ODBC

InstallMod = SQW32

Available

Release | _______
Patch |


Passwd

[DBHandler:xxx]
Passwd

Passwd

[ DBHandler:xxx]

Passwd = Edit

Parameter | Description
Edit |

Remarks

Specifies the Password to use with the specified Userid when the Documaker application issues the DBMS (i.e. DB2, SQL, Oracle) or Documanage Connect.

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the

~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Example

<DBHandler:xxx>

Class = DMIA

UserID = Atlanta

Passwd = Az2090

Available

Release | _______
Patch |


UserID

[DBHandler:xxx]
UserID

UserID

Specifies the Userid to use when the Documaker application issues the DBMS (i.e. DB2, SQL, or Oracle) or Documanage Connect.

[ DBHandler:xxx]

UserID = Edit

Parameter | Description
Edit |

Remarks

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the

~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Example

< DBHandler:xxx >

Class = ODBC

UserID = Atlanta

Passwd = Az2090

Available

Release | _______
Patch |


DBTable:Appidx

DBTable:
Appidx

DBTable:Appidx Options

  • DBHandler
  • DefaultTag


DBHandler

[DBTable:Appidx]
DBHandler

DBHandler

This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

[ DBTable:Appidx]

DBHandler =

Parameter | Description
Edit | This new feature lets you use DocuManage to archive files created from the GenArc program. This is done using the PO Handler.

Remarks

422 USING DOCUMANAGE WITH GENARC

When you display a transaction using the Entry system:

1 Folders are searched based on the fields defined in the FolderBy option. If a folder exists, the documents in the folder that match the type are searched. If no documents match, the folder is ignored. The document type is defined in the FileType option in the Cabinet control group. The system then creates a row in the Formset Selection window for each document where the folder has matching properties and document types.

2 When you select a document, the body of the document (CARDATA) is extracted into a temporary file. The data is then retrieved into the ARCHIVE record and the form set is displayed. Here are examples of the INI options you use. These options set all archive tables to use the PO Handler:

< DBTable:APPIDX >

DBHandler = PO

< DBTable:ARCHIVE >

DBHandler = PO

< DBTable:CATALOG >

DBHandler = PO

These options set up the PO Handler:

< DBHandler:PO >

UserID = EZPOWER

PassWord = EZPOWER

Cabinet = ARCCAB

Domain = FSI

Example

< DBTable:APPIDX >

DBHandler = PO

Available

Release | 10.0
Patch |


DefaultTag

[DBTable:Appidx]
DefaultTag

DefaultTag

The DefaultTag option lets you specify the default tag for ODBC and DB2.

[ DBTable:Appidx]

DefaultTag =

Parameter | Description
tagname | Any tag name (including key name itself).

Remarks

Only one column can be used to change the order. For DB2 user, the only sort order is ascending. For ODBC users, the descending order can be implemented by adding Descending = 1 to [Key:tagname] control group in the appidx.dfd.

This option provides more flexibility to the ODBC users. They can sort the records from the Table without asking the DBA to create a View for them.

This option can be used for archive retrieval from AFEMAIN and Docupresentment.

Example

< DBTable:appidx >

DefaultTag = policynum

Available

Release | 10.1
Patch | 426

Used By

AFEMAIN


DBTable:LBY_DB2

DBTable:
LBY_DB2

DBTable:LBY_DB2 Options

  • DBHandler
  • DFD


DBHandler

[DBTable:LBY_DB2]
DBHandler

DBHandler

This INI option (DFD) in the INI group is only valid for the Library Manager tables.

[ DBTable:LBY_DB2]

DBHandler =

Remarks

Previously, Library Manager and Archive shared the same DFD file. With the advent of DM Studio and its capability to import Library Manager tables that could exist in different data base types, the ability to specify different DFD's for each data base type was needed. This INI option allows you to specify a different DFD for each Library Manager table.

You can specify the DFD as shown here. If your library data tables are called LBY_DB2 and LBY_ORA, add the DFD option to the <DBTable:xxxx> INI group as follows:

< DBTable:LBY_DB2 >

DBHandler = DB2

DFD = deflib\lby_db2.dfd

< DBTable:LBY_ORA >

DBHandler = DB2

DFD = deflib\lby_ora.dfd

Example

< DBTable:LBY_DB2 >

DBHandler = DB2

DFD = deflib\lby_db2.dfd

Available

Release | 11.0
Patch | 43


DFD

[DBTable:LBY_DB2]
DFD

DFD

This INI option (DFD) in the INI group is only valid for the Library Manager tables.

[ DBTable:LBY_DB2]

DFD = Path

Parameter | Description
Path |

Remarks

Previously, Library Manager and Archive shared the same DFD file. With the advent of DM Studio and its capability to import Library Manager tables that could exist in different data base types, the ability to specify different DFD's for each data base type was needed. This INI option allows you to specify a different DFD for each Library Manager table.

You can specify the DFD as shown here. If your library data tables are called LBY_DB2 and LBY_ORA, add the DFD option to the <DBTable:xxxx> INI group as follows:

< DBTable:LBY_DB2 >

DBHandler = DB2

DFD = deflib\lby_db2.dfd

< DBTable:LBY_ORA >

DBHandler = DB2

DFD = deflib\lby_ora.dfd

Example

< DBTable:LBY_DB2 >

DBHandler = DB2

DFD = deflib\lby_db2.dfd

Available

Release | 11.0
Patch | 43


DBTable:LBY_ORA

DBTable:
LBY_ORA

DBTable:LBY_ORA Options

  • DBHandler
  • DFD


DBHandler

[DBTable:LBY_ORA]
DBHandler

DBHandler

This INI option (DFD) in the INI group is only valid for the Library Manager tables.

[ DBTable:LBY_ORA]

DBHandler =

Remarks

Previously, Library Manager and Archive shared the same DFD file. With the advent of DM Studio and its capability to import Library Manager tables that could exist in different data base types, the ability to specify different DFD's for each data base type was needed. This INI option allows you to specify a different DFD for each Library Manager table.

You can specify the DFD as shown here. If your library data tables are called LBY_DB2 and LBY_ORA, add the DFD option to the <DBTable:xxxx> INI group as follows:

< DBTable:LBY_DB2 >

DBHandler = DB2

DFD = deflib\lby_db2.dfd

< DBTable:LBY_ORA >

DBHandler = DB2

DFD = deflib\lby_ora.dfd

Example

< DBTable:LBY_ORA >

DBHandler = DB2

DFD = deflib\lby_ora.dfd

Available

Release | 11.0
Patch | 43


DFD

[DBTable:LBY_ORA]
DFD

DFD

This INI option (DFD) in the INI group is only valid for the Library Manager tables.

[ DBTable:LBY_ORA]

DFD =

Remarks

Previously, Library Manager and Archive shared the same DFD file. With the advent of DM Studio and its capability to import Library Manager tables that could exist in different data base types, the ability to specify different DFD's for each data base type was needed. This INI option allows you to specify a different DFD for each Library Manager table.

You can specify the DFD as shown here. If your library data tables are called LBY_DB2 and LBY_ORA, add the DFD option to the <DBTable:xxxx> INI group as follows:

< DBTable:LBY_DB2 >

DBHandler = DB2

DFD = deflib\lby_db2.dfd

< DBTable:LBY_ORA >

DBHandler = DB2

DFD = deflib\lby_ora.dfd

Example

< DBTable:LBY_ORA >

DBHandler = DB2

DFD = deflib\lby_ora.dfd

Available

Release | 11.0
Patch | 43


DBTable:LBYCAB

DBTable:
LBYCAB

Remarks

The DBTable:LBYCAB group lets you configure the settings which are used by the library manager interface with Documanage. The syntax of this group name is <DBTable:xxx> where xxx is the name of the Documanage cabinet to be used for the resource library. You can name it any thing you like as long as it matches with the cabinet name in your Documanage server. LBYCAB is just an example here.

DBTable:LBYCAB Options

  • DBHandler
  • SelfIndex


DBHandler

[DBTable:LBYCAB]
DBHandler

DBHandler

The value of this option must match with the name used in the DBHandler control group.

[ DBTable:LBYCAB]

DBHandler =

Example

[DBTable:LBYCAB]:

DBHandler = LBYSETUP.

Available

Release | _______
Patch |


SelfIndex

[DBTable:LBYCAB]
SelfIndex

SelfIndex

[ DBTable:LBYCAB]

SelfIndex =

Available

Release | _______
Patch |


DBTable:LBYD

DBTable:
LBYD

Remarks

UniqueTag

DBTable:LBYD Options

  • DBHandler
  • UniqueTag


DBHandler

[DBTable:LBYD]
DBHandler

DBHandler

Enter DB2 to indicate the LBYD table should be handled with DB2.

[ DBTable:LBYD]

DBHandler =

Parameter | Description
value | Enter DB2 to indicate the LBYD table should be handled with DB2.

Example

< DBTable:LBYD >

DBHandler =

Available

Release | 10.1
Patch | 199


UniqueTag

[DBTable:LBYD]
UniqueTag

UniqueTag

You must define a UniqueTag option to remove warning messages. For DB2, enter: UniqueTag = ArcKey+Seq_Num

[ DBTable:LBYD]

UniqueTag =

Parameter | Description
value | You must define a UniqueTag option to remove warning messages. For DB2, enter: UniqueTag = ArcKey+Seq_Num

Example

< DBTable:LBYD >

UniqueTag =

Available

Release | 10.1
Patch | 199


DBTable:WIP

DBTable:
WIP

DBTable:WIP Options

  • DBHandler
  • UniqueTag


DBHandler

[DBTable:WIP]
DBHandler

DBHandler

ODBC tells the system that WIP is a table in a ODBC-compliant database.

[ DBTable:WIP]

DBHandler =

Parameter | Description
value | ODBC tells the system that WIP is a table in a ODBC-compliant database.

Remarks

Use this ini setting when putting WIP into SQL server.

Example

[ DBTable:WIP ]

DBHandler = ODBC

Available

Release | _______
Patch |


UniqueTag

[DBTable:WIP]
UniqueTag

UniqueTag

Using UniqueTag INI option to assign a unique KEY defined in WIP.DFD.

[ DBTable:WIP]

UniqueTag =

Parameter | Description
value | Using UniqueTag INI option to assign a unique KEY defined in WIP.DFD. If the default WIP.DFD is used, DOCTAG is a good candidate since it is a unique KEY.

Remarks

If the default WIP.DFD is used, DOCTAG is a good candidate since it is a unique KEY, because the definition of

[ KEY:DOCTAG ] EXPRESSION = Key1+Key2+KeyID+RECTYPE in the wip.dfd will make DOCTAG unique.

If UniqueTag = DOCTAG is not defined, the transaction cannot be saved successfully in WIP even though Afemain does not produce any error.

Example

[ DBTable:WIP ]

UniqueTag = DOCTAG

Available

Release | _______
Patch |


DBTable:xxx

DBTable:
xxx

Remarks

The < DBTable:xxx > control group is to configure the settings for a sepecific Database table used for library and/or archive purposes, where xxx represents the DB table name up to eight characters.

(Note: If the "real" table names on the DBMS exceed 8 characters, be sure to use the <DB2_FileConvert> , <ODBC_FileConvert> , or <ORA_FileConvert> INI control group to convert the "real" table names to the short names, depending up what type of DBMS is used by you.)

Both the Archive and the Library have an Index component, a Data component and a Catalog component. The Archive Index component is commonly known as APPIDX (Application Index file) which contains the Key information for the archived transactions such as Compnay, Line of Business, Account Number/Policy Number, ArcKey, etc. and is defined with the < ArcRet > APPIDX INI option. The Archive Data component is commonly known as CarFile (Compressed Archives file) which contains the combined and compressed form set data (commonly known as "CarData") from the NAFile/POLFile and is defined with the < ArcRet > CarFile INI option. The Archive Catalog component temporarily stores the CATALOGID values used to contruct an ARCKEY with which the Catalog connects the CARFILE and APPIDX, and is defined with the <ArcRet > Catalog INI option. (Note: Catalog is used to support concurrent GenArc processes with different job IDs to archive data to the SQL database. Catalog reflects the archive. If the archive is a flat file, the catalog must also be created as a dBase IV file. If the archive is a database table, the catalog must also be a database table.)

For instance, you have three SQL tables, ArcIndx, ArcData and ArcCatg for the archives. You would need the following INI options to tell the system that you are using these tables for Archives:

< ArcRet >

APPIDX = ArcIndx

CarFile = ArcData

Catalog = ArcCatg

Then, you would need to tell the system what type of database handler should be used to access each of the these tables with the following INI options:

< DBTable: ArcIndx >

DBHandler = ODBC

< DBTable: ArcData >

DBHandler = ODBC

< DBTable: ArcCatg >

DBHandler = ODBC

Meanwhile, be sure to use the <DBHandler:ODBC> INI control group to configure the Database Handler, called ODBC.

Additionally, you may take the advantage of commit and rollback operations in the SQL database. You would need to define the < ArcRet > RestartTable INI option to tell the system the name of the Restart table, for example, "Restart". Also use the following INI option to tell the system to use ODBC DBHandler to access this table:

< DBTable:restart >

DBHandler = ODBC

You would also need to define the Data Format Definition (DFD) of the restart table with the < ArcRet > RestartDFD option. The RestartDFD option supports full path such as .\deflib\odbc\restart.dfd. If you omit the path, the system defaults to the path defined in the DefLib option in the MasterResource control group.

You may use the Database Management System (DBMS) to store your WIP transactions. It is suggested that you use the default name "WIP" (defined in the < WIPData > File INI option) for your WIP table. If your WIP table real name is called some thing else, be sure use the < ODBC_FileConvert >, < DB2_FileConvert > or < ORA_FileConvert > control group to convert the table name. Use the <DBTable:WIP> control group to configure your WIP DB Table.

DBTable:xxx Options

  • DBHandler
  • DefaultTag
  • DFD
  • Persistent
  • UniqueTag


DBHandler

[DBTable:xxx]
DBHandler

DBHandler

Feature 1419 This option specifies the type of database file.

[ DBTable:xxx]

DBHandler = List

Parameter

Description

List

This option specifies the type of database file.

Values can be

  • ASCII
  • CB5
  • DB2
  • DMIADMIA
  • DMIL
  • DMS
  • MEM
  • ORA
  • ODBC
  • PO

Remarks

Use this option to specify the database file type for the specific DB Table, named xxx, where xxx resprents the DB table name. The following is the list of the database file types supported by the System:

ASCII (cannot be used for Libraries)

CB5

DB2

DMIA (for Documanage Archives for REL 11.0 or higher)

DMIL (for Documanage Libraries)

DMS (cannot be used for Libraries)

MEM (used for memory tables)

PO (for Documanage Archives for REL 10.3 or below)

ODBC

ORA

Memory tables are useful when a program needs to create a temporary database table for a fast search, sort, or sequential access, such as with DAL scripts with DALDB. For instance, you can use this feature to create a few database tables from the input extract XML file for easier mapping and searching if those tasks were taking too long.

To tell the system to open a memory table in a DAL script, include the MEM or MEMORY parameter as the database type. This is the second parameter of DBOpen DAL function. Here is an example:

rc=DBOpen("tablel","MEM","d:\deflib\appidx.dfd","READ & WRITE");

Keep in mind that since the tables are in memory, they go away once the program terminates and the data is lost. DFD files are required to use memory tables since those tables are not self-describing. When you use a memory table with either a DAL script that did not specify the MEM parameter or with some other kind of table, include one of these INI options to tell the system the table will be using memory:

< DBTable:XXX >

DBHandler = MEM

or

< DBTable:XXX >

DBHandler = MEMORY

If you are using Documanage Archives, be sure set the DBHandler = DMIA (for REL 11.0 or higher) or PO (for REL 10.3 or lower). Please refer to <DBTable:Appidx> and <DBHandler:DMIA> , or <DBHandler:PO> for more information.

If you are using Documanage Libraries , be sure set the DBHandler with the DMIL class. Please refer to <DBTable:LBYCAB> , and <DBHandler:LBYSETUP> for more information.

Example

< DBTable:xxx >

DBHandler = DB2 (ODBC,CB5 or ASCII)

DBHandler = MEM (MEMORY)

Available

Release | 10.3
Patch |


DefaultTag

[DBTable:xxx]
DefaultTag

DefaultTag

The DefaultTag option lets you specify the default tag for ODBC and DB2.

[ DBTable:xxx]

DefaultTag =

Parameter | Description
tagname | Any tag name (including key name itself).

Remarks

This is also an option that can be defined in a DFD file.

Only one column can be used to change the order. For DB2 user, the only sort order is ascending. For ODBC users, the descending order can be implemented by adding Descending = 1 to [Key:tagname] in the DFD file (e.g. appidx.dfd).

This option provides more flexibility to the ODBC users. They can sort the records from the Table without asking the DBA to create a View for them.

This option can be used for archive retrieval from AFEMAIN and Docupresentment.

Example

< DBTable:xxx >

DefaultTag = policynum

Available

Release | 10.1
Patch | 426

Used By

AFEMAIN


DFD

[DBTable:xxx]
DFD

DFD

This INI option (DFD) in the INI group is only valid for the Library Manager tables.

[ DBTable:xxx]

DFD =

Remarks

Previously, Library Manager and Archive shared the same DFD file. With the advent of DM Studio and its capability to import Library Manager tables that could exist in different data base types, the ability to specify different DFD’s for each data base type was needed. This INI option allows you to specify a different DFD for each Library Manager table.

You can specify the DFD as shown here. If your library data tables are called LBY_DB2 and LBY_ORA, add the DFD option to the <DBTable:xxxx> INI group as follows:

< DBTable:LBY_DB2 >

DBHandler = DB2

DFD = deflib\lby_db2.dfd

< DBTable:LBY_ORA >

DBHandler = DB2

DFD = deflib\lby_ora.dfd

Example

< DBTable:LBY_DB2 >

DBHandler = DB2

DFD = deflib\lby_db2.dfd

Available

Release | _______
Patch |


Persistent

[DBTable:xxx]
Persistent

Persistent

Feature 1419 To keep the table in memory after the DBClose call.

[ DBTable:xxx]

Persistent = No

Parameter | Description
Boolean (No) | To keep the table in memory after the DBClose call. Default value is: No

Remarks

To keep the table in memory after the DBClose call, include this INI option:

< DBTable:XXX >

Persistent = Yes

Keep in mind, in this case table memory is released only when the program terminates. Use carefully to make sure you do not run out of memory.

Example

< DBTable:XXX >

Persistent = Yes

Available

Release | 10.3
Patch |


UniqueTag

[DBTable:xxx]
UniqueTag

UniqueTag

This option identifies the name of the unique tag key in the DFD file.

[ DBTable:xxx]

UniqueTag =

Parameter | Description
value | This option identifies the name of the unique tag key in the DFD file.

Remarks

The format for the statement is:

UniqueTag = A KEY IN THE KEY SECTION IN THE SPECIFIED DFD

NOTE: Be very careful that the Unique Tag key is really unique because Delete or Update statements will apply to all matching records (rows) having that key.

If you are using DB2 or ODBC compliant database for the Libraries, set UniqueTag equal to ArcKey+Seq_Num.

In this example, ARCKEY+SEQ_NUM specifies that the columns ARCKEY and SEQ_NUM can be combined to represent a unique tag for the table. This unique tag is only used for internal purposes. If you do not specify a unique tag for this table, and a column with the name UNIQUE_ID does not exist within the table, you receive warning messages indicating that there is no unique tag defined.

Example

< DBTable:xxx >

UniqueTag = xxxID

Available

Release | 10.0
Patch |


DDTResource

DDTResource Options

  • AutoIncludeSetOrigin
  • ErrorOnMissingFile
  • RemoveImageMissingDDT
  • StringentChecking
  • WarnOnMissingFile


AutoIncludeSetOrigin

[DDTResource]
AutoIncludeSetOrigin

AutoIncludeSetOrigin

Feature 1384 The FAP2DDT utility now adds a default SetOrigin rule to the Image Rules section if one does not exist.

[ DDTResource]

AutoIncludeSetOrigin = ;SetOrigin;Abs+0,Abs+0;

Parameter

Description

List

The FAP2DDT utility now adds a default SetOrigin rule to the Image Rules section if one does not exist. The SetOrigin rule that is added is ;SetOrigin;Abs+0,Abs+0;

Values can be

  • ;SetOrigin;Abs+0,Abs+0;

Default value is: ;SetOrigin;Abs+0,Abs+0;

Remarks

The FAP2DDT utility now adds a default SetOrigin rule to the Image Rules section if one does not exist. The SetOrigin rule that is added is

;SetOrigin;Abs+0,Abs+0;

For the FAP2DDT utility or Docutoolbox to add a SetOrigin rule into your DDT file, include this INI option in the FAPCOMP.INI file:

< DDTResource >

AutoIncludeSetOrigin = ;SetOrigin;Abs+0,Abs+0;

The DDTResource control group is used for DDT settings, such as WriteCoordinates, MultipleDDTs, and so on.

A SetOrigin rule is only added to a DDT file if there is an AutoIncludeSetOrigin option and the following conditions are true:

- The AutoIncludeSetOrigin setting begins with a semicolon (;)

- The AutoIncludeSetOrigin setting contains the string "SetOrigin"

- The DDT file does not already contain a SetOrigin rule (SetOrigin,

SetOriginI, SetOriginM, RULSetOrigin2, UTILSetOrigin)

Other than verifying that the rule begins with a semicolon and contains some form of the string "SetOrigin", no other validation is performed. You must make sure you specify a valid rule with valid parameters.

Note: Choosing the Convert Multiple FAPs, Update DDT from FAP option in Docucreate is another way to have the default SetOrigin rule added to the DDT file if it does not exist. The same caveats apply.

Example

< DDTResource >

AutoIncludeSetOrigin = ;SetOrigin;Abs+0,Abs+0;

Available

Release | 10.2
Patch | 84


ErrorOnMissingFile

[DDTResource]
ErrorOnMissingFile

ErrorOnMissingFile

Feature 1184 Stringently Applying Effective Dates This feature changes the way the Rules Processor interprets effective dates.

[ DDTResource]

ErrorOnMissingFile = YN

Parameter | Description
boolean | You can store DDT files on disk or via the Library Manager. The system generates an error if a DDT file cannot be found for a triggered image. Set this option to No to prevent the system from generating an error message when it cannot find the DDT file. The default is Yes.

Remarks

If the image's effective date indicates the image is inactive, the system will not use the image.

NOTE: This only applies to DDT files and only affects Documaker RP batch processing.

In prior versions, the system would use the most recent version of an image if it could not find a version that complies with the requested effective date. By default, Library Manager tried to find some version of the requested file, assuming that any version is better than no version. This feature also lets you give an image an expiration date after which it cannot be used.

You can store DDT files on disk or via the Library Manager. The system generates an error if a DDT file cannot be found for a triggered image. Set this option to No to prevent the system from generating an error message when it cannot find the DDT file. The default is Yes.

Keep these things in mind…

* You can set any of these INI options and you can use them in any combination.

* The feature to remove an image that's missing its DDT file can also be used when DDT files are stored on disk, such as when they are stored in DEFLIB.

Making an expired image active: If you expire an image by mistake, for example if you check it out, then check it in and inadvertently mark it expired, you can correct the mistake using the Library Manager.

To do this, use the Action, Delete option to delete the expired FAP and DDT file entries. If you have checked out the files, made major changes, and then checked in the FAP and DDT and inadvertently marked them as expired, you must delete those two entries. Unfortunately, this means you will lose your changes. The only way to recover the files with the changes is to follow these steps exactly:

1. Rename the FAP and DDT files.

2. Delete the expired FAP and DDT files from the library using the Action, Delete option in Library Manager. You can reorganize the files, but it is not required.

3. Extract the latest version\revision of the FAP and DDT files using the Action, Extract option in Library Manager. The Save As window appears. Use the actual FAP and DDT file names.

4. Go to the directories where the extracted FAP and DDT files are located. Flag them as read only. You do not have to check in the files again, as they are already in the library.

These steps assume you have other versions or revisions of the FAP and DDT files in the library. If you only have one version or revision of the FAP file and it is marked expired, skip step 4. You will need to check the files into the library.

The system generates an error message if it cannot find a DDT file for a triggered image on disk or stored via Library Manager. You can set this option to No to change the error messages into warning messages. There are these possible error messages:

10063 - No eligible DDT file. This message appears when you are not using Library Manager and the DDT file was

not found in DDTLib or DEFLib.

10088 - DDT file not found in version control. This message appears if no versions of the file are found in Library Manager and stringent checking is in effect.

10089 - DDT file not found by original loader. This message appears when no versions of the file are found in Library Manager and stringent checking is not in effect.

NOTE: Not having stringent checking in effect tells the system to also search the disk directory.

Example

< DDTResource >

ErrorOnMissingFile =

Available

Release | 10.1
Patch | 214


RemoveImageMissingDDT

[DDTResource]
RemoveImageMissingDDT

RemoveImageMissingDDT

Feature 1184 Stringently Applying Effective Dates This feature changes the way the Rules Processor interprets effective dates.

[ DDTResource]

RemoveImageMissingDDT = No

Parameter | Description
boolean (No) | Normally, a DDT file is required for any triggered image and not finding an image is a fatal error for a transaction. Setting this option to Yes, tells the system that when it cannot find a DDT file for a triggered image, it should remove the image from the form set. Default value is: No

Remarks

If the image's effective date indicates the image is inactive, the system will not use the image.

NOTE: This only applies to DDT files and only affects Documaker RP batch processing.

In prior versions, the system would use the most recent version of an image if it could not find a version that complies with the requested effective date. By default, Library Manager tried to find some version of the requested file, assuming that any version is better than no version. This feature also lets you give an image an expiration date after which it cannot be used.

Normally, a DDT file is required for any triggered image and not finding an image is a fatal error for a transaction. Setting this option to Yes, tells the system that when it cannot find a DDT file for a triggered image, it should remove the image from the form set.

This may result in the removal of the form as well, if all images are removed. An empty form set could result if all of the forms are removed. If this results in an empty form set, the system generates an error message. The default is No.

Normally, every triggered image must have a DDT file and not finding an image is a fatal error for a transaction. If, however, you set this option to Yes, the system removes the image from the form set if it cannot find a DDT file for the image.

If all images are removed, then the entire form set is removed, leaving you with an empty form set, which will also trigger an error message.

Example

< DDTResource >

RemoveImageMissingDDT =

Available

Release | 10.1
Patch | 214


StringentChecking

[DDTResource]
StringentChecking

StringentChecking

Feature 1184 Stringently Applying Effective Dates This feature changes the way the Rules Processor interprets effective dates.

[ DDTResource]

StringentChecking = No

Parameter | Description
boolean (No) | You can store DDT files on disk or via the Library Manager. By design, Library Manager makes every attempt to find a copy of the file. If the effective date check fails, the most recent version is used. If the file is not found in Library Manager but is found on disk, that copy is used. Default value is: No

Remarks

If the image's effective date indicates the image is inactive, the system will not use the image.

NOTE: This only applies to DDT files and only affects Documaker RP batch processing.

In prior versions, the system would use the most recent version of an image if it could not find a version that complies with the requested effective date. By default, Library Manager tried to find some version of the requested file, assuming that any version is better than no version. This feature also lets you give an image an expiration date after which it cannot be used.

You can store DDT files on disk or via the Library Manager. By design, Library Manager makes every attempt to find a copy of the file. If the effective date check fails, the most recent version is used. If the file is not found in Library Manager but is found on disk, that copy is used.

Setting this option to Yes tells the system to only use a version of the file that satisfies the effective date checking.

Failing this stringent check is the same as not finding the file. Stringent checking is only applicable when you use Library Manager to control the effective dates of DDT files.

This stringent checking also affects expiration. An image expires when a newer version is checked in and the newer image's effective date matches the transaction run date. You can set an expiration date for an image by using Library Manager to check in a new version which has an effective date equal to the expiration date and EXP in the Revision field. (The Revision field is case sensitive.)

If the Library Manager finds a version to be the correct version for the effective date, but the Revision field is set to EXP and the StringentChecking option is set to Yes, the image's DDT file is considered to be not found.

The default is No.

DDT files can be stored on disk or in Library Manager. The normal behavior of Library Manager is to make every attempt to find a copy of the file. If the effective date check fails, the most recent version is returned. If the file is not found in Library Manager but still is found on disk, then that copy is used. By setting this option to Yes, the most stringent checking is used, and only a truly eligible version of the file (one that satisfies the effective date checking) in Library Manager, will be returned. Failing the stringent check is the same as not finding any copy of the file. Stringent checking is only applicable when Library Manager is used to control effective date eligibility of DDT files.

In addition, stringent checking also pertains to expiration. To expire an image, a new version is checked into Library Manager with an effective date of the date of discontinue for that image, and with a revision value of EXP (in all caps). If Library Manager effective date matching logic finds a version to be the correct version for that effective date, but the Revision field is set to EXP, and if stringent checking is on, the image DDT file will be considered to be not found.

Example

< DDTResource >

StringentChecking =

Available

Release | 10.1
Patch | 214


WarnOnMissingFile

[DDTResource]
WarnOnMissingFile

WarnOnMissingFile

Feature 1184 Stringently Applying Effective Dates This feature changes the way the Rules Processor interprets effective dates.

[ DDTResource]

WarnOnMissingFile = Yes

Parameter | Description
boolean (Yes) | When you suppress this type of error, the system assumes you still want a warning message. Set this option to No to suppress that warning Default value is: Yes

Remarks

If the image's effective date indicates the image is inactive, the system will not use the image.

NOTE: This only applies to DDT files and only affects Documaker RP batch processing.

In prior versions, the system would use the most recent version of an image if it could not find a version that complies with the requested effective date. By default, Library Manager tried to find some version of the requested file, assuming that any version is better than no version. This feature also lets you give an image an expiration date after which it cannot be used.

You can store DDT files on disk or via the Library Manager and the system generates an error if it cannot find a DDT file for a triggered image.

You can, however, suppress this error by setting the ErrorOnMissingFile option to No. When you suppress this type of error, the system assumes you still want a warning message. Set this option to No to suppress that warning message. The default is Yes.

The text of the warning message (10063) is defined in the TRANSLAT.INI file. Here is an example:

DM10063: Warning: No eligible DDT file for:<SAMPCO;LB1;DEC PAGE>. Image<q1snam>.

The system generates a message if it cannot find a DDT file for a triggered image on disk or stored via Library Manager. Stringent checking can affect whether or not a file is found. For instance, with stringent checking a file might not be available because it has expired or because it is not yet in effect. Messages noting these situations are warnings, as opposed to errors, which tell you the file simply was not found.

You can set this option to No to suppress these warning messages.

In addition to the two errors that could become warnings if the file is not found, here are the two warnings you may see if the file is found but is not eligible for use:

10086 = DDT file found but not effective. This warning is generated when the file is found in Library Manager but it is not yet effective, and stringent checking is being used.

10087 = DDT file found but expired. This warning is generated when the file is found in Library Manager but it is expired, and stringent checking is being used.

Example

< DDTResource >

WarnOnMissingFile =

Available

Release | 10.1
Patch | 214


Debug_Switches

Debug_Switches Options

  • ArcLib
  • BaseRuleTime
  • CarLib
  • CodePage
  • CSTSyncFiles
  • DALFuncTime
  • DALLib
  • DBLib
  • Debug_DAL_Rules
  • DEBUG_FONTSUBS
  • Debug_GenArc
  • DEBUG_GROUP_RULE
  • Debug_XPath
  • Debug_XPath_Errors
  • Dump_AFGJob_File
  • DumpDAL
  • Dump_AFGJob_File
  • DXMLIB
  • Enable_Debug_Options
  • EPT_Debug
  • FDT2DB
  • FieldFunctTime
  • FormSetRuleTime
  • ImageFuncTime
  • ImageRuleTime
  • INILib
  • LBYLib
  • LoadListFromTable
  • MSM_Debug
  • RulLib_Recips
  • RulLib_Recips_LVL2
  • Rundate
  • Show_Debug_Options


ArcLib

[Debug_Switches]
ArcLib

ArcLib

[ Debug_Switches]

ArcLib = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

This option enables the debug process for genarc and the Documaker workstation archive. The output is put to the file defined in the <Data> TraceFile = INI option or the default Trace file.

Example

< DEBUG_SWITCHES >

ArcLib = No

Available

Release | _______
Patch |


BaseRuleTime

[Debug_Switches]
BaseRuleTime

BaseRuleTime

Enter Yes to report base or job-level (level 1) rules.

[ Debug_Switches]

BaseRuleTime = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Debug_Switches >

BaseRuleTime = Yes

Available

Release | 11.1
Patch |


CarLib

[Debug_Switches]
CarLib

CarLib

[ Debug_Switches]

CarLib = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

This option enables the debug process for genarc and the Documaker workstation archive. The output is put to the file defined in the <Data> TraceFile = INI option or the default Trace file.

Example

< DEBUG_SWITCHES >

CarLib = No

Available

Release | _______
Patch |


CodePage

[Debug_Switches]
CodePage

CodePage

[ Debug_Switches]

CodePage = Yes

Parameter | Description
Boolean (Yes/No) | Default value is: No

Remarks

Lists the system codepage setting to be used for interpreting single byte (non-Unicode) text.

Output is directed to the file defined in the <DATA> TraceFile = INI option or the default Trace file.

Example

< DEBUG_SWITCHES >

CodePage = Yes

Available

Release | 12.1_______
Patch |


CSTSyncFiles

[Debug_Switches]
CSTSyncFiles

CSTSyncFiles

[ Debug_Switches]

CSTSyncFiles = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The CSTSyncFiles debug switch traces the synchronization of MRL files between a server and a client workstation during the Documaker Workstation startup. The output is put to the file defined in the <Data> TraceFile = INI option or the default Trace file.

Example

< Debug_Switches >

CSTSyncFiles = Yes

Available

Release | _______
Patch |


DALFuncTime

[Debug_Switches]
DALFuncTime

DALFuncTime

Provides timing/detail information on DAL function execution; i.e. Time on stack, calling function, call depth.

[ Debug_Switches]

DALFuncTime = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Debug_Switches >

DALFuncTime = Yes

Available

Release | 11.1
Patch |


DALLib

[Debug_Switches]
DALLib

DALLib

Turns on or off debugging of DAL rules.

[ Debug_Switches]

DALLib = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Default is No. Enables the creation of debug data related to the execution of DAL library subroutines.

Example

< Debug_Switches >

DALLib = Yes

Available

Release | _______
Patch |


DBLib

[Debug_Switches]
DBLib

DBLib

[ Debug_Switches]

DBLib = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Enables database actions to be written to the file defined in the <Data> TraceFile = INI option or the default trace file when using the Library Manager.

Note that you turn tracing on and off for each DB Handler in the specific DB Handler group, e.g.

<DBHandler:ODBC>

Debug = Yes

<DBHandler:DB2>

Debug = Yes

Example

< DEBUG_SWITCHES >

DBLib = No

Available

Release | _______
Patch |


Debug_DAL_Rules

[Debug_Switches]
Debug_DAL_Rules

Debug_DAL_Rules

Turns on or off debugging of DAL rules.

[ Debug_Switches]

Debug_DAL_Rules = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Enables creation of debug data for each DAL rule/function executed.

Example

< DEBUG_SWITCHES >

Debug_DAL_Rules = No

Available

Release | _______
Patch |


DEBUG_FONTSUBS

[Debug_Switches]
DEBUG_FONTSUBS

DEBUG_FONTSUBS

Turns on or off debugging of RTF font substitution.

[ Debug_Switches]

DEBUG_FONTSUBS = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

For debugging purposes .

Font substitution messages can be written to the trace file and the DMStudio Output window.

Example

< DEBUG_SWITCHES >

DEBUG_FONTSUBS = No

Available

Release | 11.5
Patch |


Debug_GenArc

[Debug_Switches]
Debug_GenArc

Debug_GenArc

Debugging option for GenArc.

[ Debug_Switches]

Debug_GenArc = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

When this option is turned on, the debug messages are put to the file defined in the <DATA> LogFile = INI option or the default LogFile.dat file.

Example

< DEBUG_SWITCHES >

Debug_GenArc = No

Available

Release | _______
Patch |


DEBUG_GROUP_RULE

[Debug_Switches]
DEBUG_GROUP_RULE

DEBUG_GROUP_RULE

[ Debug_Switches]

DEBUG_GROUP_RULE = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The information you get back is such as the name of the begin and end image of the group, the rule parameter that is used, and if this is a nested group, whether this group is a master group. The info is written to the logfile.dat.

Enables creation of debug data related with the execution of the RP image rules GroupBegin/GroupEnd.

Example

< DEBUG_SWITCHES >

Debug_Group_Rule = No

Available

Release | 10.1
Patch |


Debug_XPath

[Debug_Switches]
Debug_XPath

Debug_XPath

When XML path references do not yield the proper results, it can be difficult to determine why. The system can output information as an XML path reference is executed to help you debug those situations.

This INI option lets you tell the system to write XML path information into the trace log file during GenData processing:

[ Debug_Switches]

Debug_XPath = Yes

Parameter | Description
Boolean (No) | Enter Yes to check all xPaths used. The default is No. Default value is: No

Remarks

Here is an excerpt from a trace file that checks the xPaths used:

1. ... Xpath:</formRequest/formInfo/keyList/keyData[keyNme='KEY1']/keyValue> ImageName:<>

2. ... Xpath:</formRequest/formInfo/keyList/keyData[keyNme='KEY2']/keyValue> ImageName:<>

3. ... Xpath:</formRequest/payload/LPROLetters/DocRepositoryReq/ReqData/Policy_NBR> ImageName:<>

4. ... Xpath:</formRequest/formInfo/formList/formId='5480.CO-500WEB-0208'> ImageName:<>

5. ... Xpath:</formRequest/payload/Document/Application/FormNo='5480.CO-500WEB-1008'> ImageName:<>

This trace file is created when you set the Debug_XPath option to Yes. It lists all of the XML paths used during processing.

Example

< DEBUG_SWITCHES >

Debug_XPath = Yes

Available

Release | 11.4
Patch |


Debug_XPath_Errors

[Debug_Switches]
Debug_XPath_Errors

Debug_XPath_Errors

When XML path references do not yield the proper results, it can be difficult to determine why. The system can output information as an XML path reference is executed to help you debug those situations.

This INI option lets you tell the system to write XML path information into the trace log file during GenData processing:

[ Debug_Switches]

Debug_XPath_Errors = Yes

Parameter | Description
Boolean (No) | Enter Yes to check all xPaths used. The default is No. Default value is: No

Remarks

Here is an excerpt from a trace file that lists xPath errors:

1. ... Not found: Xpath </formRequest/payload/LPROLetters/DocRepositoryReq/ReqData/ Policy_NBR> ImageName <>

2. ... Not found: Xpath </formRequest/formInfo/formList/formId='5480.CO-500WEB-0208'> ImageName <>

3. ... Not found: Xpath </formRequest/payload/Document/Application/FormNo='5480.CO-500WEB- 1008'> ImageName <>

4. ... Not found: Xpath </formRequest/payload/Document/Application/FormNo='5480.WI-500WEB- 0209'> ImageName <>

5. ... Not found: Xpath </formRequest/payload/Document/Application/FormNo='5480.IL-500WEB- 0208'> ImageName <>

This trace file is created when you set the Debug_XPath_Errors option to Yes. It lists all of the XML paths used during processing.

This trace file is created when you set the Debug_XPath_Errors option to Yes. It includes the XML paths that produced Not found, Blank field, and Xpath failure messages.

Keep in mind that the Not found and Blank field messages are not necessarily errors. The system produced these messages because the match did not exist or the match returned blank field data. You must check the validity of the XML path and the existence of the element in the XML tree.

The Xpath failure message is typically caused by incorrect syntax. For example, here is a common error.

11. ... Xpath failure: Xpath </formRequest/payload/Document/IdCards/[FormNo='5480.IL-171A-I4- T']>

This error is caused by extra backslash (/) before the condition.

NOTE: Entering Yes to turn on these debug options slows performance because it requires the system to log information into an output file. Consult Oracle Insurance support before turning on these options and for help interpreting the results.

Example

< DEBUG_SWITCHES >

Debug_XPath_Errors = Yes

Available

Release | 11.4
Patch |


DumpDAL

[Debug_Switches]
DumpDAL

DumpDAL

[ Debug_Switches]

DumpDAL = File

Parameter | Description
File |

Remarks

DumpDAL = xxxxx where xxxxxxx = either the name of the DAL script for which to generate debug data or the word "all", which indicates that all scripts are to be dumped.

The debug option, DALLib, must be set to 'Yes' in conjunction with this option. Default is No.

Output is directed to the file defined in the <DATA> TraceFile = INI option or the default Trace file.

Example

< Debug_Switches >

Enable_Debug_Options = Yes

DALLIB = Yes

DumpDAL = All

Available

Release | _______
Patch |


Dump_AFGJob_File

[Debug_Switches]
Dump_AFGJob_File

Dump_AFGJob_File

[ Debug_Switches]

Dump_AFGJob_File = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Lists the rules in the AFGJOB file loaded for the job execution.

Output is directed to the file defined in the <DATA> TraceFile = INI option or the default Trace file.

Example

< DEBUG_SWITCHES >

Dump_AFGJob_File =

Available

Release | _______
Patch |


DXMLIB

[Debug_Switches]
DXMLIB

DXMLIB

[ Debug_Switches]

DXMLIB = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

If you turn on this INI option, it will produce information regarding the reading and parsing of XML data. The output is directed to the file defined in the <Data> TraceFile = INI option or the default Trace file.

Example

< Debug_Switches >

DXMLIB = Yes

Available

Release | _______
Patch |


Enable_Debug_Options

[Debug_Switches]
Enable_Debug_Options

Enable_Debug_Options

Enter Yes to turn on the logging service.

[ Debug_Switches]

Enable_Debug_Options = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Enables debug options processing. The debug information is output to the file defined in the <DATA> TraceFile = INI option or the default Trace file. Without this setting, every other option defaults to No.

Example

< Debug_Switches >

Enable_Debug_Options = Yes

Available

Release | 11.1
Patch |


EPT_Debug

[Debug_Switches]
EPT_Debug

EPT_Debug

1456 MISCELLANEOUS ENHANCEMENTS

[ Debug_Switches]

EPT_Debug = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

New INI options you can use for debugging. Use these options to turn on debug log tracing for Microsoft Mail (MSM_Debug = Yes) and the Email Print Driver (EPT_Debug = Yes):

< Debug_Switches >

MSM_Debug = Yes

EPT_Debug = Yes

Use the EPT_Debug option to generate addition trace information about errors within that driver. This includes outputting the names of the printer and email drivers that are referenced.

Example

< Debug_Switches >

MSM_Debug = Yes

EPT_Debug = Yes

Available

Release | 10.3
Patch |


FDT2DB

FDT2DB

Enter Yes to report field functions.

[ Debug_Switches]

FDT2DB = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Debug_Switches >

FDT2DB = Yes

Available

Release | 11.2
Patch |


FieldFunctTime

[Debug_Switches]
FieldFunctTime

FieldFunctTime

Enter Yes to report field functions.

[ Debug_Switches]

FieldFunctTime = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Debug_Switches >

FieldFuncTime = Yes

Available

Release | 11.1
Patch |


FormSetRuleTime

[Debug_Switches]
FormSetRuleTime

FormSetRuleTime

Enter Yes to report form set-level (level 2) rules.

[ Debug_Switches]

FormSetRuleTime = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Debug_Switches >

FormSetRuleTime = No

Available

Release | 11.1
Patch |


ImageFuncTime

[Debug_Switches]
ImageFuncTime

ImageFuncTime

Enter Yes to report image functions.

[ Debug_Switches]

ImageFuncTime = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Debug_Switches >

ImageFuncTime = Yes

Available

Release | 11.1
Patch |


ImageRuleTime

[Debug_Switches]
ImageRuleTime

Enter Yes to report image-level (level 3) rules.

[ Debug_Switches]

ImageRuleTime = No

Parameter | Description
boolean | Default value is: No

Example

< Debug_Switches >

ImageRuleTime = Yes

Available

Release | 11.1
Patch |


INILib

[Debug_Switches]
INILib

Turns on or off trace file entries of the names of the INI files and the INI options themselves.

[ Debug_Switches]

INILib = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Default is No. Yes causes the names of the INI files and the INI options themselves to be written to the “trace” file.

Example

< Debug_Switches >

INILib = Yes

Available

Release | 11.2
Patch |


LBYLib

[Debug_Switches]
LBYLib

LBYLib

Enter Yes to create a trace file. The default is No.

[ Debug_Switches]

LBYLib = No

Parameter | Description
boolean (No) | Enter Yes to create a trace file. The default is No. Default value is: No

Remarks

Enables generation of Library Manager debug data.

Example

< Debug_Switches >

LBYLib = No

Available

Release | 10.1
Patch | 199


LoadListFromTable

[Debug_Switches]
LoadListFromTable

LoadListFromTable

[ Debug_Switches]

LoadListFromTable = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

This option is to be used with LoadListFromTable rule. When this option is turned on, the system will loop through all records, skip comment records and print them to the screen.

Example

< DEBUG_SWITCHES >

LoadListFromTable = Yes

Available

Release | _______
Patch |


MSM_Debug

[Debug_Switches]
MSM_Debug

MSM_Debug

1456 MISCELLANEOUS ENHANCEMENTS

[ Debug_Switches]

MSM_Debug = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

New INI options you can use for debugging. Use these options to turn on debug log tracing for Microsoft Mail (MSM_Debug = Yes) and the Email Print Driver (EPT_Debug = Yes):

< Debug_Switches >

MSM_Debug = Yes

EPT_Debug = Yes

Use the EPT_Debug option to generate addition trace information about errors within that driver. This includes outputting the names of the printer and email drivers that are referenced.

If you need error trace information from the referenced email driver, activate the appropriate option for that email driver. Use the new MSM_Debug option for the Microsoft Mail (Outlook or MAPI) interface driver. Use the existing VIM_Debug option to get additional error information when using the Lotus (Notes or cc:Mail) interface driver.

Example

< Debug_Switches >

MSM_Debug = Yes

EPT_Debug = Yes

Available

Release | 10.3
Patch |


RulLib_Recips

[Debug_Switches]
RulLib_Recips

RulLib_Recips

[ Debug_Switches]

RulLib_Recips = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Turn on this option to debug the form trigger process executed by gendata. The debug messages are put to the file defined in the <Data> TraceFile = INI option or the default Trace file.

If RulLib_Recips = Yes, trace file contains

1. Tue Nov 30 13:24:19.312 2004 pid=00002412

RCTLoadSetRecipientTable: New trigger list.

2. Tue Nov 30 13:24:19.328 2004 pid=00002412

RCTSetRecipsFromTable: ENTER

3. Tue Nov 30 13:24:19.328 2004 pid=00002412

Evaluating: <;FSI;GL;DEMO;;;COMPANY,INSURED;;1;0;0;1;;RECIPIF;return("^1^")>

4. Tue Nov 30 13:24:19.328 2004 pid=00002412

TriggerType is Standard

5. Tue Nov 30 13:24:19.328 2004 pid=00002412

Triggered Objects To Add=<1> Adjusted Objects To Add=<1>

6. Tue Nov 30 13:24:19.328 2004 pid=00002412

Object to add is Form <FSI,GL,(null)> <DEMO>

7. Tue Nov 30 13:24:19.328 2004 pid=00002412

Adding form <FSI><GL><DEMO> to Formset.

8. Tue Nov 30 13:24:19.328 2004 pid=00002412

RCTSetRecipsFromTable: EXIT, FAPTotalForms = <1>

If both RulLib_Recips and RulLib_Recips_LVL2 = Yes, trace file contains

1. Tue Nov 30 13:24:44.250 2004 pid=00002988

RCTLoadSetRecipientTable: New trigger list.

2. Tue Nov 30 13:24:44.250 2004 pid=00002988

Current Recip (Trigger) table dump....

3. Tue Nov 30 13:24:44.250 2004 pid=00002988

Recip = <;FSI;GL;DEMO;;;COMPANY,INSURED;;1;0;0;1;;RECIPIF;return("^1^")>

4. Tue Nov 30 13:24:44.250 2004 pid=00002988

End current Recip (Trigger) table dump.

5. Tue Nov 30 13:24:44.250 2004 pid=00002988

RCTSetRecipsFromTable: ENTER

6. Tue Nov 30 13:24:44.250 2004 pid=00002988

Evaluating: <;FSI;GL;DEMO;;;COMPANY,INSURED;;1;0;0;1;;RECIPIF;return("^1^")>

7. Tue Nov 30 13:24:44.250 2004 pid=00002988

TriggerType is Standard

8. Tue Nov 30 13:24:44.250 2004 pid=00002988

(Method3), function <RECIPIF>

9. Tue Nov 30 13:24:44.250 2004 pid=00002988

Function Search counter=<1>.

10. Tue Nov 30 13:24:44.250 2004 pid=00002988

Triggered Objects To Add=<1> Adjusted Objects To Add=<1>

11. Tue Nov 30 13:24:44.250 2004 pid=00002988

Object to add is Form <FSI,GL,(null)> <DEMO>

12. Tue Nov 30 13:24:44.250 2004 pid=00002988

Adding form <FSI><GL><DEMO> to Formset.

13. Tue Nov 30 13:24:44.250 2004 pid=00002988

RCTSetRecipCpyCnts: ENTER

14. Tue Nov 30 13:24:44.250 2004 pid=00002988

Form recip: <COMPANY>=1

15. Tue Nov 30 13:24:44.250 2004 pid=00002988

Form recip: <INSURED>=1

16. Tue Nov 30 13:24:44.250 2004 pid=00002988

RCTSetRecipCpyCnts: EXIT

17. Tue Nov 30 13:24:44.250 2004 pid=00002988

RCTSetRecipsFromTable: EXIT, FAPTotalForms = <1>

Example

< DEBUG_SWITCHES >

RulLib_Recips = No

Available

Release | _______
Patch |


RulLib_Recips_LVL2

[Debug_Switches]
RulLib_Recips_LVL2

RulLib_Recips_LVL2

[ Debug_Switches]

RulLib_Recips_LVL2 = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Turn on this option to debug the form trigger process executed by gendata. The debug messages are put to the file defined in the <Data> TraceFile = INI option or the default Trace file.

Example

< DEBUG_SWITCHES >

RulLib_Recips_LVL2 = No

Available

Release | _______
Patch |


Rundate

[Debug_Switches]
Rundate

Rundate

[ Debug_Switches]

Rundate = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

If RUNDATE field is not specified in rcbdfdfl.dfd, then Genprint will produce trace with

1. Wed Nov 24 11:37:54.750 2004 pid=00002108 RUNDATE GVM variable not located

If RUNDATE field is specified and contain some data, then Genprint will produce trace with

1. Wed Nov 24 12:25:39.078 2004 pid=00001396 GENPrint Transaction RUNDATE = 19000223

Example

< Debug_Switches >

Rundate = Yes

Available

Release | _______
Patch |


Show_Debug_Options

[Debug_Switches]
Show_Debug_Options

Show_Debug_Options

Shows a list of debug options.

[ Debug_Switches]

Show_Debug_Options = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

List the state (Yes or No) for each INI option in the INI group < Debug_Switches >

Example

< DEBUG_SWITCHES >

Show_Debug_Options = Yes

Available

Release | _______
Patch |


DefaultBarCode

DefaultBarCode Options

  • Code
  • Color
  • Format
  • Orientation
  • ScaleFactor


Code

[DefaultBarCode]
Code

Code

[ DefaultBarCode]

Code = 12345

Parameter | Description
Edit | Default value is: 12345

Remarks

This option is to set the default "code" for the bar code object in the Image Manager of the Documaker Studio. For example, if you will add your zip code "11089" to many images, you may set this INI option to 11089. When you insert a bar code to the image, it will be by default in the ZIP Code format with the code of 11089.

Example

< DefaultBarCode >

Code = 11089

Available

Release | _______
Patch |


Color

[DefaultBarCode]
Color

Color

[ DefaultBarCode]

Color = Color

Parameter | Description
Color |

Remarks

This option is to set the default color for the bar code objects in the Image Manager of the Documaker Studio.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255). The default value of this option is 0 for Black.

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

For example, if most of your bar codes will be in the Red color, you will set this INI option to 255. When you are adding new bar codes to the images, they will be in Red color by default.

The INI option is also used in FixForm (fixfmw32.exe), which is a command line utility available with various options. Please refer to the Docutoolbox Reference book for more information.

If you specify the /A option in FixForm and you also have the Color option in the DefaultBarCode INI group in the INI file that you use with FixForm, then FixForm will change the color of those bar codes, which were originally in the default color other than black but not set to "Print in color", with the color specified in this INI option, and also turn on the "Print in color" option for the bar codes.

Here is an example:

You set the bar code default color to Green in the Image Editor by choosing Format, Image Properties, and Color tab. You also have four bar codes in the FAP file:

Barcode 1 is in Black and not to print in color.

Barcode 2 is in the Default color (Green) and not to print in color.

Barcode 3 is in Red and not to print in color.

Barcode 4 is in the Default color (Green) and to print in color.

In the INI file, you have the following entry:

< DefaultBarCode >

Color = 255

Then, you use the FixForm utility with /A option to convert all colored objects in the FAP file.

Barcode 1 will remain unchanged because it is not a colored object.

Barcode 2 will change to Red and to print in color.

Barcode 3 will change to print in color but keep its original color, because it was not in the Default color.

Barcode 4 will remain unchanged because the print in color has been turned on.

Example

< DefaultBarCode >

Color = 0

Available

Release | _______
Patch |


Format

[DefaultBarCode]
Format

Format

[ DefaultBarCode]

Format = Z

Parameter

Description

LimitList

Values can be

  • A - Code 39 1:1:3:3
  • B - Code 39 1:1:2:2
  • C - Code 39 1:2:4:5
  • D - Codabar Standard
  • E - Codabar compressed
  • F - Interleaved 2 of 5 1:1:3:3
  • G - UPC-A 1:2:3:4 11 Digit
  • H - UPC-EO Zero Suppress 10 Digit
  • I - UPC-EO 6 Digit
  • J - UPC-EI 6 Digit
  • K - EAN-8 Digit
  • L - EAN-13 Digit
  • M - Code 39 3:1 Mod 43 Check Digit
  • N - MSI no Check Digit
  • O - MSI Mod 10 Check Digits
  • P - MSI Mod 10/10 Check Digits
  • Q - MSI Mod 11/10 Check Digits
  • R - Code 128 Start Code A
  • S - Code 128 Start Code B
  • T - Code 128 Start Code C
  • U - Code 128 Automatic Add-On
  • V - UPC 2-Digit Add-On
  • W - UPC 5-Digit Add-On
  • X - Interleaved 2 of 5 Mod 10
  • Y - Code 93
  • Z - Zip code
  • 1 - Planet

Default value is: Z

Remarks

This option defines the default format for the bar codes in the Documaker Studio and the Image Editor. If you are using the Image Editor, the Default Bar Code Format can be selected in the tool by choosing Options, Default Properties and selecting the Format on the Bar Code tab.

Example

< DefaultBarCode >

Format = L

Available

Release | _______
Patch |


Orientation

[DefaultBarCode]
Orientation

Orientation

[ DefaultBarCode]

Orientation = 0

Parameter

Description

LimitList

Values can be

  • 0 - 0 deg.: Normal
  • 90 - 90 deg.: Downward
  • 180 - 180 deg.: Upside down
  • 270 - 270 deg.: Upward

Default value is: 0

Remarks

This option defines the default orientation for the bar code in the Documaker Studio and the Image Editor. If you are using the Image Editor, the Default Bar Code Orientation can be selected in the tool by choosing Options, Default Properties and selecting the Orientation on the Bar Code tab.

Example

< DefaultBarCode >

Orientation = 270

Available

Release | _______
Patch |


ScaleFactor

[DefaultBarCode]
ScaleFactor

ScaleFactor

[ DefaultBarCode]

ScaleFactor = 10

Parameter | Description
Spin | Default value is: 10

Remarks

This option defines the default scale factor for the bar code in the Documaker Studio and the Image Editor. If you are using the Image Editor, the Default Bar Code Scale Factor can be selected in the tool by choosing Options, Default Properties and selecting the Scale Factor on the Bar Code tab. The value is in 1/10 unit without the decimal point. For instance, if the value is set to 16, which means 1.6 as it is shown in the Image Manager of the Documaker Studio or the Image Editor.

Example

< DefaultBarCode >

Scalefactor = 10

Available

Release | _______
Patch |


DefaultBitmap

DefaultBitmap Options

  • BitmapData
  • Color
  • InLineGraphics
  • Style


BitmapData

[DefaultBitmap]
BitmapData

BitmapData

[ DefaultBitmap]

BitmapData = Edit

Parameter | Description
Edit |

Remarks

If you use the same logo consistently, you can use this option to set the default logo in the Image Manager in the Documaker Studio.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Logo tab.

Example

< DefaultShading >

BitmapData = Q1DLOG

Available

Release | _______
Patch |


Color

[DefaultBitmap]
Color

Color

[ DefaultBitmap]

Color = Color

Parameter | Description
Color |

Remarks

This option is to set the default color for the bar code objects in the Image Manager of the Documaker Studio.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255).

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

This INI option is also used in FixForm (fixfmw32.exe), which is a command line utility available with various options. Please refer to the Docutoolbox Reference book for more information.

If you specify the /A option in FixForm and you also have the Color option in the DefaultBitmap INI group in the INI file that you use with FixForm, then FixForm will change the color of those Logos, which were originally in the default color other than black but not set to "Print in color", with the color specified in this INI option, and also turn on the "Print in color" option for the Logos.

Here is an example:

You set the Logo default color to Green in the Image Editor by choosing Format, Image Properties, and Color tab. You also have four Logos in the FAP file:

Logo 1 is in Black and not to print in color.

Logo 2 is in the Default color (Green) and not to print in color.

Logo 3 is in Red and not to print in color.

Logo 4 is in the Default color (Green) and to print in color.

In the INI file, you have the following entry:

< DefaultBitmap >

Color = 255

Then, you use the FixForm utility with /A option to convert all colored objects in the FAP file.

Logo 1 will remain unchanged because it is not a colored object.

Logo 2 will change to Red and to print in color.

Logo 3 will change to print in color but keep its original color, because it was not in the Default color.

Logo 4 will remain unchanged because the print in color has been turned on.

Example

< DefaultBitmap >

Color = 0

Available

Release | _______
Patch |


InLineGraphics

[DefaultBitmap]
InLineGraphics

InLineGraphics

[ DefaultBitmap]

InLineGraphics = 0

Parameter

Description

LimitList

Values can be

  • 0 - Turn off "In line graphics"
  • 1 - Turn on "In line graphics"

Default value is: 0

Remarks

This option is to set the default value of the "In line graphics" checkbox for the Logo objects in the Image Manager in the Documaker Studio. If you edited the default value of "In line graphics" for the Logo in the Image Manager, the edited value will become the new default value for the subsequent Logos in the Image Manager until the workspace is closed.

Check the Inline Graphics field to prevent the logo from being downloaded to the printer. With it checked, you can only print the logo through print screen selection. If the form includes signatures for approval, you may need to use this feature.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Logo tab.

Example

< DefaultBitmap >

InlineGraphics = 1

Available

Release | _______
Patch |


Style

[DefaultBitmap]
Style

Style

[ DefaultBitmap]

Style = 0

Parameter

Description

LimitList

Values can be

  • 0 - Turn off "Runtime block"
  • 1 - Turn on "Runtime block"

Default value is: 0

Remarks

This option is to set the default value of the "Runtime block" checkbox for the Logo objects in the Image Manager in the Documaker Studio. If you edited the default value of the "Runtime block" for the Logo in the Image Manager, the edited value will become the new default value for the subsequent Logos in the Image Manager until the workspace is closed.

Check the Runtime Block field to prevent the logo from being merged with the image when the form is processed by the Rules Processor. By blocking the logo, you can prevent someone from cutting the logo from the form and pasting it into another document. If your forms include signatures for approvals, you may need to use this feature.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Logo tab.

Example

< DefaultShading >

Style = 1

Available

Release | _______
Patch |


DefaultBookmark

DefaultBookmark Options

  • Level
  • Style


Level

[DefaultBookmark]
Level

Level

[ DefaultBookmark]

Level = 1

Parameter | Description
Spin | Default value is: 1

Remarks

This option is to set the default value of Level for the book mark in the Image Manager in the Documaker Studio. If you edited the default value of Level for the book mark in the Image Manager, the edited value will become the new default value for the subsequent book marks in the Image Manager until the workspace is closed.

Example

<DefaultBookmark>

Level = 3

Style =

Available

Release | _______
Patch |


Style

[DefaultBookmark]
Style

Style

[ DefaultBookmark]

Style = 3

Parameter

Description

LimitList

Values can be

  • 3 - Contents Only
  • 8 - Figures Only
  • 4 - Index Only
  • 7 - Contents and Index
  • 11 - Contents and Figures
  • 15 - Contents and Figures and Index
  • 12 - Figures and Index

Default value is: 3

Remarks

This option is to set the default values of the style checkboxes (i.e. Table of contents, Table of figures and Index) for the book mark object in the Image Manager in the Documaker Studio. If you edited the default values of these checkboxes for the book mark in the Image Manager, the edited values will become the new default values for the subsequent book marks in the Image Manager until the workspace is closed.

Example

<DefaultBookmark>

Level = 3

Style = 2

Available

Release | _______
Patch |


DefaultBox

DefaultBox Options

  • Color
  • Effects
  • HorizWeight
  • Pattern
  • VertWeight


Color

[DefaultBox]
Color

Color

[ DefaultBox]

Color = Color

Parameter | Description
Color |

Remarks

This option is to set the default color for the bar code objects in the Image Manager of the Documaker Studio.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255).

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

This INI option is also used in FixForm (fixfmw32.exe), which is a command line utility available with various options. Please refer to the Docutoolbox Reference book for more information.

If you specify the /A option in FixForm and you also have the Color option in the DefaultBox INI group in the INI file that you use with FixForm, then FixForm will change the color of those boxes, which were originally in the default color other than black but not set to "Print in color", with the color specified in this INI option, and also turn on the "Print in color" option for the boxes.

Here is an example:

You set the box default color to Green in the Image Editor by choosing Format, Image Properties, and Color tab. You also have four boxes in the FAP file:

Box 1 is in Black and not to print in color.

Box 2 is in the Default color (Green) and not to print in color.

Box 3 is in Red and not to print in color.

Box 4 is in the Default color (Green) and to print in color.

In the INI file, you have the following entry:

< DefaultBox >

Color = 255

Then, you use the FixForm utility with /A option to convert all colored objects in the FAP file.

Box 1 will remain unchanged because it is not a colored object.

Box 2 will change to Red and to print in color.

Box 3 will change to print in color but keep its original color, because it was not in the Default color.

Box 4 will remain unchanged because the print in color has been turned on.

Example

< DefaultBox >

Color = 0

Available

Release | _______
Patch |


Effects

[DefaultBox]
Effects

Effects

[ DefaultBox]

Effects = 0

Parameter

Description

LimitList

Values can be

  • 0 - All of Top, Bottom, Left, and Right are selected
  • 1 - Bottom, Left, and Right are selected
  • 2 - Top, Left, and Right are selected
  • 3 - Both of Left and Right are selected
  • 4 - Top, Bottom, and Right are selected
  • 5 - Both of Bottom and Right are selected
  • 6 - Both of Top and Right are selected
  • 7 - Only Right is selected
  • 8 - Top, Bottom and Left are selected
  • 9 - Both of Bottom and Left are selected
  • 10 - Both of Top and Left are selected
  • 11 - Only Left is selected
  • 12 - Both of Top and Bottom are selected
  • 13 - Only Bottom is selected
  • 14 - Only Top is selected
  • 15 - None are selected

Default value is: 0

Remarks

This option is to set the default values of the checkboxes in Draw edges (i.e. Left, Top, Right, and Bottom) for the box objects in the Image Manager in the Documaker Studio. If you edited the default values of these checkboxes for the box in the Image Manager, the edited value will become the new default values for the subsequent boxes in the Image Manager until the workspace is closed.

This option is also used by the Image Editor. You may set this option in the Image Editor by choosing Options, Default Properties, and then the Box tab.

Example

< DefaultBox >

Effects = 1

Available

Release | _______
Patch |


HorizWeight

[DefaultBox]
HorizWeight

HorizWeight

[ DefaultBox]

HorizWeight = 15

Parameter | Description
Faps | Default value is: 15

Remarks

This option is to set the default value of Horizontal Weight for the box objects in the Image Manager in the Documaker Studio. If you edited the default value of Horizontal Weight for the box in the Image Manager, the edited value will become the new default value for the subsequent boxes in the Image Manager until the workspace is closed.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Box tab.

The value of this option is in the FAP units (i.e. 2400 FAPs = 1 inch).

Example

< DefaultBox >

HorizWeight = 24

Available

Release | _______
Patch |


Pattern

[DefaultBox]
Pattern

Pattern

[ DefaultBox]

Pattern = LimitList

Parameter

Description

LimitList

Values can be

  • 0 - Solid
  • 1 - Horizontal
  • 2 - Vertical
  • 3 - Diagonal right
  • 4 - Diagonal left
  • 5 - Hatch
  • 6 - Diagonal Hatch
  • 7 - Lightest
  • 8 - Lighter
  • 9 - Light
  • 10 - Medium
  • 11 - Dark
  • 12 - Darker
  • 13 - Darkest
  • 14 - None (or No shade in Image Editor)

Remarks

This option is to set the default value of Pattern for the box objects in the Image Manager in the Documaker Studio. If you edited the default value of Pattern for the box in the Image Manager, the edited value will become the new default value for the subsequent boxes in the Image Manager until the workspace is closed.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Box tab.

Example

< DefaultBox >

Pattern = 9

Available

Release | _______
Patch |


VertWeight

[DefaultBox]
VertWeight

VertWeight

[ DefaultBox]

VertWeight = 15

Parameter | Description
Faps | Default value is: 15

Remarks

This option is to set the default value of Vertical Weight for the box objects in the Image Manager in the Documaker Studio. If you edited the default value of Vertical Weight for the box in the Image Manager, the edited value will become the new default value for the subsequent boxes in the Image Manager until the workspace is closed.

This option is also used by the Image Editor. You may set this option in the Image Editor by choosing Options, Default Properties, and then the Box tab.

The value of this option is in the FAP units (i.e. 2400 FAPs = 1 inch).

Example

< DefaultBox >

VertWeight = 24

Available

Release | _______
Patch |


DefaultFields

Remarks

The DEFAULTFIELDS control group prefills specified fields within form sets with user defined data. The prefilled data is a default, which users can change. To prefill fields with static data, use the AutoFields control group option. Options in this group have the syntax:

FIELD NAME = DATA

The FIELD NAME is a form set field name. The DATA is user defined data appearing in the field.

The Processing System lets you use all available INI built in functions as data. INI built in functions retrieve data dependent INI values. When a program gets an INI value, it gets the value returned by the built in function instead of ~FUNCTION. For this option to work, the scope for each default variable field must be defined as formset global. The following table lists and describes the INI built in functions:

Functions Description

~KEYID Returns KEYID field value from WIP structure(policy number)

~KEY1 Returns KEY1 field value from WIP structure (Company), or if found, matching values from <Company_Table> INI control group

~KEY2 Returns KEY2 field value from WIP structure (Line of Business)

~DATE Returns current date (the format is defined in the value <

Formats DateFormat =). The default format is MM/DD/YY.

~TIME Returns current time (the format is defined in the INI value ,

Formats TimeFormat =). The default format is HH:MM:SS in 12 hour format.

~HEXTIME Returns current time as a hexadecimal value (number of seconds since 1/1/1970).

~USERID Returns user ID of current user

~ACTION Returns current action, such as Create, Update, Delete, Save, Complete, and so on.

Example

< DEFAULTFIELDS >

PRODUCER ADDR1 = 2300 Windy Ridge Parkway

PRODUCER ADDR2 = Suite 400 N

PRODUCER CITY = Atlanta

PRODUCER NAME 1 = FSI

PRODUCER NAME 2 = FormMaker Software

PRODUCER STATE = GA

PRODUCER ZIP = 30339

DefaultFields Options

  • PRODUCER ADDR1


PRODUCER ADDR1

[DefaultFields] PRODUCER
ADDR1

PRODUCER ADDR1

[ DefaultFields]

PRODUCER ADDR1 =

Parameter | Description
value | text

Remarks

Please refer to the Remarks under the [DefaultFields] group for detailed information.

Example

< DEFAULTFIELDS >

PRODUCER ADDR1 = 2300 Windy Ridge Parkway

Available

Release | _______
Patch |

Used By

AFEMAIN


DefaultGuideBox

DefaultGuideBox Options

  • Color
  • Options


Color

[DefaultGuideBox]
Color

Color

[ DefaultGuideBox]

Color = Color

Parameter | Description
Color |

Remarks

This option is to set the default color for the Guide objects in the image.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255). The default value of this option is 12632256 for gray.

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

For example, if most of your Guide will be in the Blue color, you will set this INI option to 16711680. When you are adding new Guides to the images, they will be in Blue color by default.

The INI option is also used in FixForm (fixfmw32.exe), which is a command line utility available with various options. Please refer to the Docutoolbox Reference book for more information.

If you specify the /A option in FixForm and you also have the Color option in the DefaultGuideBox INI group in the INI file that you use with FixForm, then FixForm will change the color of those Guide Boxes, which were originally in the default color other than black but not set to "Print in color", with the color specified in this INI option, and also turn on the "Print in color" option for the guide boxes.

Here is an example:

You set the guide box default color to Green in the Image Editor by choosing Format, Image Properties, and Color tab. You also have four guide boxes in the FAP file:

Guide box 1 is in Black and not to print in color.

Guide box 2 is in the Default color (Green) and not to print in color.

Guide box 3 is in Red and not to print in color.

Guide box 4 is in the Default color (Green) and to print in color.

In the INI file, you have the following entry:

< DefaultGuideBox >

Color = 255

Then, you use the FixForm utility with /A option to convert all colored objects in the FAP file.

Guide box 1 will remain unchanged because it is not a colored object.

Guide box 2 will change to Red and to print in color.

Guide box 3 will change to print in color but keep its original color, because it was not in the Default color.

Guide box 4 will remain unchanged because the print in color has been turned on.

Example

< DefaultGuideBox >

Color = 50331648

Available

Release | _______
Patch |


Options

[DefaultGuideBox]
Options

Options

[ DefaultGuideBox]

Options = 0

Parameter | Description
Spin | Default value is: 0

Remarks

This option is to set the default values for the properties (i.e. Horizontal Align, Vertical Align, and Line Snap) for the Guide objects in the Image Manager in Documaker Studio. If you edited the values for these properties, the edited value becomes the new default values for the subsequent Guide objects in the Image Manager until the workspace is closed.

The value of this INI option is a combined value for Horizontal Align, Vertical Align, Horizontal Line Snap and Vertical Line Snap.

The values for Horizontal Align are as follows:

0 (default) None

1 Left

2 Right

4 Center

The values for Vertical Align are as follows:

0 (default) None

16 Top

32 Bottom

64 Center

The values for Horizontal Line Snap are as follows:

0 (default) Not checked

8 Checked

The valuesfor Vertical Line Snap are as follows:

0 (default) Not checked

128 Checked

For examples:

If you want Horizontal Align to Left, Vertical Align to Bottom, Horizontal Line Snap, and Vertical Line Snap, then the value for this INI option should be 169 (i.e. 1 + 32 + 8 + 128).

If you want Horizontal Align to none, Vertical Align to none, no Horizontal Line Snap, and no Vertical Line Snap, then the value for this INI option should be 0 (i.e. 0 + 0 + 0 + 0), which is the default value for this INI option.

If you want to Horizontal Align to Right, and Vertical Align to Center only, and no Line Snap, then the value for this INI option should be 66 (i.e. 2 + 64 + 0 + 0).

This INI option is also used by the Image Editor. You may select these default properties by choosing Options, Default Properties, and then the Guide Box tab.

Example

< DefaultGuideBox >

Options = 169

Available

Release | _______
Patch |


DefaultIndex

DefaultIndex Options

  • ColumnGap
  • Columns
  • Locale
  • Type


ColumnGap

[DefaultIndex]
ColumnGap

ColumnGap

[ DefaultIndex]

ColumnGap = 2400

Parameter | Description
Faps | Default value is: 2400

Remarks

This option is to set the default value of the column gap for the Index objects in the Image Manager in Documaker Studio. If you edited the default value of the column gap for the index in the Image Manager, the edited value will become the new default value of the column gap for the subsequent indexes until the workspace is closed. The value of this INI option is in FAPs unit (i.e. 2400 FAPs = 1 inch). The default value of this option is 2400 FAPs.

Example

<DefaultIndex>

Type = 4

Locale = ARS

Columns = 3

ColumnGap = 1200

Available

Release | _______
Patch |


Columns

[DefaultIndex]
Columns

Columns

[ DefaultIndex]

Columns = 1

Parameter | Description
Spin | Default value is: 1

Remarks

This option is to set the default number of the columns for the Index objects in the Image Manager in Documaker Studio. If you edited the default value of the columns for the index in the Image Manager, the edited value will become the new default value of the columns for the subsequent indexes until the workspace is closed. The default value of this option is 1 column. The maximal columns for the index object is 5.

Example

<DefaultIndex>

Type = 4

Locale = ARS

Columns = 3

ColumnGap = 1200

Available

Release | _______
Patch |


Locale

[DefaultIndex]
Locale

Locale

[ DefaultIndex]

Locale = LimitList

Parameter

Description

LimitList

Values can be

  • ARS - Argentina\Spanish
  • ATS - Austria\German
  • AUD - Australia\English
  • BED - Belgium\Dutch
  • BEF - Belgium\French
  • BOB - Bolivia\Spanish
  • BRC - Brazil\Portuguese
  • CAD - Canada\French
  • CAN - Canada\English
  • CHF - Switzerland\German
  • CHH - Switzerland\French
  • CHI - Switzerland\Italian
  • CHL - Liechtenstein\German
  • CLP - Chile\Spanish
  • COP - Columbia\Spanish
  • CRC - Costa Rica\Spanish
  • DEM - Germany\German
  • DKK - Denmark\Danish
  • ECS - Ecuador\Spanish
  • ESB - Spain\Basque
  • ESC - Spain\Catalan
  • ESP - Spain\Spanish
  • FLX - France\French
  • FMK - Finland\Swedish
  • FRF - Luxembourg\French
  • GBP - United Kingdom\English
  • GTQ - Guatemala\Spanish
  • IDR - Indonesia\Indonesian
  • IEP - Ireland\English
  • ISK - Iceland\Icelandic
  • LUX - Luxembourg\German
  • MXN - Mexico\Spanish
  • NLG - The Netherlands\Dutch
  • NOK - Norway\Norwegian
  • NZD - New Zealand\English
  • PAB - Panama\Spanish
  • PES - Peru\Spanish
  • PTE - Portugal\Portuguese
  • PYG - Paraguay\Spanish
  • SEK - Sweden\Swedish
  • ITL - Italy\Italian
  • USD - United States\English
  • UYU - Uruguay\Spanish
  • VEB - Venezuela\Spanish
  • ZAA - South Africa\Afrikaans
  • ZAR - South Africa\English

Remarks

This option is to set the default value of the Language for the Index objects in the Image Manager in Documaker Studio. If you edited the default value of the Language for the index object in the Image Manager, the edited value will become the new default value of the Language for the subsequent indexes until the workspace is closed.

Example

<DefaultIndex>

Type = 4

Locale = ARS

Columns = 3

ColumnGap = 1200

Available

Release | _______
Patch |


Type

[DefaultIndex]
Type

Type

Can be 3 for table of contents, 4 for index, or 8 for figure

[ DefaultIndex]

Type = 3

Parameter

Description

LimitList

Values can be

  • 3 - Table of Contents
  • 4 - Index
  • 8 - Table of Figures

Default value is: 3

Remarks

This option is to set the default value of the Type for the Index and Table objects in the Image Manager in Documaker Studio. If you edited the default value of the Type for the index and table object in the Image Manager, the edited value will become the new default value of the type for the subsequent index and table objects until the workspace is closed. The default value of this INI option is 3 for table of contents.

Example

<DefaultIndex>

Type = 4

Locale = ARS

Columns = 3

ColumnGap = 1200

Available

Release | _______
Patch |


DefaultLine

DefaultLine Options

  • Color
  • DashOff
  • DashOn
  • HorizWeight
  • Pattern
  • Type
  • VertWeight


Color

[DefaultLine]
Color

Color

[ DefaultLine]

Color = 0

Parameter | Description
Color | Default value is: 0

Remarks

This option is to set the default color for the line objects in the Image Manager of the Documaker Studio.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255). The default value of this option is 0 for Black.

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

For example, if most of your lines will be in the Red color, you will set this INI option to 255. When you are adding new lines to the images, they will be in Red color by default.

The INI option is also used in FixForm (fixfmw32.exe), which is a command line utility available with various options. Please refer to the Docutoolbox Reference book for more information.

If you specify the /A option in FixForm and you also have the Color option in the DefaultLine INI group in the INI file that you use with FixForm, then FixForm will change the color of those lines, which were originally in the default color other than black but not set to "Print in color", with the color specified in this INI option, and also turn on the "Print in color" option for the lines.

Here is an example:

You set the line default color to Green in the Image Editor by choosing Format, Image Properties, and Color tab. You also have four lines in the FAP file:

Line 1 is in Black and not to print in color.

Line 2 is in the Default color (Green) and not to print in color.

Line 3 is in Red and not to print in color.

Line 4 is in the Default color (Green) and to print in color.

In the INI file, you have the following entry:

< DefaultLine >

Color = 255

Then, you use the FixForm utility with /A option to convert all colored objects in the FAP file.

Line 1 will remain unchanged because it is not a colored object.

Line 2 will change to Red and to print in color.

Line 3 will change to print in color but keep its original color, because it was not in the Default color.

Line 4 will remain unchanged because the print in color has been turned on.

Example

< DefaultLine >

Color = 0

Available

Release | _______
Patch |


DashOff

[DefaultLine]
DashOff

DashOff

[ DefaultLine]

DashOff = 15

Parameter | Description
Faps | Default value is: 15

Remarks

This option is to set the default space length for the dashed line objects in Documaker Studio and Image Editor. If you are using Image Editor, you may set this option by choosing Options, Default Properties, and selecting the Line tab. The value of this INI option is in Faps unit (i.e. 2400FAPs = 1 inch).

Example

< DefaultLine >

DashOff = 12

Available

Release | _______
Patch |


DashOn

[DefaultLine]
DashOn

DashOn

[ DefaultLine]

DashOn = 15

Parameter | Description
Faps | Default value is: 15

Remarks

This option is to set the default dash length for the dashed line objects in Documaker Studio and Image Editor. If you are using Image Editor, you may set this option by choosing Options, Default Properties, and selecting the Line tab. The value of this INI option is in Faps unit (i.e. 2400 FAPs = 1 inch).

Example

< DefaultLine >

DashOn = 24

Available

Release | _______
Patch |


HorizWeight

[DefaultLine]
HorizWeight

HorizWeight

[ DefaultLine]

HorizWeight = 15

Parameter | Description
Faps | Default value is: 15

Remarks

This option is to set the default Height (or Vertical Thickness) for the horizontal line objects in the Image Manager of the Documaker Studio (or in the Image Editor). If you are using Image Editor, you may set this option by choosing the Options, Default Properties, and selecting the Line tab. The value of this INI option is in Faps unit.

Example

< DefaultLine >

HorizWeight = 20

Available

Release | _______
Patch |


Pattern

[DefaultLine]
Pattern

Pattern

[ DefaultLine]

Pattern = 0

Parameter

Description

LimitList

Values can be

  • 0 - Solid
  • 1 - Horizontal
  • 2 - Vertical
  • 3 - Diagonal right
  • 4 - Diagonal left
  • 5 - Hatch
  • 6 - Diagonal hatch
  • 7 - Lightest
  • 8 - Lighter
  • 9 - Light
  • 10 - Medium
  • 11 - Dark
  • 12 - Darker
  • 13 - Darkest
  • 14 - No shade (or No shade in Image Editor)

Default value is: 0

Remarks

This option is to set the default value of Pattern for the line object in the Image Manager in the Documaker Studio. If you edited the default value of Pattern for the line in the Image Manager, the edited value will become the new default value for the subsequent lines in the Image Manager until the workspace is closed.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Line tab.

Example

< DefaultLine >

Pattern = 9

Available

Release | _______
Patch |


Type

[DefaultLine]
Type

Type

[ DefaultLine]

Type = 0

Parameter

Description

LimitList

Values can be

  • 0 - Solid
  • 4 - Dashed

Default value is: 0

Remarks

This option is to set the default characteristics the line objects in Documaker Studio and Image Editor. If you are using Image Editor, you may set this option by choosing Options, Default Properties, and selecting the Line tab. The default is Solid line.

Example

< DefaultLine >

Type = 4

Available

Release | _______
Patch |


VertWeight

[DefaultLine]
VertWeight

VertWeight

[ DefaultLine]

VertWeight = 15

Parameter | Description
Faps | Default value is: 15

Remarks

This option is to set the default Width (or Horizontal Thickness) for the vertical line objects in the Image Manager of the Documaker Studio (or in the Image Editor). If you are using Image Editor, you may set this option by choosing the Options, Default Properties, and selecting the Line tab. The value of this INI option is in Faps unit.

Example

< DefaultLine >

VertWeight = 20

Available

Release | _______
Patch |


DefaultNote

DefaultNote Options

  • SendFrom
  • Style


SendFrom

[DefaultNote]
SendFrom

SendFrom

[ DefaultNote]

SendFrom =

Remarks

This option sets the default value for the user sending the note in Documaker Studio and in the Image Editor. If you are using Image Editor, this value can be entered by choosing Options, Default Properties and selecting the Note tab. The default value is the current user.

Example

< DefaultNote >

SendFrom = JohnDoe

Available

Release | _______
Patch |


Style

[DefaultNote]
Style

Style

[ DefaultNote]

Style = 2 for Memo

Parameter

Description

LimitList

Values can be

  • 1 - Sticky Pad
  • 2 - Memo

Default value is: 2 for Memo

Remarks

This option identifies either Sticky pad or Memo as the default style of note in the Image Manager of Documaker Studio and in the Image Editor.

If you are using the Image Editor, you can enter this option value by choosing Options, Default Properties and selecting the Note tab.

Example

< DefaultNote >

Style = 1

Available

Release | _______
Patch |


DefaultShading

DefaultShading Options

  • Color
  • Pattern


Color

[DefaultShading]
Color

Color

[ DefaultShading]

Color = Color

Parameter | Description
Color |

Remarks

This option is to set the default color for the Shade objects in the Image Manager of the Documaker Studio.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255). The default value of this option is 0 for Black.

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

For example, if most of your shade will be in the Gray color, you will set this INI option to 8224125. When you are adding new Shade objects to the images, they will be in Gray color by default.

The INI option is also used in FixForm (fixfmw32.exe), which is a command line utility available with various options. Please refer to the Docutoolbox Reference book for more information.

If you specify the /A option in FixForm and you also have the Color option in the DefaultShading INI group in the INI file that you use with FixForm, then FixForm will change the color of those Shade objects, which were originally in the default color other than black but not set to "Print in color", with the color specified in this INI option, and also turn on the "Print in color" option for the lines.

Here is an example:

You set the Shade default color to Green in the Image Editor by choosing Format, Image Properties, and Color tab. You also have four Shades in the FAP file:

Shade 1 is in Black and not to print in color.

Shade 2 is in the Default color (Green) and not to print in color.

Shade 3 is in Red and not to print in color.

Shade 4 is in the Default color (Green) and to print in color.

In the INI file, you have the following entry:

< DefaultShading >

Color = 8224125

Then, you use the FixForm utility with /A option to convert all colored objects in the FAP file.

Shade 1 will remain unchanged because it is not a colored object.

Shade 2 will change to Gray and to print in color.

Shade 3 will change to print in color but keep its original color, because it was not in the Default color.

Shade 4 will remain unchanged because the print in color has been turned on.

Example

< DefaultShading >

Color = 0

Available

Release | _______
Patch |


Pattern

[DefaultShading]
Pattern

Pattern

[ DefaultShading]

Pattern = 0 for Solid

Parameter

Description

LimitList

Values can be

  • 0 - Solid
  • 1 - Horizontal
  • 2 - Vertical
  • 3 - Diagonal right
  • 4 - Diagonal left
  • 5 - Hatch
  • 6 - Diagonal hatch
  • 7 - Lightest
  • 9 - Light
  • 10 - Medium
  • 11 - Dark
  • 12 - Darker
  • 13 - Darkest
  • 14 - No shade (or No shade in Image Editor)
  • 8 - Lighter

Default value is: 0 for Solid

Remarks

This option is to set the default value of Pattern for the Shade object in the Image Manager in the Documaker Studio. If you edited the default value of Pattern for the Shade object in the Image Manager, the edited value will become the new default value for the subsequent Shade objects in the Image Manager until the workspace is closed.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Shade Area tab.

Example

< DefaultShading >

Pattern = 9

Available

Release | _______
Patch |


DefaultTextArea

Remarks

Use the < DefaultTextArea > INI control group to specify the default settings for the text area objects.

DefaultTextArea Options

  • Color
  • Flags
  • FmtType
  • Font
  • Hindentation
  • HYPLanguage
  • HYPParaLanguage
  • LeftIndentation
  • Options
  • ParaOptions
  • RightIndentation
  • SpaceAbove
  • SpaceBelow
  • TabStop


Color

[DefaultTextArea]
Color

Color

[ DefaultTextArea]

Color = 0 for Black

Parameter | Description
Color | Default value is: 0 for Black

Remarks

The INI option is used in FixForm (fixfmw32.exe), which is a command line utility available with various options. Please refer to the Docutoolbox Reference book for more information.

If you specify the /A option in FixForm and you also have the Color option in the DefaultTextArea INI group in the INI file that you use with FixForm, then FixForm will change the color of those text area objects, which were originally in the default color other than black but not set to "Print in color", with the color specified in this INI option, and also turn on the "Print in color" option for the text areas.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255). The default value of this option is 0 for Black.

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

Here is an example:

You set the text area default color to Green in the Image Editor by choosing Format, Image Properties, and Color tab. You also have four text areas in the FAP file:

Text area 1 is in Black and not to print in color.

Text area 2 is in the Default color (Green) and not to print in color.

Text area 3 is in Red and not to print in color.

Text area 4 is in the Default color (Green) and to print in color.

In the INI file, you have the following entry:

< DefaultTextAea >

Color = 255

Then, you use the FixForm utility with /A option to convert all colored objects in the FAP file.

Text area 1 will remain unchanged because it is not a colored object.

Text area 2 will change to Red and to print in color.

Text area 3 will change to print in color but keep its original color, because it was not in the Default color.

Text area 4 will remain unchanged because the print in color has been turned on.

Example

< DefaultTextArea >

Color = 0

Available

Release | _______
Patch |


Flags

[DefaultTextArea]
Flags

Flags

[ DefaultTextArea]

Flags = 0 for Normal Indentation and Left Justification

Parameter

Description

LimitList

Values can be

  • 0 - Normal Indentation and Left Justification
  • 1 - Normal Indentation and Centered
  • 2 - Normal Indentation and Right Justification
  • 8 - Normal Indentation and Left/Right Justification
  • 4096 - Hanging Indentation and Left Justification
  • 4097 - Hanging Indentation and Centered
  • 4098 - Hanging Indentation and Right Justification
  • 4104 - Hanging Indentation and Left/Right Justification
  • 8192 - First Line Indentation and Left Justification
  • 8193 - First Line Indentation and Centered
  • 8194 - First Line Indentation and Right Justification
  • 8200 - 1st Line Indentation and Left/Right Justification

Default value is: 0 for Normal Indentation and Left Justification

Remarks

This option is to set the default value of the Paragraph Indentation and Justification properties for the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default paragraph indentation and justification properties in Image Editor by choosing Options, Default Properties, the Text Area tab, and then the Paragraph button.

The default value of this INI option is 0 for Normal Indentation and Left Justification.

Example

< DefaultTextArea >

Flags = 8200

Available

Release | _______
Patch |


FmtType

[DefaultTextArea]
FmtType

FmtType

[ DefaultTextArea]

FmtType = 0 turns off Can grow and shrink and Can span pages

Parameter

Description

LimitList

Values can be

  • 0 - None
  • 2 - Can grow and shrink
  • 4 - Can span pages
  • 6 - Can grow and shrink and Can span pages

Default value is: 0 turns off Can grow and shrink and Can span pages

Remarks

This option is to set the default value of the "Can grow & shrink" and "Can span pages" properties for the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default "Can grow & shrink" and "Can span pages" properties in Image Editor by choosing Options, Default Properties, and then the Text Area tab.

The default value of this INI option is 0 for turning off "Can grow & shrink" and "Can span pages".

Example

< DefaultTextArea >

FmtType = 2

Available

Release | _______
Patch |


Font

[DefaultTextArea]
Font

Font

Font - The Font option specifies a default font to be used in an image's text area. Enter the font's ID number for this option.

[ DefaultTextArea]

Font = 11010

Parameter | Description
value | font id number Default value is: 11010

Remarks

The Font option specifies a default font to be used in text area in the Image Manager of Documaker Studio and in the Image Editor. You can set the default font for the text area object in Image Editor by choosing Options, Default Properties, and then the Text Area tab. Enter the font's ID number for this option. The default value of this INI option is 11010 Arial Narrow 10 PT.

Example

< DefaultTextArea >

Font = 16010

Available

Release | _______
Patch |


Hindentation

[DefaultTextArea]
Hindentation

Hindentation

[ DefaultTextArea]

Hindentation = 0

Parameter | Description
Spin | Default value is: 0

Remarks

This option is to set the default value of the Paragraph Special Indentation (i.e. Hanging or First Line) for the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default special indentation for the paragraph for the text area in Image Editor by choosing Options, Default Properties, the Text Area tab, and then the Paragraph button. The value of this INI option is in 1/100 inch unit. For example, if you want to indent the first line of your paragraph by 0.5 inch, you would need to set this INI option to 50.

Example

< DefaultTextArea >

HIndentation = 50

Available

Release | _______
Patch |


HYPLanguage

[DefaultTextArea]
HYPLanguage

HYPLanguage

[ DefaultTextArea]

HYPLanguage = 45 for US English

Parameter

Description

LimitList

Values can be

  • 65 - Brazilian Portuguese
  • 3 - Danish
  • 4 - Dutch
  • 6 - Finnish
  • 7 - French
  • 8 - German
  • 11 - Italian
  • 12 - Norwegian
  • 14 - Portuguese
  • 17 - Spanish
  • 18 - Swedish
  • 5 - UK English
  • 45 - US English

Default value is: 45 for US English

Remarks

This option is to specify the language to base on, when hyphenating the text in the Text Area object in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default language for hyphenation in Image Editor by choosing Options, Default Properties, and then the Text Area tab.

The default value of this INI option is 45 for US English.

Example

< DefaultTextArea >

HYPLanguage = 7

Available

Release | _______
Patch |


HYPParaLanguage

[DefaultTextArea]
HYPParaLanguage

HYPParaLanguage

[ DefaultTextArea]

HYPParaLanguage = 45 for US English

Parameter

Description

LimitList

Values can be

  • 3 - Danish
  • 65 - Brazilian Portuguese
  • 4 - Dutch
  • 6 - Finnish
  • 7 - French
  • 8 - German
  • 11 - Italian
  • 12 - Norwegian
  • 14 - Portuguese
  • 17 - Spanish
  • 18 - Swedish
  • 5 - UK English
  • 45 - US English

Default value is: 45 for US English

Remarks

This option is to specify the language to base on, when hyphenating the text in the paragraph in the Text Area object in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default language for paragraph hyphenation in Image Editor by choosing Options, Default Properties, the Text Area tab and then the Paragraph button.

The default value of this INI option is 45 for US English.

Example

< DefaultTextArea >

HYPParaLanguage = 7

Available

Release | _______
Patch |


LeftIndentation

[DefaultTextArea]
LeftIndentation

LeftIndentation

[ DefaultTextArea]

LeftIndentation = 0

Parameter | Description
Spin | Default value is: 0

Remarks

This option is to specify the default value of the Paragraph Left Indentation for the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default left indentation for the paragraph of the text area in Image Editor by choosing Options, Default Properties, the Text Area tab, and then the Paragraph button. The value of this INI option is in 1/100 inch unit. For example, if you want to indent your paragraph at the left side by 1 inch, you would need to set this INI option to 100.

Example

< DefaultTextArea >

LeftIndentation = 100

Available

Release | _______
Patch |


Options

[DefaultTextArea]
Options

Options

[ DefaultTextArea]

Options = 0 for turning off hyphenation

Parameter

Description

LimitList

Values can be

  • 0 - Turn off hyphenation
  • 4 - Turn on hyphenation

Default value is: 0 for turning off hyphenation

Remarks

This option is to turn on or off the Hyphenation flag for the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default hyphenation in Image Editor by choosing Options, Default Properties, and then the Text Area tab.

The default value of this INI option is 0 for turning off Hyphenation.

Example

< DefaultTextArea >

Options = 4

Available

Release | _______
Patch |


ParaOptions

[DefaultTextArea]
ParaOptions

ParaOptions

[ DefaultTextArea]

ParaOptions = 0 for turning off hyphenation

Parameter

Description

LimitList

Values can be

  • 0 - Turn off hyphenation
  • 4 - Turn on hyphenation

Default value is: 0 for turning off hyphenation

Remarks

This option is to turn on or off the Hyphenation flag for the Paragraph of the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default hyphenation for the paragraph of the text area in Image Editor by choosing Options, Default Properties, the Text Area tab and then the Paragraph button.

The default value of this INI option is 0 for turning off Hyphenation.

Example

< DefaultTextArea >

ParaOptions = 4

Available

Release | _______
Patch |


RightIndentation

[DefaultTextArea]
RightIndentation

RightIndentation

[ DefaultTextArea]

RightIndentation = 0

Parameter | Description
Spin | Default value is: 0

Remarks

This option is to set the default value of the Right Indentation for the Paragraph in the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default right indentation for the paragraph in the text area object in Image Editor by choosing Options, Default Properties, the Text Area tab, and then the Paragraph button. The value of this INI option is in 1/100 inch unit. For example, if you want to indent your paragraph at the right side by 1 inch, you would need to set this INI option to 100.

Example

< DefaultTextArea >

RightIndentation = 100

Available

Release | _______
Patch |


SpaceAbove

[DefaultTextArea]
SpaceAbove

SpaceAbove

[ DefaultTextArea]

SpaceAbove = 0

Parameter | Description
Faps | Default value is: 0

Remarks

This option is to specify the default space above the Paragraph for the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default space above the paragraph for the text area in Image Editor by choosing Options, Default Properties, the Text Area tab, and then the Paragraph button. The value of this INI option is in the FAPs Unit (i.e. 2400 FAPs = 1 inch).

Example

< DefaultTextArea >

SpaceAbove = 1200

Available

Release | _______
Patch |


SpaceBelow

[DefaultTextArea]
SpaceBelow

SpaceBelow

[ DefaultTextArea]

SpaceBelow = 0

Parameter | Description
Faps | Default value is: 0

Remarks

This option is to specify the default space below the Paragraph for the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default space below the paragraph for the text area in Image Editor by choosing Options, Default Properties, the Text Area tab, and then the Paragraph button. The value of this INI option is in the FAPs Unit (i.e. 2400 FAPs = 1 inch).

Example

< DefaultTextArea >

SpaceBelow = 1200

Available

Release | _______
Patch |


TabStop

[DefaultTextArea]
TabStop

TabStop

[ DefaultTextArea]

TabStop = 0

Parameter | Description
Faps | Default value is: 0

Remarks

This option is to set the default Tab Stop for the Text Area objects in the Image Manager of Documaker Studio, and in the Image Editor. You can set the default tab stop for the text area in Image Editor by choosing Options, Default Properties, and then the Text Area tab. The value of this INI option is in the FAPs Unit (i.e. 2400 FAPs = 1 inch).

Example

< DefaultTextArea >

TabStop = 1200

Available

Release | _______
Patch |


DefaultTextLabel

DefaultTextLabel Options

  • Color
  • Effects
  • Font
  • Length
  • Orientation


Color

[DefaultTextLabel]
Color

Color

This option defines the default color for text labels.

[ DefaultTextLabel]

Color = 0

Parameter | Description
Color | Default value is: 0

Remarks

This option is to set the default color for the Text Label objects in the image.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255). The default value of this option is 0 for Black.

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

For example, if most of your Text Labels will be in the Blue color, you will set this INI option to 16711680. When you are adding new Text Labels to the images, they will be in the Blue color by default.

The INI option is also used in FixForm (fixfmw32.exe), which is a command line utility available with various options. Please refer to the Docutoolbox Reference book for more information.

If you specify the /A option in FixForm and you also have the Color option in the DefaultTextLabel INI group in the INI file that you use with FixForm, then FixForm will change the color of those Text Labels, which were originally in the default color other than black but not set to "Print in color", with the color specified in this INI option, and also turn on the "Print in color" option for the text labels.

Here is an example:

You set the text label default color to Green in the Image Editor by choosing Format, Image Properties, and Color tab. You also have four text labels in the FAP file:

Text label 1 is in Black and not to print in color.

Text label 2 is in the Default color (Green) and not to print in color.

Text label 3 is in Red and not to print in color.

Text label 4 is in the Default color (Green) and to print in color.

In the INI file, you have the following entry:

< DefaultTextLabel >

Color = 255

Then, you use the FixForm utility with /A option to convert all colored objects in the FAP file.

Text label 1 will remain unchanged because it is not a colored object.

Text label 2 will change to Red and to print in color.

Text label 3 will change to print in color but keep its original color, because it was not in the Default color.

Text label 4 will remain unchanged because the print in color has been turned on.

Example

< DefaultTextLabel >

Color = 0

Available

Release | _______
Patch |


Effects

[DefaultTextLabel]
Effects

Effects

[ DefaultTextLabel]

Effects = 0

Parameter

Description

LimitList

Values can be

  • 0 - None
  • 1 - Underline
  • 2 - Strike-out
  • 3 - Underline and Strike-out

Default value is: 0

Remarks

This option is to set the default properties (i.e. Underline and Strike-out) for text label.

The values of this option are:

0 (default) None of Underline and Strike-out are selected

1 Underline is selected

2 Strike-out is selected

3 Both Underline and Strike-out are selected

For example, if most of your text labels will be underlined, you may set this INI option to 1. When you are adding new text labels to the image, they will be underlined by default.

If you are using Image Editor, you may select these properties by choosing Options, Default properties, and then Text Label tab.

Example

< DefaultTextLabel >

Effects = 1

Available

Release | _______
Patch |


Font

[DefaultTextLabel]
Font

Font

[ DefaultTextLabel]

Font = Font

Parameter | Description
Font |

Remarks

This INI option defines the default font for text labels in Documaker Studio. If you are using Image Editor, this value may be set in the Default Properties window of the tool.

Example

< DefaultTextLabel >

Font = 16010 Helv 10 PT

Available

Release | _______
Patch |


Length

[DefaultTextLabel]
Length

Length

This option defines the default length of text labels in inches.

[ DefaultTextLabel]

Length = Spin

Parameter | Description
Spin |

Example

< DefaultTextLabel >

Length = 1

Available

Release | _______
Patch |


Orientation

[DefaultTextLabel]
Orientation

Orientation

[ DefaultTextLabel]

Orientation = 0

Parameter

Description

LimitList

Values can be

  • 0 - 0 deg.: Normal
  • 90 - 90 deg.: Downward
  • 180 - 180 deg.: Upside down
  • 270 - 270 deg.: Upward

Default value is: 0

Remarks

This option is to set the default rotation (orientation) for text labels.

The values of this option are:

0 (default) 0 deg.: Normal

90 90 deg. Downward

180 180 deg.: Upside down

270 270 deg.: Upward

For example, if most of your text labels in an image will be upside down for folding reason, you may set this INI option to 180. When you are adding new text labels to the image, they will be upside down by default.

If you are using Image Editor, you may select these properties by choosing Options, Default properties, and then Text Lebel tab.

Example

< DefaultTextLabel >

Orientation = 180

Available

Release | _______
Patch |


DefaultVarField

Remarks

Use the DefaultVarField control group to specify the default properties for the Field objects in an image. The properties for the field vary depending upon the type of the field. For instance, you may specify the date format, separator, and etc. for the date field, or you may specify the "Can grow" and "Can span page" flags for the multi-line text field. If you are using Image Editor, you may have multiple DefaultVarField groups in the INI file with one group for one type each.

Example

< DefaultVarField >

Effects = 1

Flags = 4104

FmtType = 6

Font = 10012

HIndentation = 100

LeftIndentation = 50

Orientation = 90

Required = 1

RightIndentation = 50

Scope = 1

SpaceAbove = 240

SpaceBelow = 480

SpacingType = 4

TabStop = 600

Type = M

DefaultVarField Options

  • DisplayOnly
  • Dummy
  • Effects
  • Flags
  • FmtType
  • Font
  • Format
  • Hindentation
  • HYPLanguage
  • HYPParaLanguage
  • LeftIndentation
  • Options
  • Orientation
  • ParaOptions
  • Required
  • RightIndentation
  • Scope
  • SendCopyTo
  • SpaceAbove
  • SpaceBelow
  • Spacing
  • SpacingType
  • TabStop
  • Type


DisplayOnly

[DefaultVarField]
DisplayOnly

DisplayOnly

[ DefaultVarField]

DisplayOnly = 0 for turning off "No User Edit"

Parameter

Description

LimitList

Values can be

  • 0 - Turn off "No User Edit"
  • 1 - Turn on "No User Edit"

Default value is: 0 for turning off "No User Edit"

Remarks

Use the DisplayOnly option to specify the default value of the "No User Edit" flag for the variable fields in an image. The default value of this INI option is 0 for turning off the "No User Edit" flag. If you are using Image Editor, you may specify this INI option by choosing Options, Default Properties, and then the Field tab.

Example

< DefaultVarField >

DisplayOnly = 1

Available

Release | _______
Patch |


Dummy

[DefaultVarField]
Dummy

Dummy

[ DefaultVarField]

Dummy = 0 for turning off "Hidden" and "Never Print"

Parameter

Description

LimitList

Values can be

  • 0 - Turn off "Hidden" and "Never Print"
  • 1 - Turn on "Hidden" only
  • 2 - Turn on "Never Print" only
  • 3 - Turn on "Hidden" and "Never Print"

Default value is: 0 for turning off "Hidden" and "Never Print"

Remarks

Use the Dummy option to specify the default value of the "Hidden" and "Never Print" flags for the variable fields in an image. The default value of this INI option is 0 for turning off the "Hidden" and "Never Print" flags. If you are using Image Editor, you may specify this INI option by choosing Options, Default Properties, and then the Field tab.

Example

< DefaultVarField >

Dummy = 3

Available

Release | _______
Patch |


Effects

[DefaultVarField]
Effects

Effects

[ DefaultVarField]

Effects = 0 for turning off "Underline"

Parameter

Description

LimitList

Values can be

  • 0 - Turn off "Underline"
  • 1 - Turn on "Underline"

Default value is: 0 for turning off "Underline"

Remarks

Use the Effects option to specify the default value of the Underline flag for the variable fields in an image. The default value of this INI option is 0 for turning off the Underline flag. If you are using Image Editor, you may specify this INI option by choosing Options, Default Properties, and then the Field tab.

Example

< DefaultVarField >

Effects = 1

Available

Release | _______
Patch |


Flags

[DefaultVarField]
Flags

Flags

[ DefaultVarField]

Flags = 0 for Normal Indentation and Left Justification

Parameter

Description

LimitList

Values can be

  • 0 - Normal Indentation and Left Justification
  • 1 - Normal Indentation and Centered
  • 8 - Normal Indentation and Left & Right Justification
  • 4096 - Hanging Indentation and Left Justification
  • 4097 - Hanging Indentation and Centered
  • 4098 - Hanging Indentation and Right Justification
  • 4104 - Hanging Indentation and Left & Right Justification
  • 8192 - First Line Indentation and Left Justification
  • 8193 - First Line Indentation and Centered
  • 8194 - First Line Indentation and Right Justification
  • 8200 - First Line Indentation, Left & Right Justification
  • 2 - Normal Indentation and Right Justification

Default value is: 0 for Normal Indentation and Left Justification

Remarks

This option is to set the default value of the Paragraph Indentation and Justification properties for the multi-line text fields in the Image Editor. You can set the default paragraph indentation and justification properties by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text type and then clicking on the Paragraph button.

The default value of this INI option is 0 for Normal Indentation and Left Justification.

Example

< DefaultVarField >

Flags = 8200

Available

Release | _______
Patch |


FmtType

[DefaultVarField]
FmtType

FmtType

[ DefaultVarField]

FmtType = 0 for none

Parameter

Description

LimitList

Values can be

  • 0 - None
  • 2 - Can grow & shrink
  • 4 - Can span pages
  • 6 - Can grow & shrink and Can span pages

Default value is: 0 for none

Remarks

This option is to set the default value of the "Can grow & shrink" and "Can span pages" properties for the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The default value of this INI option is 0 for turning off "Can grow & shrink" and "Can span pages". You can set the default "Can grow & shrink" and "Can span pages" properties by choosing Options, Default Properties, and the Field tab, and selecting Multi-Line Text for the field type.

Example

< DefaultVarField >

Type = M

FmtType = 2

Available

Release | _______
Patch |


Font

[DefaultVarField]
Font

Font

[ DefaultVarField]

Font = 0 for Arial Narrow 10 PT (PCL AFP XER PS Oth)

Parameter | Description
Font | Default value is: 0 for Arial Narrow 10 PT (PCL AFP XER PS Oth)

Remarks

Use the Font option to specify the default font ID for the variable fields in Image Editor. The default value of this INI option is 10010 for Arial Narrow 10 PT (PCL AFP XER PS Oth). You may specify this INI option by choosing Options, Default Properties, and then the Field tab.

Example

< DefaultVarField >

Font = 10012

Available

Release | _______
Patch |


Format

[DefaultVarField]
Format

Format

[ DefaultVarField]

Format = Edit

Parameter | Description
Edit |

Remarks

If the default type for the variable fields is "Bar Code" , "Date Format" or "Time Format", use the Format option to specify the default format for the bar code or the date fields in an image.

The value of this INI option for the bar code fields can be any code in the following list for the type of bar code:

Code - Type of bar code

A - Code 39 1:1:3:3

B - Code 39 1:1:2:2

C - Code 39 1:2:4:5

D - Codabar Standard

E - Codabar compressed

F - Interleaved 2 of 5 1:1:3:3

G - UPC-A 1:2:3:4 11 Digit

H - UPC-EO Zero Suppress 10 Digit

I - UPC-EO 6 Digit

J - UPC-EI 6 Digit

K - EAN-8 Digit

L - EAN-13 Digit

M - Code 39 3:1 Mod 43 Check Digit

N - MSI no Check Digit

O - MSI Mod 10 Check Digits

P - MSI Mod 10/10 Check Digits

Q - MSI Mod 11/10 Check Digits

R - Code 128 Start Code A

S - Code 128 Start Code B

T - Code 128 Start Code C

U - Code 128 Automatic Add-On

V - UPC 2-Digit Add-On

W - UPC 5-Digit Add-On

X - Interleaved 2 of 5 Mod 10

Y - Code 93

Z - Zip code

1 - Planet

The default value of this INI option is Z for Zipcode for the bar code fields.

For the date variable fields, this INI option has 4 parameters: A, B, C, and D.

Parameter A is for the date formats. The value of this parameter can be any code in the following list for the date format:

Code - Date Format

1 - MM/DD/YY

2 - DD/MM/YY

3 - YY/MM/DD

4 - Month D, Yr

5 - M/D/YY

6 - D/M/YY

7 - YY/M/D

8 - bM/bD/YY

9 - bD/bM/YY

A - YY/bM/bD

B - MMDDYY

C - DDMMYY

D - YYMMDD

E - MonDDYY

F - DDMonYY

G - YYMonDD

H - DAY/YY

I - YY/DAY

J - D Month, Yr

K - Yr, Month D

L - Mon-DD-YY

M - DD-Mon-YY

N - YY-Mon-DD

O - Mon D, Yr

P - D Mon, Yr

Q - Yr, Mon D

Parameter B is for the separator. The value of this parameter can be any code in the following list for the separator:

Code - Separator

/ - Slash

- - Dash

. - Period

, - Comma

b - Space

- None

Parameter C is for the year size. The value of this parameter can be any code in the following list for the year size:

Code - Year Size

- Default

2 - 2

3 - 2 Exact

4 - 4

5 - 4 Exact

Parameter D is for the case (i.e. Default, Lowercase, or Uppercase). The value of this parameter can be any code in the following list for the case:

Code - Year Size

- Default

> - Lowercase

< - Uppercase

The default value of this INI option for the date fields is "1/" for MM/DD/YY with Slash ("/") as separator.

For the time format variable fields, this INI option has 2 parameters: A and B.

Parameter A is for the time formats. The value of this parameter can be any code in the following list for the time format:

Code - Date Format

1 - HH:MM:SS

2 - HH:MM:SS XM

3 - HH:MM

4 - HH:MM XM

Parameter B is for the separator. The value of this parameter can be any code in the following list for the separator:

Code - Separator

: - Colon

- - Dash

. - Period

, - Comma

b - Space

The default value of this INI option for the time fields is 1: for HH:MM:SS with colon (":") as separator.

If you are using Image Editor, you can enter this setting by choosing Options, Default Properties and the Field tab, and selecting Bar Code, Date Format or Time Format type for the field.

Example

< DefaultVarField >

Type = d

Format = 1/2

Available

Release | _______
Patch |


Hindentation

[DefaultVarField]
Hindentation

Hindentation

[ DefaultVarField]

Hindentation = 0

Parameter | Description
Spin | Default value is: 0

Remarks

This option is to set the default value of the Paragraph Special Indentation (i.e. Hanging or First Line) for the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The value of this INI option is in 1/100 inch unit. For example, if you want to indent the first line of your paragraph by 0.5 inch, you would need to set this INI option to 50. You can set the default special indentation for the paragraph for the multi-line text field by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

HIndentation = 50

Available

Release | _______
Patch |


HYPLanguage

[DefaultVarField]
HYPLanguage

HYPLanguage

[ DefaultVarField]

HYPLanguage = 45 for US English

Parameter

Description

LimitList

Values can be

  • 65 - Brazilian Portuguese
  • 3 - Danish
  • 4 - Dutch
  • 6 - Finnish
  • 7 - French
  • 8 - German
  • 11 - Italian
  • 12 - Norwegian
  • 14 - Portuguese
  • 17 - Spanish
  • 18 - Swedish
  • 5 - UK English
  • 45 - US English

Default value is: 45 for US English

Remarks

This option is to specify the language to base on, when hyphenating the text in the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The default value of this INI option is 45 for US English. You can set the default language for hyphenation by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type.

Example

< DefaultVarField >

Type = M

HYPLanguage = 7

Available

Release | _______
Patch |


HYPParaLanguage

[DefaultVarField]
HYPParaLanguage

HYPParaLanguage

[ DefaultVarField]

HYPParaLanguage = 45 for US English

Parameter

Description

LimitList

Values can be

  • 65 - Brazilian Portuguese
  • 3 - Danish
  • 4 - Dutch
  • 6 - Finnish
  • 7 - French
  • 8 - German
  • 11 - Italian
  • 12 - Norwegian
  • 14 - Portuguese
  • 17 - Spanish
  • 18 - Swedish
  • 5 - UK English
  • 45 - US English

Default value is: 45 for US English

Remarks

This option is to specify the language to base on, when hyphenating the text in the paragraph in the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The default value of this INI option is 45 for US English. You can set the default language for paragraph hyphenation by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

HYPParaLanguage = 7

Available

Release | _______
Patch |


LeftIndentation

[DefaultVarField]
LeftIndentation

LeftIndentation

[ DefaultVarField]

LeftIndentation = Spin

Parameter | Description
Spin |

Remarks

This option is to specify the default value of the Paragraph Left Indentation for the multi-line text variable field (i.e. the Type option must equal to M) in Image Editor. The value of this INI option is in 1/100 inch unit. For example, if you want to indent your paragraph at the left side by 1 inch, you would need to set this INI option to 100. You can set the default left indentation for the paragraph by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text type and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

LeftIndentation = 100

Available

Release | _______
Patch |


Options

[DefaultVarField]
Options

Options

[ DefaultVarField]

Options = 0 for turning off hyphenation

Parameter

Description

LimitList

Values can be

  • 0 - Turn off hyphenation
  • 4 - Turn on hyphenation

Default value is: 0 for turning off hyphenation

Remarks

This option is to turn on or off the Hyphenation flag for the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The default value of this INI option is 0 for turning off Hyphenation. You can set the default hyphenation by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type.

Example

< DefaultVarField >

Type = M

Options = 4

Available

Release | _______
Patch |


Orientation

[DefaultVarField]
Orientation

Orientation

[ DefaultVarField]

Orientation = 0 for 0 deg.: Normal

Parameter

Description

LimitList

Values can be

  • 0 - 0 deg.: Normal
  • 90 - 90 deg.: Downward
  • 180 - 180 deg.: Upside down
  • 270 - 270 deg.: Upward

Default value is: 0 for 0 deg.: Normal

Remarks

This option is to set the default rotation (orientation) for variable fields in an image.

The values of this option are:

0 (default) 0 deg.: Normal

90 90 deg. Downward

180 180 deg.: Upside down

270 270 deg.: Upward

For example, if most of your variable fields in an image will be upside down for folding reason, you may set this INI option to 180. When you are adding new variable fields to the image, they will be upside down by default.

If you are using Image Editor, you may select these properties by choosing Options, Default properties, and then Field tab.

Example

< DefaultVarField >

Orientation = 180

Available

Release | _______
Patch |


ParaOptions

[DefaultVarField]
ParaOptions

ParaOptions

[ DefaultVarField]

ParaOptions = 0 for turning off hyphenation

Parameter

Description

LimitList

Values can be

  • 0 - Turn off hyphenation
  • 4 - Turn on hyphenation

Default value is: 0 for turning off hyphenation

Remarks

This option is to turn on or off the Hyphenation flag for the Paragraph of the Multi-line Text field (i.e. the Type INI option must equal to M) in Image Editor. The default value of this INI option is 0 for turning off Hyphenation. You can set the default hyphenation for the paragraph by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

ParaOptions = 4

Available

Release | _______
Patch |


Required

[DefaultVarField]
Required

Required

[ DefaultVarField]

Required = 0 for turning off the "Required" flag

Parameter

Description

LimitList

Values can be

  • 0 - Uncheck Required
  • 1 - Check Required

Default value is: 0 for turning off the "Required" flag

Remarks

Turn on the Required flag under the Attributes tree for a field if a user must complete the field. If most of your varialbe fields must be completed by a user, you can use this INI option to turn on the "Required" flag, when a variable field is being added to an image. The default value of this INI option is 0, i.e. turn off the "Required" flag. If you are using the Image Editor, you can set up this option by choosing Options, Default Properties and then the Field tab.

Note: The Documaker Rules Processing System is using the other "Required" flag under the Rule tree.

Example

< DefaultVarField >

Required = 1

Available

Release | _______
Patch |


RightIndentation

[DefaultVarField]
RightIndentation

RightIndentation

[ DefaultVarField]

RightIndentation = Spin

Parameter | Description
Spin |

Remarks

This option is to specify the default value of the Paragraph Right Indentation for the multi-line text variable field (i.e. the Type option must equal to M) in Image Editor. The value of this INI option is in 1/100 inch unit. For example, if you want to indent your paragraph at the right side by 1 inch, you would need to set this INI option to 100. You can set the default left indentation for the paragraph by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text type and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

RightIndentation = 100

Available

Release | _______
Patch |


Scope

[DefaultVarField]
Scope

Scope

[ DefaultVarField]

Scope = 0 for Section

Parameter

Description

LimitList

Values can be

  • 0 - Section
  • 1 - Form
  • 3 - Global

Default value is: 0 for Section

Remarks

Use the Scope option to specify the default scope for the variable fields. The scopes that the Documaker system supports are Section, Form, and Formset. The default value of this INI option is 0 for Section. If you are using Image Editor, you may specify this INI option by choosing Options, Default Properties, and then the Field tab.

Example

< DefaultVarField >

Scope = 1

Available

Release | _______
Patch |


SendCopyTo

[DefaultVarField]
SendCopyTo

SendCopyTo

[ DefaultVarField]

SendCopyTo = 0

Parameter

Description

LimitList

Values can be

  • 0 - Uncheck "Send Copy To"
  • 1 - Check "Send Copy To"

Default value is: 0

Remarks

Use this INI option to specify the default value of the "Send Copy To" flag for the variable field object in an image. The default value of this INI option is 0, i.e. turn off the "Send Copy To" flag. If you are using the Image Editor, you can set up this option by choosing Options, Default Properties and then the Field tab.

Example

< DefaultVarField >

SendCopyTo = 1

Available

Release | _______
Patch |


SpaceAbove

[DefaultVarField]
SpaceAbove

SpaceAbove

[ DefaultVarField]

SpaceAbove = Faps

Parameter | Description
Faps |

Remarks

This option is to specify the default space above the Paragraph for the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The value of this INI option is in the FAPs Unit (i.e. 2400 FAPs = 1 inch). You can set the default space above the paragraph by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

SpaceAbove = 1200

Available

Release | _______
Patch |


SpaceBelow

[DefaultVarField]
SpaceBelow

SpaceBelow

[ DefaultVarField]

SpaceBelow = Faps

Parameter | Description
Faps |

Remarks

This option is to specify the default space below the Paragraph for the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The value of this INI option is in the FAPs Unit (i.e. 2400 FAPs = 1 inch). You can set the default space below the paragraph by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type, and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

SpaceBelow = 1200

Available

Release | _______
Patch |


Spacing

[DefaultVarField]
Spacing

Spacing

[ DefaultVarField]

Spacing = Faps

Parameter | Description
Faps |

Remarks

This option is to specify the default spacing between lines in the Paragraph for the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The value of this INI option is in the FAPs Unit (i.e. 2400 FAPs = 1 inch). You can set the default line spacing in the paragraph by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

SpacingType = 16

Spacing = 400

Available

Release | _______
Patch |


SpacingType

[DefaultVarField]
SpacingType

SpacingType

[ DefaultVarField]

SpacingType = 0 for single line spacing

Parameter

Description

LimitList

Values can be

  • 0 - Single
  • 4 - Double
  • 16 - Exactly
  • 32 - At least
  • 256 - Multiple

Default value is: 0 for single line spacing

Remarks

This option is to specify the default line spacing type for the Paragraph in the multi-line text field (i.e. the Type INI option must equal to M) in Image Editor. The default value of this INI option is 0 for single line spacing. You can set the default line spacing in the paragraph by choosing Options, Default Properties and the Field tab, and selecting Multi-line Text field type and then clicking on the Paragraph button.

Example

< DefaultVarField >

Type = M

SpacingType = 16

Spacing = 400

Available

Release | _______
Patch |


TabStop

[DefaultVarField]
TabStop

TabStop

[ DefaultVarField]

TabStop = 0

Parameter | Description
Faps | Default value is: 0

Remarks

This option is to set the default Tab Stop for the variable fields in an image. The value of this INI option is in the FAPs Unit (i.e. 2400 FAPs = 1 inch). If you are using Image Editor, you can set the default tab stop for the variable fields by choosing Options, Default Properties, and then the Field tab.

Example

< DefaultVarField >

TabStop = 600

Available

Release | _______
Patch |


Type

[DefaultVarField]
Type

Type

[ DefaultVarField]

Type = x for Alphanumeric blank for Neutral

Parameter

Description

Type

Type

Values can be

  • C - Custom
  • x - Alphanumeric
  • k - Int'l Alphanumeric
  • a - Alphabetic
  • I - Int'l Alphabetic
  • X - Uppercase Alphanumeric
  • K - Int'l Uppercase Alphanumeric
  • A - Uppercase Alphabetic
  • l - Int'l Uppercase Alphabetic
  • n - Numeric
  • y - (Y)es or (N)o
  • m - X or Space
  • d - DateFormat
  • t - Table Only
  • M - Multi-line Text
  • B - Bar Code
  • T - Time Format

Default value is: x for Alphanumeric

Locale

Locale

Values can be

  • ARS - Argentina\Spanish
  • ATS - Austria\German
  • AUD - Australia\English
  • BED - Belgium\Dutch
  • BEF - Belgium\French
  • BOB - Bolivia\Spanish
  • BRC - Brazil\Portuguese
  • CAD - Canada\French
  • CAN - Canada\English
  • CHF - Switzerland\German
  • CHH - Switzerland\French
  • CHI - Switzerland\Italian
  • CHL - Liechtenstein\German
  • CLP - Chile\Spanish
  • COP - Columbia\Spanish
  • CRC - Costa Rica\Spanish
  • DEM - Germany\German
  • DKK - Denmark\Danish
  • ECS - Ecuador\Spanish
  • ESB - Spain\Basque
  • ESC - Spain\Catalan
  • ESP - Spain\Spanish
  • FLX - France\French
  • FMK - Finland\Swedish
  • FRF - Luxembourg\French
  • GBP - United Kingdom\English
  • GTQ - Guatemala\Spanish
  • IDR - Indonesia\Indonesian
  • IEP - Ireland\English
  • ISK - Iceland\Icelandic
  • LUX - Luxembourg\German
  • MXN - Mexico\Spanish
  • NLG - The Netherlands\Dutch
  • NOK - Norway\Norwegian
  • NZD - New Zealand\English
  • PAB - Panama\Spanish
  • PES - Peru\Spanish
  • PTE - Portugal\Portuguese
  • PYG - Paraguay\Spanish
  • SEK - Sweden\Swedish
  • ITL - Italy\Italian
  • USD - United States\English
  • UYU - Uruguay\Spanish
  • VEB - Venezuela\Spanish
  • ZAA - South Africa\Afrikaans
  • ZAR - South Africa\English

Default value is: blank for Neutral

Remarks

Use the Type option to specify the default type for the variable fields in an image. If the default type is "Numeric", "Y(es) or N(o)", or "Date Format", this INI option also allows you to specify the Locale for the variable fields. The default value of this INI option is x for Alphanumeric.

Example

< DefaultVarField >

Type = nCAD

Available

Release | _______
Patch |


DefaultVector

DefaultVector Options

  • BrushColor
  • BrushStyle
  • PenColor
  • PenStyle
  • PenWidth
  • Type


BrushColor

[DefaultVector]
BrushColor

BrushColor

[ DefaultVector]

BrushColor = 16777215

Parameter | Description
Color | Default value is: 16777215

Remarks

This option is to set the default value of the Brush Color for the Vector objects in the Image Manager in the Documaker Studio. If you edited the default value of the brush color for the vector in the Image Manager, the edited value will become the new default value of the brush color for the subsequent vectors in the Image Manager until the workspace is closed. The default value for this INI option is 16777215 for White.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255). The default value of this option is 0 for Black.

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

For example, if you use consistently the Gray color for the brush in the Vector objects, you may set this INI option to 8224125. When you are adding new Vector objects to the images, the brush will be in Gray color by default.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Vector tab.

Example

< DefaultVector >

BrushColor = 255

Available

Release | _______
Patch |


BrushStyle

[DefaultVector]
BrushStyle

BrushStyle

[ DefaultVector]

BrushStyle = 14

Parameter

Description

LimitList

Values can be

  • 0 - Solid
  • 1 - Horizontal
  • 2 - Vertical
  • 3 - Diagonal right
  • 4 - Diagonal Left
  • 5 - Hatch
  • 6 - Diagonal hatch
  • 7 - Lightest
  • 8 - Lighter
  • 9 - Light
  • 10 - Medium
  • 11 - Dark
  • 12 - Darker
  • 13 - Darkest
  • 14 - None (or No shade in Image Editor)

Default value is: 14

Remarks

This option is to set the default value of the Brush Style for the Vector objects in the Image Manager in the Documaker Studio. If you edited the default value of the Brush Style for the vector in the Image Manager, the edited value will become the new default value of the Brush Style for the subsequent vectors in the Image Manager until the workspace is closed. The default value for this INI option is 14 for None.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Vector tab.

Example

< DefaultVector >

BrushStyle = 5

Available

Release | _______
Patch |


PenColor

[DefaultVector]
PenColor

PenColor

[ DefaultVector]

PenColor = 0

Parameter | Description
Color | Default value is: 0

Remarks

This option is to set the default value of the Pen Color for the Vector objects in the Image Manager in the Documaker Studio. If you edited the default value of the pen color for the vector in the Image Manager, the edited value will become the new default value of the pen color for the subsequent vectors in the Image Manager until the workspace is closed. The default value for this INI option is 0 for Black.

The value you use for this INI option is a number which represents the combined Red, Green, and Blue values (each from 0 to 255). The default value of this option is 0 for Black.

The formula to determine the value you would use is as follows:

Color = (Red value) + (Green value * 256) + (Blue value * 65536)

The color Black would have an RGB value of Red=0, Green=0, and Blue=0.

The Color INI option for Black would be (0) + (0*256) + (0*65536) which equals 0.

The color Red would have an RGB value of Red=255, Green=0, and Blue=0.

The Color INI option for Red would be (255) + (0*256) + (0*65536) which equals 255.

The color Cyan would have an RGB value of Red=0, Green=255, and Blue=255.

The Color INI option for Cyan would be (0) + (255*256) + (255*65536) which equals 16776960.

For example, if you use consistently the Gray color for the pen in the Vector objects, you may set this INI option to 8224125. When you are adding new Vector objects to the images, the pen will be in Gray color by default.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Vector tab.

Example

< DefaultVector >

PenColor = 255

Available

Release | _______
Patch |


PenStyle

[DefaultVector]
PenStyle

PenStyle

[ DefaultVector]

PenStyle = 2

Parameter

Description

LimitList

Values can be

  • 2 - Solid line
  • 8 - Empty

Default value is: 2

Remarks

This option is to set the default value of the Pen Style for the Vector objects in the Image Manager in the Documaker Studio. If you edited the default value of the pen style for the vector in the Image Manager, the edited value will become the new default value of the pen style for the subsequent vectors in the Image Manager until the workspace is closed. The default value for this INI option is 2 for solid line.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Vector tab.

Example

< DefaultVector >

PenStyle = 2

Available

Release | _______
Patch |


PenWidth

[DefaultVector]
PenWidth

PenWidth

[ DefaultVector]

PenWidth = 0

Parameter | Description
Faps | Default value is: 0

Remarks

This option is to set the default value of the Pen Width for the Vector objects in the Image Manager in the Documaker Studio. If you edited the default value of the pen width for the vector in the Image Manager, the edited value will become the new default value of the pen width for the subsequent vectors in the Image Manager until the workspace is closed.

This option is also used by the Image Editor. You may set this option in the Image Editor by choosing Options, Default Properties, and then the Vector tab.

The value of this option is in the FAP units (i.e. 2400 FAPs = 1 inch).

Example

< DefaultVector >

PenWidth = 24

Available

Release | _______
Patch |


Type

[DefaultVector]
Type

Type

[ DefaultVector]

Type = 72

Parameter

Description

LimitList

Values can be

  • 22 - Alternate polygon
  • 3 - Arc
  • 39 - Chord
  • 55 - Circle
  • 7 - Ellipse
  • 23 - Pie Slice
  • 18 - Polyline
  • 72 - Rounded rectangle
  • 20 - Winding polygon

Default value is: 72

Remarks

This option is to set the default value for the Type of the Vector objects in the Image Manager in the Documaker Studio. If you edited the default value of the Type for the vector in the Image Manager, the edited value will become the new default value for the subsequent vectors in the Image Manager until the workspace is closed. The default value of this INI option is 72 for Rounded rectangle.

This option is also used by the Image Editor. You may set this option in Image Editor by choosing Options, Default Properties, and then the Vector tab.

Example

< DefaultVector >

Type = 22

Available

Release | _______
Patch |


DlgTitles

Remarks

Use the DlgTitles control group to change the screen text (field labels, window titles, column headings, and/or button captions.) in the Documaker Workstation. If the options are not specified in the INI file, the system default text will be displayed. The value of the option is the text to display on the window. If the option equals to no value (i.e. blank), then it will display blank for the item used by the option.

For example, if the INI file contains the following entry:

< DlgTitles >

Key1Title =

Key1Title is used to display the label for the Key1 field. Since the value of this INI option is blank, there will be no label (i.e. label is blank) for the Key1 field on the window.

Example

< DlgTitles >

Key1Title = Region

Key2Title = Line of Business

KeyIDTitle = Account #

TransTitle = Shipments

InfoTitle = Shipment Doc ID

FormListTitle = Available Doc

CheckArchiveTitle = Archived Bills

CheckImportTitle = Import Data

DuplicateTitle = Duplicate Bills

DlgTitles Options

  • AddBtnTitle
  • ArchiveTitle
  • AssignDlgTitle
  • AssignListTitle
  • AutoKeyIDBeginTitle
  • AutoKeyIDEndTitle
  • BatchTitle
  • CheckArchiveTitle
  • CheckImportTitle
  • CompleteDlgTitle
  • DemandTitle
  • DownBtnTitle
  • DuplicateTitle
  • FormDlgTitle
  • FormListTitle
  • InfoTitle
  • JurisdictnTitle
  • Key1Title
  • Key1TitleFS
  • Key2Title
  • Key2TitleFS
  • KeyIDTitle
  • KeyIDTitleFS
  • LocIDTitle
  • Personal
  • PersonalDlgTitle
  • PersonalListTitle
  • PrintTitle
  • RemoveBtnTitle
  • RetOptionsDlgTitle
  • RetrieveDlgTitle
  • RetrOptionsOnlyEntry
  • RetrOptionsPrintOnly
  • RetrOptionsStackOnly
  • SortDlgTitle
  • StatusDlgTitle
  • StatusListTitle
  • SubLocIDTitle
  • TransTitle
  • TrnNameTitle
  • UpBtnTitle


AddBtnTitle

[DlgTitles]
AddBtnTitle

AddBtnTitle

This option assigns the characters "Add->", for the example below, to the Add button in the Personal Formset Selection window.

[ DlgTitles]

AddBtnTitle =

Parameter | Description
value |

Remarks

Note, unlike menus, the tilde character (~) is optionally used to indicate that the next character is the accelerator for the button.

Example

< DlgTitles >

AddBtnTitle = ~Add ->

Available

Release | _______
Patch |


ArchiveTitle

[DlgTitles]
ArchiveTitle

ArchiveTitle

This option overrides the text of the Archive checkbox on the Complete dialog.

[ DlgTitles]

ArchiveTitle =

Parameter | Description
value | This option overrides the text of the Archive checkbox on the Complete dialog.

Example

< DlgTitles >

ArchiveTitle = My Archives

Available

Release | _______
Patch |


AssignDlgTitle

[DlgTitles]
AssignDlgTitle

AssignDlgTitle

This option overrides the default title for the Assign dialog that displays users to receive WIP.

[ DlgTitles]

AssignDlgTitle = Edit

Parameter | Description
value | This option overrides the default title for the Assign dialog that displays users to receive WIP.

Example

< DlgTitles >

AssignDlgTitle = Assigned List

Available

Release | _______
Patch |


AssignListTitle

[DlgTitles]
AssignListTitle

AssignListTitle

This option overrides the defaults for Assign dialog list of users title.

[ DlgTitles]

AssignListTitle = Edit

Parameter | Description
value | This option overrides the defaults for Assign dialog list of users title.

Example

< DlgTitles >

AssignListTitle = My assigned list

Available

Release | _______
Patch |


AutoKeyIDBeginTitle

[DlgTitles]
AutoKeyIDBeginTitle

AutoKeyIDBeginTitle

This option defines the text displayed on the Policy Number Generation window.

[ DlgTitles]

AutoKeyIDBeginTitle = Begin

Parameter | Description
value | Default value is: Begin

Remarks

If no value is specified in the INI, the default value is "Begin".

Example

< DlgTitles >

AutoKeyIDBeginTitle = Begin

Available

Release | _______
Patch |


AutoKeyIDEndTitle

[DlgTitles]
AutoKeyIDEndTitle

AutoKeyIDEndTitle

This option defines the text displayed on the Policy Number Generation window.

[ DlgTitles]

AutoKeyIDEndTitle = End

Parameter | Description
value | Default value is: End

Remarks

If no value is specified in the INI, the default value is "End".

Example

< DlgTitles >

AutoKeyIDEndTitle = End

Available

Release | _______
Patch |


BatchTitle

[DlgTitles]
BatchTitle

BatchTitle

This option overrides the text of the Batch Print button on the Complete dialog.

[ DlgTitles]

BatchTitle = Edit

Parameter | Description
value | This option overrides the text of the Batch Print button on the Complete dialog.

Example

< DlgTitles >

BatchTitle = Print Batch

Available

Release | _______
Patch |


CheckArchiveTitle

[DlgTitles]
CheckArchiveTitle

CheckArchiveTitle

Changes the name of the "Retrieve" button on the Form Selection dialog.

[ DlgTitles]

CheckArchiveTitle =

Parameter | Description
Edit | Changes the name of the "Retrieve" button on the Form Selection dialog.

Example

< DlgTitles >

CheckArchiveTitle = Retrieve Data

Available

Release | _______
Patch |


CheckImportTitle

[DlgTitles]
CheckImportTitle

CheckImportTitle

[ DlgTitles]

CheckImportTitle = Edit

Parameter | Description
Import Data |

Remarks

The CheckImportTitle option overrides the default name of the "Import" button on the Form Selection dialog.

Example

< DlgTitles >

CheckImportTitle = Import Data

Available

Release | _______
Patch |


CompleteDlgTitle

[DlgTitles]
CompleteDlgTitle

CompleteDlgTitle

This option overrides the default title of the Complete dialog.

[ DlgTitles]

CompleteDlgTitle = Edit

Parameter | Description
value | This option overrides the default title of the Complete dialog.

Remarks

To change the title of the Complete window, use the following INI option. If do not want the window to have a title, leave the right side (TitleToDisplay) blank.

Example

< DlgTitles >

CompleteDlgTitle = Complete Bill

Available

Release | 10.0
Patch |


DemandTitle

[DlgTitles]
DemandTitle

DemandTitle

This option overrides the text of the Immediate Print button on the Complete dialog.

[ DlgTitles]

DemandTitle =

Parameter | Description
value | This option overrides the text of the Immediate Print button on the Complete dialog.

Example

< DlgTitles >

DemandTitle = Print Immediately

Available

Release | _______
Patch |


DownBtnTitle

[DlgTitles]
DownBtnTitle

DownBtnTitle

This option assigns the name "Down" to the Down button in the Personal Formset Selection window.

[ DlgTitles]

DownBtnTitle =

Parameter | Description
value |

Remarks

Note, unlike menus, the tilde character (~) is optionally used to indicate that the next character is the accelerator for the button.

Example

< DlgTitles >

DownBtnTitle = Do~wn

Available

Release | _______
Patch |


DuplicateTitle

[DlgTitles]
DuplicateTitle

DuplicateTitle

Changes the name of the Duplicate button on the Form Selection dialog.

[ DlgTitles]

DuplicateTitle =

Example

< DlgTitles >

DuplicateTitle = Duplicate Bill

Available

Release | _______
Patch |


FormDlgTitle

[DlgTitles]
FormDlgTitle

FormDlgTitle

Changes the name of Form Selection dialog.

[ DlgTitles]

FormDlgTitle =

Example

< DlgTitles >

FormDlgTitle = Document selection

Available

Release | _______
Patch |


FormListTitle

[DlgTitles]
FormListTitle

FormListTitle

Changes the "Available Forms" heading on the Personal Form Selection dialog.

[ DlgTitles]

FormListTitle =

Example

< DlgTitles >

FormListTitle = My Document list

Available

Release | _______
Patch |


InfoTitle

[DlgTitles]
InfoTitle

InfoTitle

Changes the label of the Description field on the Form Selection dialog.

[ DlgTitles]

InfoTitle =

Example

< DlgTitles >

InfoTitle = Billing Code

Available

Release | _______
Patch |


JurisdictnTitle

[DLGTitles]
JurisdictnTitle

JurisdictnTitle

Changes the label of the JURISDICTN field on the Form Selection dialog.

[ DlgTitles]

JurisdictnTitle =

Parameter | Description
Edit | Changes the label of the JURISDICTN field on the Form Selection dialog.

Example

< DlgTitles >

JurisdictnTitle = State

Available

Release | 11.4
Patch |


Key1Title

[DlgTitles]
Key1Title

Key1Title

Changes the default label of the KEY1 field on all dialogs.

[ DlgTitles]

Key1Title =

Parameter | Description
Edit | Changes the default label of the KEY1 field on all dialogs.

Example

< DlgTitles >

Key1Title = Business Region

Available

Release | _______
Patch |


Key1TitleFS

[DlgTitles]
Key1TitleFS

Key1TitleFS

Changes the label of the KEY1 field on the Form Selection dialog.

[ DlgTitles]

Key1TitleFS =

Parameter | Description
Edit | Changes the label of the KEY1 field on the Form Selection dialog.

Example

< DlgTitles >

Key1TitleFS = Business Region

Available

Release | _______
Patch |


Key2Title

[DlgTitles]
Key2Title

Key2Title

Changes the default label of the KEY2 field on all dialogs.

[ DlgTitles]

Key2Title =

Parameter | Description
Edit | Changes the default label of the KEY2 field on all dialogs.

Example

< DlgTitles >

Key2Title = Line of Business

Available

Release | _______
Patch |


Key2TitleFS

[DlgTitles]
Key2TitleFS

Key2TitleFS

Overrides the default label of the KEY2 field on the Form Selection dialog.

[ DlgTitles]

Key2TitleFS =

Parameter | Description
Edit | Overrides the default label of the KEY2 field on the Form Selection dialog.

Example

< DlgTitles >

Key2TitleFS = Line Of Business

Available

Release | _______
Patch |


KeyIDTitle

[DlgTitles]
KeyIDTitle

KeyIDTitle

Changes the default label of the KEYID field on all dialogs.

[ DlgTitles]

KeyIDTitle =

Parameter | Description
Edit | Changes the default label of the KEYID field on all dialogs.

Example

< DlgTitles >

KeyIDTitle = Account #

Available

Release | 10.1
Patch | 207


KeyIDTitleFS

[DlgTitles]
KeyIDTitleFS

KeyIDTitleFS

Changes the label of the KEYID field on the Form Selection dialog.

[ DlgTitles]

KeyIDTitleFS =

Parameter | Description
Edit | Changes the label of the KEYID field on the Form Selection dialog.

Example

< DlgTitles >

KeyIDTitleFS = Account #

Available

Release | _______
Patch |


LocIDTitle

[DlgTitles]
LocIDTitle

LocIDTitle

Changes the label of the LOCID field on the Form Selection dialog.

[ DlgTitles]

LocIDTitle =

Parameter | Description
Edit | Changes the label of the LOCID field on the Form Selection dialog.

Example

< DlgTitles >

LocIDTitle = State

Available

Release | 11.4
Patch |


Personal

[DlgTitles]
Personal

Personal

[ DlgTitles]

Personal =

Parameter | Description
value |

Remarks

This option determines the text appearing on the button for accessing the Personal Formset Selection window in the Processing System.

The Personal Forms List feature is enabled with the following INI option.

[ AFEProcedures ]

Button1 = AFEW32->AFEPersonalEdit

Once activated, this button will appear on the Forms Selection window (just above the forms list). By default the button text will read, "Personal". This can be customized via the following option:

< DLGTitles >

Personal = ~text

The value text can be any text, however the button's size is fixed and will not accommodate long descriptions. Note, unlike menus, the tilde character (~) is optionally used to indicate that the next character is the accelerator for the button.

Example

< DlgTitles >

Personal = My Bills

Available

Release | _______
Patch |


PersonalDlgTitle

[DlgTitles]
PersonalDlgTitle

PersonalDlgTitle

This option overrides the default title of the "Personal Formset Selection" window.

[ DlgTitles]

PersonalDlgTitle = Personal Formset Selection

Parameter | Description
value | This option assigns "Personal Formset Selection" as the title of the Personal Formset Selection window. Default value is: Personal Formset Selection

Example

< DlgTitles >

PersonalDlgTitle = Personal Formset Selection

Available

Release | _______
Patch |


PersonalListTitle

[DlgTitles]
PersonalListTitle

PersonalListTitle

This option overrides the default title "Selected Forms" in the Personal Formset Selection window.

[ DlgTitles]

PersonalListTitle = Selected Forms

Parameter | Description
value | This option assigns the title "Selected Forms:" to the Selected Forms list in the Personal Formset Selection window. Default value is: Selected Forms

Example

< DlgTitles >

PersonalListTitle = Selected Forms:

Available

Release | _______
Patch |


PrintTitle

[DlgTitles]
PrintTitle

PrintTitle

This option overrides the text of the Print checkbox on the Complete dialog.

[ DlgTitles]

PrintTitle =

Parameter | Description
value | This option overrides the text of the Print checkbox on the Complete dialog.

Example

< DlgTitles >

PrintTitle = Print

Available

Release | _______
Patch |


RemoveBtnTitle

[DlgTitles]
RemoveBtnTitle

RemoveBtnTitle

This option overrides the default caption "<- Remove" of the Remove button in the Personal Formset Selection window.

[ DlgTitles]

RemoveBtnTitle =

Parameter | Description
value | The value is the text to display.

Remarks

Note, unlike menus, the tilde character (~) is optionally used to indicate that the next character is the accelerator for the button.

Example

< DlgTitles >

RemoveBtnTitle = <-~Remove

Available

Release | _______
Patch |


RetOptionsDlgTitle

[DlgTitles]
RetOptionsDlgTitle

RetOptionsDlgTitle

This option assigns the title to the Retrieval Options window.

[ DlgTitles]

RetOptionsDlgTitle =

Parameter | Description
value | This option assigns the title to the Retrieval Options window.

Remarks

The Retrieval Options window is displayed by selecting the Options button in the Retrieve Document window.

Example

< DlgTitles >

RetOptionsDlgTitle = Retrieval options

Available

Release | _______
Patch |


RetrieveDlgTitle

[DlgTitles]
RetrieveDlgTitle

RetrieveDlgTitle

The system defaults to the default title included in the MEN.RES file.

[ DlgTitles]

RetrieveDlgTitle =

Parameter | Description
value | The system defaults to the default title included in the MEN.RES file. To change the title of the Retrieve window, use this INI option. If you do not want the window to have a title, leave the right side (TitleToDisplay) blank.

Remarks

To change the title of the Retrieve window, use this INI option. If you do not want the window to have a title, leave the right side (TitleToDisplay) blank.

Example

< DLGTitles >

RetrieveDlgTitle = Retrieve Documents

Available

Release | 10.0
Patch |


RetrOptionsOnlyEntry

[DlgTitles]
RetrOptionsOnlyEntry

RetrOptionsOnlyEntry

This option overrides the default title for the Display forms with variable data only checkbox in the Retrieval Options window.

[ DlgTitles]

RetrOptionsOnlyEntry =

Parameter | Description
value | This option assigns the title for the Display Only Forms With Variable Data checkbox in the Retrieval Options window.

Example

< DlgTitles >

RetrOptionsOnlyEntry = Display only forms with variable data

Available

Release | _______
Patch |


RetrOptionsPrintOnly

[DlgTitles]
RetrOptionsPrintOnly

RetrOptionsPrintOnly

This option overrides the default title for the Include 'print only' forms checkbox in the Retrieval Options window.

[ DlgTitles]

RetrOptionsPrintOnly =

Parameter | Description
value | The value is the text to display.

Example

< DlgTitles >

RetrOptionsPrintOnly = Display 'print only' forms

Available

Release | _______
Patch |


RetrOptionsStackOnly

[DlgTitles]
RetrOptionsStackOnly

RetrOptionsStackOnly

This option overrides the default title for the 'Stack only' mode checkbox in the Retrieval Options window.

[ DlgTitles]

RetrOptionsStackOnly =

Parameter | Description
value | The value is the text to display.

Example

< DlgTitles >

RetrOptionsStackOnly = Only one form per window

Available

Release | _______
Patch |


SortDlgTitle

[DlgTitles]
SortDlgTitle

SortDlgTitle

This option overrides the default title for the WIP Sort order dialog.

[ DlgTitles]

SortDlgTitle =

Parameter | Description
value | This option overrides the default title for the WIP Sort order dialog.

Example

< DlgTitles >

SortDlgTitle = Sorted List

Available

Release | _______
Patch |


StatusDlgTitle

[DlgTitles]
StatusDlgTitle

StatusDlgTitle

This option overrides the title of the Status List dialog.

[ DlgTitles]

StatusDlgTitle =

Parameter | Description
value | This option overrides the title of the Status List dialog.

Example

< DlgTitles >

StatusDlgTitle = Bills by Status

Available

Release | _______
Patch |


StatusListTitle

[DlgTitles]
StatusListTitle

StatusListTitle

This option overrides the column heading on the Status List dialog.

[ DlgTitles]

StatusListTitle =

Parameter | Description
value | This option overrides the column heading on the Status List dialog.

Example

< DlgTitles >

StatusListTitle = Status List

Available

Release | _______
Patch |


SubLocIDTitle

[DlgTitles]
SubLocIDTitle

SubLocIDTitle

Changes the label of the SUBLOCID field on the Form Selection dialog.

[ DlgTitles]

LocIDTitle = State

Parameter | Description
Edit | Changes the label of the SUBLOCID field on the Form Selection dialog.

Example

< DlgTitles >

SubLocIDTitle = State

Available

Release | 11.4
Patch |


TransTitle

[DlgTitles]
TransTitle

TransTitle

Changes the label of the Transaction field on th Form Selection dialog.

[ DlgTitles]

TransTitle = Transaction

Parameter | Description
value | The value is the text to display.

Example

< DlgTitles >

TransTitle = Billing Code

Available

Release | _______
Patch |


TrnNameTitle

[DlgTitles]
TrnNameTitle

TrnNameTitle

Changes the label of the Transaction Name field on th Form Selection dialog.

[ DlgTitles]

TranNameTitle = Transaction Name

Parameter | Description
value | The value is the text to display.

Example

< DlgTitles >

TrnNameTitle = My Trn Name

Available

Release | 11.4
Patch |


UpBtnTitle

[DlgTitles]
UpBtnTitle

UpBtnTitle

This option overrides the default name of the Up button in the Personal Formset Selection window.

[ DlgTitles]

UpBtnTitle = Up

Parameter | Description
value | The value is the text to display. Default value is: Up

Remarks

Note, unlike menus, the tilde character (~) is optionally used to indicate that the next character is the accelerator for the button.

Example

< DlgTitles >

UpBtnTitle = ~Up

Available

Release | _____
Patch |


DLL

Remarks

Use this INI control group to define Dynamic Link Libraries.

If you are linking rules statically, remove or comment out this control group and remove DLL references from DDT files.

Note: Do not use these DLL's for host testing.

Example

< DLL >

DDTW32 = DDTW32

FDTW32 = FDTW32

JDTW32 = JDTW32

DLL Options

  • DDTW32


DDTW32

[DLL]
DDTW32

DDTW32

Use this FSISYS.INI control group to define Dynamic Link Libraries.

[ DLL]

DDTW32 =

Parameter | Description
Edit | Use this FSISYS.INI control group to define Dynamic Link Libraries.

Remarks

Please refer to the Remarks under the DLL control group for detailed information.

Example

< DLL >

DDTW32 = DDTW32

Available

Release | _______
Patch |


DMIA:Documanage_cabinet_name

DMIA:
Documanage_cabinet_name

DMIA:Documanage_cabinet_name Options

  • FileType
  • FolderBy
  • NameDocBy
  • StackedDPA


FileType

[DMIA:Documanage_cabinet_name]
FileType

FileType

1286 New Interfaces for DMILIB

[ DMIA:Documanage_cabinet_name]

FileType =

Remarks

The value of the FileType option is user defineable. It must match the Category name in Documanage server.

Example

< DMIA:Your_documanage_server_archive_cabinet_name >

FileType = DAP

FolderBy = Company, Lob, PolicyNum

NameDocBy = ARCKey

Available

Release | 10.3
Patch |


FolderBy

[DMIA:Documanage_cabinet_name]
FolderBy

FolderBy

1286 New Interfaces for DMILIB

[ DMIA:Documanage_cabinet_name]

FolderBy =

Remarks

The values of the FolderBy option must be the fields and keys defined in the appidx DFD file, and the "Part of the Folder key" flags for these fields in the Documanage Business table must be turned on.

Example

< DMIA:Your_documanage_server_archive_cabinet_name >

FileType = DAP

FolderBy = Company, Lob, PolicyNum

NameDocBy = ARCKey

Available

Release | 10.3
Patch |


NameDocBy

[DMIA:Documanage_cabinet_name]
NameDocBy

NameDocBy

1286 New Interfaces for DMILIB

[ DMIA:Documanage_cabinet_name]

NameDocBy =

Example

< DMIA:Your_documanage_server_archive_cabinet_name >

FileType = DAP

FolderBy = Company, Lob, PolicyNum

NameDocBy = ARCKey

Available

Release | 10.3
Patch |


StackedDPA

[DMIA:Documanage_cabinet_name]
StackedDPA

StackedDPA

You can create a stacked DPA file using the StackedDPA INI option for the DMIA Database Handler to Documanage for archive.

[ DMIA:Documanage_cabinet_name]

StackedDPA = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

If you set this INI option to Yes, all of the transactions from a GenArc batch run are put into one DPA file. The default is No.

As an alternative to direct archiving to Documanage or to a database management system (DBMS), the GenArc program lets you create a single file which contains multiple compressed packages of DAP archive (DPA) documents. Each package is preceded by an XML header. This stacked DPA file consists of multiple DPA files that have been concatenated. You can submit it to a Docusave Server and import it into a Documanage Server. When Docusave Server processes the stacked DPA file, it separates the file into individual DPA files and extracts information from each DPA file's XML header. The information extracted is used when the file is imported into Documanage. From the DPA file's XML header, Documanage extracts the cabinet name, class, subtype, title, date, status, and the column names of the Line-of-Business table. This data usually makes up the indexing information.

You can include other fields in the DPA file's XML header for use as Documanage document level basic properties. The optional fields include Description, UserFlag1, UserFlag2, KeyWord1, and KeyWord2. The XML header information that precedes each individual DPA file is propagated to the XML header from a GenArc program structure that is mapped by the GenArc program’s application index data format definition file (APPIDX.DFD). Thus, for the GenArc program to produce a stacked DPA file that contains the XML header information necessary for use by Docusave and Documanage, you must add several fields to the APPIDX.DFD file. The field names that should be added to the APPIDX.DFD file are framed with three percent signs (%%%) and are case-sensitive, for example: %%%Cabinet%%%.

The fields in the XML header are propagated by the Documaker Rules Processing System. These fields are propagated during the GenTrn process from the extract file to the TRNFILE with the fields defined in the TRNDFDFL.DFD file and mapped from the extract file to the TRNFILE via the TRN_Fields INI control group. Then, during GenData processing, the fields are propagated from the TRNFILE file to the NEWTRN file. Next, during GenArc processing, these fields are propagated from the NEWTRN file to the APPIDX structure via the Trigger2Archive INI control group and into the XML headers. For this to happen, you must include additional information in the extract file, the INI files and the TRNDFDFL.DFD and APPIDX.DFD files. See the TRN_Fields control group and the Trigger2Archive control group for an example of the INI file, TRNDFDFL.DFD and APPIDX.DFD files.

Note: The Documanage Line-of-Business table data and other data must be mapped into the DPA file's XML header instead of being referenced by an external INDEX.CFG file, as is done with other 'stacked' files supported by Docusave.

Example

< DMIA:ARCCAB >

StackedDPA = Yes

Available

Release | 10.3
Patch |

Used By

dmilib


DocSetNames

Remarks

Generally, each DocSetNames option corresponds to a field name in the trnfile.dfd

DocSetNames Options

  • Description
  • FormName
  • FSITemp
  • GroupName1
  • GroupName2
  • GroupName3
  • TransactionId
  • TransactionType


Description

[DocSetNames]
Description

Description

[ DocSetNames]

Description =

Example

< DocSetNames >

Description =

Available

Release | _______
Patch |


FormName

[DocSetNames]
FormName

FormName

FormName option must be present.

[ DocSetNames]

FormName =

This option may be required in order for the feature to function.

Remarks

Either code as Null or enter the Form set definition file (form.dat, .BDF, .GRP, or .FOR) external form name.

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, genprint, GENTRN, GENWIP


FSITemp

[DocSetNames]
FSITemp

FSITemp

[ DocSetNames]

FSITemp =

Example

< DocSetNames >

FSITemp = Temp

Available

Release | _______
Patch |


GroupName1

[DocSetNames]
GroupName1

GroupName1

GroupName1 field is mandatory. Refers to the first key field in the Form set definition file (form.dat, .BDF, .GRP, or .FOR).

[ DocSetNames]

GroupName1 =

This option may be required in order for the feature to function.

Remarks

Does not accept Null. For insurance market, usually is the Company Code.

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


GroupName2

[DocSetNames]
GroupName2

GroupName2

GroupName2 field is mandatory. Refers to the second key field in the Form set definition file (form.dat, .BDF, .GRP, or .FOR).

[ DocSetNames]

GroupName2 =

This option may be required in order for the feature to function.

Remarks

Does not accept Null. For insurance market is usually Line of Business (LOB).

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


GroupName3

[DocSetNames]
GroupName3

GroupName3

GroupName3 field is mandatory. Refers to the third key field in the Form set definition file (form.dat, .BDF, .GRP, or .FOR).

[ DocSetNames]

GroupName3 =

This option may be required in order for the feature to function.

Remarks

For insurance market usually for state code, can be set to null.

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


TransactionId

[DocSetNames]
TransactionId

TransactionId

For insurance market, usually Policy Number. Can be set to Null.

[ DocSetNames]

TransactionId =

This option may be required in order for the feature to function.

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


TransactionType

[DocSetNames]
TransactionType

TransactionType

For insurance market, usually business transaction type. Can be set to Null

[ DocSetNames]

TransactionType =

This option may be required in order for the feature to function.

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


Email

Email Options

  • FileAttachment


FileAttachment

[Email]
FileAttachment

FileAttachment

[ Email]

FileAttachment =

Parameter | Description
value | value

Available

Release | _______
Patch |


EntryOptions

Remarks

SaveWIPResponse

EntryOptions Options

  • SaveWIPResponse


SaveWIPResponse

[EntryOptions]
SaveWIPResponse

SaveWIPResponse

[ EntryOptions]

SaveWIPResponse = No

Parameter | Description
Boolean (No) | Lets you suppress a message asking if you want to save data when you close an edited form set and lets you specify the default answer to the question. Default value is: No

Remarks

Lets you suppress a message asking if you want to save data when you close an edited form set and lets you specify the default answer to the question.

Yes (or True) Saves the data when you close the form set you are editing but does not display the Do You Wish to Save window.

No (or False) (Default) Does not save the form set and does not display the Do You Wish to Save window.

Leave blank Does not save the form set but does display the Do You Wish to Save window.

The system assumes any entry that begins with Y or T, in either upper- or lowercase, to equal Yes and any entry that begins with N or F, in upper- or lowercase, to equal No.

Example

< EntryOptions >

SaveWIPResponse = Yes

Available

Release | 10.1
Patch |


Environment

Remarks

The FSIUSER.INI ENVIRONMENT control group defines the Processing System logon procedure, the company library, and the name and location of the system INI file (FSISYS.INI). The Environment control group references the <SignOn> control group to configure logon procedures.

Example

< Environment >

CompanyLibName = SAMPCO

DO_LOGON = YES

MaxLogonAttempts = 4

FSISYSINI = ..\FSISYS.INI

FSITEMP = TEMP

Environment Options

  • CompanyLibName
  • DO_LOGON
  • FontName
  • FSISYSINI
  • FSITEMP
  • MaxLogonAttempts


CompanyLibName

[Environment]
CompanyLibName

CompanyLibName

CompanyLibName is the subdirectory name of the company resource library.

[ Environment]

CompanyLibName =

Parameter | Description
value | subdirectory name

Remarks

The system's Selective Import feature uses this line to search for the company library.

Example

< Environment >

CompanyLibName = SAMPCO

Available

Release | _______
Patch |

Used By

AFEMAIN


DO_LOGON

[Environment]
DO_LOGON

DO_LOGON

DO_LOGON controls the appearance of the Logon window.

[ Environment]

DO_LOGON = YN

Parameter | Description
Boolean | value

Remarks

This option is used in conjunction with the SignOn control group. If DO_LOGON = Yes, the Logon window appears at the beginning of every Entry session. To assign each user a user ID, a UserID value must be entered in the SignOn control group. For example:

< SignOn >

UserID = USER1

The Processing System does not function properly if DO_LOGON = NO and there is a value entered for UserID in the SignOn control goup. The following INI settings are recommended:

Option

Assign each user a password and make them log in every time they run the system

INI Settings

<Environment>

Do_Logon = Yes

Result

The logon window appers at the beginning of every Entry session

Please Note:

Set up user IDs and passwords using the Tools, User ID Maintenance menu option

Option

Assign each user a password and automatically log them in every time they run the system

INI Settings

<Environment>

Do_Logon = Yes

<SignOn>

UserID = USER1

Result

The user is automatically logged onto the Entry System. The logon window does not appear.

Please Note:

Set up user IDs and passwords using the Tools, User ID Maintenance menu option. Each user should have their

own FSIUSER.INI file with their own user ID.

Example

< Environment >

Do_Logon = value

Available

Release | 10.1
Patch |

Used By

GENARC, GENDATA, GENPRINT, GENTRN


FontName

[Environment]
FontName

FontName

Add fonts to the AFP output file for text label records which may be added during the merge process in the bill printing utility

[ Environment]

FontName = File

Parameter | Description
Font Name | Name of the font you want added

Remarks

The system will include the specified fonts in the output file, regardless of whether they are present in the input files.

Example

< Added_Fonts >

FontName = XOFATINO

FontName = XOFAUNN8

Available

Release | _______
Patch |

Used By

AFPLIB


FSISYSINI

[Environment]
FSISYSINI

FSISYSINI

Name of a FSISYS INI file.

[ Environment]

FSISYSINI =

Parameter | Description
value | Path and Name of a FSISYS INI file

Remarks

Typically, the FSISYSINI option is specified in the FSIUSER.INI file and it indicates the name of a FSISYS.INI file to read.

The FSISYSINI option defines the file name and directory path of the system INI file (FSISYS.INI). When the Entry system is started, it loads the FSIUSER.INI file in the current subdirectory and then searches the Environment control group for a value in the FSISYSINI option. If the value of FSISYSINI = FSISYS.INI, the system will look in the current directory for a file with that name. Any name may be given to the FSISYS.INI and it does not have to

be in the current directory as long as the directory path is specified.

Example

< Environment >

FSISYSINI = ..\FSISYS.INI

Available

Release | _______
Patch |


FSITEMP

[Environment]
FSITEMP

FSITEMP

The FSISYSINI option defines the file name and directory path of the system INI file (FSISYS.INI).

[ Environment]

FSITEMP = TEMP

Parameter | Description
Path | Default value is: TEMP

Example

< Environment >

FSITEMP = TEMP

Available

Release | _______
Patch |


MaxLogonAttempts

[Environment]
MaxLogonAttempts

MaxLogonAttempts

MaxLogonAttempts controls the maximum number of user logon attempts before the system locks out the user.

[ Environment]

MaxLogonAttempts = Spin

Parameter | Description
value | number of user logon attempts (default is 3)

Remarks

If the INI option is undefined, the system defaults to 3 attempts; otherwise:

0 = 1 attempt; 1 = 1 attempt; 2 = 2 attempts

The maximum value of n (number of attempts) is 4 billion. If the User ID is incorrectly defined in the INI file, the User Logon window automatically appears.

Example

< Environment >

MaxLogonAttempts = 4

Available

Release | _______
Patch |

Used By

AFEMAIN


Error

Remarks

Printer

Error Options

  • Printer


Printer

[Error]
Printer

Printer

Use this FSISYS.INI control group to include transaction errors in the print batches.

[ Error]

Printer =

Parameter | Description
Printer5 |

Remarks

GENPRINT uses the ERROR control group to find out where to send the print created for that recipient batch file. In the sample entry above, the print will be sent to Printer5.

Example

< Error >

Printer = Printer5

Printer = Error_PTR

Available

Release | _______
Patch |


Error2Manual

Remarks

10513

Error2Manual Options

  • 10513


10513

[Error2Manual]
10513

10513

Use this INI option to identify the field errors which cause a transaction to be sent to the manual batch.

[ Error2Manual]

10513 =

Remarks

< Error2Manual >

(CurrentError) = (NextError1),..,(NextErrorN),(M)

Option Description

CurrentError The error that just occurred.

NextError1 The error caused by the CurrentError failure. This continues through the

list of errors until the last one.

M This tells the system to send the transaction to the manual batch.

Add this rule to the section in the AFGJOB.JDT file:

;ErrorHandler;;;

If field error DM10513 occurs, then it will cause errors, DM12051, DM12048, DM1283, and DM12074. This function will send these transactions to the manual batch for userentry, continue processing, and create a blank field in the NAFILE.DAT file.

Example

< Error2Manual >

10513 = 12051, 12048, 12083, 12074

< GenDataStopOn >

FieldErrors = No

Available

Release | 10.1
Patch |


ExpFile_CD

ExpFile_CDExpFile_CD

Remarks

The FSIUSER.INI ExpFile_cd control group lets you designate the default directory where the Processing System stores export data and it lets you configure the export feature so it works the way you need it to work. Export data can be used in other agency applications. The absence of this control group or its settings causes the system to default to the working directory as specified in the icon setting.

Example

< ExpFile_cd >

AppendedExport = Yes/No

File = file name

Ext = .OUT

Overwrite = Yes/No

Path = MSTRRES\(resource library name)

SuppressDlg = Yes/No

ExpFile_CD Options

  • AllowDuplicateField
  • AppendedExport
  • Ext
  • File
  • OutputFieldScope
  • Overwrite
  • Path
  • SuppressDlg


AllowDuplicateField

AllowDuplicateField[ExpFile_CD]
AllowDuplicateField

AllowDuplicateField

[ ExpFile_CD]

AllowDuplicateField = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Feature 1522 lets you prevent the duplication of fields with global and form scope during a standard export. The occurrences are limited based on the scope of the field. For instance, a field with global scope will only appear once in your export file. A field with form scope will appear once for every form that has the scope of this field as form.

This option defaults to Yes.

For this feature to work, you must also set the OutputFieldScope option to Yes. To summarize, if...

* The OutputFieldScope option is set to Yes

* The AllowDuplicateField option is set to No

* The form set has fields with both global and form scope, such as a policy number field, then during a standard export the number of times a field such as a policy number appears is based on the scope.

Example

< ExpFile_CD >

AllowDuplicateField = No

Available

Release | 11.0
Patch |

Used By

TRNLIB


AppendedExport

AppendedExport[ExpFile_CD]
AppendedExport

AppendedExport

This option lets the user append the current form set data to an existing export file.

[ ExpFile_CD]

AppendedExport = Edit

Parameter | Description
Boolean (No) | Yes or No (default)

Remarks

If you set this option to Yes and the export file exists, the system does not display the Confirm Overwrite message to the user. The system simply appends the current form set data to the existing file. If the file name you specified does not exist, the system creates a new file using that name.

The default value for this option is No.

Example

< ExpFile_CD >

AppendedExport = Yes

Available

Release | 10.1
Patch |

Used By

AFEMAIN


Ext

Ext[ExpFile_CD]
Ext

Ext

The default for this option is .OUT.

[ ExpFile_CD]

Ext = .OUT

Parameter | Description
value | export file extenstion (default is .OUT) Default value is: .OUT

Remarks

To use another extension, simply specify it using this option. If the File=option is used and the filename contains an extension, that extension will override this option.

The Ext option defines the export file extension. The default is .OUT. You may substitute a valid file extension but be sure to include the period. On the File window, the user can use the List of Files field to display only those files with the export file extension. If you use the File= option and the file name you entered there includes an extension, that extension overrides one entered here.

Example

< ExpFile_CD >

Ext = .ext

Available

Release | 10.1
Patch |

Used By

AFEMAIN


File

File[ExpFile_CD]
File

File

There is no default for this option and without it, the user must specify a filename for export.

[ ExpFile_CD]

File =

Parameter | Description
value | file name

Remarks

If this option is assigned a valid filename then, the File dialog for selecting the export filename will default to this value. Optionally, the File dialog can be suppressed if a valid filename is specified.

This option determines the default file users see in the File window when selecting the export

file. Enter a valid file name of up to eight characters with a three-character extension. There

is no default for this option.

Example

< ExpFile_CD >

File = filename

Available

Release | 10.1
Patch |

Used By

AFEMAIN


OutputFieldScope

OutputFieldScope[ExpFile_CD]
OutputFieldScope

OutputFieldScope

1337 Listing Global Fields

[ ExpFile_CD]

OutputFieldScope =

Parameter | Description
value | 1337 Listing Global Fields

Remarks

You can use the OutputFieldScope option to list the global scope fields near the beginning of the export file:

< ExpFile_CD >

OutputFieldScope = Yes

Keep in mind this option only applies to standard V2 imports and that the system only lists the fields once per form set.

Example

< ExpFile_CD >

OutputFieldScope = Yes

Available

Release | 10.2
Patch | 1


Overwrite

Overwrite[ExpFile_CD]
Overwrite

Overwrite

This option controls the Confirm Overwrite message when a user chooses an existing file as the export file.

[ ExpFile_CD]

Overwrite =

Parameter | Description
value | Yes or No (default is No)

Remarks

Enter Yes to turn off the message. The default is No. The system ignores this option is the AppendedExport option is set to Yes. Appending to an export file implicitly means the export file will not be overwritten.

Example

< ExpFile_CD >

Overwrite = Yes

Available

Release | _______
Patch |

Used By

AFEMAIN


Path

Path[ExpFile_CD]
Path

Path

Path specifies the drive and directory path to store export files created by the Processing System.

[ ExpFile_CD]

Path =

Parameter | Description
value | drive and directory path

Remarks

There is no default for this option. Specifying the export directory lets you map where your export files are located. If you omit this option, the system looks for your export files in the working directory specified during system setup.

The system uses the path you enter here to determine the default directory displayed in the File window. If you use the File= option and the file name specified there includes a path, that path overrides one entered here.

Example

< ExpFile_CD >

Path = MSTRRES\(resource library name)

Available

Release | _______
Patch |

Used By

AFEMAIN


SuppressDlg

SuppressDlg[ExpFile_CD]
SuppressDlg

SuppressDlg

This option, if set to Yes, suppresses the Export File Selection window. The default for this option is No.

[ ExpFile_CD]

SuppressDlg = No

Parameter | Description
Boolean (No) | Yes or No (default is No) Default value is: No

Remarks

If the File= option was not defined, or if it was defined improperly, the window appears regardless of what you enter here.

The File Selection window is also affected by the AppendedExport= option and the Overwrite= option. If you set either of these options to yes, SuppressDlg=Yes tells the system not to display the File Selection window. If you set those options to no, the File Selection window appears unless the export file does not exist. This prevents the user from accidentally overwriting a valid export file without confirmation.

Example

< ExpFile_CD >

SuppressDlg = Yes

Available

Release | 10.1
Patch |

Used By

AFEMAIN


ExportFormats

01

1399 TRANSFORMING XML FILES

[ ExportFormats]

01 = Edit; Edit; Edit

Parameter | Description
value | Code
Edit | Description
Edit | Function

Remarks

User defined value that determines the sort order for the Export funcions declared within this group.

Now you can export an XML file with XSLT transformation. This lets you transform the output XML file into another format, such as HTML or text. The final output format is determined by the XSLT template you choose.

To enable this export add the following INI option to the ExportFormats control group:

< ExportFormats >

01=;MX;Export with XSL;WXMW32->WXMExportWithXSL

and then add these options to support the new option above:

< ExportWithXSL:MX >

XSLTName =

Executable =

Debug =

< ExportWithXSL >

XSLTName =

Executable =

Debug =

You can append multiple XSLT output transformations to the same file using this INI option:

< ExpFile_cd >

AppendedExport = Yes

NOTE: The default control group used by the WXMExportWithXSL rule is the ExportWithXSL control group. If you specify another control group in your Documaker Workstation selection, such as ExportWithXSL:M1, and it is either not found in the INI file or one of the expected options for that group is missing, the system tries to read the default value from the ExportWithXSL control group.

Example

< ExportFormats >

01 =

Available

Release | 10.2
Patch | 93


01

[ExportFormats]
01

01

1399 TRANSFORMING XML FILES

[ ExportFormats]

01 = Edit; Edit; Edit

Parameter | Description
value | Code
Edit | Description
Edit | Function

Remarks

User defined value that determines the sort order for the Export funcions declared within this group.

Now you can export an XML file with XSLT transformation. This lets you transform the output XML file into another format, such as HTML or text. The final output format is determined by the XSLT template you choose.

To enable this export add the following INI option to the ExportFormats control group:

< ExportFormats >

01=;MX;Export with XSL;WXMW32->WXMExportWithXSL

and then add these options to support the new option above:

< ExportWithXSL:MX >

XSLTName =

Executable =

Debug =

< ExportWithXSL >

XSLTName =

Executable =

Debug =

You can append multiple XSLT output transformations to the same file using this INI option:

< ExpFile_cd >

AppendedExport = Yes

NOTE: The default control group used by the WXMExportWithXSL rule is the ExportWithXSL control group. If you specify another control group in your Documaker Workstation selection, such as ExportWithXSL:M1, and it is either not found in the INI file or one of the expected options for that group is missing, the system tries to read the default value from the ExportWithXSL control group.

Example

< ExportFormats >

01 =

Available

Release | 10.2
Patch | 93


02

[ExportFormats]
02

02

User defined value that determines the sort order for the Export funcions declared within this group.

[ ExportFormats]

02 = Edit

Parameter | Description
value | User defined value that determines the sort order for the Export funcions declared within this group.

Example

< ExportFormats >

02 =

Available

Release | _______
Patch |


03

[ExportFormats]
03

03

User defined value that determines the sort order for the Export funcions declared within this group.

[ ExportFormats]

03 = Edit

Parameter | Description
value | User defined value that determines the sort order for the Export funcions declared within this group.

Example

< ExportFormats >

03 =

Available

Release | _______
Patch |


99

[ExportFormats]
99

99

1211 USING THE MULTI-EXPORT FEATURE This feature lets you identify a list of export functions you want the system to execute.

[ ExportFormats]

99 = Edit

Parameter | Description
value | This feature lets you identify a list of export functions you want the system to execute. You can use this capability for a variety of purposes.

Remarks

For instance, you can create a backup copy of an exported file in a second directory or you can run multiple exports using different export methods.

To install this feature, add the following INI option:

< ExportFormats >

99 =;ME;Multi-Export;TRNW32->TRNMultiExport;

If you have other export functions listed under this control group and you want to remove those functions, insert a semicolon as the first character on the line to comment out that line. You can also delete the line from the INI file.

Keep in mind:

* The INI file is sorted when loaded. This lets you control which option appears first, second, third, and so on. For instance, you can use numbers as the option indicator left of the equal sign (01 =, 02 =, and so on) to set the order of the options.

* The semicolons identify and separate each portion of the definition.

* ME is a token that represents this export method. You can change the text, but make sure it is unique.

* The text Multi-Export appears in the Export area on the Complete Form Set window. You can enter any description you want, but space is limited in the export list display area. Make sure the text you enter fits.

* The final portion of the definition

TRNW32->TRNMultiExport

must be copied exactly as shown. This identifies the DLL to load and the function that performs this feature. This information is case sensitive.

Example

< ExportFormats >

99 =;ME;Multi-Export;TRNW32->TRNMultiExport;

Available

Release | 10.1
Patch | 313


ExportWithXSL

Remarks

XSLTName

ExportWithXSL Options

  • Debug
  • Executable
  • XSLTName


Debug

[ExportWithXSL]
Debug

Debug

1399 Transforming XML Files

[ ExportWithXSL]

Debug = Path

Parameter | Description
Path |

Remarks

Enter the full or relative path and name of the XSL style sheet.

The default control group used by the WXMExportWithXSL rule is the ExportWithXSL control group. If you specify another control group in your Documaker Workstation selection, such as ExportWithXSL:M1, and it is either not found in the INI file or

one of the expected options for that group is missing, the system tries to read the default value from the ExportWithXSL control group.

Here is an example. This example transforms an XML export into a semicolon-delimited output file you can import into Excel. It also uses the in-process executable XSLTW32.EXE for the transformation.

First, you need these INI options:

< ExportWithXSL >

XSLTName = x:\rp\mstrres\taeic\xsl\output1.xsl

Debug = no

Example

< ExportWithXSL >

Debug = no

Available

Release | 10.2
Patch | 93


Executable

[ExportWithXSL]
Executable

Executable

1399 Transforming XML Files

[ ExportWithXSL]

Executable = Path

Parameter | Description
Path |

Remarks

Enter the full path and name of the XSLTW32.EXE program. If you omit this option, the program will use the entry for the Executable option in the ExportWithXSL control group. If that option is missing, the program will query the full path of the XSLTW32.EXE program.

Example

< ExportWithXSL >

Executable =

Available

Release | 10.2
Patch | 93


XSLTName

[ExportWithXSL]
XSLTName

XSLTName

1399 Transforming XML Files

[ ExportWithXSL]

XSLTName = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Enter Yes to send debug output to the trace file.

The default control group used by the WXMExportWithXSL rule is the ExportWithXSL control group. If you specify another control group in your Documaker Workstation selection, such as ExportWithXSL:M1, and it is either not found in the INI file or

one of the expected options for that group is missing, the system tries to read the default value from the ExportWithXSL control group.

Here is an example. This example transforms an XML export into a semicolon-delimited output file you can import into Excel. It also uses the in-process executable XSLTW32.EXE for the transformation.

First, you need these INI options:

< ExportWithXSL:M1 >

XSLTName = x:\rp\mstrres\taeic\xsl\output1.xsl

Debug = no

Example

< ExportWithXSL >

XSLTName =

Available

Release | 10.2
Patch | 93


ExtractFile

ExtractFile Options

  • BinaryExt


BinaryExt

[ExtractFile]
BinaryExt

BinaryExt

[ ExtractFile]

BinaryExt =

Parameter | Description
value | value

Available

Release | _______
Patch |


ExtractKeyField

Remarks

Use this FSISYS.INI control group to define the key field in the extract records. The Documaker Rules Processing System uses this information to determine when to stop reading extract records into memory.

Note: For MVS, OS/390 - this is not required for the PDAM method.

Note

Question: I thought that the search mask was the first qualifier to retrieve a record in the extract file. Then the key would be used to determine how many associated records to read in when you run Gendata. But is seems that gentran reads a record, finds the key, extracts the transaction data = tranfile and then reads until the key changes then repeats the process. There doesn't seem to be any delimiting/selection value to the search mask for gentran. Can you clarify this for me?

Answer: The Key option was designed to replace SearchMask. If Key is not suitable for your extrfile, then use SearchMask. If you mix both Key and SearchMask, each of them has same effect. It is not a first qualifier and a second qualifier. They are equal.

Example

< ExtractKeyField >

Key = 4,7

SearchMask = 11,HEADERREC

ExtractKeyField Options

  • SearchMask


SearchMask

[ExtractKeyField]
SearchMask

SearchMask

Use this FSISYS.INI control group to define the key field in the extract records.

[ ExtractKeyField]

SearchMask = Edit

Parameter | Description
value | ***SearchMask = Offset,SearchCriteria,Offset,SearchCriteria Offset,SearchCriteria is the standard GetRecord format. This option is used by both the GenTrn and GenData programs.

This option may be required in order for the feature to function.

Remarks

***SearchMask = Offset,SearchCriteria,Offset,SearchCriteria

Offset,SearchCriteria is the standard GetRecord format. This option is used by both the GenTrn and GenData programs.

This is used only by the GenData program before version 9.0. Beginning with version 9.0, this information is used by both the GenData and GenTrn programs. You no longer need to define the key in the Trn_Fields control group and the system supports multiple keys.

The Documaker Rules Processing System uses this information to determine when to stop reading extract records into memory.

NOTE: This is not required for the PDAM method.

Example

<ExtractKeyField>

SearchMask = 11,HEADERREC

Available

Release | _______
Patch |

Used By

GENDATA, GENTRN


Fix_Batches

Remarks

Batch1

Fix_Batches Options

  • Batch1
  • ERROR


Batch1

[Fix_Batches]
Batch1

Batch1

[ Fix_Batches]

Batch1 = File

Parameter | Description
File |

Example

<Print_Batches>

BATCH1 = BATCH.BCH

ERROR = ERROR.BCH

Available

Release | 10.0
Patch |


ERROR

[Fix_Batches]
ERROR

ERROR

[ Fix_Batches]

ERROR = File

Parameter | Description
File |

Example

<Print_Batches>

BATCH1 = BATCH.BCH

ERROR = ERROR.BCH

Available

Release | 10.0
Patch |


FixOffsets

FixOffsets Options

  • NewTrn
  • Outpath


NewTrn

[FixOffsets]
NewTrn

NewTrn

Name of the new NEWTRN file. Defaults to FXNEWTRN.DAT. If you omit the path, the utility, defaults to the OUTPATH option.

[ FixOffsets]

NewTrn = FXNEWTRN.DAT

Parameter | Description
Path | Name of the new NEWTRN file. Defaults to FXNEWTRN.DAT. If you omit the path, the utility, defaults to the OUTPATH option. Default value is: FXNEWTRN.DAT

Example

< FixOffsets >

NewTrn = FXNEWTRN.DAT

Available

Release | 10.0
Patch |


Outpath

[FixOffsets]
Outpath

Outpath

The path for the output files the utility creates. Defaults to the path you set in the DATAPATH option.

[ FixOffsets]

Outpath = Path

Parameter | Description
Path | The path for the output files the utility creates. Defaults to the path you set in the DATAPATH option.

Example

< FixOffsets >

Outpath =

Available

Release | 10.0
Patch |


FixOptions

Remarks

ChkRect

FixOptions Options

  • ChkRect
  • ColorDef
  • ColorPrint
  • CombText
  • DeleteFields
  • FieldCase
  • FixCalcs
  • FixDALCheck
  • FixDALSyntax
  • FixLeftMargin
  • FixNegative
  • FixRect
  • FixRectSaveBottom
  • FixTopMargin
  • FromFDB
  • ImageCase
  • LeftMargin
  • MapChars
  • MapFonts
  • NegativeBase
  • NoFixImageDims
  • Rotate90
  • TopMargin
  • UniqueFieldNames
  • UpdateDDT
  • UseXDBRule
  • YearDigit4


ChkRect

[FixOptions]
ChkRect

ChkRect

[ FixOptions]

ChkRect = YN

Parameter | Description
Boolean |

Remarks

Use this FAPCOMP.INI control group to set default values on option tabs in the Convert Multiple FAPs window of the DAP Development System.

This option sets the default value for the Combine Overlapping Text Labels field of the Other tab in the Convert Multiple FAPS window. Occasionally, conversions from print streams produce text labels which overlap. Check the Combine Overlapping Text Labels field to have the system correct these kinds of problems.

Example

< FixOptions >

ChkRect = No

Available

Release | _______
Patch |


ColorDef

[FixOptions]
ColorDef

ColorDef

[ FixOptions]

ColorDef = YN

Parameter | Description
Boolean |

Remarks

The ColorDef group option sets the default value for the Return To Default Colors field of the Other tab on the Convert Multiple FAPS window. Check the Return to Default Colors field to reset all colors on the selected images to the default colors.

Example

< FixOptions >

ColorDef = No

Available

Release | _______
Patch |


ColorPrint

[FixOptions]
ColorPrint

ColorPrint

This option sets the default value for the Print In Color checkbox on the Other tab of the Convert Multiple FAPS window.

[ FixOptions]

ColorPrint = YN

Parameter | Description
Boolean |

Remarks

Check the Print in Color field if you want the system to make all colors printable for the images you selected. This option, in effect, checks the Print in Color field on each object's Color Selection window.

Example

< FixOptions >

ColorPrt = No

Available

Release | _______
Patch |


CombText

[FixOptions]
CombText

CombText

[ FixOptions]

CombText = YN

Parameter | Description
Boolean |

Remarks

The CombText option sets the default value for the Combine Adjacent Text Labels field of the Other tab in the Convert Multiple FAPS window. Check the Combine Adjacent Text Labels field to combine text labels that are very close into one label. The system will combine text labels if the text labels use the same font and have the same baseline.

If the text areas are located closer than half the width of a space character, the system joins the labels without a space. If the labels are more than half the width of a space character apart, but less than the width of a space character, the system joins the labels with a space between them. If the labels are located more than a space apart, the system does not combine them.

NOTE: You can use the Image Editor's Format, Convert to text label or Convert to text area options to combine text areas and labels you select on a specific image. The File, Convert, Multiple FAPs option is more often used when print files are converted to FAP files and each character is turned into a separate label.

Example

< FixOptions >

CombText = No

Available

Release | _______
Patch |


DeleteFields

[FixOptions]
DeleteFields

DeleteFields

DeleteFields sets the default value for the Delete Fields checkbox on the Fields tab.

[ FixOptions]

DeleteFields = YN

Parameter | Description
Boolean |

Remarks

To delete fields, check the Delete Fields field if you want the system to delete all variable fields from the images you selected. The system does not delete the fields from the Field Database. You can use this option to turn an image into a template which you can reuse or as another way of creating overlays.

Example

< FixOptions >

DeleteFields = No

Available

Release | _______
Patch |


FieldCase

[FixOptions]
FieldCase

FieldCase

The FieldCase option sets the default value for the Match Case checkbox on the Fields tab.

[ FixOptions]

FieldCase = YN

Parameter | Description
Boolean |

Remarks

Check the Match Case field if you want the system to consider upper- and lowercase letters when it searches for the field names to change.

This feature's INI value and default setting is:

< FixOptions >

FieldCase = No

To change field names, enter the current name of the field in the Old Name field and the name you wish to change to in the New Name field. You can use the Import button to import a semicolon delimited file with these names. If you import a file, make sure the field names are listed as shown below, with the new name last:

;PLCY#;POLICY_NUM;

;FIELD;LAST_NAME;

Example

< FixOptions >

FieldCase = No

Available

Release | _______
Patch |


FixCalcs

[FixOptions]
FixCalcs

FixCalcs

FixCalcs sets the default value for the Change DAL calcs to DAL scripts checkbox on the Fields tab.

[ FixOptions]

FixCalcs = YN

Parameter | Description
Boolean |

Remarks

To change DAL calculations into DAL scripts, check the Change DAL Calcs to DAL Scripts field.

Example

< FixOptions >

FixCalcs = No

Available

Release | _______
Patch |


FixDALCheck

[FixOptions]
FixDALCheck

FixDALCheck

Feature 1371 Enter Yes to have the utility check field DAL script syntax. The default is No.

[ FixOptions]

FixDALCheck = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< FixOptions >

FixDALCheck = No

Available

Release | 10.2
Patch | 39


FixDALSyntax

[FixOptions]
FixDALSyntax

FixDALSyntax

Feature 1371 Enter Yes to have the utility check DAL script syntax and attempt to correct errors. The default is No.

[ FixOptions]

FixDALSyntax = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< FixOptions >

FixDALSyntax = No

Available

Release | 10.2
Patch | 39


FixLeftMargin

[FixOptions]
FixLeftMargin

FixLeftMargin

This option determines the default value of the Adjust X Coordinates field of the Images tab.

[ FixOptions]

FixLeftMargin = YN

Parameter | Description
Boolean |

Remarks

To adjust X coordinates, enter the appropriate value in FAP units into the Adjust X Coordinates field. One inch is equivalent to 2400 FAP units. For instance, to adjust by 1.5 inches, you would enter 3600 in this field.

Example

< FixOptions >

FixLeftMargin = No

LeftMargin = 600

Available

Release | _______
Patch |


FixNegative

[FixOptions]
FixNegative

FixNegative

This option determines whether the Fix Negative Coordinates field on the Images tab is checked by default (No).

[ FixOptions]

FixNegative = YN

Parameter | Description
Boolean |

Remarks

Negative coordinates are not produced by the system, but some users have encountered them with conversions into DAP software from print streams.

Example

< FixOptions >

FixNegative = No

NegativeBase = 4800

Available

Release | _______
Patch |


FixRect

[FixOptions]
FixRect

FixRect

The FixRect option recalculates font coordinates when converting FAP files.

[ FixOptions]

FixRect = YN

Parameter | Description
Boolean |

Remarks

If FixRect = Yes, the Retain Top Adjust Bottom Coordinates checkbox on the Fonts tab of the Convert Multiple

Faps window will be selected by default. Converted fonts will retain their top coordinates and the bottom coordinates will be adjusted. Typically, you would want to adjust the font's top coordinates and keep the bottom coordinates so that the text would retain its current baselines.

The Retain Top and Bottom Coordinates checkbox will be selected by default and converted fonts will retain top and bottom coordinates.

Example

< FixOptions >

FixRect = No

Available

Release | _______
Patch |


FixRectSaveBottom

[FixOptions]
FixRectSaveBottom

FixRectSaveBottom

This option sets the default values for the Calculate Coordinates section of the Fonts tab.

[ FixOptions]

FixRectSaveBottom = YN

Parameter | Description
Boolean |

Remarks

To have the system recalculate font coordinates, click the appropriate option. Typically, you would use the Retain Bottom, Adjust Top Coordinates option so the text would retain its current baselines. Click Retain Top, Adjust Bottom Coordinates if you want to keep the top coordinates.

Click Retain Top and Bottom Coordinates if you do not want the system to recalculate font coordinates.

Example

< FixOptions >

FixRectSaveBottom = No

FixRect = No

Available

Release | _______
Patch |


FixTopMargin

[FixOptions]
FixTopMargin

FixTopMargin

This option determines the default value of the Adjust Y Coordinates field of the Images tab.

[ FixOptions]

FixTopMargin = YN

Parameter | Description
Boolean |

Remarks

To adjust Y coordinates, enter the appropriate value in FAP units into the Adjust Y Coordinates field. FAP units are 2400 units per inch. For instance, to adjust by 1.5 inches, you would enter 3600 in this field.

Example

< FixOptions >

LeftMargin = No

TopMargin = 400

Available

Release | _______
Patch |


FromFDB

[FixOptions]
FromFDB

FromFDB

This option sets the default value for the Update Fields from Database checkbox on the Fields tab.

[ FixOptions]

FromFDB = YN

Parameter | Description
Boolean |

Remarks

To update fields from the Field Database, check the Update Fields from Database field. The system retrieves all of the information stored in the field database except for the font ID.

Example

< FixOptions >

FromFDB = No

Available

Release | _______
Patch |


ImageCase

[FixOptions]
ImageCase

ImageCase

[ FixOptions]

ImageCase = YN

Parameter | Description
Boolean |

Remarks

The ImageCase option determines whether the system matches case when searching for FAP files to change in the Change Name field of the Convert Multiple FAPS window. Check the Match Case field if you want the system to consider upper- and lowercase letters when it searches for the FAP files to change.

To change the names of FAP files enter the current name of the FAP file in the Old Name field and the name you want to change to in the New Name field. You can use the IMPORT button to import a semicolon delimited file with these names. If you import a file, make sure the image names are listed as shown below, with the new name last:

;IMG001;IMGABC;

;IMG002;NEW002;

Example

< FixOptions >

ImageCase = No

Available

Release | _______
Patch |


LeftMargin

[FixOptions]
LeftMargin

LeftMargin

The LeftMargin option sets the default value for the image's left margin in FAP units.

[ FixOptions]

LeftMargin = Edit

Parameter | Description
Edit |

Example

< FixOptions >

LeftMargin = 600

Available

Release | _______
Patch |


MapChars

[FixOptions]
MapChars

MapChars

[ FixOptions]

MapChars = YN

Parameter | Description
Boolean |

Remarks

This option determines the default value for the Map Alternate Characters field of the Other tab in the Convert Multiple Faps window.

Example

< FixOptions >

MapChars = No

Available

Release | _______
Patch |


MapFonts

[FixOptions]
MapFonts

MapFonts

[ FixOptions]

MapFonts = YN

Parameter | Description
Boolean |

Remarks

This option determines the default value of the Make Font Changes checkbox on the Fonts tab of the Convert Multiple Faps window.

To change font Ids, enter the current ID of the font in the Old ID field and the ID you wish to change to in the New ID field. You can use the IMPORT button to import a semicolon delimited file with these IDs. If you import a file, make sure the IDs are listed as shown below, with the new font ID last:

;6010;11010;

;6110;11110;

Example

< FixOptions >

MapFonts = Yes

Available

Release | _______
Patch |


NegativeBase

[FixOptions]
NegativeBase

NegativeBase

NegativeBase sets the base FAP unit value (2400 FAP units = 1 inch) for the FixNegative option.

[ FixOptions]

NegativeBase = Edit

Parameter | Description
Edit | 2400 FAP units = 1 inch

Example

< FixOptions >

NegativeBase = 4800

Available

Release | _______
Patch |


NoFixImageDims

[FixOptions]
NoFixImageDims

NoFixImageDims

NoFixImageDims determines the default value of the Retain Image Dimensions field on the Images tab.

[ FixOptions]

NoFixImageDims = YN

Parameter | Description
Boolean |

Remarks

The system increases an image's horizontal or vertical dimensions if you place objects outside the image's borders. To prevent this from happening, check the Retain Image Dimensions field.

Example

< FixOptions >

NoFixImageDims = No

Available

Release | _______
Patch |


Rotate90

[FixOptions]
Rotate90

Rotate90

[ FixOptions]

Rotate90 = YN

Parameter | Description
Boolean |

Remarks

This option determines the default value of the Rotate 90 Degrees field of the Images tab. To rotate images 90 degrees, check the Rotate 90 Degrees field.

Example

< FixOptions >

Rotate90 = No

Available

Release | _______
Patch |


TopMargin

[FixOptions]
TopMargin

TopMargin

The TopMargin option sets the default value for the image's top margin in FAP units.

[ FixOptions]

TopMargin = Edit

Parameter | Description
Edit | 2400 FAP units = 1 inch

Example

< FixOptions >

TopMargin = 400

Available

Release | _______
Patch |


UniqueFieldNames

[FixOptions]
UniqueFieldNames

UniqueFieldNames

The UniqueFieldNames option sets the default value for the Require Unique Field Names checkbox on the Fields tab.

[ FixOptions]

UniqueFieldNames = YN

Parameter | Description
Boolean |

Remarks

To use unique field names, check the Require Unique Field Names field if you want the system to check for duplicate field names and warn you if any are found. If the system finds duplicate fields, it appends a pound sign (#) followed by a number such as 001 to the field name.

Example

< FixOptions >

UniqueFieldNames = No

Available

Release | _______
Patch |


UpdateDDT

[FixOptions]
UpdateDDT

UpdateDDT

[ FixOptions]

UpdateDDT = YN

Parameter | Description
Boolean |

Remarks

This group option sets the default value for the Update DDT from FAP and XDB (Data Dictionary) field on the Other tab of the Convert Multiple FAPS window.

To update the DDT files for the images you selected using existing FAP and Data Dictionary information, check this field. The system updates the font ID and x and y coordinates. If the system finds a field name which matches one found in the Data Dictionary, it updates the remaining DDT information.

Example

< FixOptions >

UpdateDDT = No

Available

Release | _______
Patch |


UseXDBRule

[FixOptions]
UseXDBRule

UseXDBRule

Controlling which rule is used when inserting a field on an image from Extract Dictionary

[ FixOptions]

UseXDBRule = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Example

< FixOptions >

UseXDBRule = YES

Available

Release | _______
Patch |


YearDigit4

[FixOptions]
YearDigit4

YearDigit4

This option sets the default value for the Use 4-digit Year Date Format checkbox on the Fields tab.

[ FixOptions]

YearDigit4 = YN

Parameter | Description
Boolean |

Remarks

To format dates using 4-digit years, check the Use 4-digit Year Date Format field to change all date fields on the selected images to use 4-digit years. At the turn of the century, it may become difficult to tell which century a 2-digit year value references. The system will adjust the fields input length if necessary, but makes no other changes to the field.

This INI option is also supported for the stand-alone utility FIXFORM, which offers the same functionality as the Convert, Multiple FAPs option. When you use FIXFORM, you can use the command line option /Y4 to turn on this feature.

Example

< FixOptions >

YearDigit4=Yes

Available

Release | _______
Patch |


FDBEditor

Remarks

ImportUpdateDups

FDBEditor Options

  • ImportUpdateDups


ImportUpdateDups

[FDBEditor]
ImportUpdateDups

ImportUpdateDups

Note: This option is referenced from the stand-alone FDB (Fields) Editor and not DM Studio or its derivatives.

Feature 1406 You can now use the ImportUpdateDups option to handle repeating fields found during a Field Database import.

[ FDBEditor]

ImportUpdateDups = No

Parameter | Description
Boolean (No) | You can now use the ImportUpdateDups option to handle repeating fields found during a Field Database import. Default value is: No

Remarks

If you enter Yes, the system updates the field database (overwriting the previously entered field). The default is No, which tells the system not to update the field database.

If you omit this option, a message appears to ask if you want to update the record.

Keep in mind that including this INI option disables the message so you will no longer be asked or know if duplicates are found.

Example

< FDBEditor >

ImportUpdateDups = Yes

Available

Release | 10.2
Patch | 72


FDT2DB

Remarks

Using this group fixes a problem when running FDT2DB. The trace file was logged to whether or not the user has debugging enabled. Using these ini options will limit the trace log to the desired handler.

<Debug_Switches>

FDT2DB = Yes

and

<FDT2DB>

DBHandler = <dbname>

Available

Release | 11.2
Patch |

FDBEditor Options

  • DBHandler


DBHandler

[FDT2DB]
DBHandler

[ FDT2DB]

DBHandler = Name

Parameter | Description
Name | Enter the name of the DBHandler group

Remarks

Using this group fixes a problem when running FDT2DB. The trace file was logged to whether or not the user has debugging enabled. Using these ini options will limit the trace log to the desired handler.

Example

<Debug_Switches>

FDT2DB = Yes

and

<FDT2DB>

DBHandler = <dbname>

Available

Release | 11.2
Patch |


FMRes

Remarks

Codepages

FMRes Options

  • Codepage
  • Deflib
  • FormLib
  • XrfFile


Codepage

[FMRes]
Codepage

Codepage

The Codepage option specifies the INI file containing information about characters in various code pages.

[ FMRes]

Codepage = File

Parameter | Description
File |

Example

< FMRes >

Codepage = CODEPAGE.INI

Available

Release | _______
Patch |


Deflib

[FMRes]
Deflib

Deflib

[ FMRes]

Deflib = Path

Parameter | Description
Path |

Remarks

DefLib is the directory path of Form set definition file and FXR files (default location of font files).

Example

< FMRes >

DefLib = ..\MSTRRES\FMRES\DEFLIB\

Available

Release | _______
Patch |


FormLib

[FMRes]
FormLib

FormLib

FormLib defines the directory path of library forms and logos.

[ FMRes]

FormLib = Path

Parameter | Description
Path |

Example

< FMRes >

..\MSTRRES\FMRES\FORMS\

Available

Release | _______
Patch |


XrfFile

[FMRes]
XrfFile

XrfFile

This option specifies the name of the Font Cross Reference file.

[ FMRes]

XrfFile = File

Parameter | Description
File |

Example

< FMRes >

XrfFile = REL95SM

Available

Release | _______
Patch |


FontFamilyMatching

Remarks

When converting a file from one format to another, you may need to convert the fonts used in the document. You can use INI control groups and options to map fonts in a source document to the fonts you want to use in the destination document. For instance, if you are converting an RTF file into a FAP file, you can use the following control group:

< RTFFontMAP >

Arial = Swiss

This tells the system to convert all Arial fonts into Swiss fonts. Use this control group when converting DCD files into FAP files:

< FontFamilyMatching >

Arial = Swiss

The left of the equal sign is the family of the fonts used in the DCD files, and the right of the equal sign is the family of the fonts you want to use in the FAP files, which should be in the FXR file.

Place these control groups and options in the INI file.

RTF and DCD files contain font information about the generic font families used. For example, Arial and Universe, both san serif proportional fonts, belong to a generic font family called Swiss.

The RTF and DCD converters in the system use the RTFFontMap and FontFamilyMatching control groups to assign a font when other means of mapping fonts from the RTF or DCD file fails.

In Windows environments, there are several generic font families, as shown in this table:

Family ---------- Description

Decorative ---- Specifies a novelty font, such as Old English.

Dontcare ------ Specifies a generic family name. This name is used when information about a font does not exist or does not matter. The default font is used.

Modern --------- Specifies a monospace font with or without serifs. Monospace fonts are usually modern fonts, such as Pica, Elite, and Courier New.

Roman -------- Specifies a proportional font with serifs, such as Times New Roman.

Script ----------- Specifies a font that is designed to look like handwriting, such as Script and Cursive.

Swiss ---------- Specifies a proportional font without serifs, such as Arial.

Example

< FontFamilyMatching >

Arial = Swiss

FontFamilyMatching Options

  • Arial


Arial

[FontFamilyMatching]
Arial

Arial

Use this control group to convert the fonts used in the document, when converting DCD files into FAP files.

[ FontFamilyMatching]

Arial = Edit

Parameter | Description
Edit |

Remarks

Please refer to Remarks under the < FontFamilyMatching > INI control group for detailed information.

Example

< FontFamilyMatching >

Arial = Swiss

Available

Release | _______
Patch |

Used By

corplib, dcdlib, FNTLIB


Formats

Remarks

Manual

Formats Options

  • DateFormat
  • TimeFormat


DateFormat

[Formats]
DateFormat

DateFormat

Use this FSISYS.INI control group to define system date and time formats.

[ Formats]

DateFormat = Edit

Parameter | Description
value | The DateFormat option controls the system date format. If not defined, DateFormat is %m/%d/%y, which only provides a 2-digit year.

Remarks

The DateFormat option controls the system date format. If not defined, DateFormat is %m/%d/%y, which only provides a 2-digit year.

NOTE: If you want a 4-digit year, which is highly recommended, you should change the %y in the example above to %Y (upper case Y). This will produce MM/DD/YYYY as the result.

The order of the % variables is not important and any other characters in the format string serve simply as placeholders. If the date is to be used by DAL scripts, however, you should make sure the separators conform to one of the standard date formats. The valid format options for this control group are shown below.

%m 2 digit month

%d 2 digit day

%y 2-digit year

%Y 4-digit year

%H Hour (00 - 23)

%I Hour (00-12)

%p AM/PM indicator

%M Minutes (00-59)

%S Seconds (00-59)

Example

< Formats >

DateFormat = %m/%d/%Y

Available

Release | _______
Patch |


TimeFormat

[Formats]
TimeFormat

TimeFormat

Use this FSISYS.INI control group to define system date and time formats.

[ Formats]

TimeFormat = Edit

Parameter | Description
value | The TimeFormat option controls the system time format. If not defined, TimeFormat is %I/%M/%S, which provides a HH/MM/SS format in twelve hour increments.

Remarks

The TimeFormat option controls the system time format. If not defined, TimeFormat is %I/%M/%S, which provides a HH/MM/SS format in twelve hour increments.

The order of the % variables is not important and any other characters in the format string serve simply as placeholders. The valid format options for this control group are shown below.

%m 2 digit month

%d 2 digit day

%y 2-digit year

%Y 4-digit year

%H Hour (00 - 23)

%I Hour (00-12)

%p AM/PM indicator

%M Minutes (00-59)

%S Seconds (00-59)

Example

< Formats >

TimeFormat = %I/%M/%S

Available

Release | _______
Patch |


FormDescription

Remarks

Script

FormDescription Options

  • Script


Script

[FormDescription]
Script

Script

The name of the DAL script you want the system to execute.

[ FormDescription]

Script = File

Parameter | Description
File |

Remarks

This example shows how you can call a DAL script to customize the description placed in the Form Description Line fields. To use this functionality, make sure you have the Script option set up in the FormDescription control group:

< FormDescription >

Script = AddDate.DAL

Example

< FormDescription >

Script = AddDate.DAL

Available

Release | 10.3
Patch |


FormDescTable

FormDescTable Options

  • AutoOverFlow
  • BoldKey2
  • ColumnFormat
  • ExcludedForm
  • ExcludedGroup
  • FILE
  • IncludeDuplicateForms
  • IncludeFormDesc
  • IncludeFormName
  • IncludeKey2
  • IncludeKEY2Name
  • KEY2PostInc
  • KEY2Prefix
  • KEY2PreInc
  • OverFlowSectionName
  • Script
  • StartFromFirstForm
  • TABLE
  • UseDefaultIfMissing


AutoOverFlow

[FormDescTable]
AutoOverFlow

AutoOverFlow

[ FormDescTable]

AutoOverFlow = No

Parameter | Description
Boolean | Default setting is Yes to overflow form description line fields.

Remarks

By default, if there are not enough Form Desc Line fields to accommodate the number of forms in the form set, the form automatically overflows to a new page. This is accomplished by duplicating the section that contains the Form Desc Line fields to a new page along with any header or footer sections that are designated as Copy on overflow.

If you do not wish it to overflow, set this option to no.

Example

< FormDescTable >

AutoOverFlow = No

Available

Release | 11.4
Patch |

See Also

OverFlowSectionName


BoldKey2

[FormDescTable]
BoldKey2

BoldKey2

This option determines if the KEY2 (Line of Business) descriptions are presented in a "bold" font.

[ FormDescTable]

BoldKey2 = No

Parameter | Description
Boolean (No) | value Default value is: No

Remarks

The actual font used is determined automatically by querying the font defined on the field and evaluating its &quot;bold&quot; equivalent. The fonts of normal Form Description Lines fields (not assigned a KEY2 name) will be changed to their &quot;non-bold&quot; counterparts.

Use this option to present Key2 descriptions in a bold font. The system determines which font to use by querying the font defined on the field and selecting its bold equivalent. The fonts of normal Form Description Lines fields (not assigned a Key2 name) are changed to their non-bold counterparts.

Example

< FormDescTable >

BoldKey2 = Yes

Available

Release | _______
Patch |


ColumnFormat

[FormDescTable]
ColumnFormat

ColumnFormat

1354 Customizing Form Description Lines

[ FormDescTable]

ColumnFormat = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

By default, the system writes out the form description lines in a columnar format with the form name on the left and pads the text based on the longest form name. To have the system write out the form description lines in a non-columnar format, set this option to No. If set to No, the system adds the form description to the end of the form name, separated by two spaces.

You now have two new INI options to customize form description lines. Form description lines had been formatted in a columnar format with the form name on left padded to the largest form name length used. Use the new ColumnFormat option to format the form lines in a non-columnar format.

When using an associated table to look up form descriptions, if the form was not defined in the table, you would find no description of the form. You can now use the UseDefaultIfMissing option to tell the system to use the form description from the Form set definition file (form.dat, .BDF, .GRP, or .FOR).

Here is an example of these options:

< FormDescTable >

ColumnFormat = No

UseDefaultIfMissing = Yes

ColumnFormat--Set this option to No to have the system append the form description to the end of the form name, separated by two spaces. The default is Yes, which formats the form lines in a columnar fashion.

UseDefaultIfMissing--Enter Yes to tell the system to use the form description from the Form set definition file (form.dat, .BDF, .GRP, or .FOR), if the entry is not found in the table. The default is No, meaning that the form name must be in the table for a description to appear.

Example

< FormDescTable >

ColumnFormat = No

Available

Release | 10.2
Patch |


ExcludedForm

[FormDescTable]
ExcludedForm

ExcludedForm

Feature 1301

[ FormDescTable]

ExcludedForm =

Parameter | Description
value | Now you can exclude a form or group from the Form Description lines without having to move it within the form set. This change does not affect the printing of the form.

Remarks

Now you can exclude a form or group from the Form Description lines without having to move it within the form set. This change does not affect the printing of the form.

To exclude forms, use the ExcludedForm INI option. To exclude a group of forms (as defined in the Key2 field), use the ExcludedGroup option, as shown in this example:

< FormDescTable >

ExcludedForm = FORMDESC

ExcludedForm = CDEC

ExcludedGroup = PROPERTY FORMS

Example

< FormDescTable >

ExcludedForm = FORMDESC

ExcludedForm = CDEC

Available

Release | 10.2
Patch | 75


ExcludedGroup

[FormDescTable]
ExcludedGroup

ExcludedGroup

Feature 1301

[ FormDescTable]

ExcludedGroup =

Parameter | Description
value | Now you can exclude a form or group from the Form Description lines without having to move it within the form set. This change does not affect the printing of the form.

Remarks

Now you can exclude a form or group from the Form Description lines without having to move it within the form set. This change does not affect the printing of the form.

To exclude forms, use the ExcludedForm INI option. To exclude a group of forms (as defined in the Key2 field), use the ExcludedGroup option, as shown in this example:

< FormDescTable >

ExcludedForm = FORMDESC

ExcludedForm = CDEC

ExcludedGroup = PROPERTY FORMS

Example

< FormDescTable >

ExcludedGroup = PROPERTY FORMS

Available

Release | 10.2
Patch | 75


ExcludeDuplicateDescriptions

[FormDescTable]
ExcludedDuplicateDescriptions

Add this option to the Form Description Line processing to suppress subsequent forms that have the same description as a previous form.

< FormDescTable >

ExcludeDuplicateDescriptions=Yes

The default option for this is set to No, meaning that we don't normally look for duplicate form descriptions.

This means that if two forms have different names, but the same form description, you can suppress the second form from being listed in the Form Description table.


FILE

[FormDescTable]
FILE

FILE

This option defined the name of a FSI table file (located by the [MasterResource] TABLELIB directory).

[ FormDescTable]

FILE = Edit

Parameter | Description
value | value

This option may be required in order for the feature to function.

Example

< FormDescTable >

FILE = Tablefilename

Available

Release | _______
Patch |


IncludeDuplicateForms

[FormDescTable]
IncludeDuplicateForms

IncludeDuplicateForms

[ FormDescTable]

IncludeDuplicateForms = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

If you want the system to include duplicate forms, set this option to Yes. The system excludes the duplicate forms from the form description lines as a default.

Example

< FormDescTable >

IncludeDuplicateForms = Yes

Available

Release | _______
Patch |


IncludeFormDesc

[FormDescTable]
IncludeFormDesc

IncludeFormDesc

Set this option to No if you want to suppress the description from the form description lines.

[ FormDescTable]

IncludeFormDesc = Yes

Parameter | Description
boolean (Yes) | Default value is: Yes

Remarks

The system includes the form description by default.

The system will write the form description without the form name if you set the INI options (IncludeFormDesc and IncludeFormName) to 'No'.

Example

< FormDescTable >

IncludeFormDesc = Yes

Available

Release | _______
Patch |


IncludeFormName

[FormDescTable]
IncludeFormName

IncludeFormName

Suppresses the form name from the Form Description Lines table.

[ FormDescTable]

IncludeFormName = Yes

Parameter | Description
Boolean (Yes) | Suppresses the form name from the Form Description Lines table. Default value is: Yes

Remarks

This option is used to determine whether the form's name obtained from the table is also to be included in the returned description. This option is active by default. If form names are not to be included in the returned description line, set this INI option to &quot;No&quot;.

Normally, when including Form Description Lines on a form, the information will include the form name and the description. This option lets you optionally not show the form name and only print the description for each form.

Although this option is defined under the FormDescTable control group, you can use this option when you do not use an associated table file to provide longer descriptions than those provided in the Form set definition file (form.dat, .BDF, .GRP, or .FOR).

Enter No if you want to suppress the form name from the form description lines. By default, the system includes the form names.

Example

< FormDescTable >

IncludeFormName = No

Available

Release | 10.1
Patch |


IncludeKey2

[FormDescTable]
IncludeKey2

IncludeKey2

You can use these ini options to tell the system how to represent form group lines on for description lines.

[ FormDescTable]

IncludeKey2 = No

Parameter | Description
Boolean (No) | value Default value is: No

Remarks

This option is the enabling / disabling option for including KEY2 descriptions. If you wish to enable this option you must set this option to &quot;Yes&quot;. By default the KEY2 descriptions are not be included in the formset.

Enter Yes to enable Key2 descriptions. By default, the form description lines only contain descriptions of the forms.

Optionally, you can include descriptions for form groups, such as lines of business. These form groups are called Key2s.

Example

< FormDescTable >

IncludeKey2 = Yes

Available

Release | _______
Patch |


IncludeKEY2Name

[FormDescTable]
IncludeKEY2Name

IncludeKEY2Name

[ FormDescTable]

IncludeKEY2Name = Edit

Parameter | Description
value | value

Remarks

Like the previous option, the value assigned to this option is used to determine whether the KEY2 group name obtained from the table is also to be included in the returned description. This option is NOT active by default. If KEY2 names are to be included in the returned description line, set this INI option to &quot;Yes&quot;.

Example

< FormDescTable >

IncludeKEY2Name = Yes

Available

Release | _______
Patch |


KEY2PostInc

[FormDescTable]
KEY2PostInc

KEY2PostInc

This option is a "spacer" option.

[ FormDescTable]

KEY2PostInc = Edit

Parameter | Description
value | value

Remarks

Use these options to add blank lines between the Key2 descriptions and the form descriptions. If you set both of these options to one (1), your output might look like this:

Forms Applicable - COMMON POLICY

DEC PAGE Common Policy Declarations

FIL 1010 04 92 Supplemental Declarations

Forms Applicable GENERAL LIABILITY

CG DEC General Liability Declarations

If you include Key2 descriptions, the first text will always represent the first form grouping. This first Key2 description will not use the Key2PreInc option to include blank lines before the text. Subsequent groups, however, will have the specified number of blank lines before their text descriptions.

Use this option to add blank lines between Key2 descriptions the form descriptions. For example, if you include Key2 descriptions, and set this option to one, your output might look like this:

Form Applicable - General Liability Coverage

Form 1Automobile Coverage

Form 2Homeowner Coverage

Example

< FormDescTable >

KEY2PostInc = one

Available

Release | _______
Patch |


KEY2Prefix

[FormDescTable]
KEY2Prefix

KEY2Prefix

This option assigns a text string that is to start each KEY2 description line.

[ FormDescTable]

KEY2Prefix = Edit

Parameter | Description
value | value

Remarks

The system automatically appends a single space after the text string. By default, this option is blank and does not affect the description lines. Here is an example of how you can use this option:

Key2Prefix = Forms Applicable -

By setting the option as shown above, the system prefixes all Key2 descriptions with the specified text. For instance, the output might look like this:

Forms Applicable - General Liability Coverage

Enter the text you want to appear before each Key2 description line. The system automatically adds a single

space after the text. By default, this option is blank and does not affect the description lines. For instance, if you enter Form Applicable - the system prefixes all Key2 descriptions with that text. The output might look like this:

Form Applicable - General Liability Coverage

Example

< FormDescTable >

KEY2Prefix = Forms Applicable -

Available

Release | _______
Patch |


KEY2PreInc

[FormDescTable]
KEY2PreInc

KEY2PreInc

This option is a "spacer" option.

[ FormDescTable]

KEY2PreInc = Edit

Parameter | Description
value | value

Remarks

Use these options to add blank lines between the Key2 descriptions and the form descriptions. If you set both of these options to one (1), your output might look like this:

Forms Applicable - COMMON POLICY

DEC PAGE Common Policy Declarations

FIL 1010 04 92 Supplemental Declarations

Forms Applicable GENERAL LIABILITY

CG DEC General Liability Declarations

If you include Key2 descriptions, the first text will always represent the first form grouping. This first Key2 description will not use the Key2PreInc option to include blank lines before the text. Subsequent groups, however, will have the specified number of blank lines before their text descriptions.

Example

< FormDescTable >

KEY2PreInc = one

Available

Release | _______
Patch |


OverFlowSectionName

[FormDescTable]
OverFlowSectionName

OverFlowSectionName

[ FormDescTable]

OverFlowSectionName = SectionName

Parameter | Description
SectionName | Enter the name of the section you want the system to use during overflow.The system inserts this section instead of copying the section where the last Form Desc Line field was encountered. When you include this option, the system still copies the header and footer sections that are designated as Copy on overflow.

Remarks

By default, if there are not enough Form Desc Line fields to accommodate the number of forms in the form set, the form automatically overflows to a new page. This is accomplished by duplicating the section that contains the Form Desc Line fields to a new page along with any header or footer sections that are designated as Copy on overflow.

As an alternative to the normal overflow method, you can now specify a section to insert instead of copying the section at which the page ended. This lets you create a specialized section that contains more (or a different arrangement of) form description fields.

Use this option to specify the section you want the system to use.

NOTE: If the AutoOverflow option is set to No, the OverflowSectionName option is ignored.

Example

< FormDescTable >

OverFlowSectionName = Body123

Available

Release | 11.4
Patch |


Script

[FormDescTable]
Script

Script

The name of DAL script you want the system to execute.

[ FormDescTable]

Script = Edit

Parameter | Description
value |

Remarks

This example shows how you can call a DAL script to customize the description placed in the Form Description Line fields. To use this functionality, make sure you have the Script option set up in the FormDescription control group:

< FormDescription >

Script = AddDate.DAL

Example

< FormDescTable >

Script = AddDate.DAL

Available

Release | _______
Patch |


StartFromFirstForm

[FormDescTable]
StartFromFirstForm

StartFromFirstForm

[ FormDescTable]

StartFromFirstForm = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Enter Yes if you want the system to include forms starting from the first form. By default, only forms placed after the first form that contains a FORM DESC LINE field are included in the list of forms.

Note that the form that contains the form description lines is not included in the list unless this option is turned on.

Example

< FormDescTable >

StartFromFirstForm = No

Available

Release | _______
Patch |


TABLE

[FormDescTable]
TABLE

TABLE

This option defines the name of a specific table within that file defined by the previous option.

[ FormDescTable]

TABLE = Edit

Parameter | Description
value | value

This option may be required in order for the feature to function.

Remarks

If an invalid table name is provided or the name is omitted, the function will fail.

NOTE: You do not have to attach the table to the form description line fields. The INI options that enable this feature provide all the information that is required. No. .FAP changes are required to begin using a table with existing form description line fields.

Example

< FormDescTable >

TABLE = tablename

Available

Release | _______
Patch |


UseDefaultIfMissing

[FormDescTable]
UseDefaultIfMissing

UseDefaultIfMissing

1354 Customizing Form Description Lines

[ FormDescTable]

UseDefaultIfMissing = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

You now have two new INI options to customize form description lines. Form description lines had been formatted in a columnar format with the form name on left padded to the largest form name length used. Use the new ColumnFormat option to format the form lines in a non-columnar format.

When using an associated table to look up form descriptions, if the form was not defined in the table, you would find no description of the form. You can now use the UseDefaultIfMissing option to tell the system to use the form description from the Form set definition file (form.dat, .BDF, .GRP, or .FOR).

Here is an example of these options:

< FormDescTable >

ColumnFormat = No

UseDefaultIfMissing = Yes

ColumnFormat--Set this option to No to have the system append the form description to the end of the form name, separated by two spaces. The default is Yes, which formats the form lines in a columnar fashion.

UseDefaultIfMissing--Enter Yes to tell the system to use the form description from the Form set definition file (form.dat, .BDF, .GRP, or .FOR), if the entry is not found in the table. The default is No, meaning that the form name must be in the table for a description to appear.

Example

< FormDescTable >

UseDefaultIfMissing = Yes

Available

Release | 10.2
Patch |


FormSelection

Remarks

Options specified under this group generally related only to the Form Selection dialog behavior. Options are available to control the appearance or behavior of most of the elements that can appear on the dialog.

Example

< FormSelection >

HideTransaction = Yes

HideKey1 = Yes

HideKey2 = Yes

HideKeyID = Yes

HideDescription = Yes

HideImport = Yes

HideRetrieve = Yes

HideDuplicate = Yes

HideCheckBox = Yes

HideMode = Yes

HideFormName = Yes

HideFormDescription = Yes

HideRecip*** = Yes

HideRecipInsured = Yes

HideRecipAgent = Yes

HideRecipHome Office = Yes

ProtectRecip*** = Yes

ProtectRecipInsured = Yes

ProtectRecipAgent = Yes

ProtectRecipHome Office = Yes

OnyEditZeroRecip = Yes

FullRecipWidth = Yes

DescriptionRequired = Yes

CreateStartField =

UpdateStartField =

FormSelection Options

  • CreateStartField
  • DescriptionRequired
  • FullRecipWidth
  • HideCheckBox
  • HideDescription
  • HideDuplicate
  • HideFormDescription
  • HideFormName
  • HideImport
  • HideKey1
  • HideKey2
  • HideKeyID
  • HideMode
  • HideRecipCustom
  • HideRetrieve
  • HideTransaction
  • OnlyEditZeroRecip
  • OriginalKeyID
  • ProtectRecip????
  • RetrieveVersionInfo
  • SelectByRowClick
  • SuppressDialog
  • UpdateStartField


CreateStartField

[FormSelection]
CreateStartField

CreateStartField

[ FormSelection]

CreateStartField = YN

Parameter | Description
boolean | Yes | No

This option may be required in order for the feature to function.

Remarks

Use this option to override the dialog field that nor- mally receives focus when the dialog appears in &quot;create&quot; WIP mode. Valid responses to this option are TRANSACTION, KEY1, KEY2, KEYID, and DESCRIPTION.

Example

< FormSelection >

CreateStartField=

Available

Release | 10.1
Patch |


DescriptionRequired

[FormSelection]
DescriptionRequired

DescriptionRequired

Enabling this option will require the user to fill in some data in the Description field before accepting the dialog.

[ FormSelection]

DescriptionRequired = YN

Parameter | Description
boolean | Yes | No

Example

< FormSelection >

DescriptionRequired= Yes

Available

Release | 10.1
Patch |


FullRecipWidth

[FormSelection]
FullRecipWidth

FullRecipWidth

[ FormSelection]

FullRecipWidth = YN

Parameter | Description
boolean | Yes | No

Remarks

Using this option will attempt to create the recipient columns wide enough to display the entire recipient name on the column header. Normally, we allocate minimal space to the recipient columns to allow as many as possi- ble to show on the initial view of the dialog. This is done to prevent the user from having to scroll to see additional recipients- which becomes necessary the more recipients that are named. This option, forgoes that attempt at maximizing the number of recipients shown on the initial view.

Example

< FormSelection >

FullRecipWidth= Yes

Available

Release | 10.1
Patch |


HideCheckBox

[FormSelection]
HideCheckBox

HideCheckBox

The CheckBox column for selecting and deselecting forms in the available list will not appear.

[ FormSelection]

HideCheckBox = YN

Parameter | Description
boolean | Yes | No

Remarks

This means that the user cannot change the forms selected.

Example

< FormSelection >

HideCheckBox = Yes

Available

Release | 10.1
Patch |


HideDescription

[FormSelection]
HideDescription

HideDescription

Description field and prompt will not display.

[ FormSelection]

HideDescription = YN

Parameter | Description
boolean | Yes | No

Remarks

During creation, you would have to utilize a hook(or some other method) to assign a description to new formsets. WIP formsets will maintain any description read from the WIP record.

Example

< FormSelection >

HideDescription = Yes

Available

Release | 10.1
Patch |


HideDuplicate

[FormSelection]
HideDuplicate

HideDuplicate

Removes the Duplicate button from display.

[ FormSelection]

HideDuplicate = YN

Parameter | Description
boolean | Yes | No

Example

< FormSelection >

HideDuplicate = Yes

Available

Release | 10.1
Patch |


HideFormDescription

[FormSelection]
HideFormDescription

HideFormDescription

The FormDescription column will not appear in the forms list.

[ FormSelection]

HideFormDescription = YN

Parameter | Description
boolean | Yes | No

Example

< FormSelection >

HideFormDescription = Yes

Available

Release | 10.1
Patch |


HideFormName

[FormSelection]
HideFormName

HideFormName

The FormName column will not appear in the forms list.

[ FormSelection]

HideFormName = YN

Parameter | Description
boolean | Yes | No

Example

< FormSelection >

HideFormName = Yes

Available

Release | 10.1
Patch |


HideImport

[FormSelection]
HideImport

HideImport

Removes the Import button from display.

[ FormSelection]

HideImport = YN

Parameter | Description
boolean | Yes | No

Example

< FormSelection >

HideImport = Yes

Available

Release | 10.1
Patch |


HideKey1

[FormSelection]
HideKey1

HideKey1

Key1 field and prompt will not display. However, the first Key1 in the list will be selected.

[ FormSelection]

HideKey1 = YN

Parameter | Description
boolean | Yes | No

This option may be required in order for the feature to function.

Remarks

Lets you hide the Key1 field and prompt.

Example

< FormSelection >

HideKey1 = No

Available

Release | 10.1
Patch |


HideKey2

[FormSelection]
HideKey2

HideKey2

Key2 field and prompt will not display.

[ FormSelection]

HideKey2 = YN

Parameter | Description
boolean | Yes | No

This option may be required in order for the feature to function.

Remarks

The first item in the Key2 list will be selected. Note: When Master Dec groups are used, that Key2 will normally appear as the title over the listbox and automati- cally selected as well.

Example

< FormSelection >

HideKey2 = No

Available

Release | 10.1
Patch |


HideKeyID

[FormSelection]
HideKeyID

HideKeyID

KeyID field and prompt will not display.

[ FormSelection]

HideKeyID = YN

Parameter | Description
boolean | Yes | No

This option may be required in order for the feature to function.

Remarks

Note: Unless you limit users to editing WIP or utilize some type of automatic KeyID generation, you cannot leave this field blank. Even when it is not visible.

Example

< FormSelection >

HideKeyID = No

Available

Release | 10.1
Patch |


HideMode

[FormSelection]
HideMode

HideMode

The Mode column that identifies the Entry and Pull Form setting will not display.

[ FormSelection]

HideMode = YN

Parameter | Description
boolean | Yes | No

Example

< FormSelection >

HideMode = Yes

Available

Release | 10.1
Patch |


HideRecipCustom

[FormSelection]
HideRecipCustom

HideRecipCustom

Use this option to identify a specific recipient column that should be suppressed.

[ FormSelection]

HideRecipCustom = YN

Parameter | Description
boolean | Yes | No

Remarks

To use, append the name of the recepient to the option where you see the question marks above. For instance, if the recipient you want to suppress is AGENT, then you would specify the following.

[FormSelection]

HideRecipAgent=Yes

Notice there is not a space between the last the prefix 'HideRecip' and the recipient name.

If there is a space in the recipient name however, you would include that space in the definition. For instance, if the recipient you want to suppress is defined as HOME OFFICE (where the is a space between the words), it would be specified like this.

[FormSelection]

HideRecipHome Office = Yes

Notice that there is no space in HideRecipHome but there is still a space between Home and Office.

Example

< FormSelection >

HideRecipAgent = Yes

HideRecipHome Office = Yes

Available

Release | 10.1
Patch |

Used By

AFELIB


HideRetrieve

[FormSelection]
HideRetrieve

HideRetrieve

Removes the Retrieval button from display.

[ FormSelection]

HideRetrieve = YN

Parameter | Description
boolean | Yes | No

Example

< FormSelection >

HideRetrieve = Yes

Available

Release | 10.1
Patch |


HideTransaction

[FormSelection]
HideTransaction

HideTransaction

Transaction field and prompt will not display. However, the default selection for the Transaction is still active.

[ FormSelection]

HideTransaction = YN

Parameter | Description
boolean | Yes | No

Remarks

Provides an option to hide the transaction field from the Form Selection window, for those applications that do not wish to see this field. Others include options to hide the mode column and to protect the recipients column.

Another is to designate the starting field for user entry using, for example:

CreateStartField = KeyID

Lets you hide the Transaction field and prompt. Keep in mind that the default selection for the Transaction list is still active.

Example

< FormSelection >

HideTransaction = Yes

Available

Release | 10.1
Patch |


HideTrnName

[FormSelection]
HideTrnName

HideTrnName

Transaction field and prompt will not display. However, the default selection for the Transaction is still active.

[ FormSelection]

HideTrnName = YN

Parameter | Description
boolean | Yes | No

Remarks

Provides an option to hide the transaction name field from the Form Selection window, for those applications that do not wish to see this field. Others include options to hide the mode column and to protect the recipients column.

Example

< FormSelection >

HideTrnName = Yes

Available

Release | 11.4
Patch |


OnlyEditZeroRecip

[FormSelection]
OnlyEditZeroRecip

OnlyEditZeroRecip

[ FormSelection]

OnlyEditZeroRecip = YN

Parameter | Description
boolean | Yes | No

Remarks

This option will only allow the user to change the reci- pient copy count on forms that initially have a 0 (zero) specified in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). If you are editing WIP that specifies a recipient not included in the Form set definition file (form.dat, .BDF, .GRP, or .FOR), the user will still be allowed to change those recipient copy counts. When this option is active, only the edi- table copy counts will appear on the dialog, the rest are hidden from view.

Example

< FormSelection >

OnlyEditZeroRecip = Yes

Available

Release | 10.1
Patch |


OriginalKeyID

[FormSelection]
OriginalKeyID

OriginalKeyID

[ FormSelection]

OriginalKeyID = Edit

Parameter | Description
Edit |

Remarks

Feature 1577 is available for you starting release 11.0 to use the new field to show the original policy number on your banner page.

When you renew a policy you retrieve the original policy from archive and then assign it a new policy number on the Forms Selection window. You can add a field to the banner page that automatically displays the previous policy number.

To do this, create a field on the banner page (i.e. FAP file) called, for example, PRVPOL. In your INI file, include the new field in the Banner control group, as shown here:

< Banner >

Field = PRVPOL

Field = POLICY NBR

Field = INSURED NAME

Name = PFORM

Size =

Note: Make sure to list the Field options in the same order as they appear on the banner page.

Be sure to include the following INI option:

< AFEProcedures >

BannerProc = TRNw32->TRNSetBannerFormInfo

Also you must enter the following line in the FormSelection group of the INI file:

< FormSelection >

OriginalKeyID = PRVPOL

Example

< Banner >

Field = PRVPOL

Name = PFORM

< FormSelection >

OriginalKeyID = PRVPOL

Available

Release | 11.0
Patch |


ProtectRecip????

[FormSelection] ProtectRecip
????

ProtectRecip????

Prevent user from changing the form copy counts shown in a particular recipient column.

[ FormSelection]

ProtectRecip???? = YN

Parameter | Description
boolean | Yes | No

Remarks

Use this option to identify a specific recipient column that should be protected but still displayed. When pro- tected, the user cannot change the form copy counts for that recipient. To use, append the name of the recipient to the option. For instance, if the recipient column you want to protect is AGENT, you would specify this option.

[Form Selection]

ProtectRecipAgent

Notice there is not a space between the last the prefix 'ProtectRecip' and the recipient name.

If there is a space in the recipient name however, you would include that space in the definition. For instance, if the recipient you want to protect is defined as HOME OFFICE (where the is a space between the words), it would be specified like this.

[FormSelection]

ProtectRecipHome Office = Yes

Notice that there is no space in ProtectRecipHome but there is still a space between Home and Office.

Example

< FormSelection >

ProtectRecipAgent = Yes

ProtectRecipHome Office = Yes

Available

Release | 10.1
Patch |

Used By

AFELIB


RetrieveVersionInfo

[FormSelection]
RetrieveVersionInfo

RetrieveVersionInfo

Lets you clear the library version and revision information stored in an archived form set.

[ FormSelection]

RetrieveVersionInfo = Edit

Parameter | Description
value | Lets you clear the library version and revision information stored in an archived form set.

Remarks

You would use this option if you want to use newer versions of the forms than those in the retrieved form set.

Set this option to No to clear that information when you are using an archived form set to create a new form set.

Example

< FormSelection >

RetrieveVersionInfo = No

Available

Release | 10.1
Patch | 334


SelectByRowClick

[FormSelection]
SelectByRowClick

SelectByRowClick

Lets you select a form on the Form Selection window by simply clicking on the form line.

[ FormSelection]

SelectByRowClick = YN

Parameter | Description
Boolean | Lets you select a form on the Form Selection window by simply clicking on the form line.

Example

< FormSelection >

SelectByRowClick = Yes

Available

Release | 10.1
Patch |


SetTransCodeAfterImport

[FormSelection]
SetTransCodeAfterImport

[ FormSelection]

SetTransCodeAfterImport = YN

Parameter | Description
boolean | Yes | No

This option may be required in order for the feature to function.

Example

[FormSelection]

SetTransCodeAfterImport= Yes

Available

Release | 11.3
Patch |


SuppressDialog

[FormSelection]
SuppressDialog

SuppressDialog

Use this option to to prevent the FormSelection dialog from appearing when editing existing WIP.

[ FormSelection]

SuppressDialog = YN

Parameter | Description
boolean | Yes | No

This option may be required in order for the feature to function.

Example

< FormSelection >

SuppressDialog= Yes

Available

Release | _______
Patch |


TrnNameRequired

[FormSelection]
TrnNameRequired

TrnNameRequired

Enabling this option will require the user to fill in some data in the Transaction Name field before accepting the dialog.

[ FormSelection]

TrnNameRequired = YN

Parameter | Description
boolean | Yes | No

Example

< FormSelection >

TrnNameRequired= Yes

Available

Release | 11.4
Patch |


UpdateStartField

[FormSelection]
UpdateStartField

UpdateStartField

[ FormSelection]

UpdateStartField = YN

Parameter | Description
boolean | Yes | No

This option may be required in order for the feature to function.

Remarks

Use this option to override the dialog field that nor- mally receives focus when the dialog appears in &quot;update&quot; WIP mode. Valid responses to this option are TRANSACTION, KEY1, KEY2, KEYID, and DESCRIPTION.

Example

< FormSelection >

UpdateStartField=

Available

Release | 10.1
Patch |


FormSize

FormSize Options

  • Type


Type

[FormSize]
Type

Type

[ FormSize]

Type = 0

Parameter

Description

type

Values 4 - 90 were added in version 10.3

Values can be

  • 1 - Legal
  • 2 - A4
  • 3 - Executive
  • 4 - US Ledger
  • 5 - US Tabloid
  • 6 - US Statement
  • 7 - US Folio
  • 8 - US Fanfold
  • 20 - ISO A0
  • 21 - ISO A1
  • 22 - ISO A2
  • 23 - ISO A3
  • 24 - ISO A4
  • 25 - ISO A5
  • 26 - ISO A6
  • 27 - ISO A7
  • 28 - ISO A8
  • 29 - ISO A9
  • 30 - ISO A10
  • 32 - ISO 2A
  • 34 - ISO 4A
  • 40 - ISO B0
  • 41 - ISO B1
  • 42 - ISO B2
  • 43 - ISO B3
  • 44 - ISO B4
  • 45 - ISO B5
  • 46 - ISO B6
  • 47 - ISO B7
  • 48 - ISO B8
  • 49 - ISO B9
  • 50 - ISO B10
  • 52 - ISO 2B
  • 54 - ISO 4B
  • 60 - ISO C0
  • 61 - ISO C1
  • 62 - ISO C2
  • 63 - ISO C3
  • 64 - ISO C4
  • 65 - ISO C5
  • 66 - ISO C6
  • 67 - ISO C7
  • 68 - ISO C8
  • 69 - ISO C9
  • 70 - ISO C10
  • 71 - ISO DL
  • 80 - JIS B0
  • 81 - JIS B1
  • 82 - JIS B2
  • 83 - JIS B3
  • 84 - JIS B4
  • 85 - JIS B5
  • 86 - JIS B6
  • 87 - JIS B7
  • 88 - JIS B8
  • 89 - JIS B9
  • 90 - JIS B10
  • 98 - Custom
  • 99 - Current Type
  • 0 - Letter

Default value is: 0

Remarks

This option is only used in the stand-alone Image Editor and decides what default paper size you want to use when printing a custom size image.

Example

< FormSize >

Type = 1

Available

Release | _______
Patch |


GenarcStopOn

GenarcStopOn Options

  • DBErrors


DBErrors

[GenarcStopOn]
DBErrors

DBErrors

[ GenarcStopOn]

DBErrors = Yes

Parameter | Description
Boolean (Yes) | Yes (default ) or No Default value is: Yes

Remarks

The INI option tells the GenArc program whether it should terminate processing or skip the transaction in error and then continue processing with the next transaction in the NEWTRN.DAT file.

One example for its usage is as follows:

The user set unique constraint on a primary key on the APPIDX table in a SQL database so that any transaction must have a unique transaction ID. This will caused Genarc to produce error and stop processing when a duplicate transaction ID is found. In order to allow Genarc to skip this duplicate transaction and continue to process the remaining transactions, the user can set this option to No.

Example

< GenarcStopOn >

DBErrors = No

Available

Release | 10.0
Patch |

Used By

GENARC


Gendata

Gendata Options

  • ClearMsgFile


ClearMsgFile

[Gendata]
ClearMsgFile

ClearMsgFile

[ Gendata]

ClearMsgFile = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

The FSISYS.INI and the FSIUSER.INI file provide system setting information, such as whether or not it should stop processing if it encounters errors, how to identify key fields in extract files, whether or not it should check the output data size against the defined field length, and so on.

For single step processing, use the following INI option to delete all MSGFILE.DAT, ERRFILE.DAT, and LOGFILE.DAT files before the system begins the single step process.

< GenData >

ClearMsgFile = Yes

The default is No.

Example

< GenData >

ClearMsgFile = Yes

Available

Release | 10.0
Patch |


GenDataStopOn

Remarks

Use the GenDataStopOn INI control group to define the types of errors which can stop the GenData program from processing.

This control group can also be used if you want to use the restart feature available starting with release 10.1.

You can set up the GenData program to restart itself at a particular transaction if it encounters a failure. To accomplish this, the system uses a restart table. NOTE: This feature does not apply if you are using single-step processing.

The restart table tracks the records successfully processed so that if a run is interrupted, you simply restart the GenData program and it completes the job, beginning with the last successfully processed transaction. These rules are used to handle restarting the GenData program:

RULCheckTransaction

RULRestartJob

The RULCheckTransaction rule is always the first base form set rule. It saves the EXTRFILE offset, TRNFILE offset, NEWTRN offset, NAFILE offset, POLFILE offset, and batch file offsets into a restart (RSTFILE) file.

Here is an example:

;RULCheckTransaction;2;Always the first form set rule;

These offsets are updated in the post process after a specific number of transaction. You specify the number of transactions using the CheckCount option. You define the Restart file and the check count in the Restart control group.

The RULRestartJob is always the first base rule. This rule opens the restart file (RSTFILE) and resets the EXTRFILE, TRNFILE, NEWTRN, NAFILE, POLFILE, and batch files at the broken transaction if the restart file exists. If the restart file does not exist, the

RULRestartJob rule is skipped.

Here is an example:

;RULRestartJob;1;Always the first base rule;

You should also set the following INI options:

< GenDataStopOn >

BaseErrors = Yes

TransactionErrors = Yes

ImageErrors = Yes

FieldErrors = Yes

GenDataStopOn Options

  • BaseErrors
  • FieldErrors
  • ImageErrors
  • JobErrors
  • TransactionErrors


BaseErrors

[GenDataStopOn]
BaseErrors

BaseErrors

[ GenDataStopOn]

BaseErrors = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Use this INI option to tell the GenData program whether to stop processing when an error at the base level occurs.

Example

< GenDataStopOn >

BaseErrors = Yes

Available

Release | _______
Patch |


FieldErrors

[GenDataStopOn]
FieldErrors

FieldErrors

Use this INI option to tell the GenData program whether to stop processing when an error at the field level occurs.

[ GenDataStopOn]

FieldErrors = Yes

Parameter | Description
Boolean (YES) | The GenData program now lets you restart a processing run that failed without having to re-process the entire job. Default value is: Yes

Remarks

192 RESTARTING THE GENDATA PROGRAM

To accomplish this, the system uses a restart table. In this restart table, the system notes the last transaction it has successfully processed, based on the CheckCount option. You use INI options to set up the restart table.

To use this feature, add the following INI options:

< GendataStopOn >

JobErrors = Yes

TransactionErrors = Yes

ImageErrors = Yes

NOTE: This feature does not apply if you are using single-step processing. This feature is not supported on MVS systems.

The restart table tracks the records successfully processed so that if a run is interrupted, you simply restart the GenData program and it completes the job, beginning with the last successfully processed transaction. These rules are used to handle restarting the GenData program:

RULCheckTransaction

RULRestartJob

Example

< GendataStopOn >

FieldErrors = Yes

Available

Release | 10.1
Patch |


ImageErrors

[GenDataStopOn]
ImageErrors

ImageErrors

Use this INI option to tell the GenData program whether to stop processing when an error at the Image level occurs.

[ GenDataStopOn]

ImageErrors = Yes

Parameter | Description
boolean | Use this FSISYS.INI control group to define the types of errors which can stop the GenData program from processing. Default value is: Yes

Example

< GenDataStopOn >

ImageErrors = Yes

Available

Release | _______
Patch |


JobErrors

[GenDataStopOn]
JobErrors

JobErrors

Use this FSISYS.INI control group to define the types of errors which can stop the GenData program from processing.

[ GenDataStopOn]

JobErrors = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Example

< GenDataStopOn >

JobErrors = Yes

Available

Release | _______
Patch |


TransactionErrors

[GenDataStopOn]
TransactionErrors

TransactionErrors

Use this INI option to tell the GenData program whether to stop processing when an error at the transaction level occurs.

[ GenDataStopOn]

TransactionErrors = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Example

< GenDataStopOn >

TransactionErrors = Yes

Available

Release | _______
Patch |


GenTranStopOn

Remarks

TransactionErrors

GenTranStopOn Options

  • TransactionErrors


TransactionErrors

[GenTranStopOn]
TransactionErrors

TransactionErrors

Feature 1351 Controlling GenTrn Processing

[ GenTranStopOn]

TransactionErrors = Edit

Parameter | Description
value | Include the following control group and option in the FSISYS.INI file when you want the GenTrn program to continue processing transactions when errors occur. By default, the GenTrn program halts when it encounters an error.

Remarks

Include the following control group and option in the FSISYS.INI file when you want the GenTrn program to continue processing transactions when errors occur. By default, the GenTrn program halts when it encounters an error.

NOTE: This control group and option is typically used if you are using XML extract files and you do not want the GenTrn program to stop every time it encounters an error. For any type of extract file, using this option detects missing Key1, Key2, or Key3 information.

Here is an example of the control group and option:

< GenTranStopOn >

TransactionErrors = Parameter1;Parameter2;Parameter3;

Parameter1--Enter No to turn the GenTranStopOn option off. The default is Yes.

Parameter2--Enter the name of the transaction file. To write out the error transaction, enter the name of the file where you want the extract file records written. If you omit the path, the system uses the DataPath option in the Data control group in the FSISYS.INI file to determine where to locate this file.

Parameter3--The system only looks at this parameter if you entered a file name for Parameter2. Enter Yes to tell the system to append the error transactions accumulated during this processing run to the file created in a prior run.

Enter No to tell the system to overwrite any existing file. If Parameter2 exists and you omit this parameter, the system defaults to No. If you enter Yes, you must remove the file when necessary. Keep in mind that over a series of processing runs, this file will expand in size.

Separate the parameters with semicolons (;).

The system records all errors and warnings it encounters during a processing run in the ERRORFILE.DAT file. In addition, it writes the extract file records of the transaction in error to the file you specify in Parameter2. This lets you inspect those transactions and determine the best way to proceed.

Here are some examples. This option:

TransactionErrors = No;..\Extracts\ErrorTransaction.dat;No;

Is the same as:

TransactionErrors = No;..\Extracts\ErrorTransaction.dat;;

Both let the GenTrn program continue processing subsequent transactions when errors occur. These options tell the GenTrn program to write the error transaction to a file named ERRORTRANSACTION.DAT, stored in the \Extracts directory.

TransactionErrors = No; ErrorTransaction.dat;Yes;

This option lets the GenTrn program continue processing subsequent transactions when errors occur. Since the path of the error transaction file was omitted, the system uses the DataPath option in the Data control group in the FSISYS.INI file to find the file so it can append any error transactions to the existing error transaction file.

TransactionErrors = No;;;

This option lets the GenTrn program continue processing subsequent transactions when errors occur. It does not, however, write out error transactions.

When using this option, you may encounter these errors:

-Problem in loading the XML file. Syntax error.

GenTrn

Transaction Error Report - System timestamp: Mon Dec 16 13:42:27 2002

DM12041: Error: FAP library error: Transaction:<1111111111>, area:<DXMLoadXMLRecs> code1:<48>, code2:<0>

msg:<XML Parse Error: The 15 chars before error=< <Key1>Comp1<>, the 8 chars starting at error=</Key1c>>>.

DM12041: Error : FAP library error: Transaction:<1111111111>, area:<DXMLoadXMLRecs> code1:<48>,code2:<0>msg:<mismatched tag at line 3 column 16>.

DM10293: Error: Error in <BuildTranRecs>: Unable to <DXMLoadXMLRecs()>.

Skip Transaction# <2>.

Warning: the specific info you see may not be the info for the error transaction. It may be the info on the last complete transaction.

==> Warning count: 0

==> Error count: 3

-No problem in loading the file, however, Key1 is omitted in the transaction.

GenTrn

Transaction Error Report - System timestamp: Fri Dec 13 13:52:13 2002

DM1002: Error: Required INI definition omitted.

Cannot locate INI group <Key1Table> with value = defined.

DM15062: Error in BuildTrnRecs(): Unable to GENGetDocSetNames(pRPS).

Skip Transaction# <3>.

==> Warning count: 0

==> Error count: 2

Example

< GenTranStopOn >

TransactionErrors = Parameter1;Parameter2;Parameter3;

Available

Release | _______
Patch |


GentrnDummyFields

Remarks

ONE

GentrnDummyFields Options

  • ExecutionMode
  • ONE
  • TIFF_File_GVM
  • TWO


ExecutionMode

[GentrnDummyFields]
ExecutionMode

ExecutionMode

[ GentrnDummyFields]

ExecutionMode =

Example

< GentrnDummyFields >

ExecutionMode = Multiple Step Execution

Available

Release | _______
Patch |


ONE

[GentrnDummyFields]
ONE

ONE

[ GentrnDummyFields]

ONE = File

Parameter | Description
File |

Remarks

Use this FSISYS.INI control group to get value for a variable defined in the TRNDFDFL.DFD file, which does not exist in the extract file.

Using this control group, you define the name of the variable on the left side (ONE and TWO in this example) and the variable's value on the right (1111111111 and 2222222222, respectively).

Note: The name of the variable on the left must match the variable name in the TRNDFDFL.DFD file.

Example

< GentrnDummyFields >

ONE = 1111111111

Available

Release | _______
Patch |


TIFF_File_GVM

[GentrnDummyFields]
TIFF_File_GVM

TIFF_File_GVM

[ GentrnDummyFields]

TIFF_File_GVM =

Example

< GentrnDummyFields >

TIFF_File_GVM = .\tif_gvm\t_gvm

Available

Release | _______
Patch |


TWO

[GentrnDummyFields]
TWO

TWO

[ GentrnDummyFields]

TWO = File

Parameter | Description
File |

Remarks

Use this FSISYS.INI control group to get value for a variable defined in the TRNDFDFL.DFD file, which does not exist in the extract file.

Using this control group, you define the name of the variable on the left side (ONE and TWO in this example) and the variable's value on the right (1111111111 and 2222222222, respectively).

Note: The name of the variable on the left must match the variable name in the TRNDFDFL.DFD file.

Example

< GentrnDummyFields >

TWO = 2222222222

Available

Release | _______
Patch |


Group1

Remarks

Title1

Group1 Options

  • Title1
  • Title2
  • Title3
  • Title4
  • Title5
  • Title6
  • Title7


Title1

[Group1]
Title1

Title1

Override the Retrieve dialog title for the KEY1 field.

[ Group1]

Title1 =

Parameter | Description
value | Override the Retrieve dialog title for the KEY1 field.

Example

< Group1 >

Title1 =

Available

Release | _______
Patch |


Title2

[Group1]
Title2

Title2

Override the Retrieve dialog title for the KEY2 field.

[ Group1]

Title2 =

Parameter | Description
value | Override the Retrieve dialog title for the KEY2 field.

Example

< Group1 >

Title2 =

Available

Release | _______
Patch |


Title3

[Group1]
Title3

Title3

Override the Retrieve dialog title for the KEYID field.

[ Group1]

Title3 =

Parameter | Description
value | Override the Retrieve dialog title for the KEYID field.

Example

< Group1 >

Title3 =

Available

Release | _______
Patch |


Title4

[Group1]
Title4

Title4

Override the Retrieve dialog title for the RUNDATE field.

[ Group1]

Title4 =

Parameter | Description
value | Override the Retrieve dialog title for the RUNDATE field

Example

< Group1 >

Title4 =

Available

Release | _______
Patch |


Title5

[Group1]
Title5

Title5

Use the Retrieve dialog title for the "Invoice flag" checkbox.

[ Group1]

Title5 =

Parameter | Description
value | Use the Retrieve dialog title for the "Invoice flag" checkbox. See next option.

Example

< Group1 >

Title5 =

Available

Release | _______
Patch |


Title6

[Group1]
Title6

Title6

Use the Retrieve dialog title for the "Claim flag" checkbox.

[ Group1]

Title6 =

Parameter | Description
value | Use the Retrieve dialog title for the "Claim flag" checkbox. The Invoice and Claim checkboxes only appear on th Retrieve dialog if these titles are declared.

Remarks

The Invoice and Claim checkboxes only appear on th Retrieve dialog box. These dialog checkboxes can be used to "filter" the retrieved list of archive records IF (and only IF) you have defined and used the corresponding record fields in the archive records.

Example

< Group1 >

Title6 =

Available

Release | _______
Patch |


Title7

[Group1]
Title7

Title7

This is the old version of the Retrieve dialog title list of column titles.

[ Group1]

Title7 =

Parameter | Description
value | This is the old version of the Retrieve dialog title list of column titles. The preferred method of doing column titles is via the definitions.

Example

< Group1 >

Title7 =

Available

Release | _______
Patch |


Help

Remarks

ShowIDs

Help Options

  • ShowIDs


ShowIDs

[Help]
ShowIDs

ShowIDs

Use this FAPCOMP.INI control group to set display options for help tables attached to variable fields.

[ Help]

ShowIDs = YN

Parameter | Description
Boolean |

Remarks

To display help IDs in help tables attached to variable fields, set this option to Yes.

Example

< Help >

ShowIDs = No

Available

Release | _______
Patch |


HorizontalRuler

Remarks

Use this FSIUSER.INI control group to specify the unit of measure for the horizontal ruler. By default, the system uses inches as the unit of measure. This means your rulers and grid lines are marked in increments based on inches. In the Processing System, you can select a different unit of measure by modifying your FSIUSER.INI or FSISYS.INI files. The sample entry above shows how to set the horizontal ruler and grid to centimeters.

Example

< HorizontalRuler >

Type = 4

HorizontalRuler Options

  • BackColor
  • ForeColor
  • Type


BackColor

[HorizontalRuler]
BackColor

BackColor

This FAPCOMP.INI group controls the display of the horizontal ruler in the Image Editor window.

[ HorizontalRuler]

BackColor = Color

Parameter | Description
Color |

Remarks

This option defines the background color of the horizontal ruler in the Image Editor window. This option value may be set in the Image Editor by choosing View, Options; then select the Rulers tab in the View Properties window. Click BACKGROUND in the Horizontal field to display the color selection window.

Example

< HorizontalRuler >

BackColor = 16776960

Available

Release | _______
Patch |


ForeColor

[HorizontalRuler]
ForeColor

ForeColor

This option defines the foreground color of the horizontal ruler (numbers and increments) in the Image Editor window.

[ HorizontalRuler]

ForeColor = Color

Parameter | Description
Color |

Remarks

This option value may be set in the Image Editor by choosing View, Options; then select the Rulers tab in the View Properties window. Click FOREGROUND in the Horizontal field to display the color selection window.

Example

< HorizontalRuler >

ForeColor = 0

Available

Release | _______
Patch |


Type

[HorizontalRuler]
Type

Type

Type determines the unit of measure for the horizontal ruler and grid.

[ HorizontalRuler]

Type = Edit

Parameter | Description
value | unit of measure (default is inches)

Remarks

Your options are explained in the table below:

To choose: none Set Type equal to: 0

To choose: FAP units (1/2400 of an inch) Set Type equal to: 1

To choose: Points Set Type equal to: 2

To choose: Inches Set Type equal to: 3

To choose: Metric (centimeters) Set Type equal to: 4

To choose: Picas Set Type equal to: 5

To choose: 1/8 inch increments Set Type equal to: 6

To choose: 1/6 inch increments Set Type equal to: 7

Note: You have the same unit of measurement options in the Image Editor. When you create an image, the system stores all measurement information in FAP units. Based on the user's INI file settings, the system automatically switches to the user's unit of measure for entry and display purposes. For example, if you create an image using

inches, a data entry user in the Processing System will see centimeters as the unit of measure if his or her INI files are set for centimeters.

Example

< HorizontalRuler >

Type = 4

Available

Release | _______
Patch |

Used By

AFEMAIN


HP LaserJet 4050 Series PS

HP LaserJet 4050 Series
PS

HP LaserJet 4050 Series PS Options

  • FullSupport


FullSupport

[HP LaserJet 4050 Series PS]
FullSupport

FullSupport

[ HP LaserJet 4050 Series PS]

FullSupport = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Use the FullSupport option to prevent problems with FAX drivers which could occur when you were printing from Documaker Workstation.

The GDI driver first looks for this INI option in the control group whose name reflects the Windows print driver, such as HP LaserJet 4050 Series PS.

If it finds the FullSupport option set to Yes, the GDI driver assumes the Windows print driver contains full print support and can handle form sets with mixed simplex and duplex forms (some FAX drivers crash when presented these kinds of forms).

Here is an example:

< HP LaserJet 4050 Series PS >

FullSupport = Yes

If not found there, the GDI driver looks for the FullSupport option in the control group for the printer type, such as PrtType:GDI. If you place the FullSupport option in the PrtType:GDI control group, it serves as a default for all GDI printers. Putting the option in for specific devices overrides this default.

Example

< HP LaserJet 4050 Series PS >

FullSupport = Yes

Available

Release | 10.3
Patch |


IMGFileList

Remarks

File

IMGFileList Options

  • File


File

[IMGFileList]
File

File

Use this FAPCOMP.INI control group

[ IMGFileList]

File = Path

Parameter | Description
Path |

Example

< IMGFileList >

File = E:\fap_ds\mstrres\rpex1\forms\a4.fap

Available

Release | _______
Patch |


ImpExpCombined

Remarks

File

ImpExpCombined Options

  • AppendedExport
  • Ext
  • Field
  • File
  • Path
  • Separator
  • SuppressDlg
  • WIPHeader


AppendedExport

[ImpExpCombined]
AppendedExport

AppendedExport

If you enter Yes, the data on the current form set data is appended to the existing file. The default is No.

[ ImpExpCombined]

AppendedExport = No

Parameter | Description
Boolean (no) | Default value is: No

Example

< ImpExpCombined >

AppendedExport = No

Available

Release | _______
Patch |


Ext

[ImpExpCombined]
Ext

Ext

(optional) Enter the default extension of the file. Defaults to DS.

[ ImpExpCombined]

Ext = DS

Parameter | Description
value | (optional) Enter the default extension of the file. Defaults to DS. Default value is: DS

Remarks

The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

Example

< ImpExpCombined >

Ext =

Available

Release | 10.1
Patch |


Field

[ImpExpCombined]
Field

Field

The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

[ ImpExpCombined]

Field =

Parameter | Description
value | The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

Remarks

For each field that should be imported to the WIP record line, you must include a line in the INI file. You can import as many fields as necessary.

Begin each line with FIELD= and use this syntax:

Field = The WIP field name;stringformat

The string format is the standard C sprintf function format. Here are some examples:

Field =KEY1;%-3.3s

Field =KEYID;%-10.10s

Example

< ImpExpCombined >

Field =

Available

Release | 10.1
Patch |


File

[ImpExpCombined]
File

File

The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

[ ImpExpCombined]

File = File

Parameter | Description
value | (optional) Enter the name of the import file.

Remarks

(optional) Enter the name of the import file.

The input file should contain WIP record information appended with standard NA and POL form set data.and POLFILE information.

Add the following option to your INI file to use this new import format:

< ImportFormats >

02 = ;DS;Full Document Import;TRNW32->TRNImportDS;

You can also add these options in the ImpExpCombined control group:

< ImpExpCombined >

File =

Path =

Ext =

SuppressDlg =

WIPHeader =

Separator =

Field =

Example

< ImpExpCombined >

File =

Available

Release | 10.1
Patch |


Path

[ImpExpCombined]
Path

Path

(optional) Enter the path for the import file if not included in the File option.

[ ImpExpCombined]

Path = Path

Parameter | Description
value | (optional) Enter the path for the import file if not included in the File option.

Remarks

The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

Example

< ImpExpCombined >

Path =

Available

Release | 10.1
Patch |


Separator

[ImpExpCombined]
Separator

Separator

The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

[ ImpExpCombined]

Separator =

Parameter | Description
value | The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

Remarks

(optional) Enter a text string to indicate an alternative separator for WIP fields. The default separator is a quotation mark ("). You could use another character as the separator, such as a semicolon (;).

If a variable record layout is being used for WIP information, field separators are essential. You can enter up to 39 characters. Choose a separator that is not likely to appear in any of the data you intend to output.

Example

< ImpExpCombined >

Separator =

Available

Release | 10.1
Patch |


SuppressDlg

[ImpExpCombined]
SuppressDlg

SuppressDlg

The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

[ ImpExpCombined]

SuppressDlg = No

Parameter | Description
boolean | (optional) Set to Yes to prevent the File Selection window from appearing if enough information is specified in the INI file. The default is No. Default value is: No

Remarks

(optional) Set to Yes to prevent the File Selection window from appearing if enough information is specified in the INI file. The default is No.

Example

< ImpExpCombined >

SuppressDlg =

Available

Release | 10.1
Patch |


WIPHeader

[ImpExpCombined]
WIPHeader

WIPHeader

(optional) Enter a text string to indicate where WIP record transactions begin. The default value is ' WIP= '.

[ ImpExpCombined]

WIPHeader = Edit

Parameter | Description
value | (optional) Enter a text string to indicate where WIP record transactions begin. The default value is ' WIP= '.

Remarks

The Entry system now lets you import files which contain WIP, NAFILE, and POLFILE information.

Enter the text for the header. You can enter as much text as you like, but avoid exceeding 1024 characters in the entire export record line. The default is WIP.

Example

< ImpExpCombined >

WIPHeader =

Available

Release | 10.1
Patch |


ImpFile

Remarks

Impfile_CD

ImpFile Options

  • Impfile_cd


Impfile_cd

[ImpFile]
Impfile_cd

Impfile_cd

This control group lets you designate a default directory for the Import Data window.

[ ImpFile]

Impfile_cd = YN

Parameter | Description
Boolean |

Remarks

The absence of this control group or its settings causes the system to default to the working directory as specified in the icon setting.

Example

< ImpFile >

Impfile_cd = N

Available

Release | _______
Patch |


ImpFile_CD

Remarks

The FSIUSER.INI ImpFile_cd control group lets you designate a default directory and filename for the import data window, and it lets you configure the import feature so it works the way you need it to work. The absence of this control group or its settings causes the system to default to the working directory as specified in the icon setting.

ImpFile_CD Options

  • Ext
  • File
  • IgnoreInvalidGroup
  • LOADHEADER
  • Path
  • ProtectFlds
  • SelectionFile


Ext

[ImpFile_CD]
Ext

Ext

The Ext option defines the import file extension.

[ ImpFile_CD]

Ext = .DAT

Parameter | Description
value | .DAT is the default Default value is: .DAT

Remarks

The default is .DAT. You may substitute a valid file extension but be sure to include the period. On the File window, the system will use this default extension to fill the selection list with available files. If you use the File= option and the file name you entered there includes an extension, that extension overrides one entered here.

Example

< ImpFile_CD >

Ext = .ext

Available

Release | _______
Patch |

Used By

AFEMAIN


File

[ImpFile_CD]
File

File

[ ImpFile_CD]

File = File

Parameter | Description
value | filename.ext (no default)

Remarks

Use this option to specify the import file which will appear as the default in the File window when users select the import file. Enter a valid file name of up to eight characters with a three-character extension. There is no default for this option.

Example

< ImpFile_CD >

File = filename

Available

Release | _______
Patch |

Used By

AFEMAIN


IgnoreInvalidGroup

[ImpFile_CD]
IgnoreInvalidGroup

IgnoreInvalidGroup

This option lets you ignore invalid groups in import headers.

[ ImpFile_CD]

IgnoreInvalidGroup = YN

Parameter | Description
Boolean (No) | Yes or No (default is No)

Remarks

This option lets you ignore invalid groups in import headers. The default value for this option is No. All KEY1 and KEY2 group names must correspond to those specified in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). If you turn this option on (which it is not recommended), the system attempts to import the data into the current form set. Since the system does not check the form group information, there is no way to make sure the data in the import file is valid for the current form set. Any information in the import file which does not correspond with fields in the form set simply disappears.

Example

< IMPFILE_CD >

IgnoreInvalidGroup = No

Available

Release | _______
Patch |

Used By

AFEMAIN


LOADHEADER

[ImpFile_CD]
LOADHEADER

LOADHEADER

[ ImpFile_CD]

LOADHEADER = Edit

Parameter | Description
value | value

Available

Release | _______
Patch |


Path

[ImpFile_CD]
Path

Path

There is no default for this option and without it, the current working directory will be assumed.

[ ImpFile_CD]

Path = Path

Parameter | Description
value | path name (no default)

Remarks

Assigning a value to this option will cause the starting directory presented in the File dialog to default to this location. If the File=option is used and the filename contains a pathname, that pathname will override this option.

Path defines the path and directory containing import files used by the Processing System. There is no default for this option. Specifying the import directory lets you map where your import files are located. If you omit this option, the system looks for your import files in the working directory specified during Icon Setup.

The system uses the path you enter here to determine the default directory displayed in the File window. If you enter a directory path in the File= option, that path overrides the one entered here.

Example

< ImpFile_CD >

Path = pathname

Available

Release | _______
Patch |

Used By

AFEMAIN


ProtectFlds

[ImpFile_CD]
ProtectFlds

ProtectFlds

The default for this option is Yes; and all imported data is protected from being changed by the user.

[ ImpFile_CD]

ProtectFlds = YN

Parameter | Description
Boolean (Yes) | Yes or No (default is Yes)

Remarks

The initial assumption for imported data is that it came from an external system. If the data is incorrect, then it needs to be corrected in the external system and re-exported for import again. If your system merely exports "suggestive" values for import that can be overriden by the user, then set this option to "No." Remember, that due to field propagation from one form to another, only the first occurence of any "formset" ;"Form" scope field will be editable.

Use this option to prevent the contents of imported fields from being changed from within the Processing System. This option defaults to Yes because import data typically comes from another application. If the data is incorrect, most users prefer to correct the data in the original application and re-import the data into the Processing System. If you are using the import file to provide default data, and you do not mind if users change the imported data,

Note: Keep in mind that normally the system only lets users change a global field the first time the field is accessed. Your system may function differently if it has been customized.

Example

<ImpFile_CD>

ProtectFlds = No

Available

Release | _______
Patch |

Used By

AFEMAIN


SelectionFile

[ImpFile_CD]
SelectionFile

SelectionFile

There is no default for this option and without it the user must specify a filename that contains the import selections.

[ ImpFile_CD]

SelectionFile = File

Parameter | Description
value | driver filename (no default)

Remarks

If this option is assigned a valid filename, then the File dialog for selecting the selection filename will default to this value and not appear.

The option indicates the driver file you want to use for selective imports. There is no default for this option. If you enter a valid driver file name here, the system will not display the File window. If you omit this option, or if the file name you enter is invalid, the system will display the File window so the user can select a driver file to import.

Example

< ImpFile_CD >

SelectionFile = filename

Available

Release | _______
Patch |

Used By

AFEMAIN


Import_Data

Remarks

Import_File

Import_Data Options

  • Import_File


Import_File

[Import_Data]
Import_File

Import_File

This example imports the F_INI.XML file from the \export directory.

[ Import_Data]

Import_File = Edit

Parameter | Description
value | This example imports the F_INI.XML file from the \export directory.

Remarks

Using this file, the GenData program creates the recipient batch, NA, POL, and NewTrn files needed for GenPrint and GenArc processing.

Example

< Import_Data >

Import_File = .\Export\F_File.xml\

Available

Release | _______
Patch |


ImportExtract

Remarks

IndexDuplicateFields

ImportExtract Options

  • IndexDuplicateFields


IndexDuplicateFields

[ImportExtract]
IndexDuplicateFields

IndexDuplicateFields

MAPFROMIMPORTDATA

[ ImportExtract]

IndexDuplicateFields =

Parameter | Description
value | Use this field level (level 4) rule to map imported data from an internal dictionary to a field, as opposed to mapping from an extract file. Normally, you use this rule with either the ImportFile or ImportExtract rules, however, you can use this rule with any preceding rule that fills in field dictionary values.

Remarks

Use this field level (level 4) rule to map imported data from an internal dictionary to a field, as opposed to mapping from an extract file. Normally, you use this rule with either the ImportFile or ImportExtract rules, however, you can use this rule with any preceding rule that fills in field dictionary values.

By default, this rule checks for a dictionary value starting with the image dictionary, then the form dictionary, and finally the form set (global) dictionary. The search ends as soon as the rule finds a value for the field.

If no dictionary entry is found for the field, the field remains blank. Use the Required flags in the rule definition to control whether an empty field is considered an error.

NOTE: For some legacy implementations, this rule was registered under the name NoOpImp.

If you do not use this rule, you must use the ReplaceNoOpFunc rule and make sure that all of the fields for each DDT file are set to NoOpFunc.

Syntax MapFromImportData( )

You can use the optional INDEX parameter to specify a particular dictionary instance of the field to use. This is only useful if you use the ImportFile or ImportExtract rules to import form set data.

For the ImportFile rule, to support field instances you must include this INI option:

< ImportFile >

IndexDuplicateFields = Yes

For the ImportExtract rule, to support field instances you must include this INI option:

< ImportExtract >

IndexDuplicateFields = Yes

Normally, duplicate field entries found in the import file are ignored. If, however, you enter Yes, each instance is stored in a separate dictionary entry.

NOTE: Field instance (indexing) only applies to field data stored in the form set (global) dictionary.

The parameter value to specify indexing has this syntax:

INDEX(option,...)

Where option is a keyword that indicates how to calculate the dictionary instance to use or a constant value to use as the index.

Example

< ImportFile >

IndexDuplicateFields = Yes

Available

Release | _______
Patch |


ImportFile

Remarks

IndexDuplicateFields

ImportFile Options

  • IndexDuplicateFields


IndexDuplicateFields

[ImportFile]
IndexDuplicateFields

IndexDuplicateFields

MAPFROMIMPORTDATA

[ ImportFile]

IndexDuplicateFields =

Parameter | Description
value | Use this field level (level 4) rule to map imported data from an internal dictionary to a field, as opposed to mapping from an extract file. Normally, you use this rule with either the ImportFile or ImportExtract rules, however, you can use this rule with any preceding rule that fills in field dictionary values.

Remarks

Use this field level (level 4) rule to map imported data from an internal dictionary to a field, as opposed to mapping from an extract file. Normally, you use this rule with either the ImportFile or ImportExtract rules, however, you can use this rule with any preceding rule that fills in field dictionary values.

By default, this rule checks for a dictionary value starting with the image dictionary, then the form dictionary, and finally the form set (global) dictionary. The search ends as soon as the rule finds a value for the field.

If no dictionary entry is found for the field, the field remains blank. Use the Required flags in the rule definition to control whether an empty field is considered an error.

NOTE: For some legacy implementations, this rule was registered under the name NoOpImp.

If you do not use this rule, you must use the ReplaceNoOpFunc rule and make sure that all of the fields for each DDT file are set to NoOpFunc.

Syntax MapFromImportData( )

You can use the optional INDEX parameter to specify a particular dictionary instance of the field to use. This is only useful if you use the ImportFile or ImportExtract rules to import form set data.

For the ImportFile rule, to support field instances you must include this INI option:

< ImportFile >

IndexDuplicateFields = Yes

For the ImportExtract rule, to support field instances you must include this INI option:

< ImportExtract >

IndexDuplicateFields = Yes

Normally, duplicate field entries found in the import file are ignored. If, however, you enter Yes, each instance is stored in a separate dictionary entry.

NOTE: Field instance (indexing) only applies to field data stored in the form set (global) dictionary.

The parameter value to specify indexing has this syntax:

INDEX(option,...)

Where option is a keyword that indicates how to calculate the dictionary instance to use or a constant value to use as the index.

Example

< ImportExtract >

IndexDuplicateFields = Yes

Available

Release | _______
Patch |


ImportFormats

Remarks

01

ImportFormats Options

  • 01
  • 02
  • ImportFormats


01

[ImportFormats]
01

01

User defined value that determines the sort order for the Import funcions declared within this group.

[ ImportFormats]

01 = Edit

Parameter | Description
value | User defined value that determines the sort order for the Import funcions declared within this group.

Remarks

This FSISYS.INI control group enables the Processing System to perform import functions. The options contained in this control group specify which type of import function is available. If the control group or an option line is omitted, the Processing System import function is disabled. Use this FSISYS.INI control group to define a value in an extract file and its corresponding name in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) and trigger files.

01 =;ST;Standard Import;TRNW32->TRNImport

Use this option to enable the Standard Import function in the Processing System. A standard import file contains data for a specific form set. The import file contains a header record which the system uses to match the data with the appropriate form set. When you select a Standard Import function, the system displays a window which contains a list of import files. You must know what data the import files contain, and what type of policy transaction the data relates to, to choose the proper import file.

The option format is as follows:

01=;NOT USED;DESCRIPTION; DLL NAME->FUNCTION NAME

You can modify the default format to customize the import format selection displayed for users, and you can modify the numeric value to display a format in a different order. Change only the numeric and the description parameters as desired, using the table above as a guideline. The format description appears in the Import window when a user selects the import option.

Example

< ImportFormats >

01 =;TD;Token Data;TRNW32->TRNImport;

Available

Release | _______
Patch |


02

[ImportFormats]
02

02

User defined value that determines the sort order for the Import funcions declared within this group.

[ ImportFormats]

02 = Edit

Parameter | Description
value | User defined value that determines the sort order for the Import funcions declared within this group.

Remarks

Use this option to enable the Selective Import function in the Processing System. A Selective Import function contains a driver file and import files. The driver file filters the import files based on the user's policy selections. The driver file recognizes the current user and the selected transaction type, and displays only the import files which correspond to that user ID and policy transaction. The driver file can include a brief description of each import file, which helps the user select the appropriate file.

The option format is as follows:

02=;NOT USED;DESCRIPTION; DLL NAME->FUNCTION NAME

You can modify the default format to customize the import format selection displayed for users, and you can modify the numeric value to display a format in a different order. Change only the numeric and the description parameters as desired, using the table above as a guideline. The format description appears in the Import window when a user selects the import option.

Example

< ImportFormats >

02 =;SI;Selective Import;TRNW32->TRNSelImport

Available

Release | _______
Patch |


[ImportFormats]
ImportFormats

ImportFormats

The type of formats that you are able to import.

[ ImportFormats]

ImportFormats =

Available

Release | _______
Patch |


ImportFromArchive

ImportFromArchive Options

  • ProtectFlds
  • SelectForms
  • TransferRecord


ProtectFlds

[ImportFromArchive]
ProtectFlds

ProtectFlds

[ ImportFromArchive]

ProtectFlds = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

Set the ProtectFlds option to No and then you can modify the data imported from archive to the entry form in the Documaker Workstation. The default is Yes, that means the data imported from archive will be protected from change.

Example

< ImportFromArchive >

ProtectFlds = No

Available

Release | _______
Patch |

Used By

TRNLIB


SelectForms

[ImportFromArchive]
SelectForms

SelectForms

520 IMPORTING ARCHIVE DATA WITH FORMS AND IMAGES

[ ImportFromArchive]

SelectForms = No

Parameter | Description
boolean (No) | The system can now transfer data when importing forms and images--if the form and image names match. Default value is: No

Remarks

The system can now transfer data when importing forms and images--if the form and image names match.

For instance, if the archived form set consists of FORM_A and FORM_B and you currently have FORM_A and FORM_B_v2 selected, the system transfers the form data from FORM_A, plus any global fields set up for the entire form set. Since FORM_B does not match FORM_B_v2, no form or image level information is transferred between the form sets. Similar name matching is also required at the image levels.

To use this feature, you must include these new INI options.

< ImportFromArchive >

SelectForms = Yes

TransferRecord = Yes

The default for both options is No, to be compatible with the original release of the ImportFromArchive feature.

If you set the SelectForms option to Yes, the import operation selects the forms based on matching forms found in the archive. Any prior form selection made by the user is removed before the import begins.

If you set the TransferRecord option to Yes, the archive index record information is transferred to the WIP record information and the system updates the Form Selection window to show any changed values. For instance, you would set this option to Yes if you want the Key1, Key2, KeyID, and Description fields from the archived record used on your current form selection.

Example

< ImportFromArchive >

SelectForms = Yes

Available

Release | 10.1
Patch |


TransferRecord

[ImportFromArchive]
TransferRecord

TransferRecord

520 IMPORTING ARCHIVE DATA WITH FORMS AND IMAGES

[ ImportFromArchive]

TransferRecord = No

Parameter | Description
boolean (No) | The system can now transfer data when importing forms and images--if the form and image names match. Default value is: No

Remarks

The system can now transfer data when importing forms and images--if the form and image names match.

For instance, if the archived form set consists of FORM_A and FORM_B and you currently have FORM_A and FORM_B_v2 selected, the system transfers the form data from FORM_A, plus any global fields set up for the entire form set. Since FORM_B does not match FORM_B_v2, no form or image level information is transferred between the form sets. Similar name matching is also required at the image levels.

To use this feature, you must include these new INI options.

< ImportFromArchive >

SelectForms = Yes

TransferRecord = Yes

The default for both options is No, to be compatible with the original release of the ImportFromArchive feature.

If you set the SelectForms option to Yes, the import operation selects the forms based on matching forms found in the archive. Any prior form selection made by the user is removed before the import begins.

If you set the TransferRecord option to Yes, the archive index record information is transferred to the WIP record information and the system updates the Form Selection window to show any changed values. For instance, you would set this option to Yes if you want the Key1, Key2, KeyID, and Description fields from the archived record used on your current form selection.

Example

< ImportFromArchive >

TransferRecord = Yes

Available

Release | 10.1
Patch |


INI2XML

INI2XML Options

DownloadURL

DownloadScript

DownloadUserid

DownloadPassword


DownloadURL

[INI2XML]
DownloadURL

DownloadURL

[ INI2XML ]

DownloadURL = www.oracle.com

Parameter | Description
URL | Enter the desired URL

Remarks

This can be the web site address, or machine name on the network. It is similar to the PUTURL option which may already be in the INI2XML control group.

Here are some examples

localhost

www.oracle.com

It can also be an IP address. The exact value is specific to your implementation.

Example

< INI2XML >

DownloadURL = localhost

Available

Release | 11.4
Patch |

See Also

DownloadScript

DownloadUserid

DownloadPassword


DownloadScript

[INI2XML]
DownloadScript

DownloadScript

[ INI2XML ]

DownloadScript = myscript

Parameter | Description
name | Enter the desired script name

Remarks

This is the part of the URL which points to the location within the host for the installation file. It should contain the name of the installation file.

This is similar to the SCRIPT option which usually points to the wipsave.asp or wipsave.jsp file for iDocumaker. The exact value is specific to your implementation.

Example

< INI2XML >

DownloadScript = doc-prog/data/install/wipedit.dpi

Available

Release | 11.4
Patch |

See Also

DownloadURL

DownloadUserid

DownloadPassword


DownloadUserid

[INI2XML]
DownloadUserid

DownloadUserid

[ INI2XML ]

DownloadUserid = myid

Parameter | Description
name | Enter the user ID used for authentication.

Remarks

This option may be encrypted.

Example

< INI2XML >

DownloadUserid = *****

Available

Release | 11.4
Patch |

See Also

DownloadURL

DownloadScript

DownloadPassword


DownloadPassword

[INI2XML]
DownloadPassword

DownloadPassword

[ INI2XML ]

DownloadPassword = pass

Parameter | Description
name | Enter the password used for authentication.

Remarks

This option may be encrypted.

Example

< INI2XML >

DownloadPassword = *****

Available

Release | 11.4
Patch |

See Also

DownloadURL

DownloadScript

DownloadUserid


INIGroup

INIGroup Options

[ INIGroup]

Option1 = Edit

Parameter | Description
value | Use the new DALRUN and DALVAR built-in functions to execute DAL scripts or get DAL variable information you can use to complete INI options.

Remarks

Use the new DALRUN and DALVAR built-in functions to execute DAL scripts or get DAL variable information you can use to complete ini options. For instance, you can use this to map unique recipient information into batch records.

These functions are automatically registered when DAL is initialized. Several programs can initialize DAL, such as the GenData and GenPrint programs, the AFEMAIN program (including RACLIB/RACCO), Image Editor, and various utilities such as ARCRET, ARCSPLIT, and DALRUN.

NOTE: If you try to use these functions in systems that do not initialize DAL, an incorrect INI value is returned.

Here is an example:

< INIGroup >

Option1 = ~DALRUN MY.DAL

Option2 = ~DALVAL XYZ_VAL

If the program requests Option1, the script MY.DAL is executed and the resulting option is assigned. If the program requests Option2, the DAL variable XYZ_VAL is located and its contents are assigned to the INI option.

Using this function with the GenPrint program to initialize INI options can produce errors. At the point in the GenPrint program that INI files are loaded, the system may not have processed enough information to use some DAL functions in the script executed by this function. Here is an example:

< PDFNames >

Archive = c:..\Output\~GetEnv ExtrFileName ~ Archive_Name

< Printer2 >

Port = <PDFNames> Archive =

Here is the problem statement from the DAL script (ARCHIVE_NAME.DAL):

f_name = "_" & GVM("RunDate") & "_A" & newcount & "_" & GVM("PolicyNumber")

Instead you will receive an error message similar to the following.

DM12041: Error : FAP library error: Transaction:<>,
area:<..\C\genbannr.c,Jun 23 2004 20:14:14,400.110.002,GENDALErrorNotify>

code1:<0>, code2:<0>

msg:<Script: c:..\Deflib\Archive_Name.dal

Line: 6 Col: 33 Err: 15 Token: )

Msg: No result value returned>.

In this example, the GVM values, RunDate and PolicyNumber have not been loaded.

Example

< INIGroup >

Option1 = ~DALRUN MY.DAL

Option2 = ~DALVAL XYZ_VAL

Available

Release | 10.1
Patch | 106


INIFiles

Example

< INIFiles >

File = fsisys2.ini

INIFiles Options

  • File


File

[INIFiles]
File

File

Name of an additional INI file to read.

[ INIFiles]

File = File

Parameter | Description
name | Name of an INI file

Remarks

More than one File option can be specified.

Q: In the Documaker WS and RPS systems, can I load an INI file from another INI file?

A: Yes. You can use the following option to do this:

< INIFiles >

File = filename.ini

This feature works with the FSISYS.INI and FSIUSER.INI files. After loading the FSIUSER.INI file, the system then looks for the FSISYS.INI file. After loading the FSISYS.INI file, the system looks for the INIFiles control group. The system then loads any file you specify in the INIFiles control group.

Example

< INIFiles >

File = fsisys2.ini

File = fsisys3.ini

Available

Release | _______
Patch |


INISubs

Remarks

Use <INISubs> to define substitutions for common shortened names such as TIMES which is a substitution for Times New Roman or E.EXE which is used for NOTEPAD.EXE.

Defaults:

<INISubs>

E.EXE = NOTEPAD.EXE

EPM.EXE = NOTEPAD.EXE

CMD.EXE = COMMAND.COM

HELV = ARIAL

UNIVERS = ARIAL

UNIVERS ATT = ARIAL

COURIER = COURIER NEW

TMS RMN = TIMES NEW ROMAN

TIMES = TIMES NEW ROMAN

TIMES ROMAN = TIMES NEW ROMAN

THORNDALE AMT = TIMES NEW ROMAN

LETTER GOTHIC MT = COURIER NEW

LETTER GOTHIC = COURIER NEW

CUMBERLAND AMT = COURIER NEW

ANDALE DUOSPACE WT = COURIER NEW

ALBANY AMT = ARIAL

DOCUDINGS = WINGDINGS


Key1Table

Remarks

This group is used to map a short name that might be in your extract file to the long name in the BDF file. The group is no longer necessary because Aliases can be defined within the BDF file.

Syntax

short_name = long_name

Mapping KEY1 and KEY2 Aliases within a BDF File

Documaker Studio now supports the automatic mapping of group alias names into the Key1Table and Key2Table control groups. These groups are used to map a short name that might be in your extract file to the long name in the BDF file.

Studio lets you identify any number of aliases that, when encountered in a batch operation, should map to the standard group name. This means you no longer have to edit the INI file to add alias group names under the Key1Table or Key2Table control groups.

When a batch run starts, the system loads the BDF file and automatially assigns the defined alias names for each group to the appropriate INI setting. This lets the GenData program run as expected without you having to manually define the values.

Example

< KEY1TABLE >

JD = John Doel

FP = First Protection

Available

Release | _______
Patch |


Key2Table

Remarks

This group is used to map a short name that might be in your extract file to the long name in the BDF file. The group is no longer necessary because Aliases can be defined within the BDF file.

Syntax

short_name = long_name

Mapping KEY1 and KEY2 Aliases within a BDF File

Documaker Studio now supports the automatic mapping of group alias names into the Key1Table and Key2Table control groups. These groups are used to map a short name that might be in your extract file to the long name in the BDF file.

Studio lets you identify any number of aliases that, when encountered in a batch operation, should map to the standard group name. This means you no longer have to edit the INI file to add alias group names under the Key1Table or Key2Table control groups.

When a batch run starts, the system loads the BDF file and automatially assigns the defined alias names for each group to the appropriate INI setting. This lets the GenData program run as expected without you having to manually define the values.

Example

< KEY2TABLE >

JD = John Doel

FP = First Protection

Available

Release | _______
Patch |


Key3Table

Remarks

This group is used to map a short name that might be in your extract file to the long name in the BDF file. The group is no longer necessary because Aliases can be defined within the BDF file.

Syntax

short_name = long_name

Mapping KEY1 and KEY2 Aliases within a BDF File

Documaker Studio now supports the automatic mapping of group alias names into the Key1Table and Key2Table control groups. These groups are used to map a short name that might be in your extract file to the long name in the BDF file.

Studio lets you identify any number of aliases that, when encountered in a batch operation, should map to the standard group name. This means you no longer have to edit the INI file to add alias group names under the Key1Table or Key2Table control groups.

When a batch run starts, the system loads the BDF file and automatially assigns the defined alias names for each group to the appropriate INI setting. This lets the GenData program run as expected without you having to manually define the values.

Example

< KEY3TABLE >

JD = John Doel

FP = First Protection

Available

Release | _______
Patch |


Keyed Files

Remarks

MessageDataBase

Keyed Files Options

  • MessageDataBase


MessageDataBase

[Keyed Files]
MessageDataBase

MessageDataBase

[ Keyed Files]

MessageDataBase =

Example

< Keyed Files >

MessageDataBase = Messages 0 11

Available

Release | _______
Patch |


Language

Remarks

Use the < Language > control group to specify the language version of the Documaker System (English, French Canadian) by setting the INI values for the Master Resource Library and other system components.

Example

Here's an example of an English language group found in ENGUSER.INI.

< Language >

HelpFile = FPSO2US1

MasterResource = SAMPCO

RCDLL = RCENGOS2

Here's an example of a French Canadian language group found in

FCHUSER.INI.

< Language >

RCDLL = RCFCHOS2

HelpFile = FPSO2CF1

MasterResource = SAMPCOFCH

International Considerations

ENGUSER.INI File

The ENGUSER.INI file is one of the initialization (INI) files used bythe DAP system to set system parameters and to enable or disable system features.

The ENGUSER.INI file contains information about setting up the system for an English-speaking user. This includes information that tells the system which menu file to use (so the system menus appear in the language of the user), and which Help file to display.

FCHUSER.INI File

The FCHUSER.INI file is one of the initialization (INI) files used by the DAP system to set system parameters and to enable or disable system features.

The FCHUSER.INI file contains information about setting up the system for a Canadian French user. This includes information that tells the system where to find the translated forms, which menu file to use (so the system menus appear in the language of the user), and which Help file to display.

Language Options

  • CodePage
  • HelpFile
  • Locale
  • MasterResource
  • RCDLL


CodePage

[Language]
CodePage

CodePage

Specifies the system codepage setting to be used for interpreting single byte (non-Unicode) text.

[ Language]

CodePage = 1252

Parameter

Description

CodePage

Supported code pages are:

  • 1250
  • 1251
  • 1252
  • 1253
  • 1254
  • 1257
  • 65001

The default is 1252

Example

Use this option to set the code page to use whenever character data has to be operated on, and the encoding is not self-describing or explicitly specified in some way, and it is necessary to know the encoding of the source data in order to operate on it. For example, if you have DAL scripts and INI files that are not UTF-8 encoded and that contain extended ASCII characters (code points 128 to 255), set the code page so that these characters can be interpreted correctly.

Code Page | Language Support
1250 | Enables support for the following “Eastern European” languages: Polish, Czech, Slovak, Hungarian, Slovene, Bosnian, Croatian, Serbian (Latin script), Romanian and Albanian.
1251 | Enables support for the Russian, Bulgarian and other languages that use the Cyrillic alphabet.
1252 | Enables support for all “Western” languages such as Afrikaans, English, Danish, Dutch, Finnish, French, German, Italian, Portuguese, Spanish, and Welsh.
1253 | Enables support for the Modern Greek language.
1254 | Enables support for the Turkish language.
1257 | Enables support for the following languages: Estonian, Latvian, and Lithuanian.
65001 | UTF-8 encoded Unicode. Represents multi-byte Unicode, for any language, but specifically for languages such as Chinese Simplified, Chinese Traditional, Japanese, Korean, and Thai.

< Language >

CodePage = 1252

Available

Release | 12.1
Patch |


HelpFile

[Language]
HelpFile

HelpFile

Specifies the name of the Help file to display.

[ Language]

HelpFile = File

Parameter | Description
Name | Help file name.

Example

< Language >

HelpFile = FPSWNUS1

For French Canadian:

< Language >

HelpFile = FPSWNCF1

Available

Release | _______
Patch |


Locale

[Language]
Locale

Locale

Lets you set the default country code. The system is distributed with the country code default set to US.

[ Language]

Locale = USD

Parameter

Description

value

Locale

Values can be

  • ARS - Argentina\Spanish
  • ATS - Austria\German
  • AUD - Australia\English
  • BED - Belgium\Dutch
  • BEF - Belgium\French
  • BOB - Bolivia\Spanish
  • BRC - Brazil\Portuguese
  • CAD - Canada\French
  • CAN - Canada\English
  • CHF - Switzerland\German
  • CHH - Switzerland\French
  • CHI - Switzerland\Italian
  • CHL - Liechtenstein\German
  • CLP - Chile\Spanish
  • COP - Columbia\Spanish
  • CRC - Costa Rica\Spanish
  • DEM - Germany\German
  • DKK - Denmark\Danish
  • ECS - Ecuador\Spanish
  • ESB - Spain\Basque
  • ESC - Spain\Catalan
  • ESP - Spain\Spanish
  • FLX - France\French
  • FMK - Finland\Swedish
  • FRF - Luxembourg\French
  • GBP - United Kingdom\English
  • GTQ - Guatemala\Spanish
  • IDR - Indonesia\Indonesian
  • IEP - Ireland\English
  • ISK - Iceland\Icelandic
  • LUX - Luxembourg\German
  • MXN - Mexico\Spanish
  • NLG - The Netherlands\Dutch
  • NOK - Norway\Norwegian
  • NZD - New Zealand\English
  • PAB - Panama\Spanish
  • PES - Peru\Spanish
  • PTE - Portugal\Portuguese
  • PYG - Paraguay\Spanish
  • SEK - Sweden\Swedish
  • ITL - Italy\Italian
  • USD - United States\English
  • UYU - Uruguay\Spanish
  • VEB - Venezuela\Spanish
  • ZAA - South Africa\Afrikaans
  • ZAR - South Africa\English

Default value is: USD

Remarks

Adding this INI to the FAPCOMP.INI file lets you to control the paper size in Image Editor and Form Set Manager. The system defaults to A4 instead of letter depending on the country code selected.

The Locale option controls the default date format, based on the country code selected.

Adding this option to FAPCOMP.INI or FSISYS.INI\FSIUSER.INI file controls the default country in the Spelling Options window.

Adding this option to the FSISYS or FSIUSER has an effect on the DAL Date functions if locality is not specified in the scripts.

Setting the INI options will also affect how the system chooses month names in charts.

For example if you set the local to ARS (Argentina, Spanish) and you set your chart labels to month (short or long), the month will show in Spanish instead of English.

This option also affects SysDate, FmtDate, and FmtNum rules. If you specify a locale parameter in the format mask for these rules, that parameter determines the locale. If not, these rules use the Locale option as a default.

NOTE: If you set a default locale, and the paper size does not change appropriately, check the Type INI option. For example, suppose the default locale is set to BEF (Belgium). This indicates the system should use A4 paper. If, however, the paper size shows up as Letter, check the Type option in the Paper control group.

Also, if the Type option is set to something like nFLX, check the DefaultVarField option. You may need to delete this option to get the system to use the locale specified in the Locale option.

CODE Country\Language

ARS = Argentina\Spanish

AUD = Australia\English

ATS = Austria\German

BED = Belgium\Dutch

BEF = Belgium\French

BOB = Bolivia\Spanish

BRC = Brazil\Portuguese

CAN = Canada\English

CAD = Canada\French

CLP = Chile\Spanish

COP = Columbia\Spanish

CRC = Costa Rica\Spanish

DKK = Denmark\Danish

ECS = Ecuador\Spanish

FLX = France\French

FMK = Finland\Swedish

DEM = Germany\German

GTQ = Guatemala\Spanish

ISK = Iceland\Icelandic

IDR = Indonesia\Indonesian

TL = Italy\Italian

IEP = Ireland\English

CHL = Liechtenstein\German

LUX = Luxembourg\German

FRF = Luxembourg\French

MXN = Mexico\Spanish

NLG = The Netherlands\Dutch

NZD = New Zealand\English

NOK = Norway\Norwegian

PAB = Panama\Spanish

PYG = Paraguay\Spanish

PES = Peru\Spanish

PTE = Portugal\Portuguese

ZAA = South Africa\Afrikaans

ZAR = South Africa\English

ESB = Spain\Basque

ESC = Spain\Catalan

ESP = Spain\Spanish

SEK = Sweden\Swedish

CHF = Switzerland\German

CHH = Switzerland\French

CHI = Switzerland\Italian

GBP = United Kingdom\English

USD = United States\English

UYU = Uruguay\Spanish

VEB = Venezuela\Spanish

Example

< Language >

Locale = XXX

Available

Release | 10.1
Patch |


MasterResource

[Language]
MasterResource

MasterResource

Specifies the Master Resource library.

[ Language]

MasterResource = File

Parameter | Description
Name | Master Resource name.

Example

< Language >

MasterResource = SAMPCO

For French Canadian:

< Language >

MasterResource = SAMPCOFCH

Available

Release | _______
Patch |


RCDLL

[Language]
RCDLL

RCDLL

Names the DLL (Dynamic Link Library) to load for external function calls.

[ Language]

RCDLL = File

Parameter | Description
DLLName | Resource file name.

Example

< Language >

RCDLL = RCENGW32

For French Canadian:

< Language >

RCDLL = RCFCHW32

Available

Release | _______
Patch |


Library:XXX

Library:
XXX

Remarks

DBTable

Library:XXX Options

  • DBTable
  • RetrieveFile
  • RetrieveMemFile
  • SaveFile


DBTable

[Library:XXX]
DBTable

DBTable

1162 Storing Library Manager Objects in Database Tables.

[ Library:XXX]

DBTable = Edit

Parameter | Description
value | Use this INI option to specify the database table you want to use for the data portion of the library.

Remarks

This feature lets you include the index and data portions of the Library Manager repository in a Data Base Management System (DBMS), such as DB2 and SQL server.

Use this INI option to specify the database table you want to use for the data portion of the library.

< Library:LBYI >

DBTable = LBYD

For instance, if you are running the LBRYMGRW utility and you want to indicate you are using a database table for the data portion, you could enter:

LBRYMGRW /LBY=LBYI /RSP=RESPONSE.RSP /INI=FSIUSER.INI

and specify the INI control group and option above. LBYI and LBYD name the index and data tables you want use. This example runs the response file and stores the objects, such as FAP, DDT, DAL, and LOG files, in the LBYD database table. The index for the objects is stored in the LBYI table.

This feature will allow both the Index and Data portions of the Library Manager repository to be contained in Database files such as DB2.

The LBRYMGR utility, which allows a user to create a "response" file or to run the response file to populate a Library Manager Library, supports a new parameter, /LBYD= . The LBYD parameter stands for "Library Data" and it allows the user to specify a DBMS table to use to contain the Library Manager "data" (when not using DBMS this "data" is written to the *.lby file). So, if a user wishes to run a response file and have the response file objects stored into DB2 tables, the following command might be entered:

LBRYMGRW /LBY=LBYI /LBYD=LBYD /RSP=RESPONSE.RSP /INI=FSIUSER.INI

In addition to the use of the /LBYD parameter, the user will need to setup several INI options to cause the LBYI and LBYD tables to be created in a DB2 DBMS.

Sample INI options to support the storing of Library Manager objects (FAPs, DDTs, LOGOs) into DB2 tables follows:

[ MasterResource ]

DDTFile = LBYI # tells RP to look for DDTs in the LBYI index table

FormFile = LBYI # tells RP to look for FAPs in the LBYI index table

FormFileData = LBYD # (** NEW **) tells RP to look for the data portion of the objects in the LBYD table

LogoFile = LBYI # tells RP to look for LOGOs in the LBYI index table

[DBHandler:DB2]

Database = LBYLIB # database name

User = xxx # userid to connect to DB2 with

Password = yyy # password

Debug = Yes # default is No - set to Yes to produce "trace" file (degrades performance)

[DBTable:LBYI]

DBHandler = DB2 # indicates the LBYI table should be handled with DB2

[DBTable:LBYD]

DBHandler = DB2 # indicates the LBYD table should be handled with DB2

[DBTable:CATALOG]

DBHandler = DB2 # indicates the Catalog table should be handled with DB2

[Debug_Switches]

LBYLIB = Yes # (** NEW **) default is No - set to Yes to produce "trace" file containing tracing information

[DB2_FileConvert]

LBYI = DAP101_LBYI_R1 # maps LBYI to a table name greater than 8 characters

LBYD = DAP101_LBYD_R1 # maps LBYD to a table name greater than 8 characters

CATALOG = DAP101_CAT_R1 # maps CATALOG to a table name greater than 8 characters

Example

< Library:LBYI >

DBTable = LBYD

Available

Release | _______
Patch |


RetrieveFile

[Library:XXX]
RetrieveFile

RetrieveFile

This option is an internal/system stetting that defines the function to retrieve a file. This option should not be defined in your INI files.

[ Library:xxx]

RetrieveFile =

Parameter | Description
value | This option defines the function to retrieve a file.

Remarks

This option defines the function to retrieve a file.

Example

< Library:xxx >

RetrieveFile =

Available

Release

Patch


RetrieveMemFile

[Library:xxx]
RetrieveMemFile

RetrieveMemFile

This option defines the function to retrieve a file.

[ Library:xxx]

RetrieveMemFile =

Parameter | Description
value | This option defines the function to retrieve a file.

Remarks

This option defines the function to retrieve a file.

Example

< Library:xxx >

RetrieveMemFile =

Available

Release

Patch


SaveFile

[Library:xxx]
SaveFile

SaveFile

This option .

[ Library:xxx]

SaveFile =

Parameter | Description
value | This option defines the function to save a file.

Remarks

This option defines the function to save a file.

Example

< Library:xxx >

SaveFile =

Available

Release

Patch


LibraryTier:XXX

LibraryTier:
XXX

Tiers reflect the different stages of resource development. Studio defines five categories of tiers:

  • Development (DEV)
  • Unit Test (UNIT)
  • System Test (SYST)
  • Model Office (MODL)
  • Production (PROD)

Each tier category has a separate INI group designated by the abbreviated name. For example, the Development tier category has settings specified by the INI group <LibraryTier:DEV>

You can create as many libraries within each tier category as you want. Within each category, however, you can only designate one tier as the primary (001) library for that category. This is designated with a setting similar to this:

<LibraryTier:XXX>

001= Library Name; Ini File; Tier Description

NOTE: You should allow DMStudio Settings Manager maintain these INI values for you and not manipulate them by hand.

When you change tiers, you are indicating that you want to change your focus into a new library. When you work within that tier, Studio shows you only those resources that have been promoted to that level. The idea is that you should be able to test resources at each level to make sure only those resources that should are promoted forward. This is typically accomplished by using the Mode and Status library record members as promotion criteria.

Tiers

  • 001 (primary tier library)
  • 002 (additional tier library)


001

LibraryTier
001

001

Library tier.

[ LibraryTier:DEV]

001 = Primary

Parameter | Description
value | This is the primary tier library within the given category

Remarks

Tiers reflect the different stages of resource development. Studio defines five categories of tiers:

  • Development (DEV)
  • Unit Test (UNIT)
  • System Test (SYST)
  • Model Office (MODL)
  • Production (PROD)

You do not have to use every category. For instance, you could skip Model Office or Unit Test, though we recommend that you thoroughly test resources before you place them into production.

You can create as many tier libraries within each category as you want. Within each category, however, you can only designate one tier as the primary (001) library tier for that category.

Initial resource creation is done in the first Development tier. When you feel those resources are ready for testing, you promote them to another tier. Depending upon your work-flow, you may promote to another tier library within the same category or to the next tier category.

For instance, you may promote to the Unit Test category from the Development category. From there a tester decides if the resources pass or fail and are kicked back to Development.

A promotion to the next category will always go to the primary (001) library defined in that category. From the primary library, you may then promote to other libraries within that same category.

When you change tiers, you are indicating that you want to change your focus into a new library. When you work within that tier, Studio shows you only those resources that have been promoted to that level. The idea is that you should be able to test resources at each level to make sure only those resources that should are promoted forward. This is typically accomplished by using the Mode and Status library record members as promotion criteria.

Example

< LibraryTier:DEV >

001 = Primary; Inifile; Development


002

LibraryTier
002

002

Library tier.

[ LibraryTier:DEV]

002 = Additional Library

Parameter | Description
value | a secondary library tier within the given category

Remarks

Tiers reflect the different stages of resource development. Studio defines five categories of tiers:

  • Development (DEV)
  • Unit Test (UNIT)
  • System Test (SYST)
  • Model Office (MODL)
  • Production (PROD)

You can create as many tier libraries within each category as you want. Within each category, however, you can only designate one tier as the primary (001) library tier for that category.

Number the secondary libraries within the category to show you the tiers in your preferred order. You are allowed to promote into the secondary tiers in whatever order you choose. Studio project management does not force resources through the secondary library tiers.

When the resources pass the testing within a given category, you would typically promote the resources to the next category. Promotions to the next category will always go to the primary (001) tier library within that category first.

Development (DEV)

001 - Primary

002 - Design Review

When you change tiers, you are indicating that you want to change your focus into a new library. When you work within that tier, Studio shows you only those resources that have been promoted to that level. The idea is that you should be able to test resources at each level to make sure only those resources that should are promoted forward. This is typically accomplished by using the Mode and Status library record members as promotion criteria.

Example

< LibraryTier:DEV >

002 = Design Review; INI File; Development Review


LibraryManager

LibraryManager Options

  • Class
  • KeepFileOnCheckin
  • LBYLogFile
  • Library
  • Mode
  • Project
  • Status
  • StringentChecking
  • Types


Class

[LibraryManager]
Class

Class

[ LibraryManager]

Class = Edit; Edit

Parameter | Description
Name | Name
Description | Description

Example

< LibraryManager >

Class = GA;Georgia Resource

Class = TX;Texas Resource

Class = MD;Maryland Resource

Available

Release | 10.3
Patch |


DefaultPromoteSelectedOn

[LibraryManager]
DefaultPromoteSelectedOn

DefaultPromoteSelectedOn

[ LibraryManager]

DefaultPromoteSelectedOn = Yes

Parameter | Description
Boolean (Yes/No) | Default value is: No

Remarks

This option configures Studio to have the Promote Selected Files Only checked by default when running Promote

Example

< LibraryManager >

DefaultPromoteSelectedOn = Yes

Available

Release | 11.4
Patch | --


KeepFileOnCheckin

[LibraryManager]
KeepFileOnCheckin

KeepFileOnCheckin

[ LibraryManager]

KeepFileOnCheckin = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Set the KeepFileOnCheckin option to Yes if you want to keep the working copy of the resource files on disk after checkin or unlocked.

In version 10.2 and higher, when you check a resource into the library, the system removes the working copy of the resource from disk. You can now set the INI option to Yes to retain that working copy on disk after it is checked in or unlocked. The default is No.

In Docucreate this entry would go in the FAPCOMP.INI file and would apply to all libraries set up in that file. This INI option also applies to Documaker Studio. Enter the INI option in your workspace's FSIUSER.INI or FSISYS.INI file where it will apply just to that workspace.

Example

<LibraryManager>

KeepFileOnCheckin = Yes

Available

Release | 10.3
Patch | 43


LBYLogFile

[LibraryManager]
LBYLogFile

LBYLogFile

1281 Changes to the Library Manager Index

[ LibraryManager]

LBYLogFile = Edit

Parameter | Description
value | The Library Manager index has been altered to include these new fields: Mode, RecStatus (tells you if the file is locked), Class, Project

Remarks

The Library Manager index has been altered to include these new fields: MODE, STATUS, CLASS and PROJECT. Additionally, the index fields FILENAME, DESCRIPTION & USERID have been lengthened. Initially, the new fields will be used to enable one Library to be synchronized to another library. Future improvements will allow a user to promote a library object (change an object's MODE & STATUS) and migrate an object (copy the object to another library).

By default, the new Effective Date for an object being checked in is the same as the Effective Date of the object was originally checked out. You can only change the Effective Date if the Increment Version field is checked.

Additions, deletions, and changes to a library are now logged into an activity log. By default, the name of the log is LBYLOG. You can specify another name using this INI option:

< LibraryManager >

LBYLogFile = mylbylog

You can use the File, Library Report option to view the report or you can use any application that can read a dBase IV formatted file, such as Microsoft Access, to view it. By default, the LBYLOG file is written in dBase IV format so the resulting default file name would be LBYLOG.DBF.

Example

< LibraryManager >

LBYLogFile = mylbylog

Available

Release | 10.1
Patch | 267


LibAutoRefresh

LibAutoRefresh

[ LibraryManager]

LibAutoRefresh = Yes

Parameter | Description
Boolean (Yes/No) | Default value is: Yes

Remarks

This option configures the Library Manager to automatically refresh its contents to reflect changes made elsewhere in studio; for example, a check-in or unlock executed from another manager. The default behavior is for the refresh to occur. In some situations it may be desirable to set this option to "No", such as if a workspace is being accessed over a slower network or an unusually large workspace is causing performance issues. It must be remembered that when this option is set to "No", the information in the currently opened library manager may become out of date with what is actually stored in the database.

Example

< LibraryManager >

LibAutoRefresh = Yes

Available

Release | 12.1
Patch | --


Library

[LibraryManager]
Library

Library

The default path to the Master.lby.

[ LibraryManager]

Library = Deflib\master.lby

Parameter | Description
Path | Default value is: Deflib\master.lby

Example

< LibraryManager >

Library = Deflib\master.lby

Available

Release | 10.3
Patch |


Mode

[LibraryManager]
Mode

Mode

[ LibraryManager]

Mode = Edit; Edit

Parameter | Description
Name | Name
Description | Description

Example

< LibraryManager >

Mode = DEV;Development

Mode = TEST;Test

Mode = PROD;Production

Available

Release | 10.3
Patch |


PromoteReqClass

[LibraryManager]
PromoteReqClass

PromoteReqClass

[ LibraryManager]

PromoteReqClass = Yes

Parameter | Description
Boolean (Yes/No) | Default value is: No

Remarks

Yes if Class is required for promote, No otherwise.

Example

< LibraryManager >

PromoteReqClass = Yes

Available

Release | 11.4
Patch | --


PromoteReqDesc

[LibraryManager]
PromoteReqDesc

PromoteReqDesc

[ LibraryManager]

PromoteReqDesc = Yes

Parameter | Description
Boolean (Yes/No) | Default value is: No

Remarks

Yes if Description is required for promote, No otherwise.

Example

< LibraryManager >

PromoteReqDesc = Yes

Available

Release | 11.4
Patch | --


PromoteReqMode

[LibraryManager]
PromoteReqMode

PromoteReqMode

[ LibraryManager]

PromoteReqMode = Yes

Parameter | Description
Boolean (Yes/No) | Default value is: No

Remarks

Yes if Mode is required for promote, No otherwise.

Example

< LibraryManager >

PromoteReqMode = Yes

Available

Release | 11.4
Patch | --


PromoteReqProject

[LibraryManager]
PromoteReqProject

PromoteReqProject

[ LibraryManager]

PromoteReqProject = Yes

Parameter | Description
Boolean (Yes/No) | Default value is: No

Remarks

Yes if Project is required for promote, No otherwise.

Example

< LibraryManager >

PromoteReqProject = Yes

Available

Release | 11.4
Patch | --


PromoteReqStat

[LibraryManager]
PromoteReqStat

PromoteReqStat

[ LibraryManager]

PromoteReqStat = Yes

Parameter | Description
Boolean (Yes/No) | Default value is: No

Remarks

Yes if Status is required for promote, No otherwise.

Example

< LibraryManager >

PromoteReqStat = Yes

Available

Release | 11.4
Patch | --


Project

[LibraryManager]
Project

Project

[ LibraryManager]

Project = Edit; Edit

Parameter | Description
Name | Name
Description | Description

Example

< LibraryManager >

Project = p001;Project 001

Project = p002;Project 002

Project = p003;Project 003

Available

Release | 10.3
Patch |


Status

[LibraryManager]
Status

Status

[ LibraryManager]

Status = Edit; Edit

Parameter | Description
Name | Name
Description | Description

Example

< LibraryManager >

Status = TEST;needs to be retested

Status = FAILED;Failed Testing

Status = PASSED;Passed Testing

Status = PROMOTED;Has been promoted

Available

Release | 10.3
Patch |


StringentChecking

[LibraryManager]
StringentChecking

StringentChecking

Feature 1427 With this release, the default for the StringentChecking option in the LibraryManager control group is now Yes.

[ LibraryManager]

StringentChecking = Yes

Parameter | Description
Boolean (Yes) | With this release, the default for the StringentChecking option in the LibraryManager control group is now Yes. Default value is: Yes

Remarks

This means Library Manager only returns a requested resource, such as a FAP file or logo, if the resource's effective date is less than or equal to the run date of the transaction for which the system is generating a form set.

To turn off stringent checking, set the option as shown here:

< LibraryManager >

StringentChecking = No

If you set StringentChecking to No, Library Manager will try to return a resource, even if that resource's effective date has not yet been reached.

Also, when you set StringentChecking to No, if there is no version of the resource in the library, the system tries to find the resource on disk. If it finds the resource anywhere on disk, it will return that copy.

With StringentChecking set to Yes, the system does not search for resources. The concept of stringent checking has been extended to all types of resources stored in libraries (FAP, DDT, LOG, DAL). In prior versions,

stringent checking only applied to DDT files.

Example

< LibraryManager >

StringentChecking = Yes

Available

Release | 10.2
Patch | 85


Types

[LibraryManager]
Types

Types

[ LibraryManager]

Types = Edit

Parameter | Description
Edit |

Remarks

Library file types.

The default value is:

;(any);BDF;GRP;FOR;PSL;PAR;FAP;STY;TPL;LOG;DAL;XDD;DDT;TLK

Available

Release | _______
Patch |


LMGLIB

Remarks

OpenFunc

LMGLIB Options

  • OpenFunc


OpenFunc

[LMGLIB]
OpenFunc

OpenFunc

[ LMGLIB]

OpenFunc =

Example

< LMGLIB >

OpenFunc = lmgw32->LMGConnectLibrary

Available

Release | _______
Patch |


Loader:COMPUSET

Loader:
COMPUSET

Loader:COMPUSET Options

  • Desc
  • Func
  • Module


Desc

[Loader:COMPUSET]
Desc

Desc

[ Loader:COMPUSET]

Desc =

Remarks

There is a new library in rel 11.1 called CSLDRDLL. The Compuset Image Loader section of FAPCOMP.INI should now be

< Loader:COMPUSET >

Desc = COMPUSET file (*.txt)

Func = CompuSetLoadFAP

Module = CSLDRDLL

Example

< Loader:COMPUSET >

Desc = COMPUSET file (*.txt)

Available

Release | 11.1
Patch |


Func

[Loader:COMPUSET]
Func

Func

[ Loader:COMPUSET]

Func =

Remarks

There is a new library in rel 11.1 called CSLDRDLL. The Compuset Image Loader section of FAPCOMP.INI should now be

< Loader:COMPUSET >

Desc = COMPUSET file (*.txt)

Func = CompuSetLoadFAP

Module = CSLDRDLL

Example

< Loader:COMPUSET >

Func = CompuSetLoadFAP

Available

Release | 11.1
Patch |


Module

[Loader:COMPUSET]
Module

Module

[ Loader:COMPUSET]

Module =

Remarks

There is a new library in rel 11.1 called CSLDRDLL. The Compuset Image Loader section of FAPCOMP.INI should now be

< Loader:COMPUSET >

Desc = COMPUSET file (*.txt)

Func = CompuSetLoadFAP

Module = CSLDRDLL

Example

< Loader:COMPUSET >

Module = CSLDRDLL

Available

Release | 11.1
Patch |


Loader:DOC

Loader:
DOC

Remarks

Desc

Loader:DOC Options

  • Desc
  • Ext
  • Func
  • Module


Desc

[Loader:DOC]
Desc

Desc

Desc specifies the name of the word processing system (MSWord 6.0).

[ Loader:DOC]

Desc = Edit

Parameter | Description
Edit |

Remarks

Use this FAPCOMP.INI control group to enable the Image Editor, in conjunction with the third party Adobe File Utilities, to import Microsoft Word document files. The Release 9.0 Image Editor contains the interface to the Microsoft Word document conversion software contained in the Adobe File Utilities. The Adobe File Utilities must be purchased and installed by the user. Once this is done, users can import Microsoft Word .DOC files in a similar

manner to the way the Image Editor imports RTF files.

Note: To use this feature, the DOS version of the Adobe File Utilities must be installed. The DOS version is used because it works with the Image Editor under both OS/2 and windows. The directory in which the Adobe File Utilities has been installed must be added to the Operating System's path statement. The FAPCOMP.INI file must be modified by adding the Loader:DOC control group and entering the options shown above.

Example

< Loader:DOC >

Desc = MSWord 6.0 (*.DOC)

Available

Release | _______
Patch |


Ext

[Loader:DOC]
Ext

Ext

Ext specifies the file extension for Microsoft Word document files.

[ Loader:DOC]

Ext = Edit

Parameter | Description
Edit | extension

Example

< Loader:DOC >

Ext = .DOC

Available

Release | _______
Patch |


Func

[Loader:DOC]
Func

Func

The Func option specifies the function name. Do not change this value.

[ Loader:DOC]

Func = LimitList

Parameter

Description

LimitList

The Func option specifies the function name. Do not change this value.

Values can be

  • RTFLoadFAP

Example

< Loader:DOC >

Func = RTFLoadFAP

Available

Release | _______
Patch |


Module

[Loader:DOC]
Module

Module

The Module is the DLL name. Do not change this value.

[ Loader:DOC]

Module = LimitList

Parameter

Description

LimitList

The Module is the DLL name. Do not change this value.

Values can be

  • RTFW32

Example

< Loader:DOC >

Module = RTFW32

Available

Release | _______
Patch |


Loader:FAP

Loader:
FAP

Remarks

LoadFunc

Loader:FAP Options

  • LoadFunc


LoadFunc

[Loader:FAP]
LoadFunc

LoadFunc

Use this FAPCOMP.INI control group to name the function to call for loading FAP files during batch processing.

[ Loader:FAP]

LoadFunc = Edit

Parameter | Description
Edit |

Remarks

This option defines to the system the function to call for loading FAP files during batch processing.

Example

< Loader:FAP >

LoadFunc = FAPLoadAsc

Available

Release | _______
Patch |


Loader:MOBIUS

Loader:
MOBIUS

Remarks

Desc

Loader:MOBIUS Options

  • Desc
  • Func
  • Module


Desc

[Loader:MOBIUS]
Desc

Desc

Feature 1405 Reading From A MOBIUS Archive

[ Loader:MOBIUS]

Desc = Edit

Parameter | Description
Edit |

Remarks

Now you can read Metacode print streams retrieved from a Mobius archive. For instance, you can now use Mobius to archive Metacode print streams, then use Docupresentment to retrieve the archived Metacode print streams and produce PDF files. You can also open Mobius files in Image Editor.

NOTE: Mobius Metacode files do not, however, appear on the list of most recently opened files at the bottom of the File menu in Image Editor.

The archived Metacode print streams can be retrieved using Mobius: ViewDirect APIs. The ViewDirect APIs communicate with the Mainframe Mobius Archive via TCP/IP. If you license the Mobius' ViewDirect APIs, you can write a custom rule to retrieve your archived Metacode print streams.

Metacode print streams retrieved from a Mobius archive have a special record blocking scheme and use special comment records to indicate the fonts used in the document.

As with support for loading other Metacode print streams, you must have a Xerox printer control group which defines the options required by the print stream, such as DJDEIden, DJDEOffset, and so on.

NOTE: The Mobius Metacode loader now performs its operations quicker and with better coding. This makes the output easier to read and use.

To specify a Mobius Metacode print stream, the OutMode option in the Xerox printer control group must be set to MOBIUS. The OutMode option tells the Metacode loader to expect the special record blocking scheme and to expect special comment records which indicate the fonts used in the document.

Mobius Metacode support is available in both Image Editor and the MRG2FAP utility. Include these options in your FAPCOMP.INI file for Image Editor or FSISYS.INI for MRG2FAP.

< PrtType:XER >

OutMode = Mobius

< Loader:MOBIUS >

Desc = Mobius Metacode Files (*.met)

Func = XERLoadMobius

Module = XERW32

< Loaders >

Loader = Mobius

< Control >

Mobius = XER

Where XER is the printer group that contains the Mobius Metacode information.

To us the Mobius Metacode loader in Docupresentment, use the MTCLoadFormset rule. To specify Mobius Metacode print stream instead of a Documerge print stream, set the OutMode option in the Xerox printer control group to MOBIUS.

Example

< Loader:MOBIUS >

Desc = Mobius Metacode Files (*.met)

Available

Release | 10.2
Patch | 66


Func

[Loader:MOBIUS]
Func

Func

Feature 1405 Reading From A Mobius Archive

[ Loader:MOBIUS]

Func = Edit

Parameter | Description
Edit |

Remarks

Now you can read Metacode print streams retrieved from a Mobius archive. For instance, you can now use Mobius to archive Metacode print streams, then use Docupresentment to retrieve the archived Metacode print streams and produce PDF files. You can also open Mobius files in Image Editor.

NOTE: Mobius Metacode files do not, however, appear on the list of most recently opened files at the bottom of the File menu in Image Editor.

The archived Metacode print streams can be retrieved using Mobius: ViewDirect APIs. The ViewDirect APIs communicate with the Mainframe Mobius Archive via TCP/IP. If you license the Mobius' ViewDirect APIs, you can write a custom rule to retrieve your archived Metacode print streams.

Metacode print streams retrieved from a Mobius archive have a special record blocking scheme and use special comment records to indicate the fonts used in the document.

As with support for loading other Metacode print streams, you must have a Xerox printer control group which defines the options required by the print stream, such as DJDEIden, DJDEOffset, and so on.

NOTE: The Mobius Metacode loader now performs its operations quicker and with better coding. This makes the output easier to read and use.

To specify a Mobius Metacode print stream, the OutMode option in the Xerox printer control group must be set to MOBIUS. The OutMode option tells the Metacode loader to expect the special record blocking scheme and to expect special comment records which indicate the fonts used in the document.

Mobius Metacode support is available in both Image Editor and the MRG2FAP utility. Include these options in your FAPCOMP.INI file for Image Editor or FSISYS.INI for MRG2FAP.

< PrtType:XER >

OutMode = Mobius

< Loader:MOBIUS >

Desc = Mobius Metacode Files (*.met)

Func = XERLoadMobius

Module = XERW32

< Loaders >

Loader = Mobius

< Control >

Mobius = XER

Where XER is the printer group that contains the Mobius Metacode information.

To us the Mobius Metacode loader in Docupresentment, use the MTCLoadFormset rule. To specify Mobius Metacode print stream instead of a Documerge print stream, set the OutMode option in the Xerox printer control group to MOBIUS.

Example

< Loader:MOBIUS >

Func = XERLoadMobius

Available

Release | 10.2
Patch | 66


Module

[Loader:MOBIUS]
Module

Module

Feature 1405 Reading From a MOBIUS Archive

[ Loader:MOBIUS]

Module = Edit

Parameter | Description
Edit |

Remarks

Now you can read Metacode print streams retrieved from a Mobius archive. For instance, you can now use Mobius to archive Metacode print streams, then use Docupresentment to retrieve the archived Metacode print streams and produce PDF files. You can also open Mobius files in Image Editor.

NOTE: Mobius Metacode files do not, however, appear on the list of most recently opened files at the bottom of the File menu in Image Editor.

The archived Metacode print streams can be retrieved using Mobius: ViewDirect APIs. The ViewDirect APIs communicate with the Mainframe Mobius Archive via TCP/IP. If you license the Mobius' ViewDirect APIs, you can write a custom rule to retrieve your archived Metacode print streams.

Metacode print streams retrieved from a Mobius archive have a special record blocking scheme and use special comment records to indicate the fonts used in the document.

As with support for loading other Metacode print streams, you must have a Xerox printer control group which defines the options required by the print stream, such as DJDEIden, DJDEOffset, and so on.

NOTE: The Mobius Metacode loader now performs its operations quicker and with better coding. This makes the output easier to read and use.

To specify a Mobius Metacode print stream, the OutMode option in the Xerox printer control group must be set to MOBIUS. The OutMode option tells the Metacode loader to expect the special record blocking scheme and to expect special comment records which indicate the fonts used in the document.

Mobius Metacode support is available in both Image Editor and the MRG2FAP utility. Include these options in your FAPCOMP.INI file for Image Editor or FSISYS.INI for MRG2FAP.

< PrtType:XER >

OutMode = Mobius

< Loader:MOBIUS >

Desc = Mobius Metacode Files (*.met)

Func = XERLoadMobius

Module = XERW32

< Loaders >

Loader = Mobius

< Control >

Mobius = XER

Where XER is the printer group that contains the Mobius Metacode information.

To us the Mobius Metacode loader in Docupresentment, use the MTCLoadFormset rule. To specify Mobius Metacode print stream instead of a Documerge print stream, set the OutMode option in the Xerox printer control group to MOBIUS.

Example

< Loader:MOBIUS >

Module = XERW32

Available

Release | 10.2
Patch | 66


Loaders

Remarks

Loader

Loaders Options

  • Loader


Loader

[Loaders]
Loader

Loader

[ Loaders]

Loader = LimitList

Parameter

Description

LimitList

Values can be

  • FAP
  • DOC
  • MOBIUS

Remarks

Use this control group to specify, by file extension, the type of files to be loaded by GenPrint during batch processing. Each option listed in the Loaders group should have a Loader:xxx INI group (where xxx represents the loader name) within the FAPCOMP.INI file. Conditions for loading FAP files are contained in the FSISYS.INI RunMode control group.

Loader = DOC

This option tells the system to load document files during batch processing.

Loader = FAP

This option tells the system to load FAP files during batch processing. Parameters for loading FAP files are set in the FSISYS.INI RunMode control group.

Loader = MOBIUS

Now you can read Metacode print streams retrieved from a Mobius archive. For instance, you can now use Mobius to archive Metacode print streams, then use Docupresentment to retrieve the archived Metacode print streams and produce PDF files. You can also open Mobius files in Image Editor.

NOTE: Mobius Metacode files do not, however, appear on the list of most recently opened files at the bottom of the File menu in Image Editor.

The archived Metacode print streams can be retrieved using Mobius: ViewDirect APIs. The ViewDirect APIs communicate with the Mainframe Mobius Archive via TCP/IP. If you license the Mobius' ViewDirect APIs, you can write a custom rule to retrieve your archived Metacode print streams.

Metacode print streams retrieved from a Mobius archive have a special record blocking scheme and use special comment records to indicate the fonts used in the document.

As with support for loading other Metacode print streams, you must have a Xerox printer control group which defines the options required by the print stream, such as DJDEIden, DJDEOffset, and so on.

NOTE: The Mobius Metacode loader now performs its operations quicker and with better coding. This makes the output easier to read and use.

To specify a Mobius Metacode print stream, the OutMode option in the Xerox printer control group must be set to MOBIUS. The OutMode option tells the Metacode loader to expect the special record blocking scheme and to expect special comment records which indicate the fonts used in the document.

Mobius Metacode support is available in both Image Editor and the MRG2FAP utility. Include these options in your FAPCOMP.INI file for Image Editor or FSISYS.INI for MRG2FAP.

< PrtType:XER >

OutMode = Mobius

< Loader >

Desc = Mobius Metacode Files (*.met)

Func = XERLoadMobius

Module = XERW32

< Loaders >

Loader = Mobius

< Control >

Mobius = XER

Where XER is the printer group that contains the Mobius Metacode information.

To us the Mobius Metacode loader in Docupresentment, use the MTCLoadFormset rule. To specify Mobius Metacode print stream instead of a Documerge print stream, set the OutMode option in the Xerox printer control group to MOBIUS.

Example

< Loaders >

Loader = DOC

Loader = FAP

Loader = MOBIUS

Available

Release | _______
Patch |


Loader:xxx

Loader:
xxx

Remarks

The Loader:xxx control group (where xxx is the loader name) enables the GUI loader. The loader name is user definable and it needs to be included in the Loaders control group with the Loader option.

Here is an example:

< Loader:ABC >

< Loaders >

Loader = ABC

Generally, the Loader:xxx control group lets you specify the description of the loader, the file extension of the file to be loaded, and the Module and the Function of the loader. For example:

< Loader:CompuSet >

Desc = CompuSet files (*.TXT)

Ext = *.TXT

Module = CompuSetLoadFAP

Func = CSLDRDLL

The example above which is used to load the CompuSet script files is available starting with release 11.0. Please refer to the CompuSet group for more information.

Example

< Loaders >

Loader = CompuSet

Loader = Mobius

Loader = NormMET

Loader = NormAFP

Loader = FM2

Loader = EMF

< Loader: CompuSet >

Desc = CompuSet files (*.TXT)

EXT = *.TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loader:NormMET>

Desc = Normalized Metacode (*.MET)

Ext = *.MET

Module = XERW32

Func = XERLoadNormalize

< Loader:Mobius >

Desc = Mobius Metacode files (*.MET)

EXT = *.MET

Func = XERLoadMobius

Module = XERW32

< Loader:NormAFP >

Desc = Normalized AFP (*.AFP)

Ext = *.AFP

Module = AFPPRT

Func = AFPLoadNormalize

< Loader:FM2>

Desc = Formaker II files (*.FM2)

Ext = *.FM2

Module = FIBW32

Func = FIBLoadFM2

< Loader:EMF>

Desc = Enhanced meta files (*.EMF)

Ext = *.EMF

Module = DFXW32

Func = DFXLoadEMF

Loader:xxx Options

  • Desc
  • Ext
  • Func
  • Module


Desc

[Loader:xxx]
Desc

Desc

The Desc option lets you specify the description of the GUI loader.

[ Loader:xxx]

Desc = Edit

Parameter | Description
Edit |

Remarks

The Desc option lets you specify the description of the GUI loader, which appears in the File Type list for selection of the file to open.

Example

< Loader:CompuSet >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loaders >

Loader = Compuset

Available

Release | _______
Patch |


Ext

[Loader:xxx]
Ext

Ext

The Ext option lets you specify the extension name of the file to be loaded by the GUI loader.

[ Loader:xxx]

Ext = Edit

Parameter | Description
Edit |

Remarks

The Ext option lets you specify the extension name of the file to be loaded by the GUI loader. The GUI tool filters the file list to show only files with the extension specified with this INI option (case insensitive).

Example

< Loader:CompuSet >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loaders >

Loader = Compuset

Available

Release | _______
Patch |


Func

[Loader:xxx]
Func

Func

The Func option lets you specify the loading function name.

[ Loader:xxx]

Func = List

Parameter

Description

List

Values can be

  • XERLoadMobius - XERLoadMobius
  • XERLoadNormalize - XERLoadNormalize
  • AFPLoadNormalize - AFPLoadNormalize
  • FIBLoadFM2 - FIBLoadFM2
  • FDBLoadTGA - FDBLoadTGA
  • DXFLoadDTF - DXFLoadDTF
  • DXFLoadEMF - DXFLoadEMF
  • DXFLoadRTF - DXFLoadRTF
  • DXFLoadMET - DXFLoadMET
  • CompuSetLoadFAP - CompuSetLoadFAP

Remarks

The Func option lets you specify the loading function name.

Example

< Loader:CompuSet >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loaders >

Loader = Compuset

Available

Release | _______
Patch |


Module

[Loader:xxx]
Module

Module

The Module option lets you specify the Module of the GUI loader.

[ Loader:xxx]

Module = List

Parameter

Description

List

Values can be

  • XERW32 - XERW32
  • AFPPRT - AFPPRT
  • DFXW32 - DFXW32
  • FIBW32 - FIBW32
  • FDBW32 - FDBW32
  • CSLDRDLL - CSLDRDLL

Remarks

The Module option lets you specify the Module of the GUI loader.

Example

< Loader:CompuSet >

Desc = Compuset Files (*.TXT)

Ext = .TXT

Func = CompuSetLoadFAP

Module = CSLDRDLL

< Loaders >

Loader = Compuset

Available

Release | _______
Patch |


Mail

Remarks

< Mail >

MailType = CCM

SlipTable = path\filename

To let users email forms, you can add file settings to your existing INI file <Control> control group. If your Documaker WS / Documaker Processing System is networked, you have to add the email INI controls and parameters only once to the FSISYS.INI file. Otherwise, you must add the controls to the FSIUSER.INI file on each personal computer.

Note: The <Mail> control group and its MailType option, should appear below the <Control> control group. Add the <MailType:xxx> control group below the <Mail> control group.

Mail Options

  • MailType
  • ReceiveForms
  • SendForms
  • SlipTable


MailType

[Mail]
MailType

MailType

MailType is the name of the email system.

[ Mail]

MailType = Edit

Parameter | Description
value | MailType is the name of the email system. Enter CCM for Lotus CC:Mail. This entry tells the system to look for the MailType:CCM control group for the mail system requirements.

Remarks

Use this FSISYS.INI group to add email to your system. The Mail control group identifies the section of the INI file (<MailType:xxx>) containing the current mail system requirements. To let users email forms, you can add file settings to your existing INI file <Control> control group. If your DAP Processing System is networked, you have to add the email INI controls and parameters only once to the FSISYS.INI file. Otherwise, you must add the controls to the FSIUSER.INI file on each personal computer.

NOTE: The <Mail> control group and its MailType option, should appear below the <Control> control group. Add the <MailType:xxx> control group below the <Mail> control group.

Example

<Mail>

MailType = CCM

MailType = MSM

Available

Release | _______
Patch |

Used By

AFEMAIN


ReceiveForms

[Mail]
ReceiveForms

ReceiveForms

Enter Yes to allow the recipient to receive faps into the forms directory of the MRL.

[ Mail]

ReceiveForms = Yes

Parameter | Description
Boolean (No) | Enter Yes to let the user receive forms. Default value is: No

Example

< Mail >

ReceiveForms = Yes

Available

Release | _______
Patch |


SendForms

[Mail]
SendForms

SendForms

Yes allows you to send faps along with the wip policies that you are sending. The default is No which means that you will receive the forms into wip but no faps.

[ Mail]

SendForms = Yes

Parameter | Description
boolean | Default value is: No

Example

< Mail >

SendForms = Yes

Available

Release | _______
Patch |


SlipTable

[Mail]
SlipTable

SlipTable

This option lets you specify the location of routing slips.

[ Mail]

SlipTable = Path

Parameter | Description
value | path\ filename

Remarks

Before version 9.7, routing slips were automatically created in the table directory. Version 9.7 lets you use the following INI option to specify the location of routing slips:

<Mail>

SlipTable = path\filename

You can use this option to:

- Specify an alternate path for the routing slip table. In this scenario, the default slip table name (RTESLIPS) will be used, but accessed via another path. If you specify only the path, you must enter the terminating backslash.

SlipTable = ..\MyPath\

- Specify an alternate file name for the routing slip table. In this scenario, the default table directory is used (taken from the Master Resource) to locate the named routing slip table. With this option, no path would be assigned on the table name text. The extension is usually optional, but may be defined for clarity.

SlipTable = MyTable.dbf

- Specify both a new path and file name for the routing slip table. The extension is optional.

SlipTable = ..\MyPath\MyTable.dbf

Example

<Mail>

SlipTable = path\filename

Available

Release | _______
Patch |

Used By

AFEMAIN


MailType:MSM

MailType:
MSM

Remarks

Use the MailType:MSM group to define the setting for the MailType named "MSM". The MailType name, "MSM" is defined by the user with the <Mail> MailType option.

MailType:MSM Options

  • HiddenMsgSupport
  • MailFunc
  • Module
  • Name
  • ReceiveFromInbox


HiddenMsgSupport

[MailType:MSM]
HiddenMsgSupport

HiddenMsgSupport

Set to No if you are having trouble getting messages retrieved into WIP.

[ MailType:MSM]

HiddenMsgSupport = Yes

Parameter | Description
Boolean (Yes) | Set to No if you are having trouble getting messages retrieved into WIP. Default value is: Yes

Example

< MailType:MSM >

HiddenMsgSupport = No

Available

Release | _______
Patch |


MailFunc

[MailType:MSM]
MailFunc

MailFunc

The name of the exported DLL function for the email handler.

[ MailType:MSM]

MailFunc = MSMMail

Parameter | Description
value | The name of the exported DLL function for the email handler. Default value is: MSMMail

Example

< MailType:MSM >

MailFunc = MSMMail

Available

Release | _______
Patch |


Module

[MailType:MSM]
Module

Module

The name of the DLL that supports the email system.

[ MailType:MSM]

Module = MSMW32

Parameter | Description
File | The name of the DLL that supports the email system. Default value is: MSMW32

Example

< MailType:MSM >

Module = MSMW32

Available

Release | _______
Patch |


Name

[MailType:MSM]
Name

Name

The name of the system (to identify the system on internal dialogs).

[ MailType:MSM]

Name = MSMail

Parameter | Description
File | The name of the system (to identify the system on internal dialogs). Default value is: MSMail

Example

< MailType:MSM >

Name = MSMail

Available

Release | _______
Patch |


ReceiveFromInbox

[MailType:MSM]
ReceiveFromInbox

ReceiveFromInbox

Lets a user of MS Outlook (MAPI) receive mail through the normal inbox from a non-Outlook user.

[ MailType:MSM]

ReceiveFromInbox = YN

Parameter | Description
Boolean | Lets a user of MS Outlook (MAPI) receive mail through the normal inbox from a non-Outlook user.

Remarks

Lets a user of MS Outlook (MAPI) receive mail through the normal inbox from a non-Outlook user (such as CC:Mail using VIM) which did not set our normal application mail type attribute.

The system automatically receives mail (hidden from the normal Inbox) that has our mail type attribute set.

This option tells the MAPI support to check the inbox for messages of our subject type as well as the normal process of getting messages with our application mail-type.

When you set the Receive From Inbox option and the user normally uses hidden mail types, Send\Receive will also look in the users' normal inbox to check for messages not hidden.

Example

< MailType:MSM >

ReceiveFromInbox=Yes

Available

Release | 10.1
Patch |


MailType:XXX

MailType:
XXX

Remarks

< MailType:xxx >

DataPath = V:\CCDATA

MailFunc = VMMail

Module = VIMWIN

Name = CCMail

ReceiveMailOnWIPList = Yes

UserID =

UserPassword =

The FSIUSER.INI MailType:xxx control group, where xxx refers to the MailType you set up in the <Mail> control group (such as MailType:CCM (for Lotus CC:Mail), contains information and file settings for the email system.

You can add file settings to your existing INI file <Control> control group to enable users to email forms. If your Documaker Processing System is networked, you have to add the email INI controls and parameters only once to the FSISYS.INI file. Otherwise, you must add the controls to the FSIUSER.INI file on each personal computer.

The Module and MailFunc statements are required for all email applications. Some systems may require one or more of the other control group options to be pre-defined within the INI file. Most applications will simply use the additional login information to either eliminate or pre-fill login dialogs.

Note:The <Mail> control group and its MailType option, should appear below the <Control> control group. Add the <MailType:xxx> control group below the <Mail> control group.

MailType:XXX Options

  • Append_Subject
  • DataPath
  • MailFunc
  • Module
  • Name
  • Password
  • UserID


Append_Subject

[MailType:XXX]
Append_Subject

Append_Subject

Use the Append_Subject INI option to add information to the subject line when sending emails.

[ MailType:XXX]

Append_Subject = Edit

Parameter | Description
Edit |

Remarks

Feature 1537 provides you with the Append_Subject INI option to add information to the subject line when sending emails via Documaker Workstation and Documaker RP. This option will work with all features that use the email system, such as EPT, routing, and so on.

Here are some examples of how you can use this option:

< MailType:MSM >

Append_Subject = [ ~Key1 | ~USERID ]

or

Append_Subject = ~Key1 | ~USERID

or

Append_Subject = ~Key1

or

Append_Subject = ~DALRUN MyMessage.DAL

or

Append_Subject = My Subject Here

In these examples, the tilde (~) in front of Key and USERID tells the system to retrieve the Key1 and user ID values from the form set currently loaded in memory. If no form set is in memory, the value for the Append_Subject option will be blank.

The example ~DALRUN MyMessage.DAL tells the system to run a DAL script named MyMessage.DAL if necessary.

The pipe symbol ( | ) between KEY1 and USERID is not required. It is only there to separate the two values. For example, if the value for ~KEY1 is ABC Company, and the value for ~USERID is James Brown, the subject line will look like this:

FILE_FAPMSG [ ABC Company | James Brown]

Example

< MailType:xxx >

Append_Subject = [ ~Key1 | ~USERID ]

or

Append_Subject = ~Key1 | ~USERID

or

Append_Subject = ~Key1

or

Append_Subject = ~DALRUN MyMessage.DAL

or

Append_Subject = My Subject Here

Available

Release | 11.0
Patch |

Used By

EPTLIB, FSRLIB


DataPath

[MailType:XXX]
DataPath

DataPath

The DataPath is the path of your email system; usually the drive and "CCDATA".

[ MailType:XXX]

DataPath = Path

Parameter | Description
value | The DataPath is the path of your email system; usually the drive and “"CDATA". For example: V:\CCDATA (where V: is the drive where your email system resides).

Remarks

The FSISYS.INI MailType:xxx control group, where xxx refers to the MailType you set up in the <Mail> control group (such as MailType:CCM (for Lotus CC:Mail), contains information and file settings for the email system.

You can add file settings to your existing INI file <Control> control group to enable users to email forms. If your DAP Processing System is networked, you have to add the email INI controls and parameters only once to the FSISYS.INI file. Otherwise, you must add the controls to the FSIUSER.INI file on each personal computer.

The Module and MailFunc statements are required for all email applications. Some systems may require one or more of the other control group options to be pre-defined within the INI file. Most applications will simply use the additional login information to either eliminate or pre-fill login dialogs.

NOTE: The <Mail> control group and its MailType option, should appear below the <Control> control group. Add the <MailType:xxx> control group below the <Mail> control group.

Example

<MailType:XXX>

DataPath = V:\CCDATA

Available

Release | _______
Patch |

Used By

AFEMAIN


MailFunc

[MailType:XXX]
MailFunc

MailFunc

MailFunc is the exported DLL function name of the mail handler. The MailFunc statement is required for all email applications.

[ MailType:XXX]

MailFunc = File

Parameter | Description
value | DLL function name of the mail handler. (required)

This option may be required in order for the feature to function.

Example

< MailType:xxx >

MailFunc = VMMail

Available

Release | _______
Patch |

Used By

AFEMAIN


Module

[MailType:XXX]
Module

Module

Module defines the email type and your operating system, such as VIMWIN for Windows.

[ MailType:XXX]

Module = Edit

Parameter | Description
value | email type and your operating system. Required for all email apps.

Remarks

The Module statement is required for all email applications.

Note: If you enter the value Module=VIMW32, the correct DLL name will be substituted for OS/2, Windows 3.x, and Windows 95/NT. If you enter a specific DLL name (such as VIMWIN.DLL) then only one platform will be supported by this INI file.

Example

< MailType:xxx >

Module = VIMWIN

Available

Release | _______
Patch |


Name

[MailType:XXX]
Name

Name

Name is the name of your email system, such as CCMail.

[ MailType:XXX]

Name = Edit

Parameter | Description
value | name of email system

Example

< MailType:xxx >

Name = CCMail

Available

Release | _______
Patch |

Used By

AFEMAIN


Password

[MailType:XXX]
Password

Password

Password defines the default user password for logging on to the email system. [ MailType:XXX] Password = Edit

[ MailType:XXX]

Password =

Parameter | Description
Edit |

Remarks

Leave this field blank to require the user to enter an email password before receiving mail.

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <MailType:xxx> Password option, <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the ~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Example

<MailType:XXX>

Password =

Available

Release | _______
Patch |

Used By

AFEMAIN


UserID

[MailType:XXX]
UserID

UserID

UserID defines the default user ID for logging onto the email system.

[ MailType:XXX]

UserID = Edit

Parameter | Description
value | blank or default user ID for email system

Remarks

Leave this field blank to require the user to enter an email password before receiving mail.

Example

<MailType:XXX>

UserID =

Available

Release | _______
Patch |

Used By

AFEMAIN


Manual

Remarks

Printer

Manual Options

  • Printer


Printer

[Manual]
Printer

Printer

Use this FSISYS.INI control group to include the manual batch in the print batches.

[ Manual]

Printer = Edit

Parameter | Description
value | Use this FSISYS.INI control group to include the manual batch in the print batches.

Remarks

Manual batches include form sets with incomplete data or form sets that have fields marked for manual entry only. GENPRINT uses the MANUAL control group to find out where to send the print created for that recipient batch file. In the sample entry above, the print will be sent to Printer4.

Example

< Manual >

Printer = ManPrt

< MANUAL >

Printer = Printer4

Available

Release | _______
Patch |


Margins

Margins Options

  • Bottom
  • Left
  • Right
  • Top


Bottom

[Margins]
Bottom

Bottom

[ Margins]

Bottom = 400

Parameter | Description
Edit | Default value is: 400

Remarks

These are FAP units.

These options are used by the stand-alone Image Editor and the Image Manager within DM Studio when creating new images.

Example

< Margins >

Bottom = 400

Left = 600

Right = 600

Top = 400

Available

Release | _______
Patch |


Left

[Margins]
Left

Left

[ Margins]

Left = 600

Parameter | Description
Edit | Default value is: 600

Remarks

These are FAP units.

These options are used by the stand-alone Image Editor and the Image Manager within DM Studio when creating new images.

Example

< Margins >

Bottom = 400

Left = 600

Right = 600

Top = 400

Available

Release | _______
Patch |


Right

[Margins]
Right

Right

[ Margins]

Right = 600

Parameter | Description
Edit | Default value is: 600

Remarks

These are FAP units.

These options are used by the stand-alone Image Editor and the Image Manager within DM Studio when creating new images.

Example

< Margins >

Bottom = 400

Left = 600

Right = 600

Top = 400

Available

Release | _______
Patch |


Top

[Margins]
Top

Top

[ Margins]

Top = 400

Parameter | Description
Edit | Default value is: 400

Remarks

These are FAP units.

These options are used by the stand-alone Image Editor and the Image Manager within DM Studio when creating new images.

Example

< Margins >

Bottom = 400

Left = 600

Right = 600

Top = 400

Available

Release | _______
Patch |


MasterResource

Remarks

The < MasterResource > group indentifies the names and locations of the Files and Directories that make up the "Master Resources".

Often times, as in the example below, the values for the options in the MasterResource group are re-directed to another INI group known as a "CONFIG: " group. So, for example, the value associated with the CompLib option would be located in the INI group called <CONFIG:Batch Processing> like so:

<CONFIG:Batch Processing> CompLib = .\Complib

Use this FSIUSER.INI control group to define the file names and directory paths for the master resource library components. Resources consist of images, logos, font files, formset definition files, etc. When you select a resource library using the File, Library Setup option, the system changes the <CONFIG:xxx> portion of the option to point to your selected library (xxx represents a library name). For example, if you selected SAMPCO all of the CONFIG:xxx portions would read CONFIG:SAMPCO.

Note: Depending on your system configuration, your FSIUSER.INI file may not include the following group options: FormFile, LogoFile, DalFile and LbyLib. These options relate to the Library Manager. If your company uses Image Editor to create forms, you must define your master resource library within the FSIUSER.INI for each company you define for your system. The library files must be properly defined in the INI file for users to access the correct forms.

Example

< MasterResource >

BaseDef = <CONFIG:Batch Processing> BaseDef =

CompLib = <CONFIG:Batch Processing> CompLib =

DalFile = <CONFIG:Batch Processing> DalFile =

DdtLib = <CONFIG:Batch Processing> DdtLib =

DefLib = <CONFIG:Batch Processing> DefLib =

FntFile = <CONFIG:Batch Processing> FntFile =

FontLib = <CONFIG:Batch Processing> FontLib =

Form7x = <CONFIG:Batch Processing> Form7x =

FormDef = <CONFIG:Batch Processing> FormDef =

FormFile = <CONFIG:Batch Processing> FormFile =

FormLib = <CONFIG:Batch Processing> FormLib =

FormsetTrigger = <CONFIG:Batch Processing> FormsetTrigger =

HelpLib = <CONFIG:Batch Processing> HelpLib =

LogoFile = <CONFIG:Batch Processing> LogoFile =

TableLib = <CONFIG:Batch Processing> TableLib =

XrfFile = <CONFIG:Batch Processing> XrfFile =

< MasterResource >

BaseDef =

CompLib =

DalFile =

DdtLib =

DefLib =

FntFile =

FontLib =

Form7x =

FormDef =

FormFile =

FormLib =

FormsetTrigger =

HelpLib =

LogoFile =

TableLib =

XrfFile =

MasterResource Options

  • ARCPath
  • BaseDef
  • BDFFile
  • BDFLib
  • CARPath
  • CompLib
  • DALFile
  • DALTriggers
  • DDTFile
  • DDTLib
  • DEFLIB
  • DictionaryFile
  • EDLLib
  • FieldBaseFile
  • FntFile
  • FontLib
  • FORFile
  • FORLib
  • Form7x
  • FormDef
  • FormFile
  • FormFileData
  • FormLib
  • FormsetTrigger
  • GRPFile
  • GRPLib
  • HelpLib
  • LbyLib
  • LbyScriptLib
  • LOGOFile
  • LogoLib
  • OverlayPath
  • TableLib
  • TablePath
  • TransTrigger
  • WIPPath
  • XDDFile
  • XRFFile


ARCPath

[MasterResource]
ARCPath

ARCPath

Use this FSIUSER.INI control group to define the file names and directory paths for the master resource library components.

[ MasterResource]

ARCPath = Path

Parameter | Description
Path |

Remarks

Resources consist of images, logos, font files, formset definition files, etc. When you select a resource library using the File, Library Setup option, the system changes the <CONFIG:xxx> portion of the option to point to your selected library (xxx represents a library name). For example, if you selected SAMPCO all of the CONFIG:xxx

portions would read CONFIG:SAMPCO.

Example

< MasterResource >

ARCPath = <CONFIG:~Platform > ARCPath =

Available

Release | _______
Patch |


BaseDef

[MasterResource]
BaseDef

BaseDef

BaseDef is the file name of the list of form definition files. This is an optional entry in the MasterResource control group.

[ MasterResource]

BaseDef = File

Parameter | Description
value | location of BaseDef

This option may be required in order for the feature to function.

Example

< MasterResource >

BaseDef = <CONFIG:xxx> BaseDef =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


BDFFile

[MasterResource]
BDFFile

BDFFile

[ MasterResource]

BDFFile = File

Parameter | Description
File |

Example

< MasterResource >

BDFFile = [CONFIG:rpex11] BDFFile =

Available

Release | 10.3
Patch |


BDFLib

[MasterResource]
BDFLib

BDFLib

[ MasterResource]

BDFLib = Path

Parameter | Description
Path |

Example

< MasterResource >

BDFLib= [CONFIG:rpex11] BDFLib =

Available

Release | 10.3
Patch |


CARPath

[MasterResource]
CARPath

CARPath

[ MasterResource]

CARPath = Path

Parameter | Description
Path |

Example

< MasterResource >

CARPath = <CONFIG:~Platform > CARPath

Available

Release | _______
Patch |


CompLib

[MasterResource]
CompLib

CompLib

Indicates where the Compiled FAPs are located.

[ MasterResource]

CompLib = Path

Parameter | Description
Path | location of Compiled FAPs

This option may be required in order for the feature to function.

Remarks

Indicates where the Compiled FAPs are located.

Example

< MasterResource >

CompLib =

Available

Release | 10.0
Patch |

Used By

GENDATA, GENPRINT, GENTRN


DALFile

[MasterResource]
DALFile

DALFile

DALFile defines the directory path of library DAL files.

[ MasterResource]

DALFile = File

Parameter | Description
value | location of DAL Scripts

This option may be required in order for the feature to function.

Example

< MasterResource >

DALFile = <CONFIG:xxx> DalFile =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


DALTriggers

[MasterResource]
DALTriggers

DALTriggers

This option allows you to name the DAL trigger file as you desire.

[ MasterResource]

DALTriggers = Setrcptbl.dal

Parameter | Description
value | Parameter Default is the filename defined in the FormSetTrigger option or Setrcptbl.dal if not defined. Default value is: Setrcptbl.dal

Remarks

By default, the system looks for the trigger file using the same name as the FormSetTrigger option from the MasterResource control group. However, because some platforms do not support the use of extensions (like .DAL) to distinguish files, this new option lets you specifically name your DAL triggers script library file differently from your FormSetTrigger file.

If you omit this option, the system uses the name specified in the FormSetTrigger option in the MasterResource control group. If that option is omitted, the system uses SETRCPTB.DAL as the name.

Example

< MasterResource >

FormsetTrigger = CASETRCPTB.DAT

DALTriggers = MASETRCPTB.dal

FormDef = LAFORM.DAT

Available

Release | 10.3
Patch | 11

Used By

CORPLIB, FDTLIB, PXLIB, RULLIB


DDTFile

[MasterResource]
DDTFile

DDTFile

1162 Telling IDS you are Using Library Manager

[ MasterResource]

DDTFile = File

Parameter | Description
value | If you are using an xBase library, not a DBMS like DB2 or Oracle, use these INI options to indicate you are using Library Manager.

Remarks

If you are using an xBase library, not a DBMS like DB2 or Oracle, use these INI settings:

< MasterResource >

DDTFile = master.lby

FormFile = master.lby

LogoFile = master.lby

LbyLib = ..\rpex1\

where master.lby is the name of your library and the LybLib option points to the directory where the library resides.

You can also turn on tracing of Library Manager component by specifying these INI options:

< Debug_Switches >

Enable_Debug_Options = Yes

LbyLib = Yes

With these options set, the system creates a trace file you can use to resolve problems.

Example

< MasterResource >

DDTFile = master.lby

Available

Release | 10.1
Patch | 199


DDTLib

[MasterResource]
DDTLib

DDTLib

Indicates where the DDTs are located.

[ MasterResource]

DDTLib = Path

Parameter | Description
location | location of DDTs

This option may be required in order for the feature to function.

Remarks

Indicates where the DDTs are located.

Example

< MasterResource >

DDTLib =

Available

Release | _______
Patch |

Used By

GENDATA, GENPRINT, GENTRN


DEFLIB

[MasterResource]
DEFLIB

DEFLIB

[ MasterResource]

DEFLIB = Path

Parameter | Description
value | location of the DEFLIB

This option may be required in order for the feature to function.

Remarks

DefLib is the directory path of the Form set definition files and FXR files (default location of font files).

Indicates where the DEFLIB is located. The DEFLIB contains several types of files, including DFD (Data Format Definition) files, Form set definition files and Set Recipient (trigger) files. Depending on the platform, INI files (e.g. FSIUSER.INI, FSISYS.INI) are sometimes kept in the DEFLIB as well.

Example

< MasterResource >

DefLib = <CONFIG:xxx> DefLib =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


DictionaryFile

[MasterResource]
DictionaryFile

DictionaryFile

[ MasterResource]

DictionaryFile = File

Parameter | Description
value |

Example

< MasterResource >

DictionaryFile = <Config:xxx> DictionaryFile =

Available

Release | _______
Patch |


EDLLib

[MasterResource]
EDLLib

EDLLib

The EDLLib is used to specify the location of the output file when generating normalized AFP or Metacode files.

[ MasterResource]

EDLLib = Path

Parameter | Description
value | The EDLLib is used to specify the location of the output file when generating normalized AFP or Metacode files.

Remarks

When you select the Manage, Conversion option and then pick Compile FAP images to Print Files on the Conversion type drop-down list in Documaker Studio or choose the Tools, Convert option in the Image Editor to generate normalized AFP or Metacode files, the system creates normalized AFP or Metacode files which have the same file name as the input file with an AFP or MET extension, assuming that is how your system is set up. Normalized AFP or Metacode files have the same file extension as regular AFP or Metacode files, so setting up a distinct destination is a good way to separate the two types of files.

Enter the name of the folder into which you want the system to place the normalized AFP or MET file it creates. If you omit this option, the file is placed in the current directory.

To generate the desired AFP printer format, you must have the appropriate printer options set in the AFP printer type group, and the Normalize option in the Control group. Here is an example:

< Control >

Normalize = Norm

< PrtType:Norm >

Class = AFP

Module = AFPPrt

PrintFunc = AFPPrint

Please refer to the Normalize option in the Control group and PrtType:AFP group for detailed information.

To generate the desired normalized Metacode files, you must set up the Metacode printer type control group, the CommonFonts control group and the Normalize option in the Control group. Here is an example:

< CommonFonts >

Name1 = FXCON0

Name2 = FXUNN6

Name3 = FORMSX

Names = 3

< Control >

Normalized = Norm

< PrtType:Norm >

Class = XER

CodeDef = DCASCII9

DJDEIden = A'@@@DJDE'

DJDEOffset = 0

DJDESkip = 8

JDEName = DFLT

JDLCode = NONE

JDLData = 0,255

JDLHost = IBMONL

JDLName = DFAULT

JDLRStack = 0,10,EQ,X'13131313131313131313'

Module = XERW32

PrintFunc = XERPrint

OutMode = MRG4

Please refer to the Normalize option in the Control group, CommonFonts group, and PrtType:XER group for detailed information.

Example

< MasterResource >

EDLLib = .\EDLLIB\

Available

Release | 10.2
Patch |


FieldBaseFile

[MasterResource]
FieldBaseFile

FieldBaseFile

[ MasterResource]

FieldBaseFile = File

Parameter | Description
value |

Example

< MasterResource >

FieldBaseFile = <Config:xxx> FieldBaseFile =

Available

Release | _______
Patch |


FntFile

[MasterResource]
FntFile

FntFile

FntFile specifies the file name of the downloadable font spool file.

[ MasterResource]

FntFile = File

Parameter | Description
value | location of FntFile

This option may be required in order for the feature to function.

Remarks

When you wish to download fonts using the large font file that includes many fonts you must specify the file name and extension and do not specify the full path.

For example:

<MasterResource>

FntFile = rel95sm.fnt

The system will not issue a warning if the file cannot be found.

If you do not wish to download the large font file and want the system to determine the fonts to send to the printer with each transaction (formset) then leave this field blank. The system will load into memory the font IDs associated with each form you will print. The system will then look for the fonts in the INI file fontlib directory, then the INI file Deflib directory for the fonts. You must specify either or both these directories in the INI file.

Notes:

You must specify either the INI file fontlib directory and/ or the INI file deflib directory in the INI file.

The paths must exist and be valid names.

The fonts must be in either directory to be found.

You must also specify the INI option DownloadFonts = yes for the system to send the font files to the printer.

This option is located under the INI Group < PrtType:PCL > or < PrtType:PST >

If you include the large FNT file in this FntFile INI option, the system will send all fonts in the file to the printer.

If you leave the large FNT (PCL or Postscript font file) blank for this FntFile INI option, the system will send targeted fonts to the printer.

In this case, You must select DisplayPrintOnly = yes for the system to read these forms' font Ids as well.

Example

< MasterResource >

FntFile = rel102sm.fnt

Available

Release | _______
Patch |

Used By

AFEMAIN


FontLib

[MasterResource]
FontLib

FontLib

FontLib defines the directory path of font files, if it is different from the DefLib option.

[ MasterResource]

FontLib = Path

Parameter | Description
value | location of FontLib

This option may be required in order for the feature to function.

Example

< MasterResource >

FontLib = ..\fmres\DEFLIB\

Available

Release | _______
Patch |

Used By

AFEMAIN, GENPRINT


FORFile

[MasterResource]
FORFile

FORFile

[ MasterResource]

FORFile = File

Parameter | Description
File |

Example

< MasterResource >

FORFile = [CONFIG:rpex11] FORFile =

Available

Release | 10.3
Patch |


FORLib

[MasterResource]
FORLib

FORLib

[ MasterResource]

FORLib = Path

Parameter | Description
Path |

Example

< MasterResource >

FORLib = [CONFIG:rpex11] FORLib =

Available

Release | 10.3
Patch |


Form7x

[MasterResource]
Form7x

Form7x

The Development System uses Form7x to determine where to store FAP files created in Version 7.0 format.

[ MasterResource]

Form7x = Path

Parameter | Description
value | location of Form7x

This option may be required in order for the feature to function.

Example

< MasterResource >

Form7x = <CONFIG:xxx> Form7x =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


FormDef

[MasterResource]
FormDef

FormDef

FormDef specifies the file name of the form set definition files (form.dat, .BDF, .GRP, or .FOR).

[ MasterResource]

FormDef = File

Parameter | Description
value | location of the FormDef file

This option may be required in order for the feature to function.

Example

< MasterResource >

FormDef =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


FormFile

[MasterResource]
FormFile

FormFile

If all forms are combined into one file, FormFile specifies the form file name.

[ MasterResource]

FormFile = File

Parameter | Description
value | location of FormFile

This option may be required in order for the feature to function.

Example

< MasterResource >

FormFile =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


FormFileData

[MasterResource]
FormFileData

FormFileData

Tells the system to look for the data portions of Library Manager objects in this table (instead of in the LBY file).

[ MasterResource]

FormFileData = Path

Parameter | Description
value | Tells the system to look for the data portions of Library Manager objects in this table (instead of in the LBY file). There is no default value.

Remarks

There is no default value.

To indicate that a Library Manager data and index are to be kept in a DataBase Management System (DBMS), use INI options such as the following:

<MasterResource>

FormFile = LBYI

<Library:LBYI>

DBTable = LBYD

<DBTable:LBYI>

DBHandler = DB2

<DBTable:LBYD>

DBHandler = DB2

In the above example, the Library tables LBYI (Library Index) and LBYD (Library Data) are defined to use the DB2 handler. So, these 2 tables will exist as DB2 tables in a DB2 DBMS. Note: Documaker 10.1 used an INI option like the following to indicate that the "data" portion of a Library was defined in a DBMS:

<MasterResource>

FormFile = LBYI

FormFileData = LBYD <-- !!! OBSOLETE !!!

The FormFileData INI option above is no longer supported.

Example

< MasterResource >

FormFileData =

Available

Release | 10.1
Patch | 199


FormLib

[MasterResource]
FormLib

FormLib

Indicates location for the forms (fap files) FormLib defines the directory path of library forms and logos.

[ MasterResource]

FormLib = Path

Parameter | Description
value | location of FormLib (FAPs)

This option may be required in order for the feature to function.

Example

< MasterResource >

FormLib = .\forms\

Available

Release | _______
Patch |

Used By

AFEMAIN, GENARC, GENDATA, GENPRINT, GENTRN, GENWIP


FormsetTrigger

[MasterResource]
FormsetTrigger

FormsetTrigger

location of Formset Trigger file

[ MasterResource]

FormsetTrigger = File

Parameter | Description
location | location of Formset Trigger file

This option may be required in order for the feature to function.

Example

< MasterResource >

FormSetTrigger =

Available

Release | _______
Patch |

Used By

GENDATA, GENPRINT, GENTRN


GRPFile

[MasterResource]
GRPFile

GRPFile

[ MasterResource]

GRPFile = File

Parameter | Description
File |

Example

< MasterResource >

GRPFile = [CONFIG:rpex11] GRPFile =

Available

Release | 10.3
Patch |


GRPLib

[MasterResource]
GRPLib

GRPLib

[ MasterResource]

GRPLib = Path

Parameter | Description
Path |

Example

< MasterResource >

GRPLib = [CONFIG:rpex11] GRPLib =

Available

Release | 10.3
Patch |


HelpLib

[MasterResource]
HelpLib

HelpLib

HelpLib defines the directory path of the form related help information.

[ MasterResource]

HelpLib = Path

Parameter | Description
value | location of HelpLib

This option may be required in order for the feature to function.

Example

< MasterResource >

HelpLib =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


LbyLib

[MasterResource]
LbyLib

LbyLib

[ MasterResource]

LbyLib = Path

Parameter | Description
value |

Remarks

Depending on your system configuration, your FSIUSER.INI file may not include the following group options: FormFile, LogoFile, DalFile and LbyLib. These options relate to the Library Manager. If your company uses Image Editor to create forms, you must define your master resource library within the FSIUSER.INI for each company you define for your system. The library files must be properly defined in the INI file for users to access the correct forms.

If you assume that LbyLib is used for Path and left LbyLib = ..\mstrres\rpex1\deflib\., then LBRYMN32.exe not only gives an error, "No file of the requested type are available in ..\mstrres\rpex1\deflib\" but also wiped out this option from fapcomp.ini.

LbyLib must be used to define the name of the CABINET for library manager. It has a different purpose for different types of Library Manager. If the library manager is a file such as master.lby with master.dbf and master.mdx as index, LbyLib is used to define the path for these files. If LbyLib is not defined, the default path will be determined by Deflib = option.

Example

< MasterResource >

LbyLib = <Config:xxx> LbyLib =

Available

Release | _______
Patch |


LBYScriptLib

[MasterResource]LbyScriptLib

LbyScriptLib

[ MasterResource]

LbyScriptLib = Path

Parameter | Description
value |

Remarks

This option defines the location of Library Script files for Documaker Studio.

Example

< MasterResource >

LbyScriptLib = <Config:xxx> LbyScriptLib =

Available

Release | 11.4
Patch |


LOGOFile

[MasterResource]
LOGOFile

LOGOFile

LogoFile specifies the directory path of library logo files.

[ MasterResource]

LOGOFile = File

Parameter | Description
value | location of LOGOFile

This option may be required in order for the feature to function.

Example

< MasterResource >

LOGOFile =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


LogoLib

[MasterResource]
LogoLib

LogoLib

The system now lets you use the following option to specify a directory for logos.

[ MasterResource]

LogoLib = Path

Parameter | Description
value | The system now lets you use the following option to specify a directory for logos. If you omit this option, the system looks for logos in the path defined for FormLib.

Example

< MasterResource >

LogoLib =

Available

Release | 10.2
Patch |


MasterLibrary

MasterLibrary

[ MasterResource]

MasterLibrary = File

Parameter | Description
File |

Remarks

MasterLibrary is used to store the library name for the workspace. All of the resource file INI options, such as BDFFile, GRPFile, and FormFile, will now point to this option.

Example

< MasterResource >

MasterLibrary = [CONFIG:rpex11] MasterLibrary =

Available


OverlayPath

[MasterResource]
OverlayPath

OverlayPath

[ MasterResource]

OverlayPath = Path

Parameter | Description
Path |

Example

< MasterResource >

OverlayPath = [CONFIG:Batch_Processing] OverlayPath =

Available

Release | _______
Patch |


TableLib

[MasterResource]
TableLib

TableLib

TableLib defines the directory path of the form related table information.

[ MasterResource]

TableLib = Path

Parameter | Description
value | location of TableLib

This option may be required in order for the feature to function.

Example

< MasterResource >

TableLib =

Available

Release | 10.0
Patch |

Used By

AFEMAIN, GENDATA, GENPRINT, GENTRN


TablePath

[MasterResource]
TablePath

TablePath

Path to where the tables are stored

[ MasterResource]

TablePath = Path

Parameter | Description
Path |

Example

< MasterResource >

TablePath = <CONFIG:~Platform > TableLib =

Available

Release | 10.0
Patch |


TransTrigger

[MasterResource]
TransTrigger

TransTrigger

This option defines the directory path of the transaction trigger table (trigger).

[ MasterResource]

TransTrigger = Path

Parameter | Description
Path |

Remarks

The trigger is used with the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to build form sets and to specify recipient batches given specific transaction types and other dependent conditions. It is also used to describe overflow conditions.

Example

< MasterResource >

TransTrigger = <CONFIG:Rules Proc Example 1> TransTrigger =

Available

Release | _______
Patch |


WIPPath

[MasterResource]
WIPPath

WIPPath

Path to WIP directory.

[ MasterResource]

WIPPath = Path

Parameter | Description
Path |

Example

< MasterResource >

WIPPath = <CONFIG:~Platform > WIPPath =

Available

Release | _______
Patch |


XDDFile

[MasterResource]
XDDFile

XDDFile

[ MasterResource]

XDDFile = File

Parameter | Description
File |

Available

Release | _______
Patch |


XRFFile

[MasterResource]
XRFFile

XRFFile

XrfFile is the file name of the font cross reference file.

[ MasterResource]

XRFFile = File

Parameter | Description
value | location of the FXR file

This option may be required in order for the feature to function.

Example

< MasterResource >

XRFFile =

Available

Release | _______
Patch |

Used By

AFEMAIN


Menu

Remarks

Use the < Menu > control group to specify the directory path and file name of the Menu Resource file (MEN.RES) for the Entry System. This allows custom menus and international language support.

International Considerations

ENGUSER.INI File

The ENGUSER.INI file is one of the initialization (INI) files used by the DAP system to set system parameters and to enable or disable system features.

The ENGUSER.INI file contains information about setting up the system for an English-speaking user. This includes information that tells the system which menu file to use (so the system menus appear in the language of the user), and which Help file to display.

FCHUSER.INI File

The FCHUSER.INI file is one of the initialization (INI) files used bythe DAP system to set system parameters and to enable or disable system features.

The FCHUSER.INI file contains information about setting up the system for a Canadian French user. This includes information that tells the system where to find the translated forms, which menu file to use (so the system menus appear in the language of the user), and which Help file to display.

Example

< Menu >

File = .\MEN.RES

For French Canadian, the FCHUSER.INI could have:

< Menu >

File = .\FRENCH.RES

Menu Options

  • DDSFile
  • File
  • TXMMenu


DDSFile

[Menu]
DDSFile

DDSFile

[ Menu]

DDSFile = Path

Parameter | Description
Path |

Remarks

Use this FAPCOMP.INI control group to define the directory path and file name of the external menu resource for menu items provided by DDS workbench.

This option specifies the directory path and file name of the external menu resource for menu items provided by DDS workbench. By default, the file named as DDS.MNU is used.

Example

< Menu >

DDSFile = ..\..\DDS.MNU

Available

Release | _______
Patch |


File

[Menu]
File

File

Specify the directory path and menu resource file (MEN.RES).

[ Menu]

File = File

Parameter | Description
MenuFile | Menu file name. (MEN.RES)

Remarks

Use the file option to specify the directory path and file name of the Menu Resource file (MEN.RES) for the Entry System. This allows custom menus an international language support.

Example

< Menu >

File = .\MEN.RES

For French Canadian, the FCHUSER.INI could have:

< Menu >

File = .\FRENCH.RES

Available

Release | _______
Patch |


TXMMenu

[Menu]
TXMMenu

TXMMenu

Lets you use customized menus and toolbar for the Text Editor.

[ Menu]

TXMMenu = File

Parameter | Description
value | Lets you use customized menus and toolbar for the Text Editor.

Remarks

You can now customize the Text Editor's menus and toolbar. To do so, add this option in the Menu control group in your FSIUSER.INI or FSISYS.INI (FAPCOMP.INI for DocuCreate) file:

< Menu >

TXMMenu = filename.res

This option tells the system to find the definition of the Text Editor's menus and toolbar in the file named. For examples, you could name the file TXM.RES.

NOTE: DocuMaker uses a resource file named MEN.RES to define its menus. The TxmMenu option used here lets you do a similar thing with the Text Editor. Keep in mind, however, that the MEN.RES file can call custom functions and DLLs while the file specified with the TxmMenu option cannot. TXM.RES is an example in the INI option above. You do not have to use that file name.

Example

< Menu >

TXMMenu = filename.res

Available

Release | 10.1
Patch |


Messages

Remarks

Cache

Messages Options

  • Cache
  • DefaultLangCode
  • GroupingFlag
  • MaxMsgLength
  • SecondLanguageCode


Cache

[Messages]
Cache

Cache

[ Messages]

Cache = Edit

Parameter | Description
Edit |

Example

< Messages >

Cache = 100

Available

Release | _______
Patch |


DefaultLangCode

[Messages]
DefaultLangCode

DefaultLangCode

[ Messages]

DefaultLangCode = Edit

Parameter | Description
Edit |

Example

< Messages >

DefaultLangCode = E

Available

Release | _______
Patch |


GroupingFlag

[Messages]
GroupingFlag

GroupingFlag

[ Messages]

GroupingFlag = Edit

Parameter | Description
Edit |

Example

< Messages >

GroupingFlag = 50,1

Available

Release | _______
Patch |


MaxMsgLength

[Messages]
MaxMsgLength

MaxMsgLength

[ Messages]

MaxMsgLength = Edit

Parameter | Description
Edit |

Example

< Messages >

MaxMsgLength = 2048

Available

Release | _______
Patch |


SecondLanguageCode

[Messages]
SecondLanguageCode

SecondLanguageCode

[ Messages]

SecondLanguageCode = Edit

Parameter | Description
Edit |

Example

< Messages >

SecondLanguageCode = LanguageCode

Available

Release | _______
Patch |


MultiDataDict

Remarks

File

MultiDataDict Options

  • File


File

[MultiDataDict]
File

File

You specify XDB files using the MultiDataDict control group.

[ MultiDataDict]

File = Edit

Parameter | Description
value |

Remarks

For each XDB file, use an INI option similar to the one shown here:

< MultiDataDict >

File = FileName;IDFormat

For FileName, include the full file name and path followed by a semicolon. The IDFormat is based on the parameters you supplied to the rule.

Example

< MultiDataDict >

File = FileName;IDFormat

Available

Release | _______
Patch |


MultiExportList

Remarks

01

MultiExportList Options

  • 01


01

[MultiExportList]
01

01

This export feature does not export data. Instead, it lets you call multiple export operations during a single event.

[ MultiExportList]

01 = Edit

Parameter | Description
Edit | This export feature does not export data. Instead, it lets you call multiple export operations during a single event.

Remarks

For instance, you can use this feature to call the standard V2 export multiple times or in combination with other export routines.

Each option must list the export DLL and function name you want to execute. The export functions you list here do not have to be defined in the ExportFormats control group shown earlier. The method of defining this information is:

DLL->FunctionName

Notice the example above actually names the export function, TRNExportV2, twice in the list. Depending upon how you have configured your INI options for each export function, this may or may not result in a separate export file.

If you want to temporarily change the export options used by the called function, you can include two optional parameters, separated by semicolons, after the export function name. You can see an example of this in this option line:

02 = TRNW32->TRNExportV2;EXPORT2;EXPFILE_CD;

Each parameter names a control group that contains the options you want to temporarily use.

The first parameter names a source control group that contains alternate INI options you want to apply to the destination control group in the second parameter. The destination control group is the control group normally associated with the export operation you want to call.

The above example tells the system to copy the INI options found in the Export2 control group to the ExpFile_CD control group. The standard V2 export function, TRNExportV2, uses the ExpFile_CD control group to define its options.

During the first export, the options remain as is. During the second export operation, the system first copies the alternate options from the source control group into the destination control group used by the export function.

This option switching process replaces any INI options which have the same name and adds missing INI options to the destination group. Once the export function completes, the original INI values from the destination group are restored. This makes sure your default INI options are always left intact once the export operations are completed.

NOTE: Any INI options that exist in the destination group and are not replaced by an option in the source group are left unchanged. This means that you only have to include in the source control group those options you want to alter for the subsequent export operation.

Keep in Mind:

The individual export functions listed under the MultiExportList control group do not know they are being called indirectly or in series. Each operates normally unless you override their INI options by substituting INI options as discussed previously. Normal operation can include displaying a window to ask for an export file name or for permission to overwrite an existing file.

So, if you want your exports to work without user intervention, check the INI options for each export and use those that answer or suppress questions which have to be answered for the export to operate.

Each export operation can generate error messages. The MultiExport feature calls all export functions in the list regardless of any errors which occur inside the subordinate export functions. If one of the export operations fails, this does not necessarily prevent the other operations from being called.

If an export function named in an option in the MultiExportList control group cannot be located, an error message appears and that function is skipped.

If you define a source control group without naming a destination control group, that will cause an error and the export function will be skipped.

Do not include the multi-export function in the list declared in the MultiExportList control group.

Do not name the MultiExportList control group as a destination control group on any of the listed export functions.

If the source and destination control group are the same, the export is called without doing any substitutions.

If you specify a destination control group without specifying a source control group, the export function is called and any substitutions are omitted.

Example

< MultiExportList >

01 = TRNW32->TRNExportV2

02 = TRNW32->TRNExportV2;EXPORT2;EXPFILE_CD;

03 = TRNW32->TRNExportDS

Available

Release | 10.1
Patch | 313


ODBC_FieldConvert

ODBC_FieldConvert Options

  • AlwaysSQLPrepare
  • CREATETIME
  • CURRUSER
  • DESC
  • INUSE
  • KEY1
  • KEY2
  • KEY3
  • Message
  • MODIFYTIME
  • STATUSCODE
  • TRANCODE


AlwaysSQLPrepare

[ODBC_FieldConvert]
AlwaysSQLPrepare

AlwaysSQLPrepare

This will be needed for some databases, but not all. It is safer to ALWAYS define it.

[ ODBC_FieldConvert]

AlwaysSQLPrepare = No

Parameter | Description
Boolean (No) | This will be needed for some databases, but not all. It is safer to ALWAYS define it. Default value is: No

This option may be required in order for the feature to function.

Example

< DBHANDLER:ODBC >

AlwaysSQLPrepare = No

Available

Release | 10.1
Patch | 444


CREATETIME

[ODBC_FieldConvert]
CREATETIME

CREATETIME

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

CREATETIME = Edit

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

CREATETIME = ADD_TIME

Available

Release | _______
Patch |


CURRUSER

[ODBC_FieldConvert]
CURRUSER

CURRUSER

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

CURRUSER =

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

CURRUSER = USER_ID

Available

Release | _______
Patch |


DESC

[ODBC_FieldConvert]
DESC

DESC

Since DESC is a reserved word for SQL Server, convert it to a different name.

[ ODBC_FieldConvert]

DESC = Edit

Parameter | Description
value | Since DESC is a reserved word for SQL Server, we need to convert it to a different name.

Remarks

Use this ini setting when putting WIP into SQL server.

Example

[ ODBC_FieldConvert ]

DESC = DESC2

Available

Release | _______
Patch |


INUSE

[ODBC_FieldConvert]
INUSE

INUSE

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

INUSE =

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

INUSE = IN_USE_STATUS

Available

Release | _______
Patch |


KEY1

[ODBC_FieldConvert]
KEY1

KEY1

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

KEY1 =

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

KEY1 = TBD_1

Available

Release | _______
Patch |


KEY2

[ODBC_FieldConvert]
KEY2

KEY2

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

KEY2 =

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

KEY2 = TBD_2

Available

Release | _______
Patch |


KEY3

[ODBC_FieldConvert]
KEY3

KEY3

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

KEY3 =

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

KEY3 = TBD_3

Available

Release | _______
Patch |


Message

[ODBC_FieldConvert]
Message

Message

[ ODBC_FieldConvert]

Message =

Remarks

The columns normally defined by the system are required under the DBTABLE:USERINFO control group. If the user decides to change the name of any of these columns, they must associate that name with one of our internal names using the ODBC_FIELDCONVERT ini group.

Available

Release | _______
Patch |


MODIFYTIME

[ODBC_FieldConvert]
MODIFYTIME

MODIFYTIME

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

MODIFYTIME =

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

MODIFYTIME = MOD_TIME

Available

Release | _______
Patch |


STATUSCODE

[ODBC_FieldConvert]
STATUSCODE

STATUSCODE

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

STATUSCODE =

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

STATUSCODE = PRT_STATUS

Available

Release | _______
Patch |


TRANCODE

[ODBC_FieldConvert]
TRANCODE

TRANCODE

This FSISYS.INI control group is for field name translation.

[ ODBC_FieldConvert]

TRANCODE =

Parameter | Description
value | This FSISYS.INI control group is for field name translation.

Remarks

Use this group when the ODBC driver has limitations on field names or if the field name does not match the field name (column) from the database file. Your option lines will vary depending on the WIP, NA or POL DFD field name and the field name from your database file.

The format for group options is:

DFD FIELD NAME = DATABASE FIELD NAME

The DFD field name is the field name from WIP, NA or POL DFD file. The Database field name is the field (column) name from the database file (table).

Example

< ODBC_FieldConvert >

TRANCODE = TRX_TYPE

Available

Release | _______
Patch |


ODBC_FileConvert

Remarks

This control group is used to map the table names defined in the DBTable:tablename or ArcRet control group (e.g. APPIDX, CATALOG, etc.) to the "real" ODBC table names as it exists on the database management system. The table names defined in the DBTable: control group may not exceed eight characters. However, for ODBC, the "real" table name may be longer. If the "real" table names are not longer than eight characters, you do not need to make any entries in the ODBC_FileConvert control group. If this is not specified, the table name defined in the DBTable or ArcRet control group is used.

Example 1:

[ODBC_FileConvert]

APPIDX = DAP100_APP_R1

The option on the left (APPIDX) is the value associated with the corresponding option in the ArcRet control group. The value on the right (DAP100_APP_R1) is the name of the ODBC table as it exists in the ODBC subsystem.

Example 2:

[ODBC_FileConvert]

LBYI = DAP110_LBYI

The option on the left (LBYI) is the table name used in the DBTable:LBYI control group. The value on the right (DAP110_LBYI) is the name of the ODBC table as it exists in the ODBC subsystem.

Example

< ODBC_FileConvert >

APPIDX = FSIV100_APP_R1

ARCHIVE = FSIV100_ARC_R1

CATALOG = FSIV100_CAT_R1

RESTART = FSIV100_RES_R1

LBYI = DAP110_LBYI

LBYD = DAP110_LBYD

ODBC_FileConvert Options

  • Catalog


Catalog

[ODBC_FileConvert]
Catalog

Catalog

You can use the ODBC_FileConvert control group to convert short file names into long file names supported by the SQL database.

[ ODBC_FileConvert]

Catalog = Edit

Parameter | Description
name | ODBC Catalog Table name. You can use the ODBC_FileConvert control group to convert short file names into long file names supported by the SQL database.

Remarks

Please refer to the Remarks under the <ODBC_FileConvert> control group for detailed information.

Example

< ODBC_FileConvert >

CATALOG = FSIV100_CAT_R1

Available

Release | _______
Patch |


OMR_Params

Remarks

Mark

OMR_Params Options

  • Mark


Mark

[OMR_Params]
Mark

Mark

Definition for each OMR mark.

[ OMR_Params]

Mark =

Remarks

You need a definition for each OMR mark that can be generated on a page. For instance if eight is the maximum number of OMR marks per page, you need eight mark definitions in this control group.

Example

< OMR_Params >

Mark = Cord(20298,21000,600,1500) Rule(Always), When(All)

Available

Release | _______
Patch |


OpenUser

OpenUser Options

  • INOPENUSER


INOPENUSER

[OpenUser]
INOPENUSER

INOPENUSER

[ OpenUser]

INOPENUSER =

Parameter | Description
value | value

Available

Release | _______
Patch |


ORA_FileConvert

Remarks

This control group is used to map the table names defined in the DBTable:tablename or ArcRet control group (e.g. APPIDX, CATALOG, etc.) to the "real" Oracle table names as it exists on the database management system. The table names defined in the DBTable: control group may not exceed eight characters. However, for Oracle, the "real" table name may be longer. If the "real" table names are not longer than eight characters, you do not need to make any entries in the ORA_FileConvert control group. If this is not specified, the table name defined in the DBTable or ArcRet control group is used.

Example 1:

[ORA_FileConvert]

APPIDX = DAP100_APP_R1

The option on the left (APPIDX) is the value associated with the corresponding option in the ArcRet control group. The value on the right (DAP100_APP_R1) is the name of the Oracle table as it exists in the Oracle subsystem.

Example 2:

[ORA_FileConvert]

LBYI = DAP110_LBYI

The option on the left (LBYI) is the table name used in the DBTable:LBYI control group. The value on the right (DAP110_LBYI) is the name of the Oracle table as it exists in the Oracle subsystem.

Example

< ORA_FileConvert >

APPIDX = FSIV100_APP_R1

ARCHIVE = FSIV100_ARC_R1

CATALOG = FSIV100_CAT_R1

RESTART = FSIV100_RES_R1

LBYI = DAP110_LBYI

LBYD = DAP110_LBYD

ORA_FileConvert Options

  • Catalog


Catalog

[ORA_FileConvert]
Catalog

Catalog

[ ORA_FileConvert]

Catalog =

Parameter | Description
name | Oracle Catalog Table name

Remarks

Please refer to the Remarks under the <ORA_FileConvert> control group for detailed information.

Example

< ORA_FileConvert >

CATALOG = FSIV100_CAT_R1

Available

Release | _______
Patch |


OverflowPaperTray

Remarks

FormName

OverflowPaperTray Options

  • FormName


FormName

[OverflowPaperTray]
FormName

FormName

[ OverflowPaperTray]

FormName = Edit

Parameter | Description
value |

Remarks

Use this form set level rule (level 2), with the required INI option to change the printer tray selection during transaction processing.

This rule lets you print the first page of a form set on a special paper and the rest on different stock. For example, the first page of a utility bill is typically printed on perforated stock while the rest of the bill is printed on non-perforated stock.

;SetOverflowPaperTray;;

There are no parameters for this rule.

The FormName option is required:

< OverflowPaperTray >

FormName = Tray#

Enter the name of the form on the left and the tray you want used for the subsequent pages on the right. To specify the tray, you can only enter Trays 1-9. See the example below.

Here is an example:

< OverflowPaperTray >

Gas Bills = Tray4

Water Bills = Tray4

Elec Bills = Tray4

Keep in mind…

* You must include the PaginateAndPropagate rule in your AFGJOB.JDT file for the SetOverflowPaperTray rule to work correctly.

* When running in single- or two-step mode, place these rules in this order after the WriteOutput and WriteNAFile rules:.

; SetOverflowPaperTray;;

;PaginateAndPropagate;;

When running multi-step mode, although UpdatePOLFile rule does pagination, you must still include the PaginateAndPropagate rule in your AFGJOB.JDT file, as pagination is needed before the SetOverflowPaperTray rule executes and before the NA and POL files are updated. Here is how the rules should be placed:

;UpdatePolfile;;

;SetOverflowPaperTray;;

;PaginateAndPropagate;;

* In duplex printing mode, the first page prints on stock from the original specified paper tray (for instance, containing perforated paper). If an overflow condition occurs and additional pages are printed; because you are duplexing, the first overflow page will print on the backside of the first page (on the perforated paper). The system redirects any additional overflow pages (pages 3, 4, and so on) to the paper tray you specify using the OverflowPaperTray control group.

* In simplex printing mode, the first page prints on stock from the original specified paper tray (for instance, pre-printed color letter head). If an overflow condition occurs, additional pages are printed on stock from the redirected paper tray you specify using the OverflowPaperTray control group.

* This rule will not work when printing in duplex mode and the first page is set as a back page. Example Let's assume your Form set definition file (form.dat, .BDF, .GRP, or .FOR) specifies duplex printing, tray 2 for all images, and this INI option:

< OverflowPaperTray >

UtilBill = tray4

This tells the system to use stock from tray 2 to print the first two pages (duplex) and stock from tray 4 for the subsequent pages 3 and 4 (duplex). Here are examples of the Form set definition and POLFILE.DAT files:

Form set definition file:

;RP10;CIS;UtilBill;Utility;N;;\

billhdrp|FDLONX <Customer(1)>/\

billsum |RDLS <Customer(1)>/\

billftr |RDLS <Customer(1)>/\

billrwtr|RDLS <Customer(1)>/\

billsere|RDLS <Customer(1)>/\

billstbr|RDLS <Customer(1)>/\

billrswr|RDLS <Customer(1)>/\

billcwt3|RDLS <Customer(1)>/\

blchart |RDLS <Customer(1)>;

POLFILE.DAT file:

;RP10;CIS;UtilBill;Utility;R;;\

billhdrp|FDLONX <Customer>/\ page 1 - from Lower/tray 2 (L)

billsum |RDLSN <Customer>/\

billftr |RDLSN <Customer>/\

billhdrp|RDLONX <Customer>/\ page 2 - from Lower/tray 2 (L)

billrwtr|RDLSN <Customer>/\

billsere|RDLS <Customer>/\

billstbr|RDLSN <Customer>/\

billhdrp|RD4ONX <Customer>/\ page 3 - from tray 4 (4)

billrswr|RDLSN <Customer>/\

billcwt3|RDLSN <Customer>/\

billhdrp|RD4ONX <Customer>/\ page 4 - from tray 4 (4)

blchart |RDLS <Customer>;

\ENDDOCSET\ BillHead

Here is a simplex printing example:

Assume your Form set definition file (form.dat, .BDF, .GRP, or .FOR) specifies simplex printing, lower/tray 2 for all images, and this INI control group:

< OverflowPaperTray >

InsurBill = tray4

This tells the system to use the stock from tray 2 to print the first page and stock in tray 4 for the subsequent pages 2 and 3. Here are examples of the Form set definition and POLFILE.DAT files:

Form set definition file:

Summary of Changes

;RP10;CIS;InsurBill;NW Company;N;;\

insuhdr |DLONX <Customer(1)>/\

insuintr|DLS <Customer(1)>/\

insurate|DLOS <Customer(1)>/\

insusign|DLS <Customer(1)>;

POLFILE.DAT file:

;RP10;CIS;InsurBill;NW Company;R;;\

insuhdr |FDLONX <Customer>/\ page 1 - from Lower/tray 2 (L)

insuintr|DLS <Customer>/\

insurate|DLOS <Customer>/\

insuhdr |FD4ONX <Customer>/\ page 2 - from tray 4 (4)

insurate|DLOS <Customer>/\

insuhdr |FD4ONX <Customer>/\ page 3 - from tray 4 (4)

insusign|DLS <Customer>/\

\ENDDOCSET\ InsurHead

Example

< OverflowPaperTray >

Gas Bills = Tray4

Water Bills = Tray4

Elec Bills = Tray4

Available

Release | _______
Patch |


PaperStockID:XXX

In Documaker, you can specify that a form should print from any of nine paper trays. In version 11.2 of Documaker Studio, for Metacode printers you can additionally specify what paper stock the form should print on. This will help users who have more than nine types of paper stocks.

Here is an example of the INI options you could set up:

< PaperStockIDs >

PaperStockID = Drilled

PaperStockID = 20lb

...(and so on)

< PaperStockID:Drilled >

Description = 3-hole paper

< PaperStockID:20lbW >

Description = 20lb White Paper

DJDE = DJDE name

Once you have set up the appropriate PaperStockID INI options, you will see those

options available via Studio's Form manager.

Your selection is reflected in the POL file produced by the GenData program. In this example, the form called DEC PAGE has a paper stock ID of Drilled.

;SAMPCO;LB1;DECPAGE;||FORMPAPERSTOCK=Drilled||;R;;QPRUNA|DL(3360,18600)<AGENT,COMPANY,INSURED>

In the Metacode printer control group, you must set the TrayUsePaperStockID option to Yes, as shown here:

< PrtType:XER >

TrayUsePaperStockID = Yes

If the TrayUsePaperStockID option is set to Yes, the Metacode print driver will take the form’s PaperStockID and try to find the DJDE INI option for it in the INI file when it emits the tray command.

Available

Release | 11.2
Patch |

PaperStockID:XXX Options

  • Description
  • DJDE


Description

[PaperStockID:XXX]
Description

Description

Use this option to set the description to be shown in the form manager for this paper stock.

[ PaperStockID:XXX]

Description =

Parameter | Description
Description |

Remarks

This option sets the description of the paper stock.

Example

< PaperStockIDs >

PaperStockID = Drilled

PaperStockID = 20lb

...(and so on)

< PaperStockID:Drilled >

Description = 3-hole paper

< PaperStockID:20lbW >

Description = 20lb White Paper

DJDE = DJDE name

Available

Release | 11.2
Patch |

See Also

  • PaperStockIDs
  • PaperStockID:XXX


DJDE

[PaperStockID:XXX]
DJDE

DJDE

Use this option to set the DJDE command to use for this paper stock.

[ PaperStockID:XXX]

DJDE =

Parameter | Description
DJDE |

Remarks

This option sets the DJDE command of the paper stock.

Example

< PaperStockIDs >

PaperStockID = Drilled

PaperStockID = 20lb

...(and so on)

< PaperStockID:Drilled >

Description = 3-hole paper

< PaperStockID:20lbW >

Description = 20lb White Paper

DJDE = DJDE name

Available

Release | 11.2
Patch |

See Also

  • PaperStockIDs
  • PaperStockID:XXX


PaperStockIDs

In Documaker, you can specify that a form should print from any of nine paper trays. In version 11.2 of Documaker Studio, for Metacode printers you can additionally specify what paper stock the form should print on. This will help users who have more than nine types of paper stocks.

Here is an example of the INI options you could set up:

< PaperStockIDs >

PaperStockID = Drilled

PaperStockID = 20lb

...(and so on)

< PaperStockID:Drilled >

Description = 3-hole paper

< PaperStockID:20lbW >

Description = 20lb White Paper

DJDE = DJDE name

Once you have set up the appropriate PaperStockID INI options, you will see those

options available via Studio's Form manager.

Your selection is reflected in the POL file produced by the GenData program. In this example, the form called DEC PAGE has a paper stock ID of Drilled.

;SAMPCO;LB1;DECPAGE;||FORMPAPERSTOCK=Drilled||;R;;QPRUNA|DL(3360,18600)<AGENT,COMPANY,INSURED>

In the Metacode printer control group, you must set the TrayUsePaperStockID option to Yes, as shown here:

< PrtType:XER >

TrayUsePaperStockID = Yes

If the TrayUsePaperStockID option is set to Yes, the Metacode print driver will take the form’s PaperStockID and try to find the DJDE INI option for it in the INI file when it emits the tray command.

Available

Release | 11.2
Patch |

PaperStockIDs Options

  • PaperStockID


PaperStockID

[PaperStockIDs]
PaperStockID

PaperStockID

Use this option to list paper stocks.

[ PaperStockIDs]

PaperStockID =

Parameter | Description
PaperStockID |

Remarks

Use this option to list paper stocks.

Example

< PaperStockIDs >

PaperStockID = Drilled

PaperStockID = 20lb

...(and so on)

< PaperStockID:Drilled >

Description = 3-hole paper

< PaperStockID:20lbW >

Description = 20lb White Paper

DJDE = DJDE name

Available

Release | 11.2
Patch |

See Also

  • PaperStockIDs
  • PaperStockID:XXX


Paper

Remarks

Height

Paper Options

  • Height
  • Orientation
  • Type
  • Weight
  • Width


Height

[Paper]
Height

Height

Use this control group to set default paper properties.

[ Paper]

Height = Faps

Parameter | Description
Height | 2400 Fap Units = 1 inch

Remarks

This option sets the default height measurement for print paper. This option may be set in the Editor Properties window under the Options menu in the Image Editor.

Example

< Paper >

Height = 26400

Available

Release | _______
Patch |


Orientation

[Paper]
Orientation

Orientation

[ Paper]

Orientation = 0

Parameter

Description

Orientation

Values can be

  • 0 - Portrait
  • 1 - Landscape

Default value is: 0

Example

< Paper >

Height = 19843

Orientation = 0

Type = 98

Width = 28063

Available

Release | _______
Patch |


Type

[Paper]
Type

Type

[ Paper]

Type = 0

Parameter

Description

type

Values can be

  • 0 - Letter
  • 1 - Legal
  • 2 - A4
  • 3 - Executive
  • 4 - US Ledger
  • 5 - US Tabloid
  • 6 - US Statement
  • 7 - US Folio
  • 8 - US Fanfold
  • 20 - ISO A0
  • 21 - ISO A1
  • 22 - ISO A2
  • 23 - ISO A3
  • 24 - ISO A4
  • 25 - ISO A5
  • 26 - ISO A6
  • 27 - ISO A7
  • 28 - ISO A8
  • 29 - ISO A9
  • 30 - ISO A10
  • 32 - ISO 2A
  • 34 - ISO 4A
  • 40 - ISO B0
  • 41 - ISO B1
  • 42 - ISO B2
  • 43 - ISO B3
  • 44 - ISO B4
  • 45 - ISO B5
  • 46 - ISO B6
  • 47 - ISO B7
  • 48 - ISO B8
  • 49 - ISO B9
  • 50 - ISO B10
  • 52 - ISO 2B
  • 54 - ISO 4B
  • 60 - ISO C0
  • 61 - ISO C1
  • 62 - ISO C2
  • 63 - ISO C3
  • 64 - ISO C4
  • 65 - ISO C5
  • 66 - ISO C6
  • 67 - ISO C7
  • 68 - ISO C8
  • 69 - ISO C9
  • 70 - ISO C10
  • 71 - ISO DL
  • 80 - JIS B0
  • 81 - JIS B1
  • 82 - JIS B2
  • 83 - JIS B3
  • 84 - JIS B4
  • 85 - JIS B5
  • 86 - JIS B6
  • 87 - JIS B7
  • 88 - JIS B8
  • 89 - JIS B9
  • 90 - JIS B10
  • 98 - Custom
  • 99 - Current Type

Default value is: 0

Example

< Paper >

Height = 19843

Orientation = 0

Type = 98

Width = 28063

Available

Release | _______
Patch |


Weight

[Paper]
Weight

Weight

Use this control group to set default paper properties.

[ Paper]

Weight = Spin

Parameter | Description
Spin | 2400 Fap Units = 1 inch

Remarks

This option sets the default width measurement for print paper. This option may be set in the Editor Properties window under the Options menu in the Image Editor.

Example

< Paper >

Width = 20400

Available

Release | _______
Patch |


Width

[Paper]
Width

Width

[ Paper]

Width = Faps

Parameter | Description
width |

Example

< Paper >

Height = 19843

Orientation = 0

Type = 98

Width = 28063

Available

Release | _______
Patch |


PDF_Encryption

Remarks

The PDF Print Driver can now generate files that use the Advanced Encryption Standard (AES). AES is supported by Adobe’s PDF standard beginning with version 1.6 (Acrobat 7 and higher).

PDF_Encryption Options

  • AES_Encryption


AES_Encryption

[PDF_Encryption]
AES_Encryption

AES_Encryption

AES is much more secure than the RC4 encryption used in prior versions of Acrobat. To enable AES encryption, add this setting in your INI file:

[PDF_Encryption]

AES_Encryption = Yes

Parameter | Description
Boolean | Enter Yes to create that use the Advanced Encryption Standard (AES). The default is No.

Remarks

The PDF Print Driver can now generate files that use the Advanced Encryption Standard (AES). AES is supported by Adobe’s PDF standard beginning with version 1.6 (Acrobat 7 and higher).

NOTE: To view AES-encrypted PDF files, you must have Acrobat Reader version 7.0 or higher. The current version of Acrobat Reader is 9.0 and can be downloaded for free at Adobe’s web site.

NOTE: When you run the PDFKEY utility, it creates the INI options and settings you need to add to your INI file. For example, the utility can either write the output to the terminal session or you can send it to a file name and extension you specify by adding a parameter similar to this to the end of the command you use to run the PDFKEY utility:
> filename.extension
For best results, copy these INI options and settings from that text file and paste them into your INI file.

The actual control group name may vary. The name of the control group should match the value of the SecurityGroup option in the PDF printer INI control group.

Keep in mind:

  • AES encryption causes a small increase in the size of the output file. For example, in one test, the increase was about 1.9%, from 16593 bytes to 16901 bytes. For larger files, the size increase (as a percentage) should be smaller. The AES algorithm was developed to be very efficient. No performance impact is expected.
  • AES encryption requires a 128-bit key length. This will be enforced by the PDFKEY utility and the PDF Print Driver.
  • To generate keys for AES encryption, include the /AES parameter when you run the PDFKEY utility.

Example

< PDF_Encryption >

AES_Encryption = Yes

Available

Release | 11.4
Patch |


PDFViewerOptions

PDFViewerOptions

  • CenterWindow
  • Direction
  • DisplayDocTitle
  • Duplex
  • FitWindow
  • HideMenubar
  • HideToolbar
  • HideWindowUI
  • NonFullScreenPageMode
  • NumCopies
  • PickTrayByPDFSize
  • PrintPageRange
  • PrintScaling


CenterWindow

[PDFViewerOptions]
CenterWindow

CenterWindow

Now you can specify a set of viewer preferences for the PDF files you create.

[PDFViewerOptions]

CenterWindow = Yes

Parameter | Description
Boolean | Enter Yes if you want the PDF viewer to size its window to the page contents. The default is No.

Remarks

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

CenterWindow = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


Direction

[PDFViewerOptions]
Direction

Direction

Now you can specify a set of viewer preferences for the PDF files you create.

[PDFViewerOptions]

Direction = L2R

Parameter

Description

List

Specify the reading order.

Chooser

  • L2R to specify the reading order for text as left to right.
  • R2L to specify the reading order as or right to left.

The default is L2R.

Remarks

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

Direction = L2R

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


DisplayDocTitle

[PDRViewerOptions]
DisplayDocTitle

DisplayDocTitle

Now you can specify a set of viewer preferences for the PDF files you create.

Note: Requires PDF version 1.4.

[PDFViewerOptions]

DisplayDocTitle = Yes

Parameter | Description
Boolean | Enter Yes if you want the PDF viewer to display the document title. The default is No, which tells the viewer to display the PDF file name.

Remarks

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

DisplayDocTitle = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


Duplex

[PDRViewerOptions]
Duplex

Duplex

Now you can specify a set of viewer preferences for the PDF files you create.

Note: Requires PDF version 1.7.

[PDFViewerOptions]

Duplex = Simplex

Parameter

Description

List Options

Use this option to specify the default duplex options for the Print window. You can choose from:

  • Simplex - Print single-sided
  • DuplexFlipShortEdge - Print duplex and flip on the short edge of the sheet
  • DuplexFlipLongEdge - Print duplex and flip on the long edge of the sheet

Remarks

The printing related options (PrintScaling, Duplex, PickTrayByPDFSize, and NumCopies) merely set defaults for the Print window. You can change these defaults at print time.

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

Duplex = Simplex

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


FitWindow

[PDFViewer]
FitWindow

FitWindow

Now you can specify a set of viewer preferences for the PDF files you create.

[PDFViewerOptions]

FitWindow = Yes

Parameter | Description
Boolean | Enter Yes if you want the PDF viewer to size its window to the page contents. The default is No.

Remarks

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

FitWindow = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


HideMenubar

[PDRViewerOptions]
HideMenubar

HideMenubar

Now you can specify a set of viewer preferences for the PDF files you create.

[PDFViewerOptions]

HideMenubar = Yes

Parameter | Description
Boolean | Enter Yes if you want the PDF viewer to hide the menu bar. The default is No.

Remarks

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

HideMenubar = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


HideToolbar

[PDFViewerOptions]
HideToolbar

HideToolbar

Now you can specify a set of viewer preferences for the PDF files you create.

[PDFViewerOptions]

HideToolbar = Yes

Parameter | Description
Boolean | Enter Yes if you want the PDF viewer to hide the toolbar. The default is No.

Remarks

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

HideToolbar = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


HideWindowUI

[PDRViewerOptions]
HideWindowUI

HideWindowUI

Now you can specify a set of viewer preferences for the PDF files you create.

[PDFViewerOptions]

HideWindowUI = Yes

Parameter | Description
Boolean | Enter Yes if you want the PDF viewer to hide items such as scroll bars and navigation controls. The default is No.

Remarks

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

HideWindowUI = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


NonFullScreenPageMode

[PDFViewerOptions]
NonFullScreenPageMode

NonFullScreenPageMode

Now you can specify a set of viewer preferences for the PDF files you create.

[PDFViewerOptions]

NonFullScreenPageMode = UseOutlines

Parameter

Description

List Options

This option tells the PDF viewer what to do when the user exits full-screen mode. This is only used if the DisplayMode option of the PDF printer group is set to FullScreen.

You can choose from these options:

  • UseNone - None of outline, thumbnail, or option content panes are visible
  • UseOutlines - The outline pane is visible UseThumbs - The thumbnail image pane is visible
  • UseOC - The optional content pane is visible

The default is UseNone.

Remarks

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

NonFullScreenPageMode = UseOutlines

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


NumCopies

[PDFViewerOptions]
NumCopies

NumCopies

Now you can specify a set of viewer preferences for the PDF files you create.

Note: Requires PDF version 1.7.

[PDFViewerOptions]

NumCopies = 2

Parameter | Description
List Options | Enter a number between 2 and five (inclusive) to specify the number of copies to print. The default varies, depending on the viewer.

Remarks

The printing related options (PrintScaling, Duplex, PickTrayByPDFSize, and NumCopies) merely set defaults for the Print window. You can change these defaults at print time.

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

NumCopies = 2

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


PickTrayByPDFSize

[PDRViewerOptions]
PickTrayByPDFSize

PickTrayByPDFSize

Now you can specify a set of viewer preferences for the PDF files you create.

Note: Requires PDF version 1.6.

[PDFViewerOptions]

PickTrayByPDFSize = Yes

Parameter

Description

Boolean
  • Enter Yes if you want to use the PDF page size to select the paper tray when printing.
  • Enter No if you do not want the PDF viewer to use the PDF pages size to select the paper tray.

Remarks

The printing related options (PrintScaling, Duplex, PickTrayByPDFSize, and NumCopies) merely set defaults for the Print window. You can change these defaults at print time.

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

PickTrayByPDFSize = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


PrintPageRange

[PDFViewerOptions]
PrintPageRange

PrintPageRange

Now you can specify a set of viewer preferences for the PDF files you create.

Note: Requires PDF version 1.7.

[PDFViewerOptions]

PrintPageRange = 1-2

Parameter | Description
List Options | Use this option to specify the range of pages to be printed. The format is firstpage-lastpage where firstpage and lastpage are the beginning and ending page numbers. Here is an example: PrintPageRange = 2-7 This tells the system to print pages two through seven of the document. The default varies, depending on the viewer.

Remarks

The printing related options (PrintScaling, Duplex, PickTrayByPDFSize, and NumCopies) merely set defaults for the Print window. You can change these defaults at print time.

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

PrintPageRange = 1-2

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


PrintScaling

[PDRViewerOptions]
PrintScaling

PrintScaling

Now you can specify a set of viewer preferences for the PDF files you create.

Note: Requires PDF version 1.6.

[PDFViewerOptions]

PrintScaling = None

Parameter

Description

List Options

Use this option to specify the default page scaling option for the Print window. You can choose from these options:

  • AppDefault - Use the application’s current default value
  • None - Do not scale the page

The default is AppDefault.

Remarks

The printing related options (PrintScaling, Duplex, PickTrayByPDFSize, and NumCopies) merely set defaults for the Print window. You can change these defaults at print time.

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

< PDFViewerOptions >

PrintScaling = None

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

ViewerPreferences


Personal

Remarks

Group1

Personal Options

  • Group1
  • Group2


Group1

[Personal]
Group1

Group1

The personal text entered for the Group1 option will appear as a choice in the Key1 list.

[ Personal]

Group1 =

Parameter | Description
value | The personal text entered for the Group1 option will appear as a choice in the Key1 list.

Remarks

Use this FSISYS.INI control group to specify new KEY1 (company) and KEY2 (LOB) selections for the Form Selection window. These new options pertain to the personal forms list feature.

Example

< Personal >

Group1 = Personal

Available

Release | _______
Patch |


Group2

[Personal]
Group2

Group2

The personal text entered for the Group2 option will appear as a choice in the Key2 list.

[ Personal]

Group2 =

Parameter | Description
value | The personal text entered for the Group2 option will appear as a choice in the Key2 list.

Remarks

Use this FSISYS.INI control group to specify new KEY1 (company) and KEY2 (LOB) selections for the Form Selection window. These new options pertain to the personal forms list feature.

Example

< Personal >

Group2 = Personal

Available

Release | _______
Patch |


PO:ARCCAB

PO:
ARCCAB

Remarks

FileType

PO:ARCCAB Options

  • FileType
  • FolderBy
  • NameDocBy


FileType

[PO:ARCCAB]
FileType

FileType

Use this option to define the file types that can be placed in the folder.

[ PO:ARCCAB]

FileType =

Parameter | Description
value | Use this option to define the file types that can be placed in the folder.

Example

< PO:ARCCAB >

FileType = dap

Available

Release | 10.1
Patch |


FolderBy

[PO:ARCCAB]
FolderBy

FolderBy

Use this option to define the fields you want the system to use to sort the document into the various folders.

[ PO:ARCCAB]

FolderBy =

Parameter | Description
value | Use this option to define the fields you want the system to use to sort the document into the various folders. For instance, if you enter KEY1,KEY2,KEYID, the system places documents which have the same data in these fields in the same folder.

Remarks

For instance, if you enter KEY1,KEY2,KEYID, the system places documents which have the same data in these fields in the same folder.

Example

< PO:ARCCAB >

FolderBy = KEY1,KEY2,KEYID

Available

Release | 10.1
Patch |


NameDocBy

[PO:ARCCAB]
NameDocBy

NameDocBy

Use this option to tell the system which field contains the document name. If you omit this field, the systems uses ARCKEY.

[ PO:ARCCAB]

NameDocBy =

Parameter | Description
Edit | Use this option to tell the system which field contains the document name. If you omit this field, the systems uses ARCKEY.

Example

< PO:ARCCAB >

NameDocBy = KEY1,KEYID,TRANCODE

Available

Release | 10.1
Patch |


PODocument2Field

Remarks

CreateTime

PODocument2Field Options

  • CreateTime


CreateTime

[PODocument2Field]
CreateTime

CreateTime

Use this control group to map the OT_Docs fields to the DFD fields.

[ PODocument2Field]

CreateTime =

Parameter | Description
value | Use this control group to map the OT_Docs fields to the DFD fields:

Example

< PODocument2Field >

CreateTime = AddedOn

Available

Release | _______
Patch |


POField2Document

Remarks

AddedOn

POField2Document Options

  • AddedOn


AddedOn

[
POField2DocumenAddedOnt]
AddedOn

Use this control group to map the DFD fields to the OT_Docs fields.

[ POField2Document]

AddedOn =

Parameter | Description
value | Use this control group to map the DFD fields to the OT_Docs fields.

Remarks

For instance, this example assumes that AddedOn is in the OT_Docs table:

< POField2Document >

AddedOn = CreateTime

Example

< POField2Document >

AddedOn = CreateTime

Available

Release | _______
Patch |


PO:PROD

PO:
PROD

Remarks

FileType

PO:PROD Options

  • FileType
  • FolderBy
  • ForceFolderUpdate
  • NameDocBy


FileType

[PO:PROD]
FileType

FileType

Feature 1397 You can now use the new ForceFolderUpdate INI option to force folder updates when the folder already exists.

[ PO:PROD]

FileType = No

Parameter | Description
boolean | You can now use the new ForceFolderUpdate INI option to force folder updates when the folder already exists. Default value is: No

Remarks

This lets Documanage Folder Update Authorities, when set to No, prevent duplicate archive entries from

being sent to the Documanage archive repository.

Example

< PO:Prod >

FileType = PROD

FolderBy = DOC_TYPE_CODE,DOC_NUM,DOC_REV_NUM

NameDocBy = DOC_TYPE_CODE,DOC_NUM,DOC_REV_NUM

ForceFolderUpdate = Yes

Available

Release | 10.1
Patch | 452


FolderBy

[PO:PROD]
FolderBy

FolderBy

Feature 1397 You can now use the new ForceFolderUpdate INI option to force folder updates when the folder already exists.

[ PO:PROD]

FolderBy = Edit

Parameter | Description
value | You can now use the new ForceFolderUpdate INI option to force folder updates when the folder already exists.

Remarks

This lets Documanage Folder Update Authorities, when set to No, prevent duplicate archive entries from

being sent to the Documanage archive repository.

Example

< PO:Prod >

FileType = PROD

FolderBy = DOC_TYPE_CODE,DOC_NUM,DOC_REV_NUM

NameDocBy = DOC_TYPE_CODE,DOC_NUM,DOC_REV_NUM

ForceFolderUpdate = Yes

Available

Release | 10.1
Patch | 452


ForceFolderUpdate

[PO:PROD]
ForceFolderUpdate

ForceFolderUpdate

Feature 1397 You can now use the new ForceFolderUpdate INI option to force folder updates when the folder already exists.

[ PO:PROD]

ForceFolderUpdate = No

Parameter | Description
boolean (No) | You can now use the new ForceFolderUpdate INI option to force folder updates when the folder already exists. Default value is: No

Remarks

This lets Documanage Folder Update Authorities, when set to No, prevent duplicate archive entries from

being sent to the Documanage archive repository.

Example

< PO:Prod >

ForceFolderUpdate = Yes

Available

Release | 10.1
Patch | 452


NameDocBy

[PO:PROD]
NameDocBy

NameDocBy

Feature 1397 You can now use the new ForceFolderUpdate INI option to force folder updates when the folder already exists.

[ PO:PROD]

NameDocBy = Edit

Parameter | Description
value | You can now use the new ForceFolderUpdate INI option to force folder updates when the folder already exists.

Remarks

This lets Documanage Folder Update Authorities, when set to No, prevent duplicate archive entries from

being sent to the Documanage archive repository.

Example

< PO:Prod >

FileType = PROD

FolderBy = DOC_TYPE_CODE,DOC_NUM,DOC_REV_NUM

NameDocBy = DOC_TYPE_CODE,DOC_NUM,DOC_REV_NUM

ForceFolderUpdate = Yes

Available

Release | 10.1
Patch | 452


Print

Print Options

  • CallbackFunc
  • COMPILEINSTREAM
  • MultiFileLog
  • RCBDfdField
  • SENDOVERLAY
  • Booklet


CallbackFunc

[Print]
CallbackFunc

CallbackFunc

The GenPrint program creates the print stream for each recipient batch and sends it to a printer output file.

[ Print]

CallbackFunc = Path

Parameter | Description
value | user specified function

Remarks

A batch active flag tells PRTLIB's installed output function to keep the current file open and to append each output group to the active stream, only closing the file at the end of the batch. However, for PDF or RTF output to be viewied correctly, you need to create a separate file for each transaction in the batch. In DAP version 9.5, a new callback function is included in the GenPrint program to do this. This callback function is called MultiFilePrint().

To use this callback function, you must change the FSISYS.INI file as shown below:

< Print >

CallbackFunc = MultiFilePrint

MultiFileLog = { full path file name of a log file (optional) }

As of version 9.5 when this function was implemented this is the naming convention.:

The first file name written out is the same as on the INI option PORT (I.e. PORT = DATA\PdfBAT1.pdf ); the remaining file names use the 1st four character of the port name plus a index number of 2 thru 999.

The CallbackFunc = MultiFilePrint option breaks the RTF file into smaller files. This is necessary because you can only view the first transaction in a large RTF file. The RTFLOG.DAT file stores the information about which RTF contains which transaction for which batch.

The new email print driver uses the RTF print driver to email form sets.

CUSMultiFilePrint() is a print callback function that creates a new output file for each recipient and creates a log record of each. This is similar to the MultiFilePrint callback in GenPrint except it allows for greater control over the name of the file, and supports long file names. The assumption behind this function is that a built-in INI function will be used to create the filename unqiue each time. This is important because the callback itself has no ability to assign the very first filename. You can use the DAL function to assign the very first filename.

Here is an example of the INI options:

< Printer1 >

Port = ~DALRUN Batch1Files.dal

< Print >

CallbackFunc = CUSMultiFilePrint

An example of the DAL script is as follows:

#counter = #counter

file_name = "cusmultifileprint" & #counter & ".pdf"

#counter = #counter+1

return (file_name)

Please note that this function is used for the multiple steps process only.

Feature 1350 Sorting Forms by Recipient

Use the SortFormsForRecip call back function to sort forms in a different order, depending on recipient. This function reads the given sort table and sorts the forms by recipient. A form identifier called a Document Type Number (DTN) tells the system how to sort the forms. The DTN resides in the form description of the Form set definition file (form.dat, .BDF, .GRP, or .FOR) and begins with a tilde (~).

Example

< Print >

CallbackFunc = MultiFilePrint

OR,

CallbackFunc = SortFormsForRecip

Do not use both of these at the same time, as your results will be unpredictable.

Available

Release | 10.1
Patch |

Used By

GENPRINT


COMPILEINSTREAM

[Print]
COMPILEINSTREAM

COMPILEINSTREAM

Use this FSIUSER.INI control group to specify information used by the Metacode Print Driver.

[ Print]

COMPILEINSTREAM = YN

Parameter | Description
Boolean | This option controls the compilation method used by the Metacode Print Driver. Set this option to Yes to compile the overlays (images) from fap files, then send the compiled overlays in the print stream.

Remarks

This option controls the compilation method used by the Metacode Print Driver. Set this option to Yes to compile the overlays (images) from fap files, then send the compiled overlays in the print stream.

Example

< Print >

COMPILEINSTREAM = Yes

Available

Release | _______
Patch |


MultiFileLog

[Print]
MultiFileLog

MultiFileLog

[ Print]

MultiFileLog =

Available

Release | _______
Patch |


RCBDfdField

[Print]
RCBDfdField

RCBDfdField

[ Print]

RCBDfdField =

Parameter | Description
value |

Remarks

If you intend to use the GenPrint program instead of single-step processing, you must include these Print control group options:

< Print >

RCBDfdField = PDFNAME

CallBackFunc = MultiFilePrint

MultiFileLog = ..\data\MFP.LOG

In single-step mode, you must have these INI options:

< PrintFormset >

RCBDfdField = PDFNAME

MultiFilePrint = Yes

LofFileType = Text (or XML)

LogFile = mfp.log

Example

< Print >

RCBDfdField = PDFNAME

CallBackFunc = MultiFilePrint

MultiFileLog = ..\data\MFP.LOG

Available

Release | _______
Patch |


SENDOVERLAY

[Print]
SENDOVERLAY

SENDOVERLAY

Use this FSIUSER.INI control group to specify information used by the Metacode Print Driver.

[ Print]

SENDOVERLAY =

Parameter | Description
value | This option sends the overlays (images) in the print stream. For Metacode printing, the SENDOVERLAY and COMPILEINSTREAM options are mutually exclusive. If COMPILEINSTREAM = Yes, then SENDOVERLAY must be No.

Remarks

This option sends the overlays (images) in the print stream. For Metacode printing, the SENDOVERLAY and COMPILEINSTREAM options are mutually exclusive. If COMPILEINSTREAM = Yes, then SENDOVERLAY must be No.

Example

< Print >

SENDOVERLAY = No

Available

Release | _______
Patch |


Booklet

Boo klet

[ Print]

Booklet =

Parameter | Description
Name of the booklet group | This option identifies the booklet option to be used.

Remarks

You can use Documaker Server to print booklets. A booklet is a 2-up duplex print format that can be stapled in the middle and folded to form a small book. Although the system does not impose a size limit, there is a practical limit on the number of pages that can be affixed in this manner. The system lets you customize the paper size, cover sheets, a custom blank page, and different size and tray selections for the cover sheet and booklet pages.

Example

< Print >

Booklet = MyBooklet

< Booklets >

Booklet = MyBooklet

< Booklet:MyBooklet >

BookletPapersize =

BookletTray =

RightGutter =

BlankPage =

CoverSheet =

CoverFrontOut =

CoverFrontIn =

CoverBackOut =

CoverBackIn =

CoverTray =

Available

Release | Rel 11.5
Patch |


Print_Batches

Remarks

The names of the entries in the [ Print_Batches ] INI group are user-defined.

In other words, you could call them something else besides Batch1, Batch2, etc.

The value of each entry is that name of the recipient batch file.

In the example below, "Batch1" is the name of one of the entries in the [ Print_Batches ] INI group and ".\data\Batch1.BCH" is the name of the recipient batch file.

< Print_Batches >

Batch1 = .\data\Batch1.BCH

The format of the recipient batch file is defined by the RCBDFDFL.DFD.

"Batch1" or the name of an entry in the [ Print_Batches ] INI group is also used as the name of an INI group that names the Printer used for that recipient print batch.

The "Batch1" INI group usually contains a "Printer" entry whose value is the name of another INI group.

In the example below, the "Batch1" INI group contains a "Printer" entry whose value "Printer1" is the name of another INI group.

< BATCH1 >

Printer = Printer1

The "Printer1" INI group contains a "PORT" entry whose value is the name of the device or file to write to when printing this recipient print batch.

In the example below, the "Printer1" INI group contains a "PORT" entry whose value data\afpbat1" is the name of the file to produce when printing this recipient print batch.

< Printer1 >

PORT = data\afpbat1

Print_Batches Options

  • Batch1
  • Error
  • Manual


Batch1

[Print_Batches]
Batch1

Batch1

[ Print_Batches]

Batch1 =

Remarks

The option name itself (BATCH1) is important in that GENPRINT will attempt to find an INI control group of that name in order to find out where to send the print created for that recipient batch file. The filename is an unqualified file name that describes the recipient batch file. These recipient batch files will be created and written to during GENDATA and will be opened and read from during GENPRINT.

Filenames for the MVS environment follow the convention DD:BATCH1, etc.; this notation signifies that the recipient batch file is the file associated with the DD statement named BATCH1.

Example

< Print_Batches >

Batch1 = Batch1.BCH

Available

Release | 10.0
Patch |


Error

[Print_Batches]
Error

Error

The ERROR option names the recipient batch file created by GENDATA for the ERROR recipient batch.

[ Print_Batches]

Error = File

Parameter | Description
File |

Remarks

Error batches consist of form sets with invalid transactions.

This FSISYS.INI control group provides GENDATA with the names of the recipient batches (BATCH1, BATCH2, etc.) and with the names of the recipient batch files (BATCH1.BCH, BATCH2.BCH, etc.) that GENDATA will create. Since GENPRINT has to open and read the recipient batch file, it also uses this group.

Example

< PRINT_BATCHES >

ERROR = ERROR.BCH

Available

Release | 10.0
Patch |


Manual

[Print_Batches]
Manual

Manual

Specifies the name of the manual recipient batch and the manual recipient batch filename which GENDATA will write to.

[ Print_Batches]

Manual = File

Parameter | Description
File |

Remarks

Manual batches consist of incomplete form sets or form sets having fields marked for manual entry.

Example

< PRINT_BATCHES >

MANUAL = MANUAL.BCH

Available

Release | _______
Patch |


Print_To_Folder

Remarks

Test_Folder

Print_To_Folder Options

  • Example_Folder
  • Sample_Folder
  • Test_Folder


Example_Folder

[Print_To_Folder]
Example_Folder

Example_Folder

1376 Directing Print Streams

[ Print_To_Folder]

Example_Folder = Edit

Parameter | Description
Edit |

Remarks

Now you can specify the folder you would like to send a print stream to while on the Print Window. You use this INI control group to specify choices:

< Print_To_Folder >

Test_Folder = d:\DAP\Test_Folder

Example_Folder =d:\DAP\Example_Folder

Sample_Folder =d:\DAP\Sample_Folder

The names of the folders you specify, such as Test_Folder, appear as options the user can choose from on the Print Window. You can select one folder per print. You can also print to the same folder as many times as necessary. The system creates a unique file name for each print stream which cannot be overwritten. The names of these print streams are a combination of the user name, the date (using format E-Mar062003), and the time (192459 is 07:24:59).

Example

< Print_To_Folder >

Test_Folder = d:\DAP\Test_Folder

Example_Folder =d:\DAP\Example_Folder

Sample_Folder =d:\DAP\Sample_Folder

Available

Release | 10.1
Patch | 447


Sample_Folder

[Print_To_Folder]
Sample_Folder

Sample_Folder

1376 Directing Print Streams

[ Print_To_Folder]

Sample_Folder = Edit

Parameter | Description
Edit |

Remarks

Now you can specify the folder you would like to send a print stream to while on the Print Window. You use this INI control group to specify choices:

< Print_To_Folder >

Test_Folder = d:\DAP\Test_Folder

Example_Folder =d:\DAP\Example_Folder

Sample_Folder =d:\DAP\Sample_Folder

The names of the folders you specify, such as Test_Folder, appear as options the user can choose from on the Print Window. You can select one folder per print. You can also print to the same folder as many times as necessary. The system creates a unique file name for each print stream which cannot be overwritten. The names of these print streams are a combination of the user name, the date (using format E-Mar062003), and the time (192459 is 07:24:59).

Example

< Print_To_Folder >

Test_Folder = d:\DAP\Test_Folder

Example_Folder =d:\DAP\Example_Folder

Sample_Folder =d:\DAP\Sample_Folder

Available

Release | 10.1
Patch | 447


Test_Folder

[Print_To_Folder]
Test_Folder

Test_Folder

1376 Directing Print Streams

[ Print_To_Folder]

Test_Folder = Edit

Parameter | Description
Edit |

Remarks

Now you can specify the folder you would like to send a print stream to while on the Print Window. You use this INI control group to specify choices:

< Print_To_Folder >

Test_Folder = d:\DAP\Test_Folder

Example_Folder =d:\DAP\Example_Folder

Sample_Folder =d:\DAP\Sample_Folder

The names of the folders you specify, such as Test_Folder, appear as options the user can choose from on the Print Window. You can select one folder per print. You can also print to the same folder as many times as necessary. The system creates a unique file name for each print stream which cannot be overwritten. The names of these print streams are a combination of the user name, the date (using format E-Mar062003), and the time (192459 is 07:24:59).

Example

< Print_To_Folder >

Test_Folder = d:\DAP\Test_Folder

Example_Folder =d:\DAP\Example_Folder

Sample_Folder =d:\DAP\Sample_Folder

Available

Release | 10.1
Patch | 447


Printer

Printer Options

  • BatchBannerBeginForm
  • BatchBannerBeginScript
  • BatchBannerEndForm
  • BatchBannerEndScript
  • EnableBatchBanner
  • EnableTransBanner
  • GenerateFileName
  • PageNumberFormat
  • Port
  • PrtType
  • RecipientPrintOrder
  • RightJustifyPageNumber
  • SuppressDialog
  • TransBannerBeginForm
  • TransBannerBeginScript
  • TransBannerEndForm
  • TransBannerEndScript


BatchBannerBeginForm

[Printer]
BatchBannerBeginForm

BatchBannerBeginForm

You can globally specify forms and scripts for all batches, or locally for specific batches.

[ Printer]

BatchBannerBeginForm =

Parameter | Description
value | You can globally specify forms and scripts for all batches, or locally for specific batches.

Remarks

Use these INI options to specify global batch forms and scripts:

< Printer >

BatchBannerBeginForm = form name

BatchBannerBeginScript = script name

BatchBannerEndForm = form name

BatchBannerEndScript = script name

TransBannerBeginForm = form name

TransBannerBeginScript = script name

TransBannerEndForm = form name

TransBannerEndScript = script name

Specify form names as follows:

;KEY1;KEY2;Form name;

You must have an associated form line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to match the specified form. The images (FAP files) for the forms are specified in the form lines in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). You must include these FAP files in FormLib.

Store the banner forms in a separate and unique banner form group, defined by a combination of Key1 and Key2. You can use the AddForm DAL function in a DAL script to insert additional forms for banner processing. Place these additional forms and images in the same group as the initial banner form. Each form is printed separately

and after all banner forms are printed, the entire banner group is removed from the document set. For these reasons, it is critical that you isolate the banner forms from the rest of the transaction document set by specifying a Key1/Key2 combination that does not otherwise occur within the document.

The FAP files assigned to the form (on the form line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR)) must have the recipient BANNER with a copy count of at least one. When banner forms are printed, only images assigned to the recipient BANNER with a non-zero copy count are printed.

Specify the DAL script names without a path or extension. We recommend that you store the DAL scripts in your DAL libraries because they are easier to maintain. DAL libraries are automatically be loaded if specified in the INI file as shown here:

< DALLibraries >

LIB = library1

LIB = library2

The DAL script libraries or files must reside in DefLib. You can specify forms and scripts at the recipient batch level to override the global specification. Here is an example of how you do this:

< Print_Batches >

BATCH1 = BATCH1.BCH

BATCH2 = BATCH2.BCH

< Batch1 >

BatchBannerBeginForm = form name

BatchBannerBeginScript = script name

BatchBannerEndForm = form name

BatchBannerEndScript = script name

TransBannerBeginForm = form name

TransBannerBeginScript = script name

TransBannerEndForm = form name

TransBannerEndScript = script name

You can specify some, none, or all of the forms and scripts for local override of the default global forms and scripts.

An individual batch can completely or partially disable banner processing if the forms, script names, or both are blank, as shown here:

< Batch1 >

BatchBannerBeginForm =

BatchBannerBeginScript =

BatchBannerEndForm =

BatchBannerEndScript =

TransBannerBeginForm =

TransBannerBeginScript =

TransBannerEndForm =

TransBannerEndScript =

Example

< Printer >

BatchBannerBeginForm = ;BANNER;BATCH;BATCH BANNER;

Available

Release | 10.1
Patch |


BatchBannerBeginScript

[Printer]
BatchBannerBeginScript

BatchBannerBeginScript

You can globally specify forms and scripts for all batches, or locally for specific batches.

[ Printer]

BatchBannerBeginScript =

Parameter | Description
value | You can globally specify forms and scripts for all batches, or locally for specific batches.

Remarks

Use these INI options to specify global batch forms and scripts:

< Printer >

BatchBannerBeginForm = form name

BatchBannerBeginScript = script name

BatchBannerEndForm = form name

BatchBannerEndScript = script name

TransBannerBeginForm = form name

TransBannerBeginScript = script name

TransBannerEndForm = form name

TransBannerEndScript = script name

Specify form names as follows:

;KEY1;KEY2;Form name;

You must have an associated form line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to match the specified form. The images (FAP files) for the forms are specified in the form lines in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). You must include these FAP files in FormLib.

Store the banner forms in a separate and unique banner form group, defined by a combination of Key1 and Key2. You can use the AddForm DAL function in a DAL script to insert additional forms for banner processing. Place these additional forms and images in the same group as the initial banner form. Each form is printed separately

and after all banner forms are printed, the entire banner group is removed from the document set. For these reasons, it is critical that you isolate the banner forms from the rest of the transaction document set by specifying a Key1/Key2 combination that does not otherwise occur within the document.

The FAP files assigned to the form (on the form line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR)) must have the recipient BANNER with a copy count of at least one. When banner forms are printed, only images assigned to the recipient BANNER with a non-zero copy count are printed.

Specify the DAL script names without a path or extension. We recommend that you store the DAL scripts in your DAL libraries because they are easier to maintain. DAL libraries are automatically be loaded if specified in the INI file as shown here:

< DALLibraries >

LIB = library1

LIB = library2

The DAL script libraries or files must reside in DefLib. You can specify forms and scripts at the recipient batch level to override the global specification. Here is an example of how you do this:

< Print_Batches >

BATCH1 = BATCH1.BCH

BATCH2 = BATCH2.BCH

< Batch1 >

BatchBannerBeginForm = form name

BatchBannerBeginScript = script name

BatchBannerEndForm = form name

BatchBannerEndScript = script name

TransBannerBeginForm = form name

TransBannerBeginScript = script name

TransBannerEndForm = form name

TransBannerEndScript = script name

You can specify some, none, or all of the forms and scripts for local override of the default global forms and scripts.

An individual batch can completely or partially disable banner processing if the forms, script names, or both are blank, as shown here:

< Batch1 >

BatchBannerBeginForm =

BatchBannerBeginScript =

BatchBannerEndForm =

BatchBannerEndScript =

TransBannerBeginForm =

TransBannerBeginScript =

TransBannerEndForm =

TransBannerEndScript =

Example

< Printer >

BatchBannerBeginScript = PreBatch

Available

Release | _______
Patch |


BatchBannerEndForm

[Printer]
BatchBannerEndForm

BatchBannerEndForm

You can globally specify forms and scripts for all batches, or locally for specific batches.

[ Printer]

BatchBannerEndForm =

Parameter | Description
Edit | You can globally specify forms and scripts for all batches, or locally for specific batches.

Remarks

Use these INI options to specify global batch forms and scripts:

< Printer >

BatchBannerBeginForm = form name

BatchBannerBeginScript = script name

BatchBannerEndForm = form name

BatchBannerEndScript = script name

TransBannerBeginForm = form name

TransBannerBeginScript = script name

TransBannerEndForm = form name

TransBannerEndScript = script name

Specify form names as follows:

;KEY1;KEY2;Form name;

You must have an associated form line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to match the specified form. The images (FAP files) for the forms are specified in the form lines in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). You must include these FAP files in FormLib.

Store the banner forms in a separate and unique banner form group, defined by a combination of Key1 and Key2. You can use the AddForm DAL function in a DAL script to insert additional forms for banner processing. Place these additional forms and images in the same group as the initial banner form. Each form is printed separately

and after all banner forms are printed, the entire banner group is removed from the document set. For these reasons, it is critical that you isolate the banner forms from the rest of the transaction document set by specifying a Key1/Key2 combination that does not otherwise occur within the document.

The FAP files assigned to the form (on the form line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR)) must have the recipient BANNER with a copy count of at least one. When banner forms are printed, only images assigned to the recipient BANNER with a non-zero copy count are printed.

Specify the DAL script names without a path or extension. We recommend that you store the DAL scripts in your DAL libraries because they are easier to maintain. DAL libraries are automatically be loaded if specified in the INI file as shown here:

< DALLibraries >

LIB = library1

LIB = library2

The DAL script libraries or files must reside in DefLib. You can specify forms and scripts at the recipient batch level to override the global specification. Here is an example of how you do this:

< Print_Batches >

BATCH1 = BATCH1.BCH

BATCH2 = BATCH2.BCH

< Batch1 >

BatchBannerBeginForm = form name

BatchBannerBeginScript = script name

BatchBannerEndForm = form name

BatchBannerEndScript = script name

TransBannerBeginForm = form name

TransBannerBeginScript = script name

TransBannerEndForm = form name

TransBannerEndScript = script name

You can specify some, none, or all of the forms and scripts for local override of the default global forms and scripts.

An individual batch can completely or partially disable banner processing if the forms, script names, or both are blank, as shown here:

< Batch1 >

BatchBannerBeginForm =

BatchBannerBeginScript =

BatchBannerEndForm =

BatchBannerEndScript =

TransBannerBeginForm =

TransBannerBeginScript =

TransBannerEndForm =

TransBannerEndScript =

Example

< Printer >

BatchBannerEndForm = ;BANNER;BATCH;BATCH TRAILER;

Available

Release | _______
Patch |


BatchBannerEndScript

[Printer]
BatchBannerEndScript

BatchBannerEndScript

You can globally specify forms and scripts for all batches, or locally for specific batches.

[ Printer]

BatchBannerEndScript =

Parameter | Description
Edit | You can globally specify forms and scripts for all batches, or locally for specific batches.

Remarks

Use these INI options to specify global batch forms and scripts:

< Printer >

BatchBannerBeginForm = form name

BatchBannerBeginScript = script name

BatchBannerEndForm = form name

BatchBannerEndScript = script name

TransBannerBeginForm = form name

TransBannerBeginScript = script name

TransBannerEndForm = form name

TransBannerEndScript = script name

Specify form names as follows:

;KEY1;KEY2;Form name;

You must have an associated form line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to match the specified form. The images (FAP files) for the forms are specified in the form lines in the Form set definition file (form.dat, .BDF, .GRP, or .FOR). You must include these FAP files in FormLib.

Store the banner forms in a separate and unique banner form group, defined by a combination of Key1 and Key2. You can use the AddForm DAL function in a DAL script to insert additional forms for banner processing. Place these additional forms and images in the same group as the initial banner form. Each form is printed separately

and after all banner forms are printed, the entire banner group is removed from the document set. For these reasons, it is critical that you isolate the banner forms from the rest of the transaction document set by specifying a Key1/Key2 combination that does not otherwise occur within the document.

The FAP files assigned to the form (on the form line in the Form set definition file (form.dat, .BDF, .GRP, or .FOR)) must have the recipient BANNER with a copy count of at least one. When banner forms are printed, only images assigned to the recipient BANNER with a non-zero copy count are printed.

Specify the DAL script names without a path or extension. We recommend that you store the DAL scripts in your DAL libraries because they are easier to maintain. DAL libraries are automatically be loaded if specified in the INI file as shown here:

< DALLibraries >

LIB = library1

LIB = library2

The DAL script libraries or files must reside in DefLib. You can specify forms and scripts at the recipient batch level to override the global specification. Here is an example of how you do this:

< Print_Batches >

BATCH1 = BATCH1.BCH

BATCH2 = BATCH2.BCH

< Batch1 >

BatchBannerBeginForm = form name

BatchBannerBeginScript = script name

BatchBannerEndForm = form name

BatchBannerEndScript = script name

TransBannerBeginForm = form name

TransBannerBeginScript = script name

TransBannerEndForm = form name

TransBannerEndScript = script name

You can specify some, none, or all of the forms and scripts for local override of the default global forms and scripts.

An individual batch can completely or partially disable banner processing if the forms, script names, or both are blank, as shown here:

< Batch1 >

BatchBannerBeginForm =

BatchBannerBeginScript =

BatchBannerEndForm =

BatchBannerEndScript =

TransBannerBeginForm =

TransBannerBeginScript =

TransBannerEndForm =

TransBannerEndScript =

Example

< Printer >

BatchBannerEndScript = PstBatch

Available

Release | _______
Patch |


EnableBatchBanner

[Printer]
EnableBatchBanner

EnableBatchBanner

The system now includes support for banner processing.

[ Printer]

EnableBatchBanner = False

Parameter | Description
Boolean (False) | The system now includes support for banner processing. Default value is: False

Remarks

Banner processing is supported at these points in the processing cycle:

Beginning of a batch

Before a transaction

After a transaction

End of a batch

Banner processing is optional at each point. Banner processing can optionally include FAP forms processing and DAL script processing. FAP forms are specified in this manner:

;key1;key2;form name;

and must appear in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) in DefLib. The associated FAP images for those forms will be loaded from, and must reside in, FormLib.

You can set up banner forms and scripts at a global level so they can be used by all print batches. Individual recipient print batches can specify local forms or scripts to override the global forms and scripts.

Keep in mind these limitations:

* This enhancement only affects the GenPrint program. DocuMaker Workstation has a separate banner handling method, and does not support this new banner method.

* The GenData batch printing rules in CusLib that are used for single-step processing or for 2-up processing of AFP bills, do not support this enhancement.

* Only the standard printer drivers (AFP, Metacode, PCL, and Postscript) support batch banner processing. Avoid batch banner processing if you are using another print driver.

For performance reasons batch banner processing is, by default, disabled. You must enable it using one or both of these INI options:

< Printer >

EnableTransBanner = True

EnableBatchBanner = True

Omitting either option disables the associated level of batch banner processing. Once enabled, banner processing is in effect for the entire GenPrint run. You can, however, disable banner processing for individual batches by specifying forms and scripts with blank names.

Example

< Printer >

EnableBatchBanner = True

Available

Release | 10.1
Patch |


EnableTransBanner

[Printer]
EnableTransBanner

EnableTransBanner

You can use this function with the banner processing feature.

[ Printer]

EnableTransBanner = False

Parameter | Description
Boolean (False) | You can use this function with the banner processing feature. Default value is: False

Remarks

First, specify a DAL script that runs at the start of each transaction. The DAL script calls the AddBlankPages function. This tells the system to convert each transaction to a fully duplexed form set with blank pages added as needed.

Here is an example of the BANNER.DAL script:

BeginSub PreBatch

AddBlankPages()

EndSub

Banner processing is optional at each point. Banner processing can optionally include FAP forms processing and DAL script processing. FAP forms are specified in this manner:

;key1;key2;form name;

and must appear in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) in DefLib. The associated FAP images for those forms will be loaded from, and must reside in, FormLib.

You can set up banner forms and scripts at a global level so they can be used by all print batches. Individual recipient print batches can specify local forms or scripts to override the global forms and scripts.

Keep in mind these limitations:

* This enhancement only affects the GenPrint program. DocuMaker Workstation has a separate banner handling method, and does not support this new banner method.

* The GenData batch printing rules in CusLib that are used for single-step processing or for 2-up processing of AFP bills, do not support this enhancement.

* Only the standard printer drivers (AFP, Metacode, PCL, and Postscript) support batch banner processing. Avoid batch banner processing if you are using another print driver.

For performance reasons batch banner processing is, by default, disabled. You must enable it using one or both of these INI options:

< Printer >

EnableTransBanner = True

EnableBatchBanner = True

Omitting either option disables the associated level of batch banner processing. Once enabled, banner processing is in effect for the entire GenPrint run. You can, however, disable banner processing for individual batches by specifying forms and scripts with blank names.

Example

< Printer >

EnableTransBanner = True

Available

Release | 10.0
Patch | 367


GenerateFileName

[Printer]
GenerateFileName

GenerateFileName

Feature 1377 You can use the new GenerateFileName option to tell the system to automatically generate names for print streams.

[ Printer]

GenerateFileName = No

Parameter | Description
boolean | You can use the new GenerateFileName option to tell the system to automatically generate names for print streams. Default value is: No

Remarks

The file name is comprised of the user ID, the date (such as Mar062003), and the time (such as 192459, which is 07:24:59 pm).

< Printer >

GenerateFileName = Yes

When you set the option to Yes, the device on the Printer window is grayed out and the system generates a print file in the current directory.

Example

< Printer >

GenerateFileName = Yes

Available

Release | 10.1
Patch | 447


PageNumberFormat

[Printer]
PageNumberFormat

PageNumberFormat

New INI options added to allow for additional control over page number formats.

[ Printer]

PageNumberFormat =

Parameter | Description
value | New INI options added to allow for additional control over page number formats.

Remarks

For example:

<Printer>

PageNumberFormat=ZZZ

RightJustifyPageNumber=Y

Z represents the page number precision, or the number of digits. Options added to INI file for right justification of page numbers. The page number format may be determined three different ways:

1. The FAP file may contain a format string. This can be set up through the image editor. However if FAPs are not loaded during the print step, the format will not be applied to the page number.

2. If FAPs are not loaded or the format string was not specified in the FAP, the first text value of the field will be used as a format string. If the page number field was created by Mk_Hard, the rule parameters will be used.

NOTE: 'X' is not a valid format string.

3. If we do not have a valid format string in the first element of the text list, the INI option PageNumberFormat will be used. If we attempt to format the field with an invalid format string from either the FAP file or the field value, you can try the INI option. This will happen when the Mk_Hard rule creates the field with an 'X' as the rule parameter and FAPs are not loaded.

When RightJustifyPageNumber is set to Yes the right coordinate of the field will be used as the anchor point. You must insure the proper right coordinate is used. You may use JustFld with Mk_Hard . See the example below for an 8-digit page number.

Example

< Printer >

PageNumberFormat =

Available

Release | 10.0
Patch |


Port

[Printer]
Port

Port

Enter the name of the print batch file for each designated printer.

[ Printer]

Port =

Parameter | Description
value | Enter the name of the print batch file for each designated printer. Note the group name is defined by the printer option in the PrinterInfo control group.

Example

< Printer >

Port =

Available

Release | _______
Patch |


PrtType

[Printer]
PrtType

PrtType

[ Printer]

PrtType = PCL

Parameter

Description

List

Values can be

  • AFP
  • EPT
  • GDI
  • HTM
  • MDR
  • PCL
  • PDF
  • PST
  • RTF
  • XER

Default value is: PCL

Remarks

NOTE: If you are using the GDI output or redirecting raw PCL through the GDI device, make sure you set the necessary options in that PrtType control group to automatically complete windows that appear.

Example

<Printer>

PrtType = PDF

<CONFIG:~Platform > PrtType =

Available

Release | 10.1
Patch |


RecipientPrintOrder

[Printer]
RecipientPrintOrder

RecipientPrintOrder

Feature 1388 Now you can use the RecipientPrintOrder option to specify the sequence in which recipient copies print.

[ Printer]

RecipientPrintOrder = Edit

Parameter | Description
value | Now you can use the RecipientPrintOrder option to specify the sequence in which recipient copies print.

Remarks

If you omit this option, recipients copies print in alphabetic order, by recipient name. Here is an example:

< Printer >

RecipientPrintOrder = Company,INSURED,PRODUCER

If you append ;YES to this option, the system displays a window which shows all recipients from the global recipient list. You can use this window to rearrange the order in which recipient copies print. Here is an example:

< Printer >

RecipientPrintOrder = Company,INSURED,PRODUCER;YES

Example

< Printer >

RecipientPrintOrder = Company,INSURED,PRODUCER

< Printer >

RecipientPrintOrder = Company,INSURED,PRODUCER;YES

Available

Release | 10.1
Patch | 448


RightJustifyPageNumber

[Printer]
RightJustifyPageNumber

RightJustifyPageNumber

New INI options added to allow for additional control over page number formats.

[ Printer]

RightJustifyPageNumber =

Parameter | Description
value | New INI options added to allow for additional control over page number formats.

Remarks

For example:

<Printer>

PageNumberFormat=ZZZ

RightJustifyPageNumber=Y

Z represents the page number precision, or the number of digits. Options added to INI file for right justification of page numbers. The page number format may be determined three different ways:

1. The FAP file may contain a format string. This can be set up through the image editor. However if FAPs are not loaded during the print step, the format will not be applied to the page number.

2. If FAPs are not loaded or the format string was not specified in the FAP, the first text value of the field will be used as a format string. If the page number field was created by Mk_Hard, the rule parameters will be used.

NOTE: 'X' is not a valid format string.

3. If we do not have a valid format string in the first element of the text list, the INI option PageNumberFormat will be used. If we attempt to format the field with an invalid format string from either the FAP file or the field value, you can try the INI option. This will happen when the Mk_Hard rule creates the field with an 'X' as the rule parameter and FAPs are not loaded.

When RightJustifyPageNumber is set to Yes the right coordinate of the field will be used as the anchor point. You must insure the proper right coordinate is used. You may use JustFld with Mk_Hard . See the example below for an 8-digit page number.

Example

< Printer >

RightJustifyPageNumber =

Available

Release | 10.0
Patch |


SuppressDialog

[Printer]
SuppressDialog

SuppressDialog

Go to your Printer groups and make sure this option is set for automated processing.

[ Printer]

SuppressDialog = No

Parameter | Description
boolean | Go to your Printer groups and make sure this option is set for automated processing. Default value is: No

Example

< Printer >

SuppressDialog = Yes

Available

Release | 10.1
Patch |


TransBannerBeginForm

[Printer]
TransBannerBeginForm

TransBannerBeginForm

You can globally specify forms and scripts for all batches, or locally for specific batches.

[ Printer]

TransBannerBeginForm =

Parameter | Description
value | You can globally specify forms and scripts for all batches, or locally for specific batches.

Example

< Printer >

TransBannerBeginForm = ;BANNER;TRANSACTION;TRANS HEADER;

Available

Release | _______
Patch |


TransBannerBeginScript

[Printer]
TransBannerBeginScript

TransBannerBeginScript

You can use this function with the banner processing feature.

[ Printer]

TransBannerBeginScript =

Parameter | Description
value | you can use this function with the banner processing feature.

Remarks

First, specify a DAL script that runs at the start of each transaction. The DAL script calls the AddBlankPages function. This tells the system to convert each transaction to a fully duplexed form set with blank pages added as needed.

Here is an example of the BANNER.DAL script:

BeginSub PreBatch

AddBlankPages()

EndSub

Example

< Printer >

TransBannerBeginScript = PreBatch

Available

Release | 10.0
Patch | 367


TransBannerEndForm

[Printer]
TransBannerEndForm

TransBannerEndForm

You can globally specify forms and scripts for all batches, or locally for specific batches.

[ Printer]

TransBannerEndForm =

Remarks

First, specify a DAL script that runs at the start of each transaction. The DAL script calls the AddBlankPages function. This tells the system to convert each transaction to a fully duplexed form set with blank pages added as needed.

Here is an example of the BANNER.DAL script:

BeginSub PreBatch

AddBlankPages()

EndSub

Example

< Printer >

TransBannerEndForm = ;BANNER;TRANSACTION;TRANS TRAILER;

Available

Release | _______
Patch |


TransBannerEndScript

[Printer]
TransBannerEndScript

TransBannerEndScript

You can use this function with the banner processing feature.

[ Printer]

TransBannerEndScript =

Parameter | Description
value | You can use this function with the banner processing feature.

Remarks

First, specify a DAL script that runs at the start of each transaction. The DAL script calls the AddBlankPages function. This tells the system to convert each transaction to a fully duplexed form set with blank pages added as needed.

Here is an example of the BANNER.DAL script:

BeginSub PreBatch

AddBlankPages()

EndSub

Example

< Printer >

TransBannerEndScript = PstTrans

Available

Release | 10.1
Patch |


PrinterInfo

Remarks

Printer

PrinterInfo Options

  • DefaultPrinter
  • Printer


DefaultPrinter

[PrinterInfo]
DefaultPrinter

DefaultPrinter

This PrinterInfo group option defines the default INI print group name.

[ PrinterInfo]

DefaultPrinter = Edit

Parameter | Description
Value | This PrinterInfo group option defines the default INI print group name.

Remarks

Print groups designate the name of a print file for the GenPrint program to write to.

Use this FSISYS.INI control group to tell the GenPrint program which INI groups to write its print-ready files to. The values on the right side of the equation are INI groups that indicate the actual file names that the print-ready data streams are written to.

Example

< PrinterInfo >

DefaultPrinter = Printer1

Available

Release | _______
Patch |


Printer

[PrinterInfo]
Printer

Printer

Enter the designated printers for print batches.

[ PrinterInfo]

Printer = Edit

Parameter | Description
value | Enter the designated printers for print batches.

Remarks

Use this FSISYS.INI control group to tell the GenPrint program which INI groups to write its print-ready files to. The values on the right side of the equation are INI groups that indicate the actual file names that the print-ready data streams are written to.

This option in the PrinterInfo group defines an INI group for the GenPrint program. The INI group designates the name of a print file. A printer statement is required for each print output group.

Example

< PrinterInfo >

Printer = Printer1

Printer = Printer2

Printer = Printer3

Printer = Printer4

Printer = Printer5

Available

Release | _______
Patch |


Printers

Printers Options

  • PrtType


PrtType

[Printers]
PrtType

PrtType

The PRTTYPE entry is the logical name for a printer INI group and it can be named anything.

[ Printers]

PrtType = List

Parameter

Description

value

Use this FSISYS.INI control group to define the printers which appear on the GUI dropdown menu selection.

Values can be

  • AFP
  • BMP
  • EPT
  • GDI
  • HTM
  • MDR
  • PCL
  • PDF
  • PST
  • PXL
  • RTF
  • XER

Remarks

Use this FSISYS.INI control group to define the printers which appear on the GUI dropdown menu selection.

Each PrtType option line entry must also have a corresponding PrtType Control Group.

PrtType control group specifying printer type options.To have the system display a printer as an option, remove the semi-colon which precedes PrtType. You can set up as many as you like. To remove a printer from the list of options, add a semicolon before PrtType.

PrtType =

This option in the Printers control group defines the printer types (such as AFP or PCL) available on the GUI dropdown menu. Remove the semicolon before an option to add that PrtType to the menu. Add a semicolon before the PrtType option to remove it from the GUI dropdown menu.

Feature 380 USING THE RTF PRINT DRIVER

The system now includes an RTF print driver which lets you convert the content of a form set into medium fidelity RTF format. You can then view or edit the RTF file using a standard word processor, such as Microsoft Word.

To use the RTF print driver, set it up like any other printer type:

< Printers >

PrtType = RTF

< PrtType:RTF >

Module = RTFW32

PrintFunc = RTFPrint

You will need to specify an output device name on the Print window.

You can also use this driver with the Rules Processor. The setup is identical except the PrtType option is in the Printer control group. If you are using this print driver with the Rules Processor, you can also use these INI options:

< Print >

CallbackFunc = MultiFilePrint

MultiFileLog = data\rtflog.dat

Feature 1420--Adding PDF to Documaker Workstation.

PrtType = MDR-Multiple Driver Router (optional)

PrtType = EPT-e-mail print option (optional)

The order you place the options listed above in the INI file will determine the order that appears on the Printer Type drop-down options in Documaker Workstation.

Example

< Printers >

PrtType = LOG

PrtType = PXL

PrtType = PDF

PrtType = PDF_Old

PrtType = PS2

PrtType = PSX

PrtType = PST

PrtType = PST-4850

PrtType = PST-DP65

PrtType = PCL

PrtType = AFP

PrtType = AFP_MRG2

PrtType = AFP_MRG4

PrtType = GDI

PrtType = XER

PrtType = XER_JES2

PrtType = XER_DPLJDL

PrtType = XER_MRG2

PrtType = XER_MRG4

PrtType = 4235

PrtType = NICK

PrtType = RTF

PrtType = HTM

PrtType = LIN

< PrtType:4235 >

Device = d:\x.met

...

< PrtType:AFP >

Device = d:\x.afp

...

Available

Release | 10.1
Patch |


PrintFormset

Remarks

Note: When running the rules processor in multi-step mode, you should instead use the Callback INI option = to MultiFilePrint in the Print INI Group.

For example:

Single Step mode (Gendata)

<PrintFormset>

MultiFilePrint = Yes

If running two or three step mode (Gendata, GenPrint) then use

<Print>

CallbackFunc = MultiFilePrint

PrintFormset Options

  • LogFile
  • LogFileType
  • MultiFilePrint


LogFile

[PrintFormset]
LogFile

LogFile

[ PrintFormset]

LogFile = File

Parameter | Description
value | Specifies the name of the log file.

Remarks

Specifies the name of the log file. Include the full path. If you omit the path, the system uses DATAPATH. If you omit this option, the system creates a file named TMP.LOG. If you enter XML in the LogFileType option and a different extension here, the system uses XML.

Example

< PrintFormset >

LogFile = (log file name and path)

Available

Release | 10.2
Patch |


LogFileType

[PrintFormset]
LogFileType

LogFileType

Specifies the type of the log file. Enter XML for an XML file. Any other entry results in a text file.

[ PrintFormset]

LogFileType = XML

Parameter

Description

value

Specifies the type of the log file. Enter XML for an XML file. Any other entry results in a text file.

Values can be

  • XML
  • txt

Default value is: XML

Example

< PrintFormset >

LogFileType = XML

Available

Release | 10.2
Patch |


MultiFilePrint

[PrintFormset]
MultiFilePrint

MultiFilePrint

Set this option to Yes to allow multiple file print.

[ PrintFormset]

MultiFilePrint = YN

Parameter | Description
Boolean | Yes or No

Remarks

When running the rules processor in single step mode (Gendata) you will receive one print file with all transactions included. If you process more than one transaction at a time, and print RTF or PDF files, you must include this MultiFilePrint INI option set to Yes. This tells the system to produce a separate print file for each transaction processed. Note: Since the RTF and PDF viewers will only support viewing one transaction in a file, you must create a separate file for each transaction.

Example

Running rules processor in Single Step mode and PrtType: is PDF or RTF:

<PrintformSet>

MultiFilePrint = Yes

Available

Release | 10.2
Patch |

Used By

GENDATA


PrtType:AFP

PrtType:
AFP

Remarks

IBM created the Advanced Function Printing (AFP) language. The data streams produced by Documaker software for AFP printers are called Mixed Object Document Content Architecture (MO:DCA) data streams. MO:DCA data streams are sometimes referred to as AFP data streams (AFPDS). You must have a program such as IBM's Print Services Facility (PSF) to convert AFP data stream into the printer's native language. PSF is the umbrella software that brings the AFP resources (created by AFP or system utilities) together in one print job and sends it to the printer.

PrtType:AFP Options

  • 2UpCopyGroup
  • ChartResolution
  • Class
  • DefaultEndChar
  • Descender
  • Device
  • DisplayCodedFont
  • DocuSaveScript
  • DownLoadFonts
  • FAPLogicalBottom
  • FormDef
  • FormNameCR
  • FudgeWidth
  • GraphicSupport
  • InitFunc
  • KeepBlankPages
  • LandscapeSupport
  • LogicalBottom
  • ManualLogicalBottom
  • MediumMapSupport
  • Module
  • NamedColors
  • Normalize
  • OnDemandScript
  • OutMode
  • OutputMod
  • OverlayExt
  • PageNumbers
  • PageSegExt
  • PrePrintedPaper
  • PrintFunc
  • PrintViewOnly
  • RecordLength
  • ReplaceBitmap
  • Resolution
  • SendColor
  • SendOverlays
  • SkipChartColorChange
  • SkipChartPatternChange
  • SplitPercent
  • SplitText
  • StreamBufferSize
  • SuppressLogoUnload
  • TemplateFields
  • TermFunc
  • TLEEveryPage
  • TLEScript
  • TLESeparator
  • Tray1
  • Tray2
  • Tray3
  • Tray4
  • Tray5
  • Tray6
  • Tray7
  • Tray8
  • Tray9
  • UniqueFieldNames
  • UseCodedFonts
  • Watermark

Example

<PrtType:AFP>

Device = LPT3

DownLoadFonts = No,Hidden

FitToWidth = No,Hidden

InitFunc =

Module = AFPPrt

MultipleCopies = Yes

OutputMod = AFPPRT

OverlayExt = .AFP

PageNumbers = Yes

PrintFunc = AFPPrint

Resolution = 240

SelectRecipients = Yes,Enabled

SendColor = Yes,Enabled

SendOverlays = Yes,Enabled

TemplateFields = No,Disabled

TermFunc =


2UpCopyGroup

[PrtType:AFP]
2UpCopyGroup

[PrtType:AFP]

2UpCopyGroup = Edit

Parameter | Description
copy group name | The name of the AFP copy group used for 2-up printing. Default value is LLUO

Remarks

Used when specifying the AFP copy group to use for 2-up printing.

Default = LLUO

Example

<PrtType:AFP>

2UpCopyGroup = LLUO

Available

Release | _______
Patch |

Used By


ChartResolution

[PrtType:AFP]
ChartResolution

Set chart resolution.

[PrtType:AFP]

ChartResolution = Edit

Parameter | Description
numeric value | 120 | 150 | 240 | 300 Defaults to one-half of the resolution option setting.

Remarks

Used when printing charts as inline bitmap graphics on an AFP printer that does not have graphics (GOCA) support. Defaults to one-half of the Resolution option setting.

Example

<PrtType:AFP>

ChartResolution = 120

Available

Release | _______
Patch |

Used By

AFPLIB


Class

[PrtType:AFP]
Class

Specifies the printer classification, such as AFP, GDI, PCL, XER, PST, etc.

[PrtType:AFP]

Class = List

Parameter

Description

class name

Valid class names include others:

  • AFP
  • GDI
  • PCL
  • XER
  • PST

Remarks

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing. The default is the first three characters of the Module option settings. For AFP print, this value should be set to AFP.

Example

<PrtType:AFP>

Class=AFP

Available

Release | _______
Patch |

Used By

AFPLIB


DefaultEndChar

[PrtType:AFP]
DefaultEndChar

[PrtType:AFP]

DefaultEndChar = Edit

Parameter | Description
a single character | Default value is: [

Remarks

This setting is used when generating normalized AFP files.

You can use the DefaultEndChar option to set the default line end character when you are creating new fields on a FAP file that you will later normalize to AFP file for Documerge. The default for this optional INI option is a square bracket ( [ ). You can only designate one character and you cannot use an equals sign (=).

Example

<PrtType:AFP>

DefaultEndChar = !

Available

Release | 10.2
Patch | 135


Descender

[PrtType:AFP]
Descender

[PrtType:AFP]

Descender = YN

Parameter | Description
boolean | Yes | No Default value is: No.

Remarks

This setting is used when generating normalized AFP files.

The Logical bottom is calculated based on either the baseline or the physical bottom of the rectangle, including descenders.

Documerge offers both methods, and defaults to the baseline method.

The default value of No means to use the baseline method.

Example

<PrtType:AFP>

Descender = No

Available

Release | _______
Patch |

Used By


Device

[PrtType:AFP]
Device

The name of the file or device (LPT1) where the AFP device name data stream should be written.

[PrtType:AFP]

Device = File

Parameter | Description
value | Any file or device name

Remarks

This setting is ignored by the GenPrint program but is used when printing from GUI Documaker applications like DMStudio, Documaker Workstation, and legacy development tools such as the Image Editor.

Example

<PrtType:AFP>

Device = filename

Available

Release | _______
Patch |

Used By

AFPLIB


DisplayCodedFont

[PrtType:AFP]
DisplayCodedFont

Use this option to output the AFP character set and code page combination instead of the coded font in the font list when you generate normalized AFP files.

[PrtType:AFP]

DisplayCodedFont = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Use this option to output the AFP character set and code page combination instead of the coded font in the font list when you generate normalized AFP files. The defaults is Yes, which tells the system to include the coded fonts.

If you want the character set/code page combinations to be output in the AFP font list, instead of the coded fonts, you must add the DisplayCodedFont option, as shown here:

<PrtType:AFP>

DisplayCodedFont = No

Keep in mind the FXR file must contain the character set and code page entries in the AFP font record for this option to work. If you set the INI option to No and the character set and code page entries are not in the FXR file, the font list in the AFP file will contain

only the coded fonts.

NOTE: The AFP output record can only contain either coded fonts or character set/code page entries — it cannot contain a combination. It will default to coded fonts for all if the font for one or more objects does not contain character set/code page entries.

Available

Release | 11.2
Patch |


DocuSaveScript

[PrtType:AFP]
DocuSaveScript

The feature enables Documaker-produced AFP print streams to be able to be archived by DocuSave.

Use the DocuSaveScript option in the PrtType:AFP or XER control groups to have the system execute a DAL script at the times when DocuSave comments can be added to the print streams.

[PrtType:AFP]

DocuSaveScript = Edit

Parameter | Description
script file name | name of DAL script

Remarks

The DAL script is used to add Docusave comment records into the print stream. In addition, you must specifiy the OutMode option to use MRG4 if you wish to include comment records in the print streams. The comment records in the print streams are used as an index into the Docusave archive.

To add DocuSave comments to an AFP print stream, you must add the DocuSaveScript option and the name of a DAL script to execute. The DAL script should call the AddDocuSaveComment function to add a string as a DocuSave comment record. Here is an example:

<PrtType:AFP>

DocuSaveScript = DocuSave.DAL

OutMode = MRG4

Here is a simple example of what the DOCUSAVE.DAL script file might contain:

* Add Docusave Comment - use default: APPIDX record!

comment = AppIdxRec( )

class = PAD("bio",8)

cabinet = PAD("rpex7",8)

title = PAD("TITLE",22)

indextag = comment & class & cabinet & title

Print_It (indextag)

AddDocuSaveComment (indextag)

Return ('FINISHED!')

Available

Release | 10.1
Patch |

See Also

  • OutMode


DownLoadFonts

[PrtType:AFP]
DownLoadFonts

[PrtType:AFP]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

The AFP print driver ignores this setting.

Example

<PrtType:AFP>

DownLoadFonts = Yes,Enabled

Available

Release | _______
Patch |


FAPLogicalBottom

[PrtType:AFP]
FAPLogicalBottom

[PrtType:AFP]

FAPLogicalBottom = YN

Parameter | Description
boolean | Yes | No Default value is: Yes.

Remarks

This setting is used when generating normalized AFP files.

This setting indicates whether the value of the INI setting, ManualLogicalBottom , is set in FAP units (2400 dpi) or AFP units.

Example

<PrtType:AFP>

FAPLogicalBottom = No

Available

Release | _______
Patch |

Used By


FormDef

[PrtType:AFP]
FormDef

Documaker supports paper trays five through 9 on AFP printers. To enable support for these paper trays, you must use the new AFP formdef file, F1DOCUMK.FDF. This formdef file replaces the legacy AFP formdef file, F1FMMST.

[PrtType:AFP]

FormDef = Edit

Parameter | Description
Value | Set to F1DOCUMK if you want to use the Documaker formdef for paper trays 5 though 9.

Remarks

Enter F1DOCUMK to tell the AFP print driver to change the default AFP printer group INI options as follows:

< PrtType:AFP >

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Setting the FormDef option to F1DOCUMK, tells the AFP print driver to print to trays 5 through 9 when it encounters a form that is marked to use these paper trays.

Without this INI setting, forms marked to use paper trays 5 through 9 print instead to tray 1.

You can use the F1DOCUMK formdef file to print both your new Documaker AFP print streams and your legacy Documaker AFP print streams.

If your Documaker AFP print streams do not use more than four paper trays, you can continue to use the legacy AFP formdef file, F1FMMST. Because F1FMMST only includes support for four paper trays, it is smaller than the new F1DOCUMK AFP formdef file.

Example

<PrtType:AFP>

FormDef = F1DOCUMK

Available

Release | 11.4
Patch |

See Also

<PrtType:AFP>

Tray1


FormNameCR

[PrtType:AFP]
FormNameCR

[PrtType:AFP]

FormNameCR = YN

Parameter | Description
boolean | Yes | No Default value is: No.

Remarks

Use this setting to enable Documerge Form Name Comment Records in your AFP output.

Here is an example of the AFP records in an AFP print stream which includes the Documerge form level comment (NOP) records:

000,Begin,Document,29,

001, Data,NOP,84,%%%DMGFORMBEG%%% DEC PAGE 00001

AFP Docucorp 000001

002, Map,Medium Map,16,PLUD

...

033, End,Page,16,

034, Data,NOP,84,%%%DMGFORMEND%%% DEC PAGE 00001

AFP Docucorp 000001

035, Data,NOP,84,%%%DMGFORMBEG%%% LETTER 00001

AFP Docucorp 000002

036, Begin,Page,16,

...

053, End,Page,16,

054, Data,NOP,84,%%%DMGFORMEND%%% LETTER 00001

AFP Docucorp 000002

173,End,Document,16,

000,Begin,Document,29,

001, Data,NOP,84,%%%DMGFORMBEG%%% OP714 00001

AFP Docucorp 000001

002, Map,Medium Map,16,PLUO

...

Example

<PrtType:AFP>

FormNameCR = No

Available

Release | _______
Patch |

Used By


FudgeWidth

[PrtType:AFP]
FudgeWidth

[PrtType:AFP]

FudgeWidth = Edit

Parameter | Description
width | any number (default = 0)

Remarks

Can be used when building page overlays for images smaller than a page.

Use this setting if you previously produced an AFP overlay that resulted in a "outside of boundary" error when printed.

Example

<PrtType:AFP>

FudgeWidth = 0

Available

Release | _______
Patch |

Used By

AFPLIB


GraphicSupport

[PrtType:AFP]
GraphicSupport

Set printer support type for inline bitmap graphics and GOCA charts.

[PrtType:AFP]

GraphicSupport = LimitList

Parameter

Description

Graphic Support

Values can be

  • 0 - no graphics (GOCA) support
  • 1 - inline bitmap graphics
  • 2 - GOCA charts support
  • 3 - inline bitmap graphics and GOCA charts support

Remarks

The following values can be configured:

0 = no graphics (GOCA) support

1 = specifies the level of graphic support when producing AFP output

2 = GOCA charts support

3 = inline bitmap graphics and GOCA charts support

Example

<PrtType:AFP>

GraphicSupport = 3

Available

Release | _______
Patch |

Used By

AFPLIB


InitFunc

[PrtType:AFP]
InitFunc

The name of the program function that is the initializing entry point into the system's AFP print driver.

[PrtType:AFP]

InitFunc = Edit

Parameter | Description
value | function name. Default is to have no value.

Remarks

The AFP print driver currently does not have an initialization entry function. Leave this setting blank.

Example

<PrtType:AFP>

InitFunc = AFPInit

Available

Release | _______
Patch |

Used By

AFPLIB


KeepBlankPages

[PrtType:AFP]
KeepBlankPages

Use the new KeepBlankPages option when you are converting AFP and XEROX Documerge files into FAP files (via DMStudio Conversion Wizard or MRG2FAP command line utility) to retain blank pages.

[PrtType:AFP]

KeepBlankPages = YN

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

Normally blank pages are removed because the system assumes they are duplex back pages that are not needed. If, however, you want to retain these pages, add this option and set it to Yes.

Example

<PrtType:AFP>

KeepBlankPages = Yes

Available

Release | 10.1
Patch | 378


LandscapeSupport

[PrtType:AFP]
LandscapeSupport

You can set this option to Yes if your printer supports landscape medium maps.

[PrtType:AFP]

LandscapeSupport = YN

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

Although not required for printing, you can set this option to Yes if your printer supports landscape medium maps. Generally, AFP printers using cut-sheet paper do not support landscape medium maps.

Example

<PrtType:AFP>

LandscapeSupport = No

Available

Release | _______
Patch |

Used By

AFPLIB


LogicalBottom

[PrtType:AFP]
LogicalBottom

[PrtType:AFP]

LogicalBottom = Edit

Parameter | Description
numeric value | Default value is: 26400

Remarks

This setting is used when generating normalized AFP files.

The LogicalBottom setting can contain a positive or zero (0) value and is used to override the normal logical bottom calculation for a FAP file. A zero (0) value will default to 26400.

The value is in FAP units (2400 dots/inch) unless the INI setting FAPLogicalBottom is set to No.

Use of this setting is not recommended.

Example

<PrtType:AFP>

LogicalBottom = 19200

Available

Release | _______
Patch |

See Also

  • FAPLogicalBottom
  • ManualLogicalBottom


ManualLogicalBottom

[PrtType:AFP]
ManualLogicalBottom

[PrtType:AFP]

ManualLogicalBottom = Edit

Parameter | Description
numeric value | Default value is to have no value.

Remarks

This setting is used when generating normalized AFP files.

The ManualLogicalBottom setting can contain a positive or zero (0) value and is used to override the normal logical bottom calculation for a FAP file. A zero (0) value means the logical bottom is set to the top of the page.

The value is in FAP units (2400 dots/inch) unless the INI setting FAPLogicalBottom is set to No.

Use of this setting is not recommended.

Example

<PrtType:AFP>

ManualLogicalBottom = 0

Available

Release | _______
Patch |

See Also

  • LogicalBottom
  • FAPLogicalBottom


MediumMapSupport

[PrtType:AFP]
MediumMapSupport

[PrtType:AFP]

MediumMapSupport = YN

Parameter | Description
boolean | Yes | No Default value is: Yes.

Remarks

Medium maps are used to control paper size, paper tray selection, duplexing, etc.

Example

<PrtType:AFP>

MediumMapSupport = Yes

Available

Release | _______
Patch |

Used By


Module

[PrtType:AFP]
Module

The name of the program module which contains the system's AFP print driver.

[PrtType:AFP]

Module = File

Parameter | Description
value | DLL name. Default is AFPPRT.

Remarks

In order to produce AFP output the module should be set to AFPPRT. See also the discussion of the Class option.

Example

<PrtType:AFP>

Module = AFPPRT

Available

Release | _______
Patch |

Used By

AFPLIB, PSTLIB


NamedColors

[PrtType:AFP]
NamedColors

Use the NamedColors option to tell the system to use only specific AFP named colors.

[PrtType:AFP]

NamedColors = red;blue;magenta;green;cyan;yellow

Parameter

Description

List

Use the NamedColors option to tell the system to use only specific AFP named colors

Values can be

  • blue
  • brown
  • cyan
  • dark_blue
  • dark_cyan
  • dark_green
  • gray
  • green
  • magenta
  • mustard
  • orange
  • purple
  • red
  • yellow

Remarks

The system maps the RGB (red, green, blue) color setting for each object to the closest AFP named color. The default AFP named colors are blue, red, magenta, green, cyan, yellow, dark_blue, orange, purple, dark_green, dark_cyan, mustard, gray, and brown.

Use the NamedColors option to tell the system to use only specific AFP named colors:

<PrtType:AFP>

NamedColors = blue

For example, if you wanted all highlight (non-black) colors mapped to blue, you would set the NamedColors option to blue, as shown above.

To allow the mapping of the colors you assigned to the objects in the FAP file to multiple colors, separate each color with a semicolon (;). For example, to use all of the default AFP named colors except brown, set the NamedColors option as shown here:

NamedColors = red;blue;magenta;green;cyan;yellow

The order of the named colors does not matter.

Example

< PrtType:AFP >

NamedColors = blue

Available

Release | 10.1
Patch |


Normalize

[PrtType:AFP]
Normalize

[PrtType:AFP]

Normalize = YN

Parameter | Description
boolean | Yes | No Default value is: No.

Remarks

This setting enables the generation of normalized AFP files.

If this setting is set to Yes, the Normalize INI setting in the Control INI group is used to determine the printer INI group to use in order to produce a normalized AFP file.

Example

<PrtType:AFP>

Normalize = No

Available

Release | _______
Patch |

Used By


OnDemandScript

[PrtType:AFP]
OnDemandScript

Use this option to enhance DAP-produced AFP print stream to be able to be archived by OnDemand.

[PrtType:AFP]

OnDemandScript = Edit

Parameter | Description
value | OnDemand is part of an IBM suite of products that provide high performance document capture, indexing, storage, retrieval and presentation of AFP data streams. The feature enhances DAP-produced AFP print stream to be able to be archived by OnDemand.

Remarks

OnDemand is part of an IBM suite of products that provide high performance document capture, indexing, storage, retrieval and presentation of AFP data streams. The feature enhances DAP-produced AFP print stream to be able to be archived by OnDemand.

To enable a DAP-produced AFP print stream to be archived by OnDemand, you will need to define a new INI setting and provide a DAL script that produces the archive keys to use.

In the printer group set up for AFP printing (usually PRTType:AFP), you will need to add the OnDemandScript option, containing the name of a DAL script to execute.

Example

<PrtType:AFP>

OnDemandScript = OnDemand.DAL

You can use these new DAL functions to create archive keys to use with OnDemand.

Function | Description
AddComent | Adds a comment string to the print stream
AppIdxRec | Gets an archive record based on APPIDX.DFD and Trigger2Archive INI settings
HaveGVM | Verifies if a GVM variable exists
SetGVM | Updates the contents of a GVM variable
GVM | Gets the contents of a GVM variable
MajorVersion | Gets the system's major version number
MinorVersion | Gets the system's minor version number
PrinterClass | Gets the type of print being produced
PrinterGroup | Gets the name of the print group being used
Print_It | Debug tool to print a string to the console

This example shows DAL scripting which you could use to format and configure an AFP or Metacode print stream for storage using DocuSave.

The FSISYS.INI or FSIUSER.INI files must contain these options:

<PrtType:xxx>

OutMode = MRG4 or JES2

DocuSaveScript = DOCUSAVE.DAL

Where XXX is either AFP or XER. For the OutMode option, enter MRG4 or JES2. Enter the name of the script in the DocuSaveScript option.

The DOCUSAVE.DAL script file should contain this information:

* Add DocuSave Comment - use default: APPIDX record!

Comment = AppIdxRec( )

Class = PAD("bio",8)

Cabinet = PAD("rpex7",8)

Title = PAD("Title",22)

IndexTag = comment & class & cabinet & title

Print_It (indextag)

AddDocuSaveComment (IndexTag)

Return ('Finished!')

This example shows DAL scripting which you could use to format and configure an AFP print stream for storage using IBM's OnDemand product. The FSISYS.INI or FSIUSER.INI files must specify the name of the DAL script in the OnDemandScript option:

<PrtType:AFP>

OnDemandScript = ONDEMAND.DAL

The ONDEMAND.DAL script file should contain this information:

* Make sure #loadlib is initialized

#loadlib = #loadlib

* Load script into cache memory!

If (#loadlib = 0) Then

LoadLib('OnDmdLib')

End

#loadlib+= 1

* Execute script!

OnDemand( )

Return('Finished!')

OnDmdLib.DAL script library file

BeginSub OnDemand

* OnDemand Script is only valid for AFP print streams!

If (PrinterClass() != 'AFP') Then

Return

End

* Example of reading GVM variables

* If (HaveGVM('Company') Then

* company = GVM('Company')

* End

* Make sure #docnum is initialized

#docnum = #docnum

If (#docnum = 0) Then

semi= ';'

colon = ':'

acifinfo = 'ACIFINFO'

docnum = 'DOCUMENT_NO'

mvsfile= 'MVS_FILENAME'

expbprep = 'EXPBPREP'

procdate = 'PROCESS_DATE'

proctime = 'PROCESS_TIME'

idxname = 'ACIF_INDEX_NAME'

idxdata = 'ACIF_INDEX_DATA'

recid = 'RECID=470'

grpname = GroupName( )

dapver = MajorVersion( ) & '.' & MinorVersion( )

Print_It ('DAP Version is ' & dapver)

End

* Add comment, ' ACIFINFO;DOCUMENT_NO:0000001'

#docnum += 1

AddComment (acifinfo & semi& docnum & colon &

Format(#docnum,'n',9999999))

* Add comment, 'MVS_FILENAME:PROD.EX.P.DCS.AFP.PREPOUT'

AddComment (mvsfile & colon & 'PROD.EX.P.DCS.AFP.PREPOUT')

* Add comment, 'EXPBPREP;PROCESS_DATE:mm-dd-yyyy'

AddComment (expbprep & semi & procdate & colon & Date('1-4'))

* Add comment, 'EXPBPREP;PROCESS_TIME:hh:mm:ss'

AddComment (expbprep & semi& proctime & colon & TIME())

* Add comment, 'RECID=470;ACIF_INDEX_NAME01;026;Correspondence Copy

Number'

* Add comment, 'RECID=470;ACIF_INDEX_DATA01;009;840127920'

#idxnum = 1

fldname = 'Correspondance Copy Number'

flddata = '840127920'

AddComment (recid & semi& idxname & Format (#idxnum,'n',99) & semi & \

Format (Len (fldname),'n',999) & semi & fldname)

AddComment (recid & semi& idxdata & Format (#idxnum,'n',99) & semi & \

Format (Len (flddata),'n',999) & semi& flddata)

* Add Comment, 'RECID=470;ACIF_INDEX_NAME02;019;Correspondance Type'

* Add Comment, 'RECID=470;ACIF_INDEX_DATA02;025;Notice of Initial

Reserve'

#idxnum += 1

fldname = 'Correspondance Type'

flddata = 'Notice of Initial Reserve'

AddComment (recid & semi& idxname & Format (#idxnum,'n',99) & semi&\

Format (Len (fldname),'n',999) & semi& fldname)

AddComment (recid & semi& idxdata & Format (#idxnum,'n',99) & semi&\

Format (Len (flddata),'n',999) & semi& flddata)

* Get DAP Field - 'INSURED NAME'

* Add Comment, 'recid=470;ACIF_INDEX_NAME03;012;INSURED NAME'

* Add Comment, 'recid=470;ACIF_INDEX_DATA03;008;John Doe'

If (HaveField('INSURED NAME',,,grpname)) Then

#idxnum += 1

fldname = 'INSURED NAME'

flddata = @(fldname,,,grpname)

AddComment (recid & semi& idxname & Format (#idxnum,'n',99) & semi&\

Format (Len (fldname),'n',999) & semi & fldname)

AddComment(recid & semi& idxdata & Format (#idxnum,'n',99) & semi&\

Format (Len (flddata),'n',999) & semi & flddata)

End

Return

EndSub

Example

<PrtType:AFP>

OnDemandScript = OnDemand.DAL

Available

Release | 10.1
Patch |


OutMode

[PrtType:AFP]
OutMode

Use this option to archive AFP and Metacode print streams that are in a DocuSave compatible format and contain special records used to index the archive.

[PrtType:AFP]

OutMode = Edit

Parameter | Description
value | Leave OutMode blank to produce native (print-ready) AFP output files (default). MRG2 or MRG4 will produce AFP files using 2-byte or 4-byte Documerge record blocking.

Remarks

DocuSave can archive AFP and Metacode print streams that are in a DocuSavecompatible format and contain special records used to index the archive.

To produce a print stream for DocuSave on an NT platform, you must set the OutMode option equal to MRG4. When you set the OutMode option to MRG4, the GenPrint program creates print stream records with a 4-byte sequence that precedes them. This sequence defines the record lengths. Records are grouped into blocks with one or more records in each block. Both records and blocks have a 4-byte sequence that precedes them, defining their length.

Use MRG2 to produce use 2-byte Documerge record block scheme.

Leave OutMode blank to produce native (print-ready) AFP output files (default).

Example

<PrtType:AFP>

OutMode = MRG4

Available

Release | 10.1
Patch |


OutputMod

[PrtType:AFP]
OutputMod

[PrtType:AFP]

OutputMod = Edit

Parameter | Description
value | module name (default is AFPPRT)

Remarks

Leave this setting blank

Example

<PrtType:AFP>

OutputMod = AFPPRT

Available

Release | _______
Patch |

Used By


OverlayExt

[PrtType:AFP]
OverlayExt

[PrtType:AFP]

OverlayExt = Edit

Parameter | Description
value | default is .ovl

Remarks

This setting is used when generating AFP overlays or when converting AFP files that reference AFP overlays.

If the AFP print file contains references to overlays or page segments, copy the overlay or page segment files into the directory in which the AFP print file resides. Add the following INI options in the PRTType:AFP control group in the FSISYS.INI file to specify the file extension for overlay and page segment files.

Example

<PrtType:AFP>

OverlayExt=

Available

Release | 10.0
Patch |


PageNumbers

[PrtType:AFP]
PageNumbers

Set to Yes to turn on form or form set page numbering

[PrtType:AFP]

PageNumbers = YN

Parameter | Description
boolean | Yes | No

Remarks

The PageNumbers option activates the page numbering feature. Set this value to "Yes" to have page numbers printed in the "Page X of Y" format.

Example

<PrtType:AFP>

PageNumbers = No

Available

Release | _______
Patch |

Used By

AFPLIB


PageSegExt

[PrtType:AFP]
PageSegExt

[PrtType:AFP]

PageSegExt = Edit

Parameter | Description
value | File extension used for page segment files.

Remarks

This setting is used when generating AFP page segments or when converting AFP files that reference AFP page segments.

If the AFP print file contains references to overlays or page segments, copy the overlay or page segment files into the directory in which the AFP print file resides. Add the following INI options in the PRTType:AFP control group in the FSISYS.INI file to specify the file extension for overlay and page segment files.

Example

<PrtType:AFP>

PageSegExt=.psg

Available

Release | 10.0
Patch |


PrePrintedPaper

[PrtType:AFP]
PrePrintedPaper

Define pre-printed objects state.

[PrtType:AFP]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Also determines the default for this check box--checked or unchecked. You must add this option to the INI file if you want the check box to appear on the Print window.

The default for this option includes the checkbox on the Print window and leaves it unchecked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:AFP>

PrePrintedPaper = (option not checked)

Available

Release | _______
Patch |

Used By

AFPLIB


PrintFunc

[PrtType:AFP]
PrintFunc

The name of the program function that is the main entry point into the system's AFP print driver.

[PrtType:AFP]

PrintFunc = Edit

Parameter | Description
value | function name

Remarks

In order to produce AFP output, print func should be set to AFPPrint.

Example

<PrtType:AFP>

PrintFunc = AFPPrint

Available

Release | _______
Patch |

Used By

AFPLIB


PrintViewOnly

[PrtType:AFP]
PrintViewOnly

[PrtType:AFP]

PrintViewOnly = YN

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

If set to Yes, the view only images will print. This does not apply to entry only images, which are never printed. Entry only images are usually worksheets. If the image is marked as hidden and view only, it will not print.

Example

<PrtType:AFP>

PrintViewOnly = No

Available

Release | 10.1
Patch |

Used By

AFPLIB


RecordLength

[PrtType:AFP]
RecordLength

Used only on the AS/400 to specify the record length of each AFP command.

[PrtType:AFP]

RecordLength = Edit

Parameter | Description
value | Record length. Default value is 80.

Note

Used only on the AS/400

Example

<PrtType:AFP>

RecordLength = 80

Available

Release | _______
Patch |

Used By

AFPLIB


ReplaceBitmap

[PrtType:AFP]
ReplaceBitmap

Use this option to replace the shading bitmaps in AFP files with the Documaker internal FAP shading patterns.

[PrtType:AFP]

ReplaceBitmap = _SHADING,LIGHTEST

Parameter

Description

Name

Name of the bitmap to replace

Replacement pattern

Default value is: LIGHT

  • LIGHT
  • LIGHTER
  • LIGHTEST
  • MEDIUM
  • DARK
  • DARKER
  • DARKEST
  • NOSHADE
  • SOLID
  • HORIZONTAL
  • VERTICAL
  • DIAGRIGHT
  • DIAGLEFT
  • HATCH
  • DIAGHATCH

Remarks

You can replace the shading bitmaps defined within AFP files with the Documaker internal FAP shading patterns. Using the internal FAP shading patterns results in smaller and more efficient FAP files and you will have more flexibility in choosing patterns.

NOTE: The system ignores this option if the AFP output file being loaded is one generated by Documaker because it automatically replaces shading bitmaps from internally-generated AFP files with FAP shading patterns when appropriate.

The system replaces all occurrences of the bitmap you specify with the shading pattern you choose. The system places the replacement shading pattern in the same location as the AFP bitmap. To replace multiple bitmaps, repeat the ReplaceBitmap option as necessary.

The bitmap patterns that are replaced must be named in bytes 10-17 of the Begin Image (D3 A8 7B) AFP structured field and the bitmap name listed in the ReplaceBitmap option must match the bitmap name in the Begin Image structured field. All Begin Image structured fields encountered that have names that match the name in the ReplaceBitmap option are replaced.

NOTE: While the system does support color text, color bitmaps are not supported by the AFP loader of the MRG2FAP utility.

Example

<PrtType:AFP>

ReplaceBitmap = _SHADING,LIGHTEST

ReplaceBitmap = BWSHADE,LIGHTEST

Available

Release | 11.0
Patch | 46


ReportTermID

[PrtType:AFP]
ReportTermID

This setting is used converting mixed mode AFP to a FAP or PDF file.

Remarks

Extra text can show up in the converted FAP/PDF when the input AFP file was created by Docusave and has an end of report line appended at the bottom of the file. The conversion process could think it is another record of mixed mode line data and process it like that. Hence, the extra text. To prevent this from happening, if the customer runs Docusave and it appends end of report text records like "REPORT END" (that is the default value) at the end of files, add the following option to the INI file in the PrtType:AFP group:

ReportTermID = REPORT END

Where REPORT END is the EXACT text (case-sensitive) that Docusave is appending to the file. The conversion process will then recognize it as an end of report indicator, and not a line of line data.

Example

<PrtType:AFP>

ReportTermID = REPORT END

Available

Release | 11.0
Patch | 74


Resolution

[PrtType:AFP]
Resolution

The dots per inch (dpi) resolution of the printer which receives the AFP data stream.

[PrtType:AFP]

Resolution = Edit

Parameter | Description
dots_per_inch | 240 | 300

Remarks

For AFP default is 240

Example

<PrtType:AFP>

Resolution = 240

Available

Release | _______
Patch |

Used By

AFPLIB


SendColor

[PRTType:AFP]
SendColor

[PrtType:AFP]

SendColor = YN

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

The system maps the RGB (red, green, blue) color setting for each object to the closest AFP named color. The default AFP named colors are blue, red, magenta, green, cyan, yellow, dark_blue, orange, purple, dark_green, dark_cyan, mustard, gray, and brown.

Use the NamedColors option to tell the system to use only specific AFP named colors:

<PrtType:AFP>

NamedColors = blue

For example, if you wanted all highlight (non-black) colors mapped to blue, you would set the NamedColors option to blue, as shown above.

To allow the mapping of the colors you assigned to the objects in the FAP file to multiple colors, separate each color with a semicolon (;). For example, to use all of the default AFP named colors except brown, set the NamedColors option as shown here:

NamedColors = red;blue;magenta;green;cyan;yellow

The order of the named colors does not matter.

Example

<PrtType:AFP>

SendColor = Yes,Enabled

Available

Release | _______
Patch |

Used By

AFPLIB


SendOverlays

[PrtType:AFP]
SendOverlays

[PrtType:AFP]

SendOverlays = YesNoHide

Parameter | Description
Boolean | Yes | No Default value is: Yes,Enabled

Remarks

If SendOverlays=Yes is specified, the AFP output will contain references to AFP overlays containing static data (text and graphics).

If SendOverlays=Yes is specified, you should also make sure that you have specified the INI option

<RunMode>

DownloadFAP=No

Performance Tip:

Genprint will usually run faster if SendOverlays=Yes is used.

AFP Overlays are created from FAPs by running the FAP2OVL utility program or from the DMStudio Conversion Wizard.

SendOverlays: This print window option lets the user send images compiled into printer language. Sending overlays enhances print speed so this option is usually selected automatically. The INI value shown in this option's heading represents the recommended value for this Print option.

Example

<PrtType:AFP>

SendOverlays = Yes,Enabled

Available

Release | _______
Patch |

Used By

AFPLIB, AFPPRT


SkipChartColorChange

[PrtType:AFP]
SkipChartColorChange

Prevent color change intended to enhance 3-D effect of charts as is normally done for the top and sides of bars.

[ PrtType:AFP]

SkipChartColorChange = YN

Parameter | Description
boolean | Yes | No

Remarks

Prevent color change intended to enhance 3-D effect of charts as is normally done for the top and sides of bars.

Because some printers might represent the "deepness" of color by applying a pattern, we now support this option to prevent us from changing a bar's side color. The reasoning is that if we deepen the color on the side and the printer then apply a pattern on top of the pattern we explicitly output, the results may not be what the user wants.

Example

<PrtType:AFP>

SkipChartColorChange = Yes

Available

Release | 10.1
Patch | 211

Used By

AFPLIB, AFPPRT


SkipChartPatternChange

[PrtType:AFP]
SkipChartPatternChange

Prevent pattern changes intended to enhance 3-D effect of charts as is normally done for the top and sides of bars.

[PrtType:AFP]

SkipChartPatternChange = YN

Parameter | Description
boolean | Yes | No

Remarks

Prevent pattern changes intended to enhance 3-D effect of charts as is normally done for the top and sides of bars.

Because some printers might represent the "deepness" of color by applying a pattern, we now support this option to prevent us from changing a bar's side color. The reasoning is that if we change the pattern on the sides and the printer then apply a color pattern on top of the pattern we explicitly output, the results may not be what the user wants.

Example

<PrtType:AFP>

SkipChartPatternChange = Yes

Available

Release | 10.1
Patch | 211

Used By

AFPLIB, AFPPRT


SplitPercent

[PrtType:AFP]
SplitPercent

Percentage of space width for rounding errors between resolutions.

[PrtType:AFP]

SplitPercent = Edit

Parameter | Description
percentage | 0 to 100 (default is 50)

Remarks

This setting is used in conjunction with the SplitText INI setting.

The SplitPercent represents the percentage of the width of the space character. When the rounding error between 240 and 300 dpi printing has caused a difference that exceeds this width, the text string will be split into smaller strings.

The SplitPercent value is from zero (0) to 100. Do not enter a value greater than 100. For example, if you set the SplitPercent option to 75, the string is broken into sections if the accumulated rounding error is greater than 75% of the width of the space character. This value is set to 50 by default.

NOTE: Using 50 as the SplitPercent value is a good trade-off between the appearance and the performance impact on the GenPrint program and print spool size. Setting the SplitPercent option to a smaller value gives you a more accurate printout but slows the GenPrint program, increases the size of the print spool, and increases the amount of time it takes to print.

Example

<PrtType:AFP>

SplitPercent = 50

Available

Release | _______
Patch |

Used By

AFPLIB


SplitText

[PrtType:AFP]
SplitText

Used to minimize the print differences between 240 and 300 dpi printing.

[PrtType:AFP]

SplitText = YN

Parameter | Description
boolean | Yes | No Default is No.

Remarks

Due to differences in resolution on 240 and 300 dpi AFP printers, a text string may print with slightly different lengths. One example where this may be noticeable is when the text is printed inside of a boxed region. Another example where this may be noticeable is when a text area contains an embedded variable field.

To minimize the print differences between 240 and 300 dpi printing, use the SplitText option. Make sure these options are in your printer PrtType:xxx control group:

< PrtType:AFP >

SplitText = Yes/No (default is No)

SplitPercent = ### (% of space-width as max rounding error)

Resolution = ### (default is 300)

If you set the SplitText option to Yes, each text string is checked to see if it needs to be split into sections for printing. The SplitPercent value helps determine when a text string must be split into sections for printing. The SplitPercent option sets the percentage of the width of the space character to use as the maximum amount of rounding error that can accumulate in a string before it is broken into sections.

The SplitPercent value is from zero (0) to 100. Do not enter a value greater than 100. For example, if you set the SplitPercent option to 75, the string is broken into sections if the accumulated rounding error is greater than 75% of the width of the space character. This value is set to 50 by default.

The Resolution option determines the rounding error. Most FXRs are built using 300 dpi fonts. This causes rounding errors when the FXR is used for printing to a 240 dpi printer. If you omit the Resolution option, the system uses the default setting of 300.

You need to know whether the FXR you are using was built by importing 300 dpi fonts or 240 dpi fonts. The standard FXRs are built using 300 dpi fonts. When an FXR is built using 300 dpi fonts, there are rounding errors when printing to a 240 dpi printer.

If your font cross-reference file was built from 300 dpi fonts and your printer resolution is 300 dpi, you do not need to set the SplitText option.

If your font cross-reference file was built from 240 dpi fonts and your printer resolution is 240 dpi, you do not need to set the SplitText option.

Here are some examples of options to use in different situations:

Example

If your font cross-reference (FXR) file was built from 300 dpi fonts and your printer resolution is 240 dpi, set the options as shown here:

<PrtType:AFP>

SplitText = Yes

SplitPercent = 50

Resolution = 240

If your font cross-reference (FXR) file was built from 240 dpi fonts and your printer resolution is 300 dpi, set the options as shown here:

<PrtType:AFP>

SplitText = Yes

SplitPercent = 50

Resolution = 300

Available

Release | _______
Patch |

Used By

AFPLIB


StreamBufferSize

[PrtType:AFP]
StreamBufferSize

[PrtType:AFP]

StreamBufferSize = Edit

Parameter | Description
numeric value | Default value is: 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. A value of 0 (zero) means to use the default buffer size.

Example

<PrtType:AFP>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


SuppressLogoUnload

[PrtType:AFP]
SuppressLogoUnload

[PrtType:AFP]

SuppressLogoUnload = YN

Parameter | Description
boolean | Yes | No Default value is: No.

Remarks

This setting is used when converting AFP print files to avoid unloading Documaker logo files.

Example

<PrtType:AFP>

SuppressLogoUnload = No

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType:AFP]
TermFunc

[PrtType:AFP]

TermFunc = Edit

Parameter | Description
value | function name to call on termination of print.

Remarks

The AFP print driver currently does not have an termination function. Leave this setting blank.

Example

<PrtType:AFP>

TermFunc = AFPTerm

Available

Release | _______
Patch |

Used By


TLEEveryPage

[PrtType:AFP]
TLEEveryPage

This setting is used to produce TLE (Tagged Logical Element) records into your AFP output.

[PrtType:AFP]

TLEEveryPage = YN

Parameter | Description
boolean | Yes | No Default value is: No.

Remarks

If you enter Yes, the TLE DAL script will be executed at the start of every page. If you enter No, the TLE DAL script is executed at the start of every form set. The default is No.

Example

<PrtType:AFP>

TLEEveryPage = No

Available

Release | _______
Patch |

See Also

  • TLEScript
  • TLESeparator


TLEScript

[PrtType:AFP]
TLEScript

This setting is used to produce TLE (Tagged Logical Element) records into your AFP output.

[PrtType:AFP]

TLEScript = Edit

Parameter | Description
script file name | Name of script file. Default is no script name. Enter the name of the DAL script to execute to add Tagged Language Element (TLE) records to the print stream.

Remarks

You can add TLE (Tag Logical Element) records into AFP print streams which can be used by some 3rd-party archive systems to archive AFP print streams in a manner similar to archiving AFP or Metacode print streams in Docusave.

You must include comment records in the print streams to index the archive. You can use a DAL script to add comment records into the print stream. Use the TLEScript option in the PrtType:AFP control group to name the DAL script to execute when TLE records can be added into the print stream. The DAL script should call the AddComment function to add a string as a TLE comment record.

The TLE comment string must include a key and a value. Separate these components with a special character. This character can be any printable character as long as it is a unique character not found in the key or value portion of the comment string.

For example, you might build a comment string using a colon (:) as a separator as in the following example:

PolicyNum:7SAMPCO

The key portion of the string is PolicyNum, the value portion of the string is 7SAMPCO, and the separator character is a colon (:).

Example

<PrtType:AFP>

TLEScript = TLE.DAL

TLEEveryPage = No

TLESeparator = :

Here is an example of what TLE.DAL script might look like:

cidlabel = 'PolicyNum'

clientid = GVM("PolicyNum")

colon = ':'

AddComment (cidlabel & colon & clientid);

RETURN('FINISHED!')

In this example, the key portion remains constant (PolicyNum) while the value portion changes based on the contents of the GVM variable, PolicyNum.

Available

Release | _______
Patch |

See Also

  • TLEEveryPage
  • TLESeparator


TLESeparator

[PrtType:AFP]
TLESeparator

This setting is used to produce TLE (Tagged Logical Element) records into your AFP output.

[PrtType:AFP]

TLESeparator = Edit

Parameter | Description
single character | The separator character in the TLE comment record.

Remarks

Enter the character you want to use to separate the key and value portions of the TLE comment string.

Example

<PrtType:AFP>

TLESeparator = :

Available

Release | _______
Patch |

See Also

  • TLEScript
  • TLEEveryPage


Tray1

[PrtType:AFP]
Tray1

[PrtType:AFP]

Tray1 = Edit

Parameter | Description
value | Tray name. The default is 1

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray2

[PrtType:AFP]
Tray2

[PrtType:AFP]

Tray2 = Edit

Parameter | Description
value | Tray name. The default is 2

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray3

[PrtType:AFP]
Tray3

[PrtType:AFP]

Tray3 = Edit

Parameter | Description
value | Tray name. The default is 3

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray4

[PrtType:AFP]
Tray4

[PrtType:AFP]

Tray4 = Edit

Parameter | Description
value | Tray name. The default is 4

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray5

[PrtType:AFP]
Tray5

[PrtType:AFP]

Tray5 = Edit

Parameter | Description
value | Tray name. The default is 1

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray6

[PrtType:AFP]
Tray6

[PrtType:AFP]

Tray6 = Edit

Parameter | Description
value | Tray name. The default is 1

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray7

[PrtType:AFP]
Tray7

[PrtType:AFP]

Tray7 = Edit

Parameter | Description
value | Tray name. The default is 1

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray8

[PrtType:AFP]
Tray8

[PrtType:AFP]

Tray8 = Edit

Parameter | Description
value | Tray name. The default is 1

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray9

[PrtType:AFP]
Tray9

[PrtType:AFP]

Tray9 = Edit

Parameter | Description
value | Tray name. The default is 1

Remarks

The AFP print driver has been modified to support up to nine paper trays. See the Formdef INI setting for details on using paper trays 5 to 9.

You can override AFP tray commands by providing an alternate paper tray to use. Here are the default PrtType:AFP control group settings:

Example

<PrtType:AFP>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 1

Tray6 = 1

Tray7 = 1

Tray8 = 1

Tray9 = 1

Available

Release | 10.1
Patch |

Used By

GENPRINT


UniqueFieldNames

[PrtType:AFP]
UniqueFieldNames

[PrtType:AFP]

UniqueFieldNames = YN

Parameter | Description
boolean | Yes | No Default value is: No.

Remarks

This setting is used when generating normalized AFP files.

Use this setting to fix duplicate tag names that may occur on a page.

Example

<PrtType:AFP>

UniqueFieldNames = No

Available

Release | _______
Patch |

Used By


UseCodedFonts

[PrtType:AFP]
UseCodedFonts

[PrtType:AFP]

UseCodedFonts = YN

Parameter | Description
boolean | Yes | No Default value is: Yes.

Remarks

By default, Documaker will use AFP Coded Font names when producing AFP output.

Set UseCodedFonts = No will cause Documaker will to use AFP AFP Character Set and AFP Code Page names when producing AFP output. Your FXR file must contain AFP Character Set and AFP Code Page names in each font record.

Example

<PrtType:AFP>

UseCodedFonts = No

Available

Release | _______
Patch |

Used By


PrtType:BMP

PrtType:
BMP

PrtType:BMP Options

Bitmap Print Driver INI Settings

See PrtType:BPD


PrtType:BPD

PrtType:
BPD

Remarks

Using the Bitmap Print Driver, you can create bitmaps in several formats from a form set or a single FAP file. Output from the Bitmap Print Driver can be written to disk and stored in one or more files. You can view and print the output in any application that reads bitmap files. You can also archive output using other software applications.

The bitmap print driver works just like other print drivers available for Documaker applications. The Bitmap Print Driver lets you specify a bitmap type to use, such as LOG, TIF, MTIF, JPG, PNG or BMP.

The Bitmap Print Driver can produce bitmap files, typically in TIFF format, for each page of a form set or for the form set as a whole. Depending on the application you are using, you may need to set the INI options to produce the output you want.

FOR DOCUMAKER STUDIO, DOCUMAKER WORKSTATION, AND DOCUCREATE

For Documaker Studio, Documaker Workstation, and Docucreate, there are two ways to process a form set that contains multiple pages. You can create...

  • One TIFF file for each page of the form set

If you set the BmpType option in the PrtType:BPD control group to TIF, the Bitmap Print Driver creates a TIFF file for each page of the form set. For instance, if the form set consists of four pages, you would get four TIFF files.

  • One TIFF file that contains the entire form set

If you set the BmpType option in the PrtType:BPD control group to MTIF, the Bitmap Print Driver creates a single TIFF file for each multi-page form set. For example, if the form set consists of four pages, you would get one TIFF file.

You should make sure the PrtType:BPD options are set similar to those shown here:

< PrtType:BPD >

BMPType = MTIF

Module = BPDW32

PrintFunc = BPDPrint

Device = D:\print\

SendColor = Yes,Enabled

Resolution = 300

Fonts = PCL,TTF,PS,AFP,XER

< Printers >

PrtType = BPD

PrtType:BPD Options

  • BmpType
  • Class
  • DefaultSymSet
  • Device
  • DownLoadFonts
  • Fonts
  • ForcePrintInColor
  • GrayShades
  • InitFunc
  • Module
  • OverlayExt
  • PageNumbers
  • PrePrintedPaper
  • PrintFunc
  • Resolution
  • RotateLandscapePages
  • SendColor
  • StreamBufferSize
  • TermFunc


BmpType

[PrtType:BPD]
BmpType

[PrtType:BPD]

BmpType = Edit

Parameter | Description
value | bitmap type. Default is LOG.

Remarks

Use this option to specify the bitmap format you want to create, such as compressed LOG, LOGPACK, TIF, MTIF, BMP, FNT, IMG, SEG, and JPG.

LOG = Documaker Logo

LOGPACK = Compressed Documaker Logo

JPG = JPEG file

TIF = TIFF format

MTIF = Multipage TIFF format

BMP = Windows BMP format

FNT = Xerox FNT file

IMG = Xerox IMG file

SEG = IBM AFP Page Segment file

Example

<PrtType:BPD>

bmpType = LOG

Available

Release | _______
Patch |

Used By


Class

[PrtType:BPD]
Class

Specifies the printer classification, such as AFP, BPD, PCL, XER, PST, GDI, etc.

[PrtType:BPD]

Class = List

Parameter

Description

class name

Valid class names include others:

  • AFP
  • BPD
  • PCL
  • XER
  • PST
  • GDI

Remarks

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. The internal functions check the Class option to make sure the correct printer is available before continuing. The default is the first three characters of the Module option settings. For bitmap print, this value should be set to BPD.

Example

<PrtType:BPD>

Class=BPD

Available

Release | _______
Patch |

Used By


DefaultSymSet

[PrtType:BPD]
DefaultSymSet

[PrtType:BPD]

DefaultSymSet = Edit

Parameter | Description
value | Specify the symbol set to use when using TrueType and PostScript fonts to convert text into bitmap data. Default is W1.

Remarks

In order to convert a document containing text, the bitmap print driver may use TrueType and PostScript fonts specified in the FXR file to convert the text into a bitmap. Scalable fonts fonts such as TrueType and PostScript fonts can contain characters for multiple character (symbol) sets. The DefaultSymSet setting is used when the font record in the FXR file does not specify a symbol set to use. The W1 symbol set is the symbol set for characters in the Windows ANSI code page.

Example

<PrtType:BPD>

DefaultSymSet = W1

Available

Release | _______
Patch |

See Also

Fonts


Device

[PrtType:BPD]
Device

The name of the file or device where the bitmap output will go.

[PrtType:BPD]

Device = File

Parameter | Description
value | File or device name

Remarks

This setting is ignored by the GenPrint program but is used when printing from GUI Documaker applications like DMStudio, Documaker Workstation, and legacy development tools such as the Image Editor.

Example

<PrtType:BPD>

Device = filename

Available

Release | _______
Patch |

Used By

AFPLIB


DownLoadFonts

[PrtType:BPD]
DownLoadFonts

[PrtType:BPD]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: No,Hidden

Remarks

The bitmap print driver ignores this setting.

Example

<PrtType:BPD>

DownLoadFonts = Yes,Enabled

Available

Release | _______
Patch |


Fonts

[PrtType:BPD]
Fonts

[PrtType:BPD]

Fonts = Edit

Parameter | Description
comma separated list | List of fonts. Default is PCL,AFP,XMC,TTF,PS.

Remarks

This option specifies which type(s) of fonts you want to use when convert text into bitmap data. This option also determines order in which different types of fonts are searched for. For example, if you set the Fonts option to PCL,TTF, the Bitmap Print Driver first tries to locate the PCL font. If the PCL font does not exist, the Bitmap Print Driver then looks for the TTF (TrueType) font.

Types of fonts that can be used:

PCL - PCL (bitmap) printer font

AFP - AFP (bitmap) printer font

XMC - Xerox metacode (bitmap) printer font

TTF - TrueType (scalable) font

PS - PostScript Type 1 (scalable) font

Each text object in a Documaker document is associated with a font record in the FXR file. The font records in the FXR file contain AFP, PCL, Xerox, PostScript, and PDF print sections which can contain the name of the appropriate font to use. The fonts are expected to be located in the directory specified by your MRL's FONTLIB setting.

Example

<PrtType:BPD>

Fonts = PCL,AFP,XMC,TTF,PS

Available

Release | _______
Patch |

Used By


ForcePrintInColor

[PrtType:BPD]
ForcePrintInColor

[PrtType:BPD]

ForcePrintInColor = YN

Parameter | Description
boolean | Yes | No Default value is: No.

Remarks

Enter Yes if you want all objects on the form set to print in their default colors.

The default (No) tells the system that the object’s Print in Color property setting and the print driver’s SendColor option determine if the object prints in color.

This affects all Documaker objects - text labels, text areas, text fields, boxes, lines, bar codes, charts, shaded areas, logos, vectors, and so on.

Example

<PrtType:BPD>

ForcePrintInColor = No

Available

Release | _______
Patch |

Used By


GrayShades

[PrtType:BPD]
GrayShades

[PrtType:BPD]

GrayShades = YN

Parameter | Description
boolean | Yes | No Default value is: No.

Remarks

If you set the GrayShades option to Yes, 8-bit color bitmaps and 24-bit color bitmaps are printed in 256 shades of gray.

Example

<PrtType:BPD>

GrayShades = No

Available

Release | _______
Patch |

Used By


InitFunc

[PrtType:BPD]
InitFunc

The name of the program function that is the initializing entry point into the system's BPD print driver.

[PrtType:BPD]

InitFunc = Edit

Parameter | Description
value | function name. Default is to have no value.

Remarks

The bitmap print driver currently does not have an initialization entry function. Leave this setting blank.

Example

<PrtType:BPD>

InitFunc =

Available

Release | _______
Patch |

Used By


Module

[PrtType:BPD]
Module

The name of the program module which contains the system's BPD print driver.

[PrtType:BPD]

Module = File

Parameter | Description
value | DLL name. Default is BPDW32.

Remarks

In order to produce BPD output, the module must be set to BPDW32.

Example

<PrtType:BPD>

Module = BPDW32

Available

Release | _______
Patch |

Used By


OverlayExt

[PrtType:BPD]
OverlayExt

[PrtType:BPD]

OverlayExt = Edit

Parameter | Description
value | default is .ovl

Remarks

The bitmap print driver does not support overlays. Leave this setting blank.

Example

<PrtType:BPD>

OverlayExt=

Available

Release | 10.0
Patch |


PageNumbers

[PrtType:BPD]
PageNumbers

Set to Yes to turn on form or form set page numbering

[PrtType:BPD]

PageNumbers = YN

Parameter | Description
boolean | Yes | No

Remarks

The PageNumbers option activates the page numbering feature. Set this value to "Yes" to have page numbers printed in the "Page X of Y" format.

Example

<PrtType:BPD>

PageNumbers = No

Available

Release | _______
Patch |

Used By


PrePrintedPaper

[PrtType:BPD]
PrePrintedPaper

Define pre-printed objects state.

[PrtType:BPD]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Also determines the default for this check box--checked or unchecked. You must add this option to the INI file if you want the check box to appear on the Print window.

The default for this option includes the checkbox on the Print window and leaves it unchecked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:BPD>

PrePrintedPaper = (option not checked)

Available

Release | _______
Patch |

Used By


PrintFunc

[PrtType:BPD]
PrintFunc

The name of the program function that is the main entry point into the system's AFP print driver.

[PrtType:BPD]

PrintFunc = Edit

Parameter | Description
value | function name. Default is BPDPrint.

Remarks

In order to produce BPD (bitmap) output the print function must be set to BPDPrint (default).

Example

<PrtType:BPD>

PrintFunc = BPDPrint

Available

Release | _______
Patch |

Used By


StreamBufferSize

[PrtType:BPD]
StreamBufferSize

[PrtType:BPD]

StreamBufferSize = Edit

Parameter | Description
numeric value | Default value is: 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:BPD>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


RotateLandscapePages

[PrtType:BPD]
RotateLandscapePages

[PrtType:BPD]

RotateLandscapePages = YN

Parameter | Description
Boolean | Enter Yes to rotate landscape pages 90 degrees to portrait orientation. Enter No if you do not want to rotate the page. The default is No.

Remarks

You can use the RotateLandscapePages option to tell the system to rotate landscape pages to portrait orientation when Documaker uses the Bitmap Print Driver to create output pages.

The RotateLandscapePages option tells the system to rotate landscape pages so those pages display in portrait orientation, just as they would be displayed by Docusave.

Note: This option is used primarily for viewing purposes. Setting the RotateLandscapePages option to Yes will slow performance.

Keep in mind the multi-page form set per bitmap file will only work with TIFF output.

Example

<PrtType:BPD>

RotateLandscapePages = Yes

Available

Release | 11.4
Patch |


Resolution

[PrtType:BPD]
Resolution

The dots per inch (dpi) resolution of the printer which receives the bitmap data stream.

[PrtType:BPD]

Resolution = Edit

Parameter | Description
dots_per_inch | The dpi at which to generate the bitmap output. Default is 300.

Remarks

Keep in mind that the higher the color depth and resolution, the longer it will take to create output.

For example, changing from 24-bit color bitmap to monochrome (black and white) makes the bitmap 24 times smaller.

For example, a 24-bit color bitmap at 300 DPI that measures

an 8.5 x 11 inches will require a bitmap file that is roughly

25MB in size.

300 x 300 x 8.5 x 11 x 24 / 8 = 25,245,000 bytes

300 = resolution in DPI

8.5 X 11 = letter page size in inches

24 =color depth in bits

8 = bits in one byte

The larger the bitmap, the slower the processing.

Example

<PrtType:BPD>

Resolution = 300

Available

Release | _______
Patch |

Used By


SendColor

[PrtType:BPD]
SendColor

[PrtType:BPD]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default is No,Enabled

Remarks

Set to Yes to enable color printing.

Keep in mind that as color depth (bits per pixel) and resolution increases, the bitmap file will take longer to create and will be bigger in terms of the size of the bitmap file.

The bits-per-pixel of a page bitmap may be 1-bit, 8-bit, or 24-bit, depending on the objects on the page.

For instance...

If | The bitmap will be
All objects are the same color | A 1-bit single color or BW (black and white)

Objects are single colors or use the orthogonal color palette

An 8-bit bitmap based on the orthogonal color palette

The bitmap is from a 24-bit logo

A 24-bit true color bitmap

A 24-bit color bitmap at 300 DPI that measures an 8.5 x 11 inches will requires roughly 25MB in bitmap data.

300 = resolution in DPI

8.5 X 11 = letter page size in inches

24 = color depth in bits

8 = bits in one byte

300 x 300 x 8.5 x 11 x 24 / 8 = 25,245,000 bytes

Changing from 24-bit color bitmap to monochrome (black and white) makes the amount of bitmap data 24 times smaller.

If you set the SendColor option to No or uncheck the corresponding field on the Print window, the output will be in black and white.

If you set the GrayShades option to Yes, 8-bit color bitmaps and 24-bit true color bitmaps are printed in 256 shades of gray.

Be aware that when converted to a bitmap, an object must have a color selection and the Print in Color option should be checked. Otherwise, it will print in black and white — unless you use the ForcePrintInColor option.

Example

<PrtType:BPD>

SendColor = Yes,Enabled

Available

Release | _______
Patch |

See Also

ForcePrintInColor


TermFunc

[PrtType:BPD]
TermFunc

[PrtType:BPD]

TermFunc = Edit

Parameter | Description
value | function name to call on termination of print. Default is to have no value specified.

Remarks

The bitmap print driver currently does not have a termination function. Leave this setting blank.

Example

<PrtType:BPD>

TermFunc =

Available

Release | _______
Patch |

Used By


PrtType:EPT

PrtType:
EPT

Remarks

The email print driver lets you create a print-ready file (such as a PDF or RTF file) that you can email to another user.

Since EPTLIB is essentially a wrapper for a real print driver, the INI options must also include a reference to the actual print driver that the system will use to create the print-ready file (such as a PDF or RTF file).

There are also INI options for the email processing, in addition to the regular email INI options.

The PrtType:EPT INI settings are used to customize the email print driver. For instance, you can add subject and message information and use the email address book when printing from Documaker Workstation using the EPT print driver. The system would then display the email address book. After selecting the recipients, a window will appear into which you can enter the subject and message text. You then choose to send or cancel the message.

PrtType:EPT Options

  • Class
  • Device
  • DownLoadFonts
  • FileName
  • InitFunc
  • KeepFile
  • Message
  • MessageFile
  • Module
  • MsgPrtType
  • OverlayExt
  • PageNumbers
  • PrePrintedPaper
  • PrintFunc
  • PrtType
  • RecipFunc
  • Recipient
  • RecipMod
  • SendColor
  • StreamBufferSize
  • Subject
  • TermFunc
  • WriteToFile


Class

[PrtType:EPT]
Class

Specifies the printer classification, such as AFP, EPT, PCL, XER, PST, GDI, etc.

[PrtType:EPT]

Class = List

Parameter

Description

class name

Valid class names include others:

  • AFP
  • EPT
  • PCL
  • XER
  • PST
  • GDI

Remarks

If you omit this INI option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. The internal functions check the Class option to make sure the correct printer is available before continuing. The default is the first three characters of the Module option settings. For EPT, this value should be set to EPT.

Example

<PrtType:EPT>

Class=EPT

Available

Release | _______
Patch |

Used By


Device

[PrtType:EPT]
Device

[PrtType:EPT]

Device = Edit

Parameter | Description
value | File name and path

Remarks

This setting is ignored by the GenPrint program but is used when printing from GUI Documaker applications like DMStudio, Documaker Workstation, and legacy development tools such as the Image Editor.

Example

<PrtType:EPT>

Device = .\data\sample.rtf

Available

Release | 10.0
Patch | 409


DownLoadFonts

[PrtType:EPT]
DownLoadFonts

[PrtType:EPT]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Set to Yes to enable downloading of fonts.

Tip

Many print options, such as the DownloadFonts option, are set before the system calls the email print driver. These options are passed on another print driver which creates the file to be attached to the email. To have the email print driver use the DownloadFonts setting from another print driver (such as PDF), set your PrtType:EPT control group to look like this:

< PrtType:EPT >

PrtType = PDF

DownloadFonts = [PrtType:PDF] DownloadFonts =

This way, if you change the DownloadFonts options in the PrtType:PDF control group, those changes are automatically picked up in the PrtType:EPT control group.

Example

<PrtType:EPT>

DownLoadFonts = No,Enabled

Available

Release | _______
Patch |


FileName

[PrtType:EPT]
FileName

[PrtType:EPT]

FileName = Edit

Parameter | Description
value | File name and path of email attachment

Remarks

This INI option gives the name of the output file to create for email attachment which will be produced by the printer driver you specified in the PrtType option. This is only used if the Device name field is empty in the GUI print window (the batch file name is used for GenPrint).

If the device name is empty and the FileName option is omitted, a temporary file name is used. Use a file name with an extension that matches the print driver type, such as RTF. For GenPrint, the file name is the name of the print batch if PrtType is specified.

Example

<PrtType:EPT>

FileName = .\data\sample.rtf

Available

Release | 10.0
Patch | 409


InitFunc

[PrtType:EPT]
InitFunc

Tells the system to use a special initialization function called EPTInit which is located in EPTW32.DLL.

[PrtType:EPT]

InitFunc = Edit

Parameter | Description
value | Default value is: EPTINIT

Remarks

This setting tells the system to use a special initialization function called EPTInit which is located in EPTW32.DLL.

Example

<PrtType:EPT>

InitFunc = EPTInit

Available

Release | 10.0
Patch | 409


KeepFile

[PrtType:EPT]
KeepFile

[PrtType:EPT]

KeepFile = YN

Parameter | Description
Boolean | Default value is: No

Remarks

The INI option tells EPTLIB whether or not to keep the output file after it has been emailed. The default is No.

Example

<PrtType:EPT>

KeepFile = No

Available

Release | 10.0
Patch | 409


Message

[PrtType:EPT]
Message

[PrtType:EPT]

Message = Edit

Parameter | Description
value | Enter a brief message

Remarks

This INI option is used to add a brief message to the email body when printing from Documaker Workstation using the EPT print driver. The message can be added only if MsgPrtType option is not specified.

Example

<PrtType:EPT>

Message = This is a testing message

Available

Release | 10.0
Patch | 409


MessageFile

[PrtType:EPT]
MessageFile

[PrtType:EPT]

MessageFile = .\data\mpm.htm

Parameter | Description
value | File name and path of email message.

Remarks

This INI option gives the name of the output file to create for email message which will be produced by the printer driver you specified in the MsgPrtType option. This is only used if the Device name field is empty in the GUI print window (the batch file name is used for GenPrint).

If the device name is empty and the MessageFile option is omitted, a temporary file name is used. Use a file name with an extension that matches the print driver type, such as MPM, MHT or EML, etc. For GenPrint, the file name is the name of the print batch if MsgPrtType is specified.

Example

<PrtType:EPT>

MessageFile = .\data\sample.mht

Available

Release | 11.5
Patch | P01


Module

[PrtType:EPT]
Module

The name of the program module which contains the system's email print driver.

[PrtType:EPT]

Module = File

Parameter | Description
value | The Default value is: EPTW32

Remarks

This setting tells the system to load a DLL called EPTW32.DLL.

Example

<PrtType:EPT>

Module = EPTW32

Available

Release | 10.0
Patch | 409


MsgPrtType

[PrtType:EPT]
MsgPrtType

[PrtType:EPT]

MsgPrtType = MPM

Parameter | Description
value | Name of Multipart MIME printer INI group.

Remarks

The MsgPrtType option tells the email print driver which print driver to hook up to create the print-ready file for email message. If omitted, a brief message can be added if Message option is set.

Since EPTLIB is essentially a wrapper for a real print driver, the INI options must also include a reference to the actual print driver that the system will use to create the print-ready file (such as a MPM or HTM file).

Example

<PrtType:EPT>

PrtType = MPM

Available

Release | 11.5
Patch | P01


OverlayExt

[PrtType:EPT]
OverlayExt

[PrtType:EPT]

OverlayExt = Edit

Parameter | Description
value | default is .ovl

Remarks

The email print driver does not support overlays. Leave this setting blank.

Example

<PrtType:EPT>

OverlayExt=

Available

Release

Patch


PageNumbers

[PrtType:EPT]
PageNumbers

Set to Yes to turn on form or form set page numbering

[PrtType:EPT]

PageNumbers = YN

Parameter | Description
boolean | Yes | No

Remarks

The PageNumbers option activates the page numbering feature. Set this value to "Yes" to have page numbers printed in the "Page X of Y" format.

Tip

Many print options, such as the PageNumbers option, are set before the system calls the email print driver. These options are passed on another print driver which creates the file to be attached to the email. To have the email print driver use the PageNumbers setting from another print driver (such as PDF), set your PrtType:EPT control group to look like this:

< PrtType:EPT >

PrtType = PDF

PageNumbers = [PrtType:PDF] PageNumbers =

This way, if you change the PageNumbers options in the PrtType:PDF control group, those changes are automatically picked up in the PrtType:EPT control group.

Example

<PrtType:EPT>

PageNumbers = No

Available

Release | _______
Patch |

Used By


PrePrintedPaper

[PrtType:EPT]
PrePrintedPaper

Define pre-printed objects state.

[PrtType:EPT]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Also determines the default for this check box--checked or unchecked. You must add this option to the INI file if you want the check box to appear on the Print window.

The default for this option includes the checkbox on the Print window and leaves it unchecked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Tip

Many print options, such as the PrePrintedPaper option, are set before the system calls the email print driver. These options are passed on another print driver which creates the file to be attached to the email. To have the email print driver use the PrePrintedPaper setting from another print driver (such as PDF), set your PrtType:EPT control group to look like this:

< PrtType:EPT >

PrtType = PDF

PrePrintedPaper = [PrtType:PDF] PrePrintedPaper =

This way, if you change the PrePrintedPaper options in the PrtType:PDF control group, those changes are automatically picked up in the PrtType:EPT control group.

Example

<PrtType:EPT>

PrePrintedPaper = (option not checked)

Available

Release | _______
Patch |

Used By


PrintFunc

[PrtType:EPT]
PrintFunc

Tells the system to use a print function called EPTPrint located in EPTW32.DLL.

[PrtType:EPT]

PrintFunc = Edit

Parameter | Description
value | Default value is: EPTPrint

Remarks

This setting tells the system to use a print function called EPTPrint located in EPTW32.DLL.

Example

<PrtType:EPT>

PrintFunc = EPTPrint

Available

Release | 10.0
Patch | 409


PrtType

[PrtType:EPT]
PrtType

[PrtType:EPT]

PrtType = Edit

Parameter | Description
value | Name of another printer INI group (e.g. RTF, PDF, etc.). Default is RTF.

Remarks

The PrtType option tells the email print driver which print driver to hook up to create the print-ready file for email attachment. If omitted, it defaults to the RTF print driver (Rich Text Format).

Since EPTLIB is essentially a wrapper for a real print driver, the INI options must also include a reference to the actual print driver that the system will use to create the print-ready file (such as a PDF or RTF file).

Example

<PrtType:EPT>

PrtType = PDF

Available

Release | 10.0
Patch | 409


RecipFunc

[PrtType:EPT]
RecipFunc

[PrtType:EPT]

RecipFunc =

Parameter | Description
value | Name of function to use to determine the recipient

Remarks

The RecipFunc option tells the system which function to use to determine the recipient. If it is omitted, the system uses the email print driver's default recipient function.

The CSTSetMailRecip function displays a window which shows the subject and message text and lets you edit this text. This window also lets you provide the email recipient for Documaker Workstation. Documaker Server lets you use these functions to set up recipients:

RecipMod = CUSW32

RecipFunc = CUSSetMailRecip

or

RecipMod = CUSW32

RecipFunc = CUSSetMailRecipGVM

Function | Description
CUSSetMailRecip | This function finds the print recipient and looks up the recipient in the RECIP_MAIL control group to get the email address of the recipient. Here is an example: < RECIP_MAIL > AGENT = myagent@sampco.com COMPANY = support@sampco.com

CUSSetMailRecipGVM

This function finds the recipient in a global variable, the name of which is defined in this INI option:

< PrtType:EPT >

Recipient = EAddress

Instead of using EAddress as the recipient name, the system uses it as the variable name to look up to find the recipient name. This global variable can have any name.

Custom Code

If you wanted to write your own custom recipient function, the recipient function must use the following syntax:

DWORD _VMMAPI EPTDefSetRecipient(VMMHANDLE objectH,

char FAR * recip,

size_t len);

Parameter | Description
objectH | The object being printed (form set, form, or page)
recip | The recipient buffer

len

Length of the buffer, currently 80 characters

The return value should be SUCCESS or FAILURE. If FAILURE, then the message is not sent and FAILURE is returned from EPTPrint.

To set the recipient function without using the RecipMod and RecipFunc INI options, use the EPTSetRecipFunc function:

EPTRECIPFUNC _VMMAPI EPTSetRecipFunc(EPTRECIPFUNC newfunc);

Call it with the address of the recipient function:

EPTSetRecipFunc(func);

The EPTSetRecipFunc function returns the previous installed function, which can be used to set it back.

Example

<PrtType:EPT>

RecipFunc = CSTSetMailRecipgvm

Available

Release | 10.0
Patch | 409


Recipient

[PrtType:EPT]
Recipient

[PrtType:EPT]

Recipient = Edit

Parameter | Description
value | Recipient email address

Remarks

This INI option allows you to set the email Recipient.

Example

<PrtType:EPT>

Recipient = johndoe@mailserv.com

Available

Release | 10.0
Patch | 409


RecipMod

[PrtType:EPT]
RecipMod

[PrtType:EPT]

RecipMod = Edit

Parameter | Description
value | Name of module to locate the RecipFunc.

Remarks

The RecipMod option tells the system which module to use to locate the RecipFunc. If this option is omitted, the system uses the email print driver's default recipient function.

Example

<PrtType:EPT>

RecipMod = CSTW32

Available

Release | 10.0
Patch | 409


SendColor

[PrtType:EPT]
SendColor

[PrtType:EPT]

SendColor = YN

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

Set to Yes to enable color printing.

Tip

Many print options, such as the SendColor option, are set before the system calls the email print driver. These options are passed on another print driver which creates the file to be attached to the email. To have the email print driver use the SendColor setting from another print driver (such as PDF), set your PrtType:EPT control group to look like this:

< PrtType:EPT >

PrtType = PDF

SendColor = [PrtType:PDF] SendColor =

This way, if you change the SendColor or DownloadFonts options in the PrtType:PDF control group, those changes are automatically picked up in the PrtType:EPT control group.

Example

<PrtType:EPT>

SendColor = Yes

Available

Release | _______
Patch |

Used By


StreamBufferSize

[PrtType:EPT]
StreamBufferSize

[PrtType:EPT]

StreamBufferSize = Edit

Parameter | Description
numeric value | Default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:EPT>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


Subject

[PrtType:EPT]
Subject

[PrtType:EPT]

Subject = Edit

Parameter | Description
value | Enter the email subject.

Remarks

Now you can add Subject to the email when printing from Documaker Workstation using the EPT print driver.

Example

<PrtType:EPT>

Subject = Multipart MIME email test

Available

Release | 10.0
Patch | 409


TermFunc

[PrtType:EPT]
TermFunc

Tells the system to use a special termination function called EPTTerm located in EPTW32.DLL.

[PrtType:EPT]

TermFunc = Edit

Parameter | Description
value | Default value is: EPTTerm

Remarks

This tells the system to use a special termination function called EPTTerm located in EPTW32.DLL.

Example

<PrtType:EPT>

TermFunc = EPTTerm

Available

Release | 10.0
Patch | 409


WriteToFile

[PrtType:EPT]
WriteToFile

This option enables EPT print driver to create an email file in MultiPart MIME format on disk which may contain embedded HTM, PCL, PDF, PST, RTF, XML or bitmap (BMP, JPG, PNG, TIF, and so on) data in the message body or as attachment.

[PrtType:EPT]

WriteToFile = filename

Parameter | Description
WriteToFile | path\fname.ext - where fname denotes the file name and ext the file extension.

Remarks

If you do not specify a path, the EPT print driver writes the MPM data to the current working directory. If you leave fname empty, the EPT print driver creates a globally unique identifier (GUID) file name for you. The default file extension is .mht, You can, however, specify another text type extension, such as .eml (for email, such as Microsoft Outlook Express), .mpm (for normal MPM) or .txt (for plain text).

Example

<PrtType:EPT>

WriteToFile = .\data\sample.mht

Available

Release | 11.5
Patch | P01

Used By


PrtType:GDI

PrtType:
GDI

Remarks

Oracle Insurance developed a Graphics Device Interface (GDI) print driver because it provides many opportunities for Windows platform users. For example, by using a GDI driver, you can now fax, since fax drivers can be installed into Windows as a GDI Windows printer driver.

Also, printing using GDI lets you print to printers that do not support any of the printer languages the system supports, such as inkjet printers. To make this driver even more useful, it includes the ability to scale output, which lets you shrink the printed output to the size of the paper.

The advantages of using the Graphics Device Interface (GDI) include:

  • Ability to print to any printer attached via a Windows print driver
  • Ability to print to any fax machine attached via a Windows print driver
  • Ability to scale edge to edge forms to print within the printable area defined by the Windows print driver.

The disadvantages of using the Graphics Device Interface (GDI) include:

  • Print quality is often poorer
  • Inability to print a mixture of portrait and landscape forms
  • Inability to print a mixture of simplex and duplex forms
  • Inability to address the same printable area available when using our native print drivers.

When you use our GDI driver, a Windows print driver will use the Windows screen fonts to print the document with its goal being to make the printed document look like it does on your screen.

NOTE: In Documaker implementations, users typically decide what fonts they want to use and then install those fonts on the production printer. Documaker applications try to make the screen look like the printed output, not the other way around. Information from the production printer fonts is loaded into the font cross-reference file. The system uses this information to try to represent the printer fonts on screen.

GDI print quality, by definition, is based on the fonts used for display. The attributes which describe fonts in the font cross-reference file determine which screen fonts are used. The screen fonts used determine what you see on the screen and how GDI printed output will look.

So, the key to improving GDI print is to improve the fonts used in the display system. Some of this can be improved by making sure the font’s character widths and family name is correct. There are INI options for improving the screen font substitutions, if names cannot be matched up.

For the best results, you should use exact matching screen fonts. The system comes with a set of TrueType fonts that match the printer fonts included with the system. Install and use these fonts for best results.

NOTE: If you are instead working backward from existing production fonts, as is often the case, either an approximation must take place, or you have to find screen fonts built from the printer fonts.

"GDI" is our standard naming convention when referring to a Windows installed printer. The actual INI group defined by the customer might be named something else.

When we refer to using the "GDI" group, this means the user will be picking a printer that is installed as a Windows Print Driver.

NOTE: Normally with GDI print, it is a good idea to use the FitToWidth option because a Windows print device normally does not give you full edge-to-edge support of the page. Therefore, FitToWidth can be used to scale your forms to fit within whatever your Windows print driver defines as the printable area of the page.

PrtType:GDI Options

  • BitmapFix
  • Class
  • ColorBitmapMode
  • Device
  • DownLoadFonts
  • FitToWidth
  • FullSupport
  • GDIDevice
  • InitFunc
  • Module
  • MonoBitmapMode
  • MultipleCopies
  • OverlayExt
  • PageNumbers
  • PaperSizeMatching
  • PrintFunc
  • PrintToFile
  • PrintViewOnly
  • Resolution
  • SelectRecipients
  • SendColor
  • SendOverlays
  • StreamBufferSize
  • SuppressDlg
  • TemplateFields
  • TermFunc
  • Tray1
  • Tray2
  • Tray3
  • Tray4
  • Tray5
  • Tray6
  • Tray7
  • Tray8
  • Tray9
  • Watermark

Example

[PrtType:GDI]

PrintFunc = GDIPrint

Module = GDIW32

SendColor = No,Enabled

FitToWidth = Yes,Enabled


BitmapFix

[PrtType:GDI]
BitmapFix

BitmapFix

[PrtType:GDI]

BitmapFix = YN

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

The setting was added to handle a problem with some Windows print drivers would not print a color bitmap until a black bitmap was printed. If you experience a problem printing in color and the problem appears to occur when printing the first bitmap, try using this setting and see if it corrects the problem.

Example

<PrtType:GDI>

BitmapFix = Yes

Available

Release | _______
Patch |

Used By


Class

[PrtType:GDI]
Class

Class

Specifies the printer classification, such as AFP, GDI, PCL, XER, PST, etc.

[PrtType:GDI]

Class = Edit

Parameter

Description

class name

Valid class names include others:

  • AFP
  • GDI
  • PCL
  • XER
  • PST
  • GDI

Remarks

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PRTType:GDI>

Class = GDI

Available

Release | _______
Patch |

Used By

GDILIB


ColorBitmapMode

[PrtType:GDI]
ColorBitmapMode

ColorBitmapMode

[PrtType:GDI]

ColorBitmapMode = Edit

Parameter | Description
numeric value | Default value is 13369376 (equivalent to CC0020 in hexadecimal.)

Remarks

The value of the ColorBitmapMode is used as raster operator when transferring or resizing bitmap data. The value 13359376 (or 0x00CC0020) is an known as a "SRCCOPY" setting that copies the source rectangle directly to the destination rectangle.

You would only change this setting if you have a problem printing color bitmaps.

Example

<PrtType:GDI>

ColorBitmapMode = 13369376

Available

Release | _______
Patch |

Used By


Device

[PrtType:GDI]
Device

Device

The name of the printer device you want to use.

[PrtType:GDI]

Device = File

Parameter | Description
Name | any file or device name

Remarks

This setting is ignored by the GDI print driver.

Example

<PrtType:GDI>

Device = filename

Available

Release | _______
Patch |

Used By

GDILIB


DownLoadFonts

[PrtType:GDI]
DownLoadFonts

DownLoadFonts

Downloads fonts to the printer.

[PrtType:GDI]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No

Remarks

This setting is ignored by the GDI print driver.

Example

<PrtType:GDI>

DownLoadFonts = Yes,Enabled

Available

Release | _______
Patch |

Used By


FitToWidth

[PrtType:GDI]
FitToWidth

FitToWidth

Scale pages to fit on the paper.

[PrtType:GDI]

FitToWidth = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

Scale pages to fit on the paper. This option will, if necessary, shrink the size of the page to fit on the paper. It will not increase (expand) the size of the page.

Example

<PrtType:GDI>

FitToWidth = No

Available

Release | _______
Patch |

Used By

GDILIB


FullSupport

[PrtType:GDI]
FullSupport

FullSupport

[PrtType:GDI]

FullSupport = YN

Parameter | Description
Boolean (Yes) | Yes | No Default value is: Yes

Remarks

If the FullSupport option is set to Yes, the GDI driver assumes the Windows print driver contains full print support and can handle form sets with mixed simplex and duplex forms (some FAX drivers crash when presented these kinds of forms).

You may need to set the FullSupport option to No in order to prevent problems with FAX drivers which could occur when you were printing from Documaker Workstation.

The GDI driver first looks for this INI option in the control group whose name reflects the Windows print driver, such as HP LaserJet 4050 Series PS.

Here is an example:

<HP LaserJet 4050 Series PS>

FullSupport = Yes

If not found there, the GDI driver looks for the FullSupport option in the control group for the printer type, such as PrtType:GDI.

If you place the FullSupport option in the PrtType:GDI control group, it serves as a default for all GDI printers. Putting the option in for specific devices overrides this default.

Example

<PrtType:GDI>

FullSupport = Yes

Available

Release | 10.3
Patch |


GDIDevice

[PrtType:GDI]
GDIDevice

GDIDevice

Specifies the Windows printer name.

[PrtType:GDI]

GDIDevice = Edit

Remarks

The GDIDevice setting allows you to specifies the Windows printer name to use for printing.

The GDIDevice setting is often used along with the SuppressDlg option option to have the GDI print driver use a specific Windows print driver instead of displaying a dialog to allow the user to select the Windows print driver.

If you specify a Windows printer name in the GDIDevice setting and set the SuppressDlg option to Yes, the system suppresses the Print window and automatically prints to the Windows printer name you specified.

If you leave the GDIDevice option blank and set the SuppressDlg option to Yes, the system suppresses the Print window and automatically prints to the default Windows printer.

To see the list of the printers available on your system, open the Printers folder in the Windows Control Panel.

Example

<PrtType:GDI>

GDIDevice = HP LaserJet 8000

Additional Use

Lets say that you want to use the Documaker PCL print driver and you want the PCL output sent directly to a Windows print driver (instead of producing a print stream written to disk).

If you are using the Documaker PCL print driver to print from GUI Documaker applications like DMStudio, Documaker Workstation, and legacy development tools such as the Image Editor, you can specify an empty Device setting.

When you leave the Device setting blank, you are using the "Pass Through Printing" method.

When you leave the Device setting blank, you are telling the print driver that you want to print through an installed Windows printer device. Leaving the Device setting blank will cause the system to open the Windows Print dialog so you can select which printer device to send (pass through) the output from the Documaker PCL print driver.

Instead of opening the Windows Print dialog and manually selecting a specific device driver, you can use the GDIDevice setting to specify the Windows printer name to use for printing.

Here is an example that leaves the Device setting blank to invoke Pass Through Printing and specifies a particular Windows print driver to use for printing:

<PrtType:PCL>

Device =

GDIDevice = HP LaserJet 8000

In this example, the Documaker PCL print driver is used to produce the PCL output and pass it through directly to the Windows print driver called "HP LaserJet 8000".

Available

Release | 10.1
Patch |

Used By

GDILIB


InitFunc

[PrtType:GDI]
InitFunc

InitFunc

[PrtType:GDI]

InitFunc = Edit

Parameter | Description
Edit |

Remarks

Enter GDIInit to tell the system to use this initialization function, which is located in the GDIW32.DLL file. This function is required when using the GDI print driver for batch printing.

Example

<PrtType:GDI>

Module = GDIW32

PrintFunc = GDIPrint

InitFunc = GDIInit

TermFunc = GDITerm

Available

Release | _______
Patch |

See Also

PrintToFile , TermFunc


Module

[PrtType:GDI]
Module

Module

The name of the program module which contains the system's GDI print driver.

[PrtType:GDI]

Module = File

Parameter | Description
DLL Name | The DLL name of the print driver. The default GDI print driver is GDIW32.DLL.

Remarks

The name of the program module which contains the system's GDI print driver. See also the Class option.

Example

<PrtType:GDI>

Module = GDIW32

Available

Release | _______
Patch |

Used By

GDILIB


MonoBitmapMode

[PrtType:GDI]
MonoBitmapMode

MonoBitmapMode

[PrtType:GDI]

MonoBitmapMode = Edit

Parameter | Description
numeric value | Default value is 8913094 (equivalent to 8800C6 in hexadecimal.)

Remarks

The value of the MonoBitmapMode is used as raster operator when transferring or resizing bitmap data. The value 8913094 (or 0x008800C6) is an known as a "SRCAND" setting that combines the colors of the source and destination rectangles by using the Boolean AND operator.

You would only change this setting if you have a problem printing monochrome bitmaps.

Example

<PrtType:GDI>

MonoBitmapMode = 8913094

Available

Release | _______
Patch |

Used By


MultipleCopies

[PrtType:GDI]
MultipleCopies

MultipleCopies

Setting MultipleCopies to Yes will allow you to specify the number of copies to be printed from the Documaker print dialog.

[PrtType:GDI]

MultipleCopies = No

Parameter | Description
boolean | Yes | No Default value is: No

Example

<PrtType:GDI>

MultipleCopies = No

Available

Release | _______
Patch |


OverlayExt

[PrtType:GDI]
OverlayExt

OverlayExt

[PrtType:GDI]

OverlayExt = Edit

Parameter | Description
value | default is .ovl

Remarks

The GDI print driver does not support overlays. Leave this setting blank.

Example

<PrtType:GDI>

OverlayExt=

Available

Release

Patch


PageNumbers

[PrtType:GDI]
PageNumbers

PageNumbers

Set to Yes to enable form or form set page numbering.

[PrtType:GDI]

PageNumbers = YN

Parameter | Description
boolean | Yes | No Default is No.

Example

<PrtType:GDI>

PageNumbers = No

Available

Release | _______
Patch |

Used By

GDILIB


PaperSizeMatching

[PrtType:GDI]
PaperSizeMatching

PaperSizeMatching

[PrtType:GDI]

PaperSizeMatching = YN

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

When PaperSizeMatching is set to Yes and printing a Documaker document uses a paper size that is not supported by Windows, the GDI print driver will attempt to select a larger Windows paper size.

When PaperSizeMatching is set to No and printing a Documaker document uses a paper size that is not supported by Windows, the GDI print driver will use letter paper size.

Example

<PrtType:GDI>

PaperSizeMatching = Yes

Available

Release | _______
Patch |

Used By


PrePrintedPaper

[PrtType:GDI]
PrePrintedPaper

PrePrintedPaper

Define pre-printed objects state.

[PrtType:GDI]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No

Remarks

Determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Also determines the default for this check box--checked or unchecked. You must add this option to the INI file if you want the check box to appear on the Print window.

The default for this option includes the checkbox on the Print window and leaves it unchecked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:GDI>

PrePrintedPaper = Yes,Disabled

Available

Release | _______
Patch |

Used By

GDILIB


PrintFunc

[PrtType:GDI]
PrintFunc

PrintFunc

The name of the program function that is the main entry point into the system's GDI print driver.

[PrtType:GDI]

PrintFunc = Edit

Parameter | Description
function Name | The default function name is GDIPrint for the GDIW32.DLL module.

Example

<PrtType:GDI>

PrintFunc = GDIPrint

Available

Release | _______
Patch |

Used By

GDILIB


PrintToFile

[PrtType:GDI]
PrintToFile

PrintToFile

You can use the GDI print driver to print to a file by adding the PrintToFile option in your GDI printer control group. This lets you direct output to the path and file you specify — equivalent to checking the Print to File field on the Windows Print dialog.

[PrtType:GDI]

PrintToFile = YN

Parameter | Description
boolean | Yes | No Enter Yes to have the GDI print driver use the Port options as the output print file names for each batch when running GenPrint. The default is No.

Remarks

In the GenPrint program, output print file names for each batch are specified using the Port INI option. When you use the GenPrint program with most Documaker print drivers, the Port option determines the name of the print stream created for each batch.

Normally, the GDI print driver prints directly to a Windows print driver and does not create files written to disk. By setting the PrintToFile option to Yes in your GDI printer control group, the GDI print driver creates a print stream for each batch based on the names specified in the Port options — just like the other Documaker print drivers.

Because the Documaker GDI print driver is not designed for batch print, these additional GDI print options are recommended when you set the PrintToFile to Yes:

< PtrType:GDI >

Module = GDIW32

PrintFunc = GDIPrint

SuppressDlg = Yes

GDIDevice = (Windows printer name)

FullSupport = Yes

InitFunc = GDIInit

TermFunc = GDITerm

...

This feature is limited to using the GDI driver with GenPrint (multi-step batch print) to produce output print files and is limited to simple GenPrint (batch print) environments.

Keep in mind that all normal GDI print limitations (fidelity, tray selection, duplexing, and so on) apply, plus the following:

  • Banner page processing may not work.
  • Cannot use the SetDeviceName and BreakBatch DAL functions.
  • Callback functions may not work.
  • Single step processing does not work correctly (all transactions are printed to a single file).
  • Multiple driver routers may not work.
  • Printing from Studio or Image Editor may work but the Device setting will be used to create the file. Printing from Documaker Workstation may not work.
  • Printing to fax drivers, email drivers, and so on may not work and other types of print or print features not previously discussed may not work.

In other words, trying to use PrintToFile option with anything except GenPrint running in a simple batch mode using a normal Windows print driver is not supported.

Example

<PrtType:GDI>

PrintToFile = No

Available

Release | _______
Patch |

See Also

InitFunc , TermFunc


PrintViewOnly

[PrtType:GDI]
PrintViewOnly

PrintViewOnly

If set to Yes, the view only images will print.

[PrtType:GDI]

PrintViewOnly = YN

Parameter | Description
boolean | Yes | No

Remarks

If set to Yes, the view only images will print. This does not apply to entry only images, which are never printed. Entry only images are usually worksheets. If the image is marked as hidden and view only, it will not print.

Example

<PrtType:GDI>

PrintViewOnly = Yes

Available

Release | _______
Patch |

Used By

GDILIB


Resolution

[PrtType:GDI]
Resolution

Resolution

The dots per inch (dpi) resolution of the data stream.

[PrtType:GDI]

Resolution = Edit

Parameter | Description
dots_per_inch | Default is 0

Remarks

This setting is ignored by the GDI print driver.

Example

<PrtType:GDI>

Resolution = 0

Available

Release | _______
Patch |

Used By


SelectRecipients

[PrtType:GDI]
SelectRecipients

SelectRecipients

[PrtType:GDI]

SelectRecipients = YesNoHide

Parameter | Description
boolean | Yes | No Default is Yes,Enabled.

Remarks

Enabled means the Select Recipients checkbox and recipient list appears in the Print window and is active (available to be checked).

Disabled means the Select Recipients checkbox and recipient list appears in the Print window but is grayed out (not available to be checked).

Hidden means the Select Recipients checkbox and recipient list does not appear in the Print window.

Example

<PrtType:GDI>

SelectRecipients = No,Enabled

Available

Release | _______
Patch |

Used By

GDILIB


SendColor

[PrtType:GDI]
SendColor

SendColor

Set to Yes to enable color printing.

[PrtType:GDI]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No

Remarks

This print window option is for color printers. If you plan to use a color printer, enter Yes,Enabled for SendColor parameters.

NOTE: If you do not specify the option for sending color to a GDI printer, the system converts color (4-, 8-, or 24-bit) graphics into monochrome before sending them to the printer driver. Depending on the bitmap, this conversion from color to monochrome may not yield acceptable results. Be sure to consider your printers capabilities when you are creating graphics.

If you elect to send color, including color graphics, to a GDI printer that does not support color, the printer driver determines what to do. Some ignore the color commands (printing in black), and some apply a gray-scale adjustment to the output to simulate the color changes. Some GDI printer drivers cannot accept color commands at all. If printing to your Windows-attached printer causes a program fault, or print failure, try turning off the Send Color option via the system’s Print window and sending the output again.

Example

<PrtType:GDI>

SendColor = No

Available

Release | _______
Patch |

Used By

GDILIB


SendOverlays

[PrtType:GDI]
SendOverlays

SendOverlays

This print window option lets the user send images compiled into printer language.

[PrtType:GDI]

SendOverlays = YesNoHide

Parameter | Description
boolean | Yes | No

Remarks

The GDI print driver does not support overlays. Leave this setting blank.

Example

<PrtType:GDI>

SendOverlays =

Available

Release | _______
Patch |


StreamBufferSize

[PrtType:GDI]
StreamBufferSize

StreamBufferSize

[PrtType:GDI]

StreamBufferSize = Edit

Parameter | Description
numeric value | Default value is: 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:GDI>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


SuppressDlg

[PrtType:GDI]
SuppressDlg

SuppressDlg

Set to Yes to suppress the Windows Print Driver window.

[PrtType:GDI]

SuppressDlg = YN

Parameter | Description
boolean | Yes | No

Remarks

If you set the SuppressDlg option to Yes and leave the GDIDevice blank, the system suppresses the Windows Print Driver window and automatically prints to the default printer.

Example

<PRTType:GDI>

SuppressDlg = No

Available

Release | _______
Patch |

Used By

GDILIB


TermFunc

[PrtType:GDI]
TermFunc

TermFunc

[PrtType:GDI]

TermFunc = Edit

Parameter | Description
Edit | Default is to have no entry at all.

Remarks

Enter GDITerm to tell the system to use this termination function, which performs clean up tasks and is located in the GDIW32.DLL file. This function is required when using the GDI print driver for batch printing.

Example

<PrtType:GDI>

Module = GDIW32

PrintFunc = GDIPrint

InitFunc = GDIInit

TermFunc = GDITerm

Available

Release | _______
Patch |

See Also

InitFunc , PrintToFile


Tray1

[PrtType:GDI]
Tray1

Tray1

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray1 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray2

[PrtType:GDI]
Tray2

Tray2

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray2 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray3

[PrtType:GDI]
Tray3

Tray3

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray3 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray4

[PrtType:GDI]
Tray4

Tray4

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray4 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray5

[PrtType:GDI]
Tray5

Tray5

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray5 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray6

[PrtType:GDI]
Tray6

Tray6

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray6 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray7

[PrtType:GDI]
Tray7

Tray7

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray7 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray8

[PrtType:GDI]
Tray8

Tray8

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray8 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray9

[PrtType:GDI]
Tray9

Tray9

Documaker supports up to nine paper trays but the GDI print driver currently supports the following four paper trays:

Tray 1 prints to "automatic" paper tray

Tray 2 prints to "lower" paper tray

Tray 3 prints to "manual" paper tray

Tray 4 prints to "envelope" paper tray

Trays 5 through 9 print to the "automatic" paper tray

[PrtType:GDI]

Tray9 = Edit

Remarks

You can override GDI tray commands by providing an alternate paper tray to use. Here are the default PrtType:GDI control group settings:

<PrtType:GDI>

Tray1=1

Tray2=2

Tray3=3

Tray4=4

Tray5=1

Tray6=1

Tray7=1

Tray8=1

Tray9=1

Available

Release | _______
Patch |

Used By

GENPRINT


PrtType:HTML

PrtType:
HTML

Remarks

You can create HTML files by simply printing to the new HTML print driver. The HTML print driver includes support for:

  • Boxes - solid and shaded colors only
  • Bar codes
  • Charts
  • Vectors - solid and shaded colors only
  • Logos - converted to JPG files by the driver
  • Lines - solid and shaded colors only. Dashed lines are supported but do not take the line characteristics as specified. The spacing and length of dashed lines are defaulted by the HTML 4 specification.
  • Shaded areas - solid and shaded colors only
  • Text areas
  • Text
  • Variable fields

Also, you can now run the GenData program in single step mode and create separate files for each transaction. Each transaction will have its own HTML file if you include INI options similar to these:

<PrintFormSet>

MultiFilePrint = Yes

LogFileType = XML

LogFile = d:\fap\mstrres\rpex1\data\jlog

<Printer>

PrtType = HTML

; Printers is for the GUI dropdown selection (uncomment many)...

<Printers>

PrtType = AFP

PrtType = PCL

PrtType = XER

PrtType = HTML

NOTE: To make sure the page looks the same to all users, only use fonts which all users have. Otherwise, fonts are substituted. The look of the printed HTML file depends on the settings in affect for the user's browser. For example, the following shows printed output when the page setup includes a header and footer with a top and bottom margin of 0.166".

PrtType:HTML Options

  • AddColorSheetLink
  • AddPropFonts
  • AllowInput
  • Barcode
  • Bitmap
  • BmSub
  • BmSubChar
  • Box
  • Chart
  • Class
  • CollapsePage
  • ColorSheet
  • CreateJPG
  • CreateScriptFile
  • Device
  • DirLinks
  • DownLoadFonts
  • DumpScript
  • EntryBackColor
  • EntryFontColor
  • Field
  • FieldFontFudge
  • FormName
  • HiddenFieldScript
  • HR
  • Hyperlink
  • IgnoreBPDelete
  • ImageExt
  • ImagePath
  • ImagePathCreate
  • IMG_Zindex
  • InitFunc
  • JavaScript
  • MinFieldHeight
  • Module
  • MonospaceFonts
  • MultiPage
  • Note
  • OnLoad
  • OverlayExt
  • PageBreaks
  • PageHeight
  • PageNumbers
  • PageOffset
  • PageWidth
  • PrePrintedPaper
  • PrintFunc
  • ProportionalFonts
  • ScriptPath
  • ScriptPathCreate
  • SendColor
  • SplitText
  • StreamBufferSize
  • StyleSheet
  • SuppressDAL
  • SuppressJPGCreate
  • SuppressScript
  • Table
  • TemplateFields
  • TermFunc
  • Text
  • TextMerge
  • VBScript
  • Vector


AddColorSheetLink

[PrtType:HTML]
AddColorSheetLink

[PrtType:HTML]

AddColorSheetLink = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

This setting enables HTML output to reference your color cascading style sheet (css) file.

Example

<PrtType:HTML>

AddColorSheetLink = No

Available

Release | _______
Patch |

See Also

ColorSheet


AddPropFonts

[PrtType:HTML]
AddPropFonts

[PrtType:HTML]

AddPropFonts = Edit

Parameter | Description
value | Default value is to leave empty.

Remarks

If set to Yes or if this setting is left blank, then the ProportionalFonts setting is used to add a list of proportionally spaced font names to use in case the original font is not available.

Example

<PrtType:HTML>

AddPropFonts =

Available

Release | _______
Patch |

Used By


AllowInput

[PrtType:HTML]
AllowInput

AllowInput

[PrtType:HTML]

AllowInput = YN

Parameter | Description
boolean | Enter Yes if you are running iPPS. Default value is: No

Remarks

Enter Yes if you want to allow data entry into variable fields. If you are producing HTML files for use when running iPPS or iDocumaker, then you should set this setting to Yes. The default is No.

Example

<PrtType:HTML>

AllowInput = No

Available

Release | 1.8
Patch |

Used By


Barcode

[PrtType:HTML]
Barcode

[PrtType:HTML]

Barcode = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Barcode = No

Available

Release | _______
Patch |

Used By


Bitmap

[PrtType:HTML]
Bitmap

[PrtType:HTML]

Bitmap = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Bitmap = No

Available

Release | _______
Patch |

Used By


Box

[PrtType:HTML]
Box

[PrtType:HTML]

Box = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Box = No

Available

Release | _______
Patch |

Used By


BmSub

[PrtType:HTML]
BmSub

BmSub

[PrtType:HTML]

BmSub = YN

Parameter | Description
Boolean | Yes | No Default value is: Yes

Remarks

The Java Script function calls are generated by using the name of the variable field. The fieldname can contain invalid characters. For example, FIELD #002 contains the # character. The function call generated is __FIELD_#002(this). This causes script errors.

Enter No if you do not want the system to substitute invalid characters with the character you specify in the BmSubChar option. The default is Yes.

This functionality was added to Release 10.2 P141 and Release 10.3 P36

Example

<PrtType:HTML>

BmSub = Yes

BmSubChar = '_'

Available

Release | 10.2
Patch | 141


BmSubChar

[PrtType:HTML]
BmSubChar

BmSubChar

[PrtType:HTML]

BmSubChar = Edit

Parameter | Description
Single Character | Default value is: '_'

Remarks

The Java Script function calls are generated by using the name of the variable field. The fieldname can contain invalid characters. For example, FIELD #002 contains the # character. The function call generated is __FIELD_#002(this). This causes script errors.

Enter the character you want the system to use to replace invalid characters. The default is an underscore ( _ ). See also BmSub .

Example

<PrtType:HTML>

BmSub = Yes

BmSubChar = '_'

Available

Release | 10.2
Patch | 141


Chart

[PrtType:HTML]
Chart

[PrtType:HTML]

Chart = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Chart = No

Available

Release | _______
Patch |

Used By


Class

[PrtType:HTML]
Class

Specifies the printer classification, such as AFP, HTML, PCL, XER, PST, etc.

[PrtType:HTML]

Class = Edit

Parameter

Description

class name

Valid class names include others:

  • AFP
  • HTML
  • PCL
  • XER
  • PST
  • GDI

Remarks

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PRTType:HTML>

Class = HTML

Available

Release | _______
Patch |

Used By


CollapsePage

[PrtType:HTML]
CollapsePage

CollapsePage

[PrtType:HTML]

CollapsePage = YN

Parameter | Description
boolean | Yes | No The default value is Yes.

Remarks

Use this option to eliminate white space between HTML pages.

Example

<PrtType:HTML>

CollapsePage = No

Available

Release | 1.8
Patch |


ColorSheet

[PrtType:HTML]
ColorSheet

ColorSheet

Specify the style sheet that contains the color information. The default is WSCOLOR.CSS.

[PrtType:HTML]

ColorSheet = Edit

Parameter | Description
value | Specify the style sheet that contains the color information. The default is WSCOLOR.CSS. The WSCOLOR.CSS file contains web safe colors. The IECOLOR.CSS file contains Internet Explorer colors.

Remarks

The WSCOLOR.CSS file contains web safe colors. The IECOLOR.CSS file contains Internet Explorer colors.

Example

<PrtType:HTML>

ColorSheet = iecolor.css

See Also

AddColorSheetLink

Available

Release | 1.8
Patch |


CreateJPG

[PrtType:HTML]
CreateJPG

[PrtType:HTML]

CreateJPG = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

If set to Yes or if this setting is left blank, then Documaker bitmaps will be converted into JPG files when the HTML output is produced. See also SuppressJPGCreate .

Example

<PrtType:HTML>

CreateJPG = No

Available

Release | _______
Patch |

Used By


CreateScriptFile

[PrtType:HTML]
CreateScriptFile

CreateScriptFile

[PrtType:HTML]

CreateScriptFile = YN

Parameter | Description
boolean | Yes | No The default is No.

Remarks

Set to "Yes" if the HTML driver is to generate script files.

Enter Yes is if you want the HTML driver to generate script files. The script files correspond to the name of the FAP. For example, if the Q1ADDR.FAP file contained either an inline script or a call to a function in an external script file, the generated script file is named Q1ADDR.JS.

The corresponding function for a function that occurred in an external DAL script file would be called. For example:

_q1addr_dal_1ST NAME ZIP(obj)

where the q1addr represents the name of the FAP file, _dal implies it was contained in an external script file, and _1ST NAME ZIP is the name of the field. If the DAL script is inline and not in an external file, the example would look like this:

_q1addr_1ST NAME ZIP(obj)

Example

<PrtType:HTML>

CreateScriptFile = Yes

Available

Release | 1.8
Patch |


Device

[PrtType:HTML]
Device

Device

[PrtType:HTML]

Device = Edit

Parameter | Description
value | Any file name

Remarks

This setting is ignored by the GenPrint program but is used when printing from GUI Documaker applications like DMStudio, Documaker Workstation, and legacy development tools such as the Image Editor.

Example

<PrtType:HTM>

Device = Sample.htm

Available

Release | 1.8
Patch |


DirLinks

[PrtType:HTML]
DirLinks

DirLinks

[PrtType:HTML]

DirLinks = No

Parameter | Description
boolean | Yes | No The default is: No

Remarks

Enter Yes to include Next and Prev navigation links on pages. The default is No.

Example

<PrtType:HTML>

DirLinks = Yes

Available

Release | 1.8
Patch |


DownLoadFonts

[PrtType:HTML]
DownLoadFonts

DownLoadFonts

Enter Yes to enable font style information to be written into the HTML file.

[PrtType:HTML]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default is No.

Remarks

It is recommended that this setting should be set to Yes in order to enable font style information to be written into the HTML file.

Example

<PrtType:HTML>

DownLoadFonts = Yes,Enabled

Available

Release | 1.8
Patch |


DumpScript

[PrtType:HTML]
DumpScript

DumpScript

[PrtType:HTML]

DumpScript = YN

Parameter | Description
boolean | Yes | No The default is Yes.

Remarks

If DumpScript is set to yes, it will allow the inline script to be written to the java script file as a comment in the js file. For example if the inline script for an effective date field existed it would be dumped to the js file as: function _samplefap_EFFDTE(obj);

{

/*HOLDDTE = DATEADD(@("EFFDTE"),,,,1); SETFLD ( HOLDDTE, "EXPDTE");*/

}

If DumpScript is no, then the inline script is not written out as a comment. It is handled as if it existed in an external file. The corresponding function would be as follows_samplefap_EFFDTE(obj);

{ /*alert( EFFDTED code goes here);*/ }

Example

<PrtType:HTML>

DumpScript = Yes

Available

Release | 1.8
Patch |


EntryBackColor

[PrtType:HTML]
EntryBackColor

[PrtType:HTML]

EntryBackColor = Edit

Parameter | Description
value | Default value is #B0E0E6.

Remarks

This is the background color for the data entry fields. This can be overridden in formatting script functions. The default is #B0E0E6. This example uses a legacy HTML color code which are in hexadecimal. You can also use the form of rgb(176,224,230) which uses decimal numbers.

Example

<PrtType:HTML>

EntryBackColor =

Available

Release | _______
Patch |

Used By


EntryFontColor

[PrtType:HTML]
EntryFontColor

[PrtType:HTML]

EntryFontColor = Edit

Parameter | Description
value | Default value is #FFD2D2.

Remarks

Enter the color for the font used in data entry fields. The default is #FFD2D2. This example uses a legacy HTML color code which are in hexadecimal. You can also use the form of rgb(255,210,210) which uses decimal numbers.

Example

<PrtType:HTML>

EntryFontColor =

Available

Release | _______
Patch |

Used By


Field

[PrtType:HTML]
Field

[PrtType:HTML]

Field = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Field = No

Available

Release | _______
Patch |

Used By


FieldFontFudge

[PrtType:HTML]
FieldFontFudge

[PrtType:HTML]

FieldFontFudge = Edit

Parameter | Description
value | Default value is 0.535.

Remarks

Use this option to increase or decrease the font size for the input fields. The default is 0.535. This option is necessary because browsers usually use fonts larger than the input fields, so the top or bottom of the text inside the input field is chopped off. When you use this option, the font size inside the input field is the font height times this value.

Example

<PrtType:HTML>

FieldFontFudge =

Available

Release | _______
Patch |

Used By


FormName

[PrtType:HTML]
FormName

[PrtType:HTML]

FormName = Edit

Parameter | Description
value | Default value is Form.

Remarks

FormName gives a name to the form. This is most useful in scripting, where you frequently need to refer to the form in order to refer to the element within the form.

Example

<PrtType:HTML>

FormName =

Available

Release | _______
Patch |

Used By


HiddenFieldScript

[PrtType:HTML]
HiddenFieldScript

HiddenFieldScript

[PrtType:HTML]

HiddenFieldScript = Edit

Parameter | Description
value | HiddenFieldScript = textMergeP(this); Hidden fields that have a length of one. This will allow a box to pop up so the user can input data into the form. Default is an empty value.

Remarks

Hidden fields that have a length of one. This option will allow a box to pop up so the user can input data into the form.

Example

<PrtType:HTML>

HiddenFieldScript = Yes

Available

Release | 1.8
Patch |


HR

[PrtType:HTML]
HR

HR

[PrtType:HTML]

HR = Edit

Parameter | Description
value | The default value is Size=2 Width=100% Color=Black

Remarks

(Header Rule) Displays a line between pages. You can configure the size, color and width. See example to see how to configure the rule.

Example

<PrtType:HTML>

HR = Size=2 Width=100% Color=Black

Available

Release | 1.8
Patch |


Hyperlink

[PrtType:HTML]
Hyperlink

[PrtType:HTML]

Hyperlink = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Hyperlink = No

Available

Release | _______
Patch |

Used By


IgnoreBPDelete

[PrtType:HTML]
IgnoreBPDelete

[PrtType:HTML]

IgnoreBPDelete = YN

Parameter | Description
boolean | Yes | No The default is No.

Remarks

IgnoreBPDelete - ignore boiler plate delete option. This option when set to No will cause the scope of a field to be set to 'Y' which is global, despite the scope being 'F' for the form. When set to 'Yes' this option will be ignored and the field scope remains at whatever it has initially been set to regardless of the state of the field tag delete option.

Example

<PrtType:HTML>

IgnoreBPDelete = Yes

Available

Release | 10.2
Patch | 128


ImageExt

[PrtType:HTML]
ImageExt

[PrtType:HTML]

ImageExt = Edit

Parameter | Description
value | default is .jpg

Remarks

Use this option to specify the extension to use for references to graphic files. The default is JPG. You will need to set this option to the correct value, if your bitmaps are converted into some other file format, such as GIF, PNG, or TIFF.

See also ImagePath and ImagePathCreate .

Example

<PrtType:HTML>

ImageExt =

Available

Release

Patch


ImagePath

[PrtType:HTML]
ImagePath

ImagePath

[PrtType:HTML]

ImagePath = Path

Parameter | Description
value | Enter the path for JPG files.

Remarks

Use this option to specify the location of the graphics files in your HTML output. Use a relative path, such as /images/, so the reference to the logo will be output in the HTML file with the attribute SRC=”images/GRAPH1BB.jpg”.

Be sure to use this option if you keep the graphics in a separate directory on the web server.

See also ImageExt and ImagePathCreate .

Example

<PrtType:HTML>

ImagePath = e:\rpex1

Available

Release | 1.8
Patch |


ImagePathCreate

[PrtType:HTML]
ImagePathCreate

[PrtType:HTML]

ImagePathCreate = Edit

Parameter | Description
value | The default is an empty value.

Remarks

Enter a path to indicate where you want the images to be physically created.

See also ImagePath and ImageExt .

Example

<PrtType:HTML>

ImagePathCreate =

Available

Release

Patch


IMG_Zindex

[PrtType:HTML]
IMG_Zindex

IMG_Zindex

Feature 1403 You can now use the Z-Index option to position JPG objects.

[PrtType:HTML]

IMG_Zindex = Edit

Parameter | Description
Value | The default is an empty value.

Remarks

The z-index indicates the stacking order of objects based on the order in which those objects appear in the HTML file. Higher values place objects closer to the front while lower values place them further to the back. Objects with the same value are stacked based on the order in which they appear in the HTML source.

For instance, a positive value positions an object above text that has no defined z-index. A negative value would place the object below the same text.

If you omit this option or leave it blank, the system will not layer objects.

Example

<PrtType:HTML>

IMG_ZIndex = 100

Available

Release | 10.2
Patch | 59


InitFunc

[PrtType:HTML]
InitFunc

[PrtType:HTML]

InitFunc = Edit

Parameter | Description
Edit | The default is an empty value.

Remarks

Enter HTMInit to tell the system to use this initialization function, which is located in the HTMW32.DLL file. This function may be required by some processes.

Example

<PrtType:HTML>

InitFunc = HTMInit

Available

Release | _______
Patch |

Used By


Inline

[PrtType:HTML]
InLine

[PrtType:HTML]

InLine = style sheet filename

Parameter | Description
value | The default is an empty value.

Remarks

Name of style sheet to inline within HTML output.

Do not use this setting - use InlineStyle instead.

Initially we were using "InLine" to inline style sheets.

Later, we added the ability to inline scripts using the ini option "ScriptFile".

The InLine setting name does not describe what type of file is being inlined.

The ScriptFile setting name does not describe it as being inlined.

So these two options are going to stay for backward compatability but moving forward there are two options now, "InLineStyle" and "InLineScript" to make it more clear as to what the option does.

Example

<PrtType:HTML>

InLine =


InLineScript

[PrtType:HTML]
InLineScript

[PrtType:HTML]

InLineScript = filename

Parameter | Description
value | The default is an empty value.

Remarks

Name of script to inline within HTML output.

This setting is meant to replace ScriptFile .

Initially we were using "InLine" to inline style sheets.

Later, we added the ability to inline scripts using the ini option "ScriptFile".

The InLine setting name does not describe what type of file is being inlined.

The ScriptFile setting name does not describe it as being inlined.

So these two options are going to stay for backward compatability but moving forward there are two options now, "InLineStyle" and "InLineScript" to make it more clear as to what the option does.

Example

<PrtType:HTML>

InLineScript =


InlineStyle

[PrtType:HTML]
InLineStyle

[PrtType:HTML]

InLineStyle = style sheet filename

Parameter | Description
value | The default is an empty value.

Remarks

Name of style sheet to inline within HTML output.

This setting is meant to replace Inline .

Initially we were using "InLine" to inline style sheets.

Later, we added the ability to inline scripts using the ini option "ScriptFile".

The InLine setting name does not describe what type of file is being inlined.

The ScriptFile setting name does not describe it as being inlined.

So these two options are going to stay for backward compatability but moving forward there are two options now, "InLineStyle" and "InLineScript" to make it more clear as to what the option does.

Example

<PrtType:HTML>

InLineStyle =


JavaScript

[PrtType:HTML]
JavaScript

JavaScript

[PrtType:HTML]

JavaScript = File

Parameter | Description
value | The default is an empty value.

Remarks

Specify any script files which contain functions you want the system to use.

Example

<PrtType:HTML>

JavaScript = format.js

JavaScript = help.js

JavaScript = data.js

Available

Release | 1.8
Patch |


MinFieldHeight

[PrtType:HTML]
MinFieldHeight

[PrtType:HTML]

MinFieldHeight = Edit

Parameter | Description
value | The default value is -1.

Remarks

This setting refers to the minimum field height (in FAP units) to use for a data entry field.

This setting is ignored if zero or a negative number.

This setting is ignored for "Yes or No" and "X or space" field types.

Example

<PrtType:HTML>

MinFieldHeight =

Available

Release | _______
Patch |

Used By


Module

[PrtType:HTML]
Module

Module

[PrtType:HTML]

Module = File

Parameter | Description
value | The default module name is HTMW32

Remarks

Enter the name of the print driver DLL file.

Example

<PrtType:HTML>

Module = HTMW32

Available

Release | 1.8
Patch |


MonospaceFonts

[PrtType:HTML]
MonospaceFonts

[PrtType:HTML]

MonospaceFonts = Edit

Parameter | Description
value | The default value is "letter gothic","courier" (Note the quotation marks are required for this comma-separated entry.)

Remarks

Enter a list of font face names to use for monospaced fonts separated by a comma. This list is used by the browser to select a font when the original font is not available.

Example

<PrtType:HTML>

MonospaceFonts = "letter gothic","courier"

Available

Release | 1.8
Patch |


MultiPage

[PrtType:HTML]
MultiPage

MultiPage

[PrtType:HTML]

MultiPage = YN

Parameter | Description
boolean | Yes | No Default is No.

Remarks

Enter Yes only when running the DMStudio or the legacy Image Editor and you want to print multiple page FAP files with each page as a separate HTML file. This feature is not supported when printing from Documaker RP and Documaker Workstation.

Example

<PrtType:HTML>

MultiPage = No

Available

Release | 1.8
Patch |


Note

[PrtType:HTML]
Note

[PrtType:HTML]

Note = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Note = No

Available

Release | _______
Patch |

Used By


OnLoad

[PrtType:HTML]
OnLoad

[PrtType:HTML]

OnLoad = Edit

Parameter | Description
value | The default is an empty value.

Remarks

This setting adds the ability to specify a function to execute when the browser loads the HTML file. The "onload" event that can have a function associated with it is configurable via the ini file as described below.

For example:

< PRTTYPE:HTM>

AllowInput = no

onLoad = adjustLocation();

InLineScript = c:\myscripts\overlap.js

InLineScript = c:\myscripts\data.js

The expected results are in the first "head element" of the HTML output.

<body NOWRAP=" " onLoad="adjustLocation();">

and to have the script that exists in overlap.js and data.js in the HTM file in the <script> section of the first head element. It should only occur in the HTML file once.

When the AllowInput option is set to "Yes" then the expected results are to have the overlap.js and data.js in the HTML file in the <script> section of the first head element. However the body tag will be as follows:

<body NOWRAP=" " onLoad="setFocus();">

Example

<PrtType:HTML>

OnLoad =

Available

Release

Patch


OverlayExt

[PrtType:HTML]
OverlayExt

[PrtType:HTML]

OverlayExt = Edit

Parameter | Description
value | default is .ovl

Remarks

The HTML print driver does not support overlays. Leave this setting blank.

Example

<PrtType:HTML>

OverlayExt =

Available

Release

Patch


PageBreaks

[PrtType:HTML]
PageBreaks

PageBreaks

[PrtType:HTML]

PageBreaks = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Forces a page break between pages during HTML print.

Example

<PrtType:HTML>

PageBreaks = Yes

Available

Release | 1.8
Patch |


PageHeight

[PrtType:HTML]
PageHeight

[PrtType:HTML]

PageHeight = Edit

Parameter | Description
value | The default value is 26400

Remarks

Page height in FAP units

Example

<PrtType:HTML>

PageHeight = 26400

Available

Release

Patch


PageOffset

[PrtType:HTML]
PageOffset

[PrtType:HTML]

PageOffset = Edit

Parameter | Description
value | The default value is 600

Remarks

The HTML print driver does not use this setting. Leave this setting blank.

Example

<PrtType:HTML>

PageOffset = 600

Available

Release

Patch


PageNumbers

[PrtType:HTML]
PageNumbers

PageNumbers

[PrtType:HTML]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default is No.

Remarks

The PageNumbers option activates the page numbering feature. Set this value to "Yes" to have page numbers printed in the "Page X of Y" format.

Example

<PrtType:HTML>

PageNumbers = Yes

Available

Release | 1.8
Patch |


PageWidth

[PrtType:HTML]
PageWidth

[PrtType:HTML]

PageWidth = Edit

Parameter | Description
value | The default value is 20400

Remarks

Page width in FAP units

Example

<PrtType:HTML>

PageWidth = 20400

Available

Release

Patch


PrePrintedPaper

[PrtType:HTML]
PrePrintedPaper

[PrtType:HTML]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Also determines the default for this check box--checked or unchecked. You must add this option to the INI file if you want the check box to appear on the Print window.

The default for this option includes the checkbox on the Print window and leaves it unchecked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:HTML>

PrePrintedPaper = No

Available

Release | _______
Patch |

Used By


ProportionalFonts

[PrtType:HTML]
ProportionalFonts

[PrtType:HTML]

ProportionalFonts = Edit

Parameter | Description
value | The default value is "arial","times" (Note the quotation marks are required for this comma-separated entry.)

Remarks

Enter a list of font face names to use for proportionally spaced fonts separated by a comma. This list is used by the browser to select a font when the original font is not available.

Example

<PrtType:HTML>

ProportionalFonts = "arial","times"

Available

Release | 1.8
Patch |


PrintFunc

[PrtType:HTML]
PrintFunc

PrintFunc

[PrtType:HTML]

PrintFunc = Edit

Parameter | Description
value | The default value is HTMPrint

Remarks

Enter the name of function within the print driver for print.

Example

<PrtType:HTML>

PrintFunc = HTMPrint

Available

Release | 1.8
Patch |


ScriptFile

[PrtType:HTML]
ScriptFile

[PrtType:HTML]

ScriptFile = filename

Parameter | Description
value | The default is an empty value.

Remarks

Name of script to inline within HTML output.

Do not use this setting - use InlineScript instead.

Initially we were using "InLine" to inline style sheets.

Later, we added the ability to inline scripts using the ini option "ScriptFile".

The InLine setting name does not describe what type of file is being inlined.

The ScriptFile setting name does not describe it as being inlined.

So these two options are going to stay for backward compatability but moving forward there are two options now, "InLineStyle" and "InLineScript" to make it more clear as to what the option does.

Example

<PrtType:HTML>

ScriptFile =


ScriptPath

[PrtType:HTML]
ScriptPath

ScriptPath

Feature 1423 The HTML print driver now adds references to generated script files.

[PrtType:HTML]

ScriptPath = Path

Parameter | Description
Path | Enter path to location of script (.js) files. The default is an empty value.

Remarks

This lets you assign a path that points to where the generated script files are created and gives you a path to use for the reference to the generated script files in the HTML file.

Use these INI options to set this up:

<PrtType:HTML>

ScriptPath = e:\rpex1\deflib

ScriptPathCreate = e:\scripts

For the ScriptPath option, enter the path to the script (.js) files generated by the HTML print driver. This is used for script files references in the HTML files.

For the ScriptPathCreate option, enter the path that points to where the driver creates the script files.

Example

<PrtType:HTML>

ScriptPath = e:\rpex1\deflib

Available

Release | 10.2
Patch | 83


ScriptPathCreate

[PrtType:HTML]
ScriptPathCreate

ScriptPathCreate

Feature 1423 The HTML print driver now adds references to generated script files.

[PrtType:HTML]

ScriptPathCreate = Path

Parameter | Description
Path | The HTML print driver now adds references to generated script files. The default is an empty value.

Remarks

This lets you assign a path that points to where the generated script files are created and gives you a path to use for the reference to the generated script files in the HTML file.

Use these INI options to set this up:

<PrtType:HTML>

ScriptPath = e:\rpex1\deflib

ScriptPathCreate = e:\scripts

For the ScriptPath option, enter the path to the script (.js) files generated by the HTML print driver. This is used for script files references in the HTML files.

For the ScriptPathCreate option, enter the path that points to where the driver creates the script files.

Example

<PrtType:HTML>

ScriptPathCreate = e:\scripts

Available

Release | 10.2
Patch | 83


SendColor

[PrtType:HTML]
SendColor

SendColor

[PrtType:HTML]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

Enter Yes,Enabled to print in color. The default is No.

Example

<PrtType:HTML>

SendColor = Yes,Enabled

Available

Release | 1.8
Patch |


SplitText

[PrtType:HTML]
SplitText

[PrtType:HTML]

SplitText = Edit

Parameter | Description
value | The default value is -1.

Remarks

-1 tells the system to split the text so a single word appears on each HTML line.

0 tells the system not to split text in the HTML file.

>0 tells the system to split the text into the number of characters specified.

SplitText is useful when the screen fonts used in the browser do not match the fonts used when the document was designed.

A value of 0 will produce the smallest HTML file but may not produce an HTML file with acceptable fidelity when the screen fonts used in the browser do not match the fonts used when the document was designed.

A value of -1 (default) will produce an HTML file where each word is separately positioned. This often produces a good compromise between screen fidelity and file size.

A value greater than 0 will break up the text into strings of the given length specified. A value of 1 will cause each letter to output separately and usually produces the best fidelity but results in the largest HTML file to be produced. A value of 2 would cause each two letters to be output at a time and would result in a somewhat smaller file. Higher values would continue to result in more characters output at a time while also producing smaller files with less fidelity.

Example

<PrtType:HTML>

SplitText =

Available

Release | _______
Patch |

Used By


SplitTextIDs

[PrtType:HTML]
SplitTextIDs

[PrtType:HTML]

SplitTextIDs = SplitTextValue,fontID,fontID,fontID,...

Parameter | Description
value | The default value is empty

Remarks

You can customize the SplitText values you want to use for different sets of font IDs.

Example

<PrtType:HTML>

SplitTextIDs = 0,12006,12008,12010

SplitTextIDs = -1,16006,16008,16010,16012

Available

Release | _______
Patch |

Used By


StreamBufferSize

[PrtType:HTML]
StreamBufferSize

StreamBufferSize

[PrtType:HTML]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:HTML>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


StyleSheet

[PrtType:HTML]
StyleSheet

[PrtType:HTML]

StyleSheet = File

Parameter | Description
file | Default value is an empty value.

Remarks

This setting allows you to specify a stylesheet to be named in the HTML output

Example

<PrtType:HTML>

StyleSheet =

Available

Release | _______
Patch |

Used By


SuppressDAL

[PrtType:HTML]
SuppressDAL

[PrtType:HTML]

SuppressDAL = YN

Parameter | Description
boolean | Yes | No Default value is No.

Remarks

This setting controls whether scripts are generated from variable fields containing DAL scripts

Example

<PrtType:HTML>

SuppressDAL = Yes

Available

Release | _______
Patch |

Used By


SuppressJPGCreate

[PrtType:HTML]
SuppressJPGCreate

[PrtType:HTML]

SuppressJPGCreate = YN

Parameter | Description
boolean | Yes | No Default value is No.

Remarks

If set to Yes, this setting will prevent JPG files from being created from bitmap, chart, and vector objects. The default is No, which allows JPG files to be created from bitmap, chart, and vector objects. See also CreateJPG .

Example

<PrtType:HTML>

SuppressJPGCreate = Yes

Available

Release | _______
Patch |

Used By


SuppressScript

[PrtType:HTML]
SuppressScript

[PrtType:HTML]

SuppressScript = YN

Parameter | Description
boolean | Yes | No Default value is No.

Remarks

This setting controls whether scripts for JavaScript or VBScript are created.

Example

<PrtType:HTML>

SuppressScript = Yes

Available

Release | _______
Patch |

Used By


Table

[PrtType:HTML]
Table

[PrtType:HTML]

Table = YN

Parameter | Description
boolean | Yes | No Default value is No.

Remarks

This setting causes the HTML driver to use HTML table commands to position objects instead of using HTML 4.0 absolute positioning commands.

Use of this setting is not recommended.

Example

<PrtType:HTML>

Table = Yes

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType:HTML]
TermFunc

[PrtType:HTML]

TermFunc = Edit

Parameter | Description
Edit | Default is to have no entry at all.

Remarks

Enter HTMTerm to tell the system to use this termination function, which performs clean up tasks and is located in the HTMW32.DLL file. This function may be required by some processes.

Example

<PrtType:HTML>

Module = HTMW32

TermFunc = HTMTerm

Available

Release | _______
Patch |

Used By


Text

[PrtType:HTML]
Text

[PrtType:HTML]

Text = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Text = No

Available

Release | _______
Patch |

Used By


TextMerge

[PrtType:HTML]
TextMerge

[PrtType:HTML]

TextMerge = YN

Parameter | Description
boolean | Yes | No Enter No if you want to omit these kind of objects from the HTML file. Default value is: Yes

Example

<PrtType:HTML>

TextMerge = No

Available

Release | _______
Patch |

Used By


VBScript

[PrtType:HTML]
VBScript

[PrtType:HTML]

VBScript = YN

Parameter | Description
boolean | Yes | No Default value is No.

Remarks

Specify any script files which contain functions you want the system to use.

Example

<PrtType:HTML>

VBScript =

Available

Release | _______
Patch |

Used By


Vector

[PrtType:HTML]
Vector

[PrtType:HTML]

Vector = YN

Parameter | Description
boolean | Yes | No Default value is: Yes

Remarks

Enter No if you want to omit these kind of objects from the HTML file.

Example

<PrtType:HTML>

Vector = No

Available

Release | _______
Patch |

Used By


PrtType:MDR

PrtType:
MDR

Remarks

In PPS (Documaker Workstation), you can have the system create recipient output for multiple print devices by using the Multiple Driver Router (MDR) feature.

For instance, the MDR feature lets you print one recipient’s output to one device and other recipient output to other devices. Here is an example:

This recipient | Gets a copy of the form set in this format
Home Office | PDF
Insured | PCL
Agent | PCL

Add this option to your FSISYS.INI file using a text editor:

< Printers >

PrtType = MDR

Add these settings to your FSIUSER.INI file using a text editor:

< PrtType:MDR >

Default = PCL

Device = lpt1

Module = MDRW32

PageNumbers = No

PrintFunc = MDRPrint

Recip:Home Office = PDF

In this example,

Insured and Agent both receive the standard PCL output (to be sent to a PCL printer) while the Home Office receives a PDF file. The name of the PDF file is defined in the PrtType:PDF control group.

Keep in mind:

  • Recip:Home Office=PDF is just an example of how to specify a driver for a recipient. You can have as many such options as you need. You only need to specify the recipients you want sent to a driver other than the default driver.
  • You specify Recip: and the standard name of the recipient, such as Insured or Home Office. This name must match the name in your master resource library (MRL). The other side of the equal sign is the name of the printer driver to route to, same as the group specified in your INI file. For this example above, the assumption is that there is a PrtType:PDF control group in the INI file.

PrtType:MDR Options

  • Class
  • Default
  • Device
  • DownLoadFonts
  • InitFunc
  • Module
  • OverlayExt
  • PageNumbers
  • PrePrintedPaper
  • PrintFunc
  • Recip:Home Office
  • StreamBufferSize
  • TermFunc


Class

[PrtType:MDR]
Class

Specifies the printer classification, such as AFP, MDR, PCL, XER, PST, etc.

[PrtType:MDR]

Class = Edit

Parameter

Description

class name

Valid class names include others:

  • AFP
  • MDR
  • PCL
  • XER
  • PST
  • GDI

Remarks

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PRTType:MDR>

Class = MDR

Available

Release | _______
Patch |

Used By


Default

[PrtType:MDR]
Default

Default

Default is used to specify the normal print driver to use if one is not declared specifically for a given recipient.

[PrtType:MDR]

Default = Edit

Parameter | Description
value | The default value of Default is PCL

Remarks

Feature 1290

Default is used to specify the normal print driver to use if one is not declared specifically for a given recipient--this is typically PCL.

Example

<PrtType:MDR>

Default =

Available

Release | 10.3
Patch |


DownLoadFonts

[PrtType:MDR]
DownLoadFonts

[PrtType:MDR]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default is No.

Remarks

The value Enabled results in the check box being enabled during Workstation and Image Editor print.

Example

<PrtType:MDR>

DownLoadFonts = Yes,Enabled

Available

Release | 1.8
Patch |


Device

[PrtType:MDR]
Device

Device

The "Device=" option is not required, but can be used to specify a default print device.

[PrtType:MDR]

Device = Edit

Parameter | Description
value | The default is an empty value.

Remarks

The "Device=" option is not required, but can be used to specify a default print device, such as a network printer, to use when not otherwise specified by another driver. If you leave it blank, MDR will ask you to pick a printer and then use that device name for any subsequent printer driver that does not specify a device name.

Example

<PrtType:MDR>

Device =

Available

Release | 10.3
Patch |


InitFunc

[PrtType:MDR]
InitFunc

[PrtType:MDR]

InitFunc = Edit

Parameter | Description
Edit | The default is MDRInit

Remarks

Enter MDRInit to tell the system to use this initialization function, which is located in the MDRW32.DLL file. This function may be required by some processes.

Example

<PrtType:MDR>

InitFunc = MDRInit

Available

Release | _______
Patch |

Used By


Module

[PrtType:MDR]
Module

Module

[PrtType:MDR]

Module = MDRW32

Parameter | Description
value | The default value is MDRW32

Example

<PrtType:MDR>

Module = MDRW32

Available

Release | 10.3
Patch |


OverlayExt

[PrtType:MDR]
OverlayExt

[PrtType:MDR]

OverlayExt = Edit

Parameter | Description
value | default is .ovl

Remarks

Example

<PrtType:MDR>

OverlayExt =

Available

Release

Patch


PageNumbers

[PrtType:MDR]
PageNumbers

PageNumbers

The "PageNumbers=" option is required if you want page numbering on or off.

[PrtType:MDR]

PageNumbers = YN

Parameter | Description
Boolean | Yes | No The "PageNumbers=" option is required if you want page numbering on or off. The default is Yes

Remarks

You may already specify this on the other printer drivers, but it will be necessary to specify it here so that it can carry through to the other drivers during printing.

The page numbers option is set externally by the main print routine before it ever calls a specific print driver, such as MDR.

The main print routine checks the INI group for the selected driver, and then goes by whatever it has set.

Therefore, when using MDR, to get page numbers to print on the subsequent print driver, like PCL or PDF, it does not really matter what is set in those other INI groups, it only matters what was set in the MDR group, and whatever it says applies to all the others.

So, if you want page numbers, you have to say:

<PrtType:MDR>

PageNumbers = Yes

And that will be the way it will work for any and all of the print drivers that get called after that, regardless of what they have set.

If you leave it off, they won't get page numbers.

Example

<PrtType:MDR>

PageNumbers = Yes/No

Available

Release | 10.3
Patch |


PrePrintedPaper

[PrtType:MDR]
PrePrintedPaper

[PrtType:MDR]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes

Example

<PrtType:MDR>

PrePrintedPaper = No

Available

Release | _______
Patch |

Used By


PrintFunc

[PrtType:MDR]
PrintFunc

PrintFunc

[PrtType:MDR]

PrintFunc = MDRPrint

Parameter | Description
value | The default value is MDRPrint

Example

<PrtType:MDR>

PrintFunc = MDRPrint

Available

Release | 10.3
Patch |


Recip:Home Office

[PrtType:MDR]
Recip:Home Office

Recip:Home Office

"Recip:Agent=PDF" is just an example of how to specify a driver for a recipient.

[PrtType:MDR]

Recip:Home Office =

Parameter | Description
value | You can have as many such options as you need, depending on how many of your recipients need to be switched to a different driver. You need to specify the recipients that are applicable to your configuration, but only for the ones that want to invoke a different driver. (The "Default=" option will handle the rest.) You specify "Recip:" and then the standard name of the recipient, such as "Insured" or "Home office", however you have chosen to specify the recipients in your MRL. The other side of the equal sign is the name of the printer driver to route to, same as the group specified in your INI file. The default print driver is PCL

Remarks

You can have as many such options as you need, depending on how many of your recipients need to be switched to a different driver. You need to specify the recipients that are applicable to your configuration, but only for the ones that want to invoke a different driver. (The "Default=" option will handle the rest.) You specify "Recip:" and then the standard name of the recipient, such as "Insured" or "Home office", however you have chosen to specify the recipients in your MRL. The other side of the equal sign is the name of the printer driver to route to, same as the group specified in your INI file. For the example above, the assumption is that there is a

<PrtType:PDF> INI group somewhere in the INI file.

One thing that will be different with this approach is that each recipient will now have its own "open/close" operation on the print device. That means that if specifying a device name, make sure to cycle a different device name each time a recipient is printed, or else the file will be overwriten each time and only the last recipient printed to that name will "take" or be saved. Below are two examples of how to name the PDF file.

<PrtType:PDF>

Device = ~DALRUN MYSCRIPT.DAL

In other words, you can use a DAL script to come up with a file name. Make sure your DAL script ends with a RETURN statement that returns the file name.

Another method that has been used with success is below:

<PrtType:PDF>

Device = F:\PDF\ ~KEYID ~DATE; [%I-%M %P];.PDF

Example

<PrtType:MDR>

Recip:Home office = PDF

Available

Release | 10.3
Patch |


StreamBufferSize

[PrtType:MDR]
StreamBufferSize

[PrtType:MDR]

StreamBufferSize = Edit

Parameter | Description
numeric value | Default value is: 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:MDR>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType:MDR]
TermFunc

[PrtType:MDR]

TermFunc = Edit

Parameter | Description
Edit | Default is to have no entry at all.

Remarks

Enter MDRTerm to tell the system to use this termination function, which performs clean up tasks and is located in the MDRW32.DLL file. This function may be required by some processes.

Example

<PrtType:HTML>

TermFunc = MDRTerm

Available

Release | _______
Patch |

Used By


PrtType:MPM

PrtType:
MPM

Remarks

Use the MPM print driver to produce output in multi-part MIME (MPM) format that contains both plain text and generic HTML contents. This lets the EPT print driver send MPM output as the email body and allow email clients that cannot read email in HTML format to alternatively receive a plain text version.

NOTE: The generic HTML format produced by the MPM print driver differs from the dynamic HTML produced by the HTML print driver. The generic HTML produced is based on HTML version 4.0 and uses more HTML elements such as TABLE, TR, TD, and so on, to lay out FAP objects in relative positions. FAP objects that can be printed in HTML format include lines, boxes, shaded areas, graphics, charts, bar codes, vectors, texts, and text areas.

Keep in mind...

  • During form design, do not overlap FAP objects. Overlapping can cause the misplacement of objects in the output. So if you see that a FAP object is missing or misplaced, the first thing to check is whether the object overlaps another object.

  • Make sure the appropriate fonts are included in the font cross reference (FXR) file and make sure the font file is in its designated location and you have properly set up the font library and path. If you see that text or a text area is missing, first check for overlapping objects and then make sure the font is listed in the FXR file and exists in the designated location.

  • Do not use a horizontal line as a text underline. The horizontal line tags include space which keeps the horizontal line from being associated with the text above it. Horizontal lines are generally used as separators, such as page or paragraph separators. If, however, you position the horizontal line close enough to the text, the system automatically changes it to an underline.

  • Avoid using vertical lines. These types of lines will not appear in the generic HTML format output. For example, do not use lines to compose a box or table. Instead, use box objects to compose a table.

  • Because charts, bar codes, and vectors are converted into bitmaps and assigned a name based on the object name you assigned in Name field under General Properties in Studio, make sure each object has a unique name. For instance, if a chart has an object name of CHART#0001, it will be converted into a bitmap named CHART#0001.JPG. If another chart has the same object name, it will overwrite the first chart.

  • When a vector is converted into a bitmap, its solid areas may overlap other objects or push other objects away.

PrtType:MPM Options

  • AddPropFonts
  • BitmapHTTP
  • BitmapPath
  • BitmapResolution
  • Class
  • CollapsePage
  • ContentDisposition
  • CreatePlainText
  • Debug
  • Device
  • DirLinks
  • DownLoadFonts
  • EmbedImages
  • Fonts
  • ForcePrintInColor
  • HR
  • InitFunc
  • Module
  • MonospaceFonts
  • OutputFunc
  • OutputMod
  • PageBorder
  • PageNumbers
  • PrintFunc
  • SendColor
  • TermFunc


AddPropFonts

[PrtType:MPM]
AddPropFonts

[PrtType:MPM]

AddPropFonts = Edit

Parameter | Description
value | Default value is "Arial","Times" (Note the quotation marks are required for this comma-separated entry.)

Remarks

Specify the type of proportional fonts you want to use.

The list of proportional fonts will be used by the browser when the original font is not available.

The example below tells the system to first use Arial and if that font is not found, use Times.

Example

<PrtType:MPM>

AddPropFonts = "Arial","Times"

Available

Release | 11.5
Patch |

Used By


BitmapHTTP

[PrtType:MPM]
BitmapHTTP

[PrtType:MPM]

BitmapHTTP = Edit

Parameter | Description
value | The default is an empty value

Remarks

Specify the HTTP address of the location specified in the BitmapPath option so the bitmaps can be referenced by the MPM output. If this location does not exist, the system uses the location you specified in the BitmapPath option.

Example

<PrtType:MPM>

BitmapHTTP =

Available

Release | 11.5
Patch |


BitmapPath

[PrtType:MPM]
BitmapPath

[PrtType:MPM]

BitmapPath = File

Parameter | Description
value | The default is an empty value

Remarks

Specify the location where the bitmaps are output. The default is the file path. You can enter either UNC or URL paths.

Example

<PrtType:MPM>

BitmapPath =

Available

Release | 11.5
Patch |


BitmapResolution

[PrtType:MPM]
BitmapResolution

[PrtType:MPM]

BitmapResolution = Edit

Parameter | Description
dots_per_inch | The default is 300

Remarks

This option only affects charts and bar codes. The MPM print driver converts these objects into bitmaps. Specify the resolution in pixels per inch.

Valid entries range from 30 to 600 pixels per inch. The default is 300.

Keep in mind that the higher the resolution and color depth, the longer it takes to create output.

For example, changing the resolution from 300 DPI to 150 DPI makes the output four times smaller. The larger the bitmap, the slower the processing.

Example

<PrtType:MPM>

BitmapResolution = 300

Available

Release | 11.5
Patch |

Used By


CharSet

[PrtType:MPM]
CharSet

[PrtType:MPM]

CharSet = utf-8

Parameter | Description
CharSet | The default value is UTF-8

Remarks

Set the HTML charset for the font map. Some common ones are:

charset=iso-8859-1 | Western Alphabet
charset=iso-8859-2 | Central European Alphabet (ISO)
charset=iso-8859-3 | Latin 3 Alphabet (ISO)
charset=iso-8859-4 | Baltic Alphabet (ISO)
charset=iso-8859-5 | Cyrillic Alphabet (ISO)
charset=iso-8859-7 | Greek Alphabet (ISO)
charset=koi8-r | Cyrillic Alphabet (KOI8-R)
charset=utf-8 | Universal Alphabet (UTF-8)
charset=windows-1250 | Central European Alphabet (Windows)
charset=windows-1251 | Cyrillic Alphabet (Windows)
charset=windows-1252 | Western Alphabet (Windows)
charset=windows-1253 | Greek Alphabet (Windows)
charset=windows-1254 | Turkish Alphabet
charset=windows-1257 | Baltic Alphabet (Windows)

Note: The option is now active for release 11.5 P03

Example

<PrtType:MPM>

CharSet = UTF-8

Available

Release | 11.5
Patch | P03

Used By


Class

[PrtType:MPM]
Class

Specifies the printer classification, such as AFP, MPM, PCL, XER, PST, etc.

[PrtType:MPM]

Class = Edit

Parameter

Description

class name

Valid class names include others:

  • AFP
  • MPM
  • PCL
  • XER
  • PST
  • GDI

Remarks

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PRTType:MPM>

Class = MPM

Available

Release | 11.5
Patch |

Used By


CollapsePage

[PrtType:MPM]
CollapsePage

[PrtType:MPM]

CollapsePage = YN

Parameter | Description
boolean | Yes | No The default value is Yes.

Remarks

Use this option to eliminate white space between HTML pages.

Example

<PRTType:MPM>

CollapsePage = No

Available

Release | 11.5
Patch |

Used By


ContentDisposition

[PrtType:MPM]
ContentDisposition

[PrtType:MPM]

ContentDisposition = Inline

Parameter

Description

ContentDisposition

Choice of:

  • inline
  • attachment

The default value is inline.

Remarks

Content-Disposition is an optional header field in MIME. In its absence, the mail user agent (MUA) may use whatever presentation method it seems suitable.

Inline Disposition Type

Inline images are displayed automatically upon display of the message and are presented in the order in which they occur within the multi-part (MIME) messages.

Attachment Disposition Type

Attachment images are separate from the main body of the mail message, and that their display should not be automatic, but contingent upon some further action of the user. The MUA might instead present the user of a bitmap terminal with an iconic representation of the attachments, or, on character terminals, with a list of attachments from which the user could select for viewing or storage.

Note: The option is now active for release 11.5 P03 and is set when the option EmbedImages is set.

Example

<PrtType:MPM>

ContentDisposition = attachment

Available

Release | 11.5
Patch | P03

Used By


CreatePlainText

[PrtType:MPM]
CreatePlainText

[PrtType:MPM]

CreatePlainText = YN

Parameter | Description
boolean | Yes | No The default value is No.

Remarks

Enter Yes to produce multipart MIME output containing both HTML and plain text.

The default is No, which produces only HTML.

Example

<PrtType:MPM>

CreatePlainText = No

Available

Release | 11.5
Patch |

Used By


Debug

[PrtType:MPM]
Debug

[PrtType:MPM]

Debug = YN

Parameter | Description
boolean | Yes | No The default value is No.

Remarks

Enter Yes to tell the system to write error or warning information into a trace file for debugging purposes.

The default is No.

Example

<PrtType:MPM>

Debug = No

Available

Release | 11.5
Patch |

Used By


Device

[PrtType:MPM]
Device

[PrtType:MPM]

Device = Edit

Parameter | Description
value | File or print device name. The default is blank.

Remarks

The name of the file or device (LPT1) where the MPM print stream should be written. The "Device=" option is not required, but can be used to specify a default print device, such as a network printer, to use when not otherwise specified by another driver. If you leave it blank, MPM will ask you to pick a printer.

This setting is ignored by the GenPrint program but is used when printing from GUI Documaker applications like DMStudio, Documaker Workstation, and legacy development tools such as the Image Editor.

Example

<PrtType:MPM>

Device = .\data\sample.mht

Available

Release | 11.5
Patch |


DirLinks

[PrtType:MPM]
DirLinks

[PrtType:MPM]

DirLinks = No

Parameter | Description
boolean | Yes | No The default is: Yes

Remarks

Enter Yes to include Next and Prev navigation links on pages.

Note: The default option was changed to 'yes' starting release 11.5 P03

Example

<PrtType:MPM>

DirLinks = Yes

Available

Release | 11.5
Patch | P03


DownLoadFonts

[PrtType:MPM]
DownLoadFonts

[PrtType:MPM]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No The default is No

Remarks

The value Enabled results in the check box being enabled during Workstation and Image Editor print.

Example

<PrtType:MPM>

DownLoadFonts = Yes,Enabled

Available

Release | 11.5
Patch |


EmbedImages

[PrtType:MPM]
EmbedImages

[PrtType:MPM]

EmbedImages = YesNo

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

Images are now embedded in MIME mail message by default. You can over-ride this behavior by setting the option to No (or False) to use attachments. Embedded images produce larger file sizes however, the content is contained within the one file that is emailed and external files are not left on your server.

Note: The default for this option changed to 'yes' with release 11.5 P03

Example

<PrtType:MPM>

EmbedImages = Yes

Available

Release | 11.5
Patch | P03


Fonts

[PrtType:MPM]
Fonts

[PrtType:MPM]

Fonts = Edit

Parameter | Description
comma separated list | List of fonts. Default is TTF,PS,PCL,AFP,XMC

Remarks

This option only affects charts and bar codes which contain text. The MPM print driver converts these objects into bitmaps. Use this option to specify the fonts you intend to use, in order.

For example, if you set the Fonts option to PCL,TTF, the system first locates the PCL font. If the PCL font does not exist, it finds the TTF font.

The default font order is: PCL,AFP,XER,TTF,PS.

Example

<PrtType:MPM>

Fonts = TTF,PS,PCL,AFP,XMC

Available

Release | 11.5
Patch |

Used By


ForcePrintInColor

[PrtType:MPM]
ForcePrintInColor

[PrtType:MPM]

ForcePrintInColor = YN

Parameter | Description
boolean | Yes | No The default value is Yes.

Remarks

This setting will force objects (text, lines, bitmaps, etc.) to print in color even though the “Print in Color” setting is not set on that object.

Note: The default for this option changed to 'yes' with release 11.5 P03

Example

<PrtType:MPM>

ForcePrintInColor = No

Available

Release | 11.5
Patch | P03

Used By


HR

[PrtType:MPM]
HR

[PrtType:MPM]

HR = Edit

Parameter | Description
value | The default value is size=2 color=#999999 width=100% style=dashed"

Remarks

(Header Rule) Displays a line between pages. You can configure the size, color and width. See example to see how to configure the rule.

Note: The default option was changed from empty starting release 11.5 P03

Example

<PrtType:MPM>

HR = Size=2 Width=100% Color=Black

Available

Release | 11.5
Patch |


InitFunc

[PrtType:MPM]
InitFunc

[PrtType:MPM]

InitFunc = Edit

Parameter | Description
Edit | The default is MPMInit

Remarks

Enter MPMInit to tell the system to use this initialization function, which is located in the MPMW32.DLL file. This function may be required by some processes.

Example

<PrtType:MPM>

InitFunc = MPMInit

Available

Release | 11.5
Patch |

Used By


Module

[PrtType:MPM]
Module

[PrtType:MDR]

Module = MPMW32

Parameter | Description
value | The default value is MPMW32

Example

<PrtType:MPM>

Module = MPMW32

Available

Release | 11.5
Patch |


MonospaceFonts

[PrtType:MPM]
MonospaceFonts

[PrtType:MPM]

MonospaceFonts = Edit

Parameter | Description
value | The default value is "Letter Gothic","Courier" (Note the quotation marks are required for this comma-separated entry.)

Remarks

Enter a list of font face names to use for monospaced fonts separated by a comma.

The list of monspaced fonts will be used by the browser when the original font is not available.

The example below tells the system to first use Letter Gothic and if that font is not found, use Courier.

Example

<PrtType:MPM>

MonospaceFonts = "Letter Gothic","Courier"

Available

Release | 11.5
Patch |


OutputFunc

[PrtType:MPM]
OutputFunc

[PrtType:MPM]

OutputFunc = Edit

Parameter | Description
value | The default is PRTStdOutputFunc

Remarks

Leave this setting blank to accept the default value.

Example

<PrtType:MPM>

OutputFunc = PRTStdOutputFunc

Available

Release | 11.5
Patch |

Used By


OutputMod

[PrtType:MPM]
OutputMod

[PrtType:MPM]

OutputMod = Edit

Parameter | Description
value | Module name; the default is PRTW32

Remarks

Leave this setting blank to accept the default value.

Example

<PrtType:MPM>

OutputMod = PRTW32

Available

Release | 11.5
Patch |

Used By


PageBorder

[PrtType:MPM]
PageBorder

[PrtType:MPM]

PageBorder = YN

Parameter | Description
boolean | Yes | No The default value is Yes.

Remarks

Enter Yes to draw a border around the page. The default is No.

Note: The default option was changed to 'yes' starting release 11.5 P03

Example

<PrtType:MPM>

PageBorder = No

Available

Release | 11.5
Patch | P03

Used By


PageNumbers

[PrtType:MPM]
PageNumbers

[PrtType:MPM]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default is Yes.

Remarks

The PageNumbers option activates the page numbering feature. Set this value to "Yes" to have page numbers printed in the "Page X of Y" format.

Example

<PrtType:MPM>

PageNumbers = Yes

Available

Release | 11.5
Patch |


PrintFunc

[PrtType:MPM]
PrintFunc

[PrtType:MPM]

PrintFunc = MPMPrint

Parameter | Description
value | The default value is MPMPrint

Remarks

Enter the name of function within the print driver for print.

Example

<PrtType:MPM>

PrintFunc = MPMPrint

Available

Release | 11.5
Patch |


SendColor

[PrtType:MPM]
SendColor

[PrtType:MPM]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled.

Remarks

Enter Yes,Enabled to print in color. The default is No.

Example

<PrtType:MPM>

SendColor = Yes,Enabled

Available

Release | 11.5
Patch |

Used By


TermFunc

[PrtType:MPM]
TermFunc

[PrtType:MPM]

TermFunc = Edit

Parameter | Description
Edit | The default is MPMTerm

Remarks

Enter MPMTerm to tell the system to use this termination function, which performs clean up tasks and is located in the MPMW32.DLL file. This function may be required by some processes.

Example

<PrtType:MPM>

TermFunc = MPMTerm

Available

Release | 11.5
Patch |

Used By


PrtType:PCL

PrtType:
PCL

Remarks

Hewlett-Packard created the Printer Control Language (PCL) to provide a way for application programs to control a range of printer features across a wide array of printing devices. The PCL language has evolved over time.For the most part, system-produced PCL output will run on any printer that supports PCL 5. To support color printing,the printer must support PCL 5C, which contains color extensions. To support more than two paper trays, the printer must support PCL 5E.

PCL INI OPTIONS

You must define the necessary printer options for the GenPrint program to produce PCL output. These options specify PCL output and are located in a PrtType:xxx control group, such as PrtType:PCL. Common PCL printer options are shown below, with default values in bold:

PrtType:PCL Options

  • AdjLeftMargin
  • Class
  • Compression
  • DefaultTray
  • Device
  • DocuSaveScript
  • DownLoadFonts
  • FitToWidth
  • GDIDevice
  • HighlightBlackCmd
  • HighlightColor
  • HighlightColorCmd
  • HighlightInitCmd
  • InitFunc
  • Module
  • MultipleCopies
  • OutputBin
  • OutputMod
  • OverlayExt
  • OverlayPath
  • PageNumbers
  • PaperSizeMatching
  • PJLCommentOn
  • PJLCommentScript
  • PrePrintedPaper
  • PrintFunc
  • PrintViewOnly
  • Resolution
  • SelectRecipients
  • SendColor
  • SendOverlays
  • StapleBin
  • StreamBufferSize
  • SuppressDlg
  • TemplateFields
  • TermFunc
  • TEXTCommentOn
  • TEXTScript
  • TRAY1
  • Tray2
  • Tray3
  • Tray4
  • Tray5
  • Tray6
  • Tray7
  • Tray8
  • Tray9
  • Watermark


AdjLeftMargin

[PrtType:PCL]
AdjLeftMargin

AdjLeftMargin

[PrtType:PCL]

AdjLeftMargin = YN

Parameter | Description
boolean | Yes | No Yes is the default.

Remarks

Automatically adjusts the left margin to compensate for the 1/4-inch left margin added by PCL printers.

Yes = Automatically adjust the left margin. Forms print exactly as they appear on screen (default).

No = Do not adjust the left margin. Forms may not print correctly on PCL printers after performing a retrieve function.

Example

<PrtType:PCL>

AdjLeftMargin = No

Available

Release | _______
Patch |

Used By

PCLLIB


Class

[PrtType:PCL]
Class

Class

[PrtType:PCL]

Class = List

Parameter

Description

class name

Values can be

  • AFP
  • PCL
  • XER
  • PST
  • GDI

PCL is the default value.

Remarks

Specifies the printer classification, such as AFP, PCL, XER, PST, or GDI. Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

If you omit this option, the system defaults to the first three letters from the Module option.

Example

<PrtType:PCL>

Class = PCL

Available

Release | _______
Patch |

Used By

PCLLIB


Compression

[PrtType:PCL]
Compression

[PrtType:PCL]

Compression = YN

Parameter | Description
boolean | Yes | No The default value is Yes.

Remarks

The PCL print driver also supports bitmap compression. To disable bitmap compression, add the following INI option to the PCL printer control group:

< PrtType:PCL >

Compression = No

Example

<PrtType:PCL>

Compression = No

Available

Release | _______
Patch |

Used By


DefaultTray

[PrtType:PCL]
DefaultTray

[PrtType:PCL]

DefaultTray = Edit

Parameter | Description
value | The default is 1.

Remarks

Use this setting to select a specific paper tray for pages specified as using the Default Tray.

Example

<PrtType:PCL>

DefaultTray = 1

Available

Release | _______
Patch |

Used By

PCLLIB


Device

[PrtType:PCL]
Device

Device

[PrtType:PCL]

Device = Edit

Parameter | Description
value | The default is blank.

Remarks

The name of the file or device (LPT1) where the PCL print stream should be written. The "Device=" option is not required, but can be used to specify a default print device, such as a network printer, to use when not otherwise specified by another driver. If you leave it blank, PCL will ask you to select a printer.

Example

<PrtType:PCL>

Device = filename

Available

Release | _______
Patch |

Used By

PCLLIB


DocuSaveScript

[PrtType:PCL]
DocuSaveScript

[PrtType:PCL]

DocuSaveScript = File

Parameter | Description
value | The default is blank.

Remarks

Docusave has support for archiving PCL 5 print streams.

You must include comment records in the print streams to index the archive. You can use a DAL script to add comment records into the print stream. Use the DocusaveScript option in the PrtType:PCL control group to have the system execute a DAL script when Docusave comments can be added to the print stream.

To add Docusave comments to an PCL print stream, add the DocusaveScript option and the name of a DAL script to execute. The DAL script should call the AddDocusaveComment function to add a string as a Docusave comment record.

Here is an example:

< PrtType:PCL >

DocusaveScript = DOCUSAVE.DAL

Here is an example of what the DOCUSAVE.DAL file might look like:

* Add DocuSave Comment - use default: APPIDX record!

COMMENT = AppIdxRec()

PRINT_IT(COMMENT)

ADDDOCUSAVECOMMENT(COMMENT)

RETURN('FINISHED!')

Below are some of the DAL functions you can use to create archive keys to use with Docusave.

Function | Description
AddDocusaveComment | Adds a Docusave comment string to the print stream
AddComent | Adds a comment string to the print stream
AppIdxRec | Gets an archive record based on APPIDX.DFD and Trigger2Archive INI settings
HaveGVM | Verifies if a GVM variable exists
SetGVM | Updates the contents of a GVM variable
GVM | Gets the contents of a GVM variable
MajorVersion | Gets the system’s major version number
MinorVersion | Gets the system’s minor version number
PrinterClass | Gets the type of print being produced
PrinterGroup | Gets the name of the print group being used
Print_It | Debug tool to print a string to the console

Example

<PrtType:PCL>

DocuSaveScript =

Available

Release | 10.2
Patch |


DownLoadFonts

[PrtType:PCL]
DownLoadFonts

DownLoadFonts

[PrtType:PCL]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes,Enabled

Remarks

Set to Yes to enable downloading of PCL fonts.

For Genprint:

When the system attempts to download fonts, here is what happens:

The system will find the FXR file (generally in the defib directory), then attempt to find the fonts. The system first looks for the fonts in the INI file Fontlib directory. If you do not define the fontlib option, the system will then look in the INI file deflib directory for the fonts.

Tip: You must define either or both the Fontlib and Deflib options with valid paths in the INI file; otherwise, the system will return an error DM12041.

Example

<PrtType:PCL>

DownLoadFonts = No,Enabled

Available

Release | _______
Patch |

Used By

AFEMAIN, GENPRINT


FitToWidth

[PrtType:PCL]
FitToWidth

FitToWidth

[PrtType:PCL]

FitToWidth = YesNoHide

Parameter | Description
boolean | Yes | No The default is Yes,Enabled

Remarks

Not supported by either PCL print driver.

Example

<PrtType:PCL>

FitToWidth = No,Hidden

Available

Release | _______
Patch |


GDIDevice

[PrtType:PCL]
GDIDevice

GDIDevice

[PrtType:PCL]

GDIDevice = Edit

Parameter | Description
value | The GDI pass-through alternate PCL print method now lets you suppress the Windows Printer Selection window. Default is blank.

Remarks

The GDI pass-through alternate PCL print method now lets you suppress the Windows Printer Selection window.

To turn on this feature, include these options in your FSISYS.INI or FSIUSER.INI file:

<PrtType:PCL>

SuppressDlg = Yes/No

GDIDevice = PrinterName

where PrinterName is the name assigned to a printer accessible through your computer. Set the SuppressDlg option to Yes to prevent the Printer window from appearing.

Example

<PrtType:PCL>

GDIDevice = PrinterName

Available

Release | 10.1
Patch |


HighlightBlackCmd

[PrtType:PCL]
HighlightBlackCmd

HighlightBlackCmd

[PrtType:PCL]

HighlightBlackCmd = Edit

Parameter | Description
value | Default is "~*v7S" (without the quotation marks).

Remarks

You can optionally use these INI options to specify the PCL color commands to use for printing the black colors.

The default value is shown here:

<PrtType:PCL>

HighlightBlackCmd = ~*v7S

Note that the tilde (~) is used in place of the PCL escape character (hexadecimal 1B) and that the number used in the command corresponds to the color indexes, such as 7=Black (see also HighlightColor ).

To use a different highlight color, you must include the HighlightColorCmd option.

To use a different black color, you must specify the HighlightBlackCmd option.

Example

<PrtType:PCL>

HighlightBlackCmd = ~*v7S

Available

Release | 10.2
Patch |


HighlightColor

[PrtType:PCL]
HighlightColor

HighlightColor

1132 Using PCL Simple Color Mode Support

[PrtType:PCL]

HighlightColor = YN

Parameter | Description
value | Yes | No Default is No

Remarks

The PCL print driver now supports the PCL simple color mode in addition to full RGB color support.

PCL simple color mode uses a 3-plane CMY palette. The 3-plane CMY palette contains these indexed colors:

0 - White

1 - Cyan

2 - Magenta

3 - Blue

4 - Yellow

5 - Green

6 - Red

7 - Black

To specify highlight color printing for PCL, include these INI options in your PCL printer group:

<PrtType:PCL>

SendColor = Yes

HighlightColor = Yes

Marking objects to print in color: For any object, such as lines, boxes, or text, you must select the Print in Color option on the Color Selection window if you want the object to print in a color other than black.

Keep in mind:

If the object is black and is not marked as Print in color, the system will print the object using a black color index.

If the object has a color other than black and is marked as Print in color, the system will print it using a highlight color index.

Charts print in black, although you can print chart labels in the highlight color.

Example

<PrtType:PCL>

HighlightColor = Yes

Available

Release | 10.2
Patch |


HighlightColorCmd

[PrtType:PCL]
HighlightColorCmd

HighlightColorCmd

[PrtType:PCL]

HighlightColorCmd = Edit

Parameter | Description
value | The default value is "~*v3S" (not including the quote marks)

Remarks

You can optionally use these INI options to specify the PCL color commands to use for printing the highlight colors.

The default value is shown here:

<PrtType:PCL>

HighlightColorCmd = ~*v3S

Note that the tilde (~) is used in place of the PCL escape character (hexadecimal 1B) and that the number used in the command corresponds to the color indexes, such as 3=Blue and 7=Black (see also HighlightColor .)

To use a different highlight color, you must include the HighlightColorCmd option.

To use a different black color, you must specify the HighlightBlackCmd option.

Example

<PrtType:PCL>

HighlightColorCmd = ~*v3S

Available

Release | 10.2
Patch |


HighlightInitCmd

[PrtType:PCL]
HighlightInitCmd

HighlightInitCmd

[PrtType:PCL]

HighlightInitCmd = Edit

Parameter | Description
value | Default is "~*r-3U" (not including the quote marks)

Remarks

Note that the tilde (~) is used in place of the PCL escape character (hexadecimal 1B).

Example

<PrtType:PCL>

HighlightInitCmd = ~*r-3U

Available

Release | _______
Patch |


InitFunc

[PrtType:PCL]
InitFunc

InitFunc

[PrtType:PCL]

InitFunc = Edit

Parameter | Description
Edit | The default is PCLInit

Remarks

The InitFunc option names the printer function called at the initial printing. Do not change this value.

Example

<PrtType:PCL>

InitFunc = PCLInit

Available

Release | _______
Patch |


Module

[PrtType:PCL]
Module

Module

[PrtType:PCL]

Module = Edit

Parameter | Description
Edit | The default is PCLW32

Remarks

The name of the program module which contains the system's PCL print driver. See also the discussion of the Class option.

Example

<PrtType:PCL>

Module = PCLW32

Available

Release | _______
Patch |

Used By

PCLLIB


MultipleCopies

[PrtType:PCL]
MultipleCopies

MultipleCopies

[PrtType:PCL]

MultipleCopies = YN

Parameter | Description
boolean | Yes | No The default is Yes.

Remarks

This print window option lets the user print multiple copies of the document set.

The INI value shown in this option's heading represents the recommended default value for this Print window check box.

Example

<PrtType:PCL>

MultipleCopies = No

Available

Release | _______
Patch |


OutputBin

[PrtType:PCL]
OutputBin

OutputBin

[PrtType:PCL]

OutputBin = Edit

Parameter | Description
value | The default is blank.

Remarks

Enter the printer escape sequence to select the normal output bin (for non-stapled forms) if nonstapled forms are being sent to the wrong output bin.

Example

<PrtType:PCL>

OutputBin = ~&l1G

Available

Release | _______
Patch |

Used By

PCLLIB


OutputMod

[PrtType:PCL]
OutputMod

OutputMod

[PrtType:PCL]

OutputMod = Edit

Parameter | Description
LimitList | The default value is PCLW32

Remarks

The output module.

Example

<PrtType:PCL>

OutputMod = PCLW32

Available

Release | _______
Patch |


OverlayExt

[PrtType:PCL]
OverlayExt

OverlayExt

[PrtType:PCL]

OverlayExt = Edit

Parameter | Description
extension | a file extension (the default is .ovl)

Remarks

The file extension of the PCL overlays.

Example

<PrtType:PCL>

OverlayExt = .ovl

Available

Release | _______
Patch |

Used By

PCLLIB


OverlayPath

[PrtType:PCL]
OverlayPath

OverlayPath

[PrtType:PCL]

OverlayPath = Path

Parameter | Description
Path | Set to the directory containing the PCL overlays for each FAP file. The default is the FormLib option of the MasterResource control group. The default is blank which will use the MasterResource value.

Remarks

Set to the directory containing the PCL overlays for each FAP file.

The default is the FormLib option of the MasterResource control group.

<MasterResource>

FormLib = <CONFIG:Batch Processing>

FormLib = <CONFIG:Batch Processing>

FormLib = ./forms/

Example

<PrtType:PCL>

OverlayPath =

Available

Release | _______
Patch |

Used By

PCLLIB


PageNumbers

[PrtType:PCL]
PageNumbers

PageNumbers

[PrtType:PCL]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

The PageNumbers option activates the page numbering feature. Set this value to "Yes" to enable form or form set page numbering printed in the "Page X of Y" format.

Example

<PrtType:PCL>

PageNumbers = No

Available

Release | _______
Patch |

Used By

PCLLIB


PaperSizeMatching

[PrtType:PCL]
PaperSizeMatching

[PrtType:PCL]

PaperSizeMatching = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

This table outlines the various paper sizes supported by the different print drivers. The table includes information for the PDF, RTF, HTML, Metacode, PCL 5, PCL 6, GDI, PostScript, and AFP print drivers. The PDF, RTF, HTML, and Metacode print drivers support all paper sizes.

 | Driver |  |  |  |  |
Paper Size | PDF | PXL1 | PCL2 | GDI2 | PST3 | AFP4
US Letter | X | X | X | X | X | X
US Legal | X | X | X | X | X | X
US Executive | X | X | X | X | X | X
US Ledger | X | X | X | X | X | X
US Tabloid | X | Y | US Letter | X | X | X
US Statement | X | JIS B5 | US Executive | X | X | X
US Folio | X | US Legal | US Legal | X | X | X
US Fanfold | X | US Ledger | US Ledger | X | X | X
ISO 4A | X | Y | US Letter | US Letter | US Letter | C
ISO 2A | X | Y | US Letter | US Letter | US Letter | C
ISO A0 | X | Y | US Letter | US Letter | X | C
ISO A1 | X | Y | US Letter | US Letter | X | C
ISO A2 | X | Y | US Letter | US Letter | X | C
ISO A3 | X | X | X | X | X | X
ISO A4 | X | X | X | X | X | X
ISO A5 | X | X | ISO C5 | X | X | X
ISO A6 | X | X | ISO C5 | X | X | X
ISO A7 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO A8 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO A9 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO A10 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO 4B | X | Y | US Letter | US Letter | US Letter | C
ISO 2B | X | Y | US Letter | US Letter | US Letter | C
ISO B0 | X | Y | US Letter | US Letter | X | C
ISO B1 | X | Y | US Letter | US Letter | X | C
ISO B2 | X | Y | US Letter | US Letter | X | C
ISO B3 | X | Y | US Letter | US Letter | X | C
ISO B4 | X | JIS B4 | US Ledger | X | X | X
ISO B5 | X | JIS B5 | X | JIS B5 | X | X
ISO B6 | X | JIS B6 | ISO C5 | JIS B6 | X | X
ISO B7 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO B8 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO B9 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO B10 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO C0 | X | Y | US Letter | US Letter | X | C
ISO C1 | X | Y | US Letter | US Letter | X | C
ISO C2 | X | Y | US Letter | US Letter | X | C
ISO C3 | X | Y | US Letter | X | X | C
ISO C4 | X | JIS B4 | US Ledger | X | X | C
ISO C5 | X | X | X | X | X | C
ISO C6 | X | JIS B6 | ISO C5 | X | X | C
ISO C7 | X | ISO A6 | ISO C5 | ISO A6 | X | C
ISO C8 | X | ISO A6 | ISO C5 | ISO A6 | US Letter | C
ISO C9 | X | ISO A6 | ISO C5 | ISO A6 | US Letter | C
ISO C10 | X | ISO A6 | ISO C5 | ISO A6 | US Letter | C
ISO DL | X | X | X | X | X | X
JIS B0 | X | Y | US Letter | US Letter | X | C
JIS B1 | X | Y | US Letter | US Letter | X | C
JIS B2 | X | Y | US Letter | US Letter | X | C
JIS B3 | X | Y | US Letter | US Letter | X | C
JIS B4 | X | X | US Ledger | US Fanfold | X | X
JIS B5 | X | X | US Executive | X | X | X
JIS B6 | X | X | ISO C5 | X | X | X
JIS B7 | X | ISO A6 | ISO C5 | ISO A6 | X | C
JIS B8 | X | ISO A6 | ISO C5 | ISO A6 | X | C
JIS B9 | X | ISO A6 | ISO C5 | ISO A6 | X | C
JIS B10 | X | ISO A6 | ISO C5 | ISO A6 | X | C

Sizes marked with an 'X' are fully supported by the corresponding driver

Sizes marked with a 'Y' are supported by sending the paper dimensions in millimeters to the printer

Sizes referring to another size substitute the referred size when Paper Size Matching is turned on. If paper size matching is not turned on, the behavior depends upon the specific driver

1. When paper size matching is not turned on, the PCL 6 (PXL) driver sends the paper dimensions in millimeters

2. When paper size matching is not turned on, these drivers substitute US Letter.

3. This driver does not use paper size matching. US Letter is substituted for the unsupported paper sizes

4. Sizes marked with a C are supported, but are commented out of the AFP formdef source file called

F1FMMST.DAT.

Example

<PrtType:PCL>

PaperSizeMatching = Yes

Available

Release | _______
Patch |

Used By

PCLLIB


PJLCommentOn

[PrtType:PCL]
PJLCommentOn

PJLCommentOn

[PrtType:PCL]

PJLCommentOn = LimitList

Parameter | Description
value | BATCH | FORMSET The default is BATCH

Remarks

Use this option to tell the system to add PJL comment records to the beginning of every form set or batch. You can set PJLCommentOn to either formset or, the default, batch.

Example

<PrtType:PCL>

PJLCommentOn = FORMSET

Available

Release | 11.0
Patch |


PJLCommentScript

[PrtType:PCL]
PJLCommentScript

PJLCommentScript

427 ADDING PRINTER JOB LANGUAGE COMMENTS

[PrtType:PCL]

PJLCommentScript = Edit

Parameter | Description
value | The default value is blank

Remarks

Printer Job Language (PJL) comments are supported by some, but not all, PCL printers. One type of command lets you add a comment to your PCL print stream. The PJL comment does not affect printing but it can be used to pass information to other products that look for specific information in PJL comment records, such as an imaging system.

NOTE: Imaging products can be used to archive PCL print streams. These products often require a control record at the beginning of the PCL print stream. These options and DAL functions let you create that control record.

To add PJL comments, add the INI option as shown in the example below to the PCL print group. The PJLCommentScript option specifies the DAL script you want to run. This DAL script creates a control string and adds it as an ASCII comment.

Example

<PrtType:PCL>

PJLCommentScript = imaging.DAL

Available

Release | 10.1
Patch |


PrePrintedPaper

[PrtType:PCL]
PrePrintedPaper

PrePrintedPaper

[PrtType:PCL]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Determines if the check box which lets you print or not print pre-printed objects appears on the Print window.

Also determines the default for this check box--checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:PCL>

PrePrintedPaper = No,Hidden

Available

Release | _______
Patch |

Used By

PCLLIB


PrintFunc

[PrtType:PCL]
PrintFunc

PrintFunc

[PrtType:PCL]

PrintFunc = Edit

Parameter | Description
value | The default value is PCLPrint

Remarks

The name of the program function that is the main entry point into the PCL print driver. Enter the name of function within the print driver for print.

Example

<PrtType:PCL>

PrintFunc = PCLPrint

Available

Release

Patch

Used By


PrintViewOnly

[PrtType:PCL]
PrintViewOnly

PrintViewOnly

[PrtType:PCL]

PrintViewOnly = YN

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

If set to Yes, the view only images will print. This does not apply to entry only images, which are never printed. Entry only images are usually worksheets. If the image is marked as hidden and view only, it will not print.

Example

<PrtType:PCL>

PrintViewOnly = No

Available

Release

Patch

Used By

PCLLIB


Resolution

[PrtType:PCL]
Resolution

Resolution

[PrtType:PCL]

Resolution = Edit

Parameter | Description
dots per inch | 300 | 600

Remarks

The dots per inch (dpi) resolution of the printer which receives the PCL data stream.

Example

<PrtType:PCL>

Resolution = 300

Available

Release | _______
Patch |

Used By

PCLLIB


SelectRecipients

[PrtType:PCL]
SelectRecipients

SelectRecipients

[PrtType:PCL]

SelectRecipients = YesNoHide

Parameter | Description
boolean | Yes | No The default is Yes,Enabled

Remarks

Enabled means the Select Recipients checkbox and recipient list appears in the Print window and is active (available to be checked).

Disabled means the Select Recipients checkbox and recipient list appears in the Print window but is grayed out (not available to be checked).

Hidden means the Select Recipients checkbox and recipient list does not appear in the Print window.

Example

<PrtType:PCL>

SelectRecipients = No,Enabled

Available

Release | _______
Patch |

Used By

PCLLIB


SendColor

[PrtType:PCL]
SendColor

SendColor

[PrtType:PCL]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default value is: No,Enabled

Remarks

Set to Yes to print in color. This print window option is for color printers. If you plan to use a color printer, enter Yes,Enabled for SendColor parameters. The INI value shown in this option's heading represents the recommended default value for this Print window check box.

Example

<PrtType:PCL>

SendColor = No

Available

Release | _______
Patch |

Used By

PCLLIB


SendOverlays

[PrtType:PCL]
SendOverlays

SendOverlays

[PrtType:PCL]

SendOverlays = YesNoHide

Parameter | Description
boolean | Yes | No The default is No,Enabled

Remarks

Set to Yes if you created PCL overlays for each FAP file

This print window option lets the user send images compiled into printer language. Sending overlays enhances print speed so this option is usually selected automatically. The INI value shown in this option's heading represents the recommended default value for this Print window check box.

Example

<PrtType:PCL>

SendOverlays = Yes,Enabled

Available

Release | _______
Patch |

Used By

PCLLIB


StapleBin

[PrtType:PCL]
StapleBin

StapleBin

[PrtType:PCL]

StapleBin = Edit

Parameter | Description
value | The default is blank

Remarks

Set this option to the PCL printer escape sequence that selects the output bin which contains the staple attachment. Use a tilde character (~) in place of the binary escape character.

Example

<PrtType:PCL>

StapleBin = ~&l2G

Available

Release | _______
Patch |

Used By

PCLLIB


StreamBufferSize

[PrtType:PCL]
StreamBufferSize

[PrtType:PCL]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:PCL>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


SuppressDlg

[PrtType:PCL]
SuppressDlg

SuppressDlg

[PrtType:PCL]

SuppressDlg = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

The GDI pass-through alternate PCL print method now lets you suppress the Windows Printer Selection window.

This prevents the printer window from appearing each time the feature tries to print to a PCL printer. You can also create a different PrtType:PCL control group and make it the default for MDR recipients.

To turn this feature on, include these options in your FSISYS.INI or FSIUSER.INI file (the SuppressDlg can be either Yes or No here)

<PrtType:PCL>

SuppressDlg = Yes

GDIDevice = PrinterName

where PrinterName is the name assigned to a printer accessible through your computer. Set the SuppressDlg option to Yes to prevent the Printer window from appearing.

To turn this feature on for DocuCreate, add this option in the FAPCOMP.INI file.

Example

<PrtType:PCL>

SuppressDlg = Yes

Available

Release | 10.1
Patch |


TermFunc

[PrtType:PCL]
TermFunc

TermFunc

[PrtType:PCL]

TermFunc = Edit

Parameter | Description
Edit | The default is blank.

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Example

<PrtType:PCL>

TermFunc = PCLTerm

Available

Release | _______
Patch |

Used By


TEXTCommentOn

[PrtType:PCL]
TEXTCommentOn

TEXTCommentOn

[PrtType:PCL]

TEXTCommentOn = LimitList

Parameter

Description

value

Values can be

  • Batch - Beginning of every print batch
  • Formset - Beginning of every form set

The default value is Batch

Remarks

The TEXTCommentOn option tells the system to add free form text or data to the beginning of every form set or print batch. The PCL and PDF drivers can now add free form text or data at the beginning of a batch or each form set within the batch. This can help you interface with imaging systems such as RightFax.

Use the TEXTScript INI option to specify the DAL script you want to run. This DAL script creates a free form data or text buffer and adds it to the print stream.

Here is an example of the DAL script:

* Populate PCL comment with field values in the RCBDFDFL.DFD file.

Faxnum = trim(GVM('FaxNumber'))

faxname = trim(GVM('FaxName'))

AddComment('<TOFAXNUM:' & faxnum & '>',1)

AddComment('<TONAME:' & faxname & '>',1)

Return

Notice the use of the second parameter to the AddComment DAL function. The 1 indicates the string should be an ASCII string. If you omit this parameter, the system converts the string into an EBCDIC string. You can also use the TEXTCommentOn option to tell the system to add free form text or data to the beginning of every form set or print batch. The default is Batch i.e. the beginning of every print batch. Here is an example:

<PrtType:PCL> or <PrtType:PDF>

TEXTScript = imaging.DAL

TEXTCommentOn = formset

Example

<PrtType:PCL>

Device = LPT1

DownLoadFonts = No,Enabled

Module = PCLW32

SendOverlays = No,Enabled

TEXTScript = freetext.dal

TEXTCommentOn = formset

Available

Release | 10.2
Patch | 127

Used By

CORPLIB, PCLLIB


TEXTScript

[PrtType:PCL]
TEXTScript

TEXTScript

[PrtType:PCL]

TEXTScript = File

Parameter | Description
File | The default is blank.

Remarks

The TEXTScript option specifies the name of the DAL script which creates a free form data or text buffer and adds it to the printer stream. The PCL and PDF drivers can now add free form text or data at the beginning of a batch or each form set within the batch. This can help you interface with imaging systems such as RightFax.

Use the TEXTScript INI option to specify the DAL script you want to run. This DAL script creates a free form data or text buffer and adds it to the print stream.

Here is an example of the DAL script:

* Populate PCL comment with field values in the RCBDFDFL.DFD file.

Faxnum = trim(GVM('FaxNumber'))

faxname = trim(GVM('FaxName'))

AddComment('<TOFAXNUM:' & faxnum & '>',1)

AddComment('<TONAME:' & faxname & '>',1)

Return

Notice the use of the second parameter to the AddComment DAL function. The 1 indicates the string should be an ASCII string. If you omit this parameter, the system converts the string into an EBCDIC string. You can also use the TEXTCommentOn option to tell the system to add free form text or data to the beginning of every form set or print batch. Here is an example:

<PrtType:PCL> or <PrtType:PDF>

TEXTScript = imaging.DAL

TEXTCommentOn = formset

Example

<PrtType:PCL>

Device = LPT1

DownLoadFonts = No,Enabled

Module = PCLW32

SendOverlays = No,Enabled

TEXTScript = freetext.dal

TEXTCommentOn = formset

Available

Release | 10.2
Patch | 127

Used By

CORPLIB, PCLLIB


Tray1

[PrtType:PCL]
Tray1

Tray1

[PrtType:PCL]

Tray1 = Edit

Parameter | Description
value | Tray name. The default is ~&l1H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

TRAY1 = ~&l1H

TRAY2 = ~&l4H

TRAY3 = ~&l5H

TRAY4 = ~&l20H

TRAY5 = ~&l21H

TRAY6 = ~&l22H

TRAY7 = ~&l23H

TRAY8 = ~&l24H

TRAY9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray2

[PrtType:PCL]
Tray2

Tray2

[PrtType:PCL]

Tray2 = Edit

Parameter | Description
value | Tray name. The default is ~&l4H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

Tray1 = ~&l1H

Tray2 = ~&l4H

Tray3 = ~&l5H

Tray4 = ~&l20H

Tray5 = ~&l21H

Tray6 = ~&l22H

Tray7 = ~&l23H

Tray8 = ~&l24H

Tray9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray3

[PrtType:PCL]
Tray3

Tray3

[PrtType:PCL]

Tray3 = Edit

Parameter | Description
value | Tray name. The default is ~&l5H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

Tray1 = ~&l1H

Tray2 = ~&l4H

Tray3 = ~&l5H

Tray4 = ~&l20H

Tray5 = ~&l21H

Tray6 = ~&l22H

Tray7 = ~&l23H

Tray8 = ~&l24H

Tray9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray4

[PrtType:PCL]
Tray4

Tray4

[PrtType:PCL]

Tray4 = Edit

Parameter | Description
value | Tray name. The default is ~&l20H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

Tray1 = ~&l1H

Tray2 = ~&l4H

Tray3 = ~&l5H

Tray4 = ~&l20H

Tray5 = ~&l21H

Tray6 = ~&l22H

Tray7 = ~&l23H

Tray8 = ~&l24H

Tray9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray5

[PrtType:PCL]
Tray5

Tray5

[PrtType:PCL]

Tray5 = Edit

Parameter | Description
value | Tray name. The default is ~&l21H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

Tray1 = ~&l1H

Tray2 = ~&l4H

Tray3 = ~&l5H

Tray4 = ~&l20H

Tray5 = ~&l21H

Tray6 = ~&l22H

Tray7 = ~&l23H

Tray8 = ~&l24H

Tray9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray6

[PrtType:PCL]
Tray6

Tray6

[PrtType:PCL]

Tray6 = Edit

Parameter | Description
value | Tray name. The default is ~&l22H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

Tray1 = ~&l1H

Tray2 = ~&l4H

Tray3 = ~&l5H

Tray4 = ~&l20H

Tray5 = ~&l21H

Tray6 = ~&l22H

Tray7 = ~&l23H

Tray8 = ~&l24H

Tray9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray7

[PrtType:PCL]
Tray7

Tray7

[PrtType:PCL]

Tray7 = Edit

Parameter | Description
value | Tray name. The default is ~&l23H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

Tray1 = ~&l1H

Tray2 = ~&l4H

Tray3 = ~&l5H

Tray4 = ~&l20H

Tray5 = ~&l21H

Tray6 = ~&l22H

Tray7 = ~&l23H

Tray8 = ~&l24H

Tray9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray8

[PrtType:PCL]
Tray8

Tray8

[PrtType:PCL]

Tray8 = Edit

Parameter | Description
value | Tray name. The default is ~&l24H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

Tray1 = ~&l1H

Tray2 = ~&l4H

Tray3 = ~&l5H

Tray4 = ~&l20H

Tray5 = ~&l21H

Tray6 = ~&l22H

Tray7 = ~&l23H

Tray8 = ~&l24H

Tray9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


Tray9

[PrtType:PCL]
Tray9

Tray9

[PrtType:PCL]

Tray9 = Edit

Parameter | Description
value | Tray name. The default is ~&l25H

Remarks

The PCL print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults. Note the '~' (tilde) is used instead of the PCL escape character.

<PrtType:PCL>

Tray1 = ~&l1H

Tray2 = ~&l4H

Tray3 = ~&l5H

Tray4 = ~&l20H

Tray5 = ~&l21H

Tray6 = ~&l22H

Tray7 = ~&l23H

Tray8 = ~&l24H

Tray9 = ~&l25H

Available

Release | 10.1
Patch |

Used By

GENPRINT


PrtType:PDF

PrtType:
PDF

Remarks

Adobe Systems created the Portable Document Format (PDF). It is the native file format of the Adobe Acrobat family of products. The original PDF file format was version 1.0. The system produces PDF files which adhere to PDF file format version 1.2. This version supports compression and page-at-a-time downloading. With page-at-a-time downloading (byte-serving), a web server sends only the requested page of information to the user, not the entire PDF document.

Note

Note 1: Review LoadPrintOnly for details on this INI Control group option.This INI file option should be set to Yes when you are printing PDF output from Entry when there are Print Only forms in the formset. Tip: If you produce an invalid PDF file, check your Form set definition file (form.dat, .BDF, .GRP, or .FOR) to see if you have any print only forms. If so, change the LoadPrintOnly option to Yes. The default is No.

Note 2: PDF viewers can only view one transaction in a file. So, you must generate a separate PDF file for every transaction in a batch. For two or three step processing mode (Gentrn, Gendata, Genprint) you must use the <Print> Group CallbackFunc INI option set to MutiFilePrint to accomplish this. For single step processing mode (Gendata) you use the <PrintFormset> Group MultiFilePrint INI option instead.

PrtType:PDF Options

  • BlankPageImage
  • BookMark
  • Class
  • Compression
  • Device
  • DisplayMode
  • DownLoadFonts
  • EmitXFA
  • EmulateDuplexPrinter
  • Encrypt
  • FieldTemplateAnnotations
  • FillableFields
  • FontCompression
  • ForceColorBitmaps
  • Hyperlink
  • JPEGCompression
  • LanguageLevel
  • Linearize
  • Module
  • OutputFunc
  • OutputMod
  • OverlayExt
  • PageNumbers
  • PaperSize
  • PrePrintedPaper
  • PrintFunc
  • PrintType
  • PrintViewOnly
  • SendColor
  • SendOverlays
  • SplitPercent
  • SplitText
  • StreamBufferSize
  • TEXTCommentOn
  • TEXTScript
  • TOCIndexLinks
  • Watermark

Example

<PrtType:PDF>

Device = E:\TEST.PDF

BookMark = Yes,Page

DownLoadFonts = No,Enabled

Module = PDFOS2

PageNumbers = Yes

PrintFunc = PDFPrint

SendOverlays = No,Enabled

SendColor = Yes,Enabled

PrintViewOnly = No

SplitText = No

SplitPercent = 50

Class = PDF

PrePrintedPaper= (not supported)

PaperSize = 0

FontCompression= 0


AdjustTextWidth

[PrtType:PDF]
AdjustTextWidth

[PrtType:PDF]

AdjustTextWidth = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Use AdjustTextWidth to force the PDF Driver to adjust the text width of every string that is displayed using an embedded font. Occasionally, this scaling will improve fidelity when embedding fonts. Set to Yes if you want the PDF Driver to adjust the text width of every string that is displayed using an embedded font.

The PDF driver automatically scales text when using internal (base) Acrobat fonts to make sure the text occupies the same width as defined by the font information in the font cross-reference (.FXR) file. This AdjustTextWidth INI setting tells the PDF driver to perform the same scaling when using embedded fonts.

Example

<PrtType:PDF>

AdjustTextWidth = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DownloadFonts


BlankPageImage

[PrtType:PDF]
BlankPageImage

[PrtType:PDF]

BlankPageImage = File

Parameter | Description
file | The default is blank.

Remarks

Use this option to define an image file to be used with the EmulateDuplexPrinter option. Defining the image to be used when emulating duplex printing.

The image defined by BlankPageImage will be used when emulating duplex printing. One way to use the image is to have a text label to denote that it is a blank page such as a text label with "This page intentionally left blank"

Do not use this feature with the AddBlankPages DAL function or the DPRAddBlankPages Docupresentment Bridge rule. This feature is used instead of those rules.

Example

<PrtType:PDF>

EmulateDuplexPrinter = Yes

BlankPageImage = imagename

Available

Release | 11.3
Patch |

Used By

PDFLIB


BookMark

[PrtType:PDF]
BookMark

[PrtType:PDF]

BookMark = YN

Parameter | Description
boolean | Yes | No
level | Formset | Group | Form | Page

Remarks

Turn bookmarks on or off.

This option contains two values, an on/off flag and a bookmark level. The values should be separated by a comma (,). If you do not specify a value, the option is set to No. The first value could be Yes or No, or simply Y or N. The system is not case sensitive. If a string other than the above is specified, the value will be set to No.

The second value could be Formset, Group, Form, or Page. This setting indicates the lowest level for which the system will set bookmarks. For example, if you enter Form, the system will set bookmarks for each form set, for each group in all form sets and for each form in all of the groups. You can include spaces before and after the string and it is not case sensitive. If you specify a string other than the one above, the value will be set to Page.

Example

<PrtType:PDF>

BookMark = Yes,Group

Available

Release | _______
Patch |

Used By

PDFLIB


CacheFiles

[PrtType:PDF]
CacheFiles

[PrtType:PDF]

CacheFiles = Edit

Parameter | Description
integer | The default value is 16.

Remarks

Sets the number of fonts to be cached (for performance reasons).

If n = 0, caching is turned off. If n = -1, there is no limit set on the number of fonts that will be cached.

Example

<PrtType:PDF>

CacheFiles = 0

Available

Release | 11.2
Patch | 11.1 P20

Used By

PDFLIB


Class

[PrtType:PDF]
Class

[PrtType:PDF]

Class = Edit

Parameter | Description
value | The default value is PDF

Remarks

Specifies the printer classification, such as AFP, PCL, PDF, XER, PST, or GDI.

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PrtType:PDF>

Class = PDF

Available

Release | _______
Patch |

Used By

PDFLIB


Compression

[PrtType:PDF]
Compression

[PrtType:PDF]

Compression = Edit

Parameter | Description
value | The default value is 2

Remarks

SETTING PDF COMPRESSION OPTIONS

You can choose from these PDF compression settings:

  • 0 (zero) = no compression
  • 1 = best speed
  • 2 = default compression
  • 3 = best compression

You can test the various compression options to see what works best for your implementation by comparing...

  • The time difference between the request to view the transaction in Acrobat Reader and when it is displayed.
  • The size of the PDF file after it is retrieved.

There are several ways to customize the PDF Print Driver so it produces PDF files more efficiently. For instance, you can adjust the PDF compression option ( Compression ), make JPEG compression ( JPEGCompression ) the default method for compressing graphics (LOG files), subset embedded fonts ( SubsetAllEmbeddedFonts ), compress fonts ( FontCompression ), and use compact fonts ( UseCompactFonts ).

Example

<PrtType:PDF>

Compression = 2

Available

Release | _______
Patch |

Used By


Device

[PrtType:PDF]
Device

[PrtType:PDF]

Device = Edit

Parameter | Description
value | The default is blank.

Remarks

The name of the file or device (LPT1) where the PDF print stream should be written. The "Device=" option is not required, but can be used to specify a default print device, such as a network printer, to use when not otherwise specified by another driver. If you leave it blank, PDF will ask you to select a printer.

Example

<PrtType:PDF>

Device = data\pdfout.pdf

Available

Release | _______
Patch |

Used By

PDFLIB


DisplayMode

[PrtType:PDF]
DisplayMode

1106 Specifying the Display Mode This option lets you control how the PDF file is initially displayed.

[PrtType:PDF]

DisplayMode = List

Parameter

Description

value

This option lets you control how the PDF file is initially displayed.

Values can be:

  • UseOutlines
  • UseThumbs
  • FullScreen
  • UseNone (the default)

Remarks

To have the PDF file open with:

    • bookmarks (document outline) visible Enter: UseOutlines
    • thumbnail images visible Enter: UseThumbs
    • full-screen mode-no menu bar or other window controls visible Enter: FullScreen
    • default mode-no bookmarks or thumbnails visible Enter: UseNone

These options are case-sensitive, so enter them exactly as shown here.

Example

<PrtType:PDF>

DisplayMode = UseThumbs

Available

Release | 10.2
Patch |


DownLoadFonts

[PrtType:PDF]
DownLoadFonts

[PrtType:PDF]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

Set to Yes to enable fonts to be embedded into the PDF file.

Embedding fonts lets you control the appearance of the document by letting you specify which fonts Acrobat Reader should use and what the font width will be. When you need to reproduce the exact look of the original document and you use custom fonts that do not scale exactly as Adobe expects, you should embed fonts.

To embed fonts, you need a set of PostScript Type 1 fonts or TrueType fonts, and you need to set the DownloadFonts INI option to Yes.

The PDF driver can also embed PCL, Xerox, or AFP printer fonts in addition to PostScript Type 1 and TrueType fonts. If the PDF Print Driver cannot locate a scalable font file (PostScript Type 1 or TrueType) in the PDF or PostScript properties, it checks the other font properties, in the order you specified in the FontSearchOrder option. To embed fonts in these formats, you must add the FontSearchOrder option to your PDF printer INI control group.

Example

<PrtType:PDF>

DownLoadFonts = Yes,Enabled

Available

Release | _______
Patch |

Used By

PDFLIB


EmitXFA

[PrtType:PDF]
EmitXFA

[PrtType:PDF]

EmitXFA = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Reserved for future use

Example

<PrtType:PDF>

EmitXFA = Yes

Available

Release | _______
Patch |

Used By


EmbeddedINI

[PrtType:PDF]
EmbeddedINI

[PrtType:PDF]

EmbeddedINI = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

The PDF Print Driver can embed its own INI control group within the PDF metadata for support purposes.

Example

<PrtType:PDF>

EmbeddedINI = Yes

Available

Release | _______
Patch |

Used By


EmulateDuplexPrinter

[PrtType:PDF]
EmulateDuplexPrinter

[PrtType:PDF]

EmulateDuplexPrinter = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Use this to emulating duplex printing for PDF output.

An image can be placed on the added blank pages by using the INI option BlankPageImage = <image name> in the PDF Printer group as well.

Do not use this feature with the AddBlankPages DAL function or the DPRAddBlankPages Docupresentment Bridge rule. This feature is used instead of those rules.

Example

<PrtType:PDF>

EmulateDuplexPrinter = Yes

Available

Release | 11.3
Patch |

Used By

PDFLIB


Encrypt

[PrtType:PDF]
Encrypt

[PrtType:PDF]

Encrypt = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

This option tells the PDF library to encrypt PDF files. Encrypting the PDF file changes the file so it is no longer easy to read when transmitted over the network. It also means you cannot use a text editor to alter the file without destroying it.

Since, however, no passwords or permissions have been specified, this option provides only a minimal amount of security. If someone gets a copy of the file, there is no way to prevent that person from viewing the file in Acrobat Reader or altering it with the full Acrobat product.

You can, however, create more secure documents by including additional options in the PDF printer control group of your INI file.

In the same control group as the Encrypt option, you can add the SecurityGroup option to specify a control group which will contain the permissions, passwords, and encryption strength. Here is an example:

< PrtType:PDF >

SecurityGroup = PDF_Encryption

Encrypt = Yes

< PDF_Encryption >

..

NOTE: While the only way to specify passwords is through INI options, the PDFKEYGEN built-in function lets you create a custom built-in that supplies the actual passwords. This way, the only thing that the INI file contains is

OwnerKey = ~PDFKEYGEN ~CUSTOMPASSWORDRULE

Keep in mind the INI files are generally inside a firewall and the passwords are stored in encrypted form. If you have a custom password rule, you can just specify:

Owner = ~CUSTOMPASSWORDRULE

Example

<PrtType:PDF>

Encrypt = Yes

Available

Release | _______
Patch |

Used By


FieldTemplateAnnotations

[PrtType:PDF]
FieldTemplateAnnotations

[PrtType:PDF]

FieldTemplateAnnotations = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

If this setting and TemplateFields are both set, then the PDF file will display the field name for each variable field and there will be an annotation object for each variable field that displays information about the field such as field name, field type, field length, scope, rotation, font description.

Example

<PrtType:PDF>

FieldTemplateAnnotations = Yes

Available

Release | _______
Patch |

Used By


FillableFields

[PrtType:PDF]
FillableFields

[PrtType:PDF]

FillableFields = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Reserved for future use

Example

<PrtType:PDF>

FillableFields = Yes

Available

Release | _______
Patch |

Used By


FontCompression

[PrtType:PDF]
FontCompression

[PrtType:PDF]

FontCompression = LimitList

Parameter | Description
level | 0 | 1 | 2 | 3 The default is 2

Remarks

Use this option to compress embedded fonts.

Enter zero (0), 1, 2, or 3 to indicate the level of compression. Zero indicates no compression and three indicates the highest level of compression. Keep in mind that this option only compresses the ASCII portion of PostScript fonts, so the compression ratio is between 5-15%. For True Type fonts, the compression ratio is between 40-50%.

There are several ways to customize the PDF Print Driver so it produces PDF files more efficiently. For instance, you can adjust the PDF compression option ( Compression ), make JPEG compression ( JPEGCompression ) the default method for compressing graphics (LOG files), subset embedded fonts ( SubsetAllEmbeddedFonts ), compress fonts ( FontCompression ), and use compact fonts ( UseCompactFonts ).

Example

<PrtType:PDF>

FontCompression = 3

Available

Release | _______
Patch |

Used By

PDFLIB


FontSearchOrder

[PrtType:PDF]
FontSearchOrder

[PrtType:PDF]

FontSearchOrder = Edit

Parameter | Description
value | Set to the printer font types separated by commas (AFP, PCL, XMC) that you wish to use when embedding fonts. The default is blank.

Remarks

The PDF driver can embed PCL, Xerox, or AFP printer fonts in addition to PostScript Type 1 and TrueType fonts. If the PDF Print Driver cannot locate a scalable font file (PostScript Type 1 or TrueType) in the PDF or PostScript properties, it checks the other font properties, in the order you specified in the FontSearchOrder option. To embed fonts in these formats, you must add the FontSearchOrder option to your PDF printer INI control group.

For instance, assume you set the option as shown here:

<PrtType:PDF>

FontSearchOrder = PCL,XMC

In the above example, after seaching the PDF and PostScript attributes, the PDF Print Driver would see if the PCL attributes of the font contain a font file name. If they do and that file exists, the PDF Print Driver embeds that font. If not, it looks at the Xerox Metacode (XMC) attributes to see if they contain a font file name and if that file exists. If it cannot find a font it can embed, the PDF Print Driver generates an error message and stops processing the transaction.

The PCL, Xerox, or AFP printer fonts must be available in the FONTLIB directory for your MRL.

Example

<PrtType:PDF>

FontSearchOrder = XMC,PCL,AFP

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DownloadFonts


ForceColorBitmaps

[PrtType:PDF]
ForceColorBitmaps

[PrtType:PDF]

ForceColorBitmaps = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Enter Yes if you want the PDF Driver to print graphic images in color even if the images are not set to print in color. The default is No.

Example

<PrtType:PDF>

ForceColorBitmaps = Yes

Available

Release | _______
Patch |

Used By


Hyperlink

[PrtType:PDF]
Hyperlink

[PrtType:PDF]

Hyperlink = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

This allows hyperlinks in PDF output.

Set to No if you do not want hyperlinks to be produced by the PDF Printer. The default is Yes.

Example

<PrtType:PDF>

Hyperlink = No

Available

Release | _______
Patch |

Used By

PDFLIB


InitFunc

[PrtType:PDF]
InitFunc

[PrtType:PDF]

InitFunc = Edit

Parameter | Description
value | The default is PDFInit

Remarks

The InitFunc option names the printer function called at the initial printing.

Example

<PrtType:PDF>

InitFunc = PDFInit

Available

Release | _______
Patch |

Used By

PDFLIB


JPEGCompression

[PrtType:PDF]
JPEGCompression

[PrtType:PDF]

JPEGCompression = YN

Parameter | Description
boolean | Yes | No Enter No to disable the default compression method (JPEG Compression) and instead use a lossless compression method. The default is Yes.

Remarks

Depending upon the options you choose, you can see a very significant size reduction in the PDF files you produce. For instance, if you are using 24-bit color graphics, you will see the greatest reduction. Also, if you are using embedded fonts and you are sub-setting the fonts instead of embedding all of them, you will see the file size decrease.

If compression is turned on, and by default the PDF Print Driver uses compression method 2, 24-bit color images are compressed using the JPEG compression method. This is a lossy compression method. You can, however, use the JPEGCompression option to disable JPEG compression, as shown here:

< PrtType:PDF >

JPEGCompression = No

A lossy compression method is one where compressing data and then decompressing it retrieves data that may differ from the original, but is close enough to be useful. Lossy compression is typically used to compress multimedia data (audio, video, still images), especially in applications such as streaming media and internet telephony.

On the other hand, lossless compression is preferred for text and data files, such as bank records, text articles, and so on. Most lossy compression formats suffer from generation loss: repeatedly compressing and decompressing the file will cause it to progressively lose quality. This is in contrast with lossless data compression.

Lossless data compression allows the exact original data to be reconstructed from the compressed data. Use lossless compression when it is important that the original and the decompressed data be identical. For instance, you would use lossless compression for executable programs and source code. Some image file formats, like PNG or GIF, use only lossless compression, while others like TIFF and MNG use either lossless or lossy methods.

There are several ways to customize the PDF Print Driver so it produces PDF files more efficiently. For instance, you can adjust the PDF compression option ( Compression ), make JPEG compression ( JPEGCompression ) the default method for compressing graphics (LOG files), subset embedded fonts ( SubsetAllEmbeddedFonts ), compress fonts ( FontCompression ), and use compact fonts ( UseCompactFonts ).

Example

<PrtType:PDF>

JPEGCompression = No

Available

Release | _______
Patch |

Used By

PDFLIB


LanguageLevel

[PrtType:PDF]
LanguageLevel

[PrtType:PDF]

LanguageLevel = LimitList

Parameter | Description
value | Level1 | Level2 The default is Level2

Remarks

This setting is obsolete for the PDF print driver.

Example

<PrtType:PDF>

LanguageLevel = Level2

Available

Release | _______
Patch |

Used By

PDFLIB


Linearize

[PrtType:PDF]
Linearize

[PrtType:PDF]

Linearize = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

This setting is used to create linearized PDF files.

With a linearized PDF file, a browser can display the first page of the PDF file before it finishes loading the entire file. This lets those who are using the PDF file start working with it sooner.

Also, if you are making the PDF files available via byte-serving web servers (servers that allow a user to request a specific range of bytes), linearization lets the user jump to any page in the PDF without having to first load all of the pages in between.

So if you are creating large PDF files which may be accessed via the internet, you probably want to linearize them.

Example

<PrtType:PDF>

Linearize = No

Available

Release | _______
Patch |

Used By

PDFLIB


Module

[PrtType:PDF]
Module

[PrtType:PDF]

Module = Edit

Parameter | Description
Edit | The default is PDFW32

Remarks

The name of the program module which contains the system's PDF print driver. See also the discussion of the Class option.

Example

<PrtType:PDF>

Module = PDFW32

Available

Release | _______
Patch |

Used By

PDFLIB


OutputFunc

[PrtType:PDF]
OutputFunc

[PrtType:PDF]

OutputFunc = Edit

Parameter | Description
value | The default is to leave blank.

Remarks

Leave this setting blank to accept the default value.

Example

<PrtType:PDF>

OutputFunc = PRTStdOutputFunc

Available

Release | 10.2
Patch | 109


OutputMod

[PrtType:PDF]
OutputMod

[PrtType:PDF]

OutputMod = Edit

Parameter | Description
value | Module name; the default is PRTW32

Remarks

Leave this setting blank to accept the default value.

Example

<PrtType:MPM>

OutputMod = PRTW32

Available

Release | 10.2
Patch | 109

Used By


OverlayExt

[PrtType:PDF]
OverlayExt

[PrtType:PDF]

OverlayExt = Edit

Parameter | Description
extension | a file extension (the default is .pdf)

Remarks

The PDF driver does not support overlays. This setting is ignored.

Example

<PrtType:PDF>

OverlayExt = .pdf

Available

Release | _______
Patch |

Used By


PageNumbers

[PrtType:PDF]
PageNumbers

[PrtType:PDF]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

The PageNumbers option activates the page numbering feature. Set this value to "Yes" to enable form or form set page numbering printed in the "Page X of Y" format.

Example

<PrtType:PDF>

PageNumbers = No

Available

Release | _______
Patch |

Used By

PDFLIB


PaperSize

[PrtType:PDF]
PaperSize

[PrtType:PDF]

PaperSize = 0

Parameter

Description

List

Values can be

  • 0 - Letter (Default)
  • 1 - US Legal
  • 2 - ISO A4
  • 4 - US ledger
  • 5 - US Tabloid
  • 3 - US Executive
  • 6 - US statement
  • 7 - US Folio
  • 8 - US fanfold
  • 20 - ISO A0
  • 21 - ISO A1
  • 22 - ISO A2
  • 23 - ISO A3
  • 25 - ISO A5
  • 26 - ISO A6
  • 27 - ISO A7
  • 28 - ISO A8
  • 29 - ISO A9
  • 30 - ISO A10
  • 32 - ISO 2A
  • 34 - ISO 4A
  • 40 - ISO B0
  • 41 - ISO B1
  • 42 - ISO B2
  • 43 - ISO B3
  • 44 - ISO B4
  • 45 - ISO B5
  • 46 - ISO B6
  • 47 - ISO B7
  • 48 - ISO B8
  • 49 - ISO B9
  • 50 - ISO B10
  • 52 - ISO 2B
  • 54 - ISO 4B
  • 60 - ISO C0
  • 61 - ISO C1
  • 62 - ISO C2
  • 63 - ISO C3
  • 64 - ISO C4
  • 65 - ISO C5
  • 66 - ISO C6
  • 67 - ISO C7
  • 68 - ISO C8
  • 69 - ISO C9
  • 70 - ISO C10
  • 71 - ISO DL
  • 80 - JIS B0
  • 81 - JIS B1
  • 82 - JIS B2
  • 83 - JIS B3
  • 84 - JIS B4
  • 85 - JIS B5
  • 86 - JIS B6
  • 87 - JIS B7
  • 88 - JIS B8
  • 89 - JIS B9
  • 90 - JIS B10
  • 98 - Custom
  • 99 - Current Type

The default value is 0 (8.5" x 11")

Remarks

This option selects the paper size.

When deciding the size the system first sets the page size to the size of the first image on the page. If the page size is Custom, the page size will be set to the form size. If the page size is now Letter (the default), the PDF Converter checks the PaperSize option. If the PaperSize is specified, the system uses it to determine the size. If the PaperSize option is set to Custom and page size is less than Letter, the page size will set to Letter. Otherwise, the system uses the custom width and height.

Available

Release | _______
Patch |

Used By

PDFLIB


PDFAOptions

[PrtType:PDF]
PDFAOptions

[PrtType:PDF]

PDFAOptions = Edit

Parameter | Description
Edit | Include this option if you want to produce PDF/A-1b compliant PDF files. Your entry identifies the INI control group that contains PDF/A-specific options. The default is PDFA.

Remarks

The PDF Print Driver complies with the requirements of the PDF for Archive (PDF/A) specification. This specification was designed by the International Standards Organization (ISO) and is intended to facilitate the long-term storage of electronic documents. The specification (ISO 19005-1) outlines the restrictions to which conforming files must adhere.

There are two sets of requirements. The PDF/A-1a set of requirements is more rigorous than the PDF/A-1b set. The Oracle Insurance PDF Print Driver implements PDF/A-1b compliance.

To set up your system to generate PDF/A-1b compliant documents, add the following INI option:

< PrtType:PDF >

PDFAOptions = PDFA

If you use the default, the system automatically assumes the PDFA control group has the following options and values, so you do not have to actually include it — unless you want to use different values:

< PDFA >

ICCProfile = srgb.icc

OutputCondition = Generic CRT Monitor

OutputConditionID = sRGB IEC61966-2.

Option

Description

ICCProfile

This specifies the name of the International Color Consortium (ICC) profile. This file describes the color attributes of a device or viewing requirement by defining a mapping between the source or target color space and a profile connection space (PCS).

The file you specify must reside in the directory defined by the DefLib option in the MasterResource control group.

The default is srg.icc. This file is embedded in the source code and will be used unless you include this control group and option and enter a different value in this field.

OutputCondition

A text string that describes the intended output device or production condition in human-readable form.

OutputConditionID

A text string identifier for the output condition.

Keep in mind...

  • The PDF file header must begin at byte offset zero (0) in the file. This is not a concern unless DAL scripts are used to place comments at the start of the file. If you enable PDF/A in a system that does emit comments at the beginning of the PDF file, the PDF driver will issue a warning but will still emit the comments.
  • The document cannot be encrypted. If encryption and PDF/A support are both enabled, a warning appears and the document will not be encrypted.
  • Colors must be specified in a device-independent manner. Oracle Insurance applications support the RGB scheme of specifying colors, which is device- dependent.

To implement device-independence, the PDF driver must embed an ICC profile in the file. ICC profiles are widely available for an extensive array of devices. There may be licensing requirements if color profiles are to be embedded in PDF files. Adobe offers a royalty-free license for embedding the color profiles located at: www.adobe.com/digitalimag/adobergb.html

The embedded color profile must be an RGB-based profile. The Oracle Insurance PDF Print Driver defaults to using a file called srgb.icc, which is a generic color profile with a wide range of colors (gamut).

NOTE: ICC profiles vary in size from a few hundred bytes to a megabyte or more. If the system is configured to produce compressed PDF files, these are compressed as well. Be aware, however, that they add to the size of the file.

  • To be PDF/A compliant, all fonts, TrueType or Postscript, must be embedded into the PDF file. This means the font files for every font used must be available on disk. Furthermore, you must have the legal right to embed all fonts used in a document. It is up to you to handle any font licensing issues that may arise. Keep in mind that embedding fonts increases the size of the PDF file. Enabling font compression in the PDF driver will minimize this to an extent.
  • The document catalog must contain a metadata key referencing a valid xmp metadata stream. The metadata stream must contain 2-4 KB of padding at the end to allow for in-place updating by applications that may not be PDF-aware. The Oracle Insurance driver uses 3KB. Additionally, the metadata stream must be unfiltered — specifically, uncompressed. Therefore, metadata will increase the size of PDF files by a minimum of 3kB.

NOTE: Metadata is generated by the driver and is not configurable.

Important Notice

  1. Oracle Insurance applications may include an ICC Profile for use in producing PDF/A-compliant output. Oracle Insurance obtained the ICC Profile from Adobe Systems Incorporated (“Adobe”), but this ICC Profile and others can also be obtained directly from Adobe's Support Web site and then used with Oracle Insurance applications.
  2. Oracle Insurance has not modified the Adobe ICC Profile, however, Customer acknowledges that (a) Adobe disclaims all warranties and conditions, express or implied; (b) Adobe excludes any and all liability for damages related to the use of the ICC Profile as provided by Oracle Insurance; and (c) the terms and conditions with respect to the license granted herein for the Adobe ICC Profile are offered by Oracle Insurance alone and not by Adobe. The ICC Profile is Copyrighted 2006 by Adobe Systems Incorporated.

Example

<PrtType:PDF>

PDFAOptions = PDFA

Available

Release | _______
Patch |

Used By

PDFLIB


PrePrintedPaper

[PrtType:PDF]
PrePrintedPaper

[PrtType:PDF]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Determines if the check box which lets you print or not print pre-printed objects appears on the Print window.

Also determines the default for this check box--checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:PDF>

PrePrintedPaper = No,Hidden

Available

Release | _______
Patch |

Used By


PrintFunc

[PrtType:PDF]
PrintFunc

[PrtType:PDF]

PrintFunc = Edit

Parameter | Description
value | The default value is PDFPrint

Remarks

The name of the program function that is the main entry point into the PDF print driver. Enter the name of function within the print driver for print.

Example

<PrtType:PDF>

PrintFunc = PDFPrint

Available

Release

Patch

Used By

PDFLIB


PrintType

[PrtType:PDF]
PrintType

[PrtType:PDF]

PrintType = Edit

Parameter | Description
value | The default is PDF

Remarks

The type of output you are printing. This setting is obsolete for the PDF print driver.

Example

<PrtType:PDF>

PrintType = PDF

Available

Release | _______
Patch |

Used By

PDFLIB


PrintViewOnly

[PrtType:PDF]
PrintViewOnly

[PrtType:PDF]

PrintViewOnly = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

Use this option to output view only forms when you create PDF files.

Set to Yes to print these images. Images marked as Entry only will not be printed, as these usually are the worksheet type images used for data collection.

Example

<PrtType:PDF>

PrintViewOnly = Yes

Available

Release | _______
Patch |

Used By

PDFLIB


SecurityGroup

[PrtType:PDF]
SecurityGroup

[PrtType:PDF]

SecurityGroup = INI group name

Parameter | Description
value | name of an INI group containing security settings

Remarks

The SecurityGroup option specifies the control group where permissions, passwords, and encryption strength are set. The permissions let you control if users can...

  • Print the document. (You can also control the print quality.)
  • Modify the document.
  • Copy text or graphics to the clipboard.
  • Add or update annotations.
  • Fill in form fields.
  • Access the document with accessibility tools, such as text to speech applications.
  • Add navigational aids to the document.

This table shows the INI options you can set.

All of the AllowXXX options default to Yes, meaning the permission is granted.

Option

Description

AllowPrinting

Lets the user print the document.

AllowModify

Lets the user modify the document.

AllowCopy

Lets the user copy data to the clipboard.

AllowAnnotate

Lets the user add or update annotations.

AllowFormFields

Lets the user fill in form fields.

You must set the KeyLength to 128 to use this option.

AllowAccessibility

Lets accessibility tools, such as text to speech applications, access the document.

You must set the KeyLength to 128 to use this option.

AllowAssembly

Lets the user add navigational elements to the document.

You must set the KeyLength to 128 to use this option.

AllowHighQualityPrinting

If you set AllowPrinting to Yes, set this option to Yes to let the user generate a high quality hard copy of the document.

If you set AllowPrinting to Yes and this option to No, users can only print draft quality hard copy.

You must set the KeyLength to 128 to use this option.

OwnerKey

Specifies the password required to change the document or its security settings. The password takes the form of an encrypted 64-byte hexadecimal encoded string.

For additional security, instead of specifying encrypted data in the INI file, you can use custom rules to provide the passwords directly. Here is an example:

Owner = ~CUSTOMPASSWORDRULE

User = ~CUSTOMERUSERPASSRULE

For less security, you can use settings similar to these to specify plain text passwords:

Owner = pdfowner

User = pdfuser

UserKey

Specifies the password required to open the document. The password takes the form of an encrypted 64-byte hexadecimal encoded string.

KeyLength

Specifies the encryption strength, in bits, either 40 or 128. The default is 128. The key length must match the length provided to the PDFKey tool.

The choice of key length is a primary factor in determining how secure the PDF file will be. Computers are fast enough that 40- bit encryption is susceptible to attacks in which every possible encryption key is tried.

The 128-bit encryption is much more secure and allows finer control of permissions, but PDF files encrypted with a key length of 128 bits can only be viewed using Adobe Acrobat and Acrobat Reader 5.0 or later. Because Acrobat Reader is available at no cost, this restriction is generally no more than a minor inconvenience.

Example

You can set up your PDF PrtType:XXX control groups to share a common set of security settings or have security settings tailored to each control group. This illustration shows how you would set your printer options to use the same security settings: Or, you can have custom security settings for each printer control group: Choose the approach that works best in your situation.

Or, you can have custom security settings for each printer control group:

<PrtType:PDF>

SecurityGroup = PDF_Encryption

<PDF_Encryption>

AllowAccessibility = No

AllowAnnotate = No

AllowCopy = No

AllowFormFields = No

AllowPrinting = Yes

OwnerKey = 36451bd39d753b7c1d10922c28e6665aa4f3353fb0348b536893e3b1db5c579b

UserKey = 1d5993d363f2c3b3815f48417c5a0bb600000000000000000000000000000000

Available

Release | _______
Patch |

Used By

PDFLIB


SendColor

[PrtType:PDF]
SendColor

[PrtType:PDF]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled.

Remarks

Set to Yes to enable color printing.

Example

<PrtType:PDF>

SendColor = Yes,Enabled

Available

Release | _______
Patch |

Used By

PDFLIB


SendOverlays

[PrtType:PDF]
SendOverlays

[PrtType:PDF]

SendOverlays = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled.

Remarks

The PDF driver does not support overlays. This setting is ignored.

Example

<PrtType:PDF>

SendOverlays = Yes,Enabled

Available

Release | _______
Patch |

Used By

PDFLIB


SplitPercent

[PrtType:PDF]
SplitPercent

[PrtType:PDF]

SplitPercent = Number

Parameter | Description
percentage amount | Range between -1 and 100 with a default of 50

Remarks

This setting is obsolete.

Because the PDF Print Driver can discriminate between scalable and bitmap fonts as well as scale text both horizontally and vertically, the SplitText option is no longer necessary or supported. Also, the Font Index field in the font records in the FXR file are no longer needed and are ignored.

Example

<PrtType:PDF>

SplitPercent = 50

Available

Release | _______
Patch |

Used By

PDFLIB


SplitText

[PrtType:PDF]
SplitText

[PrtType:PDF]

SplitText = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

This setting is obsolete.

Because the PDF Print Driver can discriminate between scalable and bitmap fonts as well as scale text both horizontally and vertically, the SplitText option is no longer necessary or supported. Also, the Font Index field in the font records in the FXR file are no longer needed and are ignored.

Example

<PrtType:PDF>

SplitText = Yes

Available

Release | _______
Patch |

Used By

PDFLIB


SpoolBatches

[PrtType:PDF]
SpoolBatches

[PrtType:PDF]

SpoolBatches = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

The PDF Print Driver can print an entire batch of transactions to a single PDF file. Set to Yes if you want to print an entire batch of transactions to a single PDF file.

You must also turn off the MultiFilePrint callback function. To do this, remove or comment out (using a semicolon;)) the CallbackFunc option. Here is an example of commenting out the CallbackFunc option:

<Print>

; CallbackFunc = MultiFilePrint

You cannot generate linearized PDF files if you set the SpoolBatches option to Yes because when linearizing, the PDF Print Driver must have the entire contents of the PDF file in memory. Since batches can be very large, it is not practical to keep an entire batch in memory.

Example

<PrtType:PDF>

SpoolBatches = Yes

Available

Release | 11.4
Patch |

See Also

<Print>

CallbackFunc


StreamBufferSize

[PrtType:PDF]
StreamBufferSize

[PrtType:PDF]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:PDF>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


SubsetAllEmbeddedFonts

[PrtType:PDF]
SubsetAllEmbeddedFonts

[PrtType:PDF]

SubsetAllEmbeddedFonts = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

To reduce the size of PDF files, the PDF Driver will embed only those glyphs that appear in the document when embedding fonts. Set to No if you want to embed all of the glyphs contained in font files regardless of whether the glyphs are needed in the document.

The glyphs are typographical symbols, such as letters of the alphabet and punctuation symbols.

Embedding only the glyphs used in the document will result in smaller PDF files.

There are several ways to customize the PDF Print Driver so it produces PDF files more efficiently. For instance, you can adjust the PDF compression option ( Compression ), make JPEG compression ( JPEGCompression ) the default method for compressing graphics (LOG files), subset embedded fonts ( SubsetAllEmbeddedFonts ), compress fonts ( FontCompression ), and use compact fonts ( UseCompactFonts ).

Example

<PrtType:PDF>

SubsetAllEmbeddedFonts = No

Available

Release | 11.2
Patch |

See Also

<PrtType:PDF>

DownloadFonts

UseCompactFonts


TemplateFields

[PrtType:PDF]
TemplateFields

[PrtType:PDF]

TemplateFields = YesNoHide

Parameter | Description
boolean | Yes | No The default is Yes, Enabled

Remarks

When this option is set to Yes, the field name is printed. See also FieldTemplateAnnotations .

Note: The PDF will show as much of the field name as will fit in the field. If the field length is set to 10 and the name of the field is more than 10 characters, only the first 10 characters will display\print in the field. A rectangle drawn around the field shows how large the field is. Hovering over the field with the mouse will display information about the field if FieldTemplateAnnotations is enabled.

Example

<PrtType:PDF>

TemplateFields = No,Enabled

Available

Release | _______
Patch |

Used By

PDFLIB


TermFunc

[PrtType:PDF]
TermFunc

[PrtType:PDF]

TermFunc = Edit

Parameter | Description
value | The default is blank.

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Example

<PrtType:PDF>

TermFunc = PDFTerm

Available

Release | _______
Patch |

Used By

PDFLIB


TEXTCommentOn

[PrtType:PDF]
TEXTCommentOn

[PrtType:PCL]

TEXTCommentOn = LimitList

Parameter

Description

value

Values can be

  • Batch - Beginning of every print batch
  • Formset - Beginning of every form set

The default value is Batch

Remarks

The TEXTCommentOn option tells the system to add free form text or data to the beginning of every form set or print batch.

The PCL and PDF drivers can now add free form text or data at the beginning of a batch or each form set within the batch. This can help you interface with imaging systems such as RightFax.

Use the TEXTScript INI option to specify the DAL script you want to run. This DAL script creates a free form data or text buffer and adds it to the print stream.

Here is an example of the DAL script:

* Populate PCL stream comment with field values from RCBDFDFL.DFD

Faxnum = trim(GVM('FaxNumber'))

faxname = trim(GVM('FaxName'))

AddComment('<TOFAXNUM:' & faxnum & '>',1)

AddComment('<TONAME:' & faxname & '>',1)

Return

Notice the use of the second parameter to the AddComment DAL function. The 1 indicates the string should be an ASCII string. If you omit this parameter, the system converts the string into an EBCDIC string. You can also use the TEXTCommentOn option to tell the system to add free form text or data to the beginning of every form set or print batch. The default is Batch i.e. the beginning of every print batch. Here is an example:

<PrtType:PCL> or <PrtType:PDF>

TEXTScript = imaging.DAL

TEXTCommentOn = formset

Example

<PrtType:PDF>

BookMark = Yes, Page

Device = data\pdfout.pdf

DownLoadFonts = No,Enabled

Module = PDFW32

PrintFunc = PDFPrint

SendOverlays = No,Enabled

SendColor = Yes,Enabled

TEXTScript = freetext.dal

TEXTCommentOn = formset

Available

Release | 10.2
Patch | 127

Used By

CORPLIB, PDFLIB


TEXTScript

[PrtType:PDF]
TEXTScript

[PrtType:PDF]

TEXTScript = File

Parameter | Description
File | The default is blank.

Remarks

The TEXTScript option specifies the name of the DAL script which creates a free form data or text buffer and adds it to the printer stream. The PCL and PDF drivers can add free form text or data at the beginning of a batch or each form set within the batch. This can help you interface with imaging systems such as RightFax.

Use the TEXTScript INI option to specify the DAL script you want to run. This DAL script creates a free form data or text buffer and adds it to the print stream.

Here is an example of the DAL script:

* Populate PCL comment with field values in the RCBDFDFL.DFD file.

Faxnum = trim(GVM('FaxNumber'))

faxname = trim(GVM('FaxName'))

AddComment('<TOFAXNUM:' & faxnum & '>',1)

AddComment('<TONAME:' & faxname & '>',1)

Return

Notice the use of the second parameter to the AddComment DAL function. The 1 indicates the string should be an ASCII string. If you omit this parameter, the system converts the string into an EBCDIC string. You can also use the TEXTCommentOn option to tell the system to add free form text or data to the beginning of every form set or print batch. Here is an example:

<PrtType:PCL> or <PrtType:PDF>

TEXTScript = imaging.DAL

TEXTCommentOn = formset

Example

<PrtType:PDF>

Bookmark = Yes,Page

Device = data\pdfout.pdf

DownLoadFonts = No,Enabled

Module = PDFW32

SendColor = Yes,Enabled

SendOverlays = No,Enabled

TEXTScript = freetext.dal

TEXTCommentOn = formset

Available

Release | 10.2
Patch | 127

Used By

CORPLIB, PDFLIB


TOCIndexLinks

[PrtType:PDF]
TOCIndexLinks

[PrtType:PDF]

TOCIndexLinks = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

This allows hyperlinks in PDF output for Table of Contents and Index objects.

Set to No if you do not want hyperlinks to be produced by the PDF Printer. The default is Yes.

Example

<PrtType:PDF>

TOCIndexLinks = No

Available

Release

Patch

See Also


UseCompactFonts

[PrtType:PDF]
UseCompactFonts

[PrtType:PDF]

UseCompactFonts = YN

Parameter | Description
boolean | Yes | No Enter No if you do not want to use Adobe’s Compact Font Format (CFF) for embedding Type 1 (PostScript) fonts. Using CFF results in smaller PDF files. The default is Yes

Remarks

The PDF Print Driver supports Adobe’s Compact Font Format (CFF) for embedding Type 1 fonts. Type 1 fonts, also known as PostScript fonts, are a type of scalable font created by Adobe.

CFF provides for a smaller embedded font output. The amount of space savings depends on several factors, including:

  • The number of characters used by the PDF
  • Whether you are subsetting fonts (the default behavior)
  • Whether you are using font compression

For example, when using every character from 32 (space) to 255 (ydieresis) and default compression, the Times-Roman Type 1 font supplied with Documaker uses 48,114 bytes in the Type 1 format, but only 21,730 bytes in the Compact Font format.

To use compact fonts, first make sure font downloading is enabled with this INI setting:

<PrtType:PDF>

DownloadFonts = Yes

UseCompactFonts = Yes

There are several ways to customize the PDF Print Driver so it produces PDF files more efficiently. For instance, you can adjust the PDF compression option ( Compression ), make JPEG compression ( JPEGCompression ) the default method for compressing graphics (LOG files), subset embedded fonts ( SubsetAllEmbeddedFonts ), compress fonts ( FontCompression ), and use compact fonts ( UseCompactFonts ).

Example

<PrtType:PDF>

UseCompactFonts = Yes

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DownloadFonts

SubsetAllEmbeddedFonts


ViewerPreferences

[PrtType:PDF]
ViewerPreferences

ViewerPreferences

[PrtType:PDF]

ViewerPreferences = List

Parameter | Description
Value | The default value is PDFViewerOptions

Remarks

You may specify a set of viewer preferences for the PDF files you create.

Enter the name of the INI control group that contains the PDF viewer options. Letting you choose the name of this control group gives you the option of defining multiple sets of PDF viewer options; however, you also have to remember the control group names you assign. Choose your names so they will be easy to remember and meaningful to other users.

For instance, if you need two sets of options to handle different security settings, you could name the groups as shown here:

PDFViewerOptions_MinSecurity

PDFViewerOptions_MaxSecurity

Since some of these settings require specific PDF versions, you should consider the version of Acrobat or Adobe Reader needed to fully support each PDF version.

This Version of Acrobat | Supports
4.0 and higher | PDF version 1.3
5.0 and higher | PDF version 1.4
6.0 and higher | PDF version 1.5
7.0 and higher | PDF version 1.6
8.0 and higher | PDF version 1.7

If you are creating documents that will be distributed widely, consider only using features that only require Acrobat 5 (PDF 1.4) or Acrobat 6 (PDF 1.5). This will help make sure all users can view and print your documents correctly.

Example

<PrtType:PFD>

ViewerPreferences = PDFViewerOptions

Available

Release | 11.4
Patch |

See Also

<PrtType:PDF>

DisplayMode

< PDFViewerOptions >


PrtType:PST

PrtType:
PST

Remarks

Adobe Systems created the PostScript language. It is an interpretive programming language with powerful graphics capabilities. For the most part, system-produced PostScript output will run on any printer that supports PostScript Level 2.

PrtType:PST Options

  • AdjustDuplex
  • AdjustTextWidth
  • CacheFiles
  • Class
  • Compression
  • DebugDuplex
  • Device
  • DownLoadFonts
  • DSCHeaderComment
  • DuplexInsertPage
  • InitFunc
  • LanguageLevel
  • Module
  • OverlayExt
  • OverlayPath
  • PageNumbers
  • PrePrintedPaper
  • PrinterModel
  • PrintFunc
  • PrintViewOnly
  • Resolution
  • SendColor
  • SendOverlays
  • SetOverprint
  • StapleOff
  • StapleOn
  • StreamBufferSize
  • TemplateFields
  • TermFunc
  • Tray1
  • Tray2
  • Tray3
  • Tray4
  • Tray5
  • Tray6
  • Tray7
  • Tray8
  • Tray9
  • Watermark


AdjustDuplex

[PrtType:PST]
AdjustDuplex

[PrtType:PST]

AdjustDuplex = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

This legacy setting is not recommended but it might be needed to correct a deficiency when using older Documaker releases to print PostScript for Xerox DocuPrint printers.

When printing PostScript, 2 single page forms that were marked as Duplex Front would print front and back on a single page.

A second problem is that when a duplex job with a blank back page prints on a DocuPrint printer, click charges occur for both the front and back side of each page even though nothing printed on the back side.

A new INI setting, AdjustDuplex = Yes, has been added to the PostScript printer INI options. If set to Yes, the PostScript print stream will use simplex commands whenever possible.

Example

<PrtType:PST>

AdjustDuplex = Yes

Available

Release | _______
Patch |

Used By


AdjustTextWidth

[PrtType:PST]
AdjustTextWidth

[PrtType:PST]

AdjustTextWidth = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

The AdjustTextWidth setting addresses an issue where the long strings of text in PostScript printed output can be slightly shorter or longer than it should be.

Because PostScript fonts are scalable fonts, the character widths of these fonts can be calculated in fractional dots for a given resolution while the character widths in the font cross reference file are rounded up or down to the nearest dot. As a result, there can be slight differences in the lengths of long strings of text printed in PostScript (using scalable fonts) versus the same long strings of text printed in AFP, PCL, or Metacode (using bitmap fonts).

If AdjustTextWidth is set to Yes, the PostScript driver will adjust the width of text strings to match the

calculated width based on the character widths stored in the font cross-reference file.

< PrtType:PST >

AdjustTextWidth = Yes

The easiest places to see where the PostScript text is slightly shorter or longer than it should be would be on long text labels that are underlined or when using the table of contents (e.g. “Chapter 1 ………………………………. Page 4”).

Example

<PrtType:PST>

AdjustTextWidth = Yes

Available

Release | _______
Patch |

Used By


CacheFiles

[PrtType:PST]
CacheFiles

[PrtType:PST]

CacheFiles = Edit

Parameter | Description
integer | The default value is 100

Remarks

Set to enable the caching of PostScript overlays. The first x number of PostScript overlays in the print job are cached. The default is 100.

Example

<PrtType:PST>

CacheFiles = 100

Available

Release

Patch

Used By


Class

[PrtType:PST]
Class

[PrtType:PST]

Class = Edit

Parameter | Description
value | The default value is PST

Remarks

Specifies the printer classification, such as AFP, PCL, PST, XER, PST, or GDI.

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PrtType:PST>

Class = PST

Available

Release | _______
Patch |

Used By


Compression

[PrtType:PST]
Compression

[PrtType:PST]

Compression = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

The PostScript print driver supports bitmap compression. To disable bitmap compression, add the following INI option to the PostScript printer control group:

< PrtType:PST >

Compression = No

Example

<PrtType:PST>

Compression = No

Available

Release | _______
Patch |

Used By


DebugDuplex

[PrtType:PST]
DebugDuplex

[PrtType:PST]

DebugDuplex = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

This setting will write out to a trace file information about the duplex settings used when producing a PostScript print job.

Example

<PrtType:PST>

DebugDuplex = Yes

Available

Release | _______
Patch |

Used By


Device

[PrtType:PST]
Device

Device

[PrtType:PST]

Device = Edit

Parameter | Description
value | The default is blank.

Remarks

The name of the file or device (LPT1) where the PST print stream should be written. The "Device=" option is not required, but can be used to specify a default print device, such as a network printer, to use when not otherwise specified by another driver. If you leave it blank, PST will ask you to select a printer.

This setting is ignored by the GenPrint program but is used by the Image Editor and other system programs.

Example

<PrtType:PST>

Device = data\pdfout.pst

Available

Release | _______
Patch |

Used By

PSTLIB


DownLoadFonts

[PrtType:PST]
DownLoadFonts

DownLoadFonts

[PrtType:PST]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No The default is Yes,Enabled

Remarks

Set to Yes to enable downloading of PostScript fonts.

The value Enabled results in the check box being enabled in the print dialogs for Documaker Workstation and DMStudio print.

Example

<PrtType:PST>

DownLoadFonts = No,Enabled

Available

Release | _______
Patch |

Used By

PSTLIB


DSCHeaderComment

[PrtType:PST]
DSCHeaderComment

DSCHeaderComment

1214 Adding DSC Comments

[PrtType:PST]

DSCHeaderComment = Edit

Parameter | Description
value | The default is to leave blank.

Remarks

Use the DSCHeaderComment INI option in the PostScript printer control group to specify PostScript Document Structure Convention (DSC) Comments you want added.

Add to the header portion of the generated PostScript print stream. You can include as many DSCHeaderComment options as are necessary.

The DSC header comments are added at the beginning of the generated PostScript print stream as shown here:

%!PS-Adobe-3.0

%%Title: INSUREDS COPY

%%Creator: FormMaker PostScript Driver

%%CreationDate: Thu Apr 04 17:50:57 2002

%For: INSURED

%%Pages: (atend)

%%DocumentData: Clean7Bit

%%DocumentSuppliedResources: font (atend)

%%DocumentMedia:Media1 612 792 75 (White) (Tray1)

%%+ Media2 612 792 75 (White) (Tray2)

%%+ Media3 612 792 75 (White) (Tray3)

%%+ Media4 612 792 75 (White) (Tray4)

%%EndComments

Example

<PrtType:PST>

DSCHeaderComment = %%DocumentMedia:Media1 612 792 75 (White) (Tray1)

DSCHeaderComment = %%+ Media2 612 792 75 (White) (Tray2)

DSCHeaderComment = %%+ Media3 612 792 75 (White) (Tray3)

DSCHeaderComment = %%+ Media4 612 792 75 (White) (Tray4)

Tray1 = "<< /MediaType (Tray1)/MediaColor(White) /MediaWeight 75>> setpagedevice"

Tray2 = "<< /MediaType (Tray2)/MediaColor(White) /MediaWeight 75>> setpagedevice"

Tray3 = "<< /MediaType (Tray3)/MediaColor(White) /MediaWeight 75>> setpagedevice"

Tray4 = "<< /MediaType (Tray4)/MediaColor(White) /MediaWeight 75>> setpagedevice"

Available

Release | 10.0
Patch | 409

Used By


DuplexInsertPage

[PrtType:PST]
DuplexInsertPage

[PrtType:PST]

DuplexInsertPage = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

To produce consistent duplexing across PostScript printers made by different vendors, DuplexInsertPage should be set to Yes (default setting is Yes).

One example of the duplexing problems that this setting will correct is for printers that do not honor duplex commands when printing on the back side of a page.

Example

<PrtType:PST>

DuplexInsertPage = Yes

Available

Release | _______
Patch |

Used By


InitFunc

[PrtType:PST]
InitFunc

[PrtType:PST]

InitFunc = Edit

Parameter | Description
value | The default is PSTInit

Remarks

The InitFunc option names the printer function called at the initial printing.

Example

<PrtType:PST>

InitFunc = PSTInit

Available

Release | _______
Patch |

Used By


LanguageLevel

[PrtType:PST]
LanguageLevel

LanguageLevel

[PrtType:PST]

LanguageLevel = LimitList

Parameter | Description
value | Level1 | Level2 The default is Level2

Remarks

The Language level supported by tye PostScript printer. Complex printing requirements require a Level2 printer.

Example

<PrtType:PST>

LanguageLevel = Level1

Available

Release | _______
Patch |

Used By

PSTLIB


Module

[PrtType:PST]
Module

Module

[PrtType:PST]

Module = Edit

Parameter | Description
Edit | The default is PSTW32

Remarks

The name of the program module which contains the system's PostScript print driver. In order to produce PostScript output, Module should be set to PSTW32. See also the discussion of the Class option.

Example

<PrtType:PST>

Module = PSTW32

Available

Release | _______
Patch |

Used By

PSTLIB


OverlayExt

[PrtType:PST]
OverlayExt

OverlayExt

[PrtType:PST]

OverlayExt = Edit

Parameter | Description
extension | a file extension The default is .ovl

Remarks

The file extension of the PostScript overlays.

Example

<PrtType:PST>

OverlayExt = .ovl

Available

Release | _______
Patch |

Used By

PSTLIB


OverlayPath

[PrtType:PST]
OverlayPath

OverlayPath

[PrtType:PST]

OverlayPath = Path

Parameter | Description
Path | If this field is left blank, the default is to use the FormLib directory pointed to by the FormLib option in the MasterResource control group.

Remarks

Set to the directory which contains the PostScript overlays for each FAP file.

Instead of using the MasterResource control group's FormLib options, you could use the following options:

<MasterResource>

OverlayPath = <CONFIG:Batch Processing>

OverlayPath = <CONFIG:Batch Processing>

OverlayPath = .\PstOvl\

The default is the FormLib directory pointed to by the FormLib option in the MasterResource control group, as shown here:

<MasterResource>

FormLib = <CONFIG:Batch Processing>

FormLib = <CONFIG:Batch Processing>

FormLib = ./forms/

Example

<MasterResource>

OverlayPath = <CONFIG:Batch Processing>

OverlayPath = <CONFIG:Batch Processing>

OverlayPath = .\PstOvl\

Available

Release | _______
Patch |

Used By

PSTLIB


PageNumbers

[PrtType:PST]
PageNumbers

PageNumbers

[PrtType:PST]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

Set to Yes to enable form or form set page numbering.

Example

<PrtType:PST>

PageNumbers = No

Available

Release | _______
Patch |

Used By

PSTLIB


PrePrintedPaper

[PrtType:PST]
PrePrintedPaper

[PrtType:PST]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enabled or Hidden determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Yes or No determines whether this check box is checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option (Yes,Enabled) includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:PST>

PrePrintedPaper = No,Hidden

Available

Release | _______
Patch |

Used By


PrinterModel

[PrtType:PST]
PrinterModel

PrinterModel

[PrtType:PST]

PrinterModel = File

Parameter | Description
file name | file name (omit extension) The default is blank.

Remarks

Contains the name of the PostScript Printer Definition (PPD) file. This file contains information about printer-specific features. This file must be in the directory specified by the DefLib option of the FMRES control group.

Example

<PrtType:PST>

PrinterModel = file1

Available

Release | _______
Patch |

Used By

PSTLIB


PrintFunc

[PrtType:PST]
PrintFunc

PrintFunc

[PrtType:PST]

PrintFunc = Edit

Parameter | Description
value | The default value is PSTPrint

Remarks

The name of the program function that is the main entry point into the PostScript print driver. Enter the name of function within the print driver for print.

Example

<PrtType:PST>

PrintFunc = PSTPrint

Available

Release

Patch

Used By

PSTLIB


PrintViewOnly

[PrtType:PST]
PrintViewOnly

PrintViewOnly

[PrtType:PST]

PrintViewOnly = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

If set to Yes, the view only images will print. This does not apply to entry only images, which are never printed. Entry only images are usually worksheets. If the image is marked as hidden and view only, it will not print.

Example

<PrtType:PST>

PrintViewOnly = Yes

Available

Release | _______
Patch |

Used By

PSTLIB


Resolution

[PrtType:PST]
Resolution

Resolution

[PrtType:PST]

Resolution = Edit

Parameter | Description
dots per inch | The default is 300

Remarks

The dots per inch resolution of the printer which will receive the PostScript data stream.

Example

<PrtType:PST>

Resolution = 300

Available

Release | _______
Patch |

Used By

PSTLIB


SendColor

[PrtType:PST]
SendColor

SendColor

[PrtType:PST]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default is No,Enabled

Remarks

Set to Yes to enable color printing.

Example

<PrtType:PST>

SendColor = Yes,Enabled

Available

Release | _______
Patch |

Used By

PSTLIB


SendOverlays

[PrtType:PST]
SendOverlays

SendOverlays

[PrtType:PST]

SendOverlays = YesNoHide

Parameter | Description
boolean | Yes | No The default is No,Enabled

Remarks

Set to Yes if you have created PostScript overlays for each FAP file.

When you say SendOverlays = Yes, make sure you convert all FAPs to PostScript Overlays (PST) by running the OVLCOMPW utility as follows:

1. copy rel103sm.fxr and fsisys.ini to the directory where the FAP files are located

2. execute the following command:

ovlcompw /I=my.fap /L=PSTW32 /F=PSTPrint /U=PST /X=REL95SM /H /C

Example

<PrtType:PST>

SendOverlays = Yes,Enabled

Available

Release | _______
Patch |

Used By

PSTLIB


SetOverprint

[PrtType:PST]
SetOverprint

[PrtType:PST]

SetOverprint = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

Set Overprint to Yes if you are printing to a highlight color printer, such as the Xerox DocuTech/DocuPrint 180 Highlight Color printer, and there is a white outline that appears around black letters printed on a highlight color background.

If you are using pre-compiled overlays, be sure to re-create the overlays after you set this option to

Yes.

If you still see a small white outline around the characters in your printed output, your printer may

need to be re-calibrated. Contact your printer vendor to fine tune your printer calibration.

Example

<PrtType:PST>

SetOverprint = Yes

Available

Release | _______
Patch |

Used By


StapleOff

[PrtType:PST]
StapleOff

[PrtType:PST]

StapleOff = Edit

Parameter | Description
value | The default is blank.

Remarks

Use the StapleOn and StapleOff INI options in the PostScript printer control group to control staple support on a form level.

Here is an example. Suppose you have seven forms in the form set and all but one (Form D) are to be stapled. There are two recipients who are to receive these forms as shown in this table:

Form | Staple? | Recipients
A | Yes | INSURED, AGENT
B | Yes | INSURED
C | Yes | INSURED, AGENT
D | No | INSURED, AGENT
E | Yes | INSURED
F | Yes | INSURED, AGENT
G | Yes | INSURED, AGENT

The INSURED recipient’s forms print as:

The AGENT recipient’s forms print as:

The StapleOff setting works in a similar fashion to the Tray1 option which let you specify PostScript

commands directly as a quoted string or to look up the PostScript commands to use in your printer's PPD file.

By default, the PostScript print driver will use these commands:

< PrtType:PST >

...

StapleOn = "<</Staple 3 >> setpagedevice"

StapleOff = "<</Staple 0 >> setpagedevice"

You can override PostScript staple commands by providing an alternate PostScript command to use via the StapleOn and StapleOff options in your PostScript printer control group.

You can issue PostScript staple commands in these forms:

• A quoted string containing the PostScript commands. The quoted string should contain the appropriate PostScript commands for turning stapling on or off. Here is an example:

StapleOn = "1 dict dup /Staple 0 put setpagedevice"

* A UI keyword from a PPD file specifed in the PrinterModel setting. UI keywords represent features that commonly appear in a user interface (UI). They provide the code to invoke a user-selectable feature within the context of a print job, such as the selection of an input tray or manual feed. The entries of UI keywords are surrounded by these structure keywords:

*OpenUI/*CloseUI or *JCLOpenUI/*JCLCloseUI

Here is an example of an OpenUI structure for XRXFinishing:

*OpenUI *XRXFinishing/Finishing: PickOne

*OrderDependency: 60.0 AnySetup *XRXFinishing

*DefaultXRXFinishing: None

*XRXFinishing None/None: "

1 dict dup /Staple 0 put setpagedevice"

*End

*XRXFinishing Single_Portrait_Staple/Single Portrait Staple: "

2 dict dup /Staple 3 put

dup /StapleDetails 2 dict dup /Type 1 put dup /StapleLocation

(SinglePortrait) put

put setpagedevice"

*End

*XRXFinishing Single_Landscape_Staple/Single Landscape Staple: "

2 dict dup /Staple 3 put

dup /StapleDetails 2 dict dup /Type 1 put dup /StapleLocation

(SingleLandscape) put

put setpagedevice"

*End

*XRXFinishing Dual_Portrait_Staple/Dual Portrait Staple: "

2 dict dup /Staple 3 put

dup /StapleDetails 2 dict dup /Type 1 put dup /StapleLocation

(DualPortrait) put

put setpagedevice"

*End

*XRXFinishing Dual_Staple/Dual Landscape Staple: "

2 dict dup /Staple 3 put

dup /StapleDetails 2 dict dup /Type 1 put dup /StapleLocation

(DualLandscape) put

put setpagedevice"

*End

*?XRXFinishing: "(Unknown) = flush"

*CloseUI: *XRXFinishing

A PostScript Printer Definition (PPD) file is supplied with a PostScript printer. This file contains information about printer-specific features. You specify the PPD file you want to use in the PrinterModel option in your PostScript printer control group (just the file name, no drive, path, or file extension). If the PrinterModel option contains the name of a PPD file, this file must be in the directory specified in the DefLib option in the FMRes control group.

This example shows a PostScript printer group that uses a PPD file for a DocuPrint 65 printer (XRD60651.PPD) and specifies StapleOn and StapleOff options using keyword settings from the PPD file:

< PrtType:PST >

...

PrinterModel = XRD60651

StapleOn = *XRXFinishing Single_Portrait_Staple/Single Portrait Staple:

StapleOff = *XRXFinishing None/None:

Example

<PrtType:PST>

StapleOff =

Available

Release | _______
Patch |

Used By


StapleOn

[PrtType:PST]
StapleOn

[PrtType:PST]

StapleOn = Edit

Parameter | Description
value | The default is blank.

Remarks

Use the StapleOn and StapleOff INI options in the PostScript printer control group to control staple support on a form level.

See the StapleOff setting for detailed information on using staple support.

Example

<PrtType:PST>

StapleOn =

Available

Release | _______
Patch |

Used By


StreamBufferSize

[PrtType:PST]
StreamBufferSize

[PrtType:PST]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:PST>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType:PST]
TermFunc

[PrtType:PST]

TermFunc = Edit

Parameter | Description
value | The default is PSTTerm.

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Example

<PrtType:PST>

TermFunc = PSTTerm

Available

Release | _______
Patch |

Used By


Tray1

[PrtType:PST]
Tray1

Tray1

[PrtType:PST]

Tray1 = Edit

Parameter | Description
value | Tray name. The default is 1

Remarks

The PST print driver has been modified to support up to nine paper trays.

You can override PostScript tray commands by providing an alternate PostScript command to use. You issue PostScript tray commands in these forms:

  • A quoted string containing the PostScript commands. The quoted string should contain the appropriate PostScript commands for selecting a paper tray. Here is an example:

Tray1 = "statusdict /lettertray get exec”

  • A tray number from 1 to 9. You can use tray numbers to map non-existent trays. For example, Tray5=1 maps output for tray 5 to tray 1. The system checks the INI setting for overriding Tray1 before it checks the setting for Tray2 and so on. Because of this, do not specify a tray number less than the tray you are overriding. For example, you should not use a setting of Tray5=6.

  • A UI keyword from a PPD file specifed in the PrinterModel setting. UI keywords represent features that commonly appear in a user interface (UI). They provide the code to invoke a user-selectable feature within the context of a print job, such as the selection of an input tray or manual feed. The entries of UI keywords are surrounded by these structure keywords:

*OpenUI/*CloseUI or *JCLOpenUI/*JCLCloseUI

Here is an example of an OpenUI structure for MediaColor:

*OpenUI *MediaColor: PickOne

*OrderDependency: 30 AnySetup *MediaColor

*DefaultMediaColor: white

*MediaColor white: "1 dict dup /MediaColor (white) put setpagedevice"

*MediaColor clear: "1 dict dup /MediaColor (clear) put setpagedevice"

*MediaColor blue: "1 dict dup /MediaColor (blue) put setpagedevice"

*MediaColor buff: "1 dict dup /MediaColor (buff) put setpagedevice"

*MediaColor green: "1 dict dup /MediaColor (green) put setpagedevice"

*MediaColor goldenrod: "1 dict dup /MediaColor (goldenrod) put setpagedevice"

*MediaColor pink: "1 dict dup /MediaColor (pink) put setpagedevice"

*MediaColor yellow: "1 dict dup /MediaColor (yellow) put setpagedevice"

*?MediaColor: "

save

currentpagedevice /MediaColor

{get} stopped

{pop pop (white)} {dup null eq {pop (white)} if} ifelse

= flush

restore

"

*End

*CloseUI: *MediaColor

Input media (paper trays) are often selected on PostScript printers by specifying PageSize, MediaColor, MediaWeight, and MediaType. In the above example, media (paper) colors were defined for white, clear, blue, and so on. If you wanted to specify that the paper assigned to tray 5 uses blue paper, you could use one of these INI settings:

Tray5 = *MediaColor blue:

or

Tray5 = "1 dict dup /MediaColor (blue) put setpagedevice"

The first example (Tray5 = *MediaColor blue:) uses the UI keyword in the PPD file while the second example (Tray5 = "1 dict dup /MediaColor (blue) put setpagedevice") uses the actual PostScript commands in a quoted string.

When you use the UI keyword in an INI setting, always include the beginning asterisk (*) and the terminating colon (:).

Example

Here are the default PostScript INI settings:

<PrtType:PST>

; UI keyword is used if PPD is specified and keyword is found. Otherwise, quoted string is used.

TRAY1="0 statusdict /setpapertray get exec" or TRAY1=*InputSlot Upper:

TRAY2="1 statusdict /setpapertray get exec" or TRAY2=*InputSlot Lower:

TRAY3="2 statusdict /setpapertray get exec" or TRAY3=*InputSlot Manual:

TRAY4="3 statusdict /setpapertray get exec" or TRAY4=*InputSlot Envelope:

; Make trays 5 through 9 use the PostScript commands for tray 1

TRAY5=1

TRAY6=1

TRAY7=1

TRAY8=1

TRAY9=1

Available

Release | _______
Patch |

Used By

GENPRINT


Tray2

[PrtType:PST]
Tray2

[PrtType:PST]

Tray2 = Edit

Parameter | Description
value | Tray name. The default is 2

Remarks

The PST print driver can support up to nine paper trays.

For more information see also PrtType:PST Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:PST>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Available

Release | _______
Patch |

Used By


Tray3

[PrtType:PST]
Tray3

[PrtType:PST]

Tray3 = Edit

Parameter | Description
value | Tray name. The default is 3

Remarks

The PST print driver can support up to nine paper trays.

For more information see also PrtType:PST Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:PST>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Available

Release | _______
Patch |

Used By


Tray4

[PrtType:PST]
Tray4

[PrtType:PST]

Tray4 = Edit

Parameter | Description
value | Tray name. The default is 4

Remarks

The PST print driver can support up to nine paper trays.

For more information see also PrtType:PST Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:PST>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Available

Release | _______
Patch |

Used By


Tray5

[PrtType:PST]
Tray5

[PrtType:PST]

Tray5 = Edit

Parameter | Description
value | Tray name. The default is 5

Remarks

The PST print driver can support up to nine paper trays.

For more information see also PrtType:PST Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:PST>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Available

Release | _______
Patch |

Used By


Tray6

[PrtType:PST]
Tray6

[PrtType:PST]

Tray6 = Edit

Parameter | Description
value | Tray name. The default is 6

Remarks

The PST print driver can support up to nine paper trays.

For more information see also PrtType:PST Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:PST>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Available

Release | _______
Patch |

Used By


Tray7

[PrtType:PST]
Tray7

[PrtType:PST]

Tray7 = Edit

Parameter | Description
value | Tray name. The default is 7

Remarks

The PST print driver can support up to nine paper trays.

For more information see also PrtType:PST Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:PST>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Available

Release | _______
Patch |

Used By


Tray8

[PrtType:PST]
Tray8

[PrtType:PST]

Tray8 = Edit

Parameter | Description
value | Tray name. The default is 8

Remarks

The PST print driver can support up to nine paper trays.

For more information see also PrtType:PST Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:PST>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Available

Release | _______
Patch |

Used By


Tray9

[PrtType:PST]
Tray9

[PrtType:PST]

Tray9 = Edit

Parameter | Description
value | Tray name. The default is 9

Remarks

The PST print driver can support up to nine paper trays.

For more information see also PrtType:PST Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:PST>

Tray1 = 1

Tray2 = 2

Tray3 = 3

Tray4 = 4

Tray5 = 5

Tray6 = 6

Tray7 = 7

Tray8 = 8

Tray9 = 9

Available

Release | _______
Patch |

Used By


PrtType:PXL

PrtType:
PXL

Remarks

Version 10.2 Feature 1192 USING THE NEW PCL 6 PRINTER DRIVER

Version 10.2 includes PXLLIB, which includes a new printer driver for PCL 6. PCL 6 is a newer version of the PCL language, not an superset of PCL 5. It is a completely different page description language (PDL). Oracle has chosen to include a PCL 6 driver because of its Unicode support.

NOTE: For more information about Unicode support, see Using Unicode Support.

PCL 6 is a stack-based protocol (similar to PostScript) composed of attributes and operators that let you define paths, clip paths, pens, brushes, fonts, raster patterns, and so on. PCL 6 also supports 16-bit character codes which makes it a better choice for Unicode than PCL 5.

NOTE: The original PCL printer driver (PCLLIB) supports PCL 5, 5c, and 5e. This new PCL printer driver, PXLLIB, supports PCL 6.

Both the PCL5 and PCL6 print drivers use the PCL printer section of the FXR file. The PCL6 print driver supports PCL5 bitmap fonts and TrueType fonts. You can use PCL5 bitmap fonts for printing ASCII data (SBCS). However, to printing Unicode data, you must use TrueType fonts. To specify a TrueType font in the PCL printer section of the FXR, enter the name of the TrueType font in the Font File field. The TrueType font must reside in the FontLib directory as specified in your master resource library (MRL).

PXL (PCL6) INI options

You must define the necessary printer options for the GenPrint program to produce PCL 6 output. These options specify PCL 6 output and are located in a PrtType:xxx control group, such as PrtType:PXL. Many of the PCL 5 and PCL 6 printer INI settings are the same.

PrtType:PXL Options

  • Class
  • Compression
  • DownLoadFonts
  • InitFunc
  • Module
  • PageNumbers
  • PaperSizeMatching
  • PrePrintedPaper
  • PrintFunc
  • SendOverlays
  • StreamBufferSize
  • TermFunc
  • Watermark

The following INI options are different for PCL 6:

Module = PXLW32

PrintFunc = PXLPrint

DownLoadFonts = Yes (internal font selection is not supported)

These INI options are not supported for PCL 6:

AdjLeftMargin

FitToWidth

HighlightColor

OutputBin

OverlayExt

OverlayPath

PJLCommentOn

PJLCommentScript

SendOverlays

StapleBin

Tray# (where # is 1,2,3, and so on)

The PCL 6 driver lets you download both PCL bitmap fonts and TrueType fonts. You must specify the TrueType font file name in the Font File entry of the PCL printer section in the font cross-reference (FXR) file.

To turn on Unicode support, be sure to check the Unicode Character Widths field when you insert a TrueType font into the FXR file. Unicode support lets you use additional characters and languages supported by the TrueType font.

Keep in mind...

  • Because the PCL 6 driver supports PCL bitmap fonts, you can use existing MRLs.

Just remember to change your INI options as discussed above.

  • When printing using a TrueType font, only the characters used on the form are downloaded into the print stream. This reduces the size of print stream files, particularly if the TrueType font includes support for Asian languages.

In comparison to the PCL 5 printer driver, the PCL 6 driver has these limitations:

  • No overlay support
  • No support for a separate downloadable font file which contains multiple PCL fonts
  • No internal printer font support
  • Less paper tray support, no INI options to specify which PCL commands to use
  • No INI options to specify PCL commands to output bin or staple bin
  • No highlight color support
  • No comment script support

PrtType:PXL Options

  • SendOverlays


Class

[PrtType:PXL]
Class

[PrtType:PXL]

Class = Edit

Parameter | Description
value | The default value is PXL

Remarks

Specifies the printer classification, such as AFP, PCL, PXL, XER, PST, or GDI.

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PrtType:PXL>

Class = PXL

Available

Release | _______
Patch |

Used By


Compression

[PrtType:PXL]
Compression

[PrtType:PXL]

Compression = LimitList

Parameter | Description
value | 0 (No Compression) | 1 (RLE Compression) The default is 1

Remarks

The PXL (PCL6) print driver supports bitmap compression. To disable bitmap compression, add the following INI option to the PXL printer control group:

< PrtType:PXL >

Compression = 0

Example

<PrtType:PXL>

Compression = 1

Available

Release | _______
Patch |

Used By


DownLoadFonts

[PrtType:PXL]
DownLoadFonts

[PrtType:PXL]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes,Enabled

Remarks

Set to Yes to enable downloading of PCL fonts.

Example

<PrtType:PXL>

DownLoadFonts = No,Enabled

Available

Release | _______
Patch |

Used By


InitFunc

[PrtType:PXL]
InitFunc

[PrtType:PXL]

InitFunc = Edit

Parameter | Description
Edit | The default is PXLInit

Remarks

The InitFunc option names the printer function called at the initial printing. Do not change this value.

Example

<PrtType:PXL>

InitFunc = PXLInit

Available

Release | _______
Patch |

Used By


Module

[PrtType:PXL]
Module

[PrtType:PXL]

Module = Edit

Parameter | Description
Edit | The default is PXLW32

Remarks

The name of the program module which contains the system's PXL print driver. See also the discussion of the Class option.

Example

<PrtType:PXL>

Module = PXLW32

Available

Release | _______
Patch |

Used By


OutputBin

[PrtType:PXL]
OutputBin

[PrtType:PXL]

OutputBin = Edit

Parameter | Description
value | The default is 0.

Remarks

Possible values include:

  • 0 - Default bin (default)
  • 1 - Face down bin
  • 2 - Face up bin
  • 3 - Job offset bin

NOTE: Support for these values will vary by PXL (PCL6) printer.

Example

<PrtType:PXL>

OutputBin = 0

Available

Release | _______
Patch |

Used By

PCLLIB


PageNumbers

[PrtType:PXL]
PageNumbers

[PrtType:PXL]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

Set to Yes to enable form or form set page numbering.

Example

<PrtType:PXL>

PageNumbers = No

Available

Release | _______
Patch |

Used By


PaperSizeMatching

[PrtType:PXL]
PaperSizeMatching

[PrtType:PXL]

PaperSizeMatching = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

See PaperSizeMatching for more details.

Example

<PrtType:PXL>

PaperSizeMatching = Yes

Available

Release | _______
Patch |

Used By


PJLCommentOn

[PrtType:PXL]
PJLCommentOn

[PrtType:PXL]

PJLCommentOn = LimitList

Parameter | Description
value | BATCH | FORMSET The default is BATCH

Remarks

Use this option to tell the system to add PJL comment records to the beginning of every form set or batch. You can set PJLCommentOn to either formset or, the default, batch.

Example

<PrtType:PXL>

PJLCommentOn = FORMSET

Available

Release | _______
Patch |

Used By


PJLCommentScript

[PrtType:PXL]
PJLCommentScript

[PrtType:PXL]

PJLCommentScript = Edit

Parameter | Description
value | The default value is blank

Remarks

Printer Job Language (PJL) comments are supported by some, but not all, PXL/PCL6 printers. One type of command lets you add a comment to your PCL print stream. The PJL comment does not affect printing but it can be used to pass information to other products that look for specific information in PJL comment records, such as an imaging system.

NOTE: Imaging products can be used to archive PXL/PCL6 print streams. These products often require a control record at the beginning of the PXL/PCL6 print stream. These options and DAL functions let you create that control record.

To add PJL comments, add the INI option as shown in the example below to the PXL print group. The PJLCommentScript option specifies the DAL script you want to run. This DAL script creates a control string and adds it as an ASCII comment.

Example

<PrtType:PXL>

PJLCommentScript = imaging.DAL

Available

Release | _______
Patch |

Used By


PrePrintedPaper

[PrtType:PXL]
PrePrintedPaper

[PrtType:PXL]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Determines if the check box which lets you print or not print pre-printed objects appears on the Print window.

Also determines the default for this check box--checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:PXL>

PrePrintedPaper = No,Hidden

Available

Release | _______
Patch |

Used By


PrintFunc

[PrtType:PXL]
PrintFunc

[PrtType:PXL]

PrintFunc = Edit

Parameter | Description
value | The default value is PXLPrint

Remarks

The name of the program function that is the main entry point into the PXL print driver. Enter the name of function within the print driver for print.

Example

<PrtType:PXL>

PrintFunc = PXLPrint

Available

Release

Patch

Used By


SendOverlays

[PrtType:PXL]
SendOverlays

SendOverlays

[PrtType:PXL]

SendOverlays = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: No,Hidden

Remarks

The PXL driver does not support overlays. This setting is ignored.

Example

<PrtType:PXL>

SendOverlays = Yes,Enabled

Available

Release

Patch

Used By


StreamBufferSize

[PrtType:PXL]
StreamBufferSize

[PrtType:PXL]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:PXL>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType:PXL]
TermFunc

[PrtType:PXL]

TermFunc = Edit

Parameter | Description
Edit | The default is blank.

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Example

<PrtType:PXL>

TermFunc = PXLTerm

Available

Release | _______
Patch |

Used By


PrtType:RTF

PrtType:
RTF

Note

Note: RTF viewers can only view one transaction in a file. So, you must generate a separate RTF file for every transaction in a batch.

For two or three step processing mode (Gentrn, Gendata, Genprint) you must use the <Print> Group CallbackFunc INI option set to MutiFilePrint to accomplish this.

For single step processing mode (Gendata) you use the <PrintFormset> Group MultiFilePrint INI option instead.

To use the RTF print driver, you need these INI settings:

<Printers>

PrtType = RTF

<PrtType:RTF>

Module = RTFW32

PrintFunc = RTFPrint

You will also need to specify an output device name on the Print window.

PrtType:RTF Options

  • AllowInput
  • Barcode
  • Bitmap
  • Box
  • BMSUB
  • BMSUBChar
  • Chart
  • Class
  • Device
  • DownLoadFonts
  • EmptyFooters
  • EmptyHeaders
  • FrameAdjustSpaceWidth
  • FrameHeightCanGrow
  • FrameTextareaText
  • Field
  • GenerateAddInXML
  • InitFunc
  • MinBottomMargin
  • MinLeftMargin
  • MinRightMargin
  • MinTopMargin
  • Module
  • NoBatchSupport
  • OverlayExt
  • PageNumbers
  • PreLoadRequired
  • PrePrintedPaper
  • PrintFunc
  • ReplaceFAPHeadFoot
  • RTFCompatibilityOptions
  • StreamBufferSize
  • Template
  • TemplateFields
  • TermFunc
  • Text
  • TextMerge
  • UseFORFile
  • Vector
  • Watermark
  • WriteFrames

Example

<PrtType:RTF>

PrintFunc = RTFPrint

Module = RTFW32

SendColor = Yes,Enabled


AllowInput

[PrtType:RTF]
AllowInput

AllowInput

[PrtType:RTF]

AllowInput = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

This option is used by DocuToolbox, Image Editor and the FAP2RTF command line utility to print or convert a FAP file into an RTF file with form fields that can be used entry fields in a word processor such as Microsoft Word.

Set the AllowInput option to Yes to enable form fields in the output file. The default is No.

The syntax for the FAP2RTF utility is: fap2rtf /I /x /ini /o

Here is an example:

Fap2rtf /i=.\forms\q1addr.fap /x=.\forms\rel102sm.fxr /ini=fapcomp.ini /o=.\forms\test.rtf

The fxr must be present in the same location where the fap file is located, even if you specify the path with the /x parameter to point to a different location.

This example shows how you can use wild cards:

Fap2rtf /i=*.fap /x=rel102sm.fxr /ini=fapcomp.ini

In addition to the above INI options, you would need to set up the RTF print type and the Printer (for command line utility) or Printers (for the GUI tools).

If the variable field is date format or time format type, you may use the WordDateFormats and WordTimeFormats groups to convert the Documaker date/time format to Word date/time format. Please refer to the WordDateFormats , WordTimeFormats, Printers Printer groups for more information.

NOTE: This works with print types RTF and RTF_NoFrame.

Examples

For GUI tools, use the following example:

<Printers>

PrtType = RTF

<PrtType:RTF>

Module = RTFW32

PrintFunc = RTFPrint

AllowInput = Yes

TemplateFields = Yes

For the command line utility, use the following example:

<Printer>

PrtType = RTF

<PrtType:RTF>

Module = RTFW32

PrintFunc = RTFPrint

AllowInput = Yes

TemplateFields = Yes

Available

Release | 10.3
Patch | 26

Used By

RTFLIB


Barcode

[PrtType:RTF]
Barcode

[PrtType:RTF]

Barcode = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Enter No if you want to omit these kind of objects from the RTF file.

Example

<PrtType:RTF>

Barcode = No

Available

Release | _______
Patch |

Used By


Bitmap

[PrtType:RTF]
Bitmap

[PrtType:RTF]

Bitmap = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Enter No if you want to omit these kind of objects from the RTF file.

Example

<PrtType:RTF>

Bitmap = No

Available

Release | _______
Patch |

Used By


Box

[PrtType:RTF]
Box

[PrtType:RTF]

Box = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Enter No if you want to omit these kind of objects from the RTF file.

Example

<PrtType:RTF>

Box = No

Available

Release | _______
Patch |

Used By


BMSUB

[PrtType:RTF]
BMSUB

BMSUB

[PrtType:RTF]

BMSUB = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Set the BMSUB option to No if you do not want to replace invalid characters in the form field name. The default is Yes.

This option is used by DocuToolbox, Image Editor and FAP2RTF command line utility to print or convert a FAP file into an RTF file with form fields that can be used as entry fields in a word processor such as Microsoft Word.

The names of the variable fields in the FAP file will be stored to the BookMark field in the RTF file. If you have spaces in the variable field names, set the BMSUB option to Yes to avoid the error message, "The bookmark name is not valid", when entering data into Form Fields.

If you do not want to replace invalid characters in the form field name, then set this option to No. The default is Yes.

The syntax for the FAP2RTF utility is fap2rtf /i /x /ini /o

Here is an example:

Fap2rtf /i=.\forms\q1addr.fap /x=.\forms\rel102sm.fxr /ini=fapcomp.ini /o=.\forms\test.rtf

The fxr must be present in the same location where the fap file is located, even if you specify the path with the /x parameter to point to a different location.

This example shows how you can use wild cards:

Fap2rtf /i=*.fap /x=rel102sm.fxr /ini=fapcomp.ini

In addition to the above INI options, you would need to set up the RTF print type and the Printer (for command line utility) or Printers (for the GUI tools).

Examples

For the GUI tools, use the following example:

<Printers>

PrtType = RTF

<PrtType:RTF>

Module = RTFW32

PrintFunc = RTFPrint

AllowInput = Yes

BMSUB = Yes

BMSUBChar = b

TemplateFields = Yes

For the command line utility, use the following example:

<Printer>

PrtType = RTF

<PrtType:RTF>

Module = RTFW32

PrintFunc = RTFPrint

AllowInput = Yes

BMSUB = Yes

BMSUBChar = b

TemplateFields = Yes

Available

Release | 10.3
Patch | 33

Used By

RTFLIB


BMSUBChar

[PrtType:RTF]
BMSUBChar

BMSUBChar

[PrtType:RTF]

BMSUBChar = _ (underscore)

Parameter | Description
Edit | The default value is: _ (underscore)

Remarks

The BMSUBChar option specifies the character to use when invalid characters are substituted.

This option is used by DocuToolbox, Image Editor and the FAP2RTF command line utility to print or convert a FAP file into an RTF file with form fields that can be used as entry fields in a word processor such as Microsoft Word.

The names of the variable fields in the FAP file will be stored to the BookMark field in the RTF file. If you have spaces in the variable field names, set the BMSUB option to Yes to avoid the error message, "The bookmark name is not valid", when entering data into Form Fields. The BMSUBChar option specifies the character to use when invalid characters are substituted. The default is the underscore ( _ ).

The syntax for the FAP2RTF utility is: fap2rtf /i /x /ini /o

Here is an example:

Fap2rtf /i=.\forms\q1addr.fap /x=.\forms\rel102sm.fxr /ini=fapcomp.ini /o=.\forms\test.rtf

The fxr must be present in the same location where the fap file is located, even if you specify the path for the /x parameter to point to a different location.

This example shows how you can use wild cards:

Fap2rtf /i=*.fap /x=rel102sm.fxr /ini=fapcomp.ini

In addition to the above INI options, you would need to set up the RTF print type and the Printer (for command line utility) or Printers (for the GUI tools).

Examples

For the GUI tools, use the following example:

<Printers>

PrtType = RTF

<PrtType:RTF>

Module = RTFW32

PrintFunc = RTFPrint

AllowInput = Yes

BMSUB = Yes

BMSUBChar = b

TemplateFields = Yes

For the command line utility, use the following example:

<Printer>

PrtType = RTF

<PrtType:RTF>

Module = RTFW32

PrintFunc = RTFPrint

AllowInput = Yes

BMSUB = Yes

BMSUBChar = b

TemplateFields = Yes

Available

Release | 10.3
Patch | 33

Used By

RTFLIB


Chart

[PrtType:RTF]
Chart

[PrtType:RTF]

Chart = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Enter No if you want to omit these kind of objects from the RTF file.

Example

<PrtType:RTF>

Chart = No

Available

Release | _______
Patch |

Used By


Class

[PrtType:RTF]
Class

[PrtType:RTF]

Class = Edit

Parameter | Description
value | The default value is RTF

Remarks

Specifies the printer classification, such as AFP, PCL, RTF, XER, PST, or GDI.

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PrtType:RTF>

Class = RTF

Available

Release | _______
Patch |

Used By


Device

[PrtType:RTF]
Device

[PrtType:RTF]

Device = Edit

Parameter | Description
value | The default is blank.

Remarks

The name of the file or device (LPT1) where the RTF print stream should be written. The "Device=" option is not required, but can be used to specify a default print device, such as a network printer, to use when not otherwise specified by another driver. If you leave it blank, RTF will ask you to select a printer.

This setting is ignored by the GenPrint program but is used by the Image Editor and other system programs.

Example

<PrtType:RTF>

Device = data\rtfout.rtf

Available

Release | _______
Patch |

Used By


DownLoadFonts

[PrtType:RTF]
DownLoadFonts

[PrtType:RTF]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: Yes,Enabled

Remarks

This setting is ignored by the RTF print driver.

Example

<PrtType:RTF>

DownLoadFonts = No,Enabled

Available

Release | _______
Patch |

Used By


EmptyFooters

[PrtType:RTF]
EmptyFooters

[PrtType:RTF]

EmptyFooters = YN

Parameter | Description
Boolean | Yes | No The default is No.

Remarks

Enter Yes to remove the contents from any footers in the file. This setting can be used to remove both text and graphics from the footer when printing.

Example

<PrtType:RTF>

EmptyHeader = No

EmptyFooter = Yes

Available

Release | _______
Patch |

Used By


EmptyHeaders

[PrtType:RTF]
EmptyHeaders

[PrtType:RTF]

EmptyHeaders = YN

Parameter | Description
boolean | Yes | No The default is No.

Remarks

Enter Yes to remove the contents from any headers in the file. This setting can be used to remove both text and graphics from the header when printing.

Example

<PrtType:RTF>

EmptyHeader = No

EmptyFooter = Yes

Available

Release | _______
Patch |

Used By


FrameAdjustSpaceWidth

[PrtType:RTF]
FrameAdjustSpaceWidth

FrameAdjustSpaceWidth

Parameter | Description
Boolean | Default value is: No

Remarks

This RTF output option is a companion option with the FrameTextareaText option and will only process when FrameTextareaText is set to Yes.

When the FrameAdjustSpaceWidth option is set to Yes, the space character widths are reduced using font condensing options to prevent text overlaps.

When this option is set to No, the space characters are not altered for width reduction.

Example

<PrtType:RTF>

WriteFrames = Yes

FrameTextareaText = Yes

FrameAdjustSpaceWidth = Yes

Available

Release | 12.0
Patch |

Used By

RTFLIB


FrameHeightCanGrow

[PrtType:RTF]
FrameHeightCanGrow

FrameHeightCanGrow

Parameter | Description
Boolean | Default value is: No

Remarks

This setting is used injunction with the RTF INI option WriteFrames=Yes.

When this option is set to Yes, the frame height is set to "AtLeast" which will allow the frame to increase in vertical size.

When this option is set to No, the frame height is set to "Exactly" which will not expand.

Example

<PrtType:RTF>

WriteFrames = Yes

FrameHeightCanGrow = Yes

Available

Release | 11.4
Patch | 7

Used By

RTFLIB


FrameTextareaText

[PrtType:RTF]
FrameTextareaText

FrameTextareaText

Parameter | Description
Boolean | Default value is: No

Remarks

This RTF output option is a companion option with the WriteFrames option and will only process when WriteFrames is set to Yes.

When the FrameTextareaText option is set to Yes, the text strings from a textarea will be individually positioned on each page.

When this option is set to No, the text strings from a textarea are allowed to grow and wrap.

Example

<PrtType:RTF>

WriteFrames = Yes

FrameTextareaText = Yes

Available

Release | 12.0
Patch |

Used By

RTFLIB


Field

[PrtType:RTF]
Field

[PrtType:RTF]

Field = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Enter No if you want to omit these kind of objects from the RTF file.

Example

<PrtType:RTF>

Field = No

Available

Release | _______
Patch |

Used By


GenerateAddInXML

[PrtType:RTF]
GenerateAddInXML

[PrtType:RTF]

GenerateAddInXML = YN

Parameter | Description
boolean | Yes | No The default is No.

Remarks

This setting is used when creating RTF output for Documaker AddIn. When this option is set to Yes,the RTF output will contain embedded XML and RTF bookmarks to identify the document elements included in the document. When the RTF is imported into Documaker AddIn the document elements are converted into content controls.

Example

<PrtType:RTF>

GenerateAddInXML = Yes

Available

Release | 12.1
Patch | 1

Used By


InitFunc

[PrtType:RTF]
InitFunc

[PrtType:RTF]

InitFunc = Edit

Parameter | Description
value | The default is blank.

Remarks

The InitFunc option names the printer function called at the initial printing. Do not change this value.

Example

<PrtType:RTF>

InitFunc = RTFInit

Available

Release | _______
Patch |

Used By


MinBottomMargin

[PrtType:RTF]
MinBottomMargin

MinBottomMargin

[PrtType:RTF]

MinBottomMargin = 400

Parameter | Description
FAP units | The default value is 400

Remarks

The MinBottomMargin option specifies the minimum required bottom margins in FAP units.

The RTF print driver produces margins by calculating what is required and putting the result in the RTF output. You can set minimum required margins using the RTF print type control group.

You must set the minimum required margins in FAP units (2400 FAP units per inch). Here are the default settings:

<PrtType:RTF>

MinTopMargin = 400

MinLeftMargin = 600

MinRightMargin = 600

MinBottomMargin= 400

Margin values specified in the INI file override those set in the FAP file if the page margins in the FAP file are smaller.

Example

<PrtType:RTF>

MinTopMargin = 1200

MinLeftMargin = 1200

MinRightMargin = 1200

MinBottomMargin= 1200

Available

Release | 10.2
Patch | 124

Used By


MinLeftMargin

[PrtType:RTF]
MinLeftMargin

MinLeftMargin

[PrtType:RTF]

MinLeftMargin = 600

Parameter | Description
FAP units | The default value is 600

Remarks

The MinLeftMargin option specifies the minimum required left margins in FAP units.

The RTF print driver produces margins by calculating what is required and putting the result in the RTF output. You can set minimum required margins using the RTF print type control group.

You must set the minimum required margins in FAP units (2400 FAP units per inch). Here are the default settings:

<PrtType:RTF>

MinTopMargin = 400

MinLeftMargin = 600

MinRightMargin = 600

MinBottomMargin= 400

Margin values specified in the INI file override those set in the FAP file if the page margins in the FAP file are smaller.

Example

<PrtType:RTF>

MinTopMargin = 1200

MinLeftMargin = 1200

MinRightMargin = 1200

MinBottomMargin= 1200

Available

Release | 10.2
Patch | 124

Used By


MinRightMargin

[PrtType:RTF]
MinRightMargin

MinRightMargin

[PrtType:RTF]

MinRightMargin = 600

Parameter | Description
FAP units | The default value is 600

Remarks

The MinRightMargin option specifies the minimum required right margins in FAP units.

The RTF print driver produces margins by calculating what is required and putting the result in the RTF output. You can set minimum required margins using the RTF print type control group.

You must set the minimum required margins in FAP units (2400 FAP units per inch). Here are the default settings:

<PrtType:RTF>

MinTopMargin = 400

MinLeftMargin = 600

MinRightMargin = 600

MinBottomMargin= 400

Margin values specified in the INI file override those set in the FAP file if the page margins in the FAP file are smaller.

Example

<PrtType:RTF>

MinTopMargin = 1200

MinLeftMargin = 1200

MinRightMargin = 1200

MinBottomMargin= 1200

Available

Release | 10.2
Patch | 124

Used By


MinTopMargin

[PrtType:RTF]
MinTopMargin

MinTopMargin

[PrtType:RTF]

MinTopMargin = 400

Parameter | Description
FAP units | The default value is 400

Remarks

The MinTopMargin option specifies the minimum required top margins in FAP units.

The RTF print driver produces margins by calculating what is required and putting the result in the RTF output. You can set minimum required margins using the RTF print type control group.

You must set the minimum required margins in FAP units (2400 FAP units per inch). Here are the default settings:

<PrtType:RTF>

MinTopMargin = 400

MinLeftMargin = 600

MinRightMargin = 600

MinBottomMargin= 400

Margin values specified in the INI file override those set in the FAP file if the page margins in the FAP file are smaller.

Example

<PrtType:RTF>

MinTopMargin = 1200

MinLeftMargin = 1200

MinRightMargin = 1200

MinBottomMargin= 1200

Available

Release | 10.2
Patch | 124

Used By


Module

[PrtType:RTF]
Module

[PrtType:RTF]

Module = Edit

Parameter | Description
Edit | The default is RTFW32

Remarks

The name of the program module which contains the system's RTF print driver. See also the discussion of the Class option.

Example

<PrtType:RTF>

Module = RTFW32

Available

Release | _______
Patch |

Used By


NoBatchSupport

[PrtType:RTF]
NoBatchSupport

NoBatchSupport

You can generate separate files for each transaction when you choose RTF (or PDF) from WIP or batch print.

The name of the files will have a rolling number appended to the end of the name that starts the process and is filled in on the Print window. This is automatically handled and you do not have to set INI options to get the WIP or batch print to work as long as your PrtType name is PrtType:RTF.

There are several INI options you can use to override the naming process and also name other print drivers that require this unique handling.

< BatchPrint >

NoBatchSupport = RTF

PreLoadRequired = RTF

These are the default settings and cannot be overridden. However, you can specify other PrtType print driver definitions you want to fall into these same categories.

NoBatchSupport: Indicates that the named PrtType items, separated by semicolon, do not really support batch transactions and require special handling.

Example

< BatchPrint >

NoBatchSupport = RTF


OverlayExt

[PrtType:RTF]
OverlayExt

[PrtType:RTF]

OverlayExt = Edit

Parameter | Description
extension | a file extension The default is .ovl

Remarks

The file extension of the RTF overlays.

Example

<PrtType:RTF>

OverlayExt = .ovl

Available

Release | _______
Patch |

Used By


PageNumbers

[PrtType:RTF]
PageNumbers

PageNumbers

[PrtType:RTF]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

Set to Yes to enable form or form set page numbering.

Example

<PrtType:RTF>

PageNumbers = No

Available

Release | _______
Patch |

Used By


PreLoadRequired

[PrtType:RTF]
PreLoadRequired

PreLoadRequired

You can generate separate files for each transaction when you choose RTF (or PDF) from WIP or batch print.

The name of the files will have a rolling number appended to the end of the name that starts the process and is filled in on the Print window. This is automatically handled and you do not have to set INI options to get the WIP or batch print to work as long as your PrtType name is PrtType:RTF.

There are several INI options you can use to override the naming process and also name other print drivers that require this unique handling.

< BatchPrint >

NoBatchSupport = RTF

PreLoadRequired= RTF

These are the default settings and cannot be overridden. However, you can specify other PrtType print driver definitions you want to fall into these same categories.

PreLoadRequired: Lets you specify all the PrtType items, separated by semicolon, that should be forced to load the form set prior to the starting print. Most print drivers don't require this special requirement, but some, such as PDF do.

Example

< BatchPrint >

PreLoadRequired= RTF


PrePrintedPaper

[PrtType:RTF]
PrePrintedPaper

[PrtType:RTF]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enabled or Hidden determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Yes or No determines whether this check box is checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option (Yes,Enabled) includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:RTF>

PrePrintedPaper = No,Hidden

Available

Release | _______
Patch |

Used By


PrintFunc

[PrtType:RTF]
PrintFunc

[PrtType:RTF]

PrintFunc = Edit

Parameter | Description
value | The default value is RTFPrint

Remarks

The name of the program function that is the main entry point into the RTF print driver. Enter the name of function within the print driver for print.

Example

<PrtType:RTF>

PrintFunc = RTFPrint

Available

Release

Patch

Used By


RemoveEmbeddedLogos

[PrtType:RTF]
RemoveEmbeddedLogos

[PrtType:RTF]

RemoveEmbeddedLogos = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

This setting is used when converting RTF files into section (FAP) files.

When this option is set to yes, the system will create separate graphic (LOG) files.

These files are named according to the name in the input document.

Many times, the graphic names are a computer generated ID.

When this option is set to no, the graphics are embedded into the section (FAP) file itself.

Embedded graphics can be removed later by editing the FAP and replacing the graphic or un-checking the embedded option for the graphic.

Example

<PrtType:RTF>

RemoveEmbeddedLogos = Yes

Available

Release | 11.5
Patch |

Used By


ReplaceFAPHeadFoot

[PrtType:RTF]
ReplaceFAPHeadFoot

[PrtType:RTF]

ReplaceFAPHeadFoot = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

No means to keep size of the headers and footers from the original form when importing an RTF file.

Yes mean to override the size of the headers and footers from the original form when importing an RTF file.

Example

<PrtType:RTF>

ReplaceFAPHeadFoot = Yes

Available

Release | _______
Patch |

Used By


RTFCompatibilityOptions

[PrtType:RTF]
RTFCompatibilityOptions

RTFCompatibilityOptions

Parameter | Description
Value | The default value is blank

Remarks

RTFCompatibilityOptions provide the ability to insert RTF compatibility option commands into the RTF output file. The RTF Compatibility Options are documented in the RTF Specification manuals.

Example

<PrtType:RTF>

RTFCompatibilityOptions = \nolead

Available

Release | 11.4
Patch | 7

Used By

RTFLIB


SendColor

[PrtType:RTF]
SendColor

[PrtType:RTF]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default is No,Enabled

Remarks

Set to Yes to enable color printing.

Example

<PrtType:RTF>

SendColor = Yes,Enabled

Available

Release | _______
Patch |

Used By


StreamBufferSize

[PrtType:RTF]
StreamBufferSize

[PrtType:RTF]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:RTF>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


Template

[PrtType:RTF]
Template

[PrtType:RTF]

Template = Edit

Parameter | Description
value | The default is blank.

Remarks

Example

<PrtType:RTF>

Template =

Available

Release | _______
Patch |

Used By


TemplateFields

[PrtType: ]
TemplateFields

[PrtType:XXX]

TemplateFields = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

Set to Yes to test print test print templates for empty variable fields. This option contains two parameters, separated by a comma ",".

The first parameter is Yes or No (default). Set the first parameter to Yes to template field print.

The second parameter is Enabled (default), Disabled, or Hidden.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window.

By default the system templates fields with the field name starting with release 12.1 rather than X’s. Some print outputs such as PDF already did this. Since the field name may not exactly fit the dimensions of the field, it is surrounded by square brackets placed at the extremes of the field-defining rectangle. You can change this behavior by defining settings:

<Control>

TemplateWithName=No

Example

<PrtType:XXX>

TemplateFields = Yes, Disabled

Available

Release

Patch

Used By


TermFunc

[PrtType:RTF]
TermFunc

[PrtType:RTF]

TermFunc = Edit

Parameter | Description
Edit | The default is blank.

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Example

<PrtType:RTF>

TermFunc = RTFTerm

Available

Release | _______
Patch |

Used By


Text

[PrtType:RTF]
Text

[PrtType:RTF]

Text = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Enter No if you want to omit these kind of objects from the RTF file.

Example

<PrtType:RTF>

Text = No

Available

Release | _______
Patch |

Used By


TextMerge

[PrtType:RTF]
TextMerge

[PrtType:RTF]

TextMerge = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Enter No if you want to omit these kind of objects from the RTF file.

Example

<PrtType:RTF>

TextMerge = No

Available

Release | _______
Patch |

Used By


UseFORFile

[PrtType:RTF]
UseFORFile

UseFORFile

[PrtType:RTF]

UseFORFile = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

Set to Yes to create a FOR definition with separate images for the headers, footers, and body..

Example

<PrtType:RTF>

UseFORFile = Yes

Available

Release | 11.4
Patch |

Used By

RTFLIB


Vector

[PrtType:RTF]
Vector

[PrtType:RTF]

Vector = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Enter No if you want to omit these kind of objects from the RTF file.

Example

<PrtType:RTF>

Vector = No

Available

Release | _______
Patch |

Used By


WriteFrames

[PrtType:RTF]
WriteFrames

WriteFrames

[PrtType:RTF]

WriteFrames = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

By default, the RTF print driver uses frames to replicate the look of a document. If you do not want the frames, which print as boxes around the various document objects, to appear, set the WriteFrames option to No.

This option is turned on by default and causes the resulting output to maintain layout fidelity. WYSIWYG. "Frames" are a Word (and RTF) method of defining "fixed" object locations. Essentially, this creates a box or "frame" for each object to live within in the resulting document. The result is that the output looks very much like the original formset does in WIP or Archive.

For instance, you can use the RTF driver to print form sets to an RTF file. Once the RTF file is created, you can then open it in a word processor. To avoid having frames in the file, you would set this option to No.

If you turn this option off, the resulting output will contain the data, but may not format in the same way, or in the same places, as your original document when loaded into Word.

Example

[PrtType:RTF]

WriteFrames = No

Available

Release | _______
Patch |

Used By

RTFLIB


PrtType:VPP

PrtType:
VPP

Remarks

Variable Data Intelligent PostScript PrintWare (VIPP) is based on PostScript and works by extending the PostScript programming language.

VIPP can be used on any PostScript compatible printer, including Xerox and third-party network, workgroup, and production devices that have been licensed for VIPP.

VIPP is supported on these devices:

• DocuPrint NPS (monochrome and color)

• DocuPrint N-series

• DocuSP controllers, including iGen3

• DocuColor, EFI, and Creo controllers, (including iGen3)

The Documaker VIPP print driver requires that you have VIPP version 5.3 or later installed on your printer’s controller. To use the Documaker VIPP print driver, any supported device must have a local file system you can access to transfer resource files.

The Documaker VIPP print driver produces native mode VIPP output. Native mode refers to files composed solely of VIPP commands. VIPP commands are used to place text, lines, boxes, shades, and graphics directly on the page. Native mode is the default VIPP mode.

A VIPP print job can refer to external resource files such as fonts, TIFF and JPEG graphics files, and page overlays (segments). The resource files referenced by a Documaker VIPP job are:

• Pictures (images) in TIFF or JPEG format

• Overlays (segments) in VIPP format

• PostScript Fonts

• Font encoding tables

NOTE: All VIPP resource files stored on the VIPP console that are referenced by a Documaker VIPP job must have lower case file names.

The Documaker VIPP print driver assumes that mono-color (1 bit per pixel) logos have been converted into TIFF format and multi-color (more than 1 bit per pixel) logos have been converted into JPEG format. Use Logo Manager, Conversion Wizard in Documaker Studio, Docutoolbox or command line utilities (LOG2TIF or LOG2JPEG) to convert your mono-color (1 bit per pixel) logos into TIFF files or to convert your multi-color (more than 1 bit per pixel) logos into JPEG files

You can use the OVLCOMP utility to convert Documaker FAP files into VIPP segment files. You will need a FSISYS.INI file in the directory that you run the OVLCOMP utility from. Within the FSISYS.INI file, you should have a VIPP printer group defined. For example, below is a subset of the INI settings you might find in a VIPP printer group.

<PrtType:VPP>

Module = VPPW32

OverlayExt = .seg

PrintFunc = VPPPrint

SendOverlays = Yes,Enabled

While VIPP supports any font type (Type 1, Type 3, and composite) supported by the PostScript interpreter, Documaker only supports Type 1 PostScript fonts. The PostScript fonts you use must be defined in your font cross-reference (FXR) file.

If you are using a base FXR file, like REL103.FXR or REL110.FXR, the base PostScript fonts are already set up for you in the FXR file. The same PostScript fonts used for printing with the Documaker PostScript print driver are also used with the Documaker VIPP print driver.

If you are using a custom FXR file and you have not set up your FXR file for printing PostScript, then you will need to add the PostScript fonts to your FXR file. You can use the Import feature in Font Manager to import PostScript fonts into your FXR file. The primary fields used by the PostScript and VIPP print drivers are the Codepage field on the Dimensions tab, and the Font File, Font Name, and Char Set ID fields in the PostScript section of the Printers tab.

VIPP font encoding files serve a similar purpose as the Documaker CODEPAGE.INI file and the Codepage and Char Set ID settings in the font cross-reference file. The Documaker VIPP print driver uses the Codepage setting for each font in the font crossreference to determine the name of the encoding file to use. The Documaker VIPP print driver appends the letters cp to the value of the code page setting for each font in the font cross-reference to determine the name of the VIPP font encoding file. Therefore, if a font has a Codepage setting of 1004, then the Documaker VIPP print driver will use a VIPP font encoding file called cp1004.

These VIPP encoding files are provided to correspond to the code pages used by the base Documaker font cross-reference files:

The VIPP encoding file, cp1004, is used for fonts that use the standard Windows ANSI code page. Most text fonts will use this.

The VIPP encoding file, cp9998, is used for the DocuDings font (clone of Wingdings).

The VIPP encoding file, cp9999, is used for the base MICR font.

VIPP provides a mechanism called VIPP Projects that all you to manage all of the resources needed for a VIPP print job.

VIPP Projects allow you to organize the resources of a job under a single name (the project) and group the jobs by family (the folder).

A folder is a collection of projects that share some common features. For example, you may decide to create one folder for each customer, each division, or each line of business. Within each folder, you could define multiple projects. A folder can contain common resources (company logo, standard boilerplate page segments, and so on) that are shared by the projects within the folder. The projects will contain resources that are unique to the project. You can also have resources that global across all projects and folders. Having multiple folders and projects provide a great deal of flexibility in how you organize and share your resources. Folders and projects can even provide the logical grouping of the physical resources used by the job at one or more steps during in the job life cycle (development, testing, production, and so on).

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

DSCHeaderComment = %%DocumentMedia:Media1 612 792 75 (White)(Plain)

DSCHeaderComment = %%+ Media2 612 792 75 (Yellow)(Plain)

DSCHeaderComment = %%+ Media3 612 792 75 (Pink)(Plain)

DSCHeaderComment = %%+ Media4 612 792 75 (White)(Drilled)

Folder = head-office

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Project = monthly-report

ProjectPath = /usr/xgfc/$$FOLDER./$$PROJECT./

ProjectPath = /usr/xgfc/$$FOLDER./fshared/

ProjectPath = /usr/xgfc/gshared/

ProjectPath = /usr/xgfc/fontlib/

ProjectPath = /usr/xgf/encoding/

ProjectPath = /usr/xgf/gshared/

ProjectPath = /opt/XRXnps/resources/ps/mislib/

Resolution = 300

SelectRecipients = No,Enabled

SendColor = No,Hidden

SendOverlays = Yes,Enabled

TemplateFields = No,Disabled

Tray1 = Plain:White:75

Tray2 = Plain:Yellow:75

Tray3 = Plain:Pink:75

Tray4 = Drilled:White:75

PrtType:VPP Options

  • CacheFiles
  • CacheLogos
  • Class
  • Device
  • DownLoadFonts
  • DSCHeaderComment
  • Folder
  • HighlightColor
  • InitFunc
  • Module
  • OverlayExt
  • OverlayPath
  • PageNumbers
  • PrePrintedPaper
  • PrintFunc
  • Project
  • ProjectPath
  • Resolution
  • SelectRecipients
  • SendColor
  • SendOverlays
  • SetParams
  • StreamBufferSize
  • TemplateFields
  • TermFunc
  • Tray1
  • Tray2
  • Tray3
  • Tray4
  • Tray5
  • Tray6
  • Tray7
  • Tray8
  • Tray9
  • Watermark


CacheFiles

[PrtType:VPP]
CacheFiles

[PrtType:VPP]

CacheFiles = Spin

Parameter | Description
number | Default value is: 0 (zero)

Remarks

Set to enable the caching of VIPP segments and images. The first x number of VIPP segments and images in the print job are cached. The default is 0 (zero).

Example

<PrtType:VPP>

CacheFiles = 0

Available

Release | _______
Patch |

Used By


CacheLogos

[PrtType:VPP]
CacheLogos

[PrtType:VPP]

CacheLogos = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Set to enable the caching of VIPP images if CacheFiles is also enabled (see CacheFiles ). The default is No.

Example

<PrtType:VPP>

CacheLogos = Yes

Available

Release | _______
Patch |

Used By


Class

[PrtType:VPP]
Class

[PrtType:VPP]

Class = List

Parameter | Description
value | The default value is VPP

Remarks

Specify the printer classification, such as AFP, PCL, XER, PST, GDI, or VPP.

If you omit this option, the system defaults to the first three letters from the Module option.

Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

Available

Release | 11.1
Patch |

Used By

VPPLIB


Device

[PrtType:VPP]
Device

[PrtType:VPP]

Device = Edit

Parameter | Description
value | device or file name. The default value is blank.

Remarks

Specify the name of the file or device (LPT1) where the VIPP print stream should be written.

This setting is ignored by the GenPrint program but is used by the Image Editor and other system programs.

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

Available

Release | 11.1
Patch |

Used By

VPPLIB


DownLoadFonts

[PrtType:VPP]
DownLoadFonts

[PrtType:VPP]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Set to Yes to embed (download) PostScript fonts within the VIPP print stream. Set to No if you have loaded the PostScript fonts onto the VIPP controller. The default is Yes but you will get better performance if you set this option to No.

This option contains two parameters, separated by a comma ",". The first parameter is Yes (default) or No. Set the first parameter to Yes to enable use of PostScript fonts as VIPP resources.

The second parameter is Enabled (default), Disabled, or Hidden.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window .

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes,Disabled

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

SendColor = Yes,Disabled

Available

Release | 11.1
Patch |

Used By

VPPLIB


DSCHeaderComment

[PrtType:VPP]
DSCHeaderComment

[PrtType:VPP]

DSCHeaderComment = Edit

Parameter | Description
value | The default is to leave blank.

Remarks

Use the DSCHeaderComment option to specify PostScript Document Structure Convention (DSC) comments you want added to the header portion of the generated VIPP print stream. You can include as many DSCHeaderComment options as are necessary.

The following example shows how, in addition to specifying media commands in the Tray# options, you can also include DSC comments you want added to the header portion of the generated VIPP print stream:

<PrtType:VIPP>

DSCHeaderComment = %%DocumentMedia:Media1 612 792 75 (White) (Plain)

DSCHeaderComment = %%+ Media2 612 792 75 (Yellow) (Plain)

DSCHeaderComment = %%+ Media3 612 792 75 (Pink) (Plain)

DSCHeaderComment = %%+ Media4 612 792 75 (White) (Drilled)

Tray1 = Plain:White:75

Tray2 = Plain:Yellow:75

Tray3 = Plain:Pink:75

Tray4 = Drilled:White:75

The form of the DocumentMedia DSC comment is % Key:

<Tag Name> <width> <height> <weight> <color> <type>

Tag Name is any unique name, ignored by VIPP; Width represents the width of paper stock, measured in 1/72” units; Height is the height of paper stock, measured in 1/72” units; Color is the color of paper stock, any alphanumeric string; Type is the type of paper stock, any alphanumeric string.

The DSC header comments are added at the beginning of the generated VIPP print stream as shown here:

%!

%%Title: INSURED

%%Creator: Documaker VIPP Driver

%%CreationDate: Wed Jul 13 11:55:34 2005

%%DocumentMedia:Media1 612 792 75 (White) (Plain)

%%+ Media2 612 792 75 (Yellow) (Plain)

%%+ Media3 612 792 75 (Pink) (Plain)

%%+ Media4 612 792 75 (White) (Drilled)

%%EndComments

Example

<PrtType:VPP>

DSCHeaderComment = %%DocumentMedia:Media1 612 792 75 (White) (Plain)

DSCHeaderComment = %%+ Media2 612 792 75 (Yellow) (Plain)

DSCHeaderComment = %%+ Media3 612 792 75 (Pink) (Plain)

DSCHeaderComment = %%+ Media4 612 792 75 (White) (Drilled)

Tray1 = Plain:White:75

Tray2 = Plain:Yellow:75

Tray3 = Plain:Pink:75

Tray4 = Drilled:White:75

Available

Release | 11.1
Patch |

Used By

VPPLIB


Folder

[PrtType:VPP]
Folder

[PrtType:VPP]

Folder = Edit

Parameter | Description
value | The default is blank

Remarks

Use the Folder option to name the high level directory (folder) under which a project may appear.

VIPP uses a configuration file called xgfunix.run (stored in the /usr/xgf/src directory) to define a list of libraries (directories) for projects.

In the xgfunix.run file, you might see a SETPPATH (VIPP command) that looks like this:

[ (/usr/xgfc/$$FOLDER./$$PROJECT./) % project local paths

(/usr/xgfc/$$FOLDER./fshared/) % project folder shared paths

(/usr/xgfc/gshared/) % project global shared paths

(/usr/xgfc/fontlib/) % project access to font lib

(/usr/xgf/encoding/) % project access to standard encoding

(/usr/xgf/gshared/) % project global shared path

(/opt/XRXnps/resources/ps/mislib/) % project access to DocuSP resource list

] SETPPATH

SETPPATH is a VIPP command that defines a list of libraries (directories) for projects. The "$$FOLDER." and "$$PROJECT." strings as place holders for project folders and project names.

You can use the "projects" directory for your main folder or create your folder directory. Of course, the name of the directory for your local project resources can be anything you wish.

Let’s say you wanted to create a series of projects for the head office. Your VIPP projects repository might look like this:

/xgfc (parent of folder)

…………./gshared global-shared resources

…………./head-office (folder)

…………./fshared folder-shared resources

……………………………../monthly-report local resources for monthly report project

……………………………../quarterly-report local resources for quarterly report project

…………………………..../annual-report local resources for annual report project

Of course, you would need to create the directory along with the subdirectories for the "fshared", "monthly-report", "quarterly-report", and "annual-report" on the VIPP controller. And you would need to transfer the VIPP resource files (images, segments, fonts, etc) into the appropriate directories.

However, before you can produce one of the reports for the head office, you will need to tell the Documaker VIPP print driver which VIPP folder and project names this report will use. You do this by specifying two INI settings, Folder and Project, in your VIPP printer INI group.

The Folder = INI setting contains the name of the high level directory (folder) under which a project may appear.

The value set in the Folder INI setting will be substituted automatically as the $$FOLDER string in the SETPPATH statement found in the xgfunix.run file on the VIPP controller.

The Project = INI setting contains the name of the directory where local resources for a project will reside.

The value set in the Project INI setting will be substituted automatically as the $$PROJECT string in the SETPPATH statement found in the xgfunix.run file on the VIPP controller.

Using the example described earlier, let’s say that you wanted to produce a monthly report for the head office. In that case, you would use the following Folder and Project settings:

<PrtType:VIPP>

Folder = head-office

Project = monthly-report

Example

<PrtType:VPP>

Folder = head-office

Project = monthly-report

Module = VPPW32

PrintFunc = VPPPrint

Class = VPP

Device = .\data\output.vpp

Available

Release | 11.1
Patch |

Used By

VPPLIB


HighlightColor

[PrtType:VPP]
HighlightColor

[PrtType:VPP]

HighlightColor = No

Parameter | Description
Boolean (No) | Yes | No The default value is No

Remarks

Set to Yes to enable highlight color support. The default is No. If you set this option to Yes, you must also set the SendColor option to Yes.

Example

<PrtType:VPP>

HighlightColor = Yes

Available

Release | _______
Patch |

Used By


InitFunc

[PrtType:VPP]
InitFunc

[PrtType:VPP]

InitFunc = Edit

Parameter | Description
value | The default is VPPInit

Remarks

The InitFunc option names the printer function called at the initial printing.

Example

<PrtType:VPP>

InitFunc = VPPInit

Available

Release | _______
Patch |

Used By


Module

[PrtType:VPP]
Module

[PrtType:VPP]

Module = Edit

Parameter

Description

List

Values can be

  • VPPW32 - VIPP print driver program module

The default value is PCLW32

Remarks

Specify the name of the program module that contains the VIPP print driver. This option is required for the VIPP print driver to work. The default is PCLW32, but you must enter VPPW32 to use the VIPP print driver.

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

Available

Release | 11.1
Patch |

Used By

VPPLIB


OverlayExt

[PrtType:VPP]
OverlayExt

[PrtType:VPP]

OverlayExt = Edit

Parameter | Description
file extension | The default value is .ovl

Remarks

Specify the file extension of the VIPP overlays (segments).

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

Available

Release | 11.1
Patch |

Used By

VPPLIB


OverlayPath

[PrtType:VPP]
OverlayPath

[PrtType:VPP]

OverlayPath = Path

Parameter | Description
value | The default is blank.

Remarks

Example

<PrtType:VPP>

OverlayPath =

Available

Release | _______
Patch |

Used By


PageNumbers

[PrtType:VPP]
PageNumbers

[PrtType:VPP]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Set to Yes to enable form or form set page numbering.

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

Available

Release | 11.1
Patch |

Used By

VPPLIB


PrePrintedPaper

[PrtType:VPP]
PrePrintedPaper

[PrtType:VPP]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enabled or Hidden determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Yes or No determines whether this check box is checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option (Yes,Enabled) includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:VPP>

PrePrintedPaper = No,Hidden

Available

Release | _______
Patch |

Used By


PrintFunc

[PrtType:VPP]
PrintFunc

[PrtType:VPP]

PrintFunc = Edit

Parameter | Description
Edit | The default value is VPPPrint

Remarks

Specify the name of the program function that is the main entry point into the VIPP print driver.

This option is required for the VIPP print driver to work.

The default is PCLPrint, but you must enter VPPPrint. Case is important when using this option, therefore, you must enter it exactly as shown here:

VPPPrint

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

Available

Release | 11.1
Patch |

Used By

VPPLIB


Project

[PrtType:VPP]
Project

[PrtType:VPP]

Project = Edit

Parameter | Description
Edit | The default is blank.

Remarks

Use the Project option to name the directory where local resources for a project will reside.

VIPP uses a configuration file called xgfunix.run (stored in the /usr/xgf/src directory) to define a list of libraries (directories) for projects.

In the xgfunix.run file, you might see a SETPPATH (VIPP command) that looks like this:

[ (/usr/xgfc/$$FOLDER./$$PROJECT./) % project local paths

(/usr/xgfc/$$FOLDER./fshared/) % project folder shared paths

(/usr/xgfc/gshared/) % project global shared paths

(/usr/xgfc/fontlib/) % project access to font lib

(/usr/xgf/encoding/) % project access to standard encoding

(/usr/xgf/gshared/) % project global shared path

(/opt/XRXnps/resources/ps/mislib/) % project access to DocuSP resource list

] SETPPATH

SETPPATH is a VIPP command that defines a list of libraries (directories) for projects. The "$$FOLDER." and "$$PROJECT." strings as place holders for project folders and project names.

You can use the "projects" directory for your main folder or create your folder directory. Of course, the name of the directory for your local project resources can be anything you wish.

Let’s say you wanted to create a series of projects for the head office. Your VIPP projects repository might look like this:

/xgfc (parent of folder)

…………./gshared global-shared resources

…………./head-office (folder)

…………./fshared folder-shared resources

……………………………../monthly-report local resources for monthly report project

……………………………../quarterly-report local resources for quarterly report project

……………………………../annual-report local resources for annual report project

Of course, you would need to create the "head-office" directory along with the subdirectories for the "fshared", "monthly-report", "quarterly-report", and "annual-report" on the VIPP controller. And you would need to transfer the VIPP resource files (images, segments, fonts, etc) into the appropriate directories.

However, before you can produce one of the reports for the head office, you will need to tell the Documaker VIPP print driver which VIPP folder and project names this report will use. You do this by specifying two INI settings, Folder and Project, in your VIPP printer INI group.

The Folder = INI setting contains the name of the high level directory (folder) under which a project may appear.

The value set in the Folder INI setting will be substituted automatically as the $$FOLDER string in the SETPPATH statement found in the xgfunix.run file on the VIPP controller.

The Project = INI setting contains the name of the directory where local resources for a project will reside.

The value set in the Project INI setting will be substituted automatically as the $$PROJECT string in the SETPPATH statement found in the xgfunix.run file on the VIPP controller.

Using the example described earlier, let’s say that you wanted to produce a monthly report for the head office. In that case, you would use the following Folder and Project settings:

<PrtType:VIPP>

Folder = head-office

Project = monthly-report

Example

<PrtType:VPP>

Folder = head-office

Project = monthly-report

Module = VPPW32

PrintFunc = VPPPrint

Class = VPP

Device = .\data\output.vpp

Available

Release | 11.1
Patch |

Used By

VPPLIB


ProjectPath

[PrtType:VPP]
ProjectPath

[PrtType:VPP]

ProjectPath = Edit

Parameter | Description
Edit | The default is blank.

Remarks

Each ProjectPath INI setting defines a path that will be used to define a SETPPATH command that overrides the one found in the xgfunix.run file found on the VIPP controller. The path defined by the first ProjectPath INI setting will be the first directory searched for VIPP resources. If the resource is not found, the path defined by the second ProjectPath will be searched next (and so on).

As mentioned before, VIPP uses a configuration file called xgfunix.run (stored in the /usr/xgf/src directory) to define a list of libraries (directories) for projects.

In the xgfunix.run file, you might see a SETPPATH (VIPP command) that looks like this:

[ (/usr/xgfc/$$FOLDER./$$PROJECT./) % project local paths

(/usr/xgfc/$$FOLDER./fshared/) % project folder shared paths

(/usr/xgfc/gshared/) % project global shared paths

(/usr/xgfc/fontlib/) % project access to font lib

(/usr/xgf/encoding/) % project access to standard encoding

(/usr/xgf/gshared/) % project global shared path

(/opt/XRXnps/resources/ps/mislib/) % project access to DocuSP resource list

] SETPPATH

If you wanted to override the list of project paths with a different set, you can do so by using a series of ProjectPath INI settings. Each ProjectPath INI setting defines a path that will be used to define a SETPPATH command that overrides the one found in the xgfunix.run file found on the VIPP controller. The path defined by the first ProjectPath INI setting will be the first directory searched for VIPP resources. If the resource is not found, the path defined by the second ProjectPath will be searched next (and so on).

The following ProjectPath INI settings would produce the same list of paths as described earlier:

<PrtType:VIPP>

ProjectPath = /usr/xgfc/$$FOLDER./$$PROJECT./

ProjectPath = /usr/xgfc/$$FOLDER./fshared/

ProjectPath = /usr/xgfc/gshared/

ProjectPath = /usr/xgfc/fontlib/

ProjectPath = /usr/xgf/encoding/

ProjectPath = /usr/xgf/gshared/

ProjectPath = /opt/XRXnps/resources/ps/mislib/

When defining your own list of project paths, please be aware of the following limitations and rules:

  • In the Local scope category, $$PROJECT must immediately follow $$FOLDER.
  • A path containing $$PROJECT without $$FOLDER is not allowed.
  • If present, $$FOLDER and $$PROJECT must appear only once in each path.
  • No additional path components are allowed after $$PROJECT.
  • A path ending by $$FOLDER is invalid.
  • There must be at least one path for each category.
  • There may be several paths in each category but they must be defined and grouped by category (local, folder, global) in the SETPPATH list.
  • A folder or project name must appear only once in the trees of directories covered by SETPPATH.
  • When a resource is present with the same name in more than one scope, the order of precedence is: local, folder, global.
  • To improve cross-platform portability, Xerox recommends that FOLDER and PROJECT names do not contain more than 32 characters, and only use the characters "a" to "z", "0" to "9", "." (dot), "-" (dash) and "_" (underscore).

Example

<PrtType:VPP>

Folder = head-office

Project = monthly-report

Module = VPPW32

PrintFunc = VPPPrint

Class = VPP

Device = .\data\output.vpp

ProjectPath = /usr/xgfc/$$FOLDER./$$PROJECT./

ProjectPath = /usr/xgfc/$$FOLDER./fshared/

ProjectPath = /usr/xgfc/gshared/

ProjectPath = /usr/xgfc/fontlib/

ProjectPath = /usr/xgf/encoding/

ProjectPath = /usr/xgf/gshared/

ProjectPath = /opt/XRXnps/resources/ps/mislib/

Available

Release | 11.1
Patch |

Used By

VPPLIB


Resolution

[PrtType:VPP]
Resolution

[PrtType:VPP]

Resolution = Spin

Parameter | Description
number | The default value is 300

Remarks

Specify the dots per inch resolution of the printer that will receive the PostScript data stream.

The VIPP print driver defaults to 300 dpi.

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

Available

Release | 11.1
Patch |

Used By

VPPLIB


SelectRecipients

[PrtType:VPP]
SelectRecipients

[PrtType:VPP]

SelectRecipients = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enter Yes to have the system pre-select this option when the Print window appears. This only applies to the Documaker Workstation/PPS systems.

This option contains two parameters, separated by a comma ",". The first parameter is Yes or No (default). Set the first parameter to Yes to select recipients.

The second parameter is Enabled (default), Disabled, or Hidden.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window .

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes,Disabled

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

SelectRecipients = Yes, Disabled

Available

Release | 11.1
Patch |

Used By

VPPLIB


SendColor

[PrtType:VPP]
SendColor

[PrtType:VPP]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

This option contains two parameters, separated by a comma ",". The first parameter is Yes or No (default). Set the first parameter to Yes to enable color printing.

The second parameter is Enabled (default), Disabled, or Hidden.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window .

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes

SendColor = Yes, Disabled

Available

Release | 11.1
Patch |

Used By

VPPLIB


SendOverlays

[PrtType:VPP]
SendOverlays

[PrtType:VPP]

SendOverlays = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

Use the SendOverlays option to tell the system whether to use the printer overlays. This INI option contains two components: Parameter 1 and Parameter 2, separated by a comma ",".

Use parameter 1 to tell the system whether to use the overlays or not. The value of parameter 1 is Yes or No. The default is No,Enabled. If SendOverlays = Yes is specified, make sure that you have compiled the image files (i.e. FAP files) to the printer language files (i.e. overlays) by running the Conversion Utilities or the Conversion Wizard of Documaker Studio, and also be sure that you have specified the INI option:

<RunMode>

DownloadFAP=No

Performance Tip:

The Genprint program of Documaker Rules Processing System wil usually run faster if SendOverlays=Yes is used.

Use parameter 2 to tell the system whether the "Send overlays" checkbox should be displayed and editable on the "Print" window in Documaker Studio or Documaker Workstation. The values of this parameters are Enabled, Disabled or Hidden. The default is Enabled.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window.

Example

<PrtType:VPP>

Class = VPP

Device = .\Data\Batch1.vpp

DownloadFonts = Yes

Module = VPPW32

OverlayExt = .seg

PageNumbers = Yes

PrintFunc = VPPPrint

Resolution = 300

SendOverlays = Yes,Enabled

Available

Release | 11.1
Patch |

Used By

VPPLIB


SetParams

[PrtType:VPP]
SetParams

[PrtType:VPP]

SetParams = Edit

Parameter | Description
value | The default value is blank.

Remarks

SETPARAMS sets persistent parameters throughout the VIPP print job. Once a parameter has been set with SETPARAMS, that parameter applies to all of the subsequent commands to which it relates.

You can find information on the possible parameters to use in Xerox's VIPP Reference Manual.

Example

<PrtType:VPP>

SetParams =

Available

Release | _______
Patch |

Used By


StreamBufferSize

[PrtType:VPP]
StreamBufferSize

[PrtType:VPP]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:VPP>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType:VPP]
TermFunc

[PrtType:VPP]

TermFunc = Edit

Parameter | Description
value | The default is blank.

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Example

<PrtType:VPP>

TermFunc = VPPTerm

Available

Release | _______
Patch |

Used By


Tray1

[PrtType:VPP]
Tray1

[PrtType:VPP]

Tray1 = Edit

Parameter | Description
value | The default is blank.

Remarks

Use the Tray# (where # is a number from 1 to 9) to specify a media string in the form of "MediaType:MediaColor:MediaWeight".

The MediaType can be named Plain, Transparency, Drilled, etc.

The MediaColor can be any color such as White, Green, Blue, GoldenRod, etc.

The MediaWeight is measured in grams per square meter. Usually, the media weight is set to 75 g/m2 (equivalent to 20 lb paper).

When designing your formset, you may have specified that certain forms use a specific paper tray to ensure that the proper paper (pre-printed forms, colored paper, perforated paper, etc) was used.

To ensure that these forms print on the desired type of paper, you would need to define a unique MediaType, MediaColor, and MediaWeight combination for the paper tray.

This information must be set up on both the printer and in the TRAY# INI settings in your VIPP printer INI group.

For example, let’s say that on your printer, you defined a type of paper will be stored in TRAY1 as having a MediaType of Plain, a MediaColor of Green, and a MediaWeight of 75 g/m2.

In order for your formset to print from that paper tray, you would add the following INI setting to your VIPP printer INI group:

<PrtType:VIPP>

Tray1 = Plain:Green:75

The TRAY# INI settings expect a string in the form of MediaType:MediaColor:MediaWeight

It is possible to specify any of the media attributes as "null" or omit them entirely. When any of the media attributes are omitted or specified as null, those attributes are ignored in the following media selections. This example ignores MediaType.

Tray1 = null:Green:75

If the trailing media attributes are omitted, then the trailing ":" may be omitted as shown in this example:

Tray2 = Plain::

or

Tray2 = Plain:

or

Tray2 = Plain

When any of the media attributes such as type, color, or weight are omitted, the last specification or the default value for that attribute remains in effect. Because it may be difficult for you to know the value of the attribute that remains in effect, omitting or setting media attributes as "null" should be used with caution.

Finally, the TRAY# INI settings can also be specified with just a tray number from 1 to 9. For example, Tray5=1 maps output for tray 5 to tray 1. The system checks the INI setting for overriding Tray1 before it checks the setting for Tray2 and so on. Because of this, do not specify a tray number less than the tray you are overriding.

For example, you should not use a setting of Tray5=6.

<PrtType:VIPP>

Tray1 = Plain:White:75

Tray2 = Plain:Yellow:75

Tray3 = Plain:Pink:75

Tray4 = Drilled:White:75

Tray5 = 1

Tray6 = 1

Example

<PrtType:VPP>

DSCHeaderComment = %%DocumentMedia:Media1 612 792 75 (White) (Plain)

DSCHeaderComment = %%+ Media2 612 792 75 (Yellow) (Plain)

DSCHeaderComment = %%+ Media3 612 792 75 (Pink) (Plain)

DSCHeaderComment = %%+ Media4 612 792 75 (White) (Drilled)

Tray1 = Plain:White:75

Tray2 = Plain:Yellow:75

Tray3 = Plain:Pink:75

Tray4 = Drilled:White:75

Available

Release | 11.1
Patch |

Used By

VPPLIB


Tray2

[PrtType:VPP]
Tray2

[PrtType:VPP]

Tray2 = Edit

Parameter | Description
value | Tray name. The default is blank.

Remarks

For more information see also PrtType:VPP Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:VPP>

Tray1 =

Tray2 =

Tray3 =

Tray4 =

Tray5 =

Tray6 =

Tray7 =

Tray8 =

Tray9 =

Available

Release | _______
Patch |

Used By


Tray3

[PrtType:VPP]
Tray3

[PrtType:VPP]

Tray3 = Edit

Parameter | Description
value | Tray name. The default is blank.

Remarks

For more information see also PrtType:VPP Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:VPP>

Tray1 =

Tray2 =

Tray3 =

Tray4 =

Tray5 =

Tray6 =

Tray7 =

Tray8 =

Tray9 =

Available

Release | _______
Patch |

Used By


Tray4

[PrtType:VPP]
Tray4

[PrtType:VPP]

Tray4 = Edit

Parameter | Description
value | Tray name. The default is blank.

Remarks

For more information see also PrtType:VPP Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:VPP>

Tray1 =

Tray2 =

Tray3 =

Tray4 =

Tray5 =

Tray6 =

Tray7 =

Tray8 =

Tray9 =

Available

Release | _______
Patch |

Used By


Tray5

[PrtType:VPP]
Tray5

[PrtType:VPP]

Tray5 = Edit

Parameter | Description
value | Tray name. The default is blank.

Remarks

For more information see also PrtType:VPP Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:VPP>

Tray1 =

Tray2 =

Tray3 =

Tray4 =

Tray5 =

Tray6 =

Tray7 =

Tray8 =

Tray9 =

Available

Release | _______
Patch |

Used By


Tray6

[PrtType:VPP]
Tray6

[PrtType:VPP]

Tray6 = Edit

Parameter | Description
value | Tray name. The default is blank.

Remarks

For more information see also PrtType:VPP Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:VPP>

Tray1 =

Tray2 =

Tray3 =

Tray4 =

Tray5 =

Tray6 =

Tray7 =

Tray8 =

Tray9 =

Available

Release | _______
Patch |

Used By


Tray7

[PrtType:VPP]
Tray7

[PrtType:VPP]

Tray7 = Edit

Parameter | Description
value | Tray name. The default is blank.

Remarks

For more information see also PrtType:VPP Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:VPP>

Tray1 =

Tray2 =

Tray3 =

Tray4 =

Tray5 =

Tray6 =

Tray7 =

Tray8 =

Tray9 =

Available

Release | _______
Patch |

Used By


Tray8

[PrtType:VPP]
Tray8

[PrtType:VPP]

Tray8 = Edit

Parameter | Description
value | Tray name. The default is blank.

Remarks

For more information see also PrtType:VPP Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:VPP>

Tray1 =

Tray2 =

Tray3 =

Tray4 =

Tray5 =

Tray6 =

Tray7 =

Tray8 =

Tray9 =

Available

Release | _______
Patch |

Used By


Tray9

[PrtType:VPP]
Tray9

[PrtType:VPP]

Tray9 = Edit

Parameter | Description
value | Tray name. The default is blank.

Remarks

For more information see also PrtType:VPP Tray1 .

Example

If not otherwise specified these are the defaults:

<PrtType:VPP>

Tray1 =

Tray2 =

Tray3 =

Tray4 =

Tray5 =

Tray6 =

Tray7 =

Tray8 =

Tray9 =

Available

Release | _______
Patch |

Used By


PrtType:XER

PrtType:
XER

Remarks

Xerox created the Metacode printer language which is used to print on a Metacode printer. A JSL (Job Source Library) file resides on the printer that contains the printer configuration (in the form of individual entries called JDE (Job Descriptor Entries) that are used for certain jobs. To use it, you have to first compile the JSL (Job Source Library) to what is called a JDL (Job Descriptor Library). Then, when you get ready to print, you start that compiled JDL, then print, and the JDE's are used. Documaker is very flexible since it can use dynamic JDEs, called DJDE for Dynamic Job Descriptor Entries, which overwrite the JDEs on the printer for just a particular Metacode page.

PrtType:XER Options

  • AdditionalDJDE
  • AutoSize
  • CacheFAPFiles
  • CacheFiles
  • ChartResolution
  • ChartSegMax
  • Class
  • CodeDef
  • ColorCharts
  • CommentRecords
  • CompileInStream
  • CompressMode
  • DefaultEndChar
  • DefaultFont
  • DefReplaceChar
  • Device
  • DJDECarrControl
  • DJDEFontFile
  • DJDEIden
  • DJDELevel
  • DJDEOffset
  • DJDESkip
  • DocuSaveScript
  • DownLoadFonts
  • DuplicateCommonFonts
  • Environment
  • FAPLogicalBottom
  • FastSearch
  • FieldScope
  • ImageOpt
  • ImageOptNotSet
  • InitFunc
  • JDEName
  • JDLCode
  • JDLData
  • JDLHost
  • JDLName
  • JDLROffset
  • JDLRPage
  • JDLRStack
  • KeepBlankPages
  • Loader
  • LogicalBottom
  • LogoPrefix
  • ManualLogicalBottom
  • MaxError
  • MaxFonts
  • MOBIUS
  • ModifyFile
  • Module
  • MultipleOText
  • Normalize
  • OffsetLevel
  • Optimize
  • OTextString
  • OutMetFunc
  • OutMode
  • OutputFunc
  • OutputMod
  • OverlayExt
  • PageNumbers
  • PaperSize
  • PMetLib
  • PrePrintedPaper
  • PrinterInk
  • PrinterModel
  • PrintFunc
  • PrintViewOnly
  • RelativeScan
  • Resolution
  • RuleFilePool
  • SaveComment
  • SendColor
  • SendOverlays
  • SkipMaxLen
  • StapleJDEName
  • StreamBufferSize
  • TemplateFields
  • TermFunc
  • Tray
  • Tray1
  • Tray2
  • Tray3
  • Tray4
  • Tray5
  • Tray6
  • Tray7
  • Tray8
  • Tray9
  • UniqueFieldNames
  • ValidLevel
  • VSAM
  • Watermark


AdditionalDJDE

[PrtType:XER]
AdditionalDJDE

AdditionalDJDE

1366 GREATER CONTROL OVER METACODE PRINTING

[PrtType:XER]

AdditionalDJDE = Edit

Parameter | Description
value | The default is blank.

Remarks

Now you can add additional DJDE statements via the AdditionalDJDE option in the PrtType:XER control group.

You can place the new AdditionalDJDE option anywhere in the PrtType:XER control group. Each AdditionalDJDE value represents a distinct and separate DJDE statement, given verbatim. You can include as many AdditionalDJDE statements as needed. The system inserts all of the additional DJDE statements into the print stream.

You can also specify the batch in which to output the DJDE statement. Here is an example:

<PrtType:XER>

AdditionalDJDE = "BATCH1";FEED=COVER,;

InitFunc = XERInit

...

AdditionalDJDE = "BATCH1";STOCKS=BLUE,;

...

AdditionalDJDE = JDL=DPLJDL,JDE=STRTON,;

The first two occurrences only apply to the BATCH1 batch. The third occurrence has no batch specified, so this DJDE statement is written to all print batches.

Keep in mind that these user-defined DJDE statements are placed after the BEGIN DJDE record and before the other DJDEs that are always inserted, such as FONTS. Make sure the DJDE syntax is correct and that the new DJDE records do not interfere with the ones automatically inserted into the print stream by the system.

Also, it is very important that you follow the correct syntax when coding the INI line. If you enter an invalid batch name, no corresponding batch will be found and the DJDE line will be ignored or not output in any batch. And, if the DJDE syntax is incorrect, unpredictable results may occur.

Example

<PrtType:XER>

AdditionalDJDE = "BATCH1";FEED=COVER,;

Available

Release | 10.1
Patch | 354


AutoSize

[PrtType:XER]
AutoSize

AutoSize

[PrtType:XER]

AutoSize = YN

Parameter | Description
boolean | Yes | No Default value is: No

Remarks

To have the system automatically size the FAP files, set the AutoSize INI option to Yes.

Feature 1671 lets you tell the system whether to automatically size FAP files converted from Metacode files, (usually Documerge EDL members). You can create the FAP files as custom sized images that are the minimum size required to contain all of the converted objects from the Metacode file.

If you omit this option, the system creates full page size images.

Keep in mind: The system will not automatically size the image if the converted Metacode file results in a multi-page image.

If the image is automatically sized and the result is a custom sized image, the Metacode loader does not try to determine if the image is landscape and does not rotate landscape objects.

Example

<PrtType:XER>

AutoSize = Yes

Available

Release | 11.0
Patch | 7

Used By

XERLIB


BPSDReport

[PrtType:XER]
BPSDReport

BPSDReport

[PrtType:XER]

BPSDReport = file

Parameter | Description
file | filename to write when producing BPSD report

Remarks

By adding this setting, a metacode conversion will produce a listing of the BPSD tag field names from the input file and the subsequently created FAP field names.

Example

<PrtType:XER>

BPSDReport = file

Available

Release

Patch

Used By

XERLIB


CacheFAPFiles

[PrtType:XER]
CacheFAPFiles

CacheFAPFiles

[PrtType:XER]

CacheFAPFiles = Edit

Parameter | Description
number | The default is 100.

Remarks

Specifies the number of FAP members to keep available for re-use without re-loading them from disk. This option is in the CONTROL control group in the FSISYS.INI file.

MET files contain pre-compiled Metacode information produced by the FAP2MET utility. The GenPrint program loads MET members from the PMETLIB PDS under MVS. On other platforms, the PMetLib option specifies the directory containing the pre-compiled MET files. Default is 100.

Example

<PrtType:XER>

CacheFAPFiles = 100

Available

Release | _______
Patch |

Used By

XERLIB


CacheFiles

[PrtType:XER]
CacheFiles

CacheFiles

[PrtType:XER]

CacheFiles = Edit

Parameter | Description
number | The default value is 100

Remarks

MET files contain pre-compiled Metacode information produced by the FAP2MET utility.

The GenPrint program loads MET members from the PMETLIB PDS under MVS. On other platforms, the PMetLib option specifies the directory containing the pre-compiled MET files. Default is 100. If not set, the system uses the setting for the FormLib option in the MasterResource control group. The CacheFiles option keeps frequently used MET members available for re-use. This option is placed in the PrtType:XER control group in the FSISYS.INI file, as shown below:

Caching pre-compiled Metacode files (PMETs) has a big effect on the GenPrint program. Here is an example of where you can set the cache for pre-compiled Metacode files:

<PrtType:XER>

CacheFiles = 100

InitFunc = XERInit

TermFunc = XERTerm

NOTE: You must include the InitFunc and TermFunc options in the PrtType:XER control group to enable caching.

Example

<PrtType:XER>

CacheFiles = 100

InitFunc = XERInit

TermFunc = XERTerm

Available

Release | 10.0
Patch |

Used By

XERLIB


CFAPDark

[PrtType:XER]
CFAPDark

[PrtType:XER]

CFAPDark = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight
  • MetMed
  • MetDark (default)

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files.

Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating highlight color Metacode shaded boxes from FAP color shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

CFAPLightest = MetLight

CFAPLighter = MetMed

CFAPLight = MetMed

CFAPMed = MetMed

CFAPDark = MetDark

CFAPDarker = MetDark

CFAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

CFAPDarker

CFAPDarkest

CFAPLight

CFAPLighter

CFAPLightest

CFAPMed


CFAPDarker

[PrtType:XER]
CFAPDarker

[PrtType:XER]

CFAPDarker = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight
  • MetMed
  • MetDark (default)

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files.

Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating highlight color Metacode shaded boxes from FAP color shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

CFAPLightest = MetLight

CFAPLighter = MetMed

CFAPLight = MetMed

CFAPMed = MetMed

CFAPDark = MetDark

CFAPDarker = MetDark

CFAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

CFAPDark

CFAPDarkest

CFAPLight

CFAPLighter

CFAPLightest

CFAPMed


CFAPDarkest

[PrtType:XER]
CFAPDarkest

[PrtType:XER]

CFAPDarkest = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight
  • MetMed
  • MetDark (default)

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files.

Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating highlight color Metacode shaded boxes from FAP color shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

CFAPLightest = MetLight

CFAPLighter = MetMed

CFAPLight = MetMed

CFAPMed = MetMed

CFAPDark = MetDark

CFAPDarker = MetDark

CFAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

CFAPDark

CFAPDarker

CFAPLight

CFAPLighter

CFAPLightest

CFAPMed


CFAPLight

[PrtType:XER]
CFAPLight

[PrtType:XER]

CFAPLight = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight (default)
  • MetMed
  • MetDark

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files.

Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating highlight color Metacode shaded boxes from FAP color shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

CFAPLightest = MetLight

CFAPLighter = MetMed

CFAPLight = MetMed

CFAPMed = MetMed

CFAPDark = MetDark

CFAPDarker = MetDark

CFAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

CFAPDark

CFAPDarker

CFAPDarkest

CFAPLighter

CFAPLightest

CFAPMed


CFAPLighter

[PrtType:XER]
CFAPLighter

[PrtType:XER]

CFAPLighter = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight (default)
  • MetMed
  • MetDark

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files.

Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating highlight color Metacode shaded boxes from FAP color shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

CFAPLightest = MetLight

CFAPLighter = MetMed

CFAPLight = MetMed

CFAPMed = MetMed

CFAPDark = MetDark

CFAPDarker = MetDark

CFAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

CFAPDark

CFAPDarker

CFAPDarkest

CFAPLight

CFAPLightest

CFAPMed


CFAPLightest

[PrtType:XER]
CFAPLightest

[PrtType:XER]

CFAPLightest = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight (default)
  • MetMed
  • MetDark

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files.

Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating highlight color Metacode shaded boxes from FAP color shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

CFAPLightest = MetLight

CFAPLighter = MetMed

CFAPLight = MetMed

CFAPMed = MetMed

CFAPDark = MetDark

CFAPDarker = MetDark

CFAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

CFAPDark

CFAPDarker

CFAPDarkest

CFAPLight

CFAPLighter

CFAPMed


CFAPMed

[PrtType:XER]
CFAPMed

[PrtType:XER]

CFAPMed = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight
  • MetMed (default)
  • MetDark

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files.

Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating highlight color Metacode shaded boxes from FAP color shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

CFAPLightest = MetLight

CFAPLighter = MetMed

CFAPLight = MetMed

CFAPMed = MetMed

CFAPDark = MetDark

CFAPDarker = MetDark

CFAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

CFAPDark

CFAPDarker

CFAPDarkest

CFAPLight

CFAPLighter

CFAPLightest

CFAPLight


ChartResolution

[PrtType:XER]
ChartResolution

ChartResolution

[PrtType:XER]

ChartResolution = LimitList

Parameter | Description
value | 150 | 300 The default is 150

Remarks

Charts are scaled by the printer to their proper size and are printed as 300 dpi (dots per inch) bitmaps.

Because fewer dots are used at these lower dpi settings, you may notice some loss of detail in the printed output and effects such as:

  • The circle which makes up the pie chart is less precise

  • The lines used in a chart are thicker

Test charts printed to see if the loss of detail is acceptable. In general, horizontal and vertical lines scale with little or no loss of precision. Arcs and diagonal lines may lose some detail. By default, charts are rendered at 150 dpi in a Metacode print stream. This setting typically provides for a smaller print stream and optimal performance from the GenPrint program. To disable rendering charts at 150 dpi, add the following option to the Xerox printer control group, usually named PrtType:XER:

ChartResolution = 300

The only other acceptable value for this option is 150. This option does not affect logos printed as inline graphics.

Example

<PrtType:XER>

ChartResolution = 150

Available

Release | _______
Patch |

Used By

XERLIB


ChartSegMax

[PrtType:XER]
ChartSegMax

[PrtType:XER]

ChartSegMax = Edit

Parameter | Description
number | The default value is 32760

Remarks

This setting defines the maximum number of bitmap rows produced for a chart.

This setting should not be changed.

Example

<PrtType:XER>

ChartSegMax = 32760

Available

Release

Patch

Used By


Class

[PrtType:XER]
Class

Class

[PrtType:XER]

Class = List

Parameter | Description
value | The default value is XER

Remarks

You can use the following INI option to specify the printer classification, such as AFP, PCL, XER, PST, GDI, etc.

If you omit this option, the system defaults to the first three letters from the Module option.

Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing. If you omit this option, the system defaults to the first three letters from the Module option.

Example

<PrtType:XER>

Class = XER

Available

Release | _______
Patch |

Used By

XERLIB


CodeDef

[PrtType:XER]
CodeDef

CodeDef

[PrtType:XER]

CodeDef = File

Parameter | Description
File | The default is DCASCII9

Remarks

This option specifies the Codedef file that you use, if processing normalized Metacode. The default CodeDef file is DCASCII9.

For loading and creating Normalized Metacode output, the default CodeDef, which is like an ASCII and EBCDIC translation table, is DCASCII9. To specify another one other than the default shipped one, define the file in the CodeDef INI value, as shown in the example below, in the PrtType INI group. The system loads the file from the directory specified by the DefLib option of the MasterResource control group. The file must be 8 characters in length.

To enable the normalized file feature, please refer to the Normalize option in the Control group and CommonFonts group for detailed information.

Example

<PrtType:XER>

CodeDef = DCASCII9

Available

Release | _______
Patch |

Used By


ColorCharts

[PrtType:XER]
ColorCharts

ColorCharts

[PrtType:XER]

ColorCharts = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

Use the ColorCharts option to print the graphic portion of the chart in color. This option is used with the SendColor and PrinterInk options.

Example

<PrtType:XER>

ColorCharts = Yes

Available

Release | _______
Patch |

Used By

XERLIB


CommentRecords

[PrtType:XER]
CommentRecords

[PrtType:XER]

CommentRecords = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

Use this setting if you are converting metacode files produced by another compositional tool which uses 0x09 carriage controls in front of the header record and index tag records instead of the traditional 0x03 carriage control, which is for a comment record.

Example

<PrtType:XER>

CommentRecords = Yes

Available

Release | _______
Patch |

Used By


CommonFonts

[PrtType:XER]
CommonFonts

CommonFonts

[PrtType:XER]

CommonFonts = Edit

Parameter | Description
value | INI group name qualifier

Remarks

Each Xerox printer INI group can name its own CommonFonts INI group to use.

See CommonFonts and Name1 for more information.

Example

<PrtType:XER>

CommonFonts = Life

<CommonFonts:Life>

...

Available

Release

Patch

Used By


CompileInStream

[PrtType:XER]
CompileInStream

CompileInStream

[PrtType:XER]

CompileInStream = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

Set CompileInstream=No if you want Genprint to use pre-compiled metacode files instead of FAPs. This INI option needs to have the same value as the INI option:

<RunMode>

DownloadFAP =

i.e. if you set CompileInstream=No, set DownloadFAP=No.

Performance Tip:

Genprint will usually run faster if CompileInstream=No is specified.

Specifying Installable Functions

For the Xerox print driver, you must specify the following set of installable functions in the PrtType:XER control group:

OutputFunc = XEROutput

OutMetFunc = XEROutMet

InitFunc = XERInit

TermFunc = XERTerm

Module = XERW32

PrintFunc = XERPrint

The print driver creates the print stream using pre-compiled Metacode files. Use the FAP2MET utility to create pre-compiled Metacode files. The GenPrint program loads pre-compiled Metacode members from the PMETLIB PDS under MVS. On other platforms, the PMetLib option specifies the directory which contains the pre-compiled MET files. If you do not set this option, the system uses the setting for the FormLib option in the MasterResource control group.

For Xerox Metacode printers, set the CompileInstream INI option to No. For Metacode printers, the SendOverLays option has no effect. The time you save on one FAP may not be significant, but the time saved on all FAP files will be.

<PrtType:XER>

CompileInStream = Yes

Example

<PrtType:XER>

CompileInStream = Yes

Available

Release | 10.0
Patch |

Used By

XERLIB


CompressMode

[PrtType:XER]
CompressMode

CompressMode

[PrtType:XER]

CompressMode = LimitList

Parameter

Description

value

Values can be

  • UNC
  • ENC
  • LIN
  • HTN

Default value is: HTN

Remarks

The CompressMode option compresses bitmaps output as inline graphics, such as charts and logos with the inline graphics flag set. There are four compression modes available, which you can specify using the CompressMode option in the PrtType:XER control group:

* CompressMode = UNC

* CompressMode = ENC

* CompressMode = HTN

* CompressMode = LIN

UNC is the uncompressed or raw bitmap mode. If none is specified, the system defaults to HTN mode.

To demonstrate the effects of Metacode graphics compression, the following chart shows the GenPrint program run times and file sizes with the different compression options for a test environment containing in-line images.

Test------------------- GenPrint time---------- File size

No charts (ImageOpt=No)-182 seconds (3:02)----- 697,599

UNC - uncompressed----- 309 seconds (5:09)----- 9,011,058

LIN compression-------- 290 seconds (4:50)----- 1,589,226

ENC compression-------- 301 seconds (5:01)----- 2,248,302

HTN compression-------- 296 seconds (4:56)----- 1,831,050

Which compression method yields the smallest file size or the quickest compression time depends on the graphic bitmaps you are printing. In general, HTN or LIN compression provides the best results. HTN generally does best with graphics which contain more filled-in or shaded areas, while LIN performs better with graphics which contain more line art. Experiment with your images to determine the best compression method.

The results of compression can be dramatic, as the above chart shows. The uncompressed print-ready file is over nine megabytes in size, while the compressed file size ranges from 18% to 25% of the uncompressed file. However, keep in mind that while the reduced file sizes save disk space and reduce transmission times, these files must be decompressed by the printer at print time, which is done automatically by the print controller.

Example

<PrtType:XER>

CompressMode = UNC

CompressMode = ENC

CompressMode = HTN

CompressMode = LIN

Available

Release | _______
Patch |

Used By

XERLIB


DefaultEndChar

[PrtType:XER]
DefaultEndChar

DefaultEndChar

[PrtType:XER]

DefaultEndChar = Edit

Parameter | Description
single character | The default value is: [

Remarks

You can use the DefaultEndChar option to set the default line end character when you are creating new fields on a FAP file that you will later normalize. The default for this optional INI option is a square bracket ( [ ). You can only designate one character and you cannot use an equals sign (=).

Example

<PrtType:XER>

DefaultEndChar = !

Available

Release | 10.2
Patch | 135


DefaultFont

[PrtType:XER]
DefaultFont

[PrtType:XER]

DefaultFont = Edit

Parameter | Description
value | The default value is blank

Remarks

The DefaultFont option defines the default font to use to indicate the names of any graphics in the print-ready Metacode file. The graphics do not display in Image Editor when the print-ready Metacode file is

opened. Instead the name of the graphic appears, in the default font, and the space taken by the graphic is indicated.

In addition, the default font is also used for displaying any text that references a font not present in the font cross-reference file. To set the default font, enter the name of a Xerox font file contained in the font cross-reference file as shown here:

< PrtType:XER >

DefaultFont = FXTIN8

Example

<PrtType:XER>

DefaultFont =

Available

Release | _______
Patch |

Used By


DefReplaceChar

[PrtType:XER]
DefReplaceChar

[PrtType:XER]

DefReplaceChar = Edit

Parameter | Description
single character | The default value is * (an asterisk)

Remarks

The DefReplaceChar is used when the Documerge tag contains a quote (") as the replacement character because the quote character cannot used in Documaker section (FAP) files.

Example

<PrtType:XER>

DefReplaceChar = *

Available

Release | _______
Patch |

Used By


Device

[PrtType:XER]
Device

Device

[PrtType:XER]

Device = Edit

Parameter | Description
value | device or file name. The default value is blank.

Remarks

The name of the printer device you want to use. The name of the file or device (LPT1) where the PCL print stream should be written. This setting is ignored by the GenPrint program but is used by the Image Editor and other system programs.

Example

<PrtType:XER>

Device = filename

Available

Release | _______
Patch |

Used By

XERLIB


DJDECarrControl

[PrtType:XER]
DJDECarrControl

DJDECarrControl

Feature 1450

[PrtType:XER]

DJDECarrControl = Edit

Parameter | Description
value | If you use third party software to read Documaker Metacode files and that software needs the DJDE, RSTACK, and RPAGE commands to begin with a carriage control value other than the default value of 0x01, you can now use the DJDECarrControl option to handle this. Default value is: 1 (X'01')

Remarks

If you use third party software to read Documaker Metacode files and that software needs the DJDE, RSTACK, and RPAGE commands to begin with a carriage control value other than the default value of 0x01, you can now use

the DJDECarrControl option to handle this. You simply enter a value in the form of a string constant. These string constants are supported:

- ASCII (A'string')

- EBCDIC (E'string')

- character ('string')

- hexadecimal (X'string').

Note: The character string produces an EBCDIC string, same as E'string'. The default value is 1 (X'01'). Here is an example:

<PrtType:XER>

DJDECarrControl = X'09'

Keep in mind that any carriage control value will be accepted and no attempt is made to make sure a valid carriage control is used.

Example

<PrtType:XER>

DJDECarrControl = X'09'

Available

Release | 10.2
Patch | 98

Used By


DJDEFontFile

[PrtType:XER]
DJDEFontFile

[PrtType:XER]

DJDEFontFile = File

Parameter | Description
File | The default is blank.

Remarks

The metacode conversion code supports an INI setting that can be used to specify a list of fonts to use when converting a print stream.

Set DJDEFontFile equal to the name of a text file containing a list of fonts (one per line). This will handle the problem of converting a metacode print stream that relies on a PDE that contains a font list.

Example

<PrtType:XER>

DJDEFontFile =

Available

Release | _______
Patch |

Used By


DJDEForceOffsetEnd

[PrtType:XER]
DJDEForceOffsetEnd

[PrtType:XER]

DJDEForceOffsetEnd = YN

Parameter | Description
boolean | Yes | No The default is No

Remarks

Used to force OFFSET,END onto all the DJDE statements. Normally, the first metacode print stream produced will have "DJDE SIDE=NUFRONT,END" while all of the remaining print streams produced will have "DJDE SIDE=(NUFRONT,OFFSET),END". In other words, only one metacode print stream (the first one) will not have "DJDE SIDE=(NUFRONT,OFFSET),END".

Setting this INI option to Yes will force the first DJDE to be set with OFFSET as well.

Example

<PrtType:XER>

DJDEForceOffsetEnd = Yes

Available

Release | 11.3
Patch |

Used By

XERLIB


DJDEIden

[PrtType:XER]
DJDEIden

DJDEIden

[PrtType:XER]

DJDEIden = Edit

Parameter | Description
value | The DJDE identifier. The default is blank.

Remarks

This represents the IDEN statement of the JDL. The value of the DJDEIden setting is a string constant. The types of string constants supported are ASCII (A'string'), EBCDIC (E'string'), Character ('string'), and Hexadecimal (X'string'). Octal, H2, and H6 strings are not supported. Strings containing repeat counts, embedded hexadecimal values, and upper/lower case toggles are not supported. The following table shows the relevant JSL statements for the earlier example and the options to use based on the JSL example.

Example

For a JSL statement with the values of:

| IDEN PRE=A'@@@DJDE',

| OFF=0,

| SKIP=8;

<PrtType:XER>

DJDEIden = A'@@@DJDE'

DJDEOffset = 0

DJDESkip = 8

Available

Release | _______
Patch |

Used By


DJDELevel

[PrtType:XER]
DJDELevel

DJDELevel

[PrtType:XER]

DJDELevel = Edit

Parameter | Description
value | NO | Formset The default is blank which is the same as no formset.

Remarks

In earlier versions of the system, a Metacode print stream began and continued as a simplex job until the system encountered a page that needed to be duplex. At that point, the duplexing option was turned on. From that point forward, the print stream remained in duplex mode. For performance reasons, the system did not switch out of duplex mode. Research showed that for most cases, this was the most efficient way to drive the printer.

If, however, you are directing the printer output stream to a value-added process, you may want to include the actual duplex selection information with each form set. Without the commands to specify the duplex state, some value-added processes may not work properly. By setting the DJDELevel option to Formset, each form set will include a duplex command which specifies either simplex or duplex mode (DJDE DUPLEX=YES or NO always appears at the beginning of every new form set).

A value other than Formset causes the duplex commands to be output as before.

Example

<PrtType:XER>

DJDELevel = Formset

Available

Release | _______
Patch |

Used By

XERLIB


DJDEOffset

[PrtType:XER]
DJDEOffset

DJDEOffset

[PrtType:XER]

DJDEOffset = Spin

Parameter | Description
number | 0 - 255 The default is blank.

Remarks

Represents the IDEN statement of the JDL. The value of the DJDEIden setting is a string constant. The types of string constants supported are ASCII (A'string'), EBCDIC (E'string'), Character ('string'), and Hexadecimal (X'string'). Octal, H2, and H6 strings are not supported. Strings containing repeat counts, embedded hexadecimal values, and upper/lower case toggles are not supported. The following table shows the relevant JSL statements for the earlier example and the options to use based on the JSL example.

Example

For a JSL statement with the values of:

| IDEN PRE=A'@@@DJDE',

| OFF=0,

| SKIP=8;

<PrtType:XER>

DJDEIden = A'@@@DJDE'

DJDEOffset = 0

DJDESkip = 8

Available

Release | _______
Patch |

Used By


DJDESkip

[PrtType:XER]
DJDESkip

DJDESkip

[PrtType:XER]

DJDESkip = Edit

Parameter | Description
number | 0 - 255 The default is blank.

Remarks

Represents the IDEN statement of the JDL. The value of the DJDEIden setting is a string constant. The types of string constants supported are ASCII (A'string'), EBCDIC (E'string'), Character ('string'), and Hexadecimal (X'string'). Octal, H2, and H6 strings are not supported. Strings containing repeat counts, embedded hexadecimal values, and upper/lower case toggles are not supported. The following table shows the relevant JSL statements for the earlier example and the options to use based on the JSL example.

Example

For a JSL statement with the values of:

| IDEN PRE=A'@@@DJDE',

| OFF=0,

| SKIP=8;

<PrtType:XER>

DJDEIden = A'@@@DJDE'

DJDEOffset = 0

DJDESkip = 8

Available

Release | _______
Patch |

Used By


DocuSaveScript

[PrtType:XER]
DocuSaveScript

DocuSaveScript

[PrtType:XER]

DocuSaveScript = Edit

Parameter | Description
value | The default is blank.

Remarks

DocuSaveScript INI option works with Outmode = MRG4 to allow Genprint or Gendata (with InitPrint and PrintFormset rules defined in the afgjob.jdt file) to add user-defined comment records into the metacode printstream.

<PrtType:XER>

DocuSaveScript = script

OutMode = MRG4

Example

<PrtType:XER>

DocuSaveScript = DocuSave.DAL

OutMode = MRG4

Available

Release | _______
Patch |

Used By


DownLoadFonts

[PrtType:XER]
DownLoadFonts

DownLoadFonts

[PrtType:XER]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: No,Enabled

Remarks

This setting is ignored by the Xerox print driver.

Example

<PrtType:XER>

DownLoadFonts = Yes,Enabled

Available

Release | _______
Patch |

Used By


DuplicateCommonFonts

[PrtType:XER]
DuplicateCommonFonts

DuplicateCommonFonts

[PrtType:XER]

DuplicateCommonFonts = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Duplicate common fonts are sometimes needed, and are fully supported by Documerge. The INI option should be placed in the normalizing Metacode printer group, and is called DuplicateCommonFonts. A value of Yes turns on the support; a value of No turns it off. The option defaults to No.

Example

<PrtType:XER>

DuplicateCommonFonts = Yes

Available

Release | 10.2
Patch | 153

Used By


Environment

[PrtType:XER]
Environment

Environment

[PrtType:XER]

Environment =

Parameter | Description
platform | OS22 | MVS | AIX

Remarks

Defines the printer environment. Until version 10.1, the Environment option was required to determine the printer environment. If you are using version 10.1 or greater, you can omit this option. If you are are not using version 10.1 or greater, the only values for this option are OS22, MVS, and AIX.

Use OS22 if the software is being compiled and run on a Windows system. Use MVS if the software is being compiled and run on an MVS system. Likewise, use AIX for AIX systems.

The Environment option determines whether the input strings are in ASCII or EBCDIC format. If you are going from an MVS to a Xerox printer, all the text has to be converted from EBCDIC to ASCII. Below are the additional required options not based on the printer's JSL file.

Example

<PrtType:XER>

Environment = OS22

Available

Release | _______
Patch |

Used By

XERLIB


FAPDark

[PrtType:XER]
FAPDark

[PrtType:XER]

FAPDark = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight
  • MetMed
  • MetDark (default)

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating Metacode shaded boxes from FAP shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

FAPLightest = MetLight

FAPLighter = MetMed

FAPLight = MetMed

FAPMed = MetMed

FAPDark = MetDark

FAPDarker = MetDark

FAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

FAPDarker

FAPDarkest

FAPLight

FAPLighter

FAPLightest

FAPMed


FAPDarker

[PrtType:XER]
FAPDarker

[PrtType:XER]

FAPDarker = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight
  • MetMed
  • MetDark (default)

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating Metacode shaded boxes from FAP shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

FAPLightest = MetLight

FAPLighter = MetMed

FAPLight = MetMed

FAPMed = MetMed

FAPDark = MetDark

FAPDarker = MetDark

FAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

FAPDark

FAPDarkest

FAPLight

FAPLighter

FAPLightest

FAPMed


FAPDarkest

[PrtType:XER]
FAPDarkest

[PrtType:XER]

FAPDarkest = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight
  • MetMed
  • MetDark (default)

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating Metacode shaded boxes from FAP shaded boxes:

Example

For example, you could set up your INI options this way:

< PrtType: XER >

FAPLightest = MetLight

FAPLighter = MetMed

FAPLight = MetMed

FAPMed = MetMed

FAPDark = MetDark

FAPDarker = MetDark

FAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

FAPDark

FAPDarkest

FAPLight

FAPLighter

FAPLightest

FAPMed


FAPLight

[PrtType:XER]
FAPLight

[PrtType:XER]

FAPLight = value

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight (default)
  • MetMed
  • MetDark

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating Metacode shaded boxes from FAP shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

FAPLightest = MetLight

FAPLighter = MetMed

FAPLight = MetMed

FAPMed = MetMed

FAPDark = MetDark

FAPDarker = MetDark

FAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

FAPDark

FAPDarker

FAPDarkest

FAPLighter

FAPLightest

FAPMed


FAPLighter

[PrtType:XER]
FAPLighter

[PrtType:XER]

FAPLighter = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight (default)
  • MetMed
  • MetDark

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating Metacode shaded boxes from FAP shaded boxes:

Example

For example, you could set up your INI options this way:

< PrtType: XER >

FAPLightest = MetLight

FAPLighter = MetMed

FAPLight = MetMed

FAPMed = MetMed

FAPDark = MetDark

FAPDarker = MetDark

FAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

FAPDark

FAPDarker

FAPDarkest

FAPLight

FAPLightest

FAPMed


FAPLightest

[PrtType:XER]
FAPLightest

[PrtType:XER]

FAPLightest = LimitList

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight (default)
  • MetMed
  • MetDark

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating Metacode shaded boxes from FAP shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

FAPLightest = MetLight

FAPLighter = MetMed

FAPLight = MetMed

FAPMed = MetMed

FAPDark = MetDark

FAPDarker = MetDark

FAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

FAPDark

FAPDarker

FAPDarkest

FAPLight

FAPLighter

FAPMed


FAPLogicalBottom

[PrtType:XER]
FAPLogicalBottom

[PrtType:XER]

FAPLogicalBottom = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

This setting is used when generating normalized Metacode files.

This setting indicates whether the value of the INI setting, ManualLogicalBottom , is set in FAP units (2400 dpi) or Xerox metacode (300 dpi) units.

Example

<PrtType:XER>

FAPLogicalBottom = No

Available

Release

Patch

Used By


FAPMed

[PrtType:XER]
FAPMed

[PrtType:XER]

FAPMed = value

Parameter

Description

value

Use one of the following Metacode shading patterns (listed from lightest to darkest):

  • MetLight
  • MetMed (default)
  • MetDark

Remarks

Set this option to the map one of the seven (7) Documaker shades to a Metacode shading pattern. This mapping is used when creating Metacode files from Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are creating black and white Metacode shaded boxes from FAP black and white shaded boxes:

Here are the INI options you can use to override the default settings when you are creating Metacode shaded boxes from FAP shaded boxes:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

FAPLightest = MetLight

FAPLighter = MetMed

FAPLight = MetMed

FAPMed = MetMed

FAPDark = MetDark

FAPDarker = MetDark

FAPDarkest = MetDark

Available

Release | 11.4
Patch |

See Also

FAPDark

FAPDarker

FAPDarkest

FAPLight

FAPLighter

FAPLightest


FastSearch

[PrtType:XER]
FastSearch

[PrtType:XER]

FastSearch = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

This setting can be used if the user wants to improve runtime performance of metacode optimization (see Optimize setting). This setting can significantly improve runtime performance, but can also affect metacode record consolidation (optimization) negatively.

Example

<PrtType:XER>

FastSearch = Yes

Available

Release

Patch

Used By


FieldScope

[PrtType:XER]
FieldScope

[PrtType:XER]

FieldScope = LimitList

Parameter

Description

LimitList

Values can be

  • Image
  • Form
  • GlobalFormset

The default is blank.

Remarks

This setting controls the scope of variable fields created during a metacode conversion.

Example

<PrtType:XER>

FieldScope = Image

Available

Release | _______
Patch |

Used By


FormNameCR

[PrtType:XER]
FormNameCR

[PrtType:XER]

FormNameCR = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Set to Yes if you want to include Documerge form-level comments in Metacode print streams produced by Documaker. Use this feature if you have a reprint utility program that needs information about a form before it can reprint the form. Form-level comment records are not written for normalized Metacode/Documerge EDL members.

Example

<PrtType:XER>

FormNameCR = Yes

Available

Release | 11.4
Patch |

Used By


ImageOpt

[PrtType:XER]
ImageOpt

ImageOpt

[PrtType:XER]

ImageOpt = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

The ImageOpt option specifies if the logos are being saved on Xerox printer as IMG files or as FNT files. To use IMG files, the printer needs a special GVG or GHO hardware installed. Also, in the JSL you have to specify GRAPHICS = YES. If you are using IMG files, set the ImageOpt option to Yes; otherwise set it to No. Also, if you want to print charts, you must set the ImageOpt option to Yes. Metacode printers have a limit of sixteen (16) images on a page.

As of patch 45 for 11.0: The Xerox printer INI group now respects the ImageOpt entry. Setting this to YES allows images to generate the required GHO headers and packets in the FRM. This patch enhances the conversion of FAP files into Xerox FRMs. FAP files that contain IMG references can now be converted into Xerox FRMs when using FAP2FRM.

Example

<PrtType:XER>

ImageOpt = No

Available

Release | _______
Patch |

Used By

XERLIB


ImageOptNotSet

[Prttype:XER]
ImageOptNotSet

ImageOpt

[PrtType:XER]

ImageOptNotSet = ERROR

Parameter

Description

value

Choose from:

  • ERROR
  • WARNING
  • NONE

The default value is ERROR.

Remarks

This option allows you to suppress the printing of inline graphics, when generating Metacode print and to emit either an error message, a warning message, or no message at all.

Example

<PrtType:XER>

ImageOpt = NONE

Available

Release | 12.1
Patch |

Used By

XERLIB


ImgHeader

[PrtType:XER]
ImgHeader

ImgHeader

[PrtType:XER]

ImgHeader =

Parameter | Description
value | The default value is empty

Remarks

You can now override the default text assigned when creating Xerox graphic image files (IMG) for Xerox printers. The default header text assigned for IMG files is shown here.

Type of IMG file | Default header text
Black and white | Interpress/Xerox/2.0/ImgFormat/2.00
Color | Interpress/Xerox/2.1/RasterEncoding/2.1

This will suffice for most Xerox printers and print submission systems, but if you need to specify header text that will work on the remaining systems, you can do so.

Example

<PrtType:XER>

ImgHeader = Interpress/Xerox/1.0/ImgFormat/1.00

Available

Release | 11.3
Patch |

Used By

XERLIB


InitFunc

[PrtType:XER]
InitFunc

InitFunc

[PrtType:XER]

InitFunc = Edit

Parameter | Description
value | The default value is XERInit

Remarks

The InitFunc option names the printer function called at the initial printing. Do not change this value.

Caching pre-compiled Metacode files (PMETs) has a big effect on the GenPrint program. Here is an example of where you can set the cache for pre-compiled Metacode files:

<PrtType:XER>

CacheFiles = 100

InitFunc = XERInit

TermFunc = XERTerm

NOTE: You must include the InitFunc and TermFunc options in the PrtType:XER control group to enable caching.

Example

<PrtType:XER>

InitFunc = XERInit

Available

Release | 10.0
Patch |

Used By


JDEName

[PrtType:XER]
JDEName

JDEName

[PrtType:XER]

JDEName = Edit

Parameter | Description
value | The default value is blank.

Remarks

Represents the name of the job to use. A JDL may contain many jobs (JDEs) from which to choose. This JDE must contain a VOLUME CODE=NONE statement.

Example

For a JSL statement with the values of:

| META:JOB;

| VOLUME CODE=NONE

<PrtType:XER>

JDEName = META

Available

Release | _______
Patch |

Used By

XERLIB


JDLCode

[PrtType:XER]
JDLCode

JDLCode

[PrtType:XER]

JDLCode = LimitList

Parameter

Description

LimitList

Values can be

  • EBCDIC
  • ASCII
  • H2BCD
  • NONE
  • BCD
  • H6BCD
  • IBMBCD
  • PEBCDIC

Remarks

Represents the type of input format expected by the Xerox printer. Character translation occurs as necessary. Currently, the supported code types are EBCDIC, ASCII, NONE (same as ASCII), BCD, H2BCD, H6BCD, IBMBCD, and PEBCDIC. Userdefined code translations are not supported.

Referring to the sample JSL, if the printer is normally started with STA DLFT,CBA then the JDLCode option must be set to CODE = EBCDIC. The system's option must contain the value of the CODE statement for the printer's normal operation. This table shows the relevant JSL statements for the earlier example and the proper option to use based on the JSL example.

JSL statements

DFLT: JDE;

VOLUME CODE=EBCDIC

INI option

JDLCode = EBCDIC

Example

<PrtType:XER>

JDLCode = EBCDIC

Available

Release | _______
Patch |

Used By


JDLData

[PrtType:XER]
JDLData

JDLData

[PrtType:XER]

JDLData = Edit

Parameter | Description
value | The default value is blank.

Remarks

Represents the starting position and length of the print line data within an input data record. The LINE statement contains a DATA entry that holds these values. This table shows the relevant JSL statement for the earlier example and the proper option to use based on the JSL example.

JSL statement

LINE DATA=(0,255);

INI option

JDLData = 0,255

Example

<PrtType:XER>

JDLData = 0,255

Available

Release | _______
Patch |

Used By

XERLIB


JDLHost

[PrtType:XER]
JDLHost

JDLHost

[PrtType:XER]

JDLHost = LimitList

Parameter

Description

value

Values can be

  • IBMONL
  • IBMOS

The default is blank.

Remarks

Represents whether the printer is normally in an on-line or off-line state. Currently, the only values we accept for this option are IBMONL (on-line) and IBMOS (off-line). The following table shows the relevant JSL statement for the earlier example and the proper option to use based on the JSL example.

JSL statement

VOLUME HOST = IBMONL;

INI option

JDLHost = IBMONL

Example

<PrtType:XER>

JDLHost = IBMONL

Available

Release | _______
Patch |

Used By

XERLIB


JDLName

[PrtType:XER]
JDLName

JDLName

[PrtType:XER]

JDLName = Edit

Parameter | Description
value | The default value is blank.

Remarks

Represents the name of the JDL to use. The following shows the relevant JSL statement for the earlier example and the proper option to use based on the JSL example.

JSL statement

CBA: JDL;

INI option

JDLName = CBA

Example

<PrtType:XER>

JDLName = CBA

Available

Release | _______
Patch |

Used By

XERLIB


JDLROffset

[PrtType:XER]
JDLROffset

JDLROffset

[PrtType:XER]

JDLROffset = Edit

Parameter | Description
value | The default value is XERInit

Remarks

Use the JDLROffset option to set the criterion that tells the printer to initiate a page offset in the output bin.

In the JDL sample, the ROFFSET statement performed a criteria test named C1. The C1 test checks a specific part of each input line against the string named T1. If the string T1 matches an input data record at position zero (0) for length of 9 bytes, a page offset is initiated. Only CONSTANT criteria using an EQ operator are supported. Setting the JDLROffset option is optional. Using the JDL sample listed earlier, the option should be:

JSL statements

T1: TABLE CONSTANT=X'121212121212121212';

C1: CRITERIA CONSTANT=(0,9,EQ,T1);

ROFFSET TEST=C1;

INI option

JDLROffset = 0,9,EQ,X'121212121212121212'

Note

This option has not been fully implemented.

Example

<PrtType:XER>

JDLROffset = 0,9,EQ,X'121212121212121212'

Available

Release | _______
Patch |

Used By


JDLRPage

[PrtType:XER]
JDLRPage

JDLRPage

[PrtType:XER]

JDLRPage = Edit

Parameter | Description
value | The default value is blank.

Remarks

Use the JDLRPage option to set the criteria which signals a jump to front side of a new sheet to the printer.

In the JDL sample listed earlier, the RPAGE statement performed a criteria test named C3. The C3 test checks a specific part of each input line against the string named T3. If the string T3 matches an input data record at position zero (0) for length of 5 bytes, a jump to new sheet condition is signaled because of the SIDE=NUFRONT setting. Only CONSTANT criteria using an EQ operator are supported. For the JDLRPage option to work properly, the SIDE=NUFRONT and WHEN=NOW settings must be used as a part of the RPAGE settings in the JSL file.

Remarks:Setting the JDLRPage option is optional. If the print job contains duplex pages alternating with simplex (one-sided) pages, this option provides a way to leave blank the backsides of certain pages. Using the JDL sample listed earlier, the option should be:

Example

For JSL statements with the values of:

| T3: TABLE CONSTANT=X'FFFF26FFFF';

| C2: CRITERIA CONSTANNT = (1,5,EQ,T3);

| RPAGE TEST = C3, SIDE = NUFRONT, WHEN = NOW;

<PrtType:XER>

JDLRPage = 1,5,EQ,X'FFFF26FFFF'

Available

Release | _______
Patch |

Used By

XERLIB


JDLRStack

[PrtType:XER]
JDLRStack

JDLRStack

[PrtType:XER]

JDLRStack = Edit

Parameter | Description
value | The default value is blank.

Remarks

Use the JDLRStack option to set the criteria which signals an end of report condition to the printer.

Assuming the following example where In the JDL sample listed earlier, the RSTACK statement performed a criteria test named C2. The C2 test checks a specific part of each input line against the string named T2. If the string T2 matches an input data record at position zero (0) for a length of 10 bytes, an end of report condition is signaled. Only CONSTANT criteria using an EQ operator are supported.

Setting the JDLRStack option is optional. If your printer is used for both Metacode and text file print jobs, you must set this option. Using the JDL sample listed earlier, the option should be:

Example

For JSL statements with the values of:

| T2: TABLE CONSTANT=X'13131313131313131313';

| C2: CRITERIA CONSTANNT = (0,10,EQ,T2);

| RSTACK TEST = C2, DELIMITER = Yes, PRINT = NONE;

<PrtType:XER>

JDLRStack = 0,10,EQ,X'13131313131313131313'

Available

Release | _______
Patch |

Used By

XERLIB


KeepBlankPages

[PrtType:XER]
KeepBlankPages

KeepBlankPages

[PrtType:XER]

KeepBlankPages = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Use the new KeepBlankPages option when you are converting AFP and XEROX Documerge files into FAP files (MRG2FAP) to retain blank

Normally blank pages are removed because the system assumes they are duplex back pages that are not needed. If, however, you want to retain these pages, add this option and set it to Yes.

The default is No which indicates you do want to remove blank pages during a conversion.

Example

<PrtType:XER>

KeepBlankPages = Yes

Available

Release | 10.1
Patch | 378

Used By


Loader

[PrtType:XER]
Loader

Loader

[PrtType:XER]

Loader =

Remarks

The system lets you load print-ready Metacode files. For this feature to work, the print-ready Metacode file must have the same extension as the Ext option in the Loader:MET control group in the FAPCOMP.INI file.

<Loader:MET>

Desc = Xerox Metacode (*.MET)

Ext = .MET

LoadFunc = XERLoadMet

Module = XERW32

<Loaders>

Loader = MET

Along with the Image Editor's Metacode loader feature, another INI option is required in the PrtType:XER control group. The DefaultFont option defines the default font to use to indicate the names of any graphics in the print-ready Metacode file.

The graphics do not display in the Image Editor when the print-ready Metacode file is opened. Instead the name of the graphic appears, in the default font, and the space taken by the graphic is indicated. In addition, the default font is also used for displaying any text that references a font not present in the font cross-reference file. If there are any logos in the MET file, the system requires a LOGO.DAT file in the Logo directory so it can display logos properly for all rotations. The LOGO.DAT file, which is a semicolon-delimited file, should look similar to this:

[file name for 0° rotation];[file name for 90° rotation];[file name

for 180° rotation];[file name for 270° rotation];

Here are a few points to keep in mind when using this feature:

  • The PrtType settings must match the setting used to produce the print-ready Metacode file.
  • Rotated text will not display properly.
  • Blank pages are created for simplex forms printed in duplex mode.
  • This feature slows the printing of large print-ready files (more than 100 pages).
  • If there is a reference to a FRM file in the MET file, the system cannot display the MET file.
  • The system cannot display charts and logos.

To set the default font, enter the name of a Xerox font file contained in the font cross-reference file as shown below:

Example

<PrtType:XER>

DefaultFont=FXTIN8

Available

Release | _______
Patch |

Used By

XERLIB


LogicalBottom

[PrtType:XER]
LogicalBottom

[PrtType:XER]

LogicalBottom = Edit

Parameter | Description
value | The default value is blank.

Remarks

This setting is used when generating normalized Xerox metacode files.

The LogicalBottom setting can contain a positive or zero (0) value and is used to override the normal logical bottom calculation for a FAP file. A zero (0) value will default to 26400.

The value is in FAP units (2400 dots/inch) unless the INI setting FAPLogicalBottom is set to No.

Use of this setting is not recommended.

Example

<PrtType:XER>

LogicalBottom =

Available

Release | _______
Patch |

Used By


LogoPrefix

[PrtType:XER]
LogoPrefix

[PrtType:XER]

LogoPrefix = Edit

Parameter | Description
value | The default value is Q

Remarks

This setting is used to control the starting letter used when creating logos during a metacode conversion.

Example

<PrtType:XER>

LogoPrefix = Q

Available

Release | _______
Patch |

Used By


ManualLogicalBottom

[PrtType:XER]
ManualLogicalBottom

[PrtType:XER]

ManualLogicalBottom = Edit

Parameter | Description
value | The default value is blank.

Remarks

This setting is used when generating normalized Xerox metacode files.

The ManualLogicalBottom setting can contain a positive or zero (0) value and is used to override the normal logical bottom calculation for a FAP file. A zero (0) value means the logical bottom is set to the top of the page.

The value is in FAP units (2400 dots/inch) unless the INI setting FAPLogicalBottom is set to No.

Use of this setting is not recommended.

Example

<PrtType:XER>

ManualLogicalBottom =

Available

Release | _______
Patch |

Used By


MaxError

[PrtType:XER]
MaxError

MaxError

[PrtType:XER]

MaxError = Edit

Parameter | Description
number | The default value is 25

Remarks

MRG2FAP normally quits after reporting 25 errors. Since these "errors" are not always important, increase the number of allowable "errors" before MRG2FAP quits.

Add the INI setting, MaxError, to your Xerox printer INI group and set it to a large number.

Example

<PrtType:XER>

MaxError = 250

Available

Release | _______
Patch |

Used By


MaxFonts

[PrtType:XER]
MaxFonts

MaxFonts

[PrtType:XER]

MaxFonts = Spin

Parameter | Description
value | The default value is 20

Remarks

Set this option to the maximum number of fonts your printer can handle in a single DJDE command. This number will vary based upon the printer's memory and configuration. The maximum value is 99 and the default is 20.

NOTE: Remove or comment out the CommonFonts control group to turn off this feature.

If the number of fonts in your common font list exceeds the MaxFonts value, the system outputs the MaxFonts number of fonts in the DJDE FONTS command. The DJDE FONTS command will contain the names of the fonts used on that page plus additional fonts from the common fonts list until the MaxFonts number of fonts is reached.

If the system encounters a page that uses a font not specified in the common fonts list (or the prior DJDE FONTS command to be more precise), it issues a new DJDE FONTS command that appends to the common font list the new fonts from that page's DJDE FONTS command.

NOTE: If the Metacode print stream accesses printer-resident forms (FRM files), keep in mind that each time the system encounters a DJDE FORMS command, it must issue a new DJDE FONTS command because loading an FRM removes all fonts in the printer's font memory. Therefore, if you use a lot of FRMs in the print stream, using a common fonts list may not improve performance.

Example

<PrtType:XER>

MaxFonts = 20

Available

Release | 10.1
Patch |

Used By


MetDark

[PrtType:XER]
MetDark

[PrtType:XER]

MetDark = LimitList

Parameter

Description

value

Use one of the following Documaker shading patterns (listed from lightest to darkest):

  • FAPLightest
  • FAPLighter
  • FAPLight
  • FAPMed
  • FAPDark
  • FAPDarker (default)
  • FAPDarkest

Remarks

Set this option to the map a Metacode shading pattern to one of the seven (7) Documaker shades. This mapping is used when converting Metacode files into Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are opening Metacode shaded boxes in Documaker or when you are converting them into FAP shaded box objects:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

MetLight = FAPLightest

MetMed = FAPLight

MetDark = FAPDarkest

Available

Release | 11.4
Patch |

See Also

MetLight

MetMed


MetLight

[PrtType:XER]
MetLight

[PrtType:XER]

MetLight = LimitList

Parameter

Description

value

Use one of the following Documaker shading patterns (listed from lightest to darkest):

  • FAPLightest
  • FAPLighter (default)
  • FAPLight
  • FAPMed
  • FAPDark
  • FAPDarker
  • FAPDarkest

Remarks

Set this option to the map a Metacode shading pattern to one of the seven (7) Documaker shades. This mapping is used when converting Metacode files into Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are opening Metacode shaded boxes in Documaker or when you are converting them into FAP shaded box objects:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

MetLight = FAPLightest

MetMed = FAPLight

MetDark = FAPDarkest

Available

Release | 11.4
Patch |

See Also

MetMed

MetDark


MetMed

[PrtType:XER]
MetMed

[PrtType:XER]

MetMed = value

Parameter

Description

value

Use one of the following Documaker shading patterns (listed from lightest to darkest):

  • FAPLightest
  • FAPLighter
  • FAPLight
  • FAPMed (default)
  • FAPDark
  • FAPDarker
  • FAPDarkest

Remarks

Set this option to the map a Metacode shading pattern to one of the seven (7) Documaker shades. This mapping is used when converting Metacode files into Documaker files. Documaker FAP files support seven shade patterns: lightest, lighter, light, medium, dark, darker, and darkest. Metacode, however, only supports three levels of shading: light, medium, and dark.

In previous versions, when Documaker opened Metacode files (normalized or FRM files) and when it converted FAP files into Metacode, it converted the seven shades into the three Metacode supported shades. It did this by converting all three Documaker light shades into Metacode light and all three Documaker dark shades into Metacode dark.

NOTE: The shading in this example is for illustrative purposes only. It does not represent how the various shades will reproduce in your printed output.

In version 11.4, you can now add INI options into your Metacode printer control group and set the shade conversions any way you like. There are also new color INI options which you can use to convert FAP color shaded boxes into Metacode highlight color shaded boxes.

Here are the INI options you can use to override the default settings when you are opening Metacode shaded boxes in Documaker or when you are converting them into FAP shaded box objects:

Example

For example, you could set up your INI options this way:

<PrtType:XER>

MetLight = FAPLightest

MetMed = FAPLight

MetDark = FAPDarkest

Available

Release | 11.4
Patch |

See Also

MetLight

MetDark


MOBIUS

[PrtType:XER]
MOBIUS

MOBIUS

Feature 1405 Reading From A MOBIUS Archive

[PrtType:XER]

MOBIUS = Edit

Parameter | Description
Edit |

Remarks

Now you can read Metacode print streams retrieved from a Mobius archive. For instance, you can now use Mobius to archive Metacode print streams, then use Docupresentment to retrieve the archived Metacode print streams and produce PDF files. You can also open Mobius files in Image Editor.

NOTE: Mobius Metacode files do not, however, appear on the list of most recently opened files at the bottom of the File menu in Image Editor.

The archived Metacode print streams can be retrieved using Mobius: ViewDirect APIs. The ViewDirect APIs communicate with the Mainframe Mobius Archive via TCP/IP. If you license the Mobius' ViewDirect APIs, you can write a custom rule to retrieve your archived Metacode print streams.

Metacode print streams retrieved from a Mobius archive have a special record blocking scheme and use special comment records to indicate the fonts used in the document.

As with support for loading other Metacode print streams, you must have a Xerox printer control group which defines the options required by the print stream, such as DJDEIden, DJDEOffset, and so on.

NOTE: The Mobius Metacode loader now performs its operations quicker and with better coding. This makes the output easier to read and use.

To specify a Mobius Metacode print stream, the OutMode option in the Xerox printer control group must be set to MOBIUS. The OutMode option tells the Metacode loader to expect the special record blocking scheme and to expect special comment records which indicate the fonts used in the document.

Mobius Metacode support is available in both Image Editor and the MRG2FAP utility. Include these options in your FAPCOMP.INI file for Image Editor or FSISYS.INI for MRG2FAP.

<PrtType:XER>

OutMode = Mobius

<Loader>

Desc = Mobius Metacode Files (*.met)

Func = XERLoadMobius

Module = XERW32

<Loaders>

Loader = Mobius

<Control>

Mobius = XER

Where XER is the printer group that contains the Mobius Metacode information.

To us the Mobius Metacode loader in Docupresentment, use the MTCLoadFormset rule. To specify Mobius Metacode print stream instead of a Documerge print stream, set the OutMode option in the Xerox printer control group to MOBIUS.

Example

<PrtType:XER>

OutMode = Mobius

Available

Release | 10.2
Patch | 66


ModifyFile

[PrtType:XER]
ModifyFile

[PrtType:XER]

ModifyFile = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

This setting can be used to override the Optimize setting.

If ModifyFile is set to No, the metacode print driver will ignore the Optimize setting.

Example

<PrtType:XER>

ModifyFile = No

Available

Release

Patch

Used By


Module

[PrtType:XER]
Module

Module

[PrtType:XER]

Module = Edit

Parameter | Description
value | The default value is XERW32

Remarks

Module specifies the print DLL name. Do not change this value.

Example

<PrtType:XER>

Module = XERW32

Available

Release | _______
Patch |

Used By


MultipleOText

[PrtType:XER]
MultipleOText

[PrtType:XER]

MultipleOText = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

The system also supports multiple OTEXT messages in the Metacode print driver at a print batch level.

Additionally, the system lets OTEXT messaging generate multiple messages per print batch. To turn on multiple OTEXT messaging, add this option to the FSISYS.INI file

< PrtType:XER >

MultipleOText = Yes

The default is No.

This tells the system to ignore the OTextString value in the PrtType control group and instead use the ones found in the appropriate print batch group.

For example, if you have three print batches, called BATCH1, BATCH2, and BATCH3, under each separate batch group, put required number of sequential messages for that batch:

< BATCH1 >

...

OTextString1 = "Batch 1 OText String1"

OTextString2 = "Batch 1 OText String2"

OTextString3 = "Batch 1 OText String3"

< BATCH2 >

...

OTextString1 = "Batch 2 OText String1"

OTextString2 = "Batch 2 OText String2"

OTextString3 = "Batch 2 OText String3"

< BATCH3 >

...

OTextString1 = "Batch 3 OText String1"

OTextString2 = "Batch 3 OText String2"

OTextString3 = "Batch 3 OText String3"

***

Keep in mind that the index tags OTextStringX (where X is a number) must start with one (1) and be sequential. The system stops writing OTEXT records to the batch when it finds a tag that is out of sequence. Here is an example:

OTextString1 = "Batch 3 Otext String 1"

OTextString3 = "Batch 3 Otext String 3"

In this example, only the first one would display on the screen, because OTextString2 is not encountered next.

See Also OTextString

Example

<PrtType:XER>

MultipleOText = Yes

Available

Release

Patch

Used By


Normalize

[PrtType:XER]
Normalize

[PrtType:XER]

Normalize = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

This setting determined whether the metacode print driver is producing a normalized metacode file.

Example

<PrtType:XER>

Normalize = Yes

Available

Release

Patch

Used By


OffsetLevel

[PrtType:XER]
OffsetLevel

OffsetLevel

[PrtType:XER]

OffsetLevel = Edit

Parameter | Description
boolean | Yes | No The default value is No

Remarks

When printing on a Metacode printer, you can now jog form sets by transaction instead of by batch. In some situations, this can make manual assembly easier. To do this, set the new OffsetLevel option in the PrtType:XER control group to Yes.

<PrtType:XER>

OffsetLevel = Yes

This adds an additional 'OFFSET' parameter to the SIDE=NUFRONT command, which tells the printer to jog after each transaction.

Example

<PrtType:XER>

OffsetLevel = Yes

Available

Release | 10.1
Patch | 160

Used By


Optimize

[PrtType:XER]
Optimize

Optimize

[PrtType:XER]

Optimize = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

The GenPrint program lets you produce optimized Metacode print streams.

You may want to consider using optimization if your Metacode output causes the printer to cycle down (wait) while printing. This condition can occur when Metacode records cannot be transferred fast enough to the printer. Optimization helps remedy this situation by combining Metacode print records into larger and fewer records. Reducing the number of records that must be transmitted reduces the amount of time needed to spool the Metacode print stream to the printer. The cost is decreased GenPrint performance. You can also use the MetOpt utility to optimize normal (non-optimized) Metacode output. For more information on this utility, see the Utilities Reference Guide.

To have the GenPrint program produce optimized Metacode output streams,add this FSISYS.INI option to have the GenPrint program sort and consolidate records to create more efficient print streams:

<PrtType:XER>

Optimize = Yes

You can enable some extra error checking during optimization. If optimization encounters critical errors, such as the inability to find or open a file, it will notify you and stop immediately. It can report actual or potential non-critical problems it encounters while it runs. For instance, if optimization finds Metacode records that may prevent the file from printing, it can warn you.

To have optimization notify you if it spots potential problems, add the following option to your PrtType:XER control group:

<PrtType:XER>

ValidLevel = 0 (default)

Enter zero (0) to tell the utility not to report non-critical problems. Enter one (1) to tell the utility to report warnings for non-critical problems, but continue optimizing. Enter two (2) to tell the utility to report warnings for non-critical problems and attempt to fix the problems. Enter three (3) to tell the utility to report warnings for non-critical problems and exit immediately.

Regardless of the option you choose, if you receive any warnings, be sure to closely check both the original and, if applicable, the optimized file. The Optimize option defaults to No, which tells the GenPrint program to run without sorting and consolidating records.

See also FastSearch , RelativeScan , ValidLevel , and SaveComment .

Example

<PrtType:XER>

Optimize = Yes

Available

Release | 10.1
Patch |

Used By

XERLIB


OTextString

[PrtType:XER]
OTextString

OTextString

[PrtType:XER]

OTextString = Edit

Parameter | Description
value | The default value is blank.

Remarks

Use the OTextString option to display a message on the printer console. The text you specify is sent before the print job starts. This lets you display a message on the printer console, such as "Put BLUE paper in tray 1" before a print job starts.

<PrtType:XER>

OTextString = message

Example

<PrtType:XER>

OTextString = Put BLUE paper in tray 1

Available

Release | 10.1
Patch | 126

Used By

XERLIB


OutMetFunc

[PrtType:XER]
OutMetFunc

OutMetFunc

[PrtType:XER]

OutMetFunc = Edit

Parameter | Description
value | The default value is XEROutMet

Remarks

For the Xerox print driver, you must specify the following set of installable functions in the PrtType:XER control group:

<PrtType:XER>

OutputFunc = XEROutput

OutMetFunc = XEROutMet

InitFunc = XERInit

TermFunc = XERTerm

Module = XERW32

PrintFunc = XERPrint

Example

<PrtType:XER>

OutMetFunc = XEROutMet

Available

Release | _______
Patch |

Used By


OutMode

[PrtType:XER]
OutMode

OutMode

[PrtType:XER]

OutMode = List

Parameter

Description

value

Values can be

  • BARR
  • BARRWORD
  • ELIXIR
  • EPS
  • JES2
  • MRG2
  • MRG4

The default value is blank.

Remarks

The OutMode option indicates the output format for the Metacode data stream generated by Documaker software.

Use EPS, if the Metacode output is to be transmitted to a Xerox Enterprise Printing System (EPS) printer via a TCP/IP connection.

Use BARR, if the Metacode output is to be transmitted to the Xerox printer via BARR SPOOL hardware and software. When using the BARR setting, a length byte is placed at the start and end of each Metacode record.

Use BARRWORD, if the Metacode output is to be transmitted to the Xerox printer via BARR SPOOL hardware and software. BARRWORD should be used only if the Xerox printer can handle records longer than the 255 characters.

Use JES2, if the Environment option is set to MVS. In some special cases, if output is to be uploaded to a mainframe (MVS) and then transmitted to the printer via JES2, then use OutMode = JES2

REL102: The MRG2FAP utility can convert Elixir-formatted Metacode print files into FAP files. To use this utility with Elixir files, change the OutMode option in your Xerox printer control group as shown here:

<PrtType:XER>

OutMode = ELIXIR

CREATING PRINT STREAMS FOR DOCUSAVE

DocuSave can archive AFP and Metacode print streams that are in a DocuSavecompatible format and contain special records used to index the archive.

To activate this function, include the OutMode option in the PrtType:xxx control group in your FSISYS.INI or FSIUSER.INI file. Here are some examples:

<PrtType:AFP>

OutMode = MRG4

<PrtType:XER>

OutMode = JES2

To produce a print stream for DocuSave on an NT platform, you must set the OutMode option equal to MRG4. When you set the OutMode option to MRG4, the GenPrint program creates print stream records with a 4-byte sequence that precedes them. This sequence defines the record lengths. Records are grouped into blocks with one or more records in each block. Both records and blocks have a 4-byte sequence that precedes them, defining their length.

To produce a print stream for DocuSave under MVS or OS/390, you must set the OutMode INI option equal to JES2. Use JES2 to produce print streams under MVS or OS/390. When you set the OutMode option to JES2, the GenPrint program creates print stream records that are native to a mainframe environment.

In addition to using the OutMode option, you must include comment records in the print streams to index the archive. You can use a DAL script to add comment records into the print stream. Use the DocuSaveScript option in the PrtType:AFP or XER control group to have the system execute a DAL script at the times when DocuSave comments can be added to the print streams.

To add DocuSave comments to an AFP print stream, you must add the DocuSaveScript option and the name of a DAL script to execute. The DAL script should call the AddDocuSaveComment function to add a string as a DocuSave comment record. Here is an example:

<PrtType:AFP>

DocuSaveScript = DocuSave.DAL

OutMode = MRG4

Here is an example DAL script (File: E:\Fap10\mstrres\REX1\DEFLIB\DOCUSAVE.DAL 4/27/0, 3:38:00PM):

*Add DocuSave Comment - use default: APPIDX record!

Comment = ApIdxRec()

Class = PAD("bio",9)

Cabinet = PAD(rpex1",8)

Title = PAD("Title",22)

IndexTag = Comment & Class & Cabinet & Title

Print_It(IndexTag)

AddDocuSaveComment (IndexTag)

Return ('Finished!')

Feature 1393 For Normalized Metacode, the system only supported the standard Documerge 4-byte ISI format of Metacode, which in the INI files is represented by setting the OutMode option to MRG4.

The system now also supports the 2-byte variable (ISI 2-byte) format for loading and creating Metacode. To indicate this, set the OutMode option as shown here:

<PrtType:XER>

OutMode = MRG2

Example

<PrtType:XER>

OutMode = EPS

Available

Release

Patch

Used By

XERLIB


OutputFunc

[PrtType:XER]
OutputFunc

OutputFunc

[PrtType:XER]

OutputFunc = Edit

Parameter | Description
value | The default value is XEROutput

Remarks

This option specifies the printer function name. Do not change this option's value.

Example

<PrtType:XER>

OutputFunc = XEROutput

Available

Release | _______
Patch |

Used By


OutputMod

[PrtType:XER]
OutputMod

OutputMod

[PrtType:XER]

OutputMod = Edit

Parameter | Description
value | The default value is XERW32

Remarks

This option specifies the DLL containing the function called by the OuputFunc option. Do not change this option's value.

Example

<PrtType:XER>

OutputMod = XERW32

Available

Release | _______
Patch |

Used By


OverlayExt

[PrtType:XER]
OverlayExt

[PrtType:XER]

OverlayExt = Edit

Parameter | Description
extension | a file extension The default is .met

Remarks

The file extension of the Metacode overlays.

Example

<PrtType:XER>

OverlayExt = .met

Available

Release | _______
Patch |

Used By


PageNumbers

[PrtType:XER]
PageNumbers

PageNumbers

[PrtType:XER]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

The PageNumbers option activates the page numbering feature. Set this value to Yes to have page numbers printed in the Page X of Y format.

Example

<PrtType:XER>

PageNumbers = No

Available

Release | _______
Patch |

Used By


PaperSize

[PrtType:XER]
PaperSize

[PrtType:XER]

PaperSize = Spin

Parameter | Description
number | The default is 0

Remarks

This option selects the paper size when converting metacode print streams.

Parameter

Description

List

Values can be

  • 0 - Letter (Default)
  • 1 - US Legal
  • 2 - ISO A4
  • 4 - US ledger
  • 5 - US Tabloid
  • 3 - US Executive
  • 6 - US statement
  • 7 - US Folio
  • 8 - US fanfold
  • 20 - ISO A0
  • 21 - ISO A1
  • 22 - ISO A2
  • 23 - ISO A3
  • 25 - ISO A5
  • 26 - ISO A6
  • 27 - ISO A7
  • 28 - ISO A8
  • 29 - ISO A9
  • 30 - ISO A10
  • 32 - ISO 2A
  • 34 - ISO 4A
  • 40 - ISO B0
  • 41 - ISO B1
  • 42 - ISO B2
  • 43 - ISO B3
  • 44 - ISO B4
  • 45 - ISO B5
  • 46 - ISO B6
  • 47 - ISO B7
  • 48 - ISO B8
  • 49 - ISO B9
  • 50 - ISO B10
  • 52 - ISO 2B
  • 54 - ISO 4B
  • 60 - ISO C0
  • 61 - ISO C1
  • 62 - ISO C2
  • 63 - ISO C3
  • 64 - ISO C4
  • 65 - ISO C5
  • 66 - ISO C6
  • 67 - ISO C7
  • 68 - ISO C8
  • 69 - ISO C9
  • 70 - ISO C10
  • 71 - ISO DL
  • 80 - JIS B0
  • 81 - JIS B1
  • 82 - JIS B2
  • 83 - JIS B3
  • 84 - JIS B4
  • 85 - JIS B5
  • 86 - JIS B6
  • 87 - JIS B7
  • 88 - JIS B8
  • 89 - JIS B9
  • 90 - JIS B10
  • 98 - Custom
  • 99 - Current Type

The default value is 0 (8.5" x 11")

Example

<PrtType:XER>

PaperSize = 0

Available

Release | _______
Patch |

Used By


PMetLib

[PrtType:XER]
PMetLib

[PrtType:XER]

PMetLib = Edit

Parameter | Description
extension | The default is blank.

Remarks

The print driver creates the print stream using pre-compiled Metacode files. Use the FAP2MET utility to create pre-compiled Metacode files. The GenPrint program loads pre-compiled Metacode members from the PMETLIB PDS under MVS. On other platforms, the PMetLib option specifies the directory which contains the pre-compiled MET files. If you do not set this option, the system uses the setting for the FormLib option in the MasterResource control group.

See also CompileInStream .

Example

<PrtType:XER>

PMetLib =

Available

Release | _______
Patch |

Used By


PrePrintedPaper

[PrtType:XER]
PrePrintedPaper

[PrtType:XER]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enabled or Hidden determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Yes or No determines whether this check box is checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option (Yes,Enabled) includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:XER>

PrePrintedPaper = No,Hidden

Available

Release | _______
Patch |

Used By


PrinterInk

[PrtType:XER]
PrinterInk

PrinterInk

[PrtType:XER]

PrinterInk = List

Parameter

Description

color

Blue | Brown| Cardinal | Cyan | Gray | Green | Magenta | Red | Ruby | Royal | Violet

Values can be

  • Blue
  • Brown
  • Cardinal
  • Cyan
  • Gray
  • Green
  • Magenta
  • Red
  • Royal
  • Ruby
  • Violet

The default color is Blue

Remarks

Use the PrinterInk option to specify the color of ink loaded on a Xerox highlight color printer. You can set this option to one of the following colors:

Blue, Red, Green, Ruby, Violet, Brown,

Gray, Cardinal, Royal, Cyan, Magenta

Blue is the default if you omit this option. This option is used with the SendColor option. If you set the SendColor option to Yes, be sure to also set the PrinterInk option. Here is how you would specify cyan as the color of the ink stored on the printer:

Example

<PrtType:XER>

PrinterInk = cyan

Available

Release | _______
Patch |

Used By


PrinterModel

[PrtType:XER]
PrinterModel

PrinterModel

[PrtType:XER]

PrinterModel = Edit

Parameter | Description
model | The default is blank.

Remarks

Use the PrinterModel option to specify the particular printer model you are using. There may be subtle differences between printer models that can affect the output sent to the printer. Currently, only the 3700 printer requires the following setting.

Example

<PrtType:XER>

PrinterModel = 3700

Available

Release | _______
Patch |

Used By

XERLIB


PrintFunc

[PrtType:XER]
PrintFunc

PrintFunc

[PrtType:XER]

PrintFunc = Edit

Parameter | Description
value | The default value is XERPrint

Remarks

PrinFunc defines the printer function name. Do not change this option's value.

Example

<PrtType:XER>

PrintFunc = XERPrint

Available

Release | _______
Patch |

Used By


PrintViewOnly

[PrtType:XER]
PrintViewOnly

PrintViewOnly

[PrtType:XER]

PrintViewOnly = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

If set to Yes, this option tells the system to print the view only images. This does not apply to entry only images, which are never printed. Entry only images are usually worksheets. If the image is marked as hidden and view only, it will not print. The default is No.

Example

<PrtType:XER>

PrintViewOnly = Yes

Available

Release | _______
Patch |

Used By

XERLIB


RelativeScan

[PrtType:XER]
RelativeScan

[PrtType:XER]

RelativeScan = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

This setting determines whether to increase metacode optimization by consolidating records with the relative scan opcode.

See also Optimize

Example

<PrtType:XER>

RelativeScan = No

Available

Release

Patch

Used By


Resolution

[PrtType:XER]
Resolution

Resolution

[PrtType:XER]

Resolution = List

Parameter | Description
value | The default value is 300

Remarks

Use the Resolution option to specify the printer's dots per inch resolution.

Note

Currently, only 300 dpi is supported.

Example

<PrtType:XER>

Resolution = 300

Available

Release | _______
Patch |

Used By


RuleFilePool

[PrtType:XER]
RuleFilePool

RuleFilePool

[PrtType:XER]

RuleFilePool =

Parameter | Description
Edit |

Remarks

The RuleFilePool option specifies the number of DDT files to keep available for re-use without re-loading them from disk. This option is in the CONTROL control group in the FSISYS.INI file.

MET files contain pre-compiled Metacode information produced by the FAP2MET utility. The GenPrint program loads MET members from the PMETLIB PDS under MVS. On other platforms, the PMetLib option specifies the directory containing the pre-compiled MET files. Default is 100.

Example

<CONTROL>

RuleFilePool = 100 (default is 100)

Available

Release | _______
Patch |

Used By

XERLIB


SaveComment

[PrtType:XER]
SaveComment

[PrtType:XER]

SaveComment = List

Parameter

Description

value

Save As Is | ASCII | EBCDIC | Hexadecimal | No Save

Values can be

  • Save As Is
  • ASCII
  • EBCDIC
  • Hexadecimal
  • No Save

The default value is No Save

Remarks

The SaveComment INI option is for the optional ability to save the last metacode comment record processed and display it when an error is encountered. This can be a helpful placeholder when trying to isolate the location of an error record in a very large file with many occurrences of the same or similar records. If the metacode file contains occasional or frequent comment records, then the SaveComment may be a useful troubleshooting tool.

See also Optimize and ValidLevel .

Example

<PrtType:XER>

SaveComment = Save As Is

Available

Release | _______
Patch |

Used By


SendColor

[PrtType:XER]
SendColor

SendColor

[PrtType:XER]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

This setting determines whether (highlight) color print is enabled.

Example

<PrtType:XER>

SendColor = Yes,Enabled

Available

Release | _______
Patch |

Used By


SendOverlays

[PrtType:XER]
SendOverlays

SendOverlays

[PrtType:XER]

SendOverlays = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

This print window option lets the user send images compiled into printer language. Sending overlays enhances print speed so this option is usually selected automatically. The INI value shown in this option's heading represents the recommended default value for this Print window check box.

Note: For Metacode printing, the SENDOVERLAY and COMPILEINSTREAM options are mutually exclusive. If the value <Print> COMPILEINSTREAM = Yes, then SENDOVERLAY must be No.

Example

<PrtType:XER>

SendOverlays = Yes,Enabled

Available

Release | _______
Patch |

Used By


SkipMaxLen

[PrtType:XER]
SkipMaxLen

[PrtType:XER]

SkipMaxLen = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

When the metacode print driver encounters records which are in excess of the printer's maximum record length, an error is generated and the offending record is not printed. If SkipMaxLen is enabled, the metacode driver will continue printing. If SkipMaxLen is NOT enabled, processing will abort at this point.

Example

<PrtType:XER>

SkipMaxLen = Yes

Available

Release | 10.1
Patch |

Used By


StapleJDEName

[PrtType:XER]
StapleJDEName

StapleJDEName

[PrtType:XER]

StapleJDEName = Edit

Parameter | Description
JDEName | The default is blank.

Remarks

Some Metacode printers include a stapling feature. The system supports this feature, but it has not been tested and is not warranted. Using this feature, forms printed on certain Metacode printers can be stapled if you specify a StapleJDEName option in the PrtType control group. This causes a new JDE to be specified on forms that need to be stapled.

It is assumed that the Staple JDE option has the same settings as the normal JDE specified except for the additional STAPLE command. You specify which forms should be stapled using the Form Set Manager, which is part of DocuCreate. This option only affects implementations which print to Metacode printers with the optional stapling feature. For more information on this feature, see the DocuCreate User's Guide.

Example

<PrtType:XER>

StapleJDEName = JDEBIND

Available

Release | _______
Patch |

Used By

XERLIB


StopOnInvalidChar

[PrtType:XER]
StopOnInvalidChar

[PrtType:XER]

StopOnInvalidChar = YN

Parameter | Description
boolean | Yes | No The default is Yes

Remarks

The printer ignores the rest of the record after encountering an invalid/illegal character. Under normal circumstances, the metacode conversion should behave precisely the same way.

The default setting (Yes) will cause the metacode conversion to ignore the rest of the record after encountering an invalid/illegal character.

Example

<PrtType:XER>

StopOnInvalidChar = No

Available

Release

Patch

Used By


StreamBufferSize

[PrtType:XER]
StreamBufferSize

[PrtType:XER]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:XER>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType:XER]
TermFunc

TermFunc

[PrtType:XER]

TermFunc = Edit

Parameter | Description
value | The default value is XERTerm

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Caching pre-compiled Metacode files (PMETs) has a big effect on the GenPrint program. Here is an example of where you can set the cache for pre-compiled Metacode files:

<PrtType:XER>

CacheFiles = 100

InitFunc = XERInit

TermFunc = XERTerm

NOTE: You must include the InitFunc and TermFunc options in the PrtType:XER control group to enable caching.

Example

<PrtType:XER>

TermFunc = XERTerm

Available

Release | 10.0
Patch |

Used By


Tray

[PrtType:XER]
Tray

Tray

[PrtType:XER]

Tray = Edit

Parameter | Description
value |

Remarks

By default, Metacode output specifies the main tray for pages that use Tray 1. The AUX tray is specified for all other trays. If you have named trays in your JSL, specify these named trays in your options. An example of this option is shown here:

<PrtType:XER>

Tray1 = ONE1

Tray2 = TWO2

Tray3 = THREE3

Tray4 = FOUR4

By default, Metacode output specifies the main tray for pages that use Tray 1.

Example

<PrtType:XER>

Tray1 = ONE1

Available

Release | _______
Patch |

Used By


Tray1

[PrtType:XER]
Tray1

Tray1

[PrtType:XER]

Tray1 = Edit

Parameter | Description
value | The default value is MAIN

Remarks

The Metacode print driver has been modified to support up to nine paper trays. Refer to Release 10.1 Release Letter for Feature.

You can override Metacode tray commands by providing an alternate tray name to use.

Here are the default PrtType:XER control group settings for each tray:

<PrtType:XER>

Tray1=MAIN

Tray2=AUX

Tray3=AUX

Tray4=AUX

Tray5=AUX

Tray6=AUX

Tray7=AUX

Tray8=AUX

Tray9=AUX

By default, Metacode output usually specifies the main tray for pages that use tray 1. The AUX tray is specified for all other trays. If you have named trays in your JSL, specify these named trays in your options. An example is shown below.

Example

<PrtType:XER>

Tray1=ONE1

Tray2=TWO2

Tray3=THREE3

Available

Release | _______
Patch |

Used By

GENPRINT


Tray2

[PrtType:XER]
Tray2

[PrtType:XER]

Tray2 = Edit

Parameter | Description
value | Tray name. The default is AUX

Remarks

The Metacode print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults.

<PrtType:XER>

Tray1 = MAIN

Tray2 = AUX

Tray3 = AUX

Tray4 = AUX

Tray5 = AUX

Tray6 = AUX

Tray7 = AUX

Tray8 = AUX

Tray9 = AUX

See also [PrtType:XER] Tray1 .

Example

<PrtType:XER>

Tray2 = HOLED

Available

Release

Patch

Used By

GENPRINT


Tray3

[PrtType:XER]
Tray3

[PrtType:XER]

Tray3 = Edit

Parameter | Description
value | Tray name. The default is AUX

Remarks

The Metacode print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults.

<PrtType:XER>

Tray1 = MAIN

Tray2 = AUX

Tray3 = AUX

Tray4 = AUX

Tray5 = AUX

Tray6 = AUX

Tray7 = AUX

Tray8 = AUX

Tray9 = AUX

See also [PrtType:XER] Tray1 .

Example

<PrtType:XER>

Tray3 = HOLED

Available

Release

Patch

Used By

GENPRINT


Tray4

[PrtType:XER]
Tray4

[PrtType:XER]

Tray4 = Edit

Parameter | Description
value | Tray name. The default is AUX

Remarks

The Metacode print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults.

<PrtType:XER>

Tray1 = MAIN

Tray2 = AUX

Tray3 = AUX

Tray4 = AUX

Tray5 = AUX

Tray6 = AUX

Tray7 = AUX

Tray8 = AUX

Tray9 = AUX

See also [PrtType:XER] Tray1 .

Example

<PrtType:XER>

Tray4 = HOLED

Available

Release

Patch

Used By

GENPRINT


Tray5

[PrtType:XER]
Tray5

[PrtType:XER]

Tray5 = Edit

Parameter | Description
value | Tray name. The default is AUX

Remarks

The Metacode print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults.

<PrtType:XER>

Tray1 = MAIN

Tray2 = AUX

Tray3 = AUX

Tray4 = AUX

Tray5 = AUX

Tray6 = AUX

Tray7 = AUX

Tray8 = AUX

Tray9 = AUX

See also [PrtType:XER] Tray1 .

Example

<PrtType:XER>

Tray5 = HOLED

Available

Release

Patch

Used By

GENPRINT


Tray6

[PrtType:XER]
Tray6

[PrtType:XER]

Tray6 = Edit

Parameter | Description
value | Tray name. The default is AUX

Remarks

The Metacode print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults.

<PrtType:XER>

Tray1 = MAIN

Tray2 = AUX

Tray3 = AUX

Tray4 = AUX

Tray5 = AUX

Tray6 = AUX

Tray7 = AUX

Tray8 = AUX

Tray9 = AUX

See also [PrtType:XER] Tray1 .

Example

<PrtType:XER>

Tray6 = HOLED

Available

Release

Patch

Used By

GENPRINT


Tray7

[PrtType:XER]
Tray7

[PrtType:XER]

Tray7 = Edit

Parameter | Description
value | Tray name. The default is AUX

Remarks

The Metacode print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults.

<PrtType:XER>

Tray1 = MAIN

Tray2 = AUX

Tray3 = AUX

Tray4 = AUX

Tray5 = AUX

Tray6 = AUX

Tray7 = AUX

Tray8 = AUX

Tray9 = AUX

See also [PrtType:XER] Tray1 .

Example

<PrtType:XER>

Tray7 = HOLED

Available

Release

Patch

Used By

GENPRINT


Tray8

[PrtType:XER]
Tray8

[PrtType:XER]

Tray8 = Edit

Parameter | Description
value | Tray name. The default is AUX

Remarks

The Metacode print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults.

<PrtType:XER>

Tray1 = MAIN

Tray2 = AUX

Tray3 = AUX

Tray4 = AUX

Tray5 = AUX

Tray6 = AUX

Tray7 = AUX

Tray8 = AUX

Tray9 = AUX

See also [PrtType:XER] Tray1 .

Example

<PrtType:XER>

Tray8 = HOLED

Available

Release

Patch

Used By

GENPRINT


Tray9

[PrtType:XER]
Tray9

[PrtType:XER]

Tray9 = Edit

Parameter | Description
value | Tray name. The default is AUX

Remarks

The Metacode print driver has been modified to support up to nine paper trays.

If no trays are defined these are the defaults.

<PrtType:XER>

Tray1 = MAIN

Tray2 = AUX

Tray3 = AUX

Tray4 = AUX

Tray5 = AUX

Tray6 = AUX

Tray7 = AUX

Tray8 = AUX

Tray9 = AUX

See also [PrtType:XER] Tray1 .

Example

<PrtType:XER>

Tray9 = HOLED

Available

Release

Patch

Used By

GENPRINT


TrayUsePaperStockID

[PRTType:XER]
TrayUsePaperStockID

TrayUsePaperStockID

[PrtType:XER]

TrayUsePaperStockID = YN

Parameter | Description
boolean | Yes | No The default value is No

This setting enables PaperStock support in the metacode print driver.

In the Metacode printer control group, you must set the TrayUsePaperStockID option to Yes, as shown here:

< PrtType:XER >

TrayUsePaperStockID = Yes

If the TrayUsePaperStockID option is set to Yes, the Metacode print driver takes the form’s PaperStockID and tries to find the DJDE INI option for it in the INI file when it emits the tray command.

Using Documaker Studio you can specify what paper stock the form should print on. This will help users who have more than nine types of paper stocks. Here is an example of the INI options you could set up:

< PaperStockIDs >

PaperStockID = Drilled

PaperStockID = 20lb

...(and so on)

< PaperStockID:Drilled >

Description = 3-hole paper

DJDE = DJDE name

< PaperStockID:20lbW >

Description = 20lb White Paper

DJDE = DJDE name

Once you have set up the appropriate PaperStockID options, you will see those options available via Studio's Form manager. Just open a form and select the appropriate paper stock in the Paper Stock field on the Properties tab, as shown here:

Your selection is reflected in the POL file produced by the GenData program. In this example, the form called DEC PAGE has a paper stock ID of Drilled.

;SAMPCO;LB1;DECPAGE;||FORMPAPERSTOCK=Drilled||;R;;QPRUNA|DL(3360,18600)<AGENT,COMPANY,INSURED>

Keep in mind...

  • The paper stock selection applies to the entire form
  • Only the Metacode print driver uses the paper stock selection
  • Only Documaker Studio lets you select the paper stock

Example

<PaperStockIDs>

PaperStockID = Drilled

PaperStockID = 20lb

...(and so on)

<PaperStockID:Drilled>

Description = 3-hole paper

DJDE = DJDE name

<PaperStockID:20lbW>

Description = 20lb White Paper

DJDE = DJDE name

<PrtType:XER>

TrayUsePaperStockID = Yes

Available

Release | 11.2
Patch |

See Also

  • PaperStockIDs
  • PaperStockID:XXX

Used By


UniqueFieldNames

[PrtType:XER]
UniqueFieldNames

[PrtType:XER]

UniqueFieldNames = Edit

Parameter | Description
value | The default value is blank.

Remarks

If this setting is blank or set to No, then the metacode normalize code will look for variable fields whose names end with a pound sign (#) followed by three digits (0-9) and create a tag name without these characters.

Documaker prevents duplicate field names by appending a pound sign (#) followed by three digits (0-9).

For example,

BLARG

BLARG #001

BLARG #002

In this example, 3 tags whose name is BLARG would be created.

If this setting is not blank and is not set to No, then the metacode normalize code will look for variable fields whose names end with a pound sign (#) followed by three digits (0-9) and create a unique tag name for each by replacing the space character before the pound sign (#) with a period (.).

Example

<PrtType:XER>

UniqueFieldNames =

Available

Release | _______
Patch |

Used By


ValidLevel

[PrtType:XER]
ValidLevel

ValidLevel

[PrtType:XER]

ValidLevel = List

Parameter

Description

value
  • 0 - Report only critical problems
  • 1 - Report warnings, continue optimizing
  • 2 - Report warnings and try to fix
  • 3 - Report warnings and exit

The default value is 0

Remarks

METOPT--Use this utility to optimize Metacode print streams before they are sent to the printer.

This utility combines Metacode print records into larger and fewer records. Reducing the number of records that must be transmitted reduces the amount of time needed to spool the Metacode print stream to the printer.

To have this utility notify you if it spots potential problems, add the following option to your PrtType:XER control group:

<PrtType:XER>

ValidLevel =

Regardless of the option you choose, if you receive any warnings, be sure to check closely both the original and, if applicable, the optimized file.

ValidLevel----Enter zero (0) to tell the utility not to report non-critical problems. This is the default. Enter one (1) to tell the utility to report warnings for non-critical problems, but continue optimizing. Enter two (2) to tell the utility to report warnings for non-critical problems and attempt to fix the problems Enter three (3) to tell the utility to report warnings for non-critical problems and exit immediately

Example

<PrtType:XER>

ValidLevel = 0

Available

Release | 10.0
Patch |

Used By


VSAM

[PrtType:XER]
VSAM

VSAM

Remarks

The system lets you store DDT files, precompiled Metacode resources, NA and POL files, and transaction trigger files in VSAM KSDS (Virtual Storage Access Method/Key Sequence Data Set) data sets. For more information on implementing VSAM support under MVS, see Optimizing Performance in the MVS Installation Guide. If you use this feature, you must set the following options in the VSAM control group in the FSISYS.INI file.

Example

<VSAM>

DDTVSAM = DD:DDTVSAM DDT files

METVSAM = DD:PMETVSAM PreCompiled Metacode files

VSAMRCPTB = DD:SETRCPVS Transaction Trigger file

VSAMNA = DD:NAFILE NA and POL files

Available

Release | _______
Patch |

Used By

XERLIB


PrtType:XMP

PrtType:
XMP

The new XMPLIB library has been added so you can use Documaker RP to create Documaker standard XML output. This lets you unload Documaker standard XML output from the GenPrint or GenData programs (using the PrintFormset rule).

NOTE: You must have a Docupresentment (IDS) license to receive this feature.

Here is an example of the INI setup this feature requires:

< Printers >

PrtType = XMP

< PrtType:XMP >

Module = XMPW32

PrintFunc = XMPPrint

When using with Documaker RP, be sure to use the MultiFilePrint functionality to create a separate XML file per transaction. If multiple XML files are written into the same file, the file will not load in an XML parser, browser, or editor.

NOTE: For more information on the Documaker Standard XML format, see Documaker XML guide titled "Working with XML Files", available on the Oracle OTN site.

PrtType:XMP Options

  • Class
  • DownLoadFonts
  • InitFunc
  • Module
  • OverlayExt
  • PageNumbers
  • PrePrintedPaper
  • PrintFunc
  • StreamBufferSize
  • TermFunc
  • Watermark


Class

[PrtType:XMP]
Class

[PrtType:XMP]

Class = List

Parameter | Description
value | The default value is XMP

Remarks

You can use the following INI option to specify the printer classification, such as AFP, PCL, XER, XMP, GDI, etc.

If you omit this option, the system defaults to the first three letters from the Module option.

Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing. If you omit this option, the system defaults to the first three letters from the Module option.

Example

<PrtType:XMP>

Class = XMP

Available

Release | _______
Patch |

Used By


DownLoadFonts

[PrtType:XMP]
DownLoadFonts

[PrtType:XMP]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: No,Enabled

Remarks

This setting is ignored by the Documaker XML print driver.

Example

<PrtType:XMP>

DownLoadFonts = Yes,Enabled

Available

Release | _______
Patch |

Used By


InitFunc

[PrtType:XMP]
InitFunc

[PrtType:XMP]

InitFunc = Edit

Parameter | Description
value | The default value is XMPInit

Remarks

The InitFunc option names the printer function called at the initial printing. Do not change this value.

Example

<PrtType:XMP>

InitFunc = XMPInit

Available

Release

Patch

Used By


Module

[PrtType:XMP]
Module

Module

[PrtType:XMP]

Module = List

Parameter

Description

List

Values can be

  • XMPW32 - (default) XML Print driver module

Remarks

The new XMPLIB library has been added so you can use Documaker RP to create Documaker standard XML output. This lets you unload Documaker standard XML output from the GenPrint or GenData programs (using the PrintFormset rule).

NOTE: You must have a Docupresentment (IDS) license to receive this feature.

Here is an example of the INI setup this feature requires:

<Printers>

PrtType = XMP

<PrtType:XMP>

Module = XMPW32

PrintFunc = XMPPrint

When using with Documaker RP, be sure to use the MultiFilePrint functionality (i.e. the <Print> CallbackFunc = MultiFilePrint INI option for multiple steps or the <PrintFormset> MultiFilePrint = Yes INI option for single step) to create a separate XML file per transaction. If multiple XML files are written into the same file, the file will not load in an XML parser, browser, or editor.

NOTE: For more information on the Documaker Standard XML format, see Documaker XML guide titled "Working with XML Files", available on the Oracle OTN site.

Example

<PrtType:XMP>

Module = XMPW32

PrintFunc = XMPPrint

Available

Release | 11.0
Patch |

Used By

XMPLIB


OverlayExt

[PrtType:XMP]
OverlayExt

[PrtType:XMP]

OverlayExt = Edit

Parameter | Description
extension | a file extension The default is .ovl

Remarks

This setting is ignored by the Documaker XML print driver.

Example

<PrtType:XMP>

OverlayExt = .ovl

Available

Release | _______
Patch |

Used By


PageNumbers

[PrtType:XMP]
PageNumbers

[PrtType:XMP]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

The PageNumbers option activates the page numbering feature. Set this value to Yes to have page numbers printed in the Page X of Y format.

Example

<PrtType:XMP>

PageNumbers = No

Available

Release | _______
Patch |

Used By


PrePrintedPaper

[PrtType:XMP]
PrePrintedPaper

[PrtType:XMP]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enabled or Hidden determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Yes or No determines whether this check box is checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option (Yes,Enabled) includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:XMP>

PrePrintedPaper = No,Hidden

Available

Release | _______
Patch |

Used By


PrintFunc

[PrtType:XMP]
PrintFunc

PrintFunc

[PrtType:XMP]

PrintFunc = Edit

Parameter

Description

List

Values can be

  • XMPPrint - (default) XML Print driver function

Remarks

The new XMPLIB library has been added so you can use Documaker RP to create Documaker standard XML output. This lets you unload Documaker standard XML output from the GenPrint or GenData programs (using the PrintFormset rule).

NOTE: You must have a Docupresentment (IDS) license to receive this feature.

Here is an example of the INI setup this feature requires:

<Printers>

PrtType = XMP

<PrtType:XMP>

Module = XMPW32

PrintFunc = XMPPrint

When using with Documaker RP, be sure to use the MultiFilePrint functionality (i.e. the <Print> CallbackFunc = MultiFilePrint INI option for multiple steps or the <PrintFormset> MultiFilePrint = Yes INI option for single step) to create a separate XML file per transaction. If multiple XML files are written into the same file, the file will not load in an XML parser, browser, or editor.

NOTE: For more information on the Documaker Standard XML format, see Documaker XML guide titled "Working with XML Files", available on the Oracle OTN site.

Example

<PrtType:XMP>

Module = XMPW32

PrintFunc = XMPPrint

Available

Release | 11.0
Patch |

Used By

XMPLIB


StreamBufferSize

[PrtType:XMP]
StreamBufferSize

[PrtType:XMP]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:XMP>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType:XMP]
TermFunc

[PrtType:XMP]

TermFunc = Edit

Parameter | Description
value | The default value is XMPTerm

This option may be required in order for the feature to function.

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Example

<PrtType:XMP>

TermFunc = XMPTerm

Available

Release

Patch

Used By


PrtType:XPS

PrtType:
XPS

XPS is a new electronic paper format invented by Microsoft and used as an alternative to the PDF format. It is expected to have a significant impact on the document world. An XPS document is actually a compressed ZIP archive data file composing of fixed-format parts, relationships, fonts and images, etc.

Unlike PDF and other file formats, XPS is unique in its file structure, which has internal physical and logical organizations (ZIP archive), containing XML markup files, embedded fonts, raster images, vector graphics, as well as the digital rights management information, etc. The contents of an XPS file can be examined simply by opening it in an application with support of ZIP and un-Zip tools.

Many Microsoft products such as 2007 Microsoft Office system programs now export XPS document by installing XPS Document Writer and save as XPS document by inserting save-as XPS adds-in. This allows you to print or save a text layout or a webpage as an XPS file. Then you can use Microsoft XPS Viewer (internet adds-in) or XPS Viewer EP to view XPS document files. This makes your web publication of XPS document more convenient and easier.

  • PrtType:XPS Options

  • bmpType
  • Class
  • CompressLevel
  • Debug
  • Device
  • DeviceCapabFile
  • DigitalSignature
  • DocPTConfig
  • DocPTNumbers
  • DocumentOutline
  • DownLoadFonts
  • DumpPrintCapabilities
  • ExportPrintTicket
  • ForcePrintInColor
  • GlyphIndices
  • InitFunc
  • Intent
  • JobPTConfig
  • Module
  • ObfuscateFonts
  • OutputFunc
  • OverlayExt
  • PageNumbers
  • PagePTConfig
  • PagePTNumbers
  • PrePrintedPaper
  • PrintFunc
  • Resolution
  • SelectRecipients
  • SendColor
  • SignBy
  • SigningLocation
  • StreamBufferSize
  • SubsetFonts
  • TemplateFields
  • TermFunc
  • UniqueFile
  • Watermark


bmpType

[PrtType:XPS]
bmpType

[PrtType:XPS]

bmpType = List

Parameter

Description

value

Values can be

  • HDP
  • JPEG
  • PNG
  • TIFF
  • WMP

The default value is PNG

Remarks

This setting specifies the type of bitmap files to be stored in an XPS document.

Example

<PrtType:XPS>

bmpType = jpeg

Available

Release | 12.0
Patch |

Used By


Class

[PrtType:XPS]
Class

[PrtType:XPS]

Class = List

Parameter | Description
value | The default value is XPS

Remarks

You can use the following INI option to specify the printer classification, such as AFP, PCL, XER, PST, XPS, etc.

If you omit this option, the system defaults to the first three letters from the Module option.

Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing. If you omit this option, the system defaults to the first three letters from the Module option.

Example

<PrtType:XPS>

Class = XPS

Available

Release | 12.0
Patch |

Used By


CompressLevel

[PrtType:XPS]
CompressLevel

[PrtType:XPS]

CompressLevel = Spin

Parameter | Description
value | Range between -1 and 9 with a default of -1

Remarks

Specifies the compression level of XPS document file. You can choose one of following 4 options:

0 – No compression

1 – Best speed

9 – Best compression

-1 – Default compression

An XPS document is a ZIP archived data file that contains document parts compressed in the selected compression level.

Example

<PrtType:XPS>

CompressLevel = 5

Available

Release | 12.0
Patch |

Used By


Debug

[PrtType:XPS]
Debug

[PrtType:XPS]

Debug = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

This setting enables debug information to be written out to a log trace file.

Modify this setting only if directed to by Oracle support.

Example

<PrtType:XPS>

Debug = Yes

Available

Release | 12.0
Patch |

Used By


Device

[PrtType:XPS]
Device

[PrtType:XPS]

Device = Edit

Parameter | Description
value | device or file name. The default value is blank.

Remarks

The name of the printer device you want to use. The name of the file or device (LPT1) where the print stream should be written. This setting is ignored by the GenPrint program but is used by the Image Editor and other system programs.

Example

<PrtType:XPS>

Device = filename

Available

Release | 12.0
Patch |

Used By


DeviceCapabFile

[PrtType:XPS]
DeviceCapabFile

[PrtType:XPS]

DeviceCapabFile = File

Parameter | Description
File | The default is blank.

Remarks

This setting specifies a PrintCapabilities file for the purpose creating device-specific PrintTickets. If this file is not provided, a default PrintCapalibities will be used and, based on it, generic PrintTickets can be generated.

Example

<PrtType:XPS>

DeviceCapabFile =

Available

Release | 12.0
Patch |

Used By


DigitalSignature

[PrtType:XPS]
DigitalSignature

[PrtType:XPS]

DigitalSignature = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

This setting enables digital signature support in the XPS files created.

Example

<PrtType:XPS>

DigitalSignature = No

Available

Release | 12.0
Patch |

Used By


DocPTConfig

[PrtType:XPS]
DocPTConfig

[PrtType:XPS]

DocPTConfig = File

Parameter | Description
File | The default is blank.

Remarks

This is a printer property configuration file for setting up a document level PrintTicket, for example, docpt.ini.

Example

<PrtType:XPS>

DocPTConfig =

Available

Release | 12.0
Patch |

Used By


DocPTNumbers

[PrtType:XPS]
DocPTNumbers

[PrtType:XPS]

DocPTNumbers = Edit

Parameter | Description
value | The default value is 1-100

Remarks

Enter the number of document level PrintTickets to attach. You can enter anything like, 1,3-8,10 The default is 1-100.

Example

<PrtType:XPS>

DocPTNumbers = 1-100

Available

Release | 12.0
Patch |

Used By


DocumentOutline

[PrtType:XPS]
DocumentOutline

[PrtType:XPS]

DocumentOutline = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Document outline contains a structured list of indices into XPS document, similar to a table of contents. You can easily use this feature to navigate through an XPS document when the document becomes huge. This feature is always turned on by default. In some cases if the performance becomes concern, you can turn it off by specifically setting INI option DocumentOutline to No like this,

< PrtType:XPS >

DocumentOutline = No

To use the Document outline, you open a XPS document that contains the feature part DocumentStructure, and select View/Document Outline to start your navigation. The figure below shows a typical Documaker XPS document with the Document Outline. On the left of this figure, the XPS document contains 3 recipient copies of a formset with total 9 pages. The first level is the recipient, the second level is the group, the third level is the form, and the bottom level is the page. When you click on the title of any level, the right side window shows the corresponding page.

Example

<PrtType:XPS>

DocumentOutline = No

Available

Release | 12.0
Patch |

Used By


DownLoadFonts

[PrtType:XPS]
DownLoadFonts

[PrtType:XPS]

DownLoadFonts = YesNoHide

Parameter | Description
boolean | Yes | No Default value is: No,Enabled

Remarks

This setting is ignored by the XPS print driver.

Example

<PrtType:XPS>

DownLoadFonts = Yes,Enabled

Available

Release | 12.0
Patch |

Used By


DumpPrintCapabilities

[PrtType:XPS]
DumpPrintCapabilities

[PrtType:XPS]

DumpPrintCapabilities = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Dump the PrintCapabilities.xml for debug purposes.

Modify this setting only if directed to by Oracle support.

Example

<PrtType:XPS>

DumpPrintCapabilities = Yes

Available

Release | 12.0
Patch |

Used By


ExportPrintTicket

[PrtType:XPS]
ExportPrintTicket

[PrtType:XPS]

ExportPrintTicket = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Enter Yes to export PrintTickets. The default is No.

Example

<PrtType:XPS>

ExportPrintTicket = Yes

Available

Release | 12.0
Patch |

Used By


ForcePrintInColor

[PrtType:XPS]
ForcePrintInColor

[PrtType:XPS]

ForcePrintInColor = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Enter Yes if you want the XPS Driver to print objects in color even if the objects are not set to print in color. The default is No.

Example

<PrtType:XPS>

ForcePrintInColor = Yes

Available

Release | 12.0
Patch |

Used By


GlyphIndices

[PrtType:XPS]
GlyphIndices

[PrtType:XPS]

GlyphIndices = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Enter Yes to export attribute Indices to Glyph element in the fixed page. Default is No.

Modify this setting only if directed to by Oracle support.

Example

<PrtType:XPS>

GlyphIndices = Yes

Available

Release | 12.0
Patch |

Used By


InitFunc

[PrtType:XPS]
InitFunc

[PrtType:XPS]

InitFunc = Edit

Parameter | Description
value | The default value is XPSInit

Remarks

The InitFunc option names the printer function called at the initial printing. Do not change this value.

Example

<PrtType:XPS>

InitFunc = XPSInit

Available

Release | 12.0
Patch |

Used By


Intent

[PrtType:XPS]
Intent

[PrtType:XPS]

Intent = Edit

Parameter | Description
value | The default value is "I have reviewed the contents of this document."

Remarks

This setting contains a string describing the intent of the digital signer.

Example

<PrtType:XPS>

Intent =

Available

Release | 12.0
Patch |

Used By


JobPTConfig

[PrtType:XPS]
JobPTConfig

[PrtType:XPS]

JobPTConfig = File

Parameter | Description
File | The default is blank.

Remarks

This is a user defined printer property configuration file for implementing or modifying job level PrintTicket settings, for example, jobpt.ini.

Example

<PrtType:XPS>

JobPTConfig =

Available

Release | 12.0
Patch |

Used By


Module

[PrtType:XPS]
Module

[PrtType:XPS]

Module = Edit

Parameter | Description
value | The default value is XPSW32

Remarks

Module specifies the print DLL name. Do not change this value.

Example

<PrtType:XPS>

Module = XPSW32

Available

Release | 12.0
Patch |

Used By


ObfuscateFonts

[PrtType:XPS]
ObfuscateFonts

[PrtType:XPS]

ObfuscateFonts = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

For the copyright protection of fonts, the XML Page Specification sets some rules for users to follow. According to the rules, whether or not the embedded fonts should be obfuscated based on the fsType field of OS/2 table in the font file. Microsoft XPS products always obfuscate fonts. Documaker XPS Print Driver honors this requirement by default. However you can turn it off by specifically setting ObfuscateFonts INI option to No like this,

< PrtType:XPS >

ObfuscateFonts = No

Note that generally an XPS documents receiver is an individual who does not have the authorization to use and install embedded fonts.

An obfuscated TrueType font has an extension .odttf while TrueType collection has an extension .odttc. The obfuscated TrueType font has a name similar to this,

EFFDCE3C-E263-49A5-953A-A0D2913F032A.odttf

Obfuscated font files embedded within an XPS document cannot be directly installed on any client operating system. These fonts can be shared and referenced internally since they are closely tied to contents referencing them, but cannot be moved from one document package to another.

Example

<PrtType:XPS>

ObfuscateFonts = No

Available

Release | 12.0
Patch |

Used By


OutputFunc

[PrtType:XPS]
OutputFunc

[PrtType:XER]

OutputFunc = Edit

Parameter | Description
value | The default value is XPSOutputFunc

Remarks

This option specifies the print function name. Do not change this option's value.

Example

<PrtType:XPS>

OutputFunc = XEROutputFunc

Available

Release | 12.0
Patch |

Used By


OverlayExt

[PrtType:XPS]
OverlayExt

[PrtType:XPS]

OverlayExt = Edit

Parameter | Description
extension | a file extension The default is .ovl

Remarks

This setting is ignored by the XPS print driver.

Example

<PrtType:XPS>

OverlayExt = .ovl

Available

Release | 12.0
Patch |

Used By


PageNumbers

[PrtType:XPS]
PageNumbers

[PrtType:XPS]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

The PageNumbers option activates the page numbering feature. Set this value to Yes to have page numbers printed in the Page X of Y format.

Example

<PrtType:XPS>

PageNumbers = No

Available

Release | 12.0
Patch |

Used By


PagePTConfig

[PrtType:XPS]
PagePTConfig

[PrtType:XPS]

PagePTConfig = File

Parameter | Description
File | The default is blank.

Remarks

This is a printer property configuration file for setting up a page level PrintTicket, for example, pagept.ini

Example

<PrtType:XPS>

PagePTConfig =

Available

Release | 12.0
Patch |

Used By


PagePTNumbers

[PrtType:XPS]
PagePTNumbers

[PrtType:XPS]

PagePTNumbers = Edit

Parameter | Description
value | The default value is 1-100

Remarks

Enter the number of page level PrintTickets to attach. You can enter anything like, 1,3-8,10 The default is 1-100.

Example

<PrtType:XPS>

PagePTNumbers = 1-100

Available

Release | 12.0
Patch |

Used By


PrePrintedPaper

[PrtType:XPS]
PrePrintedPaper

[PrtType:XPS]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enabled or Hidden determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Yes or No determines whether this check box is checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option (Yes,Enabled) includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:XPS>

PrePrintedPaper = No,Hidden

Available

Release | 12.0
Patch |

Used By


PrintFunc

[PrtType:XPS]
PrintFunc

[PrtType:XPS]

PrintFunc = Edit

Parameter | Description
value | The default value is XPSPrint

Remarks

PrinFunc defines the print function name. Do not change this option's value.

Example

<PrtType:XPS>

PrintFunc = XPSPrint

Available

Release | 12.0
Patch |

Used By


Resolution

[PrtType:XPS]
Resolution

[PrtType:XPS]

Resolution = Edit

Parameter | Description
value | The default value is 96

Remarks

Use the Resolution option to specify the dots per inch resolution used in the XPS file.

Example

<PrtType:XPS>

Resolution = 96

Available

Release | 12.0
Patch |

Used By


SelectRecipients

[PrtType:XPS]
SelectRecipients

[PrtType:XPS]

SelectRecipients = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enabled or Hidden determines if the check box which lets you print or not print pre-printed objects appears on the Print window. Yes or No determines whether this check box is checked or unchecked. You must add this option to the INI file if you do not want the check box to be checked or appear on the Print window.

The default for this option (Yes,Enabled) includes the checkbox on the Print window and leaves it checked. All objects except fields can be designated as pre-printed on the object's Properties window in the Image Editor.

Example

<PrtType:XPS>

SelectRecipients = No,Hidden

Available

Release | 12.0
Patch |

Used By


SendColor

[PrtType:XPS]
SendColor

[PrtType:XPS]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

This setting enables objects to print in color.

Example

<PrtType:XPS>

SendColor = Yes,Enabled

Available

Release | 12.0
Patch |

Used By


SignBy

[PrtType:XPS]
SignBy

[PrtType:XPS]

SignBy = Edit

Parameter | Description
value | The default value is blank.

Remarks

This setting contains a string describing the date and time by which this document must be signed.

If blank, a string is generated containing a date and time that is 30 days in the future.

Example

<PrtType:XPS>

SignBy =

Available

Release | 12.0
Patch |

Used By


SigningLocation

[PrtType:XPS]
SigningLocation

[PrtType:XPS]

SigningLocation = Edit

Parameter | Description
value | The default value is blank.

Remarks

This setting contains the location (e.g. Atlanta, GA) where the document was signed.

Example

<PrtType:XPS>

SigningLocation =

Available

Release | 12.0
Patch |

Used By


StreamBufferSize

[PrtType:XPS]
StreamBufferSize

[PrtType:XPS]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:XPS>

StreamBufferSize = 0

Available

Release | 12.0
Patch |

Used By


SubsetFonts

[PrtType:XPS]
SubsetFonts

[PrtType:XPS]

SubsetFonts = LimitList

Parameter

Description

value

Values can be

  • FDOC
  • FDSEQ
  • NO

The default value is FDSEQ

Remarks

Enter FDSEQ to subset fonts at fixed doc sequence level.

Enter FDOC to subset fonts at fixed document level.

Default is FDSEQ

Modify this setting only if directed to by Oracle support.

Example

<PrtType:XPS>

SubsetFonts = NO

Available

Release | 12.0
Patch |

Used By


TermFunc

[PrtType:XPS]
TermFunc

[PrtType:XPS]

TermFunc = Edit

Parameter | Description
value | The default value is XPSTerm

Remarks

This option specifies the printer function called at the completion of the printing process. Do not change this option's value.

Example

<PrtType:XPS>

TermFunc = XPSTerm

Available

Release | 12.0
Patch |

Used By


UniqueFile

[PrtType:XPS]
UniqueFile

[PrtType:XPS]

UniqueFile = LimitList

Parameter | Description
number | Values can be 0, 8, or 46 The default value is 0

Remarks

Enter 8 to generate a unique name of 8 characters. Enter 46 to generate a unique name of 46 characters.

Example

<PrtType:XPS>

UniqueFile = NO

Available

Release | 12.0
Patch |

Used By


PrtType:XXX

PrtType:
XXX

Remarks

Use the <PrtType:XXX> control group to define the settings for a printer type, where xxx represents the name of that printer type. You may name it any thing you like, but it must match with the value assigned to the PrtType INI option in the <Printer> control group, which is used by the Documaker Rules Processing System (GENPRINT or single step GENDATA), or in the <Printers> control group, which is used by the Documaker Studio or the Documaker Workstation.

You may define as many printer type groups as you need in the INI file. Below is an example:

You may use the PCL printer for sample printing and the Xerox printer for production printing. Let's say you want to show them as "Sample" and "Massive" respectively on the printer drop-down list in Documaker Studio or Documaker Workstation. You can have a <PrtType:Sample> control group to define the settings for the PCL printer, and a <PrType:Massive> control group to define the settings for the Xerox printer. You would need the following entries in the INI file so that you may pick the printer type off the printer drop-down list when you want to print a form from Documaker Studio or Documaker Workstation:

<Printers>

PrtType = Sample

PrtType = Massive

You would need the PrtType = Sample or Massive entry in the <Printer> control group, depending upon which type of print stream files you want to produce with GENPRINT or GENDATA (single step).

PrtType:XXX Options

  • AdjLeftMargin
  • AllRecipients
  • Class
  • Device
  • DownLoadFonts
  • InitFunc
  • Module
  • MultipleCopies
  • OverlayExt
  • OverlayPath
  • PageNumbers
  • PrePrintedPaper
  • PrintFunc
  • PrintViewOnly
  • Resolution
  • SelectRecipients
  • SendColor
  • SendOverlays
  • StreamBufferSize
  • TemplateFields
  • TermFunc
  • Tray#
  • Watermark


AdjLeftMargin

[PrtType: ]
AdjLeftMargin

AdjLeftMargin

[PrtType:XXX]

AdjLeftMargin = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Automatically adjusts the left margin to compensate for the 1/4-inch left margin added by PCL printers.

Yes = Automatically adjust the left margin. Forms print exactly as they appear on screen (default).

No = Do not adjust the left margin. Forms may not print correctly on PCL printers after performing a retrieve function.

Example

<PrtType:XXX>

AdjLeftMargin = No

Available

Release | _______
Patch |

Used By


AllRecipients

[PrtType: ]
AllRecipients

AllRecipients

[PrtType:XXX]

AllRecipients = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Lets you customize how users select recipients.

Enter Yes if you want the All Recipients field pre-selected so the system will print copies for all recipients. Enter No if you want to make the user choose the individual recipients which should receive printed copies. If you enter Yes for the SelectRecipients option and omit this option, the system defaults to pre-selecting the All Recipients field.

Example

<PrtType:XXX>

AllRecipients = No,Enabled

Available

Release | 10.1
Patch |

Used By


Class

[PrtType: ]
Class

Class

[PrtType:XXX]

Class = List

Parameter

Description

value

Values can be

  • AFP
  • EPT
  • GDI
  • HTML
  • MDR
  • PCL
  • PDF
  • PST
  • PXL
  • RTF
  • VPP
  • XER
  • XMP

The default value is PCL

Remarks

The Class option specifies the type of the printer.

If you omit this option, the system defaults to the first three letters from the Module option.

If you omit this option, the system defaults to the first three letters from the Module option. Some internal functions expect a certain type of printer. For instance, all 2-up functions require an AFP printer. The internal functions check the Class option to make sure the correct printer is available before continuing.

Example

<PrtType:PCL>

Class = PCL

Available

Release | _______
Patch |

Used By


Device

[PrtType: ]
Device

Device

[PrtType:XXX]

Device = Edit

Parameter | Description
Edit | The default is blank.

Remarks

The Device option specifies the Printer Device (e.g. LPT1 for a local printer, or the print file name).

Example

<PrtType:XXX>

Device = LPT1

<PrtType:XXX>

Device = batch1.pcl

Available

Release | _______
Patch |

Used By


DownLoadFonts

[PrtType: ]
DownLoadFonts

DownLoadFonts

[PrtType:XXX]

DownLoadFonts = YesNoHide

Parameter | Description
YesNoHide | Yes | No Default value is: Yes, Enabled

Remarks

This INI option contains two components: Parameter 1 and Parameter 2, separated by a comma ",".

Use parameter 1 to tell the system whether the fonts should be downloaded or not. The value of parameter 1 is Yes or No. The default is Yes. For PCL 6 printers, this option must set to Yes, because currently internal font selection is not supported. For Genprint, when the system attempts to download fonts, here is what happens:

The system will find the FXR file (generally in the defib directory), then attempt to find the fonts. The system first looks for the fonts in the INI file Fontlib directory. If you do not define the fontlib option, the system will then look in the INI file deflib directory for the fonts. (Tip: You must define either or both the Fontlib and Deflib options with valid paths in the INI file. Otherwise, the system will return an error DM12041.)

Use parameter 2 to tell the system whether the "Download fonts" checkbox should be displayed and editable on the "Print" window in Documaker Studio, Documaker Workstation or Image Editor. The values of this parameters are Enabled, Disabled or Hidden. The default is Enabled.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window.

This print window option lets the user download to the printer the fonts needed to correctly print the format.

Example

<PrtType:XXX>

DownLoadFonts = No,Enabled

Available

Release | _______
Patch |

Used By


InitFunc

[PrtType: ]
InitFunc

InitFunc

[PrtType:XXX]

InitFunc = Edit

Parameter

Description

List

Values can be

  • XERInit - XER (Metacode) Initialization function
  • GDIInit - GDI Initialization function

The default value is blank.

Remarks

The InitFunc option names the printer function called at the initial printing. You do not need to specify this INI option for the print type to work, except that if you are using the caching file functionality of the Metacode print type to improve the performance or if you are using GDI print type.

Example

<PrtType:XXX>

Module = XERW32

PrintFunc = XERPrint

InitFunc = XERInit

Available

Release | _______
Patch |

Used By


Module

[PrtType: ]
Module

Module

[PrtType:XXX]

Module = File

Parameter

Description

List

Values can be

  • AFPPRT - AFP print driver module
  • EPTW32 - EPT (Email Print) print driver module
  • GDIW32 - GDI print driver module
  • HTMW32 - HTML print driver module
  • MDRW32 - MDR (Multiple Driver Router) print driver module
  • PCLW32 - PCL print driver module
  • PDFW32 - PDF print driver module
  • PSTW32 - PST print driver module
  • PXLW32 - PXL (PCL 6) print driver module
  • RTFW32 - RTF print driver module
  • VPPW32 - VIPP print driver module
  • XERW32 - XER (Metacode) print driver module
  • XMPW32 - XML print driver module

The default value is PCLW32

Remarks

The Module option specifies the print module (i.e. the DLL file name) for the print type. This option is required for any print type other than the system default PrtType:PCL.

Example

<PrtType:XXX>

Module = PCLW32

Available

Release | _______
Patch |

Used By


MultipleCopies

[PrtType: ]
MultipleCopies

MultipleCopies

[PrtType:XXX]

MultipleCopies = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

This print window option lets the user print multiple copies of the document set.

Set this option to Yes to enable the "Number of copies" option on the Print Window. The default is No.

Example

<PrtType:XXX>

MultipleCopies = Yes

Available

Release | _______
Patch |

Used By


OverlayExt

[PrtType: ]
OverlayExt

OverlayExt

[PrtType:XXX]

OverlayExt = Edit

Parameter | Description
value | .met | .ovl The default value is .ovl

Remarks

Use the OverlayExt option to specify the overlay file extension (.met for Metacode and .ovl for other print streams.) If you turn on the SendOverlays option, and your overlay file extension name is other than the default overlay extension (MET for Metacode overlays and OVL for other printer overlays), you would need to specify the overlay file extension in the INI file. (Note: The SendOverlays option is supported by AFP, Metacode, PCL (but not PCL 6), PostScript, and VIPP print drivers.)

Example

<PrtType:XXX>

OverlayExt = .ovl

Available

Release | _______
Patch |

Used By


OverlayPath

[PrtType: ]
OverlayPath

OverlayPath

[PrtType:XXX]

OverlayPath = Path

Parameter | Description
Path | The default value is blank.

Remarks

The OverlayPath option specifies the directory containing the printer overlays for each FAP file. The default location is the FormLib option of the MasterResource control group. For example, in the following INI entries, the FormLib in the MasterResource control group sets to the FormLib value defined in the My_MRL configuration group, which in turn points to the Forms directory under the current directory.

<CONFIG:My_MRL>

FormLib = FORMS\

<MasterResource>

FormLib = <CONFIG:My_MRL> FormLib =

You can enter an absolute (d:\dap\myinc\mstrres\forms\overlays\) or relative path (..\mstrres\forms\overlays\)

Note: The Overlays function is not supported for the PCL6 and GDI print types.

Example

<PrtType:XXX>

OverlayPath = .\Forms\

Available

Release | _______
Patch |

Used By


PageNumbers

[PrtType: ]
PageNumbers

PageNumbers

[PrtType:XXX]

PageNumbers = YN

Parameter | Description
boolean | Yes | No The default value is Yes

Remarks

Set to Yes to enable form or form set page numbering.

Example

<PrtType:XXX>

Class = PCL

Device = .\Data\Batch1.pcl

DownloadFonts = Yes

Module = PCLW32

PageNumbers = No

PrintFunc = PCLPrint

Available

Release | _______
Patch |

Used By


PrePrintedPaper

[PrtType: ]
PrePrintedPaper

PrePrintedPaper

[PrtType:XXX]

PrePrintedPaper = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

An option called "Pre-Printed" was added to all objects with the exception of variable fields.

Variable fields have an option "Never Print" instead of Pre-Printed. This means that user entry is allowed but that the field will NEVER print. This option is supported for all fields including barcode fields and multi-line text fields.

Marking an item "Preprinted" tells the system NOT to print this object when you print the image. Using a pre-printed flag on an object can be useful during forms creation or when test printing your forms. You may be using letterhead or special paper that has the company name or logo already embossed on the paper. Inserting a text label or logo on your form in the same location as the company name or logo helps to ensure that that space isn't inadvertently written over by other objects. These objects would 'reserve' that space on the form. You may wish to include pre-printed objects when test printing the form to compare against your special paper to make sure that there is enough space on the special paper for the non pre-printed objects.

By default, the Print dialog will not display a Pre-printed option. Any objects flagged with Pre-printed will not print on the form. In order to display the Pre-printed option on your print dialog and control the printing of preprinted objects on the image the following ini option must be included in the appropriate printer group.

[PrtType:XXX]

PrePrintedPaper = Yes,Enabled

for example:

[PrtType:PCL]

PrePrintedPaper = Yes,Enabled

NOTE: The PDF print driver does not support the Pre-Printed option. The PrePrintedPaper INI option is ignored by PDFLIB. Any object that specifies the Pre-Printed option will print when using the PDF printer Leaving the Pre-Printed paper option unchecked on the print dialog tells the system to print those objects that are flagged as pre-printed along with your other objects on that image.

Example

[PrtType:XXX]

PrePrintedPaper = No,Enabled

Available

Release | 10.0
Patch |

Used By


PrintFunc

[PrtType: ]
PrintFunc

PrintFunc

[PrtType:XXX]

PrintFunc = PCLPrint

Parameter

Description

List

Values can be

  • AFPPrint - AFP print driver function
  • EPTPrint - EPT (Email Print) print driver function
  • GDIPrint - GDI print driver function
  • HTMPrint - HTML print driver function
  • MDRPrint - MDR (Multiple Driver Router) print driver function
  • RTFPrint - RTF print driver function
  • PCLPrint - PCL print driver function
  • PDFPrint - PDF print driver function
  • PSTPrint - PST print driver function
  • PXLPrint - PXL (PCL 6) print driver function
  • VPPPrint - VIPP print driver function
  • XERPrint - XER (Metacode) print driver function
  • XMPPrint - XML print driver function

The default value is PCLPrint

Remarks

The PrintFunc option specifies the print function name for the print type. This option is required for any print type other than the system default PrtType:PCL.

Example

<PrtType:XXX>

PrintFunc = PCLPrint

Available

Release | _______
Patch |

Used By


PrintViewOnly

[PrtType: ]
PrintViewOnly

PrintViewOnly

[PrtType:XXX]

PrintViewOnly = YN

Parameter | Description
boolean | Yes | No The default value is No

Remarks

Display only forms can be used to represent pre-printed forms for view-only in the Entry system. In order to print ViewOnly objects a new INI option, PrintViewOnly, was added. This INI option is supported for any print driver.

<PrtType:XXX>

PrintViewOnly =

If this option is set to Yes, the view only images will print. Default is No. This does not apply to entry only images, which are never printed. Entry only images usually are the worksheet type of forms. If the image is marked as hidden and view only, it will not print. DDT files are now loaded for the ViewOnly image. If DDT file does not exist, no error message will be displayed.

Example

<PrtType:XXX>

PrintViewOnly = Yes

Available

Release | 10.0
Patch |

Used By


Resolution

[PrtType: ]
Resolution

Resolution

[PrtType:XXX]

Resolution = Spin

Parameter | Description
number | 0 - 99999999 The default value is 300 dpi

Remarks

Specify the dots per inch (dpi) resolution of the printer that will receive the data stream.

Example

<PrtType:XXX>

Resolution = 300

Available

Release | _______
Patch |

Used By


SelectRecipients

[PrtType: ]
SelectRecipients

SelectRecipients

[PrtType:XXX]

SelectRecipients = YesNoHide

Parameter | Description
boolean | Yes | No The default value is Yes,Enabled

Remarks

Enter Yes to have the system pre-select this option when the Print window appears.

Use the SelectRecipients option to tell the system whether to pre-select this option when the Print window appears.

This INI option contains two components: Parameter 1 and Parameter 2, separated by a comma ",".

Use parameter 1 to tell the system whether to pre-select this option when the Print window appears. The value of parameter 1 is Yes or No. The default is Yes.

Use parameter 2 to tell the system whether the "Select recipients" checkbox should be displayed and editable on the "Print" window in Documaker Studio or Documaker Workstation. The values of this parameters are Enabled, Disabled or Hidden.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window.

Example

<PrtType:XXX>

SelectRecipients = No,Enabled

Available

Release | 10.1
Patch |

Used By


SendColor

[PrtType: ]
SendColor

SendColor

[PrtType:XXX]

SendColor = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

Use the SendColor option to tell the system whether to print in color. This INI option contains two components: Parameter 1 and Parameter 2, separated by a comma ",".

Use parameter 1 to tell the system whether to print in color. The value of parameter 1 is Yes or No. The default is No.

Use parameter 2 to tell the system whether the "Send color" checkbox should be displayed and editable on the "Print" window in Documaker Studio or Documaker Workstation. The values of this parameters are Enabled, Disabled or Hidden. The default is Enabled.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window.

Example

<PrtType:XXX>

SendColor = Yes,Enabled

Available

Release | _______
Patch |

Used By


SendOverlays

[PrtType: ]
SendOverlays

SendOverlays

[PrtType:XXX]

SendOverlays = YesNoHide

Parameter | Description
boolean | Yes | No The default value is No,Enabled

Remarks

Use the SendOverlays option to tell the system whether to use the printer overlays. This INI option contains two components: Parameter 1 and Parameter 2, separated by a comma ",".

Use parameter 1 to tell the system whether to use the overlays or not. The value of parameter 1 is Yes or No. The default is No. If SendOverlays = Yes is specified, make sure that you have compiled the image files (i.e. FAP files) to the printer language files (i.e. overlays) by running the Conversion Utilities or the Conversion Wizard of Documaker Studio, and also be sure that you have specified the INI option:

<RunMode>

DownloadFAP=No

Performance Tip:

The Genprint program of Documaker Rules Processing System wil usually run faster if SendOverlays=Yes is used.

The SendOverlays option is supported by AFP, Metacode, PCL (but not PCL 6), and PostScript print drivers.

For Metacode printing, the SENDOVERLAY and COMPILEINSTREAM options are mutually exclusive. If the value < Print > COMPILEINSTREAM = Yes, then SENDOVERLAY must be No.

Use parameter 2 to tell the system whether the "Send overlays" checkbox should be displayed and editable on the "Print" window in Documaker Studio or Documaker Workstation. The values of this parameters are Enabled, Disabled or Hidden. The default is Enabled.

Enabled = Option appears in the Print window and is active (available to be checked).

Disabled = Option appears in the Print window but is grayed out (not available to be checked).

Hidden = Option does not appear in the Print window.

Example

<PrtType:XXX>

SendOverlays = Yes,Enabled

Available

Release | _______
Patch |

Used By


StreamBufferSize

[PrtType: ]
StreamBufferSize

[PrtType:XXX]

StreamBufferSize = Edit

Parameter | Description
numeric value | The default value is 0

Remarks

The value is the number of bytes to use for buffering. This may allow for some performance tuning. 0 means to use the default buffer size.

Example

<PrtType:XXX>

StreamBufferSize = 0

Available

Release | _______
Patch |

Used By


TermFunc

[PrtType: ]
TermFunc

TermFunc

[PrtType:XXX]

TermFunc = List

Parameter

Description

value

Values can be

  • XERTerm - XER (Metacode) Termination function
  • GDITerm - GDI Termination function

The default value is blank.

Remarks

The TermFunc option names the printer function called at termination of printing. You do not need to specify this INI option for the print type to work, except that if you are using the caching file functionality of the Metacode print type to improve the performance or if you are using GDI print type.

Example

<PrtType:XXX>

Module = XERW32

PrintFunc = XERPrint

InitFunc = XERInit

TermFunc = XERTerm

Available

Release | _______
Patch |

Used By


Tray#

[PrtType: ]
Tray#

Tray#

[PrtType:XXX]

Tray# = Edit

Parameter | Description
Edit |

Remarks

Use the Tray# (where # is a number from 1 to 9) to specify a tray.

Example

<PrtType:XXX>

Tray1 = 1

Tray2 = 2

Available

Release | _______
Patch |

Used By


Watermark

[PrtType: ]
Watermark

Watermark

Parameter | Description
Boolean | Yes or no. Default setting is no.

Remarks

Use this watermark option to specify that print should include a watermark. You define the details in the watermark group.

Example

<PrtType:XXX>

Watermark = Yes

Available

Release | Rel 12.1
Patch |

Used By


RacLib

RacLib Options

  • DisableHook


DisableHook

[RacLib]
DisableHook

DisableHook

[ RacLib]

DisableHook =

Parameter | Description
value | value

Example

< RACLIB >

DisableHook =

Available

Release | _______
Patch |


RecipMap2GVM

RecipMap2GVM Options

  • Form
  • Image
  • Opt
  • Req
  • WarnOnLocate


Form

[RecipMap2GVM]
Form

Form

Enter the name of the form. (This is an optional setting)

[ RecipMap2GVM]

Form =

Parameter | Description
value | Enter the name of the form

Remarks

The GenData program now lets you add unique data to each recipient batch record before it is written to the recipient batch files. The recipient batch record data and format is defined by the GVM variable definitions in the RCBDFDFL.DAT file.

You can use this feature if you need to add:

Address information or other field level information to the batch record, which is typically unique for each recipient.

Recipient information that is not handled by normal field mapping from the transaction DFD to the recipient batch DFD.

Cumulative or calculated information not available until the document is nearly completed.

Before this feature was implemented, the recipient batch records were identical except for the recipient code field which contains a unique identifier assigned to a given recipient. If additional recipient data was required, you had to write a custom rule.

Use the options in the RecipMap2GVM control group to set up this capability. Data that can be added to the recipient batch record can be:

Contents of a variable field on the specified image or form/image

Constant value

Data from an existing INI built-in functions, such as ~DALRun

Data from a custom written INI function

Example

< RecipMap2GVM >

Form =

Available

Release | 10.2
Patch | 38


Image

[RecipMap2GVM]
Image

Image

Enter the name of the image.

[ RecipMap2GVM]

Image =

Parameter | Description
value | Enter the name of the image.

Remarks

You can also enter an image name root. An image name root is the first part of a name. For instance, MAILER is the root name for images with names such as MAILER_ A, MAILER_B, or MAILERS.

Example

< RecipMap2GVM >

Image =

Available

Release | 10.2
Patch | 38


Opt

[RecipMap2GVM]
Opt

Opt

[ RecipMap2GVM]

Opt =

Parameter | Description
value | A semi-colon delimited string

Remarks

A semi-colon delimited string that contains one of the following:

- GVM variable name; variable field name; optional formatting information

- GVM variable name; blank character (space); constant value

- GVM variable name; INI built-in function

Repeat for each GVM variable you are setting up.

Example

< RecipMap2GVM >

Opt =

Available

Release | 10.2
Patch | 38


Req

[RecipMap2GVM]
Req

Req

[ RecipMap2GVM]

Req =

Parameter | Description
value | A semi-colon delimited string

Remarks

A semi-colon delimited string that contains one of the following:

- GVM variable name; variable field name; optional formatting information

- GVM variable name; blank character (space); constant value

- GVM variable name; INI built-in function

Repeat for each GVM variable you are setting up.

Available

Release | 10.2
Patch | 38


WarnOnLocate

[RecipMap2GVM]
WarnOnLocate

WarnOnLocate

[ RecipMap2GVM]

WarnOnLocate = True

Parameter | Description
Boolean (True) | Default value is: True

Remarks

WarnOnLocate = False will turn off the following RP Warning Message :

DM13029: Warning in RCBMapFromINI(): Cannot locate image root named/image named <MAILER> in RecipMap2GVM INI Group for recipient <INSURED> in Formset <>.

Tip: Check if the image root named/image named <MAILER> is triggered for this recipient <INSURED>

Example

< RecipMap2GVM >

WarnOnLocate = True/False

Available

Release | 11.0
Patch | 45


Record_Type

Record_Type Options

  • Assign
  • New
  • Partial


Assign

[Record_Type]
Assign

Assign

The RecordType option defines which INI option to locate in the Record_Type control group as the default setting for WIP RecType

[ Record_Type]

Assign =

Parameter | Description
value | The RecordType option defines which INI option to locate in the Record_Type control group as the default setting for WIP RecType.

Example

< Record_Type >

Assign = 01

Available

Release | 10.1
Patch | 135


New

[Record_Type]
New

New

The RecordType option defines which INI option to locate in the Record_Type control group as the default setting for WIP RecType

[ Record_Type]

New =

Parameter | Description
value | New is the normal default for the AFG2WIP control group and would therefore map 00 into the WIP RecType field.

Remarks

New is the normal default for the AFG2WIP control group and would therefore map 00 into the WIP RecType field.

< Record_Type >

New =00

Example

< Record_Type >

New =00

Available

Release | 10.1
Patch | 135


Partial

[Record_Type]
Partial

Partial

The RecordType option defines which INI option to locate in the Record_Type control group as the default setting for WIP RecType

[ Record_Type]

Partial =

Parameter | Description
value | The RecordType option defines which INI option to locate in the Record_Type control group as the default setting for WIP RecType.

Example

< Record_Type >

Partial = 02

Available

Release | 10.1
Patch | 135


RecordDictionary

Remarks

Name

RecordDictionary Options

  • Name


Name

[RecordDictionary]
Name

Name

Use the Name option to enter the name of the Record Dictionary file.

[ RecordDictionary]

Name = File

Parameter | Description
File | Use the Name option to enter the name of the Record Dictionary file.

Example

< Record Dictionary >

Name =

Available

Release | 10.0
Patch |


Records

Remarks

Message

Records Options

  • Account
  • Message


Account

[Records]
Account

Account

[ Records]

Account = Edit

Parameter | Description
value |

Remarks

The Records section begins with the tag <Records> and has the record name to the left of the equals sign and the record description to the right of the equals sign.

Record names must be unique and are not case sensitive. The name you enter can contain up to 30 characters and must begin with an alpha character. Here is an example:

<Records>

Message = Search (61,01) Repeating

Record descriptions provide information about the record. At a minimum, you must include the search mask for the record as the parameter to the Search keyword. If a record occurs only once per transaction it is a non-repeating record and no further formatting is required.

Use the Repeating keyword to tell the system there may be several records of that type within the transaction.

Example

<Records>

Account = Search(61,02)

Available

Release | 10.0
Patch |


Message

[Records]
Message

Message

[ Records]

Message = Edit

Parameter | Description
value |

Remarks

The Records section begins with the tag <Records> and has the record name to the left of the equals sign and the record description to the right of the equals sign.

Record names must be unique and are not case sensitive. The name you enter can contain up to 30 characters and must begin with an alpha character. Here is an example:

<Records>

Message = Search (61,01) Repeating

Record descriptions provide information about the record. At a minimum, you must include the search mask for the record as the parameter to the Search keyword. If a record occurs only once per transaction it is a non-repeating record and no further formatting is required.

Use the Repeating keyword to tell the system there may be several records of that type within the transaction.

Example

<Records>

Message = Search(61,01) Repeating

Available

Release | 10.0
Patch |


Resources

Remarks

DEFLIB

Resources Options

  • DEFLIB
  • FONTS
  • FORMLIB
  • XRFEXT
  • XRFFILE


DEFLIB

[Resources]
DEFLIB

DEFLIB

[ Resources]

DEFLIB = Path

Parameter | Description
Path | DefLib is the directory path of FORM.DAT and FXR files (default location of font files).

Remarks

DefLib is the directory path of Form set definition file and FXR files (default location of font files).

Example

< RESOURCES >

DEFLIB = .\DEFLIB\

Available

Release | _______
Patch |


FONTS

[Resources]
FONTS

FONTS

This option specifies the directory path of font files.

[ Resources]

FONTS = Path

Parameter | Description
Path | This option specifies the directory path of font files.

Example

< RESOURCES >

FONTS = ..\fmres\deflib\

Available

Release | _______
Patch |


FORMLIB

[Resources]
FORMLIB

FORMLIB

FormLib defines the directory path of library forms and logos.

[ Resources]

FORMLIB = Path

Parameter | Description
Path | FormLib defines the directory path of library forms and logos.

Example

< RESOURCES >

FORMLIB = .\FORMS\

Available

Release | _______
Patch |


XRFEXT

[Resources]
XRFEXT

XRFEXT

This option identifies the file extension (FXR) for font cross reference files.

[ Resources]

XRFEXT =

Parameter | Description
value | This option identifies the file extension (FXR) for font cross reference files.

Example

< RESOURCES >

XRFEXT = .FXR

Available

Release | _______
Patch |


XRFFILE

[Resources]
XRFFILE

XRFFILE

This option specifies the name of the font cross reference file.

[ Resources]

XRFFILE =

Parameter | Description
value | This option specifies the name of the font cross reference file.

Example

< RESOURCES >

XRFFILE = REL113

Available

Release | _______
Patch |


CheckCount

[Restart]
CheckCount

CheckCount

Enter a number to specify the number of transactions to process before updating the offsets.

[ Restart]

CheckCount =

Parameter | Description
value | Enter a number to specify the number of transactions to process before updating the offsets.

Remarks

For instance, if you specify two hundred (200), the system processes two hundred transactions, updates the offsets, processes two hundred more transactions, and so on. The default is 100. You can also use the /cnt command line option with the GenData program to override the CheckCount option. Here is an example:

Gendaw32 /cnt=10

Example

< Restart >

CheckCount =

Available

Release | 10.1
Patch |


RstFile

[Restart]
RstFile

RstFile

Enter the name of the restart file.

[ Restart]

RstFile =

Parameter | Description
value | Enter the name of the restart file.

Remarks

If you omit this option, the system uses RSTFILE.RST (DD:RSTFILE for MVS) as the file name. The system uses the DataPath option in the Data control group to determine where to create the restart file. The default location is the current working directory.

Example

< Restart >

RstFile =

Available

Release | 10.1
Patch |


RTFDefaultFont

RTFDefaultFont Options

When converting an RTF file, a default font name can be specified in the INI file. If there is a tie for the best match this font name will be used if possible. If the INI entry is not specified then Albany AMT is used as the default. Here is an example of the INI entry:

< RTFDefaultFont >
RTFDefaultFont = Courier

For more information on RTF font substituion, see RTFFontSubs


[RTFDefaultFont]
RTFDefaultFont

RTFDefaultFont

[ RTFImport]

RTFDefaultFont =

Parameter | Description
value | The default value is Albany AMT

Remarks

A default font name can be specified in the INI file. If there is a tie for the best match this font name will be used if possible. If the INI entry is not specified then Albany AMT is used as the default.

See also RTFFontSubs .

Example

< RTFImport >

RTFDefaultFont = Courier

Available

Release | 11.5
Patch |

Used By

RTFLIB


RTFFontSubs

RTF Font Substitution

While importing rtf files, the fonts used in that rtf need to be matched with fonts in the FXR. To find the best match, many attributes are considered. A score is determined for how well the attributes match up and the font with the highest score is used. Below is a description of how the overall font matching process works. To simply things, the font we are trying to match from the RTF file will be called the RTF font. The fonts in the FXR will be called FXR fonts.

  • If the RTF font uses UNICODE characters then a UNICODE font in the FXR will always be picked over a non-UNICODE font.
  • The best match for the name of the font is checked. The RTF font name is compared with the family name of the FXR font.
    • If a full match isn’t found then partial matches are allowed for some fonts (Times and Courier).
    • The user can specify specific matches in the ini section “RTFFontSubs”. Here is an example of an entry:
      < RTFFontSubs >

Arial = Albany AMT:UNIVERS:HELV

The name on the left is the facename of the RTF font. On the right, each matching FXR font’s family name is separated with a semicolon. Preference is given to the names listed first.

    • A default font name can be specified in the INI file. If there is a tie for the best match this font name will be used if possible. If the INI entry is not specified then Albany AMT is used as the default. Here is an example of the INI entry:
      < RTFDefaultFont >
      RTFDefaultFont = Courier
  • The font sizes are matched as closely as possible. The difference between the font sizes is considered. If the difference is too large (over 2 point sizes in most cases) then a facename match is disregarded. This allows fonts of a different name to be used if their font size is a much closer match.
  • Other attributes are considered such as if the font is bold or italic.

For debugging purposes Font substitution messages can be written to the trace file and the Output window by adding the following to the users ini file:

[Debug_Switches]

Enable_Debug_Options = Yes

DEBUG_FONTSUBS = Yes

RTFFontSubs Options

  • Arial


Arial

Use the RTFFontSubs INI group to specify the font the Docucreate system substitutes when importing an RTF file.

< RTFFontSubs >

Arial = Albany AMT:UNIVERS:HELV

Parameter | Description
Font name | FXR Font Name(s) separated by colons

Remarks

The user can specify specific matches in the ini section “RTFFontSubs”.

The name on the left is the facename of the RTF font.

On the right, each matching FXR font’s family name is separated with a semicolon.

Preference is given to the names listed first.

Example

< RTFFontSubs >

Arial = Albany AMT:UNIVERS:HELV

Available

Release | 11.5
Patch |


RTFFontMap

RTFFontMap Options

NOTE: This INI group is available for legacy purposes.

RTFFontSubs is the preferred method for specifying font substitution when converting RTF files into sections.

When converting a file from one format to another, you may need to convert the fonts used in the document. You can use INI control groups and options to map fonts in a source document to the fonts you want to use in the destination document. For instance, if you are converting an RTF file into a FAP file, you can use the following control group:

< RTFFontMAP >

Arial = Swiss

This tells the system to convert all Arial fonts into Swiss fonts.

Use this control group when converting DCD files into FAP files:

< FontFamilyMatching >

Arial = Swiss

RTF and DCD files contain font information about the generic font families used. For example, Arial and Univers, both san serif proportional fonts, belong to a generic font family called Swiss.

The RTF and DCD converters in the system use the RTFFontMap and FontFamilyMatching control groups to assign a font when other means of mapping fonts from the RTF or DCD file fails.

In Windows environments, there are several generic font families, as shown in this table:

Family | Description
Decorative | Specifies a novelty font, such as Old English.
Dontcare | Specifies a generic family name. This name is used when information about a font does not exist or does not matter. The default font is used.
Modern | Specifies a monospace font with or without serifs. Monospace fonts are usually modern fonts, such as Pica, Elite, and Courier New.
Roman | Specifies a proportional font with serifs, such as Times New Roman.
Script | Specifies a font that is designed to look like handwriting, such as Script and Cursive.
Swiss | Specifies a proportional font without serifs, such as Arial.


Roman

[RTFFontMap]
Roman

Roman

Use this FAPCOMP.INI control group to specify the font the Docucreate system substitutes when importing an RTF file.

[ RTFFontMap]

Roman = Edit

Parameter | Description
Edit |

Remarks

You can include up to eight font substitution entries in the RTFFontMap control group. The INI values shown above are the default settings for these fonts. The syntax for group options is:

RTF Font Name = FXR Font Family Name

Example

< RTFFontMap >

Roman = Times

Swiss = Helv

Modern = Courier

Script =

Decorative =

Technical =

Bidi =

Available

Release | _______
Patch |


RTFImport

RTFImport Options

  • CellGapPercent
  • DefaultFieldLength
  • DefaultFieldScope
  • PageNumMask
  • ParseFieldNameType
  • RemoveEmbeddedLogos
  • SeperateFAPs


CellGapPercent

CellGapPercent

[ RTFImport]

CellGapPercent =

Parameter | Description
long | Percentage of Table Cell Gap value to apply. Values can range from 50 - 125. Default value is: 100.

Remarks

When selected the RTF import process will apply the percentage of the table cell gap value. This option is used to provide a little extra space for text formatting. Values less than 100 increase text formatting space and values greater than 100 reduce formatting space. This option is typically used to force text to fit in table cells when fonts have been substituted.

Example

< RTFImport >

CellGapPercent = 85

Available

Release | 12.1
Patch |

Used By

RTFLIB


DefaultFieldLength

[RTFImport]
DefaultFieldLength

DefaultFieldLength

[ RTFImport]

DefaultFieldLength = 12

Parameter | Description
Length | Default value is: 50

Remarks

This option is used to allow RTF importing (RTF2FAP) default the field length.

< RTFImport >

DefaultFieldLength = 10

Example

< RTFImport >

DefaultFieldLength = 10

Available

Release | 11.4
Patch |

Used By

RTFLIB


DefaultFieldScope

[RTFImport]
DefaultFieldScope

DefaultFieldScope

[ RTFImport]

DefaultFieldScope = Global

Parameter

Description

LimitList

Values can be

  • 3 - Global
  • 1 - Form
  • 0 - Section

Default value is: Section

Remarks

This option is used to allow RTF importing (RTF2FAP) default the field scope to Form or Global instead of local section scope. Use the DefaultFieldScope option in the RTFImport control group to set the scope as Global or Form.

Here is an example of how you would set the DefaultFieldScope option to Global:

< RTFImport >

DefaultFieldScope = Global

You can also enter Form to specify form scope. The default is section scope.

Example

< RTFImport >

DefaultFieldScope = Global

Available

Release | 10.2
Patch | 21

Used By

RTFLIB


PageNumMask

[RTFImport]
PageNumMask

PageNumMask

[ RTFImport]

PageNumMask = string

Parameter | Description
Edit | Default value is empty

Remarks

Specify the separator between the name and page number for files generated when BurstPages is 'Yes'.

The separator may be nothing, a blank, an underscore, number sign or valid file name character(s).

The separator is appended to the generated name prior to page number.

Below are examples using various PageNumMask settings:

Page | Default | PageNumMask = _ | PageNumMask = # | PageNumMask = RTF
1 | Myfile1 | Myfile_1 | Myfile#1 | MyfileRTF1
1 | Myfile1 | Myfile_1 | Myfile#1 | MyfileRTF1
1 | Myfile1 | Myfile_1 | Myfile#1 | MyfileRTF1

Example

< RTFImport >

BurstPages = Yes

PageNumMask = #

Available

Release | 11.5
Patch |

Used By

RTFLIB


ParseFieldNameType

[RTFImport]
ParseFieldNameType

ParseFieldNameType

[ RTFImport]

ParseFieldNameType = None, <fieldname>, «fieldname», <<fieldname>>, {fieldname}, [fieldname], |-fieldname-|, IStream Migration

Parameter

Description

long
  • 0 None
  • 1 <fieldname>
  • 2 «fieldname»
  • 3 <<fieldname>>
  • 4 {fieldname}
  • 5 [fieldname]
  • 6 |-fieldname-|
  • 10 IStream Migration

The default value is 0

Remarks

When selected the import process will parse text content for field names identified between field delimiters. The field name without the field delimiters is added to the document. Duplicate field names are appended with a counter. On Windows, the field database is accessed to retrieve additional field attributes.

See also PageNumMask .

Example

< RTFImport >

ParseFieldNameType = 10

Available

Release | 12.0
Patch |

Used By

RTFLIB


RemoveEmbeddedLogos

[RTFImport]
RemoveEmbeddedLogos

RemoveEmbeddedLogos

[ RTFImport]

RemoveEmbeddedLogos = Yes

Parameter | Description
Boolean | Default value is: No

Remarks

When this option is set to yes, the system will create separate graphic (LOG) files. These files are named according to the name in the RTF. Many times this is a computer generated ID.

When this option is set to no, the graphics are embedded into the section (FAP) file itself. Embedded graphics can be removed later by editing the FAP and replacing the graphic or unchecking the embedded option for the graphic.

< RTFImport >

RemoveEmbeddedLogos = Yes

Example

< RTFImport >

RemoveEmbeddedLogos = Yes

Available

Release | 11.4
Patch |

Used By

RTFLIB


SeparateFAPs

[RTFImport]
SeparateFAPs

SeparateFAPs

[ RTFImport]

SeparateFAPs = Yes/No

Parameter | Description
boolean | Yes | No The default value is No

Remarks

When 'Yes', the import process will generate a section (FAP) for each section imported into the form. When 'No' these sections are embedded within the form.

See also PageNumMask .

Example

< RTFImport >

SeparateFAPs = Yes

Available

Release | 11.5
Patch |

Used By

RTFLIB


RunMode

Example

< RunMode >

ChkDstLenExceeded = Yes

CompiledFAP = Yes

DownLoadFAP = Yes

LoadCordFAP = No

LoadFAPBitmap = No

NAUnload = Yes

RunMode Options

  • AliasPrintBatches
  • CheckZeroFontID
  • ChkDstLenExceeded
  • CompiledFAP
  • DownLoadFAP
  • FlushDALSymbols
  • LoadCordFAP
  • LoadFAPBitmap
  • MasterDDTNotInLibrary
  • MergedDDTs
  • NAUnload
  • OpSystem
  • PreRel113GrpPagi
  • SendOverlays
  • XMLExtract
  • XMLFileExtract
  • XMLFileExtractName


AliasPrintBatches

[RunMode]
AliasPrintBatches

AliasPrintBatches

Set this option value to Yes to let users of the batch system group all of their print batches (.BCH files) in one file.

[ RunMode]

AliasPrintBatches = Yes

Parameter | Description
boolean | Set this option value to Yes to let users of the batch system group all of their print batches (.BCH files) in one file. Default value is: Yes

Remarks

Additionally you must make the following entry in the <DATA> control group:

<DATA>

BatchTable = <tablename>

If a path is not specified here, the option DATAPATH in the <DATA> group will be used.

Use this FSISYS.INI control group to define various runtime parameters to control batch processing.

Example

< RUNMODE >

AliasPrintBtches = Yes

Available

Release | _______
Patch |


CheckZeroFontID

[RunMode]
CheckZeroFontID

CheckZeroFontID

[ RunMode]

CheckZeroFontID = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Version 11.1 adds a new runtime INI option that tells the system to display a warning or error message if the field being processed contains a font ID equal to zero (0).

Typically, this means no font was assigned during the mapping. Since the merging of FAP and DDT files in version 11.0, the field definition should be complete at the time of processing. So if you encounter a field with no font ID assigned, it probably means some unusual situation has occurred like the field was defined via an import method but not actually defined on the FAP file where it resides.

Enter Yes (or Error) to have the system to issue an error message if it encounters a font ID set to zero (0). If you enter Yes (or Error) and the system encounters a font ID of zero, you get a message similar to this:

DM30046: Error: Field < FLDNAME > on Image < IMGNAME > has Font ID = 0. The field may have been included incorrectly or the FAP has not been updated to include the field's definition.

Enter Warn if you want the system to issue a warning message if it encounters a font ID set to zero. If you enter Warn and the system encounters a font ID of zero, you will get a message similar to this:

DM30046: Warning: Field < FLDNAME > on Image < IMGNAME> has Font ID = 0. The field may have been included incorrectly or the FAP has not been updated to include the field's definition.

In either message, FLDNAME and IMGNAME are reflect the appropriate field name and image name. The default is No, which means nothing is checked and no message is issued.

Example

< RunMode>

CheckZeroFontID = Yes, Error, Warning, or No

Available

Release | 11.0
Patch | 45


ChkDstLenExceeded

[RunMode]
ChkDstLenExceeded

ChkDstLenExceeded

Indicates whether destination length should be checked for overflow.

[ RunMode]

ChkDstLenExceeded = YN

Parameter | Description
Boolean | Yes | No

Remarks

The ChkDstLenExceeded option indicates whether checking should be performed, when values are copied from a &quot;source&quot; field to a &quot;destination&quot; field, to determine whether the copying of the value causes the length of the destination field to be exceeded.

Yes - checking is performed.

No - checking is not performed.

Example

< RunMode >

ChkDstLenExceeded = Yes

Available

Release | _______
Patch |

Used By

GENDATA, GENPRINT


CompiledFAP

[RunMode]
CompiledFAP

CompiledFAP

Indicates whether Compiled FAPs are being used.

[ RunMode]

CompiledFAP = Yes

Parameter | Description
Boolean | Yes | No Default value is: Yes

Remarks

The CompiledFAP option indicates whether the Gendata and Genprint programs should read FAPs from the Compiled FAP location or the standard FORMLIB. The Compiled FAP location is pointed to by <MasterResource> CompLib option. The standard FORMLIB is pointed to by the <MasterResource> FormLib option.

Yes - Compiled FAPs are used.

No - Compiled FAPs are not used.

Since, in some cases, you must load FAP files, the system includes utilities which let you pre-compile FAP files and FXR files. By pre-compiling these files into CFA (FAP) and CFX (FXR) files, you can speed performance by eliminating parsing operations. The system is set up to use pre-compiled FAP and FXR files. You can see this setting below:

<RunMode>

CompiledFAP=Yes

To turn off this setting, change the Yes to No. We recommend you leave the setting set to Yes.

Example

< RunMode >

CompiledFAP = Yes

Available

Release | 10.0
Patch |

Used By

GENDATA, GENPRINT


DownLoadFAP

[RunMode]
DownLoadFAP

DownLoadFAP

Indicates whether Genprint should load FAPs.

[ RunMode]

DownLoadFAP = No

Parameter | Description
Boolean | Yes | No Default value is: No

Remarks

The DownLoadFAP option indicates whether the GENPRINT program is to load FAP files into memory.

Yes - Genprint downloads FAPs.

No - Genprint does not download FAPs.

Performance:

Xerox Print:

If you are using Xerox pre-compiled metacode files (PMETs), you should set DownLoadFAP=No, since GENPRINT does not need to load or compile the FAPs if they are already compiled into PMETs. If you are not using pre-compiled metacode files you should set DownLoadFAP=Yes. For best Xerox performance, use DownLoadFAP=No in combination with the Xerox Print Group option:

<PrtType:XER> CompileInstream = No

AFP Print:

If you are using AFP Overlays, you should set DownLoadFAP=No, since GENPRINT does not need to load or compile the FAPs if they are already compiled into AFP Overlays. If you are not using AFP Overlays, you should set DownLoadFAP=Yes. For best AFP performance, use DownLoadFAP=No in combination with the AFP Print Group option:

<PrtType:AFP> SendOverlays = Yes

NOTE: For single step Gendata, LoadCorpFAP is closely tied to DownLoadFAP.

If DownLoadFAP is set to Yes, the system will always set LoadCorpFAP to Yes no matter whether the user set it to Yes or No.

For example:

If the INI file contains

< RunMode >

DownLoadFAP = Yes

LoadCordFAP = No

the system will change it into

< RunMode >

DownLoadFAP = Yes

LoadCordFAP = Yes

Example

< RunMode >

DownLoadFAP = No

Available

Release | 10.0
Patch |

Used By

GENDATA, GENPRINT


FlushDALSymbols

[RunMode]
FlushDALSymbols

FlushDALSymbols

Indicates whether GenData should clear all DAL variables between transactions.

[ RunMode]

FlushDALSymbols = No

Parameter | Description
boolean | Indicates whether GenData should clear all DAL variables between transactions. Default value is: No

Remarks

The FlushDALSymbols option indicates whether GenData should clear all DAL variables between transactions.

Yes - clear all variables between transactions.

No - do not clear all variables between transactions.

Example

< RunMode >

FlushDALSymbols = Yes

Available

Release | 10.2
Patch | 59


LoadCordFAP

[RunMode]
LoadCordFAP

LoadCordFAP

Indicates whether Gendata should load FAPs.

[ RunMode]

LoadCordFAP = Yes

Parameter | Description
Boolean | Yes | No Default value is: Yes

Remarks

The LoadCordFAP option indicates whether GENDATA is to obtain Image coordinates from the FAP (Yes) or from the DDT (No).

Yes - load and obtain coordinates from FAPs.

No - do not load FAPs; obtain coordinates from DDTs.

Performance: For best performance, use LoadCordFAP=No.

NOTE: For single step Gendata, LoadCorpFAP is closely tied to DownLoadFAP.

If DownLoadFAP is set to Yes, the system will always set LoadCorpFAP to Yes no matter whether the user set it to Yes or No.

For example:

If the INI file contains

< RunMode >

DownLoadFAP = Yes

LoadCordFAP = No

the system will change it into

< RunMode >

DownLoadFAP = Yes

LoadCordFAP = Yes

Example

< RunMode >

LoadCordFAP = No

Available

Release | 10.0
Patch |

Used By

GENDATA, GENPRINT


LoadFAPBitmap

[RunMode]
LoadFAPBitmap

LoadFAPBitmap

[ RunMode]

LoadFAPBitmap = YN

Parameter | Description
Boolean | This option is set for AFP Print type only so that FAPS that have more than one in-line graphic object on them will be able to print them all.

Remarks

This option is set for AFP Print type only so that FAPS that have more than one in-line graphic object on them will be able to print them all.

Example

< RunMode >

LoadFAPBitmap = Yes

Available

Release | _______
Patch |

Used By

GENDATA, GENPRINT


MasterDDTNotInLibrary

[RunMode]
MasterDDTNotInLibrary

MasterDDTNotInLibrary

[ RunMode]

MasterDDTNotInLibrary = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Normally, if you define the DDTFile option in the MasterResource control group to point to a library containing DDT files, the system expects to find all DDT files there, including the MASTER.DDT file. Set this INI option to Yes if the MASTER.DDT file should be excluded from being located in the library and is in the DEFLIB location instead.

The only advantage to having an external MASTER.DDT file is if your setup creates the MASTER.DDT file on the fly, before a transaction is run. If that is the case, it is easier to manipulate if it is outside of the library.

Example

< RunMode >

MasterDDTNotInLibrary = Yes

Available

Release | 10.3
Patch | 11


MergedDDTs

[RunMode]
MergedDDTs

MergedDDTs

[ RunMode]

MergedDDTs = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Remarks

If you are using BDF file, the GenData program will, by default, not use the DDT files. It assumes that the DDT information is merged in the FAP files, if the BDF file exists. If your DDT files are separated from the FAP files while you are using the BDF file, then you need to turn off the MergedDDTs INI option, otherwise, your NAFILE.DAT file will not contain field records when you run the GenData program.

Example

< RunMode >

MergedDDTs = No

Available

Release | 10.3
Patch |


NAUnload

[RunMode]
NAUnload

NAUnload

This option determines whether GenData unloads the internal FAP structure at the form set level or at field level.

[ RunMode]

NAUnload = Yes

Parameter | Description
Boolean (Yes) | This option determines whether GenData unloads the internal FAP structure at the form set level or at field level. Default value is: Yes

Remarks

Yes: The GenData program unloads the internal FAP structure at the form set level

No: The GenData program unloads the internal FAP structure at the field level. (Always use NAUNLOAD = Yes; never set it to No.)

Example

< RunMode >

NAUnload = Yes

Available

Release | _______
Patch |


OpSystem

[RunMode]
OpSystem

OpSystem

To specify the origination platform of an extract file.

[ RunMode]

OpSystem = Edit

Parameter | Description
value | To specify the origination platform of an extract file.

Remarks

If you enter OS400, the system loads an EBCDIC conversion table which handles binary number conversions for source extract files originating from an IBM AS/400 system.

Example

< RunMode >

OpSystem =

Available

Release | 10.1
Patch |


PreRel113GrpPagi

[RunMode]
PreRel113GrpPagi

PreRel113GrpPagi

To specify the origination platform of an extract file.

[ RunMode]

PreRel113GrpPagi = YN

Parameter | Description
Boolean |

Remarks

Setting the INI value listed below will restore the pre Rel 11.3 pagination.

Example

< RunMode >

PreRel113GrpPagi = Yes

Available

Release | 11.3
Patch |


SendOverlays

[RunMode]
SendOverlays

SendOverlays

This option sends images compiled into printer language to the printer.

[ RunMode]

SendOverlays = No

Parameter | Description
Boolean | This option sends images compiled into printer language to the printer Default value is: No

Remarks

Sending overlays enhances print speed so this option should be set to Yes.

NOTE: For Metacode printing, the SENDOVERLAY and COMPILEINSTREAM options are mutually exclusive. If the value < Print > COMPILEINSTREAM = Yes, then SENDOVERLAY must be No.

The GenPrint program merges static data with the data in the NA file. Static data can come from FAP files or from overlay files. FAP files contain some information, such as updating information, which is not needed by the GenPrint program.

FAP files are larger than overlays and the system must also parse these files. Therefore, it's more efficient to compile FAP files into overlays and tell the GenPrint program to use overlays instead of FAP files. You do this for AFP, PCL and Postscript printers by setting the DownLoadFap and SendOverlays INI options as shown below:

<RunMode>

DownLoadFap = No

SendOverlays = Yes

Example

< RUNMODE >

SendOverlays = Yes

Available

Release | 10.0
Patch |


XMLExtract

[RunMode]
XMLExtract

XMLExtract

MAPPING FIELDS WITH XPATH

[ RunMode]

XMLExtract = YN

Parameter | Description
Boolean | To let the system know you are using the XML file, set the XMLTrnFields option in the TRN_File control group to Yes and also set the XMLExtract option in the RunMode control group to Yes.

Remarks

The GenTrn program and the NoGenTrnTransactionProc rule now let you use the TRN_Fields control group to map all of your fields with the XPath. To let the system know you are using the XML file, set the XMLTrnFields option in the TRN_File control group to Yes and also set the XMLExtract option in the RunMode control group to Yes.

Example

< RunMode >

XMLExtract = Yes

Available

Release | _______
Patch |


XMLFileExtract

[RunMode]
XMLFileExtract

XMLFileExtract

Enter Yes to tell the system your extract file is a list of pointers pointing to the XML file.

[ RunMode]

XMLFileExtract = YN

Parameter | Description
Boolean | Enter Yes to tell the system your extract file is a list of pointers pointing to the XML file.

Example

< RunMode >

XMLFileExtract = Yes

Available

Release | _______
Patch |


XMLFileExtractName

[RunMode]
XMLFileExtractName

XMLFileExtractName

Use this option to tell the system how to find your XML file.

[ RunMode]

XMLFileExtractName = Edit

Parameter | Description
value | Use this option to tell the system how to find your XML file. Enter the method you use to point to your XML file. This should be exactly the same as how you would set up the rule parameter for the XMLFileExtract rule in your AFGJOB.JDTfile.

Remarks

Enter the method you use to point to your XML file. This should be exactly the same as how you would set up the rule parameter for the XMLFileExtract rule in your AFGJOB.JDTfile.

Example

< RunMode >

XMLFileExtractName = SCH=1,XML 20,60

Available

Release | _______
Patch |


SignOn

SignOn Options

  • UserID


UserID

[SignOn]
UserID

UserID

Use this FSIUSER.INI group to specify which user is logged on to the system.

[ SignOn]

UserID =

Parameter | Description
Edit | Use this FSIUSER.INI group to specify which user is logged on to the system.

Remarks

The USERID option assigns a valid userID from the USERINFO database. The following INI values are recommended:

OPTION: Assign each user a password and make them log in every time they run the system

INI Setting: <Environment>

Do_Logon = Yes

RESULT: The logon window appears at the beginning of every Entry session.

Please Note: Set up user IDs and passwords using the Tools, User ID Maintenance menu

OPTION: Assign each user a password and automatically log them in every time they run the system

INI Setting: <Environment>

Do_Logon = Yes

<SignOn>

UserID = USER1

RESULT: The user is automatically logged onto the Entry System. The logon window does not appear. Set up user IDs and passwords using the Tools, User ID Maintenance menu option. Each user should have their own FSIUSER.INI file with their own user ID.

You can use the ~ENCRYPTED INI function to encrypt those confidential information in the INI file, such as the <DBHandler:xxx> UserID and Passwd INI options, or <SignOn> UserID INI option.

To get the encrypted value, you can execute the CRYRU utility. Here is an example of how you could use this utility on Windows:

cryruw32.exe user1 (where User1 is the string that you want to encrypt.)

The result would be something like this:

Encrypted string (2yz76tCkk0BRiPqLJLG00)

You then paste the value 2yz76tCkk0BRiPqLJLG00 into an INI file and use the

~ENCRYPTED INI function, as shown in this example:

< SignOn >

UserID = ~ENCRYPTED 2yz76tCkk0BRiPqLJLG00

When Documaker application runs and gets the value of the UserID option in the SignOn control group, it will get the real value USER1.

NOTE: The encryption method used is proprietary.

Keep in mind these limitations:

* Only Windows and UNIX platforms are supported.

* This feature has nothing to do with secure PDF or PDF encryption.

* Almost any INI option can be encrypted.

Example

< SignOn >

UserID = USER1

Available

Release | _______
Patch |


Sort

Sort Options

  • Default


Default

[Sort]
Default

Default

This FSIUSER.INI control group determines the default sort order of policies that appear in a list window.

[ Sort]

Default =

Parameter | Description
value | This FSIUSER.INI control group determines the default sort order of policies that appear in a list window.

Remarks

Values entered in the Default option correspond to entries contained in the Sort_Menu control

group. To list policies by the date the policy was modified and by current user, enter the

corresponding numbers from the Sort_Menu control group options. In the Sort_Menu which

follows, the entry would be 08, 07.

<Sort_Menu >

01 = ;Key1;Company;N;A;

02 = ;Key2;LOB;N;A;

03 = ;KeyID;Policy Number;Y;A;

04 = ;RecType;Record Type;N;A;

05 = ;CreateTime;Create Time;N;A;

06 = ;OrigUser;Original User;N;A;

07 = ;CurrUser;Current User;Y;A;

08 = ;ModifyTime;Modify Time;Y;D;

09 = ;FormsetID;Formset ID;N;A;

Example

< Sort >

Default = 08,07

Available

Release | _______
Patch |


Sort_Forms

Remarks

TableName

Sort_Forms Options

  • TableName


TableName

[Sort_Forms]
TableName

TableName

Feature 1350 Sorting Forms by Recipient

[ Sort_Forms]

TableName = Edit

Parameter | Description
TableName |

Remarks

Use the SortFormsForRecip call back function to sort forms in a different order, depending on recipient. This function reads the given sort table and sorts the forms by recipient. A form identifier called a Document Type Number (DTN) tells the system how to sort the forms. The DTN resides in the form description of the Form set definition file (form.dat, .BDF, .GRP, or .FOR) and begins with a tilde (~).

Example

< Sort_Forms >

TableName = ..\Mstrres\Table\Sort.tbl

Available

Release | 10.3
Patch |


Sort_Menu

The FSIUSER.INI Sort_Menu control group defines the menu for policy sorting. You can configure the Processing System to sort policies according to your company's needs.

[ Sort_Menu]

NUMERIC ID = ;FIELD NAME;FIELD DESCRIPTION;DISPLAY FLAG;SORT ORDER

Parameter | Description
numeric id | Number of the field. Used to specify default sort keys.
Field Name | Name of field in WIP file. Do not change.
Field Description | Description of the field displayed on the sort menu
Display Flag | Controls the appearance of the field in the sort menu "Y" = Field enabled "N" = Field not enabled
Sort Order | Controls the order of the sort "A" = Sort in ascending order "D" = Sort in descending order

Remarks

You can configure the Processing System to sort policies according to your company's needs. The option parameters in the Sort Menu control group determine whether or not a sort option is enabled or disabled, and whether information is sorted in ascending (A) or descending (D) order.

Example

< Sort_Menu >

01 = ;Key1;Company;N;A;

02 = ;Key2;LOB;N;A;

03 = ;KeyID;Policy Number;Y;A;

04 = ;RecType;Record Type;N;A;

05 = ;CreateTime;Create Time;N;A;

06 = ;OrigUser;Original User;N;A;

07 = ;CurrUser;Current User;Y;A;

08 = ;ModifyTime;Modify Time;Y;D;

09 = ;FormsetID;Formset ID;N;A;

10 = ;TranCode;Transaction Code;Y;A;

11 = ;StatusCode;Status Code;Y;A;

12 = ;FormUserID;From User ID;N;A;

13 = ;FromTime;From Time;N;A;

14 = ;ToUserID;To User ID;N;A;

15 = ;ToTime;To Time;N;A;

16 = ;Desc;Description;N;A;

17 = ;InUse;In Use;N;A;

18 = ;RecNum;Record Number;N;A;

Available

Release | _______
Patch |


Spell

Remarks

Spell Check Considerations

The < Spell > group defines spelling options used by the system. All of the options have system defaults, therefore this group is not required in order to use the spell checking feature. Any settings differing from the system defaults must reside in the INI file.

You can use the Spelling Options… menu option or click theSetup… button on the Spell Check window in the system.

  1. From the Spelling Options window, select the language in the Language field. You can choose from several languages, including Danish, Dutch, Finnish, French, German, Italian, Norwegian, Portuguese(Brazil), Spanish, Swedish, UK English, and US English.
  2. Click any or all of the following spell check options:
    • Ignore capitalized words - skip capitalized words, such as ASCII.
    • Ignore words with numbers - skip words containing numbers, such as Y2K.
    • Ignore words with mixed case - skip words containing both upper- and lowercase letters, regardless of spelling. When you select this option, the Report words with mixed case option is inactivated.
    • Report words with mixed case - locate words containing both upper- and lowercase letters, regardless of spelling. When you select this option, the Ignore words with mixes case option is inactivated.
    • Treat apostrophe as word separator - check letters on both sides of an apostrophe as separate words.
    • Treat hyphen as word separator - check letters on both sides of a hyphen as separate words.
    • Case sensitive - check for improper capitalization
    • Accept compound words - accept compound words (mainly useful if you are checking German text)
    • Suggest splitting compound words - make suggestions on how to split compound words
    • Phonetic suggestions - make suggestions based on how the misspelled word sounds when spoken
    • Typographical suggestions - make suggestions based on how the word is typed
    • Always Suggest - show suggested spellings.
  3. Click OK.

Example

< Spell >

AlwaysSuggest = Yes

ApostropheSeparator =

CaseSensitive =

FixedDialogPos =

HyphenSeparator =

IgnoreCappedWords =

IgnoreMixedCase =

IgnoreMixedDigits =

MainDicts = ssceam.tlx,ssceam2.clx

PhoneticSugg =

ReportMixedCase =

SplitWords =

SuggestDepth = 100

SuggestSplit =

TypographicalSugg =

UserDict = user.tlx

Spell Options

  • AlwaysSuggest
  • ApostropheSeparator
  • CaseSensitive
  • FixedDialogPos
  • HyphenSeparator
  • IgnoreCappedWords
  • IgnoreMixedCase
  • IgnoreMixedDigits
  • MainDicts
  • PhoneticSugg
  • ReportMixedCase
  • SplitWords
  • SuggestDepth
  • SuggestSplit
  • TypographicalSugg
  • UserDict


AlwaysSuggest

[Spell]
AlwaysSuggest

AlwaysSuggest

Show suggested spellings.

[ Spell]

AlwaysSuggest = YN

Parameter | Description
Boolean | True or false value.

Remarks

The default value of True is supplied if this option is not set in the INI file.

Example

< Spell >

AlwaysSuggest = No

Available

Release | _______
Patch |


ApostropheSeparator

[Spell]
ApostropheSeparator

ApostropheSeparator

Treat apostrophe as a word separator

[ Spell]

ApostropheSeparator = Edit

Parameter | Description
Edit |

Remarks

Check letters on both sides of an apostrophe as separate words.

Example

< Spell >

ApostropheSeparator =

Available

Release | _______
Patch |


CaseSensitive

[Spell]
CaseSensitive

CaseSensitive

Check for improper capitalization.

[ Spell]

CaseSensitive =

Example

< Spell >

CaseSensitive =

Available

Release | _______
Patch |


FixedDialogPos

[Spell]
FixedDialogPos

FixedDialogPos

To anchor the Spell window and not have it float, depending on the location of the text it highlights.

[ Spell]

FixedDialogPos = No

Parameter | Description
boolean | To anchor the Spell window and not have it float, depending on the location of the text it highlights. Default value is: No

Remarks

Enter Yes to anchor the window. The default is No.

Example

< Spell >

FixedDialogPos =

Available

Release | 10.1
Patch |


HyphenSeparator

[Spell]
HyphenSeparator

HyphenSeparator

Treat hyphen as word separator.

[ Spell]

HyphenSeparator =

Remarks

Check letters on both sides of a hyphen as separate words.

Example

< Spell >

HyphenSeparator =

Available

Release | _______
Patch |


IgnoreCappedWords

[Spell]
IgnoreCappedWords

IgnoreCappedWords

Spell Check ignores words in all caps.

[ Spell]

IgnoreCappedWords = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Spell >

IgnoreCappedWords =

Available

Release | _______
Patch |


IgnoreMixedCase

[Spell]
IgnoreMixedCase

IgnoreMixedCase

Spell Check ignores words in mixed case.

[ Spell]

IgnoreMixedCase = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Spell >

IgnoreMixedCase =

Available

Release | _______
Patch |


IgnoreMixedDigits

[Spell]
IgnoreMixedDigits

IgnoreMixedDigits

Spell Check ignores words with mixed digits.

[ Spell]

IgnoreMixedDigits = No

Parameter | Description
Boolean (No) | Default value is: No

Example

< Spell >

IgnoreMixedDigits =

Available

Release | _______
Patch |


MainDicts

[Spell]
MainDicts

MainDicts

[ Spell]

MainDicts = LimitList

Parameter

Description

MainDicts

Values can be

  • ssceaf.tlx,ssceaf.clx - Afrikaans
  • sscepb.tlx,sscepb2.clx - Brazilian Portuguese
  • ssceda.tlx,ssceda2.clx - Danish
  • sscedu.tlx,sscedu2.clx - Dutch
  • sscefi.tlx,sscefi2.clx - Finnish
  • sscefr.tlx,sscefr2.clx - French
  • sscege.tlx,sscege2.clx - German
  • ssceit.tlx,ssceit1.clx - Italian
  • sscenb.tlx,sscenb2.clx - Norwegian
  • sscepo.tlx,sscepo2.clx - Portuguese
  • sscesp.tlx,sscesp2.clx - Spanish
  • sscesw.tlx,sscesw2.clx - Swedish
  • sscebr.tlx,sscebr2.clx - UK English
  • ssceam.tlx,ssceam2.clx - US English

Remarks

Two files are required to define the dictionary information for each language; "ssceLLc.tlx" and "ssceLLn.clx", where "LL" identifies the language and 'n' identifies a revision number of the library. For instance, sscefr.tlx, sscefr2.clx identifies the French dictionary files.

The list above shows the possible choices for the the MainDicts value.

Example

This example establishes the default dictionary to use as US English.

< Spell >

MainDicts = ssceam.tlx,ssceam2.clx

Available

Release | _______
Patch |


PhoneticSugg

[Spell]
PhoneticSugg

PhoneticSugg

Make suggestions based on how the misspelled word sounds when spoken.

[ Spell]

PhoneticSugg = Edit

Parameter | Description
Edit |

Example

< Spell >

PhoneticSugg =

Available

Release | _______
Patch |


ReportMixedCase

[Spell]
ReportMixedCase

ReportMixedCase

Reports mixed case words.

[ Spell]

ReportMixedCase = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Example

< Spell >

ReportMixedCase =

Available

Release | _______
Patch |


SplitWords

[Spell]
SplitWords

SplitWords

Accept compound words.

[ Spell]

SplitWords = Edit

Parameter | Description
Edit |

Remarks

This option is useful if you are checking German text.

Example

< Spell >

SplitWords =

Available

Release | _______
Patch |


SuggestDepth

[Spell]
SuggestDepth

SuggestDepth

[ Spell]

SuggestDepth = 0

Parameter

Description

LimitList

Values can be

  • 100 - Complete
  • 50 - Moderate
  • 0 - Quick

Default value is: 0

Remarks

These options control how quickly and how completely the spell checker searches for errors.

[Spell]

SuggestDepth = 0

The default is zero (0).

If your users notice the spell checker is not finding errors in commonly used words, try setting the spell checker at a different setting.

To have the spell checker work more quickly, but find fewer items Enter 0 (zero)

To have the spell checker work moderately fast and accurate Enter 50

To have the spell checker work slowly, but very accurately Enter 100

Example

< Spell >

SuggestDepth = 50

Available

Release | 10.0
Patch |


SuggestSplit

[Spell]
SuggestSplit

SuggestSplit

Make suggestions on how to split compound words.

[ Spell]

SuggestSplit =

Example

< Spell >

SuggestSplit =

Available

Release | _______
Patch |


TypographicalSugg

[Spell]
TypographicalSugg

TypographicalSugg

Make suggestions based on how the word is typed.

[ Spell]

TypographicalSugg =

Example

< Spell >

TypographicalSugg =

Available

Release | _______
Patch |


UserDict

[Spell]
UserDict

UserDict

[ Spell]

UserDict = Edit

Parameter | Description
Edit |

Remarks

Starting with release 11.0, Feature 1594 lets you use this built-in INI function to tell the system to substitute a value in the INI file with a value from the WIP record. This works with either Documaker Workstation (AFEMAIN) or the WIPEdit plug-in.

For example, if you want the UserDict value to equal the value for ORIGUSER in the current WIP record, you would set up the following option:

< Spell >

UserDict = ~WIPFIELD ORIGUSER

Example

< Spell >

UserDict = user.tlx

< Spell >

UserDict = ~WIPFIELD ORIGUSER

Available

Release | _______
Patch |


StartUp

Remarks

MenuID

StartUp Options

  • MenuID


MenuID

[StartUp]
MenuID

MenuID

Use this option to determine the startup window in the Entry System.

[ StartUp]

MenuID =

Parameter | Description
value | Use this option to determine the startup window in the Entry System.

Remarks

The option value is set to the numerical value of a MenuID from the menu resource (MENRES) file. If the INI entry

is:

< StartUp >

MenuID = 261

then the Entry System will start up in the Edit Existing Document window.

Use this FSISYS.INI control group to configure the Base Entry system to start at a specific window.

Example

< StartUp >

MenuID = 261

Available

Release | _______
Patch |


Status_CD

Status_CD Options

  • Approve
  • Archive
  • Assign
  • BatchPrint
  • COMBINE
  • COMPLETE
  • DUPLICATE
  • Printed
  • Quote
  • Reject
  • Transmit
  • WIP


Approve

[Status_CD]
Approve

Approve

[ Status_CD]

Approve =

Parameter | Description
value |

Remarks

You can now use several new rules to input or merge WIP transactions manually approved or rejected into a GenData processing run. These transactions can be processed as new transactions or appended to an MRL already processed by the GenData program-one that has existing NAFILE.DAT, POLFILE.DAT, and NEWTRAN.DAT files.

You can then print, archive, or print and archive the transactions using the Rules Processor. You can approve or reject the transactions using DocuMaker Workstation. T0 do this, you place these new rules into a simplified AFGJOB.JDT file along and set up several new INI options.

Basically, this process requires a new job level rule to initialize the GenData run so it can include for processing manually approved or rejected WIP transactions. These transactions are appended to a prior run or processed as new data. A new form set level rule initiates the importing of WIP transactions that match a specified status. The new image and field level rules tell the system to bypass the processing of fields and images because the form sets were completed in the WIP module of DocuMaker Workstation.

To view the transactions with a changed status, be sure to add the User_StatusCD control group and applicable status codes:

< User_StatusCD >

Approve = AP

Reject = RJ

Make sure these options match those in the Status_CD control group.

Approve and Reject are not normal AFE/Entry Workstation WIP statuses. Those are limited to the WIP Plug-In using IDS setup. In that setup, these INI options default to

Approve = AP

Reject = RJ

Example

< Status_CD >

Approve = AP

Reject = RJ

Available

Release | 10.1
Patch |


Archive

[Status_CD]
Archive

Archive

The StatusCode option defines which INI option in the Status_CD control group to use as the default WIP StatusCD field.

[ Status_CD]

Archive =

Parameter | Description
value |

Example

< Status_CD >

Archive = AR

Available

Release | 10.1
Patch | 135


Assign

[Status_CD]
Assign

Assign

The StatusCode option defines which INI option in the Status_CD control group to use as the default WIP StatusCD field.

[ Status_CD]

Assign =

Parameter | Description
value | The StatusCode option defines which INI option in the Status_CD control group to use as the default WIP StatusCD field.

Example

< Status_CD >

Assign =A

Available

Release | 10.1
Patch | 135


BatchPrint

[Status_CD]
BatchPrint

BatchPrint

The StatusCode option defines which INI option in the Status_CD control group to use as the default WIP StatusCD field.

[ Status_CD]

BatchPrint = b

Parameter | Description
value | Default value is: b

Example

< Status_CD >

BatchPrint = b

Available

Release | 10.1
Patch | 135


COMBINE

[Status_CD]
COMBINE

COMBINE

Use this FSISYS.INI control group to define system status codes. Status codes appear in the WIP list as policy status.

[ Status_CD]

COMBINE = CO

Parameter | Description
value | COMBINE = CO This option assigns the status code designating Combine. Default value is: CO

Remarks

The syntax for STATUS_CD options is:

DESCRIPTION = STATUS CODE

COMBINE = CO

This option assigns the status code designating Combine.

Example

< STATUS_CD >

COMBINE = CO

Available

Release | _______
Patch |


COMPLETE

[Status_CD]
COMPLETE

COMPLETE

Use this FSISYS.INI control group to define system status codes. Status codes appear in the WIP list as policy status.

[ Status_CD]

COMPLETE = C

Parameter | Description
value | COMPLETE = C This option assigns the status code designating Complete. Default value is: C

Remarks

COMPLETE = C

This option assigns the status code designating Complete.

There is no default for this status code because a record is normally deleted when WIP is completed. If you want a special status for completed WIP, set this option. CP is shown as an example. You can define any one- or two-character status code not already used by one of the other modes defined in the same INI control group.

Example

< STATUS_CD >

COMPLETE = C

Available

Release | _______
Patch |


DUPLICATE

[Status_CD]
DUPLICATE

DUPLICATE

Use this FSISYS.INI control group to define system status codes. Status codes appear in the WIP list as policy status.

[ Status_CD]

DUPLICATE = DU

Parameter | Description
value | DUPLICATE = DU This option assigns the status code designating Duplicate Default value is: DU

Remarks

DUPLICATE = DU

This option assigns the status code designating Duplicate

Example

< STATUS_CD >

DUPLICATE = DU

Available

Release | _______
Patch |


Printed

[Status_CD]
Printed

Printed

The StatusCode option defines which INI option in the Status_CD control group to use as the default WIP StatusCD field.

[ Status_CD]

Printed =

Parameter | Description
value |

Example

< Status_CD>

Printed = P

Available

Release | 10.1
Patch | 135


Quote

[Status_CD]
Quote

Quote

The StatusCode option defines which INI option in the Status_CD control group to use as the default WIP StatusCD field.

[ Status_CD]

Quote =

Parameter | Description
value |

Example

< Status_CD

Quote =Q

Available

Release | 10.1
Patch | 135


Reject

[Status_CD]
Reject

Reject

The reject status generated from Reject option in the Status_CD control group.

[ Status_CD]

Reject = RJ

Parameter | Description
value | Default value is: RJ

Remarks

Approve and Reject are not normal AFE/Entry Workstation WIP statuses. These are limited to the WIP Plug-In using IDS setup. In that setup, these INI options default to:

Approve = AP

Reject = RJ

Example

< Status_CD >

Reject = RJ

Available

Release | 10.1
Patch |


Transmit

[Status_CD]
Transmit

Transmit

Status code assigned for WIP routed via e-mail. Normally set =T, but can be any 2 characters.

[ Status_CD]

Transmit =

Parameter | Description
value | Status code assigned for WIP routed via e-mail. Normally set =T, but can be any 2 characters.

Example

< Status_CD >

Transmit = =T

Available

Release | _______
Patch |


WIP

[Status_CD]
WIP

WIP

The StatusCode option defines which INI option in the Status_CD control group to use as the default WIP StatusCD field.

[ Status_CD]

WIP = Edit

Parameter | Description
value | This means a W would be assigned to the WIP StatusCD field (usually meaning a normal WIP transaction).

Remarks

This means a W would be assigned to the WIP StatusCD field (usually meaning a normal WIP transaction).

Example

< Status_CD >

WIP = W

Available

Release | 10.1
Patch | 135


Symbol

Contains options related to Data Extract (XDD) manager and Rules Processor (GenData) execution.

ImportXMLAttribute

UniqueID


ImportXMLAttribute

[Symbol]
ImportXMLAttribute

ImportXMLAttribute

Feature 2555

[ Symbol]

ImportXMLAttribute = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

When importing an XML file into the XDD, Studio creates fields for each node in the XML tree. Now Studio can also create fields based upon node attributes.

< Symbol >

ImportXMLAttribute = Yes

Attribute nodes will be named NODE_ATTRIBUTE and will be children of the NODE in the XDD file.

Example

< Symbol >

ImportXMLAttribute = Yes

Available

Release | 11.5
Patch | NA


UniqueID

[Symbol]
UniqueID

UniqueID

Feature 2552

[ Symbol]

UniqueID = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

This setting is used to increase performance for Resource Libraries that only use UniqueID name mappings with the XDD (Data Extract). If all of the XDD mappings are in the format of NAME/#UNIQUEID, set this option to yes. If a combination of mappings (those using NAME or NAME/PARENT) are used in conjunction with Unique ID mappings do not set this option.

< Symbol >

UniqueID = Yes

Example

< Symbol >

UniqueID = Yes

Available

Release | 11.5
Patch | NA


SymLookup

SymLookup Options

  • AutoSpace
  • LeastFrequent
  • MaxCache


AutoSpace

[SymLookup]
AutoSpace

AutoSpace

[ SymLookup]

AutoSpace = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

Set AutoSpace to yes to tell the system that a space is needed before the searchmask/Xpath is appended together when using parent/child mapping and a child is a rule parameter, not a searchmask.

In version 10.3 the XDB parent/child processing was enhanced so that a child could be a search mask, an XPath (XML) or a rule parm. This provided the option of chaining children to build a complete search mask or XPath. With the implementation of this new functionality, a requirement was introduced to tag rule parms with an asterisk (*) if the child XDB data did not include a search mask.

In version 10.2 the following XDB database entries:

Name---Parent----Rule------Data

Child1---Parent2--printif-----A=Accident:C=Casualty

Parent1--------------------------1,HEADREC

Parent2-Parent1--------------20,ABC

would create the following search mask:

1,HEADREC,20,ABC A=Accident:C=Casualty

In 10.3, the same entries would create the search mask shown below.

1,HEADREC,20,ABC,A=Accident:C=Casualty

To get the same result in version 10.3 the XDB database entries would need to be

coded as follows:

Name----Parent-----Rule---------------Data

Child1----Parent2---printif--------------*A=Accident:C=Casualty

Parent1-------------------------------------1,HEADREC

Parent2--Parent1-------------------------20,ABC

For backward compatibility, the AutoSpace INI option was added in version 10.3.

With the AutoSpace option set to Yes, XDB processing is functionally equivalent to

version 10.2.

Example

<SymLookup>

AutoSpace = Yes

Available

Release | 10.3
Patch | 50


LeastFrequent

[SymLookup]
LeastFrequent

LeastFrequent

To return data from an external table in an XDB database.

[ SymLookup]

LeastFrequent = Yes

Parameter

Description

value

To return data from an external table in an XDB database.

Values can be

  • Yes
  • No

Default value is: Yes

Remarks

Determines how to purge cache entries when the MaxCache number is reached. If you set this option to Yes, the system finds the least frequently used record and removes it from the cache to make room for a new record. If you set this option to No, the removes the least recently used record. The default is Yes.

Set it to Yes if you are running batches which call the same symbolic names many times. Set it to No if you are running batches which have different data in each batch.

Example

< SymLookup >

LeastFrequent =

Available

Release | 10.1
Patch | 345


MaxCache

[SymLookup]
MaxCache

MaxCache

To return data from an external table in an XDB database.

[ SymLookup]

MaxCache =

Parameter | Description
value | To return data from an external table in an XDB database.

Example

< SymLookup >

MaxCache =

LeastFrequent =

Available

Release | 10.1
Patch | 345


Tables

Tables Options

  • Conditions
  • NewFormatOnly
  • OldFormatOnly
  • PATH
  • RECIPIENT


Conditions

[Tables]
Conditions

Conditions

[ Tables]

Conditions =

Parameter | Description
value |

Remarks

Enter the file name of your Condition table in the Tables control group. Use the Conditions option to define the Condition table's file name.

Example

< Tables >

Conditions = <CONFIG:~Platform > Tables_Conditions

Available

Release | 10.0
Patch |


NewFormatOnly

[Tables]
NewFormatOnly

NewFormatOnly

You can use these new INI options to specify that entry table files will use the old or new format.

[ Tables]

NewFormatOnly =

Parameter | Description
value | You can use these new INI options to specify that entry table files will use the old or new format.

Remarks

If you are using a lot of entry table lookups from the DAL code, your tables are located on a network drive, and the tables are a mix of both old and new format tables, performance can be affected because the system has to check the format of each table.

If, however, you can use one of these new options to tell the system that all tables are in the same format, it can omit that query and performance improves. Specify only the option that applies. If you omit these options, the system continues to test each table file to determine if the file is in new or old format.

Keep in mind that if you include one of these options, all of your tables must be in that format. For instance if you set the OldFormatOnly option to Yes, all of your tables must be in the old format. If you later decide to convert your tables to the new format, you must remove this option and, to get the same performance gain, include the NewFormatOnly option.

Example

< Tables >

NewFormatOnly = Yes

Available

Release | 10.1
Patch | 289


OldFormatOnly

[Tables]
OldFormatOnly

OldFormatOnly

You can use these new INI options to specify that entry table files will use the old or new format.

[ Tables]

OldFormatOnly =

Parameter | Description
value | You can use these new INI options to specify that entry table files will use the old or new format.

Remarks

If you are using a lot of entry table lookups from the DAL code, your tables are located on a network drive, and the tables are a mix of both old and new format tables, performance can be affected because the system has to check the format of each table.

If, however, you can use one of these new options to tell the system that all tables are in the same format, it can omit that query and performance improves. Specify only the option that applies. If you omit these options, the system continues to test each table file to determine if the file is in new or old format.

Keep in mind that if you include one of these options, all of your tables must be in that format. For instance if you set the OldFormatOnly option to Yes, all of your tables must be in the old format. If you later decide to convert your tables to the new format, you must remove this option and, to get the same performance gain, include the NewFormatOnly option.

Example

< Tables >

OldFormatOnly = Yes

Available

Release | 10.1
Patch | 289


PATH

[Tables]
PATH

PATH

PATH is the directory path of tables loaded during batch processing.

[ Tables]

PATH = Path

Parameter | Description
Path | PATH is the directory path of tables loaded during batch processing.

Remarks

Use this FSISYS.INI control group to define the directory path and file names of tables the system loads during batch processing. The LoadListFromTable function used during rules processing tells the system to look in the Tables INI group for a specific option and to load the table indicated in that option's value. In the Recipient = RECIPTBL.DAT option above, the system will load RECIPTBL.DAT if the LoadListFromTable rule specifies the Recipient INI table option.

Example

< TABLES >

PATH = .\TABLES\

Available

Release | _______
Patch |


RECIPIENT

[Tables]
RECIPIENT

RECIPIENT

[ Tables]

RECIPIENT = RECIPTBL.DAT

Parameter | Description
Edit | Use this FSISYS.INI control group to define the directory path and file names of tables the system loads during batch processing. Default value is: RECIPTBL.DAT

Remarks

Use this FSISYS.INI control group to define the directory path and file names of tables the system loads during batch processing. The LoadListFromTable function used during rules processing tells the system to look in the Tables INI group for a specific option and to load the table indicated in that option's value. In the Recipient = RECIPTBL.DAT option above, the system will load RECIPTBL.DAT if the LoadListFromTable rule specifies the Recipient INI table option.

Example

< TABLES >

RECIPIENT = RECIPTBL.DAT

Available

Release | _______
Patch |


TimerFuncs

TimerFuncs Options

  • 01
  • 02
  • AutoSave


01

[TimerFuncs]
01

01

Use this FSISYS.INI control group to register timed service functions called through TMRLIB.

[ TimerFuncs]

01 =

Parameter | Description
value | Use this FSISYS.INI control group to register timed service functions called through TMRLIB.

Remarks

Registration is accomplished by adding lines to an INI group that conforms to the following prototype.

<TIMERFUNCS>

REF = ;STATE;URGENCY;SECONDS;DLLNAME->FuncName;\DATA

The semicolons (;) are a required part of each registration statement. The DATA element is optional, but if included, must be preceded with the backslash (\).

REF is simply a placeholder to distinguish each entry under the INI group, TIMERFUNCS. Each registered function should have a different REF value. The actual value is not used by TMRLIB. In most cases, you may wish to use simple ASCII numbering (i.e. 01=, 02=, 03=, etc.) to distinguish each service function line.

NOTE: Although the REF value is not used by TMRLIB, remember that INI files are sorted when loaded. If the sequence of the service functions is important, the REF values should be established in a manner that will not be changed when sorted.

The first placeholder STATE is a mode or state of program flag. The STATE (in combination with URGENCY) indicates at what point during processing it is valid to call the service function. This indicator only applies to service function calls triggered by the timer. Initialization and termination affects all registered service functions regardless of the setting indicated on the registration line.

This valid values for this flag and their meanings are:

0= Desktop closed ( No formset is currently loaded or in view )

1= Desktop open ( A formset is currently loaded and in view )

2= Call any time ( Use with caution )

The desktop is considered "opened" when a form set is currently being viewed and/or entry is active, otherwise the desktop is considered "closed". The desktop is considered opened when any form contained within the current form set, (retrieved by FAPFormset) has a FAPWINDOW associated with it.

If a service function should only be called when the desktop is closed, assign ‘0' as the STATE. Note however, even if the desktop is closed, service function registered at STATE level 0 will not be called if the URGENCY requirement is not satisfied. In Processing System Entry, STATE level 0 might be used to implement features like automatic import, or automatic WIP edit.

Use STATE level 1 when a service function should only be called while the desktop is opened. (Remember, this means that a FAPWINDOW is associated with a form in the current form set.) Note however, service functions are not called if the URGENCY requirement is not satisfied. In Processing System Entry, STATE level 1 might be used to implement a feature like auto-save to WIP.

STATE level 2 should be used with discretion. Any service function using STATE level 2 will be called whether the desktop is opened or closed as long as the URGENCY requirement is satisfied. Service functions registered as STATE level 2 should probably not attempt to alter current forms or change the form set management. Doing so might cause the program to crash and burn.

Since STATE level 2 is active whether the desktop is opened or closed, this setting should only be used to implement features that do not hinder user operations and do not rely upon form set management.

Once the STATE setting has been satisfied, the URGENCY flag will be evaluated. URGENCY represents how "timely" the call to the service function should be enforced. This setting may skip or delay the call if the user is engaged with an open dialog or menu. This indicator only applies to service function calls triggered by the timer. Initialization and termination calls all registered service functions regardless of the setting indicated on the registration line.

The valid values for this flag and their meanings are:

0 = Not Urgent (okay to bypass if dialog or menu is open)

1 = Rush (call as soon as possible after dialog or menu is not open)

2 = Urgent (call even if dialog or menu is open -- USE WITH CAUTION)

NOTE: TMRLIB subclasses the main window of the application and looks for messages that indicate the menu is active. In addition, all child windows associated with the application window are scanned to determine if any of them are dialogs. These two tasks are used to determine when URGENCY should be enforced.

A setting of zero (0) indicates that the call to the service function should be skipped if a dialog or menu controlled by the program is open. Skipping the call means that the service function will not activate again until the registered time interval next elapses.

An URGENCY setting equal to one (1) will call the service function if no dialog or menu is active. However, this setting will delay the call, rather than skip it, if a dialog or menu is open.

Delayed service functions are evaluated approximately every second (based upon the system timer) to determine when the call can safely go through. Delaying the call means the interval between when the call finally goes through and the next standard interval registered with the function may be reduced.

Also note, however, that time intervals are not accumulated. If the delay causes the function to miss two or three time intervals, it will only be called once when the URGENCY is finally satisfied.

Example

< TimerFuncs >

01 = ;0;0;300;TRNW32->TRNAutoImport;

Available

Release | _______
Patch |


02

[TimerFuncs]
02

02

Use this FSISYS.INI control group to register timed service functions called through TMRLIB.

[ TimerFuncs]

02 =

Parameter | Description
value | Use this FSISYS.INI control group to register timed service functions called through TMRLIB.

Remarks

Use URGENCY level 2 with discretion. This setting will call the service function without regard for whether a dialog or menu is active. Service functions registered with an URGENCY level 2 should probably not attempt to alter current forms or change the form set management. Doing so might cause the program to crash and burn.

Since the user might be interacting with a dialog, this setting should only be used to implement features that do not affect or hinder user operations. Also, these functions should probably not open dialogs or windows. Imagine the user's frustration, if while completing the print dialog, the program suddenly switches to another task or window.

The SECONDS placeholder is a time-out value that designates (in seconds) how often the service function should be called. SECONDS can be any value from 1 to 32767. (The maximum value exceeds 9 hours). Any line that contains a SECONDS value equal to zero (0) will be skipped.

Although, the time-out value is designated in seconds, the actual time is only approximated.

NOTE: Internally, two "time" values are maintained. One of these values is used exclusively to test when STATE level 2 functions should be called. Remember, STATE level 2 functions are called whether the desktop is opened or closed.

STATE levels 0 and 1 use a second time value maintained by TMRLIB. Only those functions satisfied by the current STATE flag (desktop opened or closed) will be called when the proper time interval has elapsed. When the desktop is opened or closed, the second time value is reset to zero. This guarantees that the time interval associated with a function must elapse before being called when the desktop state changes.

NOTE: Calling a service function too frequently may adversely affect program performance.

The placeholder, DLLNAME->FuncName, is the standard FSI method used to identify a DLL to load and an exported function to call. DLLNAME should be a valid DLL name and FuncName must match a name that can be "queried" from that DLL. Only functions named in a DLLs export list can be referenced by TMRLIB.

As mentioned previously, the function identified by this option must conform to the FAPHANDLER function prototype.

The DATA registration member is optional. DATA should only be declared if the service function requires it. There is no format requirements established for the data line other than it must begin with a backslash (\).

Function specific DATA is attached, as a string of ASCII characters, to the FSITIMERREC structure associated with the registration line. It is the service functions responsibility to verify the existence or validity of the line.

NOTE: The leading backslash will not appear in the data member of the structure.

Example

< TimerFuncs >

02 = ;0;0;300;TRNW32->TRNAutoImport; \AUTOBATCH

Available

Release | _______
Patch |


AutoSave

[TimerFuncs]
AutoSave

AutoSave

Use this FAPCOMP.INI control group to register timed service functions called through TMRLIB.

[ TimerFuncs]

AutoSave =

Parameter | Description
value | Use this FAPCOMP.INI control group to register timed service functions called through TMRLIB.

Remarks

Registration is accomplished by adding lines to an INI group that conforms to the following prototype.

< TIMERFUNCS >

REF = ;STATE;URGENCY;SECONDS;DLLNAME->FuncName;\DATA

The semicolons (;) are a required part of each registration statement. The DATA element is optional, but if included, must be preceded with the backslash (\).

REF is simply a placeholder to distinguish each entry under the INI group, TIMERFUNCS. Each registered function should have a different REF value. The actual value is not used by TMRLIB. In most cases, you may wish to use simple ASCII numbering (i.e. 01=, 02=, 03=, etc.) to distinguish each service function line.

Note: Although the REF value is not used by TMRLIB, remember that INI files are sorted when loaded. If the sequence of the service functions is important, the REF values should be established in a manner that will not be changed when sorted.

The first placeholder STATE is a mode or state of program flag. The STATE (in combination with URGENCY) indicates at what point during processing it is valid to call the service function. This indicator only applies to service function calls triggered by the timer. Initialization and termination affects all registered service functions regardless of the setting indicated on the registration line.

This valid values for this flag and their meanings are:

0= Desktop closed ( No formset is currently loaded or in view )

1= Desktop open ( A formset is currently loaded and in view )

2= Call any time ( Use with caution )

The desktop is considered "opened" when a form set is currently being viewed and/or entry is active, otherwise the desktop is considered "closed". The desktop is considered opened when any form contained within the current form set, (retrieved by FAPFormset) has a FAPWINDOW associated with it.

If a service function should only be called when the desktop is closed, assign 0 as the STATE. Note however, even if the desktop is closed, service function registered at STATE level 0 will not be called if the URGENCY requirement is not satisfied. In Processing System Entry, STATE level 0 might be used to implement features like automatic import, or automatic WIP edit.

Use STATE level 1 when a service function should only be called while the desktop is opened. (Remember, this means that a FAPWINDOW is associated with a form in the current form set.) Note however, service functions are not called if the URGENCY requirement is not satisfied. In Processing System Entry, STATE level 1 might be used to implement a feature like auto-save to WIP.

STATE level 2 should be used with discretion. Any service function using STATE level 2 will be called whether the desktop is opened or closed as long as the URGENCY requirement is satisfied. Service functions registered as STATE level 2 should probably not attempt to alter current forms or change the form set management. Doing so might cause the program to crash and burn. Since STATE level 2 is active whether the desktop is opened or closed, this setting should only be used to implement features that do not hinder user operations and do not rely upon form set management.

Once the STATE setting has been satisfied, the URGENCY flag will be evaluated. URGENCY represents how "timely" the call to the service function should be enforced. This setting may skip or delay the call if the user is engaged with an open dialog or menu. This indicator only applies to service function calls triggered by the timer. Initialization and termination calls all registered service functions regardless of the setting indicated on the registration line.

The valid values for this flag and their meanings are:

0 = Not Urgent (okay to bypass if dialog or menu is open)

1 = Rush (call as soon as possible after dialog or menu is not open)

2 = Urgent (call even if dialog or menu is open -- USE WITH CAUTION)

Note: TMRLIB subclasses the main window of the application and looks for messages that indicate the menu is active. In addition, all child windows associated with the application window are scanned to determine if any of them are dialogs. These two tasks are used to determine when URGENCY should be enforced.

A setting of zero (0) indicates that the call to the service function should be skipped if a dialog or menu controlled by the program is open. Skipping the call means that the service function will not activate again until the registered time interval next elapses.

An URGENCY setting equal to one (1) will call the service function if no dialog or menu is active. However, this setting will delay the call, rather than skip it, if a dialog or menu is open.

Delayed service functions are evaluated approximately every second (based upon the system timer) to determine when the call can safely go through. Delaying the call means the interval between when the call finally goes through and the next standard interval registered with the function may be reduced.

Also note, however, that time intervals are not accumulated. If the delay causes the function to miss two or three time intervals, it will only be called once when the URGENCY is finally satisfied.

Use URGENCY level 2 with discretion. This setting will call the service function without regard for whether a dialog or menu is active. Service functions registered with an URGENCY level 2 should probably not attempt to alter current forms or change the form set management. Doing so might cause the program to crash and burn.

Since the user might be interacting with a dialog, this setting should only be used to implement features that do not affect or hinder user operations. Also, these functions should probably not open dialogs or windows. Imagine the user's frustration, if while completing the print dialog, the program suddenly switches to another task or window.

The SECONDS placeholder is a time-out value that designates (in seconds) how often the service function should be called. SECONDS can be any value from 1 to 32767. (The maximum value exceeds 9 hours). Any line that contains a SECONDS value equal to zero (0) will be skipped.

Although, the time-out value is designated in seconds, the actual time is only approximated.

Note: Internally, two "time" values are maintained. One of these values is used exclusively to test when STATE level 2 functions should be called. Remember, STATE level 2 functions are called whether the desktop is opened or closed.

STATE levels 0 and 1 use a second time value maintained by TMRLIB. Only those functions satisfied by the current STATE flag (desktop opened or closed) will be called when the proper time interval has elapsed. When the desktop is opened or closed, the second time value is reset to zero. This guarantees that the time interval associated with a function must elapse before being called when the desktop state changes.

Note: Calling a service function too frequently may adversely affect program performance.

The placeholder, DLLNAME->FuncName, is the standard FSI method used to identify a DLL to load and an exported function to call. DLLNAME should be a valid DLL name and FuncName must match a name that can be "queried" from that DLL. Only functions named in a DLLs export list can be referenced by TMRLIB.

As mentioned previously, the function identified by this option must conform to the FAPHANDLER function prototype.

The DATA registration member is optional. DATA should only be declared if the service function requires it. There is no format requirements established for the data line other than it must begin with a backslash (\).

Function specific DATA is attached, as a string of ASCII characters, to the FSITIMERREC structure associated with the registration line. It is the service functions responsibility to verify the existence or validity of the line.

Note: The leading backslash will not appear in the data member of the structure.

Autosave

The Autosave option specifies the conditions under which an image or a form set is saved automatically to WIP and it names the DLL and function to call for performing this action. The format for this option is:

REF = ;STATE;URGENCY;SECONDS;DLLNAME->FuncName;\DATA

An explanation of TimerFuncs formats appears under the control group heading. A sample Autosave option appears below.

< TimerFuncs >

Autosave = ;1;1;60;IMGW32->IMGAutosave;

In this example Autosave is called every 60 seconds when the desktop is open, and as soon as possible after a dialog or menu is not open.

Example

< TimerFuncs >

Autosave = ;1;1;60;IMGW32->IMGAutosave;

Available

Release | _______
Patch |


TransactionRecord

Remarks

Symbol

TransactionRecord Options

  • Symbol


Symbol

[TransactionRecord]
Symbol

Symbol

[ TransactionRecord]

Symbol =

Parameter | Description
value | This FSISYS.INI control group was used in early versions of DAP to define how the GenData program should read the TRNFILE.DAT file. Beginning with version 8.5, you do not need to use this control group.

Remarks

This FSISYS.INI control group was used in early versions of DAP to define how the GenData program should read the TRNFILE.DAT file. Beginning with version 8.5, you do not need to use this control group. The control group and all options should be commented out with semicolons, as shown below.

;< TransactionRecord >

; Symbol = 1,3

; PolicyNum = 4,7

; Module = 38,2

; State = 43,2

; TransactionType = 45,2

; Company = 35,3

; Lob = 40,3

; Branch = 49,2

; RunDate = 51,8

; CustomerNumber = 87,10

Example

;< TransactionRecord >

; Symbol = 1,3

; PolicyNum = 4,7

; Module = 38,2

; State = 43,2

; TransactionType = 45,2

; Company = 35,3

; Lob = 40,3

; Branch = 49,2

; RunDate = 51,8

; CustomerNumber = 87,10

Available

Release | _______
Patch |


Transactions

Transactions Options

  • 01
  • 02
  • 03
  • 04


01

[Transactions]
01

01

This option is user defined. The values used on the left of the equal sign will determine the display sort order for the transa

[ Transactions]

01 = Edit

Parameter | Description
value | This option is user defined. The values used on the left of the equal sign will determine the display sort order for the transaction functions declared within the group.

Remarks

Use this FSISYS.INI control group to define WIP transaction codes. All WIP transactions have a "code" or type associated with them. This Transaction Code is a user definable value and its effect on the transaction can be customized within the program.

The left side of the equation is used to delineate each item and to specify the order of appearance in the dialog list presented to the user. While loading the INI options, the list is sorted alphanumerically. In the example above, New Business will be the default transaction presented to the user since it will sort as the top item.

The right side of the equation contains the heart of the definition. Notice that the expression begins, ends, and separates each of its components with semicolons. The first value is a two character transaction code abbreviation. This is the value assigned into the WIP transaction record. The next value is the transaction name or description. This is the value that is shown to the user in the selection list for transaction type. The name should not exceed nineteen characters. Finally, the last value is the standard definition for DLL to load and an exported

function name to call. Functions are associated with transactions to assist the user in selecting the form set or to affect the behavior of the transaction within the program.

Each two character Transaction Code should be unique. If not, it may not be possible for the program to match the Transaction Code with the name actually selected by the user when creating the form set.

On the other hand, there are times when you might want a doubly defined code. For instance, suppose you want an Endorsement based upon an archived policy to behave differently than one created by importing data. In each of these cases, you may wish the transaction be given the EN Transaction Code. To accomplish the different behaviors during form selection, you would need different custom functions associated with separate transaction lines.

02 = ;EN;Endorsement;TRNW32->TRNEndorse;

05 = ;EN;Arc Endorsement;TRNW32->TRNNew;

Shown above is an example of how one transaction code might be defined with two behaviors. If the user selects either of these transactions, the WIP record is still assigned EN as the Transaction Code. However, notice that each transaction will invoke a different function and thus may affect how the user completes the form selection process.

This example works because the creation of the form set is usually the only time that the user can specify the transaction to use. Once WIP is created, the transaction type usually does not change.

Endorsement = EN

Endorsement is a term taken from the Insurance Industry. Basically, it means an amended transaction is required on an existing business transaction. The function invoked by selecting Endorsement, normally TRNEndorse(), will not preselect any of the forms for the user. It is assumed that the user will know which forms to select in this situation. Since an Endorsement usually implies that the transaction is associated with another, the check for unique WIP keys is relaxed.

New Business = NB

New Business is probably self defining. Associating NB with a WIP transaction indicates that this is a first time entry or that the transaction stands on its own. The function invoked when selecting this transaction is usually TRNNew(). The Form Selection dialog will display the available forms with the "required" forms preselected (or checked). Also, if the INI specifies unique WIP keys are required, the default functionality enables this check on this transaction type.

Quotes = QU

A Quote is usually considered a temporary transaction. The default behavior is assumed to be similar to New Business and uses the function, TRNNew(). In fact, many times a Quote transaction is later converted into New Business. This is the only transaction type that some users allow to change after the WIP is created.

Renewal = RN

Renewal is also a term taken from the Insurance Industry, but it applies to many others. There are many industries where a customer must be "renewed" after some period of time has elapsed. In addition to insurance, such a concept might apply for certain types of contracts, lines of credit, and licenses. The default functionality of TRNRenew() is to preselect the required forms but to not require unique WIP keys.

Example

< Transactions >

01 =

Available

Release | _______
Patch |


02

[Transactions]
02

02

This option is user defined.

[ Transactions]

02 = Edit

Parameter | Description
value | This option is user defined. The values used on the left of the equal sign will determine the display sort order for the transaction functions declared within the group.

Remarks

The values used on the left of the equal sign will determine the display sort order for the transaction functions declared within the group.

Example

< Transactions >

02 =

Available

Release | _______
Patch |


03

[Transactions]
03

03

This option is user defined.

[ Transactions]

03 = Edit

Parameter | Description
value | This option is user defined. The values used on the left of the equal sign will determine the display sort order for the transaction functions declared within the group.

Remarks

The values used on the left of the equal sign will determine the display sort order for the transaction functions declared within the group.

Example

< Transactions >

03 =

Available

Release | _______
Patch |


04

[Transactions]
04

04

This option is user defined.

[ Transactions]

04 = Edit

Parameter | Description
value | This option is user defined. The values used on the left of the equal sign will determine the display sort order for the transaction functions declared within the group.

Remarks

The values used on the left of the equal sign will determine the display sort order for the transaction functions declared within the group.

Example

< Transactions >

04 =

Available

Release | _______
Patch |


Trigger2Archive

Remarks

The Trigger2Archive INI control group lets you map a field in the NEWTRN file to a field in the APPIDX (Application Index) table. The GenArc program uses the Trigger2Archive group to get the data from the NEWTRN file and create the APPIDX table. The field name on the left side indicates the name of the field in the APPIDX table (which cannot exceed 10 characters as required by DBASE IV) and the field on the right side indicates the name of the field in the NEWTRN file. Often times these field names are the same, but they can be different. Field names on the left side should be defined in the file pointed to by the AppIdxDFD option in the ArcRet control group and the field names on the right side should be defined in the file pointed to by the TrnDFDFile option in the Data group. Once the data is in the APPIDX table, you can display it in Documaker Workstation by adding a Field = INI option in the AfeArchiveDisplay control group.

If you use the GenArc program, without direct connection with the Documanage server, to create a single file which contains multiple compressed packages of DAP archive (DPA) documents with the StackedDAP INI option in the DMIA:Documanage_cabinet_name group. Each package is preceded by an XML header. You can submit the stacked DAP file to a Docusave Server and import it into a Documanage Server. When Docusave Server processes the stacked DPA file, it separates the file into individual DPA files and extracts information from each DPA file's XML header. The information extracted is used when the file is imported into Documanage.

From the DPA file's XML header, Documanage extracts the cabinet name, class, subtype, title, date, status, and the column names of the Line-of-Business table. This data usually makes up the indexing information. You can include other fields in the DPA file's XML header for use as Documanage document level basic properties. The optional fields include Description, UserFlag1, UserFlag2, KeyWord1, and KeyWord2.

The XML header information that precedes each individual DPA file is propagated to the XML header from a GenArc program structure that is mapped by the Trigger2Archive control group. Thus, for the GenArc program to produce a stacked DPA file that contains the XML header information necessary for use by Docusave and Documanage, you must add these fields to the APPIDX.DFD and TRNDFDFL.DFD files. The field names that should be added to the APPIDX.DFD and TRNDFDFL.DFD files are framed with three percent signs (%%%) and are case-sensitive. Here is the correct format for these fields:

%%%Cabinet%%%

%%%Class%%%

%%%SubType%%%

%%%Title%%%

%%%Date%%%

%%%Status%%%

%%%Description%%%

%%%UserFlag1%%%

%%%UserFlag2%%%

%%%Keyword1%%%

%%%Keyword2%%%

In order for the appropriate fields to be used by the GenArc program with the Trigger2Archive group, those fields must be propagated from the extract file to the TRNFILE during the GenTrn process with the TRN_Fields control group and then from the TRNFILE file to the NEWTRN file during the GenData process.

Below is an example of the additional information required in the Trigger2Archive INI control group:

< Trigger2Archive >

%%%Cabinet%%% = %%%Cabinet%%%

%%%Class%%% = %%%Class%%%

%%%SubType%%% = %%%SubType%%%

%%%Title%%% = %%%Title%%%

%%%Description%%% = %%%Description%%%

%%%Date%%% = %%%Date%%%

%%%Status%%% = %%%Status%%%

%%%UserFlag1%%% = %%%UserFlag1%%%

%%%UserFlag2%%% = %%%UserFlag2%%%

%%%Keyword1%%% = %%%Keyword1%%%

%%%Keyword2%%% = %%%Keyword2%%%

Below is an example of the additional information required in the APPIDX.DFD file:

< FIELDS >

FIELDNAME = %%%Cabinet%%%

FIELDNAME = %%%Class%%%

FIELDNAME = %%%SubType%%%

FIELDNAME = %%%Title%%%

FIELDNAME = %%%Description%%%

FIELDNAME = %%%Date%%%

FIELDNAME = %%%Status%%%

FIELDNAME = %%%UserFlag1%%%

FIELDNAME = %%%UserFlag2%%%

FIELDNAME = %%%Keyword1%%%

FIELDNAME = %%%Keyword2%%%

FIELDNAME = %%%LastEditBy%%%

FIELDNAME = %%%LastEditOn%%%

FIELDNAME = %%%AddedFrom%%%

FIELDNAME = %%%AddedOn%%%

< FIELD:%%%Cabinet%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 32

EXT_TYPE = CHAR_ARRAY

EXT_LENGTH = 32

KEY = Y

REQUIRED = Y

< FIELD:%%%Class%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 15

EXT_TYPE = CHAR_ARRAY

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

< FIELD:%%%SubType%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 15

EXT_TYPE = CHAR_ARRAY

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

< FIELD:%%%Title%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 64

EXT_TYPE = CHAR_ARRAY

EXT_LENGTH = 64

KEY = Y

REQUIRED = Y

< FIELD:%%%Description%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 100

EXT_TYPE = CHAR_ARRAY

EXT_LENGTH = 100

KEY = Y

REQUIRED = Y

< FIELD:%%%Date%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 20

EXT_TYPE = CHAR_ARRAY

EXT_LENGTH = 20

KEY = Y

REQUIRED = Y

< FIELD:%%%Status%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 10

EXT_TYPE = CHAR_ARRAY

EXT_LENGTH = 10

KEY = Y

REQUIRED = Y

< FIELD:%%%UserFlag1%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 15

EXT_TYPE = CHAR_ARRAY

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

NOTE: Field lengths are limited to Documanage field lengths. DATE type data must be passed in a format that is accepted by the Documanage Server. Docusave's default date mask is {ts'%s'}. This format causes the '%s' to be replaced with the DATE string passed in from the DPA file’s XML header. Other date mask options exist, such as to_date('%s','YYYYMMDD').

NOTE: The Documanage Line-of-Business table data and other data must be mapped into the DPA file's XML header instead of being referenced by an external INDEX.CFG file, as is done with other stacked files supported by Docusave.

The ARCRET utility is designed to find all the relevant information about your archive setup under the ArcRet control group. In general, the INI options required by the ARCRET utility are almost identical to those used by the GenArc program. With a few exceptions, the settings referenced are the almost the same as those used and required by the AFEMAIN program. One exception is the Trigger2Archive control group. The ARCRET utility uses this Trigger2Archive control group to re-create the NEWTRN file. If you use the GenArc program to produce your archives, you already have this group to map the fields from the NEWTRN file to the APPIDX (application index) file. Since the AFEMAIN program does not use this control group, you may have to add it to your INI file. For example:

<Trigger2Archive>

ArcField1 = TrnFiled1

ArcField2 = TrnFiled2

Example

< Trigger2Archive >

Company = Company

Lob = Lob

PolicyNum = PolicyNum

RunDate = RunDate

%%%Cabinet%%% = %%%Cabinet%%%

%%%Class%%% = %%%Class%%%

%%%SubType%%% = %%%SubType%%%

%%%Title%%% = %%%Title%%%

%%%Description%%% = %%%Description%%%

%%%Date%%% = %%%Date%%%

%%%Status%%% = %%%Status%%%

Trigger2Archive Options

  • Company
  • DAPDate
  • RunDate


Company

[Trigger2Archive]
Company

Company

Field name in NEWTRN file which maps to Company field in APPIDX.

[ Trigger2Archive]

Company =

Parameter | Description
value | Field in NEWTRN which maps to APPIDX table

Remarks

Note that the field names in this Group will not necessarily be called Company, Lob, PolicyNum, etc. The names will depend on the implementation.

Example

< Trigger2Archive >

Company = Company

Available

Release | 10.0
Patch |

Used By

GENARC


DAPDate

[Trigger2Archive]
DAPDate

DAPDate

[ Trigger2Archive]

DAPDate =

Remarks

If you then want to place the system date into archive, define a field, such as DAPDate, in the APPIDX.DFD file and add...

< Trigger2Archive >

dapdat = systemdate

Once the system date is in APPIDX.DBF file, you can display it by adding...

< AfeArchiveDisplay >

Field = dapdata,DD%m/%d/%Y

Example

< Trigger2Archive >

dapdat = systemdate

Available

Release | 10.1
Patch |


RunDate

[Trigger2Archive]
RunDate

RunDate

[ Trigger2Archive]

RunDate =

Parameter | Description
value | Field in NEWTRN which maps to APPIDX table

Remarks

The system now also lets you format data values that will be mapped to the Archive index record from the Trigger2Archive control group.

Note

DM18014

Example

< Trigger2Archive >

RunDate = RunDate

Available

Release | 10.0
Patch |


Trigger2Wip

Remarks

The field name on the right side indicates the name of the field in the WIP table (which cannot exceed 10 characters as required by DBASE IV) and the field on the left side indicates the name of the field in the manual BCH file. Often times these field names are the same, but they can be different. Field names on the right side should be defined in the file pointed to by the <WipData> WipDFDFile option and the field names on the left side should be defined in the file pointed to by the <Data> RCBDFDFile option.

Example

< Trigger2Wip >

Company = KEY1

Lob = KEY2

PolicyNum = KEYID

Trigger2Wip Options

  • AccountNum
  • Company
  • LOB
  • PolicyNum
  • RCBField
  • RunDate
  • TransactionType


AccountNum

[Trigger2Wip]
AccountNum

AccountNum

1150 CONTROLLING WIP RECORD FIELD ASSIGNMENTS

[ Trigger2Wip]

AccountNum = Edit

Parameter | Description
value |

Remarks

This feature changes the behavior of the GenWIP program so you can use the Trigger2WIP control group to set almost all of the WIP record fields for each transaction.

Do not try to set the ModifyTime, InUse, or the FormSetID fields of the WIP record. The ModifyTime field is assigned by the system when a WIP record is added or updated. If you need to save a date and time for the transaction, store that information in the CreateTime field, using the HEXTIME X format for the destination as shown in one of the examples. The InUse field is used internally to prevent multiple people from editing the same transaction. Let the system manage this column. The FormSetID is assigned by the system when a new WIP transaction is created. Let the system handle this.

The Trigger2WIP control group defines which recipient batch (RCB) transaction fields from the manual batch (those kicked to WIP) are mapped to the corresponding WIP transaction record fields.

Example

< Trigger2WIP >

AccountNum = KEYID

Available

Release | _______
Patch |


Company

[Trigger2Wip]
Company

Company

[ Trigger2Wip]

Company =

Parameter | Description
value | Field in manual BCH maps to WIP table.

This option may be required in order for the feature to function.

Example

< Trigger2Wip >

Company = Key1

Available

Release | _______
Patch |

Used By

GENWIP


LOB

[Trigger2Wip]
LOB

LOB

[ Trigger2Wip]

LOB =

Parameter | Description
value | Field in manual BCH maps to WIP table.

This option may be required in order for the feature to function.

Example

< Trigger2Wip >

LOB = Key2

Available

Release | _______
Patch |

Used By

GENWIP


PolicyNum

[Trigger2Wip]
PolicyNum

PolicyNum

[ Trigger2Wip]

PolicyNum =

Parameter | Description
value | Field in manual BCH maps to WIP table.

This option may be required in order for the feature to function.

Example

< Trigger2Wip >

PolicyNum = KeyID

Available

Release | _______
Patch |

Used By

GENWIP


RCBField

[Trigger2Wip]
RCBField

RCBField

[ Trigger2Wip]

RCBField =

Parameter | Description
value |

Remarks

Although the normal mapping technique is to name a RCB field on the left side, the left side can name any defined GVM (global variable member). Typically, the only GVMs that exist during GenWIP processing are those defined in the RCB DFD file, but custom applications or single-step WIP systems may have additional GVMs.

The changes in this release support this INI definition and also let you convert data or define a constant value you want to map to a WIP field. For a data conversion, define your INI options as shown here:

< Trigger2WIP >

RCBField = WIPField; input format ; output format;

The conversion information must appear on the right side of the INI option, after the WIPField name definition. Separate it from the named variable with a semicolon. Here is an example:

RunDate = CREATETIME;DD4;X

The first semicolon denotes the input format of the data. The second separates the desired output format. In this example, the input format of DD4 means the source data is a date field in the format D4, which is YYYYMMDD.

The output format X indicates you want to convert the date value to the internal HEXTIME format used in the WIP CreateTime field.

Example

< Trigger2WIP >

RCBField = WIPField; input format ; output format;

Available

Release | 10.1
Patch | 135


RunDate

[Trigger2Wip]
RunDate

RunDate

[ Trigger2Wip]

RunDate = Edit

Parameter | Description
value | Use this FSISYS.INI control group to designate the fields in the TRNFILE that are copied to the columns in the manual batch dfd during batch processing

Remarks

Use this FSISYS.INI control group to designate the fields in the TRNFILE that are copied to the columns in the manual batch dfd during batch processing. Option values in this control group have the following format:

Left side = manual batch.dfd column Right side = trnfile.dfd field

Example

< Trigger2Wip >

RunDate = APPDATA

Available

Release | _______
Patch |


TransactionType

[Trigger2Wip]
TransactionType

TransactionType

[ Trigger2Wip]

TransactionType =

Parameter | Description
Trancode | transaction code

Remarks

By default the trancode will be NB for new business.

Note

TransactionType = Trancode is not a required INI e

Example

TransactionType = Trancode

Available

Release | _______
Patch |

Used By

GENWIP


Trn_Fields

Remarks

The < TRN_FIELDS > group is used by gentrn to get the source data from the EXTRACT file and to copy the values into the corresponding fields in the trnfile.dat and newtrn.dat files that are created.

Depending on the EXTRACT file (text file or XML file), the formats for the options in the TRN_Fields control group are different.

If the EXTRACT file is a text file, use the following format (1 based):

Field in the transaction DFD file (trndfdfl.dfd) = offset, length, Key;Field Format

The left side of the equation is the field name which must be defined in the trndfdfl.dfd. The right side of the equation is the offset, relative to 1, of the field in the EXTRACT file, the length of the field in the EXTRACT file, and the key which indicates whether the field is required to have a value in the EXTRACT file. Enter Y to indicate the field must have data or N to indicate data is not required. You may optionally specify the data format for the field in the EXTRACT file after the third parameter (Key) separated by a semicolon ";".

For example:

<TRN_Fields>

company = 35,3,N

cust_num = 87,10,N

EffectiveDate = 25,6,N;DB;D4

lob = 40,3,N

RunDate = 51,14,N

If the EXTRACT file is an XML file, use the following format:

Field in the transaction DFD file (trndfdfl.dfd) = Xpath;Field Format

The left side of the equation is the field name which must be defined in the trndfdfl.dfd. The right side of the equation is an XML path search and the field format (optional), separated by semicolon ";". An XML path search must begin with an exclamation mark (!). The exclamation mark is not part of the actual search routine. Do not specify whether a field is a key. The system does not support a multiple (search) keys with the XML implementation.

For example:

< TRN_Fields >

Company = !/Forms/Key1

LOB = !/Forms/Key2

PolicyNum = !/Forms/PolicyNum

RunDate = !/Forms/RunDate;DM-4;D4

If you are selectively excluding transactions, in your exclude file, instead of an offset and SearchMask, replace it with the Xpath. Here is an example:

!/Forms[PolicyType="OLD"]

If you use the GenArc program, without direct connection with the Documanage server, to create a single file which contains multiple compressed packages of DAP archive (DPA) documents with the StackedDAP INI option in the DMIA:Documanage_cabinet_name group. Each package is preceded by an XML header. You can submit the stacked DAP file to a Docusave Server and import it into a Documanage Server. When Docusave Server processes the stacked DPA file, it separates the file into individual DPA files and extracts information from each DPA file's XML header. The information extracted is used when the file is imported into Documanage.

From the DPA file's XML header, Documanage extracts the cabinet name, class, subtype, title, date, status, and the column names of the Line-of-Business table. This data usually makes up the indexing information. You can include other fields in the DPA file's XML header for use as Documanage document level basic properties. The optional fields include Description, UserFlag1, UserFlag2, KeyWord1, and KeyWord2.

The XML header information that precedes each individual DPA file is propagated to the XML header from a GenArc program structure that is mapped by the Trigger2Archive control group. Thus, for the GenArc program to produce a stacked DPA file that contains the XML header information necessary for use by Docusave and Documanage, you must add these fields to the APPIDX.DFD and TRNDFDFL.DFD files. The field names that should be added to the APPIDX.DFD and TRNDFDFL.DFD files are framed with three percent signs (%%%) and are case-sensitive. Here is the correct format for these fields:

%%%Cabinet%%%

%%%Class%%%

%%%SubType%%%

%%%Title%%%

%%%Date%%%

%%%Status%%%

%%%Description%%%

%%%UserFlag1%%%

%%%UserFlag2%%%

%%%Keyword1%%%

%%%Keyword2%%%

In order for the appropriate fields to be used by the GenArc program with the Trigger2Archive group, those fields must be propagated from the extract file to the TRNFILE during the GenTrn process with the TRN_Fields control group and then from the TRNFILE file to the NEWTRN file during the GenData process.

Below is an example of the additional information required in the Trn_Fields INI control group:

< TRN_FIELDS >

%%%Cabinet%%% = 120,32,N

%%%Class%%% = 152,15,N

%%%SubType%%% = 45,2,N

%%%Title%%% = 182,64,N

%%%Description%%% = 246,100,N

%%%Date%%% = 51,8,N

%%%Status%%% = 346,10,N

%%%UserFlag1%%% = 49,2,N

%%%UserFlag2%%% = 38,2,N

%%%Keyword1%%% = 356,15,N

%%%Keyword2%%% = 371,15,N

Below is an example of the additional information required in the TRNDFDFL.DFD file:

< FIELDS >

FIELDNAME = %%%Cabinet%%%

FIELDNAME = %%%Class%%%

FIELDNAME = %%%SubType%%%

FIELDNAME = %%%Title%%%

FIELDNAME = %%%Description%%%

FIELDNAME = %%%Date%%%

FIELDNAME = %%%Status%%%

FIELDNAME = %%%UserFlag1%%%

FIELDNAME = %%%UserFlag2%%%

FIELDNAME = %%%Keyword1%%%

FIELDNAME = %%%Keyword2%%%

< FIELD:%%%Cabinet%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 33

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 32

KEY = Y

REQUIRED = Y

< FIELD:%%%Class%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 16

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

< FIELD:%%%SubType%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 16

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

< FIELD:%%%Title%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 65

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 64

KEY = Y

REQUIRED = Y

< FIELD:%%%Description%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 101

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 100

KEY = Y

REQUIRED = Y

< FIELD:%%%Date%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 9

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 8

KEY = Y

REQUIRED = Y

< FIELD:%%%Status%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 11

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 10

KEY = Y

REQUIRED = Y

< FIELD:%%%UserFlag1%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 16

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

< FIELD:%%%UserFlag2%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 16

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

< FIELD:%%%Keyword1%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 16

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

< FIELD:%%%Keyword2%%% >

INT_TYPE = CHAR_ARRAY

INT_LENGTH = 16

EXT_TYPE = CHAR_ARRAY_NO_NULL_TERM

EXT_LENGTH = 15

KEY = Y

REQUIRED = Y

NOTE: Field lengths are limited to Documanage field lengths. DATE type data must be passed in a format that is accepted by the Documanage Server. Docusave's default date mask is {ts'%s'}. This format causes the '%s' to be replaced with the DATE string passed in from the DPA file’s XML header. Other date mask options exist, such as to_date('%s','YYYYMMDD').

NOTE: The Documanage Line-of-Business table data and other data must be mapped into the DPA file's XML header instead of being referenced by an external INDEX.CFG file, as is done with other stacked files supported by Docusave.

Example

< TRN_FIELDS >

Symbol = 1,3,N

PolicyNum = 4,7,N

Module = 3-,2,N

State = 43,2,N

TransactionType = 45,2,N

Company = 35,3,N

Lob = 40,3,N

Branch = 49,2,N

RunDate = 51,-,N

CustomerNumber = -7,10,N

Trn_Fields Options

  • RunDate


RunDate

[Trn_Fields]
RunDate

RunDate

[ Trn_Fields]

RunDate = Edit

Parameter | Description
Edit |

Remarks

Please refer to the Remarks under <TRN_Fields> control group for details.

Example

<TRN_Fields>

RunDate = 80,8,N

Available

Release | _______
Patch |


Trn_File

Remarks

The < TRN_FILE > group tells GENDATA about the Transaction File (TRNFILE).

Example

< TRN_FILE >

BinaryExt = N

MaxExtRecLen = 119

Trn_File Options

  • BinaryExt
  • MaxExtRecLen
  • XMLTrnFields


BinaryExt

[Trn_File]
BinaryExt

BinaryExt

Set extract file as binary or text type.

[ Trn_File]

BinaryExt =

This option may be required in order for the feature to function.

Remarks

Indicates whether the input Extract File is to be opened and read as a Binary file (Y) or as a Text file (N).

If BinaryExt is set to Y on OS/390 (or MVS), the MaxExtRecLen must be set to the exact logical record length (LRECL) of the extract file.

Example

< TRN_FIELDS >

BinaryExt = Y | N

Available

Release | _______
Patch |

Used By

GENDATA, GENTRN


MaxExtRecLen

[Trn_File]
MaxExtRecLen

MaxExtRecLen

Maximum length of extract record.

[ Trn_File]

MaxExtRecLen = Spin

Parameter | Description
max | Maximum length of records of the Extract file.

This option may be required in order for the feature to function.

Remarks

Lists the maximum length of the records of the Extract file.

Note: The TRNRECFMT option is obsolete - it is no longer used.

On OS/390 (or MVS), the MaxExtRecLen must be set to the exact logical record length (LRECL) of the extract file if BinaryExt is set to Y.

Example

< TRN_FIELDS >

MaxExtRecLen = xxx

Available

Release | _______
Patch |

Used By

GENDATA, GENTRN


XMLTrnFields

[Trn_File]
XMLTrnFields

XMLTrnFields

[ Trn_File]

XMLTrnFields =

Parameter | Description
value | To let the system know you are using the XML file, set the XMLTrnFields option in the TRN_File control group to Yes and also set the XMLExtract option in the RunMode control group to Yes.

Remarks

To let the system know you are using the XML file, set the XMLTrnFields option in the TRN_File control group to Yes and also set the XMLExtract option in the RunMode control group to Yes.

Example

< TRN_File >

XMLTrnFields= Yes

Available

Release | 10.2
Patch | 1


TrnLib

Remarks

GetFirst

TrnLib Options

  • GetFirst
  • GetNext
  • InitFunc
  • TermFunc


GetFirst

[TrnLib]
GetFirst

GetFirst

Use this FSISYS.INI control group to define the DLL and function name to call for the GenWip.exe Section.

[ TrnLib]

GetFirst = Edit

Parameter | Description
value | GetFirst = A2WBW32->A2WGetFirst

Remarks

GetFirst = A2WBW32->A2WGetFirst

Example

< TrnLib >

GetFirst = A2WBW32->A2WGetFirst

Available

Release | _______
Patch |


GetNext

[TrnLib]
GetNext

GetNext

Use this FSISYS.INI control group to define the DLL and function name to call for the GenWip.exe Section.

[ TrnLib]

GetNext = Edit

Parameter | Description
value | GetNext = A2WBW32->A2WGetNext

Remarks

GetNext = A2WBW32->A2WGetNext

Example

< TrnLib >

GetNext = A2WBW32->A2WGetNext

Available

Release | _______
Patch |


InitFunc

[TrnLib]
InitFunc

InitFunc

Use this FSISYS.INI control group to define the DLL and function name to call for the GenWip.exe Section.

[ TrnLib]

InitFunc = Edit

Parameter | Description
value | InitFunc = A2WBW32->A2Winit

Remarks

InitFunc = A2WBW32->A2Winit

Example

< TrnLib >

InitFunc = A2WBW32->A2WInit

Available

Release | _______
Patch |


TermFunc

[TrnLib]
TermFunc

TermFunc

Use this FSISYS.INI control group to define the DLL and function name to call for the GenWip.exe Section.

[ TrnLib]

TermFunc = Edit

Parameter | Description
value | TermFunc = A2WBW32->A2WTerm

Remarks

TermFunc = A2WBW32->A2WTerm

Example

< TrnLib >

TermFunc = A2WBW32->A2WTerm

Available

Release | _______
Patch |


TwoUp

Remarks

CounterTbl

TwoUp Options

  • CounterDFD
  • CounterTbl
  • DivertOMR
  • DivertOpt
  • Lmargin
  • Lshift
  • PageSize
  • Rshift


CounterDFD

[TwoUp]
CounterDFD

CounterDFD

This option specifies the name of the Counter Data Format Definition file.

[ TwoUp]

CounterDFD = Path

Parameter | Description
Path |

Remarks

DFD files define to the system the database file formats of the files generated by the system.

Example

< TWOUP >

CounterDFD = deflib\counter.dfd

Available

Release | 10.0
Patch |


CounterTbl

[TwoUp]
CounterTbl

CounterTbl

This option specifies the file name for the table that contains recipient batch page counts.

[ TwoUp]

CounterTbl = Path

Parameter | Description
Path |

Remarks

Use this FSISYS.INI control group to specify the counter table and the counter DFD as well as set margin values in the bill print utility.

Example

< TwoUp >

CounterTbl = data\counter.tbl

Available

Release | 10.0
Patch |


DivertOMR

[TwoUp]
DivertOMR

DivertOMR

[ TwoUp]

DivertOMR =

Remarks

Generates the OMR mark only for a special divert page. This only applies to 2-up printing. If you use this rule, you must also define the DivertOpt and DivertOMR options in the TwoUp control group.

Example

< TwoUp >

DivertOMR = 000

Available

Release | 10.0
Patch |


DivertOpt

[TwoUp]
DivertOpt

DivertOpt

[ TwoUp]

DivertOpt = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

This only applies to 2-up printing. If you use this rule, you must also define the DivertOpt and DivertOMR options in the TwoUp control group.

Example

< TWOUP >

DivertOpt = No

Available

Release | 10.0
Patch |


Lmargin

[TwoUp]
Lmargin

Lmargin

This option sets the left margin equal to a value in FAP units (2400 per inch).

[ TwoUp]

Lmargin = LMargin = 600

Parameter | Description
value | Default value is: LMargin = 600

Remarks

If LMargin = 600, the margin is ¼ inch. If you omit this option, the system uses LMargin = 600 as the default.

Example

< TwoUp >

LMargin = 600

Available

Release | 10.0
Patch |


Lshift

[TwoUp]
Lshift

Lshift

This option shifts the left page to the right by a distance specified in FAP units (2400 per inch).

[ TwoUp]

Lshift = Lshift = 1200

Parameter | Description
value | Default value is: Lshift = 1200

Remarks

If Lshift = 1200, the system shifts the left page image ½ inch from the left edge of the paper. If you omit this option the system uses Lshift = 1200 as the default.

Example

< TwoUp >

LShift = 1200

Available

Release | 10.0
Patch |


PageSize

[TwoUp]
PageSize

PageSize

[ TwoUp]

PageSize =

Example

< TWOUP >

PageSize = 40800

Available

Release | 10.0
Patch |


Rshift

[TwoUp]
Rshift

Rshift

This option shifts the right page to the right by a value specified in FAP units (2400 per inch).

[ TwoUp]

Rshift = Rshift = 16800

Parameter | Description
value | Default value is: Rshift = 16800

Remarks

If Rshift = 15600, the right page image is shifted 6 ½ inches from the left edge of the paper. If you omit this option the system uses Rshift = 16800 as the default.

Example

< TwoUp >

RShift = 16800

Available

Release | 10.0
Patch |


UnixSubs

Remarks

Use <UnixSubs> to define substitutions for common shortened names such as TIMES which is a substitution for Times New Roman or E.EXE which is used for NOTEPAD.EXE.

Defaults:

<UnixSubs>

times = time new roman

e.exe = notepad.exe

epm.exe = notepad.exe

cmd.exe = command.com

helv = arial

univers = arial

univers att = arial

courier = courier new

tms rmn = times new roman

times roman = times new roman

thorndale amt = times new roman

letter gothic mt = courier new

letter gothic = courier new

cumberland amt = courier new

andale duospace wt = courier new

albany amt = arial

docudings = wingdings


UnLoader:FAP

UnLoader:
FAP

Remarks

Desc

UnLoader:FAP Options

  • Desc
  • UnLoadFunc


Desc

[UnLoader:FAP]
Desc

Desc

Use this FAPCOMP.INI control group to enable GenData to unload the internal FAP structure during batch processing.

[ UnLoader:FAP]

Desc = File

Parameter | Description
File |

Remarks

Parameters for unloading the FAP files are set in the FSISYS.INI RunMode control group.

Desc = FormMaker III (*.FAP)

This option names the files to be unloaded by GenData to GenPrint during batch processing.

Example

< UnLoader:FAP >

Desc = FormMaker III (*.FAP)

Available

Release | _______
Patch |


UnLoadFunc

[UnLoader:FAP]
UnLoadFunc

UnLoadFunc

This option names the function to call for unloading FAPs to the GenPrint program.

[ UnLoader:FAP]

UnLoadFunc =

Remarks

The option value shown in this heading specifies that GenData unloads FAP images only, and uses DDT

files for font and coordinate information. If DDT files have the font and coordinate information, this option optimizes GenData performance.

Example

< UnLoader:FAP >

UnLoadFunc = FAPUnloadImageNoFonts

Available

Release | _______
Patch |


UnLoaders

Remarks

UnLoader

UnLoaders Options

  • UnLoader


UnLoader

[UnLoaders]
UnLoader

UnLoader

Use this FAPCOMP.INI control group to specify the type of files GenData unloads during batch processing.

[ UnLoaders]

UnLoader =

Remarks

Each option listed in the UnLoaders group should have an UnLoader:xxx INI group (where xxx represents the loader name) within the FAPCOMP.INI file. Parameters for unloading FAP files are contained in the FSISYS.INI RunMode control group.

UnLoader = FAP

This option tells GenData to unload FAP files during batch processing. Parameters for unloading FAP files are set in the FSISYS.INI RunMode control group.

Example

< UnLoaders >

UnLoader = FAP

Available

Release | _______
Patch |


User_StatusCD

User_StatusCD Options

  • Quote
  • Underwritten


Quote

[User_StatusCD]
Quote

Quote

The FSIUSER.INI USER_STATUSCD control group contains user defined status codes.

[ User_StatusCD]

Quote =

Parameter | Description
Edit | The FSIUSER.INI USER_STATUSCD control group contains user defined status codes.

Remarks

User defined status codes appear in the WIP list as policy status and are changed manually using the WIP, Status menu option. The Processing System accepts any number of user defined status codes; however, you cannot duplicate system status code values contained in the FSISYS.INI file under the STATUS_CD control group.

Example

< USER_STATUSCD >

Quote = Q

Available

Release | _______
Patch |


Underwritten

[User_StatusCD]
Underwritten

Underwritten

The FSIUSER.INI USER_STATUSCD control group contains user defined status codes.

[ User_StatusCD]

Underwritten =

Parameter | Description
value | The FSIUSER.INI USER_STATUSCD control group contains user defined status codes.

Remarks

User defined status codes appear in the WIP list as policy status and are changed manually using the WIP, Status menu option. The Processing System accepts any number of user defined status codes; however, you cannot duplicate system status code values contained in the FSISYS.INI file under the STATUS_CD control group.

Example

< USER_STATUSCD >

UnderWritten = UN

Available

Release | _______
Patch |


UserInfo

Remarks

File

UserInfo Options

  • Encrypt
  • File
  • ImportBadReportTo
  • Path
  • SupportSuperUser
  • SuppressDeleteDialog


Encrypt

[UserInfo]
Encrypt

Encrypt

Turns off encryption for the UserInfo.

[ UserInfo]

Encrypt = Yes

Parameter | Description
Boolean (Yes) | Default value is: Yes

Example

< USERINFO >

Encrypt = Yes

Available

Release | _______
Patch |


File

[UserInfo]
File

File

File is the file name of the USERINFO database.

[ UserInfo]

File = Edit

Parameter | Description
value | File is the file name of the USERINFO database.

Remarks

Use this FSISYS.INI control group to specify the name and location of the user information database. User IDs should be set to a valid user ID from the USERINFO database and each user should have hiw own FISUSER.INI file. The list of users to display comes from the USERINFO file.

Example

< USERINFO >

FILE = USERINFO

Available

Release | _______
Patch |


ImportBadReportTo

[UserInfo]
ImportBadReportTo

ImportBadReportTo

[ UserInfo]

ImportBadReportTo = No

Parameter | Description
boolean (No) | Default value is: No

Remarks

If you are importing a file which contains a record with a report to person who is not in the database, the system produces a warning and skips that record. You can use the following option to suppress this feature so the record is imported even if the report to person does not exist.

The default (No) is to show the warning and not import the record.

Resetting Locked User Ids:

From the User ID Maintenance window, you can now select a user and click the Release button to reset the user ID. For example, if the system is shut down inadvertently, such as when there is a loss of power, user IDs can become locked. Once locked, you cannot use the ID to start the system. Instead, when the user attempts to restart the system, it displays a message stating the user ID is already in use. This occurs because the system assumes the user is still logged on. Resetting a locked user ID lets you unlock the ID so it can be used again.

NOTE: You can still use the separate OpenUser program to reset locked IDs.

Example

< UserInfo >

ImportBadReportTo = Yes

Available

Release | 10.1
Patch |


Path

[UserInfo]
Path

Path

Path specifies the directory path of the USERINFO database.

[ UserInfo]

Path = Path

Parameter | Description
value | Path specifies the directory path of the USERINFO database.

Remarks

Use this FSISYS.INI control group to specify the name and location of the user information database. User IDs should be set to a valid user ID from the USERINFO database and each user should have hiw own FISUSER.INI file. The list of users to display comes from the USERINFO file.

Example

< USERINFO >

PATH = ..\

Available

Release | _______
Patch |


SupportSuperUser

[UserInfo]
SupportSuperUser

SupportSuperUser

[ UserInfo]

SupportSuperUser = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

To have SuperUser access, you must have a security level of zero (0) and you must have the SupportSuperUser option set to Yes in your FSIUSER.INI or FSISYS.INI (or FAPCOMP.INI for DocuCreate) file, as shown here:

< UserInfo >

SupportSuperUser = Yes

You should also have the Do_Logon option set as shown here:

< Enviroment >

Do_Logon = Yes

With these settings and the appropriate access level, the User ID Maintenance window provides access to the new features. You'll notice that there is no longer a Save button because the system saves your information as you enter it, and there are two new buttons: Import and Release.

The Import button lets you import user information. The Release button lets you reset a user ID that has been locked.

NOTE: With version 10.1, DOCUCORP is now the default supervisor ID. The FORMAKER ID used in earlier versions is still valid, but it now reports to the DOCUCORP ID.

Example

< UserInfo >

SupportSuperUser = Yes

Available

Release | 10.1
Patch |


SuppressDeleteDialog

[UserInfo]
SuppressDeleteDialog

SuppressDeleteDialog

When you delete a user, the system asks you to confirm the deletion.

[ UserInfo]

SuppressDeleteDialog = No

Parameter | Description
boolean | When you delete a user, the system asks you to confirm the deletion. Default value is: No

Remarks

You can set the following option to suppress the confirmation window.

When you delete a user, the system asks you who to reassign as the user's report to person and displays a list of all users. Select the appropriate report-to person to replace the one you just deleted. This will apply to all users who formerly reported to the user you just deleted.

For example, assume the user DOCUCORP has three users that report to it. If you delete DOCUCORP from the User ID Maintenance window, the system asks if you would like to continue. Choose Yes to continue. Since DOCUCORP is not the user currently logged in, another window appears with a list of user IDs. Choose a user ID from the list. The users that once reported to DOCUCORP now report to the new user.

If you want to suppress this window, add this INI option:

< UserInfo >

SuppressReportToDlg = Yes

If you set the SuppressReportToDlg option to Yes, the system sets the current user as the new report to person for each person in the deleted user's report to list.

Example

< UserInfo >

SuppressDeleteDialog = Yes

Available

Release | 10.1
Patch |


VerifyKeyID

Remarks

Script

VerifyKeyID Options

  • OnCreate
  • OnUpdate
  • Script


OnCreate

[VerifyKeyID]
OnCreate

OnCreate

This option defaults to yes to indicate you want to call the script when creating a new form set via the Form Selection window.

[ VerifyKeyID]

OnCreate = YN

Parameter | Description
boolean | This option defaults to yes to indicate you want to call the script when creating a new form set via the Form Selection window.

Example

< VerifyKeyID >

OnCreate = Yes

Available

Release | 10.1
Patch | 345


OnUpdate

[VerifyKeyID]
OnUpdate

OnUpdate

[ VerifyKeyID]

OnUpdate = No

Parameter | Description
boolean (No) | This option defaults to No to indicate you do not want to call the script to verify the KeyID on transactions that have already been saved to WIP. Default value is: No

Remarks

This option defaults to No to indicate you do not want to call the script to verify the KeyID on transactions that have already been saved to WIP.

To verify WIP transactions as well, set this option to Yes.

Example

< VerifyKeyID >

OnUpdate = No

Available

Release | 10.1
Patch | 345


Script

[VerifyKeyID]
Script

Script

[ VerifyKeyID]

Script =

Parameter | Description
value | Enter the name of the script you want the system to use. Store this script in the DefLib directory specified for your master resource library (MRL).

Remarks

Enter the name of the script you want the system to use. Store this script in the DefLib directory specified for your master resource library (MRL).

Example

< VerifyKeyID >

Script = KeyID.DAL

Available

Release | 10.1
Patch | 345


VerticalRuler

VerticalRuler Options

  • BackColor
  • ForeColor
  • Type


BackColor

[VerticalRuler]
BackColor

BackColor

This FAPCOMP.INI group controls the display of the vertical ruler in the Image Editor window.

[ VerticalRuler]

BackColor = Color

Parameter | Description
Color |

Remarks

This option defines the background color of the vertical ruler in the Image Editor window. This option value may be set in the Image Editor by choosing View, Options; then select the Rulers tab in the View Properties window. Click BACKGROUND in the Vertical field to display the color selection window.

Example

< VerticalRuler >

BackColor = 16776960

Available

Release | _______
Patch |


ForeColor

[VerticalRuler]
ForeColor

ForeColor

This FAPCOMP.INI group controls the display of the vertical ruler in the Image Editor window.

[ VerticalRuler]

ForeColor =

Remarks

This option defines the foreground color of the vertical ruler (numbers and increments) in the Image Editor window. This option value may be set in the Image Editor by choosing View, Options; then select the Rulers tab in the View Properties window. Click FOREGROUND in the Vertical field to display the color selection window.

Example

< VerticalRuler >

ForeColor = 0

Available

Release | _______
Patch |


Type

[VerticalRuler]
Type

Type

Use this control group to specify the unit of measure for the vertical ruler. By default, the system uses inches as the unit of

[ VerticalRuler]

Type =

Parameter | Description
value | Type determines the unit of measure for the vertical ruler and grid.

Remarks

Your rulers and grid lines are marked in increments based on inches. In the Processing System, you can select a

different unit of measure by modifying your FSIUSER.INI or FSISYS.INI files.

Type determines the unit of measure for the vertical ruler and grid. Your options are explained in below:

To choose: Set Type equal to:

none 0

FAP units (1/2400 of an inch) 1

Points 2

Inches 3

Metric (centimeters) 4

Picas 5

1/8 inch increments 6

1/6 inch increments 7

Note: You have the same unit of measurement options in the Image Editor. When you create an image, the system stores all measurement information in FAP units. Based on the user's INI file settings, the system automatically switches to the user's unit of measure for entry and display purposes. For example, if you create an image using

inches, a data entry user in the Processing System will see centimeters as the unit of measure if his or her INI files are set for centimeters.

Example

< VerticalRuler >

Type = 4

Available

Release | _______
Patch |


VSAM

Remarks

The < VSAM > group only applies to the MVS (a.k.a. OS/390) Operating System platform.

Example

< VSAM >

DDTVSAM = DD:DDTVSAM

JDTVSAM = DD:JDTVSAM

METVSAM = DD:PMETVSAM

VSAMNA = DD:NAFILE

VSAMRCPTB = DD:SETRCPVS

VSAM Options

  • DDTVSAM
  • JDTVSAM
  • METVSAM
  • VSAMNA
  • VSAMRCPTB


DDTVSAM

[VSAM]
DDTVSAM

DDTVSAM

Indicates that the DDT files are located in a VSAM file.

[ VSAM]

DDTVSAM =

Parameter | Description
value | DD name for DDT VSAM file

Remarks

The DDTVSAM option indicates that the DDTs are located in the VSAM file associated with the specified DD name.

Example

< VSAM >

DDTVSAM = DD:DDTVSAM

Available

Release | _______
Patch |

Used By

GENARC, GENDATA


JDTVSAM

[VSAM]
JDTVSAM

JDTVSAM

Indicates that the JDT file(s) are located in a VSAM file.

[ VSAM]

JDTVSAM =

Parameter | Description
value | DD name for JDT VSAM file

Remarks

The JDTVSAM option indicates that the JDT(s) are located in the VSAM file associated with the specified DD name.

Example

< VSAM >

JDTVSAM = DD:JDTVSAM

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT


METVSAM

[VSAM]
METVSAM

METVSAM

Indicates that the Xerox pre-compiled Metacode files (PMETs) are located in a VSAM file.

[ VSAM]

METVSAM =

Parameter | Description
value | DD name for Xerox PMET VSAM file

Remarks

The METVSAM option indicates that the Xerox pre-compiled Metacode files (PMETs) are located in the VSAM file associated with the specified DD name.

Example

< VSAM >

METVSAM = DD:PMETVSAM

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT


VSAMNA

[VSAM]
VSAMNA

VSAMNA

Indicates that the NAFILE and POLFILE files are located in a VSAM file.

[ VSAM]

VSAMNA =

Parameter | Description
value | DD name for the NAFILE VSAM file

Remarks

Indicates that the NAFILE is located in the VSAM file associated with the specified DD name. If this option is specified, it is also assumed that the POLFILE is also to be processed as a VSAM file and that the DD name associated with the POLFILE is DD:POLFILE.

Example

< VSAM >

VSAMNA = DD:NAFILE

Available

Release | _______
Patch |

Used By

GENARC, GENDATA, GENPRINT


VSAMRCPTB

[VSAM]
VSAMRCPTB

VSAMRCPTB

Indicates that the Set Recipient file is located in a VSAM file.

[ VSAM]

VSAMRCPTB =

Parameter | Description
value | DD name for Set Recipient VSAM file

Remarks

Indicates that the Set Recipient file is locatedin the VSAM file associated with the specified DD name.

Example

< VSAM >

VSAMRCPTB = DD:SETRCPVS

Available

Release | _______
Patch |


Watermark

Watermark Options

  • Angle
  • Color
  • FontID
  • Left
  • Logo
  • Pages
  • Text
  • Top
  • Washout


Pages

[Watermark]
Pages

Pages

Parameter | Description
Pages | Define pages to watermark. The default is all.

Remarks

You can select pages to watermark. Use a format such as “1,3,5,10-15, 25-30,31”.

By defining “ALL” or default, all pages will be selected.

Example

< Watermark >

Pages = All

Available

Release | 12.1
Patch |

Used By


Angle

[Watermark]
Angle

Angle

Parameter | Description
Angle | Set the rotation angle desired. Choose from: 0, 45, -45, 90, 180, 270. The default is 0.

Remarks

You can rotate the watermark by 0, 45, -45, 90, 180, or 270 degrees. If not specified, there is no rotation.

Example

< Watermark >

Angle = 45

Available

Release | 12.1
Patch |

Used By

Print library.


Color

[Watermark]
Color

Color

Parameter | Description
Color | Define color conversion desired. The default is no conversion.

Remarks

When specified, watermark logo will be converted to monochrome or gray scale. If not specified, there is no color conversion.

following are valid formats to use:

Format | Description
RGB(red,green,blue) | Where each of the color values range from 0 - 255
(red,green,blue,options) | Where each of the color values range from 0 - 255. The options should be set to zero.
#rrggbb | Hexadecimal representation for red, green, blue where each color value ranges from 00 - FF
16777215 | Decimal representation of the hexadecimal definition shown above. Range will be 0 - 16777215.

Example

< Watermark >

Color = (0,0,255,0)

Available

Release | 12.1
Patch |

Used By


FontID

[Watermark]
FontID

FontID

Parameter | Description
FontID | Define a font ID to use that is in your FXR.

Remarks

When using a text watermark, you must supply the font ID to use. A text watermark generates a text label for these types of watermarks.

Example

< Watermark >

FontID = 16010

Available

Release | 12.1
Patch |

Used By


Left

[Watermark]
Left

Left

Parameter | Description
Left | Left position in FAP units. Default value is zero.

Remarks

Define the watermark horizontal position in FAP units. The default value is zero which positions the watermark at middle of page horizontally.

Example

< Watermark >

Left = 2400

Available

Release | 12.1
Patch |

Used By


Logo

[Watermark]
Logo

Logo

Parameter | Description
Logo | Name

Remarks

Define the logo file name to use for the watermark. The logo can can be in library or qualified with a full path.

Example

< Watermark >

Logo = proof

Available

Release | 12.1
Patch |

Used By


Text

[Watermark]
Text

Text

Parameter | Description
Text | Text

Remarks

Define the text that should appear when defining a text only watermark. You must supply a font ID to use for these watermarks.

Example

< Watermark >

Text = Proof Only!

Available

Release | 12.1
Patch |

Used By


Washout

[Watermark]
Washout

Washout

Parameter | Description
Washout | Percentage to washout color. The default is 0.

Remarks

Define the a percent range from 0 – 100 to washout the watermark. Default is zero, no washout.

Example

< Watermark >

Washout = 50

Available

Release | 12.1
Patch |

Used By


Top

[Watermark]
Top

Top

Parameter | Description
Top | Top position in FAP units. Default value is zero.

Remarks

Define the watermark vertical position in FAP units. The default value is zero which positions the watermark at middle of page vertically

Example

< Watermark >

Top = 4800

Available

Release | 12.1
Patch |

Used By


Window32Subs

Remarks

Use <Window32Subs> to define substitutions for common shortened names such as TIMES which is a substitution for Times New Roman or E.EXE which is used for NOTEPAD.EXE.

Defaults:

<Window32Subs>

E.EXE = NOTEPAD.EXE

EPM.EXE = NOTEPAD.EXE

CMD.EXE = COMMAND.COM

HELV = ARIAL

UNIVERS = ARIAL

UNIVERS ATT = ARIAL

COURIER = COURIER NEW

TMS RMN = TIMES NEW ROMAN

TIMES = TIMES NEW ROMAN

TIMES ROMAN = TIMES NEW ROMAN

THORNDALE AMT = TIMES NEW ROMAN

LETTER GOTHIC MT = COURIER NEW

LETTER GOTHIC = COURIER NEW

CUMBERLAND AMT = COURIER NEW

ANDALE DUOSPACE WT = COURIER NEW

ALBANY AMT = ARIAL

DOCUDINGS = WINGDINGS


Window64Subs

Remarks

Use <Window64Subs> to define substitutions for common shortened names such as TIMES which is a substitution for Times New Roman or E.EXE which is used for NOTEPAD.EXE.

Defaults:

<Window64Subs>

E.EXE = NOTEPAD.EXE

EPM.EXE = NOTEPAD.EXE

CMD.EXE = COMMAND.COM

HELV = ARIAL

UNIVERS = ARIAL

UNIVERS ATT = ARIAL

COURIER = COURIER NEW

TMS RMN = TIMES NEW ROMAN

TIMES = TIMES NEW ROMAN

TIMES ROMAN = TIMES NEW ROMAN

THORNDALE AMT = TIMES NEW ROMAN

LETTER GOTHIC MT = COURIER NEW

LETTER GOTHIC = COURIER NEW

CUMBERLAND AMT = COURIER NEW

ANDALE DUOSPACE WT = COURIER NEW

ALBANY AMT = ARIAL

DOCUDINGS = WINGDINGS


WipData

Remarks

Any system functions that use the wip database need this information.

WipData Options

  • DupCount
  • File
  • Key1
  • Key2
  • KeyId
  • MaxWIPRecords
  • Path
  • UNIQUE
  • WIPDFDFile


DupCount

[WipData]
DupCount

DupCount

[ WipData]

DupCount =

Example

< WipData >

DupCount =

Available

Release | _______
Patch |

Used By

AFEMAIN


File

[WipData]
File

File

File name of the WIP database

[ WipData]

File = WIP

Parameter | Description
File | Default value is: WIP

This option may be required in order for the feature to function.

Remarks

This control group is required in the fsiuser.ini file. If you are missing the file name for this option you will receive an error message:

Afemain Error: missing Wip File in INI.

Example

< WipData >

File = WIP

Available

Release | _______
Patch |

Used By

AFEMAIN, GENWIP


Key1

[WipData]
Key1

Key1

[ WipData]

Key1 =

Remarks

The system uses this field to refer to the first key field defined in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to retrieve the formset. You may leave the Key1 option out of the WipData INI control group and the system defaults to Key1.

However, the ArcRet INI Control Group Key1 option is required.

So, initially it would be best to complete both option names with the same useful field name.

Note: The DocSetNames INI Control Group applies to the rules processor and not the processing system (afemain).The first key field in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) must be defined in the DocSetNames INI Control Group

Afemain (Processing system):

The DocSetNames control INI group is not used in the AFEMAIN system.

Rules Processor (RP system):

The DocSetNames control INI group is required by the rules processor system.

So, for consistency, you should initially ensure the WipData, ArcRet and (optionally) the DocSetNames INI Control Groups contain the key1 field with the same name.

Subsequently, you may choose a different key1 name for the ArcRet group so you can retrieve using different field criteria.

Example

< WipData >

Key1 =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENWIP


Key2

[WipData]
Key2

Key2

[ WipData]

Key2 =

Remarks

The system uses this field to refer to the first key field defined in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) to retrieve the formset. You may leave the Key1 option out of the WipData INI control group and the system defaults to Key2. You may leave the Key2 option out of the WipData INI control group and the system defaults to Key2.

However, the ArcRet INI Control Group Key2 option is required.

So, initially it would be best to complete both option names with the same useful field name.

Note: The DocSetNames INI Control Group applies to the rules processor and not the processing system (afemain).The first key field in the Form set definition file (form.dat, .BDF, .GRP, or .FOR) must be defined in the DocSetNames INI Control Group

Afemain (Processing system):

The DocSetNames control INI group is not used in the AFEMAIN system.

Rules Processor (RP system):

The DocSetNames control INI group is required by the rules processor system.

So, for consistency, you should initially ensure the WipData, ArcRet and (optionally) the DocSetNames INI Control Groups contain the key2 field with the same name.

Subsequently, you may choose a different key2 name for the ArcRet group so you can retrieve using different field criteria.

Example

< WipData >

Key2 =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENWIP


KeyId

[WipData]
KeyId

KeyId

This is the transaction ID field.

[ WipData]

KeyId =

Remarks

The KeyId option defaults to the KeyId name field. Ordinarily, in Afemain you manually enter the transaction's Key ID. In the rules processor, the information comes from the extract file and is declared in the DocSetNames INI group.

Note: in Afemain you must enter the KeyId field data to save a transaction.

In the rules processor, you can save the transaction to Wip, but you potentially would have a blank KeyId for this transaction.

Example

< WipData >

KeyID =

Available

Release | _______
Patch |

Used By

AFEMAIN, GENWIP


MaxWIPRecords

[WipData]
MaxWIPRecords

MaxWIPRecords

Specifies the maximum records to read in the processQ. Use this to prevent it from slowing due to volume records.

[ WipData]

MaxWIPRecords =

Parameter | Description
value |

This option may be required in order for the feature to function.

Example

< WipData >

MaxWIPRecords = 200

Available

Release | _______
Patch |


Path

[WipData]
Path

Path

Path = [CONFIG:SAMPCO] WIPPath= Path of the WIP database and all files saved to WIP

[ WipData]

Path = Path

Parameter | Description
Path |

This option may be required in order for the feature to function.

Remarks

Location of WIP database and all data files saved to WIP.

Otherwise, Afemain Error: WipPath INI option not found.

Example

< WipData >

Path = mstrres\sampco\wip

Available

Release | _______
Patch |

Used By

AFEMAIN, GENWIP


TransCode

[WipData]
TransCode

Used for naming on predefined TransCode

[WipData]

TransCode = TransCode

Parameter | Description
TransCode | Name of the TransCode to be used.

This option may be required in order for the feature to function.

Remarks

Name of the TransCode to be used

Example

[WipData]

TransCode = Transcode

Available

Release | 11.3
Patch |


UNIQUE

[WipData]
UNIQUE

UNIQUE

This option is not required. The system defaults to a file that is named unique.dat.

[ WipData]

UNIQUE = Edit

Parameter | Description
value |

Remarks

The purpose of the unique.dat file is to serve as a control or flag that lets the system know a user has accessed a transaction from the Wip database. A second user can access the same transaction but cannot update the data.

From PCR 10380: Only authorized individuals can seed the Unique file. This helps make sure the Unique file is not deleted and recreated without notice.

This PCR addresses the authorized seed functionality plus a new UNIQUE.DAT file that is used instead of the UNIQUE.DBF and UNIQUE.MDX files.

For legacy reasons, if there are UNIQUE.DBF and UNIQUE.MDX files, and you can continue to use them. To make sure you always use the UNIQUE.DBF file, add or modify the INI option which names the file to include the .DBF extension, as shown here:

< WIPData >

Unique = UNIQUE.DBF

Normally this option is not present in the INI file. "UNIQUE" is the normal default when the option is omitted.

Example

< WipData >

Unique =

Available

Release | _______
Patch |

Used By

AFEMAIN


WIPDFDFile

[WipData]
WIPDFDFile

WIPDFDFile

This option is not required. This option lets you specify the full path and name for the Wip DFD file.

[ WipData]

WIPDFDFile = wip.dfd

Parameter | Description
Path | Default value is: wip.dfd

Remarks

This option is used to define the full path name of the custom WIP DFD file. If just the file name is specified, the default path is where < MasterResource> Deflib option points to.

This lets you specify an alternate file name and location for the wip.dfd file. The dfd file defines the fields and names in the Wip DBF file.

Note: You can define your own dfd file and location. Ensure the path and file name are valid. Otherwise, if the system cannot find the file it will use the default wip.dfd file without warning.

The result is you may receive subsequent error messages saying the key fields are not defined in the dfd file.

Example

< WipData >

WIPDFDFile = wip.dfd

or

WIPDFDFile = .\deflib\wip.dfd

Available

Release | _______
Patch |

Used By

AFEMAIN, GENWIP


WipEdit

WipEdit Options

ExecDir

VersionFile

VersionFileName


ExecDir

[WipEdit]
ExecDir

ExecDir

[ WipEdit ]

ExecDir = path

Parameter | Description
Path | Enter the full path for the setup.exe and install.wipedit files.

Remarks

This option is only necessary if you did not use the default install location and the system is not locating the correct executable path.

Example

< WIPEdit >

VersionFile = c:\docserv\data\install

ExecDir = c:\docserv\data\install\wipedit\

VersionFileName = install

Available

Release | 11.4
Patch |


VersionFile

[WipEdit]
VersionFile

VersionFile

[ WipEdit ]

VersionFile = file

Parameter | Description
file | Enter the full path to the version file.

Remarks

This option is only necessary if you did not use the default install location and the system is unable to locate the correct executable location.

Example

< WIPEdit >

VersionFile = c:\docserv\data\install

ExecDir = c:\docserv\data\install\wipedit\

VersionFileName = install

Available

Release | 11.4
Patch |


VersionFileName

[WipEdit]
VersionFileName

VersionFileName

[ WipEdit ]

VersionFileName = filename

Parameter | Description
filename | Enter the name of the version file.

Remarks

This option is only necessary if you did not use the default install location and the system is unable to locate the correct executable location.

Example

< WIPEdit >

VersionFile = c:\docserv\data\install

ExecDir = c:\docserv\data\install\wipedit\

VersionFileName = install

Available

Release | 11.4
Patch |


WIPFilter

Remarks

DefaultRecipView

WIPFilter Options

  • DefaultRecipView
  • DisplayRecipDialog


DefaultRecipView

[WIPFilter]
DefaultRecipView

DefaultRecipView

Feature 1378 Now you can filter the forms you want to view when editing a policy. The filter is based on recipients.

[ WIPFilter]

DefaultRecipView = Edit

Parameter | Description
data | Now you can filter the forms you want to view when editing a policy. The filter is based on recipients.

Remarks

The DefaultRecipView option lets you specify the recipient forms you want to see.

The DisplayRecipDialog option tells the system whether or not it should display a window which shows all recipient names. The default is No.

If you include the DefaultRecipView option, the system ignores the DisplayRecipDialog option.

Example

< WIPFilter >

DefaultRecipView = AGENT,client;

Available

Release | 10.1
Patch | 448


DisplayRecipDialog

[WIPFilter]
DisplayRecipDialog

DisplayRecipDialog

Feature 1378 Now you can filter the forms you want to view when editing a policy. The filter is based on recipients.

[ WIPFilter]

DisplayRecipDialog = No

Parameter | Description
Boolean (No) | Now you can filter the forms you want to view when editing a policy. The filter is based on recipients. Default value is: No

Remarks

The DefaultRecipView option lets you specify the recipient forms you want to see.

The DisplayRecipDialog option tells the system whether or not it should display a window which shows all recipient names. The default is No.

If you include the DefaultRecipView option, the system ignores the DisplayRecipDialog option.

Example

< WIPFilter >

DisplayRecipDialog = Yes

Available

Release | 10.1
Patch | 448


WordDateFormats

Remarks

When you convert or print FAP file to RTF file, you can use the WordDateFormats and WordTimeFormats control groups to convert the Documaker format to a Word format for variable fields in the FAP file. The following groups and options let you map a Documaker format to a Word format.

< WordDateFormats >

bD/bM/YY =

< WordTimeFormats >

hh:mm XM =

To the left of the equals sign, you list the Documaker date format used on the section. To the right, you list the Word format you want to use. If not specified, the system will convert date formats to MM/DD/YY and time formats to hh:mm:ss.

Below is the list of Documaker date formats:

  • MM/DD/YY
  • DD/MM/YY
  • YY/MM/DD
  • M/D/YY
  • D/M/YY
  • YY/M/D
  • bM/bD/YY
  • bD/bM/YY
  • YY/bM/bD
  • MMDDYY
  • DDMMYY
  • YYMMDD
  • MonDDYY
  • DDMonYY
  • YYMonDD
  • DAY/YY
  • YY/DAY
  • Mon-DD-YY
  • DD-Mon-YY
  • YY-Mon-DD

If the WordDateFormats control group is omitted, the system will convert the date format to the MM/DD/YY format.

In addition to the WordDateFormats control group, you would need to set up the RTF print type and the Printer (for command line utility) or Printers (for the GUI tools). Here is an example:

< Printer >

PrtType = RTF

< PrtType:RTF >

Class = RTF

Module = RTFW32

PrintFunc = RTFPrint

AllowInput = Yes

TemplateFields = Yes

Please refer to the AllowInput and TemplateFields options in the PrtType:RTF group, and Printers and Printer groups for more information.

Example

< WordDateFormats >

bD/bM/YY = YYYY-MM-DD

bM/bD/YY = MM.dd.yy

WordDateFormats Options

  • YYMMDD


YYMMDD

[WordDateFormats]
YYMMDD

YYMMDD

Use the WordDateFormats group to map the Documaker date format to the Word date format when printing or converting a fap to RTF.

[ WordDateFormats]

YYMMDD = MM/DD/YY

Parameter | Description
Edit | Default value is: MM/DD/YY

Remarks

When you convert or print FAP file to RTF file, you can use the WordDateFormats and WordTimeFormats control groups to convert the Documaker format to a Word format for variable fields in the FAP file. The following groups and options let you map a Documaker format to a Word format.

< WordDateFormats >

bD/bM/YY =

< WordTimeFormats >

hh:mm XM =

To the left of the equals sign, you list the Documaker date format used on the section. To the right, you list the Word format you want to use. If not specified, the system will convert date formats to MM/DD/YY and time formats to hh:mm:ss.

If the WordDateFormats control group is omitted, the system will convert the date format to the MM/DD/YY format.

Example

< WordDateFormats >

bD/bM/YY = YYYY-MM-DD

bM/bD/YY = MM.dd.yy

Available

Release | 10.3
Patch | 33

Used By

RTFLIB


WordTimeFormats

Remarks

When you convert or print FAP file to RTF file, you can use the WordDateFormats and WordTimeFormats control groups to convert the Documaker format to a Word format for variable fields in the FAP file. The following groups and options let you map a Documaker time format to a Word format.

< WordDateFormats >

bD/bM/YY =

< WordTimeFormats >

hh:mm XM =

To the left of the equals sign, you list the Documaker time format used on the section. To the right, you list the Word format you want to use. If not specified, the system will convert date formats to MM/DD/YY and time formats to hh:mm:ss.

Below is the list of Documaker time formats:

  • HH:MM:SS
  • HH:MM:SS XM
  • HH:MM
  • HH:MM XM

If the WordTimeFormats control group is omitted, the system will convert the time format to the HH:MM:SS format.

In addition to the above INI options, you would need to set up the RTF print type and the Printer (for command line utility) or Printers (for the GUI tools). Here is an example:

< Printer >

PrtType = RTF

< PrtType:RTF >

Class = RTF

Module = RTFW32

PrintFunc = RTFPrint

AllowInput = Yes

TemplateFields = Yes

Please refer to the AllowInput and TemplateFields options in the PrtType:RTF group, and Printers and Printer groups for more information.

Example

< WordTimeFormats >

hh:mm:ss = h:mm am/pm

WordTimeFormats Options

  • hh:mm


hh:mm

[WordTimeFormats] hh:
mm

hh:mm

[ WordTimeFormats]

hh:mm = hh:mm:ss

Parameter | Description
Edit | Default value is: hh:mm:ss

Remarks

Use the WordTimeFormats group to map the Documaker time format to the Word time format when printing or converting a fap to RTF.

When you convert or print FAP file to RTF file, you can use the WordDateFormats and WordTimeFormats control groups to convert the Documaker format to a Word format for variable fields in the FAP file. The following groups and options let you map a Documaker date/time format to a Word format.

< WordDateFormats >

bD/bM/YY =

< WordTimeFormats >

hh:mm XM =

To the left of the equals sign, you list the Documaker time format used on the section. To the right, you list the Word format you want to use. If not specified, the system will convert date formats to MM/DD/YY and time formats to hh:mm:ss.

If the WordTimeFormats control group is omitted, the system will convert the time format to the HH:MM:SS format.

Example

< WordTimeFormats >

hh:mm:ss = h:mm am/pm

hh:mm XM = hh:mm:ss

Available

Release | 10.3
Patch | 33

Used By

RTFLIB


WorkArea

Remarks

Actionbar

WorkArea Options

  • Actionbar
  • Objectbar
  • Statusline


Actionbar

[WorkArea]
Actionbar

Actionbar

Use this FAPCOMP.INI control group to set default values for the location of toolbars on the window.

[ WorkArea]

Actionbar = LimitList

Parameter

Description

LimitList

Values can be

  • T - Top
  • B - Bottom

Remarks

Actionbar = T

This option specifies the location of the action bar in the window. The option values are T (top) or B (bottom).

Example

< WorkArea >

Actionbar = T

Available

Release | _______
Patch |


Objectbar

[WorkArea]
Objectbar

Objectbar

Use this FAPCOMP.INI control group to set default values for the location of toolbars on the window.

[ WorkArea]

Objectbar = LimitList

Parameter

Description

LimitList

Values can be

  • T - Top
  • B - Bottom

Remarks

Objectbar = T

This option specifies the location of the object bar in the window. The option values are T (top) or B (bottom).

Example

< WorkArea >

Objectbar = T

Available

Release | _______
Patch |


Statusline

[WorkArea]
Statusline

Statusline

Use this FAPCOMP.INI control group to set default values for the location of toolbars on the window.

[ WorkArea]

Statusline = LimitList

Parameter

Description

LimitList

Values can be

  • T - Top
  • B - Bottom

Remarks

Statusline = B

This option specifies the location of the status line in the window. The option values are T (top) or B (bottom).

Example

< WorkArea >

Statusline = B

Available

Release | _______
Patch |


XDB Editor

XDB
Editor

Remarks

SortByParentOffset

XDB Editor Options

  • SortByParentOffset


SortByParentOffset

[XDB Editor]
SortByParentOffset

SortByParentOffset

Feature 1407

[ XDB Editor]

SortByParentOffset = No

Parameter | Description
Boolean (No) | Default value is: No

Remarks

You can now use the SortByParentOffset option to tell the system to sort the items in the data dictionary by parent and offset key. The default sort order is by field name.

< XDB Editor >

SortByParentOffset = Yes

If you enter Yes, the system sorts the data dictionary by parent then offset within parent. The default is No, which tells the system to sort the data dictionary by field name.

Keep in mind that using this INI option also affects the Image Editor and Form Set Manager, as well as the Dictionary Editor.

Example

< XDB Editor >

SortByParentOffset = Yes

Available

Release | 10.2
Patch | 65


XML_Imp_Exp

Remarks

Ext

XML_Imp_Exp Options

  • DSIAttachedVarFile
  • DSIIgnoreTimeoutError
  • DSIImportLevel
  • DSIRecordDFD
  • DSIReqType
  • DSITimeout
  • DSIUseNTUserID
  • DSIVARS
  • Ext
  • File
  • Path
  • SuppressDlg


DSIAttachedVarFile

[XML_Imp_Exp]
DSIAttachedVarFile

DSIAttachedVarFile

(optional) The default is DOCC_XML.

[ XML_Imp_Exp]

DSIAttachedVarFile =

Parameter | Description
value | (optional) The default is DOCC_XML. Set this option to the attachment name if it differs from DOCC_XML. This gives you a way to specify the variable name the XML file is attached to.

Remarks

Set this option to the attachment name if it differs from DOCC_XML. This gives you a way to specify the variable name the XML file is attached to.

Example

< XML_IMP_EXP >

DSIAttachedVarFile =

Available

Release | 10.1
Patch | 380


DSIIgnoreTimeoutError

[XML_Imp_Exp]
DSIIgnoreTimeoutError

DSIIgnoreTimeoutError

(optional) Enter yes to continue processing if a timeout occurs. The default is no.

[ XML_Imp_Exp]

DSIIgnoreTimeoutError = No

Parameter | Description
boolean (No) | (optional) Enter yes to continue processing if a timeout occurs. The default is no. This gives you a way to ignore a timeout when waiting on a return queue. Default value is: No

Remarks

This gives you a way to ignore a timeout when waiting on a return queue.

Example

< XML_IMP_EXP >

DSIIgnoreTimeoutError =

Available

Release | 10.1
Patch | 380


DSIImportLevel

[XML_Imp_Exp]
DSIImportLevel

DSIImportLevel

(optional) This option is typically used by programmers. Enter 2 if you want the hook to operate on the FAP_MSGOPEN level.

[ XML_Imp_Exp]

DSIImportLevel =

Parameter | Description
value | (optional) This option is typically used by programmers. Enter 2 if you want the hook to operate on the FAP_MSGOPEN level. Enter 3 if you want it to operate on the FAP_MSGRUN level. The default is 2.

Remarks

Enter 3 if you want it to operate on the FAP_MSGRUN level. The default is 2.

Example

< XML_IMP_EXP >

DSIImportLevel =

Available

Release | 10.1
Patch | 380


DSIRecordDFD

[XML_Imp_Exp]
DSIRecordDFD

DSIRecordDFD

(Optional) Enter the name of a DFD file.

[ XML_Imp_Exp]

DSIRecordDFD =

Parameter | Description
value | (Optional) Enter the name of a DFD file. The system tries to match variable fields sent in the request to field values in this DFD file. It the attaches the DFD record to the end of the message.

Remarks

The system tries to match variable fields sent in the request to field values in this DFD file. It the attaches the DFD record to the end of the message.

Example

< XML_IMP_EXP >

DSIRecordDFD =

Available

Release | 10.1
Patch | 380


DSIReqType

[XML_Imp_Exp]
DSIReqType

DSIReqType

(optional) Enter the name of the request type of the message placed in the queue. The default is GETXML.

[ XML_Imp_Exp]

DSIReqType =

Parameter | Description
value | (optional) Enter the name of the request type of the message placed in the queue. The default is GETXML.

Example

< XML_IMP_EXP >

DSIReqType =

Available

Release | 10.1
Patch | 380


DSITimeout

[XML_Imp_Exp]
DSITimeout

DSITimeout

(optional) Enter the number of milliseconds you want for the timeout. The default is 60000 milliseconds or 60 seconds.

[ XML_Imp_Exp]

DSITimeout =

Parameter | Description
value | (optional) Enter the number of milliseconds you want for the timeout. The default is 60000 milliseconds or 60 seconds.

Example

< XML_IMP_EXP >

DSITimeout =

Available

Release | 10.1
Patch | 380


DSIUseNTUserID

[XML_Imp_Exp]
DSIUseNTUserID

DSIUseNTUserID

(optional) Set this option to Yes to use the NT user ID. The default is No.

[ XML_Imp_Exp]

DSIUseNTUserID = No

Parameter | Description
boolean (No) | (optional) Set this option to Yes to use the NT user ID. The default is No. This gives you a way to pass the NT user ID in the queue instead of the normal DMWS ID. Default value is: No

Remarks

This gives you a way to pass the NT user ID in the queue instead of the normal DMWS ID.

Example

< XML_IMP_EXP >

DSIUseNTUserID =

Available

Release | 10.1
Patch | 380


DSIVARS

[XML_Imp_Exp]
DSIVARS

DSIVARS

(optional) Enter variable;value, where variable is the variable name and value is its value.

[ XML_Imp_Exp]

DSIVARS = YN

Parameter | Description
boolean | (optional) Enter variable;value, where variable is the variable name and value is its value. This lets you identify a constant list of variables to be sent in the queue.

Remarks

This lets you identify a constant list of variables to be sent in the queue.

Example

< XML_IMP_EXP >

DSIVARS =

Available

Release | 10.1
Patch | 380


Ext

[XML_Imp_Exp]
Ext

Ext

1163 WORKING WITH XML FILES

[ XML_Imp_Exp]

Ext =

Parameter | Description
value | You can now import and export XML files while using Documaker Workstation and you can send and receive XML messages.

Remarks

You can now import and export XML files while using Documaker Workstation and you can send and receive XML messages.

Setting up the new import and export capabilities is similar to setting up any import/export file format.

(optional) Enter the extension for the output files. The default is XML.

NOTE: The ability to work with XML files is included in Documaker Workstation, but must be purchased separately by Documaker Workstation users. You must also have a Docupresentment license to use the messaging features in the WXMEntryHookExtXMLLoad function because it calls Docupresentment files.

Example

< XML_IMP_EXP >

Ext = XML

Available

Release | 10.1
Patch | 380


File

[XML_Imp_Exp]
File

File

(optional) Enter a file name, such as XMLEXP. If you omit this option the system prompts the user to enter the file name.

[ XML_Imp_Exp]

File =

Parameter | Description
value | Enter a file name, such as XMLEXP. If you omit this option the system prompts the user to enter the file name.

Example

< XML_IMP_EXP >

File =

Available

Release | 10.1
Patch | 380


Path

[XML_Imp_Exp]
Path

Path

(optional) Enter the path, such as \myxmlfile. If you omit this option, the system defaults to the current directory.

[ XML_Imp_Exp]

Path =

Parameter | Description
value | (optional) Enter the path, such as \myxmlfile. If you omit this option, the system defaults to the current directory.

Example

< XML_IMP_EXP >

Path =

Available

Release | 10.1
Patch | 380


SuppressDlg

[XML_Imp_Exp]
SuppressDlg

SuppressDlg

(optional) Enter Yes to suppress the File Selection window. The default is No.

[ XML_Imp_Exp]

SuppressDlg = No

Parameter | Description
Boolean | (optional) Enter Yes to suppress the File Selection window. The default is No. Default value is: No

Example

< XML_IMP_EXP >

SuppressDlg =

Available

Release | 10.1
Patch | 380


XMLTags2GVM

XMLTags2GVM Options

  • GVM


GVM

[XMLTags2GVM]
GVM
         Previous Topic

GVM

Where GVM is the name of the GVM variable and XMLTag is the tag name in the XML file.

[ XMLTags2GVM]

GVM =

Parameter | Description
value | Where GVM is the name of the GVM variable and XMLTag is the tag name in the XML file. Include Req or Opt to specify whether it is required or optional.

Remarks

Include Req or Opt to specify whether it is required or optional.

If it is required and is not present in the XML file, processing will terminate.

Example

< XMLTags2GVM >

GVM = XMLTag, (Req/Opt)

Available

Release | _______
Patch |