Preface

The following topics contain additional information about this guide and other important links:

Documentation Topics

  • Utility Reference Overview
  • Using the Help
  • Document Conventions
  • Documentation Accessibility
  • Related Documents
  • Send Feedback About This Guide

Oracle Links

  • Oracle Insurance
  • Oracle Support

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


Utility Reference Overview

This guide contains information about the various utilities you can use. It describes each utility, discusses the parameters you can set, and provides examples.

To find a utility:

  • Available Utilities by its description.
  • Use the table of contents (TOC) . The table of contents (TOC) includes folders listed alphabetically by letter. Each utility is listed alphabetically in each folder. Click a folder in the TOC to open it and display its list of utilities.
  • Use the Index .

This guide also contains information about the The IStream Migration Utility which creates migration-ready files based on their content.

Notes

  • Run these utilities from a command line prompt, such as from a DOS box under Windows.
  • These utilities are located in the directory where your Documaker executable files are installed. For example, under Windows you will typically find these utilities in your \fap\dll directory.
  • You can enter the name of the utility with the Help parameter (/?) to display all of the parameters and defaults. No processing occurs when you include the Help parameter. Here is an example:

UTILITYNAME /?

  • You can identify the parameters using dashes (-) or slashes (/). For instance,

UTILITYNAME /?

is the same as

UTILITYNAME -?

  • Omit spaces between a parameter and its value.
  • All utilities are listed in the TOC in alphabetical order.


Available Utilities

Use the table below to find the utility you want more information about.

This table includes the following columns:

  • To – A description of the task you want to accomplish.

  • Works with – The applications that the utility works with.

  • GUI available? – Indicates if you can perform this task using one of the graphical user interface (GUI) tools, like Studio or Documaker Workstation.

  • Platforms – The platforms that the utility works under.

  • Use – The name of the utility that accomplishes the task. Click the name for more information about the utility.

To… | Works with | GUI available? | Platforms | Use
Add missing header information for Xerox fonts | Docuview | no | Windows | ATPHDR
Analyze IStream model documents and create migration-ready files | IStream, Studio, Documaker | yes | Windows | The IStream Migration Utility
Back up an archive file | Documaker Workstation | no | Windows | ARCSPLIT
Check a font cross-reference (FXR) file for settings which would cause problems when generating PDF files | Studio, Documaker | no | Windows | FXRVALID
Check the integrity of a CAR file | Documaker | no | Windows | CARINTEG
Compare two font cross-reference (FXR) files | Studio, Documaker | no | Windows | FXRCMP
Compile FAP files into AFP overlays | Studio, Documaker | Studio | Windows, z/OS | FAP2OVL
Compile FAP files into AFP print files | Documaker | Studio | Windows, UNIX, z/OS | FAP2AFP
Compile FAP files into overlay files | Studio, Documaker | Studio | Windows | OVLCOMP
Compile FAP files into Xerox Metacode FRM files | Studio, Documaker | Studio | Windows | FAP2FRM
Compile FAP files into Xerox Metacode print files | Studio, Documaker | Studio | Windows, z/OS | FAP2MET
Convert a BDF file into a pre-version 11.x format FORM.DAT file | Studio | no | Windows | BDF2FDT
Convert a database into another database | Studio | no | Windows | DB2DB
Convert a FAP file into a compiled FAP (CFA) file | Studio, Documaker | no | Windows | FAP2CFA
Convert a FORMDEF and SETRCPTB pair into BDF, GRP, and FOR files | Studio | no | Windows | CVTFASR
Convert a non-VSAM NAFILE and POLFILE dataset into a VSAM dataset | Documaker | no | z/OS | SEQ2KSDS
Convert AFP fonts into PCL fonts | Studio, Documaker | Studio | Windows | AFP2PCL
Convert AFP overlays into FAP files | Studio, Documaker | no | Windows | OVL2FAP
Convert AFP page segments into LOG files | Studio, Documaker | Studio | Windows | PSEG2LOG
Convert AFP print files into variable block format | Docuview LFS | no | Windows | AFP2VB
Convert all of the FAP files listed in a FORM.DAT file into a compiled FAP files | Studio, Documaker | no | Windows | FDT2CFA
Convert CompuSet files into FAP files | Studio, Documaker | Studio | Windows | CSET2FAP
Convert DCD files into a FAP files | Documerge, Studio, Documaker | Studio | Windows | DCD2FAP
Convert Documerge VRF files into Documaker Workstation-style import files, export files, or INI files | Documerge, Documaker Workstation, Documaker | no | Windows, z/OS | VRF2EXP
Convert DOS archive files into Windows archive files | Studio, Documaker | no | Windows | ARCCNV
Convert embedded graphics into referenced graphics | Studio, Documaker | Studio | Windows | FXLOGREF
Convert FAP files into HTML files | IDS | no | Windows | FAP2HTML
Convert FAP files into PDF files | Studio, Documaker | no | Windows | FAP2PDF
Convert FAP files into RTF files | Studio | Studio | Windows | FAP2RTF
Convert FAP files into XML files | iPPS | no | Windows | FAP2XML
Convert file names into lowercase file names | na | no | UNIX | up2low
Convert files written in variable block record format into AFP files | Documerge, Documaker | no | Windows | VB2AFP
Convert files written in variable block record format into BARR format files | Documerge, Documaker | no | Windows | VB2BARR
Convert FOR files into XML files | Studio | Studio | Windows | FOR2XML
Convert FORM.DAT files into database files | Studio, Documaker | no | Windows | FDT2DB
Convert FORM.DAT files into EDL files | Documerge, Documaker | no | Windows | FDT2EDL
Convert a FORM.DAT file into an HTML page | IDS | no | Windows | FD2HTW32
Convert FormMaker II PCL overlays into FAP files | Studio, Documaker | Studio | Windows | PCL2FAP
Convert LOG files into a Xerox image files | Documaker | Studio | Windows | LOG2IMG
Convert LOG files into AFP page segments | Documaker | Studio | Windows, z/OS | LOG2PSEG
Convert LOG files into DOS entry LOB graphic files | na | no | Windows | LOG2LOB
Convert LOG files into JPEG files | Studio, IDS | Studio | Windows | LOG2JPG
Convert LOG files into TIFF files | Studio | Studio | Windows | LOG2TIF
Convert LOG files into Xerox fonts | Studio, Documaker | Studio | Windows | LOG2XFNT
Convert Metacode and AFP files that use Documerge record formatting into MVS record-oriented files | Documerge, Documaker | no | z/OS | MRG2MVS
Convert Metacode files in BARR format into EPS (Enterprise Printing System) format | Documaker | no | Windows | BARR2EPS
Convert multicolor graphics into JPG files and monocolor graphics into TIFF files for use as VIPP printer resources | Documaker | no | Windows | LOG2VIPP
Convert PCL fonts into AFP fonts | Studio, Documaker | Studio | Windows | PCL2FAP
Convert PCL fonts into Xerox Metacode fonts | Documaker | Studio | Windows | PCL2XFNT
Convert PNG (Portable Network Graphic) files into LOG files | Studio, Documaker, IDS | Studio | Windows | PNG2LOG
Convert PostScript fonts into PCL fonts | Studio, Documaker | Studio | Windows | PS2PCL
Convert print streams from cut-sheet to continuous-form | Documaker | no | Windows, z/OS | AFPCOPY
Convert RTF files into FAP or FOR files | Studio, IStream Migration Utility | Studio | Windows | RTF2FAP
Convert text file from one code page to another | Documaker | no | Windows, z/OS * | CPCNV
Convert the records of a VSAM KSDS into a sequential file | Documaker | no | z/OS | KSDS2SEQ
Convert TrueType fonts into PCL fonts | Studio, Documaker | Studio | Windows | TT2PCL
Convert uploaded AFP files into z/OS compatible files | Documaker | no | z/OS | AFP2MVS
Convert uploaded BARR formatted Metacode output into a z/OS-compatible file | Documaker | no | z/OS | BARR2MVS
Convert WIP data into a database format | Documaker, Documaker Workstation | no | Windows | WIP2WIP
Convert Xerox fonts into PCL bitmap fonts | Studio, Documaker | Studio | Windows | XFNT2PCL
Convert Xerox FRM files into FAP files | Studio, Documaker | Studio | Windows | FRM2FAP
Convert Xerox Metacode files in variable block (VB) format into EPS (Enterprise Printing System) format | Documerge/Docuflex, Documaker | no | Windows | VB2EPS
Convert Xerox Metacode files into FAP files | Studio, Documaker | Studio | Windows | MET2FAP
Convert Xerox Metacode fonts into TrueType fonts | Studio, Documaker | no | Windows | META2TTF
Convert Xerox Metacode resources into downloadable BARR or PCO files | Documaker | no | Windows, z/OS | XERDNLD
Copy from an existing WIP database index into a new index while using the latest WIP layout | Documaker | no | Windows | WIPUPDATE
Create a formatted dump of a Xerox FRM file | Documaker | no | Windows | FRMDUMP
Create a formatted dump of an AFP file | Documaker | no | Windows | AFPDUMP
Create a library file from a response file | Studio, Documaker | Studio | Windows | LBRYMGR
Create a PDF file for each section in a FORM.DAT file | IDS | no | Windows | PTFMDW32
Create a response file | Studio, Documaker | no | Windows | LBRYMGR
Create AFP coded font files | Documaker | no | Windows | AFPCF
Create AFP form definition resource objects | Documaker | no | Windows, z/OS | AFPFMDEF
Create DDL files from your DFD files | Documaker | no | Windows | DFD2DDL
Create DDT files from FAP files | Documaker | no | Windows | FAP2DDT
Create NA and POL files from a Documaker archive and call plug-ins to process the transactions in these files | Documaker, Documaker Workstation | no | Windows | ARCSPLIT
Create the ERRFILE.DAT and LOGFILE.DAT files from the MSGFILE.DAT file | Documaker | no | Windows, z/OS | TRANSLAT
Create the installation file and the version file for iDocumaker | iDocumaker | no | Windows, UNIX | VERSUPD
Debug (and execute) DAL scripts | Studio, Documaker | Studio | Windows | DALRUN
Determine the AFP resources used by an AFP print stream | Documaker | no | Windows, z/OS | AFPRESRC
Determine the resources used by a Metacode print stream | Documaker | no | Windows, z/OS | METRESRC
Encrypting passwords | iDocumaker | no | Windows | CRYRUN
Encrypting and decrypting data (for IDS) | iDocumaker | no | Java-based | DataCrypt
Fix field offsets | Documaker | no | Windows, z/OS | FIXOFFS
Generate the encrypted passwords used in the security control group for PDF files. | Documaker | no | Windows, z/OS | PDFKEY
Get the iDocumaker installation file from the IDS and then update iDocumaker | iDocumaker | no | Windows | UPDWDT
Get the local version information and updates the registry for iDocumaker | iDocumaker | no | Windows | VERS2REG
List the fonts used in specified FAP files | Studio, Documaker | Studio | Windows | FONTLIST
List the resources found in a print stream or those not located in the library | Documerge, Documaker | no | Windows | MRGCHK
Maintain FAP files | Studio, Documaker | Studio | Windows | FIXFORM
Maintain FXR files | Studio, Documaker | Studio | Windows | FIXFXR
Optimize AFP print streams | Documaker | no | Windows, UNIX, z/OS | AFPOPT
Optimize Metacode print streams before they are sent to the printer | Documaker | no | Windows, z/OS | METOPT
Prepare AFP resources to be uploaded | Documaker | no | Windows | ADDCRLF
Process library scripts | Studio, Documaker | Studio | Windows, UNIX, z/OS | LBYPROC
Reformat z/OS-generated Metacode output for submission to a BARR system | Documaker | no | Windows, z/OS | BARRWRAP
Read a text file which contains a series of requests and submit those requests to IDS | IDS | no | Windows | FILE2IDS
Reindex dBase files | Documaker | no | Windows | REINDEX
Remove embedded graphics from FAP files | Studio, Documaker | Studio | Windows | FXLOGREF
Rename CAR files | Documaker | no | Windows | CARREN
Rename FAP files | Studio, Documaker | Studio | Windows | RENFORM
Repair archive files | Documaker, Documaker Workstation | no | Windows | ARCFIX
Reset locked user IDs | Studio, Documaker Workstation | yes | Windows | OPENUSER
Reset PostScript printers | Documaker | no | Windows | PSRESET
Restore an archive backed up or split with ARCSPLIT | Documaker, Documaker Workstation | no | Windows | ARCMERGE
Retrieve archive records to produce files to send to plug-in functions | Documaker, Documaker Workstation | no | Windows | ARCRET
Run the FD2HTW32 and PTFMDW32 utilities from a graphical interface | IDS | yes | Windows | FORMPUB
See patch level information for Docupresentment’s Java .jar files. | IDS | no | Windows | PatchReporter
See version and patch level information for Documaker or Docupresentment | Studio, IDS, Documaker | Studio, Documaker Workstation | Windows, UNIX, z/OS | FSIVER
Split an archive file | Documaker, Documaker Workstation | no | Windows | ARCSPLIT
Synchronize a library | Studio, Documaker | no | Windows | LBYSYNC
Test the transfer of files to and from IDS | IDS | no | Windows | DSITEST
Use a MRGCHK list to add missing fonts to a font cross-reference (FXR) file | Documaker | no | Windows | MRGADD
View a Documanage archive file | Documanage, Documaker | yes | Windows | ARCVIEW

* Can be ported to other platforms.


ADDCRLF

Use the ADDCRLF utility to prepare AFP resource files created in a Windows environment for uploading to z/OS systems. This utility adds carriage return/line feeds (CR/LF) to the files. The CR/LFs serve as record delimiters.

Note Some AFP resources, such as AFPBAT1 output from the GenPrint program, can have carriage return/line feeds (x’0D0A’) embedded in them. On these resources, the ADDCRLF utility will fail, giving you a message stating the data has embedded carriage return/line feeds (CR/LFs). If this happens, do the file transfer with no CR/LF, and then use the AFP2MVS utility on the z/OS system.

Program names

  • Windows: ADDCRLFW.EXE

Syntax

ADDCRLFW /I /F

Parameter | Description
/I | The AFP file name with the extension TMP, which you can omit.
/F | Add this parameter to force the output file to be built, ignoring any embedded CR/LF errors.

For the input file, the utility looks for the default extension TMP. For the output file, the utility will assign the extension IBM.

PSF software on the z/OS is record-oriented software. It needs each structured field record in an AFP resource such as font, formdef, overlay, page segment, and so on, in discrete records.

PSF2 on a Windows system has no concept of records. The entire datastream is a single record. If you use the system in a Windows environment to create AFP resources, and you want to transfer them to z/OS, you must insert CR/LFs at the end of each structured field and then use the CR/LF keyword on the file upload command.

Example

ADDCRLF /I=afpfile

This creates a file called AFPFILE.IBM. The input file must have the extension TMP. You do not have to enter the extension if you enter the command as shown above. The output file will have the same file name, but with the IBM extension.


AFP2MVS

Use the AFP2MVS utility to record-orient an AFP file that has been transferred to z/OS (MVS, OS/390) from a Windows or UNIX-based system.

When an AFP file such as a print stream, font, or a page segment is uploaded from Windows or UNIX to a z/OS system, the resulting AFP file is not oriented into separate records — instead it looks like one continuous record. For the AFP file to be properly processed on z/OS, it must be oriented into separate records.

Because of the structure of AFP records, these records can be separated fairly easily. Each AFP record usually begins with a 0x5A byte. In the EBCDIC character set, this value (code point) is displayed as an exclamation point (!). Following the 0x5A byte is the length of the record. The AFP2MVS utility reads through the AFP file, separates the file into records and writes the resulting record-oriented file out as an output file. If you were then to browse the file, the 0x5A records (first byte displayed as an exclamation point) would display one per row.

Program names

  • z/OS: AFP2MVS

Syntax

AFP2MVS /I /L

Parameter | Description
/I | If the input file is a Partitioned Data Set (PDS), use this parameter to specify the member within the PDS to process. To process all members, enter /I=*. If the input file is a sequential file, omit this parameter.
/L | Include this parameter to tell the utility that the dataset is a Mixed Mode dataset. Unlike regular AFP files, Mixed Mode AFP files typically contain records of line data — not AFP records.

Keep in mind...

  • Sample JCL for this utility is located in member AFP2MVSX in the JCLLIB PDS that is created when Documaker Server is installed on z/OS.
  • In Documaker Server version 11.0 and earlier, the DD names RSCOS2 and RSCMVS were used to designate the input and output files. The preferred DD names are now INPUT and OUTPUT.
  • When you transfer AFP files from Windows or UNIX to z/OS, be sure to transfer the files in binary mode, not text mode.
  • The dataset you create on z/OS to contain the AFP files you upload should have DCB characteristics similar to the dataset the AFP2MVS utility will write to. For example, for a sequential file you could specify DCB characteristics as shown here:
Data Set Name  . . . . : FSI.V112.RPEX1.GENPRINT.PRTBAT1.FROMPC

General Data                      Current Allocation
 Management class .  : **None**     Allocated cylinders : 1
Storage class .  . .  : STANDARD    Allocated extents . : 1
 Volume serial   . .  : DCI009
 Device type. . . .  :3390
Data class  . . . .  : **None**    Current Utilization
 Organization    . .  : PS          Used cylinders  . . : 0
 Record format . . .  : VBM          Used extents  . . . : 0
 Record length  . .  :8209
 Block size   . . . .  :23500
 1st extent cylinders: 1
 Secondary cylinders : 1
 Data set name type :              SMS Compressible.: NO

Examples

  • AFP2MVS Example 1
  • AFP2MVS Example 2


AFP2MVS Example 1

This example demonstrates running the AFP2MVS utility on a print stream:

In this example, the AFP2MVS utility reads the print stream associated with the INPUT DD statement (FSI.V112.RPEX1.GENPRINT.PRTBAT1.FROMPC), separates the print stream into records, then writes the new print stream to the file associated with the OUTPUT DD statement (FSI.V112.RPEX1.GENPRINT.PRTBAT1).

Since the file associated with the INPUT DD statement is a Sequential Data Set and not a Partitioned Data Set (PDS), the /I parameter is not necessary.

//AFP2MVSD EXEC PGM=IEFBR14

//OUTPUT DD DSN=FSI.V112.RPEX1.GENPRINT.PRTBAT1,

// DISP=(MOD,DELETE),SPACE=(TRK,0),UNIT=SYSDA

//*

//AFP2MVS EXEC PGM=AFP2MVS

//STEPLIB DD DSN=FSI.V112..LINKLIB,DISP=SHR

// DD DSN=SYS1.SCEERUN,DISP=SHR

//SYSPRINT DD SYSOUT=*

//INPUT DD DSN=FSI.V112.RPEX1.GENPRINT.PRTBAT1.FROMPC,DISP=SHR

//OUTPUT DD DSN=FSI.V112.RPEX1.GENPRINT.PRTBAT1,

// UNIT=SYSDA,SPACE=(CYL,(1,1)),DISP=(,CATLG),

// DCB=(RECFM=VBM,LRECL=8209,BLKSIZE=23500)


AFP2MVS Example 2

This example demonstrates running the AFP2MVS utility on a PDS that contains several fonts:

In this example, the AFP2MVS utility reads each member of the PDS that is associated with the INPUT DD statement (FSI.V112.RPEX1.FONTLIB.FROMPC). Each member is then separated into records and the resulting record-oriented member is written to the PDS associated with the OUTPUT DD statement (FSI.V112.RPEX1.FONTLIB).

Since the file associated with the INPUT DD statement is a PDS, the /I parameter is included to indicate which members to process. In this case, you specify /I=* to indicate that all members are to be processed.

Note

In the EXEC statement's PARM parameter, the first forward slash (/) is used to separate any Language Environment (LE) runtime options from the program's command line options. If you need to specify any LE runtime options, place those options before the first forward slash. Any options placed after the first forward slash are considered options for the program being executed.

Documaker-related programs typically use the forward slash (/) or dash (-) as the initial character of a command line parameter, so the number of forward slashes on the command line will total one more than the number of parameters you specified.

//AFP2MVSD EXEC PGM=IEFBR14

//OUTPUT DD DSN=FSI.V112.RPEX1.FONTLIB,

// DISP=(MOD,DELETE),SPACE=(TRK,0),UNIT=SYSDA

//*

//AFP2MVS EXEC PGM=AFP2MVS,PARM='/ /I=*'

//STEPLIB DD DSN=FSI.V112.LINKLIB,DISP=SHR

// DD DSN=SYS1.SCEERUN,DISP=SHR

//SYSPRINT DD SYSOUT=*

//INPUT DD DSN=FSI.V112.RPEX1.FONTLIB.FROMPC,DISP=SHR

//OUTPUT DD DSN=FSI.V112.RPEX1.FONTLIB,

// UNIT=SYSDA,SPACE=(CYL,(1,1,1)),DISP=(,CATLG),

// DSNTYPE=LIBRARY,

// DCB=(RECFM=VBM,LRECL=8209,BLKSIZE=23500)


AFP2PCL

Use the AFP2PCL utility to convert an AFP bitmap font into a corresponding PCL bitmap font. See the subtopics for more information on AFP fonts and standard font naming conventions.

Note You can perform this task using the Convert Bitmap Files to Graphic Files option in Studio’s Conversion wizard.

Program names

  • Windows: AFP2PCLW.EXE

Syntax

AFP2PCLW /I /S /D /O

Parameter | Description
/I | The AFP file name, such as FILENAME.FNT (AFP coded font file), the extension is optional and will defaulted to FNT.
/S | The source dots per inch (DPI), either 240 or 300 (the AFP font DPI setting default is 300).
/D | The destination dots per inch, either 240 or 300 (the PCL font DPI setting default is 300).
/O | The output file, such as FILENAME.PCL (a PCL font file) If you omit the output name, the output PCL file name will be the same as the input file name, except for the PCL extension.

The utility creates a PCL character set file using code page 1004. You must include the /I parameter.


AFP2PCL Example

An example of using the AFP2PCL utility is

AFP2PCL /I=x0facob9

This will convert an AFP coded font file, x0facob9.fnt, into a PCL font file named x0facob9.pcl.

The AFP2PCL utility requires these files:

  • AFP coded font file (system coded font files are named X0DAxxxx.fnt)
  • AFP character set file (system character set files are named C0FAxxxx.240/300)
  • AFP code page file (the system’s standard code page is T1DOC037). The code page file cannot have an extension.

In addition, AFP2PCL uses the FSISYS.INI and CODEPAGE.INI files. AFP2PCL looks for the FMRES control group in the FSISYS.INI file. In the FMRES control group, AFP2PCL looks for DefLib and CodePage options. Set the DefLib option to the directory where your system resources are stored.

Set the CodePage option to the name of the INI file which contains code page information. The system looks for the CODEPAGE.INI file in the DefLib path specified in the FMRES control group. In this example,

< FMRes >

CodePage = CODEPAGE.INI

DefLib = \fap\mstrres\fmres\deflib\

The name of the INI file containing code page information is CODEPAGE.INI and will be located in the \fap\mstrres\fmres\deflib\directory directory.


AFP Terminology

An AFP font is composed of these component files: coded font, code page and character set files. The coded font file contains the names of character set and code page files to use when printing.

Note You can use the AFPDUMP utility to find out the names of character set and code page files contained in a coded font file.

The code page maps text to the characters in a character set file. Each character, like a capital ‘A’, has a particular name and a particular numeric value known as a code point. The character capital ‘A’ has an AFP name of LA020000. On a PC, a capital ‘A’ usually has a code point of 65. However, on a mainframe, a capital ‘A’ usually has a code point of 193.

For both the PC and the mainframe to print the letter ‘A’, a different code page may be used. The code page used to print text from the PC would associate a code point of 65 with the letter ‘A’ (LA020000). The code page used to print text from the mainframe would associate a code point of 193 with the letter ‘A’ (LA020000). The code page is merely a list of the character names and their associated code points.

The character set file contains the characters which can be printed. Like PCL fonts, each character set file can only represent a single font typeface, style, and point size. A character set file also specifies the list of AFP character names, like LA020000, it can print.

So, when you try to print the letter ‘A’ (code point 65 on a PC) using an AFP coded font file, the system examines the coded font file to determine the names of the code page and character set files. It then looks up code point 65 in the code page file to find the AFP character name associated with it. If the code page is set up for PC printing, it finds the character named LA020000 associated with code point 65. The character set file is then used to print the bitmap information associated with the character name LA020000. An AFP character name, like LA020000, must be present in both the AFP code page and character set files.


Font Naming Convention

When using the AFP2PCL utility, the system’s AFP coded font files are named X0DAxxxx.FNT, where X0 indicates a coded font file, D symbolizes Documaker, and A denotes the AFP font. The first two XXs indicate the font type family. The next X indicates style. The last X indicates the font point size.

AFP character set files are named C0FAxxxx.240 or C0FAxxxx.300. The C0 indicates a character set file. The extensions 240 and 300 indicates the dots per inch or DPI setting. The rest of the naming convention is the same as previously discussed.


AFP2VB

Use this utility if you have a printable (native) AFP file and you want to view it to use it with Docuview LFS. This utility converts the file into variable block format.

Program names

  • Windows: AFP2VB.EXE

Syntax

AFP2VB /I /O /D

Parameter | Description
/I | The name of the native AFP file.
/O | The name of the output AFP file which will have variable block record format.
/D | (Optional) This parameter tells the utility to add Docusave comments.


AFPCF

Use the AFPCF utility to create coded font files for AFP printers.

Program names

  • Windows: AFPCFW32.EXE

Syntax

AFPCFW32 /C /T /X

Parameter | Description
/C | The AFP character set file name.
/T | The AFP code page file name.
/X | The AFP codefont file to create (.FNT).

Example

You would enter:

AFPCFW32 /c=C0FATIN0 /t=T1DOC037 /x=X0DATIN0

In this example, AFPCF creates an AFP coded font file called X0DATIN0.FNT.

To print using this coded font, all of these files must be resident on the printer. On z/OS, it should be placed in a PDS which is available to the PSF procedure. On a Novell print server, it is must be installed into the coded font group within PSF2.

To use this coded font for printing with Documaker Server, enter the name of the coded font file (without the FNT extension) into the Coded Font File field under AFP Properties on the Font Properties tab in Studio’s Font manager.


AFPCOPY

Use the AFPCOPY utility to convert a print stream from cut-sheet to continuous-form. The utility does this by taking an AFP print stream which contains multiple BEGINDOC and ENDDOC statements and generating a print stream with only one BEGINDOC and one ENDDOC statement.

Program names

  • Windows: AFPCOPY.EXE
  • z/OS: AFPCOPY

Syntax

AFPCOPY /I /O

Parameter | Description
/I | (Optional) The input file name (with page breaks).
/O | (Optional) The output file name.

The input AFP print stream is read from the INFILE DD statement and the output AFP print stream is written to the OUTFILE DD statement. Look in member AFPCOPYX of JCLLIB to find an example of this utility.

On z/OS systems, use DD:INFILE as the input file in the JCL. Use DD:OUTFILE as the output file in the JCL. Use VBM,8205,8209 on the SysUT2 DD statement.

Example

Here is an example

AFPCOPY /infile /outfile


AFPDUMP

Use the AFPDUMP utility to create a text file from a print-ready AFP file. This utility produces a formatted dump of an AFP output file.

Program names

  • Windows: AFPDPW32.EXE

Syntax

AFPDPW32 /I /H

Parameter | Description
/I | The file name of the AFP file to dump. Include the extension. The output is named filename.dds
/H | (Optional) Include this parameter to tell the utility to also dump the HEX values.

The AFPDUMP utility reads a print-ready AFP file and creates a text file which contains English explanations of the AFP printer commands. If you include the /H option, the utility lists the hexadecimal characters for each AFP command before the its English explanation.

In addition to reading a print-ready AFP file, the AFPDUMP utility can also read AFP overlays (page segments) and AFP font files (coded font, code page, and character set files).

You can use the AFPDUMP utility to check:

  • Which fonts are being used in an AFP print ready or overlay.
  • If text is correctly output in an AFP print ready or overlay.
  • Which code page and character set files are used by a coded font file.
  • What characters and code points are defined in an AFP code page file.
  • If the characters named in the code page file match those in the character set file.

Example

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


AFPDUMP Example

Here is an example of AFPDUMP:

AFPDUMP /I=filename.pds /H

This example converts the filename.pds file into the filename.dds file which you can read using any text editor.

Note If the file to be converted does not have a PDS extension, you must include the extension when you enter the command. It the file has no extension, add a period (.) after the file name.

Here is an example AFPDUMP output file (filename.dds) with the /H option:

....5A 0010 D3A8A8 00 0000

000,Begin,Document,16

....4040404040404040

,

.... 5A 0010 D3ABCC 00 0001

001, Map,Medium Map,16

.... D7D3E4D640404040

,PLUO

.... 5A 0010 D3A8AF 00 0002

002, Begin,Page,16

.... 4040404040404040

,

.... 5A 0010 D3A8C9 00 0003

003, Begin,Active Env. Group,16

.... 4040404040404040

,

.... 5A 0017 D3A6AF 00 0004

004, Descriptor,Page,23

.... 0000096009600007F8000A50000000

,unit base 0 0,L-Units 2400 2400,Page Size x=2040 y=2640

.... 5A 0019 D3A69B 00 0005

005, Descriptor,Composed Text,25

.... 00000960096007F80A5000000000000000

.... 5A 0010 D3A9C9 00 0006

006, End,Active Env. Group,16

.... 4040404040404040

,

.... 5A 0010 D3A89B 00 0007

007, Begin,Composed Text,16

.... 4040404040404040

.... 5A 0012 D3EE9B 00 0008

008, Data,Composed Text,18

.... 2BD306F700002D0002F8

Set Text Orientation,6,0000,2D00

NOP,2,

.... 5A 0010 D3A99B 00 0009

009, End,Composed Text,16

.... 4040404040404040

.... 5A 0010 D3A89B 00 000A

010, Begin,Composed Text,16

.... 4040404040404040

.... 5A 0012 D3EE9B 00 000B

011, Data,Composed Text,18

.... 2BD306F700002D0002F8

Set Text Orientation,6,0000,2D00

NOP,2,

.... 5A 0010 D3A99B 00 000C

012, End,Composed Text,16

.... 4040404040404040

.... 5A 0010 D3A89B 00 000D

013, Begin,Composed Text,16

.... 4040404040404040

.... 5A 000C D3EE9B 00 000E

014, Data,Composed Text,12

.... 2BD302F8

NOP,2,

.... 5A 0010 D3A99B 00 000F

015, End,Composed Text,16

.... 4040404040404040

.... 5A 0010 D3A89B 00 0010

016, Begin,Composed Text,16

.... 4040404040404040

.... 5A 000C D3EE9B 00 0011

017, Data,Composed Text,12

.... 2BD302F8

NOP,2,

.... 5A 0010 D3A99B 00 0012

018, End,Composed Text,16

.... 4040404040404040

.... 5A 0010 D3A8BB 00 0013

019, Begin,Graphic,16

.... 4040404040404040

,

.... 5A 0010 D3A8C7 00 0014

020, Begin,Obj. Env. Group,16

.... 4040404040404040

,

.... 5A 001C D3A66B 00 0015

021, Descriptor,Object Area,28

.... 034301084B000009600960094C020007B1000A60

,Unit Base 0 0,L-Units 2400 2400,Object Area Size x=1969 y=2656

.... 5A 0020 D3AC6B 00 0016

022, Position,Object Area,32

.... 011800000000000000002D000000000000000000002D0000

,Object Area Origin 0 0, Object Area Orientation (0, 90), Object Content Origin 0 0

,Use the current coordinate system

.... 5A 000D D3ABBB 00 0017

023, Map,Graphic,13

.... 0005030420

,Scale-to-fit

.... 5A 0020 D3A6BB 00 0018

024, Descriptor,Graphic,32

.... F6160000000009600960000080007FFF80007FFF00000000

,No absolute picture units ,Unit base 0 ,Window Coordinates xLeft=-32768 xRight=32767 yBottom=-32768 yTop=32767

.... 5A 0010 D3A9C7 00 0019

025, End,Obj. Env. Group,16

.... 4040404040404040

,

.... 5A 0056 D3EEBB 00 001A

026, Data,Graphic,86

.... 700C1010101000000040000000000A0168C00A011807C10C1000100030003000500

07000600022083000300000000000C706000000000100C51400000000150040003000000

04500400060000000

Begin Segment Introducer, 12

Set Color, 01

Begin Area, c0

Set Color, 01

Set Line Type, 07

Line, Point (4096 4096), Point (12288 12288), Point (20480 28672),

End Area, 00

Set Arc Parameters, Point (12288 12288), Point (0 0),

Full Arc, Point (0 0), Scale 1.000000

Fillet, Point (0 0), Point (5376 16384), Point (12288 0), Point (17664 16384), Point (24576 0),

.... 5A 0010 D3A9BB 00 001B

027, End,Graphic,16

.... 4040404040404040

,

.... 5A 0010 D3A89B 00 001C

028, Begin,Composed Text,16

.... 4040404040404040

.... 5A 000C D3EE9B 00 001D

029, Data,Composed Text,12

.... 2BD302F8

NOP,2,

.... 5A 0010 D3A99B 00 001E

030, End,Composed Text,16

.... 4040404040404040

.... 5A 0010 D3A9AF 00 001F

031, End,Page,16

.... 4040404040404040

,

....5A 0010 D3A9A8 00 0020

032,End,Document,16

....4040404040404040


AFPFMDEF

Use the AFPFMDEF utility to create an AFP form definition resource file from a DAT file (see the example below).

Program names

  • Windows: AFPFMDEW.EXE
  • z/OS: See the Documaker Installation Guide.

Syntax

AFPFMDEW /I

Parameter | Description
/I | The data file's first two characters must be F1.

The AFP form definition resource file defines certain print attributes, such as paper size, orientation, and duplex settings. This utility takes a text file with a DAT extension and compiles it into an AFP form definition resource file which is installed on the AFP printer.

Example

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


AFPFMDEF Example

Here is an example of AFPFMDEF:

AFPFMDEW /I=f1fsi.dat

The output file will have the same name as the data file, with an FDF extension.

Here is an example of a form definition DAT file:

******************************************************************

*

* FIELD LAYOUT

*

*;Medium Map Name;Medium Map Id;X Origin;Y Origin;Paper Size;Orientation;Copies;

*

* Stacking;Tray;Flash;Duplex;Print Quality;

*

* Medium Map Name => up to 8 character long use A-Z 0-9 $ # @

*

* Medium Map Id => 1 to 127

*

* X Origin => 0 to 32767

*

* Y Origin => 0 to 32767

*

* Paper Size => L Letter (default)

* E Executive

* G Legal

* A A4

*

* Orientation => O1 - Portrait

* O2 - Landscape

* O3 - Portrait 90

* O4 - Landscape 90

*

* Copies => 1 to 255

*

* Stacking => Yes or No

*

* Tray => T1 - Source Drawer #1

* T2 - Source Drawer #2

* T3 - Source Drawer #3

* T4 - Manual Feed

* T5 - Envelopes

*

* Flash => Yes or No

*

* Duplex => Simplex, Duplex, or Tumble duplex

*

* Print Quality => Default, Lowest, or Highest

*

*------------------------------------------------

* Medium Map Name convention

*------------------------------------------------

* Position Values Description

* ======== ====== ===========

* 0 Orientation

* L Landscape

* P Portrait (default)

* 1 Papersize

* E Executive

* G Legal

* A A4

* L Letter (default)

* 2 Tray selection

* M Manual

* F Envelope feeder

* L Lower

* U Upper (default)

* 3 Duplex

* L Long binding

* S Short binding

* O Simplex

* ? Unknown (default)

*

*

******************************************************************

;B1;1;0;0;L;O1;1;Y;T1;Y;S;L;

*----Landscape [Paper Size] Upper Simplex

;LLUO;60;0;0;L;O2;255;Y;T1;Y;S;D;

A standard form definition file called F1FMMST is included with the system. It contains medium maps of all possible combinations of orientations, paper sizes, duplex mode and so on.

This form definition file should be resident on the printer. On z/OS, place it in a PDS which is available to the PSF procedure. On a Novell print server, define it as a device option in the printer profile in PSF2.


AFPOPT

Use this utility to optimize an AFP print stream. The AFPOPT utility reads an AFP print stream produced by Documaker and outputs a smaller, optimized AFP print stream. During the optimization process, the utility removes:

  • Some unnecessary AFP records by combining text blocks together
  • Font selection commands from consecutive text records that use the same font
  • Text orientation commands from consecutive text records that use the same text orientation
  • Baseline positioning commands from consecutive text records that use the same baseline
  • Variable space increment commands from consecutive text blocks that use the same variable space increment

Program names

  • Windows: AFPOPTW
  • UNIX/Linux: AFPOPT
  • z/OS: AFPOPT

Syntax

AFPOPT /I /O

Parameter | Description
/I | Enter the input AFP file name. You can omit the extension.
/O | Enter the name you want the utility to assign to the optimized AFP file. You can omit the extension

Keep in mind...

  • This utility only supports native AFP record format. It does not support Documerge record format (MRG2 or MRG4).
  • This utility is specifically designed to optimize Documaker-produced AFP print streams. This means it removes certain AFP commands (Abs. Move Baseline, and Set Var-Space Char Inc) which could result in an invalid AFP print stream if you run it on a non-Documaker produced AFP print stream.

Example

Here is an example:

afpoptw /i=original.afp /o=optimized.afp

AFPOPT - AFP Optimize Program

Reading original.afp...

opt.afp optimized as follows:

AFP Record count reduced by 12% (27 -> 24)

Font Selections reduced by 94% (228 -> 14)

Text Orientations reduced by 100% (229 -> 2)

Abs Move Baseline reduced by 85% (252 -> 40)

Set Var Space Incr reduced by 100% (228 -> 1)


AFPRESRC

Use this utility to determine the AFP resources used by an AFP print stream. You can also use this utility to combine an original AFP print stream along with its required AFP resources into a new AFP print stream.

The types of AFP resource files supported by this utility are:

  • AFP formdef files
  • AFP font (coded font, character set, code page) files
  • AFP overlay files
  • AFP page segment files

Program names

  • Windows: AFPRESRC.EXE
  • z/OS: AFPRESRC

Syntax

AFPRESRC /I /O /F /L /RESDIR

Note If you are running on z/OS, see AFPRESRC z/OS Considerations regarding these parameters.
Parameter | Description
/I | Enter the name of the input AFP print file.
/O | (Optional) Enter the name you want assigned to the output AFP print file which includes the added resource files.
/F | (Optional) Enter the name of the Formdef file you want to add to the output file.
/L | (Optional) Enter the name of the listing file that contains the names of resource files which will be used.
/RESDIR | (Optional) Enter the name of the directory that contains the AFP resource files. The default is the directory of the input AFP print file.

Be sure to produce a listing file before you create a new AFP print stream. This will help you determine what AFP resource files you will need to have available.

The lines of the listing file will be in the following comma-delimited format:

FileName,AFP,Type

Element | Description
FileName | This is the name of the resource file.
AFP | This indicates the file is an AFP resource.
Type | This tells you what type of AFP resource it is, such as FDF, OVL, PSG, CFF, CSF, or CPF.

Notes

  • You must specify either the /O or /L parameter. You can specify both.
  • If you run AFPRESRC without any parameters or with incorrect parameters, it displays syntax information about how to run it.

AFP Resource Files

If the AFP print stream contains AFP overlays or AFP coded font references, the AFPRESRC utility opens these files to look for the other resource files used by these files. Here is a list of the types of AFP resource files the utility supports and the file extensions it uses when it searches for these files.

AFP resources | Type | File extensions searched
AFP formdef | FDF | “.fdf”, “.”
AFP overlay | OVL | “.ovl”, “.oly”, “.”
AFP page segment | PSG | “.psg”, “.seg”, “.”
AFP coded font | CFF | “.”, “.fnt” “.cff”
AFP character set | CSF | “.”, “.240”, “.300”, “.fnt”, “.csf”
AFP code page | CPF | “.”, “.fnt”, “.cpf”

The utility looks for the AFP resource files in the directory you specify in the RESDIR parameter. If you omit the RESDIR parameter, the utility looks for the AFP resource files in the directory in which the input AFP print stream is located.

Here are a couple of examples:

Scenario 1

Assume you want to identify the AFP resource files are used by an AFP print stream, perhaps because you want to convert the AFP print stream into a FAP file. Assume you have an AFP print stream named scenario1.afp. To produce a list of the AFP resources used in scenario1.afp, use this command:

AFPRESRC /I=scenario1.afp /L=list.txt

This command produces a text file named list.txt. This text file contains a list of the AFP resource files used by the AFP print stream, scenario1.afp. The text file would look similar to this one:

Q1ADDR,AFP,OVL

Q1B302,AFP,OVL

Q1BA32,AFP,OVL

Q1BA36,AFP,OVL

Q1BILL,AFP,OVL

Q1DLOG,AFP,PSG

QCBUL,AFP,PSG

QJANED,AFP,PSG

QJOHND,AFP,PSG

X0DACON0,AFP,CFF

X0DACON6,AFP,CFF

X0DACON8,AFP,CFF

X0DACONB,AFP,CFF

X0DATIBF,AFP,CFF

C0FACON0,AFP,CSF

C0FACON6,AFP,CSF

C0FACON8,AFP,CSF

C0FACONB,AFP,CSF

C0FATIBF,AFP,CSF

T1DOC037,AFP,CPF

Scenario 2

Assume you want to take the AFP print stream mentioned in Scenario 1 and print it on an AFP printer that does not have the necessary AFP resource files. To produce an AFP print stream that contains the original AFP print stream (scenario1.afp) plus all of the AFP resources used in scenario1.afp, you would use this command:

AFPRESRC /I=scenario1.afp /L=list.txt /O=NewFile.afp /RESDIR=c:\AFPFiles

This command produces an AFP print stream named NewFile.afp. This print stream contains the original AFP print stream (scenario1.afp) plus all of the AFP resources used in scenario1.afp. For this scenario, the AFP resource files must be in the c:\AFPFiles directory, as specified in the /RESDIR parameter.

This scenario also produces a text file called list.txt which contains a list of the AFP resources files used by the AFP print stream, scenario1.afp. You could have omitted the /L parameter if do not want a listing of the AFP resource files.

Note The command used in scenario 2 does not include the /F file parameter, so no formdef file is embedded in the new AFP print stream (NewFile.afp). As a result, you would need to specify a formdef file when you print the AFP print stream.

Sample JCL for printing the AFP OUTPUT FILE

Here is an example of the JCL you could use to print the AFP print stream using a formdef file named F1FMMST.

//OUT1 OUTPUT FORMDEF=FMMST,

// USERLIB=(FSI.V114.RPEX1.FDEFLIB)

//*

//PRINT EXEC PGM=IEBGENER

//SYSPRINT DD SYSOUT=*

//SYSUT1 DD DSN=FSI.AFP.PRINT,DISP=SHR

//SYSUT2 DD SYSOUT=2,OUTPUT=*.OUT1

//SYSIN DD DUMMY

If you use the /F parameter to specify a formdef file to be embedded in the new AFP print stream, you can simplify the first two lines of the JCL as shown here:

//OUT1 OUTPUT

//*

//PRINT EXEC PGM=IEBGENER

//SYSPRINT DD SYSOUT=*

//SYSUT1 DD DSN= FSI.AFP.PRINT,DISP=SHR

//SYSUT2 DD SYSOUT=2,OUTPUT=*.OUT1

//SYSIN DD DUMMY

Run-time messages

The AFPRESRC utility displays information as it runs. For example, when producing a listing file as described in Scenario 1, the AFPRESRC utility would display this information:

C:\>afpresrc /i=scenario1.met /l=list.txt

--- AFPRESRC Copyright (C) 1997, 2009 Oracle. All rights reserved.

Informational in AFPRESRC: Creating listing file: list.txt

Informational in AFPRESRC: Finished Successfully

If the AFPRESRC utility cannot find references to AFP resource files in an AFP print stream, it usually means you omitted the /RESDIR parameter which tells the utility where to find the AFP resource files. If this occurs, you see messages similar to these:

C:\>afpresrc /i=Example1.met /l=list.txt

--- AFPRESRC Copyright (C) 1997, 2009 Oracle. All rights reserved.

Informational in AFPRESRC: Creating listing file: list.txt

Informational in AFPRESRC: Cannot find overlay Q1ADDR. in ;

Informational in AFPRESRC: Cannot find coded font X0DACON0.cff in ;

If you were producing a new AFP print stream containing AFP resource files as described in Scenario 2, you could see many more messages for missing page segments and AFP font files. The AFPRESRC utility displays information about each AFP resource file that is being embedded into the new AFP print stream. In this case, the messages from AFPRESRC could look something like this:

C:\>afpresrc /i=Example1.met /l=list.txt /resdir=fonts

--- AFPRESRC Copyright (C) 1997, 2009 Oracle. All rights reserved.

Informational in AFPRESRC: Creating listing file: list.txt

Informational in AFPRESRC: Cannot find character set file C2N20000 in ;

Informational in AFPRESRC: Cannot find character set file C4T05500 in ;

Informational in AFPRESRC: Cannot find code page file T1GI0395 in ;

Informational in AFPRESRC: Cannot find code page file T1V10500 in ;

*********************************

* UTLDefErrorExit

* ..\C\afpresrc.c

Sep 18 2008 16:01:03

400.114.000

AFPRESRC <0> <0> ERROR --> 4 font files could not be downloaded

*********************************

Informational in AFPRESRC: Finished with Errors

In this example, there were two AFP character set files (C2N20000 and C4T05500) and two AFP code page files (T1GI0395 and T1V10500) that were not found in the directory specified by the /RESDIR parameter.

Error messages

Here are some error messages you can see when producing a new AFP output file such as described in Scenario 2:

*********************************

AFPRESRC <0> <0> ERROR --> Example1.afp is a corrupt file or not an AFP file

*********************************

This error tells you the AFPRESRC utility does not recognize the input AFP print stream as a valid AFP file.

*********************************

AFPRESRC <0> <0> ERROR --> Unable to recognize record 1

*********************************

This error tells you the AFPRESRC utility does not recognize the AFP record format of the input AFP print stream. The AFPRESRC utility supports AFP print files written using native record format and Documerge variable block format.

*********************************

AFPRESRC <0> <0> ERROR --> Cannot open output file NewFile.afp

*********************************

This error tells you the output file cannot be created. One possibility is that the output file already exists as a read-only file. On a mainframe, the output file needs to be deleted in the JCL used to run AFPRESRC.

*********************************

AFPRESRC <0> <0> ERROR --> Error trying to write ##### bytes

*********************************

or

*********************************

AFPRESRC <0> <0> ERROR --> Cannot write to output file NewFile.afp

*********************************

This error could mean that you ran out of disk space while producing the new AFP print file. On a mainframe, this error might tell you that you did not allocate enough space for the new AFP file or the logical record length (LRECL) is not big enough. You can also tell that the DD:OUTFILE ran out of space because of the B37 abend message in the JES job log. Any kind of x37 message, such as B37, D37, or E37, indicates an out-of-space condition.

Using the trace file

Because there can be a large number of AFP resource files used in an AFP print stream, these messages are written to a trace file in addition to being displayed on the console. The trace file is overwritten each time you run the AFPRESRC utility. If you want to keep the results from a run, you must rename the trace file so that is not overwritten.


AFPRESRC z/OS Considerations

When running on z/OS, the input (/I), output (/O), formdef (/F), and listing (/L) file parameters must specify a DD: name that is defined in your JCL.

DD:FDEFLIB() | The name of the PDS that contains the AFP formdef files
DD:FONTLIB() | The name of the PDS that contains the AFP font files
DD:OVERLIB() | The name of the PDS that contains the AFP overlay files
DD:PSEGLIB() | The name of the PDS that contains the AFP page segment files
DD:INFILE | The name of the AFP input file
DD:OUTFILE | The name of the AFP output file
DD:FORMDEF | The name of the AFP formdef file
DD:TRACE | The name of the trace file

Assume you want to read an AFP print stream and produce a new AFP print stream that contains the required AFP font resources. For this example, assume you have this environment on the mainframe:

FSI.V114.RPEX1.GENPRINT.AFPBAT1 | The AFP print stream
FSI.ORACLE.AFP240.FONTLIB | The PDS for AFP fonts
FSI.V114.RPEX1.PSEGLIB | The PDS for AFP page segments
FSI.V114.RPEX1.OVERLIB | The PDS for AFP overlays
FSI.V114.RPEX1.AFPRESC1.TRACE | The trace file you want to produce
FSI.V114.RPEX1.AFPRESC1.LIST | The listing file you want to produce
FSI.V114.FDEFLIB(F1FMMST) | The AFP formdef to add
FSI.V114.RPEX1.GENPRINT.AFPBAT1.NEW | The new print stream to produce

See JCL for AFPRESRC of the JCL for this utility to produce the new AFP print stream that contains AFP fonts ready for printing

Note z/OS does not allow file names that begin with a number (0-9). If the name of an AFP resource file begins with a number, you will not be able to upload that files to z/OS. Therefore, you will not be able to run AFPRESRC on z/OS for this environment. Instead, you must run AFPRESRC on a Windows or UNIX platform and upload the final print stream to z/OS for printing.


JCL for AFPRESRC

The JCL for the AFPRESRC utility to produce the new AFP print stream that contains AFP fonts ready for printing might look like this:

//USERIDA  JOB   (33005),'DAP -         ',CLASS=T,MSGCLASS=X,
//         NOTIFY=USERID
//*
//         SET HLQ='FSI.V114'    <== SET HIGH LEVEL QUALIFIER
//         SET RES='RPEX1'       <== SET RESOURCE (E.G. RPEX1, UTEX1)
//*
//         JCLLIB  ORDER=&HLQ..PROCLIB
//*
//****************************************************************
//*  PROGRAM : AFPRESRC
//*  PURPOSE : TO DETERMINE THE AFP RESOURCES USED BY AN AFP
//*            PRINT STREAM.
//*
//*  PARMS   : /I=   NAME OF AFP PRINT FILE (REQUIRED)
//*            /O=   NAME OF AFP PRINT FILE TO CREATE WITH
//*                  RESOURCES FILES ADDED
//*            /L=   NAME OF LISTING FILE CONTAINING NAMES OF RESOURCE
//*                  FILES USED (/O OR /L PARAMETERS ARE REQUIRED)
//*                  (BOTH /O AND /L CAN BE USED)
//*            /F=   NAME OF AFP FORMDEF FILE TO ADD TO OUTPUT FILE
//*
//****************************************************************
//*
//AFPRESCD EXEC PGM=IEFBR14
//LIST     DD DSN=&HLQ..&RES..AFPRESC1.LIST,
//            UNIT=SYSDA,SPACE=(TRK,0),
//            DISP=(MOD,DELETE,DELETE)
//TRACE    DD DSN=&HLQ..&RES..AFPRESC1.TRACE,
//            UNIT=SYSDA,SPACE=(TRK,0),
//            DISP=(MOD,DELETE,DELETE)
//OUTFILE  DD DSN=&HLQ..&RES..GENPRINT.AFPBAT1.NEW,
//            UNIT=SYSDA,SPACE=(TRK,0),
//            DISP=(MOD,DELETE,DELETE)
//*
//AFPRESC1 EXEC PGM=AFPRESRC,
//        PARM='/ /I=DD:INFILE /L=DD:LIST /O=DD:OUTFILE /F=DD:FORMDEF'
//STEPLIB  DD DSN=&HLQ..LINKLIB,DISP=SHR
//         DD DSN=SYS1.SCEERUN,DISP=SHR
//*
//INFILE   DD DSN=&HLQ..&RES..GENPRINT.AFPBAT1,DISP=SHR
//OUTFILE  DD DSN=&HLQ..&RES..GENPRINT.AFPBAT1.NEW,
//            DISP=(,CATLG),
//            LIKE=&HLQ..&RES..GENPRINT.AFPBAT1
//LIST     DD DSN=&HLQ..&RES..AFPRESC1.LIST,
//            UNIT=SYSDA,SPACE=(TRK,(1,1)),DISP=(,CATLG),
//            DCB=(RECFM=FB,LRECL=80,BLKSIZE=3120)
//FORMDEF  DD DSN=&HLQ..FDEFLIB(F1FMMST),DISP=SHR
//TRACE    DD DSN=&HLQ..&RES..AFPRESC1.TRACE,
//            UNIT=SYSDA,SPACE=(TRK,(1,1)),DISP=(,CATLG),
//            DCB=(RECFM=VB,LRECL=1024,BLKSIZE=23040)
//FONTLIB  DD DSN=&HLQ..&RES..FONTLIB,DISP=SHR
//PSEGLIB  DD DSN=&HLQ..&RES..PSEGLIB,DISP=SHR
//OVERLIB  DD DSN=&HLQ..&RES..OVERLIB,DISP=SHR
//*FDEFLIB  DD DSN=&HLQ..FDEFLIB,DISP=SHR       <=UNCOMMENT AS NEEDED
//SYSPRINT DD SYSOUT=*

If you have to create a Partitioned Data Set (PDS) for AFP fonts, overlays, page segments, or formdef files, you can use the settings shown here as a guide:

Data Set Name . . . . : FSI.ORACLE.AFP240.FONTLIB

 General Data                        Current Allocation
 Management class . . : **None**       Allocated cylinders : 59
 Storage class  . . . : STANDARD       Allocated extents . : 1
  Volume serial . . . : DCI030         Maximum dir. blocks : 65
  Device type . . . . : 3390
 Data class . . . . . : **None**
  Organization  . . . : PO            Current Utilization
  Record format . . . : VBM            Used cylinders  . . : 56
  Record length . . . : 12284          Used extents  . . . : 1
  Block size  . . . . : 27998          Used dir. blocks  . : 61
  1st extent cylinders: 59             Number of members . : 1,261
Secondary cylinders : 5
  Data set name type  : PDS

  Creation date . . . : 2003/10/08     Referenced date . . : 2008/09/23
  Expiration date . . : ***None***


ARCCNV

Use the ARCCNV utility to convert old DOS archive files into the newer FAP file format.

Program names

  • Windows: ARCCVW32.EXE

Syntax

ARCCVW32 /O /N /F /I /R

Parameter | Description
/O | The old archive directory, where the old archive files are stored.
/N | The new archive directory, where the new archive files will be stored.
/F | The forms directory, where the corresponding FAP files are stored.
/I | (Optional) The file name for a single file conversion.
/R | (Optional) The file name restart point.

Convert all forms and then run this utility. The Windows archive subdirectory must be empty when you start the utility, otherwise you may lose data.

Example

Here is an example:

ARCCVW32 /O=\PPS\RESLIB\SAMPCO\ARC /N=\PPSWIN\MSTRRES\SAMPCO\ARC /F=PPSWIN\MSTRRES\SAMPCO\FORMS

After the conversion is complete, you must copy the APPIDX.DFD file to the new archive subdirectory. These conversion steps are necessary for every company library in the DOS PPS system.

Errors

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


ARCCNV Error messages

Select a topic below for an explanation of possible error messages you may receive:

  • NA load image failure on ‘IMAGENAME’ at offset OFFSET
  • Cannot load file ‘FILENAME.DAT’
  • Checking ARCHIVE.CAR file for possible corrupted data files


NA load image failure on ‘IMAGENAME’ at offset OFFSET

This message generally appears if:

  • The FAP file for ‘IMAGENAME’ is missing
  • You entered an incorrect forms subdirectory on the command line

To correct this error:

  1. Remove all files from WINDOWS archive subdirectory.
  2. Correct command line parameters or find the FAP file for IMAGENAME.
  3. Start the ARCCNVW utility again.


Cannot load file ‘FILENAME.DAT’

This message generally appears if the data file is corrupted in DOS PPS archive. To correct this error, do the following:

  1. Remove all files from the Windows archive subdirectory.
  2. Edit the FILENAME.DAT file using text editor and correct the corrupted data.
  3. Rearchive the FILENAME.DAT file using the DOS command line utility, REPLARC. Here is the syntax for the REPLARC utility:

REPLARC.EXE <CARFILENAME> <FILENAME.DAT>

For example:

REPLARC.EXE ARCHIVE.CAR B225F307.DAT

  4. Then, restart the archive conversion. If the problem reappears, see the next topic.


Checking ARCHIVE.CAR file for possible corrupted data files

Run the DOS utility RESTARC.EXE and redirect the output into a file. For example...

RESTARC.EXE ARCHIVE.CAR /V > FILE.BAT

Edit the FILE.BAT file using a text editor. The file will look similar to this one:

DOS Archive Restore Program

Usage

restarc <archive file name> [/Verbose]

Example

restarc archive.car

File B1DA85BC.POL is OK

File B1DA85BC.DAT is OK

File B1DA872F.POL is OK

File B1DA872F.DAT is OK

File B1DC356D.POL is OK

File B1DC356D.DAT is OK

File B1E1289C.POL is OK

File B1E1289C.DAT is OK

Done

You have to create a batch file using this file. The batch file should look like this:

RETRIEVE.EXE ARCHIVE.CAR B1DA85BC.POL

RETRIEVE.EXE ARCHIVE.CAR B1DA85BC.DAT

RETRIEVE.EXE ARCHIVE.CAR B1DA872F.POL

RETRIEVE.EXE ARCHIVE.CAR B1DA872F.DAT

RETRIEVE.EXE ARCHIVE.CAR B1DC356D.POL

RETRIEVE.EXE ARCHIVE.CAR B1DC356D.DAT

RETRIEVE.EXE ARCHIVE.CAR B1E1289C.POL

RETRIEVE.EXE ARCHIVE.CAR B1E1289C.DAT

RETRIEVE.EXE ARCHIVE.CAR B1EA6DB4.POL

RETRIEVE.EXE ARCHIVE.CAR B1EA6DB4.DAT

Where the file names at the end of each line are the same names as those in the original FILE.BAT file. Run the batch file to unzip all DAT and POL files from the ARCHIVE.CAR file. Then, enter the following command:

GREP -l -v [\ -~] *.DAT

Note You must enter a space after the backslash (\)

This command displays a list of files which contain non-ASCII characters. These are files you must fix. See Cannot load file ‘FILENAME.DAT’ for information on what to do next.

After you fix all files, run the ARCCNV utility.


ARCFIX

Use the ARCFIX utility to evaluate and, if necessary, attempt to repair archive files.

Important

  • The ARCFIX utility should only be used by those who understand archive well because of the risk of data loss.
  • Make sure you back up your archive files before you run this utility.

Program names

  • Windows: ARCFXW32.EXE

Syntax

ARCFXW32 /I /A /F

Parameter | Description
/I | Enter the name of the CAR file.
/A | (Optional) Include this parameter to repair all files.
/F | (Optional) Include this parameter to fix the table of offsets.

Please note that:

  • Index files must be in current directory.
  • You must have the following files in the working directory:
    • APPIDX.DFD
    • ???.CAR (for example. ARCHIVE.CAR)

The ARCFIX utility first checks to see that each record in the CAR file has a corresponding APPIDX record and then deletes any extra APPIDX records.

If you use the /F parameter, the ARCFIX utility rebuilds the table of offsets at the end of the CAR file.


ARCMERGE

Use this utility to combine two archives that have the same DFD files for the archive index, catalog, and CAR file. This utility can take a secondary archive and merge it into the main archive.

Note This utility only works with xBase files. It does not work on Oracle, SQL, or DB2 databases.

Program names

Windows: ARCMW32.EXE

Syntax

ARCMW32 I /INI

Parameter | Description
/I | If the secondary archive is a database, enter the name of the index (APPIDX) file. If the secondary archive is a file, enter the name and path of the file. You can omit the remaining parameters.
/INI | Enter the name of the INI file you want the utility to reference.

Run this utility from your master archive environment. The ARCMERGE utility uses the FSIUSER.INI and FSISYS.INI files, along with your resources. You can include these additional INI options in the FSIUSER.INI file to specify the names of the split archive files/tables.

< ArcRet >

MergeLog =

Option | Description
MergeLog | The name of the log file. The default is ARCMERGE.LOG. The utility creates this file in the Data directory.

ARCMERGE Example

See Also

  • ARCSPLIT


ARCMERGE Example

Assume that D:\rel11\MSTRRES\ARCB is the secondary archive, to be merged into the main archive. This is the command you would use if the secondary archive is stored in files rather than in a database:

ARCMW32 /I=d:\rel11\mstrres\arcb

If the archive is in a database archive, you would enter this command:

ARCMW32 /I=arcb/appidxs /A=arcb/archives /C=arcb/catalogs

Here is an example of the ARCMERGE.LOG file:

--- ArcMerge ---

Rows copied from <archives> to<archive>, Day Mon DD HH:MM:SS YYYY

C: Original ArcKey: New ArcKey

.

.

End of copy, Day Mon DD HH:MM:SS YYYY

Rows copied from<catalogs> to<Catalog>, Day Mon DD HH:MM:SS YYYY

C:Catalog ID

.

.

End of copy, Day Mon DD HH:MM:SS YYYY

Rows copied from<catalogs> to<Catalog>, Day Mon DD HH:MM:SS YYYY

C:FIELD1,FIELD2,FIELD3,original ARCKEY:updated ARCKEY

.

.

End of copy, Day Mon DD HH:MM:SS YYYY


ARCRET

Use this utility to retrieve records from your archives and produce files that can then be sent to plug-in functions to generate additional output. You can choose from these plug-in functions:

Plug-in | Description
PLGGenPrint | Produces a batch file the GenPrint program can use to produce printed form set output. Use it to reprint your archives.
PLGGenArc | Produces a batch file the GenArc program can use to archive transactions to a different archive. Use it to help migrate your archive to another archiving method.
PLGTest | Used to test the retrieval results from the archive. This function does nothing with the output of the ARCRET utility.

For example, you can use the PLGGenPrint plug-in function to take output from the ARCRET utility, produce a batch file, and then run the GenPrint program to produce printed form sets.

You can also use the PLGGenArc plug-in to migrate traditional LAN flat file archives to host or server based SQL database format archives, or as a part of an upgrade or conversion to a Documanage repository.

Transaction sets are passed to the plug-in functions you define in the INI file for additional processing. If no plug-in functions are defined, nothing happens to the retrieved records. All temporary files created during the run are deleted when the utility stops.

Before starting any migration, you should...

  • Back up your archives.
  • Read all of the documentation concerning this utility.
  • Run some tests and verify the results. Testing should help you:
    • Determine if archiving and retrieving from the new system is working properly.
    • Decide the optimal size of the batch sets.
    • Estimate how long the entire process will take.

After you verify the test results, change all systems that do archiving and retrieval to use the new system. Do not use the old system while you are migrating from it.

Note After you complete the migration, keep your original archives just in case. Only after you are satisfied that the new system is working properly and that all of your data has been migrated, should you consider dropping the old archive and old archive system.

Program names

  • Windows: ARCRET.EXE

ARCRET Syntax

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


ARCRET Syntax

The syntax for the ARCRET utility is:

ARCRET /INI /R /N /S /P /BEF /OR /AFT /DAL /NC /DB /K /REV /LOAD
/RUNDATE

Parameter

Description

/INI

Specifies the INI file to use. If you omit this option, the utility uses the FSIUSER.INI file as the default.

/R

Defines the sequential row or record number to begin processing. The default is one.

/N

Tells the utility to stop after retrieving this number of sequential rows or records. The default is to retrieve all rows.

/S

Sets the number of records to include in a set or batch. The default is one transaction per set.

/P

Tells the utility to pause between sets.The default is off.

/BEF

Selects rows/records with a RUNDATE before this date (YYYYMMDD). The date you specify is not included in the set.

/AFT

Selects rows/records with a RUNDATE after this date (YYYYMMDD). The date you specify is not included in the set.

/OR

Changes the date comparison to mean before or after as opposed to the default before and after.

/DAL

Specifies a script file the utility should run to determine if a row/record is included in a set.

/NC

Tells the utility not to compile the DAL script. DAL scripts are compiled by default to improve performance.

/DB

Dumps debug information as the script runs. When you include this parameter, use a small set (/S) size.

/K

Keeps all intermediate files by renaming them instead of deleting them. Using this option can leave numerous files that you will have to remove manually.

/REV

Tells the utility to process the archives in reverse order. The last record is read first and the first record is read last. This only applies to xBase databases.

/LOAD

This parameter lets you filter archive records by examining the fields in the loaded form set using a DAL script. You can update the ARCRET record members passed to DAL as the script executes.

The /LOAD parameter names a script the system will execute after the form set is retrieved from archive and loaded. DAL had the ability to query form set field values as well as other form set members. Any changes the script makes to the loaded document are temporary, as the actual archived document cannot be changed. However, the script can change ARCRET member values, which represent the archive index record used to identify the document.

By allowing DAL to update the ARCRET record members, the script can change the current record values that will be written to the output files generated by ARCRET. This may later influence any plug-in functions called via ARCRET.

/RUNDATE

Lets the user to specify a field to use instead of RUNDATE. The format of the field you designate should be YYYYMMDD.

/DATEFMT

Identifies the date format used within the RUNDATE field. If you omit this parameter, the utility assumes the RUNDATE field is stored in the typical YYYYMMDD format.

The DATEFMT must be specified using a standard internal FAP date format. Additionally you can use the format X to indicate that the RUNDATE field is stored using the Hex Time format.

If a PPS user has an archive that doesn’t specify a RUNDATE field but instead uses the WIP CreateTime as the date field, it is usually stored in a Hex Time format. To do a retrieval from this archive, you would specify a command line with these parameters:

ARCRET /RUNDATE=CreateTime /DATEFMT=X

The /RUNDATE parameter is an existing parameter that identifies an alternative field to use as the RUNDATE. The /DATEFMT parameter indicates how to interpret the date information in the specified RUNDATE field.


ARCRET INI files

By default, the ARCRET utility loads the FSIUSER.INI and the INI file defined by this option in the FSIUSER.INI file:

< Environment >

FSISYSINI =

To specify a different INI file, use the INI parameter as shown here:

ARCRET /INI=My.INI


Defining the Plug-in Functions

Define the plug-in functions in the ArcRet control group as shown here:

< ArcRet >

PlugInMod = NAME.DLL

PlugInFunc = Function

PlugInFunc = Function2

PlugInFunc = Function3

PlugInFunc = Function4

PlugInFunc = Function5

The PlugInMod option defines the DLL file that contains the functions you want to use. The PlugInFunc option defines the function name of a plug-in compatible function.

You can define up to five plug-in functions which will be executed in the order they are defined in the INI file. If no functions are defined, the utility displays this message:

Warning: No plug-ins loaded.

Note The ARCRET utility will continue to run even if no plug-in functions are defined.

Plug-in functions must conform to a specific prototype and will be passed specific information about the files to process.

You can also use the DLL->FunctionName method for naming plug-ins. This lets you keep plug-ins in multiple DLL files. Here is an example:

PlugInFunc = DLL->FunctionName

If the option does not contain the “->” to indicate a DLL name is specified, the system assumes it should use the PlugInMod option to locate the DLL for this function.


Archive Index Field Map

The ARCRET utility is designed to find all the relevant information about your archive setup under the ArcRet control group. In general, the INI options required by the ARCRET utility are almost identical to those used by the GenArc program.

With a few exceptions, the settings referenced are the almost the same as those used and required by the AFEMAIN program. One exception is the Trigger2Archive control group.

The ARCRET utility uses this Trigger2Archive control group to re-create the NEWTRN file. If you use the GenArc program to produce your archives, you already have this group to map the fields from the NEWTRN file to the APPIDX (application index) file.

Since the AFEMAIN program does not use this control group, you may have to add it to your INI file. Here is an example of what you would need to add:

< Trigger2Archive >

ArcField = TrnField

ArcField2 = TrnField2

...

Each Trn field is defined in the TRNDFDFL.DFD file which is specified using the TrnDFDFile option in the Data control group. Each Arc field is defined in the APPIDX.DFD file which is specified using the AppIdxDFD option in the ArcRet control group.

If you do not have the Trigger2Archive control group defined, the ARCRET utility tries to match the fields in the TRNDFDFL.DFD and APPIDX.DFD files by name. If no field names match, an error message appears and the ARCRET utility stops.


Skipping Rows or Records

By default, the ARCRET utility selects each archive index record in sequence. Since you may not always want this, several parameters are included so you can designate which rows/records you want to process.

Keep in mind that the ARCRET utility presumes every index record is a potential candidate for selection.

The first record in the first index file is read and checked against the selection criteria (unless you included the /REV parameter). The next record is then read and so on until all the records in the index have been examined. Each record is either accepted or rejected based on the parameters you specify.

You can use the /R parameter to skip a specific number of sequential transactions.

You can also use the /N parameter to indicate a maximum number of accepted transactions you want to process. By default, the ARCRET utility continues until the last index row/record is processed.

You use the /R and /N parameters to control where and when to stop processing. The /REV parameter lets you specify whether the utility should start at the beginning or the end of the file. These parameters can be useful when you have a large number of rows/records that will take a long time to process.

For example, suppose you can only process 1000 transactions a day with the plug-in you want to use and you have 3000 transactions in your archive. Potentially, that means it would take three days to process these transactions using your plug-in.

Assuming you are not using any other parameters, you would enter these commands:

Day 1: ARCRET /N=1000

Day 2: ARCRET /N=1000 /R=1001

Day 3: ARCRET /R=2001

Notice, that the first day, you did not have to specify the /R command, but you did specify to stop after processing 1000 transactions. The second and third days, you did specify how many leading transactions to skip. Note that on the final day, the /N parameter was omitted. If you know the remaining set of records will not exceed your maximum, you can omit this parameter.


Controlling the Number of Transactions Sent to Plug-ins

Each time a set of matching transactions are located and retrieved, the ARCRET utility calls the plug-in functions to process those transactions. By default the ARCRET utility searches until a single matching transaction is found, retrieves the associated form set, and then calls the plug-ins. Therefore, the default set size is one transaction.

For some plug-in functions, a larger set size will improve performance—especially if the plug-in has excessive startup or shutdown time requirements. Use the /S parameter to designate the number of rows/records to include in a set before the ARCRET utility calls the plug-in functions.

Note If there are not enough matching transactions found in the index file, the plug-ins are called with however many matching transactions were found. If you create a plug-in, keep in mind the plug-in should make no assumptions about the number of transactions in the sets.

You can also use the /P parameter with sets. This parameter tells the utility to pause as each set is processed and wait until you press Enter before building the next set. This parameter is useful if you need to examine or copy the output files produced by the plug-ins before starting the next set.


Selecting Records by Date

The ARCRET utility has several parameters that you can use to select transactions which fall within or outside a given date range. When specifying dates for these parameters, be sure to use the YYYYMMDD format.

Keep in mind that these parameters assume the RUNDATE or CREATETIME variables are the names of the transaction date fields. The utility first looks for RUNDATE. If it is not found, the utility looks for CREATETIME (the name used by standard AFEMAIN archives).

If the utility finds RUNDATE it looks for the record which should be in YYYYMMDD format. When using CREATETIME, the utility assumes the date is in the internal HEXTIME format and converts it to YYYYMMDD format, comparing it to the dates specified. If neither field is found, the ARCRET utility displays an error and stops processing.

Note For the remainder of this topic, assume that RUNDATE means either RUNDATE or CREATETIME and that the data value will be in YYYYMMDD format.

Use the /BEF parameter to tell the utility to select records with a RUNDATE value that falls before a given date. Transactions with the specified date are excluded. For instance, to select transactions archived before 2001, you would specify:

/BEF=20010101

No records after December 31, 2000 are selected.

To select transactions with a RUNDATE that falls after a given date, use the /AFT parameter. Transactions with the specified date are excluded. For instance, to select the transactions archived in 2001, specify:

/AFT=20001231

All records after December 31. 2000 are selected.

You can also use these parameters together to specify a range. When you use both parameters, the utility assumes you want a logical AND comparison, so the /BEF date should fall after the /AFT date. For example, to select all records for the year 2000, you would specify these parameters:

ARCRET /AFT=19991231 /BEF=20010101

This tells the utility to select all transaction with a RUNDATE that falls within the two dates. You can also include the /OR parameter to omit records that fall within a certain range.

When you use the /BEF, /AFT, and /OR parameters, the utility excludes the transactions which fall within the dates specified. For example, to select all records except those which fall in the year 2000, you would specify these parameters:

ARCRET /BEF=20000101 /OR /AFT=20011231

Note that when you use the /OR parameter, you identify the earlier date using the /BEF parameter and the later date with the /AFT parameter.

Note Where you place the parameters in the command does not matter.

The ARCRET utility tries to validate the date ranges you specify based on the parameters you enter. If the utility detects a combination of parameters or values that do not make sense, it displays an error message and stops.


Using DAL to Select Records

You can also include a DAL script to provide the final approval or rejection of a particular transaction. Note that the ARCRET utility processes all other parameters before it executes the DAL script.

The /DAL parameter names the DAL script you want to execute on each transaction. Before calling the script, the APPIDX record variables are converted into DAL variables using the standard DAL DB naming convention.

The DAL DB nomenclature associates all the row/record variable names with a table name. The table name is typically specified in the script or is the name of the table being referenced. Because DAL does not actually open the database and because there may be more than one index file, all record members are associated with the name ARCRET.

For instance, suppose your APPIDX has these members specified in the DFD file:

< Fields >

FieldName = Key1

FieldName = Key2

FieldName = PolicyNum

FieldName = RunDate

FieldName = ArcKey

FieldName = FormsetID

These fields would be referenced using the following names in any script associated with the ARCRET utility.

ArcRet.Key1

ArcRet.Key2

ArcRet.PolicyNum

ArcRet.RunDate

ArcRet.ArcKey

ArcRet.FormsetId

Note that since DAL only supports STRING, LONG, and DECIMAL data types, some variables may be converted to the closest matching type. When in doubt, assume the data will be of the STRING type for comparison purposes.

Since DAL has no knowledge of how a field will be used, always use the FORMAT and DEFORMAT functions where appropriate in your DAL scripts. For DFD members that hold DATE values, be sure to use the appropriate DATE functions, such as DATE2DATE, to convert values to a standard format before comparing them.

For example, if you want to select all transactions where the Key2 variable contains TEXAS, you would write a DAL script similar to this one:

IF ArcRet.Key2 = “TEXAS”

RETURN(“Yes”);

END

RETURN(“NO”);

Note The return value from the script is important. If the script returns Yes, that means to include the transaction in the set. Any other return value – including omitting a return value—excludes the transaction from the set. The case of the word Yes in the returned value is not important.

If you saved this script using the name MATCH.DAL, you would enter this command:

ARCRET /DAL=MATCH.DAL

For performance reasons, the utility normally pre-compiles your DAL scripts in memory before executing them. This makes each subsequent execution of the script faster than if the script was not pre-compiled. You can, however, turn off this behavior by including the /NC parameter. Typically, you would only include this parameter for debugging purposes.

You can also use the /DB parameter to debug scripts. This parameter produces lots of output, so be sure to send the console output to a file using the <“>filename” parameter on the command line. Also, use the /S parameter to limit the run to only a few transactions. Otherwise, the amount of output will be overwhelming.


Keeping Intermediate Files

Normally, the ARCRET utility removes intermediate files after each batch set is complete and before it starts the next set. Use the /K parameter to keep these files for each batch sets. Each set of files is renamed with an extension that matches the set (batch) count. For instance, the files from the first batch of records will be renamed as *.1; the second set of files as *.2; and so on.

Be careful using this parameter. Depending upon the size of each transaction and the number of transactions retrieved, using this parameter can consume a lot of file space. Keep in mind you must remove these files when the ARCRET utility finishes.


Batch Queuing

Normally, the ARCRET utility retrieves transactions interactively while sequentially accessing your archive index systems. In some instances, however, the underlying archive system does not support retrieving transactions while sequentially processing the records.

This is the case with Documanage. Since Documanage serves as both the archive index and storage system, it is cannot currently be accessed in the same manner as a database. Therefore, use the /BQ option to queue sequential transactions in memory before attempting to retrieve the associated files.

Queuing the transactions this way consumes more memory than would otherwise be required. In general, you can determine the index record size by examining the APPIDX.DFD file you use. Add some extra for overhead and then divide that into the maximum amount of memory that you wish to consume—over and above that used by the ARCRET utility itself. To determine this, use the Windows NT Task Manager to get an idea of how much memory is in use while you run the utility on a single transaction.

Batch queuing also affects performance because the utility has to reset the sequential index search between each set of records. For instance, suppose it reads and queues 100 transactions in a set. After the set is processed, it has to re-read sequentially from the beginning of the index back down to the 100th record to prepare for the next set. For each set of transactions, this resetting takes longer and longer, because it has to start at the beginning of the index each time.

Note Only use the /BQ parameter when the source archive system that ARCRET utility is reading does not support the interactive retrieval of documents while sequential reading the index records.


Using the PLGTest Plug-in

This plug-in prints a few messages each time it is called. Use it for testing purposes only. For instance, you would use this plug-in before using one of the other plug-ins to make sure you are successfully retrieving records and that those records match your criteria.

You can include the /P (pause) option to temporarily stop processing between batches. This lets you examine the intermediate files.

To use this plug-in, make sure you have these options in your INI file:

< ArcRet >

PlugInMod = PLGW32.DLL

PlugInFunc= PLGTest


Using the PLGGenPrint Plug-in

This plug-in accepts output from the ARCRET utility and executes the GenPrint program to produce printed output of archived transactions.

Note Before you use this plug-in, make sure you have a batch setup that can run the GenPrint program to produce the printed output you want.

To specify this plug-in, include these INI settings:

< ArcRet >

PlugInMod = PLGW32.DLL

PlugInFunc = PLGGenPrint

Note that case is important when specifying the name of the plug-in. You must specify it exactly as shown here.

The ARCRET utility produces an NA/POL file set similar to that produced by the GenData program. This includes a NewTrn file that is created from the archive index using the options in the Trigger2Archive control group. The plug-in then converts the NewTrn file into a batch (RCBDFDFL.DFD) compatible file and starts the GenPrint program to complete the process.

The conversion from the NewTrn type output of the ARCRET utility to a recipient batch file is accomplished by matching the field names between the two files. No addition INI options are necessary. The utility simply uses the TRNDFDFL.DFD file and the RCBDFDFL.DFD file (or whatever names you give these files in your INI settings) and match the fields by name. The utility automatically handles any other necessary conversions.

The plug-in produces a recipient batch record for each recipient found in the form set associated with the transaction. Because only one batch file is produced, all recipients are written to the same file.

Once the batch file is produced, the utility internally re-maps the INI options for the following items, writes a temporary INI file, and then executes the GenPrint program specifying that INI file to produce the batch output.

< Environment >

FSISYSINI =

< Print_Batches >

...

< Exclude_Batches >

...

< Data >

NAFile =

POLFile =

NewTrn =

Option | Changes
Environment control group
FSISYSINI | This option is eliminated. All of the current options from both INI files were placed in memory while executing the ARCRET utility, so the file is not necessary in the subsequent run of the GenPrint program.
Print_Batches control group
all options | All batches defined under this group are eliminated except for the first alphabetical group. The utility uses the first option as the batch to be processed. Make sure the printer settings for this batch are appropriate. The utility changes the name of the BCH file associated with this option to match the file produced by the plug-in.
Exclude_Batches control group
all options | The utility eliminates all of the options in the control group to make sure the one batch left intact is processed.
Data control group
NAFile | This option is changed to match the output from the ARCRET utility.
POLFile | This option is changed to match the output from the ARCRET utility.
NewTrn | This option is changed to match the output from the ARCRET utility.

In general, all the temporary files that are produced have the same (8-digit hexadecimal) name and a different extension. This includes the temporary INI file the utility produces for the GenPrint program.

If GenPrint errors occur, remember the output of the GenPrint program is written to the error file specified in the Data control group and is not controlled by the plug-in or the ARCRET utility.


Using the PLGGenArc Plug-in

This plug-in accepts output from the ARCRET utility and executes the GenArc program to archive your transactions to another system.

Note For this discussion, source refers to archive system where the ARCRET utility is reading transactions. Destination refers to the new archive system where the GenArc program will save transactions retrieved from the source.

Before you use this plug-in, make sure your system can successfully...

  • Retrieve transactions from your source archive system. This involves INI options in a file which this discussion refers to as the FSIOLD.INI file.
  • Add transactions to your destination archive system. This involves INI options in a file which this discussion refers to as the FSINEW.INI file.

Make sure the TriggerToArchive control group is in the (source) FSIOLD.INI file and that you map the archive index fields defined in the APPIDX.DFD file to the corresponding fields in the TRNDFDFL.DFD file. The field names between the two DFD files don't have to be the same. In the FSIOLD.INI, add these options:

< ArcRet >

PlugInMod = PLGW32.DLL

PlugInFunc = PLGGenArc

< GenArcPlugIn >

INIFile = FSINEW.INI

The options in the ArcRet control group identify the plug-in function the ARCRET utility will use. The INIFile option in the GenArcPlugIn control group identifies the INI file that should be supplied to the GenArc program by the plug-in.

Use a command similar to this one to run the ARCRET utility:

ARCRET /INI=FSIOLD.INI

This tells the ARCRET utility to use the correct INI file to retrieve from your source archive. When the plug-in is called, the batch files created by the ARCRET utility are automatically added to the INI file you named. In part, the changes will be to several options in the Data control group, such as those shown here:

< Data >

NAFile =

NewTrn =

POLFile =

The plug-in then starts a GenArc session and sends to it a temporary INI file created by combining these options. If you have successfully tested your GenArc program setup using the INI file you named, it should work without further intervention.


ARCRET Examples

These examples begin with the base FSIUSER.INI file in DMS1 and use the standard xBase and CARFile archives.

  • ArcRet control group
  • ODBC/SQL Server Changes
  • DB2 Changes
  • Documanage Changes

Only those changes required to get each archive system to work are shown.


ArcRet control group

Here is an example of the ARCRET control group:

< ArcRet >

AppIdx = ARC\AppIdx

AppIdxDfd = DefLib\AppIdx.Dfd

ARCPath = [CONFIG:Batch Processing] ARCPath =

Arrangement = Stack

CARFile = ARCHIVE

CARPath = [CONFIG:Batch Processing] CARPath =

Catalog = ARC\Catalog

ExactMatch = No

Key1 = Company

Key2 = Lob

KeyID = PolicyNum

LBLimit = 500

PlugInFunc = PLGGenArc

PlugInMod = PLGW32

TempIDX = ARC\Temp


ODBC/SQL Server Changes

Make these changes. Options not listed remain the same as those in the standard ArcRet control group from DMS1. For SQL, you must change the CARData column from the default VARCHAR to a BLOB. You must also have a special restart table DFD to change the LASTRECORD column VARCHAR length.

< DBHandler:ODBC >

CreateTable = Yes

CreateIndex = No

InstallMod = sqw32

InstallFunc = SQInstallHandler

UserID = sa

Passwd =

Server = MS SQL FSINTSRV07

< DBTable:CATALOG >

DBHandler = ODBC

UniqueTag = catalogID

< DBTable:APPIDX >

DBHandler = ODBC

< DBTable:ARCHIVE >

DBHandler = ODBC

UniqueTag = arckey

< DBTable:RESTART >

DBHandler = ODBC

< Archival >

ArchiveMem = Yes

< ArcRet >

RestartTable = Restart

CARFileDFD = carfile.dfd

RestartDFD = restart.dfd


DB2 Changes

Make these changes. Options not listed remain the same as those in the standard ArcRet control group from DMS1.

< DBHandler:DB2 >

BindFile = ..\dll\db2lib.bnd

CreateTable = Yes

CreateIndex = No

Database = ARCDBL

UserID = user

Passwd = admin

< DBTable:CATALOG >

DBHandler = DB2

< DBTable:APPIDX >

DBHandler = DB2

< DBTable:ARCHIVE >

DBHandler = DB2

< DBTable:RESTART >

DBHandler = DB2

< Archival >

ArchiveMem = Yes

< ArcRet >

RestartTable = Restart


Documanage Changes

Make these changes. Options not listed remain the same as those in the standard ArcRet control group from DMS1.

< Archival >

ArchiveMem = Yes

UseRestartTable = No

< DBHandler:PO >

Cabinet = DMS1

Domain = docucorp

Password = password

UserID = user

< DBTable:APPIDX >

DBHandler = PO

< DBTable:ARCHIVE >

DBHandler = PO

< PO:DMS1 >

FileType = DAP

FolderBy = Company,Lob,PolicyNum

NameDocBy = ARCKEY


ARCSPLIT

Use the ARCSPLIT utility to back up all or part of your archives or split archive data based on a cut-off date or on a DAL script. Use the ARCMERGE utility to combine an archive split with this utility.

Please note

  • This utility only works with xBase files. It does not work on SQL, Oracle, or DB2 databases.
  • This utility uses the current master resource library (MRL) as the base for splitting the archive. If the archive you intend to split is not part of the current MRL, you will get incorrect output.

You can use the following parameters or INI options or a combination of both to control how this utility splits archives.

Program names

  • Windows: ARCSPLIT.EXE

Syntax

ARCSPLIT /D /DAL /ED /INI /L /LOG /N /NCF /NSCF /NSIF /O /P /R /SD /SET /SRCH

Parameter | Description
/D | (Optional) Include this parameter if you want the utility to delete any existing split archive files before it creates new ones.
/DAL | (Optional) Enter the name of the DAL script you want to use. This parameter overrides the DALScript and RunDALScript INI options.
/ED | Enter the date after which to end the search, in YYYYMMDD format. This parameter overrides the SplitToDate INI option.
/INI | Enter the name of the INI file you want the utility to reference. If you are using the default INI file (FSIUSER.INI) and it is in the current directory, you do not have to specify it.
/L | (Optional) Enter the size limit for the new CAR files the utility creates. For instance, it you want to set the maximum size at 100KB, enter 1. If you want to set the limit at 1,400,000KB, enter 1400. This parameter overrides the EnableCARFileSize and CARFileSize options.
/LOG | (Optional) Enter the name of the file into which the utility should write error messages. This parameter overrides the LogFile INI option.
/N | (Optional) Enter the number of records you want to process. This parameter overrides the RecordsToProcess INI option.
/NCF | Enter the full name you want to assign to the new catalog file. The utility defaults to the current MRL path. This parameter overrides the SplitCatalog INI option.
/NSCF | Enter the full name of the newly split archive (CAR) file. The utility defaults to the current MRL path. This parameter overrides the SplitCARFile INI option.
/NSIF | Enter the full name of the newly split index (IDX) file. The utility defaults to the current MRL path. This parameter overrides the SplitAppIdx INI option.
/O | (Optional) Use this parameter to override the required date range when splitting an archive
/P | (Optional) Purge from the master archive the records which are split. If you omit this parameter, the specified records are written to the directory defined in the INI options and the master archive is not affected. This parameter overrides the PurgeRecords INI option.
/R | Enter the number or records to skip before processing occurs. The default is zero which tells the utility to start with the first record. This parameter overrides the RecordsToSkip INI option.
/SD | Enter the date on which to start the search, in YYYYMMDD format. This parameter overrides the SplitFromDate INI option.
/SET | Use to specify which configuration settings to use. You can have multiple configuration settings in the INI file. Keep in mind that command line parameters override INI settings, except/SET.
/SRCH | Enter RunDate to search the records based on the RunDate. Enter ArchivedDate to search the records based on the date on which they were archived. This parameter overrides the SearchDateBy INI option.

See Also

  • ARCMERGE


ARCSPLIT INI Options

In addition to the parameters, you can also set up INI options to use the ARCSPLIT utility. The utility looks in the INI file defined by the /INI parameter for these options. If you omit the /INI parameter, the utility looks in the FSIUSER.INI file.

These INI options are required. These options tell the ARCSPLIT utility where to find the source archive files you want to split.

< ArcRet >

AppIdx = arc\appidx.dbf

ArcPath = arc\

CARFile = archive

CARPath = arc\

Catalog = arc\catalog

The utility also looks for options that specify the names of the split archive files and provide other information. These options are located in the ArcSplit and ArcSplitConfig control groups:

< ArcSplit >

ArcSplitConfig =

DefConfig =

< ArcSplitConfig:TEST1 >

SplitDays =

RunDALScript =

DALScript =

RecordsToProcess =

RecordsToSkip =

SearchDateBy =

SplitAppIdx =

SplitCARFile =

SplitCatalog =

SplitFromDate =

SplitToDate =

PurgeRecords =

CARFileSize =

EnableCARFileSize =

AllowChanges =

LogFile =

Option

Description

ArcSplit

ArcSplitConfig

Lets you assign a name to your archive split settings. You can create as many ArcSplitConfig options as you need. Each group of settings represents a control group with individual options. Below is an example of a setting named TEST1.

DefConfig

For the ARCSPLIT utility, if you define the DefConfig option and omit the /SET parameter, the utility uses the DefConfig option to look for the ARCSPLIT configuration settings.

If you set up multiple ArcSplitConfig options for Documaker Workstation, you can use this option to designate a default.

ArcSplitConfig:TEST1

SplitDays

(Optional) This option is not used by the ARCSPLIT utility, but is used by Documaker Workstation. Enter the number of days you want the utility to add to the start date to determine the end date. The utility then splits the archive between the start and end dates.

RunDALScript

(Optional) Enter Yes if you want the utility to run the DAL script you specified with the DALScript option.

The /DAL parameter overrides this option.

DALScript

(Optional) Enter the name of the DAL script you want to run.

Use the RunDALScript option to tell the utility if it should run the DAL script you specify with this option.

The /DAL parameter overrides this option.

RecordsToProcess

(Optional) Enter the number of records to process. Use this option if you have a very large archive and you want to limit the number of records processed at one time.

The /N parameter overrides this option.

RecordsToSkip

(Optional) Enter the number of the record the utility to process first. If you omit this option, the utility starts with the first record.

The /R parameter overrides this option.

SearchDateBy

(Optional) Enter RunDate to search the records based on the RunDate. Enter ArchivedDate to search the records based on the date on which they were archived.

The /SRCH parameter overrides this option.

SplitAppIdx

(Optional) Enter a name for the newly split IDX file, such as APPIDX1.

The utility stores the data in the file you specify. If the file exists and you have set the /D parameter, the utility overwrites the file. If you have not set the /D parameter and the file exists, the utility stops.

The /NSIF parameter overrides this option.

SplitCARFile

(Optional) Enter a name for the newly split CAR file, such as ARCHIVE1.

The utility stores the data in the file you specify. If the file exists and you have set the /D parameter, the utility overwrites the file. If you have not set the /D parameter and the file exists, the utility stops.

The /NSCF parameter overrides this option.

SplitCatalog

(Optional) Enter a name for the newly split catalog file, such as CATALOG1.

The utility stores the data in the file you specify. If the file exists and you have set the /D parameter, the utility overwrites the file. If you have not set the /D parameter and the file exists, the utility stops.

The /NCF parameter overrides this option.

SplitFromDate

(Optional) Enter the date on which you want the split to begin. The default is the current date. The format is MM/DD/YYYY.

The /SD parameter overrides this option.

SplitToDate

(Optional) Enter the date on which you want the split to end. The default is the current date. The format is MM/DD/YYYY.

The /ED parameter overrides this option.

PurgeRecords

(Optional) Enter Yes if you want the utility to purge from the master archive the records it split from the archive.

The default is No, which tells the utility to copy but not delete those records. The utility stores the copied records in the files and directories you specified.

The /P parameter overrides this option.

CARFileSize

Enter a number between one (1) to 14,000 to define the size for the CAR file. If you enter one (1), the utility interprets that as 100,000 bytes (100 KB). If you enter 14,000, the utility interprets that as 1,400,000,000 bytes (1,4000,000 KB).

Omit this option if the EnableCARFileSize option is set to No.

EnableCARFileSize

(Optional) This option turns on and off the related radio button field on the ArcSplit window in Documaker Workstation and also tells both Documaker Workstation and the ARCSPLIT utility whether to use the CARFileSize option. The default is No.

The /L parameter overrides this option.

AllowChanges

(Optional) Lets you change settings from a window. The default is No.

LogFile

(Optional) Enter the name of the file into which the utility should write any error messages. Here is an example:

LogFile = c:\errlog.txt

The /LOG parameter overrides this option.


Using ARCSPLIT with DAL Scripts

You can use DAL scripts to when you split or back up an archive. The ARCSPLIT utility makes available to the DAL script all of the APPIDX column values you specify. This script can only return Yes or No. If anything else is returned, the system defaults to No.

All field names specified in the script file must include the word ARCSPLIT, such as ARCSPLIT.KEY1. This is required in case multiple index files are in use.

Note Refer to the DAL Reference for information on the DAL functions you can use to create the scripts.

Assume the following form sets are stored in the archive, the INI options are set as shown below, and the DAL scripts COMPANY.DAL and COMBINED.DAL exist in the DefLib directory.

KeyID | Key1 | Key2 | Date archived
AA | Sampco | LB1 | 03/01/1999
BB | Sampco | LB2 | 03/01/1999
CC | FSI | GL | 03/02/1999
DD | FSI | GF | 03/02/1999
EE | MyCompany | GO | 03/03/1999

Also assume these INI options are set:

< ArcRet >

SplitAppIdx = arc1\AppIdx1.dbf

SplitCARFile = arc1\Archive1.car

SplitCatalog = arc1\Catalog1.

The COMPANY.DAL script looks like this:

If ARCSPLIT.Key1 = "FSI" then Return ("Yes");

Else Return ("No");

End

The COMBINED.DAL script looks like this:

if (ARCSPLIT.KEY1 = "FSI " AND ARCSPLIT.KEY2 = "GL ") then

Return ("YES");

Else Return("NO");

End

Note Make sure the value you specify matches the field length defined in the DFD (Database Field Definition) file. In this example, the field length of KEY1 is four characters and the search value should be “FSI “ (with a space between I and the ending quotation mark) instead of “FSI”.

Based on these assumptions, this table shows the results if you enter the following commands to run the ARCSPLIT utility:

If you enter… | The result is…
ARCSPLIT /sd=19990301 /ed=19990301 /ini=fsiuser.ini | Records AA and BB are written to the archive files (ARCHIVE.CAR, APPIDX1.DBF, CATALOG1.DBF, APPIDX1.MDX, and CATALOG1.MDX) in the arc1 directory. The records in the master archive are not changed.
ARCSPLIT /sd=19990301 /ed=19990301 /ini=fsiuser.ini | Records AA and BB are written to the archive files in the arc1 directory. The records in the master archive are not changed. The APPIDX1 and CATALOG1 files will be flat files.
ARCSPLIT /sd=19990301 /ed=19990301 /ini=fsiuser.ini /p | Records AA and BB are written to the archive files in the arc1 directory. These records are also deleted from the master archive.
ARCSPLIT /dal=deflib\company.dal ini=fsiuser.ini | Records CC and DD are written to the archive files in the arc1 directory. The records in the master archive are not changed.
ARCSPLIT /dal=deflib\combined.dal ini=fsiuser.ini | Record CC is written to the archive files in the arc1 directory. The records in the master archive are not changed.


ARCVIEW

You can use the ARCVIEW utility to view Documaker archive files checked into the Documanage archive system. This utility only runs under 32-bit Windows.

Program names

  • Windows: ARCVWW32.EXE

You do not run this utility from the command line. Instead, you simply register this utility as the program you want to use to view Documanage files. To use this utility, follow these steps:

  1. Register the Documanage file extension (DPA) in Windows so the operating system will automatically use the ARCVIEW utility to view these files.
  2. Set the environment variable FSIPATH to point to the directory where the INI file for the AFEMAIN program is stored. Here is an example:

FSIPath = d:\dms1

Note The AFEMAIN program is the executable file for Documaker Workstation.
  3. Place a menu file, similar to the MEN.RES file used by Documaker Workstation, be in the directory specified by the FSIPath option. The name of the menu file should be ARCVIEW.RES.
Note You can edit this file to remove functionality you do not want to include.
  4. Edit the FILETYPES.INI file on the computer where the Documanage server runs. Add the DPA file extension to the list of file types to view with the ARCVIEW.EXE program. This causes the Documanage client to use the viewer registered in Windows instead of the default Documanage viewer.

You can now click on Documaker archive files in Windows Explorer to display them.


ATPHDR

Use the ATPHDR utility to add missing header information for Xerox fonts if you experience this problem when you insert Xerox fonts into a font cross-reference file (FXR) using Studio’s Font manager.

Note Docuview, which is part of Docusave workstation, requires Xerox resources to be padded to fill 512 byte blocks. Some old Xerox resources built with prior versions of the system do not meet this criteria. You can use this utility to read and update those Xerox resources so they can be used by Docuview.

Program names

  • Windows: ATPHDRW.EXE

Syntax

ATPHDRW /I

Parameter | Description
/I | Enter the input file name. Omit the extension.

The input file must have the extension TMP. The utility will create an output file with the extension FNT.


BARR2EPS

Use this utility to convert Metacode files in BARR format into EPS (Enterprise Printing System) format so you can then print the files on a Xerox EPS printer via a TCP/IP connection.

Note BARR format is a print-ready format if you use a BARR server to submit the print stream.

This utility is typically used when you have multiple printers (some BARR and some EPS) or when you upgrade from a BARR server to an EPS printer and have archived print streams in BARR format.

Program names

  • Windows: BARR2EPS

Syntax

BARR2EPS /I /O

Parameter | Description
/I | Enter the input Metacode file name. This file will be in BARR format.
/O | Enter the name you want the utility to assign to the output Metacode file. This file will be in EPS format.

Determining the format

If you are unsure of the format of a print stream, use Studio’s Printstream Analyzer to determine the format. First, open the print stream in the Printstream Analyzer, then click the Properties button to see an analysis of the print stream. Included in the analysis is format information. Here are some examples:

This | Indicates the print stream is...
Variable 2-byte BE | An EPS format file
BARR Format (1) | A BARR format file
Variable Blocked | A Documerge variable block format file


BARR2MVS

Use the BARR2MVS utility when you have a Xerox Metacode spool file which is one long record and you want to separate it into separate records for z/OS (MVS).

Note This program is only available on z/OS.

Metacode print spools which are created on PCs and which use JES2 format, contain carriage return/line feeds (CR/LF) at the end of each record. However, some Metacode print spools created on a PC may contain binary data which happens to contain a carriage return/line feed. In this case, uploading the spool file with CR/LF translation will produce an invalid Metacode print spool file on z/OS.

In this case, create the Metacode print spool using the BARR format, upload the original Metacode print spool file as binary, with no CR/LFs, and use the BARR2MVS utility to convert the BARR formatted print spool file into a Metacode print spool file with separate records on z/OS.

Example

Here is an example to show you how to do this:

  1. Create a PS (Physical Sequential) file on z/OS with DCB=U,0,23200. Name this file WINFILE.
  2. Create another PS file with DCB=VB,600,23200 and call it z/OSFILE.

The BARR2MVS utility uses DD:RSCWIN as the DD name for the original Metacode print spool file and uses DD:RSCMVS as the DD name for the newly-created Metacode print spool file with separate records.


BARR2VB

Use this utility to convert a Metacode print stream from a BARR record format to a Variable Block (VB) format.

Variable block format Metacode records are used in Docuview LFS, which lets you view a Metacode print stream, and in JES Commander, which lets you upload Metacode print streams to MVS, OS/390, or z/OS.

Program names

  • Windows: BARR2VB.EXE

Syntax

BARR2VB /I /O /D /P

Parameter | Description
/I | Enter the name of the input file in BARR format.
/O | Enter the name of the output file in VB format.
/D | (Optional) Include this parameter to add Docusave comments.
/P | (Optional) Use this option to specify the PrtType control group you want the utility to use from the INI file. For example, you could enter XER.

Use the /D parameter to add a dummy Docusave record to the variable block format print stream.

Your FSISYS.INI file should include a printer control group, such as PrtType:XER, which contains the options used to produce the BARR formatted Metacode print stream. This information is necessary for BARR2VB to read the BARR formatted Metacode print stream.


BARRWRAP

Use this utility to reformat z/OS-generated Metacode output for submission to a BARR system for Xerox printing on a local area network.

Program names

  • Windows: BARRWW32.EXE

  • z/OS:See the Documaker Installation Guide.

Syntax

BARRWW32 /I

Parameter | Description
/I | The Metacode file. The extension must be MET, which you can omit.

The file will be formatted for BARR spool output and the output file name will have the same name with a TXT extension.

This utility converts Metacode output from a JES2 format to a BARR format. The BARR interface attachment for Xerox Metacode printers requires Metacode print stream files to contain BARR specific information. BARRWRAP adds this information to an existing Metacode print stream file, allowing the output file to be printed via the BARR interface. After the utility is run on the Metacode file, “76 1A FF 00” will be added at the beginning of the file which informs BARR that the file is of Metacode type. A byte denoting record length is also added at the beginning and end of each record in the file.

To use this utility, you must set these INI options:

Environment=MVS

OutMode=JES2

BARRWRAP is useful when testing the GenPrint program on z/OS. If the z/OS system is not directly channel attached to the Xerox printer, you have to download the print data stream to a Windows system. (use no ASCII translation, but do use CR/LF). Then, using BARRWRAP, it is packaged to pass through BARR/SPOOL successfully.

Note Occasionally, binary data contained in the Metacode file has a sequence of hex bytes x’0D0A’, which could be misinterpreted as a carriage return / line feed. This is true particularly for charts and other inline graphics. Such data streams should be BARRWRAPped on the z/OS platform before being downloaded with no ASCII and no CR/LF options.


BDF2FDT

Use this utility to load a complete tree, based on the specified BDF file, and then convert it to a pre-version 11.x format FORM.DAT file.

Note This utility is typically used by customers who have purchased tools from 3rd party vendors that parse FORM.DAT files. These tools extract a list of the forms in the library as a part of the data exchange mapping process.

Program names

  • Windows: BDF2FDT.EXE

Syntax

BDF2FDT /I /INI /O /D

Parameter | Description
/I | (Optional) Enter the name of the BDF file you want to convert. If you omit this parameter, the system looks for the one in the INI file you specify using the INI parameter.
/INI | (Optional) Enter the name of the INI file which contains the name of the BDF file you want to convert. The default is FSIUSER.INI.
/O | (Optional) Enter the name of the output FORM.DAT file. The default is FORM.DAT.
/D | (Optional) Enter the effective date in YYYYMMDD format. The default is the current date.
Note Not all document features and options supported by Documaker Studio can be represented in a FORM.DAT file. You must make sure the forms you develop in Studio convert appropriately.


CARINTEG

Use the CARINTEG utility to check the integrity of CAR archive files. This utility is built into the base system, so you may not need to run it separately if you are using version 7.5 or later.

Program names

  • Windows:CARIGW32.EXE

Syntax

CARIGW32 /I

Parameter | Description
/I | Enter the name of the CAR file.

A CAR file contains compressed NA and POL information along with a table of offsets to this information. CARINTEG queries the table of offsets to determine the number entries, counts back to the first entry in the table, then verifies that the record referenced by that offset is a valid CAR record.

CARINTEG returns a message which tells you if the CAR file is OK or if it has errors.


CARREN

Use the CARREN utility to rename CAR files. Typically, this is done to keep CAR file sizes at a manageable level.

Program names

  • Windows: CARRNW32.EXE

Syntax

CARRNW32 /I /P

Parameter | Description
/I | Enter the name of the CAR file.
/P | Enter the path in which to place the renamed file.

You must have the following two files in the working directory, along with the CAR file:

  • CATALOG.DBF
  • CATALOG.MDX

This utility renames the specified CAR archive file with a new and unique name. The next time archive is run, the system creates a new CAR archive file with the same name as the original CAR file.

Tip You can automate this process using INI options.


CFA2FAP

Use the CFA2FAP utility to convert a CFA or CFX file into a FAP or FXR file. CFA files are compiled FAP files. CFX files are compiled FXR (font cross-reference files). This utility is used for debugging purposes.

When you use this utility, the result matches your original FAP file, with these exceptions:

  • Version records will not be decompiled
  • Some error and backward compatibility issues may have been corrected when you compiled the file so the new, decompiled file will include those changes
Note The version of the system you use to compile the FAP and FXR files must be the same version you will use when running Documaker Server. Furthermore, the platforms must also match. For instance, if you compile the FAP and FXR files on version 11.0 for Windows, to use them in Documaker Server (GenTrn, GenData, GenPrint), you must run version 11.0 for Windows of Documaker Server.

Program names

  • Windows: CFA2FAPW.EXE

Syntax

CFA2FAPW /I /O /F

Parameter | Description
/I | The input CFA file or CFX file
/O | (Optional) The output FAP or FXR file
/F | Include this option to create a font cross-reference (FXR) file which contains only fonts

Make sure the CompiledFAP option is set to Yes (the default is No) in the RunMode control group of your INI files before you run the system using precompiled FAP files.

In addition, use the File, Library Setup option (or edit your INI files) to specify the path for the CompLib, which is where the system will look for the compiled files. In your INI files, you will find this setting in the following control group:

<MasterResource>

CompLib=(directory or library the CFA and CFX files are stored in)

For z/OS systems, you can specify a DD name, such as DD:COMPLIB()

Note If you are going to use pre-compiled FAP files, you must also use precompiled FXR files. Also keep in mind that you cannot upload CFA files.


CPCNV

Use the CPCNV utility to convert the text of a flat file, record by record, from a source code page to a destination code page. This utility supports record lengths up to 32k.

Note You can port this utility to other platforms.
  • Windows : CPCNVW32.EXE
  • z/OS: See the Documaker Installation Guide.

Syntax

CPCNVW32 /S /D /I /O /N /R

Parameter | Description
/S | The code page the source file is written in.
/D | The code page to convert to.
/I | The text file to convert (you can use asterisks as wildcards).
/O | (Optional) The name of the output file.
/N | (Optional) A nontranslatable character value, the default is 255.
/R | (Optional) Reads the CR/LFs in the ASCII file and converts the data into multiple records. Use this parameter if you use FTP or similar communications programs to upload files. If the program you use to upload the files converts CR/LFs into separate records, you can omit this parameter.

Use the CPCNV utility to convert text files written in one code page to another code page. The CPCNV utility loads either the FSISYS.INI or FAPCOMP.INI file to find these FMRES control group options:

< FMRes >

DefLib = ..\MSTRRES\FMRES\DEFLIB\ (default shown)

CodePage = CODEPAGE.INI (default shown)

This utility uses the CODEPAGE.INI file in your \mstrres\fmres\deflib directory. If the file is not there, the utility displays an error message. You can specify a different location by adding an INI option in the FSISYS.INI or FSIUSER.INI files, as shown here:

< FMRes >

DefLib =

Option | Description
DefLib | Enter the path to the CODEPAGE.INI file.

The CODEPAGE.INI file contains information about characters in various code pages. Here is an excerpt of the CODEPAGE.INI file:

< CodePages >
  CodePage  = 1004,W1
  CodePage  = 863,CF
  CodePage  = 850,PM
  CodePage  = 437,PC
  CodePage  = 37,Z1
< CodePage >
  Char  = SP010000,         space, , 32, 32, 32, 32, 64
  Char  = SP020000,        exclam, , 33, 33, 33, 33, 90
  Char  = SP040000,      quotedbl, , 34, 34, 34, 34,127
(and so on)
  Char  = LA160000,   Acircumflex, ,194,132,182, 0, 98
  Char  = LA150000,   acircumflex, ,226,131,131,131, 66
(and so on)

The first control group, CodePages, lists the code pages specified by this file. The two character abbreviation, following the code page number, specifies an internal character set name used by some system font conversion utilities.

The second control group, CodePage, specifies character names and their associated code points in the different code pages listed in the first control group. The first column is the name of the character when printing to an AFP printer. The second column is the name of the character when printing to a PostScript printer. The third column is the name of the character when printing to a TrueType printer (not currently supported). The remaining columns correspond to the code points for the code pages specified in the first control group.

In the example above, there are five code pages specified: 1004, 863, 850, 437, and 37. Therefore, the last five columns represent code points for code pages 1004, 863, 850, 437, and 37 respectively.

For example, the first character defined (the space character) has these attributes:

Char = SP010000, space, , 32, 32, 32, 32, 64

AFP name = SP010000

PostScript name = space

TrueType name = (blank, not used)

1004 code point = 32

863 code point = 32

850 code point = 32

437 code point = 32

37 code point = 64

where as the A-circumflex (Â) character has the following attributes:

Char = LA160000, Acircumflex, ,194,132,182, 0, 98

AFP name = LA160000

PostScript name = Acircumflex

TrueType name = (blank, not used)

1004 code point = 194

863 code point = 132

850 code point = 182

437 code point = 0 (not defined for this code page)

37 code point = 98

Therefore, if you were to convert a text file built using code page 863 (Canadian French) to code page 1004 (ANSI/Documaker standard), any space characters would remain unchanged but any A-circumflex (Â) characters would change from a 132 to a 194 code point.

See the Fonts Reference for more information about fonts and code pages.

See Also

  • Transferring Files in Binary or Text Mode


Transferring Files in Binary or Text Mode

Sometimes you need to transfer files between the PC and host (z/OS) platforms. There are a number of products that provide this capability. For instance, you can use FTP to transfer files from the PC to the host (z/OS). FTP can transfer a file using a binary or text mode.

  • Binary mode means do not translate the characters contained in the file.
  • Text mode means translate the characters from ASCII on the PC to EBCDIC on the host.

Text mode will also write a separate record on the host for each carriage return line feed combination found in the original PC file.

Unfortunately, the Text mode ASCII to EBCDIC translation used by FTP does not match our standard ASCII to EBCDIC translation for extended ASCII characters (code points 128 and above contain international characters, some currency and punctuation symbols, and so on). Therefore, if system resource files to be uploaded contain some of these extended ASCII characters, the files must be uploaded as Binary.

If a system resource file, such as a FAP, FXR, or DDT file is uploaded as binary, not only do you need to convert the ASCII characters to EBCDIC, you also need to create records that correspond to each line of text in the PC file.

On the PC, the end of a line is indicated by a couple of control characters, specifically a carriage return character followed by a line feed character (CRLF). Since the PCL file was uploaded as binary, the file still contains the CRLF characters. Use the /R parameter to treat the CRLFs as an end of line indicator when converting the file on z/OS.

Some products, including IBM's Personal Communication, provide the ability to upload a file as binary but will translate CRLFs into separate records when uploading the file. Do not use the /R parameter if you use a file transfer program that converts lines ending with CRLFs into separate records when uploading to z/OS.


CRYRUN

Use this utility to generate an encrypted version of a password. You can then use the encrypted version of the password in an INI file, along with the ~Encrypted INI built-in function.

For more information on INI built-in functions, see the Documaker Administration Guide.

Program names

  • Windows: CRYRUW32.EXE

This utility only runs on Windows, but you can copy the encrypted password this utility generates into an INI file on a UNIX system and use it there in the same way you would use it on a Windows system.

Syntax

CRYRUW32 string

Parameter | Description
string | Enter the string that you would like to encrypt.

Once you generate the encrypted version of the string, you can specify this encrypted version of the string in an INI file, along with the ~Encrypted INI built-in function.

Here's an example of how you would run this utility:

C:\fap\mstrres\dms1>cryruw32 mypassword
Encrypted string (0eSYru9MskUELiEy4M1CT1meU)

Here is an example that shows how you use the encrypted version of the string in an INI file:

< LDAP >
LDAP.PWD = ~ENCRYPTED 0eSYru9MskUELiEy4M1CT1meU


CSET2FAP

Use the CSET2FAP utility to convert Document Sciences CompuSet scripts into Documaker FAP files. This utility performs conversions as part of a batch process.

Note Using this utility reduces the work necessary to convert a Document Sciences resource base into a Documaker resource base. These commands are supported:
Command | Description | Command | Description
BD | bold | BL | blank line
BOX | create a box | CB | change baseline
CC | center on column | COLOR | set color
CP | center on page | CW | column width
DL | dot leader | EL | end underline
EVR | end vertical rule | F | select font
HR | horizontal rule | JU | horizontal justify
LT | non bold | NL | new line
NP | new page | NPR | new page recto
PA | set paragraph indent | PD | page depth (height)
PT | point size | PW | page width
QL | quad left | QR | quad right
SK | skip text (comment) | SP | space vertically
SVR | start vertical rule | T | select tab
TABC | set text-centered tab | TABJ | set text-justified tab
TABL | set quad left tab | TABR | set quad right tab
UL | underline | VR | vertical rule
Note Keep in mind the utility does not convert the full set of CompuSet logic. Also, in version 12.0 and later, the utility ignores the SC (set counter) command.

Syntax

CS2FPW32 /I /C /F /S

Parameter | Description
I | The name of the INI file from which to load the INI options discussed in the configuration topic following this table. The default is the FSISYS.INI file.
C | The name of the configuration file that contains font information. If you omit this parameter, the utility uses the value for the Config option in the CompuSet control group.
F | The name of the form you want to convert.
L | Including this parameter tells the utility to log all of the debug information created when creating FAP files from a CompuSet file. This parameter is turned off by default.
S | The name of the file that contains the master styles, if any. If you omit this parameter, the utility uses the value for the MasterStyles option in the CompuSet control group.
Note All parameters are case insensitive.


Configuring the INI File

Since Documaker applications can use the same font files as the Document Sciences system, first copy the font files into your Documaker Metacode resource directory. This is the same place the Metacode fonts licensed via Documaker software are located. Then use Studio’s Font manager to import the fonts. Specify the name of the new font cross-reference (FXR) file in the XRFFile option of the MasterResource control group.

The CSET2FAP utility also uses these INI options:

< CompuSet >

MasterStyles =

Config =

ExtremeLogging =

< MasterResource >

DefLib =

< Config:XXX >

XRFFile =

< Loaders >

Loader =

< Loader:CompuSet >

Desc =

Func =

Module =

Option | Comments
CompuSet control group
MasterStyles | (Optional) Enter the global styles definition file name.
Config | Enter the name of the file that contains logical and machine font definitions and the font files in which they are located.
ExtremeLogging | Enter Yes to view all of the debug information when creating a FAP file from a Document Sciences file. The system defaults to No.
MasterResource control group
Deflib | Enter the path to your Documaker resources.
Config:XXX control group where XXX is the name of the library or workspace
XRFFile | Enter the name of the font cross-reference file (FXR) you want the system to load.
LOGO.DAT | Enter the name of the file containing the fonts you want to use as graphics. For more information, see Using Fonts as Graphics.
Loaders control group
Loader | This entry is used to locate image loader INI groups. For instance, you could enter CompuSet.
Loader:CompuSet control group
Desc | Enter the description you want to appear in the file types list of the File Open window. For example, you could enter Compuset files (*.TXT).
Func | Enter the name of the image loading function, such as CompuSetImageLoader.
Module | Enter the name of the image loader module, such as CSLDRW32.
Note Because the conversion does not handle all CompuSet commands, you may receive some error messages.


Using Fonts as Graphics

If you have fonts you use as graphics, you must first convert them to LOG files. Then, enter the root file name for each graphic in the LOGO.DAT file. The LOGO.DAT file should reside in the current working directory.

The LOGO.DAT file is a semicolon-delimited text file that names the various rotations of graphic fonts. It should look similar to this:

[file name for 0° rotation];[file name for 90° rotation];[file name for 180°rotation];[file name for 270° rotation];

You can omit any of the rotations, but you must include a semicolon as a delimiter. For example, this omits the 90 degree file rotation:

[file name for 0° rotation];;[file name for 180°rotation];[file name for 270° rotation];

Note Do not list the graphic fonts in the FXR file. If the utility cannot find a font, it will look for a graphic.


Handling SVR and EVR Commands

If the CSET2FAP utility encounters these commands, it will convert the (dynamic) vertical rules in your CompuSet scripts to (static) vertical rules in the FAP files. If the rule is not of one of the valid types listed in the CompuSet documentation, you will get the following message:

Unrecognized rule type

Only the following rules types are supported:

  • solid
  • light
  • medium
  • dark
  • light dot
  • medium dot
  • heavy dot
  • light dash
  • medium dash
  • heavy dash


CVTFASR

Use the CVTFASR utility to convert a FORMDEF and SETRCPTB pair into BDF (Business unit definition file), GRP (group file), and FOR (form file) files. The existing FORMDEF and SETRCPTB files are not modified or removed.

CVTFASR /FORMDEF /SETRECIP /INI

Parameter | Description
FORMDEF | Enter the name of the form definition file.
SETRECIP | Enter the name of the set recipient file.
INI | Enter the name of the INI file.

The CVTFASR utility reads the specified FORMDEF and SETRECIP files and generates the appropriate BDF, GRP, and FOR files. If you include the INI parameter, the utility opens and reads that INI file. The utility tries to locate these INI options to get the directory locations into which the BDF, GRP and FOR files will be written.

< MasterResource >
  BDFLIB = .\bdflib
  GRPLIB = .\grplib
  FORLIB = .\forlib

If the INI option for one or more of the generated file types is missing, the utility writes the files for that type into the working directory.

Here is an example of the messages you may see when running the CVTFASR utility on Windows:

c:\fap\mstrres\dms1>cvtfasrw /formdef=.\deflib\form.dat /setrecip=.\deflib\setrcptb.dat

--- DocuCorp CVTFASR Utility Program (C) ---

--- Convert Formdef And SetRecip Files ---

Number Of Files Generated From Formdef & SetRecip:

Basedef (BDF) : 1

Group (GRP) : 4

Form (FOR) : 24

CVTFASRW was successful.


DALRUN

Use this utility to execute and debug DAL functions.

Debug messages, certain errors, and a dump of the symbol table at the end of the run are examples of output this utility will generate.

Program names

  • Windows: DALRW32.EXE

Syntax

DALRW32 /X /INI /D /T /B

Parameter

Description

/X

(Optional) Supplies the name of a script to run. If you omit this option, you can use this INI option to provide the name of the script:

< DALRun >

Script = file name

You can use any extension. The default is DAL.

/INI

(Optional) Supplies the name of an INI file to load. This INI file supplies additional parameters and options. If an INI file named DALRUN.INI is present, the utility loads it by default.

Here are the INI options you can include in the INI file:

< DALRun >

Title = title string (an override to the window title)

Script = file name (the script to run)

< DALFunctions >

Keyword = DLLMOD->FunctionName

Keyword2 = DLLMOD->FunctionName2

(and so on)

/D

The debug switch starts the DAL debugger. When on, the script executes in single step mode and registers this DAL function: DEBUG(“message”).

The DEBUG function breaks execution, displays a message, and invokes the debugger in single step mode.

/T

This parameter sends certain text messages to the standard output device. These messages are not visible at runtime, but may be redirected when you run this utility. Here is an example:

DALRW32 /ini=test /d /t > test.txt

/B

This parameter lets you run the utility in batch or command line mode. When you include this parameter, the Windows dialog shown when the utility terminates is suppressed.

Note Refer to the DAL Reference for information on the DAL functions you can use to create the scripts DALRUN executes.


DataCrypt

Use this utility to encrypt and decrypt data files.

The program is a Java class in the DocuCorpUtil.jar library. To run it, enter a command similar to the one shown here:

java -cp DocuCorpUtil.jar com.docucorp.util.DataCrypt

Here is a summary of the parameters:

Parameter | Description
-i | Treat the text argument as a file name instead of text to encrypt/decrypt.
text | The text to encrypt/unencrypt or the name of a file if the -i parameter is included. The input file is overwritten with the new information.
-u | Include this parameter if you want to decrypt the text or file instead of encrypting it. Encrypting is the default behavior for this utility.
Note If you omit all of the parameters, a usage message appears.


DB2DB

Use this utility to copy data from one database table to another database table. The database tables can be from a different DBMS, such as one from ODBC and the other from a native DB2 database.

Program names

  • Windows: DB2DBW32.EXE

Syntax

DB2DBW32 /ST /SD /SD /TT /TD /TH

Parameter | Description
ST | Enter the name of the source table.
SD | Enter the name of the DFD file for the source table.
SH | Enter the type of handler for the source table.
TT | Enter the name of the target table.
TD | Enter the name of the DFD file for the target table.
TH | Enter the type of handler for the target table.

Note:

The source and the target table names must be different. You can rename target table after the conversion to a new database. For example:

db2dbw32 /st=xdb ……. /tt= xdb … (incorrect)

db2dbw32 /st=xdb ……. /tt= xdb2 … (correct)

See the following examples:

  • DB2DB Example 1
  • DB2DB Example 2


DB2DB Example 1

How to convert an XDB dictionary (a CB5 table) into a DB2 table:

db2dbw32 /st=xdb /sb=.\deflib\xdb.dfd /sh=CB5 /tt= xdb2 /td= .\deflib\xdb.dfd /th=db2

These parameters tell the utility to copy the source table (XDB), which is associated with the xBase DBHandler called CB5 and is mapped using the XDB.DFD file in the .\deflib directory, to the target table (xdb2), which is associated with a DB2 DBHandler called DB2 and is also mapped using the same DFD file. In this example, the actual name of the XDB2 DB2 table is CP_Xpress.

In this example, your FSIUSER.INI file contains entries similar to these. The DB2 table, cpxdb2, is contained in the DB2 database, CP_Xpress.

< DBHandler:DB2 >
  Database	= CP_Xpress
  BindFile	= c:\dap32103\dll\db2lib.bnd
  Connect	= Yes
  CreateTable	= Yes
  UserID	= db2admin
  Debug		= Yes
  PassWd	= XXX
< DBTable:xdb >
  DBHandler	= CB5
< DBTable:xdb2
  DBHandler	= DB2
< DB2_FileConvert >
  xdb2		= cp_xpress_xdb

You can use the DB2_FileConvert INI control group to specify longer names for the table in DB2.

Option | Description
CreateTable | Enter Yes so DB2 will create the table if it does not exist.
BindFile | Enter the name and path of the DB2LIB.BND file.

See also DB2DB Example 2.


DB2DB Example 2

How to convert an Access table into a DB2 table:

db2dbw32 /st=coverage /sd=.\deflib\coverage.dfd /sh=CB5 /tt= coverage2 /td= .\deflib\coverage2.dfd /th=db2

These parameters tell the utility to copy the Microsoft Access source table (coverage), which is associated with a DBHandler called ODBC and is mapped using the COVERAGE.DFD file in the .\deflib directory, to the target table (coverage2), which is associated with a DBHandler called DB2 and is mapped using the COVERAGE2.DFD file in the .\deflib directory.

In this example, your FSIUSER.INI file contains entries similar to these. The DB2 table, coverage2, is contained in the DB2 database, CP_Xpress.

< DBHandler:DB2 >
  Database	= CP_Xpress
  BindFile	= c:\dap32103\dll\db2lib.bnd
  Connect	= Yes
  CreateTable	= Yes
  UserID	= db2admin
  Debug		= Yes
  PassWd	= MVF
< DBHandler:ODBC <
  Server	= cpxpress
< DBTable:Coverage <
  DBHandler	= ODBC
< DBTable:Coverage2 <
  DBHandler	= DB2

Here an example of the MS Data Sources (ODBC) setup from a conversion:

See also DB2DB Example 1.


DCD2FAP

Use this utility to convert a Docucorp Compound Document (DCD) file into a FAP file. DCD files are produced by applications such as Documerge for Windows NT version 3.0 and older versions of Documanage (Printcommander for Windows 95 version 2.0.)

Program names

  • Windows: DCD2FAPW.EXE

Syntax

DCD2FAPW /I /X

Parameter | Description
/I | The name of the input DCD file. You can use wildcards.
/X | The name of the font cross-reference (FXR) file. Include the extension (.FXR).

The resulting FAP file will have the same name as the DCD file but with a FAP extension.


DFD2DDL

Use this utility to generate DDL (Data Definition Language) files from your DFD files. DDL files consist of the SQL statements that create your tables and views. This is helpful if you have an RDBMS database where an administrator is required to create tables and indexes and users are not typically granted those privileges.

Program names

  • Windows: DFD2DDLW.EXE

Syntax

DFD2DDLW /I /O /D /T /S /P /L

Parameter | Description
/I | Enter the name of the DFD file. Include the full or relative path.
/O | Enter the name you want the utility to assign to the DDL file it will create. The default is the DDLFile root plus the extension .SQL.
/D | Enter the name of the target database. You can choose from: MSSQL, DB2, Oracle, MySQL. The default is MSSQL.
/T | Enter the name of the target table. The default is the DFD root name.
/S | (Optional) Enter the name of the target schema. This is typically used for Oracle schema, DB2 schema, and MSSQL DBowner.
/P | (Optional) Enter the name of the primary table index. This allows for unique constraints on key fields.
/L | (Optional) Enter the name of the target location. This is used for DB2 (location) and MySQL (database name).

Avoid the following ExtTypes because they are not supported as external data types in Documaker’s database handlers:

  • CHAR
  • UCHAR
  • DECIMAL
  • DOUBLE
  • LONG_DOUBLE
  • TIMESTAMP
  • DATETIME


DSITEST

Use this utility to test the transfer of files to and from IDS. Here is an example of the syntax and parameters for this utility:

Note By default, the DSITEST utility runs in Java mode. You can, however, run it in C mode. To switch modes, open DSITEST in a text editor and follow the instructions at the beginning of the script.

Syntax

dsitestw /time /waitonlast / display /nowait /reqtype /msg /notrans /noattachs /norcvs /atcfile /rcvfile

Parameter | Description
Time | Displays total seconds for all operations. Do not include NoRCVs, ATCFile, or RCVFile with this parameter because those parameters contain user prompts that affect the time.
WaitOnLast | Waits on the last message before capturing the ending time.
Display | Displays the resulting DSI Soap XML message that contains the name/value pairs for each transaction.
NoWait | Do not wait for the server before adding next message to queue.
ReqType | The IDS request type. The default is SSS.
MSG | The name of the file that contains the request name/value pairs.
NoTrans | The total number of transactions to process.
NoAttachs | The total number of file attachments to send per transaction using the DSISendFile API. If you include this parameter, the program expects an input file named SENDFILES.MSG that contains the information for each attachment to send.
NoRCVs | The total number of file attachments to receive per transaction via the DSIReceiveFile API. If you include this parameter, the program expects an input file named RECEIVEFILES.MSG that contains the information for each attachment to receive.
ATCFile | A single file attachment to send via the DSISendFile API. The program prompts the user for the attachment ID, file name, and encoding type.
RCVFile | A single file attachment to receive via the DSIReceiveFile API. The program prompts the user for the attachment ID and file name.
Neither the case nor the order of the parameters is important.

You can include these parameters on the command line or place them in an input file named PARAMS.MSG. On the command line, separate parameters with slashes (/), dashes (-), or spaces:

DSITESTW /time=yes

DSITESTW -time=yes

DSITESTW time=yes

If you include the parameters in the PARAMS.MSG file, format them as shown in this example of the PARAMS.MSG file:

time=yes

waitonlast=no

display=yes

nowait=no

reqtype=LGN

notrans=50

msg=prt.msg

noattchs=0

norcvs=0

atcfile=yes

rcvfile=yes

Here is an example of how you could execute this program from the command line:

dsitesw time=yes display=yes notrans=2 reqtype=prt msg=c:\prt.msg

Here is an example of the PRT.MSG file:

USERID=FORMAKER

Arckey=00345A0D5600000008

reqtype=PRT

config=UTILITY

company=1199999

lob=Lee

policynum=Roswell, Ga 30015

rundate=021705

printpath=\10.8.10.137\Websrvr_client\html

If the NoAttachs parameter is greater than zero, the program expects an input file named SENDFILES.MSG which contains a list of the attachments to send. Use either NoAttachs or ATCFile, but not both.

Use the ATCFile parameter when you only want to send one file attachment. The ATCFile parameter uses command line parameters for the attachment ID, file name, and encoding type. Here is an example of the ATTACHMENTS.MSG file:

name=UTILITYINI

file=X:\IDS\AddlSrvrs\utility.ini

type=TEXT

name=TESTPDF

file=X:\websrvr_client\html\test.pdf

type=BINARY

If the NoRCVs parameter is greater than zero, the program expects an input file named RECEIVEFILES.MSG, which contains a list of attachments to receive. Include either NoRCVs or RCVFile, but not both.

Use the RCVFile parameter when you only want to receive one attachment. The RCVFile parameter uses command line parameters for the attachment ID and file name. Here is an example of the RECEIVEFILES.MSG file:

name=PDFFILE1

file=X:\\IDS\\AddlSrvrs\\Output\\file1.pdf

name=PDFFILE2

file=X:\\IDS\\AddlSrvrs\\Output\\file2.pdf

If you omit the request type from the command line or the PARAMS.MSG file, the program uses SSS as the default request type.


FAP2AFP

Use this utility to compile a FAP file into an AFP print file.

The FAP2AFP utility generates an AFP print-ready file from the FAP file you specify. In addition to the name of the FAP file, you must also specify the font cross-reference (FXR) file used by the FAP file.

Program names

  • Windows: FAP2AFPW.EXE
  • UNIX/Linux: fap2afp
  • z/OS: See the Documaker Installation Guide.

Syntax

FAP2AFPW /I /O /INI /X /VF /NORM /LIB /VER /REV

Parameter | Description
/I | Enter the name of the FAP file you want to compile. You can use asterisks (*) as wildcards to select multiple files. Note that you cannot use asterisks if you include the /LIB parameter.
/O | (Optional) Enter the output file name and location. This can be different than input name. This default is the input name.
/INI | (Optional) Enter the name of the INI file. The default is FSIUSER.INI.
/X | (Optional) Enter the name of the font cross-reference (FXR) file. The default is the FXR file specified in the INI file.
/VF | (Optional) Add this parameter to print variable fields as template fields.
/NORM | (Optional) Add this parameter to create a normalized output file.
/LIB | (Optional) Enter the name of the library from which you want to retrieve the input FAP file. If you omit the /VER and/or the /REV parameters, the utility retrieves the latest version and/or revision.
/VER | (Optional) Enter L to retrieve the latest version in the library or else enter a specific version number.
/REV | (Optional) Enter L to retrieve the latest revision in the library or else specify a specific revision number.
Note This utility is not case sensitive.


FAP2AFP on z/OS

This utility generates an AFP print-ready file from a FAP file. You can convert a single FAP file in the PDS (/I=FAPNAME) or all FAP files in the PDS (/I=*). Look in the FAP2AFPX member of JCLLIB to find an example of this utility.

You can also convert a FAP file in the library (use /LIB=LIBNAME). You can specify the optional parameter /VER and /REV parameters to specify the version and/or revision of a FAP file in the library you want to convert. Keep in mind that you cannot use wildcards (/I=*) when you include the /LIB parameter.

Look in the FAP2AFPL member of JCLLIB to find an example of this utility.


FAP2CFA

Use the FAP2CFA utility to convert a FAP file into a compiled FAP file. By pre-compiling your FAP files, you can speed processing.

Note The version of the system you use to compile the FAP and FXR files must be the same version you will use when running Documaker Server. Furthermore, the platforms must also match. For instance, if you compile the FAP and FXR files on version 11.0 for Windows, to use them in Documaker Server (GenTrn, GenData, GenPrint), you must run version 11.0 for Windows of Documaker Server.

Program names

  • Windows:FAP2CFAW.EXE

Syntax

FAP2CFAW /I /O /INI /F

Parameter | Description
/I | The input FAP file or font cross-reference (FXR) file (you can use asterisks as wildcards).
/O | The output CFA or CFX file. You can enter an absolute (d:\dap\myinc\mstrres\fap) or relative path (..\mstrres\fap).
/INI | Specifies an INI file which contains additional parameters. You can enter an absolute (d:\dap\myinc\mstrres\fap) or relative path (..\mstrres\fap).
/F | Include this option to create a compiled font cross-reference (FXR) file which contains only fonts.

This utility lets you compile FAP files one at a time. To compile all of the FAP files listed in a FORM.DAT file, see FDT2CFA. To convert a CFA or CFX file back into a FAP or FXR file. see CFA2FAP.

Make sure the CompiledFAP option is set to Yes (the default) in the RunMode control group of your INI files before you run the system using precompiled FAP files. In addition, use the File, Library Setup option (or edit your INI files) to specify the path for CompLib, which is where the system will look for the compiled files. In your INI files, you will find this setting in the following control group:

< MasterResource >

CompLib = (library which contains the CFA and CFX files)

For z/OS systems, you can specify a DD name, such as DD:COMPLIB()

Note If you are using pre-compiled FAP files, you must also use compiled FXR files.
If you enter this command... | The result is a compiled FAP file named...
FAP2CFAW /I=qaihead | qaihead.cfa
FAP2CFAW /I=qaihead /o=qaihead1 | qaihead1.cfa
FAP2CFAW /I=cwqa240.fxr /f | cwqa240.cfx
FAP2CFAW /I=cwqa240 /f | cwqa240.cfx
FAP2CFAW /I=qaihead.old | qaihead.cfa
FAP2CFAW /I=..\faps\qaihead | qaihead.cfa, located in the ..\fap subdirectory


FAP2DDT

Use the FAP2DDT utility to create or update a DDT file from a FAP file.

Note DDT files were used in legacy Documaker implementations. Master resource libraries (MRLs) created with Documaker Studio do not use DDT files.

Program names

  • Windows: FAP2DDTW.EXE

Syntax

FAP2DDTW /I /O

Parameter | Description
/I | Enter the name of the input FAP file. Omit the extension.
/O | (Optional) Enter the name of the DDT file. If you omit this file name, the utility uses the FAP file name with the DDT extension. If the DDT file does not exist, the utility creates it.
/X | Enables the output of ;X;Y;FontID;
/V | Enter 7 or 8, force output to the new (8) or old (7) format, defaults to the same format as DDT input, or version 8.0 format if you omit this parameter.
/S | Synchronizes with the existing DDT file.

The FAP2DDT utility creates a data definition table (DDT) file from the existing FAP. The DDT file stores section rule assignments. The parameters are optional and case insensitive.

Keep in mind the FAP2DDT utility adds a default SetOrigin rule to the Image Rules section if one does not exist. The SetOrigin rule that is added is shown here:

;SetOrigin;Abs+0,Abs+0;

For the FAP2DDT utility to add a SetOrigin rule into your DDT file, include this INI option in the FAPCOMP.INI file:

< DDTResource >

AutoIncludeSetOrigin = ;SetOrigin;Abs+0,Abs+0;

The DDTResource control group is used for DDT settings, such as WriteCoordinates, MultipleDDTs, and so on.

A SetOrigin rule is only added to a DDT file if there is an AutoIncludeSetOrigin option and these conditions are true:

  • The AutoIncludeSetOrigin setting begins with a semicolon (;)
  • The AutoIncludeSetOrigin setting contains the string “SetOrigin”
  • The DDT file does not already contain a SetOrigin rule (SetOrigin, SetOriginI, SetOriginM, RULSetOrigin2, UTILSetOrigin)

Other than verifying that the rule begins with a semicolon and contains some form of the string “SetOrigin,” no other validation is performed. You must make sure you specify a valid rule with valid parameters.

Here is an example:

FAP2DDTW /I=fapfile

This will create a file named FAPFILE.DDT whose contents look like:

<Image Rules>

;SetImageDimensions;0,0,26400,20400,400,600,400,600;

/* By default, this section contains the following fields */

<Image Fields>

<Image Field Rules Override>

;0;0;BLANK FIELD NAME;;;BLANK FIELD NAME;;0;;noopfunc;;;;;;


FAP2FRM

Use the FAP2FRM utility to compile a FAP file into a Xerox FRM Metacode overlay file.

Note You can also convert FAP files into FRM files using Studio’s Conversion manager.

Program names

  • Windows: FAP2FRMW.EXE

Syntax

FAP2FRMW /I /X

Parameter | Description
/I | Enter the name of the FAP file. Omit the extension.
/X | Enter the name of the font cross-reference (FXR) file. Omit the extension.
/P | Enter the INI file PrtType to use, such as XER.
/D | Enter SF for short bind front page duplex. Enter SB for short bind back page duplex.
/H | (Optional) Add this parameter to use HMI.
/C | (Optional) Add this parameter to use color in the FRM file.
Note The name of the FAP file cannot exceed six characters (123456.fap).

The FAP2FRM utility requires these files:

  • FSISYS.INI
  • the font cross-reference file (rel121.FXR)

FAP2FRM generates a Xerox form printer resource file (FRM) from a FAP file. In addition to the FAP file name, the FXR font cross-reference file used by the FAP must also be specified. Since FRM file is a printer resident resource, the file name should be no more than six characters long.

FAP2FRM looks for a control group named Printer in the FSISYS.INI. In the Printer control group, FAP2FRM looks for the PrtType option, which determines the type of printer being used, such as AFP, XER, or PCL. Use the /P parameter to specify which PrtType control group the utility should use. The default control group is PrtType:XER.

If the FAP file contains multiple pages, FAP2FRM generates multiple output files with 2-digit numeric suffixes. In this case, file names for these FAP files should not exceed four characters (1234.FAP).

After running FAP2FRM, download the output FRM files to the printer, using the XERDNLD utility.

Also, in Studio’s Form manager, check the Printer Resident field for each such section.

If the FAP file contains graphics, the FAP2FRM utility produces a Xerox FRM file using either Xerox fonts or Xerox images, based on the value for the ImageOpt option in your Xerox printer control group. If you set the ImageOpt option to Yes, Xerox images (IMG files) are used in the Xerox FRM file the utility produces. Otherwise, Xerox fonts (.FNT files) are used.

Note

  • Image references are supported in FRM files. If you set the ImageOpt entry to Yes, the system generates the required GHO headers and packets in the FRM file so FAP files that contain IMG references can be converted into Xerox FRMs.
  • You cannot have FRM and MET files in the same MRL which have the same file name.


FAP2HTML

Use this utility to convert FAP files into dynamic HTML files.

Program names

  • Windows: FAP2HTML.EXE

Syntax

FAP2HTML /I /TS /D /X /INI

Parameter | Description
/I | The name of the FAP file. You can use wildcards, such as *.FAP.
/ts | Include this parameter to tell the utility to produce HTML output for TerSub paragraphs. TerSub is a pre-and post-edit function which selects and assembles pre-written, standardized paragraphs as a time-saving feature.
/d | Include this parameter to include output that can help you diagnose any problems that occur.
/X | The name of the FXR file (font cross-reference file).
/INI | (Optional) The name of the INI file to use. The default is FSIUSER.INI.

This utility creates an HTML file for each FAP files you specify. The utility appends the extension HTM to the output files. You can then display the HTML files using a browser.

Keep in mind:

  • Dynamic HTML commands require Microsoft Internet Explorer 4.0 or later.
  • If the FAP form is complex, you may experience problems in older versions of Internet Explorer. To avoid such problems, use Internet Explorer 6.0 or later.
  • Using absolute positioning, dynamic HTML commands make the HTML page the exact size of the FAP page. This means you cannot zone the HTML file in a browser.
  • A multipage FAP file is converted into multiple HTML files, one for each page. Pages have _p# appended to the FAP file name with the HTM extension. For example, the first page has _1 appended to the end of the FAP file name with the HTM extension. The second page has _2 appended to the end of the FAP file name with the HTM extension, and so on.
  • True Type font names are retrieved from the FXR (font cross-reference) file. The computer used to display the output HTML files must have these same fonts or the output may differ.

The mapping to the True Type font occurs in the Window32Subs control group. Here you can specify, for example, a Times family font and map it to the True Type equivalent, Times New Roman. You do not have to change your FXR file, just make sure you have the correct mappings in the INI file.

  • This utility does not convert logos. It will, however, set up references to the logo file. You must use a graphics file conversion utility (not included) to convert the logo files into GIF or JPEG files.
  • To create TerSub paragraphs, include the /TS and /D parameters.


FAP2HTML INI Options

You can use these INI options to customize how the FAP2HTML utility works:

< PrtType:HTM >
  SplitText	 =
  Field		 =
  Text		 =
  TextMerge	 =
  Box		 =
  Barcode	 =
  Bitmap	 =
  ImagePath	 =
  ImageExt	 =
  Table		 =
  FieldFontFudge =
  DirLinks	 =
  CollapsePage	 =
  PageBreaks	 =
  HR		 =
  AllowInput	 =

Option

Description

SplitText

Use this option to specify the number of characters to output as a separate text label. If you set this set option to -1 (the default), each word is output as a separate word. If you set this option to zero (0), the system will not split the text.

Splitting the text on every character produces a better fidelity HTML file, but slows the performance of the utility and of the browser. The default value seems to produce good results. If you plan to later edit the HTML file, set this value to zero (0) so all the text is output together without positioning commands.

Field

Enter No if you want to omit this kind of objects from the HTML file. The default is Yes.

Text

Enter No if you want to omit this kind of objects from the HTML file. The default is Yes.

TextMerge

Enter No if you want to omit this kind of objects from the HTML file. The default is Yes.

Box

Enter No if you want to omit this kind of objects from the HTML file. The default is Yes.

Barcode

Enter No if you want to omit this kind of objects from the HTML file. The default is Yes.

Bitmap

Enter No if you want to omit this kind of objects from the HTML file. The default is Yes.

ImagePath

Use this option to specify the location of the graphics files. Use a relative path, such as /images/, so the reference to the logo will be output in the HTML file with the attribute

SRC=”images/GRAPH1BB.jpg”

Be sure to use this option if you keep the graphics in a separate directory on the web server.

ImageExt

Use this option to specify the extension to use for references to graphic files. The default is JPG. You will need to set this option to the correct value, if your bitmaps are converted into some other file format, such as GIF, PNG, or TIFF.

Table

Use this option to specify if the dynamic HTML absolute positioning should be used for the text. The default is No.

When HTML tables are used for text positioning, the FAP lines and boxes are not output and the fidelity of the output document is low.

Set this option to Yes to edit the HTML text after the conversion.

FieldFontFudge

Use this option to increase or decrease the font size for the input fields. The default is 0.535.

This option is necessary because browsers usually use fonts larger than the input fields, so the top or bottom of the text inside the input field is chopped off. When you use this option, the font size inside the input field is the font height times this value.

DirLinks

Use this option to add Next and Prev links on pages. The default is No.

CollapsePage

Use this option to eliminate white space between HTML pages. The default is No.

PageBreaks

Use this option to force a page break between pages during HTML print. The default is Yes.

HR

Use this option to display a line between HTML pages. You can configure the size, color and width. Here is an example:

HR = Size=2 Width=100% Color=Black

AllowInput

Set this option to Yes to enable variable fields for entry. The default is No.


FAP2MET

Use this utility to compile a FAP file into a pre-complied Xerox Metacode overlay. This utility generates a Metacode print file from a FAP file.

Program names

  • Windows: FAP2METW.EXE
  • z/OS: See the Documaker Installation Guide.

Syntax

FAP2METW /I /X /P /N /VF /SV /D /H /C /LB

Parameter | Description
/I | Enter then name of the FAP file (you can use asterisks as wildcards).
/X | Enter the name of the font cross-reference (FXR) file.
/P | Enter the INI file PrtType to use, such as XER.
/N | Enter the font ID to use to print the name of section, such as 11006.
/VF | Add this parameter to sample print with variable fields.
/SV | Add this parameter to save the MET file for the GenPrint program. Keep in mind you cannot use this parameter if you have the ImageOpt INI option set to Yes for floating sections which contain inline graphic (LOG) files.
/D | (Optional) Enter SF for short bind front page duplex, enter SB for short bind back page duplex.
/H | Add this parameter to use HMI.
/C | Add this parameter to use color in the MET file.
/LB | Add this parameter to override the default logical bottom for the form being normalized. To specify a different logical bottom value, include the parameter and a value, as shown here: /LB = value

This utility requires these files:

  • FSISYS.INI
  • the font cross-reference file (rel121.FXR)

Depending on the option flags, the print file may be a print-ready file or a pre-complied file for use with the GenPrint program.

In addition to the FAP file name, you must also specify the name of the font cross-reference file (rel121.FXR) used by the FAP file. To print the file, you must install Xerox versions of the fonts used in the FAP file on the printer.

Note The INI options for FAP2MET are in XEROXJDL control group in the FSISYS.INI file in version 8.0, and in PrtType:XXX control group in versions 8.5 and later.

This table shows the INI options which will work in the FSI environment:

Option | Setting
DJDEIden | A’@@@DJDE’
DJDEOffset | 0
DJDESkip | 8
JDLHost | IBMONL
JDLData | 0,255
JDLCode | NONE
JDLName | DFAULT
JDEName | DFLT
JDLRStack | 0,10,X’13131313131313131313’
JDLROffset | 0,9,X’121212121212121212’
JDLRPage | 1,5,X’FFFF26FFFF’
ImageOpt | No
PrinterInk | Blue
Environment | Win
OutMode | BARR
Note These settings must match those set in the JDL. The JDL is a compiled JSL installed on the Xerox printer as a resource. The JDL contains the print instructions for Xerox print jobs.


Running FAP2MET on z/OS

If you are running the FAP2MET utility on z/OS, set the Environment and OutMode options to:

Environment	=  MVS
OutMode		= JES2

This is based on definitions in the FSISYS.INI file. For example, in the INI file, you can set up different modes of Xerox printing by setting up different control groups, such as…

< PrtType:XER1 >
  DJDEIDEN = E’$$Xerox’
  OUTMODE = JES2
  .........
< PrtType:XER2 >
  DJDEIDEN = A’@@@DJDE’
  OUTMODE = BARR
  .........

When you want to send the FAP2MET output to the printer via JES2, you could provide /P= XER1, or if your output is going through BARR, you could provide /P = XER2 to select proper paragraph. If you omit the /P parameter, it defaults to XER.

The /D parameter provides short edge binding duplex functions. /D=SB means the section is to be compiled for short edge binding as a back page. This forces the text to be printed in inverse portrait mode. Your FXR file should have the corresponding font names suitable for inverse portrait mode. /D=SF means the section is to be compiled for short edge binding as a front page. The default is SF.

The /VF parameter creates Metacode which can be sent to the printer immediately for sample printing, with all field positions indicated with XXXX strings. The name of the form is printed at the bottom right corner, using the font ID you specified with the /N parameter. Check your FXR file, and make sure the font ID is assigned to a suitable font.

Note Do not use this parameter if you are precompiling Metacode files in preparation to run the GenPrint program.

The /SV parameter creates an intermediate form of Metacode which can not be sent to the printer directly, but which at GenPrint time, gets merged with field data and gets converted into proper Metacode. This combined Metacode is then sent to the printer. Therefore, if you are creating the Metacode files as precompiled Metacode files to be used in GenPrint process, use /SV parameter. In the absence of either of these flags, a sample print Metacode is generated without the XXXX strings.

If you add an H to either the /VF or /SV parameters (/VFH or /SVH), the system generates a more efficient Metacode output by combining several Metacode records into one, reducing the output file size. You can also specify this option as a separate standalone parameter (/H).

Note This feature is available only for portrait mode printing.

Use the /C parameter when you want to print the compiled instream Metacode on a 4850 or 4890 highlight color printer, and some elements of the form have a color specification. (Be sure to set PrinterInk option to whatever ink is installed on the printer. Also, the SendColor option must be set to Yes).

Note The PrinterInk option supports red, blue, green, ruby, violet, brown, gray, cardinal, royal, cyan, and magenta.


Parameters passed via the PARM=‘ ‘field (MVS/JCL)

In earlier versions (before 8.5) of the FAP2MET utility, these parameters were passed in the PARM=‘ ‘field: fapfilename, SAVE or TEMPLATE, and USEHMI.

The parameters are identical in both environments. The only difference is that an extra backslash (/) must precede the list of parameters. A typical EXEC statement in a FAP2MET run JCL would be:

//FAP2MET EXEC PGM=FAP2MET,PARM=‘/ /I=fapfile /P=XER /VFH /C’


Producing Normalized Metacode

You can use the FAP2MET utility to produce normalized Metacode files. To produce a normalized Metacode file, you must add these INI settings to your FSISYS.INI file:

< Control >
  Normalize = Norm
< PrtType:Norm >
...

Option

Description

Normalize

Specify the PrtType control group you want the system to use when it normalizes the files. For instance, if you create a control group called PrtType:Norm to contain the option you want the system to use when it normalizes Metacode files, enter Norm.

If the control group you specify is missing or does not appear to be a Xerox printer group (Class=XER) you will receive errors.

Note Typically, the Class option is not explicitly set in the INI file. The Class name is normally derived from the first three letters of the Module option. If the Module is not XERW32, and you want the system to think the control group is a Xerox print group, you must set the Class option to XER.

You can also use the /LB parameter to override the default logical bottom for the form being normalized. To specify a different logical bottom value, include the parameter and a value, as shown here:

/LB = value

Note You only use the /LB parameter when normalizing files.


GenPrint Program Notes

The INI options required for the GenPrint program are the same as those needed by the FAP2MET utility. In addition, there are other parameters which affect printing on Xerox printers. In the Print control group, or in the PrtType:XER control group,

CompileInstream = Yes or No

and in the RunMode control group,

DownLoadFAP = Yes or No

The CompileInStream=Yes and DownLoadFAP=Yes options load all of the FAP files in memory when the GenPrint program runs. This is slow, and is typically used only during testing and development. This mode does not need precompilation of FAP files into intermediate Metacode files.

For production environments, use the CompileInStream=No and DownLoadFAP=No options. This mode requires that you precompile the FAP files using the FAP2MET utility with the /SV parameter.

The precompiled Metacode files must be available to the GenPrint program in the MSTRRES\FORMS directory in Windows, or in a PDS which is assigned to the PMETLIB DD statement on z/OS.


Multiple Page FAP Files

You can use the FAP2MET utility with multiple page FAP files. For example, if TEST.FAP contains 10 pages, FAP2MET will build 10 pre-compiled met files. These files will be used by the GenPrint program as each page is printed.

You can also use the FAP2MET utility to produce a test print version of a MET file, otherwise known as a print-ready file. This file is only to be sent to the printer. It is not to be used with the GenPrint program. This type of file is produced when you omit the /SV parameter.


FAP2OVL

Use the FAP2OVL utility to compile a FAP file into an overlay for an AFP printer.

Note

  • You can perform this task using the Compile Sections to Print Files option in Studio’s Conversion wizard. You can also use the OVLCOMP utility.
  • You can also create overlays using the Studio’s Conversion option.

Program names

  • Windows: FAP2OVLW.EXE
  • z/OS: See the Documaker Installation Guide.

Syntax

FAP2OVLW /I /X /VF /O /C /R /INI /NO

Parameter | Description
/I | The FAP file you want to compile. Omit the extension. You can use asterisks as wildcards to select multiple files.
/X | The font cross-reference (FXR) file. Omit the extension. You can enter an absolute (d:\dap\myinc\mstrres\rel110) or relative path (..\mstrres\rel110).
/VF | Add this parameter to print variable fields.
/O | Specifies the output directory. You can enter an absolute d:\dap\my\mst\ovllib) or relative path (..\mstrres\ovl).
/C | Add this parameter if the AFP overlay should use color. Enter one of the named AFP colors such as blue, red, magenta, green, cyan, yellow, dark_blue, orange, purple, dark_green, dark_cyan, mustard, gray, or brown. For details, see Printing in Color .
/R | Enter 240, 300, or 600 to indicate the resolution in dots per inch (DPI). The default is 240. Use this parameter to support producing AFP overlays using 240, 300, or 600 DPI for coordinates and bitmap data produced when using inline graphics. Documaker Studio can produce AFP output (print streams and normalized AFP files) using either a 240 or 300 DPI coordinate system.
/INI | Specifies an INI file which contains additional parameters. You can enter an absolute (d:\dap\myinc\mstrres\fsisys.ini) or relative path (..\mstrres\fsisys). The file name does not have to be FSISYS.INI.
/NO | Add this parameter if you want the FAP file name at the bottom but no fields.
Note This utility is not case sensitive.

The FAP2OVL utility generates an AFP OVL overlay printer resource file from a FAP file. In addition to the FAP file name, you must also specify the font cross-reference (FXR) file used by the FAP file.

The /VF parameter prints the FAP file name at the bottom of the page using font ID 3001, and fills all variable fields on the FAP with X characters. The /NO option only prints the FAP file name at the bottom of the page using font ID 3001. These options are useful when you are developing and proofing your implementation.

Note Do not use the /VF or /NO options when you are creating an overlay (OVL) file for production print use.

After a production quality overlay file is generated, you have to make it available to the PSF2 by copying it to the print server and add it to the PSF2/ Librarian database.

On z/OS, the overlay has to be copied into a PDS, which is attached to the OVERLIB DD statement in the PSF PROC, or a PDS which is assigned to the USERLIB= parameter, on the OUTPUT statement in the job JCL. After all the required overlays are installed on PSF2 or PSF, run the GenPrint program with this INI option:

SendOverlays = Yes

The spool file the GenPrint program creates will include calls to merge those overlays as needed.


Printing in color

Include the /C parameter in the FAP2OVL utility if the AFP overlay should print in color. AFP highlight color printing on printers from Xerox and Oce is supported. Before using this feature, make sure the:

  • SendColor INI option is set to Yes.
  • Objects you want to print in color (text, lines, shades, and so on) are set to print in color. The Print in Color option is on the Color Selection window. You can display this window by clicking the Color button on the object’s Properties window.

The system maps the RGB (red,green,blue) color setting for each object to the closest AFP named color. The default AFP named colors are blue, red, magenta, green, cyan, yellow, dark_blue, orange, purple, dark_green, dark_cyan, mustard, gray, and brown.

Use the NamedColors option to tell the system to use only specific AFP named colors:

< PrtType:AFP >

NamedColors = blue

For example, if you wanted all highlight (non-black) colors mapped to blue, you would set the NamedColors option to blue, as shown above.

To allow the mapping of the colors you assigned to the objects in the FAP file to multiple colors, separate each color with a semicolon (;). For example, to use all of the default AFP named colors except brown, set the NamedColors option as shown here:

NamedColors = red;blue;magenta;green;cyan;yellow

The order of the named colors does not matter.


FAP2PDF

Use the FAP2PDF utility to convert FAP files into PDF files. To produce a PDF file from a FAP file, you must also supply an FXR file. The FXR file determines what fonts are used in the PDF files the utility produces.

The utility looks in the PDF printer control group in your FSISYS.INI file for options that tell it how to create the PDF file. These options let you include bookmarks, embed fonts, use internal fonts, and so on.

Note You can use the /INI parameter to specify the INI file that contains the PDF printer control group and you can use the /P parameter to specify the actual name of the PDF printer control group. For information about the INI options you can use to customize PDF output, see Using the PDF Print Driver.

FAP2PDF /I /X /INI /P /VF

Syntax

Parameter | Description
/I | Enter the names of the FAP files you want to convert into PDF files. You can use wildcard characters (*). You do not have to specify the .FAP extension.
/X | Enter the name of the FXR file you want to use. The FXR file determines which fonts are used in the PDF file. You do not have to specify the .FXR extension.
/INI | (Optional) Enter the name of the INI file that contains PDF settings. The default is FSISYS.INI.
/P | (Optional) Enter the name of the PDF PrtType control group in the FSISYS.INI file. The default is PDF.
/VF | (Optional) Include this parameter if you want to template fields.

If the FXR and INI files specify that you want the fonts embedded, the INI file must contain a FontLib option in the MasterResource control group that specifies the directory of the TrueType or PostScript fonts.

Note To see a list of the FAP2PDF parameters, run the utility with no parameters.


FAP2RTF

Use the FAP2RTF utility to convert a FAP file into an RTF file that can be used, for instance in a word processor such as Microsoft Word.

Syntax

FAP2RTF /I /X /INI /D /P /O

Parameter | Description
/I | Enter the name of the FAP file you want to convert. If the name of the FAP file includes spaces, enclose it in quotation marks, as shown here: /I="forms/form name with spaces.fap"
/X | Enter the name of the corresponding FXR file (REL121.FXR).
/INI | Enter the name of the INI file which contains the options for this utility.
/D | (Optional) Include this parameter to specify a directory for the output files.
/P | (Optional) Use this parameter to specify the PrtType control group you want the utility to use. The default is RTF.
/O | (Optional) Enter the name for the output RTF file. If you omit this option, the system uses the name of the FAP file and adds the RTF extension.

Here is an example:

fap2rtf /i=q1addr.fap /x=rel121.fxr /ini=fapcomp.ini /o=test.rtf

This example shows how you can use wild cards:

fap2rtf /i=*.fap /x=rel121.fxr /ini=fapcomp.ini

Wild cards are not supported if you also use the /O parameter.


FAP2RTF INI File Settings

The following control groups and options are required for the FAP2RTF utility.

< Printer >
PrtType	= RTF
Option | Description
PrtType | Enter a name such as RTF.
< Printers >
PrtType	= RTF
Option | Description
PrtType | Enter the name you entered for this option in the Printer control group.
< PrtType:RTF >
  Module	= RTFW32
  PrintFunc	= RTFPrint
  Device	= c:\frame.rtf
  PageNumbers	= Yes
  AllowInput	= Yes
  EmptyHeaders	= Yes
  EmptyFooters	= Yes
  WriteFrames	= No
  BmSub		= Yes
  BmSubChar	= _
  TemplateFields = Yes,Enabled
  SendColor	= Yes,Enabled
Option | Description
Module | The DLL name of the RTF driver.
PrintFunc | Enter the function name of the print function.
Device | Enter the name of output file when printing from Studio.
PageNumbers | Enter Yes to print page numbers on each page. The default is No.
AllowInput | Enter Yes to enable form fields. The default is No.
EmptyHeaders | Enter Yes if you want empty headers in the RTF file. The default is No.
EmptyFooters | Enter Yes if you want empty footers in the RTF file. The default is No.
WriteFrame | Enter No if frames are not required. The default is Yes.
BmSub | Enter No if you do not want to replace invalid characters. The default is Yes.
BmSubChar | Enter character to use when invalid characters are substituted. The default is the underscore ( _ ).
TemplateFields | The default, Yes, tells the system to test print Xs in variable fields. If you also include Enabled (Yes,Enabled), the Template Variable Fields field in Studio is checked.
SendColor | Enter Yes to print in color. The default is No. If you also include Enabled (Yes,Enabled), the Send Color field in Studio is checked.

If you chose to allow form fields, you may also need to include the WordTimeFormats and WordDateFormats control groups. You can use these control groups in case you are using a time or date format in Documaker that has no equivalent in Word. The following groups and options let you map a Documaker format to a Word format.

< WordTimeFormats >
  hh:mm XM =
< DateTimeFormats >
  bD/bM/YY =

To the left of the equal sign, you list the Documaker format used on the section. To the right, you list the Word format you want to use.


FAP2XML

Use the FAP2XML utility to convert a FAP file into an XML file.

You can use this utility to prepare snippets of FAP files for editing in iPPS. You can also use it to get a list of the fields in a section or form. This is useful when you are creating your own iPPS user interface or data feeds based on forms in your MRL.

Note This utility is intended for iPPS manuscripting support and is not used by the Documaker system. Neither IDS or Documaker Studio can read the resulting file and turn it into a FAP or NA file.

Program names

  • Windows: FAP2XMLW.EXE

Syntax

FAP2XMLW /i=FAPFile /o=XMLFile /x=FXRFile /ini=INIFile

Parameter | Description
/I | (Optional) Enter the name of the FAP file.
/O | (Optional) Enter the name you want assigned to the XML file. The default is the name of the FAP file with an XML extension.
/X | Enter the name of the font cross-reference file (FXR) file.
/INI | (Optional) Enter the name of the INI file which contains settings for this utility. The utility looks in the MasterResource control group find the location of FAP and other files.
Note If you want to convert a specific version/revision of the form, be sure to extract the desired version/revision of that form. Then use this utility to generate the XML file.


FD2HTW32

Use this utility to convert a FORM.DAT file into an HTML page.

Syntax

fd2htw32 [-i=<formdef>] [-ini= <inifile>] [-o=<outfile>] [-d=<dirname>]

Parameters

Parameter | Description
i | The form definition file from which to read. Defaults to the FORM.DAT file.
ini | The initialization file from which to read. Defaults to the FSIUSER.INI file.
o | The name of the output HTML file.
d | The name of the web server directory.


FDT2CFA

Use the FDT2CFA utility to convert all of the FAP files listed in a FORM.DAT file into compiled FAP files. By pre-compiling your FAP files, you can speed processing.

Note The version of the system you use to compile the FAP and FXR files must be the same version you will use when running Documaker Server. Furthermore, the platforms must also match. For instance, if you compile the FAP and FXR files on version 11.0 for Windows, to use them in Documaker Server (GenTrn, GenData, GenPrint), you must run version 11.0 for Windows of Documaker Server.

Program names

  • Windows: FDT2CFAW.EXE

Syntax

FDT2CFAW /INI /I /F /L /O

Parameter | Description
/INI | The input FSIUSER.INI file.
/I | The input FORM.DAT file.
/F | The input font cross-reference (FXR) file.
/L | The input FAP file library.
/O | The output CFA file library.

This utility lets you compile all of the FAP files in a FORM.DAT file at a time. To compile individual FAP files, see FAP2CFA. To convert a CFA or CFX file back into a FAP or FXR file. see CFA2FAP.

Make sure the CompiledFAP option is set to Yes (the default) in the RunMode control group of your INI files before you run the system using precompiled FAP files.

In addition, use the File, Library Setup option (or edit your INI files) to specify the path for the CompLib, which is where the system will look for the compiled files. In your INI files, you will find this setting in the following control group:

< MasterResource >
  CompLib = (directory the CFA and CFX files are stored in)

For z/OS systems, you can specify a DD name, such as DD:COMPLIB()

Note If you are going to use pre-compiled FAP files, you must also use compiled FXR files.


FDT2DB

Use this utility to create a cross-referenced database of your master resource library (MRL) forms, sections, and fields. You can use the resulting database to query this information from within any appropriate database tool. For instance, you can use this information to:

  • Build basic reports, such as a field usage report
  • Design import/export files for interfacing to other systems
  • Create files for use with Transall

The utility uses the FORM.DAT or BDF (Business Definition File) file to extract resource information into a database file, with tables for the library, form group keys, global recipients, form groups, forms, sections, linked recipients, and fields.

Note Rules are not converted.

The utility reads the entire MRL, but if the resource is not listed in the FORM.DAT or BDF file, the utility does not include it.

Program names

  • Windows: FDT2DB.EXE

Syntax

FDT2DB /INI /I /BDF /PURGE

Parameter | Description
/INI | (Optional) Tells the utility which INI file to use. The default is the FSIUSER.INI file. The information in the INI file tells the utility where to find the master resource library (MRL).
/I | (Optional) The name of the input file. If you omit this parameter, the utility defaults to FORM.DAT. If you enter a file name but omit the extension, the utility defaults to DAT — unless you include the /BDF parameter, in which case it defaults to BDF. If you omit the extension, include the period at the end of the file name.
 | (Optional) Tells the utility to use the Business Definition (BDF) file instead of the FORM.DAT file. You must include this parameter if you want the utility to use a BDF file when it converts resources.
/Purge | (Optional) Tells the utility to remove the current table data before it repopulates the database with data from the BDF or FORM.DAT file.

You can run this utility multiple times. Be aware, however, that if you run it multiple times, data may be duplicated and you may have unnecessary records in the database. To remove unnecessary records, include the /Purge parameter. This tells the utility to remove all records from the database before opening the input file. After the purge, only records from the input file are in the database file.

Specifying the database

Use the following INI options to specify the database you want to use:

< DBHandlers >
  DBHandler = ODBC

You cannot run this utility without the DBHandler option. The DBHandlers control group defines the ODBC available to the system. With this option, you can name the ODBC anything you want.

< DBHandler:ODBC >
  Server = DMS1

The Server option is referenced by the DBHandler option. The utility searches for the DBHandlers:XXXX (XXXX being the selected ODBC) for Server option. If you omit these options and choose to use a blank database, the utility uses the default table DFDs.


Creating a Database

You can create an ODBC database and use Windows’ Control Panel to open the ODBC applet and add a new database connection by following these steps:

Note To use the new database, remember to set up the Server option in the INI file.
  1. Open Windows’ Control Panel. Double-click the ODBC Data Sources icon.
  2. On the User DSN page (the first page), click Add. The next page that appears should have the Microsoft Access Driver selected. If not, select it and click Finish.
  3. On the next window, enter a name for your database in the Data Source Name field. Then click Create.
  4. On the File window, move to the directory where you want the database created. Enter the database file name. This does not have to be the same name as the Data Source Name. When you finish, click Ok. You should now see the database name above the buttons in the Data Source Name window. Click OK again.

Now you see the list of databases window again and your new database should appear in the list. Click Ok to close the window.

Note For Windows 2000, first select Administrative Tools which takes you to another window that contains the ODBC Data Sources icon.
  5. Edit the FSIUSER.INI for the new database. Add these lines (assuming its name is DMS1):
    < DBHandler:ODBC >
    Server = DMS1

The Server option defines the Data Source Name you used to name the database, not the file name of the database.

  6. Run the utility in the directory where your INI files reside. When it finishes, you should be able to open the database using Access to see that it is populated.


Using an Existing Database

If you use an existing database, make sure the tables are in the following formats:

Library table

Key | Type | Description
LibraryName | Text (32) | Short name to identify a library set. This relates a name to a path where the rest of the tables reside.
LibraryDescription | Text (50) |
LibraryPath | Text (255) | MRL library path

FormGroupKeys table

Key | Type | Description
KeyType | Text (3) | For example, 001 = key 1 (such as company), 002 = key 2 (such as line of business).
KeyName | Text (30) | Key name used in the FormGroups table.

GlobalRecipients table

Key | Type | Description
RecipName | Text (30) | Short recipient name.
RecipDescription | Text (50) | Longer description.
RecipCode | Text (20) | Used in some print sorting.
Recip_ID | Number | Unique ID. Used to link recipients.

FormGroups table

Key | Type | Description
GroupName1 | Text (30) | Such as a company. Must be an entry in the FormGroupKeys table where KeyType = 001.
GroupName2 | Text (30) | Such as a line of business. Must be an entry in the FormGroupKeys table where KeyType = 002.
GroupName3 | Text (30) | Such as a recipient. Not yet supported. When supported, this value must be a name in the GlobalRecipients table.
Group_ID | Number | Unique ID. Used to group forms within the Forms table

Forms table

Key | Type | Description
Group_ID | Number | Key from the FormGroups table
FormName | Text (30) |
FormEffectiveDate | Date/time |
FormDescription | Text (50) |
FormOptions | Text (20) |
FormRevInfo | Text (20) | Reserved for future use.
Form_ID | Number | Unique ID. Used to group sections in the Images table.

Images table

Key | Type | Description
Form_ID | Number | Key from the Forms table.
FormSequence | Number | The order within the form.
ImageName | Text (30) | The section name.
ImageEffectiveDate | Date/time |
ImageDescription | Text (50) | The section description.
ImageOptions | Text (20) |
ImageRevInfo | Text (20) | Reserved for future use.
Image_ID | Number | Unique ID. Used to group fields in the Fields table.

LinkedRecipients table

Key | Type | Description
RecipScope | Number | Contains 0=image, 1=form, 2=group
Referring_ID | Number | Form_ID, or Image_ID, or Group_ID
Recip_ID | Number | The key from the GlobalRecipients table.
RecipCopyCount | Number |

Fields table

Key | Type | Description
FieldScope | Number | 0=image, 1=form, 3=form set
Referring_ID | Number | 0=global, else, Form_ID or Image_ID
FieldName | Text (32) |
FieldType | Text (20) |
FieldFormat | Text (20) |
FieldLength | Number |

INI options

Also, if you use an existing database and the tables are already created, make sure you have these INI options set up:

< ODBC_FileConvert >
FrmGrpKy = FormGroupKeys
GlbRec   = GlobalRecipients
FrmGrps	 = FormGroups
LnkRcps	 = LinkedRecipients

These are necessary because some types of databases do not like tables with long names.


FDT2EDL

Use this utility to generate EDL output from a FORM.DAT file. You can use this utility to read a FORM.DAT file and convert an master resource library (MRL) into a Documerge EDL file.

Note An EDL file serves the same function in the Documerge system as an FDT file does in the Documaker system.

Program names

  • Windows: FDT2EDL.EXE

Syntax

FDT2EDL /INI /O /N

Parameter | Description
/INI | Enter the path and file name of FSIUSER.INI file.
/O | Enter the drive and path of output directory.
/N | Enter the name of output file you want to create.

For each line in the FORM.DAT file, the sections are parsed and a group of entries are written out for each section.

Output [*<edlname>*] required section header-<edlname> supplied by command line /N parameter

[ChnDir=<edlpath>\] directory location of chain files, with trailing backslash

The following entries are written for each section:

[<membername>]
  1+Info=ED=YYYYMMDD,MD=YYYYMMDD,DTN=0,Desc=36 spaces
   HiRev=n
  1+CHNS=

Where...

Component | Description
[*<edlname>*] | The output EDL name supplied via command line parameter
[ChnDir=<edlpath>] | The output directory supplied via command line parameter.
[<membername>] | The name of the section (FAP) for the form in the FORM.DAT file
ED | YYYYMMDD is the current date
MD | YYYYMMDD is the current date
DTN | Is always zero
Desc | 36 spaces
HiRev | Is always 1
1+CHNS | An entry with no value

The utility returns success or failure. The following errors may occur:

  • Output path was not specified
  • Output file name was not specified
  • Could not open the FSIUSER.INI file
  • Could not open the FORM.DAT file
  • Could not open the output file


FILE2IDS

Use this utility to read a text file which contains a series of requests and submit those requests to IDS. Each line of the text file equals one request. You specify the request type on the command line and the attachment variables are created from each line in the input file in this manner:

  • Each line is broken into 1000 byte chunks (1000 is the default size, you can set the size using the /L parameter)
  • Each chunk is added as attachment variable RECORDLINEXX, where XX is the sequence number of the chunk.

The attachment variable RECORDPARTS specifies how many chunks are added.

Note The FILE2IDS is a Visual Basic program. You must have a VB runtime installed to run this program. You can click the Help button when you run FILE2IDS to see a summary of the various parameters.

To run the FILE2IDS utility, enter this command:

file2ids /C /D /I /L /K /R /T /Name /W

Parameter | Description
/C | Specifies the value of the CONFIG attachment variable
/D | Set to On to turns on the debugging window and wait for the result from IDS.
/I | The name of the file
/K | Enter Y or N to have the system wait or not wait for a key to be pressed in the debug window.
/L | Specifies the line length. The default is 1000.
/R | The request type. The default is Email.
/T | The length of time in milliseconds before IDS times out. The default is 15000.
/Name | Lets you pass a name and value to the IDS rule in this format: /Name=Value For instance, /ABC=BCD adds the attachment variable ABC with the value BCD.
/W | The length of time in milliseconds IDS will wait before retrying. The default is 1000.

All parameters are passed in with the equal sign (=). Here is an example:

/I=file.txt

If you run the utility with no parameters, it displays a window which lets you then enter the parameters shown above.

The utility returns one of the following values:

Value | Description
0 | The utility completed its task and no errors occurred.
1 | No input file information was found.
2 | The utility was canceled before it ran. Typically, this indicates you clicked Exit on the window which asks for the parameters.
3 | Other error.


FIXFNT

Use this utility to test and fix Xerox fonts so you can use them with optimized Metacode. If you notice that text prints in the wrong location on the page when a Metacode print stream is optimized but prints correctly when not optimized, you may be using a font that needs to be corrected.

See METOPT for more information about optimizing Metacode print streams.

Note Docuview, which is part of Docusave Workstation, requires Xerox resources to be padded to fill 512 byte blocks. This includes Xerox fonts. Some old Xerox fonts built with prior versions of the system do not meet this criteria. You can use this utility to read and update those Xerox fonts so they can be used by Docuview.

Program names

  • Windows: FIXFNTW.EXE

Syntax

FIXFNT /I /T

Parameter | Description
/I | The name of the FNT file. You can use asterisks (*) as wildcards.
/T | Add this parameter if you only want to test the Xerox font.

Use the /T option to test any Xerox font to see if it can be used with Metacode optimization.

Once this utility finishes, download the corrected fonts to the printer to eliminate the problem.

Note Before version 10.0, graphics converted to Xerox fonts contained font specification table entries that prevent them from being used with Metacode optimization. In most cases, this is not an issue if LOG files are placed on forms. To cause a problem with Metacode optimization, you must use a text label instead of a LOG file for printing a signature or graphics file and the Xerox signature font must be inserted into the FXR file.


FIXFORM

Use the FIXFORM utility to make changes and correct problems in FAP and DDT files. This utility is often used when converting older FAP files into a newer format. You can also use it, for instance, to check DAL script syntax and perform other tasks such as reassigning font IDs, and modifying text rectangle coordinates which define the space reserved for text.

Note

  • DDT files were used in legacy Documaker implementations. Master resource libraries (MRLs) created with Documaker Studio do not use DDT files.
  • You can perform this task using the Change Multiple Sections (FAPs) option in Studio’s Conversion wizard.

Program names

  • Windows: FIXFMW32.EXE

Syntax

FIXFMW32 /I /X /O /SHRINK /SS /SX /G/P

Parameter | Description
/I | Enter the name of the FAP file.
/X | Enter the name of the font cross-reference file (REL121.FXR).
/O | Enter the name of the output FAP file if different. Omit the extension.
/SHRINK | Include this parameter to shrink the FAP file to a custom size. This parameter tells the utility to remove all of the white space from the bottom, right-hand side of the section.
/SS | Include this parameter to check field DAL script syntax.
/SX | Include this parameter to check field DAL script syntax and attempt to correct errors.
/G | Include this parameter to load global bitmaps (LOG files).
/P | Enter the name of the INI file.

You can also include these conversion options:

Option | Description
/A | Convert all colored objects to print in color
/C | Combine text elements. The utility defaults to combining text elements if the space between those elements is less than 99% of the width of the space character. You can also specify the percentage. For instance, /C50 tells the utility to combine the text elements into a single text element if the distance between them is less than 50% of the width of the space character.
/M | Map alternate fonts
/K | Map alternate characters
/N | Fix negative coordinates
/B | Widen text areas as needed to prevent word wrapping that could occur when performing tasks such as re-mapping fonts. Use /B to check the form to see if the text in the text area exceeds the right boundary of the text area. If it does, the FIXFORM utility adjusts the right edge of the text area to be one FAP unit greater than the right edge of the text — as long as that adjustment does not extend the text area beyond the edge of the page. This keeps existing text areas from wrapping differently. This parameter does not tell the utility to contract the right edge, but only to expand it if necessary.
/R | Fix rectangle coordinates using font information. Use /RT to preserve top coordinates. Use /RB to preserve bottom coordinates. You would typically use /RB.
/E | Examine coordinates for overlap.
/L | Adjust x coordinates for 1/4 in. left margin.
/T | Adjust y coordinates for 1/6 in. top margin.
/S | Convert DAL calcs to DAL script statements.
/U | Make field names unique.
/Y4 | Force all date field formats to use a four-digit year.
/D | Delete all fields.
/ROTATE90 | Rotate 90 degrees to left.
/NOFIXDIMS | Do not fix dimensions (for custom size sections).
Note If you omit an option, the system omits that task, unless the option is turned on in the INI file. The settings in the INI file override command line parameters.


Setting Up FIXFORM.INI

You can enter some parameters from the command line, while others must be set in an INI file. The /P parameter specifies the name of the INI file, usually FIXFORM.INI.

To use the FIXFORM utility you must have a FIXFORM.INI and an FXR file. The FXR file must be specified in the parameter list to change font information. When you use the File, Convert, Multiple FAPs option, instead of this utility, be aware that any FIXFORM headings in the FAPCOMP.INI file will be used instead of those in the FIXFORM.INI file. Therefore, you should set up the INI settings in only one INI file.

Here is an example of a FIXFORM.INI file. This example shows all of all the options for the FixOptions control group.

< FixOptions >
  FixRect = No
  CombText = No
  MapFonts = Yes
  MapChars = No
  FixLeftMargin = No
  LeftMargin = 0
  FixTopMargin = No
  TopMargin = 0
  DeleteFields = No
  ChkRect = Yes
  Color = No
  FixRectSaveBottom = No
  FixNegative = No
  Rotate90 = No
  FixCalcs = No
  YearDigit4 = Yes
  UniqueFieldNames = No
  FixDALCheck = No
  FixDALSyntax = No
< MasterResource >
  DefLib  = \fap\mstrres\sampco\deflib\
  FormLib = \fap\mstrres\sampco\forms\
  FontLib = \fap\mstrres\sampco\deflib\
  FxrFile = rel121
< MappedFonts >
  1    = 22010
  10   = 22008
  16   = 22008
  1006 = 21006
  1007 = 21007
  1008 = 21008
  1009 = 21009
  1010 = 21010
  1011 = 21011
  1012 = 21012
  1014 = 21014
  1016 = 21016
  1018 = 21018
  1024 = 21024

(and so on…)

 < MappedChars >
   65 = 18
   69 = 22
   70 = 23
   73 = 26
   74 = 27
   75 = 28

(and so on…)

This example shows how to use the SX option to check DAL script syntax and correct errors. Note the second line of output. This line tells you that an attempt to correct the DAL syntax will be made.

fixfmw32 /i=ca2071 /x=rel121 /p=fixform /sx

Here is a sample of the output:

** Check field DAL syntax **

** Attempt DAL syntax correction **

Successful load of D:\FixForm - Feature 1371\deflib\rel121.FXR
Successful load of D:\FixForm - Feature 1371\formlib\Ca2071.FAP
DAL Syntax error on field <VEHICLE NO.>
Error 11:Invalid IF statement last token [end] at line 1 column 25
Orig: return jcenter (@(), 9);end;
Mods: return jcenter (@(), 9);;
Successful unload of D:\FixForm - Feature 1371\formlib\ca2071.FAP

The Mods line tells you how the DAL script syntax was modified.

Here is another example:

fixfmw32 /i=ca67a /x=rel121 /p=fixform /sx

Here is a sample of the output:

** Check field DAL syntax **
 ** Attempt DAL syntax correction **
Successful load of D:\FixForm - Feature 1371\deflib\rel121.FXR
Successful load of D:\FixForm - Feature 1371\formlib\Ca67a.FAP
DAL Syntax error on field <NBR OF AUTOS>

Error 11:Invalid IF statement last token [(EOF)] at line 1 column 102

Orig: IF Numeric (@()) then return (jcenter(format(@(),"n","zzz,zzz,zzz"),11));else return jcenter (@(),11)

Successful unload of D:\FixForm - Feature 1371\formlib\ca67a.FAP

Here, the Mods line does not exist. The utility detected the DAL syntax error but did not know how to correct it. You must correct this error.

This example shows how to use the SS option to check DAL script syntax:

fixfmw32 /i=ca2071 /x=rel121 /p=fixform /ss

Here is a sample of the output:

** Check field DAL syntax **
Successful load of D:\FixForm - Feature 1371\deflib\rel121.FXR
Successful load of D:\FixForm - Feature 1371\formlib\Ca2071.FAP
DAL Syntax error on field <VEHICLE NO.>
Error 11:Invalid IF statement last token [end] at line 1 column 25
    Orig: return jcenter (@(), 9);end;
DAL Syntax error on field <VEHICLE NO. #002>
    Error 11:Invalid IF statement last token [end] at line 1 column 25
    Orig: return jcenter (@(), 9);end;
DAL Syntax error on field <VEHICLE NO. #003>
    Error 11:Invalid IF statement last token [end] at line 1 column 25
    Orig: return jcenter (@(), 9);end;
Successful unload of D:\FixForm - Feature 1371\formlib\ca2071.FAP

The second line of output tells you that the utility will only check for DAL syntax errors.


FIXFXR

Use this utility to renumber or delete font IDs in a font cross-reference (FXR) file.

Program names

  • Windows: FIXFXR.EXE

Syntax

FIXFXR /I /O /P

Parameter | Description
/I | Enter the name of the input font cross-reference (FXR) file.
/O | Enter the name of the output FXR file if different. Omit the extension.
/P | Enter the name of the INI file. The default is FIXFXR.INI.

You can use this utility to maintain font cross-reference files (FXR) by renumbering or deleting font IDs. This utility takes a FXR file as an input file and then updates or creates a new FXR file based on settings in an INI file.

This utility works similarly to the FIXFORM utility .

The /P parameter specifies the INI file name. The default is FIXFXR.INI. Here is an example of a FIXFXR.INI file:

< FixOptions >
  MapFonts = Y
  DeleteFonts = Y
< MappedFonts >
  1 = 12304
  2 = 12305
  3 = 12306
  4 = 12307
< DeletedFonts >
  11004 = Y
  11005 = Y
  11006 = N
  11007 = Y
  11008 = N

In this example, font IDs 1 through 4 are renumbered to 12304-7 and font IDs 11004, 11005, and 11007 are deleted from the font cross-reference file (FXR).


FIXOFFS

Use this utility to recalculate file offsets when you move files from one platform to another. This utility determines the new offsets within the NAFILE.DAT and POLFILE.DAT files and updates the other output files accordingly. For example, you must use this utility if you are running the GenArc program in a z/OS environment using a local area network (LAN) archive of z/OS-generated data.

This utility corrects offsets in the NEWTRN.DAT file (path and file name given in INI file) and any number of recipient batches specified in Fix_Batches control group. The location of the NEWTRN.DAT file is specified in the INI files. If the Fix_Batches control group is undefined, this utility updates all of the recipient batches defined in the Print_Batches control group.

Note You can also use this utility to fix offsets in a VSAM NAFILE and POLFILE. To indicate that the NAFILE and POLFILE are VSAM files, use the /V parameter.

Program names

  • z/OS: FIXOFFS
  • Windows: FIXOFW32.EXE

Syntax

FIXOFW32 /O /INI /V /L

Parameter

Description

/O

Tells the utility to override the setting for the Outpath option in the FixOffsets control group with the path name you enter.

/INI

Tells the utility which INI file to use.

/V

Tells the utility that the NAFILE and POLFILE are VSAM files. If you omit this parameter, the utility checks for the NAFILE=DD:NAVSAM option in the VSAM control group. If the utility finds this INI option, it processes the NAFILE and POLFILE as VSAM files.

/L

Activates logging. The name you specify overrides the default log file name. If you include the option without specifying a file name, the utility uses the name specified in the INI file. If omitted from the INI file, the utility defaults to FIXOFFS.LOG.

When the LOG is activated the utility lists each transaction processed, showing the fields you specified in the LogFields option in the FixOffs control group.


Defining Parameters by Order

You can include parameters without dashes or slashes. The FIXOFFS utility assigns the parameters in this order if you omit the dashes (-) or slashes (/).

  1. INI file
  2. Output path
  3. Log file

For example, if the INI file is set to FSIUSER.INI, the output path is set to mypath, and the log file is set to mylog.log, the command would look like this:

fixoffs fsiuser.ini mypath\ mylog.log


Defining Parameters by Order and Flags

Some parameters may be used with flags while others or not. In this case FIXOFFS will look through the parameter list assigning specified parameters first. It assumes unspecified parameters to be values that have not been already been set with the specified parameters.

For example, if the log file has been specified but the INI file and output path have not, this works because the utility assigns the log file to mylog and then parses the remaining parameters in order, first the INI file, next the output path, and so on.

fixoffs fsiuser.ini -Log=mylog.log mypath\


Mixing the Default Parameters

You do not have to specify all of the parameters. The FIXOFFS utility defaults to the settings specified in the INI file.

For example, if you specified the /O parameter, the utility assumes the next parameter is in the INI file. Based on this example, the utility looks in the FSIUSER.INI file to find the name of the log file. If you omitted the name there, the utility would use the default, FIXOFFS.LOG.

fixoffs -o=mypath\ fsiuser.ini


INI Options

This table explains the various options you can set in the FIXOFFS utility.

Control Group

Option

Description

Environment

FSISYSINI

Identifies the name and location of the FSISYS.INI file.

MasterResource

Deflib

Defines the path to the default files.

Defaults to ..\deflib\.

Data

TrnDFDFile

Required. Identifies the TRNFILE (generated by GenTrn and read by GenData) and the NEWTRN file (written by GenData and read by GenWIP and GenArc).

If you omit the path, the utility looks in the \deflib directory.

DataPath

Identifies the default location for the input and output files, such as the NAFILE.DAT, POLFILE.DAT, and recipient batch files.

Defaults to ..\data\.

NewTrn

Identifies the name of the NEWTRN.DAT file. If you omit the path, the utility looks in the directory you defined in the DataPath option.

NAFILE

Required. Identifies the NAFILE.DAT file name and path. If you omit the path, the utility looks in the directory you defined in the DataPath option.

POLFILE

Required. Identifies the POLFILE.DAT file name and path. If you omit the path, the utility looks in the directory you defined in the DataPath option.

Print_Batches

*

By default, all print batches identified under this group can be corrected (if located). All names will either contain an explicit path or should default to DATAPATH.

If omitted, the utility processes only the NEWTRN.DAT file.

DocsetNames

GroupName1

GroupName2

TransactionID

These options typically correspond to the Key1 (Company), Key2 (line of business), and KeyID (Policy number) fields. The utility uses these fields to get the DFD names for fields as the default for log information.

FixOffsets

LogFields

This option overrides the default DocsetNames fields for log information. You can create a comma- or semicolon-delimited list of field names the utility will retrieve and print from each NewTrn record it corrects. The order of the names in your list determines the log output line.

Defaults to Company, LOB, PolicyNumber

LogFile

Identifies the file which receives the logging information. Including this option enables the log option. If you omit this option, you can enable logging using the command line option.

Defaults to FIXOFFS.LOG.

OutPath

The path for the output files the utility creates.

Defaults to the path you set in the DATAPATH option.

NewTrn

Name of the new NEWTRN file.

Defaults to FXNEWTRN.DAT. If you omit the path, the utility, default to the OUTPATH option.

X_OFFSET

Name of field that contains the offsets for the extract file. The NEWTRN.DAT file and the print batches must be sorted by this field.

Defaults to X_OFFSET.

NA_OFFSET

Name of field that contains the offsets for the NA file.

Defaults to NA_OFFSET.

LOGTRANSACTIONS

Log messages for each transaction, this option is overrode by command line parameter -LOG

Defaults to No.

POL_OFFSET

Name of field that will contain the offsets for the POL file.

Defaults to POL_OFFSET.

Fix_Batches

*

This group and option will list all batches that are to be corrected. The option names (on the left of the equal) must match a known batch from Print_Batches. The option value (right side of the equation) will identify the new name and path for the output file. If no path is specified, default to OUTPATH.

Defaults to the Print_Batches control group, if you defined the OutPath option. If you defined the OutPath option, the utility assigns FXBAT00, FXBAT01, and so on.

The utility displays a warning or an error message for any missing INI value it expected to find in the INI file. Here is an example:

WARNING <FixOffsets> <NA_OFFSET> Not defined in INI file

Default to: NA_OFFSET

The second line indicates what the utility used as a default.


Log File Entries

The FIXOFFS utility makes the following types of log file entries:

Errors

The utility terminates when an error occurs. You should consider any data produced by the utility unreliable. Here is an example:

ERROR    mainLoop End of File Never reached mainLoop .\data\NaFile.Dat

Warnings

This indicates the utility detected an unexpected condition but attempted to continue processing. You must analyze warning messages to determine if a real problem exists. Here is an example:

WARNING  <FixOffsets> <NA_OFFSET> Not defined in INI file
Default to: NA_OFFSET

Information Messages

The utility displays information messages when you include the -LOG option on the command line. Informational messages are not preceded with WARNING or ERROR. Here is an example:

This message is logged for every transaction when the -LOG option is set.

Processing:  <1234567> <LB1> <SAMPCO>
Updated Input Batch=NewTrn.Dat  InputBatch=NEWTRN.Fix


Warning and Error Messages

Here are descriptions of the warning and error messages you may encounter.

Command Line Parameter Already Defined

This warning message tells you a command line parameter has been entered more than once.

Command Line Parameter Does Not have Value

This warning message indicates you specified a command line parameter but omitted its value. Follow each command line parameter with an equal sign (=) and a value, as shown here:

fixofw32 -ini=fsiuser.ini (correct)

fixofw32 -ini fsiuser.ini (incorrect)

Error in Logging

This warning message indicates the utility was unable to record an entry to the log file.

Input and Output Files have the Same Path and File Name

A warning issued if the output and input files you specified in the INI file are identical. For this to occur the Print_Batches control group must be identical to the Fix_Batches control group, and the OutPath option in the FixOffsets control group must be identical to the DataPath option in the Data control group. The utility modifies the offsets of the existing file.

<FixOffsets><LogFields> Specified But Not Found in Record

This warning message indicates the LogFields option in the FixOffsets control group defined fields which are not in defined in the TRNDFDFL.DFD or RCBDFDFL.DFD files. Since this affects only the logging of messages, the utility alerts you to the situation and continues processing.

Unknown Command Line Parameter Ignored

This warning message indicates you included a command line parameter the utility did not understand and therefore ignored. Use the Help (?) parameter or refer to the syntax discussion for a list of valid command line parameters.

Not Defined in INI File

A warning or an error message is issued if the utility cannot find an option it needs in the INI file. If the message says WARNING, the next entry indicates the value the utility will use as default.

Cannot Add to Link List

This error message occurs if the utility cannot create or add to a link list.

Could Not Load INI Data

This error message that indicates either the INI file could not be opened or a required option in the INI file is missing. If a required option is missing, look in the log file for information on the option you need to add.

End of Docset Without Data

This error message indicates an end of docset marker was found in the NAFILE.DAT file or POLFILE.DAT file without any preceding data.

End of File Never Reached

This error message indicates a file has unprocessed data. All input files must be from the same run of the GenData program.

Failed to Get Record fgets

This error message tells you the utility could not read a record from the NAFILE.DAT or POLFILE.DAT files. This message is followed by additional information which tells you which file produced the error.

Failed to Return File Position ftell

This error message indicates an ftell function call returned an error. This message is followed in the log file by an entry that indicates which file produced the error and information that describes the system-level error message.

Failure to Update Record

This error message indicates the utility could not change or add a record. The following error messages indicate the utility cannot open a file it needs and generate the Failure to Update Record error message. These messages indicate why the utility could not change or add a record in a database file and are used for debugging purposes.

Could not store NAOFFSET field

Could not store POLOFFSET field

DBGotoNthRecord(%p, %p, %lu) - FAILED

DBAdd(%p,%p,%u) - FAILED

DBGetFirstRecord(%p,%p,%u) - FAILED

DBGetCurrRecNum(%p, %p) - FAILED

DBGetFieldDataPtr(%p, %p, %s) - FAILED

Could not copy data to new record

Fatal Error Cannot Continue

This error message indicates an error occurred and processing was terminated. All error messages terminate processing, but since some messages may be used as warnings or errors this message accompanies the more serious errors.

File Could Not be Opened

This error message tells you the utility could not open a file it needs for processing. The utility includes the name of the file and the file definition, if applicable, as the next entry in the log file. If you encounter this error, make sure the files indicated in the log file are present and have proper permissions.

The following error messages indicate the utility cannot open a file it needs and generate the File Could Not be Opened error message. These messages indicate why a database file was not opened and are used for debugging purposes.

Invalid Record size returned by DBAllocateStructMemory

DBAlloateStructMemory failed(%p, %p)

DBOpen(%p, %d) failed

DBInitializeFile(%s, %s, %p) failed

DBQueryFormatInfo(%s) failed

DBInitDB((FAPDBINSTALLER)ASCInstallHandler, ASCII) failed

DBPutFieldData(%p,%p,%s,%p,%u) - FAILED

File Not Sorted by X_Offset (file name)

This error message indicates the utility detected a record that was not sorted by the X_OFFSET field. The NEWTRN.DAT file and all batch files must be sorted by the X_OFFSET field.

Output File Defined in Fix_Batches Without Matching Entry in Print_Batches

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


Output File Defined in Fix_Batches Without Matching Entry in Print_Batches

An error appears if you define a batch option in your Fix_Batches control group without defining an identical option in the Print_Batches control group. For example, based on the settings below, the BATCH2 option causes an error because it is not defined in the Print_Batches control group:

< Fix_Batches >

Batch1 = BAT1.BCH

Batch2 = BAT2.BCH <<--- Illegal

< Print_Batches >

Batch1 = BAT1.BCH

Example

In this example, the utility updates the NEWTRN.DAT file and the first recipient batch. The output files will have the same name as the input files, but will be stored in the \fixout directory. This example assumes the input files are in the \data directory.

< Data >
  DataPath =.\data
  NewTrn  = newtrn.dat
< Print_Batches >
  Batch1 = BATCH1.BCH
  Batch2 = BATCH2.BCH   <- Note: This batch will not be corrected.
< FixOffsets>
  Outpath=.\fixout
  NewTrn = newtrn.dat
< Fix_Batches >
  Batch1=BATCH1.BCH

Normally this utility creates new files with the corrected offsets and leaves the original files intact. You can, however, have the utility overwrite the original files by specifying the same file names and paths for input and output. These INI settings force the utility to alter the input file instead of creating a new file:

< Data >
  DataPath =.\data
  NewTrn  = newtrn.dat
< Print_Batches >
  Batch1 = BATCH.BCH
  Error = ERROR.BCH
< FixOffsets >
  Outpath=.\data
  NewTrn = newtrn.dat
< Fix_Batches >
  Batch1 = BATCH.BCH
  Error = ERROR1.BCH

If the FixOffsets control group has not been set up in the INI file, the utility will use the default file names and will write all output to the \data directory.

< Data >
  DataPath =.\data
  NewTrn  = newtrn.dat
< Print_Batches >
  Batch1 = BATCH.BCH
  Error = ERROR.BCH

The corrected version of the NEWTRN.DAT file is named FXNEWTRN.DAT. The corrected version of Batch1 is named FXBAT00. The corrected version of Error is named FXBAT01.


FONTLIST

Use this utility to create a report which lists the fonts used in the specified FAP files. This report includes information on...

  • The font IDs used in each FAP file
  • The font IDs used in all specified FAP files
  • A list of the font IDs contained in the FXR file but not used in the FAP files
  • A list of all FAP files that use a specific font ID (optional)

Syntax

FONTLIST /I /X /O /F

Parameter | Description
 | Enter the name of the FAP file from which you want to compile a list of fonts. You can use wild cards (*) in the name to specify multiple files.
/X | Enter the name of the font cross-reference (REL121.FXR) file to search.
/O | Enter the name you want to assign to the report. The default report name is FONTLIST.DAT.
/F | (Optional) Enter a specific font ID to search for.

FONTLIST Example

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


FONTLIST Example

For the FONTLIST utility, this command:

fontlist /i=forms\c* /x=deflib\rel121 /o=.\fonts.txt /f=11020

would produce a report that looks similar to this one:

--- FONTLIST Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Produces a font usage report

FontList Utility

FAP: D:\FAP\mstrres\DMS1\forms\c*

FXR: D:\FAP\mstrres\DMS1\deflib\rel121

FAP and Font ID Report

---------------------

Fap: CODE128

12012 Courier 12 PT

Fap: Checkbox

11010 Times-Roman 10 PT

11020 Times-Roman 20 PT

Fap: Color

11020 Times-Roman 20 PT

Fap: cuscolor

16016 Univers-Medium 16 PT

Fap Count: 0000000005

Consolidated List of Fonts Report

---------------------------------

11010 Times-Roman 10 PT

11020 Times-Roman 20 PT

12012 Courier 12 PT

16016 Univers-Medium 16 PT

Fap List for Font ID 11020 Report

---------------------------------

Color

Checkbox

Fonts Included in FXR - Not Found in Fap(s)

-------------------------------------------

11006 Times-Roman 6 PT

11008 Times-Roman 8 PT

11012 Times-Roman 12 PT

11014 Times-Roman 14 PT

< and so on... >


FOR2XML

Use the FOR2XML utility to convert a (Documaker Studio) FOR file into an XML file which includes field and field attribute information. You can use this utility’s output and the XMLDIFF utility to compare the fields, for instance, on a form in your production library versus a form in your development library.

Note If you want to convert a specific version/revision of the form, be sure to extract the desired version/revision of that form. Then use this utility to generate the XML file.

Syntax

FOR2XML /i=FORFile /o=XMLFile /t= /filter= /ini=INIfile

Parameters

Description

/i

Enter the name of the form (FOR) file. When the form name (FOR) contains spaces or other special characters, enclose the name in quotation marks, as shown here:

"This is an_example.for"

/o

(Optional) Enter the name of the output XML file. If you omit this parameter, the utility uses the form name with an XML extension.

/t

(Optional) Include this parameter to export a list of section-level triggers. Here is an example of the XML output you get with this parameter:

<TRIGGER>

<MASK1></MASK1>

<RECSPERIMG>1</RECSPERIMG>

<DATA>www.oracle.com</DATA>

</TRIGGER>

/filter

(Optional) Use this parameter to add rules or subtract object types from the output. By default these types of objects are exported:

Forms

FormDefs

Fields

FieldData

Recips

Dynamic

EmptyFields

FieldAttr

To omit an object, include the /filter parameter, a minus sign, and the name of the object. For instance, to omit fields include this parameter:

/filter=-fields

You can also list the types of objects you want included. For instance, to see only fields, forms, and recipients, you could use the parameter as shown here:

/filter=fields,forms,recips

To add form or section rules to the default set of objects, add a plus sign and the text rules, as shown here:

/filter=+rules

Here is an example of the output you see when you include form or section rules:

<FORMIMGRULE NAME="SetOriginM" DATA="abs+0,abs+50"/>

<FORMIMGRULE NAME="SetOrigin" DATA="rel+0,Max+0"/>

/ini

(Optional) Enter the name of the INI file you want to use to determine the setup and paths.

Note

The XMLDIFF utility compares two XML files. Its syntax is shown here:

XMLDIFFW file1 file2

The utility creates an output file called TMP.XML that shows you the results of the comparison.

Examples

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


FOR2XML Examples

Here are some examples for the FOR2XML utility:

The /t parameter returns section-level trigger information. Here is an example:

SECTION NAME="q1op62">
<TRIGGER>
  <TRANSCDS>T1</TRANSCDS>
  <RECIPS>INSURED,COMPANY,AGENT</RECIPS>
  <MASK1 />
  <OCCURRENCE>0</OCCURRENCE>
  <RECSPERIMG>0</RECSPERIMG>
  <RECSPER1ST>0</RECSPER1ST>
  <RECIPCPYCT>1</RECIPCPYCT>
  <CONDITIONAL>11,FRMLSTREC,29,1,108,CUR</CONDITIONAL>
  <FUNCTIONNAME />
  <DATA />
 </TRIGGER>

The /t and filter=+rules parameters return section-level triggers and form rules information (when form information is in the FOR file). Here is an example:

<SECTION NAME="q1op62">
- <TRIGGER>
  <TRANSCDS>T1</TRANSCDS>
  <RECIPS>INSURED,COMPANY,AGENT</RECIPS>
  <MASK1 />
  <OCCURRENCE>0</OCCURRENCE>
  <RECSPERIMG>0</RECSPERIMG>
  <RECSPER1ST>0</RECSPER1ST>
  <RECIPCPYCT>1</RECIPCPYCT>
  <CONDITIONAL>11,FRMLSTREC,29,1,108,CUR</CONDITIONAL>
  <FUNCTIONNAME />
  <DATA />
  </TRIGGER>
  <FORMIMGRULE NAME="SetOrigin" DATA="Rel+0,Max+0" />

The /filter=+rules parameter returns field-level rule information, such as the rule name, data, and format mask. Here is an example:

<SECTION NAME="q1mdc1" SRCNAME="q1mdc1" OPTIONS="D4S" VERSION="1" REVISION="1" EFFDATE="19800101">
- <FIELD NAME="ISSUE DATE" SCOPE="L">
  <MAXLENGTH VALUE="8" />
  <DAPFIELDTYPE VALUE="DateFormat" />
  <DAPFIELDFORMAT VALUE="1" />
  <DAPSCOPE VALUE="LOCAL" />
  <DAPFIELDRULE NAME="ffsysdte" DATA="" FMTMASK="" />
  </FIELD>


FORMPUB

This utility provides a graphical interface from which you can run the FD2HTW32 and PTFMDW32 utilities. If you want to run these utilities as stand-alone programs, see

  • FD2HTW32
  • PTFMDW32


FRM2FAP

Use this utility to convert a version 1 or version 2 Xerox form (FRM) file into a FAP file. This utility is useful if you have existing form files in FRM format and you want to convert those forms into FAP files.

Program names

  • Windows: FRM2FAPW.EXE

Syntax

FRM2FAPW /I /X

Parameter | Description
/I | Enter the name of the FRM file. Omit the extension.
/X | Enter the name of the font cross-reference file (REL121.FXR). Omit the extension.
/F | Enter the default font name to use if the logo is not found.
/P | Enter the PrtType control group to use in the INI file, such as XER.

This utility requires these files:

  • FSISYS.INI
  • The font cross-reference file: rel121.FXR

In addition to the FRM file, you must specify the font cross-reference file (FXR) which contains information about the Xerox fonts used in the Xerox FRM file. The FXR file contains information about the fonts which can be used in a FAP file. FRM files also include the names of the Xerox fonts used in the FRM file.

When the utility finds a Xerox font in the FRM file which is not included in the FXR file, it assumes it must be a font which the system will represent as a logo (LGO) file. Logos can be converted to Xerox fonts but this information is not stored in the FXR file. Therefore, the utility looks for the missing Xerox font name in the LOGO.DAT file.

Keep in mind you must convert the Xerox logos (LGO) used in a Xerox FRM file into Documaker graphics (LOG) files before you use this utility.

Note LGO files are used to print pictures, signatures, company logos, and so on. The FRM file may contain these pictures by using the Xerox fonts or logos created for the picture. If so, the names of these Xerox fonts or logos need to be added to the LOGO.DAT file.

If the utility finds the Xerox name in the LOGO.DAT file, it creates a logo record in the FAP file. If it does not find this Xerox name in the LOGO.DAT file, it creates a text label in the FAP file which contains the name of the missing Xerox font file.

To do this, the utility needs a font ID to use for the text label. The /F parameter tells the utility which font ID to use if it has to create text labels for the missing Xerox font files.

Note A way to determine missing fonts is to provide the /F parameter with a font ID from the FXR. If you choose a font ID with a large point size, you can easily spot the text labels which contain the names of the missing fonts. If the missing font is a normal Xerox font, simply import the Xerox font into the FXR file. If the missing font is one of these picture fonts, add its name to the LOGO.DAT file. Then rerun FRM2FAP with the improved FXR and/or LOGO.DAT files. When the FXR and LOGO.DAT files contain all of the fonts used in the FRM file, you will have a properly converted FAP file.

If you omit the output file parameter, the utility uses the FRM file name with an FAP extension.

The FRM2FAP utility looks for a control group named PRINTER in the FSISYS.INI file. In the PRINTER control group, the utility looks for the PrtType option, which determines the type of printer being used, such as AFP, XER, or PCL. Use the /P parameter to specify which PrtType control group to use.


FRMDUMP

Use this utility to create a text file from a version 1 or version 2 Xerox form printer resource (FRM) file.

Similar to the AFPDUMP utility, this utility reads a Xerox Metacode FRM form printer resource file and outputs a formatted text file which contains a list of the fonts and sections used as well as positioning information for text, lines, and sections.

Program names

  • Windows: FRMDPW32.EXE

Syntax

FRMDPW32 /I /O

Parameter | Description
/I | Enter the name of the FRM file.
/O | (Optional) Enter the output file name with a TXT extension.

If you omit the /O parameter, the utility uses the FRM file name with the extension TXT.


FSIVER

Use this utility to generate a report that shows version and patch level information for the Documaker or Docupresentment products. Patches are corrections that have been made to the product's program files (executable and DLL files) after the initial release of the product.

Note To generate a patch report for Docupresentment Java .jar files, see PatchReporter .

The FSIVER utility reads the program files and generates a report showing which patches have been applied to these program files. If you contact Support, they may ask you to run this utility to determine what patch level your system is at.

On Windows, the program files consist of executable files (.exe) and dynamic link library files (.dll). On UNIX, the program files consist of executable files (usually no extension) and shared object files (usually a .so extension). On z/OS (MVS, OS/390), the program files are statically linked so there are no DLL files, only executable files.

Generally, two sections are shown in the report. The first section is called the detailed report and it shows version and patch information for each program file. The second section is called the summary report and it includes a listing of the patches that have been applied to the system as a whole.

Program names

  • Windows: FSIVRW32.EXE
  • UNIX/Linux: fsiver
  • z/OS: FSIVER

Syntax

FSIVRW32 /I= /O= /VO /PO /SO /NV /NP /NS >xxx

Parameter | Description
I= | (Optional) Enter the name and path of the file or files you want to check. You can include asterisks as wildcards. If you omit this parameter, the utility checks a predefined set of known program files for version and patch information.
O= | (Optional) Lets you specify a file to capture the output from this utility. Use this option if you want to send the results to a text file.
VO | (Optional) Only produce the version report.
PO | (Optional) Only produce the patch report.
SO | (Optional) Only produce the summary patch report.
NV | (Optional) Do not produce the version report.
NP | (Optional) Do not produce the patch report.
NS | (Optional) Do not produce the summary patch report.
>xxx | (Optional) This parameter lets you specify an alternative method of capturing the output from the utility. For instance, > version.txt tells the system to save the output to a file named version.txt.

This utility produces these reports:

  • Version report - includes basic version information for each program file
  • Patch report - shows the patches (P01, P02, and so on) applied to each program file. The report is sorted in patch number order.
  • Summary patch report - lists, in numerical order, all of the patches applied to the program files. The report is sorted by product in patch number order. Missing patches are noted.

In addition to showing patch information for Documaker Server and IDS products, this utility also includes information about patches made to some common, low-level libraries. These program files are called 3rd party libraries and are used by both products. The third party patches are reported in this format:

3RD PATCH 3RD:Pxx

where xx is the patch number.

Note The utility tries to note missing patches. For example, if P03 and P05 are found but not P04, the utility notes that P04 was not detected. Missing patches do not necessarily indicate an error because some patches only apply to one platform and not others.


FSIVER Running FSIVER on zOS (MVS, OS/390)

The JCL for running FSIVER on z/OS is provided in member FSIVERX of the JCLLIB dataset. Here is an example:

//ZDA JOB (33005),'FSIVER - 110 ',CLASS=T,MSGCLASS=X,

// NOTIFY=&SYSUID

//*

// SET HLQ='FSI.V110' <== SET HIGH LEVEL QUALIFIER

// SET RES='DMS1' <== SET RESOURCE (such as DMS1)

//*

// JCLLIB ORDER=&HLQ..PROCLIB

//*

//

******************************************************************

//* PROGRAM : FSIVER

//* PURPOSE : CREATES A REPORT THAT LISTS WHICH PATCHES HAVE BEEN

//* APPLIED TO THE PROGRAMS IN THE LINKLIB REFERENCED BY

//* THE LINKLIB DD STATEMENT.

//*

//* PARMS : /I=PROGRAM (NAME OF MEMBER IN DD:LINKLIB)

//* OR '*' TO LIST PATCH LEVEL OF ALL PROGRAMS IN

//* DD:LINKLIB.

//*

//

******************************************************************

//FSIVER EXEC PGM=FSIVER,PARM='/ /I=*'

//*

//STEPLIB DD DSN=&HLQ..LINKLIB,DISP=SHR

// DD DSN=SYS1.SCEERUN,DISP=SHR

//LINKLIB DD DSN=&HLQ..LINKLIB,DISP=SHR

//SYSPRINT DD SYSOUT=*

Keep in mind:

  • The LINKLIB DD statement should point to the dataset that contains the program files, such as FSI.V110.LINKLIB.
  • The report is written to the SYSPRINT DD statement.


FSIVER Example 1

Here is an example of how you to use the FSIVER utility:

FSIVRW32 /i=C:\FAP\DLL\*.* > VERSION.TXT

This tells FSIVER to read all the program files in the \FAP\DLL\ directory on the C: drive. The report is written to the file named version.txt. Here is an excerpt from the report:

--- DocuCorp FSIVER Utility Program (C) ---

--- Display Version & Patch Level Report ---

Version Report For : A2WBW32.DLL

--------------------------------

C:\RELEASE\REL110\RPS100\SHIPW32\A2WBW32.DLL 40110010 400.110.010 Nov 24 2004

> 00:50:46

Patch Report For : C:\RELEASE\REL110\RPS100\SHIPW32\A2WBW32.DLL

-----------------------------------------------------------------

No Patches Detected For : C:\RELEASE\REL110\RPS100\SHIPW32\A2WBW32.DLL

Version Report For : AFEW32.DLL

-------------------------------

C:\RELEASE\REL110\RPS100\SHIPW32\AFEW32.DLL 40110010 400.110.010 Jul 25 2005

> 14:01:32

Patch Report For : C:\RELEASE\REL110\RPS100\SHIPW32\AFEW32.DLL

----------------------------------------------------------------

DAP PATCH 11.0:P03:PCR16419:400.110:..\C\afedform.c:Jun 17 2005:15:16:39:

DAP PATCH 11.0:P03:PCR16335,PCR16378:400.110:..\C\afedpw.c:Jun 30 2005:10:26:51:

DAP PATCH 11.0:P04:PCR16457:400.110:..\C\afedform.c:Jun 17 2005:15:16:39:

DAP PATCH 11.0:P04:PCR15354:400.110:..\C\afedupfm.c:Jun 30 2005:10:14:30:

DAP PATCH 11.0:P04:PCR16457:400.110:..\C\afetrans.c:Mar 4 2005:10:16:07:

DAP PATCH 11.0:P05:PCR16711:400.110:..\C\afedform.c:Jun 17 2005:15:16:39:

DAP PATCH 11.0:P05:PCR16615,PCR16670:400.110:..\C\afedpw.c:Jun 30 2005:10:26:51:

DAP PATCH 11.0:P06:PCR15354:400.110:..\C\afedupfm.c:Jun 30 2005:10:14:30:

DAP PATCH 11.0:P07:PCR16913:400.110:..\C\afeprint.c:Mar 9 2005:12:14:46:

DAP PATCH 11.0:P10:PCR17065:400.110:..\C\afedform.c:Jun 17 2005:15:16:39:

DAP PATCH 11.0:P15:PCR17025:400.110:..\C\afedpw.c:Jun 30 2005:10:26:51:

DAP PATCH 11.0:P18:PCR17557:400.110:..\C\afeversn.c:Jul 25 2005:14:01:32:

DAP PATCH 11.0:P19:PCR17601:400.110:..\C\afedform.c:Jun 17 2005:15:16:39:

DAP PATCH 11.0:P21:PCR17727:400.110:..\C\afedal.c:Jul 25 2005:14:01:21:

DAP PATCH 11.0:P21:PCR17727:400.110:..\C\afedupfm.c:Jun 30 2005:10:14:30:

DAP PATCH 11.0:P21:PCR17689:400.110:..\C\afeentry.c:Jun 30 2005:15:31:22:

DAP PATCH 11.0:P24:PCR14945:400.110:..\C\afedal.c:Jul 25 2005:14:01:21:

. . .

Version Report For : P417W32.DLL

--------------------------------

*** Version information unavailable for : P417W32.DLL

Patch Report For : C:\RELEASE\REL110\RPS100\SHIPW32\P417W32.DLL

-----------------------------------------------------------------

No Patches Detected For : C:\RELEASE\REL110\RPS100\SHIPW32\P417W32.DLL

Summary Patch Report:

----------------------

3RD PATCH 3RD:P01 * Not detected, see explanation below.

3RD PATCH 3RD:P02 * Not detected, see explanation below.

3RD PATCH 3RD:P03 * Not detected, see explanation below.

3RD PATCH 3RD:P04

3RD PATCH 3RD:P05 * Not detected, see explanation below.

3RD PATCH 3RD:P06

3RD PATCH 3RD:P07 * Not detected, see explanation below.

3RD PATCH 3RD:P08

3RD PATCH 3RD:P09 * Not detected, see explanation below.

3RD PATCH 3RD:P10

3RD PATCH 3RD:P11

3RD PATCH 3RD:P12

3RD PATCH 3RD:P13 * Not detected, see explanation below.

3RD PATCH 3RD:P14 * Not detected, see explanation below.

3RD PATCH 3RD:P15

3RD PATCH 3RD:P16 * Not detected, see explanation below.

3RD PATCH 3RD:P17

3RD PATCH 3RD:P18

3RD PATCH 3RD:P19

3RD PATCH 3RD:P20

3RD PATCH 3RD:P21 * Not detected, see explanation below.

3RD PATCH 3RD:P22

3RD PATCH 3RD:P23 * Not detected, see explanation below.

3RD PATCH 3RD:P24

DAP PATCH 11.0:P01

DAP PATCH 11.0:P02

DAP PATCH 11.0:P03

DAP PATCH 11.0:P04

DAP PATCH 11.0:P05

DAP PATCH 11.0:P06

DAP PATCH 11.0:P07

DAP PATCH 11.0:P08

DAP PATCH 11.0:P09

DAP PATCH 11.0:P10

DAP PATCH 11.0:P11

DAP PATCH 11.0:P12

DAP PATCH 11.0:P13

DAP PATCH 11.0:P14

DAP PATCH 11.0:P15

DAP PATCH 11.0:P16

DAP PATCH 11.0:P17

DAP PATCH 11.0:P18

DAP PATCH 11.0:P19

DAP PATCH 11.0:P20

DAP PATCH 11.0:P21

DAP PATCH 11.0:P22

DAP PATCH 11.0:P23

DAP PATCH 11.0:P24

* When a patch is identified as 'Not detected', it means

that either the patch is not applicable to your system

or the patch has been omitted.

--- FSIVER Completed ---

See Also

  • FSIVER Example 2


FSIVER Example 2

Here is another example report that shows patch information for Docupresentment (IDS) patches and for Documaker Shared Objects (DAP) patches. Low-level 3rdParty patches are also shown on this report, but in most cases, you can disregard the 3rd party patch information unless Oracle Support specifically asks about it.

At the end of the FSIVER report is a Summary Patch Report section, which summarizes the patches that have been found in the DLL files. Typically, this summary patch report section shows the 3rdParty, Documaker Shared Objects (DAP), and Docupresentment (IDS) patches that have been applied.

--- FSIVER Copyright (C) 1997, 2009, Oracle. All rights reserved.

--- Documaker runtime version/patch-level report

Version Report For : AFPPTW32.DLL

---------------------------------

Windows Version Information:

****************************

Name: AFPPTW32.DLL

Version: 11.4.0.271

Company: Oracle

Time Stamp: Mon May 04 12:33:54 2009

FSI Version Information:

************************

Module Name: C:\docserv\AFPPTW32.DLL

Version Number: 40114010

Version String: 400.114.010

Version Date: May 4 2009

Version Time: 13:33:46

Patch Report For : AFPPTW32.DLL

---------------------------------

DAP PATCH 11.4:P02:PCR23738:400.114:..\C\afpbox.c:Feb 25 2009:17:11:46:

DAP PATCH 11.4:P02:PCR17484:400.114:..\C\afpldovl.c:Feb 16 2009:09:30:33:

DAP PATCH 11.4:P02:PCR17484:400.114:..\C\afpmcf.c:Feb 16 2009:09:26:45:

DAP PATCH 11.4:P03:PCR24056:400.114:..\C\afppage.c:May 4 2009:13:33:38:

DAP PATCH 11.4:P03:PCR23977:400.114:..\C\afpversn.c:May 4 2009:13:33:46:

DAP PATCH 11.4:P03:PCR23977:400.114:..\C\afpgad.c:Apr 10 2009:15:04:58:

. . .

Summary Patch Report For *:

---------------------------

3RD PATCH 3RD:P01

3RD PATCH 3RD:P02 * Not detected, see explanation below.

. . .

3RD PATCH 3RD:P31 * Not detected, see explanation below.

3RD PATCH 3RD:P32

DAP PATCH 11.4:P01

DAP PATCH 11.4:P02

DAP PATCH 11.4:P03

IDS PATCH 2.2:P01

IDS PATCH 2.2:P02

IDS PATCH 2.2:P03

IDS PATCH 2.2:P04 * Not detected, see explanation below.

IDS PATCH 2.2:P05

IDS PATCH 2.2:P06

See Also

  • FSIVER Example 1


FXLOGREF

Use this utility to change embedded graphics in a FAP file into referenced graphics. This utility searches a FAP file for embedded graphics and either removes…

  • Any duplicate graphics are changed to reference the first occurrence of the embedded graphic.
  • All embedded graphics and instead references the graphics to external graphic files it creates.

The resulting FAP file will be identical in appearance, but smaller in size if duplicate embedded graphics are found and removed.

You can also use this utility to change your graphic files without having to update the FAP files. If a graphic is embedded, the only way to remove it is by deleting it and then insert a new reference. If it is an external reference, then you can update the graphic file without having to edit each FAP file that might use that graphic.

Program names

  • Windows: FXLOGREF.EXE

Syntax

FXLOGREF /F /O /C /L /I

Parameter | Description
/F | Enter the name of the input FAP file.
/O | Enter the name of the output file.
/C | Compares the embedded graphics to all of the graphics in the directory to find duplicates.
/L | Include this option to remove all embedded graphics and replace them with references to external files (*.LOG) the utility creates.
/I | Enter the name of the INI file to use. The default is the FAPCOMP.INI file.

Note

This utility can be useful if you are using a newer version of the system to create FAP files for an older version. For instance, if you use the RTF import feature to import a file, it will embed graphics for you.

If, however, you then plan to use the FAP file you created in a version that predates version 10.1, you would need to use this utility to remove the embedded graphics. (Prior to 10.1, the system did not support embedded graphics.)


FXRCMP

Use this utility to compare two font cross-reference (FXR) files and print the differences to a file you specify. The utility also compares matching font IDs. The output contains the names of the structure for the FXR.

Program names

  • Windows: FXRCMPW32.C

Syntax

FXRCMP32 /1 /2 /INI /O /M /V /C

Parameter | Description
/1 | Enter the name of the first FXR file.
/2 | Enter the name of the second FXR file.
/INI | (Optional) Enter the name of the INI file you want the utility to use. The default is the FAPCOMP.INI file.
/O | (Optional) Enter the name of the output file in which you want this utility to print its results. The default is TEMP.TXT.
/M | (Optional) Include this parameter if you want the utility to only report the differences between the fonts used in both FXRs. Fonts which appear in only one of the FXRs are excluded from the comparison.
/V | (Optional) Include this parameter if you want the utility to make an extensive or verbose comparison.
/C | (Optional) Include this parameter if you want the utility to compare for case sensitivity

Example

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


FXRCMP Example

Here is an example of the results you will see when you use the FXRCMP command:

FXRCMP32 /1=FirstFXR /2=SecondFXR

The output contains the names of the structure for the FXR.

Mon May 01 11:27:26 2005
PLEASE NOTE: Results are listed in order by Font ID with
the contents of the first fxr listed and then the contents
of the second fxr listed.
  Font ID: #, <rel121>:<test>

Font ID: 1, FAPFONTHDR->fntName <CO______.PFB>:<COURIE.TTF>
Font ID: 1, FAPFONTATTR->chrwid:code point<127> width <136>:<80>
Font ID: 1, FAPFONTATTR->chrwid:code point<175> width <64>:<80>
Font ID: 1, FAPFONTATTR->internalLeading <32>:<16>
Font ID: 1, FAPFONTPRT<PS>->typefaceCode <0>:<>
Font ID: 1, FAPFONTPRT<PS>->fontFile <CO______.PFB>:<>
Font ID: 1, FAPFONTPRT<PS>->charSetID <W1>:<>
Font ID: 1, FAPFONTPRT<PS>->SetupData <Courier>:<>
Font ID: 1, FAPFONTPRT<OTHER>->typefaceCode <>:<0>
Font ID: 1, FAPFONTPRT<OTHER>->fontFile <>:<COURIE.TTF>
Font ID: 1, FAPFONTPRT<OTHER>->charSetID <>:<W1>

Font ID: 2, FAPFONTHDR->fntName <CO______.PFB>:<COURIE.TTF>
Font ID: 2, FAPFONTINF->height <184>:<176>
Font ID: 2, FAPFONTATTR->chrwid:code point<32> width <104>:<96>
Font ID: 2, FAPFONTATTR->chrwid:code point<33> width <104>:<96>
Font ID: 2, FAPFONTATTR->chrwid:code point<34> width <104>:<96>
Font ID: 2, FAPFONTATTR->chrwid:code point<35> width <104>:<96>
Font ID: 2, FAPFONTATTR->chrwid:code point<36> width <104>:<96>
May 01 11:27:26 2000
PLEASE NOTE: Results are listed is the following format/order:
  <c:\012600ps.fxr>:<c:\012600tt.fxr>

Font ID: 1, FAPFONTHDR->fntName <CO______.PFB>:<COURIE.TTF>
Font ID: 1, FAPFONTATTR->chrwid:code point<127> width <136>:<80>
Font ID: 1, FAPFONTATTR->chrwid:code point<175> width <64>:<80>
Font ID: 1, FAPFONTATTR->internalLeading <32>:<16>
Font ID: 1, FAPFONTPRT<PS>->typefaceCode <0>:<>
Font ID: 1, FAPFONTPRT<PS>->fontFile <CO______.PFB>:<>
Font ID: 1, FAPFONTPRT<PS>->charSetID <W1>:<>
Font ID: 1, FAPFONTPRT<PS>->SetupData <Courier>:<>
Font ID: 1, FAPFONTPRT<OTHER>->typefaceCode <>:<0>
Font ID: 1, FAPFONTPRT<OTHER>->fontFile <>:<COURIE.TTF>
Font ID: 1, FAPFONTPRT<OTHER>->charSetID <>:<W1>

Font ID: 2, FAPFONTHDR->fntName <CO______.PFB>:<COURIE.TTF>
Font ID: 2, FAPFONTINF->height <184>:<176>
Font ID: 2, FAPFONTATTR->chrwid:code point<32> width <104>:<96>
Font ID: 2, FAPFONTATTR->chrwid:code point<33> width <104>:<96>
Font ID: 2, FAPFONTATTR->chrwid:code point<34> width <104>:<96>
Font ID: 2, FAPFONTATTR->chrwid:code point<35> width <104>:<96>
Font ID: 2, FAPFONTATTR->chrwid:code point<36> width <104>:<96>


FXRVALID

Use this utility to check a font cross-reference (FXR) files for settings which would cause problems. This includes problems affecting Adobe© Acrobat© (PDF) files, such as noting any font ID which would cause problems when during the creation of a PDF files.

Program names

  • Windows: FXRVALDW.EXE

Syntax

FXRVALDW /I /E /G /O /R /D?

Parameter | Description
/I | The name of the font cross-reference file (REL121.FXR). Omit the extension.
/E | (Optional) An error file name. Omit the extension.
/G | Turns on the adding of “OTH” entry and the grouping of fonts. You can specify the grouping threshold as an error percentage (see FXRVALID Utility Checks). The default is zero (0). The default range is 32,127.
/O | (Optional) An output file name. The new FXR file contains “OTH” entries and grouping. If you omit the file name, the utility uses the input file name with an FXX extension. If you include a file name without an extension, they utility defaults to FXX.
/R | (Optional) Use this parameter (startchar,endchar) to specify the range of characters in width table to be checked for grouping. You can enter any integer from 0 to 255. The default value for startchar is 32 and the default value for endchar is 127. If endchar is less than startchar, the value of endchar is set to that for startchar.
/D? | Turns on the DownloadFont option, known as the Option field in the “OTH” entry, in every “OTH” entry. The DownloadFont option in every “OTH” entry is turned off if you omit this parameter.

The FXRVALID utility performs FXRVALID Utility Checks on font IDs in the font cross-reference (FXR) file.


FXRVALID Utility Checks

This topic describes the various checks that the FXRVALID utility performs.

Check typeface

This check makes sure all font IDs contain one of the following PostScript font names in the Font Name field for PostScript printing:

Courier | Times-Roman
Courier-Bold | Times-Bold
Courier-BoldItalic | Times-Italic
Courier-Oblique | Times-BoldItalic
Courier-BoldOblique | Symbol
Courier-Italic | ZapfDingbats
Helvetica | Univers-Medium
Helvetica-Bold | Univers-Bold
Helvetica-Oblique | Univers-MediumItalic
Helvetica-BoldOblique | Univers-BoldItalic

The FXRVALID utility tells you via an error message if the FXR file contains an invalid PostScript font name or does not contain a PostScript font. The message also tells you whether a fixed or proportional font will be used in place of the invalid typeface. The PDF printer driver will make the font substitution.

Note Font IDs have either a fixed pitch or a proportional spacing value. If font substitution is required for fixed pitch fonts, Courier is typically used. If font substitution is required for proportional fonts, Helvetica is typically used. In addition, the stroke weight and style settings of the font ID are checked to see if bold or italic or bold and italic versions of these fonts should be used.

Check point size

This check compares the font height to the point size for each PostScript font in the FXR. A warning message appears for every font ID whose font height differs from the point size by a factor of 1/3 or greater. A warning also appears if the font height equals zero.

Note If the font height and point size do differ by the factor of 1/3, the printer driver will use font height to determine point size. The FXRVALID utility does not determine point size in these situations.

Check the code page

A warning appears for any font IDs whose CodePage field is not empty or is not set to 1004.

Note The PDF printer driver uses the ANSI code page for text. Code page 1004 is the IBM code page which is equivalent to the ANSI code page. Some older version FXRs, built before the CodePage field was added to the FXR, have a blank in the CodePage field.

Check spacing

This check makes sure the spacing value (fixed or proportional) of the font ID matches a PostScript font with an equivalent spacing style. If the spacing value does not match, a warning appears.

Check style

This check makes sure the font style (upright or italic) of the font ID matches a PostScript font with an equivalent font style. If a font ID specifies an italic style, a warning appears if the Font Name field does not contain a PostScript font name containing the word Italic or Oblique. If a font ID specifies an upright style, a warning appears if the Font Name field contains the word Italic or Oblique.

Check weight

This check makes sure the font weight (bold or normal) of the font ID matches a PostScript font with an equivalent font weight. If a font ID specifies a bold style, a message appears if the Font Name field does not contain a PostScript font name which includes the word Bold and vice versa.

Using grouping

When grouping fonts, the utility performs these steps:

  1. Creates “OTH” entries for every font record in the FXR file.
  2. Groups fonts (set the font index in “OTH” entry the same for each group) if the following conditions are true:
  • Font spacing (proportional or fixed) is the same.
  • Font style (italic or upright) is the same.
  • Font family is the same.
  • Font stroke weight (bold or non-bold) is the same.
  • The percentage difference of the absolute width for every character within the user-specified range is not greater than the user-specified grouping threshold.
Note Absolute width is defined as: the value in the width table divided by the point size.
  3. Sets the Font File field the same for each group. The Font File field (PostScript or TrueType font) that has the smallest absolute width for the W character in each group is copied to every font in the same group. This font is called the base font.

If there is no entry in the Font File field in the base font, the FXRVALID utility tries to find a Font File field in the group and use it as base font file. If none is found in the entire group, the Font File field in “OTH” entry for this group is left empty. It is your responsibility to fill in the Font File field in this situation. If you do not, the system may create an invalid PDF file.

Example

In a Windows environment, you would enter:

    FXRVALDW /I=rel121

In this example, FXRVALDW checks the font cross-reference file named rel121.FXR and creates an error file named rel121.ERR.


The IStream Migration Utility

The IStream Migration Utility analyzes your IStream model documents and creates migration-ready files based on their content.

These files can be imported directly into Documaker Studio, using Studio’s Conversion option or by using the RTF2FAP utility.

For more information on converting IStream Migration RTF files into Documaker Studio, see the Documaker Studio User Guide. See also the RTF2FAP utility.

This section contains the following topics:

  • Overview of the Migration Utility
  • Migrating IStream Model Documents

The IStream to Documaker How To Guide, which discusses additional steps required when moving from IStream to Documaker, is also available.


Overview of the Migration Utility

The IStream Migration Utility helps you convert your IStream model documents (.CMS and .CDS files) to Oracle Documaker document resources.

The Migration utility scans your IStream model documents and analyzes their content and logic. Based on this analysis, the Migration utility creates new files which you then import into Documaker, where they can be further updated.

Please note that the Migration utility does not

  • Alter your IStream model documents, but creates new files based on the contents of these documents
  • Convert IStream model documents to the Documaker format, but does make the process of conversion easier by creating the necessary files to import into Documaker

See Also

  • Getting Additional Information
  • Migrating IStream Model Documents


Getting Additional Information

For more information, please refer to the IStream to Documaker How To Guide. This guide contains additional information about preparing for and using the utility, including:

  • System requirements and project planning
  • Documaker pre-importing tasks
  • The files created by the utility
  • Importing into, configuring, and updating Documaker
  • Post-importing tasks
  • Testing the output files
  • Deploying the library


Migrating IStream Model Documents

Before running the Migration Utility, make sure:

  • Microsoft Word can access the .DOT template files required by the IStream model documents
  • The fonts used in the CMS and CDS files are correctly installed and be available to Microsoft Word during processing
Note If the template files or fonts are not accessible, this will cause the output documents to be improperly formatted, which will result in incorrectly formatted Documaker form documents.

When you are ready to begin migrating your IStream model documents, you can run the Migration Utility.

  1. Open the Migration utility by selecting Start, All Programs, Oracle Documaker, IStream Migration Utility option. The Oracle IStream Migration Utility opens.
  2. Click the Browse button next to the Source Folder field to select the folder where your IStream Model documents are located.

To process all the IStream model documents in the subfolders of the selected Source Folder, check the Include Subfolders box.

  3. In the Target Files field, you can select certain file types to process by entering the file extension with a wildcard. For example, to process...
  • Only master sections, enter *.cms
  • Only sub-sections, enter *.cds

All of your IStream model documents, leave this field as *.c?s.

  4. Click the Browse button next to Output Folder to select the folder you want to add the migrated files into.
  5. To permanently delete all the files in the selected Output Folder, select Delete Files in Output Folder.
  6. Enter the Key1 and Key2 Documaker values. These keys define a business group of forms, such as, proposals, letters, or policy forms.
  7. Enter the Default Recipient name and count.

The default Key1, Key2, and Default Recipient values will be associated with the documents once you have set them up in Documaker. Documaker requires these values for its resource and publishing setup. These values are specific to each implementation. For more information, see the IStream to Documaker How To Guide.

  8. Click Start to begin processing the files. The progress bar and file list update as each file is processed. Note that the status of the progress bar is based on the file size, not the number of files.
Note The Migration utility uses Microsoft Word Automation and the shared Windows clipboard. Therefore, do not use Microsoft Word while the files are being migrated.

Various information about the files appears in the Files Found section: see Viewing File Information for details.

To stop the processing, click Stop. The Migration utility will finish processing the current file, but will still generate reports.

When all files have been processed, a completion window appears, and a list of reports is displayed.

  9. Click a report to view it.


Viewing File Information

The following information appears in the Files Found section while the Migration utility is migrating the IStream model documents:

Item | Description
Elapsed | The total processing time for the IStream model documents
Template | Identifies the Microsoft Word template used during the IStream model document migration
Source | Identifies the source of the IStream model document
# RTFs | The number of Rich Text Format files created from the IStream Model documents
Fonts | The total number of fonts in the IStream model documents
Header | Identifies whether the IStream model documents contain headers
Footer | Identifies whether the IStream model documents contain footers
Tables | The total number of headers in the IStream model documents
Graphics | The total number of graphics in the IStream model documents

See Also

  • Viewing the Reports


Viewing the Reports

These reports show information on the IStream model documents that were processed:

Report | Description
Summary Report | Provides information on the model documents processed; includes the number of model documents, fonts, headers, footers, tables, and graphics.
Fonts Report | Identifies all fonts used in the models documents. This includes the font name, font attribute, and point size.
Headers Report | Identifies whether a model document uses a Microsoft Word header.
Footers Report | Identifies whether a model document uses a Microsoft Word footer.
Tables Report | Identifies whether a model document uses a Microsoft Word table.
Logos Report | Identifies whether a model document contains graphics, such as company logos and signatures.
Exceptions Report | Identifies if the utility encountered an unexpected problem; includes the path and the name of the model document that encountered the problem, and an error message.
DAL Scripts Report | Identifies model documents that contain braces ( {} ) to insert a value of an expression into the text.
Tags Report | Identifies field names used in model documents.
Include Summary Report | Identifies common INCLUDE statements across forms within a group of model documents.

For more information about these reports, please refer to the IStream to Documaker How To Guide.


KSDS2SEQ

Use this utility to read the records of a VSAM KSDS and write the records to a sequential file. The utility removes the index before the record is written.

Note This utility is only available for z/OS systems.

For example, you could run this utility against a VSAM NAFILE and a VSAM POLFILE to produce sequential copies of those files. You could then download the sequential copies from an z/OS system to a Windows Server, where the GenPrint or GenArc programs could use the sequential NAFILE and POLFILE files.

Here is a copy of the JCL. You can find sample JCL for the KSDS2SEQ utility in member KSDS2SQX of JCLLIB.

//* COPY JOBCARD HERE
//* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
//*      KSDS2SEQ -
//*
//*      PARAMETERS:
//*         /M=MAX   WHERE MAX IS THE MAXIMUM RECORD LENGTH OF THE
//*                  OUTPUT DATASET (DEFAULT = 512).
//*
//*        JOB PERFORMS 2 STEPS :
//*
//*        1.  DELETES / RE-DEFINES SEQUENTIAL OUTFILE.
//*        2.  RUNS KSDS2SEQ PROGRAM TO COPY VSAM KSDS TO SEQUENTIAL
//*            FILE.  CHANGE FILE NAMES APPROPRIATELY.
//*
//* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
//*
//DEL      EXEC PGM=IEFBR14
//OUTFILE  DD DSN=&HLQ..&RES..GENDATA.NAFILE,DISP=(MOD,DELETE),
//         UNIT=SYSDA,SPACE=(TRK,0)
//*
//KSDS2SEQ EXEC PGM=KSDS2SEQ,PARM='/ /M=512'
//STEPLIB  DD  DISP=SHR,DSN=&HLQ..LINKLIB
//         DD  DISP=SHR,DSN=SYS1.SCEERUN
//SYSOUT   DD SYSOUT=*
//SYSPRINT DD SYSOUT=*
//INFILE   DD DSN=&HLQ..&RES..GENDATA.NAFILE.KSDS,DISP=SHR
//OUTFILE  DD DSN=&HLQ..&RES..GENDATA.NAFILE,DISP=(,CATLG),
//         UNIT=SYSDA,SPACE=(CYL,(5,1)),
//         RECFM=FB,LRECL=512,BLKSIZE=23040


LBRYMGR

Use this utility to create a response file from a FORM.DAT file. Response files define the file references to include in a particular resource library. By running the response file using Library Manager, you can insert or check in numerous file references in a resource library.

Note For more information about Library Manager, see the Documaker Studio User Guide.

When you create a response file from a FORM.DAT file, you extract FORM.DAT information to build a the response file (RSP). You can then edit the response file to add the information not included in the FORM.DAT file.

Program names

  • Windows: LBRYMGRW.EXE

Syntax

LBRYMGRW /LBY /RSP /FORMDEF /REC /S /SP /XP /INI /ALL /FAP /LOGO /DDT
/BDF /GRP /FOR /EFF /NOSTATS /NOLOG /R /V /C /DAL /REV /VER /MODE
/STATUS /CLASS /PROJECT /LN /EXP /CVTOLD /TLK /TLP

Parameter

Description

/LBY

The name of the library file. Include the LBY extension

/RSP

The name of the response file you want to build. Include the RSP extension. The extension is optional but will help you identify the file you created.

/FORMDEF

The name and path of your form definition (FORM.DAT) file, such as \fap\mstrres\rpex1\deflib\form.dat.

/REC

Lets you specify whether the utility creates Add records (REC=A), Extract records (REC=X), or Sync records (REC=S). The default is A.

/S

Tells the utility to write synchronization records to the response file.

Using /REC=S instead of /S provides consistency with the way the utility creates Add (REC=A) or Extract (REC=X) records.

/SP

Specifies the path into which the utility unloads Library Manager objects into temporary files (with file names like F1.SYN, F2.SYN, and so on).

/XP

Specifies the path for target file names when creating extract records.

/INI

The name and path of the INI file, such as \fap\dll\fapcomp.ini.

/ALL

If you include just /ALL, the utility includes all files in the response file. If you specify a path after the parameter, as shown here:

/ALL=d:\data

the utility builds add records using all files from the given path or builds extract records and uses the path you specified in the target file name.

/FAP

If you include just /FAP, the utility includes FAP files in the response file. If you specify a path after the parameter, as shown here:

/FAP=d:\data

the utility either builds add response records using FAP files from the given path, or it builds extract response records using the path in the target file name.

/LOGO

If you include just /LOGO, the utility includes graphics (LOG) files in the response file. If you specify a path after the parameter, as shown here:

/LOGO=d:\data

the utility either builds add response records using LOG files from the given path, or it builds extract response records using the path in the target file name.

/DDT

If you include just /DDT, the utility includes DDT files in the response file. If you specify a path after the parameter, as shown here:

/DDT=d:\data

the utility either builds add response records using DDT files from the given path, or it builds extract response records using the path in the target file name.

/BDF

If you include just BDF, the utility includes BDF files in the response file. If you specify a path after the parameter, as shown here:

/BDF=d:\data

the utility either builds add response records using BDF files from the given path, or it builds extract response records using the path in the target file name.

/GRP

If you include just GRP, the utility includes GRP files in the response file. If you specify a path after the parameter, as shown here:

/GRP=d:\data

the utility either builds add response records using GRP files from the given path, or it builds extract response records using the path in the target file name.

/FOR

If you include just FOR, the utility includes FOR files in the response file. If you specify a path after the parameter, as shown here:

/FOR=d:\data

the utility either builds add response records using FOR files from the given path, or it builds extract response records using the path in the target file name.

/EFF

Lets you specify an effective date for the objects you are adding to the library. Enter the effective date in one of these formats: mm/dd/yy, mm/dd/yyyy, or yyyymmdd. If you omit this parameter, the utility uses the current date as the effective date.

/NOSTATS

Include this parameter to suppress the statistics report which appears when the utility finishes.

/NOLOG

Include this parameter to suppress logging, which otherwise goes into the trace file.

/R

Enter LAST if you want the utility to generate sync records for only the latest revision of the resource. Enter E if you want to it to generate records only for expired resources.

The default is ALL which generates records for all revisions of the resource.

/V

Enter LAST if you want the utility to generate sync records for only the latest version of the resource.

The default is ALL which generates records for all versions of the resource.

/C

Include this parameter to display a counter which shows the progress of response file processing.

/DAL

If you include this parameter and specify a path, the utility builds Add records using DAL files from the given path.

/REV

When generating Add records, this parameter tells the utility what revision to set for the resources added to the library. The default is 00001.

/VER

When generating Add records, this parameter tells the utility what version to set for the resources added to the library. The default is 00001.

/MODE

This parameter tells the utility to set the mode when creating Add records or, when creating Extract records, to only create records for objects with the given mode.

/STATUS

This parameter tells the utility to set the status when creating Add records or, when creating Extract records, to only create records for objects with the given status.

/CLASS

This parameter tells the utility to set the class when creating Add records or, when creating Extract records, to only create records for objects with the given class.

/PROJECT

This parameter tells the utility to set the project when creating Add records or, when creating Extract records, to only create records for objects with the given project.

/LN

The LN (Long Name) parameter lets you specify whether the utility applies standard file names or long file names to the library objects it extracts. The default is Yes.

A long (or versioned) file name contains the version, revision and effective date in the name. For example, version 1, revision 2 of the Q1ADDR section (FAP), with an effective date of September 1, 2005, would have a long file name of...

Q1ADDR_0000100002_20050901.FAP

When extracting various versions and/or revisions of a library object, it is necessary to extract the objects to long file names to prevent one version/revision of the object from replacing another version/revision of an object with the same name.

/EXP

Set this parameter to No to prevent the utility from creating Add or Extract records for expired objects. The default is Yes.

/CVTOLD

Use this parameter to convert library files created before version 10.2 into the newer format.

Keep in mind you should always back up your files before you convert a library.

/TLK

Include this parameter to include TLK files in the response file.

This parameter tells the utility to build Add response records using TLK files from the path you specify or build extract response records and use the specified directory in the target file name.

/TLP

Include this parameter to include TPL files in the response file.

This parameter tells the utility to build Add response records using TPL files from the path you specify or build extract response records and use the specified directory in the target file name.


Creating Response Files

You tell the utility to create a response file by specifying certain parameters. Generally, if you include the FORMDEF parameter or the BDF, GRP, FOR, FAP, DDT, LOGO, DAL, or ALL parameters, the utility creates a response file. If you omit these parameters, the utility instead processes a response file.

You indicate which type of response file records you want the utility to create using the /REC parameter. The default is to generate Add records in the response file.


Generating Add Records

You can use the LBRYMGR utility to add resources, such as FAP, DDT, LOG, DAL, BDF, GRP, and FOR files, into a library. When you generate Add records to the response file, you can tell the utility to read the contents of your FORM.DAT file and generate Add records for the resources referenced in it. You can also specify paths you want the utility to use to search for files to generate Add records from.

Example 1 - Using the /FORMDEF parameter

In this example, the command tells the LBRYMGR utility to create a response file named RESPONSE.RSP and to read the FORM.DAT file located in the indicated DefLib directory. The utility then generates Add records and writes them into the response file for all referenced resource files.

Note Unless you specifically indicate otherwise, the system uses the current date as the effective date for each Add record.

C:\fap\dll> LBRYMGR /rsp=response.rsp
/formdef=c:\fap\mstrres\rpex1\deflib\form.dat /fap /ddt /logo

--- DocuCorp LBRYMGR Utility Program (C) ---

--- Library Manager Response File Utility ---

Attempting to create Response File <response.rsp>

Effective Date for objects will be: October 24 00:00 2007

Successfully created response file <response.rsp>

Example 2 - Using the /FAP, /DDT, and /LOGO parameters

Instead of using the /FORMDEF parameter to indicate which resources to create Add records for, you can also point to specific directories and the LBRYMGR utility will generate Add records for all files in those directories.

This example tells the LBRYMGR utility to create a response file named RESPONSE.RSP. It generates Add records for the files located in the forms directory that have a .FAP extension. It also generates Add records for the DDT and LOG files stored in the specified directories.

C:\fap\dll> LBRYMGR /rsp=response.rsp
/fap=c:\fap\mstrres\rpex1\forms\*.fap
/ddt=c:\fap\mstrres\rpex1\deflib\*.ddt
/logo=c:\fap\mstrres\rpex1\forms\*.log

--- DocuCorp LBRYMGR Utility Program (C) ---

--- Library Manager Response File Utility ---

Attempting to create Response File <response.rsp>

Successfully created response file <response.rsp>


Generating Extract Records

You can use the LBRYMGR utility to create a response file that contains Extract records. You can then process this response file. The utility will extract the indicated resources from the library and copy them to the location you specified. To generate Extract records, use the /REC=X parameter.

Example 1 - Creating extract records for all resources

This example tells the LBRYMGR utility to create a response file named RESPONSE.RSP. It generates Extract records for all resources in the library. The response file contains the target path and file name for each resource that is extracted. The /ALL parameter tells the system to extract all resource types and to create target file names using the indicated directory.

C:\fap\dll>lbrymgrw /rsp=response.rsp /rec=x
/lby=.\deflib\master.lby /all=.\ext\

--- DocuCorp LBRYMGR Utility Program (C) ---

--- Library Manager Response File Utility ---

Successfully created response file <response.rsp>

Example 2 - Creating extract records for the latest version and revision

This example tells the LBRYMGR utility to create a response file named RESPONSE.RSP. It generates Extract records for the latest revision of the latest version of each FAP file in the library. The file name for each resource placed in the response file will be the short name instead of the long or versioned name, which is the default.

C:\fap\dll>lbrymgrw /rsp=response.rsp /rec=x
/lby=.\deflib\master.lby /fap=.\ext\ /r=l /ln=no /v=l

--- DocuCorp LBRYMGR Utility Program (C) ---

--- Library Manager Response File Utility ---

Successfully created response file <response.rsp>


Generating Sync Records

Using the LBRYMGR utility, you can use Sync records to update or promote resources. For instance, you could generate Sync records to promote resources from a development library into a testing library. Include the /REC=S parameter to create a response file that contains Sync records.

Note To promote resources from one library to another or to synchronize libraries, use the LBYSYNC utility.

Example - Creating sync records

This example tells the LBRYMGR utility to create a response file named RESPONSE.RSP. It generates Sync records for all resources in the library. Part of the process of generating the response file involves extracting the resources from the library, assigning them a temporary name, and writing these files to the directory indicated with the /SP parameter. When you later process the response file, these resources are copied into the target library, provided they are newer than the existing resources in the target library.

C:\fap\dll>lbrymgrw /rsp=response.rsp /rec=s
/lby=.\deflib\master.lby /sp=.\sync\

--- DocuCorp LBRYMGR Utility Program (C) ---

--- Library Manager Response File Utility ---

Will create Sync records for all Revisions of all Versions.

Attempting to create Sync Response File <response.rsp>

Successfully created response file <response.rsp>


Response File Format

Generally you create a response file by running the LBRYMGR utility. Though it is best to let the LBRYMGR utility create the response file, there may be situations in which you need to later edit the resulting response file.

Response files contain one or more records. Each record contains the information necessary information for an action (Add, Extract, Sync) to be performed on a single resource. Each record consists of several semi-colon delimited fields. The fields are ordered as shown here:

;Action;FileType;FileSubType;FullName;Name;Resource;Description;EffectiveDate;

UserLevel;Password;UserID;Version;Revision;ModifyTime;Mode;Status;Class;Project;

Field

Description

Action

Specifies what action to perform when this response record is processed. You can enter

- A (adds a file)

- D (deletes a file)

- R (replaces the reference by deleting old reference and adding a new one)

- U (updates record data but does not update the file

- X (extracts file)

- S (synchronizes or promotes the resource to another library).

FileType

Indicates the type of resource that is being processed. You can enter

- FAP (section)

- DDT (data definition table)

- LOG (graphics)

- DAL (Document Automation Language)

- BDF (business unit definition)

- GRP (business unit group)

- FOR (form).

FileSubType

Indicates the subtype of the resource that is being processed. You can enter

- FAP (section)

- DDT (data definition table)

- LOG (graphics)

- DAL (Document Automation Language)

- BDF (business unit definition)

- GRP (business unit group)

- FOR (form)

Use the same value here as is used for the FileType field.

FullName

Indicates the fully or partially qualified name of the resource being processed.

Name

Specifies the name of the resource.

When processing an Add record, the name field indicates the value the name field in the library index will be set to as the resource is added to the library.

When processing an Extract record, the name field indicates the name of the resource to extract from the library.

Resource

This is a legacy field used to indicate the general location the resource came from, such as FORMS or DEFLIB. This field is no longer used.

Description

(Optional) You can use this field to include a comment that will be placed in the library index Description field. You can enter up to 100 characters.

Effectivedate

(Optional) You can use this field to specify a date at which the resource will become effective. Enter the date in the YYYYMMDD format. If you omit this date, the system uses the date on which the response file is created.

UserLevel

(Optional) You can use this field to specify a two-digit key for access rights. The default is 99, which allows access to all users.

Password

(Optional) You can use this field to associate a password with the resource.

UserID

(Optional) You can use this field to specify the user ID you want to associate with the resource in the library index. You can enter up to 64 characters. The default is docucorp.

Version

(Optional) When processing an Add record, this field specifies the value the Version field in the library index will be set to as the resource is added to the library.

When processing an Extract record, this field specifies the version of the resource to extract.

The Version field should consist of five digits padded with zeros, such as 00001 or 00015. The default is 00001.

Revision

(Optional) When processing an Add record, this field specifies the value the Revision field in the library index will be set to as that resource is added to the library.

When processing an Extract record, this field specifies the revision of the resource to extract from the library.

The Revision field should consist of five digits padded with zeros, such as 00001 or 00015. The default is 00001.

ModifyTime

(Optional) When processing an Add or Sync record, this field specifies the value that the ModifyTime field in the library index will be set to as that resource is added to the library. If omitted, the ModifyTime field in the library index is set to the time at which the resource is added to the library. This value is in a hexadecimal format and should generally not be manually edited.

Mode

(Optional) When processing an Add record, you can use this field to specify the value the Mode field in the library index will be set to as the resource is added to the library. If omitted, the Mode field in the library index is set to blank.

Status

(Optional) When processing an Add record, you can use this field to specify the value the Status field in the library index will be set to as the resource is added to the library. If omitted, the Status field in the library index is set to blank.

Class

(Optional) When processing an Add record, you can use this field to specify the value the Class field in the library index will be set to as the resource is added to the library. If omitted, the Class field in the library index is set to blank.

Project

(Optional) When processing an Add record, you can use this field to specify the value the Project field in the library index will be set to as the resource is added to the library. If omitted, the Project field in the library index is set to blank.

Here is an example of an Add record:

;A;FAP;FAP;.\forms\q1snam.fap;q1snam;FORMS;sample description;20040603;99;;DOCUCORP;00001;00001;;DEV;TEST;GA;P001;


Processing Response Files

You process a response file by specifying a combination of parameters. Generally, you only need to specify a response file name and a library name. The LBYPROC utility then processes the response file and, depending on the contents of the response file, adds to, extracts from, or synchronizes resources in the library.


Processing Add Records

If you have created a response file that contains Add records, you can run this response file against a library. The utility then adds the resources listed in the response file to the library.

Example - Adding resources to the library

In this example, the LBRYMGR utility reads the response file and processes the records against the library called master.lby. They are all add records. Including the /C parameter tells the utility to display a counter to show its progress.

C:\fap\dll> LBRYMGR /rsp=response.rsp /lby=c:\fap\mstrres\rpex1\deflib\master.lby /c
   ---      DocuCorp LBRYMGR Utility Program (C)      ---
   ---      Library Manager Response File Utility     ---
   Attempting to read and process Response File <response.rsp>
   Successfully processed response file <response.rsp>

   Add (A) Record Statistics:
   Records Read                 :     125
   Objects updated index        :       0
   Objects added, Ver/Rev ok    :       0
   Objects added as new         :     125
   Objects added Ver/Rev incr   :       0
   Objects Ver/Rev error        :       0
   Objects add error            :       0


Processing Extract Records

If you have created a response file that contains Extract records, you can run this response file against a library and the resources will be extracted from the library and saved to the location you specified in the response file.

Example - Extracting resources from the library

In this example, the LBRYMGR utility reads the response file and processes the records against the library named MASTER.LBY. They are all extract records. Including the /C parameter tells the utility to display a counter to show its progress.

C:\fap\dll>lbrymgrw /rsp=response.rsp /lby=.\deflib\master.lby /c
---      DocuCorp LBRYMGR Utility Program (C)      ---
---      Library Manager Response File Utility     ---

Attempting to read and process Response File <response.rsp>
Successfully processed response file <response.rsp>

Extract (X) Record Statistics:
Records Read                 :     142
Objects not found in Library :       0
Objects extracted            :     142
Objects extract error        :       0


Processing Sync Records

If you have created a response file that contains Sync records, you can run this response file against a target library and the resources listed in the response file will be copied into the target library, provided the last modified date and time for the resource in the response file is newer than the last modified date and time of the resource in the target library.

Example - Synchronizing libraries

In this example, the LBRYMGR utility reads the response file and processes the Sync, records, against the library named MASTER.LBY. The /C parameter tells the utility to display a counter to show its progress.

C:\fap\dll>lbrymgrw /rsp=response.rsp /lby=.\deflib\prod.lby /c
---      DocuCorp LBRYMGR Utility Program (C)      ---
---      Library Manager Response File Utility     ---

Attempting to read and process Response File <response.rsp>
Successfully processed response file <response.rsp>

Sync (S) Record Statistics:
Records Read                 :     142
Objects found in Library     :       0
Objects not found in Library :     142
Objects older or same        :       0
Objects updated index        :       0
Objects added, Ver/Rev ok    :      18
Objects added as new         :     124
Objects added Ver/Rev incr   :       0
Objects Ver/Rev error        :       0
Objects add error            :       0


Converting Libraries

If a library is in an older, pre-version 10.2 format, use the LBRYMGR utility to convert the library to the newer format. The format of the library changed in version 10.2 to increase the lengths of some fields and to add these fields, used for project management:

  • Mode
  • Status
  • Class
  • Project

Example - Converting a library

In this example, you use the /CVTOLD parameter to tell the LBRYMGR utility to convert the library named MASTER.LBY from an older format into the newer format. Before converting the library, the utility backs up the library using file names prefixed with a dollar sign ($). For instance, for the MASTER.LBY library, this table shows the backup files:

This file | Is backed up to
MASTER.DBF | $MASTER.DBF
MASTER.MDX | $MASTER.MDX
MASTER.LBY | $MASTER.LBY

Once the library is backed up, the utility converts it to the newer format.

C:\fap\dll> LBRYMGR /lby=c:\fap\mstrres\rpex1\deflib\master.lby /cvtold

--- DocuCorp LBRYMGR Utility Program (C) ---

--- Library Manager Response File Utility ---

Library <c:\fap\mstrres\rpex1\deflib\master.lby> was successfully backed up.

Library <c:\fap\mstrres\rpex1\deflib\master.lby> was successfully converted.


LBYPROC

Use this utility to process library scripts. Library scripts are XML-based files that let you perform actions on a resource library.

You can use these scripts to peform these tasks:

  • Adding Resources to a library.
  • Deleting Resources from a library.
  • Updating Resources library index record.
  • Extracting Resources from a library (writing the contents to a disk file).
  • Promoting Resources from one library to another.
  • Reversing Changes to Resources that have been promoted.
  • Filtering Resources that match a designated set of filter values.

The scripts are designed to perform the indicated action on multiple resources. For example, a promote script can promote many resources from one library to another and an extract script can extract many resources from the library and write them to disk.

Note You can create and execute scripts for some actions, such as extracting or promoting files, in Studio.

Program names

  • Windows: lbyproc.exe
  • UNIX/Linux: lbyproc
  • z/OS: LBYPROC

Syntax

LBYPROC /I /INI /TEST /T /L /NOLOG /P /S /X

Parameter | Description
/I | Include this parameter to specify the name of the file that contains the library scripts you want the utility to process.
/INI | Include this parameter to specify the name and path of the INI file. The default is FSIUSER.INI.
/TEST | (Optional) Include this parameter to run the utility without actually updating anything. The utility then reports what actions it would perform if it were actually run.
/T | (Optional) Include this parameter to turn on tracing. This can be useful when analyzing problems.
/L | (Optional) Include this parameter to tell the utility to write the INI options to the trace file. This can be useful when analyzing problems.
/NOLOG | (Optional) Include this parameter to suppress the logging of library actions to the library log file.
/P | (Optional) Include this parameter to execute the Promote section in the script. If the script contains no Promote section, no promote occurs.
/S | (Optional) Include this parameter to execute the Filter section in this script. If the script contains no Filter section (possible only in older scripts) no Filter report appears.
/X | (Optional) Include this parameter to execute the Extract section in the script. If the script contains no Extract section, no extract occurs.

See Also

  • Using the /P, /S, and /X Parameters
  • Handling Return Codes


Handling Return Codes

Include these INI options in the LBYPROC control group to control processing and handle the return codes generated during a promotion.

< LBYPROC >
  TermLevel =
  ZeroPromote =

Option

Description

TermLevel

Use this option to tell the utility what to do when it encounters an error. You have these choices:

None - Enter None if you want processing to continue regardless of any warnings or errors.

Error - Enter Error if you want processing to stop if there is an error code.

Warning - Enter Warning if you want processing to stop if there is a warning or error code.

The default is None.

ZeroPromote

When processing a promotion, the system may encounter a situation where there is no data or no change is made. Use this option to tell the system how to handle this situation. You have these choices:

Success - Enter Success if you want the condition of no data or no change to be treated as a successful operation. The return code is zero (0).

Warning - Enter Warning if you want the condition of no data or no change to be treated as a warning. The return code is 4.

Error - Enter Error if you want the condition of no data or no change to be treated as an error. The return code is 8.

The default is Success.


Using the P, S, and X Parameters

If you omit the /P, /S, and /X parameters, the LBYPROC utility executes all sections of the script. If you specify one or more of these parameters, then only the sections of the script controlled by those parameters are executed. Here are some examples:

Assume myscript.lsc is a library script file that contains filter, extract, and promote information.

LBYPROC  /I=myscript.lsc

This command tells the utility to display the filter report and perform the extract and promote using the records from the script filter.

LBYPROC /I=myscript.lsc /X

The /X parameter tells the utility to perform the Extract using the records from the script filter. No promote is performed and the Filter report does not appear.

LBYPROC /I=myscript.lsc /S /P

The /S and /P parameters tell the utility to display the Filter report and perform the promote using the records from the script filter. No extract is performed.

This utility returns these codes upon execution:

Code | Description
0 | SUCCESS
4 | WARNING
8 | ERROR


Compound Library Scripts

A compound library script is a script that consists of more than one script. An example of a compound library script would be one that contains a Filter script and a Promote script, or two Filter scripts and a Promote script, or a Filter script and an Extract script.

Generally, in a compound library script, the Filter scripts are used to select a set of resources and then a Promote or an Extract script is used to perform the actual promotion or extraction of those resources.

See Promoting Resources: Example 4 of a compound library script.


Adding Resources

The LBYPROC utility lets you add resources to your libraries. Here are some examples of how you can add resources.

This table defines the XML tags used in the following Add script examples:

XML tag | Description
LIBRARY | Enter the name of the library to which you want to add resources. Here is an example: <LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
FILENAME | Enter the name and path of the file you want to add. You can include asterisks (*) as wildcards. Here is an example: <FILENAME VALUE=".\forms\q1addr.fap"/> The default is "" which adds all files in the library you specified.
NAME | Enter the name of the file, without the extension or path. You can include asterisks (*) as wildcards. Here is an example: <NAME VALUE="Q1ADDR"/> The default is "" which adds all files in the library you specified.
TYPE | Enter the file extension, such as FAP or LOG. You can include asterisks (*) as wildcards. Here is an example: <TYPE VALUE="FAP"/> The default is "" which adds all files in the library you specified.
DESC | Enter a description of the task you are performing. Here is an example: <DESC VALUE="Added this resource using LBYPROC"/>
EFFDATE | Enter the effective date you want the utility to assign to the resources it will add. Here is an example which shows an effective date of January 1, 2011 <EFFDATE VALUE="20110101"/>
VERSION | Enter the version number you want the utility to assign to the resources it adds. Here is an example: <VERSION VALUE="00001"/>
REVISION | Enter the revision number you want the utility to assign to the resources it adds. Here is an example: <REVISION VALUE="00001"/>
MODE * | Enter the mode you want the utility to assign to the resources it adds or enter "" for any mode. You can also use this tag to enter descriptive text about the resource. Here is an example: <MODE VALUE="Mode-added-via-LBYPROC"/>
STATUS * | Enter the status you want the utility to assign to the resources it adds or enter "" for any status. You can also use this tag to enter descriptive text about the resource. Here is an example: <STATUS VALUE="Status-added-via-LBYPROC"/>
CLASS * | Enter the class you want the utility to assign to the resources it adds or enter "" for any class. You can also use this tag to enter descriptive text about the resource. Here is an example: <CLASS VALUE="Class-added-via-LBYPROC"/>
PROJECT * | Enter the project you want the utility to assign to the resources it adds or enter "" for any project. You can also use this tag to enter descriptive text about the resource. Here is an example: <PROJECT VALUE="Project-added-via-LBYPROC"/>

* You define modes, statuses, classes, and projects when you check in a resource using Documaker Studio. See the Documaker Studio User Guide for more information.

See also the following detailed examples:

  • Adding Resources - Example 1
  • Adding Resources Using Wildcards - Example 2


Adding Resources: Example 1

This example shows how to add a resource to a development library. The script adds a FAP file stored on the disk into a development library. The FAP file is assigned a name of Q1ADDR, a type of FAP, a version of 00001, and a revision of 00001.

If you run the utility with these parameters:

C:\fap\dll\dms1dm>lbyproc /i=deflib\add1.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.
--- Documaker library script processor

ADD Successful.  File<.\forms\Q1ADDR.fap>

Add performed.  The following number of objects were added to the library.

LIBRARY:    DEFLIB\MASTER.LBY
BDFs :      0
GRPs :      0
FORs :      0
FAPs :      1
DDTs :      0
LOGs :      0
DALs :      0
XDDs :      0
-------------
Total:      1

--- LBYPROC Complete ---

Here are the contents of the add1.lsc file, which contains the Add script:

<LBYSCRIPT>
<ADD>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<FILENAME VALUE=".\forms\Q1ADDR.fap"/>
<NAME VALUE="Q1ADDR"/>
<TYPE VALUE="FAP"/>
<VERSION VALUE="00001"/>
<REVISION VALUE="00001"/>
<MODE VALUE=""/>
<STATUS VALUE=""/>
<CLASS VALUE=""/>
<PROJECT VALUE=""/>
</ADD>
</LBYSCRIPT>


Adding Resources: Example 2

When you import multiple resources using the LBYPROC utility, you can include asterisks (*) as wildcards when defining the file name and extension. So instead of having to perform this task for each resource type, such as BDF, GRP, and FOR, you can include a wildcard and perform the task once.

Here is an example of an Add script that includes wildcards:

<LBYSCRIPT>
<ADD>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<FILENAME VALUE=".\lbyproc\addtest\forms\*.fap"/>
<NAME VALUE=""/>
<DESC VALUE="Added this resource using LBYPROC"/>
<TYPE VALUE="FAP"/>
<EFFDATE VALUE="20110101"/>
<VERSION VALUE=""/>
<REVISION VALUE=""/>
<MODE VALUE="MODE-ADDED-VIA-LBYPROC"/>
<STATUS VALUE="STATUS-ADDED-VIA-LBYPROC"/>
<CLASS VALUE="CLASS-ADDED-VIA-LBYPROC"/>
<PROJECT VALUE="PROJECT-ADDED-VIA-LBYPROC"/>
</ADD>
</LBYSCRIPT>


Deleting Resources

The LBYPROC utility lets you delete resources based on their status. Here are some examples of how you can delete resources.

This table defines the XML tags used in the following Deleting Resources Example:

XML tag | Description
LIBRARY | Enter the name of the library to which you want to delete resources. Here is an example: <LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
NAME | Enter the name of the file, without the extension or path. You can include asterisks (*) as wildcards. Here is an example: <NAME VALUE="Q1ADDR"/> The default is "" which deletes all files in the library you specified.
TYPE | Enter the file extension to indicate the type of files you want to delete, such as FAP or LOG. You can include asterisks (*) as wildcards. Here is an example: <TYPE VALUE="FAP"/> The default is "" which adds deletes all types of files in the library you specified.
EFFDATE | Enter the effective date you want the resources that will be deleted to have. Here is an example which shows an effective date of January 1, 2011 <EFFDATE VALUE="20110101"/>
VERSION | Enter the version number you want the resources that will be deleted to have. Here is an example: <VERSION VALUE="00001"/>
REVISION | Enter the revision number you want the resources that will be deleted to have. Here is an example: <REVISION VALUE="00001"/>
MODE * | Enter the mode you want the resources that will be deleted to have or enter "" for any mode. You can also use this tag to enter descriptive text about the resource. Here is an example: <MODE VALUE=""/>
STATUS * | Enter the status you want the resources that will be deleted to have or enter "" for any status. You can also use this tag to enter descriptive text about the resource. Here is an example: <STATUS VALUE="Failed"/>
CLASS * | Enter the class you want the resources that will be deleted to have or enter "" for any class. You can also use this tag to enter descriptive text about the resource. Here is an example: <CLASS VALUE=""/>
PROJECT * | Enter the project you want the resources that will be deleted to have or enter "" for any project. You can also use this tag to enter descriptive text about the resource. Here is an example: <PROJECT VALUE=""/>

* You define modes, statuses, classes, and projects when you check in a resource using Documaker Studio. See the Documaker Studio User Guide for more information.


Deleting Resources Example

This example shows you how to delete resources from a development library. This script removes all FAP resources in the development library (master.lby) which have a status of Failed.

If you run the utility with these parameters:

C:\fap\dll\dms1dm>lbyproc /i=deflib\del1.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.
--- Documaker library script processor

DELETE Successful. Name<Q1ADDR> Type<FAP> Ver<00001> Rev<00001> Note<Normal Deletion>
DELETE Successful. Name<Q1AFLG> Type<FAP> Ver<00001> Rev<00001> Note<Normal Deletion>
DELETE Successful. Name<Q1B302> Type<FAP> Ver<00001> Rev<00001> Note<Normal Deletion>
. . .
DELETE Successful. Name<Q1TILE> Type<FAP> Ver<00001> Rev<00001> Note<Normal Deletion>
DELETE Successful. Name<Q1VRFL> Type<FAP> Ver<00001> Rev<00001> Note<Normal Deletion>

Delete performed.  The following number of objects were
deleted from the library.

LIBRARY:    DEFLIB\MASTER.LBY

BDFs :      0
GRPs :      0
FORs :      0
FAPs :     81
DDTs :      0
LOGs :      0
DALs :      0
XDDs :      0
-------------
Total:     81

--- LBYPROC Complete ---

Here are the contents of the del1.lsc file, which contains the DELETE script:

<LBYSCRIPT>
<DELETE>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<NAME VALUE=""/>
<TYPE VALUE=""/>
<VERSION VALUE=""/>
<REVISON VALUE=""/>
<MODE VALUE=""/>
<STATUS VALUE="FAILED"/>
<CLASS VALUE=""/>
<PROJECT VALUE=""/>
</DELETE>
</LBYSCRIPT>


Updating Resources

The LBYPROC utility lets you update resources based on their status. The LBYPROC utility lets you update the Mode, Status, Class, and Project fields of a resource. For these fields, you specify a VALUE and a NEWVALUE. Here are some examples of how you can update resources.

This table defines the XML tags used in the following Updating Resources Example:

XML tag

Description

LIBRARY

Enter the name of the library which contains the resources you want to update. Here is an example:

<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>

NAME

Enter the name and path of the file without the extension or path. You can include asterisks (*) as wildcards. Here is an example:

<FILENAME VALUE="Q1ADDR"/>

The default is "" which updates all files in the library you specified.

TYPE

Enter the file extension to indicate the type of files you want to delete, such as FAP or LOG. You can include asterisks (*) as wildcards.

Here is an example:

<TYPE VALUE="FAP"/>

The default is "" which adds updates all types of files in the library you specified.

VERSION

Enter the version number you want the utility to assign to the resources it updates.

Here is an example:

<VERSION VALUE=""/>

REVISION

Enter the revision number you want the utility to assign to the resources it updates. Here is an example:

<REVISION VALUE=""/>

MODE *

Use the VALUE attribute to specify the mode of the resources you want to update. Use the NEWVALUE attribute to specify the new value you want to assign in the Mode field. You can enter "" to indicate any value.

Here is an example:

<MODE VALUE="" NEWVALUE="DISCARDED"/>

STATUS *

Use the VALUE attribute to specify the status of the resources you want to update. Use the NEWVALUE attribute to specify the new value you want to assign in the Status field. You can enter "" to indicate any value.

Here is an example of how you can tell the utility to find resources with a status of Test and change that status to Failed:

<STATUS VALUE="Test" NEWVALUE="Failed"/>

CLASS *

Use the VALUE attribute to specify the class of the resources you want to update. Use the NEWVALUE attribute to specify the new value you want to assign in the Class field. You can enter "" to indicate any value. Here is an example:

<CLASS VALUE="" NEWVALUE="US"/>

PROJECT *

Use the VALUE attribute to specify the project of the resources you want to update. Use the NEWVALUE attribute to specify the new value you want to assign in the Project field. You can enter "" to indicate any value. Here is an example:

<PROJECT VALUE="P001" NEWVALUE="P002"/>

* You define modes, statuses, classes, and projects when you check in a resource using Documaker Studio. See the Documaker Studio User Guide for more information.


Updating Resources Example

This example shows you how to update resources in a development library. This script updates all FAP resources in the development library (master.lby) that have a status of Test and changes that status to Failed.

If you run the utility with these parameters:

C:\fap\dll\dms1dm>lbyproc /i=deflib\upd1.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.
--- Documaker library script processor

UPDATE Successful. Name<Q1ADDR> Type<FAP> Ver<00001> Rev<00001> Note<Resource updated>
UPDATE Successful. Name<Q1AFLG> Type<FAP> Ver<00001> Rev<00001> Note<Resource updated>
UPDATE Successful. Name<Q1B302> Type<FAP> Ver<00001> Rev<00001> Note<Resource updated>
. . .
UPDATE Successful. Name<Q1VRFL> Type<FAP> Ver<00001> Rev<00001> Note<Resource updated>

Update performed.  The following number of objects were
updated in the library.

LIBRARY:    DEFLIB\MASTER.LBY

BDFs :      0
GRPs :      0
FORs :      0
FAPs :     81
DDTs :      0
LOGs :      0
DALs :      0
XDDs :      0
-------------
Total:     81

--- LBYPROC Complete ---

Here are the contents of the upd1.lsc file, which contains the Update script:

<LBYSCRIPT>
<UPDATE>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<NAME VALUE=""/>
<TYPE VALUE=""/>
<VERSION VALUE=""/>
<REVISON VALUE=""/>
<MODE VALUE=""/>
<STATUS VALUE="TEST" NEWVALUE="FAILED"/>
<CLASS VALUE=""/>
<PROJECT VALUE=""/>
</UPDATE>
</LBYSCRIPT>


Extracting Resources

On Windows, the LBYPROC utility lets you extract resources and write them to disk. Extractions and promotion operate on the set of records defined by the library filter. A library script can contain these sections:

  • Filter section
  • Extract section
  • Promote section (optional)

This table defines the XML tags used in the following Extract script examples:

  • Example 1
  • Example 2

For information on the Filter section XML tags, see Filtering Resources.

XML tag

Description

LIBRARY

Enter the name of the source library, from which you want the resources extracted. Here is an example:

<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>

FILENAME

Enter the name and path of the file you want to extract. You can include asterisks (*) as wildcards. Here is an example:

<FILENAME VALUE=".\forms\q1addr.fap"/>

The default is "" which adds all files in the library you specified.

NAME

Enter the name of the file, without the extension or path, you want to extract. You can include asterisks (*) as wildcards. Here is an example:

<NAME VALUE="Q1ADDR"/>

The default is "" which adds all files in the library you specified.

TYPE

Enter the file extension to indicate the type of files you want to extract, such as FAP or LOG. You can include asterisks (*) as wildcards.

Here is an example:

<TYPE VALUE="FAP"/>

The default is "" which extracts all files in the library you specified.

DESC

Enter a description of the task you are performing. Here is an example:

<DESC VALUE="Extracted using LBYPROC"/>

VERSION

Enter the version number, such as 00001.

Set this tag to (last) to indicate you only want to extract the latest version of each resource to disk. Here is an example:

<VERSION VALUE="(last)"/>

REVISION

Enter the revision number such as 00001.

Set this tag to (last) to indicate you only want to extract the latest revision of each resource. Here is an example:

<REVISION VALUE="last"/>

USERID

 Enter a specific user ID or enter "" for any user ID. You can use this tag to extract the resources associated with a specific user.

EFFDATE

Enter the effective date you want the utility to use when selecting resources to extract.

Here is an example which shows an effective date of January 1, 2011

<EFFDATE VALUE="20110101"/>

MODE *

Enter the name of the mode assigned to the resources you want to extract or "" for any mode. You can use this tag, for instance, to extract resources assigned to a specific mode.

STATUS *

Enter the name of the status assigned to the resources you want to extract or "" for any status. You can use this tag, for instance, to extract resources assigned a specific status.

CLASS *

Enter the name of the class assigned to the resources you want to extract or "" for any class. You can use this tag, for instance, to extract resources assigned a specific class.

PROJECT *

Enter the name of the project assigned to the resources you want to extract or "" for any class. You can use this tag, for instance, to extract resources assigned a specific project.

ALLLIB

Enter the target directory. Here is an example that tells the utility to place the resources it extracts into the ext directory.

<ALLLIB VALUE=".\ext\"/>
xxxLIB

Enter the path for the library. Here are some examples:

<BDFLIB VALUE=""/>

<GRPLIB VALUE=""/>

<FORLIB VALUE=""/>

The default is "", which tells the utility to extract resources from any library.

LONGFILENAME

Enter Yes to tell the utility to write the resources it extracts to disk using the versioned or long name.

The long name consists of the resource name followed by an underscore, the version and revision of the resource. another underscore, the effective date of the resource, a period, and the resource type. For example, the long name of version 1 revision 3 of the RPEX1DM BDF resource is called:

RPEX1DM_0000100003_20110101.bdf

Setting this option to Yes allows multiple versions/revisions of the same resource to be written to disk and identified uniquely. Here is an example”

<LONGFILENAME VALUE="Yes"/><LONGFILENAME VALUE="Yes"/>

* You define modes, statuses, classes, and projects when you check in a resource using Documaker Studio. See the Documaker Studio User Guide for more information.

Note In newer scripts that contain both a Extract section and a Filter section, the extract values are ignored because the Filters section defines the resources to extract. For more information on the XML tags you can use in Filter sections, see Filtering Resources.


Extracting Resources: Example 1

This example extracts all resources from the development library and writes them to disk. This script tells the utility to extract all resources from the library (MASTER.LBY) and write the resources into the “.\ext\” directory. You specify the target directory using the ALLLIB tag.

Set the LONGFILENAME tag to Yes to tell the utility to write the resources to disk using the versioned or long name. The long name of the resource consists of the resource name followed by an underscore, followed by the version and revision of the resource followed by an underscore, followed by the effective date of the resource, followed by a period and the resource type. For example, the long name of version 1 revision 3 of the RPEX1DM BDF resource is called:

RPEX1DM_0000100003_19800101.bdf

Setting the LONGFILENAME tag to Yes allows multiple versions/revisions of the same resource to be written to disk and identified uniquely.

If you run the utility with these parameters:

c:\fap\dll\rpex1dm>lbyproc /i=deflib\ext1.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.
--- Documaker library script processor

Found <1> Library Scripts

EXTRACT Successful. Filename<.\ext\RPEX1DM_0000100001_19800101.bdf> Name<RPEX1DM> Type<BDF> Ver<00001> Rev<00001> Note<File did not exist yet>
EXTRACT Successful. Filename<.\ext\RPEX1DM_0000100002_19800101.bdf> Name<RPEX1DM> Type<BDF> Ver<00001> Rev<00002> Note<File did not exist yet>
EXTRACT Successful. Filename<.\ext\RPEX1DM_0000100003_19800101.bdf> Name<RPEX1DM> Type<BDF> Ver<00001> Rev<00003> Note<File did not exist yet>
EXTRACT Successful. Filename<.\ext\RPEX1DM_0000200001_20060901.bdf> Name<RPEX1DM> Type<BDF> Ver<00002> Rev<00001> Note<File did not exist yet>
EXTRACT Successful. Filename<.\ext\ADDCOM_0000100001_19800101.dal> Name<ADDCOM> Type<DAL> Ver<00001> Rev<00001> Note<File did not exist yet>
EXTRACT Successful. Filename<.\ext\ADDCOM_0000100002_19800101.dal> Name<ADDCOM> Type<DAL> Ver<00001> Rev<00002> Note<File did not exist yet>
. . .
EXTRACT Successful. Filename<.\ext\SYMBOL_0000100001_19800101.XDD> Name<SYMBOL> Type<XDD> Ver<00001> Rev<00001> Note<File did not exist yet>

--- LBYPROC Complete ---

Here are the contents of the ext1.lsc file, which contains the Extract script:

<LBYSCRIPT>
<EXTRACT>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<FILENAME VALUE=""/>
<NAME VALUE=""/>
<TYPE VALUE=""/>
<DESC VALUE=""/>
<VER VALUE=""/>
<REV VALUE=""/>
<USERID VALUE=""/>
<EFFDATE VALUE=""/>
<MODE VALUE=""/>
<STATUS VALUE=""/>
<CLASS VALUE=""/>
<PROJECT VALUE=""/>
<ALLLIB VALUE=".\ext\"/>
<BDFLIB VALUE=""/>
<GRPLIB VALUE=""/>
<FORLIB VALUE=""/>
<FAPLIB VALUE=""/>
<DDTLIB VALUE=""/>
<LOGLIB VALUE=""/>
<DALLIB VALUE=""/>
<DEFLIB VALUE=""/>
<LONGFILENAME VALUE="Yes"/>
</EXTRACT>
</LBYSCRIPT>


Extracting Resources: Example 2

This example shows you how to extract the last version and revision of all FAP resources from the development library and write them to disk. This script tells the utility to extract FAP resources from the library (MASTER.LBY) and write the resources to the “.\ext\” directory. You specify the target directory using the ALLLIB tag.

Set the VER VALUE tag to (last) to indicate that you only want to extract the latest version of each resource to disk. Also set the REV VALUE tag to (last) to indicate you only want to extract the latest revision of each resource. This combination means that, for any given resource, the utility will only extract the latest revision of the latest version of that resource.

VER VALUE=(last)

REV VALUE=(last)

Since you are asking for only the latest version and revision of each FAP resource, set the LONGFILENAME tag to No. So instead of the resource Q1ADDR.FAP being written to disk with a long name of Q1ADDR_0000100001_19800101.fap, it is written to disk with a name of Q1ADDR.FAP.

If you run the utility with these parameters:

c:\fap\dll\dms1dm>lbyproc /i=deflib\ext2.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Documaker library script processor

Found <1> Library Scripts

EXTRACT Successful. Filename<.\ext\Q1ADDR.fap> Name<Q1ADDR> Type<FAP> Ver<00001> Rev<00001> Note<File did not exist yet>

EXTRACT Successful. Filename<.\ext\Q1AFLG.fap> Name<Q1AFLG> Type<FAP> Ver<00001> Rev<00001> Note<File did not exist yet>

EXTRACT Successful. Filename<.\ext\Q1B302.fap> Name<Q1B302> Type<FAP> Ver<00001> Rev<00001> Note<File did not exist yet>

EXTRACT Successful. Filename<.\ext\Q1BA32.fap> Name<Q1BA32> Type<FAP> Ver<00001> Rev<00001> Note<File did not exist yet>

. . .

EXTRACT Successful. Filename<.\ext\Q1VRFL.fap> Name<Q1VRFL> Type<FAP> Ver<00001> Rev<00001> Note<File did not exist yet>

--- LBYPROC Complete ---

Here are the contents of the ext2.lsc file, which contains the Extract script:

<LBYSCRIPT>
<EXTRACT>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<FILENAME VALUE=""/>
<NAME VALUE=""/>
<TYPE VALUE="FAP"/>
<DESC VALUE=""/>
<VERSION VALUE="(last)"/>
<REVISON VALUE="(last)"/>
<USERID VALUE=""/>
<EFFDATE VALUE=""/>
<MODE VALUE=""/>
<STATUS VALUE=""/>
<CLASS VALUE=""/>
<PROJECT VALUE=""/>
<ALLLIB VALUE=".\ext\"/>
<BDFLIB VALUE=""/>
<GRPLIB VALUE=""/>
<FORLIB VALUE=""/>
<FAPLIB VALUE=""/>
<DDTLIB VALUE=""/>
<LOGLIB VALUE=""/>
<DALLIB VALUE=""/>
<DEFLIB VALUE=""/>
<LONGFILENAME VALUE="No"/>
</EXTRACT>
</LBYSCRIPT>


Promoting Resources

The LBYPROC utility lets you promote resources from one library to another. Promotions and extractions operate on the set of records defined by the library filter. A library script can contain these sections:

  • Filter section
  • Promote section
  • Extract section (optional)

This table defines the XML tags used in the following Promote script examples. For information on the Filter section XML tags, see Filtering Resources.

XML tag

Description

LIBRARY

Enter the name of the source library. You can also use this tag to indicate a target library, to which you want the resources promoted. Here is an example:

<LIBRARY SRC="LBYDEV" TGT="LBYTEST"/>

NAME

Enter the name of the file, without the extension or path, such as Q1ADDR. You can include asterisks (*) as wildcards. The default is "", which tells the utility to select all files in the source library.

TYPE

Enter the file extension, such as FAPThis lets you promote only specific types of files, like FAP files or LOG files. You can include asterisks (*) as wildcards.

The default is "", which tells the utility to select all types of files in the source library.

VERSION

Enter the version number, such as 00001.

Set this tag to (last) to indicate you only want to promote the latest version of each resource.

The default is "", which tells the utility to select all versions in the source library.

REVISION

Enter the revision number such as 00001.

Set this tag to (last) to indicate you only want to promote the latest revision of each resource.

The default is "", which tells the utility to select all revisions in the source library.

USERID

 Enter a specific user ID or enter "" for any user ID. This lets you promote resources tied to a specific user.

EFFDATE

Enter the effective date you want the utility to assign to the resources it will promote.

Here is an example which shows an effective date of January 1, 2011

<EFFDATE VALUE="20110101"/>

MODE *

This specifies the mode value the source library resources must have to be promoted. You can include these attributes:

  • SRC - Specifies the mode the source library resources must have to be promoted. Enter a specific mode or "" for any mode.
  • TGT - (Optional) Specifies the mode the resources in the target library must have to be promoted. Enter a specific mode or "" if you want the mode to remain unchanged.
  • FINAL - (Optional) Specifies the mode the utility will write into the source library resource record after the promotion Enter a specific mode or "" if you want the mode to remain unchanged.

Here is an example:

<MODE SRC="" TGT="" FINAL=""/>

STATUS *

This specifies the status value the source library resources must have to be included in the promotion. You can include these attributes:

  • SRC - Specifies the status the source library resources must have to be promoted. Enter a specific status or "" for any status.
  • TGT - (Optional) Specifies the status the utility will write into the target library resource record after the promotion. Enter a specific status or "" if you want the status to remain unchanged.
  • FINAL - (Optional) Specifies the status the utility will write into the source library resource record after the promotion. Enter a specific status or "" if you want the status to remain unchanged.

Here is an example:

<STATUS SRC="PASSED" TGT="TEST" FINAL="PROMOTED"/>

CLASS *

This specifies the class value the source library resources must have to be included in the promotion. You can include these attributes:

  • SRC - Specifies the class the source library resources must have to be promoted. Enter a specific class or "" for any class:
  • TGT - (Optional) Specifies the class the utility will write into the target library resource record after the promotion. Enter a specific status or "" if you want the class to remain unchanged.
  • FINAL - (Optional) Specifies the class the utility will write into the source library resource record after the promotion. Enter a specific class or "" if you want the class to remain unchanged.

Here is an example:

<CLASS SRC="" TGT="" FINAL=""/>

PROJECT *

This specifies the project value the source library resources must have to be included in the promotion. You can include these attributes:

  • SRC - Specifies the project code the source library resources must have to be promoted. Enter a specific project or "" for any project:
  • TGT - (Optional) Specifies the project the utility will write into the target library resource record after the promotion. Enter a specific project or "" if you want the project to remain unchanged.
  • FINAL - (Optional) Specifies the project the utility will write into the source library resource record after the promotion. Enter a specific project or "" if you want the project to remain unchanged.

Here is an example:

<PROJECT SRC="" TGT="" FINAL=""/>

* You define modes, statuses, classes, and projects when you check in a resource using Documaker Studio. See the Documaker Studio User Guide for more information.

Note In newer scripts that contain both a Promote section and a Filter section, the promote SRC values are ignored because the Filters section defines the resources to promote. For more information on the XML tags you can use in Filter sections, see Filtering Resources.

Here are some examples of how you can promote resources:

  • Example 1
  • Example 2
  • Example 3
  • Example 4


Promoting Resources: Example 1

This example promotes all resources from a development library into a test library. This example script specifies the source library name (MASTER.LBY) and the target library name (TEST.LBY). In this example, both libraries are in xBase format.

If you run the utility with these parameters:

c:\fap\dll\dms1dm>lbyproc /i=deflib\pro1.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Documaker library script processor

Found <1> Library Scripts

PROMOTE Successful. Name<DMS1DM> Type<BDF> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<ADDCOM> Type<DAL> Ver<00001> Rev<00001> Note<Normal promotion>

. . .

--- LBYPROC Complete ---

Here are the contents of the pro1.lsc file, which contains the Promote script:

<LBYSCRIPT>
<PROMOTE>
<LIBRARY SRC="DEFLIB\MASTER.LBY" TGT="DEFLIB\TEST.LBY"/>
<NAME SRC=""/>
<TYPE SRC=""/>
<VERSION SRC=""/>
<REVISION SRC=""/>
<USERID SRC=""/>
<EFFDATE SRC="" />
<TEMPNAME SRC="" />
<MODE SRC="" TGT=""/>
<STATUS SRC="" TGT="*"/>
<CLASS SRC="" TGT="*"/>
<PROJECT SRC="" TGT="*"/>
</PROMOTE>
</LBYSCRIPT>


Promoting Resources: Example 2

This example uses the /TEST parameter to preview what the Promote script will do. This script promotes all resources that have a status of Passed from the development library (MASTER.LBY) into the test library (TEST.LBY).

You first run the LBYPROC utility using the /TEST parameter so you can see a preview of what will be promoted. After running it with the /TEST parameter, remove this parameter and run the utility again to actually promote resources.

Resources in the source library (MASTER.LBY) that have a status of Passed are promoted to the target library (TEST.LBY). In the target library, these newly promoted resources are assigned a status of Test. Upon successful promotion, the resources in the source library that were promoted are assigned a status of Promoted.

If you run the utility with these parameters:

c:\fap\dll\dms1dm>lbyproc /i=deflib\pro2.lsc /test

You will get this output from the utility when running in Test mode:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Documaker library script processor

Found <1> Library Scripts

(Preview)PROMOTE Successful. Name<SETRCPTB> Type<DAL> Ver<00001> Rev<00001> Note<Normal promotion>

(Preview)PROMOTE Successful. Name<Q1ADDR> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

(Preview)PROMOTE Successful. Name<Q1AFLG> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

(Preview)PROMOTE Successful. Name<Q1B302> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

(Preview)PROMOTE Successful. Name<CGDEC> Type<FOR> Ver<00001> Rev<00001> Note<Normal promotion>

(Preview)PROMOTE Successful. Name<Q1DLOG> Type<LOG> Ver<00001> Rev<00001> Note<Normal promotion>

--- LBYPROC Complete ---

Use a command similar to this one to actually promote the resources:

c:\fap\dll\dms1dm>lbyproc /i=deflib\pro2.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Documaker library script processor

Found <1> Library Scripts

PROMOTE Successful. Name<SETRCPTB> Type<DAL> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<Q1ADDR> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<Q1AFLG> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<Q1B302> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<CGDEC> Type<FOR> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<Q1DLOG> Type<LOG> Ver<00001> Rev<00001> Note<Normal promotion>

--- LBYPROC Complete ---

Here are the contents of the pro2.lsc file, which contains the Promote script:

<LBYSCRIPT>

<PROMOTE>
<LIBRARY SRC="DEFLIB\MASTER.LBY" TGT="DEFLIB\TEST.LBY"/>
<NAME SRC=""/>
<TYPE SRC=""/>
<VERSION SRC=""/>
<REVISION SRC=""/>
<USERID SRC=""/>
<EFFDATE SRC="" />
<TEMPNAME SRC="" />
<MODE SRC="" TGT=""/>
<STATUS SRC="PASSED" TGT="TEST" FINAL="PROMOTED"/>
<CLASS SRC="" TGT="*"/>
<PROJECT SRC="" TGT="*"/>
</PROMOTE>

</LBYSCRIPT>


Promoting Resources: Example 3

This example shows how to promote resources from a development library (in SQL Server) to a test library (in SQL Server). This script specifies the source library name (LBYDEV) and the target library name (LBYTEST). Each library is stored in an SQL Server database.

Resources in the source library (LBYDEV) that have a status of Passed are promoted to the target library (LBYTEST). In the target library, these newly promoted resources are assigned a status of Test. Upon successful promotion, the resources in the source library that were promoted are assigned a status of Promoted.

If you run the utility with these parameters:

c:\fap\dll\dms1dm>lbyproc /i=deflib\pro3.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Documaker library script processor

Found <1> Library Scripts

PROMOTE Successful. Name<Q1ADDR> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<Q1AFLG> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<Q1B302> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<Q1BA32> Type<FAP> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<SUPPLEMENT> Type<FOR> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<FSI_CPP> Type<GRP> Ver<00001> Rev<00001> Note<Normal promotion>

PROMOTE Successful. Name<Q1DLOG> Type<LOG> Ver<00001> Rev<00001> Note<Normal promotion>

--- LBYPROC Complete ---

Here are the contents of the pro3.lsc file, which contains the Promote script:

<LBYSCRIPT>

<PROMOTE>
<LIBRARY SRC="LBYDEV" TGT="LBYTEST"/>
<NAME SRC=""/>
<TYPE SRC=""/>
<VERSION SRC=""/>
<REVISION SRC=""/>
<USERID SRC=""/>
<EFFDATE SRC=""/>
<MODE SRC="" TGT="" FINAL=""/>
<STATUS SRC="PASSED" TGT="TEST" FINAL="PROMOTED"/>
<CLASS SRC="" TGT="" FINAL=""/>
<PROJECT SRC="" TGT="" FINAL=""/>
</PROMOTE>

</LBYSCRIPT>

Here are the INI options that relate to the ODBC database handlers and library tables used for this example:

< DBHandler:LBYSETUP >

Class             = ODBC
CreateTable       = Yes
Debug             = No
Description       = Original ODBC handler in SQL Server
Passwd            = pw
Server            = SQLDEV    (ODBC Data Source Name)
UserID            = userid

< DBHandler:LBYTEST >

Class             = ODBC
CreateTable       = Yes
Debug             = No
Description       = ODBC handler for Test database in SQL Server
Passwd            = pw
Server            = SQLTEST   (ODBC Data Source Name)
UserID            = userid

< DBTable:CATALOG >

DBHandler         = LBYSETUP

< DBTable:LBYDEV >

DBHandler         = LBYSETUP

< DBTable:LBYDEVD >

DBHandler         = LBYSETUP

< DBTable:LBYTEST >

DBHandler         = LBYTEST

< DBTable:LBYTESTD >

DBHandler         = LBYTEST

< Library:LBYDEV >

DBTable           = LBYDEVD
Description       = Development library in SQL Server

< Library:LBYTEST >

DBTable           = LBYTESTD
Description       = Test library in SQL Server

< ODBC_FileConvert >

CATALOG           = dbo.DMKR_CATALOG
LBYDEV            = dbo.DMKR_LBYDEV
LBYDEVD           = dbo.DMKR_LBYDEVD
LBYTEST           = dbo.DMKR_LBYTEST
LBYTESTD          = dbo.DMKR_LBYTESTD


Promoting Resources: Example 4

Here is an example of a Promote script that also contains two Filter scripts — a compound script.

This script contains two Filter scripts and one Promote script. The first Filter script searches the library for all resources that have a status of Passed. Since the <LO> tag is set to zero (0), the results of this filter replace any current (existing) results. There are no current results, so you start with the results of this filter.

Because the second Filter script's <LO> tag is set to one (1), this script searches the current results — the results produced by the first Filter script — for resources that have a project equal to P001.

After the utility executes the second Filter script, the results consist of library resources that have a status of Passed and a project of P001. Note that you could have gotten the same results with a single Filter script that specified both of these criteria.

The Promote script then promotes these resources to the test\deflib\master.lby library.

<LBYSCRIPT>
<FILTER>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<LO VALUE="0"/>
<NAME VALUE=""/>
<DESC VALUE=""/>
<TYPE VALUE=""/>
<VERSION VALUE=""/>
<REVISION VALUE=""/>
<USERID VALUE=""/>
<EFFDATE VALUE=""/>
<LOCKED VALUE=""/>
<MODE VALUE=""/>
<STATUS VALUE="PASSED"/>
<CLASS VALUE=""/>
<PROJECT VALUE=""/>
<OBJECTTYPE VALUE=""/>
<OBJECTNAME VALUE=""/>
<OBJECTTEXT VALUE=""/>
<OBJECTTEXTCASE VALUE=""/>
</FILTER>

<FILTER>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<LO VALUE="1"/>
<NAME VALUE=""/>
<DESC VALUE=""/>
<TYPE VALUE=""/>
<VERSION VALUE=""/>
<REVISION VALUE=""/>
<USERID VALUE=""/>
<EFFDATE VALUE=""/>
<LOCKED VALUE=""/>
<MODE VALUE=""/>
<STATUS VALUE=""/>
<CLASS VALUE=""/>
<PROJECT VALUE="P001"/>
<OBJECTTYPE VALUE=""/>
<OBJECTNAME VALUE=""/>
<OBJECTTEXT VALUE=""/>
<OBJECTTEXTCASE VALUE=""/>
</FILTER>

<PROMOTE>
<LIBRARY SRC="DEFLIB\MASTER.LBY" TGT="..\TEST\DEFLIB\ MASTER.LBY"/>
<NAME SRC=""/>
<TYPE SRC=""/>
<VERSION SRC=""/>
<REVISION SRC=""/>
<USERID SRC=""/>
<EFFDATE SRC=""/>
<MODE SRC="" TGT="" FINAL=""/>
<STATUS SRC="" TGT="" FINAL=""/>
<CLASS SRC="" TGT="" FINAL=""/>
<PROJECT SRC="" TGT="" FINAL=""/>
</PROMOTE>
</LBYSCRIPT>
Note If you include a filter in the script and you use the /P parameter (but omit /S), the utility still only promotes the records identified by the filter. For information on the XML tags used in the Filter section, see Filtering Resources.


Reversing Changes to Resources

The LBYPROC utility lets you roll back changes to resources, such as promotions.

This table defines the XML tags used in the following Rollback script examples. For information on the Filter section XML tags, see Filtering Resources.

XML tag

Description

LIBRARY

Enter the name of the source library. You can also use this tag to indicate a target library, to which you want the resources rolled back. Here is an example:

<LIBRARY SRC="LBYDEV" TGT="LBYDEV"/>

NAME

Enter the name of the file, without the extension or path, such as Q1ADDR. You can include asterisks (*) as wildcards.

The default is "", which tells the utility to select all files in the source library.

TYPE

Enter the file extension, such as FAPThis lets you roll back only specific types of files, like FAP files or LOG files. You can include asterisks (*) as wildcards.

The default is "", which tells the utility to select all types of files in the source library.

VERSION

Enter the version number, such as 00001.

Set this tag to (last) to indicate you only want to roll back the latest version of each resource.

The default is "", which tells the utility to select all versions in the source library.

REVISION

Enter the revision number such as 00001.

Set this tag to (last) to indicate you only want to roll back the latest revision of each resource.

The default is "", which tells the utility to select all revisions in the source library.

USERID

 Enter a specific user ID or enter "" for any user ID. This lets you roll back resources tied to a specific user.

EFFDATE

Enter the effective date you want the utility to assign to the resources you want to roll back.

Here is an example which shows an effective date of January 1, 2011

<EFFDATE VALUE="20110101"/>

MODE *

This specifies the mode value the source library resources must have to be rolled back. You can include these attributes:

  • SRC - Specifies the mode the source library resources must have to be rolled back. Enter a specific mode or "" for any mode.
  • TGT - (Optional) Specifies the mode the resources in the target library must have to be rolled back. Enter a specific mode or "" if you want the mode to remain unchanged.
  • FINAL - (Optional) Specifies the mode the utility will write into the source library resource record after the roll back. Enter a specific mode or "" if you want the mode to remain unchanged.

Here is an example:

<MODE SRC="" TGT="" FINAL=""/>

STATUS *

This specifies the status value the source library resources must have to be included in the promotion. You can include these attributes:

  • SRC - Specifies the status the source library resources must have to be rolled back. Enter a specific status or "" for any status.
  • TGT - (Optional) Specifies the status the resources in the target library must have to be rolled back. Enter a specific status or "" if you want the status to remain unchanged.
  • FINAL - (Optional) Specifies the status the utility will write into the source library resource record after the roll back. Enter a specific status or "" if you want the status to remain unchanged.

Here is an example:

<STATUS SRC="PASSED" TGT=""/>

CLASS *

This specifies the class value the source library resources must have to be rolled back. You can include these attributes:

  • SRC - Specifies the class the source library resources must have to be rolled back. Enter a specific class or "" for any class:
  • TGT - (Optional) Specifies the class the utility will write into the target library resource record to be rolled back. Enter a specific status or "" if you want the class to remain unchanged.
  • FINAL - (Optional) Specifies the class the utility will write into the source library resource record after the roll back. Enter a specific class or "" if you want the class to remain unchanged.

Here is an example:

<CLASS SRC="" TGT="" FINAL=""/>

PROJECT *

This specifies the project value the source library resources must have to be rolled back. You can include these attributes:

  • SRC - Specifies the project code the source library resources must have to be rolled back. Enter a specific project or "" for any project:
  • TGT - (Optional) Specifies the project the resources in the target library must have to be rolled back. Enter a specific project or "" if you want the project to remain unchanged.
  • FINAL - (Optional) Specifies the project the utility will write into the source library resource record after the roll back. Enter a specific project or "" if you want the project to remain unchanged.

Here is an example:

<PROJECT SRC="" TGT="" FINAL=""/>

* You define modes, statuses, classes, and projects when you check in a resource using Documaker Studio. See the Documaker Studio User Guide for more information.

Here are some examples of how you can roll back changes:

  • Example 1
  • Example 2


Reversing Changes: Example 1

The LBYPROC utility lets you process a Rollback script to reverse the library updates which occurred from processing a Promote script. You can roll back changes in test mode to first verify what changes are reversed..

In addition, the utility writes statistical information, such as how many resources promoted, rolled back, and so on, for each script and also lets you specify and also lets you specify the version and revision.

Here are examples of using a Rollback script with and without TEST mode:

LBYPROC /I=DEFLIB\roll1.LSC /TEST

LBYPROC /I=DEFLIB\roll1.LSC

Here is an example a Rollback script:

<DOCUMENT TYPE="RPWIP" VERSION="11.3">

<LBYSCRIPT>
<ROLLBACK>
<LIBRARY SRC="..\TEST\DEFLIB\MASTER.LBY" TGT="DEFLIB\MASTER.LBY"/>
<NAME SRC=""/>
<TYPE SRC=""/>
<VERSION SRC=""/>
<REVISION SRC=""/>
<USERID SRC=""/>
<EFFDATE SRC=""/>
<MODE SRC="" TGT="" FINAL=""/>
<STATUS SRC="PASSED" TGT=""/>
<CLASS SRC="" TGT="" FINAL=""/>
<PROJECT SRC="" TGT="" FINAL=""/>
</ROLLBACK>
</LBYSCRIPT>

</DOCUMENT>

Here is an example of the statistical output:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Documaker library script processor

ROLLBACK Successful. Name<DEV> Type<BDF> Ver<00001> Rev<00002> Note<Normal rollback>

ROLLBACK Successful. Name<SETRCPTB> Type<DAL> Ver<00001> Rev<00002> Note<Normal rollback>

ROLLBACK Successful. Name<MASTER> Type<DDT> Ver<00001> Rev<00002> Note<Normal rollback>

ROLLBACK Successful. Name<Q1ADDR> Type<FAP> Ver<00001> Rev<00002> Note<Normal rollback>

ROLLBACK Successful. Name<BARCODE FORM> Type<FOR> Ver<00001> Rev<00002> Note<Normal rollback>

ROLLBACK Successful. Name<FSI_CPP> Type<GRP> Ver<00001> Rev<00002> Note<Normal rollback>

ROLLBACK Successful. Name<Q1DLOG> Type<LOG> Ver<00001> Rev<00002> Note<Normal rollback>

ROLLBACK Successful. Name<SYMBOL> Type<XDD> Ver<00001> Rev<00002> Note<Normal rollback>

Rollback performed. The following number of objects were

rolled back from the source library to the target library.

SOURCE LIBRARY: ..\TEST\DEFLIB\MASTER.LBY

TARGET LIBRARY: DEFLIB\MASTER.LBY

BDFs : 1

GRPs : 1

FORs : 1

FAPs : 1

DDTs : 1

LOGs : 1

DALs : 1

XDDs : 1

-------------

Total: 8

--- LBYPROC Complete ---


Reversing Changes: Example 2

This example shows you how to reverse changes to resources from a test library (in SQLServer) to a development library (in SQL Server).

This example reverses the promotion performed in Promoting Resources. The LBYPROC utility is run with a single Rollback script. The Rollback script specifies the source library name (LBYTEST) and the target library name (LBYDEV). Each library is stored in an SQL server database. Note that the source library is the library you are rolling back from and the target library is the library you are rolling back to.

Note A rollback does not copy any resources from the source library to the target library. A rollback removes a resource from the source library and, optionally, updates the Mode, Status, Class, and/or Project fields of that resource in the target library to a value you assign, like RolledBack, to indicate that it has been rolled back from a higher library.

In this example, resources in the source library (LBYTEST) that have a status of TEST are removed from this library. In the target library (LBYDEV), these resources are then assigned a status of RolledBack.

If you run the utility with these parameters:

C:\fap\dll\dms1dm>lbyproc /i=deflib\roll3.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Documaker library script processor

ROLLBACK Successful. Name<Q1ADDR> Type<FAP> Ver<00001> Rev<00001> Note<Normal rollback>

ROLLBACK Successful. Name<Q1AFLG> Type<FAP> Ver<00001> Rev<00001> Note<Normal rollback>

ROLLBACK Successful. Name<Q1B302> Type<FAP> Ver<00001> Rev<00001> Note<Normal rollback>

ROLLBACK Successful. Name<Q1BA32> Type<FAP> Ver<00001> Rev<00001> Note<Normal rollback>

ROLLBACK Successful. Name<SUPPLEMENT> Type<FOR> Ver<00001> Rev<00001> Note<Normal rollback>

ROLLBACK Successful. Name<FSI_CPP> Type<GRP> Ver<00001> Rev<00001> Note<Normal rollback>

ROLLBACK Successful. Name<Q1DLOG> Type<LOG> Ver<00001> Rev<00001> Note<Normal rollback>

--- LBYPROC Complete ---

Here are the contents of the pro3.lsc file, which contains the Rollback script:

<LBYSCRIPT>

<ROLLBACK>

<LIBRARY SRC="LBYTEST" TGT="LBYDEV"/>

<NAME SRC=""/>

<TYPE SRC=""/>

<VERSION SRC=""/>

<REVISION SRC=""/>

<USERID SRC=""/>

<EFFDATE SRC=""/>

<MODE SRC="" TGT=""/>

<STATUS SRC="TEST" TGT="ROLLEDBACK"/>

<CLASS SRC="" TGT=""/>

<PROJECT SRC="" TGT=""/>

</ROLLBACK>

</LBYSCRIPT>


Filtering Resources

The LBYPROC utility lets you filter lists of resources so you can select only the resources you want to work with. This table defines the XML tags used in the following example and in the Filter section of Promoting Resources: Example 4.

XML tag

Description

LIBRARY

Enter the name of the library that contains the resources you want to include. Here is an example:

<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
LO

Use this option if your script contains multiple Filter scripts. The LO tag tells the utility what to do with the matching records for this script.

If you use the Library Search wizard in Documaker Studio to create the library script, it automatically sets the LO option to the appropriate value.

The possible values are:

0 - Replace all current results with matching records.

1 - Search within current results only.

2 - Add matching records to current results.

3 - Remove matching records from current results.

NAME

Enter the name of the file you want to include, without the extension or path. You can include asterisks (*) as wildcards.

The default is "", which tells the utility to select all files in the source library.
DESC

Enter a description assigned to the resources you want to include. Here is an example

<DESC VALUE="Added using LBYPROC"/>

TYPE

Enter the file extension, such as FAPThis lets you promote only specific types of files, like FAP files or LOG files.

The default is "", which tells the utility to select all types of files in the source library.

VERSION

You can enter the version number, such as 00001, or you can set this tag to (last) to indicate you only want to include the latest version of each resource to disk.

The default is "", which tells the utility to select all versions in the source library.

REVISION

You can enter a revision number, such as 00001, or you can set this tag to (last) to indicate you only want to include the latest revision of each resource to disk.

The default is "", which tells the utility to select all revisions in the source library.

USERID

Enter a specific user ID or enter "" for any user ID. This lets you promote include resources assigned to a specific user.

EFFDATE

Enter the effective date of the resources you want to include.

Here is an example which shows an effective date of January 1, 2011

<EFFDATE VALUE="20110101"/>

LOCKED

Enter No if you do not want to include locked resources. Enter Yes if you want to promote only locked resources. The default is "", which tells the utility to promote both locked and unlocked resources.

MODE *

This specifies the mode value the source library resources must have to be included in the operation. The default is "", which tells the utility to select all modes in the source library.

Here is an example:

<MODE VALUE="DEVELOPMENT"/>

STATUS *

This specifies the status value the source library resources must have to be included in the operation. The default is "", which tells the utility to select all statuses in the source library.

Here is an example:

<STATUS VALUE="PROMOTED"/>

CLASS *

This specifies the class value the source library resources must have to be included in the operation. The default is "", which tells the utility to select all classes in the source library. Here is an example:

<CLASS VALUE="GA"/>

PROJECT *

This specifies the project value the source library resources must have to be included in the operation. The default is "", which tells the utility to select all projects in the source library. Here is an example:

<PROJECT VALUE="PROJECT1"/>

OBJECTTYPE

Enter an object type or enter "" for any type of object. Here is an example:

<OBJECTTYPE VALUE="TEXT"/>

OBJECTNAME

Enter the name of the resource or enter "" for any resource. Here is an example:

<OBJECTNAME VALUE=""/>

OBJECTTEXT

Enter the text contained in the resource to filter on or enter "" for any text. Here is an example:

<OBJECTTYPE VALUE="TEXT"/>

<OBJECTTEXT VALUE="POLICY"/>

This tells the utility to filter for text objects that contain the word POLICY.

OBJECTTEXTCASE

Enter the case of the text in the resource you want to filter on or enter ""for any case. Here is an example:

<OBJECTTEXTCASE VALUE="UPPERCASE"/>

* You define modes, statuses, classes, and projects when you check in a resource using Documaker Studio. See the Documaker Studio User Guide for more information.

See Filtering Resources Example of how you can filter resources.


Filtering Resources Example

This example filters the development library for all FAP files that contain a Text element with the value POLICY. (Only on Windows.)

In this example you specify the source library name (MASTER.LBY), the type (FAP) of resources you want to search, the type of object (TEXT, such as a Text Label or Text Area) within each FAP file you want to search, and the text string (POLICY) you are searching for, within each of those TEXT objects.

If you run the utility with these parameters:

c:\fap\dll\dms1dm>lbyproc /i=deflib\filter1.lsc

You will get this output from the utility:

--- LBYPROC Copyright (C) 1997, 2009 Oracle. All rights reserved.

--- Documaker library script processor

Found <1> Library Scripts

Search parameters follow:

Library : DEFLIB\MASTER.LBY

Type : FAP

Object Type : TEXT

Object Name :

Object Text : POLICY

Object TextCase :

Found match: <Q1AFLG> <FAP> <00001> <00001> <Initial check in>

Found match: <Q1BA32> <FAP> <00001> <00001> <Initial check in>

Found match: <Q1BA36> <FAP> <00001> <00001> <Initial check in>

. . .

SEARCH Successful. Found <23> matching resources.

--- LBYPROC Complete ---

Here are the contents of the filter1.lsc file, which contains the Filter script:

<LBYSCRIPT>

<FILTER>
<LIBRARY VALUE="DEFLIB\MASTER.LBY"/>
<NAME VALUE=""/>
<DESC VALUE=""/>
<TYPE VALUE="FAP"/>
<VERSION VALUE=""/>
<REVISION VALUE=""/>
<USERID VALUE=""/>
<EFFDATE VALUE=""/>
<LOCKED VALUE=""/>
<MODE VALUE=""/>
<STATUS VALUE=""/>
<CLASS VALUE=""/>
<PROJECT VALUE=""/>
<OBJECTTYPE VALUE="TEXT"/>
<OBJECTNAME VALUE=""/>
<OBJECTTEXT VALUE="POLICY"/>
<OBJECTTEXTCASE VALUE=""/>
</FILTER>

</LBYSCRIPT>


LBYSYNC

Use the LBYSYNC utility to synchronize libraries. To use this utility, simply designate a library to sync from and a library to sync to. You can also designate synchronization criteria, which lets the LBYSYNC restrict library objects synchronized to those with a specific MODE, STATUS, and CLASS.

Program names

  • Windows: LBYSYNC.EXE

Syntax

LBYSYNC /FROMLBY /TOLBY /INI /TEST /CRIT /C /R /T /V

Parameter

Description

/FROMLBY

The name of the library to synchronize from.

/TOLBY

The name of the library to synchronize to.

/INI

The INI file you want the utility to use. The default is the FSIUSER.INI file.

/TEST

Include this parameter to simulate a synchronization without actually copying any files to the target library. This lets you see what the utility would do without changing anything.

/CRIT

Specifies the synchronization criteria to use. This criteria determines which resources in the source library are eligible to be synchronized to the target library and what values to set in the source and target library for each resource upon a successful promotion. The criteria string consists of three sets of three parameters.

The first set of parameters specifies the values for the Mode, Status, and Class fields of the resources in the source library eligible for promotion.

The second set of parameters specifies the values to set in the target library for the Mode, Status, and Class fields if the resource is successfully promoted.

The third set of parameters specifies the values to set in the source library for the Mode, Status, and Class fields if the resource is successfully promoted to the target library.

The fields are semi-colon delimited. Specify the criteria like this:

;SMODE;SSTATUS;SCLASS;TMODE;TSTATUS;TCLASS;FMODE;FSTATUS;FCLASS;

If you omit the /CRIT parameter, it defaults as shown here:

;*;*;*;*;*;*;*;*;*;

This tells the utility:

- All resources in the source library are eligible to be promoted to the target library

- Mode, Status, and Class fields of the resource in the target library will be set to the value of those fields from the source library.

- Mode, Status, and Class fields of the resource in the source library will remain unchanged upon a successful promotion.

/C

Causes a counter to show the progress of the utility as it processes library entries.

/R

Specifies which revisions of the resource to synchronize. Enter LAST if you want the utility to synchronize only the latest revision of the resource. The default is ALL which synchronizes all revisions of the resource.

/T

Include this parameter to generate a trace file. The trace file includes information about the source and target libraries, which resources in the source library are eligible for promotion, and the command you entered to run the utility.

On Windows and UNIX systems, the trace file is named trace and is written to the working directory. On z/OS systems, the trace file is written to the dataset associated with the TRACE DD statement.

If you omit this parameter, the trace file is not created.

/V

Specifies which version of the resource to synchronize. Enter LAST if you want the utility to synchronize only the latest version of the resource. The default is ALL which synchronizes all versions of the resource.

In this example:

;SMODE;SSTATUS;SCLASS;TMODE;TSTATUS;TCLASS;FMODE;FSTATUS;FCLASS;
  • SMODE, SSTATUS and SCLASS are the mode, status, and class of the resources in the source library you want to copy
  • TMODE, TSTATUS and TCLASS are the mode, status, and class you want to assign to the resource entry in the target library as it is stored in the target library
  • FMODE, FSTATUS, and FCLASS are used to set the final mode, status, and class of the resource entry in the source library, once the resource has been successfully promoted to the target library

You can enter an asterisk (*) for the SMODE, SSTATUS, or SCLASS fields to indicate any value.

You specify the synchronization criteria using the /CRIT parameter or in the INI file with the SyncCriteria option. If you use the /CRIT parameter, you can only enter a single record of synchronization criteria. You can enter multiple records of synchronization criteria using the SyncCriteria option.

Examples

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


LBYSYNC Examples

The following examples apply to the LBYSYNC utility.

  • Synchronizing with No Parameters
  • Synchronizing Using the /CRIT Parameter

.


Synchronizing with No Parameters

In this example, resources in the library named MASTER.LBY are synchronized to the library named PROD.LBY. No synchronization criteria is specified, so the default of

;*;*;*;*;*;*;*;*;*;

is used, which means any source library resource whose index record contains a newer modification date than the newest modification date for a resource of that same name, type, version, and revision in the target library, will be copied.

E:\fap\dll> lbysync /fromlby=c:\fap\mstrres\rpex1\deflib\master.lby /tolby=c:\fap\mstrres\rpex1\deflib\prod.lby /c

--- DocuCorp LBYSync Utility Program (C) ---

--- Synchronize Library ---

Inserting default LBYSync criteria ;*;*;*;*;*;*;*;*;*;

Synchronization performed. The following number of objects were

added to the target library.

SOURCE LIBRARY: c:\fap\mstrres\rpex1\deflib\master.lby

TARGET LIBRARY: c:\fap\mstrres\rpex1\deflib\prod.lby

FAPs : 61

DDTs : 61

LOGOs: 5

DALs : 0

Total: 127


Synchronizing Using the /CRIT Parameter

In the example below, resources in the library named MASTER.LBY are synchronized to the library named PROD.LBY.

The synchronization criteria is supplied using the /CRIT parameter. This tells the utility to copy resources from the MASTER.LBY source library that have a mode of DEV, a status of PASSED, and are in any class, into the PROD.LBY target library.

As the resources are copied into the PROD.LBY library, the utility assigns a new mode of PROD. The status and class do not change. Each resource in the source library that is successfully promoted is assigned a new status of PROMOTED.

E:\fap\dll>lbysync /fromlby=c:\fap\mstrres\rpex1\deflib\master.lby /tolby=c:\fap\mstrres\rpex1\deflib\prod.lby /crit=;DEV;PASSED;*;PROD;*;*;*;PROMOTED;*;

--- DocuCorp LBYSync Utility Program (C) ---

--- Synchronize Library ---

Synchronization performed. The following number of objects were

added to the target library.

SOURCE LIBRARY: c:\fap\mstrres\rpex1\deflib\master.lby

TARGET LIBRARY: c:\fap\mstrres\rpex1\deflib\prod.lby

FAPs : 1

DDTs : 1

LOGOs: 0

DALs : 0

Total: 2


LOG2IMG

Use the LOG2IMG utility to convert a graphic (bitmap) file into a Xerox graphic image (IMG) file. An IMG file is a Xerox printer resource that contains bitmap graphics information.

Program names

  • Windows: LOG2IMGW.EXE

Syntax

LOG2IMGW /A /I /O /H /R /M /C

Parameter | Description
/A | Include this parameter to create all four rotations.
/I | Enter the name of the LOG file.
/O | (Optional) Enter the name you want to assign to the IMG file.
/H | Enter the text you want used as the Xerox header text. The text you enter overrides the default header text.
/R | Enter the rotation of image (0, 90, 180, 270). The default is zero (0).
/M | Enter the mode. You can select from ENC, LIN, or HTN compression modes or select UNC for uncompressed image mode.
/C | (Optional) Include to create a red, green, blue, ruby, violet, brown, gray, cardinal, royal, cyan, or magenta image.

Parameters /A and /R are mutually exclusive. If you include the /A parameter, you need to specify four names in the LOGOED window.

Header Text

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


Header Text

The LOG2IMG utility also automatically adds tape header information at the beginning of the Xerox IMG file as some products expect a 128-byte block tape header at the beginning of the file. You can override the default text assigned when creating Xerox graphic image files (IMG) for Xerox printers. The default header text assigned for IMG files is shown here :

Type of IMG file | Default header text
Black and white | Interpress/Xerox/2.0/ImgFormat/2.00
Color | Interpress/Xerox/2.1/RasterEncoding/2.1

This works for most Xerox printers and print submission systems, but if you need to specify header text for the remaining systems, include the /H parameter.

You can also use the IMGHeader option to specify the header text. The system looks for this option in your Xerox printer control group. Here is an example:

< PrtType:XER >

IMGHeader = Interpress/Xerox/1.0/ImgFormat/1.00

In this example, the text Interpress/Xerox/1.0/ImgFormat/1.00 overrides the default header text. If you omit this option, the system creates the IMG file with the default header text.


LOG2JPG

Use the LOG2JPG utility to convert a graphic (bitmap) file into a JPEG graphic file. This utility can convert any color, gray, or 2-bit single color images into compressed JPEG files. During the conversion, the utility tells you which files are converted.

Note You can perform this task using the Convert Graphics Files option in Studio’s Conversion wizard.

Program names

  • Windows: LOG2JPGW.EXE

Syntax

LOG2JPGW /I /O /R /C

Parameter | Description
/I | The graphic file for input with or without the extension (.log). When converting a large number of graphic files, simply enter /i=*.
/O | The name of the JPEG file you want to create. Enter the name with or without the extension (.jpg). If omitted, the utility uses the graphic’s file name and the JPG extension.
/R | Specifies the orientation or rotation. If omitted or specified incorrectly, no rotation takes place. 1 - 0 degrees (portrait) 2 - 90 degrees 3 - 180 degrees 4 - 270 degrees (landscape) 5 - the rotation specified in the rotation names in the graphic header. The settings /r=5 and /o=ofile are mutually exclusive. When you specify /r=5, the output file uses the rotation name in the graphic header. If there is no rotation name, the output file takes input file as a default.
/C | Tells the utility to convert a color graphic to a single color. Specify the color using these values: 1-black 9-dark blue 2-blue 10-dark cyan 3-cyan 11-dark green 4-green 12-dark magenta 5-magenta 13-dark red 6-red 14-dark yellow 7-yellow 15-dark gray 8-white 16-light gray


LOG2LOB

Use the LOG2LOB utility to convert a LOG (graphic) file into a DOS entry LOB file.

Program names

  • Windows: LOG2LB32.EXE

Syntax

LOG2LB32 /I /O

Parameter | Description
/I | Enter the name of the LOG file.
/O | Enter the name of the LOB file.
Note The LOB extension defines a FormEntry file format.


LOG2PSEG

Use the LOG2PSEG utility to compile a LOG (graphic) file into an AFP page segment. Use this utility to apply rotations to graphics before downloading them to an AFP printer. You can also enlarge the graphic using the scale option.

Program names

  • Windows: LOG2PG32.EXE
  • z/OS: See the Documaker Installation Guide.

Syntax

LOG2PG32 /I

Parameter | Description
/I | Enter the name of the file which contains records in this format: ;name;logofile;outfile;scale;orientation; The default extension is DAT. (you can use asterisks as wildcards)

- or-

LOG2PG32 /I /O /C /S /R

Parameter | Description
/I | Enter the name of the graphic file. The default extension is LOG.
/O | Enter the name of the output file. The default extension is SEG.
/C | Add this parameter if the AFP overlay should use color. Enter one of the named AFP colors such as blue, red, magenta, green, cyan, yellow, dark_blue, orange, purple, dark_green, dark_cyan, mustard, gray, or brown.
/S | Enter 1 or 2. The default is 1 (normal), 2 indicates enlarge.
/R | Enter 1 (0 degrees-portrait), 2 (90 degrees), 3 (180 degrees), 4 (landscape 270 degrees), or 5 (all rotations).
Note The utility ignores the /O option if you include /R=5. The utility will instead use data from the LOG file.

Printing in Color

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


Printing in Color

Include the /C parameter if the AFP overlay should print in color. AFP highlight color printing on printers from Xerox and Oce is supported. Before using this feature, make sure the:

  • SendColor INI option is set to Yes.
  • Objects you want to print in color (text, lines, shades, and so on) are set to print in color. The Print in Color option is on the Color Selection window. You can display this window by clicking the Color button on the object’s Properties window.

The system maps the RGB (red,green,blue) color setting for each object to the closest AFP named color. The default AFP named colors are: blue, red, magenta, green, cyan, yellow, dark_blue, orange, purple, dark_green, dark_cyan, mustard, gray, and brown.

Use the NamedColors option to tell the system to use only specific AFP named colors:

< PrtType:AFP >
  NamedColors = blue

For example, if you wanted all highlight (non-black) colors mapped to blue, you would set the NamedColors option to blue, as shown above.

To allow the mapping of the colors you assigned to the objects in the FAP file to multiple colors, separate each color with a semicolon (;). For example, to use all of the default AFP named colors except brown, set the NamedColors option as shown here:

NamedColors = red;blue;magenta;green;cyan;yellow

The order of the named colors does not matter.


LOG2TIF

Use the LOG2TIF utility to convert any graphic (LOG) file into a TIFF file. During the conversion, the utility tells you whether or not each file was converted and then provides a summary when finished.

Program names

  • Windows: LOG2TIFW.EXE

Syntax

LOG2TIFW /I /O /C

Parameter | Description
/I | Enter the name of the graphic file. The extension defaults to .LOG. Enter an asterisk (*) if you want the utility to convert all the graphic files in the current directory.
/O | (Optional) Enter the name you want the utility to assign to the resulting TIFF file. The extension defaults to .TIF.
/C | (Optional) Include this parameter to convert the graphic into a monocolor TIFF image.

Here are some examples:

LOG2TIFW /I=BEAST004.LOG /O=BEAST.TIF /C

LOG2TIFW /I=*


LOG2VIPP

Use the LOG2VIPP utility to convert multicolor graphics (LOG) files into JPG files and monocolor graphics into TIFF files for use as VIPP printer resources.

Program names

  • Windows: LOG2VIPW.EXE

Syntax

LOG2VIPW /I /C

Parameter | Description
/I | Enter the name of the graphic file. The utility assumes the default extension .LOG. To process all graphic files in the current directory, enter an asterisk (*).
/C | (Optional) Include this parameter to convert to a monocolor TIFF image. This is useful when you have the SendColor INI option set to No for producing VIPP print streams.
Note If you include the /C parameter, the utility creates TIFF files for all graphics.


LOG2XFNT

Use the LOG2XFNT utility to compile a graphic (LOG) file into a Xerox Metacode font file.

Note You can also use Studio to perform this task.

Program names

  • Windows: LOG2XF32.EXE

Syntax

LOG2XF32 /I

Parameter | Description
/I | Enter the name of the LOG file.

This utility converts a LOG file into a Xerox font file (FNT). This allows a bitmap graphic to be treated as a font on the printer. There will be a font file created for each rotation (0, 90, 180, and 270 degrees) and the output files will have FNT extensions.

Note There is a limit to the size of a Xerox font. Because of this limit, you cannot convert graphics larger than 128k.


MET2FAP

Use this utility to convert a Xerox Metacode file created by the system into a FAP file. You can then view and edit the FAP file using Studio.

Note This utility supports DJDE FORMAT commands contained in the Metacode print stream you are converting.

Program names

  • Windows: MET2FAPW.EXE

Syntax

MET2FAPW /I /X /P

Parameter | Description
/I | Enter the name of the MET file. Omit the extension.
/X | Enter the name of the font cross-reference (FXR) file. Omit the extension.
/P | Enter the PrtType control group in the INI file to use, such as XER.

This utility requires the following files:

  • FSISYS.INI
  • *.FXR
  • LOGO.DAT file should be included, but is not required, in the following format: logo0;logo90;logo180;logo270;

FLOGO;FLOGO9;FLOGO1;FLOGO2;

This utility reads a Metacode print file created using the system and creates a FAP file.

In addition to a Metacode print file (MET), you must also specify a font cross-reference (FXR) file which contains the Xerox fonts used.

Note The MET2FAP utility only works with Metacode print files created by Documaker Server. To convert a Metacode print file which was created by the Documerge system, use the MRG2FAP utility.


META2TTF

Use this utility to create TrueType fonts from Xerox Metacode fonts. Using TrueType fonts that match Metacode printer fonts improves how documents designed for Metacode printers appear on your screen.

Note This utility only creates corresponding TrueType fonts for portrait Metacode fonts.

Program names

  • Windows: meta2ttf.exe

Syntax

meta2ttf input-metacode.fnt output-truetype.ttf [internal-TTF-name]

Parameter | Description
input- | Enter the name of the Metacode file, including an FNT extension. Also include a path if this file is in a directory other than the one in which the utility resides.
output- | Enter the name you want assigned to the resulting TrueType file, including the TTF extension. Also include a path if you want the utility to place the TTF file into a directory other than the one in which the utility resides.
internal- | (Optional) Enter an internal TTF file name if it should be different from the TTF font name.
Note Unlike other Documaker utilities, this utility does not accept the /I and /O parameters. Enter the parameters as shown above.

After you convert the Xerox fonts into TrueType fonts, you must install the TrueType fonts in the Fonts folder via Windows Control Panel. Then use the Manage, System, Fonts option in Documaker Studio to make sure the FXR file is using these TrueType fonts.

Example

Here is an example:

meta2ttf input-metacode.fnt output-truetype.ttf [internal-TTF-name]


METOPT

Use this utility to optimize Metacode print streams before they are sent to the printer. This utility combines Metacode print records into larger and fewer records. Reducing the number of records that must be transmitted reduces the amount of time needed to spool the Metacode print stream to the printer.

The METOPT utility detects errors in the Metacode information caused by the data passed or by the compiled resources used. This helps you detect errors before printing. This utility also notes comment (or pure text) records that are loaded and will output a copy of the most recent comment record when it detects errors in a Metacode print stream.

The utility also lets you use common font lists at the beginning of a Metacode print stream. A common font list names all of the Xerox fonts that will be used by the print job. This helps some Metacode printers print jobs at their highest rated speed.

Program names

  • Windows: METOPT32.EXE
  • z/OS: see Running METOPT on z/OS

Syntax

METOPT32 /I /O /N /X

Parameter | Description
/I | The name and location of the input file to be optimized
/O | The name and location of the output optimized file to be created by the MetOpt utility.
/N | (Optional) The name and location of an INI file to use. The default value is FSISYS.INI for the PC and DD:FSISYS for z/OS. The INI file used for running this utility should be the same INI file used to produce the print stream to be optimized.
/X | (Optional) The name and location of the FXR file to use other than the default on the PC and DD:FXRFILE on z/OS. The FXR used for running METOPT should be the same FXR used to produce the print stream to be optimized.
Note This utility does not work with precompiled MET files.


Running METOPT on zOS

The METOPT utility is currently supported for use using BARR and JES2 output modes (PrtType:XER control group, OutMode option).

Consider the sample JCL below for running METOPT on z/OS:

//MRCC JOB (33005),'RUN METOPT ',CLASS=T,MSGCLASS=X, NOTIFY=MRC

//*

// SET HLQ='MRC.V100' <== SET HIGH LEVEL QUALIFIER

// SET RES='DAPDATA' <== SET RESOURCE

//*

// JCLLIB ORDER=&HLQ..PROCLIB

//*

//METOPTD EXEC PGM=IEFBR14

//DD1 DD DSN=&HLQ..&RES..OUTPUT.OPT,DISP=(MOD,DELETE),

// SPACE=(TRK,(1,1)),UNIT=SYSDA

//*

//METOPT EXEC PGM=METOPT

//STEPLIB DD DSN=&HLQ..LINKLIB,DISP=SHR

// DD DSN=SYS1.SCEERUN,DISP=SHR

//FSISYS DD DSN=&HLQ..&RES..DEFLIB(FSISYS),DISP=SHR

//PFRMLIB DD DSN=&HLQ..&RES..PFRMLIB, DISP=SHR

//FXRFILE DD DSN=&HLQ..&RES..DEFLIB(FONTFILE),DISP=SHR

//INFILE DD DSN=&HLQ..&RES..INPUT,DISP=SHR

//OUTFILE DD DSN=&HLQ..&RES..OUTPUT.OPT,DISP=(,CATLG),

// SPACE=(CYL,(20,5)),LIKE=&HLQ..&RES..INPUT

//SYSPRINT DD SYSOUT=*

Note that the input and output DD statements (INFILE and OUTFILE) refer to physical sequential datasets. The INI member FSISYS and the FXR member FONTFILE in this example are both contained in a partitioned dataset called DefLib. Also note that the DD statements, FSISYS, PFRMLIB, and FXRFILE, reference the INI and FXR files instead of command line parameters.


FRM Support

For the METOPT utility to correctly optimize print streams that reference printer-resident FRM files, you must make available a copy of each FRM file.

In a Windows environment, make sure the FRM files are in the same directory as this utility.

On z/OS systems, the METOPT utility uses the standard naming convention PFRMLIB for the PDS that contains the pre-compiled FRM members the utility will need.


Using a Common Font List

The METOPT utility lets you use common font lists at the beginning of a Metacode print stream. A common font list names all of the Xerox fonts that will be used by the print job.

By knowing all of the fonts up front, the Metacode driver can issue a single DJDE FONTS command once at the beginning of the job and avoid issuing DJDE FONTS commands on subsequent pages. This helps some Metacode printers print jobs at their highest rated speed.

In the CommonFonts control group, you will see a list of options similar to these:

< CommonFonts >
    Names=28
    Name1=FORMSX
    Name2=FXUNBD
    Name3=FXUNN6
    Name4=FXCON6
    Name5=FXUNN8
    Name6=FXUNN0
    Name7=FXUNBH
    ...
    Name28=FXUNI0

The first option, Names, defines the number of font name entries that follow. The following options specify the Xerox fonts which will be used in the print job.

CommonFonts Control Group

The format used for the CommonFonts control group is the same as that used by Documerge. Therefore, if you used this in Documerge, you can copy that INI control group into your Documaker INI file.

If there are more than 20 fonts (like in the previous example which includes 28 fonts), be sure to set the MaxFonts option as shown here:

< PrtType:XER >
  MaxFonts = 28

This option is not needed if there are 20 fonts or fewer in the common font list.


METOPT Errors

If the METOPT utility encounters critical errors, such as the inability to find or open a file, while it is running, it will notify you and stop immediately. Common critical errors include:

  • Cannot create the output file
  • Cannot read the output file
  • Cannot open the FRM file

The METOPT utility can also report actual or potential non-critical problems it encounters while it runs. For instance, if the utility finds Metacode records that may prevent the file from printing, it can warn you. These non-critical errors usually fall into two categories:

  • One of the METOPT utility's required steps was unable to be completed, such as building the font symbol table.
  • Invalid input data of some kind was encountered, so the METOPT utility's output data may be invalid, too. This could mean that some data in the optimized file will not be printed, will not print correctly, or will generate printer errors.

To have this utility notify you if it spots potential problems, add the following option to your PrtType:XER control group:

< PrtType:XER >
  ValidLevel =
Option | Description
0 | Enter zero (0) to tell the utility not to report non-critical problems. This is the default.
1 | Enter one (1) to tell the utility to report warnings for non-critical problems, but continue optimizing.
2 | Enter two (2) to tell the utility to report warnings for non-critical problems and attempt to fix the problems
3 | Enter three (3) to tell the utility to report warnings for non-critical problems and exit immediately

Using the ValidLevel option gives you a degree of control over how certain errors are handled. Keep in mind that, although classified as non-critical, many of these errors can produce invalid output. So, many of the more severe non-critical errors will be promoted automatically by METOPT to a ValidLevel of 3. METOPT will then display the error and stop executing. Such instances usually fall into the first category described above.

Usually, the non-critical errors that do not force METOPT to stop processing involve one corrupt record, such as a record that contains an invalid Metacode sequence. In most cases, if you set the ValidLevel option to 1, a warning appears and the record displays, but the utility continues to process the record.

For the same record, if you set ValidLevel to 2, the same warnings appear, but this time the record is not processed with the others. So, since that record is left alone, the printer will treat it as it would have the identical record in the input file.

Note When you set the ValidLevel option to a value other than zero and the problem involves a particular Metacode record, the METOPT utility typically displays the record in hexadecimal to help you solve the problem.

You can also use the following INI option to help track down and resolve errors:

< PrtType:XER >
  SaveComment =

The SaveComment option lets you save the last Metacode comment record processed and display it when an error is encountered. This can be a helpful placeholder when you are trying to isolate the location of an error record in a large file. If the Metacode file contains occasional or frequent comment records, then the SaveComment option can be a useful troubleshooting tool.

The possible values for the SaveComment option are:

Option | Description
(blank) | Do not save comments. This is the default.
S | Display the last comment as-is, with no conversion.
A | Convert the last comment to ASCII, then display.
E | Convert the last comment to EBCDIC, then display.
H | Display the last comment in hexadecimal.


METRESRC

Use this utility to determine the Xerox resources used by a Metacode print stream. You can also use this utility to combine an original Metacode print stream along with its required Xerox resources into a new Metacode print stream.

The types of Xerox resource files supported by this utility are:

  • Xerox fonts (.FNT files)
  • Xerox images (.IMG files)
  • Xerox forms (.FRM files)
  • Xerox logos (.LGO files)
Note The METRESRC utility does not try to determine if there are Xerox files already contained (embedded) within a Metacode print stream. If you use a Metacode print stream that contains the required Xerox resources, the utility adds these resources again to a new Metacode print stream.

Program names

  • z/OS: METRESRC
  • Windows: METRESRC.EXE

Syntax

METRESRC /I /O /L /INI /P /RESDIR /RESTYPE /SAVE

Parameter | Description
/I | Enter the name of the input Metacode print file.
/O | Enter the name you want assigned to the Metacode print file the utility will create with resource files added. You must include this parameter or the /L parameter. You can include both of these parameters.
/L | Enter the name of the listing file that contains the names of the resource files used. You must include this parameter or the /O parameter. You can include both of these parameters.
/INI | (Optional) Enter the name of INI file that contains the Xerox printer INI control group. The default is FSISYS.INI.
/P | (Optional) Enter the name of Xerox printer INI control group. The default is XER.
/RESDIR | (Optional) Enter the name of the directory that contains the Xerox resource files. The default is the directory for the input Metacode print file.
/RESTYPE | (Optional) List the types of resource files you want the utility to search for, separated by commas: FNT - Xerox font IMG - Xerox image FRM - Xerox form LGO - Xerox logo ALL - All Xerox files (same as /RESTYPE FNT,IMG,FRM,LGO) The default is ALL.
/SAVE | (Optional) Include this parameter if you want the utility to save the downloaded files onto the printer. The default is to delete the downloaded files from the printer after printing.
Note If you run this utility without any parameters or with incorrect parameters, it will display syntax information about how to run it.


Defining the JSL Settings

So the utility can read the Metacode print stream, you must include INI options in the Xerox printer control group that match the JSL settings used by the Metacode printer to create the print stream. Here is an example of a Xerox printer control group that contains these options:

< PrtType:XER >
   DJDEIden           = E'$$XEROX'
   DJDEOffset         = 0
   DJDESkip           = 8
   OutMode            = MRG4
   JDEName            = DFLT
   JDLData            = 0,255
   JDLHost            = IBMONL
   JDLName            = DFAULT
   JDLCode            = EBCDIC
   JDLRStack          = 0,10,EQ,X'13131313131313131313'
   ...

Several of these options are based on the comparable parameter values in the settings of the printer's JSL.

For detailed information on setting up a Xerox printer control group to match your printer's JSL settings, see the Metacode Printers chapter in the Printers Reference.


METRESRC Scenario 1

Assume you want to identify the Xerox resource files used by a Metacode print stream, perhaps because you plan to convert the Metacode print stream into a FAP file.

For this example, assume you have an INI file named FSISYS.INI that contains a Xerox printer control group (PrtType:XER) with the necessary entries to read a Metacode print stream named example1.met. To produce a list of the Xerox resources used in example1.met, you would enter this command:

METRESRC /I=Example1.met /L=list.txt /INI=FSISYS.INI /P=XER

Note In this example, you could omit the /INI and /P parameters since you are using the default INI file and default Xerox printer control group the utility expects.

This command produces a text file called list.txt that contains a list of the Xerox resources files used by the Metacode print stream, Example1.met.

The lines of the listing file are in this comma-delimited format:

FILENAME,XER,TYPE

Element | Description
FILENAME | The name of the resource file
XER | Indicates that the file is a Xerox resource
TYPE | Indicates the Xerox resource type, such as FNT, IMG, FRM, or LGO

The listing file might look something like this:

QARRD,XER,IMG

QARRD2,XER,IMG

QARRR,XER,IMG

QARRU2,XER,IMG

QJANED,XER,IMG

QJOHND,XER,IMG

FXCOB0,XER,FNT

FXCOB6,XER,FNT

FXTIN6,XER,FNT

FXTIN8,XER,FNT

FXUNN0,XER,FNT

FXUNN4,XER,FNT

FXUNN6,XER,FNT

FXUNN8,XER,FNT

FXUNNN,XER,FNT

The first few entries are the names of Xerox IMG resource files (QARRD.IMG, QARRD2.IMG, and so on). The latter entries are the names of Xerox FNT resource files (FXCOB0.FNT, FXCOB6.FNT, and so on).

The listing file is in the same format as that used by the MRGADD utility, which can be used to create a font cross-reference (FXR) file.

Notes:

  • It is highly recommended that you produce a listing file before you create a new Metacode print stream. Doing so helps you determine which Xerox resource files you need to have available.
  • Producing a listing file also helps you make sure your Xerox printer control group matches the printer's JSL settings used for the Metacode print stream.


METRESRC Scenario 2

Assume you want to take Metacode print stream from Scenario 1 and print it on a Metacode printer that does not have the necessary Xerox resource files.

To produce a Metacode print stream that contains the original Metacode print stream (example1.met) plus all of the Xerox resources used in that file, you would enter this command:

METRESRC /I=Example1.met /L=list.txt /O=NewFile.met /RESDIR=C:\XRXFiles

This command produces a new Metacode print stream called newfile.met that contains the original Metacode print stream (example1.met) plus all of the Xerox resources used in that file. For this example, the Xerox resource files must be in the c:\xrxfiles directory, as specified by the /RESDIR parameter.

The Xerox resource files contained in the newfile.met file are downloaded to the printer before printing the contents of the original Metacode print stream. Because you omitted the /SAVE parameter, the Xerox resource files contained in the newfile.met file are deleted from the printer after the print stream finishes printing. If you had included the /SAVE parameter, the embedded Xerox resource files would have been retained on the printer after the new print stream finished printing.

The optional /L parameter tells the utility to also produce a text file named list.txt that contains a list of the Xerox resources files used by the Metacode print stream (example1.met).

Notes:

  • Printing a Metacode print stream with embedded Xerox resource files will overwrite any Xerox resource files stored on the printer with the same names.
  • All embedded Xerox resource files — even those that overwrite existing files — are deleted from the printer after the print stream has finished printing unless you include the /SAVE parameter when you produce the new print stream.
  • Because an embedded Xerox font overwrites an existing Xerox font stored on the printer, the METRESRC utility never embeds the standard Xerox line drawing font (FORMSX.FNT) into a new Metacode print stream.


Messages from METRESRC

The METRESRC utility displays information about its state of operation as it is runs. For example, when producing a listing file as described in Scenario 1, the METRESRC utility displays the following information:

C:\>METRESRC /I=Example1.met /L=list.txt /INI=FSISYS.INI /P=XER

--- METRESRC Copyright (C) 1997, 2009 Oracle. All rights reserved.

Informational in METRESRC: Creating listing file: list.txt

Informational in METRESRC: Finished Successfully

If the METRESRC utility cannot find references to any Xerox resource files in a Metacode print stream, it usually means that your Xerox printer control group does not match the printer's JSL settings used for the Metacode print stream. If this occurs, you will see the following warning message:

C:\>METRESRC /I=Example1.met /L=list.txt /INI=FSISYS.INI /P=XER

--- METRESRC Copyright (C) 1997, 2009 Oracle. All rights reserved.

Informational in METRESRC: Creating listing file: list.txt

Informational in METRESRC: Could not find references to resource files in example1.met

Verify <PrtType:XER> INI settings in fsisys.ini match JSL settings for example1.met

If you were producing a new Metacode print stream containing Xerox resource files as described in Scenario 2, you would see many more messages. The METRESRC utility displays information about each Xerox resource file that is being embedded into the new Metacode print stream. In this case, the messages from METRESRC would look something like this:

C:\>METRESRC /I=Example1.met /L=list.txt /O=NewFile.met /RESDIR=C:\XRXFiles

--- METRESRC Copyright (C) 1997, 2009 Oracle. All rights reserved.l

* UTLDefInfoNotify * METRESRC: Creating listing file: list.txt

* UTLDefInfoNotify * METRESRC: Creating new metacode file: NewFile.met

* UTLDefInfoNotify * METRESRC: Copied C:\XRXFiles\AF16JP.FNT into output file NewFile.met

* UTLDefInfoNotify * METRESRC: Copied C:\XRXFiles\AF18JP.FNT into output file NewFile.met

* UTLDefInfoNotify * METRESRC: Copied C:\XRXFiles\P0812C.FNT into output file NewFile.met

* UTLDefInfoNotify * METRESRC: Copied C:\XRXFiles\P08OAA.FNT into output file NewFile.met

* UTLDefErrorExit * ..\C\xerfont.c

Jan 17 2006 19:36:35

400.111.006

XERDownloadFile <11> <0> Unable to open resource file PR111E.FNT for downloading

* UTLDefInfoNotify * METRESRC: ERROR --> Error downloading PR111E.FNT

* UTLDefErrorExit * ..\C\xerfont.c

Jan 17 2006 19:36:35

400.111.006

XERDownloadFile <11> <0> Unable to open resource file PR211E.FNT for downloading

* UTLDefInfoNotify * METRESRC: ERROR --> Error downloading PR211E.FNT

* UTLDefInfoNotify * METRESRC: Copied C:\XRXFiles\XIZIPL.FNT into output file NewFile.met

* UTLDefInfoNotify * METRESRC: Copied C:\XRXFiles\XIZIPP.FNT into output file NewFile.met

* UTLDefErrorExit * ..\C\metresrc.c

Jan 17 2006 20:34:43

400.111.006

METRESRC <0> <0> ERROR --> 2 fonts could not be downloaded

* UTLDefInfoNotify * METRESRC: Finished with Errors

In the example above, there were two Xerox fonts, PR111E.FNT and PR211E.FNT, that were not found in the directory specified by the /RESDIR parameter.

Because there can be a large number of Xerox resource files used in a Metacode print stream, these messages are written to a TRACE file in addition to being displayed on the console.

Note The TRACE file is overwritten each time the utility runs so you will need to rename the TRACE file if you want to keep the results from a prior run.

Below is an error message you might see on a z/OS machine if you were producing a new Metacode print stream containing Xerox resource files as described in Scenario 2:

* UTLDefErrorExit * FSI.V111.SOURCE(XERPRINT)

Feb 4 2006 12:01:41

400.111.007

XEROutput <13> <0> Failure to write to device DD:OUTFILE. Error: 19 EDC5019I An unrecoverable error has permanently marked the file in error.

This error tells you that you did not allocate enough space for the new Metacode file. You can also tell that the DD:OUTFILE ran out of space by the presence of the B37 abend message in the JES job log. Any kind of x37 message, such as B37, D37, E37, means some kind of out of space condition.


METRESRC z/OS Considerations

The command line parameter processing is slightly different when running on a z/OS machine. The input (/I), output (/O), and listing (/L) file parameters must specify a DD: name that is defined in your JCL.

DD name | Description
DD:FSISYS | The name of the INI file used by the METRESRC utility
DD:FONTLIB | The name of the PDS containing the Xerox font resources
DD:IMGLIB | The name of the PDS containing the Xerox image resources
DD:LGOLIB | The name of the PDS containing the Xerox logo resources
DD:PFRMLIB | The name of the PDS containing the Xerox form resources
DD:TRACE | The name of the TRACE file

Assume you want to read a Metacode print stream and produce a new Metacode print stream that contains the required Xerox fonts resources and you want the Xerox fonts to be saved on the printer after printing. For this example, assume the following environment on the z/OS machine:

FSI.V111.RPEX1.GENPRINT.PRTBAT1 | The Metacode print stream
FSI.V111.RPEX1.DEFLIB(FSISYS) | The FSISYS INI file
FSI.V111.RPEX1.FONTLIB | The Xerox fonts for the print stream
FSI.V111.RPEX1.METRESC1.TRACE | The trace file to produce
FSI.V111.RPEX1.METRESC1.LIST | The listing file to produce
FSI.V111.RPEX1.GENPRINT.PRTBAT1.NEW | The new print stream to produce

The JCL for the METRESRC utility might look like this:

//USERIDA  JOB   (33005),'DAP -         ',CLASS=T,MSGCLASS=X,
//         NOTIFY=USERID
//*
//         SET HLQ='FSI.V111'    <== SET HIGH LEVEL QUALIFIER
//         SET RES='RPEX1'       <== SET RESOURCE (E.G. RPEX1, UTEX1)
//*
//         JCLLIB  ORDER=&HLQ..PROCLIB
//*
//******************************************************************
//*  PROGRAM : METRESRC
//*  PURPOSE : TO DETERMINE THE XEROX RESOURCES USED BY A METACODE
//*            PRINT STREAM.
//*
//*  PARMS   : /I=   NAME OF METACODE PRINT FILE (REQUIRED)
//*            /O=   NAME OF METACODE PRINT FILE TO CREATE WITH
//*                  RESOURCES FILES ADDED
//*            /L=   NAME OF LISTING FILE CONTAINING NAMES OF RESOURCE
//*                  FILES USED (/O OR /L PARAMETERS ARE REQUIRED)
//*                  (BOTH /O AND /L CAN BE USED)
//*            /INI= NAME OF INI FILE CONTAINING XEROX PRINTER INI
//*                  GROUP (OPTIONAL, DEFAULT IS DD:FSISYS)
//*            /P=   NAME OF XEROX PRINTER INI GROUP
//*                  (OPTIONAL, DEFAULT IS XER)
//*            /RESTYPE= TYPE(S) OF RESOURCE FILES TO SEARCH FOR
//*                      (SEPARATED BY COMMAS):
//*                      FNT - XEROX FONT
//*                      IMG - XEROX IMAGE
//*                      FRM - XEROX FORM
//*                      LGO - XEROX LOGO
//*                      ALL - ALL XEROX FILES
//*                            (SAME AS /RESTYPE=FNT,IMG,FRM,LGO)
//*                      (OPTIONAL, DEFAULT IS ALL)
//*            /SAVE  SAVE DOWNLOADED FILES PERMANENTLY ONTO PRINTER
//*                   (OPTIONAL, DEFAULT IS DOWNLOADED FILES ARE
//*                    DELETED FROM PRINTER)
//*
//****************************************************************
//*
//METRESCD EXEC PGM=IEFBR14
//LIST     DD DSN=&HLQ..&RES..METRESC1.LIST,
//            UNIT=SYSDA,SPACE=(TRK,0),
//            DISP=(MOD,DELETE,DELETE)
//TRACE    DD DSN=&HLQ..&RES..METRESC1.TRACE,
//            UNIT=SYSDA,SPACE=(TRK,0),
//            DISP=(MOD,DELETE,DELETE)
//OUTFILE  DD DSN=&HLQ..&RES..GENPRINT.PRTBAT1.NEW,
//            UNIT=SYSDA,SPACE=(TRK,0),
//            DISP=(MOD,DELETE,DELETE)
//*
//METRESC1 EXEC PGM=METRESRC,
                PARM='/ /I=DD:INFILE /L=DD:LIST /O=DD:OUTFILE /SAVE'
//STEPLIB  DD DSN=&HLQ..LINKLIB,DISP=SHR
//         DD DSN=SYS1.SCEERUN,DISP=SHR
//*
//FSISYS   DD DSN=&HLQ..&RES..DEFLIB(FSISYS),DISP=SHR
//INFILE   DD DSN=&HLQ..&RES..GENPRINT.PRTBAT1,DISP=SHR
//OUTFILE  DD DSN=&HLQ..&RES..GENPRINT.PRTBAT1.NEW,
//            DISP=(,CATLG),
//            LIKE=&HLQ..&RES..GENPRINT.PRTBAT1
//LIST     DD DSN=&HLQ..&RES..METRESC1.LIST,
//            UNIT=SYSDA,SPACE=(TRK,(1,1)),DISP=(,CATLG),
//            DCB=(RECFM=FB,LRECL=80,BLKSIZE=3120)
//TRACE    DD DSN=&HLQ..&RES..METRESC1.TRACE,
//            UNIT=SYSDA,SPACE=(TRK,(1,1)),DISP=(,CATLG),
//            DCB=(RECFM=VB,LRECL=1024,BLKSIZE=23040)
//FONTLIB  DD DSN=&HLQ..&RES..FONTLIB,DISP=SHR  <=UNCOMMENT AS NEEDED
//*PFRMLIB  DD DSN=&HLQ..&RES..PFRMLIB,DISP=SHR <=UNCOMMENT AS NEEDED
//*IMGLIB  DD DSN=&HLQ..&RES..IMGLIB,DISP=SHR   <=UNCOMMENT AS NEEDED
//*LGOLIB  DD DSN=&HLQ..&RES..LGOLIB,DISP=SHR   <=UNCOMMENT AS NEEDED

//SYSPRINT DD SYSOUT=*

If you have to create a Partitioned Data Set (PDS) for Xerox fonts, forms, images, or logos, you can use these settings as a guide:

 Data Set Name . . . . : FSI.V111.RPEX1.FONTLIB

 General Data                          Current Allocation
  Management class . . : **None**       Allocated cylinders : 75
  Storage class  . . . : STANDARD       Allocated extents . : 1
   Volume serial . . . : DCI004         Maximum dir. blocks : 50
   Device type . . . . : 3390
  Data class . . . . . : **None**
   Organization  . . . : PO            Current Utilization
   Record format . . . : FB             Used cylinders  . . : 1
   Record length . . . : 128            Used extents  . . . : 1
   Block size  . . . . : 27904          Used dir. blocks  . : 1
   1st extent cylinders: 75             Number of members . : 10
   Secondary cylinders : 10
   Data set name type  : PDS

   Creation date . . . : 2006/02/06     Referenced date . . : 2006/02/07
   Expiration date . . : ***None***
Note z/OS does not allow file names that begin with a number (0-9). If any of your Xerox resource files begin with a number, you will not be able to upload these files to z/OS. Therefore, you will not be able to run the METRESRC utility on z/OS for this environment. Instead, you must run the METRESRC utility on a Windows or UNIX platform and upload the final print stream to z/OS for printing.


Xerox Print Considerations

If you receive a Report Integrity Problem message on the Xerox printer console when printing, your Metacode print file may have too many fonts for your printer to process. This is more likely to happen when your Metacode print file uses a common font list that names every possible font that can be used. If the amount of font memory on your printer is less than the amount of memory needed for the fonts listed in the Metacode print file, you may receive a Report Integrity Problem message on the Xerox printer console when printing.


MRG2FAP

Use the MRG2FAP utility to convert a Documerge or Documaker AFP or Metacode file into a FAP file or a PDF file or both. You can then view and edit the FAP file using Documaker Studio. In addition to creating a FAP file, you can also create a PDF file.

The MRG2FAP utility lets you load Xerox FRM files and IMG files that are referenced in the Metacode print stream being converted. It can also produce a BPSD/Field cross-reference listing.

The system looks for the FRM and IMG files in the directory specified by the FormLib option in the MasterResource control group. If you omit this option, the system looks in the current directory.

Note

  • This utility supports DJDE FORMAT commands contained in the Metacode print stream you are converting.
  • This utility only works with Metacode print files created by Documerge and EFS. To convert a Metacode print file which was created by Documaker Server, use the MET2FAP utility. You can use the MRG2FAP utility to convert AFP print files created by either Documerge or Documaker Server into FAP files.

Program names

  • Windows: MRG2FAPW.EXE

Syntax

MRG2FAPW /I /T /X /P /L /A /O /AO //VF /MF /MR /M /INI

Parameter

Description

/I

Enter the name of the AFP file (include the extension) or Metacode file (omit the extension).

/T

Enter the file type: AFP or MET.

/X

Enter the name of the font cross-reference (FXR) file. Omit the extension.

/P

(Optional) Enter the PrtType control group in the INI file to use, such as XER.

/L

(Optional) Include to create a listing of the BPSD tag field names from the input file and the subsequently created FAP field names. You must specify the file name in the BPSDReport option in the MasterResource control group.

/A

(Optional) Include to also create a PDF file. The system uses the PDF settings in the PrtType:PDF control group. See also Adding PDF bookmarks.

/O

Use this parameter to specify the output FAP file name.

This name can differ from the input file name. Include a path to direct the output FAP file to a specific location. Here is an example:

/O=d:\output\FAPFileName

/AO

Use this parameter to tell the utility to only create an Adobe PDF file — no FAP file is created.

If you want the PDF file to have a name that differs from the input file name, include the PDF file name. You can also include a path to direct the output FAP file to a specific location. Here is an example:

/AO=d:\pdfoutput\newPDFfile

/VF

Include this parameter to tell the utility that the resulting PDF file should contain template fields.

In PDF parlance, text fields are fields that display text, allow you to enter information, or accept multiple lines of text. In Documaker Studio these types of fields are called variable fields.

Template fields look similar to text and variable fields but do not allow you to enter information. Template fields instead display the name of the variable field and if you pause your cursor over one, you will see information about the variable field, such as its name, type, length, scope, rotation, font, and locale.

/MF

Include this parameter to tell the utility to merge fields from a FAP file.

You can specify the name of the FAP file and include a path. Here is an example:

/MF=d:\source\FAPFileName

Besides using /MF option, the utility also looks in the MergeFields option in the PrtType:xxx control group to determine if it should merge fields.

If you omit the FAP file name, the utility uses the FAP file name you specified with the /I parameter.

/MR

Include this parameter to tell the utility to merge rules from a FAP file.

You can specify the name of the FAP file and include a path. Here is an example:

/MR=d:\source\FAPFileName

If you omit the FAP file name, the utility uses the FAP file name you specified with the /I parameter. You can also do this via Documaker Studio.

/M

Include this parameter to tell the utility to merge both fields and rules from a FAP file.

You can specify the name of the FAP file and include a path. Here is an example:

/M=d:\source\FAPFileName

If you omit the FAP file name, the utility uses the FAP file name you specified with the /I parameter.

/INI

Include this parameter if you want to specify the INI file the utility should use. For instance, you could point to a FSIUSER.INI file and if the FSIUSER.INI file referenced a FSISYS.INI file, the utility would load the FSISYS.INI file too.

By default, the utility only loads the FSISYS.INI, so all necessary INI options (in the PrtType:XER and PrtType:PDF control groups) need to be in the FSISYS.INI file.


Required Files

The MRG2FAP utility requires the following files:

  • FSISYS.INI
  • *.FXR
  • IBMXFER.TBL cross-reference table which correlates the coded font names with character sets and code pages (only for Documerge AFP output)
  • LOGO.DAT file should be included, but is not required. The LOGO.DAT file is a text file that specifies the names and rotations of logo fonts. If there are any logo fonts in the Metacode file, MRG2FAP uses a LOGO.DAT file in the FormLib directory so it can convert logo fonts for all rotations into a single Documaker graphic (LOG file).

The LOGO.DAT file, which is a semicolon-delimited file, should look similar to this:

[file name for 0° rotation];[file name for 90° rotation];[file name for 180° rotation];[file name for 270° rotation];

Here is an example:

logo0;logo90;logo180;logo270;;

If you do not have a LOGO.DAT file, you will see a warning message.

  • In addition to an AFP or Metacode print file, you must also specify a font cross-reference (FXR) file which contains the AFP or Xerox fonts used.


Reading Tag Index Comment Records

Generally, tag index comment records in Documerge files begin with x'03'. If, however, you have Documerge files with tag records that begin with x'09' or x'01' instead of the standard x'03', Documaker Studio, and the MRG2FAP utility will consider x'09' or x'01' records located between the index begin and end records if you set the following INI option to Yes in the normalize printer driver:

CommentRecords = Yes

The default is No.

Note '09' controls usually indicate line text. As this record type is not used extensively in true Metacode output, this version adds a check for the “begin” and “end” Documerge tag notification within the 09 control processing. This limits the affect on performance.


Handling Overlays and Page Segments

When using the MRG2FAP utility, if the AFP print file contains references to overlays or page segments, copy the overlay or page segment files into the directory in which the AFP print file resides. Add the following INI options in the PrtType:AFP control group in the FSISYS.INI file to specify the file extension for overlay and page segment files.

< PrtType:AFP >
  OverlayExt	=
  PageSegExt	=


Keeping Blank Pages

When using the MRG2FAP utility, use the KeepBlankPages option when you are converting AFP and Xerox Documerge files into FAP files to retain blank pages. Here is an example:

< PrtType:AFP > or < PrtType:XER >

KeepBlankPages = Yes

Normally blank pages are removed because the system assumes they are duplex back pages that are not needed. If, however, you want to retain these pages, add this option and set it to Yes. The default is No which indicates you do want to remove blank pages during a conversion.


Importing Graphics

When using the MRG2FAP utility, you can select a graphic to be imported into a FAP file when you are converting from an AFP file. This graphic is placed on the page based on a medium map tray selection. The graphic is imported so it can mimic paper in a particular tray that has a preprinted graphic.

The options for the tray graphic will be placed within the print driver control group. The system supports up to nine trays so there are up to nine available INI options for the bitmaps. You must include the name of the graphic file, followed by the top and left coordinates specified in FAP units (2400 per inch).

Here is an example:

TrayLogo1 = logoa.log,300,4800

TrayLogo3 = logob.log,300,6500

TrayLogo9 = logoc,200,2000

Note Keep in mind that you can only import graphics.


Suppressing LOG files When Converting AFP to FAP or PDF

When using the MRG2FAP utility, you can use the SuppressLogoUnload option when converting AFP files into FAP or PDF format to avoid possible conversion errors which can arise from converting the same AFP file multiple times.

< PrtType:AFP >

SuppressLogoUnload = Yes

Option | Description
SuppressLogoUnload | Enter Yes to suppress the unloading of graphic (LOG) files during a conversion of AFP files to FAP or PDF format. You should always set this option to yes when creating PDF files. The default is No.

When you enter Yes, AFP to PDF conversions, whether run from the MRG2FAP utility or IDS, do not result in new LOG files being unloaded from AFP page segments. The LOG files were unloaded for use by FAP files and are not needed for the conversion to PDF format.

Unless you need to look at or use the FAP files, set this option to Yes. If you do need the FAP files, you must also delete all LOG files before you run the MRG2FAP utility to make sure you are getting the correct results.

Note This option does not delete any LOG files created by a prior conversion, so you should delete all LOG files before you use the SuppressLogoUnload option


Adding PDF Bookmarks

You can add bookmarks to your PDF output when converting AFP files into FAP files and then into PDF files using the MRG2FAP utility. The bookmarks on the AFP file are TLE records.

Use the Bookmark option to tell the system how to create bookmarks:

< PrtType:PDF >
  Bookmark = Yes,Page,No

Option

Description

Bookmark

This option contains three values. Separate the values with commas (,).

The first value enables bookmarks. Enter Yes to tell the system to create bookmarks. The default is No.

The second value indicates the lowest level for which the system will create bookmarks. You can choose from Formset, Group, Form, or Page. For example, if you enter Form, the system creates bookmarks for each form set, for each group in all form sets, and for each form in all of the groups. The default is Page.

Use the third value to turn off generic bookmarks for all pages. For example, enter No if you do not want every page to have a bookmark like Page 01, Page 02, Page 03, and so on.

If you only want TLE bookmarks to appear, enter No for the third value.

You can add TLE support to your AFP printer driver by including these options in your AFP printer control group:

< PrtType:AFP >
  TLEScript	= TLE.DAL
  TLEEveryPage	= No
  TLESeparator	= :

Then use this DAL script to create a TLE script for the page. The word BOOKMARK must appear at the beginning of the comment. The text that immediately follows BOOKMARK will comprise the bookmark for that page. Here is an example:

bkmark = 'BOOKMARK'
bkmrktext = 'Introduction and Comments'
AddComment (bkmark & bkmrktext);
RETURN('FINISHED!')

This would create the following TLE record for the corresponding page:

BOOKMARKIntroduction and Comments

The AFP loader would then translate the TLE record into a PDF bookmark when the AFP file was converted using the MRG2FAP utility.

For more information on adding TLE scripts to an AFP file, please see Adding TLE Records in the Documaker Administration Guide.

Note Keep in mind the bookmarks are only passed through the FAP file. There is no way to edit bookmarks.


Handling Incorrect Translation Tables

This topic applies to tthe MRG2FAP utility.

Before version 11.4, no warnings were issued when you loaded a normalized Metacode file if there was a problem with the CodeDef translation table, which handles EBCDIC to ASCII translation for the replacement (Documerge tag) records.

Replacement (Documerge tag) records are converted into Documaker variable field records when you convert Documerge EDL members into Documaker section (FAP) files.

In version 11.4 and later, the utility shows you this error message if there is a problem with the CodeDef file translation of the Metacode record:

Replacement character mismatch: Possibly invalid Metacode file or CodeDef file

This message can indicate...

  • An incorrect CodeDef file is being used
  • The CodeDef file is corrupt
  • The Metacode file is corrupt

After the error message appears, the utility continues processing and creates output, but you should check that output to make sure it is correct.


Specifying Code Pages

When using the MRG2FAP utitliy, you can use font definition files to specify the code pages you want to use in a document. The system loads these files as it loads the AFP print stream. For instance, you can use...

  • The default EBCDIC code page for every font used in a document (just as before)
  • The default EBCDIC code page for some fonts and a specified code page for other fonts
  • Specified code pages for all of the fonts in the document
Note Prior to version 11.1, Documaker Server handled traditional AFP font resources (character sets, code pages, and coded fonts), but only allowed you to use a single, default code page for each document. The AFP loader translated input AFP text from EBCDIC to ASCII using a default EBCDIC code page.

Here is a brief summary of the font definition files you can use to specify code pages:

File | Description
CODED.FNT | The coded font definitions. This file specifies which AFP code page and AFP font character set make up the coded font.
CPDEF.FNT | The code page definitions. This file maps each AFP code page to a Windows character set.
CPGID.CP | The code page map file. This file contains the character identifiers (and associated EBCDIC hexadecimal code points) for an IBM code page and maps them to character identifiers (and associated ASCII code points) for a Windows ANSI or SYMBOL character set.

Syntax Rules

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


Syntax Rules

Here are the general syntax rules for the font definition files:

  • A semicolon (;) in the first column of any of these files will cause the line to be treated as a comment statement and ignored.
  • Section headers within files are enclosed either in brackets (<> or []) with no spaces and must not be removed or changed.
  • All values are case insensitive.
  • If a parameter value is invalid and a default value exists, it will be substituted.
  • All parameters are positional.
  • Blanks are allowed between parameter values.
  • The question mark (?) is used in some areas as a single wildcard character.
  • If the resource file exists in DEFLIB directory and contains valid data conforming to these specifications, it will be loaded and used.
  • If bad data is encountered in the file, either the offending record is ignored or a warning is issued. If the file is considered corrupt or invalid enough, it may not be used at all.


CODED.FNT file

This file specifies which AFP code page and AFP font character set make up the coded font. The CODED.FNT file is necessary for basic multiple code page support. When creating this file, keep these rules in mind:

  • The coded font name and both parameters are required.
  • A question mark (?) can be used as the wildcard character only for the second character in the coded font name and for any character of the character set name. This allows all the character rotations of the coded fonts to be handled with one entry for searching.
  • After the coded font name, the character set name must be listed first, followed by the code page name.
  • The character set and code page must be separated by a comma.

Here is an example of this file:

X?COL8=C?420080,T1000850
X?COL7=C?420070,T1000850
;Core
X?H210AC=C?H200A0,T1V10500
X?H210FC=C?H200F0,T1V10500
;FormMaker Fonts
X?FA????=C?FA????,T100ASC4
X?DA????=C?FA????,T1DOC037
X0P09X12=C0P09X12,T1DOC037
X0P12X16=C0P12X16,T1DOC037


CPDEF.FNT file

This file maps each AFP code page name to its code page global identifier (CPGID) and to a Windows character set. If you do not have at least one valid entry in this file for each code page you want to use, the system uses the default code page. When creating this file, keep these rules in mind:

  • Parameters must be separated by a comma.
  • AFP code page name and code page identifier are required.
  • If you create your own code page, you must assign it a unique code page identifier. Leading zeros are invalid.
  • Code Page Global Identifier (CPGID) attribute's possible values: IBM-defined CPGID or your own defined CPGID between 65280 and 65534, inclusively. This value matches the name of a code page map file.
  • For each CPDEF.FNT entry, you must have a corresponding code page map file with the same name as the CPGID.
  • Windows character set attribute's possible values: ANSI or SYMBOL.

Here is an example of this file:

<CODEPG>

;code page = cpgid,wincp

;*****Put User-defined/Custom code pages Here *****

T100ASC4=361,ANSI

T1DOC037=37,ANSI

T1OMR=5280,ANSI

T1POSTBC=5280,ANSI

;******* End User-defined/Custom code pages ******

T1000259=259,SYMBOL

T1000290=290,ANSI

T1000293=293,ANSI

T1000310=310,ANSI

DEFAULT=361,ANSI


CPGID.CP (code page map file)

You must have a separate CPGID.CP file for each AFP code page entry in the CPDEF.FNT file. Each code page map file contains the character identifiers (and associated EBCDIC hexadecimal code points) for an IBM code page and maps them to character identifiers (and associated ASCII code points) for a Windows ANSI or SYMBOL character set. Code page map files are necessary for basic multiple code page support.

Note:

The actual file name is not CPGID.CP, but rather the CPGID value from the CPDEF.FNT file with an extension of CP. For instance, in the CPDEF.FNT example, the first two lines are:

T100ASC4=361,ANSI

T1DOC037=37,ANSI

So, since those two entries are in the CPDEF.FNT file, that means that there must be code page map files with named 361.CP and 37.CP.

Also, if these two entries are in the CPDEF.FNT file, but the corresponding 361.CP and 37.CP code page map files are not in DEFLIB, the translations for those fonts will not be correct.

When creating this file, keep these rules in mind:

  • Parameters must be separated by blanks.
  • All four parameters are required.
  • NOMATCH means there is not a matching character in the Windows character set.

Here is an example of this file: (395.cp for the T1000395 code page mapped to the Windows ANSI character set):

;T1000395 to ANSI
SP010000 40 SP010000 20
LA150000 42 LA150000 E2
LA170000 43 La170000 E4
LA130000 44 LA130000 E0
SP180000 8B SP180000 BB
SM560000 8C SM560000 89
SA000000 8D SP100000 2D
LI510000 8E NOMATCH 00
LI570000 8F NOMATCH 00
SM190000 90 SM190000 B0
LJ010000 91 LJ010000 6A
LF510000 A0 NOMATCH 00
;;;;;;;; ;  SD150000 5E
;;;;;;;; ;  SD130000 60


Converting Mixed Mode AFP Files into FAP or PDF Files

The MRG2FAP utility includes limited support for converting Mixed Mode AFP source files into FAP or PDF files.

The utility assumes the Mixed Mode AFP source contains AFP commands and line data for one or more pages. A single page/side consists of an AFP Invoke Medium Map command, followed by an AFP Invoke Data Map command, optionally followed by an Invoke Page Segment (IPS) command, followed by a line of actual, unformatted line data. The line data must be formatted using the AFP commands and formatting information contained in the invoked Medium Map and Data Map.

All AFP resources, including the AFP source file, the PageDef (page definition) file, and the FormDef (form definition) file must be in variable block format.

Note Additional resources, such as AFP overlays and page segments, must also be in variable block format. Only 4-byte variable block format has been tested.

Keep in mind...

  • The utility assumes all medium maps necessary for the conversion are contained in a single external FormDef file and all data maps are contained in a single external PageDef file. Use these INI options to specify the location of these files:
< PrtType:AFP >
  FormDef = F1POLL.fde
  PageDef = P1POLL.pde

Both files are necessary for converting Mixed Mode AFP into FAP or PDF files.

Note Although inlined medium maps have been tested in regular AFP conversions, inlined medium maps and inlined data maps have not been tested in a Mixed Mode environment.
  • The first line/record of line data for each invoked data map is preceded by a single byte carriage control. Although ANSI and machine code control characters are supported, only ANSI control characters have been tested. According to IBM AFP documentation, only one of the two kinds of control characters should exist in each Mixed Mode source file.
  • You cannot use Table Reference Characters (TRCs).


Using Mobius Metacode Print Streams

You can use Mobius to archive Metacode print streams and also use Docupresentment to retrieve archived Metacode print streams and produce or present PDF files.

You can retrieve the archived Metacode print streams using Mobius' ViewDirect APIs. The ViewDirect APIs are built to communicate with the Mainframe Mobius Archive via TCP/IP. If you license the Mobius' ViewDirect APIs, you can write a custom rule to retrieve your archived Metacode print streams.

To do this, include these options in your FSISYS.INI file for MRG2FAP utility (and Studio):

< PrtType:XER >
  OutMode  = MOBIUS
< Loader:MOBIUS >
  Desc	   = Mobius Metacode files (*.MET)
  Func     = XERLoadMobius
  Module   = XEROS2
< Loaders >
  Loader   = MOBIUS
< Control >
  Mobius   = XER

Where XER is the printer control group that contains the Mobius Metacode information.

To use the Mobius Metacode loader in Docupresentment, use the same MTCLoadFormset rule you would use to load a Documerge Metacode print stream.

To specify a Mobius Metacode print stream, instead of a Documerge print stream, the Xerox printer control group must include this INI option:

< PrtType:XER >
 OutMode = MOBIUS

Metacode print streams retrieved from a Mobius archive have a special record blocking scheme and use special comment records to indicate the fonts used. This version adds support for reading Metacode print streams retrieved from a Mobius archives.

Use XERLoadDocuMerge as the loader function. It checks for an OutMode setting of MRG2, MRG4, or ELIXIR. You must add MOBIUS to the list of allowed OutMode settings and you must add your Mobius comment checking to XERLoadMet, when the OutMode option is set to MOBIUS.

Notes

  • The loader functions convert a particular type of file, such as a PCL print stream, a Metacode print stream, an RTF file, and so on, into an internally formatted file. Once converted, the system can then do a variety of things with that file, like display it in Studio, print it on a supported printer, or save it as another type of file, such as a FAP file, RTF file, or a print stream file.
  • The loader included in this version can also be used in other Documaker products. For instance, Studio can use it to load Mobius Metacode, then display, modify, and save the result as a FAP file or print to a supported printer. It can also be used by the METDUMP utility to dump information about the Mobius Metacode print stream.


Building Metacode Resources

The FSISYS.INI and FAPCOMP.INI files are system initialization files used by various Documaker programs, including the MRG2FAP utility. You must add a PrtType:XER control group to these INI files. This control group contains the Xerox Metacode options used for the archived Metacode print streams.


PrtType Control Group

Below is an example of the PrtType:XER control group, which contains these options:

< PrtType:XER >
    DJDEIden	= A'@@@DJDE'
    DJDEOffset	= 0
    DJDESkip	= 8
    OutMode	= BARR
    ImageOpt	= No
    JDEName	= DFLT
    JDLCode	= NONE
    JDLData	= 0,255
    JDLHost	= IBMONL
    JDLName	= CBA
    JDLRStack	= 0,10,EQ,X'13131313131313131313'									(optional)
    JDLRPage	= 1,5,EQ,X'FFFF26FFFF'									(optional)
    PrinterInk	= Blue
    PaperSize	= 0
    DefaultFont	= 11010

Several of these INI settings are based on comparable options and values in the settings of the printer's JSL. A JSL may contain many JDLs from which to choose, or there may be multiple JSLs compiled into multiple JDLs.

An excerpt of a JDL follows, along with an explanation of each of the PrtType:XER control group options.

  • JDL Example
  • DJDEIden, DJDEOffset, and DJDESkip
  • OutMode
  • ImageOpt
  • JDEName
  • JDLCode
  • JDLData
  • JDLHost
  • Additional Settings for Xerox Printers
  • JDLName
  • JDLRStack
  • JDLRPage
  • PrinterInk
  • PaperSize
  • DefaultFont


Additional Settings for Xerox Printers

For a Xerox print driver, you must also specify these functions in the PrtType:XER control group:

OutputFunc = XEROutput

OutMetFunc = XEROutMet

InitFunc = XERInit

TermFunc = XERTerm

Module = XERW32


DefaultFont

Use this option when displaying the names of fonts which are not found in the font cross reference (FXR) or LOGO.DAT files. The value for the DefaultFont option is a font ID which is contained in the font cross reference (FXR) file being used.

< PrtType:XER >

DefaultFont = 11010


DJDEIden, DJDEOffset, and DJDESkip

These options represent the IDEN statement of the JDL. The value of the DJDEIden setting is a string constant. The types of supported string constants are ASCII (A'string'), EBCDIC (E'string'), Character ('string'), and Hex (X'string').

These types of strings are not supported: Octal, H2, and H6. Strings containing repeat counts, embedded hex values, and upper/lower case toggles are not supported. Using the JDL sample listed earlier, the INI options should be:

DJDEIden = A'@@@DJDE'

DJDEOffset = 0

DJDESkip = 8


ImageOpt

Use this option to specify if the logos are saved on the Xerox printer as IMG files or as FNT files. To use IMG files, your printer must have GVG or GHO hardware installed. Also, in the JSL, you must set the Graphics option to Yes.

If you are using IMG files, set this option to Yes; otherwise set it to No. Metacode printers have a limit of 16 images on a page. Here is an example of this option:

ImageOpt = No


JDEName

Use this option to represent the name of the job. A JDL may contain many jobs (JDEs) from which to choose. Using the JDL sample listed earlier, the Metacode job is selected using this INI setting: (This JDE must contain VOLUME CODE=NONE)

JDEName = META


JDL Example

Here is an excerpt of a JDL. This excerpt is referenced in the control group options discussion.

CBA: JDL;

T1: TABLE CONSTANT=X'121212121212121212';

T2: TABLE CONSTANT=X'13131313131313131313';

T3: TABLE CONSTANT=X'FFFF26FFFF';

C1: CRITERIA CONSTANT=(0,9,EQ,T1);

C2: CRITERIA CONSTANT=(0,10,EQ,T2);

C3: CRITERIA CONSTANT=(1,5,EQ,T3);

VOLUME HOST=IBMONL;

LINE DATA=(0,255);

IDEN PRE=A'@@@DJDE',

OFF=0,

SKIP=8;

ROFFSET TEST=C1;

RSTACK TEST=C2,DELIMITER=YES,PRINT=NONE;

RPAGE TEST=C3,SIDE=NUFRONT;

/* 8.5 x 11 job */

USA1: JDE; /* JOB can be used in place of JDE */

OUTPUT PAPERSIZE=USLETTER;

/* 8.5 x 14 job */

META: JOB;

VOLUME CODE=NONE

/* Default job */

DFLT: JDE;

VOLUME CODE=EBCDIC

END;


JDLCode

Use this option to represent the type of input format expected by the Xerox printer during normal operation (that is, the JDL/JDE setting used to start the printer). Character translation is performed as necessary.

The system supports EBCDIC, ASCII, or NONE, which is the same as ASCII. These formats are not supported: BCD, H2BCD, H6BCD, IBMBCD, PEBCDIC, and user-defined code translation.

Referring to the sample JSL, if the printer is normally started with STA DLFT,CBA then the JDLCode parameter must be set to CODE = EBCDIC. The INI setting must contain the value of the CODE= statement for the printer's normal operation. Here is an example of this INI option:

JDLCode = EBCDIC


JDLData

Use this option to represent the starting position and length of the print line data within an input data record. The LINE statement contains a DATA entry which holds these values. An example of this INI setting is as follows:

JDLData = 0,255


JDLHost

Use this option to tell the system whether the printer is normally on-line or off-line. You can choose from IBMONL (on-line) and IBMOS (off-line). Using the JDL example listed earlier, this INI option should be set to:

JDLHost = IBMONL


JDLName

Use this option to represent the name of the JDL to use. Using the JDL sample listed earlier, this option should be set to:

JDLName = CBA


JDLRPage

Use this optional INI option to represent the criteria which signals a jump to the front side of a new sheet to the printer. In the JDL sample listed earlier, the RPAGE statement performed a criteria test named C3. The C3 test checks a specific part of each input line against the string named T3. If the string T3 matches an input data record at position zero (0) for a length of 5 bytes, a jump to new sheet condition is signaled because of the SIDE=NUFRONT setting. Only CONSTANT criteria using an EQ operator is supported. The SIDE=NUFRONT setting in the JSL is required for JDLRPage to work properly.

Note If the print job is likely to contain duplex pages alternating with simplex (one sided) pages, JDLRPAGE provides a way to leave the back sides of certain pages blank.

Using the JDL sample listed earlier, this option should be set to:

JDLRPage = 1,5,EQ,X'FFFF26FFFF'


JDLRStack

Use this optional INI option to represent criteria which tells the system to send an end of report condition to the printer. In the JDL example, the RSTACK statement performed a criteria test named C2. The C2 test checks a specific part of each input line against the string named T2. If the string T2 matches an input data record at position 0 for length of 10 bytes, an end of report condition is signaled. Only CONSTANT criteria using an EQ operator is supported.

Note If the printer is alternately used for Metacode and text file print jobs, you must include the JDLRStack option. We recommend always using JDLRStack.

Using the JDL sample listed earlier, this option should be set to:

JDLRStack = 0,10,EQ,X'13131313131313131313'


OutMode

This option indicates the output format for the Metacode data stream generated by your Documerge system. You have these options:

Enter BARR, if you generate output using a Windows system and then transmit that output to a Xerox printer using BARR SPOOL hardware and software. If you choose BARR, a length byte is placed at the start and end of each Metacode record.

Enter BARRWORD only if records longer than 255 characters can be handled by your Xerox printer.

Enter ELIXIR to convert Elixir-formatted Metacode print files into FAP files.

For normalized Metacode, the system supports the standard Documerge 4-byte ISI format and the 2-byte variable (ISI 2-byte) format. Enter MRG4 to use the Documerge 4-byte ISI format. Enter MRG2 to indicate you want to use the 2-byte variable (ISI 2-byte) format.

Enter PCO if you generate output using a Windows system and then transmit that output to a Xerox printer using PCO hardware and software (from Prism). When you select PCO, a 4-byte length field is placed at the start of each Metacode record.

Note We have not completely tested the PCO interface.

Enter JES2 for z/OS environments. If you will upload output generated on a Windows system to an z/OS system and then transmit the output to your printer via JES2, use OutMode = JES2.

Enter ENTIRE if you will transmit output generated by a Windows or UNIX system to a Xerox printer via a Sun workstation using ENTIRE/FIBER GATEWAY hardware and software (from Entire, Inc.). When you choose ENTIRE, a 2-byte length field is placed at the start of each Metacode record.

Enter LAN4235, if you generate output for a Xerox 4235 printer attached to a network.

Here is an example of this INI option:

OutMode = BARR

Note This version assumes Metacode output produced by Documerge which does not correspond to any of the outmodes listed above. You must, however, still choose an outmode from those options listed above.


PaperSize

Use this option to specify the size of the paper. Here are your options:

For | Enter
US letter | zero (0). This is the default.
US legal | 1
ISO A4 | 2
US executive | 3
US ledger | 4
US tabloid | 5
US statement | 6
US folio | 7
US fanfold | 8
ISO A0 | 20
ISO A1 | 21
ISO A2 | 22
ISO A3 | 23
ISO A5 | 25
ISO A6 | 26
ISO A7 | 27
ISO A8 | 28
ISO A9 | 29
ISO A10 | 30
ISO 2A | 32
ISO 4A | 34
ISO B0 | 40
ISO B1 | 41
ISO B2 | 42
ISO B3 | 43
ISO B4 | 44
ISO B5 | 45
ISO B6 | 46
ISO B7 | 47
ISO B8 | 48
ISO B9 | 49
ISO B10 | 50
ISO 2B | 52
ISO 4B | 54
ISO C0 | 60
ISO C1 | 61
ISO C2 | 62
ISO C3 | 63
ISO C4 | 64
ISO C5 | 65
ISO C6 | 66
ISO C7 | 67
ISO C8 | 68
ISO C9 | 69
ISO C10 | 70
ISO DL | 71
JIS B0 | 80
JIS B1 | 81
JIS B2 | 82
JIS B3 | 83
JIS B4 | 84
JIS B5 | 85
JIS B6 | 86
JIS B7 | 87
JIS B8 | 88
JIS B | 89
JIS B10 | 90
custom | 98


PrinterInk

Use this option to specify the color of ink loaded on a Xerox highlight color printer. You can set the PrinterInk option to either Blue, Red, or Green (blue is the default). This option is used with the SendColor INI option. If you set the SendColor option to Yes, you should also set the PrinterInk option. Here is an example of this INI option:

PrinterInk = Blue


MRG2FAP Error Messages

The following information describes how to handle error messages you may encounter while using the MRG2FAP utility on AFP print streams.

Character set ___ not found

Error opening overlay: xxxxxxxx

This message indicates the AFP print stream uses an overlay the system could not find. Note the path and file extension of the overlay specified in the error message. Make sure your AFP overlay is stored in the directory with the AFP print stream. The overlay extension is specified in the OVERLAYEXT option of the printer control group. If no OVERLAYEXT option setting is found, the system looks for the default extension (OVL) for the AFP overlays.

Error opening page segment: xxxxxxxx

This message indicates the AFP print stream uses a page segment the system could not find. Note the path and file extension of the page segment specified in the error message. Make sure your AFP page segment is stored in the proper directory and contains the expected file extension. Page segments are expected to be in the same directory as the AFP print stream. The page segment extension is specified in the PAGESEGEXT option of the printer control group. If no PAGESEGEXT option setting is found, the system looks for the default extension (PSG) for the AFP overlays.

Error opening logo: xxxxxxxx

If you receive this message, it is likely the AFP print stream uses a page segment the system could not find. If so, you would have received an error message for the missing page segment as well. Correct the problem with the missing page segment and this error will not occur.


Character set ___ not found

If you receive this message, the AFP print stream uses a character set and code page file name instead of a coded font file name to specify the AFP font to be used. In this case, you must create a file called IBMXREF.TBL to provide additional AFP font information. IBMXREF.TBL is a text file that contains pairs of coded font names and character set names. Place this file in the directory with the AFP print stream.

What you are doing is specifying the coded font file name to use when a reference to the character set file is found in the AFP print stream. The system searches in the FXR file for the coded font file name to determine font information it needs during the PDF conversion.

When entering the coded font and character set names in IBMXREF.TBL, do not use the first two letters (X0, X1, C0, C1, and so on). The coded font and character set names need to be written in UPPER CASE and separated by at least one space. Each pair of coded font and character set names should be written on separate lines. For example, if you receive an error stating…

Character set C0AR111 not found...

Add a line of coded font and character set names to the IBMXREF.TBL. If a coded font file named X0AR11P contained a reference to the character set file C0AR111, you would add the following line to IBMXREF.TBL:

AR11P AR111

Notice the first two letters of X0AR11P and C0AR111 are omitted from the line added to IBMXREF.TBL. You should have inserted the coded font file, X0AR11P, into the FXR file previously.

If you have character set files but do not have any coded font files, you can insert a character file into the FXR. However, you must edit fonts inserted into the FXR and specify a coded font file name on the Printers page. In this case, simply use the character set name as the coded font name (remembering to change the first letter from C to X). In this case, the pair of names stored in the IBMXREF.TBL will be the same.

If you have a character set file used by more than one code page file, you may want to map each character set/code page file combination to a coded font file named in the FXR. To do this, add a third column to the IBMXREF.TBL. The third column will contain the name of code page file. For example, to map the coded font file, X0AR11P, to the character set and code page files, C0AR111, and T1ISI121, you would add the following line to IBMXREF.TBL:

AR11P AR111 T1ISI121

Notice the first two letters of X0AR11P and C0AR111 are omitted from the line added to IBMXREF.TBL but the full name of the code page file, T1ISI121, is used.


MRG2MVS

Use this utility to convert Metacode and AFP files that use Documerge record formatting into MVS record-oriented files. You need to use this re-blocking utility when you transfer Metacode and AFP files to host-attached IBM AFP or Xerox Metacode high-speed printers.

Note Use this utility in place of the Documerge Host Communications utility, DFXVBFIX.

Program names

  • z/OS: MRG2MVS

Syntax

MRG2MVS /I /O /2

Parameter | Description
/I | Enter the name of the variable block input file. The default is DD:INFILE.
/O | Enter a name for the record-oriented MVS output file. The default is DD:OUTFILE.
/2 | (Optional) Include this parameter if the Input file uses a 2-byte record format.
Note z/OS does not allow file names that begin with a number (0-9). If one or more of your print files begin with a number, you will not be able to upload these files to z/OS.


Sample JCL for Converting AFP or Metacode Files

Here is an example of the JCL you might use to convert an uploaded AFP or Metacode print stream for subsequent printing:

***************************** Top of Data ***********************
//USERIDA  JOB   (33005),'DAP -       ',CLASS=T,MSGCLASS=X,
//         NOTIFY=USERID
//*
//         SET HLQ='FSI.V114'   <== SET HIGH LEVEL QUALIFIER
//         SET RES='RPEX1'      <== SET RESOURCE (E.G. RPEX1, UTEX1)
//*
//         JCLLIB  ORDER=&HLQ..PROCLIB
//*
//*****************************************************************
//*  PROGRAM : MRG2MVS
//*  PURPOSE : TO CONVERT DOCUMERGE VARIABLE BLOCK FILE INTO
//*            AN MVS RECORD ORIENTED FILE.
//*
//*  PARMS   : /I=   NAME OF INPUT FILE  (DEFAULT: DD:INFILE)
//*            /O=   NAME OF OUTPUT FILE (DEFAULT: DD:OUTFILE)
//*            /2    INPUT FILE USES 2-BYTE VARIABLE BLOCK FORMAT
//*                  (OPTIONAL)
//*
//****************************************************************
//*
//MRG2MVSD EXEC PGM=IEFBR14
//OUTFILE  DD DSN=&HLQ..&RES..GENPRINT.PRTBAT1,
//            UNIT=SYSDA,SPACE=(TRK,0),
//            DISP=(MOD,DELETE,DELETE)
//*
//MRG2MVS1 EXEC PGM=MRG2MVS,
//         PARM='/ /I=DD:INFILE /O=DD:OUTFILE'
//STEPLIB  DD DSN=&HLQ..LINKLIB,DISP=SHR
//         DD DSN=SYS1.SCEERUN,DISP=SHR
//*
//INFILE   DD DSN=&HLQ..&RES..GENPRINT.PRTBAT1.FROMPC,DISP=SHR
//OUTFILE  DD DSN=&HLQ..&RES..GENPRINT.PRTBAT1,
//         UNIT=SYSDA,SPACE=(CYL,(1,1)),DISP=(,CATLG),
//         DCB=(RECFM=VBM,LRECL=8205,BLKSIZE=23000)
//SYSPRINT DD SYSOUT=*


MRG2MVS Messages

The MRG2MVS utility displays information about its state of operation as it is running.

For example, if you are converting a Xerox Metacode print stream like the one shown in the sample JCL, the utility displays the following information:

------ MRG2MVS -------

Converting variable block file to native MVS file...

Finished writing 5579 records: DD:OUTFILE

------ MRG2MVS -------

You could have omitted the “/I=DD:INFILE /O=DD:OUTFILE” parameters since these DD names are the defaults for the /I and /O parameters. If, however, you had omitted these parameters, you would see warning messages similar to these:

------ MRG2MVS -------

Missing /I= parameter, will use DD:INFILE

Missing /O= parameter, will use DD:OUTFILE

Converting variable block file to native MVS file...

Finished writing 5579 records: DD:OUTFILE

------ MRG2MVS -------

If you were converting a 2-byte Documerge record format file, you would need to include the /2 parameter. If you had included this parameter, you would see messages similar to these:

------ MRG2MVS -------

Converting 2 byte variable block file to native MVS file...

Finished writing 5579 records: DD:OUTFILE

------ MRG2MVS -------

Here are the error messages you may see when using the MRG2MVS utility:

------ MRG2MVS -------

Converting variable block file to native MVS file...

ERROR-> Invalid record length (> 64K) at pos: #######

ERROR-> Input file does not use variable block format

ERROR-> Exiting program

-or-

------ MRG2MVS -------

Converting variable block file to native MVS file...

Block/record length mismatch at pos: #######

ERROR-> Exiting program

These messages indicate the utility does not recognize the input file as using the normal Documerge record format. This could be because the input file...

  • Was not uploaded properly
  • Uses the 2-byte variable block format

In either case, try including the /2 parameter.

------ MRG2MVS -------

ERROR-> Cannot create output file DD:OUTFILE

ERROR-> Exiting program

This error means the utility cannot create the output file. This could be because the output file already exists and the JCL used did not delete the existing output file before starting this utility.

------ MRG2MVS -------

Converting variable block file to native MVS file...

WARNING-> No records written, possible empty input file

------ MRG2MVS -------

This error indicates the input file cannot be read or is empty. Make sure the input file is valid.


MRGADD

Use this utility to search the text file produced by the MRGCHK utility and add the fonts listed there to the designated FXR file so they can be used in the library.

Syntax

MRGADDW /I /X /N

Parameter | Description
/I | This is the file created by the MRGCHK utility.
/X | This is the FXR file (REL121.FXR) that contains the fonts you want to add.
/N | (Optional) Use this parameter to specify an INI file to use. The utility uses the master resource information for the directories so it can find the resources.

Here is an example:

mrgaddw.exe /I=resource.txt /X=rel121.fxr /N=fapcomp.ini

This would use the directories from the FAPCOMP.INI file to search for the fonts and resources that are in the RESOURCE.TXT file. It would add the fonts found to the rel121.FXR file. MRGADD would then output the RESOURCE.TXT file with all the resources that were still not found.


MRGCHK

Use this utility to check all the print files you designate and output the resources used in those files into a text file you specify. Use this utility and the MRGADD utility to get information about Documerge Metacode and AFP print streams.

This utility can detect Metacode files that have improper formats, such as if the files are not 4-byte variable blocked (MRG4 format). The utility issues an error message if such a file is detected.

Syntax

MRGCHKW /I /L /P /N /X /A /R

Parameter

Description

/I

Use this parameter to specify the print files you want to scan for resources. You can use wildcard, such as *.met.

/L

Enter the name of the output file where you want the utility to put the resource list. The utility returns the information in a comma-delimited text file. The file is placed in the directory from which you are running the MRGCHK utility.

/P

This is the printer type to be used from the INI file. MRGCHK automatically uses the FSISYS.INI so you must designate which printer information to use.

/N

(Optional) You can use this parameter to specify an INI file. The default is the FSISYS.INI file.

/X

(Optional) Use this parameter to check for font names instead of just checking the font directory from the INI file.

/A

(Optional) Use this parameter to tell the utility to load an existing output file and append new resources to it; otherwise, the output file is overwritten. Existing resources are not duplicated so using this option gives you a growing list of resources.

/R

(Optional) This parameter outputs all resources regardless of whether they are found within the setup. Use this option only if you want to have a concise list of resources and are not using the output file with the MRGADD utility.

Omitting this parameter means only the resources that were not found in the fonts directory or in the FXR are included in the output file.

Examples

Here is an example:

mrgchkw.exe /I=*.met /L=resource.txt /P=XER

This example will search for all MET files in the forms library using the XER PrtType from the FSISYS.INI file and will list the resources that were not found in the file named RESOURCE.TXT.

Here is another example:

mrgchkw.exe /I=*.met /L=resource.txt /P=XER /N=fapcomp.ini /X=rel121.fxr /A /R

This example would find all the resources used by all the MET files in the forms directory using the XER printer found in the FAPCOMP.INI file. It would append those resources to an existing file named RESOURCE.TXT.


OPENUSER

Use the OPENUSER utility to reset user IDs.

Note This utility only works with xBase files. It does not work on SQL, Oracle, or DB2 databases.

Program names

  • Windows: OPENUW32.EXE

Syntax

OPENUW32

Only one user can log in at a time. This prevents people on different workstations from clashing over the same resources. If the InUse flag is inadvertently left on, usually through a crash or power off, a system supervisor can run this utility to unlock that user's ID. Then the user can log on as usual.

This window appears when you run this utility:

The OPENUSER utility requires the following files to be in the working directory:

  • FSIUSER.INI
  • USERINFO.DBF


OVL2FAP

Use the OVL2FAP utility to convert an OVL (IBM AFP overlay) file into a FAP file.

Program names

  • Windows: OVL2FAPW.EXE

Syntax

OVL2FAPW /I /X /T /O

Parameter | Description
/I | Enter the name of the OVL file.
/X | Enter the name of the font cross-reference (FXR) file.
/T | Enter the path where the utility should look for the IBMXREF.TBL file.
/O | Enter the name of the FAP file if different than input file name.

The OVL2FAP utility requires the following files be present:

  • ?.FXR
  • IBMXREF.TBL (This file contains pairs of coded font names and character set names, without prefixes. It is not included with Documaker applications.)

The OVL2FAP utility is the opposite of the FAP2OVL utility. The OVL2FAP utility converts an AFP overlay printer resource file into a FAP file. In addition to the OVL AFP overlay file, you must also specify the font cross-reference (FXR) file which contains the AFP fonts used.

Example

Here is an example:

OVL2FAP /I=AFPBAT1 /X=REL121SM

This command creates a file named AFPBAT1.FAP.

Note Be sure the OVL file used is one used for AFP and not PCL. To be sure that the correct file type is being used, open the OVL file in an editor that supports hex mode. If the first byte is “1B” then the OVL is for a PCL printer. If the first byte is 5A, the correct OVL is being used.


OVLCOMP

Use the OVLCOMP utility to create precompiled overlays for the GenPrint program.

Note You can also perform these tasks using the Tools, Compile option in Studio.

Program names

  • Windows: OVLCOMPW.EXE

Syntax

OVLCOMPW /I /X /O /L /F /U /T /W /N /P /H /VF /C /LB

Parameter | Description
/I | Enter the name of the FAP file. Omit the extension.
/X | Enter the name of the FXR file (REL121.FXR). Omit the extension. The utility creates a FNT file if you omit the /I parameter.
/O | (Optional) Enter the name of the output OVL file. Omit the extension.
/L | Enter the name of the DLL. PCLW32 is the default.
/F | Enter the name of the function. PCLPrint is the default.
/U | Enter the type of printer. PCL is the default.
/T | Include to perform a print test to a file with a TST extension.
/W | Include to download fonts in the test, if requested.
/N | Include if you do not want to be notified of errors.
/P | Include to incorporate permanent fonts, f downloaded.
/H | Include to use HMI.
/VF | Include to get a sample print with variable fields.
/C | Include to use color.
/LB | Add this parameter to override the default logical bottom for the form being normalized. To specify a different logical bottom value, include the parameter and a value, as shown here: /LB = value
Note All switches are optional and all except those noted below are case-insensitive.

See OVLCOMP Parameter Considerations.

The OVLCOMP utility requires the following files:

  • FSISYS.INI
  • ?.FXR (you must specify the FXR as one of the parameters)

Producing Normalized Files

Example

Here is an example:

ovlcomp /i=chtovp3 /x=rel121

This command creates a PCL overlay file named CHTOVP3.OVL.

Here is another example, which shows how you can use this utility to compile a FAP file into a PST overlay.

  1. Copy the FXR and INI files (such as rel121.FXR and FSISYS.INI) into the directory where the FAP files are stored.
  2. Enter this command:

ovlcompw /I=my.fap /L=PSTW32 /F=PSTPrint /U=PST /X=rel121 /H /C


OVLCOMP Parameter Considerations

Please note that:

  • The /P and /W parameters are for PCL only.
  • The /P parameter must be used with the /W parameter.
  • The parameters used with the /F parameter are case sensitive.
  • The /L parameter tells the utility which DLL to use, such as AFPPRT, PCLW32, XERW32, or PSTW32.
  • The /F parameter tells the utility which print function to use, such as AFPPrint, PCLPrint, or XERPrint. These print function names are case sensitive.
  • The /U parameter specifies the type of printer. This is the same as the PrtType:XXX control group in the FSISYS.INI file. The XXX represents the printer type. For example, XER for Xerox, AFP for IBM's AFP printers, PCL for the many different PCL type printers such as HP, Optra, Lexmark, and PST for PostScript printers.
  • The /T parameter creates a print ready file to run a test print.
  • The /W parameter downloads PCL fonts that are used in the PCL test file being created.
  • The /N parameter suppresses error notification.
  • The /P parameter, used with the /W parameter, restores printer resident fonts.
  • The /H parameter combines many small Metacode records into one Metacode record to conserve space. This is often referred to as HMI.
  • The /VF parameter creates a print-ready sample file with variable fields filled with Xs to indicate the length of the field. For example, a variable field eight spaces long would appears as XXXXXXXX when printed.
  • The /C parameter turns on the color flag. For Xerox printers, set the PrinterInk option in the PrtType:XER control group in the FSISYS.INI file to the color you want all colored areas to be.
Note Red, blue, or green are the only colors supported by Xerox. Blue is the default for Xerox. AFP printers do not support color. PCL printers use the colors specified in the FAP file (blue is blue, red is red, green is green, and so on). The PrinterInk option supports red, blue, green, ruby, violet, brown, gray, cardinal, royal, cyan, and magenta.


Producing Normalized Files

The OVLCOMP utility can create normalized AFP and Metacode files in addition to AFP overlays or Metacode pre-compiled MET files. To create a normalized file, you must start the OVLCOMP utility with the /VF parameter to specify a print-ready file.

Modify your INI file as shown here:

< Control >
        Normalize = Norm
< PrtType:Norm >
        ...

Option

Description

Normalize

Specify the PrtType control group you want the system to use when it normalizes the files. For instance, if you create a control group called PrtType:Norm to contain the option you want the system to use when it normalizes Metacode files, enter Norm.

If the control group you specify is missing or does not appear to be a Xerox or an AFP printer group (Class=XER, Class=AFP) you will receive errors.

The OVLCOMP utility also now includes the /LB parameter which you can use to override the default logical bottom for the form being normalized. To specify a different logical bottom value, include the parameter and a value, as shown here:

/LB = value

Note You can only use the /LB parameter when normalizing files.


PatchReporter

Use this utility to create a report that shows which patches are installed to Docupresentment’s Java .jar files.

Note Docupresentment contains both .DLL files and Java .jar files. To determine what patches have been applied to the .DLL files, see FSIVER.

You run this utility from the command line. Here is an example:

java -jar c:\int020\int200\jars\PatchReporter.jar -f "*.jar"

The utility has these options:

Option

Description

-f

This option specifies what files or directories to search for text matches. If the next argument is a directory, every jar file in the directory is checked.

Separate individual files or directories using the path separator for your operating system. The default is to use the classpath.

If you use a wildcard with this option, such as

/home/user/int020/docserv/lib/Do*.jar

Enclose the directory list in quotation marks (“), otherwise Java automatically expands the wildcard list.

-s

This option specifies which patch identifier string to search for in the files. Matches are performed on the beginnings of strings. In most cases you will not need to specify this parameter. The default is shown here:

@@IDS

Here is an example, which assumes you are in the directory where the jar files are located:

java -jar PatchReporter.jar -f "*.jar" >report.txt

Here is an excerpt from the report produced by the PatchReporter utility:

--- Docucorp Patch Report Utility Program ---

--- Display Patch Reports ---

Patch Report For : C:\docserv\lib\.\agentxapi.jar

------------------------------------------------------------------

No matches detected for : agentxapi.jar

. . .

Patch Report For : C:\docserv\lib\.\DocumentServer.jar

------------------------------------------------------------------

com/docucorp/ids/DocumentServer.class : 09/18/2009 11:13

@@IDS PATCH 2.2:P01:PCR22166, PCR22380

@@IDS PATCH 2.2:P03:PCR22726

@@IDS PATCH 2.2:P05:PCR23136, PCR23161, PCR23237

@@IDS PATCH 2.2:P06:PCR23776

@@IDS PATCH 2.2:P07:PCR24379

com/docucorp/ids/FilenameTranslator.class : 03/05/2009 11:10

@@IDS PATCH 2.2:P06:PCR23776


PCL2AFP

Use the PCL2AFP utility to convert HP PCL fonts into IBM AFP fonts.

Note You can also use Studio’s Font manager to perform this task.

Program names

  • Windows: PCL2AFPW.EXE

Syntax

PCL2AFPW /I /C /S /D /O

Parameter | Description
/I | Enter the name of the PCL file. Omit the extension.
/C | Enter the code page, such as 437, 850, 1004, or T file name (/C=1004 is the standard in most cases.)
/S | Enter the dots per inch, such as 240 or 300 PCL font. The default is 300.
/D | Enter the dots per inch, such as 240 or 300 AFP font.
/O | (Optional) Enter the output file extension, such as 240 or 300.

You must specify the /I, /C, /D, /S parameters. The output file will default to the same name as the PCL file with either a 300 or 240 extension. This utility creates an AFP character set file.

Note This utility uses the FSISYS.INI file to retrieve code page information.


PCL2FAP

Use the PCL2FAP utility to convert a PCL overlay file into a FAP file.

Program names

  • Windows: PCL2FAPW.EXE

Syntax

PCL2FAPW /I /R /X /O /F /S /N

Parameter | Description
/I | Enter the name of the OVL file.
/R | Enter the name of the font cross-reference (FXR) file.
/X | (Optional) Enter the name of the XRF file.
/O | (Optional) Enter the name of the output FAP file and/or font cross-reference (FXR) file name. Omit the extension.
/F | (Optional) Add to include font records in the FAP file, if created.
/S | (Optional) Add to strip sequence numbers from field names.
/N | (Optional) Enter the name of the INI file. The default is the FAPCOMP.INI file.
Note All parameters are case-insensitive.


PCL2XFNT

Use the PCL2XFNT utility to convert a PCL bitmap font file into a Xerox Metacode font file.

Program names

  • Windows: PCL2XFTW.EXE

Syntax

PCL2XFTW /A /I /O /M /R

Parameter | Description
/A | Include this parameter to adjust bitmaps with a negative left offset.
/I | Enter the name of the PCL file.
/O | Enter the name of the FNT file.
/M | Enter the maximum character number, greater than 64.
/R | Enter the rotation of the font (90, 180, 270, or all), no rotation is the default.

This utility creates a Xerox Metacode font file with an FNT extension from a PCL font file.


PDFKEY

Use the PDFKEY utility to generate the encrypted passwords used in the security control group. This control group specifies where permissions, passwords, and encryption strength are set.

Program names

  • Windows: PDFKW32.EXE
  • MVS: See the Documaker Installation Guide.

Place the executable file (PDFKW32.EXE) in the directory which contains the other Oracle Documaker binary files.

Syntax

pdfkw32 /U /O /K /P /F /M /C /N /R /A /? /H

Parameter | Description
/U | Enter the password required to open the document. You can enter up to 32 characters. Passwords are case sensitive.
/O | Enter the password required to modify the document or its security settings. You can enter up to 32 characters. Passwords are case sensitive.
/K | Enter either 40 or 128 to specify the length of the encryption key. The default is 128.
/P | Enter No to prevent users from printing the file, L to permit low quality printing, or H to permit high quality printing.
/F | Enter No to prevent users from entering form fields. The default is Yes.
/M | Enter No to prevent users from modifying the document. The default is Yes.
/C | Enter No to prevent users from copying text from the document to the clipboard. The default is Yes.
/N | Enter No to prevent users from annotating the document. The default is Yes.
/R | Enter No to prevent users from using reader accessibility tools to view the document. The default is Yes.
/A | Enter No to prevent users from adding navigation aids, such as bookmarks. The default is Yes.

Passwords can contain spaces. Simply enclose the entire password parameter in quotation marks, as shown here:

pdfkw32 "/O=Password With Spaces"


PNG2LOG

Use the PNG2LOG utility to convert a PNG (Portable Network Graphic) file into a graphics (LOG) file.

Note You can also use Studio’s Graphic manager to convert PNG files.

Not all PNG formats are supported. Specifically, PNG supports a transparency attribute that is not supported. The system only supports opaque (non-transparent) bitmaps.

PNG also supports a variety of color bit patterns, such as - 1, 2, 4, 8, 16, 24, and 32 bits per pixel. The system does not support all of these formats, but a 3rd-party PNG library included with the system will convert the bitmaps into a pixel format the system does support.

Program names

  • Windows: PNG2LOG.EXE

Syntax

PNG2LOG /I /O

Parameter | Description
/I | Enter the name of the PNG file you want to convert, with or without the extension (PNG). When converting a large number of files, simply enter /i=*.
/O | The name of the graphics (LOG) file you want to create. Enter the name with or without the extension (LOG). If omitted, the utility uses the PNG file’s name and the LOG extension.

Keep in mind...

  • The system converts PNG files into bitmaps when printing. It handles monochrome (1 bit), 16-color (4-bit), 256-color (8-bit), and full color (24-bit) bitmaps. However, not all printers can support these, so make sure you use bitmaps appropriate for your printer.
  • PDF only supports 1-bit and 24-bit bitmaps. So, some types of PNG files may look different when you create PDF files.


PS2PCL

Use the PS2PCL utility to convert a PostScript font into a PCL bitmap font file.

Note You can also use Studio’s Font manager. See also TT2PCL.

Program names

  • Windows: PS2PCL32.EXE

Syntax

PS2PCL32 /I /P /D /S /O /T

Parameter | Description
/I | Enter the name of the FNT file (PFB file.)
/P | Enter the point size, such as 6, 10, and so on.
/D | (Optional) Enter the dots per inch. The default is 300.
/S | Enter the PS2PCL Symbol Set.
/O | Enter the name of the output PCL file to be created.
/T | Enter the typeface family, such as 3=Courier, 4=Helv, or 5=TmsRmn.

In most cases, you should set the /S parameter to W1. The W1 symbol set matches the characters used by Windows for English and several Western European languages.

For importing PostScript symbol fonts, such as Euro Sans and ITD Zapf Dingbats, which contain characters that do not adhere to a standard Windows code page, set the /S parameter to WD. This tells the utility that these PostScript fonts that contain characters that do not adhere to a standard Windows code page.

The PS2PCL utility converts a PostScript PFB font file into a PCL font. Because PostScript fonts are scalable and PCL fonts are bitmaps, you must specify a point size.

The PS2PCL utility loads the FSISYS.INI file and looks for the DefLib option in the FMRES control group. The path you specify in the DefLib option should indicate where a CODEPAGE.INI file can be found (usually ..\fap\mstrres\fmres\deflib), however, the CODEPAGE.INI file is not required.

If no FMRES control group or DefLib option exists in the FSISYS.INI file, the utility uses the default path (..\mstrres\fmres\deflib).

Documaker uses the Java Runtime Environment (also known as the Java Virtual Machine) to support TrueType and PostScript fonts. In order for Documaker to use the JVM, the system looks for the jvm DLL/DSO (for example, jvm.dll for windows, libjvm.so for Linux and Solaris) and supporting files to be installed in one of the following locations:

  • in your library PATH
  • in "..\jre\bin\client" relative to the current directory
  • in "..\jre\bin\client" relative to any directory in your PATH


PS2PCL Symbol Set

You can choose from the following sets:

  • US - ISO 6: ASCII
  • W1 - Windows Latin/ANSI
  • WE - Windows Latin/Eastern Europe
  • WG - Windows Latin/Greek
  • WL - Windows Latin/Baltic
  • WR - Windows Latin/Cyrillic
  • WT - Windows Latin/Turkish


PSEG2LOG

Use the pseg2log utility to convert an AFP page segment resource which contains a bitmap graphic into a graphics (LOG) file.

Note You can perform this task using the Convert Graphics Files option in Studio’s Conversion wizard.

Program names

  • Windows: PSEG2LGW.EXE

Syntax

PSEG2LGW /I

Parameter | Description
/I | Enter the name of the SEG file. Omit the extension.


PSRESET

Use the PSRESET utility to reset a PostScript printer.

Program names

  • Windows: PSRESETW.EXE

Syntax

PSRESETW/I /P

Parameter | Description
/I | Enter the printer in this format: LPTx (where x is 1, 2, 3, or 4).
/P | (Optional) Enter the printer definition file (.PPD).

This utility resets a PostScript printer attached to the port specified by the /I parameter. If you do not specify a printer definition file, the utility sends a generic PostScript reset command to the printer.


PTFMDW32

Use this utility to create a PDF file for each section (image) in the FORM.DAT file.

Syntax

ptfmdw32 [-i=<formdef>] [-ini=<inifile>] [-f=<formlib>] [-x=<fxrfile>] [-o=<outdir>]

Parameters

Parameter | Description
-i=<formdef> | The form definition file from which to read. The default is FORM.DAT.
-ini=<inifile> | The initialization file from which to read. The default is FSIUSER.INI.
-f=<formlib> | Location of FAP files.
-x=<fxrfile> | Full name of font cross-reference file (FXR file).
-o=<outdir> | Location of output PDF files. Defaults to the same directory as FAP files.


REINDEX

Use the REINDEX utility to reindex a dBase file.

Program names

  • Windows: REINDEXW.EXE

Syntax

REINDEXW /I /T /X

Parameter | Description
/I | Enter the name of the dBase file.
/T | Enter the tag name.
/X | Enter the index definition.
Note DBF files are dBase data files and MDX files are dBase index files.

Tags define sort orders in the index file. Tags contain information about the different ways to sort records in the data file. A tag name is a label for a tag. Reindexing is comparable to packing the file. You recalculate the sort for each tag.

If you do not have the corresponding MDX file, you must provide the tag name information if the file you are reindexing does not have a DFD file.

When reindexing a file, you have to specify all the tags and components of those tags in the correct order. Although shown on different lines for clarity, all the tags for a given file must be specified on the command line. For example...

reindex /T=tag1 /X=field /T=tag1 /X=field1+field2

Type of file | Tag name |
WIP.DBF | /T=DOCTAG /T=KEY2TAG /T=KEYIDTAG /T=USERTAG | /X=KEY1+KEY2+KEYID+RECTYPE /X=KEY2 /X=KEYID /X=CURRUSER
Help DBF files | /T=HELP_KEY | /X=HELP_KEY
Table DBF files | /T=TS_KEY_FIELD | /X=TABLE_NAME,ENTRY_NAME
XDB.DBF files | /T=BYFILE_NAME /T=BYFILE_OFFSET /T=BYNAME /T=BYFIELD_NAME | /X=SrcFile+Parent+SrcName/ /X=SrcFile+Parent+STR(SrcOffset,5,0) /X=SrcName /X=Name
FDB.DBF | /T=BYNAME | /X=NAME
Library Manager DBF files | /T=FILEINDX /T=UNIQUE_ID | /X=FILETYPE+FILESTYP+FILENAME /X=UNIQUE_ID

Here is an example:

REINDEX /I=RCPMSTR /T=POLRCPKEY /X=POLICY+RECIPCD

input | RCPMSTR.DBF
output | RCPMSTR.MDX


RENFORM

Use the RENFORM utility to rename a section (FAP file).

Note You can perform this task using the Change Multiple Sections (FAPs) option in Studio’s Conversion wizard.

Program names

  • Windows: RENFORMW.EXE

Syntax

RENFORMW /I /U /O /INI /D

Parameter | Description
/I | Enter the name of the section you want to rename (FAP file).
/U | Enter your user ID (required.)
/O | Enter the new name for the section (FAP file).
/INI | Enter the name of the INI file to refer to.
/D | Enter whether you want to delete the original section. The default is No.

Use the /P parameter to use path information in the MasterResource control group in an INI file, such as the FSISYS.INI file. The RENFORM utility will look in the directory you specify in the FormLib entry. For instance:

FormLib = D:\FAP\MSTRRES\FORMS

In addition to copying the first FAP file to the second FAP file with a different name, this utility also changes the file name in the header. It also adds a comment line noting who renamed it and when it was renamed. In the comment, the utility notes the FAP file’s original name.


RTF2FAP

Use this utility to convert Rich Text Format (RTF) files into section (FAP) or form (FOR) files. These RTF files can be standard RTF files produced by a word processor or IStream Migration RTF files produced by the IStream Migration Utility.

Note This utility converts RTF files into sections (FAP files) by default. Include the
/F parameter if you want it to convert RTF files into forms (FOR files).

Program names

  • UNIX/Linux: rtf2fap
  • Windows: RTF2FAP.EXE

Syntax

RTF2FAP /I /X /D /F /INI /L /M /N /O /P /S /W

Parameter

Description

/I

Enter the name of the RTF file you want to convert.

If the name of the FAP file includes spaces, enclose it in quotation marks, as shown here:

/I="forms/form name with spaces.fap"

/X

Enter the name of the FXR file you want the utility to use during the conversion.

/D

(Optional) Include this parameter to specify a directory for the output files.

/F

(Optional) Include this parameter and a file name to create a form (FOR) file for use with Documaker Studio. If you omit the file name, the utility appends the FOR extension to the input file name.

If you omit this parameter, the system creates sections instead of forms.

/INI

(Optional) Include this parameter to specify an INI file to load. The default is the FSISYS.INI file.

/L

(Optional) Include this parameter to create LOG files for all bitmaps in the input file.

/M

(Optional) Include this parameter to specify what kind of FAP file the utility will create. You have these options:

/M=1 creates a FAP file with separate sections and separate headers and footers

/M=2 creates a FAP file with separate sections and merges headers and footers onto the page

The default is one (1).

/N

(Optional) Include this parameter if you have multiple Documaker documents that use the same section. This parameter tells the utility to prepend the input file name to the output file to make sure the output file name is unique.

Here ire some examples:

Form01_Section1.FAP

Form03_Section1.FAP

Form05_Section1.FAP

/O

(Optional) Enter the name you want the utility to assign to the FAP file.

/P

(Optional) Include this parameter to parse text for field names. You have these options:

/P=0 - No field parsing

/P=1 - <fieldname>

/P=2 - «fieldname»

/P=3 - <<fieldname>>

/P=4 - {fieldname}

/P=5 - [fieldname]

/P=6 - |-fieldname-|

/P=10 - Parse IStream migration fields

When you include this parameter, the utility treats the text between the field identifiers as fields on the converted form and optional section. If it finds duplicates, it appends a counter to the field name.

The default is zero (0).

Note: Be sure to include /P=10 if you are converting RTF files created by the The IStream Migration Utility.

/S

(Optional) Use this parameter to specify how you want the utility to number pages. For instance,

/S=_

results in:

image.fap, image_2.fap, image_3.fap

If you include the /M parameter but omit the /S parameter or its mask, the utility numbers the pages in this manner:

image.fap, image2.fap, image3.fap

/W

(Windows only)

(Optional) Include this parameter if the input file (/I) is Word document. For instance, enter

/W=1 - if the Word document is s standard Word DOC or DOCX file.

/W=2 - if the Word document was created using the Documaker Add-In for Microsoft Word.

The default is one (1).

When using this utility, keep in mind...

  • You can import polyline or vector drawings.
  • Unicode support includes paragraphs containing mixed single- and multibyte characters.
  • Hyphenation settings are retained.
  • The utility converts bitmaps in the original document into external Documaker graphics (LOG) file references.

Also keep in mind these RTF2FAP Limitations.

Examples

Here are some examples:

To get a | Include these parameters
Form (FOR) file with separate sections | /F /M
Form (FOR) file with separate sections and separate graphics | /F /M /L
Legacy style image (FAP) file | /M=2

You can direct output using these parameters:

To specify a | Include this parameter
Destination directory | /D=.\mydir\
Graphic-only destination directory | /L=.\mydir\
Word file created using the Documaker Add-In for Microsoft Word | /W=2

Here are some additional examples:

If you want | Enter this command
Forms with embedded content | rtf2fap.exe /i=*.rtf /x=my.fxr /d=.\destination\ /L=.\LOGs\ /S=_ /F
Forms with separate sections (headers, footers, and body) | rtf2fap.exe /i=*.rtf /x=my.fxr /d=.\destination\ /L=.\LOGs\ /S=_ /F /M
Legacy-style FAP files | rtf2fap.exe /i=*.rtf /x=my.fxr /d=.\destination\ /L=.\LOGs\ /S=_ /M=2


RTF2FAP Limitations

  • The RTF2FAP has the following limitaitons
    • If a bitmap does not specify a resolution, the utility defaults to 300 DPI. This may result in graphics being sized incorrectly. The utility tries to calculate a resolution based on the output size specified by the RTF file, but this may not work in every instance.
    • The linkstyles control word causes Microsoft Word to alter a document (fonts) according to user-specific styles held in the Normal.dot template. Since the utility cannot interpret the Normal.dot file — as it would vary according to the user — the linkstyles control word cannot be supported. If the imported FAP file has fonts that are significantly different from those in the original RTF file, this may be the cause.
    • The utility does not support z-ordering, the layering of objects one over the other. Documents which rely on z-ordering appear differently when imported.
    • The charscalex and charscaley control words cause individual characters to be scaled horizontally or vertically, respectively. The utility does not support such functionality, so these control words are not supported.
    • Document layout is heavily dependent on choice of fonts. The utility tries to match the fonts in the source document, but substitution can affect the layout. The best way to avoid layout changes is to include all used fonts in your font cross-reference (FXR) file. Be aware of font copyright restrictions when doing so.
    • When you use the RTF import feature to convert rich text pasted into a FAP text area, the system has no information about the margins in the FAP file. This can cause some objects to shift.
    • Documaker applications do not include a table object, so RTF tables are converted to columnar data. If, however, the table is embedded in a column, this results in nested columns (columns within a column), which is not supported.
    • Merged table cells are not supported.
    • On UNIX/Linux, the utility does not retrieve the field length and type when you include /P=10.
    • On UNIX/Linux, the utility does not access the field database.


SEQ2KSDS

Use the SEQ2KSDS utility to convert a non-VSAM NAFILE or POLFILE dataset into a VSAM copy of that dataset.

Program names

  • z/OS: see below

Syntax

SEQ2KSDS

SEQ2KSDS takes no parameters. A 4-byte key is prefixed to each record of the VSAM dataset as it is created.

You can find sample JCL for running the SEQ2KSDS utility in the SEQ2KSDX member of JCLLIB. The SEQ2KSDX member is also shown below.

//USERIDA  JOB   (33005),'SEQ2KSDS      ',CLASS=T,MSGCLASS=X,
//         NOTIFY=USERID
//*
//         SET HLQ='FSI.V100'    <== SET HIGH LEVEL QUALIFIER
//         SET RES='RPEX1'      <== SET RESOURCE (E.G. RPEX1, UTEX1)
//*
//         JCLLIB  ORDER=&HLQ..PROCLIB
//*
//* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
//*        JOB PERFORMS 2 STEPS :
//*
//*        1.  DELETES / RE-DEFINES OUTFILE KSDS.
//*        2.  RUNS SEQ2KSDS PROGRAM TO COPY SEQUENTIAL FILE TO
//*            VSAM KSDS.
//*
//* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
//*
//IDCAMS  EXEC PGM=IDCAMS
//SYSPRINT DD SYSOUT=*
//SYSUDUMP DD SYSOUT=*
//SYSIN    DD  *

  DELETE FSI.V100.RPEX1.GENDATA.NAFILE.KSDS CLUSTER

  DEFINE CLUSTER(NAME(FSI.V100.RPEX1.GENDATA.NAFILE.KSDS) +
           CYL(5 1)     +
           KEY(4 0)     +
           REUSE )      +
         DATA(NAME(FSI.V100.RPEX1.GENDATA.NAFILE.KSDS.DATA) +
           RECORDSIZE(2048 2048) )                      +
         INDEX(NAME(FSI.V100.RPEX1.GENDATA.NAFILE.KSDS.INDEX))

  IF LASTCC = 00 THEN SET MAXCC = 00

//*
//SEQ2KSDS EXEC PGM=SEQ2KSDS
//STEPLIB  DD  DISP=SHR,DSN=&HLQ..LINKLIB
//         DD  DISP=SHR,DSN=SYS1.SCEERUN
//SYSOUT   DD SYSOUT=*
//SYSPRINT DD SYSOUT=*
//INFILE   DD DSN=&HLQ..&RES..GENDATA.NAFILE,DISP=SHR
//OUTFILE  DD DSN=&HLQ..&RES..GENDATA.NAFILE.KSDS,DISP=SHR


TRANSLAT

Use the TRANSLAT utility to create ERRFILE.DAT and LOGFILE.DAT files from the MSGFILE.DAT file. This utility uses the TRANSLAT.INI file as a resource.

Normally, the system creates the ERRFILE.DAT and LOGFILE.DAT files for you during the normal GenTrn, GenData, and GenPrint processing steps. If, however, you have used the ImmediateTranslate option in the Control INI file control group to turn off the automatic conversion of the MSGFILE.DAT file, you must use the TRANSLAT utility to convert the MSGFILE.DAT file into the ERRFILE.DAT and LOGFILE.DAT files.

Note Typically, you would turn off the creation of the ERRFILE.DAT file to maximize performance. You can also use this utility to translate error message into different languages or to substitute your own custom messages.

Program names

  • z/OS: TRANSLAT
  • Windows: TRANSW32.EXE

Syntax

TRANSLAT /INI /MSG /TINI

Parameter | Description
 | Enter the name of the INI file you want the utility to read. The default is FSIUSER.INI.
/MSG | Enter the name of the message file (MSGFILE.DAT) you want the utility to use.
/TINI | Enter the name and path of the INI file you want the utility to use, typically TRANSLAT.INI.

You can omit all of these command line parameters and simply specify the information in your FSIUSER.INI or FSISYS.INI files.

TRANSLAT.INI File

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


TRANSLAT.INI File

The TRANSLAT.INI file is used to customize or localize log and error messages in the system. For instance, if you want the system's error messages to appear in a language other than US English, you can use this INI file to translate the error messages.

All messages must have a unique number. The error message section contains a complete list of numbers already assigned in the system. If the message is only used in the log message section, the number should appear in the error message section, followed by a comment stating that it is only used in the log section. This table shows how the numbers are assigned:

Range | Description
100-499999 | Reserved general messages
10000-10999 | Reserved for RULLIB
11000-11999 | Reserved for GENLIB
12000-12999 | Reserved for RPLIB
13000-13999 | Reserved for RCBLIB
14000-14999 | Reserved for A2WBLIB
15000-15999 | Reserved for the GenTrn program
16000-16999 | Reserved for the GenData program
17000-17999 | Reserved for the GenPrint program
18000-18999 | Reserved for the GenArc program
19000-19999 | Reserved for the GenWip program
20000-20999 | Reserved for CUSLIB (the base system libraries)
500000-999999 | Custom messages
Note Each library has its own section within the ERROR MESSAGE SECTION, complete with a range of valid numbers.

When you add message numbers and text to a library, use the next available message number in the section.

The TRANSLAT.INI file does not contain control groups.


TT2PCL

Use the TT2PCL utility to convert TrueType fonts into PCL bitmap fonts.

Note See also PS2PCL.

Program names

  • Windows: TT2PCL32.EXE

Syntax

TT2PCL32 /I /P /S /D /O /T

Parameter | Description
/I | Enter the name of the TTF file (True Type font).
/P | Enter the font point size, such as 6, 10, and so on.
/D | (Optional) Enter the dots per inch, 240 or 300. The default is 300.
/S | Enter the TT2PCL Symbol Set.
/O | Enter the name of the PCL file to be created.
/T | Enter the typeface family (3=Courier, 4=Helv, 5=Times Roman, and so on).
Note In most cases, you should set the /S parameter to W1. The W1 symbol set matches the characters used by Windows for English and several Western European languages.

This utility loads the FSISYS.INI file and looks for the DefLib option in the FMRES control group. The path you specify in the DefLib option tells the utility where to find the CODEPAGE.INI file (usually..\fap\mstrres\fmres\deflib), however, the utility does not require the CODEPAGE.INI file.

If there is no FMRES control group or no DefLib option, the utility uses the default path (..\mstrres\fmres\deflib).

Documaker uses the Java Runtime Environment (also known as the Java Virtual Machine) to support TrueType and PostScript fonts. In order for Documaker to use the JVM, the system looks for the jvm DLL/DSO (for example, jvm.dll for windows, libjvm.so for Linux and Solaris) and supporting files to be installed in one of the following locations:

  • in your library PATH
  • in "..\jre\bin\client" relative to the current directory
  • in "..\jre\bin\client" relative to any directory in your PATH


TT2PCL Symbol Set

You can choose from the following sets:

  • US - ISO 6: ASCII
  • W1 - Windows Latin/ANSI
  • WE - Windows Latin/Eastern Europe
  • WG - Windows Latin/Greek
  • WL - Windows Latin/Baltic
  • WR - Windows Latin/Cyrillic
  • WT - Windows Latin/Turkish


up2low

Use the up2low utility to convert all file names in a directory to lowercase names.

Program names

  • UNIX/Linux: up2low.exe

This utility will only convert files in the directory in which you run it. If you have additional subdirectories in which there are additional files to convert, go to those subdirectories and run the utility again.

Note The up2low utility is a UNIX script and should always be entered in lowercase. The up2low utility is version independent.


UPDWDT

Use this utility to get the iDocumaker installation file from the IDS and then update iDocumaker.

Note The UPDWDT utility is typically executed by iDocumaker when needed. Information about running this utility is only included in case you are having problems with the iDocumaker and need to update your system.

Syntax

updwdt /b /i /r

Parameter | Description
/b | This tells the utility to copy the reboot/backup directory contents to the installation directory. This option is used when there are files to update during the reboot process.
/i | This tells the utility to install from a file specified by the next parameter. This is used if the installation file is already present on the local machine.
/r | The registry location where iDocumaker has been installed. The defaults is: HKEY_CLASSES_ROOT\\wipedit.Document\\protocol\\StdFileEditing\\server

Documaker Bridge rules get the version information and CRC from the iDocumaker executables. You should have a separate location for each CONFIG value for these executables.


VB2AFP

Use this utility to convert files written in variable block record format.

For instance, Documerge creates print streams and printer resource files which have variable block record format. You can use this utility to remove that formatting and create a file which you can use as an AFP print stream.

AFP or Metacode printer resource files (AFP page segments, AFP overlays, Metacode FRMs, and so on) may also be in variable block format. Other utilities expects these files to be in their native format as does the printer. You can use this utility to remove the variable block formatting from either AFP or Metacode printer resource files.

Program names

  • Windows: VB2AFP.EXE

Syntax

VB2AFP /I /O

Parameter | Description
/I | Enter the name of the input file (in variable block format).
/O | Enter the name of the output file — without variable block format.
Note To convert variable block files into BARR format, see VB2BARR.


VB2BARR

Use this utility to convert files written in variable block record format.

For instance, Documerge creates print streams and printer resource files which have variable block record format. You can use this utility to remove that formatting and create a file which you can use as a Metacode print stream with BARR record formatting.

Program names

  • Windows: VB2BARR.EXE

Syntax

VB2BARR /I /O /W

Parameter | Description
/I | Enter the name of the input file (in variable block format).
/O | Enter the name of the output file—in BARR record format.
/W | Include this parameter to tell the utility to write the output file in BARRWORD record format.
Note To convert variable block files into AFP format, see VB2AFP.


VB2EPS

Use this utility to convert Metacode files in variable block (VB) format into EPS (Enterprise Printing System) format so you can then print the files on a Xerox EPS printer via a TCP/IP connection.

Note Documerge (VB) format is not a print-ready format. Documerge format Metacode is usually used as an input into Documerge/Docuflex. If you want to print a Documerge format Metacode file, you must convert it into another format.

Program names

  • Windows: VB2EPS

Syntax

VB2EPS /I /O

Parameter | Description
/I | Enter the input Metacode file name. This file will be in variable block format.
/O | Enter the name you want the utility to assign to the output Metacode file. This file will be in EPS format.

Determining the format

If you are unsure of the format of a print stream, use Studio’s Printstream Analyzer to determine the format. First, open the print stream in the Printstream Analyzer, then click the Properties button to see an analysis of the print stream. Included in the analysis is format information. Here are some examples:

This... | Indicates the print stream is...
Variable 2-byte BE | An EPS format file
BARR Format (1) | A BARR format file
Variable Blocked | A Documerge variable block format file


VERS2REG

Use this utility gets the local version information and updates the registry. This utility executes on the workstation side from a command prompt.

Typically, it is only executed during the original installation of iDocumaker. You can, however, start it from a command prompt. You can use the /v and /i parameters to determine which files and patch levels are in the current installation.

Syntax

vers2reg /v /i /p /r

Parameter | Description
/v | This parameter writes to stdout the values it will put in the registry.
/i | This parameter tells the utility to simply display the patch and CRC information and not change the registry.
/p | Use this parameter to set the path to the iDocumaker executables instead of using the registry to find the installed location
/r | This parameter indicates the registry key where the utility can find iDocumaker executables.
Note CRC (Cyclic Redundancy Check) is a way to check for data transmission errors.


VERSUPD

Use this utility to create the installation file and the version file.

  • A version file which contains XML entries for version number, patch level, and accumulated CRC for files without patches.
  • An installation file which has all of the executables for iDocumaker compressed into one file. The executable is installed on client machines via the UPDWDT utility.
Note The UPDWDT utility is typically executed by iDocumaker when needed. You do not have to run it.

Both the version file and the installation file need to be created where the IDS rules expect them to be. By default, the VERSUPD utility creates them in same location IDS expects to find them.

Program names

  • Windows: versupd.exe
  • UNIX: versupd

Syntax

versupd /config /ini /versionfile /installation /base /debug

Parameter | Description
/config | Enter the name of the configuration, such as SAMPCO.
/ini | (Optional) Enter the path to the configuration INI file used by IDS. Specifying an INI file helps you make sure IDS and the VERSUPD utility look for shared files in the same location.
/versionfile | (Optional) Enter the path to the version file. This overrides the entry in the INI file.
/installation | (Optional) Enter the path to the installation file. This overrides the entry in the INI file.
/base | (Optional) Enter the path to the executables for iDocumaker Workstation. By default, this utility looks for executables in the data\config\wipedit directory under the current directory. This overrides the entry in the INI file
/debug | (Optional) Include this option to send a list of each file included in the installation to stdout.

Here is an example:

versupd /config=SAMPCO

This command puts both files in the following path:

c:\docserv\Data\SAMPCO

Here is another example:

versupd /config=SAMPCO /versionfile=c:\docserv\VersionControl
/installation=c:\docserv\WIPEditInstallation

This command creates these files:

File type | Name and path
Version | c:\docserv\VersionControl
Installation | c:\docserv\WIPEditInstallation

INI options

These INI options from the CONFIG.INI files are read by the VERSUPD utility:

< WIPEdit >

ExecDir =

VersionFile =

Option | Description
ExecDir | Enter the location for iDocumaker Workstation’s executables.
VersionFile | Enter the location of the file that contains the version information.

VERSUPD Error Messages

© Copyright 2011, Oracle and/or its affiliates. All rights reserved. Legal notices.


VERSUPD Error Messages

The following error messages may be generated by the VERSUPD utility. These errors will go both to stdout and to a file named trace that will be in the current directory of the VERSUPD utility.

Could not create installation file (version file path)

Could not find files to build installation in directory (iDocuMaker Workstation directory)

Not able to add file (executable name) to installation (installation file name)

Could not access directory where the iDocuMaker Workstation executables are suppose to be.

Could not access directory where custom wipedit executables are suppose to be (custom executable directory)

Unable to create version file (installation file)

Unable to retrieve version information from directory (iDocumaker Workstation directory)

Unable to create document (version file)

Could not lock version file (version file name).


VRF2EXP

Use this utility to convert a Documerge Variable Replacement File (VRF) into various types of output files, including:

  • A Documaker Workstation-style import file
  • An extract file
  • An INI file

This is useful, for instance, when you are migrating from Documerge to Documaker.

Program names

  • Windows: VRF2EXPW.EXE
  • z/OS: VRF2EXP

Syntax

VRF2EXP /I /O /F /KEY1 /KEY2 /INI /D

Parameter | Description
/I | Enter the name of the file you want to convert. If you omit the extension, the system defaults to VRF though the input file can have any extension. If the input file does not have an extension, add a period to the end of the file name.
/O | (Optional) Enter a file name for the output Documaker file. If you omit this parameter, the input name will be used with the extension of DAP. Since a Documaker Workstation-style import file typically has an extension of DAT, you may want to use this parameter and be sure to specify the extension.
/F | (Optional) Choose from these types of output formats: 0 - Documaker Workstation-style import file 1 - a flat extract file 2 - INI file Examples of these formats are at the end of this topic. The default is zero (0) for a Documaker Workstation-style import file.
KEY1 | (Optional) Enter the value you want to assign as the Key1 value. The utility writes this value to column 10 of the M record in the extract file it generates.
KEY2 | (Optional) Enter the value you want to assign as the Key2 value. The utility writes this value to column 51 of the M record in the extract file it generates.
/INI | (Optional) If you chose to create a Documaker Workstation-style import file, the utility looks for an INI file. By default, the utility looks for a file named VRF2EXP.INI in the current directory. If not found, the program will try to continue on without it.
/D | (Optional) Include this parameter to run the utility in Using Debug Mode.


Using the INI Parameter

Here’s an example of how you can use the /INI parameter with the VRF2EXP utility:

VRF2EXP /I=MAPPER

This example will input a file called MAPPER.VRF, assume a Documaker Workstation-style import format, load the VRF2EXP.INI file, and then output an import file named MAPPER.DAP.

Keep in mind...

  • The VRF2EXP utility sets the scope of the field data to Global. Therefore, to import the field data during Entry, the FAP file's variable field must also have a scope of Global.
  • If the utility encounters a DMG.FLST.recipient record, each form listed in that record is written to the extract file as an F record, with the form name written to column 10 and the recipient name written to column 51.
  • VRF tag records that begin with DMG.OPT or DMG.SRC are not processed.


Using Debug Mode

If the VRF2EXP utility does not appear to be working correctly, you may have a problem with your INI file. You can find out by running in debug mode to see what the utility thinks the INI options are.

Here is an example of the output without debug mode:

--- Docucorp VRF2EXP Utility Program (C) ---

--- Convert Docucorp VRF to DAP Format ---

Using standard import format for DAP output.

Reading VRF File - MAPPER.VRF

Creating DAP File - MAPPER.DAP

Using INI File - VRF2EXP.INI

Merge sets found=1

Here is an example of the output when running in debug mode:

--- Docucorp VRF2EXP Utility Program (C) ---
---  Convert Docucorp VRF to DAP Format  ---
Run in debug mode
Using standard import format for DAP output.
Reading VRF File - MAPPER.VRF
Creating DAP File - MAPPER.DAP
<VRF2ImportHeaderTags> DESCRIPTION =
<VRF2ImportHeaderTags> KEY1 = "PMI"
<VRF2ImportHeaderTags> KEY2 = "LB1"
<VRF2ImportHeaderTags> KEYID = INSURED.NAME
<VRF2ImportHeaderTags> STATUSCODE = "W"
<VRF2ImportHeaderTags> TRANSCODE = "NB"
Using INI File - VRF2EXP.INI
VRF2EXP context:
<VRF2ImportHeaderTags> DESCRIPTION =
<VRF2ImportHeaderTags> KEY1 = "PMI"
<VRF2ImportHeaderTags> KEY2 = "LB1"
<VRF2ImportHeaderTags> KEYID = INSURED.NAME
<VRF2ImportHeaderTags> STATUSCODE = "W"
<VRF2ImportHeaderTags> TRANSCODE = "NB"
End of VRF2EXP context
Using these INI options:
    KEY1 = "PMI"
    KEY2 = "LB1"
    KEYID = INSURED.NAME
    TRANSCODE = "NB"
    STATUSCODE = "W"
    DESCRIPTION = DESCRIPTION
Merge sets found=1


Setting Up VRF2EXP.INI

The VRF2EXP.INI file supplies key fields needed by a Documaker Workstation-style import header file. There are several ways to provide these values:

  • Default in a constant value. Do this by supplying a constant value enclosed in quotation marks.
  • Variable data from tags. Enable this by supplying the VRF tag-name (not in quotation marks).

Here is an example:

< VRF2ImportHeaderTags >
    KEY1 = "PMI"
    KEY2 = "LB1"
    KEYID = INSURED.NAME
    TRANSCODE = "NB"
    STATUSCODE = "W"
    DESCRIPTION =

For help reading the FAP file that is produced, add these INI options to have a header and footer that separates each transaction. Here is an example:

< VRF2ImportTransaction >
  Header = ************Begin Transaction************
  Footer = *************End Transaction*************

These settings produce the following output:

************Begin Transaction************

;PMI;LB1;;NB;W

$TAG\GO$OD

DMG.MERGESET.ID\124

DMG.SRC.JBGRP1\

DMG.SRC.JBGRP2\

\NA=\PMI;LB1;DOL.MET;

*************End Transaction*************

To see the print options for a VRF file, use this INI option:

< VRF2ImportData >

ShowPrintOptions = Yes

The default is to not print them out.


Format 0 - Documaker Workstation-style import file

Here is an example of the format used for a Documaker Workstation-style import file:

;PMI;LB1;021999BMW;NB;W

1A\your second

1B\OUTPATIENT PROTECTION

1C\applying for

1D\ALL NEW

1G\On behalf of Physicians Mutual and AAA Chicago Motor Club. Welcome!

1H\Insurance

2B\Your insurance policy, which has been in force since September 12, 1999 is enclosed.

2E\Insurance

3A\you and your family

3B\$250.00

3D\$1,000.00

3E\$5,000.00

5\$500.00

6A\you or a covered family member's

6B\you or a covered family member are

7\have

AAA\AAA Chicago Motor Club.

AMOUNT\500.50

CC301\print

INSURED.NAME\021999BMW

ISSUE\SHORT

ISSUEDATE\September 12, 1999

MONEY\REGULAR

PLAN\FAMILY

POLICY.TYPE\LIFE

SPO\2

STATE\TX

\NA=\PMI;LB1;N150-72A;

\NA=N150HDR\<INSURED>

\NA=N150-72A\<INSURED>

\NA=N150-72B\<INSURED>

\NA=\PMI;LB1;Coverage Outline;

\NA=PTYPE\<INSURED>

\NA=PPOLNO\<INSURED>

\NA=PCONF\<INSURED>

\NA=PTYPE\<INSURED>

\NA=PTYPE\<INSURED>

\NA=PACC\<INSURED>

\NA=PEXC\<INSURED>

\NA=PPREM\<INSURED>

\NA=PNUM\<INSURED>

\NA=PFORM\<INSURED>

\NA=PLAST\<INSURED>


Format 1 - Extract file

The format of a flat extract file is shown here:

Pos 1 to 6 Numeric relative merge set within the VRF file

Pos 7 Blank

Pos 8 Record-type flag

M = Begins a merge set

T = A merge tag/data record

E = Ends a merge set

Pos 9 Blank

Pos 10 to 49 Merge tag name

Pos 50 Blank

Pos 51 to 56 Numeric length of data

Pos 57 Blank

Pos 58 Data (any length)

<EOR - CR/LF>

You can use the /F=1 option, as shown here, to generate an extract file:

VRF2EXP /I=MYFILE.VRF /F=1 /KEY1=MYGROUP1 /KEY2=MYGROUP2

For each merge set found in the VRF file, the utility generates and writes a block of records to the extract file. Merge tags are written as T records. Merge forms are written as F records. The generated extract file would look similar to this example:

000001 M MYGROUP1 MYGROUP2

000001 T BILL.STUB 000031 --- STATEMENT OF ACCOUNT ---

000001 T DOCUMERGE.ID.TAG 000012 FO 123456789

000001 T DMG.MERGESET.ID 000012 FO 123456789

000001 T PIF.SYMBOL 00002 FO

000001 T PIF.POLICY.NUMBER 000007 1234567

000001 F TOP INSURED

000001 F BILL INSURED

000001 F BILL.STUB220 INSURED

000001 E


VRF2EXP Format 2 INI File

Use this format to see the internal organization used to create a Documaker Workstation-style import file. This can be useful for debugging purposes. Here is an example:

< DMG.FLST >
    Form         = N150-72A\N150HDR
    Form         = N150-72A\N150-72A
    Form         = N150-72A\N150-72B
    Form         = Coverage Outline\PTYPE
    Form         = Coverage Outline\PPOLNO
    Form         = Coverage Outline\PCONF
    Form         = Coverage Outline\PTYPE
    Form         = Coverage Outline\PTYPE
    Form         = Coverage Outline\PACC
    Form         = Coverage Outline\PEXC
    Form         = Coverage Outline\PPREM
    Form         = Coverage Outline\PNUM
    Form         = Coverage Outline\PFORM
    Form         = Coverage Outline\PLAST
< Form:Coverage Outline\PACC >
    RECIP        = INSURED
< Form:Coverage Outline\PCONF >
    RECIP        = INSURED
< Form:Coverage Outline\PEXC >
    RECIP        = INSURED
< Form:Coverage Outline\PFORM >
    RECIP        = INSURED
< Form:Coverage Outline\PLAST >
    RECIP        = INSURED
< Form:Coverage Outline\PNUM >
    RECIP        = INSURED
< Form:Coverage Outline\PPOLNO >
    RECIP        = INSURED
< Form:Coverage Outline\PPREM >
    RECIP        = INSURED
< Form:Coverage Outline\PTYPE >
    RECIP        = INSURED
< Form:N150-72A\N150-72A >
    RECIP        = INSURED
< Form:N150-72A\N150-72B >
    RECIP        = INSURED
< Form:N150-72A\N150HDR >
    RECIP        = INSURED
< VRF:1 >
    1A           = your second
    1B           = OUTPATIENT PROTECTION
    1C           = applying for
    1D           = ALL NEW
    1G           = On behalf of Physicians Mutual and AAA Chicago Motor Club.  Welcome!
    1H           = Insurance
    2B           = Your insurance policy, which has been in force since September 12,
    2E           = Insurance
    3A           = you and your family
    3B           = $250.00
    3D           = $1,000.00
    3E           = $5,000.00
    5            = $500.00
    6A           = you or a covered family member's
    6B           = you or a covered family member are
    7            = have
    AAA          = AAA Chicago Motor Club.
    AMOUNT       = 500.50
    CC301        = print


WIP2WIP

Use this utility to convert WIP data and a WIP index stored in a database or xBase into any supported database format. By storing WIP data in a database, you can enhance performance when you are using multiple keys to access transactions in intra- and internet applications.

Program names

  • Windows: WIP2WIPW.EXE

Syntax

wip2wipw /I

Parameter | Description
/I | Use this parameter to specify the name of a conversion INI file the utility should use during the conversion. The conversion INI file defines the source and target WIP configurations.

The conversion INI file must include a source WIP control group (SourceWIP) and a target WIP control group (TargetWIP). These control groups define the source and target WIP configurations.

The ConvertIndex option in the WIP2WIP control group tells the utility if the index should be converted. The default is No. If you enter Yes to tell the utility to convert the index, keep in mind that you must specify different file names in the File option for the SourceWIP and TargetWIP control groups.

Here is an example of the INI options you would need to convert flat file WIP data with an xBase index into SQL data with an SQL index.

< WIP2WIP >
  ConvertIndex		= Yes
< SourceWIP >
  File 			= Wip
  Path 			= /…/…/Wip
< TargetWIP >
  WIPData 		= WipData
  File 			= SQLWip
  DatabaseWIP 		= True
  Path 			= /…/…/Wip
  WIPDFDFile 		= wip2.dfd
< DBTable:SQLWIP >
  DefaultTag		= KeyID
  DBHandler		= SQLWIP
< DBTable:WipData >
  DBHandler		= SQLWIP
< DBHandler:SQLWIP >
  CreateTable		= Yes
  CreateIndex		= No
  Server		= WIP
  UserID		= wip
  Passwd		= wip
  Class			= ODBC
  Debug			= Yes
< ODBC_FieldConvert >
  Desc			= DESCRIPTION

Here is an example of the INI options you would need to convert SQL data with an SQL index into flat file WIP data:

< WIP2WIP >
  ConvertIndex	= Yes
< TargetWIP >
  File		= WIP
  Path		= \...\...\...\Wip
< SourceWIP >
  File		= wip
  Path		= \...\...\wip\
  WIPDFDFile	= \...\...\wip.dfd
  MaxWIPRecords	= 20
  CompressWIP	= True
  DatabaseWIP	= True
  WIPDataDFD	= \...\...\wipdata.dfd
  WIPData		= WipData
< DBHandler:ODBC >
  CommitEvery	= 0
  Connect	= Yes
  CreateIndex	= No
  CreateTable	= Yes
  Server	= DBNAME
  Debug		= Yes
  Passwd	=
  UserID	= sa
< DBTable:WIP >
  DBHandler	= ODBC
  UniqueTag	= DocTag
< DBTable:WIPData >
  DBHandler	= ODBC
  UniqueTag	= FORMSETID
<ODBC_FileConvert>
  WIP		= METLWIP
<ODBC_FieldConvert >
  Descr		= DESCRIPTION


WIPUPDATE

Use this utility to copy from an existing WIP database index into a new index while using the latest WIP layout.

Version 11.2 introduced a WIP layout that includes additional columns like JURISDICTN, LOCID, SUBLOCID, TRNNAME, and some others. Some of these columns are used in features introduced after version 11.2, like the stamps and signature support.

While Documaker still supports older WIP layouts, this utility lets you upgrade your WIP indexing to take advantage of newer features, without completing pending transactions.

Program names

  • Windows: WIPUPDATE.EXE

Syntax

WIPUPDATE

There are no parameters for this utility.

Follow these steps to use this utility:

  1. Make sure no one is actively using the WIP database.
  2. Create a backup directory of all the WIP files. This includes the WIP index as well as the associated DAT and POL files that contain the actual WIP transactions.
  3. After you create the backup, delete the WIP.DBF and MDX files in the standard WIP directory, but leave the other files.
Note The name of your WIP.DBF file may differ if you had a different name specified in the INI file.
  4. Run the WIPUPDATE utility from the same location you run AFEMNW32.EXE. This will be the directory where the FSIUSER.INI file is located.
  5. A window appears to ask the location of the WIP database you want to convert. Browse to the location where you made the backup of your original WIP database (and other files). Click Ok.

The update process begins and the original WIP database index is copied into a new layout for use by your workstation application. Status messages tell you how many records were found and converted.

  6. When the update process finishes, run AFEMNW32.EXE (or your normal WIP application) and make sure you can successfully query and load WIP transactions.

Keep in mind...

  • The utility does not delete your existing WIP index and will report an error if you fail to remove it before running the utility. Be sure to make a backup of the original. This will serve as a fall-back in the event of failure, but more importantly is necessary for importing into the new database the utility will create.
  • If you try to run with an old WIP database at the destination, you will see the following message.

The destination WIP database was not created with the latest definition.

You should do one of the following

  • Move the original WIP.DBF and MDX to a new (backup) location and allow a new database to be created here; or
  • Change the File option in the WIPData control group to use a new file name.
  • The utility queries the destination for the key components of the source record. It does this to avoid overwriting existing WIP records. The key includes the column components for key1, Key2, KeyID, and RecType. If a match is found, a secondary check determines if the record specifies the same FormSetID. If it does, that record is not copied into the destination index because the utility assumes it is a duplicate.
  • When the utility finishes, you are shown how many records were found in the source and how many were copied into the destination. A discrepancy between those two numbers indicates duplications were found and skipped.


XERDNLD

Use the XERDNLD utility to convert Xerox Metacode printer resources, such as FNT files, IMG files, or FRM files, into downloadable files.

Program names

  • Windows: XERDNLDW.EXE
  • z/OS: See the Documaker Installation Guide.

Syntax

XERDNLDW /I /O /P

Parameter | Description
/I | Enter the file name. Include the extension, such as FRM, FNT, or IMG.
/O | (Optional) Enter the name of the output DAT file.
/P | Enter the INI file PrtType to use, such as XER.

You can also use wildcards to select multiple files or specify a single file. For instance, on Windows machines, adding this parameter

/i=*.FNT

selects all files in current directory with extension FNT. Include a file extension when using wildcards, otherwise the XERDNLD utility will try to process all of the files in the directory.

Note You must have the FSISYS.INI file to run the XERDNLD utility.

This utility lets you send resources to a Xerox printer if you do not have other software programs to accomplish this task. The utility accepts as input a Xerox Metacode resource, such as a font, image, or FRM file, encapsulates it with location-specific DJDE information and writes the resource back out as a .DAT file. You can then send the .DAT file to the Xerox printer as if it were a print stream. The DJDE information at the beginning of the .DAT file will cause the Xerox printer to store the resource on the printer’s local disk device.

Xerox 4235 printers

When you use the XERDNLD utility to download Xerox resources to a 4235 printer, you must set the printer to use a JDL called 9EBC, and a JDE called LAND. You can set the JDL and JDE from the Document Formatting menu under the XPPM option. In addition, you must set the EBCDIC Parallel Meta / GHO Enabler - IB option to disabled, via the User Services/Printer Options menu.

After you set these options, set the 4235 in Print Mode and send your .DAT files. After you finish sending the .DAT files, remember to reset your JDL, JDE, and EBCDIC Parallel Meta / GHO Enabler - IB options to resume normal print settings.


XFNT2PCL

Use the XFNT2PCL utility to convert a Xerox Metacode font into a PCL bitmap font.

Note You can also perform this task using the Studio’s Font manager.

Program names

  • Windows: XFNT2PCW.EXE

Syntax

XFNT2PCW /I

Parameter | Description
/I | Enter the name of the FNT file.

The utility creates a converted PCL font file. The output file will have the extension PCL.

The XFNT2PCL utility is the reverse of the PCL2XFNT utility. The XFNT2PCL utility creates a PCL font file from a Xerox FNT font file.


Using the Help

Using the Help involves:

  • Viewing (opening) the help
  • Searching the help
  • Adding a help topic to a Favorites list


Viewing the Help

The online help contains the following tabs in the lower left corner:

  • Contents – click this tab to display the Table of Contents of the help
  • Index – click this tab to display the index; from there, you can click any index term to display its topic
  • Search – click this tab to search the help: see Searching the Help
  • Favorites – click this tab to display any topics or search strings that you have saved as a “Favorite”; Favorites are similar to web bookmarks: see Adding a Help Topic to Favorites


Searching the Help

You can search the online help for topics containing specific words.

To search the online help

  1. Click the Search tab.
  2. Enter the word(s) to search on. If you enter more than one word, topics containing either word will be displayed in the search results.
  3. Click the List Topics button.

The search results are displayed. They are ranked in order based on the number of times the search word appears in the topic.

  4. To sort the search results by rank or title, click on the Rank or Title column heading respectively.
  5. Double-click a topic to display it.

The topic is displayed with all the occurrences of the search term highlighted.


Adding a Help Topic to Favorites

You can add a help topic to a collection of Favorites to quickly refer to it later.

To add a help topic to Favorites

  1. With a help topic open, click the Favorites tab.
  2. Click Add.

The topic is added to the list of Favorites.

  3. To view your current Favorites, click the Favorites tab.

Any favorite topics are displayed.

To display a favorite topic, double-click it.

To delete a Favorite, single-click the item in the Favorites tab, then click the Remove button at the bottom of the pane.


Related Documents

You can view the documentation for all Oracle Insurance applications on the Oracle Technology Network.

Finding Topics on OTN

You can use your favorite search engine to find topics in the Documaker documentation set on OTN.

For example, to find information on the Documaker Add-In for Microsoft Word, you could enter:

Oracle Documaker + Documaker Add-In

For information about Documaker’s MET2FAP utility, you could enter:

Oracle Documaker + MET2FAP

Review your search engine’s documentation for advanced searching tips and techniques.


Oracle Insurance

View the Oracle Insurance site for complete information on all Oracle Insurance products and solutions


Oracle Support

If you have any questions about the installation or use of our products, please visit the My Oracle Support website or call 800. 223.1711.


Send Feedback

You are here: Send Feedback

Send Feedback About This Guide

Your feedback helps us improve this guide. Please click the link below to email your feedback.

Send feedback about this guide

Please note:

  • If you are commenting about a specific topic, please include its title in your message.
  • We will review your feedback but you may not receive a direct response.
  • If your feedback is not documentation-related, or you have any questions about the installation or use of our products, please visit the My Oracle Support web site.


Document Conventions

The following text conventions are used in this document:

Convention | Description
bold | Indicates information you enter.
italic | Indicates book titles, emphasis, or placeholder variables for which you supply particular values.
monospace | Indicates commands, URLs, code in examples, and text that appears on the screen.


Documentation Accessibility

This documentation may contain links to Web sites of other companies or organizations that Oracle does not own or control. Oracle neither evaluates nor makes any representations regarding the accessibility of these Web sites.

TTY Access to Oracle Support Services

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the United States of America 24 hours a day, seven days a week. For TTY support, call 800.446.2398.


Legal Notices

Copyright © 2011, Oracle and/or its affiliates. All rights reserved.

License Restrictions Warranty/Consequential Damages Disclaimer

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

Warranty Disclaimer

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

Restricted Rights Notice

If this software or related documentation is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS

Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

Hazardous Applications Notice

This software is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications which may create a risk of personal injury. If you use this software in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure the safe use of this software. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software in dangerous applications.

Trademark Notice

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.

Third Party Content, Products, and Services Disclaimer

This software and documentation may provide access to or information on content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.