ヘッダーをスキップ
Oracle Real User Experience Insightユーザーズ・ガイド
リリース6.5.1 for Linux x86-64
B61012-01
  目次
目次
索引
索引

戻る
戻る
 
次へ
次へ
 

3 データ・ブラウザの使用

この章では、データ・ブラウザの使用方法について説明します。データ・ブラウザはRUEIの中心となる機能であり、監視中に収集された情報への直接アクセスを提供します。データ・ブラウザでは、直感的でユーザーフレンドリな方法を使用して、情報のドリルダウン、検索およびフィルタを実行できます。

3.1 データ・ブラウザの概要

各レポートに示される情報は、監視中に取得したすべての情報を含む多次元データ構造から導出されます。この構造を使用することで、より詳細なレベルを次々にクリックするだけでWebデータを探索でき、様々なディメンション(期間、リファラ、ビジター・タイプなど)別にWebデータを表示できます。このデータ構造は、「Browse data」タブで表示できます。

データ・ブラウザを使用すると、レポートに示されるデータのコンテキストを理解できるとともに、情報をドリルダウン、ランク付け、ソートおよびフィルタすることで原因、結果および傾向を把握することができます。レポート内からデータ・ブラウザを開くには、レポート・メニューから「Browse」オプションを選択します。データ・ブラウザを他の場所から開くには、「Browse data」タブをクリックします。図3-1に示すようなウィンドウが表示されます。

図3-1 データ・ブラウザ

図3-1の説明が続きます
「図3-1 データ・ブラウザ」の説明

3.1.1 データ・ブラウザのツールバー

データ・ブラウザ画面の上部には、図3-2に示すツールバー・アイコンが表示されます。表3-1は、これらのアイコンについて説明しています。

図3-2 データ・ブラウザのツールバー

図3-2の説明が続きます
「図3-2 データ・ブラウザのツールバー」の説明

表3-1 データ・ブラウザのアイコン

アイコン 説明
棒グラフ

グラフ。

データの標準グラフ(円グラフ、線グラフまたは棒グラフ)を表示します。グラフの種類は、基になるデータによって異なります。

水平棒グラフ 円グラフのアイコン

追加のグラフの種類。

標準的なグラフに加えて、基となるデータによって、追加のグラフの種類を使用できる場合があります。その場合、目的のグラフの種類を選択するには、該当するアイコンをクリックします。

また、「Graph」メニューの「Type」オプションを使用して、グラフの種類を選択することもできます。

表のアイコン

値。

ブラウザのデータの基となるデータ値を表示します。値リストの使用方法の詳細は、3.3項「値リストの使用」を参照してください。

左向きおよび右向きの緑色の矢印

前のページおよび次のページ。

これらのコントロールを使用して、表示されたデータセットのページ間を移動します。

青い情報アイコン

用語集。

データ・ブラウザ内に現在示されているメトリックの簡単な説明を表示します。この説明には、グラフまたは値テーブルに示されているディメンションおよび適用されているフィルタの両方が記載されます。フィルタの使用方法は、3.7項「フィルタの使用」に記載されています。

虫メガネのアイコン

検索。

現在表示されているデータセット内の文字列を検索できます。検索機能の使用方法の詳細は、3.4項「データ・ブラウザでの検索」に記載されています。

虫メガネのアイコン(正符号) 虫メガネのアイコン(負符号)

ズーム・インおよびズーム・アウト。

表示される詳細のレベルを変更できます。ズーム・インおよびズーム・アウトの操作時には、表示されるデータのディメンションを変更します。新しいディメンションは、現在選択されているディメンションによって決まります。たとえば、年次データを表示している場合は、ズーム・イン操作により、月次データの表示に変更されます。クライアントの場所を国別に表示している場合は、ズーム・イン操作により、表示されるディメンションがクライアントの場所が属する国の中のプロバイダに変更されます。

元のディメンションにすばやく戻すには、「View」メニューから「Reset view」を選択します。

レポートのアイコン

レポートとしてオープン。

現在表示されているデータをレポート印刷レイアウト・モードの新しいウィンドウで開きます。レポートの作成とカスタマイズの詳細は、第2章「レポートの操作」に記載されています。

スプレッドシートのアイコン

エクスポートとしてオープン。

現在表示されているデータを、各種アプリケーション(Microsoft Excelなど)にエクスポートするにあたってカスタマイズできる新しいウィンドウを開きます。この機能の詳細は、3.8項「データのエクスポート」に記載されています。

ダッシュボード項目のアイコン

ダッシュボードに追加。

選択されているダッシュボードに現在のビューを追加します。この機能の詳細は、1.7.4項「ダッシュボードへのデータ・ブラウザまたはKPIビューの追加」に記載されています。

戻ると進むの青色矢印アイコン

戻る/進む。

データ・ブラウザ内での直前のアクションを元に戻す、または繰り返します。


3.2 データ構造の概要

データ・ブラウザ内に表示される情報は、グループ別に分けられます。最上位レベルには、アプリケーション関連グループとサービス関連グループの2つのグループ・タイプがあります。各グループでは、収集されたデータを様々な視点、つまりビューで表示できるようになっています。これらのビューは、データ・ブラウザ・ウィンドウ(図3-1)の左側にある「View selection」パネルから選択できます。

「View selection」パネル内のメイン・グループの1つ1つは、様々な情報カテゴリに関連しています。監視対象のWeb環境でアクセスされたページ、ビジター・セッション、ユーザー・フロー、失敗したURLとページ、およびキー・ページに関するグループがあります。

これらの各グループ内のサブグループには、選択したカテゴリの特定項目に関する情報が表示されます。具体的には、情報が特定のディメンションで表示されます。これらのディメンションは、サブグループの名前に示されます。たとえば、「All sessions」グループには、ドメイン、期間、ユーザーID、クライアント・ブラウザ、言語、場所およびオペレーティング・システムをそれぞれディメンションとしたビューが用意されています。図3-3にこれを示します。

図3-3 データ構造の選択パネル

図3-3の説明が続きます
「図3-3 データ構造の選択パネル」の説明

個々のビューは、表示される情報のタイプを示す標準的な分類(失敗、パフォーマンス、全体およびサイズ)でグループ化されています。これらの中で、基となるデータを調べるために使用するアクティブ・ディメンションを選択できます。

この項で説明されている標準的なディメンションに加えて、カスタム・ディメンションを使用して、データ・ブラウザ内に表示できる情報を拡張することもできます。この詳細は、3.9項「カスタム・ディメンションの使用」に記載されています。

セッション診断機能の詳細は、3.10項「診断機能の使用」に記載されています。

3.2.1 リアルタイム・データとセッションベースのデータ

RUEIで対応できる情報には2種類あります。5分間隔で検出されるすべてのアクティブなセッションから導出される情報と、完了した(クローズ)セッションから導出される情報です。それぞれの詳細は次の各項で説明します。

アクティブ・セッションから導出される情報

RUEIでレポートされるほぼすべての情報は、5分間隔で検出されるオープン(アクティブ)セッションに基づきます。1つの例外は、「All sessions」グループでの複数日のレポートです。この詳細は次の項に記載されています。

5分ごとにセッションについてレポートされるプロパティ(IPアドレスやユーザーIDなど)は、実質的には5分間の最後に取得されたスナップショットであることに注意してください。これらのプロパティの値はその5分間内では変動していた可能性がありますが、その期間の最後の値がレポートされます。

クローズ・セッションから導出される情報

「All sessions」グループで複数日についてレポートされる情報は、完了した(クローズ)セッションから導出されます。結果として、この情報には遅延が伴います。遅延が発生するのは、定義されているセッション・アイドル時間が原因です。セッション・アイドル時間は、ビジターのセッションが非アクティブになってから終了したとみなされるまでの期間を指定します。デフォルトでは60分です。

情報がこのようにして導出されるため、5分間隔のレベルにドリルダウンすることはできません。また、ビジター・セッションが午前9時に開始して午後5時に終了する場合について考えてみてください。セッションは、昼食休憩の午後12時〜午後1時を除いてずっとアクティブです。通常、このセッションは1つのセッションとしてレポートされます。ただし、「All sessions」グループでの複数日の期間では、2つのセッションとして報告されます。非アクティブな期間があるためです。

レポートされるデータに相違が生じることがある理由

1日についてレポートされるデータと複数日についてレポートされるデータには、わずかな差異が生じる可能性があります。たとえば、ある1日について「All sessions」ビューでレポートされるセッション数は、「All sessions」ビューの2日間に対する表示において、同じ1日についてレポートされる数と若干異なる場合があります。このような差異が生じる理由を理解するためには、1日のデータと複数日のデータが処理される方法を知る必要があります。

図3-4に示す状況について検討します。2名のビジターAとBが両方とも、12:05に閲覧を開始します。Aのセッションは12:45に終了し、Bのセッションは13:55に終了します。ビジターAが14:05に再開し、14:55に終了します。

図3-4 セッションのレポート

図3-4の説明が続きます
「図3-4 セッションのレポート」の説明

時間単位での同時ビジター・セッションの数は、表3-2のようにレポートされます。

表3-2 時間単位のレポート

時刻 セッション

12:00

2(12時〜13時には一意のビジターを2名確認)

13:00

1(13時〜14時には一意のビジターを1名確認)

14:00

1(14時〜15時には一意のビジターを1名確認)


日単位では、2つの同時セッションがレポートされます。ただし、月単位または2日単位で表示すると、セッションの数がレポートされます。この場合、Aの2つのセッションの間にアイドル時間が含まれるため、セッション数は3としてレポートされます。レポートされるセッション数の差異を防ぐには、監視対象のアプリケーションのセッション・アイドル時間と一致するようにセッション・アイドル時間を指定する必要があります。

3.2.2 問題分析グループ

問題分析カテゴリのビュー(表1-3を参照)では、アプリケーションの場合、失敗したり問題のあるページ・ビューやヒットに関する詳細な情報が提供されます。問題分析カテゴリには次のビューがあります。

  • Failed URLs

    失敗したページ内のオブジェクト(ヒット)についてレポートします。たとえば、破損したイメージや使用できないダウンロードが含まれるページなどです。5分間当たり最大で5000個のオブジェクトが記録されます。該当するオブジェクトのすべての技術エラー(付録E「エラー・コードの説明」を参照)がレポートされます。このビューではアプリケーション情報は使用されないため、アプリケーションが構成されていない場合でも、失敗したページに関して考えられる理由がレポートされます。

  • Failed pages

    アプリケーションのページで発生したサーバー、ネットワーク、Webサイトおよびコンテンツの各エラーについてレポートします。

  • Slow URLs

    5分間にシステムで検出されたオブジェクトのうち、エンドツーエンド時間が最も遅い5000個のオブジェクトについてレポートします。なお、オブジェクトがこのビューでレポートされるには、エンドツーエンド時間が5秒以上あることが必要です。このビューのためにアプリケーションを構成する必要はありません。

サービスの場合、問題分析カテゴリには次のビューがあります。

  • Failed functions

    関数コールで発生したサーバー、ネットワーク、Webサイトおよびコンテンツの各エラーについてレポートします。


注意:

失敗したURL、ページおよびサービス・コールに関する情報の有効期間は、レポータ・システムのデータ保存ポリシーによって決定されます。この詳細は、9.6.1項「レポータの保存ポリシーの定義」に記載されています。

3.2.3 ページ配信ディメンション

ページ配信ディメンションは、「Failed pages」、「All pages」、「Key pages」の各ビューで使用でき、監視対象のWebサイトで検出されたエラーをレポートします。ページ配信ディメンションでレポートされるすべてのエラーは、セッション診断の再生機能でも表示できます(3.10項「診断機能の使用」を参照)。

ページまたはオブジェクトで複数のタイプのエラー(たとえば、ネットワーク・エラーとWebサービス・エラーの両方)が発生した場合、ページ・エラーまたはオブジェクト・エラーは複数回は記録されません。かわりに、エラーは特定の順序(Webサイト、サーバー、ネットワーク、コンテンツの順)でレポートされます。たとえば、Webサイト・エラーとネットワーク・エラーの両方が発生したオブジェクトは、ネットワーク・エラーではなくWebサイト・エラーとして記録されます。

このディメンションでレポートされるエラーは、KPIのベース(カウンタと割合の両方で表されるメトリック)としても使用できます。図3-5にこれを示します。

図3-5 ページ可用性メトリック

図3-5の説明が続きます
「図3-5 ページ可用性メトリック」の説明

3.2.4 「URL Diagnostics」グループ

ヒットベースの情報は、「Failed URLs」グループおよび「Slow URLs」グループに表示されます。これらのグループには、イメージや他の静的オブジェクトおよび動的オブジェクトに関する詳しい情報が含まれます。この結果、これらのグループでレポートされるURLには、大容量のセッション情報と一意の情報(ユーザーIDおよび様々なオブジェクトで共有される識別子など)が含まれることがあります。これらのグループには5分間隔につき5000のオブジェクトという制限があることにも注意してください。このため、特定のヒットに関連する情報をレポートのURL内で特定するのが困難になることがあります。

「URL diagnostics」グループは、ページ内の動的オブジェクト(ポートレットやフレームなど)の個別の記録に特に適しています。特定のヒットに関連するリテラルURLをレポートするかわりに、「URL diagnostics」グループは機能URLをレポートします。これらはカスタマイズ可能なレポート方法です。通常は、レポートされたURLからセッション情報や一意の情報は除去されます。このグループで得られる情報を使用すると、ページとは無関係に動的サーバー相互作用URLにアクセスできます。このアプローチには、関連するヒットベースの情報がすぐに見つかるという利点があります。たとえば、JavaまたはPHPベースのコールの監視のみに関心があることを指定できます。これは、診断ユーティリティ(CAMMおよびAD4Jなど)の専用サポートを提供する強力なクリックアウト機能によって補われます。

URL診断の構成は、アプリケーション・レベルおよびスイート・レベルで指定されます。6.2.16項「「URL Diagnostics」グループ内でのレポートの制御」および3.2.5項「「Suite」グループ」を参照してください。RUEI内からのクリックアウトのための外部ユーティリティの構成手順は、7.7項「外部ツールへのクリックアウトの構成」に記載されています。

3.2.5 「Suite」グループ

スイート・カテゴリのビュー(表1-3を参照)では、監視対象スイートの運用に関する詳細な情報が提供されます。各スイート・グループが表示されるかどうかは、RUEIインストールにインストールされているアクセラレータ・パッケージによって異なります。また、各スイートを表示するためには、スイートを1つ以上構成しておく必要もあります。

インストールおよび構成されている各スイートについても診断グループが存在し、アプリケーションに関して「URL diagnostics」グループ(3.2.4項「「URL Diagnostics」グループ」を参照)で得られる情報と同等の情報が提供されます。

3.2.6 Oracle Enterprise Managerのサービス・テスト監視

「Service tests」グループは、Oracle Enterprise Managerで監視されるサービス・テストのレポートを提供します。組織はサービス・テストを使用して、可能な限り最高レベルの品質と可用性をビジネス・サービスで確保することができます。

Oracle Enterprise Managerのサービス・テストはビーコンから実行されます。Oracle Enterprise Managerは、エンドユーザーの観点からサービスを監視し、ベースのITインフラストラクチャとサービスの相関関係も監視します。ビーコンは、通常のアプリケーション使用に相当するユーザー・フローを実行するように設定されます。Oracle Enterprise Managerは、ユーザー・フローのレスポンス時間を各構成部分に細分化して分析します。

RUEI内では、特定のアプリケーションおよびスイートのサービス・テスト・トラフィックを監視でき、検出されるとデータ・ブラウザの「Service tests」グループでレポートできます。また、監視対象サービス・テストに関する診断情報をサービス・テスト診断機能で表示することもできます。サービス・テスト・トラフィックを検出するようにアプリケーションを構成する手順は、6.2.4項「サービス・テスト・ビーコン・トラフィックのレポート」に記載されています。

重要:

この機能を利用するためには、監視対象のデプロイメント環境にOracle Enterprise Manager Grid Control 11gがインストールされ稼働していることが必要です。

Oracle Enterprise Manager Grid Control内でサービス・テストを構成するときは、次の点に特に注意してください。

  • Oracle Enterprise Managerでは、ビーコンを作成するときに「メッセージIDのリクエスト・ヘッダーの有効化」チェック・ボックスを選択する必要があります。これは、RUEIがユーザー・フロー・トラフィックを監視できるようにするために必要です。

  • Oracle Enterprise Managerでは、監視対象の環境またはアプリケーションでセッションの追跡に使用されるCookieを、サービス・テストの「拡張プロパティ」セクションで指定する必要があります。具体的には、「テスト・パラメータ」セクションの「リクエスト」部分の「セッション・パラメータ」フィールドで指定します。この指定を行わないと、セッションが混同される可能性があります。

  • 条件付きユーザー・フロー(パスワード失効通知など)は、レポートされるページ・ビューおよびメトリック・レベルが少ない場合があるため、RUEIの監視対象サービス・テストでは使用しないことをお薦めします。

  • すべてのサービス・テスト・ステップにはページが関連付けられていることが必要です。

  • サービス・テストを構成するときは、5分間の収集間隔を指定することを強くお薦めします。それ以外の場合は、サービス・テストの時間ベース・レポートに隙間が空き、実際のユーザー・ページ・ビューの合計数が少なくレポートされることがあります。

3.3 値リストの使用

値リストの使用時に、表示されたリストに列を追加できます。表示されたデータにインジケータ列を追加するには、「Values」メニューから「Show percentage」または「Show growth」を選択します。これらのオプションを使用できるかどうかは、現在表示されているリストによって異なります。また、リストをレポートとして表示(「View」メニューから「Open as report」を選択)した場合も、列が引き継がれます。

3.3.1 ソート順序の変更

値リストの上部にある列ヘッダーを選択して、ソート順序を変更することもできます。ビューは、選択した列を昇順でソートしたものに変更されます。列ヘッダーを再クリックすると、ソート順序が降順になります。列ヘッダー内の順序記号は、現在の順序を示しています。例を図3-6に示します。

図3-6 ソート順序

図3-6の説明が続きます
「図3-6 ソート順序」の説明

3.3.2 包含フィルタと除外フィルタ

値リストでは、項目を右クリックして図3-7に示すメニューを開くこともできます。

図3-7 値のコンテキスト・メニュー

図3-7の説明が続きます
「図3-7 値のコンテキスト・メニュー」の説明

次のオプションがあります。

  • Select value: 包含フィルタとして選択した値をフィルタ・パネルに追加します。つまり、選択した値と一致する値のみがブラウザに表示されます。

  • Exclude value: 除外フィルタとして選択した値をフィルタ・パネルに追加します。つまり、選択した値と一致しない値のみがブラウザに表示されます。

3.4 データ・ブラウザでの検索

検索機能を使用して、現在表示されているデータセット内での文字列の有無を検索できます。図3-8にこれを示します。

図3-8 「Search」タブ

図3-8の説明が続きます
「図3-8 「Search」タブ」の説明

検索機能では、完全一致または部分文字列として指定した検索パターンとの一致が行われます。したがって、検索パターンfireを指定すると、すべてのfireの出現の他に、firefox、x-fireおよびsefirewallの出現とも一致します。前述のように、検索対象は現在表示されているデータに制限されます。検索を拡張するには、現在のビューを変更するか、適用されているフィルタを解除して、検索を再実行します。一致が見つからなかった場合は、「No results were found」というポップアップ・ダイアログが表示されます。


注意:

検索機能では、ワイルドカード文字(*など)の使用はサポートされていません。すべての文字がリテラルとして扱われます。結果リストは値リストであり、値リストと同じ機能を持ちます(3.3項「値リストの使用」を参照)。

3.5 データのソート

グラフのデータをソートするには、グラフの下にある凡例から該当するディメンションを選択します。図3-9にこれを示します。

値リスト内でのソートの詳細は、3.3.1項「ソート順序の変更」を参照してください。

また、「Data」メニュー内の「Sorting」オプションを使用して、指定したソート仕様を元に戻したり(「Remove sorting」)、現在のソート仕様を反転できます(「Invert sorting」)。

3.6 データ・ブラウザでの取消しとやり直し

データ・ブラウザを使用するとき、タスクバーの「Back」アイコンと「Forward」アイコン(表3-1を参照)を使用すると、それまでの選択動作を元に戻したりやり直したりすることができます。この方法で、直前の動作(フィルタの設定など)を元に戻すことができます。表示するための動作をすべて繰り返す必要はありません。この機能を使用するときは、次の点に注意してください。

3.7 フィルタの使用

データ・ブラウザ・ウィンドウの上部にあるフィルタ・パネルを使用して、表示する情報のプロファイルを制限できます。例を図3-10に示します。

図3-10 フィルタ・パネルの例

図3-10の説明が続きます
「図3-10 フィルタ・パネルの例」の説明

フィルタ・パネルの最初の項目は常に、情報が必要な日付または期間になります。図3-10の例では、「period/year」の2007がこれに相当します。この項目は、最上位レベルのフィルタとなり、カレンダで変更できます(2.4項「カレンダの使用方法」を参照)。

その後、追加のフィルタを設定できます。フィルタには、包含フィルタと除外フィルタの2種類があります。包含フィルタは、フィルタ内のデータ値と一致するデータ・アイテムのみを表示することを指定します。除外フィルタは、フィルタ内のデータ値とは一致しないデータ・アイテムのみを表示することを指定します。

たとえば、図3-10のフィルタ・プロファイルでは、クライアントの場所がLiechtensteinであり、クライアント・ブラウザがFirefoxでない2007年の情報のみを表示するように指定しています。

3.7.1 フィルタの定義

データ・ブラウザ・ウィンドウ内の任意のデータ・アイテムは、フィルタとして定義できます。それには、データ・アイテムを右クリックして、図3-7に示すメニューを開きます。フィルタは定義した後、クリックして図3-11に示すコンテキスト・メニューを使用し、自由に変更できます。

図3-11 フィルタのコンテキスト・メニュー

図3-11の説明が続きます
「図3-11 フィルタのコンテキスト・メニュー」の説明

次のオプションがあります。

  • Invert: 選択した包含フィルタを除外フィルタに変更します(またはその逆)。

  • Invert filters(s): 現在定義されているすべてのフィルタの設定を変更します(上記を参照)。

  • Remove: 選択したフィルタを解除します。


    注意:

    フィルタは、定義した順序で適用されます。この順序は、フィルタ・パネルでのフィルタの表示順序でもあり、定義後には変更できません。フィルタの順序を変更するには、フィルタを解除してから、必要な順序で定義しなおす必要があります。

  • Mark as report filter: このオプションの使用方法は、3.7項「フィルタの使用」を参照してください。

  • Remove all: 現在定義されているすべてのフィルタを削除します。

3.7.2 複数のフィルタの使用

値リストでは、複数の値を選択できます。それには、「Multiple section」コマンド・ボタンをクリックしてから、関連リンクを除く必要な値をそれぞれクリックします。選択した項目はハイライト表示されます。例を図3-14に示します。

図3-12 複数の値の選択

図3-12の説明が続きます
「図3-12 複数の値の選択」の説明

必要な値を選択したら、画面の下部にあるツールバーを使用して、値を包含フィルタと除外フィルタのいずれにするかを指定できます。また、このツールバーでは、現在定義されているすべてのフィルタを反転したり解除することもできます。

3.7.3 レポート・フィルタの使用方法

データ・ブラウザから作成したレポートでは、レポート・フィルタを使用できます。レポートに含める情報に対してレポート・フィルタを指定しておくと、レポートを開いたユーザーが、レポートのコンテンツを表示するときに、定義済のフィルタを使用できます。

たとえば、(「All sessions」グループと「client-location」サブグループを使用して)クライアントの場所情報を参照している場合、ユーザーがクライアントの場所に基づいて選択を行うことを可能にするレポートを作成できます。フィルタを定義する手順は、次のとおりです。

  1. 表示された場所のリストから値を選択し、それをフィルタとして定義します。

  2. 値がフィルタ・パネルに表示されたら、右クリックしてメニューから「Mark as report filter」を選択します。例を図3-13に示します。

    図3-13 レポート・フィルタの例

    図3-13の説明が続きます
    「図3-13 レポート・フィルタの例」の説明


    注意:

    各ディメンションに対して定義できるレポート・フィルタは1つのみです。ただし、異なるディメンションに複数のレポート・フィルタを定義することは可能です。複数のフィルタを使用したレポートを設計する場合は、レポートの外観を損わないように注意してください。

  3. 「View」メニューから「Open as report」を選択し、必要なレポートの構造を確定します。これで、選択したフィルタがレポート内に表示されます。例を図3-14に示します。

    図3-14 フィルタを使用したレポート

    図3-14の説明が続きます
    「図3-14 フィルタを使用したレポート」の説明

  4. マウス・ポインタをフィルタ上に置いてフィルタをハイライト表示し、メニューから「Edit filter type」を選択します。図3-15に示すようなダイアログが表示されます。

    図3-15 「Edit Filter Type(s)」ダイアログ

    図3-15の説明が続きます
    「図3-15 「Edit Filter Type(s)」ダイアログ」の説明

  5. 「Edit filter type(s)」ダイアログに表示されたチェック・ボックスを使用してフィルタを設定し、ユーザーがレポートを開くときに選択できるようにしておきます。定義したレポート・フィルタごとにチェック・ボックスが表示されます。次に、「Apply」をクリックします。

  6. 2.9項「新規レポートの作成」の説明に従って、レポートを保存します。

レポートの実行

レポートが開かれ、レポート・フィルタが有効化されると、レポート・フィルタとして選択した値が、ディメンション値のリストでデフォルトの選択項目になります。例を図3-16に示します。

図3-16 レポートでのフィルタの使用

図3-16の説明が続きます
「図3-16 レポートでのフィルタの使用」の説明

3.8 データのエクスポート

データ・ブラウザに現在表示されているデータは、スプレッドシートなど、様々なアプリケーションにエクスポートできます。データのエクスポート処理を開始するには、「Open as export」アイコンをクリックするか、「View」メニューから「Open as export」を選択して、エクスポート・ウィンドウを開きます。現在のデータを使用した新しいウィンドウが開きます。例を図3-17に示します。

図3-17 エクスポート・ウィンドウ

図3-17の説明が続きます
「図3-17 エクスポート・ウィンドウ」の説明


注意:

Microsoft Excelにエクスポートできるのは5000項目までです。

3.8.1 エクスポートするデータの変更

エクスポート・ウィンドウ(図3-17)には、エクスポート可能なRAWデータが表示されます。ここで、データのエクスポート方法をカスタマイズできます。それには、エクスポート・ウィンドウ内で右クリックして「Edit」を選択します。図3-18に示すようなダイアログが表示されます。

図3-18 「Customize Export」ダイアログ

図3-18の説明が続きます
「図3-18 「Customize Export」ダイアログ」の説明

このダイアログでは、データ列の順序やデータ列での値の表示順序を変更したり、Microsoft Excelエクスポートに表示する追加の列を指定できます。

「Data columns」フィールドと「Value columns」フィールドでは、リストを使用して、1次索引列と1次索引列に表示するデータ列を追加できます。各リストで使用可能なデータ列と値列の選択は、使用しているビュー・グループによって厳密に決定されます。たとえば、「All clients」グループでデータを表示している場合は、Webサイトおよびページのデータ列は、ドメインとWebサイトの場合にのみ選択できます。ただし、「All pages」グループで作業している場合は、「page-content」や「page user flow」などの項目に追加のデータ列も使用できます。各ビュー・グループ内のエクスポート可能なデータ列と値列の詳細は、付録D「データ・アイテムの概要」を参照してください。

「Percentage」チェック・ボックスでは、レポートされる値が占める割合構成を示す列を、Microsoft Excelエクスポートに追加するかどうかを指定できます。

「Growth」チェック・ボックスでは、レポートされるメトリックの実増値を示す列を、Microsoft Excelエクスポートに追加するかどうかを指定できます。

データ列の選択項目の横にある「Up」、「Down」および「Remove」アイコンを使用して、ソート順序階層を制御したり、データの索引としてのデータ列を削除できます。同様に、値列フィールド内の同じコントロールを使用して、エクスポートでの値列の表示順序を並べ替えられます。

エクスポートは、新規ファイルまたは既存ファイルに保存したり、既存のエクスポートに追加できます。

3.8.2 エクスポート書式の選択

エクスポートするデータの表示方法を制御できるのみでなく、データのエクスポート書式も指定できます。それには、「Download」メニューを選択します。次のエクスポート形式が使用可能です。

  • カンマ区切り値(CSV)

  • タブ区切り値(TSV)

  • Microsoft Excel(2000互換)ワークシート

  • Webquery書式

エクスポートされたデータはUnicode(UTF-8)形式になることに注意してください。

3.9 カスタム・ディメンションの使用

カスタム・ディメンションを使用すると、データ・ブラウザのビューに独自のユーザー定義ディメンションを追加できます。この新しいディメンションは、レポートおよびエクスポートにおいてのみでなくKPIでも使用できるようになります。たとえば、組織の仕入先をより簡単に追跡および分析できるように、supplierというディメンションを追加できます。この機能を使用して、主要業務で顧客転換率が最も高い商品の仕入先や、組織のWebサイトで最もページ・ビューの多い仕入先を判別できます。問題ベースのカスタム・ディメンションは、主にアプリケーションをデバッグする目的のために使用することに注意してください。


注意:

カスタム・ディメンションは、ページベース、セッションベース、機能ベース、ユーザー・フロー・ベースまたは問題ベースにすることができます。KPIはリアルタイム・データに基づくため、セッションベースのカスタム・ディメンションはKPIのメトリックとしては使用できません。ただし、ページベースのカスタム・ディメンションはKPIフィルタとして使用できます。

カスタム・ディメンションのレポート

各カスタム・ディメンションには一意の名前があり、ページ、セッション、機能、ユーザー・フローまたは問題をベースとしています。カスタム・ディメンションにより、レポートが行われるデータ・ブラウザ・グループが決まります。また、次の項で説明するように、ディメンション情報がページ・ビュー間でどのように保存されるかが決まります。データ・ブラウザ・グループにおけるカスタム・ディメンションのレポートを、表3-3に示します。

表3-3 データ・ブラウザ・グループにおけるカスタム・ディメンションのレポート

ソース All Pages Key pages All sessions Failed pages Failed URLs Slow URLs All functions Failed functions (named) Suite URL diagnostics All user flows

ページ

X

X


X

X

X



X

X


ページ(セッション対応)

X

X


X

X

X



X



セッション


X

X

X

X

X






機能







X

X




問題分析




X

X

X






ユーザー・フロー











X


セッションベース・カスタム・ディメンション情報をリアルタイムで(セッションと同じ日に)再確認すると、レポートされるユーザー名が変わることがあります。複数日について同じ情報を表示すると、レポートされるユーザー名はセッションの最後に検出されたユーザー名に基づきます。

ディメンション情報の保存

前に説明したように、カスタム・ディメンションが基づくエンティティ(ページ、セッション、機能、ユーザー・フローまたは問題)によって、ディメンション内の情報がページ・ビュー間で保存される方法が決まります。ここでは、選択した方法がカスタム・ディメンション情報のレポートにどのように影響するかを詳しく説明します。サンプルのビジター・セッションのデータに基づいて説明します。各サンプル・セッションは、販売カタログを含む監視対象のWebサイトを参照します。カタログ内のどのコレクションをビジターが表示しているかという情報を取得するために、3レベルのカスタム・ディメンションが定義されています。これら3つのレベルは3つの引数a、bおよびcから導出されます。

カスタム・ディメンションがページベースとして指定されると、表3-4の値がレポートされます。

表3-4 ページベースのカスタム・ディメンション情報の保存

入力 ディメンション・レベル

1(a)

2(a » b)

3(a » b » c)

a=男性用

男性用

男性用 » なし

男性用 » なし » なし

a=男性用、b=コート

男性用

男性用 » コート

男性用 » コート » なし

a=男性用、b=コート、c=冬物

男性用

男性用 » コート

男性用 » コート » 冬物

a=男性用、b=帽子

男性用

男性用 » 帽子

男性用 » 帽子 » なし

a=男性用、b=帽子、c=フェルト帽

男性用

男性用 » 帽子

男性用 » 帽子 » フェルト帽

a=子供用

子供用

子供用 » なし

子供用 » なし » なし


この方法を使用しているとき、カスタム・ディメンション・レベルについてレポートすると、現在のページ・ビューの情報のみが使用されることがわかります。前のページ・ビューから継承される情報はありません。

カスタム・ディメンションがページベース(セッション対応)として指定されると、表3-5の値がレポートされます。

表3-5 ページベース(セッション対応)のカスタム・ディメンション情報の保存

入力 ディメンション・レベル

1(a)

2(a » b)

3(a » b » c)

a=男性用

男性用

男性用 » なし

男性用 » なし » なし

(a=男性用、)b=コート

男性用

男性用 » コート

男性用 » コート » なし

(a=男性用、)(b=コート、)c=冬物

男性用

男性用 » コート

男性用 » コート » 冬物

(a=男性用、)b=帽子

男性用

男性用 » 帽子

男性用 » 帽子 » なし

(a=男性用、)(b=帽子、)c=フェルト帽

男性用

男性用 » 帽子

男性用 » 帽子 » フェルト帽

a=子供用

子供用

子供用 » なし

子供用 » なし » なし


ここでは、カスタム・ディメンションのレベル情報がページ・ビューにないと、情報が前のページ・ビューから継承されていることがわかります。継承はカッコによって示されます。カッコ内の情報は現在のページ・ビューには含まれないため、前のページ・ビューから導出されています。

カスタム・ディメンションがセッションベースとして指定されると、表3-6の値がレポートされます。

表3-6 セッションベースのカスタム・ディメンション情報の保存

入力 ディメンション・レベル

1(a)

2(a » b)

3(a » b » c)

b=コート

なし

なし » コート

なし » コート » なし

b=コート、c=冬物

なし

なし » コート

なし » コート » なし

c=冬物

なし

なし » なし

なし » なし » 冬物

......

なし

なし » なし

なし » なし » なし


この例では、カスタム・ディメンション情報の継承が発生していないことがわかります。また、この方法を使用すると1つのページ・ビューしかレポートできないことに注意してください。これは、カスタム・ディメンション情報が存在する最初のページ・ビューです。このケースでは、これは表示履歴の最初のページです(なし » コート » なし)。他のページ・ビューのすべてのカスタム・ディメンション情報は廃棄されます。表3-4、表3-5および表3-6は、いずれも1つのセッションを参照していることに注意してください。

カスタム・ディメンションの説明

必要に応じて、ディメンションでレポートされる一意の各ソース値に対して一連の説明を定義することもできます。たとえば、表3-7に示すように、サービスベースのカスタム・ディメンションである「server ID」を定義して、それに説明を関連付けることができます。

表3-7 カスタム・ディメンションの説明の例

値 説明

178349

ビジネス・パートナシップ

561808

ニュースレターとイベント

405969

カタログ

969533

支払い処理


カスタム・ディメンションの定義

カスタム・ディメンションを定義する手順は、次のとおりです。

  1. 機能ベースのカスタム・ディメンションの場合は、「Configuration」→「Services」→「Custom dimensions」の順に選択します。アプリケーションベースのカスタム・ディメンションの場合は、「Configuration」→「Applications」→「Custom dimensions」の順に選択します。現在定義されているカスタム・ディメンションのリストが表示されます。ユーザー・フローベースのカスタム・ディメンションは最大で2個、ページベースまたはセッションベースのカスタム・ディメンションは最大で5個定義できます。機能ベースのカスタム・ディメンションは、最大で10個定義できます。「New dimension」コマンド・ボタンをクリックします。図3-19に示すようなダイアログが表示されます。

    図3-19 「New Custom Dimension」ダイアログ

    図3-19の説明が続きます
    「図3-19 「New Custom Dimension」ダイアログ」の説明

  2. 新しいディメンションに一意の名前を指定します。定義したカスタム・ディメンションが組み込まれる画面(データ・ブラウザやレポートなど)では、ディメンションの名前にアスタリスク(*)が付けられます。

  3. 「Based on」メニューを使用して、ディメンションのベースとするエンティティ・タイプを指定します。機能ベースのディメンションの場合は、機能がベースとして自動的に選択され、変更できません。アプリケーションベースのディメンションの場合は、ベースとしてページ、ページ(セッション対応)、セッション、ユーザー・フローまたは問題分析を選択できます。これらのオプションの使用方法は前の項に記載されています。ページベース、セッションベース、ユーザー・フローベースまたは問題ベースのカスタム・ディメンションは最大で5個定義でき、機能ベースのカスタム・ディメンションは最大で10個定義できます。

  4. 「Number of levels」メニューを使用して、保存するディメンション情報のレベルを指定します。デフォルトでは、定義したカスタム・ディメンションに対して保存される情報は1レベルのみです。ただし、この機能を使用することで、保存するセッション情報の階層を構築できます。たとえば、国、リージョンおよび市区町村の3つのレベルを使用して、ユーザーの場所に関する情報を取得できます。最大で4つのレベルがサポートされます。

  5. 表示される「Level」タブに、ディメンション・レベルの名前を指定します。「Source type」メニューと「Source value」フィールドを使用して、ディメンションの検索範囲、および検索でXPath式、ヘッダー、Cookie、URL引数(リクエスト)、カスタム・タグまたはカスタム関数を使用するかどうかを指定します。XPath問合せの使用方法の詳細は、付録F「XPath問合せの使用」に記載されています。ソースがURL引数の場合は、RAW入力(元の入力)が使用されます。ただし、HTTPヘッダーの場合は、ASCII入力のみが許可されます。非ASCII文字は、レポート時にアンダースコア(_)文字で置き換えられます。エンコーディング・サポートの詳細は、付録G「各国語サポートの使用」を参照してください。

    カスタム・タグまたはカスタム関数のオプションを選択した場合は、タグまたは関数の名前を「Source value」フィールドに指定する必要があります。カスタム関数の場合は、最初のパラメータのみが使用されることに注意してください。パラメータは単一引用符または二重引用符で囲む必要があります。次に例を示します。

    wiViewState("wi_menu_main_menu");
    

    カスタム・タグおよびカスタム関数がページ内でどのように解釈されるかの詳細は、付録A「タグ付け規則」を参照してください。

    次に、「Save」をクリックします。定義したカスタム・ディメンションの概要が表示されます(図3-20を参照)。

    図3-20 カスタム・ディメンションの概要

    図3-20の説明が続きます
    「図3-20 カスタム・ディメンションの概要」の説明

  6. 必要に応じて、ディメンションでレポートされる一意の各ソース値に対して一連の説明を定義することもできます。それには、「«Add new translation»」をクリックします。図3-21に示すダイアログが表示されます。

    図3-21 Add Translation

    図3-21の説明が続きます
    「図3-21 Add Translation」の説明

    必要なソース値とその説明を指定します。次に、「Save」をクリックします。

インポートする説明のリストが非常に大きい場合は、図3-20の下部のツールバーにあるコントロールを使用して画面をスクロールできます。また、検索機能を使用して、必要な説明を検索できます。検索文字列には、ソース値または説明を指定できます。ワイルドカード文字(*など)の使用はサポートされておらず、すべての文字がリテラルとして扱われます。

説明のリストのインポート

それぞれの説明を別々に定義するかわりに、(図3-20の下部にある)ツールバーの「Upload list」アイコンをクリックして、説明のリストを含むファイルをインポートできます。図3-22に示すダイアログが表示されます。

図3-22 Upload Custom Dimension Translations

図3-22の説明が続きます
「図3-22 Upload Custom Dimension Translations」の説明

「Browse」ボタンを使用し、目的のファイルを検索して選択します。必要に応じて、「File encoding」メニューを使用し、ファイルのキャラクタ・エンコーディングを指定します。各国語のキャラクタ・セットのサポートの詳細は、付録G「各国語サポートの使用」を参照してください。サポートされていないエンコーディングが検出された場合、またはトランスコーディングに失敗した場合は、エラーがレポートされます。ファイルには、ソース値とその説明をタブで区切って、1行に1つの説明のみを含めることができます。次に、「Merge」をクリックします。


注意:

また、カスタム・ディメンション機能を使用して、標準ディメンションの機能を再定義することもできます。

カスタム・ディメンションでレポートされるフォールバック値

カスタム・ディメンションでは、次の2つのフォールバック値をレポートできます。

3.9.1 カスタム・ディメンションの削除

カスタム・ディメンションを削除する手順は、次のとおりです。

  1. アプリケーションベースのディメンションの場合は、「Configuration」→「Applications」→「Custom dimensions」の順に選択します。機能ベースのディメンションの場合は、「Configuration」→「Services」→「Custom dimensions」の順に選択します。現在定義されているカスタム・ディメンションのリストが表示されます。目的のカスタム・ディメンションを右クリックし、メニューから「Remove」を選択します。

  2. カスタム・ディメンションをKPIまたはレポートでフィルタとして使用している場合は、カスタム・ディメンションを削除すると、関連付けられているKPIまたはレポートも削除されることを警告するメッセージが表示されます。「Yes」または「No」をクリックします。

3.10 診断機能の使用

診断機能には、アプリケーション・マネージャとIT技術スタッフが業務上の問題の根本原因分析を行うために使用できる強力な方法が備わっています。この機能では、セッション・パフォーマンス・ブレークダウンがサポートされ、失敗したページやヒットがセッションに及ぼす影響、失敗した各ページの完全なコンテンツ、さらにオブジェクト、ページ・ビュー、セッションの関係などが表示されます。Webサービスを診断して関数コールの失敗を調査することも可能です。

診断機能では、問題が特定されると、ユーザーがRUEIの大規模なデータ構造をドリルダウンして、その問題がWebサイトのビジターおよびWebサービスに及ぼす影響を評価するとともに、考えられる原因を直接見極める手段を得ることができます。


重要:

セッション再生データを取得するためには、セッション記録を有効にする必要があります。この詳細は、8.4項「ユーザー情報のマスキング」に記載されています。

エラー記録機能

これまでに説明した情報に加えて、RUEIでは、監視対象Webサイトのビジターがどのようなエラー・メッセージをいつ受け取ったかを正確に追跡することができます。この機能を使用してアプリケーションの失敗を再現することで、Webページで不備や問題のある箇所を正確かつ早急に除去できます。

セッション・レポートの概要

ユーザー・セッションに関する情報は、診断機能においてはユーザー・レコードとしてレポートされます。情報は5分間隔でレポートされることを理解してください。IPアドレスやユーザーIDなどのセッション関連プロパティは、実質的には5分間隔の最後に取得されたスナップショットです。これらのプロパティの値はその5分間内では変動していた可能性がありますが、その期間の最後の値がレポートされることに注意してください。

診断機能の使用方法

必要な診断情報を検索する手順は、次のとおりです。

  1. 「Browse data」を選択し、開始するグループを選択します。診断情報は、「All sessions」グループ、「Service test」グループ、「Failed URLs」グループ、「Failed pages」グループ、「Failed functions」グループ、およびアクセラレータ固有のグループ(Oracle E-Business SuiteやSiebelなど)について使用可能です。目的の診断オプションをクリックします。選択したグループがオプションの名前に反映されることに注意してください。たとえば、「Session diagnostics」、「Page diagnostics」または「URL diagnostics」となります。図3-23に示すような診断パネルが表示されます。

    図3-23 診断パネル

    図3-23の説明が続きます
    「図3-23 診断パネル」の説明

  2. カレンダ・コントロール(2.4項「カレンダの使用方法」を参照)を使用して、目的の期間を選択します。表示範囲としては1日(または未満)を選択する必要があります。この制限外で検索しようとするとエラーが発生します。再生コンテンツの有無は、対応するコレクタの保存ポリシーによって異なります(9.6.2項「コレクタのデータ保存ポリシーの定義」を参照)。

  3. 検索機能を使用して、目的のユーザー・レコードを検索します。使用可能な基準は、選択したグループによって異なります。使用可能な検索基準を表3-8に示します。各基準メニューでは最初の100項目しか表示されないことに注意してください。したがって、目的の項目が表示されていない場合は、該当する基準フィールドの右側の「Search」アイコンを使用して、項目を検索して選択します。「Exit diagnostics」アイコンを選択すると、診断機能を開始する直前のデータ・ブラウザに戻ります。

    表3-8 診断の検索基準

    データ・ブラウザ・グループ All sessions Service tests Failed pages Failed URLs Slow URLs E-Business Suite Siebel PeopleSoft JD Edwards

    Application name

    •


    •


    •




    •


    •


    •


    •


    User ID

    •



    •



    •


    •


    •


    •


    •


    Client IP address

    •



    •



    •






    Service name


    •









    Beacon name


    •









    Object URL




    •


    •






    Object delivery




    •







    Object URL




    •







    Client network










    EBS responsibility






    •





    Siebel method







    •




    PeopleSoft node name








    •



    JD Edwards form









    •



    オプションとして、「Add more filters」機能を使用して追加の検索基準を指定できます。最初の検索基準と同じく、追加の検索フィルタ・オプションも選択したグループによって異なります。検索に指定したすべての基準が一致しないと、ユーザー・レコードはレポートされません。厳密な検索が行われることに注意してください。すべての文字列はリテラルとみなされます。ワイルドカードは使用できません。

    オプションとして、一致したユーザー・レコードのレポート順序を「Search result order」機能で指定できます。次に、「Search」をクリックします。検索結果がウィンドウの主要部に表示されます。例を図3-24に示します。

    図3-24 Session Diagnosticsウィンドウ

    図3-24の説明が続きます
    「図3-24 Session Diagnosticsウィンドウ」の説明

  4. 上部にあるツールバーのコントロールを使用して、結果ページ間で移動できます。1ページ当たり最大で100ユーザー・レコードがリストされます。表示リストの特定のユーザー・レコードをクリックして選択できます。

    オプションとして、「Order」メニューを使用して、一致したユーザー・レコードがリストされる順序を指定します。また、「Dimension level」メニューおよび「Value」メニューを使用すると、表示リストにさらにフィルタを適用することができます。次に、「Add」をクリックします。「Dimension level」メニューのオプションは、選択したグループによって異なります。

    図3-24に示すユーザー・レコードのコンテキスト・メニューで「Export session」オプションを選択できることに注意してください。この機能の使用方法の詳細は、3.10.3項「すべてのセッション情報のエクスポート」に記載されています。

  5. ユーザー・レコードを選択した後、ウィンドウの左側のパネルにある「View」の部分に、選択したユーザー・レコードの情報を表示できます。「Session」の下の「Pages」、「Object」および「Info」項目を使用して、選択したユーザー・レコードに関する特定の情報を表示します。例を図3-25に示します。

    図3-25 診断パネルの例

    図3-25の説明が続きます
    「図3-25 診断パネルの例」の説明

    セッション・ページはグループ分けされており、展開すると関連するオブジェクトが表示されます。選択したユーザー・レコード内に記録されたページ(およびその時間)の概要が表示されます。アイコンによって、処理が遅いオブジェクトまたは失敗したオブジェクト、ページ・ロード満足度、キー・ページかどうか、再生コンテンツの有無が示されます。Replay Viewerの使用方法は、3.10.1項「ユーザー・セッションの再生」に記載されています。

    ツールバーの「Include/Exclude spurious objects」アイコンを使用すると、レポートされるページに直接関連していないヒットをオブジェクトの表示リストに含めるかどうかを制御できます。この機能は、ロード時間が非常に長くかかる問題のオブジェクトを特定するときに特に役立ちます。通常、このようなオブジェクトにはページが関連していないため、セッション・ページ・レポートには表示されません。

    「Export session pages」コマンド・ボタンを使用すると、現在選択されているユーザー・レコードのサマリーをMicrosoft Excelにエクスポートできます。この機能の使用方法の詳細は、3.10.2項「Microsoft Excelへのセッション・ページのエクスポート」に記載されています。

  6. パネルの「View」の下にある「Pages」オプションまたは「Objects」オプションをクリックすると、ビジターが表示したページのサマリー、またはそれらのページ内のオブジェクトを確認できます。例を図3-26に示します。

    図3-26 「Page Properties」ダイアログの例

    図3-26の説明が続きます
    「図3-26 「Page Properties」ダイアログの例」の説明

    表示されるページ履歴では、ページのすべてのコンテンツの他に、サーバーやクライアントで受信されたメッセージが基づくHTMLコードも表示されます。レポートされるコンテンツは、HTTPプロトコル項目に対して現在定義されているマスキング・オプションによって変化することに注意してください。ページまたはURLのアプリケーション関連およびセッション関連の詳しい情報は、「Info」オプションで表示されます。例を図3-27に示します。

    図3-27 セッション情報の例

    図3-27の説明が続きます
    「図3-27 セッション情報の例」の説明

  7. 次に、選択したユーザー・レコードの右にある「Remove」アイコンをクリックします。図3-24に示す診断ウィンドウに戻ります。ここで、他のユーザー・レコードを選択してドリルダウンできます。

診断機能での機密情報のマスキング

前述のように、診断機能での情報(ヘッダーやURL情報など)の表示または非表示は、適切なHTTPプロトコル項目のマスキング機能によって制御できます。この詳細は、8.4項「ユーザー情報のマスキング」に記載されています。

3.10.1 ユーザー・セッションの再生

表示しているページの横に「Replay」アイコンがある場合には、それをクリックすると完全なユーザー・セッションを再生できます。こうすることで、ビジターがセッション中に表示した各ページとレポートされたエラー・メッセージを確認できます。例を図3-28に示します。

図3-28 セッション再生の例

図3-28の説明が続きます
「図3-28 セッション再生の例」の説明

メイン・ウィンドウと同じサイズの新しいウィンドウに、再生の詳細が表示されます。メインの「Session Diagnostics」ウィンドウ(図3-24を参照)から選択したときは、完全なセッション・ページ履歴が「Replay」ウィンドウの左側に表示されることに注意してください。ただし、選択したユーザー・レコード内でページの「Replay」アイコンをクリックして選択すると、選択したページの時点からページ履歴の表示が開始します。

ページ表示の下のコントロールを使用して、ページ履歴をナビゲートできます。「Page information」セクションには、現在表示されているページのロード満足度、キー・ページかどうか、およびエラーの有無が示されます。

ページ・イベントのレポート

表示されたページにHTTPフォーム要素が含まれる場合、フォーム要素とビジターの応答が「Page events」パネルにレポートされます。名前のない要素は"NO_NAME_number"としてレポートされます(numberは名前のない要素ごと1つずつ増えます)。非表示のフォーム要素もレポートされます。フォーム要素に対するビジターの応答は、セッション・ページ表示履歴の次のページのリクエスト本文から導出されることに注意してください。したがって、ビジターが、リクエスト・ページとレスポンス・ページの間で別のページにコンテキストを切り替えた場合、ユーザーの応答は抽出できずレポートされません。

図3-28の下部のステータス・バーには、セッション・ユーザーID、ページごとに記録されたタイムスタンプ、ロード時間、オブジェクト数に関する情報が表示されます。また、静的ページの場合には、レポートされたページがライブ・ソース(アプリケーション・サーバーなど)から取得されていることも示されます。

ページ・コンテンツの表示

ツールバーの「HTTP content」コマンド・ボタンを使用すると、現在選択されているページの実際のリクエスト・コンテンツとレスポンス・コンテンツを表示できます。例を図3-29に示します。

図3-29 ページ・コンテンツの例

図3-29の説明が続きます
「図3-29 ページ・コンテンツの例」の説明

ページ・コンテンツ内のリンクをクリックすると外部のJavaScriptファイルも表示できることに注意してください。このようなファイルのレポートされるコンテンツは、ライブ・ソース(たとえばアプリケーション・サーバー)から取得されます。

静的ページ・コンテンツの表示

表示される表示履歴でページの横に「Replay」アイコンがない場合は、ページのコンテンツがないことを意味します。これは、データ保存制限のために情報が期限切れになったため、または表示したページが静的ページだったためです。静的ページの場合は、静的ページのコンテンツを表示できます。表示履歴で静的ページの直前または直後のページをハイライト表示し、そのページから静的ページのコンテンツを表示します。

静的ページのオブジェクトについてレポートされるコンテンツは、ライブ・ソースから取得されることに注意してください。このため、なんらかの理由でライブ・ソースが使用できないと、ページのコンテンツが正しくレポートされないことがあります。また、データ・マスキングやJavaScript実行ルールは、ライブ・ソースから取得されるページ・コンテンツには適用されません。ページ・コンテンツは現状のままで表示されます。静的ページがクライアントでキャッシュされていると、以前の任意のセッションにおける完全なページ・フェッチがプレビューに使用されることに注意してください。したがって、監視対象Webサイトの構成によって異なりますが、ページはビジターが実際にページを見た後で変更されている可能性があります。たとえば、最新の株式相場をリストするページなどです。ライブ・ソースのデータがレポートされるときは、「Replay」ステータス・バーに示されます。

Replay ViewerでのJavaScriptの実行

ビジターが表示したページに、インラインJavaScriptコードが含まれることがあります。アプリケーション定義機能を使用して、このJavaScriptコードの実行を再生機能でどのように扱うかを指定できます。この詳細は、6.2.17項「JavaScript再生実行の制御」に記載されています。また、スイート(SiebelおよびPeopleSoftなど)では、Replay Viewerでのレポートを最適化するJavaScriptの実行ルールが事前構成されていることに注意してください。

3.10.2 Microsoft Excelへのセッション・ページのエクスポート

現在選択しているセッション内のページのサマリーをMicrosoft Excelにエクスポートできます。これを行う手順は、次のとおりです。

  1. 前に説明した手順を使用して目的のセッションを選択します。「Export session pages」コマンド・ボタンをクリックします。ブラウザの構成方法によって異なりますが、ファイルを直接開くツール(デフォルトはMicrosoft Excel)の指定を求められるか、定義済のデフォルトの場所にファイルがすぐに保存されます。

  2. Microsoft Excelで、生成されたファイルを表示して編集できます。例を図3-30に示します。

    図3-30 Microsoft Excelでのセッション・ページ・エクスポートの例

    図3-30の説明が続きます
    「図3-30 Microsoft Excelでのセッション・ページ・エクスポートの例」の説明

エクスポートされたページ表示履歴とセッション・サマリーを使用して、一連のリアルユーザー・セッションをまとめることができます。たとえば、テストまたはパフォーマンス分析のベースとして使用できます。

3.10.3 すべてのセッション情報のエクスポート

セッション情報の表示だけでなく、完全なセッション・コンテンツを外部ユーティリティにエクスポートして、詳しい分析や他のデータとの統合を行うことができます。たとえば、この方法を利用すると、完全なリアルユーザー・セッションに基づいてテスト・スクリプト生成を行うことができます。Oracle Application Testing Suite(ATS)などのテスト・プラットフォームを構成すると、アプリケーションで最もよく発生する使用シナリオに対して自動テスト・スクリプトを簡単に生成できます。

また、この機能を使用して高性能の根本原因分析をサポートすることもできます。アプリケーションまたは運用のスペシャリストに完全なユーザー・セッション情報を提供することができ、珍しい問題や切り分けにくい問題を特定するために役立ちます。エクスポートされたデータの機密情報は、HTTPプロトコル項目のマスキング機能で定義される動作に応じてマスキングされます。この詳細は、8.4項「ユーザー情報のマスキング」に記載されています。

セッション情報をエクスポートする手順は、次のとおりです。

  1. 目的のセッションを探して、コンテキスト・メニューで「Export session」オプションを選択します。図3-31にこれを示します。

    図3-31 ユーザー・レコードのコンテキスト・メニュー

    図3-31の説明が続きます
    「図3-31 ユーザー・レコードのコンテキスト・メニュー」の説明

    または、再生機能で「Session」メニューを選択し、「Export session」オプションを選択します。いずれの場合も、選択したセッションのエクスポートの確認を求めるダイアログが表示されます。

    エクスポートされるデータに機密情報が含まれる可能性があることを理解してください。セッションのコンテンツをよく確認して、機密情報が正確にマスキングされるようにすることをお薦めします。選択したセッションのエクスポートを確認するには、「Yes」をクリックします。

  2. ブラウザの構成方法によって異なりますが、zipファイルの保存場所の指定を求められるか、定義済のデフォルトの場所にファイルがすぐに保存されます。

重要:

セッション・エクスポート・ファイルを正しく作成するためには、次の点を確認する必要があります。

また、エクスポートされたコンテンツ・ファイル(次の項を参照)が存在することを確認してから、エクスポートされたRUEIセッションを外部ユーティリティにインポートすることをお薦めします。

エクスポート・データの構造について

エクスポートされるセッションのzipファイルには次のファイルが含まれます。

  • data.tab: コレクタのログ・ファイルから抽出された、選択したセッションの直接(RAW)ヒット情報が含まれます。

  • content_hitno.tab: 指定されたヒットの完全な(RAW)コンテンツ情報が含まれます。data.tabファイル内のコンテンツを含む各ヒットに対して1つのファイルがあります。たとえば、3番目のヒットと6番目のヒットにコンテンツがある場合には、2つのファイルcontent_3.tabとcontent_6.tabが作成されます。ヒット・ファイルの例を図3-32に示します。

    図3-32 ヒット情報ファイルの例

    図3-32の説明が続きます
    「図3-32 ヒット情報ファイルの例」の説明

    ファイルの最初の行(ここでは589 68 313 221)には4つの整数が含まれ、それぞれがリクエスト・ヘッダー、リクエスト本文、レスポンス・ヘッダー、レスポンス・本文の長さ(バイト単位)を表します。また、このファイルでユーザーのパスワードがマスキングされている方法にも注意してください。


注意:

エクスポート・セッション・ファイルを作成する基礎として使用されるログ・ファイルも、RUEIによって内部で使用されます。これらのファイルの形式と内容は予告なしに変更される場合があります。