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Preface
Welcome to the Oracle Insurance Insight Administration Guide. This guide presents the 
information you will need to manage data and user accounts in Oracle Insurance Insight (OII) 
using the administrative tools of Oracle Business Intelligence Enterprise Edition (OBIEE).
This is not a complete system administrator’s guide for OBIEE. The purpose of this manual 
is to describe the basic administrative duties that you will need to perform in order to 
maintain the data in OII.

VERSION
This manual corresponds to Oracle Insurance Insight (OII) version 7.0.

INTENDED AUDIENCE
This manual is intended for experienced system administrators with advanced knowledge of 
OBIEE and OII. 

RELATED DOCUMENTS
For more information, refer to the following documents:

• Oracle Insurance Insight Release Notes

• Oracle Insurance Insight Installation Guide

• Oracle Insurance Insight Warehouse Palette Guide

• Oracle Insurance Insight Implementation Guide

• Oracle Insurance Insight User Guide
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RELEVANT ORACLE DOCUMENTATION
For complete documentation on OBIEE and its components, please go to the documentation 
section of the Oracle website to consult the following manuals:

• Oracle Business Intelligence Server Administration Guide

• Oracle Business Intelligence Presentation Services Administration Guide

• Oracle Business Intelligence Answers, Delivers, and Interactive Dashboards User 
Guide

OII DOCUMENTATION ON THE ORACLE TECHNOLOGY NETWORK 
(OTN)

The OII documentation set is packaged with the product release. You can also obtain these 
guides online thought the Oracle Technology Network (OTN) at this address: 
 
http://www.oracle.com/technology/documentation/insurance.html

CUSTOMER SUPPORT
 If you need assistance with Oracle Insurance Insight, please log a Service Request using My 
Oracle Support at https://support.oracle.com.
Address any additional inquiries to:
Oracle Corporation
World Headquarters
500 Oracle Parkway
Redwood Shores, CA 94065
U.S.A.

Worldwide Inquiries:
Phone: +1.650.506.7000
Fax: +1.650.506.7200
oracle.com

BLOCKED::http://metalink.oracle.com/
BLOCKED::http://metalink.oracle.com/
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Chapter 1

OII Administrator’s Duties
Oracle Insurance Insight (OII) is a comprehensive business intelligence system created 
exclusively for the Property and Casualty (P&C) insurance industry that provides the 
following advantages: 

• Consolidates data from multiple, disparate source systems to provide a strategic 
enterprise-wide view across operating units. 

• Provides an underlying data model constructed specifically for the P&C insurance 
industry.

• Delivers information management, reporting and advanced analytics to end-users 
through the OBIEE interface.

• Accommodates all P&C lines of business and all states/provinces in the U.S. and 
Canada.

BASIC ADMINISTRATIVE TASKS
The OII system administrator is responsible for performing the following basic duties 
outlined in the table below. These tasks will be performed using components of the OBIEE 
and separate OII applications.

Table 1: Basic Administrative Tasks

Task Performed Using this Application:

• Add users to the OII Repository
• Edit the OII Repository

• OBIEE Administration Tool

• Add users to groups • OBIEE’s Presentation Services Administration page

• Manage Load Manager • Load Manager is a job scheduler designed to perform automated data 
loads into OII. 

• Load Manager is a separate Java based application that must be 
installed, configured, and run outside of the OBIEE system. 

• Instructions for installing and setting up Load Manager can be found in 
the Oracle Insurance Installation Guide. 

• For information on configuring and using Load Manager, refer toChapter 
5: Using Load Manager.

• Create an ODBC Data Source to the 
OBIEE Server

• Control Panel>Administration Tools>Data Sources on your desktop
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ADMINISTRATOR PREREQUISITES
Any system administrator should meet the following prerequisites:

• Strong Technical Skills

• Understanding of business data 

• Understanding of OBIEE

• Understanding of OII 
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Chapter 2

Managing the OII Repository
This chapter describes the following OII administrative duties:

• Logging into the OBIEE Administration Tool

• Adding new users to the OII Repository

• Removing objects from the OII Repository

OPENING THE OII REPOSITORY
To open the OBIEE Administration Tool: 

1. From the Start menu select Oracle Business Intelligence > Administration. 
 
The Administration interface workspace opens:

Figure 1: OBIEE Administration Workspace
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2. Select File>Open from the menu or click on the Open icon. The login dialog box opens.

Figure 2: Open OII Repository (AnalyticsWeb)

3. Enter the Administrator ID and password

4. Select “AnalyticsWeb” and press OK. The OII repository opens.

Figure 3: OII Repository in the OBIEE Administration Tool

The OII Repository contains three layers.

• Presentation Layer – this pane represents the physical structure of the OII repository. 
This layer shows each mart in the repository. When you expand a mart it will display a 
list of all metrics and fields contained in the mart. This is the layer you will be most 
concerned with and will be the one that you edit directly.

• Business Model and Mapping layer – this pane represents the logical structure of the 
information in the OII repository
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• Physical Layer – this pane represents the physical structure of the data sources to which 
the OBIEE Server submits queries. 

ADDING A NEW USER TO THE OII REPOSITORY
To add a new user to the OII Repository:

1. From the top menu, select Manage>Security. The Security Manager appears.

Figure 4: Security Manager

2. From the menu, select Action>New>User. The Add New User screen opens:
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Figure 5: Add New User Screen

3. Enter the information at the fields on this screen as required. 

4. Check the appropriate group(s) that you want to assign to the user. There are five OII 
groups:

• Actuary
• Claims Management
• Executive
• Production
• Underwriting

Note The administrator can also add users to groups within OII. 
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5. Click OK after you have entered the user information and selected the groups. 

Figure 6: New User Information

6. Close the Security Manager.

7. On the top menu, click on the Checkin icon (the one with the red arrow).

8. Save the OII repository.

9. Close the OII repository and exit from the Administration Tool.

10. Open the Oracle Business Intelligence screen for OII and login as the Administrator.

11. Log out of the OBIEE.

12. Log into OBIEE as the new user.

13. Log out.

The new user has now been added to the OBIEE.



Chapter 2 – Managing the OII Repository

8

EDITING A USER
To edit a user in the OII Repository:

1. From the top menu, select Manage>Security. The Security Manager appears.

Figure 7: Security Manager

2. In the left frame click on the Users icon. The accounts in the frame of the right will be 
sorted alphabetically by user. 

3. Double-click on a user. A dialog box will appear and ask you if you want to check out 
the selected user.

4. Select Yes and the User box opens:
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Figure 8: Edit User

5. Edit the user’s information and click the OK Button when you are through. 
 
The checkout icon on the top menu will become active.

6. On the top menu, click on the Checkin icon (the one with the red arrow).

7. Save the OII repository.

8. Close the OII repository and exit from the Administration Tool.

9. Open the Oracle Business Intelligence screen for OII and login as the Administrator.
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REMOVING A METRIC OR FILTER FROM THE REPOSITORY
On occasion, a need may arise to remove metrics or filter fields from the OII repository that 
are not applicable to users. The administrator can remove any metrics or fields from the 
Presentation Layer of the OII Repository so that they will not appear within the OBIEE. 

To Delete a Metric or Filter:
1. Expand the mart and category containing the metric or filter you want to delete.

2. Highlight the metric or filter and select Edit>Delete from the top menu. 
 
A dialog box will appear asking if you want to check the item out.

3. If you’re sure then click Yes in the dialog box. 
 
The item will be deleted and the Checkin icon on the menu will become active.

4. Click on the Checkin icon.

5. Click the Save icon.

6. Close the repository and exit the Administration Tool.

7. Log into OBIEE and go to the mart that contained the metric or filter. The deleted item 
will no longer appear in the interface.

Note The removal of any metric or filter from the OII Repository is permanent!
Before you delete any object from the Presentation Layer, ALWAYS make a backup of 
the OII Repository. 
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Chapter 3

Managing User Accounts in OBIEE
Once a user has been added to the OII Repository, the administrator will need to add them to 
the same group within OBIEE Presentation Catalog through the OBIEE Presentation 
Services Administration page within the OBIEE GUI.

OPENING THE OBIEE ADMINISTRATION PAGE
1. Log into OBIEE as an Administrator.

Figure 9: The OBIEE Home Page
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2. Click on Settings>Administration.

Figure 10: Administration Menu in OBIEE

The OBIEE Presentation Services Administration page opens:

Figure 11: OBIEE Presentation Services Administration

This screen allows you to manage various aspects of the OBIEE interface. For our intents and 
purposes, this document only discusses the features that relate to managing user accounts. 
For a comprehensive discussion of the OBIEE Presentation Services Administration screen, 
refer to the Oracle Business Intelligence Presentation Services Administration Guide.
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ADDING A MEMBER TO A GROUP
Users can be assigned to one or more of the five OII groups when they are initially added to 
the OII repository using the Oracle Administrative Tool. After the user is created, you can 
use the Administrative link in OBIEE to assign them to other groups.  
To add a member to a group, follow these instructions:

1. The new user account needs to be logged in at least once prior to this step so that it would 
be available in the Presentation Catalog Users List. Just login as that user with the 
matching password and logout. Then login as the Administrator again.

2. On the OBIEE Presentation Services Administration screen, click the Manage 
Presentation Catalog Groups and Users link under the Activities section.

3. The Presentation Catalog Security: Groups and Users screen opens.

Figure 12: Groups and Users Screen

This screen lists the five OII groups along with the Administrator group. To view all current 
users and groups in alphabetical order, click on the Show users and groups link:

Figure 13: All Current Users and Groups in the System
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4. Click on the  icon in the row of the group that you want to add a user to. For this 
example we will add a member to the Underwriting group.

5. The Edit Catalog Group screen opens. 
 
The Group Membership section of the screen lists all of the current members of the 
selected group. In the figure below the Underwriting group has two other groups as 
members: Claims management and Executive. This means that all members of these two 
groups also belong to Underwriting.

Figure 14: Edit Catalog Group Screen

6. Click on the Add New Member link. 

The Add Member to Group screen opens. 

Figure 15: Add Member to Group Screen



Adding a Member to a Group

15

7. Click on the Add link in the row of the group or user that you want to add to the group. 
 
You will be returned to the Edit Catalog Group screen. Under the Group Membership 
section you will see the new user under the list of members.

Figure 16: User is Added to the Group

8. Click the Finished button in the right hand corner of the screen. You will be returned to 
the Presentation Catalog Security: Groups and Users screen.

9. Click on the Finished button on this screen. You will be returned to the OBIEE 
Presentation Services Administration Screen. 

10. Click Close Window to close this window.
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DELETING A MEMBER OF A GROUP
To delete a member from a group, follow these instructions:

1. Select the Manage Presentation Catalog Groups and Users link on the OBIEE 
Presentation Services Administration screen to open the Presentation Catalog 
Security: Groups and Users screen.

Figure 17: Presentation Catalog Security: Groups and Users Screen

2. Click on the  icon in the row of the group that contains the user that you want to 
delete. The Edit Catalog Group screen opens.

3.  Under the Group Membership section of the screen, click the  icon in the row on the 
member. The screen will refresh and the user will be removed from the list.

4. Click the Finished button. You will be returned to the Presentation Catalog security: 
Groups and Users screen.

5. Clicked the Finished button on this screen. You will be returned to the OBIEE 
Presentation Services Administration Screen. 

6. Click Close Window to close this window.
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Chapter 4

Creating an Oracle ODBC Data Source
As part of the post-installation configuration steps for OBIEE (see the OII Installation 
Guide) you must create two separate Oracle ODBC data sources to connect to the OBIEE 
Server: 

• ODBC Data Source 1:The first ODBC data source must be named Insight700 with a 
user name OII_DM. 

• ODBC Data Source 2: The second ODBC data source must be named 
Insight700Config with a user name of OII_SYS.

STEP 1: CREATE A CLIENT CONNECTION 
1. Open Net Manager by selecting:  

 
All Programs >Oracle – OraClient11g_home1>Configuration and Migration 
Tools>Net Manger

Figure 18: Oracle Net Manager Welcome Screen

Note Oracle Database Client 11g must be installed on your machine in order to create an 
Oracle ODBC data source. 
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2. In the menu on the left, expand the Local and then the Service Naming node.

3. Highlight the Service Naming node and click the ‘+’ button to the left of the menu tree. 
The Net Service Wizard: Welcome screen displays.

Figure 19: Welcome Screen

4. Enter a Net Service Name. The name may be any name you choose.

5. Click on Next. The Protocol screen opens.

Figure 20: Protocol Screen
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6. Keep the default selection (“TCP/IP (Internet Protocol)”) and click on Next. The 
Protocol Settings screen opens.

Figure 21: Protocol Settings Screen

7. Enter the following settings on the Protocol Settings screen:

a. Host Name: The TCP/IP host name where the database server is located.

b. Port Number: Keep 1521 as the default. This is the standard default for Oracle 
databases.

8. Click Next. The Service screen opens. 

Figure 22: Service Screen
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9. Specify the following settings on the Service Name screen:

a. Service Name: The Service Name name may be any name you choose. In this 
example we will call it OII_CONNECT.

b. Connection Type: Accept Database Default (this is the default selection).

10. Click on Next. The Test screen opens.

Figure 23: Test Screen

11. Click on the Test button to test the database connection. The Connection Test screen 
will appear and confirm whether or not the connection was achieved with the information 
that you provided on the previous screens.

• If the connection failed then click the Close button on the Connection Test screen 
and verify the information that you provided on the previous screens was correct.

• If the connection was a success, click the Close button to close the Connection Test 
screen.
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12. Click on Finish on the Test screen. The main Net Manager screen opens and the 
connection you just created (OII_CONNECT) will appear under the Service Naming 
folder.

Figure 24: The New Connection Appears Under Service Naming Folder

13. Click on File>Save Network Configuration to save the connection.

14. Select File>Exit to close the screen.
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STEP 2: CREATE AN ORACLE ODBC DATA SOURCE
Ymust create two separate Oracle ODBC data sources to connect to the OBIEE Server: 

• ODBC Data Source 1:The first ODBC data source must be named Insight700 with a 
user name OII_DM. 

• ODBC Data Source 2: The second ODBC data source must be named 
Insight700Config with a user name of OII_SYS.

Follow these steps to create a data source:

1. Select All Programs>Oracle – OraClient11g_home>Configuration and Migration 
Tools>Microsoft ODBC Administrator.  
 
The ODBC Data Source Administrator window will display.

Figure 25: ODBC Data Source Administrator Screen

2. Click on the “System DSN” tab. 

3. Click on the Add button. The Create New Data Source screen appears.
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4. Scroll down and select Oracle in OraClien11g_home1.

Figure 26: Select “Oracle in OraClient11g_home1”

5. Click on Finish. The Oracle ODBC Driver Configuration window opens. 

Figure 27: Driver Configuration Screen

6. Enter the following information in this window:

a. Data Source Name: Enter Insight700 as the Data Source Name.

b. Description: Enter an optional descirption.
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c. TNS Service Name: Select the appropriate “TNS Service Name” from the 
drop-down list that you created in the previous section.

d. User ID: Enter OII_DM as the name of the schema.

Figure 28: Driver Configuration Screen Entries

7. Click on the Test Connection button. The Oracle ODBC Driver Connect window will 
display. 

Figure 29: Driver Connect Window

8. Type in the correct password. 

9. Click on OK. A “Connection successful” message box will display. 

10. Click on OK to close this message box.
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11. Click on OK on the Oracle ODBC Driver Connect window. The new data source is 
listed in the System DSN tab of the ODBC Data Source Administrator window.

Figure 30: New ODBC Data Source

12. Repeat the steps in this section to create a second ODBC data source connection with:

• Data Source Name: Insight700Config

• User ID: OII_SYS

Figure 31: ODBC Data Source 
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