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This document provides late-breaking information as well as information that is not 
yet part of the formal documentation.

This document contains the following sections:

■ Changes in this release

■ Supported TimesTen releases and platforms

■ Prerequisites

■ Known problems and limitations

Changes in this release
This section lists changes in this release:

■ Changes for Release 2.1.1 from Release 2.1

■ New features in SQL Developer 2.1

■ New features in SQL Developer 1.5

Changes for Release 2.1.1 from Release 2.1
■ If the set serveroutput off command is used before a PL/SQL block and the 

block calls procedures from the DBMS_OUTPUT package such as PUT_LINE, then 
output is no longer erroneously displayed in the Dbms Output pane while 
connected to a TimesTen database.

■ If you connect to a TimesTen database using a User specified DSN and a 
client/server connection, and the connection string contains settings for the 
TTC_SERVER_DSN, TTC_SERVER and TCP_PORT attributes, you can 
successfully connect to the database. When you attempt to view the DDL 
statement used to create a particular database element in the SQL tab of the 
element’s tab, a ttSchema utility error is no longer returned and you can 
successfully view the statement.
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New features in Release 2.1.1
■ You can cache an Oracle table that contains columns of data type BLOB, CLOB, or 

NCLOB. In the corresponding TimesTen cache table, an Oracle BLOB column must 
be mapped to a TimesTen VARBINARY column, an Oracle CLOB column must be 
mapped to a TimesTen VARCHAR2 column, and an Oracle NCLOB column must 
be mapped to a TimesTen NVARCHAR2 column.

VARBINARY, VARCHAR2, and NVARCHAR2 data types have a size limit of 
4 MB. Data that exceed the user-defined column size are truncated at run time.

Caching Oracle BLOB, CLOB and NCLOB columns is available in TimesTen 
Releases 11.2.1.5.0 and later.

New features in SQL Developer 2.1
■ You can create, drop, load, refresh, unload and flush cache groups. You can also 

view and alter the characteristics of a cache group such as its automatic refresh 
attributes, as well as view the definition of the cache group and its cache tables.

■ You can set or change the cache administration user.

■ You can define an aging policy on regular tables or cache tables. You can also view 
and alter the aging properties of a table.

■ You can change the memory usage thresholds and aging cycle for all tables that 
have an LRU aging policy defined. 

■ You can start and stop the cache agent and replication agent processes.

■ You can update and view the table and column statistics used by the query 
optimizer.

■ You can view the execution plan of a statement.

New features that apply to TimesTen 11g and later
■ You can create a bitmap index on a table.

■ You can create, drop, edit, compile, run, view the characteristics and details of, and 
export the DDL of PL/SQL packages, procedures and functions. (PL/SQL 
functionality is available on Microsoft Windows 32-bit systems in TimesTen 
Releases 11.2.1.4.0 and later, and Microsoft Windows 64-bit systems in TimesTen 
Releases 11.2.1.5.0 and later.)

■ You can grant privileges to and revoke privileges from a particular user on 
database elements such as regular and cache tables, regular and materialized 
views, sequences, and PL/SQL packages, procedures and functions. You can also 
view the privileges granted to all users on a particular database element.

■ The following ttIsql utility command is supported in SQL Worksheet: set 
serveroutput
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New features in SQL Developer 1.5
■ Both direct-linked and client/server connections to TimesTen In-Memory 

Database and In-Memory Database Cache are supported.

■ The Connections navigator supports the following database objects: cache groups, 
replication schemes, tables, views, indexes, sequences and materialized views.

■ You can view the definitions and the properties including the SQL CREATE 
statements associated with the database objects from the Connections navigator. 

■ The Connections navigator supports creation and modification of tables, views, 
indexes, sequences and materialized views. 

■ Within the Data tab, you can view, sort, search and edit data in existing tables, 
including cache tables and replicated tables.

■ You can use SQL Worksheet to compose and execute TimesTen SQL statements, 
call TimesTen built-in procedures and run SQL scripts. 

■ The following ttIsql utility commands are supported in SQL Worksheet: desc, 
autocommit, version and dssize

■ Data from Oracle and TimesTen tables can be exported in the ttBulkCp utility text 
file format. 

■ Supports the creation of TimesTen user-defined reports.

Supported TimesTen releases and platforms
SQL Developer 2.1 is available on 32-bit and 64-bit Microsoft Windows and Linux 
systems. SQL Developer 2.1 supports TimesTen In-Memory Database and Oracle 
In-Memory Database Cache Releases 7.0.5 and later, and 11.2.1.2.0 and later, and can 
be used to connect to a TimesTen database that resides on any platform that is 
supported by the TimesTen software.

Prerequisites
Before you can use SQL Developer to connect to a TimesTen database:

1. Install TimesTen 7.0.5 or later release, or TimesTen 11.2.1.2.0 or later release of the 
TimesTen Data Manager or TimesTen Client on the same system as SQL 
Developer. If SQL Developer will be used to connect to a local database, at 
minimum install the TimesTen Data Manager on the same system as SQL 
Developer. If SQL Developer will be used to connect to a remote database, at 
minimum install the TimesTen Client on the same system as SQL Developer.

2. Execute the TimesTen_install_dir/bin/ttenv.sh or 
TimesTen_install_dir/bin/ttenv.csh shell script on Linux systems, or the 
TimesTen_install_dir\bin\ttenv.bat batch file on Microsoft Windows 
systems to set the TimesTen environment variables before starting SQL Developer. 

3. Make sure the CLASSPATH environment variable includes the proper TimesTen 
JDBC driver file (TimesTen_install_dir/lib/ttjdbc6.jar on Linux 
systems or TimesTen_install_dir\lib\ttjdbc6.jar on Microsoft 
Windows systems). SQL Developer 2.1 requires Java Development Kit (JDK) 6 be 
installed.
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Known problems and limitations
■ When you use a named connection to connect to a TimesTen database and the 

Save Password check box in the connection’s New/Select Database Connection 
dialog box is not selected, you cannot perform any cache group operations such as 
creating or loading a cache group even if a password for the Oracle user was 
specified in the Oracle Password (for Cache) field. A "No Oracle password found 
in connection" error is returned when attempting to perform a cache group 
operation.

Also, if the Save Password check box is not selected, you cannot view the DDL 
statement for any database element such as a table or view in the element’s SQL 
tab.

■ If the "Autocommit in SQL Worksheet" check box is not selected, then TimesTen 
SQL operations within the Connections navigator are not always automatically 
committed. The user must issue an explicit commit by either clicking the Commit 
button or by issuing the commit command in SQL Worksheet. If the operation 
encounters any errors, it must be explicitly rolled back by either clicking the 
Rollback button or by issuing the rollback command in SQL Worksheet.

If the "Autocommit in SQL Worksheet" check box is selected, then TimesTen SQL 
operations within the Connections navigator are automatically committed. A 
transaction in SQL Worksheet is also automatically committed if there are no open 
tables in the transaction. If there are open tables, then the transaction in the 
worksheet is not automatically committed and the user must issue an explicit 
commit by either clicking the Commit button or by issuing the commit command 
in SQL Worksheet.

To access the "Autocommit in SQL Worksheet" check box, select Tools > 
Preferences. Then in the Preferences dialog box click the + to the left of the 
Database node to expand the node and select Worksheet.

■ Setting the passthrough level to a value other than 0 can affect the SQL operations 
in the Connections navigator. Make sure this setting is reset to 0 when switching 
from issuing passthrough operations in SQL Worksheet back to the Connections 
navigator.

You can also create an unshared worksheet which uses a separate database 
connection from the Connections navigator so that a particular passthrough level 
setting applies only that worksheet. From a shared worksheet, click the Unshared 
SQL Worksheet icon or press Ctrl+Shift+N to create an unshared worksheet.

■ If you click the + to the left of the Indexes node to view the list of indexes, and 
then click the name of the index that you want to view the characteristics of, you 
cannot view the index’s DDL statement because the SQL tab is missing. To view 
the CREATE INDEX statement, click the SQL tab on the index’s underlying table 
or materialized view.

■ You can issue the desc command in SQL Worksheet to display column definitions 
for a table or a view. However, displaying the column definitions for a SQL 
statement or PL/SQL package, procedure or function are not currently supported.

■ If you right-click the Tables node and select Apply Filter, or click the Apply Filter 
icon, then in the Filter dialog box select = instead of LIKE to find an exact match of 
a table name.
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■ Before you right-click the name of a table in an Oracle database and select
Export Data > ttbulkcp to export the data in a format that is compatible with the 
TimesTen ttBulkCp utility, set the format for DATE and TIMESTAMP data using 
the following instructions:

1. Select Tools > Preferences.

2. In the Preferences dialog box click the + to the left of the Database node to 
expand the node.

3. Select NLS.

4. In the Date Format field, specify RRRR-MM-DD

5. In the Timestamp Format field, specify DD-MON-RRRR HH24:MI:SSXFF

You can change the DATE and TIMESTAMP data format back to their original 
settings after the data has been exported.

■ If you right-click a data cell in the Data tab of a TimesTen table and select Export 
Data > ttbulkcp, a TimesTen error may be returned or a Java exception may be 
thrown. The workaround is to select Export Data > ttbulkcp either from the 
Actions pull-down menu in any of the table’s tabs or after you right-click the 
name of the table.

■ You can right-click the name of a table and select Export Data > ttbulkcp to export 
data from the table in a format that the ttBulkCp utility recognizes. After you 
select Export Data > ttbulkcp, the Export Data dialog box appears. If you click the 
Browse button in the Export Data dialog box, the Export File Chooser dialog box 
appears. In the File Encoding pull-down menu of the Export File Chooser dialog 
box, you must select UTF-8 if the exported data is to be imported into a table in a 
TimesTen database using a ttBulkCp -i utility command because all other file 
encodings are not supported.

■ In TimesTen 7.0 and 11g releases up to and including 11.2.1.3, if you connect to a 
TimesTen database with a client/server connection, you cannot view the DDL 
statement for any database element such as a table or view in the element’s SQL 
tab. Also, you cannot export the DDL of PL/SQL packages, procedures and 
functions.

■ For a table that has a time-based aging policy defined, you cannot view its DDL 
statement within the table’s SQL tab in the following situations involving 
particular releases of the TimesTen JDBC driver being used and the version of the 
TimesTen database that contains the table:

- TimesTen 7.0.6.0 JDBC driver and TimesTen 7.0.5 database

- TimesTen 11.2.1.4 JDBC driver and TimesTen 7.0.5 database

- TimesTen 11.2.1.4 JDBC driver and TimesTen 11g database up to and including 
11.2.1.3

In the first case, you must use a TimesTen 7.0.6.1 or later JDBC driver. In the 
second case, you must upgrade the TimesTen database to release 7.0.6.1 or later, or 
11.2.1.4 or later. In the third case, you must upgrade the TimesTen database to 
release 11.2.1.4 or later.
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■ In TimesTen 7.0 and 11g releases up to and including 11.2.1.3, if a user in a 
TimesTen database does not own any tables, you cannot use SQL Developer to 
create an element within that user’s schema by right-clicking the node 
corresponding to the element type within that user’s node and selecting New 
ElementType or Create (simple). You must first create a table owned by that user 
using a command-line interface such as the ttIsql utility, or within SQL Developer 
using SQL Worksheet.

■ If autocommit is disabled and DDL statements are not automatically committed, 
you cannot view the results of an uncommitted DDL operation performed from 
SQL Developer when you click the database element’s SQL tab until the operation 
is explicitly committed.

Issues that apply to TimesTen 11g and later
■ In TimesTen 11g releases up to and including 11.2.1.5, a user that has not been 

granted the ADMIN privilege cannot create PL/SQL objects such as procedures, 
functions, and packages even if the user has been granted the CREATE 
PROCEDURE or CREATE ANY PROCEDURE privilege. The workaround is to 
grant the SELECT privilege on the SYS.SYSTEM_PRIVILEGE_MAP system table 
to the PUBLIC role. 

■ An "agent status cannot be determined" error is returned when you attempt to 
start the cache agent or the replication agent as a user that has not been granted 
the ADMIN privilege. The same error is returned when you attempt to perform an 
operation that is to be processed by the cache agent such as loading or refresh a 
cache group.

This problem is fixed in TimesTen Releases 11.2.1.5.0 and later. Granting the 
CACHE_MANAGER privilege to the user is sufficient to perform these 
operations.

■ When you execute a PL/SQL procedure or function, its output is written to the 
Script Output pane but not to the Dbms Output pane that is accessible by 
selecting View > Dbms Output.

■ The hierarchical profile and debugging of PL/SQL procedures and functions in a 
TimesTen database are not supported.

Issues that apply only to TimesTen 7.0
■ Unlike the Oracle database, TimesTen does not implicitly commit and roll back 

DDL transactions. These transactions can be rolled back like DML statements.

If you select Tools > Preferences, then in the Preferences dialog box click the + to 
the left of the Database node to expand the node, select Worksheet but do not 
select the "Autocommit in SQL Worksheet" check box, TimesTen SQL operations 
are not automatically committed. This applies to both SQL Worksheet and the 
DDL operations available within the Connections navigator. The user must 
explicitly commit the transaction by either clicking the Commit button or by 
issuing the commit command in SQL Worksheet.

■ DDL operations fail with error 'TT0941: Execution of operation not possible - 
dependent object is in use' when the Data tab is being viewed. A SELECT cursor is 
opened when rows are being viewed in the Data tab. Certain DDL statements such 
as ALTER TABLE .. ADD COLUMN are not allowed in TimesTen when a SELECT 
cursor is opened on the same table. The workaround is to ensure that the Data tab 
is not viewing the same table that you are issuing DDL statements on.
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■ If a user does not own any tables or materialized views, SQL Developer does not 
detect the user and, therefore, perceives that the user does not exist. You must use 
a TimesTen application such as the ttIsql utility to create a table or materialized 
view owned by that user in order for SQL Developer to determine that the user 
exists.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible to all users, including users that are disabled. To that end, our 
documentation includes features that make information available to users of assistive 
technology. This documentation is available in HTML format, and contains markup to 
facilitate access by the disabled community. Accessibility standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be 
accessible to all of our customers. For more information, visit the Oracle Accessibility 
Program Web site at http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an 
otherwise empty line; however, some screen readers may not always read a line of text 
that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or 
organizations that Oracle does not own or control. Oracle neither evaluates nor makes 
any representations regarding the accessibility of these Web sites.

Deaf/Hard of Hearing Access to Oracle Support Services
To reach Oracle Support Services, use a telecommunications relay service (TRS) to call 
Oracle Support at 1.800.223.1711. An Oracle Support Services engineer will handle 
technical issues and provide customer support according to the Oracle service request 
process. Information about TRS is available at 
http://www.fcc.gov/cgb/consumerfacts/trs.html, and a list of phone 
numbers is available at http://www.fcc.gov/cgb/dro/trsphonebk.html.
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