|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Information Library|
- profile description database
/etc/security/prof_attr is a local source for execution profile names, descriptions, and other attributes of execution profiles. The prof_attr file can be used with other profile sources, including the prof_attr NIS map. Programs use the getprofattr(3C) routines to gain access to this information.
The search order for multiple prof_attr sources is specified in the /etc/nsswitch.conf file, as described in the nsswitch.conf(4) man page.
An execution profile is a mechanism used to bundle together the commands and authorizations needed to perform a specific function. An execution profile can also contain other execution profiles. Each entry in the prof_attr database consists of one line of text containing five fields separated by colons (:). Line continuations using the backslash (\) character are permitted. The format of each entry is:
The name of the profile. Profile names are case-sensitive.
The characters RO in this field indicate it is read only and not modifiable by the tools that update this database.
Reserved for future use.
A long description. This field should explain the purpose of the profile, including what type of user would be interested in using it. The long description should be suitable for displaying in the help text of an application.
An optional list of semicolon-separated (;) key-value pairs that describe the security attributes to apply to the object upon execution. Zero or more keys can be specified. The following keys are currently interpreted by the system:
help is assigned the name of a file ending in .htm or .html.
auths specifies a comma-separated list of authorization names chosen from those names defined in the auth_attr(4) database. Authorization names can be specified using the asterisk (*) character as a wildcard. For example, solaris.printer.* would mean all of Sun's authorizations for printing.
audit_flags specifies per-user Audit preselection flags as colon-separated always-audit-flags and never-audit-flags. For example, audit_flags=always-audit-flags:never-audit-flags. See audit_flags(5).
profiles specifies a comma-separated list of profile names chosen from those names defined in the prof_attr database.
defaultpriv and limitpriv have the same semantics as in user_attr(4). If they are not specified in the user_attr database, the assigned profiles are searched until a match is found.
audit_flags specifies per-user audit preselection flags as a colon-separated list of always-audit-flags and never-audit-flags values, for example, audit_flags=always-audit-flags:never-audit-flags. See audit_flags(5).
Example 1 Allowing Execution of All Commands
The following entry allows the user to execute all commands:
All:::Use this profile to give a :help=All.html
Example 2 Consulting the Local prof_attr File First
With the following nsswitch.conf entry, the local prof_attr file is consulted before the NIS map:
prof_attr: files nis
Locally added entries. Make sure that the shipped header remains intact.
Entries added by package installation.
The root user is usually defined in local databases because root needs to be able to log in and do system maintenance in single-user mode and at other times when the network name service databases are not available. So that the profile definitions for root can be located at such times, root's profiles should be defined in the local prof_attr file, and the order shown in the example nsswitch.conf(4) file entry under EXAMPLES is highly recommended.
Because the list of legal keys is likely to expand, any code that parses this database must be written to ignore unknown key-value pairs without error. When any new keywords are created, the names should be prefixed with a unique string, such as the company's stock symbol, to avoid potential naming conflicts.
Each application has its own requirements for whether the help value must be a relative pathname ending with a filename or the name of a file. The only known requirement is for the name of a file.
The following characters are used in describing the database format and must be escaped with a backslash if used as data: colon (:), semicolon (;), equals (=), and backslash (\).
The following authorizations are required to set various fields:
prof namename of profile solaris.profile.manage desc description of profile solaris.profile.manage help html help file name solaris.profile.manage of profile auths authorizations granted solaris.auth.assign/delegate profiles profiles granted solaris.profile.assign/delegate privs privileges granted solaris.privilege.assign/delegate limitpriv the limit set of solaris.privilege.assign/delegate privileges for the command process defaultpriv the inheritable set of solaris.privilege.assign/delegate privileges for the command process
The value of limitpriv that can be set by an authorized user for a given command are limited to the limitpriv privilges that are granted to the user.
The value of the defaultpriv that can be set by an authorized user for a given command are limited to the defaultpriv privileges granted to the user.
The solaris.auth.assign authorization allows the authorized user to grant any authorization to another user. The solaris.auth.delegate allows the authorized user to grant only the user's authorizations to another user. The same principle applies to profiles, privileges.