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Preface

Oracle's StorageTek SL8500 modular library system is an enterprise storage solution 
that provides fully automated tape-cartridge storage and retrieval. This guide 
provides a general overview of the tape library and covers installation planning, 
configuration, and operation of the library.

Related Documentation
Additional SL8500 library documentation can be found at: 
https://docs.oracle.com/en/storage/tape-storage/index.html

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support 
through My Oracle Support. For information, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

IMPORTANT: Starting with FRS_8.67, the content of this document 
has been frozen. All subsequent product updates are documented 
within the SL8500 Release Notes. Refer to that document for the latest 
changes and product update information.
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1Library Overview

■ Library Modules

■ Hardware Components

■ Storage Capacity

■ Power Configuration Options

■ Optional Library Features

■ Networking and Communication

■ Library Monitoring

■ Library Management Software

■ Ordering

Library Modules 
Customer Interface Module (CIM)
There is one CIM at the front of the library which contains:

■ 648 data cartridge slots, 198 slots for diagnostic and cleaning cartridges, and 24 
end slots or targeting and drop-off

■ Touch screen operator panel and keypad

■ Two load-sharing DC power supplies 

■ Service safety door for maintenance activity

■ CAPs and two elevator assemblies that transfer up to four cartridges each between 
rails

Storage Expansion Module (SEM)
A library can have up to five SEMs. Each SEM contains 1,728 customer-usable data 
cartridge slots.

Robotics Interface Module (RIM)
In a basic library, the RIM is between the DEM and CIM. In a library with additional 
storage, the RIM is between the DEM and a SEM. The RIM contains 800 data cartridge 
slots, pass-thru ports (PTPs) used to connect adjacent libraries in a library complex, 
and access to the front of the drives.
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Drive and Electronics Module (DEM)
There is one DEM at the rear of the library which contains the AC power distribution 
units (PDUs), load sharing DC power supplies, four accessory racks, electronics 
control module, and tape drive bay with 64 slots.

Figure 1–1 Drive Expansion Module (rear view)

Figure Legend:

1. Accessory rack

2. Drive bay

3. DC power supplies

4. Ethernet switches

5. Electronics control module

6. AC PDUs
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Figure 1–2 Library Modules (top view)

Figure Legend:

1. AC power and electronics control module

2. DC power supplies

3. Tap drive bay

4. Accessory rack

5. Inner wall cartridge slots

6. Reserved slots (E = end stop, X = diagnostic cartridge)

7. Operator panel

8. Elevators

9. Service safety door

Hardware Components
■ Electronics Control Module

■ Cartridge Access Ports (CAPs)

■ Robotics

■ Elevators

■ Pass-thru Ports (PTPs)

■ Library Cameras

■ Accessory Racks

■ Keypad

■ Local Operator Panel

■ Service Safety Door
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Electronics Control Module
The electronics control module (ECM) is responsible for electronics control, robotic and 
drive control, and host connectivity. The ECM is located in the rear of the library in the 
DEM. The main controller cards are the HBCR (library controller) and HBT (drive 
controller).

Figure 1–3 Electronics Control Module

Figure Legend:

1. Serial port (reserved)

2. Serial port (CLI port for service representatives)

3. Primary Ethernet port

4. Dual TCP/IP Ethernet port

5. Ethernet port (reserved)

Command-Line Interface (CLI)
The command-line interface (CLI) is used by Oracle support to configure and diagnose 
the library. Service representatives can access the CLI through the electronics control 
module:

■ Serial Port Connection on the HBCR card (RS-232) and a HyperTerminal 
connection to enter the commands.

■ Ethernet Port Connection (ports 1A, 2A, or 2B) on the HBCR card and a secure 
shell (PuTTY) to enter the commands.

Redundant Electronics Option
The optional redundant electronics (RE) feature provides failover protection with a 
second set of controller cards including HBCR, HBT, HBS, and an internal Ethernet 
switch. If an active controller experiences errors, operations switch automatically to a 
stand-by controller, with minimal disruption to library and host operations. For more 
information, see "Redundant Electronics Overview" on page D-1.

Cartridge Access Ports (CAPs)
CAPs import and export cartridges. There are two types of CAPs:

■ Bulk CAP

■ Rotational CAPs (legacy)

An SL8500 library cannot contain both CAP types. It may contain either the bulk CAP, 
or a maximum of two rotational CAPs.
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Bulk CAP
The bulk CAP consists of eight CAPs located on the front access doors of the library. 
There are two CAPs per rail, each with 36 slots (three 12-slot magazines). The library 
now comes standard with bulk CAPs. To upgrade a library with rotational CAPs to the 
bulk CAP, see "Cartridge Access Ports" on page 1-20.

Figure 1–4 SL8500 Internal view (with bulk CAP)

Figure Legend:

1. Rails, numbered 1 to 4 (top to bottom)

2. Closed CAP

3. Open CAP with three 12-slot magazines

Rotational CAPs
A rotational CAP consists of 39 slots (three 13-slot magazines). The library came 
standard with one rotational CAP, with the option for an additional rotational CAP. 
Rotational CAPs are located on the right front access door. A single rotational-CAP 
spans across rails 2, 3, and 4. Entering or ejecting cartridges from rail 1 requires an 
elevator operation.
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Figure 1–5 SL8500 Internal View (with rotational CAPs)

Figure Legend:

1. Rails, numbered 1 to 4 (top to bottom)

2. Rotational CAPs

Robotics
Robots move cartridges between CAPs, elevators, PTPs, storage slots, and tape drives. 
Each library can have either four (standard) or eight robots (redundant robotics 
option). The four rails of the library provide power and communication to the robots.

Elevators
An elevator moves cartridges vertically between rails. There are two 4-slot elevators in 
the front of the library, between the front access doors and the service safety door of 
the CIM. 

Pass-thru Ports (PTPs)
A PTP moves up to two cartridges at a time horizontally between two libraries in a 
library complex. A separate frame, installed between two adjacent libraries, houses 
four PTP mechanisms — one PTP for each rail. The PTPs are located on the curved 
sections of the RIM near the tape drives (see Figure 1–2). Installing or servicing a PTP 
does not interrupt existing library operations. Each PTP slides out of the frame from 
the rear of the library for servicing.

Plan ahead before adding a new library to a complex. Although the library complex 
can expand in either direction, adding a new library to the left (when viewed from the 
front) is less disruptive (see "Pass-thru Port Planning" on page 2-11).



Hardware Components

Library Overview 1-7

Library Cameras 
A camera system (WebCam) allows you to remotely see the inside of the library. There 
is one camera on each side (left/right) of the library, mounted in the upper frame of 
the front access door. The library cameras use third party monitoring software and 
attach to a 10Base-T/100Base-TX Ethernet connection to provide remote audio and 
video. The table below lists the library camera specifications:

Accessory Racks 
The SL8500 library provides space for four 19 inch racks. Each rack is 6U (U = 4.4 cm 
(1.75 in.)) and oriented so the components mount vertically. Oracle cannot mandate 
what equipment you install, however you should follow the guidelines below to 
prevent voiding the warranty. 

Keypad 
There is a keypad on the front of the library with: 

■ Two buttons to open and close the CAPs. 

■ Eight LEDs that indicate library activity and status. 

OS Compatibility Windows 7, Vista, XP SP3

Minimum Browser Requirements Windows Explorer 6.0 SP3

Dimensions Depth: 74mm (2.9 in.); Width: 100mm (3.9 in.); Height: 100mm (3.9 in.)

Weight: 345 g (12.2 oz or 0.76 lb)

Connectivity Ethernet 10Base-T/100Base-TX

Camera ¼ MOS color sensor, 1.3 megapixels

Min illumination: 0.6 lx color, 0.5 lx black/white

Video Max resolution: 1280x960 at 30fps; 8x Digital Zoom

H.264 digital video format; NTSC video format

Audio Built-in microphone, two way audio capable

Table 1–1 Rack Specifications

Description Value/Range

Maximum weight The accessory rack is mounted on slides rated for 80 kg (175 lb). Safe 
load is 64 kg (140 lb).

Mounting Components must function in a vertical position. Rails are not 
provided; use the mounting hardware supplied by the manufacturer. 

Height 48.25 cm (19 in.)

Width 27.3 cm (10.75 in.) including power strip

Depth 72 cm (28 in.) safe length is 66 cm (26 in.)

Mount-points 72.4 cm (28.5 in.) between mounting points

Thermal Requirements 880 watts (3,000 Btu/hr) maximum per rack module.

Air flow Two cooling fans. Maximum volume per 6u rack module is 241 scfm.

Power1

1 The N+1 power configuration supports racks 2 and 4. Powering racks 1 and 3 requires the 2N power 
configuration.

200–240 VAC, 50 to 60 Hz, 4 Amps maximum. Six IEC320 C13 outlet 
receptacles

Regulatory agency compliance Minimum requirements: Safety –UL or CSA and Electromagnetic 
–Class A certification from agencies such as the FCC or BSMI. 
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■ Two safety locks that allow service representatives to place the library in 
maintenance mode.

■ A red safety button that cuts power to the robots in the library.

Figure 1–6 Keypad

Figure Legend:

1. Emergency robotics stop switch (ERS)

2. Service safety door lock

3. Indicator

4. Lock/unlock CAP button (rotational CAPs only)

Local Operator Panel
The local operator panel is a 12-inch touch screen display on the front of the library. 
The panel uses StorageTek Library Console (SLC) software to access diagnostics, 
library status, library and drive monitoring, and functional information.

Service Safety Door
The service safety door is a sliding door that moves to the left or right side of the 
library, depending upon which maintenance lock is activated. Using the safety door 
places the library in service mode. The safety door separates the front maintenance 
area from the library interior so a service representative can safely replace a front 
frame component while the library remains fully operational.

Supported Tape Drives
■ StorageTek T-series T9840 A/B/C/D, T9940 B, and T10000 A/B/C/D

■ HP LTO generations 2, 3, 4, 5, and 6

■ IBM LTO generations 2, 3, 4, 5, 6, 7, and 8

■ Quantum SDLT 600 and DLT-S4

Note: Only qualified service representatives with a maintenance key 
can initiate service mode.



Power Configuration Options

Library Overview 1-9

For more information, see the tape drive section on the Oracle website: 
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/ove
rview/index.html

OKM Encryption-Compatible Tape Drives
■ StorageTek T10000 A, B, C, D 

■ StorageTek T9840 D

■ HP LTO generations 4, 5, 6

■ IBM LTO generations 4, 5, 6, 7

For more information, see "Tape Drive Encryption" on page 1-21.

Storage Capacity
The physical capacity of the library depends on the number of SEMs installed. Each 
SEM increases the slot count by 1,728 (excluding reserved slots). Physical capacity 
must be activated by a hardware activation file. Only activated slots can be used for 
data storage and accessed by a client. Inactivated slots are not recognized by the 
library. You can purchase active capacity in 100, 250, 500, and 1000 slot increments.

To configure capacity, see "Configuring Capacity" on page 6-1.

Power Configuration Options
The power configuration of the SL8500 library depends on the power source and 
power redundancy options you select.

Power Redundancy Options
There are two power redundancy options. To determine the number of load sharing 
power supplies required to support each option, see "DC Power Supplies" on 
page 1-11.

Note: LTO-8 drives can read and write one generation back. LTO-5, 
6, and 7 drives can read two generations back and write one 
generation back. For best capacity and performance, always use 
cartridges of the same generation as your drives.

Library Configuration
Rotational CAP Physical 
Cartridge Capacity

Bulk CAP Physical Cartridge 
Capacity 

Base configuration 1,448 1,360

One SEM 3,176 3,088

Two SEMs 4,904 4,816 

Three SEMs 6,632 6,544

Four SEMs 8,360 8,272

Five SEMs (maximum) 10,088 10,000 

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
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N+1 Power Configuration (standard)
■ Provides DC power redundancy by adding an additional load-sharing power 

supply to each DC power grid.

■ One load-sharing power supply for every two robots plus one redundant power 
supply.

■ One load-sharing power supply for every eight drives plus one redundant power 
supply. 

■ Contains two power distribution units (PDUs): one system PDU and one N+1 
PDU. 

■ Supports two racks (2 and 4).

2N Power Configuration
■ Provides both DC and AC redundancy

■ Provides one power supply for every four tape drives and one supply for every 
robot.

■ Requires a second AC power source for a second system PDU.

■ Supports all four racks.

AC Power Source Options
There are three external AC power options. A licensed electrician should connect the 
external power cables. For additional information, see "AC Power Connections" on 
page 1-11.

Delta
■ Requires one three-phase input for each system PDU.

■ 200–240 VAC, line-to-line, three-phase, 40 Amps, 50–60 Hz (mostly used in the 
United States).

■ Used when the voltage measured from phase-to-phase is 200-240 VAC.

■ Requires four wires (three phases plus ground). Does not use neutral (a fifth wire).

Wye
■ Requires one three-phase input for each system PDU.

■ 200–240VAC, line-to-neutral, three-phase, 24 Amps, 50–60 Hz (mostly used in 
Europe).

■ Used when the voltage measured from phase-to-phase is 380–415 VAC.

■ Requires five wires (three phases, ground, and neutral). Neutral (N) is required.

Single-phase
■ Requires three single phase inputs for each system PDU (three circuits for N+1 or 

six circuits for 2N)

■ 200–240 VAC, single phase, 24 Amps, 50–60 Hz
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AC Power Connections 
AC wiring from the power source branch circuit must be installed in conduit (flexible 
or rigid) with a 90-degree elbow-down fitting. If plugs and connectors are required 
instead of using conduit, the table below lists the Hubbell part numbers (or 
equivalent) to use. 

Circuit Breaker Ratings 
The minimum circuit breaker ratings required for the service panel are listed in the 
tables below. Wire size should be determined by the electrician.

DC Power Supplies
The tape drives and robots use the same 1200W DC power supplies. The number of 
DC load sharing power supplies required depends on the library configuration and 
power options selected. Use the tables below to determine the number of power 
supplies to order. For ordering information, see "Power Configurations" on page 1-23.

Table 1–2 Hubbell Connectors and Plugs (IEC 309) 

Description Part Number

Single Phase US plug 30 amp HBL330P6W 

Single Phase US connector 30 amp HBL330C6W 

Single Phase Europe plug 32 amp HBL332P6W 

Single Phase Europe connector 32 amp HBL332C6W 

Wye plug 32 amp HBL532P6W 

Wye connector 32 amp HBL532C6W 

Delta plug 60 amp HBL460P9W 

Delta connector 60 amp HBL460C9W 

NEMA Delta receptacle (250 V, 50 Amp) L15-50 R

NEMA Delta plug (250 V, 50 Amp) L15-50 P 

Table 1–3 Circuit Breaker Ratings

Option
Panel Breaker / 
Service Rating Connector PDU Breaker

Single Phase 30 Amps US — 30 Amps

Europe — 32 Amps

30 Amps

Delta 50 Amps US — 50 Amps (NEMA), 60 Amps (IEC 309)

Europe — 63 Amps

40 Amps

Wye 30 Amps US — 30 Amps

Europe — 32 Amps

30 Amps

Table 1–4 Tape Drive DC Power Supplies 

Quantity of Drives to Power Power Supplies Required for N+1 Power Supplies Required for 2N

0 - 16 3 4 

17 - 24 4 6 

25 - 32 5 8 

33 - 40 6 10 

41 - 48 7 12 

49 - 56 8 14 
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Power Usage

You can use an online power calculator to estimate the electrical and heat loads for 
typical operating conditions of a library configuration.:

http://www.oracle.com/us/products/servers-storage/sun-power-calculators/in
dex.html

Optional Library Features
The following features are optional features for the SL8500 library.

Partitioning
Library partitioning is an optional feature that reserves library resources for the 
exclusive use of specified hosts. Partitioning is enabled with a hardware activation file 
(see "Activating Optional Features" on page 5-1). You can partition a single library or a 
library complex using SLC.

Single Library Partitioning
■ Can contain up to eight partitions.

■ The smallest slot increment is one array.

■ The smallest drive increment is one drive.

Library Complex Partitioning
■ Can contain up to 16 partitions.

56 - 64 9 16 

Table 1–5 Robotics DC Power Supplies

Robotics Configuration Power Supplies Required for N+1 Power Supplies Required for 2N

Standard 3 4

Redundant 5 8

Table 1–6 SL8500 Power Specifications

Component Idle Watts Max Continuous Watts

Base Library 263 349

Redundant Robotics 92 154

Redundant Electronics 79 98

Pass-thru Ports (4 mechanisms) 80 92

Rack space (each) 68 720

T9840 drive (each) 79 100

T10000A/B/C drive (each) 61 93

T10000D drive (each) 64 127

LTO drive (each) 30 46

SDLT drive (each) 38 52

Table 1–4 (Cont.) Tape Drive DC Power Supplies 

Quantity of Drives to Power Power Supplies Required for N+1 Power Supplies Required for 2N

http://www.oracle.com/us/products/servers-storage/sun-power-calculators/index.html
http://www.oracle.com/us/products/servers-storage/sun-power-calculators/index.html
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■ The smallest slot increment is a quarter rail.

■ The smallest drive increment is one drive.

■ Partition boundaries can span across pass-thru ports (PTPs).

■ Requires minimum library firmware 8.31 and SLC 6.25.

■ Requires the following minimum level for library management software:

– ACSLS 8.3

– HSC 6.2: PTF L1H16SG (VM)

– ELS 7.0: PTF L1H15SI (MVS), ELS 7.1: PTF L1H16SJ, ELS 7.2: integrated

For more details about the partitioning feature, see "Partitioning the Library" on 
page 7-1.

Media Validation
Media validation allows you to verify all T10000 tape cartridge types using SLC. The 
following validation methods are available: Basic Verify, Standard Verify, and 
Complete Verify. Media validation provides a "pass" or "suspect" result for each tape 
cartridge tested.

Media validation requires a designated pool of T10000C or T10000D tape drives. Up to 
ten drives can be placed in the media validation pool using SLC. The drives in the pool 
are not available to hosts. The pool is not considered a partition and does not contain 
cartridges.

The media validation feature requires minimum firmware SL8500 FRS_8.31, SLC FRS_
6.25, and a high memory HBT card. For more information about media validation 
using SLC, see "Validating Media" on page 11-1.

Networking and Communication
The SL8500 library has several connectivity and network topology options. A TCP/IP 
connection provides the host library interface (HLI) used to communicate with library 
management applications such as ACSLS or ELS/HSC.

The library controller card is responsible for coordinating all component operations 
within the library and providing the interface connection with the host. There are two 
separate Ethernet connections for host to library communications—Ports 2A and 2B.

■ Port 2B provides the primary host connection (standard).

■ Port 2A provides the optional Dual TCP/IP connection or it can be used to connect 
to SLC.

Host Connectivity Options
There are several host connectivity options that offer flexibility and redundancy to 
support a variety of customer requirements:.

■ Dual TCP/IP provides two connections between a library or a library complex and 
an ACSLS or ELS/HSC host(s). Dual TCIP/IP avoids the single point of failure 
when there is only one connection between the library and the host. See "Dual 
TCP/IP Overview" on page E-1.

■ Multi TCP/IP provides multiple connections between a library complex and an 
ACSLS or ELS/HSC host(s). In addition to redundancy in connectivity, this feature 



Library Monitoring

1-14 StorageTek SL8500 Library Guide

also helps reduce contention and improve performance of the library and tape 
drives.  See "Multi TCP/IP Overview" on page F-1.

■ Redundant Electronics (RE) provides redundant library control and 
communications, and protects against failure should the active HBC/HBCR card 
fail or if communication to the card is lost. See "Redundant Electronics Overview" 
on page D-1.

Switched Fabric Topology 
In a switched fabric topology, all nodes on the storage area network connect to Fibre 
Channel switches that provide optimized, dynamic interconnections between nodes. 
When an SL8500 library is connected to a Fibre Channel switch or fabric-capable host, 
it automatically configures itself for switched topology. This configuration can support 
up to 16 million ports on the fabric.

To configure library-attached drives on an SL8500 library, you must use a switched 
fabric topology. The SL8500 library does not support tape drives configured in 
arbitrated loops.

Port Bonding
Port bonding combines multiple ports to create redundancy. The SL8500 library uses 
an active-backup mode. In active-backup mode, there is one bond with two slave 
ethernet interfaces. If the active interface fails, the backup interface becomes active. 
With minimum library firmware 8.31 and a second Ethernet switch installed in the 
library, port bonding is automatically enabled—no command or activation file is 
required.

Dynamic World Wide Name
The SL8500 library uses the dynamic World Wide Name (dWWN) feature. When 
enabled, dWWN assigns world wide names to the library drive slots rather than the 
drives themselves. Therefore, when a drive is replaced, it is assigned the same WWN 
as the drive it replaced, preventing reconfiguration of the network. Both library and 
tape drives must have microcode or firmware that supports the dWWN feature. 

With the dWWN feature enabled, tape drives do not keep their original WWNs when 
they are migrated between libraries. A drive that was previously known to the SAN 
under its own, drive-specific WWN will no longer be recognized. Therefore, you 
should configure all drive bay slots in the library and verify that the tape drive data 
path is bound correctly over the SAN.

Library Monitoring
The library can be monitored using SLC or Simple Network Management Protocol 
(SNMP). Additionally, service representatives can use the Log SnapShot feature to 
collect logs from the controller cards.

StorageTek Library Console (SLC)
SLC is a GUI application for configuring, monitoring, and managing the SL8500 
library. SLC is included with the purchase of an SL8500 library. You can access SLC 
from the local operator panel, a stand-alone version on a workstation, or through a 
browser. For installation requirements and additional information, see "Installing 
StorageTek Library Console" on page 3-1.
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Library Attach
Library Attach (LibAttach) for Windows Servers is a client application that enables 
Windows networks to use Oracle's StorageTek storage libraries. LibAttach provides 
the connection between a Windows application and ACSLS through a TCP/IP 
network.

LibAttach is included with the SLC download. No additional activation is required. 
For more information, refer to the Library Attach documentation on OTN.

Simple Network Management Protocol (SNMP)
SNMP is an application layer protocol that performs network management operations 
over an Ethernet connection. SNMP allows the library to inform the administrator of 
potential problems. The administrator can query the library for configuration, 
operation, and statistical informations using SNMP traps. The library supports SNMP 
v2c and SNMP v3.

There is a Management Information Base (MIB) on the controller card which contains 
information that describes the library, components, and configuration. For more 
information, see the StorageTek Tape Library SNMP Reference Guide.

Log SnapShot Feature
The Log SnapShot feature is a utility that gathers, compresses, and encrypts logs from 
a given controller card or from an entire library such as the SL8500 library. A log 
snapshot can be generated using the CLI or SLC. Only authorized Oracle 
representatives have access to the data obtained from the Log SnapShot utility.

Service Delivery Platform
The Service Delivery Platform (SDP) is a smart appliance that monitors the library and 
T-series drives. SDP provides remote diagnosis by logging device events and alerting 
Oracle support if there is an issue.

For more information, see "Service Delivery Platform" on page 1-25.

Library Management Software
Library management software controls the library by allocating drives and requesting 
library operations, such as entering, mounting, dismounting, and ejecting cartridges. 
Library management software manages the library database, which tracks volume 
identifiers (vol-ids), attributes, and locations of cartridges.

There are two main library management options:

■ Automated Cartridge System Library Software (ACSLS)

■ Enterprise Library Software (ELS)

Automated Cartridge System Library Software (ACSLS)
ACSLS is centralized, multi-platform library management software for an 
open-systems environment. ACSLS manages all library operations and shares library 
resources with any ACSLS-enabled application. A single instance of ACSLS can 
manage multiple libraries. The key benefits of ACSLS include:

■ Centralized library control across multiple StorageTek libraries, including legacy 
technology.
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■ Optimized library performance through load balancing, automatic request recover 
and retry, and multiple request processing in parallel.

■ Reduced downtime through dynamic configuration capabilities and queuing 
commands during short-term library outages.

■ Enriched reporting and management capabilities for ease of use

Enterprise Library Software (ELS)
ELS incorporates multiple software products to monitor and manage tape libraries and 
virtual solutions for a mainframe environment.

Host Software Component (HSC) and Storage Management Component (SMC)
HSC manages volume pools and communication with the SL8500 library. HSC resides 
on the host, but is transparent to the operating system. A separate component, SMC, 
provides the interface between z/OS operating systems and HSC. SMC resides on all 
MVS hosts that perform tape processing with HSC.

HSC and SMC work together to influence allocations and determine policies, volume 
locations, and drive ownership. HSC and SMC translate user requests into library 
commands and provide message handling.

Virtual Tape Control System (VTCS)
VTCS is the host software that enables centralized management of StorageTek virtual 
tape libraries, such as VSM and VLE. VTCS manages virtual tape volumes and drives, 
which includes the migration and recall of virtual volumes and the use of real tape 
cartridges and drives.

Concurrent Disaster Recovery Test (CDRT)
CDRT enables disaster recovery testing while the library or virtual storage is in use.

Independent Software Vendors (ISVs)
There are a variety of ISVs that support the SL8500 library. Some applications include: 

■ ASG Time Navigator 

■ CA ArcServe 

■ Commvault Simpana 

■ Dell NetVault

■ EMC DiskXtender

■ EMC NetWorker

■ FileTek StorHouse

■ HP Data Protector

■ IBM HPSS

■ IBM Tivoli TSM

■ MassTech MassStor

■ DIVA

■ Oracle HSM
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■ Oracle Secure Backup

■ Quantum StorNext

■ SGI DMF

■ SGL FlashNet

■ Veritas NetBackup

Not every application is tested on every platform or version. To ensure the software is 
supported, contact an Oracle marketing or sales representative, or application vendor. 
Oracle representatives can check compatibility with the Interoperability Tool.

Other Storage System Solutions
The SL8500 library is compatible with several other Oracle products to provide a 
multifaceted storage solution. This list is not all-inclusive. For more information 
contact an Oracle sales representative or visit:

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/ove
rview/index.html

Client System Component (CSC)
The CSC allows SMC on MVS to use ACSLS as its library server. One CSC is Library 
Station, which allows an open systems client to use HSC on MVS as its library server.

Expert Performance Reporter (ExPR)
ExPR software collects performance data and generates reports about status and 
performance. It provides information on manual tape systems, as well as Nearline and 
VSM tape systems. ExPR has both an MVS component and a PC component. 

Extended High Performance Data Mover (ExHPDM)
ExHPDM is utility software that performs high-speed backup and restore of data sets 
by interleaving very large block sizes on high-speed, high-capacity tape devices. 
ExHPDM achieves its speed by treating all data equally regardless of the type. Its only 
function is to move data from disk to very fast tape and back again.

The ExHPDM software moves blocks of data in parallel from several concurrently 
executing MVS application programs. The data from the application programs is 
buffered into 256 KB tape block sizes in the application program's address space, and 
the 256 KB blocks are interleaved onto single or multiple tape volumes. 

Library Content Manager (LCM) 
LCM — formerly Expert Library Manager (ExLM) — manages Nearline and VSM 
resources. LCM optimizes overall performance by assuring there are adequate 
resources available for a scheduled job. LCM also includes LCM Explorer, a graphical 
user interface that allows a user to configure LCM by creating configuration files 
instead of parameter files. 

StorageTek Tape Analytics (STA)
STA is an intelligent monitoring application available exclusively for StorageTek 
Modular Tape Libraries. It simplifies tape storage management and helps make 
informed decisions about future tape storage investments based on the current health 
of the tape storage environment.

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
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With STA allows you to monitor multiple libraries from a single, browser-based user 
interface. STA can manage open systems and mainframe, mixed-media, and 
mixed-drive environments across multiple library platforms. STA allows you to 
increase the use and performance of tape investments by performing detailed 
performance trending analyses. These analyses are based on a regularly-updated 
database of library operations.

Virtual Storage Manager (VSM)
VSM stores virtual tape volumes on a disk buffer called the Virtual Tape Storage 
Subsystem (VTSS). VSM then migrates the virtual tape volumes to real tape volumes 
mounted on real tape drives in the library. The primary host software for VSM is the 
Virtual Tape Control System (VTCS). VTCS manages virtual tape volumes and drives, 
which includes the migration and recall of virtual volumes and the use of real tape 
cartridges and drives.

Virtual Library Extension (VLE)  

VLE can be added to a VSM for additional capacity. VLE provides an economical 
second tier of disk storage that can be used to boost the overall VSM storage capacity 
or use VSM as a tapeless virtual library.

Ordering
This section provides the part numbers for ordering the SL8500 library and 
components. Contact Sales Assistance at +1.888.672.2534 for more information.

The tables throughout this chapter provide the part numbers for library components 
and upgrade options. The ATO number is for initial orders and PTO is for orders after 
the initial purchase of an SL8500 library.

Ordering Process
1. Physical Configuration — order a base library and optional expansion modules. 

2. Hardware Options — select hardware options (CAPs, PTPs, redundant robotics, 
and redundant electronics). 

3. Tape Drives — order tape drives (T10000 and LTO).

4. Tape Cartridges and Labels — order tape cartridges and labels.

5. Power Configurations — select a power redundancy option (N+1 or 2N). Order 
the required number of power supplies, AC power cords, and PDUs (to calculate 
requirements, see "Power Configuration Options" on page 1-9).

6. Hardware Activation Files — determine the active capacity required. Quantity 
options include: +100, +250, +500, +1000. Select optional features (partitioning, 
dual TCP/IP, multi TCP/IP). 

7. Cables — select required cables.

8. Support — select maintenance options and professional service options.

Hardware Activation Files
Hardware activation files enable library features. You can download the files through 
Oracle's Software Delivery Cloud, and then add and remove them from the library 
using the SLC (see the "Activating Optional Features" on page 5-1). Hardware 
activation files are required to enable:
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■ Active capacity

■ Partitioning

■ Dual TCP/IP

■ Multi TCP/IP 

Physical Configuration 
Order a base library, select the desired number of SEMs, and corresponding rail kit.

Base Library 
The base library includes a CIM, SEM, RIM, DEM, operator panel, four robots, CAPs, 
service safety door, and web cameras. It is the smallest configuration you can order.

Storage Expansion Modules (SEMs)
The library can contain up to 5 SEMs to increase the capacity of the library.

Rail Kits 
Order one rail kit that correspond to the total number of SEMs.

Hardware Options 
■ Accessory Racks

■ Cartridge Access Ports

■ Internal Ethernet Switch

■ Pass-thru Ports

■ Redundant Electronics

■ Robots

■ Service Safety Door

■ Touchscreen Op Panel

Base Library Part Number Description ATO

Base Module with 1,360 slots (2,000 active slots) 7113666

Base Module with 1,360 slots (2,000 active slots) for non-EU countries 7114548

SEM Part Number Description ATO PTO

SEM with 1,728 slots (no active slots) 7100898 SL8500-EXP-FRZ-N

Rail Kit Part Number Description ATO PTO

Rail kit for one SEM 7100886 XSL8500-1EF-RAIL-N

Rail kit for two SEMs 7100888 XSL8500-2EF-RAIL-N

Rail kit for three SEMs 7100889 XSL8500-3EF-RAIL-N

Rail kit for four SEMs 7100891 XSL8500-4EF-RAIL-N

Rail kit for five SEMs 7100892 XSL8500-5EF-RAIL-N
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Accessory Racks 
The library provides space for up to four traditional 19-inch racks to be installed in the 
DEM. Equipment should meet the rack requirements (see "Accessory Racks" on 
page 1-7). The number of racks supported in the library is determined by the library 
power configuration:

■ N+1 power configuration = 2 racks max

■ 2N power configuration = 4 racks

Cartridge Access Ports
To upgrade a library with rotational CAPs to the bulk CAP, purchase the upgrade kit 
listed below.

Internal Ethernet Switch

Pass-thru Ports 
Connecting two or more SL8500 libraries with pass-thru ports (PTPs) creates a library 
complex. The PTPs are installed between the DEMs and RIMs of the adjacent libraries. 

A single order of PTP mechanisms includes a set of four PTP mechanisms, one 
mechanism for each rail area between the libraries. The ILC kit includes the Ethernet 
hub and cables to connect the additional libraries. Each ILC kit can support up to five 
libraries in a complex. Order two kits for a complex with more than five libraries.

Description ATO PTO

6u Accessory Rack 7100942 XSL8500-RACK-Z-N

Description PTO

Bulk CAP upgrade kit123

1 The D-link library camera is incompatible with the bulk CAP. If you have a D-link camera, contact your 
service representative.

2 Libraries purchased prior to August 2005 may require an HBN card upgrade. Contact your service 
representative.

3 An HBCR is required for bulk CAP. If you have an HBC card, contact your service representative.

7113597

Optional — Additional 12-slot CAP magazine (for Bulk CAPs) 7113791

Description PTO

Internal Ethernet Switch XSL8500-ETHRNT-Z

Internal Ethernet Switch for non-EU countries 7114566

Description ATO PTO

PTP without mechanisms (frame only) 7100926 XSL8500P-BLANK-N

PTP mechanisms (set of four) 7100919 XSL8500-MECH-Z-N

PTP mechanisms (set of four) for non-EU countries 7114553 7114568

Hub and intra-library communications (ILC) kit 7100924 XSL8500P-HUB-Z-N

Hub and intra-library communications (ILC) kit for 
non-EU countries

7114552 7114567
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Redundant Electronics 
The optional redundant electronics (RE) feature provides failover protection with a 
second set of controller cards including an HBCR, HBT, HBS, and an internal Ethernet 
switch. For upgrades, order both PTO parts listed below.

Robots 
Each library comes standard with four robots. Optionally you can order four 
additional robots for redundant robotics. See also "Power Configurations" on 
page 1-23.

Service Safety Door

Touchscreen Op Panel

Tape Drives 
See the tape storage area on the corporate website for additional information: 
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/ove
rview/index.html

For more information about encryption, see the Oracle Key Management Overview and 
Planning Guide on OTN. 

Tape Drive Encryption
There are two encryption key management options:

■ Application-managed — an application manages the keys using the data path.

■ OKM-managed — Oracle Key Manager (OKM) appliance manages the keys using 
an ethernet connection outside the data path which is generally more secure.

Support for application-managed and OKM-managed encryption depends on the 
drive type.

T10000 Encryption  All T10000 generations are encryption-ready, however enabling 
either application-managed or OKM-managed encryption requires a T10K-EKEY-A-N 
encryption activation permit. You can order an encryption activation permit at any 

Description ATO PTO

Redundant Electronics 7100917 XSL3000-REDELCT-Z 
and 7101366

Redundant Electronics for non-EU countries 7114551 7114540 and 7114565

Description ATO PTO

Redundant robots (four additional) 7100928 XSL8500-4BOT-Z-N

Redundant robots (four additional) for non-EU 
countries

7114550 7114564

Description PTO

Service Safety Door XSL8500-SVDR-Z-N

Description PTO

Touch Screen Op Panel XSL8500-TSOP-Z-N

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
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time (during initial purchase or afterwards). After purchasing the permit, use Virtual 
Operator Panel (VOP) to enable encryption. T10000C and T10000D drives no longer 
require encryption license keys to enable encryption.

LTO Encryption  OKM-managed encryption requires an LTO-ENCRYPT-ACTIVE 
encryption activation permit. Application-managed encryption using the data path 
does not require a permit.

HP LTO 5 and 6 drives support both OKM-managed and application-managed 
encryption.

IBM LTO 5, 6, and 7 drives require an encryption card in the drive tray to interface 
with OKM (LTO 5 and 6 use the Belisarius card. LTO 7 may have either the Belisarius 
card or the LKM card. LTO 7 drive trays with LKM began shipping in July 2018). Note 
to use drive trays with LKM cards, the library must be in ADI mode.

You may purchase a drive with or without OKM compatibility. To upgrade a 
non-OKM-compatible IBM drive, you can purchase a kit to add the encryption card.

Re-using Encryption Activation Permits  If you previously purchased an activation permit 
for an older drive, you can re-use the activation permit when upgrading to a newer 
generation drive of the same family, as long as the total number of encryption enabled 
drives does not exceed your total number activation permits for that family. For 
example, if you have six T10K-EKEY-A-N activation permits, you can only have a total 
of six encryption-enabled T10000 drives (regardless of generation).

T10000 Drives
There may be other configurations for the T10000 tape drives than those listed below. 
For more information, see the drive specific Systems Assurance Guide on the OTN.

LTO Drives

Conversion Kits
Tape drive conversion kits convert drives previously used in an SL3000 library for use 
in the SL8500 library.

T-series Tape Drive Type Part Number

T10000D 16Gb Fibre Channel 7105797

T10000D 16Gb FICON 7105798

T10000 encryption activation permit for one drive1

1 See "T10000 Encryption" and "Re-using Encryption Activation Permits" above.

T10K-EKEY-A-N 

LTO Tape Drive Type Part Number

IBM LTO8 Fibre Channel no OKM compatibility 7118442

IBM LTO7 Fibre Channel with OKM compatibility 7113987

IBM LTO7 Fibre Channel no OKM compatibility 7113988

Encryption Upgrade Kit for IBM drives (Belisarius card) 7113290

LTO encryption activation permit for one drive1

1 See "LTO Encryption" and "Re-using Encryption Activation Permits" above

LTO-ENCRYPT-ACTIVE
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Tape Cartridges and Labels 
To order tape cartridges or labels: 

■ Call 1.877.STK.TAPE

■ E-mail tapemediaorders_ww@oracle.com

See the tape storage area on the corporate website for additional information: 
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/ove
rview/index.html

Power Configurations
You must selected a power redundancy and AC power configuration. Refer to "Power 
Configuration Options" on page 1-9 for more information.

DC Power Supplies
The number of DC 1200W power supplies required depends on the power 
configuration (N+1 or 2N) and the number of components in the library. Refer to"DC 
Power Supplies" on page 1-11 to determine the number of power supplies required. 

Hardware Activation Files 
The following features are enabled with a hardware activation file. For information 
about downloading and installing activation files, see "Activating Optional Features" 
on page 5-1.

Tape Drive Conversion Kit Part Number

IBM LTO generation 3 or higher 7110127

HP LTO generation 3 or higher 7110128

T9840C/D 7110129

T10000A/B/C 7110130

T10000D 7110131

Power Options ATO PTO

Delta Power 7100930 XSL8500-DELTAZ-N

Delta Power for non-EU countries 7114555 7114571

Wye Power 7100938 XSL8500-WYE-Z-N

Wye Power for non-EU countries 7114556 7114572

Single Phase Power 7100929 XSL8500-1PH-Z-N

Single Phase Power for non-EU countries 7114554 7114570

DC Power Supply Description ATO PTO

DC 1200W Power Supply1

1 Power supply for tape drives and robotics

7100931 XSL8500-DR-PWR-Z-N

Library Feature Description ATO PTO

Dual TCP/IP host interface activation permit 7100932 XSL8500-DTCPIP-N

Multi-TCP/IP host interface activation permit XSL8500-MTCPIP-N

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
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Capacity Activation 
For libraries with library firmware FRS_7.x and higher, use the table below for slot 
upgrade part numbers.

Cables 
The following sections provide information about the different interface cables. When 
ordering cables, keep this in mind: 

■ Riser cables can be used in computer rooms and are not classified according to 
flammability or toxic gas emissions.

■ Plenum cables are designed for installation in air ducts and manufactured to meet 
UL standards for flammability and produce little smoke. 

Ethernet Cables 
The library uses Ethernet cables for TCP/IP connections, which include host and 
library-to-library communications.

Fiber-Optic Cables 
LC connectors are the industry standard for all 2 Gbps or higher Fibre Channel 
devices. SC connectors are the standard for 1 Gbps Fibre Channel devices such as the 
T9840A tape drive. The SL8500 drive tray requires LC plugs for connection on the rear 
panel. When re-using T9840A tape drives, you will need to use an SC to LC adapter. 
The SL8500 drive tray only supports LC connectors.

Active Capacity Description ATO PTO

100 Slot Upgrade activation permit 7100880 7100945

250 Slot Upgrade activation permit 7100881 7100946

500 Slot Upgrade activation permit 7100882 7100947

1,000 Slot Upgrade activation permit 7100883 7900948

Ethernet Cable Part Number Description PTO

CAT5E, 8 ft, 24 AWG, Shielded CABLE10187033-Z-N

CAT5E, 35 ft, 24 AWG, Shielded CABLE10187034-Z-N

CAT5E, 50 IN, 24 AWG, Shielded CABLE10187035-Z-N

LC-LC 50/125 Micron Fiber-Optic Cables ATO PTO

50 m (164 ft) FC cable OM4, 50/125 Duplex riser 7106951 7106952

50 m (164 ft) FC cable OM4, 50/125 Duplex plenum 7106953 7106954

3 m (9.8 ft) Duplex riser CABLE10800340-Z-A CABLE10800340-Z-N

5 m (16.4 ft) Duplex riser CABLE10800341-Z-A CABLE10800341-Z-N

10 m (32.8 ft) Duplex riser CABLE10800310-Z-A CABLE10800310-Z-N

10 m (32.8 ft) Duplex plenum CABLE10800313-Z-A CABLE10800313-Z-N

LC to LC, 9/125 Micron Two Gigabit Fiber-Optic Cables Part Number

10 m (32.8 ft) Duplex, Riser CABLE10800331-Z-N

50 m (164 ft) Duplex, Riser CABLE10800333-Z-N

100 m (328 ft) Duplex, Riser CABLE10800306-Z-N
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Support
Service and support representatives are available to assist with hardware and software 
problem resolution. During the initial order and installation planning, you can contact 
local and remote support with any questions. 

Service Delivery Platform
The Service Delivery Platform (SDP) is a support enhancement solution that provides 
faster problem resolution, analysis, trending, and improved diagnostic capabilities. 
The SDP consists of a smart appliance placed at the customer site that connects to the 
library and any StorageTek T-series tape drives. The SDP collects device events and 
alerts support analysts, providing remote diagnosis and auto service requests (ASR).

For more information, customers should contact an Oracle representative, or visit: 
http://www.oracle.com/technetwork/systems/asr/documentation/oracle-install
ed-storage-330027.html

Oracle Premier Support for Systems
Oracle Premier Support is a fully integrated support solution which features:

■ Complete system coverage and unlimited 24/7 access to Oracle system specialists

■ Essential product updates, such as firmware

■ Personalized, proactive IT support and rapid-response hardware service

For more information, visit: http://www.oracle.com/us/support/index.html

Contacting Support
The Oracle Global Customer Support Contacts Directory can be found at: 
http://www.oracle.com/us/support/contact-068555.html

To submit, update, or review service requests, go to My Oracle Support at: 
https://support.oracle.com/

10 m (32.8 ft) Duplex, Plenum CABLE10800330-Z-N

50 m (164 ft) Duplex, Plenum CABLE10800332-Z-N

100 m (328 ft) Duplex, Plenum CABLE10800305-Z-N

ESCON Cables Part Number

13 m (40 ft) Riser CABLE10800289-Z-N

107 m (350 ft) Riser CABLE10800292-Z-N

13 m (40 ft) Plenum CABLE10800285-Z-N

31 m (100 ft) Plenum CABLE10800286-Z-N

107 m (350 ft) Plenum CABLE10800288-Z-N

LC to LC, 9/125 Micron Two Gigabit Fiber-Optic Cables Part Number

http://www.oracle.com/technetwork/systems/asr/documentation/oracle-installed-storage-330027.html
http://www.oracle.com/technetwork/systems/asr/documentation/oracle-installed-storage-330027.html
http://www.oracle.com/us/support/index.html
http://www.oracle.com/us/support/contact-068555.html
https://support.oracle.com/
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2Installation Planning

This chapter provides planning information and requirements to consider before 
installation of the SL8500 library. Key planning considerations include:

■ Dimensions and Weights

■ Installation Site Requirements

■ Cabling

■ Fire Suppression Planning

■ Pass-thru Port Planning

■ Time and Personnel

■ Installation Tools

■ Transporting the Library

Dimensions and Weights
Ensure there is adequate space for the library, future expansions, and service areas.

Table 2–1 Library Weights and Measures

Component Length Width Height Empty Weight1

1 Base library configuration with N+1 power and four robots; without tape drives or tape cartridges.

Full Weight2

2 All tape drives, DC power supplies, and cartridges, with 2N power, four robots, doors and facade, but 
does not include a full rack.

DEM 30.0 in. 
(76.2 cm)

67.25 in. 
(170.8 cm)

93.15 in. 
(236.6 cm)

1,300 lbs 
(590 kg)

2,725 lbs 
(1236 kg)

RIM 30.0 in. 
(76.2 cm)

67.25 in. 
(170.8 cm)

93.15 in. 
(236.6 cm)

775 lbs  (352 kg) 1,825 lbs 
(828 kg)

SEM 37.5 in. 
(95.25 cm)

67.25 in. 
(170.8 cm)

93.15 in. 
(236.6 cm)

850 lbs  (386 kg) 1,775 lbs 
(805 kg)

CIM3

3 Weight values are for a CIM with the bulk CAP

37.5 in. 
(95.25 cm)

67.25 in. 
(170.8 cm)

93.15 in. 
(236.6 cm)

1,483 lbs 
(673 kg)

2,020 lbs 
(916 kg)

PTP frame 59.4 in. 
(150.8 cm)

6.76 in. 
(17.17 cm)

91 in. 
(231.1 cm)

N/A 266 lbs  (121 kg)

Front Service Area 26.0 in. 
(66 cm)

71.25 in. 
(181 cm)

N/A N/A N/A

Rear Service Area 35.0 in. 
(89 cm)

74.30 in. 
(188.7 cm)

N/A N/A N/A
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Figure 2–1 Sample Library Layout (Top View)

Figure Legend:

1. Rear doors (open)

2. Cable cut outs

3. Rear service area

4. PTP frame

5. Front service area

Tape Drives and Cartridges Weights and Dimensions
The weights below are for reference only, check the drive specific documentation for 
exact weights and measures.

Table 2–2 Drive Tray Weights and Measures 

Drive Tray Height Width Length Weight

Drive tray only 10.8 cm (4.25 in.) 16.5 cm (6.5 in.) 85 cm (33.5 in.) 4.3 kg (9.5 lb) 
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Shipping Weights and Dimensions 
The SL8500 library is delivered on pallets that can measure up to 2.5 m (8.25 ft) in 
length and weigh up to 481 kg (1060 lb). Ensure there are forklifts or pallet jacks that 
can handle these pallets. If moving between floors, verify the elevator can handle these 
loads. 

Total Pallet Weights
The total weight of the pallets for various library configurations are listed below. If 
ordering the optional CAP, increase the total weight by 33 kg (73 lb). CAPs are shipped 
on their own pallet. Similarly, if ordering redundant robotics, increase the total weight 
by 65 kg (143 lb). Four additional robots are shipped on an additional #10 pallet. 
Additional pallets not listed below may be shipped depending on the library features 
ordered.

Shipping Pallets Weights and Dimensions
The individual pallet sizes and weights are listed below:

Table 2–3 Tape Drive and Cartridge Weights 

Drive Type Tape Drive Weight (with drive tray) Cartridge Tape Weight 

T9840 8.2 kg (18.0 lb) 262 g (9.2 oz)

T9940 11 kg (24.3 lb) 262 g (9.2 oz) 

T10000 9.4 kg (20.75 lb) 264 g (9.31 oz) 

LTO 6.9 kg (15 lb) 210 g (7.4 oz) 

SDLT 6.7 kg (14.8 lb) 222.5 g (7.85 oz) 

Note: The values listed are estimates and subject to change. The 
values are for a bulk CAP library.

Table 2–4 Total Pallet Weights for a Selected Library Configuration 

Configuration Pallets Shipped
Approximate Total 
Weight

Basic Library 1, 2, 3, 4, 5, 6, 7, 8, 9, 9A, 10 2481 kg (5,470 lb)

One SEM 1, 2, 3, 4, 4A, 5, 6, 7A, 8, 8A, 9, 9A, 10 3090 kg (6,814 lb)

Two SEMs 1, 2, 3, 4, 4A (x2), 5, 6, 7B, 8, 8A (x2), 9, 9A, 10 3709 kg (8,178 lb)

Three SEMs 1, 2, 3, 4, 4A (x3), 5, 6, 7C, 8, 8A (x3), 9, 9A, 10 4336 kg (9,562lb)

Four SEMs 1, 2, 3, 4, 4A (x4), 5, 6, 7D, 8, 8A (x4), 9, 9A, 10 4887 kg (10,777 lb)

Five SEMs 1, 2, 3, 4, 4a (x5), 5, 6, 7E, 8, 8A (x5), 9, 9A, 10 5436 kg (11,987 lb)

Table 2–5 Shipping Pallets –Weights and Dimensions 

Pallet Description Height Width Length Weight 

1 Lower DEM 205 cm (81 in.) 97 cm (38 in.) 185 cm (73 in.) 480 kg (1058 lb) 

2 Upper DEM 87 cm (34 in.) 97 cm (38 in.) 185 cm (73 in.) 160 kg (353 lb)

3 Lower RIM 198 cm (78 in.) 99 cm (39 in.) 183 cm (72 cm) 293 kg (646 lb)

4 Upper RIM 94 cm (37 in.) 94 cm (37 in.) 188 cm (74 in.) 113 kg (249 lb)

4A SEM - Frame (one per SEM) 120 cm (47 in.) 105 cm (41 in.) 244 cm (96 in.) 357 kg (787 lb) 

5 CIM 120 cm (47 in.) 82 cm (32 in.) 244 cm (96 in.) 332 kg (732 lb) 

6 Z-frame 76 cm (30 in.) 66 cm (26 in.) 246 cm (97 in.) 136 kg (300 lb)
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Package Component Weights and Dimensions
The package weights and dimensions for additional components are listed below:

Installation Site Requirements
■ Physical Space

■ Floor Requirements

■ Ceiling Requirements

7 Basic library rails (no SEMs) 33 cm (13 in.) 112 cm (44 in.) 125 cm (49 in.) 100 kg (220 lb)

7A Rail Kit for one SEM 33 cm (13 in.) 112 cm (44 in.) 218 cm (86 in.) 182 kg (400 lb) 

7B Rail Kit for two SEMs 33 cm (13 in.) 112 cm (44 in.) 315 cm(124 in.) 272 kg (600 lb) 

7C Rail Kit for three SEMs 51 cm (20 in.) 112 cm (44 in.)  315 cm(124 in.) 372 kg (820 lb) 

7D Rail Kit for four SEMs 51 cm (20 in.) 112 cm (44 in.)  315 cm(124 in.) 395 kg(871 lbs)

7E Rail Kit for five SEMs 46 cm (18 in.) 107 cm (42 in.) 310 cm(122 in.) 416 kg (917 lb)

8 Base Module Arrays 122 cm (48 in.) 115 cm (45 in.) 150 cm (59 in.) 161 kg (355 lb) 

8A SEM Arrays (one per SEM) 122 cm (48 in.) 115 cm (45 in.) 153 cm (60 in.) 171 kg (377 lb) 

9 Covers and Rear Doors 112 cm (44 in.) 114 cm (45 in.) 254 cm(100 in.) 346 kg (762 lb)

9A Bulk CAP, safety door, op 
panel

112 cm (44 in.) 114 cm (45 in.) 254 cm(100 in.) 296 kg (652 lb)

10 4 Robots (additional pallet 
with redundant robotics)

72 cm (28 in.) 97 cm (38 in.) 140 cm (55 in.) 65 kg (143 lb)

PF PLT Performance Kit 61 cm (24 in.) 107 cm (42 in.) 107 cm (42 in.) 38 kg (84 lb)

Table 2–6 Component Package Weights and Dimensions 

Description Height Width Length Weight

Rotational CAP 36 cm (14 in.) 38 cm (15 in.) 229 cm (90 in.) 22 kg (48 lb)

Façade- Upper and Lower (pallet 9) 13 cm (5 in.) 49 cm (19 in.) 242 cm (95 in.) 19 kg (40 lb)

Copper Kit for Rails 76 in. (pallet 7A) 8 cm (3 in.) 44 cm (17 in.) 196 cm (77 in.) 9 kg (20 lb)

Copper Kit for Rails 114 in. (pallet 7B ) 8 cm (3 in.) 92 cm (36 in.) 178 cm (70 in.) 12 kg (25 lb)

Copper Kit for Rails +114in. (pallet 7C) 8 cm (3 in.) 92 cm (36 in.) 178 cm (70 in.) 14 kg (30 lb)

Drive Bay 94 cm (36 in.) 59 cm (23 in.) 83 cm (32 in.) 37 kg (80 lb)

HBS 16 cm (6 in.) 26 cm (10 in.) 61 cm (24 in.) 5 kg (10 lb)

Op Panel/Display 31 cm (12 in.) 41 cm (16 in.) 46 cm (18 in.) 11 kg (23 lb)

PDU 28 cm (11 in.) 74 cm (29 in.) 74 cm (29 in.) 9 kg (19 lb)

PDU N+1 21 cm (8 in.) 61 cm (24 in.) 69 cm (27 in.) 9 kg (19 lb)

Power Supplies 23 cm (9 in.) 26 cm (10 in.) 46 cm (18 in.) 5 kg (10 lb)

Drive Tray - Common SL8500 31 cm (12 in.) 33 cm (13 in.) 102 cm (40 in.) 14 kg (30 lb)

Drive - Common 107 cm (42 in.) 107 cm (42 in.) 138 cm (54 in.) 173 kg (380 lb)

LTO Drive on SL8500 Tray 31 cm (12 in.) 33 cm (13 in.) 102 cm (40 in.) 12 kg (26 lb)

9940 Drive on SL8500 Tray 31 cm (12 in.) 33 cm (13 in.) 125 cm (49 in.) 18 kg (38 lb)

9940 Drive 107 cm (42 in.) 72 cm (28 in.) 127 cm (50 in.) 118 kg (260 lb)

Rack Module (19" Rack) 64 cm (25 in.) 51 cm (20 in.) 92 cm (36 in.) 19 kg (40 lb)

Safety Door 33 cm (13 in.) 66 cm (26 in.) 229 cm (90 in.) 20 kg (42 lb)

Table 2–5 (Cont.) Shipping Pallets –Weights and Dimensions 

Pallet Description Height Width Length Weight 
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■ Environmental Requirements

Physical Space
Ensure there is adequate space in elevators, passageways, and the construction area. If 
modules will be added in the future, ensure there is enough space to expand the 
library (see "Dimensions and Weights" on page 2-1).

Floor
Ensure that the weight and coplanar requirements are satisfied (see "Floor 
Requirements" on page 2-5").

Transportation
If the equipment must be transported on elevators, the elevator cars must be capable 
of safely handling the weight. Additionally, ensure that the components can pass 
through doorways and fit in elevators. For more information, see "Shipping Weights 
and Dimensions" on page 2-3 and "Transporting the Library" on page 2-14. 

Construction Area
The minimum working area (not including the space required for the pallets) is 
approximately 56 m2 (600 ft2).

Waste Disposal
Sales and service personnel should plan with customers on the disposal of all packing 
material. Determine if waste bins or recycling containers will be provided on site, or 
whether an independent company will handle the disposal at additional cost.

Floor Requirements 
A raised floor is not required if the site meets all environmental requirements and has 
adequate airflow (see "Environmental Requirements" on page 2-7).

Weight and Load Distribution
Ensure all elevators transporting the library can safely handle the weight (see 
"Shipping Weights and Dimensions" on page 2-3). 

Ensure the site floor can support the weight of the library (see Table 2–1, " Library 
Weights and Measures"). The floor must be capable of supporting 454 kg (1,000 lb) per 
weight distribution pad, which measure 4 by 8 inches. There are four distribution pads 
per module, except for the DEM which has six pads.

The 454 kg (1,000 lb) weight represents the modules, plus a factor of safety to 
accommodate for torque values, installation procedures, component variances, and the 
floor construction. When adjusting the weight pads during installation, the load 
distribution may not be evenly spread to each pad—one or more of these pads may be 
subject to higher loads that near the 454 kg (1,000 lb) value.
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Figure 2–2 Weight Pad Locations

Co-planar Requirements
Robots must travel along a level plane throughout the library. Any excessive 
out-of-plane conditions can cause frame damage, binding, premature wear, or damage 
to the robots. 

The site floor should be laser-leveled before receiving any equipment. The library 
modules must be level across the width (from left to right) and installed on the same 
horizontal plane to within ±25 mm (1 in.) tolerance. The floor variations cannot exceed 
28 mm ± 0.8 mm (1.1 in. ± 0.0325 in.) throughout the length of the library.

For future library expansion, check the entire floor adjacent to the library for a library 
complex or in front of the library for SEMs. Adjust each library module so that the rails 
are on the same plane.

Ceiling Requirements 
The DEM and RIM contain an upper module and a lower module. Installing the upper 
module requires adequate ceiling clearance. 

■ Recommended method: Hang the modules on the clamps then swing the upper 
modules into place. This method requires at least 239 cm (94 in.) of floor-to-ceiling 
clearance and a minimum of three people to lift the module. 

■ Optional method: Remove the clamps (for clearance), lift the upper modules up and 
slide them over the lower modules. This requires four people to accomplish (one 
person on each corner) and 236.6 cm (93.15 in) of floor-to-ceiling clearance.

Height Adjustments 
The library height specifications are:

CAUTION: Check for any equipment that may hang from the 
ceiling before installing the upper modules.
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■ Minimum height =231.4 cm (91 in.) 

■ Maximum height =236.6 cm (93.15 in.) 

Adjust the floor-to-module distance to meet the "Co-planar Requirements" on 
page 2-6. The floor-to-module distance should be adjusted to 25.4 mm ± 0.8 mm (1 in. 
± 0.0325 in.). The absolute minimum floor-to-module height permitted is 19 mm (0.75 
in.) the maximum height is 47mm (1.85 in.). 

Clearances 
The table below lists the minimum library-to-ceiling clearances for installation of side 
covers, front and rear doors, and the upper modules. To calculate maximum height, 
use the library height and add the overhead clearance. 

Environmental Requirements
For optimal reliability, maintain the environment between the recommended ranges. 

Airborne Contaminants 
Airborne particulates can damage tape libraries, drives, and tapes. The operating 
environment for the tape library must meet to the following requirements:

■ ISO 14644-1 Class 8 Environment

■ Total mass of airborne particulates must be less than or equal to 200 micrograms 
per cubic meter

■ Severity level G1 per ANSI/ISA 71.04-1985

Particles ten microns or smaller are particularly harmful to most data processing 
hardware. Gasses that are particularly dangerous to electronic components include 
chlorine compounds, ammonia and its derivatives, oxides of sulfur, and petrol 
hydrocarbons. In the absence of appropriate hardware exposure limits, health 
exposure limits must be used.

Humidification with chlorinated water is a common source of airborne chlorine. 
Appropriately-designed carbon filters must be used to ensure safe levels of airborne 
chlorine when chlorinated water is used for humidification.

Table 2–7 Overhead Clearances 

Description Overhead Clearance 

Side cover installation 1.9 cm (0.75 in.)

Upper RIM installation 1.3 cm (0.5 in.) 

Facade installation, Upper DEM installation 2.5 cm (1 in.)

CIM and SEM roof installation 4.5 cm (1.75 in.) 

Description Temperature 
Relative Humidity 
(non-condensing) Wet Bulb Maximum Maximum Altitude

Operating 15 to 32°C (60 to 90°F) 
dry bulb

20% to 80%1

1 Oracle recommends maintaining a relative humidity of 40% to 50%.

29.2°C (84.5°F) 3.05 km (10,000 ft)

Storage 10 to 40°C (50 to 
104°F)

10% to 95% 35.0°C (95.0°F) 3.05 km (10,000 ft)

Shipping -40 to 60°C (-40 to 
140°F)

10% to 95% 35.0°C (95.0°F) 15.24 km (50,000 ft)
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Some basic precautions to follow:

■ Do not allow food or drink into the data center.

■ Do not store cardboard, wood, or packing materials in the data center clean area.

■ Identify a separate area for unpacking new equipment from crates and boxes.

■ Do not allow construction or drilling in the data center without first isolating 
sensitive equipment. Dry wall and gypsum are especially damaging to equipment.

Seismic or Earthquake Ratings 
The requirements for seismic compatibility vary dramatically throughout the world. It 
is recommended that you work with local experts familiar with the local code and 
requirements. Professional Services can also be engaged to help coordinate this 
activity.

Airflow
In the SL8500 library, air flows front-to-back (CIM-to-DEM). The airflow required 
depends on the number of components installed in the library. Plan for the cooling 
requirements of all data center equipment.

A maximum configured library with 64 tape drives, 24 DC power supplies, four rack 
modules, and the electronic control module would require 112.3 m3/min. (3956 
ft3/min.) of air supply to avoid recirculation.

Most configurations are smaller than this and require less airflow. For example, 12 tape 
drives, 12 DC power supplies, four robots, one rack module, and the electronic control 
module would require 33.3 m3/min. (1176 ft3/min.).

Table 2–8 Gas Limit Recommendations

Chemical ASHRAE OSHA (PEL) ACGIH NIOSH 

Acetic Acid (CH3COOH) Not defined 10 ppm Not defined Not defined 

Ammonia (NH) 3500 µg/m3 350 ppm 25 ppm Not defined 

Chlorine (Cl) 2100 µg/m3 31 ppm (c) Not defined 0.5 ppm (c) 

Hydrogen Chloride (HCl) Not defined 5 ppm (c) Not defined Not defined 

Hydrogen Sulfide (H2S) 50 µg/m3 320 ppm (c) 10 ppm 10 ppm 

Ozone (O3) 235 µg/m3 30.1 ppm Not defined Not defined 

Petrol-hydrocarbons (CnHn) Not defined 500 ppm 75 ppm 300 ppm 

Sulfur Dioxide (SO2) 80 µg/m3 35 ppm 2 ppm 0.5 ppm (c) 

Sulfuric Acid (H2SO4) Not defined 1 ppm Not defined 1 ppm (c) 

Table 2–9 Airflow Requirements (at 1atm, 22°C/72°F)

Component Required Airflow Quantity

Tape drive 0.57m3/min. (20 ft3/min.) each 64 max

DC power supply 0.71m3/min. (25ft3/min.) each 24 max

Rack Modules 13.59m3/min. (480ft3/min.) each 4 max

Electronics Module 4.42m3/min. (156ft3/min.) each 1
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Power Requirements
A licensed electrician should install the library's external AC wiring. For more 
information about power requirements of the SL8500, see "Power Configuration 
Options" on page 1-9.

Cabling
The rear library doors have notches on the top and bottom for routing interface and 
power cables to the tape drives and PDUs. In the table below, left and right are when 
viewing the rear of the library.

Ethernet, power, and interface cables should be routed through floor or ceiling cutouts 
of the site. Cutouts should be located near the rear corners of the DEM. The 
recommended "rough-in" AC feed (power cable) measured from the top of the raised 
floor to the input of the power distribution unit is 46 cm (18 in.).

Make sure any cabling or conduit inside the library does not interfere with the 
removal and replacement of any components, such as the DC power supplies, 
electronics control module, tape drives, or accessory rack equipment. See Figure 2–3 
below.

If the existing fire suppression cutouts are not being used, use flexible conduit or 
cables to route power connections to the AC power supply from above the library. If 
the fire suppression cutouts are being used, new cutouts should be made in the frame 
to route conduit or cables to the AC power supply. Optional routing to the left of the 
tape drive bays may be used for clearance. However, use flexible conduit for the tape 
drive DC power supply grid.

Table 2–10 Door Notch Dimensions

Location Length Width

Top Left 25 cm (10 in.) 3.8 cm (1.5 in.)

Bottom Left 40.6 cm (16 in.) 7 cm (2.75 in.)

Top Right 25 cm (10 in.) 3.8 cm (1.5 in.)

Bottom Right 33 cm (13 in.) 7 cm (2.75 in.)
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Figure 2–3 Conduit and Cable Routing (Rear View)

1. Fire suppression cutouts (route cables here if not using fire suppression)

2. New frame cutouts (if fire suppression cutouts are being used)

3. Obstruction to avoid — accessory racks and equipment

4. Optional routing used for clearance, be aware of possible tape drive interference 
and ethernet cables

5. Obstruction to avoid — HBS and internal switches

6. Obstruction to avoid — tape drive DC power supply

Fire Suppression Planning 
The library’s smoke detector cuts all power to the library when smoke is detected. You 
can restore power to the library by resetting the AC circuit breakers on the PDUs.

The library does not ship with a fire suppression system, but there are two 5 cm (2 
inch) diameter nozzle openings in each module (see Figure 2–4). Plates, 7 cm (2.75 

Table 2–11 Legend for Figure 2–3

Flexible Conduit

Rigid Conduit
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inch) square and 1.2 mm (0.048 inch) thick, cover the openings and can be drilled to 
custom fit nozzles. Nozzles must be clear of robotic operations and cannot protrude 
more than 2.54 cm (1 inch) into the library. Professional Services can assist with fire 
suppression planning (contact your Oracle sales representative).

Figure 2–4 Fire Suppression Ceiling Access (viewed from the top of the library)

Figure Legend:

1. Datum (measurements are without covers or doors)

2. Nozzle cutout

Pass-thru Port Planning 
Although the library complex can expand in either direction, adding a new library to 
the left is non-disruptive. To expand the library complex in the other direction, you 
must bring the library offline to re-configuration the system and re-IPL the library. 
Figure 2–5 shows two examples of a three-library complex. 

■ Example 1, on the left, shows the preferred non-disruptive method of adding 
another library (C) to the left of the library complex.

■ Example 2, on the right, shows the disruptive method. Adding another library (C) 
to the right of the library complex requires a reconfiguration of LSM numbering.
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Figure 2–5 Pass-thru Port Planning Example

Figure Legend:

1. Preferred, non-disruptive method of installation

2. Disruptive method of installation

3. New library and PTP

4. PTP connecting existing libraries

Time and Personnel
When preparing for an SL8500 installation, it is important to consider personnel 
requirements, which include safe lifting and time.

Lifting
The upper drive bay and robotic rail modules must be manually lifted for installation. 
These modules weigh approximately 40 kg (85 lb) and are raised a height of 1.7 m (5.5 
ft). There are two methods for installing the upper module. Be aware that one of the 
methods requires four people to complete. For more information about the upper 
module installation methods, see "Ceiling Requirements" on page 2-6.

Time
The estimated time to physically install a library is about 24 hours. This is based on 
three qualified people working approximately eight hours each. For initial planning, 
allow for two days to completely install the library. This provides time to ensure a 
quality installation and allows for training. Time factors to consider include: 

■ Guiding the pallets from the dock to the installation site

■ Removing packaging material when floor space is limited 

■ Lifting requirements of 40 kg (85 lb) to attach upper frame assemblies 

■ Configuring the library and up to 64 drives with switches and cables

Installation Tools
The table below lists the tools contained in the installation kit (part number 24100250). 
The installation kit is currently not available for order. There are sufficient kits in the 
field to support installation needs. Oracle service representatives should obtain a kit 
from their local area and ensure that the following tools are in the kit. 
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■ Kit dimensions are: 99 cm (39 in.) long, 71 cm (28 in.) wide, and 51 cm (20 in.) high. 
The kit comes with an extendable handle and wheels. 

Track Stop Installation Tools
Both the rack alignment tool kit (418644901) and original track alignment (419894001) 
tool have been distributed to regional depots. Service representatives can order and 
check out the special tools as typically done for spare parts. Use two rack alignment 
kits and two track alignment tools to work both sides of the library in parallel. 
Installation time for five SEMs is approximately 5 hours.

The rack alignment tool kit (418644901) includes:

■ Short tool (418623102)

■ Long tool (418623002)

■ Serialized shipping container

Additional tools to be acquired locally:

■ 1/16 hex Allen driver — required

■ Step stool and knee pads — recommended

■ SL8500 Array Extraction Tool (24100275) — if available

The rack stops (418626901) are packaged in kits of 17 stops and are used in groups of 
16 so spares will always be available.

Table 2–12 Installation Tools for Tool Kit

Description Part Number 

Copper rail connector extraction tool 313921001 

Frame jacks with handles (adjustable jack) 313880803 (check availability)

Serial cable for laptop 24100134

Crossover cable for laptop 24100163

Tape drive power kit 314831204

Torx screwdriver and bits Obtain locally

3/8-in. drive ratchet wrench with 6 in. extension

1/4-in., 3/8-in., and 5/16-in. socket for 3/8-in. drive

1/4-in. and 5/16-in. hex(Allen) on 3/8-in. drive

Obtain locally

3/4-in., 5/8-in., and 9/16 in. combination wrench Obtain locally

25 ft tape measure, 2 ft level Obtain locally

Utility knife, wire side cutters, rubber mallet Obtain locally

Flashlight, step stool, work gloves, safety glasses Obtain locally

Volt/Ohmmeter Obtain locally

Table 2–13 Rack Stops Per Library

SEMs Rack Stops Per Rail Total Rack Stops Per Library Quantity of PN 418626901

0 1 16 1

1 1 16 1

2 1 16 1

3 1 16 1

4 5 80 5
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Transporting the Library
There are special considerations to follow when transporting the components of the 
library to the installation site. If necessary, you can unpack the library components 
from the pallets to move them to the installation site. Follow the unpacking 
instructions on the outside packaging material or installation manual. The tables that 
follow list the specifications for these components.

Adjustable Jacks
You may need a special jack to assist in unpacking, moving, and positioning the larger 
modules. This jack is part of the tool kit, which is required for an installation (see 
"Installation Tools" on page 2-12). 

Module Components
The DEM and RIM come in two parts: a lower and an upper module. The lower DEM 
is the heaviest component of the library. Use care when moving this component.

The CIM is not pre-assembled and must be constructed on-site. Allow 3 m (10 ft) of 
space at the end of the box or pallet to unpack these components. A rear section and a 
front section, called the Z frame must be attached to the floor of the CIM.

The SEM is not pre-assembled and must be constructed on-site. Allow 3 m (10 ft) of 
space at the end of the box or pallet to unpack these components.

5 6 96 6

Module Pallet Height Width Depth Weight

DEM lower 1 173 cm (68 in.) 168 cm (66 in.) 76 cm (30 in.) 386 kg (850 lb)

DEM upper 2 58.5 cm (23 in.) 168 cm (66 in.) 76 cm (30 in.) 37 kg (80 lb)

RIM lower1

1 Diagonal stabilizers are attached to help move and handle the RIM. 

3 176.5 cm (69.5 in.) 168 cm (66 in.) 76 cm (30 in.) --

RIM upper1 4 54.6 cm (21.5 in.) 168 cm (66 in.) 76 cm (30 in.) --

SEM floor 4A 167.6 cm (66 in.) 94.6 cm (37.25 in.) 3.8 cm (1.5 in.) 67 kg (147 lbs)

SEM ceiling 4A 167.6 cm (66 in.) 95.25 cm (37.5 in.) 3.8 cm (1.5 in.) 25 kg (54 lbs)

SEM center 
wall

4A 227.3 cm (89.5 in.) 44.5 cm (17.5 in.) 95.25 cm (37.5 in.) 80 kg (175 lbs)

SEM outer 
walls

4A 231 cm (91 in.) 186.7 cm (73.5 in.) 4.4 cm (1.75 in.) 58 kg (127 lbs)

CIM floor 5 167.6 cm (66 in.) 94.6 cm (37.25 in.) 3.8 cm (1.5 in.) 84 kg (185 lbs)

CIM ceiling 5 167.6 cm (66 in.) 95.25 cm (37.5 in.) 3.8 cm (1.5 in.) 25 kg (54 lbs)

CIM walls 5 231 cm (91 in.) 186.7 cm (73.5 in.) 4.4 cm (1.75 in.) 58 kg (127 lbs)

CIM Z-frame 6 227.3 cm (89.5 in.) 44.5 cm (17.5 in.) 51 cm (20 in.) 77 kg (170 lbs)

Front doors 
(bulk CAP)

9 231 cm (91 in.) 61.5/66 cm 
(24.25/26 in.)

8.25 cm (3.25 in.) 43 kg (95 lbs)

Rear doors 9 231 cm (91 in.) 85.7 cm (33.75 in.) 10 cm (4 in.) --

Rack 
assembly

-- 48.26 cm (19 in) 33.65/38 cm 
(13.25/15 in.)

-- --

Table 2–13 (Cont.) Rack Stops Per Library

SEMs Rack Stops Per Rail Total Rack Stops Per Library Quantity of PN 418626901
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Rails
Rails are on pallet 7 and are composed of five major parts: 

1. Clamps (installed at the factory)

2. Rail extrusions

3. Bottom floor extrusion

4. Geared tracks

5. Power/signal strips

Depending on the number of SEMs, the rails can be the longest components in the 
library. The extrusion lengths are 1 m (3.3 ft), 2 m (6.4 ft), 3 m (9.5 ft), and 3.9 m (12.6 
ft).
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3Installing StorageTek Library Console

Oracle's StorageTek Library Console (SLC) is a GUI application for configuring, 
monitoring, and managing the SL8500 tape library.

■ Selecting an SLC Version

■ Downloading the SLC Media Pack

■ Installing Standalone (Remote) SLC

■ Installing Web-launched SLC

■ Upgrading SLC on the Local Op Panel

Selecting an SLC Version
You can perform the procedures in this document with any of the following SLC 
versions, unless otherwise noted.

■ Standalone — SLC runs remotely from any system that has a network connection 
to the library.

■ Web-launched — SLC is installed on a web server (or server running a web 
application such as Tomcat, Apache or GlassFish), allowing individual clients to 
use a browser to access SLC.

■ Local Operator Panel — SLC is pre-installed on the library, enabling library 
operators to access most SLC functions directly at the library.

Downloading the SLC Media Pack
The media pack includes the web-launched SLC server, web-launched SLC client, and 
the standalone SLC.

1. Go to the Oracle Software Delivery Cloud at:

http://edelivery.oracle.com/

2. Click Sign In/Register.

3. Search for SLC, and then select Oracle StorageTek Library Console version. Click 
Select Platform.

Note: Customer data on tape cartridges is never available to SLC or 
the library. The external data interface of the tape drives is separate 
from the library infrastructure.
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4. Verify Oracle StorageTek Library Console is listed under Selected Products, and 
then click Continue.

5. Read the terms and restrictions. Indicate your acceptance, and then click 
Continue.

6. Save the zip file. Extract the media pack to the desired location.

Installing Standalone (Remote) SLC
1. Uninstall all previous versions of SLC before updating.

2. Download and extract the standalone SLC media pack (see "Downloading the SLC 
Media Pack" on page 3-1).

3. Select the SLC installer file for your operating system (refer to the media pack 
readme).

4. Review the information. Click Next.

5. Specify where to install SLC. Click Next.

6. Specify where to create the SLC shortcut icons. Click Next.

7. Verify the information is correct. Click Install.

8. Click Done.

Supported Platforms
■ Solaris 10 SPARC, Solaris 10 x86

■ Windows Server 2008 SP2 64-bit, Windows 2012 Enterprise Server

■ Windows 7 SP1 64-bit, Windows 8 64-bit, Windows 8.1 64-bit

■ Oracle Unbreakable Linux 5 (2.6.18) 32-bit

■ SUSE Enterprise Linux 10.2 (2.6.16) 32-bit

Security Considerations
SLC interfaces with the primary library interface (PLI) over SSL, which provides a 
secure communication path between the library and the SLC session. This prevents 
unauthorized network users from monitoring library activity.

Installing Web-launched SLC
You only need to install web-launched SLC updates on the server. You can update the 
web-launched SLC server while it is running. After the updates are installed, they are 
downloaded automatically when a client starts the application.

1. Download and extract the web-launch SLC server (.war) file (see "Downloading 
the SLC Media Pack" on page 3-1).

2. Deploy the file on the server (refer to the web server documentation).

Note: On Solaris, you cannot choose the default root directory. 
Oracle recommends /u-sr/bin or a similar location.
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Minimum Browser Requirements
■ Internet Explorer 8 (on Windows 7: 64 bit)

■ Firefox 17.0.2 ESR (on Windows 7: 64 bit)

Security Considerations
The web-launched SLC is digitally signed, which guarantees that the software has 
been issued by Oracle Corporation and has not been altered or corrupted since it was 
created. As a Java Web Start process, the web-launched SLC includes the security 
features provided by the Java 2 platform.

Upgrading SLC on the Local Op Panel
1. Select Tools > Diagnostics, and then select the Library in the device tree.

2. Click the Activate Code tab.

3. In the Target list, select the code package to activate (in this case SLConsole).

4. In the Available Versions section, select the code version to activate. Click the 
Activate button.

5. When the activation process finishes, click OK.

Important: You are responsible for implementing all appropriate 
additional security systems, including firewalls, and user access.
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4Logging In To SLC

■ Logging In For the First Time After Library Installation

■ Logging In to the Standalone SLC

■ Logging In to the Web-launched SLC

■ Logging In to the Local Operator Panel

■ Changing a User Password

Logging In For the First Time After Library Installation
1. With the admin user ID, log in to SLC with the first eight characters of the 

activation password provided by Oracle.

2. Change the admin password:

a. Select Tools > User Mgmt

b. Complete the password fields.

c. Click Modify.

Logging In to the Standalone SLC
1. To start SLC on your system, either:

■ Double-click the SLC desktop icon.

■ Select Start > RunSLConsole or Launch > RunSLConsole.

2. Enter your login information. Click Log on.

Logging In to the Web-launched SLC
To log in using a browser, download Mozilla Firefox from http://www.mozilla.com. 
On Solaris platforms, you can also log in to the web-launched SLC using the command 
line. 

1. Obtain the DNS alias or IP address of the SLC server.

2. Choose a login method:

Note: After an RE failover, log in using the IP address or DNS alias 
of the newly active library controller (previously the standby 
controller).
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– Command line — Available on Solaris only. In the terminal window, enter:

javaws http://server_ID:port_ID/opel/slc.jnlp

– Browser — Available on either Windows or Solaris. In a browser on the client 
system, go to the SLC Web Start application:

http://server_ID:port_ID/opel

where:

■ server_ID — Either the IP address or DNS alias of the SLC server.

■ port_ID — Port ID of the SLC application, typically 8080.

■ opel — The name (context root) of the web-launched SLC application on the 
server.

3. Click Launch Now.

4. Specify the action to take with the slc.jnlp file. Select either:

■ Open with Java Web Start Launcher to start SLC directly.

■ Save to Disk to save the slc.jnlp file to your client and log in to the SLC later.

5. If this is your first time running the web-launched SLC, complete the digital 
signature warning dialog box (verify the publisher and click Run).

6. Enter your SLC login information. Click Log on.

Logging In to the Local Operator Panel
Only one user at a time can log in to the local operator panel.

1. If the screen is blank, touch the screen anywhere to activate the login screen.

2. Enter your login information.

3. Click Log on.

Changing a User Password
Each site has a fixed set of user IDs: admin (customer administrator), service (Oracle 
support representative), and oem (third-party field service technician). Each user ID is 
assigned a set of permissions that determines access to utilities within SLC. 

1. Log in to SLC using the account you want to modify.

2. Select Tools > User Mgmt

3. Complete the following fields: Current Password, New Password, and Retype 
Password.

4. Click Modify.



5

Activating Optional Features 5-1

5Activating Optional Features

Hardware activation files enable optional features of the library, such as capacity 
upgrades and partitioning. You must install one hardware activation file for each 
feature.

■ Downloading a New Hardware Activation File

■ Installing a New Hardware Activation File

■ Displaying Current Hardware Activation Files

■ Deleting a Hardware Activation File

■ Enabling Features on a Library with Firmware Before FRS_7.00

Downloading a New Hardware Activation File
Only use this procedure for libraries with firmware FRS_7.00 or above. For libraries 
with lower firmware levels, see "Enabling Features on a Library with Firmware Before 
FRS_7.00" on page 5-3.

1. Go to the Oracle Software Delivery Cloud at:

http://edelivery.oracle.com/

2. Click Sign In /Register.

3. Read the terms and restrictions. Indicate your acceptance.

4. Search for SL8500, and then select the hardware activation file. Click Select 
Platform.

5. Select GENERIC (All Platforms), and then click Select.

6. Verify the correct hardware activation file is listed under Selected Products, and 
then click Continue.

7. Select the available release. Click Continue.

8. Read the terms and restrictions. Indicate your acceptance, and then click 
Continue.

9. Save the zip file, and then extract it to the desired location.
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Installing a New Hardware Activation File

1. Use SLC to log in to the target library.

2. Select Tools > Hardware Activation.

3. Click the Install Hardware Activation Keys tab. 

4. Browse to the hardware activation file.

5. Review the hardware activation file details. Click Install.

6. Verify that the activation file installed successfully (see "Displaying Current 
Hardware Activation Files" on page 5-2). 

Displaying Current Hardware Activation Files

1. Log in to the target library.

As of firmware FRS_8.31 and SLC 6.25, all hardware activation files for a library 
complex are shown on a single screen. You can log in to any library in the 
complex.

2. Select Tools > Hardware Activation

3. Click the Current Hardware Activation Keys tab.

Deleting a Hardware Activation File
Deleting a hardware activation file is rarely necessary and can impact library 
operations. Having extra hardware activation files installed on a library does not cause 
problems (for example, capacity activation files that exceed the physical capacity of the 
library). 

1. Use SLC to log in to the target library.

2. Select Tools > Hardware Activation.

3. Click the Delete Hardware Activation Files tab.

4. Select the activation file to delete.

Note: As of firmware FRS_8.31 and SLC 6.25, a single partitioning 
hardware activation file activates partitioning across an entire library 
complex.

Note: You may need to perform additional tasks to use the new 
feature (see "Configuring Capacity" on page 6-1 and "Partitioning the 
Library" on page 7-1).

Note: To display a log of all hardware activation activity, use the 
Reports utility (see "Viewing Library and Device Reports with the 
Reports Utility" on page 14-1).
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5. Verify the correct activation file is selected, and click Delete.

Enabling Features on a Library with Firmware Before FRS_7.00
For SL8500 libraries with firmware before FRS_7.00, contact Oracle support to enable 
optional features. For firmware FRS_7.00 or above, use the processes described in 
"Downloading a New Hardware Activation File" on page 5-1.

Note: You may need to perform additional tasks after deleting the 
file (see "Deleting a Partition" on page 7-2).
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6Configuring Capacity

■ Applying the Default Capacity Configuration in a Single Library

■ Creating a Custom Capacity Configuration in a Single Library

■ Creating a Custom Capacity Configuration in a Library Complex

■ Resolving Orphaned Cartridges Caused by Capacity Changes

■ Guidelines for Customizing Capacity Activation

■ Effect on HLI Hosts after Modifying the Capacity Configuration

Applying the Default Capacity Configuration in a Single Library
For a non-partitioned single library with a single host, the library can automatically 
activate the capacity after you install the hardware activation file.

As of firmware FRS_8.31, the default configuration activates capacity from the 
drives-outward until the capacity license is exhausted.

1. To prevent conflicts, coordinate with other library users before configuring the 
library.

2. From standalone or web-launched SLC, select Tools > Select Active Cells.

3. Click the Design By Library tab.

4. Click Apply Default Capacity.

Note: The library controller automatically assigns capacity in a 
partitioned library. You can only configure capacity in a 
non-partitioned library.

Note: Applying the default capacity removes all drives from the 
media validation pool. To re-add the drives, see "Defining the Media 
Validation Pool" on page 11-1.

Caution: If there are warnings, DO NOT commit the changes. Click 
Details >>, then perform recovery moves on the orphaned cartridges 
(see "Moving Cartridges (Recovery Moves)" on page 10-1).
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5. Reconfigure library host applications to recognize the changes (see the host 
software documentation).

Creating a Custom Capacity Configuration in a Single Library

1. To prevent conflicts, coordinate with other library users before configuring the 
library.

2. From standalone or web-launched SLC, select Tools > Select Active Cells > 
Design By Library tab.

3. Select areas of the library from the drop-down lists. Then, click Add (to select the 
area for activation) or Remove (to deactivate the area).

4. After you complete the configuration, click Apply User Design.

5. Reconfigure library host applications to recognize the changes (see the host 
software documentation).

Creating a Custom Capacity Configuration in a Library Complex

1. To prevent conflicts, coordinate with other library users before configuring the 
library.

2. From standalone or web-launched SLC, select Tools > Active Cells.

3. Select areas of the library (you can click the Rail or Library buttons, or click 
individual areas). Then, click Add (to activate) or Delete (to deactivate). 

Red sections indicate activate capacity. White sections indicate inactive capacity. 
The smallest capacity activation increment is a quarter rail for a maximum of 16 
regions per library.

4. After you complete the configuration, click Apply User Design.

Note: You can click Refresh to discard uncommitted changes and 
restore the last saved configuration. You must apply the configuration 
to save it to the library controller.

Caution: If there are warnings, DO NOT commit the changes. Click 
Details >>, then perform recovery moves on the orphaned cartridges 
(see "Moving Cartridges (Recovery Moves)" on page 10-1).

Note: You can click Refresh to discard uncommitted changes and 
restore the last saved configuration. You must apply the configuration 
to save it to the library controller.

Note: Clicking Reset Capacity removes the current capacity 
configuration and all drives from the media validation pool, requiring 
you to create a new custom capacity design.
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5. Reconfigure library hosts to recognize the changes (see the host software 
documentation).

Resolving Orphaned Cartridges Caused by Capacity Changes
Changing the active capacity of the library may cause orphaned cartridge errors. A 
cartridge becomes orphaned when it is inaccessible to the host.

To resolve orphaned cartridges, you can:

■ Generate a report of orphaned cartridges (see "Generating Active Capacity 
Reports" on page 14-2).

■ Audit the library (see "Auditing the Library" on page 12-1).

■ Perform recovery moves on a cartridge (see "Moving Cartridges (Recovery 
Moves)" on page 10-1).

For partitioned libraries, see "Resolving Orphaned Cartridges Caused by Partitioning 
Changes" on page 7-5.

Guidelines for Customizing Capacity Activation
■ Select storage resources in the largest blocks possible (rails, library sides, or library 

walls). Avoid selecting individual drives and storage arrays.

■ For best access to drives, activate library inner and outer library walls together and 
activate storage slots near the tape drives.

■ When rapid import and export of cartridges is a priority, activate storage slots near 
the Cartridge Access Ports (CAPs).

■ Avoid deactivating a slot containing a cartridge or manually moving a cartridge to 
an inactive slot. This will create an orphaned cartridge.

Effect on HLI Hosts after Modifying the Capacity Configuration
Initiate an audit through the host software after modifying the capacity configuration.

After activating capacity, the affected library will temporarily go offline and then come 
back online. While offline, the library stops accepting new incoming host jobs, but will 
complete the jobs already accepted. There is no need to disconnect and re-connect the 
HLI host.

The library controller sends an asynchronous message to any host, notifying them that 
the library configuration has changed. ACSLS hosts must perform an audit of a 
non-partitioned library to account for the new capacity. Hosts can continue processing 
jobs while the audit takes place.

Caution: If there are warnings, DO NOT commit the changes. Click 
Details >>, then perform recovery moves on the orphaned cartridges 
(see "Moving Cartridges (Recovery Moves)" on page 10-1).
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7Partitioning the Library

Library partitioning reserves library resources (drives, slots, and bulk CAPs) for the 
exclusive use of a specified host. Partitioning is included with a new library purchase. 
You no longer need to purchase the feature separately. However, partitioning is still 
enabled with a hardware activation file (see "Activating Optional Features" on 
page 5-1).

As you allocate slots to a partition, the library controller automatically activates these 
slots. Ensure there is enough purchased capacity for your partitioning design. 
Partitions can be non-contiguous. 

■ Partitioning the Library Using SLC

■ Sharing CAPs in a Partitioned Library

■ Resolving Orphaned Cartridges Caused by Partitioning Changes

■ Maximizing Library Performance when Partitioning

Partitioning the Library Using SLC

■ Adding a Partition ID

■ Changing the Name of a Partition

■ Deleting a Partition

■ Allocating Resources in a Partition for a Single Library

■ Allocating Resources in a Partition for a Library Complex

■ Committing Partitioning Changes

Adding a Partition ID
1. Stop all host operations.

Note: Rotational CAPs are a shared library resource, so you cannot 
assign them to a partition (see "Sharing CAPs in a Partitioned Library" 
on page 7-5).

Note: No partitioning changes occur until you apply the changes 
with the Commit tab. To discard uncommitted changes, click Refresh.
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2. Select Tools > Partitions > Summary (Step 2) tab.

3. In the Partition Allocation Summary area, click Add Partition.

4. Select a partition ID from the drop-down list and enter a partition name. Partition 
IDs do not need to be consecutive. 

5. Click OK.

6. For a single library, proceed to "Allocating Resources in a Partition for a Single 
Library" on page 7-2.

For a library complex, proceed to "Allocating Resources in a Partition for a Library 
Complex" on page 7-3.

Deleting a Partition
When you delete a partition, all resources allocated to the partition are marked 
available, all host connections for the partition are deleted, and the partition ID is 
deleted.

1. Move valid data cartridges out of the partition that you will delete (see "Moving 
Cartridges (Recovery Moves)" on page 10-1).

2. Stop all host operations.

3. Select the Tools > Partitions > Summary (Step 2) tab.

4. In the Partition Allocation Summary table, select the partition to delete.

5. Click Delete Partition.

6. For a single library, click the Design by Library (Step 3) tab. Then, click Verify.

For a library complex, verification is automatic.

7. If there are no warnings, proceed to "Committing Partitioning Changes" on 
page 7-4. 

Changing the Name of a Partition
1. Select Tools > Partitions > Summary (Step 2) tab.

2. In the Partition Allocation Summary table, select partition to modify.

3. Click Modify Partition.

4. Enter the partition name. Click OK.

5. Proceed to "Committing Partitioning Changes" on page 7-4.

Allocating Resources in a Partition for a Single Library
1. Select the Tools > Partitions > Design by Library (Step 3) tab.

2. Select a partition ID from the drop-down list.

3. Select the areas of the library using the drop-down lists. Click Add (to allocate) or 
Remove (to unallocated).

Caution: If there are warnings, click Details >> and perform 
recovery moves on the orphaned cartridges (see "Moving Cartridges 
(Recovery Moves)" on page 10-1). The re-verify the design.
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4. To refine the partition, select Remove Array or Add Array from the second 
drop-down list. Then, click the drives, arrays, or bulk CAPs to modify.

5. Repeat steps 2 - 4 for each partition ID.

6. When you complete the partition design, click Verify.

7. If there are no warnings, proceed to "Committing Partitioning Changes" on 
page 7-4.

Specifications for Single Library Partitioning
■ Up to eight partitions.

■ Smallest slot increment is one array.

■ Smallest drive increment is one drive.

Allocating Resources in a Partition for a Library Complex
1. Select the Tools > Partitions > Design (Step 3) tab.

2. Select a partition from the options in the upper left (if there are no partitions, see 
"Adding a Partition ID" on page 7-1).

3. Select resources of the library. You can click the Rail or Library buttons, or click 
individual areas.

4. Click Add (to allocate) or Delete (to unallocate).

5. Repeat steps 2-5 for each partition.

6. Proceed to "Committing Partitioning Changes" on page 7-4.

Specifications of Library Complex Partitioning
■ Up to 16 partitions total, with a maximum of eight per library.

Note: You can assign bulk CAPs to a partition. Bulk CAPs are the 
larger rectangles on the ends of each rail. An S indicates a shared CAP.

Note: To re-assign a resource from one partition to another, you must 
remove the resource from the initial partition before re-allocating it.

Caution: If there are warnings, click Details >> and perform 
recovery moves on the orphaned cartridges (see "Moving Cartridges 
(Recovery Moves)" on page 10-1). Then re-verify the design.

Note: You can assign bulk CAPs to a partition. Bulk CAPs are the 
larger rectangles on the ends of each rail. An S indicates a shared CAP.

Note: To re-assign a resource from one partition to another, you must 
remove the resource from the initial partition before re-allocating it.
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■ Smallest slot increment is a quarter rail (for example: the inner wall of rail 1 on the 
right side of the library)

■ Smallest drive increment is one drive.

■ Partition boundaries can span across pass-thru ports (PTPs).

Committing Partitioning Changes
No changes are made to the partitioning configuration until you complete these 
procedures.

1. To prevent configuration conflicts, you should make the library unavailable to 
other users and stop all host operations before committing partitioning changes.

2. Select the Commit (Step 4) tab.

3. Click Apply.

4. Update any affected host applications to recognize the changes (see the host 
software documentation).

Meaning of the SLC Partitioning Icons

Figure 7–1 Library Complex Partitioning Example

Figure Legend:

1. Selects the full library

Caution: If there are warnings, DO NOT commit the changes. Click 
Details >>. Then, perform recovery moves on the orphaned cartridges 
(see "Moving Cartridges (Recovery Moves)" on page 10-1).

Table 7–1 Library Partitioning Icons

Icon Description

 (white rectangle)
Available — area of rail not yet assigned to a partition

 (colored rectangle)
Allocated — area of rail assigned to a partition

 (white rectangle with S)
Shared Bulk CAP

Library complex partitioning only

 (thick black border)

Selected — area chosen for modification. Clicking Add 
assigns the area to a partition. Clicking Delete makes the 
area available to other partitions.
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2. Selects a half rail

3. Allocated half rail to red partition

4. Available quarter rail 

5. Selected quarter rail (indicated by the thick black border)

Sharing CAPs in a Partitioned Library
In a partitioned library, hosts can share CAPs. Each host can reserve the CAP when 
needed, and then release the CAP when it is no longer required. A host can reserve a 
CAP if the CAP is empty, closed, locked, and not already reserved by another 
partition. CAP auto enter mode is disabled in partitioned libraries, because it interferes 
with the reservation system (see "Auto Enter Mode" on page 8-5).

If the partition does not release the CAP reservation and you cannot terminate the 
enter or eject command in ACSLS or ELS, a library administrator must override the 
reservation (see "Overriding a CAP Reservation of a Partition" on page 8-3).

Resolving Orphaned Cartridges Caused by Partitioning Changes
In partitioned libraries, an orphaned cartridge is in a slot not allocated to the original 
host. Orphaned cartridges can occur when you change the size of a partition, delete a 
partition, or move a cartridge to a slot or drive that is not allocated to a partition.

In a partitioned library, orphaned cartridges can cause data loss. A host that finds an 
orphaned cartridge in its partition may treat the cartridge as a scratch volume and 
overwrite the data. 

SLC will warn you when it identifies orphaned cartridges. To resolve orphaned 
cartridges:

■ Generate a report of orphaned cartridges (see "Generating Active Capacity 
Reports" on page 14-2 )

■ Audit the library (see "Auditing the Library" on page 12-1)

■ Perform a recovery move on the cartridge (see "Moving Cartridges (Recovery 
Moves)" on page 10-1)

Maximizing Library Performance when Partitioning
■ Partition storage slots in the largest blocks possible (rails, library sides, or library 

walls). Partition complete library rails to minimize the use of elevators. In a library 
complex, keep a partition contained within a library to minimize the use of PTPs.

■ For best access to drives, activate inner and outer library walls together.

■ Avoid partitioning individual drives and storage slot arrays. Individually select 
and deselect resources only when you need to fine-tune a capacity that has already 
been broadly defined in larger blocks.

■ For quicker enter and ejects, partition storage slots close to the CAPs. For quicker 
access to stored data, partition storage slots close to the drives.
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8Operating a CAP

Cartridge access ports (CAPs) are used to enter or eject cartridges. There are two CAP 
types: bulk CAPs and rotational CAPs. For an overview of the CAP types, see 
"Cartridge Access Ports (CAPs)" on page 1-4.

■ Entering Cartridges Using a CAP

■ Ejecting Cartridges Using a CAP

■ Removing a CAP Magazine from a Bulk CAP

■ Locking/Unlocking a CAP

■ Overriding a CAP Reservation of a Partition

■ Modifying Bulk CAP Messages

■ Enabling and Disabling a Bulk CAP

■ CAP Modes

■ Guidelines for using CAPs

See Also
■ "Sharing CAPs in a Partitioned Library" on page 7-5

Entering Cartridges Using a CAP
CAP magazines are removable. You can place cartridges in any magazine slot and in 
any order with the hub gear facing down and cartridge label facing you.

1. Initiate the enter operation at the host (see the host software documentation).

2. When the unlock indicator turns on, press the CAP button.

3. Place the cartridges in the CAP with the hub gear face down and barcode toward 
you. 

Caution: CAP magazines must be standing up when you load 
cartridges. Placing the CAP magazine on its back while loading 
cartridges can cause robot errors due to improper cartridge alignment.

Caution: To avoid equipment damage, do not force the CAP to open 
or close. Do not enter unlabeled cartridges or place cartridges 
upside-down.



Ejecting Cartridges Using a CAP

8-2 StorageTek SL8500 Library Guide

4. If using a bulk CAP, close the CAP door and press the CAP button.

If using a rotational CAP, press the CAP button to close the CAP.

The library moves the cartridge from the CAP to a storage slot, records the 
cartridge's location, and sends the location to the host. When the CAP is empty, 
the library returns the CAP to its default state.

How to Use CAPs to Maximize Library Performance
■ Place cartridges that require numerous enters and ejects adjacent to CAP 

magazines. 

■ Load magazines adjacent to the rail in which the cartridges will reside.

■ To help identify which cartridges go to which rail, place labels outside the CAP to 
indicate the type of cartridge for a magazine.

■ Enter cartridges using a CAP magazine adjacent to the rail with compatible tape 
drives.

Ejecting Cartridges Using a CAP

1. Initiate the eject operation at the host (see the host software documentation).

2. When the unlock indicator turns on, press the CAP button. 

The CAP door opens.

3. Remove all cartridges from the CAP.

4. If using a bulk CAP, close the CAP door and press the CAP button.

If using a rotational CAP, press the CAP button to close the CAP.

5. The robot continues filling the CAP until all cartridges you specified are exported. 
Repeat step 2 through step 4.

Once the library ejects all cartridges, the robot audits the CAP to verify it is empty 
(the robot does not read cartridge labels during export operations). Then, the 
library erases the location of the cartridge from the library controller database and 
the host database. The CAP returns to its default state.

Caution: To avoid equipment damage, do not force the CAP to open 
or close.
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Removing a CAP Magazine from a Bulk CAP

Locking/Unlocking a CAP
Normally, the host software unlocks or locks a CAP. However, you can use the 
following procedure if you cannot unlock the CAP through the host. An unlocked 
CAP is reserved by the library and unavailable to all hosts until it is locked.

1. Attempt to unlock the CAP using the host software.

2. If you cannot unlock the CAP through the host, in SLC select Tools > Diagnostics.

3. Expand the CAP folder. Select the CAP to modify.

4. Click the Access tab.

5. In the Locked pull-down list select:

■ False to unlock.

■ True to lock.

6. Click Apply.

Overriding a CAP Reservation of a Partition
If the partition does not release the CAP reservation and you cannot terminate the 
enter or eject command on the host, use this procedure to override the CAP 
reservation.

1. In SLC, select Tools > Diagnostics.

2. Expand the CAP folder, and then select the CAP to override.

Note: If the CAP is reserved by a host, the host must release the CAP 
reservation before you can unlock the CAP. 

Note: You must follow all steps in this procedure, or the CAP could 
become unavailable to all partitions.
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3. Click the Unreserve tab. Note the partition ID of the CAP.

4. Click Apply to override the reservation.

5. If the CAP is locked, unlock it (see "Locking/Unlocking a CAP" on page 8-3).

6. Open the CAP. Remove any cartridges.

7. Close the CAP. The library verifies the CAP is empty. The CAP status changes to 
"unreserved", which makes the CAP available to all partitions.

8. Determine if you should re-enter the cartridges into the library. Ensure you enter 
the cartridges into the correct partition.

Modifying Bulk CAP Messages
SLC can display a CAP notification message based on a message number sent from 
ACSLS or ELS during an enter or eject. The message displays on the Systems Details 
CAP Status page after the CAP unlocks (see "Viewing Device Status and Properties" on 
page 13-2).

You must configure the message in SLC (see below) and send the message number 
with an enter or eject request from the host (see the host software documentation). 

Creating a New Bulk CAP Message
1. In SLC, select Tools > Configuration.

2. Click the Cap Usage Messages tab.

3. Click Add.

4. Enter a message number (between 4 and 99).

5. Enter the message (maximum of 80 characters). Click OK.

6. Click Apply.

Modifying or Deleting an Existing Bulk CAP Message

1. In SLC, select Tools > Configuration.

2. Click the Cap Usage Messages tab.

3. Select a message from the list, and then click Modify or Delete.

Note: Messages longer than 18 characters will be cut off on the CAP 
status page. However, from the status page you can click on the 
message to view a pop-up of the entire message.

Note: You cannot modify or delete the first four messages.
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4. Click Apply.

Enabling and Disabling a Bulk CAP
The library will not use a disabled bulk CAP for entering or ejecting cartridges. For 
example, if you cannot comfortably operate the top CAPs, you should disable the 
CAPs on rail 1.

1. In SLC, select Tools > Configuration.

2. Click the Enable/Disable CAP tab.

3. Select Disable or Enable for the CAP.

4. Click Apply.

CAP Modes

Auto Enter Mode
Only non-partitioned HLI libraries support the CAP auto enter mode (see the host 
software documentation to enable auto enter).

CAP auto enter mode enables a library operator to open a CAP and initiate an enter 
operation without issuing an explicit enter request. CAPs in auto enter mode are left 
unlocked and do not require a host reservation.

Manual Mode
Manual mode is the most secure method of CAP operations. When in manual mode, 
the system locks a CAP by default, and its LED is off. To initiate an enter or eject 
operation using a manual CAP, you must enter an explicit enter or eject request before 
pressing CAP Open on the keypad.

Guidelines for using CAPs
■ Insert cartridges with the correct orientation (hub gear facing down and label 

facing you). You can skip slots in the CAP when loading cartridges.

■ Verify all cartridges are properly labeled before placing them into a CAP. Do not 
enter unlabeled cartridges.

■ To enter cartridges more efficiently, load the CAP magazines prior to issuing the 
enter command.

■ If only one CAP is required to do the job, do not use multiple CAPs. Opening 
multiple CAPs will increase the audit time.

■ If a robot adjacent to the CAP is inoperative, that CAP (or portion of a rotational 
CAP) is inaccessible.
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9Configuring Drives

■ Configuring Drive Cleaning

■ Configuring the Drive Tray Serial Numbers

■ Maximizing Library Performance Through Drive Placement

Configuring Drive Cleaning 
Library tape drives require periodic cleaning with a cleaning cartridge to prevent 
read/write errors. Library management software (such as ACSLS or ELS) must 
manage drive cleaning.

As of SL8500 firmware FRS_8.31 and SLC 6.25, the library will automatically clean 
media validation drives. Therefore, libraries using media validation must have 
cleaning cartridges in the reserved system slots. You can enter media validation 
cleaning cartridges using SLC (see "Importing or Exporting Diagnostic or Cleaning 
Cartridges" on page 10-3). Additionally, you can manage cleaning cartridges using the 
CLI (see the cleaning section of Appendix B, "Command Line Interface Reference").

Configuring Host-Managed Drive Cleaning
1. In SLC, select Tools > Configuration. Disable auto cleaning for the library and all 

partitions. Click Apply. (The auto clean function is disabled by default).

2. Enable automatic cleaning from the host.

a. For ELS, see the ELS System Programmer's Guide to enable the cleaning 
function.

b. For ACSLS, automatic cleaning is enabled by default. See the ACSLS 
Administrator's Guide.

3. Use ACSLS or ELS commands to enter cleaning cartridges into the library.

4. Use ACSLS or ELS to monitor the status of cleaning cartridges and drives.

Note: Enabling/disabling auto clean is not available through SLC. It 
is only available to the library administrator through the CLI.

Note: Do not use the SLC Import/Export page to enter cleaning 
cartridges for host managed cleaning.
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5. Use the ACSLS or ELS commands to eject cleaning cartridges from the library. You 
cannot use the SLC Import/Export page to eject host-managed cleaning cartridges.

Configuring the Drive Tray Serial Numbers
1. Select Tools > Configuration.

2. Click the Drive Tray S/N tab.

3. Click Refresh to display the current data.

4. To edit an individual drive tray serial number:

a. Double-click the Drive Tray S/N field.

b. Enter the drive tray serial number. Proceed to step 6.

5. To edit multiple drive tray serial numbers at once, you can edit a 
comma-separated value (csv) file:

a. Click Export, and then save the file to a desired location.

b. Open the file and edit only the drive tray serial numbers. Do not alter any 
other values. Save the changes.

c. In SLC, click Import. Locate the updated .csv file, and then click Open.

6. Click Apply, then Yes.

Maximizing Library Performance Through Drive Placement
■ To reduce elevator and pass-thru activity, place multiple drive types on each rail.

■ Group together tape drives and compatible cartridges on the same rail. 

■ For high mount rate applications, do not place sixteen drives on an rail. This can 
lead to increased wait times for the robot to be available. High mount rate 
applications may require clustering drives on more than one rail.

■ In a redundant robotics library, install drives in the outer columns (± 2) first. This 
allows both robots to access drives at the same time.
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10Managing Cartridges

■ Moving Cartridges (Recovery Moves)

■ Locating Cartridges

■ Viewing Cartridge Information

■ Importing or Exporting Diagnostic or Cleaning Cartridges

■ Cartridge Types

■ Handling Cartridges

■ Maximizing Library Performance Though Cartridge Placement

See Also:
■ "Entering Cartridges Using a CAP" on page 8-1

■ "Ejecting Cartridges Using a CAP" on page 8-2

■ "Resolving Orphaned Cartridges Caused by Partitioning Changes" on page 7-5

■ "Resolving Orphaned Cartridges Caused by Capacity Changes" on page 6-3

Moving Cartridges (Recovery Moves)
Moving a cartridge using SLC only updates the cartridge's location in the library 
controller database. You must perform an audit from the host software to update the 
host database to prevent mount failures.

To view a table of all cartridges in the library, see "Viewing Cartridge Information" on 
page 10-2.

1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the RcvrMove tab.

3. Select the Source Location Mode:

■ For VOLID, enter the vol-id of the cartridge to move.

■ For Location, select the cartridge's current location (CAP, Slot, Drive, 
Reserved Slots).

Caution: To avoid data loss, use caution when moving cartridges in 
partitioned libraries. Accidentally moving a cartridge from one 
partition to another will orphan the cartridge and the new partition 
may overwrite the existing data.
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4. Select the Destination Location type (CAP, Storage Slots, Drive, and Reserved 
Slots) and select the destination address.

5. Click Start.

6. Initiate a library audit from the host software to update the host database (see the 
tape management software documentation).

Locating Cartridges
You can search for a cartridge by volume ID, internal library address, or HLI address.

To view a table of all cartridges in the library, see "Viewing Cartridge Information" on 
page 10-2.

Locating a Cartridge by Volume ID
1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the Search tab.

3. Select VOLID.

4. Enter the volume ID (use * as a wildcard).

5. From the Requester drop-down list, select the format for the search results:

■ default to display in library internal address format.

■ hli0 or hli1 to display in HLI-PRC address format.

6. Select the Cartridge Type.

7. Click Search.

Locating a Cartridge by Address
1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the Search tab.

3. Select Location.

4. Select the search criteria from the drop-down list, and enter the address (wildcards 
are invalid).

5. From the Requester drop-down list, select the type of address you entered in the 
Location field.

6. Click Search.

7. Click . . . to see details about the cartridge. 

Viewing Cartridge Information
1. In SLC, select Tools > Reports.

Note: Only select Drive if the source is a CAP or reserved slot.

Do not move data cartridges into reserved slots. Reserved slots should 
only contain diagnostic or cleaning cartridges.
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2. Expand the Status Summary folder in the navigation tree.

3. Select the Cartridge Table.

See Also
■ "Viewing Library and Device Reports with the Reports Utility" on page 14-1

Importing or Exporting Diagnostic or Cleaning Cartridges

The library stores diagnostic and cleaning cartridges in reserved system slots. Host 
library applications cannot access these cartridges. The library can perform only one 
diagnostic or cleaning cartridge import or export operation at a time. The library 
controller reserves the CAP for the entire operation.

Before importing, verify all cartridges have a proper label. Diagnostic cartridges must 
have DG as the first two characters of the eight character volume ID. Cleaning 
cartridges must have CLN as the first three characters.

Importing Diagnostic or Cleaning Cartridges

1. Verify that the library has enough empty system slots. Robot recovery and library 
initialization requires one empty system slot on each side of the library.

2. Verify that the CAP is empty, not reserved by a host, closed, and locked (see 
"Viewing Device Status and Properties" on page 13-2).

3. In SLC, select Tools > Diagnostics.

4. Expand the CAP folder in the device tree. Select a CAP to use.

5.  Click the Import/Export tab.

6. In the Operation section, select Import Cleaning/Diagnostic cartridges.

7. In the "Select favored rail for import" list, select the preferred storage rail or No 
affinity.

8. Click Start. 

9. Load the cartridges into the CAP (see "Entering Cartridges Using a CAP" on 
page 8-1).

Caution: The library will treat used cleaning cartridges as new. To 
avoid equipment damage, do not re-import used cleaning cartridges.

Note: As of SL8500 firmware FRS_7.00 and SLC 5.50, host 
applications (such as ACSLS or ELS) must manage drive cleaning. For 
host managed cleaning, do not use the following procedure. Instead, 
enter cleaning cartridges using the host software.

Note: The library enters diagnostic and cleaning cartridges into 
system slots on the selected rail if space is available. Otherwise, the 
library distributes cartridges among all system slots.
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Exporting Diagnostic or Cleaning Cartridges
1. Verify that the library has enough empty system slots. Robot recovery and library 

initialization requires one empty system slot on each side of the library.

2. Verify that the CAP is empty, not reserved by a host, closed, and locked (see 
"Viewing Device Status and Properties" on page 13-2).

3. In SLC, select Tools > Diagnostics.

4. Expand the CAP folder in the device tree. Select a CAP to use. 

5. Click the Import/Export tab.

6. Select the type of export operation.

7. Click Start. 

8. When the unload notification appears, unload the CAP (see "Ejecting Cartridges 
Using a CAP" on page 8-2).

Cartridge Types
■ Data cartridges — store customer data.

■ Diagnostic cartridges — used by service representatives to run read/write tests on 
drives (see "Importing or Exporting Diagnostic or Cleaning Cartridges" on 
page 10-3)

■ Cleaning cartridges — clean the tape path and read/write heads of the tape drives 
(see "Configuring Drive Cleaning" on page 9-1)

Cartridge Labels
For information about media label standards, see the Barcode Technical Brief on OTN. 
All library cartridges must have a readable external label. The robot reports an error 
when it encounters an unreadable label.

Non-labeled cartridges are not supported. The library exports any non-labeled 
cartridges it finds through the CAP. A non-labeled or unknown type cartridge will not 
mount to a drive.

Handling Cartridges

■ Keep cartridges clean and inspect them for damage before each use.

■ Never open a cartridge.

■ Do not handle tape that is outside the cartridge.

■ Do not expose the tape or cartridge to direct sunlight, moisture, or magnetic fields.

Inspecting a Cartridge
Always inspect a cartridge before you insert it into a tape drive or a library. A 
defective or dirty cartridge can damage a tape drive. Never use a damaged cartridge. 
Look for:

Caution: When cartridges are improperly handled, loss of data or 
damage to a library component can occur.
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■ Dirt or debris

■ Cracked or broken housing

■ Damaged write-protect switch

■ Liquid in the cartridge

■ Labels not firmly attached, or that extend over the cartridge edge

Cleaning the Cartridge Exterior
Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. Use Oracle 
StorageTek Tape Cleaner Wipes to clean the cartridges. These wipes are saturated with 
isopropyl alcohol. Do not let any solution touch the tape or get inside the cartridge.

Storing Cartridges
Store cartridges in a clean environment. Do not take a cartridge out of its protective 
wrapping until you are ready to use it. Use the tear string, not a sharp instrument, to 
remove the wrapping. Before using a cartridge, ensure that it has been in its operating 
environment for at least 24 hours.

Maximizing Library Performance Though Cartridge Placement
■ Group together cartridges and compatible drives on the same rail. Mount 

cartridges in tape drives that are on the same rail and limit the distance cartridges 
must travel. Minimize elevator operations between rails within a library and 
pass-thru operations between libraries. 

■ Ensure that each rail has the enough empty slots, data cartridges, scratch 
cartridges, and tape drives to support peak usage.

■ Move inactive cartridges out of the library. Move less frequently used cartridges 
away from the drives and more frequently used cartridges closer to the drives.

■ Load magazines adjacent to the rail in which the cartridges will reside..

■ Use Library Content Manager (LCM) to automatically manage free slots for z/OS 
customers. 

■ Use the float option available with host management software (ACSLS and HSC).

■ Place cartridges that require significant enters and ejects on rails adjacent to a CAP. 
In libraries with rotational CAPs, place inactive cartridges on the top rail. 

Caution: Potential damage to cartridges. Do not use acetone, 
trichloroethane, toluene, xylene, benzene, ketone, methylethyl ketone, 
methylene chloride, ethyldichloride, esters, ethyl acetate, or similar 
chemicals to remove labels or clean cartridges.



Maximizing Library Performance Though Cartridge Placement

10-6 StorageTek SL8500 Library Guide



11

Validating Media 11-1

11Validating Media

■ Media Validation Requirements

■ Defining the Media Validation Pool

■ Starting or Resuming Media Validation

■ Stopping a Validation

■ Updating Host Information After Modifying the MV Pool

Media Validation Requirements
■ Minimum SL8500 FRS_8.31 and SLC 6.25 (for T10000 cartridges)

■ Minimum SL8500 FRS_8.67 and SLC 6.71 (for LTO cartridges)

■ A designated pool of LTO 6/7/8 drives in ADI mode or T10000C/D drives at TTI 
level 5.40+

■ High-memory HBT card

■ Minimum STA 2.0 to automate media validation for T10000 cartridges (optional)

Defining the Media Validation Pool
To validate the integrity of cartridges using the media validation (MV) feature, you 
must define a pool of valid drives. You can perform media validation with the 
following drive types:

■ LTO 6, 7, or 8 in ADI mode (requires minimum FRS_8.67 and SLC 6.71)

■ T10000C or T10000D at TTI level 5.40+ (requires minimum FRS_8.31 and SLC 6.25)

The pool is not considered a partition, does not contain cartridges, and hosts cannot 
access the drives in the pool.

1. For a library complex, you can log in to any library within the complex to modify 
the MV pool. Verify all libraries in the complex are online.

2. Verify that hosts are not using the drives you want to add to the pool. Adding a 
drive to the MV pool will trigger an automatic reconfiguration in all ELS hosts 
attached to the library

Note: The library automatically cleans MV drives regardless of the 
auto clean status for the library. You should ensure there are cleaning 
cartridges in the library.
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3. In SLC, select Tools > Media Validation. Click the Slot Selection tab.

4. Click Refresh to display the latest configuration.

5. Place a maximum of 10 drives into the pool. Highlight the drive slots, and then 
click Add or Remove.

6. Click Apply.

7. If using a partitioned library reassign any drive slots removed from the pool to a 
partition (see "Partitioning the Library" on page 7-1).

8. Reconfigure host applications (see "Updating Host Information After Modifying 
the MV Pool" on page 11-3).

Media Validation Drive Pool Icons

Starting or Resuming Media Validation
You can only validate one cartridge at a time per each SLC session. To automate the 
process for T10000 cartridges, use StorageTek Tape Analytics 2.0 or above (see the STA 
documentation).

1. Log in to the library. For a library complex, log in to the library that contains the 
drive that you will use for validation.

2. In SLC, select Tools > Media Validation. Click the Media Validation tab.

3. Select a drive. If there are no drives listed, see "Defining the Media Validation 
Pool" on page 11-1.

4. Select a cartridge from the list or enter a VOLSER in the cartridge label field.

5. Select a validation type (see Validation Types for a description).

Note: When adding drives to the MV pool, the library (or affected 
partition) will go offline.

SLC Drive Icon Meaning

 
Empty drive slot

 
Slot contains either an invalid drive type or a correct drive type 
in an invalid state

 
Correct drive type (T10000C/D or LTO 6/7/8 in ADI) in a valid 
state

 
Partition number of drive slot

 
Drive slot is in media validation pool

Note: You may not be able to select a drive if the drive is in an 
invalid state, the drive type is invalid, the IBM LTO drive is not in ADI 
mode, or you are not logged into the library containing the drive.



Updating Host Information After Modifying the MV Pool

Validating Media 11-3

6. Click Start. Validation begins if the cartridge loads successfully.

Once validation completes, the library returns the tape to its source location (if 
available, otherwise the library moves the tape to a system slot for host recovery).

Validation Types

Stopping a Validation
If a host requests a cartridge currently being validated, the validation stops. You can 
also stop the validation using SLC.

1. Log in as the user who initiated the validation.

2. In SLC, select Tools > Media Validation.

3. Select the Media Validation tab.

4. Click Stop. 

Once validation stops, the library returns the tape to its source location (if 
available, otherwise the library moves the tape to a system slot for host recovery). 

Updating Host Information After Modifying the MV Pool
■ For ACSLS, you must initiate re-configuration after modifying the MV pool. Use 

the config drives <panel_id> utility. For more information, see the ACSLS 
Administrator's Guide.

Note: If media validation is interrupted, select the Complete 
Resume or Complete Plus Resume to resume where the validation 
left off. You cannot resume an LTO validation, Basic Verify, Standard 
Verify, or Rebuild MIR.

Type of Validation T10000 Description LTO Description
Approximate Duration per 
Cartridge

Basic Verify Simple mount/dismount of the 
cartridge to determine if MIR is 
unreadable or out of sync.

Simple mount/dismount of the 
cartridge. Reads the CM on the 
mount.

2 minutes

Standard Verify Starts at beginning of tape (BOT).

Reads1000 records from BOT.

Reads wrap that contains EOD, 
then into the EOD.

Reads outermost wraps on top and 
bottom bands to verify edges.

Starts at beginning of tape 
(BOT).

Reads 2 wraps, then stops the 
validation.

30 minutes

Complete Verify
or
Complete Resume

Starts at beginning of tape (BOT) or 
resumes where it left off. Reads 
data at tape speed.

Starts at beginning of tape (BOT) 
and verifies to EOD. Resume not 
available.

T10000C: 6 hours 

T10000D: 9 hours max

LTO: 5 to 8 hours

Complete Plus1

or
Complete Plus 
Resume

1 Plus StorageTek Data Integrity Validation — encryption key management system required.

Starts at beginning of tape (BOT) or 
resumes where it left off.

Checks DIV CRC to determine if it 
exists.

Not Available T10000C: 6 hours for 
compression ratios less than 
2.5:1.

T10000D: 9 hours for 
compression ratios less than 3:1

Rebuild MIR Starts at invalid position in the 
MIR. Reads data at tape speed

Not Available T10000C: 5 hours 

T10000D: 9 hours
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■ For ELS, no action is required after modifying the MV pool. ELS hosts 
automatically reconfigure. However, the reconfiguration can cause a disruption in 
mount/dismount requests when trying to set a lock on the control data set (see the 
host management documentation).

Effect on HLI Hosts of Modifying the MV Pool
After adding drives to the MV pool, the library (or affected partition) will go offline. 
The affected hosts receive "Configuration Changed", "LSM Ready", and then "Not 
Ready" messages from the library. ELS automatically removes drives moved to the MV 
pool from its configuration. ACSLS automatically updates drives moved to the MV 
pool to an offline state, but ACSLS requires you to initiate re-configuration.

After removing drives from the MV pool, the library and partitions remain online. For 
a non-partitioned library, the drive slots are available to hosts immediately. ELS hosts 
begin re-configuration, but ACSLS hosts require you to initiate re-configuration. For a 
partitioned library, you must allocate the drive slot removed from the MV pool to a 
partition (see "Partitioning the Library" on page 7-1).
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An audit verifies cartridge locations and updates the library database, which contains 
the volume ID, current location, and verified status for each cartridge.

The library automatically performs an audit after an access door closes or after the 
library initializes.

■ Performing a Physical Audit of the Entire Library

■ Performing a Physical Audit on a Range of Cells

■ Performing a Verified Audit on a Range of Cells

■ Meaning of the Audit Indicator

See Also
■ "Viewing Cartridge Information" on page 10-2

Performing a Physical Audit of the Entire Library

For an entire library audit, the robot visits all slots (storage, CAP, drive, reserved), 
updates the cartridge database, and changes the "verified" status of cartridge locations 
to true.

Do not run this audit during peak activity periods (see "Effects of an Entire Library 
Audit" below). The audit takes approximately 0.5 seconds per cartridge slot.

1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree.

3. Click the Audit tab.

4. Select Yes for Entire Library (select No for Physical Audit and Verified Audit).

5. Click Audit.

Note: Initiating an audit from SLC only updates the library database. 
To update the host database, you must initiate an audit from the host.

Note: You cannot stop a physical audit after it begins.
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Effects of an Entire Library Audit
Although an entire library audit is a background process and does not interrupt 
library operations, it does require sharing of robot resources. You may notice that 
library operations take slightly longer to perform until the audit finishes. There may be 
a slight delay in processing a request that requires information about a location not yet 
audited because the library will audit the location before processing the request.

Performing a Physical Audit on a Range of Cells

1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree.

3. Click the Audit tab.

4. Select Yes for Physical Audit (select No for Entire Library and Verified Audit).

5. From the drop-down lists, select the internal address for the starting and ending 
locations of the audit.

6. Click Audit.

Performing a Verified Audit on a Range of Cells
A verified audit validates the status of a specific cartridge location or range of 
locations in the cartridge database. If a cartridge address has a verified status of false, 
a physical audit of that location is performed and the cartridge database is updated.

1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree.

3. Click the Audit tab.

4. Select Yes for Verified Audit (select No for Entire Library and Physical Audit).

5. From the drop-down lists, select the internal address for the starting and ending 
locations of the audit.

6. Click Audit.

Meaning of the Audit Indicator
To indicate an audit is in progress, the SLC displays a spinning indicator and the 
message "Audit in progress". When you see this indicator do not open the library 
access door. This will cause the audit to restart.

The audit indicator only displays when an audit is initiated automatically (library 
access door has been opened and closed, library power up or reboot). The indicator 
does not display for audits initiated from SLC or the host.

Note: You cannot stop a physical audit after it begins.
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SLC only displays the latest library and device information saved to the library 
controller database. Click Refresh to update SLC with the latest configuration data.

■ Viewing Library Operational Status

■ Viewing Library Properties and Configuration

■ Viewing Device Status and Properties

■ Viewing the Local Operator Panel Type

■ Meaning of Library and Device Status Indicators in SLC

See Also
■ "Generating Reports and Logs" on page 14-1

■ "Viewing Cartridge Information" on page 10-2

Viewing Library Operational Status
1. In SLC, select Tools > System Detail. Select the Library in the device tree.

2. Click the Status tab.

3. Select a secondary tab:

■ General - displays the current operational state of the library. These values 
update whenever there is host activity, background operations, or operator 
activity. You can place the library online or offline with this tab (see "Taking 
the Library Offline" on page 15-1 and "Bringing the Library Online" on 
page 15-2).

■ Complex - displays the current operational state of a library complex.

■ Status Module - displays library status alerts. This feature is available only if 
service is active on the library. See also "Clearing Library Status Alerts" on 
page 16-6.

■ HLI - displays the current status of all HLI interface ports on the library. 
Information includes the local TCP/IP socket, local IP, connection status, port 
status, and transmission sent and received from the time of connection.

■ Internal Networks - displays port status.

Viewing Library Properties and Configuration
1. In SLC, select Tools > System Detail. Select the Library in the device tree.
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2. Click the Properties tab.

3. Select a secondary tab:

■ General - displays the physical, mechanical, logical, and network 
configuration of the library.

■ Complex - displays IP address information for a library complex.

■ Library Controller - displays details of the library controller, including the 
serial number and firmware versions.

■ Drive Controller - displays details of the drive controller, including the serial 
number and current firmware versions.

Viewing Device Status and Properties
You can view information about CAPs, drives, robots, redundant electronics, power 
supplies, and the safety door. You can also view device information using the SLC 
Reports utility (see "Viewing Library and Device Reports with the Reports Utility" on 
page 14-1).

1. In SLC, select Tools > System Detail.

2. Select the device folder in the device tree.

3. For status and properties information, expand the device folder. Select a device. 

4. Select a tab. Depending on the device you selected, refer to the corresponding 
information below.

Device Status and Properties Tabs
■ Status Tab - displays the current operational state of the device

■ Properties Tab - displays device configuration information, including the serial 
number and current firmware levels

Drive Tabs
Only drives have the following system details tabs.

■ Display Tab - displays network data, the Virtual Operator Panel (VOP) for T10000 
and T9840D drives, and drive LED status

■ Drive Tray Tab - displays the current status of a drive tray 

Note: For a bulk CAP library, select the CAP folder and click Status 
to view all CAPs at once and the bulk CAP enter/eject messages (see 
"Modifying Bulk CAP Messages" on page 8-4).

Drive Status Meaning

Empty No cartridge is mounted to the drive.

Unloaded Cartridge is ready for dismount.

Ready Cartridge is loaded.

NotCommunicating Controller card can not communicate with the drive.

rewindUnload Drive is busy rewinding and unloading.
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Redundant Electronics Card Status
"A" indicates the left card slot and "B" indicates the right card slot, as viewed from the 
back of the library.

■ hbca: Library controller, A (left) slot

■ hbcb: Library controller, B (right) slot

■ hbta: Drive controller, A (left) slot

■ hbtb: Drive controller, B (right) slot

Viewing the Local Operator Panel Type
1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree, and then click the OpPanel Tab.

The type is listed at the bottom of the screen. A W indicates windows-based and a 
DL or OL indicates linux-based.

Meaning of Library and Device Status Indicators in SLC

Health Status of a Device
The device tree of the System Details and the Diagnostics utility displays device heath 
status.

■ Normal — library device is functioning normally

■ Warning — device is offline or operating in a degraded state

■ Error — device has experienced a failure

Communication Status
The lower left of all SLC screens shows communication status, which indicates the 
communication status between SLC and the library controller.

■ Normal — SLC is communicating normally with the library controller

Card Status Meaning

Duplex: Software ready, 
switch possible

Active library controller is functioning normally.

Not installed Card is not installed in the library.

Ok Active or standby drive controller card is functioning normally.

Pre-standby: software 
not ready

Standby library controller card is loading standby code and is not 
ready to be used in an automatic failover or manual switch.

Standby: software ready Standby library controller card is functioning normally and can be 
used for an automatic failover or manual switch.

SLC Icon Meaning

Normal

Warning

Error
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■ Warning — server is taking longer than 10 seconds to respond

■ Error — server is taking longer than 30 seconds respond

After about 30–60 seconds of lost communication with the library controller, the 
heartbeat monitor turns gray, then red, and displays:

Heartbeat message not received from the library controller.

Log off the SLC and log on again to restore communication.

Health Status of the Library
The lower right of all SLC screens shows the library health status.

■ Normal — all library devices are functioning normally

■ Warning — one or more library devices is offline or operating in a degraded state

■ Error — one or more library devices has experienced a failure

After a device error is fixed, the library health indicator changes to "Warning". The 
indicator will not change to "Normal" until the library is taken offline. If there are 
multiple problems with a device or status alert condition, the health indicator 
displays the most severe condition.
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■ Viewing Library and Device Reports with the Reports Utility

■ Generating Active Capacity Reports

■ Generating Partitioning Reports (Single Library Only)

■ Generating Diagnostic Files for Oracle Support

■ Monitoring Library Events

See Also
■ "Viewing Library and Device Information" on page 13-1

■ "Viewing Cartridge Information" on page 10-2

Viewing Library and Device Reports with the Reports Utility
All report output is a static display of information at the time the report is generated. 
Click Update in the upper right corner to refresh the information. 

1. In SLC, select Tools > Reports.

2. In the navigation tree, expand a report folder. Select a report.

You can access additional reports from the Partitions utility or the Active Capacity 
utility. You can view individual device information using the System Details 
utility.

Note: Running multiple instances of SLC on the same workstation 
can cause inconsistent data on reports. It is recommended that only 
one user at a time produce SLC reports.

Table 14–1 SLC Reports

Folder Report Description

Statistics Drive Events Displays drive events and errors. The report can display up to 70 entries.

Drive Media Events Displays cartridge error events that have occurred with a drive. The report can 
display up to 500 entries.

General Events Displays a summary of library operational events.

Media Events Displays cartridge errors. The report can display up to 2000 entries.

Log EventLog Displays a log of events based on severity (see "Severity" on page 14-5).
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Generating Active Capacity Reports
1. In SLC, select Tools > Select Active Cells > View Reports tab. 

2. Select a report:

■ Cartridge and Cell Media Summary - displays slot addresses and volume 
serial numbers (volsers) for media within the active capacity area

■ Orphaned Cartridge Report - displays a detailed list of all orphaned 
cartridges

Generating Partitioning Reports (Single Library Only)
1. In SLC, select the Tools > Partitions > Reports tab.

2. Select a type of report from the menu:

■ Cartridge Cell and Media Summary — displays slot addresses and volume 
serial numbers (volsers) for the media in each partition

■ Orphaned Cartridge Report — displays slot addresses and volume serial 
numbers (volsers) for orphaned cartridges

■ Partition Summary — displays the resources allocated to each partition

■ Partition Details — displays details for a specific partition ID

Generating Diagnostic Files for Oracle Support
Your Oracle support representative may request that you capture and transfer the 
Management Information Base (MIB) or Log Snapshot file.

Status Summary Cartridge Table Lists cartridge location, media type, label, and status information.

Device Reserve Table Lists elevator, robot, and PTP reservation information.

Drive Table Lists drive location, type, and serial number information.

CAP Summary Lists the location of the CAPs.

Cartridge Summary Lists the location, media type, and label information for all cartridges in the library.

Drive Summary Lists drive location, type, serial number, code information, and device details.

Library Information Lists the library physical configuration, code version, and state of the library.

Robot Summary Lists robot address and state.

Status Detail CAP/Drive/Robot 
Details

Lists identifying information, code version, and status of the devices.

Library Details Lists the library physical configuration, code version, and state of the library.

Versions Hardware Versions Lists the FRU serial number for controller cards, CAPs, robots, and PTPs.

Software Versions Lists the code version for controller cards, CAPs, elevators, robots, and PTPs.

Audit Log Feature Audit Log Lists all feature activation activity for the life of the library. To view only the current 
hardware activation files, see "Displaying Current Hardware Activation Files" on 
page 5-2.

CAP Usage 
Messages

Messages Lists the CAP usage messages. To define the messages, see "Modifying Bulk CAP 
Messages" on page 8-4

Table 14–1 (Cont.) SLC Reports

Folder Report Description
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Generating the Library SNMP MIB File
1. In SLC, select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the TransferFile tab.

4. Select SNMP MIB. Click Transfer File.

5. Save the file using a .txt suffix.

6. E-mail the file to your Oracle support representative.

Generating the Library Log Snapshot File
You must save the log within 15 minutes of generation. The file is encrypted.

1. In SLC, select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the Transfer File tab.

4. Select Log Snapshot.

5. Select either All Devices or Selected Device. If you choose Selected Device, select 
the device.

6. Click Generate Log Snapshot on Library.

7. Click Yes, and then OK.

8. Click Transfer Log Snapshot To Your Computer.

9. Save the file using the automatically generated name. 

10. E-mail the file to your Oracle support representative.

Monitoring Library Events
The library controller continually monitors library operations and logs all events. 
Using the Monitors utility of SLC, you can open an event monitor to display event 
data or spool it to a file. Event monitors are useful tools for root cause analysis.

■ Event Monitor Types

■ Starting an Event Monitor

■ Saving Event Monitor Data to a File

■ Displaying Result Code Definitions

Starting an Event Monitor
1. In SLC, select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree.

3. Click an event monitor type (see )"Event Monitor Types" on page 14-4). Click 
Open.

4. Use the Monitor menu to pause, resume, permanently stop, or clear the event 
monitor. Use the Spool File menu to save the event monitor to a file (see "Saving 
Event Monitor Data to a File" on page 14-4).
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Saving Event Monitor Data to a File
You may need to send the file to your Oracle support representative to assist in 
diagnosing problems.

1. Open an event monitor (see "Starting an Event Monitor" on page 14-3).

2. In the event monitor window, select Spool File > Start Spooling.

3. Browse to the desired directory, enter the file name, and click Save.

4. To stop spooling, select Monitor > Stop Spooling.

Displaying Result Code Definitions
Result codes identify the library event type (result codes are the same as library 
EventIds).

1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the Search tab.

3. In the Search Type list, select Result Code.

4. To search for a specific result code, enter the complete code (wildcards or partial 
codes are invalid).

To list all result codes, select List All.

5. Click Search.

Event Monitor Types
There are four types of event monitors: All, Error Warn Info, Error and Warnings, and 
Errors. Each monitor type logs events based on the severity of the event. For example, 
the Errors monitor only logs error events (see "Severity" on page 14-5 for a description 
of the event types).

Each event logged in the event monitor contains the following information:

Time
Identifies when the event occurred.

Device ID
Identifies the library address of the device corresponding to the event.

User
Identifies the user that originated the event. This is "root" for HLI or SCSI host 
activities.

I / F
Identifies the interface type of the requester. The interface can be hli, scsi, or default 
(for SLC or CLI requests). 

Activity
Identifies the command that was issued, such as "load drive".

Note: To arrange multiple event monitors on one screen, use the 
Window menu in the upper right corner.
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Request Identifier
Identifies all host interface requests. Helps track the sequence of log activity resulting 
from each host request.

Severity
Identifies the significance of the event. Some event data is non-volatile, meaning it 
persists across system power cycles.

Error — non-volatile data indicating a fault that prevented a request (host or 
diagnostic) from completing successfully.

Warning — non-volatile data indicating a fault that has not stopped the library's ability 
to complete requests (host or diagnostic). A warning can identify a loss of performance 
or a condition that may indicate future irrecoverable errors.

Information — volatile data indicating general device or library information (such as 
the device state, device added, listener registered, tray serial number updated, and so 
on). This information may be important to establish a history of activity for the 
warning or error event.

Trace — volatile data indicating diagnostic activity tracing.

Result Code
Identifies the library event type (result codes are the same as library EventIds). To 
search for the meaning of the Result Code using SLC, see "Displaying Result Code 
Definitions" on page 14-4 or refer to the SL8500_FRSxxx_JavaErrorCodes.html file 
included in the library firmware code package.

Result Text
Provides information about the results of the request or event.
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15Changing Online/Offline Status and Rebooting

■ Taking the Library Offline

■ Bringing the Library Online

■ Taking a Device Offline

■ Bringing a Device Online

■ Rebooting the Library

■ Rebooting the Local Operator Panel

■ Rebooting an Elevator

■ Rebooting a Robot

Taking the Library Offline

1. Take all library drives offline (see "Taking a Device Offline" on page 15-2).

2. In SLC, select Tools > System Detail.

3. Select the Library in the device tree.

4. Click the Status tab, and then the General tab.

5. In the Transition Request field, click Take offline. 

6. Click Apply. Before the library goes offline, all outstanding library jobs complete.

7. Wait for the offline confirmation message. If the library does not come offline, 
check the status of the library (see "Viewing Library Operational Status" on 
page 13-1).

When to place the library offline:
■ Before powering down the library

■ Before opening a library access door

■ When the library is inoperative and requires maintenance

Note: Always try to take the library offline with ACSLS or ELS 
software before using SLC.
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Bringing the Library Online

1. In SLC, select Tools > System Detail.

2. Click the Library in the device tree.

3. Click the Status tab, and then the General tab.

4. In the Transition Request field, click Bring online.

5. Click Apply.

6. If applicable, bring the library online to ACSLS and ELS hosts (see the host 
software documentation).

Taking a Device Offline

1. In SLC, select Tools > System Detail.

2. Expand the device folder (CAP, robot, or drive). Select the device to modify.

3. Click the Status tab.

4. In the Transition Request list, select Take Offline. The system completes all 
outstanding jobs for the device before taking the device offline

When robot goes offline, it moves to the end of the rail, and the library cannot use 
it. If the library is using the redundant robotics feature, the second robot will take 
all requests.

5. Click Apply. 

Bringing a Device Online

1. In SLC, select Tools > System Detail.

2. Expand the CAP folder. Select the CAP to modify.

3. Click the Status tab.

4. In the Transition Request list, select Bring Online. 

5. Click Apply. 

Note: Always try to bring the library online with ACSLS or ELS 
software before using SLC.

Note: Always try to take a device offline with ACSLS or ELS tape 
management software before using SLC.

Note: Library devices that are offline and in an error state cannot go 
online. The error condition must be corrected first.
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Rebooting the Library
Rebooting the library involves reloading the firmware from flash memory and 
restarting the library controller.

1. In SLC, select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click Reboot. 

4. All other users must log off. Click OK. 

5. If the library is online, click OK to take the library offline. 

6. Click OK to reboot the library.

7. Click OK to terminate this SLC session. Do not log back in to the SLC until the 
library has fully initialized.

Rebooting the Local Operator Panel
You may need to reboot the local operator panel if it hangs or the help content is not 
visible. You can reboot at the local operator panel or from a remote SLC session.

1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree, and then click the OpPanel tab.

3. Click the Reboot Operator Panel button.

4. If rebooting from the local operator panel, the screen will go blank. The reboot is 
complete when the operator panel comes back online.

If rebooting from a remote SLC session, "Reboot Complete" indicates the reboot of 
the local operator panel has finished.

Rebooting an Elevator
1. Select Tools > Diagnostics.

2. Expand the Elevator Folder, and then select an elevator.

3. Click Reboot. 

4. Click OK to reboot the elevator.

Rebooting a Robot
1. Select Tools > Diagnostics.

2. Expand the Robot Folder, and then select a robot.

3. Click Reboot. 

4. Click OK to reboot the robot.
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16Troubleshooting

■ Basic Troubleshooting

■ Running a Library Self-Test

■ Running a Device Self-Test

■ Diagnosing Robotic Issues

■ Determining the Status of a Controller Card

■ Clearing Library Status Alerts

■ Initiating a Manual RE Switch Using SLC

■ Calibrating the Touch Screen

■ Troubleshooting Host Connectivity

See Also
■ "Changing Online/Offline Status and Rebooting" on page 15-1

■ "Generating Diagnostic Files for Oracle Support" on page 14-2

■ "Monitoring Library Events" on page 14-3

■ "Servicing the Library" on page 17-1

Basic Troubleshooting
Before running diagnostic tests or contacting Oracle support, review the following 
troubleshooting tips.

Service Required (amber) LED is constantly on
Use SLC to check the health of the library and the attached devices (drives, CAPs, and 
robots). See "Viewing Library and Device Information" on page 13-1.

To perform a health check:

1. Log in to the SLC.

2. Access the System Detail module, Tools > System Detail.

3. Check the navigation tree for the following indicators: Device Healthy or Device 
Error

Additional checks:

1. Check the Status (for example, online/offline) and Statistics (for example, uptime, 
downtime, errors and warnings) tabs for more information on the health of the 
library and devices.
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2. Ensure the cartridges are fully seated and properly oriented in their storage slots.

3. Inspect the X table for any foreign objects or debris and remove them if found.

CAP Open LED is on and blinking
Open the CAP and ensure the cartridges properly seated. Close the CAP.

SLC does not display modified data or information remains static
Check the SLC Heartbeat icon.

Robot Fault or Library Fault Amber LED is constantly on
1. Check the SLC for any displayed error messages. Write down the error messages 

reported.

2. Open the front door. Observe and note the state of the cartridges, hand, and tape 
drives.

3. Ensure cartridges are fully seated and properly oriented in their storage slots.

4. Ensure packing materials have been removed.

5. Inspect the library floor for any objects or debris. If there are any, remove them.

6. Check the status of the tape drives.

7. Close the front door.

8. Ensure the tape drives are fully seated and locked forward by pushing and pulling 
on the rear of the drive tray. Any motion of the tray indicates that it requires 
re-seating and locking down.

Client computer cannot communicate with the library or tape drives
Ensure cables are securely attached to their connectors on the rear of the library, the 
tape drives, and the client computer.

Library cannot communicate with the drives and drive status on the SLC displays 
"Not communicating" 
Ensure cables are securely attached to their connectors on the rear of the library, the 
drives, and the client computer.

Repeated or excessive drive cleaning or cleaning messages
1. Replace the cleaning cartridge with a new cleaning cartridge.

2. Run the Library Self-Test and note if errors are reported for the drive.

3. Run any client computer-based drive diagnostic tests.

Running a Library Self-Test
Use library self-tests to help diagnose issues. Library self tests can be non-disruptive 
(cartridges are returned to their original locations) or disruptive (cartridges may be 
placed in new locations).

1. Make sure the proper drive diagnostic cartridges are in the library (see "Importing 
or Exporting Diagnostic or Cleaning Cartridges" on page 10-3).

2. In SLC, select Tools > Diagnostics, and click the Library folder.

 Note: Before performing a disruptive test, the library must be taken 
offline (see "Taking the Library Offline" on page 15-1).
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3. Click the SelfTest tab.

4. In the Mode list, select the type of self-test:

■ Non-Disruptive - all cartridges used in the test are returned to their original 
locations

■ Disruptive - cartridges may be returned to new locations. The library must be 
taken offline to all hosts before running this test.

5. Click Run. Test results display when the test completes. 

6. For disruptive tests, bring the library online to resume normal operations.

What the library checks during a self-test:
■ Verifies the communication path between the library controller, drives, elevators, 

and robots.

■ Performs get and put operations to check the health of the robots, elevators, and 
CAPs. This includes get and put operations from a reserved system slot to a 
random empty storage slot or CAP slot.

■ Performs a full library audit.

■ Performs mounts and dismounts of diagnostic cartridges for all the drives 
installed in the library. The self-test does not begin unless a diagnostic cartridge is 
found in the system slots. If the system finds a compatible diagnostic cartridge, the 
self-test repeats for each drive type. If the system does not find a diagnostic 
cartridge for a drive type, the system skips the mount/dismount operation for the 
drive.

Running a Device Self-Test
Use device self-tests to help diagnose issues. A self-test can be performed on a CAP, 
robot, or drive.

Running a Self-Test on All CAPs (Bulk CAP Only)
1. In SLC, select the Tools >Diagnostics, and then select the CAP Folder.

2. In the Mode list, select Non-Disruptive (disruptive tests require the library to be 
taken offline to all hosts).

3. Click Run. 

4. Open and close the CAP doors as indicated. A message appears when the test 
finishes.

Running a Self-Test on an Individual Device
1. In SLC, select Tools >Diagnostics.

2. Expand the device folder (CAP, robot, drive, PTP, or elevator) in the device tree. 
Select the device.

Note: Running a self-test on a bulk CAP requires human 
intervention to open and close the CAP door.
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3. In the Mode list, select Non-Disruptive.

4. Click Run. A message appears when the test finishes.

Diagnosing Robotic Issues
Diagnostic moves can help monitor or diagnose robotic problems by issuing a series of 
"get" and "put" operations. The system chooses a robot for the diagnostic move based 
on the minimum and maximum ranges set for the target and pool addresses. Multiple 
robots may be selected if the address range requires it.

Successful diagnostic moves do not rearrange the cartridges in the library — the 
system returns cartridges to their original locations. However, some diagnostic move 
failures can cause cartridges to be left in new locations.

Defining a Diagnostic Move

You can set up and run multiple diagnostic move routines simultaneously if the target 
and pool ranges for each diagnostic move do not overlap.

1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the DiagMove tab, and then the Manage tab.

3. In the Defined Sequence section, click Add.

4. Define the target address range (the area used for "get" operations).

a. Select a slot type.

b. Select the starting and ending locations for the range.

5.  Click Next.

6. Define the source address range (the area used to supply cartridges or empty slots 
if a target address does not contain a cartridge or no empty slots are available.)

a. Select a slot type.

b. Select the starting and ending locations.

7. Click Next.

8. Name the move and specify a move count (between 1 and 5000).

9. Select an access order., move type, and enable/disable the pre-move compatibility 
check (see below for details).

10. Click Finish. The new diagnostic sequence is listed in the Defined Sequences 
section. See "Starting a Diagnostic Move" on page 16-5.

Note:  To perform a robot self-test, diagnostic cartridges must be 
available in the library (see "Importing or Exporting Diagnostic or 
Cleaning Cartridges" on page 10-3).

Note:  Diagnostic moves require sharing of robot resources. You 
should not run a diagnostic move during peak activity periods.
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A diagnostic move is defined by:
■ Target Address Range — defines the area used to perform the "get" operation in a 

diagnostic move. Valid target address types are storage slots, CAP, drive and 
storage slots, system slots, or all.

■ Pool Address Range — defines the area used to supply cartridges or empty slots if 
a target address does not contain a cartridge or no empty slots are available. The 
pool and target address can overlap.

■ Access Order — determines how the robot performs get operations within the 
target address range. There are two options:

– Sequential — robot performs a get operation starting with the first location in 
the target address range. The robot continues visiting the locations 
sequentially through the range until it completes the requested number of 
moves.

– Random — robot randomly picks a location in the target address range to get a 
cartridge. The robot can also visit the same location in the target address range 
multiple times to get a cartridge; however, if you specify enough move 
requests, the robot is guaranteed to visit all slots. The random access routine 
ends after the requested number of moves is complete.

Starting a Diagnostic Move

Before starting a diagnostic move, you must define the move (see "Defining a 
Diagnostic Move" on page 16-4).

1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the DiagMove tab, and then the Manage tab.

3. In the Defined Sequences section, select a diagnostic move. Click Open.

4. Select File > Start Sequence.

Saving a Diagnostic Move
You can save a defined diagnostic move to a file and use it to restore a move that has 
been deleted from the library or copy it to a different library.

1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the DiagMove tab, and then the Manage tab.

3. In the Defined Sequence section, select a diagnostic move, and then click Save at 
the top of the SLC screen.

Note: All resources within the target address range are reserved. 
However, only the location currently being accessed by the robot for a 
get/put operation is unavailable to the host.

Note: You can run multiple moves simultaneously as long as the 
target and pool address ranges for the moves do not overlap.
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Monitoring and Controlling Open Diagnostic Moves
To start a diagnostic move, see "Starting a Diagnostic Move" on page 16-5.

1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the DiagMove tab, and then the Monitor tab.

3. Each monitor window indicates the status of the move:

4. Use the File menu in each Monitor window to start/stop/pause the sequence, 
clear the output window, or start/stop spooling.

Determining the Status of a Controller Card
Controller card status is indicated by LEDs on the card and displayed in SLC (see 
"Viewing Device Status and Properties" on page 13-2). You can use the status of the 
card to troubleshoot issues with the library.

The LEDs and meanings are the same on both card types (HBC and HBT).

Clearing Library Status Alerts
You can only clear alerts marked as "Clearable" and only if service is active on the 
library.

Clearing an alert only removes it from the Status Module display; it does not resolve 
the underlying cause. The library health indicator returns to "Normal" if there are no 
other device or status alerts. If the alert is subject to periodic updates, it will reappear 
at the next update cycle. 

1. In SLC, select Tools > System Detail, and click the Library folder.

2. Click the Status tab, and then the Status Module tab.

3. On the Clear Alert Number list, select the alert number to clear, and then click 
Apply.

Status Indicators Valid Values

Spooling Status — whether the move output is being saved to a file True, False

State — execution state of the move Running, pausing, paused, 
stopping, stopped

Health — health state of the move OK, warning, error

Completed moves — number of moves completed Count

Controller Card LED Definition

ACTIVE - Green Card is functioning as the active and is running active code.

STANDBY - Amber Card is functioning as the standby and is running standby code.

FAULT - Red Card has experienced a serious error.

EJECT OK - Blue Support representative can safely initiate a card eject. 
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Initiating a Manual RE Switch Using SLC

This procedure is not available at the local operator panel.

1. Verify the device state of the card indicates "switch is possible" (see "Viewing 
Device Status and Properties" on page 13-2).

2. In SLC, select Tools > Diagnostics.

3. Select the Redundant Electronics folder

4. Click Apply to begin the switch process. If there is a problem with the standby 
library and drive controller cards, you are not allowed to continue with the switch.

5. If there are no errors, click Yes.

6. Click OK to log off the SLC.

7. Wait until the switch is complete before logging back into the library. You must 
specify the IP address or DNS alias of the new active controller.

Calibrating the Touch Screen
Alignment of the touch screen is calibrated at the factory. If the touch screen becomes 
mis-aligned, you can re-calibrate or reset it. The method for calibrating the touch 
screen depends on the type and version (see "Viewing the Local Operator Panel Type" 
on page 13-3).

■ If you have a Linux-based local operator panel (DL or OL), you can re-calibrate it 
yourself or reset it to factory setting with the procedures below.

■ If you have a Windows-based local operator panel (W), contact your Oracle 
support representative.

Re-calibrating the Local Operator Panel
1. For an accurate calibration, make sure there is no debris on the touch screen.

2. Log in to the local operator panel. Select Tools > Calibrate.

3. Click Calibrate.

4. A series of targets will display. Gently tap the center of each target with your 
finger or a pointing stylus.

5. To save the new settings:

a. Tap the Click Me buttons.

If the buttons do not depress, the touch screen is not properly aligned. Discard 
the new settings (see step 6).

b. Click OK to save the new settings.

6. To discard the new settings:

a. Let the timer run out without tapping the Click Me button.

b. Return to step 3 and re-calibrate.

Note: You can also initiate a manual RE switch using host software 
or the CLI (see "Ways to Initiate a Manual Failover" on page D-3).
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The local operator panel reboots automatically after an unsuccessful second 
calibration and restores the previously saved alignment.

Resetting the Local Operator Panel to Factory Settings
1. Log into the local operator panel.

2. In SLC, select Tools > Calibrate.

3. Click Reset Calibration. The local operator panel reboots.

Troubleshooting Host Connectivity
■ Use a sniffer (a device or program that traces the network traffic for the library).

■ Display the port statistics on the switch or router connected to the library. Search 
for any errors.

■ Run a trace with the library management software that displays host-to-library 
packets and transmissions.

■ Verify that two separate hosts are not competing to manage one library or one 
partition. To view current host connections, see "Viewing Library Operational 
Status" on page 13-1. Click the HLI tab.
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■ Turning Off the Library

■ Turning On the Library

■ Entering the Library without the Service Safety Door in Place

■ Using the Emergency Robotics Stop Switch

■ Manually Mounting or Dismounting a Cartridge

■ Operating the Service Safety Door

See Also
■ "Troubleshooting" on page 16-1

Turning Off the Library

1. Ensure that all library requests have completed.

2. Take the library and the drives offline.

3. Ensure that the drives are empty by verifying the drive state using the SLC (see 
"Viewing Library and Device Reports with the Reports Utility" on page 14-1).

4. Open the rear doors of the library.

5. Locate the power distribution unit (PDU) in the lower-right and set the power 
switch to the OFF position (0). If the library has a 2N power configuration, switch 
off both PDUs. 

For more information about PDUs, see the "Power Configuration Options" on 
page 1-9.

Turning On the Library
1. Verify that the front access doors are closed and locked.

Caution: If you turn off the library without performing the following 
procedure, you risk possible equipment damage, cartridge damage, or 
loss of data.

Note: If you do not want to turn on the robots, CAPs, and the 
elevators, leave the front access doors open.
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2. Set the power switch to the ON position.

If the library has a 2N power configuration, switch on both PDUs.

Entering the Library without the Service Safety Door in Place

1. Follow all safety precautions (see "Safety Precautions when Entering the Library" 
on page 17-2).

2. Place the library offline (see "Taking the Library Offline" on page 15-1).

3. Unlock and open the front access door. Lock the access door open and retain the 
key

4. If necessary, move the robots out of your way starting with the bottom rail. Avoid 
damaging the robot's mechanical or electronic components. The robot should 
move freely. Do not force the robot if movement is restricted.

5. Before you exit the library, verify that there are no loose items or people in the 
library.

6. Close and latch the doors.

7. Lock the doors and retain the key.

8. Bring the library online (see "Bringing the Library Online" on page 15-2).

Safety Precautions when Entering the Library

■ Verify the library is offline. Do not enter the library or move any of the robots if 
you suspect the robots are online.

■ Do not attempt to override any of the electrical or mechanical safety devices in the 
library.

■ Inform someone in the immediate area that you are going to enter the library.

■ Locate the mechanical door releases (yellow handles on the inside of the access 
doors). If the doors close while you are inside the library, push the mechanical 
release to unlock and open the door.

■ Always leave both the front access doors open while inside the library.

■ Know the physical restrictions of the library. Be careful not to bump you body or 
snag clothing on the arrays (there is only 0.4 m [18 in.] of aisle clearance).

Using the Emergency Robotics Stop Switch
The emergency robotics stop (EMS) switch cuts all power to the robots.

Note: Opening an access door without the safety door in place will 
stop all library operations. When the library comes back online, it will 
perform a full audit. See also "Operating the Service Safety Door" on 
page 17-3.

WARNING: To prevent the door from accidentally closing, lock the 
access door open and retain the key.
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In the unlikely event that someone becomes locked inside the library and the system 
begins to turn on, lights flash for 30 seconds before the robot starts to move. This 
provides enough time for someone outside the library to push the emergency robotic 
stop switch.

Figure 17–1 Emergency Robotic Stop Switch

1. Emergency Robotic Stop Switch (ERS)

Manually Mounting or Dismounting a Cartridge
Refer to the drive documentation before manually mounting a cartridge.

1. Record the volume ID, cartridge location, and drive slot provided by the library 
management software.

2. Locate the drive ("Viewing Library and Device Reports with the Reports Utility" 
on page 14-1). L

3. Locate the cartridge ("Locating Cartridges" on page 10-2).

4. Orient the cartridge so that the hub gear is facing down and the vol-id label is 
facing you.

5. Push the cartridge into the drive. Do not force the cartridge. If you feel some 
resistance as you insert the cartridge, verify that you are inserting the correct 
cartridge type for the drive.

6. To dismount the drive, press the UNLOAD switch on the front of the drive.

If the cartridge does not eject, refer to the drive documentation.

Operating the Service Safety Door
You can use the SLC to monitor the status of the safety door (see "Viewing Device 
Status and Properties" on page 13-2). 

The safety door is a sliding barrier that temporarily closes off the left or right area 
between the front door and the rear of the elevator assembly. Service representatives 
can activate the service safety door with a maintenance key. With the safety door in 
place, a service representative can open the front door to access a faulty robot without 
bringing the library offline.

Caution: Keep your hands clear of the drive’s mechanical and 
electronic components.
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With the safety door in place, the library continues to process host requests. The 
library will queue any mount requests for slots next to or behind the safety door until 
the service representative finishes. Once the access door is closed and locked, the 
service safety door moves to the center of the library. The robots then resume their full 
service.

Accessing the Left Maintenance Area
Before activating the safety door, the service representative should take the left 
elevator and left bulk CAPs offline using SLC. After completing the maintenance 
activity, the service representative should bring the left elevator and bulk CAPs back 
online.

Accessing the Right Maintenance Area
Before activating the safety door, the service representative should take the right 
elevator and rotational or right bulk CAPs offline using SLC. After completing the 
maintenance activity, the service representative should bring the CAPs and the right 
elevator online. 
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Library Features

Media Validation
■ High-memory HBT card

– If using RE, both HBT cards should be high-memory

■ Minimum FRS_8.31 and SLC FRS_6.25

■ See also: "Media Validation Requirements" on page 11-1

Partitioning
■ Minimum FRS_7.01 and SLC 5.50 (for single library partitioning)

■ Minimum FRS_8.31 and SLC 6.25 (for library complex partitioning)

– ACSLS 8.3, HSC 6.2: PTF L1H16SG (VM), ELS 7.0: PTF L1H15SI (MVS), ELS 
7.1: PTF L1H16SJ, ELS 7.2: integrated

Redundant Electronics
■ Minimum FRS_6.00 and SLC version 4.65

■ See also: "Redundant Electronics Requirements" on page D-1

Enabling ADI Mode
■ High-memory HBT

– If using RE, both HBT cards must be high-memory

■ Minimum FRS_8.36

Sending Rich Drive Data to STA
■ A high-memory HBT is required for T10000 drives running TTI 5.40+ to send all 

data to STA. Without a high-memory HBT, the drives operate normally, but STA 
only receives basic data.
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BCommand Line Interface Reference

This appendix describes the Command Line Interface (CLI) commands available for an 
Admin user. Since the CLI is firmware-based, not all commands may be available for 
your library. 

Admin accessible CLI commands include:

■ audit

■ capCommand

■ cleaning

■ config

■ date

■ drive

■ hwActivation

■ mediaValidation

■ network

■ partition

■ reControl

■ snmp

■ ssh

■ time

■ traceRoute

■ version

■ whereAmi

audit
This command performs a physical audit on all or part of the library.

audit
Displays help for the audit command, the same as "help audit".

audit *
Initiates a physical audit of the entire library. This command returns immediately and 
displays no results.
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Example:

SL8500> audit *
   requestId
   requestId 9
   Done
   Failure Count 0
   Success Count 1
COMPLETED

audit <device address> <address>
Performs a physical audit of a single address and displays the results.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

■ <address> - specifies the slot location to audit in library, rail, column, side, row 
format.

Example:

SL8500> audit 1,4,0,1,0 1,4,-45,1,1
   requestId
   requestId 9
   Attributes Media Label #EMPTY..
   Object     Location    1,4,-45,1,1
   Done
   Failure Count 0
   Success Count 1
COMPLETED

audit <device address> <start address> <end address>
Performs a physical audits of a range of addresses and displays the results.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

■ <start address> <end address> - specifies the starting and ending slot location to 
audit in library, rail, column, side, row format. Only the row is variable between 
the start and end addresses.

Example:

SL8500> audit 1,4,0,1,0 1,4,-45,1,1 1,4,-45,1,2
   requestId
   requestId 10
   Attributes Media Label #EMPTY..
   Object     Location    1,4,-45,1,1
 
   Attributes Media Label EN34410R
   Object     Location    1,4,-45,1,2
   ...
   Done
   Failure Count 0
   Success Count 5
COMPLETED

audit multiRowScan {enable | disable | print} <device address>
Enables or disables multiple row scan audit capability to speed up audit time.

■ print - prints the multi-row scan audit state.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.
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Example:

SL8500> audit multiRowScan print 1,1,0,1,0
   requestId
   requestId 8401
   Attributes Multi Row Scan enabled
   Object     Robot          1,1,0,1,0
   Done
   Failure Count 0
   Success Count 1
COMPLETED

capCommand
This command is for managing CAPs.

capCommand
Displays help for the capCommand command, the same as "help capCommand".

capCommand <enable|disable> <device_address>
Enables or disables a CAP on a rail (for bulk CAP only). Certain situations may 
prevent a CAP from being disabled, such as a reservation by a host.

■ <device address> - specifies the CAP to release in library, rail, column, side, row 
format.

capCommand forceUnreserve <device address>
Forces the release of a CAP. If cartridges are in the CAP, the reservation changes to 
"default". If there are no cartridges in the CAP, the reservation changes to "none".

■ <device address> - specifies the CAP to release in library, rail, column, side, row 
format.

capCommand {lock | unlock} <device address>
Locks or unlocks a CAP specified by the device address.

■ <device address> - specifies the CAP to lock/unlock in library, rail, column, side, 
row format.

cleaning
This family of commands displays and controls cleaning and diagnostic 
cartridge-related functions within the library. Only customers with the media 
validation feature should use these commands.

cleaning
Displays help for the cleaning command, the same as "help cleaning".

cleaning list cleaning
Lists all cleaning cartridges in the system slots.

Example:

SL8500> cleaning list cleaning
   requestId
   requestId 9001
   Attributes Expired  false
      Label            CLN0080U
      Location         1,1,-52,1,13
      Max Usage Count  100
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      Media Type       9840_Cleaning
      Status           ok
      Usage Count      0
Object Cartridge       cleaning

cleaning import <cap device address> [ to { 1 | 2 | 3 | 4 | * } ]
Imports cleaning and diagnostic cartridges to system slots. Only one import/export 
operation is allowed at a time. There must be a minimum 9 empty system slots for 
SL8500 libraries to allow imports. 

■ <cap device address> - specifies the CAP to use for the import operation, in library, 
rail, column, side, row format.

■ to { 1 | 2 | 3 | 4 | * } - specifies the rail to import cartridge to if possible (optional)

Example:

SL8500> cleaning import 1,2,55,1,0 to 1
   requestId
   requestId 10101
   Message CAP open(ing). Place cartridges to import in CAP, then close CAP.Use 
CONTINUE cmd to proceed...
   Done
   Failure Count 0
   Success Count 0
COMPLETED

cleaning export <cap device address> cleaning select { 1 | 2 | 3 | 4 | expired }
Exports selected cleaning cartridges. Only one import/export operation is allowed at a 
time.

■ <cap device address> - specifies the CAP to use for the export operation, in library, 
rail, column, side, row format.

■ select { 1 | 2 | 3 | 4 | expired } - specifies the rail number to export cleaning 
cartridges from.

Example:

SL8500> cleaning export 1,2,55,2,0 cleaning select expired
   requestId
   requestId 9601
   Address      1.4.-52.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to 
proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning export <cap device address> <cartridge address>
Exports a specific cleaning or diagnostic cartridge to the specified cap. Only one 
import/export operation is allowed at a time. 

■ <cap device address> - specifies the CAP to use for the export operation, in library, 
rail, column, side, row format.

■ <cartridge address> - specifies the location of the cartridge to export in library, rail, 
column, side, row format. The specified cartridge must be in a system slot and 
must be either a cleaning or diagnostic cartridge.
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Example:

SL8500> cleaning export 1,2,55,2,0 1,4,-52,1,12
   requestId
   requestId 9601
   Address      1.4.-52.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to 
proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning threshold list
Displays a list of cleaning cartridge types and their warning thresholds. Each cleaning 
cartridge type has 4 attributes: 

■ Index - cleaning cartridge type used by the "cleaning threshold set" command

■ Media type - the type of cleaning cartridge used

■ Maximum usage count - recommended max usage by tape manufacturer

■ Warning threshold value - user-defined threshold that determines when a 
warning status is set for a cleaning cartridge once its usage count reaches that 
threshold.

Example:

SL8500> cleaning threshold list
   requestId
   requestId 15001
   Attributes
   Object     Index               1
              Media Type          SgtUltrium1_Cleaning
              Recommend Max Usage 100
              Warning Threshold   0
   Attributes
   Object     Index               3
              Media Type          T10000_Cleaning
              Recommend Max Usage 50
              Warning Threshold   0

cleaning threshold set <warning threshold value> <list index number>
Sets a warning threshold value for a particular cleaning cartridge type.

■ <warning threshold value> - can be any positive integer up to 1000. A value of 0 
indicates no warning threshold.

■ <list index number> - cleaning cartridge type as specified by the index number from 
the table listing of the "cleaning threshold list" command.

Example:

SL8500> cleaning threshold set 55 11
   requestId
   requestId 15101
   Attributes
   Object      Success true
   Done
COMPLETED
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cleaning driveWarning set { on | off }
Sets the drive cleaning warning flag to either on or off.

■ on - the drive health status will be set to warn if it needs cleaning

■ off - the drive health status is not affected if the drive needs cleaning

config
This command will either display the current physical library configuration or set 
library configuration parameters.

config
Displays help for the config command, the same as "help config".

config complexId set {1 - 127}
Sets the complexId used for SDP for just the library in which the command is 
executed. If more than one library exists in a complex, the complexId must be set 
individually for each library in the complex.

config complexId set {1 - 127} <library address>
Sets the complexId used for SDP for a remote library. If more than one library exists in 
a complex, the complexId must be set individually for each library in the complex.

■ <library address> - specifies the library in library, rail, column, side, row format. For 
example: 2, 0, 0, 0, 0.

config complexId clear
Clears the complexId number for a library. This command will restart the network 
stack and cause the SDP ILC IP address to stop responding.

config complexId clear <library address>
Clears the complexId number for a remote library. This command will restart the 
network stack and cause the SDP ILC IP address to stop responding.

■ <library address> - specifies the library in library, rail, column, side, row format. For 
example: 2, 0, 0, 0, 0.

config complexId print
Displays the current complexId for the library in which the command is executed.

config ilc print
Display the ilc status.

config ilc {enable | disable}
Enables or disables the Inter-Library Communications (ILC) LAN. If a disable is 
requested, the library must first be taken offline using the "accessState offline <device 
address>" command.

config libraryId print
Displays the current library identifier for this library.

config libraryId set {1 - 32}
Sets the libraryId with a value from 1-32. The library must be offline for this command.

config print
Displays the current physical library configuration.
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config serviceInfo print
Displays the library service information.

config serviceInfo set
Sets service information: contact 'contactName' phone 'phoneNumber' streetAddr 
'streetAddress' city 'city' state 'state' country 'country' zip 'zipCode' description 
'description data'. 

Currently the maximum string length is 31 characters. Each string must be delimited 
by ' ' (single quotes) to provide the ability to use spaces and other characters.

Example:

SL8500> config serviceInfo set city 'Denver' contact 'Andy' country 'USA' 
description 'Manager' phone '303 222-4444' state 'C0' streetAddr '1 tape drive' 
zip '80027'

requestId
requestId 1512402
Device serviceInfo
Success true
Done
Failure Count 0
Success Count 1
COMPLETED

date
This command sets the library date in Greenwich Mean Time (GMT).

date
Displays help for the date command, the same as "help date".

date print
Displays the current system date.

date <MM> / <DD> / <YYYY>
Sets the system date. In a library complex, the library with libraryId = 1 is the master. 
Change the date on the master library.

■ <MM> - two digit month

■ <DD> - two digit day

■ <YYYY> - four digit year

drive
This command displays information about the drives or executes the drive utilities 
such as adiEnable, fastLoad, power, and rewindUnload.

drive
Displays help for the drive command, the same as "help drive".

drive adiEnable {on | off | print}
Turns on or off or prints status of drive discovery with ADI. Once enabled, any 
subsequently added drives will attempt ADI drive discovery. To enable ADI for all 
ADI capable drives in the library, the library must be rebooted.
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drive fastLoad {on | off | print}
Turns on or off or prints the status of the fastLoad feature. FastLoad changes the 
behavior of drive mounts (move commands). With fastLoad on, the robot will not wait 
for a complete load of a PUT to a drive, but will go immediately to the next operation. 
Also changes the behavior of the rewindUnload command to return immediately, not 
waiting for the drive to unload. The state of the fastLoad applies to all drives.

drive print { <drive address> | * }
Displays summary drive information: location, state, status, type, firmware version, 
interface type, in use, serial number, state (online/offline), status (ok, warning, or 
error), and drive vendor.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

■ * - displays drive information for all drives in the library

drive search {on | off} <drive address>
Causes the green LED on the drive tray to blink. Blinking continues until the search off 
command issued.Used to locate a drive within the library.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

hwActivation
This command activating certain library features after purchasing a hardware 
activation permit.

hwActivation
Displays help for the hwActivation command, same as "help hwActivation".

hwActivation addLicenseFile
Adds a license file. The license file must be named SL8500_license_config.dsf. The full 
path name being /usr/local/SL8500_license_config.dsf.

hwActivation deleteFile <index>
Deletes the specified installed feature file.

■ <index> - specifies file number to delete as specified in the library controller 
hwActivation module database. See "hwActivation listFiles".

hwActivation listFiles
Lists the installed feature files in the library controller hwActivation module database.

hwActivation print
Lists all of the enabled features in the library controller hwActivation module 
database.

Note: This command only affects commands issued in the same CLI 
session where this command was issued.

Note: The library must be rebooted when disabling openVolser, 
dualRobot, partitioning, or redundant electronics.
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mediaValidation
This command manages the media validation feature.

mediaValidation
Displays help for the mediaValidation command, same as "help mediaValidation"

mediaValidation print { all | poolOnly } { * | @ }
Displays drive locations of the media validation pool.

■ all - lists all drive slots

■ poolOnly - lists only drive slots in the media validation pool

■ * - displays only information for the target library

■ @ - displays information for the entire complex

mediaValidation reservation clear <drive address>
Clears media validation reservation for specified drive.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

mediaValidation stopValidation <drive address>
Stops a validation currently in progress. Cartridge is returned to source storage slot.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

network
This command is used to configure and display network configuration for the 
controller card.

network clone [Port 2B IP address] [Port 2A IP address]
Used for redundant electronics configuration. Copies all port, routing, and IP policy 
configurations to side B HBC. IP addresses are replaced with the ones specified in the 
command for side B. If no port IP address is specified, then they are not set on side B.

network config print
Displays the target library side (A or B) that is set for network commands.

network config side {a | b}
Sets the target library side for network commands.

network config clear
Clears the network configuration. This command stops network connectivity. 
Reconfiguration requires access to the serial port on the HBC card.

network export
Exports library network configuration file (.lnc) and generates a network configuration 
script (.scr). It can only be used in cases where no prior network configurations have 
been set.

network gateway <IP address>
Sets the external network default gateway.

network gateway clear
Clears the external network default gateway.
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network import
Imports a library network configuration file (.lnc).

network ip <IP address>
Sets the IP address of port 2B.

network ip address add <IP address> dev {2A | 2B}
Sets the IP address of a particular port.

network ip address del <IP address> dev {2A | 2B}
Removes the IP address of a port.

network ip address show [dev {2A | 2B}]
Displays the current address information for a particular port or both ports if dev is 
not specified.

network ip link set dev {2A | 2B} {up | down}
Sets the operation status of a port, which controls whether a port can send and receive 
Ethernet traffic.

■ up - sets port online

■ down - sets port offline

network ip policy {enable | disable} dev {2A | 2B}
Enables or disables policy routing for device 2A or 2B.

network ip policy status
Displays policy routing status for devices 2A and 2B.

network ip policy route {add | del} <IP address> dev {2A | 2B}
Adds or deletes a static route to policy for device 2A or 2B.

network ip policy route {add | del} <IP address> via <Gateway IP address> dev {2A | 
2B}
Adds or deletes a static route to policy for device 2A or 2B via gateway.

network ip policy route show [ dev {2A | 2B} ]
Displays policy route information for device 2A or 2B.

network ip route add default via <IP address>
Sets the default gateway routing IP address.

network ip route delete default
Deletes the default gateway routing IP address.

network ip route {add | del} <IP address [/netmask] > dev {1A | 1B | 2A | 2B}
Adds or deletes a static IP (Internet Protocol) routing address for a specified host. This 
command also enables a user to set the netmask for a particular port.

Example:

SL8500>network ip route add 129.80.81.59/24 dev 1B
COMPLETED

network ip route {add | del} <IP address [/netmask] > via <Gateway IP address>
Adds or deletes a static route to a destination network IP gateway address.
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network ip route show [dev {2A | 2B}]
Displays the current routing table information or routing table information for a 
particular port.

network name <host name string>
Sets the host name.

network netmask <netmask>
Sets the external network netmask in xxx.xxx.xxx.xxx form.

network print
Displays the current network configuration for the external Ethernet ports (2A and 
2B).

partition
This command displays the current status or disables the partition feature.

partition
Displays help for the partition command, same as "help partition".

partition autoClean set { * | <Partition Id> }
Set auto clean in a specified partition (0, for a non-partitioned library).

partition attribute status { * | <Partition Id> }
Displays the status attributes of a single specified partition or all partitions.

partition disable
Disables partitioning in the library.

partition getCapacity
Displays the capacity values for library or any defined partitions.

partition status
Displays the current partitioning status.

partition setCapacity { <Partition Id> , <Capacity> }
Sets the capacity for the designated partition. Existing partitions not listed in the 
command will have their capacity set to zero.

Example:

SL8500> partition setCapacity 1,200 2,50 3,600
   requestId 7601
   Done
   Failure Count 0
   Success Count 1
COMPLETED

partition setNonPartitionedHLI
Sets the partition to hli0. If there are any drives in the media validation pool, they must 
be removed beforehand. If in complex, it sets all the libraries to hli0. 

partition set state {online | offline} <Partition Id>
Sets the current state (offline/online) of a specified partition.
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reControl
This command controls/switches the redundant electronics and retrieves the library 
controller redundant electronics statuses.

reControl
Displays help for the reControl command, same as "help reControl".

reControl status [ <library address> | * ]
Retrieves the redundant electronics status.

■ <library address> - specifies the library in library, rail, column, side, row format. For 
example: 2, 0, 0, 0, 0.

■ * - retrieves status from all libraries in a complex

snmp
This command configures the Simple Network Management Protocol (SNMP). For 
more information, see the SNMP Reference Guide on OTN.

ssh
This command controls configuration for the ssh daemon/server which resides on the 
HBC. This is the protocol utility which SLC and other various applications use to 
connect to the library controller.

ssh print
Prints the current ssh daemon protocol settings.

ssh set version1and2
Sets the ssh daemon protocol restriction to v1 and v2. (this is the default). The ssh 
server is restarted.

ssh set version2
Sets the ssh daemon protocol restriction to v2 only.

time
This command sets the library time in military time notation.

time
Displays help for the time command, same as "help time".

time print
Displays the current system time.

time <HH> : <MM>
Sets the system time. Resolution is within one minute. In a library complex, the library 
with libraryId = 1 is the master. Change the time on the master library.

■ <HH> - two digit hour

■ <MM> - two digit minute

time <HH> : <MM> : <SS>
Sets the system time. Resolution is within one second. In a library complex, the library 
with libraryId = 1 is the master. Change the time on the master library.
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■ <HH> - two digit hour

■ <MM> - two digit minute

■ <SS> - two digit second

traceRoute
This command traces the network route to a specified IP address.

traceRoute <IP Address>
Executes a traceRoute to the IP address specified.

version
This command displays the customer version and the versions of the software for the 
device(s) requested.

version print [ <device address> | *]
Displays the software version of code for a device or all devices.

■ <device address> - specifies the device in library, rail, column, side, row format. 

whereAmi
This command displays the system and logic card information relative to the library 
and card related to redundant electronics command is being executed.

whereAmi
Displays the information relating to where the command is being issued.

Example:

SL8500> whereAmI
   Host Name: gulibtst02b
   Port 2B IP Address: 172.20.151.24
   Library Type: SL8500
   HBC side: B
   Active side: B
COMPLETED
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CLibrary Addressing Reference

■ Translating a Slot Address Between HLI and Library Format using SLC

■ Comparison of Addressing Schemes

■ Understanding Structural Elements Used in Addressing

■ Internal Library Addressing Scheme

■ HLI-PRC Addressing Scheme

■ Physical Hardware Numbering for Tape Drives

■ Reserved Internal IP Addresses

Translating a Slot Address Between HLI and Library Format using SLC
You can use SLC to translate between an internal library address (Library, Rail, 
Column, Side, Row) and an HLI address (LSM, panel, row, column) used by ACSLS 
and ELS.

1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the Search tab.

3. Select Location.

4. Select the search criteria from the drop-down list, and enter the address (wildcards 
are invalid).

5. From the Requester drop-down list, select hli0 if you entered an HLI addresses or 
select default if you entered an internal library address.

6. Click Search.

7. If you entered an HLI address, the internal library address displays in the Address 
column of the search results. If you entered an internal library address, click . . . to 
view the HLI address. 

Comparison of Addressing Schemes
■ Internal Library Addressing Scheme (Library, Rail, Column, Side, Row) — used by 

the firmware and internal communications to represent all devices and locations 
within the library.

Note: Left and right are in reference to viewing the library from the 
CAP-side (front) unless otherwise specified.



Understanding Structural Elements Used in Addressing

C-2 StorageTek SL8500 Library Guide

– Begins at 1 and uses negative numbers.

– Column indicates the horizontal location in the library

– Outer wall row numbering is 1 to 13, and inner wall numbering is 1 to 14.

■ HLI-PRC Addressing Scheme (LSM, Panel, Row, and Column) — used by HLI 
clients, such as ACSLS and ELS, to represent library locations and components.

– Begins with 0 and uses only positive numbers.

– Column indicates the left or right side of the library

– Outer wall row numbering is 0 to 12, and inner wall numbering is 13 to 26.

■ Physical Hardware Numbering for Tape Drives — identifies the drive slot 
locations assigned by the HBC card.

Figure C–1 Internal Library versus HLI-PRC Addressing (top view of library)

Understanding Structural Elements Used in Addressing

Walls
■ Each side of the library (left/right) has an inner wall and an outer wall.

Standard Arrays
■ 14-slot arrays on the inner wall
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■ 13-slot arrays on the outer walls

Special Arrays
■ 8-slot arrays above the pass-thru port

■ 8-slot arrays under the stop brackets for the service safety door

■ 4-slot arrays on the elevators and pass-thru ports

■ 3-slot arrays at the ends of each rail

■ 12-slot arrays for bulk CAP magazine

Rails (LSMs)
Each library has four robotic rails. For HLI addressing, each of these rails is considered 
a library storage module (LSM).

Columns (Panels)
Columns (equivalent to panels in HLI-PRC addressing) refer to the horizontal location 
of a component in the library (similar to the columns in a spreadsheet). Special 
columns include:

■ Corners because there is no inner wall

■ Pass-thru ports because the top six slots are inaccessible because of the PTPs

■ Pass-thru port panels because the top cartridge slot (under the port) is reserved as 
a redundant robotics drop-off slot (two for each rail, one on each side)

Internal Library Addressing Scheme
■ Internal Library Addressing Overview

■ Drive Internal Library Addressing

■ Rotational CAP Internal Addressing

■ PTP Internal Addressing

■ Elevator Internal Addressing

■ Robot Internal Addressing

Internal Library Addressing Overview
Internal library addressing designates location using Library, Rail, Column, Side, Row 
(L,R,C,S,W).

■ Library — the number of the library within a library complex (always 1 for a 
single library)

■ Rail — robotic rails numbered top down from 1 to 4.

■ Column — the horizontal location of a device or slot. Column numbering begins 
at the center of the drive bays and increments +1 to the right or -1 to the left as you 
move toward the front of the library:

– +1 is just right of the center of the drive bays.

– -1 is just to the left of center of the drive bays.

– The first columns containing tape cartridges are +3 and -3.
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■ Side — indicates the inner and outer wall, left or right robots, or left or right 
rotational CAP.

– Outer wall =1, Inner wall =2

– Left robot =1, Right robot =2 (in non-redundant robotics the side is always 1)

– Right rotational CAP =1, Left rotational CAP =2 (for Bulk CAPs the side is 
always 1)

■ Row — The vertical location of a device or slot. Rows are consecutively numbered 
from the top (1) down (to 13 outer wall and 14 inner wall).

Components (such as CAPs, elevators, PTP, and robots) have unique addressing rules:

■ A row value equal to 0 indicates the address is referring to the device, not a slot in 
the device.

■ The side value may not directly correlate to inner and outer walls.

■ The column value of elevators and CAPs depends on the number of storage 
expansion modules in the library.

Drive Internal Library Addressing
Drives always have a column value between -2 and 2, a side value of 1, and a row 
value between 1 and 4.

Figure C–2 Tape Drive Internal Library Addressing (viewed from front of library)

Rotational CAP Internal Addressing
■ Rail and Row:

– When numbering the device, the rail value is 2 and the row value is 0.
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– When numbering a specific slot, the rail refers to the rail adjacent to the CAP 
magazine (can be values 2-4) and the row is the slot in the CAP magazine (can 
be values 1-13).

■ Column: The column value is the number of customer accessible columns plus 3. 
In a library with no SEMs, there are 11 customer accessible columns, therefore the 
CAP column value is 14.

■ Side:

– Right CAP = side value of 1

– Left CAP = side value of 2

Example

For firmware address 1, 3, 22, 2, 10: The library value is 1. The rail is the third from the 
top (3). The library contains one SEM (19 customer accessible columns plus 3 = 22). 
The CAP is on the left side (2). The slot is the 10th in the CAP magazine.

Bulk CAP Internal Addressing

Figure C–3 Bulk CAP Slot Arrays

Figure Legend

1. Bulk CAP arrays (12-slots each)

2. Three pack array

3. Reserved system cells

4. Service safety door

Bulk CAP addressing:

■ Rail: The rail number adjacent to the CAP (1 - 4).

■ Row: When numbering the device, the row value is 0. When numbering a specific 
slot, the row value is the slot in the CAP magazine (1 - 12).
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■ Column: The CAP magazines occupy the last three columns in the library. If the 
library has one SEM, there are 19 customer accessible column. Therefore, the CAP 
magazines would be in column 20, 21, and 22.

■ Side: Always a value of 1.

Example

For firmware address 1, 3, 22, 2, 10: The library value is 1. The rail is the third from the 
top (3). The library contains one SEM (19 customer accessible columns, so column 22 is 
the outer-most column). The CAP is on the left side (2). The slot is the 10th in the CAP 
magazine.

PTP Internal Addressing
■ Rail: The value (1 to 4) refers to the rail adjacent to the PTP.

■ Column: Right PTP = column value of +6, left PTP = column value of -6.

■ Side: The side value is always 1, because the PTPs are on the outer wall.

■ Row:

– When numbering the device, the row is 0.

– When numbering a specific slot, the row is the slot in the PTP (1 or 2).

Example

For firmware address 1, 2, -6, 1, 0: The library value is 1. The PTP is the second rail 
from the top (2). It is on the left side (column -6), outer wall (side 1), and the address is 
referring to the device (0).

Elevator Internal Addressing
■ Rail: The value is always 0, since the elevators do not correspond to a specific rail.

■ Column: The number of customer accessible columns plus 2. In a library with no 
SEMs, there are 11 customer accessible columns, therefore the elevator column 
value is 13.

■ Side: The value is always 2 because the elevators are on the inner wall.

■ Row:

– When numbering the device, the row is 0.

– When numbering a specific slot, the row is the slot in the elevator (1-4).

Example

For firmware address 1, 0, 21, 2, 4: The library value is 1. The elevators span all rails 
(0). The library contains one SEM (19 customer accessible columns plus 2 = 21). The 
elevator is on the inner wall (side 2), and the address is referring to the fourth slot in 
the elevator.

Robot Internal Addressing
■ Rail: The value (1 to 4) refers to the rail the robot is on.

■ Column: The value is always 0.

■ Side:

– If there is only one robot per rail, the value is always 1.
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– For redundant robotics, the left robot = 1, and the right robot = 2.

■ Row:

– When numbering the device, the row is 0.

– When numbering the specific slot, the row is the slot value (1).

Example

For firmware address 1, 1, 0, 2, 0: The library value is 1. The robot is on the top rail (1). 
The robot spans all columns (0). It is the right robot in a redundant robotics system (2), 
and the address is referring to the device (0).

HLI-PRC Addressing Scheme
■ HLI-PRC Addressing Scheme Overview

■ Library Complex LSM Numbering

■ Drive HLI-PRC Addressing

HLI-PRC Addressing Scheme Overview
HLI-PRC addressing begins with 0, uses only positive numbers, and has four 
parameters: LSM, Panel, Row, and Column.

■ LSM: Each rail is considered a separate library storage module (LSM). LSMs are 
numbered 0 to 3 (from the top down).

The libraries in a complex are identified by LSM (see "Library Complex LSM 
Numbering" on page C-7).

■ Panel: Indicates the horizontal position in the library. Panels span across the width 
of the library to include both sides (left and right) and both walls (inner and outer) 
for each LSM. Panel 1 = Drives. Panel 2 to n = Storage slots

■ Row: Is the vertical location of a tape cartridge and are consecutively numbered 
from the top down. Outer walls = 0 to12. Inner walls = 13 to 26.

■ Column: Indicates the left or right side of the library (as viewed from the front). 
Left = 0. Right = 1.

Library Complex LSM Numbering
In a library complex, the LSM number increases sequentially with each additional 
library. The LSM numbering continues with the following pattern for up to ten 
libraries:

Table C–1 Panel Numbering for Various Library Configurations

Configuration Panel Numbering

Base Library RIM 
(2-7)

CIM 
(8-10)

One Expansion Module RIM 
(2-7)

SEM 
(8-15)

CIM 
(16-18)

Two Expansion Modules RIM 
(2-7)

SEM 
(8-15)

SEM 
(16-23)

CIM 
(24-26)

Five Expansion Modules RIM 
(2-7)

SEM 
(8-15)

SEM 
(16-23)

SEM 
(24-31)

SEM 
(32-39)

SEM 
(40-47)

CIM 
(48-50)
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■ Library 1: LSM 0 to 3

■ Library 2: LSM 4 to 7

■ Library 3: LSM 8 to 11

When adding an additional library to a complex, you should add libraries from right 
to left (viewed from the CAP-side of the library). Expanding left to right re-numbers 
the LSMs requiring you to reconfigure hosts.

Figure C–4 Pass-thru Port Planning Example

1. Recommended method with the library added to the left which increases the LSM 
numbering sequentially

2. Disruptive method, which requires a reconfiguration of LSM numbering.

3. New library

4. Pass-thru-port connecting existing libraries

Drive HLI-PRC Addressing
For drives, the panel value is always equal to 1, the column value is always equal to 0, 
and the row value is between 0 and 15.
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Figure C–5 Tape Drive HLI-PRC Addressing (viewed from front of library)

CAP HLI-PRC Addressing
The HLI addressing format for a CAP is (LSM, CAP ID, row, column).

■ LSM - For rotational CAPs, LSM this is always 1. For bulk CAP, LSM corresponds 
to the rail containing the CAP. Numbered 0 to 3 from top to bottom in a single 
library. For a complex, see "Library Complex LSM Numbering" on page C-7.

■ CAP ID - Left CAP is 0. Right CAP is 1.

■ Row - Each CAP appears as one continuous column. For rotational CAP, row 0 is 
at the top and row 38 is at the bottom. For bulk CAP, row 0 is at the top-left corner, 
and row 35 is at the bottom-right corner of the CAP.

■ Column - Always 0.

Figure C–6 Bulk CAP HLI-PRC Addressing 
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Figure C–7 Rotational CAP HLI-PRC Addressing

Physical Hardware Numbering for Tape Drives
The HBC card assigns a physical hardware number from 1 to 64.

Figure C–8 Physical Hardware Numbering of Tape Drive (viewed from rear of library)
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Figure C–9 Comparison of Tape Drive Numbering (viewed from front of the library)

Reserved Internal IP Addresses

IP Address Description

10.0.0.0./24 Internal device network.

10.0.11.0/24 ILC network. Host IP addresses based on library identifier.

10.x+2.11.0/24 or

10.(1...253) + 2.11.0/24

SDP aliasing. X = complex identifier (1...253).

10.0.4.0/24 Rail 0 device network.

10.0.3.0/24 Rail 1 device network.

10.0.2.0/24 Rail 2 device network.

10.0.1.0/24 Rail 3 device network.
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DRedundant Electronics Overview

The optional redundant electronics (RE) feature provides failover protection for the 
library controller. If the library controller or drive controller experiences errors, 
operations will switch to the standby controller. The library controller and drive 
controller installed on the same side of the card cage always switch as a pair.

RE allows an Oracle support representative to replace a faulty card while the library is 
online and provides minimal disruption during firmware upgrades.

■ Redundant Electronics Requirements

■ Redundant Electronics Configuration Examples

■ What Occurs During a Failover

■ Factors that Prevent an RE Switch

■ Factors that Initiate and Automatic Failover

■ Ways to Initiate a Manual Failover

■ Firmware Upgrades with RE

See Also:
■ "Initiating a Manual RE Switch Using SLC" on page 16-7

Redundant Electronics Requirements
■ Two library controller cards (HBCR) 

■ Two drive controller cards (HBT) 

■ Minimum SL8500 firmware version FRS_6.00 and SLC version 4.65

■ Hardware activation file enabled using the CLI

Note: Any reference to HBCR also refers to HBC.

Note:  To enable ADI mode, both cards must be high-memory HBTs.

If using media validation, Oracle recommends that both cards be 
high-memory HBTs.
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Redundant Electronics Configuration Examples
Each library controller card requires its own unique IP address. For dual TCP/IP, each 
card requires two unique IP addresses: one for the primary port 2B and one for the 
secondary port 2A. Therefore, a library with RE and dual TCP/IP requires four unique 
IP addresses.

On each controller card, port 2B and 2A must be on different broadcast domains. 
However, port 2B on the active card and port 2B on the standby card can be on the 
same broadcast domain. The same is true for the 2A ports.

Figure D–1 Redundant Electronics Configuration Examples

See also: "Dual TCP/IP Overview" on page E-1 and "Multi TCP/IP Overview" on 
page F-1.

What Occurs During a Failover
In a controller card failover, the active library controller attempts to complete all 
in-process jobs and copies the cartridge database to the standby controller card. If the 
database cannot be copied (usually only in a sudden failure), you must perform an 
audit after failover (see "Auditing the Library" on page 12-1). The library returns any 
in-transit cartridges to their home slots. The library places any cartridges it cannot 
return to a home slot in a system slot for host recovery (see the host software 
documentation).

After all in-process jobs complete or time out, the cards switch roles. The standby 
controller becomes active and the previously active controller becomes the standby. If 
the previously active controller cannot bring up the standby software, the controller 
enters a fault state.

Effect of a Failover on Users
■ Users of tape management software (Symantec or Virtual Storage Manager) do not 

see an interruption.

■ HLI host applications queue requests during the failover process for completion 
after the failover switch. For ACSLS, only mount and dismount requests are 
affected (see the host software documentation).

■ SLC and CLI connections are terminated. You must re-establish connections to the 
library using the IP address or DNS alias of the new active library controller (the 
former standby controller).
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Factors that Prevent an RE Switch
■ The standby library or drive controller is in a fault or eject state.

■ The standby code is not running on the standby library or drive controller cards.

■ A firmware download or card initialization is in progress.

Factors that Initiate and Automatic Failover
An automatic failover can be initiated by either the active or standby library controller.

The active library controller initiates an automatic failover when:

■ Its partner drive controller card is not installed or it is not communicating.

■ It detects a catastrophic internal software error.

The standby library controller initiates an automatic failover if the active controller is 
not functioning normally.

Ways to Initiate a Manual Failover
Before initiating a manual switch, you should verify that the standby library and drive 
controllers are running normally. You can initiate a manual switch using:

■ Host tape management (ACSLS or ELS) — Failover can be initiated from either 
the active or standby library controller. The standby library controller accepts only 
set host path group and force switchover HLI requests.

■ SLC — Failover is initiated from the active library controller only (see "Initiating a 
Manual RE Switch Using SLC" on page 16-7).

■ CLI — An Oracle support representative can initiate failover from either the active 
or standby library controller.

You may want to perform a manual switch after initial installation of the standby 
cards, after a firmware upgrade, or periodically to check that the failover function is 
working properly. It is not possible to manually switch the library controllers without 
the drive controllers — the controllers are always switched as a pair.

Firmware Upgrades with RE
Firmware upgrades for RE libraries are minimally disruptive to library operations. The 
library loads and unpacks new code simultaneously on the active and standby 
controller cards and on all devices. Then the library activates code and re-initiallizes 
the controllers and most devices. Under most circumstances, the library bypasses 
robot initialization.

The loading, unpacking, and activation of code does not disrupt library operations 
until the library reboots. During the reboot process (which takes approximately 10 
minutes), the host applications (ACSLS and ELS) queue all mount and dismount 
requests. After the reboot is complete, the queued requests are submitted to the library 
controller.

See "Upgrading Library Firmware" on page G-1 for firmware download and activation 
information.
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EDual TCP/IP Overview

Dual TCP/IP provides two connections between the host and the library using the 
primary port 2B and secondary 2A of the HBC/HBCR card. If the primary host 
connection fails, the library automatically uses the secondary connection.

■ Minimum Requirements for Dual TCP/IP

■ Using a Shared Network

■ Configuring Dual TCP/IP

■ Dual TCP/IP Configuration Examples

See Also
■ "Redundant Electronics Overview" on page D-1

■ ACSLS or ELS documentation

Minimum Requirements for Dual TCP/IP
■ ACSLS 7.1 with PUT0701 for Solaris or AIX. Oracle recommends ACSLS 8.1 or 

above.

■ NCS 6.2 with the following PTFs for HSC/MVS/VM: SOS620 L1H168G, SMS620 
L1H168F, and MSP: MSP PTF LF620DL.

■ All switch or router ports must be configured to auto negotiate. The SL8500 ports 
are configured to auto negotiate by default and support 10/100 Mbps speeds.

■ Hardware activation file (see Chapter 5, "Activating Optional Features")

Using a Shared Network

If you must use a shared network:

■ Directly connect the library to a switch or router that filters out undirected 
(broadcast) traffic.

■ Place the library on its own subnet. This may protect the library from receiving 
broadcast messages.

■ Use a managed switch or router to:

Note: Oracle recommends a private network for maximum 
throughput, minimum resource contention, and higher security.
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– Set priorities on ports to supply the host and library with higher priority.

– Provide dedicated bandwidth between the host and library.

– Create a virtual local area network (VLAN) between the host and library.

■ Use a virtual private network (VPN) to insulate host-to-library traffic from other 
interference, such as irrelevant broadcasts.

Network Broadcast Issues on a Shared Network
Broadcasts sent to all network nodes may be directed to the library. The library cannot 
efficiently process requests while it is receiving these irrelevant broadcasts. As a result, 
the host may lose the connection to the library.

Heavy network traffic can also overwhelm the Ethernet controller on the HBC/HBCR 
card. As a result, the controller continuously resets.

ARP Floods on a Shared Network
The SL8500’s processor can be overwhelmed by floods of address resolution protocol 
(ARP) broadcasts. You should connect the library behind a switch or router.

Configuring Dual TCP/IP

■ Configuring the Library for Dual TCP/IP

■ Configuring an ACSLS Host for Dual TCP/IP

■ Configure an ELS Host for Dual TCP/IP

Configuring the Library for Dual TCP/IP
Use the route command to manage the routing tables. Define routes for the 2A and 2B 
ports to the hosts.

1. Using the CLI, take both ports offline:

SL8500> network ip link set dev 2A down
SL8500> network ip link set dev 2B down

2. Add the new IP addresses and subnet masks for both ports:

SL8500> network ip address add IP_address/netmask dev 2A
SL8500> network ip address add IP_address/netmask dev 2B

3. To make the change active, bring both ports online:

SL8500> network ip link set dev 2A up
SL8500> network ip link set dev 2B up

4. Enter the network routing configuration for each port:

■ For multiple hosts, add the IP address and netmask for each host:

SL8500> network ip route add IP_address/netmask dev 2A
SL8500> network ip route add IP_address/netmask dev 2B

Note: Before configuring dual TCP/IP, gather information regarding 
the network, routing, and IP addresses from the administrator or use 
the appropriate network ip command. 
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■ For a single host, no netmask value is required:

SL8500> network ip policy route add host_IP_address dev 2A
SL8500> network ip policy route add host_IP_address via gateway_IP_address 
dev 2A
SL8500> network ip policy enable 2A |2B
SL8500> network ip policy status

5. Verify the configuration.

SL8500> network ip address show
SL8500> network ip route show
SL8500> network ip policy route show dev 2A |2B

6. Check the date and time for accuracy.

SL8500> time
time print
time HH: MM
time HH:MM:SS

7. Test the configuration to ensure you can access the library through both ports.

Configuring an ACSLS Host for Dual TCP/IP
For the ACSLS server, you should use the acsss_config command or the Dynamic 
Configuration config utility to configure two network interfaces on two separate 
subnets. Use the route command to define the two routes on the ACSLS server. A 
second physical connection improves reliability.

1. Update the routing tables of the ACSLS server by following the ACSLS 
documentation. If there is a single network interface on the ACSLS server, no 
special routing is required on the host.

2. Using the UNIX command prompt at the ACSLS server, use the Dynamic Config 
command to add a port connection to the SL8500.

a. Ensure the ACS is in online or diagnostic mode to ACSLS.

b. Use config port acs_id to add a port.

c. If not already online, bring the ACS online to ACSLS.

3. To remove or replace an existing IP address with a different port:

a. Shut down ACSLS by issuing kill.acsss (for 7.3 and below) or acsss 
disable (for 8.0 and above).

b. Configure the new ports by issuing acsss_config.

c. Bring ACSLS back online by issuing rc.acsss (for 7.3 and below) or acsss 
enable (for 8.0 and above)

For more information, see the ACSLS Administrator’s Guide.

Configure an ELS Host for Dual TCP/IP
1. Update the routing tables of the IBM mainframe by following the ELS 

documentation. If there is a single network interface on the IBM mainframe, no 
special routing is required on the host.

2. At the IBM mainframe console or PARMLIB, use the LMUPATH control statement to 
define network LMU attachments.
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3. Specify a second LMUADDR parameter to define the dual TCP/IPs. ELS 
automatically determines whether the connection is dual TCP/IP or dual LMU.

4. Take the ACS offline, issue the LMUPDEF command, and bring the ACS back online 
to pick up the revised LMUPATH statement that includes the second connection.

For more information, see the ELS documentation.

Dual TCP/IP Configuration Examples
■ ACSLS Dual TCP/IP and Shared Subnets Example

■ ACSLS Dual TCP/IP Through a Public Network Example

■ ACSLS High Availability Dual TCP/IP Example

■ See also "Redundant Electronics Configuration Examples" on page D-2 for an 
example of RE and dual TCP/IP.

ACSLS Dual TCP/IP and Shared Subnets Example
In this example, the ACSLS server and the library share two separate subnets. The 
SL8500 uses a one-to-one relationship with the network interfaces on the ACSLS 
server. The network interface card on subnet 192.168.0/23 connects to port 2B and the 
network interface card on subnet 192.168.1/23 connects to port 2A.

Routing
Force a relationship by using the UNIX route commands. For more information, see 
the ACSLS Administrator's Guide.

Figure E–1 ACSLS Dual TCP/IP with Shared Subnets

ACSLS Dual TCP/IP Through a Public Network Example
In this example, the ACSLS server contains two network interfaces that reside on two 
separate subnets. Both interfaces pass through a public network and into two different 
subnets before connecting to the SL8500 library. This configuration uses the same 
commands as in the first example.



Dual TCP/IP Configuration Examples

Dual TCP/IP Overview E-5

Figure E–2 ACSLS Dual TCP/IP

ACSLS High Availability Dual TCP/IP Example
The following example is an ACSLS High Availability (HA) environment that requires 
dual TCP/IP. The purpose of the HA environment is to have two ACSLS servers, one 
active and one standby. In this configuration, two ACSLS servers connect six network 
interfaces (three on each server) to two separate subnets. A third subnet connects the 
two ACSLS servers through a public network.

For more information on ACSLS HA and dual TCP/IP, see the ACSLS Administrator's 
Guide.

Routing
You should separate the SL8500 network interfaces over two different subnets when 
using ACSLS HA. The two different ACSLS servers use different network interfaces; 
therefore, you should add custom route entries to both ACSLS HA servers. Add the IP 
addresses for both servers to the SL8500 configuration.

Routing Tables
Add custom entries to the routing tables on the ACSLS server; however, any 
customized routing table entries will be lost after a reboot of the ACSLS server. To 
maintain custom routing table entries, create scripts to add custom routes. Place the 
scripts in the rc directory structure for automatic execution at boot time.

For more information, refer to the ACSLS Administrator's Guide.

Figure E–3 ACSLS High Availability Dual TCP/IP
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ELS/HSC and Dual TCP/IP Example
The following example shows a preferred configuration for mainframe systems using 
dual TCP/IP. The mainframe host contains two network interfaces residing on two 
separate subnets. Each connection travels through a public network, then connects to 
two different subnets before reaching the SL8500 library.

For more information, refer to the ELS documentation.

Figure E–4 ELS/HSC Dual TCP/IP
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FMulti TCP/IP Overview

Multi TCP/IP allows hosts to connect to multiple libraries in a complex. If the 
connection to one library in the complex fails, the host can still communicate through 
other libraries in the complex. ACSLS hosts support up to 15 connections and ELS 
hosts support up to 32 connections. 

■ Minimum Multi TCP/IP Requirements

■ Configuration Recommendations

■ Multi TCP/IP Configuration Examples

See Also:
■ "Dual TCP/IP Overview" on page E-1

■ "Redundant Electronics Overview" on page D-1

■ ACSLS and ELS documentation

Minimum Multi TCP/IP Requirements
■ A library complex

■ SL8500 firmware version FRS_3.97 and SLC version 3.38

■ ACSLS 7.1 or 7.1.1 with PUT0701 (HA 2.0 also requires PTF 6514766). ACSLS 8.1 or 
above is required to support 15 library connections.

■ ELS version 7.0 with PTF L1H168H, or ELS version 7.1 with PTF L1H168I

■ Hardware activation file (see Chapter 5, "Activating Optional Features")

Configuration Recommendations
■ Always use multiple subnets for redundancy.

■ For single connections between the ACSLS server and each SL8500 in the complex, 
routing tables are not necessary.

■ For a library with dual and multi TCP/IP, use the CLI to configure routing for port 
2A. Ensure port 2A and 2B are on separate broadcast domains.

■ For ELS, use the LMUPATH control statement to define multiple LMUADDR parameters. 
The parameters are the IP addresses for the muti TCP/IP connections.

In the following example, the host is connected to four SL8500 libraries.

LMUPATH ACS(00)LMUADDR(123.456.789.012,123.456.789,
013,123.456.789.014,123.456.789.015)
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Multi TCP/IP Configuration Examples

Figure F–1 Multi TCP/IP Connections to a Library Complex

Figure F–2 Dual and Multi TCP/IP Connections to a Library Complex

For more information, see "Dual TCP/IP Overview" on page E-1.
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GUpgrading Library Firmware

The library controller stores up to two versions of firmware. This allows the library to 
continue normal operations, running one version of firmware, while you load and 
unpack an upgraded version. Since activating firmware requires a reboot, this allows 
you to upgrade firmware at a convenient time for library users.

After activating the upgraded code, the library retains the previous version of code, so 
that you can revert without having to download and unpack it again. However, 
reverting to a previous version of code is not recommended, you should only do so 
when instructed to by Oracle support.

■ Downloading Firmware from My Oracle Support

■ Loading Firmware

■ Activating Firmware

■ Downgrading Firmware

Downloading Firmware from My Oracle Support
1. Go to My Oracle Support (MOS): https://support.oracle.com/

2. Sign in to your MOS account.

3. Click the Patches & Updates tab.

4. In the Patch Search tab, click Product or Family (Advanced).

5. In the Product field, enter SL8500 and then select Sun StorageTek SL8500 
Modular Library System from the drop-down list.

6. In the Release field, select the firmware version.

7. Click Search.

8. Click the link under Patch Name.

9. Click Download and save the file to a location on your system. Extract the ZIP 
archive to a folder on your system.

Note: Library firmware does not contain drive code upgrades (see 
the drive-specific documentation for drive code information).
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Loading Firmware

1. Download the code to the system you will use to run SLC (see "Downloading 
Firmware from My Oracle Support" on page G-1).

2. Review the pre-requisites and code load instructions provided with the download.

3. Log in to SLC.

If you are upgrading an SL8500 complex, you can start an SLC session on any 
library in the complex. The upgrade propagates to all libraries in the complex from 
a single SLC session.

4. Select Tools > Diagnostics, and then select the Library in the device tree.

5. Click the Load Code tab.

6. Click Browse, and then locate the firmware package on your system. Within the 
firmware package, select the SL8500_FRS<X.XX>_firmware.jar file.

7. In the File Load Console Window, verify the file contents contain the FRS version 
of code you intend to load.

8. Click the Load button. The process could take up to 10 minutes as the library loads 
and then unpacks the code.

9. Verify the package unpacked successfully (Failed 0). If there are any failures, 
contact Oracle support.

Activating Firmware

Note: This procedure is for upgrading to FRS_8.60 or above. The 
current firmware must be a minimum of FRS_8.51 and SLC 6.60. To 
install an older version, to downgrade firmware, or if your current 
firmware version is below FRS_8.51 contact Oracle support.

Note: Code load is not available at the local operator panel.

Note: To activate code, the library must reboot. Schedule the 
activation accordingly.
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1. If you have not already downloaded and unpacked the code, see "Loading 
Firmware" on page G-2).

2. Take the library and all drives offline before activating new code (see "Taking the 
Library Offline" on page 15-1).

3. In SLC, select Tools > Diagnostics, and then select the Library in the device tree.

4. Click the Activate Code tab.

5. From the Target drop down list, select the code package to activate (in this case 
SL8500 Code). In the Available Versions section, select the code version to activate 
(usually the highest FRS version listed).

6. Click the Activate button. Read the caution, and then click OK. Approximate 
activation time is 45 minutes (+/- 15) for a four robot configuration. An eight robot 
configuration can increase this time by about 25 minutes.

7. When the Overall Progress bar reaches 100%, verify that the code activated 
successfully (Failed - 0). Skipped means that the version is already on the device, 
so activation is not necessary. If something failed, contact Oracle support.

8. When the activation process finishes and there are no failures, click Reboot to 
reboot the library (in a complex click All Libraries In Complex).

9. Click OK to terminate the SLC session. After library initialization completes, you 
can log back in to SLC.

Approximate time is 3 to 5 minutes for SLC reconnect and 5 to 8 minutes for all 
devices to become green on SLC (if the front access doors have not been opened, 
otherwise, an audit is automatically triggered, which can take 20-120 minutes 
depending on the size of the library).

Downgrading Firmware
Contact Oracle support if you wish to downgrade code or install a version of code 
below FRS_8.51.

Caution: Do not open the door or power cycle the SL8500 or robots 
during this phase. Potential damage can be done to controller cards. 
Do not reboot any devices in the library or execute any operations on 
the library while activating code.

Note: If you encounter errors while updating firmware, contact 
Oracle support.
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HBarcode Labels

This document describes the requirements for cartridge barcode labels used in Oracle’s 
StorageTek tape libraries. All tape cartridges must have a proper barcode label. 
Mis-aligned, mis-oriented, or improperly-labeled cartridges may cause equipment 
damage.

■ Barcode Standards

■ Label Design

■ Applying a Label

■ Label Care

Barcode Standards
StorageTek libraries use labels based on the Code 39 barcode standard (refer to 
ANSI/AIM BC1/1995, Uniform Symbology Specification - Code 39). This standard 
uses discrete barcodes, meaning a fixed pattern of bars represents a single character. 
Each character is made up five black and four white, where three bars are wider than 
the others.

For example, Figure H–1 represents the letter A using six narrow bars and three wide 
bars (two black and one white).

Figure H–1 Code 39 Barcode Standard — Letter A

When multiple barcode characters are arranged together as a label, a narrow white bar 
is placed between the individual characters. This bar is called the inter-character gap.

Figure H–2 Code 39 Barcode Standard — Inter-Character Gap
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Label Design
Each label must have a six-character volume serial ID (vol-id) and a one- or 
two-character media ID. The media ID identifies the cartridge type. The labels can 
only use the uppercase letters A through Z, the numbers 0 through 9, and an asterisk 
(*) for the start and stop character (for example, *ABC123L6*, where ABC123 is the 
vol-id and L6 is the media ID).

The StorageTek T-series cartridge labels made by Tri-optic use a dollar sign ($) as the 
start and stop character. Never use the asterisk or dollar sign as part of the 
customer-defined characters of a barcode. Barcode algorithms only decode the 
characters between the end stops, ignoring any characters outside. Refer to the table 
below for examples. 

Table H–1 Start and Stop Character Placement

Actual Barcode Label After Decoding Result

*ABC123L6* ABC123L6 Correct label

*ABC*23L6* ABC Misplaced stop character

*ABC1234L6 Unreadable No stop character
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Figure H–3 Barcode Placement Standards (T10000 and LTO)

Figure Legend:

1. Start character

2. Volume ID

3. Media ID

4. Stop character

LTO
These cartridges require an eight-character label — a six-character vol-id and a 
two-character media ID. The media ID characters are:

■ L3 = Generation 3
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■ L4 = Generation 4

■ L5 = Generation 5

■ L6 = Generation 6

■ L7 = Generation 7

■ L8 = Generation 8

■ LT = Generation 3 WORM

■ LU = Generation 4 WORM

■ LV = Generation 5 WORM

■ LW = Generation 6 WORM

■ LX = Generation 7 WORM

■ LY = Generation 8 WORM

■ CU = universal cleaning

T9840 and T9940
These cartridges require a six-character vol-id label plus a separate one-character 
media ID label. Only Tri-Optic Corporation, American Eagle Systems/Wrightline, or 
Imation Corporation can print these labels. The media ID characters are:

■ R = T9840 data

■ U = T9840 A/B/C cleaning

■ Y = T9840 D cleaning

■ P = T9940 data

■ W = T9940 cleaning

T10000
These cartridges require an eight-character label — a six-character vol-id and a 
two-character media ID. The media ID characters are:

■ T1 = T10000 A/B data

■ T2 = T10000 C/D data

■ TS = T10000 A/B sport

■ TT = T10000 C/D sport

■ CT = cleaning (A and B only)

■ CL = universal cleaning

Cleaning and Diagnostic Labels
Cleaning and diagnostic cartridges require unique labels to distinguish them from 
data cartridges. The first three alphanumeric characters in the vol-id determine the 
type of cartridge.

■ Cleaning cartridges — use CLNnnn for the vol-id plus the cleaning-specific media 
ID, where CLN is the cleaning cartridge identifier and nnn is a sequence of numbers 
(for example, CLN001CU could be an LTO cleaning cartridge label).
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■ Diagnostic cartridges — use DG[space]nnn plus the media ID, where DG[space] is the 
diagnostic cartridge identifier, and nnn is a sequence of numbers (for example, 
DG 001L6 could be an LTO6 diagnostic cartridge label).

Cartridge Label Examples

Figure Legend:

1. Data cartridges

2. Cleaning cartridges

3. Diagnostic cartridges

Applying a Label

Guidelines for applying the labels include:

■ Inspect and clean the cartridge. Wipe all dust, dirt, and moisture using a lint-free 
cloth. Use a safe cleaning solution (such as isopropyl alcohol) to clean the cartridge 
exterior housing.

■ Ensure the cartridge and label are oriented correctly. Orient the label with the 
barcode below the human-readable characters and the cartridge with the hub-side 
down. For LTO cartridges, hold the cartridge so that the write-protect switch is 
toward you. For a T10000 cartridge, ensure the write-protect switch is away from 
you. For a T9840 cartridge, ensure the write-protect switch is on the right side.

■ Apply the labels with in the recess on the cartridge as straight as possible. Ensure 
the edges of the label are parallel to the edges of the cartridge. The label must not 
overlap the edge of the recessed area.

■ For T9840 and T9940 labels, align the vol-id label and media ID label.

■ For best adhesion, apply the label within one year of purchase.

Caution: Mis-aligned, mis-oriented, or improperly-labeled cartridges 
may cause equipment damage.
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Figure H–4 Cartridge Label Orientation

Figure Legend:

1. Write-protect switch

2. Cartridge label

3. Separate media ID label (T9840 and T9940 only)

T9840 and T9940 Label Issues
All media ID labels must have a correctly sized white area above and below the 
barcode. If the white area is too small, the radius of the label die can cut into the first 
black bar of the barcode, causing barcode read errors.

Figure H–5 White Area on Separate Media ID Label

Figure Legend:

1. White area is too small

2. Correctly sized white area

The media ID label must be aligned with the vol-id label. Ensure the media ID label is 
not rotated or off-center from the vol-id label.
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Figure H–6 Mis-aligned Media ID Label

Figure Legend:

1. Rotated media ID label

2. Off-center media ID label

Label Care
Proper label care is required to prevent barcode read errors or damage to the 
equipment:

■ Keep the barcode intact. Do not mark or damage the barcode label or place any 
kind of tape across the label.

■ Remove old labels completely before applying a new label. Do not apply a new 
label on top of an old one.

■ Do not use sharp instruments to seat or remove a label.
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2N

An optional power configuration that provides both AC and DC redundancy. There is 
one power supply for every four tape drives and one supply for every robot. This 
configuration requires a second AC power source to support an additional system 
PDU. All four accessory racks are powered. See also N+1.

ADI

Automation drive interface. Supports rich data for StorageTek Tape Analytics.

access door

A door on either side of the CIM through which service personnel can enter the 
library.

active slot

A storage slot that can be used for cartridge storage.

active capacity

The number of storage slots the library is authorized to use for storage. This cannot 
exceed the installed capacity or the purchased capacity. Same as allocated capacity.

allocated capacity

The number of active slots. Allocated capacity cannot exceed the purchased capacity 
defined by the hardware activation file. Same as active capacity. See also unallocated 
capacity.

audit

An inventory of cartridge locations in all areas of the library, including the slots in the 
storage and reserved areas. Audits occur when:

■ The library initializes at power-on.

■ After either one or both access doors are opened and closed without activating the 
service safety door.

■ A physical audit request is made through SLC.

See also host audit, physical audit, verified auditand virtual audit.

away library

The SL8500 library located on the left side of a home library, as viewed from the front. 
The away library does not supply power to, control, or recover the pass-thru port.
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CAP

See cartridge access port (CAP).

CLI

Command line interface.

capacity

The storage capacity of the library. See also active capacityand installed capacity.

cartridge

A container holding magnetic tape that can be mounted to a drive to read or write 
data. The library uses data, diagnostic, and cleaning cartridges.

cartridge access port (CAP)

A port built into the door panel of the library used to import or export cartridges.

cartridge array

A plastic housing that holds multiple cartridges when not in use. The inner walls of 
the SL8500 library consist of 14-slot arrays and the outer walls consist of 13-slot arrays.

cleaning cartridge

A tape cartridge that used to clean the tape path in a drive. Cleaning cartridges are 
drive specific and should be replaced after a limited number of uses.

customer interface module (CIM)

The front module of the SL8500 library which contains the touch screen operator panel 
and allows service personnel to access the library and service bay.

DEM

See drive and electronics module (DEM).

dWWN

See dynamic WWN.

data cartridge

A cartridge used to store data.

diagnostic cartridge

A cartridge used for diagnostic routines of a drive.

drive and electronics module (DEM)

The module in the SL8500 library that houses the electronics control module, power 
distribution units (PDUs), power supplies, accessory racks and equipment, and tape 
drives for the library. The module is located at the rear of the library.

drive array

The metal housing installed in the drive and electronics module for mounting tape 
drive tray assemblies. The drive and electronics module holds up to four array 
assemblies, and each array holds up to 16 tape drive tray assemblies.

drive bay

A section of the drive array that holds one tape drive tray.
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drive bay address

A two-digit integer (01–64) that represents the physical locations into which drive tray 
assemblies are inserted.

drive tray

A metal chassis, cables, electronic cards, and tape drive used to interface the tape drive 
to the tape library. The drive tray contains the drive controller card (HBD or LOD).

Dual TCP/IP

Provides two separate host connections between the host software (ACSLS or HSC) 
and the library controller.

dynamic WWN

When enabled, dWWN assigns names to library drive slots rather than devices. When 
a drive is replaced, the new drive receives the same name as the one it replaced, 
thereby eliminating the need for system re-configuration. dWWN assigns names to 
individual tape drive slots rather than devices

ECM

See electronics control module (ECM).

ELS

See Enterprise Library Software.

ERS

See emergency robotics stop switch (ERS).

eject

See export.

electronics control module (ECM)

A module that includes the HBK card, HBC/HBCR card, and HBT card. The ECM 
Processes commands from a host system assembly, coordinates the activities of library 
components, and monitors status inputs from sensors and switches

elevator

The device that transports cartridges vertically. The SL8500 library features two 
elevators that move cartridges between the rails of the library.

emergency robotics stop switch (ERS)

A switch located on the CIM keypad that removes all power to the robots.

enter

See import.

Enterprise Library Software

The software products that automate tape operations for mainframe clients.

export

The library places a cartridge into a CAP slot so that an operator can remove the 
cartridge from the library. Same as eject.
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FRU

Field replaceable unit.

failover

The act of moving to a secondary or redundant path when the primary path fails.

front controller module

The module that houses the controller for the elevators, CAPs, turntables, and safety 
barrier.

front facade

The external portion of the CIM, between the access doors, that holds the keypad and 
local operator panel.

get

An activity in which a robot obtains a cartridge from a slot or drive.

HLI/PRC

Host Library Interface/Panel Row Column

home library

The library that provides power, signal, and control lines to the pass-thru port 
(PTP)mechanisms. This is the library on the right of a library complex as viewed from 
the front.

host audit

The process of updating the cartridge vol-ids and locations in a host database. This 
audit is initiated by a host command.

hot swap

Removal and replacement of a system component while system power remains on and 
system operations continue.

hot-pluggable

The capability that allows an Oracle service representative to replace a system 
component while power to the system is maintained. This feature allows hardware 
maintenance actions and hardware upgrades to proceed without disrupting subsystem 
availability. Contrast with hot swap.

import

The process of placing a cartridge into the cartridge access port so that the library can 
insert it into a storage slot.

inactive slot

A storage slot that is explicitly deactivated and cannot be used for cartridge storage.

installed capacity

The number of storage slots physically present in the library.

interlock switch

A switch that disconnects power to library mechanisms, excluding tape drives, when 
the front door is opened.
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keypad

The interface located on the CIM. The keypad contains the CAP open/close buttons, 
safety door locks, and the ERS button.

LCM

See Library Content Manager (LCM).

LTO

See linear tape open format (LTO).

library complex

Two or more SL8500 libraries attached to each other with a pass-thru port (PTP).

library controller (LC)

The HBC/HBCR card within the library that controls operations and communicates 
with the operator panel.

Library Content Manager (LCM)

Software that provides content management for mainframe automated tape 
environments. Works with host software component, virtual storage manager and 
your tape management system.

library operator panel

See touch screen operator control panel.

library storage module (LSM)

Library component connected to other LSMs in a library complex with a pass-thru 
port. Same as an SL8500 rail.

linear tape open format (LTO)

A set of tape data format standards created to enable data interchange among different 
LTO Ultrium tape drive vendors. These standards allow data cartridges to be shared.

magazine

A removable array that holds cartridges and is placed into the cartridge access port 
(CAP).

Multi TCP/IP

Using TCP/IP connections to multiple libraries to provide redundant communication 
paths between the host software (ACSLS or HSC) and an SL8500 library complex.

MIR

Media Information Region (MIR). A kind of map or directory of the location of user 
data on the physical media. This capability allows the drive to optimize access to user 
data, saving vital time to data access. The MIR data on an encrypted tape is not 
encrypted.

N+1

The standard power configuration that provides DC power redundancy by adding an 
additional DC power supply to DC power grid. There is one power supply for every 
two robots plus one redundant supply and one supply for every eight drives plus one 
redundant supply. There are two PDUs: one system PDU and one N+1 PDU. Only 
accessory racks 2 and 4 are powered. See also 2N.
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online replacement

Replacement or service of a module while the library remains operational. The service 
person may be required to power off the module before removing or replacing it.

operator panel

See touch screen operator control panel.

orphaned cartridge

A cartridge in a partitioned library that is located in an unallocated slot or drive (that 
is, a slot or drive not allocated to any defined partition). Cartridges may become 
orphaned when partition boundaries are changed, partitions are deleted, or cartridges 
are manually moved to unallocated or inaccessible slots.

PDU

See power distribution unit (PDU).

PLI

See primary library interface (PLI).

PTP

See pass-thru port (PTP).

pass-thru port (PTP)

An electro-mechanical device that allow one library storage module to pass a cartridge 
to another adjacent library storage module in the same complex. A library complex is a 
series of libraries connected with pass-thru ports. SL8500 libraries are joined together 
by four PTPs because there are four rails. See also home libraryand away library.

physical audit

Physical audits occur when the robots:

■ Scan the cartridge locations in the library

■ Verify the volumes

■ Update the library control card inventory

■ Set the status of the cartridge location to true

physical capacity

The number of storage slots in the library. Compare to active capacity.

power distribution unit (PDU)

A device for the distribution of AC line power from one inlet to multiple outlets. 
Multiple PDUs provide higher availability because the power continues if one PDU (or 
its alternating current source if the PDUs use separate AC sources) loses power.

primary library interface (PLI)

The communication path between the operator panel and the library controller.

purchased capacity

The total number of storage slots authorized for activation. The value is defined by the 
hardware activation file. See also allocated capacity and active capacity.
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put

An activity in which a robot places a cartridge into a slot or drive.

RE

See redundant electronics (RE).

RIM

See robotics interface module (RIM).

rail

(1) That portion of the upper robot track assembly that provides power and 
communication to the robot. (2) All of the cartridge slots and drives accessible through 
a rail.

redundant electronics (RE)

A feature that provides failover protection in enterprise libraries. RE uses a two sets of 
library controller cards. At any given time, one set is active and the other set is 
standby. The active library controller can failover to the standby in response to a 
command from ACSLS or the SLC. Automatic failover can be initiated by the library if 
a library card failure.

robot

A mechanism that moves horizontally along a track to transport tape cartridges to and 
from other locations in the library.

robotics interface module (RIM)

The module containing the curved rails and pass-thru port (PTP)assemblies.

selected slot

A storage slot that cannot currently be used for cartridge storage, but will be made 
active automatically by the library controller when activated capacity is increased.

service area

An area between the access doors of the customer interface module and the safety 
barrier. In the service area, a redundant or inoperable robot can be stored for service 
and other mechanisms can be repaired or replaced.

service safety door

A motor-driven barrier that lowers and raises. This door separates the service areas of 
the front interface assembly from the rest of the library. The SSD allows service 
personnel to safely repair or replace library mechanisms while the front access door is 
opened and closed., without interference with most library operations.

slot

A storage location for a cartridge with the library.

TTI

See tape transport interface (TTI).

tape drive

An electromechanical device that moves magnetic tape and includes mechanisms for 
writing and reading data to and from the tape.
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tape storage area

The area in the library where cartridges are stored.

tape transport interface (TTI)

An interface to control and monitor tape movement.

touch screen operator control panel

A flat-panel display with a touch screen interface and a panel mount computer. This 
feature is attached to the front of the library.

track

The horizontal path upon which a robot travels.

unallocated capacity

The number of storage slots available for capacity activation. This value is equal to the 
purchased capacity minus the allocated capacity.

vol-id

Volume ID assigned to a cartridge. Same as VOLSER.

VOLSER

Volume serial number. Same as vol-id.

VSM

See virtual storage manager (VSM).

VTCS

See virtual tape control system (VTCS).

VTD

See virtual tape drive (VTD).

VTSS

See virtual tape storage subsystem (VTSS).

verified audit

Verified audits are invoked from the SLC and actually validate the status of a specific 
cartridge slot or range of slots.

virtual audit

Virtual audits are invoked from the SLC and only display the cartridge inventory in 
the console screen (either local or remote).

virtual storage manager (VSM)

A storage solution that virtualizes volumes and transports in the buffer of a virtual 
tape storage subsystem to improve media and transport use.

virtual tape control system (VTCS)

The primary host code that controls activity and information about VTSSs, VTVs, 
RTDs, and MVCs.
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virtual tape drive (VTD)

An emulation of a physical transport in the VTSS that looks like a physical tape 
transport to MVS. The data written to a VTD is really being written to DASD. The 
VTSS has 64 VTDs that do virtual mounts of VTVs.

virtual tape storage subsystem (VTSS)

The DASD buffer containing virtual volumes (VTVs) and virtual drives (VTDs). The 
VTSS is a STK RAID 6 hardware device with microcode that enables transport 
emulation. The RAID device can read and write "tape" data from/to disk, and can read 
and write the data from/to an RTD.

virtual tape volume (VTV)

A portion of the DASD buffer that appears to the operating system as a real tape 
volume. Data is written to and read from the VTV, and the VTV can be migrated to 
and recalled from real tape.

WWN

See World Wide Name.

World Wide Name

A 64-bit address that uniquely identifies each individual device and vendor, much like 
the MAC address of an Ethernet interface. Each port on a Fibre Channel network must 
have a its own WWN. The WWN is not just a physical hardware address. It also serves 
as the logical address of a node on the SAN. The SAN configuration changes if any of 
the attached hardware changes. If a device fails and is replaced, the WWN of the node 
changes, forcing reconfiguration of the SAN. There are three World wide Names 
reserved for each drive bay: Node, Port A, and Port B.



World Wide Name

Glossary-10



Index-1

Index

Numerics
2N power configuration

block diagram, 1-10
description, 1-10

39-slot cartridge access port, 1-5
9840

ordering, 1-22

A
AC power, 1-11

connections, 1-11
options, delta/wye, 1-11
ordering, 1-23

accessory rack
about the, 1-7
feature codes, 1-20

accessory racks, 1-7
ACSLS

advantages, 1-15
description, 1-15
Dual TCP/IP and high availability 

configuration, E-5
Dual TCP/IP and high availability routing, E-5
Dual TCP/IP separate subnets, E-4

activated features
capacity, 6-1
display current, 5-2
files, 5-1
partitioning, 7-1, 13-1, 14-1
redundant electronics, D-1, F-1

active capacity, 6-1
HLI hosts, 6-3
library complex, 6-2
reports, 14-2
single library, 6-1, 6-2

addressing
dWWN, 1-14

adjustable jacks, 2-14
arbitrated loops, 1-14
ARP floods, E-2
audits

audit indicator, 12-2
description, 12-1
full library, 12-1

main access door and, 12-2
physical, 12-1, 12-2
range of cells, 12-2
verified, 12-2

auto enter mode, 8-5

B
base configuration

description, 1-1
ordering, 1-19

C
cables

ESCON, 1-25
Ethernet, 1-24
ordering, 1-24
plenum, 1-24
riser, 1-24

cabling
routing

external, 2-9
internal, 2-9

CAP
description, 1-5

capacity
activation, 6-1
CAP, 1-5
capacity on demand, 1-9
HLI hosts, 6-3
library complex, 6-2
non-partitioned library, 6-1
ordering, 1-24
real time growth, 1-9
single library, 6-1, 6-2

CAPs
bringing online, 15-2
closing, 8-3
display properties, 13-2
display status, 13-2
display summary information, 13-2
inserting cartridges, 8-1
library partitions, 7-5
manual mode, 8-5
modes, 8-5
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reservations, 7-5
self-test, 16-3
taking offline, 15-2

cartridge access port, 1-5
cartridges

display information, 14-2
ejects, 8-2
enters, 8-1
exterior cleaning, 10-5
handling, 10-4
inserting in a cell or drive, 10-4
inserting in the CAP, 8-1
inspecting, 10-4
list, 14-2
locate by address, 10-2
locate by VOLID, 10-2
locating by address, 10-2
locating by VOLID, 10-2
mounting, 17-3
move by VOLID, 10-1
move from specified location, 10-1
orphaned, 6-3
recovery moves, 10-1
storing, 10-5
unlabeled, 10-4
validation, 1-13

cautions
solvents for cleaning a cartridge, 10-5

ceiling clearances, 2-7
cells

capacities, 1-9
circuit breaker ratings, 1-11
cleaning cartridges, 10-4
clearances, 2-7
communication

connectivity, 1-13
HBC controller, 1-4

components
camera, 1-7
CAP, 1-4
electronics module, 1-4
elevator, 1-6
moving, 2-14
PTP, 1-6
safety door, 1-8
unpacked, 2-14

configurations
module types, 1-1

connections
interface cable types, 1-24
power, 1-11

connectivity
interface cables, 1-24
options, 1-13

cooling, airflow requirements, 2-8
co-planar, 2-6
crossover cable, 2-13
CSC

description, 1-17
customer

floor requirements, 2-5
Customer Interface Module

components, 1-1
customer service, 1-25

D
DC power

power supplies, 1-11
delete

hardware activation, 5-2
device status

listing codes, 14-4
diagnostic cartridges

description, 10-3
exporting, 10-4
importing, 10-3
library self-tests and, 16-3
management tasks, 10-3

diagnostic moves (robot)
defining, 16-4
description, 16-4

diagnostic support files, 14-2
dimensions

shipping, 2-3
distribution pads, 2-5
door

cutouts, 2-9
notches for cable routing, 2-9
safety for, 1-8

download
hardware activation, 5-1

drive
dWWN, 1-14

Drive and Electronics Module
overview, 1-2

drive cleaning
description, 9-1

drive controller, 13-1
Drive Events Report, 14-1
Drive Media Events Report, 14-1
drive trays

status, 13-2
drive VOP

displaying for T10000, 13-2
drives

bringing online, 15-2
display drive properties, 13-2
display drive summary information, 13-2
display status, 13-2
Fibre Channel topology supported, 1-14
LED status, 13-2
mounting a cartridge, 17-3
network data, 13-2
power on and off, 17-1
taking offline, 15-2

Dual TCP/IP
ACSLS routing, E-4
ACSLS separate subnets, E-4
configuration tasks, E-2
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definition, E-1
description, 1-13

dWWN
drive addressing, 1-14

E
earthquakes, 2-8
ECM, 1-4
eject operations, 8-2
Electronics Control Module

overview, 1-4
elevator

status of, 13-2
summary information, 13-2

elevators
description, 1-6

ELS
description, 1-16

emergency robotics stop
usage, 17-3

enter operations, 8-1
entering the library, 17-2
ESCON

cables, 1-25
Ethernet

cables, part numbers, 1-24
event monitors

display, 14-3
spool data to a file, 14-4
tasks, 14-4

Expert Library Manager, 1-17
Expert Performance Reporter, 1-17
ExPR

description, 1-17
Extended High Performance Data Mover, 1-17
extractor tool, used for power rails, 2-13

F
FC-SW, 1-14
features

fire suppression, 2-10
fiber optic cable

ordering, 1-24
Fibre Channel

topology supported, 1-14
Fire Suppression System, 2-10
floor

co-planar requirement/tolerance, 2-6
customer, installation requirements, 2-5
cutouts, 2-9
variations, 2-6
weight capacity, 2-5

G
General Events Statistics Report, 14-1

H
HandBots

description, 1-6
hardware

overview, 1-1
tools required for installation, 2-12

hardware activation
delete, 5-2
download, 5-1
Feature Audit Log, 14-2
file type, 5-1
install, 5-2
overview, 5-1

hardware activation file
display current, 5-2

hardware activation files, 1-18
height

limits/tolerance, 2-6
HLI interface

displaying port status, 13-1
horizontal pass-thru operations, 1-6
host

connectivity, 1-13
Fibre Channel connection, 1-14
library management software, 1-15

host interfaces
HLI. See HLI interface., 13-1

HSC
description, 1-16

Hubbell, plugs and connectors, 1-11

I
Independent Software Vendors, 1-16
install

hardware activation file, 5-2
installation

adjustable jacks, 2-14
moving the library, 2-14
tool kit, 2-12

interface
cable routing, 2-9
cables, 1-24

J
jack assembly part number, 2-12
jacks, 2-14

K
key

opening the front access doors, 17-2
keypad, 1-7
kit

installation tools, 2-12

L
labels
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ordering, 1-23
laptop cross-over and serial cables, 2-13
LC to SC adapter, 1-24
LCM

description, 1-17
LibAttach, 1-15
library

capacities, 1-9
ceiling clearances, 2-7
entering the library, 17-2
entry precautions, 17-2
mounting a cartridge, 17-3
moving unpacked components, 2-14
partitions

CAP operations, 8-3
placing in manual mode, 15-1
placing online, 15-2
power off, 17-1
transporting, 2-14
weights and measures, 2-1

Library Attach, 1-15
library complex

displaying status, 13-1
locating cartridges, 10-2
partitioning, 1-12
properties, 13-1
PTP, 1-6

library configuration
display, 13-1

library console, 1-14
Library Content Manager, 1-17
library controller

display redundant electronics, 13-3
properties, 13-1

library firmware upgrades, G-1
activate, G-2
download, G-2

library management software
ACSLS, 1-15
described, 1-15
HSC, 1-15

library partitions
CAP reservations, 7-5
deleting, 7-2
orphaned cartridges in, 7-5

library reboot, 15-3
library reports

displaying, 14-1
saving data to a file,SL Console report tasks, 14-1
searching, 14-1

library self-tests, 16-2
performing, 16-2

library status
display, 13-1

local operator panel
factory alignment, 16-7
logging in, 4-2
re-calibrating, 16-7

log snapshot file
generating process, 14-3

transfer process, 14-3
logic cards, 1-4
login IDs, 4-2
logs

Feature Audit Log, 14-2

M
main access door

audits and, 12-2
manual CAP, 8-5
manual mode

entering the library, 17-2
mounting a cartridge, 17-3
physical restrictions, 17-2
placing the library in manual mode, 15-1

manual operations
safety precautions, 17-2

general, 17-2
measurements, library, 2-1
media, 1-23

Service Center, 1-23
media validation, 1-13
MIB file

transfer process, 14-3
minimum

working area, 2-5
modules

Customer Interface, 1-1
Robotics Interface, 1-1
Storage Expansion, 1-1
types, 1-3

moving
library, 2-14
unpacked components, 2-14

Multi TCP/IP, 1-14
Multi-TCP/IP

configuration recommendations, F-1

N
N+1 configuration, 1-10
network

topology, 1-14
network broadcasts, E-2

O
operator panels

SLC, 1-14
options

connectivity, 1-13
host library management software, 1-15
storage expansion modules, 1-1
storage system solutions, 1-17

orphaned cartridges, 6-3
partitioned libraries and, 7-5

overhead clearances, 2-7
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P
part numbers

cables, 1-24
Hubbell plugs and connectors, 1-11
installation tools, 2-13
tool kit, 2-12

partitioning, 7-1, 13-1, 14-1
library complex, 1-12
overview, 1-12

partitions
overview, 7-1, 13-1, 14-1

pass-thru ports
description, 1-6
ordering, 1-20
planning, 2-11

Pass-thru Ports (PTPs)
locating cartridges, 10-2

passwords
activation, 4-1
modifying, 4-2

PDUs, 1-10
photo-electric smoke detector, 2-10
physical

planning, 2-1
placing the library in manual mode, 15-1
planning

physical, 2-1
shipping weights and dimensions, 2-3

plenum cables, 1-24
plugs and connectors, 1-11
port bonding, 1-14, 13-1
port trunking, 1-14
ports

status, 13-1
power

AC, 1-11
calculator, 1-12
configurations

2N, 1-10
connections, 1-11
DC, 1-11
distribution units, 1-10
off, 17-1
options, 1-11
switches, 17-1

power rails, extractor tool, 2-13
power supplies

monitoring tasks, 13-2
status of, 13-2
summary information, 13-2

pre-installation planning
physical, 2-1
shipping weights and dimensions, 2-3

PTP
properties, 13-2
status of, 13-2

R
rack

descriptions, 1-7
feature codes, 1-20

reboot
library, 15-3

recirculation, 2-8
recovery moves, 10-1
redundant electronics

manual switch, 16-7
tasks, 13-3

Redundent Electronics (RE), 1-14
report

capacity activated, 14-2
orphaned cartridges, 14-2

reports
cartridge summary, 14-2
cartridge table, 14-2
drive events, 14-1
feature audit log, 14-2

requirements
airflow, 2-8

restrictions, library interior, 17-2
result codes

listing, 14-4
riser cables, 1-24
robot

description, 1-6
display status of, 13-2
display summary information, 13-2
monitoring tasks, 13-2
properties, 13-2
self-test, 16-3
varying offline, 15-2
varying online, 15-2

Robotics Interface Module
description, 1-1

routing cables, 2-9

S
safety door

monitoring tasks, 13-2
operation of, 17-3
properties, 13-2
summary information, 13-2

safety precautions, 17-2
general, 17-2

SAN, 1-14
SC to LC adapter, 1-24
SDP, 1-15, 1-25
seismic compatibility, 2-8
self-tests

CAP, 16-3
library, 16-2
robot, 16-3

serial cable, 2-13
service delivery platform

See SDP
service mode, 1-8
shipping

dimensions, 2-3
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SL Console
activation password, 4-1
communications failures, 13-3
first-time access, 4-1
login ID, 4-2
modifying passwords, 4-2
security, 4-2
user ID, 4-2

SL Console reports
Drive Events, 14-1
Drive Media Events, 14-1
General Events, 14-1

SLC, 1-14
LibAttach, 1-15
media validation, 1-13

SLConsole
downloading, 3-1
media pack, 3-1
modes, 3-1
overview, 3-1
standalone, 3-2
web-launched, 3-2

slopes, 2-6
slots

capacities, 1-9
SMC

description, 1-16
smoke detector, 2-10
SNMP, 1-15

transfer the library MIB file, 14-3
software

independent vendors, 1-16
STA, 1-17

ST connectors, 1-25
STA, 1-17

media validation, 1-13
standalone SL Console

logging in, 4-1
standalone SLConsole

description, 3-2
security, 3-2

stand-by, PTP, 2-11
status alerts

clearing, 16-6
displaying, 13-1

storage area network
Switched Fabric, 1-14

Storage Expansion Module
components in, 1-1
number of cartridge slots in, 1-1

storage system solutions, 1-17
StorageTek

Library Console, 1-14
Tape Analytics, 1-17

StorageTek Tape Analytics, 1-17
support, 1-25
system power distribution units, 1-10

T
T10000

ordering, 1-22
T9840

ordering, 1-22
tape cartridge

validation, 1-13
tape cartridges

ordering, 1-23
tape drive power kit, 2-13
tape drives

model numbers, 1-21
tolerance, floor, 2-6
tools

required for installation, 2-12
transferring the log snapshot file, 14-3
transporting, 2-14

adjustable jacks, 2-14
troubleshooting, 1-25, 16-1
Two Gigabit Fiber Optic Cable Order 

Worksheet, 1-24

U
unpacked components, 2-14
User ID

types, 4-2

V
vary the library offline, 15-1
vary the library online, 15-2
Virtual Library Extension, 1-18
Virtual Storage Manager, 1-18
Virtual Tape Control System, 1-16
Virtual Tape Storage Subsystem, 1-18
VLE, 1-18
VOP

displaying for T10000 drives, 13-2
VSM, 1-18
VTCS, 1-16
VTSS, 1-18

W
web-launched SLConsole

client requirements, 3-3
installing, 3-2
log in, 4-1
overview, 3-2
security, 3-3
updating, 3-2

weight
distribuiton pads, 2-5
floor capacity, 2-5

working area, 2-5
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