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Creating Projects

The Oracle Solaris Studio IDE lets you create C, C++, and Fortran Application and Library projects with
generated makefiles, as well as projects that have existing source code and makefiles, and projects from
existing binary files.

You can build, run, and debug your project on the local host (the system from which you started the IDE), or
on a remote host running the Solaris operating system or the Linux operating system.

With a C/C++/Fortran Application, Dynamic Library, Static Library, or Oracle Database project, the IDE
controls all aspects of how your application is built, run, and debugged. You specify project settings when
creating the project and in the Project Properties dialog box. The IDE generates a makefile in which all of
your settings are stored.

A project from existing sources is built using your makefile.

Creating an Application Project

1. Open the New Project wizard by choosing File > New Project (Ctrl+Shift+N).
2. Inthe wizard, select the C/C++/Fortran category.

3. The wizard gives you a choice of several types of new projects. Select C/C++/Fortran Application and click
Next.
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Description:
Creates a new application project. It uses an IDE-generated makefile to
build your project.
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4. Create a new C/C++/Fortran Application project from the wizard using the defaults. You can choose the
name of the project and the location of the project.

5. Click Finish to exit the wizard.

A project is created with several logical folders. A logical folder is not a directory. It is a way for you to
organize your files and does not reflect where the files are physically stored on disk. Files added to logical
folders are automatically part of the project and are compiled when you build the project.

Files added to the Important Files folder are not part of the project and are not compiled when you build the
project. These files are just for reference and are convenient when you have a project with an existing
makefile.

Switching Between the Logical View and the Physical View of the Project

A project has both alogical and a physical view. You can switch between the logical view and the physical
view of your project.

1. Select the Files tab. This window shows the physical view of your project. It displays files and folders as
they are stored on disk.

Oracle Solaris Studio 12.3 IDE Quick Start Tutorial



Projects | Files a1 x| Classes Services
< 3@ CppApplication_1
= 3 nbproject
P O private
T Makefile-Debug.mk
T Makefile-Release mk
Tl Makefile-impl.mk
T Makefile-variables.mk
i Package-Debug.bash
&1 Package-Release.bash
configurations xml
project.xmil
T Makefile
= main.cpp

2. Select the Projects tab. This window shows the logical view of your project.

Projects 40 xl Files Classes | Services
= [ cppApplication_1

B Header Files

b Resource Files

B Source Files

b [F Test Files

b [ Important Files

Adding Files and Folders to Your Project

You can add logical folders to your project.

1. Right-click the project node of your CppApplication_1 project and choose New Logical Folder. A new
logical folder is added to the project.

2. Right-click the new logical folder and select Rename. Type the name you would like to give the new folder.

You can add both files and folders to an existing folder. Logical folders can be nested.

Adding New Files to Your Project
You can add new files to your project.
1. Right-click the Source Files folder and choose New > C Main File.

2. Onthe Name and Location page, newmain is displayed in the File Name field.
3. Click Finish.

The newmain. c file is created on disk in the project directory and added to the Source Files folder. You can
add any kind of file to this folder, not only source files.

Note - You can also remove files from the folder. In this case, you do not need the main. cpp file that was added
by default when you created the project. To remove this file from the project, right-click on the file name and
choose Remove From Project.

Adding More New Files to Your Project

1. Right-click the Header Files folder and choose New > C Header File.
2. Onthe Name and Location page, newfile is displayed in the File Name field.
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3. Click Finish.

The newfile.h file is created on disk in the project directory and added to the Header Files folder.

Adding Existing Files to Your Project

You can add existing files to your project in two ways:

= Right-click the Source Files folder and choose Add Existing Item. You can point to an existing file on disk
using the Select Item dialog box and add the file to the project.

= Right-click the Source Files folder and choose Add Existing Items from Folders. Use the Add Folders
dialog box to add folders that contain existing files.

Do not use the New menu item to add existing items. The Name and Location panel will tell you the file
already exists.

Setting Project Properties

When the project is created, it has two configurations, Debug and Release. A configuration is a collection of
settings used for the project, which allows you to easily switch many property settings at once. The Debug
configuration builds a version of your application that includes debug information. The Release
configuration builds an optimized version.

The Project Properties dialog box contains build and configuration information for your project. To open the
Project Properties dialog box:

= Right-click the project node of the Application project and choose Properties.

& . Project Properties - CppApplication_1 % |
Categaones:
Configuration: <All Configurations = [ﬂanage Configurations... |
= @ Build
> € Compiler Project Location: fhorme/ar3d406/SolStudioProjects/CppApplication_1
# C++ Compiler Source Folders:
> Fortran Compiler F
» Assemnbler lﬁ;dd]
Linker S
> Packaging =
> Rumn L
> Profile
» Debug . Jown
* Related Projects ignored Folders Pattern: '
lad .nbprnje:t|hui|d|test|tests}$ DEfaHn

(See also IDE level file filker in Options->Miscellaneous->Files)

Encoding: UTF-8 L=

l oK JlCancell &pplyl ﬂe|p

You can modify the compiler settings and other configuration settings in the Project Properties dialog box by
selecting a node in the left panel and modifying the properties in the right panel. Select some of the nodes and
property values and notice the properties you can set. When you set General properties, you are setting them
in all configurations of the project. When you set Build, Run, or Debug properties, you are setting properties
in the currently selected configuration.
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Managing Configurations

Properties changed in the Project Properties dialog box are stored in the makefile for the current
configuration. You can edit the default configurations or create new ones. To create a new configuration:

1.
2.

Click the Manage Configurations button in the Project Properties dialog box.

In the Configurations dialog box, select the configuration which most closely matches your desired
configuration. In this case, select the Release configuration and click the Copy button. Then click Rename.

In the Rename dialog box, rename the configuration to PerformanceRelease. Click OK.
Click OK in the Configurations dialog box.

In the Project Properties dialog box, select the C Compiler node in the left panel. Note that the
PerformanceRelease configuration is selected in the Configuration drop-down list.

In the property sheet in the right panel, change the Development Mode from Release to
PerformanceRelease. Click OK.

You have created a new configuration that will compile the application with a different set of options.

Setting Source File Properties

When you set the project properties for your project, the relevant properties apply to all files in the project.
You can set some properties for a specific file.

1.
2.

Right-click the newmain. c source file and choose Properties.

Click the General node in the Categories panel and see that you can select a different compiler or other
tool to build this file. You can also select a checkbox to exclude the file from the build of the currently
selected project configuration.

Click the C compiler node and see that you can override the project compiler settings and other properties
for this file.

Cancel the Project Properties dialog box.

Setting the Main Project

When you right-click a project node in the Projects window, the IDE displays a pop-up menu of actions you
can perform on the selected project. If you have multiple projects open at the same time, the pop-up menu for
a project node implies you are operating on that project.

Most of the project-related actions on the menu bar and toolbar operate on the main project. The main
project node is displayed in bold text in the Projects window.

To change the main project in the IDE:

Right-click the desired project node and choose Set as Main Project. This project is now the main project
in the IDE and actions in the menu bar and toolbar refer to this project.

Building Your Project

To build your project:

1.

Right-click the project and choose Build. The project builds. The build output is shown in the Output
window.
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2. Switch the configuration from Debug to PerformanceRelease in the configuration drop-down list in the
main toolbar. Now the project will be built using the PerformanceRelease configuration.

3. Right-click the project and choose Build. The project builds. The build output is shown in the Output

window.

To build multiple configurations of the project at the same time, choose Run > Batch Build Main Project and
select the configurations you want to build in the Batch Build dialog box.

You can build, clean, or both clean and build the project by right-clicking the project and choosing actions
from the menu. The project also keeps object files and executables from different configurations separate, so
you do not have to worry about mixing files from multiple configurations.

Compiling a Single File
To compile a single source file:

= Right-click on the newmain. c file and choose Compile File. Only this file is compiled.

Note - Single file compilation is not supported for the project type C/C++/Fortran Project From Existing
Code.

Running a Project

The Arguments sample program prints command-line arguments. Before running the program, you'll set
some arguments in the current configuration. Then you'll run the program.

To create the Arguments_1 project, set some arguments, and run the project:

Choose File > New Project.

In the project wizard, expand the Samples category.

Select the C/C++ subcategory, then select the Arguments project. Click Next, then click Finish.
Right-click the Arguments_1 project node and choose Build. The project builds.

Right-click the Arguments_1 project node and choose Properties.

In the Project Properties dialog box, select the Run node.

NSk w

In the Run Command text field, type 1111 2222 3333 after the output path. Click OK.
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8. Choose Run > Run Main Project. The application builds and runs. Your arguments are displayed in an
external window.

Tip - The Run Monitor tab opens when you run the project and displays profiling tools for observing your
application's behavior. You can turn off the profiling tools in the Profile category in the Project Properties
dialog box.

Creating a Project From Existing Sources

With a C/C++/Fortran Project From Existing Sources, the IDE relies on your existing makefile for
instructions on how to compile and run your application.

1. Choose File > New Project.

2. Select the C/C++/Fortran category.

3. Select C/C++/Fortran Project From Existing Sources and click Next.
4

On the Select mode page of the New Project wizard, click the Browse button. In the Select Project Folder
dialog box, navigate to the directory where your source code is located. Click Select.
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= > New Project

Steps Select Mode

1. Choose Project Specify the folder that contains exsting sources;

g ?lele::t Maxle jhome/fredMyapp Browse...
Build Host: localhost E2

Tool Collaction: Default (OracleSolarisStudio (Oracle Solaris Studio Com... |2
Select Configuration Mode:

®) Autornatic (using Makefile)

() Custom

|Select Automatic to enable automatic configuration of project settings from
|an existing makefile or configure seript in the source folder, Select Custom if
ithera is no makefile or configure script in the source folder, or to view or
Echange project settings before the project is created.

[important:

\After the project is created, the Clean and Build actions specified in the
;e:-:isting makefile are run automatically. Compiled binaries in the project
ffolders will be overwritten, To disable this action, select Custorm mode and
ithen deselect Clean and Build after Finish.

< Back | Mext =  Finish | Cancel || Help

Use the default configuration mode, Automatic. Click Finish.

6. The projectis created and opened in the Projects window, and the IDE automatically runs the Clean and
Build sections specified in the existing Makefile. The project is also automatically configured for code
assistance.

The project is created and opened in the Projects window. You have created a project that is a thin wrapper
around existing code.

Building and Rebuilding Your Project
To build the project:

= Right-click the project node of the project and choose Build.

To rebuild the project:
= Right-click the project node of the project and choose Clean and Build.

Creating a Project From a Binary File

With a C/C++/Fortran project from a binary file, you can create a project from an existing binary file.

1. Choose File > New Project.

2. Select the C/C++/Fortran category.

3. Select C/C++/Fortran Project from Binary File and click Next.
4

On the Select Binary File page of the New Project wizard, click the Browse button. In the Select Binary File
dialog box, navigate to the binary file from which you want to create a project.

The root directory for the source files from which the binary was built is filled in automatically. By default,
only the source files from which the binary was built are included in the project. By default, dependencies
are included in the project. The shared libraries required by the project are automatically listed.
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1. Choose Project
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Stop Search

< Back Finish | Cancel || Help

5. Click Next.

6. On the Project Name and Location page, you can choose the name and location of the project. Click

Finish.

Creating an Oracle Database Project

You can create a project for an Oracle Database application. In order to do so, the Oracle Solaris Studio
installation you are using must include the optional Oracle Instant Client component.

1. Choose File > New Project.

2. Inthe New Project dialog box, select the C/C++/Fortran category and the C/C++ Database Application

project. Click Next.

3. On the Project Name and Location page, you can choose name and location of the project. Click Next.

4. On the Master table page, select jdbc:derby://localhost:1527/sample from the Database Connection
drop-down list. The IDE connects to the database. Select the master table for your project from the
Database Table drop-down list. Use the arrow keys between the Available Columns and Columns to
Include lists to select the table columns you want to include in your project.
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5.

[+ > New C/C++ Database Application

Steps Master Table

1. Choose Project

2. Project Name and Database Connection: jdbc:derby:/flocalhost:1527/sample [app on APP] E}
Location Database Table: MANUFACTURER B3]

3. Master Table
Available Columns Columns to Include

IMANUFACTURER_ID |

| = Back | MNext > i Finish ICEncaI‘l Help I

Click Finish.

Doing Remote Development

You can build, run, and debug projects on the local host (the system from which you started the IDE) or on a
remote host running a UNIX® operating system. Remote development lets you run the IDE locally in your
familiar desktop environment, while using the computing power and development tools on a remote server
to build your projects.

You can configure remote development hosts in the Build Tools tab of the Options dialog box. To add a
remote host:

1
2
3.
4

Choose Tools > Options, and click the C/C++ category.
In the Build Tools tab of the Options dialog box, click Edit.
In the Build Hosts Manager dialog box, click Add.

On the Select Host page in the New Remote Build Host wizard, type the system name of the host in the
Hostname field or double-click an available host in the Network neighborhood list to select it. Click Next.
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5. On the Setup Host page, type your login name in the Login field and click Next.

Steps

1. Select Host
2. Setup Host
3. Summary

6. The wizard prompts you for a password, connects to the host, and displays a Summary page. Click Finish.

7. After the host is added to the Build Hosts list in the Build Hosts Manager dialog box, click OK.
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8. You can set properties that specify how the IDE uses the remote host in the Services window. Expand the
C/C++ Build Hosts node, right-click the remote host, and choose Properties. Set the desired properties in
the Host Properties dialog box.

9. To set the remote host as the default build host, right-click the host in the C/C++ Build Hosts node in the
Services window, and choose Set as Default.

To develop a project on a remote host, the project must be on a shared filesystem that is visible on both the
local host and the remote host. Typically such a filesystem is shared using NFS or Samba. You can define the
mapping between local and remote paths to project source files when you define the remote host.

When you create a project, the default build host is selected as the build host for the project. You can change
the build host for the project on the Build panel of the Project Properties dialog box. You can also specify the
build host when you are debugging an executable or a core file.

To work on a project that resides on a remote host on your local host, choose File > Open Remote C/C++
Project.

Packaging an Application

You can package a completed application as a tar file, zip file, Solaris SVR4 package, RPM, or Debian package.
Right-click the Arguments_1 project and choose Properties.

In the Project Properties dialog box, select the Packaging node.

Select the Solaris SVR4 package type from the drop-down list.

Change the output path if you want to use a different destination directory or filename for the package.

NI

Click the Packaging Files browse button. In the Packaging Files dialog box (for an SVR4 package), modify
the package parameters on the Info tab as needed.
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v
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6. For all package types, add files to the package using the buttons on the Files tab. For each file, you can
specify the path you want it to have in the package in the File or Directory Path in Package column of the
Files list. Click OK when your Files list is complete.
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Top Directory: argumentsl

Files:
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Default File Properties (used when adding files or directories):
rwx rwx rwx Owner and Group
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Exe Files: (V| [ ] E’]DE’]F Group:  bin

[ oK MCancelH Help J

7. Turn off verbose mode if you wish by clicking the checkbox.
8. Click OK.
9. To build your package, right-click the project and choose More Build Commands > Build Package.

Editing Source Files

The Oracle Solaris Studio IDE provides advanced editing and code assistance features to help you in viewing
and modifying your source code. To explore these features, use the Quote project:

1. Choose File > New Project.

2. Inthe project wizard, expand the Samples category and the C/C++ subcategory, then select the Quote
project. Click Next, then click Finish.

Setting the Formatting Style

You can use the Options dialog box to configure default formatting style for your projects.
Choose Tools > Options.

Click Editor in the top pane of the dialog box.

Click the Formatting tab.

Select the language for which you want to set formatting style from the Language drop-down list.

A

Select the style you want to set from the Style drop-down list.
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e 7 >l |
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Export | | Import
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6. Modify the style properties as desired.

Folding Blocks of Code in Cand C++ Files

For some types of files, you can use the code folding feature to collapse blocks of code so that only the first line

of the block appears in the Source Editor.

1. IntheQuote_1 application project, open the Source Files folder, then double-click the cpu. cc file to open

it in the Source Editor.

2. Click the collapse icon (small box with minus sign) in the left margin to fold the code of one of the

methods.

3. Mouse over the {...} symbol to the right of the folded block to display the code in the block.

Using Semantic Highlighting

You can set an option so that when you click on a class, function, variable, or macro, all occurrences of that
class, function, variable, or macro in the current file are highlighted.

Choose Tools > Options.

Click the Highlighting tab.

Click OK.

N Sk w D=
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Click C/C++ in the top pane of the dialog box.

Make sure that all of the check boxes contain checkmarks.

Click on an occurrence of the Customer class.

In the customer. cc file of the Quote 1 project, notice that the function names are highlighted in bold.

All of the occurrences of the Customer class in the file are highlighted with a yellow background.
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Start Page * |

1|
3z
33|
14/

35

37|
38
334
a0
41!
42
43
44/
a5
4E |

47
48
48
50

51
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o
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OF LIABILITY, WHETHER

[ ¥ BUBSI[ITUIE ¢
* TNTERRUPTICH

EVE ED AND OIT ANTY
LIABILITY, OR T T
WAY OUT OF THE USE OF

OF SUCH DAMAGE.

finclude "cuscomsr k"

l:ust:mﬁr: :Customer (const string initName, int initDiscount) :

nams | iniciames) ,
discount (initDiscounc) |

int Customer::GetDiscount () const |
return discount:
t

string Customer::GetWame () const {
ESTUEnR nams:

+

cELreami operator << |ostreamé output, const Customeréd customsr) |
output << customer.name= << " has discount " << customer.discount << ‘%'
CELUrn ourput:

9. Inthe customer.h file, notice that class fields are highlighted in bold.

| Start Pageﬂ@customenc: x

B E-E- Q&R Pe% AU 0E Bak

25
28
27
28
28
ao
a1
32
13
34
35
36
a1
3B
a8

ESRGEEEBES

g &

51
52
53

=

INTERREUPTICON) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
NCE OF OTHERWISE)

T (INCLUD EGLIG
THIS SOFTWARE,

ACT, STRICT LIABILITY, OR
NG IN ANY WAY OUT OF THE
POSSIBILITY OF SUCH DAMAGE.

N IF ADVISED OF

flifndef customer H
fidefine _customer_H

fiincluds <io=cresam:
using namespace sStd;

class Customer |
public:
Cnstomer (conat scring initName, int initDiscount) ;
artring GetWame |} const;
int GetDisceunt (| const;

privace:
String name:

int diacount;

friend cstreamsé operater<< (ostreamé, const Customerk);
|

#endlt * _customer_H *
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Using Code Completion

The IDE has a dynamic C and C++ code completion feature that enables you to type one or more characters
and then see a list of possible classes, methods, variables, and so on that can be used to complete the
expression.

1. Openthe quote. cc filein the Quote_1 project.

2. Onthe first blank line of the quote. cc file, type a capital C and press Ctrl-Space. The code completion box
displays a short list that includes the Cpu and Customer classes. A documentation window also opens and

displays the message No documentation found because the project source code does not include
documentation.

3. Expand the code completion list by pressing Ctrl-Space again.

ot Page = il L] T":-'IPL"I"-'PF' w| B embomer by = ?i‘."m = A b|jw=iD
= e - ey #F4% a2 o8 48 —
L ] |
g
19
11
i -
41
14
o No documentabion found
13
17
12
19
=0
=1
=3
24
25
2
=7
=8
%
& c
1§ Cpu -
1580 Customer
1|5 customers 118T<Customer >
M|
% e
Outpt [ L
.I.L # t acl Al udg—
L
L
‘e
L/ - (1] amesntsl
W
i
-
&
"

4. Selectastandard library function such as calloc() from the list and the documentation window displays

the man page for the function if the man page is accessible to the IDE.

5. Select the Customer class and press Enter.

6. Complete the new instance of the Customer class by typing andrew; . On the next line, type the letter a and

press Ctrl-Space. The code completion box displays a list of choices starting with the letter a, such as
method arguments, class fields, and global names, that are accessible from the current context.
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e 4
12 |l andrew
13 g Ll R
M| 8 ansere (E
“l||:5- altzone
Outeud| & anss L
i W atdliconst char®)
W abore ()
Ll.r 1@ abeiine)
| 1@ access coast char*, int
:u' ACCE (conmt char*)
| J & acosidouble
4 @ acost(float
| { @ acosh(double
W acosht (float
E& acoshl (long doubls
W acoalilong double

@ aaer ima ir imawai s rimevalsg

Customer

Ry ———

igang/argument sl dist /Delbug/Craclefelar iafru

Sparc/packags/argussnt sl

rackaging

= i ]

7. Double-click the andrew option to accept it and type a period after it. You are automatically provided with
alist of the public methods and fields of the Customer class.

Io Customer andrew;

@ andrev.

3120 #inc Q) discount

13 #inc|@F name string
34 #inc| @ GerDiscount

" O GetName atring

8. Delete the code you have added.

Using Static Code Error Checking

When you type code in a source or header file in the Source Editor, the editor performs static code error

checking as you type and displays an erroricon @ in the left margin when it detects an error.

1. Inthequote.cc file of the Quote_1 project, type #include "m on line 40 and notice the error icon that

appears in the margin.

30

31 ] #include <iocstreams
3z #include <list:
33 H#include <cstdlib:

34
35 #include "customer.h"
36 H#include "svstem.h"

37 #include "disk.h"
38 #includs "cpu.h"
39 H#include "memory.h'"

@ - #include "m?

2. Backspace over the second quotation mark and complete the statement by typing odule.h”, and notice
that error icon disappears as soon as the statement references an existing header file.

3. Delete the statement you have added.
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Adding Source Code Documentation

You can add comments to your code to generate documentation for your functions, classes, and methods.
The IDE recognizes comments that use Doxygen syntax and automatically generates documentation. It can
also automatically generate a comment block to document the function below the comment.

1. Inthe quote. cc file, place your cursor on the line above the line int readNumberOf (const char* item,
int min, int max) {.

2. Typeaslash and two asterisks and press Enter The editor inserts a Doxygen-formatted comment for the
readNumberOf class.

72

1 return -1

4| - 3

75

TE

7 pPAar am

T PALam

79 param T

Bo returs

Bl

gz | int readilfumberdf (const char* item, int min, int max] {
B3 cout << UF Br numbet £ " << item << " (" << min << " i "o max << "l "

B

3. Add some descriptive text to each of the @param lines and save the file.

4. Click the readNumberOf class to highlight it in yellow, and click one of the occurrences marks on the righ
to jump to a location where the class is used.

5]
T8
m”
78
78 I
ao ireturn

a1l -

8z int readifmmber0f (const char* ictem, int min, int max) |

a3 cout £< "Enter numbet £ " << dtem €< " (" ££ min €€ " <= W £= " ££ max €< " Lo
a4

a5 aCELng 85

5. Click the readNumberOf class in the line you jumped to, and press Ctrl-Shift-Space to show the
documentation you just added for the parameters.

161
1E2 int amount = readiumberOf("CPUs", 1, 10);:
163 > EF
184 Cpu HyCpuityps, |
1E5 p t
1EE MySystem, AddNody T arame “"F_
e itern Type of item
1€8 cesponse = readC] '
i o G Parameter:
: min Least amount of iterm customer can order
170 swicch (response
l.'.-‘il: case i _ Parameter:
i:; EETUER S max Maximum amount of item customer can ordar
174 case 'R': Returns:
175 typs = D
17€ break;
177
178 case
179 L'I-.E: Eq.ulll' i

6. Click anywhere else in the file to close the documentation window, and click on the readNumberOf class
again.

7. Choose Source > Show documentation to open the documentation window for the class again.
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Using Code Templates

The Source Editor has a set of customizable code templates for common snippets of C, C++, and Fortran
code. You can generate the full code snippet by typing its abbreviation and pressing the Tab key. For example,
in the quote. cc file of the Quote_1 project:

Type uns followed by a tab and uns expands to unsigned.
Type iff followed by a tab and 1ff expands to if (exp) {}.
Type ifs followed by a tab and ifs expands to if (exp) {} else {}.

Type fori followed by a tab and fori expands to for (int i=0; i< size; i++) { Object size =
array[i]; }.

To see all of the available code templates, modify them, create your own code templates, or select a different
key to expanded the templates:

1.
2.
3.

Choose Tools > Options.
In the Options dialog box, select C/C++, and click the Code Templates tab.

Select alanguage from the Language drop-down list.

n € options _
@ oy ") Al
" & @ 55 ¢ 6
Genearal Editor Fonts & Colors Kaymap CiC++ Miscellaneous

| General | Formatting | Code Cur‘npletianL Code Templates | HintsJ Mark Dccurrences | Macros |

Language: C++ u

Templates:

LAbbreviation 1Expanded Text iDescript':un ] ;

EX |ExEC SqL ] e
[ Remove

br break D

ca |case e

Expanded Text ' Description |

hool

Expand Template on:  Tab

s ] On Template Expansion: Reformat Text | =

Export | | Import | oK I[Cancel“ ﬂelp‘

Using Pair Completion

When you edit your C and C++ source file, the Source Editor does “smart” matching of pair characters such
as brackets, parentheses, and quotation marks. When you type one of these characters, the Source Editor
automatically inserts the closing character.

1.

In the Quote_1 project, placed the cursor after the { on line 116 of the module. cc file and press Return to
open a new line.
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2. Type enum state { and press Return. The closing curly bracket and the semi-colon are added

automatically and the cursor is placed between the brackets.

3. Type invalid=0, success=1to complete the enumeration.

4. On theline after the closing } ; of the enumeration, type if (. The closing parenthesis is added
automatically and the cursor is placed between the parentheses.

5. Type v==null. Then type i and newline after the right parenthesis. The closing bracket is added

automatically.

6. Delete the code you have added.

Navigating Source Files

The IDE provides advanced navigation features for viewing your source code. To explore these features,

continue using the Quote_1 project.

Using the Classes Window

The Classes window lets you see all of the classes in your project, and the members and fields for each class.

1. Click the Classes tab to display the Classes window.
2. Expand the Quote_1node. All classes in the project are listed.

3. Expand the Customer class.

b Arguments_1
b & CppApplication_1
b [E DbApplication_1
< (J Quote_1
P §3 unnamed
b & Cpu
¥ &y Customer
&3 discount
&1 name

O GetDiscount() const

© GetName() const

i operator <<(ostreamé& , const Customeré&: )
& Disk
€5 Memory
& Module
Ky System
@ mainlint argc, char** argv)
A& operator <<(ostreamé&: , const Customer&: )
4, operator <<(ostreamé& , const Module&: )
A operator <<(ostream& , const System&: )

v vy Vv

4. Double-click on the name variable to open the customer . h header file.

Using the Navigator Window

Projects iFiIes Classes 1 x| Services

¢ Customer(const string initName, int initDiscount)

The Navigator window provides a compact view of the file that is currently selected, and simplifies navigation

between different parts of the file. If the Navigator window is not open, choose Window > Navigating >

Navigator to open it.
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1. Click anywhere in the quote. cc file in the Editor. window.

2. A compact view of the file is displayed in the Navigator window. Click the node a the top of the window to
expand the view.

customers

fetchCustomersList()

getDiscountFor{string name)

outCustomersList()

readChar{const char* prompt, char defaultAnswer)
readNumberOf(const char* item, int min, int max)
cpu.h

cstdlib

custormer.h

disk.h

iostream

list

©00O0BE

main(int argc, char** argv)
memory.h
system.h

HECEBEBHE8H

3. To navigate to an element of the file, double-click the element in the Navigator window and the cursor in
the Editor window moves to that element.

4. Right-click in the Navigator window to see options for sorting the elements in the window, grouping the
items, or filtering.

5. To see what the icons in the Navigator window represent, open the IDE online help by choosing Help >
Help Contents. In the Help browser, click the Search tab and type navigator icons in the Find field.

Finding Class, Method, and Field Usages

You can use the Usages window to show you everywhere a class (structure), function, variable, macro, or file
is used in your project's source code.

1. Inthe customer.cc file, right-click the Customer class on line 42, and choose Find Usages.
2. Inthe Find Usages dialog box, click Find.

3. The Usages window opens and displays all of the usages of the Customer class in the source files of the
project.

-

@ = {8 custemer.ce

EE Customer:Customer(const string initMame, int initDiscaunt] :

[EE] int Customer: GatDiscount!) canst {

== ostreamé operater < <(ostreamé sutput, const Custemers custemer) {

4 = ¥ quate.cc

6 list= Customers= customers;
forllist< Customer=iterator it = customers begint); it 1= custorners.endl): +-+itl {
customers.push_back{ Custemer|"jchn®, 10));
customers.push_back{Custemer| ke, o))
customers. push_back{Customer|Feter, 13]);
customers.push_back{Custemer{"~nn", 111k [
customers.push_back{CustomerTom’, 9)1:

L ferlist=Customer=:iterator it = customers.benin() it = customers.endll; ++itl { X
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Using the Call Graph

The Call Graph window displays two views of the calling relationships between functions in the classes. A tree
view shows the functions called from a selected function, or the functions that call that function. A graphical
view shows the calling relationships using arrows between the called and calling functions.

1. Inthe quote.cc file, right-click on the main function and choose Show Call Graph.

2. The Call Graph window opens and displays a tree view and a graphical view of all of the functions called
from the main function.

Gk, end|

i, fatchCustomersList
@ outCustomersList
@, getline

b
L
k
b
b Gk getDuscountFar
3
b
b
k

#EE e §

Gy readChar i
B readriumberof

(O AddModule

s GatSupportMetric

If you do not see all of the functions shown in the screen shot, click the third button on the left side of the
Call Graph window to show who is called from this function.

3. Expand the end1 node to display the functions called by that function. Notice that the graph is updated to
add the functions called by end1.

4. Select the end1 node and click the second button on the left side of the window to focus on the end1l
function, then click the fourth button to view all of the functions that call the end1 function.

S T — s aape.

3 E’D main |wll:u|=wlwﬂwt| [llldﬂllml
b %4 operator <<

b A operator ==

b %@ outCustomersList

b @ readchar

b 0 readnurmberof ﬂ

2@ 9e §

b @ main
® b %4 operstor <<
b 34 oparator <<
= . "0 outCustamersiist
b @ main
* %W readChar
i b %@ main ﬂ
- 50 readtumbercf
3 u main
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Using Hyperlinks

Hyperlink navigation lets you jump from the invocation of a class, method, variable, or constant to its
declaration, and from its declaration to its definition. Hyperlinks also let you jump from a method that is
overridden to the method that overrides it, and the reverse.

1. Inthe cpu.cc file of the Quote_1 project, mouse over line 37 while pressing Ctrl. The
ComputeSupportMetric function is highlighted and an annotation displays information about the
function.

L SmrtPage*I'i‘:lqunte.cc "‘l'ii‘,cuﬂomer.cc "Lﬁ'i]cpu.:( x4

BE-d SR Fee 9 0@ LLRH

28

ki)

<1 |

1z

3|  Winclude Method vold ComputeSupportMetric()

4 From class Cpu

15 Cpu::Cpuiinz cype 5 - ; | + Int unica 1
1612 Bodule (=i, ) CtitAletclck Navigates To Overndden Methods|

7 CompukteSuppoctBetric () ;7

;'

2. Click the hyperlink and the editor jumps to the definition of the function.

34
35 Cpu::Cpu{int typs MEDIUM */, int architecture /* JPTERCH */, int units
36 =) Module ("CPU", "generic”, type, architecture, units) |

37 ComputeSupportMetrici) ;

38 }

35

40 |

41 I i ie i} P mo 1 omp 1 it i 1 1 numb

10 * target use |("categorv™) ~PU architecture twpe” is not considered in
43 heuri

a4 | -
45
@[] void Cpu::ComputeSupportMetric() |
47 int metric = 100 * GetUnits():
48

3. Mouse over the definition while pressing Ctrl, and click the hyperlink. The editor jumps to the declaration
of the function in the cpu. h header file.

4. Click the leftarrow in the editor tool bar and the editor jumps back to the definition in cpu. cc.

5. Hover the mouse cursor over the green circle @ in the left margin and see the annotation that indicates
that this method overrides another method.

17 ComputeSupportBetreic ||
£
k]
0=l
aL
4%
43
a4
45
B woid Cpu::ComputeSupportMetriei) |
4T int metrle = 100 * GecUnita():

Overrides Modu'a::ComputeSupportMatric|

6. Click the green circle to go to the overridden method and the editor jumps to the module. h header file,
which shows a gray circle in the margin to indicate the method is overridden.
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7. Click the gray circle and the editor displays a list of methods that override this method.

BS protected:

=] wirtual vold ComputeSupportMetric() = 0: metE 1 8 defined srived
71 Is Overridden

i "-' Cpus:ComputeSupportMetric

73 iy Disk::ComputeSupportMetric

by f-L,.; Memory::ComputeSupportMetnc ADSFRERS . '

75| | —ae " 1

[ inc CACEQOLY;

i int nunita:

8. Click the Cpu: : ComputerSupportMetric item and the editor jumps back to the declaration of the method

in the cpu. h header file.

Using the Include Hierarchy

The Include Hierarchy window lets you inspect all header and source files that are directly or indirectly

included in a source file, or all source and header files that directly or indirectly include a header file.

1. IntheQuote_1 project, open the module. cc file in the Source Editor.

2. Right-click on the #include "module.h" line in the file and choose Navigate > View Includes Hierarchy.

3. Bydefault, the Hierarchy window displays a plain list of files that directly include the header file. Click the

right-most button at the bottom of the window to change the display to a tree view. Click the second
button from the right to change the display to all files that include or are included. Expand the nodes in

the tree view to see all of the source files that include the header file.

module.h - Hierarchy * X
» Bl module.h
v 93 cpuh
! " cpu.cc
i guote.cc
| = 95 disk h
! %3 disk.cc
58] quote.cc
<+ %5 memory.h
%) memory.cc
5% quote.cc
%5 module.cc
v %1 system.h
55 quote.cc
R o) system.cc

geinpouw ¢ ]

(AypieieiH -

Using the Type Hierarchy

The Type Hierarchy window lets you inspect all subtypes or supertypes of a class.

1. IntheQuote_1 project, open the module.h file.
2. Right-click on the declaration of the Module class and choose Navigate > View Type Hierarchy.
3. The Hierarchy window displays all of the subtypes of the Module class.
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Module - Hierarchy o x|
» % Module | - §
& Cpu =

&y Disk &

& Memory =

o

a

3

Running Memory Access Checking on Your Project

You can use the Memory Analysis Tool to find memory access errors in your project. The tool allows you to
find these errors easily by pointing out exactly where the each error occurs in your source code.

The Memory Analysis tool catches and reports memory access errors dynamically during program execution,
so ifa portion of your code is not executed at run time, errors in that portion are not reported.

1. Ifyouhave notalready done so, download the sample applications zip file from the Oracle Solaris Studio
12.3 Sample Applications web page at http://www.oracle.com/
technetwork/server-storage/solarisstudio/downloads/solaris-studio-samples-1408618.html,
and unzip the file in a location of your choice. The memorychecks application is located in the
CodeAnalyzer subdirectory of the SolarisStudioSampleApplications directory.

2. Create a project from existing sources using the memorychecks application.

3. Right-click the project and choose Properties. In the Project Properties dialog box, select the Run node,
and type Customer.db after the output path in the Run Command. Click OK.

4. Run the project.
5. Now build the project with instrumentation for memory analysis.

a. Make sure that your memorychecks project is set as the main project.

b. Click the down arrow next to the Profile Project button &} and select Profile Project to find
Memory Access Errors from the drop-down list.

c. Inthe Select Analysis Type dialog box, select All Memory Access Errors from the drop-down list.

] i select Analysis Type 3
Collect Data For:  All Memory Access Errors v
Overhead: Leak Detection and API Check

All Memary Ac

The Overhead field displays High or Moderate to indicate the load that will be placed on the system.
The performance of other programs running on your system might be affected when the overhead is
high, which is the case when you are detecting both data races and deadlocks.

d. Click Start.

6. The Run Memory Profile dialog box opens to let you know that your binary will be instrumented. Click
OK.

7. The project is built and instrumented. The application starts running and the Memory Analysis window
opens. When your project run is complete, the Memory Analysis window lists the memory access error
types found in your project. The number of errors of each type is shown in parentheses after the error

type.

Oracle Solaris Studio 12.3 IDE Quick Start Tutorial 27


http://www.oracle.com/technetwork/server-storage/solarisstudio/downloads/solaris-studio-samples-1408618.html
http://www.oracle.com/technetwork/server-storage/solarisstudio/downloads/solaris-studio-samples-1408618.html

Projects | Files | Classes Services | M., 40
Analysis complete, see results below
= #f Bug type

Mermory Leak (4)

ABW (Beyond Array Bounds Write) (2)

ABR (Beyond Array Bounds Read) (1)
UMR (Uninitialized Memory Read) (1

. When you click on an error type, the errors of that type are displayed in the Memory Analysis Tool
window.

Output i Memory Analysis Tool 7 x|
|@E = & memtest.c el .53" Stack
- : = e T ® main st memtest.c:a
' MemoryLeak at line 40 cpl = [char *)mall; LAY H L Fi
start in memtest 0«10k

@ MemoryLeak at line 48 cpl = (char *)mallocl{ARRAY_SIZE];
lz]l @ MemoryLeak at line 63 cpl = (char *)malloclARRAY_SIZE]:
@ MemoryLeak at line 67 cpl = (char *imallocl ARRAY_SIZE];

By default, the errors are grouped by the source file in which they were found. When you click on an error,
the call stack for that error is displayed. Double-click a function call in the stack to display the associated
lines in the source file.

Creating Breakpoints

You can create and manipulate breakpoints in your code at any time.

Creating and Removing a Line Breakpoint

1. IntheQuote_1 project, open the quote. cc file.

2. Setaline breakpoint by clicking in the left margin of the Editor window next to line 171 (response =

readChar("Enter disk module type: (S for single disks, R for RAID; Q - exit)", ’S’);). The

line is highlighted in red to indicate that the breakpoint is set.

|5tart nga K_'E‘;qunts.:: K|

RRE-8- aes@ e au en Sl
188

187 Cpu MyCpuitype, 0, amount):

1&8

L&s HySystem. AddModule | ENyCpu) 2

170

=] regponse = readChar ("Encer disk module cype: |5 for single disks,
172

173 avitch (reaponse) |

174 case 'Q

175 Eetuen 2;

176

3. You could remove the breakpoint by clicking on the icon in the left margin.

4. Choose Window > Debugging > Breakpoints to open the Breakpoints window. Your line breakpoint is

listed in the window.
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| Braakpoints w5
0 | Name J Context ];E
M & guote.ccil17l L

Creating a Function Breakpoint

1. Choose Debug > New Breakpoint (Ctrl+Shift+{8) to open the New Breakpoint dialog box.
2. Inthe Breakpoint Type drop-down list, set the type to Function.
3. Type the function name Customer: :GetDiscount in the Function text field. Click OK.

(¥ & New Breakpoint X |

Breakpoint Type: Function r I
Settings

Function: | Customer::GetDiscount

(®) Unigue Function With this Name

() All Member Functions With this Name
() On Return

Filters
Condition:
Count Limit: —EJ Current Count:
while In:

Thread:

Actions

Action: Stop i - l

= II]iE:

Cancel

4. Your function breakpoint is set and is added to the list in the Breakpoints window.

| Breakpoints. wx
E | Mames | Context |E’E
Bl @ guote.cc:a7l 5

¥l @ customer:GetDiscount

Debugging a Project

When you start a debugging session, the IDE starts the debugger in the project's associated tool collection (by
default, the dbx debugger), then runs the application inside the debugger. The IDE automatically opens
debugger windows and prints debugger output to the Debugger Console window.

Starting a Debugging Session

1. Starta debugging session for the Quote_1 project by right-clicking the project node and choosing Debug.
The debugger starts and the application runs, and the Variables and Debugger Console windows open.
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|Vinahks lDlh.quu Consola ¥ x| Output
Feading Libm,so.Z |&
feading libc.so.l

idbx) cd 7/ home/ar3440E/Sol5tudioFrojects/ Quote 1"

idbx) runargs

() INCErcepr =S80 -unbandled, -unsxpected

idibe) HEH dbwers run_pty /dew/peajE

idibot) HEW dbxenv rec_error_log file name /dewvi/noull

idx) atop at "/ home/ar3d40E/SclStudioPro]ecta/ Duote I/ quote.cem: LTl

(dbx] stop in Customer::Gecliscount

idbxl run

Pupping: quote 1

iprocess 1d EEI)

Peading libc_psr.so.l

L4

2. Open the Sessions window by choosing Window > Debugging > Sessions. The debugging session is
shown in this window.

wariables L Breakpoints Debugger Consale Sessions 7 xl Output
Name | Process o | Process state | Host |

‘ B quote_1 6336 Running locabhost

Inspecting the State of the Application

1. TheQuote_1 application prompts you for input in the Output window.
2. Enter a customer name after the Enter customer name: prompt.

3. Theapplication stops at the function breakpoint you set earlier. The Breakpoints window lists the two
breakpoints you set earlier. The green program counter arrow appears on top of the breakpoint icon of the

function breakpoint.
Wariables Jm .:.-xl Debugger Consale I Sessions | Qutput
& | Name | context |
B @ quote.cec:171 [6336] quete_1
¥ & customer:GetDiscount{lconst [6326] quate_1

4. Inthe customer.cc file, the green program counter arrow appears on top of the breakpoint icon on the
first line of the GetDiscount function.

30

31 ffinclude "customer.h"

32

33 Customer::Custemer (const string initName, int initDiscount)

34 name ( initName) ,

35 discount (initDiscount)

36 1

2

38 int Customer::GetDiscount () constc |
E}LT‘ return discount;

40 }

41

42 string Customsr::Getlame () const |
QET Eeturn name:

44 }

45

5. Open the Call Stack window. The call stack shows three frames.
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Projects ] Files Classes i Services | Memor... | C.. WX

l Name J@
CJCustomer::GetDiscount(this = 0x4¢908) ;:_‘
L]__unnamed_9QlkBsgBcOGrY::getDiscountFor(name = CLA!

[Imainlargc = 1, argv = 0xffbfed14)

6. Click the Variables window and note that one variable is displayed. Click the nodes to expand the
structure.

lm £l ui Breskpoints | Debugger Cansole | Sessians | Dutput |
| & | Name ] Vakue '.E’[
&2 =t Lt

& = g this Oxdc 0B u

= Ename i bra u

b @__data_ =

dinpas 42949672950 Ll

W __nullref struct __rwstd:;__null_strng_ref_rep<char.std:char_trags<char=.st... | |

E discount 11 U

L

7. Click the Continue button. The GetDiscount function is executed, printing the customer discount to the
Output window. Then you are prompted for input.

8. Enter the input in response to the prompts. The program stops at the next breakpoint, the line breakpoint
you set earlier. Click the Variables window and note the long list of local variables.

|\.|'nmaﬂel = xi ﬁreakpnan‘ls Deﬁugger Consale Sessions | Output

& | Name | walue =Y
r@] Ent |_,'P.'

| & b o argy Duffbfedld =)

i MyDisk %)

Pupe o lJ

@ MyCpu J

¥ & customeridama O30 “Ann®) 4284086720500 s5truct __rwst null_string_ref_rep. . 4§

B & MySystemn 12 1cdfe |

@ rESpONSE W L4

S MyMemory %% )
S rac 1 S 1L

9. Lookat the Call Stack window and note that there is only one frame in the stack.

10. Click Continue @ and continue entering input in response to the prompts in the Output window until
the program is completed. When you enter the last input to the program, your debug session ends. To end
the debug session before the execution of the program was complete, you could right-click the session in
the Sessions window, and choose Finish.

Debugging at the Machine-Instruction Level

The debugger provides windows that let you debug your project at the machine-instruction level.

1. Right-click the Quote_1 project and choose Debug.

2. Inthe Output window, type a customer name in response to the prompt.
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3. When the program pauses at the breakpoint on the GetDiscount function, choose Window > Debugging

> Disassembly to open the Disassembly window as in the Editor window. The green program counter
arrow appears on top of the breakpoint icon at the instruction on which the program is paused.

| Start Paue*lﬂqume.:c "‘lEcustnmeu:c "‘IEl Disaszembly "i wolita ) el
- Bl - a3 =
] nam= | tnithlar :
15 dismcount (1 Discount) | I
AxOinlacdl Cuse o=t H s %sp, -0, wsp
Ox000Lacdc:  Customer+0x0004 st vil, [vEp + €8]
AxOinLac 50 Cus koo r+ O BO08 s ¥il, [%fp + 72] '
Ox000Lacsd: Customer+0x000c; st %iZ, [%Ep + 7€)
Ox000Llacss: Customer+00010: 1d [VEp + &B], %10
Ox000Lacic: Customer+0x0014: ld [¥Ep + 721, %1l
Ox000Lac60:  Customer+0x0016: or V10, g0, oo
Ox000Lactd: Customer+0x001lc: call basic_string [PLT]
Ax0i0lactl Cons i omee v+ O @030 or ¥11, %gl, %ol
Ox000Lachc:  Customer+0x0024: 14 [¥Ep + 7€), %1l
AxOinlacTh Cust ome r+ @028 14 [%€p + EB), 1O
Bx000LanTd Customer+0x0020; ba Customer+Hladl
Ox0iBlacTh Cons it ome r+ e @030 oL ¥1li, [W10 + 4]
Ox000LacTe:  Customer+0x0034: 1d [¥E£p + 681, %10
Ox000lachld: Costomer+0xB03I6: call basic string [FLT]
OO0 Lacid;: Customer+0x003c: - %10, 0, %20
Ox000lachli: Costomer+Ox@040: call ex rethrow g [PFLT]
Bx000Lavfc:  Customer+0x00dd: o
Ox000Lavd0: Custemer+0x0048: ret
Bx000Lacdd: Customer+OxB0do: restore
23 1E 3
4 17
25 ia int Castomsr::Getbiscount{) consc |
aE g ceturn discount
b Ax0inlacall C=tbimcount t CEAES S%up, —104, %mp
=8 Ox000Llacac: GetDiscount+0x0004; st vid, [%fp + €8]
o Oxd00iachd: GetDiscount+0x0008: 14 [¥&p + EB], %10
k) Bx000Lachd: GetDiscount+0wliog; ld [%10 + 41, %10
31 Ax0i0lachd Gethiscownt +0x0BL10 L1 %10, [vEp — 4]
iz Ox000Lackhe: GetDiscount+0x0014: 1d [¥&p — 4}, %10
33 Ax000Lacch Gethiscownt+0wiLs ar W10, %g0, %i0 L
Address M File: customer.co

Choose Window > Debugging > Registers to open the Registers window, which displays the contents of
the registers.

Variables | Breakpoints | Debugger Cansole | sessions J Registers ¥ %[ Output |
Name J_Wlun |
g0-gl O0x00000000 O0x00000000 Ox00000000 Ox001032548 —i
go-gd 000000000 0x00000000 Dx00300000 D:00030000

g1-gs 0x00000000 0x00000000 0x00000000 0x00000000

aé-g? 0x00000000 0x00000000 Dx00000000 OxE££382a00

al-ol 0x00000000 0x00000000 Dx00DDDO00 Qx0O000000L

aZ-o03 OxD0000000 Ox00000001 Dx00000000 Ox00000000

ad-of Ox00000000 0x00000000 0x00000000 0x000000E8=

oE=07 Ox00000000 Oxfibfeail Dx00D0D000 OxfflSeshd

10-11 0x00000000 Dx0004cS08 000000000 Ox0004c8508

12-13 0x00000000 0x00000000 0x00000000 Dx00000000

14=15 OxD0D00000 Ox0004ch42 Dx00000000 Ox0000000L

1E-1% OxO0000000 Ox£43£31718 0x00000000 Ox000000Z0 vl

Choose Window > Debugging > Memory to open the Memory window, which displays the contents of
memory currently used by your project At the bottom of the window, you can specify a memory address
to browse, change the length of the memory browse, or change the format for memory information.

wariables | Breakpoints l Debugger Cansale l Sessions | Mernory ¥ xi Registers I output

Qx00012LI0: main H 0x9de3bas000000000 0xE02 7404400000000 OxEIZ7404000000000 0xI10000LZ00000000 _-"

OxD0012130: main+s0x0010: Dxal 1420000000000 0xZ3I00007000000000 OxaZ L4£00000000000 0xS0L4000000000000

Ow00012140: main+0x00Z01: Dx200050c000000000 0xS2Z144900000000000 O 100005000000000 Oxa0dl4ZIb300000000

0ux00018150: waintDx0030: Dx400050e200000000 0x52 14000000000000 Owxl 100005800000000 Oxadidl 300000000

Ox0001S160:  waine0x0040: Dx400050be 00000000 0x%3 14000000000000 CxTLELd2 000000000 Ox L00000000000000

Qx00012170:  main+0x0050: DxallO1£££00000000 Ox=02ThE£B00000000 CxalO7eE£300000000 Dx400050=400000000

0x00012160: wain+Dx00ED: 0x9014000000000000 0x400ThEL400000000 OxaZ07RLLI00000000 0xS0L4000000000000

Ox00012150: main+0x0070: Dx400050=000000000 OxS2 14400000000000 OxTLELLoc400000000 Ox l0OO000000D00000

Qu000181a0: main+0x0080: 0xZ LO000BZ00000000 Oxa01420B000000000 Ox2I0000TO00000000 Oxali4£01400000000

0x0D01E1b0: mwainsDx0050: 0x9014000000000000 0x52 14400000000000 Ox400050aZ00000000 Dx LODODD0IODO0D00

Ox000151c0:  wain+OxO0a0: 02 10000b00000000 Oxa0142 11000000000 Cxal07kEf400000000 0xS014000000000000

OO0 MI AN - e § e (1R - OxE% 1430000000000y 400007 £ 10000000 Oy 1AAOAANAANMANANT_Oyx ™ SOOOTH S 000000 k!
Address main| Hungth 20 Format Hexadecimal (2 bytes)
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Debugging a Running Program by Attaching to It

If you want to debug a program that is already running, you can attach the debugger to the appropriate

process.
1. Choose File > New Project.
2. Inthe New Project wizard, expand the Samples node and select the C/C++ category.
3. Select the Freeway Simulator project. Click Next and then click Finish.
4. Right-click the Freeway_1 project you created and choose Run. The project builds and the Freeway
application starts. In the Freeway GUI window, choose Actions > Start.
5. IntheIDE, choose Debug > Attach Debugger.
%] € Attach %]
gehuwer: Using Dbx Debugger u
Host: localhost g Hosts...
Filter: ]_'J ¥ Refresh
Process to attach:
o | PO | PRI | smme |emo
ar3d4o6 a34 794 Sep OF fusrfbin/metacity --sm-client-id=defaulto
ar34406 827 1 Sep 07 wscreensaver -nosplash
ar34406 515 512 Sep 07 fusrfopenwin/bin/®sun 10 -defdepth 24 -nolisten tep... ||
arasq06 780 717 Sap 07 fusridybinfsde_shell -c 'unseten _ PWD: ur...
ar34406 717 50 Sep 07 fusrfoinfksh fusr/dtfbinfXsession
ar34ao6 a43 794 Sep 07 jusribinfnautilus --no-default-window --sm-client-id ... ||
ar34406 718 717 Sep 07 jusrjbin/ssh-agent -- fusrdt/bin/Xsassion
arad4406 T8l T80 Sep 07 fusrfbinfcsh -c 'unsetenv _ PWD: unseteny ... ||
ar34406 776 1 Sep 07 fusridt/binfdsdm
ar3d44o06 742 781 Sep 07 jusrjbinjksh jusridtjconfigfXsession2 jds
ar34406 794 792 Sep 07 fusrfbin/gnome-session
ar3d406 833 1 Sep 07 fusrilibfgvfsd
aridang @813 1 Sep 07 jusrfiib/geonfd-2 13
ar34406 819 1 Sep 07 fusrilib/gnome-sattings-daemaon
ar3d4o6 817 1 Sep OF fusriib/dbus-dasmon --fork --print-address 21 --pn...
ar34406 815 1 Saep 07 fusribin/gnome-keyring-daemaon
ar34406 835 794 Sep 07 jusrjbin/gnome-panel --sm-chent-id defaultl
ara4406 g42 1 Sep 07 fusrfib/bonobo-activation-server --ac-activate --ior...
ar34406 853 1 Sep 07 fusrflibftrashapplet '--oaf-actrvate-ind= 0AFNDIGHO...
arafa0s a&61 1 Sep OF jusrilibpwnck-applet *--oaf-activate-id=0AFID:GNG...
ar34406 18150 18058 17;19:07 tsbinish sh sh L/
Executable:
Project: Juote_ ]
Cancel || Help
6. Inthe Attach dialog box, type Freeway in the Filter field to filter the list of processes.
7. Select the Freeway process from the filtered list.
8. Click OK.
9. A debugging session is started and execution of the Freeway process pauses at the point where the

10. Click Continue @ to continue execution of Freeway, which is now running under control of the

debugger attached to it.

debugger. If you click Pause @ , execution of Freeway pauses, and you can examine variables, the call

stack, and such.
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11. Click Continue again and then click Finish Debugger Session . The debugger session ends, but the
Freeway process continues executing. Choose File > Exit in the Freeway GUI to exit the application.

Debugging a Core File

If your program is crashing, you might want to debug the core file (the memory image of your program when
it crashed). To load a core file into the debugger:

1. Choose Debug > Debug core file.

2. Type the full path to a core file in the Core File field or click Browse and navigate to your core file in the
Select Core File dialog box.

[+ & Debug Core File %]

Select a core file and an executable to use with it

Host: localhost g8 Hosts,

Debug Engine: dbx i *

Core File: jexportihomel/debug_tutorialfcore | -Ernwsa

Executable: =from cora= * || Browse... |
Lt =

Project: <no project> .

DeBug Cancel

3. Ifthe debugger cannot associate the core file you specified with an executable, it displays an error message.
If this situation occurs, type the path name of the executable in the Executable text box, or click the
Browse button and use the Executable dialog box to select the executable.

By default, the Project text field displays either <no project> or the name of an existing project that

exactly matches the name of the executable. If you want a new project created for the executable, select
<create new project>.

5. Click Debug.

For a more in-depth tutorial on debugging, see the Oracle Solaris Studio 12.3: dbxtool Tutorial.
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