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Welcome to the JD Edwards EnterpriseOne Configuration
Assistant

This section describes:

• Overview

• News and Links

• Productivity Hints

• Manually Creating a Shortcut for Configuration Assistant

Overview

The Configuration Assistant is a standalone Java-based tool that allows you to extract a subset of JD Edwards
EnterpriseOne configuration information into a portable archive. This data can then be loaded into any other JD
Edwards EnterpriseOne environment using Change Assistant.
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Tip

The maximum size of a SQL Server Express (SSE) local database is 4 GB, while there is no limit for an
Oracle Enterprise Edition (OEE) local database. As a point of reference, the sample JD Edwards Config-
urations are typically less than 100 MB.

Beginning in JD Edwards EnterpriseOne Tools Release 8.98, the configuration database is delivered as
xml.

Note

JD Edwards EnterpriseOne Compatibility. The Configuration Assistant tool is compatible with JD
Edwards EnterpriseOne Applications Release 8.11 SP1 and forward. However, JD Edwards Enter-
priseOne does not support cross release data configuration imports and exports using this tool.

For a description of how the Configuration Assistant and Change Assistant are used together to create
and distribute the configurations, and how specific machine types are required for each function, refer to
Packaging and Loading an Extracted File onto a Target Machine.

Warning

Microsoft Windows Server 2008. On the Microsoft Windows 2008 platform, you must start Configura-
tion Assistant using Run as Administrator. Right-click on the shortcut and select Run as Administrat-
or from the drop-down. For details on creating a shortcut for Configuration Assistant, refer to the sec-
tion entitled: Manually Creating a Shortcut for Configuration Assistant at the end of this chapter.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Caution

Use careful design analysis as you configure your portable archive in the source environment to ensure
that loading it in the target environment (using replace and append) will not cause problems.

When architecting data configurations, you should refer to the JD Edwards EnterpriseOne Configura-
tion Development Methodology Guide to ensure that you are adhering to known design constraints and
are aware of risks inherent with any data replacement strategy. This guide presents the guidelines you
should follow when creating new User Defined Codes (UDCs), Versions, Task Views, or special data
types in order to avoid potential conflicts with the base EnterpriseOne data set, and as a result core En-
terpriseOne application functionality.

Additionally, you should be aware that some types of configuration data are inherently more risky than
others. For example, you should exercise care when dealing with any technical tables such Next Num-
bers. That is, the system will not execute properly if you include tables associated with Next Numbers,
but then fail to take the associated Next Number table.

Further, generally you should not include any Control Tables or serialized object tables in your configur-
ation. That is, you should not include tables from any datasource other than Business Data.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Configuration designers will do well to consider the axiom of trade craftsmen:

The Configuration Assistant is designed to work with these specific types of JD Edwards EnterpriseOne config-
uration information:

• Tables

• Object Management Workbench (OMW) Projects and OMW Objects (requires JD Edwards Tools Release
8.98 or greater)

• User Defined Codes

• Security (Public, Roles, and Users)

• Tasks Views

• Versions

The user interface for Configuration Assistant includes a main window and two panes. The left pane displays a
tree view of work in process and sample JD Edwards EnterpriseOne configurations that are delivered by default.
Each configuration node represents the definition of the contents. After you have completed the definition of a
configuration, you use a separate step to actually extract the data and create the portable archive.

This Welcome section also describes these topics:

• Icons Used by Configuration Assistant

• Productivity Hints

When you start Configuration Assistant, this dialog box appears the first time you start the program or if the pro-
gram has changed and needs to reload a more current version. The dialog indicates the relative progress of load-
ing the Configuration Assistant Java program:

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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News and Links
The News and Links tab is available when you select the Configurations node and whenever you are connected to
the Update Center (see Using the Authentication Tab in Using Preferences). This tab displays a replica of the
page displayed by the Update Center, which is a companion tool to Configuration Assistant. The page contains
links to a variety of collateral information such as known issues and workarounds, breaking news, and tips. The
linked information is instrumental to the entire Update Center and Configuration Assistant methodology, design,
and end user processes.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Productivity Hints
The Configuration Assistant user interface includes a variety of tools to enhance end user productivity. These in-
clude:

• Adding or Removing Items to Your Configuration

• Backing Up Your Target Database Environment

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Help Tab

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• PDF Version of this Document

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Adding or Removing Items to Your Configuration
Whenever you select a check box in the right-hand pane to add an item to your configuration, that item is imme-
diately added to your configuration, as evidenced by the display in the left-hand pane. Likewise, if you clear a
check box in the right-hand pane, the item is immediately removed from the configuration and in the left-hand
display.

To add or remove an item to your configuration (from the tool-populated list of available tables in this data-
source), select the check box to the left of the item name; this is the first column of the table properties grid.

Tip

If you remove a configuration node or specific item from the My Configurations tree structure in the
left-hand pane, Configuration Assistant automatically clears the corresponding item in the right-hand
pane.

Backing Up Your Target Database Environment
You should always back up your target database environment before performing any process that alters the data,
including the loading of an extracted configuration that was created using Configuration Assistant. Unless prop-
erly designed and tested, it is possible that when you are loading data from a configuration that you might inad-
vertently overwrite production data.

As shown in the Environment Selection screen below, when you use Change Assistant to deploy an XML pack-
age, you can choose to back it up. With the Backup option selected, Change Assistant creates a configuration
that is a mirror of the configuration being loaded that contains data from the target system. To restore, you can
load the backup configuration from Change Assistant.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Edit Functions in Specific Nodes
Configuration Assistant logically enables and disables these edit functions within specific nodes:

• Cut

• Paste

• Delete

• Rename

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Folder Structure in the Configuration Assistant
In this portion of the tree, configuration definitions are grouped together by using folders and subfolders. You can
use folder structures to organize your configurations.

Tip

You can right-click on a folder and choose to create a new subfolder, or delete the selected folder.

See Also

• My Configurations

• JD Edwards Configurations

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Help Tab

Within Configuration Assistant, Help is mapped according to three specific nodes:

• Configurations

• My Configurations

• JD Edwards Configurations

See Also

The topic Help in the section: Menu Options.

Configurations
This portion of Help provides overview information and includes a number of Productivity Hints regarding the
user interface of the Configuration Assistant.

When initially selected, the Help for this node maps to the file Welcome.html. This file name is displayed
whenever you click the Back or Next buttons in the Help navigation.

Tip

Clicking the Home button returns you to the beginning of the Welcome.html file. To see a complete
index of Help topics for Configuration Assistant, use this Home navigation at the bottom of any Help
panel:

My Configurations
This portion of Help includes a description of My Configurations and includes links to further Help for all sub-
nodes:

• Tables

• OMW Projects and OMW Objects (requires JD Edwards Tools Release 8.98 or greater)

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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• User Defined Codes

• Security

• Task Views

• Versions

When initially selected, the help for this node maps to the file MyConfigurations.html. This file name is
displayed whenever you click the Back or Next buttons in the Help navigation.

Tip

Clicking the Home button returns you to the beginning of the My_Configurations.html file. To
see a complete index of Help topics for Configuration Assistant, use the Home navigation at the bottom
of each help topic as described in the Tip in the Configuration portion of Help Tab.

JD Edwards Configurations
This portion of Help includes a description of JD Edwards Configurations and includes links to further Help for
all subnodes:

• Tables

• OMW Projects and OMW Objects

• User Defined Codes

• Security

• Task Views

• Versions

When initially selected, the help for this node maps to the file JDE_Configurations.html. This file name
is displayed whenever you click the Back or Next buttons in the Help navigation.

Tip

Clicking the Home button returns you to the beginning of the JDE_Configurations.html file. To
see a complete index of Help topics for Configuration Assistant, use the Home navigation at the bottom
of each help topic as described in the Tip in the Configuration portion of Help Tab.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Icons Used by Configuration Assistant
This list includes the icons used within the Configuration Assistant:

• About

Indicates context sensitive help is available.

• Add

Adds a new item from a list of available items that are logically determined according to the location from
which the command is invoked.

• APPL Object

Identifies an item as an APPL object within OMW.

• APPL Version Object

Identifies an item as an APPL version object within OMW.

• BL Object

Identifies an item as a BL object within OMW.

• BSFN Object

Identifies an item as a BSFN object within OMW.

• BSFN SBF Object

Identifies an item as a BSFN SBF object within OMW.

• BSVW Object

Identifies an item as a BSVW object within OMW.

• Configuration

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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• Copy

Copies the selected item and places the contents in the clipboard.

• Cut

Cuts the selected item and places the contents in the clipboard.

• DD (Data Dictionary) Object

Identifies an item as a DD (Data Dictionary) object within OMW.

• Delete

Deletes the selected item and places the contents in the clipboard.

• Deselect All

Deselects all check boxes within an array displayed in the right-hand pane.

• Document

Identifies the item as an attached document.

• DSTR Object

Identifies an item as a DSTR object within OMW.

• End User Tasks

Identifies an item as an end user task.

• Exit

Exits the form from which this icon is clicked.

• Extract

Extracts the selected package or selected items.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant

14 GA.Rev1 Copyright © 2009, Oracle. All rights reserved.



• Find

Executes a search for objects based on criteria into the search dialog box box, either when entered by a user
or selected from a drop-down list.

• Folder

Identifies a node as a folder with no specific attributes known to Configuration Assistant.

• Folder Open

Indicates the selected node is an opened folder with no specific attributes known to Configuration Assistant.

• Help

Displays help for the selected subject.

• GT Media Object

Identifies an item as a GT media object within OMW.

• JD Edwards Configurations

Identifies the currently selected item as a default read-only configuration located under the JD Edwards Con-
figurations node.

• My Configurations

Identifies the currently selected item as a user-defined configuration located under the My Configurations
node.

• None Exist

Indicates an error condition for a table. For example, it could indicate a table spec mismatch, DD item miss-
ing, or that the table does not exist in the datasource to which it is mapped.

• OK

Indicates it is OK to accept a selection.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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• OMW Object

Identifies an item as an OMW object.

• OMW Project

Identifies an item as an OMW project.

• OMW User Defined Code

Identifies an item as an OMW UDC.

• OMW User Defined Code Value

Identifies an item as an OMW UDC value.

• Paste

Pastes the current contents of the clipboard at the selected location.

• Preferences

Identifies the item selection (from File > Preferences) as preferences for Configuration Assistant.

• Public

Indicates an item as containing *PUBLIC records within JD Edwards EnterpriseOne.

• Public Security Record

Indicates an item as a *PUBLIC security record within JD Edwards EnterpriseOne.

• Refresh

Identifies the Rename function in the file menu Edit > Rename.

• Rename

Refreshes and collapses the left-hand pane node display within Configuration Assistant.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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• Role

Indicates an item as containing roles records within JD Edwards EnterpriseOne.

• RPDF Object

Identifies an item as a RPDF object within OMW.

• Save

Saves the selected contents from memory to disk.

• Save All

Saves all currently unsaved items from memory to disk.

• Security Data

Identifies an item as containing security records within JD Edwards EnterpriseOne.

• Select All

Selects all check boxes within an array displayed in the right-hand pane.

• Solution Explorer Relationship

Identifies an item as a Solution Explorer relationship.

• Solution Explorer Task

Identifies an item as a Solution Explorer task.

• Solution Explorer Variant

Identifies an item as a Solution Explorer variant.

• SVCT Object

Identifies an item as a SVCT object within OMW.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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• Table

Identifies an item as a JD Edwards EnterpriseOne database table.

• TBLE Object (existing)

Identifies an item as an existing TBLE object within OMW.

• TBLE Object (existing)

Identifies an item as an existing TBLE object within OMW.

• Tables

Identifies items as JD Edwards EnterpriseOne database tables.

• TBLE Object (existing)

Identifies an item as an existing TBLE object within OMW.

• TBLE Object (non-existing)

Identifies an item as a non-existing TBLE object within OMW.

• Task Views

Identifies an item as a task view within JD Edwards EnterpriseOne.

• UBE Template Object

Identifies an item as a UBE template object within OMW.

• UBE Version Object

Identifies an item as a UBE version object within OMW.

• User Defined Code (UDC)

Identifies an item as a User Defined Code (UDC) within JD Edwards EnterpriseOne.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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• User

Indicates an item as containing user records within JD Edwards EnterpriseOne.

• Version

Identifies an item as a JD Edwards EnterpriseOne version.

• View

Identifies an item as a view within JD Edwards EnterpriseOne.

• Welcome

Identifies the item selection as the welcome for Configuration Assistant.

• Workflow Object

Identifies an item as a workflow object within OMW.

• XMLP Object

Identifies an item as an XMLP object within OMW.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Multiple Selects and Deselects
You can select or deselect multiple items using the check (checkmark) and uncheck (X) icons that are located at
the top of the Tables tab.

Each icon has an associated drop-down list that enables you to perform batch selection of:

Selects

• Highlighted

• All

• Tables with Data

Tip

The check pulldown option to select Tables With Data instructs the system to calculate the record
count on all the tables. Be aware that this process can take considerable time to complete depending
on the extent of the database.

Deselects

• Highlighted

• All

• Tables without Data

Tip

This selection is temporarily disabled (grayed out) until the counts for the All Tables panel or the
Search result panel have been completed and populated.

If this functionality is disabled (that is, the icon group is completely grayed out), it is because the configuration is
read-only. For example, all JD Edwards Configurations are set to read-only.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Panes in the Configuration Assistant
The Configuration Assistant allows you to display or hide the right-hand pane of the display.

If the display is showing both panes, to hide the right-hand panel click the lower right-facing arrow on the separ-
ator bar between the panes.

If the display is showing a single pane, to show the left-hand panel, click the upper left-facing arrow.

PDF Version of this Document
This document is also available in PDF form on the Update Center.

Search Drop-Down List - Selecting All
If you select All from the Search drop-down list, the Configuration Assistant pulls in all items which are defined
for the selected node. This does not include transactional data.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Search Results
For each Search that you execute, Configuration Assistant automatically creates and opens a new and separate tab
called Results. If you click on a node of a different type, then back to the previous node, Configuration Assistant
recalls the results tabs that were open. This is true whether or not the nodes are in the same configuration. If you
do not want to save any search results, you should close them as appropriate. To close a results tab, right-click on
the tab and select Close Results or Close All Results.

If you hover over a Results tab, the Search criteria of the results are displayed in a flyover panel. For example:

Search Strings - Valid Delimiters
If you manually enter search strings, or if you copy them from any application such as a spreadsheet, valid delim-
iters for any search field can include these characters, either singly or in any combination:

• space character(s)

• comma character(s)

• semicolon character(s)

• tab character(s)

If there are multiple contiguous valid delimiters, the system parses them to a single occurrence. For example, if
you enter the search string table1,,,,,table2, the system parses the search string as if a single comma de-
limiter were entered and, assuming the system located the tables, the returned results are displayed as ta-
ble1,table2.

Search Strings - Wild Cards
You can use an asterisk (*) as a wild card to substitute for any character in any position within a search string.
However, you cannot use any other operators or Boolean expressions in the search string.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Sorting Within Columns in a Grid
You can sort (either ascending or descending) the data in the column in a grid by clicking the column heading.
You can sort on multiple columns by holding the control (Ctrl) key and clicking the column headings.

Status Bar
The bottom bar of the Configuration Assistant screen lists helpful status information for the selected node with
these segments (from left to right):

• Segment 1: Generally displays the name of the Java-based EnterpriseOne application. In this case, Configura-
tion Assistant.

Note

Exceptions

If you are working on a single new unsaved configuration within My Configurations, when you click
Save Definition this element is populated with the phrase NAME saved, where NAME is the name of
your configuration.

If you are working on multiple new unsaved configurations within My Configurations, when you
click Save All this element is populated with the phrase x configurations saved, where x is the
number of previously unsaved configurations that were saved.

• Segment 2: Name of the selected configuration.

• Segment 3: Name of EnterpriseOne user who is currently signed on.

• Segment 4: Name of EnterpriseOne environment that is currently signed in to.

• Segment 5: Role of the user who is currently signed on.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Manually Creating a Shortcut for Configuration As-
sistant

To manually create a shortcut for Configuration Assistant:

1. In Microsoft Windows, navigate to Start > Settings > Control Panel and double-click on the Java icon.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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2. On Java Control Panel, on the General tab, in the Temporary Internet Files section, click the Settings...
button.

3. On Temporary Files Settings, click the View Applications... button.

4. On Java Cache Viewer, with Configuration Assistant highlighted, click the icon to create a shortcut or from
the File Manual select Applications > Install Shortcuts.

Welcome to the JD Edwards EnterpriseOne Configuration Assistant
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Menu Options
Configuration Assistant provides these menu options:

• File

• Edit

• View

• Help

File
From the File menu, you have the following selections:

• Add a New Configuration

• Extract a Configuration

• Save Definition

• Save All
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Add a New Configuration
Caution

You must be within the My Configurations folder in order to add a new configuration.

This section discusses:

• Accessing the Configuration Properties

• Configuration Properties - General Tab

• Configuration Properties - Advanced Tab

Accessing the Configuration Properties
To add (create) a new configuration, you must access the Configuration Properties using one of these three (3)
methods, which are functionally equivalent:

1. From the Configuration Assistant toolbar, select File > Add > Configuration.

2. Click the Add button and select Configuration from the pulldown list.

3. In the tree node view in the left pane, highlight and right-click on the My Configurations node, and select
Add Configuration.

Using any of the preceding three methods, Configuration Assistant displays the Configuration Properties dialog
box, which enables you to specify the properties for the configuration you are adding.

See Also

• Configuration Properties - General Tab

• Configuration Properties - Advanced Tab

Menu Options
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Configuration Properties - General Tab

On Configuration Properties, with the General tab selected, complete these fields

• Name

Enter a name for your configuration.

Menu Options
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Warning

This field is restricted to 10 characters maximum, and all characters must be in upper case. You can-
not use any of these special characters in this field:

/~`!@#$%^&()+=[]{}|\":;,?\\><*.'";

Additionally, if you plan on extracting a configuration to a RDB, the name cannot start with a num-
ber due to RDB restrictions.

• Description

Enter a description for your configuration.

Warning

This field can contain a maximum of 30 characters.

• Documentation

Optionally, you can attach documentation to be delivered with your configuration. For example, you may
want to include some special installation instructions for your configuration in the form of an HTML file. At-
tached documentation that is attached using this field will appear in the Task Assistant, which should be asso-
ciated with each task in the load schedule.

There is no restriction on the file types that you can attach as documentation.

You can only attach a single physical file from this field.

Tip

If you want to include multiple files as documentation, you can zip them into a single file and attach
that. Alternately, you can include the documentation (or any other files) that you want to include in
an extracted configuration by placing them in this directory:

<Solution Directory>/<solution name>/

That is, all contents of the <solution name> directory are automatically included in the .par
file created by Configuration Assistant when it performs an Extract. However, even though the files
are delivered to a source location using this method, they are not associated with a task as they
would be if you used the Documentation field.

This directory is defined in Using Preferences.

• Deploy To:

Note

Use this option to limit the configuration "consumer's" deployment options when the extracted con-
figuration is deploying using Change Assistant. Use of this option does not limit the user of Config-
uration Assistant.

Use the pulldown to select the environments to which to deploy:

• Selected Environment(s)

Using this selection you can deploy to any selected environment, which can include local.

• Local Environment Only
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Using this section you can only deploy to local, regardless of whether local is explicitly selected or not.
When you choose this selection, any other selected environments are ignored.

• Local and Selected Environment

Using this selection you can deploy to all selected environments including local regadless of whether loc-
al is explicitly selected or not.

Configuration Properties - Advanced Tab
You should use the Advanced tab to make selections from preconfigured solutions, if you already have pre-
defined OMW Projects or Tasks Views, or if you are using languages.

JD Edwards Tools Release 8.97.
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JD Edwards Tools Release 8.98 or greater.
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On Configuration Properties, with the Advanced tab selected, complete the fields in these two regions:

• Industry/Region

• Additional Configuration
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Industry/Region

In the Industry/Region section of the Advanced tab, complete these fields:

• Region

The pulldown list is populated based on the UDC Description01 field for the region (01RS/RC).

For example:

• ANZ - Australia/New Zealand

• Industry

The pulldown list is populated based on the UDC Description01 field for the industry (01RS/RI).

For example:

• MD - Manufacturing and Distributing

Caution

The first time you define an industry or region in a configuration the data is retrieved based on
the combination of the region and industry UDC values specified. If you subsequently change
the industry or region UDC, by design your changed configuration will still contain the original
data because the Configuration Assistant only changes the definition of the data within the con-
figuration, not the data itself. When you extract the configuration, the Configuration Assistant as-
signs any Versions with the changed value.

As an example use case, if you first design a configuration based on the ANZ region, the Config-
uration Assistant pulls in all record types associated with that UDC. If you subsequently change
the region to Singapore, then the previously retrieved data remains the same, while in the config-
uration the identifier for the records is changed from ANZ to SIN. When you extract the config-
uration, the Configuration Assistant changes the identifier for Versions from ANZ to SIN. As a
result, when the configuration is loaded into a target environment, there are no artifacts from the
ANZ region.

Warning

For UDC values for the 01RS/RC and 01RS/RI tables other than the defaults provided by JD Ed-
wards EnterpriseOne:

• Customers should use values in the range from 900 to 999 for your configuration.

• Business partners should contact Oracle to obtain a unique code.

• Default Task View

The Default Task View is based on the values you select for region and industry. The field is populated auto-
matically after an industry and region are selected.
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Additional Configuration

In the Additional Configuration region of the Advanced tab, complete these fields:

• OMW Projects (not displayed with JD Edwards Tools Release 8.98 or greater)

Click the browse button to select from existing OMW Project Names. This enables you to bring all configura-
tion information such as UDCs and Versions into your definition.

Note

Configuration information does not include code or objects. For more information on product pack-
aging, refer to the JD Edwards EnterpriseOne Tools Package Management Guide.

• Task Views

Click the browse button to select from an existing Task Master for tasks of type 00 (Task Views).

• Language

Configuration Assistant populates a pulldown list of languages based on the values of UDC 01/LP. When you
select a language from this pulldown, the translation table (that is, “D” tables) records for UDCs and Task
Views are included in your configuration.

For example, a language selection on the pulldown might be:

• P – Portuguese

Note

Specifying a language pulls language records into your configuration for UDCs and Task Views
only. If you want to include the entire translation table for these, or any other data, you must spe-
cifically include translation tables in the Tables section of your configuration definition.

See Also

Configuration Properties - General Tab
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Extract a Configuration
Tip

On Web Development Clients (fat clients), the Extract function allows you to extract local specs and
Central Objects.

On Standalone Clients and the Deployment Server, the Extract function only allows you to extract local
specs.

After you create a configuration, you can extract it to a portable database. The output of the extraction depends
on the JD Edwards EnterpriseOne Tools release, JD Edwards EnterpriseOne Applications Release, and the ma-
chine on which the extraction is performed.

Extraction Output Matrix
Tools Release Output

Applications Release 8.12
or prior

Application Release 9.00

8.98 XML XML -- with these extraction machine variables:
MSDE Standalone: Extract Local > XML
SSE Deployment Server: Extract Local > XML

Web Development Client: Extract Central > XML

Extract Local > XML
8.97

8.96

Depends on installed data-
base on extraction machine
which can be either:

• MSDE

• SSE

MSDE

See Also

• Troubleshooting Extract

• Packaging and Loading an Extracted File onto a Target Machine

• Tables Involved when Extracting a Configuration Definition with Configuration Assistant

To extract a configuration, highlight the configuration to be extracted in the tree node display in the left pane:

1. From the Configuration Assistant toolbar, select File > Extract.
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Note

As an alternate method, you can either:

• Click the Extract button.

Extract button (Tools Release 8.97).

Extract button (Tools Release 8.98).

• Use the keyboard shortcut: Ctrl+T
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Caution

If you accidentally click Extract, or if you want to stop the Extract process once it has begun, click
the Cancel button in the Extract Status dialog box.

The status of the extraction process is displayed in the node_name-Extract Status panel.

If the Extract completes successfully, each extracted category will be flagged with a green check mark and
the bottom of the Extract Status panel will indicate Completed Successfully in the bottom left hand portion
of the dialog box.

2. When the extraction is complete, select either Report to view the Extract Report or Close to close the Extract
Status window.

For details on the Extract Report, refer to Extract Report.

Tip

The portable archive (.par file) of the configuration that you extract is placed into the directory
you have specified in Using Preferences. The prefix of the .par file (that you specified in Name
field during the task Add a New Configuration) identifies each custom configuration you create in
My Configurations.
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Troubleshooting Extract
If you have not previously extracted a report for the selected configuration, and you attempt to view the Extract
Report, this error is displayed:

If you have previous extracted a configuration, this error is displayed:
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Warning

If the Extract does not completed normally, each unsuccessful category will be flagged with a red X and
the bottom of the of the Extract Status panel will indicate Errors Occurred. Click the Report button to
view the exception report, which contains information useful in troubleshooting the error conditions.

Click Yes to view the Exception Report. For details on the Extract Report, refer to Extract Report.

Tip

You can also use OMW logs to help in troubleshooting. In OMW, find project named
CFG_your_configuration_name, click the project, and use the form exit to view the logs.
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Packaging and Loading an Extracted File onto a Target Machine
Configuration Assistant. This tool is used to create configurations and to extract them into a portable archive.
Typically the machine on which the tool is running must use a Microsoft Windows operating system. Typically
such a machine would be either a JD Edwards EnterpriseOne Standalone Client or a JD Edwards EnterpriseOne
Web Development Client (also known as a Fat Client).

The output of the extraction depends on the JD Edwards EnterpriseOne Tools release, JD Edwards EnterpriseOne
Applications Release, and the machine on which the extraction is performed. For details, refer to the Extraction
Output table in the section entitled: Extract a Configuration.

Change Assistant. This tool is used to load an extraction onto a target machine, which must be a JD Edwards
EnterpriseOne Deployment Server or Standalone Client. By definition, the Deployment Server must also be run-
ning a Microsoft Windows operating system. By default, the Configuration Assistant creates the .par file in the
directory you specified in Using Preferences.

To summarize the Change Assistant steps:

1. In order to avoid having the Change Assistant inadvertently locate test extractions or perhaps other extrac-
tions that you may not be ready to share, you should copy the .par file to an appropriate folder under the
Change Assistant downloads directory on the Deployment Server or Standalone Client.

2. Navigate to the specified source directory containing the .par file and select the .par file from the Change
Assistant display.

3. Click the Deploy button.

Change Assistant displays a list of available JD Edwards EnterpriseOne installed environments on this ma-
chine (which is either a Deployment Server or Standalone Client).

4. Select the target JD Edwards EnterpriseOne environment into which you want to load the contents of the
configuration.

Warning

You should always beware of data integrity concerns, especially in production data environments. Refer
to Backing Up Your Target Database Environment.
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Tables Involved when Extracting a Configuration Definition with Config-
uration Assistant

This section lists the tables involved when extracting a configuration definition with Configuration Assistant.

1. OMW Projects and OMW Objects

These tables and objects will have records extracted corresponding to the OMW projects and OMW Objects
specified in the advanced options:

Table Description or Object Type
F98220 OMW Project Header
F98222 OMW Project Objects
F9860 TBLE -- Object Librarian Master Table
F9861 TBLE -- Object Librarian Status Detail
F98710, F98711, F98712, F98713 TBLE
F98720 BSFN
F98740, F98741 ER
F98743 DSTR
F98750, F98751 APPL
F98760, F98761 UBE

2. Versions

These tables will have records extracted corresponding to the Versions specified in the configuration defini-
tion:

• F983051 - Versions List

• F983052 - Versions List Tag Table

• F98740 - Event Rules - Link Table

• F98741 - Event Rules - Spec Table

• F98760 - Report Design Aid Text Information

• F98761 - Report Design Aid Specification Information

3. User Defined Codes

These tables will have records extracted corresponding to the UDC codes and values specified in the config-
uration definition:

• F0004 - User Defined Code Types

• F0005 - User Defined Code Values
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Note

If language is specified, these tables will also be extracted.

• F0004D - User Defined Code - Alternate Language

• F0005D - User Defined Code - Alternate Language Description

4. Task Views

These tables will have records extracted corresponding to the Task Views specified in the configuration
definition:

• F9000 - Task Master

• F9001 - Task Relationships

• F9005 - Variant Description

• F9006 - Variant Detail

Note

If language is specified, these tables will also be extracted.

• F9002 - Task Alternate Description

• F9005D - Variant Description Alternate Description

• F9006D - Variant Detail Alternate Description

5. Security

These tables will have records extracted corresponding to the users and roles specified in the configuration
definition, and the address book information associated with these users will also be extracted:

• F0092 - Library List - Users

• F00921 - User Display Preferences

• F00922 - User Display Preferences Tag File

• F00924 - User Install Packages

• F00925 - User Access Definition

• F00926 - Anonymous User Access Table

• F00927 - E1 Users PIM Information

• F0093 - Library List Control

• F00950 - Security Workbench Table

• F95921 - Role Relationships Table

• F95922 - Permissions List Relationship Table

• F98OWSEC - One World Security
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• F0101 - Address Book Master

• F0111 - Address Book - Who’s Who

Menu Options

44 GA.Rev1 Copyright © 2009, Oracle. All rights reserved.



Save Definition
Caution

You must be within the My Configurations folder in order to Save Definition.

To save a configuration that you have created (or modified), select Save Definition:

1. Highlight the node for the definition you want to save.

2. From the Configuration Assistant toolbar, select File > Save Definition.

Note

As an alternate method, you can either:

• Click the Save Definition button.

• Use the keyboard shortcut: Ctrl+S
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Save All
Caution

You must be within the My Configurations folder in order to Save All definitions.

To save all configurations that you have created (or modified), select Save All:

1. Highlight the node for the definition you want to save.

2. From the Configuration Assistant toolbar, select File > Save All.

Note

As an alternate method, you can either:

• Click the Save All button.

• Use the keyboard shortcut: Ctrl+Shift+S
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Edit
From the Edit menu, you can perform functions as described in these sections:

• Using Standard Editing Functions (Cut, Copy, Paste, Delete, Rename)

• Using Preferences

Using Standard Editing Functions (Cut, Copy, Paste, Delete,
Rename)

Warning

All configurations within the JD Edwards Configurations node are read-only. Configuration Assistant
logically enables and disables certain standard editing functions as applicable, depending on which tree
node you select and the context of the configuration.

If you select Delete, there is no direct recovery (or "undo") from within the Configuration Assistant pro-
gram. However, if you do not Save or Save All subsequent to an inadvertent Delete action, you can ef-
fectively recover by not saving and then exiting from Configuration Assistant and re-entering with the
previously saved state.

This section describes these standard editing functions:

• Cut

• Copy

• Paste

• Delete

• Rename

Tip

The functionality of the standard editing functions is also duplicated with Drag and Drop.

For example, if you want to copy the security roles from a JD Edwards Configuration to a My Configur-
ations, you can either:

• In the source JD Edwards Configuration, highlight the Roles node and choose the standard editing
function Copy (either from the Edit menu or by right-clicking).

In the target My Configuration, highlight either the Roles node (if it exists), or the Security node (if
the Roles node does not exist) and choose the standard editing function Paste.

• In the source JD Edwards Configuration, highlight the Roles node and drag it.

In the target My Configuration, drop the Roles node that you are dragging either to the Roles node
(if it exists) or the Security node (if the Roles node does not exist).
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See Also

The topic Edit Functions in Specific Nodes in the section Productivity Hints.

Cut
If you use the standard editing function Cut from either the Edit menu or with the keyboard shortcut Ctrl+C key,
the currently selected node is deleted and its contents are copied to the clipboard.

Copy
If you use the standard editing function Copy from either the Edit menu or with the keyboard shortcut Ctrl+C, the
contents of the selected node are copied to the clipboard and can be pasted into a new location by using the Paste
command.

If you choose Copy by right-clicking, this dialog box prompts you to enter the new name of the selected node:

Tip

Use the browse button or enter a fully qualified path to the target directory to which you want to Copy
the selected node. For example:

c:\Change Assistant\Packages\Configurator\My
Configurations\copied_configuration_name

Paste
If you use the standard editing function Paste from either the Edit menu or with the keyboard shortcut Ctrl+V
key, the current contents of the clipboard are pasted into the currently selected node.

Delete
If you use the standard editing function Delete from either the Edit menu or with the keyboard shortcut Delete
key, you are prompted to confirm the deletion:
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Rename
If you use the standard editing function Rename from either the Edit menu or with the keyboard shortcut F2, you
are prompted to enter the new name for the selected node:
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Using Preferences
From Edit > Preferences you can choose from tabs described in these sections:

• Using the Authentication Tab

• Using the Advanced Tab

• Using the My Configurations Tab

Using the Authentication Tab

If you choose to use the optional Configuration Assistant Update Center Authentication functionality, complete
these fields:

• User ID
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• Password

• User Name

• E-mail

• Phone

If you want to disable the automatic connection to the Update Center, you can select this check box:

Disable Update Center Connection

If you want Configuration Assistant to always prompt for authentication credentials on startup, you can select this
check box:

Always Prompt at Startup?

Using the Advanced Tab
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If you choose to use the optional Configuration Assistant advanced functionality for connections to the Update
Center and for proxy server authentication, complete these fields:

Update Center Connection

• Timeout (milliseconds)

The default value is 300,000 milliseconds.

• Number of Retries

The default value is 5 retries.

Proxy Server Authentication

• User ID

• Password

• Domain

If you want to be prompted for any advanced functionality on this tab during the startup of Configuration Assist-
ant, you can select this check box:

Always Prompt at Startup?
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Using the My Configurations Tab
You use the My Configurations tab to define the default working directory for your Configuration Assistant. This
is the working folder for all configurations that you create.

On Preferences, with the My Configurations tab selected, complete this field:

• Enter the Configuration Directory

Enter the directory path or use the browse button to enter the directory for your configurations, which the
Configuration Assistant displays under the My Configurations node.

Warning

If you plan to extract RDB configurations this path cannot be to a mapped drive
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View
The View menu enables you to generate HTML versions of these reports:

• Summary Report

• Extract Report

• Compare Report

• Refresh

Summary Report
Note

As a design aid, you can view a Summary Report for any new or existing configuration regardless of
whether it has been extracted using the Extract function of Configuration Assistant.

The Summary Report provides a listing of all the information contained in the configuration. The report provides
links so that you can easily navigate to each section, including:

• Definition

• OMW Projects and OMW Objects

• Tables

• UDCs

Note

The system generates UDCs in this report if you specify one UDC value at a time. If you specify an
entire table, the system generates UDCs in the Tables section of this report.

• Versions

• Security

• Task View

The report only displays a link if information exists for the section. That is, if you do not include a Task View in
the configuration, the Summary Report does not create a link to Task View.

In addition, if any documentation is attached to the report, the system provide an active link to it. The generated
source HTML file for the Summary Report is located in the directory of the node name. For example, if you gen-
erated a Summary Report for RSMDGR, then the file is located here:

x:\Change Assistant\Packages\your_configuration_name

where x: is the drive on which your configurations reside, and

where your_configuration_name is the name of the node that defines your configuration.
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To generate a Summary Report:

1. Highlight any node in an existing configuration.

2. From the View menu, select Summary Report.

The following status panel displays to indicate the report is generating as requested:

After the report is generated, the HTML output is displayed by your default browser as shown in this ex-
ample:
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Extract Report
The Extract Report provides a listing of all the information about the extraction process and the resulting .par
file. The report provides links so that you can easily navigate to each section, including:

• Definition

• Action

• Activity

You can only view an Extract Report for configurations that you have previously extracted. To verify if a config-
uration has already been extracted, check the directory of the node to verify if a
<node_name>_EXTRACT.html file exists. If this file exists, an Extraction has previously been attempted for
the selected configuration. To verify that the Extract is valid, open the Extract Report file and verify that the Ex-
traction completed with no errors.

To view an Extract Report:

1. Highlight a configuration for which you have previously performed an Extract.

2. From View, select Extract Report.
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Compare Report
If you want to compare the contents of one configuration against another, you can view the Compare Report,
which presents a side-by-side comparison of the components for the two configurations that you choose. The
Compare Report provides two groups of links, which you can use to review the configurations differently:

• All

The links in this grouping provide a listing of the components for the first configuration and a second column
that describes whether the component exists in the second configuration. For example, All Tables provides a
listing of all the tables in the first configuration and a Yes/No value in the column for the second configura-
tion to indicate whether that same table is included there.

• Added and Removed

The links in this grouping provide the differences noted in the All comparisons categories. For example, if
you clicked the Added Tables link, the system displays the additional business units in the first configuration
that are not in the second. If there are more tables in the second configuration than the first, a link for Re-
moved Tables lists those tables.

To compare configurations:

1. Highlight an existing configuration and from the View menu select Compare Report.

The system displays this dialog box window:

2. Use the browse button or enter the path to locate the configuration that you want to use for the comparison.

3. Click Open.

Configuration Assistant generates the Compare report and opens it in your default browser. For example:
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4. Use the links at the top of the report to navigate through the different sections of the report. Each topic con-
tains a comparison of items (by their names, numbers, and descriptions) which exist in one configuration,
but not the other.

Note

In this context, the term "removed" indicates that no add or append action occurred resulting in a
difference between the compared configuration, where the source configuration contains an item
while the target configuration does not.
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Refresh
From the View menu, if you select Refresh (or use the keyboard shortcut F5), the Configuration Assistant re-
freshes the screen and returns the tree node display in the left-hand pane to a fully collapsed state. The contents
display of the right-hand pane are not affected.

Warning

If you have made changes (which the system indicates by bold portions of a configuration and affected
nodes), clicking Refresh will cause the system to disregard any changes that you made but did not save.
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Help
When you select Help from the menu selections, you can choose from:

• Show Log

• About Configuration Assistant

See Also

The topic Help Tab in the section: Welcome to the JD Edwards EnterpriseOne Configuration Assistant.

Show Log
The Configuration Assistant creates a new log file every time you start Configuration Assistant. If a log file exists
from a prior startup, it is overwritten.

The type of errors written to this log are typically those for which the Configuration Assistant has specific know-
ledge, such as Java exceptions or if it detects the Update Center is down.

The log file is written to the Configuration Directory specified on the My Configurations tab of Preferences, as
described in Using Preferences of this guide. The name of the log file is:

ConfigurationAssistantLog.txt

Below is an example of the contents of a Configuration Assistant log file:

Tip

The logging levels are not selectable by the end user.
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About Configuration Assistant

If you choose About Configuration Assistant from the Help menu, a dialog box is displayed that contains this in-
formation about Configuration Assistant:

• Version

• Build date

• Install date

Click OK to close the dialog box and return to Configuration Assistant.
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My Configurations

The My Configurations folder stores the definitions that the Configuration Assistant tool uses to create the port-
able archive of a configuration. Your customized My Configurations contain the framework for specific solutions
packaged by the Extract function of the Configuration Assistant tool into the portable archive.

You can use any portion of the JD Edwards read-only configurations as a basis for your custom configuration.
For a description of the Configuration Assistant tools you can use to duplicate any functionality, refer to Using
Standard Editing Functions (Cut, Copy, Paste, Delete, Rename).

These subnodes of My Configurations are described separately:

• Tables

• Tables

• OMW Projects and OMW Objects

• User Defined Codes

• Security

• Task Views
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• Versions

See Also

• Add a New Configuration

• Extract a Configuration

• Troubleshooting Extract

• Packaging and Loading an Extracted File onto a Target Machine

• Save Definition

• Save All

• The topic Status Bar in the section Productivity Hints.
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JD Edwards Configurations

This folder is used to store predefined sample versions of configurations that were created using the Configura-
tion Assistant tool. The JD Edwards Configurations are all shipped as read-only.

You can review all of the components of each configuration and use all or any portion of them as templates to
create your own configurations. Use the Drag and Drop features of the configuration definition tools or standard
editing functions to duplicate the desired functionality. For a description of Configuration Assistant tools you can
use to duplicate any functionality, refer to Using Standard Editing Functions (Cut, Copy, Paste, Delete, Rename).

Note

Change Assistant refreshes these definitions each time you connect to the Update Center. As a result,
each time you connect you will have access to all new configurations as well as existing ones.

These subnodes of My Configurations are described separately:

• Tables

• Tables

• OMW Projects and OMW Objects

• User Defined Codes

• Security

• Task Views

• Versions

• The topic Status Bar in the section Productivity Hints.
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Configuration Properties
To access the Properties of any configuration under My Configurations and JD Edwards Configurations, click
on the node for the configuration.

The chapter describes these sections of the Properties screen for configurations:

• Configuration

• Advanced

• Default Load Actions

• Object Counts

Copyright © 2009, Oracle. All rights reserved. GA.Rev1 67



Configuration
The Configuration section of the Configuration Properties describes these fields:

• Name

Displays the name of the configuration selected in the Configurations tree view, either in the My Configura-
tion or JD Edwards Configurations node. This name was defined when the configuration was created, and
is not editable.

• Description

Displays a description of the selected configuration. This Properties Configuration field is editable in this
view.

Warning

This field can contain a maximum of 30 characters.

• Documentation

Optionally, you can attach documentation to be delivered with your configuration. For example, you may
want to include some special installation instructions for your configuration in the form of an HTML file. At-
tached documentation that is attached using this field will appear in the Task Assistant, which should be asso-
ciated with each task in the load schedule.

There is no restriction on the file types that you can attach as documentation.

You can only attach a single physical file from this field.

Tip

If you want to include multiple files as documentation, you can zip them into a single file and attach
that. Alternately, you can include the documentation (or any other files) that you want to include in
an extracted configuration by placing them in this directory:

<Solution Directory>/<solution name>/

That is, all contents of the <solution name> directory are automatically included in the .par
file created by Configuration Assistant when it performs an Extract. However, even though the files
are delivered to a source location using this method, they are not associated with a task as they
would be if you used the Documentation field.

This directory is defined in Using Preferences.

• Release

Configuration Assistant populates this value based on the release level of the JD Edwards EnterpriseOne that
is signed on the machine on which Configuration Assistant is running at the time the configuration is created.

Tip

Although this Release value is programmatically determined when creating a configuration, an en-
hancement to Change Assistant allows configurations to be applied to any release. If there is a mis-
match in the Release value during deployment, Change Assistant issues a warning that cautions the
user that although cross release application of the configuration is allowed, it should not be done
without full knowledge of the consequences and thoughtful testing.
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• Deploy To:

Note

Use this option to limit the configuration "consumer's" deployment options when the extracted con-
figuration is deploying using Change Assistant. Use of this option does not limit the user of Config-
uration Assistant.

Use the pulldown to select the environments to which to deploy:

• Selected Environment(s)

Using this selection you can deploy to any selected environment, which can include local.

• Local Environment Only

Using this section you can only deploy to local, regardless of whether local is explicitly selected or not.
When you choose this selection, any other selected environments are ignored.

• Local and Selected Environment

Using this selection you can deploy to all selected environments including local regadless of whether loc-
al is explicitly selected or not.
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Advanced
The Advanced section of the Configuration Properties describes these fields:

• Region

The pulldown list is populated based on the UDC Description01 field for the region (01RS/RC).

For example:

• ANZ - Australia/New Zealand

• Industry

The pulldown list is populated based on the UDC Description01 field for the industry (01RS/RI).

For example:

• MD - Manufacturing and Distributing

Caution

The first time you define an industry or region in a configuration the data is retrieved based on
the combination of the region and industry UDC values specified. If you subsequently change
the industry or region UDC, by design your changed configuration will still contain the original
data because the Configuration Assistant only changes the definition of the data within the con-
figuration, not the data itself. When you extract the configuration, the Configuration Assistant as-
signs any Versions with the changed value.

As an example use case, if you first design a configuration based on the ANZ region, the Config-
uration Assistant pulls in all record types associated with that UDC. If you subsequently change
the region to Singapore, then the previously retrieved data remains the same, while in the config-
uration the identifier for the records is changed from ANZ to SIN. When you extract the config-
uration, the Configuration Assistant changes the identifier for Versions from ANZ to SIN. As a
result, when the configuration is loaded into a target environment, there are no artifacts from the
ANZ region.

Warning

For UDC values for the 01RS/RC and 01RS/RI tables other than the defaults provided by JD Ed-
wards EnterpriseOne:

• Customers should use values in the range from 900 to 999 for your configuration.

• Business partners should contact Oracle to obtain a unique code.

• Language

Configuration Assistant populates a pulldown list of languages based on the values of UDC 01/LP. When you
select a language from this pulldown, the translation table (that is, “D” tables) records for UDCs and Task
Views are included in your configuration.

For example, a language selection on the pulldown might be:

• P – Portuguese

Configuration Properties
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Note

Specifying a language pulls language records into your configuration for UDCs and Task Views
only. If you want to include the entire translation table for these, or any other data, you must spe-
cifically include translation tables in the Tables section of your configuration definition.
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Default Load Actions
The Default Load Actions section of the Configuration Properties consists of these sections:

• Tables

• UDCs

• Security

Tables
Use the radio buttons to select a data load action into your database when the configuration data is loaded into
your target environment:

• Replace Tables

The table in the target environment will be replaced with the table in the configuration.

Caution

If any records exist in the target tables to be replaced, they will be lost because this selection indic-
ates you want to replace the table with data from the portable archive created by Configuration As-
sistant.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.

• Replace Records

Table records in the target environment will be replaced with the records in the configuration table.

Warning

Replace Records does not clear the table before it copies. It replaces records in the target with the
same key. Any new records are appended.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.

• Append Records

Only records that do not exist in the target environment will be copied from the configuration tables.

Caution

You cannot create a configuration to extract and deliver an empty table. That is, you cannot define
an empty table in your source environment to overwrite an existing populated table in your target en-
vironment.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.
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UDCs
Use the radio buttons to select a data load action into your database when the configuration data is loaded into
your target environment:

• Replace UDCs

The UDCs in the target environment will be replaced with the UDCs in the configuration.

Caution

If any UDCs exist in the target tables to be replaced, they will be lost because this selection indicates
you want to replace the UDC with data from the portable archive created by Configuration Assistant.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.

• Replace Records

Table records in the target environment will be replaced with the records in the configuration table.

Warning

Replace Records does not clear the table before it copies. It replaces records in the target with the
same key. Any new records are appended.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.

• Append Records

Only records that do not exist in the target environment will be copied from the configuration tables.

Caution

You cannot create a configuration to extract and deliver an empty table. That is, you cannot define
an empty table in your source environment to overwrite an existing populated table in your target en-
vironment.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.

Security
Use the radio buttons to select a data load action into your database when the configuration data is loaded into
your target environment:

• Replace *Public/Role/User

The *Public/Role/User in the target environment will be replaced with the *Public/Role/User in the configur-
ation.
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Caution

If any *Public/Role/User exists in the target tables to be replaced, they will be lost because this se-
lection indicates you want to replace the *Public/Role/User with data from the portable archive cre-
ated by Configuration Assistant.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.

• Replace Records

Table records in the target environment will be replaced with the records in the configuration table.

Warning

Replace Records does not clear the table before it copies. It replaces records in the target with the
same key. Any new records are appended.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.

• Append Records

Only records that do not exist in the target environment will be copied from the configuration tables.

Caution

You cannot create a configuration to extract and deliver an empty table. That is, you cannot define
an empty table in your source environment to overwrite an existing populated table in your target en-
vironment.

You should always beware of data integrity concerns, especially in production data environments.
Refer to Backing Up Your Target Database Environment.

Configuration Properties

74 GA.Rev1 Copyright © 2009, Oracle. All rights reserved.



Object Counts
This section provides quantity statistics of the selected configuration for these individual items:

• Business Data Tables

• User Defined Codes

• Public Security

• Roles

• Users

• Task Views

• Versions

• Projects

• Objects

Configuration Properties
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Tables
The Tables node lists and describes JD Edwards EnterpriseOne tables that are available in Configuration Assist-
ant. You typically use Configuration Assistant with configuration tables and not transactional tables. Oracle
provides a way to identify just the configuration tables using Search and All Tables functions.

Tip

In addition to the tables that Configuration Assistant automatically identifies as transactional, you can
manually select D tables if you need them.

Caution

Because JD Edwards EnterpriseOne Tools Release 8.98 uses the XML format, if the target table has new
columns, the database default value for the new column is used for each record added. It is recommen-
ded that configurations containing such tables should not be done without full knowledge of the con-
sequences and thoughtful testing.

You can include all or a subset of these tables in your configuration. As it retrieves the tables from the JD Ed-
wards EnterpriseOne database, Configuration Assistant provides a set of known and assigned attributes assigned
to these tables, which are helpful in determining their contents and suitability for inclusion in your configuration:

• Table number (as assigned by JD Edwards EnterpriseOne)

• Number of rows in the table

• Load action (as defined with Configuration Assistant; the action that will be performed in the target environ-
ment for this configuration)

• Data class

• Copy data

• Description

• Object use

• System code

• Reporting code

• Data source

To populate the Tables node, you can use these tabs:

• Search

• All Tables

See Also
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These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Tables
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Search
With the Tables node selected, the Search tab provides these functions:

• Search button

• Pulldown selections (predefined database query)

Pulldown selections include predefined database queries. When you make a selection the Table Name field is
automatically populated with the table names associated with the selection. These pulldown selections of pre-
defined database queries and their predefined tables are:

• Non-Transactional Tables

The list of tables was created by Oracle applications development. It does not include any system code 74,
75, or 76 tables. When you choose this search type the Table Name field is automatically populated with
the list, which includes hundreds of tables. To view the complete list, you can manually copy the contents
out of the field display and into a readable form.

• Business Data

Includes all tables that have a data class of B, which is automatically populated in the applicable Criteria
field.

• System Tables

Includes all tables that have a data class of S, which is automatically populated in the applicable Criteria
field.

• Control Tables

Includes all tables that have a data class of T, which is automatically populated in the applicable Criteria
field.

• Foundation Tables

Includes all tables for system code 00.

• Distribution Tables

Includes all tables for system codes 40, 41, 42, 43, 43Q, 45, 46, 49, 40, 40G, 40R, 41B, 43C, 43E, 46L,
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and 46R.

• Manufacturing Tables

Includes all tables for system codes 30, 31, 31B, 32, 34, 37, 40, 41, F30L, F31, F31K, and F34R.

• Search Criteria Fields

• Table Name

• Description

• System Code

• Reporting Code

• Data Class

• Copy Data Flag

Tables
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All Tables
When you select the Tables tab in the right panel, the Configuration Assistant displays a list of all JD Edwards
EnterpriseOne tables in the Tables datasource for the environment in which you are logged on.

The grid contains a variety of information about each table, including the current row count.

By default, the lists of Tables is shown with a split screen where the top portion lists all the tables, and the bottom
portion is used to display the records in the specified table. You can click the up and down arrow in the separator
bar to toggle the split screen on and off (refer to screen shot below for location of these arrows).

Note

The system performs the data retrieval and table analysis in method that improves memory management.
The table search starts the first time you click on the Table node of a configuration. The table record
count is not calculated until you select a table. In order to select all tables with data, you can use the
check pulldown option to select Tables With Data, which instructs the system to calculate the record
count on all the tables. You can then deselect unwanted tables. For details on using the check option,
refer to Multiple Selects and Deselects.

Note

The Tables tree node in the left pane displays subnodes for selected records if All Tables or Selected
Tables are chosen. The tree subnode shows record level detail such as *All records or the Primary Key
for Selected Records.

Tables
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You can use the lower half of the All Tables split panel to search and select individual records within a table. To
view a specific record within a table, use the checkbox in the top half of the split panel to select a table. The bot-
tom half of the split panel displays each record, where bolded entries indicate key fields (not necessary the
Primary Key). To search for specific key values within a record, enter a value in the data entry field on the Search
panel and click the Search tab. Individual Results tabs are created to display the results of each search.

Caution

A value of blank in any field indicates a wild card search for any value. Because tables with a large
number of records may consume more memory than available, Configuration Assistant displays a warn-
ing is given if a search is going to return too much data. In this case, you should either narrow the search
or select the entire table.

Tip

Hover Text. You can hover over any field description within a record to ascertain the literal key name.
For example, in F0002, if you hover on Product Code the key name NNSY is displayed.

Tip

None Exist Icon. This icon in the Rows column of a listed table indicates an error condition for a table.
For example, it could indicate a table spec mismatch, DD item is missing, or that the table does not exist
in the datasource to which it is mapped.

Tables
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OMW Projects and OMW Objects
You can include all or a subset of OMW Projects and OMW Objects in your configuration. As it retrieves the
OMW Projects and OMW Objects from the JD Edwards EnterpriseOne database, Configuration Assistant
provides a set of known and assigned attributes assigned to these projects, which are helpful in determining their
contents and suitability for inclusion in your configuration:

OMW Projects

• Project Name

• Description

• Status

• Type

• System Code

• Release

OMW Objects

• Object

• Status

• Type

• System Code

• Reporting Code

To populate the OMW Projects node, you can use these tabs:

• Search

• All Projects

See Also

These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant
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• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

OMW Projects and OMW Objects
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Search
With the OMW Projects node selected, the Search tab provides these functions:

• Search button

• Pulldown selection (All)

• Search Criteria Fields

• Project Name

• Description

• System Code

• Status

• Type

• Release

Under the OMW Projects node, with EnterpriseOne Objects node selected, you can choose from these Object
Search Categories:

• Object Librarian (APPL, BSFN, BSVW, DSTR, TBLE, UBE)

• Data Dictionary

• OMW Project

• Workflow

• User Overrides

• Business Service Property

• Report Definition

• XMLP Publisher Object (Business Intelligence)

The following screens show example searches for each of the above listed Object Seach Category.

OMW Projects and OMW Objects
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Object Search Category: Object Librarian.

OMW Projects and OMW Objects
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Object Search Category: Data Dictionary.

OMW Projects and OMW Objects
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Object Search Category: OMW Project.

OMW Projects and OMW Objects
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Object Search Category: WorkFlow.

OMW Projects and OMW Objects
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Object Search Category: User Overrides.

OMW Projects and OMW Objects
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Object Search Category: Business Service Property.

OMW Projects and OMW Objects

Copyright © 2009, Oracle. All rights reserved. GA.Rev1 91



Object Search Category: Report Definition.

OMW Projects and OMW Objects
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Object Search Category: XMLP (Business Intelligence).

OMW Projects and OMW Objects
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All Projects
When you select the Tables tab in the right panel, the Configuration Assistant displays a list of all JD Edwards
EnterpriseOne OMW Projects and OMW Objects in the OMW Projects datasource for the environment in which
you are logged on.

The grid contains a variety of information about each OMW Project and OMW Object.

OMW Projects and OMW Objects
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User Defined Codes
The User Defined Codes node lists and describes JD Edwards EnterpriseOne UDCs which Configuration Assist-
ant has identified from the source data source. You can include all or a subset of these UDCs in your configura-
tion. As it retrieves the UDCs from the JD Edwards EnterpriseOne database, Configuration Assistant provides a
set of known and assigned attributes assigned to these tables, which are helpful in determining their contents and
suitability for inclusion in your configuration. Different attributes are displayed in the right-hand pane depending
on the level of detail:

• Upper portion of right-hand pane

• Product Code

• Code Type

• Description

• Lower portion of right-hand pane

• Product Code

• Code Type

• Value

• Description 01

• Description 02

Note

For any selected records, the non-changeable default load action is to Replace Records.

Caution

Some UDCs contain technical values related to your JD Edwards EnterpriseOne environment setup.
Carefully consider how these might affect your target environment if you choose to extract all UDCs.

To populate the User Defined Codes node, you can use these tabs:

• Search

• All User Defined Codes

See Also

These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes
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• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

User Defined Codes

98 GA.Rev1 Copyright © 2009, Oracle. All rights reserved.



Search
With the User Defined Codes node selected, the Search tab provides these functions:

• Search button

• Pulldown selections from predefined searches by industry or other category (for example, Financials)

• Search Criteria Fields

• Code|Type (combination search for code type pairs, for example: 01|AB and 02|CD)

• Product Code

• Code Type

• Type Description

• Value

• Value Description 01

• Value Description 02

User Defined Codes

Copyright © 2009, Oracle. All rights reserved. GA.Rev1 99



All User Defined Codes
When you select the All User Defined Codes tab in the right panel, the Configuration Assistant displays a list of
all JD Edwards EnterpriseOne UDCs in the User Defined Codes datasource for the environment in which you are
logged on.

The grid contains a variety of information about each UDC, including types and descriptions.

User Defined Codes
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Security
The Security node contains these subnodes:

• Public

• Roles

• Users

When you click the Security tab, you are presented with a grid that displays all currently defined security records
for the selected node:

See Also. These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All
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• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Security
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Public

With the Public node selected, the Search tab provides these functions:

• Search button

• Pulldown selections from predefined searches

• Search Criteria Fields

• Security Type

You can use the pulldown to select one of these security types:

• 1 - Action Security

• 2 - Column Security

• 3 - Application Security

• 4 - Row Security

• 5 - Processing Option Security

• 6 - Hyper Exit Security

• 7 - External Calls Security

• User Name

The system displays a static value of *PUBLIC for this field. This value cannot be changed.

• Object Name

• Version Name

• Data Item

Security
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• System Code

Note

For any selected records, the non-changeable default load action is to Replace Records.

Tip

If you have a configuration that was created by a prior version of Configuration Assistant that did not
support this function, the security node in the tree view it will not have a Public node underneath it. You
can add the Public node by using the Add > Security button.

This displays all three security nodes (Public, Role, User) underneath the Security node.

Security
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Roles

Caution

When you use Configuration Assistant to select User or Role records, the system also selects any corres-
ponding security records that are set up for the User and Role, including: Action, Solution Explorer, En-
vironment, and Application. The system automatically tags the selected roles with the information
provided for the Region and Industry fields that you used when you added the configuration properties
when you extract the data.

With the Roles node selected, the Search tab provides these functions:

• Search button

• Pulldown selections from predefined searches

• Search Criteria Fields

• Address Book

Warning

User input in this field is restricted to numeric data. That is, no alpha characters are allowed in
order to avoid database errors.

Security
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• Name

• Description

• Region

• Industry

Note

For any selected records, the non-changeable default load action is to Replace Records.

Tip

For searches, you can use the pulldowns to choose from predefined values for the Region and Industry
fields. Refer to Configuration Properties - Advanced Tab for a description of the UDC values that are
used by Configuration Assistant to populate these pulldown selections.

Security
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Users

With the Users node selected, the Search tab provides these functions:

• Search button

• Pulldown selections from predefined searches

• Search Criteria Fields

• Address Book

Warning

User input in this field is restricted to numeric data. That is, no alpha characters are allowed in
order to avoid database errors.

• Name

• Description

• Region

• Industry

Note

For any selected records, the non-changeable default load action is to Replace Records.

Security
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Tip

For searches, you can use the pulldowns to choose from predefined values for the Region and Industry
fields. Refer to Configuration Properties - Advanced Tab for a description of the UDC values that are
used by Configuration Assistant to populate these pulldown selections.

Security
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Task Views
When you select the Task Views tab, you are presented with a grid that displays all currently defined task views
for the selected node:

Note

The selection of task views is only from the highest level within JD Edwards EnterpriseOne. That is,
you cannot select only specific sections within a task view. You must either select the entire task view or
not.

With the Task Views node selected, the Task Views tab presents a list of the Task View categories. If you expand
a Task View category, Configuration Assistant retrieves and populates the display with all task views associated
with the category. During the retrieval, Configuration Assistant displays a status indicating the progress of the re-
cord retrieval.

Note

For any selected objects, the non-changeable default load action is to Replace Objects.
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Warning

This can be a time-consuming process, depending on the number of records that are retrieved. You can-
not cancel the record load once you have initiated it. However, you can continue to use other functional-
ity of Configuration Assistant while the load is in progress.

See Also. These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar

Task Views
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Versions
When you click the Versions node, in the right panel you can select from these tabs:

• Search

• All Versions

See Also

These topics in the Productivity Hints:

• Adding or Removing Items to Your Configuration

• Edit Functions in Specific Nodes

• Folder Structure in the Configuration Assistant

• Icons Used by Configuration Assistant

• Multiple Selects and Deselects

• Panes in the Configuration Assistant

• Search Drop-Down List - Selecting All

• Search Results

• Search Strings - Valid Delimiters

• Search Strings - Wild Cards

• Sorting Within Columns in a Grid

• Status Bar
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Search
With the User Defined Codes node selected, the Search tab provides these functions:

• Search button

• Pulldown selections from predefined searches by industry or other category (for example, Rapid Start)

Note

If you select All from the Search pulldown, the Configuration Assistant pulls in all items which are
defined for the selected node. This does not include transactional data.

• Search Criteria Fields

• Code Type

• Product Code

• Type Description

• Value

• Value Description 01

• Value Description 02

Note

For any selected objects, the non-changeable default load action is to Replace Objects.

Versions
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All Versions
When you select the All Versions tab in the right panel, the Configuration Assistant displays a list of all JD Ed-
wards EnterpriseOne Versions in the Version datasource for the environment in which you are logged on.

The grid contains a variety of information about each version, including object, version, and description.

Note

When you select All Versions, the Configuration Assistant displays all default JD Edwards versions
(such as those prefixed with XJDE and ZJDE) as well as versions associated with Rapid Start (those that
are prefixed with RIS).

Versions
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