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This document provides late-breaking information as well as information that is not 
yet part of the formal documentation.

This document contains the following sections:

■ Changes in this release

■ Supported TimesTen releases and platforms

■ Prerequisites

■ Known problems and limitations

■ Documentation Accessibility

1 Changes in this release
This section lists changes between releases:

■ Changes for Release 3.1 from Release 3.0

■ Changes for Release 3.0 from Release 2.1.1

1.1 Changes for Release 3.1 from Release 3.0
■ To start SQL Developer on a Mac OS X system, go to the sqldeveloper directory 

under the <sqldeveloper_install> directory, and run 
sh sqldeveloper.sh -J-d32.  The option -J-d32 is required.

■ If you duplicate rows and the data type for the column(s) is BLOB (for TimesTen 
Release 11.2.2 or later), ROWID, or BINARY/VARBINARY, the column(s) are 
populated with null values.

■ There are new features.  See New features in release 3.1.

1.1.1 New features in release 3.1
Features supported in TimesTen Release 11.2.2 or later:

■ You can define and use LOB data types. This includes defining columns with LOB 
data types, adding columns with LOB data types, displaying LOB data types, and 
defining LOB data types in IN, OUT, and IN OUT parameters in PL/SQL editors. 

■ You can compute table size information.  After computing table size information 
for one or more tables, you can view values for INLINE BYTES, OUT OF LINE 
BYTES, and METADATA BYTES. 
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■ There is a new Table report called Table Sizes. This report displays table size 
information for tables on which you have computed table sizes.

■ The Columns reports has been enhanced to display LOB data types.

Features supported in TimesTen Release 11.2.1.4.0 or later:

■ You can specify INLINE for data types VARCHAR2, NVARCHAR2, and VARBINARY 
when defining columns in the Create Cache Group dialog, Create Table dialog, 
and Add Column dialog.

■ You can test your PL/SQL function, procedure, or package using a REF CURSOR 
as an OUT parameter. 

■ You can load data into tables using Import Data. 

■ There are two new cache group reports.  One report provides a summary of the 
type and count of cache groups. The second report lists attributes of the read-only, 
asynchronous writethrough, synchronous writethrough and user managed cache 
groups.

1.2 Changes for Release 3.0 from Release 2.1.1
■ When you use a named connection to connect to a TimesTen database, you no 

longer have to select the Save Password check box in the connection's New/Select 
Database Connection dialog box to view the DDL statement for any database 
element such as a table or view in the element's SQL tab.

■ You no longer have to select the Save Password check box in a named connection's 
New/Select Database Connection dialog box to perform any cache group 
operations such as creating or loading a cache group.

1.2.1 New features in release 3.0
■ You can use the Schema Browser for filtering and narrowing the list of objects 

displayed.

■ You can create and drop internal and external TimesTen database users. You can 
grant system privileges to a new user that you are creating. You can grant system 
privileges to or revoke system privileges from an existing user. You can change the 
password of an existing internal user.

■ You can generate the following TimesTen reports:

- Data source attribute settings and database version

- Names of all database objects accessible to the user connected to the TimesTen 
database

- Count of all database objects by owner and type accessible to the user 
connected to the TimesTen database

- Names of all public and private synonyms

- Program unit arguments, source code search and source code line counts for 
PL/SQL packages, procedures and functions

- System and object privileges granted to the user connected to the TimesTen 
database

- Privileges granted to the PUBLIC role
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- Names of all tables and columns accessible to the user connected to the 
TimesTen database

- Names of all tables owned by the user connected to the TimesTen database

- Listing of all internal and external database users

- Names of all indexes owned by the user connected to the TimesTen database

- Names of all indexes accessible to the user connected to the TimesTen database

■ You can create and drop private synonyms. You can export the definition of a 
private synonym to a file or to SQL Worksheet. You can display the details of a 
private synonym.

■ You can create and drop public synonyms. You can display the details of a public 
synonym.

■ You can create and drop materialized view logs. You can display the details of a 
materialized view log.

■ You can create a hash index when:

- Adding a primary key to a table

- Changing the type of index on the columns of a table's existing primary key

■ You can cache an Oracle table that has a unique index but no primary key defined 
on it.

■ You can cache an Oracle private synonym.

■ You can update table and column statistics used by the query optimizer for all 
tables owned by the user connected to the TimesTen database.

■ You can compile invalid or all PL/SQL packages, procedures and functions.

■ You can specify cascade delete when adding a foreign key to a table.

■ You can view and update the data in a table's column using display editors. You 
can use text editor, binary editor, or Date and Timestamp editor to update data in 
the data grid.

2 Supported TimesTen releases and platforms
SQL Developer 3.1 is available on 32-bit and 64-bit Microsoft Windows and Linux 
systems. SQL Developer 3.1 supports Oracle TimesTen In-Memory Database and 
Oracle In-Memory Database Cache Releases 11.2.1.4.0 and later, and can be used to 
connect to a TimesTen database that resides on any platform that is supported by the 
TimesTen software.

In a client/server environment, if you connect to the TimesTen server with an older 
release of the TimesTen client, then new features added to the newer release of the 
server are not supported. 

3 Prerequisites
Before you can use SQL Developer to connect to a TimesTen database:

1. Install 11.2.1.4.0 or later release of the TimesTen Data Manager or TimesTen Client 
on the same system as SQL Developer. If you use SQL Developer to connect to a 
local database, at minimum install the TimesTen Data Manager on the same 
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system as SQL Developer. If you use SQL Developer to connect to a remote 
database, at minimum install the TimesTen Client on the same system as SQL 
Developer.

2. Execute the TimesTen_install_dir/bin/ttenv.sh or 
TimesTen_install_dir/bin/ttenv.csh shell script on Linux systems, or the 
TimesTen_install_dir\bin\ttenv.bat batch file on Microsoft Windows 
systems to set the TimesTen environment variables before starting SQL Developer. 

3. Make sure the CLASSPATH environment variable includes the proper TimesTen 
JDBC driver file (TimesTen_install_dir/lib/ttjdbc6.jar on Linux 
systems or TimesTen_install_dir\lib\ttjdbc6.jar on Microsoft 
Windows systems). SQL Developer 3.1 requires Java Development Kit (JDK) 6 be 
installed.

4 Known problems and limitations
■ If you do not select "Autocommit," then TimesTen SQL operations within the 

Connections navigator are not always automatically committed. You must issue 
an explicit commit by either selecting Commit or by issuing the commit command 
in SQL Worksheet. If TimesTen encounters errors in your transaction, you must 
explicitly roll back the transaction by either selecting Rollback or by issuing the 
rollback command in SQL Worksheet.

If "Autocommit" is selected, then TimesTen SQL operations within the 
Connections navigator are automatically committed. A transaction in the SQL 
Worksheet is also automatically committed if there are no open tables in the 
transaction. If there are open tables, then the transaction in the worksheet is not 
automatically committed and you must issue an explicit commit by either 
selecting Commit or by issuing the commit command in SQL Worksheet.

To enable "Autocommit," select Tools > Preferences. In the Preferences dialog 
box, click the + to the left of the Database node to expand the node and select 
Advanced.

■ Setting the passthrough level to a value other than 0 can affect the SQL operations 
in the Connections navigator. Make sure this setting is reset to 0 when switching 
from issuing passthrough operations in SQL Worksheet back to the Connections 
navigator.

You can also create an unshared worksheet which uses a separate database 
connection from the Connections navigator so that a particular passthrough level 
setting applies only to that worksheet. From a shared worksheet, click the 
Unshared SQL Worksheet icon or press Ctrl+Shift+N to create an unshared 
worksheet.

■ If you click the + to the left of the Indexes node to view the list of indexes and then 
click the name of the index with the characteristics you want to view, you cannot 
view the index's DDL statement, because the SQL tab is missing. To view the 
CREATE INDEX statement, from the index's underlying table or materialized view, 
click the SQL tab.

■ TimesTen error 2963 (Inconsistent datatypes: (NUMBER,CHAR) are not 
compatible in expression) is returned when you attempt specify a numeric 
value filter on a numeric column. To specify a filter value for a numeric column, 
click the + to the left of the Tables node to view the list of tables, and then click the 
name of a table that contains a numeric column. In the Data tab of the table, click 
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the name of a numeric column. In the Filter field, enter a numeric value and press 
the Enter key.

■ Before you export data from a table in a format that is compatible with the 
TimesTen ttBulkCp utility, set the format for DATE and TIMESTAMP data using 
the following instructions:

1. Select Tools > Preferences.

2. In the Preferences dialog box click the + to the left of the Database node to 
expand the node.

3. Select NLS.

4. In the Date Format field, specify RRRR-MM-DD

5. In the Timestamp Format field, specify DD-MON-RRRR HH24:MI:SSXFF

To export data from a table in a format that the ttBulkCp utility recognizes, 
right-click the name of the table and select Unload. After you select Unload, step 1 
(Source/Destination) of the Unload Wizard appears. In the Format drop-down 
menu, select ttbulkcp. After you complete step 1, click the Next button to advance 
to step 2 (Specify Data) of the Unload Wizard. After you complete step 2, click the 
Next button to advance to step 3 (Unload Summary). Click the Finish button to 
complete the data export operation.

You can change the DATE and TIMESTAMP data format back to their original 
settings after the data has been exported.

■ In TimesTen 11g releases up to and including 11.2.1.5, a user that has not been 
granted the ADMIN privilege cannot create PL/SQL objects such as procedures, 
functions and packages even if the user has been granted the CREATE 
PROCEDURE or CREATE ANY PROCEDURE privilege. The workaround is to grant 
the SELECT privilege on the SYS.SYSTEM_PRIVILEGE_MAP system table to the 
PUBLIC role. 

■ In TimesTen 11g releases up to and including 11.2.1.4, an "agent status 
cannot be determined" error is returned when you attempt to start the cache 
agent or the replication agent as a user that has not been granted the ADMIN 
privilege. The same error is returned when you attempt to perform an operation 
that is to be processed by the cache agent such as loading or refreshing a cache 
group.

In TimesTen Releases 11.2.1.5.0 and later, granting the CACHE_MANAGER privilege 
to the user is sufficient to perform these operations.

■ The hierarchical profile and debugging of PL/SQL procedures and functions in a 
TimesTen database are not supported.

5 Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit 
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http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are 
hearing impaired.
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