Oracle® Essbase Studio

New Features

Release 11.1.2.2.000


Copyright © 2011, Oracle and/or its affiliates. All rights reserved.

Authors: EPM Information Development Team

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS:

Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). Oracle America, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

This software or hardware and documentation may provide access to or information on content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.


Table of Contents:

Essbase Studio 11.1.2.2.000 New Features

Oracle Essbase Studio continues to simplify cube construction by delivering a single environment for data modeling and cube design, providing a consistent platform for building analytic applications and loading data.

The sections that follow describe the new features in Essbase Studio Release 11.1.2.2.000.

Essbase Model Resync

With Oracle Essbase model resync, changes made to hierarchies and cube schemas can be propagated to affected Essbase models. In prior releases, changing hierarchies and cube schemas meant recreating the Essbase model and resetting any properties the Essbase properties in the model. Using the new “Update Out-of-sync Models” option, you can pick and choose which models to sync, without having to recreate them or reset properties.

For example, suppose a change was made to a hierarchy belonging to a cube schema used to build an Essbase model. When saving the hierarchy, a warning message is displayed indicating that, as a result of the change, there are Essbase models that are out of sync. In the Metadata Navigator, an icon signifies the out-of-sync models. You may right-click either the updated hierarchy or the out-of-sync model in the Metadata Navigator, and then select the “Update Out-of-sync Models” option. This launches the Sync Models dialog box, where you can choose to update selected out-of-sync models or all out-of-sync models.

Note that there are three launch points to the Resync Models dialog box:

  • Right click on an out-of-sync model.

  • Right-click on the cube schema which has an out-of-sync model under it.

    Note that this option is enabled only if there are changes in the cube schema such as adding, removing, or repositioning a hierarchy in the cube schema.

  • Right click on a modified hierarchy.

    Note that this option will sync only this particular hierarchy, regardless of how many hierarchies have been changed. Also, hierarchies added or removed from the cube schema will not be synced.

Following are the types of metadata changes which would prompt a model resync:

  • A new hierarchy is added to a cube schema

  • A hierarchy is removed from a cube schema

  • A hierarchy is replaced with a different hierarchy in a cube schema

  • A hierarchy is moved or repositioned in a cube schema

  • A chain is added to a hierarchy

  • A chain is removed from a hierarchy

  • A chain is replaced in a hierarchy

  • A chain is moved or repositioned in a hierarchy

  • A chain in a hierarchy is edited

  • A member is added to a hierarchy

  • A member is removed from a hierarchy

  • A member is replaced in a hierarchy

  • A member is moved or repositioned in a hierarchy

Whenever you perform a model resync, always be sure to validate the affected Essbase model before attempting to deploy it.

For more information, see the “Model Resync” chapter in the Oracle Essbase Studio User's Guide.

New Streaming Option in Cube Deployment Wizard

A new check box, “Enable streaming mode for cube deployment” has been added to the first page of the Cube Deployment Wizard. This new option allows users to select to deploy cubes in streaming or nonstreaming mode. The selection is made each time you deploy or redeploy.

In prior releases, the property, server.essbase.streamingCubeBuilding, was set in the server.properties file to indicate whether cube deployment would occur in streaming or nonstreaming mode. This property dictated behavior for all cube deployments.

Starting with this release, the choice to perform deployment in streaming mode can be made at deployment time in the Cube Deployment Wizard, and can be changed for each individual deployment and redeployment.

Streaming mode means that during cube deployment, Essbase Studio Server queries the external data source directly (rather than Essbase Server querying the external data source).

The “Enable streaming mode for cube deployment” check box is enabled when the Essbase model being deployed contains single or multiple relational data sources.

The check box is disabled when the data sources used in the Essbase model are one or more text file sources, one or more Dimension Server (Performance Management Architect) sources, or a mix of text file and relational sources.

For more information, see the“ Cube Deployment” chapter, “Providing Connection Information for Cube Deployment” topic in the Oracle Essbase Studio User's Guide.

Minischemas Now Part of Data Source Connection

Minischemas have been reimplemented in this release to associate them with data source connections.

To accommodate this, the Source Navigator area of the Essbase Studio Console is changed as follows:

  • The Minischema tab is removed from the Source Navigator area.

  • The Data Sources tab is renamed Data Source Navigator. This pane is now referred to as the Data Source Navigator and data source connections are listed in the physical tree in this pane.

  • In the physical tree in the Data Source Navigator, under each data source connection name, all minischemas for that connection are stored in a new folder named “Minischemas”. If there are no minischemas for a connection, then that folder is empty.

  • The tables used in a minischema are no longer displayed under the minischema in the physical tree. Double-click the minischema and display it to view the tables.

You can access all previously-available minischema functionality from the opened minischema.

Note:

If you migrated to this release from a prior release, any minischemas you previously had that were created from multiple data sources are not displayed in the Data Source Navigator.

For more information, see the “Minischemas” chapter in the Oracle Essbase Studio User's Guide.

Alias Set Enhancements

In this release, all tasks related to alias set creation and maintenance become accessible directly in the Metadata Navigator. From the File menu or the context menu, you can create alias sets in any folder in the Metadata Navigator, including the root folder. From the Edit menu or the context menu, you can also edit, copy, rename, delete, and export alias sets

Alias sets are now treated as metadata elements, on a par with hierarchies, dimension elements, cube schemas, etc. They can be created in a user-defined metadata folder or in the root folder. They can be exported as part of a catalog export or exported individually.

There are also changes to the way alias properties are handled in the Essbase Model Properties dialog box:

  • Because alias sets can have the same name under different folders in the Metadata Navigator, the new alias set “Name in Cube” field is introduced in the Alias tab for the model. It allows you to rename alias sets so that they appear with a different name in a cube, making all alias table names unique inside a cube.

    During model validation, any duplicates in the “Name in Cube” field result in a model validation error in the Validate Properties dialog box.

  • In the Alias tab for members, the “Name in Cube” is displayed for all alias sets that are included in the model.

  • In the Dynamic Time Series dialog box, for alias sets that are included in the model, the “Name in Cube” for each is displayed as column headers.

Note:

The Alias Set Manager interface is removed from the console and the Alias Set Manager option is removed from the Tools menu. Use the File menu or context menu in the Metadata Navigator to create and access alias sets.

For more information, see the “Alias Sets” chapter in the Oracle Essbase Studio User's Guide.

Streamlined Modeling of Oracle BI EE Business Model Sources

Essbase Studio now lets you create a cube schema and Essbase model during the data source connection creation process.

During Oracle Business Intelligence Enterprise Edition connection creation, when you select the Business Model option, not only are you creating dimension elements and hierarchies, you may now also choose to create a cube schema and Essbase model.

After exploring the source database for dimensions and deriving dimension elements and hierarchies, Essbase Studio then examines the source for fact table elements, from which you can specify measures. Dimensions are also displayed, from which you specify hierarchies. The measures and hierarchies you specify are the basis of a new cube schema, from which an Essbase model is automatically created.

Upon completion of this process, the dimension elements, hierarchies, cube schema, and Essbase model are stored in the Metadata Navigator. You may edit any of these elements, if required. For example, you can open the Essbase model and edit the property settings. Work with these elements as you would elements created from any other relational data source.

For more information on creating metadata elements from Oracle BI EE, see the “Data Source Connections” chapter,“ Creating Oracle BI EE Dimensions” and “Creating an Oracle BI EE Cube Schema” in the Oracle Essbase Studio User's Guide

Cube Deployment from Oracle BI EE

To take advantage of the aggregation power of Essbase, Oracle BI EE allows users to deploy Essbase cubes from within Oracle BI EE.

In Oracle BI EE, users define measures, dimensions, and attributes, and then specify cube building options to deploy an Essbase cube. During the cube deployment process, Oracle Business Intelligence Enterprise Edition sends an XML file containing data source information and the cube schema definition, along with deployment options, to Essbase Studio, to be stored in the Essbase Studio catalog.

For information on the Oracle Essbase connection, data source connection, and metadata element artifacts that are created in Essbase Studio as a result of a deployment fromOracle Essbase Studio, and how you may work with these artifacts, see the “Data Source Connections” chapter and the “Metadata Elements” chapter in the Oracle Essbase Studio User's Guide.

Support for Oracle RAC Data Sources

You may now create and edit data source connections to Oracle Real Application Cluster (RAC) sources. In the Connection Wizard, you enter an Oracle Service Name, and then you can enter multiple Oracle RAC server nodes per connection.

After data source connection creation, you work with Oracle RAC connection and elements in the same manner as an Oracle connection.