Contents

Send Us Your Comments

Preface

Part 1  Introduction and Basics

1  Introduction

Overview ........................................................................................................................................... 1-1
Dashboard: Collaborator Workbench ............................................................................................... 1-2
Predictive Trade Planning Business Processes and Worksheets ..................................................... 1-3
Promotion Modeling and Optimization Business Processes and Worksheets ............................... 1-5
Forecasting and Simulation ............................................................................................................. 1-7
Optimization .................................................................................................................................... 1-8

2  Predictive Trade Planning Concepts

Worksheet Basics ................................................................................................................................. 2-1
PTP Data Hierarchy .......................................................................................................................... 2-3
Promotions ....................................................................................................................................... 2-6
Retailer Profiles ............................................................................................................................... 2-8
Funding ........................................................................................................................................... 2-8
Promotion Costs and Spending ......................................................................................................... 2-9
Volume and Volume Breakdown ...................................................................................................... 2-9
Data Access ...................................................................................................................................... 2-11
3 Logging in and Getting Started
   Initial Log in and Download ........................................................................ 3-1
   Logging in to PTP .................................................................................. 3-2
   Tutorial: Getting Acquainted with Worksheets ........................................ 3-3
   Controlling Synchronization of Embedded Worksheets ............................ 3-6

4 Working with Data
   Editing Data ......................................................................................... 4-1
   Saving and Viewing Changes .................................................................. 4-3
   Sorting Worksheet Data ......................................................................... 4-4
   Copying and Pasting Data ...................................................................... 4-5
   Copying and Pasting to and from Microsoft Excel .................................. 4-6
   Exporting Data to Microsoft Excel ....................................................... 4-6
   Linking Data into Third-Party Reporting Tools (via DOL) ....................... 4-7
   Printing .................................................................................................. 4-10
   Viewing Notes ...................................................................................... 4-11
   Editing Notes ......................................................................................... 4-13
   Viewing and Managing Attachments to Notes ....................................... 4-14
   Specifying Note Permissions .................................................................. 4-16
   Refreshing the Local Worksheet Cache ................................................ 4-17
   Viewing the Audit Trail .......................................................................... 4-17

Part 2 Business Processes

5 Oracle Demantra Dashboard
   Introduction to the Dashboard ............................................................... 5-1
   Reviewing Metrics ................................................................................ 5-3
   Reviewing the Planning Hierarchy ....................................................... 5-5
   Editing Retailer Information ................................................................ 5-6
   Opening Worksheets ............................................................................. 5-9
   Managing Tasks .................................................................................. 5-10
   Creating and Sending a Task ................................................................ 5-10
   Personalizing the Dashboard .............................................................. 5-12
   Configuring Your Default Layout ..................................................... 5-12
   Configuring My Tasks .......................................................................... 5-14
   Configuring My Worksheets ............................................................... 5-15
6 Managing and Viewing Quotas and Funds

Overview................................................................................................................................................. 6-1
Managing Quotas and Funds at the Retailer Level....................................................................................... 6-3
Managing Quotas and Funds at the Promotion Group Level................................................................. 6-5
Viewing Quotas and Funds......................................................................................................................... 6-6
Reference.................................................................................................................................................. 6-7

7 Tracking Volume

Overview...................................................................................................................................................... 7-1
Reference.................................................................................................................................................. 7-5

8 Planning Promotions

Introduction to the Planning Environment................................................................................................ 8-1
Creating a Promotion................................................................................................................................. 8-6
Editing a Promotion................................................................................................................................. 8-8
Marking a Promotion as Planned............................................................................................................. 8-8
Approving a Promotion............................................................................................................................. 8-9
Committing a Promotion........................................................................................................................... 8-9
Marking a Promotion as Partially Paid or Paid......................................................................................... 8-10
Closing a Promotion................................................................................................................................ 8-10
Making Other Changes to a Promotion.................................................................................................... 8-10
Duplicating a Promotion........................................................................................................................... 8-13
Copying and Pasting a Promotion............................................................................................................ 8-15
Deleting a Promotion............................................................................................................................... 8-16
Reference.................................................................................................................................................. 8-17

9 Promotion Calendars

Overview....................................................................................................................................................... 9-1
Working with Promotions in the Promotion Calendar............................................................................ 9-3
Predefined Calendar Views....................................................................................................................... 9-5

10 Simulation and Optimization

Overview...................................................................................................................................................... 10-1
Running the Analytical Engine in Simulation Mode.................................................................................. 10-3
Running a Simulation.................................................................................................................................. 10-3
Optimizing a Promotion............................................................................................................................ 10-6
Viewing Optimization Results.................................................................................................................. 10-8
Calendar Optimization............................................................................................................................... 10-11
Accepting an Optimized Promotion.......................................................... 10-14
Reference.................................................................................................. 10-15

11 Examining and Comparing Promotions

Overview..................................................................................................... 11-1
Examining Promotions from the Manufacturer’s Point of View............... 11-2
Examining Promotions from a Retailer’s Point of View........................... 11-6
Comparing Promotions in a Scenario....................................................... 11-8
Reference.................................................................................................. 11-10

12 Reviewing Past Performance

Overview..................................................................................................... 12-1
Evaluating Performance from the Manufacturer’s Point of View............. 12-2
Evaluating Performance from a Retailer’s Point of View......................... 12-5
Reference.................................................................................................. 12-8

Part 3 Advanced Topics

13 Creating Worksheets and Content Panes

Introduction.............................................................................................. 13-2
Working with Lists.................................................................................. 13-3
Creating or Editing a Worksheet or Content Pane.................................. 13-3
Configuring the Basics.......................................................................... 13-4
Selecting Series on a Worksheet.............................................................. 13-6
Managing the Series Lists....................................................................... 13-7
Specifying the Time Resolution and Time Span..................................... 13-9
Specifying Aggregation Levels............................................................... 13-11
Using the Advanced Selection Options................................................ 13-12
Changing the Overall Scale or Unit of Measure..................................... 13-14
Filtering the Worksheet or Content Pane.............................................. 13-16
Managing the List of Members............................................................... 13-18
Applying Exception Filters..................................................................... 13-18
Defining the View Layout....................................................................... 13-20
Adding and Managing Worksheet Views.............................................. 13-22
Specifying the Worksheet Elements in a View..................................... 13-24
Displaying an Embedded Worksheet.................................................... 13-25
Filtering a Worksheet View.................................................................... 13-26
Sharing Worksheet and Content Panes................................................ 13-28
Deleting Worksheet or Content Panes................................................... 13-28
Creating New Product Launches ................................................................. 13-28
General Tips on Worksheet Design ......................................................... 13-29

14 Shipment and Consumption Planning
Overview ................................................................................................. 14-1
Setting Shipment and Consumption Planning Attributes ......................... 14-3

15 Reference
Series ....................................................................................................... 15-1
Item Levels .............................................................................................. 15-19
Location Levels ....................................................................................... 15-20
Retailer ..................................................................................................... 15-21
Corporate ................................................................................................. 15-21
Promotion Levels .................................................................................... 15-23
Lookup Tables .......................................................................................... 15-28
Methods ................................................................................................... 15-29
Procedures .............................................................................................. 15-30
Triggers .................................................................................................... 15-32
Workflows ................................................................................................ 15-33
Engine Configuration ............................................................................... 15-35
Additional Checklist Before Running Optimization .................................. 15-36

16 Administration
Running the Analytical Engine ................................................................. 16-1
Running Required Workflows ................................................................. 16-2
Managing the PTP Users ........................................................................ 16-8

Index
Send Us Your Comments

Part No. E22233-13

Oracle welcomes customers' comments and suggestions on the quality and usefulness of this document. Your feedback is important, and helps us to best meet your needs as a user of our products. For example:

- Are the implementation steps correct and complete?
- Did you understand the context of the procedures?
- Did you find any errors in the information?
- Does the structure of the information help you with your tasks?
- Do you need different information or graphics? If so, where, and in what format?
- Are the examples correct? Do you need more examples?

If you find any errors or have any other suggestions for improvement, then please tell us your name, the name of the company who has licensed our products, the title and part number of the documentation and the chapter, section, and page number (if available).

Note: Before sending us your comments, you might like to check that you have the latest version of the document and if any concerns are already addressed. To do this, access the new Oracle E-Business Suite Release Online Documentation CD available on My Oracle Support and www.oracle.com. It contains the most current Documentation Library plus all documents revised or released recently.

Send your comments to us using the electronic mail address: appsdoc_us@oracle.com

Please give your name, address, electronic mail address, and telephone number (optional).

If you need assistance with Oracle software, then please contact your support representative or Oracle Support Services.

If you require training or instruction in using Oracle software, then please contact your Oracle local office and inquire about our Oracle University offerings. A list of Oracle offices is available on our Web site at www.oracle.com.
Preface

Intended Audience
See Related Information Sources on page xiii for more Oracle E-Business Suite product information.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trsif you are hearing impaired.

Structure
1 Introduction
Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

2 Predictive Trade Planning Concepts
Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.
3 Logging in and Getting Started
   Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

4 Working with Data
5 Oracle Demantra Dashboard
   Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

6 Managing and Viewing Quotas and Funds
   Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

7 Tracking Volume
   Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

8 Planning Promotions
   Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter describes how to create promotions and make changes if needed, as part of the TPO business process.

9 Promotion Calendars
   Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

10 Simulation and Optimization
    Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

11 Examining and Comparing Promotions
    Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

12 Reviewing Past Performance
    Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.
13 Creating Worksheets and Content Panes

**Important:** The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

14 Shipment and Consumption Planning

**Important:** The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

15 Reference

**Important:** The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter provides reference information for PTP series, levels, and methods.

16 Administration

**Important:** The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

### Related Information Sources

Oracle Demantra products share business and setup information with other Oracle Applications products. Therefore, refer to other user guides when you set up and use Oracle Demantra.

User Guides Related to Oracle Demantra:

- *Oracle Demantra Analytical Engine Guide*
- *Oracle Demantra User’s Guide*

Installation and System Administration Guides:

- *Oracle Demantra Implementation Guide*
- *Oracle Demantra Integration Guide*
- *Oracle Demantra Installation Guide*
- *Oracle Demantra System Requirements Guide*
- *Oracle Demantra Security Guide*
Integration Repository

The Oracle Integration Repository is a compilation of information about the service endpoints exposed by the Oracle E-Business Suite of applications. It provides a complete catalog of Oracle E-Business Suite's business service interfaces. The tool lets users easily discover and deploy the appropriate business service interface for integration with any system, application, or business partner.

The Oracle Integration Repository is shipped as part of the Oracle E-Business Suite. As your instance is patched, the repository is automatically updated with content appropriate for the precise revisions of interfaces in your environment.

Do Not Use Database Tools to Modify Oracle E-Business Suite Data

Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser, database triggers, or any other tool to modify Oracle E-Business Suite data unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus to modify Oracle E-Business Suite data, you risk destroying the integrity of your data and you lose the ability to audit changes to your data.

Because Oracle E-Business Suite tables are interrelated, any change you make using an Oracle E-Business Suite form can update many tables at once. But when you modify Oracle E-Business Suite data using anything other than Oracle E-Business Suite, you may change a row in one table without making corresponding changes in related tables. If your tables get out of synchronization with each other, you risk retrieving erroneous information and you risk unpredictable results throughout Oracle E-Business Suite.

When you use Oracle E-Business Suite to modify your data, Oracle E-Business Suite automatically checks that your changes are valid. Oracle E-Business Suite also keeps track of who changes information. If you enter information into database tables using database tools, you may store invalid information. You also lose the ability to track who has changed your information because SQL*Plus and other database tools do not keep a record of changes.
Part 1

Introduction and Basics
Introduction

Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:

- Overview
- Dashboard: Collaborator Workbench
- Predictive Trade Planning Business Processes and Worksheets
- Promotion Modeling and Optimization Business Processes and Worksheets
- Forecasting and Simulation
- Optimization

Overview

Oracle Demantra’s Predictive Trade Planning and Trade Promotion Optimization applications provide a complete Predictive Trade Planning (PTP) solution, is a powerful combination of a financial application to manage retailer trade funds coupled with a comprehensive promotion analysis tool specifically targeted at manufacturers for the purpose of better planning trade funds usage. The application considers sales, point of sale (POS), and syndicated data to provide advanced pre and post promotion analysis:

- Historical event evaluation, including detailed analysis of lift components, taking into account both direct and indirect effects
- Base volume forecast by item over time based on past history
- Event planning
- Incremental volume forecast based on user-defined promotional variables and causals (by product, time, price, vehicle, buydown, and so on)
• Detailed fund analysis, including quota versus actuals

• Event optimization taking into consideration a variety of constraints (time, budget, spend, number of events, and so on)

While Oracle Demantra’s PTP solution provides standard, out-of-the-box configuration to achieve this, it also recognizes that every manufacturer manages accounts and trade promotions a bit differently. The application is highly configurable, allowing Oracle Demantra consultants and trained users to tailor them to the customer’s needs, both today and as these needs evolve in the future.

**Dashboard: Collaborator Workbench**

The Collaborator Workbench is the starting point for Oracle Demantra’s PTP solution. You log into the application and immediately have access to a number of key performance indicators (KPIs), displayed inside content panes. PTP provides several out-of-the-box content panes, and you can add others.
From Collaborator Workbench, you can launch worksheets and review tasks. Each worksheet is a working environment designed to support specific business processes. In general, you can open worksheets from within Collaborator Workbench or from worksheets that are currently open.

For details, see Opening Worksheets, page 5-9.

See also Oracle Demantra User’s Guide.

Predictive Trade Planning Business Processes and Worksheets

For PTP business processes, you start in the Collaborator Workbench and launch any of the PTP worksheets. The following diagram shows the overall workflow:
PTP includes the following worksheets:

- **PTP: Quota and Fund Entry: Top-Down** allows headquarters to manage funds, including fund rates and fixed funds as well as sales quotas, at a fairly high level (yearly, for retailers and territories). PTP provides the following standard set of promotion funds: Brand Development Funds (BDF), Market Development Funds (MDF), and slotting funds. In turn, both BDF and MDF include a fixed portion (for fixed funds) and a volume-dependent portion, per common practice.

- **PTP: Quota and Fund Entry: Bottom-Up** is provided to help you fine-tune quotas and funds, by displaying their breakout, weekly, by promotion group. You can edit values at this level and they are automatically rolled up to the higher level. At all times, upper-level and lower-level numbers are automatically reconciled.

- **PTP: Quota and Fund View** is a read-only version of the bottom-up entry worksheet. It allows you to view authorized funds against your sales quota.

- **Volume Tracking** is the central location where product, territory, and account volumes are forecasted and monitored to ultimately feed volume requirements to operations. Fund planning already covered is integrated with volume planning, because forecast volumes drive budgets in live accrual environments and drive spending for case rate allowances and other variable spending deals.

- **Volume Tracking - Detail** is similar to Volume Tracking, but allows you to drill
down to the retailer level.

For details, see PTP: Managing and Viewing Quotas and Funds and PTP: Tracking Volume.

**Promotion Modeling and Optimization Business Processes and Worksheets**

For Trade Promotion Optimization (TPO) business processes, you generally start in the Collaborator Workbench, and then open the Planning Environment worksheet. From there, you right-click a promotion and launch any of the TPO worksheets to see data for that promotion. Or, to compare multiple promotions, you right-click a scenario and launch a worksheet to view the promotions in that scenario side-by-side. From within an open worksheet, you can also launch a different worksheet, to look at the same promotion in a different way.

The following diagram shows the overall workflow:
TPO includes the following worksheets:

- Planning Environment is the entry point to both historical and planned event analysis. Event planning consists of creating and managing a calendar of promotional events, and understanding their impact on sales, promotion spending, and profitability, as well as their correlation with sales quotas. The Planning Environment provides all this critical information in one place. See Planning Promotions - Introduction to the Planning Environment, page 8-1.

- PTP: Promo Effect - Mfg display the effects of future promotions, to show the impact on volume and spending, as well as a breakdown of the event with respect to the sales dollars and profit generated for the manufacturer. See Examining and Comparing Promotions - Examining Promotions from the Manufacturer's Point of View, page 11-2.
• PTP: Promo Effect - Rtl is similar to the previous worksheet, but shows the breakout of cannibalizing effects as a retailer would view them.

• PTP: Promotion Comparison helps you compare and evaluate multiple promotions in a scenario, so that you can determine how best to spend trade dollars. Typically you create multiple potential promotions in the Sandbox and compare them side by side here. See Examining and Comparing Promotions - Comparing Promotions in a Scenario, page 11-8

• PTP: Optimization Comparison provides the capability to simultaneously view and compare the results of a promotion before and after running optimization. After comparing, you can accept, reject, or re-optimize the promotion. Once satisfied with the results of a promotion, you can add it to your current plan. See Simulation and Optimization. Overview, page 11-2.

• PTP: Promo-Evaluation: Mfg and PTP: Promo-Evaluation: Rtl provide a detailed post-promotional analysis of each individual promotion (by compare forecast to actual performance), from the manufacturer’s point of view and the retailer’s point of view, respectively. Here, you can view the breakdown of each event with respect to the sales dollars and profit generated for the manufacturer and retailer. See
  • Reviewing Past Performance- Evaluating Performance from the Manufacturer’s Point of View, page 12-2.
  • Reviewing Past Performance- Evaluating Performance from the Retailer’s Point of View, page 12-5.

Forecasting and Simulation

Typically, the Analytical Engine is run periodically in batch mode, perhaps weekly, to generate a forecast for all items and locations in the system. The forecast data includes total volume, base volume (volume in the absence of promotions), pre- and post-promotional volume, and volume due to cannibalization. This forecast, including the detailed breakdown of promotional effects, is available for future dates and for the past—so that you can better understand promotions that have already run.

Running the Analytical Engine in batch mode may take hours, depending on the volume of data, so PTP also provides the ability to run simulations. You can run a simulation quickly, see the results, and accept or reject them.

A simulation generates a forecast for a much smaller set of data, typically a single promotion, and provides immediate data for the total volume, base volume (volume in the absence of promotions), pre- and post-promotional volume. Depending on where you perform a simulation, you may also be able to see cannibalization; this depends on whether the worksheet contains all the data that the Analytical Engine needs to find cannibalization effects.
The effectiveness of a promotion depends on many factors, as noted earlier. To help you find the most effective promotion for your needs, PTP provides the ability to optimize a promotion.

The Promotion Optimization module uses the previously stored results of the Analytical Engine and information about past variations in the promotions. You provide a specific goal (optimizing units, revenue, or profit) and constraints (such as minimum retailer margin), and the optimizer determines the best set of promotion properties.
Predictive Trade Planning Concepts

Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:
- Worksheet Basics
- PTP Data Hierarchy
- Promotions
- Retailer Profiles
- Funding
- Promotion Costs and Spending
- Volume and Volume Breakdown
- Data Access

Worksheet Basics
This section provides a closer look at the basic data elements in worksheets, introduced previously in "Tutorial: Getting Acquainted with Worksheets."

Levels (Segmentation)
A level lets you aggregate or group data in a worksheet.
For example, if you select a territory, then a retailer, and then a product category to display, the data in the rest of the worksheet is aggregated across this territory, retailer, and category.

Oracle Demantra uses several different kinds of levels:

- Item levels group and aggregate data according to characteristics of the items you sell. For example, PTP item levels include brand, category, and promotion group.

- Location levels group and aggregate data according to the locations where they are sold. For example, PTP location levels include retailer, territory, and so on.

- Promotion levels correspond to promotional events.

In generic terminology, the word member refers to a unit within a level. For example, Alberton’s is a member of the retailer level.

### Series (Measures)

A worksheet table or graph displays series data associated with the current selection.

<table>
<thead>
<tr>
<th>Scenarios</th>
<th>Promotion</th>
<th>Start Ship</th>
<th>End Ship</th>
<th>Start Event</th>
<th># Weeks</th>
<th>Veh Type</th>
<th>Veh $</th>
<th>Cons Promo</th>
<th>Shelf Price</th>
<th>Sale Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sandbox</td>
<td>Test Opti Senc</td>
<td>04/03/2005</td>
<td>4</td>
<td>FEATURE</td>
<td>$20,000</td>
<td>N/A</td>
<td>$5.99</td>
<td>$4.19</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Test New promotion</td>
<td>05/05/2005</td>
<td>2</td>
<td>FEATURE</td>
<td>$10,000</td>
<td>N/A</td>
<td>$5.99</td>
<td>$5.29</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Test Past End Dta</td>
<td>01/06/2005</td>
<td>1</td>
<td>FSD</td>
<td>$4</td>
<td>N/A</td>
<td>$5.99</td>
<td>$1.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Test CAMlization</td>
<td>02/12/2005</td>
<td>1</td>
<td>FEATURE</td>
<td>$5,000</td>
<td>N/A</td>
<td>$5.99</td>
<td>$2.29</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Current Year</td>
<td>Fall back pricing</td>
<td>07/07/2005</td>
<td>1</td>
<td>F SHOFFER</td>
<td>$1,250</td>
<td>N/A</td>
<td>$5.99</td>
<td>$5.23</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Hot sales days</td>
<td>03/03/2005</td>
<td>1</td>
<td>FEATURE</td>
<td>$5,000</td>
<td>N/A</td>
<td>$5.99</td>
<td>$1.99</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Summary</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

PTP provides many kinds of series:

- Some series describe properties of item-location combinations; for example, Sales Quota. Others describe properties of promotions; for example, Veh Type.

- Most series have numeric values, but some have string or date values. For some series (like Cons Promo and Veh Type), you choose a value from a dropdown list.

- Some series are editable, some are editable only for specific dates, and some are not editable at all.

- Some are based on imported data.

- Some series are shown in different colors, depending on the data values or on other local conditions. For example, Incr Mfg Prft is shown in red if profit is negative.
PTP Data Hierarchy

PTP uses specific levels, organized into a flexible set of hierarchies. Some of these levels are not used in PTP worksheets, but are available if needed for reporting. Products are organized into several hierarchies, and locations are organized into another set of hierarchies. This section provides an overview.

**Product Hierarchies**

The lowest item level is the Item. PTP organizes items into four hierarchies.

**The Manufacturer Hierarchy**

In the manufacturer hierarchy, items belong to brands. Brands, in turn, belong to manufacturers.

```
Highest item level, which aggregates data across all items

Manufacturers

Brands

Items
```

**The Category Hierarchy**

In the category hierarchy, items belong to brands, which belong to segments. Segments belong to categories.
The Promotion Group Hierarchy

In the promotion group hierarchy, items are organized into promotion groups. Promotions are usually created at this level, applying to entire sets of items.

The Product Line Hierarchy

In the product line hierarchy, items are organized into product subgroups, which are organized into product groups, which are organized into product lines.

Location Hierarchies

PTP provides two location levels that are both at the same (apparent) lowest level. These levels are Ship To and Territory. Internally, PTP has only one lowest location level, which is a combination of Ship To and Territory, created automatically by Oracle Demantra.

Ship To Hierarchies

Ship To locations are organized by Bill To locations, as follows:
Ship To locations are also organized by retailer.

**Territory Hierarchy**

The Territory locations are organized in a single, fairly deep hierarchy. Territories are grouped into districts, which are grouped into regions. Regions, in turn, are grouped into sales areas, which are grouped into divisions, which are grouped into companies. The following figure sketches these relationships without indicating the members of each level:
The Territory-Retailer Level

PTP also uses another level, the combined territory-retailer level, for analytic purposes. This level is meant for use only by the Analytical Engine.

Promotions

A promotion is an occurrence that starts at a specific date, has a certain duration, and has a certain time-varying effect on sales. PTP models promotions as another kind of level, as mentioned earlier, so that they can be used in worksheets in all the same ways as item and location levels.

In PTP, you usually create promotions at the retailer-promotion group level. Multiple promotions can be associated with a retailer and promotion group during the same time bucket.

How PTP Uses Promotion Properties

PTP models a common set of promotion properties that are known to affect the impact of promotions. These properties include the following:
• Vehicle type
• Sale price
• Promotion timing and duration

Each of these properties can have a different effect on the forecast or simulations. When the Analytical Engine runs (either in batch mode or simulation mode), it uses mathematical models to determine what effect each property had in the past. It uses this information to predict how each future promotion will behave.

These properties also affect how the Promotion Optimization behaves. See Optimizing a Promotion, page 10-6.

Promotions and Scenarios

Because it is useful to separate tentative promotions from real ones, most PTP worksheets organize promotions into two scenarios: Current Year and the Sandbox. When you create a new promotion, you place it in the Sandbox as long as it is tentative. When the promotion is definite (when mark its status as Planned), then you should move the promotion to the Current Year scenario.

A third scenario, actuals, contains promotions from previous years. These promotions are excluded from most PTP worksheets because they fall outside the span of time used in these worksheets.

Promotion Life Cycle and Status

PTP models a distinct life cycle for every promotion. The Event Status series shows the stage in which a given promotion resides; you can see this series in the Planning Environment and other worksheets. Typically a qualified user changes the status when appropriate.

1. When a promotion is first created, its status is initialized as Unplanned. Unplanned promotions are considered hypothetical and do not have an impact on the promotion funds or the forecast.

2. Typically you run a simulation to see the baseline and incremental volume for the proposed promotion. In addition, the system will calculate measures to be used for the cost benefit review. These include profit for the manufacturer and retailer, available fund balances as well as the proposed cost for the promotion.

3. Once you are ready to use the event in forecasting, you change its status event to Planned. This causes several things to happen:
   • The cost of the promotion is deducted from the available balance of funds.
   • The forecast is updated.
4. The next stage is approved.

5. When you have a firm commitment from the retailer, you move the promotion to the committed stage. When a promotion is marked as committed, PTP takes a snapshot of details of the promotion, for use in later analysis. With this information, it will be possible to compare the total projected sales with the total actual sales, for example.

Once a promotion has been committed, it is no longer editable.

6. After the promotion runs, the retailer may require payment for the promotion. You can advance the status to Partial Paid or to Paid to record the payment status.

7. Finally, the last stage is closed.

Retailer Profiles

Given that different retailers run different types of events differently, PTP stores retailer profiles that include details such as the following:

- Average everyday selling margin
- Minimum required event margin
- Default vehicle costs for each type of event

When you create a promotion of a given type for a retailer, PTP automatically initializes the vehicle cost as appropriate for that retailer, saving you the work of making a manual adjustment each time. You can override this vehicle cost if necessary.

The other retailer details affect the optimization process, which finds the best possible promotion for a given goal, considering the retailer-specific constraints.

PTP provides default settings that you can use for any retailer, so that you can start by providing details for just a few key retailers, without needing to enter all of them. You can modify these default settings as needed.

Funding

PTP provides the following standard set of promotion funds:

- Brand Development Funds (BDF)
- Market Development Funds (MDF)
- Slotting funds

In turn, both BDF and MDF include a portion for fixed funds and a volume-dependent portion, per common practice. For example, the total authorized BDF fund is computed
as follows:

rate * volume + fixed funds

This means that when the planned volume increases, you accrue funding. That is, the authorized funding also increases.

In the Planning Environment, the Fund Balances window displays a summary of the funds and their balances. To set fund amounts, see PTP: Managing and Viewing Quotas and Funds - Overview, page 6-1.

**Promotion Costs and Spending**

Following standard practice, PTP models the promotional spend as a combination of fixed spending and per-unit spending. Specifically, apart from slotting costs, the spend for a given promotion is computed as follows:

vehicle costs + volume * buydown

For a given retailer, each vehicle type is assumed to have its own default cost. When you specify the vehicle type for a promotion for a retailer, PTP looks up and displays that cost. You can override this cost if necessary. As part of specifying the promotion details, you also specify the buydown, or discount per promoted unit that will be paid to the retailer (either as billback from the retailer or as an off-invouse settlement with the retailer).

In addition to specifying the promotion cost as described here, you also control how that promotion is to be funded. Specifically, when you mark a promotion as planned, you indicate how to split the cost between MDF and BDF; see Marking a Promotion as Planned, page 8-8.

**Volume and Volume Breakdown**

In general, PTP volume calculations use actuals for the past and forecasted volume for the future. So to compute volume as needed for total MDF or BDF funds for the year, PTP combines the actuals to date and the forecast.

In addition to providing the overall volume, PTP shows a breakdown of that volume into the following categories:

- Base volume.

- Incremental volume due to a promotion. Part of this incremental volume is due to cannibalization effects. The manufacturer and the retailers have different points of view about cannibalization, as noted below.

- Pre and post-promotional effects. Sales are usually lower just before and after a promotion, as consumers take advantage of the better price during the promotion itself. The Analytical Engine computes the total volume before and after the
Cannibalization

In addition to computing the incremental volume due to a promotion, the Analytical Engine computes specific cannibalization effects. Cannibalization includes multiple components, and the manufacturer and the retailer have different points of view.

- **Product switching**, as described in Cannibalization Seen by the Manufacturer, decreased sales due to sales at another retailer.

- Decreased sales of other products of the same brand at the same retailer. For example, sales of Exedra 24 were depressed by the promotion on Exedra 100, at the same retailer.

- Decreased sales of other brands (of the same manufacturer), regardless of retailer. For example, sales of Advo 50 were depressed by the promotion on Exedra 100, which is made by the same manufacturer.

**Cannibalization Seen by the Manufacturer**

PTP computes cannibalization that is undesirable to the manufacturer.

This worksheet table shows a promotion group where a promotion was run and all promotion groups that were adversely affected, according to the manufacturer.

The row in blue indicates the promotion group (Exedra 100) on which you ran a promotion. In this row, you can see the total event dollars, incremental event dollars, net incremental event dollars and so on, for the promotion. Note that for Exedra 100, there was zero dollars of cannibalization and $2324 of pre- and post-promotional effect.

On the other hand, examine the other promotion groups here and notice that they were all cannibalized. Of course, for these promotion groups, there was zero direct lift, by definition, as the promotion did not run on them.

**Cannibalization Seen by the Retailer**

PTP also computes cannibalization that is undesirable to the retailer.
This worksheet table shows a promotion group where a promotion was run and all promotion groups that were adversely affected, according to the retailer. As before, the row in blue indicates the promotion group (Exedra 100) on which you ran a promotion.

Notice two promotion groups are listed here that were not seen in the manufacturer version: Notrim 24 and Tyitol 50. These promotion groups represent products that this retailer sells, but that are made by a different manufacturer. To the retailer, it is undesirable to cannibalize these promotion groups.

**Data Access**

Once customer data is loaded, an administrator can configure a security access level for each user.

The Paste method is enabled for any level that has Write or Full Control permission in the component.

- If you do not have access to the target population, the Paste method is not visible
- If you have partial access to the target population the method Paste is visible but when the method is executed, read-only members are removed from the population.

For levels with a population attribute:

- When creating a new promotion, the default population is a merge of the worksheet levels and the population of the level member from where the method was invoked.
- Members of the population with Read-Only or No Access are excluded.

See Also: "Security" in the *Oracle Demantra Implementation Guide*
Logging in and Getting Started

**Important:** The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:
- Initial Log in and Download
- Logging in to PTP
- Tutorial: Getting Acquainted with Worksheets
- Controlling Synchronization of Embedded Worksheets

**Initial Log in and Download**

The first time you log in to PTP, Oracle Demantra typically downloads and installs software. This operation occurs only once for each machine you use.

1. Open Microsoft Internet Explorer.

2. Enter the web address supplied by your system administrator. This URL probably has the following format:

   http://server name/virtual directory/portal/partnerLogin.jsp
   
   For example:

   http://frodo/demantra/portal/partnerLogin.jsp

   **Tip:** Your Windows Start menu may also include a shortcut to this URL.

3. Type your name and password and click Login.

   Oracle Demantra prompts you to install JRE.
4. When you are prompted to install Sun JRE 1.4.2_10, do so. Choose the Typical installation and accept all the default values, unless otherwise advised by your system administrators.

   **Note:** Oracle Demantra uses Sun JRE 1.4.2_10. If you are prompted to install a later version of JRE, do not do so.

   To prevent Java from searching for updates, open the Java control panel. On the Update tab, make sure to deselect the check box Check for Updates Automatically.

Next, Oracle Demantra displays a dialog box that asks if you want to trust the signed application distributed by Oracle. The dialog box is slightly different depending on your configuration.

5. Click Yes (or Always) or Start, depending on which dialog box is displayed.

   After the initial configuration is completed, Oracle Demantra displays a new browser window. The page contains a menu bar, a tool bar, and a work space that is initially empty.

   ![Menu Bar, Tool Bar, and Work Area](image)

   - **create new worksheet**
   - **open existing worksheet**
   - **work area**

6. Click File > Open.

7. Click a worksheet in the list and then click Open.

   Now the work area displays a worksheet, and the menu bar and tool bar have many more options.

   See also
   - Creating or Editing a Worksheet or Content Pane, page 13-3.

---

**Logging in to PTP**

If you have already performed the initial setup (see Initial Logon and Download, page 3-1), then log in as follows.
To log in to PTP:
1. Open Microsoft Internet Explorer.
2. Enter the web address supplied by your system administrator. This URL probably has the following format:
   http://server name/virtual directory/portal/partnerLogin.jsp
   For example:
   http://frodo/demantra/portal/partnerLogin.jsp
   **Tip:** Your Windows Start menu may also include a shortcut to this URL.
3. Type your name and password, and then click Login.
   You can access Oracle Demantra Predictive Trade Planning worksheets using:
   • Collaborator Workbench
   See also *Oracle Demantra User’s Guide*.

Tutorial: Getting Acquainted with Worksheets
To view and edit data, you work within an environment called a worksheet. Each worksheet is a working environment designed to support specific business processes. However, all worksheets share certain common characteristics and behavior. This exercise is meant to help you get acquainted with any worksheet.
2. If the worksheet does not show data, click Data > Rerun. Or click the Run button.
3. Scan the windows within the worksheet.

First, most worksheets contain an area that you use to select the data to display. This area is sometimes displayed as a treelike hierarchy).

When you make a selection here, that changes anything of a lower level that is displayed elsewhere in the worksheet. For example, if you change the selection, you would see different promotions.

Second, worksheets contain two different kinds of tables, and it is important to know the difference between them. The first kind of table is a normal table.
The other kind of table is an embedded worksheet and appears as a tab within a tile. PTP uses embedded worksheets where they are needed for technical reasons.

Both kinds of tables are labeled to indicate what they contain.

For PTP, there is one behavioral difference between these kinds of tables:

- When you select a row in a normal table, that may affect selections elsewhere in the worksheet. For example, if you click in a promotion row, the worksheet focus moves to that same promotion throughout the worksheet, including the embedded worksheets.

  **Note:** If you use the keyboard to move within a table, notice that the embedded worksheets are not automatically refreshed, for performance reasons.

- In contrast, when you select a row in an embedded worksheet, that has no effect on the focus in the rest of the worksheet.

A worksheet may also include graphs. Note that even if you click the graphs, it would have no effect on them. Note that you can change the graph style; see Changing the Graph Style

4. Right-click a data cell in one of the tables. Notice that you have options to copy and paste data, to edit multiple cells, and to display associated notes.

5. Right-click a promotion in the non-scrolling part of a worksheet table.
Notice that the right-click menu here provides options for working with promotions. Depending on your permissions, you may be able to do any of the following:

- View promotion attributes in a pop-up dialog box.
- Edit those attributes.
- Create new promotions.
- Copy, paste, or delete promotions.
- Open a promotion in a different worksheet (via the Open or Open With options).

**Note:** When you open a worksheet this way, it is filtered to show just the promotion from which you launched it. Notice that the name of the promotion is added to the beginning of the worksheet title.

The right-click menu is also available for scenarios, in worksheets that display scenarios.

**Controlling Synchronization of Embedded Worksheets**

The embedded worksheets worksheet may or may not be synchronized with the rest of the worksheet. A worksheet runs faster if synchronization is off. On the other hand, you might find it less confusing to keep synchronization switched on. Also note that only promotion status changes have any effect on the data in embedded worksheets.

**To control the synchronization:**

Do one of the following:

1. Click one of the following toggle buttons in the tool bar.
   - Automatically synchronize the embedded worksheets with the rest of
worksheet

- Synchronize on demand

2. Select Options > Synchronize On Demand or Synchronize Automatically.
Working with Data

This chapter covers the following topics:

- Editing Data
- Saving and Viewing Changes
- Sorting Worksheet Data
- Copying and Pasting Data
- Copying and Pasting to and from Microsoft Excel
- Exporting Data to Microsoft Excel
- Linking Data into Third-Party Reporting Tools (via DOL)
- Printing
- Viewing Notes
- Editing Notes
- Viewing and Managing Attachments to Notes
- Specifying Note Permissions
- Refreshing the Local Worksheet Cache
- Viewing the Audit Trail

Editing Data

This chapter describes the basics of working with data: how to edit data, add notes and attachments, print, exchange data with outside tools, and so on. It includes the following sections:

You can usually edit data in a worksheet, although not all series are editable. Note that within a given worksheet, if some of the tabs or windows show data at a higher aggregation level, the data is not editable in those tabs or windows.
**Note:** Within Oracle Demantra, do not use the following special characters:
- Single quote (’)
- Double quote ("")
- Ampersand (&)

If you use these characters, unexpected results may occur.

**To change a data value manually**
1. Select an editable data cell (white). The cell appears contained in a box.
2. Edit the value as needed.

**To update multiple cells**
1. In the table, select a range of cells.
2. Right-click the selection and then select Edit Cells. The Edit Cells dialog box appears.
3. In the dialog box, type a new value and then click OK.

**To edit a retailer or a promotion**
1. Right-click the retailer or promotion and then select Edit Retailer or Edit Promotion.
2. Edit as needed and then click OK.

**Note:** Your changes are saved immediately in this case and cannot be undone.

**To undo**
Do one of the following:
- Click Edit > Undo.
- Click Data > Reset Manual Changes. This option restores the worksheet data to the
To redo an action
Click Edit > Redo.

See
• Saving and Viewing Changes,
• Copying and Pasting Data,

Saving and Viewing Changes
Apart from minor adjustments to the worksheet layout, the changes you make are not saved automatically.

Saving Changes
You save changes to data separately from changes to the worksheet definition:
• To save changes that you have made to the data in the worksheet, including changes to notes, click Data > Save Data. Or click the Save Data button.
• To save changes that you have made to the worksheet definition, click File > Save Worksheet. Or click the Save Worksheet button.
  • If you own the worksheet, this option saves the basic worksheet definition and its initial layout. For information on changing the worksheet definition, see Creating or Editing a Worksheet or Content Pane, page 13-3.
  • If you do not own the worksheet, this option saves only your own layout of the worksheet.

See Worksheet Definition, Layout, and Local Adjustments, .

Controlling the Recalc Option
Usually at least some of the read-only series are computed by means of a local expression. By default, Oracle Demantra recalculates all local series expressions automatically. In some cases, you may want to switch off this automatic recalculation:

To switch the Recalc option off
Click Data > Set Data Recalc Off. Or click the Recalc Off button.
To force calculation while Recalc is off
Click Data > Calculate.

To switch the Recalc option on
Click Data > Set Data Recalc On. Or click the Recalc On button.

Viewing Pending Changes to Data

To see pending data changes
1. Click Data > Update to save your data changes.
2. Click Data > Process Monitor. Oracle Demantra displays a screen that shows all data saves that are waiting to be processed.

If you are working at a relatively high level, this takes longer to run.

Sorting Worksheet Data

By default, the worksheet table is sorted in ascending order, according to the current contents of the x-axis, which is usually time. You can sort the worksheet table in either ascending or descending order, according to any series that is displayed in the table.

To sort the worksheet table
Click the header of the column by which you want to sort the worksheet.
Oracle Demantra then sorts the entire worksheet table, putting entries in this column in descending order. A downward arrow is added to the column header, to indicate that the table is sorted by this column.

<table>
<thead>
<tr>
<th>Time</th>
<th>Fixed Plan Lift</th>
<th>Last Year Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>03/01/2004</td>
<td>10,000</td>
<td>475,854</td>
</tr>
<tr>
<td>02/02/2004</td>
<td>372,066</td>
<td>147,741</td>
</tr>
</tbody>
</table>

To resort in ascending order, click the column header again. Oracle Demantra resorts the table and changes the direction of the arrow.

**To restore the default sorting order of the worksheet table**
Click View > Reset Table Sort.

**Copying and Pasting Data**
You can copy and paste data within the worksheet table.

**Note:** From a worksheet, you can also paste data to different Windows products.

**To copy data**

1. Within a worksheet, do one of the following:
   - In the table, select a cell whose value you want to copy.
   - To copy values from more than one cell, click the first cell, and then drag the mouse to select all cells you want to include.

2. Right-click and then select Copy. Or click Edit > Copy.

**To paste data**

1. Do one of the following:
   - In the table, select the cell into which you want to paste the data.
   - To paste values into more than one cell, select the upper left data cell of the block of cells into which you want to paste.

2. Right-click and then select Paste. Or click Edit > Paste.
See

Saving and Viewing Changes,

**Copying and Pasting to and from Microsoft Excel**

You can copy and paste data from a worksheet to Excel and vice versa.

**To copy and paste data to Excel**

1. Within a worksheet, copy data as described in "Copying and Pasting Data."
2. Start Microsoft Excel, open a worksheet, and select a cell or block of cells.
3. Right-click and then select Paste.

**To copy and paste data from Excel**

1. Start Microsoft Excel and open a worksheet.
2. Select one or more cells.
3. Right-click and then select Copy.
4. In Oracle Demantra, select the cell or cells into which you want to paste the data.
5. Right-click and then select Paste. Or click Edit > Paste.

**See also**

Exporting Data to Microsoft Excel,
Linking Data into Third-Party Reporting Tools (via DOL),

**Exporting Data to Microsoft Excel**

You can export worksheet data to Excel. Your computer’s regional settings can affect the results; see the note.

**To export data to Excel**

1. Within a worksheet, click File > Export. Or click the Export to Microsoft Excel button.
   An export dialog box appears.
2. Select Current Combination to export data currently displayed, or Entire Worksheet
to export all data from the worksheet.

3. Click OK.

A Save page appears.

4. Define the location where the worksheet data will be saved and enter a name for the file.

5. Click Save.

**Note**

When receiving data from an external source, Microsoft Excel uses the Regional Options in the Windows Control Panel to determine whether a given cell should be formatted as Currency or General (as is or text). This means that if you export Oracle Demantra data that is formatted with a currency symbol, and if the Windows Control Panel uses a different currency symbol, those cells will appear in Excel as text values.

If you export to Excel and you receive text values where you wanted currency values, do the following:

1. Open the Windows Control Panel.

2. Double-click Regional and Language Options.

3. On the Regional Options tab, make sure that the Currency setting uses the same currency symbol as Oracle Demantra.

4. Export again from Oracle Demantra.

Later versions of Excel provide an option for converting problematic cells that it recognizes.

See

Copying and Pasting to and from Microsoft Excel,

Linking Data into Third-Party Reporting Tools (via DOL),

**Linking Data into Third-Party Reporting Tools (via DOL)**

When you work within a third-party reporting tool, you can import a Oracle Demantra worksheet via Oracle's Dynamic Open Link (DOL) technology. This technology lets you use any reporting tool that can connect to the Oracle Demantra database.

Oracle Demantra provides a web page (http://server name/virtual directory/portal/DOL_HTML.htm) to which you can link from your reporting tool, such as Microsoft Excel). Then to access the latest Oracle Demantra data, you can use the refresh functionality within that reporting tool.
The following steps describe how to link Oracle Demantra data into Excel, as an example.

**Note:** The details here may vary depending on the version of Excel. Consult the Excel documentation for information about "web queries."

**To create a worksheet report in Excel**

1. In Microsoft Excel, open the Data menu.

2. Click Get External Data and select New Web Query.

The New Web Query screen appears.

3. Click Browse Web..., which displays a browser.

4. In the address bar, type the following URL and then click Go:
   
   http://server name/virtual directory/portal/DOL_HTML.htm

   For example:

   http://frodo/demantra/portal/DOL_HTML.htm
A login page appears.

![Login Page](image)

5. Type your Oracle Demantra user name and password and click Login.

The browser now displays a list of worksheets.

![Worksheet Dropdown](image)

6. Select a worksheet from the dropdown list and click Confirm.

The worksheet opens in your browser in non-editable HTML format.

7. Optionally close the browser window.

8. Return to Excel, which is still displaying the same dialog box as before.

9. For step 2, select The entire page.

10. For step 3, select Full HTML formatting.

   **Note:** To save the query for repeat use, click Save Query...

11. Click OK.

Excel asks where to put the data.
12. Make your choice and click OK.

The Oracle Demantra worksheet opens in Excel.

See

Copying and Pasting to and from Microsoft Excel,
Exporting Data to Microsoft Excel,

Printing

To print the displayed data

1. Click File > Print. Or click the Print button on the toolbar.

   The Print Settings dialog box appears.

2. Select the required options.

<table>
<thead>
<tr>
<th>Content selection</th>
<th>Specify whether to print the currently selected item-location combination, all combinations in the worksheet, or the screen.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout</td>
<td>Choose portrait or landscape orientation.</td>
</tr>
<tr>
<td>Paper</td>
<td>Choose a paper size.</td>
</tr>
<tr>
<td>Font</td>
<td>Choose a font size.</td>
</tr>
<tr>
<td>Object selection</td>
<td>If this worksheet includes a Gantt chart, this option lets you specify whether to include the Gantt chart in the printout.</td>
</tr>
</tbody>
</table>

3. If this worksheet includes a Gantt chart, optionally click the Gantt Settings tab. On this tab, specify which promotion attributes to include in the print-out.
4. Click OK.

5. Oracle Demantra displays the normal system print dialog box, where you choose the printer to use, the number of copies to make, and so on.

6. Make selections as you would normally do.

7. Click OK.

**Viewing Notes**

You can add notes to record comments and reminders. You attach the note to combination and date or dates. The worksheet table displays indicator symbols on those dates, generally in only some of the columns (depending on how your system is configured).

| 471,400  |
| 158,100  |
| 603,000  |
| 161,500  |
| 259,800  |

The graph displays an indicator as well.

You can see notes in two different areas:

- In the Notes dialog box.
In the Notes/Attachments subtab, if this is included in your worksheet. This subtab also displays any associated attachments.

To open the Notes page

Do one of the following:

- In the table, right-click a cell and select Notes... The note will be associated with only this row.
- In the table, select one or more rows, right-click and then select Notes.... The note will be associated with each of the selected rows.
- In the table, double-click the left (non-scrolling) column. (Depending on how Oracle
Demantra is configured, this action may not bring up the Notes page.)

- In the graph, hold the mouse button over a point, right-click and then select Notes...

**To display the Notes/Attachments subtab**

See

- Specifying the Worksheet Elements in a View, page 13-24
- Editing Notes,
- Viewing and Managing Attachments to Notes, , and
- Specifying Note Permissions,

**Editing Notes**

First display the Notes page or the Notes/Attachments subtab; see Viewing Notes, . In the upper part of the worksheet, click the element to which you want to attach this note.

**To add a note**

1. If the Note box is gray (uneditable), click the Add button.
2. Type a note in the Note box.
3. If you are working in the Notes/Attachments subtab, you can optionally upload an attachment See Viewing and Managing Attachments to Notes, .
4. Click the Save button.

**To edit a note**

1. Select a note and click the Edit button.
2. Type a note in the Note box.
3. If you are working in the Notes/Attachments subtab, you can optionally upload an attachment See Viewing and Managing Attachments to Notes, .
4. Click the Save button.
To delete a note

1. Select a note and click the Delete button.
   The Confirm Delete message box appears.

2. Select one of the following:
   • Partial Deletion (deletes the note only from the current member and date)
   • Total Deletion (deletes the note from all members and dates)

3. Click OK.

4. Click Save.

See
• Viewing Notes,
• Specifying Note Permissions,

Viewing and Managing Attachments to Notes

You can attach files to the notes, and Oracle Demantra uploads those files into the database (in compressed form). To view and manage attachments, you work in the Notes/Attachments subtab of your worksheet.

To add an note attachment to a

1. Click the note.

2. Click Details.
   Oracle Demantra displays the Note Details screen.
3. Click Add.

4. Find the file that you want to attach and then click Open.
   Oracle Demantra uploads a compressed version of the file into the database.

5. Click OK.

**To remove an attachment from a note**

1. Click the note.

2. Click Details.
   Oracle Demantra displays the Note Details screen:

3. Click the row that lists the attachment and then click Remove.

4. Click OK.

**To download an attachment**

1. Click the note.

2. Click Details.
   Oracle Demantra displays the Note Details screen.
3. Click the row that lists the attachment and then click Download.

4. Specify the directory and filename for the downloaded file and then click Save.

5. Click OK.

See
• Viewing Notes,
• Specifying the Worksheet Elements in a View, page 13-24

Specifying Note Permissions

In general, notes (and their optional attachments) can be viewed by other users. You can specify permissions for the notes, to determine who can read the note and what type of access they are permitted. You can specify permissions for groups or for specific users.

To specify permissions for a note and its attachments

1. On the Details tab, select the note.

2. Click the Permissions tab.

3. Select the User Permissions or Group Permissions tab.

4. For each user or group that should have non-default settings for this note, move that user or group from the left list to the right list (Selected Users or Selected Groups). Use any of the techniques in "Working with Lists."

   **Note:** Read-only is the default setting for non-selected users or groups.

5. Remove any unwanted users or groups from the right list.

6. Then for each user or group in the right list, do the following:
   1. Click the user or group.

   2. Select a setting from the Permission dropdown list at the bottom of the page.

   The following options are available:

<table>
<thead>
<tr>
<th>Permission</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read and Write</td>
<td>Enables the user or group to read the notes list, edit notes, and add notes.</td>
</tr>
<tr>
<td>Permission</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td>Read Only</td>
<td>Enables the user or group to read the notes list.</td>
</tr>
<tr>
<td>Not Visible</td>
<td>Makes the note list not visible to this user or group.</td>
</tr>
<tr>
<td>Full Control</td>
<td>Enables the user or group to read the notes list, edit notes,</td>
</tr>
<tr>
<td></td>
<td>add notes, and delete notes.</td>
</tr>
</tbody>
</table>

7. Click Save.

8. Click Close.

**Group and user permission priorities**

- User permissions take precedence over permissions of any groups the user belongs to.
- If a user belongs to more than one group, the highest level of permissions from the associated groups will be granted.

See Viewing Notes,.

**Refreshing the Local Worksheet Cache**

Depending on the definition of a worksheet, Oracle Demantra may store a local copy of the worksheet data on your machine, for faster performance. Also depending on the worksheet definition, the cache may be refreshed automatically or may require periodic refreshing by you.

**To refresh your local worksheet cache**

Click Data > Refresh worksheet data cache.

See

- Saving and Viewing Changes,
- Configuring the Basics, page 13-4

**Viewing the Audit Trail**

Oracle Demantra automatically records changes in an audit trail. The audit trail includes changes due to edits within worksheets, copy/paste actions, and changes caused by import, and so on.
Note: You can see only changes that were made by you or other users who are in the same collaboration groups as you.

Oracle Demantra provides two ways to view the audit trail:

- You can view the changes that have occurred to the item-location combination that is currently displayed in the worksheet.

- You can create and then execute a profile that specifies a wider set of data: multiple combinations, a wider span of time, and so on.

In either case, the audit trail looks like this:

The top part of the page lists the changes. When you select a row in this table, the bottom part of the page lists details corresponding to that row.

- The Series Values tab displays details on the series that were changed.

- The Aggregate Level Population tab displays the specific aggregation levels to which this change applies. The change could have occurred at a different aggregation level.

- The Filtered Population tab displays the filtering that was used at the time of this change.
Viewing the Audit Trail for a Specific Combination

To view the audit trail for a combination

1. In a given worksheet, select a combination.

2. Click Data > Audit Trail.

   If any changes have occurred to this combination, the Audit Trail screen appears, displaying a table with one row for each recorded change. The following information is displayed:

   | Audit Date | Date when change was made. |
   | User Name  | User who made the change   |
   | Update Mode| Indicates the type of change: Manual, BLE (Business Logic Engine) or Integration |
   | Unit Name  | Unit of measure that was used at the time of the change |
   | Index Name | Index that was used at the time of the change |
   | Series List| Series affected by the change |
   | Status     | In Progress, Fail, or Success |

3. To see specific details on this change, click a change in this table and then click the Series Values tab.

   This tab displays the following information:

   | Series Name | Name of the series that was changed. |
   | Series Value| New value used in this series. |
   | Original Value| Original value in this series. |
   | From Date   | First date in the series when the change occurs. |
   | To Date     | Last date in the series when the change occurs. |
4. To see the specific aggregation levels to which this change applies, click the Aggregate Level Population tab. The change could have occurred at a different aggregation level.

5. To see the filtering that was used at the time of this change, click the Filtered Population tab.

**Viewing the Audit Trail for Other Data**

An audit trail profile enables you to select a specific portion of the audit trail so that you can view changes that affect more than one combination.

**To create or modify an audit trail profile**

1. Click File > Audit Trail.

2. Then:
   - To create a new profile, click New.
   - To modify a profile, click an audit trail profile name and click Modify.

   The wizard displays a properties screen.

3. In the Name and Description fields, type a name and optional description.

4. If you want to share this audit trail profile with others, click Public.

5. Click Next.

   The wizard prompts you for information about the changes you want to see.

6. For Source Type, select the check box for each type of change you want to see. Here, BLE represents the Business Logic Engine.

7. For each user whose changes you want to see, move the name from Available Users to Selected Users.

8. Click Next.

   The wizard prompts you for the range of time you are interested in.

9. For Time Filter, select Relative or Fixed, depending on whether you want to define a window of time relative to today.

10. For From Date and To Date, specify a range of dates.

11. Click Next.
The wizard prompts you to specify the aggregation levels you are interested in.

12. For each aggregation level that you are interested in, move that level from Available Filter Levels to Selected Filter Levels.

13. Click Next.

The wizard prompts you to specify the series you are interested in.

14. For each series that you are interested in, move that series from Available Series to Selected Series.

15. Click OK.

16. Click Close to exit the wizard.

To use an audit trail profile

1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Execute.

   Oracle Demantra displays the specified part of the audit trail. See Viewing the Audit Trail, .

To delete an audit trail profile

1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Delete.

4. Click Yes.
Part 2

Business Processes
This chapter covers the following topics:

- Introduction to the Dashboard
- Reviewing Metrics
- Reviewing the Planning Hierarchy
- Editing Retailer Information
- Opening Worksheets
- Managing Tasks
- Creating and Sending a Task
- Personalizing the Dashboard
- Configuring Your Default Layout
- Configuring My Tasks
- Configuring My Worksheets

Introduction to the Dashboard

This chapter introduces the Oracle dashboard: Collaborator Workbench.

Oracle’s Collaborator Workbench is a starting point for PTP. This dashboard is designed for use by sales managers. You log into the application and immediately have access to a number of key performance indicators (KPIs). You can also jump directly to TPO worksheets, which are working environments that support specific business processes; these are described in the following chapters.

Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.
To log into the dashboard

1. In Windows, click Start and click Programs.
2. Click Demantra > Demantra Spectrum release > Collaborator Workbench.
3. In the Log On dialog box, enter your user name and password.
4. Click Login.
5. If the toolbar includes a link labeled Click here to install Java Web Start, click that link.
   Next Oracle Demantra prompts you to install JRE.
6. When you are prompted to install JRE, do so. Choose the Typical installation and accept all the default values, unless otherwise advised by your system administrators.
   After you install this software, Collaborator Workbench comes up, displaying your personal page.
At this point, Oracle Demantra might display a dialog box that asks if you want to trust the signed application distributed by Oracle.

**Note:** In some cases, you do not see this dialog box until you click a worksheet name.

7. Click Yes (or Always) or Start.

**Reviewing Metrics**

Collaborator Workbench displays summary panes that display critical information and which you can customize to your needs. Initially, it displays the following summary panes.
**Actuals versus Plan**

This summary pane is a graph that shows cumulative actual volume and planned volume.

![Dashboard: YTD Actuals vs. Plan](image)

**Sales versus Quota**

This summary pane shows current sales compared to the sales quota.

![Dashboard: Sales vs Quota](image)

**Volume Breakdown**

This summary pane displays a table that shows the breakdown of volume into base volume and incremental volume.
Reviewing the Planning Hierarchy

The Planning Hierarchy is an expandable, treelike view that you can use to navigate the planning hierarchy.

Expand the hierarchy as needed.

You can right-click for more options.
In particular, you can open worksheets that are filtered to the selected retailer (for example). In the case of retailers, you can also view or edit properties of the retailer such as minimum event margin.

**Editing Retailer Information**

PTP stores basic retailer details so that when you create a promotion, it is automatically specified appropriately for that particular retailer. PTP provides default settings that you can use for any retailer.

**Setting a Retailer Profile to the Default**

1. In the Planning Hierarchy, expand the tree display to the retailer level.

2. Right-click the retailer and click Edit Retailer.

   PTP displays the Edit Retailer screen.
3. Change Use Default Profile to Yes.

   **Caution:** Do this only if you are certain that you want to change all settings for this retailer.

4. Click OK.

5. Log into the Workflow Manager and run the CopyRetailerDefaults workflow; see Administration - Running Required Workflows, page 16-2.

   This workflow checks for any retailers that have been set to use the default profile, and it copies the default details to those retailers.

**Editing a Retailer Profile**

**To edit a retailer profile**

1. In the Planning Hierarchy, expand the tree display to the retailer level.
2. Right-click the retailer and click Edit Retailer. PTP displays the Edit Retailer screen, as shown in the previous procedure.

3. Set Use Default Profile to No.  
   **Caution:** If you do not set Use Default Profile to No, your changes will be reset to the default.

4. Enter values for the other attributes as follows:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the retailer.</td>
</tr>
<tr>
<td>Class_of_Trade</td>
<td>Dropdown list with the following choices:</td>
</tr>
<tr>
<td></td>
<td>• Food</td>
</tr>
<tr>
<td></td>
<td>• Drug</td>
</tr>
<tr>
<td></td>
<td>• Mass</td>
</tr>
<tr>
<td></td>
<td>• C-Store</td>
</tr>
<tr>
<td></td>
<td>• Military</td>
</tr>
<tr>
<td>Number of Active Stores</td>
<td>Number of active stores that this retailer operates.</td>
</tr>
<tr>
<td>Account Classification</td>
<td>Dropdown list with the following choices:</td>
</tr>
<tr>
<td></td>
<td>• Growth</td>
</tr>
<tr>
<td></td>
<td>• Holding</td>
</tr>
<tr>
<td></td>
<td>• Declining</td>
</tr>
<tr>
<td>Avg Everyday Selling Margin</td>
<td>Average selling margin, disregarding promotions.</td>
</tr>
<tr>
<td>Min Rtl Event Margin</td>
<td>Minimum margin that this retailer must make on an event. Promotion Optimization considers only events that provide at least this much margin.</td>
</tr>
<tr>
<td>Veh Costs: Feature &amp; Display</td>
<td>Default cost for an event of type F&amp;D for this retailer.</td>
</tr>
<tr>
<td>Veh Costs: Feature Only</td>
<td>Default cost for an event of type Feature for this retailer.</td>
</tr>
<tr>
<td>Veh Costs: Display Only</td>
<td>Default cost for an event of type Display for this retailer.</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------------------------------</td>
</tr>
<tr>
<td>Veh Costs: TPR Only</td>
<td>Default cost for an event of type TPR for this retailer.</td>
</tr>
<tr>
<td>Veh Costs: F Shopper</td>
<td>Default cost for an event of type F. Shopper for this retailer.</td>
</tr>
<tr>
<td>Key Competitors</td>
<td>A text field where you can list the key competitors of this retailer.</td>
</tr>
</tbody>
</table>

5. Click OK.

**Opening Worksheets**

Each worksheet is a working environment designed for specific PTP and TPO business processes.

To open worksheets using Collaborator Workbench, click My Worksheets, or right-click Planning Hierarchy, or right click an open worksheet.

See also *Oracle Demantra User’s Guide*.

**To open a worksheet**

- To open an unfiltered worksheet, click a worksheet listed in My Worksheets.

- To open a worksheet that is filtered to a specific context, right-click a promotion, scenario, retailer, or territory, click Open With, and then click the worksheet name. You can do this within the Planning Hierarchy or within an open worksheet.

When you open a worksheet this way, it is filtered to show just the object from which you launched it. Notice that the name of the object is added to the beginning of the worksheet title.

**Note:** When you first open a worksheet, Oracle Demantra might display a dialog box that asks if you want to trust the signed application distributed by Oracle.

Click Yes (or Always) or Start.

See

- Configuring My Worksheets, page 5-15
Managing Tasks

My Tasks lists all tasks that are assigned to you and that you have not yet addressed. For example, if you are a manager, you will receive promotions that require approval.

**Note:** If a due date is shown in red text, that means the response period has nearly ended and the task is going to time out fairly soon.

To view all assigned tasks

If you have many open tasks, the My Tasks module does not necessarily display all of them. To check for additional tasks:

Click the More link in the bottom right corner of My Tasks.

My Tasks fills the wide pane and shows all current tasks.

To mark a task as done

Before you mark a task as done, make sure that you have reviewed all the relevant information and that you have addressed any concerns or issues. Then do the following:

1. First:
   - Select the appropriate response from the dropdown list in the Select value column. The check box next to the task is automatically selected.
   - If there is no dropdown list, just select the check box to the left of the task.

2. Click the Save & Refresh link at the bottom of the task list.

The task is removed from My Tasks and the updated task list is shown.

**Caution:** If you go to another page or log off without clicking Save & Refresh, then your changes will be lost.

Creating and Sending a Task

To create and send a task

1. Start by doing one of the following:
• Within My Worksheets, click Send on the worksheet that you want to send.

• Within My Tasks, click Create Task.

The Send Task to User dialog box appears.

2. Click To..... and select the users or groups to receive the task.

3. In the Message field, type a short text message.

   This will be the task message that the recipient sees. The worksheet that you are sending will be added automatically as a link from the Message text.

4. In the Description field, type a short description.

   This description will be displayed below the task message in the recipient's My Tasks module.

5. To link the task subject line to a Web page, enter the full path to the file in URL field.

   **Note:** You must enter the full URL, including server name and directory hierarchy. The http:// part will be added automatically if omitted.

6. To attach a file to the task, enter the path to the file in the File Attachment field or use the Browse button to find it.
7. To ensure that this task is completed by a specific time, click Escalate and then provide the following information:

<table>
<thead>
<tr>
<th>Due Date</th>
<th>Date and time by which this task must be completed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert Time</td>
<td>Date and time at which an alert will be displayed</td>
</tr>
<tr>
<td>To</td>
<td>Additional email addresses</td>
</tr>
</tbody>
</table>

8. To send an email notification to the recipient of the task, select the Send email list check box. (Depending on how your system has been configured, this option may not be available.)

9. Click Send Task.

When the recipient next logs in (or refreshes My Tasks), he or she will see the new task.

**Personalizing the Dashboard**

You can personalize Collaborator Workbench in several different ways:

- Configuring Your Default Layout, page 5-12
- Configuring My Tasks, page 5-14
- Configuring My Worksheets, page 5-15

To add new summary panes, see Creating or Editing a Worksheet or Content Pane, page 13-3.

**Configuring Your Default Layout**

The Collaborator Workbench page includes a wide pane and a narrow pane, and each pane has a possible set of modules that it can display. You choose the modules and their display order, top to bottom.

**To personalize your default layout**

1. Click the Personalize link.

   The Personalize - Modules page appears. This page contains two lists: one for items that can be displayed in the wide pane and one for items that can be displayed in the narrow pane.
These lists include the following:

- My Tasks and My Worksheets, which can be displayed only in the wide pane.
- Who's Online, which can be displayed only in the narrow pane.
- Worksheets that have been defined as content and to which you have access.

2. In each list, use the check boxes to select or clear the modules that you want to see.

3. Click Next.

The Personalize - Order page appears. Like the previous page, this page has one list for the wide pane and one for the narrow pane.
4. Select a module and then click the up or down buttons to change its position in the list.

The order here is the order in which these modules are shown in Collaborator Workbench.

5. Click Next.

The next page summarizes your choices. You can return to the previous pages to make further alterations.

6. Click Finish to save your changes. Or click Back to go back to the previous pages.

### Configuring My Tasks

**To configure My Tasks**

1. If Collaborator Workbench is not currently displaying My Tasks, then display it as described in “Configuring Your Default Layout”.

2. In My Tasks module, click the personalize button in the upper right corner of the pane.

Collaborator Workbench displays a page like the following:
3. In the Number of Tasks to View field, type the maximum number of tasks that you want to see in My Tasks.

4. From the Order Tasks by list, select the field that you want to list the tasks by.

5. From the Sort dropdown menu, select the sorting order that you want for the tasks. Task fields can be listed in either ascending or descending order.

6. Click Finish.
   My Collaborator Workbench refreshes with My Tasks in the new configuration.

**Configuring My Worksheets**

**To configure My Worksheets**

1. If Collaborator Workbench is not currently displaying My Worksheets, then display it as described in "Configuring Your Default Layout".

2. In My Worksheets module, click the personalize button in the upper right corner. Collaborator Workbench displays a list of all available worksheets. This includes all worksheets you own and all public worksheets.
3. Select the check box next to worksheet that you want to display.

4. Click Next.

   Collaborator Workbench displays a new page where you specify how many worksheets to display and the display order for the worksheets you have selected.

5. In the Number of Worksheets to View field, type the maximum number of worksheets that you want to see in My Worksheets.

6. In the Order list, click a worksheet and then click the up or down arrows to specify the display order of that worksheet. Repeat as necessary.

7. Click Finish to save your changes.
Managing and Viewing Quotas and Funds

Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:

- Overview
- Managing Quotas and Funds at the Retailer Level
- Managing Quotas and Funds at the Promotion Group Level
- Viewing Quotas and Funds
- Reference

Overview

This chapter describes how to manage or view quotas and funds in Oracle Demantra, as part of the PTP business process.

To manage or view quotas and funds, you start in the Collaborator Workbench and launch any of the relevant PTP worksheets.
About Quotas and Funds

Oracle Demantra displays a standard set of promotion funds, which you can view or modify at several different levels, as appropriate, along with the quota (Sales Quota) that they are intended to support.

Available Funds

PTP provides the following standard set of promotion funds, broken out as follows:

- **Brand Development Funds (BDF)**: Base rate (BDF Base Rate), development rate (BDF Dev Rate), and fixed funds (BDF Fixed Funds). The total of BDF funds is shown as BDF Auth.

- **Market Development Funds (MDF)**: Base rate (MDF Base Rate), development rate (MDF Dev Rate), and fixed funds (MDF Fixed Funds). The total of MDF funds is shown as MDF Auth.

- **Slotting funds** (Slot Auth)

- In summary, the total authorized funding (BDF, MDF, and slotting) is shown as Ttl Fund Auth.

As in standard usage, the rates are per unit so that the authorized funding is the volume multiplied by the rate. For example, BDF Auth is computed as follows:

\[(\text{BDF Base Rate} + \text{BDF Dev Rate}) \times \text{volume} + \text{BDF Fixed Funds}\]

You can see or edit these funds on several worksheets. One example (PTP: Quota and Fund Entry: Top-Down) is shown below.
Because volume affects the use of the funds, PTP also displays the following volume information:

- Actuals Ttl (the past volume)
- Volume Base (the base volume, in the absence of any promotions)
- Uplift (additional volume due to planned promotions)

In general, PTP volume calculations use actuals for the past and forecasted volume for the future. This means that to compute volume as needed for total BDF funds for the year, for example, PTP combines the actuals and the forecast.

Unplanned promotions do not affect volume.

Managing Quotas and Funds at the Retailer Level

Typically, you would start by working top-down, setting quotas and funds at the retailer-territory level.
To manage quotas and funds at the retailer-territory level

1. Start in Collaborator Workbench.

   Or if a worksheet is currently open, click File > Open. Click PTP: Quota and Fund Entry: Top-Down and then click Open.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.

4. At the top of the screen, select the territory to display.

5. In the Entry Data table, edit the quota and fund values as needed. Here you are editing values for the entire year, for a given retailer.

6. Click Data > Save Data. Or click the Save Data button.

**Entry Data**

Here you enter the funds and quotas. This table shows all the quotas and funds for each retailer, aggregated over the year.
Volume Details

This table summarizes the volume information.

<table>
<thead>
<tr>
<th>T1-World Brands Comb</th>
<th>Retailer</th>
<th>Actuals LY</th>
<th>Plan Vol</th>
<th>Sales Proj</th>
<th>Actuals Ttl</th>
<th>Base Fct</th>
<th>Incr Fct</th>
</tr>
</thead>
<tbody>
<tr>
<td>Albertsons</td>
<td>2,493,003</td>
<td>2,593,003</td>
<td>2,201,506</td>
<td>1,230,472</td>
<td>1,706,149</td>
<td>495,350</td>
<td></td>
</tr>
<tr>
<td>Safeway</td>
<td>2,493,003</td>
<td>2,523,003</td>
<td>2,109,465</td>
<td>1,230,472</td>
<td>1,706,149</td>
<td>492,336</td>
<td></td>
</tr>
<tr>
<td>Winn-Dixie</td>
<td>2,493,003</td>
<td>2,493,003</td>
<td>2,109,465</td>
<td>1,230,472</td>
<td>1,706,149</td>
<td>492,336</td>
<td></td>
</tr>
<tr>
<td>Summary</td>
<td>7,473,008</td>
<td>7,503,008</td>
<td>6,418,476</td>
<td>3,691,416</td>
<td>5,118,645</td>
<td>1,300,030</td>
<td></td>
</tr>
</tbody>
</table>

Sales Quota

This graph shows the plan, the sales quota, and the projection for each retailer.

Possible Actions

In this worksheet, depending on your authorization, you can do the following:

- Edit fund rates, fixed funds, and quotas.

- Use File > Open to access other PTP worksheets. (It is not recommended to open the TPO worksheets this way, because they will not be filtered and will be slow.)

Managing Quotas and Funds at the Promotion Group Level

If you have already set quotas and funds at a high level, you might want to fine-tune
the amounts by adjusting values at the lower levels.

**To manage quotas and funds at the promotion group level**

In the table, edit the quota and fund values as needed. You can select and edit multiple cells.

**Entry Data**

This table shows all the quotas and funds for the selection, by week.

**Sales Quota**

This graph shows the plan, the sales quota, and the projection for each promotion group.

![Sales Quota](image)

**Possible Actions**

In this worksheet, depending on your authorization, you can do the following:

- Edit funds and quotas.

- Use File > Open to access other PTP worksheets. (It is not recommended to open the TPO worksheets this way, because they will not be filtered and will be slow.)

**Viewing Quotas and Funds**

If you are a sales representative, you can view authorized funds against your sales quota. You use the PTP: Quota and Fund View worksheet, which is a view-only worksheet.
To view quotas and funds

1. In My Worksheets (in Collaborator Workbench), click PTP: Quota and Fund View. Or if a worksheet is currently open, click File > Open. Click PTP: Quota and Fund View and then click Open.

2. If the worksheet does not show data immediately, click Data > Rerun.

3. At the top of the screen, select the territory, retailer, and brand to display.

The table shows all the quotas and funds for each brand, broken down by promotion group. For each promotion group, the quotas and funds are displayed for the entire year.

The graph below that shows the quota for each promotion group.

Possible Actions

In this worksheet, depending on your authorization, you can do the following:

Use File > Open to access other PTP worksheets.

Reference

PTP: Quota and Fund Entry: Top-Down

This worksheet lets you set quotas and funds at the retailer level.

Basics
Accessing this worksheet

- If a worksheet is currently open, click File > Open. Click PTP: Quota and Fund Entry: Top-Down and then click Open.

Levels you can select
Territory

Levels used in cross tabulation
Retailer

Time aggregation
Yearly

### Business Data

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entry Data</td>
<td>Plan $</td>
<td>The manufacturer’s planned revenue</td>
</tr>
<tr>
<td></td>
<td>Sales Quota</td>
<td>Sales quota (revenue)</td>
</tr>
<tr>
<td></td>
<td>$ Sales Proj</td>
<td>Planned sales dollars: actuals plus forecast</td>
</tr>
<tr>
<td></td>
<td>Sales Proj</td>
<td>Planned sales volume: actuals plus forecast</td>
</tr>
<tr>
<td></td>
<td>Base Fcst</td>
<td>Base volume: actuals plus forecast</td>
</tr>
<tr>
<td></td>
<td>Incr Fcst</td>
<td>Incremental volume: actuals and forecast due only to planned promotions</td>
</tr>
<tr>
<td></td>
<td>MDF Base Rate</td>
<td>Market development fund base rate</td>
</tr>
<tr>
<td></td>
<td>MDF Dev Rate</td>
<td>Market development fund development rate</td>
</tr>
<tr>
<td></td>
<td>MDF Fixed Funds</td>
<td>MDF fixed funds</td>
</tr>
<tr>
<td></td>
<td>MDF Auth</td>
<td>Authorized market development funds, calculated as follows: (base rate + dev rate)*volume + fixed MDF funds</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>BDF Base Rate</td>
<td>Brand development fund base rate</td>
</tr>
<tr>
<td></td>
<td>BDF Dev Rate</td>
<td>Brand development fund development rate</td>
</tr>
<tr>
<td></td>
<td>BDF Fixed Funds</td>
<td>BDF fixed funds</td>
</tr>
<tr>
<td></td>
<td>BDF Auth</td>
<td>Authorized brand development funds, calculated as follows: (base rate + dev rate)*volume + fixed BDF funds</td>
</tr>
<tr>
<td></td>
<td>Slot Auth</td>
<td>Authorized slotting funds</td>
</tr>
<tr>
<td></td>
<td>Ttl Fund Auth</td>
<td>Total authorized spending, including MDF, BDF, and slotting</td>
</tr>
<tr>
<td>Volume Details</td>
<td>Actuals LY</td>
<td>Actual demand one year ago</td>
</tr>
<tr>
<td></td>
<td>Plan Vol</td>
<td>The manufacturer’s planned volume</td>
</tr>
<tr>
<td></td>
<td>Sales Proj</td>
<td>Planned sales volume: actuals plus forecast</td>
</tr>
<tr>
<td></td>
<td>Actuals Ttl</td>
<td>Total actual quantity (including both base and incremental volume)</td>
</tr>
<tr>
<td></td>
<td>Base Fcst</td>
<td>Base volume: actuals plus forecast</td>
</tr>
<tr>
<td></td>
<td>Incr Fcst</td>
<td>Incremental volume: actuals and forecast due only to planned promotions</td>
</tr>
<tr>
<td>Sales Quota</td>
<td>Plan $</td>
<td>The manufacturer’s planned revenue</td>
</tr>
<tr>
<td></td>
<td>Sales Quota</td>
<td>Sales quota (revenue)</td>
</tr>
<tr>
<td>$ Sales Proj</td>
<td></td>
<td>Planned sales dollars: actuals plus forecast</td>
</tr>
</tbody>
</table>

**PTP: Quota and Fund Entry: Bottom-Up**

This worksheet lets you set quotas and funds at lower levels.
### Basics

**Accessing this worksheet**
- If a worksheet is currently open, click File > Open. Click PTP: Quota and Fund Entry: Bottom-Up and then click Open.

**Levels you can select**
- Territory, Retailer, Brand, Promotion Group

**Levels used in cross tabulation**
- None

**Time aggregation**
- Weekly

---

### Business Data

Same as for PTP: Quota and Fund Entry: Top-Down, except that this worksheet does not include a Volume Details area.

---

### PTP: Quota and Fund View

This read-only worksheet lets you view quotas and funds.

---

### Basics

This read-only worksheet lets you view quotas and funds.

**Accessing this worksheet**
- In My Worksheets (in Collaborator Workbench), click PTP: Quota and Fund View.
- If a worksheet is currently open, click File > Open. Click PTP: Quota and Fund View and then click Open.

**Levels you can select**
- Territory, Retailer, Brand

**Levels used in cross tabulation**
- Promotion Group

**Time aggregation**
- Weekly
Business Data

Same as for PTP: Quota and Fund Entry: Top-Down, except that this worksheet does not include a Volume Details area.
Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:
- Overview
- Reference

Overview

This chapter describes how track sales volume, as part of the PTP business process. It includes the following sections.

To track volume, you start in the Collaborator Workbench and launch the Volume Tracking worksheet:

The Volume Tracking report is where product, territory, and account volumes are forecasted and monitored to ultimately feed volume requirements to operations. Fund planning already covered will be integrated with volume planning, because forecast volumes drive budgets in live accrual environments and drive spending for case rate allowances and other variable spending deals.
In the Volume Tracking - Detail report, you can drill down to the retailers of a territory and see the same data.

**Tracking Volume for Territories**

1. In My Worksheets (in Collaborator Workbench), click Volume Tracking
   Or if a worksheet is currently open, click File > Open. Click Volume Tracking and then click Open.

2. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.

3. At the top of the screen, select the territory whose volume you want to see.

**Volume Tracking Table**

The table compares last year’s sales to this year’s plan, for the selected territory.
This table tracks the following on a weekly basis:

- Last year's shipments
- This year's shipments
- The current year's base volume projection
- The current year's incremental volume projection
- Cumulative % versus your plan

The information here can be updated weekly to give you an up-to-date tally of how you are performing versus your plan. Numbers are highlighted in different colors to give you a quick and easy way to keep abreast of your performance:

- Green is above plan
- Orange is slightly below plan (95-99.99%)
- Red is more than 5% below plan

Volume Tracking Graph

The Volume Tracking graph gives you a week-by-week look at the plan and the total forecast.
Base and Incremental Graph

The Base and Incremental graph displays the current year's base and incremental sales.

Possible Actions

In this worksheet, depending on your authorization, you can do the following:

Use File > Open to access other PTP worksheets.

Tracking Volume for Retailers

1. In My Worksheets (in Collaborator Workbench), click Volume Tracking - Detail.
   Or if a worksheet is currently open, click File > Open. Click Volume Tracking - Detail and then click Open.

2. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.

3. At the top of the screen, select the territory and then retailer whose volume you want to see.
This worksheet shows the same data as the Volume Tracking worksheet; see Tracking Volume for Territories, page 7-2.

Reference

Volume Tracking

This worksheet compares last year's sales to this year's plan.

Basics

Accessing this worksheet
• In My Worksheets (in Collaborator Workbench), click Volume Tracking.
• If a worksheet is currently open, click File > Open. Click Volume Tracking and then click Open.

Levels you can select

<table>
<thead>
<tr>
<th>Territory</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
</tbody>
</table>
Levels used in cross tabulation: None

Time aggregation: Weekly

Business Data

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forecast vs Actuals</td>
<td>Shipments</td>
<td>Historical shipment volume from the manufacturer to the retailers' locations</td>
</tr>
<tr>
<td>ActuALLY</td>
<td></td>
<td>Actual demand one year ago</td>
</tr>
<tr>
<td>Actuals Ttl</td>
<td></td>
<td>Total actual quantity (including both base and incremental volume)</td>
</tr>
<tr>
<td>Ttl Fcst</td>
<td></td>
<td>Total volume: base forecast plus incremental forecast</td>
</tr>
<tr>
<td>Base Fcst</td>
<td></td>
<td>Base volume: actuals plus forecast</td>
</tr>
<tr>
<td>Incr Fcst</td>
<td></td>
<td>Incremental volume: actuals and forecast due only to planned promotions</td>
</tr>
<tr>
<td>Plan Vol</td>
<td></td>
<td>The manufacturer's planned volume</td>
</tr>
<tr>
<td>Cumulative Actuals</td>
<td></td>
<td>Total actuals (base plus incremental) cumulative to date</td>
</tr>
<tr>
<td>Cumulative Plan</td>
<td></td>
<td>Cumulative frozen planned volume</td>
</tr>
<tr>
<td>Cumulative % vs Plan</td>
<td></td>
<td>Total cumulative actuals, as a fraction of the plan</td>
</tr>
<tr>
<td>Base and Incremental</td>
<td>Base Fcst</td>
<td>Base volume: actuals plus forecast</td>
</tr>
<tr>
<td></td>
<td>Incr Fcst</td>
<td>Incremental volume: actuals and forecast due only to planned promotions</td>
</tr>
</tbody>
</table>
**Volume Tracking - Detail**

This worksheet compares last year's sales to this year's plan, at a lower level.

**Basics**

- **Accessing this worksheet**
  - In My Worksheets (in Collaborator Workbench), click Volume Tracking - Detail.
  - If a worksheet is currently open, click File > Open. Click Volume Tracking - Detail and then click Open.

- **Levels you can select** Territory, Retailer

- **Levels used in cross tabulation** None

- **Time aggregation** Weekly

**Business Data**

Same as in the Volume Tracking worksheet.
Planning Promotions

**Important:** The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter describes how to create promotions and make changes if needed, as part of the TPO business process. This chapter covers the following topics:

- Introduction to the Planning Environment
- Creating a Promotion
- Editing a Promotion
- Marking a Promotion as Planned
- Approving a Promotion
- Committing a Promotion
- Marking a Promotion as Partially Paid or Paid
- Closing a Promotion
- Making Other Changes to a Promotion
- Duplicating a Promotion
- Copying and Pasting a Promotion
- Deleting a Promotion
- Reference

**Introduction to the Planning Environment**

You plan and manage promotions in the Planning Environment, which is the entry point to both historical and planned event analysis. Event planning consists of creating and managing a calendar of promotional events, and understanding their impact on
sales, promotion spending, and profitability, as well as their correlation with sales quotas. Demantra's Planning Environment provides all this critical information in one place.

To open and navigate the Planning Environment
2. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.
3. At the top of the screen, select the territory, retailer, category, and promotion group.
4. In the Event Planner window, click a row. Notice the following changes in the rest of the worksheet, depending on the scenario and promotion associated with that row:
   - The graphs below this display graphical information for the promotion.
   - The tables below this display side-by-side details for all promotions within the currently selected scenario.
5. Click a promotion in the Cost Benefit Review or Fund Allocation window. Notice
that the same promotion is highlighted throughout the worksheet.

**Color Conventions**

The Planning Environment uses the following color conventions:

- White indicates editable fields.
- Gray indicates loaded data such as Start Ship and End Ship.
- Blue indicates data that is calculated by PTP, especially by the Analytical Engine.
- Red indicates negative profit numbers.

Also notice that in the Event Planner window, the Evt Status for a promotion may be displayed in different colors, to indicate whether that promotion has been optimized. Here:

- White means that the promotion has not been optimized.
- Yellow means that the promotion has been optimized.
- Green means that the promotion has been optimized and accepted, so that the promotion is using the optimization results.

**Sales % vs. Quota**

This window shows an analysis of planned sales to sales quota, for the given retailer. This is the total for the retailer. For convenience, the sales projection is also shown.

![Sales % vs Quota](image)

**Fund Balances**

This window provides a detailed overview of authorized funds (MDF, BDF, slotting), spend and fund balances to date, for the given territory. This is the total for the territory.
Event Planner

This window shows event details such as the start and end ship dates, vehicle type, vehicle cost, buydown, base volume and incremental volume. Incremental volume is generated by Demantra's comprehensive analytical engine.

Notice that the events are grouped according to the associated scenario. As noted in "Promotions and Scenarios", the Sandbox scenario contains all the tentative events (unplanned events), and the Current Year scenario contains all the rest. The unplanned events have no impact on budget.

This window is the primary area in which you create or modify promotions.

Also notice that when you select a row in this window, the graphs and tables below are updated to show details depending on the scenario and promotion associated with that row.

Sales Breakdown for Event

This window graphically shows the sales breakdown for the selected event. The breakdown shows both base and incremental volume.
Spend Breakdown for Event

This window graphically shows the spending breakdown for the selected event. The breakdown shows both vehicle spending and buydown.

Cost Benefit Review

This window presents a detailed cost benefit analysis for each event in the currently selected scenario. Details include profitability metrics from both the manufacturer and retailer’s perspective, overall event spend, cost per incremental unit (CPIU), and payment type. Here you can control the status of the event.

The incremental manufacturing profit is the additional profit that the manufacturer earns because of the promotion, in addition to the base profit that would be earned even without a promotion. The incremental retailer profit is analogous.

Fund Allocation

This window displays the allocated funding for each event in the currently selected scenario. Here you allocate the promotional costs between the MDF and BDF funds.
Possible Actions

In this worksheet, depending on your authorization, you can do the following:

- Edit a promotion, by changing the sale price and other properties. You can also right-click a promotion and select Edit to access other properties. See Editing a Promotion.

- Copy and paste promotions. See Copying and Pasting a Promotion, page 8-15.

- Delete promotions. See Deleting a Promotion, page 8-16.

- Run simulations. See Running a Simulation, page 10-3. Note that this worksheet does not contain the data needed to find cannibalization.

- Run optimization. See Optimizing a Promotion, page 10-6.

- Right-click on a promotion and open other worksheets filtered to this promotion. For example, see Examining Promotions from a Retailer’s Point of View, page 11-6.

- Right-click on a scenario and open the PTP: Promotion Comparison worksheet filtered to that scenario. See Comparing Promotions in a Scenario, page 11-8.

Creating a Promotion

Security Restrictions

The new promotion method is only displayed if the promotion level in the component is set to Write or Full Control access. Your member security settings determine the populations on which you can define the new promotion.

To create a promotion

1. Open the Planning Environment; see “Introduction to the Planning Environment”.

2. At the top of the screen, select the territory, retailer, category, and then promotion group with which you want to create the promotion.

3. In the Event Planner window, right-click an existing promotion and then select New Promotion.
   Oracle Demantra displays the following screen:
4. The Population area shows the currently selected combinations with which the new promotion will be associated.

The default combinations are taken from the current selection in the worksheet. To change them, see "To reassign a promotion to a different item or location".

5. The Start and End dates are controlled by default settings. Edit them as needed.

6. Specify values for the other attributes as appropriate:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Ship, End Ship</td>
<td>Optionally specify when the product will be shipped for the promotion. You might specify this information later, when the promotion is more certain.</td>
</tr>
<tr>
<td>Scenarios</td>
<td>Select a scenario from the drop-down list.</td>
</tr>
<tr>
<td>Cons Promo</td>
<td>Specify the type of consumer overlay, if any. This affects the number of Units. For example, if Cons Promo is a two-for-one deal, then Units becomes 2.</td>
</tr>
<tr>
<td>Promotion Plan</td>
<td>Select the promotion plan from the drop-down list.</td>
</tr>
</tbody>
</table>

7. Click Create. The new promotion is created and is displayed in the Event Planner.
window. It has a default cost based on the vehicle type you specified.

8. Specify the Sale Price for use during the promotion.

9. Specify the costs for this promotion:
   1. If the Veh Type is incorrect, change it, save the data and rerun the worksheet. PTP puts the default fixed cost for the new vehicle type into the Veh $ series.
   2. Optionally edit Veh $, if the fixed cost for this promotion is different from the default.
   3. For Buydown, specify the discount per promoted unit that will be paid to the retailer.

10. Click Data > Save Data.

Because this promotion is unplanned, it is considered hypothetical and does not have an impact on the promotion funds or on the forecast.

See also
"Duplicating a Promotion"
"Copying and Pasting a Promotion"
"Editing a Promotion"

Editing a Promotion
You may want to edit a promotion for a variety of reasons such as filtering to a different level or changing the item or location.

Marking a Promotion as Planned
Before you mark a promotion as planned, you may want to run simulation, optimization, or both, as described in "Simulation and Optimization."

Before marking a promotion as planned, you also generally examine the promotion to be sure you have chosen the best vehicle type and so on. You may want to create several tentative promotions (all in the Sandbox scenario) and view them side by side. See "Examining and Comparing Promotions."

To mark a promotion as planned
1. In the Fund Allocation window, change MDF Alloc % as desired. This specifies the percentage of the event that is funded by MDF. Enter 50 for 50%, for example.
   The remainder is automatically funded by BDF, as PTP automatically computes
BDF Alloc % and BDF Alloc.

2. In the Cost Benefit Review window, change the Evt Status of the promotion to Planned.

3. Right-click the promotion and then select Edit Promotion.

4. Change Scenarios to Current Year.

5. Click OK.

6. Click another promotion in the worksheet. PTP automatically updates the details for the newly planned promotion. Notice that the promotion now consumes funds and has an impact on sales projections.

Approving a Promotion

To approve a promotion

1. In the Event Planner window, change the Evt Status to Approved.

2. Click Data > Save Data.

3. Rerun the worksheet.

Committing a Promotion

You commit a promotion when you have a firm commitment from the retailer to run the promotion. When you commit a promotion, PTP takes a snapshot of the current state of the promotion, for use in later analysis. The committed promotions are included in all projections. PTP also freezes the promotion at this point, so that you cannot change its properties (apart from advancing the status further).

To commit a promotion

1. In the Event Planner window, change the Evt Status to Committed.

2. Click Data > Save Data.

3. Optionally, to see the projections that PTP has just captured, use the PTP: Promo-Evaluation: Mfg or PTP: Promo-Evaluation: Rtl worksheet. See "Reviewing Past Performance."
Marking a Promotion as Partially Paid or Paid

To mark a promotion as paid

1. Open the Planning Environment; see "Introduction to the Planning Environment."
2. In the Event Planner window, change the Evt Status to Partial Paid or Paid.
3. Click Data > Save Data.
4. Rerun the worksheet.

Closing a Promotion

To close a promotion

1. Open the Planning Environment; see "Introduction to the Planning Environment".
2. In the Event Planner window, change the Evt Status to Closed.
3. Click Data > Save Data.
4. Rerun the worksheet.

Making Other Changes to a Promotion

Security Restrictions

The Edit promotion method is only enabled for promotions that have Read and Write or Full Control security access. The component level security access must also be Write or Full Control.

- If your security access level is Read Only, you cannot edit a promotion
- If your security access level is Read & Write or Full Control, but the promotion level is Read Only, it cannot be edited

Note: Before you change a promotion, you should change its status back to Unplanned. After making your change, restore the previous status. This procedure ensures that Demantra triggers all internal processes as needed.
To modify a promotion

1. In the Event Planner window, edit any details in the row corresponding to the promotion.

2. Click Data > Save Data.

3. If you changed the Veh Type, rerun the worksheet to see the new default cost of this promotion.

To rename a promotion

1. Right-click it and click Edit.

2. Type a new name and click OK.

To reassign a promotion to a different item or location

You can reassign an unplanned promotion to associate it with a different territory, retailer, item, or Ship To, as needed.

Important: You must create both a Refresh Population workflow and method before executing this procedure. First, create a Refresh Population workflow that contains only the Refresh Population workflow step. Then create the Refresh Population method on the Promotion level without any input or output arguments and link it to the Refresh Population workflow.

1. Right-click a promotion and click Edit.

2. Click Edit below the Population area.

   The Edit Population dialog box is displayed.
usually a promotion is associated with a territory, retailer, category, and promotion group.

To change the territory, retailer, category, or promotion group, click that level name in Selected Filter Levels and change the selection displayed in Selected members.

For example, to associate the promotion with a different promotion group:

1. In Selected Filter Levels, click Promotion Group.

2. Then in the Selected members list, double-click the promotion group that you no longer want to use for this promotion. For example, double-click ADVO 100 to remove it from this list.

3. Then in Available members, double-click the promotion group that should be used. This promotion group is then moved to the Selected members list. For example, double-click ADVO 200 to move it to the Selected members list; now the promotion is associated with ADVO 200 instead of ADVO 100.

3. Repeat as necessary.

4. Click Finish to exit this dialog box.

5. From the PTP: Planning Environment worksheet, right-click on the promotion group you have modified.
6. Choose the Refresh Population method from the menu.

7. Rerun the worksheet to see the changes.

See Also


- "System Parameters" in the Oracle Demantra Implementation Guide for more information about the CopyPasteIntersect system parameter which determines how volume is distributed when an item is moved from one promotion group to another.

- "Specifying Data Properties of a Series" in the Oracle Demantra Implementation Guide for more information about how to configure the Copy/Paste preservation Type series setting.

## Duplicating a Promotion

The Duplicate method enables you to duplicate an existing promotion with the same duration and population (item/location). All attributes and series remain the same as the original except for the name of the promotion, its event status and starting date. If you want to perform a context sensitive copy of a promotion from one account to another and substitute accounts, use the Copy/Paste procedure instead. The Duplicate method only works on the promotion level.

### To duplicate a promotion

1. Start in the TPM: Planning Environment worksheet. A list of scenarios and promotions are displayed.

2. Right-click a promotion and choose Duplicate from the methods menu. The Duplicate Promotions form appears.

3. Input the following information about the duplicate promotion:

<table>
<thead>
<tr>
<th>Field name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The promotion name.</td>
</tr>
<tr>
<td>Field name</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Event Status</td>
<td>The status of the event. Options include:</td>
</tr>
<tr>
<td></td>
<td>• a. Unplanned</td>
</tr>
<tr>
<td></td>
<td>• b. Planned</td>
</tr>
<tr>
<td></td>
<td>• c. Approved</td>
</tr>
<tr>
<td></td>
<td>• d. Committed</td>
</tr>
<tr>
<td></td>
<td>• e. Partial Paid</td>
</tr>
<tr>
<td></td>
<td>• f. Paid</td>
</tr>
<tr>
<td></td>
<td>• g. Closed</td>
</tr>
<tr>
<td>Start Event</td>
<td>The starting date for the promotion event. A calendar is available to assist you. If you do not specify a starting date for the promotion event, it will default to the date used for the original promotion.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> If you specify the start date of the promotion, the duration of the promotion remains the same as the original promotion.</td>
</tr>
<tr>
<td>End Event</td>
<td>The end date for the promotion event.</td>
</tr>
</tbody>
</table>

**Note:** Only the values of those attributes that appear in the Duplicate Promotions form can be changed during the duplication process. All other attributes remain the same as the original. The fields in the Duplicate Promotions form can be modified in the Business Modeler by the Administrator to include additional attributes except Population. For more information about how to customize the duplicate promotions method, see "Configuring Methods" in the Demantra Implementation Guide. If you want to change the population, create a new promotion or copy and paste a promotion.
4. Check the Save Parameters option if you want to customize the form's defaults.

5. Click Duplicate Promotion. The new promotion appears in the worksheet.

Determining the Population for a Duplicated Promotion

The following rules apply to determining the population for a pasted promotion when Available Filter Levels are configured:

• Any levels in the pasted promotion’s population that are not configured as Available Filter Levels do not appear in the pasted promotion.

• All available members for Mandatory Levels are included in a pasted promotion.

See Also
"Creating a Promotion"

Copying and Pasting a Promotion

The copy method is only enabled if the promotion level in the component is set to Write or Full control access.

The paste method is only enabled if the promotion level in the component is set to Write or Full Control access and you have access to the target population. If you only have partial access to the target population, the paste method is displayed, but when the method is executed, members with Read Only access levels are removed from the population.

• Replace the population (for example, copying a promotion from ABC Company to XYZ Company replaces the account).

• Change the promotion duration. The data is adjusted to make the new promotion similar to the original promotion.

Security Restrictions

You can copy and paste in any level that has Write or Full Control, regardless of user security restrictions. This means that everyone can copy and paste promotions, as long as the level’s access status is not Read Only, in which case no user can copy and paste promotions.

Determining the Population for a Pasted Promotion

The following rules apply to determining the population for a pasted promotion when Available Filter Levels are configured:
• Any levels in the pasted promotion's population that are not configured as Available Filter Levels do not appear in the pasted promotion.

• All available members for Mandatory Levels are included in a pasted promotion.

See Also
"Creating a Promotion"

To copy and paste a promotion
1. You typically start in the Planning Environment; see "Introduction to the Planning Environment".

2. In the Event Planner window, right-click a promotion and click Copy.
   
   Tip: You can do the same thing in any area of the worksheet that displays promotions.

3. Right-click and then select Paste.
   
   Oracle Demantra displays a dialog box that asks for details about the copy.

4. Specify one of the following:
   
   • To shift the dates of the newly copied promotion, specify a number in the Shift By field. The copy will be shifted later in time by the specified amount, but will last for the same length of time. You can use any integer, including negative number or zero.

   • To specify a different start and end date, specify values in the From and To fields.

   • To make the new promotion span the entire length of time used in the worksheet, select Worksheet Derive.

5. Click OK.

6. When prompted for a new promotion name, type the name and click OK.

Deleting a Promotion

Security Restrictions

You can only delete a promotion if the promotion level at the component level is set to Full Control and you also have Full Control access to the promotion.
To delete a promotion

1. You typically start in the Planning Environment; see "Introduction to the Planning Environment."

2. In the Event Planner window, right-click a promotion and click Delete.
   Tip: You can do the same thing in any area of the worksheet that displays promotions.

3. Oracle Demantra prompts you to confirm the action. Click Yes or No.

4. Rerun the worksheet to see the change.

Reference

Planning Environment

Basics

- In My Worksheets (in Collaborator Workbench), click Planning Environment.
- If a worksheet is currently open, click File > Open. Click Planning Environment and then click Open.

Levels you can select: Territory, Retailer, Category, Promotion Group

Levels used in cross tabulation: Scenario, Promotion

Time aggregation: Yearly

Business Data

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales % vs Quota (Base + Viewed Events)</td>
<td>Sales Quota</td>
<td>Sales quota (revenue)</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>% Attained</td>
<td></td>
<td>Percentage of sales quota attained</td>
</tr>
<tr>
<td>$ Sales Proj</td>
<td></td>
<td>Planned sales dollars: actuals plus forecast</td>
</tr>
<tr>
<td>Fund Balances</td>
<td>MDF Auth</td>
<td>Authorized market development funds, calculated as follows: (base rate + dev rate)*volume + fixed MDF funds</td>
</tr>
<tr>
<td></td>
<td>MDF Bal</td>
<td>Remaining market development funds, calculated as the authorized MDF less the spent or committed funds</td>
</tr>
<tr>
<td></td>
<td>BDF Auth</td>
<td>Authorized brand development funds + D75</td>
</tr>
<tr>
<td></td>
<td>BDF Bal</td>
<td>Remaining brand development funds, calculated as the authorized BDF less the spent or committed funds</td>
</tr>
<tr>
<td></td>
<td>Slot Auth</td>
<td>Authorized slotting funds</td>
</tr>
<tr>
<td></td>
<td>Slot Bal</td>
<td>Remaining slotting budget, accounting for the part that has been spent</td>
</tr>
<tr>
<td></td>
<td>Unmatched $</td>
<td>Trade spend not yet matched to a promotion</td>
</tr>
<tr>
<td></td>
<td>Ttl Fund Auth</td>
<td>Total authorized spending, including MDF, BDF, and slotting</td>
</tr>
<tr>
<td></td>
<td>Ttl Fund Bal</td>
<td>Remainder of total authorized spending, after accounting for spending</td>
</tr>
<tr>
<td>Event Planner</td>
<td>Start Ship</td>
<td>Date when the product starts to ship.</td>
</tr>
<tr>
<td></td>
<td>End Ship</td>
<td>Date when the shipments end for the event.</td>
</tr>
<tr>
<td></td>
<td>Start Event</td>
<td>Date when the promotion starts in stores.</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>End Event</td>
<td></td>
<td>Date when the promotion ends.</td>
</tr>
<tr>
<td># Wks</td>
<td></td>
<td>Event length in whole weeks, assuming that each week starts on Monday.</td>
</tr>
<tr>
<td>Veh Type</td>
<td></td>
<td>Vehicle type or event type of the promotion</td>
</tr>
<tr>
<td>Veh $</td>
<td></td>
<td>Vehicle cost for the promotion</td>
</tr>
<tr>
<td>Cons Promo</td>
<td></td>
<td>Consumer overlay, the deal type as seen by the consumer.</td>
</tr>
<tr>
<td>Shelf Price</td>
<td></td>
<td>Everyday price to the consumer</td>
</tr>
<tr>
<td>Sale Price</td>
<td></td>
<td>Sale price per unit at shelf</td>
</tr>
<tr>
<td>Units</td>
<td></td>
<td>Number of units in the deal to the consumer. Usually equal to 1. Use 2 for</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2-for-1 sales, for example.</td>
</tr>
<tr>
<td>Buydown</td>
<td></td>
<td>Buydown allowance per unit, discount offered to retailer for running the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>event</td>
</tr>
<tr>
<td>Lift</td>
<td></td>
<td>Lift factor for the promotion</td>
</tr>
<tr>
<td>Base Evt Vol</td>
<td></td>
<td>Base volume during the promotion</td>
</tr>
<tr>
<td>Incr Evt Vol</td>
<td></td>
<td>Incremental volume due to the promotion</td>
</tr>
<tr>
<td>Ttl Evt Vol</td>
<td></td>
<td>Total volume for the promotion</td>
</tr>
<tr>
<td>Sales Breakdown for Event</td>
<td>Base Evt Vol</td>
<td>Base volume during the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt Vol</td>
<td>Incremental volume due to the promotion</td>
</tr>
<tr>
<td>Cost Benefit Review</td>
<td>Ttl Evt $</td>
<td>Total sales during the promotion, for the manufacturer</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Incr Evt $</td>
<td></td>
<td>Incremental sales to the manufacturer due to the event</td>
</tr>
<tr>
<td>Mfg Profit</td>
<td></td>
<td>Manufacturer’s profit from the event</td>
</tr>
<tr>
<td>Incr Mfg Prft</td>
<td></td>
<td>Incremental profit to the manufacturer due to the promotion</td>
</tr>
<tr>
<td>Rtl Prft</td>
<td></td>
<td>Retailer’s profit from the event</td>
</tr>
<tr>
<td>Incr Rtl Prft</td>
<td></td>
<td>Incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td>Evt Spend</td>
<td></td>
<td>Total planned spending for promotion, sum of buydown, vehicle costs, and slotting</td>
</tr>
<tr>
<td>CPIU</td>
<td></td>
<td>Event cost per incremental unit sold as a result of the promotion.</td>
</tr>
<tr>
<td>% Spend</td>
<td></td>
<td>Event spending, as a percentage of event sales</td>
</tr>
<tr>
<td>Pay Type</td>
<td></td>
<td>Indicates the payment terms between the manufacturer and the retailer for this promotion</td>
</tr>
<tr>
<td>Evt Status</td>
<td></td>
<td>Current status of the promotion</td>
</tr>
<tr>
<td>Spend Breakdown for Event</td>
<td>Buydown $</td>
<td>Buydown spend for the promotion</td>
</tr>
<tr>
<td></td>
<td>Veh $</td>
<td>Vehicle cost for the promotion</td>
</tr>
<tr>
<td>Fund Allocation</td>
<td>Evt Spend exS</td>
<td>Total planned buydown and vehicle costs for promotion</td>
</tr>
<tr>
<td></td>
<td>MDF Alloc %</td>
<td>Market development funds, as a percentage of total plan spending (excluding slotting costs).</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>MDF Alloc</td>
<td>Allocated market development funds, based on the percentage set by the planner</td>
</tr>
<tr>
<td></td>
<td>BDF Alloc %</td>
<td>Brand development funds, as a percentage of total plan spending (excluding slotting costs)</td>
</tr>
<tr>
<td></td>
<td>BDF Alloc</td>
<td>Allocated brand development funds, based on the percentage set by the planner</td>
</tr>
</tbody>
</table>
Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:

- Overview
- Working with Promotions in the Promotion Calendar
- Predefined Calendar Views

Overview

Promotion calendars graphically display promotions in an interactive calendar, as seen here below:
In a promotion calendar, levels, table and calendar are combined into a single view. In the example above, a Promotion Calendar is configured to display the Brand and Promote Group levels. The right side of a promotion calendar displays promotions across configurable units of time. In the example above, time is displayed in a days within weeks format.

- Each promotion appears as a separate box in the calendar, and each may display several series and their values (for example, Vehicle Type, Start and End Event dates, Event Spend).

- Multiple promotions may appear in the same row and their start and end dates may overlap.

- Promotion calendars must be defined manually using PLSQL. For more information, see the Oracle Demantra Implementation Guide.

**Note:** Time and Promotion levels are not displayed when a promotion calendar is added to a worksheet. Data in a series is aggregated across all combinations and dates of a promotion in a single row.

There are five control buttons near the top right corner of the Promotion Calendar:

- + Zoom in
- - Zoom out
- < Position to the earliest date on the calendar
• Position to the latest date on the calendar
• Position the calendar to the current day

If you right-click the calendar header, you can zoom in to the calendar, zoom out, or change the level (month, week, or day). Zooming in increases the width of each promotion box; you can see more details of each promotion but fewer promotions on the calendar. Zooming out decreases the width of each promotion box; you can see fewer details of each promotion but more promotions on the calendar. Zooming in and out automatically changes the time scale.

Opening a Promotion Calendar

To open a promotion calendar:

1. In a worksheet, open the Worksheet Designer.

2. In the Layout area, right-click on a level.

3. Click the Show Calendar checkbox.

4. In the Calendar View submenu, select one of the calendar views.

See Also:
"Defining a Promotion Calendar" in the Oracle Demantra Implementation Guide

Working with Promotions in the Promotion Calendar

Right-clicking a promotion in a promotion calendar displays the same Methods menu as when you right-click a level member in a worksheet. For example, if Promotions is displayed in boxes in your Calendar, then the same menu for the Promotion Level are displayed when you right-click a promotion in the Calendar.

Viewing the Details of a Promotion

To view the details of a promotion in a promotion calendar, do one of the following:

• Hover your mouse over a promotion.

• Right-click on a promotion and select View Promotion.

• If View Promotion is defined as a menu option, click the View Promotion button on the menu bar.

• If you double-click on a read-only member, the View Member dialog appears.

• If you double-click on an editable member, the Edit Member dialog appears. If you
double-click on a read-only member, the View Member dialog appears.

The information displayed when you hover your mouse over a promotion is configurable. For more information, see the "Defining a Promotion Calendar" section in the *Oracle Demantra Implementation Guide*.

**Creating New Promotions in a Promotion Calendar**

To create a new promotion in a promotion calendar, do one of the following:

- Right-click on a promotion and select New Promotion
- Click the New Promotion button on the menu bar
- Double-click on a blank area of the calendar.

Any of these actions will launch the New Promotion creation process.

See Also:

"Creating a Promotion"

**Editing Promotions in the Promotion Calendar**

To edit a promotion in a promotion calendar, do one of the following:

- Right-click on a promotion and select Edit Promotion
- Click the Edit Promotion button on the menu bar
- Double-click on an editable member.

Any of these actions will enable you to edit a promotion directly from a promotion calendar.

Due to user security restrictions, you might be prevented from making changes in a promotion calendar, regardless of the promotion's status. For more information, see the "Defining a Promotion" section in the *Oracle Demantra Implementation Guide*.

You can change the timing of a promotion by moving or resizing it in a promotion calendar. There is a configurable set of rules that determine whether or not a promotion can be moved or resized on the calendar. For more information, see the "Defining a Promotion" section in the *Oracle Demantra Implementation Guide*.

To automatically update the start and end date of a promotion, drag a promotion box to a different time period on a promotion calendar or extend either side of the promotion box.

- Dragging the left border of the promotion box updates the start date of the promotion
• Dragging the right border of the promotion box updates the end date of the promotion

Note: The minimum duration for a promotion is one day. You must click the Save Data button to save modified promotions dates.

See Also:
"Making Other Changes to a Promotion"

Deleting Promotions in the Promotion Calendar
To delete a promotion from a promotion calendar, do one of the following:
• Right-click a promotion and select Delete Promotion
• Click the Delete Promotion icon on the menu bar

Other available right-click options include Open With, Copy, Paste, Duplicate and Optimize.

See Also:
• "Copying and Pasting a Promotion"
• "Duplicating a Promotion"
• "Optimizing a Promotion"

Printing the Promotion Calendar
To print a promotion from the promotion calendar:
1. Click the Print icon on the menu bar.
2. In the Content Selection area, select Current Combination or Entire View.
3. Complete the Layout, Paper, Font, and Fit options as desired.
4. Click the OK button.

Predefined Calendar Views

The PTP: Planning Calendar Worksheet
Oracle Demantra contains a worksheet named PTP: Planning Calendar which has predefined calendar views, as seen here below:
The PTP: Planning Calendar worksheet is designed to be viewed for a selected Retailer, Category and Brand. The Promotion Calendar tab appears in the top section of the worksheet, which contains rows for each Scenario and Promotion Group combination for the selected Retailer, Category and Brand.

- The default Time Scale displays Days within Weeks.

- The Time Range is One Year starting a half-year prior to the latest sales date and ending a half-year after the latest sales date.

- Promotions are displayed on the PTP: Planning Calendar worksheet based on their Start and End Date, which corresponds to the Start Event and End Event series.

- Boxes in the PTP: Planning Calendar worksheet display the following information:
  - Promotion Name
  - Promotion Tactic
  - Sale Price
  - Event Spend

Hovering the mouse pointer over a calendar box displays information about these series as well as the following pre-seeded series:

- Start Event
- End Event
• Start Ship
• End Ship
• Lift
• Incr Mfg Prft

Boxes in the PTP: Planning Calendar worksheet are color-coded based on the predefined Promotion Tactic.

The Promotional Details tab appears at the bottom of the worksheet. It provides a tabular view of all promotions for the currently selected Retailer, Category, Brand, and Promotion Group. The Promotion Group is determined by the currently selected row in the calendar. This tab can be used to edit Series values for a promotion. The worksheet is pre-defined as an Open With on both the Retailer and Category Levels.

Predefined Promotion Calendar Series
The Promotion Calendar contains two series:

• Calendar View Settings: This series defines the Color Expression for the promotion boxes in the calendar.

• Calendar Edit Lock Setting: This series determines whether or not a promotion box can be moved or re-sized.

Moving and Resizing Boxes in the Predefined Promotion Calendar
The ability to move and resize boxes in the PTP Planning Calendar worksheet is controlled by predefined Promotion Status values. Promotions can be moved and resized only until they reach a Committed status. The ability to move and resize boxes in the predefined Promotion Calendar is dependent on the following:

• Users’ security clearance must allow them update access to the Promotion Member.

• The Allow Updates from Calendar system parameter must be set to Yes. The default value is No.

• Start Date and End Date series must be editable. By default, these series are not editable.

• The LOCK_EXPRESSION_SERIES_ID for the Calendar View must be set to null or the corresponding Edit Lock Expression must be set to False.

Configuring Calendar Views
System administrators can further define Promotion Calendar definitions by updating tables with a tool such as SQL Developer.
Configuring Time Granularity

Use worksheet tables to change the time granularity displayed on a promotion calendar.

See Also:
"Configuring Calendar Views" in the Oracle Demantra Implementation Guide

You can also change the time granularity by right-clicking the header at the top of the Promotion Calendar. Available options are as follows:

- Year
- Month
- Week
- Day
This chapter covers the following topics:

- Overview
- Running the Analytical Engine in Simulation Mode
- Running a Simulation
- Optimizing a Promotion
- Viewing Optimization Results
- Calendar Optimization
- Accepting an Optimized Promotion
- Reference

**Overview**

Before you mark a promotion as planned (or before you commit a promotion), you may want to run a simulation on it, or run the optimizer, or both. This chapter describes how to perform these tasks.


A qualified user or administrator typically runs the Analytical Engine periodically in batch mode to generate a forecast for all items and locations in the system. The forecast data includes total volume, base volume (volume in the absence of promotions), incremental volume, pre- and post-promotional volume, and volume due to cannibalization.

To see an immediate forecast for a newly entered promotion, however, you do not have
to wait for the next batch run. You can simply run a simulation, which considers only one promotion. With the forecasted numbers, you can see the effect on quota, accruals, spending, and so on. Likewise, if you change the properties of a promotion, you can run a simulation to see the resulting forecast.

Also, to help you find the most effective promotion for your needs, PTP provides the ability to optimize a promotion. The Promotion Optimization module uses the previously stored results of the Analytical Engine. You provide a specific goal and constraints, and the optimizer determines the best set of promotion properties. PTP provides a worksheet for viewing the optimized results, which you can then accept, if these results meet your needs.

In principle, you can run simulation or optimization anywhere PTP displays future promotions. Then you can open another worksheet filtered to your promotion to see further details. Or you can first open that worksheet and then run simulation or optimization. Several worksheets are useful for these purposes.

The path you choose depends on what meets your needs at any time, but consider the following general principles:

- If you run a simulation in the Planning Environment or the PTP: Optimization Comparison worksheet, the engine does not have the data needed to see cannibalization, which means that you may need to rerun simulation later in a different worksheet. If you run simulation in the other worksheets (PTP: Promotion Comparison, PTP: Promo Effect - Mfg, and PTP: Promo Effect - Rtl), the Analytical Engine can find cannibalization.

- The PTP: Optimization Comparison worksheet is the only place that displays optimization results.
Note: Before you can perform either simulation or optimization, it is necessary to run the Analytical Engine in batch mode once in your application. See Running Required Workflows, page 10-2.

Running the Analytical Engine in Simulation Mode

Before you can perform simulations, you must start the Analytical Engine in simulation mode. Note that an error will occur if the Analytical Engine has not been run previously in batch mode.

To run the engine in simulation mode

1. Click Start > Programs.
2. Click Demantra > Demantra Spectrum release > Simulation Engine.

Running a Simulation

You can run a simulation to get a forecast for a promotion, particularly a newly created promotion or a promotion that you have just changed.

Note: The promotion must start in the future.

To run a simulation

1. Make sure the Analytical Engine is running in simulation mode; see Running the Analytical Engine in Simulation Mode, page 10-3.
2. Start in the Planning Environment worksheet.
3. Right-click a promotion and launch a worksheet, such as PTP: Promo Effect - Mfg or PTP: Promo Effect - Rt1.

Note: In principle, you can run a simulation in any worksheet. Note that if you run a simulation in the Planning Environment worksheet, however, the engine does not have the data needed to see cannibalization.

4. Click Data > Run Simulation or click the Simulation icon.

The Select Simulation Type page appears.
5. Click Selected Combination.

6. For Select Engine Profile, click Simulation.

7. Click OK.

   Depending on the amount of data in your worksheet, simulation may take a few minutes.

8. When the simulation is complete, Oracle Demantra displays a message. Click OK.

9. Rerun the worksheet.

10. Examine the results.

11. To accept the results, click Data > Accept Simulation.

In certain circumstances, you may want to specify these settings each time you run a simulation. In other instances, perhaps in situations where you will be using essentially the same settings repeatedly, you can set and save defaults for running simulations. You can save simulation settings for:

- A specific user and worksheet combination
- A specific user for all worksheets
- A specific worksheet for all users
- All users and all worksheets

**To set simulation defaults**

1. Click Data > Set Simulation Defaults or click the Simulation Defaults icon.
The Simulation Settings page appears.

2. Optionally, select the Save any unsaved worksheet data changes checkbox. By default, this checkbox is unchecked.

3. In the second checkbox and drop-down list combination, specify if you want to accept or reject any existing simulations on the worksheet. By default, this checkbox is not checked and the drop-down list is set to Accept.

4. Select the third checkbox if you want to specify Engine Profile and Simulation Type defaults. By default, this checkbox is not selected.
   - Select an engine profile from the Engine Profile drop-down list.
   - Select one of the following simulation types from the Simulation Type drop-down list:
     - Selected Combination
     - Selected Page Item
     - Entire Worksheet

5. Optionally, select the Notify when Simulation Completes checkbox.

6. Use the Save as Default Settings checkbox to specify if the default settings apply to the current worksheet or to all worksheets. When you select All Worksheets, you can also specify whether or not to clear any existing worksheet specific settings.
7. Click the Run Simulation button.

The system runs a simulation using the current settings. If the Save as Default Settings checkbox is selected, these settings are saved as specified. The next time you run a simulation, you will be prompted for each option that was not checked in the saved settings.

### Optimizing a Promotion

If you need to find the best possible promotion, license Oracle Demantra Trade Promotion Optimization (TPO).

PTP provides an optimizer that you can use to find the best possible promotion to maximize revenue, profit, or units. It considers constraints such as the following:

- Retailer-specific details such as minimum needed retailer event margin. You can override the retailer’s default event margin if needed.
- Maximum budget and buydown for this promotion.
- Basics such cost of goods, list price, and so on.

If you need more control of the analytical engine and use Oracle Demantra Trade Promotion Optimization, you can use its advanced analytics capability.

### To optimize a promotion

**Note:** Before you can optimize a promotion you must set certain parameters and other setup tasks. For more information, see Configuring Promotion Optimization for Predictive Trade Planning in the Demantra Implementation guide.


2. In the Event Planner window, right-click any future promotion and click Methods > Optimize.

   PTP displays the Optimize Promotion dialog box.
3. Specify values for the following parameters:

- **Optimization Goal**: Select one of the following goals for this promotion:
  - Maximize Revenue
  - Maximize Profit
  - Maximize Units

- **Max Budget**: Maximum allowed budget for this promotion. If you leave this unspecified, there is no maximum budget.
Optimization Range Start, Optimization Range End
If these are blank, Promotion Optimization assumes that you want the optimized promotion to fall within the span of time of the original promotion. If you want Promotion Optimization to search for a better time for this promotion, use these parameters to specify the range of time for optimization to consider.

Buydown Generation Method
Specify whether Promotion Optimization should use the buydown that you have already entered or calculate an optimal buydown for this promotion.

Max Buydown
Maximum allowed buydown for this promotion. If Promotion Optimization calculates an optimal buydown, the buydown will not exceed this value.

Min Rtl Margin Override
Minimum margin that the retailer must make on this promotion, as specified in this retailer's profile. Use this parameter to override that value, if needed.

Use a value greater than 0 and less than or equal to 1.

4. Click Optimize.

Now the system will select the promotion parameters (sale price, vehicle type, and so on) that best meet your goal. This is a huge time saver because you do not have to go through all the possible permutations of each promotion in order to find the best one for your goal.

When optimization is complete, PTP displays a message that indicates the status of the optimization and the number of iterations that it ran. (You may not see this message, depending on how PTP is configured.)

Then PTP asks if you want to rerun the worksheet.

5. Click OK.

6. If you are not yet in the TPO: Optimization Comparison worksheet, right-click the promotion and open that worksheet. See Viewing Optimization Results, page 10-8.

Viewing Optimization Results

To view optimization results
If you are not yet in the TPO: Optimization Comparison worksheet, right-click the
promotion and click Open With > TPO: Optimization Comparison.

The TPO: Optimization Comparison worksheet provides the capability to view the optimization results (shown in yellow) and compare them to the current state of the promotion, to help you decide if you want to accept this optimization. This worksheet contains the following information.

**Event Planner and Optimized Event Planner**

These windows provide details of the events, including start and end ship dates, vehicle type, vehicle cost, buydown, base volume and incremental volume. Incremental volume is generated by Oracle Demantra’s comprehensive analytical engine.

The Event Planner window shows these details for the actual promotion as it currently is. The Optimized - Event Planner window shows the details of the optimized promotion. If you accept the optimization, these details are moved to the actual promotion.

Notice that the values are given right below the original values of the promotion to facilitate easy comparison.

If you have not yet optimized this promotion, the Optimized - Event Planner window is empty.
Cost Benefit Review and Optimized - Cost Benefit Review

These windows display a detailed cost benefit analysis, including profitability metrics from both the manufacturer and retailer’s perspective, overall event spend, cost per incremental unit (CPIU), and so on. The Cost Benefit Review window displays these details for the actual promotion as it currently is. The Optimized - Cost Benefit Review window shows the details of the optimized promotion. If you accept the optimization, these details are moved to the actual promotion.

Here notice that the color of the Evt Status series (upper window only) indicates the optimization status of this promotion:

- White means that the promotion has not been optimized.
- Yellow means that the promotion has been optimized.
- Green means that the promotion has been optimized and accepted, so that the promotion is using the optimization results.

If you have not yet optimized this promotion, the Optimized - Cost Benefit Review window is empty.

Graphs

This worksheet also provides the following graphs:

- Sales Comparison: Compares the total event dollars generated before and after optimization.
- Incr Mfg Prft Comparison: Compares the incremental manufacturing profit generated before and after optimization. This is the additional profit that the manufacturer earns because of the promotion, in addition to the base profit that would be earned even without a promotion.
- Incr Rtl Prft Comparison: Compares the incremental retailer profit generated before and after running optimization. This is the additional profit that the retailer earns because of the promotion, in addition to the base profit that would be earned even without a promotion.
- Spend Comparison: Compares the event spend before and after running
If you have not yet optimized this promotion, each of these graphs includes only one bar, corresponding to the promotion in its current state.

Possible Actions

In this worksheet, depending on your authorization, you can do the following:

- Edit a promotion, by changing the sale price and other properties. You can also right-click a promotion and select Edit to access other properties.

- Run simulations. See Running a Simulation, page 10-3.

- Run or rerun optimization. See Optimizing a Promotion, page 10-6.

- Use the right-click menu to open other worksheets filtered to this promotion.

Calendar Optimization

Calendar Optimization enables users to create and optimize groups of promotions that are designed to achieve specific business goals. Users enter a set of business objectives (such as optimizing units, revenue, or profit) and constraints (such as minimum retailer margin), and the optimizer determines the best set of promotions and promotion properties.

This process differs from Promotion Optimization in that rather than optimizing a single, existing promotion, Calendar Optimization optimizes groups of existing promotions and will also create new promotions within a Scenario to meet the objectives that you specify. As well, Calendar Optimization creates new promotions within a scenario to meet the requested business objectives that you specify.

You can access the Calendar Optimization process from any worksheet that includes the Promotion hierarchy and the Scenarios hierarchy level. You can also execute Calendar Optimization functions and view calendar optimization output from the PTP: Calendar Optimization worksheet.

Optimizing a Promotion Calendar

1. Open the PTP: Calendar Optimization Worksheet.

   Note: You can also access the Calendar Optimization from any worksheet that includes the Promotion hierarchy and the Scenarios level.

2. Right-click on a scenario and select Call Calendar Optimizer.
The Call Calendar Optimizer dialog box appears.

3. Specify values for the following parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum Budget</td>
<td>The maximum amount of funds the Optimizer can spend across all promotions it creates in the scenario.</td>
</tr>
<tr>
<td>Optimization Goal</td>
<td>The business goal the optimizer will focus on across all promotions in the scenario. Can be one of:</td>
</tr>
<tr>
<td></td>
<td>• Optimize Units</td>
</tr>
<tr>
<td></td>
<td>• Optimize Revenue</td>
</tr>
<tr>
<td></td>
<td>For more information on these options, refer to Optimizing a Promotion.</td>
</tr>
<tr>
<td>Optimization Target</td>
<td>The accounts and products that the Optimizer evaluates as possible places to promote when selecting the optimal calendar. All promotions created by the Calendar Optimizer are always created within the Optimization Target. The time range provided is the time range evaluated during the calendar optimization. The Optimizer selects the optimal time and products and places of the Optimization Target to promote.</td>
</tr>
<tr>
<td>Max Promotions in Scenario</td>
<td>The maximum number of promotions the Optimizer can create in the scenario.</td>
</tr>
<tr>
<td>Max Promotions Per Account</td>
<td>The maximum number of promotions the Optimizer can create in each account.</td>
</tr>
<tr>
<td>Max Promos Per Promo Group</td>
<td>The maximum number of promotions the Optimizer can create for each promotion group per account.</td>
</tr>
<tr>
<td>Max Allocation Per Promotion</td>
<td>The maximum percentage budget allocation (out of the total budget) allowable for any single promotion in the scenario.</td>
</tr>
<tr>
<td>Max Length of Promotion</td>
<td>The maximum number of periods for any single promotion created in the scenario.</td>
</tr>
</tbody>
</table>
Budget Fair Share Flexibility  The flexibility that the Optimizer has to spend funds outside the allocation of budget according to sales revenue share. The larger the number the more flexibility the optimizer has to spend funds outside a fair share sales allocation.

4. Click Optimize. The Optimizer will select the promotion parameters (sale price, vehicle type, and so on) that best meet your goals.

   **Note:** Calendar Optimization is a larger process than Promotion Optimization so the performance of the request will depend on the scope of the Optimization Target values specified for the other parameters.

   While the Optimizer is working the lower left of the window shows an activity signal. Once the Optimizer has completed a dialog appears with the optimization results. The dialog displays:

   • Optimal Budget: the amount of funds the Optimizer spent in this scenario.
   • Total Lift($): the total amount of Incremental Dollars in this scenario.
   • Profit: the total profit of the scenario across all promotions.
   • Return on Investment (ROI): the value calculated by (Total Lift)/ Investment (Optimal Budget).

**Viewing Calendar Optimization Results**

You can review the promotions created by the optimizer in the PMO: Calendar Optimization worksheet and any worksheet that includes the Promotion hierarchy and Scenarios level. The Promotion Calendar tab of the PMO: Calendar Optimization worksheet shows the calendar of promotions in the scenario laid out across products and time for each account.

The Investment Across Products tab contains a graph that shows how the optimizer allocated the funds across the products it selected for optimization. The table shows additional data on how the investment, return and profit varied across the products promoted by the Optimizer.

The user can always see the optimization summary results by selecting the View Optimization Results menu item available in the Scenario popup menu. This opens a dialog showing the optimization summarized results.

You can see a summary of optimization results by right-clicking on a Scenario and...
selecting the View Optimization Results method. This opens a dialog showing a summary of the optimization results.

The promotions created by the optimizer are similar to any other promotion and can be included in the planning process at any time. The optimizer creates promotions with a proposed status. To include a promotion in the planning process, change the promotion status to either Unplanned, Planned or Committed. When the promotion is changed to any of these statuses, it is still included in the optimization process. Every time the Optimizer runs, it produces a set of promotions to satisfy the optimization goals. Existing promotions with the Proposed status may be replaced by alternative promotions. All promotions which are in other statuses are always preserved by the Optimizer.

If the promotion status is Planned, then the promotion will be included in the optimization and the promotion tactic will not be changed, but the promotion attributes may be optimized to reflect a possibly better attribute (such as discount) for the planned promotion. If the status is Committed, then the promotion will be included in the optimal solution and the tactic and attributes that are defined will not be modified by the optimizer. Additionally, any committed promotions that are outside the scope of the scenario will also be included if they fall into the same Product Account and Date ranges defined for the scenario.

You can also delete the promotions that were added to the scenario by the optimizer by selecting the method Clear Optimizer Promotions.

**Accepting an Optimized Promotion**

After you optimize a promotion, you can accept it. You can do this in any worksheet that displays promotions. For example, you can start in the TPO: Optimization Comparison worksheet.

**Note:** This action has no effect on a promotion that has not been optimized.

**To accept an optimized promotion**

1. Right-click the promotion and select Methods > Accept Optimization.

   If you accept the optimization, the attributes of the optimized promotion are copied into the original promotion. Also notice that the color of the Evt Status series changes to green, to indicate that optimization has been accepted.

2. Optionally rerun simulation for a new net-lift analysis; see Running a Simulation, page 10-3.

3. Optionally right-click the promotion and launch either PTP: Promo Effect - Mfg or PTP: Promo Effect - Rt.
See

- PTP: Examining and Comparing Promotions - Examining Promotions from the Manufacturer’s Point of View, page 11-2

Reference

TPO: Optimization Comparison

Basics

<table>
<thead>
<tr>
<th>Accessing this worksheet</th>
<th>Right-click a promotion and click Open With &gt; TPO: Optimization Comparison.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Levels you can select</td>
<td>Territory, Retailer, Promotion</td>
</tr>
<tr>
<td>Levels used in cross tabulation</td>
<td>Promotion Group, Scenario</td>
</tr>
<tr>
<td>Time aggregation</td>
<td>Yearly</td>
</tr>
</tbody>
</table>

Business Data

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Planner</td>
<td>Start Ship</td>
<td>Date when product will start to ship</td>
</tr>
<tr>
<td></td>
<td>End Ship</td>
<td>Date when shipments will end for the event</td>
</tr>
<tr>
<td></td>
<td>Start Event</td>
<td>Date when promotion starts in stores</td>
</tr>
<tr>
<td></td>
<td>End Event</td>
<td>Date when the promotion ends.</td>
</tr>
<tr>
<td></td>
<td># Wks</td>
<td>Event length in whole weeks, assuming that each week starts on Monday.</td>
</tr>
<tr>
<td></td>
<td>Veh Type</td>
<td>Vehicle type or event type of the promotion</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Veh $</td>
<td>Vehicle cost for the promotion</td>
<td></td>
</tr>
<tr>
<td>Cons Promo</td>
<td>Consumer overlay, the deal type as seen by the consumer.</td>
<td></td>
</tr>
<tr>
<td>Shelf Price</td>
<td>Everyday price to the consumer</td>
<td></td>
</tr>
<tr>
<td>Sale Price</td>
<td>Sale price per unit at shelf</td>
<td></td>
</tr>
<tr>
<td>Buydown</td>
<td>Buydown allowance per unit, discount offered to retailer for running the event</td>
<td></td>
</tr>
<tr>
<td>Lift</td>
<td>Lift factor for the promotion</td>
<td></td>
</tr>
<tr>
<td>Base Evt Vol</td>
<td>Base volume during the promotion</td>
<td></td>
</tr>
<tr>
<td>Incr Evt Vol</td>
<td>Incremental volume due to the promotion</td>
<td></td>
</tr>
<tr>
<td>Ttl Evt Vol</td>
<td>Total volume for the promotion</td>
<td></td>
</tr>
<tr>
<td>Optimized - Event Planner</td>
<td>Start Ship</td>
<td>Date when product will start to ship</td>
</tr>
<tr>
<td></td>
<td>End Ship</td>
<td>Date when shipments will end for the event</td>
</tr>
<tr>
<td></td>
<td>Start Event O</td>
<td>Date when optimized promotion starts in stores</td>
</tr>
<tr>
<td></td>
<td>End Event</td>
<td>Date when the promotion ends.</td>
</tr>
<tr>
<td></td>
<td># Wks O</td>
<td>Event length in whole weeks, assuming that each week starts on Monday, for optimized promotion</td>
</tr>
<tr>
<td></td>
<td>Veh Type O</td>
<td>Vehicle type or event type of the optimized promotion</td>
</tr>
<tr>
<td></td>
<td>Veh $ O</td>
<td>Vehicle cost for the optimized promotion</td>
</tr>
<tr>
<td></td>
<td>Cons Promo</td>
<td>Consumer overlay, the deal type as seen by the consumer.</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Shelf Price</td>
<td>Everyday price to the consumer</td>
<td></td>
</tr>
<tr>
<td>Sale Price O</td>
<td>Sale price per unit at shelf, for the optimized promotion</td>
<td></td>
</tr>
<tr>
<td>Buydown O</td>
<td>Buydown allowance per unit, for optimized promotion</td>
<td></td>
</tr>
<tr>
<td>Lift O</td>
<td>Lift factor for the optimized promotion</td>
<td></td>
</tr>
<tr>
<td>Base Evt Vol O</td>
<td>Base volume for optimized promotion</td>
<td></td>
</tr>
<tr>
<td>Incr Evt Vol O</td>
<td>Incremental volume due to the optimized promotion</td>
<td></td>
</tr>
<tr>
<td>Ttl Evt Vol O</td>
<td>Total volume for the optimized promotion</td>
<td></td>
</tr>
<tr>
<td>Cost Benefit Review</td>
<td>Base Evt $</td>
<td>Base sales for the manufacturer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $</td>
<td>Incremental sales to the manufacturer due to the event</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt $</td>
<td>Total sales during the promotion, for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Mfg Profit</td>
<td>Manufacturer’s profit from the event</td>
</tr>
<tr>
<td></td>
<td>Incr Mfg Prft</td>
<td>Incremental profit to the manufacturer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Rtl Prft</td>
<td>Retailer’s profit from the event</td>
</tr>
<tr>
<td></td>
<td>Incr Rtl Prft</td>
<td>Incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Evt Spend exS</td>
<td>Total planned buydown and vehicle costs for promotion</td>
</tr>
<tr>
<td></td>
<td>CPIU</td>
<td>Event cost per incremental unit sold as a result of the promotion.</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>% Spend</td>
<td></td>
<td>Event spending, as a percentage of event sales</td>
</tr>
<tr>
<td>Evt Status</td>
<td></td>
<td>Current status of the promotion</td>
</tr>
<tr>
<td>Optimized - Cost Benefit</td>
<td>Base Evt $ O</td>
<td>Base sales for manufacturer, for optimized promotion</td>
</tr>
<tr>
<td>Review</td>
<td>Incr Evt $ O</td>
<td>Incremental sales to the manufacturer due to the event, for the optimized promotion</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt $ O</td>
<td>Total sales during the promotion, for the manufacturer (for the optimized promotion)</td>
</tr>
<tr>
<td></td>
<td>Mfg Prft O</td>
<td>Manufacturer's profit from the optimized event</td>
</tr>
<tr>
<td></td>
<td>Incr Mfg Prft O</td>
<td>Incremental profit to the manufacturer due to the optimized promotion</td>
</tr>
<tr>
<td></td>
<td>Rtl Prft O</td>
<td>Retailer's profit from the optimized event</td>
</tr>
<tr>
<td></td>
<td>Incr Rtl Prft O</td>
<td>Incremental profit to the retailer due to the optimized promotion</td>
</tr>
<tr>
<td></td>
<td>Evt Spend exS O</td>
<td>Total planned buydown and vehicle costs for optimized promotion</td>
</tr>
<tr>
<td></td>
<td>CPIU O</td>
<td>Event cost per incremental unit sold as a result of the promotion, for optimized promotion</td>
</tr>
<tr>
<td></td>
<td>% Spend O</td>
<td>Event spending, as a percentage of event sales, for optimized promotion</td>
</tr>
<tr>
<td>Sales Comparison</td>
<td>Ttl Evt $</td>
<td>Total sales during the promotion, for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt $ O</td>
<td>Total sales during the promotion, for the manufacturer (for the optimized promotion)</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------</td>
<td>--------------------------------------------------------------</td>
</tr>
<tr>
<td>Incr Mfg Prft Comparison</td>
<td>Incr Mfg Prft</td>
<td>Incremental profit to the manufacturer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Mfg Prft O</td>
<td>Incremental profit to the manufacturer due to the optimized promotion</td>
</tr>
<tr>
<td>Incr Rtl Prft Comparison</td>
<td>Incr Rtl Prft</td>
<td>Incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Rtl Prft O</td>
<td>Incremental profit to the retailer due to the optimized promotion</td>
</tr>
<tr>
<td>Spend Comparison</td>
<td>Evt Spend exS</td>
<td>Total planned buydown and vehicle costs for promotion</td>
</tr>
<tr>
<td></td>
<td>Evt Spend exS O</td>
<td>Total planned buydown and vehicle costs for optimized promotion</td>
</tr>
</tbody>
</table>
Examining and Comparing Promotions

Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:

• Overview
• Examining Promotions from the Manufacturer’s Point of View
• Examining Promotions from a Retailer’s Point of View
• Comparing Promotions in a Scenario
• Reference

Overview

This chapter describes how to examine and compare promotions, to help you choose the best promotion for your needs. It includes the following sections:

Before you mark a promotion as planned (or before you commit a promotion), you generally examine the promotion to be sure you have chosen the best vehicle type and so on.

To evaluate promotions, you generally start in the Planning Environment worksheet. From there, you right-click a promotion and launch any of the relevant TPO worksheets to see data for that promotion.
Examining Promotions from the Manufacturer's Point of View

To evaluate a future promotion from the manufacturer's point of view

1. You typically start in the Planning Environment; see Introduction to the Planning Environment, page 8-1.

2. In the Event Planner window, right-click a promotion and click Open With > PTP: Promo Effect - Mfg.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.

The system displays the PTP: Promo Effect - Mfg worksheet, filtered to display just the promotion that you right-clicked.
This worksheet includes the following areas.

**Event Planner**

This window is the same as the Event Planner window in the Planning Environment worksheet. It displays details of all events, including start and end ship dates, vehicle type, vehicle cost, buydown, base volume and incremental volume.

**Cost Benefit Review**

This window is similar to the Cost Benefit Review window in the Planning Environment worksheet. It displays a detailed cost benefit analysis, including profitability metrics, overall event spend, and cost per incremental unit (CPIU).

**Lift Decomposition Graph - Manufacturer**

This window shows the effects of the promotion, from the perspective of the manufacturer.
Four series are shown here:

- **Base Evt Value** is the base money earned by the manufacturer over the course of the promotion. This money would have been earned even without the promotion.

- **Canbl Value P** is the net additional money earned by the manufacturer as a result of the promotion; this accounts for both cannibalization and pre- and post-effects.

- **Canbl $** is the money lost by the manufacturer due to cannibalistic effects of the promotion. For display purposes only, this is shown as a positive number so that it can be graphed.
• Pre Post Sales is the money lost by the manufacturer due to decreased sales before and after the promotion. For display purposes only, this is shown as a positive number so that it can be graphed.

The total height of the bar graph indicates how much money the manufacturer received in sales, if cannibalization and pre- and post-effects were ignored.

**Lift Decomposition Table - Manufacturer**

The Lift Decomposition table displays the same numbers as the preceding graph, but displays all promotion groups that were impacted by the selected promotion. Each promotion group is shown as a row; the blue row indicates the promotion group on which the selected promotion actually ran. This table also summarizes the effects across brands, and across companies, for convenient comparison.

For the promoted promotion group (Exedra 100), you can see the total event dollars, incremental event dollars, net incremental event dollars and so on, for the selected promotion. Note that for Exedra 100, there was zero dollars of cannibalization and $2743 of pre- and post-promotional effect.

On the other hand, examine the other promotion groups and notice that they were all cannibalized. Of course, for these promotion groups, there was zero direct lift, by definition, as the promotion did not run on them.

Here you can see these useful summaries:

• Total for promotion group where the promotion was run.

• Total effect on the brand.

• Total effect on the manufacturer.

Also notice that this table displays cannibalized and pre- and post-event volume, as well.

**Lift Decomposition - Retailer**

This table summarizes the cannibalization effects as seen by the retailer; see Examining Promotions from a Retailer’s Point of View, page 11-6 for details.
Possible Actions

In this worksheet, depending on your authorization, you can do the following:

- Edit a promotion, by changing the sale price and other properties. You can also right-click a promotion and select Edit to access other properties.

- Run simulations. See Running a Simulation, page 10-3.

- Run optimization. See Optimizing a Promotion, page 10-6.

- Use the right-click menu to open other worksheets filtered to this promotion. For example, you can open the PTP: Promo Effect - Rtl worksheet to see the retailer’s perspective. See Examining Promotions from a Retailer’s Point of View, page 11-6.

- View aggregate information for the retailer at the bottom of the screen.

Examining Promotions from a Retailer’s Point of View

To evaluate a future promotion from a retailer’s point of view

1. You typically start in the Planning Environment; see "Introduction to the Planning Environment.

2. In the Event Planner window, right-click a promotion and click Open With > PTP: Promo Effect - Rtl.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.

The system displays the PTP: Promo Effect - Rtl worksheet, filtered to display just the promotion that you right-clicked.
This worksheet includes the same areas as the PTP: Promo Effect - Mfg worksheet, but from the retailer's point of view rather than the manufacturer's.

**Lift Decomposition Table - Retailer**

The Lift Decomposition table displays all promotion groups that were impacted by the selected promotion, from the point of view of the retailer. Each promotion group is shown as a row; the blue row indicates the promotion group (Exedra 100) on which the selected promotion actually ran.

Notice two promotion groups are listed here that were not seen in the manufacturer version: Notrim 24 and Tyitol 50. These promotion groups represent products that this retailer sells, but that are made by a different manufacturer. To the retailer, it is undesirable to cannibalize these promotion groups.

Here you can see these useful summaries:

- Total for promotion group where the promotion was run.
- Total effect on the brand.
- Total effect on each manufacturer.

Also notice that this table displays cannibalized and pre- and post-event volume, as well.
Possible Actions

In this worksheet, depending on your authorization, you can do the following:

- Edit a promotion, by changing the sale price and other properties. You can also right-click a promotion and select Edit to access other properties.

- Run simulations. See "Running a Simulation."

- Run optimization. See "Optimizing a Promotion."

- Use the right-click menu to open other worksheets filtered to this promotion. For example, you can open the PTP: Promo Effect - Mfg worksheet to see the manufacturer’s perspective. See "Examining Promotions from the Manufacturer’s Point of View."

Comparing Promotions in a Scenario

To determine how best to spend trade dollars, you can compare and evaluate multiple promotions in a scenario. Typically you create multiple unplanned promotions in the Sandbox scenario and then open the PTP: Promotion Comparison worksheet to view them side by side.

When you identify the best promotion, you can mark it as planned; see Marking a Promotion as Planned, page 8-8.

To compare promotions

1. You typically start in the Planning Environment; see "Introduction to the Planning Environment."

2. In the Event Planner window, right-click a scenario and click Open.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.

This launches the PTP: Promotion Comparison worksheet filtered to show the promotions of that scenario.
Now you can easily compare all events in the selected scenario. The screen now displays the following areas.

**Event Planner**

This window is the same as the Event Planner window in the Planning Environment worksheet. It displays details of all events, including start and end ship dates, vehicle type, vehicle cost, buydown, base volume and incremental volume. Incremental volume is generated by Oracle’s comprehensive Analytical Engine.

**Cost Benefit Review**

This window is the same as the Cost Benefit Review window in the Planning Environment worksheet. It displays a detailed cost benefit analysis, including profitability metrics from both the manufacturer and retailer’s perspective, overall event spend, cost per incremental unit (CPIU), payment type and price analysis (average retail vs. list).

**Graphs**

This worksheet displays the following graphs:
- Lift Breakdown: each event is shown as a separate bar.
- Cost Per Incremental Unit: each event is shown as a separate bar.
Possible Actions

In this worksheet, depending on your authorization, you can do the following:

• Edit a promotion, by changing the sale price and other properties. You can also right-click a promotion and select Edit to access other properties.

• Create new promotions; see Creating a Promotion, page 8-6.

• Delete a promotion; see Deleting a Promotion, page 8-16.

• Make a copy of a promotion; see Copying and Pasting a Promotion, page 8-15.

• Run simulations. See Running a Simulation, page 10-3.

• Run optimization. See Optimizing a Promotion, page 10-6.

• Right-click a promotion and open another worksheet filtered to that promotion. For example, you can open the PTP: Promo Effect - Rt worksheet to see cannibalization from the retailer's perspective. See Examining Promotions from a Retailer's Point of View, page 11-6.

• Change the status of a promotion, as described in PTP: Planning Promotions - Introduction to the Planning Environment, page 8-1.

Reference

PTP: Promo Effect - Mfg

Basics

<table>
<thead>
<tr>
<th>Accessing this worksheet</th>
<th>Right-click a promotion and click Open With &gt; PTP: Promo Effect - Mfg.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Levels you can select</td>
<td>Retailer, Category, Promotion</td>
</tr>
<tr>
<td>Levels used in cross tabulation</td>
<td>Promotion</td>
</tr>
<tr>
<td>Time aggregation</td>
<td>Yearly</td>
</tr>
</tbody>
</table>
## Business Data

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Planner</td>
<td>Start Ship</td>
<td>Date when product will start to ship</td>
</tr>
<tr>
<td></td>
<td>End Ship</td>
<td>Date when shipments will end for the event</td>
</tr>
<tr>
<td></td>
<td>Start Event</td>
<td>Date when the promotion starts in stores</td>
</tr>
<tr>
<td></td>
<td>End Event</td>
<td>Date when the promotion ends</td>
</tr>
<tr>
<td></td>
<td># Wks</td>
<td>Event length in whole weeks, assuming that each week starts on Monday.</td>
</tr>
<tr>
<td></td>
<td>Veh Type</td>
<td>Vehicle type or event type of the promotion</td>
</tr>
<tr>
<td></td>
<td>Veh $</td>
<td>Vehicle cost for the promotion</td>
</tr>
<tr>
<td></td>
<td>Cons Promo</td>
<td>Consumer overlay, the deal type as seen by the consumer.</td>
</tr>
<tr>
<td></td>
<td>Shelf Price</td>
<td>Everyday price to the consumer</td>
</tr>
<tr>
<td></td>
<td>Sale Price</td>
<td>Sale price per unit at shelf</td>
</tr>
<tr>
<td></td>
<td>Units</td>
<td>Number of units in the deal to the consumer. Usually equal to 1. Use 2 for 2-for-1 sales, for example.</td>
</tr>
<tr>
<td></td>
<td>Buydown</td>
<td>Buydown allowance per unit, discount offered to retailer for running the event</td>
</tr>
<tr>
<td></td>
<td>Lift</td>
<td>Lift factor for the promotion</td>
</tr>
<tr>
<td></td>
<td>Base Evt Vol</td>
<td>Base volume during the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt Vol</td>
<td>Incremental volume due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt Vol</td>
<td>Total volume for the promotion</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Cost Benefit Review</td>
<td>Ttl Evt $</td>
<td>Total sales during the promotion, for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $</td>
<td>Incremental sales to the manufacturer due to the event</td>
</tr>
<tr>
<td></td>
<td>Base Evt $</td>
<td>Base sales for the manufacturer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $</td>
<td>Net revenue to the manufacturer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Canbl $</td>
<td>Cannibalization dollars for the manufacturer</td>
</tr>
<tr>
<td>Pre Post Sales</td>
<td></td>
<td>Total sales made before and after the promotion, as a result of the promotion (manufacturer's perspective)</td>
</tr>
<tr>
<td></td>
<td>Mfg Profit</td>
<td>Manufacturer's profit from the event</td>
</tr>
<tr>
<td></td>
<td>Incr Mfg Prft</td>
<td>Incremental profit to the manufacturer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Mfg Prft</td>
<td>Net incremental profit for the manufacturer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Rtl Prft</td>
<td>Retailer's profit from the event</td>
</tr>
<tr>
<td></td>
<td>Incr Rtl Prft</td>
<td>Incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Rtl Prft</td>
<td>Net incremental profit for the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Evt Spend</td>
<td>Total planned spending for promotion, sum of buydown, vehicle costs, and slotting</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CPIU</td>
<td>Event cost per incremental unit sold as a result of the promotion.</td>
<td></td>
</tr>
<tr>
<td>% Spend</td>
<td>Event spending, as a percentage of event sales.</td>
<td></td>
</tr>
<tr>
<td>PayType</td>
<td>Indicates the payment terms between the manufacturer and the retailer for this promotion.</td>
<td></td>
</tr>
<tr>
<td>Evt Status</td>
<td>Current status of the promotion.</td>
<td></td>
</tr>
<tr>
<td>Lift Decomposition - Mfg</td>
<td>Base Evt Value</td>
<td>Base sales for the manufacturer, during the promotion.</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $</td>
<td>Net revenue to the manufacturer, after considering cannibalization and pre- and post-effects.</td>
</tr>
<tr>
<td></td>
<td>Canbl $</td>
<td>Cannibalization dollars for the manufacturer.</td>
</tr>
<tr>
<td></td>
<td>Pre Post Value</td>
<td>Total sales made before and after the promotion, as a result of the promotion (manufacturer's perspective)</td>
</tr>
<tr>
<td>Lift Decomposition Table - Manufacturer</td>
<td>Ttl Evt Value</td>
<td>Total sales during the promotion, for the manufacturer.</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $</td>
<td>Incremental sales to the manufacturer due to the event.</td>
</tr>
<tr>
<td></td>
<td>Base Evt $</td>
<td>Base sales for the manufacturer, during the promotion.</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $</td>
<td>Net revenue to the manufacturer, after considering cannibalization and pre- and post-effects.</td>
</tr>
<tr>
<td></td>
<td>Canbl $</td>
<td>Cannibalization dollars for the manufacturer.</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pre Post Sales</td>
<td></td>
<td>Total sales made before and after the promotion, as a result of the promotion (manufacturer’s perspective)</td>
</tr>
<tr>
<td>Canbl Vol Mfg</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pre Post Vol</td>
<td></td>
<td>Total volume before and after the promotion, as a result of the promotion</td>
</tr>
<tr>
<td>Lift Decomposition - Retailer</td>
<td>Ttl Evt Value Rtl P</td>
<td>Total sales during the promotion, for the retailer</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Base Evt $ Rtl</td>
<td>Base sales for the retailer, during the promotion</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Incr Evt $ Rtl</td>
<td>Incremental sales to the retailer due to the event</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $ Rtl</td>
<td>Net revenue to the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Canbl $ Rtl</td>
<td>Cannibalization dollars for the retailer</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pre Post Value Rtl</td>
<td>Total sales made before and after the promotion, as a result of the promotion (retailer’s perspective)</td>
</tr>
</tbody>
</table>

**PTP: Promo Effect - Rtl**

**Basics**

- **Accessing this worksheet**: Right-click a promotion and click Open With > PTP: Promo Effect - Rtl.
- **Levels you can select**: Retailer, Category, Promotion
- **Levels used in cross tabulation**: Promotion
### Business Data

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Planner</td>
<td>Start Ship</td>
<td>Date when product will start to ship</td>
</tr>
<tr>
<td></td>
<td>End Ship</td>
<td>Date when shipments will end for the event</td>
</tr>
<tr>
<td></td>
<td>Start Event</td>
<td>Date when the promotion starts in stores</td>
</tr>
<tr>
<td></td>
<td>End Event</td>
<td>Date when the promotion ends</td>
</tr>
<tr>
<td></td>
<td># Wks</td>
<td>Event length in whole weeks, assuming that each week starts on Monday.</td>
</tr>
<tr>
<td></td>
<td>Veh Type</td>
<td>Vehicle type or event type of the promotion</td>
</tr>
<tr>
<td></td>
<td>Veh $</td>
<td>Vehicle cost for the promotion</td>
</tr>
<tr>
<td></td>
<td>Cons Promo</td>
<td>Consumer overlay, the deal type as seen by the consumer.</td>
</tr>
<tr>
<td></td>
<td>Shelf Price</td>
<td>Everyday price to the consumer</td>
</tr>
<tr>
<td></td>
<td>Sale Price</td>
<td>Sale price per unit at shelf</td>
</tr>
<tr>
<td></td>
<td>Units</td>
<td>Number of units in the deal to the consumer. Usually equal to 1. Use 2 for 2-for-1 sales, for example.</td>
</tr>
<tr>
<td></td>
<td>Buysdown</td>
<td>Buydown allowance per unit, discount offered to retailer for running the event</td>
</tr>
<tr>
<td></td>
<td>Lift</td>
<td>Lift factor for the promotion</td>
</tr>
<tr>
<td></td>
<td>Base Evt Vol</td>
<td>Base volume during the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt Vol</td>
<td>Incremental volume due to the promotion</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>Cost Benefit Review</td>
<td>Ttl Evt Vol</td>
<td>Total volume for the promotion</td>
</tr>
<tr>
<td>Retailer</td>
<td>Ttl Evt $ Rtl</td>
<td>Total sales during the promotion, for the retailer</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $ Rtl</td>
<td>Incremental sales to the retailer due to the event</td>
</tr>
<tr>
<td></td>
<td>Base Evt $ Rtl</td>
<td>Base sales for the retailer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $ Rtl</td>
<td>Net revenue to the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Canbl $ Rtl</td>
<td>Cannibalization dollars for the retailer</td>
</tr>
<tr>
<td></td>
<td>Pre Post Value Rtl</td>
<td>Total sales made before and after the promotion, as a result of the promotion (retailer’s perspective)</td>
</tr>
<tr>
<td></td>
<td>Rtl Prft</td>
<td>Retailer’s profit from the event</td>
</tr>
<tr>
<td></td>
<td>Incr Rtl Prft</td>
<td>Incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Rtl Prft</td>
<td>Net incremental profit for the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Evt Spend</td>
<td>Total planned spending for promotion, sum of buydown, vehicle costs, and slotting</td>
</tr>
<tr>
<td></td>
<td>Pay Type</td>
<td>Indicates the payment terms between the manufacturer and the retailer for this promotion</td>
</tr>
<tr>
<td></td>
<td>Evt Status</td>
<td>Current status of the promotion</td>
</tr>
<tr>
<td>Lift Decomposition</td>
<td>Base Evt $ Rtl</td>
<td>Base sales for the retailer, during the promotion</td>
</tr>
</tbody>
</table>
### View

<table>
<thead>
<tr>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Net Incr Evt $ Rtl</td>
<td>Net revenue to the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td>Canbl $ Rtl</td>
<td>Cannibalization dollars for the retailer</td>
</tr>
<tr>
<td>Pre Post Value Rtl</td>
<td>Total sales made before and after the promotion, as a result of the promotion (retailer’s perspective)</td>
</tr>
<tr>
<td>Lift Decomposition Table - Retailer</td>
<td>Total sales during the promotion, for the retailer</td>
</tr>
<tr>
<td>Incr Evt $ Rtl</td>
<td>Incremental sales to the retailer due to the event</td>
</tr>
<tr>
<td>Base Evt $ Rtl</td>
<td>Base sales for the retailer, during the promotion</td>
</tr>
<tr>
<td>Net Incr Evt $ Rtl</td>
<td>Net revenue to the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td>Net Incr Rtl Prft</td>
<td>Net incremental profit for the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td>Canbl $ Rtl</td>
<td>Cannibalization dollars for the retailer</td>
</tr>
<tr>
<td>Pre Post Value Rtl</td>
<td>Total sales made before and after the promotion, as a result of the promotion (retailer’s perspective)</td>
</tr>
<tr>
<td>Canbl Vol Rtl</td>
<td>Total volume before and after the promotion, as a result of the promotion</td>
</tr>
</tbody>
</table>

### PTP: Promotion Comparison

#### Basics
Accessing this worksheet  
Right-click a scenario and click Open.

Levels you can select  
Territory, Retailer, Promotion Group

Levels used in cross tabulation  
Scenario, Promotion

Time aggregation  
Yearly

### Business Data

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Planner</td>
<td>Start Ship</td>
<td>Date when product will start to ship</td>
</tr>
<tr>
<td></td>
<td>End Ship</td>
<td>Date when shipments will end for the event</td>
</tr>
<tr>
<td></td>
<td>Start Event</td>
<td>Date when the promotion starts in stores</td>
</tr>
<tr>
<td></td>
<td>End Event</td>
<td>Date when the promotion ends</td>
</tr>
<tr>
<td></td>
<td># Wks</td>
<td>Event length in whole weeks, assuming that each week starts on Monday.</td>
</tr>
<tr>
<td></td>
<td>Veh Type</td>
<td>Vehicle type or event type of the promotion</td>
</tr>
<tr>
<td></td>
<td>Veh $</td>
<td>Vehicle cost for the promotion</td>
</tr>
<tr>
<td></td>
<td>Cons Promo</td>
<td>Consumer overlay, the deal type as seen by the consumer.</td>
</tr>
<tr>
<td></td>
<td>Shelf Price</td>
<td>Everyday price to the consumer</td>
</tr>
<tr>
<td></td>
<td>Sale Price</td>
<td>Sale price per unit at shelf</td>
</tr>
<tr>
<td></td>
<td>Units</td>
<td>Number of units in the deal to the consumer. Usually equal to 1. Use 2 for 2-for-1 sales, for example.</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Examine and Compare Promotions</td>
<td>Buydown</td>
<td>Buydown allowance per unit, discount offered to retailer for running the event</td>
</tr>
<tr>
<td></td>
<td>Lift</td>
<td>Lift factor for the promotion</td>
</tr>
<tr>
<td></td>
<td>Base Evt Vol</td>
<td>Base volume during the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt Vol</td>
<td>Incremental volume due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt Vol</td>
<td>Total volume for the promotion</td>
</tr>
<tr>
<td>Cost Benefit Review</td>
<td>Base Evt $</td>
<td>Base sales for the manufacturer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $</td>
<td>Incremental sales to the manufacturer due to the event</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt $</td>
<td>Total sales during the promotion, for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Mfg Profit</td>
<td>Manufacturer's profit from the event</td>
</tr>
<tr>
<td></td>
<td>Incr Mfg Prft</td>
<td>Incremental profit to the manufacturer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Rtl Prft</td>
<td>Retailer's profit from the event</td>
</tr>
<tr>
<td></td>
<td>Incr Rtl Prft</td>
<td>Incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Evt Spend exS</td>
<td>Total planned buydown and vehicle costs for promotion</td>
</tr>
<tr>
<td></td>
<td>CPIU</td>
<td>Event cost per incremental unit sold as a result of the promotion.</td>
</tr>
<tr>
<td></td>
<td>% Spend</td>
<td>Event spending, as a percentage of event sales</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pay Type</td>
<td></td>
<td>Indicates the payment terms between the manufacturer and the retailer for this promotion</td>
</tr>
<tr>
<td>Evt Status</td>
<td></td>
<td>Current status of the promotion</td>
</tr>
<tr>
<td>Lift Breakdown</td>
<td>Base Evt $</td>
<td>Base sales for the manufacturer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $ Net</td>
<td></td>
</tr>
<tr>
<td>Cost Per Incremental Unit</td>
<td>CPIU</td>
<td>Event cost per incremental unit sold as a result of the promotion.</td>
</tr>
</tbody>
</table>
This chapter covers the following topics:

- Overview
- Evaluating Performance from the Manufacturer’s Point of View
- Evaluating Performance from a Retailer’s Point of View
- Reference

**Overview**

This chapter describes how to review past performance of your promotions. It includes the following sections:

To review the performance of past promotions, you generally start in the Planning Environment, page 8-1 worksheet. From there, you right-click a promotion and launch any of the relevant PTP worksheets to see data for that promotion.
Once a promotion has been planned and executed, it is useful to evaluate its performance against your original plan. The PTP: Promo-Evaluation: Mfg, page 12-8 and PTP: Promo-Evaluation: Rtl, page 12-8 worksheets provide a detailed post-promotional analysis of each individual promotion (that is, compare forecast to actual performance).

You can view the breakdown of each event with respect to the sales dollars and profit generated for the manufacturer. Depending on the detail of the historical data, a lift decomposition can be provided showing promotional effects such as the following:

- Cannibalization
- Pre and post effects, such as pantry loading

This will enable you to see your true "net lift" and revised financial figures in order to properly evaluate the event's performance and uncover its true profitability.

**Evaluating Performance from the Manufacturer's Point of View**

**To evaluate a past promotion from the manufacturer's point of view**

1. You typically start in the Planning Environment; see Introduction to the Planning Environment, page 8-1.

2. In the Event Planner window, right-click a promotion and click Open With > PTP: Promo-Evaluation: Mfg.
3. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.

The system displays the PTP: Promo-Evaluation: Mfg worksheet, filtered to display just the promotion that you right-clicked.

The PTP: Promo-Evaluation: Mfg worksheet includes the following windows.

**Event Projections and Event Actuals**

These windows compare the projections and the actuals, one directly above the other. Notice that the actuals are displayed mostly in blue.
The Event Projections window displays planned event details, including event start, vehicle type, total planned volume, anticipated manufacturer profit and anticipated spend. For the series in this window, PTP uses colors to indicate deviations between the projections and the actuals:

- If the actual value is more than 20% different from the projection in the undesirable sense, the projection is shown in red.
- If the actual value is more than 20% different from the projection in the desirable sense, the projection is shown in green. For example, if the actual profit was 130% of the projected profit, the projection is shown in green.

The Event Actuals window shows the corresponding actuals.

**Lift Decomposition Graphs**

This worksheet also displays lift decomposition graphs showing the projected breakdown and the actual breakdown.

![Lift Decomposition Graphs](image)

**Net Incremental Graphs**

The worksheet includes the following graphs to show the net incremental dollars earned for this promotion; each graph compares the projection to the actual. The first graph shows the net incremental dollars. The second and third graphs show the net incremental profit to the manufacturer and retailer, respectively. The net incremental profit is the net additional profit that is earned because of the promotion, in addition to the baseline profit.
Lift Decomposition Table Actual (Manufacturer)

The lift decomposition table shows the specific breakdown into base, incremental, cannibalization, and pre- and post-effect dollars. This table also shows the net incremental volume for the event. This table applies to the manufacturer's point of view.

Possible Actions

In this worksheet, depending on your authorization, you can do the following:

Right-click a promotion and open another worksheet filtered to that promotion. For example, you can open the PTP: Promo-Evaluation: Rtl worksheet to see past performance from the retailer's perspective. See Evaluating Performance from a Retailer's Point of View, page 12-5.

Evaluating Performance from a Retailer's Point of View

To evaluate a past promotion from a retailer's point of view

1. You typically start in the Planning Environment; see Introduction to the Planning Environment, page 8-1.

2. In the Event Planner window, right-click a promotion and click Open With > PTP: Promo-Evaluation: Rtl

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the
Run button.

The system displays the PTP: Promo-Evaluation: Rtl worksheet, filtered to display just the promotion that you right-clicked.

<table>
<thead>
<tr>
<th>Event Projections and Event Actuals</th>
</tr>
</thead>
<tbody>
<tr>
<td>These windows compare the projections and the actuals, one directly above the other. Notice that the actuals are displayed mostly in blue.</td>
</tr>
</tbody>
</table>

The Event Projections window displays planned event details, including event start, vehicle type, total planned volume, anticipated retailer profit and anticipated spend. For the series in this window, PTP uses colors to indicate deviations between the projections and the actuals:

- If the actual value is more than 20% different from the projection in the undesirable sense, the projection is shown in red.

- If the actual value is more than 20% different from the projection in the desirable
sense, the projection is shown in green. For example, if the actual profit was 130% of
the projected profit, the projection is shown in green.

The Event Actuals window shows the corresponding actuals.

**Lift Decomposition Table - Actual (Retailer)**

The lift decomposition table shows the specific breakdown into base, incremental,
cannibalization, and pre- and post-effect dollars. This table also shows the net
incremental volume for the event. This table applies to the retailer’s point of view.

Here you can see these useful summaries:

- Total for promotion group where the promotion was run.
- Total effect on the brand.
- Total effect on each manufacturer.

Also notice that this table displays cannibalized and pre- and post-event volume, as
well.

**Lift Decomposition Graphs**

The worksheet includes two graphs to show the projected lift decomposition and the
actual lift decomposition. These are displayed vertically in the worksheet for space
reasons. For convenience here, the documentation displays them side by side.
Possible Actions

In this worksheet, depending on your authorization, you can do the following:

Right-click a promotion and open another worksheet filtered to that promotion. For example, you can open the PTP: Promo-Evaluation: Mfg worksheet to see past performance from the manufacturer’s perspective. See Evaluating Performance from the Manufacturer’s Point of View, page 12-2.

Reference

PTP: Promo-Evaluation: Mfg

This worksheet compares projections to actuals for a past promotion, from the point of view of the manufacturer:

Basics

<table>
<thead>
<tr>
<th>Accessing this worksheet</th>
<th>Right-click a promotion and click Open With &gt; PTP: Promo-Evaluation: Mfg.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Levels you can select</td>
<td>Retailer, Category, Promotion</td>
</tr>
<tr>
<td>Levels used in cross tabulation</td>
<td>Promotion</td>
</tr>
<tr>
<td>Time aggregation</td>
<td>Yearly</td>
</tr>
</tbody>
</table>
## Business Data

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Projections</td>
<td>Start Event P</td>
<td>Projected date when promotion starts in stores</td>
</tr>
<tr>
<td></td>
<td># Wks P</td>
<td>Projected event length in whole weeks, assuming that each week starts on Monday.</td>
</tr>
<tr>
<td></td>
<td>Veh Type P</td>
<td>Projected vehicle type or event type of the promotion</td>
</tr>
<tr>
<td></td>
<td>Cons Promo P</td>
<td>Projected consumer overlay.</td>
</tr>
<tr>
<td></td>
<td>Sale Price</td>
<td>Sale price per unit at shelf</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt Vol P</td>
<td>Projected total volume for the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt Vol P</td>
<td>Projected incremental volume due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt $ P</td>
<td>Projected total sales during the promotion, for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $ P</td>
<td>Projected incremental sales to the manufacturer due to the event</td>
</tr>
<tr>
<td></td>
<td>Evt Spend exS P</td>
<td>Projected total planned buydown and vehicle costs for promotion</td>
</tr>
<tr>
<td></td>
<td>CPIU P</td>
<td>Projected event cost per incremental unit sold as a result of the promotion.</td>
</tr>
<tr>
<td></td>
<td>% Spend P</td>
<td>Projected event spending, as a percentage of event sales</td>
</tr>
<tr>
<td></td>
<td>Incr Mfg Prft P</td>
<td>Projected incremental profit to the manufacturer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Mfg Prft P</td>
<td>Projected net incremental profit for the manufacturer</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>View</td>
<td>Incr Rtl Prft P</td>
<td>Projected incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td>Event Projections</td>
<td>Net Incr Rtl Prft P</td>
<td>Projected net incremental profit for the retailer</td>
</tr>
<tr>
<td>Event Actuals</td>
<td>Start Event</td>
<td>Date when the promotion starts in stores</td>
</tr>
<tr>
<td></td>
<td>End Event</td>
<td>Date when the promotion ends</td>
</tr>
<tr>
<td></td>
<td># Wks</td>
<td>Event length in whole weeks, assuming that each week starts on Monday.</td>
</tr>
<tr>
<td></td>
<td>Veh Type</td>
<td>Vehicle type or event type of the promotion</td>
</tr>
<tr>
<td></td>
<td>Cons Promo</td>
<td>Consumer overlay, the deal type as seen by the consumer.</td>
</tr>
<tr>
<td></td>
<td>Avg Rtl</td>
<td>Average unit retail price at shelf</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt Vol</td>
<td>Total volume for the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt Vol</td>
<td>Incremental volume due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Ttl Evt $</td>
<td>Total sales during the promotion, for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $</td>
<td>Incremental sales to the manufacturer due to the event</td>
</tr>
<tr>
<td></td>
<td>Evt Spend exS</td>
<td>Total planned buydown and vehicle costs for promotion</td>
</tr>
<tr>
<td></td>
<td>CPIU</td>
<td>Event cost per incremental unit sold as a result of the promotion.</td>
</tr>
<tr>
<td></td>
<td>% Spend</td>
<td>Event spending, as a percentage of event sales</td>
</tr>
<tr>
<td></td>
<td>Incr Mfg Prft</td>
<td>Incremental profit to the manufacturer due to the promotion</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Net Incr Mfg Prft</td>
<td>Net incremental profit for the manufacturer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Incr Rtl Prft</td>
<td>Incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Rtl Prft</td>
<td>Net incremental profit for the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td>Lift Decomposition - Projected</td>
<td>Base Evt $ P</td>
<td>Projected base sales for the manufacturer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $ P</td>
<td>Projected net revenue to the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Canbl $ P</td>
<td>Projected cannibalization dollars for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Pre Post Sales Value P</td>
<td>Projected total sales made before and after the promotion, as a result of the promotion (manufacturer’s perspective)</td>
</tr>
<tr>
<td>Lift Decomposition - Actual</td>
<td>Base Evt $</td>
<td>Base sales for the manufacturer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $</td>
<td>Net revenue to the manufacturer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Canbl $</td>
<td>Cannibalization dollars for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Pre Post Sales</td>
<td>Total sales made before and after the promotion, as a result of the promotion (manufacturer’s perspective)</td>
</tr>
<tr>
<td>Net Incremental $</td>
<td>Net Incr Evt $ P</td>
<td>Projected net revenue to the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $</td>
<td>Net revenue to the manufacturer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Net Incr Mfg Profit</td>
<td>Net Incr Mfg Prft P</td>
<td>Projected net incremental profit for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Net Incr Mfg Prft</td>
<td>Net incremental profit for the manufacturer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td>Net Incr Rtl Profit</td>
<td>Net Incr Rtl Prft P</td>
<td>Projected net incremental profit for the retailer</td>
</tr>
<tr>
<td></td>
<td>Net Incr Rtl Prft</td>
<td>Net incremental profit for the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td>Lift Decomposition Table - Actual (Retailer)</td>
<td>Ttl Evt $ Rtl</td>
<td>Total sales during the promotion, for the retailer</td>
</tr>
<tr>
<td></td>
<td>Base Evt $ Rtl</td>
<td>Base sales for the retailer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $ Rtl</td>
<td>Incremental sales to the retailer due to the event</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $ Rtl</td>
<td>Net revenue to the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Canbl $ Rtl</td>
<td>Cannibalization dollars for the retailer</td>
</tr>
<tr>
<td></td>
<td>Pre Post Value Rtl</td>
<td>Total sales made before and after the promotion, as a result of the promotion (retailer's perspective)</td>
</tr>
<tr>
<td>Lift Decomposition Table - Actual (Mfg)</td>
<td>Ttl Evt $</td>
<td>Total sales during the promotion, for the manufacturer</td>
</tr>
<tr>
<td></td>
<td>Incr Evt $</td>
<td>Incremental sales to the manufacturer due to the event</td>
</tr>
<tr>
<td></td>
<td>Base Evt $</td>
<td>Base sales for the manufacturer, during the promotion</td>
</tr>
</tbody>
</table>
### View | Series | Description
--- | --- | ---
Net Incr Evt $ & Net revenue to the manufacturer, after considering cannibalization and pre- and post-effects
Canbl $ & Cannibalization dollars for the manufacturer
Pre Post Sales & Total sales made before and after the promotion, as a result of the promotion (manufacturer’s perspective)
Canbl Vol Mfg & Total volume before and after the promotion, as a result of the promotion

**PTP: Promo-Evaluation: Rtl**

This worksheet compares projections to actuals for a past promotion, from the point of view of the retailer:

**Basics**

- Accessing this worksheet: Right-click a promotion and click Open With > PTP: Promo-Evaluation: Rtl.
- Levels you can select: Retailer, Category, Promotion
- Levels used in cross tabulation: Promotion
- Time aggregation: Yearly

**Business Data**

<table>
<thead>
<tr>
<th>View</th>
<th>Series</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Projections</td>
<td>Start Event P</td>
<td>Projected date when promotion starts in stores</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td># Wks P</td>
<td></td>
<td>Projected event length in whole weeks, assuming that each week starts on Monday.</td>
</tr>
<tr>
<td>Veh Type P</td>
<td></td>
<td>Projected vehicle type or event type of the promotion</td>
</tr>
<tr>
<td>Cons Promo P</td>
<td></td>
<td>Projected consumer overlay.</td>
</tr>
<tr>
<td>Sale Price</td>
<td></td>
<td>Sale price per unit at shelf</td>
</tr>
<tr>
<td>Ttl Evt Vol P</td>
<td></td>
<td>Projected total volume for the promotion</td>
</tr>
<tr>
<td>Incr Evt Vol P</td>
<td></td>
<td>Projected incremental volume due to the promotion</td>
</tr>
<tr>
<td>Ttl Evt $ Rtl P</td>
<td></td>
<td>Projected total sales during the promotion, for the retailer</td>
</tr>
<tr>
<td>Incr Evt $ Rtl P</td>
<td></td>
<td>Projected incremental sales to the retailer due to the event</td>
</tr>
<tr>
<td>Evt Spend exS P</td>
<td></td>
<td>Projected total planned buydown and vehicle costs for promotion</td>
</tr>
<tr>
<td>CPIU P</td>
<td></td>
<td>Projected event cost per incremental unit sold as a result of the promotion.</td>
</tr>
<tr>
<td>% Spend P</td>
<td></td>
<td>Projected event spending, as a percentage of event sales</td>
</tr>
<tr>
<td>Rtl Profit P</td>
<td></td>
<td>Projected retailer’s profit from the event</td>
</tr>
<tr>
<td>Incr Rtl Prft P</td>
<td></td>
<td>Projected incremental profit to the retailer due to the promotion</td>
</tr>
<tr>
<td>Net Incr Rtl Prft P</td>
<td></td>
<td>Projected net incremental profit for the retailer</td>
</tr>
<tr>
<td>Event Actuals</td>
<td>Start Event</td>
<td>Date when the promotion starts in stores</td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>End Event</td>
<td>Date when the promotion ends</td>
<td></td>
</tr>
<tr>
<td># Wks</td>
<td>Event length in whole weeks, assuming that each week starts on Monday.</td>
<td></td>
</tr>
<tr>
<td>Veh Type</td>
<td>Vehicle type or event type of the promotion</td>
<td></td>
</tr>
<tr>
<td>Cons Promo</td>
<td>Consumer overlay, the deal type as seen by the consumer.</td>
<td></td>
</tr>
<tr>
<td>Avg Rtl</td>
<td>Average unit retail price at shelf</td>
<td></td>
</tr>
<tr>
<td>Ttl Evt Vol</td>
<td>Total volume for the promotion</td>
<td></td>
</tr>
<tr>
<td>Incr Evt Vol</td>
<td>Incremental volume due to the promotion</td>
<td></td>
</tr>
<tr>
<td>Ttl Evt $ Rtl</td>
<td>Total sales during the promotion, for the retailer</td>
<td></td>
</tr>
<tr>
<td>Incr Evt $ Rtl</td>
<td>Incremental sales to the retailer due to the event</td>
<td></td>
</tr>
<tr>
<td>Evt Spend exS</td>
<td>Total planned buydown and vehicle costs for promotion</td>
<td></td>
</tr>
<tr>
<td>CPIU</td>
<td>Event cost per incremental unit sold as a result of the promotion.</td>
<td></td>
</tr>
<tr>
<td>% Spend</td>
<td>Event spending, as a percentage of event sales</td>
<td></td>
</tr>
<tr>
<td>Rtl Prft</td>
<td>Retailer’s profit from the event</td>
<td></td>
</tr>
<tr>
<td>Incr Rtl Prft</td>
<td>Incremental profit to the retailer due to the promotion</td>
<td></td>
</tr>
<tr>
<td>Net Incr Rtl Prft</td>
<td>Net incremental profit for the retailer, after considering cannibalization and pre- and post-effects</td>
<td></td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Lift Decomposition</td>
<td>Ttl Evt $ Rtl</td>
<td>Total sales during the promotion, for the retailer</td>
</tr>
<tr>
<td>Table - Actual (Retailer)</td>
<td>Incr Evt $ Rtl</td>
<td>Incremental sales to the retailer due to the event</td>
</tr>
<tr>
<td></td>
<td>Base Evt $ Rtl</td>
<td>Base sales for the retailer, during the promotion</td>
</tr>
<tr>
<td></td>
<td>Net Incr Evt $ Rtl</td>
<td>Net revenue to the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Net Incr Rtl Prft</td>
<td>Net incremental profit for the retailer, after considering cannibalization and pre- and post-effects</td>
</tr>
<tr>
<td></td>
<td>Canbl $ Rtl</td>
<td>Cannibalization dollars for the retailer</td>
</tr>
<tr>
<td></td>
<td>Pre Post Value Rtl</td>
<td>Total sales made before and after the promotion, as a result of the promotion (retailer's perspective)</td>
</tr>
<tr>
<td></td>
<td>Canbl Vol Rtl</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pre Post Vol</td>
<td>Total volume before and after the promotion, as a result of the promotion</td>
</tr>
<tr>
<td>Lift Decomposition</td>
<td>Base Evt $ Rtl P</td>
<td>Projected base sales for the retailer, during the promotion</td>
</tr>
<tr>
<td>Projected</td>
<td>Net Incr Evt $ Rtl P</td>
<td>Projected net revenue to the retailer</td>
</tr>
<tr>
<td></td>
<td>Canbl $ Rtl P</td>
<td>Projected cannibalization dollars for the retailer</td>
</tr>
<tr>
<td></td>
<td>Pre Post Value Rtl P</td>
<td>Projected total sales made before and after the promotion, as a result of the promotion (retailer's perspective)</td>
</tr>
<tr>
<td>Lift Decomposition</td>
<td>Base Evt $ Rtl</td>
<td>Base sales for the retailer, during the promotion</td>
</tr>
<tr>
<td>Actual</td>
<td></td>
<td></td>
</tr>
<tr>
<td>View</td>
<td>Series</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Net Incr Evt $ Rtl</td>
<td>Net revenue to the retailer, after considering cannibalization and pre- and post-effects</td>
<td></td>
</tr>
<tr>
<td>Canbl $ Rtl</td>
<td>Cannibalization dollars for the retailer</td>
<td></td>
</tr>
<tr>
<td>Pre Post Value Rtl</td>
<td>Total sales made before and after the promotion, as a result of the promotion (retailer's perspective)</td>
<td></td>
</tr>
</tbody>
</table>
Part 3

Advanced Topics
Creating Worksheets and Content Panes

**Important:** The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:

- Introduction
- Working with Lists
- Creating or Editing a Worksheet or Content Pane
- Configuring the Basics
- Selecting Series on a Worksheet
- Managing the Series Lists
- Specifying the Time Resolution and Time Span
- Specifying Aggregation Levels
- Using the Advanced Selection Options
- Changing the Overall Scale or Unit of Measure
- Filtering the Worksheet or Content Pane
- Managing the List of Members
- Applying Exception Filters
- Defining the View Layout
- Adding and Managing Worksheet Views
- Specifying the Worksheet Elements in a View
- Displaying an Embedded Worksheet
- Filtering a Worksheet View
- Sharing Worksheet and Content Panes
• Deleting Worksheet or Content Panes
• Creating New Product Launches
• General Tips on Worksheet Design

Introduction

This chapter describes how to create and redefine worksheets and content panes.

To create or redefine worksheets and content panes, you use the worksheet editor, which is divided into multiple screens. This section provides a quick overview:

<table>
<thead>
<tr>
<th>Area</th>
<th>Purpose</th>
<th>For details, see</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Specify basic information.</td>
<td>Configuring the Basics, page 13-4</td>
</tr>
<tr>
<td>Series</td>
<td>Select series to include.</td>
<td>Selecting Series on a Worksheet, page 13-6</td>
</tr>
<tr>
<td>Time</td>
<td>Specify time resolution of worksheet or content pane and span of time to consider.</td>
<td>Specifying the Time Resolution and Time Span, page 13-9</td>
</tr>
<tr>
<td>Aggregation Levels</td>
<td>Optionally specify aggregation levels to include.</td>
<td>Specifying Aggregation Levels, page 13-11</td>
</tr>
<tr>
<td>Filters</td>
<td>Optionally filter the selected combinations.</td>
<td>Filtering a Worksheet View, page 13-26</td>
</tr>
<tr>
<td>Exceptions</td>
<td>Optionally apply exception filters to further filter the combinations.</td>
<td>Applying Exception Filters, page 13-18</td>
</tr>
<tr>
<td>Layout Designer</td>
<td>Applicable only to worksheets. Define the layout of the worksheet and its views, including the layout of the worksheet tables, the location of each included series, and the graph format.</td>
<td>Defining the View Layout, page 13-20</td>
</tr>
</tbody>
</table>

Within the editor, you have the following options:

• To move to another page, either click a button on the left side of the page or click Previous or Next.
• To exit the worksheet editor and keep your changes, click OK.

• To exit the worksheet editor and discard all changes, click Cancel.

### Working with Lists

As you create or edit worksheets and content panes, you will often use pages that present two lists of elements, where you specify your selections. To do so, you move elements from the left list to the right list. The left list always presents the available elements (such as the available series) and the right list always shows your selections.

You can move elements from one list to the other in many equivalent ways, summarized here:

• To move all elements from one list to the other, click one of the double arrow buttons, as appropriate.

• To move a single element from one list to the other, click the element and then click one of the single arrow buttons, as appropriate. Or double-click the element.

• To move several adjacent elements, click the first element, press Shift and click the last element. Then click one of the single arrow buttons, as appropriate.

• To move several elements that are not adjacent, press Ctrl and click each element you want. Then click one of the single arrow buttons, as appropriate.

### Creating or Editing a Worksheet or Content Pane

**To create a new worksheet or content pane**

Click File > New. Or click the New button.

**To edit an existing worksheet or content pane**

1. Click File > Open. Or click the Open button.

2. Click a worksheet or content pane and click Open.

3. Click the Worksheet menu and select one of the menu items. Or click one of the worksheet buttons on the tool bar.

4. Save your changes to the worksheet definition: To save the new definition, click the Save button. Or click File > Save
Note: In contrast, the Data > Update option saves the data and notes in the worksheet, not the worksheet definition.

To save the worksheet with a new name, click the Save As button.

Configuring the Basics

To configure basic information for a worksheet or content pane:

1. Click Worksheet > Display. Or click the Display button.

The system displays a page where you specify the following basic information:

<table>
<thead>
<tr>
<th>Name:</th>
<th>100 Introduction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td></td>
</tr>
<tr>
<td>Access</td>
<td>Private</td>
</tr>
<tr>
<td>Enable extra filters</td>
<td></td>
</tr>
<tr>
<td>Cache Worksheet Data</td>
<td>Manual</td>
</tr>
<tr>
<td>Refresh Type:</td>
<td>Manual</td>
</tr>
<tr>
<td>Open With Content:</td>
<td>Selected Member</td>
</tr>
<tr>
<td>Content Definition:</td>
<td></td>
</tr>
<tr>
<td>Display Format:</td>
<td>Line Graph</td>
</tr>
<tr>
<td>Location:</td>
<td>Wide Pane</td>
</tr>
</tbody>
</table>

Name: The title to use in the My Worksheets module and in the window title.

Description: Provides optional information to display in My Worksheets. This is especially useful in public worksheets for explaining the purpose of the worksheet to other users.

Access: Select Private or Public. Private is for your use only. Public worksheets and content panes are available to all users in the group.
Enable Extra Filters

This option adds an extra, user-controlled filter to the worksheet. If you select the Enable Extra Filters check box, that means that when you open the worksheet, you can prefilter the data before seeing the worksheet results; this is especially useful for users who use Demantra Anywhere.

Normally when you specify aggregation levels to include in the worksheet, as described in "Specifying Aggregation Levels", all members of those levels are available in the worksheet.

If you select the Enable Extra Filters check box, that means that when you run the worksheet, Demantra first prompts you to select the members to display for each level.

This option has no effect on content panes.

Cache Worksheet Data

Specifies whether Demantra should cache the data for this worksheet, for each user who works with it. If you cache a worksheet, it will run more quickly in general, but the cache will need to be refreshed periodically. Choose one of the following refresh options:

- Manual—users will have to manually refresh the cache.
- Automatic—Demantra will automatically refresh the cache, as specified by your implementors.

In either case, Demantra automatically detects when a cache is out of date and behaves appropriately. Demantra also automatically refreshes the cache when you make certain structural changes to the worksheet.

Open With Context

Specifies how this worksheet should be filtered when a user opens it via the Open or Open With menu options (on the right-click menu).

Choose one of the following options:

- Selected Member (this will filter the worksheet to the object from which it was launched, aggregating across all combinations associated with that object)
- Selected Combination (this will filter the worksheet to the combination from which it was launched)

2. To display the content of this worksheet as a content pane in Collaborator Workbench, check Content and then complete the following fields:
Display Format

Specifies the display format to use. Not all display formats may be possible, depending on the number of levels and series you include.

Currently, Collaborator Workbench chooses the color to use for each series, when displaying series in the graph-type content panes.

Location

Select Wide Pane or Narrow Pane to determine where the content pane will be displayed in Collaborator Workbench.

Top/BOTTOM Filter

(Only for bar chart content panes.) Specifies how to filter the members or combinations for display in the bar chart (to save space, not all members are shown).

- Use the dropdown menu to specify whether the filter should apply to the top-ranked or to bottom-ranked members.
- In the input field, specify the number of members to be included.
- For Criteria Series, select the series that Demantra should use to rank the members. (This does not control the order in which they are displayed in the chart.)

Note: If multiple items have identical values, all of them are displayed, and they collectively count as 1 towards the total. For example, suppose top values were 200, 150, 150, 100, and 50. If you specified Top/BOTTOM filter as three, you would see a total of four items: both the 150 items, in addition to the 200 and 100 items.

This option does not affect the worksheet.

3. For worksheets only, to specify how the table should appear, see Defining the View Layout, page 13-20.

Selecting Series on a Worksheet

Every worksheet or content pane must include at least one series.

Note: If you use a settlement level in a worksheet or content pane, all series in the worksheet or content pane must refer to tables used by the settlement hierarchy.
**To specify the series on a worksheet or content pane:**

1. Click Worksheet > Series. Or click the Series button.

   The system displays the Available Series and Selected Series lists. Each list is a collapsible list of series groups and the series in them.

2. Move all series that you want into the Selected Series list. To do so, either double-click each series or drag and drop it. You can also move an entire series group from one list to the other in the same way.

3. Remove any series from the Selected Series list that you do not want to include.

   **Note:** You cannot remove a series if it is used as the Criteria Series for bar chart content.

To change the order in which the series are displayed, see Defining the View Layout, page 13-20.


**Managing the Series Lists**

You may have a very large number of series, and it can be useful to sort and filter these lists so that you can readily find what you need. The system also provides a search mechanism.
**Note:** This section applies only to the series page of the worksheet editor (Worksheet > Series).

**To sort a list of series:**
1. Click the Sort button.
   The Sort dialog box is displayed.
2. Drag the list name from the Available Columns to the Sort Columns. Or double-click the list name in the Available Columns list.
3. Click OK.

**To filter a list of series:**
1. Click the Filter button.
   The Filter page appears.
2. Click Add.
3. Click the arrow to the right of the operator box and select an operator from the dropdown list.
4. In the number box, enter the value by which to filter the list.
5. (Optional) You can filter further by using the AND relationship.
6. Click OK.

**To find a series:**
1. Click the Find button.
   The Find dialog box appears.
2. In the Find where box, select the name of the list to search.
3. In the Find what box, type name of the series.
4. Select Up, Down or All to determine the direction of the search.
5. (Optional) Select one or more of the check boxes:
   - Whole Word: Search for the exact match of a word.
   - Match Case: Search for the exact match of a word (case sensitive).
6. Click Find Next to begin (or continue) searching.

Specifying the Time Resolution and Time Span

Each worksheet or content pane selects data for a specified span of time and optionally aggregates it in time. You use the Time dialog box to specify the time resolution and span of time of the results.

<table>
<thead>
<tr>
<th>Time Scaling</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Scale:</td>
</tr>
<tr>
<td>Quarter</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time Filtering</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scaled by periods of a Quarter from today</td>
</tr>
<tr>
<td>Time Filter:</td>
</tr>
<tr>
<td>Fixed</td>
</tr>
<tr>
<td>Relative to Today</td>
</tr>
<tr>
<td>Relative to Last Sales Date</td>
</tr>
<tr>
<td>From Date:</td>
</tr>
<tr>
<td>03/10/2003</td>
</tr>
<tr>
<td>To Date:</td>
</tr>
<tr>
<td>03/06/2006</td>
</tr>
</tbody>
</table>

To specify time criteria:
1. Click Worksheet > Time. Or click the Time button.

2. In the Time Scale box, specify the time resolution. The data in the worksheet or content pane is aggregated to this time resolution. That is, this option specifies the period of time that each data point in the line graph represents.

3. In the Time Filter box, specify the time period to which the worksheet or content pane applies:
   - Fixed if you always want to show a specific time range, regardless of the current date.
   - Relative to Today if you always want to show a time range relative to today.
   - Relative to Last Sales Date if you always want to show a time range relative to the last sales date in the loaded data.

4. In the From Date and To Date boxes, enter values depending on the time filter you
have chosen, as follows:

<table>
<thead>
<tr>
<th>Time Filter</th>
<th>Box</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative</td>
<td>From Date / To Date</td>
<td>Specify periods in both From and To with the current (computer) date as the reference point.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For example: If the Time Scale is Month, and you want to see results starting from six months before today, enter -6 in From Date.</td>
</tr>
<tr>
<td>Fixed</td>
<td>From Date</td>
<td>Enter a specific date as a starting point of the results. To enter a date, click the calendar button and select a date.</td>
</tr>
<tr>
<td>Fixed</td>
<td>To Date</td>
<td>Specify the number of periods you want to include, starting from the From Date.</td>
</tr>
</tbody>
</table>

5. To control how dates are displayed, click the Advanced button, which brings up the following dialog box:

   ![Advanced Time Settings Dialog Box]

6. In the Format dropdown list, select a display format.
   For example, to add one month to each displayed date, specify 1 for Month Offset.
The Preview field shows what the first time bucket would look like with this format and offset.

7. To offset the displayed dates, optionally specify values for Month Offset or Year Offset.

8. Click OK.

**Note:** If you change the time scale, the worksheet or content pane might not show exactly the same aggregate numbers, because the cutoff dates would not necessarily be the same. For example, suppose your worksheet is weekly and displays 48 weeks of data. Then supposed you change the worksheet to display quarterly data. A quarter is 13 weeks, and the original span (48 weeks) is not an integer multiple of 13. So the worksheet selects a different amount of data and shows different overall results.

---

**Specifying Aggregation Levels**

A worksheet or content pane usually includes aggregation levels. When you use the worksheet or content pane, you can examine data for the item-location combinations associated with those levels.

- If you do not specify any aggregation levels, the data is completely aggregated across all items and locations.
- If you use a settlement level, you cannot use levels from any other hierarchy.

**To specify the aggregation levels in a worksheet or content pane:**

1. Click Worksheet > Aggregation Levels. Or click the Levels button.

   The system displays the Available Levels and Selected Levels lists.

2. Move all aggregation levels that you want into the Selected Levels list, using any of the techniques in "Working with Lists".

3. Remove any unwanted levels from the Selected Levels list.
For a worksheet, the selected levels will now be used on all views of this worksheet, unless you configure the views otherwise. The layout of the worksheet view controls the order in which the levels are used; see Defining the View Layout, page 13-20.

See also

- Using the Advanced Selection Options, page 13-12
- Changing the Overall Scale or Unit of Measure, page 13-14

**Using the Advanced Selection Options**

By default, if a worksheet or content pane includes a promotion level, the worksheet or content pane includes all the following types of combinations:

- Combinations that have both sales data and promotions
- Combinations that have sales data, but no promotions
- Combinations that have promotions, but no sales data

The worksheet or content pane displays placeholders for combinations that do not have promotions. For example:

For a worksheet, if you move the promotion level to the worksheet axis (see Defining the View Layout, page 13-20), the table will display a similar placeholder.
You can exclude some of these combinations. For example, you might want a worksheet to include only the combinations that have both sales and promotions, as follows:

To exclude combinations with partial data:
1. Click Worksheet > Aggregation Levels. Or click the Levels button.

2. Include at least two levels, one of which should be a promotional level.
   When you do so, the screen displays an Advanced button in the lower right.

3. Click Advanced.
   Oracle displays a dialog box with additional options.
Include combinations that exist only in Promotion.

This option selects combinations that have associated promotions, even if they do not have sales data.

Include combinations that exist only in SALES_DATA.

This option selects combinations that have sales data, even if they do not have any associated promotions.

4. To exclude the combinations you do not want to see, click the check boxes as needed.

See Specifying Aggregation Levels, page 13-11.

Changing the Overall Scale or Unit of Measure

In addition to levels, series, and filtering, a worksheet or content pane has the following characteristics:

- A single unit of measure. Typically, most series refer to this unit of measure, but there are exceptions such as percentage values. You can switch the unit of measure, and the displayed values are changed accordingly. The units in your system depend upon your implementation but probably include unit count and dollars.

For monetary units, you can also switch to a different index (such as the Consumer Price Index or CPI) or exchange rate, and the worksheet or content pane automatically multiplies all values accordingly.
• An overall scale. The default value is 1. If the displayed values are all large, it can be useful to re-scale the numbers, for example, to display in amounts of 1000 or 1000000.

You can change either or both of these. When you make this change, the displayed values for most or all of the series in the worksheet or content pane are changed.

**Note:** This change affects only the series that are scaled. Not all series are scaled. For example, a series defined as a percentage is probably not scaled.

**To change the overall scaling factor:**
1. Click Worksheet > Aggregation Levels. Or click the Levels button.

   The Levels page includes a section where you specify the overall scale of the worksheet or content pane, as well as its units of measure.

   ![Select Units](image)

   2. In the Scale Units by box, specify the factor by which all numbers are to be divided (for display purposes).

   For example, if you specify a factor of 1000, the displayed data will divided by 1000. So the number 96,000 will be displayed as 96. The vertical axis of the graph is updated to show the factor in parentheses. For example, if the vertical axis was formerly labeled "units", it will be updated to say "units (1000)" instead.

**To change the unit of measure :**
1. Click Worksheet > Aggregation Levels. Or click the Levels button on the toolbar.

2. In the Unit Type box, select the unit of measure to display in the worksheet or content pane results.

   For example, our items are bottles, and suppose that a case that contains six bottles. If you display the worksheet or content pane with cases instead, the system will display the number of bottles divided by six.

3. If the Index box is displayed, choose an index from the dropdown list.
The Index menu lists all the time-dependent indexes and exchange rates that are associated with this unit. Each index or exchange rate is a time-varying factor that the worksheet or content pane can use. When you select an index, the worksheet or content pane will automatically multiply all monetary series by the factor for each date. For example, if you choose Consumer Price Index (CPI) as the index, the system will calculate all monetary quantities with relation to the CPI.

**Note:** These indexes and exchange rates are generally imported from other systems. The set available to you depends upon your implementation.

See Specifying Aggregation Levels, page 13-11.

**Filtering the Worksheet or Content Pane**

Filters control the combinations that you are able to see. Filtering can have multiple sources:

- A given worksheet or content pane may be filtered. For example, worksheet X might show only Brand X, which means that the worksheet would show only combinations related to Brand X.

- Your user ID may be filtered. For example, if you are an account manager, your user ID might give you access only to your accounts. At any level, you would not be able to see combinations associated with other accounts.

- The data that you share with other users (called the component) might also be filtered. Components divide the data for different sets of users.

Demantra automatically combines all the filters. In the preceding example, if the component is not filtered, if you use worksheet X, you can see only data for Brand X at your accounts.

In contrast to an exception filter ("Applying Exception Filters"), this type of filter is static and behaves the same no matter how the data changes.
To apply a filter to a worksheet or content pane:

1. Click Worksheet > Filters. Or click the Filters button.
   The system displays the Available Filter Levels and Selected Filter Levels lists.

2. Find the aggregation level at which you want to filter data and move it from the Available Filter Levels list into the Selected Filter Levels list, using any of the techniques in "Working with Lists".

   Note: This level does not have to be the same as any of the aggregation levels you display in the worksheet or content pane. In fact, typically you filter using a different level than you use to display.

3. In the Available Members list, find a member that you want to include and move it into the Selected Members list, using any of the techniques in "Working with Lists.".
   At this stage, the worksheet or content pane includes only data for this member. (Before you applied a filter at this level, the worksheet or content pane could theoretically include any member of this level.)

4. Continue to move members from the Available Members list into the Selected Members list, until the latter list includes all the members you want.

   ![Available Members and Selected Members table]

   level members not included in the filter
   level members included in the filter (and therefore displayed in the worksheet)

To filter data further:

Once you have applied a filter as described previously, the worksheet or content pane contains only those combinations that are associated with the members you specified. You can further filter the data in exactly the same way.

See Applying Exception Filters, page 13-18.
Managing the List of Members

Depending on how your system has been configured, it might contain a very large number of members. If so, you might want to sort or filter the list or search it. For information, see Managing the Series Lists, page 13-7.

Applying Exception Filters

If you attach an exception filter, Demantra checks the values of the data and displays only the combinations that meet the exception criteria. In contrast to an explicit filter, Filtering the Worksheet or Content Pane, this type of filter is dynamic and can behave differently as the data changes.

Specifically, you define an exception condition that consists of a series, a comparison operator, and a value, for example:

```
Exceptions Filter

<table>
<thead>
<tr>
<th>Series</th>
<th>Operator</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales Plan</td>
<td>&gt;=</td>
<td>150000.0</td>
</tr>
</tbody>
</table>
```

When you open the worksheet, Demantra checks each combination in the worksheet. For each combination, if the condition is met for any time in the worksheet date range, Demantra displays that combination. For example, the worksheet shows combinations that have Sales Plan values greater than or equal to 150000, within the time range included in the worksheet.

If the condition is not met at any time for any of the worksheet combinations, Demantra shows the worksheet as empty. That is, if all values in the Sales series are less than 15000 for all combinations, the worksheet comes up empty.

**Note:** If the worksheet includes a promotion level or a promotion series, the behavior is slightly different. In this case, the Members Browser or dropdown list does initially show all combinations. When you click display a combination to display it, the worksheet then checks for exceptions.

You can apply multiple exceptions to a worksheet. When you apply multiple exceptions, you can relate them to each other via logical AND or logical OR relationships. For example:

```
Exceptions Filter

<table>
<thead>
<tr>
<th>Series</th>
<th>Operator</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Frcst</td>
<td>&gt;=</td>
<td>150000.0</td>
</tr>
<tr>
<td>Discount</td>
<td>&lt;=</td>
<td>15.0</td>
</tr>
</tbody>
</table>
```
To apply an exception filter:
1. Click Worksheet > Exceptions. Or click the Exceptions button. The Exceptions Filter page appears.
2. Click Add.
3. In the first box in the new row, select a series from the dropdown list.
   Note: Typically only some series are available for exceptions. If you do not see a series you need, contact your Demantra administrator or your implementors.
4. In the second box, select an operator from the dropdown list.
5. In the third box, type or choose a value.
   - For a numeric series, type a number.
   - For a dropdown series, choose one of the allowed values of this series.
   - For a string-type series, type any string. You can use the percent character (%) as a wildcard.
   - For a date-type series, type a date or use the calendar control to choose a date.
6. (Optional) You can apply additional exceptions. Select the AND or the OR radio button to specify the relationship between the exceptions.

To delete an exception filter:
1. Click the exception and then click Delete.
See
- Filtering the Worksheet or Content Pane, page 13-16.
Defining the View Layout

This section applies only to worksheets, not to content panes.

To define the layout of a current view:
1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

The system displays a page where you specify the layout. This page displays the following areas:

In addition, this screen displays the following icons:

• An icon for each aggregation level that you have included in the worksheet. By default, these levels are included in the Members Browser or selector lists.

• An icon that represents the time axis. By default, time is shown on the x-axis.

• An icon that represents the series data. Series are shown on the y-axis.

2. To change the worksheet layout, drag the level or time axis icons to the appropriate areas. You cannot move the series icon.

3. To specify the type of graph to use, select a graph type from the Graph Type dropdown list.

4. To specify how to display series in this view:
   1. Click the Sort button.

   The Layout Designer displays a page that shows the order in which this view
2. To hide a series in this view, click the None option in the dropdown list to the right of the series name.

3. Otherwise, to specify where to display the data for a series, select one of the following options: Table, Graph, Table and Graph.

4. To move a series up or down in this list, click the series name and drag it up or down.

5. When you are done, click Close.

5. Click Save.

6. Rerun the worksheet to see your changes. To do so, click Data > Rerun.

**To specify a cross-tab layout:**
1. Drag one or more level icons from the Page Item area to x-axis or y-axis areas.

**To specify which levels to use in a worksheet view:**
By default, all levels you include in a worksheet are used on all views of the worksheet. Within a multi-view worksheet, you often hide some of the levels in some views, so that each view is aggregated differently.
1. Right-click within the Page area of the Layout Designer.
The system displays a menu like the following:

2. Click Hide level and then click the name of the level to hide.

When you hide a level, the worksheet automatically aggregates data across members of that level.

**Note:** Do not use this option to hide the time axis.

### To revert to the default layout of a worksheet view:

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to reset.

3. Click the Reset button.

In the default layout, all selected levels are visible and are on the X axis. Also, all series are displayed in the graph and table according to their default definitions.

See

- Specifying the Worksheet Elements in a View, page 13-24

- Displaying an Embedded Worksheet, page 13-25

- Filtering a Worksheet View, page 13-26

### Adding and Managing Worksheet Views

This section applies only to worksheets, not to content panes.

A worksheet can include multiple views, each of which can have a different set of series and a different layout.

### To add a worksheet view:

1. Within the Layout Designer, click the Add Worksheet View button.
2. In the popup dialog box, type the name of the new view.

3. Click OK.

**To control synchronization between the views:**

The views of a worksheet may or may not be synchronized with each other. If they are synchronized, when you edit in one view, that change automatically appears in the other views. Because this can affect performance, sometimes it is best to switch off this synchronization.

Within the Layout Designer, click one of the following buttons, whichever is currently displayed:

- Do not force synchronization between views
- Synchronize data between views

**To rename a worksheet view:**

1. Within the Layout Designer, click the Rename Worksheet View button.

2. In the popup dialog box, type the new name of the view.

3. Click OK.

**To enable or disable a worksheet view:**

1. Within the Layout Designer, click the Hide/Display button.

2. The Layout Designer displays a popup list of all the views associated with this worksheet. A check mark is displayed next to each view that can currently be displayed.

3. For the view interest, select the check box next to the name of the view.

4. Click elsewhere on the screen to close the list of views.

**To delete a worksheet view:**

Within the Layout Designer, do one of the following:
• Click the tab that corresponds to the worksheet view. Then click the Delete Worksheet View button.

• Click the Delete All Worksheet View button. Then, at the prompt, click Yes.

See
• Defining the View Layout, page 13-20
• Specifying the Worksheet Elements in a View, page 13-24
• Displaying an Embedded Worksheet, page 13-25
• Filtering a Worksheet View, page 13-26

Specifying the Worksheet Elements in a View

This section applies only to worksheets, not to content panes.

For each worksheet view, you can specify which of the basic worksheet elements are included: the table, the graph, and so on.

To specify the elements to include in a worksheet view:
1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to modify.

3. Click Advanced... in the lower right.

   Demantra displays the following screen:
4. For Combination Selector, click either Tree (to display a Members Browser) or Dropdowns (to display dropdown menus instead).

5. Select the check box next to each element you want to include in this view of the worksheet.

6. Click OK.

Displaying an Embedded Worksheet

This section applies only to worksheets, not to content panes.

You can display embedded worksheets on subtabs within a view. An embedded worksheet can be at a higher aggregation level than the rest of the worksheet, and the worksheet itself remains editable in general.

Note: The choice of worksheets you see depends on the level-worksheet associations that are controlled within the Business Modeler.

To display an embedded worksheet as a subtab within a view:

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view to which you want to add the
sub tab.

3. Click Advanced... in the lower right.
   - Demantra displays the Advanced screen.

4. Click the Add WS As Subtabs tab.
   - Demantra displays a screen like the following:

   Depending on the level that you select, the bottom part of the screen shows different worksheets that you can add as a subtab to this worksheet view.

5. For Selected Levels, select the level that is associated with the worksheet you want. In general, a worksheet is associated with the levels where it makes sense to use it; this is controlled by your system configuration. You can choose any of the levels that are used in this worksheet.

6. For Selected Worksheets, select the worksheets that you want to display as sub tabs within this worksheet view.

7. Click OK.

Filtering a Worksheet View

This section applies only to worksheets, not to content panes.
For each worksheet view, you can filter the view to show a subset of the data in the worksheet.

**To filter a worksheet view:**

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to filter.

3. Click Advanced... in the lower right.
   - Demantra displays the Advanced screen.

4. Click the Filter By Level Members tab.
   - Demantra displays a screen like the following:

5. For Selected Filter Levels, select the level by which you want to filter this worksheet view. You can choose any of the levels that are used in this worksheet.

6. For Selected Members, select the level members whose data should be displayed in this worksheet view.

7. Click OK.
Sharing Worksheet and Content Panes

In general, any worksheet or content pane is one of the following:

- Private—available only to you

- Public—available to other users as well. (If you are using Collaborator Workbench, this means the worksheet or content pane is available to other users within the collaborative group.)

In either case, the original creator owns it and only that person can change it.

When you do share worksheet and content panes, however, you should consider data security. Demantra automatically prevents any user from seeing data for which he or she does not have permissions. If you build a worksheet or content pane with data that other users do not have permissions to view, then those users will see an empty worksheet or content pane. Similarly, if a user has partial permissions for the data, then the worksheet or content pane will open with only those results that are permitted.


Deleting Worksheet or Content Panes

You can delete a worksheet or content pane if you are its owner.

To delete a worksheet or content pane:
1. Open the worksheet or content pane.
2. Click File > Delete. Or click the Delete button.
   - Demantra prompts you to confirm the deletion.
3. Click Yes or No.

Creating New Product Launches

New Product Launch Management is the introduction of a new product at a site (DC/store), site group (also known as a store group), account, or retailer. Launch Management uses an existing product’s historical demand to generate a forecast for the new product. With Launch Management you can:

- Choose whether source data should be scaled when copied.
- Specify a start date when copying historical data.
- Specify an end date when copying forecast data.
• Specify how much historical demand to use (e.g. 50%, 100%, 200%, and so on).

You have the following options when launching a new product:

• New product introduction at one site based on an existing product.

• New product introduction at one, multiple or all accounts based on an existing product.

• New product introduction at one, multiple or all retailers based on an existing product.

• New product introduction at one, multiple or all site groups based on an existing product.

Launch Management can also copy promotional data including historical promotions from the source product. For details about creating new product launches, as well as the seeded Launch Management worksheet and related workflows, see New Product Launch Worksheet in the Oracle Demantra Demand Management User Guide.

**General Tips on Worksheet Design**

This section applies mostly to worksheets, not to content panes.

• For performance reasons, don't select too much data to view, unless there is no other choice.

• If you receive a message saying "out of memory," try the following techniques to reduce the amount of memory that your worksheet selects:
  • Remove series if possible
  • Reduce the span of time
  • Apply filters

• If you do need to select a large amount of data, use the levels to your advantage. Specifically, use the levels in the Members Browser or selector lists rather than moving them to a worksheet axis. If levels are in the Members Browser or selector lists, each combination in the worksheet is relatively smaller and will load more quickly.

• If you do not plan on working with the Activity Browser, you can switch off the Auto Sync option on the toolbar, and you can also hide the Activity Browser and Gantt chart.

• Remember that you can filter the worksheet by any level, including levels that are not shown in the worksheet. For example, you might want to see data at the region
level, but exclude any data that does not apply to the Acme territory. To do this, you would filter the worksheet to include only the Acme member of the Territory level, but you would select data at the Region level.

- A multi-view worksheet is useful in following cases:
  - If you need to edit data at one aggregation level and see easily how that affects higher aggregation levels.
  - If you need to display a large number of series without having to scroll to see each one.
Shipment and Consumption Planning

Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:

- Overview
- Setting Shipment and Consumption Planning Attributes

Overview

Consumer Goods manufacturers need the ability to plan for two Demand Streams: Shipment Demand and Consumption Demand.

- Shipment Demand is the movement of goods from the manufacturer who produces the products to the retailer who sells the products. This movement can occur directly from the manufacturer to the retailer or indirectly through an intermediary such as a wholesaler or distributor.

- Consumption Demand is the movement of goods from the retailer who sells the products to the end consumer that purchases the products.

Predictive Trade Planning gives you the ability to plan for both Shipment Demand and Consumption Planning.

For additional details and required configuration tasks, refer to the Oracle Demantra Enhanced Support for Shipment and Consumption Planning white paper on My Oracle Support (support.oracle.com).

Promotional Timing

When you run promotions, the timing for the shipment demand differs from the timing for the consumption demand. Shipments occur first in order to ensure that there is
sufficient inventory in the retail stores to meet the consumption demand. For example, a promotion running in retail stores during the first week of March will have consumption demand in March and shipment demand in February.

For some promotions:

- The Shipment and Consumption Demand partially overlap.
- The Shipment Demand ends before the Consumption Demand begins (potentially with a gap in between).
- The Shipment and Consumption Demand could fully overlap.

Data Availability and Forecasting

Shipment data is usually available for all Customers and Products, except when competitive products are included and shipment data is unavailable. Consumption data is generally not available for all Customers and Products. Only a subset of the Item/Location combinations in Demantra have Consumption data. You can use Consumption data as the demand stream when it is available and use Shipment data otherwise.

- You can generate a Shipment Demand forecast for all Item/Location combinations, regardless of whether or not consumption data is available.
- You can also generate a Shipment Demand forecast for those combinations that have no consumption data. In these cases, Shipment Forecasts are calculated based on the Consumption Forecast using lag times and other rules.

Promotional Spending Calculations

Sales-based promotional allowances are structured in the following ways:

- Off-invoice allowances: Per unit allowances that reduce the price the retailer, distributor, or wholesaler pays the manufacturer for the product. Off-invoice allowances are calculated based on Shipment Demand during the promotion’s shipment window.
- Bill-back allowances: Per unit allowances that are accrued and paid to the retailer, distributor, or wholesaler once the promotion is complete. Bill-back allowances are also referred to as rebates and are calculated based on Shipment Demand during the promotion’s shipment window.
- Scan-down allowances: Per unit allowances paid to the retailer, distributor, or wholesaler based on how much they sell during the promotion. Scan-down allowances are calculated based on Consumption Demand during the promotion’s consumption window.
Setting Shipment and Consumption Planning Attributes

Indicating the Availability of Shipment and Consumption Demand Streams
In most cases, shipment data is available for all customers and products, and consumption data is only available for a subset of customers and products. You can flag combinations on MDP_MATRIX to indicate the availability of shipment and consumption demand streams.

For more information, refer to the Oracle Demantra Enhanced Support for Shipment and Consumption Planning white paper on My Oracle Support (support.oracle.com).

Configuring the Dates Label and the List of Available Filter Streams
The Dates label and the list of Available Filter Levels are configurable. For more information, see the "Configuring Predictive Trade Planning" chapter in the Oracle Demantra Implementation Guide.

Hiding the Dates Field
To hide the Dates field in the Population Window, use the IS_HIDE_DATES column in the GROUP_ATTRIBUTES_POPULATION database table. For more information, see the "Non-Engine Parameters" chapter in the Oracle Demantra Implementation Guide.

Configuring Promotional Data Series Updates
For information on configuring promotional data series updates, refer to the Oracle Demantra Enhanced Support for Shipment and Consumption Planning white paper on My Oracle Support (support.oracle.com).

Defining an Engine Profile to Run a Consumption Forecast
In order for the analytical engine to create a consumption forecast, you must first define an engine profile; a pre-seeded Consumption Forecast for the Engine Profile is not provided. To create a consumption forecast, set the CONSUMPTION_DEMAND flag on MDP_MATRIX to 1 (Yes). For more information, refer to the Oracle Demantra Enhanced Support for Shipment and Consumption Planning white paper on My Oracle Support (support.oracle.com).
Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter provides reference information for PTP series, levels, and methods.
This chapter covers the following topics:

- Series
- Item Levels
- Location Levels
- Retailer
- Promotion Levels
- Lookup Tables
- Methods
- Procedures
- Triggers
- Workflows
- Engine Configuration
- Additional Checklist Before Running Optimization

Series

This chapter provides reference information for PTP series, levels, methods, and so on.
PTP provides the following series:
<table>
<thead>
<tr>
<th>Series</th>
<th>Table</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td># Wks</td>
<td>promotion</td>
<td>Event length in weeks, assuming that each week starts on Monday. Always rounded up to a whole number of weeks.</td>
</tr>
<tr>
<td># Wks O</td>
<td>promotion level</td>
<td>Event length in weeks, for optimized promotion.</td>
</tr>
<tr>
<td># Wks P</td>
<td>promotion level</td>
<td>Projected event length in weeks, as predicted when the promotion was committed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is configured (via a client expression) to have three branches, as follows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If the value of this series is not null, that means Demantra has captured projections for this promotion. So use that value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If the value is null and if the promotion is Committed, use the value # Wks.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If the value is null and if the promotion is not Committed, use null.</td>
</tr>
<tr>
<td>$ Sales</td>
<td>sales_data</td>
<td>Annual dollar sales.</td>
</tr>
<tr>
<td>$ Sales Proj</td>
<td>sales_data</td>
<td>Planned sales dollars: actuals (for past dates) plus forecast (for future dates)</td>
</tr>
<tr>
<td>% ACV Promoted</td>
<td>Promotion</td>
<td>Indicates the expected level of promotion participation based on each stores All Commodity Volume</td>
</tr>
<tr>
<td>% ACV ANY PROMO</td>
<td>sales_data</td>
<td>Measures the number of stores that ran any promotion, weighted by store size. Loaded from syndicated data.</td>
</tr>
<tr>
<td>% ACV DISP</td>
<td>sales_data</td>
<td>Measures the number of stores that ran displays, weighted by store size. Loaded from syndicated data.</td>
</tr>
<tr>
<td>% ACV FEAT</td>
<td>sales_data</td>
<td>Measures the number of stores that ran features, weighted by store size. Loaded from syndicated data.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>% ACV FEAT&amp;DISPLAY</td>
<td>sales_data</td>
<td>Measures the number of stores that ran combined features and displays, weighted by store size. Loaded from syndicated data.</td>
</tr>
<tr>
<td>% ACV FREQSHOPPER</td>
<td>sales_data</td>
<td>Measures the number of stores that ran frequent shopper specials, weighted by store size. Loaded from syndicated data.</td>
</tr>
<tr>
<td>% ACV TPR</td>
<td>sales_data</td>
<td>Measures the number of stores that ran temporary price reductions, weighted by store size. Loaded from syndicated data.</td>
</tr>
<tr>
<td>% Attained</td>
<td>sales_data</td>
<td>Percentage of sales quota attained.</td>
</tr>
<tr>
<td>% Spend</td>
<td>promotion</td>
<td>Event spending (vehicle and buydown), as a percentage of event sales. This is a useful metric of the effectiveness of a promotion; the lower this number, the better.</td>
</tr>
<tr>
<td>% Spend O</td>
<td>promotion</td>
<td>Event spending (vehicle and buydown), as a percentage of event sales, for the optimized promotion.</td>
</tr>
<tr>
<td>% Spend P</td>
<td>promotion</td>
<td>Projected event spending (vehicle and buydown), as a percentage of event sales, as predicted when the promotion was committed.</td>
</tr>
</tbody>
</table>

PTP uses colors to indicate deviations between the projections and the actuals:

- If the actual value is more than 20% different from the projection in the undesirable sense, the projection is shown in red.

- If the actual value is more than 20% different from the projection in the desirable sense, the projection is shown in green. For example, if the actual profit was 130% of the projected profit, the projection is shown in green.

This series is configured (via a client expression) to have three branches, in the same way as # Wks P.
<table>
<thead>
<tr>
<th>Series</th>
<th>Table</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actually</td>
<td>sales_data</td>
<td>Actual demand one year ago.</td>
</tr>
<tr>
<td>Actuals Base</td>
<td>sales_data</td>
<td>Base number of units sold in the past, if there had been no promotions. Loaded from syndicated data.</td>
</tr>
<tr>
<td>Actuals Incr</td>
<td>sales_data</td>
<td>Incremental number of units sold in the past, due to promotions. Loaded from syndicated data.</td>
</tr>
<tr>
<td>Actuals LY</td>
<td>sales_data</td>
<td>Actual demand one year ago.</td>
</tr>
<tr>
<td>Actuals Ttl</td>
<td>sales_data</td>
<td>Total number of units sold in the past. This includes both base and incremental volume. Loaded from syndicated data.</td>
</tr>
<tr>
<td>Avg % Disc</td>
<td>promotion</td>
<td>Average percent discount</td>
</tr>
<tr>
<td>Avg % Spend</td>
<td>promotion</td>
<td>Average percent spend</td>
</tr>
<tr>
<td>Avg B Dwn</td>
<td>promotion</td>
<td>Average buy down for the event</td>
</tr>
<tr>
<td>Avg CPIU</td>
<td>promotion</td>
<td>Average cost per incremental unit</td>
</tr>
<tr>
<td>Avg Evt Spend</td>
<td>promotion</td>
<td>Average weekly event spend</td>
</tr>
<tr>
<td>Avg Inc Rtl Prft</td>
<td>promotion</td>
<td>Average weekly incremental retailer profit</td>
</tr>
<tr>
<td>Avg Incr Evt $</td>
<td>promotion</td>
<td>Average weekly incremental event dollars for manufacturer</td>
</tr>
<tr>
<td>Avg Incr Evt Vol</td>
<td>promotion</td>
<td>Average weekly incremental event volume</td>
</tr>
<tr>
<td>Avg Incr Mfg Prft</td>
<td>promotion</td>
<td>Average weekly incremental manufacturer profit</td>
</tr>
<tr>
<td>Avg Lift</td>
<td>promotion</td>
<td>Average lift factor for promotion</td>
</tr>
<tr>
<td>Avg Mfg Prft</td>
<td>promotion</td>
<td>Average weekly manufacturer profit</td>
</tr>
<tr>
<td>Avg Rtl</td>
<td>promotion</td>
<td>Average unit retail price at shelf. Loaded from syndicated data.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>------------------</td>
<td>---------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Avg Rtl Margin</td>
<td>promotion</td>
<td>Average retailer event margin</td>
</tr>
<tr>
<td>Avg Rtl Prft</td>
<td>promotion</td>
<td>Average weekly retailer profit</td>
</tr>
<tr>
<td>Avg Rtl sd</td>
<td>sales_data</td>
<td>Average unit retail price at shelf. Loaded from syndicated data.</td>
</tr>
<tr>
<td>Avg Ttl Evt Vol</td>
<td>sales_data</td>
<td>Average weekly total event volume</td>
</tr>
<tr>
<td>Base Evt $</td>
<td>promotion</td>
<td>Base sales for the manufacturer, during the promotion.</td>
</tr>
<tr>
<td>Base Evt $ O</td>
<td>promotion</td>
<td>Base sales for the manufacturer, during the optimized promotion.</td>
</tr>
<tr>
<td>Base Evt $ P</td>
<td></td>
<td>Projected base sales for the manufacturer, during the promotion.</td>
</tr>
<tr>
<td>Base Evt $ Rtl</td>
<td>promotion</td>
<td>Base sales for the retailer, during the promotion.</td>
</tr>
<tr>
<td>Base Evt $ Rtl Act</td>
<td>promotion</td>
<td>Base event dollars from a retailer’s perspective, as determined by syndicated data.</td>
</tr>
<tr>
<td>Base Evt $ Rtl P</td>
<td>promotion</td>
<td>Projected base sales for the retailer, during the promotion.</td>
</tr>
<tr>
<td>Base Evt $ Rtl sd</td>
<td>sales_data</td>
<td>Base event dollars earned by the retailer, as loaded from external systems. By default, this series displays loaded syndicated data.</td>
</tr>
<tr>
<td>Base Evt Vol</td>
<td>promotion</td>
<td>Baseline volume during the promotion.</td>
</tr>
<tr>
<td>Base Evt Vol O</td>
<td>promotion</td>
<td>Baseline volume during the optimized promotion.</td>
</tr>
<tr>
<td>Bill Back UOM</td>
<td>Promotion</td>
<td>The Bill-Back Accrual Rate for the promotion in the standard Unit of Measure</td>
</tr>
<tr>
<td>Base Fcst</td>
<td>sales_data</td>
<td>Base volume: actuals (for past dates) plus forecast (for future dates).</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>----------------</td>
<td>---------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>BDF Auth</td>
<td>sales_data</td>
<td>Authorized brand development funds, calculated as follows: ((\text{base rate} + \text{dev rate}) \times \text{volume} + \text{fixed funds})</td>
</tr>
<tr>
<td>BDF Alloc</td>
<td>promotion</td>
<td>Allocated brand development funds, based on the percentage set by the planner</td>
</tr>
<tr>
<td>BDF Alloc %</td>
<td>promotion</td>
<td>Read-only series that indicates how much of event spending (apart from slotting costs) is to be allocated to BDF. Note that BDF Alloc % + MDF Alloc % = 100%</td>
</tr>
<tr>
<td>BDF Auth</td>
<td>sales_data</td>
<td>Authorized brand development fund, calculated as follows: ((\text{base rate} + \text{dev rate}) \times \text{volume} + \text{fixed funds})</td>
</tr>
<tr>
<td>BDF Bal</td>
<td>sales_data</td>
<td>Remaining (unspent) BDF funds, computed as follows: (\text{BDF Auth} - \text{BDF Alloc})</td>
</tr>
<tr>
<td>BDF Base Rate</td>
<td>sales_data</td>
<td>Brand Development Fund Base rate -- displayed to the user in the field.</td>
</tr>
<tr>
<td>BDF Dev Rate</td>
<td>sales_data</td>
<td>Brand Development Fund Development rate, entered by corporate HQ.</td>
</tr>
<tr>
<td>BDF Fixed Funds</td>
<td>sales_data</td>
<td>BDF fixed funds</td>
</tr>
<tr>
<td>Buydown</td>
<td>promotion</td>
<td>The sum of the OI/UOM, BB/UOM, and SD/UOM series. Represents the total variable cost per standard Unit of Measure for the promotion.</td>
</tr>
<tr>
<td>Buydown $</td>
<td>promotion</td>
<td>Buy down spend for the promotion, computed as the buy down allowance multiplied by the volume.</td>
</tr>
<tr>
<td>Buydown O</td>
<td>promotion</td>
<td>Buy down spend for the optimized promotion.</td>
</tr>
<tr>
<td>Can Vol Dir</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Canbl $</td>
<td>promotion</td>
<td>Cannibalization dollars for the manufacturer. This considers volume that has been cannibalized from other products.</td>
</tr>
<tr>
<td>Canbl $ P</td>
<td>promotion</td>
<td>Projected cannibalization dollars for the manufacturer.</td>
</tr>
<tr>
<td>Canbl $ Rtl</td>
<td>promotion</td>
<td>Cannibalization dollars for the retailer. This considers volume that has been cannibalized from other products and from other stores of this retailer.</td>
</tr>
<tr>
<td>Canbl $ Rtl P</td>
<td>promotion</td>
<td>Projected cannibalization dollars for the retailer.</td>
</tr>
<tr>
<td>Canbl Vol Mfg</td>
<td>promotion</td>
<td>Cannibalization volume for the manufacturer.</td>
</tr>
<tr>
<td>Canbl Vol Other</td>
<td>promotion</td>
<td>Cannibalization of sales at other stores, as a result of the promotion. This is a negative number that indicates how many fewer units were sold. To the retailer, this is an undesirable effect. To the manufacturer, this effect is neutral, because the manufacturer cares only about net volume. (In Promotion Effectiveness terminology, this is the so-called “store switching” effect.)</td>
</tr>
<tr>
<td>Canbl Vol Own</td>
<td>promotion</td>
<td>Cannibalization of sales of other products by the same manufacturer, as a result of the promotion. This is a negative number that indicates how many fewer units were sold. (In Promotion Effectiveness terminology, this is the so-called “product switching” effect.)</td>
</tr>
<tr>
<td>Canbl Vol RtI</td>
<td>promotion</td>
<td>Cannibalization volume for the retailer. This is the sum of Canbl Vol Other and Canbl Vol Own, both of which are undesirable to the retailer.</td>
</tr>
<tr>
<td>COGS</td>
<td>promotion</td>
<td>Cost of goods, as paid by the manufacturer.</td>
</tr>
<tr>
<td>COGS sd</td>
<td>sales_data</td>
<td>Cost of goods, as paid by the manufacturer.</td>
</tr>
</tbody>
</table>
### Series | Table | Purpose
--- | --- | ---
Cons Promo | promotion level | Consumer overlay, the deal type as seen by the consumer. For example, buy-1-get-1-free. Controls the number of units in the deal and affects the volume.

Uses the Cons_type lookup table; see "Lookup Tables".

Cons Promo P | promotion level | Projected consumer overlay, the deal type as seen by the consumer, as predicted when the promotion was committed.

This is shown in red if the actual deal type was different.

This series is configured (via a client expression) to have three branches, in the same way as # Wks P.

Uses the Cons_type lookup table; see "Lookup Tables".

CPIU | promotion | Cost per incremental unit sold as a result of the promotion.

CPIU O | promotion | Cost per incremental unit sold as a result of the optimized promotion.

CPIU P | promotion | Projected cost per incremental unit sold as a result of the promotion, as predicted when the promotion was committed.

PTP uses colors to indicate deviations between the projections and the actuals; see "% Spend P".

This series is configured (via a client expression) to have three branches, in the same way as # Wks P.

Cumulative % vs Plan | sales_data | Total cumulative actuals, as a fraction of the plan.

Cumulative Actuals | sales_data | The total actuals (base plus incremental) cumulative to date.

Cumulative Plan | sales_data | Cumulative frozen planned volume.
<table>
<thead>
<tr>
<th>Series</th>
<th>Table</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>End Ship</td>
<td>promotion level</td>
<td>Date when shipments will end for the event</td>
</tr>
<tr>
<td>Evt Spend</td>
<td>promotion</td>
<td>Total plan spend (by the manufacturer) for the promotion, sum of buy down, vehicle costs, and slotting.</td>
</tr>
<tr>
<td>Evt Spend exS</td>
<td>promotion</td>
<td>Total planned buy down and vehicle costs for promotion. This spend is split between MDF and BDF funds. To control the split, you set the MDF Alloc % series, which controls how much of the spending is funded by MDF.</td>
</tr>
<tr>
<td>Evt Spend exS O</td>
<td>promotion</td>
<td>Total planned buy down and vehicle costs for optimized promotion.</td>
</tr>
<tr>
<td>Evt Spend exS P</td>
<td>promotion</td>
<td>Projected total planned buy down and vehicle costs for promotion, as predicted when the promotion was committed. PTP uses colors to indicate deviations between the projections and the actuals; see “% Spend P”. This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>Evt Status</td>
<td>promotion level</td>
<td>Status of the promotion as shown to users. For allowed values, see &quot;Promotion Status&quot;. Also, the color of this series indicates the optimization status of this promotion: Yellow means that the promotion has been optimized. • Green means that the promotion has been optimized and accepted, so that the promotion is using the optimization results. • White means that the promotion has not been optimized.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Incr Evt $</td>
<td>promotion</td>
<td>Incremental sales to the manufacturer due to the promotion.</td>
</tr>
<tr>
<td>Incr Evt $ Net</td>
<td>promotion</td>
<td>Net incremental sales due to the event.</td>
</tr>
<tr>
<td>Incr Evt $ O</td>
<td>promotion</td>
<td>Incremental sales to the manufacturer due to the optimized promotion.</td>
</tr>
<tr>
<td>Incr Evt $ P</td>
<td>promotion</td>
<td>Projected incremental sales to the manufacturer, due to the event, as predicted when the promotion was committed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>Incr Evt $ Rtl</td>
<td>promotion</td>
<td>Incremental sales to the retailer due to the promotion.</td>
</tr>
<tr>
<td>Incr Evt $ Rtl Act</td>
<td>promotion</td>
<td>Incremental sales to the retailer due to the promotion, as determined by syndicated data.</td>
</tr>
<tr>
<td>Incr Evt $ Rtl sd</td>
<td>sales_data</td>
<td>Incremental event dollars earned by the retailer, as loaded from external systems. By default, this series displays loaded syndicated data.</td>
</tr>
<tr>
<td>Incr Evt Vol</td>
<td>promotion</td>
<td>Incremental volume due to the promotion.</td>
</tr>
<tr>
<td>Incr Evt Vol Act</td>
<td>promotion</td>
<td>Incremental volume due to the promotion, as determined by syndicated data.</td>
</tr>
<tr>
<td>Incr Evt Vol Fut</td>
<td>promotion</td>
<td>Incremental volume due to the promotion. This series has values for all dates (not just future dates).</td>
</tr>
<tr>
<td>Incr Evt Vol O</td>
<td>promotion</td>
<td>Incremental volume due to the optimized promotion.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>------------------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Incr Evt Vol P</td>
<td>promotion</td>
<td>Projected incremental volume due to the promotion, as predicted when the promotion was committed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PTP uses colors to indicate deviations between the projections and the actuals; see &quot;% Spend P&quot;.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>Incr Evt Vol sd</td>
<td>sales_data</td>
<td>Incremental event volume, as loaded from syndicated data.</td>
</tr>
<tr>
<td>Incr Fcst</td>
<td>sales_data</td>
<td>Incremental volume: actuals and forecast due only to planned promotions.</td>
</tr>
<tr>
<td>Incr Mfg Prft</td>
<td>promotion</td>
<td>Incremental profit to the manufacturer due to the promotion. Event spending and slotting have been deducted.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This profit is in addition to the manufacturer’s usual profit and is thus a measure of the value of the promotion.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is displayed in red if the value is negative.</td>
</tr>
<tr>
<td>Incr Mfg Prft O</td>
<td>promotion</td>
<td>Incremental profit to the manufacturer due to the optimized promotion.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is displayed in red if the value is negative.</td>
</tr>
<tr>
<td>Incr Mfg Prft P</td>
<td>promotion</td>
<td>Projected incremental profit to the manufacturer due to the promotion, as predicted when the promotion was committed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PTP uses colors to indicate deviations between the projections and the actuals; see &quot;% Spend P&quot;.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>--------------</td>
<td>---------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Incr Rtl Prft</td>
<td>promotion</td>
<td>Incremental retailer profit due to the promotion, calculated as the incremental volume multiplied by the retailer's margin.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This profit is in addition to the retailer's usual profit and is thus a measure of the value of the promotion to the retailer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is displayed in red if the value is negative.</td>
</tr>
<tr>
<td>Incr Rtl Prft O</td>
<td>promotion</td>
<td>Incremental retailer profit due to the optimized promotion.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is displayed in red if the value is negative.</td>
</tr>
<tr>
<td>Incr Rtl Prft P</td>
<td>promotion</td>
<td>Projected incremental retailer profit due to the promotion, as predicted when the promotion was committed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PTP uses colors to indicate deviations between the projections and the actuals; see &quot;% Spend P&quot;.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>incr_vol_no_unplan</td>
<td>promotion</td>
<td>Incremental volume caused only by the planned promotions.</td>
</tr>
<tr>
<td>Is_self</td>
<td>promotion</td>
<td>For internal use only. This series indicates whether the promotion and the item-location combination are related:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 1 means that the promotion applies to the item-location combination.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 0 means that the promotion applies to some other item-location combination.</td>
</tr>
<tr>
<td>Lift</td>
<td>promotion</td>
<td>Lift factor for the promotion. This is the event volume divided by the base volume.</td>
</tr>
<tr>
<td>Lift O</td>
<td>promotion</td>
<td>Lift factor for the optimized promotion.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>List Price</td>
<td>promotion</td>
<td>List price, the price charged by the manufacturer to the retailer.</td>
</tr>
<tr>
<td>List Price sd</td>
<td>sales_data</td>
<td>List price, the price charged by the manufacturer to the retailer.</td>
</tr>
<tr>
<td>MDF Auth</td>
<td>sales_data</td>
<td>Authorized market development fund, computed as follows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(base rate + dev rate)*volume + fixed funds</td>
</tr>
<tr>
<td>MDF Alloc</td>
<td>promotion</td>
<td>MDF spending that is allocated to fund this event. This is computed as follows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MDF Alloc % * Evt Spend exS</td>
</tr>
<tr>
<td>MDF Alloc %</td>
<td>promotion</td>
<td>Editable series that controls how much of event spending (apart from slotting costs) is to be</td>
</tr>
<tr>
<td></td>
<td></td>
<td>allocated to MDF.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note that BDF Alloc % + MDF Alloc % = 100%</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Enter 50 for 50%, for example.</td>
</tr>
<tr>
<td>MDF Auth</td>
<td>sales_data</td>
<td>Authorized market development fund, computed as follows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(base rate + dev rate)* volume + fixed funds</td>
</tr>
<tr>
<td>MDF Bal</td>
<td>sales_data</td>
<td>Remaining (unspent) MDF funds, computed as follows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MDF Auth - MDF Alloc</td>
</tr>
<tr>
<td>MDF Base Rate</td>
<td>sales_data</td>
<td>Market development fund base rate.</td>
</tr>
<tr>
<td>MDF Dev Rate</td>
<td>sales_data</td>
<td>Market development fund development rate.</td>
</tr>
<tr>
<td>MDF Fixed Funds</td>
<td>sales_data</td>
<td>MDF fixed funds.</td>
</tr>
<tr>
<td>Mfg Prft O</td>
<td>promotion</td>
<td>Manufacturer's profit from the optimized event.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is displayed in red if the value is negative.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Mfg Profit</td>
<td>promotion</td>
<td>Manufacturer's profit from the event, considering both cost of goods and event spending. This series is displayed in red if the value is negative.</td>
</tr>
<tr>
<td>Mfg Profit Var</td>
<td>promotion</td>
<td></td>
</tr>
<tr>
<td>Net Incr Evt $</td>
<td>promotion</td>
<td>Net revenue from the manufacturer's perspective. This considers the total manufacturer's lift dollars and subtracts costs due to cannibalization and pre- and post-effects.</td>
</tr>
<tr>
<td>Net Incr Evt $ Rtl</td>
<td>promotion</td>
<td>Net revenue from a retailer's perspective. This considers the total retailer's lift dollars and subtracts costs due to cannibalization (as seen by the retailer) and pre- and post-effects.</td>
</tr>
<tr>
<td>Net Incr Rtl Prft</td>
<td>promotion</td>
<td>Net incremental profit for the retailer, after considering cannibalization and pre- and post-effects.</td>
</tr>
<tr>
<td>Optimization Status</td>
<td>promotion level</td>
<td>Indicates the status of any optimization that was run on this promotion. Used in the color expression of the Evt Status series. Not meant for direct use.</td>
</tr>
<tr>
<td>Optimized</td>
<td>promotion</td>
<td>For internal use only. Indicates if optimization was run on this promotion.</td>
</tr>
<tr>
<td>Off Invoice UOM</td>
<td>Promotion</td>
<td>The Off-Invoice Allowance Rate for the promotion in the standard Unit of Measure</td>
</tr>
</tbody>
</table>
### Series Table

<table>
<thead>
<tr>
<th>Series</th>
<th>Table</th>
<th>Purpose</th>
</tr>
</thead>
</table>
| Past End Date           | promotion level| Not displayed. This internal series is used to check whether a promotion has already occurred. For any promotion, this series equals one of the following values:  
  • 1 means that the promotion is past; specifically, the max_sales_date is equal to or after the end date of the promotion.  
  • 0 means that the promotion is in the future.  
  Other series use this series within client expressions that have the following general logic:  
  if past end date = 1, use actuals data; otherwise, use forecast data. |
<p>| Pay Type                | promotion      | Type of settlement arranged with the retailer for this promotion. Indicates the payment terms between the manufacturer and the retailer for this promotion. |
| Plan Vol                | sales_data     | Manufacturer’s planned revenue.                                                                                                                                                                |
| Pre Post Sales          | promotion      | Total sales made by the manufacturer before and after the promotion, as a result of the promotion. This is shown as a positive number for graphing purposes. These sales, however, are subtracted from the total sales. |
| Pre Post Value Rtl      | promotion      | Total sales made by the retailer before and after the promotion, as a result of the promotion. This is shown as a positive number for graphing purposes. These sales, however, are subtracted from the total sales. |
| Pre Post Vol            | promotion      | Total volume before and after the promotion, as a result of the promotion. This is generally a negative number.                                                                                  |
| Rtl Prft                | promotion      | Retailer’s profit from the event. This series is displayed in red if the value is negative.                                                                                                      |</p>
<table>
<thead>
<tr>
<th>Series</th>
<th>Table</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rtl Prt O</td>
<td>promotion</td>
<td>Retailer’s profit from the optimized event.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is displayed in red if the value is negative.</td>
</tr>
<tr>
<td>Sale Price</td>
<td>promotion</td>
<td>Sale price per unit at shelf.</td>
</tr>
<tr>
<td>Sale Price O</td>
<td>promotion level</td>
<td>Sale price per unit at shelf, for the optimized promotion.</td>
</tr>
<tr>
<td>Sales Quota</td>
<td>sales_data</td>
<td>Sales quota (revenue).</td>
</tr>
<tr>
<td>Sales Quota</td>
<td>sales_data</td>
<td>Sales quota (revenue).</td>
</tr>
<tr>
<td>Sales Var</td>
<td>promotion</td>
<td></td>
</tr>
<tr>
<td>SD UOM</td>
<td>Promotion</td>
<td>The Scan-Down Allowance Rate for the promotion in the standard Unit of Measure</td>
</tr>
<tr>
<td>Shelf Price</td>
<td>promotion</td>
<td>Everyday price to the consumer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In contrast to the Shelf Price sd series, this series is stored in promotion_data for better performance.</td>
</tr>
<tr>
<td>Shelf Price sd</td>
<td>sales_data</td>
<td>The everyday price to the consumer, as loaded from external systems. This series is stored in sales_data and is mainly for internal use; see Shelf Price.</td>
</tr>
<tr>
<td>Shipments</td>
<td>sales_data</td>
<td>Number of units shipped from the manufacturer to the ship-to destination of the retailer.</td>
</tr>
<tr>
<td>Slot Auth</td>
<td>sales_data</td>
<td>Authorized slotting funds.</td>
</tr>
<tr>
<td>Slot Bal</td>
<td>sales_data</td>
<td>Remaining slotting budget.</td>
</tr>
<tr>
<td>Start Event</td>
<td>promotion</td>
<td>Date when the promotion starts in stores.</td>
</tr>
<tr>
<td>End Event</td>
<td>promotion</td>
<td>Date when the promotion ends.</td>
</tr>
<tr>
<td>Start Event O</td>
<td>promotion level</td>
<td>Date when optimized promotion starts in stores.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>----------------</td>
<td>-----------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Start Event P</td>
<td>promotion level</td>
<td>Projected date when promotion starts in stores, as predicted when the promotion was committed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>Start Ship</td>
<td>promotion level</td>
<td>Date when the product will start to be shipped</td>
</tr>
<tr>
<td>Status</td>
<td>promotion level</td>
<td>For internal use only.</td>
</tr>
<tr>
<td>Ttl Evt $</td>
<td>promotion</td>
<td>Total revenue during the event, for the manufacturer.</td>
</tr>
<tr>
<td>Ttl Evt $ O</td>
<td>promotion</td>
<td>Total revenue during the optimized event, for the manufacturer.</td>
</tr>
<tr>
<td>Ttl Evt $ P</td>
<td>promotion</td>
<td>Projected total revenue during the event, for the manufacturer, as predicted when the promotion was committed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PTP uses colors to indicate deviations between the projections and the actuals; see “% Spend P”.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>Ttl Evt $ Rtl</td>
<td>promotion</td>
<td>Total revenue during the event, for the retailer.</td>
</tr>
<tr>
<td>Ttl Evt Vol</td>
<td>promotion</td>
<td>Total volume for the promotion.</td>
</tr>
<tr>
<td>Ttl Evt Vol O</td>
<td>promotion</td>
<td>Total volume for the optimized promotion.</td>
</tr>
<tr>
<td>Ttl Evt Vol P</td>
<td>promotion</td>
<td>Projected total event volume, as predicted when the promotion was committed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PTP uses colors to indicate deviations between the projections and the actuals; see “% Spend P”.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>Series</td>
<td>Table</td>
<td>Purpose</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ttl Fcst</td>
<td>sales_data</td>
<td>Total volume: base forecast plus incremental forecast.</td>
</tr>
<tr>
<td>Ttl Fund Auth</td>
<td>promotion</td>
<td>Total authorized spending, including MDF, BDF, and slotting.</td>
</tr>
<tr>
<td>Ttl Fund Bal</td>
<td>promotion</td>
<td>Remainder of total authorized spending, after accounting for spending.</td>
</tr>
<tr>
<td>Units</td>
<td>promotion level</td>
<td>Number of units associated with the consumer deal (Cons Promo). Usually this is 1. This is 2 in the case of 2-for-1 deals.</td>
</tr>
<tr>
<td>Unmatched $</td>
<td>sales_data</td>
<td>Trade spend not yet matched to an event.</td>
</tr>
<tr>
<td>Uplift</td>
<td>promotion_data</td>
<td></td>
</tr>
<tr>
<td>Veh Cost</td>
<td>promotion</td>
<td>Vehicle cost for the promotion.</td>
</tr>
<tr>
<td>Veh Cost O</td>
<td>promotion</td>
<td>Vehicle cost for the optimized promotion.</td>
</tr>
<tr>
<td>Veh Type O</td>
<td>promotion level</td>
<td>The vehicle type or event type of the optimized promotion.</td>
</tr>
<tr>
<td>Veh Type P</td>
<td>promotion level</td>
<td>Projected vehicle type of the promotion, as predicted when the promotion was committed. This series is configured (via a client expression) to have three branches, in the same way as # Wks P.</td>
</tr>
<tr>
<td>Vehicle Cost</td>
<td>promotion</td>
<td>Vehicle cost for event of type DISPLAY.</td>
</tr>
<tr>
<td>DISPLAY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vehicle Cost</td>
<td>promotion</td>
<td>Vehicle cost for event of type F&amp;D.</td>
</tr>
<tr>
<td>F&amp;D</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vehicle Cost</td>
<td>promotion</td>
<td>Vehicle cost for event of type F. SHOPPER.</td>
</tr>
<tr>
<td>F. SHOPPER</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vehicle Cost</td>
<td>promotion</td>
<td>Vehicle cost for event of type FEATURE.</td>
</tr>
<tr>
<td>FEATURE</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Series Table Purpose

<table>
<thead>
<tr>
<th>Series</th>
<th>Table</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vehicle Cost NATIONAL TV</td>
<td>promotion</td>
<td>Vehicle cost for event of type NATIONAL TV.</td>
</tr>
<tr>
<td>Vehicle Cost TPR</td>
<td>promotion</td>
<td>Vehicle cost for event of type TPR.</td>
</tr>
<tr>
<td>Volume Base</td>
<td>sales_data</td>
<td>Base volume aggregated over sales data.</td>
</tr>
<tr>
<td>Volume Base Ttl</td>
<td>sales_data</td>
<td>Base volume series used by many other series. This series gives the base volume, if no promotions were run or are run. It checks the value of Past End Date and uses the following logic. If past end date = 1, use actuals data; otherwise, use forecast data.</td>
</tr>
<tr>
<td>Volume Incr Ttl</td>
<td>promotion_data</td>
<td>Incremental volume series used by many other series. This series gives the incremental volume due to promotions. It checks the value of Past End Date and uses the following logic. If past end date = 1, use actuals data; otherwise, use forecast data.</td>
</tr>
</tbody>
</table>

### Item Levels

PTP uses the following item levels:
The most commonly used item level is Promotion Group. Some PTP worksheets use Brand or Segment. The other levels are provided for convenience, so that you can create worksheets aggregated at those levels.

The Manufacturer level is populated via the APPPROC_MAINTAIN_TERR_RETAILER procedure. The rest are created by ep_load_main.

**Location Levels**

PTP uses a variety of different location levels.

- Retailer
- Corporate

The most commonly used location levels is PTP are Territory and Retailer. The Retailer has a set of attributes, described in the following subsection. The other levels are provided for convenience, so that you can create worksheets aggregated at those levels.

The Territory-Retailer level is used by the Analytical Engine. This level is populated via the APPPROC_MAINTAIN_TERR_RETAILER procedure. The rest are created by ep_load_main.
Internally, the lowest location level is a combination of Ship To and Territory and is created automatically by Demantra.

**Retailer**

This level contains the retailers. It is expected that retailers will be loaded rather than created within PTP. However, users can and should modify attributes of these retailers:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account Classification</td>
<td>Drop-down list with the following choices:</td>
</tr>
<tr>
<td></td>
<td>• Growth</td>
</tr>
<tr>
<td></td>
<td>• Holding</td>
</tr>
<tr>
<td></td>
<td>• Declining</td>
</tr>
<tr>
<td>Avg Everyday Selling Margin</td>
<td>Average selling margin, disregarding promotions.</td>
</tr>
<tr>
<td>Class_of_Trade</td>
<td>Drop-down list with the following choices:</td>
</tr>
<tr>
<td></td>
<td>• Food</td>
</tr>
<tr>
<td></td>
<td>• Drug</td>
</tr>
<tr>
<td></td>
<td>• Mass</td>
</tr>
<tr>
<td></td>
<td>• C-Store</td>
</tr>
<tr>
<td></td>
<td>• Military</td>
</tr>
<tr>
<td>Event Threshold: Display Only</td>
<td>Minimum number of units that should be sold for an event of type Display.</td>
</tr>
<tr>
<td>Event Threshold: F Shopper</td>
<td>Minimum number of units that should be sold for an event of type F. Shopper.</td>
</tr>
<tr>
<td>Event Threshold: Feat Display</td>
<td>Minimum number of units that should be sold for an event of type F&amp;D.</td>
</tr>
<tr>
<td>Event Threshold: Feature Only</td>
<td>Minimum number of units that should be sold for an event of type Feature.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Purpose</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Event Threshold: Natl TV</td>
<td>Minimum number of units that should be sold for an event of type National TV.</td>
</tr>
<tr>
<td>Event Threshold: TPR Only</td>
<td>Minimum number of units that should be sold for an event of type TPR.</td>
</tr>
<tr>
<td>Key Competitors</td>
<td>A text field where you can list the key competitors of this retailer.</td>
</tr>
<tr>
<td>Min Man Event Margin</td>
<td></td>
</tr>
<tr>
<td>Min Rt Event Margin</td>
<td>Minimum margin that this retailer must make on an event. Promotion Optimization considers only events that provide at least this much margin.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the retailer.</td>
</tr>
<tr>
<td>Number of Active Stores</td>
<td>Number of active stores that this retailer operates.</td>
</tr>
<tr>
<td>Ship Timing: Display Stock #Wk</td>
<td>Specifies how much earlier this retailer likes to receive any items to be placed in display stock. Specify as the number of weeks needed before the start of the promotion.</td>
</tr>
<tr>
<td>Ship Timing: Displays # Wks</td>
<td>Specifies how much earlier this retailer likes to receive any displays to be placed in the stores. Specify as the number of weeks needed before the start of the promotion.</td>
</tr>
<tr>
<td>Ship Timing: Reg Open Stock Wks</td>
<td>Specifies how much earlier this retailer likes to receive any items to be placed in open stock. Specify as the number of weeks needed before the start of the promotion.</td>
</tr>
<tr>
<td>Slotting Fees per item</td>
<td>Amount that this retailer charges to place the items on the shelf, per item.</td>
</tr>
<tr>
<td>Use Default Profile</td>
<td>Controls whether to update this profile by getting the default values for all these attributes.</td>
</tr>
<tr>
<td>Veh Costs: Display Only</td>
<td>Default cost for an event of type Display for this retailer.</td>
</tr>
<tr>
<td>Veh Costs: F Shopper</td>
<td>Default cost for an event of type F. Shopper for this retailer. Adamit rethler.</td>
</tr>
<tr>
<td>Veh Costs: Feature &amp; Display</td>
<td>Default cost for an event of type F&amp;D for this retailer.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Purpose</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Veh Costs: Feature Only</td>
<td>Default cost for an event of type Feature for this retailer.</td>
</tr>
<tr>
<td>Veh Costs: Natl TV</td>
<td>Default cost for an event of type National TV for this retailer.</td>
</tr>
<tr>
<td>Veh Costs: TPR Only</td>
<td>Default cost for an event of type TPR for this retailer.</td>
</tr>
</tbody>
</table>

**Corporate**

This level allows retailers to be defined at both the corporate name level and the regional level.

**Promotion Levels**

PTP uses a variety of different promotion levels.

The following sections provide details on these levels:

- "Promotion"
- "Promotion Status"
- "Promotion Type"
- “Scenarios”
- "Optimization Goal"
- "Plans"

**Plan**

This level stores a set of promotions for a particular account over a given time period.
<table>
<thead>
<tr>
<th>Attribute</th>
<th>When Displayed</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>-</td>
<td>The account on which these promotions will be run.</td>
</tr>
</tbody>
</table>

### Promotion

This level contains the promotions. Users can add, modify, or remove promotions as needed. The following table lists all the attributes of promotions and indicates when these attributes are displayed:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>When Displayed</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Approval</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Buydown</td>
<td>-</td>
<td>Buy down allowance for this promotion. May be used for Off Invoice or Bill back purposes.</td>
</tr>
<tr>
<td>Cons Promo</td>
<td>When creating or editing</td>
<td>Consumer overlay. Indirectly specifies the number of units included in the deal to the customer. Uses the Cons_type lookup table; see &quot;Lookup Tables&quot;.</td>
</tr>
<tr>
<td>End Ship</td>
<td>When creating or editing</td>
<td>-</td>
</tr>
<tr>
<td>Event Status</td>
<td>Not used.</td>
<td>Ignore this attribute. It is not used.</td>
</tr>
<tr>
<td>Fixed Buydown</td>
<td>When optimizing</td>
<td>Specifies whether Promotion Optimization should use the buydown that you have already entered or calculate an optimal buydown for this promotion. Uses a lookup table that should not be edited.</td>
</tr>
<tr>
<td>Max Budget</td>
<td>When optimizing</td>
<td>Maximum allowed budget for this promotion.</td>
</tr>
<tr>
<td>Max Buydown</td>
<td>When optimizing</td>
<td>Maximum allowed buydown for this promotion. If Promotion Optimization calculates an optimal buydown, the buydown will not exceed this value.</td>
</tr>
<tr>
<td>Attribute</td>
<td>When Displayed</td>
<td>Purpose</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>method_status</td>
<td>-</td>
<td>Uses a lookup table that should not be edited.</td>
</tr>
<tr>
<td>Min Rtl Margin Override</td>
<td>When optimizing</td>
<td>Minimum margin that the retailer must make on this promotion. By default, Promotion Optimization considers the retailer's default required minimum margin. Use this parameter to override that value, if needed. Use a value greater than 0 and less than or equal to 1.</td>
</tr>
<tr>
<td>Name</td>
<td>When creating or editing</td>
<td>Name of the promotion. Does not have to be unique.</td>
</tr>
<tr>
<td>Optimal Budget</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Optimal Lift</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Optimal Price Decrease</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Optimal Profit</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Optimal Revenue</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Optimal Type</td>
<td>-</td>
<td>Indicates the optimal vehicle type for this promotion. This attribute is a lookup attribute that uses the Promotion Type level.</td>
</tr>
<tr>
<td>Optimization Goal</td>
<td>When optimizing</td>
<td>Select one of the following goals for this promotion:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Maximize Revenue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Maximize Profit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Maximize Units</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This attribute is a lookup attribute that uses the Optimization Goal level.</td>
</tr>
<tr>
<td>Optimization Range End</td>
<td>When optimizing</td>
<td>By default, Promotion Optimization assumes that you want the optimized promotion to fall</td>
</tr>
</tbody>
</table>

Reference 15-25
<table>
<thead>
<tr>
<th>Attribute</th>
<th>When Displayed</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optimization Range Start</td>
<td>When optimizing</td>
<td>within the span of time of the original promotion. If you want Promotion Optimization to search for a better time for this promotion, use these attributes to specify the range of time for optimization to consider.</td>
</tr>
<tr>
<td>Optimization Status</td>
<td>Never displayed</td>
<td>Status of the optimization process on this promotion. Uses a lookup table that should not be edited.</td>
</tr>
<tr>
<td>Population</td>
<td>When creating or editing</td>
<td>Combinations where this promotion will run and dates of the promotion.</td>
</tr>
<tr>
<td>Promotion Status</td>
<td>Not used.</td>
<td>Ignore this attribute. It is not used.</td>
</tr>
<tr>
<td>Promotion Type1</td>
<td>Never displayed</td>
<td>Current vehicle type for this promotion. This attribute is a lookup attribute that uses the Promotion Type level.</td>
</tr>
<tr>
<td>Return on Investment (ROI)</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Scenarios</td>
<td>When creating or editing</td>
<td>Scenario to which this promotion belongs. This attribute is a lookup attribute that uses the Scenarios level.</td>
</tr>
<tr>
<td>Start Ship</td>
<td>When creating or editing</td>
<td>-</td>
</tr>
<tr>
<td>Status</td>
<td>Never displayed; not used directly</td>
<td>-</td>
</tr>
<tr>
<td>Vehicle Type</td>
<td>When creating or editing</td>
<td>Type of the promotion. This attribute is a lookup attribute that uses the Promotion Type level.</td>
</tr>
</tbody>
</table>

**Promotion Status**

This level contains the PTP promotion statuses.
Promotion Type

This level contains the promotion types, by default, the following set:

<table>
<thead>
<tr>
<th>Type</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Display Only</td>
</tr>
<tr>
<td>F. Shopper</td>
<td>F Shopper</td>
</tr>
<tr>
<td>F&amp;D</td>
<td>Feature and Display</td>
</tr>
<tr>
<td>Feature</td>
<td>Feature Only</td>
</tr>
<tr>
<td>National TV</td>
<td>National TV advertising. If this does not apply, you can use this type as a placeholder for another type, as needed.</td>
</tr>
<tr>
<td>TPR</td>
<td>Temporary price reduction only</td>
</tr>
</tbody>
</table>

Consultants can add other types, but changes are needed in multiple places if this is done. The documentation for this is currently out of scope.

Scenarios

This level contains the scenarios, which have the following purposes:

- Actuals contains promotions from previous years. These promotions are excluded from most PTP worksheets because they fall outside the span of time used in these worksheets.
- Current Year should contain the promotions that are planned for the current fiscal year.
- Sandbox should contain all promotions that are not yet planned.

Optimization Goal

This level contains the predefined optimization goals. Do not make changes to this level.

Plans

This level is not used in PTP worksheets.
Lookup Tables

This section lists the configurable lookup tables used by promotion levels and series.

**Note:** You can change the contents of these table, but you should not change their structure.

Cons_type

This table lists types of consumer overlays and for each type, indicates the number of units included in the deal to the consumer. This lookup table is used by the Cons Promo attribute, the Cons Promo series, and the Cons Promo P series. This table has the following structure:

<table>
<thead>
<tr>
<th>Field</th>
<th>Required?</th>
<th>Data type</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONS_TYPE_ID</td>
<td>required</td>
<td>NUMBER(10)</td>
<td>Unique ID for Oracle internal use.</td>
</tr>
<tr>
<td>CONS_TYPE_CODE</td>
<td></td>
<td>VARCHAR2(50)</td>
<td>Code for the consumer overlay.</td>
</tr>
<tr>
<td>CONS_TYPE_DESC</td>
<td></td>
<td>VARCHAR2(50)</td>
<td>Name of the consumer overlay.</td>
</tr>
<tr>
<td>IS_FICTIVE</td>
<td></td>
<td>NUMBER(1)</td>
<td>Leave these null.</td>
</tr>
<tr>
<td>SELF SHAPE INDICATOR</td>
<td></td>
<td>NUMBER(5)</td>
<td></td>
</tr>
<tr>
<td>IG SHAPE INDICATOR</td>
<td></td>
<td>NUMBER(5)</td>
<td></td>
</tr>
<tr>
<td>OMIT_SEASONAL</td>
<td></td>
<td>NUMBER(5)</td>
<td></td>
</tr>
<tr>
<td>FICTIVE_CHILD</td>
<td></td>
<td>NUMBER(10)</td>
<td></td>
</tr>
<tr>
<td>LAST_UPDATE_DATE</td>
<td></td>
<td>DATE</td>
<td></td>
</tr>
</tbody>
</table>
Pay_Type_lookup

This table controls the drop-down choices in the Pay Type series. This table has the following structure:

<table>
<thead>
<tr>
<th>Field</th>
<th>Required?</th>
<th>Data type</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAY_TYPE_ID</td>
<td>required</td>
<td>NUMBER(10)</td>
<td>Unique ID for Oracle internal use.</td>
</tr>
<tr>
<td>PAY_TYPE_CODE</td>
<td></td>
<td>VARCHAR2(50)</td>
<td>Code for the consumer overlay.</td>
</tr>
<tr>
<td>PAY_TYPE_DESC</td>
<td></td>
<td>VARCHAR2(50)</td>
<td>Name of the consumer overlay.</td>
</tr>
<tr>
<td>IS_FICTIVE</td>
<td></td>
<td>NUMBER(1)</td>
<td>Leave these null.</td>
</tr>
<tr>
<td>SELF_SHAPE_INDICATOR</td>
<td></td>
<td>NUMBER(5)</td>
<td></td>
</tr>
<tr>
<td>IG_SHAPE_INDICATOR</td>
<td></td>
<td>NUMBER(5)</td>
<td></td>
</tr>
<tr>
<td>OMIT_SEASONAL</td>
<td></td>
<td>NUMBER(5)</td>
<td></td>
</tr>
<tr>
<td>FICTIVE_CHILD</td>
<td></td>
<td>NUMBER(10)</td>
<td></td>
</tr>
<tr>
<td>LAST_UPDATE_DATE</td>
<td></td>
<td>DATE</td>
<td></td>
</tr>
</tbody>
</table>

Methods

PTP uses the following custom methods.

Optimize Promotion

This method uses the Call Promotion Optimizer predefined workflow. The Call Promotion Optimizer workflow consists of three steps in addition to the edit member step:

1. The first step initializes the necessary fields in the database. This step collects arguments, passes them to the APPPROC_PRE_OPTIMIZATION stored procedure,
and then runs that stored procedure.

Caution: You should not change this step.

2. The second step calls the optimizer. This is a custom step that collects arguments and calls the OPL class file, which runs the optimization.

Note: You must configure this for your specific installation, as described in Configuring the Optimization Step in the Demantra Implementation guide.

3. The final step cleans up the necessary fields in the database, collects arguments, passes them to the APPPROC_POST_OPTIMIZATION stored procedure, and then runs that stored procedure.

Caution: You should not change this step.

If the user uses this method, Demantra creates a virtual promotion that the user can display along with the current promotion (in the TPO: Optimization Comparison worksheet).

Accept Optimization

This method saves the optimized promotion, overwriting the previous details. Specifically, it copies data from the optimized series to the corresponding standard series, for the selected promotion. For example, it copies data from # Wks O to # Wks.

This method uses the AcceptOptimization predefined workflow. This workflow consists of one step (which calls the APPPROC_ACCEPT_OPTIMIZATION procedure).

Procedures

PTP uses the following custom procedures.

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>APPPROC_ACCEPT_OPTIMIZATION</td>
<td>Used by Promotion Optimization.</td>
</tr>
<tr>
<td>APPPROC_BLE_ACTUALS_LY</td>
<td>Updates the Actuals_LY series.</td>
</tr>
<tr>
<td>Procedure</td>
<td>Purpose</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
</tr>
<tr>
<td>AP PPROC_BLE_VOLUME_BASE_FUTURE</td>
<td>Updates sales_data.vol_base_ttl, for all dates. For dates in the future, this procedure sets the field equal to the latest base forecast from the engine. For dates in the past, this procedure sets the field equal to the value of sales_data.sdata5, the syndicated base volume.</td>
</tr>
<tr>
<td>AP PPROC_BLE_VOLUME_BASE_HIST</td>
<td>Updates sales_data.vol_base_ttl, for dates in the past. This procedure sets the field equal to the value of sales_data.sdata5, the syndicated base volume.</td>
</tr>
<tr>
<td>APPPROC_CLEAR_DATA</td>
<td>Clears the sales_data, mdp_matrix, promotion, and promotion_data tables.</td>
</tr>
<tr>
<td>APPPROC_COPY_DEF_RETAILER</td>
<td>Iterates through all retailers, finds any that have been marked as using the default profile, and copies the default attribute values to each of those retailers.</td>
</tr>
<tr>
<td>APPPROC_DROP_TEMPS</td>
<td>Drops the temporary tables.</td>
</tr>
<tr>
<td>AP PPROC_MAINTAIN_TERR_RETAILER</td>
<td>Populates the Manufacturer level and the Territory-Retailer level.</td>
</tr>
</tbody>
</table>
Procedure | Purpose
---|---
APPPROC_POST_DATA_LOAD | This procedure completes the last steps needed during data loading:
- Updates the LAST_DATE_BACKUP parameter in the INIT_PARAMS_0 table to equal the last sales date in the system.
- Runs the APPPROC_COPY_DEF RETAILER procedure.
- Runs the APPPROC_MAINTAIN_TERR RETAILER procedure.
- Updates the promotion_data table with values loaded into sales_data.
- Updates sales_data.vol_base_ttl according to the sdata5 column that was loaded. This initiates the APPTRIG_VOLUME_BASE_UPDATE_SD trigger; see Triggers, page 15-32.

APPPROC_POST_OPTIMIZATION | Used by Promotion Optimization.

APPPROC_PRE_OPTIMIZATION | Used by Promotion Optimization.

Instead of running procedures directly, use the workflows provided by PTP.

See Workflows, page 15-33.

Triggers

PTP uses the following custom triggers.

<table>
<thead>
<tr>
<th>Trigger</th>
<th>When activated</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>APPTRIG_INSERT_PROMOTION</td>
<td>When inserting promotion</td>
<td>Gets list price, shelf price, and COGs from sales_data and copies them to promotion_data.</td>
</tr>
</tbody>
</table>
### Trigger

<table>
<thead>
<tr>
<th>Trigger</th>
<th>When activated</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>APP PTRIG_INSERT_PROMOTION_PAST</td>
<td>When inserting promotion in the past</td>
<td>Updates the following series for this promotion:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Avg Rtl sd</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Incr Evt Vol Act</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Base Evt $ Rtl Act</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Incr Evt $ Rtl Act</td>
</tr>
<tr>
<td>APP PTRIG_SHELF_PRICE_UPDATE_SD</td>
<td>When updating shelf price on sales_data.</td>
<td>Copies that data into promotion_data.</td>
</tr>
<tr>
<td>APP PTRIG_VOLUME_BASE_UPDATE_PD</td>
<td>When inserting a promotion</td>
<td>Gets sales_data.volume_base_ttl and updates the field by the same name in promotion_data.</td>
</tr>
<tr>
<td>APP PTRIG_VOLUME_BASE_UPDATE_SD</td>
<td>When updating volume_base_ttl in sales_data.</td>
<td>Copies that data into promotion_data</td>
</tr>
</tbody>
</table>

### Workflows

PTP uses the following workflows:

<table>
<thead>
<tr>
<th>Workflow</th>
<th>When to run</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AcceptOptimization</td>
<td>Do not run directly.</td>
<td>Used by the Accept Optimization method.</td>
</tr>
<tr>
<td>Call Promotion Optimizer</td>
<td>Do not run directly.</td>
<td>Used by the Optimize Promotion method.</td>
</tr>
</tbody>
</table>

**Note:** Includes installation-dependent details and must be configured for each installation.
<table>
<thead>
<tr>
<th>Workflow</th>
<th>When to run</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CopyRetailerDefaults</td>
<td>Run this each time you</td>
<td>Executes the APPPROC_COPY_DEF_RETAILER procedure.</td>
</tr>
<tr>
<td></td>
<td>edit a retailer to use the</td>
<td></td>
</tr>
<tr>
<td></td>
<td>default profile and each</td>
<td></td>
</tr>
<tr>
<td></td>
<td>time you edit the retailer</td>
<td></td>
</tr>
<tr>
<td></td>
<td>defaults in the Business</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Modeler.</td>
<td></td>
</tr>
<tr>
<td>Create Member</td>
<td>Do not run directly.</td>
<td>Used internally when a user creates a member of a level.</td>
</tr>
<tr>
<td>Delete Member</td>
<td>Do not run directly.</td>
<td>Used internally when a user deletes a member of a level.</td>
</tr>
<tr>
<td>DoNothing</td>
<td>Do not use.</td>
<td>Do not use.</td>
</tr>
<tr>
<td>Edit Member</td>
<td>Do not run directly.</td>
<td>Used internally when a user edits a member of a level.</td>
</tr>
<tr>
<td>Import Promo Data</td>
<td>Not required.</td>
<td>Provided for you to use if you want to load data manually.</td>
</tr>
<tr>
<td>ImportPromotionLevels</td>
<td>Not required.</td>
<td>Provided for you to use if you want to load data manually.</td>
</tr>
<tr>
<td>Paste Member</td>
<td>Do not run directly.</td>
<td>Used internally when a user pastes a member of a level.</td>
</tr>
<tr>
<td>Run App Proc After Batch</td>
<td>Run this after you run the</td>
<td>Runs the following required procedures:</td>
</tr>
<tr>
<td>Engine</td>
<td>Analytical Engine.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• APPPROC_BLE_ACTUALS_LY</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• APPPROC_BLE_VOLUME_BASE_FUTURE</td>
</tr>
<tr>
<td>Run Drop Temps</td>
<td>Run this daily.</td>
<td>Executes the APPPROC_DROP_TEMPS procedure.</td>
</tr>
<tr>
<td>Run Engine and BLE</td>
<td>Do not use.</td>
<td></td>
</tr>
<tr>
<td>runprocsteps</td>
<td>Do not run directly.</td>
<td>Used by the Optimize Promotion method.</td>
</tr>
</tbody>
</table>
Engine Configuration

This section describes the basic engine configuration in PTP.

Forecast Tree

The PTP forecast tree is as follows:

<table>
<thead>
<tr>
<th>Forecast level number</th>
<th>Levels used in this forecast level</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Item level</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Location level</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Lowest level</td>
<td>Lowest level</td>
</tr>
<tr>
<td></td>
<td>Item</td>
<td>Site</td>
</tr>
<tr>
<td>2</td>
<td>Item</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Location level</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Retailer</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Item</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Location level</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Retailer</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Promotion Group</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Location level</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Corporate</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Promotion Group</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Location level</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Highest</td>
<td>Highest</td>
</tr>
</tbody>
</table>

Parameter Settings

In PTP, the following parameter values are set for the Analytical Engine:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
<th>Notes</th>
<th>Needed for</th>
</tr>
</thead>
<tbody>
<tr>
<td>COMPETITION_IT</td>
<td>352</td>
<td>This is the manufacturer level.</td>
<td>Analytical Engine</td>
</tr>
<tr>
<td>Setting</td>
<td>Value</td>
<td>Notes</td>
<td>Needed for</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------</td>
<td>----------------------------------------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>COMPETITION_LOCATION</td>
<td>237</td>
<td>This setting refers to the Competition_Location group table, which has only one row. This has the same effect as setting COMPETITION_LOCATION equal to the Retailer level.</td>
<td>Promotion Optimization</td>
</tr>
<tr>
<td>CalcOptimizationInput</td>
<td>yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>StartAverage</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AverageHorizon</td>
<td>52</td>
<td>Specify the length of time, in base time units, to use in calculating the average baseline forecast. Typically one year or half a year is suitable.</td>
<td></td>
</tr>
<tr>
<td>BottomCoefficientLevel</td>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TopCoefficientLevel</td>
<td>3</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Engine Models**

Only the linear models work with Promotion Optimization. Therefore, in the model table in the database, the following models are marked as IS_OPTIMIZATION=1: R-REGR, M-MRIDGE, and C-CMREG.

**Additional Checklist Before Running Optimization**

1. The application server currently must be a WINDOWS machine in order to run optimization.

2. The application server must have Oracle or SQL Server clients installed.

3. TNS entry in TNSNames.ora where name matches the DBNAME entry in the APPSERVER.PROPERTIES file which can be reached in <ROOT>\Collaborator\demantra
4. From Business Modeler, navigate to system parameters.
Parameters > System Parameters

In the system tab, check that the parameter `AppServerLocation` contains the correct path where the application is installed. If there is a mismatch, enter the correct path into the parameter `application_root`

**Example**
Example setting: `F:\Program Files\Integration 7.1.1\Collaborator\demantra`

5. Navigate on the desktop to My Computer. Right click, and then choose Properties from the right-click menu.

6. Choose the Advanced tab, and then click Environmental Variables.
Verify that the path variable contains path to
`<ROOT>\Collaborator\demantra\optimization\dll`. 
Important: The Demantra Local Application replaces Collaborator Workbench. You may see both names in this text.

This chapter covers the following topics:

- Running the Analytical Engine
- Running Required Workflows
- Managing the PTP Users

Running the Analytical Engine

You should run the Analytical Engine in batch mode probably about once a week. This generates a forecast for all the data in the system.

1. Click Demantra > Demantra Spectrum release > Engine Administrator.
2. Click File > Run Engine.
3. For Username and Password, enter the username and password of the database user that stores the Demantra data. (In the installer, this user is referred to as the Oracle Database User).

4. For Server, enter the Oracle SID of the database.

5. Click Connect.

6. For Run Mode, click Batch.

7. For Engine Profile, click Batch.

8. Click Run Engine.

   After running the Analytical Engine, you should run the Run App Proc After Batch Engine workflow.

   See Running Required Workflows, page 16-2.

### Running Required Workflows

PTP provides several workflows that perform necessary back-end tasks. An administrator will need to run these workflows periodically. To run workflows, you use the Workflow Manager, a Web-based tool that can be accessed only by users with the System Manager permission level.

This section lists these workflows and describes how to run them.
**Required Workflows**

You should run the following workflows periodically:

<table>
<thead>
<tr>
<th>Workflow</th>
<th>When to run</th>
</tr>
</thead>
<tbody>
<tr>
<td>CopyRetailerDefaults</td>
<td>Run this each time you edit a retailer to use the default profile and each time you edit the retailer defaults in the Business Modeler.</td>
</tr>
<tr>
<td>Run Drop Temps</td>
<td>Run this daily.</td>
</tr>
<tr>
<td>Run App Proc After Batch Engine</td>
<td>Run this after you run the Analytical Engine in batch mode.</td>
</tr>
</tbody>
</table>

**Logging on to the Workflow Manager**

1. Click Demantra > Demantra Spectrum release > Collaborator Workflow.
2. In the Log On dialog box, enter your user name and password. The Workflow Manager comes up, displaying a list of workflow schemas.

**Starting Workflow Instances**

To start a workflow instance

Click Start next to the schema that you want to start.

**Viewing Workflow Status**

You can view all the status of all public workflow schemas and all private workflow schemas that you created. This means that you can see how many instances of those schemas are running, as well as the status of each instance.

**To view overall status of the workflows**

The Workflow Manager displays the overall status information for the workflows.
Each row corresponds to a workflow schema. The Instances column indicates how many instances of this workflow schema are currently running, if any. The Status column uses the following color codes:

- **Green**: The workflow schema is live and you may execute it, creating a workflow instance.
- **Red**: The workflow schema is archived and cannot be executed.
- **Yellow**: There is a data error or other fault within this schema.

### To view the currently running instances of a schema

1. Click the Instances link in the row corresponding to that workflow.

   The Workflow Manager lists all the instances of that schema that are currently running.

2. When you are done, click Back.

### Scheduling Workflow Instances

If you are the owner of a workflow, you can schedule an instance to start at a specific time or times. If you are not the owner, you cannot schedule it, although you can start it
To schedule a workflow instance

1. If the workflow schema is not visible, use the dropdown menu and select the name of a schema group to which it belongs. Or select All.

2. Click Schedule in the row corresponding to that workflow.

The system displays the Schema Scheduler page, which lists all the times when Workflow Engine will start an instance of this schema.

3. Click Add.
4. In the Schedule Schema dropdown list, select the option that specifies how often to start an instance of this workflow:
   - Daily
   - Weekly
   - Monthly
   - Once
   - At Startup (This option launches the workflow whenever the Web server is started.)
   - Periodic (in this option, you can start a workflow at periodic intervals (measured in seconds, minutes, hours, days, weeks, months, or years. Note that you cannot choose the starting time.)

Depending on the choice you make here, the system displays additional scheduling options in the bottom part of the page.

5. In the rest of the page, finish specifying the schedule.
To unschedule a workflow instance
1. On the Workflow Management page, click Schedule in the row corresponding to that workflow.

The system displays the Schema Scheduler page. This page displays one row for each scheduling entry for this workflow.

2. Click the row corresponding to the scheduling entry you want to remove.

3. Click Remove.

Stopping Workflow Instances
You can stop any workflow instance that you started. You cannot stop a workflow instance started by another user.

To stop a workflow instance
1. If the workflow schema is not visible, use the dropdown menu and select the name of a schema group to which it belongs. Or select All.

2. Click the number in the Instances column that corresponds to that workflow.

The system lists all the instances of that schema.

<table>
<thead>
<tr>
<th>Process ID</th>
<th>Started at</th>
<th>Initiator</th>
<th>Current step</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>Mon Dec 08 16:53 EST 2008</td>
<td>db</td>
<td>#SortableData</td>
<td>Terminate</td>
</tr>
</tbody>
</table>

**Note:** Instances that show in red are instances of Fail-To-Execute Step steps. For more information, see the *Oracle Demantra Foundation Implementation Guide*.

3. Click Terminate next to the instance that you want to stop.

4. Click OK.

The instance is stopped and is removed from the list of instances.

**Note:** Terminate stops only the workflow instance itself. It does not cancel any work that the instance may have initiated (such as tasks that were sent or requests placed in the Simulation Engine or
Business Logic Engine queues). These items must be cancelled manually.

See the *Oracle Demantra Implementation Guide*

**Managing the PTP Users**

To manage the PTP users, you use the Business Modeler, a desktop tool that can be accessed only by users with the System Manager permission level. (Other users can log into the Business Modeler, to change their own passwords, but no other options are available to them.)

**Logging onto the Business Modeler**

Before starting the Business Modeler, make sure that the database is running.

**To start the Business Modeler**

1. On the Start menu, click Programs.
2. Click Demantra > Demantra Spectrum release > Business Modeler.
   
   A login window appears.
3. Enter your user name and password.
4. Click Login.

**Copying a User**

The easiest way to create new users is to copy existing users and edit the details as needed.

**To copy a user**

1. In the Business Modeler, click Security > Create/Modify User.
   
   The Create/Modify User dialog box appears.
2. Click the button of the user you want to copy, and then click Create Copy.
   
   The User Details dialog box appears. Some of the information, such as user name, is blank. Other details, such as the company name, are copied from the original user.
3. Specify the user name and password for the new user.
4. Make other changes as needed.

5. Do one of the following:
   - Click Next to continue editing information for the new user. Demantra initially uses all the same values as for the original user.
   - Click Finish.

Creating or Modifying a User

To create or modify a user

1. In the Business Modeler, click Security > Create/Modify User.

2. Next:
   - To create a new user, click the New User button, and then click OK.
   - To modify a user, click the button of that user then click OK. Or double-click the icon of the user whose details you want to modify.

The User Details dialog box appears.

<table>
<thead>
<tr>
<th>Enter User Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>User: Jeff_Wilson</td>
</tr>
<tr>
<td>Password: ********</td>
</tr>
<tr>
<td>Permission Level:</td>
</tr>
<tr>
<td>Language: English</td>
</tr>
<tr>
<td>First Name: Jeff</td>
</tr>
<tr>
<td>Last Name: Wilson</td>
</tr>
<tr>
<td>Company Name: Rory's International</td>
</tr>
<tr>
<td>Phone Number:</td>
</tr>
<tr>
<td>Fax Number:</td>
</tr>
<tr>
<td>E-Mail Address: <a href="mailto:wilson@orys.com">wilson@orys.com</a></td>
</tr>
</tbody>
</table>

3. Specify basic user details as follows:
   1. Under Enter User Details, type the following information in the appropriate boxes (or select from the dropdown lists):
      - The user name, password, permission level, and the language in which the system will be operated.
• The first and last name of the user, the company name, phone and fax number, and the email address.

2. For Permission Level, use System Manager if this user needs access to the Business Modeler and the Workflow Manager. Otherwise, use Supervisor.

3. Click Next.

The User Modules dialog box appears. Here you specify which Demantra user interfaces this user can access.

<table>
<thead>
<tr>
<th>Name</th>
<th>Status</th>
<th>Available Named Users</th>
<th>Defined Concurrent Users</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demantra Administrative Tools</td>
<td>✓</td>
<td>9983/9999</td>
<td>9999</td>
</tr>
<tr>
<td>Demantra Demand Planner</td>
<td>✓</td>
<td>9982/9999</td>
<td>9999</td>
</tr>
<tr>
<td>Demantra Demand Planner Web</td>
<td>✓</td>
<td>9982/9999</td>
<td>9999</td>
</tr>
<tr>
<td>Demantra Collaborator Workbench</td>
<td>✓</td>
<td>9961/9999</td>
<td>9999</td>
</tr>
<tr>
<td>Demantra Anywhere</td>
<td>✓</td>
<td>9990/9999</td>
<td>9999</td>
</tr>
<tr>
<td>Demantra Promotion Effectiveness</td>
<td>✓</td>
<td>9991/9999</td>
<td>9999</td>
</tr>
<tr>
<td>Settlement Management</td>
<td>✓</td>
<td>9999/9999</td>
<td>9999</td>
</tr>
<tr>
<td>Demantra Promotions Optimization</td>
<td>✓</td>
<td>9999/9999</td>
<td>9999</td>
</tr>
</tbody>
</table>

4. Click the check box next to each module that the user needs to work with. Then click Next.

The New User - Select User Series dialog box appears. This dialog box allows you to determine what data series will be active for the new user, from the entire set of series in this component. Each list is a collapsible list of series groups and the series in them.
If a series is not active for a user, it is not available when the user creates worksheets and is not viewable in existing worksheets to which the user has access.

5. Specify the series that a user can see, as follows:

1. Move all series that you want into the Selected Series list. To do so, either double-click each series or drag and drop it.

2. Remove any unwanted series from the Selected Series list.

   **Note:** You can also move an entire series group from one list to the other in the same way.

3. When you are done specifying series, click Next.

   The New User - Select User Filters dialog box appears. This dialog box lets you filter the data that the user can see; specifically, you control which levels and which members of those levels the user can see.
6. Filter the data that the user can see, as follows:
   1. Click a level in the left side of the dialog box and drag it to the box on the right. Or double-click a level in the left side.
   2. Now specify which members of this level the user can see. To do so, click a member in the list, and then click the right arrow button. Or double-click the member you want to filter out.

   The system moves the selected members to the box on the lower right side. Now the user can see only the selected members of this level. In the preceding example, the user can see only data that is associated with the Rainbow brand.

   **Note:** The Selected Members list cannot include more than 200 members.

3. Repeat the preceding steps for each filter you want to add. Each filter automatically limits the choices available in subsequent filters.

4. When you have appropriately filtered data for the user, click Next.

   The New User - Select User Groups dialog box appears. This dialog box allows you to select the group or groups to which the new user will belong. Members of a group can see each other within Who’s Online.

7. Specify the collaboration groups to which a user belongs, as follows:
   1. Move all groups to which the user should belong into the Selected Groups list.
To do so, either double-click each group or drag and drop it.

**Note:** You can also select and move multiple groups with the standard Ctrl+click or Shift+click actions.

2. Remove any unwanted groups from the Selected Groups list.

3. Click Next.

8. Click Finish.

**Deleting a User**

**To delete a user**

1. In the Business Modeler, click Security > Create/Modify User.

2. Click the button of the user you want to delete, and then click Delete.

   A question box appears, asking if you are sure you want to delete the selected user.

3. To delete the selected user, click Yes.

See the *Oracle Demantra Implementation Guide*
ActualLY, 15-4
actuals
  colors used for deviations, 15-3
  compared to projections, 12-4, 12-6
  details for event, 12-4, 12-7
  used in TFO, 2-9
  versus plan, 5-4
Actuals Base, 15-4
Actuals Incr, 15-4
Actuals scenario, 15-27
Actuals Ttl, 15-4
Actuals versus Plan summary pane, 5-4
aggregation
  introduction, 2-1
  kinds of levels, 2-1
ampersand, in Oracle Demantra Spectrum, 4-2
Analytical Engine
  configuring for optimization, 15-35
  running in simulation mode, 10-3
  typical use, 1-7
applet
  installing, 3-2, 5-3, 5-9
APPPROC_COPY_DEF_RETAILER, 15-31
APPPROC_BLE_ACTUALS_LY, 15-30
  running from a workflow, 15-34
APPPROC_BLE_VOLUME_BASE_FUTURE, 15-31
  running from a workflow, 15-34
APPPROC_BLE_VOLUME_BASE_HIST, 15-31
APPPROC_COPY_DEF_RETAILER
  running from a workflow, 15-34
APPPROC_DROP_TEMPS, 15-31
  running from a workflow, 15-34
APPPROC_MAINTAIN_TERR_RETAILER, 15-20, 15-20, 15-31
APPPROC_POST_DATA_LOAD, 15-32
APPPROC_POST_OPTIMIZATION, 15-32
APPPROC_PRE_OPTIMIZATION, 15-32
APPROC_ACCEPT_OPTIMIZATION, 15-30
APPTRIG_INSERT_PROMOTION, 15-32
APPTRIG_INSERT_PROMOTION_PAST, 15-33
APPTRIG_SHELF_PRICE_UPDATE_SD, 15-33
APPTRIG_VOLUME_BASE_UPDATE_PD, 15-33
APPTRIG_VOLUME_BASE_UPDATE_SD, 15-33
attachment
  adding, 4-14
  downloading, 4-15
  permissions for, 4-16
  removing, 4-15
attribute
  copying from optimized promotion to original promotion, 10-14
  editing for retailer, 5-8
  of plan, reference, 15-23
  of promotion, reference, 15-24
  of retailer, reference, 15-21
  specifying for promotion, 8-7
audit trail
  defining profile for viewing, 4-20
  for a combination, 4-19
  introduction, 4-17
AverageHorizon parameter, 15-36
Avg Rtl, 15-4
Avg Rtl sd, 15-5
axes of a worksheet, specifying, 13-20

B
Base Evt Vol, 15-5
Base Evt Vol O, 15-5
Base Fcst, 15-5
batch run, 16-3
BDF
introduction, 2-8
series names, 6-2
setting fund amounts, 6-3, 6-5
using fund, 8-8
viewing fund balances, 8-3
viewing funds, 6-6
BDF Alloc, 15-6
BDF Auth, 15-6, 15-6
BDF Bal, 15-6
BDF Base Rate, 15-6
BDF Dev Rate, 15-6
BDF Fixed Funds, 15-6
Bill Back UOM, 15-5
bill-to locations, 2-4
BottomCoefficientLevel parameter, 15-36
brand
and other levels, 15-20
introduction, 2-3
budget
consuming, 8-8
establishing, 6-3, 6-5
introduction, 2-8
series names, 6-2
viewing, 6-6
viewing balance, 8-3
Business Modeler, starting, 16-8
Buydown, 15-6
Buydown $, 15-6
Buydown O, 15-6
cannibalization
introduction, 2-10
manufacturer
actual, 12-5
actual versus projected, 12-4
retailer
actual, 12-7
actual versus projected, 12-4
categories
introduction, 2-3
characters to avoid, 4-2
client expressions and recalculation, 4-3
Collaborator Workbench
adding content panes, 13-5
introduction, 1-2
key metrics, 5-3
logging in, 5-1
opening worksheets, 5-9
personalizing, 5-12
combination
exporting data for, 4-6
including in worksheet, 13-11, 13-12
companies, 2-5
Cons Promo, 15-8
Cons Promo P, 15-8
consumption planning, 14-1, 14-3
content
adding pane from existing panes, 5-12
introduction to options, 13-2
options, 13-5
predefined summary panes, 5-3
cost benefit review
for future promotion, 11-3, 11-9
for optimized promotion, 10-10
for promotions in selected scenario, 8-5
CPI (Consumer Price Index), 13-14
CPIU
comparing promotions, 11-9
how computed, 15-8
CPIU O, 15-8
CPIU P, 15-8
Cumulative Actuals, 15-8
Cumulative Plan, 15-8
Current Year scenario, 2-7, 15-27

C
cache, worksheet
enabling for a worksheet, 13-5
refreshing manually, 4-17
CalcOptimizationInput parameter, 15-36
Canbl $, 15-7
Canbl $ Rtl, 15-7

D
dashboard
  adding content panes, 13-5
  introduction, 1-2
  key metrics, 5-3
  logging in, 5-1
  opening worksheets, 5-9
  personalizing, 5-12

data
  copying and pasting with Excel, 4-6
  copying and pasting within worksheet, 4-5
  editing, 4-1
  exporting to Excel, 4-6
  importing into Excel, 4-7
  printing, 4-10

database
  connecting to via DOL, 4-7

default
  combinations for new promotion, 8-7
  combinations in worksheet, 13-12
  layout in Collaborator Workbench, 5-12
  recalculation, 4-3
  table sort, restoring, 4-4
  worksheet view layout, 13-20

districts, 2-5
divisions, 2-5
DOL, using, 4-7
Dynamic Open Link, using, 4-7

duplicating, 8-13
evaluating future event, 11-2
evaluating past event, 12-2, 12-5
introduction, 2-6
life cycle, 2-7
marking as paid, 8-10
marking as planned, 8-8
modifying, 8-11
optimization results, 10-9
optimizing, 10-6
projections and actuals, 12-3, 12-6
reference for attributes, 15-24
specifying how to fund, 8-8
Evt Spend, 15-9
Evt Spend exS, 15-9
Evt Spend exS O, 15-9
Evt Spend exS P, 15-9
Evt Status, 15-9
display color, 8-3
Excel
  copying data to, 4-6
  exporting data to, 4-6
  linking data into via Dynamic Open Link (DOL), 4-7
  pasting data from, 4-6
exception filter, applying to worksheet, 13-18
exchange rate
  introduction, 13-14
  used in worksheet, 13-15
extra filters option, 13-5

e
  email
    escalating a task, 5-12
    sending notification of task, 5-10
    specifying for users, 16-9
End Event, 15-16
End Ship, 15-9
ep_load_main, 15-20, 15-20
event
  accepting optimization, 10-14
  approving, 8-9
  closing, 8-10
  committing, 8-9
  comparing to other events in scenario, 11-8
  copying and pasting, 8-16
  costs and spending, 2-9
  creating, 8-6
  deleting, 8-16

F

  files
    attaching to a task, 5-11
    attaching to notes, 4-14
    downloading from notes, 4-15
  filter
    adding for when worksheet opens, 13-5
    adding to worksheet view, 13-26
    and other performance tips, 13-29
    at user level, 16-11
    filtering performance, 13-16
    for bar charts, 13-6
    introduction, 13-16
    finding elements, 13-8
    fixed funds
introduction, 2-8
series names, 6-2
forecast
  affected by promotions, 2-7
  and actuals, 6-3
  and simulation, 10-1
  and unplanned promotions, 2-7
  and volume breakdown, 2-9
  introduction, 1-7
  viewing, 7-3
forecast tree and Promotion Optimization, 15-35
funds
  introduction, 2-8
  series names, 6-2
  setting amounts, 6-3, 6-5
  using, 8-8
  viewing, 6-6
  viewing balances, 8-3

G
graph
  adding series to, 13-21
  choosing type, 13-20
  time resolution of, 13-9
  viewing note from within, 4-13
  group
    adding users to, 16-12

I
illegal characters, 4-2
incr_vol_no_unplan, 15-12
Incr Evt $, 15-10
Incr Evt $ Net, 15-10
Incr Evt $ O, 15-10
Incr Evt $ P, 15-10
Incr Evt $ Rtl, 15-10
Incr Evt $ Rtl sd, 15-10
Incr Evt Vol, 15-10
Incr Evt Vol Act, 15-10
Incr Evt Vol Fut, 15-10
Incr Evt Vol O, 15-10
Incr Evt Vol P, 15-11
Incr Fcst, 15-11
Incr Mfg Prft, 15-11
Incr Mfg Prft O, 15-11
Incr Mfg Prft P, 15-11
Incr Rt Prft, 15-12
Incr Rt Prft O, 15-12
Incr Rt Prft P, 15-12
index (financial)
  in audit trail, 4-19
  introduction, 13-14
  used in worksheet, 13-15
Is_self, 15-12
items, 2-3
item-type levels, introduction, 2-2

J
Java
  preventing updates, 3-2
Web Start, 5-2
JRE, 5-2
  installing, 3-1

L
layout, Collaborator Workbench
  configuring by user, 5-12
  configuring My Tasks, 5-14
  configuring My Worksheets, 5-15
layout, worksheet
  defining, 13-20
  tips, 13-29
  level
    adding to worksheet, 13-11
    in worksheet, 13-11
    item levels in TPO, 15-19
    location levels in TPO, 15-20
    on worksheet tab, 13-21
    promotion levels in TPO, 15-23
Lift, 15-12
lift decomposition, manufacturer
  introduction, 2-10
  projected and actual, 12-4
lift decomposition, retailer
  actual, 12-7
  introduction, 2-10
  projected and actual, 12-7
Lift O, 15-12
links in Collaborator Workbench
  adding link within a task, 5-11
List Price sd, 15-13
location-type levels, introduction, 2-2
M
manufacturer
and other levels, 15-20
incremental profit, 10-10
introduction, 2-3
maintaining level, 15-31
MDF
introduction, 2-8
series names, 6-2
setting fund amounts, 6-3, 6-5
using fund, 8-8
viewing fund balances, 8-3
viewing funds, 6-6
MDF Alloc, 15-13
MDF Auth, 15-13, 15-13
MDF Bal, 15-13
MDF Base Rate, 15-13
MDF Dev Rate, 15-13
MDF Fixed Funds, 15-13
member
and Open With context, 13-5
introduction, 2-2
methods, reference information, 15-29
Mfg Prft O, 15-13
Mfg Profit, 15-14
Mfg Profit Var, 15-14
models for use with Promotion Optimization, 15-36
My Tasks
configuring, 5-12
configuring and sorting of number of tasks, 5-14
refreshing, 5-10
My Worksheets, 5-9
configuring, 5-12
configuring list of worksheets, 5-15
sending a worksheet as a task, 5-10
worksheet descriptions in, 13-4
N
Net Incr Evt $, 15-14
Net Incr Evt $ Rtl, 15-14
new product launches, 13-28
note
adding, 4-13
adding an attachment, 4-14
deleting, 4-14
editing, 4-13
setting permissions, 4-16
viewing, 4-13
Notes/Attachments subtab, 4-12, 4-14
O
Off Invoice UOM, 15-14
Open With menu
introduction, 3-6
specifying context for filtering, 13-5
optimization
accepting results, 10-14, 10-14
effect on color of Evt Status, 8-3
introduction, 1-8
performing, 10-6
Optimization Comparison worksheet, 10-8, 10-15
Optimized series, 15-14
P
parameters
for optimization, 10-7
for Promotion Optimization, 15-35
Past End Date, 15-15
Pay Type, 15-15
Pay Type series, 15-29
performance tips for worksheet design, 13-29
permission level
specifying for user, 16-9, 16-9
permissions in a note, 4-16
personalization
My Tasks, 5-14
My Worksheets, 5-15
wide and narrow panes, 5-12
Planning Environment worksheet, 8-1, 8-17
Planning Hierarchy summary pane, 5-5, 5-6, 5-7, 5-9, 5-9
Plan Vol, 15-15
Pre Post Sales, 15-15
Pre Post Value Rtl, 15-15
Pre Post Vol, 15-15
printing, 4-10
procedures, reference information, 15-30
product groups, 2-4
product lines, 2-4
product subgroups, 2-4
profile for selecting parts of audit trail, 4-20
projections
colors used for deviations, 15-3
compared to actuals, 12-4, 12-6
Promo Effect - Mfg worksheet, 11-2, 11-10
Promo Effect - Rtl worksheet, 11-14
Promo-Evaluation Mfg worksheet, 12-2, 12-8
Promo-Evaluation Rtl worksheet, 12-5, 12-13
promotion
accepting optimization, 10-14
approving, 8-9
closing, 8-10
committing, 8-9
comparing to other promotions in scenario, 11-8
copying and pasting, 8-16
costs and spending, 2-9
creating, 8-6
deleting, 8-16
duplicating, 8-13
editing, 8-8
evaluating future promotion, 11-2
evaluating past promotion, 12-2, 12-5
introduction, 2-6
life cycle, 2-7
marking as paid, 8-10
marking as planned, 8-8
modifying, 8-11
optimization results, 10-9
optimizing, 10-6
projections and actuals, 12-3, 12-6
reference for attributes, 15-24
specifying how to fund, 8-8
Promotion Comparison worksheet, 11-8, 11-17
promotion group
and other levels, 15-20
creating a promotion for, 8-6
introduction, 2-4
specifying quotas and funds, 6-5
Promotion Optimization
parameters, 15-35
percent attained, 8-3
specifying bottom-up, 6-5
specifying top-down, 6-3
versus sales, 5-4
viewing, 6-6
Quota and Fund Entry Bottom-Up worksheet, 6-5, 6-9
Quota and Fund Entry Top-Down worksheet, 6-3, 6-7
Quota and Fund View worksheet, 6-6, 6-10
quote marks, in Oracle Demantra Spectrum, 4-2
R
redo, 4-3
refreshing, 5-10
regions, 2-5
restoring default table sorting, 4-4
retailer
creating promotion for, 8-6
editing profile, 5-6
effect on optimization, 10-6
evaluating past promotion, 12-5
incremental profit, 10-10
introduction, 2-5
introduction to profiles, 2-8
reference for attributes, 15-21
running workflow to copy default profile, 16-3
setting quotas and funds for, 6-3
right-click menu
and copying data, 4-5
and editing data, 4-2
and opening notes, 4-12
as basic navigation tool, 1-5
in Planning Hierarchy, 5-5
introduction, 3-6
Rtl Prft, 15-15
Rtl Prft O, 15-16
Run App Proc After Batch Engine, 15-34
Run Engine and BLE procedure, 16-3
S
Sale Price, 15-16
Sale Price O, 15-16
sales areas, 2-5
Sales Quota, 15-16, 15-16
Sales Var, 15-16
Q
quota
managing, 6-1
Sales versus Quota, 5-4
Sales versus Quota summary pane, 5-4
Sandbox scenario, 2-7, 15-27
  comparing promotions in, 11-8
scenarios
  comparing promotions in, 11-8
  introduction, 2-7
  reference, 15-27
scheduling workflow instances, 16-4
segment
  and other levels, 15-20
  introduction, 2-3
selection task, marking as done, 5-10
series
  available to user, 16-11
  editing data, 4-1
  for lift decomposition, 11-4
  introduction, 2-2
  making available for specific user, 16-10
  reference information, 15-1
  related to funds, 6-2
  related to volume, 6-3
  selecting, 13-7
  specifying display, 13-21
Shelf Price, 15-16
Shelf Price sd, 15-16
shipment planning, 14-1, 14-3
Shipments, 15-16
simulation
  accepting, 10-4
  defaults, 10-4
  introduction, 1-7
  running, 10-3
  starting Simulation Engine, 10-3
  useful worksheets, 10-2
Slot Auth, 15-16
Slot Bal, 15-16
slotting funds
  introduction, 2-8
  series, 6-2
  viewing balance, 8-3
sorting
  controlling order of series in table, 13-20
  restoring default table sort, 4-4
  series in worksheet editor, 13-8
  sort order in My Tasks, 5-15
  worksheet table, 4-4
special characters (to avoid), 4-2
StartAverage parameter, 15-36
Start Event, 15-16
Start Event O, 15-16
Start Event P, 15-17
starting
  Business Modeler, 16-8
  TPO, 3-1
  workflow instance, 16-4
Start Ship, 15-17
subtabs of worksheet
  Notes/Attachments, 4-12, 4-14
  other worksheet as subtab, 13-25
summary panes
  Actuals versus Plan, 5-4
  Planning Hierarchy, 5-5, 5-6, 5-7, 5-9, 5-9
  Sales versus Quota, 5-4
  Volume Breakdown, 5-4
Sun JRE, 5-2
synchronization
  between views, 13-23
syndicated data, 1-1
task
  configuring My Tasks, 5-14
  creating and sending, 5-10
  marking as done, 5-10
territory
  introduction, 2-5
  managing funds and quotas, 6-3
  tracking volume, 7-2
  viewing fund balances, 8-3
Territory-Retailer level
  maintaining, 15-31
  purpose, 15-20
time resolution, specifying for worksheet, 13-9
Top/Bottom filter, specifying, 13-6
TopCoefficientLevel parameter, 15-36
TPM
  worksheets of, 1-3
TPO
  worksheets of, 1-6
  TPO, logging on, 3-1
triggers, reference information, 15-32
troubleshooting
cannot see new promotion, 3-6
Ttl Evt $, 15-17
Ttl Evt $ O, 15-17
Ttl Evt $ P, 15-17
Ttl Evt $ Rtl, 15-17
Ttl Evt Vol, 15-17
Ttl Evt Vol O, 15-17
Ttl Evt Vol P, 15-17
Ttl Fcst, 15-18
Ttl Fund Auth, 15-18
Ttl Fund Bal, 15-18

U
undo, 4-2
Units, 15-18
units of measure
 introduction, 13-14
 in worksheet, 13-14
Unmatched $, 15-18
Uplift, 15-18
user
 access to series, 16-11
 adding to groups, 16-12
 creating, 16-9
 deleting, 16-13
 filtering data, 16-11
 specifying modules, 16-10

V
Veh cost, 15-18
Veh cost O, 15-18
Vehicle Cost DISPLAY, 15-18
Vehicle Cost F. SHOPPER, 15-18
Vehicle Cost FEATURE, 15-18
Vehicle Cost NATIONAL TV, 15-19
Vehicle Cost TPR, 15-19
Veh Type O, 15-18
Veh Type P, 15-18
view
 adding to worksheet, 13-22
 defining layout, 13-20, 13-20
 deleting from worksheet, 13-23
 enabling or disabling, 13-23
 hiding worksheet levels, 13-21
 renaming, 13-23
 restoring default layout, 13-22

W
Web server, launching workflows when starting, 16-6
Whoxd$ Online, configuring, 5-12
workflow
 email addresses used in, 16-9
 reference information, 15-33
 schema instances
 launching at Web server start, 16-6
 scheduling, 16-4
 starting, 16-3
 stopping, 16-7
Workflow Manager, logging on, 16-3
worksheet
 adding notes, 4-13
 adding to My Worksheets, 5-15
 copying to Excel, 4-6
 data in, 2-2
 deleting, 13-28
 deleting notes, 4-14
 design
 adding a subtab worksheet, 13-25
 aggregating and organizing, 13-11
 basics, 13-4
 caching, 13-5
 exception filter, 13-18
 filtering individual view, 13-26
 index used in, 13-14

synchronization, 13-23
volume
 actual versus plan, 5-4
 breakdown, 2-9, 5-4, 6-3
 breakdown week by week, 7-4
 creating for newly entered promotion, 10-3
 for past and future, 2-9
 series, 6-3
 tracking, 7-1
 used in accruing funds, 2-8, 6-2
 week by week, 7-3
 year on year, 7-2
Volume Base, 15-19
Volume Base Ttl, 15-19
Volume Breakdown summary pane, 5-4
Volume Incr Ttl, 15-19
Volume Tracking worksheet, 7-1, 7-2, 7-5

index-8
selecting series, 13-7
specifying elements to include, 13-24
time criteria, 13-9
tips, 13-29
units of measure, 13-14
views in, 13-20
editing notes, 4-13
exporting to Excel, 4-6
how aggregated and organized, 2-1
layout, 13-20
linking via Dynamic Open Link (DOL), 4-7
notes in, 4-13
ownership and security, 13-28
printing, 4-10
sending as task to another user, 5-10
sorting data, 4-4
specifying note permissions, 4-16
worksheets
genereal introduction, 1-3
Optimization Comparison, 10-8, 10-15
Planning Environment, 8-1, 8-17
Promo Effect - Mfg, 11-2, 11-10
Promo Effect - Rtl, 11-14
Promo-Evaluation Mfg, 12-2, 12-8
Promo-Evaluation Rtl, 12-5, 12-13
Promotion Comparison, 11-8, 11-17
Quota and Fund Entry Bottom-Up, 6-5, 6-9
Quota and Fund Entry Top-Down, 6-3, 6-7
Quota and Fund View, 6-6, 6-10
Volume Tracking, 7-1, 7-5

X
x-axis
and default table sorting, 4-4
specifying, 13-20

Y
y-axis
specifying, 13-20
units and scale, 13-14