|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- introduction to maintenance commands and application programs
This section describes, in alphabetical order, commands that are used chiefly for system maintenance and administration purposes.
Because of command restructuring for the Virtual File System architecture, there are several instances of multiple manual pages that begin with the same name. For example, the mount, pages - mount(1M), mount_cachefs(1M), mount_hsfs(1M), mount_nfs(1M), mount_tmpfs(1M), and mount_ufs(1M). In each such case the first of the multiple pages describes the syntax and options of the generic command, that is, those options applicable to all FSTypes (file system types). The succeeding pages describe the functionality of the FSType-specific modules of the command. These pages list the command followed by an underscore ( _ ) and the FSType to which they pertain. Note that the administrator should not attempt to call these modules directly. The generic command provides a common interface to all of them. Thus the FSType-specific manual pages should not be viewed as describing distinct commands, but rather as detailing those aspects of a command that are specific to a particular FSType.
Unless otherwise noted, commands described in this section accept options and other arguments according to the following syntax:
name [option(s)] [cmdarg(s)]
The name of an executable file.
- noargletter(s) or,
- argletter< >optarg
where < > is optional white space.
A single letter representing an option without an argument.
A single letter representing an option requiring an argument.
Argument (character string) satisfying preceding argletter.
Pathname (or other command argument) not beginning with - or, - by itself indicating the standard input.
See attributes(5) for a discussion of the attributes listed in this section.
Upon termination, each command returns 0 for normal termination and non-zero to indicate troubles such as erroneous parameters, bad or inaccessible data, or other inability to cope with the task at hand. It is called variously ``exit code,'' ``exit status,'' or ``return code,'' and is described only where special conventions are involved.
Unfortunately, not all commands adhere to the standard syntax.