|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 10 1/13 Information Library|
- device operations structure
#include <sys/conf.h> #include <sys/devops.h>
Solaris DDI specific (Solaris DDI).
dev_ops contains driver common fields and pointers to the bus_ops and cb_ops(9S).
Following are the device functions provided in the device operations structure. All fields must be set at compile time.
Driver build version. Set this to DEVO_REV.
Driver reference count. Set this to 0.
Get device driver information (see getinfo(9E)).
This entry point is obsolete. Set to nulldev.
Probe device. See probe(9E).
Attach driver to dev_info. See attach(9E).
Detach/prepare driver to unload. See detach(9E).
Reset device. (Not supported in this release.) Set this to nodev.
Pointer to cb_ops(9S) structure for leaf drivers.
Pointer to bus operations structure for nexus drivers. Set this to NULL if this is for a leaf driver.
Power a device attached to system. See power(9E).
int devo_rev; int devo_refcnt; int (*devo_getinfo)(dev_info_t *dip, ddi_info_cmd_t infocmd, void *arg, void **result); int (*devo_identify)(dev_info_t *dip); int (*devo_probe)(dev_info_t *dip); int (*devo_attach)(dev_info_t *dip, ddi_attach_cmd_t cmd); int (*devo_detach)(dev_info_t *dip, ddi_detach_cmd_t cmd); int (*devo_reset)(dev_info_t *dip, ddi_reset_cmd_t cmd); struct cb_ops *devo_cb_ops; struct bus_ops *devo_bus_ops; int (*devo_power)(dev_info_t *dip, int component, int level);