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Preface

Oracle's StorageTek SL3000 Modular Library System is an enterprise storage solution 
that provides fully automated tape cartridge storage and retrieval. This guide provides 
a general overview of Oracle's StorageTek SL3000 modular tape library and covers 
installation planning, configuration, and operation of the library.

Related Documentation
Additional SL3000 library documentation can be found at: 
https://docs.oracle.com/en/storage/tape-storage/index.html

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support 
through My Oracle Support. For information, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

IMPORTANT: Starting with FRS_4.51, the content of this document 
has been frozen. All subsequent product updates are documented 
within the SL3000 Release Notes. Refer to that document for the latest 
changes and product information.
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1Library Overview

■ Library Modules

■ Hardware Components

■ Power Configurations

■ Cooling

■ Storage Capacity

■ Host Connectivity

■ Library Monitoring

■ Media Validation

■ Library Management Software

■ Ordering

Library Modules
■ Base Module — one required per library.

■ Drive Expansion Module (DEM) — maximum of one on the left side of a Base 
module only.

■ Cartridge Expansion Module (CEM) — maximum of eight with four on the left 
side of the library and four on the right side.

■ Access Expansion Module (AEM) — maximum of two with one on each end of 
the library. An AEM cannot be installed directly to the left of the Base module.

■ Parking Expansion Module (PEM) — an alternative to an AEM for redundant 
electronics support. PEMs must be installed as a pair, with one on each end of the 
library. A PEM is a converted CEM.
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Figure 1–1 SL3000 Library Configuration Example

Figure Legend:

1. Perforated window

2. Operator panel

3. Service door

4. CAP (open)

Base Module
One Base module is required in every library. A standalone Base module is the 
smallest possible configuration of an SL3000 library. 

Base Module Configuration Options
■ 205 to 431 cartridge capacity (see "Calculating Physical Capacity" on page 1-17).

■ 8 (standard), 16, or 24 drive slots.

■ Perforated window (standard), window storage array, or operator panel.

■ CAP (standard). See "Rotational Cartridge Access Port (CAP)" on page 1-7.

Base Module Components
The front of the Base module contains a single CAP, service door, front panel with 
LEDs, and a perforated window, optional operator panel, or window storage array. 
The rear of the Base module contains the electronics module, power distribution units 
(PDUs), DC power supplies, tape drives, and two 1-unit rack spaces.
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Figure 1–2 Base Module Rear View

Figure Legend:

1. Tape drives

2. Electronics module

3. Drive DC power supplies

4. Ethernet switches (optional)

5. Power distribution units

Drive Expansion Module (DEM)
The DEM is attached to the left side of the Base module (when viewed from the front 
of the library). The DEM expands the number of tape drives and provides additional 
cartridge storage. There can be only one DEM per library.

DEM Configuration Options
■ 153 to 522 cartridge capacity (see "Calculating Physical Capacity" on page 1-17).

■ 8 (standard), 16, 24, or 32 drive slots.

■ Perforated window (standard), window storage array, or operator panel.

■ CAP (optional), See "Rotational Cartridge Access Port (CAP)" on page 1-7.

DEM Components
The front of the DEM contains a service door, optional CAP, and a perforated window 
or optional operator panel (if not already in the Base module) or window storage 
array. The rear of the DEM contains tape drives, PDUs, DC power supplies, and two 
1-unit rack spaces.



Library Modules

1-4 StorageTek SL3000 Library Guide

Figure 1–3 DEM Rear View

Figure Legend:

1. Tape drives

2. Drive DC power supplies

3. Ethernet switches (optional)

4. Power distribution unit

Cartridge Expansion Module (CEM)
The CEM provides additional cartridge storage. There are no tape drives present 
within this module. CEMs on the end of the library can be converted to PEMs (see 
"Parking Expansion Module (PEM)" on page 1-5). A maximum of eight CEMs are 
supported in a single library. The initial CEM should be installed to the right of a Base 
module, then a second to the left of the DEM/Base module, a third to the right, and 
the fourth one to the left, and so on. This alternating method maximizes library 
performance.

CEM Configuration Options
■ 438 to 620 cartridge capacity (see "Calculating Physical Capacity" on page 1-17).

■ CAP (optional). See "Rotational Cartridge Access Port (CAP)" on page 1-7.

■ Placement to the left or right of a Base module and DEM

■ A maximum of four CEMs on each side of centerline (eight total)

Access Expansion Module (AEM)
An AEM has a large cartridge access door used for bulk loading and unloading of up 
to 234 cartridges. Additionally, a library with two AEMs supports the redundant 



Library Modules

Library Overview 1-5

robotics feature (see "Robotics" on page 1-7). A sliding safety door sections off a 
defective robot, allowing a service representative to access the disabled robot while the 
library remains online.

AEM Configuration Options
■ Must be placed on the ends of the library. An AEM cannot be installed directly to 

the left of the Base module; there must be a module in between.

■ A single AEM supports bulk load capabilities only. You should install a single 
AEM on the left for an additional 104 storage slots (see "Calculating Physical 
Capacity" on page 1-17).

■ Dual AEMs support bulk load and redundant robotics support.

Parking Expansion Module (PEM)
The PEM is a converted CEM used to "park" a defective robot without blocking access 
for the operational robot in a redundant robotics configuration (see "Robotics" on 
page 1-7). Performing maintenance on a disabled robot in a PEM is disruptive to 
library operations. 

The parking space causes six columns of cartridge arrays in the PEM to become 
inaccessible (three on the front wall and three on the rear wall). You do not need to 
remove the inaccessible arrays. The module can be restored to a CEM at anytime. 

PEM Configuration Options
■ 230 to 312 cartridge capacity (see "Calculating Physical Capacity" on page 1-17).

■ Only the left PEM can have an optional CAP.

■ Must be installed on each end of the library.

Figure 1–4 PEMs attached to a Base Module

Figure Legend:

Note: AEMs and PEMs cannot be installed in the same library.
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1. Inaccessible CAP area

2. Robot parking area (inaccessible cartridge slots)

Hardware Components
■ Electronics Control Module

■ Robotics

■ Rotational Cartridge Access Port (CAP)

■ Bulk Load Cartridge Access Ports (AEM)

Electronics Control Module
The electronics control module (ECM) is responsible for electronics control, robot and 
drive control, and host connectivity. The ECM is located in the rear of the Base module 
(see Figure 1–2). The main controller cards are the HBCR (library controller) and HBT 
(drive controller).

Figure 1–5 Electronics Control Module

Figure Legend:

1. Serial port (reserved)

2. Serial port (CSE port for CLI)

3. Primary Ethernet port

4. Dual TCP/IP Ethernet port

5. Ethernet port (reserved)

Command Line Interface
The command line interface (CLI) can be used by Oracle support to configure and 
diagnose the library. Service representatives can access the CLI through the electronic 
control module using either of the following:

■ Serial Port Connection on the HBCR card (RS-232) and a HyperTerminal 
connection to enter the commands

■ Ethernet Port Connection (ports 1A, 2A, or 2B) on the HBCR card and a secure 
shell (PuTTY) to enter the commands

Note: The ECM ships with an optional MPU2 card (2Gb) or PUA2 
card (8 Gb) for Fibre Channel interface connections. This card is not 
shown in the figure but is installed below the HBCR card.
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Redundant Electronics
The optional redundant electronics (RE) feature is available for failover protection for 
the HBCR controller card. With the RE feature, each library has two HBCR controller 
cards. If the active library controller experiences errors, operations switch 
automatically to the stand-by library controller, with minimal disruption to library and 
host operations.

RE is not available for libraries that use the direct FC-SCSI connection to hosts.

For more information, see "Redundant Electronics Overview" on page B-1.

Robotics
Each library can have either one (standard) or two robots (known as redundant 
robotics). Robots retrieve and insert cartridges into CAPs or slots and mount or 
dismount cartridges from tape drives.

Robots move along two rails on the rear wall of the library. One rail is at the top of the 
library and one rail attaches to the floor. Two copper strips in the top rail provide 
power and a signal path between the robot and library controller (HBCR) card. Power 
is supplied from +48 VDC 1200 W load-sharing supplies (see "Power Configurations" 
on page 1-9). 

Robots contain a barcode scanner that reads the configuration blocks in each module 
during library initialization and identifies volume serial numbers (VOLSERs) of 
cartridges during CAP entries and audits.

Redundant Robotics
The optional redundant robotics feature increases the speed for robotic operations and 
allows library operations to continue if one robot fails. Redundant robotics requires 
240 VAC, 2N power, and either two PEMs or two AEMs.

Rotational Cartridge Access Port (CAP)
A CAP is a vertically-mounted, rotating cylinder with two removable 13-slot 
magazines.

■ The Base module comes standard with a CAP.

■ The DEM and CEMs can have one optional CAP per module. Only the left PEM 
can contain a CAP.

■ There can be a maximum of 10 rotational CAPs per library. 

■ Each CAP has a keypad with an unlock indicator and a button to open the CAP.
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Figure 1–6 Library CAPs

Figure Legend:

1. CAP (closed)

2. No CAP installed

3. CAP (open)

4. Keypad

Bulk Load Cartridge Access Ports (AEM) 
An AEM allow you to enter and eject up to 234 cartridges without disrupting library 
operations. Only one AEM is required in a library to support the bulk loading feature 
(see "Access Expansion Module (AEM)" on page 1-4).

Supported Tape Drives
■ StorageTek T-Series (T9840C and D) 

■ StorageTek T-Series (T10000A, B, C, and D) 

■ HP LTO generations 3, 4, 5, and 6

■ IBM LTO generations 3, 4, 5, 6, 7, and 8

Note: LTO-8 drives can read and write one generation back. LTO-5, 
6, and 7 drives can read two generations back and write one 
generation back. For best capacity and performance, always use 
cartridges of the same generation as your drives.

Note: Tape drives must support the dynamic World Wide Name 
feature to be placed online by the SL3000 library.
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Most drives are capable of reading the data recorded by an earlier generation tape 
drive from the same family. Therefore, you can use existing cartridges if they are 
within their warranty period.

For more information, refer to the tape drive section on the Oracle website: 
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/ove
rview/index.html

Encryption Capable Tape Drives
■ StorageTek T10000 A, B, C, D

■ StorageTek T9840 D

■ HP LTO generations 4, 5, 6

■ IBM LTO generations 4, 5, 6, 7

For more information, see "Tape Drive Encryption" on page 1-26.

Power Configurations
The power configuration depends on the power source and redundancy.

AC Power Source Options
Each PDU installed in the library requires a separate AC power source. There can be a 
maximum of four PDUs in the library depending on the configuration selected (two in 
the Base module and two in the DEM). There are two AC power source options. Both 
are single phase:

■ 120 VAC, 50/60 Hz, at 20 amps (range: 100–127 VAC, 47–63 Hz, 16 amps)

– Limited support for T9840 and T10000 drives; no redundant robotics support

■ 240 VAC, 50/60 Hz, at 30 amps (range: 200–240 VAC, 47–63 Hz, 24 amps)

– Supports all drive types and redundant robotics

Power Redundancy Options
There are three power configurations that offer various levels of power redundancy.

N+1 power configuration (standard) 
■ Offers DC power redundancy only

■ Consists of one PDU (per Base module or DEM), with one extra drive DC supply 
and one extra robotics DC supply

■ Provides N+1 DC power supply redundancy

■ Limited support for T9840 and T10000 drives and no redundant robotics support

2N power configuration
■ Offers both AC and DC power redundancy

■ Consists of two PDUs (per Base module or DEM) for AC redundancy, with a set of 
DC power supplies for each PDU

■ Provides N DC power supplies per PDU

■ Requires two separate AC input sources per Base module or DEM

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
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■ Required for redundant robotics and redundant electronics support

2N+1 power configuration
■ Offers both AC and DC power redundancy with additional DC redundancy

■ Consists of two PDUs (per Base module or DEM) for AC redundancy, with 
additional DC power supplies for each PDU

■ Provides N+1 DC power redundancy for each PDU (except the second PDU only 
has N DC power supply redundancy for the robot)

■ Requires two separate AC input sources per Base module or DEM

■ Supports redundant robotics and redundant electronics

DC Power Supplies
There are two types of DC power supplies:

■ Load sharing 1200W DC — used for the robotics unit and tape drives

■ 200W cPCI — used for the electronics control module

Figure 1–7 Power Supply Locations - Base and DEM (Rear View)

Figure Legend:

1. Robotics DC power supplies (1200W DC)

2. Electronics module DC power supplies (200W cPCI)

3. Tape drive DC power supplies (1200W DC)

4. Power distribution unit (120 VAC or 240 VAC)
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Electronics Control Module Power Supplies
The electronics control module (ECM) uses 200 W cPCI power supplies. These power 
supplies are located below the HBT card in the Base module (there are no ECM power 
supplies in the DEM) — see Figure 1–7. The power supply for the electronics control 
module is different from the power supplies used for the robotics unit and the tape 
drives. 

Each Base module ships standard with two ECM power supplies used for N+1 and 2N 
configurations. Order two additional ECM supplies for the 2N+1 configuration (see 
"DC Power Supplies" on page 1-28).

Robotics Unit Power Supplies
The robotics unit uses load-sharing 1200 W DC power supplies located at the top of 
the Base module (the DEM does not contain robotics DC supplies) — see Figure 1–7. 
The 1200 W DC power supply used for the robotics unit is the same power supply 
used for the tape drives. 

Each Base module ships standard with two robotics DC power supplies used for N+1 
and 2N configurations. Order a third DC power supply for the 2N+1 configuration 
(see "DC Power Supplies" on page 1-28). 

Tape Drive Power Supplies
The tape drives use load-sharing 1200 W DC power supplies. Up to four tape drive 
power supplies are located to the left of each PDU in both the Base module and the 
DEM — see Figure 1–7. 

The library ships with two tape drive DC power supplies per Base module and two 
tape drive DC power supplies per DEM. The number of tape drive DC power supplies 
required depends on the power configuration selected and the number and type of 
tape drives in the library. To calculate the number of power supplies to order, see 
"Calculating Tape Drive Power Supply Quantities" below.

Calculating Tape Drive Power Supply Quantities
The number of power supplies required depends on:

■ Power configuration (120 VAC or 240 VAC with N+1, 2N, or 2N+1)

■ Number and type of tape drive (T10000, T9840, or LTO) 

To determine the number of power supplies required for a library configuration:

1. Determine the total number of each drive type.

2. Multiply by the watts-per-drive for each drive type, see Table 1–1, " Watts Per 
Drive".

3. Add together the watts used by each drive type to calculate the total watts 
consumed.

4. Use Table 1–2 through Table 1–5 to determine the number of DC power supplies 
needed.

For ordering part numbers, see "DC Power Supplies" on page 1-28.
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Watt Consumption Per Drive

Power Supplies Required for 120 VAC PDUs
To use 120 VAC PDUs, the total watts used by the drives must be less than 843 W in 
the Base module and less than 1,481 W in the DEM. If the total watts exceeds 843 W in 
the Base module or 1,481 W in the DEM, 240 VAC PDUs are required. You cannot mix 
120 VAC with 240 VAC PDUs within the library. All PDUs must be the same type.

Power Supplies Required for 240 VAC PDUs
If the total watts used by the drives exceeds 843 W in the Base module or 1,481 W in 
the DEM, 240 VAC PDUs are required. You cannot mix 120 VAC with 240 VAC PDUs 
within the library. All PDUs must be the same type.

Table 1–1 Watts Per Drive

Drive Type
Maximum Watts 
Used by Each Drive

T9840D 100

T10000A/B/C 93

T10000D 127

LTO 46

Table 1–2  DC Power Supplies for Base (120 VAC PDU)

Total Watts Used 
by All Drives

Power Supplies 
Required for N+1

Power Supplies 
Required for 2N

Power Supplies 
Required for 2N+1

1 - 563 2 2 4

564-843 3 4 6

Table 1–3  DC Power Supplies for DEM (120 VAC PDU)

Total Watts Used 
by All Drives

Power Supplies 
Required for N+1

Power Supplies 
Required for 2N

Power Supplies 
Required for 2N+1

1 - 700 2 2 4

701 - 1,400 3 4 6

1,401-1,481 4 6 8

Table 1–4  DC Power Supplies for Base (240 VAC PDU)

Total Watts Used 
by All Drives

Power Supplies 
Required for N+1

Power Supplies 
Required for 2N

Power Supplies 
Required for 2N+1

1 - 1,063 2 2 4

1,064 - 2,263 3 4 6

2,264 - 3,463 4 6 8

3,464 - 3,805 5 8 8
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Example: Calculating Required Number of Drive DC Power Supplies
The example library has a Base module and a DEM with all three drive types (T10000, 
T9840, LTO). Table 1–6 and Table 1–7 show how to calculate the total watts used by the 
tape drives in the Base module and DEM:

The drives in the Base module use 1,546 W. In Table 1–2, 1,546 W exceeds the 
maximum 843 W supported by a 120 VAC PDU. Therefore, the Base module requires a 
240 VAC PDU to support the drive configuration — refer to Table 1–4.

The drives in the DEM use 756 W. In Table 1–3 and Table 1–5, either a 120 VAC or 240 
VAC PDU can support 756 W. However, you cannot mix 120 VAC with 240 VAC PDUs 
within the library. Therefore, the example library requires 240 VAC PDUs.

Two tape drive DC power supplies ship standard with the Base module and two 
power supplies ship standard with the DEM. Therefore, subtract two from the DC 
supplies required. Use Table 1–4 and Table 1–5 to determine what to order.

The tables below list the power supplies required for the example library.

Table 1–5  DC Power Supplies for DEM (240 VAC PDU)

Total Watts Used 
by All Drives

Power Supplies 
Required for N+1

Power Supplies 
Required for 2N

Power Supplies 
Required for 2N+1

1 - 1,200 2 2 4

1,201 - 2,400 3 4 6

2,401 - 3,600 4 6 8

3,601 - 4,443 5 8 8

Table 1–6 Base Module Tape Drive Watts Consumption Example

Drive Type Quantity of Drives
Multiply by Watts 
Per Drive

Total Watts Per 
Drive Type

T10000D 6 127 762

T9840D 6 100 600

LTO7 4 46 184

Table 1–7 DEM Tape Drive Watts Consumption Example

Drive Type Quantity of Drives
Multiply by Watts 
Per Drive

Total Watts Per 
Drive Type

T10000C 4 93 372

T9840D 2 100 200

LTO5 4 46 184

Table 1–8 DC Supplies Required for Base Example

Configuration Option
DC Supplies 
Required

DC Supplies to Order 
(= Required - 2)

N+1 (240 VAC PDU) 3 1

2N (240 VAC PDU) 4 2

2N+1 (240 VAC PDU) 6 4
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The number of drive DC supplies that must be ordered depends on the power 
configuration selected. For instance, if the example library had a 2N+1 configuration, it 
would require an order of six additional drive DC power supplies (four supplies for 
the Base module and two supplies for the DEM). The 2N+1 also requires an additional 
DC supply for the robotics and an additional ECM 200W cPCI power supply. The ECM 
power supply is different than the tape drive and robot power supplies listed in this 
example. For ordering information, see "DC Power Supplies" on page 1-28.

AC Power Cables
The following table lists the cables required for each power configuration. You must 
order one power cord per PDU installed:

■ N+1 — order one power cord for the Base module and an additional power cord 
for the DEM (if installed)

■ 2N or 2N+1 — two power cords for the Base module and two additional power 
cords for the DEM (if installed)

Power Consumption
For environmental or economical reasons, you might want to determine the total 
power consumption (watts), CO2 emission values, and British Thermal Units (Btu/hr) 
for the SL3000 library and tape drives. The table below provides power consumption 
in watts.

Table 1–9 DC Supplies Required for Drive Expansion Module - Example

Configuration Option
DC Supplies 
Required

DC Supplies to Order 
(= Required - 2)

N+1 (240VAC PDU) 2 0

2N (240VAC PDU) 2 0

2N+1 (240VAC PDU) 4 2

Table 1–10 Power Cable Descriptions

Power Source Description
Circuit 
Breaker

Wall 
Connector

Library 
Connector

Power Cord

Length/Type

120 VAC/20A US/Japan 20A L5-20P L5-20R 3.7 m (12 ft) 12 AWG

240 VAC/30A US 30A L6-30P L6-30R 3.7 m (12 ft) 12 AWG

240 VAC/30A International 30A 330P6W L6-30R 4 m (13 ft) HAR

Table 1–11 Power Consumption Values

Components Quantity Idle Watts Max Watts

Base Library (required)

Includes: 1 ECM, 1 robot, and 1 CAP

1 156 197

Redundant Electronics (optional) 1 100 100

Redundant Robotics (optional) 1 28 55

Operator Panel (optional) 1 29 37

Additional CAPs (optional) Each 10 14

Access Expansion Module (optional) Each 8 30
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Calculating Total Watts, CO2 Emissions, and Btu/hr
To calculate the total power consumption in Watts for the library, add up all the 
applicable wattage values for the library configuration from Table 1–11.

To calculate kilograms of CO2 emissions per day, multiply watts by the CO2 emissions 
constant. Use the constant that is applicable for your country (0.02497 for US).

To convert electrical values to Btu/hr, multiply the number of watts by 3.412 (1 W 
=3.412 Btu/hr). Many manufacturers publish kW, kVA, and Btus for their equipment. 
Use the information provided by the manufacturer. Otherwise, use the formula below.

■ 3.41214 x Watts =Btu/hr

Power Consumption Example 1  

Using the maximum continuous values for the following components:

■ Emissions: 933W x 0.02497 = 23.3 Kg of CO2

■ Power consumption: 933W x 3.412 = 3,183 Btu/hr

Power Consumption Example 2  

Using the maximum continuous values for the following components:

■ Emissions: 1,771W x 0.02497 = 44.2 Kg of CO2

T9840 Each 79 100

T10000A/B/C Each 61 93

T10000D Each 64 127

LTO Each 30 46

Table 1–12 Power Consumption Example

Quantity Component Description Watts

1 SL3000 Base (including one ECM, one robot, one CAP) 197

16 LTO7 Tape Drives 736

-- Total 933

Table 1–13 Power Consumption Example

Quantity Component Description Watts

1 SL3000 Base (including one ECM, one robot, one CAP) 197

8 T9840D Tape Drives 800

1 Drive Expansion Module --

8 T10000C Tape Drives 744

1 Cartridge Expansion Module --

3 CAPs (3 at 10 Watts each) 30

-- Total 1,771

Table 1–11 (Cont.) Power Consumption Values

Components Quantity Idle Watts Max Watts
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■ Power consumption: 1,771W x 3.412 = 6,043 Btu/hr

Cooling
Cooling within the SL3000 library is divided into three areas:

■ Electronics control module

■ Tape drives

■ DC power supplies

Library Electronics Control Module
Two fans, located to the right of the electronics control module, provide cooling for the 
electronics in the library. Air is drawn from the sides of the library and flows through 
the fans to the rear of the library. 

■ The library controller card (HBCR) monitors these fans for proper operation.

■ The amber Fault indicator on the fan assembly indicates a failure.

While there are two dedicated fans, one fan is sufficient to provide adequate cooling 
for the library and the electronics. The fans can be replaced without interfering with 
library operations. Replace a defective fan when it is detected.

Tape Drives
Each tape drive tray contains a fan for drive cooling. The tape drive's power converter 
card supplies power for the fans. Air is drawn from the front of the drive and flows 
through the fan to the rear of the drive/library.

DC Power Supplies
Each 1200 Watt DC power supply contains a fan that pulls air from the library, through 
the rear of the supply, and out the rear of the library. 

Storage Capacity
There are two types of capacity:

■ Physical Capacity — the number of cartridge slots in the library, excluding 
reserved slots. Physical storage capacity can range from 205 to 5,925 data cartridge 
slots and 1 to 56 tape drives.

■ Active Capacity — the number of slots in the library activated by a hardware 
activation file. Only activated slots can be used for data storage and accessed by a 
client. Inactivated slots are not recognized by the library.

A diagram of the slot locations within each module can be helpful for understanding 
capacity (for wall maps, see "Library Addressing Reference" on page E-1).

Note: Oracle recommends adding physical capacity in advance to 
meet future storage needs. Although modules can be added to an 
SL3000 library at any time, adding a module is disruptive to library 
operations.
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Calculating Physical Capacity
Use the table below to calculate the physical capacity of a library configuration. For 
each module in the library, start with the standard slot count. Then, either add or 
subtract slots based on the module’s position and add-on options. Finally, add the slot 
counts of each module together to get the total capacity of the library.

Calculation Example 1: Base, DEM, CEMs, PEMs
The example library has a Base module, a DEM, two CEMs (one on each side of 
centerline), and two PEMs (one on each end of the library).

Base module
Contains an op panel and three drive arrays. There are modules to the right and left.

320 (standard) + 0 (op panel) + 13 (right module) + 88 (left module) – 
66 (2nd drive array) – 72 (3rd drive array) = 283 

DEM
Contains a window array, a CAP, and four drive arrays. There is a module to the left.

410 (standard) + 88 (left module) + 23 (window array) – 77 (CAP) 
– 66 (2nd drive array) – 72 (3rd drive array) – 78 (4th drive array) = 228 

Left CEM
The module is installed left of centerline. There is a module to the left.

516 (standard) + 104 (left module) = 620

Right CEM
Contains a CAP. The module is installed right of centerline with a module to the right.

620 (standard) – 78 (CAP) = 542

PEMs
There are two PEMs, one on each end of the library. The left PEM contains a CAP.

313 (standard right PEM) + 308 (standard left PEM) - 78 (CAP) = 542 

Library Total
283 (Base) + 228 (DEM) + 620 (left CEM) + 542 (right CEM) + 542 (PEMs) = 2,215

Table 1–14 Physical Slot Capacity Per Module

Physical Configuration
Left 
AEM

Left 
PEM

Left 
CEM DEM Base

Right 
CEM

Right 
PEM

Right 
AEM

Standard 0 308 516 410 320 620 312 0

2nd Drive Array1

1 For additional drive arrays, the first number listed is the change in capacity when there is no module to 
the left, and the second number is the change in capacity when there is a module to the left.

-- -- -- -55/-66 -55/-66 -- -- --

3rd Drive Array1 -- -- -- -60/-72 -60/-72 -- -- --

4th Drive Array1 -- -- -- -65/-78 -- -- -- --

Module to Left -- -- +104 +88 +88 0 0 0

Module to Right 0 0 0 0 +13 0 -- --

CAP --  -78 -78 -77 Std. -78 -- --

Window Storage Array -- -- -- +23 +23 -- -- --
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Calculation Example 2: Base and CEM
The example library has a Base module and a CEM to the right of centerline.

Base module
Contains a window array and three drive arrays. There is a module to the right.

320 (standard) + 13 (right module) + 23 (window array) – 55 (2nd drive array) 
– 60 (3rd drive array) = 241 

Right CEM
Contains a CAP. The module is installed right of centerline with a module to the left.

516 (standard) + 104 (left module) – 78 (CAP) = 542

Library Total
241 (Base) + 542 (right CEM) = 783

Calculation Example 3: Base, DEM, CEMs, AEM
The example library has a Base module, DEM, two CEMs (one on each side of 
centerline), and a single AEM on the right for bulk loading. Oracle does not 
recommend installing a single AEM on the right. If the AEM was installed on the left 
end of the library, 104 additional cartridge slots would be accessible in the far left 
CEM.

Base module
Contains window array and two drive arrays. There are modules to the right and left. 

320 (standard) + 23 (window array) + 13 (right module) + 88 (left module) 
– 66 (2nd drive array) = 378

DEM
Contains an op panel and three drive arrays. There is a module to the left.

410 (standard) + 88 (left module) + 0 (op panel) – 66 (2nd drive array) 
– 72 (3rd drive array) = 360

Left CEM
Module is installed left of centerline with no module to the left.

516 (standard) = 516

Right CEM
Module is installed right of centerline with modules to the right and left.

516 (standard) + 104 (left module) = 620

AEM
Module is installed right of centerline (not recommended for single AEM).

0 (standard) = 0 

Library Total
378 (Base) + 360 (DEM) + 516 (left CEM) + 620 (right CEM) + 0 (AEM) = 1,874

Host Connectivity
The SL3000 library supports two types of host connections:

■ Small computer system interface over a physical Fibre Channel interface (FC-SCSI)
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■ Ethernet using 10/100 Base-T and CAT-5 cable (TCP/IP)

In a non-partitioned configuration, the library can use only one interface type, either 
FC-SCSI or TCP/IP. In a partitioned configuration, the library can have one interface 
type per partition. The SL3000 does not support DHCP.

FC-SCSI Connection
The SL3000 comes standard with a PUA2 Fibre Channel card, which provides an 8GB 
interface and contains two ports. You can use the ports for two independent 
connections to applications. Or, if the your application supports two ports for failover, 
you can use the ports for failover protection.

The SL3000 SCSI Reference Guide contains information about the SCSI command set, FC 
operations, command implementations, topologies, cables, and connectors.

Supported Topologies
■ Switched Fabric — Oracle recommends this topology. It provides dynamic 

interconnections between nodes and multiple, simultaneous FC connections. If the 
library is connected to a FC switch or fabric-capable host, it configures itself as a 
switched topology and can support up to 16 million ports logged into the fabric.

■ Arbitrated Loop — While the library supports the arbitrated loop topology, Oracle 
does not recommend it. This topology provides multiple connections for devices 
that share a single loop and allows only point-to-point connections between an 
initiator and target during communications. An arbitrated loop can connect only 
up to 126 ports.

TCP/IP Connection
The TCP/IP connection provides the host library interface (HLI) used to communicate 
with library management applications, such as:

■ Open system platforms with ACSLS

■ Enterprise-level mainframes with ELS /HSC

The library controller card is responsible for coordinating all component operations 
within the library and providing the interface connection with the host. There are two 
separate Ethernet connections for host to library communications — Ports 2A and 2B.

■ Port 2B provides the primary host connection (standard).

■ Port 2A provides the dual TCP/IP connection (optional) or can be connected to 
StorageTek Library Console (SLC).

The dual TCP/IP feature uses both ports to provide two connections between the 
library and ACSLS or ELS/HSC hosts, eliminating a single point of failure. For more 
information, refer to "Dual TCP/IP Overview" on page C-1.

Port Bonding
Port bonding combines multiple ports to create redundancy. The SL3000 library uses 
an active-backup mode. In active-backup mode, there is one bond with two slave 
Ethernet interfaces. If the active interface fails, the backup interface becomes active. 
With minimum library firmware FRS_4.30 and a second Ethernet switch installed in 
the library, port bonding is automatically enabled — no command or activation file is 
required.
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Library Monitoring
The library can be monitored using SLC or Simple Network Management Protocol 
(SNMP). Additionally, service representatives can use the Log SnapShot feature to 
collect logs from the controller cards.

StorageTek Library Console (SLC)
SLC is a GUI application for configuring, monitoring, and managing the SL3000 
library. SLC is included with the purchase of an SL3000 library. You can access SLC 
from the local operator panel, a workstation, or through a browser. For installation 
requirements and additional information, refer to "Installing StorageTek Library 
Console" on page 3-1.

Simple Network Management Protocol
The SL3000 library supports SNMP v2c and SNMP v3 (preferred). For more 
information, refer to the SNMP Reference Guide.

Log SnapShot Feature
Log SnapShot gathers, compresses, and encrypts library logs. You can use the CLI or 
SLC to generate a log snapshot and send it to an Oracle representative to assist with 
troubleshooting.

Media Validation
The SL3000 library supports media validation, which allows you to verify the integrity 
of T10000 cartridges using SLC or StorageTek Tape Analytics (STA). The following 
validation methods are available: Basic Verify, Standard Verify, and Complete Verify. 

For more information about media validation using SLC, refer to "Validating a 
Cartridge" on page 12-1. For more information about media validation using STA, 
refer to the STA documentation on OTN.

Library Management Software
Library management software controls the library by allocating drives and requesting 
library operations, such as entering, mounting, dismounting, and ejecting cartridges. 
Library management software manages the library database, which tracks volume 
identifiers (vol-ids), attributes, and locations of cartridges.

There are two main library management options:

■ Automated Cartridge System Library Software (ACSLS)

■ Enterprise Library Software

Automated Cartridge System Library Software (ACSLS)
ACSLS is a centralized, multi-platform library management software product for an 
open-systems environment. ACSLS manages all library operations and shares library 
resources with any ACSLS-enabled application. A single instance of ACSLS can 
manage multiple libraries. The key benefits of ACSLS include:

■ Centralized library control across multiple StorageTek libraries, including legacy 
technology
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■ Optimized library performance by load-balancing hardware and executing 
parallel commands

■ Reduced downtime through dynamic configuration capabilities and queuing 
commands during short-term library outages

■ Enriched reporting and management capabilities for ease of use

ACSLS version 7.3 or greater is required for interfacing with the SL3000 library. ACSLS 
7.3 requires PUT 0801 for AEM support.

Enterprise Library Software
Enterprise Library Software (ELS) incorporates multiple software products to monitor 
and manage tape libraries and virtual solutions for a mainframe environment.

Host Software Component (HSC) and Storage Management Component (SMC)
HSC manages volume pools and communication with the SL3000 library. HSC resides 
on the host, but is transparent to the operating system. A separate component, SMC, 
provides the interface between z/OS operating systems and HSC. SMC resides on all 
MVS hosts that perform tape processing with HSC. HSC and SMC work together to 
influence allocations and determine policies, volume locations, and drive ownership. 
HSC and SMC translate user requests into library commands and provide message 
handling.

Virtual Tape Control System (VTCS)
VTCS is host software that enables centralized management of StorageTek virtual tape 
libraries, such as Virtual Storage Manager (VSM) and Virtual Library Extension (VLE). 
VTCS manages virtual tape volumes and drives, which includes the migration and 
recall of virtual volumes and the use of real tape cartridges and drives.

Concurrent Disaster Recovery Test (CDRT)
CDRT enables disaster recovery testing while the library or virtual storage is in use.

Independent Software Vendors (ISVs)
There are a variety of ISVs that support the SL3000 library. Most ISV applications 
connect through ACSLS or direct-attach. Some applications include:

■ BakBone NetVault

■ CA ArcServe

■ HP Data Protector

■ Legato NetWorker

■ SAM FS

■ Tivoli Storage Manager

■ Veritas BackupExec

■ Veritas Netbackup

Not every application is tested on every platform or version. To make sure the 
software is supported, contact an Oracle sales representative or application vendor.



Library Management Software

1-22 StorageTek SL3000 Library Guide

Other Storage System Solutions
The following Oracle products are compatible with the SL3000 library to provide a 
multifaceted storage solution. This list is not all-inclusive. For more information, 
contact an Oracle sales representative or visit:

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/ove
rview/index.html

Client System Component (CSC)
The client system component (MVS/CSC) allows SMC on MVS to use ACSLS as its 
library server. One CSC is Library Station, which allows an open systems client to use 
HSC on MVS as its library server.

Expert Performance Reporter
Expert Performance Reporter (ExPR) software collects performance data and generates 
reports about status and performance. It provides information on manual tape systems 
as well as Nearline and VSM tape systems. ExPR has both an MVS component and a 
PC component.

Extended High Performance Data Mover
Extended High Performance Data Mover (ExHPDM) is utility software that performs 
high-speed backup and restore of data sets by interleaving very large block sizes on 
high-speed, high-capacity tape devices. ExHPDM achieves its speed by treating all 
data equally regardless of the type. Its only function is to move data from disk to tape 
and back again.

The ExHPDM software moves blocks of data in parallel from several concurrently 
executing MVS application programs. The data from the application programs is 
buffered into 256 KB tape block sizes in the application program's address space, and 
the 256 KB blocks are interleaved onto single or multiple tape volumes.

Library Content Manager (LCM)
Library Content Manager (LCM) — formerly Expert Library Manager (ExLM) — 
manages Nearline and VSM resources. LCM optimizes overall performance by 
assuring there are adequate resources available for a scheduled job. LCM also includes 
LCM Explorer, a graphical user interface that allows a user to configure LCM by 
creating configuration files instead of parameter files.

Linear Tape File System (LTFS)
LTFS software improves file access and portability of data on StorageTek T10000 or 
LTO media. LTFS software enables applications to write and retrieve files directly from 
tape through standard file format interfaces: CIFS or POSIX. Files may also be accessed 
with ease through a browser or operating system graphical interface. You can drag and 
drop files to and from any storage medium: disk, tape, or flash.

Oracle’s Linear Tape File System, Library Edition (LTFS-LE) software supports the 
SL3000 tape library, managing multiple tape drives and media. When you select a file, 
the library automatically mounts the corresponding tape and the file is made available 
to that application.

StorageTek Tape Analytics
Oracle's StorageTek Tape Analytics (STA) is an intelligent monitoring application 
available for StorageTek Modular Tape Libraries. It simplifies tape storage 

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
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management so you can make informed decisions about future tape storage 
investments based on the current health of the tape storage environment.

STA can monitor multiple libraries from a single, browser-based user interface. STA 
supports open systems and mainframe, mixed-media, and mixed-drive environments 
across multiple library platforms. Using STA, you can increase the utilization and 
performance of tape investments by performing detailed performance trending 
analyses. These analyses are based on a regularly updated database of library 
operations.

Virtual Storage Manager (VSM)
VSM stores virtual tape volumes on a disk buffer called the Virtual Tape Storage 
Subsystem (VTSS). VSM then migrates the virtual tape volumes to tape media 
mounted on real tape drives in the library. This optimizes access time and throughput 
of data to physical tape media. The primary host software for VSM is the Virtual Tape 
Control System (VTCS). VTCS manages virtual tape volumes and drives, which 
includes the migration and recall of virtual volumes and the use of real tape cartridges 
and drives.

Virtual Library Extension (VLE)  Virtual Library Extension (VLE) can be added to a VSM 
for additional capacity. VLE provides an economical second tier of disk storage that 
can be used to boost the overall VSM storage capacity or use VSM as a tapeless virtual 
library.

Ordering
Contact Sales Assistance at +1.888.672.2534. 

The tables in this chapter provide the part numbers for library components and 
upgrade options. The ATO number is for initial orders and the PTO is for upgrade 
orders after the initial purchase of an SL3000 library.

1. Physical Configuration — choose library modules. You should plan for future 
growth.

2. Module Add-ons — select module specific add-ons (drive arrays, CAPs, and so 
on).

3. Tape Drives — order tape drives (T10000 and LTO).

4. Cartridges and Labels — order tape cartridges and labels.

5. Power Options — select a power redundancy option: N+1, 2N, or 2N+1. Order the 
required number of power supplies, AC power cords, and PDUs (to calculate 
requirements, see "Power Configurations" on page 1-9).

6. Hardware Activation Files — determine the active capacity required. Quantity 
options include: +25, +100, +200, +500, +700, +1000. Select options: dual TCP/IP, 
dual fibre channel, redundant electronics, library management software, and 
network connectivity.

7. Cables — select required cables.

8. Support — select maintenance options and professional service options.

Physical Configuration
Before selecting a physical configuration, read the options and requirements for each 
module in "Library Modules" on page 1-1.
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Base Module (required)
A standalone Base module is the smallest library configuration.

Options:

■ 8 (standard), 16, or 24 drive slots. To order additional drive arrays, see "Tape Drive 
Arrays" on page 1-25.

■ Perforated window (standard), window storage array, or operator panel. To order, 
see "Module Add-ons" on page 1-25.

Requirements:

■ You must purchase a minimum of 200 activated slots, see "Capacity Activation" on 
page 1-29.

Drive Expansion Module (DEM)
The library can have one DEM.

Options:

■ 8 (standard), 16, 24, or 32 drive slots. To order additional drive arrays, see "Tape 
Drive Arrays" on page 1-25.

■ Perforated window (standard), window storage array, operator panel, or CAP. To 
order, see "Module Add-ons" on page 1-25.

■ The DEM includes 200 active slots. To activate more capacity, see "Capacity 
Activation" on page 1-29.

Cartridge Expansion Module (CEM)

Options:

■ One CAP per module. To order, see "Cartridge Access Ports" on page 1-26.

■ A CEM can be converted to PEMs at any time if the dual robotics option is 
selected. There is a loss of capacity when converting a CEM to a PEM. Ensure that 
the library has the required capacity.

Requirements:

■ Maximum of eight CEMs per library.

Base Module Part Number Description ATO

Base module, no active slots, one drive array (eight drive slots), CAP SL3000-BASE-Z

Base module, no active slots, one drive array (eight drive slots), CAP for non-EU 
countries

7114504

DEM Part Number Description ATO PTO

DEM, 200 active slots, one drive array (eight drive slots) SL3000K-DEM200-Z XSL3000-DEM200-F

DEM, 200 active slots, one drive array (eight drive slots) 
for non-EU countries

7114505 7114531

CEM Part Number Description ATO PTO

CEM, no active slots (438 to 620 cartridge slots) SL3000-1CEM-Z XSL3000-CEM-Z-N
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■ Purchase activation permits to activate storage capacity in this module (see 
"Capacity Activation" on page 1-29).

Access Expansion Module (AEM)
AEMs can provide bulk loading and dual robotics support. AEMs can only be placed 
at the ends of the library. An AEM cannot be placed directly to the left of the Base 
module; there must be a module in between.

Options:

■ One AEM supports bulk loading capability only; dual robotics is not supported. 
Oracle recommends installing a single AEM on the left for maximum storage slot 
capacity.

■ Two AEMs support bulk loading and dual robotics. 

Dual Robotics
Dual robotics requires either two PEMs or two AEMs and a minimum 2N power with 
240 VAC.

Module Add-ons
■ Tape Drive Arrays

■ Cartridge Access Ports

■ Window Cartridge Array

■ Local Op Panel

■ Redundant Electronics

Tape Drive Arrays
You can order up to two additional drive arrays for the Base module and up to three 
arrays for the DEM.

AEM Part Number Descriptions ATO PTO

Left AEM, 234 bulk loading CAP SL3000-LEFTAEM-Z XSL3000-AEM-LFT-N

Left AEM, 234 bulk loading CAP for non-EU countries 7114506 7114532

Right AEM, 234 bulk loading CAP SL3000-RIGHTAEM-Z XSL3000-AEM-RT-Z-N

Right AEM, 234 bulk loading CAP for non-EU 
countries

7114507 7114533

Dual Robotic Part Number Descriptions ATO PTO

Dual robot SL3000-DUALBOT-Z XSL3000K-DUALBOT-N

Dual robot for non-EU countries 7114511 7114536

Note: Some options are only compatible with a specific module.

Tape Drive Array Part Number Description ATO PTO

Tape Drive Array (eight drive slots) SL3000-DRVARRAY-Z XSL3000-DRVARY-Z-N

Tape Drive Array (eight drive slots) for non-EU 
countries

7114512 7114537
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Cartridge Access Ports
Order a maximum of one CAP per CEM or DEM module. The Base module comes 
standard with one CAP.

Window Cartridge Array
The window array replaces the perforated window in the Base module and DEM with 
23 storage slots 

Local Op Panel
There can only be one local op panel per library. The operations panel replaces the 
perforated window on the Base module or DEM.

Redundant Electronics
Redundant electronics provides failover protection if a library controller card fails.

Tape Drives
Refer to the tape media section on the Oracle website for additional information: 
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/ove
rview/index.html.

For more information about encryption, see the Oracle Key Management Overview and 
Planning Guide on OTN.

Tape Drive Encryption
There are two encryption key management options:

■ Application-managed — an application manages the keys using the data path.

■ OKM-managed — Oracle Key Manager (OKM) appliance manages the keys using 
an ethernet connection outside the data path which is generally more secure.

Note: Bulk cartridge loading is available with an AEM (see "Dual 
Robotics" on page 1-25).

Rotational CAPs Part Number Description ATO PTO

Cartridge Access Port (26 slots) SL3000-1CAP-Z XSL3000-CAP-Z-N

Cartridge Access Port (26 slots) for non-EU countries 7114539 7114541

Spare CAP Magazine (13 slots) SL3000-CAPMAG-Z XSL3000-CAP-MAG-N

Window Cartridge Array Part Number Description ATO PTO

Cartridge Window Array (+23 slots) SL3000-WARRAY-Z XSL3000-W-ARRAY-N

Local Op Panel Description ATO PTO

Operations Panel SL3000-OPPANL-Z XSL3000-OP-PANL-N

RE Description ATO PTO

Redundant Electronics SL3000-REDELCT-Z XSL3000-REDELCT-Z

Redundant Electronics for non-EU countries 7114538 7114540

http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
http://www.oracle.com/us/products/servers-storage/storage/tape-storage/overview/index.html
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Support for application-managed and OKM-managed encryption depends on the 
drive type.

T10000 Encryption  All T10000 generations are encryption-ready, however enabling 
either application-managed or OKM-managed encryption requires a T10K-EKEY-A-N 
encryption activation permit. You can order an encryption activation permit at any 
time (during initial purchase or afterwards). After purchasing the permit, use Virtual 
Operator Panel (VOP) to enable encryption. T10000C and T10000D drives no longer 
require encryption license keys to enable encryption.

LTO Encryption  OKM-managed encryption requires an LTO-ENCRYPT-ACTIVE 
encryption activation permit. Application-managed encryption using the data path 
does not require a permit.

HP LTO 5 and 6 drives support both OKM-managed and application-managed 
encryption.

IBM LTO 5, 6, and 7 drives require a Belisarius card in the drive tray to interface with 
OKM. You may purchase a drive with or without OKM compatibility. To upgrade a 
non-OKM-compatible drive, you can purchase a kit to add the Belisarius card.

Re-using Encryption Activation Permits  If you previously purchased an activation permit 
for an older drive, you can re-use the activation permit when upgrading to a newer 
generation drive of the same family, as long as the total number of encryption enabled 
drives does not exceed your total number activation permits for that family. For 
example, if you have six T10K-EKEY-A-N activation permits, you can only have a total 
of six encryption-enabled T10000 drives (regardless of generation).

T10000 Drives
There may be other configurations for the T10000 tape drives than those listed below. 
For more information, see the drive specific Systems Assurance Guide on the OTN.

LTO Drives

Conversion Kits
Tape drive conversion kits convert drives previously used in an SL8500 library for use 
in the SL3000 library.

Description Part Number

T10000D 16 Gb Fibre Channel 7105799

T10000D 16 Gb FICON 7105800

T10000 encryption activation permit for one drive1

1 See "T10000 Encryption" and "Re-using Encryption Activation Permits" above.

T10K-EKEY-A-N

Description Part Number

IBM LTO8 Fibre Channel without OKM compatibility 7118443

IBM LTO7 Fibre Channel with OKM compatibility 7113979

IBM LTO7 Fibre Channel without OKM compatibility 7113981

OKM Interface Upgrade Kit for IBM LTO (Belisarius card) 7113290

LTO encryption activation permit for one drive1

1 See "LTO Encryption" and "Re-using Encryption Activation Permits" above

LTO-ENCRYPT-ACTIVE
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Port Conversions Kits
Port conversion kits convert the port type or install additional ports. For single port to 
dual port upgrades or dual port long to short wave conversions, order two kits.

Cartridges and Labels
You must order tape cartridges separately. You can use existing cartridges if they are 
compatible and still within their warranty period. Professional Services and Data 
Center Services offer media and drive migration services.

■ Call 1-877-STK-TAPE to order media from your local reseller or to obtain media 
pre-sales support. 

■ E-mail: tapemediaorders_ww@oracle.com

Label kits are available in either 60 or 200 piece quantities. The 60 piece kit has 60 data 
and 6 cleaning cartridge labels. The 200 piece kit has 200 data and 20 cleaning 
cartridge labels. The label ranges are sequentially numbered, non-repeating, and 
cannot be customized.

Refer to the T-Series Systems Assurance Guides for information about the media part 
numbers for the T9840 and T10000 tape drives. Refer to "Barcode Labels" on page F-1 
for more details about media labels.

Power Options
To determine the library’s power configuration requirements, refer to "Power 
Configurations" on page 1-9.

DC Power Supplies
To calculate the DC power supplies required, see "Calculating Tape Drive Power 
Supply Quantities" on page 1-11.

Tape Drive Conversion Kit Description Part Number

IBM LTO generation 3 or higher 7110132

HP LTO generation 3 or higher 7110133

T9840C/D 7110134

T10000A/B/C 7110135

T10000D 7110136

Tape Drive Port Conversion Kit Description Part Number

T10000C Fibre Channel to FICON conversion kit T10C-FC/FI-CKITZ

T10000A/B 4GB Fibre Channel and FICON single 4GB long wave SFP XT10K-4GB-LW-Z-N

T10000A/B 4GB Fibre Channel and FICON single 4GB short wave SFP XT10K-4GB-SW-Z-N

T9840C/D and T10000A 2GB FC and FICON single 2GB long wave SFP X984/T10K-2GB-LW-N

T9840C/D and T10000A 2GB FC and FICON single 2GB short wave SFP X984/T10K-2GB-SW-N

HP LTO4 FC dual-port conversion kit for installation of a second data port XL4-HF-SL30-DPCK-N

IBM LTO4 FC dual-port conversion kit for installation of a second data port XL4-IF-SL30-DPCK-N

LTO5 FC dual-port conversion kit for installation of a second data port XL5-SL85-SL30-DPCK

mailto:tapemediaorders_ww@oracle.com
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AC Power Distribution Units (PDU)
You cannot mix PDU types within a library. To determine the number and type of 
PDUs to order, see "Power Configurations" on page 1-9. 

AC Power Cords
■ N+1 power requires one power cord for the Base module and an additional power 

cord for the DEM (if installed)

■ 2N or 2N+1 power requires two power cords for the Base module and two 
additional power cords for the DEM (if installed)

Hardware Activation Files
Hardware activation files activate these options. For download instructions, see 
"Activating Optional Features" on page 5-1.

Capacity Activation
You can purchase capacity upgrades at any time. Order larger quantities first and add 
smaller quantities to get the total desired active capacity. For more information, see 
"Storage Capacity" on page 1-16.

Note: For the 2N+1 power option, order one additional 1200W DC 
supply and two additional 200W cPCI power supplies. These are in 
addition to the DC supplies required for the tape drives. For more 
information, see "DC Power Supplies" on page 1-10.

DC Power Supply Options ATO PTO

1200W DC power supply (for tape drives and robotics) SL3000-1DCPWR-Z XSL3000-DCPWR-Z-N

200W cPCI power supply (for ECM) SL3000-EMDCPWR-Z XSL3000-EM-DCPWR-N

PDU Power Options ATO PTO

100 - 127 VAC 20 Amp PDU SL3000-PDU110-Z XSL3000-PDU-110-N

200 - 240 VAC 30 Amp PDU 7114509 7114534

200 - 240 VAC 30 Amp PDU for non-EU countries SL3000-PDU240-Z XSL3000-PDU-240-N

AC Power Cords ATO PTO

US Power Cord 20A/110V, 3.7 meter SL3000-PWCD20110 XSL3000-PC20110-N

US Power Cord 30A/220V, 3.7 meters SL3000-PWCD30220 XSL3000-PC30220-N

International Power Cord, 30A/220V, 4 meters SL3000-IPWCD30220 XSL3000-IPC30220-N

Hardware Activation File ATO PTO

Dual TCP/IP SL3000-2TCPIP XSL3000-2TCPIP-F

Dual Fibre Channel Card XSL3000-2FCCARD XSL3000-2FCCARD

Dual Fibre Channel Port SL3000K-2FCPORT XSL3000-2FCPORT-F

Quantity of Active Capacity ATO PTO

1000 Cartridge Slot Upgrade SL3000K-1000SLOT XSL3000-1000SLOT-F
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Cables
The following tables list the cables available for the SL3000 library and tape drives. 
The cables are either Riser or Plenum. Plenum-rated cables have a higher flammability 
rating and are used for under-the-floor applications. SL3000 drive trays accept only LC 
fiber cable connectors. If you are using cables with SC connectors, you must add an 
adapter.

Fiber Optic Cables
LC connectors are the industry standard for all 2 Gb-capable or higher Fibre Channel 
devices. SL3000 drive trays accept only LC fiber cable connectors. 

700 Cartridge Slot Upgrade SL3000K-700-SLOT Not available

500 Cartridge Slot Upgrade SL3000K-500-SLOT XSL3000-500-SLOT-F

200 Cartridge Slot Upgrade SL3000K-200-SLOT XSL3000-200-SLOT-F

100 Cartridge Slot Upgrade SL3000K-100-SLOT XSL3000-100-SLOT-F

25 Cartridge Slot Upgrade SL3000K-25SLOT XSL3000-25-SLOT-F

LC to LC 50/125 Micron, Multimode Cable ATO PTO

50 m (164 ft) FC cable OM4, 50/125 duplex riser 7106951 7106952

50 m (164 ft) FC cable OM4, 50/125 duplex plenum 7106953 7106954

3 m (9.8 ft) FC cable, duplex riser CABLE10800340-Z-A CABLE10800340-Z-N

5 m (16.4 ft) FC cable, duplex riser CABLE10800341-Z-A CABLE10800341-Z-N

10 m (32.8 ft) FC cable, duplex riser CABLE10800310-Z-A CABLE10800310-Z-N

10 m (32.8 ft) FC cable, duplex plenum CABLE10800313-Z-A CABLE10800313-Z-N

LC-to-LC, 9/125 Micron, Single Mode Cable Part Number

3 m (9.8 ft) Optical Cable, LC-to-LC Duplex, Riser CABLE10800302-Z-A

10 m (32.8 ft) Optical Cable, LC-to-LC Duplex, Riser CABLE10800331-Z-A

50 m (164 ft) Optical Cable, LC-to-LC Duplex, Riser CABLE10800333-Z-A

100 m (328 ft) Optical Cable, LC-to-LC Duplex, Riser CABLE10800306-Z-A

10 m (32.8 ft) Optical Cable, LC-to-LC Duplex, Plenum CABLE10800330-Z-A

50 m (164 ft) Optical Cable, LC-to-LC Duplex, Plenum CABLE10800332-Z-A

100 m (328 ft) Optical Cable, LC-to-LC Duplex, Plenum CABLE10800305-Z-A

LC-to-SC, 9/125 Micron Cable Part Number

10 m (32.8 ft) Optical Cable, LC-to-SC Duplex, Riser CABLE10800335-Z

50 m (164 ft) Optical Cable, LC-to-SC Duplex, Riser CABLE10800337-Z

100 m (328 ft) Optical Cable, LC-to-SC Duplex, Riser CABLE10800304-Z

10 m (32.8 ft) Optical Cable, LC-to-SC Duplex, Plenum CABLE10800334-Z

50 m (164 ft) Optical Cable, LC-to-SC Duplex, Plenum CABLE10800336-Z

100 m (328 ft) Optical Cable, LC-to-SC Duplex, Plenum CABLE10800303-Z

Quantity of Active Capacity ATO PTO
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Ethernet Cables
These cables provide the interface connection for TCP/IP (HLI-PRC). Only connect 
shielded cables to the library and tape drives.

Support
Service and support representatives are available to assist with hardware and software 
problem resolution. During the initial order and installation planning, you can contact 
local and remote support with any questions. 

Service Delivery Platform
The Service Delivery Platform (SDP) is a support enhancement solution that provides 
faster problem resolution, analysis and trending, and improved diagnostic capabilities. 
The SDP consists of a smart appliance placed at the customer site that connects to the 
library and any StorageTek T-series tape drives. The SDP collects device events and 
alerts support analysts, providing remote diagnosis and auto service requests (ASR).

For more information, contact an Oracle representative or visit: 
http://www.oracle.com/technetwork/systems/asr/documentation/oracle-install
ed-storage-330027.html

Oracle Premier Support for Systems
Oracle Premier Support is a fully integrated support solution that features:

■ Complete system coverage and unlimited 24/7 access to Oracle system specialists

■ Essential product updates, such as firmware

■ Personalized, proactive IT support and rapid-response hardware service

For more information, visit:
http://www.oracle.com/us/support/index.html

Contacting Support
The Oracle Global Customer Support Contacts Directory can be found at: 
http://www.oracle.com/us/support/contact-068555.html

To submit, update, or review service requests, go to My Oracle Support at: 
https://support.oracle.com/

ESCON Cable Part Number

13 m (4 ft) Riser CABLE10800289-Z

107 m (350 ft) Riser CABLE10800292-Z

13 m (4 ft) Plenum CABLE10800285-Z

31 m (100 ft) Plenum CABLE10800286-Z

107 m (350 ft) Plenum CABLE10800288-Z

Ethernet Cable Part Number

2.4 m (8 ft), 24 AWG, CAT5, Shielded CABLE10187033-Z-A

10.7 m (35 ft), 24 AWG, CAT5, Shielded CABLE10187034-Z-A

http://www.oracle.com/technetwork/systems/asr/documentation/oracle-installed-storage-330027.html
http://www.oracle.com/technetwork/systems/asr/documentation/oracle-installed-storage-330027.html
http://www.oracle.com/us/support/index.html
http://www.oracle.com/us/support/contact-068555.html
https://support.oracle.com/
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2Installation Planning

■ Physical Dimensions and Weights

■ Installation Site Requirements

■ Fire Suppression Planning

■ Networking

■ Cable Routing

■ Approximate Installation Time

■ Installation Tools

Physical Dimensions and Weights

Figure 2–1 Service Clearances and Dimensions (Side View)

Figure Legend:

1. Base and DEM rear service clearance

2. Base and DEM front service clearance

3. AEM service clearance
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4. Weight pad adjustment range

Figure 2–2 Service Clearances and Dimensions (Top View)

Figure Legend:

1. Side cooling area

2. Side cover

3. Nozzle cutout for fire suppression system

4. Base and DEM service clearance (light gray areas)

5. AEM service clearance (dark gray areas)

6. Weight distribution pad
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Base Module

Drive Expansion Module

Table 2–1 Base Module Measurements

Dimension Type Measurement

Height 196.7 cm (77.45 in.) on casters for transport

197.5 cm (77.75 in.) to 201.68 cm (79.4 in.) on weight pads for permanent install

Width 76.8 cm (30.22 in.) when placed between modules

81.3 cm (32 in.) transport width (no side covers) 1

91.5 cm (36 in.) standalone with side covers on both sides2

1 Minimum transportation clearance. There are alignment tabs on each side of the module that add 4.5 cm 
to the 76.8 cm width of the module. Therefore, 81.3 cm is the minimum transportation width.

2 One side cover adds 7.4 cm (2.9 in.) to the module width. Only the ends of the library require side covers.

Depth 121.9 cm (48 in.) 

Service Area Front: 45.7 cm (18.0 in.)

Rear: 81.3 cm (32.0 in.)

Side Cooling Area: 5 cm (2 in.)

Side Install Area: 45.7 cm (18.0 in.)

Weight Frame only: 361 kg (796 lb) 

8 drives and media: 623 kg (1372 lb)

16 drives and media: 661 kg (1457 lb)

24 drives and media: 687 kg (1514 lb)

Side Covers: 18.5 kg (41 lb) per side

Table 2–2 Drive Expansion Module Measurements

Dimension Measurement

Height 196.7 cm (77.45 in.) on casters for transport:

197.5 cm (77.75 in.) to 201.68 cm (79.4 in.) on weight pads for permanent install

Width (module only) 76.8 cm (30.22 in.) when placed between modules

81.3 cm (32 in.) transport width (no side covers) 1

83.8 cm (33 in.) with one side cover

1 Minimum transportation clearance. There are alignment tabs on each side of the module that add 4.5 cm 
to the 76.8 cm width of the module. Therefore, 81.3 cm is the minimum transportation width.

Depth (doors closed) 121.9 cm (48 in.) 

Service Area Front: 45.7 cm (18.0 in.)

Rear: 81.3 cm (32.0 in.)

Side Cooling Area: 5 cm (2 in.)

Side Install Area: 45.7 cm (18.0 in.)

Weight Frame only, no CAP: 265 kg (584 lb) 

8 drives and media: 540 kg (1190 lb), 582 kg (1284 lb) with CAP

16 drives and media: 596 kg (1314 lb), 621 kg (1369 lb) with CAP

24 drives and media: 647 kg (1426 lb), 660 kg (1456 lb) with CAP

32 drives and media: 709 kg (1564 lb), 723 kg (1594 lb) with CAP
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Cartridge and Parking Expansion Modules

Access Expansion Module

Covers, Doors, and Service Clearances

Table 2–3 Cartridge and Parking Expansion Module Measurements

Dimension Measurements

Height 196.7 cm (77.45 in.) on casters for transport

197.5 cm (77.75 in.) to 201.68 cm (79.4 in.) on weight pads for permanent install

Width (module only) 76.8 cm (30.22 in.) when placed between modules/side cover

81.3 cm (32 in.) transport width (no side covers) 1

83.8 cm (33 in.) with one side cover

1 Minimum transportation clearance. There are alignment tabs on each side of the module that add 4.5 cm 
to the 76.8 cm width of the module. Therefore, 81.3 cm is the minimum transportation width.

Depth 77.5 cm (30.5 in.)

Weight (CEM) Frame only: 175 kg (385 lb)

Shipping: 213 kg (469 lb)

Installed, with media: 340 kg (749 lb)

Weight (PEM) Frame only: 175 kg (385 lb) 

Installed, with media: 257kg (567 lb)

Table 2–4 Access Expansion Module Measurements 

Dimension Measurement

Height 196.7 cm (77.45 in.) on casters for transport

197.5 cm (77.75 in.) to 201.68 cm (79.4 in.) on weight pads for permanent install

Width 91.4 cm (36.0 in.) when placed between module and side cover

96 cm (37.8 in) transport width (no side covers) 1

99.1 cm (39 in.) with one side cover 

1 Minimum transportation clearance. There are alignment tabs on each side of the module that add 4.5 cm 
to the 91.5 cm width of the module. Therefore, 96 cm is the minimum transportation width.

Depth 77.5 cm (30.5 in.) 

Service Area Front: 59.7 cm (23.5 in.)

Weight Frame only: 204.2 kg (450 lb)

Table 2–5 Covers, Doors, and Service Clearance Measurements 

Dimension Measurement

Height 190.3 cm (74.9 in.) frame only

Door thickness Front: 1.9 cm (0.75 in.) 

Rear: 4.5 cm (1.75 in.) 

Door latches 2.53 cm (0.9 in.)

Service clearance Front: 45.7 cm (18 in.) for Base and DEM only, 59.7 cm (23.5 in.) for AEM

Rear: 81 cm (32 in.) for Base and DEM only

Side: 5 cm (2 in.) for cooling, 45.7 cm (18.0 in.) for install

Side cover 7.4 cm (2.9 in.) width

18.5 kg (41 lb) each
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Shipping Weights and Measures
The SL3000 library modules and other components are shipped on pallets. The table 
below lists each module and its shipping specifications. If equipment on a pallet must 
be transported on elevators, the elevator cars must be capable of safely handling the 
weight.

Either a split-pallet or pallet-ramp design is used to ship and provide safe removal of 
the module at the customer site. SL3000 library modules are shipped with wheels 
(casters) already attached to allow for easy positioning within the data center. Once 
positioned, the modules must be raised from their wheel-base to rest upon load plates 
for stability and leveling purposes.

The suggested library adjustment height is 200 cm (77.6 in.). Ensure the top of the 
library does not interfere with ceiling fixtures at the installation site.

Installation Site Requirements
■ Physical Space Requirements

■ Transporting the Library

■ Floor Requirements

■ Environmental Requirements

■ Waste Disposal

Physical Space Requirements
The SL3000 library requires adequate physical space. For dimensions of the library 
modules, see "Physical Dimensions and Weights" on page 2-1. If modules will be 
added in the future, ensure there is enough room to expand the library.

The minimum working area (not including the space required for the pallets) is 
approximately 19 m2 (200 ft2). 

Transporting the Library
If the equipment must be transported on elevators, the elevator cars must be capable 
of safely handling the weight. Additionally, ensure that the components can pass 
through doorways and fit in elevators. For more information, see "Shipping Weights 
and Measures" on page 2-5.

Table 2–6 Module and Tape Drive Shipping Information 

Type Height Width Depth Weight

Base 216 cm (85 in.) 97 cm (38.3 in.) 134 cm (53 in.) 410 kg (905 lb)

DEM 216 cm (85 in.) 97 cm (38.3 in.) 134 cm (53 in.) 321 kg (708 lb)

CEM 216 cm (85 in.) 97 cm (38.3 in.) 96 cm (38 in.) 213 kg (469 lb)

PEM 216 cm (85 in.) 97 cm (38.3 in.) 96 cm (38 in.) 213 kg (469 lb)

AEM 216 cm (85 in.) 97 cm (38.3 in.) 148 cm (58 in.) 260 kg (570 lb)

LTO 32 cm (12.6 in.) 31 cm (12.2 in.) 66 cm (26 in.) 9.5 kg (20.9 lbs)

T10000 34 cm (13.4 in.) 31 cm (12.2 in.) 66 cm (26 in.) 10.5 kg (23.1 lbs)
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Pallet Double Stacking

In the event that a forklift is unavailable to safely remove the module, notify the 
installation coordinator. Inform them that the library may need to be picked up from 
the site by the delivery company, taken off the second pallet, and re-delivered. 
Delivery personnel are not authorized to remove the modules from the second pallet 
without proper equipment. 

Floor Requirements
You can install the SL3000 library on a raised, solid, or carpeted floor with a smooth 
surface, as long as there is adequate airflow. If the floor is raised, ensure there are no 
ventilation panels directly below the library. If the floor is solid, you should route 
cables from the ceiling to avoid creating a tripping hazard. If the floor is carpeted, 
ensure the carpet is approved for computer-room equipment and provides protection 
from electrostatic discharge (ESD).

Weight
Verify the site floor can support the weight of the library. It must support 454 kg (1,000 
lb) per weight distribution pad. There are four distribution pads per module, and each 
measures 4 by 8 inches.

If the equipment must be transported on elevators, the elevator cars must be capable 
of safely handling the weight. Depending on the library configuration, the weight of 
the library can vary (see "Physical Dimensions and Weights" on page 2-1).

Floor Slope 
Robots must travel along a level plane throughout the library. Any excessive 
out-of-plane conditions could cause binding, premature wear, and damage to the 
robots. Use the height of the weight pads to adjust the library on a sloped floor.

Environmental Requirements
For optimal reliability, maintain the environment between the recommended ranges. 
Although this equipment is designed to operate in environmental conditions of 20% to 
80% humidity, a recommended industry best practice is to maintain a relative 
humidity of 40% to 50%.

WARNING: Possible Physical Injury. Only use a forklift operated 
by a qualified operator to remove a stacked second pallet. Do not 
attempt to tilt or slide the pallet off by hand.

Table 2–7 Environmental Specifications 

Description Temperature 
Relative Humidity 
(non-condensing) Wet Bulb Maximum Maximum Altitude

Operating 15 to 32°C (60 to 90°F) 
dry bulb

20% to 80% 29.2°C (84.5°F) 3.05 km (10,000 ft)

Storage 10 to 40°C (50 to 
104°F)

10% to 95% 35.0°C (95.0°F) 3.05 km (10,000 ft)

Shipping -40 to 60°C (-40 to 
140°F)

10% to 95% 35.0°C (95.0°F) 15.24 km (50,000 ft)
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Airborne Contaminants 
Airborne particulates can damage tape libraries, drives, and tapes. The operating 
environment for the tape library must meet to the following requirements:

■ ISO 14644-1 Class 8 Environment

■ Total mass of airborne particulates must be less than or equal to 200 micrograms 
per cubic meter

■ Severity level G1 per ANSI/ISA 71.04-1985

Particles ten microns or smaller are particularly harmful to most data processing 
hardware. Gasses that are particularly dangerous to electronic components include 
chlorine compounds, ammonia and its derivatives, oxides of sulfur, and petrol 
hydrocarbons. In the absence of appropriate hardware exposure limits, health 
exposure limits must be used.

Humidification with chlorinated water is a common source of airborne chlorine. 
Appropriately-designed carbon filters must be used to ensure safe levels of airborne 
chlorine when chlorinated water is used for humidification.

Some basic precautions to follow:

■ Do not allow food or drink into the data center.

■ Do not store cardboard, wood, or packing materials in the data center clean area.

■ Identify a separate area for unpacking new equipment from crates and boxes.

■ Do not allow construction or drilling in the data center without first isolating 
sensitive equipment. Dry wall and gypsum are especially damaging to equipment.

Seismic or Earthquake Ratings
The requirements for seismic compatibility vary dramatically throughout the world. 
Therefore, Oracle does not offer a standard "seismic" feature for the SL3000 library. If 
you have seismic concerns, Oracle recommends that you work with local experts who 
are familiar with the local code and requirements. Professional Services can also help 
coordinate this activity.

Table 2–8 Gas Limit Recommendations

Chemical ASHRAE OSHA (PEL) ACGIH NIOSH 

Acetic Acid (CH3COOH) Not defined 10 ppm Not defined Not defined 

Ammonia (NH) 3500 µg/m3 350 ppm 25 ppm Not defined 

Chlorine (Cl) 2100 µg/m3 31 ppm (c) Not defined 0.5 ppm (c) 

Hydrogen Chloride (HCl) Not defined 5 ppm (c) Not defined Not defined 

Hydrogen Sulfide (H2S) 50 µg/m3 320 ppm (c) 10 ppm 10 ppm 

Ozone (O3) 235 µg/m3 30.1 ppm Not defined Not defined 

Petrol-hydrocarbons (CnHn) Not defined 500 ppm 75 ppm 300 ppm 

Sulfur Dioxide (SO2) 80 µg/m3 35 ppm 2 ppm 0.5 ppm (c) 

Sulfuric Acid (H2SO4) Not defined 1 ppm Not defined 1 ppm (c) 

Caution: Bodily injury and equipment damage: You must consult a 
qualified seismic engineer to verify seismic zone exposures and 
adequate site preparation. 
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For sites in areas of seismic activity, you might want to permanently fix the library 
position for added stability. The SL3000 library provides mounting holes in the floor of 
each module where half-inch carriage bolts (mounting studs) can be used to 
permanently fix the library's position.

Power Requirements
For power requirements, heat output, and power consumption, see "Power 
Configurations" on page 1-9.

Waste Disposal
Plan for the disposal of all packing material. Determine if waste bins or recycling 
containers will be provided on site or whether an independent company will handle 
the disposal at additional cost.

Fire Suppression Planning
The library does not ship with a fire suppression system, but each module has a 5 cm 
(2 inch) diameter nozzle opening (see Figure 2–2). Plates, 7 cm (2.75 inch) square and 
1.2 mm (0.048 inch) thick, cover the openings and can be drilled to custom fit nozzles. 
Nozzles must be clear of robotic operations and cannot protrude more than 1.9 cm 
(0.75 inches) into the library. Professional Services can assist with fire suppression 
planning (contact your Oracle sales representative).

Networking
If possible, use a dedicated and secure private network for communication between 
the library and host management software. A secure private network connection using 
an Ethernet hub or switch is required for maximum throughput and minimum 
resource contention.

If a shared network must be used: 

■ Place the library on its own subnet. 

■ Directly connect the library to a switch and use a managed switch that can:

– Set priorities on ports to give the host and library higher priority.

– Provide dedicated bandwidth and create a VLAN between the host and the 
library.

■ Use a virtual private network (VPN) to insulate host and library traffic. 

Cable Routing
The SL3000 library has rear door cut-outs on both the top and bottom of the door to 
allow for cable routing. The cut-out is a 2.5 cm (1 inch) opening that runs 73 cm (29 
inches) along the length of the door with cable routing hardware and reliefs available.

Note: The Base module and DEM have square holes on the face of 
rear door. These are for access to the PDUs, not for cable routing. 
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When routing cables, make sure to include locations for power, drive interface, library 
control, and Ethernet cables. As a best practice, route power cables through one 
cut-out and signal cables through another cut-out. 

Figure 2–3 Door Cable Routing Cutouts

Figure Legend:

1. Cable routing area

2. Top/bottom view of rear door

AC Power Cables
SL3000 libraries require that you select one of the following single phase AC power 
options for the Base module and DEM: 

■ 110 VAC, 50/60 Hz, at 20 Amps (range: 100–127 VAC, 50–60 Hz, 16 Amps) 

■ 240 VAC, 50/60 Hz, at 30 Amps (range: 200–240 VAC, 50–60 Hz, 24 Amps) 

Make sure to plan for the locations of power cables and list the locations for their 
associated circuit breakers. Cables must be ordered for the appropriate power 
configuration. Order one power cord per PDU installed:

■ N+1 — one power cord for the Base module and an additional power cord for the 
DEM (if installed). 

■ 2N or 2N+1 — two power cords for the Base module and two additional power 
cords for the DEM (if installed).

Library Network and Tape Drive Cables
The library can be used in a 62.5-micron-cable Storage Area Network (SAN). However, 
the cable that connects the library to the network must be a 50-micron cable. The 
maximum distances supported on a Fibre Channel link are determined by the link 
speed, the type of fiber (50 or 62.5 micron), and the device to which the library is 
attached. Refer to your switch vendor to determine what is supported in your storage 
area network. 

The typical support distances for the cables are:

■ 4 Gbps = up to 70 m (230 ft) for 62.5-micron, 150 m (492 ft) for 50-micron

■ 2 Gbps = up to 150 m (492 ft) for 62.5-micron, 300 m (984 ft) for 50-micron

■ 1 Gbps = up to 175 m (574 ft) for 62.5-micron, 500 m (1640 ft) for 50-micron

If your library attaches to a host bus adapter (HBA), refer to the documentation for the 
HBA for the supported cable distances. For a list of cables, see "Cables" on page 1-30.

If your library will support encryption, refer to the Oracle Key Manager Overview and 
Planning Guide on OTN.
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Approximate Installation Time
The table below shows the estimated times for the installation of modules and 
components. At least two qualified service representatives should install the library. 
The times listed below do not include library initialization, testing, audits, and feature 
upgrades. Installation services are required with the purchase of the SL3000 library. 
Contact an Oracle sales representative for more information.

Installation Tools
The tables below list the installation tools required for the SL3000 library. Oracle 
service personnel should obtain the standard tools locally or from the SL8500 
installation kit if available. 

Table 2–9 Installation Time Estimates 

Module/Component 

Time 
Estimate 
(hours)

Personnel 
Required 

Total Person 
Hours

Base with 8 drives (standard) 3 2 6

Base and DEM 5 2 10

Base and CEM 4 2 8

Each additional CEM 2 2 4

Two PEMs 2 2 4

AEMs (each) 2 2 4

CAPs 1 2 2

Tape drive (each drive) 0.5 1 0.5

Operator panel or window 0.75 1 0.75

Firmware 0.2 1 0.2

Integration (cables, hubs, switches, connections) 8 1 8

Media install (each) 0.02 1 variable

Table 2–10 Standard Installation Tools

Standard Tools Use

Torx screwdriver with T8, T10, T15, T25 bits T8: Removal and replacement of the PUK card.

T10: PUO, PUW, PUN, PUF, PUZ cards. Track stops.

T15: Operator panel, window, blank plate, arrays

T25: Shipping brace, rails, and CAP screws.

3/8-in. drive ratchet wrench1 Module height adjustment, joining modules 

5/16-in. hex Allen on 3/8-in. drive1 Module height adjustment, joining modules 

9/16-in. socket on 3/8-in.-drive1 Module removal from pallet

Adjustable wrench (must accept 7/8-in. 
nut)

Lock weight distribution pads

Phillips and flat blade screwdrivers General assembly

Power drill (optional) General assembly. Adjust the torque settings to 2.8 Nm (25 
in.-lb) for T-25 screws and 0.6 Nm (5 in.-lb) for T-10 screws.

Wire side cutters Cutting shipping straps

Multimeter Electrical testing

Flashlight, step stool General assembly

Pallet jack Moving equipment
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Drive Tray Power-on Tool
A tool is available to assist in removing a stuck tape within a library tape drive. This 
tool turns on a drive outside the library. The drive tray toolkit (part number 
314831204) contains instructions and a drive power cable (part 419632401).

The tool is available from iProcurement under the Zones online tool crib.

Installation Kits
Installation kits are supplied with each module, and contain the hardware required to 
install each module. Kit part numbers are: 

■ 419838301 — Base module

■ 419844301 — DEM and CEM

1 Can be obtained from the SL8500 tool kit.

Table 2–11 Special Installation Tools

Special Tools Part Number Use

Copper rail connector 
extraction tool 

313921001 Track terminator removal (obtain from Base installation kit)

Rail separator/joiner 4199410xx Release or join extrusions (obtain from Base installation kit)

Serial cable for laptop 24100134 CLI access to library (obtain from iProcurement/Zones)

Crossover cable for laptop 24100163 Ethernet access to library (obtain from iProcurement/Zones)

Drive tray power-on tool 314831204 See "Drive Tray Power-on Tool" on page 2-11 below (obtain 
from iProcurement/Zones)

Note: An AC power cord is required to use this tool. You must 
obtain a cord that is appropriate for your region.
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3Installing StorageTek Library Console

Oracle’s StorageTek Library Console (SLC) is a GUI application for configuring, 
monitoring, and managing the SL3000 tape library.

■ Selecting an SLC Version

■ Downloading the SLC Media Pack

■ Installing Standalone SLC

■ Installing Web-launched SLC

Selecting an SLC Version
You can perform the procedures in this document using any of these three SLC 
versions, unless otherwise noted:

■ Standalone — SLC runs remotely from any system that has a network connection 
to the library.

■ Web-launched — SLC is installed on a web server (or server running a web 
service application like Tomcat, Apache, or GlassFish), allowing individual clients 
to use a browser to access SLC.

■ Local Operator Panel — SLC is pre-installed on the library, enabling library 
operators to access most SLC functions directly at the library.

Downloading the SLC Media Pack
The media pack includes the web-launched SLC server, web-launched SLC client, and 
standalone SLC.

1. Go to the Oracle Software Delivery Cloud at: 

http://edelivery.oracle.com/

2. Click Sign In/Register.

3. Search for SLC, and then select the Oracle StorageTek Library Console version. 
Click Select Platform.

4. Verify the correct version is listed in the queue. Click Continue.

Note: Customer data on tape cartridges is never available to SLC or 
the library. The external data interface of the tape drives is separate 
from the library infrastructure.
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5. Review and accept the terms and restrictions. Click Continue.

6. Verify the SLC version is correct. Click Download.

7. Save the file. Extract the media pack to the desired location.

Installing Standalone SLC
1. Uninstall all previous version of SLC before updating.

2. Download and extract the standalone SLC media pack (see "Downloading the SLC 
Media Pack" on page 3-1).

3. Select the SLC installer file for your operating system (refer to the media pack 
readme).

4. Review the information. Click Next.

5. Specify where to install SLC. Click Next.

6. Specify where to create the SLC shortcut icons. Click Next.

7. Verify the information is correct. Click Install.

8. Click Done.

Supported Platforms
■ Solaris 10 SPARC, Solaris 10 x86

■ Windows Server 2008 SP2: 64-bit, Windows 2012 Enterprise Server

■ Windows 7 SP1: 64-bit, Windows 8 64-bit, Windows 8.1 64-bit

■ Oracle Unbreakable Linux 5 (2.6.18) 32-bit

■ SUSE Enterprise Linux 10.2 (2.6.16) 32-bit

Security
SLC interfaces with the primary library interface (PLI) over SSL, which provides a 
secure communication path between the library and the SLC session. This prevents an 
unauthorized network user from monitoring library activity.

Installing Web-launched SLC
You only need to install web-launched SLC updates on the server. You can update the 
web-launched SLC server while it is running. After the updates are installed, they are 
downloaded automatically to all clients whenever the application is started.

1. Download and extract the web-launched SLC server (.war) file (see "Downloading 
the SLC Media Pack" on page 3-1).

2. Deploy the .war file on the server (refer to the web server documentation).

Note: On Solaris, you cannot choose the default root directory. 
Oracle recommends /u-sr/bin or a similar location.
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Minimum Browser Requirements
■ Internet Explorer 8 (on Windows 7: 64 bit)

■ Firefox 17.0.2 ESR (on Windows 7: 64 bit)

Security
The web-launched SLC software is digitally signed, which guarantees that it has been 
issued by Oracle and has not been altered or corrupted since it was created. As a Java 
Web Start process, the web-launched SLC includes the security features provided by 
the Java 2 platform.

Important: You are responsible for implementing all appropriate 
security systems, including firewalls and user access.
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4Logging in to SLC

■ Logging in for the First Time After Library Installation

■ Logging in to Standalone SLC

■ Logging in to Web-launched SLC

■ Logging in to the Local Operator Panel

■ Changing a User Password

Logging in for the First Time After Library Installation
1. With the admin user ID, log in to SLC with the first eight characters of the 

activation password provided by Oracle.

2. Change the admin password.

a. Select Tools > User Mgmt.

b. Complete the password fields.

c. Click Modify.

Logging in to Standalone SLC
Multiple users can be logged in to the standalone SLC.

1. To start SLC on your system, either:

■ Double-click the SLC desktop icon.

■ Select Start > RunSLConsole or Launch > RunSLConsole.

2. Enter your login information. Click Log on.

Logging in to Web-launched SLC
To log in using a browser, download Mozilla Firefox from http://www.mozilla.com. 
On Solaris platforms, you can also log in to the web-launched SLC using the command 
line. 

1. Obtain the DNS alias or IP address of the SLC server.

Note: After an RE failover, log in using the IP address or DNS alias 
of the newly active library controller (previously the standby 
controller).
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2. Choose a login method:

– Command line — Available on Solaris only. In the terminal window, enter:

javaws http://server_ID:port_ID/opel/slc.jnlp

– Browser — Available on Windows or Solaris. In a browser on the client 
system, go to the SLC Web Start application:

http://server_ID:port_ID/opel

where:

■ server_ID — Either the IP address or DNS alias of the SLC server

■ port_ID — Port ID of the SLC application, typically 8080

■ opel — The name (context root) of the web-launched SLC application on the 
server.

3. Click Launch Now.

4. Specify the action to take with the slc.jnlp file. Select either:

■ Open with Java(TM) Web Start Launcher to start SLC directly.

■ Save to Disk to save the slc.jnlp file to your client and log in to the SLC later.

5. If this is your first time running the web-launched SLC, complete the digital 
signature warning dialog box (verify the publisher and click Run).

6. Enter your SLC login information. Click Log on.

Logging in to the Local Operator Panel
Only one user at a time can log in to the local operator panel.

1. If the screen is blank, touch the screen anywhere to activate the login screen.

2. Enter your login information.

3. Click Log on.

Changing a User Password
Each site has a fixed set of user IDs: admin (customer administrator), service (Oracle 
support representative), and oem (third-party field service technician). Each user ID is 
assigned a set of permissions that determines access to utilities within SLC.

1. Log in to SLC using the account you want to modify.

2. Select Tools > User Mgmt.

3. Complete the password fields.

4. Click Modify.
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5Activating Optional Features

Hardware activation files enable optional library features, such as capacity upgrades 
and redundant electronics. You must install one hardware activation file for each 
feature.

■ Downloading a New Hardware Activation File

■ Installing a New Hardware Activation File

■ Displaying Current Hardware Activation Files

■ Deleting a Hardware Activation File

■ Installing Legacy Hardware Activation Files

Downloading a New Hardware Activation File 
Only use this procedure for libraries with firmware FRS_3.0 and above. For libraries 
with lower firmware levels, see "Installing Legacy Hardware Activation Files" on 
page 5-2.

1. Go to the Oracle Software Delivery Cloud at:

http://edelivery.oracle.com/

2. Click Sign In /Register.

3. Read the terms and restrictions. Indicate your acceptance, and then click 
Continue.

4. On the Media Pack Search screen, select Oracle StorageTek Products and Generic 
Platform. Click Go.

5. Select the SL3000 hardware activation file. Click Continue.

6. Click Download. 

7. Save the file.

8. Extract the file to a location accessible to your SLC session.

Installing a New Hardware Activation File
1. In SLC, select Tools > Hardware Activation.

2. Click the Install Hardware Activation Keys tab. 

3. Browse to the hardware activation file.

4. Review the hardware activation file details. Click Install.
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5. Click Yes, and then OK.

6. Verify that the activation file was installed successfully (see "Displaying Current 
Hardware Activation Files" on page 5-2). 

You may need to perform additional tasks to use the new feature (see 
"Configuring Capacity" on page 6-1 and "Partitioning the Library" on page 7-1).

Displaying Current Hardware Activation Files

1. In SLC, select Tools > Hardware Activation. 

2. Click the Current Hardware Activation Keys tab.

Deleting a Hardware Activation File
Deleting a hardware activation file is rarely necessary and can impact library 
operations. Having extra hardware activation files installed on a library does not cause 
problems (for example, capacity activation files that exceed the physical capacity of the 
library). 

1. In SLC, click Tools > Hardware Activation.

2. Click the Delete Hardware Activation Files tab.

3. Select the activation file to delete.

4. Verify the correct activation file is selected, and then click Delete.

5. Click Yes.

Depending on the feature of the hardware activation file, you may need to 
perform additional tasks after deleting the file (see "Deleting a Partition" on 
page 7-2).

Installing Legacy Hardware Activation Files 
For SL3000 libraries with firmware below FRS_3.0, contact Oracle support. All 
purchased features are enabled with a single hardware activation file installed by an 
Oracle support representative.

If you upgrade to firmware version FRS_3.0 and above, use the process described in 
"Installing a New Hardware Activation File" on page 5-1.

Note: To display a feature audit log showing all hardware activation 
activity, use the Reports utility (see "Viewing Library and Device 
Reports with the Reports Utility" on page 15-1).
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6Configuring Capacity

In a non-partitioned library, active capacity is automatically assigned after installing 
the hardware activation file. The automatic configuration activates storage slots in the 
order specified by the Default Capacity Policy. However, you can customize the 
configuration and select which slots will be activated.

■ Creating a Custom Capacity Configuration

■ Resetting the Capacity Configuration

■ Setting the Default Capacity Policy

■ Displaying the Current Capacity Configuration

■ Resolving Orphaned Cartridges Caused by Capacity Changes

See Also
■ "Updating Hosts After Modifying Capacity" on page 8-1

Creating a Custom Capacity Configuration
You cannot use the local operator panel to configure capacity. 

1. To prevent conflicts, coordinate with other library users before configuring the 
library.

2. In SLC, select Tools > Select Active Cells. Select the Module Map tab.

3. Select a module and click the Select Active Cells tab. To display an adjacent 
module, click Move Left or Move Right.

Note: Capacity is automatically applied in a partitioned library. You 
can only configure capacity in a non-partitioned library.

Note: You can click Refresh to discard uncommitted changes and 
restore the last saved configuration. You must apply the configuration 
to save it to the library controller.
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4. In the Select by drop-down list, select a range. Then, select Add (to enable the area 
for activation) or Remove (to deactivate the area).

5. Using the library map, click the storage slots you want to activate or deactivate.

6. When you have completed the configuration, click Apply User Design.

7. Reconfigure library host applications to recognize the changes (see your host 
software documentation and "Updating Hosts After Modifying Capacity" on 
page 8-1).

Capacity Icons

Resetting the Capacity Configuration

Resetting the capacity applies the default capacity as defined by the default capacity 
policy (see "Setting the Default Capacity Policy" on page 6-3).

1. To prevent conflicts, coordinate with other library users before configuring the 
library.

2. In SLC, select Tools > Select Active Cells. Select the Module Map tab.

3. Select any module in the library. Click the Select Active Cells tab.

4. Click Reset to Default.

Note: If you are customizing capacity for the first time, you must 
deselect all storage slots:

1. In the Select by drop-down list, choose Library. Then, select the Remove 
option.

2. Click any "Selected" slot on the module map to make all slots "Inactive".

Caution: If there are warnings, DO NOT commit the changes. Click 
Details >>, and then perform recovery moves on the orphaned 
cartridges (see "Moving Cartridges (Recovery Moves)" on page 11-1).

SLC Icon Description

Not Accessible — slot not available for activation (reserved for diagnostic 
cartridges, physically blocked, and so on).

Inactive — slot not yet licensed for use

Active — slot licensed for use

Selected — slot designated for activation or deactivation

No activation needed — resource is active by default

Caution: Resetting the configuration removes all custom capacity 
activation, partitioning, media validation pools, and resets all SCSI 
element IDs in a SCSI library.
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5. Reconfigure library host applications to recognize the changes (see your host 
software documentation and "Updating Hosts After Modifying Capacity" on 
page 8-1).

Setting the Default Capacity Policy

1. In SLC, select Tools > Configuration.

2. Click the Default Capacity Policy tab.

3. Select the type of capacity assignment for the library:

■ Left to Right (default) — capacity assignment begins in upper left slot on the 
rear wall of the left-most module, moves right, then crosses over to the upper 
left slot on the front wall of the left-most module (see Figure E–6).

■ Center Out — capacity assignment begins nearest to the drives and is split 
evenly between the left/right and front/back.

4. Click Apply.

Displaying the Current Capacity Configuration
1. In SLC, select Tools > Select Active Cells. Select the Module Map tab.

2. Select the module you want to display.

3. Select the Current Active Cells tab. Hover over a slot or drive to display detailed 
information.

Resolving Orphaned Cartridges Caused by Capacity Changes
In a non-partitioned library, an orphaned cartridge is located in an inactive storage slot 
and is inaccessible to all hosts. A cartridge can become orphaned when you reduce 
active storage capacity or manually move a cartridge to an inaccessible slot.

To resolve orphaned cartridges, you can:

■ Generate a report of orphaned cartridges (see "Viewing Active Capacity Reports" 
on page 15-2)

■ Audit the library (see "Auditing the Library" on page 13-1)

■ Perform a recovery move on a cartridge (see "Moving Cartridges (Recovery 
Moves)" on page 11-1)

For partitioned libraries, see "Resolving Orphaned Cartridges Caused by Partitioning 
Changes" on page 7-5.

Note: This setting only defines the assignment order for new 
capacity added in a non-partitioned library. After changing the policy 
setting, you can follow "Resetting the Capacity Configuration" on 
page 6-2 to remove the existing capacity and re-assign it following the 
new setting.
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7Partitioning the Library

Library partitioning reserves library resources (drives, slots, and CAPs) for the 
exclusive use of specified HLI and FC-SCSI hosts. Partitioning is an optional feature 
enabled in SLC.

■ Partitioning Guidelines to Maximize Library Performance

■ Partitioning the Library Using SLC

■ Viewing Current Partition Allocations

■ Partitioning CAPs

■ Resolving Orphaned Cartridges Caused by Partitioning Changes

See Also
■ "Updating Hosts After Modifying Partitioning" on page 8-2

Partitioning Guidelines to Maximize Library Performance
■ Partition storage slots in the largest blocks possible. Cluster cartridges and drives 

together based on workload. Ensure that each partition has an adequate number of 
data cartridges, scratch cartridges, and tape drives to support peak workload.

■ Avoid partitioning individual drives and storage cells. Individually select and 
deselect resources only when you need to fine-tune a partition that has already 
been broadly defined in larger blocks.

■ Install enough CAPs to provide at least one CAP for each partition. This allows 
each partition to contain a dedicated CAP.

■ For quicker enter and ejects, partition storage cells close to the CAPs. For quicker 
access to stored data, partition storage cells close to the drives.

Partitioning the Library Using SLC

■ Adding a Partition ID

■ Deleting a Partition

■ Changing the Partition Interface Type

Note: No partitioning changes occur until you apply the changes 
with the Commit tab. To discard uncommitted changes, click Refresh.
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■ Changing FC-SCSI Host Connection Information

■ Allocating Resources to a Partition

■ Committing Partitioning Changes

Adding a Partition ID
1. Stop any host operations.

2. Select the Tools > Partitions > Summary (Step 2) tab.

3. In the Partition Allocation Summary area, click Add Partition.

4. Select the partition ID, enter a name, and then select an interface type. Partition 
IDs do not need to be consecutive. 

5. Click OK.

6. Repeat steps 3-5 to add up to eight partitions. For FC-SCSI connections, see 
"Adding a FC-SCSI Host Connection" on page 7-2.

7. Proceed to "Allocating Resources to a Partition" on page 7-3.

Adding a FC-SCSI Host Connection
For FC-SCSI partitions, you must add a host connection (HLI host-partition 
connections are configured through the host library management software).

1. Select the Tools > Partitions > Summary (Step 2) tab.

2. In the Partition Allocation Summary area, select the partition.

3. Click Add Connection.

4. Enter the Initiator (WWPN) and LUN. Each initiator connected to the library must 
have one library partition assigned to LUN 0.

5. Click OK.

6. Repeat until you have added all required FC-SCSI connections. Each partition can 
have up to nine host connections, and each host can connect to multiple partitions. 

Deleting a Partition
When you delete a partition, all resources allocated to the partition are marked 
available, all host connections for the partition are deleted, and the partition ID is 
deleted.

1. Move valid data cartridges out of the partition that will be deleted (see "Moving 
Cartridges (Recovery Moves)" on page 11-1).

2. Select the Tools > Partitions > Summary (Step 2) tab.

3. In the Partition Allocation Summary area, click the partition to remove. 

4. Click Delete Partition. 

5. Proceed to "Committing Partitioning Changes" on page 7-4. 

Note: If you deleted all the partitions, you must select a library 
interface type (HLI or FC-SCSI).
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Changing the Partition Interface Type

1. Select the Tools > Partitions > Summary (Step 2) tab.

2. In the Partition Allocation Summary area, select the partition to modify.

3. Click Modify Partition.

4. Proceed to "Committing Partitioning Changes" on page 7-4.

Changing FC-SCSI Host Connection Information
1. Select the Tools > Partitions > Summary (Step 2) tab.

2. In the Connections section, select the host-partition connection to modify.

3. Click Modify a Connection.

4. Proceed to "Committing Partitioning Changes" on page 7-4.

Allocating Resources to a Partition
1. Select the Tools > Partitions > Module Map (Step 3a) tab.

2. Select a module, and then click the Design (Step 3b) tab. 

3. Select a partition ID from the drop-down list.

4. In the Select by drop-down list, select a range. Then, select Add or Remove.

5. Use the library map to select the resources to add or remove. Partitions can be 
non-contiguous.

6. Repeat for each partition ID. When you complete the partition design, click Verify.

7. If there are no warnings, proceed to see "Committing Partitioning Changes" on 
page 7-4.

Partitioning Icons

Caution: Changing the interface type can result in loss of active host 
connections or existing shared CAP assignments.

Note: To re-assign a resource from one partition to another, you must 
remove the resource from the initial partition before re-allocating it.

Caution: If there are warnings, click Details >> and perform 
recovery moves on the orphaned cartridges (see "Moving Cartridges 
(Recovery Moves)" on page 11-1). Then re-verify the design.

SLC Icon Description

(rectangle with X) Not Accessible — resources not available for host operations 
(reserved system slot, physically blocked, and so on).

(white rectangle) Unallocated — resource available for assignment
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Committing Partitioning Changes
You must complete these procedures to make changes to the library.

1. Take the library offline to the host (see your host software documentation). 

2. Click the Commit (Step 4) tab of the Partitions interface.

3. Click Apply.

4. Configure all affected library host applications (see the host software 
documentation and "Updating Hosts After Modifying Partitioning" on page 8-2).

Viewing Current Partition Allocations 
See also "Viewing Partitioning Reports" on page 15-2.

1. Select the Tools > Partitions > Module Map (Step 3a) tab.

2. Click a module to display. 

3. Click the Current Partition Definitions tab. Hover over a resource to display 
detailed information.

Partitioning CAPs

(yellow rectangle) Partition # — resources assigned to the current partition

(red rectangle) Other Partitions — resources assigned to another partition

(gray rectangle) Shared CAP — a CAP assigned to multiple partitions

Note: To prevent configuration conflicts, you should make the 
library unavailable to other users and stop all host operations before 
committing partitioning changes.

Note: If the Apply button is grayed out, the library capacity is 
over-subscribed. Remove storage slots from a partition or purchase 
more capacity.

Caution: If there are warnings, click Details >> and perform 
recovery moves on the orphaned cartridges (see "Moving Cartridges 
(Recovery Moves)" on page 11-1).

Note: AEM CAPs are subject to the same partitioning rules and 
restrictions as rotational CAPs. The term CAP refers to both types of 
CAPs, unless otherwise specified. 

SLC Icon Description
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Each partition can have either dedicated CAPs or shared CAPs, but not both. Only 
partitions with the same host interface type (FC-SCSI or HLI) can share a CAP. Only 
one partition at a time can use a shared CAP.

For information about CAP states in a partitioned library, see "CAP States" on 
page 10-5.

Reserving a CAP in HLI Partitions 
An HLI host can reserve a CAP if the CAP is empty, closed, locked, and not already 
reserved. Each HLI host reserves a CAP for exclusive use as needed, then releases the 
CAP when it is no longer required.

If the host does not release the CAP reservation and you cannot terminate the enter or 
eject operation in ACSLS or ELS, you can override the host partition reservation (see 
"Overriding a Partition CAP Reservation" on page 10-4).

Associating a CAP to an FC-SCSI Partition 
Most FC-SCSI hosts typically assume sole ownership of a CAP. Therefore, when using 
a shared CAP to enter or eject cartridges, you must manually associate a CAP to the 
partition (see "Assigning Ownership of a Shared CAP to an FC-SCSI Partition" on 
page 10-5).

Resolving Orphaned Cartridges Caused by Partitioning Changes
In partitioned libraries, an orphaned cartridge is located in a slot not allocated to the 
original host. Orphaned cartridges can occur when you change the size of a partition, 
delete a partition, or move a cartridge to a slot or drive that is not allocated to a 
partition.

In a partitioned library, orphaned cartridges can cause data loss. A host that finds an 
orphaned cartridge in its partition may treat the cartridge as a scratch volume and 
overwrite the data.

To resolve orphaned cartridges, you can:

■ Generate a report of orphaned cartridges (see "Viewing Partitioning Reports" on 
page 15-2)

■ Audit the library (see "Auditing the Library" on page 13-1)

■ Perform a recovery move on a cartridge (see "Moving Cartridges (Recovery 
Moves)" on page 11-1)

For non-partitioned libraries, see "Resolving Orphaned Cartridges Caused by Capacity 
Changes" on page 6-3.
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8Configuring Host Applications

■ Changing the Host Interface Type of a Non-Partitioned Library

■ Updating Hosts After Modifying Capacity

■ Updating Hosts After Modifying Partitioning

■ Updating Hosts After Modifying the MV Pool

■ Updating HLI Host Management Software for RE

■ Configuring Dual TCP/IP

See Also
■ "Enabling HLI Host Managed Drive Cleaning" on page 9-2

■ "Configuring the Barcode Format for FC-SCSI Hosts" on page 11-4

Changing the Host Interface Type of a Non-Partitioned Library

1. Select Tools > Select Active Cells.

2. Click the Select Active Cells tab.

3. Select the interface type.

4. Click Apply, and then Yes to update the library controller database.

The new interface type is active immediately. You do not need to start the library.

Updating Hosts After Modifying Capacity
■ Updating ACSLS and ELS After Modifying Capacity

■ Updating SCSI Hosts After Modifying Capacity

■ See also: "Configuring Capacity" on page 6-1 to modify capacity

Updating ACSLS and ELS After Modifying Capacity
Initiate an audit through ACSLS and ELS to update the host database (see the host 
software documentation).

Note: For a partitioned library, see "Changing the Partition Interface 
Type" on page 7-3.
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Effect on HLI Hosts After Modifying Capacity
After modifying the capacity configuration, the library controller sends an 
asynchronous message to all hosts notifying them that the library configuration has 
changed. 

After adding active storage slots, the library stays online. Host jobs and connectivity 
are not affected.

After deactivating a storage slot or removing an empty drive slot, the library goes 
offline temporarily. The library comes back online after updating the library controller 
database.

Updating SCSI Hosts After Modifying Capacity
Issue commands to update the host configuration information (see the host software 
documentation).

Effect on FC-SCSI Hosts After Modifying Capacity
After activating or deactivating resources or modifying a host LUN connection, the 
library goes offline temporarily with a "Unit Attention" condition.

After activating or deactivating drives, the library updates the SCSI element 
numbering (see "Default SCSI Storage Element (Cartridges) Numbering Scheme" on 
page E-11).

Updating Hosts After Modifying Partitioning
■ Updating ACSLS or ELS After Modifying Partitioning

■ Updating SCSI Hosts After Modifying Partitioning

■ See also: "Partitioning the Library" on page 7-1 to modify partitioning

Updating ACSLS or ELS After Modifying Partitioning
■ After creating an HLI partition, configure the host connection through ACSLS or 

ELS (see the host software documentation). An HLI partition can have up to 16 
assigned hosts. 

■ After modifying the partitioning configuration, initiate an audit through ACSLS 
and ELS to update the host database. 

Effect on Hosts of Modifying an HLI Partition
For HLI hosts, the partition remains online when you allocate resources to the 
partition. However, the partition will go offline temporarily when you remove 
resources from the partition. The affected partition automatically comes back online 
and the library notifies all hosts connected to the partition of the configuration change. 
Neighboring partitions are not disturbed. 

After allocating or removing resources, hosts experience a brief interruption as library 
configuration information is updated. The host automatically continues to process 
jobs.

Updating SCSI Hosts After Modifying Partitioning
■ After creating an FC-SCSI partition, configure the host-partition connection in SLC 

(see "Changing FC-SCSI Host Connection Information" on page 7-3).
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An FC-SCSI partition can have more than one host-partition connection. The 
connection information consists of the world wide port name of the FC-SCSI host 
bus adapter and the logical unit number (LUN) of the host.

■ After modifying the partitioning configuration, issue commands to update the 
host configuration information (see the host software documentation).

Effect on Hosts of Modifying an FC-SCSI Partition
After adding or deleting a host-partition connection or changing the LUN, the affected 
partition goes offline with a "LUNS Data Has Changed Unit Attention" condition. If a 
host has unique ITL nexus connection mappings for each partition connection, then 
only the partition experiencing the connection change is affected.

After allocating or removing a resource, the affected partition goes offline with a 
condition of "Mode Parameters Have Changed Unit Attention". Neighboring 
partitions are not disturbed.

Updating Hosts After Modifying the MV Pool
■ Updating ACSLS and ELS After Modifying the MV Pool

■ Updating SCSI Hosts After Modifying the MV Pool

■ See also: "Defining the Media Validation Pool" on page 12-1 modify the MV pool

Updating ACSLS and ELS After Modifying the MV Pool
■ For ACSLS, you must initiate reconfiguration after modifying the MV pool. Use 

the config drives <panel_id> utility. For more information, see the ACSLS 
Administrator's Guide.

■ For ELS, no action is required after modifying the MV pool. ELS hosts 
automatically reconfigure. However, the reconfiguration can cause a disruption in 
mount/dismount requests when trying to set a lock on control data sets (see the 
host management documentation).

Effect on HLI Hosts of Modifying the MV Pool
After adding drives to the MV pool, the library (or affected partition) will go offline. 
The affected hosts receive "Configuration Changed", "LSM Ready", and then "Not 
Ready" messages from the library. ELS automatically removes drives moved to the MV 
pool from its configuration. ACSLS automatically updates drives moved to the MV 
pool to an offline state, but ACSLS requires you to initiate reconfiguration. 

After removing drives from the MV pool, the library and partitions remain online. For 
a non-partitioned library, the drive slots are available to hosts immediately. ELS hosts 
begin reconfiguration, but ACSLS hosts require you to initiate reconfiguration. For a 
partitioned library, you must allocate the drive slot removed from the MV pool to a 
partition (see "Partitioning the Library" on page 7-1).

Updating SCSI Hosts After Modifying the MV Pool
Initiate a reconfiguration to update the host configuration information (see the host 
software documentation).
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Effect on SCSI Hosts of Modifying the MV Pool
After adding drives to the MV pool, the library (or affected partition) will go 
offline.The library renumbers element IDs and sends two Unit Attentions: "Not Ready 
to Ready Transition" and "Mode Parameters Changed". You should initiate a 
reconfiguration of the host.

When removing drives from the MV pool, the library and partitions remain online. 
The library logically assigns the drive the last element ID regardless of the drive’s 
physical location. When the library comes back online, SCSI hosts receive two Unit 
Attentions: "Not Ready to Ready Transition" and "Mode Parameters Changed". You 
should initiate a reconfiguration. For a partitioned library, you must allocate the drive 
slot removed from the MV pool to a partition (see "Partitioning the Library" on 
page 7-1).

Effect on SCSI Element IDs of Modifying the MV Pool
Modifying the MV pool can renumber the SCSI element IDs. If renumbering occurs, 
you may need to reconfigure the host.

When you add a drive to the MV pool, the library automatically re-assigns element 
IDs to all drives. The drive slot of the MV drive is treated as "empty" and the library 
does not assign it an element ID (see "Default SCSI Storage Element (Cartridges) 
Numbering Scheme" on page E-11).

When you remove a drive from the MV pool, the library logically assigns it the last 
element ID regardless of the drive’s physical location.

To avoid renumbering, select the drive that is both physically and logically the last 
element ID (verify the drive is a T10000C or D).

Updating HLI Host Management Software for RE
For more information about RE, see "Redundant Electronics Overview" on page B-1.

ACSLS
ACSLS 7.3 or higher is required for RE and you may need to add port connections to 
the libraries. There are two methods:

■ Stop ACSLS. Run acsss_config, specifying the existing ACSs and port 
connections (with the ACSs in the same sequence) and add the new port 
connections. Start ACSLS.

■ Run the config ports utility while ACSLS is running, specifying the existing 
ports in the same sequence and adding new ports at the end. You cannot change or 
delete port connections with config ports.

ELS 
Oracle highly recommends PTFs L1H15S0(VM)/L1H15S1(MVS) for 6.2 and L1H15S2 
for 7.0.
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Configuring Dual TCP/IP

■ Configuring the Library for Dual TCP/IP

■ Configuring an ACSLS Host for Dual TCP/IP

■ Configure an ELS Host for Dual TCP/IP

■ See also: "Dual TCP/IP Overview" on page C-1

Configuring the Library for Dual TCP/IP
Use the route command to manage the routing tables. Define routes for the 2A and 2B 
ports to the hosts.

1. Using the CLI, take both ports offline:

SL3000> network ip link set dev 2A down
SL3000> network ip link set dev 2B down

2. Add the new IP addresses and subnet masks for both ports:

SL3000> network ip address add IP_address/netmask dev 2A
SL3000> network ip address add IP_address/netmask dev 2B

3. To make the change active, bring both ports online:

SL3000> network ip link set dev 2A up
SL3000> network ip link set dev 2B up

4. Enter the network routing configuration for each port:

■ For multiple hosts, add the IP address and netmask for each host:

SL3000> network ip route add IP_address/netmask dev 2A
SL3000> network ip route add IP_address/netmask dev 2B

Table 8–1 HSC/ELS PTF HLI Compatibility Level Support for FRS_4.00 and above

HSC/ELS 
Level

Level 20 or 
Below Level 21 Level 22

Level 23 
Minimum RE 
Support1

1 Can connect to one SL3000 RE library in an ACS string. Only the connected library can be switched through HSC switch 
command.

Level 23 
Enhanced RE 
Support2

2 Can connect to one SL3000 RE library in an ACS string. All RE libraries can be switched through the HSC switch command. 
Supports 32 TCP/IP connections. Includes dual TCP/IP support, display of acs-id, auto CAP recovery, and support for 64 
read in-transit cartridges during cartridge recovery.

Level 23 
Multi-RE 
Support3

3 Can connect to multiple SL3000 RE libraries in an ACS string. Includes same functionality as the enhanced RE support.

6.1 Level 21 PTF L1H14UU (VM)

L1H14UV (MVS)

Unsupported Unsupported Unsupported Unsupported

6.2 Level 21 PTF L1HA4UW (VM)

L1H14UX (MVS)

L1H15DH (VM)

L1H15DI (MVS)

L1H15H9 (VM)

L1H15HA (MVS)

L1H15MF (VM)

L1H15ME (MVS)

L1H168F (VM)

L1H168G (MVS)

7.0 (MVS) Level 21 PTF L1H14UY L1H15DJ L1H15HB L1H15MH L1H168H

7.1 (MVS) Included Included Included Included Included L1H168I

Note: Before configuring dual TCP/IP, gather information regarding 
the network, routing, and IP addresses from the administrator or use 
the appropriate network ip command. 
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■ For a single host, no netmask value is required:

SL3000> network ip policy route add host_IP_address dev 2A
SL3000> network ip policy route add host_IP_address via gateway_IP_address 
dev 2A
SL3000> network ip policy enable 2A |2B
SL3000> network ip policy status

5. Verify the configuration.

SL3000> network ip address show
SL3000> network ip route show
SL3000> network ip policy route show dev 2A |2B

6. Check the date and time for accuracy.

SL3000> time
time print
time HH: MM
time HH:MM:SS

7. Test the configuration to ensure you can access the library through both ports.

Configuring an ACSLS Host for Dual TCP/IP
For the ACSLS server, you should use the acsss_config command or the Dynamic 
Configuration config utility to configure two network interfaces on two separate 
subnets. Use the route command to define the two routes on the ACSLS server. A 
second physical connection improves reliability.

1. Update the routing tables of the ACSLS server by following the ACSLS 
documentation. If there is a single network interface on the ACSLS server, no 
special routing is required on the host.

2. Using the UNIX command prompt at the ACSLS server, use the Dynamic Config 
command to add a port connection to the SL3000.

a. Ensure the ACS is in online or diagnostic mode to ACSLS.

b. Use config port acs_id to add a port.

c. If not already online, bring the ACS online to ACSLS.

3. To remove or replace an existing IP address with a different port:

a. Shut down ACSLS by issuing kill.acsss (for 7.3 and below) or acsss 
disable (for 8.0 and above).

b. Configure the new ports by issuing acsss_config.

c. Bring ACSLS back online by issuing rc.acsss (for 7.3 and below) or acsss 
enable (for 8.0 and above)

For more information, see the ACSLS Administrator’s Guide.

Configure an ELS Host for Dual TCP/IP
1. Update the routing tables of the IBM mainframe by following the ELS 

documentation. If there is a single network interface on the IBM mainframe, no 
special routing is required on the host.

2. At the IBM mainframe console or PARMLIB, use the LMUPATH control statement to 
define network LMU attachments.
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3. Specify a second LMUADDR parameter to define the dual TCP/IPs. ELS 
automatically determines whether the connection is dual TCP/IP or dual LMU.

4. Take the ACS offline, issue the LMUPDEF command, and bring the ACS back online 
to pick up the revised LMUPATH statement that includes the second connection.

For more information, see the ELS documentation.
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■ Enabling Drive Auto Cleaning

■ Enabling HLI Host Managed Drive Cleaning

■ Enabling/Disabling the SCSI FastLoad Feature

■ Adding or Modifying the Drive Tray Serial Numbers

■ Using the Dynamic World Wide Name (WWN) Feature

■ Drive Tray Indicators

See Also
■ "Defining Cleaning Cartridge Usage Count Warning Thresholds" on page 11-4

■ "Viewing Device Status and Properties" on page 14-2

■ "Viewing Library and Device Reports with the Reports Utility" on page 15-1

Enabling Drive Auto Cleaning
Tape drives require periodic cleaning with a cleaning cartridge to prevent read/write 
errors. Drive cleaning can be managed by the library (known as auto cleaning) or 
managed by HLI hosts. 

1. Select Tools > Configuration.

2. Select Enable Auto Clean, and then click Apply.

3. Verify there are enough compatible cleaning cartridges in the library (see "Viewing 
Cleaning Cartridge Status" on page 11-5). 

If necessary, enter or eject cleaning cartridges (see "Importing/Exporting 
Diagnostic and Cleaning Cartridges" on page 11-3).

Note: Library auto clean is enabled by default. If you disable library 
auto cleaning, the host management software must manage drive 
cleaning (see "Enabling HLI Host Managed Drive Cleaning" on 
page 9-2).

Note: If the library is partitioned, you can enable or disable library 
auto clean for each partition.
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4. Set the cleaning cartridge threshold (see "Defining Cleaning Cartridge Usage 
Count Warning Thresholds" on page 11-4).

Enabling HLI Host Managed Drive Cleaning
Tape drives require periodic cleaning with cleaning cartridges to prevent read/write 
errors. Drive cleaning can be managed by either HLI hosts or the library (see "Enabling 
Drive Auto Cleaning" on page 9-1).

1. In SLC, select Tools > Configuration.

2. Deselect Enable Auto Clean, and then click Apply.

3. Enable drive cleaning on the host (see the host software documentation).

4. Import cleaning cartridges using the host software. DO NOT use the SLC 
import/export feature.

Enabling/Disabling the SCSI FastLoad Feature 
Enabling SCSI FastLoad can improve the speed of mount and dismount operations for 
an FC-SCSI library or partition. 

The SCSI FastLoad feature requires minimum SL3000 firmware FRS_2.33 and SLC 
4.47.

You can enable or disable SCSI FastLoad separately for each FC-SCSI partition.

1. Select Tools > Configuration.

2. For each partition, set the Enable FastLoad Feature option:

■ Select to turn SCSI FastLoad on.

■ Unselect to turn SCSI FastLoad off (default).

3. Click Apply, and then click OK. 

How SCSI FastLoad Improves Speed
After a robot mounts a cartridge to a drive, the robot is immediately available for the 
next request and does not wait until the drive reports that the cartridge was loaded. 
The library controller waits to return the mount request response until it detects that 
the tape drive has successfully loaded the cartridge. 

Adding or Modifying the Drive Tray Serial Numbers
1. Select Tools > Configuration.

2. Click the Drive Tray S/N tab.

Note: If the library is partitioned, you can enable or disable library 
auto clean for each partition.

Note: If you enable SCSI FastLoad and a cartridge fails to mount the 
drive, the FC-SCSI host must move the cartridge from the drive back 
to the source location.
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3. Click Refresh to display current configuration data.

4. To edit an individual drive tray serial number:

a. Double-click the Drive Tray S/N field.

b. Enter the drive tray serial number. Proceed to step 6.

5. To edit multiple drive tray serial numbers at once, you can edit a 
comma-separated value (csv) file:

a. Click Export, and then save the file to a desired location.

b. Open the file and edit only the drive tray serial numbers. Do not alter any 
other values. Save the changes.

c. In SLC, click Import. Locate the updated .csv file, and then click Open.

6. Click Apply.

Using the Dynamic World Wide Name (WWN) Feature
The dynamic World Wide Name (dWWN) feature assigns world wide names to drive 
slots rather than the drives themselves. This allows you to swap or replace drives 
without bringing down the entire operating system. Additionally, the WWN remains 
the same even when you partition the library.

Drive Tray Indicators

Figure 9–1 Rear View of the SL3000 LTO Drive Tray
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1. Power to drive (solid green). Power to tray only (blinking green).

2. Maintenance mode (yellow)

3. Okay to remove drive (blue)

4. Power to tray on/off (push button)

5. Ethernet link (green). For HP LTO5/6 drives, this port is for encryption. For IBM 
drives, this port is the maintenance port.

6. Encryption reset to default IP address (push button)

7. Drive status

8. Encryption link (green)
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10Operating a CAP

Use cartridge access ports (CAPs) to enter or eject cartridges from the library. 

■ Guidelines for Using CAPs

■ Entering Cartridges Using a CAP

■ Ejecting Cartridges Using a CAP

■ Locking and Unlocking an HLI CAP

■ Overriding a Partition CAP Reservation

■ Changing the CAP Assignment Mode in a Non-Partitioned FC-SCSI Library

■ Assigning Ownership of a Shared CAP to an FC-SCSI Partition

■ CAP States

■ CAP Modes

■ CAP Usage Order when Ejecting Cartridges with FC-SCSI Hosts

See Also
■ "Partitioning CAPs" on page 7-4

Guidelines for Using CAPs
■ Insert cartridges with the correct orientation (hub gear facing down and label 

facing you). You can skip slots in the CAP when loading cartridges.

■ Verify all cartridges are properly labeled before placing them into a CAP. Do not 
enter unlabeled cartridges

■ To enter cartridges more efficiently, load the CAP magazines prior to issuing the 
enter command.

■ If only one CAP is required to do the job, do not use multiple CAPs. Opening 
multiple CAPs will increase the audit time.

Note: There are two CAP types: rotational CAPs and AEMs. The 
term CAP refers to both types, unless otherwise noted.
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Entering Cartridges Using a CAP
If entering cartridges through a shared CAP of an FC-SCSI partition, see "Assigning 
Ownership of a Shared CAP to an FC-SCSI Partition" on page 10-5.

CAP magazines are removable. You can place cartridges in any magazine slot and in 
any order. After entering cartridges through the CAP, the library moves the cartridge 
from the CAP to a storage slot, records the cartridge's location, and sends the location 
to the host. When the CAP is empty, the library returns the CAP to its default state.

Entering Cartridges Using Rotational CAPs
1. If the CAP is in auto enter mode (see "CAP Modes" on page 10-6), proceed to the 

next step. If it is in manual mode, initiate the enter operation at the host (see the 
tape management software documentation). 

2. Press the CAP button.

The button light turns ON and the door opens.

3. Place the cartridges in the CAP with the hub gear face down and barcode toward 
you.

4. Press the CAP button.

The CAP closes and locks automatically, and the CAP button light turns OFF. 

Entering Cartridges Using AEMs
1. If the CAP is in auto enter mode (see "CAP Modes" on page 10-6), proceed to the 

next step. If it is in manual mode, initiate the enter operation at the host (see tape 
management software documentation).

2. Once the "Unlocked" indicator lights, push the AEM CAP button. 

The "Wait" indicator blinks until the safety door is completely down. Depending 
on the level of activity in the library, this may take several minutes.

3. When the "Enter" indicator light is solid, lift the latch and open the door. Place the 
cartridges in the CAP with the hub gear face down and barcode toward you.

4. Close and latch the AEM access door.

5. Push the AEM CAP button. 

The "Enter" light turns off and the "Wait" light starts blinking. The safety door 
moves up.

Ejecting Cartridges Using a CAP
If ejecting cartridges through a shared CAP of an FC-SCSI partition, see "Assigning 
Ownership of a Shared CAP to an FC-SCSI Partition" on page 10-5.

Once the library ejects all cartridges, the robot audits the CAP to verify it is empty (the 
robot does not read cartridge labels during export operations). Then, the library erases 
the location of the cartridge from the library controller database and the host database. 
The CAP returns to its default state.

Caution: To avoid equipment damage, do not force the CAP to open 
or close. Do not enter unlabeled cartridges or place cartridges 
upside-down.
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Ejecting Cartridges Using Rotational CAPs
1. Initiate the eject operation at the host. Specify the vol-ids of the cartridges to eject 

(see the tape management software documentation).

2. Press the CAP button. The CAP door opens, and the CAP button light turns ON.

3. Remove the cartridges from the CAP.

4. Push the CAP button to close the CAP.

The CAP closes and locks, and the CAP button light turns OFF.

5. The robot continues filling the CAP until all selected cartridges are ejected. Wait 
until the CAP door is unlocked, and then repeat step 2 through step 4.

Ejecting Cartridges Using AEMs
1. Initiate the eject operation at the host. Specify the vol-ids of the cartridges to eject 

(see the tape management software documentation). 

2. Push the AEM CAP button.

The "Wait" indicator blinks until the safety door is in place, and then the "Enter" 
light is solid. Depending on the level of activity in the library, this process may 
take several minutes.

3. Lift the latch and open the door. Remove the cartridges from the AEM CAP. Close 
and latch the AEM access door.

4. Push the AEM CAP button. The "Enter" light turns off and the "Wait" light begins 
blinking. The safety door moves up. If more cartridges need to be exported, the 
robot continues filling the necessary AEMs.

5. The robot continues filling the AEM until all selected cartridges are ejected. Wait 
until the door is unlocked, and then repeat step 2 through step 4.

Locking and Unlocking an HLI CAP
An unlocked CAP is reserved by the library and unavailable to all hosts until it is 
locked. Always attempt to unlock the CAP or AEM access door using the host 
software before using SLC.

Caution: To prevent equipment damage, do not force the CAP to 
open or close.

Note: For HLI hosts, you can select a CAP for the eject operation. For 
FC-SCSI hosts, the library uses CAPs in a pre-defined order (see "CAP 
Usage Order when Ejecting Cartridges with FC-SCSI Hosts" on 
page 10-6).

Caution: To prevent data loss, do not leave expired cleaning 
cartridges in the CAP. The library will treat expired cleaning 
cartridges as new.
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1. In SLC, select Tools > Diagnostics.

2. Expand the CAP folder in the device tree, and then select the CAP to modify (the 
left AEM CAP is column –31 and the right is column 31).

3. Click the Access tab.

4. In the Locked drop-down list select:

■ True to lock

■ False to unlock

5. Click Apply.

Overriding a Partition CAP Reservation
If a CAP reservation is not released by a partition and cannot be terminated on the 
ACSLS or HSC host, use this procedure to override the CAP reservation. 

1. In SLC, select Tools > Shared CAP Assignment. 

2. Expand the CAP folder, and then select the CAP to override (the left AEM CAP is 
column –31 and the right is column 31).

3. Click the Unreserve tab.

4. Click Apply to override the reservation. 

5. Click OK to continue with the override operation. 

6. If the CAP is locked, unlock it using SLC (see "Locking and Unlocking an HLI 
CAP" on page 10-3).

7. Open the CAP. Remove any cartridges and label them with the partition ID.

8. Close the CAP. The CAP status changes to "unreserved".

9. Determine if the cartridges from the CAP should be re-entered into the library and 
then enter the cartridges into the correct partition.

Changing the CAP Assignment Mode in a Non-Partitioned FC-SCSI 
Library

Changing the CAP assignment mode changes the mode for all CAPs in the library. The 
CAP assignment mode controls whether library CAPs can be used for normal host 
operations or for diagnostic moves.

1. Verify that all library CAPs are unreserved, empty, closed, and locked.

2. If you are changing the CAPs to diagnostics mode, stop all host operations (see the 
tape management software documentation).

3. Select Tools > CAP Assignment.

Note: If the CAP is reserved by a host, the host must release the CAP 
reservation before you can unlock the CAP.

Note: You must follow all steps in this procedure or the CAP could 
be left unavailable to all partitions.
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4. Using the Mode drop-down list, select either:

■ Host Operations — causes all CAPs to be available for normal host 
operations. Select this to return the library to normal tape mount or dismount 
operations.

■ Diagnostics — causes all CAPs to be available for diagnostic operations. Select 
this to perform manual cartridge moves, such as moving cleaning or 
diagnostic cartridges from the CAPs to system slots.

5. Click Apply.

Assigning Ownership of a Shared CAP to an FC-SCSI Partition 
You must assign a shared CAP to an FC-SCSI partition to enter or eject cartridges.

■ You can associate only one partition at a time to a shared CAP. 

■ If there are multiple shared CAPs, all of them become associated.

■ A CAP association remains active until you remove it, the library restarts, the CAP 
is reallocated, or the CAP initializes. 

1. In SLC, select Tools > Shared CAP Assignment. 

2. Select the partition. 

3. Click Apply.

4. Perform the enter or eject operation (see "Entering Cartridges Using a CAP" on 
page 10-2 and "Ejecting Cartridges Using a CAP" on page 10-2).

5. Once the enter/eject completes, remove the CAP association by deselecting the 
partition.

6. Click Apply.

CAP States 

Note: If you remove the CAP association while the CAP is open or 
contains cartridges, the library controller assumes ownership of the 
CAP and the CAP becomes unavailable to all partitions. Empty and 
close the CAP before re-associating it. 

Table 10–1 CAP States in Non-partitioned Library

Type of CAP
Default 
State

CAP 
Indicator

HLI in Manual 
mode

Locked Off

HLI in Auto Enter 
mode

Unlocked On

FC-SCSI Unlocked On
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CAP Modes

Auto Enter Mode
Only HLI libraries support CAP auto enter mode (see the tape management software 
documentation).

CAP auto enter mode enables a library operator to open a CAP and initiate an enter 
operation without issuing an explicit enter request. CAPs in auto enter mode are left 
unlocked and do not require a host reservation. In a partitioned library, CAPs must be 
dedicated to use auto enter mode.

Manual Mode
Manual mode is the most secure CAP mode. When in manual mode, the system locks 
a CAP by default. To initiate an enter or eject operation using manual mode, enter an 
explicit enter or eject request before pressing the CAP Open button.

Assignment Mode
Only non-partitioned FC-SCSI host connections support assignment mode. The CAP 
assignment mode controls whether CAPs can be used for normal host operations or 
for diagnostic operations (see "Changing the CAP Assignment Mode in a 
Non-Partitioned FC-SCSI Library" on page 10-4).

CAP Usage Order when Ejecting Cartridges with FC-SCSI Hosts
In a non-partitioned library, the SCSI interface treats all CAPs as one. When you 
initiate an eject operation from an FC-SCSI host, the robot loads cartridges into the 
left-most rotational CAP, then moves right, and then moves to AEMs. For partitioned 
libraries, the CAP priority depends on how CAPs are allocated to partitions.

For the following example, assume an FC-SCSI library with a base module, two CEMs 
(one on each side of the base), and two AEMs (one on each end of the library). For an 
eject operation of 350 cartridges, the robots fills CAP slots in the following order:

Table 10–2 Default States of FC-SCSI CAPs in Partitioned Library

Type of CAP
Default 
State

CAP 
Indicator Comment

Dedicated Unlocked On None

Shared Locked Off Partition-CAP association unlocks the CAP 
and turns the light on.

Table 10–3 Default States of HLI CAPs in Partitioned Library

Type of CAP
Default 
State

CAP 
Indicator Comment

Dedicated or shared Locked Off Host reservation unlocks the CAP and turns 
the light on.

Auto enter mode Unlocked On None

Order Module Number of Cartridges Ejected Total Cartridges Ejected

1st Left CEM 26 26

2nd Base Module 26 52
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3rd Right CEM 26 78

4th Left AEM 234 312

5th Right AEM 38 350

Order Module Number of Cartridges Ejected Total Cartridges Ejected
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11Managing Cartridges

■ Moving Cartridges (Recovery Moves)

■ Locating a Cartridge

■ Importing/Exporting Diagnostic and Cleaning Cartridges

■ Defining Cleaning Cartridge Usage Count Warning Thresholds

■ Configuring the Barcode Format for FC-SCSI Hosts

■ Viewing Cartridge Information

■ Viewing Cleaning Cartridge Status

■ Using Reserved System Slots

■ Cartridge Types

■ Cartridge Handling

See Also
■ "Entering Cartridges Using a CAP" on page 10-2

■ "Ejecting Cartridges Using a CAP" on page 10-2

■ "Resolving Orphaned Cartridges Caused by Capacity Changes" on page 6-3

■ "Resolving Orphaned Cartridges Caused by Partitioning Changes" on page 7-5

Moving Cartridges (Recovery Moves)
Moving a cartridge using SLC only updates the cartridge's location in the library 
controller database. You must perform an audit from the host software to update the 
host database to prevent mount failures.

To view a table of all cartridges in the library, see "Viewing Cartridge Information" on 
page 11-4.

1. Select Tools > Diagnostics. Click the Library in the device tree.

Caution: To avoid data loss, use caution when moving cartridges in 
partitioned libraries. Accidentally moving a cartridge from one 
partition to another will orphan the cartridge and the new partition 
may treat it as a scratch cartridge.
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2. Click the RcvrMove tab.

3. Select the Source Location Mode:

■ For VOLID, enter the vol-id of the cartridge to move.

■ For Location, select the cartridge's current location (CAP, Slot, Drive, 
Reserved Slots).

4. Select the Destination Location type (CAP, Storage Slots, Drive, and Reserved 
Slots) and select the destination address.

5. Click Start.

6. Initiate a library audit from the host software to update the host database (see the 
tape management software documentation).

Locating a Cartridge
You can search for cartridges by volume ID, internal library address, or host address.

To view a table of all cartridges in the library, see "Viewing Cartridge Information" on 
page 11-4.

Locating a Cartridge by Volume ID
1. Select Tools > Diagnostics, and then click the Library in the device tree.

2. Click the Search tab.

3. Select VOLID.

4. Enter the volume ID (use * as a wildcard).

5. From the Requester drop-down list, select the format for the search results:

■ default to display in library internal address format.

■ hli0 or hli1 to display in HLI-PRC address format.

6. Select the Cartridge Type.

7. Click Search.

Locating a Cartridge by Address
1. Select Tools > Diagnostics, and then click the Library in the device tree.

2. Click the Search tab.

3. Select Location.

4. Select the search criteria from the drop-down list, and enter the address (wildcards 
are invalid).

5. From the Requester drop-down list, select the type of address you entered in the 
Location field.

6. Click Search.

Note: Only select Drive if the source is a CAP or reserved slot.

Do not move data cartridges into reserved slots. Reserved slots should 
only contain diagnostic or cleaning cartridges.
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7. Click . . . to see details about the cartridge.

Importing/Exporting Diagnostic and Cleaning Cartridges
The library can perform only one diagnostic or cleaning cartridge import or export 
operation at a time. The library controller reserves the CAP for the entire operation.

Before importing, verify the cartridge has the proper label. Diagnostic cartridges must 
have DG as the first two characters of the eight character volume ID. Cleaning 
cartridges must have CLN as the first three characters.

Importing Diagnostic and Cleaning Cartridges

1. Verify that the library has enough empty reserved system slots. There must be at 
least one empty system slot in the base and DEM for robot recovery or library 
initialization (see "Using Reserved System Slots" on page 11-5).

2. Verify the CAP is empty, not reserved by a host, closed, and locked (see "Viewing 
Device Status and Properties" on page 14-2).

3. In SLC, select Tools > Diagnostics.

4. Expand the CAP folder in the device tree, and then click a CAP to use.

5. Click the Import/Export tab.

6. In the Operation section, select Import Cleaning/Diagnostic cartridges.

7. Click Start. 

8. Load the cartridges into the CAP (follow "Entering Cartridges Using a CAP" on 
page 10-2 starting with step 2).

Exporting Diagnostic and Cleaning Cartridges
1. Verify the CAP is empty, not reserved by a host, closed, and locked (see "Viewing 

Device Status and Properties" on page 14-2).

2. In SLC, select Tools > Diagnostics.

3. Expand the CAP folder in the device tree, and then click a CAP to use. 

4. Click the Import/Export tab.

5. Select a type of export operation. If exporting specific cartridges, select the 
cartridges to export in the "Select Cartridges(s) to export" list.

6. Click Start.

Caution: The library will consider a used cleaning cartridge to be 
new, and set the usage counter to zero. 

Note: Only import cleaning cartridges using SLC if Auto Clean is 
enabled (see "Enabling Drive Auto Cleaning" on page 9-1). For host 
managed drive cleaning, import the cleaning cartridges using the host 
software.
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7. When the unload notification appears, unload the CAP (follow "Ejecting 
Cartridges Using a CAP" on page 10-2 starting with step 2).

Defining Cleaning Cartridge Usage Count Warning Thresholds
The warning threshold should be lower than the cartridge's recommended maximum 
usage to allow time to replace the cartridge (see the drive manufacturers' 
documentation for recommended usage).

When you import a cleaning cartridge into the library, the library controller sets the 
usage count to zero. To display the current usage count, see "Viewing Cleaning 
Cartridge Status" on page 11-5.

1. In SLC, select Tools > System Detail. Select the Library in the device tree.

2. Select Auto Clean, and then the Warning Threshold tab.

3. Select the index number of the cleaning cartridge type to configure.

4. Enter the new warning threshold for the cartridge type. To disable the warning, set 
the threshold to 0.

5. Click Apply.

Configuring the Barcode Format for FC-SCSI Hosts
The barcode format specifies which part of a cartridge barcode the library passes to 
FC-SCSI hosts.

1. In SLC, select Tools > Configuration.

2. From the drop-down list, select the presentation format to use for each partition:

■ all — passes all eight barcode characters to the host.

■ left6 (default) — passes only the six VOLID characters to the host. It does not 
pass the domain and type characters, which are the two characters on the right 
of the barcode.

3. Click Apply.

Viewing Cartridge Information
1. In SLC, select Tools > Reports.

2. Expand the Status Summary folder in the navigation tree.

3. Select the Cartridge Table.

See Also
■ "Viewing Cleaning Cartridge Status" on page 11-5

■ "Viewing Library and Device Reports with the Reports Utility" on page 15-1

Note: The warning threshold for all cleaning cartridges of that type 
will be modified.
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Viewing Cleaning Cartridge Status

1. In SLC, select Tools > System Details.

2. Select the Library in the device tree

3. Click the Auto Clean tab, and then the Cleaning Cartridges tab. 

Cleaning cartridge statuses
■ OK — cartridge is usable for cleaning.

■ warning — usage count has reached or exceeded the warning threshold defined for 
this cartridge type.

■ expired — cartridge has expired based on information from the drives.

Using Reserved System Slots
Both the base module and the DEM have reserved system slots on the lower rear wall. 
Reserved slots store diagnostic and cleaning cartridges imported using SLC and the 
module configuration block. Do not store data cartridges in the reserved system slots.

Figure 11–1 Location of Reserved System Cells

Viewing Cartridges Currently in the System Slots
1. In SLC, select Tools > Reports.

2. Expand Status Summary in the navigation tree.

3. Select the Cartridge Table report.

4. Click the Location Type column heading to sort the table. All system slots have a 
Location Type of "sysCell".

Important: If a drive cannot use a cleaning cartridge, it notifies the 
library that the cartridge has expired. Replace expired cleaning 
cartridges as soon as possible (see "Importing/Exporting Diagnostic 
and Cleaning Cartridges" on page 11-3). 

Note: A cleaning cartridge may not appear in the list if it is in use, in 
transit, or was entered into the library with host software.
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Module Configuration Block
Each module has an identification block with labels that identify the module 
configuration. This block is on the lower rear wall in the fourth column from the left, 
rows 49, 50, 51, and 52. 

During an initialization or after an upgrade, the robotic assembly visits the module 
identification block to determine the module configuration.

The block identifies the: 

■ Type of module — Base Module, Drive Expansion Module, Cartridge Expansion 
Module, Parking Expansion Module, or Access Expansion Module.

■ Back wall configuration — 1 drive array, 2 drive arrays, 3 drive arrays, 4 drive 
arrays, arrays, bulk load magazines, or empty.

■ Front wall configuration — Arrays, cartridge access port, CAP window, empty, or 
bulk load magazines.

■ Options — Arrays, op panel or window, empty, or service bay.

Figure 11–2 Module Identification Block Base Module Example

Special Labels
The CAPID/ label and NOMAG/ label are special labels that do not include an icon. 

■ CAPID/ is mounted only at the top of all CAPs as a generic identifier for the 
library if the CAP does not have any magazines installed on which to target. 

■ NOMAG/ is mounted behind the removable magazines in the bulk load AEM.

Cartridge Types
■ Data cartridges — used to store customer data

Table 11–1 Special Labels

Function Label Text Barcode Icon

Cartridge Access Port ID SPECIAL: CAP IDENTIFICATION CAPID/ None

No Magazines SPECIAL: NO MAGAZINES NOMAG/ None
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■ Diagnostic cartridges — used by service representatives to run read/write tests on 
drives (see "Importing/Exporting Diagnostic and Cleaning Cartridges" on 
page 11-3)

■ Cleaning cartridges — used to clean the tape path and read/write heads of the 
tape drives (see "Importing/Exporting Diagnostic and Cleaning Cartridges" on 
page 11-3)

Cartridge Labels
For information about cartridge label standards, see the Barcode Label Technical Brief on 
OTN. All library cartridges must have a readable external label. The robot reports an 
error when it encounters an unreadable label.

Non-labeled cartridges are not supported. The library exports any non-labeled 
cartridges it finds through the CAP. A non-labeled or unknown type cartridge will not 
mount to a drive.

Cartridge Handling

■ Keep cartridges clean and inspect for damage before each use.

■ Never open a cartridge.

■ Do not handle tape that is outside the cartridge; the tape edge might be damaged.

■ Do not expose the tape or cartridge to direct sunlight, moisture, or magnetic fields.

Inspecting a Cartridge
Always inspect a cartridge before you insert it into a tape drive or a library. A 
defective or dirty cartridge can damage a tape drive. Never use a damaged cartridge. 
Look for:

■ Dirt or debris

■ Cracked or broken housing

■ Damaged write-protect switch

■ Liquid in the cartridge

■ Labels not firmly attached, or that extend over the cartridge edge

Cleaning the Cartridge Exterior
Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. Use Oracle 
StorageTek Tape Cleaner Wipes to clean the cartridges. These wipes are saturated with 
isopropyl alcohol. Do not let any solution touch the tape or get inside the cartridge.

Caution: When cartridges are improperly handled, loss of data or 
damage to a library component can occur.

Caution: To avoid damage to cartridges, do not use acetone, 
trichloroethane, toluene, xylene, benzene, ketone, methylethyl ketone, 
methylene chloride, ethyldichloride, esters, ethyl acetate, or similar 
chemicals to remove labels or clean cartridges.
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Storing Cartridges
Store cartridges in a clean environment. Do not take a cartridge out of its protective 
wrapping until you are ready to use it. Use the tear string, not a sharp instrument, to 
remove the wrapping. Before using a cartridge, ensure that it has been in its operating 
environment for at least 24 hours.
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To validate the integrity of T10000 cartridges using the media validation (MV) feature, 
you must define a pool of T10000C or D drives. The pool is not considered a partition, 
does not contain cartridges, and hosts cannot access the drives in the pool. The library 
automatically cleans MV drives.

■ Media Validation Requirements

■ Defining the Media Validation Pool

■ Starting or Resuming Media Validation

■ Stopping a Validation

See Also
■ "Updating Hosts After Modifying the MV Pool" on page 8-3

Media Validation Requirements
■ Minimum SL3000 firmware FRS_4.30 and SLC FRS_6.50

■ A designated pool of T10000C or D drives at TTI level 5.40 or above

■ High-memory HBT card

■ Minimum STA 2.0 to automate media validation (optional)

Defining the Media Validation Pool

Before defining the pool in a SCSI library, review the "Effect on SCSI Element IDs of 
Modifying the MV Pool" on page 8-4.

1. Verify that hosts are not using the drives that you want to add to the pool (see the 
host management software documentation). Adding a drive to the MV pool will 
trigger a reconfiguration in all ELS hosts attached to the library.

Note: MV drive cleaning occurs regardless of the auto clean status 
for the entire library or partitions. Ensure there are cleaning cartridges 
in the library (see "Importing/Exporting Diagnostic and Cleaning 
Cartridges" on page 11-3).

Important: Hosts cannot access drives in the MV pool.
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2. In SLC, select Tools > Media Validation. Click the Slot Selection tab.

3. Click Refresh to display the latest configuration.

4. Place a maximum of 10 drives into the pool. Select the drive slots, and then click 
Add or Remove.

5. Click Apply. 

6. If using a partitioned library, assign any drive slots removed from the MV pool to 
a partition (see "Partitioning the Library" on page 7-1)

7. Reconfigure host applications (see "Updating Hosts After Modifying the MV Pool" 
on page 8-3).

Media Validation Icons

Starting or Resuming Media Validation
You can only validate one cartridge at a time per each SLC session. To automate the 
process, use StorageTek Tape Analytics 2.0 or above (refer to the STA documentation).

1. In SLC, Select Tools > Media Validation. Click the Media Validation tab.

2. Select a drive. If there are no drives, see "Defining the Media Validation Pool" on 
page 12-1.

3. Select a cartridge from the list or enter a VOLSER in the cartridge label field.

4. Select a validation type (see below for a description).

5. Click Start. Validation begins if the cartridge loads successfully.

Note: When adding drives to the MV pool, the library (or affected 
partition) will go offline.

SLC Drive Icon Meaning

 
Empty drive slot

 
Slot contains either an invalid drive type or a correct drive type in an 
invalid state

 
Correct drive type (T10000C or D) in a valid state

 
Partition number of the drive slot

 
Drive slot is in media validation pool

Note: If you cannot select a drive, it might be the wrong type or in an 
invalid state.

Note: Select Complete Resume or Complete Plus Resume to resume 
a complete validation where it left off.
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After validation completes, the cartridge is returned to its source location. If the 
source location is unavailable, the library moves the cartridge to a system slot for 
host recovery.

Validation Types

Stopping a Validation
If a host requests a cartridge currently being validated, the validation stops. You can 
also stop the validation using SLC.

1. Log in as the user who initiated the validation.

2. In SLC, select Tools > Media Validation.

3. Select the Media Validation tab.

4. Click Stop.

Once validation stops, the library returns the cartridge to its source location. If the 
source location is unavailable, the library moves the cartridge to a system slot for 
host recovery. 

Validation Type Description Starts at
Approximate Duration per 
Cartridge

Basic Verify Mount and dismount to determine if MIR is 
unreadable or out of sync

NA 2 minutes

Standard Verify Reads:

- 1000 records from the beginning of tape

- The wrap that contains EOD, then into the EOD

- Outermost wraps on top and bottom bands to 
verify edges

Beginning of tape Maximum of 30 minutes

Rebuild MIR Reads data at tape speed Invalid position in 
the MIR

T10000C — 5 hours 

T10000D — 9 hours

Complete BOT Reads data at tape speed Beginning of tape T10000C — 6 hours 

T10000D — 9 hours max

Complete Plus 
BOT1

1 Requires decompression and Oracle Key Manager.

Checks Data Integrity Validation CRC to 
determine if it exists

Beginning of tape T10000C— 6 hours for 
compression ratios less than 2.5:1.

T10000D — 9 hours for 
compression ratios less than 3:1
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An audit verifies cartridge locations and updates the library database, which contains 
the volume ID, current location, and verified status for each cartridge.

The library automatically performs an audit after an access door closes or after the 
library initializes.

■ Performing a Physical Audit of the Entire Library

■ Performing a Physical Audit of a Range of Cells

■ Performing a Verified Audit of a Range of Cells

■ Meaning of the Audit Indicator

See Also
■ "Viewing Cartridge Information" on page 11-4

Performing a Physical Audit of the Entire Library

For an entire library audit, the robot visits all slots (storage, CAP, drive, reserved), 
updates the cartridge database, and changes the "verified" status of a cartridge to true.

Although the audit is a background process, it does require sharing of robot resources. 
Do not run this audit during peak activity periods. The audit takes approximately 0.5 
seconds per cartridge slot.

1. In SLC, select Tools > Diagnostics.

2. Select the Library on the device tree.

3. Click the Audit tab.

4. Select Yes for Entire Library (select No for Physical Audit and Verified Audit).

5. Click Audit.

Note: Initiating an audit from SLC only updates the library database. 
To update the host database, you must initiate an audit from the host.

Note: You cannot stop a physical audit after it begins.
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Performing a Physical Audit of a Range of Cells

1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree.

3. Click the Audit tab.

4. Select Yes for Physical Audit (select No for Entire Library and Verified Audit).

5. From the drop-down lists, select the internal address for the starting and ending 
locations of the audit.

6. Click Audit.

Performing a Verified Audit of a Range of Cells
A verified audit validates the status of a cartridge location in the cartridge database. If 
a cartridge address has a verified status of false, the library does a physical audit of 
that location and updates the cartridge database.

1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree. 

3. Click the Audit tab.

4. Select Yes for Verified Audit (select No for Entire Library and Physical Audit).

5. From the drop-down lists, select the internal address for the starting and ending 
locations of the audit.

6. Click Audit.

Meaning of the Audit Indicator
To indicate an audit is in progress, SLC displays a spinning indicator and the message 
"Audit in progress". When you see this indicator, do not open the library access door. 
This will cause the audit to restart.

The audit indicator only displays when an audit is initiated automatically (library 
access door has been opened and closed, library power up, or restart). The indicator 
does not display for audits initiated from SLC or the host.

Note: You cannot stop a physical audit after it begins.
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SLC only displays the latest library and device information saved to the library 
controller database. Click Refresh to update SLC with the latest configuration data.

■ Viewing Library Operational Status

■ Viewing Library Properties and Configuration

■ Viewing Device Status and Properties

■ Viewing the Local Operator Panel Type

■ Meaning of SLC Library and Device Status Indicators

See Also
■ "Generating Reports and Logs" on page 15-1

■ "Viewing Cartridge Information" on page 11-4

■ "Viewing Cleaning Cartridge Status" on page 11-5

Viewing Library Operational Status
1. In SLC, select Tools > System Detail, and then select the Library in the device tree.

2. Click the Status tab.

3. Select a secondary tab:

■ General — displays the current operational state of the library. These values 
update whenever there is host activity, background operations, or operator 
activity. You can place the library online or offline with this tab (see"Taking the 
Library Offline" on page 16-1 and "Bringing the Library Online" on page 16-2).

■ Status Module — displays library status alerts and highlights significant 
messages. This feature is available only if service is active on the library. See 
also "Clearing Library Status Alerts" on page 17-6.

■ HLI — displays the current status of all HLI interface ports on the library. 
Information includes the local TCP/IP socket, local IP, connection status, port 
status, and transmission sent and received from the time of connection.

■ FC-SCSI — displays the current status of all host FC–SCSI interface ports on 
the library. Detailed information is shown by port number. If the Multi Port 
Fibre feature has been activated on the library, detail is shown for all ports.
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Viewing Library Properties and Configuration
1. In SLC, select Tools > System Detail, and then select the Library in the device tree.

2. Click the Properties tab.

3. Select a secondary tab:

■ General — displays the physical, mechanical, logical, and network 
configuration of the library.

■ Library Controller — displays details of the library controller, including the 
serial number and firmware versions.

■ Drive Controller — displays details of the drive controller, including the serial 
number and current firmware versions.

Viewing Device Status and Properties
You can view information about CAPs, drives, robots, redundant electronics, power 
supplies, and the safety door. You can also view device information using the SLC 
Reports utility (see "Viewing Library and Device Reports with the Reports Utility" on 
page 15-1).

1. In SLC, select Tools > System Detail.

2. Select the device folder in the device tree.

3. For more detailed information, expand the device folder. Select a device.

4. Select a tab. Depending on the device you select, refer to the corresponding 
information below.

Device Status and Properties Information
All devices have the following system detail tabs.

■ Status Tab — displays the current operational state of the device. You can place a 
device online or offline with this tab (see "Taking a Device Offline" on page 16-2 
and "Bringing a Device Online" on page 16-2).

■ Properties Tab — displays device configuration information, including the serial 
number and current firmware levels

Drive Information
Only drives have the following system details tabs.

■ Display Tab — displays network data, the Virtual Operator Panel (VOP) for 
T10000 and T9840D drives, and drive LED status

■ Drive Tray Tab — displays the current status of a drive tray 

Note: For AEMs, a "closed" door position indicates the safety door is 
completely down and it is safe for you to open the AEM access door.

Drive Status Meaning

Empty No cartridge is mounted to the drive.

Unloaded Cartridge is ready for dismount.
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Redundant Electronics Card Status
■ hbca — Library controller, A (bottom) slot

■ hbcb — Library controller, B (top) slot

■ hbta —Drive controller, A (bottom) slot

■ hbtb — Drive controller, B (top) slot

Viewing the Local Operator Panel Type
1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree, and then click the OpPanel tab.

The type is listed at the bottom of the screen. A W indicates Windows-based and a 
DL or OL indicates Linux-based.

Meaning of SLC Library and Device Status Indicators

Health Status of a Device
This information is found in the device tree of the System Details and Diagnostics 
page.

■ Normal — library device is functioning normally

■ Warning — device is offline or operating in a degraded state

■ Error — device has experienced a failure

Ready Cartridge is loaded.

NotCommunicating Controller card cannot communicate with the drive.

rewindUnload Drive is busy rewinding and unloading.

Card Status Meaning

Duplex: Software ready, 
switch possible

Active library controller is functioning normally.

Not installed Card is not installed in the library.

Ok Active or standby drive controller card is functioning normally.

Pre-standby: software 
not ready

Standby library controller card is loading standby code and is not 
ready to be used in an automatic failover or manual switch.

Standby: software ready Standby library controller card is functioning normally and can be 
used for an automatic failover or manual switch.

SLC Icon Definition

Normal

Warning

Error

Drive Status Meaning
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Communication Status
This information is found in lower left of all SLC screens. Indicates the communication 
status between SLC and the library controller.

■ Normal — SLC is communicating normally with the library controller

■ Warning — server is taking longer than 10 seconds to respond

■ Error — server is taking longer than 30 seconds to respond

After about 30–60 seconds of lost communication, the heartbeat monitor turns gray, 
then red, and the following error message appears:

Heartbeat message not received from the library controller.

Log off SLC, and then log on again to restore communication.

Health Status of the Library
This information is found in lower right of all SLC screens.

■ Normal — all library devices are functioning normally

■ Warning — one or more library devices is offline or operating in a degraded state

■ Error — one or more library devices has experienced a failure

After a device error is fixed, the library health indicator changes to "Warning". The 
indicator will not change to "Normal" until the library is taken offline. If there are 
multiple problems with a device or status alert condition, the health indicator 
displays the most severe condition.
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■ Viewing Library and Device Reports with the Reports Utility

■ Viewing Active Capacity Reports

■ Viewing Partitioning Reports

■ Generating Diagnostic Files for Oracle Support

■ Monitoring Library Events

See Also
■ "Viewing Library and Device Information" on page 14-1

■ "Viewing Cartridge Information" on page 11-4

■ "Viewing Cleaning Cartridge Status" on page 11-5

Viewing Library and Device Reports with the Reports Utility
All report output is a static display of information at the time the report is generated. 
Click Update in the upper right corner to refresh the information. 

1. In SLC, select Tools > Reports.

2. In the navigation tree, expand a report folder. Select a report.

Note: Running multiple instances of SLC on the same workstation 
can cause inconsistent report data. Only one user at a time should 
produce SLC reports.

Folder Report Description

Statistics Drive Events Displays drive events and errors. The report can display up to 70 entries.

Drive Media Events Displays cartridge error events that have occurred with a drive. The report can 
display up to 500 entries.

General Events Displays a summary of library operational events.

Media Events Displays cartridge errors. The report can display up to 2000 entries.

Log EventLog Displays a log of events based on severity (see "Severity" on page 15-5).
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Viewing Active Capacity Reports
The active slot reports only display data saved to the library controller database.

1. Click Tools > Select Active Cells, and then click the View Reports tab.

2. Select a report:

■ Cartridge Cell and Media Summary — displays a detailed list of all library 
resources and their status (active or inactive).

■ Orphaned Cartridge Report — displays a detailed list of all orphaned 
cartridges.

3. To save the report as a comma-sperated value (csv) file, click Save to File.

Viewing Partitioning Reports
You can generate reports to assist in partitioning management and design.

1. Select the Tools > Partitions > Reports tab.

2. Select a report from the menu:

■ Cartridge Cell and Media Summary — displays a list of all resource partition 
assignments. 

■ Host Connections Summary — displays host-partition connection 
information. 

■ Orphaned Cartridge Report — displays a list of all orphaned cartridges. 

■ Partition Details — displays information for a selected partition. 

■ Partition Summary — displays summary information for all partitions. 

Status Summary Cartridge Table Lists cartridge location, media type, label, and status information.

Device Reserve Table Lists elevator, robot, and PTP reservation information.

Drive Table Lists drive location, type, and serial number information.

CAP Summary Lists the location of the CAPs.

Cartridge Summary Lists the location, media type, and label information for all cartridges in the library.

Drive Summary Lists drive location, type, serial number, code information, and device details.

Library Information Lists the library physical configuration, code version, and state of the library.

Robot Summary Lists robot address and state.

Status Detail CAP/Drive/Robot 
Details

Lists identifying information, code version, and status of the devices.

Library Details Lists the library physical configuration, code version, and state of the library.

Versions Hardware Versions Lists the FRU serial number for controller cards, CAPs, robots, and PTPs.

Software Versions Lists the code version for controller cards, CAPs, elevators, robots, and PTPs.

Audit Log Feature Audit Log Lists all feature activation activity for the life of the library. To view only the current 
hardware activation files, see "Displaying Current Hardware Activation Files" on 
page 5-2.

Folder Report Description
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Generating Diagnostic Files for Oracle Support
Your Oracle support representative might request that you capture and transfer the 
Management Information Base (MIB) or Log Snapshot file.

Transferring the Library MIB File
1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree.

3. Click the TransferFile tab.

4. Select SNMP MIB. Click Transfer File.

5. Save the file using a .txt suffix.

6. E-mail the file to your Oracle support representative.

Transferring the Library Log Snapshot File
You must save the log within 15 minutes of generation. The file is encrypted.

1. In SLC, select Tools > Diagnostics.

2. Select the Library folder in the device tree.

3. Click the Transfer File tab.

4. Select Log Snapshot.

5. Select either All Devices or Selected Device. If you choose Selected Device, select 
the device.

6. Click Generate Log Snapshot on Library.

7. Click Yes, and then OK.

8. Click Transfer Log Snapshot To Your Computer.

9. Save the file using the automatically generated name. 

10. E-mail the file to your Oracle support representative.

Monitoring Library Events
The library controller continually monitors library operations and logs all events. 
Using the Monitors utility of SLC, you can open an event monitor to display event 
data or spool it to a file. Event monitors are useful tools for root cause analysis.

■ Starting an Event Monitor

■ Saving Event Monitor Data to a File

■ Displaying Result Code Definitions

■ Event Monitor Types

Starting an Event Monitor
1. In SLC, select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree.

3. Click an event monitor type, and then click Open.
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4. Use the Monitor menu to pause, resume, stop, or clear the event monitor. Use the 
Spool File menu to save the event monitor to a file (see "Saving Event Monitor 
Data to a File" on page 15-4).

Saving Event Monitor Data to a File
You may need to send the file to your Oracle support representative to assist in 
diagnosing problems.

1. Open an event monitor (see "Starting an Event Monitor" on page 15-3).

2. In the event monitor window, select Spool File > Start Spooling.

3. Select a directory and file name. Click Save.

4. To stop spooling, select Monitor > Stop Spooling.

Displaying Result Code Definitions
Result codes identify the library event type (result codes are the same as library 
EventIds).

1. In SLC, select Tools > Diagnostics. Select the Library in the device tree.

2. Click the Search tab.

3. In the Search Type list, select Result Code.

4. To search for a specific result code, enter the complete code (wildcards or partial 
codes are invalid)

To list all result codes, select List All.

5. Click Search.

Event Monitor Types
There are four types of event monitors: All, Error Warn Info, Error and Warnings, and 
Errors. Each monitor type logs events based on the severity of the event. For example, 
the Errors monitor only logs error events (see Severity for a description of the event 
types).

Each event logged in the event monitor contains the following information:

Time
Identifies when the event occurred.

Device ID
Identifies the library address of the device corresponding to the event.

User
Identifies the user that originated the event. This is "root" for HLI or SCSI host 
activities.

I / F
Identifies the interface type of the requester. The interface can be hli, scsi, or default 
(for SLC or CLI requests). 

Note: To arrange multiple event monitors on one screen, use the 
Window menu in the upper right corner.
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Activity
Identifies the command that was issued, such as "load drive".

Request Identifier
Identifies all host interface requests. Helps track the sequence of log activity resulting 
from each host request.

Severity
Identifies the significance of the event. Some event data is non-volatile, meaning it 
persists across system power cycles.

Error — non-volatile data indicating a fault that prevented a request (host or 
diagnostic) from completing successfully.

Warning — non-volatile data indicating a fault that has not stopped the library's ability 
to complete requests (host or diagnostic). A warning can identify a loss of performance 
or a condition that may indicate future irrecoverable errors.

Information — volatile data indicating general device or library information (such as 
the device state, device added, listener registered, tray serial number updated, and so 
on). This information may be important to establish a history of activity for the 
warning or error event.

Trace — volatile data indicating diagnostic activity tracing.

Result Code
Identifies the library event type (result codes are the same as library EventIds). To 
search for the meaning of the Result Code using SLC, see "Displaying Result Code 
Definitions" on page 15-4 or refer to the SL3000_FRSxxx_JavaErrorCodes.html file 
included in the library firmware code package.

Result Text
Provides information about the results of the request or event.
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16Changing Online/Offline Status and Rebooting

■ Taking the Library Offline

■ Bringing the Library Online

■ Taking a Device Offline

■ Bringing a Device Online

■ Rebooting the Local Operator Panel

■ Rebooting an AEM Safety Door

■ Rebooting the Library

Taking the Library Offline

1. Take all library drives offline (see "Taking a Device Offline" on page 16-2).

2. In SLC, select Tools > System Detail.

3. Select the Library folder in the device tree.

4. Click the Status tab, and then the General tab.

5. In the Transition Request field, click Take offline. 

6. Click Apply. Before the library goes offline, all outstanding library jobs complete.

7. Wait for the offline confirmation message. If the library does not go offline, check 
the status of the library (see "Viewing Library Operational Status" on page 14-1).

When to place the library offline:
■ Before powering down the library

■ Before opening a library access door

■ When the library is inoperative and requires maintenance

Note: Always attempt to take the library offline with ACSLS or ELS 
tape management software before using SLC.
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Bringing the Library Online

1. In SLC, select Tools > System Detail.

2. Select the Library in the device tree.

3. Click the Status tab, and then the General tab.

4. In the Transition Request field, click Bring online.

5. Click Apply.

6. If applicable, bring the library online to the hosts (see the host software 
documentation).

Taking a Device Offline

1. In SLC, select Tools > System Detail.

2. Expand the device folder (CAP, robot, or drive). Select the device to modify.

3. Click the Status tab.

4. In the Transition Request list, select Take Offline. The system completes all 
outstanding jobs for the device before taking the device offline.

When a robot goes offline, it moves to the end of the rail and becomes unusable by 
the library. If the library is using the redundant robotics feature, the second robot 
will take all requests.

5. Click Apply. 

Bringing a Device Online

1. In SLC, select Tools > System Detail.

2. Expand the device folder (CAP, robot, or drive). Select the device to modify.

3. Click the Status tab.

4. In the Transition Request list, select Bring Online. 

5. Click Apply.

Note: Always attempt to bring the library online with ACSLS or ELS 
tape management software before using SLC.

Note: Always attempt to take a device offline with ACSLS or ELS 
tape management software before using SLC.

Note: Library devices that are offline and in an error state cannot go 
online. You must correct the error first.
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Rebooting the Local Operator Panel
You may need to reboot the local operator panel if it hangs or the help content is not 
visible. You can reboot at the local operator panel or from a remote SLC session.

1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree, and then click the OpPanel tab.

3. Click the Reboot Operator Panel button.

4. If rebooting from the local operator panel, the screen will go blank. The reboot is 
complete when the operator panel comes back online.

If rebooting from a remote SLC session, "Reboot Complete" indicates the reboot of 
the local operator panel has finished.

Rebooting an AEM Safety Door 
Use the Tools > Diagnostics utility to reboot an AEM safety door. You may need to 
reboot the door to clear errors when the AEM safety door is in an abnormal condition. 

1. In SLC, select Tools > Diagnostics.

2. Expand the Safety Door folder, and then select the AEM safety door. 

3. Click Reboot.

4. If the safety door is online, click OK to take the safety door offline. 

5. Click OK to confirm the reboot. The library controller reboots the safety door. The 
safety door re-initializes, and the robot audits the AEM.

Rebooting the Library
Rebooting the library involves reloading the firmware from flash memory and 
restarting the library controller.

1. In SLC, select Tools > Diagnostics.

2. Select the Library in the device tree.

3. Click Reboot. 

4. All other users must log off. Click OK. 

5. If the library is online, click OK to take the library offline. 

6. Click OK to reboot the library.

7. Click OK to terminate this SLC session. Do not log back in to the SLC until the 
library has fully initialized.
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17Troubleshooting

■ Basic Troubleshooting

■ Running a Library Self-Test

■ Running a Device Self-test

■ Diagnosing Robotic Issues

■ Determining the Status of an RE Controller Card

■ Initiating a Manual RE Switch Using SLC

■ Clearing Library Status Alerts

■ Calibrating the Touch Screen

■ Troubleshooting Host Connectivity

See Also
■ "Changing Online/Offline Status and Rebooting" on page 16-1

■ "Generating Diagnostic Files for Oracle Support" on page 15-3

■ "Monitoring Library Events" on page 15-3

■ "Servicing the Library" on page 18-1

Basic Troubleshooting
Before you run diagnostic tests or contact Oracle support, review the following 
troubleshooting tips.

Service Required (amber) LED is constantly on
Use SLC to check the health of the library and the devices (see Chapter 14, "Viewing 
Library and Device Information").

To perform a health check:

1. Log in to SLC.

2. Access the System Detail module, Tools > System Detail.

3. Check the device in the device tree for the following indicators: Device Healthy or 
Device Error

Additional checks:

1. Check the Status (for example, online/offline) and Statistics (for example, uptime, 
downtime, errors and warnings) tabs for more information on the health of the 
library and devices.
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2. Make sure the cartridges are fully seated and properly oriented in their storage 
slots.

3. Inspect for any foreign objects or debris and remove them if found.

Library does not turn on and SLC does not display any messages
1. Check that the library power switch is in the ON position.

2. Check all power cord connections.

3. Make sure that there is power to the outlet.

4. Replace the power cord.

CAP Open LED is on and blinking
Open the CAP and make sure the cartridges in the CAP slots are properly seated. 
Close the CAP.

SLC does not display modified data or information remains static
Check the SLC Heartbeat icon.

Robot Fault or Library Fault Amber LED is constantly on
1. Check SLC for any displayed error messages.

2. Open the front door. Observe the state of the cartridges, robot hand, and tape 
drives.

3. Make sure cartridges are fully seated and properly oriented in their storage slots.

4. Make sure packing materials have been removed.

5. Remove any objects or debris from the library floor.

6. Check the status of the tape drives.

7. Close the front door.

8. Make sure the tape drives are fully seated and locked forward by pushing and 
pulling on the rear of the drive tray. Any motion of the tray indicates that it 
requires re-seating and locking down.

Client computer cannot communicate with the library or tape drives
Make sure cables are securely attached to their connectors on the rear of the library, the 
tape drives, and the client computer.

Library cannot communicate with the drives and drive status on SLC displays "Not 
communicating" 
Make sure cables are securely attached to their connectors on the rear of the library, the 
drives, and the client computer.

Repeated or excessive drive cleaning or cleaning messages
1. Replace the cleaning cartridge with a new one.

2. Run the Library Self-Test and note if errors are reported for the drive.

3. Run any client computer-based drive diagnostic tests.

Running a Library Self-Test
Use library self-tests to help diagnose issues. Library self tests can be non-disruptive 
(cartridges are returned to their original locations) or disruptive (cartridges may be 
placed in new locations).
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1. Make sure the proper drive diagnostic cartridges are in the library (see 
"Importing/Exporting Diagnostic and Cleaning Cartridges" on page 11-3).

2. In SLC, select Tools > Diagnostics, and click the Library folder.

3. Click the SelfTest tab.

4. In the Mode list, select the type of self-test:

■ Non-Disruptive — all cartridges used in the test are returned to their original 
locations

■ Disruptive — cartridges may be returned to new locations. The library must 
be taken offline to all hosts before running this test.

5. Click Run. Test results display when the test completes. 

6. For disruptive tests, bring the library online to resume normal operations.

What the library checks during a self-test:
■ Verifies the communication path between the library controller, drives, elevators, 

and robots.

■ Performs get and put operations to check the health of the robots, elevators, and 
CAPs. This includes get and put operations from a reserved system slot to a 
random empty storage slot or CAP slot.

■ Audits the entire library.

■ Performs mounts and dismounts of diagnostic cartridges for all the drives 
installed in the library. The self-test does not begin unless a diagnostic cartridge is 
found in the system slots. If the system finds a compatible diagnostic cartridge, the 
self-test repeats for each drive type. If the system does not find a diagnostic 
cartridge for a drive type, the system skips the mount/dismount operation for the 
drive.

Running a Device Self-test
Use device self-tests to help diagnose issues. A self-test can be performed on a CAP, 
robot, or drive.

1. In SLC, select Tools > Diagnostics.

2. Expand the device folder (CAP, Robot, or Drive). Select the device to test.

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive.

5. Click Run. A message appears when the test finishes.

 Note: Before performing a disruptive test, the library must be taken 
offline (see "Taking the Library Offline" on page 16-1).

Note: To perform a drive or robot self-test, diagnostic cartridges 
must be available in the library ("Importing/Exporting Diagnostic and 
Cleaning Cartridges" on page 11-3).
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Diagnosing Robotic Issues
Diagnostic moves can help monitor or diagnose robotic problems by issuing a series of 
"get" and "put" operations. The system chooses a robot for the diagnostic move based 
on the minimum and maximum ranges set for the target and pool addresses. Multiple 
robots may be selected if the address range requires it. 

Successful diagnostic moves do not rearrange the cartridges in the library — the 
system returns cartridges to their original locations. However, some diagnostic move 
failures can cause cartridges to be left in new locations.

■ Defining a Diagnostic Move

■ Starting a Diagnostic Move

■ Saving a Diagnostic Move

■ Monitoring and Controlling Open Diagnostic Moves

Defining a Diagnostic Move

You can set up and run multiple diagnostic move routines simultaneously if the target 
and pool ranges for each diagnostic move do not overlap.

1. Select Tools > Diagnostics. Select the Library in the device tree.

2. Click the DiagMove tab, and then the Manage tab.

3. In the Defined Sequence section, click Add.

4. Define the target address range (the area used for "get" operations).

a. Select a slot type.

b. Select the starting and ending locations for the range.

5.  Click Next.

6. Define the source address range (the area used to supply cartridges or empty slots 
if a target address does not contain a cartridge or no empty slots are available.)

a. Select a slot type.

b. Select the starting and ending locations.

7. Click Next.

8. Name the move and specify a move count (between 1 and 5000).

9. Select an access order., move type, and enable/disable the pre-move compatibility 
check (see below for details).

10. Click Finish. The new diagnostic sequence is listed in the Defined Sequences 
section. See "Starting a Diagnostic Move" on page 17-5.

A diagnostic move is defined by:
■ Target Address Range — defines the area used to perform the "get" operation in a 

diagnostic move. Valid target address types are storage slots, CAP, drive and 
storage slots, system slots, or all.

Note:  Diagnostic moves require sharing of robot resources. You 
should not run a diagnostic move during peak activity periods.
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■ Pool Address Range — defines the area used to supply cartridges or empty slots if 
a target address does not contain a cartridge or no empty slots are available. The 
pool and target address can overlap.

■ Access Order — determines how the robot performs get operations within the 
target address range. There are two options:

– Sequential — robot performs a get operation starting with the first location in 
the target address range. The robot continues visiting the locations 
sequentially through the range until it completes the requested number of 
moves.

– Random — robot randomly picks a location in the target address range to get a 
cartridge. The robot can also visit the same location in the target address range 
multiple times to get a cartridge; however, if you specify enough move 
requests, the robot is guaranteed to visit all slots. The random access routine 
ends after the requested number of moves is complete.

Starting a Diagnostic Move

Before starting a diagnostic move, you must define the move (see "Defining a 
Diagnostic Move" on page 17-4).

1. Select Tools > Diagnostics. Select the Library in the device tree.

2. Click the DiagMove tab, and then the Manage tab.

3. In the Defined Sequences section, select a diagnostic move. Click Open.

4. Select File > Start Sequence.

Saving a Diagnostic Move
You can save a defined diagnostic move to a file and use it to restore a move that has 
been deleted from the library or copy it to a different library.

1. Select Tools > Diagnostics. Select the Library in the device tree.

2. Click the DiagMove tab, and then the Manage tab.

3. In the Defined Sequence section, select a diagnostic move, and then click Save at 
the top of the SLC screen.

Monitoring and Controlling Open Diagnostic Moves
To start a diagnostic move, see "Starting a Diagnostic Move" on page 17-5.

1. Select Tools > Diagnostics. Select the Library in the device tree.

2. Click the DiagMove tab, and then the Monitor tab.

Note: All resources within the target address range are reserved. 
However, only the location currently being accessed by the robot for a 
get/put operation is unavailable to the host.

Note: You can run multiple moves simultaneously if the target and 
pool address ranges for the moves do not overlap.
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3. Each monitor window indicates the status of the move:

4. Use the File menu in each Monitor window to start/stop/pause the sequence, 
clear the output window, or start/stop spooling.

Determining the Status of an RE Controller Card
Controller card status is indicated by LEDs on the card and displayed in SLC (see 
"Viewing Device Status and Properties" on page 14-2). You can use the status of the 
card to troubleshoot issues with the library. 

The LEDs and meanings are the same on both card types (HBC and HBT).

Initiating a Manual RE Switch Using SLC
You can also initiate a switching using host software or CLI (see "Ways to Initiate a 
Manual Failover" on page B-3).

This procedure is not available at the local operator panel.

1. Verify the device state of the card indicates "switch is possible" (see "Viewing 
Device Status and Properties" on page 14-2).

2. In SLC, select Tools > Diagnostics.

3. Select the Redundant Electronics folder.

4. Click Apply to begin the switch process. If there is a problem with the standby 
library and drive controller cards, you are not allowed to continue with the switch.

5. If there are no errors, click Yes.

6. Click OK to log off the SLC.

7. Wait until the switch is complete before logging back into the library. You must 
specify the IP address or DNS alias of the new active controller.

Clearing Library Status Alerts
You can only clear alerts marked as "Clearable" and only if service is active on the 
library.

Status Indicators Valid Values

Spooling Status — whether the move output is being saved to a file True, False

State — execution state of the move Running, pausing, paused, 
stopping, stopped

Health — health state of the move OK, warning, error

Completed moves — number of moves completed Count

Controller Card LED Definition

ACTIVE - Green Card is functioning as the active and is running active code.

STANDBY - Amber Card is functioning as the standby and is running standby code.

FAULT - Red Card has experienced a serious error.

EJECT OK - Blue Support representative can safely initiate a card eject. 
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Clearing an alert only removes it from the Status Module display; it does not resolve 
the underlying cause. The library health indicator returns to "Normal" if there are no 
other device or status alerts. If the alert is subject to periodic updates, it will reappear 
at the next update cycle. 

1. Select Tools > System Detail, and click the Library folder.

2. Click the Status tab, and then the Status Module tab.

3. On the Clear Alert Number list, select the alert number to clear, and then click 
Apply.

Calibrating the Touch Screen
Alignment of the touch screen is calibrated at the factory. If the touch screen becomes 
mis-aligned, you can re-calibrate or reset it. The method of calibration depends on the 
operator panel type (see "Viewing the Local Operator Panel Type" on page 14-3).

■ If you have a Linux-based local operator panel (DL or OL), you can re-calibrate it 
yourself or reset it to the factory setting with the procedures below.

■ If you have a Windows-based local operator panel (W), contact your Oracle 
support representative.

Re-calibrating the Local Operator Panel
For an accurate calibration, make sure there is no debris on the touch screen.

1. Log in to the local operator panel.

2. Select Tools > Calibrate.

3. Tap Calibrate.

4. A series of targets will display. Gently tap in the center of each target with your 
finger or a pointing stylus.

5. To save the new settings:

a. Tap the Click Me buttons within the indicated time period.

If the buttons do not depress, the touch screen is not properly aligned. Discard 
the new settings and see Step 6.

b. Click OK to save the new settings.

6. To discard the new settings:

a. Let the timer run out without tapping the Click Me button.

b. Return to Step 4 and re-calibrate.

The local operator panel reboots automatically after an unsuccessful second 
calibration and restores the previously saved alignment.

Resetting the Local Operator Panel Calibration to the Factory Setting
1. Log in to the local operator panel.

2. Select Tools > Calibrate.

3. Click Reset Calibration. The local operator panel reboots.
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Troubleshooting Host Connectivity
■ Use a sniffer (a device or program that traces the network traffic for the library).

■ Display the port statistics on the switch or router to which the library is connected. 
Search for any errors that were encountered.

■ Run a trace with the library management software that displays host-to-library 
packets and transmissions.

■ Make sure that two separate hosts are not competing to manage one library or one 
partition.
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18Servicing the Library

■ Turning Off the Library

■ Turning On the Library

■ Entering the Library

■ Opening the AEM Access Door

■ Manually Cleaning a Drive

■ Manually Mounting and Dismounting a Cartridge

See Also
■ "Troubleshooting" on page 17-1

Turning Off the Library

1. Ensure all library requests have completed.

2. Take all library drives offline (see "Taking a Device Offline" on page 16-2).

3. Take the library offline (see "Taking the Library Offline" on page 16-1).

4. Open the rear doors of the Base Module (and DEM if present).

5. Turn off the power enable switches.

6. If necessary, turn off the circuit breakers on the PDUs.

Turning On the Library
1. Open the rear doors of the Base Module (and DEM if present).

2. If necessary, turn on the circuit breakers on the PDUs.

3. Turn on the power enable switches.

The library goes through the initialization sequence. If someone opened the access 
doors while the library was off, the library performs a full audit.

Caution: If you shut off power to the library without performing the 
following procedure, you risk possible equipment damage, cartridge 
damage, and loss of data.
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Entering the Library

1. Observe all safety precautions (see "Safety Precautions when Entering the Library" 
on page 18-2).

2. Take all drives offline (see "Taking a Device Offline" on page 16-2).

3. Take the library offline (see "Taking the Library Offline" on page 16-1).

4. Unlock the door.

5. Pull up on the door latch and open the door.

6. Before you exit the library, verify that there are no loose items in the library.

7. Close the door and latch it.

8. Lock the door and retain the key.

9. Bring the library online (see "Turning On the Library" on page 18-1 and "Bringing 
the Library Online" on page 16-2).

Safety Precautions when Entering the Library

■ Verify the library is offline. Do not enter the library or move any of the robot 
mechanisms if you suspect the robots are on.

■ Always leave the access door open while inside the library.

■ Locate the mechanical door releases (yellow handles on the inside of the access 
doors). If the doors close while inside the library, push the mechanical release to 
unlock and open the door.

■ Know the physical restrictions. Be careful not to bump your body or snag clothing 
on the arrays (there is only 0.4 m [18 in.] of aisle clearance).

■ Avoid damaging the robot's mechanical or electronic components when manually 
moving a robot.

Opening the AEM Access Door

This procedure does not lower the internal AEM safety door.

Note: Opening the library main door will trigger a full audit when 
the library comes back online.

WARNING: To prevent injury while inside the library, lock the 
access door open and retain the key.

Caution: Opening the AEM door has the same effects on the library 
as opening the main library door. It causes an abrupt interruption of 
library activity and the library will audit the entire library when you 
shut the AEM door.
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1. Insert the library access door key in the Deadbolt Override lock and unlock the 
door. The key cannot be removed from the lock while it is in the unlocked 
position.

2. Lift the AEM access door latch and open the door. DO NOT force the AEM access 
door to open or close.

Power is cut to the robots, all in-process jobs stop, and the library takes the robots 
and AEM offline.

3. To close the AEM door, close and latch it. DO NOT force the AEM access door to 
open or close.

4. Lock the door and retain the key.

Once the door shuts, the library re-initializes, the robots initialize, the library does 
a full audit, and the library brings the AEMs online.

Manually Cleaning a Drive
Normally, either the library auto clean feature or the host tape management software 
manages drive cleaning. However, there may be occasions when you need to perform 
a manual clean. Refer to the drive manufacturer's documentation for information on 
whether manual cleaning is allowed.

1. Verify that the drive needs cleaning (see "Viewing Device Status and Properties" 
on page 14-2).

2. Display a list of cleaning cartridges (see "Viewing Cleaning Cartridge Status" on 
page 11-5). Verify there is a compatible cleaning cartridge for the drive.

3. Move a compatible cleaning cartridge from a system slot to the drive that needs 
cleaning (see "Moving Cartridges (Recovery Moves)" on page 11-1).

4. When the cleaning operation is complete, move the cleaning cartridge from the 
drive back to a system slot.

Manually Mounting and Dismounting a Cartridge
Refer to the drive documentation before manually mounting a cartridge.

1. Record the vol-id, cartridge location, and the drive slot location provided by the 
library management software.

2. Locate the drive (see "Viewing Library and Device Reports with the Reports 
Utility" on page 15-1).

3. Locate the cartridge (see "Locating a Cartridge" on page 11-2).

4. Enter the library (see "Entering the Library" on page 18-2).

Caution: Cleaning a drive before it is due is not recommended. 
Excessive drive cleaning can wear out a drive head prematurely.

Caution: Keep your hands clear of the drive's mechanical and 
electronic load components.
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5. Orient the cartridge so that the hub gear is facing down and the vol-id label is 
facing you.

6. Push the cartridge into the drive. Do not force the cartridge into the tape drive. If 
you feel some resistance as you insert the cartridge, verify you are inserting the 
correct cartridge type for the drive.

7. To dismount the drive, press the UNLOAD switch on the front of the drive.

If the cartridge does not eject, refer to the drive documentation.
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The CLI is firmware-based. Therefore, some CLI commands listed below may be 
unavailable if you are running older versions of the library firmware.

Admin accessible CLI commands include:

■ audit

■ capCommand

■ cleaning

■ config

■ date

■ drive

■ hwActivation

■ FibreConfig

■ mediaValidation

■ network

■ partition

■ reControl

■ snmp

■ ssh

■ time

■ traceRoute

■ version

■ whereAmi

audit
This command performs a physical audit on all or part of the library.

audit
Displays help for the audit command, the same as "help audit".

audit *
Initiates a physical audit of the entire library. This command returns immediately and 
displays no results.
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Example:

SL3000> audit *
   requestId
   requestId 9
   Done
   Failure Count 0
   Success Count 1
COMPLETED

audit <device address> <address>
Performs a physical audit of a single address and displays the results.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

■ <address> - specifies the slot location to audit in library, rail, column, side, row 
format.

Example:

SL3000> audit 1,1,0,1,0 1,1,-10,1,1
   requestId
   requestId 9
   Attributes Media Label #EMPTY..
   Object     Location    1,1,-10,1,1
   Done
   Failure Count 0
   Success Count 1
COMPLETED

audit <device address> <start address> <end address>
Performs a physical audits of a range of addresses and displays the results.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

■ <start address> <end address> - specifies the starting and ending slot location to 
audit in library, rail, column, side, row format. Only the row is variable between 
the start and end addresses.

Example:

SL3000> audit 1,1,0,1,0 1,1,-10,1,1 1,1,-10,1,5
   requestId
   requestId 10
   Attributes Media Label #EMPTY..
   Object     Location    1,1,-10,1,1
 
   Attributes Media Label EN34410R
   Object     Location    1,1,-10,1,5
   ...
   Done
   Failure Count 0
   Success Count 5
COMPLETED

audit multiRowScan {enable | disable | print} <device address>
Enables or disables multiple row scan audit capability to speed up audit time.

■ print - prints the multi-row scan audit state.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.
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Example:

SL3000> audit multiRowScan print 1,1,0,1,0
   requestId
   requestId 8401
   Attributes Multi Row Scan enabled
   Object     Robot          1,1,0,1,0
   Done
   Failure Count 0
   Success Count 1
COMPLETED

capCommand
This command is for managing CAPs.

capCommand
Displays help for the capCommand command, the same as "help capCommand".

capCommand forceUnreserve <device address>
Forces the release of a CAP. If cartridges are in the CAP, the reservation changes to 
"default". If there are no cartridges in the CAP, the reservation changes to "none".

■ <device address> - specifies the CAP to release in library, rail, column, side, row 
format.

capCommand {lock | unlock} <device address>
Locks or unlocks a CAP specified by the device address.

■ <device address> - specifies the CAP to lock/unlock in library, rail, column, side, 
row format.

capCommand resetCap {left | right | both}
This command forces the reset of a cap string or strings based on the provided side 
argument.

Example:

SL3000> capCommand resetCap right
   requestId
   requestId 17002
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning
This family of commands displays and controls cleaning and diagnostic 
cartridge-related functions within the library. Only customers with the media 
validation feature should use these commands.

cleaning
Displays help for the cleaning command, the same as "help cleaning".

cleaning list {cleaning | diagnostic}
Lists all cleaning or diagnostic cartridges in the system slots.

Example:
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SL3000> cleaning list cleaning
   requestId
   requestId 9001
   Attributes Expired  false
      Label            CLN0080U
      Location         1,1,-12,1,13
      Max Usage Count  100
      Media Type       9840_Cleaning
      Status           ok
      Usage Count      0
Object Cartridge       cleaning

cleaning import <cap device address>
Imports cleaning and diagnostic cartridges to system slots. Only one import/export 
operation is allowed at a time. There must be a minimum 2 empty system slots for 
SL3000 libraries to allow imports. 

■ <cap device address> - specifies the CAP to use for the import operation, in library, 
rail, column, side, row format.

Example:

SL3000> cleaning import 1,1,5,2,0
   requestId
   requestId 10101
   Message CAP open(ing). Place cartridges to import in CAP, then close CAP.Use 
CONTINUE cmd to proceed...
   Done
   Failure Count 0
   Success Count 0
COMPLETED

cleaning export <cap device address> cleaning [select expired]
Exports cleaning cartridges. Only one import/export operation is allowed at a time.

■ <cap device address> - specifies the CAP to use for the export operation, in library, 
rail, column, side, row format.

Example:

SL3000> cleaning export 1,1,5,2,0 cleaning
   requestId
   requestId 9601
   Address      1.1.-12.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to 
proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning export <cap device address> <cartridge address>
Exports a specific cleaning or diagnostic cartridge to the specified cap. Only one 
import/export operation is allowed at a time. 

■ <cap device address> - specifies the CAP to use for the export operation, in library, 
rail, column, side, row format.
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■ <cartridge address> - specifies the location of the cartridge to export in library, rail, 
column, side, row format. The specified cartridge must be in a system slot and 
must be either a cleaning or diagnostic cartridge.

Example:

SL3000> cleaning export 1,1,5,2,0 1,4,-12,1,12
   requestId
   requestId 9601
   Address      1.4.-12.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to 
proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning threshold list
Displays a list of cleaning cartridge types and their warning thresholds. Each cleaning 
cartridge type has 4 attributes: 

■ Index - cleaning cartridge type used by the "cleaning threshold set" command

■ Media type - the type of cleaning cartridge used

■ Maximum usage count - recommended max usage by tape manufacturer

■ Warning threshold value - user-defined threshold that determines when a 
warning status is set for a cleaning cartridge once its usage count reaches that 
threshold.

Example:

SL3000> cleaning threshold list
   requestId
   requestId 15001
   Attributes
   Object     Index               1
              Media Type          SgtUltrium1_Cleaning
              Recommend Max Usage 100
              Warning Threshold   0
   Attributes
   Object     Index               3
              Media Type          T10000_Cleaning
              Recommend Max Usage 50
              Warning Threshold   0

cleaning threshold set <warning threshold value> <list index number>
Sets a warning threshold value for a particular cleaning cartridge type.

■ <warning threshold value> - can be any positive integer up to 1000. A value of 0 
indicates no warning threshold.

■ <list index number> - cleaning cartridge type as specified by the index number from 
the table listing of the “cleaning threshold list” command.

Example:

SL3000> cleaning threshold set 55 11
   requestId
   requestId 15101
   Attributes
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   Object      Success true
   Done
COMPLETED

cleaning driveWarning set { on | off }
Sets the drive cleaning warning flag to either on or off.

■ on - the drive health status will be set to warn if it needs cleaning

■ off - the drive health status is not affected if the drive needs cleaning

config
This command will either display the current physical library configuration or set 
library configuration parameters.

config
Displays help for the config command, the same as "help config".

config print
Displays the current physical library configuration.

config ilc print
Display the ilc status.

config ilc {enable | disable}
Enables or disables the Inter-Library Communications (ILC) LAN. If a disable is 
requested, the library must first be taken offline using the "accessState offline <device 
address>" command.

config print
Displays the current physical library configuration.

config serviceInfo print
Displays the library service information.

config serviceInfo set
Sets service information: contact ‘contactName’ phone ‘phoneNumber’ streetAddr 
‘streetAddress’ city ‘city’ state ‘state’ country ‘country’ zip ‘zipCode’ description 
‘description data’. 

The maximum string length is 31 characters. Each string must be delimited by ‘ ’ 
(single quotes) to provide the ability to use spaces and other characters.

Example:

SL3000> config serviceInfo set city 'Denver' contact 'Andy' country 'USA' 
description 'Manager' phone '303 222-4444' state 'C0' streetAddr '1 tape drive' 
zip '80027'

requestId
requestId 1512402
Device serviceInfo
Success true
Done
Failure Count 0
Success Count 1
COMPLETED



drive

Command Line Interface Reference A-7

date
This command sets the library date in Greenwich Mean Time (GMT).

date
Displays help for the date command, the same as "help date".

date print
Displays the current system date.

date <MM> / <DD> / <YYYY>
Sets the system date. In a library complex, the library with libraryId = 1 is the master. 
Change the date on the master library.

■ <MM> - two digit month

■ <DD> - two digit day

■ <YYYY> - four digit year

drive
This command displays information about the drives or executes the drive utilities 
such as adiEnable, fastLoad, power, and rewindUnload.

drive
Displays help for the drive command, the same as "help drive".

drive adiEnable {on | off | print}
Turns on or off or prints status of drive discovery with ADI. Once enabled, any 
subsequently added drives will attempt ADI drive discovery. To enable ADI for all 
ADI capable drives in the library, the library must be rebooted.

drive fastLoad {on | off | print}
Turns on or off or prints the status of the fastLoad feature. FastLoad changes the 
behavior of drive mounts (move commands). With fastLoad on, the robot will not wait 
for a complete load of a PUT to a drive, but will go immediately to the next operation. 
Also changes the behavior of the rewindUnload command to return immediately, not 
waiting for the drive to unload. The state of the fastLoad applies to all drives.

drive print { <drive address> | * }
Displays summary drive information: location, state, status, type, firmware version, 
interface type, in use, serial number, state (online/offline), status (ok, warning, or 
error), and drive vendor.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

■ * - displays drive information for all drives in the library

drive search {on | off} <drive address>
Causes the green LED on the drive tray to blink. Blinking continues until the search off 
command issued. Used to locate a drive within the library.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

Note: This command only affects commands issued in the same CLI 
session where this command was issued.
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hwActivation
This command activating certain library features after purchasing a hardware 
activation permit.

hwActivation
Displays help for the hwActivation command, same as "help hwActivation".

hwActivation addLicenseFile
Adds a license file. The license file must be named SL3000_license_config.dsf. The full 
path name being /usr/local/SL3000_license_config.dsf.

hwActivation deleteFile <index>
Deletes the specified installed feature file.

■ <index> - specifies file number to delete as specified in the library controller 
hwActivation module database. See "hwActivation listFiles".

hwActivation listFiles
Lists the installed feature files in the library controller hwActivation module database.

hwActivation print
Lists all of the enabled features in the library controller hwActivation module 
database.

FibreConfig
This command obtains and sets multi-port fibre channel configurations for the library 
controller. The Fibre Channels controls and displays by this command are not to be 
confused with the fibre channel configurations to tape drives. This command is only 
available on the SL3000.

fibreConfig print
Displays the status of the library fibre channel connections.

fibreConfig ports print
Displays the number of multi fibre port channels enabled.

fibreConfig config <hard|soft> <loopId> <portNum>
Sets either hard or soft addressing, and sets the fibre loop ID if hard addressing is 
enabled to the provided value. The loop ID is set to 126 if hard addressing is disabled. 
This configuration is on a per port basis.

fibreConfig ports set <number to enable>
Sets the number of multi fibre port channels to enable. The MultiFibrePort license 
limitation and the physical hardware determine the maximum number of ports to 
enable.

mediaValidation
This command manages the media validation feature.

Note: The library must be rebooted when disabling openVolser, 
dualRobot, or redundant electronics.
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mediaValidation
Displays help for the mediaValidation command, same as "help mediaValidation"

mediaValidation print { all | poolOnly } { * | @ }
Displays drive locations of the media validation pool.

■ all - lists all drive slots

■ poolOnly - lists only drive slots in the media validation pool

■ * - displays only information for the target library

■ @ - displays information for the entire complex

mediaValidation reservation clear <drive address>
Clears media validation reservation for specified drive.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

mediaValidation stopValidation <drive address>
Stops a validation currently in progress. Cartridge is returned to source storage slot.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

network
This command configures and displays network configuration for the controller card.

network clone [Port 2B IP address] [Port 2A IP address]
Used for redundant electronics configuration. Copies all port, routing, and IP policy 
configurations to side B HBC. IP addresses are replaced with the ones specified in the 
command for side B. If no port IP address is specified, then they are not set on side B.

network config print
Displays the target library side (A or B) that is set for network commands.

network config side {a | b}
Sets the target library side for network commands.

network config clear
Clears the network configuration. This command stops network connectivity. 
Reconfiguration requires access to the serial port on the HBC card.

network export
Exports library network configuration file (.lnc) and generates a network configuration 
script (.scr). It can only be used in cases where no prior network configurations have 
been set.

network gateway <IP address>
Sets the external network default gateway.

network gateway clear
Clears the external network default gateway.

network import
Imports a library network configuration file (.lnc).

network ip <IP address>
Sets the IP address of port 2B.
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network ip address add <IP address> dev {2A | 2B}
Sets the IP address of a particular port.

network ip address del <IP address> dev {2A | 2B}
Removes the IP address of a port.

network ip address show [dev {2A | 2B}]
Displays the current address information for a particular port or both ports if dev is 
not specified.

network ip link set dev {2A | 2B} {up | down}
Sets the operation status of a port, which controls whether a port can send and receive 
Ethernet traffic.

■ up - sets port online

■ down - sets port offline

network ip policy {enable | disable} dev {2A | 2B}
Enables or disables policy routing for device 2A or 2B.

network ip policy status
Displays policy routing status for devices 2A and 2B.

network ip policy route {add | del} <IP address> dev {2A | 2B}
Adds or deletes a static route to policy for device 2A or 2B.

network ip policy route {add | del} <IP address> via <Gateway IP address> dev {2A | 
2B}
Adds or deletes a static route to policy for device 2A or 2B via gateway.

network ip policy route show [ dev {2A | 2B} ]
Displays policy route information for device 2A or 2B.

network ip route add default via <IP address>
Sets the default gateway routing IP address.

network ip route delete default
Deletes the default gateway routing IP address.

network ip route {add | del} <IP address [/netmask] > dev {1A | 1B | 2A | 2B}
Adds or deletes a static IP (Internet Protocol) routing address for a specified host. This 
command also enables a user to set the netmask for a particular port.

Example:

SL3000>network ip route add 129.80.81.59/24 dev 1B
COMPLETED

network ip route {add | del} <IP address [/netmask] > via <Gateway IP address>
Adds or deletes a static route to a destination network IP gateway address.

network ip route show [dev {2A | 2B}]
Displays the current routing table information or routing table information for a 
particular port.

network name <host name string>
Sets the host name.
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network netmask <netmask>
Sets the external network netmask in xxx.xxx.xxx.xxx form.

network print
Displays the current network configuration for the external Ethernet ports (2A and 
2B).

partition
This command displays the current status or disables the partition feature.

partition
Displays help for the partition command, same as "help partition".

partition autoClean set { * | <Partition Id> }
Set auto clean in a specified partition (0, for a non-partitioned library).

partition attribute status { * | <Partition Id> }
Displays the status attributes of a single specified partition or all partitions.

partition fastLoad set '<partitionId-mode, partitionId-mode, ...>'
Sets the fastLoad mode for a one or more specified partitions. Currently the only valid 
modes are true or false. This command is only available on the SL3000.

Example:

SL3000> partition fastload set '1-true,3-false'
   requestId
   requestId 40901
   Attributes Success true
   Object
   Done
   Failure Count 0
   Success Count 2
COMPLETED

partition getCapacity
Displays the capacity values for library or any defined partitions.

partition get state <Partition Id>
Displays the current state of the specified partition(s). This command is available on 
SL3000 libraries only

partition predefined file <partition file number>
Uses a predefined partition text file to set the library partition configuration. Each file 
name consists of the word “partition” and a numeric value ie “2” and a “.txt” 
extension. The predefined files are below.

partition1.txt – Non-partitioned Base with a HLI interface.
partition2.txt – Non-partitioned Base with a SCSI interface.
partition3.txt – One partitioned Base with a HLI interface.
partition4.txt – One partitioned Base with a SCSI interface.
partition5.txt – Two partitioned Base with a HLI interface.
partition6.txt – Two partitioned Base with a SCSI interface.
partition7.txt – Two partition Base w/DEM HLI and SCSI partitions.
partition8.txt – Two partition Base w/DEM SCSI interface.
partition9.txt – Multiple partitions (stripes) HLI interface.
partition10.txt – Multiple partitions (stripes) SCSI interface.
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partition11.txt – Multiple partitions (random) HLI interface.
partition12.txt – Multiple partitions (random) SCSI interface.

Example:

SL3000> partition predefined file 5
   requestId
   requestId 7601
   Done
   Failure Count 0
   Success Count 1
COMPLETED

partition setCapacity { <Partition Id> , <Capacity> }
Sets the capacity for the designated partition. Existing partitions not listed in the 
command will have their capacity set to zero.

Example:

SL3000> partition setCapacity 1,200 2,50 3,600
   requestId 7601
   Done
   Failure Count 0
   Success Count 1
COMPLETED

partition setNonPartitionedHLI
Sets the partition to hli0. If there are any drives in the media validation pool, they must 
be removed beforehand. If in complex, it sets all the libraries to hli0. 

partition set state {online | offline} <Partition Id>
Sets the current state (offline/online) of a specified partition.

partition set {hli | scsi}
Sets the interface type for the entire library. Available on SL3000 only.

partition status
Displays the current partitioning status.

reControl
This command controls/switches the redundant electronics and retrieves the library 
controller redundant electronics statuses.

reControl
Displays help for the reControl command, same as "help reControl".

reControl status [ <library address> | * ]
Retrieves the redundant electronics status.

■ <library address> - specifies the library in library, rail, column, side, row format. For 
example: 2, 0, 0, 0, 0.

■ * - retrieves status from all libraries in a complex

snmp
This command configures the Simple Network Management Protocol (SNMP). For 
detailed information, see the SNMP Reference Guide on OTN.
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ssh
This command controls configuration for the ssh daemon/server which resides on the 
HBC. This is the protocol utility which SLC and other various applications use to 
connect to the library controller.

ssh print
Prints the current ssh daemon protocol settings.

ssh set version1and2
Sets the ssh daemon protocol restriction to v1 and v2. (this is the default). The ssh 
server is restarted.

ssh set version2
Sets the ssh daemon protocol restriction to v2 only.

time
This command sets the library time in military time notation.

time
Displays help for the time command, same as "help time".

time print
Displays the current system time.

time <HH> : <MM>
Sets the system time. Resolution is within one minute. In a library complex, the library 
with libraryId = 1 is the master. Change the time on the master library.

■ <HH> - two digit hour

■ <MM> - two digit minute

time <HH> : <MM> : <SS>
Sets the system time. Resolution is within one second. In a library complex, the library 
with libraryId = 1 is the master. Change the time on the master library.

■ <HH> - two digit hour

■ <MM> - two digit minute

■ <SS> - two digit second

traceRoute
This command traces the network route to a specified IP address.

traceRoute <IP Address>
Executes a traceRoute to the IP address specified.

version
This command displays the customer version and the versions of the software for the 
device(s) requested.

version print [ <device address> | *]
Displays the software version of code for a device or all devices.
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■ <device address> - specifies the device in library, rail, column, side, row format. 

whereAmi
This command displays the system and logic card information relative to the library 
and card related to the redundant electronics command being executed.

whereAmi
Displays the information relating to where the command is being issued.

Example:

SL3000> whereAmI
   Host Name: gulibtst02b
   Port 2B IP Address: 172.20.151.24
   Library Type: SL3000
   HBC side: B
   Active side: B
COMPLETED
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BRedundant Electronics Overview

The optional redundant electronics (RE) feature provides failover protection for the 
library controller. If the library controller or drive controller experiences errors, 
operations can switch to the standby controller. The library controller and drive 
controller installed on the same side of the card cage are always switched as a pair.

RE allows an Oracle support representative to replace a faulty card while the library is 
online and provides minimal disruption during firmware upgrades.

■ Requirements for Redundant Electronics

■ Redundant Electronics Configuration Examples

■ What Occurs During a Failover

■ Factors that Prevent an RE Switch

■ Factors that Initiate an Automatic Failover

■ Ways to Initiate a Manual Failover

■ Firmware Upgrades when Using RE

See Also
■ "Updating HLI Host Management Software for RE" on page 8-4

■ "Determining the Status of an RE Controller Card" on page 17-6

■ "Initiating a Manual RE Switch Using SLC" on page 17-6

Requirements for Redundant Electronics
■ Two library controller (HBC) cards

■ Two drive controller (HBT) cards

■ Minimum SL3000 firmware version FRS_3.0 and SLC version 5.00

Note: Any reference to the HBC card also refers to the HBCR card.

Note:  To enable ADI mode, both cards must be high-memory HBTs.

If using Media Validation, Oracle recommends both HBT cards are 
high-memory.
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■ Hardware activation file (see "Activating Optional Features" on page 5-1)

■ HLI host with TCP/IP or FC-SCSI host using ACSLS (see "Updating HLI Host 
Management Software for RE" on page 8-4). RE is not available to hosts using a 
native FC-SCSI interface.

Redundant Electronics Configuration Examples
Each library controller card requires its own unique IP address. If the dual TCP/IP 
feature is active on the library, each card requires two unique IP addresses: one for the 
primary port 2B and one for the secondary port 2A. Therefore, a library with RE and 
dual TCP/IP requires four unique IP addresses.

On each controller card, port 2B and 2A must be on different broadcast domains. 
However, port 2B on the active card and port 2B on the standby card can be on the 
same broadcast domain. The same is true for the 2A ports.

Figure B–1 Redundant Electronics Configuration Examples

For more information about dual TCP/IP, see "Dual TCP/IP Overview" on page C-1.

What Occurs During a Failover
In a failover, the active library controller attempts to complete all in-process jobs and 
copies the cartridge database to the standby controller card. If the database cannot be 
copied (usually only in a sudden failure), you must perform an audit after failover (see 
"Auditing the Library" on page 13-1). The library returns any in-transit cartridges to 
their home slots. The library places any cartridges it cannot return to a home slot in a 
system slot for host recovery (see the host software documentation).

After all in-process jobs complete or time out, the cards switch roles. The standby 
controller becomes active and the previously active controller becomes the standby. If 
the previously active controller cannot bring up the standby software, the controller 
enters a fault state.

Effect of a Failover on Users
■ Users of tape management software (Symantec or Virtual Storage Manager) do not 

see an interruption.

■ HLI host applications queue requests during the failover process for completion 
after the failover switch. For ACSLS, only mount and dismount requests are 
affected (see the host software documentation).
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■ SLC and CLI connections are terminated. You must re-establish connections to the 
library using the IP address or DNS alias of the new active library controller (the 
former standby controller).

Factors that Prevent an RE Switch
■ The standby library or drive controller is in a fault or eject state.

■ The standby code is not running on the standby library or drive controller cards.

■ A firmware download or card initialization is in progress.

Factors that Initiate an Automatic Failover
An automatic failover can be initiated by either the active or standby library controller.

The active library controller initiates an automatic failover when:

■ Its partner drive controller card is not installed or it is not communicating.

■ It detects a catastrophic internal software error.

The standby library controller initiates an automatic failover if the active controller is 
not functioning normally.

Ways to Initiate a Manual Failover

■ Host tape management (ACSLS or ELS) — Failover can be initiated from either 
the active or standby library controller. The standby library controller accepts only 
set host path group and force switchover HLI requests.

■ SLC — Failover is initiated from the active library controller only (see "Initiating a 
Manual RE Switch Using SLC" on page 17-6).

■ CLI — Failover can be initiated from either the active or standby library controller. 
This function is only available to Oracle support representatives.

You may want to perform a manual switch after initial installation of the standby 
cards, after a firmware upgrade, or periodically to check that the failover function is 
working properly. It is not possible to manually switch the library controllers without 
the drive controllers — the controllers are always switched as a pair.

Firmware Upgrades when Using RE
Firmware upgrades for libraries with RE are minimally disruptive to library 
operations. You can load and unpack new code simultaneously on the active and 
standby controller cards and on all devices. The code is then activated, and the active 
and standby controllers and most devices are re-initialized. Under most circumstances, 
robot initialization is bypassed.

The loading, unpacking, and activation of code are not disruptive to library operations 
until the library is rebooted. During the reboot process (which takes approximately 10 
minutes), the HLI host applications (ACSLS and ELS) queue all mount and dismount 

Note: Before initiating a manual switch, you should verify that the 
standby library and drive controllers are running normally (see 
"Viewing Device Status and Properties" on page 14-2).
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requests. After the reboot is complete, the queued requests are submitted to the library 
controller.

See "Upgrading Library Firmware" on page D-1 for firmware download and activation 
information.
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CDual TCP/IP Overview

Dual TCP/IP provides two separate connections between the library host (ACSLS or 
ELS) and the HBC/HBCR controller card using primary port 2B and secondary port 
2A. Dual TCP/IP prevents a loss of connection between the library and host by 
automatically avoiding a failing communication path.

■ Minimum Requirements for Dual TCP/IP

■ Using a Shared Network

■ Dual TCP/IP Configuration Examples

See Also
■ "Configuring Dual TCP/IP" on page 8-5

■ ACSLS or ELS documentation.

Minimum Requirements for Dual TCP/IP
■ ACSLS 7.1 with PUT0701 for Solaris or AIX. Oracle recommends ACSLS 8.1 or 

above.

■ NCS 6.2 with the following PTFs for HSC/MVS/VM: SOS620 L1H168G, SMS620 
L1H168F, and MSP: MSP PTF LF620DL.

■ The switch or router ports must be configured to auto negotiate. The SL3000 ports 
are configured to auto negotiate by default and support 10/100 Mbps speeds.

Using a Shared Network

If you must use a shared network:

■ Directly connect the library to a switch or router that filters out undirected 
(broadcast) traffic.

■ Place the library on its own subnet. This may protect the library from receiving 
broadcast messages.

■ Use a managed switch or router to:

– Set priorities on ports to supply the host and library with higher priority.

Note: Oracle recommends a private network for maximum 
throughput, minimum resource contention, and higher security.
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– Provide dedicated bandwidth between the host and library.

– Create a virtual local area network (VLAN) between the host and library.

■ Use a virtual private network (VPN) to insulate host-to-library traffic from other 
interference, such as irrelevant broadcasts.

Network Broadcast Issues on a Shared Network
Broadcasts sent to all network nodes may be directed to the library. The library cannot 
efficiently process requests while it is receiving these irrelevant broadcasts. As a result, 
the host may determine the connection to the library is lost.

Heavy network traffic can also overwhelm the Ethernet controller on the HBC/HBCR 
card. As a result, the controller continuously resets.

ARP Floods on a Shared Network
The SL3000’s processor can be overwhelmed by floods of address resolution protocol 
(ARP) broadcasts. You should connect the library behind a switch or router.

Dual TCP/IP Configuration Examples
■ ACSLS Dual TCP/IP and Shared Subnets Example

■ ACSLS Dual TCP/IP Through a Public Network Example

■ ACSLS High Availability Dual TCP/IP Example

■ See also "Redundant Electronics Configuration Examples" on page B-2 for an 
example of RE and dual TCP/IP

ACSLS Dual TCP/IP and Shared Subnets Example
In this example, the ACSLS server and the library share two separate subnets. The 
SL3000 uses a one-to-one relationship with the network interfaces on the ACSLS 
server. The network interface card on subnet 192.168.0/23 connects to port 2B and the 
network interface card on subnet 192.168.1/23 connects to port 2A.

Routing
Force a relationship by using the UNIX route commands. For more information, see 
the ACSLS Administrator's Guide and SL3000 Installation Manual.

Figure C–1 ACSLS Dual TCP/IP with Shared Subnets

ACSLS Dual TCP/IP Through a Public Network Example
In this example, the ACSLS server contains two network interfaces that reside on two 
separate subnets. Both interfaces pass through a public network and into two different 
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subnets before connecting to the SL3000 library. This configuration uses the same 
commands as in the first example.

Figure C–2 ACSLS Dual TCP/IP

ACSLS High Availability Dual TCP/IP Example
The following example is an ACSLS High Availability (HA) environment that requires 
dual TCP/IP. The purpose of the HA environment is to have two ACSLS servers, one 
active and one standby. In this configuration, two ACSLS servers connect six network 
interfaces (three on each server) to two separate subnets. A third subnet connects the 
two ACSLS servers through a public network.

For more information on ACSLS HA and dual TCP/IP, see the ACSLS Administrator's 
Guide.

Routing
You should separate the SL3000 network interfaces over two different subnets when 
using ACSLS HA. The two different ACSLS servers use different network interfaces; 
therefore, you should add custom route entries to both ACSLS HA servers. Add the IP 
addresses for both servers to the SL3000 configuration.

Routing Tables
Add custom entries to the routing tables on the ACSLS server; however, any 
customized routing table entries will be lost after a restart of the ACSLS server. To 
maintain custom routing table entries, create scripts to add custom routes. Place the 
scripts in the rc directory structure for automatic execution at boot time.

For more information, refer to the ACSLS Administrator's Guide.
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Figure C–3 ACSLS High Availability Dual TCP/IP

ELS/HSC and Dual TCP/IP Example
The following example shows a preferred configuration for mainframe systems using 
dual TCP/IP. The mainframe host contains two network interfaces residing on two 
separate subnets. Each connection travels through a public network, then connects to 
two different subnets before reaching the SL3000 library.

For more information, refer to the ELS documentation.

Figure C–4 ELS/HSC Dual TCP/IP
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DUpgrading Library Firmware

The library controller stores up to two versions of firmware. This allows the library to 
continue normal operations, running one version of firmware, while you load and 
unpack an upgraded version. Since activating firmware requires a reboot, this allows 
you to upgrade firmware at a convenient time for library users.

After activating the upgraded code, the library retains the previous version of code, so 
that you can revert without having to download and unpack it again. However, 
reverting to a previous version of code is not recommended, you should only do so 
when instructed to by Oracle support.

■ Downloading Firmware from My Oracle Support

■ Loading Firmware

■ Activating Firmware

■ Downgrading Firmware

Downloading Firmware from My Oracle Support
1. Go to My Oracle Support (MOS): https://support.oracle.com/

2. Sign in to your MOS account.

3. Click the Patches & Updates tab.

4. In the Patch Search tab, click Product or Family (Advanced).

5. In the Product field, enter SL3000 and then select Sun StorageTek SL3000 
Modular Library System from the drop-down list.

6. In the Release field, select the firmware version.

7. Click Search.

8. Click the link under Patch Name.

9. Click Download and save the file to a location on your system. Extract the ZIP 
archive to a folder on your system.

Note: Library firmware does not contain drive code upgrades (see 
the drive-specific documentation for drive code information).
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Loading Firmware

1. Download the code to the system you will use to run SLC (see "Downloading 
Firmware from My Oracle Support" on page D-1).

2. Review the pre-requisites and code load instructions provided with the download.

3. Log in to SLC.

4. Select Tools > Diagnostics, and then select the Library in the device tree.

5. Click the Load Code tab.

6. Click Browse, and then locate the firmware package on your system. Within the 
firmware package, select the SL3000_FRS<X.XX>_firmware.jar file.

7. In the File Load Console Window, verify the file contents contain the FRS version 
of code you intend to load.

8. Click the Load button. The process could take up to 10 minutes as the library loads 
and then unpacks the code.

9. Verify the package unpacked successfully (Failed 0). If there are any failures, 
contact Oracle support.

Activating Firmware

1. If you have not already downloaded and unpacked the code, see "Loading 
Firmware" on page D-2.

Note: This procedure is for upgrading to firmware FRS_4.50 or 
above. The current firmware must be a minimum of FRS_4.40 and SLC 
6.65. To install an older version, to downgrade firmware, or if your 
current firmware version is below FRS_4.40 contact Oracle support.

Note: Code load is not available at the local operator panel.

Note: To activate code, the library must reboot. Schedule the 
activation accordingly.
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2. Take the library and all drives offline before activating new code (see "Taking the 
Library Offline" on page 16-1).

3. In SLC, select Tools > Diagnostics, and then select the Library in the device tree.

4. Click the Activate Code tab.

5. From the Target drop down list, select the code package to activate (in this case 
SL3000 Code). In the Available Versions section, select the code version to activate 
(usually the highest FRS version listed). 

6. Click the Activate button. Read the caution, and then click OK. Approximate 
activation time is 45 minutes.

7. Once the Overall Progress bar reaches 100%, verify that the code activated 
successfully (Failed - 0). Skipped means that the version is already on the device, 
so activation is not necessary. If something failed, contact Oracle support.

8. Once the activation process finishes and there are no failures, click Reboot to 
reboot the library.

9. Click OK to terminate the SLC session. After library initialization completes, you 
can log back in to SLC.

Approximate time is 3 to 5 minutes for SLC reconnect and 5 to 8 minutes for all 
devices to become green on SLC (if the front access doors have not been opened, 
otherwise, an audit is automatically triggered, which can take 20-120 minutes 
depending on the size of the library).

Downgrading Firmware
Contact Oracle support if you wish to downgrade code or install a version of code 
below FRS_4.40.

Caution: Do not open the door or power cycle the SL3000 or robots 
during this phase. Potential damage can be done to controller cards. 
Do not reboot any devices in the library or execute any operations on 
the library while activating code.

Note: If you encounter errors while updating firmware, contact 
Oracle support.
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ELibrary Addressing Reference

■ Comparison of Addressing Schemes

■ Understanding the Center Line

■ Internal Firmware Addressing Scheme

■ HLI-PRC Addressing Scheme

■ FC-SCSI Element Numbering

■ Tape Drive Hardware Numbering

■ Wall Diagrams

See Also
■ "Using Reserved System Slots" on page 11-5

Comparison of Addressing Schemes
■ Internal Firmware Addressing Scheme (Library, Rail, Column, Side, Row) — 

used by the firmware and internal communications to represent all devices and 
locations within the library.

– Begins at 1 and uses negative numbers.

– Side indicates the front or rear wall of the library.

– Drive bays have column values 1 to 4 (BM) and -1 to -4 (DEM).

■ HLI-PRC Addressing Scheme (LSM, Panel, Row, and Column) — used by HLI 
clients, such as ACSLS and ELS, to represent library locations and components.

– Begins at 0 with no negative numbers.

– Panel indicates the front or rear wall of a specific module.

– Drive bays always have column value of 0.

■ FC-SCSI Element Numbering — used by hosts with FC-SCSI connections to the 
library.

– Uses single positive number for the element ID.

– Cartridge slots begin at 2000, tape drives begin at 1000, CAPs begin at 10.

Note: "Left" and "right" are in reference to viewing the library from 
the CAP-side (front) unless otherwise specified.
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– Inactive slots and empty drive bays are skipped when element numbers are 
assigned.

– Default element numbering is reassigned with any library configuration 
change.

– Element numbering depends on active capacity.

■ Tape Drive Hardware Numbering — drive slot locations assigned by the HBC 
card.

Understanding the Center Line
Internal firmware and HLI addressing use the center line of the library as a reference 
point. When you add modules to either end of the library, the existing components do 
not change address number.

Figure E–1 shows the location of the centerline for various library configurations.

Figure E–1 Center Line Location in Sample Libraries

Internal Firmware Addressing Scheme
■ Internal Firmware Addressing Overview
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■ Internal Firmware Addressing of Tape Drives

■ Internal Firmware Addressing of Robots

■ Internal Firmware Addressing of CAPs

Internal Firmware Addressing Overview
Internal firmware addressing designates physical location using Library, Rail, Column, 
Side, Row (L,R,C,S,W).

Library
Always equal to 1.

Rail
Always equal to 1.

Column
Indicates the horizontal location of a cartridge or drive referenced from the center line 
(see "Understanding the Center Line" on page E-2).

■ Positive (+) value indicates right of center line

■ Negative (-) value indicates left of center line

Base Module

■ Contains columns 1 to 6 for data cartridges and 1 to 4 for tape drives.

DEM

■ Contains columns -1 to -6 for data cartridges and -1 to -4 for tape drives.

CEM

■ Contains six columns for data cartridges.

■ Column numbering continues consecutively from the adjacent module. However, 
if there is no DEM, a CEM placed directly to the left of a Base contains columns -7 
to -12 (columns -1 to -6 are skipped).

PEM

■ Contains only three columns for data cartridges. The outer most three columns are 
inactive.

AEM

■ AEM columns are numbered as if a DEM and four CEMS are installed to the left of 
the Base Module and four CEMs are installed to the right.

■ Left AEM columns are always numbered -33 to -31.

■ Right AEM columns are always 31 to 33. 

Side
Indicates the front wall (CAP side) or rear wall (drive side) of the library.

■ Rear wall = 1 

■ Front wall = 2

Row
The vertical location of a tape cartridge, consecutively numbered from the top (1) 
down (52).
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Figure E–2 Internal Firmware Side and Column Addressing Examples (viewed from top of library)

Internal Firmware Addressing of Tape Drives
The firmware addressing (library, rail, column, side, row) distinguishes a drive based 
on column and row. The library, rail, and side values are always equal to 1.

Note: The perspective in Figure E–3 is from the drive-side (rear) of 
the library. 
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Figure E–3 Tape Drive Internal Firmware Addressing (viewed from rear of library)

Internal Firmware Addressing of Robots

Column
The column value is always 0.

Side
If there is only one robot: the side value is always 1.

For redundant robot configurations:

■ Left robot = 1

■ Right robot = 2

Row
When addressing the device: the row is 0.

When addressing the specific slot: the row is the slot value (1).

Example - Robot Firmware Addressing
For this example, the address is referring to the right robot in a redundant robotics 
library.

The firmware address is: (1, 1, 0, 2, 0)

Internal Firmware Addressing of CAPs
■ Rotational CAP Addressing

■ AEM CAP Addressing
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Rotational CAP Addressing

Column
The column value depends on the size of the library and the location of the module 
that contains the CAP.

For modules to the left of centerline, the CAP column value corresponds to the second 
column from the right of the module. For example, in a DEM, the column value for the 
CAP would be -2 and a CEM to the left of the DEM would have a CAP column value 
of -8.

For modules to the right of centerline, the CAP column value corresponds to the fifth 
column from the left of the module. For example, a CAP in the Base has a column 
value of 5 and a CEM to the right of the Base would have a CAP column value of 11.

Side
The side value is always 2, since the CAPs are only located on the front of the module.

Row
When addressing the device: the row value is 0.

When addressing a specific slot: the row value is the slot in the CAP magazine (values 
1 to 26).

Example - Rotational Firmware Addressing
For this example, the library has a Base, DEM, and four CEMs (two on each side). The 
address refers to the sixth slot down in the CAP in the CEM on the far left.

The firmware address is: (1, 1, -14, 2, 6)

AEM CAP Addressing

Column
The column value when referencing the CAP is:

■ -31 for left AEM

■ 31 for right AEM

The column value when referencing a slot in the CAP:

■ -31 to -33 for left AEM

■ 31 to 33 for right AEM

Side
Indicates the front or rear CAP doors on the library.

■ Rear wall = 1

■ Front wall = 2

Row
When addressing the device: the row value is 0.

When addressing a specific slot: the row value is the slot in the CAP (values 1 to 26).

Example - AEM CAP Firmware Addressing
For this example, the address is referencing a cartridge slot in the right AEM. The slot 
is the 37th down in the far right column in the rear CAP door.

The firmware address is: (1, 1, 33, 1, 37)
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HLI-PRC Addressing Scheme
■ HLI Addressing Overview

■ HLI Addressing of CAPs

■ HLI Addressing of Tape Drives

HLI Addressing Overview
HLI-PRC addressing designates physical location using: LSM, Panel, Row, and 
Column. 

LSM
Always equal to 0. 

Panel
Indicates the front wall (CAP side) or rear wall (drive side) of a module. The panel 
number can range from 0 to 23 depending on the configuration of the library.

■ Rear wall = even numbers

■ Front wall = odd numbers

The panel location is defined relative to the Base Module (panels 12 and 13). Panel 
values less than 12 indicate the module is to the left of the Base Module, while values 
greater than 13 indicate the module is to the right of the Base Module.

Base Module

■ Panels 12 and 13

DEM

■ Panels 10 and 11

CEM

■ Panels are numbered consecutively from the adjacent module. However, if there is 
no DEM, a CEM placed directly to the left of a Base Module contains panels -8 and 
-9 (panels -10 and -11 are skipped).

AEM

■ AEMs are considered CAPs by HLI addressing. Therefore, AEMs have a CAP ID 
instead of a panel number (see "HLI Addressing of CAPs" on page E-8)

■ Left AEM CAP ID is always numbered 0 

■ Right AEM CAP ID is always numbered 11

Row
The vertical location of a slot, consecutively numbered from the top down (0 to 51). 
However, drive bays have row numbering from 0 to 23 for the Base Module, and 0 to 
31 in the DEM.

Column
The horizontal location of a slot from left to right (0 to 5). However, drive bays always 
have a column value of 0 (see "Tape Drive Hardware Numbering" on page E-15").

AEM column numbering starts at the rear wall and runs left to right (columns 0–2), 
then proceeds to the front wall and runs left to right (columns 3–5).
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Figure E–4 HLI-PRC Panel and Column Addressing Examples (viewed from top of library)

HLI Addressing of CAPs
HLI addressing defines CAP locations with a CAP ID instead of a panel value. The 
addressing is LSM, CAP ID, row, column.

■ Rotational CAP Addressing

■ AEM CAP Addressing

Rotational CAP Addressing

LSM
Always equal to 0.

CAP ID
Ranges from 1 to 10
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■ CEMs left of centerline = 1 to 4 (left to right)

■ DEM = 5

■ Base Module = 6

■ CEMs right of centerline = 6 to 10 (left to right)

Row
The value is the slot in the CAP (can be values 0 to 25).

Column
The value always equals 0.

Example - Rotational CAP HLI Addressing
For this example, the library has a Base, DEM, and eight CEMs (four on each side). The 
address refers to the sixth slot down in the CAP in the CEM on the far left.

The HLI address is: (0, 1, 5, 0)

AEM CAP Addressing

LSM
Always equal to 0.

CAP ID
Left AEM equals 0.

Right AEM equals 11.

Row
The value is the slot in a column (can be values 0 to 38). 

Column
Rear wall = columns 0 to2

Front wall = columns 3 to 5

HLI Addressing of Tape Drives
HLI addressing defines tape drives with a drive ID instead of a row value. The 
addressing is LSM, panel, drive ID, column (see "Tape Drive Hardware Numbering" 
on page E-15). HLI distinguishes a drive based on the panel and drive value. The LSM 
and column values are always equal to 0.

Note: The perspective in Figure E–5 is from the drive-side (rear) of 
the library.
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Figure E–5 Tape Drive HLI-PRC Addressing (viewed from rear of library)

FC-SCSI Element Numbering

For FC-SCSI element numbering, each active component in the library has a unique 
element ID. SCSI element numbering consists of three element types:

■ Storage Elements (active storage slots)

– Begins at 2000.

– Numbered top to bottom, left to right, and rear to front.

■ Import/Export Elements (rotational CAPs)

– Begins at 10 for the left most CAP in the library. Storage and Import/Export 
elements are numbered sequentially by slot. No slots are skipped. 

– Numbered top to bottom, left to right (see Figure E–9)

■ Data Transfer Elements (drives)

– Begins at 1000 and increments by one for every installed drive.

– Numbered left to right, top to bottom, starting at the center line in the base 
module and continuing in the DEM if installed.

Note: Changing the library configuration can cause the library to 
re-assign element numbers.

Note: When the library powers on, a vacant drive slot will not be 
included in the element number sequence. Open Systems backup 
applications do not tolerate Data Transfer Elements that cannot or do 
not respond when you power-on the library.
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Default SCSI Numbering

Default SCSI Storage Element (Cartridges) Numbering Scheme
1. The numbering starts at 2000 in the upper left slot on the rear wall of the left-most 

module. 

2. The numbering increases from top to bottom and left to right.

3. When the numbering reaches the last slot on the rear wall, it crosses to the front 
wall of the left-most module (A to B in Figure E–6). 

4. The numbering continues top to bottom, left to right, and ends at the lower right 
slot of the right-most module.

Figure E–6 SCSI Storage Element Numbering

Default SCSI Data Transfer Element (Drives) Numbering Scheme
1. The numbering starts in the upper left drive slot in the Base Module.

2. The numbering increases from left to right and top to bottom (skipping any empty 
drive slots). 

3. When the numbering reaches the lower right drive slot on the Base Module, it 
crosses to the Drive Expansion Module (A to B in Figure E–7). 

4. The numbering continues left to right, top to bottom, and ends at the lower right 
slot of the DEM.

Note: The default numbering pattern assumes you have a 
non-partitioned library using the default "left to right" capacity 
configuration.
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Figure E–7 SCSI Data Transfer Element Numbering (viewed from front of library)

Default Numbering Example

 The example library includes:

■ Four modules: one Base, one DEM, and two CEMs 

■ 166 data cartridge slots: numbered 2000 to 2165

■ 40 tape drive bays (two tape drives are missing, one in each module): numbered 
1000 to 1037

■ Two CAPs, each with seven slots: numbered 10 to 23

The default numbering is shown in the figures below.

Note: The library in this example has been simplified. It is not an 
exact representation of an SL3000.
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Figure E–8 Default SCSI Element Numbering - Rear Wall (viewed from front of library)

Figure E–9 Default SCSI Element Numbering - Front Wall (viewed from front of library)

SCSI Numbering in Non-Partitioned Library Using Custom Capacity
After activating an area of the library, the numbering begins with the left most slot on 
the rear wall within the active area. Then, the numbering scheme follows the pattern 
defined in "Default SCSI Storage Element (Cartridges) Numbering Scheme" on 
page E-11 for all active slots, but skips over any inactive slots.

When you activate additional capacity later, the SCSI numbering of previously 
activated slots does not change. The library appends the SCSI numbering for newly 
activated slots.

If you add tapes drives, the library reassigns SCSI Data Transfer element numbering 
following the "Default SCSI Data Transfer Element (Drives) Numbering Scheme" on 
page E-11. Then, the library restarts.
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Custom Capacity Numbering Example

For this example, the user activates 50 slots, beginning with the DEM. As a result, the 
SCSI storage element numbering begins at 2000 with the upper left-most active slot in 
the DEM (see Figure E–10 below).

Figure E–10 SCSI Element Numbering for Custom Capacity - Rear Wall

At a later date, the user activates the remaining 30 slots in the library. The library 
numbers the slots starting with 2050 in the upper left corner of the CEM (see 
Figure E–11 below).

Figure E–11 Appended SCSI Element Numbering for Added Capacity - Rear Wall

SCSI Numbering in a Partitioned Library
When you define a partition, the numbering begins with the left most slot on the rear 
wall within the partition. The numbering scheme follows the pattern defined in 

Note: The library in this example has been simplified. It is not an 
exact representation of an SL3000.
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"Default SCSI Storage Element (Cartridges) Numbering Scheme" on page E-11 for all 
active slots, but skips over any inactive slots and slots not within the partition. 
Therefore, element numbering is continuous within each partition, even if slot 
locations for the partition are not adjacent. 

If you allocate more resources to the partition, the SCSI numbering of previously 
numbered elements in the partition do not change. The library simply appends the 
SCSI numbering for newly activated slots or newly inserted tape drives within the 
partition.

Tape Drive Hardware Numbering
The hardware numbering is assigned by the HBC controller card. It is used to identify 
a tape drive slot. The card automatically assigns a number, 1-56, to each drive slot.

Figure E–12 Tape Drive Physical Hardware Numbering (viewed from rear of library)

See Also
■ "Internal Firmware Addressing of Tape Drives" on page E-4

■ "HLI Addressing of Tape Drives" on page E-9

■ "Default SCSI Data Transfer Element (Drives) Numbering Scheme" on page E-11).

Wall Diagrams
■ Base Module front wall (Figure E–13)

■ Base Module rear wall (Figure E–14 and Figure E–15)

■ DEM front wall (Figure E–16 and Figure E–17)

Note: The perspective in Figure E–12 is from the drive-side (rear) of 
the library.
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■ DEM rear wall (Figure E–18 and Figure E–19)

■ CEM front wall (Figure E–20)

■ CEM rear wall (Figure E–21)

■ Left PEM (Figure E–22)

■ Right PEM (Figure E–23)

■ Left AEM (Figure E–24)

■ Right AEM (Figure E–25)

Figure E–13 Base Module, Front Wall
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Figure E–14 Base Module, Rear Wall



Wall Diagrams

E-18 StorageTek SL3000 Library Guide

Figure E–15 Base Module, rear wall with 24 drives
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Figure E–16 DEM Front Wall
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Figure E–17 DEM Front Wall (continued)
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Figure E–18 DEM Rear Wall
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Figure E–19 DEM Rear Wall (continued)
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Figure E–20 Cartridge Expansion Module, Front Wall
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Figure E–21 Cartridge Expansion Module, Rear
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Figure E–22 Parking Expansion Module, Left
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Figure E–23 Parking Expansion Module, Right
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Figure E–24 Access Expansion Module, Left
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Figure E–25 Access Expansion Module, Right
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FBarcode Labels

This section describes the requirements for cartridge barcode labels used in Oracle’s 
StorageTek tape libraries. All tape cartridges must have a proper barcode label. 
Mis-aligned, mis-oriented, or improperly-labeled cartridges may cause equipment 
damage.

■ Barcode Standards

■ Label Design

■ Applying a Label

■ Label Care

Barcode Standards
StorageTek libraries use labels based on the Code 39 barcode standard (refer to 
ANSI/AIM BC1/1995, Uniform Symbology Specification - Code 39). This standard 
uses discrete barcodes, meaning a fixed pattern of bars represents a single character. 
Each character is made up five black and four white, where three bars are wider than 
the others.

For example, Figure F–1 represents the letter A using six narrow bars and three wide 
bars (two black and one white).

Figure F–1 Code 39 Barcode Standard — Letter A

When multiple barcode characters are arranged together as a label, a narrow white bar 
is placed between the individual characters. This bar is called the inter-character gap.

Figure F–2 Code 39 Barcode Standard — Inter-Character Gap
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Label Design
Each label must have a six-character volume serial ID (vol-id) and a one- or 
two-character media ID. The media ID identifies the cartridge type. The labels can 
only use the uppercase letters A through Z, the numbers 0 through 9, and an asterisk 
(*) for the start and stop character (for example, *ABC123L6*, where ABC123 is the 
vol-id and L6 is the media ID).

The StorageTek T-series cartridge labels made by Tri-optic use a dollar sign ($) as the 
start and stop character. Never use the asterisk or dollar sign as part of the 
customer-defined characters of a barcode. Barcode algorithms only decode the 
characters between the end stops, ignoring any characters outside. Refer to the table 
below for examples. 

Table F–1 Start and Stop Character Placement

Actual Barcode Label After Decoding Result

*ABC123L6* ABC123L6 Correct label

*ABC*23L6* ABC Misplaced stop character

*ABC1234L6 Unreadable No stop character
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Figure F–3 Barcode Placement Standards (T10000 and LTO)

Figure Legend:

1. Start character

2. Volume ID

3. Media ID

4. Stop character

LTO
These cartridges require an eight-character label — a six-character vol-id and a 
two-character media ID. The media ID characters are:

■ L3 = Generation 3
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■ L4 = Generation 4

■ L5 = Generation 5

■ L6 = Generation 6

■ L7 = Generation 7

■ L8 = Generation 8

■ LT = Generation 3 WORM

■ LU = Generation 4 WORM

■ LV = Generation 5 WORM

■ LW = Generation 6 WORM

■ LX = Generation 7 WORM

■ LY = Generation 8 WORM

■ CU = universal cleaning

T9840 and T9940
These cartridges require a six-character vol-id label plus a separate one-character 
media ID label. Only Tri-Optic Corporation, American Eagle Systems/Wrightline, or 
Imation Corporation can print these labels. The media ID characters are:

■ R = T9840 data

■ U = T9840 A/B/C cleaning

■ Y = T9840 D cleaning

■ P = T9940 data

■ W = T9940 cleaning

T10000
These cartridges require an eight-character label — a six-character vol-id and a 
two-character media ID. The media ID characters are:

■ T1 = T10000 A/B data

■ T2 = T10000 C/D data

■ TS = T10000 A/B sport

■ TT = T10000 C/D sport

■ CT = cleaning (A and B only)

■ CL = universal cleaning

Cleaning and Diagnostic Labels
Cleaning and diagnostic cartridges require unique labels to distinguish them from 
data cartridges. The first three alphanumeric characters in the vol-id determine the 
type of cartridge.

■ Cleaning cartridges — use CLNnnn for the vol-id plus the cleaning-specific media 
ID, where CLN is the cleaning cartridge identifier and nnn is a sequence of numbers 
(for example, CLN001CU could be an LTO cleaning cartridge label).
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■ Diagnostic cartridges — use DG[space]nnn plus the media ID, where DG[space] is the 
diagnostic cartridge identifier, and nnn is a sequence of numbers (for example, 
DG 001L6 could be an LTO6 diagnostic cartridge label).

Cartridge Label Examples

Figure Legend:

1. Data cartridges

2. Cleaning cartridges

3. Diagnostic cartridges

Applying a Label

Guidelines for applying the labels include:

■ Inspect and clean the cartridge. Wipe all dust, dirt, and moisture using a lint-free 
cloth. Use a safe cleaning solution (such as isopropyl alcohol) to clean the cartridge 
exterior housing.

■ Ensure the cartridge and label are oriented correctly. Orient the label with the 
barcode below the human-readable characters and the cartridge with the hub-side 
down. For LTO cartridges, hold the cartridge so that the write-protect switch is 
toward you. For a T10000 cartridge, ensure the write-protect switch is away from 
you. For a T9840 cartridge, ensure the write-protect switch is on the right side.

■ Apply the labels with in the recess on the cartridge as straight as possible. Ensure 
the edges of the label are parallel to the edges of the cartridge. The label must not 
overlap the edge of the recessed area.

■ For T9840 and T9940 labels, align the vol-id label and media ID label.

■ For best adhesion, apply the label within one year of purchase.

Caution: Mis-aligned, mis-oriented, or improperly-labeled cartridges 
may cause equipment damage.
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Figure F–4 Cartridge Label Orientation

Figure Legend:

1. Write-protect switch

2. Cartridge label

3. Separate media ID label (T9840 and T9940 only)

T9840 and T9940 Label Issues
All media ID labels must have a correctly sized white area above and below the 
barcode. If the white area is too small, the radius of the label die can cut into the first 
black bar of the barcode, causing barcode read errors.

Figure F–5 White Area on Separate Media ID Label

Figure Legend:

1. White area is too small

2. Correctly sized white area

The media ID label must be aligned with the vol-id label. Ensure the media ID label is 
not rotated or off-center from the vol-id label.



Label Care

Barcode Labels F-7

Figure F–6 Mis-aligned Media ID Label

Figure Legend:

1. Rotated media ID label

2. Off-center media ID label

Label Care
Proper label care is required to prevent barcode read errors or damage to the 
equipment:

■ Keep the barcode intact. Do not mark or damage the barcode label or place any 
kind of tape across the label.

■ Remove old labels completely before applying a new label. Do not apply a new 
label on top of an old one.

■ Do not use sharp instruments to seat or remove a label.
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2N

A PDU that supplies power to the redundant AC power grid and the third and fourth 
accessory racks. See also N+1 and 2N+1. 

2N+1

Two PDUs for AC redundancy. Each PDU has extra DC power supplies for N+1 
redundancy for each PDU. 

ACSLS

See Automated Cartridge System Library Software (ACSLS). 

ADI

Automation drive interface. 

Address Resolution Protocol (ARP)

A network layer protocol that converts IP address into physical addresses, like 
Ethernet addresses. Address Resolution Protocol (ARP) Takeover allows traffic to be 
redirected from a failing OSA-Express connection to another OSA-Express connection

AEM

See access expansion module. 

access expansion module

Essentially a very large CAP, with all the characteristics of a CAP, such as 
online/offline state, ability to be shared by partitions, and so on. The cartridge slots in 
the AEM cannot be used for long-term cartridge storage. 

access door

A door on either side of the front facade through which service personnel can enter the 
library. Optional CAPs are attached to the right access door. 

activated capacity

The number of storage slots the library is activated to use. This cannot exceed the 
installed capacity. 

Automated Cartridge System Library Software (ACSLS)

An open systems software package that manages library contents and controls library 
hardware to mount and dismount cartridges on tape drives. This application also 
provides library management services such as cartridge tracking, pooling, reports, and 
library control. 
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Automated Cartridge System Library Software (ACSLS) High Availability (HA)

A hardware and software configuration that provides dual redundancy, automatic 
recovery, and automatic failover recovery to ensure uninterrupted library management 
for the SL3000.

audit

An inventory of cartridge locations in all areas of the library, including the slots in the 
storage and reserved areas. Audits occur when: 

■ The library initializes at power-on. 

■ After either one or both access doors are opened and closed without activating the 
service safety door. 

■ A physical audit request is made through SL Console. 

base module 

Provides the entry level offering for an SL3000 library. Consists of a single frame and 
centralizes the infrastructure for all other modules in the library. This module includes 
the power supplies, robotic units, electronics control module, cartridge access port, 
storage slots, tape drives, and operator controls. 

bulk load 

Manually loading cartridges into the library, for example, during library installation. 

CAP 

See cartridge access port (CAP). 

CEM 

See cartridge expansion module. 

capacity 

The storage capacity of the library. See also activated capacity and installed capacity. 

cartridge 

A container holding magnetic tape that can be processed without separating the tape 
from the container. The library uses data, diagnostic, and cleaning cartridges. 

cartridge access port (CAP) 

A bi-directional port built into the door panel of the library which provides for the 
manual entry or automatic ejection of data or cleaning cartridges. Same as 
import/export mail slot in SCSI and open system libraries. 

cartridge expansion module 

An optional module for the library that provides additional cartridge slot capacity and 
growth. 

cleaning cartridge 

A tape cartridge that contains special material to clean the tape path.

Cold swap

To remove and replace a system component (typically one such as a logic board that 
has no redundant backup) after system operations have been stopped and system 
power has been disabled.
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Control Data Set (CDS)

Data set used by the ELS/HSC host software to control the functions of the automated 
library. Also called an ELS library database.

DEM 

See drive expansion module (DEM). 

dWWN 

See dynamic WWN. 

data cartridge 

A cartridge onto which a tape drive may write data. 

diagnostic cartridge 

A data cartridge used for diagnostic routines. 

data path 

The path where data is transferred between the host and tape drives. 

drive expansion module (DEM) 

A module that allows further expansion of tape drives. 

drive slot

A partitioned section of the tape drive array assembly that holds one tape drive tray 
assembly. 

drive slot address 

A two-digit integer (01–64) that represents the physical locations into which drive tray 
assemblies are inserted. 

drop-off slots 

Cells used to hold a cartridge if a robot failure occurs while a cartridge is in the robot 
hand. 

Dual TCP/IP 

Provides two separate host connections between the host software (ACSLS or HSC) 
and the library controller. 

dynamic WWN 

When enabled, dWWN assigns names to library drive slots rather than devices. When 
a drive is replaced, the new drive receives the same name as the one it replaced, 
thereby eliminating the need for system re-configuration. dWWN assigns names to 
individual tape drive slots rather than devices 

ECM 

See electronics control module. 

ELS 

See Enterprise Library Software (ELS). 

EPO 

See emergency power-off (EPO). 
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eject 

See export.

electronics control module 

A module that includes the HBK card, HBC/HBCR card and HBT card. The assembly 
that: 

■ Processes commands from a host system 

■ Coordinates the activities of robots and tape drives 

■ Monitors status inputs from sensors and switches 

emergency power-off (EPO) 

(1) A safety scheme that allows a power down of a subsystem or a system as a whole 
instead of powering it down component-by-component. 

(2) A safety switch on a system or in a data center that allows a user to immediately 
turn off a system or a data center power supply by cutting off the external source 
power. 

enter 

See import. 

Enterprise Library Software (ELS)

The software products that automate tape operations for mainframe users. 

export 

The action in which the library places a cartridge into the cartridge access port so that 
the operator can remove the cartridge from the library. Same as eject.

FRU 

Field replaceable unit. 

failover 

The act of moving to a secondary or redundant path when the primary path fails. Also, 
in ACSLS HA, failing over to the standby (alternate) ACSLS server. 

get 

An activity in which a robot obtains a cartridge from a slot or drive. 

HBC/HBCR card

The controller card on SL3000.

HLI/PRC 

Host Library Interface/Panel Row Column 

Host Software Component (HSC)

A component of ELS, HSC is software that resides on mainframe operating systems 
and controls the library. The HSC receives requests from the programmatic interface 
and translates them into commands which are carried by the control path to the 
library. HSC is the overall manager of the library, the interface between a mainframe 
operating system and a library. HSC maintains a control data set, records of the 
cartridges stored in each library.
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host audit 

The process of updating the cartridge vol-ids and locations in a host CDS. This audit is 
initiated by a host command. 

import 

The process of placing a cartridge into the cartridge access port so that the library can 
insert it into a storage slot. 

installed capacity 

The number of storage slots physically present in the library. 

interlock switch 

A switch that disconnects power to library mechanisms, excluding tape drives, when 
the front door is opened. 

LCM 

See Library Content Manager (LCM). 

LTO 

See linear tape open format (LTO). 

LUN 

See logical unit number. 

Library Content Manager (LCM) 

Software that provides content management for mainframe automated tape 
environments.

library operator panel 

See touch screen operator control panel. 

linear tape open format (LTO) 

A set of tape data format standards created to enable data interchange among different 
LTO Ultrium tape drive vendors. These standards allow data cartridges to be shared. 

logical library 

A virtual representation of a physical library. Same as virtual library partition. 

logical unit number 

A unique identifier for a physical storage allocation. A LUN could reference an entire 
RAID set, a single hard disk or partition, or multiple disks or partitions. Unlike a 
physical LUN, the virtual LUN does not map to a specific device or allocation of 
storage space but a virtualized space that can be created in excess of the actual 
physical space available. 

magazine 

A removable array that holds cartridges and is placed into the cartridge access port 
(CAP). 

N+1 

A power configuration that provides AC power and redundant DC power by adding a 
second DC power supply to each DC bus. See also 2N. 
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operator panel 

See touch screen operator control panel. 

orphaned cartridge 

A cartridge in a partitioned library that is located in an unallocated slot or drive (that 
is, a slot or drive not allocated to any defined partition). Cartridges may become 
orphaned when partition boundaries are changed, partitions are deleted, or cartridges 
are manually moved to unallocated or inaccessible slots. 

PDU 

See power distribution unit (PDU). 

PEM 

See power distribution unit (PDU). 

PLI 

See primary library interface (PLI). 

parking expansion module (PEM) 

An additional module available for the SL3000 library that allows a redundant robot to 
be parked in it. 

physical audit 

Physical audits occur when the robots: 

■ Scan the cartridge locations in the library 

■ Verify the volumes 

■ Update the library control card inventory 

■ Set the status of the cartridge location to true 

power distribution unit (PDU) 

A device for the distribution of AC line power from one inlet to multiple outlets. 
Multiple PDUs provide higher availability because the power continues if one PDU (or 
its alternating current source if the PDUs use separate AC sources) loses power. 

primary library interface (PLI) 

The communication path between the operator panel and the library controller. 

put 

An activity in which a robot places a cartridge into a slot or drive. 

RE 

See Redundant Electronics (RE). 

rail 

(1) That portion of the upper robot track assembly that provides power and 
communication to the robot. (2) All of the cartridge slots and drives accessible through 
a rail. 

rail assembly 

The mechanism on which the robot travels between cartridge arrays and tape drives. 
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Redundant Electronics (RE) 

A feature that provides failover protection in enterprise libraries. RE uses two sets of 
library controller cards. At any given time, one set is active and the other set is 
standby. The active library controller can failover to the standby in response to a 
command from ACSLS or the SL Console. Automatic failover can be initiated by the 
library if a library card fails. 

robot 

A mechanism that moves horizontally along a track to transport tape cartridges to and 
from other locations in the library. 

routing

The process of moving a packet of data from a source to a destination. Routing enables 
messages to pass from one device to another device, and eventually reach their target.

SSL 

See Secure Sockets Layer (SSL). 

Secure Sockets Layer (SSL) 

A cryptographic protocol that provides communication security. The communication 
path between the PLI and the remote operator console occurs through SSL. 

TTI 

See tape transport interface (TTI). 

tape cartridge 

A container holding magnetic tape that can be processed without separating the tape 
from the container. The library uses data, diagnostic, and cleaning cartridges. These 
cartridges are not interchangeable. 

tape drive 

An electromechanical device that moves magnetic tape and includes mechanisms for 
writing and reading data to and from the tape. 

tape drive tray assembly 

The mechanical structure that houses a tape drive, fan assembly, power and logic 
cards, cables, and connectors for data and logic cables. Same as drive tray assembly. 

tape transport interface (TTI) 

An interface to control and monitor tape movement. 

touch screen operator control panel 

A flat-panel display with a touch screen interface and a panel mount computer. This 
feature is attached to the front of the library. 

vol-id 

Volume ID assigned to a cartridge. Same as VOLSER. 

VOLSER 

Volume serial number. Same as vol-id. 
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verified audit 

Verified audits are invoked from SLC and validate the status of a specific cartridge slot 
or range of slots. 

World Wide Name (WWN)

A 64-bit address that uniquely identifies each individual device and vendor, much like 
the MAC address of an Ethernet interface. Each port on a Fibre Channel network must 
have its own WWN. The WWN is not just a physical hardware address. It also serves 
as the logical address of a node on the SAN, meaning the SAN configuration changes 
if any of the attached hardware changes. If a device fails and is replaced, the WWN of 
the node changes, forcing reconfiguration of the SAN. There are three World wide 
Names reserved for each drive bay: Node, Port A, and Port B.
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Numerics
2N, 1-9
2N+1, 1-9

A
AC

See power
access door

closing, 18-2
opening, 18-2

access expansion module
See AEM

ACSLS, 1-20
Dual TCP/IP and high availability 

configuration, C-3
Dual TCP/IP and high availability routing, C-3
Dual TCP/IP separate subnets, C-2

activated capacity
active storage regions

reports, 15-2
changes and FC-SCSI connections, 8-2
changes and HLI connections, 8-2
orphaned cartridges and, 6-3

activated features
display current, 5-2

active storage regions
reports, 15-2

addressing, E-1
AEMs internal firmware, E-6
CAPs HLI, E-8
CAPs internal firmware, E-5
FC-SCSI, E-10
HLI-PRC, E-7
internal firmware, E-2
tape drives, E-15

AEM
associating to a partition, 10-5
emergency access, 18-2
library partitions and, 7-4
measurements, 2-4
overview, 1-4
rebooting, 16-3
removing partition associations, 10-5
shipping, 2-5

AEM access door
closing, 10-3
fast access, 18-2

AEM safety door
properties, 14-2
status, 14-2

arbitrated loop, 1-19
ARP floods, C-2
audits

audit indicator, 13-2
full library, 13-1
main access door and, 13-2
physical, 13-1, 13-2
range of cells, 13-2
verified, 13-2

auto enter mode (CAPs)
described, 10-6

automated cartridge system library software, 1-20

B
barcode presentation, 11-4
bar-code scanner, 1-7
Base module

installation time estimate, 2-10
installation tool kit, 2-11
measurements, 2-3
ordering, 1-24
overview, 1-2
power, 1-10
shipping, 2-5

Btu/hr, 1-14
bulk loading, 1-8

See also AEM

C
cables

cutouts, 2-8
Ethernet, 1-31
fiber-optic, 1-30
ordering, 1-30
routing, 2-8

CAP
bulk loading, 1-8
ordering, 1-26
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rotational, 1-7
CAP associations

library partitions and, 7-5, 10-5
removing, 10-5

CAP reservations
library partitions and, 7-5
overriding, 10-4

capacity
activated. See activated capacity.
calculation examples, 1-17
non-partitioned library, 6-1
physical, 1-17

CAPs
and library partitions, 7-5
auto enter mode, 10-6
bringing online, 16-2
closing, 10-3
display properties, 14-2
display status, 14-2
display summary information, 14-2
inserting cartridges, 10-2
library partitions and, 7-4, 10-5
making available for diagnostic moves, 10-4
manual mode, 10-6
self-test, 17-3
states

library partitions and, 10-5, 10-6
taking offline, 16-2

cartridge access port
See CAP

cartridge expansion module
See CEM

cartridges
barcode presentation, 11-4
display information, 15-2
ejecting into a partition, 10-5
ejects, 10-2
entering into a partition, 10-5
enters, 10-2
exterior cleaning, 11-7
handling, 11-7
inserting in a cell or drive, 11-7
inserting in the CAP, 10-2
inspecting, 11-7
list, 15-2
locate by address, 11-2
locate by VOLID, 11-2
locating by address, 11-2
locating by VOLID, 11-2
mounting, 18-3
move by VOLID, 11-1
move from specified location, 11-1
ordering, 1-28
recovery moves, 11-1
storing, 11-8
unlabeled, 11-7

cautions
reentering cleaning cartridge, 11-3
solvents for cleaning a cartridge, 11-7

CDRT, 1-21

CEM
installation time estimates, 2-10
measurements, 2-4
ordering, 1-24
overview, 1-4
shipping, 2-5

CenterLine, E-2
cleaning cartridges, 11-7

importing, 11-3
list, 11-5
warning threshold, 11-4

CLI, 1-6
client system component, 1-22
CO2 emissions, 1-14
command line interface, 1-6
concurrent disaster recovery test, 1-21
configurations

library modules, 1-1
power options, 1-9

connections
Ethernet, see TCP/IP
Fibre Channel, See FC-SCSI

control module
See ECM

conversion kits, 1-27
cooling, 1-16
CSC, 1-22
customer service, 1-31
cutouts, 2-8

D
DC power supplies

See power
DEM

installation time estimates, 2-10
installation tool kit, 2-11
measurements, 2-3
ordering, 1-24
overview, 1-3
power, 1-10
shipping, 2-5

device status, 14-3
diagnostic cartridges

description, 11-3
exporting, 11-3
importing, 11-3
library self-tests and, 17-3
management tasks, 11-3

diagnostic support files, 15-3
diagnostics

CAPs and, 10-4
dimensions

modules, 2-1
shipping, 2-5

distribution pads, 2-6
drive cleaning

configuring library auto clean, 9-1, 9-2
importing cleaning cartridges, 11-3
manual, 18-3
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drive controller, 14-2
Drive Events Report, 15-1
drive expansion module

See DEM
Drive Media Events Report, 15-1
drive trays

status, 14-2
drive VOP

displaying for T10000, 14-2
drives

bringing online, 16-2
display drive properties, 14-2
display drive summary information, 14-2
display status, 14-2
LED status, 14-2
mounting a cartridge, 18-3
network data, 14-2
SCSI FastLoad and, 9-2
taking offline, 16-2

Dual TCP/IP
ACSLS routing, C-2
ACSLS separate subnets, C-2
configuration tasks, 8-5
definition, C-1

dual TCP/IP, 1-19

E
earthquakes, 2-7
ECM

description, 1-6
ordering, power supply, 1-28
power, 1-11

eject operations, 10-2
partitioned libraries, 10-5

electronics control module
See ECM

elevator
status of, 14-2
summary information, 14-2

ELS, 1-21
emissions, 1-14
encryption, 1-9, 1-26
enter operations, 10-2

partitioned libraries, 10-5
enterprise library software, 1-21
environmental

requirements, 2-6
Ethernet

cables, 1-31
See TCP/IP

expert performance reporter, 1-22
extended high performance data mover, 1-22
extractor tool, 2-11

F
FC-SCSI

cables, 1-30
connections, 1-6

description, 1-19
dual FC card, 1-29
topology, 1-19

FC-SCSI elements, E-10
FC-SCSI interface, 8-1

barcode presentation and, 11-4
FastLoad feature and, 9-2

fiber-optic cables, 1-30
Fibre Channel

See FC-SCSI
fire suppression, 2-8
floor

cutouts, 2-8
requirements, 2-6
weight capacity, 2-6

G
General Events Statistics Report, 15-1

H
hardware

components, 1-6
installation tools, 2-10

hardware activation
Feature Audit Log, 15-2

hardware activation file
comparing to current features, 5-1
delete, 5-2
display current, 5-2
displaying contents of, 5-1
download, 5-1
install, 5-1

HLI interface, 8-1
displaying port status, 14-1

HLI-PRC addressing, E-7
host interfaces

changing the type, 8-1
HLI. See HLI interface., 14-1
non-partitioned libraries and, 8-1

host software component, 1-21
HSC, 1-21

I
independent software vendors, 1-21
installation

personnel required, 2-10
time estimates, 2-10
tools, 2-11

interfaces
See TCP/IP and FC-SCSI

internal firmware addressing, E-2
ISVs, 1-21

L
labels

ordering, 1-28
LCM, 1-22
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library
mounting a cartridge, 18-3
placing in manual mode, 16-1
placing online, 16-2

library auto clean, 9-1
library capacity

See capacity
library configuration

display, 14-2
library console

See SLConsole
library content manager, 1-22
library controller

display redundant electronics, 14-3
log in to alternate, B-3
properties, 14-2

library firmware upgrades, D-1
activate, D-2
download, D-2

library initialization sequence, 18-1
library management software, 1-20

ACSLS, 1-20
CDRT, 1-21
ELS, 1-21
HSC, 1-21
SMC, 1-21
VTCS, 1-21

library modules, 1-1
library partitions

AEM associations and, 10-5
barcode presentation and, 11-4
CAP associations and, 7-5, 10-5
CAP reservations and, 7-5, 10-4
CAP states and, 10-5, 10-6
commit configuration changes, 7-4
configuration tasks, 7-1
delete, 7-2
described, 7-1
design, 7-3
displaying, 6-3, 7-4
ejecting cartridges into, 10-5
entering cartridges into, 10-5
hosts and, 7-1
orphaned cartridges in, 7-5
reports, 15-2
SCSI FastLoad feature and, 9-2
shared CAPs and, 7-5
using AEMs in, 7-4
using CAPs in, 7-4
using CAPs with, 7-5

library power down, 18-1
library power up, 18-1
library reboot, 16-3
library reports

displaying, 15-1
saving data to a file,SL Console report tasks, 15-1
searching, 15-1

library self-tests, 17-2
performing, 17-2

library status, 14-3

display, 14-1
local operator panel

factory alignment, 17-7
logging in, 4-2
re-calibrating, 17-7

Log SnapShot feature, 1-20
log snapshot file

generating process, 15-3
transfer process, 15-3

logs
Feature Audit Log, 15-2

LTO
ordering, 1-27

M
main access door

audits and, 13-2
manual CAP, 10-6
manual cleaning (drive), 18-3
manual mode

mounting a cartridge, 18-3
placing the library in manual mode, 16-1

manual operations
safety precautions, 18-2

general, 18-2
MIB file

transfer process, 15-3
minimum

physical space, 2-1
working area, 2-5

modules
ordering, 1-23
overview, 1-1

monitoring, 1-20

N
N+1, 1-9
network

configuration, 2-8
connections, 1-18
SNMP, 1-20

network broadcasts, C-2
non-disruptive partitioning

FC-SCSI partitions and, 8-3

O
operator panel

ordering, 1-26
ordering, 1-23

See also part numbers
orphaned cartridges

non-partitioned libraries and, 6-3
partitioned libraries and, 7-5

P
pallets, 2-5
parking expansion module
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See PEM
part numbers

cables, 1-30
hardware activation files, 1-29
installation tools, 2-11
module-add ons, 1-25
modules, 1-23
power options, 1-28
tool kit, 2-10

partitioning
ordering, 1-29

passwords
modifying, 4-2

PDU
ordering, 1-29
overview, 1-9

PEM
measurements, 2-4
overview, 1-5
shipping, 2-5

physical capacity
See capacity

placing the library in manual mode, 16-1
port bonding, 14-1
port conversion kits, 1-28
ports, 1-6, 1-19

status, 14-1
power, 1-9

AC source, 1-9
calculating requirements, 1-11
consumption, 1-14
DC supplies, 1-10
drive power-up tool, 2-11
ordering, 1-28
See also cables

power distribution unit
See PDU

power down the library, 18-1
power rail

extractor tool, 2-11
TallBot operation, 1-7

power supplies
ECM, 1-11
monitoring tasks, 14-2
ordering, 1-28
robotics, 1-11
status of, 14-2
summary information, 14-2
tape drives, 1-11

power up the library, 18-1
PTP

properties, 14-2
status of, 14-2

R
RE, 1-7
reboot

library, 16-3
recovery moves, 11-1

redundant
electronics, 1-7, 1-26
power, 1-9
robotics

AEM, 1-5
See robotics

redundant electronics
manual switch, 17-6
tasks, 14-3

reports
cartridge summary, 15-2
cartridge table, 15-2
drive events, 15-1
feature audit log, 15-2

requirements
environmental, 2-6
floor, 2-6
network, 2-8
physical space, 2-1
power, 1-9

robot
display status of, 14-2
display summary information, 14-2
monitoring tasks, 14-2
properties, 14-2
SCSI FastLoad and, 9-2
self-test, 17-3
varying offline, 16-2
varying online, 16-2

robotics
ordering, 1-25
overview, 1-7
power, 1-11
redundant, 1-7

S
safety door

monitoring tasks, 14-2
properties, 14-2
summary information, 14-2

safety precautions, 18-2
general, 18-2

SCSI FastLoad, 9-2
SDP, 1-31
seismic compatibility, 2-7
self-tests

CAP, 17-3
library, 17-2
robot, 17-3

service clearances, 2-4
service delivery platform

See SDP
shipping

module specifications, 2-5
modules, 2-5
pallets, 2-5
weights, 2-5

SL Console
communications failures, 14-4
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modes, 3-1
SL Console reports

Drive Events, 15-1
Drive Media Events, 15-1
General Events, 15-1

SLC
modifying passwords, 4-2

SLConsole
downloading, 3-1
media pack, 3-1
overview, 1-20

slots
See capacity

SMC, 1-21
SNMP, 1-20

transfer the library MIB file, 15-3
software

independent vendors, 1-21
library management applications, 1-20
SNMP, 1-20
storage system solutions, 1-22
StorageTek Library Console, 1-20

STA, 1-22
standalone SL Console

logging in, 4-1
standalone SLC, 3-2
status

library and devices, 14-3
status alerts

clearing, 17-6
displaying, 14-1

storage capacity
See capacity

storage management component, 1-21
StorageTek Library Console

See SLConsole
StorageTek Tape Analytics, 1-22
support, 1-31
switched fabric, 1-19

T
T10000

ordering, 1-27
T9840

ordering, 1-27
TallBot

See robotics
tape drives

addressing, E-15
arrays, 1-25
conversion kits, 1-27
hardware numbering, E-15
HLI-PRCs, E-9
internal firmware address, E-4
ordering, 1-26
power supplies, 1-10
power-up tool, 2-11
shipping, 2-5
supported types, 1-8

TCP/IP
card connections, 1-6
dual TCP/IP, ordering, 1-29
overview, 1-19

tools
drive power-up, 2-11
for installation, 2-10

topology, 1-19
transferring the log snapshot file, 15-3
troubleshooting, 1-31, 17-1
T-Series

ordering, 1-27

V
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