Skip Headers
Oracle® Explorer Data Collector User's Guide
Release 6.10 for Oracle Solaris

Part Number E28392-01
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

4 Oracle Explorer Data Collector Commands

This chapter lists the commands, files, and directories that are collected by the Oracle Explorer Data Collector modules, and it provides an estimated count of the total number of commands, files, and directories collected.

1280extended

Collects Netra 1280 and V1280 system controller information.

Commands Collected

The following commands are collected:

ls -l ${EXP_LW8INPUT_CONFIG}
showcomponent -v ${BOARD}

In addition, the following commands are collected from the remote host:

history
inventory
showalarm 1
showalarm 2
showalarm system
showboards -v
showdate -v
showenvironment -v
showescape
showeventreporting
showfault
showhostname
showlocator
showlogs -v
showmodel
shownetwork -v
showresetstate -v
showsc -v
showboards -e
showboards -p proms
showboards -v -p cpu
showboards -v -p memory
showboards -v -p board
showboards -v -p io
showboards -v -p version
showchs -b
showerrorbuffer
showcodlicense -v
showcodusage -v

alomextended

Collects additional diagnostic information for an Advanced Lights Out Manager (ALOM) system when connected to the ALOM using telnet or ssh.

Commands Collected

The following commands are collected from the remote host:

showsc -v
consolehistory -e 100
showlogs -e 100
showlocator
showenvironment
showfru
showplatform -v
shownetwork -v
showdate
usershow
showusers
showsc version -v
showlogs -v
showkeyswitch
consolehistory -v
showsc -v
showfaults -v
showusers
showcomponent
showhost

b1600extended

Collects Sun Fire B1600 System Controller information when connected to the blade using telnet.

Commands Collected

The following command is collected:

ls -l ${EXP_B1600INPUT_CONFIG}

In addition, the following commands are collected from the remote host:

showsc -v
showlogs -v CH
showenvironment -v
showplatform -v
showdate
usershow
showusers
consolehistory -v ${SX}
consolehistory -v ${SX}/SWT
showfru ${SX}
showlogs ${SX}

b1600switch

Collects Sun Fire B1600 Switch and System Controller information when connected to the blade using telnet.

Commands Collected

The following commands are collected from the remote host:

show version
show system
show running-config
show vlan
show interfaces status
show interfaces switchport
show ip interface
show logging ram
show logging flash
show gvrp configuration

cluster

Collects cluster information.

The cluster script uses many loops to collect data. It attempts to collect data for Oracle, Sybase, Informix, SAP, NFS, andHA-HTTPD. For each database, it also attempts to collect data for each instance.

Commands Collected

The following commands are collected:

/bin/file <core_file>
/bin/ls -l /usr/lib | /bin/grep informix
/bin/ls -l /var/cluster/logs/eventlog* 
/bin/ls -l /var/opt/SUNWcluster/devices
/bin/ls -lLd <core_file>
/bin/ls -lR ${HASYBDIR}
/bin/ps -ecf | /bin/grep ${SAPSID}
/opt/SUNWcacao/bin/cacaoadm
/usr/bin/echo '0t${pid}:A\n*cmm_dbg_buf/s\n:R\n\$q'|     adb /usr/cluster/lib/sc/rgmd -
/usr/bin/echo '0t${pid}:A\n*ucmm_dbg_buf/s\n:R\n\$q'|     adb /usr/cluster/lib/ucmm/ucmmd -
/usr/bin/echo '0t${pid}:A\n*cmm_dbg_buf/s\n:R\n\$q'|    adb /usr/cluster/lib/ucmm/ucmmd -
/usr/bin/ls -l /var/cluster/logs/eventlog*
/usr/cluster/dtk/bin/cmm_ctl -g
/usr/cluster/dtk/bin/replctl
/usr/cluster/dtk/bin/dcs_config -c info
/usr/cluster/dtk/bin/dcs_config -c status
/usr/cluster/dtk/bin/orbadmin -P all
/usr/cluster/dtk/bin/orbadmin -R all
/usr/cluster/dtk/bin/print_net_state -s
/usr/cluster/lib/sc/cmm_ctl -g
/usr/cluster/lib/sc/replctl
/usr/cluster/lib/sc/rgmd_debug printbuf
/usr/proc/bin/pstack <core_file>
/usr/sap/${SAPSID}/SYS/exe/run/disp+work -V
/usr/sbin/pkgchk -n ${PKG}
/usr/sbin/smcwebserver -V
${CLUSTERBIN}/clustm dumpstate ${CLUSTERNAME}
${CLUSTERBIN}/finddevices disks ${ctl}
${CLUSTERBIN}/get_node_status
${CLUSTERBIN}/hainformix list
${CLUSTERBIN}/haoracle list
${CLUSTERBIN}/hareg
${CLUSTERBIN}/hareg -q ${DB}
${CLUSTERBIN}/hareg -q ${DS}
${CLUSTERBIN}/hastat
${CLUSTERBIN}/hasybase list
${CLUSTERBIN}/pmfadm -l \"\"
${CLUSTERBIN}/pmfadm -l ${handle}
${CLUSTERBIN}/pnmstat -lm
${CLUSTERBIN}/scconf -pv
${CLUSTERBIN}/scconf -pvv
${CLUSTERBIN}/scconf ${CLUSTERNAME} -p
${CLUSTERBIN}/scdidadm -c
${CLUSTERBIN}/scdidadm -l
${CLUSTERBIN}/scdidadm -L
${CLUSTERBIN}/scdpm -p all:all
${CLUSTERBIN}/scinstall -pv
${CLUSTERBIN}/scnas -p
${CLUSTERBIN}/scnasdir -p
${CLUSTERBIN}/scrgadm -pv
${CLUSTERBIN}/scrgadm -pvv
${CLUSTERBIN}/scstat
${CLUSTERBIN}/scstat -pv
${CLUSTERBIN}/scstat -pvv
${PNMBIN}/pnmstat -l
${SCIBIN}/sciadm -ident
${SCIBIN}/sciinfo -a
${SMABIN}/get_ci_status
${SMABIN}/smactl -l
${SCIDBIN}/scidstat -su ${id}
${SDSBIN}/medstat -s ${s}
echo "$G;$<threadlist" | mdb -k /dev/ksyms /dev/mem
echo "$<dump_all" | mdb -I $adb_macro_path -k /dev/ksyms /dev/mem

If Sun Cluster 3.1 Geographic Edition 3.1 08/05 is installed, the following additional commands are collected:

/usr/cluster/bin/geoadm
/usr/cluster/bin/geops
/usr/cluster/bin/geopg
/usr/cluster/bin/geohb

If Sun Cluster 3.2 is installed, the following commands are collected:

${CLUSTERBIN}/claccess
               list -v
               show
${CLUSTERBIN}/cldevice
               list -v
               show -v
${CLUSTERBIN}/cldevicegroup
               list -v
               show
               show -v
${CLUSTERBIN}/clinterconnect
               show
               status
${CLUSTERBIN}/clnas
               list -v
               show
               show -v
${CLUSTERBIN}/clnode
               list -v
               show
${CLUSTERBIN}/clquorum
               list -v
               show
${CLUSTERBIN}/clreslogicalhostname
               list -v
               show
               show -v
${CLUSTERBIN}/clresource
               list -v
               show
               show -v
${CLUSTERBIN}/clresourcegroup
               list -v
               show
               show -v
${CLUSTERBIN}/clresourcetype
               list -v
               show
               show -v
${CLUSTERBIN}/clressharedaddress
               list -v
               show
               show -v
${CLUSTERBIN}/clsnmphost
               list -v
               show
               show -v
${CLUSTERBIN}/clsnmpmib
               list -v
               show
${CLUSTERBIN}/clsnmpuser
               list -v
               show
${CLUSTERBIN}/cltelemetryattribute
               print
               print -v
               show -v
               status -v
${CLUSTERBIN}/cluster
               list -v
               list-cmds
               list-checks
               show
               show -v
               status -v
${CLUSTERBIN}/clzonecluster
               list -v
               show
               show -v
               status -v

If Solaris 10 is installed, the following additional command is collected:

/usr/bin/svcs -a | grep cluster

In addition, if Solaris 10 is installed, the following command is collected for the services that are listed by the previous grep command:

svccfg export svc:$j

Files Collected

The following files are collected:

/etc/clusters
/etc/did.conf
/etc/inet/ntf.conf.cluster
/etc/opt/${PKG}/hadsconf
/etc/pnmconfig
/etc/sci.ifconf
/etc/sma.config
/etc/sma.ip
/etc/serialports
/var/opt/SUNWcacao/logs/cacao.0
/var/cluster/logs/<eventlog_file> (var/cluster/logs/<eventlog_file>)
/tmp/scsi3_keys.out
/tmp/pgre_keys.out
/.rhosts
${CLUSTERBIN}/init.snmpd
${DBSDIR}/config${ORASID}.ora
${ERRLOGFILE}
${FILE}
${FILE}
${HADSDIR}/hadsconf
${HAINFDIR}/inftab
${HAINFDIR}/etc/sqlhosts
${HAORADIR}/listener.ora
${HAORADIR}/oratab
${HAORADIR}/sqlnet.ora
${HAORADIR}/tnsnames.ora
${HASYBDIR}/interfaces
${HASYBDIR}/sybtab
${IFILE}
${INFDIR}/etc/sqlhosts
${INFDIR}/etc/${CONFIG}
${line}
${LOGFILE}
${MSGPATH}
${ORAHOME}/orainst/RELVER
${ORAHOME}/dbs/init${ORASID}.ora
${ORANET}/listener.ora
${ORANET}/sqlnet.ora
${ORANET}/tnsnames.ora
${START}
${STOP}
${SYBHOME}/init/sqlsrv/version
${SYBHOME}/interfaces
${SRCDIR}/ha${DB}_support
${SRCDIR}/ha${DB}_config_V1
${SRCDIR}/etc/udlm.conf
${SRCDIR}/etc/cvm.conf
${WORKDIR}/dev*
${WORKDIR}/std*
${WORKDIR}/*.log
${WORKDIR}/*.trc
${WORKDIR}/[A-Z]*
instrum-cacao.0
audit-cacao.0

Directories Collected

The following directories are collected:

${SRCDIR}/${dir}
${SCDIR}
/opt/${PKG}/etc
/var/opt/SUNWcacao/run

In addition, the following directories are collected recursively:

${SRCDIR}
${EXP_TMPDIR}/cluster
/var/cluster
/etc/cluster
/usr/sap/${SAPSID}/SYS/profile
/var/opt/sybase
/var/opt/informix
${EXP_TMPDIR}/cluster
/etc/opt/SUNWcacao
/etc/cacao

If Solaris 10 is installed, the following additional directory is collected:

usr/cluster/lib/svc/method

crypto

Gathers configuration for cryptographic framework.

Commands Collected

The following commands are collected:

usr/sbin/cryptoadm list -vm
usr/sbin/cryptoadm list -p
/usr/sbin/cryptoadm list metaslot
/usr/bin/find /kernel/crypto /platform/'uname -m' /kernel/crypto -type f 2>/dev/null
| /usr/bin/elfsign verify -e

Files Collected

The following files are collected:

/etc/crypto/kcf.conf
/etc/crypto/pkcsll.conf

disks

Collects generic disk information by using loops to collect data for each disk in /dev/rdsk/ and enclosures in /dev/es/. Also collects data for each file system in df -lFufs.

Commands Collected

The following commands are collected:

/opt/SUNWhd/hd/bin/hd
/opt/SUNWhd/hd/bin/hd -a
/opt/SUNWhd/hd/bin/hd -g
/opt/SUNWhd/hd/bin/hd -l
/opt/SUNWhd/hd/bin/hd -r
/opt/SUNWhd/hd/bin/hd -R
/opt/SUNWhd/hd/bin/hd -j
/opt/SUNWhd/hd/bin/hd -T
/opt/SUNWhd/hd/bin/hd -i
/opt/SUNWhd/hd/bin/hd -o
/opt/SUNWhd/hd/bin/hd -x
/opt/SUNWhd/hd/bin/hdadm diskqual all
/opt/SUNWhd/hd/bin/hdadm read_cache display all
/opt/SUNWhd/hd/bin/hdadm smart all
/opt/SUNWhd/hd/bin/hdadm write_cache display all
/opt/SUNWhwrdg/dptutil -L all
/opt/SUNWhwrdg/dptutil -L controller
/opt/SUNWhwrdg/dptutil -L logical
/opt/SUNWhwrdg/dptutil -L physical
/opt/SUNWhwrdg/dptutil -L raid
/opt/SUNWhwrdg/dptutil -L spare
/usr/bin/df -kl
/usr/bin/df -al
/usr/bin/df -el
/usr/bin/df -gl
/usr/bin/echo \"::sata_dmsg_dump\" | /usr/bin/mdb -k 
/usr/bin/echo 0 | /usr/sbin/format 2>&1 | sed -e '/^Specify disk/,\$d'
/usr/bin/iostat -E
/usr/bin/iostat -iE
/usr/bin/iostat -xpnc 3 3
/usr/bin/find /dev -type d -print | xargs ls -lL
/usr/bin/ls -l /dev/fc
/usr/bin/ls -l /dev/nrst*
/usr/bin/ls -l /dev/rdsk
/usr/bin/ls -l /dev/rmt*
/usr/bin/ls -l /dev/rst*
/usr/bin/ls -lAR /dev /devices
/usr/bin/ls -ld /tmp
/usr/bin/ls -lL /dev/*dsk/*
/usr/bin/ls -lL /dev/rmt/
/usr/sbin/fcadm list-fcoe-ports 
/usr/sbin/fstyp -v $bdev | sed '/^cylinder number /,\$d'
/usr/sbin/iscsiadm list discovery
/usr/sbin/iscsiadm list discovery-address -v
/usr/sbin/iscsiadm list initiator-node
/usr/sbin/iscsiadm list isns-server -v
/usr/sbin/iscsiadm list static-config
/usr/sbin/iscsiadm list target -S
/usr/sbin/iscsiadm list target -v
/usr/sbin/iscsiadm list target-param -v
/usr/sbin/itadm list-initiator -v
/usr/sbin/itadm list-target -v
/usr/sbin/itadm list-tpg -v
/usr/sbin/luxadm fcode_download -p
/usr/sbin/luxadm inq /dev/es/${ES}
/usr/sbin/luxadm probe
/usr/sbin/luxadm probe -p
/usr/sbin/luxadm qlgc_s_download
/usr/sbin/luxadm -e dump_map ${HBA_PORT}
/usr/sbin/luxadm -e port
/usr/sbin/luxadm -e rdls
/usr/sbin/mount
/usr/sbin/mount -v
/usr/sbin/mpathadm list initiator-port
/usr/sbin/mpathadm show initiator-port
/usr/sbin/mpathadm list LU
/usr/sbin/mpathadm show LU
/usr/sbin/mpathadm list mpath-support
/usr/sbin/mpathadm show  mpath-support
/usr/sbin/prtvtoc /dev/rdsk/$diskname$k
/usr/sbin/raidctl
/usr/sbin/raidctl -l
/usr/sbin/raidctl -l <volume name>
/usr/sbin/stmfadm list-hg -v
/usr/sbin/stmfadm list-lu -v
/usr/sbin/stmfadm list-state
/usr/sbin/stmfadm list-target -v
/usr/sbin/stmfadm list-tg -v 
/usr/sbin/swap -l
/usr/sbin/swap -s
/usr/sbin/zpool list
/usr/sbin/zpool status -v
/usr/sbin/zpool iostat -v
/usr/sbin/zfs get -rHp all ${pool}
zlogin ${ZONENAME} '/usr/bin/df -klZ'
zlogin ${ZONENAME} '/usr/bin/df -alZ'
zlogin ${ZONENAME} '/usr/bin/df -elZ'
zlogin ${ZONENAME} '/usr/bin/df -glZ'
zlogin ${ZONENAME} '/usr/bin/ls -lAR /dev'
zlogin ${ZONENAME} '/usr/bin/swap -l'
zlogin ${ZONENAME} '/usr/bin/find /dev -type d -print | xargs ls -lL'
zlogin ${ZONENAME} '/usr/bin/ls -ld /tmp'
zlogin ${ZONENAME} '/usr/bin/df -kl'
zlogin ${ZONENAME} '/usr/bin/df -al'
zlogin ${ZONENAME} '/usr/bin/df -el'
zlogin ${ZONENAME} '/usr/bin/df -gl'
zlogin ${ZONENAME} '/usr/sbin/mount'
${DISKINFO} -d
cache
display
EOF
format -e -d <disk name> <<EOF
q
write_cache
For each LU /usr/sbin/stmfadm list-view -l <LU> 

Directories Collected

The following directory is collected:

/etc/iscsi

Files Collected

The following files are collected:

/kernel/drv/st.conf
/var/opt/SUNWhwrdg/dptelog.*
/opt/SUNWhd/web/hd_map.html file

emc

Collects EMC Powerpath information.

Commands Collected

The following command is collected:

${EMC_PATH}/EMCpower/bin/powermt display dev=all

etc

Collects /etc configuration files.

Commands Collected

The following commands are collected:

/usr/sbin/fcadm list-fcoe-ports
/usr/sbin/fcinfo logical-unit -v
/usr/sbin/svccfg -s coreadm:default listprop config_params/*
/usr/sbin/svccfg -s dumpadm:default listprop config_params/*
/usr/sbin/zlogin <zone> '/usr/sbin/svccfg -s coreadm:default listprop config_params/*'
/usr/sbin/zlogin <zone> '/usr/sbin/svccfg -s dumpadm:default listprop config_params/*' 

Files Collected

The following files are collected:

/etc/auto_master
/etc/bootparams
/etc/cpudiagd.conf
/etc/defaultdomain
/etc/defaultrouter
/etc/dfs/dfstab
/etc/dfs/sharetab
/etc/driver_aliases
/etc/driver_classes
/etc/dumpadm.conf
/etc/dumpdates
/etc/ethers
/etc/fcswitch.conf
/etc/hostname.*
/etc/hostname6.*
/etc/hosts
/etc/ibmatl.conf
/etc/inet/ike/config
/etc/inet/ipnodes
/etc/inet/ipsecinit.conf
/etc/inet/ipsecpolicy.conf
/etc/inet/ndpd.conf
/etc/inet/netmasks
/etc/inet/networks
/etc/inet/ntp.client
/etc/inet/ntp.conf
/etc/inet/ntp.server
/etc/inetd.conf
/etc/init.d/sysetup
/etc/inittab
/etc/mnttab
/etc/name_to_major
/etc/netconfig
/etc/nodename
/etc/notrouter
/etc/nscd.conf
/etc/nsswitch.conf
/etc/openwin/server/etc/OWconfig
/etc/pam.conf
/etc/path_to_inst
/etc/pooladm.conf 
/etc/power.conf
/etc/profile
/etc/project
/etc/release
/etc/resolv.conf
/etc/rmmount.conf
/etc/rpc
/etc/services
/etc/shells
/etc/ssh/ssh_config (etc/ssh/)
/etc/ssh/sshd_config (etc/ssh/)
/etc/ssphostname
/etc/syslog.conf
/etc/system
/etc/TIMEZONE
/etc/user_attr
/etc/vfstab
/etc/X11/xorg.conf
/var/inet/ndpd_state.*
${ROOTDIR}/.dtprofile
${ROOTDIR}/.profile
${ROOTDIR}/.kshrc
${ROOTDIR}/.cshrc
${ROOTDIR}/.login
${ROOTDIR}/.logout
${ZONEPATH}/etc/ssh/sshd_config (zones/<zone>/etc/ssh/)
${ZONEPATH}/etc/ssh/ssh_config (zones/<zone>/etc/ssh/) 
${ZONEPATH}/root/etc/TIMEZONE
${ZONEPATH}/root/etc/atuomaster
${ZONEPATH}/root/etc/hosts
${ZONEPATH}/root/etc/inetd.conf
${ZONEPATH}/root/etc/defaultdomain
${ZONEPATH}/root/etc/defaultrouter
${ZONEPATH}/root/etc/dumpdates
${ZONEPATH}/root/etc/coreadm.conf
${ZONEPATH}/root/etc/ethers
${ZONEPATH}/root/etc/fcswitch.conf
${ZONEPATH}/root/etc/mnttab
${ZONEPATH}/root/etc/nscd.conf
${ZONEPATH}/root/etc/nsswitch.conf
${ZONEPATH}/root/etc/pam.conf
${ZONEPATH}/root/etc/rpc
${ZONEPATH}/root/etc/release
${ZONEPATH}/root/etc/resolv.conf
${ZONEPATH}/root/etc/services
${ZONEPATH}/root/etc/vfstab
${ZONEPATH}/root/etc/nodename
${ZONEPATH}/root/etc/inittab
${ZONEPATH}/root/etc/syslog.conf
${ZONEPATH}/root/etc/shells
${ZONEPATH}/root/etc/init.d/sysetup
${ZONEPATH}/root/etc/rmmount.conf
${ZONEPATH}/root/etc/inet/netmasks
${ZONEPATH}/root/etc/inet/networks
${ZONEPATH}/root/etc/inet/ipnodes

Directories Collected

The following directories are collected:

/etc/cfg/fp
/etc/opt/SUNWexplo/sunone
-f *input.txt /etc/opt/SUNWexplo
/etc/default
${ZONEPATH}/root/etc/cfg/fp
${ZONEPATH}/root/etc/dt
${ZONEPATH}/root/etc/default

The following directories are collected recursively:

/etc/dt
/etc/zones

etcextended

Collects etcextended information using the Remote Diagnostic Agent (RDA).

Directories Collected

The following directories are collected:

/etc/security (etc/security)
${ZONEPATH}/etc/security (zones/<zone>/etc/security) 

fcal

Collects disk information on internal FCAL drives.

Commands Collected

The following command is collected:

/usr/sbin/luxadm display ${LUN}

firelink

Collects Sun Fire Link hardware and software interconnect information.

Commands Collected

The following commands are collected:

$WRSMCONF topology
$WRSMCONF check
$WRSMCONF info
$WRSMSTAT controller
$WRSMSTAT wrsm
$WRSMSTAT route
$JAVA_BIN/java -version 2>&1
$FM_BIN/listfabrics
$FM_BIN/wcfmstat $FABRICS
$FM_BIN/wcfmstat -p $PARTITIONS $FABRICS
$JAVA_BIN/java -version 2>&1

Files Collected

The following file is collected:

/tmp/wrsmconf-dump.c$c

Directories Collected

The following directories are collected recursively:

/etc/wrsm
/var/opt/SUNWwrsmp
$WCFM_BASE_DATA_DIR

fma

Collects Fault Management Architecture information.

Commands Collected

The following commands are collected:

/usr/bin/ls -l /usr/platform/'uname -m'/lib/fm/fmd/plugins/
/usr/bin/ls -l /usr/lib/fm/fmd/plugins/
/usr/lib/fm/fmd/plugins/
/usr/lib/fm/fmd/fmtopo -V
/usr/lib/fm/fmd/fmtopo -x
/usr/sbin/fmadm config
/usr/sbin/fmadm faulty
/usr/sbin/fmadm faulty -a
/usr/sbin/fmadm faulty -i
/usr/sbin/fmdump
/usr/sbin/fmdump -e
/usr/sbin/fmdump -V
/usr/sbin/fmdump -eV
/usr/sbin/fmdump -eu $UUID
/usr/sbin/fmdump -u $UUID
/usr/sbin/fmdump -eVu $UUID
/usr/sbin/fmdump -vu $UUID
/usr/sbin/fmdump -Vu $UUID
/usr/sbin/fmstat -a
/usr/sbin/fmstat -s -m ${X}
/usr/sbin/fmstat -t
/usr/sbin/fmstat -T
/usr/sbin/fmstat -a -m <module>
/usr/sbin/fmdump -av

Directories Collected

The following directory is collected:

/var/fm/fmd/topo (fma/var/fm/fmd/topo) 

Files Collected

The following files are collected:

/var/fm/fmd/errlog*
/var/fm/fmd/fltlog*
/var/fm/fmd/infolog* (fma/var/fm/fmd)
/var/fm/fmd/infolog_hival* (fma/var/fm/fmd)
/var/fm/fmd/rsrc
/etc/fm/fmd/fmd.conf
/usr/platform/'uname -m'/lib/fm/fmd/plugins/*.conf
/usr/lib/fm/fmd/plugins/*.conf

fru

Collects FRU id information.

Commands Collected

The following command is collected:

/usr/sbin/prtfru -x

hds

Collects information on the 99xx series.

Commands Collected

The following commands are collected:

/opt/HITdpo/bin/showvpath
/opt/HITdpo/bin/datapath query adapter
/opt/HITdpo/bin/datapath query device
/usr/bin/pairdisplay
$DLNKMGR view -sys
$DLNKMGR view -sys -sfunc
$DLNKMGR view -sys -msrv
$DLNKMGR view -sys -adrv
$DLNKMGR view -sys -pdrv
$DLNKMGR view -path
$RAIDQRY -h

Files Collected

The following files are collected:

$MGR_LOG_DIR/dlmmgr*
$MM_DIR/*
$TRC_FILE_DIR/hntr*$TRC_SETUP_DIR/*
$CCICONF_DIR/*.conf
/etc/horcm*

Directories Collected

The following directory is collected recursively:

$CCILOG_DIR recursive

ib

Collects InfiniBand information using the Remote Diagnostic Agent (RDA).

Commands Collected

The following commands are collected:

/usr/bin/rds-info 
/usr/sbin/dladm show-ib
/usr/sbin/fwflash -l - c IB
/usr/sbin/ibaddr
/usr/sbin/ibcheckerrors -N
/usr/sbin/ibcheckstate
/usr/sbin/ibcheckwidth
/usr/sbin/ibdatacounters -N
/usr/sbin/iblinkinfo.pl
/usr/sbin/ibnetdiscover
/usr/sbin/ibnodes
/usr/sbin/ibstat

ilomextended

Collects remote Integrated Lights OutManager (ILOM) Intelligent Platform Management Interface (IPMI) data from Galaxy systems.

Commands Collected

The ipmitool command is searched in the following directories:

/opt/ipmitool/bin
/usr/sbin
/usr/sfw/bin

The following commands are collected:

ipmitool -H {host} -p {port} -U {user} -f {pwfile} mc info
ipmitool -H {host} -p {port} -U {user} -f {pwfile} mc getenables
ipmitool -H {host} -p {port} -U {user} -f {pwfile} chassis poh
ipmitool -H {host} -p {port} -U {user} -f {pwfile} chassis restart_cause
ipmitool -H {host} -p {port} -U {user} -f {pwfile} chassis power status
ipmitool -H {host} -p {port} -U {user} -f {pwfile} fru print
ipmitool -H {host} -p {port} -U {user} -f {pwfile} pef status
ipmitool -H {host} -p {port} -U {user} -f {pwfile} pef list
ipmitool -H {host} -p {port} -U {user} -f {pwfile} sdr list full
ipmitool -H {host} -p {port} -U {user} -f {pwfile} sel info
ipmitool -H {host} -p {port} -U {user} -f {pwfile} sel elist
ipmitool -H {host} -p {port} -U {user} -f {pwfile} sensor list
ipmitool -H {host} -p {port} -U {user} -f {pwfile} user summary
ipmitool -H {host} -p {port} -U {user} -f {pwfile} user list
ipmitool -H {host} -p {port} -U {user} -f {pwfile} sunoem led get

ilomsnapshot

Collects remote Integrated Lights Out Manager (ILOM) snapshot data.

Commands Collected

The following commands are collected:

show /X/diag/snapshot result
where Xstands for CMM of SP of ILOM type.

indy

Collects Sun StorEdge 3910, 3960, 6910, and 6960 information.

Commands Collected

The following commands are collected:

/bin/ls -l ${EXP_INDYINPUT_CONFIG}
${EXP_HOME}/bin/curl.'uname -p' --silent --retry 1 -o /tmp/${INDY_NAME}.response -u %s:%s
\"http://%s:%s/?GET=RUNSS&comm=ras_ admin+host_detail\"
${EXP_HOME}/bin/curl.'uname -p' --connect-timeout 300 --silent --retry 1 -o /tmp/${INDY_NAME}
.tar -u %s:%s \"http://%s:%s/?GET=RUNSS&comm=se_extract+-r+-x\"

Files Collected

The following files are collected:

/tmp/response
/tmp/${INDY_NAME}.tar

init

Collects init.d scripts.

Directories Collected

The following directories are collected:

/etc/rc0.d
/etc/rc1.d
/etc/rc2.d
/etc/rc3.d
/etc/rcS.d

instinfo

Collects information from an instinfo installation.

Files Collected

The following file is collected:

/etc/opt/SUNWexplo/instinfo/install_info

ipmi

Collects local Intelligent Platform Management Interface (IPMI) data on x86 platform.

Commands Collected

The ipmitool command is searched in the following directories:

/opt/ipmitool/bin
/usr/sbin
/usr/sfw/bin

The following commands are collected:

ipmitool chassis status
ipmitool chassis poh
ipmitool chassis power status
ipmitool chassis restart_cause
ipmitool fru
ipmitool fru print
ipmitool mc getenables
ipmitool mc info
ipmitool pef status
ipmitool pef list
ipmitool sel info
ipmitool sel elist
ipmitool sdr enlist full
ipmitool sdr list all info
ipmitool sensor list
ipmitool sunoem led get
ipmitool -I bmc sunoem sbled get
ipmitool -v sel elist
ipmitool -V
/usr/sbin/ilomconfig list system-summary

ipmiextended

Collects remote Intelligent Platform Management Interface (IPMI) data.

Commands Collected

The ipmitool command is searched in the following directories:

/opt/ipmitool/bin
/usr/sbin
/usr/sfw/bin

The following commands are collected:

ipmitool -H {host} -p {port} -U {user} -f {pwfile} chassis status
ipmitool -H {host} -p {port} -U {user} -f {pwfile} fru
ipmitool -H {host} -p {port} -U {user} -f {pwfile} pef status
ipmitool -H {host} -p {port} -U {user} -f {pwfile} pef list
ipmitool -H {host} -p {port} -U {user} -f {pwfile} sel info
ipmitool -H {host} -p {port} -U {user} -f {pwfile} sel elist
ipmitool -H {host} -p {port} -U {user} -f {pwfile} sdr list all info
ipmitool -H {host} -p {port} -U {user} -f {pwfile} -v sel elist

j2se

Collects installation and configuration data from a Java 2 Platform Standard Edition (J2SE) installation.

Commands Collected

The following commands are collected:

${j_array[${j}]}/bin/java -version
${j_array[${j}]}/bin/java -fullversion
/usr/bin/sum ${j_array[${j}]}/jre/lib/*
/usr/bin/find ${j_array[${j}]}/jre/lib/ -type -f -exec /usr/bin/sum {} \;
${j_array[${j}]}/jre/bin/java -version
${j_array[${j}]}/jre/bin/java -fullversion
/usr/bin/sum ${j_array[${j}]}/jre/lib/*
/usr/bin/find ${j_array[${j}]}/jre/lib/ -type -f -exec /usr/bin/sum {} \
zlogin ${ZONENAME} '${j_array[${j}]}/bin/java -version'
zlogin ${ZONENAME} '${j_array[${j}]}/bin/java -fullversion'
zlogin ${ZONENAME} '/usr/bin/sum ${j_array[${j}]}/jre/lib/*'
zlogin ${ZONENAME} '/usr/bin/find ${j_array[${j}]}/jre/lib/ -type -f -exec /usr/bin/sum {} \;'
zlogin ${ZONENAME} '${j_array[${j}]}/jre/bin/java -version'
zlogin ${ZONENAME} '${j_array[${j}]}/jre/bin/java -fullversion'
zlogin ${ZONENAME} '/usr/bin/sum ${j_array[${j}]}/jre/lib/*'
zlogin ${ZONENAME} '/usr/bin/find ${j_array[${j}]}/jre/lib/ -type -f -exec /usr/bin/sum {} \;'

Files Collected

The following files are collected:

${j_array[${j}]}/lib/security/java.policy
${j_array[${j}]}/lib/security/java.security
${j_array[${j}]}/jre/lib/security/java.policy
${j_array[${j}]}/jre/lib/security/java.security
${ZONEPATH}/root/${j_array[${j}]}/lib/security/java.policy
${ZONEPATH}/root/${j_array[${j}]}/lib/security/java.security
${ZONEPATH}/root/${j_array[${j}]}/jre/lib/security/java.policy
${ZONEPATH}/root/${j_array[${j}]}/jre/lib/security/java.security

ldap

Collects both client and server Lightweight Directory Access Protocol (LDAP) information.

Commands Collected

The following commands are collected:

/usr/bin/ldaplist
/usr/bin/ldaplist -d
/usr/bin/ldaplist -l
/usr/bin/ldaplist -l profile
/usr/lib/ldap/cachemgr -g
/usr/bin/ldapsearch -h ${SRVHOST} -b ${BASEDN} aci=\* aci
/usr/bin/ldapsearch -h ${SRVHOST} -b cn=monitor -s base objectclass=*
/usr/bin/ldapsearch -h ${SRVHOST} -b cn=monitor -s one objectclass=*
/usr/sbin/directoryserver -s ${instance} monitor (Solaris 9 or higher)
/usr/sbin/ldapclient -l (Oracle Solaris 8)
/usr/sbin/ldapclient list (Oracle Solaris 9 or higher)

Files Collected

The following files are collected:

/var/ds5/${di}/logs/access
/var/ds5/${di}/logs/errors

Directories Collected

The following directory is collected:

/var/ldap

ldom

Collects information on logical domains.

Commands Collected

The following commands are collected:

/opt/SUNWldm/bin/ldm list
/opt/SUNWldm/bin/ldm ls-dom
/opt/SUNWldm/bin/ldm ls-dom -l
/opt/SUNWldm/bin/ldm ls-dom -p
/opt/SUNWldm/bin/ldm list-spconfig
/opt/SUNWldm/bin/ldm list-bindings primary
/opt/SUNWldm/bin/ldm list-devices
/opt/SUNWldm/bin/ldm list-services
/opt/SUNWldm/bin/ldm list-constraints
/opt/SUNWldm/bin/ldm list-constraints -p
/opt/SUNWldm/bin/ldm list-constraints -x
/opt/SUNWldm/bin/ldm list-spconfig
/opt/SUNWldm/bin/ldm list-variable
/opt/SUNWldm/bin/ldm list-devices cpu
/opt/SUNWldm/bin/ldm list-devices mau
/opt/SUNWldm/bin/ldm list-devices memory
/opt/SUNWldm/bin/ldm list-devices io

Files Collected

The following files are collected:

/var/opt/SUNWldm/ldom-db.xml
/var/opt/SUNWldm/mac_allocation.xml

lic

Collects license information.

Commands Collected

The following commands are collected:

/etc/fw/bin/fw printlic
/usr/sbin/vxlicense -p
/usr/sbin/vxserial -p
/usr/sbin/vxfsserial -p
/sbin/vxlicrep
$licdir/lmstat -a -c $licdir/$licfile

Files Collected

The following file is collected:

/var/tmp/license_log

lp

Collects printer information.

Commands Collected

The following commands are collected:

/usr/bin/fnlist thisorgunit/service/printer
/usr/bin/ls -l /etc/lp/interfaces
/usr/bin/ls -l /var/spool/lp
/usr/bin/ls -l /var/spool/print
/usr/bin/ls -ld /usr/bin/lp
/usr/bin/ls -ld /var/lp/logs
/usr/bin/ls -ld /var/lp/logs/lpsched
/usr/bin/ls -ld /var/lp/logs/requests
/usr/sbin/fnselect
/usr/sbin/lpfilter -fall -l

Files Collected

The following files are collected:

/etc/lp/filter.table
/etc/lp/logs/ipp-errors
/var/lp/logs/lpsched*
/var/lp/logs/requests* 
/etc/lp/Systems
/etc/printers.conf

Directories Collected

The following directories are collected:

/etc/cups
/etc/lp/printers
/var/log/cups

lvm

Collects Solstice DiskSuite information. Additional data is gathered for each disk set.

Commands Collected

The following commands are collected:

/usr/sbin/metastat -c (disks/svm/metastat-c.out)
/usr/sbin/metastat $metaparam -c (disks/svm/metastat-c.$diskset.out) 
${SDSPATH}/metastat
${SDSPATH}/metastat -p
${SDSPATH}/metastat -t
${SDSPATH}/metadb
${SDSPATH}/metastat -s$diskset
${SDSPATH}/metastat -s$diskset -p
${SDSPATH}/metastat -s$diskset -t
${SDSPATH}/metadb -s$diskset
${SDSPATH}/metaset -s$diskset

Directories Collected

The following directories are collected:

/etc/opt/SUNWmd
/etc/lvm

messages

Collects /var/adm/messages*. In addition to /var/adm/messages*, the messages script attempts to collect additional log files specified in /etc/syslog.conf.

Commands Collected

The following commands are collected:

/usr/bin/dmesg
zlogin ${ZONENAME} '/usr/bin/dmesg'

Files Collected

The following files are collected:

/var/adm/messages*
${f}
${ZONEPATH}/root/var/adm/messages*

nbu

Collects NetBackup information.

Commands Collected

The following commands are collected:

/usr/bin/ls -lartR ${OPENVDIR}
${OPENVDIR}/netbackup/bin/goodies/support
${OPENVDIR}/netbackup/bin/goodies/support/support
${OPENVDIR}/netbackup/bin/goodies/available_media
${OPENVDIR}/netbackup/bin/admincmd/get_license_key -L features
${OPENVDIR}/netbackup/bin/admincmd/get_license_key -L keys
${OPENVDIR}/netbackup/bin/admincmd/bpconfig -U
${OPENVDIR}/netbackup/bin/admincmd/bpsyncinfo -U
${OPENVDIR}/netbackup/bin/admincmd/bpgetconfig

Files Collected

The following files are collected:

${OPENVDIR}/netbackup/db/Class_att_defs
${OPENVDIR}/netbackup/db/IDIRSTRUCT
${OPENVDIR}/netbackup/db/INDEXLEVEL
${OPENVDIR}/netbackup/db/bpenableLN.scr
${OPENVDIR}/netbackup/db/bpenableTD.scr
${OPENVDIR}/netbackup/db/images/*/INDEXLEVEL
${OPENVDIR}/java/JBPSimple.properties
${OPENVDIR}/java/Launch.properties
${OPENVDIR}/java/Xenv
${OPENVDIR}/java/*conf
${OPENVDIR}/netbackup/bp.conf
${OPENVDIR}/netbackup/version
${OPENVDIR}/netbackup/bin/version
${OPENVDIR}/netbackup/bin/*notify*
${OPENVDIR}/volmgr/version
${OPENVDIR}/volmgr/bin/driver/sg.conf*
${OPENVDIR}/volmgr/bin/driver/sg.links*

Directories Collected

The following directories are collected recursively:

${OPENVDIR}/netbackup/db/class
${OPENVDIR}/netbackup/db/class_template
${OPENVDIR}/netbackup/db/client
${OPENVDIR}/netbackup/db/config
${OPENVDIR}/netbackup/db/error
${OPENVDIR}/netbackup/db/failure_history
${OPENVDIR}/netbackup/db/jobs
${OPENVDIR}/netbackup/db/media
${OPENVDIR}/java/logs
/usr/openv/netbackup/bin/support/output/nsbu/<hostname_timestam>

nbu_extended

Collects Extended NetBackup information.

Commands Collected

The following commands are collected:

ls -larTR ${OPENVDIR}
${OPENVDIR}/netbackup/bin/goodies/support
${OPENVDIR}/netbackup/bin/goodies/support/support
${OPENVDIR}/netbackup/bin/goodies/available_media
${OPENVDIR}/netbackup/bin/admincmd/get_license_key -L features
${OPENVDIR}/netbackup/bin/admincmd/get_license_key -L keys
${OPENVDIR}/netbackup/bin/admincmd/bpconfig -U
${OPENVDIR}/netbackup/bin/admincmd/bpsyncinfo -U
${OPENVDIR}/netbackup/bin/admincmd/bpgetconfig
${OPENVDIR}/netbackup/bin/admincmd/bperror -U -all -d 01/30/00 00:00:00
${OPENVDIR}/netbackup/bin/admincmd/bperror -U -media -d 01/30/00 00:00:00
${OPENVDIR}/netbackup/bin/admincmd/bpcllist -allclasses -U
${OPENVDIR}/netbackup/bin/admincmd/bpclclients
${OPENVDIR}/netbackup/bin/admincmd/bpmedialist -U -mlist
${OPENVDIR}/netbackup/bin/admincmd/bpmedialist -summary
${OPENVDIR}/netbackup/bin/admincmd/bpmedialist -summary -brief
${OPENVDIR}/netbackup/bin/admincmd/bpimmedia -U
${OPENVDIR}/netbackup/bin/admincmd/bpimagelist -A -d 01/30/00 00:00:00
${OPENVDIR}/netbackup/bin/admincmd/bpimagelist -A -media -d 01/30/00 00:00:00
${OPENVDIR}/netbackup/bin/admincmd/bpconfig -U
${OPENVDIR}/netbackup/bin/admincmd/bpsyncinfo -U
${OPENVDIR}/netbackup/bin/admincmd/bpgetconfig
${OPENVDIR}/netbackup/bin/admincmd/bpdbjobs -report
${OPENVDIR}/netbackup/bin/admincmd/bpdbjobs -summary
${OPENVDIR}/netbackup/bin/admincmd/bpstulist -U -verbose
${OPENVDIR}/netbackup/bin/bpps -a
${OPENVDIR}/netbackup/bin/bpclimagelist
${OPENVDIR}/volmgr/bin/vmquery -a
${OPENVDIR}/volmgr/bin/vmquery -a -bx
${OPENVDIR}/volmgr/bin/vmquery -a -w
${OPENVDIR}/volmgr/bin/vmpool -listall
${OPENVDIR}/volmgr/bin/vmrule -listall
${OPENVDIR}/volmgr/bin/tpclean -L
${OPENVDIR}/netbackup/bin/admincmd/bppllist -allpolicies -U
${OPENVDIR}/netbackup/bin/admincmd/bpplclients
${OPENVDIR}/netbackup/bin/admincmd/bpdbjobs -all_columns

Files Collected

The following files are collected:

$file
${OPENVDIR}/netbackup/db/Class_att_defs
${OPENVDIR}/netbackup/db/IDIRSTRUCT
${OPENVDIR}/netbackup/db/INDEXLEVEL
${OPENVDIR}/netbackup/db/bpenableLN.scr
${OPENVDIR}/netbackup/db/bpenableTD.scr
${OPENVDIR}/netbackup/db/images/*/INDEXLEVEL
${OPENVDIR}/java/JBPSimple.properties
${OPENVDIR}/java/Launch.properties
${OPENVDIR}/java/Xenv
${OPENVDIR}/java/*conf
${OPENVDIR}/netbackup/bp.conf
${OPENVDIR}/netbackup/version
${OPENVDIR}/netbackup/bin/version
${OPENVDIR}/netbackup/bin/*notify*
${OPENVDIR}/volmgr/version
${OPENVDIR}/volmgr/bin/driver/sg.conf*
${OPENVDIR}/volmgr/bin/driver/sg.links*
${OPENVDIR}/netbackup/nblog.conf

Directories Collected

The following directories are collected recursively:

${OPENVDIR}/netbackup/logs
${OPENVDIR}/netbackup/db/class
${OPENVDIR}/netbackup/db/class_template
${OPENVDIR}/netbackup/db/client
${OPENVDIR}/netbackup/db/config
${OPENVDIR}/netbackup/db/error
${OPENVDIR}/netbackup/db/failure_history
${OPENVDIR}/netbackup/db/jobs
${OPENVDIR}/netbackup/db/media
${OPENVDIR}/volmgr/debug
${OPENVDIR}/java/logs
${OPENVDIR}/netbackup/vault/sessions
${OPENVDIR}/netbackup/db/vault
/usr/openv/netbackup/bin/support/output/nsbu/<hostname_timestamp>/.texttxt

ndd

Collects network device driver information. The ndd script attempts to collect driver information for 6 services (arp, icmp, ip, sctp, tcp, and udp). It also collects data for up to 16 instances of 10 cards (such as hme or qfe). For each service or card instance, the script collects data for all parameters of that driver.

Commands Collected

The following commands are collected:

/usr/bin/echo '::walk sctps |::sctp -a' | mdb -k (netinfo/)
/usr/sbin/ndd /dev/arp \?
/usr/sbin/ndd /dev/icmp \?
/usr/sbin/ndd /dev/ip \?
/usr/sbin/ndd /dev/sctp \?
/usr/sbin/ndd /dev/tcp \?
/usr/sbin/ndd /dev/udp \?

For parameters with write only:

/usr/sbin/ndd /dev/arp <param>
/usr/sbin/ndd /dev/icmp <param>
/usr/sbin/ndd /dev/ip <param>
/usr/sbin/ndd /dev/sctp <param> 
/usr/sbin/ndd /dev/tcp <param>
/usr/sbin/ndd /dev/udp <param>

For network card devices:

/usr/sbin/ndd /dev/<device> \?

For parameters with write only:

/usr/sbin/ndd /dev/<device> <param>

netinfo

Collects generic network information.

Commands Collected

The following commands are collected:

/etc/fw/bin/fw ver
/etc/opt/SUNWconn/bin/nettr -stats $head device=ge type=1
/etc/opt/SUNWconn/bin/nettr -stats $head device=ge type=2
/etc/opt/SUNWconn/bin/nettr -stats $head device=qfe type=1
/etc/opt/SUNWconn/bin/nettr -stats $head device=qfe type=2
/etc/opt/SUNWconn/bin/nettr -stats $heads type=1
/etc/opt/SUNWconn/bin/nettr -stats $heads type=2
/etc/opt/SUNWconn/trunking/bin/nettr -conf
/etc/opt/SUNWconn/trunking/bin/nettr -conf lacp
/usr/bin/kstat -c net 3 3
/usr/bin/kstat -p
/usr/bin/netstat -an
/usr/bin/netstat -gn
/usr/bin/netstat -in
/usr/bin/netstat -m
/usr/bin/netstat -pn
/usr/bin/netstat -rn
/usr/bin/netstat -rvan
/usr/bin/netstat -s
/usr/bin/nfsstat
/usr/bin/niscat -o $domain
/usr/bin/nisdefaults
/usr/bin/nisls -lR
/usr/bin/rds-info
/usr/bin/rds-info -n
/usr/bin/rpcinfo
/usr/bin/rpcinfo -m
/usr/lib/nis/nisping -u org_dir
/usr/lib/nis/nisshowcache -v
/usr/lib/nis/nisstat
/usr/sbin/arp -a
/usr/sbin/arp ${hostname}
/usr/sbin/dladm show-aggr -L
/usr/sbin/dladm show-aggr -Z
/usr/sbin/dladm show-bridge
/usr/sbin/dladm show-dev
/usr/sbin/dladm show-ether -Z
/usr/sbin/dladm show-etherstub -Z 
/usr/sbin/dladm show-ib
/usr/sbin/dladm show-iptun -Z
/usr/sbin/dladm show-linkprop
/usr/sbin/dladm show-part
/usr/sbin/dladm show-part 
/usr/sbin/dladm show-phys -L 
/usr/sbin/dladm show-phys -Z 
/usr/sbin/dladm show-secobj
/usr/sbin/dladm show-vlan -Z
/usr/sbin/dladm show-vnic -Z 
/usr/sbin/dladm show-wifi -Z 
/usr/sbin/dlstat -A
/usr/sbin/dlstat -Z
/usr/sbin/flowadm show-flow 
/usr/sbin/flowadm show-flow -P 
/usr/sbin/flowadm show-flowprop 
/usr/sbin/flowadm show-flowprop -P 
/usr/sbin/flowstat -A 
/usr/sbin/ibdiagnet
/usr/sbin/ibv_devinfo 
/usr/sbin/idmap dump 
/usr/sbin/idmap dump -n 
/usr/sbin/idmap list 
/usr/sbin/ilbadm export-config 
/usr/sbin/ipadm show-addr 
/usr/sbin/ipadm show-addrprop 
/usr/sbin/ipadm show-if -o all 
/usr/sbin/ipadm show-ifprop 
/usr/sbin/ipf -V
/usr/sbin/ipmpstat -an (netinfo/ipmpstat_an.out) 
/usr/sbin/ipmpstat -g (netinfo/ipmpstat_g.out) 
/usr/sbin/ipmpstat -i (netinfo/ipmpstat_i.out) 
/usr/sbin/ipmpstat -pn & sleep 5 && kill $! (netinfo/ipmpstat_pn.out) 
/usr/sbin/ipmpstat -tn (netinfo/ipmpstat_tn.out) 
/usr/sbin/ipqosconf -l 
/usr/sbin/netadm list -x 
/usr/sbin/netcfg export 
/usr/sbin/sharectl get autofs
/usr/sbin/sharectl get nfs 
/usr/sbin/sharectl get smb 
/usr/sbin/smbadm show-domains 
/usr/sbin/smbadm show-groups -mp 
/usr/sbin/soconfig -l 
/usr/sbin/svccfg -s idmap listprop 
/usr/sbin/svccfg -s smb listprop 
/usr/sbin/svccfg -s smb/client listprop 
/usr/sbin/svccfg -s smb/server listprop 
/usr/sbin/vrrpadm show-router -x 
/usr/sbin/zlogin <zone> '/usr/sbin/idmap dump -n' 
/usr/sbin/zlogin <zone> '/usr/sbin/idmap dump' 
/usr/sbin/zlogin <zone> '/usr/sbin/idmap list' 
/usr/sbin/zlogin <zone> '/usr/sbin/ipmpstat -an'     (zones/<zone>/netinfo/ipmpstat_an.out) 
/usr/sbin/zlogin <zone> '/usr/sbin/ipmpstat -g'     (zones/<zone>/netinfo/ipmpstat_g.out) 
/usr/sbin/zlogin <zone> '/usr/sbin/ipmpstat -i'     (zones/<zone>/netinfo/ipmpstat_i.out) 
/usr/sbin/zlogin <zone> '/usr/sbin/ipmpstat -pn & sleep 5 && kill $!'    (zones/<zone>/netinfo/ipmpstat_pn.out) 
/usr/sbin/zlogin <zone> '/usr/sbin/ipmpstat -tn'     (zones/<zone>/netinfo/ipmpstat_tn.out) 
/usr/sbin/zlogin <zone> '/usr/sbin/sharectl get smb' 
/usr/sbin/zlogin <zone> '/usr/sbin/smbadm show-domains' 
/usr/sbin/zlogin <zone> '/usr/sbin/smbadm show-groups -mp' 
/usr/sbin/zlogin <zone> '/usr/sbin/svccfg -s idmap listprop' 
/usr/sbin/zlogin <zone> '/usr/sbin/svccfg -s smb listprop' 
/usr/sbin/zlogin <zone> '/usr/sbin/svccfg -s smb/client listprop' 
/usr/sbin/zlogin <zone> '/usr/sbin/svccfg -s smb/server listprop'
echo "*ibtf_debug_buf/s" | mdb -k
echo "*rdsv3_debug_buf/s" | mdb -k
echo "*sol_ofs_debug_buf/s" | mdb -k
zlogin ${ZONENAME} '/usr/sbin/sharectl get autofs'
zlogin ${ZONENAME} '/usr/sbin/sharectl get nfs'
zlogin ${ZONENAME} '/usr/bin/kstat -p'
zlogin ${ZONENAME} '/usr/bin/netstat -an'
zlogin ${ZONENAME} '/usr/bin/netstat -in'
zlogin ${ZONENAME} '/usr/bin/netstat -m'
zlogin ${ZONENAME} '/usr/bin/netstat -pn'
zlogin ${ZONENAME} '/usr/bin/netstat -rn'
zlogin ${ZONENAME} '/usr/bin/netstat -rvan'
zlogin ${ZONENAME} '/usr/bin/netstat -s'
zlogin ${ZONENAME} '/usr/bin/nfsstat'
zlogin ${ZONENAME} '/usr/bin/niscat -o $domain'
zlogin ${ZONENAME} '/usr/bin/nisdefaults'
zlogin ${ZONENAME} '/usr/bin/nisls -lR'
zlogin ${ZONENAME} '/usr/bin/rpcinfo -m'
zlogin ${ZONENAME} '/usr/bin/rpcinfo'
zlogin ${ZONENAME} '/usr/lib/nis/nisping -u org_dir'
zlogin ${ZONENAME} '/usr/lib/nis/nisshowcache -v'
zlogin ${ZONENAME} '/usr/lib/nis/nisstat'
zlogin ${ZONENAME} '/usr/sbin/arp -a'
zlogin ${ZONENAME} '/usr/sbin/routeadm -p'

Files Collected

The following files are collected:

/etc/net/ticlts/hosts
/etc/net/ticots/hosts
/etc/net/ticotsord/hosts
/etc/named.conf
${ZONEPATH}/root/etc/named.conf
/var/run/nfs4_domain

netract

Collects the information about alarm card for Netract systems.

Commands Collected

The following commands are collected:

showrecovery
showmohsecurity
showipmode -b 1
showipmode -b 2
showipaddr -b 1
showipaddr -b 2
showipnetmask -b 1
showipnetmask -b 2
showipgateway -b 1
showipgateway -b 2
showservicemode
showhostname
showntpserver
showcpustate
showhealth
showenvironment
shownetwork
showdate
consolehistory
loghistory
debuglog
usershow
mohusershow
showpanicdump
showfru midplane 1 Sun_Part_No
showfru midplane 1 Sun_Serial_No
showfru slot 4 Boot_Devices
showfru slot 5 Boot_Devices
showescapechar
showsecondaryboot
version
ifconfig
aps
arp -a
netstat -a
sysctl -A
/usr/sbin/dhtadm -P
/usr/sbin/pntadm -P '/usr/sbin/pntadm -L'
/usr/platform/SUNW,NetraCT-810/
sbin/netraos list
/usr/platform/SUNW,NetraCT-810/
sbin/netradc list

Files Collected

The following files are collected:

/var/adm/loghistory*
/var/adm/consolehistory*

nhas

Collects Netra High Availability Suite information.

Commands Collected

The following commands are collected:

/opt/SUNWcgha/sbin/nhadm check installation
/opt/SUNWcgha/sbin/nhadm check configuration
/opt/SUNWcgha/sbin/nhadm check starting
/usr/sbin patchadd -R /SUNWcgha/swdb -p
/usr/sbin/patchadd -R /SUNWcgha/local/export/services
/opt/SUNWcgha/sbin/nhcrfsadm -c
/opt/SUNWcgha/sbin/nhcmmadm -c -all
/bin/ls -l /tftpboot

Files Collected

The following files are collected:

/etc/opt/SUNWcgha/nhfs.conf
/etc/opt/SUNWcgha/target.conf
/etc/opt/SUNWcgha/cluster_nodes_table
/etc/inet/dhcpsvc.conf
/SUNWcgha/local/export/data/var/dhcp/SUNWnhrbs1_dhcptab
/SUNWcgha/local/export/data/var/dhcp/SUNWrbs1_*
/etc/opt/SUNWcgha/not_configured

patch

Collects patch information.

Commands Collected

The following commands are collected:

/usr/bin/showrev
/usr/bin/showrev -p
/usr/bin/egrep -e '^Patch' ${EXP_TARGET}/patch+pkg/showrev-p.out | nawk '{print \$2}' | sort
/usr/sbin/patchadd -p
/usr/bin/egrep -e '^Patch' ${EXP_TARGET}/patch+pkg/patchadd-p.out | nawk '{print \$2}' | sort
/usr/bin/ls -l /var/sadm/patch
/usr/bin/ls -almtr /var/sadm/patch
zlogin ${ZONENAME} '/usr/bin/showrev'
zlogin ${ZONENAME} '/usr/bin/showrev -p'
zlogin ${ZONENAME} '/usr/bin/egrep -e '^Patch' ${EXP_TARGET}/patch+pkg/showrev-p.out | nawk
'{print \$2}' | sort'
zlogin ${ZONENAME} '/usr/sbin/patchadd -p'
zlogin ${ZONENAME} '/usr/bin/egrep -e '^Patch' ${EXP_TARGET}/patch+pkg/patchadd-p.out | nawk
'{print \$2}' | sort'
zlogin ${ZONENAME} '/usr/bin/ls -l /var/sadm/patch'
zlogin ${ZONENAME} '/usr/bin/ls -almtr /var/sadm/patch'

pci

Collects PCI information on x86 systems running the Solaris OS.

Commands Collected

The following commands are collected:

/usr/bin/scanpci -v (sysconfig/scanpci-v.out) 
/usr/X11/bin/scanpci -v (sysconfig/scanpci-v.out) 
/usr/X11/bin/scanpci -vO

photon

Collects Sun StorEdge A5X00 information. The photon script collects data for each Sun StorEdge A5X00 found.

Commands Collected

The following commands are collected:

/usr/sbin/luxadm probe
/usr/sbin/luxadm probe -p
/usr/bin/ls -l /dev/es
/usr/sbin/luxadm display $BOXNAME
/usr/sbin/luxadm -v display $BOXNAME
/usr/sbin/luxadm display -r $BOXNAME
/usr/sbin/luxadm -e dump_map $BOXNAME
/usr/sbin/luxadm -e port $BOXNAME

pkg

Collects package information.

Commands Collected

The following commands are collected:

/usr/bin/ls -almtr /var/sadm/pkg
/usr/bin/pkg info -l
/usr/bin/pkg info -l
/usr/bin/pkg list
/usr/bin/pkg publisher
/usr/bin/pkginfo -l
/usr/bin/pkginfo -p
/usr/bin/pkginfo -i
/usr/bin/pkgparam -v <package> | sed -ne '/^SUNW_PKG/ s/^/<package>:/p'
/usr/sbin/pkg list (zones/<zone>/patch+pkg/pkg_listing_ips!) 
zlogin ${ZONENAME} '/usr/bin/pkginfo -l'
zlogin ${ZONENAME} '/usr/bin/pkginfo -p'
zlogin ${ZONENAME} '/usr/bin/pkginfo -i'
zlogin ${ZONENAME} '/usr/bin/ls -almtr /var/sadm/pkg'
zlogin <zone> '/usr/bin/pkg info -l'
zlogin <zone> '/usr/bin/pkg list'

proc

Collects information from /proc.

Commands Collected

The following commands are collected:

/usr/bin/pstack $PID
/usr/bin/pfiles $PID
zlogin ${ZONENAME} '/usr/bin/pstack $PID'
zlogin ${ZONENAME} '/usr/bin/pfiles $PID'

quorumserv

Collects Sun Cluster Quorum Server setup and configuration information.

Commands Collected

The following commands are collected:

package data is collected via pkginfo-1.out that is already in place

message data is collected via /var/adm/messages that is already in place

/usr/cluster/bin/clqs show <instance_name>

process data is collected via ps-ef.out that is already in place

Files Collected

The following files are collected:

/var/scqsd/scqsd_dbg_buf
/etc/scqsd/scqsd.conf
/var/scqsd/<cluster_name>.0x<cluster_id>

raidmanager

Collects Explorer information for Prometheus and Cougar.

Commands Collected

The following commands are collected:

/opt/MegaRAID/MegaCli/MegaCli64 -AdpAllInfo -aALL (RAIDmanager/MegaCli/)
/opt/MegaRAID/MegaCli/MegaCli64 -AdpBbuCmd -aALL (RAIDmanager/MegaCli/)
/opt/MegaRAID/MegaCli/MegaCli64 -AdpEventLog -GetEvents -aALL (RAIDmanager/MegaCli/)
/opt/MegaRAID/MegaCli/MegaCli64 -CfgDsply -aALL (RAIDmanager/MegaCli/)
/opt/MegaRAID/MegaCli/MegaCli64 -FwTermLog -dsply -aALL (RAIDmanager/MegaCli/)
/opt/MegaRAID/MegaCli/MegaCli64 -LDInfo -LALL -aALL (RAIDmanager/MegaCli/)
/opt/MegaRAID/MegaCli/MegaCli64 -LDPDInfo -aALL (RAIDmanager/MegaCli/)
/opt/MegaRAID/MegaCli/MegaCli64 -PDList -aALL (RAIDmanager/MegaCli/)
/opt/MegaRAID/MegaCli/MegaCli64 -PDList -aALL | nawk ${AWK_CMD} (RAIDmanager/MegaCli/PDList-aALL_short)
/usr/StorMan/arcconf GETCONFIG
/usr/StorMan/arcconf GETSTATUS
/usr/StorMan/arcconf GETLOGS $CNUM uart
/usr/StorMan/arcconf GETLOGS $CNUM device
/usr/StorMan/arcconf GETLOGS $CNUM dead
/usr/StorMan/arcconf GETLOGS $CNUM event
/usr/StorMan/arcconf GETLOGS $CNUM ppi

Files Collected

The following files are collected:

${STORMAN}/arcconfig.xml
${STORMAN}/Support.zip
${STORMAN}/SystemID
${STORMAN}/arcerror.txt
${STORMAN}/UcliEvt.log
${STORMAN}/RaidDP.log
${STORMAN}/RaidErr.log
${STORMAN}/RaidErrA.log
${STORMAN}/RaidEvt.log
${STORMAN}/RaidEvtA.log

rda

Some information in Explorer is not collected by an Explorer script but rather by the Remote Diagnostic Agent (RDA). This "rda" module is used to call RDA from Explorer.

samfs

Collects information from an installed Sun StorEdge SAM-FS environment.

Commands Collected

The following commands are collected:

/usr/bin/echo \"ETCDIR = ${ETCDIR}\"
/usr/bin/echo \"VARDIR = ${VARDIR}\"
/usr/bin/echo \"USERDIR = ${USERDIR}\"
/usr/bin/echo \"EXECDIR = ${EXECDIR}\"
/usr/bin/echo \"SHFSDIR = ${SHFSDIR}\"
/usr/bin/echo \"CATDIR = ${CATDIR}\"
/usr/bin/echo \"FSDDIR = ${FSDDIR}\"
/usr/bin/echo \"FTPDIR = ${FTPDIR}\"
/usr/bin/echo \"TRCDIR = ${TRCDIR}\"
/usr/bin/echo \"TRCTRMP= ${TRCTMP}\"
/usr/bin/echo \"ARCHDATA= ${ARCHDATA}\"
/usr/bin/echo \"STAGER_DATA= ${STAGER_DATA}\"
/usr/bin/echo \"DEVLOGS= ${DEVLOGS}\"
/usr/bin/tail -1000 ${SAMLOG}
$EXECDIR/samcmd d
/usr/bin/echo \"SAMLOG = ${SAMLOG}\"
/usr/bin/echo \"ARCHLOGS = ${ARCHLOGS}\"
/usr/bin/echo \"RECLLOGS = ${RECLLOGS}\"
/usr/bin/echo \"DEVLOGS = ${DEVLOGS}\"
/usr/bin/echo \"RELLOG = ${RELLOG}\"
/usr/bin/echo \"STAGELOG = ${STAGELOG}\"
/usr/bin/echo \"STAGER_LOG = ${STAGER_LOG}\"
/usr/bin/echo \"ARCHTRC = ${ARCHTRC}\"
/usr/bin/echo \"CATTRC = ${CATTRC}\"
/usr/bin/echo \"FSDTRC = ${FSDTRC}\"
/usr/bin/echo \"FTPTRC = ${FTPTRC}\"
/usr/bin/echo \"RCYTRC = ${RCYTRC}\"
/usr/bin/echo \"SHFSTRC = ${SHFSTRC}\"
/usr/bin/echo \"STGTRC = ${STGTRC}\"
/usr/bin/tail -1000 ${FILE}
/usr/bin/tail -1000 /tmp/.grau
/bin/ls /var/adm/log/fs_fifo_log
/bin/ls /var/adm/log/fs_ioctl_log
/bin/ls -l /etc/release
/bin/grep sam_statvfs_bias /etc/system
/bin/ls -l /dev/rdst*
/bin/ls -Ll /dev/rdst*
/bin/ls -l /dev/dsk/*s2
/bin/ls -Ll /dev/dsk/*s2
/bin/ls -l /dev/rdsk/*s2
/bin/ls -Ll /dev/rdsk/*s2
/bin/ls -l /etc/driver_classes
/bin/ls -l /etc/driver_aliases
/bin/ls -lR /opt/SUNWsamfs
/bin/grep sam /etc/name_to_sysnum
/usr/sbin/modinfo | /bin/grep sam | /bin/grep -v sampling
/usr/sbin/modinfo | /bin/grep ' sd '
/usr/sbin/modinfo | /bin/grep ' st '
/usr/sbin/modinfo | /bin/grep fp
/usr/sbin/modinfo | /bin/grep qlc
/usr/sbin/modinfo | /bin/grep ssd
${EXECDIR}/samset
${EXECDIR}/samset debug
${EXECDIR}/samset devlog all
/bin/ls -l /dev/samst
/bin/ls -Ll /dev/samst
/bin/ls -l /dev/samrd
/bin/ls -l /opt/SANergy/lib
/bin/ls -l /opt/SANergy/lib/sparcv9
/bin/ls -Ll /opt/SANergy/lib
/bin/ls -Ll /opt/SANergy/lib/sparcv9
${EXECDIR}/samfsinfo $fs
${EXECDIR}/samsharefs $fs
${EXECDIR}/samsharefs -R $fs
${EXECDIR}/samcmd a $fs
${EXECDIR}/samcmd N $SAMFS
${EXECDIR}/samcmd f
${EXECDIR}/samcmd m
${EXECDIR}/samcmd p
${EXECDIR}/samcmd w
${EXECDIR}/samcmd u
${EXECDIR}/samcmd r
${EXECDIR}/samcmd n
${EXECDIR}/samcmd d
${EXECDIR}/samcmd s
${EXECDIR}/samcmd c
/bin/grep wait ${ETCDIR}/archiver.cmd
${EXECDIR}/archiver -lv
${EXECDIR}/dmpshm
${EXECDIR}/samtrace -v
/usr/lib/fs/samfs/sam-fsd
/usr/proc/bin/ptree ${SAM_FSD}
/usr/proc/bin/pstack ${PID}
/usr/proc/bin/pflags ${PID}
/bin/ls -tlLd ${FILE}
/bin/file ${FILE}
/bin/file ${FILE}
/bin/file ${FILE}
/opt/SUNWsamfs/jre/bin/jre -v
/opt/SUNWsamfs/sbin/dump_cat -V ${catpath}
/opt/SUNWsamfs/sbin/dump_cat -V ${catpath}
/opt/SUNWsamfs/sbin/dump_cat -V ${catpath}
/opt/SUNWsamfs/sbin/dump_cat -V ${catpath}
/opt/SUNWsamfs/sbin/samexplorer

Files Collected

The following files are collected:

/etc/driver_classes
/etc/driver_aliases
/opt/SUNWsamfs/include/version.h

Directories Collected

The following directories are collected recursively:

${ETCDIR}
${VARDIR}

sanextended

Collects extended storage area network (SAN) switch information.

Commands Collected

The following commands are collected:

${CLIENT} ${SAN_NAME}
/bin/ls -l ${EXP_SANINPUT_CONFIG}

In addition, the following commands are collected from the remote host:

switchtype
supportshow
loomphantomshow
bloomphantomshow
show support
show support
show eventlog
show features
show frus
show ip ethernet
show nameServer
show port config
show port info
show port status
show port technology
show switch
show system
show loginserver
show zoning
show security portbinding
show tech details

Files Collected

The following file is collected:

${EXP_SANINPUT_CONFIG}

sap

Collects configuration information from an SAP installation.

Commands Collected

The following commands are collected:

/bin/su - ${SIDADM} -c \"saplicense -number NAME=${SAP_SYSTEM}\"
/bin/su - ${SIDADM} -c \"/usr/sap/${SAP_SYSTEM}/SYS/exe/run/disp+work -v\"
/bin/su - ${SIDADM} -c \"file /usr/sap/${SAP_SYSTEM}/SYS/exe/run/disp+work\"
/bin/su - ${SIDADM} -c \"sh -c /usr/sap/${SAP_SYSTEM}/SYS/exe/run/ipclimits 2>&1\"
/bin/su - ${SIDADM} -c \"/usr/sap/${SAP_SYSTEM}/SYS/exe/run/saposcol -v\"
/bin/ls -al
/bin/su - ${SIDADM} -c \"/usr/sap/${SAP_SYSTEM}/SYS/exe/run/sapparar name=${SAP_SYSTEM}
pf=${BASEDIR}/SYS/profile/${SAP_SYSTEM}_${INSTANCE}_${HOSTNAME} all\"
/bin/ls -al ${BASEDIR}/${INSTANCE}/work

Files Collected

The following files are collected:

/usr/sap/trans/bin/${FILE}
${BASEDIR}/SYS/profile/${FILE}
${BASEDIR}/SYS/profile/${FILE}
${ORA_HOME}/dbs/${FILE}

sbu

Collects Solstice Backup information.

Commands Collected

The following commands are collected:

/usr/sbin/nsr/mminfo -av
/usr/sbin/nsr/mminfo -aV
/usr/sbin/nsr/nsrls
/bin/ls -alF /nsr/index
/bin/ls -alLF /nsr/index
/bin/ls -alF /usr/sbin/nsr
/bin/ls -alF /usr/bin/nsr
/bin/ls -alF /dev/rmt
/bin/ls -alLF /dev/rmt

Files Collected

The following files are collected:

/nsr/logs/messages
/nsr/logs/daemon.log
/nsr/logs/summary

Directories Collected

The following directory is collected recursively:

/nsr/res

scextended

Collects extended Serengeti System Controller information.

Commands Collected

The following commands are collected:

${EXP_HOME}/bin/rprtfru.'uname -p' -b ${SC_NAME}:XXXXXX -x
/bin/ls -l ${EXP_SCINPUT_CONFIG}

In addition, the following commands are collected from the remote host:

showsc -v
showfru -r manr
showerrorbuffer -p
showplatform -v
showplatform -p frame
showplatform -d a
showplatform -d b
showplatform -d c
showplatform -d d
showdate -v
showdate -v -d a
showdate -v -d b
showdate -v -d c
showdate -v -d d
showlogs -v
showlogs -v -d a
showlogs -v -d b
showlogs -v -d c
showlogs -v -d d
showcodlicense -v
showcodusage -v
showcodlog -v
showerrorbuffer
showboards -e
showboards -p proms
showboards -v -p cpu
showboards -v -p memory
showboards -v
showboards -v -d a
showboards -v -d b
showboards -v -d c
showboards -v -d d
showboards -v -p board
showboards -v -p clock
showboards -v -p io
showboards -v -p power
showboards -v -p version
showcomponent -d a
showcomponent -d b
showcomponent -d c
showcomponent -d d
showenvironment -tv
showcomponent ${BOARD}
showchs -b

se3k

Collects StorEdge 3xxx product-line information in in-band mode.

Commands Collected

The following commands are collected:

format
format -e -d
sccli
ssdgrptd

Files Collected

The following file is collected:

/etc/rs_binding

Directories Collected

The following directories are collected recursively:

/etc/.ssagent__/*
/var/opt/SUNWsscs/*

se3kextended

Collects StorEdge 3xxx product-line information in out-of-band (OOB) mode.

Commands Collected

The following command is collected:

sccli

se61xx

Collects Sun StorEdge 6130 and 6140 information.

Commands Collected

The following commands are collected:

/opt/SUNWstade/bin/ras_admin
/opt/SUNWstade/bin/61*SupportData

Files Collected

The following files are collected:

/tmp/${SE61xx_NAME}_xtract.zip
${EXP_TMPDIR}/se61xx.log

se6320

Collects Sun StorEdge 6320 information.

Commands Collected

The following commands are collected:

/bin/ls -l ${EXP_SE6320INPUT_CONFIG}
/usr/sfw/bin/curl -t1 -O/tmp/response --http-user=%s --http-passwd=%s --proxy=off
\"http://%s:%s/?GET=RUNSS&comm=ras_admin+host_detail\
/usr/sfw/bin/curl -T300 --quiet -t1 -O/tmp/${SE6320_NAME}.tar --http-user=%s
--http-passwd=%s --proxy=off \"http://%s:%s/?GET=RUNSS&comm=se_extract+-r+-x\"
/usr/bin/rm /tmp/response

Files Collected

The following files are collected:

/tmp/response
/tmp/${SE6320_NAME}.tar

se6920

Collects Sun StorEdge 6920 information.

Commands Collected

The following commands are collected:

${EXP_HOME}/bin/curl 'uname -p' --quiet -t1 -O/tmp/${SE6920_NAME}.tar --http-user=%s
--http-passwd=%s --proxy=off \"https://%s:%s/?GET=RUNSS&comm=se_extract+-r+-x\"
/bin/ls -l ${EXP_SE6920INPUT_CONFIG}
rm /tmp/${SE6920_NAME}.tar

Files Collected

The following file is collected:

/tmp/${SE6920_NAME}.ta

sf15k_ndd

Collects network device driver information for Sun Fire 15K servers. The script collects driver information for the scman and dman services. The script collects data for all parameters of those drivers.

Commands Collected

The following commands are collected:

/usr/sbin/ndd /dev/$mod \?
/usr/sbin/ndd /dev/$mod $parm

sf15k_sc

Collects Sun Fire 15K System Controller information. Collects data for each domain and revisions for each lpost elf file found.

Commands Collected

The following commands are collected:

/opt/SUNWSMS/bin/smsversion -t
/bin/ls -laR /etc/opt/SUNWSMS/SMS/config
/opt/SUNWSMS/bin/showfailover
/opt/SUNWSMS/bin/showfailover -r
/opt/SUNWSMS/bin/showfailover -v
/opt/SUNWSMS/bin/showplatform
/opt/SUNWSMS/bin/showplatform -v
/opt/SUNWSMS/bin/showenvironment
/opt/SUNWSMS/bin/showdate -v
/opt/SUNWSMS/bin/marginclock
/opt/SUNWSMS/bin/marginvoltage
/opt/SUNWSMS/bin/showboards -v
/opt/SUNWSMS/bin/showbus
/opt/SUNWSMS/bin/showbus -v
/opt/SUNWSMS/bin/showcmdsync
/opt/SUNWSMS/bin/showcmdsync -v
/opt/SUNWSMS/bin/showdatasync -l
/opt/SUNWSMS/bin/showdatasync -v
/opt/SUNWSMS/bin/showcodusage -v
/opt/SUNWSMS/bin/showcodlicense -v
/usr/ccs/bin/mcs -p ${OBJ} | grep ${MOD}
/bin/getfacl /etc/opt/SUNWSMS/SMS/config/
/bin/getfacl /etc/opt/SUNWSMS/SMS/config/platform
/bin/getfacl /var/opt/SUNWSMS/adm/
/bin/getfacl /var/opt/SUNWSMS/adm/platform
/bin/getfacl /var/opt/SUNWSMS/adm/anonymous
/bin/getfacl /var/opt/SUNWSMS/data/
/opt/SUNWSMS/bin/sysid -d ${DOMAIN}
/opt/SUNWSMS/bin/showdate -v -d ${DOMAIN}
/opt/SUNWSMS/bin/showdevices -v -d ${DOMAIN}
/opt/SUNWSMS/bin/showobpparams -d ${DOMAIN}
/opt/SUNWSMS/bin/showkeyswitch -d ${DOMAIN}
/opt/SUNWSMS/bin/sysid -d /var/opt/SUNWSMS/data/${DOMAIN}/idprom.image
/bin/getfacl /etc/opt/SUNWSMS/SMS/config/${DOMAIN}
/bin/getfacl /var/opt/SUNWSMS/adm/${DOMAIN}
/bin/getfacl /var/opt/SUNWSMS/data/${DOMAIN}
/opt/SUNWSMS/bin/flashupdate -f ${OBPIMG} -n SC${sc}/FP0
/opt/SUNWSMS/bin/flashupdate -f ${POSTIMG} -n SC${sc}/FP1
/opt/SUNWSMS/bin/flashupdate -f ${SBIMG} -n ${sb}
/opt/SUNWSMS/bin/showlogs -E -p e

In addition, the following command is collected for each discovered field replaceable unit (FRU):

/opt/SUNWSMS/bin/showchs -v -c ${fru}

Files Collected

The following files are collected:

/var/opt/SUNWSMS/adm/.logger
/var/sadm/system/logs/smsbackup
/etc/opt/SUNWSMS/config/.fomd_uids.cf
/etc/opt/SUNWSMS/config/platform/.postrc
/etc/opt/SUNWSMS/config/${DOMAIN}/.postrc
/var/opt/SUNWSMS/adm/mess*
/var/opt/SUNWSMS/adm/platform/mess*
/var/opt/SUNWSMS/adm/platform/trace/tracejournal
/var/opt/SUNWSMS/adm/platform/trace/tracejournal.0
/var/opt/SUNWSMS/adm/platform/trace/tracejournal.1
/var/opt/SUNWSMS/adm/platform/trace/tracejournal.2

Directories Collected

The following directories are collected:

/var/opt/SUNWSMS/.pcd
/var/opt/SUNWSMS/adm/platform/dump
/var/opt/SUNWSMS/data/LockDump
/var/opt/SUNWSMS/data/${DOMAIN}
/var/opt/SUNWSMS/.lock/${DOMAIN}

In addition, the following directories are collected recursively:

/var/opt/SUNWSMS/adm/anonymous
/etc/opt/SUNWSMS/SMS
/var/opt/SUNWSMS/adm/${DOMAIN}

smfextended

Collects Solaris 10 Service Management Facility (SMF) files. This script runs only on user request.

Files Collected

The following files are collected:

/etc/svc/volatile/*.log
${ZONEPATH}/root/etc/svc/volatile/*.log

Directories Collected

The following directories are collected recursively:

/var/svc
${ZONEPATH}/root/var/svc

sonoma

Collects Sun StorEdge A3X00 information. Collects additional data for each logical unit number (LUN).

Commands Collected

The following commands are collected:

/usr/bin/ls -l /dev/osa/dev/dsk/*
/usr/bin/ls -l /dev/osa/dev/rdsk/*
${OSABIN}/healthck -a
${OSABIN}/lad
${OSABIN}/drivutil -d "\"${i}\""
${OSABIN}/drivutil -i "\"${i}\""
${OSABIN}/drivutil -I "\"${i}\""
${OSABIN}/drivutil -l "\"${i}\""
${OSABIN}/rdacutil -i "\"${i}\""
${OSABIN}/raidutil -c "\"${i}\"" -i
${OSABIN}/raidutil -c "\"${i}\"" -V 0
${OSABIN}/raidutil -c "\"${i}\"" -B
${OSABIN}/nvutil -v "\"${i}\""
${OSABIN}/storutil -c "\"${i}\"" -d
/usr/lib/osa/bin/perfutil -c "\"${i}\"

Files Collected

The following files are collected:

/usr/lib/osa/rmparams
/usr/lib/osa/rmlog.*
/usr/lib/osa/rdac_address
/etc/osa/mnf

srscextended

Collects information from Sun Remote System Controller.

Commands Collected

The following command is collected:

ls -l ${EXP_SRSCINPUT_CONFIG}

In addition, the following commands are collected from the remote host:

showenvironment -v
show
showdate
loghistory
usershow
consolehistory
version -v

ssa

Collects SPARCstorage Array information. Data is collected for each SPARCstorage Array found.

Commands Collected

The following commands are collected:

$SSAADM -v display ${SSA}
$SSAADM display $diskpath

ssp

Collects E10K System Service Processor (SSP) information. Data is collected for all system and I/O boards. Also collects control board data.

Commands Collected

The following commands are collected:

${SSPBIN}/domain_status
${SSPBIN}/showfailover
/usr/bin/ls -lia /tftpboot
${SSPBIN}/fan
${SSPBIN}/power
${SSPBIN}/sys_clock
${SSPBIN}/hostinfo -F
${SSPBIN}/hostinfo -S
${SSPBIN}/hostinfo -h
${SSPBIN}/hostinfo -p
${SSPBIN}/hostinfo -t
${SSPBIN}/board_id -b io -n $i
${SSPBIN}/board_id -b mem -n $i
${SSPBIN}/board_id -b sb -n $i
${SSPBIN}/board_id -b cb -n $i
${SSPBIN}/board_id -b csb -n $i
${SSPBIN}/board_id -b cp -n $i
${SSPBIN}/cb_prom -r -h $i
${SSPBIN}/sys_id -d
${SSPBIN}/check_host

In addition, the following command is collected for SSP 3.5 and later:

${SSPBIN}/domain_status -m

Files Collected

The following files are collected:

~ssp/.postrc
${SSPVAR}/*.out*
$SSP_PRIVATE/cb_config
$SSP_PRIVATE/domain_config
$SSP_PRIVATE/ssp_resource
$SSP_PRIVATE/ssp_to_domain_hosts
$SSP_PRIVATE/main_ssp_name
/var/tmp/autoconfig.log

Directories Collected

The following directories are collected:

$SSPVAR/etc/$PLATFORM
${SSPVAR}/etc/${PLATFORM}/${SUNW_HOSTNAME}

In addition, the following directories are collected recursively:

${SSPVAR}/adm
${SSPVAR}/etc
${SSPVAR}/data

st25xx

Collects Sun StorEdge ST2510, ST2530 and ST2540 information.

Commands Collected

The following commands are collected:

/opt/SUNWsefms/bin/ras_admin
/opt/SUNWsefms/bin/supportData

st5800

Collects information from ST5800 (which consists of multiple nodes running Solaris OS, couple of switches running Linux OS and Service processor running Solaris OS). This script runs by default on the ST5800 system.

Note:

Specify alternate directory for gathering Explorer output if the default output directory does not have enough space to store ST5800 output.

Commands Collected

The following command is collected:

/opt/honeycomb/extractor/extractor.pl

storade

Collects StorADE information.

Commands Collected

The following commands are collected:

${STOR_PATH}/bin/ras_admin site_info
${STOR_PATH}/bin/ras_admin host_list
${STOR_PATH}/bin/ras_admin host_detail
${STOR_PATH}/bin/ras_admin device_list
${STOR_PATH}/bin/ras_admin device_detail
${STOR_PATH}/bin/ras_admin review_config
${STOR_PATH}/bin/ras_admin login_list
${STOR_PATH}/bin/ras_admin report_list
${STOR_PATH}/bin/ras_admin alert_list
${STOR_PATH}/bin/ras_admin event_list
${STOR_PATH}/bin/ras_admin topo_list
${STOR_PATH}/bin/ras_revcheck -M ALL
${STOR_PATH}/bin/ras_admin report -k ${REP_KEY} -h ${HOST}

Directories Collected

The following directories are collected recursively:

/opt/SUNWstade/DATA
/opt/SUNWrasag/DATA

storedge

Collects Sun StorEdge information.

Commands Collected

The following commands are collected:

${ASDIR/sbin}/iiadm -i all
/usr/opt/SUNWesm/sbin/nvmadm -v
${ASDIR}/sbin/dsstat
/usr/opt/SUNWesm/SUNWnvm/sbin/fwcadm nvram -s
${ASDIR}/sbin/sbin/svadm
${ASDIR}/sbin/scmadm
/usr/opt/SUNWesm/SUNWrdc/sbin/rdcadm -p
/usr/opt/SUNWesm/SUNWte/sbin/steconf
/usr/opt/SUNWesm/SUNWte/sbin/steadm -c
/usr/opt/SUNWesm/SUNWnvm/sbin/fwcadm nvram -s
${ASDIR}/sbin/sndradm -i
${ASDIR}/sbin/sndradm -p
${ASDIR}/sbin/sndradm -P
/usr/opt/SUNWesm/SUNWrdc/sbin/sndrstat
/usr/opt/SUNWesm/SUNWnvm/sbin/nvmadm -v
${ASDIR}/sbin/dscfgadm -i
${ASDIR}/sbin/dscfg -l
${ASDIR}/sbin/dscfg
/${ASDIR}/sbin/iiadm -g -L | /usr/bin/xargs -i -t /usr/opt/SUNWesm/sbin/iiadm -g {} -l
${SECFG}/bin/getcabinet
${SECFG}/bin/checkdefaultconfig -v
${SECFG}/bin/showt3 -n ALL
${SECFG}/bin/showswitch -s sw1a
${SECFG}/bin/showswitch -s sw1b
${SECFG}/bin/showswitch -s sw2a
${SECFG}/bin/showswitch -s sw2b
${SECFG}/bin/listavailable -s -t -v
${SECFG}/bin/showvemap -n v1 -l
${SECFG}/bin/showvemap -n v2 -l
${SECFG}/bin/listt3slice -n ALL -s -v
${SECFG}/bin/listt3slice -n ALL -l -v
${SECFG}/bin/listt3slice -n ALL -p -v
${SECFG}/bin/listt3slice -n ALL -m -v
${SECFG}/flib/capture 192.168.0.30
${SECFG}/flib/capture 192.168.0.31
${SECFG}/flib/capture 192.168.0.32
${SECFG}/flib/capture 192.168.0.33
${SECFG}/bin/listt3map -l -n ${T3B}
${SECFG}/bin/listt3map -u -n ${T3B}
${SECFG}/bin/listt3map -t -n ${T3B} -v ${T3VOL}
${SECFG}/bin/listt3map -b -n ${T3B} -v ${T3VOL}
${SECFG}/bin/listt3map -s -n ${T3B}
${SECFG}/bin/listt3map -f -n ${T3B}
${SECFG}/bin/listt3map -i -n ${T3B}
${SECFG}/bin/listt3map -a -n ${T3B}
${SECFG}/bin/listt3map -c -n ${T3B}
${SECFG}/bin/listt3map -c -n ${T3B}
${SECFG}/bin/listt3map -g -n ${T3B}
${SECFG}/bin/listt3map -w -n ${T3B} -p ${WWNG}
${SECFG}/bin/listt3map -w -n ${T3B}
${SECFG}/bin/checkslicd -n v1
${SECFG}/bin/checkslicd -n v2
/opt/svengine/sduc/mpdrive view -d v1
/opt/svengine/sduc/mpdrive view -d v2
/opt/svengine/sduc/svstat -d v1
/opt/svengine/sduc/svstat -d v2
/opt/svengine/sduc/sreadlog -d v1 -v
/opt/svengine/sduc/sreadlog -d v2 -v

If the SUNWesmportal package is installed, the following additional command is collected for i equals 0 to 9:

/usr/bin/tail -1000 /var/opt/SUNWesmportal/util/pgsql/portaldb.log.${i}

In addition, if the SUNWesmportal package is installed, the following commands are collected:

/usr/bin/tail -1000000c
/opt/SUNWesmportal/util/pgsql/portal/backup/${LATESTLOG}
/usr/bin/tail -1000000c /var/opt/SUNWcacao/logs/cacao.0
/usr/sbin/smcwebserver -V

If the SUNWesmportal package and the SUNWwbsvr package are installed, the following additional commands are collected:

usr/bin/tail -1000000c /opt/SUNWwbsvr/${HTTPHOSTNAME}/logs/errors
/usr/bin/tail -1000000c /opt/SUNWwbsvr/${HTTPHOSTNAME}/logs/access

Files Collected

The following files are collected:

${ASLOG}/ds.log
/etc/opt/SUNWii/iitab
/etc/opt/SUNWrdc/rdc.cf
/etc/opt/SUNWrdc/rdc_ii.cf
/etc/opt/SUNWscm/sd.cf
/etc/opt/SUNWspsv/sv.cf
/var/adm/log/SEcfglog
/var/adm/messages.t3
/opt/svengine/sdus/IPCLOG
/opt/svengine/sdus/svengine.cfg
/opt/svengine/sdus/v1_SLICERR.log
/opt/svengine/sdus/v2_SLICERR.log

If the SUNWesmportal package is installed, the following additional files are collected:

/var/sadm/install/logs/smportal.log
/var/opt/SUNWesmportal/util/pgsql/portaldb.log

If the SUNWesmportal package and the SUNWwbsvr package are installed, the following additional file is collected:

/opt/SUNWwbsvr/${HTTPHOSTNAME}/logs/pid

Directories Collected

The following directories are collected:

/var/opt/SUNWesm
/var/opt/SUNWesm/log
/etc/opt/SUNWte
/var/opt/SUNWte

In addition, the following directory is collected recursively:

${SECFG}/etc/*

If the SUNWesmportal package is installed, the following additional directories are collected:

/var/opt/SUNWam/debug
/var/opt/SUNWam/logs

If the SUNWbaconf package is installed, the following additional directories are collected:

/var/opt/SUNWbaconf/logs
/var/opt/SUNWbaconf/share
/var/opt/SUNWbaconf/share/apps
/var/opt/SUNWbaconf/share/license
/var/opt/SUNWbaconf/share/logs
/var/opt/SUNWbaconf/share/messages
/var/opt/SUNWbaconf/share/state

If the SUNWrrm package is installed, the following additional directories are collected:

/opt/SUNWrrm/etc
/opt/SUNWrrm/etc/bui
/opt/SUNWrrm/etc/server
/var/opt/SUNWrrm/datastore
/var/opt/SUNWrrm/log
/var/opt/SUNWrrm/trace
/etc/opt/SUNWrrm

stortools

Collects StorTools 3.x information.

Files Collected

The following file is collected:

/var/opt/STORtools/logs/Golden_Snapshot*

sunjes

Collects JES product information.

Commands Collected

The following commands are collected:

prodreg browse -u "Java Enterprise System"
prodreg info -u "Java Enterprise System"
${SERVER_ROOT}/https-admserv/start -version
ls -d ${SERVER_ROOT}/https-*
${SERVER_ROOT}/proxy-admserv/start -version
ls -d ${SERVER_ROOT}/proxy-*
/usr/bin/imqadmin -v
${SERVER_ROOT}/appserver/bin/asadmin version
ls -d /var/opt/SUNWappserver/domains/*
/usr/sbin/directoryserver -listversions
ld -s ${SERVER_ROOT}/slapd*
pkgparam SUNWics5 VERSION
${SERVER_ROOT}/bin/version

Files Collected

The following files are collected:

/opt/SUNWics5/cal/config/ics.conf
/etc/opt/SUNWps/MAConfig.properties
/etc/opt/SUNWps/PSConfig.properties
/etc/opt/SUNWps/WEBLOGIC.bootstrapSystem.properties
/etc/opt/SUNWps/client-context.properties
/etc/opt/SUNWps/service-context.properties
/etc/opt/SUNWps/desktop/desktopconfig.properties
/etc/opt/SUNWps/portlet/PDConfig.properties
/etc/opt/SUNWps/portlet/userInfoMapping.properties
/etc/opt/SUNWps/wsrp/wsrpconsumerconfig.properties

Directories Collected

The following directories are collected:

${SERVER_ROOT}/userdb
${SERVER_ROOT}/https-*/logs
${SERVER_ROOT}/https-*/config
${SERVER_ROOT}/proxy-*/logs
${SERVER_ROOT}/proxy-*/config
/var/opt/SUNWappserver/domains/*/logs
/var/opt/SUNWappserver/domains/*/config
${SERVER_ROOT}/slapd*/logs
${SERVER_ROOT}/slapd*/config
/etc/opt/SUNWps/dtd
/var/opt/SUNWps/https-*/portal/config
/var/opt/SUNWps/https-*/portal/logs

sunone

Collects SunONE (iPlanet) configuration data.

Commands Collected

The following commands are collected:

/bin/ls -alr /etc/opt/SUNWips/cert
/bin/ls -l ${SERVER_ROOT}/SUNWips/public_html
/bin/ls -lrt /etc/opt/SUNWips
/usr/bin/egrep -e starting ${SERVER_ROOT}/${INSTANCE}/log/default/default*
/usr/bin/egrep ersion ${SERVER_ROOT}/${INSTANCE}/log/default/default
/usr/bin/sum ${SERVER_ROOT}/ias/classes/java/*
/usr/bin/sum ${SERVER_ROOT}/ias/gxlib/*
/usr/bin/sum ${SERVER_ROOT}/ias/java/jars/ias60.jar
/usr/bin/sum ${SERVER_ROOT}/nas/classes/java/*
/usr/bin/sum ${SERVER_ROOT}/nas/gxlib/*
/usr/bin/sum ${SERVER_ROOT}/nas/java/jars/nas40.jar
/usr/bin/tail -2000 /var/opt/SUNWips/auth/${FILE}
/usr/bin/tail -2000 /var/opt/SUNWips/debug/${FILE}
/usr/bin/tail -2000 /var/opt/SUNWips/logs/${FILE}
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/imta/mail.log_current
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/log/default/default
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/log/http/http
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/log/imap/imap
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/log/imta/mail.log_current
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/log/pop/pop
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/log/smtp/smtp
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/logs/access
/usr/bin/tail -2000 ${SERVER_ROOT}/${INSTANCE}/logs/errors
/usr/bin/tail -2000 ${SERVER_ROOT}/ias/logs/${FILE}
/usr/bin/tail -2000 ${SERVER_ROOT}/ias/logs/ias.log
/usr/bin/tail -2000 ${SERVER_ROOT}/nas/logs/${FILE}
/usr/bin/tail -2000 ${SERVER_ROOT}/nas/logs/kas.log
/usr/sbin/svccfg -s coreadm:default listprop config_params/*
/usr/sbin/svccfg -s dumpadm:default listprop config_params/* 
${J_HOME}/bin/java -fullversion
${JAVA_DIR}/bin/java -fullversion
${SERVER_ROOT}/${INSTANCE}/configutil
${SERVER_ROOT}/${INSTANCE}/configutil
${SERVER_ROOT}/${INSTANCE}/imsimta version
${SERVER_ROOT}/bin/https/bin/ns-httpd -v
${SERVER_ROOT}/bin/slapd/server/ns-slapd -D ${SERVER_ROOT}/${INSTANCE} -V
${SERVER_ROOT}/bin/slapd/server/ns-slapd -V -f ${SERVER_ ROOT}/${INSTANCE}/config/slapd.conf
${SERVER_ROOT}/ias/bin/version
${SERVER_ROOT}/ias/usr/java/bin/java -fullversion
${SERVER_ROOT}/nas/bin/version
${SERVER_ROOT}/nas/usr/java/bin/java -fullversion
${SERVER_ROOT}/netscape/directory4/slapd-'hostname'/db2ldif explorer_ldif
${SERVER_ROOT}/SUNWips/bin/ipsadmin get component iplanet.com
${SERVER_ROOT}/SUNWips/bin/ipsadmin get component iwtGateway
${SERVER_ROOT}/SUNWips/bin/ipsserver version

Files Collected

The following files are collected:

${SERVER_ROOT}/ias/bin/beanreg
${SERVER_ROOT}/ias/bin/kjs
${SERVER_ROOT}/ias/bin/kxs
${SERVER_ROOT}/ias/bin/kas
${SERVER_ROOT}/ias/bin/kcs
${SERVER_ROOT}/ias/env/iasenv.ksh
${SERVER_ROOT}/ias/bin/iascontrol
${SERVER_ROOT}/ias/bin/KIVAes.sh
${SERVER_ROOT}/ias/registry/reg.dat
${SERVER_ROOT}/ias/bin/kregedit
${SERVER_ROOT}/ias/bin/kreg
${SERVER_ROOT}/ias/bin/j2eeappreg
${SERVER_ROOT}/ias/bin/iasdeploy
${SERVER_ROOT}/ias/bin/resreg
${SERVER_ROOT}/ias/bin/beanreg
${SERVER_ROOT}/ias/bin/dsreg
${SERVER_ROOT}/ias/bin/servletReg.sh
${SERVER_ROOT}/ias/bin/ejbreg
${SERVER_ROOT}/ias/bin/redeploy
${SERVER_ROOT}/ias/bin/webappreg
${SERVER_ROOT}/ias/bin/convertNtv2Xml
${SERVER_ROOT}/ias/bin/convertProps2Xml
${SERVER_ROOT}/ias/bin/ejbc
${SERVER_ROOT}/ias/bin/deploycmd
${SERVER_ROOT}/ias/bin/ksvradmin
${SERVER_ROOT}/ias/bin/deploytool
${SERVER_ROOT}/ias/bin/redeploy
${SERVER_ROOT}/nas/bin/kjs
${SERVER_ROOT}/nas/bin/kxs
${SERVER_ROOT}/nas/bin/kas
${SERVER_ROOT}/nas/bin/kcs
${SERVER_ROOT}/nas/env/iasenv.ksh
${SERVER_ROOT}/nas/bin/iascontrol
${SERVER_ROOT}/nas/bin/KIVAes.sh
${SERVER_ROOT}/nas/registry/reg.dat
${SERVER_ROOT}/nas/bin/kregedit
${SERVER_ROOT}/nas/bin/kreg
${SERVER_ROOT}/nas/bin/j2eeappreg
${SERVER_ROOT}/nas/bin/iasdeploy
${SERVER_ROOT}/nas/bin/beanreg
${SERVER_ROOT}/nas/bin/resreg
${SERVER_ROOT}/nas/bin/dsreg
${SERVER_ROOT}/nas/bin/servletReg.sh
${SERVER_ROOT}/nas/bin/ejbreg
${SERVER_ROOT}/nas/bin/redeploy
${SERVER_ROOT}/nas/bin/webappreg
${SERVER_ROOT}/nas/bin/convertNtv2Xml
${SERVER_ROOT}/nas/bin/convertProps2Xml
${SERVER_ROOT}/nas/bin/ejbc
${SERVER_ROOT}/nas/bin/deploycmd
${SERVER_ROOT}/nas/bin/ksvradmin
${SERVER_ROOT}/nas/bin/deploytool
${SERVER_ROOT}/nas/bin/redeploy
${SERVER_ROOT}/nas/bin/deployGUI
${SERVER_ROOT}/nas/userinput.log
${SERVER_ROOT}/nas/java/jars/nas40.jar
${SERVER_ROOT}/ias/userinput.log
${SERVER_ROOT}/ias/classes/java/ias60.jar
${SERVER_ROOT}/${INSTANCE}/start*
/etc/opt/SUNWips/.wtpass
/etc/opt/SUNWips/.application
/etc/opt/SUNWips/.version
/etc/opt/SUNWips/.version-orig
/etc/opt/SUNWips/platform.conf
${SERVER_ROOT}/SUNWips/bin/ipsnetletd
${SERVER_ROOT}/SUNWips/bin/ipshttpd
/etc/S*ipsserver
/etc/init.d/ipsgateway
/etc/init.d/ipsserver
/etc/init.d/ipsnetletd
/etc/init.d/ipshttpd
/etc/coreadm.conf
/etc/named.pid
/etc/dumpadm.conf
/etc/system
/etc/opt/SUNWips/properties.file
/etc/opt/SUNWips/platform.*
${SERVER_ROOT}/netscape/directory4/bin/slapd/server/explorer_ldif
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/start-jvm
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/start
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/start
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/start
${SERVER_ROOT}/${INSTANCE}/start-jvm
${SERVER_ROOT}/${INSTANCE}/start
${SERVER_ROOT}/${INSTANCE}/start
${SERVER_ROOT}/httpacl/*
${SERVER_ROOT}/userdb/*

Directories Collected

The following directories are collected:

${SERVER_ROOT}/${INSTANCE}/config
${SERVER_ROOT}/${INSTANCE}/logs

In addition, the following directories are collected recursively:

${SERVER_ROOT}/SUNWips/lib
/etc/opt/SUNWips/cert
/etc/opt/SUNWips/auth
/etc/opt/SUNWips/xml
/etc/qlog
/etc/cron.d
/etc/dfs
/etc/saf
/var/opt/SUNWips
/var/sadm/install/logs
${SERVER_ROOT}/SUNWips/public_html
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/config/
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/logs/
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/config/
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/logs/
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/config/
${SERVER_ROOT}/${NET_DIR}/${INSTANCE}/logs/
${SERVER_ROOT}/${INSTANCE}/config/
${SERVER_ROOT}/${INSTANCE}/logs/
${SERVER_ROOT}/${INSTANCE}/config/
${SERVER_ROOT}/${INSTANCE}/logs/
${SERVER_ROOT}/shared/config
${SERVER_ROOT}/${INSTANCE}/config
${SERVER_ROOT}/${INSTANCE}/config
${SERVER_ROOT}/shared/config
${SERVER_ROOT}/${INSTANCE}/imta/config
${SERVER_ROOT}/shared/config

sunray

Collects Sun Ray server information.

Commands Collected

The following commands are collected:

/etc/opt/SUNWut/jre/bin/java -version
/opt/SUNWut/bin/utdiskadm -l -a
/opt/SUNWut/bin/utdiskadm -s -a
/opt/SUNWut/bin/utwho -Hac
/opt/SUNWut/bin/utwho -Hc
/opt/SUNWut/lib/utprodinfo
/opt/SUNWut/lib/utprop
/opt/SUNWut/sbin/utadm -x
/opt/SUNWut/sbin/utfwload -Ha
/opt/SUNWut/sbin/utusbadm
/opt/SUNWut/sbin/utgstatus
/opt/SUNWut/sbin/utreplica -l
/opt/SUNWut/sbin/utuser -L
/opt/SUNWut/sbin/utuser -L -g
/opt/SUNWut/sbin/utpolicy
/opt/SUNWut/sbin/utglpolicy
/opt/SUNWut/sbin/utadm -p
/opt/SUNWut/sbin/utcard -l
/opt/SUNWut/sbin/utdesktop -L -c
/opt/SUNWut/sbin/utdesktop -l -g
/opt/SUNWut/sbin/utmhadm
/opt/SUNWut/sbin/utfwadm -P
/opt/SUNWut/sbin/utsession -p
/opt/SUNWut/sbin/utcrypto -o
/opt/SUNWut/sbin/utreader
/opt/SUNWut/sbin/utresadm -o
/opt/SUNWut/sbin/utadm -l
/opt/SUNWut/sbin/utreplica -i
/opt/SUNWut/sbin/utsession -l
/bin/ls -lRt /tftpboot
/bin/ls -lRt /tmp/SUNWut
/bin/ls -lRt /var/opt/SUNWut
/bin/ls -lRt /var/opt/SUNWconn
/bin/ls -lRt /etc/opt/SUNWut
/bin/ls -lRt /etc/opt/SUNWconn
/bin/ls -lRt /opt/SUNWut
/usr/sbin/dhtadm -P
/usr/sbin/pntadm -P ${NET}
/usr/sbin/pntadm -P ${network}
/opt/SUNWut/sbin/utquery -d ${network}
/usr/sbin/pkgchk ${pkg}
/opt/SUNWut/bin/utxconfig -o
/opt/SUNWut/bin/utxconfig -o
/usr/bin/sum /etc/opt/SUNWut/utadmin.pw
/usr/bin/cksum /etc/opt/SUNWut/gmSignature

Files Collected

The following files are collected:

/var/opt/SUNWut/srds/log/utdsd.log*
/var/opt/SUNWut/srds/log/utdsd.pid
/var/opt/SUNWut/srds/log/utdsd.replog
/var/opt/SUNWut/srds/log/utpushd.log*
/var/opt/SUNWut/srds/log/utpulld.log*
/var/opt/SUNWut/srds/replog/utpulld.status
/var/opt/SUNWut/srds/replog/utpushd.status
/etc/opt/SUNWut/srds/current/utdsd.conf
/etc/opt/SUNWut/srds/current/utdsd.ini
/etc/opt/SUNWut/auth.props
/etc/opt/SUNWut/auth.props.bak
/var/tmp/SUNWut/utpreserve.tar
/etc/opt/SUNWut/utsettings_defaults.properties
/etc/opt/SUNWut/utsettings_mandatory.properties
/etc/opt/SUNWut/utadmin.conf
/etc/opt/SUNWut/policy/utpolicy
/etc/opt/SUNWconn/ldap/current/dsnmprad.conf
/etc/opt/SUNWconn/ldap/current/dsnmpserv.conf
/etc/opt/SUNWconn/ldap/current/dsserv.acl.conf
/etc/opt/SUNWconn/ldap/current/dsserv.at.conf
/etc/opt/SUNWconn/ldap/current/dsserv.at.ut.conf
/etc/opt/SUNWconn/ldap/current/dsserv.conf
/etc/opt/SUNWconn/ldap/current/dsserv.ini
/etc/opt/SUNWconn/ldap/current/dsserv.oc.conf
/etc/opt/SUNWconn/ldap/current/dsserv.oc.ut.conf
/etc/opt/SUNWconn/ldap/current/dswebfilter.conf
/etc/opt/SUNWconn/ldap/current/dswebfriendly.conf
/etc/opt/SUNWconn/ldap/current/ldapfilter.conf
/etc/opt/SUNWconn/ldap/current/ldapsync.conf
/etc/opt/SUNWconn/ldap/current/ldaptemplates.conf
/var/opt/SUNWut/log/admin_log*
/var/opt/SUNWut/log/auth_log*
/var/opt/SUNWut/log/messages*
/var/opt/SUNWconn/ldap/log/*.log
/var/opt/SUNWconn/ldap/log/dsserv.replog
/var/opt/SUNWconn/ldap/replog/dspushd.replog
/var/opt/SUNWconn/ldap/replog/dspulld.status
/var/http/utadmin/websites/default_site/logs
/etc/dt/config/Xservers
/etc/dt/config/Xconfig
/etc/dt/config/Xreset
/etc/dt/config/Xsetup
/var/dhcp/dhcptab
/etc/dt/config/Xservers.SUNWut.prototype
/etc/dt/config/Xconfig.SUNWut.prototype
/usr/dt/config/Xstartup
/var/dt/Xpid
/var/dt/Xerrors
/etc/dt/config/sessionetc
/var/tmp/utinstall.*.log
/var/tmp/utconfig.*.log
/var/opt/SUNWut/tmp/utreplica.*.log
/var/adm/log/ut*

Directories Collected

The following directory is collected:

var/opt/SUNWut/ndbm

In addition, the following directory is collected recursively:

/var/opt/SUNWut/kiosk

sysconfig

Collects system configuration information. Also checks values set in /etc/system and collects data for all core files found and for each class dispatch table. Also collects directory listings of coreadm command "global core file pattern" for global and local zones.

Commands Collected

The following commands are collected:

/bin/ls -al ${CRASHDIR}
/bin/ls -l /kernel
/bin/ls -l /platform/${ARCH}/kernel
/bin/ls -l /var/opt/SUNWldm
/bin/ls -lR /kernel/drv
/bin/ls -lR /platform/'uname -i'/kernel/drv
/bin/ls -lR /platform/'uname -m'/kernel/drv
/bin/ls -lR /usr/kernel/drv
/opt/CTEact/bin/act -d ${CRASHDIR}/vmcore.${LAST} -n ${CRASHDIR}/unix.${LAST}
/opt/CTEactx/bin/act -d ${CRASHDIR}/vmcore.${LAST} -n ${CRASHDIR}/unix.${LAST}
/opt/SUNWldm/bin/ldm -V
/opt/SUNWldm/bin/ldm list -l
/opt/SUNWldm/bin/ldm list -l -p
/opt/SUNWldm/bin/ldm list-devices -a
/opt/SUNWut/sbin/utadm -p
/usr/bin/coreadm
/usr/bin/echo ::fcptrace | /usr/bin/mdb -k
/usr/bin/echo ::fptrace | /usr/bin/mdb -k
/usr/bin/echo "$<msgbuf" | /usr/bin/mdb -k ${unixfile} ${core}
/usr/bin/echo \"::interrupts\" | /usr/bin/mdb -k (sysconfig/interrupts) 
/usr/bin/echo \"::softint\" | /usr/bin/mdb -k (sysconfig/softint) 
/usr/bin/echo \"::vecint\" | /usr/bin/mdb -k (sysconfig/vecint) 
/usr/bin/echo lgrp_mem_default_policy/X | /usr/bin/mdb -k
/usr/bin/echo nlgrps/X | /usr/bin/mdb -k
/usr/bin/egrep -e "rmt|DLT"
/usr/bin/env
/usr/bin/iostat -En
/usr/bin/ipcs -A
/usr/bin/ipcs -a
/usr/bin/isainfo
/usr/bin/isainfo -kv
/usr/bin/last -100
/usr/bin/last -20 reboot
/usr/bin/last reboot
/usr/bin/lgrpinfo -a
/usr/bin/locale
/usr/bin/ls -l '/usr/bin/dirname' ${COREPATTERN}'
/usr/bin/poolstat
/usr/bin/priocntl -d -i class RT
/usr/bin/priocntl -l
/usr/bin/prstat -L 1 1
/usr/bin/ps -acefl
/usr/bin/ps -aceflZ -o f,s,zone,user,pid,ppid,class,pri,addr,osz,wchan,stime,tty,time,comm (sysconfig/ps-aceflZ) 
/usr/bin/ps -aefl -o user,pid,ppid,project,zone,class,pri,lwp,psr,pset,pmem,etime,
/usr/bin/ps -ef
/usr/bin/ps -efPljyZ -o s,zone,user,pid,ppid,pgid,sid,psr,c,opri,nice,rss,vsz,wchan,stime,tty,time,comm (sysconfig/ps-efPljyZ) 
/usr/bin/ps -efZ -o zone,user,pid,ppid,c,stime,tty,time,comm (sysconfig/ps-efZ) 
/usr/bin/smbios -i 1
/usr/bin/stclient -x
/usr/bin/strings $core | head
/usr/bin/svcprop '*'
/usr/bin/svcs -av
/usr/bin/svcs -l \*
/usr/bin/svcs -xv
/usr/bin/uname -a
/usr/bin/uname -X
/usr/bin/uptime
/usr/bin/vmstat 3 3
/usr/bin/who -b
/usr/ccs/bin/nm /dev/ksyms | egrep -e $mod
/usr/kvm/prtdiag -v
/usr/platform/${ARCH}/sbin/prtdiag -v
/usr/platform/${SYSNAME}/sbin/prtdiag -v
/usr/proc/bin/ptree root
/usr/sbin/apconfig -D
/usr/sbin/apconfig -N
/usr/sbin/apconfig -N -u
/usr/sbin/apconfig -S
/usr/sbin/apconfig -S -u
/usr/sbin/apinst
/usr/sbin/cfgadm -al -o show_FCP_dev
/usr/sbin/cfgadm -alv
/usr/sbin/cfgadm -alv -o show_FCP_dev
/usr/sbin/cfgadm -l -o show_FCP_dev
/usr/sbin/cfgadm -lv
/usr/sbin/cfgadm -lv -o show_FCP_dev
/usr/sbin/cfgadm -x passthru -o showlpa ${BOARD_NO}
/usr/sbin/dispadmin -c ${CLASS} -g
/usr/sbin/dispadmin -l
/usr/sbin/dumpadm
/usr/sbin/eeprom
/usr/sbin/fcinfo hba-port -1
/usr/sbin/fcinfo remote-port -p <HBA_WWN> -ls
/usr/sbin/hotplug list -l (sysconfig/hotplug_list_-l) 
/usr/sbin/hotplug list -v (sysconfig/hotplug_list_-v) 
/usr/sbin/ifconfig -a
/usr/sbin/ifconfig -a modlist
/usr/sbin/inetadm
/usr/sbin/ipsecconf
/usr/sbin/ipsecconf -ln
/usr/sbin/lockstat sleep 5
/usr/sbin/lom -a
/usr/sbin/lom -c
/usr/sbin/lom -e
/usr/sbin/lom -l
/usr/sbin/lufslist $be (boot environment)
/usr/sbin/lustatus
/usr/sbin/modinfo
/usr/sbin/modinfo -c
/usr/sbin/ntpq -p
/usr/sbin/pcitool -v (sysconfig/pcitool-v) 
/usr/sbin/pmadm -L
/usr/sbin/pooladm
/usr/sbin/prtconf -F
/usr/sbin/prtconf -V
/usr/sbin/prtconf -v
/usr/sbin/prtconf -vD
/usr/sbin/prtconf -vp
/usr/sbin/prtpicl -v
/usr/sbin/psrinfo -pv
/usr/sbin/psrinfo -v
/usr/sbin/psrset -i
/usr/sbin/psrset -p
/usr/sbin/psrset -q
/usr/sbin/sacadm -L
/usr/sbin/smbios
/usr/sbin/smbios -w
/usr/sbin/svccfg list
/usr/sbin/sysdef
/usr/sbin/sysdef -d
/usr/ucb/ps -axuwww
$cest_dir/opt/SUNWcest/bin/cediag -A
$cest_dir/opt/SUNWcest/bin/cediag -v
$cest_dir/opt/SUNWcest/bin/cestat -v
$RSCADM date
$RSCADM loghistory
$RSCADM show
$RSCADM usershow
$RSCADM version -v
$SCADM date
$SCADM loghistory
$SCADM show
$SCADM shownetwork
$SCADM usershow
$SCADM version -v
echo "::numaio_group -c" | mdb -k
echo "::numaio_group -o all" | mdb -k
echo "::numaio_group" | mdb -k
echo "\$G;\$<threadlist" | /usr/bin/mdb -k /dev/ksyms /dev/mem
HBA_WWN port no is taken from previous command output
prtdiag -v (/usr/sbin, /usr/platform/<arch>/bin,/usr/platform//sbin, /usr/kvm) 
sho/usr/sbin/poolcfg -dc info
time,tty,args
zlogin ${ZONENAME} '/usr/sbin/inetadm'
zlogin ${ZONENAME} '/usr/sbin/psrinfo -pv'
zlogin ${ZONENAME} '/usr/bin/coreadm'
zlogin ${ZONENAME} '/usr/bin/ipcs -a'
zlogin ${ZONENAME} '/usr/bin/last -100'
zlogin ${ZONENAME} '/usr/bin/last -20 reboot'
zlogin ${ZONENAME} '/usr/bin/last reboot'
zlogin ${ZONENAME} '/usr/bin/locale'
zlogin ${ZONENAME} '/usr/bin/ls -l '/usr/bin/dirname ${COREPATTERN}''
zlogin ${ZONENAME} '/usr/bin/prctl -n zone.cpu-shares -i zone global'
zlogin ${ZONENAME} '/usr/bin/priocntl -l'
zlogin ${ZONENAME} '/usr/bin/ps -acefl'
zlogin ${ZONENAME} '/usr/bin/ps -aceflZ
zlogin ${ZONENAME} '/usr/bin/ps -axuwww'
zlogin ${ZONENAME} '/usr/bin/ps -AZ'
zlogin ${ZONENAME} '/usr/bin/ps -aZ'
zlogin ${ZONENAME} '/usr/bin/ps -ef'
zlogin ${ZONENAME} '/usr/bin/ps -efPljy'
zlogin ${ZONENAME} '/usr/bin/ps -efpljyZ'
zlogin ${ZONENAME} '/usr/bin/ps -efZ'
zlogin ${ZONENAME} '/usr/bin/ptree -z global root'
zlogin ${ZONENAME} '/usr/bin/svccfg list'
zlogin ${ZONENAME} '/usr/bin/svcs -av'
zlogin ${ZONENAME} '/usr/bin/svcs -l ${SVC}'
zlogin ${ZONENAME} '/usr/bin/svcs -xv'
zlogin ${ZONENAME} '/usr/bin/uname -a'
zlogin ${ZONENAME} '/usr/bin/uname -X'
zlogin ${ZONENAME} '/usr/bin/uptime'
zlogin ${ZONENAME} '/usr/bin/vmstat 3 3'
zlogin ${ZONENAME} '/usr/bin/who -b'
zlogin ${ZONENAME} '/usr/proc/bin/ptree root'
zlogin ${ZONENAME} '/usr/sbin/ifconfig -a'
zlogin ${ZONENAME} '/usr/sbin/ipsecconf'
zlogin ${ZONENAME} '/usr/sbin/pmadm -L'
zlogin ${ZONENAME} '/usr/sbin/psrinfo -v'
zlogin ${ZONENAME} '/usr/sbin/sacadm -L'
zlogin ${ZONENAME} '/usr/sbin/sysdef -d'
zlogin ${ZONENAME} '/usr/sbin/sysdef'
zlogin ${ZONENAME} '/usr/sbin/zoneadm list -cp'
zlogin ${ZONENAME} '/usr/sbin/zoneadm list -cv'
zlogin ${ZONENAME} '/usr/sbin/zoneadm list -ip'
zlogin ${ZONENAME} '/usr/sbin/zoneadm list -iv'
zlogin ${ZONENAME} '/usr/sbin/zonecfg -z ${ZONENAME} export'
zlogin ${ZONENAME} '/usr/sbin/zonecfg -z ${ZONENAME} info'

One of the two following outputs will be collected by Explorer in which PRODIDstands for a unique product ID for Explorer:

/usr/bin/stclient -a -p Explorer -e ${EXP_VERSION} -t $PRODID -P ' ' -m 'Sun
Microsystems, Inc.' -A'uname -p' -z global -S Explorer
/usr/bin/stclient -f -t $PRODID

Files Collected

The following files are collected:

/kernel/drv/*.conf
/usr/kernel/drv/*.conf
/platform/'uname -i'/kernel/drv/*.conf
/platform/'uname -m'/kernel/drv/*.conf
${CRASHDIR}/act.*
/etc/lutab
/boot/grub/menu.lst
/boot/solaris/bootenv.rc
chassis_serial.out (contains chassis serial number for system)

syslogs

Collects log files in /var/log.

Files Collected

The following files are collected:

/etc/logadm.conf
/var/log/syslog
${ZONEPATH}/etc/logadm.conf
${ZONEPATH}/root/var/log/syslog

t3

Collects StorEdge T3 information. Collects data for each StorEdge T3 LUN found.

Commands Collected

The following commands are collected:

/usr/sbin/format -e -f ${CFILE} -d ${LUN} 2>&1 | sed -n -e '/^Inquiry:/,/^scsi>/p
/usr/sbin/luxadm display ${LUN}
/usr/sbin/luxadm -e dump_map ${LUN}

t3extended

Collects extended StorEdge T3 information.

Commands Collected

The following command is collected:

/bin/ls -l ${EXP_T3INPUT_CONFIG}

In addition, the following commands are collected from the remote host:

ls -l /
ver
ls -l /etc
ls -l /web
ls -l /web/snmp
arp -a
lpc version
proc list
fru stat sys
sys stat
sys list
vol stat
vol list
vol mode
fru list
fru statistic
fru myuid
date
tzset
port list
port listmap
ver
set
refresh -s
route -r
.ep info
.loop stat
.set
.sys list
fru stat
fru stat
id read ${T3_ID}pcu1
id read ${T3_ID}pcu2
id read ${T3_ID}
id read ${T3_ID}l1
id read ${T3_ID}l2
id read ${T3_ID}c1
disk version ${T3_ID}d1-9
.disk pathstat ${T3_ID}d1-9
.disk linkstat ${T3_ID}d1-9 path 0
.disk linkstat ${T3_ID}d1-9 path 1
.disk tmon_list ${T3_ID}d1-9
.disk gettune ${T3_ID}d1-9
logger -dmprstlog
volslice list
lun map list
lun perm list
lun wwn list
hwwn list
hwwn listgrp
ntp
ntp stats
ntp -v
sys fc_topology
du -a
du -s
savecore list
netstat -airs
.ep info
.loop stat
.set
.sys list
fru stat
disk version ${T3_ID}d1-14
.disk pathstat ${T3_ID}d1-14
.disk linkstat ${T3_ID}d1-14 path 0
.disk linkstat ${T3_ID}d1-14 path 1
.disk tmon_list ${T3_ID}d1-14
.disk gettune ${T3_ID}d1-14
.disk plist ${T3_ID}d1-14
.disk glist ${T3_ID}d1-14
.disk softerr ${T3_ID}d1-14
.disk harderr ${T3_ID}d1-14
.pgrdb
.ecc s
.devtree ${T3_NUM}
.bat -s ${T3_NUM}pcu1
.bat -s ${T3_NUM}pcu2
global_standby list ${T3_ID}

Files Collected

The following files are collected from the remote host:

cmdlog* syslog*
hosts *.conf *.log

tape

Collects information from tape drives and STK Libraries.

Commands Collected

The following command is collected:

st_diag.'uname -p'

Tx000

Collects SP ALOM information on the Sun Fire T1000 server and Sun Fire T2000 server. Usually, only one SP will be present.

Collects CMM ALOM and SP ALOM data on the Sun Fire TX6300/TX6320 systems. Usually, one CMM will be present together with multiple SP's.

Commands Collected

The ipmitool command is searched in the following directories:

/opt/ipmitool/bin
/usr/sbin
/usr/sfw/bin

The following commands are collected:

Collection of CMM Data

${CMMCONN} stands for the CMM connection data (system, username (always root), password).

ipmitool ${CMMCONN} chassis status
ipmitool ${CMMCONN} fru
ipmitool ${CMMCONN} mc info
ipmitool ${CMMCONN} -v sdr
ipmitool ${CMMCONN} sdr elist
ipmitool ${CMMCONN} sdr list
ipmitool ${CMMCONN} sel elist
ipmitool ${CMMCONN} sensor
ipmitool ${CMMCONN} sunoem led get
ipmitool ${CMMCONN} sunoem sbled get

Collection of SP Data

${SPCONN} stands for the SP connection data (system, username (always root), password).

ipmitool ${SPCONN} chassis status
ipmitool ${SPCONN} fru
ipmitool ${SPCONN} mc info
ipmitool ${SPCONN} -v sdr
ipmitool ${SPCONN} sdr elist
ipmitool ${SPCONN} sdr list
ipmitool ${SPCONN} sel elist
ipmitool ${SPCONN} sensor
ipmitool ${SPCONN} sunoem led get
ipmitool ${SPCONN} sunoem sbled get

Snapshot Information

Where <host> is IP address of CMM and SP connected to the bladeserver

snapshot
ipmitool -H <host> -U root fru
ipmitool -H <host> -U root sel elist
ipmitool -H <host> -U root -v sdr
ipmitool -H <host> -U root sdr elist
ipmitool -H <host> -U root sdr list
ipmitool -H <host> -U root chassis status
ipmitool -H <host> -U root sunoem led get
ipmitool -H <host> -U root sensor
ipmitool -H <host> -U root mc info
ipmitool -H <host> -U root sunoem sbled get

u4ft

Collects Sheffield information. Collects all EEPROM data.

Commands Collected

The following commands are collected:

${CMSHOME}/sbin/splitinfo
/usr/bin/ls -lR /usr/platform/SUNW,Ultra-4FT/SUNWftmu
/usr/bin/cat /dev/u4ftlog:nvlog,nodelay
/usr/bin/cat /dev/u4ftlog:debug,nodelay
${CMSHOME}/lib/u4ftctl get_path $cookie
${CMSHOME}/lib/u4ftctl get_state $cookie
${CMSHOME}/lib/u4ftctl get_tag $cookie
${CMSHOME}/lib/u4ftctl get_driver $cookie
${CMSHOME}/lib/u4ftctl get_instance $cookie
${CMSHOME}/sbin/cmsfruinfo -i -l $LOCATION EE_EEPROM

Files Collected

The following files are collected:

/etc/splitd.conf
/etc/config.icn*
/etc/SUNWftmu/u4ft_compatDB
/etc/SUNWftmu/u4ft_syspartno
/etc/default/vxassist
/etc/vx/sbin/vxaltstale
/etc/rc2.d/S95vxvm-recover
/etc/release

Directories Collected

The following directories are collected:

/var/SUNWlogu
/var/SUNWftmu/u4ftcod
/etc/SUNWftmu/u4ftcod
/etc/SUNWcms/.config

ufsextended

Collects extended UFS information.

Commands Collected

The following command is collected:

/usr/sbin/fstyp -v $bdev

var

Collects log and config information in /var. Collects all crontab files.

Commands Collected

The following commands are collected:

/bin/ls -al /var/tmp
/bin/ls -l /var/cron/log
/bin/ls -l /var/ntp
/bin/ls -l /var/tmp
/bin/ls -l /var/yp/binding
/bin/ls -la /var/cron
/bin/ls -ld /var
/bin/ls -ld /var/adm
/bin/ls -ld /var/sadm
/bin/tail -10000 /var/cron/log
/etc/krb5 (etc/krb5/)
/usr/bin/tail -1000 /var/cpudiag/log/error.log
/usr/bin/tail -1000 /var/cpudiag/log/info.log
/var/krb5 (var/krb5/)
/var/opt/SUNWuce/agent/logs (var/opt/SUNWuce/agent/logs/)
/var/sadm/install_data (var/sadm/install_data/)
/var/scn/update-agent/logs (var/scn/update-agent/logs/)
/var/svc/log (var/svc/log/)
<zonepath>/root/etc/krb5 (zones/<zone>/etc/krb5/)
<zonepath>/root/var/krb5 (zones/<zone>/var/krb5/)
<zonepath>/root/var/opt/SUNWuce/agent/logs    (zones/<zone>/var/opt/SUNWuce/agent/logs/)
<zonepath>/root/var/sadm/install_data (zones/<zone>/var/sadm/install_data/)
<zonepath>/root/var/scn/update-agent/logs    (zones/<zone>/var/scn/update-agent/logs/)
<zonepath>/root/var/svc/log (zones/<zone>/var/svc/log)

Files Collected

The following files are collected:

/var/cpudiag/data/bad_cpu_id.*
/var/log/install_stb-v<version>.log
/var/log/lwact.xml
/var/ntp/ntp.drift
/var/opt/sun/jet/config/host.config
/var/opt/sun/jet/jumpstart_install.log
/var/opt/SUNWjass/run/$TIMESTAMP/jass-audit-log.txt
/var/opt/SUNWjass/run/$TIMESTAMP/jass-checksums.txt
/var/opt/SUNWjass/run/$TIMESTAMP/jass-install-log.txt
/var/opt/SUNWjass/run/$TIMESTAMP/jass-script-list.txt
/var/opt/SUNWjass/run/$TIMESTAMP/jass-undo-log.txt
/var/opt/SUNWjass/run/$TIMESTAMP/jass-version.txt
/var/opt/SUNWvts/logs/sunvts.info
/var/run/psn
/var/sadm/install/contents
/var/sadm/softinfo/INST_RELEASE
/var/sadm/system/admin/CLUSTER
/var/spool/cron/crontabs/$i
/var/sun/EIS-CD.log
/var/sun/GOLD-CD.log
/var/yp/binding/* (var/yp/binding/)
<zonepath>/root/var/yp/binding/* (zones/<zone>/var/yp/binding/)

Directories Collected

The following directories are collected recursively:

/var/sun/install-ORIG
/var/log/sunfire
/var/sun/include
/var/sadm/install/se6000
/var/ep (directory)

vtsst

Collects StorTools 4.x information.

Commands Collected

The following commands are collected:

${VTSPATH}/discman -v
${VTSPATH}/discman -c

Files Collected

The following files are collected:

/var/opt/SUNWvtsst/logs/sunvts.err
/var/opt/SUNWvtsst/logs/activity.log
/var/opt/SUNWvtsst/logs/*.errlog
/var/opt/SUNWvtsst/logs/[Ss]nap[Ss]hot.log
/var/opt/SUNWvtsst/logs/[Ss]nap[Ss]hot.diffs

vxfs

Collects Veritas file system information. Data is collected for each file system in df -lF vxfs.

Commands Collected

The following commands are collected:

/usr/sbin/vxtunefs -p $bdev
/usr/lib/fs/vxfs/fsadm -ED $fs
/usr/sbin/fstyp -v $bdev

Files Collected

The following file is collected:

/etc/vx/tunefstab

Directories Collected

The following directory is collected:

/etc/vx/elm

In addition, the following directory is collected recursively:

/etc/vx/licenses

vxvm

Collects Veritas Volume Manager information. Collects data for each disk group found.

Commands Collected

The following commands are collected:

/usr/sbin/vxprint -Ath
/usr/sbin/vxprint -th
/usr/sbin/vxprint -h
/usr/bin/ls -lR /dev/vx
/usr/bin/ls -lLR /dev/vx
/usr/sbin/vxdg -q list
/usr/bin/sum /etc/vx/slib/* /usr/lib/libc.so.1 /usr/lib/libthread.so.1
/usr/sbin/vxdg -q list
/usr/sbin/vxdg -g $DG_NAME free
/usr/sbin/vxdg list $DG_NAME
/usr/sbin/vxprint -vng $DG_NAME
/usr/sbin/vxprint -hmQqg $DG_NAME $VOL_LIST
/usr/sbin/vxprint -rmvg $DG_NAME $VOL_LIST
/usr/sbin/vxprint -hmQqg $DG_NAME
/usr/sbin/vxprint -mdg $DG_NAME
/usr/sbin/vxprint -mvrGg $DG_NAME
/etc/vx/diag.d/vxprivutil dumpconfig ${PRIV_PATH}
/usr/sbin/vxdisk list
/usr/sbin/vxdisk -o alldgs list
/usr/sbin/vxprint -thrL
/usr/sbin/vxprint -hr
/usr/sbin/vxtask list
/usr/sbin/vxdisk -o alldgs list
/usr/sbin/vxdisk list ${DISK_NAME}
/usr/sbin/vxdmpadm listexclude
/usr/sbin/vxdmpadm listctlr all
/usr/sbin/vxdmpadm getdmpnode enclosure=$enclosure
/usr/sbin/vxdmpadm stat restored
/usr/sbin/vxddladm listjbod
/usr/sbin/vxddladm listsupport all
/usr/sbin/vxddladm listexclude all
/usr/sbin/vxdisk path
/usr/sbin/vxdisk -e -o alldgs list
/usr/sbin/vxddladm listversion all
/sbin/vxlicrep
/sbin/vxlicrep -e
/usr/sbin/vxcmdlog -l
/usr/sbin/vxtranslog -l
/etc/vx/disk.info

Files Collected

The following files are collected:

/etc/vx/vxrelocd
/etc/rc2.d/S95vxvm-recover
/etc/vfstab.prevm
/etc/vx/volboot
/etc/vx/vxdmp.exclude
/etc/vx/vxvm.exclude
/etc/vx/dmpvents.log

Directories Collected

The following directories are collected:

/etc/vx/elm
/var/opt/vmsa/logs
/var/adm/vx

In addition, the following directories are collected recursively:

-f *.jar /var/vx/isis
/etc/vx/reconfig.d
/var/vxvm

Then the following three directories are collected:

/etc/vx/cbr/bk/*/*cfgrec
/etc/vx/cbr/bk/*/*dginfo
/etc/vx/cbr/bk/*/*diskinfo

Finally, the same three directories are collected but with the extensions .1, .2, .3, .4, and .5 until a maximum total size of 1.5 Mbytes is reached.

If the maximum size is reached, the output of the following command is added (to show a directory listing of the items that were not collected):

/usr/bin/ls -lR /etc/vx/cbr/bk

xscfextended

Collects Sun SPARC Enterprise M4000/M5000/M8000/M9000-32/M9000-64 information.

Commands Collected

The following commands are collected from the remote host:

snapshot -T -D -L -F

Directories Collected

The following directory is collected recursively:

/var/log/opl

Total Number of Collected Commands, Files, and Directories

Total commands collected: 12026+Total files collected: 606+Total directories collected: 238+

Grand total of all commands, files, and directories: 20470+

These totals should be viewed with caution. The command, file, and directory totals were gathered using grep. The totals could be on the low side, because they do not account for wild cards in file collection or for directories collected recursively. They also do not account for scripts that loop through files or command output to determine what needs to be collected.

The totals could also be on the high side, depending on the hardware and software installed on your system. For example, the ndd script collects data based on network hardware installed on your system. It attempts to collect data for 4 services, such as tcp and udp. It checks for up to 10 cards (such as qfe or hme) and allows for up to 16 instances of each card. For each card or service, Oracle Explorer Data Collector gets the list of parameters for each instance and collects all information for each parameter. On an Ultra 10 workstation that runs Solaris 8 software, there are 175 ndd commands collecting data for tcp, ip, udp, icmp, and hme.