Decisioneering.CB.CBCOMDevKit Namespace

CollapseAll image | DropDown image
C#

Visual Basic

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit Namespace
Crystal Ball COM and .NET Development Kit Namespace

Types

All Types | Classes
Name | Description
MRWrapper | MR Command wrapper. Use in using statements to insure MR status tracked and set into command processor for all COM visible calls for DevKit integration.


MRWrapper Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
MRWrapper Class
MR Command wrapper. Use in using statements to insure MR status tracked and set into command processor for all COM visible calls for DevKit integration.

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class MRWrapper : IDisposable
Public Class MRWrapper _
    Implements IDisposable
Dim instance As MRWrapper

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
MRWrapper(String, Boolean) | Create an MRWrapper object to insure Macro result status tracked.
MRWrapper(String, Boolean, MacroResult) | Create an MRWrapper object to insure Macro result status tracked.
CommandName | The command name for this MacroResult
Dispose()()()() | Dispose this object
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ErrorDetails | The error details
ErrorMessage | The error message
ErrorNumber | The error number, equates to New Value error numbers
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsOk | Is an error present
LastResult | The last error result
SetError(Exception) | Set the MR error for all errors encountered by the host class
SetError(Exception, Boolean) | Sets the curent error
ThrowErrors | This macro result errors are thrown
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit..::..MRWrapper

See Also

Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Constructor

Visual Basic Usage

| See Also
CB Com Devkit
MRWrapper Constructor

Overload List

Name | Description
MRWrapper(String, Boolean) | Create an MRWrapper object to insure Macro result status tracked.
MRWrapper(String, Boolean, MacroResult) | Create an MRWrapper object to insure Macro result status tracked.

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Constructor (String, Boolean)

Visual Basic Usage

CB Com Devkit
MRWrapper Constructor (String, Boolean)
Create an MRWrapper object to insure Macro result status tracked.

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MRWrapper(
    string commandName,
    bool throwErrors
)
Public Sub New ( _
    commandName As String, _
    throwErrors As Boolean _
)
Dim commandName As String
Dim throwErrors As Boolean

Dim instance As New MRWrapper(commandName, _
    throwErrors)

Parameters

commandName
String
The name of the command
throwErrors
Boolean
True if errors are thrown

See Also

MRWrapper Class
MRWrapper Overload
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Constructor (String, Boolean, )

Visual Basic Usage

CB Com Devkit
MRWrapper Constructor (String, Boolean, )
Create an MRWrapper object to insure Macro result status tracked.

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MRWrapper(
    string commandName,
    bool throwErrors,
    MacroResult mr
)
Public Sub New ( _
    commandName As String, _
    throwErrors As Boolean, _
    mr As MacroResult _
)
Dim commandName As String
Dim throwErrors As Boolean
Dim mr As MacroResult

Dim instance As New MRWrapper(commandName, _
    throwErrors, mr)

Parameters

commandName
String
The name of the command
throwErrors
Boolean
True if errors are thrown
mr
MacroResult
Current Macro result

See Also

MRWrapper Class
MRWrapper Overload
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Methods

Visual Basic Usage

CB Com Devkit
MRWrapper Methods

The MRWrapper type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dispose()()()() | Dispose this object
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetError(Exception) | Set the MR error for all errors encountered by the host class
SetError(Exception, Boolean) | Sets the curent error
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


Dispose Method

Visual Basic Usage

CB Com Devkit
MRWrapper..::Dispose Method
Dispose this object

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Dispose()
Public Sub Dispose
Dim instance As MRWrapper

instance.Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


SetError Method

Visual Basic Usage

CB Com Devkit
MRWrapper..::SetError Method

Overload List

Name | Description
SetError(Exception) | Set the MR error for all errors encountered by the host class
SetError(Exception, Boolean) | Sets the curent error

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


SetError Method (Exception)

Visual Basic Usage

CB Com Devkit
MRWrapper..::SetError Method (Exception)
Set the MR error for all errors encountered by the host class

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetError(
    Exception ex
)
Public Sub SetError ( _
    ex As Exception _
)
Dim instance As MRWrapper
Dim ex As Exception

instance.SetError(ex)

Parameters

ex
Exception
The Exception to set to the MR

See Also

MRWrapper Class
SetError Overload
Decisioneering.CB.CBCOMDevKit Namespace


SetError Method (Exception, Boolean)

Visual Basic Usage

CB Com Devkit
MRWrapper..::SetError Method (Exception, Boolean)
Sets the curent error

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetError(
    Exception ex,
    bool throwWarningsAsErrors
)
Public Sub SetError ( _
    ex As Exception, _
    throwWarningsAsErrors As Boolean _
)
Dim instance As MRWrapper
Dim ex As Exception
Dim throwWarningsAsErrors As Boolean

instance.SetError(ex, throwWarningsAsErrors)

Parameters

ex
Exception
Exception as error
throwWarningsAsErrors
Boolean
Throw warnings

See Also

MRWrapper Class
SetError Overload
Decisioneering.CB.CBCOMDevKit Namespace


MRWrapper Properties

Visual Basic Usage

CB Com Devkit
MRWrapper Properties

The MRWrapper type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CommandName | The command name for this MacroResult
ErrorDetails | The error details
ErrorMessage | The error message
ErrorNumber | The error number, equates to New Value error numbers
IsOk | Is an error present
LastResult | The last error result
ThrowErrors | This macro result errors are thrown

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


CommandName Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::CommandName Property
The command name for this MacroResult

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CommandName { get; }
Public ReadOnly Property CommandName As String
    Get
Dim instance As MRWrapper
Dim value As String

value = instance.CommandName

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


ErrorDetails Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ErrorDetails Property
The error details

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ErrorDetails { get; }
Public ReadOnly Property ErrorDetails As String
    Get
Dim instance As MRWrapper
Dim value As String

value = instance.ErrorDetails

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


ErrorMessage Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ErrorMessage Property
The error message

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ErrorMessage { get; }
Public ReadOnly Property ErrorMessage As String
    Get
Dim instance As MRWrapper
Dim value As String

value = instance.ErrorMessage

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


ErrorNumber Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ErrorNumber Property
The error number, equates to New Value error numbers

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ErrorNumber { get; }
Public ReadOnly Property ErrorNumber As Integer
    Get
Dim instance As MRWrapper
Dim value As Integer

value = instance.ErrorNumber

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


IsOk Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::IsOk Property
Is an error present

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsOk { get; }
Public ReadOnly Property IsOk As Boolean
    Get
Dim instance As MRWrapper
Dim value As Boolean

value = instance.IsOk

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


LastResult Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::LastResult Property
The last error result

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public static MRWrapper LastResult { get; internal set; }
Public Shared Property LastResult As MRWrapper
    Get
    Friend Set
Dim value As MRWrapper

value = MRWrapper.LastResult

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


ThrowErrors Property

Visual Basic Usage

CB Com Devkit
MRWrapper..::ThrowErrors Property
This macro result errors are thrown

Namespace: Decisioneering.CB.CBCOMDevKit
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As MRWrapper
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

See Also

MRWrapper Class
Decisioneering.CB.CBCOMDevKit Namespace


Decisioneering.CB.CBCOMDevKit.DataSelector Namespace

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace
DataSelector namespace provides autodetection of block of data

Types

All Types | Classes | Enumerations
Name | Description
DataSelector | DataSelector class provides COM interface for testing of autodetection of block of data.
OptDataOrientation | OptDataOrientation enum is used to define the orientation of the detected block


DataSelector Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
DataSelector Class
DataSelector class provides COM interface for testing of autodetection of block of data.

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class DataSelector
Public Class DataSelector
Dim instance As DataSelector

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataSelector()()()() | Default constructor
AutoDetect(Range, Boolean) | AutoDetect will start the autodetection process
DataOrientation | Orientation of the detected range
DetectedRange | Acces to detected range
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HasLeftHeader | HasLeftHeader is true if a detected range has left header
HasTopHeader | HasTopHeader is true if a detected range has top header
NumberOfDataPoints | Return the number of data points in detected range (series with no data are ignored)
NumberOfDataSeries | Return the number of data series in detected range
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.DataSelector..::..DataSelector

See Also

Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector Constructor

Visual Basic Usage

CB Com Devkit
DataSelector Constructor
Default constructor

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public DataSelector()
Public Sub New
Dim instance As New DataSelector()

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector Methods

Visual Basic Usage

CB Com Devkit
DataSelector Methods

The DataSelector type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AutoDetect(Range, Boolean) | AutoDetect will start the autodetection process
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


AutoDetect Method

Visual Basic Usage

CB Com Devkit
DataSelector..::AutoDetect Method
AutoDetect will start the autodetection process

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void AutoDetect(
    Range initialRange,
    bool allowDiscontiguousRanges
)
Public Sub AutoDetect ( _
    initialRange As Range, _
    allowDiscontiguousRanges As Boolean _
)
Dim instance As DataSelector
Dim initialRange As Range
Dim allowDiscontiguousRanges As Boolean

instance.AutoDetect(initialRange, allowDiscontiguousRanges)

Parameters

initialRange
Range
initial range from which auto detection starts
allowDiscontiguousRanges
Boolean
allow discontiguous ranges (a set of ranges) in initialRange

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataSelector Properties

Visual Basic Usage

CB Com Devkit
DataSelector Properties

The DataSelector type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataOrientation | Orientation of the detected range
DetectedRange | Acces to detected range
HasLeftHeader | HasLeftHeader is true if a detected range has left header
HasTopHeader | HasTopHeader is true if a detected range has top header
NumberOfDataPoints | Return the number of data points in detected range (series with no data are ignored)
NumberOfDataSeries | Return the number of data series in detected range

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DataOrientation Property

Visual Basic Usage

CB Com Devkit
DataSelector..::DataOrientation Property
Orientation of the detected range

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptDataOrientation DataOrientation { get; }
Public ReadOnly Property DataOrientation As OptDataOrientation
    Get
Dim instance As DataSelector
Dim value As OptDataOrientation

value = instance.DataOrientation

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


DetectedRange Property

Visual Basic Usage

CB Com Devkit
DataSelector..::DetectedRange Property
Acces to detected range

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range DetectedRange { get; }
Public ReadOnly Property DetectedRange As Range
    Get
Dim instance As DataSelector
Dim value As Range

value = instance.DetectedRange

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


HasLeftHeader Property

Visual Basic Usage

CB Com Devkit
DataSelector..::HasLeftHeader Property
HasLeftHeader is true if a detected range has left header

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasLeftHeader { get; }
Public ReadOnly Property HasLeftHeader As Boolean
    Get
Dim instance As DataSelector
Dim value As Boolean

value = instance.HasLeftHeader

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


HasTopHeader Property

Visual Basic Usage

CB Com Devkit
DataSelector..::HasTopHeader Property
HasTopHeader is true if a detected range has top header

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasTopHeader { get; }
Public ReadOnly Property HasTopHeader As Boolean
    Get
Dim instance As DataSelector
Dim value As Boolean

value = instance.HasTopHeader

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


NumberOfDataPoints Property

Visual Basic Usage

CB Com Devkit
DataSelector..::NumberOfDataPoints Property
Return the number of data points in detected range (series with no data are ignored)

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfDataPoints { get; }
Public ReadOnly Property NumberOfDataPoints As Integer
    Get
Dim instance As DataSelector
Dim value As Integer

value = instance.NumberOfDataPoints

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


NumberOfDataSeries Property

Visual Basic Usage

CB Com Devkit
DataSelector..::NumberOfDataSeries Property
Return the number of data series in detected range

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfDataSeries { get; }
Public ReadOnly Property NumberOfDataSeries As Integer
    Get
Dim instance As DataSelector
Dim value As Integer

value = instance.NumberOfDataSeries

See Also

DataSelector Class
Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


OptDataOrientation Enumeration

Visual Basic Usage

CB Com Devkit
OptDataOrientation Enumeration
OptDataOrientation enum is used to define the orientation of the detected block

Namespace: Decisioneering.CB.CBCOMDevKit.DataSelector
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptDataOrientation
Public Enumeration OptDataOrientation
Dim instance As OptDataOrientation

Members

Member | Description
OptDataOrientationUnknown | Orientation is unknown
OptDataInRows | Detected data block is oriented in rows
OptDataInColumns | Detected data block is in columns

See Also

Decisioneering.CB.CBCOMDevKit.DataSelector Namespace


Decisioneering.CB.CBCOMDevKit.Optimization Namespace

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit.Optimization Namespace
OptQuest COM and .NET Development Kit Namespace

Types

All Types | Classes | Interfaces | Enumerations | Delegates
Name | Description
OptRuntime..::..AfterSimulationEventHandler | After simulation event handler.
ResultsWindow..::..BestSolutionChartType | Chart type within the Best Solution view enum
BooleanOption | Optimization Option boolean
ConEnumerator | Constraint var enumerator class
Constraint | Constraint object. Access constraint properties.
DecEnumerator | Decision var enumerator class
Decision | Decision variable wrapper
DecVarValueType | Optimization values types
OptRuntime..::..EfficientFrontierEventHandler | Efficient Frontier Event handler.
ResultsWindow..::..GridType | The Grid type enum
IVarEnumerator | Base var enumerator interface
Objective | Objective class is responsible for handling all objective related operations.
ObjEnumerator | Objective var enumerator class
ObjReqBase | Base class for objectives and requirements
OptConditionType | Condition type
OptConstraintType | Constraint types
OptCounters | The set of Optimization counters.
OptDecisionType | Enumeration of possible decision variable types
OptEFFBoundType | Efficient Frontier testing type
OptEfficientFrontier | Efficient Frontier DevKit access
OptEFFSelectionType | Efficient Frontier testing type
OptEFFTestType | Efficient Frontier testing type
OptRuntime..::..OptEventHandler | Optimization Event handler.
OptimizationEvents | Optimization Events raised during an Optimization execution.
OptimizationState | The run state of the Optimization.
OptRuntime..::..OptItersEventHandler | Optimization Iterations Event handler.
OptMoreLessCondition | More/less condition type.
OptObjectiveType | Objective type
OptOptimizationType | Optimization type enum
OptOptions | COM wrapper for optimization options
OptRunForType | Run for type enum
OptRuntime | An OptRuntime object is used to start, stop and monitor optimizations. After an optimization is complete results may be obtained by calling methods such as OptRuntime.GetBestSolution. Additionally OptRuntime.GetSolutionList may be used to determine the solutions used in the course of the optimization. For Efficient Frontier optimizations, use the OptRuntime.EfficientFrontier property to access the results for specific test points.
OptSetDecVars | Set decision variable cell values type enum
OptSetup | Optimization Setup / Definition Access optimization variables, add, modify and delete variables and options for running optimizations
OptShowChartType | Show chart type enum
OptSolution | Represents a single solution in an Optimization. A solution is a set of values for Decision Variables and their associated result values. Result values may be obtained for: Objectives, Requirements, Constraints.
OptSolutionEnumerator | OptSolution enumerator class. This class is used to enumerate a list of solutions generated by an Optimization.
OptSupportedStatistics | Supported Statistics
OptVar | Base class for Optimization variable objects
OptVarSolutionFilter | The Optimization variable statistics filter. The statistics filter limits the set of solutions that affect the Optimization variable statistics.
OptVarStatistics | Optimization variable statistics. These summarize the statistics for a single optimization variable in the current Optimization. They are based upon the selected statistics filter.
ReqEnumerator | Requirement var enumerator class
Requirement | Requirement class is responsible for handling all requirement related operations.
ResultsWindow | The OptQuest Results Window
ResultsWindow..::..ResultsWindowViewType | Window view enum
RuntimeEfficientFrontier | Optimization runtime information for Efficient Frontier. Efficient Frontier allows users to create a variable list of constraint and requirement RHS (right hand side) values using a list of test points.
SolutionListSort | Possible sort orders for solution lists
SolutionStatus | The status of the solution, including the state of the simulation if run.
SolutionValueType | Type of value for a solution equation variable
TerminationReason | Optimization Termination reasons
TestPointInfo | Optimization Test Point Information for an Efficient frontier. This information summarizes the results for a single test point.
VarEnumerator | Base var enumerator class


BooleanOption Enumeration

Visual Basic Usage

CB Com Devkit
BooleanOption Enumeration
Optimization Option boolean

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum BooleanOption
Public Enumeration BooleanOption
Dim instance As BooleanOption

Members

Member | Description
Default | Set option to default
True | Set option to True
False | Set option to False

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ConEnumerator Class
Constraint var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ConEnumerator : VarEnumerator
Public Class ConEnumerator _
    Inherits VarEnumerator
Dim instance As ConEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdvancedView | Get / Set the current Constraint view preference
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
ValidateView()()()() | Check if all constraints are simple and if the constraint editor can be rendered in simple view mode

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ConEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator Methods

Visual Basic Usage

CB Com Devkit
ConEnumerator Methods

The ConEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
ValidateView()()()() | Check if all constraints are simple and if the constraint editor can be rendered in simple view mode

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Delete Method

Visual Basic Usage

CB Com Devkit
ConEnumerator..::Delete Method
Delete the object at specified index

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Delete(
    int index
)
Public Function Delete ( _
    index As Integer _
) As Boolean
Dim instance As ConEnumerator
Dim index As Integer
Dim returnValue As Boolean

returnValue = instance.Delete(index)

Parameters

index
Int32
index to use

Return Value

Was object deleted

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
ConEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As ConEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ValidateView Method

Visual Basic Usage

CB Com Devkit
ConEnumerator..::ValidateView Method
Check if all constraints are simple and if the constraint editor can be rendered in simple view mode

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ValidateView()
Public Function ValidateView As Boolean
Dim instance As ConEnumerator
Dim returnValue As Boolean

returnValue = instance.ValidateView()

Return Value

Whether constraints are simple

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConEnumerator Properties

Visual Basic Usage

CB Com Devkit
ConEnumerator Properties

The ConEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdvancedView | Get / Set the current Constraint view preference
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AdvancedView Property

Visual Basic Usage

CB Com Devkit
ConEnumerator..::AdvancedView Property
Get / Set the current Constraint view preference

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool AdvancedView { get; set; }
Public Property AdvancedView As Boolean
    Get
    Set
Dim instance As ConEnumerator
Dim value As Boolean

value = instance.AdvancedView

instance.AdvancedView = value

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Current Property

Visual Basic Usage

CB Com Devkit
ConEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As ConEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Item Property

Visual Basic Usage

CB Com Devkit
ConEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Constraint this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Constraint
    Get
Dim instance As ConEnumerator
Dim index As Integer
Dim value As Constraint

value = instance(index)

Parameters

index
Int32

See Also

ConEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraint Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
Constraint Class
Constraint object. Access constraint properties.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class Constraint : OptVar
Public Class Constraint _
    Inherits OptVar
Dim instance As Constraint

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment (Inherited from OptVar.)
ConstraintType | Is constraint linear
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equation | Constraint equation
Exclude | Is var excluded (Inherited from OptVar.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..Constraint

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraint Methods

Visual Basic Usage

CB Com Devkit
Constraint Methods

The Constraint type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Constraint Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraint Properties

Visual Basic Usage

CB Com Devkit
Constraint Properties

The Constraint type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment (Inherited from OptVar.)
ConstraintType | Is constraint linear
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equation | Constraint equation
Exclude | Is var excluded (Inherited from OptVar.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)

See Also

Constraint Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConstraintType Property

Visual Basic Usage

CB Com Devkit
Constraint..::ConstraintType Property
Is constraint linear

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptConstraintType ConstraintType { get; }
Public ReadOnly Property ConstraintType As OptConstraintType
    Get
Dim instance As Constraint
Dim value As OptConstraintType

value = instance.ConstraintType

See Also

Constraint Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Equation Property

Visual Basic Usage

CB Com Devkit
Constraint..::Equation Property
Constraint equation

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Equation { get; set; }
Public Property Equation As String
    Get
    Set
Dim instance As Constraint
Dim value As String

value = instance.Equation

instance.Equation = value

See Also

Constraint Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
DecEnumerator Class
Decision var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class DecEnumerator : VarEnumerator
Public Class DecEnumerator _
    Inherits VarEnumerator
Dim instance As DecEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..DecEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator Methods

Visual Basic Usage

CB Com Devkit
DecEnumerator Methods

The DecEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
DecEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As DecEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecEnumerator Properties

Visual Basic Usage

CB Com Devkit
DecEnumerator Properties

The DecEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Current Property

Visual Basic Usage

CB Com Devkit
DecEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As DecEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Item Property

Visual Basic Usage

CB Com Devkit
DecEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Decision this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Decision
    Get
Dim instance As DecEnumerator
Dim index As Integer
Dim value As Decision

value = instance(index)

Parameters

index
Int32

See Also

DecEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
Decision Class
Decision variable wrapper

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class Decision : CBVar
Public Class Decision _
    Inherits CBVar
Dim instance As Decision

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Decision()()()() | Default Decision variable constructor
Decision(String, String) | Decision variable constructor using cell address
BaseCase | Decision variable step
CustomValues | A set of possible values for this Decision Variable.
DecisionType | Decision variable type
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Frozen | Decision variable frozen state
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LowerBound | Decision variable lower bound
ObjectiveSensitivity | Sensitivity of the Objective to this Decision Variable
OptimizationStatistics | Get the statistics for this Decision Variable. Statistics are based upon the current OptRuntime solution filter.
SetCustomValues(Object) | Update custom values array
SetDecisionType(OptDecisionType, Double, Object) | Set to new type
Step | Decision variable step
ToString()()()() | Get variable as string (Overrides CBVarToString()()()().)
UpperBound | Decision variable upper bound

Inheritance Hierarchy

System..::..Object
CBVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..Decision

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Constructor

Visual Basic Usage

CB Com Devkit
Decision Constructor

Overload List

Name | Description
Decision()()()() | Default Decision variable constructor
Decision(String, String) | Decision variable constructor using cell address

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Constructor

Visual Basic Usage

CB Com Devkit
Decision Constructor
Default Decision variable constructor

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Decision()
Public Sub New
Dim instance As New Decision()

See Also

Decision Class
Decision Overload
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Constructor (String, String)

Visual Basic Usage

CB Com Devkit
Decision Constructor (String, String)
Decision variable constructor using cell address

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Decision(
    string aCellAddress,
    string aName
)
Public Sub New ( _
    aCellAddress As String, _
    aName As String _
)
Dim aCellAddress As String
Dim aName As String

Dim instance As New Decision(aCellAddress, _
    aName)

Parameters

aCellAddress
String
cell address
aName
String
Decision variable name

See Also

Decision Class
Decision Overload
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Methods

Visual Basic Usage

CB Com Devkit
Decision Methods

The Decision type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetCustomValues(Object) | Update custom values array
SetDecisionType(OptDecisionType, Double, Object) | Set to new type
ToString()()()() | Get variable as string (Overrides CBVarToString()()()().)

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SetCustomValues Method

Visual Basic Usage

CB Com Devkit
Decision..::SetCustomValues Method
Update custom values array

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetCustomValues(
    Object CustomValues
)
Public Function SetCustomValues ( _
    CustomValues As Object _
) As Boolean
Dim instance As Decision
Dim CustomValues As Object
Dim returnValue As Boolean

returnValue = instance.SetCustomValues(CustomValues)

Parameters

CustomValues
Object
Double array of custom values

Return Value

true if successful

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SetDecisionType Method

Visual Basic Usage

CB Com Devkit
Decision..::SetDecisionType Method
Set to new type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetDecisionType(
    OptDecisionType DecisionType,
    double Step,
    Object CustomValues
)
Public Function SetDecisionType ( _
    DecisionType As OptDecisionType, _
    Step As Double, _
    CustomValues As Object _
) As Boolean
Dim instance As Decision
Dim DecisionType As OptDecisionType
Dim Step As Double
Dim CustomValues As Object
Dim returnValue As Boolean

returnValue = instance.SetDecisionType(DecisionType, _
    Step, CustomValues)

Parameters

DecisionType
OptDecisionType
The type of decision variable
Step
Double
the step value
CustomValues
Object
any custom values

Return Value

true if successful

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
Decision..::ToString Method
Get variable as string

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As Decision
Dim returnValue As String

returnValue = instance.ToString()

Return Value

string description

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decision Properties

Visual Basic Usage

CB Com Devkit
Decision Properties

The Decision type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BaseCase | Decision variable step
CustomValues | A set of possible values for this Decision Variable.
DecisionType | Decision variable type
Frozen | Decision variable frozen state
LowerBound | Decision variable lower bound
ObjectiveSensitivity | Sensitivity of the Objective to this Decision Variable
OptimizationStatistics | Get the statistics for this Decision Variable. Statistics are based upon the current OptRuntime solution filter.
Step | Decision variable step
UpperBound | Decision variable upper bound

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BaseCase Property

Visual Basic Usage

CB Com Devkit
Decision..::BaseCase Property
Decision variable step

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double BaseCase { get; set; }
Public Property BaseCase As Double
    Get
    Set
Dim instance As Decision
Dim value As Double

value = instance.BaseCase

instance.BaseCase = value

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


CustomValues Property

Visual Basic Usage

CB Com Devkit
Decision..::CustomValues Property
A set of possible values for this Decision Variable.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double[] CustomValues { get; }
Public ReadOnly Property CustomValues As Double()
    Get
Dim instance As Decision
Dim value As Double()

value = instance.CustomValues

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecisionType Property

Visual Basic Usage

CB Com Devkit
Decision..::DecisionType Property
Decision variable type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptDecisionType DecisionType { get; }
Public ReadOnly Property DecisionType As OptDecisionType
    Get
Dim instance As Decision
Dim value As OptDecisionType

value = instance.DecisionType

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Frozen Property

Visual Basic Usage

CB Com Devkit
Decision..::Frozen Property
Decision variable frozen state

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Frozen { get; set; }
Public Property Frozen As Boolean
    Get
    Set
Dim instance As Decision
Dim value As Boolean

value = instance.Frozen

instance.Frozen = value

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


LowerBound Property

Visual Basic Usage

CB Com Devkit
Decision..::LowerBound Property
Decision variable lower bound

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double LowerBound { get; set; }
Public Property LowerBound As Double
    Get
    Set
Dim instance As Decision
Dim value As Double

value = instance.LowerBound

instance.LowerBound = value

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjectiveSensitivity Property

Visual Basic Usage

CB Com Devkit
Decision..::ObjectiveSensitivity Property
Sensitivity of the Objective to this Decision Variable

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ObjectiveSensitivity { get; }
Public ReadOnly Property ObjectiveSensitivity As Double
    Get
Dim instance As Decision
Dim value As Double

value = instance.ObjectiveSensitivity

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationStatistics Property

Visual Basic Usage

CB Com Devkit
Decision..::OptimizationStatistics Property
Get the statistics for this Decision Variable. Statistics are based upon the current OptRuntime solution filter.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptVarStatistics OptimizationStatistics { get; }
Public ReadOnly Property OptimizationStatistics As OptVarStatistics
    Get
Dim instance As Decision
Dim value As OptVarStatistics

value = instance.OptimizationStatistics

Return Value

Decision Variable statistics for this Optimization.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Step Property

Visual Basic Usage

CB Com Devkit
Decision..::Step Property
Decision variable step

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Step { get; set; }
Public Property Step As Double
    Get
    Set
Dim instance As Decision
Dim value As Double

value = instance.Step

instance.Step = value

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


UpperBound Property

Visual Basic Usage

CB Com Devkit
Decision..::UpperBound Property
Decision variable upper bound

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double UpperBound { get; set; }
Public Property UpperBound As Double
    Get
    Set
Dim instance As Decision
Dim value As Double

value = instance.UpperBound

instance.UpperBound = value

See Also

Decision Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DecVarValueType Enumeration

Visual Basic Usage

CB Com Devkit
DecVarValueType Enumeration
Optimization values types

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum DecVarValueType
Public Enumeration DecVarValueType
Dim instance As DecVarValueType

Members

Member | Description
OriginalValue | Pre-optimization value
CurrentValue | Current solution value
BestValue | Best solution value

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IVarEnumerator Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
IVarEnumerator Interface
Base var enumerator interface

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface IVarEnumerator : IEnumerable,
    IEnumerator
Public Interface IVarEnumerator _
    Inherits IEnumerable, IEnumerator
Dim instance As IVarEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of this type.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IVarEnumerator Methods

Visual Basic Usage

CB Com Devkit
IVarEnumerator Methods

The IVarEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

IVarEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
IVarEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
bool Reload()
Function Reload As Boolean
Dim instance As IVarEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Was enumeration successfully reloaded

See Also

IVarEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IVarEnumerator Properties

Visual Basic Usage

CB Com Devkit
IVarEnumerator Properties

The IVarEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of this type.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IVarEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Count Property

Visual Basic Usage

CB Com Devkit
IVarEnumerator..::Count Property
Returns the count of variables of this type.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
int Count { get; }
ReadOnly Property Count As Integer
    Get
Dim instance As IVarEnumerator
Dim value As Integer

value = instance.Count

See Also

IVarEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
Objective Class
Objective class is responsible for handling all objective related operations.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class Objective : ObjReqBase
Public Class Objective _
    Inherits ObjReqBase
Dim instance As Objective

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AbbreviatedName | Objective abbreviated name in a string form (note it doesn't include the forecast)
Comment | Var comment (Inherited from OptVar.)
Condition | Objective condition, one of the values defined in OptConditionType enumeration For objectives, Condition is used only for Probability statistic and it represents the numeric representation of the current objective condition. For example, the objective "Maximize the Probability that Forecast1 is between 100.00 and 200.00" has a Condition equal to OptConditionType.Between.
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equation | The Objective equation as a read-only value.
Exclude | Is var excluded (Inherited from OptVar.)
Forecast | Get / Set the Objective forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.
FullAbbreviatedName | Objective full abbreviated name in a string form, this includes the forecast
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ObjectiveType | Objective type defined with one of the values defined in OptObjectiveType enumeration.
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)
Statistic | Access to objective Statistic. This is a statictic from the Forecast value used in the Objective equation.
StatisticValue1 | StatisticValue1 provides access to the first statistic value for the objective. It is used only for Percentile, Probability and Certainty statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the objective "Maximize the 95% Percentile of Forecast1" has StatisticValue1 equal to 95. For Probability it represents the lower boundary of the probability range. Note that if objective Condition is set to LessThan, the StatisticValue1 will return back value of -Infinity (-1.11E+307) which is effectively the lower probability boundary. For example, the objective "Maximize the Probability that Forecast1 is less than 100.00" has StatisticValue1 equal to 100 (and StatisticValue2 is +Infinity). For Certainty it also represents the lower boundary of the specified probability range. For example, the objective "Maximize the Certainty of Forecast1 being 10.00 to 50.00" has StatisticValue1 equal to 10 and StatisticValue2 equal to 50.
StatisticValue2 | StatisticValue2 provides access to the second statistic value for the objective. It is used only for Probability and Certainty statistics. For Probability it represents the upper boundary of the specified probability range. Note that if objective Condition is set to GreaterThan, the StatisticValue2 will return back value of +Infinity (1.11E+307). For example, the objective "Set Target for Probability that Forecast1 is between 1.00 and 2.00 to 95%" has StatisticValue2 equal to 2. For Certainty it also represents the upper boundary of the specified probability range. For example, the objective "Set Target for Certainty of Forecast1 being 1000.00 to 2000.00 to 91%" has StatisticValue2 of 2000.
TargetValue | Objective Target value is available through the TargetValue property. It is used only when objective type is OptObjectiveType.SetTarget. For example the objective "Set Target for Mode of Forecast1 to 100.00" has TargetValue equal to 100.00.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate the objective, sets the error code if not valid

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjReqBase
Decisioneering.CB.CBCOMDevKit.Optimization..::..Objective

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective Methods

Visual Basic Usage

CB Com Devkit
Objective Methods

The Objective type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate the objective, sets the error code if not valid

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
Objective..::Validate Method
Validate the objective, sets the error code if not valid

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As Objective
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

True if OK, false if requirent is not valid

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objective Properties

Visual Basic Usage

CB Com Devkit
Objective Properties

The Objective type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AbbreviatedName | Objective abbreviated name in a string form (note it doesn't include the forecast)
Comment | Var comment (Inherited from OptVar.)
Condition | Objective condition, one of the values defined in OptConditionType enumeration For objectives, Condition is used only for Probability statistic and it represents the numeric representation of the current objective condition. For example, the objective "Maximize the Probability that Forecast1 is between 100.00 and 200.00" has a Condition equal to OptConditionType.Between.
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equation | The Objective equation as a read-only value.
Exclude | Is var excluded (Inherited from OptVar.)
Forecast | Get / Set the Objective forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.
FullAbbreviatedName | Objective full abbreviated name in a string form, this includes the forecast
ObjectiveType | Objective type defined with one of the values defined in OptObjectiveType enumeration.
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)
Statistic | Access to objective Statistic. This is a statictic from the Forecast value used in the Objective equation.
StatisticValue1 | StatisticValue1 provides access to the first statistic value for the objective. It is used only for Percentile, Probability and Certainty statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the objective "Maximize the 95% Percentile of Forecast1" has StatisticValue1 equal to 95. For Probability it represents the lower boundary of the probability range. Note that if objective Condition is set to LessThan, the StatisticValue1 will return back value of -Infinity (-1.11E+307) which is effectively the lower probability boundary. For example, the objective "Maximize the Probability that Forecast1 is less than 100.00" has StatisticValue1 equal to 100 (and StatisticValue2 is +Infinity). For Certainty it also represents the lower boundary of the specified probability range. For example, the objective "Maximize the Certainty of Forecast1 being 10.00 to 50.00" has StatisticValue1 equal to 10 and StatisticValue2 equal to 50.
StatisticValue2 | StatisticValue2 provides access to the second statistic value for the objective. It is used only for Probability and Certainty statistics. For Probability it represents the upper boundary of the specified probability range. Note that if objective Condition is set to GreaterThan, the StatisticValue2 will return back value of +Infinity (1.11E+307). For example, the objective "Set Target for Probability that Forecast1 is between 1.00 and 2.00 to 95%" has StatisticValue2 equal to 2. For Certainty it also represents the upper boundary of the specified probability range. For example, the objective "Set Target for Certainty of Forecast1 being 1000.00 to 2000.00 to 91%" has StatisticValue2 of 2000.
TargetValue | Objective Target value is available through the TargetValue property. It is used only when objective type is OptObjectiveType.SetTarget. For example the objective "Set Target for Mode of Forecast1 to 100.00" has TargetValue equal to 100.00.

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AbbreviatedName Property

Visual Basic Usage

CB Com Devkit
Objective..::AbbreviatedName Property
Objective abbreviated name in a string form (note it doesn't include the forecast)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string AbbreviatedName { get; }
Public ReadOnly Property AbbreviatedName As String
    Get
Dim instance As Objective
Dim value As String

value = instance.AbbreviatedName

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Condition Property

Visual Basic Usage

CB Com Devkit
Objective..::Condition Property
Objective condition, one of the values defined in OptConditionType enumeration For objectives, Condition is used only for Probability statistic and it represents the numeric representation of the current objective condition. For example, the objective "Maximize the Probability that Forecast1 is between 100.00 and 200.00" has a Condition equal to OptConditionType.Between.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptConditionType Condition { get; set; }
Public Property Condition As OptConditionType
    Get
    Set
Dim instance As Objective
Dim value As OptConditionType

value = instance.Condition

instance.Condition = value

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Equation Property

Visual Basic Usage

CB Com Devkit
Objective..::Equation Property
The Objective equation as a read-only value.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Equation { get; protected set; }
Public Property Equation As String
    Get
    Protected Set
Dim instance As Objective
Dim value As String

value = instance.Equation

instance.Equation = value

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Forecast Property

Visual Basic Usage

CB Com Devkit
Objective..::Forecast Property
Get / Set the Objective forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Forecast { get; set; }
Public Property Forecast As Range
    Get
    Set
Dim instance As Objective
Dim value As Range

value = instance.Forecast

instance.Forecast = value

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


FullAbbreviatedName Property

Visual Basic Usage

CB Com Devkit
Objective..::FullAbbreviatedName Property
Objective full abbreviated name in a string form, this includes the forecast

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string FullAbbreviatedName { get; }
Public ReadOnly Property FullAbbreviatedName As String
    Get
Dim instance As Objective
Dim value As String

value = instance.FullAbbreviatedName

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjectiveType Property

Visual Basic Usage

CB Com Devkit
Objective..::ObjectiveType Property
Objective type defined with one of the values defined in OptObjectiveType enumeration.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptObjectiveType ObjectiveType { get; set; }
Public Property ObjectiveType As OptObjectiveType
    Get
    Set
Dim instance As Objective
Dim value As OptObjectiveType

value = instance.ObjectiveType

instance.ObjectiveType = value

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Statistic Property

Visual Basic Usage

CB Com Devkit
Objective..::Statistic Property
Access to objective Statistic. This is a statictic from the Forecast value used in the Objective equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSupportedStatistics Statistic { get; set; }
Public Property Statistic As OptSupportedStatistics
    Get
    Set
Dim instance As Objective
Dim value As OptSupportedStatistics

value = instance.Statistic

instance.Statistic = value

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StatisticValue1 Property

Visual Basic Usage

CB Com Devkit
Objective..::StatisticValue1 Property
StatisticValue1 provides access to the first statistic value for the objective. It is used only for Percentile, Probability and Certainty statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the objective "Maximize the 95% Percentile of Forecast1" has StatisticValue1 equal to 95. For Probability it represents the lower boundary of the probability range. Note that if objective Condition is set to LessThan, the StatisticValue1 will return back value of -Infinity (-1.11E+307) which is effectively the lower probability boundary. For example, the objective "Maximize the Probability that Forecast1 is less than 100.00" has StatisticValue1 equal to 100 (and StatisticValue2 is +Infinity). For Certainty it also represents the lower boundary of the specified probability range. For example, the objective "Maximize the Certainty of Forecast1 being 10.00 to 50.00" has StatisticValue1 equal to 10 and StatisticValue2 equal to 50.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StatisticValue1 { get; set; }
Public Property StatisticValue1 As Double
    Get
    Set
Dim instance As Objective
Dim value As Double

value = instance.StatisticValue1

instance.StatisticValue1 = value

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StatisticValue2 Property

Visual Basic Usage

CB Com Devkit
Objective..::StatisticValue2 Property
StatisticValue2 provides access to the second statistic value for the objective. It is used only for Probability and Certainty statistics. For Probability it represents the upper boundary of the specified probability range. Note that if objective Condition is set to GreaterThan, the StatisticValue2 will return back value of +Infinity (1.11E+307). For example, the objective "Set Target for Probability that Forecast1 is between 1.00 and 2.00 to 95%" has StatisticValue2 equal to 2. For Certainty it also represents the upper boundary of the specified probability range. For example, the objective "Set Target for Certainty of Forecast1 being 1000.00 to 2000.00 to 91%" has StatisticValue2 of 2000.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StatisticValue2 { get; set; }
Public Property StatisticValue2 As Double
    Get
    Set
Dim instance As Objective
Dim value As Double

value = instance.StatisticValue2

instance.StatisticValue2 = value

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TargetValue Property

Visual Basic Usage

CB Com Devkit
Objective..::TargetValue Property
Objective Target value is available through the TargetValue property. It is used only when objective type is OptObjectiveType.SetTarget. For example the objective "Set Target for Mode of Forecast1 to 100.00" has TargetValue equal to 100.00.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TargetValue { get; set; }
Public Property TargetValue As Double
    Get
    Set
Dim instance As Objective
Dim value As Double

value = instance.TargetValue

instance.TargetValue = value

See Also

Objective Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ObjEnumerator Class
Objective var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ObjEnumerator : VarEnumerator
Public Class ObjEnumerator _
    Inherits VarEnumerator
Dim instance As ObjEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator Methods

Visual Basic Usage

CB Com Devkit
ObjEnumerator Methods

The ObjEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Delete Method

Visual Basic Usage

CB Com Devkit
ObjEnumerator..::Delete Method
Delete the object at specified index

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Delete(
    int index
)
Public Function Delete ( _
    index As Integer _
) As Boolean
Dim instance As ObjEnumerator
Dim index As Integer
Dim returnValue As Boolean

returnValue = instance.Delete(index)

Parameters

index
Int32
index to use

Return Value

Was object deleted

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
ObjEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As ObjEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjEnumerator Properties

Visual Basic Usage

CB Com Devkit
ObjEnumerator Properties

The ObjEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Current Property

Visual Basic Usage

CB Com Devkit
ObjEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As ObjEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Item Property

Visual Basic Usage

CB Com Devkit
ObjEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Objective this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Objective
    Get
Dim instance As ObjEnumerator
Dim index As Integer
Dim value As Objective

value = instance(index)

Parameters

index
Int32

See Also

ObjEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ObjReqBase Class
Base class for objectives and requirements

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ObjReqBase : OptVar
Public Class ObjReqBase _
    Inherits OptVar
Dim instance As ObjReqBase

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ObjReqBase(IOptVar) | Create a base Objective or Requirement object.
Comment | Var comment (Inherited from OptVar.)
ConvertToStatistic(OptSupportedStatistics, Double, Double, ConditionType, String%) | Converts from OptSupportedStatistics statistic to the Statistic class. Uses specified parameters when creating the Statistic object.
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exclude | Is var excluded (Inherited from OptVar.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjReqBase
Decisioneering.CB.CBCOMDevKit.Optimization..::..Objective
Decisioneering.CB.CBCOMDevKit.Optimization..::..Requirement

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase Constructor

Visual Basic Usage

CB Com Devkit
ObjReqBase Constructor
Create a base Objective or Requirement object.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ObjReqBase(
    IOptVar optvar
)
Public Sub New ( _
    optvar As IOptVar _
)
Dim optvar As IOptVar

Dim instance As New ObjReqBase(optvar)

Parameters

optvar
IOptVar
the interface to an object store optimization variable

See Also

ObjReqBase Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase Methods

Visual Basic Usage

CB Com Devkit
ObjReqBase Methods

The ObjReqBase type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ConvertToStatistic(OptSupportedStatistics, Double, Double, ConditionType, String%) | Converts from OptSupportedStatistics statistic to the Statistic class. Uses specified parameters when creating the Statistic object.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjReqBase Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConvertToStatistic Method

Visual Basic Usage

CB Com Devkit
ObjReqBase..::ConvertToStatistic Method
Converts from OptSupportedStatistics statistic to the Statistic class. Uses specified parameters when creating the Statistic object.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public static Statistic ConvertToStatistic(
    OptSupportedStatistics stats,
    double value1,
    double value2,
    ConditionType condition,
    out string advancedStat
)
Public Shared Function ConvertToStatistic ( _
    stats As OptSupportedStatistics, _
    value1 As Double, _
    value2 As Double, _
    condition As ConditionType, _
    <OutAttribute> ByRef advancedStat As String _
) As Statistic
Dim stats As OptSupportedStatistics
Dim value1 As Double
Dim value2 As Double
Dim condition As ConditionType
Dim advancedStat As String
Dim returnValue As Statistic

returnValue = ObjReqBase.ConvertToStatistic(stats, _
    value1, value2, condition, advancedStat)

Parameters

stats
OptSupportedStatistics
OptSupportedStatistics statistic
value1
Double
First statistic value
value2
Double
Second statistic value
condition
ConditionType
Objectiv/requirement condition
advancedStat
String %
returned AdvancedStat indicator

Return Value

Newly created Statistic object

See Also

ObjReqBase Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ObjReqBase Properties

Visual Basic Usage

CB Com Devkit
ObjReqBase Properties

The ObjReqBase type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment (Inherited from OptVar.)
DisplayName | Var display name (Inherited from OptVar.)
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier) (Inherited from OptVar.)
Exclude | Is var excluded (Inherited from OptVar.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter. (Inherited from OptVar.)

See Also

ObjReqBase Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptConditionType Enumeration

Visual Basic Usage

CB Com Devkit
OptConditionType Enumeration
Condition type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptConditionType
Public Enumeration OptConditionType
Dim instance As OptConditionType

Members

Member | Description
None | No condition type specified.
LessThan | Less than condition.
GreaterThan | Greater than condition.
Between | Between condition.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptConstraintType Enumeration

Visual Basic Usage

CB Com Devkit
OptConstraintType Enumeration
Constraint types

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptConstraintType
Public Enumeration OptConstraintType
Dim instance As OptConstraintType

Members

Member | Description
None | uknown type due to invalid equation
Linear | linear constraint
NonLinear | non-linear constraint
Constant | constant constraint

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptCounters Class
The set of Optimization counters.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptCounters
Public Class OptCounters
Dim instance As OptCounters

Members

All Members | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AverageSimulationSecs | Simulation iteration count
EfficientFrontierCompletedCount | Efficient Frontier Test Points completion count
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FeasibleSolutionCount | Optimization feasible solution count
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InfeasibleNonLinearCount | Optimization infeasible due to non-linear constraint solution count
InfeasibleRequirementCount | Optimization infeasible due to requirement solution count
InfeasibleSolutionCount | Optimization infeasible solution count
IterationCount | Optimization iteration count (also number of solutions count)
IterationsSinceNewBestSolution | Iterations since last new best solution, kept if optimization is iteration limited
NewBestSolutionFeasibleCount | Count of new best solutions that are feasible
NewBestSolutionInfeasibleCount | Count of new best solutions that are infeasible
OptimizationStartTime | Start Date/Time of the optimization
SimulationCount | Simulations executed count
StoppedOnCompleteCount | Simulations stopped on completion count
StoppedOnErrorCount | Simulations stopped on error count
StoppedOnInfeasibleConstraintCount | Simulations not run count
StoppedOnObjectiveLowConfidenceCount | Simulations stopped on objective low-confidence count
StoppedOnPrecisionCount | Simulations stopped on precision control count
TimeSinceNewBestSolutionSecs | Time since last new best solution, kept if optimization is time limited
ToString()()()() | Gets the counter statistics as string. (Overrides Object..::..ToString()()()().)
TotalOptimizationSecs | Total Optimization secs
TotalSimulationSecs | Total Simulation seconds

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptCounters

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters Fields

Visual Basic Usage

CB Com Devkit
OptCounters Fields

The OptCounters type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AverageSimulationSecs | Simulation iteration count
EfficientFrontierCompletedCount | Efficient Frontier Test Points completion count
FeasibleSolutionCount | Optimization feasible solution count
InfeasibleNonLinearCount | Optimization infeasible due to non-linear constraint solution count
InfeasibleRequirementCount | Optimization infeasible due to requirement solution count
InfeasibleSolutionCount | Optimization infeasible solution count
IterationCount | Optimization iteration count (also number of solutions count)
IterationsSinceNewBestSolution | Iterations since last new best solution, kept if optimization is iteration limited
NewBestSolutionFeasibleCount | Count of new best solutions that are feasible
NewBestSolutionInfeasibleCount | Count of new best solutions that are infeasible
OptimizationStartTime | Start Date/Time of the optimization
SimulationCount | Simulations executed count
StoppedOnCompleteCount | Simulations stopped on completion count
StoppedOnErrorCount | Simulations stopped on error count
StoppedOnInfeasibleConstraintCount | Simulations not run count
StoppedOnObjectiveLowConfidenceCount | Simulations stopped on objective low-confidence count
StoppedOnPrecisionCount | Simulations stopped on precision control count
TimeSinceNewBestSolutionSecs | Time since last new best solution, kept if optimization is time limited
TotalOptimizationSecs | Total Optimization secs
TotalSimulationSecs | Total Simulation seconds

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AverageSimulationSecs Field

Visual Basic Usage

CB Com Devkit
OptCounters..::AverageSimulationSecs Field
Simulation iteration count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AverageSimulationSecs
Public AverageSimulationSecs As Double
Dim instance As OptCounters
Dim value As Double

value = instance.AverageSimulationSecs

instance.AverageSimulationSecs = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


EfficientFrontierCompletedCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::EfficientFrontierCompletedCount Field
Efficient Frontier Test Points completion count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int EfficientFrontierCompletedCount
Public EfficientFrontierCompletedCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.EfficientFrontierCompletedCount

instance.EfficientFrontierCompletedCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


FeasibleSolutionCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::FeasibleSolutionCount Field
Optimization feasible solution count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int FeasibleSolutionCount
Public FeasibleSolutionCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.FeasibleSolutionCount

instance.FeasibleSolutionCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


InfeasibleNonLinearCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::InfeasibleNonLinearCount Field
Optimization infeasible due to non-linear constraint solution count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int InfeasibleNonLinearCount
Public InfeasibleNonLinearCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.InfeasibleNonLinearCount

instance.InfeasibleNonLinearCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


InfeasibleRequirementCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::InfeasibleRequirementCount Field
Optimization infeasible due to requirement solution count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int InfeasibleRequirementCount
Public InfeasibleRequirementCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.InfeasibleRequirementCount

instance.InfeasibleRequirementCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


InfeasibleSolutionCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::InfeasibleSolutionCount Field
Optimization infeasible solution count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int InfeasibleSolutionCount
Public InfeasibleSolutionCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.InfeasibleSolutionCount

instance.InfeasibleSolutionCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IterationCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::IterationCount Field
Optimization iteration count (also number of solutions count)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int IterationCount
Public IterationCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.IterationCount

instance.IterationCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IterationsSinceNewBestSolution Field

Visual Basic Usage

CB Com Devkit
OptCounters..::IterationsSinceNewBestSolution Field
Iterations since last new best solution, kept if optimization is iteration limited

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double IterationsSinceNewBestSolution
Public IterationsSinceNewBestSolution As Double
Dim instance As OptCounters
Dim value As Double

value = instance.IterationsSinceNewBestSolution

instance.IterationsSinceNewBestSolution = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


NewBestSolutionFeasibleCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::NewBestSolutionFeasibleCount Field
Count of new best solutions that are feasible

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NewBestSolutionFeasibleCount
Public NewBestSolutionFeasibleCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.NewBestSolutionFeasibleCount

instance.NewBestSolutionFeasibleCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


NewBestSolutionInfeasibleCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::NewBestSolutionInfeasibleCount Field
Count of new best solutions that are infeasible

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NewBestSolutionInfeasibleCount
Public NewBestSolutionInfeasibleCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.NewBestSolutionInfeasibleCount

instance.NewBestSolutionInfeasibleCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationStartTime Field

Visual Basic Usage

CB Com Devkit
OptCounters..::OptimizationStartTime Field
Start Date/Time of the optimization

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public DateTime OptimizationStartTime
Public OptimizationStartTime As DateTime
Dim instance As OptCounters
Dim value As DateTime

value = instance.OptimizationStartTime

instance.OptimizationStartTime = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SimulationCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::SimulationCount Field
Simulations executed count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SimulationCount
Public SimulationCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.SimulationCount

instance.SimulationCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StoppedOnCompleteCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnCompleteCount Field
Simulations stopped on completion count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnCompleteCount
Public StoppedOnCompleteCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnCompleteCount

instance.StoppedOnCompleteCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StoppedOnErrorCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnErrorCount Field
Simulations stopped on error count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnErrorCount
Public StoppedOnErrorCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnErrorCount

instance.StoppedOnErrorCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StoppedOnInfeasibleConstraintCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnInfeasibleConstraintCount Field
Simulations not run count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnInfeasibleConstraintCount
Public StoppedOnInfeasibleConstraintCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnInfeasibleConstraintCount

instance.StoppedOnInfeasibleConstraintCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StoppedOnObjectiveLowConfidenceCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnObjectiveLowConfidenceCount Field
Simulations stopped on objective low-confidence count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnObjectiveLowConfidenceCount
Public StoppedOnObjectiveLowConfidenceCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnObjectiveLowConfidenceCount

instance.StoppedOnObjectiveLowConfidenceCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StoppedOnPrecisionCount Field

Visual Basic Usage

CB Com Devkit
OptCounters..::StoppedOnPrecisionCount Field
Simulations stopped on precision control count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StoppedOnPrecisionCount
Public StoppedOnPrecisionCount As Integer
Dim instance As OptCounters
Dim value As Integer

value = instance.StoppedOnPrecisionCount

instance.StoppedOnPrecisionCount = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TimeSinceNewBestSolutionSecs Field

Visual Basic Usage

CB Com Devkit
OptCounters..::TimeSinceNewBestSolutionSecs Field
Time since last new best solution, kept if optimization is time limited

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TimeSinceNewBestSolutionSecs
Public TimeSinceNewBestSolutionSecs As Double
Dim instance As OptCounters
Dim value As Double

value = instance.TimeSinceNewBestSolutionSecs

instance.TimeSinceNewBestSolutionSecs = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TotalOptimizationSecs Field

Visual Basic Usage

CB Com Devkit
OptCounters..::TotalOptimizationSecs Field
Total Optimization secs

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TotalOptimizationSecs
Public TotalOptimizationSecs As Double
Dim instance As OptCounters
Dim value As Double

value = instance.TotalOptimizationSecs

instance.TotalOptimizationSecs = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TotalSimulationSecs Field

Visual Basic Usage

CB Com Devkit
OptCounters..::TotalSimulationSecs Field
Total Simulation seconds

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TotalSimulationSecs
Public TotalSimulationSecs As Double
Dim instance As OptCounters
Dim value As Double

value = instance.TotalSimulationSecs

instance.TotalSimulationSecs = value

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters Methods

Visual Basic Usage

CB Com Devkit
OptCounters Methods

The OptCounters type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Gets the counter statistics as string. (Overrides Object..::..ToString()()()().)

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
OptCounters..::ToString Method
Gets the counter statistics as string.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As OptCounters
Dim returnValue As String

returnValue = instance.ToString()

Return Value

Returns the counter statistics as string

See Also

OptCounters Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptDecisionType Enumeration

Visual Basic Usage

CB Com Devkit
OptDecisionType Enumeration
Enumeration of possible decision variable types

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptDecisionType
Public Enumeration OptDecisionType
Dim instance As OptDecisionType

Members

Member | Description
Continuous | a continuous range of values
Discrete | A range of values with a step
Binary | a 0 or 1 value
Category | a set unordered values
Custom | a list of values

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEFFBoundType Enumeration

Visual Basic Usage

CB Com Devkit
OptEFFBoundType Enumeration
Efficient Frontier testing type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptEFFBoundType
Public Enumeration OptEFFBoundType
Dim instance As OptEFFBoundType

Members

Member | Description
None | No Bound
Lower | Lower Bound
Upper | Upper Bound

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptEfficientFrontier Class
Efficient Frontier DevKit access

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptEfficientFrontier
Public Class OptEfficientFrontier
Dim instance As OptEfficientFrontier

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
OptEfficientFrontier()()()() | Initializes a new instance of the OptEfficientFrontier class
ClearSelection()()()() | Clear the requirement or constraint selected for efficient frontier
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SelectedVar | Get the selected EF var
SelectionType | Get selected variable type
SetCustomValues(Object) | Set custom value array for efficient frontier - clears existing From, To, Step values.
SetTestValues(Double, Double, Double) | Set test values for efficient frontier. Set the lower and upper bounds of to vary the test points and the step increment - clears existing custom list
TestBound | Set the test bound to vary for between requirements
TestConstraint | Get / Set the constraint selected for efficent frontier
TestCustomValues | Get the current custom value list
TestRequirement | Get / Set the requirement selected for efficent frontier
TestSteps | Get the current test point steps value
TestValueFrom | Get the current test from value
TestValueStep | Get the current test from value
TestValuesType | Get the current test type
TestValueTo | Get the current test to value
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptEfficientFrontier

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier Constructor

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier Constructor
Initializes a new instance of the OptEfficientFrontier class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEfficientFrontier()
Public Sub New
Dim instance As New OptEfficientFrontier()

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier Methods

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier Methods

The OptEfficientFrontier type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClearSelection()()()() | Clear the requirement or constraint selected for efficient frontier
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetCustomValues(Object) | Set custom value array for efficient frontier - clears existing From, To, Step values.
SetTestValues(Double, Double, Double) | Set test values for efficient frontier. Set the lower and upper bounds of to vary the test points and the step increment - clears existing custom list
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ClearSelection Method

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::ClearSelection Method
Clear the requirement or constraint selected for efficient frontier

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ClearSelection()
Public Function ClearSelection As Boolean
Dim instance As OptEfficientFrontier
Dim returnValue As Boolean

returnValue = instance.ClearSelection()

Return Value

was this command was successful

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SetCustomValues Method

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::SetCustomValues Method
Set custom value array for efficient frontier - clears existing From, To, Step values.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetCustomValues(
    Object CustomValues
)
Public Function SetCustomValues ( _
    CustomValues As Object _
) As Boolean
Dim instance As OptEfficientFrontier
Dim CustomValues As Object
Dim returnValue As Boolean

returnValue = instance.SetCustomValues(CustomValues)

Parameters

CustomValues
Object
Double array of efficient frontier test point values.

Return Value

was this command was successful

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SetTestValues Method

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::SetTestValues Method
Set test values for efficient frontier. Set the lower and upper bounds of to vary the test points and the step increment - clears existing custom list

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetTestValues(
    double From,
    double To,
    double Step
)
Public Function SetTestValues ( _
    From As Double, _
    To As Double, _
    Step As Double _
) As Boolean
Dim instance As OptEfficientFrontier
Dim From As Double
Dim To As Double
Dim Step As Double
Dim returnValue As Boolean

returnValue = instance.SetTestValues(From, _
    To, Step)

Parameters

From
Double
Efficient frontier lower bound
To
Double
Efficient frontier upper bound
Step
Double
Efficient frontier step increment

Return Value

was this command was successful

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEfficientFrontier Properties

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier Properties

The OptEfficientFrontier type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SelectedVar | Get the selected EF var
SelectionType | Get selected variable type
TestBound | Set the test bound to vary for between requirements
TestConstraint | Get / Set the constraint selected for efficent frontier
TestCustomValues | Get the current custom value list
TestRequirement | Get / Set the requirement selected for efficent frontier
TestSteps | Get the current test point steps value
TestValueFrom | Get the current test from value
TestValueStep | Get the current test from value
TestValuesType | Get the current test type
TestValueTo | Get the current test to value

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SelectedVar Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::SelectedVar Property
Get the selected EF var

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public IOptVar SelectedVar { get; }
Public ReadOnly Property SelectedVar As IOptVar
    Get
Dim instance As OptEfficientFrontier
Dim value As IOptVar

value = instance.SelectedVar

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SelectionType Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::SelectionType Property
Get selected variable type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEFFSelectionType SelectionType { get; }
Public ReadOnly Property SelectionType As OptEFFSelectionType
    Get
Dim instance As OptEfficientFrontier
Dim value As OptEFFSelectionType

value = instance.SelectionType

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestBound Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestBound Property
Set the test bound to vary for between requirements

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEFFBoundType TestBound { get; set; }
Public Property TestBound As OptEFFBoundType
    Get
    Set
Dim instance As OptEfficientFrontier
Dim value As OptEFFBoundType

value = instance.TestBound

instance.TestBound = value

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestConstraint Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestConstraint Property
Get / Set the constraint selected for efficent frontier

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Constraint TestConstraint { get; set; }
Public Property TestConstraint As Constraint
    Get
    Set
Dim instance As OptEfficientFrontier
Dim value As Constraint

value = instance.TestConstraint

instance.TestConstraint = value

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestCustomValues Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestCustomValues Property
Get the current custom value list

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double[] TestCustomValues { get; }
Public ReadOnly Property TestCustomValues As Double()
    Get
Dim instance As OptEfficientFrontier
Dim value As Double()

value = instance.TestCustomValues

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestRequirement Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestRequirement Property
Get / Set the requirement selected for efficent frontier

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Requirement TestRequirement { get; set; }
Public Property TestRequirement As Requirement
    Get
    Set
Dim instance As OptEfficientFrontier
Dim value As Requirement

value = instance.TestRequirement

instance.TestRequirement = value

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestSteps Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestSteps Property
Get the current test point steps value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int TestSteps { get; }
Public ReadOnly Property TestSteps As Integer
    Get
Dim instance As OptEfficientFrontier
Dim value As Integer

value = instance.TestSteps

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestValueFrom Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestValueFrom Property
Get the current test from value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestValueFrom { get; }
Public ReadOnly Property TestValueFrom As Double
    Get
Dim instance As OptEfficientFrontier
Dim value As Double

value = instance.TestValueFrom

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestValueStep Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestValueStep Property
Get the current test from value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestValueStep { get; }
Public ReadOnly Property TestValueStep As Double
    Get
Dim instance As OptEfficientFrontier
Dim value As Double

value = instance.TestValueStep

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestValuesType Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestValuesType Property
Get the current test type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEFFTestType TestValuesType { get; }
Public ReadOnly Property TestValuesType As OptEFFTestType
    Get
Dim instance As OptEfficientFrontier
Dim value As OptEFFTestType

value = instance.TestValuesType

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestValueTo Property

Visual Basic Usage

CB Com Devkit
OptEfficientFrontier..::TestValueTo Property
Get the current test to value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestValueTo { get; }
Public ReadOnly Property TestValueTo As Double
    Get
Dim instance As OptEfficientFrontier
Dim value As Double

value = instance.TestValueTo

See Also

OptEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEFFSelectionType Enumeration

Visual Basic Usage

CB Com Devkit
OptEFFSelectionType Enumeration
Efficient Frontier testing type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptEFFSelectionType
Public Enumeration OptEFFSelectionType
Dim instance As OptEFFSelectionType

Members

Member | Description
None | No variable selected for EFF
Requirement | Requirement selected for EFF
Constraint | Constraint selected for EFF

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptEFFTestType Enumeration

Visual Basic Usage

CB Com Devkit
OptEFFTestType Enumeration
Efficient Frontier testing type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptEFFTestType
Public Enumeration OptEFFTestType
Dim instance As OptEFFTestType

Members

Member | Description
TestValues | Test From - To Values
Custom | Test custom list of values

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptimizationEvents Interface
Optimization Events raised during an Optimization execution.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface OptimizationEvents
Public Interface OptimizationEvents
Dim instance As OptimizationEvents

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AfterIterationEvent(Int32%) | Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.
AfterOptimizationEvent(Int32%) | Event raised after an optimization run completes.
AfterOptimizationResetEvent()()()() | After an optimization reset event.
AfterSimulationEvent(Int32%, Int32%, Int32%, Double%, Boolean%, Boolean%, Boolean%, Boolean%) | Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.
BeforeIterationEvent()()()() | Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.
BeforeOptimizationEvent()()()() | Event raised just prior to an optimization running.
BeforeOptimizationResetEvent(Int32%) | Before an optimization reset event.
BeforeSimulationEvent()()()() | Event raised just prior to an optimization's simulation (or iteration evaluation) being run. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.
EfficientFrontierEvent(Double%) | Event raised after each Efficient Frontier Test Point completes.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationEvents Methods

Visual Basic Usage

CB Com Devkit
OptimizationEvents Methods

The OptimizationEvents type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AfterIterationEvent(Int32%) | Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.
AfterOptimizationEvent(Int32%) | Event raised after an optimization run completes.
AfterOptimizationResetEvent()()()() | After an optimization reset event.
AfterSimulationEvent(Int32%, Int32%, Int32%, Double%, Boolean%, Boolean%, Boolean%, Boolean%) | Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.
BeforeIterationEvent()()()() | Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.
BeforeOptimizationEvent()()()() | Event raised just prior to an optimization running.
BeforeOptimizationResetEvent(Int32%) | Before an optimization reset event.
BeforeSimulationEvent()()()() | Event raised just prior to an optimization's simulation (or iteration evaluation) being run. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.
EfficientFrontierEvent(Double%) | Event raised after each Efficient Frontier Test Point completes.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AfterIterationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::AfterIterationEvent Method
Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void AfterIterationEvent(
    ref int IterationsCompleted
)
Sub AfterIterationEvent ( _
    ByRef IterationsCompleted As Integer _
)
Dim instance As OptimizationEvents
Dim IterationsCompleted As Integer

instance.AfterIterationEvent(IterationsCompleted)

Parameters

IterationsCompleted
Int32 %
The total iterations (or simulations) completed.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AfterOptimizationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::AfterOptimizationEvent Method
Event raised after an optimization run completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void AfterOptimizationEvent(
    ref int IterationsCompleted
)
Sub AfterOptimizationEvent ( _
    ByRef IterationsCompleted As Integer _
)
Dim instance As OptimizationEvents
Dim IterationsCompleted As Integer

instance.AfterOptimizationEvent(IterationsCompleted)

Parameters

IterationsCompleted
Int32 %
The total iterations (or simulations) completed.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AfterOptimizationResetEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::AfterOptimizationResetEvent Method
After an optimization reset event.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void AfterOptimizationResetEvent()
Sub AfterOptimizationResetEvent
Dim instance As OptimizationEvents

instance.AfterOptimizationResetEvent()

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AfterSimulationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::AfterSimulationEvent Method
Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void AfterSimulationEvent(
    ref int IterationsCompleted,
    ref int Trials,
    ref int MaxTrials,
    ref double Progress,
    ref bool WasAborted,
    ref bool WasStopOnError,
    ref bool WasStoppedOnPrecision,
    ref bool HasNewBestSolution
)
Sub AfterSimulationEvent ( _
    ByRef IterationsCompleted As Integer, _
    ByRef Trials As Integer, _
    ByRef MaxTrials As Integer, _
    ByRef Progress As Double, _
    ByRef WasAborted As Boolean, _
    ByRef WasStopOnError As Boolean, _
    ByRef WasStoppedOnPrecision As Boolean, _
    ByRef HasNewBestSolution As Boolean _
)
Dim instance As OptimizationEvents
Dim IterationsCompleted As Integer
Dim Trials As Integer
Dim MaxTrials As Integer
Dim Progress As Double
Dim WasAborted As Boolean
Dim WasStopOnError As Boolean
Dim WasStoppedOnPrecision As Boolean
Dim HasNewBestSolution As Boolean

instance.AfterSimulationEvent(IterationsCompleted, _
    Trials, MaxTrials, Progress, WasAborted, _
    WasStopOnError, WasStoppedOnPrecision, _
    HasNewBestSolution)

Parameters

IterationsCompleted
Int32 %
Number of iterations (or simulations) completed
Trials
Int32 %
Number of trials completed for this simulation
MaxTrials
Int32 %
Total trials per simulation
Progress
Double %
Progress as a percent, from 0 to 1.0
WasAborted
Boolean %
True if the simulation was aborted
WasStopOnError
Boolean %
True if the simulation stopped due to an error
WasStoppedOnPrecision
Boolean %
True if the simulation was stopped when precision control criteria was met.
HasNewBestSolution
Boolean %
For optimizations, true indicates this is new best solution.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BeforeIterationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::BeforeIterationEvent Method
Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void BeforeIterationEvent()
Sub BeforeIterationEvent
Dim instance As OptimizationEvents

instance.BeforeIterationEvent()

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BeforeOptimizationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::BeforeOptimizationEvent Method
Event raised just prior to an optimization running.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void BeforeOptimizationEvent()
Sub BeforeOptimizationEvent
Dim instance As OptimizationEvents

instance.BeforeOptimizationEvent()

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BeforeOptimizationResetEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::BeforeOptimizationResetEvent Method
Before an optimization reset event.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void BeforeOptimizationResetEvent(
    ref int IterationsCompleted
)
Sub BeforeOptimizationResetEvent ( _
    ByRef IterationsCompleted As Integer _
)
Dim instance As OptimizationEvents
Dim IterationsCompleted As Integer

instance.BeforeOptimizationResetEvent(IterationsCompleted)

Parameters

IterationsCompleted
Int32 %
Total iterations completed.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BeforeSimulationEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::BeforeSimulationEvent Method
Event raised just prior to an optimization's simulation (or iteration evaluation) being run. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void BeforeSimulationEvent()
Sub BeforeSimulationEvent
Dim instance As OptimizationEvents

instance.BeforeSimulationEvent()

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


EfficientFrontierEvent Method

Visual Basic Usage

CB Com Devkit
OptimizationEvents..::EfficientFrontierEvent Method
Event raised after each Efficient Frontier Test Point completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
void EfficientFrontierEvent(
    ref double TestValue
)
Sub EfficientFrontierEvent ( _
    ByRef TestValue As Double _
)
Dim instance As OptimizationEvents
Dim TestValue As Double

instance.EfficientFrontierEvent(TestValue)

Parameters

TestValue
Double %
The value for the completed test point.

See Also

OptimizationEvents Interface
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationState Enumeration

Visual Basic Usage

CB Com Devkit
OptimizationState Enumeration
The run state of the Optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptimizationState
Public Enumeration OptimizationState
Dim instance As OptimizationState

Members

Member | Description
NotRunning | The Optimization is has bot been run or has been reset.
Running | The Optimization is running.
Stopped | The Optimization is stopped.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptMoreLessCondition Enumeration

Visual Basic Usage

CB Com Devkit
OptMoreLessCondition Enumeration
More/less condition type.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptMoreLessCondition
Public Enumeration OptMoreLessCondition
Dim instance As OptMoreLessCondition

Members

Member | Description
None | More/less condition type not specified.
OrMore | 'or more' condition type specified.
OrLess | 'or less' condition type specified.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptObjectiveType Enumeration

Visual Basic Usage

CB Com Devkit
OptObjectiveType Enumeration
Objective type

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptObjectiveType
Public Enumeration OptObjectiveType
Dim instance As OptObjectiveType

Members

Member | Description
None | No objective type specified.
Maximize | Maximize objective type.
Minimize | Minimize objective type.
SetTarget | SetTarget objective type.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptimizationType Enumeration

Visual Basic Usage

CB Com Devkit
OptOptimizationType Enumeration
Optimization type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptOptimizationType
Public Enumeration OptOptimizationType
Dim instance As OptOptimizationType

Members

Member | Description
Stochastic | Run stochastic optimization
Deterministic | Run deterministic optimization

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptOptions Class
COM wrapper for optimization options

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptOptions
Public Class OptOptions
Dim instance As OptOptions

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
OptOptions()()()() | Initializes a new instance of the OptOptions class
AutoStop | Get / Set whether to automatically stop after x non-improving solutions
AutoStopSolutions | Get / Set the number of non-imporoving solutions to stop after
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LowConfidenceTesting | Perform low-confidence testing on the objective value while a simulation is running. If the Objective value cannot improve a previous best solution, the simulation is stopped.
OptType | Set / Get OptOptimizationType value
RunFor | Set / Get RunFor option
RunForMinutes | Set / Get RunForMinutes value
RunForSimulations | Set / Get RunForSimulations value
SetDecVars | Set / Get whether to update to best solutions values or leave original values
ShowChart | Set / Get Show charts type option
SolutionDatabaseSizeMax | The maximum solution database size. This is the maximum number of solutions (1 per simulation) that can be run for an Optimization. Limits the maximum number of optimiztion iterations that can be run. The default is 100,000.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
UpdateOnlyNewBest | Set / Get whether to update only new best solutions

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptOptions

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions Constructor

Visual Basic Usage

CB Com Devkit
OptOptions Constructor
Initializes a new instance of the OptOptions class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptOptions()
Public Sub New
Dim instance As New OptOptions()

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions Methods

Visual Basic Usage

CB Com Devkit
OptOptions Methods

The OptOptions type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptOptions Properties

Visual Basic Usage

CB Com Devkit
OptOptions Properties

The OptOptions type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AutoStop | Get / Set whether to automatically stop after x non-improving solutions
AutoStopSolutions | Get / Set the number of non-imporoving solutions to stop after
LowConfidenceTesting | Perform low-confidence testing on the objective value while a simulation is running. If the Objective value cannot improve a previous best solution, the simulation is stopped.
OptType | Set / Get OptOptimizationType value
RunFor | Set / Get RunFor option
RunForMinutes | Set / Get RunForMinutes value
RunForSimulations | Set / Get RunForSimulations value
SetDecVars | Set / Get whether to update to best solutions values or leave original values
ShowChart | Set / Get Show charts type option
SolutionDatabaseSizeMax | The maximum solution database size. This is the maximum number of solutions (1 per simulation) that can be run for an Optimization. Limits the maximum number of optimiztion iterations that can be run. The default is 100,000.
UpdateOnlyNewBest | Set / Get whether to update only new best solutions

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AutoStop Property

Visual Basic Usage

CB Com Devkit
OptOptions..::AutoStop Property
Get / Set whether to automatically stop after x non-improving solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool AutoStop { get; set; }
Public Property AutoStop As Boolean
    Get
    Set
Dim instance As OptOptions
Dim value As Boolean

value = instance.AutoStop

instance.AutoStop = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AutoStopSolutions Property

Visual Basic Usage

CB Com Devkit
OptOptions..::AutoStopSolutions Property
Get / Set the number of non-imporoving solutions to stop after

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int AutoStopSolutions { get; set; }
Public Property AutoStopSolutions As Integer
    Get
    Set
Dim instance As OptOptions
Dim value As Integer

value = instance.AutoStopSolutions

instance.AutoStopSolutions = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


LowConfidenceTesting Property

Visual Basic Usage

CB Com Devkit
OptOptions..::LowConfidenceTesting Property
Perform low-confidence testing on the objective value while a simulation is running. If the Objective value cannot improve a previous best solution, the simulation is stopped.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool LowConfidenceTesting { get; set; }
Public Property LowConfidenceTesting As Boolean
    Get
    Set
Dim instance As OptOptions
Dim value As Boolean

value = instance.LowConfidenceTesting

instance.LowConfidenceTesting = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptType Property

Visual Basic Usage

CB Com Devkit
OptOptions..::OptType Property
Set / Get OptOptimizationType value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptOptimizationType OptType { get; set; }
Public Property OptType As OptOptimizationType
    Get
    Set
Dim instance As OptOptions
Dim value As OptOptimizationType

value = instance.OptType

instance.OptType = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RunFor Property

Visual Basic Usage

CB Com Devkit
OptOptions..::RunFor Property
Set / Get RunFor option

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptRunForType RunFor { get; set; }
Public Property RunFor As OptRunForType
    Get
    Set
Dim instance As OptOptions
Dim value As OptRunForType

value = instance.RunFor

instance.RunFor = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RunForMinutes Property

Visual Basic Usage

CB Com Devkit
OptOptions..::RunForMinutes Property
Set / Get RunForMinutes value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RunForMinutes { get; set; }
Public Property RunForMinutes As Integer
    Get
    Set
Dim instance As OptOptions
Dim value As Integer

value = instance.RunForMinutes

instance.RunForMinutes = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RunForSimulations Property

Visual Basic Usage

CB Com Devkit
OptOptions..::RunForSimulations Property
Set / Get RunForSimulations value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RunForSimulations { get; set; }
Public Property RunForSimulations As Integer
    Get
    Set
Dim instance As OptOptions
Dim value As Integer

value = instance.RunForSimulations

instance.RunForSimulations = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SetDecVars Property

Visual Basic Usage

CB Com Devkit
OptOptions..::SetDecVars Property
Set / Get whether to update to best solutions values or leave original values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSetDecVars SetDecVars { get; set; }
Public Property SetDecVars As OptSetDecVars
    Get
    Set
Dim instance As OptOptions
Dim value As OptSetDecVars

value = instance.SetDecVars

instance.SetDecVars = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ShowChart Property

Visual Basic Usage

CB Com Devkit
OptOptions..::ShowChart Property
Set / Get Show charts type option

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptShowChartType ShowChart { get; set; }
Public Property ShowChart As OptShowChartType
    Get
    Set
Dim instance As OptOptions
Dim value As OptShowChartType

value = instance.ShowChart

instance.ShowChart = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionDatabaseSizeMax Property

Visual Basic Usage

CB Com Devkit
OptOptions..::SolutionDatabaseSizeMax Property
The maximum solution database size. This is the maximum number of solutions (1 per simulation) that can be run for an Optimization. Limits the maximum number of optimiztion iterations that can be run. The default is 100,000.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SolutionDatabaseSizeMax { get; set; }
Public Property SolutionDatabaseSizeMax As Integer
    Get
    Set
Dim instance As OptOptions
Dim value As Integer

value = instance.SolutionDatabaseSizeMax

instance.SolutionDatabaseSizeMax = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


UpdateOnlyNewBest Property

Visual Basic Usage

CB Com Devkit
OptOptions..::UpdateOnlyNewBest Property
Set / Get whether to update only new best solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool UpdateOnlyNewBest { get; set; }
Public Property UpdateOnlyNewBest As Boolean
    Get
    Set
Dim instance As OptOptions
Dim value As Boolean

value = instance.UpdateOnlyNewBest

instance.UpdateOnlyNewBest = value

See Also

OptOptions Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRunForType Enumeration

Visual Basic Usage

CB Com Devkit
OptRunForType Enumeration
Run for type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptRunForType
Public Enumeration OptRunForType
Dim instance As OptRunForType

Members

Member | Description
Minutes | Run for minutes
Simulations | Run for simulations

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptRuntime Class
An OptRuntime object is used to start, stop and monitor optimizations. After an optimization is complete results may be obtained by calling methods such as OptRuntime.GetBestSolution. Additionally OptRuntime.GetSolutionList may be used to determine the solutions used in the course of the optimization.
For Efficient Frontier optimizations, use the OptRuntime.EfficientFrontier property to access the results for specific test points.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptRuntime : IDisposable
Public Class OptRuntime _
    Implements IDisposable
Dim instance As OptRuntime

Members

All Members | Constructors | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
OptRuntime()()()() | Create an Optimization runtime object.
AfterIterationEvent | Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.
AfterOptimizationEvent | Event raised just after an optimization completes.
AfterOptimizationResetEvent | Event raised just after an Optimization Reset completes.
AfterSimulationEvent | Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.
BeforeIterationEvent | Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.
BeforeOptimizationEvent | Event raised just prior to an optimization running.
BeforeOptimizationResetEvent | Event raised just prior to an optimization running.
BeforeSimulationEvent | Before Simulation Event. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.
BestSolution | The best solution as determind by the optimization.
ClearSolutionFilter()()()() | Clear the Optimization solution filter filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.
Dispose()()()() | Dispose this object
EfficientFrontier | Return optimization runtime Efficient Frontier information.
EfficientFrontierEvent | Event for Efficient Frontier. This event is generated when each Efficient Frontier Test Value evaluation completes.
ElapsedSeconds | The elapsed seconds for the current optimization run. This is seconds of run time and not wall clock.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EventHandled()()()() | Call to indicate the current event has been handled. This allows event handlers to access DecVar data, modify Excel values that affect Constraints and to update Final Values in Objectives and Forecasts.
EventsAreDisabled | Are events from this OptRuntime object disabled. Allows the user to temporarialy turn off firing of events. Not persisted after Crystal Ball is closed. The default is false.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetSolutionFilter()()()() | Get the Optimization solution filter. Null if none configured. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.
GetSolutionList(SolutionListSort, Single, Boolean, Boolean, Boolean) | Get a list of Optimization solutions using a filter and a sort.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IterationCount | The number of Optimization iterations that have been run. This number may be greater than the simulation count if the optimization contains non-linear constraints.
LastErrorNumber | The last error number returned by a Devkit method call. This is the NewValue error number from the Macro result. This returns the last Error Number from running any Devkit method. Note: calling this does not update any Macro Result information.
LastResult | The last macro result from a CBCOMDevKit method
OptCounters | Optimization state counters.
OptimizerMode | OptimizerMode - determine if CB is in optimizer mode, in other words if optimization has been or is being executed.
OptState | The current state of the Optimization.
OptTerminationReason | Optimization termination reason. This returns the last Termination Reason. Note: Calling this does not update any Macro Result information.
Reset()()()() | Resets the optimization. Memory for all solutions the best solution simulation results are cleared.
ResultsWindow | Returns the OptQuest Results Window.
Run()()()() | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.
Run(Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption) | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options. Note that options set with the provided arguments are only in effect for the duration of the Optimization and do not affect the stored user preferences. Validation errors: The ShowWizardOnError property determines if the OptQuest Wizard will be shown if pre-run validation errors occur, allowing the user a chance to fix the error. The wizard will not be shown
SetSolutionFilter(Boolean, Single, Boolean, Boolean, Boolean) | Set the Optimization variable solution filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity calculations. Statistics are kept for each variable based upon the the set of solution values. Statistics values are maintained for: Objectives, Requirements, Constraints and Decision variables. If no filter is set the Optimization variable statistics and sensitivity are be updated for all solutions.
ShowDownshiftDialog | The ShowDownshiftDialog property indicates whether to show the Extreme Speed downshift dialog if the model cannot run in Extreme Speed mode. If a model cannot run in Extreme Speed, this property determines whether a dialog will be displayed giving the user the option to "downshift" to normal speed mode. Note that this property only has effect if CB.AutoDownshift has been set to true. If CB.AutoDownshift is set to false, an error Macro result will always be returned if the model cannot run in Extreme Speed. The default for this property is false.
ShowWizardOnError | Display the OptQuest Wizard on validation error when run optimization is executed. The default is false.
Stop()()()() | Stops the optimization.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
UpdateDecVarValues(DecVarValueType) | Update the way decision variable values are set to the workbook after optimization.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptRuntime

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Constructor

Visual Basic Usage

CB Com Devkit
OptRuntime Constructor
Create an Optimization runtime object.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptRuntime()
Public Sub New
Dim instance As New OptRuntime()

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Methods

Visual Basic Usage

CB Com Devkit
OptRuntime Methods

The OptRuntime type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClearSolutionFilter()()()() | Clear the Optimization solution filter filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.
Dispose()()()() | Dispose this object
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EventHandled()()()() | Call to indicate the current event has been handled. This allows event handlers to access DecVar data, modify Excel values that affect Constraints and to update Final Values in Objectives and Forecasts.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetSolutionFilter()()()() | Get the Optimization solution filter. Null if none configured. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.
GetSolutionList(SolutionListSort, Single, Boolean, Boolean, Boolean) | Get a list of Optimization solutions using a filter and a sort.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Reset()()()() | Resets the optimization. Memory for all solutions the best solution simulation results are cleared.
Run()()()() | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.
Run(Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption) | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options. Note that options set with the provided arguments are only in effect for the duration of the Optimization and do not affect the stored user preferences. Validation errors: The ShowWizardOnError property determines if the OptQuest Wizard will be shown if pre-run validation errors occur, allowing the user a chance to fix the error. The wizard will not be shown
SetSolutionFilter(Boolean, Single, Boolean, Boolean, Boolean) | Set the Optimization variable solution filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity calculations. Statistics are kept for each variable based upon the the set of solution values. Statistics values are maintained for: Objectives, Requirements, Constraints and Decision variables. If no filter is set the Optimization variable statistics and sensitivity are be updated for all solutions.
Stop()()()() | Stops the optimization.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
UpdateDecVarValues(DecVarValueType) | Update the way decision variable values are set to the workbook after optimization.

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ClearSolutionFilter Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::ClearSolutionFilter Method
Clear the Optimization solution filter filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ClearSolutionFilter()
Public Sub ClearSolutionFilter
Dim instance As OptRuntime

instance.ClearSolutionFilter()

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Dispose Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Dispose Method
Dispose this object

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Dispose()
Public Sub Dispose
Dim instance As OptRuntime

instance.Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


EventHandled Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::EventHandled Method
Call to indicate the current event has been handled. This allows event handlers to access DecVar data, modify Excel values that affect Constraints and to update Final Values in Objectives and Forecasts.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void EventHandled()
Public Sub EventHandled
Dim instance As OptRuntime

instance.EventHandled()

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


GetSolutionFilter Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::GetSolutionFilter Method
Get the Optimization solution filter. Null if none configured. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptVarSolutionFilter GetSolutionFilter()
Public Function GetSolutionFilter As OptVarSolutionFilter
Dim instance As OptRuntime
Dim returnValue As OptVarSolutionFilter

returnValue = instance.GetSolutionFilter()

Return Value

The active optimization variable statistics filter.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data
CBExceptionIDNoSolutionFilterAvailable()()()() | No solution filter has been configured

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


GetSolutionList Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::GetSolutionList Method
Get a list of Optimization solutions using a filter and a sort.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolutionEnumerator GetSolutionList(
    SolutionListSort sort,
    float countLimit,
    bool includeFeasible,
    bool includeInFeasible,
    bool includeLowConfidence
)
Public Function GetSolutionList ( _
    sort As SolutionListSort, _
    countLimit As Single, _
    includeFeasible As Boolean, _
    includeInFeasible As Boolean, _
    includeLowConfidence As Boolean _
) As OptSolutionEnumerator
Dim instance As OptRuntime
Dim sort As SolutionListSort
Dim countLimit As Single
Dim includeFeasible As Boolean
Dim includeInFeasible As Boolean
Dim includeLowConfidence As Boolean
Dim returnValue As OptSolutionEnumerator

returnValue = instance.GetSolutionList(sort, _
    countLimit, includeFeasible, includeInFeasible, _
    includeLowConfidence)

Parameters

sort
SolutionListSort
The solution list sort order
countLimit
Single
Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count
includeFeasible
Boolean
Include feasible solutions
includeInFeasible
Boolean
Include infeasible solutions
includeLowConfidence
Boolean
Include low-confidence solutions

Return Value

A list of solution objects as an enumerator

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSolution


Reset Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Reset Method
Resets the optimization. Memory for all solutions the best solution simulation results are cleared.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As OptRuntime

instance.Reset()

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Run Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Run Method

Overload List

Name | Description
Run()()()() | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.
Run(Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption) | Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options. Note that options set with the provided arguments are only in effect for the duration of the Optimization and do not affect the stored user preferences. Validation errors: The ShowWizardOnError property determines if the OptQuest Wizard will be shown if pre-run validation errors occur, allowing the user a chance to fix the error. The wizard will not be shown

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Run Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Run Method
Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TerminationReason Run()
Public Function Run As TerminationReason
Dim instance As OptRuntime
Dim returnValue As TerminationReason

returnValue = instance.Run()

Return Value

The reason for optimization termination.

See Also

OptRuntime Class
Run Overload
Decisioneering.CB.CBCOMDevKit.Optimization Namespace
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptOptions


Run Method (Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption)

Visual Basic Usage

CB Com Devkit
OptRuntime..::Run Method (Int32, BooleanOption, BooleanOption, BooleanOption, BooleanOption)
Run or continue an optimization. This method will continue an optimization if it has not been reset. To continue there must be remaining time or iterations. The optimization options may be modified to add more time or iterations prior to a continue. To change any options use OptSetup.Options.
Note that options set with the provided arguments are only in effect for the duration of the Optimization and do not affect the stored user preferences. Validation errors: The ShowWizardOnError property determines if the OptQuest Wizard will be shown if pre-run validation errors occur, allowing the user a chance to fix the error. The wizard will not be shown

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TerminationReason Run(
    int iterations,
    BooleanOption hideForecasts,
    BooleanOption minimizeHost,
    BooleanOption showControlPanel,
    BooleanOption showDownshiftDialog
)
Public Function Run ( _
    iterations As Integer, _
    hideForecasts As BooleanOption, _
    minimizeHost As BooleanOption, _
    showControlPanel As BooleanOption, _
    showDownshiftDialog As BooleanOption _
) As TerminationReason
Dim instance As OptRuntime
Dim iterations As Integer
Dim hideForecasts As BooleanOption
Dim minimizeHost As BooleanOption
Dim showControlPanel As BooleanOption
Dim showDownshiftDialog As BooleanOption
Dim returnValue As TerminationReason

returnValue = instance.Run(iterations, _
    hideForecasts, minimizeHost, showControlPanel, _
    showDownshiftDialog)

Parameters

iterations
Int32
The number of iterations (simulations if not deterministic) that will be run, zero will invoke the default. The default is to use the current OptSetup.Options.RunFor configuration. Note: When continuing an Optimization, this value indicates the total number of iterations to run, including those already executed. Therefore this value must be greater than the number of iterations run to this point.
hideForecasts
BooleanOption
Hide all windows while running, overrides any other forecast runtime options, the default is to show forecast windows per Optimization options.
minimizeHost
BooleanOption
Minimize Excel while running, the default is to not minimize Excel.
showControlPanel
BooleanOption
Show the CB control panel, the default is to show the CB control panel.
showDownshiftDialog
BooleanOption
Show the Extreme Speed downshift dialog, indicates whether to show the Extreme Speed downshift dialog if the model cannot run in Extreme Speed mode. The default is to use the setting for the OptRuntime.ShowDownshiftDialog property.

Return Value

The reason for optimization termination.

See Also

OptRuntime Class
Run Overload
Decisioneering.CB.CBCOMDevKit.Optimization Namespace
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptOptions


SetSolutionFilter Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::SetSolutionFilter Method
Set the Optimization variable solution filter. The solution filter limits the set of solutions that affect the Optimization variable statistics and sensitivity calculations. Statistics are kept for each variable based upon the the set of solution values. Statistics values are maintained for: Objectives, Requirements, Constraints and Decision variables. If no filter is set the Optimization variable statistics and sensitivity are be updated for all solutions.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetSolutionFilter(
    bool sortBestOrder,
    float countLimit,
    bool includeFeasible,
    bool includeInFeasible,
    bool includeLowConfidence
)
Public Sub SetSolutionFilter ( _
    sortBestOrder As Boolean, _
    countLimit As Single, _
    includeFeasible As Boolean, _
    includeInFeasible As Boolean, _
    includeLowConfidence As Boolean _
)
Dim instance As OptRuntime
Dim sortBestOrder As Boolean
Dim countLimit As Single
Dim includeFeasible As Boolean
Dim includeInFeasible As Boolean
Dim includeLowConfidence As Boolean

instance.SetSolutionFilter(sortBestOrder, _
    countLimit, includeFeasible, includeInFeasible, _
    includeLowConfidence)

Parameters

sortBestOrder
Boolean
Use best solution order, otherwise iteration order
countLimit
Single
Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count
includeFeasible
Boolean
Include feasible solutions
includeInFeasible
Boolean
Include infeasible solutions
includeLowConfidence
Boolean
Include low-confidence solutions

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have been run to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Stop Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::Stop Method
Stops the optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Stop()
Public Sub Stop
Dim instance As OptRuntime

instance.Stop()

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


UpdateDecVarValues Method

Visual Basic Usage

CB Com Devkit
OptRuntime..::UpdateDecVarValues Method
Update the way decision variable values are set to the workbook after optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void UpdateDecVarValues(
    DecVarValueType decVarValueType
)
Public Sub UpdateDecVarValues ( _
    decVarValueType As DecVarValueType _
)
Dim instance As OptRuntime
Dim decVarValueType As DecVarValueType

instance.UpdateDecVarValues(decVarValueType)

Parameters

decVarValueType
DecVarValueType
Which DecVarValueType is used to update decision variable values

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Properties

Visual Basic Usage

CB Com Devkit
OptRuntime Properties

The OptRuntime type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestSolution | The best solution as determind by the optimization.
EfficientFrontier | Return optimization runtime Efficient Frontier information.
ElapsedSeconds | The elapsed seconds for the current optimization run. This is seconds of run time and not wall clock.
EventsAreDisabled | Are events from this OptRuntime object disabled. Allows the user to temporarialy turn off firing of events. Not persisted after Crystal Ball is closed. The default is false.
IterationCount | The number of Optimization iterations that have been run. This number may be greater than the simulation count if the optimization contains non-linear constraints.
LastErrorNumber | The last error number returned by a Devkit method call. This is the NewValue error number from the Macro result. This returns the last Error Number from running any Devkit method. Note: calling this does not update any Macro Result information.
LastResult | The last macro result from a CBCOMDevKit method
OptCounters | Optimization state counters.
OptimizerMode | OptimizerMode - determine if CB is in optimizer mode, in other words if optimization has been or is being executed.
OptState | The current state of the Optimization.
OptTerminationReason | Optimization termination reason. This returns the last Termination Reason. Note: Calling this does not update any Macro Result information.
ResultsWindow | Returns the OptQuest Results Window.
ShowDownshiftDialog | The ShowDownshiftDialog property indicates whether to show the Extreme Speed downshift dialog if the model cannot run in Extreme Speed mode. If a model cannot run in Extreme Speed, this property determines whether a dialog will be displayed giving the user the option to "downshift" to normal speed mode. Note that this property only has effect if CB.AutoDownshift has been set to true. If CB.AutoDownshift is set to false, an error Macro result will always be returned if the model cannot run in Extreme Speed. The default for this property is false.
ShowWizardOnError | Display the OptQuest Wizard on validation error when run optimization is executed. The default is false.

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BestSolution Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::BestSolution Property
The best solution as determind by the optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolution BestSolution { get; }
Public ReadOnly Property BestSolution As OptSolution
    Get
Dim instance As OptRuntime
Dim value As OptSolution

value = instance.BestSolution

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


EfficientFrontier Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::EfficientFrontier Property
Return optimization runtime Efficient Frontier information.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public RuntimeEfficientFrontier EfficientFrontier { get; }
Public ReadOnly Property EfficientFrontier As RuntimeEfficientFrontier
    Get
Dim instance As OptRuntime
Dim value As RuntimeEfficientFrontier

value = instance.EfficientFrontier

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ElapsedSeconds Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::ElapsedSeconds Property
The elapsed seconds for the current optimization run. This is seconds of run time and not wall clock.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ElapsedSeconds { get; }
Public ReadOnly Property ElapsedSeconds As Double
    Get
Dim instance As OptRuntime
Dim value As Double

value = instance.ElapsedSeconds

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


EventsAreDisabled Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::EventsAreDisabled Property
Are events from this OptRuntime object disabled. Allows the user to temporarialy turn off firing of events. Not persisted after Crystal Ball is closed. The default is false.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool EventsAreDisabled { get; set; }
Public Property EventsAreDisabled As Boolean
    Get
    Set
Dim instance As OptRuntime
Dim value As Boolean

value = instance.EventsAreDisabled

instance.EventsAreDisabled = value

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IterationCount Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::IterationCount Property
The number of Optimization iterations that have been run. This number may be greater than the simulation count if the optimization contains non-linear constraints.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int IterationCount { get; }
Public ReadOnly Property IterationCount As Integer
    Get
Dim instance As OptRuntime
Dim value As Integer

value = instance.IterationCount

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


LastErrorNumber Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::LastErrorNumber Property
The last error number returned by a Devkit method call. This is the NewValue error number from the Macro result. This returns the last Error Number from running any Devkit method. Note: calling this does not update any Macro Result information.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int LastErrorNumber { get; }
Public ReadOnly Property LastErrorNumber As Integer
    Get
Dim instance As OptRuntime
Dim value As Integer

value = instance.LastErrorNumber

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


LastResult Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::LastResult Property
The last macro result from a CBCOMDevKit method

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MRWrapper LastResult { get; }
Public ReadOnly Property LastResult As MRWrapper
    Get
Dim instance As OptRuntime
Dim value As MRWrapper

value = instance.LastResult

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptCounters Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::OptCounters Property
Optimization state counters.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptCounters OptCounters { get; }
Public ReadOnly Property OptCounters As OptCounters
    Get
Dim instance As OptRuntime
Dim value As OptCounters

value = instance.OptCounters

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizerMode Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::OptimizerMode Property
OptimizerMode - determine if CB is in optimizer mode, in other words if optimization has been or is being executed.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool OptimizerMode { get; }
Public ReadOnly Property OptimizerMode As Boolean
    Get
Dim instance As OptRuntime
Dim value As Boolean

value = instance.OptimizerMode

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptState Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::OptState Property
The current state of the Optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptimizationState OptState { get; }
Public ReadOnly Property OptState As OptimizationState
    Get
Dim instance As OptRuntime
Dim value As OptimizationState

value = instance.OptState

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptTerminationReason Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::OptTerminationReason Property
Optimization termination reason. This returns the last Termination Reason. Note: Calling this does not update any Macro Result information.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TerminationReason OptTerminationReason { get; }
Public ReadOnly Property OptTerminationReason As TerminationReason
    Get
Dim instance As OptRuntime
Dim value As TerminationReason

value = instance.OptTerminationReason

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::ResultsWindow Property
Returns the OptQuest Results Window.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ResultsWindow ResultsWindow { get; }
Public ReadOnly Property ResultsWindow As ResultsWindow
    Get
Dim instance As OptRuntime
Dim value As ResultsWindow

value = instance.ResultsWindow

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have been run to access the window

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ShowDownshiftDialog Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::ShowDownshiftDialog Property
The ShowDownshiftDialog property indicates whether to show the Extreme Speed downshift dialog if the model cannot run in Extreme Speed mode. If a model cannot run in Extreme Speed, this property determines whether a dialog will be displayed giving the user the option to "downshift" to normal speed mode.
Note that this property only has effect if CB.AutoDownshift has been set to true. If CB.AutoDownshift is set to false, an error Macro result will always be returned if the model cannot run in Extreme Speed.
The default for this property is false.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowDownshiftDialog { get; set; }
Public Property ShowDownshiftDialog As Boolean
    Get
    Set
Dim instance As OptRuntime
Dim value As Boolean

value = instance.ShowDownshiftDialog

instance.ShowDownshiftDialog = value

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ShowWizardOnError Property

Visual Basic Usage

CB Com Devkit
OptRuntime..::ShowWizardOnError Property
Display the OptQuest Wizard on validation error when run optimization is executed. The default is false.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowWizardOnError { get; set; }
Public Property ShowWizardOnError As Boolean
    Get
    Set
Dim instance As OptRuntime
Dim value As Boolean

value = instance.ShowWizardOnError

instance.ShowWizardOnError = value

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime Events

Visual Basic Usage

CB Com Devkit
OptRuntime Events

The OptRuntime type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AfterIterationEvent | Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.
AfterOptimizationEvent | Event raised just after an optimization completes.
AfterOptimizationResetEvent | Event raised just after an Optimization Reset completes.
AfterSimulationEvent | Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.
BeforeIterationEvent | Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.
BeforeOptimizationEvent | Event raised just prior to an optimization running.
BeforeOptimizationResetEvent | Event raised just prior to an optimization running.
BeforeSimulationEvent | Before Simulation Event. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.
EfficientFrontierEvent | Event for Efficient Frontier. This event is generated when each Efficient Frontier Test Value evaluation completes.

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AfterIterationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::AfterIterationEvent Event
Event raised after an optimization's iteration completes. At this point the simulation is complete, any extract data has been written to the workbook and objective / requirement values have been updated to OptQuest. At this point the solution for this iteration is valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptItersEventHandler AfterIterationEvent
Public Event AfterIterationEvent As OptRuntime..::..OptItersEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptItersEventHandler

AddHandler instance.AfterIterationEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AfterOptimizationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::AfterOptimizationEvent Event
Event raised just after an optimization completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptItersEventHandler AfterOptimizationEvent
Public Event AfterOptimizationEvent As OptRuntime..::..OptItersEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptItersEventHandler

AddHandler instance.AfterOptimizationEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AfterOptimizationResetEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::AfterOptimizationResetEvent Event
Event raised just after an Optimization Reset completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptEventHandler AfterOptimizationResetEvent
Public Event AfterOptimizationResetEvent As OptRuntime..::..OptEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptEventHandler

AddHandler instance.AfterOptimizationResetEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AfterSimulationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::AfterSimulationEvent Event
Event raised just after an optimization's simulation (or iteration evaluation) completes. The simulation is complete and any simulation results are valid. Any extracted data values will also have been written to the workbook as part of the simulation processing. Forecast objective and requirement values have not yet been updated to OptQuest. at this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..AfterSimulationEventHandler AfterSimulationEvent
Public Event AfterSimulationEvent As OptRuntime..::..AfterSimulationEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..AfterSimulationEventHandler

AddHandler instance.AfterSimulationEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BeforeIterationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::BeforeIterationEvent Event
Event raised prior to an optimization's iteration being run. This event occurs after any Decision Variables are placed into the workbook but before any constraints are evaluated or simulations are run. At this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptEventHandler BeforeIterationEvent
Public Event BeforeIterationEvent As OptRuntime..::..OptEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptEventHandler

AddHandler instance.BeforeIterationEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BeforeOptimizationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::BeforeOptimizationEvent Event
Event raised just prior to an optimization running.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptEventHandler BeforeOptimizationEvent
Public Event BeforeOptimizationEvent As OptRuntime..::..OptEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptEventHandler

AddHandler instance.BeforeOptimizationEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BeforeOptimizationResetEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::BeforeOptimizationResetEvent Event
Event raised just prior to an optimization running.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptItersEventHandler BeforeOptimizationResetEvent
Public Event BeforeOptimizationResetEvent As OptRuntime..::..OptItersEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptItersEventHandler

AddHandler instance.BeforeOptimizationResetEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BeforeSimulationEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::BeforeSimulationEvent Event
Before Simulation Event. This event occurs after OptQuest evaluates any constraints but before any simulations are run. At this point the solution for this iteration is NOT valid.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..OptEventHandler BeforeSimulationEvent
Public Event BeforeSimulationEvent As OptRuntime..::..OptEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..OptEventHandler

AddHandler instance.BeforeSimulationEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


EfficientFrontierEvent Event

Visual Basic Usage

CB Com Devkit
OptRuntime..::EfficientFrontierEvent Event
Event for Efficient Frontier. This event is generated when each Efficient Frontier Test Value evaluation completes.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public event OptRuntime..::..EfficientFrontierEventHandler EfficientFrontierEvent
Public Event EfficientFrontierEvent As OptRuntime..::..EfficientFrontierEventHandler
Dim instance As OptRuntime
Dim handler As OptRuntime..::..EfficientFrontierEventHandler

AddHandler instance.EfficientFrontierEvent, handler

See Also

OptRuntime Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.AfterSimulationEventHandler Delegate

Visual Basic Usage

CB Com Devkit
OptRuntime..::..AfterSimulationEventHandler Delegate
After simulation event handler.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public delegate void AfterSimulationEventHandler(
    ref int IterationsCompleted,
    ref int Trials,
    ref int MaxTrials,
    ref double Progress,
    ref bool WasAborted,
    ref bool WasStopOnError,
    ref bool WasStoppedOnPrecision,
    ref bool HasNewBestSolution
)
Public Delegate Sub AfterSimulationEventHandler ( _
    ByRef IterationsCompleted As Integer, _
    ByRef Trials As Integer, _
    ByRef MaxTrials As Integer, _
    ByRef Progress As Double, _
    ByRef WasAborted As Boolean, _
    ByRef WasStopOnError As Boolean, _
    ByRef WasStoppedOnPrecision As Boolean, _
    ByRef HasNewBestSolution As Boolean _
)
Dim instance As New AfterSimulationEventHandler(AddressOf HandlerMethod)

Parameters

IterationsCompleted
Int32 %
Number of Optimization iterations completed
Trials
Int32 %
Number of trials run in the last simulation
MaxTrials
Int32 %
The maximuk number of trials configured for a simulation
Progress
Double %
The progress of the completed simulation
WasAborted
Boolean %
True if the simulation was aborted
WasStopOnError
Boolean %
True if the simulation was stopped due to an error
WasStoppedOnPrecision
Boolean %
True if the simulation was stopped due to precision controls
HasNewBestSolution
Boolean %
True if the simulation represents a new best solution

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.EfficientFrontierEventHandler Delegate

Visual Basic Usage

CB Com Devkit
OptRuntime..::..EfficientFrontierEventHandler Delegate
Efficient Frontier Event handler.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public delegate void EfficientFrontierEventHandler(
    ref double TestValue
)
Public Delegate Sub EfficientFrontierEventHandler ( _
    ByRef TestValue As Double _
)
Dim instance As New EfficientFrontierEventHandler(AddressOf HandlerMethod)

Parameters

TestValue
Double %
The test value that has just completed processing

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.OptEventHandler Delegate

Visual Basic Usage

CB Com Devkit
OptRuntime..::..OptEventHandler Delegate
Optimization Event handler.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public delegate void OptEventHandler()
Public Delegate Sub OptEventHandler
Dim instance As New OptEventHandler(AddressOf HandlerMethod)

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptRuntime.OptItersEventHandler Delegate

Visual Basic Usage

CB Com Devkit
OptRuntime..::..OptItersEventHandler Delegate
Optimization Iterations Event handler.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public delegate void OptItersEventHandler(
    ref int IterationsCompleted
)
Public Delegate Sub OptItersEventHandler ( _
    ByRef IterationsCompleted As Integer _
)
Dim instance As New OptItersEventHandler(AddressOf HandlerMethod)

Parameters

IterationsCompleted
Int32 %
The number of iterations completed.

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetDecVars Enumeration

Visual Basic Usage

CB Com Devkit
OptSetDecVars Enumeration
Set decision variable cell values type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptSetDecVars
Public Enumeration OptSetDecVars
Dim instance As OptSetDecVars

Members

Member | Description
SetToBest | Automatically set decision variable cells to best solution
LeaveOriginal | Leave decision variable cells set to original values

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptSetup Class
Optimization Setup / Definition Access optimization variables, add, modify and delete variables and options for running optimizations

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptSetup
Public Class OptSetup
Dim instance As OptSetup

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
OptSetup()()()() | Optimization Setup / Definition Access optimization variables, add, modify and delete variables and options for running optimizations
AddConstraint(String) | Add a new constraint to the constraints collection
AddObjective(OptObjectiveType, Range, OptSupportedStatistics, Double, Double, Double, OptConditionType) | Add a new Objective to the objectives collection
AddRequirement(Range, OptSupportedStatistics, OptConditionType, Double, Double, Double, Double, OptMoreLessCondition) | AddRequirement adds a new Requirement to the requirement collection
ClearAll()()()() | Clear all Optimization variables for all open workbooks
Constraints | Get a Constraints enumerator, no updates to DecVars will be reflected until enumeration recreated
Decisions | Get a Decisions enumerator, no updates to DecVars will be reflected until enumeration recreated
EfficientFrontier | Access to Efficient Frontier options singleton
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LastResult | The last macro result from a CBCOMDevKit method
Objectives | Get a Objective enumerator, no updates to DecVars will be reflected until enumeration recreated
Options | Access to optimization options singleton
PrimaryWorkbook | Workbook that is the target for Optimization variable storage and access
Requirements | Get a Requirement enumerator, no updates to DecVars will be reflected until enumeration recreated
Show()()()() | Show the Optimization Wizard GUI
ThrowErrors | Setting to determine whether to throw errors to the client app
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate(Boolean) | Validate all optimization settings for current storage workbook and determine if optimization can be run.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSetup

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup Constructor

Visual Basic Usage

CB Com Devkit
OptSetup Constructor
Optimization Setup / Definition Access optimization variables, add, modify and delete variables and options for running optimizations

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSetup()
Public Sub New
Dim instance As New OptSetup()

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup Methods

Visual Basic Usage

CB Com Devkit
OptSetup Methods

The OptSetup type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddConstraint(String) | Add a new constraint to the constraints collection
AddObjective(OptObjectiveType, Range, OptSupportedStatistics, Double, Double, Double, OptConditionType) | Add a new Objective to the objectives collection
AddRequirement(Range, OptSupportedStatistics, OptConditionType, Double, Double, Double, Double, OptMoreLessCondition) | AddRequirement adds a new Requirement to the requirement collection
ClearAll()()()() | Clear all Optimization variables for all open workbooks
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Show()()()() | Show the Optimization Wizard GUI
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate(Boolean) | Validate all optimization settings for current storage workbook and determine if optimization can be run.

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AddConstraint Method

Visual Basic Usage

CB Com Devkit
OptSetup..::AddConstraint Method
Add a new constraint to the constraints collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Constraint AddConstraint(
    string equation
)
Public Function AddConstraint ( _
    equation As String _
) As Constraint
Dim instance As OptSetup
Dim equation As String
Dim returnValue As Constraint

returnValue = instance.AddConstraint(equation)

Parameters

equation
String
Constraint equation. This can contain decision variable names or cell addresses.

Return Value

new Constraint or null

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AddObjective Method

Visual Basic Usage

CB Com Devkit
OptSetup..::AddObjective Method
Add a new Objective to the objectives collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Objective AddObjective(
    OptObjectiveType type,
    Range forecastRange,
    OptSupportedStatistics stats,
    double targetValue,
    double statisticValue1,
    double statisticValue2,
    OptConditionType condition
)
Public Function AddObjective ( _
    type As OptObjectiveType, _
    forecastRange As Range, _
    stats As OptSupportedStatistics, _
    targetValue As Double, _
    statisticValue1 As Double, _
    statisticValue2 As Double, _
    condition As OptConditionType _
) As Objective
Dim instance As OptSetup
Dim type As OptObjectiveType
Dim forecastRange As Range
Dim stats As OptSupportedStatistics
Dim targetValue As Double
Dim statisticValue1 As Double
Dim statisticValue2 As Double
Dim condition As OptConditionType
Dim returnValue As Objective

returnValue = instance.AddObjective(type, _
    forecastRange, stats, targetValue, _
    statisticValue1, statisticValue2, _
    condition)

Parameters

type
OptObjectiveType
Objective type, one of the OptObjectiveType enumeration values
forecastRange
Range
Excel range referencing a Forecast to be used in the objective, this must be an Excel.Range type object.
stats
OptSupportedStatistics
Objective statistic, one of OptSupportedStatistics enumeration values
targetValue
Double
Objective target value, used only for SetTarget objective (optional)
statisticValue1
Double
double first statistic value (optional)
statisticValue2
Double
double second statistic value (optional)
condition
OptConditionType
Objective condition, coud be one of the values defined in OptConditionType enumeration (optional)

Return Value

new Objective or null

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AddRequirement Method

Visual Basic Usage

CB Com Devkit
OptSetup..::AddRequirement Method
AddRequirement adds a new Requirement to the requirement collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Requirement AddRequirement(
    Range forecastRange,
    OptSupportedStatistics stats,
    OptConditionType condition,
    double conditionValue1,
    double conditionValue2,
    double statisticValue1,
    double statisticValue2,
    OptMoreLessCondition moreLessCondition
)
Public Function AddRequirement ( _
    forecastRange As Range, _
    stats As OptSupportedStatistics, _
    condition As OptConditionType, _
    conditionValue1 As Double, _
    conditionValue2 As Double, _
    statisticValue1 As Double, _
    statisticValue2 As Double, _
    moreLessCondition As OptMoreLessCondition _
) As Requirement
Dim instance As OptSetup
Dim forecastRange As Range
Dim stats As OptSupportedStatistics
Dim condition As OptConditionType
Dim conditionValue1 As Double
Dim conditionValue2 As Double
Dim statisticValue1 As Double
Dim statisticValue2 As Double
Dim moreLessCondition As OptMoreLessCondition
Dim returnValue As Requirement

returnValue = instance.AddRequirement(forecastRange, _
    stats, condition, conditionValue1, _
    conditionValue2, statisticValue1, _
    statisticValue2, moreLessCondition)

Parameters

forecastRange
Range
Excel range referencing a Forecast to be used in this requirement, this must be an Excel.Range type object.
stats
OptSupportedStatistics
Defines one of OptSupportedStatistics as Requirement statistic
condition
OptConditionType
OptConditionType condition
conditionValue1
Double
double first condition value
conditionValue2
Double
double second condition value(optional)
statisticValue1
Double
double first statistic value (optional)
statisticValue2
Double
double second statistic value (optional)
moreLessCondition
OptMoreLessCondition
one of the OptMoreLessCondition values (optional)

Return Value

The requirement object added or null

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ClearAll Method

Visual Basic Usage

CB Com Devkit
OptSetup..::ClearAll Method
Clear all Optimization variables for all open workbooks

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ClearAll()
Public Function ClearAll As Boolean
Dim instance As OptSetup
Dim returnValue As Boolean

returnValue = instance.ClearAll()

Return Value

Whether all variables were successfully cleared.

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Show Method

Visual Basic Usage

CB Com Devkit
OptSetup..::Show Method
Show the Optimization Wizard GUI

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Show()
Public Function Show As Boolean
Dim instance As OptSetup
Dim returnValue As Boolean

returnValue = instance.Show()

Return Value

Whether wizard was shown.

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
OptSetup..::Validate Method
Validate all optimization settings for current storage workbook and determine if optimization can be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate(
    bool ShowWizard
)
Public Function Validate ( _
    ShowWizard As Boolean _
) As Boolean
Dim instance As OptSetup
Dim ShowWizard As Boolean
Dim returnValue As Boolean

returnValue = instance.Validate(ShowWizard)

Parameters

ShowWizard
Boolean
Show the wizard on validation error?

Return Value

Whether optimization can be run.

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSetup Properties

Visual Basic Usage

CB Com Devkit
OptSetup Properties

The OptSetup type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Constraints | Get a Constraints enumerator, no updates to DecVars will be reflected until enumeration recreated
Decisions | Get a Decisions enumerator, no updates to DecVars will be reflected until enumeration recreated
EfficientFrontier | Access to Efficient Frontier options singleton
LastResult | The last macro result from a CBCOMDevKit method
Objectives | Get a Objective enumerator, no updates to DecVars will be reflected until enumeration recreated
Options | Access to optimization options singleton
PrimaryWorkbook | Workbook that is the target for Optimization variable storage and access
Requirements | Get a Requirement enumerator, no updates to DecVars will be reflected until enumeration recreated
ThrowErrors | Setting to determine whether to throw errors to the client app

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Constraints Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Constraints Property
Get a Constraints enumerator, no updates to DecVars will be reflected until enumeration recreated

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ConEnumerator Constraints { get; }
Public ReadOnly Property Constraints As ConEnumerator
    Get
Dim instance As OptSetup
Dim value As ConEnumerator

value = instance.Constraints

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decisions Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Decisions Property
Get a Decisions enumerator, no updates to DecVars will be reflected until enumeration recreated

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public DecEnumerator Decisions { get; }
Public ReadOnly Property Decisions As DecEnumerator
    Get
Dim instance As OptSetup
Dim value As DecEnumerator

value = instance.Decisions

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


EfficientFrontier Property

Visual Basic Usage

CB Com Devkit
OptSetup..::EfficientFrontier Property
Access to Efficient Frontier options singleton

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptEfficientFrontier EfficientFrontier { get; }
Public ReadOnly Property EfficientFrontier As OptEfficientFrontier
    Get
Dim instance As OptSetup
Dim value As OptEfficientFrontier

value = instance.EfficientFrontier

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


LastResult Property

Visual Basic Usage

CB Com Devkit
OptSetup..::LastResult Property
The last macro result from a CBCOMDevKit method

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MRWrapper LastResult { get; }
Public ReadOnly Property LastResult As MRWrapper
    Get
Dim instance As OptSetup
Dim value As MRWrapper

value = instance.LastResult

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Objectives Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Objectives Property
Get a Objective enumerator, no updates to DecVars will be reflected until enumeration recreated

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ObjEnumerator Objectives { get; }
Public ReadOnly Property Objectives As ObjEnumerator
    Get
Dim instance As OptSetup
Dim value As ObjEnumerator

value = instance.Objectives

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Options Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Options Property
Access to optimization options singleton

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptOptions Options { get; }
Public ReadOnly Property Options As OptOptions
    Get
Dim instance As OptSetup
Dim value As OptOptions

value = instance.Options

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


PrimaryWorkbook Property

Visual Basic Usage

CB Com Devkit
OptSetup..::PrimaryWorkbook Property
Workbook that is the target for Optimization variable storage and access

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string PrimaryWorkbook { get; set; }
Public Property PrimaryWorkbook As String
    Get
    Set
Dim instance As OptSetup
Dim value As String

value = instance.PrimaryWorkbook

instance.PrimaryWorkbook = value

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirements Property

Visual Basic Usage

CB Com Devkit
OptSetup..::Requirements Property
Get a Requirement enumerator, no updates to DecVars will be reflected until enumeration recreated

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ReqEnumerator Requirements { get; }
Public ReadOnly Property Requirements As ReqEnumerator
    Get
Dim instance As OptSetup
Dim value As ReqEnumerator

value = instance.Requirements

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ThrowErrors Property

Visual Basic Usage

CB Com Devkit
OptSetup..::ThrowErrors Property
Setting to determine whether to throw errors to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As OptSetup
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

See Also

OptSetup Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptShowChartType Enumeration

Visual Basic Usage

CB Com Devkit
OptShowChartType Enumeration
Show chart type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptShowChartType
Public Enumeration OptShowChartType
Dim instance As OptShowChartType

Members

Member | Description
AsDefined | Show chart windows as defined
Targets | Show only target forecast windows

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptSolution Class
Represents a single solution in an Optimization. A solution is a set of values for Decision Variables and their associated result values. Result values may be obtained for: Objectives, Requirements, Constraints.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptSolution
Public Class OptSolution
Dim instance As OptSolution

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ErrorDescription | The error description if an error occurred. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.
ErrorNumber | The CB error number if an error occurred, 0 for no error, -1010 for unexpected error. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.
GetDecVarValue(Decision) | Get the value for a Decision Variable in this solution.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetPrimaryObjectiveValue()()()() | Get the value for primary objective variable in this solution.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GetValue(OptVar, SolutionValueType) | Get the value for an optimization variable in this solution. Values may be obtained for: Decision Variables, Objectives, Requirements and Constraints. The value type argument applies only for constraints. For Constraints you can select the value from either the left hand side or right hand side of the equation. The Default is left hand side.
IsFeasible(OptVar) | Determins whether a specific optimization variable in this solution is feasible. This may be obtained for: Objectives, Requirements and Constraints.
IsSolutionFeasible | Is this solution feasible.
NewBestSolution | A new best solution. This solution was the Best solution at the time it was evaluated. This property does not have meaning for Efficient Frontier optimizations because of solution reuse across test cases.
SimTrialCount | The count of trials if a simulation was run, otherwise 1.
SolutionIndex | The zero based index for this solution. This is the index based upon the order that solutions were generated (not best order).
SolutionStatus | The solution status, including the state of the simulation if run.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSolution

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution Methods

Visual Basic Usage

CB Com Devkit
OptSolution Methods

The OptSolution type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetDecVarValue(Decision) | Get the value for a Decision Variable in this solution.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetPrimaryObjectiveValue()()()() | Get the value for primary objective variable in this solution.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GetValue(OptVar, SolutionValueType) | Get the value for an optimization variable in this solution. Values may be obtained for: Decision Variables, Objectives, Requirements and Constraints. The value type argument applies only for constraints. For Constraints you can select the value from either the left hand side or right hand side of the equation. The Default is left hand side.
IsFeasible(OptVar) | Determins whether a specific optimization variable in this solution is feasible. This may be obtained for: Objectives, Requirements and Constraints.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


GetDecVarValue Method

Visual Basic Usage

CB Com Devkit
OptSolution..::GetDecVarValue Method
Get the value for a Decision Variable in this solution.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double GetDecVarValue(
    Decision decisionVariable
)
Public Function GetDecVarValue ( _
    decisionVariable As Decision _
) As Double
Dim instance As OptSolution
Dim decisionVariable As Decision
Dim returnValue As Double

returnValue = instance.GetDecVarValue(decisionVariable)

Parameters

decisionVariable
Decision
Decision Variable.

Return Value

Decision Variable value for this solution.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


GetPrimaryObjectiveValue Method

Visual Basic Usage

CB Com Devkit
OptSolution..::GetPrimaryObjectiveValue Method
Get the value for primary objective variable in this solution.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double GetPrimaryObjectiveValue()
Public Function GetPrimaryObjectiveValue As Double
Dim instance As OptSolution
Dim returnValue As Double

returnValue = instance.GetPrimaryObjectiveValue()

Return Value

Optimization variable value for this solution.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have been run to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


GetValue Method

Visual Basic Usage

CB Com Devkit
OptSolution..::GetValue Method
Get the value for an optimization variable in this solution. Values may be obtained for: Decision Variables, Objectives, Requirements and Constraints. The value type argument applies only for constraints. For Constraints you can select the value from either the left hand side or right hand side of the equation. The Default is left hand side.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double GetValue(
    OptVar optimizationVariable,
    SolutionValueType valueType
)
Public Function GetValue ( _
    optimizationVariable As OptVar, _
    valueType As SolutionValueType _
) As Double
Dim instance As OptSolution
Dim optimizationVariable As OptVar
Dim valueType As SolutionValueType
Dim returnValue As Double

returnValue = instance.GetValue(optimizationVariable, _
    valueType)

Parameters

optimizationVariable
OptVar
Optimization variable.
valueType
SolutionValueType
Get the equation right hand side value or left hand side value. Applies to constraints.

Return Value

Optimization variable value for this solution.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IsFeasible Method

Visual Basic Usage

CB Com Devkit
OptSolution..::IsFeasible Method
Determins whether a specific optimization variable in this solution is feasible. This may be obtained for: Objectives, Requirements and Constraints.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsFeasible(
    OptVar optimizationVariable
)
Public Function IsFeasible ( _
    optimizationVariable As OptVar _
) As Boolean
Dim instance As OptSolution
Dim optimizationVariable As OptVar
Dim returnValue As Boolean

returnValue = instance.IsFeasible(optimizationVariable)

Parameters

optimizationVariable
OptVar
Optimization variable.

Return Value

Optimization variable value for this solution.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolution Properties

Visual Basic Usage

CB Com Devkit
OptSolution Properties

The OptSolution type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ErrorDescription | The error description if an error occurred. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.
ErrorNumber | The CB error number if an error occurred, 0 for no error, -1010 for unexpected error. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.
IsSolutionFeasible | Is this solution feasible.
NewBestSolution | A new best solution. This solution was the Best solution at the time it was evaluated. This property does not have meaning for Efficient Frontier optimizations because of solution reuse across test cases.
SimTrialCount | The count of trials if a simulation was run, otherwise 1.
SolutionIndex | The zero based index for this solution. This is the index based upon the order that solutions were generated (not best order).
SolutionStatus | The solution status, including the state of the simulation if run.

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ErrorDescription Property

Visual Basic Usage

CB Com Devkit
OptSolution..::ErrorDescription Property
The error description if an error occurred. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ErrorDescription { get; }
Public ReadOnly Property ErrorDescription As String
    Get
Dim instance As OptSolution
Dim value As String

value = instance.ErrorDescription

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ErrorNumber Property

Visual Basic Usage

CB Com Devkit
OptSolution..::ErrorNumber Property
The CB error number if an error occurred, 0 for no error, -1010 for unexpected error. If used the SolutionStatus should be OptSolution.OptSolutionStatus.StoppedOnError.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ErrorNumber { get; }
Public ReadOnly Property ErrorNumber As Integer
    Get
Dim instance As OptSolution
Dim value As Integer

value = instance.ErrorNumber

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IsSolutionFeasible Property

Visual Basic Usage

CB Com Devkit
OptSolution..::IsSolutionFeasible Property
Is this solution feasible.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSolutionFeasible { get; }
Public ReadOnly Property IsSolutionFeasible As Boolean
    Get
Dim instance As OptSolution
Dim value As Boolean

value = instance.IsSolutionFeasible

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


NewBestSolution Property

Visual Basic Usage

CB Com Devkit
OptSolution..::NewBestSolution Property
A new best solution. This solution was the Best solution at the time it was evaluated. This property does not have meaning for Efficient Frontier optimizations because of solution reuse across test cases.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool NewBestSolution { get; }
Public ReadOnly Property NewBestSolution As Boolean
    Get
Dim instance As OptSolution
Dim value As Boolean

value = instance.NewBestSolution

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SimTrialCount Property

Visual Basic Usage

CB Com Devkit
OptSolution..::SimTrialCount Property
The count of trials if a simulation was run, otherwise 1.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SimTrialCount { get; }
Public ReadOnly Property SimTrialCount As Integer
    Get
Dim instance As OptSolution
Dim value As Integer

value = instance.SimTrialCount

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionIndex Property

Visual Basic Usage

CB Com Devkit
OptSolution..::SolutionIndex Property
The zero based index for this solution. This is the index based upon the order that solutions were generated (not best order).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SolutionIndex { get; }
Public ReadOnly Property SolutionIndex As Integer
    Get
Dim instance As OptSolution
Dim value As Integer

value = instance.SolutionIndex

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionStatus Property

Visual Basic Usage

CB Com Devkit
OptSolution..::SolutionStatus Property
The solution status, including the state of the simulation if run.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SolutionStatus SolutionStatus { get; }
Public ReadOnly Property SolutionStatus As SolutionStatus
    Get
Dim instance As OptSolution
Dim value As SolutionStatus

value = instance.SolutionStatus

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptSolution Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptSolutionEnumerator Class
OptSolution enumerator class. This class is used to enumerate a list of solutions generated by an Optimization.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptSolutionEnumerator : VarEnumerator
Public Class OptSolutionEnumerator _
    Inherits VarEnumerator
Dim instance As OptSolutionEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSolutionEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator Methods

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator Methods

The OptSolutionEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator..::Reload Method
Sync and Reload Constraint vars

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As OptSolutionEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

True on success

Implements

IVarEnumerator..::..Reload()()()()

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSolutionEnumerator Properties

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator Properties

The OptSolutionEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Current Property

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As OptSolutionEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Item Property

Visual Basic Usage

CB Com Devkit
OptSolutionEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolution this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As OptSolution
    Get
Dim instance As OptSolutionEnumerator
Dim index As Integer
Dim value As OptSolution

value = instance(index)

Parameters

index
Int32

See Also

OptSolutionEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptSupportedStatistics Enumeration

Visual Basic Usage

CB Com Devkit
OptSupportedStatistics Enumeration
Supported Statistics

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum OptSupportedStatistics
Public Enumeration OptSupportedStatistics
Dim instance As OptSupportedStatistics

Members

Member | Description
Mean | Mean statistic
Median | Median statistic
Mode | Mode statistic
StandardDeviation | Standard Deviation statistic
Variance | Variance statistic
Skewness | Skewness statistic
Kurtosis | Kurtosis statistic
CoeffOfVariability | Coefficient of variability statistic
Minimum | Minimum statistic
Maximum | Maximum statistic
RangeWidth | Range width statistic
FinalValue | Final value statistic
Percentile | Percentile statistic
Probability | Probability statistic
Chance | Chance statistic
Certainty | Certainty statistic
Cp | Cp statistic
CpkLower | CpkLower statistic
CpkUpper | CpkUpper statistic
Cpk | Cpk statistic
Cpm | Cpm statistic
ZLSL | ZLSL statistic
ZUSL | ZUSL statistic
Zst | Zst statistic
Zlt | Zlt statistic
pNCbelow | pNCbelow statistic
pNCabove | pNCabove statistic
pNCtotal | pNCtotal statistic
PPMbelow | PPMbelow statistic
PPMabove | PPMabove statistic
PPMtotal | PPMtotal statistic
Pp | Pp statistic
PpkLower | PpkLower statistic
PpkUpper | PpkUpper statistic
Ppk | Ppk statistic
Ppm | Ppm statistic

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptVar Class
Base class for Optimization variable objects

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptVar
Public Class OptVar
Dim instance As OptVar

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment
DisplayName | Var display name
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exclude | Is var excluded
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..Constraint
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjReqBase

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar Methods

Visual Basic Usage

CB Com Devkit
OptVar Methods

The OptVar type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVar Properties

Visual Basic Usage

CB Com Devkit
OptVar Properties

The OptVar type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Comment | Var comment
DisplayName | Var display name
EFDisplayName | Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)
Exclude | Is var excluded
OptimizationStatistics | Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Comment Property

Visual Basic Usage

CB Com Devkit
OptVar..::Comment Property
Var comment

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
Dim instance As OptVar
Dim value As String

value = instance.Comment

instance.Comment = value

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


DisplayName Property

Visual Basic Usage

CB Com Devkit
OptVar..::DisplayName Property
Var display name

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
Dim instance As OptVar
Dim value As String

value = instance.DisplayName

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


EFDisplayName Property

Visual Basic Usage

CB Com Devkit
OptVar..::EFDisplayName Property
Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string EFDisplayName { get; }
Public ReadOnly Property EFDisplayName As String
    Get
Dim instance As OptVar
Dim value As String

value = instance.EFDisplayName

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Exclude Property

Visual Basic Usage

CB Com Devkit
OptVar..::Exclude Property
Is var excluded

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Exclude { get; set; }
Public Property Exclude As Boolean
    Get
    Set
Dim instance As OptVar
Dim value As Boolean

value = instance.Exclude

instance.Exclude = value

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptimizationStatistics Property

Visual Basic Usage

CB Com Devkit
OptVar..::OptimizationStatistics Property
Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptVarStatistics OptimizationStatistics { get; }
Public ReadOnly Property OptimizationStatistics As OptVarStatistics
    Get
Dim instance As OptVar
Dim value As OptVarStatistics

value = instance.OptimizationStatistics

Return Value

Optimization Variable statistics for this Optimization.

Exceptions

Exception | Condition
CBExceptionIDOptimizationHasNotBeenRun()()()() | Optimization must have beenrun to access this data

See Also

OptVar Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptVarSolutionFilter Class
The Optimization variable statistics filter. The statistics filter limits the set of solutions that affect the Optimization variable statistics.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptVarSolutionFilter
Public Class OptVarSolutionFilter
Dim instance As OptVarSolutionFilter

Members

All Members | Fields | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CountLimit | Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IncludeFeasible | Include feasible solutions
IncludeInFeasible | Include infeasible solutions
IncludeLowConfidence | Include low-confidence solutions
SortBestOrder | Use best solution order, otherwise iteration order
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVarSolutionFilter

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter Fields

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter Fields

The OptVarSolutionFilter type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CountLimit | Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count
IncludeFeasible | Include feasible solutions
IncludeInFeasible | Include infeasible solutions
IncludeLowConfidence | Include low-confidence solutions
SortBestOrder | Use best solution order, otherwise iteration order

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


CountLimit Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::CountLimit Field
Limit to count solutions, values: 0.0 all, greater than 0.0 and less than 1.0 percentage, greater than 1.0 Count

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public float CountLimit
Public CountLimit As Single
Dim instance As OptVarSolutionFilter
Dim value As Single

value = instance.CountLimit

instance.CountLimit = value

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IncludeFeasible Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::IncludeFeasible Field
Include feasible solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IncludeFeasible
Public IncludeFeasible As Boolean
Dim instance As OptVarSolutionFilter
Dim value As Boolean

value = instance.IncludeFeasible

instance.IncludeFeasible = value

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IncludeInFeasible Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::IncludeInFeasible Field
Include infeasible solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IncludeInFeasible
Public IncludeInFeasible As Boolean
Dim instance As OptVarSolutionFilter
Dim value As Boolean

value = instance.IncludeInFeasible

instance.IncludeInFeasible = value

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IncludeLowConfidence Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::IncludeLowConfidence Field
Include low-confidence solutions

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IncludeLowConfidence
Public IncludeLowConfidence As Boolean
Dim instance As OptVarSolutionFilter
Dim value As Boolean

value = instance.IncludeLowConfidence

instance.IncludeLowConfidence = value

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SortBestOrder Field

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter..::SortBestOrder Field
Use best solution order, otherwise iteration order

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SortBestOrder
Public SortBestOrder As Boolean
Dim instance As OptVarSolutionFilter
Dim value As Boolean

value = instance.SortBestOrder

instance.SortBestOrder = value

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarSolutionFilter Methods

Visual Basic Usage

CB Com Devkit
OptVarSolutionFilter Methods

The OptVarSolutionFilter type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptVarSolutionFilter Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
OptVarStatistics Class
Optimization variable statistics. These summarize the statistics for a single optimization variable in the current Optimization. They are based upon the selected statistics filter.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class OptVarStatistics
Public Class OptVarStatistics
Dim instance As OptVarStatistics

Members

All Members | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Maximum | Maximum value
Mean | Mean of values
Minimum | Minimum value
RhsStatistics | Right hand side statistics
SolutionCount | Count of solutions that affected these stats
StdDev | Standard Deviation of values
Sum | Sum of values
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Variance | Variance of values

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVarStatistics

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics Fields

Visual Basic Usage

CB Com Devkit
OptVarStatistics Fields

The OptVarStatistics type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Maximum | Maximum value
Mean | Mean of values
Minimum | Minimum value
SolutionCount | Count of solutions that affected these stats
StdDev | Standard Deviation of values
Sum | Sum of values
Variance | Variance of values

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Maximum Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Maximum Field
Maximum value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Maximum
Public Maximum As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Maximum

instance.Maximum = value

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Mean Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Mean Field
Mean of values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Mean
Public Mean As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Mean

instance.Mean = value

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Minimum Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Minimum Field
Minimum value

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Minimum
Public Minimum As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Minimum

instance.Minimum = value

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionCount Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::SolutionCount Field
Count of solutions that affected these stats

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SolutionCount
Public SolutionCount As Integer
Dim instance As OptVarStatistics
Dim value As Integer

value = instance.SolutionCount

instance.SolutionCount = value

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StdDev Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::StdDev Field
Standard Deviation of values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StdDev
Public StdDev As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.StdDev

instance.StdDev = value

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Sum Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Sum Field
Sum of values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Sum
Public Sum As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Sum

instance.Sum = value

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Variance Field

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::Variance Field
Variance of values

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Variance
Public Variance As Double
Dim instance As OptVarStatistics
Dim value As Double

value = instance.Variance

instance.Variance = value

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics Methods

Visual Basic Usage

CB Com Devkit
OptVarStatistics Methods

The OptVarStatistics type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


OptVarStatistics Properties

Visual Basic Usage

CB Com Devkit
OptVarStatistics Properties

The OptVarStatistics type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RhsStatistics | Right hand side statistics

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RhsStatistics Property

Visual Basic Usage

CB Com Devkit
OptVarStatistics..::RhsStatistics Property
Right hand side statistics

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptVarStatistics RhsStatistics { get; internal set; }
Public Property RhsStatistics As OptVarStatistics
    Get
    Friend Set
Dim instance As OptVarStatistics
Dim value As OptVarStatistics

value = instance.RhsStatistics

See Also

OptVarStatistics Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ReqEnumerator Class
Requirement var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ReqEnumerator : VarEnumerator
Public Class ReqEnumerator _
    Inherits VarEnumerator
Dim instance As ReqEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ReqEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator Methods

Visual Basic Usage

CB Com Devkit
ReqEnumerator Methods

The ReqEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Delete(Int32) | Delete the object at specified index
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Reload / resync the collection (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Delete Method

Visual Basic Usage

CB Com Devkit
ReqEnumerator..::Delete Method
Delete the object at specified index

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Delete(
    int index
)
Public Function Delete ( _
    index As Integer _
) As Boolean
Dim instance As ReqEnumerator
Dim index As Integer
Dim returnValue As Boolean

returnValue = instance.Delete(index)

Parameters

index
Int32
index to use

Return Value

Was object deleted

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
ReqEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As ReqEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ReqEnumerator Properties

Visual Basic Usage

CB Com Devkit
ReqEnumerator Properties

The ReqEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Current Property

Visual Basic Usage

CB Com Devkit
ReqEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As ReqEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Item Property

Visual Basic Usage

CB Com Devkit
ReqEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Requirement this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Requirement
    Get
Dim instance As ReqEnumerator
Dim index As Integer
Dim value As Requirement

value = instance(index)

Parameters

index
Int32

See Also

ReqEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
Requirement Class
Requirement class is responsible for handling all requirement related operations.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class Requirement : ObjReqBase
Public Class Requirement _
    Inherits ObjReqBase
Dim instance As Requirement

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
AbbreviatedName
Requirement abbreviated name in a string form (note it doesn't include the forecast)
Comment
Var comment
(Inherited from OptVar.)
Condition
Requirement condition, one of values defined in the OptConditionType enumeration Every requirement has to have Condition specified. For example, the requirement "The Mean of Forecast1 must be greater than 100.00 inch" has a Condition equal to OptConditionType.GreaterThan.
ConditionValue1
ConditionValue1 is used to define the condition in requirement equation. Here are the rules on the ConditionValue1 usage: - For all statistics except for the Probability and the Between condition, ConditionValue1 is used to represent the right side of the requirements equation. Example: "The Minimum of Forecast1 must be greater than 100.00 inch" requirement has ConditionValue1 equal to 100, - For between condition it's used to represent the lower boundary of the between range. For example, requirement "The Standard Deviation of Forecast1 must be between 1.00 and 2.00 inch" has ConditionValue1 equal to 1 and ConditionValue2 equal to 2, - For the probability it's used to define the probability percentile value in range [0, 100]. So, the requirement "A 95% Probability or more that Forecast1 is less than 15.00 inch" has ConditionValue1 equal to 95.
ConditionValue2
ConditionValue2 is used to define the upper boundary for the requirement that has Between condition, for all other requirements it's ignored. So, the requirement "The Skewness of Forecast1 must be between 0 and 0.1" has ConditionValue1 equal to 0 and ConditionValue2 equal to 0.1.
DisplayName
Var display name
(Inherited from OptVar.)
EFDisplayName
Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)
(Inherited from OptVar.)
Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Equation
The Requirement equation as a read-only value.
Exclude
Is var excluded
(Inherited from OptVar.)
Forecast
Get / Set the Requirement forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.
FullAbbreviatedName
Requirement abbreviated name in a string form, including the requirement forecast
GetHashCode()()()()
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType()()()()
Gets the Type of the current instance.
(Inherited from Object.)
MoreLessCondition
MoreLessCondition defines the more/less condition for this requirement, specified with one of the values in the OptMoreLessCondition enumeration. It is used only for Probability and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
OptimizationStatistics
Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.
(Inherited from OptVar.)
Statistic
Access to requirement Statistic. This is a statictic from the Forecast value used in the Objective equation.
StatisticValue1
StatisticValue1 defines the first statistic value for the requirement. It is used only for Percentile, Probability, Certainty and Chance statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the requirement "The 91% Percentile of Forecast1 must be less than 100.00 inch" has StatisticValue1 equal to 91. For Probability it represents the lower boundary of the specified range. For example, the requirement "A 95% Probability or more that Forecast1 is less than 20" has StatisticValue1 equal to 20. For Certainty it also represents the lower boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the first chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
StatisticValue2
StatisticValue2 defines the second statistic value for the requirement. It is used only for Probability, Certainty and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
ToString()()()()
Returns a String that represents the current Object.
(Inherited from Object.)
Validate()()()()
Validate the requirement, sets the error code if not valid

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptVar
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjReqBase
Decisioneering.CB.CBCOMDevKit.Optimization..::..Requirement

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement Methods

Visual Basic Usage

CB Com Devkit
Requirement Methods

The Requirement type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate the requirement, sets the error code if not valid

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
Requirement..::Validate Method
Validate the requirement, sets the error code if not valid

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As Requirement
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

True if OK, false if requirent is not valid

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Requirement Properties

Visual Basic Usage

CB Com Devkit
Requirement Properties

The Requirement type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
AbbreviatedName
Requirement abbreviated name in a string form (note it doesn't include the forecast)
Comment
Var comment
(Inherited from OptVar.)
Condition
Requirement condition, one of values defined in the OptConditionType enumeration Every requirement has to have Condition specified. For example, the requirement "The Mean of Forecast1 must be greater than 100.00 inch" has a Condition equal to OptConditionType.GreaterThan.
ConditionValue1
ConditionValue1 is used to define the condition in requirement equation. Here are the rules on the ConditionValue1 usage: - For all statistics except for the Probability and the Between condition, ConditionValue1 is used to represent the right side of the requirements equation. Example: "The Minimum of Forecast1 must be greater than 100.00 inch" requirement has ConditionValue1 equal to 100, - For between condition it's used to represent the lower boundary of the between range. For example, requirement "The Standard Deviation of Forecast1 must be between 1.00 and 2.00 inch" has ConditionValue1 equal to 1 and ConditionValue2 equal to 2, - For the probability it's used to define the probability percentile value in range [0, 100]. So, the requirement "A 95% Probability or more that Forecast1 is less than 15.00 inch" has ConditionValue1 equal to 95.
ConditionValue2
ConditionValue2 is used to define the upper boundary for the requirement that has Between condition, for all other requirements it's ignored. So, the requirement "The Skewness of Forecast1 must be between 0 and 0.1" has ConditionValue1 equal to 0 and ConditionValue2 equal to 0.1.
DisplayName
Var display name
(Inherited from OptVar.)
EFDisplayName
Var Efficient Frontier display name (empty string if var is not defined as Efficient Frontier)
(Inherited from OptVar.)
Equation
The Requirement equation as a read-only value.
Exclude
Is var excluded
(Inherited from OptVar.)
Forecast
Get / Set the Requirement forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.
FullAbbreviatedName
Requirement abbreviated name in a string form, including the requirement forecast
MoreLessCondition
MoreLessCondition defines the more/less condition for this requirement, specified with one of the values in the OptMoreLessCondition enumeration. It is used only for Probability and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
OptimizationStatistics
Get the statistics for this Optimization Variable. Statistics are based upon the current OptRuntime solution filter.
(Inherited from OptVar.)
Statistic
Access to requirement Statistic. This is a statictic from the Forecast value used in the Objective equation.
StatisticValue1
StatisticValue1 defines the first statistic value for the requirement. It is used only for Percentile, Probability, Certainty and Chance statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the requirement "The 91% Percentile of Forecast1 must be less than 100.00 inch" has StatisticValue1 equal to 91. For Probability it represents the lower boundary of the specified range. For example, the requirement "A 95% Probability or more that Forecast1 is less than 20" has StatisticValue1 equal to 20. For Certainty it also represents the lower boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the first chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.
StatisticValue2
StatisticValue2 defines the second statistic value for the requirement. It is used only for Probability, Certainty and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


AbbreviatedName Property

Visual Basic Usage

CB Com Devkit
Requirement..::AbbreviatedName Property
Requirement abbreviated name in a string form (note it doesn't include the forecast)

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string AbbreviatedName { get; }
Public ReadOnly Property AbbreviatedName As String
    Get
Dim instance As Requirement
Dim value As String

value = instance.AbbreviatedName

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Condition Property

Visual Basic Usage

CB Com Devkit
Requirement..::Condition Property
Requirement condition, one of values defined in the OptConditionType enumeration Every requirement has to have Condition specified. For example, the requirement "The Mean of Forecast1 must be greater than 100.00 inch" has a Condition equal to OptConditionType.GreaterThan.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptConditionType Condition { get; set; }
Public Property Condition As OptConditionType
    Get
    Set
Dim instance As Requirement
Dim value As OptConditionType

value = instance.Condition

instance.Condition = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConditionValue1 Property

Visual Basic Usage

CB Com Devkit
Requirement..::ConditionValue1 Property
ConditionValue1 is used to define the condition in requirement equation. Here are the rules on the ConditionValue1 usage: - For all statistics except for the Probability and the Between condition, ConditionValue1 is used to represent the right side of the requirements equation. Example: "The Minimum of Forecast1 must be greater than 100.00 inch" requirement has ConditionValue1 equal to 100, - For between condition it's used to represent the lower boundary of the between range. For example, requirement "The Standard Deviation of Forecast1 must be between 1.00 and 2.00 inch" has ConditionValue1 equal to 1 and ConditionValue2 equal to 2, - For the probability it's used to define the probability percentile value in range [0, 100]. So, the requirement "A 95% Probability or more that Forecast1 is less than 15.00 inch" has ConditionValue1 equal to 95.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ConditionValue1 { get; set; }
Public Property ConditionValue1 As Double
    Get
    Set
Dim instance As Requirement
Dim value As Double

value = instance.ConditionValue1

instance.ConditionValue1 = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ConditionValue2 Property

Visual Basic Usage

CB Com Devkit
Requirement..::ConditionValue2 Property
ConditionValue2 is used to define the upper boundary for the requirement that has Between condition, for all other requirements it's ignored. So, the requirement "The Skewness of Forecast1 must be between 0 and 0.1" has ConditionValue1 equal to 0 and ConditionValue2 equal to 0.1.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ConditionValue2 { get; set; }
Public Property ConditionValue2 As Double
    Get
    Set
Dim instance As Requirement
Dim value As Double

value = instance.ConditionValue2

instance.ConditionValue2 = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Equation Property

Visual Basic Usage

CB Com Devkit
Requirement..::Equation Property
The Requirement equation as a read-only value.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Equation { get; protected set; }
Public Property Equation As String
    Get
    Protected Set
Dim instance As Requirement
Dim value As String

value = instance.Equation

instance.Equation = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Forecast Property

Visual Basic Usage

CB Com Devkit
Requirement..::Forecast Property
Get / Set the Requirement forecast range. This value is an Excel range that refers to the Forecast used in the objective equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Forecast { get; set; }
Public Property Forecast As Range
    Get
    Set
Dim instance As Requirement
Dim value As Range

value = instance.Forecast

instance.Forecast = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


FullAbbreviatedName Property

Visual Basic Usage

CB Com Devkit
Requirement..::FullAbbreviatedName Property
Requirement abbreviated name in a string form, including the requirement forecast

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string FullAbbreviatedName { get; }
Public ReadOnly Property FullAbbreviatedName As String
    Get
Dim instance As Requirement
Dim value As String

value = instance.FullAbbreviatedName

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


MoreLessCondition Property

Visual Basic Usage

CB Com Devkit
Requirement..::MoreLessCondition Property
MoreLessCondition defines the more/less condition for this requirement, specified with one of the values in the OptMoreLessCondition enumeration. It is used only for Probability and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptMoreLessCondition MoreLessCondition { get; set; }
Public Property MoreLessCondition As OptMoreLessCondition
    Get
    Set
Dim instance As Requirement
Dim value As OptMoreLessCondition

value = instance.MoreLessCondition

instance.MoreLessCondition = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Statistic Property

Visual Basic Usage

CB Com Devkit
Requirement..::Statistic Property
Access to requirement Statistic. This is a statictic from the Forecast value used in the Objective equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSupportedStatistics Statistic { get; set; }
Public Property Statistic As OptSupportedStatistics
    Get
    Set
Dim instance As Requirement
Dim value As OptSupportedStatistics

value = instance.Statistic

instance.Statistic = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StatisticValue1 Property

Visual Basic Usage

CB Com Devkit
Requirement..::StatisticValue1 Property
StatisticValue1 defines the first statistic value for the requirement. It is used only for Percentile, Probability, Certainty and Chance statistics. For Percentile statistic, it represents the numeric percentile value in range [0, 100]. For example, the requirement "The 91% Percentile of Forecast1 must be less than 100.00 inch" has StatisticValue1 equal to 91. For Probability it represents the lower boundary of the specified range. For example, the requirement "A 95% Probability or more that Forecast1 is less than 20" has StatisticValue1 equal to 20. For Certainty it also represents the lower boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the first chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StatisticValue1 { get; set; }
Public Property StatisticValue1 As Double
    Get
    Set
Dim instance As Requirement
Dim value As Double

value = instance.StatisticValue1

instance.StatisticValue1 = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StatisticValue2 Property

Visual Basic Usage

CB Com Devkit
Requirement..::StatisticValue2 Property
StatisticValue2 defines the second statistic value for the requirement. It is used only for Probability, Certainty and Chance statistics. For Probability it represents the upper boundary of the specified range when Between Condition is used. For example, the requirement "A 95% Probability or less that Forecast1 is between 90 and 95" has StatisticValue2 equal to 95. For Certainty it also represents the upper boundary of the specified range. For example, the requirement "The Certainty of Forecast1 being 11 to 12 must be less than 50%" has StatisticValue1 equal to 11 and StatisticValue2 equal to 12. For Chance it represents the second chance number. For example, the requirement "A 9 in 10 Chance or more that Forecast1 is less than 50.00 inch" has StatisticValue1 equal to 9 and StatisticValue2 equal to 10.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StatisticValue2 { get; set; }
Public Property StatisticValue2 As Double
    Get
    Set
Dim instance As Requirement
Dim value As Double

value = instance.StatisticValue2

instance.StatisticValue2 = value

See Also

Requirement Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ResultsWindow Class
The OptQuest Results Window

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ResultsWindow
Public Class ResultsWindow
Dim instance As ResultsWindow

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChartType | Set / Get the current chart type in the Best Solution view.
CurrentTestPoint | The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellValue(ResultsWindow..::..GridType, Int32, Int32) | Returns the displayed value within the grid at the column and row location specified.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ShowAllSolutions | Set / Get whether all solutions should be shown on the performance chart.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
View | Set / Get the current active view.
Visible | Set / Get whether the form is visible

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..ResultsWindow

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow Methods

Visual Basic Usage

CB Com Devkit
ResultsWindow Methods

The ResultsWindow type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellValue(ResultsWindow..::..GridType, Int32, Int32) | Returns the displayed value within the grid at the column and row location specified.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


GetCellValue Method

Visual Basic Usage

CB Com Devkit
ResultsWindow..::GetCellValue Method
Returns the displayed value within the grid at the column and row location specified.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string GetCellValue(
    ResultsWindow..::..GridType gridType,
    int columnIndex,
    int rowIndex
)
Public Function GetCellValue ( _
    gridType As ResultsWindow..::..GridType, _
    columnIndex As Integer, _
    rowIndex As Integer _
) As String
Dim instance As ResultsWindow
Dim gridType As ResultsWindow..::..GridType
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim returnValue As String

returnValue = instance.GetCellValue(gridType, _
    columnIndex, rowIndex)

Parameters

gridType
ResultsWindow..::..GridType
The grid to search within.
columnIndex
Int32
The column index (1-based)
rowIndex
Int32
The row index (1-based)

Return Value

The text as displayed in the cell.

Remarks

If the gridType passed in is not on the current View, then the View is changed to ensure that the grid is visible. The column and row index values are 1-based. Row and column headers are considered within the indexes. If the Results Window is not currenlty visible, it will become visible

Exceptions

Exception | Condition
CBExceptionIDGridInvalidRowOrColumnIndex()()()() | The value of the row or column index is invalid

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow Properties

Visual Basic Usage

CB Com Devkit
ResultsWindow Properties

The ResultsWindow type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChartType | Set / Get the current chart type in the Best Solution view.
CurrentTestPoint | The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.
ShowAllSolutions | Set / Get whether all solutions should be shown on the performance chart.
View | Set / Get the current active view.
Visible | Set / Get whether the form is visible

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ChartType Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::ChartType Property
Set / Get the current chart type in the Best Solution view.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ResultsWindow..::..BestSolutionChartType ChartType { get; set; }
Public Property ChartType As ResultsWindow..::..BestSolutionChartType
    Get
    Set
Dim instance As ResultsWindow
Dim value As ResultsWindow..::..BestSolutionChartType

value = instance.ChartType

instance.ChartType = value

Remarks

If the Results Window is not currenlty visible, it will become visible. The Best Solution view will become active when setting this property.

Exceptions

Exception | Condition
CBExceptionIDOptNotInEfficientFrontierMode()()()() | Setting to EfficientFrontierChart when not running an Efficient Frontier

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


CurrentTestPoint Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::CurrentTestPoint Property
The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CurrentTestPoint { get; set; }
Public Property CurrentTestPoint As Integer
    Get
    Set
Dim instance As ResultsWindow
Dim value As Integer

value = instance.CurrentTestPoint

instance.CurrentTestPoint = value

Remarks

If the Results Window is not currenlty visible, it will become visible

Exceptions

Exception | Condition
CBExceptionIDOptNotInEfficientFrontierMode()()()() | Property not applicable when not running an Efficient Frontier

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ShowAllSolutions Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::ShowAllSolutions Property
Set / Get whether all solutions should be shown on the performance chart.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowAllSolutions { get; set; }
Public Property ShowAllSolutions As Boolean
    Get
    Set
Dim instance As ResultsWindow
Dim value As Boolean

value = instance.ShowAllSolutions

instance.ShowAllSolutions = value

Remarks

If the Results Window is not currenlty visible, it will become visible. The Best Solution view will become active when setting this property.

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


View Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::View Property
Set / Get the current active view.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ResultsWindow..::..ResultsWindowViewType View { get; set; }
Public Property View As ResultsWindow..::..ResultsWindowViewType
    Get
    Set
Dim instance As ResultsWindow
Dim value As ResultsWindow..::..ResultsWindowViewType

value = instance.View

instance.View = value

Remarks

If the Results Window is not currenlty visible, it will become visible

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Visible Property

Visual Basic Usage

CB Com Devkit
ResultsWindow..::Visible Property
Set / Get whether the form is visible

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
Dim instance As ResultsWindow
Dim value As Boolean

value = instance.Visible

instance.Visible = value

See Also

ResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.BestSolutionChartType Enumeration

Visual Basic Usage

CB Com Devkit
ResultsWindow..::..BestSolutionChartType Enumeration
Chart type within the Best Solution view enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum BestSolutionChartType
Public Enumeration BestSolutionChartType
Dim instance As ResultsWindow.BestSolutionChartType

Members

Member | Description
PerformanceChart | The Performance chart
EfficientFrontierChart | The Efficient Frontier chart

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.GridType Enumeration

Visual Basic Usage

CB Com Devkit
ResultsWindow..::..GridType Enumeration
The Grid type enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum GridType
Public Enumeration GridType
Dim instance As ResultsWindow.GridType

Members

Member | Description
Objective | The Objective grid on the Best Solution view
Requirement | The Requirement grid on the Best Solution view
Constraint | The Constraint grid on the Best Solution view
DecVar | The DecVar grid on the Best Solution view
Solutions | The Solutions grid on the Solutions Analysis view
Statistics | The Statistics grid on the Solutions Analysis view

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


ResultsWindow.ResultsWindowViewType Enumeration

Visual Basic Usage

CB Com Devkit
ResultsWindow..::..ResultsWindowViewType Enumeration
Window view enum

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum ResultsWindowViewType
Public Enumeration ResultsWindowViewType
Dim instance As ResultsWindow.ResultsWindowViewType

Members

Member | Description
BestSolution | The Best Solution view
SolutionAnalysis | The Solution Analysis view

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
RuntimeEfficientFrontier Class
Optimization runtime information for Efficient Frontier. Efficient Frontier allows users to create a variable list of constraint and requirement RHS (right hand side) values using a list of test points.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class RuntimeEfficientFrontier
Public Class RuntimeEfficientFrontier
Dim instance As RuntimeEfficientFrontier

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CurrentTestPoint | The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsEfficientFrontierRun | Has an Efficient Frontier optimization been run.
TestPointCount | The count of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, the count of actual values to test is returned.
TestPointInfo(Int32) | Get the Efficient Frontier Test Point results information. Includes best solution for that test point, feasibility and test point start index.
TestPointList | The list of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, a list of actual values to test is returned.
TestPointValue | The current Efficient Frontier Test Point value. This is the currently selected Efficient Frontier test point value. To modify after an Optimization is run, set the EFTestPointNumber.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..RuntimeEfficientFrontier

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier Methods

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier Methods

The RuntimeEfficientFrontier type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
TestPointInfo(Int32) | Get the Efficient Frontier Test Point results information. Includes best solution for that test point, feasibility and test point start index.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo Method

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::TestPointInfo Method
Get the Efficient Frontier Test Point results information. Includes best solution for that test point, feasibility and test point start index.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public TestPointInfo TestPointInfo(
    int testPointNumber
)
Public Function TestPointInfo ( _
    testPointNumber As Integer _
) As TestPointInfo
Dim instance As RuntimeEfficientFrontier
Dim testPointNumber As Integer
Dim returnValue As TestPointInfo

returnValue = instance.TestPointInfo(testPointNumber)

Parameters

testPointNumber
Int32
The Efficient Frontier Test Point number, 1 based value. Default is to use the currently selected Test Point.

Return Value

The Test Point information

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


RuntimeEfficientFrontier Properties

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier Properties

The RuntimeEfficientFrontier type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CurrentTestPoint | The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.
IsEfficientFrontierRun | Has an Efficient Frontier optimization been run.
TestPointCount | The count of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, the count of actual values to test is returned.
TestPointList | The list of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, a list of actual values to test is returned.
TestPointValue | The current Efficient Frontier Test Point value. This is the currently selected Efficient Frontier test point value. To modify after an Optimization is run, set the EFTestPointNumber.

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


CurrentTestPoint Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::CurrentTestPoint Property
The current Efficient Frontier test point number. This selects a specific Test Point. This value can only be changed after an Optimization is executed. Setting this value will effect solution lists and feasibility for all solutions based upon this new test point. The value may be from 1 to number of Test Points.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CurrentTestPoint { get; set; }
Public Property CurrentTestPoint As Integer
    Get
    Set
Dim instance As RuntimeEfficientFrontier
Dim value As Integer

value = instance.CurrentTestPoint

instance.CurrentTestPoint = value

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


IsEfficientFrontierRun Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::IsEfficientFrontierRun Property
Has an Efficient Frontier optimization been run.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsEfficientFrontierRun { get; }
Public ReadOnly Property IsEfficientFrontierRun As Boolean
    Get
Dim instance As RuntimeEfficientFrontier
Dim value As Boolean

value = instance.IsEfficientFrontierRun

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointCount Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::TestPointCount Property
The count of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, the count of actual values to test is returned.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int TestPointCount { get; }
Public ReadOnly Property TestPointCount As Integer
    Get
Dim instance As RuntimeEfficientFrontier
Dim value As Integer

value = instance.TestPointCount

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointList Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::TestPointList Property
The list of Efficient Frontier Test Points. Even if an Efficient Frontier Test Point range is currently defined, a list of actual values to test is returned.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double[] TestPointList { get; }
Public ReadOnly Property TestPointList As Double()
    Get
Dim instance As RuntimeEfficientFrontier
Dim value As Double()

value = instance.TestPointList

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointValue Property

Visual Basic Usage

CB Com Devkit
RuntimeEfficientFrontier..::TestPointValue Property
The current Efficient Frontier Test Point value. This is the currently selected Efficient Frontier test point value. To modify after an Optimization is run, set the EFTestPointNumber.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestPointValue { get; }
Public ReadOnly Property TestPointValue As Double
    Get
Dim instance As RuntimeEfficientFrontier
Dim value As Double

value = instance.TestPointValue

See Also

RuntimeEfficientFrontier Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionListSort Enumeration

Visual Basic Usage

CB Com Devkit
SolutionListSort Enumeration
Possible sort orders for solution lists

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SolutionListSort
Public Enumeration SolutionListSort
Dim instance As SolutionListSort

Members

Member | Description
IterationOrder | In order by iteration (not sorted)
BestOrder | In order by best solution first

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionStatus Enumeration

Visual Basic Usage

CB Com Devkit
SolutionStatus Enumeration
The status of the solution, including the state of the simulation if run.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SolutionStatus
Public Enumeration SolutionStatus
Dim instance As SolutionStatus

Members

Member | Description
CompletedSimulation | The simulation was completed
StoppedOnObjectiveLowConfidence | The simultion stopped because an objective low-confidence condition was detected.
NonLinearInfeasible | One or more non-linear constraints were infeasible, no simulation was run.
StoppedOnPrecision | The simulation stopped because forecast precision was met for one or more forecasts.
StoppedOnError | Stopped due an error occurring

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SolutionValueType Enumeration

Visual Basic Usage

CB Com Devkit
SolutionValueType Enumeration
Type of value for a solution equation variable

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SolutionValueType
Public Enumeration SolutionValueType
Dim instance As SolutionValueType

Members

Member | Description
Default | Default value
LeftHandSide | Left hand side equation value
RightHandSide | Right hand side equation value

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TerminationReason Enumeration

Visual Basic Usage

CB Com Devkit
TerminationReason Enumeration
Optimization Termination reasons

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum TerminationReason
Public Enumeration TerminationReason
Dim instance As TerminationReason

Members

Member | Description
NotStarted | Optimization has not started
Running | The optimization is still running
LP | Linear progression
AutoStop | The auto stop feature was activated
OptimalFound | The optimal solution has been found
MaxIterations | The maximum number of iterations has been completed
MaxTime | The maximum time has been run
UserStopped | Stopped by the user
BestFound | The best solutionhas been found
OnException | An error occurred
SolutionDatabaseFull | The solution database is full
ConstraintsInfeasible | The constraints are invalid (-1201)

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
TestPointInfo Class
Optimization Test Point Information for an Efficient frontier. This information summarizes the results for a single test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class TestPointInfo
Public Class TestPointInfo
Dim instance As TestPointInfo

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestObjectiveFeasibility | The best objective Feasibility for this test point.
BestSolution | The best solution for this test point. See TestPointInfo.BestObjectiveFeasibility for the correct Feasibility at this test point.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
StartIterationIndex | The first optimization iteration index for this test point.
TestPointIndex | The test point index (which test point from the test point list).
TestPointValue | The test point value (test point value from the test point list).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..TestPointInfo

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo Methods

Visual Basic Usage

CB Com Devkit
TestPointInfo Methods

The TestPointInfo type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointInfo Properties

Visual Basic Usage

CB Com Devkit
TestPointInfo Properties

The TestPointInfo type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestObjectiveFeasibility | The best objective Feasibility for this test point.
BestSolution | The best solution for this test point. See TestPointInfo.BestObjectiveFeasibility for the correct Feasibility at this test point.
StartIterationIndex | The first optimization iteration index for this test point.
TestPointIndex | The test point index (which test point from the test point list).
TestPointValue | The test point value (test point value from the test point list).

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BestObjectiveFeasibility Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::BestObjectiveFeasibility Property
The best objective Feasibility for this test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool BestObjectiveFeasibility { get; }
Public ReadOnly Property BestObjectiveFeasibility As Boolean
    Get
Dim instance As TestPointInfo
Dim value As Boolean

value = instance.BestObjectiveFeasibility

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


BestSolution Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::BestSolution Property
The best solution for this test point. See TestPointInfo.BestObjectiveFeasibility for the correct Feasibility at this test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public OptSolution BestSolution { get; }
Public ReadOnly Property BestSolution As OptSolution
    Get
Dim instance As TestPointInfo
Dim value As OptSolution

value = instance.BestSolution

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


StartIterationIndex Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::StartIterationIndex Property
The first optimization iteration index for this test point.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int StartIterationIndex { get; }
Public ReadOnly Property StartIterationIndex As Integer
    Get
Dim instance As TestPointInfo
Dim value As Integer

value = instance.StartIterationIndex

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointIndex Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::TestPointIndex Property
The test point index (which test point from the test point list).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int TestPointIndex { get; }
Public ReadOnly Property TestPointIndex As Integer
    Get
Dim instance As TestPointInfo
Dim value As Integer

value = instance.TestPointIndex

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


TestPointValue Property

Visual Basic Usage

CB Com Devkit
TestPointInfo..::TestPointValue Property
The test point value (test point value from the test point list).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TestPointValue { get; }
Public ReadOnly Property TestPointValue As Double
    Get
Dim instance As TestPointInfo
Dim value As Double

value = instance.TestPointValue

See Also

TestPointInfo Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
VarEnumerator Class
Base var enumerator class

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public abstract class VarEnumerator : IVarEnumerator,
    IEnumerable, IEnumerator
Public MustInherit Class VarEnumerator _
    Implements IVarEnumerator, IEnumerable, IEnumerator
Dim instance As VarEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type.
Current | Returns the current variable in the enumetration (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified.
Reload()()()() | Reload / resync the collection
Reset()()()() | Resets method required by IEnumerator (resets to first variable).
SelectedCount | Returns the count of non excluded variables of the specified type.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ConEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..DecEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ObjEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..OptSolutionEnumerator
Decisioneering.CB.CBCOMDevKit.Optimization..::..ReqEnumerator
Decisioneering.CB.CBExtension.SVS..::..CellDimensionEnumerator
Decisioneering.CB.CBExtension.SVS..::..SVSCellInfoEnumerator
Decisioneering.CB.CBExtension.SVS..::..SVSScriptEnumerator
Decisioneering.CB.CBExtension.SVS..::..SVSWorksheetInfoEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator Methods

Visual Basic Usage

CB Com Devkit
VarEnumerator Methods

The VarEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified.
Reload()()()() | Reload / resync the collection
Reset()()()() | Resets method required by IEnumerator (resets to first variable).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


GetEnumerator Method

Visual Basic Usage

CB Com Devkit
VarEnumerator..::GetEnumerator Method
Returns an enumerator for these variables.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As VarEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

variable enumerator

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


MoveNext Method

Visual Basic Usage

CB Com Devkit
VarEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As VarEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

Can we move to next collection object

Implements

IEnumerator..::..MoveNext()()()()

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
VarEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As VarEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

Was enumeration successfully reloaded

Implements

IVarEnumerator..::..Reload()()()()

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
VarEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first variable).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As VarEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


VarEnumerator Properties

Visual Basic Usage

CB Com Devkit
VarEnumerator Properties

The VarEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type.
Current | Returns the current variable in the enumetration (required by IEnumerator).
SelectedCount | Returns the count of non excluded variables of the specified type.

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Count Property

Visual Basic Usage

CB Com Devkit
VarEnumerator..::Count Property
Returns the count of variables of the specified type.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As VarEnumerator
Dim value As Integer

value = instance.Count

Implements

IVarEnumerator..::..Count

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Current Property

Visual Basic Usage

CB Com Devkit
VarEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public abstract Object Current { get; }
Public MustOverride ReadOnly Property Current As Object
    Get
Dim instance As VarEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


SelectedCount Property

Visual Basic Usage

CB Com Devkit
VarEnumerator..::SelectedCount Property
Returns the count of non excluded variables of the specified type.

Namespace: Decisioneering.CB.CBCOMDevKit.Optimization
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int SelectedCount { get; }
Public Overridable ReadOnly Property SelectedCount As Integer
    Get
Dim instance As VarEnumerator
Dim value As Integer

value = instance.SelectedCount

See Also

VarEnumerator Class
Decisioneering.CB.CBCOMDevKit.Optimization Namespace


Decisioneering.CB.CBCOMDevKit.Predictor Namespace

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBCOMDevKit.Predictor Namespace
Predictor COM and .NET Development Kit Namespace

Types

All Types | Classes | Interfaces | Enumerations
Name | Description
ARIMAModelEnumerator | List of custom ARIMA models (only for Custom ARIMA).
EventRecurrenceEnum | Event repeat type
IObjectEnumerator | Base interface for the Predictor series and method enumerators.
IPredLagEnumerator | Interface for the PredLag object Enumerator.
MethodEnumerator | List of available methods for selected series.
PredAdjustForecast | Main interface to forecast adjustment settings. Provides access to forecast adjustment settings such as percentile, rounding, adjust by value, and value range restriction.
PredAdjustForecastPercentileType | Adjust forecast percentile options.
PredAdjustForecastRoundType | Adjust forecast rounding options.
PredARIMABoxCoxTransformation | Type of Box-Cox transformation to be applied.
PredARIMAConstant | Handle constant in ARIMA equation.
PredARIMAModel | Main interface to ARIMA model.
PredARIMAModelSelection | ARIMA model selection type
PredARIMAModelSelectionCriterion | Criterion for selection among ARIMA models. Used in automatic ARIMA.
PredConfidenceType | Confidence interval options.
PredDataAttributes | Main interface for data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.
PredDateType | Recognized Date types for the date series.
PredErrorMeasureType | Error measure options.
PredEvent | The main interface to event details.
PredEventDate | The main interface to event date occurrence details.
PredEventDateEnumerator | Access to the current list of dates for the event.
PredEventEnumerator | Access to the current list of events.
PredForecastingTechnique | Forecasting technique options.
PredForecastMethodType | Forecast method options.
PredictorGridType | Statistics Grid type options
PredictorViewType | Window view options.
PredInputData | Main interface to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.
PredInputDataOrientation | Input data oriantation options.
PredLag | Lag information interface. Provides access to autocorrelation lag details.
PredLagEnumerator | List of autocorrelation lags.
PredMethods | Main interface to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.
PredMissingValueFillInMethod | Missing values missing values fill in methods.
PredNeighborInterpolationStatistic | Statistic used for neighbor interpolation.
PredOptions | Main interface to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.
PredOutlierDetectionMethod | Outlier detection methods.
PredRegression | Series regression variable settings. Provides access to regression variable settings such as independent/dependent, lag, and exclude.
PredRegressionMethod | Regression method options.
PredResults | Predictor Results. Provides an interface to access predictor run results. This is the top level interface class that provides access to objects to retrieve results available through the Predictor results form.
PredResultsPreferences | Main interface to results persistant preferences. Provides access to preferences such as confidence interval, forcast periods, statistics grid display, and error measure display.
PredResultsWindow | Interface for the Predictor Results Window. Provides access to the results window and allows setting items such as selected series and method.
PredSeasonality | Series seasonality settings. Provides access to series seasonality settings such as seasonality type and seasonal cycle.
PredSeasonalityType | Seasonality type options.
PredSeries | The main interface to input series specific settings. This provides access to information such as series name, Excel number format, seasonality and cycle, regression variable details, statistics, and series data values.
PredSeriesEnumerator | List of series in input data set.
PredSeriesResult | The main interface to output series specific settings. This provides access to information such as series name, Excel number format, forecast adjustments, statistics, and series data values.
PredSeriesResultEnumerator | List of series in results set.
PredSetup | Predictor Setup / Definition Provides an interface to define a predictor run. This is the top level interface class that provides access to objects to set and define all predictor settings available through the wizard
PredStatistics | Main interface to series statistics.


ARIMAModelEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
ARIMAModelEnumerator Class
List of custom ARIMA models (only for Custom ARIMA).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class ARIMAModelEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class ARIMAModelEnumerator _
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As ARIMAModelEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get ARIMAModel by index.
MoveNext()()()() | Declares the MoveNext ARIMAModel required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets ARIMAModel required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..ARIMAModelEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator Methods

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator Methods

The ARIMAModelEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext ARIMAModel required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets ARIMAModel required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetEnumerator Method

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As ARIMAModelEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MoveNext Method

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::MoveNext Method
Declares the MoveNext ARIMAModel required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As ARIMAModelEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As ARIMAModelEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Reset Method
Resets ARIMAModel required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As ARIMAModelEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelEnumerator Properties

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator Properties

The ARIMAModelEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Get ARIMAModel by index.

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As ARIMAModelEnumerator
Dim value As Integer

value = instance.Count

Implements

IObjectEnumerator..::..Count

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Current Property

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As ARIMAModelEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Item Property

Visual Basic Usage

CB Com Devkit
ARIMAModelEnumerator..::Item Property
Get ARIMAModel by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModel this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PredARIMAModel
    Get
Dim instance As ARIMAModelEnumerator
Dim index As Integer
Dim value As PredARIMAModel

value = instance(index)

Parameters

index
Int32

Return Value

See Also

ARIMAModelEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


EventRecurrenceEnum Enumeration

Visual Basic Usage

CB Com Devkit
EventRecurrenceEnum Enumeration
Event repeat type

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum EventRecurrenceEnum
Public Enumeration EventRecurrenceEnum
Dim instance As EventRecurrenceEnum

Members

Member | Description
RepeatsNever | Event never repeats
RepeatsEvery | Event repeats in fixed periods
RepeatsCustomDates | Event repeats in customly defined intervals

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IObjectEnumerator Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
IObjectEnumerator Interface
Base interface for the Predictor series and method enumerators.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface IObjectEnumerator : IEnumerable,
    IEnumerator
Public Interface IObjectEnumerator _
    Inherits IEnumerable, IEnumerator
Dim instance As IObjectEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of series in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IObjectEnumerator Methods

Visual Basic Usage

CB Com Devkit
IObjectEnumerator Methods

The IObjectEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

IObjectEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
IObjectEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
bool Reload()
Function Reload As Boolean
Dim instance As IObjectEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

See Also

IObjectEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IObjectEnumerator Properties

Visual Basic Usage

CB Com Devkit
IObjectEnumerator Properties

The IObjectEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of series in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IObjectEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
IObjectEnumerator..::Count Property
Returns the count of series in collection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
int Count { get; }
ReadOnly Property Count As Integer
    Get
Dim instance As IObjectEnumerator
Dim value As Integer

value = instance.Count

See Also

IObjectEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IPredLagEnumerator Interface

Visual Basic Usage

| Members | See Also
CB Com Devkit
IPredLagEnumerator Interface
Interface for the PredLag object Enumerator.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public interface IPredLagEnumerator : IEnumerable,
    IEnumerator
Public Interface IPredLagEnumerator _
    Inherits IEnumerable, IEnumerator
Dim instance As IPredLagEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of lags in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IPredLagEnumerator Methods

Visual Basic Usage

CB Com Devkit
IPredLagEnumerator Methods

The IPredLagEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
MoveNext()()()() | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Reload()()()() | Reload / resync the collection
Reset()()()() | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

IPredLagEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
IPredLagEnumerator..::Reload Method
Reload / resync the collection

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
bool Reload()
Function Reload As Boolean
Dim instance As IPredLagEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

See Also

IPredLagEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IPredLagEnumerator Properties

Visual Basic Usage

CB Com Devkit
IPredLagEnumerator Properties

The IPredLagEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of lags in collection.
Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IPredLagEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
IPredLagEnumerator..::Count Property
Returns the count of lags in collection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
int Count { get; }
ReadOnly Property Count As Integer
    Get
Dim instance As IPredLagEnumerator
Dim value As Integer

value = instance.Count

See Also

IPredLagEnumerator Interface
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
MethodEnumerator Class
List of available methods for selected series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class MethodEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class MethodEnumerator _
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As MethodEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get method by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..MethodEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator Methods

Visual Basic Usage

CB Com Devkit
MethodEnumerator Methods

The MethodEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetEnumerator Method

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As MethodEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MoveNext Method

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As MethodEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As MethodEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As MethodEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodEnumerator Properties

Visual Basic Usage

CB Com Devkit
MethodEnumerator Properties

The MethodEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Get method by index.

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As MethodEnumerator
Dim value As Integer

value = instance.Count

Implements

IObjectEnumerator..::..Count

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Current Property

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As MethodEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Item Property

Visual Basic Usage

CB Com Devkit
MethodEnumerator..::Item Property
Get method by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PredForecastMethodType
    Get
Dim instance As MethodEnumerator
Dim index As Integer
Dim value As PredForecastMethodType

value = instance(index)

Parameters

index
Int32

Return Value

See Also

MethodEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredAdjustForecast Class
Main interface to forecast adjustment settings. Provides access to forecast adjustment settings such as percentile, rounding, adjust by value, and value range restriction.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredAdjustForecast
Public Class PredAdjustForecast
Dim instance As PredAdjustForecast

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustByValue | Adjust forecast by value.
ApplyToAll()()()() | Apply forecast adjustments for this series to all series.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Percentile | Forecast adjustment percentile type. Default is P_Median.
PercentileCustomValue | Precentile adjustment custom value. This value is used if Percentile is set to P_Custom.
PercentileValue | Adjustment percentile value.
RestrictMax | Restrict forecast values to maximum value.
RestrictMin | Restrict forecast values to minimum value.
Round | Round forecast values to type. Default is NoRounding.
RoundCustomValue | Custom rounding round to digits value. This is used if Round is set to Custom.
RoundValue | Round to digits value. Default is 0 for no rounding.
SetDefault()()()() | Reset to forecast adjustment defaults - no adjustment.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredAdjustForecast

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast Methods

Visual Basic Usage

CB Com Devkit
PredAdjustForecast Methods

The PredAdjustForecast type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ApplyToAll()()()() | Apply forecast adjustments for this series to all series.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetDefault()()()() | Reset to forecast adjustment defaults - no adjustment.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ApplyToAll Method

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::ApplyToAll Method
Apply forecast adjustments for this series to all series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ApplyToAll()
Public Sub ApplyToAll
Dim instance As PredAdjustForecast

instance.ApplyToAll()

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SetDefault Method

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::SetDefault Method
Reset to forecast adjustment defaults - no adjustment.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetDefault()
Public Sub SetDefault
Dim instance As PredAdjustForecast

instance.SetDefault()

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecast Properties

Visual Basic Usage

CB Com Devkit
PredAdjustForecast Properties

The PredAdjustForecast type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustByValue | Adjust forecast by value.
Percentile | Forecast adjustment percentile type. Default is P_Median.
PercentileCustomValue | Precentile adjustment custom value. This value is used if Percentile is set to P_Custom.
PercentileValue | Adjustment percentile value.
RestrictMax | Restrict forecast values to maximum value.
RestrictMin | Restrict forecast values to minimum value.
Round | Round forecast values to type. Default is NoRounding.
RoundCustomValue | Custom rounding round to digits value. This is used if Round is set to Custom.
RoundValue | Round to digits value. Default is 0 for no rounding.

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AdjustByValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::AdjustByValue Property
Adjust forecast by value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AdjustByValue { get; set; }
Public Property AdjustByValue As Double
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.AdjustByValue

instance.AdjustByValue = value

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Percentile Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::Percentile Property
Forecast adjustment percentile type. Default is P_Median.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredAdjustForecastPercentileType Percentile { get; set; }
Public Property Percentile As PredAdjustForecastPercentileType
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As PredAdjustForecastPercentileType

value = instance.Percentile

instance.Percentile = value

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PercentileCustomValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::PercentileCustomValue Property
Precentile adjustment custom value. This value is used if Percentile is set to P_Custom.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double PercentileCustomValue { get; set; }
Public Property PercentileCustomValue As Double
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.PercentileCustomValue

instance.PercentileCustomValue = value

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PercentileValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::PercentileValue Property
Adjustment percentile value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double PercentileValue { get; }
Public ReadOnly Property PercentileValue As Double
    Get
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.PercentileValue

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RestrictMax Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::RestrictMax Property
Restrict forecast values to maximum value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RestrictMax { get; set; }
Public Property RestrictMax As Double
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.RestrictMax

instance.RestrictMax = value

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RestrictMin Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::RestrictMin Property
Restrict forecast values to minimum value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RestrictMin { get; set; }
Public Property RestrictMin As Double
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Double

value = instance.RestrictMin

instance.RestrictMin = value

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Round Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::Round Property
Round forecast values to type. Default is NoRounding.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredAdjustForecastRoundType Round { get; set; }
Public Property Round As PredAdjustForecastRoundType
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As PredAdjustForecastRoundType

value = instance.Round

instance.Round = value

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RoundCustomValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::RoundCustomValue Property
Custom rounding round to digits value. This is used if Round is set to Custom.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RoundCustomValue { get; set; }
Public Property RoundCustomValue As Integer
    Get
    Set
Dim instance As PredAdjustForecast
Dim value As Integer

value = instance.RoundCustomValue

instance.RoundCustomValue = value

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RoundValue Property

Visual Basic Usage

CB Com Devkit
PredAdjustForecast..::RoundValue Property
Round to digits value. Default is 0 for no rounding.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RoundValue { get; }
Public ReadOnly Property RoundValue As Integer
    Get
Dim instance As PredAdjustForecast
Dim value As Integer

value = instance.RoundValue

See Also

PredAdjustForecast Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecastPercentileType Enumeration

Visual Basic Usage

CB Com Devkit
PredAdjustForecastPercentileType Enumeration
Adjust forecast percentile options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredAdjustForecastPercentileType
Public Enumeration PredAdjustForecastPercentileType
Dim instance As PredAdjustForecastPercentileType

Members

Member | Description
P_Median | Median percentile forecast adjustment
P_5 | 5th percentile forecast adjustment
P_10 | 10th percentile forecast adjustment
P_20 | 20th percentile forecast adjustment
P_80 | 80th percentile forecast adjustment
P_90 | 90th percentile forecast adjustment
P_95 | 95th percentile forecast adjustment
P_Custom | Custom percentile forecast adjustment

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredAdjustForecastRoundType Enumeration

Visual Basic Usage

CB Com Devkit
PredAdjustForecastRoundType Enumeration
Adjust forecast rounding options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredAdjustForecastRoundType
Public Enumeration PredAdjustForecastRoundType
Dim instance As PredAdjustForecastRoundType

Members

Member | Description
NoRounding | No forecast adjustment rounding
Integers | Round to integers
Tens | Round to tens
Hundreds | Round to hundreds
Thousands | Round to thousands
Custom | Custom rounding

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMABoxCoxTransformation Enumeration

Visual Basic Usage

CB Com Devkit
PredARIMABoxCoxTransformation Enumeration
Type of Box-Cox transformation to be applied.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredARIMABoxCoxTransformation
Public Enumeration PredARIMABoxCoxTransformation
Dim instance As PredARIMABoxCoxTransformation

Members

Member | Description
Optimize | Use optimized value.
Logarithmic | Logarithmic transformation.
SquareRoot | Square root transformation.
CustomLambda | Custom lambda value.
None | No transformation.

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAConstant Enumeration

Visual Basic Usage

CB Com Devkit
PredARIMAConstant Enumeration
Handle constant in ARIMA equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredARIMAConstant
Public Enumeration PredARIMAConstant
Dim instance As PredARIMAConstant

Members

Member | Description
AutoSelect | AutoSelect: automatically decide to include or exclude ARIMA constant in the model.
Always | Always: include constant in the ARIMA equation.
Never | Never: exclude constant from the ARIMA equation.

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredARIMAModel Class
Main interface to ARIMA model.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredARIMAModel
Public Class PredARIMAModel
Dim instance As PredARIMAModel

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PredARIMAModel()()()() | Default constructor is internal since this class is not intended to be created as a standalone class
ARIMANonSeasonalAROrder | Non-seasonal AR order, the p component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMANonSeasonalDifference | Non-seasonal difference, the d component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMANonSeasonalMAOrder | Non-seasonal MA order, the q component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMASeasonalAROrder | Seasonal AR order, the P component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
ARIMASeasonalDifference | Seasonal difference, the D component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
ARIMASeasonalMAOrder | Seasonal MA order, the Q component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsSeasonal | Returns true if model is seasonal
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate ARIMA model settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredARIMAModel

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel Constructor

Visual Basic Usage

CB Com Devkit
PredARIMAModel Constructor
Default constructor is internal since this class is not intended to be created as a standalone class

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModel()
Public Sub New
Dim instance As New PredARIMAModel()

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel Methods

Visual Basic Usage

CB Com Devkit
PredARIMAModel Methods

The PredARIMAModel type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate ARIMA model settings.

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::Validate Method
Validate ARIMA model settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredARIMAModel
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

true if successful

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModel Properties

Visual Basic Usage

CB Com Devkit
PredARIMAModel Properties

The PredARIMAModel type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ARIMANonSeasonalAROrder | Non-seasonal AR order, the p component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMANonSeasonalDifference | Non-seasonal difference, the d component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMANonSeasonalMAOrder | Non-seasonal MA order, the q component of ARIMA(p, d, q). Has to be inside [0, 10]
ARIMASeasonalAROrder | Seasonal AR order, the P component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
ARIMASeasonalDifference | Seasonal difference, the D component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
ARIMASeasonalMAOrder | Seasonal MA order, the Q component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]
IsSeasonal | Returns true if model is seasonal

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMANonSeasonalAROrder Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMANonSeasonalAROrder Property
Non-seasonal AR order, the p component of ARIMA(p, d, q). Has to be inside [0, 10]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMANonSeasonalAROrder { get; set; }
Public Property ARIMANonSeasonalAROrder As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMANonSeasonalAROrder

instance.ARIMANonSeasonalAROrder = value

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMANonSeasonalDifference Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMANonSeasonalDifference Property
Non-seasonal difference, the d component of ARIMA(p, d, q). Has to be inside [0, 10]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMANonSeasonalDifference { get; set; }
Public Property ARIMANonSeasonalDifference As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMANonSeasonalDifference

instance.ARIMANonSeasonalDifference = value

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMANonSeasonalMAOrder Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMANonSeasonalMAOrder Property
Non-seasonal MA order, the q component of ARIMA(p, d, q). Has to be inside [0, 10]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMANonSeasonalMAOrder { get; set; }
Public Property ARIMANonSeasonalMAOrder As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMANonSeasonalMAOrder

instance.ARIMANonSeasonalMAOrder = value

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMASeasonalAROrder Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMASeasonalAROrder Property
Seasonal AR order, the P component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMASeasonalAROrder { get; set; }
Public Property ARIMASeasonalAROrder As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMASeasonalAROrder

instance.ARIMASeasonalAROrder = value

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMASeasonalDifference Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMASeasonalDifference Property
Seasonal difference, the D component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMASeasonalDifference { get; set; }
Public Property ARIMASeasonalDifference As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMASeasonalDifference

instance.ARIMASeasonalDifference = value

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMASeasonalMAOrder Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::ARIMASeasonalMAOrder Property
Seasonal MA order, the Q component of SARIMA(p, d, q)(P, D, Q). Has to be inside [0, 2]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMASeasonalMAOrder { get; set; }
Public Property ARIMASeasonalMAOrder As Integer
    Get
    Set
Dim instance As PredARIMAModel
Dim value As Integer

value = instance.ARIMASeasonalMAOrder

instance.ARIMASeasonalMAOrder = value

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IsSeasonal Property

Visual Basic Usage

CB Com Devkit
PredARIMAModel..::IsSeasonal Property
Returns true if model is seasonal

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSeasonal { get; }
Public ReadOnly Property IsSeasonal As Boolean
    Get
Dim instance As PredARIMAModel
Dim value As Boolean

value = instance.IsSeasonal

See Also

PredARIMAModel Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModelSelection Enumeration

Visual Basic Usage

CB Com Devkit
PredARIMAModelSelection Enumeration
ARIMA model selection type

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredARIMAModelSelection
Public Enumeration PredARIMAModelSelection
Dim instance As PredARIMAModelSelection

Members

Member | Description
Automatic | Automatic model selected
Custom | Custom model selected

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredARIMAModelSelectionCriterion Enumeration

Visual Basic Usage

CB Com Devkit
PredARIMAModelSelectionCriterion Enumeration
Criterion for selection among ARIMA models. Used in automatic ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredARIMAModelSelectionCriterion
Public Enumeration PredARIMAModelSelectionCriterion
Dim instance As PredARIMAModelSelectionCriterion

Members

Member | Description
BIC | Minimize Bayesian Information Criterion
AIC | Minimize Akaike Information Criterion
AICc | Minimize Corrected AIC
ErrorMeasure | Minimize selected error measure

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredConfidenceType Enumeration

Visual Basic Usage

CB Com Devkit
PredConfidenceType Enumeration
Confidence interval options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredConfidenceType
Public Enumeration PredConfidenceType
Dim instance As PredConfidenceType

Members

Member | Description
CI_None | None
CI_80 | 80% confidence interval, corresponds to 10% and 90% limits
CI_90 | 90% confidence interval, corresponds to 5% and 95% limits
CI_95 | 95% confidence interval, corresponds to 2.5% and 97.5% limits
CI_99 | 99% confidence interval, corresponds to 0.5% and 99.5% limits
CI_Custom | Custom confidence interval

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredDataAttributes Class
Main interface for data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredDataAttributes
Public Class PredDataAttributes
Dim instance As PredDataAttributes

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddEvent(String, Int32, Int32, EventRecurrenceEnum, Int32, Int32) | Adds an event to the list, returns the event index.
AdjustOutliers | Will outlier adjustment will be used.
DateType | Selected date type for the selected date series.
DeleteAllEvents()()()() | Delete allexisting events.
DeleteEvent(Int32) | Deletes the existing event.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
EventFuturePeriods | Number of future periods to include in events. Has to be a positive integer less or equal to 1000.
Events | The list of currently defined events.
FillInMissingValues | Will missing values in the input data be filled in using the selected MissingValueFillInMethod. Must be set to true to work with data that has missing values.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IncludeEvents | Defines if events are used.
InterQuartileDeviations | Number of InterQuartile deviations to use for the MedianAndIQD OutlierDetectionMethod.
MedianAbsoluteDeviations | Number of median absolute deviations to use for the MedianAndMAD OutlierDetectionMethod.
MissingValueFillInMethod | The missing value fillin method to use.
NeighborInterpolationStatistic | Statistic to use for the NeighborInterpolationMethod
NeighborsOnEitherSide | Number of neighbors to factor into the NeighborInterpolationMethod
OutlierDetectionMethod | The outlier detection method to use.
ReloadEvents | Initiate the re-loading of events.
SeasonalityType | Seasonality type. Seasonal, non-seasonal, or Autodetect to have predictor detect based on the data.
StandardDeviations | Number of standard deviations to use for the MeanAndStdDev OutlierDetectionMethod.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate all data attribute settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredDataAttributes

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes Methods

Visual Basic Usage

CB Com Devkit
PredDataAttributes Methods

The PredDataAttributes type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddEvent(String, Int32, Int32, EventRecurrenceEnum, Int32, Int32) | Adds an event to the list, returns the event index.
DeleteAllEvents()()()() | Delete allexisting events.
DeleteEvent(Int32) | Deletes the existing event.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate all data attribute settings.

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AddEvent Method

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::AddEvent Method
Adds an event to the list, returns the event index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int AddEvent(
    string Name,
    int StartDate,
    int Duration,
    EventRecurrenceEnum RepeatsType,
    int RepeatInterval,
    int SeriesIndex
)
Public Function AddEvent ( _
    Name As String, _
    StartDate As Integer, _
    Duration As Integer, _
    RepeatsType As EventRecurrenceEnum, _
    RepeatInterval As Integer, _
    SeriesIndex As Integer _
) As Integer
Dim instance As PredDataAttributes
Dim Name As String
Dim StartDate As Integer
Dim Duration As Integer
Dim RepeatsType As EventRecurrenceEnum
Dim RepeatInterval As Integer
Dim SeriesIndex As Integer
Dim returnValue As Integer

returnValue = instance.AddEvent(Name, _
    StartDate, Duration, RepeatsType, _
    RepeatInterval, SeriesIndex)

Parameters

Name
String
Name of the event
StartDate
Int32
: Start Date of the event (integer period index)
Duration
Int32
Duration of the event (in integer period units)
RepeatsType
EventRecurrenceEnum
Defines how the event repeats
RepeatInterval
Int32
Defines the event repeat interval
SeriesIndex
Int32
Optional series index for the local event

Return Value

Returns the index of a new event, -1 if error

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DeleteAllEvents Method

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::DeleteAllEvents Method
Delete allexisting events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void DeleteAllEvents()
Public Sub DeleteAllEvents
Dim instance As PredDataAttributes

instance.DeleteAllEvents()

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DeleteEvent Method

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::DeleteEvent Method
Deletes the existing event.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void DeleteEvent(
    int EventIndex
)
Public Sub DeleteEvent ( _
    EventIndex As Integer _
)
Dim instance As PredDataAttributes
Dim EventIndex As Integer

instance.DeleteEvent(EventIndex)

Parameters

EventIndex
Int32
Index of the event to be deleted

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::Validate Method
Validate all data attribute settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredDataAttributes
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

true if successful

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDataAttributes Properties

Visual Basic Usage

CB Com Devkit
PredDataAttributes Properties

The PredDataAttributes type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustOutliers | Will outlier adjustment will be used.
DateType | Selected date type for the selected date series.
EventFuturePeriods | Number of future periods to include in events. Has to be a positive integer less or equal to 1000.
Events | The list of currently defined events.
FillInMissingValues | Will missing values in the input data be filled in using the selected MissingValueFillInMethod. Must be set to true to work with data that has missing values.
IncludeEvents | Defines if events are used.
InterQuartileDeviations | Number of InterQuartile deviations to use for the MedianAndIQD OutlierDetectionMethod.
MedianAbsoluteDeviations | Number of median absolute deviations to use for the MedianAndMAD OutlierDetectionMethod.
MissingValueFillInMethod | The missing value fillin method to use.
NeighborInterpolationStatistic | Statistic to use for the NeighborInterpolationMethod
NeighborsOnEitherSide | Number of neighbors to factor into the NeighborInterpolationMethod
OutlierDetectionMethod | The outlier detection method to use.
ReloadEvents | Initiate the re-loading of events.
SeasonalityType | Seasonality type. Seasonal, non-seasonal, or Autodetect to have predictor detect based on the data.
StandardDeviations | Number of standard deviations to use for the MeanAndStdDev OutlierDetectionMethod.

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AdjustOutliers Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::AdjustOutliers Property
Will outlier adjustment will be used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool AdjustOutliers { get; set; }
Public Property AdjustOutliers As Boolean
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Boolean

value = instance.AdjustOutliers

instance.AdjustOutliers = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DateType Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::DateType Property
Selected date type for the selected date series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredDateType DateType { get; set; }
Public Property DateType As PredDateType
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredDateType

value = instance.DateType

instance.DateType = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


EventFuturePeriods Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::EventFuturePeriods Property
Number of future periods to include in events. Has to be a positive integer less or equal to 1000.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int EventFuturePeriods { get; set; }
Public Property EventFuturePeriods As Integer
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Integer

value = instance.EventFuturePeriods

instance.EventFuturePeriods = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Events Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::Events Property
The list of currently defined events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEventEnumerator Events { get; }
Public ReadOnly Property Events As PredEventEnumerator
    Get
Dim instance As PredDataAttributes
Dim value As PredEventEnumerator

value = instance.Events

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


FillInMissingValues Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::FillInMissingValues Property
Will missing values in the input data be filled in using the selected MissingValueFillInMethod. Must be set to true to work with data that has missing values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool FillInMissingValues { get; set; }
Public Property FillInMissingValues As Boolean
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Boolean

value = instance.FillInMissingValues

instance.FillInMissingValues = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IncludeEvents Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::IncludeEvents Property
Defines if events are used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IncludeEvents { get; set; }
Public Property IncludeEvents As Boolean
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Boolean

value = instance.IncludeEvents

instance.IncludeEvents = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


InterQuartileDeviations Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::InterQuartileDeviations Property
Number of InterQuartile deviations to use for the MedianAndIQD OutlierDetectionMethod.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double InterQuartileDeviations { get; set; }
Public Property InterQuartileDeviations As Double
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Double

value = instance.InterQuartileDeviations

instance.InterQuartileDeviations = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MedianAbsoluteDeviations Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::MedianAbsoluteDeviations Property
Number of median absolute deviations to use for the MedianAndMAD OutlierDetectionMethod.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MedianAbsoluteDeviations { get; set; }
Public Property MedianAbsoluteDeviations As Double
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Double

value = instance.MedianAbsoluteDeviations

instance.MedianAbsoluteDeviations = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MissingValueFillInMethod Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::MissingValueFillInMethod Property
The missing value fillin method to use.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredMissingValueFillInMethod MissingValueFillInMethod { get; set; }
Public Property MissingValueFillInMethod As PredMissingValueFillInMethod
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredMissingValueFillInMethod

value = instance.MissingValueFillInMethod

instance.MissingValueFillInMethod = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NeighborInterpolationStatistic Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::NeighborInterpolationStatistic Property
Statistic to use for the NeighborInterpolationMethod

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredNeighborInterpolationStatistic NeighborInterpolationStatistic { get; set; }
Public Property NeighborInterpolationStatistic As PredNeighborInterpolationStatistic
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredNeighborInterpolationStatistic

value = instance.NeighborInterpolationStatistic

instance.NeighborInterpolationStatistic = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NeighborsOnEitherSide Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::NeighborsOnEitherSide Property
Number of neighbors to factor into the NeighborInterpolationMethod

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NeighborsOnEitherSide { get; set; }
Public Property NeighborsOnEitherSide As Integer
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Integer

value = instance.NeighborsOnEitherSide

instance.NeighborsOnEitherSide = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


OutlierDetectionMethod Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::OutlierDetectionMethod Property
The outlier detection method to use.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredOutlierDetectionMethod OutlierDetectionMethod { get; set; }
Public Property OutlierDetectionMethod As PredOutlierDetectionMethod
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredOutlierDetectionMethod

value = instance.OutlierDetectionMethod

instance.OutlierDetectionMethod = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ReloadEvents Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::ReloadEvents Property
Initiate the re-loading of events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public static bool ReloadEvents { get; set; }
Public Shared Property ReloadEvents As Boolean
    Get
    Set
Dim value As Boolean

value = PredDataAttributes.ReloadEvents

PredDataAttributes.ReloadEvents = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SeasonalityType Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::SeasonalityType Property
Seasonality type. Seasonal, non-seasonal, or Autodetect to have predictor detect based on the data.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeasonalityType SeasonalityType { get; set; }
Public Property SeasonalityType As PredSeasonalityType
    Get
    Set
Dim instance As PredDataAttributes
Dim value As PredSeasonalityType

value = instance.SeasonalityType

instance.SeasonalityType = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


StandardDeviations Property

Visual Basic Usage

CB Com Devkit
PredDataAttributes..::StandardDeviations Property
Number of standard deviations to use for the MeanAndStdDev OutlierDetectionMethod.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StandardDeviations { get; set; }
Public Property StandardDeviations As Double
    Get
    Set
Dim instance As PredDataAttributes
Dim value As Double

value = instance.StandardDeviations

instance.StandardDeviations = value

See Also

PredDataAttributes Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredDateType Enumeration

Visual Basic Usage

CB Com Devkit
PredDateType Enumeration
Recognized Date types for the date series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredDateType
Public Enumeration PredDateType
Dim instance As PredDateType

Members

Member | Description
Periods | Period time intervals
Seconds | Second time intervals
Minutes | Minute time intervals
Hours | Hour time intervals
Days | Day time intervals
Workdays | Workday time intervals
Weeks | Week time intervals
Months | Month time intervals
Quarters | Quarter time intervals
Years | Year time intervals

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredErrorMeasureType Enumeration

Visual Basic Usage

CB Com Devkit
PredErrorMeasureType Enumeration
Error measure options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredErrorMeasureType
Public Enumeration PredErrorMeasureType
Dim instance As PredErrorMeasureType

Members

Member | Description
RMSE | Root Mean Squared Error
MAD | Mean Absolute Deviation
MAPE | Mean Absolute Percent Error

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredEvent Class
The main interface to event details.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredEvent
Public Class PredEvent
Dim instance As PredEvent

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddCustomDate(Int32) | Adds a custom date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.
CustomDates | Provides enumeration access by index into the custom dates collection
DatesOfOccurrence | Returns the string display for the list of all occurrence dates as shown in the events grid.
Duration | Defines the event duration.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Name | Defines the event name.
RemoveCustomDate(Int32) | Removes a custom start date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.
RepeatInterval | Defines the event repeat interval
RepeatsType | Defines how the event repeats.
SeriesIndex | Defines the event series index for local events, -1 for global events
SetStartDate(Int32) | Update the event start date index
StartDate | Defines the event start date.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate event settings and store event.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredEvent

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent Methods

Visual Basic Usage

CB Com Devkit
PredEvent Methods

The PredEvent type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddCustomDate(Int32) | Adds a custom date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
RemoveCustomDate(Int32) | Removes a custom start date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.
SetStartDate(Int32) | Update the event start date index
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate event settings and store event.

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AddCustomDate Method

Visual Basic Usage

CB Com Devkit
PredEvent..::AddCustomDate Method
Adds a custom date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int AddCustomDate(
    int DateInteger
)
Public Function AddCustomDate ( _
    DateInteger As Integer _
) As Integer
Dim instance As PredEvent
Dim DateInteger As Integer
Dim returnValue As Integer

returnValue = instance.AddCustomDate(DateInteger)

Parameters

DateInteger
Int32
new event date

Return Value

Returns the index of the newly added custom date, -1 if wrong date is passed in.

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RemoveCustomDate Method

Visual Basic Usage

CB Com Devkit
PredEvent..::RemoveCustomDate Method
Removes a custom start date. Should be used when EventRecurrenceEnum.RepeatsCustomDates option is selected.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void RemoveCustomDate(
    int DateInteger
)
Public Sub RemoveCustomDate ( _
    DateInteger As Integer _
)
Dim instance As PredEvent
Dim DateInteger As Integer

instance.RemoveCustomDate(DateInteger)

Parameters

DateInteger
Int32
defines event date

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SetStartDate Method

Visual Basic Usage

CB Com Devkit
PredEvent..::SetStartDate Method
Update the event start date index

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SetStartDate(
    int DateIndex
)
Public Function SetStartDate ( _
    DateIndex As Integer _
) As Boolean
Dim instance As PredEvent
Dim DateIndex As Integer
Dim returnValue As Boolean

returnValue = instance.SetStartDate(DateIndex)

Parameters

DateIndex
Int32
Index for the event start date

Return Value

Returns true if that is the valid start date

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
PredEvent..::Validate Method
Validate event settings and store event.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredEvent
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

true if successful

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEvent Properties

Visual Basic Usage

CB Com Devkit
PredEvent Properties

The PredEvent type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CustomDates | Provides enumeration access by index into the custom dates collection
DatesOfOccurrence | Returns the string display for the list of all occurrence dates as shown in the events grid.
Duration | Defines the event duration.
Name | Defines the event name.
RepeatInterval | Defines the event repeat interval
RepeatsType | Defines how the event repeats.
SeriesIndex | Defines the event series index for local events, -1 for global events
StartDate | Defines the event start date.

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CustomDates Property

Visual Basic Usage

CB Com Devkit
PredEvent..::CustomDates Property
Provides enumeration access by index into the custom dates collection

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEventDateEnumerator CustomDates { get; }
Public ReadOnly Property CustomDates As PredEventDateEnumerator
    Get
Dim instance As PredEvent
Dim value As PredEventDateEnumerator

value = instance.CustomDates

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DatesOfOccurrence Property

Visual Basic Usage

CB Com Devkit
PredEvent..::DatesOfOccurrence Property
Returns the string display for the list of all occurrence dates as shown in the events grid.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string DatesOfOccurrence { get; }
Public ReadOnly Property DatesOfOccurrence As String
    Get
Dim instance As PredEvent
Dim value As String

value = instance.DatesOfOccurrence

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Duration Property

Visual Basic Usage

CB Com Devkit
PredEvent..::Duration Property
Defines the event duration.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Duration { get; set; }
Public Property Duration As Integer
    Get
    Set
Dim instance As PredEvent
Dim value As Integer

value = instance.Duration

instance.Duration = value

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Name Property

Visual Basic Usage

CB Com Devkit
PredEvent..::Name Property
Defines the event name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Dim instance As PredEvent
Dim value As String

value = instance.Name

instance.Name = value

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RepeatInterval Property

Visual Basic Usage

CB Com Devkit
PredEvent..::RepeatInterval Property
Defines the event repeat interval

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int RepeatInterval { get; set; }
Public Property RepeatInterval As Integer
    Get
    Set
Dim instance As PredEvent
Dim value As Integer

value = instance.RepeatInterval

instance.RepeatInterval = value

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RepeatsType Property

Visual Basic Usage

CB Com Devkit
PredEvent..::RepeatsType Property
Defines how the event repeats.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public EventRecurrenceEnum RepeatsType { get; set; }
Public Property RepeatsType As EventRecurrenceEnum
    Get
    Set
Dim instance As PredEvent
Dim value As EventRecurrenceEnum

value = instance.RepeatsType

instance.RepeatsType = value

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SeriesIndex Property

Visual Basic Usage

CB Com Devkit
PredEvent..::SeriesIndex Property
Defines the event series index for local events, -1 for global events

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SeriesIndex { get; set; }
Public Property SeriesIndex As Integer
    Get
    Set
Dim instance As PredEvent
Dim value As Integer

value = instance.SeriesIndex

instance.SeriesIndex = value

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


StartDate Property

Visual Basic Usage

CB Com Devkit
PredEvent..::StartDate Property
Defines the event start date.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEventDate StartDate { get; }
Public ReadOnly Property StartDate As PredEventDate
    Get
Dim instance As PredEvent
Dim value As PredEventDate

value = instance.StartDate

See Also

PredEvent Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDate Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredEventDate Class
The main interface to event date occurrence details.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredEventDate
Public Class PredEventDate
Dim instance As PredEventDate

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DateDisplay | Returns the date display string.
DateIndex | Defines the date index.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredEventDate

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDate Methods

Visual Basic Usage

CB Com Devkit
PredEventDate Methods

The PredEventDate type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredEventDate Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDate Properties

Visual Basic Usage

CB Com Devkit
PredEventDate Properties

The PredEventDate type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DateDisplay | Returns the date display string.
DateIndex | Defines the date index.

See Also

PredEventDate Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DateDisplay Property

Visual Basic Usage

CB Com Devkit
PredEventDate..::DateDisplay Property
Returns the date display string.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string DateDisplay { get; }
Public ReadOnly Property DateDisplay As String
    Get
Dim instance As PredEventDate
Dim value As String

value = instance.DateDisplay

See Also

PredEventDate Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DateIndex Property

Visual Basic Usage

CB Com Devkit
PredEventDate..::DateIndex Property
Defines the date index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int DateIndex { get; set; }
Public Property DateIndex As Integer
    Get
    Set
Dim instance As PredEventDate
Dim value As Integer

value = instance.DateIndex

instance.DateIndex = value

See Also

PredEventDate Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredEventDateEnumerator Class
Access to the current list of dates for the event.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredEventDateEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class PredEventDateEnumerator _
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As PredEventDateEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the total number of dates
Current | Returns the current date (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get date by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid date
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first date).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredEventDateEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator Methods

The PredEventDateEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid date
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first date).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredEventDateEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MoveNext Method

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid date

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredEventDateEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredEventDateEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first date).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredEventDateEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventDateEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator Properties

The PredEventDateEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the total number of dates
Current | Returns the current date (required by IEnumerator).
Item[([( Int32])]) | Get date by index.

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Count Property
Returns the total number of dates

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredEventDateEnumerator
Dim value As Integer

value = instance.Count

Implements

IObjectEnumerator..::..Count

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Current Property

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Current Property
Returns the current date (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredEventDateEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Item Property

Visual Basic Usage

CB Com Devkit
PredEventDateEnumerator..::Item Property
Get date by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEventDate this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PredEventDate
    Get
Dim instance As PredEventDateEnumerator
Dim index As Integer
Dim value As PredEventDate

value = instance(index)

Parameters

index
Int32
the date index

Return Value

returned date

See Also

PredEventDateEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredEventEnumerator Class
Access to the current list of events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredEventEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class PredEventEnumerator _
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As PredEventEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the events count
Current | Returns the current event.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these events.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get event by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid event
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first event).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredEventEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredEventEnumerator Methods

The PredEventEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these events.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid event
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first event).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::GetEnumerator Method
Returns an enumerator for these events.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredEventEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MoveNext Method

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid event

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredEventEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredEventEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first event).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredEventEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredEventEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredEventEnumerator Properties

The PredEventEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the events count
Current | Returns the current event.
Item[([( Int32])]) | Get event by index.

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Count Property
Returns the events count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredEventEnumerator
Dim value As Integer

value = instance.Count

Implements

IObjectEnumerator..::..Count

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Current Property

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Current Property
Returns the current event.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredEventEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Item Property

Visual Basic Usage

CB Com Devkit
PredEventEnumerator..::Item Property
Get event by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredEvent this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PredEvent
    Get
Dim instance As PredEventEnumerator
Dim index As Integer
Dim value As PredEvent

value = instance(index)

Parameters

index
Int32
index of the event

Return Value

returns the requested event

See Also

PredEventEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredForecastingTechnique Enumeration

Visual Basic Usage

CB Com Devkit
PredForecastingTechnique Enumeration
Forecasting technique options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredForecastingTechnique
Public Enumeration PredForecastingTechnique
Dim instance As PredForecastingTechnique

Members

Member | Description
Standard | Standard forecasting technique
SimpleLead | Simple lead forecasting technique
WeightedLead | Weighted lead forecasting technique
Holdout | Holdout forecasting technique

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredForecastMethodType Enumeration

Visual Basic Usage

CB Com Devkit
PredForecastMethodType Enumeration
Forecast method options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredForecastMethodType
Public Enumeration PredForecastMethodType
Dim instance As PredForecastMethodType

Members

Member | Description
SingleMovingAverageMethod | Single Moving Average Method
DoubleMovingAverageMethod | Double Moving Average Method
SingleExponentialSmoothingMethod | Single Exponential Smoothing Method
DoubleExponentialSmoothingMethod | Double Exponential Smoothing Method
SeasonalAdditiveMethod | Additive Method
HoltWintersAdditiveMethod | Holt Winters Additive Method
SeasonalMultiplicativeMethod | Multiplicative Method
HoltWintersMultiplicativeMethod | Holt Winters Multiplicative Method
StandardRegressionMethod | Standard Regression Method
ForwardStepwiseRegressionMethod | Forward Stepwise Regression Method
IterativeStepwiseRegressionMethod | Iterative Stepwise Regression Method
CustomARIMAMethod | Custom ARIMA Method
AutomaticARIMAMethod | Automatic ARIMA Method

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredictorGridType Enumeration

Visual Basic Usage

CB Com Devkit
PredictorGridType Enumeration
Statistics Grid type options

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredictorGridType
Public Enumeration PredictorGridType
Dim instance As PredictorGridType

Members

Member | Description
Data | The table view grid
DataStats | The Historical Data stats grid
ForecastStats | The Forecast stats grid
ParmStats | The DecVar grid on the Best Solution view

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredictorViewType Enumeration

Visual Basic Usage

CB Com Devkit
PredictorViewType Enumeration
Window view options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredictorViewType
Public Enumeration PredictorViewType
Dim instance As PredictorViewType

Members

Member | Description
Chart | Chart view
Table | Table view

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredInputData Class
Main interface to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredInputData
Public Class PredInputData
Dim instance As PredInputData

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataOrientation | Orientation of the detected range
DetectedRange | Acces to detected range
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HasLeftHeader | HasLeftHeader is true if a detected range has left header
HasTopHeader | HasTopHeader is true if a detected range has top header
NumberOfDataPoints | Return the number of data points in detected range (series with no data are ignored)
NumberOfDataSeries | Return the number of data series in detected range
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate all input data settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredInputData

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData Methods

Visual Basic Usage

CB Com Devkit
PredInputData Methods

The PredInputData type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate all input data settings.

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
PredInputData..::Validate Method
Validate all input data settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredInputData
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

true if successful

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputData Properties

Visual Basic Usage

CB Com Devkit
PredInputData Properties

The PredInputData type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataOrientation | Orientation of the detected range
DetectedRange | Acces to detected range
HasLeftHeader | HasLeftHeader is true if a detected range has left header
HasTopHeader | HasTopHeader is true if a detected range has top header
NumberOfDataPoints | Return the number of data points in detected range (series with no data are ignored)
NumberOfDataSeries | Return the number of data series in detected range

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DataOrientation Property

Visual Basic Usage

CB Com Devkit
PredInputData..::DataOrientation Property
Orientation of the detected range

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredInputDataOrientation DataOrientation { get; set; }
Public Property DataOrientation As PredInputDataOrientation
    Get
    Set
Dim instance As PredInputData
Dim value As PredInputDataOrientation

value = instance.DataOrientation

instance.DataOrientation = value

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DetectedRange Property

Visual Basic Usage

CB Com Devkit
PredInputData..::DetectedRange Property
Acces to detected range

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range DetectedRange { get; }
Public ReadOnly Property DetectedRange As Range
    Get
Dim instance As PredInputData
Dim value As Range

value = instance.DetectedRange

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


HasLeftHeader Property

Visual Basic Usage

CB Com Devkit
PredInputData..::HasLeftHeader Property
HasLeftHeader is true if a detected range has left header

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasLeftHeader { get; set; }
Public Property HasLeftHeader As Boolean
    Get
    Set
Dim instance As PredInputData
Dim value As Boolean

value = instance.HasLeftHeader

instance.HasLeftHeader = value

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


HasTopHeader Property

Visual Basic Usage

CB Com Devkit
PredInputData..::HasTopHeader Property
HasTopHeader is true if a detected range has top header

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasTopHeader { get; set; }
Public Property HasTopHeader As Boolean
    Get
    Set
Dim instance As PredInputData
Dim value As Boolean

value = instance.HasTopHeader

instance.HasTopHeader = value

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberOfDataPoints Property

Visual Basic Usage

CB Com Devkit
PredInputData..::NumberOfDataPoints Property
Return the number of data points in detected range (series with no data are ignored)

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfDataPoints { get; }
Public ReadOnly Property NumberOfDataPoints As Integer
    Get
Dim instance As PredInputData
Dim value As Integer

value = instance.NumberOfDataPoints

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberOfDataSeries Property

Visual Basic Usage

CB Com Devkit
PredInputData..::NumberOfDataSeries Property
Return the number of data series in detected range

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfDataSeries { get; }
Public ReadOnly Property NumberOfDataSeries As Integer
    Get
Dim instance As PredInputData
Dim value As Integer

value = instance.NumberOfDataSeries

See Also

PredInputData Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredInputDataOrientation Enumeration

Visual Basic Usage

CB Com Devkit
PredInputDataOrientation Enumeration
Input data oriantation options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredInputDataOrientation
Public Enumeration PredInputDataOrientation
Dim instance As PredInputDataOrientation

Members

Member | Description
InputDataInRows | Input data in rows
InputDataInColumns | Input data in columns

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredLag Class
Lag information interface. Provides access to autocorrelation lag details.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredLag
Public Class PredLag
Dim instance As PredLag

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Autocorrelation | Autocorrelation value.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Index | Autocorrelation index offset.
Probability | Probability value.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredLag

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag Methods

Visual Basic Usage

CB Com Devkit
PredLag Methods

The PredLag type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLag Properties

Visual Basic Usage

CB Com Devkit
PredLag Properties

The PredLag type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Autocorrelation | Autocorrelation value.
Index | Autocorrelation index offset.
Probability | Probability value.

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Autocorrelation Property

Visual Basic Usage

CB Com Devkit
PredLag..::Autocorrelation Property
Autocorrelation value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Autocorrelation { get; }
Public ReadOnly Property Autocorrelation As Double
    Get
Dim instance As PredLag
Dim value As Double

value = instance.Autocorrelation

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Index Property

Visual Basic Usage

CB Com Devkit
PredLag..::Index Property
Autocorrelation index offset.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
Dim instance As PredLag
Dim value As Integer

value = instance.Index

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Probability Property

Visual Basic Usage

CB Com Devkit
PredLag..::Probability Property
Probability value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Probability { get; }
Public ReadOnly Property Probability As Double
    Get
Dim instance As PredLag
Dim value As Double

value = instance.Probability

See Also

PredLag Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredLagEnumerator Class
List of autocorrelation lags.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredLagEnumerator : IPredLagEnumerator,
    IEnumerable, IEnumerator
Public Class PredLagEnumerator _
    Implements IPredLagEnumerator, IEnumerable, IEnumerator
Dim instance As PredLagEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get lag by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredLagEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredLagEnumerator Methods

The PredLagEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredLagEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MoveNext Method

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredLagEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredLagEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

Implements

IPredLagEnumerator..::..Reload()()()()

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredLagEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredLagEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredLagEnumerator Properties

The PredLagEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Get lag by index.

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredLagEnumerator
Dim value As Integer

value = instance.Count

Implements

IPredLagEnumerator..::..Count

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Current Property

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredLagEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Item Property

Visual Basic Usage

CB Com Devkit
PredLagEnumerator..::Item Property
Get lag by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredLag this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PredLag
    Get
Dim instance As PredLagEnumerator
Dim index As Integer
Dim value As PredLag

value = instance(index)

Parameters

index
Int32

Return Value

See Also

PredLagEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredMethods Class
Main interface to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredMethods
Public Class PredMethods
Dim instance As PredMethods

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ARIMAAddModel(PredARIMAModel) | Adds an ARIMA model to the method list. Returns the index number of the model in the list if the model has been successfully added, -1 otherwise. Only valid for custom ARIMA.
ARIMAConstant | Defines if constant is used in the ARIMA equation.
ARIMAExtendedSearchAutomatic | Defines the current setting for the extended search. True if the extended search is turned on in Automatic ARIMA.
ARIMAMethods | Indicates if ARIMA methods are executed, true if ARIMA methods are selected, false otherwise.
ARIMAModels | Access to the ARIMA models currently included in the method list. Only valid for custom ARIMA.
ARIMAModelSelection | Defines the ARIMA model used (either automatic or manual)
ARIMAModelSelectionCriterion | Defines the criterion by which the best model is selected in automatic ARIMA.
ARIMARemoveModel(Int32) | Deletes the model at the specified position. Only valid for custom ARIMA.
ARIMAReplaceModel(Int32, PredARIMAModel) | Replaces the ARIMA model at the index position by the new ARIMA model. Only valid for custom ARIMA.
ARIMATransformation | Defines the transformation to be performed on the input data series.
ARIMATransformationLambda | Defines the custom lambda value for Box-Cox transformation. Has to be inside [-5, 5]
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetMethodName(PredForecastMethodType) | Get the method name
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MethodDoubleExponentialSmoothing | Will the DoubleExponentialSmoothing method be run.
MethodDoubleExponentialSmoothingAlpha | DoubleExponentialSmoothing method alpha parameter value.
MethodDoubleExponentialSmoothingBeta | DoubleExponentialSmoothing method beta parameter value.
MethodDoubleExponentialSmoothingOptimize | Will the DoubleExponentialSmoothing method automatically set parameters.
MethodDoubleMovingAverage | Will the DoubleMovingAverage method be run.
MethodDoubleMovingAverageOptimize | Will the DoubleMovingAverage method automatically set parameters.
MethodDoubleMovingAverageOrder | DoubleMovingAverage method order parameter value.
MethodHoltWintersAdditive | Will the HoltWintersAdditive method be run.
MethodHoltWintersAdditiveAlpha | HoltWintersAdditive method alpha parameter value.
MethodHoltWintersAdditiveBeta | HoltWintersAdditive method beta parameter value.
MethodHoltWintersAdditiveGamma | HoltWintersAdditive method gamma parameter value.
MethodHoltWintersAdditiveOptimize | Will the HoltWintersAdditive method automatically set parameters.
MethodHoltWintersMultiplicative | Will the HoltWintersMultiplicative method be run.
MethodHoltWintersMultiplicativeAlpha | HoltWintersMultiplicative method alpha parameter value.
MethodHoltWintersMultiplicativeBeta | HoltWintersMultiplicative method beta parameter value.
MethodHoltWintersMultiplicativeGamma | HoltWintersMultiplicative method gamma parameter value.
MethodHoltWintersMultiplicativeOptimize | Will the HoltWintersMultiplicative method automatically set parameters.
MethodSeasonalAdditive | Will the SeasonalAdditive method be run.
MethodSeasonalAdditiveAlpha | SeasonalAdditive method alpha parameter value.
MethodSeasonalAdditiveGamma | SeasonalAdditive method gamma parameter value.
MethodSeasonalAdditiveOptimize | Will the SeasonalAdditive method automatically set parameters.
MethodSeasonalMultiplicative | Will the SeasonalMultiplicative method be run.
MethodSeasonalMultiplicativeAlpha | SeasonalMultiplicative method alpha parameter value.
MethodSeasonalMultiplicativeGamma | SeasonalMultiplicative method gamma parameter value.
MethodSeasonalMultiplicativeOptimize | Will the SeasonalMultiplicative method automatically set parameters.
MethodSingleExponentialSmoothing | Will the SingleExponentialSmoothing method be run.
MethodSingleExponentialSmoothingAlpha | SingleExponentialSmoothing method alpha parameter value.
MethodSingleExponentialSmoothingOptimize | Will the SingleExponentialSmoothing method automatically set parameters.
MethodSingleMovingAverage | Will the SingleMovingAverage method be run.
MethodSingleMovingAverageOptimize | Will the SingleMovingAverage method automatically set parameters.
MethodSingleMovingAverageOrder | SingleMovingAverage method order parameter value.
NonSeasonalMethods | Will non-seasonal methods will be run.
RegressionCalculateVIF | Calculate regression VIF (variance inflation factor).
RegressionFTest | Will regression Partial F-Test significance be used.
RegressionIncludeConstant | Include constant in regression.
RegressionMethod | Choose which regression method to run. Default is Standard.
RegressionMethods | Will regression methods be run.
RegressionPartialFTestProbabilityAdd | Regression Partial F-Test probability to add value.
RegressionPartialFTestProbabilityRemove | Regression Partial F-Test probability to remove value.
RegressionRSquared | Will regression R-Squared stopping be used.
RegressionRSquaredAdjusted | Will regression Adjusted R-Squared stopping be used.
RegressionRSquaredAdjustedThreshold | Regression R-Squared stopping threshold value.
RegressionRunOnlyRegressionMethods | Run only the selected regression method for the dependent variable, skip all other selected methods.
SeasonalMethods | Will seasonal methods will be run.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate all method settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredMethods

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods Methods

Visual Basic Usage

CB Com Devkit
PredMethods Methods

The PredMethods type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ARIMAAddModel(PredARIMAModel) | Adds an ARIMA model to the method list. Returns the index number of the model in the list if the model has been successfully added, -1 otherwise. Only valid for custom ARIMA.
ARIMARemoveModel(Int32) | Deletes the model at the specified position. Only valid for custom ARIMA.
ARIMAReplaceModel(Int32, PredARIMAModel) | Replaces the ARIMA model at the index position by the new ARIMA model. Only valid for custom ARIMA.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetMethodName(PredForecastMethodType) | Get the method name
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate all method settings.

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAAddModel Method

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAAddModel Method
Adds an ARIMA model to the method list. Returns the index number of the model in the list if the model has been successfully added, -1 otherwise. Only valid for custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ARIMAAddModel(
    PredARIMAModel model
)
Public Function ARIMAAddModel ( _
    model As PredARIMAModel _
) As Integer
Dim instance As PredMethods
Dim model As PredARIMAModel
Dim returnValue As Integer

returnValue = instance.ARIMAAddModel(model)

Parameters

model
PredARIMAModel
model to be added to the list

Return Value

index of the added model

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMARemoveModel Method

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMARemoveModel Method
Deletes the model at the specified position. Only valid for custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ARIMARemoveModel(
    int index
)
Public Sub ARIMARemoveModel ( _
    index As Integer _
)
Dim instance As PredMethods
Dim index As Integer

instance.ARIMARemoveModel(index)

Parameters

index
Int32
index of model to be deleted

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAReplaceModel Method

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAReplaceModel Method
Replaces the ARIMA model at the index position by the new ARIMA model. Only valid for custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ARIMAReplaceModel(
    int index,
    PredARIMAModel model
)
Public Sub ARIMAReplaceModel ( _
    index As Integer, _
    model As PredARIMAModel _
)
Dim instance As PredMethods
Dim index As Integer
Dim model As PredARIMAModel

instance.ARIMAReplaceModel(index, model)

Parameters

index
Int32
position in model list
model
PredARIMAModel
model to be added to the list

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetMethodName Method

Visual Basic Usage

CB Com Devkit
PredMethods..::GetMethodName Method
Get the method name

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string GetMethodName(
    PredForecastMethodType method
)
Public Function GetMethodName ( _
    method As PredForecastMethodType _
) As String
Dim instance As PredMethods
Dim method As PredForecastMethodType
Dim returnValue As String

returnValue = instance.GetMethodName(method)

Parameters

method
PredForecastMethodType
Provided method type

Return Value

Method name

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
PredMethods..::Validate Method
Validate all method settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredMethods
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

true if successful

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMethods Properties

Visual Basic Usage

CB Com Devkit
PredMethods Properties

The PredMethods type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ARIMAConstant | Defines if constant is used in the ARIMA equation.
ARIMAExtendedSearchAutomatic | Defines the current setting for the extended search. True if the extended search is turned on in Automatic ARIMA.
ARIMAMethods | Indicates if ARIMA methods are executed, true if ARIMA methods are selected, false otherwise.
ARIMAModels | Access to the ARIMA models currently included in the method list. Only valid for custom ARIMA.
ARIMAModelSelection | Defines the ARIMA model used (either automatic or manual)
ARIMAModelSelectionCriterion | Defines the criterion by which the best model is selected in automatic ARIMA.
ARIMATransformation | Defines the transformation to be performed on the input data series.
ARIMATransformationLambda | Defines the custom lambda value for Box-Cox transformation. Has to be inside [-5, 5]
MethodDoubleExponentialSmoothing | Will the DoubleExponentialSmoothing method be run.
MethodDoubleExponentialSmoothingAlpha | DoubleExponentialSmoothing method alpha parameter value.
MethodDoubleExponentialSmoothingBeta | DoubleExponentialSmoothing method beta parameter value.
MethodDoubleExponentialSmoothingOptimize | Will the DoubleExponentialSmoothing method automatically set parameters.
MethodDoubleMovingAverage | Will the DoubleMovingAverage method be run.
MethodDoubleMovingAverageOptimize | Will the DoubleMovingAverage method automatically set parameters.
MethodDoubleMovingAverageOrder | DoubleMovingAverage method order parameter value.
MethodHoltWintersAdditive | Will the HoltWintersAdditive method be run.
MethodHoltWintersAdditiveAlpha | HoltWintersAdditive method alpha parameter value.
MethodHoltWintersAdditiveBeta | HoltWintersAdditive method beta parameter value.
MethodHoltWintersAdditiveGamma | HoltWintersAdditive method gamma parameter value.
MethodHoltWintersAdditiveOptimize | Will the HoltWintersAdditive method automatically set parameters.
MethodHoltWintersMultiplicative | Will the HoltWintersMultiplicative method be run.
MethodHoltWintersMultiplicativeAlpha | HoltWintersMultiplicative method alpha parameter value.
MethodHoltWintersMultiplicativeBeta | HoltWintersMultiplicative method beta parameter value.
MethodHoltWintersMultiplicativeGamma | HoltWintersMultiplicative method gamma parameter value.
MethodHoltWintersMultiplicativeOptimize | Will the HoltWintersMultiplicative method automatically set parameters.
MethodSeasonalAdditive | Will the SeasonalAdditive method be run.
MethodSeasonalAdditiveAlpha | SeasonalAdditive method alpha parameter value.
MethodSeasonalAdditiveGamma | SeasonalAdditive method gamma parameter value.
MethodSeasonalAdditiveOptimize | Will the SeasonalAdditive method automatically set parameters.
MethodSeasonalMultiplicative | Will the SeasonalMultiplicative method be run.
MethodSeasonalMultiplicativeAlpha | SeasonalMultiplicative method alpha parameter value.
MethodSeasonalMultiplicativeGamma | SeasonalMultiplicative method gamma parameter value.
MethodSeasonalMultiplicativeOptimize | Will the SeasonalMultiplicative method automatically set parameters.
MethodSingleExponentialSmoothing | Will the SingleExponentialSmoothing method be run.
MethodSingleExponentialSmoothingAlpha | SingleExponentialSmoothing method alpha parameter value.
MethodSingleExponentialSmoothingOptimize | Will the SingleExponentialSmoothing method automatically set parameters.
MethodSingleMovingAverage | Will the SingleMovingAverage method be run.
MethodSingleMovingAverageOptimize | Will the SingleMovingAverage method automatically set parameters.
MethodSingleMovingAverageOrder | SingleMovingAverage method order parameter value.
NonSeasonalMethods | Will non-seasonal methods will be run.
RegressionCalculateVIF | Calculate regression VIF (variance inflation factor).
RegressionFTest | Will regression Partial F-Test significance be used.
RegressionIncludeConstant | Include constant in regression.
RegressionMethod | Choose which regression method to run. Default is Standard.
RegressionMethods | Will regression methods be run.
RegressionPartialFTestProbabilityAdd | Regression Partial F-Test probability to add value.
RegressionPartialFTestProbabilityRemove | Regression Partial F-Test probability to remove value.
RegressionRSquared | Will regression R-Squared stopping be used.
RegressionRSquaredAdjusted | Will regression Adjusted R-Squared stopping be used.
RegressionRSquaredAdjustedThreshold | Regression R-Squared stopping threshold value.
RegressionRunOnlyRegressionMethods | Run only the selected regression method for the dependent variable, skip all other selected methods.
SeasonalMethods | Will seasonal methods will be run.

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAConstant Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAConstant Property
Defines if constant is used in the ARIMA equation.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAConstant ARIMAConstant { get; set; }
Public Property ARIMAConstant As PredARIMAConstant
    Get
    Set
Dim instance As PredMethods
Dim value As PredARIMAConstant

value = instance.ARIMAConstant

instance.ARIMAConstant = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAExtendedSearchAutomatic Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAExtendedSearchAutomatic Property
Defines the current setting for the extended search. True if the extended search is turned on in Automatic ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ARIMAExtendedSearchAutomatic { get; set; }
Public Property ARIMAExtendedSearchAutomatic As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.ARIMAExtendedSearchAutomatic

instance.ARIMAExtendedSearchAutomatic = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAMethods Property
Indicates if ARIMA methods are executed, true if ARIMA methods are selected, false otherwise.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ARIMAMethods { get; set; }
Public Property ARIMAMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.ARIMAMethods

instance.ARIMAMethods = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModels Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAModels Property
Access to the ARIMA models currently included in the method list. Only valid for custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ARIMAModelEnumerator ARIMAModels { get; }
Public ReadOnly Property ARIMAModels As ARIMAModelEnumerator
    Get
Dim instance As PredMethods
Dim value As ARIMAModelEnumerator

value = instance.ARIMAModels

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelSelection Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAModelSelection Property
Defines the ARIMA model used (either automatic or manual)

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModelSelection ARIMAModelSelection { get; set; }
Public Property ARIMAModelSelection As PredARIMAModelSelection
    Get
    Set
Dim instance As PredMethods
Dim value As PredARIMAModelSelection

value = instance.ARIMAModelSelection

instance.ARIMAModelSelection = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMAModelSelectionCriterion Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMAModelSelectionCriterion Property
Defines the criterion by which the best model is selected in automatic ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModelSelectionCriterion ARIMAModelSelectionCriterion { get; set; }
Public Property ARIMAModelSelectionCriterion As PredARIMAModelSelectionCriterion
    Get
    Set
Dim instance As PredMethods
Dim value As PredARIMAModelSelectionCriterion

value = instance.ARIMAModelSelectionCriterion

instance.ARIMAModelSelectionCriterion = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMATransformation Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMATransformation Property
Defines the transformation to be performed on the input data series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMABoxCoxTransformation ARIMATransformation { get; set; }
Public Property ARIMATransformation As PredARIMABoxCoxTransformation
    Get
    Set
Dim instance As PredMethods
Dim value As PredARIMABoxCoxTransformation

value = instance.ARIMATransformation

instance.ARIMATransformation = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ARIMATransformationLambda Property

Visual Basic Usage

CB Com Devkit
PredMethods..::ARIMATransformationLambda Property
Defines the custom lambda value for Box-Cox transformation. Has to be inside [-5, 5]

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ARIMATransformationLambda { get; set; }
Public Property ARIMATransformationLambda As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.ARIMATransformationLambda

instance.ARIMATransformationLambda = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodDoubleExponentialSmoothing Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleExponentialSmoothing Property
Will the DoubleExponentialSmoothing method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodDoubleExponentialSmoothing { get; set; }
Public Property MethodDoubleExponentialSmoothing As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodDoubleExponentialSmoothing

instance.MethodDoubleExponentialSmoothing = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodDoubleExponentialSmoothingAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleExponentialSmoothingAlpha Property
DoubleExponentialSmoothing method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodDoubleExponentialSmoothingAlpha { get; set; }
Public Property MethodDoubleExponentialSmoothingAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodDoubleExponentialSmoothingAlpha

instance.MethodDoubleExponentialSmoothingAlpha = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodDoubleExponentialSmoothingBeta Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleExponentialSmoothingBeta Property
DoubleExponentialSmoothing method beta parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodDoubleExponentialSmoothingBeta { get; set; }
Public Property MethodDoubleExponentialSmoothingBeta As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodDoubleExponentialSmoothingBeta

instance.MethodDoubleExponentialSmoothingBeta = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodDoubleExponentialSmoothingOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleExponentialSmoothingOptimize Property
Will the DoubleExponentialSmoothing method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodDoubleExponentialSmoothingOptimize { get; set; }
Public Property MethodDoubleExponentialSmoothingOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodDoubleExponentialSmoothingOptimize

instance.MethodDoubleExponentialSmoothingOptimize = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodDoubleMovingAverage Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleMovingAverage Property
Will the DoubleMovingAverage method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodDoubleMovingAverage { get; set; }
Public Property MethodDoubleMovingAverage As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodDoubleMovingAverage

instance.MethodDoubleMovingAverage = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodDoubleMovingAverageOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleMovingAverageOptimize Property
Will the DoubleMovingAverage method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodDoubleMovingAverageOptimize { get; set; }
Public Property MethodDoubleMovingAverageOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodDoubleMovingAverageOptimize

instance.MethodDoubleMovingAverageOptimize = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodDoubleMovingAverageOrder Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodDoubleMovingAverageOrder Property
DoubleMovingAverage method order parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int MethodDoubleMovingAverageOrder { get; set; }
Public Property MethodDoubleMovingAverageOrder As Integer
    Get
    Set
Dim instance As PredMethods
Dim value As Integer

value = instance.MethodDoubleMovingAverageOrder

instance.MethodDoubleMovingAverageOrder = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersAdditive Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditive Property
Will the HoltWintersAdditive method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodHoltWintersAdditive { get; set; }
Public Property MethodHoltWintersAdditive As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodHoltWintersAdditive

instance.MethodHoltWintersAdditive = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersAdditiveAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditiveAlpha Property
HoltWintersAdditive method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersAdditiveAlpha { get; set; }
Public Property MethodHoltWintersAdditiveAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersAdditiveAlpha

instance.MethodHoltWintersAdditiveAlpha = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersAdditiveBeta Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditiveBeta Property
HoltWintersAdditive method beta parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersAdditiveBeta { get; set; }
Public Property MethodHoltWintersAdditiveBeta As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersAdditiveBeta

instance.MethodHoltWintersAdditiveBeta = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersAdditiveGamma Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditiveGamma Property
HoltWintersAdditive method gamma parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersAdditiveGamma { get; set; }
Public Property MethodHoltWintersAdditiveGamma As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersAdditiveGamma

instance.MethodHoltWintersAdditiveGamma = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersAdditiveOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersAdditiveOptimize Property
Will the HoltWintersAdditive method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodHoltWintersAdditiveOptimize { get; set; }
Public Property MethodHoltWintersAdditiveOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodHoltWintersAdditiveOptimize

instance.MethodHoltWintersAdditiveOptimize = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersMultiplicative Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicative Property
Will the HoltWintersMultiplicative method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodHoltWintersMultiplicative { get; set; }
Public Property MethodHoltWintersMultiplicative As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodHoltWintersMultiplicative

instance.MethodHoltWintersMultiplicative = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersMultiplicativeAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicativeAlpha Property
HoltWintersMultiplicative method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersMultiplicativeAlpha { get; set; }
Public Property MethodHoltWintersMultiplicativeAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersMultiplicativeAlpha

instance.MethodHoltWintersMultiplicativeAlpha = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersMultiplicativeBeta Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicativeBeta Property
HoltWintersMultiplicative method beta parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersMultiplicativeBeta { get; set; }
Public Property MethodHoltWintersMultiplicativeBeta As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersMultiplicativeBeta

instance.MethodHoltWintersMultiplicativeBeta = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersMultiplicativeGamma Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicativeGamma Property
HoltWintersMultiplicative method gamma parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodHoltWintersMultiplicativeGamma { get; set; }
Public Property MethodHoltWintersMultiplicativeGamma As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodHoltWintersMultiplicativeGamma

instance.MethodHoltWintersMultiplicativeGamma = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodHoltWintersMultiplicativeOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodHoltWintersMultiplicativeOptimize Property
Will the HoltWintersMultiplicative method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodHoltWintersMultiplicativeOptimize { get; set; }
Public Property MethodHoltWintersMultiplicativeOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodHoltWintersMultiplicativeOptimize

instance.MethodHoltWintersMultiplicativeOptimize = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSeasonalAdditive Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalAdditive Property
Will the SeasonalAdditive method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSeasonalAdditive { get; set; }
Public Property MethodSeasonalAdditive As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSeasonalAdditive

instance.MethodSeasonalAdditive = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSeasonalAdditiveAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalAdditiveAlpha Property
SeasonalAdditive method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSeasonalAdditiveAlpha { get; set; }
Public Property MethodSeasonalAdditiveAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSeasonalAdditiveAlpha

instance.MethodSeasonalAdditiveAlpha = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSeasonalAdditiveGamma Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalAdditiveGamma Property
SeasonalAdditive method gamma parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSeasonalAdditiveGamma { get; set; }
Public Property MethodSeasonalAdditiveGamma As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSeasonalAdditiveGamma

instance.MethodSeasonalAdditiveGamma = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSeasonalAdditiveOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalAdditiveOptimize Property
Will the SeasonalAdditive method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSeasonalAdditiveOptimize { get; set; }
Public Property MethodSeasonalAdditiveOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSeasonalAdditiveOptimize

instance.MethodSeasonalAdditiveOptimize = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSeasonalMultiplicative Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalMultiplicative Property
Will the SeasonalMultiplicative method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSeasonalMultiplicative { get; set; }
Public Property MethodSeasonalMultiplicative As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSeasonalMultiplicative

instance.MethodSeasonalMultiplicative = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSeasonalMultiplicativeAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalMultiplicativeAlpha Property
SeasonalMultiplicative method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSeasonalMultiplicativeAlpha { get; set; }
Public Property MethodSeasonalMultiplicativeAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSeasonalMultiplicativeAlpha

instance.MethodSeasonalMultiplicativeAlpha = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSeasonalMultiplicativeGamma Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalMultiplicativeGamma Property
SeasonalMultiplicative method gamma parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSeasonalMultiplicativeGamma { get; set; }
Public Property MethodSeasonalMultiplicativeGamma As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSeasonalMultiplicativeGamma

instance.MethodSeasonalMultiplicativeGamma = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSeasonalMultiplicativeOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSeasonalMultiplicativeOptimize Property
Will the SeasonalMultiplicative method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSeasonalMultiplicativeOptimize { get; set; }
Public Property MethodSeasonalMultiplicativeOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSeasonalMultiplicativeOptimize

instance.MethodSeasonalMultiplicativeOptimize = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSingleExponentialSmoothing Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleExponentialSmoothing Property
Will the SingleExponentialSmoothing method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSingleExponentialSmoothing { get; set; }
Public Property MethodSingleExponentialSmoothing As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSingleExponentialSmoothing

instance.MethodSingleExponentialSmoothing = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSingleExponentialSmoothingAlpha Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleExponentialSmoothingAlpha Property
SingleExponentialSmoothing method alpha parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MethodSingleExponentialSmoothingAlpha { get; set; }
Public Property MethodSingleExponentialSmoothingAlpha As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.MethodSingleExponentialSmoothingAlpha

instance.MethodSingleExponentialSmoothingAlpha = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSingleExponentialSmoothingOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleExponentialSmoothingOptimize Property
Will the SingleExponentialSmoothing method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSingleExponentialSmoothingOptimize { get; set; }
Public Property MethodSingleExponentialSmoothingOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSingleExponentialSmoothingOptimize

instance.MethodSingleExponentialSmoothingOptimize = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSingleMovingAverage Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleMovingAverage Property
Will the SingleMovingAverage method be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSingleMovingAverage { get; set; }
Public Property MethodSingleMovingAverage As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSingleMovingAverage

instance.MethodSingleMovingAverage = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSingleMovingAverageOptimize Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleMovingAverageOptimize Property
Will the SingleMovingAverage method automatically set parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MethodSingleMovingAverageOptimize { get; set; }
Public Property MethodSingleMovingAverageOptimize As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.MethodSingleMovingAverageOptimize

instance.MethodSingleMovingAverageOptimize = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodSingleMovingAverageOrder Property

Visual Basic Usage

CB Com Devkit
PredMethods..::MethodSingleMovingAverageOrder Property
SingleMovingAverage method order parameter value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int MethodSingleMovingAverageOrder { get; set; }
Public Property MethodSingleMovingAverageOrder As Integer
    Get
    Set
Dim instance As PredMethods
Dim value As Integer

value = instance.MethodSingleMovingAverageOrder

instance.MethodSingleMovingAverageOrder = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NonSeasonalMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::NonSeasonalMethods Property
Will non-seasonal methods will be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool NonSeasonalMethods { get; set; }
Public Property NonSeasonalMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.NonSeasonalMethods

instance.NonSeasonalMethods = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionCalculateVIF Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionCalculateVIF Property
Calculate regression VIF (variance inflation factor).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionCalculateVIF { get; set; }
Public Property RegressionCalculateVIF As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionCalculateVIF

instance.RegressionCalculateVIF = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionFTest Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionFTest Property
Will regression Partial F-Test significance be used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionFTest { get; set; }
Public Property RegressionFTest As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionFTest

instance.RegressionFTest = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionIncludeConstant Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionIncludeConstant Property
Include constant in regression.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionIncludeConstant { get; set; }
Public Property RegressionIncludeConstant As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionIncludeConstant

instance.RegressionIncludeConstant = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionMethod Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionMethod Property
Choose which regression method to run. Default is Standard.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredRegressionMethod RegressionMethod { get; set; }
Public Property RegressionMethod As PredRegressionMethod
    Get
    Set
Dim instance As PredMethods
Dim value As PredRegressionMethod

value = instance.RegressionMethod

instance.RegressionMethod = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionMethods Property
Will regression methods be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionMethods { get; set; }
Public Property RegressionMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionMethods

instance.RegressionMethods = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionPartialFTestProbabilityAdd Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionPartialFTestProbabilityAdd Property
Regression Partial F-Test probability to add value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RegressionPartialFTestProbabilityAdd { get; set; }
Public Property RegressionPartialFTestProbabilityAdd As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.RegressionPartialFTestProbabilityAdd

instance.RegressionPartialFTestProbabilityAdd = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionPartialFTestProbabilityRemove Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionPartialFTestProbabilityRemove Property
Regression Partial F-Test probability to remove value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RegressionPartialFTestProbabilityRemove { get; set; }
Public Property RegressionPartialFTestProbabilityRemove As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.RegressionPartialFTestProbabilityRemove

instance.RegressionPartialFTestProbabilityRemove = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionRSquared Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionRSquared Property
Will regression R-Squared stopping be used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionRSquared { get; set; }
Public Property RegressionRSquared As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionRSquared

instance.RegressionRSquared = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionRSquaredAdjusted Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionRSquaredAdjusted Property
Will regression Adjusted R-Squared stopping be used.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionRSquaredAdjusted { get; set; }
Public Property RegressionRSquaredAdjusted As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionRSquaredAdjusted

instance.RegressionRSquaredAdjusted = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionRSquaredAdjustedThreshold Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionRSquaredAdjustedThreshold Property
Regression R-Squared stopping threshold value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RegressionRSquaredAdjustedThreshold { get; set; }
Public Property RegressionRSquaredAdjustedThreshold As Double
    Get
    Set
Dim instance As PredMethods
Dim value As Double

value = instance.RegressionRSquaredAdjustedThreshold

instance.RegressionRSquaredAdjustedThreshold = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RegressionRunOnlyRegressionMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::RegressionRunOnlyRegressionMethods Property
Run only the selected regression method for the dependent variable, skip all other selected methods.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool RegressionRunOnlyRegressionMethods { get; set; }
Public Property RegressionRunOnlyRegressionMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.RegressionRunOnlyRegressionMethods

instance.RegressionRunOnlyRegressionMethods = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SeasonalMethods Property

Visual Basic Usage

CB Com Devkit
PredMethods..::SeasonalMethods Property
Will seasonal methods will be run.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SeasonalMethods { get; set; }
Public Property SeasonalMethods As Boolean
    Get
    Set
Dim instance As PredMethods
Dim value As Boolean

value = instance.SeasonalMethods

instance.SeasonalMethods = value

See Also

PredMethods Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredMissingValueFillInMethod Enumeration

Visual Basic Usage

CB Com Devkit
PredMissingValueFillInMethod Enumeration
Missing values missing values fill in methods.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredMissingValueFillInMethod
Public Enumeration PredMissingValueFillInMethod
Dim instance As PredMissingValueFillInMethod

Members

Member | Description
CubicSpline | Cubic spline interpolation
NeighborInterpolation | Neighbor interpolation

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredNeighborInterpolationStatistic Enumeration

Visual Basic Usage

CB Com Devkit
PredNeighborInterpolationStatistic Enumeration
Statistic used for neighbor interpolation.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredNeighborInterpolationStatistic
Public Enumeration PredNeighborInterpolationStatistic
Dim instance As PredNeighborInterpolationStatistic

Members

Member | Description
Mean | Mean neighbor interpolation statistic
Median | Median neighbor interpolation statistic

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredOptions Class
Main interface to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredOptions
Public Class PredOptions
Dim instance As PredOptions

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ErrorMeasure | The selected error measure. Default is RMSE - Root Mean Squared Error
ForecastingTechnique | The selected forecasting technique.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Holdout | Holdout forecast period value.
SimpleLead | Simple lead forecast period value.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate all options settings.
WeightedLead | Weighted lead forecast period value.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredOptions

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions Methods

Visual Basic Usage

CB Com Devkit
PredOptions Methods

The PredOptions type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate all options settings.

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
PredOptions..::Validate Method
Validate all options settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredOptions
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

true if successful

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOptions Properties

Visual Basic Usage

CB Com Devkit
PredOptions Properties

The PredOptions type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ErrorMeasure | The selected error measure. Default is RMSE - Root Mean Squared Error
ForecastingTechnique | The selected forecasting technique.
Holdout | Holdout forecast period value.
SimpleLead | Simple lead forecast period value.
WeightedLead | Weighted lead forecast period value.

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ErrorMeasure Property

Visual Basic Usage

CB Com Devkit
PredOptions..::ErrorMeasure Property
The selected error measure. Default is RMSE - Root Mean Squared Error

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredErrorMeasureType ErrorMeasure { get; set; }
Public Property ErrorMeasure As PredErrorMeasureType
    Get
    Set
Dim instance As PredOptions
Dim value As PredErrorMeasureType

value = instance.ErrorMeasure

instance.ErrorMeasure = value

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ForecastingTechnique Property

Visual Basic Usage

CB Com Devkit
PredOptions..::ForecastingTechnique Property
The selected forecasting technique.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastingTechnique ForecastingTechnique { get; set; }
Public Property ForecastingTechnique As PredForecastingTechnique
    Get
    Set
Dim instance As PredOptions
Dim value As PredForecastingTechnique

value = instance.ForecastingTechnique

instance.ForecastingTechnique = value

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Holdout Property

Visual Basic Usage

CB Com Devkit
PredOptions..::Holdout Property
Holdout forecast period value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Holdout { get; set; }
Public Property Holdout As Integer
    Get
    Set
Dim instance As PredOptions
Dim value As Integer

value = instance.Holdout

instance.Holdout = value

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SimpleLead Property

Visual Basic Usage

CB Com Devkit
PredOptions..::SimpleLead Property
Simple lead forecast period value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SimpleLead { get; set; }
Public Property SimpleLead As Integer
    Get
    Set
Dim instance As PredOptions
Dim value As Integer

value = instance.SimpleLead

instance.SimpleLead = value

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


WeightedLead Property

Visual Basic Usage

CB Com Devkit
PredOptions..::WeightedLead Property
Weighted lead forecast period value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int WeightedLead { get; set; }
Public Property WeightedLead As Integer
    Get
    Set
Dim instance As PredOptions
Dim value As Integer

value = instance.WeightedLead

instance.WeightedLead = value

See Also

PredOptions Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredOutlierDetectionMethod Enumeration

Visual Basic Usage

CB Com Devkit
PredOutlierDetectionMethod Enumeration
Outlier detection methods.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredOutlierDetectionMethod
Public Enumeration PredOutlierDetectionMethod
Dim instance As PredOutlierDetectionMethod

Members

Member | Description
MeanAndStdDev | Mean and standard deviation outlier detection method
MedianAndMAD | Median and median absolute deviation (MAD) outlier detection method
MedianAndIQD | Median and interquartile (IQD) outlier detection method

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredRegression Class
Series regression variable settings. Provides access to regression variable settings such as independent/dependent, lag, and exclude.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredRegression
Public Class PredRegression
Dim instance As PredRegression

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exclude | Exclude this series from regression.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Independent | Is this an independent variable.
Lag | Regression variable lag value.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredRegression

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression Methods

Visual Basic Usage

CB Com Devkit
PredRegression Methods

The PredRegression type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegression Properties

Visual Basic Usage

CB Com Devkit
PredRegression Properties

The PredRegression type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Exclude | Exclude this series from regression.
Independent | Is this an independent variable.
Lag | Regression variable lag value.

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Exclude Property

Visual Basic Usage

CB Com Devkit
PredRegression..::Exclude Property
Exclude this series from regression.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Exclude { get; set; }
Public Property Exclude As Boolean
    Get
    Set
Dim instance As PredRegression
Dim value As Boolean

value = instance.Exclude

instance.Exclude = value

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Independent Property

Visual Basic Usage

CB Com Devkit
PredRegression..::Independent Property
Is this an independent variable.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Independent { get; set; }
Public Property Independent As Boolean
    Get
    Set
Dim instance As PredRegression
Dim value As Boolean

value = instance.Independent

instance.Independent = value

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Lag Property

Visual Basic Usage

CB Com Devkit
PredRegression..::Lag Property
Regression variable lag value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Lag { get; set; }
Public Property Lag As Integer
    Get
    Set
Dim instance As PredRegression
Dim value As Integer

value = instance.Lag

instance.Lag = value

See Also

PredRegression Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredRegressionMethod Enumeration

Visual Basic Usage

CB Com Devkit
PredRegressionMethod Enumeration
Regression method options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredRegressionMethod
Public Enumeration PredRegressionMethod
Dim instance As PredRegressionMethod

Members

Member | Description
Standard | Standard regression
ForwardStepwise | Forward stepwise regression
IterativeStepwise | Iterative stepwise regression

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredResults Class
Predictor Results. Provides an interface to access predictor run results. This is the top level interface class that provides access to objects to retrieve results available through the Predictor results form.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredResults
Public Class PredResults
Dim instance As PredResults

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PredResults()()()() | Predictor Results. Provides an interface to access predictor run results. This is the top level interface class that provides access to objects to retrieve results available through the Predictor results form.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Paste(Range, Boolean, Boolean, Boolean, Boolean) | Paste forecast results to worksheet.
Preferences | Interface to results preferences. This provides access to results preferences such as confidence intervals and forcast periods.
ResultsLoaded | Has predictor been sucessfully run and is there a valid results set
ResultsWindow | Interface to the Predictor Results Window. This provides access to results settings such as selected series and method. This allows updates to the results window settings.
Series | The list of result series from the predictor run. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as statistics and data values.
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredResults

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults Constructor

Visual Basic Usage

CB Com Devkit
PredResults Constructor
Predictor Results. Provides an interface to access predictor run results. This is the top level interface class that provides access to objects to retrieve results available through the Predictor results form.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredResults()
Public Sub New
Dim instance As New PredResults()

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults Methods

Visual Basic Usage

CB Com Devkit
PredResults Methods

The PredResults type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Paste(Range, Boolean, Boolean, Boolean, Boolean) | Paste forecast results to worksheet.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Paste Method

Visual Basic Usage

CB Com Devkit
PredResults..::Paste Method
Paste forecast results to worksheet.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Paste(
    Range Location,
    bool IncludeDateSeries,
    bool PasteAsAssumptions,
    bool AutoFormat,
    bool FlipDataOrientation
)
Public Sub Paste ( _
    Location As Range, _
    IncludeDateSeries As Boolean, _
    PasteAsAssumptions As Boolean, _
    AutoFormat As Boolean, _
    FlipDataOrientation As Boolean _
)
Dim instance As PredResults
Dim Location As Range
Dim IncludeDateSeries As Boolean
Dim PasteAsAssumptions As Boolean
Dim AutoFormat As Boolean
Dim FlipDataOrientation As Boolean

instance.Paste(Location, IncludeDateSeries, _
    PasteAsAssumptions, AutoFormat, _
    FlipDataOrientation)

Parameters

Location
Range
Optional location start cell for the paste range.
IncludeDateSeries
Boolean
Include the date series in paste.
PasteAsAssumptions
Boolean
Define assumptions for pasted results.
AutoFormat
Boolean
Format paste range.
FlipDataOrientation
Boolean
Change the pasted orientation to be oposite from input data.

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResults Properties

Visual Basic Usage

CB Com Devkit
PredResults Properties

The PredResults type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Preferences | Interface to results preferences. This provides access to results preferences such as confidence intervals and forcast periods.
ResultsLoaded | Has predictor been sucessfully run and is there a valid results set
ResultsWindow | Interface to the Predictor Results Window. This provides access to results settings such as selected series and method. This allows updates to the results window settings.
Series | The list of result series from the predictor run. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as statistics and data values.
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Preferences Property

Visual Basic Usage

CB Com Devkit
PredResults..::Preferences Property
Interface to results preferences. This provides access to results preferences such as confidence intervals and forcast periods.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredResultsPreferences Preferences { get; }
Public ReadOnly Property Preferences As PredResultsPreferences
    Get
Dim instance As PredResults
Dim value As PredResultsPreferences

value = instance.Preferences

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ResultsLoaded Property

Visual Basic Usage

CB Com Devkit
PredResults..::ResultsLoaded Property
Has predictor been sucessfully run and is there a valid results set

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ResultsLoaded { get; }
Public ReadOnly Property ResultsLoaded As Boolean
    Get
Dim instance As PredResults
Dim value As Boolean

value = instance.ResultsLoaded

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ResultsWindow Property

Visual Basic Usage

CB Com Devkit
PredResults..::ResultsWindow Property
Interface to the Predictor Results Window. This provides access to results settings such as selected series and method. This allows updates to the results window settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredResultsWindow ResultsWindow { get; }
Public ReadOnly Property ResultsWindow As PredResultsWindow
    Get
Dim instance As PredResults
Dim value As PredResultsWindow

value = instance.ResultsWindow

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Series Property

Visual Basic Usage

CB Com Devkit
PredResults..::Series Property
The list of result series from the predictor run. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as statistics and data values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeriesResultEnumerator Series { get; }
Public ReadOnly Property Series As PredSeriesResultEnumerator
    Get
Dim instance As PredResults
Dim value As PredSeriesResultEnumerator

value = instance.Series

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ThrowErrors Property

Visual Basic Usage

CB Com Devkit
PredResults..::ThrowErrors Property
Setting to determine whether to throw errors to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As PredResults
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ThrowWarningsAsErrors Property

Visual Basic Usage

CB Com Devkit
PredResults..::ThrowWarningsAsErrors Property
Setting to determine whether to throw warnings to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowWarningsAsErrors { get; set; }
Public Property ThrowWarningsAsErrors As Boolean
    Get
    Set
Dim instance As PredResults
Dim value As Boolean

value = instance.ThrowWarningsAsErrors

instance.ThrowWarningsAsErrors = value

See Also

PredResults Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredResultsPreferences Class
Main interface to results persistant preferences. Provides access to preferences such as confidence interval, forcast periods, statistics grid display, and error measure display.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredResultsPreferences
Public Class PredResultsPreferences
Dim instance As PredResultsPreferences

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ConfidenceInterval | The selected confidence interval.
ConfidenceLower | Lower confidence interval percentage value.
ConfidenceUpper | Upper confidence interval percentage value.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ForecastPeriods | Periods to forecast.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HighlightEvents | Highlight events. This determines if the events are highlighted in the results display.
HighlightScreenedData | Highlight screened data. This determines if the missing and adjusted values are highlighted in the results display.
HighlightSeasonality | Highlight seasonality. This determines if the seasonal cycle is highlighted in the results display.
PasteShowExternalDataSubmitWarning | On forecast values paste, do we show a warning that a user must submit (accept) or refresh (undo) after the paste of Smart View data.
PasteShowOverwriteWarning | On forecast values paste, do we show a data overwrite warning.
SetCustomConfidenceInterval(Double, Double) | Set the custom confidence interval values.
ShowAllErrorMeasures | Show all error measures in statistics grid.
ShowStatistics | Show statistics grid on results window.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredResultsPreferences

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences Methods

Visual Basic Usage

CB Com Devkit
PredResultsPreferences Methods

The PredResultsPreferences type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SetCustomConfidenceInterval(Double, Double) | Set the custom confidence interval values.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SetCustomConfidenceInterval Method

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::SetCustomConfidenceInterval Method
Set the custom confidence interval values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SetCustomConfidenceInterval(
    double lower,
    double upper
)
Public Sub SetCustomConfidenceInterval ( _
    lower As Double, _
    upper As Double _
)
Dim instance As PredResultsPreferences
Dim lower As Double
Dim upper As Double

instance.SetCustomConfidenceInterval(lower, _
    upper)

Parameters

lower
Double
Lower confidence interval percentage value.
upper
Double
Upper confidence interval percentage value.

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsPreferences Properties

Visual Basic Usage

CB Com Devkit
PredResultsPreferences Properties

The PredResultsPreferences type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ConfidenceInterval | The selected confidence interval.
ConfidenceLower | Lower confidence interval percentage value.
ConfidenceUpper | Upper confidence interval percentage value.
ForecastPeriods | Periods to forecast.
HighlightEvents | Highlight events. This determines if the events are highlighted in the results display.
HighlightScreenedData | Highlight screened data. This determines if the missing and adjusted values are highlighted in the results display.
HighlightSeasonality | Highlight seasonality. This determines if the seasonal cycle is highlighted in the results display.
PasteShowExternalDataSubmitWarning | On forecast values paste, do we show a warning that a user must submit (accept) or refresh (undo) after the paste of Smart View data.
PasteShowOverwriteWarning | On forecast values paste, do we show a data overwrite warning.
ShowAllErrorMeasures | Show all error measures in statistics grid.
ShowStatistics | Show statistics grid on results window.

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ConfidenceInterval Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ConfidenceInterval Property
The selected confidence interval.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredConfidenceType ConfidenceInterval { get; set; }
Public Property ConfidenceInterval As PredConfidenceType
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As PredConfidenceType

value = instance.ConfidenceInterval

instance.ConfidenceInterval = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ConfidenceLower Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ConfidenceLower Property
Lower confidence interval percentage value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ConfidenceLower { get; }
Public ReadOnly Property ConfidenceLower As Double
    Get
Dim instance As PredResultsPreferences
Dim value As Double

value = instance.ConfidenceLower

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ConfidenceUpper Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ConfidenceUpper Property
Upper confidence interval percentage value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double ConfidenceUpper { get; }
Public ReadOnly Property ConfidenceUpper As Double
    Get
Dim instance As PredResultsPreferences
Dim value As Double

value = instance.ConfidenceUpper

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ForecastPeriods Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ForecastPeriods Property
Periods to forecast.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int ForecastPeriods { get; set; }
Public Property ForecastPeriods As Integer
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Integer

value = instance.ForecastPeriods

instance.ForecastPeriods = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


HighlightEvents Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::HighlightEvents Property
Highlight events. This determines if the events are highlighted in the results display.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HighlightEvents { get; set; }
Public Property HighlightEvents As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.HighlightEvents

instance.HighlightEvents = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


HighlightScreenedData Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::HighlightScreenedData Property
Highlight screened data. This determines if the missing and adjusted values are highlighted in the results display.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HighlightScreenedData { get; set; }
Public Property HighlightScreenedData As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.HighlightScreenedData

instance.HighlightScreenedData = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


HighlightSeasonality Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::HighlightSeasonality Property
Highlight seasonality. This determines if the seasonal cycle is highlighted in the results display.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HighlightSeasonality { get; set; }
Public Property HighlightSeasonality As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.HighlightSeasonality

instance.HighlightSeasonality = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PasteShowExternalDataSubmitWarning Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::PasteShowExternalDataSubmitWarning Property
On forecast values paste, do we show a warning that a user must submit (accept) or refresh (undo) after the paste of Smart View data.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool PasteShowExternalDataSubmitWarning { get; set; }
Public Property PasteShowExternalDataSubmitWarning As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.PasteShowExternalDataSubmitWarning

instance.PasteShowExternalDataSubmitWarning = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PasteShowOverwriteWarning Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::PasteShowOverwriteWarning Property
On forecast values paste, do we show a data overwrite warning.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool PasteShowOverwriteWarning { get; set; }
Public Property PasteShowOverwriteWarning As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.PasteShowOverwriteWarning

instance.PasteShowOverwriteWarning = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ShowAllErrorMeasures Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ShowAllErrorMeasures Property
Show all error measures in statistics grid.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowAllErrorMeasures { get; set; }
Public Property ShowAllErrorMeasures As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.ShowAllErrorMeasures

instance.ShowAllErrorMeasures = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ShowStatistics Property

Visual Basic Usage

CB Com Devkit
PredResultsPreferences..::ShowStatistics Property
Show statistics grid on results window.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowStatistics { get; set; }
Public Property ShowStatistics As Boolean
    Get
    Set
Dim instance As PredResultsPreferences
Dim value As Boolean

value = instance.ShowStatistics

instance.ShowStatistics = value

See Also

PredResultsPreferences Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredResultsWindow Class
Interface for the Predictor Results Window. Provides access to the results window and allows setting items such as selected series and method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredResultsWindow
Public Class PredResultsWindow
Dim instance As PredResultsWindow

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CurrentARIMAMethod | Currently selected ARIMA model for currently selected series Valid only for Custom ARIMA.
CurrentARIMAMethods | Returns the list of all ARIMA models for currently selected series.
CurrentMethod | Currently selected method.
CurrentMethodDisplay | Currently selected method display name.
CurrentMethodRank | Currently selected method by method rank.
CurrentMethods | List of currently available methods in rank order.
CurrentSeries | The currently selected series.
CurrentSeriesDisplay | Current selected series display name.
DisplayedScreenedValues | Number of screened values for current series and method.
DisplayedValues | Number of displayed values.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FootnoteText | Returns the current summary footnote text as displayed in the results window, includes info about missing values, outliers and events if applicable.
GetCellValue(PredictorGridType, Int32, Int32, Boolean) | Returns the displayed value within the statistics grid at the column and row location specified.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OverrideBestMethod()()()() | Set currently selected method as best method.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
View | The active results window view.
Visible | Is results form visible.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredResultsWindow

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow Methods

Visual Basic Usage

CB Com Devkit
PredResultsWindow Methods

The PredResultsWindow type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetCellValue(PredictorGridType, Int32, Int32, Boolean) | Returns the displayed value within the statistics grid at the column and row location specified.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
OverrideBestMethod()()()() | Set currently selected method as best method.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetCellValue Method

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::GetCellValue Method
Returns the displayed value within the statistics grid at the column and row location specified.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string GetCellValue(
    PredictorGridType gridType,
    int columnIndex,
    int rowIndex,
    bool format
)
Public Function GetCellValue ( _
    gridType As PredictorGridType, _
    columnIndex As Integer, _
    rowIndex As Integer, _
    format As Boolean _
) As String
Dim instance As PredResultsWindow
Dim gridType As PredictorGridType
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim format As Boolean
Dim returnValue As String

returnValue = instance.GetCellValue(gridType, _
    columnIndex, rowIndex, format)

Parameters

gridType
PredictorGridType
The grid to search within.
columnIndex
Int32
The column index (1-based)
rowIndex
Int32
The row index (1-based)
format
Boolean
Optional, get the string with cell formatting applied

Return Value

The text as displayed in the cell.

Remarks

If the gridType passed in is not on the current View, then the View is changed to ensure that the grid is visible. The column and row index values are 1-based. Row and column headers are considered within the indexes. If the Results Window is not currenlty visible, it will become visible

Exceptions

Exception | Condition
CBExceptionIDGridInvalidRowOrColumnIndex()()()() | The value of the row or column index is invalid

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


OverrideBestMethod Method

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::OverrideBestMethod Method
Set currently selected method as best method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void OverrideBestMethod()
Public Sub OverrideBestMethod
Dim instance As PredResultsWindow

instance.OverrideBestMethod()

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredResultsWindow Properties

Visual Basic Usage

CB Com Devkit
PredResultsWindow Properties

The PredResultsWindow type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CurrentARIMAMethod | Currently selected ARIMA model for currently selected series Valid only for Custom ARIMA.
CurrentARIMAMethods | Returns the list of all ARIMA models for currently selected series.
CurrentMethod | Currently selected method.
CurrentMethodDisplay | Currently selected method display name.
CurrentMethodRank | Currently selected method by method rank.
CurrentMethods | List of currently available methods in rank order.
CurrentSeries | The currently selected series.
CurrentSeriesDisplay | Current selected series display name.
DisplayedScreenedValues | Number of screened values for current series and method.
DisplayedValues | Number of displayed values.
FootnoteText | Returns the current summary footnote text as displayed in the results window, includes info about missing values, outliers and events if applicable.
View | The active results window view.
Visible | Is results form visible.

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CurrentARIMAMethod Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentARIMAMethod Property
Currently selected ARIMA model for currently selected series Valid only for Custom ARIMA.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredARIMAModel CurrentARIMAMethod { get; set; }
Public Property CurrentARIMAMethod As PredARIMAModel
    Get
    Set
Dim instance As PredResultsWindow
Dim value As PredARIMAModel

value = instance.CurrentARIMAMethod

instance.CurrentARIMAMethod = value

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CurrentARIMAMethods Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentARIMAMethods Property
Returns the list of all ARIMA models for currently selected series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ARIMAModelEnumerator CurrentARIMAMethods { get; }
Public ReadOnly Property CurrentARIMAMethods As ARIMAModelEnumerator
    Get
Dim instance As PredResultsWindow
Dim value As ARIMAModelEnumerator

value = instance.CurrentARIMAMethods

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CurrentMethod Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentMethod Property
Currently selected method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType CurrentMethod { get; set; }
Public Property CurrentMethod As PredForecastMethodType
    Get
    Set
Dim instance As PredResultsWindow
Dim value As PredForecastMethodType

value = instance.CurrentMethod

instance.CurrentMethod = value

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CurrentMethodDisplay Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentMethodDisplay Property
Currently selected method display name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CurrentMethodDisplay { get; }
Public ReadOnly Property CurrentMethodDisplay As String
    Get
Dim instance As PredResultsWindow
Dim value As String

value = instance.CurrentMethodDisplay

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CurrentMethodRank Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentMethodRank Property
Currently selected method by method rank.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CurrentMethodRank { get; set; }
Public Property CurrentMethodRank As Integer
    Get
    Set
Dim instance As PredResultsWindow
Dim value As Integer

value = instance.CurrentMethodRank

instance.CurrentMethodRank = value

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CurrentMethods Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentMethods Property
List of currently available methods in rank order.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public MethodEnumerator CurrentMethods { get; }
Public ReadOnly Property CurrentMethods As MethodEnumerator
    Get
Dim instance As PredResultsWindow
Dim value As MethodEnumerator

value = instance.CurrentMethods

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CurrentSeries Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentSeries Property
The currently selected series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CurrentSeries { get; set; }
Public Property CurrentSeries As Integer
    Get
    Set
Dim instance As PredResultsWindow
Dim value As Integer

value = instance.CurrentSeries

instance.CurrentSeries = value

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


CurrentSeriesDisplay Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::CurrentSeriesDisplay Property
Current selected series display name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CurrentSeriesDisplay { get; }
Public ReadOnly Property CurrentSeriesDisplay As String
    Get
Dim instance As PredResultsWindow
Dim value As String

value = instance.CurrentSeriesDisplay

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DisplayedScreenedValues Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::DisplayedScreenedValues Property
Number of screened values for current series and method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int DisplayedScreenedValues { get; }
Public ReadOnly Property DisplayedScreenedValues As Integer
    Get
Dim instance As PredResultsWindow
Dim value As Integer

value = instance.DisplayedScreenedValues

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DisplayedValues Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::DisplayedValues Property
Number of displayed values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int DisplayedValues { get; }
Public ReadOnly Property DisplayedValues As Integer
    Get
Dim instance As PredResultsWindow
Dim value As Integer

value = instance.DisplayedValues

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


FootnoteText Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::FootnoteText Property
Returns the current summary footnote text as displayed in the results window, includes info about missing values, outliers and events if applicable.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string FootnoteText { get; }
Public ReadOnly Property FootnoteText As String
    Get
Dim instance As PredResultsWindow
Dim value As String

value = instance.FootnoteText

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


View Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::View Property
The active results window view.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredictorViewType View { get; set; }
Public Property View As PredictorViewType
    Get
    Set
Dim instance As PredResultsWindow
Dim value As PredictorViewType

value = instance.View

instance.View = value

Remarks

If the Results Window is not currenlty visible, it will become visible

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Visible Property

Visual Basic Usage

CB Com Devkit
PredResultsWindow..::Visible Property
Is results form visible.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
Dim instance As PredResultsWindow
Dim value As Boolean

value = instance.Visible

instance.Visible = value

See Also

PredResultsWindow Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeasonality Class
Series seasonality settings. Provides access to series seasonality settings such as seasonality type and seasonal cycle.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeasonality
Public Class PredSeasonality
Dim instance As PredSeasonality

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cycle | Seasonal data cycle value.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
IsSeasonal | Does this series contain seasonal data.
SeasonalityType | Seasonality type. Default is AutoDetect.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeasonality

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality Methods

Visual Basic Usage

CB Com Devkit
PredSeasonality Methods

The PredSeasonality type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonality Properties

Visual Basic Usage

CB Com Devkit
PredSeasonality Properties

The PredSeasonality type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cycle | Seasonal data cycle value.
IsSeasonal | Does this series contain seasonal data.
SeasonalityType | Seasonality type. Default is AutoDetect.

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Cycle Property

Visual Basic Usage

CB Com Devkit
PredSeasonality..::Cycle Property
Seasonal data cycle value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Cycle { get; set; }
Public Property Cycle As Integer
    Get
    Set
Dim instance As PredSeasonality
Dim value As Integer

value = instance.Cycle

instance.Cycle = value

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


IsSeasonal Property

Visual Basic Usage

CB Com Devkit
PredSeasonality..::IsSeasonal Property
Does this series contain seasonal data.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSeasonal { get; set; }
Public Property IsSeasonal As Boolean
    Get
    Set
Dim instance As PredSeasonality
Dim value As Boolean

value = instance.IsSeasonal

instance.IsSeasonal = value

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SeasonalityType Property

Visual Basic Usage

CB Com Devkit
PredSeasonality..::SeasonalityType Property
Seasonality type. Default is AutoDetect.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeasonalityType SeasonalityType { get; set; }
Public Property SeasonalityType As PredSeasonalityType
    Get
    Set
Dim instance As PredSeasonality
Dim value As PredSeasonalityType

value = instance.SeasonalityType

instance.SeasonalityType = value

See Also

PredSeasonality Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeasonalityType Enumeration

Visual Basic Usage

CB Com Devkit
PredSeasonalityType Enumeration
Seasonality type options.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum PredSeasonalityType
Public Enumeration PredSeasonalityType
Dim instance As PredSeasonalityType

Members

Member | Description
AutoDetect | Let Predictor detect seasonality from input data.
NonSeasonal | Series contains non-seasonal data.
Seasonal | Series contains seasonal data.

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeries Class
The main interface to input series specific settings. This provides access to information such as series name, Excel number format, seasonality and cycle, regression variable details, statistics, and series data values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeries
Public Class PredSeries
Dim instance As PredSeries

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestMethodForOutlierAdjustment | Best fit method found for the current error measure.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractData(Range, PredForecastMethodType, Boolean, Boolean, PredARIMAModel) | Extract input data into an Excel range.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatistics(PredForecastMethodType, Boolean, Boolean, PredARIMAModel) | Get series statistics by method.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MethodsForOutlierAdjustment | Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.
Name | Series name.
NumberFormat | Series data source Excel number format string.
NumberOfAdjustedValues(PredForecastMethodType) | Number of data points detected as an outlier and adjusted for this series.
NumberOfFilledInValues | Number of data points filled in for this series.
NumberOfValues | Number of data points in this series.
Range | Series data source Excel Range.
Regression | Series regression variable settings.
Seasonality | Series seasonality settings.
Statistics | Series basic statistics.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate series settings.

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeries

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries Methods

Visual Basic Usage

CB Com Devkit
PredSeries Methods

The PredSeries type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractData(Range, PredForecastMethodType, Boolean, Boolean, PredARIMAModel) | Extract input data into an Excel range.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatistics(PredForecastMethodType, Boolean, Boolean, PredARIMAModel) | Get series statistics by method.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
NumberOfAdjustedValues(PredForecastMethodType) | Number of data points detected as an outlier and adjusted for this series.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate()()()() | Validate series settings.

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ExtractData Method

Visual Basic Usage

CB Com Devkit
PredSeries..::ExtractData Method
Extract input data into an Excel range.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ExtractData(
    Range startCell,
    PredForecastMethodType method,
    bool ShowScreenedDataOnly,
    bool ShowPreadjustedOutliers,
    PredARIMAModel ARIMAModel
)
Public Sub ExtractData ( _
    startCell As Range, _
    method As PredForecastMethodType, _
    ShowScreenedDataOnly As Boolean, _
    ShowPreadjustedOutliers As Boolean, _
    ARIMAModel As PredARIMAModel _
)
Dim instance As PredSeries
Dim startCell As Range
Dim method As PredForecastMethodType
Dim ShowScreenedDataOnly As Boolean
Dim ShowPreadjustedOutliers As Boolean
Dim ARIMAModel As PredARIMAModel

instance.ExtractData(startCell, method, _
    ShowScreenedDataOnly, ShowPreadjustedOutliers, _
    ARIMAModel)

Parameters

startCell
Range
Starting cell for data extract.
method
PredForecastMethodType
Method type to extract data for.
ShowScreenedDataOnly
Boolean
Optionally choose screened data only.
ShowPreadjustedOutliers
Boolean
Optionally choose pre-adjusted input data.
ARIMAModel
PredARIMAModel
Optional ARIMA model to be used

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetStatistics Method

Visual Basic Usage

CB Com Devkit
PredSeries..::GetStatistics Method
Get series statistics by method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredStatistics GetStatistics(
    PredForecastMethodType method,
    bool UseDetrendedLags,
    bool ShowPreadjustedOutliers,
    PredARIMAModel ARIMAModel
)
Public Function GetStatistics ( _
    method As PredForecastMethodType, _
    UseDetrendedLags As Boolean, _
    ShowPreadjustedOutliers As Boolean, _
    ARIMAModel As PredARIMAModel _
) As PredStatistics
Dim instance As PredSeries
Dim method As PredForecastMethodType
Dim UseDetrendedLags As Boolean
Dim ShowPreadjustedOutliers As Boolean
Dim ARIMAModel As PredARIMAModel
Dim returnValue As PredStatistics

returnValue = instance.GetStatistics(method, _
    UseDetrendedLags, ShowPreadjustedOutliers, _
    ARIMAModel)

Parameters

method
PredForecastMethodType
Method type to get statistics for.
UseDetrendedLags
Boolean
Optionally choose to get de-trended autocorrelation lags.
ShowPreadjustedOutliers
Boolean
Optionally choose to get statistics for pre-adjusted input data.
ARIMAModel
PredARIMAModel
Optional ARIMA model to be used

Return Value

the requested statistics

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberOfAdjustedValues Method

Visual Basic Usage

CB Com Devkit
PredSeries..::NumberOfAdjustedValues Method
Number of data points detected as an outlier and adjusted for this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfAdjustedValues(
    PredForecastMethodType method
)
Public Function NumberOfAdjustedValues ( _
    method As PredForecastMethodType _
) As Integer
Dim instance As PredSeries
Dim method As PredForecastMethodType
Dim returnValue As Integer

returnValue = instance.NumberOfAdjustedValues(method)

Parameters

method
PredForecastMethodType
Method type to access number of adjusted outlier for

Return Value

Number of adjusted outliers

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
PredSeries..::Validate Method
Validate series settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate()
Public Function Validate As Boolean
Dim instance As PredSeries
Dim returnValue As Boolean

returnValue = instance.Validate()

Return Value

true if successful

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeries Properties

Visual Basic Usage

CB Com Devkit
PredSeries Properties

The PredSeries type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BestMethodForOutlierAdjustment | Best fit method found for the current error measure.
MethodsForOutlierAdjustment | Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.
Name | Series name.
NumberFormat | Series data source Excel number format string.
NumberOfFilledInValues | Number of data points filled in for this series.
NumberOfValues | Number of data points in this series.
Range | Series data source Excel Range.
Regression | Series regression variable settings.
Seasonality | Series seasonality settings.
Statistics | Series basic statistics.

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


BestMethodForOutlierAdjustment Property

Visual Basic Usage

CB Com Devkit
PredSeries..::BestMethodForOutlierAdjustment Property
Best fit method found for the current error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType BestMethodForOutlierAdjustment { get; }
Public ReadOnly Property BestMethodForOutlierAdjustment As PredForecastMethodType
    Get
Dim instance As PredSeries
Dim value As PredForecastMethodType

value = instance.BestMethodForOutlierAdjustment

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MethodsForOutlierAdjustment Property

Visual Basic Usage

CB Com Devkit
PredSeries..::MethodsForOutlierAdjustment Property
Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType[] MethodsForOutlierAdjustment { get; }
Public ReadOnly Property MethodsForOutlierAdjustment As PredForecastMethodType()
    Get
Dim instance As PredSeries
Dim value As PredForecastMethodType()

value = instance.MethodsForOutlierAdjustment

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Name Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Name Property
Series name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Dim instance As PredSeries
Dim value As String

value = instance.Name

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberFormat Property

Visual Basic Usage

CB Com Devkit
PredSeries..::NumberFormat Property
Series data source Excel number format string.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string NumberFormat { get; }
Public ReadOnly Property NumberFormat As String
    Get
Dim instance As PredSeries
Dim value As String

value = instance.NumberFormat

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberOfFilledInValues Property

Visual Basic Usage

CB Com Devkit
PredSeries..::NumberOfFilledInValues Property
Number of data points filled in for this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfFilledInValues { get; }
Public ReadOnly Property NumberOfFilledInValues As Integer
    Get
Dim instance As PredSeries
Dim value As Integer

value = instance.NumberOfFilledInValues

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberOfValues Property

Visual Basic Usage

CB Com Devkit
PredSeries..::NumberOfValues Property
Number of data points in this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfValues { get; }
Public ReadOnly Property NumberOfValues As Integer
    Get
Dim instance As PredSeries
Dim value As Integer

value = instance.NumberOfValues

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Range Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Range Property
Series data source Excel Range.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Range { get; }
Public ReadOnly Property Range As Range
    Get
Dim instance As PredSeries
Dim value As Range

value = instance.Range

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Regression Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Regression Property
Series regression variable settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredRegression Regression { get; }
Public ReadOnly Property Regression As PredRegression
    Get
Dim instance As PredSeries
Dim value As PredRegression

value = instance.Regression

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Seasonality Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Seasonality Property
Series seasonality settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeasonality Seasonality { get; }
Public ReadOnly Property Seasonality As PredSeasonality
    Get
Dim instance As PredSeries
Dim value As PredSeasonality

value = instance.Seasonality

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Statistics Property

Visual Basic Usage

CB Com Devkit
PredSeries..::Statistics Property
Series basic statistics.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredStatistics Statistics { get; }
Public ReadOnly Property Statistics As PredStatistics
    Get
Dim instance As PredSeries
Dim value As PredStatistics

value = instance.Statistics

See Also

PredSeries Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeriesEnumerator Class
List of series in input data set.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeriesEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class PredSeriesEnumerator _
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As PredSeriesEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Get series by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeriesEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator Methods

The PredSeriesEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredSeriesEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MoveNext Method

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredSeriesEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredSeriesEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredSeriesEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator Properties

The PredSeriesEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Get series by index.

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredSeriesEnumerator
Dim value As Integer

value = instance.Count

Implements

IObjectEnumerator..::..Count

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Current Property

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredSeriesEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Item Property

Visual Basic Usage

CB Com Devkit
PredSeriesEnumerator..::Item Property
Get series by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeries this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PredSeries
    Get
Dim instance As PredSeriesEnumerator
Dim index As Integer
Dim value As PredSeries

value = instance(index)

Parameters

index
Int32

Return Value

See Also

PredSeriesEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeriesResult Class
The main interface to output series specific settings. This provides access to information such as series name, Excel number format, forecast adjustments, statistics, and series data values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeriesResult
Public Class PredSeriesResult
Dim instance As PredSeriesResult

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustForecast | Forecast adjustment settings.
BestMethod | Best fit method found for the current error measure.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractData(Range, PredForecastMethodType, Boolean, PredARIMAModel) | Extract input data into an Excel range.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatistics(PredForecastMethodType, Boolean, PredARIMAModel) | Get series statistics by method.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Methods | Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.
Name | Series name.
NumberFormat | Series data source Excel range number format string.
NumberOfAdjustedValues(PredForecastMethodType) | Number of data points detected as an outlier and adjusted for this series.
NumberOfFilledInValues | Number of data points filled in for this series.
NumberOfValues | Number of data points in this series.
Range | Series data source Excel range.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeriesResult

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult Methods

Visual Basic Usage

CB Com Devkit
PredSeriesResult Methods

The PredSeriesResult type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExtractData(Range, PredForecastMethodType, Boolean, PredARIMAModel) | Extract input data into an Excel range.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetStatistics(PredForecastMethodType, Boolean, PredARIMAModel) | Get series statistics by method.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
NumberOfAdjustedValues(PredForecastMethodType) | Number of data points detected as an outlier and adjusted for this series.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ExtractData Method

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::ExtractData Method
Extract input data into an Excel range.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ExtractData(
    Range startCell,
    PredForecastMethodType method,
    bool ForecastOnly,
    PredARIMAModel ARIMAModel
)
Public Sub ExtractData ( _
    startCell As Range, _
    method As PredForecastMethodType, _
    ForecastOnly As Boolean, _
    ARIMAModel As PredARIMAModel _
)
Dim instance As PredSeriesResult
Dim startCell As Range
Dim method As PredForecastMethodType
Dim ForecastOnly As Boolean
Dim ARIMAModel As PredARIMAModel

instance.ExtractData(startCell, method, _
    ForecastOnly, ARIMAModel)

Parameters

startCell
Range
Starting cell for data extract.
method
PredForecastMethodType
Method type to extract data for.
ForecastOnly
Boolean
Optionally choose to extract forecast periods only. Default is false
ARIMAModel
PredARIMAModel
Optional ARIMA model to be used

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetStatistics Method

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::GetStatistics Method
Get series statistics by method.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredStatistics GetStatistics(
    PredForecastMethodType method,
    bool UseDetrendedLags,
    PredARIMAModel ARIMAModel
)
Public Function GetStatistics ( _
    method As PredForecastMethodType, _
    UseDetrendedLags As Boolean, _
    ARIMAModel As PredARIMAModel _
) As PredStatistics
Dim instance As PredSeriesResult
Dim method As PredForecastMethodType
Dim UseDetrendedLags As Boolean
Dim ARIMAModel As PredARIMAModel
Dim returnValue As PredStatistics

returnValue = instance.GetStatistics(method, _
    UseDetrendedLags, ARIMAModel)

Parameters

method
PredForecastMethodType
Method type to get statistics for.
UseDetrendedLags
Boolean
Optionally choose to get de-trended autocorrelation lags.
ARIMAModel
PredARIMAModel
Optional ARIMA model to be used

Return Value

the requested statistics

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberOfAdjustedValues Method

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::NumberOfAdjustedValues Method
Number of data points detected as an outlier and adjusted for this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfAdjustedValues(
    PredForecastMethodType method
)
Public Function NumberOfAdjustedValues ( _
    method As PredForecastMethodType _
) As Integer
Dim instance As PredSeriesResult
Dim method As PredForecastMethodType
Dim returnValue As Integer

returnValue = instance.NumberOfAdjustedValues(method)

Parameters

method
PredForecastMethodType
Method type to access number of adjusted outlier for

Return Value

Number of adjusted outliers

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResult Properties

Visual Basic Usage

CB Com Devkit
PredSeriesResult Properties

The PredSeriesResult type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjustForecast | Forecast adjustment settings.
BestMethod | Best fit method found for the current error measure.
Methods | Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.
Name | Series name.
NumberFormat | Series data source Excel range number format string.
NumberOfFilledInValues | Number of data points filled in for this series.
NumberOfValues | Number of data points in this series.
Range | Series data source Excel range.

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AdjustForecast Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::AdjustForecast Property
Forecast adjustment settings.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredAdjustForecast AdjustForecast { get; }
Public ReadOnly Property AdjustForecast As PredAdjustForecast
    Get
Dim instance As PredSeriesResult
Dim value As PredAdjustForecast

value = instance.AdjustForecast

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


BestMethod Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::BestMethod Property
Best fit method found for the current error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType BestMethod { get; set; }
Public Property BestMethod As PredForecastMethodType
    Get
    Set
Dim instance As PredSeriesResult
Dim value As PredForecastMethodType

value = instance.BestMethod

instance.BestMethod = value

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Methods Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::Methods Property
Methods fit for current outlier adjustment settings, ordered by fit rank for the current error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredForecastMethodType[] Methods { get; }
Public ReadOnly Property Methods As PredForecastMethodType()
    Get
Dim instance As PredSeriesResult
Dim value As PredForecastMethodType()

value = instance.Methods

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Name Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::Name Property
Series name.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Dim instance As PredSeriesResult
Dim value As String

value = instance.Name

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberFormat Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::NumberFormat Property
Series data source Excel range number format string.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string NumberFormat { get; }
Public ReadOnly Property NumberFormat As String
    Get
Dim instance As PredSeriesResult
Dim value As String

value = instance.NumberFormat

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberOfFilledInValues Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::NumberOfFilledInValues Property
Number of data points filled in for this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfFilledInValues { get; }
Public ReadOnly Property NumberOfFilledInValues As Integer
    Get
Dim instance As PredSeriesResult
Dim value As Integer

value = instance.NumberOfFilledInValues

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


NumberOfValues Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::NumberOfValues Property
Number of data points in this series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int NumberOfValues { get; }
Public ReadOnly Property NumberOfValues As Integer
    Get
Dim instance As PredSeriesResult
Dim value As Integer

value = instance.NumberOfValues

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Range Property

Visual Basic Usage

CB Com Devkit
PredSeriesResult..::Range Property
Series data source Excel range.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Range { get; }
Public ReadOnly Property Range As Range
    Get
Dim instance As PredSeriesResult
Dim value As Range

value = instance.Range

See Also

PredSeriesResult Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSeriesResultEnumerator Class
List of series in results set.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSeriesResultEnumerator : IObjectEnumerator,
    IEnumerable, IEnumerator
Public Class PredSeriesResultEnumerator _
    Implements IObjectEnumerator, IEnumerable, IEnumerator
Dim instance As PredSeriesResultEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Access series result by index.
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSeriesResultEnumerator

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator Methods

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator Methods

The PredSeriesResultEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these series.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid series
Reload()()()() | Reload enumerator
Reset()()()() | Resets method required by IEnumerator (resets to first series).
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


GetEnumerator Method

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::GetEnumerator Method
Returns an enumerator for these series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
Dim instance As PredSeriesResultEnumerator
Dim returnValue As IEnumerator

returnValue = instance.GetEnumerator()

Return Value

the enumerator object

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MoveNext Method

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::MoveNext Method
Declares the MoveNext method required by IEnumerator; returns the next valid series

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool MoveNext()
Public Function MoveNext As Boolean
Dim instance As PredSeriesResultEnumerator
Dim returnValue As Boolean

returnValue = instance.MoveNext()

Return Value

true if next element exists

Implements

IEnumerator..::..MoveNext()()()()

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Reload Method
Reload enumerator

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual bool Reload()
Public Overridable Function Reload As Boolean
Dim instance As PredSeriesResultEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

true if successful

Implements

IObjectEnumerator..::..Reload()()()()

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Reset Method
Resets method required by IEnumerator (resets to first series).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As PredSeriesResultEnumerator

instance.Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSeriesResultEnumerator Properties

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator Properties

The PredSeriesResultEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the series count
Current | Returns the current series (required by IEnumerator).
Item[([( Int32])]) | Access series result by index.

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Count Property

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Count Property
Returns the series count

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
Dim instance As PredSeriesResultEnumerator
Dim value As Integer

value = instance.Count

Implements

IObjectEnumerator..::..Count

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Current Property

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Current Property
Returns the current series (required by IEnumerator).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get
Dim instance As PredSeriesResultEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Item Property

Visual Basic Usage

CB Com Devkit
PredSeriesResultEnumerator..::Item Property
Access series result by index.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeriesResult this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PredSeriesResult
    Get
Dim instance As PredSeriesResultEnumerator
Dim index As Integer
Dim value As PredSeriesResult

value = instance(index)

Parameters

index
Int32

Return Value

See Also

PredSeriesResultEnumerator Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredSetup Class
Predictor Setup / Definition Provides an interface to define a predictor run. This is the top level interface class that provides access to objects to set and define all predictor settings available through the wizard

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredSetup
Public Class PredSetup
Dim instance As PredSetup

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PredSetup()()()() | Predictor Setup / Definition Provides an interface to define a predictor run. This is the top level interface class that provides access to objects to set and define all predictor settings available through the wizard
AutoDetect(Range) | Set the time series data input range. This will auto detect the range containing the current Excel selection, or if an initialRange is specified this will be used as the input range. The selection or initialRange can be a single-cell or multi-cell selection or a discontiguous range. AutoDetect performs all the actions performed when the Predictor Wizard is displayed. Depending on current selection and saved state it may run the autodetection or reuse the saved preferences.
DataAttributes | Access to data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.
DeleteAutodetectData()()()() | Delete all data collected by Predictor auto-detection.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InputData | Access to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.
Methods | Access to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.
Options | Access to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.
Run()()()() | Run predictor with current input data and configured settings. Runs the predictor forecast and puts crystal ball into a predictor run state where you can access results from the PredResults interface.
SelectiveAutoDetect(Boolean, Boolean, Boolean) | This method provides control of the startup process so it can be used to test the various detections that are performed during Predictor startup. If ForceSeriesDetection is set to false, the series will be created based on the saved data range (an error is issued if it was not saved previously).
Series | The list of currently selected series from the input range. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as seasonality and regression variable details.
Setup()()()() | Similar to AutoDetect but this method additionally validates the Predictor properties. Internally it’s implemented as a call to AutoDetect() followed by call to Validate(False).
Show()()()() | Show the Predictor Wizard GUI
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate(Boolean) | Validate all Predictor settings for current storage worksheet

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredSetup

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup Constructor

Visual Basic Usage

CB Com Devkit
PredSetup Constructor
Predictor Setup / Definition Provides an interface to define a predictor run. This is the top level interface class that provides access to objects to set and define all predictor settings available through the wizard

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSetup()
Public Sub New
Dim instance As New PredSetup()

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup Methods

Visual Basic Usage

CB Com Devkit
PredSetup Methods

The PredSetup type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AutoDetect(Range) | Set the time series data input range. This will auto detect the range containing the current Excel selection, or if an initialRange is specified this will be used as the input range. The selection or initialRange can be a single-cell or multi-cell selection or a discontiguous range. AutoDetect performs all the actions performed when the Predictor Wizard is displayed. Depending on current selection and saved state it may run the autodetection or reuse the saved preferences.
DeleteAutodetectData()()()() | Delete all data collected by Predictor auto-detection.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Run()()()() | Run predictor with current input data and configured settings. Runs the predictor forecast and puts crystal ball into a predictor run state where you can access results from the PredResults interface.
SelectiveAutoDetect(Boolean, Boolean, Boolean) | This method provides control of the startup process so it can be used to test the various detections that are performed during Predictor startup. If ForceSeriesDetection is set to false, the series will be created based on the saved data range (an error is issued if it was not saved previously).
Setup()()()() | Similar to AutoDetect but this method additionally validates the Predictor properties. Internally it’s implemented as a call to AutoDetect() followed by call to Validate(False).
Show()()()() | Show the Predictor Wizard GUI
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
Validate(Boolean) | Validate all Predictor settings for current storage worksheet

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AutoDetect Method

Visual Basic Usage

CB Com Devkit
PredSetup..::AutoDetect Method
Set the time series data input range. This will auto detect the range containing the current Excel selection, or if an initialRange is specified this will be used as the input range. The selection or initialRange can be a single-cell or multi-cell selection or a discontiguous range. AutoDetect performs all the actions performed when the Predictor Wizard is displayed. Depending on current selection and saved state it may run the autodetection or reuse the saved preferences.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void AutoDetect(
    Range initialRange
)
Public Sub AutoDetect ( _
    initialRange As Range _
)
Dim instance As PredSetup
Dim initialRange As Range

instance.AutoDetect(initialRange)

Parameters

initialRange
Range
optional intitial range to indicate where auto-detection should start (current selection used if not specified)

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DeleteAutodetectData Method

Visual Basic Usage

CB Com Devkit
PredSetup..::DeleteAutodetectData Method
Delete all data collected by Predictor auto-detection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void DeleteAutodetectData()
Public Sub DeleteAutodetectData
Dim instance As PredSetup

instance.DeleteAutodetectData()

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Run Method

Visual Basic Usage

CB Com Devkit
PredSetup..::Run Method
Run predictor with current input data and configured settings. Runs the predictor forecast and puts crystal ball into a predictor run state where you can access results from the PredResults interface.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Run()
Public Sub Run
Dim instance As PredSetup

instance.Run()

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SelectiveAutoDetect Method

Visual Basic Usage

CB Com Devkit
PredSetup..::SelectiveAutoDetect Method
This method provides control of the startup process so it can be used to test the various detections that are performed during Predictor startup. If ForceSeriesDetection is set to false, the series will be created based on the saved data range (an error is issued if it was not saved previously).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SelectiveAutoDetect(
    bool ForceSeriesDetection,
    bool ForceDateTypeDetection,
    bool ForceSeasonalityDetection
)
Public Sub SelectiveAutoDetect ( _
    ForceSeriesDetection As Boolean, _
    ForceDateTypeDetection As Boolean, _
    ForceSeasonalityDetection As Boolean _
)
Dim instance As PredSetup
Dim ForceSeriesDetection As Boolean
Dim ForceDateTypeDetection As Boolean
Dim ForceSeasonalityDetection As Boolean

instance.SelectiveAutoDetect(ForceSeriesDetection, _
    ForceDateTypeDetection, ForceSeasonalityDetection)

Parameters

ForceSeriesDetection
Boolean
Force the detection of Predictor series
ForceDateTypeDetection
Boolean
Force the date type detection
ForceSeasonalityDetection
Boolean
Force the data seasonality detection

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Setup Method

Visual Basic Usage

CB Com Devkit
PredSetup..::Setup Method
Similar to AutoDetect but this method additionally validates the Predictor properties. Internally it’s implemented as a call to AutoDetect() followed by call to Validate(False).

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Setup()
Public Sub Setup
Dim instance As PredSetup

instance.Setup()

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Show Method

Visual Basic Usage

CB Com Devkit
PredSetup..::Show Method
Show the Predictor Wizard GUI

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Show()
Public Function Show As Boolean
Dim instance As PredSetup
Dim returnValue As Boolean

returnValue = instance.Show()

Return Value

true if no errors detected

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
PredSetup..::Validate Method
Validate all Predictor settings for current storage worksheet

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool Validate(
    bool ShowWizard
)
Public Function Validate ( _
    ShowWizard As Boolean _
) As Boolean
Dim instance As PredSetup
Dim ShowWizard As Boolean
Dim returnValue As Boolean

returnValue = instance.Validate(ShowWizard)

Parameters

ShowWizard
Boolean
If true, show the Predictor Wizard if error is detected

Return Value

true if no errors detected

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredSetup Properties

Visual Basic Usage

CB Com Devkit
PredSetup Properties

The PredSetup type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataAttributes | Access to data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.
InputData | Access to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.
Methods | Access to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.
Options | Access to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.
Series | The list of currently selected series from the input range. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as seasonality and regression variable details.
ThrowErrors | Setting to determine whether to throw errors to the client app
ThrowWarningsAsErrors | Setting to determine whether to throw warnings to the client app

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DataAttributes Property

Visual Basic Usage

CB Com Devkit
PredSetup..::DataAttributes Property
Access to data attribute setting corresponding the the Predictor wizard Data Attributes panel. This lets you control items such as seasonality, screening and outlier detection.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredDataAttributes DataAttributes { get; }
Public ReadOnly Property DataAttributes As PredDataAttributes
    Get
Dim instance As PredSetup
Dim value As PredDataAttributes

value = instance.DataAttributes

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


InputData Property

Visual Basic Usage

CB Com Devkit
PredSetup..::InputData Property
Access to input data properties corresponding the the Predictor wizard Input Data panel. This lets you control items such as data orientation and headers.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredInputData InputData { get; }
Public ReadOnly Property InputData As PredInputData
    Get
Dim instance As PredSetup
Dim value As PredInputData

value = instance.InputData

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Methods Property

Visual Basic Usage

CB Com Devkit
PredSetup..::Methods Property
Access to methods settings corresponding the Predictor Methods panel. This lets you control what methods to use and method parameters.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredMethods Methods { get; }
Public ReadOnly Property Methods As PredMethods
    Get
Dim instance As PredSetup
Dim value As PredMethods

value = instance.Methods

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Options Property

Visual Basic Usage

CB Com Devkit
PredSetup..::Options Property
Access to predictor options corresponding to the Predictor Options panel. This povides access to options such as error measure and forecasting technique.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredOptions Options { get; }
Public ReadOnly Property Options As PredOptions
    Get
Dim instance As PredSetup
Dim value As PredOptions

value = instance.Options

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Series Property

Visual Basic Usage

CB Com Devkit
PredSetup..::Series Property
The list of currently selected series from the input range. The list is ordered by position in the input range, left to right for column oriented data or top to bottom for row oriented data. This provides access to series specific information such as seasonality and regression variable details.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredSeriesEnumerator Series { get; }
Public ReadOnly Property Series As PredSeriesEnumerator
    Get
Dim instance As PredSetup
Dim value As PredSeriesEnumerator

value = instance.Series

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ThrowErrors Property

Visual Basic Usage

CB Com Devkit
PredSetup..::ThrowErrors Property
Setting to determine whether to throw errors to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowErrors { get; set; }
Public Property ThrowErrors As Boolean
    Get
    Set
Dim instance As PredSetup
Dim value As Boolean

value = instance.ThrowErrors

instance.ThrowErrors = value

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ThrowWarningsAsErrors Property

Visual Basic Usage

CB Com Devkit
PredSetup..::ThrowWarningsAsErrors Property
Setting to determine whether to throw warnings to the client app

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ThrowWarningsAsErrors { get; set; }
Public Property ThrowWarningsAsErrors As Boolean
    Get
    Set
Dim instance As PredSetup
Dim value As Boolean

value = instance.ThrowWarningsAsErrors

instance.ThrowWarningsAsErrors = value

See Also

PredSetup Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
PredStatistics Class
Main interface to series statistics.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class PredStatistics
Public Class PredStatistics
Dim instance As PredStatistics

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjRSquared | Regression Adjusted RSquared statistic.
AIC | Value of the Akike’s Information Criterion
AICc | Value of the corrected AIC
Alpha | Method Alpha parameter.
Beta | Method Beta parameter.
BIC | Value of the Bayesian Information Criterion
DataValues | Number of historical data values in series.
DurbinWatson | Series DurbinWatson statistic.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ErrorMeasure | Selected error measure.
FProbability | Regression FProbability statistic.
FStatistic | Regression FStatistic statistic.
Gamma | Method Gamma parameter.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Lags | List of autocorrelation lags.
LjungBox | Series LjungBox statistic.
LjungBoxP | Series LjungBoxP statistic.
MAD | MAD error measure value.
MAPE | MAPE error measure value.
Maximum | Maximum series value.
Mean | Series mean value.
Minimum | Minimum series value.
Order | Method Order parameter.
RMSE | RMSE error measure value.
RSquared | Regression RSquared statistic.
SeasonalityCycle | Seasonal cycle for series. Value is 0 if series is non-seasonal.
StandardDeviation | Standard devistion of series values.
StandardError | Regression StandardError statistic.
TheilsU | Series TheilsU statistic.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Predictor..::..PredStatistics

See Also

Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics Methods

Visual Basic Usage

CB Com Devkit
PredStatistics Methods

The PredStatistics type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


PredStatistics Properties

Visual Basic Usage

CB Com Devkit
PredStatistics Properties

The PredStatistics type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdjRSquared | Regression Adjusted RSquared statistic.
AIC | Value of the Akike’s Information Criterion
AICc | Value of the corrected AIC
Alpha | Method Alpha parameter.
Beta | Method Beta parameter.
BIC | Value of the Bayesian Information Criterion
DataValues | Number of historical data values in series.
DurbinWatson | Series DurbinWatson statistic.
ErrorMeasure | Selected error measure.
FProbability | Regression FProbability statistic.
FStatistic | Regression FStatistic statistic.
Gamma | Method Gamma parameter.
Lags | List of autocorrelation lags.
LjungBox | Series LjungBox statistic.
LjungBoxP | Series LjungBoxP statistic.
MAD | MAD error measure value.
MAPE | MAPE error measure value.
Maximum | Maximum series value.
Mean | Series mean value.
Minimum | Minimum series value.
Order | Method Order parameter.
RMSE | RMSE error measure value.
RSquared | Regression RSquared statistic.
SeasonalityCycle | Seasonal cycle for series. Value is 0 if series is non-seasonal.
StandardDeviation | Standard devistion of series values.
StandardError | Regression StandardError statistic.
TheilsU | Series TheilsU statistic.

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AdjRSquared Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::AdjRSquared Property
Regression Adjusted RSquared statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AdjRSquared { get; }
Public ReadOnly Property AdjRSquared As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.AdjRSquared

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AIC Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::AIC Property
Value of the Akike’s Information Criterion

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AIC { get; }
Public ReadOnly Property AIC As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.AIC

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


AICc Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::AICc Property
Value of the corrected AIC

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double AICc { get; }
Public ReadOnly Property AICc As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.AICc

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Alpha Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Alpha Property
Method Alpha parameter.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Alpha { get; }
Public ReadOnly Property Alpha As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Alpha

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Beta Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Beta Property
Method Beta parameter.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Beta { get; }
Public ReadOnly Property Beta As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Beta

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


BIC Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::BIC Property
Value of the Bayesian Information Criterion

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double BIC { get; }
Public ReadOnly Property BIC As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.BIC

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DataValues Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::DataValues Property
Number of historical data values in series.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int DataValues { get; }
Public ReadOnly Property DataValues As Integer
    Get
Dim instance As PredStatistics
Dim value As Integer

value = instance.DataValues

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


DurbinWatson Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::DurbinWatson Property
Series DurbinWatson statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double DurbinWatson { get; }
Public ReadOnly Property DurbinWatson As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.DurbinWatson

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


ErrorMeasure Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::ErrorMeasure Property
Selected error measure.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredErrorMeasureType ErrorMeasure { get; }
Public ReadOnly Property ErrorMeasure As PredErrorMeasureType
    Get
Dim instance As PredStatistics
Dim value As PredErrorMeasureType

value = instance.ErrorMeasure

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


FProbability Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::FProbability Property
Regression FProbability statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double FProbability { get; }
Public ReadOnly Property FProbability As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.FProbability

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


FStatistic Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::FStatistic Property
Regression FStatistic statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double FStatistic { get; }
Public ReadOnly Property FStatistic As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.FStatistic

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Gamma Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Gamma Property
Method Gamma parameter.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Gamma { get; }
Public ReadOnly Property Gamma As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Gamma

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Lags Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Lags Property
List of autocorrelation lags.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public PredLagEnumerator Lags { get; }
Public ReadOnly Property Lags As PredLagEnumerator
    Get
Dim instance As PredStatistics
Dim value As PredLagEnumerator

value = instance.Lags

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


LjungBox Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::LjungBox Property
Series LjungBox statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double LjungBox { get; }
Public ReadOnly Property LjungBox As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.LjungBox

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


LjungBoxP Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::LjungBoxP Property
Series LjungBoxP statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double LjungBoxP { get; }
Public ReadOnly Property LjungBoxP As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.LjungBoxP

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MAD Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::MAD Property
MAD error measure value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MAD { get; }
Public ReadOnly Property MAD As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.MAD

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


MAPE Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::MAPE Property
MAPE error measure value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double MAPE { get; }
Public ReadOnly Property MAPE As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.MAPE

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Maximum Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Maximum Property
Maximum series value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Maximum { get; }
Public ReadOnly Property Maximum As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Maximum

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Mean Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Mean Property
Series mean value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Mean { get; }
Public ReadOnly Property Mean As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Mean

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Minimum Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Minimum Property
Minimum series value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double Minimum { get; }
Public ReadOnly Property Minimum As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.Minimum

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Order Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::Order Property
Method Order parameter.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
Dim instance As PredStatistics
Dim value As Integer

value = instance.Order

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RMSE Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::RMSE Property
RMSE error measure value.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RMSE { get; }
Public ReadOnly Property RMSE As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.RMSE

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


RSquared Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::RSquared Property
Regression RSquared statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double RSquared { get; }
Public ReadOnly Property RSquared As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.RSquared

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


SeasonalityCycle Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::SeasonalityCycle Property
Seasonal cycle for series. Value is 0 if series is non-seasonal.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int SeasonalityCycle { get; }
Public ReadOnly Property SeasonalityCycle As Integer
    Get
Dim instance As PredStatistics
Dim value As Integer

value = instance.SeasonalityCycle

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


StandardDeviation Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::StandardDeviation Property
Standard devistion of series values.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StandardDeviation { get; }
Public ReadOnly Property StandardDeviation As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.StandardDeviation

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


StandardError Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::StandardError Property
Regression StandardError statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double StandardError { get; }
Public ReadOnly Property StandardError As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.StandardError

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


TheilsU Property

Visual Basic Usage

CB Com Devkit
PredStatistics..::TheilsU Property
Series TheilsU statistic.

Namespace: Decisioneering.CB.CBCOMDevKit.Predictor
Assembly: CBCOMDevKit (in CBCOMDevKit.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public double TheilsU { get; }
Public ReadOnly Property TheilsU As Double
    Get
Dim instance As PredStatistics
Dim value As Double

value = instance.TheilsU

See Also

PredStatistics Class
Decisioneering.CB.CBCOMDevKit.Predictor Namespace


Decisioneering.CB.CBExtension.SVS Namespace

Visual Basic Usage

CB Com Devkit
Decisioneering.CB.CBExtension.SVS Namespace
Smart View Extension COM and .NET Development Kit Namespace

Types

All Types | Classes | Enumerations
Name | Description
CellDimension | Cell dimension consisting of Dimension name and active member
CellDimensionEnumerator | Cell Dimension enumerator class.
SmartViewSyncHandling | Apporach to handling CB SmartView Sync errors for operations.
SVAPIGlobalOptions | Option values for SV Sheet Options API
SVAPISheetOptions | Option values for SV Sheet Options API
SVSCalcScript | A single Smart View calc script. There are multiple for an Essbase database. VTS Version: Current serialized property versions: CB Build 11.1.2.0.00: First version
SVSCellInfo | This class represents the Smart View Cell Information extracted from the SmartView Cell XML. This is a set of Dimensions and members that locate this cell in the cube.
SVSCellInfoEnumerator | Smart View Variable Data enumerator class.
SVSCellMetaData | Smart View cell metadata, This represents the MetaData returned by SmartView. This data is converted to XML by the ToXML method and stored with Crystal Ball variables associated with the cell.
SVSConfigurationDialog | The SmartView Simulator configuration dialog
SVSErrors | Smart View Error numbers. The base number for each of these errors is 7000.
SVSExtension | CB Smart View Simulator extension.
SVSheetType | Smart View Sheet types
SVSScriptEnumerator | Smart View Script enumerator class.
SVSWorksheetInfo | The Smart View worksheet information class.
SVSWorksheetInfoEnumerator | Smart View Worksheet Information enumerator class.


CellDimension Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
CellDimension Class
Cell dimension consisting of Dimension name and active member

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[SerializableAttribute]
public class CellDimension : ICloneable,
    IComparable
<SerializableAttribute> _
Public Class CellDimension _
    Implements ICloneable, IComparable
Dim instance As CellDimension

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CellDimension()()()() | Create a Smart View Cell Dimension class
Clone()()()() | Copy of this object
CompareTo(Object) | Comparable results
Equals(Object) | Check Objects are equal (Overrides Object..::..Equals(Object).)
GetHashCode()()()() | Get Hash code for object (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Member | Selected Member for the Smart View Dimension
Name | Name of the Smart View Dimension
ToString()()()() | Show as string (Overrides Object..::..ToString()()()().)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBExtension.SVS..::..CellDimension

See Also

Decisioneering.CB.CBExtension.SVS Namespace


CellDimension Constructor

Visual Basic Usage

CB Com Devkit
CellDimension Constructor
Create a Smart View Cell Dimension class

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public CellDimension()
Public Sub New
Dim instance As New CellDimension()

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


CellDimension Methods

Visual Basic Usage

CB Com Devkit
CellDimension Methods

The CellDimension type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Clone()()()() | Copy of this object
CompareTo(Object) | Comparable results
Equals(Object) | Check Objects are equal (Overrides Object..::..Equals(Object).)
GetHashCode()()()() | Get Hash code for object (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Show as string (Overrides Object..::..ToString()()()().)

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


Clone Method

Visual Basic Usage

CB Com Devkit
CellDimension..::Clone Method
Copy of this object

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Clone()
Public Function Clone As Object
Dim instance As CellDimension
Dim returnValue As Object

returnValue = instance.Clone()

Return Value

Copy of object

Implements

ICloneable..::..Clone()()()()

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


CompareTo Method

Visual Basic Usage

CB Com Devkit
CellDimension..::CompareTo Method
Comparable results

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CompareTo(
    Object objCompare
)
Public Function CompareTo ( _
    objCompare As Object _
) As Integer
Dim instance As CellDimension
Dim objCompare As Object
Dim returnValue As Integer

returnValue = instance.CompareTo(objCompare)

Parameters

objCompare
Object
Object to compare to

Return Value

Less than zero for less than, zero for equals and greater than zero for greater than.

Implements

IComparable..::..CompareTo(Object)

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


Equals Method

Visual Basic Usage

CB Com Devkit
CellDimension..::Equals Method
Check Objects are equal

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Equals(
    Object objCompare
)
Public Overrides Function Equals ( _
    objCompare As Object _
) As Boolean
Dim instance As CellDimension
Dim objCompare As Object
Dim returnValue As Boolean

returnValue = instance.Equals(objCompare)

Parameters

objCompare
Object
Object to compare to

Return Value

true if equal

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


GetHashCode Method

Visual Basic Usage

CB Com Devkit
CellDimension..::GetHashCode Method
Get Hash code for object

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Dim instance As CellDimension
Dim returnValue As Integer

returnValue = instance.GetHashCode()

Return Value

Hash code for object

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
CellDimension..::ToString Method
Show as string

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As CellDimension
Dim returnValue As String

returnValue = instance.ToString()

Return Value

String for this cell dimension

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


CellDimension Properties

Visual Basic Usage

CB Com Devkit
CellDimension Properties

The CellDimension type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Member | Selected Member for the Smart View Dimension
Name | Name of the Smart View Dimension

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


Member Property

Visual Basic Usage

CB Com Devkit
CellDimension..::Member Property
Selected Member for the Smart View Dimension

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Member { get; set; }
Public Property Member As String
    Get
    Set
Dim instance As CellDimension
Dim value As String

value = instance.Member

instance.Member = value

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


Name Property

Visual Basic Usage

CB Com Devkit
CellDimension..::Name Property
Name of the Smart View Dimension

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Dim instance As CellDimension
Dim value As String

value = instance.Name

instance.Name = value

See Also

CellDimension Class
Decisioneering.CB.CBExtension.SVS Namespace


CellDimensionEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
CellDimensionEnumerator Class
Cell Dimension enumerator class.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class CellDimensionEnumerator : VarEnumerator
Public Class CellDimensionEnumerator _
    Inherits VarEnumerator
Dim instance As CellDimensionEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToArrayList()()()() | Convert to an ArrayList.
ToList()()()() | Convert to a List.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBExtension.SVS..::..CellDimensionEnumerator

See Also

Decisioneering.CB.CBExtension.SVS Namespace


CellDimensionEnumerator Methods

Visual Basic Usage

CB Com Devkit
CellDimensionEnumerator Methods

The CellDimensionEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToArrayList()()()() | Convert to an ArrayList.
ToList()()()() | Convert to a List.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CellDimensionEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
CellDimensionEnumerator..::Reload Method
Sync and Reload Constraint vars

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As CellDimensionEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

True on success.

Implements

IVarEnumerator..::..Reload()()()()

See Also

CellDimensionEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


ToArrayList Method

Visual Basic Usage

CB Com Devkit
CellDimensionEnumerator..::ToArrayList Method
Convert to an ArrayList.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ArrayList ToArrayList()
Public Function ToArrayList As ArrayList
Dim instance As CellDimensionEnumerator
Dim returnValue As ArrayList

returnValue = instance.ToArrayList()

Return Value

an ArrayList

See Also

CellDimensionEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


ToList Method

Visual Basic Usage

CB Com Devkit
CellDimensionEnumerator..::ToList Method
Convert to a List.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public List<CellDimension> ToList()
Public Function ToList As List(Of CellDimension)
Dim instance As CellDimensionEnumerator
Dim returnValue As List(Of CellDimension)

returnValue = instance.ToList()

Return Value

a List

See Also

CellDimensionEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


CellDimensionEnumerator Properties

Visual Basic Usage

CB Com Devkit
CellDimensionEnumerator Properties

The CellDimensionEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

CellDimensionEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Current Property

Visual Basic Usage

CB Com Devkit
CellDimensionEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As CellDimensionEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

CellDimensionEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Item Property

Visual Basic Usage

CB Com Devkit
CellDimensionEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public CellDimension this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As CellDimension
    Get
Dim instance As CellDimensionEnumerator
Dim index As Integer
Dim value As CellDimension

value = instance(index)

Parameters

index
Int32

See Also

CellDimensionEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


SmartViewSyncHandling Enumeration

Visual Basic Usage

CB Com Devkit
SmartViewSyncHandling Enumeration
Apporach to handling CB SmartView Sync errors for operations.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SmartViewSyncHandling
Public Enumeration SmartViewSyncHandling
Dim instance As SmartViewSyncHandling

Members

Member | Description
IgnoreAndContinue | Ignore and continue the operation.
RemoveAndCancel | Remove any out of Sync variables and cancel the operation.
Cancel | Cancel the operation.

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVAPIGlobalOptions Enumeration

Visual Basic Usage

CB Com Devkit
SVAPIGlobalOptions Enumeration
Option values for SV Sheet Options API

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SVAPIGlobalOptions
Public Enumeration SVAPIGlobalOptions
Dim instance As SVAPIGlobalOptions

Members

Member | Description
RetainRibbonContext | keeps as SV Ribbon Context

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVAPISheetOptions Enumeration

Visual Basic Usage

CB Com Devkit
SVAPISheetOptions Enumeration
Option values for SV Sheet Options API

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SVAPISheetOptions
Public Enumeration SVAPISheetOptions
Dim instance As SVAPISheetOptions

Members

Member | Description
NullTextString | Cell text for Null data

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSCalcScript Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSCalcScript Class
A single Smart View calc script. There are multiple for an Essbase database. VTS Version: Current serialized property versions: CB Build 11.1.2.0.00: First version

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[SerializableAttribute]
public class SVSCalcScript
<SerializableAttribute> _
Public Class SVSCalcScript
Dim instance As SVSCalcScript

Members

All Members | Fields | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BRHasPrompts | The calc script has prompts or parameters
BRHidePrompts | Do not show prompts
BRName | Script (Businesss rule) name
BRNeedsPageInfo | The calc script needs Page information
BRParmNames | Current parameter names list
BRParmValues | Current parameter values list
BRRuleOnForm | Script Rule is on a Form
BRType | The type of calc script
ClearParms()()()() | Clear any parameters (will need to re-prompt)
CubeName | The cube name for the calc script
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCalcScript()()()() | Run the calc script
ExtendedScript | A simple calc script
GetCalcScriptParms()()()() | Get the calc script parmeters from the user, show the UI if needed.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
LastRanSuccessfully | Last run result
NoneSelected | No calc script has been selected for calculation
Reset()()()() | Reset the script, Clear any parameters (will need to re-prompt) reset any run prompt.
RunCount | Number of times run
ShowParmDialogIfNeeded | Show parameter dialog
Success | Last execute result
ToString()()()() | String version of script (Overrides Object..::..ToString()()()().)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBExtension.SVS..::..SVSCalcScript

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSCalcScript Fields

Visual Basic Usage

CB Com Devkit
SVSCalcScript Fields

The SVSCalcScript type exposes the following fields.

Fields

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BRHasPrompts | The calc script has prompts or parameters
BRHidePrompts | Do not show prompts
BRNeedsPageInfo | The calc script needs Page information
BRParmNames | Current parameter names list
BRParmValues | Current parameter values list
BRRuleOnForm | Script Rule is on a Form
BRType | The type of calc script
CubeName | The cube name for the calc script
ExtendedScript | A simple calc script
LastRanSuccessfully | Last run result
NoneSelected | No calc script has been selected for calculation
RunCount | Number of times run
ShowParmDialogIfNeeded | Show parameter dialog
Success | Last execute result

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


BRHasPrompts Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::BRHasPrompts Field
The calc script has prompts or parameters

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool BRHasPrompts
Public BRHasPrompts As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.BRHasPrompts

instance.BRHasPrompts = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


BRHidePrompts Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::BRHidePrompts Field
Do not show prompts

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool BRHidePrompts
Public BRHidePrompts As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.BRHidePrompts

instance.BRHidePrompts = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


BRNeedsPageInfo Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::BRNeedsPageInfo Field
The calc script needs Page information

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool BRNeedsPageInfo
Public BRNeedsPageInfo As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.BRNeedsPageInfo

instance.BRNeedsPageInfo = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


BRParmNames Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::BRParmNames Field
Current parameter names list

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[NonSerializedAttribute]
public string[] BRParmNames
<NonSerializedAttribute> _
Public BRParmNames As String()
Dim instance As SVSCalcScript
Dim value As String()

value = instance.BRParmNames

instance.BRParmNames = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


BRParmValues Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::BRParmValues Field
Current parameter values list

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[NonSerializedAttribute]
public string[] BRParmValues
<NonSerializedAttribute> _
Public BRParmValues As String()
Dim instance As SVSCalcScript
Dim value As String()

value = instance.BRParmValues

instance.BRParmValues = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


BRRuleOnForm Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::BRRuleOnForm Field
Script Rule is on a Form

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool BRRuleOnForm
Public BRRuleOnForm As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.BRRuleOnForm

instance.BRRuleOnForm = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


BRType Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::BRType Field
The type of calc script

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string BRType
Public BRType As String
Dim instance As SVSCalcScript
Dim value As String

value = instance.BRType

instance.BRType = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


CubeName Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::CubeName Field
The cube name for the calc script

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CubeName
Public CubeName As String
Dim instance As SVSCalcScript
Dim value As String

value = instance.CubeName

instance.CubeName = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


ExtendedScript Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::ExtendedScript Field
A simple calc script

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ExtendedScript
Public ExtendedScript As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.ExtendedScript

instance.ExtendedScript = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


LastRanSuccessfully Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::LastRanSuccessfully Field
Last run result

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[NonSerializedAttribute]
public bool LastRanSuccessfully
<NonSerializedAttribute> _
Public LastRanSuccessfully As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.LastRanSuccessfully

instance.LastRanSuccessfully = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


NoneSelected Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::NoneSelected Field
No calc script has been selected for calculation

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool NoneSelected
Public NoneSelected As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.NoneSelected

instance.NoneSelected = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


RunCount Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::RunCount Field
Number of times run

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[NonSerializedAttribute]
public int RunCount
<NonSerializedAttribute> _
Public RunCount As Integer
Dim instance As SVSCalcScript
Dim value As Integer

value = instance.RunCount

instance.RunCount = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


ShowParmDialogIfNeeded Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::ShowParmDialogIfNeeded Field
Show parameter dialog

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[NonSerializedAttribute]
public bool ShowParmDialogIfNeeded
<NonSerializedAttribute> _
Public ShowParmDialogIfNeeded As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.ShowParmDialogIfNeeded

instance.ShowParmDialogIfNeeded = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


Success Field

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::Success Field
Last execute result

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[NonSerializedAttribute]
public bool Success
<NonSerializedAttribute> _
Public Success As Boolean
Dim instance As SVSCalcScript
Dim value As Boolean

value = instance.Success

instance.Success = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSCalcScript Methods

Visual Basic Usage

CB Com Devkit
SVSCalcScript Methods

The SVSCalcScript type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClearParms()()()() | Clear any parameters (will need to re-prompt)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteCalcScript()()()() | Run the calc script
GetCalcScriptParms()()()() | Get the calc script parmeters from the user, show the UI if needed.
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Reset()()()() | Reset the script, Clear any parameters (will need to re-prompt) reset any run prompt.
ToString()()()() | String version of script (Overrides Object..::..ToString()()()().)

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


ClearParms Method

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::ClearParms Method
Clear any parameters (will need to re-prompt)

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ClearParms()
Public Sub ClearParms
Dim instance As SVSCalcScript

instance.ClearParms()

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


ExecuteCalcScript Method

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::ExecuteCalcScript Method
Run the calc script

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ExecuteCalcScript()
Public Function ExecuteCalcScript As Boolean
Dim instance As SVSCalcScript
Dim returnValue As Boolean

returnValue = instance.ExecuteCalcScript()

Return Value

True if run successfully

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


GetCalcScriptParms Method

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::GetCalcScriptParms Method
Get the calc script parmeters from the user, show the UI if needed.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool GetCalcScriptParms()
Public Function GetCalcScriptParms As Boolean
Dim instance As SVSCalcScript
Dim returnValue As Boolean

returnValue = instance.GetCalcScriptParms()

Return Value

True on success

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


Reset Method

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::Reset Method
Reset the script, Clear any parameters (will need to re-prompt) reset any run prompt.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void Reset()
Public Sub Reset
Dim instance As SVSCalcScript

instance.Reset()

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::ToString Method
String version of script

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As SVSCalcScript
Dim returnValue As String

returnValue = instance.ToString()

Return Value

string version

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSCalcScript Properties

Visual Basic Usage

CB Com Devkit
SVSCalcScript Properties

The SVSCalcScript type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BRName | Script (Businesss rule) name

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


BRName Property

Visual Basic Usage

CB Com Devkit
SVSCalcScript..::BRName Property
Script (Businesss rule) name

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string BRName { get; set; }
Public Property BRName As String
    Get
    Set
Dim instance As SVSCalcScript
Dim value As String

value = instance.BRName

instance.BRName = value

See Also

SVSCalcScript Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSCellInfo Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSCellInfo Class
This class represents the Smart View Cell Information extracted from the SmartView Cell XML. This is a set of Dimensions and members that locate this cell in the cube.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class SVSCellInfo
Public Class SVSCellInfo
Dim instance As SVSCellInfo

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CaptureFormatting(Boolean) | Capture and preserve any cell formatting
CBVar | The associated CB variable if any
Cell | Get the associated cell
CellDimensions | The cell dimension data. COM interface is GetCellDimensions.
Equals(Object) | Are these the same object (use object identity) (Overrides Object..::..Equals(Object).)
GetHashCode()()()() | Get a hash code (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
InSync | Is this CB Variable's SmartView data in sync with that stored last in Object Store.
IsAddedSVVar | Added to the existing SV var list due to a new scan.
IsNewSVVar | Is this CB Variable a new SmartView variable, that is Object store does not previously have this recored as a Smart View Var.
IsSVVar | Is this CB Variable defined on SmartView data.
SVCellMetaData | The Smart View cell Meta Data (dimension data)
SVWorksheetInfo | Returns the associated Smart View worksheet info if available.
SyncSVCellMetaData()()()() | Sync the cell XML data to object store if out of sync
ToString()()()() | String showing members (Overrides Object..::..ToString()()()().)
ToString(Boolean, Boolean, String) | String showing members
VCell | The associated cell

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBExtension.SVS..::..SVSCellInfo

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSCellInfo Methods

Visual Basic Usage

CB Com Devkit
SVSCellInfo Methods

The SVSCellInfo type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CaptureFormatting(Boolean) | Capture and preserve any cell formatting
Equals(Object) | Are these the same object (use object identity) (Overrides Object..::..Equals(Object).)
GetHashCode()()()() | Get a hash code (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
SyncSVCellMetaData()()()() | Sync the cell XML data to object store if out of sync
ToString()()()() | String showing members (Overrides Object..::..ToString()()()().)
ToString(Boolean, Boolean, String) | String showing members

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


CaptureFormatting Method

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::CaptureFormatting Method
Capture and preserve any cell formatting

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void CaptureFormatting(
    bool doCapture
)
Public Sub CaptureFormatting ( _
    doCapture As Boolean _
)
Dim instance As SVSCellInfo
Dim doCapture As Boolean

instance.CaptureFormatting(doCapture)

Parameters

doCapture
Boolean
True to enable

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


Equals Method

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::Equals Method
Are these the same object (use object identity)

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Dim instance As SVSCellInfo
Dim obj As Object
Dim returnValue As Boolean

returnValue = instance.Equals(obj)

Parameters

obj
Object
object to compare

Return Value

true if the same Object Identity

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


GetHashCode Method

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::GetHashCode Method
Get a hash code

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Dim instance As SVSCellInfo
Dim returnValue As Integer

returnValue = instance.GetHashCode()

Return Value

hash code

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SyncSVCellMetaData Method

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::SyncSVCellMetaData Method
Sync the cell XML data to object store if out of sync

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SyncSVCellMetaData()
Public Sub SyncSVCellMetaData
Dim instance As SVSCellInfo

instance.SyncSVCellMetaData()

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::ToString Method

Overload List

Name | Description
ToString()()()() | String showing members (Overrides Object.ToString()()()().)
ToString(Boolean, Boolean, String) | String showing members

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::ToString Method
String showing members

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As SVSCellInfo
Dim returnValue As String

returnValue = instance.ToString()

Return Value

text representation

See Also

SVSCellInfo Class
ToString Overload
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method (Boolean, Boolean, String)

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::ToString Method (Boolean, Boolean, String)
String showing members

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ToString(
    bool multiLine,
    bool includeLastData,
    string indent
)
Public Function ToString ( _
    multiLine As Boolean, _
    includeLastData As Boolean, _
    indent As String _
) As String
Dim instance As SVSCellInfo
Dim multiLine As Boolean
Dim includeLastData As Boolean
Dim indent As String
Dim returnValue As String

returnValue = instance.ToString(multiLine, _
    includeLastData, indent)

Parameters

multiLine
Boolean
show in one line
includeLastData
Boolean
Include the last data
indent
String
indent string

Return Value

text representation

See Also

SVSCellInfo Class
ToString Overload
Decisioneering.CB.CBExtension.SVS Namespace


SVSCellInfo Properties

Visual Basic Usage

CB Com Devkit
SVSCellInfo Properties

The SVSCellInfo type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CBVar | The associated CB variable if any
Cell | Get the associated cell
CellDimensions | The cell dimension data. COM interface is GetCellDimensions.
InSync | Is this CB Variable's SmartView data in sync with that stored last in Object Store.
IsAddedSVVar | Added to the existing SV var list due to a new scan.
IsNewSVVar | Is this CB Variable a new SmartView variable, that is Object store does not previously have this recored as a Smart View Var.
IsSVVar | Is this CB Variable defined on SmartView data.
SVCellMetaData | The Smart View cell Meta Data (dimension data)
SVWorksheetInfo | Returns the associated Smart View worksheet info if available.
VCell | The associated cell

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


CBVar Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::CBVar Property
The associated CB variable if any

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public CBVar CBVar { get; internal set; }
Public Property CBVar As CBVar
    Get
    Friend Set
Dim instance As SVSCellInfo
Dim value As CBVar

value = instance.CBVar

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


Cell Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::Cell Property
Get the associated cell

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Range Cell { get; }
Public ReadOnly Property Cell As Range
    Get
Dim instance As SVSCellInfo
Dim value As Range

value = instance.Cell

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


CellDimensions Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::CellDimensions Property
The cell dimension data. COM interface is GetCellDimensions.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ArrayList CellDimensions { get; }
Public ReadOnly Property CellDimensions As ArrayList
    Get
Dim instance As SVSCellInfo
Dim value As ArrayList

value = instance.CellDimensions

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


InSync Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::InSync Property
Is this CB Variable's SmartView data in sync with that stored last in Object Store.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool InSync { get; }
Public ReadOnly Property InSync As Boolean
    Get
Dim instance As SVSCellInfo
Dim value As Boolean

value = instance.InSync

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


IsAddedSVVar Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::IsAddedSVVar Property
Added to the existing SV var list due to a new scan.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsAddedSVVar { get; internal set; }
Public Property IsAddedSVVar As Boolean
    Get
    Friend Set
Dim instance As SVSCellInfo
Dim value As Boolean

value = instance.IsAddedSVVar

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


IsNewSVVar Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::IsNewSVVar Property
Is this CB Variable a new SmartView variable, that is Object store does not previously have this recored as a Smart View Var.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsNewSVVar { get; }
Public ReadOnly Property IsNewSVVar As Boolean
    Get
Dim instance As SVSCellInfo
Dim value As Boolean

value = instance.IsNewSVVar

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


IsSVVar Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::IsSVVar Property
Is this CB Variable defined on SmartView data.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSVVar { get; }
Public ReadOnly Property IsSVVar As Boolean
    Get
Dim instance As SVSCellInfo
Dim value As Boolean

value = instance.IsSVVar

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SVCellMetaData Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::SVCellMetaData Property
The Smart View cell Meta Data (dimension data)

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCellMetaData SVCellMetaData { get; }
Public ReadOnly Property SVCellMetaData As SVSCellMetaData
    Get
Dim instance As SVSCellInfo
Dim value As SVSCellMetaData

value = instance.SVCellMetaData

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SVWorksheetInfo Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::SVWorksheetInfo Property
Returns the associated Smart View worksheet info if available.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSWorksheetInfo SVWorksheetInfo { get; }
Public ReadOnly Property SVWorksheetInfo As SVSWorksheetInfo
    Get
Dim instance As SVSCellInfo
Dim value As SVSWorksheetInfo

value = instance.SVWorksheetInfo

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


VCell Property

Visual Basic Usage

CB Com Devkit
SVSCellInfo..::VCell Property
The associated cell

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public VRange VCell { get; internal set; }
Public Property VCell As VRange
    Get
    Friend Set
Dim instance As SVSCellInfo
Dim value As VRange

value = instance.VCell

See Also

SVSCellInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSCellInfoEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSCellInfoEnumerator Class
Smart View Variable Data enumerator class.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class SVSCellInfoEnumerator : VarEnumerator
Public Class SVSCellInfoEnumerator _
    Inherits VarEnumerator
Dim instance As SVSCellInfoEnumerator

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SVSCellInfoEnumerator(ArrayList) | Create the Enumerator
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToArrayList()()()() | Convert to an ArrayList.
ToList()()()() | Convert to a List.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBExtension.SVS..::..SVSCellInfoEnumerator

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSCellInfoEnumerator Constructor

Visual Basic Usage

CB Com Devkit
SVSCellInfoEnumerator Constructor
Create the Enumerator

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCellInfoEnumerator(
    ArrayList svDataVarList
)
Public Sub New ( _
    svDataVarList As ArrayList _
)
Dim svDataVarList As ArrayList

Dim instance As New SVSCellInfoEnumerator(svDataVarList)

Parameters

svDataVarList
ArrayList
List of SVSCellInfo to use

See Also

SVSCellInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSCellInfoEnumerator Methods

Visual Basic Usage

CB Com Devkit
SVSCellInfoEnumerator Methods

The SVSCellInfoEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToArrayList()()()() | Convert to an ArrayList.
ToList()()()() | Convert to a List.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SVSCellInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
SVSCellInfoEnumerator..::Reload Method
Sync and Reload Constraint vars

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As SVSCellInfoEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

True on success>

Implements

IVarEnumerator..::..Reload()()()()

See Also

SVSCellInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


ToArrayList Method

Visual Basic Usage

CB Com Devkit
SVSCellInfoEnumerator..::ToArrayList Method
Convert to an ArrayList.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ArrayList ToArrayList()
Public Function ToArrayList As ArrayList
Dim instance As SVSCellInfoEnumerator
Dim returnValue As ArrayList

returnValue = instance.ToArrayList()

Return Value

an ArrayList

See Also

SVSCellInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


ToList Method

Visual Basic Usage

CB Com Devkit
SVSCellInfoEnumerator..::ToList Method
Convert to a List.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public List<SVSCellInfo> ToList()
Public Function ToList As List(Of SVSCellInfo)
Dim instance As SVSCellInfoEnumerator
Dim returnValue As List(Of SVSCellInfo)

returnValue = instance.ToList()

Return Value

a List

See Also

SVSCellInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSCellInfoEnumerator Properties

Visual Basic Usage

CB Com Devkit
SVSCellInfoEnumerator Properties

The SVSCellInfoEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

SVSCellInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Current Property

Visual Basic Usage

CB Com Devkit
SVSCellInfoEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As SVSCellInfoEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

SVSCellInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Item Property

Visual Basic Usage

CB Com Devkit
SVSCellInfoEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCellInfo this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As SVSCellInfo
    Get
Dim instance As SVSCellInfoEnumerator
Dim index As Integer
Dim value As SVSCellInfo

value = instance(index)

Parameters

index
Int32

See Also

SVSCellInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSCellMetaData Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSCellMetaData Class
Smart View cell metadata, This represents the MetaData returned by SmartView. This data is converted to XML by the ToXML method and stored with Crystal Ball variables associated with the cell.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
[SerializableAttribute]
public class SVSCellMetaData : ICloneable,
    IComparable
<SerializableAttribute> _
Public Class SVSCellMetaData _
    Implements ICloneable, IComparable
Dim instance As SVSCellMetaData

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SVSCellMetaData()()()() | Create empty
AppName | The Smart View App Name for this Cell
CellDimensions | The Smart View cell dimension data
Clone()()()() | Copy of this object
CompareTo(Object) | Comparable results
CubeName | The Smart View Cube Name for this Cell
Equals(Object) | Performs comparison for objects. (Overrides Object..::..Equals(Object).)
FormName | The Smart View Form Name for this Cell
GetCellDimensions()()()() | Get a list of Cell Dimensions for this CB Variable
GetHashCode()()()() | Calculate hashcode over dimensions (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ServerName | The Smart View Server name for this Cell
ToString()()()() | String showing members (Overrides Object..::..ToString()()()().)
ToString(Boolean, String) | String showing members

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBExtension.SVS..::..SVSCellMetaData

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSCellMetaData Constructor

Visual Basic Usage

CB Com Devkit
SVSCellMetaData Constructor
Create empty

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCellMetaData()
Public Sub New
Dim instance As New SVSCellMetaData()

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSCellMetaData Methods

Visual Basic Usage

CB Com Devkit
SVSCellMetaData Methods

The SVSCellMetaData type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Clone()()()() | Copy of this object
CompareTo(Object) | Comparable results
Equals(Object) | Performs comparison for objects. (Overrides Object..::..Equals(Object).)
GetCellDimensions()()()() | Get a list of Cell Dimensions for this CB Variable
GetHashCode()()()() | Calculate hashcode over dimensions (Overrides Object..::..GetHashCode()()()().)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | String showing members (Overrides Object..::..ToString()()()().)
ToString(Boolean, String) | String showing members

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


Clone Method

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::Clone Method
Copy of this object

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Object Clone()
Public Function Clone As Object
Dim instance As SVSCellMetaData
Dim returnValue As Object

returnValue = instance.Clone()

Return Value

copied object

Implements

ICloneable..::..Clone()()()()

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


CompareTo Method

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::CompareTo Method
Comparable results

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public int CompareTo(
    Object objCompare
)
Public Function CompareTo ( _
    objCompare As Object _
) As Integer
Dim instance As SVSCellMetaData
Dim objCompare As Object
Dim returnValue As Integer

returnValue = instance.CompareTo(objCompare)

Parameters

objCompare
Object
Object to compare to

Return Value

Less than zero for less than, zero for equals and greater than zero for greater than.

Implements

IComparable..::..CompareTo(Object)

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


Equals Method

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::Equals Method
Performs comparison for objects.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Equals(
    Object objCompare
)
Public Overrides Function Equals ( _
    objCompare As Object _
) As Boolean
Dim instance As SVSCellMetaData
Dim objCompare As Object
Dim returnValue As Boolean

returnValue = instance.Equals(objCompare)

Parameters

objCompare
Object
Object to compare.

Return Value

True if equal.

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


GetCellDimensions Method

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::GetCellDimensions Method
Get a list of Cell Dimensions for this CB Variable

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public CellDimensionEnumerator GetCellDimensions()
Public Function GetCellDimensions As CellDimensionEnumerator
Dim instance As SVSCellMetaData
Dim returnValue As CellDimensionEnumerator

returnValue = instance.GetCellDimensions()

Return Value

List of cell dimensions

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


GetHashCode Method

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::GetHashCode Method
Calculate hashcode over dimensions

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Dim instance As SVSCellMetaData
Dim returnValue As Integer

returnValue = instance.GetHashCode()

Return Value

Hash Code

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::ToString Method

Overload List

Name | Description
ToString()()()() | String showing members (Overrides Object.ToString()()()().)
ToString(Boolean, String) | String showing members

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::ToString Method
String showing members

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As SVSCellMetaData
Dim returnValue As String

returnValue = instance.ToString()

Return Value

String showing members

See Also

SVSCellMetaData Class
ToString Overload
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method (Boolean, String)

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::ToString Method (Boolean, String)
String showing members

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ToString(
    bool multiLine,
    string startIndent
)
Public Function ToString ( _
    multiLine As Boolean, _
    startIndent As String _
) As String
Dim instance As SVSCellMetaData
Dim multiLine As Boolean
Dim startIndent As String
Dim returnValue As String

returnValue = instance.ToString(multiLine, _
    startIndent)

Parameters

multiLine
Boolean
Write on multiple lines
startIndent
String
String containing starting indent text

Return Value

String showing members

See Also

SVSCellMetaData Class
ToString Overload
Decisioneering.CB.CBExtension.SVS Namespace


SVSCellMetaData Properties

Visual Basic Usage

CB Com Devkit
SVSCellMetaData Properties

The SVSCellMetaData type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AppName | The Smart View App Name for this Cell
CellDimensions | The Smart View cell dimension data
CubeName | The Smart View Cube Name for this Cell
FormName | The Smart View Form Name for this Cell
ServerName | The Smart View Server name for this Cell

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


AppName Property

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::AppName Property
The Smart View App Name for this Cell

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string AppName { get; set; }
Public Property AppName As String
    Get
    Set
Dim instance As SVSCellMetaData
Dim value As String

value = instance.AppName

instance.AppName = value

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


CellDimensions Property

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::CellDimensions Property
The Smart View cell dimension data

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ArrayList CellDimensions { get; internal set; }
Public Property CellDimensions As ArrayList
    Get
    Friend Set
Dim instance As SVSCellMetaData
Dim value As ArrayList

value = instance.CellDimensions

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


CubeName Property

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::CubeName Property
The Smart View Cube Name for this Cell

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string CubeName { get; set; }
Public Property CubeName As String
    Get
    Set
Dim instance As SVSCellMetaData
Dim value As String

value = instance.CubeName

instance.CubeName = value

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


FormName Property

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::FormName Property
The Smart View Form Name for this Cell

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string FormName { get; set; }
Public Property FormName As String
    Get
    Set
Dim instance As SVSCellMetaData
Dim value As String

value = instance.FormName

instance.FormName = value

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


ServerName Property

Visual Basic Usage

CB Com Devkit
SVSCellMetaData..::ServerName Property
The Smart View Server name for this Cell

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
Dim instance As SVSCellMetaData
Dim value As String

value = instance.ServerName

instance.ServerName = value

See Also

SVSCellMetaData Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSConfigurationDialog Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSConfigurationDialog Class
The SmartView Simulator configuration dialog

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class SVSConfigurationDialog : Form
Public Class SVSConfigurationDialog _
    Inherits Form
Dim instance As SVSConfigurationDialog

Members

All Members | Constructors | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SVSConfigurationDialog()()()() | Default constructor
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Activate()()()() | Activates the form and gives it focus. (Inherited from Form.)
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AddOwnedForm(Form) | Adds an owned form to this form. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Close()()()() | Closes the form. (Inherited from Form.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
CreateControl()()()() | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
Focus()()()() | Sets input focus to the control. (Inherited from Control.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Hide()()()() | Conceals the control from the user. (Inherited from Control.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
LayoutMdi(MdiLayout) | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MarginChanged | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreserveHighlighting | Specifies if we have to preserve the highlighting
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
RemoveOwnedForm(Form) | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Select()()()() | Activates the control. (Inherited from Control.)
SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
SetDesktopBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation(Int32, Int32) | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Show()()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
SmartViewIntegrationEnabled | Specifies if SmartView integration is enabled
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStop | (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
ToString()()()() | Gets a string representing the current instance of the form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
ValidateChildren()()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Decisioneering.CB.CBExtension.SVS..::..SVSConfigurationDialog

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSConfigurationDialog Constructor

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog Constructor
Default constructor

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSConfigurationDialog()
Public Sub New
Dim instance As New SVSConfigurationDialog()

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSConfigurationDialog Methods

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog Methods

The SVSConfigurationDialog type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Activate()()()() | Activates the form and gives it focus. (Inherited from Form.)
AddOwnedForm(Form) | Adds an owned form to this form. (Inherited from Form.)
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
Close()()()() | Closes the form. (Inherited from Form.)
Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
CreateControl()()()() | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
Focus()()()() | Sets input focus to the control. (Inherited from Control.)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Hide()()()() | Conceals the control from the user. (Inherited from Control.)
InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
LayoutMdi(MdiLayout) | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
RemoveOwnedForm(Form) | Removes an owned form from this form. (Inherited from Form.)
ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Select()()()() | Activates the control. (Inherited from Control.)
SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
SetDesktopBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
SetDesktopLocation(Int32, Int32) | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Show()()()() | Displays the control to the user. (Inherited from Control.)
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
ToString()()()() | Gets a string representing the current instance of the form. (Inherited from Form.)
Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
ValidateChildren()()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


BeginInvoke Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::BeginInvoke Method

Overload List

Name | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


GetChildAtPoint Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::GetChildAtPoint Method

Overload List

Name | Description
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.
GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


Invalidate Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::Invalidate Method

Overload List

Name | Description
Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


Invoke Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::Invoke Method

Overload List

Name | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


PerformLayout Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::PerformLayout Method

Overload List

Name | Description
PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


ResumeLayout Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::ResumeLayout Method

Overload List

Name | Description
ResumeLayout()()()() | Resumes usual layout logic.
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


Scale Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::Scale Method

Overload List

Name | Description
Scale(Single) | Obsolete. Scales the control and any child controls.
Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.
Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


SetBounds Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::SetBounds Method

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


Show Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::Show Method

Overload List

Name | Description
Show()()()() | Displays the control to the user.
Show(IWin32Window) | Shows the form with the specified owner to the user.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


ShowDialog Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::ShowDialog Method

Overload List

Name | Description
ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner.
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


Validate Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::Validate Method

Overload List

Name | Description
Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


ValidateChildren Method

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::ValidateChildren Method

Overload List

Name | Description
ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSConfigurationDialog Properties

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog Properties

The SVSConfigurationDialog type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
DataBindings | Gets the data bindings for the control. (Inherited from Control.)
DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Height | Gets or sets the height of the control. (Inherited from Control.)
HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Icon | Gets or sets the icon for the form. (Inherited from Form.)
ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Name | Gets or sets the name of the control. (Inherited from Control.)
Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Padding | Gets or sets padding within the control. (Inherited from Control.)
Parent | Gets or sets the parent container of the control. (Inherited from Control.)
ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
PreserveHighlighting | Specifies if we have to preserve the highlighting
ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Region | Gets or sets the window region associated with the control. (Inherited from Control.)
RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Site | Gets or sets the site of the control. (Inherited from Control.)
Size | Gets or sets the size of the form. (Inherited from Form.)
SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
SmartViewIntegrationEnabled | Specifies if SmartView integration is enabled
StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Text | (Inherited from Form.)
Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Width | Gets or sets the width of the control. (Inherited from Control.)
WindowState | Gets or sets the form's window state. (Inherited from Form.)
WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


PreserveHighlighting Property

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::PreserveHighlighting Property
Specifies if we have to preserve the highlighting

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool PreserveHighlighting { get; set; }
Public Property PreserveHighlighting As Boolean
    Get
    Set
Dim instance As SVSConfigurationDialog
Dim value As Boolean

value = instance.PreserveHighlighting

instance.PreserveHighlighting = value

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


SmartViewIntegrationEnabled Property

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog..::SmartViewIntegrationEnabled Property
Specifies if SmartView integration is enabled

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SmartViewIntegrationEnabled { get; set; }
Public Property SmartViewIntegrationEnabled As Boolean
    Get
    Set
Dim instance As SVSConfigurationDialog
Dim value As Boolean

value = instance.SmartViewIntegrationEnabled

instance.SmartViewIntegrationEnabled = value

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSConfigurationDialog Events

Visual Basic Usage

CB Com Devkit
SVSConfigurationDialog Events

The SVSConfigurationDialog type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Click | Occurs when the control is clicked. (Inherited from Control.)
ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Closed | Occurs when the form is closed. (Inherited from Form.)
Closing | Occurs when the form is closing. (Inherited from Form.)
ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Enter | Occurs when the control is entered. (Inherited from Control.)
FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
FormClosed | Occurs after the form is closed. (Inherited from Form.)
FormClosing | Occurs before the form is closed. (Inherited from Form.)
GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
GotFocus | Occurs when the control receives focus. (Inherited from Control.)
HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
LostFocus | Occurs when the control loses focus. (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Move | Occurs when the control is moved. (Inherited from Control.)
PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Paint | Occurs when the control is redrawn. (Inherited from Control.)
ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Resize | Occurs when the control is resized. (Inherited from Control.)
ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
StyleChanged | Occurs when the control style changes. (Inherited from Control.)
SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Validated | Occurs when the control is finished validating. (Inherited from Control.)
Validating | Occurs when the control is validating. (Inherited from Control.)
VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

SVSConfigurationDialog Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSErrors Enumeration

Visual Basic Usage

CB Com Devkit
SVSErrors Enumeration
Smart View Error numbers. The base number for each of these errors is 7000.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SVSErrors
Public Enumeration SVSErrors
Dim instance As SVSErrors

Members

Member | Description
CBVarSyncCancelError | CB Variable Sync to Smart View with Cancel Error
CBVarSyncRemoveError | CB Variable Sync to Smart View with Remove Error
CalcScriptParmsNoUIError | Calculation script cannot be run from Devkit because it requires user input parameters
SmartViewCellNotUpdatableError | The Smart View Cell is Not Updatable Error on Define/Paste of CB Var
SmartViewDataModifiedError | The Smart View data has been modified Error
SmartViewFusionLicenseError | A Fusion license required for Smart View data was not detected Error
SmartViewCellDoesNotExistError | Smart View data does not exist for the specified cell
SmartViewWorksheetDoesNotExistError | Smart View data does not exist for the specified worksheet
SmartViewExtensionNotEnabledError | The Crystal Ball Smart View extension is not enabled
SmartViewAddInNotLoadedError | The Smart View Addin is not loaded
SmartViewWorksheetNotConnectedError | The Smart View worksheet is not connected
SmartViewInvalidLoginError | Error on invalid login credentials
SmartViewSyncLocationError | CB Object could not be Synced as adjusted location is overlaps another CB object
SmartViewSyncSVDataDoesNotExistError | The CB Object is not in Sync since the Smart View cell no longer exists in the current data view
SmartViewSyncNewSVDataError | CB Object is not in Sync since it's location no longer contains any Smart View data
SmartViewCellNotInDataAreaError | The Smart View Cell is Not in the data area Error
SmartViewAddinVersionInvalid | The Smart View Addin version is not valid
SmartViewClearProtectionsError | Failed to clear sheet protections on Smart View worksheet
SmartViewDynamicAsmParmsError | Simulation or Optimization aborted due to Dynamic Assumption Parameters detected
SmartViewForecastMissingDataError | SmartView Forecast defined on Missing Data Error
SmartViewDisabledCancelOperationWarning | SmartView integration is disabled, user canceled operation
SmartViewMultiWorkbookCancelOperationWarning | SmartView multiple workbook operation, canceled operation
SmartViewAddinDisabledError | Smart View addin is disabled error
SmartViewCellNotUpdatableShortError | The Smart View Cell is Not Updatable Error on Define/Paste of CB Var or other where Operation text is not provided
SmartViewCellNotInDataAreaShortError | The Smart View Cell is Not in the data area Error on Define/Paste of CB Var or other where Operation text is not provided
SmartViewCellNotValidForDataError | The Smart View Cell is Not in the data area Error on Define/Paste of double data or other
SmartViewServerConnectionError | Smart View server connection error
SmartViewUnknownServerError | Undetermined Smart View server error
SmartViewExpectedCBError | Recieved an expected CB error
SmartViewAddinNotEnabledError | The Smart View Excel add-in is not enabled
SmartViewWorksheetsNotDetected | No Smart View worksheets detected

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSExtension Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSExtension Class
CB Smart View Simulator extension.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class SVSExtension : CBExtension
Public Class SVSExtension _
    Inherits CBExtension
Dim instance As SVSExtension

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SVSExtension()()()() | Connect to load handlers on construct
BaseErrorNumber | The Base Error Number for this extension. (Overrides CBExtensionBaseErrorNumber()()()().)
CheckEnabled()()()() | Check enabled state, skip command logging processing (Overrides CBExtensionCheckEnabled()()()().)
ContinueWithDynamicAssumptions | Continue simulation or Optimization operations in the presence of dynamic assumption parameters. (Assumptions with cell refreence parameters). The default is true.
ContinueWithoutEPMLicense | Continue to operate with Smart View worksheets if EPM license is not present. If true, the SmartViewFusionLicenseError will not be returned and SmartView worksheet data will be treated as normal Crystal Ball worksheet data. This could cause Crystal Ball operations to fail on your Smart View worksheets. If false, any operation on a Smart View sheet will return the SmartViewFusionLicenseError. The default for this property is false and the state is saved for a single CB session only.
ContinueWithSVAddinDisabled | Continue to operate with Smart View worksheets if the Smart Viw addin is disabled. If true, the SmartViewAddinDisabledError will not be returned and SmartView worksheet data will be treated as normal Crystal Ball worksheet data. This could cause Crystal Ball operations to fail on your Smart View worksheets. If false, any operation on a Smart View sheet will return the SmartViewAddinDisabledError. The default for this property is false and the state is saved for a single CB session.
Description | Extension name (Overrides CBExtensionDescription()()()().)
Enabled | Indicates if the extension is enabled. State is stored in global prefs. Default is True (Overrides CBExtensionEnabled()()()().)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllSmartViewCellInfo(CBVarType, Boolean) | Get all the CB Smart View Cell Info list for all Cryatal Ball objects. This list contains the Cell info for each Crystal Ball object that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object list contains the Smart View data properties for each cell.
GetAllSmartViewWorksheetInfo(Boolean) | Get all CB Smart View Worksheets. A SmartView worksheet is one that has been identified as having Smart View data associated with it.
GetCBVarCellInfo(CBVar) | Get Smart View XML data property
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetSmartViewCellInfo(Range, Boolean) | Get the CB Smart View Cell Info located at a specific cell. This is the Cell info for a Crystal Ball object (Assumption, Forecast or Decision Variable) that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object contains the Smart View data properties for that cell.
GetSmartViewWorksheetInfo(Worksheet, Boolean) | Get a CB Smart View Worksheet. A SmartView worksheet is one that has been identified as having Smart View data associated with it.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GetWorksheetSmartViewCellInfo(Worksheet, CBVarType, Boolean) | Get the CB Smart View Cell Info list for all Cryatal Ball objects located in the specified worksheet. This list contains the Cell info for each Crystal Ball object that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object list contains the Smart View data properties for each cell.
IsSmartViewAddinLoaded | Check if SmartView addin is loaded
IsSmartViewConnected(Worksheet) | Determine if a SmartView worksheet is connected.
Name | Extension name (Overrides CBExtensionName()()()().)
ShowConfigurationDialog()()()() | Show the Crystal Ball Smart View extension configuration dialog
ShowSmartViewLogin | Show Login if needed when connecting to SmartView due to a Devkit call
SmartViewCommandStatusAnnotation | Returns the CB Smart View Extension command status annotation. This is the added status applied to the Excel Status Bar and Control Panel.
SmartViewConnect(Worksheet, String, String) | Connect a SmartView worksheet data connection. This operation must be accomplished prior to performing any operations on a Smart View worksheet. Note: If the user name and pasword are empty, a login dialog may be shown.
SmartViewSyncHandling | Approach to handling CB SmartView Sync errors for operations. The default approach is SmartViewSyncHandling.Cancel.
SVM | Internal Property, must be false
SVSPreserveCBCellHighlighting | Preserve any CB data highlighting (Asm, Frc and DecVar cell coloring). State is stored in global prefs.
ToString()()()() | Convert to string (Overrides Object..::..ToString()()()().)
ValidateSmartViewDataConnections()()()() | Validate all SmartView connections. This will display one or more SmartView login prompts if ShowSmartViewLogin is enabled, otherwise will return an error if not connected. Errors may include: (from Decisioneering.CB.CBExtension.SVS.SVSErrors) SmartViewAddInNotLoadedError SmartViewAddinVersionInvalid SmartViewExtensionNotEnabledError SmartViewFusionLicenseError SmartViewWorksheetNotConnectedError CBVarSyncCancelError (data is out of sync)

Inheritance Hierarchy

System..::..Object
CBExtension
Decisioneering.CB.CBExtension.SVS..::..SVSExtension

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSExtension Constructor

Visual Basic Usage

CB Com Devkit
SVSExtension Constructor
Connect to load handlers on construct

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSExtension()
Public Sub New
Dim instance As New SVSExtension()

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSExtension Methods

Visual Basic Usage

CB Com Devkit
SVSExtension Methods

The SVSExtension type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CheckEnabled()()()() | Check enabled state, skip command logging processing (Overrides CBExtensionCheckEnabled()()()().)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetAllSmartViewCellInfo(CBVarType, Boolean) | Get all the CB Smart View Cell Info list for all Cryatal Ball objects. This list contains the Cell info for each Crystal Ball object that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object list contains the Smart View data properties for each cell.
GetAllSmartViewWorksheetInfo(Boolean) | Get all CB Smart View Worksheets. A SmartView worksheet is one that has been identified as having Smart View data associated with it.
GetCBVarCellInfo(CBVar) | Get Smart View XML data property
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetSmartViewCellInfo(Range, Boolean) | Get the CB Smart View Cell Info located at a specific cell. This is the Cell info for a Crystal Ball object (Assumption, Forecast or Decision Variable) that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object contains the Smart View data properties for that cell.
GetSmartViewWorksheetInfo(Worksheet, Boolean) | Get a CB Smart View Worksheet. A SmartView worksheet is one that has been identified as having Smart View data associated with it.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
GetWorksheetSmartViewCellInfo(Worksheet, CBVarType, Boolean) | Get the CB Smart View Cell Info list for all Cryatal Ball objects located in the specified worksheet. This list contains the Cell info for each Crystal Ball object that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object list contains the Smart View data properties for each cell.
IsSmartViewConnected(Worksheet) | Determine if a SmartView worksheet is connected.
ShowConfigurationDialog()()()() | Show the Crystal Ball Smart View extension configuration dialog
SmartViewConnect(Worksheet, String, String) | Connect a SmartView worksheet data connection. This operation must be accomplished prior to performing any operations on a Smart View worksheet. Note: If the user name and pasword are empty, a login dialog may be shown.
ToString()()()() | Convert to string (Overrides Object..::..ToString()()()().)
ValidateSmartViewDataConnections()()()() | Validate all SmartView connections. This will display one or more SmartView login prompts if ShowSmartViewLogin is enabled, otherwise will return an error if not connected. Errors may include: (from Decisioneering.CB.CBExtension.SVS.SVSErrors) SmartViewAddInNotLoadedError SmartViewAddinVersionInvalid SmartViewExtensionNotEnabledError SmartViewFusionLicenseError SmartViewWorksheetNotConnectedError CBVarSyncCancelError (data is out of sync)

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


CheckEnabled Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::CheckEnabled Method
Check enabled state, skip command logging processing

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool CheckEnabled()
Public Overrides Function CheckEnabled As Boolean
Dim instance As SVSExtension
Dim returnValue As Boolean

returnValue = instance.CheckEnabled()

Return Value

True if extension is enabled.

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


GetAllSmartViewCellInfo Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::GetAllSmartViewCellInfo Method
Get all the CB Smart View Cell Info list for all Cryatal Ball objects. This list contains the Cell info for each Crystal Ball object that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object list contains the Smart View data properties for each cell.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCellInfoEnumerator GetAllSmartViewCellInfo(
    CBVarType cbVarType,
    bool syncCBData
)
Public Function GetAllSmartViewCellInfo ( _
    cbVarType As CBVarType, _
    syncCBData As Boolean _
) As SVSCellInfoEnumerator
Dim instance As SVSExtension
Dim cbVarType As CBVarType
Dim syncCBData As Boolean
Dim returnValue As SVSCellInfoEnumerator

returnValue = instance.GetAllSmartViewCellInfo(cbVarType, _
    syncCBData)

Parameters

cbVarType
CBVarType
The CB variable type, none returns all basic types (Assumption, Forecast or Decision Variable)
syncCBData
Boolean
Sync CB data prior after retrieving the Cb variables

Return Value

A list of SmartView variables types as SVCellInfo objects.

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


GetAllSmartViewWorksheetInfo Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::GetAllSmartViewWorksheetInfo Method
Get all CB Smart View Worksheets. A SmartView worksheet is one that has been identified as having Smart View data associated with it.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSWorksheetInfoEnumerator GetAllSmartViewWorksheetInfo(
    bool syncCBData
)
Public Function GetAllSmartViewWorksheetInfo ( _
    syncCBData As Boolean _
) As SVSWorksheetInfoEnumerator
Dim instance As SVSExtension
Dim syncCBData As Boolean
Dim returnValue As SVSWorksheetInfoEnumerator

returnValue = instance.GetAllSmartViewWorksheetInfo(syncCBData)

Parameters

syncCBData
Boolean
Sync CB data prior after retrieving the Cb variables

Return Value

A list of SmartView worksheet info as SVWorksheetInfo objects, empty list on none.

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


GetCBVarCellInfo Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::GetCBVarCellInfo Method
Get Smart View XML data property

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCellInfo GetCBVarCellInfo(
    CBVar cbVar
)
Public Function GetCBVarCellInfo ( _
    cbVar As CBVar _
) As SVSCellInfo
Dim instance As SVSExtension
Dim cbVar As CBVar
Dim returnValue As SVSCellInfo

returnValue = instance.GetCBVarCellInfo(cbVar)

Parameters

cbVar
CBVar
CB variable to get property for

Return Value

SmartView property

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


GetSmartViewCellInfo Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::GetSmartViewCellInfo Method
Get the CB Smart View Cell Info located at a specific cell. This is the Cell info for a Crystal Ball object (Assumption, Forecast or Decision Variable) that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object contains the Smart View data properties for that cell.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCellInfo GetSmartViewCellInfo(
    Range cell,
    bool syncCBData
)
Public Function GetSmartViewCellInfo ( _
    cell As Range, _
    syncCBData As Boolean _
) As SVSCellInfo
Dim instance As SVSExtension
Dim cell As Range
Dim syncCBData As Boolean
Dim returnValue As SVSCellInfo

returnValue = instance.GetSmartViewCellInfo(cell, _
    syncCBData)

Parameters

cell
Range
The cell where the CB variable is located
syncCBData
Boolean
Sync CB data prior after retrieving the CB variables

Return Value

The SmartView variables as a SVCellInfo object, null/nothing if not found.

Exceptions

Exception | Condition
SVSErrors..::..SmartViewCellDoesNotExistError | SmartViewCellDoesNotExistError if no Smart View cell info is found

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


GetSmartViewWorksheetInfo Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::GetSmartViewWorksheetInfo Method
Get a CB Smart View Worksheet. A SmartView worksheet is one that has been identified as having Smart View data associated with it.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSWorksheetInfo GetSmartViewWorksheetInfo(
    Worksheet excelWorksheet,
    bool syncCBData
)
Public Function GetSmartViewWorksheetInfo ( _
    excelWorksheet As Worksheet, _
    syncCBData As Boolean _
) As SVSWorksheetInfo
Dim instance As SVSExtension
Dim excelWorksheet As Worksheet
Dim syncCBData As Boolean
Dim returnValue As SVSWorksheetInfo

returnValue = instance.GetSmartViewWorksheetInfo(excelWorksheet, _
    syncCBData)

Parameters

excelWorksheet
Worksheet
Get info for this sheet
syncCBData
Boolean
Sync CB data prior after retrieving the CB variables

Return Value

A SmartView worksheet info object as SVWorksheetInfo.

Exceptions

Exception | Condition
SVSErrors..::..SmartViewWorksheetDoesNotExistError | SmartViewWorksheetDoesNotExistError if no Smart View worksheet info is found

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


GetWorksheetSmartViewCellInfo Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::GetWorksheetSmartViewCellInfo Method
Get the CB Smart View Cell Info list for all Cryatal Ball objects located in the specified worksheet. This list contains the Cell info for each Crystal Ball object that has been identified as having Smart View data elements in its associated cell. The returned SVCellInfo object list contains the Smart View data properties for each cell.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCellInfoEnumerator GetWorksheetSmartViewCellInfo(
    Worksheet excelWorksheet,
    CBVarType cbVarType,
    bool syncCBData
)
Public Function GetWorksheetSmartViewCellInfo ( _
    excelWorksheet As Worksheet, _
    cbVarType As CBVarType, _
    syncCBData As Boolean _
) As SVSCellInfoEnumerator
Dim instance As SVSExtension
Dim excelWorksheet As Worksheet
Dim cbVarType As CBVarType
Dim syncCBData As Boolean
Dim returnValue As SVSCellInfoEnumerator

returnValue = instance.GetWorksheetSmartViewCellInfo(excelWorksheet, _
    cbVarType, syncCBData)

Parameters

excelWorksheet
Worksheet
The excel worksheet to scan for vars
cbVarType
CBVarType
The CB variable type, none returns all basic types (Assumption, Forecast or Decision Variable)
syncCBData
Boolean
Sync CB data prior after retrieving the Cb variables

Return Value

A list of SmartView variables types as SVCellInfo objects.

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


IsSmartViewConnected Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::IsSmartViewConnected Method
Determine if a SmartView worksheet is connected.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSmartViewConnected(
    Worksheet worksheet
)
Public Function IsSmartViewConnected ( _
    worksheet As Worksheet _
) As Boolean
Dim instance As SVSExtension
Dim worksheet As Worksheet
Dim returnValue As Boolean

returnValue = instance.IsSmartViewConnected(worksheet)

Parameters

worksheet
Worksheet
The excel worksheet to check.

Return Value

True if connected

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


ShowConfigurationDialog Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::ShowConfigurationDialog Method
Show the Crystal Ball Smart View extension configuration dialog

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowConfigurationDialog()
Public Function ShowConfigurationDialog As Boolean
Dim instance As SVSExtension
Dim returnValue As Boolean

returnValue = instance.ShowConfigurationDialog()

Return Value

OK is true, cancel is false

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


SmartViewConnect Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::SmartViewConnect Method
Connect a SmartView worksheet data connection. This operation must be accomplished prior to performing any operations on a Smart View worksheet. Note: If the user name and pasword are empty, a login dialog may be shown.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void SmartViewConnect(
    Worksheet worksheet,
    string userName,
    string password
)
Public Sub SmartViewConnect ( _
    worksheet As Worksheet, _
    userName As String, _
    password As String _
)
Dim instance As SVSExtension
Dim worksheet As Worksheet
Dim userName As String
Dim password As String

instance.SmartViewConnect(worksheet, _
    userName, password)

Parameters

worksheet
Worksheet
the excel worksheet to use login for
userName
String
the user name
password
String
the password

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


ToString Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::ToString Method
Convert to string

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string ToString()
Public Overrides Function ToString As String
Dim instance As SVSExtension
Dim returnValue As String

returnValue = instance.ToString()

Return Value

A description of this extension

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


ValidateSmartViewDataConnections Method

Visual Basic Usage

CB Com Devkit
SVSExtension..::ValidateSmartViewDataConnections Method
Validate all SmartView connections. This will display one or more SmartView login prompts if ShowSmartViewLogin is enabled, otherwise will return an error if not connected. Errors may include: (from Decisioneering.CB.CBExtension.SVS.SVSErrors) SmartViewAddInNotLoadedError SmartViewAddinVersionInvalid SmartViewExtensionNotEnabledError SmartViewFusionLicenseError SmartViewWorksheetNotConnectedError CBVarSyncCancelError (data is out of sync)

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ValidateSmartViewDataConnections()
Public Sub ValidateSmartViewDataConnections
Dim instance As SVSExtension

instance.ValidateSmartViewDataConnections()

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSExtension Properties

Visual Basic Usage

CB Com Devkit
SVSExtension Properties

The SVSExtension type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BaseErrorNumber | The Base Error Number for this extension. (Overrides CBExtensionBaseErrorNumber()()()().)
ContinueWithDynamicAssumptions | Continue simulation or Optimization operations in the presence of dynamic assumption parameters. (Assumptions with cell refreence parameters). The default is true.
ContinueWithoutEPMLicense | Continue to operate with Smart View worksheets if EPM license is not present. If true, the SmartViewFusionLicenseError will not be returned and SmartView worksheet data will be treated as normal Crystal Ball worksheet data. This could cause Crystal Ball operations to fail on your Smart View worksheets. If false, any operation on a Smart View sheet will return the SmartViewFusionLicenseError. The default for this property is false and the state is saved for a single CB session only.
ContinueWithSVAddinDisabled | Continue to operate with Smart View worksheets if the Smart Viw addin is disabled. If true, the SmartViewAddinDisabledError will not be returned and SmartView worksheet data will be treated as normal Crystal Ball worksheet data. This could cause Crystal Ball operations to fail on your Smart View worksheets. If false, any operation on a Smart View sheet will return the SmartViewAddinDisabledError. The default for this property is false and the state is saved for a single CB session.
Description | Extension name (Overrides CBExtensionDescription()()()().)
Enabled | Indicates if the extension is enabled. State is stored in global prefs. Default is True (Overrides CBExtensionEnabled()()()().)
IsSmartViewAddinLoaded | Check if SmartView addin is loaded
Name | Extension name (Overrides CBExtensionName()()()().)
ShowSmartViewLogin | Show Login if needed when connecting to SmartView due to a Devkit call
SmartViewCommandStatusAnnotation | Returns the CB Smart View Extension command status annotation. This is the added status applied to the Excel Status Bar and Control Panel.
SmartViewSyncHandling | Approach to handling CB SmartView Sync errors for operations. The default approach is SmartViewSyncHandling.Cancel.
SVM | Internal Property, must be false
SVSPreserveCBCellHighlighting | Preserve any CB data highlighting (Asm, Frc and DecVar cell coloring). State is stored in global prefs.

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


BaseErrorNumber Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::BaseErrorNumber Property
The Base Error Number for this extension.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override short BaseErrorNumber { get; }
Public Overrides ReadOnly Property BaseErrorNumber As Short
    Get
Dim instance As SVSExtension
Dim value As Short

value = instance.BaseErrorNumber

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


ContinueWithDynamicAssumptions Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::ContinueWithDynamicAssumptions Property
Continue simulation or Optimization operations in the presence of dynamic assumption parameters. (Assumptions with cell refreence parameters). The default is true.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ContinueWithDynamicAssumptions { get; set; }
Public Property ContinueWithDynamicAssumptions As Boolean
    Get
    Set
Dim instance As SVSExtension
Dim value As Boolean

value = instance.ContinueWithDynamicAssumptions

instance.ContinueWithDynamicAssumptions = value

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


ContinueWithoutEPMLicense Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::ContinueWithoutEPMLicense Property
Continue to operate with Smart View worksheets if EPM license is not present. If true, the SmartViewFusionLicenseError will not be returned and SmartView worksheet data will be treated as normal Crystal Ball worksheet data. This could cause Crystal Ball operations to fail on your Smart View worksheets. If false, any operation on a Smart View sheet will return the SmartViewFusionLicenseError. The default for this property is false and the state is saved for a single CB session only.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ContinueWithoutEPMLicense { get; set; }
Public Property ContinueWithoutEPMLicense As Boolean
    Get
    Set
Dim instance As SVSExtension
Dim value As Boolean

value = instance.ContinueWithoutEPMLicense

instance.ContinueWithoutEPMLicense = value

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


ContinueWithSVAddinDisabled Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::ContinueWithSVAddinDisabled Property
Continue to operate with Smart View worksheets if the Smart Viw addin is disabled. If true, the SmartViewAddinDisabledError will not be returned and SmartView worksheet data will be treated as normal Crystal Ball worksheet data. This could cause Crystal Ball operations to fail on your Smart View worksheets. If false, any operation on a Smart View sheet will return the SmartViewAddinDisabledError. The default for this property is false and the state is saved for a single CB session.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ContinueWithSVAddinDisabled { get; set; }
Public Property ContinueWithSVAddinDisabled As Boolean
    Get
    Set
Dim instance As SVSExtension
Dim value As Boolean

value = instance.ContinueWithSVAddinDisabled

instance.ContinueWithSVAddinDisabled = value

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


Description Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::Description Property
Extension name

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
Dim instance As SVSExtension
Dim value As String

value = instance.Description

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


Enabled Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::Enabled Property
Indicates if the extension is enabled. State is stored in global prefs. Default is True

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Enabled { get; set; }
Public Overrides Property Enabled As Boolean
    Get
    Set
Dim instance As SVSExtension
Dim value As Boolean

value = instance.Enabled

instance.Enabled = value

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


IsSmartViewAddinLoaded Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::IsSmartViewAddinLoaded Property
Check if SmartView addin is loaded

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsSmartViewAddinLoaded { get; }
Public ReadOnly Property IsSmartViewAddinLoaded As Boolean
    Get
Dim instance As SVSExtension
Dim value As Boolean

value = instance.IsSmartViewAddinLoaded

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


Name Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::Name Property
Extension name

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
Dim instance As SVSExtension
Dim value As String

value = instance.Name

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


ShowSmartViewLogin Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::ShowSmartViewLogin Property
Show Login if needed when connecting to SmartView due to a Devkit call

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool ShowSmartViewLogin { get; set; }
Public Property ShowSmartViewLogin As Boolean
    Get
    Set
Dim instance As SVSExtension
Dim value As Boolean

value = instance.ShowSmartViewLogin

instance.ShowSmartViewLogin = value

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


SmartViewCommandStatusAnnotation Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::SmartViewCommandStatusAnnotation Property
Returns the CB Smart View Extension command status annotation. This is the added status applied to the Excel Status Bar and Control Panel.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string SmartViewCommandStatusAnnotation { get; }
Public ReadOnly Property SmartViewCommandStatusAnnotation As String
    Get
Dim instance As SVSExtension
Dim value As String

value = instance.SmartViewCommandStatusAnnotation

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


SmartViewSyncHandling Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::SmartViewSyncHandling Property
Approach to handling CB SmartView Sync errors for operations. The default approach is SmartViewSyncHandling.Cancel.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SmartViewSyncHandling SmartViewSyncHandling { get; set; }
Public Property SmartViewSyncHandling As SmartViewSyncHandling
    Get
    Set
Dim instance As SVSExtension
Dim value As SmartViewSyncHandling

value = instance.SmartViewSyncHandling

instance.SmartViewSyncHandling = value

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


SVM Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::SVM Property
Internal Property, must be false

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SVM { get; set; }
Public Property SVM As Boolean
    Get
    Set
Dim instance As SVSExtension
Dim value As Boolean

value = instance.SVM

instance.SVM = value

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSPreserveCBCellHighlighting Property

Visual Basic Usage

CB Com Devkit
SVSExtension..::SVSPreserveCBCellHighlighting Property
Preserve any CB data highlighting (Asm, Frc and DecVar cell coloring). State is stored in global prefs.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SVSPreserveCBCellHighlighting { get; set; }
Public Property SVSPreserveCBCellHighlighting As Boolean
    Get
    Set
Dim instance As SVSExtension
Dim value As Boolean

value = instance.SVSPreserveCBCellHighlighting

instance.SVSPreserveCBCellHighlighting = value

See Also

SVSExtension Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSheetType Enumeration

Visual Basic Usage

CB Com Devkit
SVSheetType Enumeration
Smart View Sheet types

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public enum SVSheetType
Public Enumeration SVSheetType
Dim instance As SVSheetType

Members

Member | Description
None | Not a Smart View Sheet
AdhocSheet | A Smart View Sheet with Adhoc data
FormSheet | A Smart View Sheet with Form data
InteractiveReportSheet | A Smart View Sheet with Report data

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSScriptEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSScriptEnumerator Class
Smart View Script enumerator class.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class SVSScriptEnumerator : VarEnumerator
Public Class SVSScriptEnumerator _
    Inherits VarEnumerator
Dim instance As SVSScriptEnumerator

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToArrayList()()()() | Convert to an ArrayList.
ToList()()()() | Convert to a List.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBExtension.SVS..::..SVSScriptEnumerator

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSScriptEnumerator Methods

Visual Basic Usage

CB Com Devkit
SVSScriptEnumerator Methods

The SVSScriptEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToArrayList()()()() | Convert to an ArrayList.
ToList()()()() | Convert to a List.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SVSScriptEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
SVSScriptEnumerator..::Reload Method
Sync and Reload Constraint vars

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As SVSScriptEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

True on success

Implements

IVarEnumerator..::..Reload()()()()

See Also

SVSScriptEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


ToArrayList Method

Visual Basic Usage

CB Com Devkit
SVSScriptEnumerator..::ToArrayList Method
Convert to an ArrayList.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ArrayList ToArrayList()
Public Function ToArrayList As ArrayList
Dim instance As SVSScriptEnumerator
Dim returnValue As ArrayList

returnValue = instance.ToArrayList()

Return Value

an ArrayList

See Also

SVSScriptEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


ToList Method

Visual Basic Usage

CB Com Devkit
SVSScriptEnumerator..::ToList Method
Convert to a List.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public List<SVSCalcScript> ToList()
Public Function ToList As List(Of SVSCalcScript)
Dim instance As SVSScriptEnumerator
Dim returnValue As List(Of SVSCalcScript)

returnValue = instance.ToList()

Return Value

a List

See Also

SVSScriptEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSScriptEnumerator Properties

Visual Basic Usage

CB Com Devkit
SVSScriptEnumerator Properties

The SVSScriptEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the variable using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

SVSScriptEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Current Property

Visual Basic Usage

CB Com Devkit
SVSScriptEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As SVSScriptEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

SVSScriptEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Item Property

Visual Basic Usage

CB Com Devkit
SVSScriptEnumerator..::Item Property
Accesses the variable using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCalcScript this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As SVSCalcScript
    Get
Dim instance As SVSScriptEnumerator
Dim index As Integer
Dim value As SVSCalcScript

value = instance(index)

Parameters

index
Int32

See Also

SVSScriptEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSWorksheetInfo Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSWorksheetInfo Class
The Smart View worksheet information class.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class SVSWorksheetInfo
Public Class SVSWorksheetInfo
Dim instance As SVSWorksheetInfo

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClearSelectedCalcScript()()()() | Clear the selected calc script. Causes no calc script to be executed for this sheet.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetSheetKey()()()() | Get a Key to uniquely identify this sheet
GetSheetKey(VWorksheet) | Get a Key to uniquely identify this sheet
GetSVCalcScripts()()()() | Get a list of the Smart View calc scripts. COM enumerator supported.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
HasCBVars | Has any CB Variables on the sheet, only avlid after scanning for CB Vars.
HasModifiedData | Does the sheet have any modified Smart View data (DataModified or FreeForm)
IsConnected | Is the worksheet connected to Smart View
Name | The associated Excel worksheet name
NullCellText | The Smart View missing data text used for this worksheet.
SelectedCalcScript | The selected calc script for execution
SVProtected | Is this a Smart View protected worksheet
SVSheetType | The Smart View sheet type
SVSheetTypeName | The Smart View sheet type name
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)
VWorksheet | The VSS worksheet for this Smart View worksheet
WorkbookName | The associated Excel workbook name
Worksheet | The associated Excel worksheet

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBExtension.SVS..::..SVSWorksheetInfo

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSWorksheetInfo Methods

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo Methods

The SVSWorksheetInfo type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ClearSelectedCalcScript()()()() | Clear the selected calc script. Causes no calc script to be executed for this sheet.
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetSheetKey()()()() | Get a Key to uniquely identify this sheet
GetSheetKey(VWorksheet) | Get a Key to uniquely identify this sheet
GetSVCalcScripts()()()() | Get a list of the Smart View calc scripts. COM enumerator supported.
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


ClearSelectedCalcScript Method

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::ClearSelectedCalcScript Method
Clear the selected calc script. Causes no calc script to be executed for this sheet.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public void ClearSelectedCalcScript()
Public Sub ClearSelectedCalcScript
Dim instance As SVSWorksheetInfo

instance.ClearSelectedCalcScript()

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


GetSheetKey Method

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::GetSheetKey Method

Overload List

Name | Description
GetSheetKey()()()() | Get a Key to uniquely identify this sheet
GetSheetKey(VWorksheet) | Get a Key to uniquely identify this sheet

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


GetSheetKey Method

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::GetSheetKey Method
Get a Key to uniquely identify this sheet

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string GetSheetKey()
Public Function GetSheetKey As String
Dim instance As SVSWorksheetInfo
Dim returnValue As String

returnValue = instance.GetSheetKey()

Return Value

A Key to uniquely identify this sheet

See Also

SVSWorksheetInfo Class
GetSheetKey Overload
Decisioneering.CB.CBExtension.SVS Namespace


GetSheetKey Method ()

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::GetSheetKey Method ()
Get a Key to uniquely identify this sheet

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public static string GetSheetKey(
    VWorksheet worksheet
)
Public Shared Function GetSheetKey ( _
    worksheet As VWorksheet _
) As String
Dim worksheet As VWorksheet
Dim returnValue As String

returnValue = SVSWorksheetInfo.GetSheetKey(worksheet)

Parameters

worksheet
VWorksheet
Worksheet to get key for

Return Value

A Key to uniquely identify this sheet

See Also

SVSWorksheetInfo Class
GetSheetKey Overload
Decisioneering.CB.CBExtension.SVS Namespace


GetSVCalcScripts Method

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::GetSVCalcScripts Method
Get a list of the Smart View calc scripts. COM enumerator supported.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSScriptEnumerator GetSVCalcScripts()
Public Function GetSVCalcScripts As SVSScriptEnumerator
Dim instance As SVSWorksheetInfo
Dim returnValue As SVSScriptEnumerator

returnValue = instance.GetSVCalcScripts()

Return Value

A enumerable list of smart view scripts

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSWorksheetInfo Properties

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo Properties

The SVSWorksheetInfo type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
HasCBVars | Has any CB Variables on the sheet, only avlid after scanning for CB Vars.
HasModifiedData | Does the sheet have any modified Smart View data (DataModified or FreeForm)
IsConnected | Is the worksheet connected to Smart View
Name | The associated Excel worksheet name
NullCellText | The Smart View missing data text used for this worksheet.
SelectedCalcScript | The selected calc script for execution
SVProtected | Is this a Smart View protected worksheet
SVSheetType | The Smart View sheet type
SVSheetTypeName | The Smart View sheet type name
VWorksheet | The VSS worksheet for this Smart View worksheet
WorkbookName | The associated Excel workbook name
Worksheet | The associated Excel worksheet

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


HasCBVars Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::HasCBVars Property
Has any CB Variables on the sheet, only avlid after scanning for CB Vars.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasCBVars { get; set; }
Public Property HasCBVars As Boolean
    Get
    Set
Dim instance As SVSWorksheetInfo
Dim value As Boolean

value = instance.HasCBVars

instance.HasCBVars = value

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


HasModifiedData Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::HasModifiedData Property
Does the sheet have any modified Smart View data (DataModified or FreeForm)

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool HasModifiedData { get; }
Public ReadOnly Property HasModifiedData As Boolean
    Get
Dim instance As SVSWorksheetInfo
Dim value As Boolean

value = instance.HasModifiedData

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


IsConnected Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::IsConnected Property
Is the worksheet connected to Smart View

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
Dim instance As SVSWorksheetInfo
Dim value As Boolean

value = instance.IsConnected

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


Name Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::Name Property
The associated Excel worksheet name

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string Name { get; }
Public ReadOnly Property Name As String
    Get
Dim instance As SVSWorksheetInfo
Dim value As String

value = instance.Name

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


NullCellText Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::NullCellText Property
The Smart View missing data text used for this worksheet.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string NullCellText { get; internal set; }
Public Property NullCellText As String
    Get
    Friend Set
Dim instance As SVSWorksheetInfo
Dim value As String

value = instance.NullCellText

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SelectedCalcScript Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::SelectedCalcScript Property
The selected calc script for execution

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSCalcScript SelectedCalcScript { get; set; }
Public Property SelectedCalcScript As SVSCalcScript
    Get
    Set
Dim instance As SVSWorksheetInfo
Dim value As SVSCalcScript

value = instance.SelectedCalcScript

instance.SelectedCalcScript = value

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SVProtected Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::SVProtected Property
Is this a Smart View protected worksheet

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public bool SVProtected { get; }
Public ReadOnly Property SVProtected As Boolean
    Get
Dim instance As SVSWorksheetInfo
Dim value As Boolean

value = instance.SVProtected

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSheetType Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::SVSheetType Property
The Smart View sheet type

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSheetType SVSheetType { get; set; }
Public Property SVSheetType As SVSheetType
    Get
    Set
Dim instance As SVSWorksheetInfo
Dim value As SVSheetType

value = instance.SVSheetType

instance.SVSheetType = value

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSheetTypeName Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::SVSheetTypeName Property
The Smart View sheet type name

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string SVSheetTypeName { get; }
Public ReadOnly Property SVSheetTypeName As String
    Get
Dim instance As SVSWorksheetInfo
Dim value As String

value = instance.SVSheetTypeName

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


VWorksheet Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::VWorksheet Property
The VSS worksheet for this Smart View worksheet

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public VWorksheet VWorksheet { get; }
Public ReadOnly Property VWorksheet As VWorksheet
    Get
Dim instance As SVSWorksheetInfo
Dim value As VWorksheet

value = instance.VWorksheet

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


WorkbookName Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::WorkbookName Property
The associated Excel workbook name

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public string WorkbookName { get; }
Public ReadOnly Property WorkbookName As String
    Get
Dim instance As SVSWorksheetInfo
Dim value As String

value = instance.WorkbookName

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


Worksheet Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfo..::Worksheet Property
The associated Excel worksheet

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public Worksheet Worksheet { get; }
Public ReadOnly Property Worksheet As Worksheet
    Get
Dim instance As SVSWorksheetInfo
Dim value As Worksheet

value = instance.Worksheet

See Also

SVSWorksheetInfo Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSWorksheetInfoEnumerator Class

Visual Basic Usage

| Members | See Also
CB Com Devkit
SVSWorksheetInfoEnumerator Class
Smart View Worksheet Information enumerator class.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public class SVSWorksheetInfoEnumerator : VarEnumerator
Public Class SVSWorksheetInfoEnumerator _
    Inherits VarEnumerator
Dim instance As SVSWorksheetInfoEnumerator

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
SVSWorksheetInfoEnumerator(ArrayList) | Create the Enumerator
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
Item[([( Int32])]) | Accesses the worksheet information using the specified index. Base 1 to match VBA
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)
ToArrayList()()()() | Convert to an ArrayList.
ToList()()()() | Convert to a List.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

Inheritance Hierarchy

System..::..Object
Decisioneering.CB.CBCOMDevKit.Optimization..::..VarEnumerator
Decisioneering.CB.CBExtension.SVS..::..SVSWorksheetInfoEnumerator

See Also

Decisioneering.CB.CBExtension.SVS Namespace


SVSWorksheetInfoEnumerator Constructor

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfoEnumerator Constructor
Create the Enumerator

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSWorksheetInfoEnumerator(
    ArrayList svDataList
)
Public Sub New ( _
    svDataList As ArrayList _
)
Dim svDataList As ArrayList

Dim instance As New SVSWorksheetInfoEnumerator(svDataList)

Parameters

svDataList
ArrayList
A list of SVSWorksheetInfo data to enumerate

See Also

SVSWorksheetInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSWorksheetInfoEnumerator Methods

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfoEnumerator Methods

The SVSWorksheetInfoEnumerator type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator()()()() | Returns an enumerator for these variables. (Inherited from VarEnumerator.)
GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
MoveNext()()()() | Declares the MoveNext method required by IEnumerator; returns the next valid variable based on the type specified. (Inherited from VarEnumerator.)
Reload()()()() | Sync and Reload Constraint vars (Overrides VarEnumerator..::..Reload()()()().)
Reset()()()() | Resets method required by IEnumerator (resets to first variable). (Inherited from VarEnumerator.)
ToArrayList()()()() | Convert to an ArrayList.
ToList()()()() | Convert to a List.
ToString()()()() | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SVSWorksheetInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Reload Method

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfoEnumerator..::Reload Method
Sync and Reload Constraint vars

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override bool Reload()
Public Overrides Function Reload As Boolean
Dim instance As SVSWorksheetInfoEnumerator
Dim returnValue As Boolean

returnValue = instance.Reload()

Return Value

True on success

Implements

IVarEnumerator..::..Reload()()()()

See Also

SVSWorksheetInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


ToArrayList Method

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfoEnumerator..::ToArrayList Method
Convert to an ArrayList.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public ArrayList ToArrayList()
Public Function ToArrayList As ArrayList
Dim instance As SVSWorksheetInfoEnumerator
Dim returnValue As ArrayList

returnValue = instance.ToArrayList()

Return Value

an ArrayList

See Also

SVSWorksheetInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


ToList Method

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfoEnumerator..::ToList Method
Convert to a List.

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public List<SVSWorksheetInfo> ToList()
Public Function ToList As List(Of SVSWorksheetInfo)
Dim instance As SVSWorksheetInfoEnumerator
Dim returnValue As List(Of SVSWorksheetInfo)

returnValue = instance.ToList()

Return Value

a List

See Also

SVSWorksheetInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


SVSWorksheetInfoEnumerator Properties

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfoEnumerator Properties

The SVSWorksheetInfoEnumerator type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Count | Returns the count of variables of the specified type. (Inherited from VarEnumerator.)
Current | Returns the current variable in the enumetration (required by IEnumerator). (Overrides VarEnumerator..::..Current.)
Item[([( Int32])]) | Accesses the worksheet information using the specified index. Base 1 to match VBA
SelectedCount | Returns the count of non excluded variables of the specified type. (Inherited from VarEnumerator.)

See Also

SVSWorksheetInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Current Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfoEnumerator..::Current Property
Returns the current variable in the enumetration (required by IEnumerator).

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public override Object Current { get; }
Public Overrides ReadOnly Property Current As Object
    Get
Dim instance As SVSWorksheetInfoEnumerator
Dim value As Object

value = instance.Current

Implements

IEnumerator..::..Current

See Also

SVSWorksheetInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace


Item Property

Visual Basic Usage

CB Com Devkit
SVSWorksheetInfoEnumerator..::Item Property
Accesses the worksheet information using the specified index. Base 1 to match VBA

Namespace: Decisioneering.CB.CBExtension.SVS
Assembly: CBExtensionLib (in CBExtensionLib.dll) Version: 11.1.2263.0

Syntax

C# | Visual Basic | Visual Basic Usage
public SVSWorksheetInfo this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As SVSWorksheetInfo
    Get
Dim instance As SVSWorksheetInfoEnumerator
Dim index As Integer
Dim value As SVSWorksheetInfo

value = instance(index)

Parameters

index
Int32

See Also

SVSWorksheetInfoEnumerator Class
Decisioneering.CB.CBExtension.SVS Namespace