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Purpose 

This document includes important, late-breaking information about this release of the Oracle® 

Hyperion Financial Data Quality Management, Fusion Edition (FDM) adapter for Oracle Hyperion 

Essbase, Fusion Edition (Essbase). Review this information thoroughly before installing the adapter. 
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Overview 

The FDM adapter for Essbase is a target adapter that allows users to load data from FDM into Essbase. 

Date Created: 12/02/2010 

Adapter Versions: ES11X-G4-H.xml 

 upsES11XG4H.exe 

Compatibility: See the FDM 11.1.2.1 Readme for FDM and Essbase compatibility 

information. 

Top of Document 



 2 

Installation 

This section includes important information about installing this release of the FDM Adapter for 

Essbase. 

> To add the Essbase adapter to an FDM application: 

1. From FDM Workbench, open an FDM application. 

2. Select the Adapters tab. 

3. Select File > Import. 

 The Open Metadata Import File dialog box is displayed. 

4. Browse to find the file  and click Open. 

5. Select File > Register Adapter. 

The Register Adapter dialog box is displayed. 

6. Browse to find the file  and click Open. 
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Configuration 

Configuration Options 

> To configure the adapter: 

1. In FDM Workbench, from the Adapters tab, select the adapter. 

2. Right-click and select Options. 

 The Adapter Options dialog box is displayed. The Options menu enables you to select any of the 

options and change the option settings. 

3. Set the adapter options per the guidelines in the following table: 

Option Name Information Required 

Application Name 

(required) 

Name of the Essbase application in which to load data. 

Essbase DB Name Name of the database used by the Essbase application to 

which you are loading data. 

Default Calculation Method 0-Dynamic, 1-File. Select Dynamic to execute a 

user-defined calculation script in Essbase. This script is 

defined in the Consolidate action found in the adapter. 

Select File to execute a pre-defined Calc script within 

Essbase. 

Enable Load On/Off switch to enable the Load action. Default setting is 

On. 

Enable Drillable Region 

Load 

On/Off switch used to enable or disable the loading of 

drillable region data to the target application. Disabling this 

option can improve performance. If drillable region data is 

not loaded to the target application, then you must set the 

drillable region manually in the target application to get 

drill-through to work. Set to “Off” when using FDM release 

11.1.1.2 or earlier. 
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Option Name Information Required 

Enable Consolidate On/Off switch used to enable the Consolidation action. 

Default setting is On. 

Enable Validation On/Off switch to enable the Validate action, which 

executes validation rules and generates a validation report 

(Check step of the FDM process flow). 

Logon Method 1-Unified, 2-Global. Default setting is 1 – Unified. If the 

machine profile contains a username/password, this 

setting is ignored. 

See the FDM Configuration Guide for information about 

setting up a machine profile. 

Global Logon Information User name and Password of an Essbase user. Separate 

with a semi-colon (;). If the machine profile contains a 

username/password, this setting is ignored. 

See the FDM Configuration Guide for information about 

setting up a machine profile. 

Load Method 0-Replace, 1-Merge. Select Replace to execute a Clear 

script (found in the Load action). 

Dimension Cache Switch On/Off switch for enabling the caching of Essbase 

members. When this option is enabled, FDM will retrieve 

the Essbase members from the dimension lookup table. 

You must have executed the ES_UpdateDimCache script to 

use this option. 

Enable Base Entity Calc On/Off switch to enable base entity calculations in Essbase. 

Browse For All Members On/Off switch. When enabled, the list of members returned 

will contain all members for a given dimension. Otherwise, 

the list will contain only base members for a given 

dimension. 

Enable String Load On/Off switch. Off is default. When disabled, only users 

with full Essbase administrator rights can load to Essbase. 

When enabled, non-administrator Essbase users can load 

to Essbase. 

Enable paging functionality 

in Export action 

On/Off switch to enable paging functionality in the adapter 

Export action. Use this option when running FDM 

11.1.1.3.x or prior. 

Page Size of Recordset 

during Export 

Default page size is 7500 records. This option is used for 

limiting the number of records to export at one time. This 

helps with memory management. 

Note: When using the Web client to set this field, the 

value cannot exceed 2,147,483,647. 

Load Rule Name Required when using the String Load option. This option is 

overridden by a location's Integration Option #2 value. 

Calculate Switch Not used. 

List1 0-Load, 1-Scan Load is the default setting and the only 

option used. 

List2 Not used. 

List3 Not used. 

Status1 Not used. 
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Option Name Information Required 

Status2 Not used. 

Status3 Not used. 

 

User and Environmental Variables 

After the Essbase install, the ARBORPATH and ESSBASEPATH variables will be assigned as a User 

variable and must be re-assigned and duplicated to System Environment variables. This is required on 

the FDM application server and any computer that is running FDM Workbench. 

Note: This procedure must be performed while logged in with the same user name that was used 

when installing Essbase. 

Note: This procedure is only required when using the Essbase G4-H adapter with FDM Release 

11.1.2.1. 

For New Installs 

 > To set the ESSBASEPATH variable: 

1. From My Computer, right-click and select Properties. 

 The System Properties dialog box is displayed. 

2. Select the Advanced tab. 

3. Click Environment Variables. 

 The Environment Variables screen is displayed. 

4. Under the System Variables field, click New. 

  The New System Variable dialog box is displayed. 

5. In the Variable Name field, enter . 

6. In the Variable Value field, enter . 

7. Click OK. 

8. From the Environment Variables screen, under System Variables, select Path. 

9. Click Edit. 

 The Edit System Variable screen is displayed. 

10. In the Variable value field, perform one of the following: 

 For 32-bit –add  

 For 64-bit – add 
 

11. Click OK to close the Edit System Variable screen. 

12. Click OK to close the Environment Variables screen. 

For Maintenance Releases 

 > To set the ESSBASEPATH and ARBORPATH variables: 

1. From My Computer, right-click and select Properties. 

 The System Properties dialog box is displayed. 

2. Select the Advanced tab. 

3. Click Environment Variables. 

 The Environment Variables screen is displayed. 
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4. Under the User Variables field, select ARBORPATH. 

5. Click Delete. 

6. Under the User Variable field, select ESSBASEPATH. 

7. Click Delete. 

8. Under the System Variables field, select ARBORPATH. 

9. Click Delete. 

10. Under the System Variables field, select ESSBASEPATH. 

11. Click Edit. 

 The Edit System Variable screen is displayed. 

12. In the Variable value field, add . 

13. Click OK. 

14. From the Environment Variable screen, under System Variables, select Path. 

15. Click Edit. 

 The Edit System Variable screen is displayed. 

16. In the Variable value field, perform one of the following: 

 For 32-bit –add  

 For 64-bit – add 
 

17. Click OK to close the Edit System Variable screen. 

18. Click OK to close the Environment Variables screen. 

Mapping FDM Dimension Names to Target System Dimension Names 

FDM dimension names must be mapped to the target system dimension names for drill-through 

functionality to work. This can be accomplished in two ways, using the Essbase adapter’s Configure 

screen, and using the Essbase adapter’s Dimension node: 

Using the Essbase Adapter’s Configure Screen 

1. Log in to FDM Workbench. 

2. Select the Adapters tab. 

3. Right-click on the Essbase adapter and select Configure. 

 The Adapter Integration Setup screen is displayed. 

4. Select the Dimensions tab. 

5. Select the dimensions that will be used to load to Essbase and ensure the following properties 

are enabled and configured: 

-  Check the Active box. 

-  Select the Target Dimension drop-down menu and select the target dimension to which 

to map. Note: Integration to the target application is required for this step. 

-  Repeat for each FDM dimension that will be mapped to a target dimension. 

Using the Essbase Adapter’s Dimension Node 

1. Log in to FDM Workbench. 

2. Select the Adapters tab. 

3. Expand the Essbase adapter. 

4. Expand the Dimensions node. 
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5. Right-click a dimension and select Properties. 

 The Dimension Properties screen is displayed. 

6. In the Foreign Name field, enter the name of the Essbase dimension to which to map. 

 Repeat for each dimension that will be mapped to a target dimension. 

Using the Adapter 

Essbase Fragmentation 

To avoid Essbase cube fragmentation, Oracle recommends that you load data to Essbase in a certain 

dimension sequence and order. There are two ways to set the order in which FDM will export and load 

dimensional data into Essbase. 

> To define the Essbase load order using Workbench: 

1. Open the FDM application. 

2. Select the Adapters tab. 

3. Select the Essbase adapter, right-click and select Configure. 

The Hyperion Essbase Integration Setup screen is displayed. 

4. Select the Dimensions tab. 

5. Select an active dimension. 

6. In the Calc Sequence field, enter a sequence number in which to load the dimension to 

Essbase. 

7. Repeat steps 5 and 6 for all active dimensions. 

8. Click OK. 

> To define the Essbase load order using the Web client: 

1. Open the FDM application. 

2. If the current POV is not using the Essbase adapter, select a location that is using the 

Essbase adapter. 

3. Select Metadata > Dimensions. 

The Dimensions screen is displayed. 

4. In the Calc Sequence column for each dimension, enter a sequence value in which to load 

the dimension to Essbase. 

5. Click Update Grid. 

Note: Calc Sequence setting changes in the adapter can affect the order in which dimensions are 

mapped. 

Calculate/Consolidate Call 

The calculate/consolidate call makes use of the Account dimension alias. The Calculate/Consolidate call 

will fail if the Account dimension alias is not specified. 
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Known Issues 

Support for BSO Cubes Only 

FDM supports only the loading of BSO cubes from Essbase. It does not support the loading of ASO 

cubes. 

Drillable Region Loading 

Drillable region loading is only supported for loading to block storage and ASCII Essbase applications. 

If you attempt to load drillable region data to a Unicode Essbase application, the drillable region load 

will fail. 

Integrating with Essbase Applications that Contain Multibyte Characters 

Problem: When using Browse to select members that contain multibyte characters, the value of the 

dimension is not returned with the correct encoding. 

Solution: 

For Dimension Mapping, you can use any of the following options. 

 Manually enter the map values (member name) for each dimension. 

 Create a map file outside of FDM (e.g. FDM Map Template) and then import the map into FDM. 

 Create * to * mapping in FDM (if imported file contains all members that exist in Essbase). 

For control table mapping, you must enter the map values (dimension names) manually. In addition, 

you must uncheck the “UseList” option for each dimension that contains multibyte characters. This also 

applies for validation rules. When defining target member lookup values, ensure that the UseList 

option is disabled for the dimensions required in the validation rule. 

Validation Rules and Essbase using European Operating Systems 

European standards use a comma (,) as a decimal separator. Because localized Essbase uses a period 

as the decimal separator regardless of the OS, FDM validation rules cannot pull the correct amounts 

from Essbase when using European-localized versions. All amounts will display as zeroes. FDM 

validation rules will not work with European-localized operating systems and the Check reports will 

always report errors. 

Method for Target Val Lookup when Period Dim Inactive 

Problem: When integrating with Essbase, the Period table reverts to using the old method of browsing 

for the target value when both of the following are set:  

 The Period dimension is inactive and its corresponding UseList option is off. 

 The Year dimension is active and has the UseList option turned on. 

Note: When a dimension is inactive, no other properties should be considered. 

Solution: Period is a required dimension for FDM. Period information from the target application must 

be mapped to the Period dimension in FDM. The Period dimension in the target application could be 

Period or it could be Year but it must be mapped to the Period dimension in FDM. 

Essbase Security Requirements 

Some FDM tasks require the user to have certain security privileges for Essbase. The following table 

outlines the tasks and Essbase privileges required. 
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Task Privileges Required 

Perform a Load by Append into 

Essbase. 

Application or Database Design privilege 

(ESB_PRIV_APPDESIGN or ESB_PRIV_DBDESIGN) for the 

specified application or database containing the object. 

Perform a string load into Essbase. No special privileges. 

Perform a replace during the load to 

Essbase. 

Application or Database Design privilege 

(ESB_PRIV_APPDESIGN or ESB_PRIV_DBDESIGN), for the 

specified application or database containing the object. 

Calc privilege (ESB_PRIV_CALC) to the active database. 

Perform a consolidation (assigning a 

Validation Entity to the FDM location). 

Calc privilege (ESB_PRIV_CALC) to the active database. 
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Notes 

 Additional languages have been added. See the Oracle Hyperion Enterprise Performance 

Management System Certification Matrix (http://www.oracle.com/technology/products/bi/hyperion-

supported-platforms.html) for information about localization for this adapter. 

 See the FDM 11.1.2.1 Readme for additional information regarding the FDM Adapter for Essbase. 
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