Oracle® Solaris 11.2 Desktop User's Guide
Ce logiciel et la documentation qui l’accompagne sont protégés par les lois sur la propriété intellectuelle. Ils sont concédés sous licence et soumis à des restrictions d’utilisation et de divulgation. Sauf disposition de votre contrat de licence ou de la loi, vous ne pouvez pas copier, reproduire, traduire, modifier, breveter, transmettre, distribuer, exposer, exécuter, publier ou afficher le logiciel, même partiellement, sous quelque forme et par quelque procédé que ce soit. Par ailleurs, il est interdit de procéder à toute ingénierie inverse du logiciel, de le désassembler ou de le décompiler, excepté à des fins d’interopérabilité avec des logiciels tiers ou tel que prescrit par la loi.

Les informations fournies dans ce document sont susceptibles de modification sans préavis. Par ailleurs, Oracle Corporation ne garantit pas qu’elles soient exemptes d’erreurs et vous invite, le cas échéant, à lui en faire part par écrit.

Si ce logiciel, ou la documentation qui l’accompagne, est concédé sous licence au Gouvernement des États-Unis, ou à toute entité qui délivre la licence de ce logiciel ou l’utilise pour le compte du Gouvernement des États-Unis, la notice suivante s’applique:

U.S. GOVERNMENT END USERS. Oracle programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, delivered to U.S. Government end users are “commercial computer software” pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, shall be subject to license terms and license restrictions applicable to the programs. No other rights are granted to the U.S. Government.

Ce logiciel ou matériel a été développé pour un usage général dans le cadre d’applications de gestion des informations. Ce logiciel ou matériel n’est pas conçu ni n’est destiné à être utilisé dans des applications à risque, notamment dans des applications pouvant causer des dommages corporels. Si vous utilisez ce logiciel ou matériel dans le cadre d’applications dangereuses, il est de votre responsabilité de prendre toutes les mesures de securité, de sauvegarde, de redondance et autres mesures nécessaires à son utilisation dans des conditions optimales de sécurité. Oracle Corporation et ses affiliés déclinent toute responsabilité quant aux dommages causés par l’utilisation de ce logiciel ou matériel pour ce type d’applications.

Oracle et Java sont des marques déposées d’Oracle Corporation et/ou de ses affiliés. Tout autre nom mentionné peut correspondre à des marques appartenant à d’autres propriétaires qu’Oracle.

Intel et Intel Xeon sont des marques ou des marques déposées d’Intel Corporation. Toutes les marques SPARC sont utilisées sous licence et sont des marques ou des marques déposées de SPARC International, Inc. AMD, Opteron, le logo AMD et le logo AMD Opteron sont des marques ou des marques déposées d’Advanced Micro Devices. UNIX est une marque déposée d’The Open Group.

Ce logiciel ou matériel et la documentation qui l’accompagne peuvent fournir des informations ou des liens donnant accès à des contenus, des produits et des services émanant de tiers. Oracle Corporation et ses affiliés déclinent toute responsabilité ou garantie expresse ou implicite, y compris mais sans limitation, la garantie commerciale, l’adaptation à un usage particulier et la non-infringement de droits de tiers. Oracle Corporation et ses affiliés ne sauraient être tenus pour responsables des pertes subies, des coûts occasionnés ou des dommages causés par l’accès ou à des contenus, produits ou services tiers, ou à leur utilisation.
# Contents

**Using This Documentation** ............................................................................................................. 9

1 **Getting Started With the Desktop** ................................................................................................ 11
   - Overview of the Desktop .................................................................................................................. 11
   - Desktop Components ....................................................................................................................... 12
   - Desktop Sessions ............................................................................................................................. 13
     - Starting a Session ......................................................................................................................... 13
     - Locking the Screen ....................................................................................................................... 14
     - Setting Programs to Start Automatically When You Log In ...................................................... 15
     - Ending a Session ......................................................................................................................... 16

2 **Using the Desktop Windows** ....................................................................................................... 17
   - Windows Overview .......................................................................................................................... 17
   - Types of Windows ............................................................................................................................ 17
   - Working With Windows ................................................................................................................... 18
     - Moving a Window ......................................................................................................................... 18
     - Resizing a Window ....................................................................................................................... 19
     - Minimizing a Window .................................................................................................................. 19
     - Maximizing a Window ................................................................................................................ 20
     - Unmaximizing a Window ............................................................................................................. 20
     - Closing a Window ....................................................................................................................... 20
     - Giving Focus to a Window ........................................................................................................... 21

3 **Using the Desktop Workspaces** .................................................................................................. 23
   - Workspaces Overview .................................................................................................................... 23
   - Working With Workspaces ............................................................................................................. 24
     - Switching Workspaces ................................................................................................................ 24
     - Adding and Deleting Workspaces ............................................................................................... 24

4 **Using the Desktop Panels** .......................................................................................................... 27
5 Using the Desktop Applications ........................................................... 49
   Applications Overview ........................................................................ 49
   Working With Files ............................................................................... 50
   Opening a File .................................................................................... 50
      Filtering the File List ....................................................................... 51
      Choosing a Folder ........................................................................... 51
   Opening a Location ............................................................................. 51
   Opening Remote Locations .................................................................. 52
   Adding and Removing Bookmarks ...................................................... 52
   Showing Hidden Files ......................................................................... 52
   Saving a File ....................................................................................... 52
      Saving a File in Another Location ................................................... 53
      Replacing an Existing File ............................................................... 53
   Creating a Folder ................................................................................ 53

6 Using the Main Menubar ..................................................................... 55
   About the Main Menubar ..................................................................... 55
   About the Applications Menu ............................................................. 55
      ▼ How to Start an Application ......................................................... 56
   Using the Places Menu ....................................................................... 56
   Using the System Menu ...................................................................... 57
   Using the Administration Menu .......................................................... 57
   Customizing the Panel Menubar ........................................................ 58
      ▼ How to Edit Menus ..................................................................... 58

7 Using Time Slider .............................................................................. 59
   Time Slider Preferences Pane ............................................................ 59
      Enabling and Disabling the Time Slider Service .............................. 60
   Working with Time Slider Snapshots ............................................... 61
      Managing Snapshots Using Time Slider ....................................... 61
      Managing Snapshots From a File Manager ................................... 63

8 Using the File Manager ...................................................................... 69
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Manager Overview</td>
<td>69</td>
</tr>
<tr>
<td><strong>Spatial Mode</strong></td>
<td>70</td>
</tr>
<tr>
<td>Spatial Mode Windows</td>
<td>70</td>
</tr>
<tr>
<td>Displaying the Home Folder in a Spatial Window</td>
<td>73</td>
</tr>
<tr>
<td>Displaying a Parent Folder</td>
<td>73</td>
</tr>
<tr>
<td>Displaying a Folder in a Browser Window</td>
<td>73</td>
</tr>
<tr>
<td>Closing Folders</td>
<td>74</td>
</tr>
<tr>
<td>Opening a Location</td>
<td>74</td>
</tr>
<tr>
<td><strong>Browser Mode</strong></td>
<td>74</td>
</tr>
<tr>
<td>Browser Windows</td>
<td>74</td>
</tr>
<tr>
<td>Showing and Hiding File Browser Window Components</td>
<td>76</td>
</tr>
<tr>
<td>Using the Location Bar</td>
<td>77</td>
</tr>
<tr>
<td>Displaying Home Folder</td>
<td>77</td>
</tr>
<tr>
<td>Displaying a Folder</td>
<td>78</td>
</tr>
<tr>
<td>Displaying a Parent Folder</td>
<td>78</td>
</tr>
<tr>
<td>Using the Tree From the Side Pane</td>
<td>78</td>
</tr>
<tr>
<td>Using Navigation History</td>
<td>79</td>
</tr>
<tr>
<td><strong>Opening Files</strong></td>
<td>80</td>
</tr>
<tr>
<td>Executing the Default Action</td>
<td>80</td>
</tr>
<tr>
<td>Executing Non-Default Actions</td>
<td>80</td>
</tr>
<tr>
<td>▼ How to Add Actions Associated With a File Type</td>
<td>81</td>
</tr>
<tr>
<td>▼ How to Modify Actions</td>
<td>81</td>
</tr>
<tr>
<td><strong>Searching Files</strong></td>
<td>81</td>
</tr>
<tr>
<td>Saving Searches</td>
<td>82</td>
</tr>
<tr>
<td><strong>Managing Files and Folders</strong></td>
<td>82</td>
</tr>
<tr>
<td>Using Views to Display Files and Folders</td>
<td>83</td>
</tr>
<tr>
<td>Working With Files and Folders</td>
<td>86</td>
</tr>
<tr>
<td>Using Drag and Drop</td>
<td>90</td>
</tr>
<tr>
<td>Viewing the Properties of a File or Folder</td>
<td>91</td>
</tr>
<tr>
<td>Changing Permissions</td>
<td>92</td>
</tr>
<tr>
<td>Adding Notes to Files and Folders</td>
<td>93</td>
</tr>
<tr>
<td>Creating Documents by Using a Template</td>
<td>94</td>
</tr>
<tr>
<td>Using Bookmarks</td>
<td>95</td>
</tr>
<tr>
<td>Using Trash</td>
<td>96</td>
</tr>
<tr>
<td>Viewing Hidden Files</td>
<td>97</td>
</tr>
<tr>
<td><strong>Using Item Properties</strong></td>
<td>98</td>
</tr>
<tr>
<td>▼ How to Display the Item Properties Window</td>
<td>98</td>
</tr>
<tr>
<td><strong>Modifying the Appearance of Files and Folders</strong></td>
<td>98</td>
</tr>
<tr>
<td>Using Icons and Emblems</td>
<td>99</td>
</tr>
<tr>
<td>Using Removable Media</td>
<td>102</td>
</tr>
</tbody>
</table>
Contents

Network .............................................................................................. 136
Network Proxy ....................................................................................  137
Desktop Sharing .................................................................................. 138
Setting Keyboard Preferences ........................................................... 139
  Keyboard ....................................................................................... 140
  Input Method Selector ...................................................................... 145
Setting Hardware Preferences ............................................................. 146
  Monitor Preference Tool ................................................................. 146
  Sound Preference Tool .................................................................. 147
Setting Session Preferences ................................................................. 149
  Configuring Startup Applications .................................................... 150

A Using the Mouse .............................................................................. 151
  Mouse Button Conventions ............................................................... 151
  Mouse Preference Tool ................................................................. 152
  Mouse Pointers ............................................................................... 154

B Using the Keyboard .......................................................................... 157
  Global Shortcut Keys ...................................................................... 157
  Window Shortcut Keys .................................................................... 158
  Application Keys ........................................................................... 159
  Access Keys .................................................................................. 160
Using This Documentation

- **Overview** – *Oracle Solaris 11.2 Desktop User's Guide* describes how to configure, customize, and use the features of the Oracle Solaris Desktop. Most of the information in this guide is generic to all releases of the desktop. Where the information is not generic, the platform is indicated.

- **Audience** – This guide is for users, system administrators, and anyone who is interested in using the Oracle Solaris Desktop.

- **Required knowledge** – You should have a basic knowledge of SPARC and x86 systems. This guide assumes that you have the following documentation available for reference:
  - “Oracle Solaris 11 Desktop Accessibility Guide ”
  - “Oracle Solaris 11.2 Desktop Administrator’s Guide ”
  - “Optimizing the Oracle Solaris Desktop for a Multi-User Environment ”
  - *Oracle Solaris 11.2 Information Library*

How This Book Is Organized

This guide is structured in this manner:

- **Chapter 1, “Getting Started With the Desktop”** introduces you to some of the basic components of the desktop. These components include windows, workspaces, and applications. This chapter also provides information needed to log in to and shut down the desktop, and to start, manage, and end a desktop session.

- **Chapter 2, “Using the Desktop Windows”** describes the desktop windows, the different types of windows available, and how to work with windows.

- **Chapter 3, “Using the Desktop Workspaces”** describes workspaces, and how to manage the workspaces available on the Oracle Solaris Desktop.

- **Chapter 4, “Using the Desktop Panels”** describes how to add, customize, and use the panels at the top and bottom of the Oracle Solaris Desktop.

- **Chapter 5, “Using the Desktop Applications”** describes the standard desktop applications and how to create, open, and save files and folders.

- **Chapter 6, “Using the Main Menubar”** describes how to use the desktop panel menubar.

- **Chapter 7, “Using Time Slider”** describes how to restore individual files or directories from automatically scheduled, incremental snapshots of home directories.
- Chapter 8, “Using the File Manager” describes how to organize and search your files, connect to remove servers, and burn CDs.

- Chapter 9, “Using the Desktop Tools and Utilities” describes what you can do with some of the tools and utilities on the desktop, such as take a screenshot or browse help documentation.

- Chapter 10, “Configuring the Desktop” describes how to use the preference tools to customize the desktop.

- Appendix A, “Using the Mouse” describes the mouse actions and the different mouse pointers.

- Appendix B, “Using the Keyboard” describes how to use the keyboard and the shortcut keys that you can use throughout the desktop and applications.

**Product Documentation Library**

Late-breaking information and known issues for this product are included in the documentation library at [http://www.oracle.com/pls/topic/lookup?ctx=E36784](http://www.oracle.com/pls/topic/lookup?ctx=E36784).

**Access to Oracle Support**


**Feedback**

Provide feedback about this documentation at [http://www.oracle.com/goto/docfeedback](http://www.oracle.com/goto/docfeedback).
This chapter introduces you to some of the basic components of the Oracle Solaris Desktop, which is based on the GNOME Desktop 2.30.2.

This chapter includes the following information:

- “Overview of the Desktop” on page 11
- “Desktop Components” on page 12
- “Desktop Sessions” on page 13

### Overview of the Desktop

The desktop lies behind all other components on the screen. When no windows are visible, the desktop is that part of the screen between the top and bottom panels. You can place files and folders on the desktop, of which you want to have easy access.

By default, the following icons are visible on the desktop:

- Start Here – Provides access to customize your desktop and view help documentation.
- Add More Software – Opens the Package Manager which enables you to add or update a software.

When you insert a CD, a flash drive, or any other removable media, an icon representing this device appears on the desktop.

To view the desktop by minimizing all windows, perform one of the following actions:

- Click the Show Desktop button.
- Press `Ctrl+Alt+D`.

Alternatively, you can switch to another workspace to see the desktop.

You can change the color of the desktop background or the image displayed. For more information about how to change the desktop background, see “Desktop Background Preferences” on page 129.
Note - The files and folders on the desktop are stored in a special folder called Desktop, within the Home folder. The contents of the Desktop folder is displayed on the desktop.

Desktop Components

When you start a desktop session for the first time, a default startup screen with panels, windows, and various icons is displayed.

The following table describes the major components of the Oracle Solaris Desktop.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panels</td>
<td>Panels are the two bars that are shown on the top and bottom of the screen. By default, the top panel shows the desktop main menubar, a set of application launcher icons, the notification area, the volume control, and a clock. The bottom panel includes the Show Desktop button, the Window List applet, the Workspace Switcher applet, and the Trash applet. Panels can be customized to contain several tools such as other menus and launchers, and small utility applications called panel applets. For example, you can configure your panel to display the current weather for your location. For more information about panels, see Chapter 4, “Using the Desktop Panels”.</td>
</tr>
<tr>
<td>Windows</td>
<td>Most applications run in one or more windows. You can display multiple windows on the desktop simultaneously. Windows can be resized and moved around to accommodate the workflow. Each window has a titlebar at the top with buttons which enables you to minimize, maximize, and close the window. For more information about working with windows, see “Working With Windows” on page 18.</td>
</tr>
<tr>
<td>Workspaces</td>
<td>You can divide the desktop into separate workspaces. Each workspace can contain several windows, enabling you to group related tasks. For more information about working with workspaces, see “Workspaces Overview” on page 23.</td>
</tr>
<tr>
<td>File manager</td>
<td>The file manager provides access to files, folders, and applications. The file manager manages the folder contents and opens the files in appropriate applications. For more information about using the file manager, see “Working With Files” on page 50.</td>
</tr>
<tr>
<td>Preferences</td>
<td>You can customize the computer using Preferences, which can be found in the System menu. Each Preference tool enables you to change a particular aspect of computer behavior. For more information about Preferences, see Chapter 10, “Configuring the Desktop”.</td>
</tr>
</tbody>
</table>
Desktop Sessions

A session is the period of time you spend using the desktop, between logging in and logging out. During a session, you use your applications, print, browse the web, and so on.

Starting a Session

Logging in to the desktop begins your session. The login screen is a gateway to the Oracle Solaris Desktop.

Note - Logging out ends the session, but you can choose to save the state of your session and restore it next time you use the desktop. For more information about restoring a session, see “Setting Programs to Start Automatically When You Log In” on page 15.

How to Log In to the Desktop

1. On the login screen, click Session. Choose GNOME from the list of available desktop environments.
2. Type the username in the Username field, and then press Return.
3. Type the password in the Password field, and then press Return.

The first time you log in, the session manager starts a new session. If you have logged in before and saved the settings for the previous session, then the session manager restores your previous session.

If you want to shut down or restart the system before you log in, click System on the login screen. Select the relevant option from the dialog, and then click OK.

How to Use a Different Language

1. On the login screen, click Language. Choose the required language from the list of available languages.
2. Type the username in the Username field, and then press Return.
3. Type the password in the Password field, and then press Return.
How to Use a Different Keyboard Layout

When you log in to a session using a different language, the user interface language is changed and not the keyboard layout.

1. **On the login screen, type your username in the Username field, and then press Return.**

2. **Click the Keyboard icon that appears at the bottom of the login screen, and choose the required keyboard layout from the list of available layouts.**

3. **Type the password in the Password field, and then press Return.**

See Also: After logging in, you can also choose a different keyboard layout using the Keyboard preference tool. For more information about the Keyboard preference tool, see “Keyboard” on page 140.

Locking the Screen

Locking the screen prevents access to the applications and information, allowing you to leave the computer unattended. While your screen is locked, the screensaver runs.

To lock the screen, perform one of the following actions:

- Choose System → Lock Screen
- Click the Lock Screen button, if it is present on a panel

**Note** - By default, the Lock Screen button is not present on the panels. For more information about how to add a Lock Screen button to a panel, see “Adding an Object to a Panel” on page 32.

To unlock the screen, move the mouse or press any key, type the password in the locked screen dialog, and then press Return.

If other users want to use the computer while it is locked, they can move the mouse or press a key and then click Switch User. The login screen is displayed and they can log in using their credentials. They will not be able to access any of your applications or information. When they log out, the screen is locked again and you can access your session by unlocking the screen.
Setting Programs to Start Automatically When You Log In

You can choose certain programs to be started automatically when you log in to a session. For example, you might want a web browser to be started as soon as you log in. Programs which start automatically when you log in are called startup programs. Startup programs are automatically saved and closed by the session manager when you log out, and are restarted when you log in.

The Startup Applications preference tool enables you to define startup programs. It has two tabs, Startup Programs and Options.

About the Startup Programs Tab

You can use the Startup Programs tab to add, modify, and remove startup programs.

A list of startup programs is displayed on this tab. The list shows a short description of each program, along with an option which denotes whether the startup program is enabled. Programs which are not enabled will not be started automatically when you log in.

Enabling/Disabling Startup Programs

To enable a program to start up automatically, select the option corresponding to that program.

To disable a program from starting automatically, deselect the option.

▼ How to Add a New Startup Program

1. In the Startup Programs tab, click Add.
   The Add Startup Program dialog box is displayed.

2. In the Name text box, specify a name for the new startup program.

3. In the Command text box, specify the command to invoke the application.
   For example, the command gedit will start the Gedit Text Editor. If you do not know the exact command, click Browse to choose the path of the command.

4. In the Comments text box, type a description for the application.
   The description of the program is displayed in the list of startup programs.
How to Add a New Startup Program

5. **Click Add.**

   The application will be added to the list of startup programs.

**Removing a Startup Program**

To remove a startup program, select it from the list of startup programs and click Remove.

**Editing a Startup Program**

To edit an existing startup program, select it from the list of startup programs and click Edit. A dialog is displayed which enables you to edit the properties of the program. For more information about the available options in this dialog, see “About the Startup Programs Tab” on page 15.

**About the Options Tab**

The session manager can remember which applications are running when you log out and can automatically restart them when you log in again. Select Automatically Remember Running Applications while logging out to restart the running applications each time you log in again. If you would like this to happen only once, click Remember Currently Running Applications before logging out.

**Ending a Session**

You can perform one of the following actions to end a session:

- Log out, leaving the computer ready for another user to begin working. To log out, choose System → Log Out `username`.
- Shut down the computer and switch off power. To shut down, choose System → Shut Down, and then click Shut Down.
- Depending on the computer's configuration, you might be able to hibernate the computer. During hibernation, less power is used, but all the open applications and documents are preserved and will be open when you resume from hibernation. You can resume from hibernation by moving your mouse or pressing a key.

Before you end a session, you might want to save your current settings so that you can restore the session later. In the Startup Applications preference tool, you can select an option to automatically save your current settings.
Using the Desktop Windows

This chapter describes the desktop windows, the different types of windows available, and how to work with windows.

This chapter includes the following information:

- “Windows Overview” on page 17
- “Types of Windows” on page 17
- “Working With Windows” on page 18

Windows Overview

A window is a rectangular area of the screen, with a border and a title bar at the top. You can think of a window as a screen within the screen. Each window displays an application, enabling you to have more than one application visible, and work on more than one task at a time.

You can control a window’s position on the screen, as well as its size. You can control which window overlaps other windows, so the one you want to work with is completely visible. For more information about moving and resizing windows, see “Working With Windows” on page 18.

Types of Windows

Each window is not necessarily a different application. An application has one main window, and might open additional windows at your request.

The following table describes the two main types of windows.

<table>
<thead>
<tr>
<th>Window Types</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application windows</td>
<td>Application windows allow all the minimize, maximize, and close operations through the buttons available on the titlebar.</td>
</tr>
</tbody>
</table>
## Working With Windows

You can change the size and position of the window on the screen. This allows you to see more than one application and do different tasks at the same time. For example, you might want to read text on a web page while writing with a word processor, or to change to another application to do a different task or check its progress.

Most of these actions are carried out by using the mouse on different parts of the window's frame. The top edge of the window frame, called the titlebar, contains several buttons that change the way the window is displayed.

The following figure displays the titlebar for a typical application window. From left to right, this contains the window menu button, the window title, and the minimize, maximize, and close buttons.

**FIGURE 2-1** Titlebar of an Application Window

All actions can also be carried out from the Window menu. Common actions can also be carried out using keyboard shortcuts. For a sample list of shortcut keys, see “Window Shortcut Keys” on page 158. The below sections list the actions you can carry out on a window, using the mouse or the keyboard.

### Moving a Window

You can click any part of the titlebar except the buttons at either end to begin the drag action. The window moves on the screen as you drag the mouse. On some computers, the movement of the window might be represented by moving an outline of its frame.

You can also perform one of the following actions to move a window:

<table>
<thead>
<tr>
<th>Window</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialog windows</td>
<td>Dialog windows are displayed at the request of an application window. A dialog window might alert you to a problem, ask for confirmation of an action, or request input. The two types of dialog windows are:</td>
</tr>
<tr>
<td></td>
<td>- Modal dialogs – Do not allow you to interact with the main application window until you have closed them.</td>
</tr>
<tr>
<td></td>
<td>- Transient dialogs – Allow you to work with the main application window without closing them.</td>
</tr>
</tbody>
</table>
Choose Move from the Window menu.
Press Alt+F7, and then either move the mouse or press the keyboard arrow keys to move the window.
Press and hold Alt and drag any part of the window.
Press and hold Shift while you move the window between the corners of the desktop and other windows.

Note - If the Num Lock key is off, you can use the arrows on the numeric keypad, as well as the 7, 9, 1, and 3 keys to move diagonally.

Resizing a Window

You can drag one of the borders to expand or contract the window on one side. Drag a corner to change two sides at once. The resize pointer appears when the mouse is at the correct position to begin the drag action.

How to Resize a Window

1. Choose Resize from the Window menu, or press Alt+F8.
The resize pointer is displayed.

2. Move the mouse in the direction of the edge you want to resize, or press one of the keyboard arrow keys.
The pointer changes to indicate the chosen edge. Now you can use the mouse or the arrow keys to move this edge of the window.

3. Click the mouse or press Return to accept the change.

Note - You can press Esc to cancel the resize action and return the window to its original size and shape.

Minimizing a Window

Click the Minimize button in the titlebar to remove the window from view. The window can be restored to its previous position and size on the screen from the Window List or the Window Selector in the top panel.
How to Resize a Window

You can also choose Minimize from the Window menu, or press Alt+F9.

Note - A minimized window is shown in the Window List and the Window Selector with [ ] around its title.

Maximizing a Window

You can click the Maximize button in the titlebar to expand the window (the panels remain visible).

You can perform one of the following actions to maximize a window:

- Choose Maximize from the Window menu.
- Press Alt+F10.
- Double-click any part of the titlebar except the buttons at either end.

Note - You can also assign the double-click action to roll up the window so that only the titlebar is displayed. For more information about window preferences, see “Working With Windows” on page 18.

Unmaximizing a Window

When a window is maximized, click the Maximize button again to restore it to its previous position and size on the screen.

You can perform one of the following actions to unmaximize a window:

- Choose Unmaximize from the Window menu.
- Press Alt+F5.
- Double-click any part of the titlebar except the buttons at either end.

Closing a Window

You can click the Close button to close the window. The application prompts you to save any unsaved work.
Giving Focus to a Window

To work with an application, you need to give the focus to its window. When a window has focus, any actions such as mouse clicks, typing text, or keyboard shortcuts are directed to the application in that window. Only one window can have focus at a time. The window that has focus will appear on top of other windows. It might also have a different appearance from other windows, depending on the theme selected.

You can give the focus to a window in any one of the following ways:

- If the window is visible, click any part of the window.
- On the bottom panel, click the Window List button that represents the window.
- On the top panel, click the Window List icon and then choose the window you want to switch to from the list.

**Note** - If the window you choose is on a different workspace, you will be switched to that workspace. For more information about using workspaces, see ”Workspaces Overview” on page 23.

- Press **Alt+Tab**. A pop-up window is displayed with a list of icons representing each window. While still holding **Alt**, press **Tab** to move along the selection list and release the **Alt** key to select the window.

**Note** - You can customize the shortcut used to perform this action with the Keyboard Shortcuts Preference tool.
Using the Desktop Workspaces

This chapter describes workspaces, and how to manage the workspaces available on the Oracle Solaris Desktop.

This chapter includes the following information:

- “Workspaces Overview” on page 23
- “Working With Workspaces” on page 24

Workspaces Overview

Workspaces enable you to manage which windows are on your screen. You can imagine workspaces as being virtual screens, which you can switch between at any time. Every workspace contains the same desktop, panels, and menus. However, you can run different applications and open different windows in each workspace. The applications in each workspace will remain in place when you switch to other workspaces.

By default, four workspaces are available. You can switch workspaces using the Workspace Switcher applet. In the following figure, Workspace Switcher contains four workspaces. The first three workspaces contain open windows. The last workspace does not contain any open windows. The currently active workspace is highlighted.

FIGURE 3-1    Workspace Switcher

Each workspace can have any number of applications open. The number of workspaces can be customized. For more information about adding workspaces, see “Adding and Deleting Workspaces” on page 24.
Note - Workspaces enable you to organize the Oracle Solaris Desktop when you simultaneously run various applications. One way to use workspaces is to allocate a specific function to each workspace.

### Working With Workspaces

You can perform the following workspace actions:

- Switch workspaces
- Add workspaces
- Delete workspaces

### Switching Workspaces

You can switch workspaces in any one of the following ways:

- In the Workspace Switcher applet, click the workspace in which you want to work.
- Move the mouse pointer over the Workspace Switcher applet, and scroll the mouse wheel.
- Press `Ctrl+Alt+right arrow` to switch to the workspace on the right of the current workspace.
- Press `Ctrl+Alt+left arrow` to switch to the workspace on the left of the current workspace.

Note - The arrow shortcut keys work according to how your workspaces are set in the Workspace Switcher applet. If you change your workspace layout to include more than one row of workspaces, use `Ctrl+Alt+Up` arrow to switch to the workspace above the current workspace, and `Ctrl+Alt+down` arrow to switch to the workspace below the current workspace.

### Adding and Deleting Workspaces

Use Workspace Switcher applet to add and delete workspaces.

#### How to Add Workspaces

1. Right-click the Workspace Switcher applet, and then choose Preferences.
The Workspace Switcher Preferences dialog is displayed.

2. In the Number of Workspaces box, increase the value to reflect the number of workspaces visible on the desktop.
3. Click Close.

▼ How to Delete Workspaces

1. Right-click the Workspace Switcher applet, and then choose Preferences.
   The Workspace Switcher Preferences dialog is displayed.
2. In the Number of Workspaces box, decrease the value to reflect the number of workspaces visible on the desktop.
3. Click Close.
Using the Desktop Panels

This chapter describes how to use the panels at the top and bottom of the Oracle Solaris Desktop, how to customize the objects that appear on them, and how to add new panels to the desktop.

This chapter includes the following information:

- “Panel Overview” on page 27
- “Managing Panels” on page 29
- “Setting Panel Properties” on page 30
- “Managing Panel Objects” on page 31
- “Applets” on page 34
- “Launchers” on page 35
- “Buttons” on page 38
- “Menus” on page 41
- “Drawers” on page 42
- “Panel Objects” on page 44

Panel Overview

A panel is an area on the Oracle Solaris Desktop where you have access to certain actions and information. For example, in the default panels, you can launch applications, see the date and time, control the system sound volume, and more.

You can change the panel behavior and its appearance, and add or remove objects from panels. You can create multiple panels, and choose different properties, objects, and backgrounds for each panel. You can also hide panels. By default, the Oracle Solaris Desktop contains a panel at the top and bottom edges of the screen. The following sections describe these panels.

Top Edge Panel

By default, the top edge panel contains the applets described in the following table.
### Panel Overview

#### Top Edge Panel Applets

<table>
<thead>
<tr>
<th>Applet</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menubar</td>
<td>Contains the Applications, Places, and System menus. For more information about the Menubar, see Chapter 6, “Using the Main Menubar”.</td>
</tr>
<tr>
<td>A set of application launcher icons</td>
<td>Use icons to launch the File Manager, the Firefox web browser, the Thunderbird mail application, the Package Manager, and the terminal.</td>
</tr>
<tr>
<td>Notification Area</td>
<td>Displays icons from other applications that might require attention, or that you might want to access without switching from the current application window. For more information about the notification area applets, see “Notification Area Applet” on page 45. Until an application adds an icon to the notification area, only a narrow bar is visible.</td>
</tr>
<tr>
<td>Clock</td>
<td>Displays the current time. Clicking the time opens a small calendar. You can also view a world map by clicking the Locations expansion label. For more information about clock applet, see the Clock Applet Manual.</td>
</tr>
<tr>
<td>Volume Control</td>
<td>Enables you to control the speaker volume on the system. For more on volume control, see the Volume Control Manual.</td>
</tr>
</tbody>
</table>

#### Bottom Edge Panel

By default, the bottom edge panel contains the applets described in the following table.

<table>
<thead>
<tr>
<th>Applet</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Desktop</td>
<td>Minimizes all open windows and displays the desktop. Click again to restore all the windows to their previous state.</td>
</tr>
<tr>
<td>Window List</td>
<td>Displays a button for each open window. The Window List enables you to minimize and restore windows. For more information about Window List, see “Window List” on page 45.</td>
</tr>
<tr>
<td>Workspace Switcher</td>
<td>Enables you to switch workspaces. For more information about workspaces, see “Working With Workspaces” on page 24.</td>
</tr>
<tr>
<td>Trash Applet</td>
<td>Shows whether you have any deleted files in the Trash. Click the applet to view its contents in the File Manager. To empty Trash, right-click the applet and select Empty Trash.</td>
</tr>
</tbody>
</table>
Managing Panels

To interact with a panel, click a vacant space on the panel rather than on any of the objects it holds. If the hide buttons are visible on the panel, you can also middle-click or right-click one of them to select the panel.

For more information about how to set a panel's properties, see “Setting Panel Properties” on page 30.

Moving a Panel

To move a panel to another side of the screen, press and hold \texttt{ALT} and drag the panel to its new location. Click any vacant space on the panel to begin the drag.

A panel that is not set to expand to the full width of the screen can be dragged away from the edge of the screen and placed anywhere.

Hiding a Panel

You can hide or show a panel if it has hide buttons. If the hide buttons are not visible on a panel, modify the panel properties so that the hide buttons are visible.

Hide buttons are at the either end of a panel. The hide buttons contain an optional arrow icon. The below figure shows the hide buttons.

\textbf{FIGURE 4-1} Hide Buttons on a Panel

To hide a panel, click one of the hide buttons. The panel shrinks in the direction of the arrow on the hide button. The hide button at the other end of the panel remains visible.

To show a hidden panel again, click the visible hide button. The panel expands in the direction of the arrow on the hide button.

You can set a panel to autohide so that the panel hides automatically when the mouse is not pointing to the panel. The panel reappears when you point to the part of the screen where the panel resides.
Adding a New Panel

To add a panel, right-click a vacant space on any panel, then choose New Panel. The new panel is added to the Oracle Solaris Desktop and has no objects. You can also customize the new panel.

Deleting a Panel

To delete a panel from the Oracle Solaris Desktop, right-click the panel that you want to delete, and then choose Delete This Panel.

Note - You must always have at least one panel on the Oracle Solaris Desktop. If you have only one panel on the Oracle Solaris Desktop, you cannot delete that panel.

Setting Panel Properties

You can change the properties of each panel, such as the position of the panel, the hide behavior, and the visual appearance.

To modify the properties of a panel, right-click a vacant space on the panel, and then choose Properties. The Panel Properties dialog contains two tabs, General and Background.

About the General Properties Tab

In the General tab, you can modify panel size, position, and hiding properties. The following table describes the dialog elements in the General tab.

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orientation</td>
<td>Selects the position of the panel on the screen. Click the required position for the panel.</td>
</tr>
<tr>
<td>Size</td>
<td>Specifies the size of the panel.</td>
</tr>
<tr>
<td>Expand</td>
<td>By default, a panel expands to the full length of the edge of the screen where it is located. A panel that does not expand can be moved away from the screen edges to any part of the screen.</td>
</tr>
</tbody>
</table>
Managing Panel Objects

About the Background Properties Tab

You can choose the type of background for the panel in the Background tab. The following table describes the dialog elements in the Background tab.

**TABLE 4-4  Background Tab Dialog Elements**

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None (use system theme)</td>
<td>Select this option to have the panel use the settings in the Appearance preference tool. This setting keeps the panel's background similar to the desktop and applications.</td>
</tr>
<tr>
<td>Solid Color</td>
<td>Specifies a single color for the panel background. Click the Color button and choose a color from Color Selector dialog. Use the Style slider to specify the degree of transparency or opaqueness for the color. For example, to make the panel transparent, move the slider towards the end.</td>
</tr>
<tr>
<td>Background image</td>
<td>Specifies an image for the panel background. Click Browse to browse for an image file. Click OK after selecting the file.</td>
</tr>
</tbody>
</table>

You can also drag a color or image on to a panel to set the color or image as the background. You can drag a color or image from many applications. For example:

- You can drag a color from any color selector dialog.
- You can drag an image file from the file manager to set it as the background of the panel.
- You can drag a color or a pattern from the Backgrounds and Emblems dialog in the file manager to a panel to set it as the background.

Managing Panel Objects

This section describes the objects that you can add to and use from your panels.
Interacting With Panel Objects

Use the mouse buttons to interact with a panel object in the following ways:

- Left-click – Launches the panel object
- Middle-click – Enables you to select an object and drag it to a new location
- Right-click – Opens the panel object pop-up menu

Selecting an Applet

Some restrictions apply on where you can click an applet to display the panel object pop-up menu, or to move the applet. Some applets have areas that you cannot use to select the applet. For example, the Command Line applet has a field in which you enter commands. You cannot middle-click or right-click this field to select the applet. Instead, middle-click or right-click another part of the applet.

Right-click particular parts of the applet to view pop-up menus of applet-specific commands. For example, the Window List applet has a vertical handle on the left side, and buttons that represent the windows on the right side. To open the panel object pop-up menu for the Window List applet, you must right-click the handle. If you right-click a button on the right side, a pop-up menu for the button is displayed.

Adding an Object to a Panel

You can add different objects to a panel.

▼ How to Add an Object to a Panel

1. Right-click a vacant space on a panel to open the panel pop-up menu.
2. Choose Add to Panel.
   
   The Add to Panel dialog is displayed. The available panel objects are listed in alphabetical order, with launchers at the top.

Note - You can type a part of the name or description of an object in the find box. This will narrow the list to those objects that match what you type. To restore the full list, delete the text in the find box.
3. Either drag an object from the list to a panel, or select an object from the list and click Add to add it at the spot on the panel where you first right-clicked.

You can also add any item in the Applications menu to the panel. Each launcher corresponds to a `.desktop` file. You can drag a `.desktop` file on to the panels to add the launcher to the panel.

### Modifying the Properties of an Object

Some panel objects, such as launchers and drawers, have a set of associated properties. The properties are different for each type of object. The properties specify the following details:

- The command that starts a launcher application
- The location of the source files for a menu
- The icon that represents the object

#### How to Modify the Properties of an Object

1. Right-click the object to open the panel object pop-up menu.

2. Choose Properties.

   Use the Properties dialog to modify the properties as required. The properties in the dialog depend on the object you select.

3. Close the Properties dialog box.

### Moving a Panel Object

You can move panel objects within a panel, and from one panel to another panel. You can also move objects between panels and drawers.

Movement of a panel object affects the position of other objects on the panel. You can specify a movement mode to control how objects move on a panel. To specify the movement mode, press one of the following keys as you move the panel object.

<table>
<thead>
<tr>
<th>Key</th>
<th>Movement Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No key</td>
<td>Switched movement</td>
<td>The object swaps places with other panel objects. Switched movement is the default movement mode.</td>
</tr>
<tr>
<td>Alt</td>
<td>Free movement</td>
<td>The object jumps over other panel objects into the next vacant space on the panel.</td>
</tr>
</tbody>
</table>
How to Move a Panel Object

1. Right-click the object, and then choose Move.

2. Point to the new location for the object, then click any mouse button to anchor the object to the new location.

This location can be on any panel that is currently on the Oracle Solaris Desktop.

**Note** - Alternatively, you can middle-click and hold the object and drag the object to a new location. When you release the middle mouse button, the object anchors at the new location.

Locking a Panel Object

You can lock panel objects so that the objects stay in the same position on the panel.

**Note** - You can lock the panels if you do not want them to change their position when you move other panel objects.

To lock an object to its current location in the panel, right-click the object, then select Lock To Panel. Deselect this option to unlock the object.

Removing a Panel Object

To remove an object from a panel, right-click the object, and then choose Remove From Panel.

Applets

An applet is an application whose user interface resides within a panel. The following figure displays the following applets:

- **Window List** – Displays the currently open windows.
- **Clock** – Displays the current date and time.
Launchers

A launcher is an object that performs a specific action when you open it.

You can find launchers in panels, in the panel menubar, and on the desktop. A launcher is represented by an icon in all of these locations. You might use a launcher to perform any of the following actions:

- Start an application
- Execute a command
- Open a folder
- Open a web browser at a particular page on the web
- Open special Uniform Resource Identifiers (URIs). The Oracle Solaris Desktop provides special URIs that enable you to access particular functions from the file manager.

You can modify the properties of a launcher. For example, the properties of a launcher include the name of the launcher, the icon that represents the launcher, and how the launcher runs. For more information about modifying a launcher, see “Modifying a Launcher” on page 36.

Adding a Launcher to a Panel

You can add a launcher to a panel from any one of the following options:

- Pop-up menu
- Menu
- File manager

How to Add a Launcher to a Panel From the Panel Pop-up Menu

1. Right-click any vacant space on the panel, then choose add to panel.
The add to panel dialog is displayed.

2. **Add a new launcher or an existing launcher**

   - **To add a new launcher:**
     a. Select custom application launcher from the list.
        The create launcher dialog is displayed.
     b. Provide the information about the launcher and click ok.
   
   - **To add an existing launcher:**
     a. Select application launcher from the list.
     b. Choose the launcher from the list of menu items.

   ▼ **How to Add a Launcher to a Panel From a Menu**

   1. Open a menu that contains the launcher and drag the launcher to the panel.
   2. Right-click the title of the launcher and choose Add this launcher to panel.

   **Note** - This method will work only if the launcher is on a submenu of the menu that is opened.

   ▼ **How to Add a Launcher to a Panel From the File Manager**

   1. Browse the file manager and select the `.desktop` file for the launcher in your file system.
   2. Drag the `.desktop` file to the panel.

   **Modifying a Launcher**

   The desktop enables you to modify the launcher properties.
How to Modify the Launcher Properties

1. Right-click the launcher to open the panel object pop-up menu.

2. Choose Properties.
   Use the Launcher Properties dialog to modify the properties as required. For more information, see “Launcher Properties” on page 37.

3. Click Close to close the dialog.

Launcher Properties

The following table describes the properties that you can set when you create or edit a launcher.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Use the drop-down list to specify whether the launcher starts an application or opens a location:</td>
</tr>
<tr>
<td></td>
<td>■ Application – The launcher starts an application.</td>
</tr>
<tr>
<td></td>
<td>■ Application in Terminal – The launcher starts an application through a terminal window.</td>
</tr>
<tr>
<td></td>
<td>■ Location – The launcher opens a file, web page, or other location.</td>
</tr>
<tr>
<td></td>
<td>If you are editing a location launcher, this drop-down list will not be displayed. If you are editing an application launcher, the Location option will not be available.</td>
</tr>
<tr>
<td>Name</td>
<td>The name is displayed if you add the launcher to a menu or to the desktop.</td>
</tr>
<tr>
<td>Command</td>
<td>For an application launcher, specify a command to execute when you click the launcher. For sample commands, see “Launcher Commands and Locations” on page 37.</td>
</tr>
<tr>
<td>Location</td>
<td>For a location launcher, specify the location that you want to open. Click Browse to select a location on the computer, or type a web address to launch a web page. For sample locations, see “Launcher Commands and Locations” on page 37.</td>
</tr>
<tr>
<td>Comment</td>
<td>Displayed as a tooltip when pointed to the launcher icon on the panel.</td>
</tr>
</tbody>
</table>

Launcher Commands and Locations

If you choose Application or Application in Terminal from the Type drop-down list in the Launcher Properties dialog, the Command text box displays the related launch command. The following table shows some sample commands and their actions.
### Buttons

<table>
<thead>
<tr>
<th>Sample Application Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>gedit</td>
<td>Starts the Gedit text editor application.</td>
</tr>
<tr>
<td>gedit /home/user/loremipsum.txt</td>
<td>Opens the file /home/user/loremipsum.txt in the Gedit text editor application.</td>
</tr>
<tr>
<td>nautilus /home/user/Projects</td>
<td>Opens the folder /home/user/Projects in a file browser window.</td>
</tr>
</tbody>
</table>

If you choose Location from the Type drop-down list in the Launcher Properties dialog, the Location text box displays the related location for the launcher. The following table shows some sample locations and their actions.

<table>
<thead>
<tr>
<th>Sample Location</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>file:///home/user/loremipsum.txt</td>
<td>Opens the file /home/user/loremipsum.txt in the default viewer for its file type.</td>
</tr>
<tr>
<td>file:///home/user/Projects</td>
<td>Opens the folder /home/user/Projects in a File Browser window.</td>
</tr>
<tr>
<td><a href="http://www.oracle.com">http://www.oracle.com</a></td>
<td>Opens the Oracle web site in the default browser.</td>
</tr>
</tbody>
</table>

### Buttons

You can add buttons to your panels to provide quick access to common actions and functions. This section describes buttons you can add to your panels. For information about how to add an object to a panel, see “Adding an Object to a Panel” on page 32.

### Force Quit

The Force Quit button enables you to click a window to force an application to quit. This button is useful if you want to terminate an application that does not respond to your commands, or if the application has crashed or is not responsive.
To terminate an application, click Force Quit, and then click a window from the application that you want to terminate. Press Esc if you do not want to terminate the application.

**Lock Screen**

The Lock Screen button locks the screen and activates the screensaver. To access the session again, you must provide your password.

Right-clicking the Lock Screen button displays a menu of screensaver-related commands. The following table describes the menu options.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate Screensaver</td>
<td>Activates the screensaver. This option also locks the screen if you have set Lock Screen When the Screensaver Is Active in the Screensaver preference tool.</td>
</tr>
<tr>
<td>Lock Screen</td>
<td>Locks the screen.</td>
</tr>
<tr>
<td>Properties</td>
<td>Opens the Screensaver preference tool, which enables you to configure the type of screensaver that is displayed when you lock the screen.</td>
</tr>
</tbody>
</table>

*Note* - Clicking the Lock Screen button locks the screen only if the screensaver is enabled in the Screensaver preference tool. By default, the screensaver is enabled.
Log Out

The Log Out button enables you to log out of a desktop session or switch to a different user account.

FIGURE 4-5  Log Out Button

Run

Clicking the Run button displays the Run Application dialog, which enables you to start an application by choosing it from a list.

FIGURE 4-6  Run Button

For more information about the Run Application dialog, see “Running Applications” on page 113.

Search for Files

Clicking the Search for Files button displays the Search Tool, which enables you to search for files on the computer. For more information about the Search Tool, see the Search Tool Manual.
Menus

Show Desktop

You can use the Show Desktop button to minimize all open windows and show the desktop.

How to Add a Menubar or Main Menu to a Panel

1. Right-click any vacant space on the panel and choose Add to Panel.
2. Choose Menubar or Main menu from the Add to Panel dialog.
How to Add a Submenu to a Panel

1. Open a submenu in any one of the following:
   - Main Menu applet
   - Applications
   - Places
   - System menu in the Menubar applet

2. Right-click a launcher item on the submenu.

3. Choose Entire Menu → Add this menu to panel.

Drawers

A drawer is an extension of a panel. You can open and close a drawer in the same way that you can show and hide a panel. A drawer can contain all panel objects, including launchers, menus, applets, and other drawers. When you open a drawer, you can use the objects in the same way that you use objects on a panel.

You can open a drawer by clicking the drawer's icon. To close the drawer, click the icon again or click the drawer's hide button.

The following figure shows an open drawer that contains two panel objects.

FIGURE 4-9  Drawer Panel

The arrow on the icon indicates that it represents a drawer or menu.
You can add, move, and remove objects from drawers in the same way that you add, move, and remove objects from panels. You can add a drawer in the same way as you add other objects. For more information, see “Adding an Object to a Panel” on page 32.

▼ How to Add a Menu as a Drawer to a Panel

1. Open a submenu in any one of the following:
   - Main Menu applet
   - Applications
   - Places
   - System menu in the Menubar applet

2. Right-click a launcher item on the submenu.

3. Choose Entire menu → Add this as drawer to panel.

▼ How to Add an Object to a Drawer

1. Right-click a vacant space on a drawer to open the drawer pop-up menu.

2. Choose Add to Drawer.
   
   The Add to Drawer dialog is displayed. The available drawer objects are listed in alphabetical order, with launchers at the top.

   Note - You can type a part of the name or description of an object in the find box to narrow the list to those objects that match what you type. To restore the full list, delete the text in the find box.

3. Either drag an object from the list to a drawer, or select an object from the list and click Add to add it at the spot on the drawer where you first right-clicked.

▼ How to Modify Drawer Properties

You can modify the properties of individual drawer. For example, you can change the visual appearance of the drawer and whether it has hide buttons.
1. **Right-click the drawer, and then choose Properties.**
   The Drawer Properties dialog appears and displays the General tab.

2. **Select the properties for the drawer. The elements on the General tab are as follows:**
   - **Size** – Specifies the width of the drawer when it is open.
   - **Icon** – Chooses an icon to represent the drawer. Click the Icon button to display an icon selector dialog. Choose an icon from the dialog and click OK to confirm your choice.
   - **Show hide buttons** – Displays hide buttons on your drawer. Click one of the buttons to close the drawer.
   - **Arrows on hide buttons** – Select this option to display arrows on the hide buttons, if the hide buttons are enabled.

3. **You can use the Background tab to set the background for the drawer.**
   For information on how to complete the Background tab, see “Setting Panel Properties” on page 30. You can also drag a color or image on to a drawer to set the color or image as the background of the drawer. For more information, see “About the Background Properties Tab” on page 31.

4. **Click Close to close the dialog.**

---

**Panel Objects**

This section covers the panel objects that appear in the Oracle Solaris Desktop.

**Menubar**

The menubar contains the Applications, Places, and System menus. You can access almost all of the standard applications, commands, and configuration options from the menubar. For more information about using the menubar, see Chapter 6, “Using the Main Menubar”.

**FIGURE 4-10** Main Menubar
Window Selector Applet

You can view a list of all windows that are currently open. You can also select a window to give focus to. To view the window list, click the Window Selector applet. The following figure shows an example of the Window Selector applet.

FIGURE 4-11 Window Selector Applet

To give focus to a window, select the window from the Window Selector applet. The Window Selector lists the windows in all workspaces. The windows in all workspaces other than the current workspace are listed under a separator line.

Notification Area Applet

The Notification Area applet displays icons from various applications to indicate activity in the application. For example, when you use the CD Player application to play a CD, a CD icon is displayed in the Notification Area applet.

Window List

The Window List applet enables you to manage the windows that are open on the Oracle Solaris Desktop. Window List uses a button to represent each window or group of windows that are open. The state of the buttons in the applet varies depending on the state of the window that the button represents. The following table describes the possible states of the Window List buttons.

<table>
<thead>
<tr>
<th>State</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>The button is pressed in.</td>
<td>The window has focus.</td>
</tr>
<tr>
<td>The button appears faded. The button text is surrounded by square brackets.</td>
<td>The window is minimized.</td>
</tr>
<tr>
<td>The button is not pressed in, and is not faded.</td>
<td>The window is displayed on the desktop and is not minimized.</td>
</tr>
</tbody>
</table>

TABLE 4-6 Window List Button States
Panel Objects

<table>
<thead>
<tr>
<th>State</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>There is a number in parentheses at the end of the button title.</td>
<td>The button represents a group of buttons.</td>
</tr>
</tbody>
</table>

**Usage**

You can use the Window List to perform the following tasks:

- Give focus to a window that is on the desktop which previously did not have focus.
- Minimize the window that has focus.
- Restore a minimized window.

You can change the order of the buttons by dragging a button to a different location on the Window List.

**Preferences**

To configure the Window List, right-click the handle to the left of the window buttons, and then choose Preferences. The following preferences can be changed:

- **Window List Content** – To specify which windows to display in the Window List, select one of the following options:
  - Show windows from current workspace – Shows only the windows that are open in the current workspace.
  - Show windows from all workspaces – Shows the windows that are open in all workspaces.
- **Window Grouping** – To specify when the Window List should group windows that belong to the same application, select one of the following options:
  - Never group windows – Windows of the same application are never grouped under one button.
  - Group windows when space is limited – Windows of the same application are grouped under one button when the space on the panel is restricted.
  - Always group windows – Windows of the same application are always grouped under one button.
- **Restoring Minimized Windows** – To define how the Window List behaves when you restore windows, select one of the following options:
  - Restore to current workspace – Windows from the applet will be restored to the current workspace even if the window did not previously reside in the current workspace.
  - Restore to native workspace – The focus will switch to the workspace in which the window originally resided.
These options are only available if Show Windows From All Workspaces is selected in the Window List Content section of the dialog.

**Command Assistant Applet**

The Command Assistant applet provides quick access to Oracle Solaris documentation such as man pages and administration guides, based on the given search query.

By default, the Command Assistant applet is not installed. You can install the Command Assistant applet by using `packagemanager(1)` or by typing the following command as a root user:

```sh
# pkg install cmdassist
```

After installing the Command Assistant applet, you have to manually add the applet to a panel. For more information about adding launchers to a panel, see “How to Add a Launcher to a Panel From the Panel Pop-up Menu” on page 35.

The Command Assistant applet displays a list of references to the documentation that can be opened in a browser by clicking the required reference. The search terms are matched against the available command-line examples in documentation, making it easy to find references for commands. For example, you can access `useradd`, `zpool create`, and many other commands.

The following example shows the available commands in documentation that you can use with the `zpool create` command.
FIGURE 4-12  Command Assistant Search Example
This chapter describes how to use the Oracle Solaris Desktop applications. The applications have a similar look-and-feel, use the same shortcut keys, and also provide a drag-and-drop option. The applications are developed using the GNOME 2.30 development platform. An application developed using this platform is also called a GNOME-compliant application. For example, the file manager and the Gedit Text Editor are GNOME-compliant applications.

This chapter includes the following information:

- “Applications Overview” on page 49
- “Working With Files” on page 50
- “Opening a File” on page 50
- “Saving a File” on page 52

Applications Overview

An application is a type of computer program that enables you to perform a particular task. You can use applications to perform one of the following tasks:

- Create text documents such as letters or reports
- Work with spreadsheets
- Listen to music
- Browse the Internet
- Create, edit, or view images and videos

To perform each of these tasks, you use a different application.

To start an application, open the Applications menu and choose the application you want to start from the submenus. For more information about starting an application, see “About the Applications Menu” on page 55.

The following table describes the applications that exist on the Oracle Solaris Desktop.
TABLE 5-1     Desktop Applications

<table>
<thead>
<tr>
<th>Application</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gedit Text Editor</td>
<td>Reads, creates, or modifies simple text without any formatting.</td>
</tr>
<tr>
<td>Dictionary</td>
<td>Enables you to search definitions of a word.</td>
</tr>
<tr>
<td>Image Viewer</td>
<td>Displays single image files and image collections.</td>
</tr>
<tr>
<td>Character Map</td>
<td>Enables you to choose letters and symbols from the Unicode character set and paste them to any application.</td>
</tr>
<tr>
<td>Nautilus File Manager</td>
<td>Displays folders and their contents. You can use this application to copy, move, classify your files. The application also enables you to access CDs, USB flash drives, and other removable media.</td>
</tr>
<tr>
<td>Terminal</td>
<td>Enables access to the system command line.</td>
</tr>
</tbody>
</table>

Further standard desktop applications include games, music and video players, a web browser, software accessibility tools, and utilities to manage the system.

**Working With Files**

The work you do with an application is stored in files. These files might be on the computer's hard drive, or on a removable device such as a USB flash drive. You can open and examine a file or save a file to store your work. This section describes actions you can perform in the File dialog.

All desktop applications use similar dialogs for opening and saving files, presenting you with a consistent interface.

**Opening a File**

The Open File dialog enables you to choose a file to open in an application. The right-hand pane of the dialog lists files and folders in the current location. This section describes actions you can perform in the File dialog.

You can use the mouse or the arrow keys on your keyboard to select a file. Once a file is selected, perform one of the following actions to open it:

- Click Open
- Press **Return**
- Press **Spacebar**
- Double-click the file
If you open a folder or a location instead of a file, the Open File dialog updates the view to show the contents of that folder or location.

To change the location shown in the right-hand pane, perform one of the following actions:

- Open a folder that is listed in the current location.
- Open an item in the left-hand pane. This pane lists places such as the Documents folder, Home folder, media such as CDs and flash drives, places on the network, and bookmarks.
- Click one of the buttons in the path bar above the File List pane. The File List shows the hierarchy of folders that contain your current location. Use the arrow buttons on either side of the button bar if the list of folders is long.

The lower part of the Open File dialog might contain further options specific to the current application.

**Filtering the File List**

You can restrict the File List to show only certain file types. To do this, choose a file type from the drop-down list below the File List pane. The list of file types depends on the application you are currently using. For example, a graphics application will list different image file formats, and a text editor will list different text file types.

Tip - Type the name of the file you want to open. The File List displays the files whose names begin with the characters you type. The characters you have typed appear in a pop-up window at the bottom of the File List. To cancel find-as-you-type, press Esc.

**Choosing a Folder**

You might sometimes need to choose a folder to work with rather than opening a file. For example, if you use Archive Manager to extract files from an archive, you need to choose a folder in which to place the files. In this case, the files in the current location are greyed out, and clicking Open when a folder is selected chooses that folder.

**Opening a Location**

You can type a full or relative path to the file you want to open. Press Ctrl+L or click the button at the top left of the window to show (or hide) the Location field. Alternatively, begin typing a full path starting with / to show the Location field.

Type a path from the current location, or an absolute path beginning with / or ~/. The Location field has the following features to simplify the typing of a full filename:
A drop-down list of possible file and folder names is displayed once you begin typing. Use the down arrow or the up arrow and **Return** to choose from the list.

If part of the name typed identifies a file or folder, the name is auto-completed. Press **Tab** to accept the suggested text. For example, if you type `Do` and the only object in the folder beginning with “Do” is “Documents, then the entire name appears in the field.

**Opening Remote Locations**

You can open files in remote locations by choosing the location from the left panel, or by typing a path to a remote location in the Location field.

If you require a password to access the remote location, you will be asked for it when you open the file or the location.

**Adding and Removing Bookmarks**

To add the current location to the bookmarks list, right-click a folder in the File List and choose Add to Bookmarks. You can add any folder listed in the current location by dragging it to the bookmarks list.

To remove a bookmark from the list, select the bookmark and click Remove.

**Note** - Changes you make to the bookmarks list also affect the Places menu. For more information about bookmarks, see “Using Bookmarks” on page 95.

**Showing Hidden Files**

To show hidden files in the list, right-click in the File List and choose Show Hidden Files. For more information about hidden files, see “Hiding a File or Folder” on page 97.

**Saving a File**

The first time you save your work in an application, the Save As dialog asks you for a location and name for the file. When you save the file on subsequent occasions, it will be updated and you will not be asked to re-enter a location or name for the file. To save an existing file as a new file, choose File → Save As.
You can type a file name and choose a location to save from the drop-down list of bookmarks and commonly used locations.

**Saving a File in Another Location**

To save the file in a location not listed in the drop-down list, click Browse. The Save File dialog is displayed.

**Note** - The expanded Save File dialog has the same features as the Open File dialog, such as filtering, find-as-you-type, and adding and removing bookmarks.

**Replacing an Existing File**

If you type the name of an existing file, you will be asked whether you want to replace the existing file with your current work. You can also replace the file by choosing the file you want to overwrite in the browser.

**Creating a Folder**

To create a folder to save your file, click the Create Folder button. Type a name for the new folder and press **Return**. You can then choose to save your file in the new folder.
Using the Main Menubar

This chapter describes how to use the desktop panel menubar. This chapter includes the following information:

- “About the Main Menubar” on page 55
- “About the Applications Menu” on page 55
- “Using the Places Menu” on page 56
- “Using the System Menu” on page 57
- “Using the Administration Menu” on page 57
- “Customizing the Panel Menubar” on page 58

About the Main Menubar

The panel menubar is the main point of access to the desktop. The menubar has the following menus:

- Applications – Starts the required applications.
- Places – Opens locations on the computer or network.
- System – Customizes the system, logs out of the desktop, or shuts down the system.

Note - By default, the panel menubar is on the top edge panel. But like any other panel object, you can move the menubar to another panel, or have more than one instance of the menubar in the panels. For more information about menus, see “Menus” on page 41.

About the Applications Menu

The Applications menu contains a hierarchy of submenus from which you can start the applications that are installed on the system.

Each submenu corresponds to a category. For example, in the Sound & Video submenu, you will find applications for playing CDs and to record sounds.
When you install a new application, it is automatically added to the Applications menu in a suitable category. For example, if you install an instant messenger application, a VoIP application, or an FTP client, it is placed in the Internet submenu.

**How to Start an Application**

1. **Open the Applications menu.**
2. **Select the desired application category.**
   Each submenu opens as you hover the mouse over the category.
3. **Click the menu item for the application you want to open.**

**Using the Places Menu**

The Places menu is a quick way to go to various locations on the computer and local network. Use Places menu to open the following items:

- Home folder.
- Desktop folder, which corresponds to the items displayed on the desktop.
- Items in the file manager bookmarks. For more information about using bookmarks, see “Using Bookmarks” on page 95.
- Local drives on the system.
- CD/DVD Creator.
- Local network. For more information about accessing network places, see “Accessing Network Places” on page 104.

The following items on the Places menu perform actions rather than opening locations:

- Connect to Server – Enables you to choose a server on a network. For more information about accessing remote networks, see “Accessing a Remote Server” on page 104.
- Search for Files – Enables you to search for files on the computer. For more information about searching for files, refer to the Search Tool Manual.
- Recent Documents – Lists the recently opened documents. The last entry in this submenu clears the list.
Using the System Menu

The System menu enables you to set the preferences for the Oracle Solaris Desktop, get help with using the desktop, and log out or shut down the system.

Use System menu to perform the following actions:

- Configure the computer using the preference tools. For more information about using these preferences, see Chapter 10, “Configuring the Desktop”.
- Start the Help Browser.
- Lock the screen to start the screensaver. For more information, see “Locking the Screen” on page 14.
- Log out or switch user.
- End your desktop session to turn off the computer, or restart it. For more information about logging out and shutting down, see “Ending a Session” on page 16.

Using the Administration Menu

The Administration menu enables you to administer the Oracle Solaris Desktop and perform tasks such as configuring network devices, managing printers, maintaining SMF services, and configuring the system to take automatic ZFS snapshots. For more information about the individual administration utilities accessed through the menu, click Help in the associated dialog.

The Administration menu has the following items:

- Core Files – Configure names, locations, and contents of core files that are generated by the Oracle Solaris Desktop.
- Network – View and configure network interface properties, connection profiles, locations, and network modifiers.
- Package Manager – Search, add, update, and remove software packages by using the Oracle Solaris Image Packaging System. You can also view and edit package publishers and boot environments.
- Print Manager – Add, remove, and configure local and network printers by using the Common UNIX Printing System (CUPS).
- SMF Services – Monitor, configure, enable, and disable Service Management Facility (SMF) services on the local system.
- System Firewall – Configure system-wide or service-specific firewall policy setting.
- Time Slider – Enable or disable regular snapshots of specified ZFS file systems. When enabled, users can visualize and browse the content of historical snapshots by using the file manager.
- Time/Date – Set the system clock, or configure it automatically from a time server.
Customizing the Panel Menubar

You can customize the contents of the following menus:

- Applications menu
- System → Preferences submenu
- System → Administration submenu

For more information about how the desktop implements these menus, and how administrators can customize them, refer to the “Oracle Solaris 11.2 Desktop Administrator’s Guide”.

How to Edit Menus

1. **Right-click the panel menubar, and choose Edit Menus.**
   
The Menu Layout dialog box is displayed. It lists the menus in the left pane.

2. **Click the expander arrows to show or hide submenus.**

3. **Choose a menu from the left pane to view its contents in the right pane.**

4. **To remove an item from the menu, deselect it. To restore an item to the menu, select it.**
Using Time Slider

Time Slider provides a graphical way for Oracle Solaris desktop users to restore individual files or directories from automatically scheduled, incremental snapshots of home directories. Once activated and set up, Time Slider takes a snapshot of every ZFS file system every 15 minutes, by default. These snapshots are then deleted again over time, such that only one snapshot is kept for each of the previous 24 hours, one for each of the previous 7 days, and one for each previous week that the Time Slider service was running.

A snapshot is a read-only copy of a file system or volume. Snapshots can be created almost instantly, and they initially consume no additional disk space within the pool. However, as data within the active dataset changes, the snapshot consumes disk space by continuing to reference the old data, thus preventing the disk space from being freed.

Time Slider snapshot services can automate periodic snapshots for any ZFS file system, including boot environments, even on non-desktop systems. However, the desktop/time-slider package does require that the desktop-incorporation package be installed, even if the Oracle Solaris Desktop will not be used on that machine.

For more information about Time Slider, see Chapter 6, “Working With Oracle Solaris ZFS Snapshots and Clones,” in “Managing ZFS File Systems in Oracle Solaris 11.2.”

Time Slider Preferences Pane

Time Slider preferences pane allows you to enable or disable Time Slider, and provides access to the following features:

- Backing up to an external storage device
- Backing up file systems
- Changing storage space available to snapshots
- Deleting existing snapshots
Enabling and Disabling the Time Slider Service

By default, Time Slider is disabled. You can enable it using the steps mentioned in the following sections. When enabled, Time Slider uses the following SMF services:

- `svc:/system/filesystem/zfs/auto-snapshot:frequent`: Takes one snapshot every 15 minutes
- `svc:/system/filesystem/zfs/auto-snapshot:hourly`: Takes one snapshot every hour
- `svc:/system/filesystem/zfs/auto-snapshot:daily`: Takes one snapshot every day
- `svc:/system/filesystem/zfs/auto-snapshot:weekly`: Takes one snapshot every week
- `svc:/system/filesystem/zfs/auto-snapshot:monthly`: Takes one snapshot every month
- `svc:/application/time-slider:default`: Manages automatic deletion of snapshots
- `svc:/application/time-slider/plugin:rsync`: Replicates each snapshot automatically to a specified external storage device

### How to Enable Time Slider

1. **Open the Time Slider preferences pane by choosing System → Administration → Time Slider.**
2. **Select the Enable Time Slider option.**
3. **Click OK.**
   
   Time Slider is enabled for all available ZFS file systems. To exclude one or more ZFS file systems, see “How to Choose a Specific ZFS File System to Snapshot” on page 62.

### How to Disable Time Slider

1. **Open the Time Slider preferences pane by choosing System → Administration → Time Slider.**
2. **Deselect the Enable Time Slider option.**
3. **Click OK.**
   
   Time Slider is disabled for all available ZFS file systems.
Working with Time Slider Snapshots

Time Slider takes frequent snapshots of all the attached ZFS file systems. These snapshots are taken every 15 minutes, hourly, daily, and weekly.

You can take snapshots using either Time Slider preferences pane or using the file manager. The following sections describe different procedures that can be performed using these methods.

Managing Snapshots Using Time Slider

When Time Slider is enabled, automatic snapshots are deleted as follows:

- frequent snapshots are deleted after 1 hour
- hourly snapshots are deleted after 1 day
- daily snapshots are deleted after 1 week
- weekly snapshots are deleted after 1 month
- One or more of the oldest snapshots on a file system will be deleted when the file system becomes more than 80% full

You can also delete snapshots manually, if required. For more information, see “How to Delete an Existing Snapshot From Time Slider” on page 61.

You can change the free disk space threshold at which the oldest snapshots will be automatically deleted. For more information, see “How to Change the Storage Space Available to Snapshots” on page 62.

If you do not require snapshots to be taken and stored on every ZFS file system, you can choose which file systems to include or exclude. For more information, see “How to Choose a Specific ZFS File System to Snapshot” on page 62.

For additional protection, every Time Slider snapshot can be automatically copied to an external storage device. For more information, see “How to Replicate Snapshots to an External Storage Device” on page 63.

How to Delete an Existing Snapshot From Time Slider

1. Open the Time Slider preferences pane by choosing System → Administration → Time Slider.
2. Open the Delete Snapshots window by clicking the Delete Snapshots button.
3. In the snapshot list, select any snapshots that you want to delete.
You can filter the list by file system and by the SMF service that took the snapshot: frequent, hourly, daily, weekly or monthly.

4. **Click the Delete button.**

5. **Click the Close button.**

---

*Note* - Snapshots that were not created by Time Slider are also listed in the Delete Snapshots window, and can be deleted by using the same method.

---

### How to Change the Storage Space Available to Snapshots

By default, Time Slider creates new snapshots on a ZFS file system until the file system is 80% full. At that point, Time Slider will automatically delete one or more of its oldest automatic snapshots as necessary to return the file system usage to 80% or less.

You can set this threshold from any value between 70% and 90%. This value applies to all ZFS file systems. Use this procedure to change the threshold value.

1. **Open the Time Slider preferences pane by choosing System → Administration → Time Slider.**

2. **Click the Advanced Options expander button.**

3. **In the Reduce Backups When Storage Space Usage Exceeds text box, type a value between 70 and 90, or use the spin buttons to increase or decrease the existing value.**

4. **Click OK to close the window.**

### How to Choose a Specific ZFS File System to Snapshot

By default, Time Slider takes snapshots of all the ZFS file systems. Use this procedure to choose a specific set of file systems for the Time Slider service to snapshot.

1. **Open the Time Slider preferences pane by choosing System → Administration → Time Slider.**

2. **Click the Advanced Options expander button.**
3. Click the Custom radio button.

4. In the list of ZFS file systems, select the option next to the file system that you want to snapshot, and deselect the other file system options that you do not want to snapshot.

5. Click OK to close the window.

▼ How to Replicate Snapshots to an External Storage Device

For additional data protection, Time Slider can duplicate every snapshot it takes to an external storage device. Use this procedure to enable this feature.

1. Open the Time Slider preferences pane by choosing System → Administration → Time Slider.

2. Click the Advanced Options expander button.

3. Select the Replicate backups to an External Drive option.

4. Choose a directory on an external device by using the file chooser button.

5. Click OK to close the window.

---

Note - External devices do not need to be formatted with the ZFS filesystem to use this feature.

---

Managing Snapshots From a File Manager

Time Slider service takes automatic snapshots of your files every 15 minutes. When your system administrator has enabled Time Slider, you can browse and recover old versions of your files by using File Manager application.

▼ How to View the Available Snapshots in File Manager

Use this procedure to view a list of the snapshots available for a particular folder.

1. Open the File Manager window and navigate to a folder.

2. Open the Time Slider pane, by using one of the following methods:
In the File Manager window, choose View→Restore and click the Time Slider toolbar button.

Press Ctrl+E to open the Time Slider pane.

The Time Slider pane shows the available snapshots for a folder in a time-ordered sequence of bars. The earliest snapshot is on the left, and the current state, labelled Now, is on the right as shown in the following figure.

For each snapshot in the Time Slider pane:

- The height of the bar indicates the amount of data in the snapshot. The higher the bar, the larger the number of file system changes since the previous snapshot.
- The appearance of the bar indicates the type of snapshot.
  - Unfilled: Local snapshot only, no external backup
  - Filled: Local snapshot with external backup
  - Rounded top: Automatic Time Slider snapshot
  - Square top: Manual snapshot

If several snapshots are displayed, you can filter the timeline by using the drop-down list in the Time Slider pane. The following options are available:

- All: Displays all the existing snapshots.
- Today: Displays only snapshots that have been taken today.
- Yesterday: Displays only snapshots that were taken the previous day.
- This week: Displays snapshots that have been taken since Sunday of the current week.
- Last week: Displays snapshots that were taken between Sunday and Saturday of the previous.
- This month: Displays snapshots that have been taken since the 1st of the current month.
- Last month: Displays snapshots that were taken between the 1st and 31st of the previous month.
- This year: Displays snapshots that have been taken since January 1st of the current year.
- Last year: Displays snapshots that were taken between January 1st and December 31st of the previous year.
To hide the Time Slider pane again, click the Close button on the top right of the pane. Alternatively, you can choose View → Restore, click the Time Slider toolbar button, or press Ctrl +E, when the pane is displayed.

**How to View the Previous Version of a File or Folder**

1. **Open the File Manager window and navigate to the folder containing the file.**

2. **Open the Time Slider pane by using one of the following methods:**
   - In the File Manager window, choose View → Restore and click the Time Slider toolbar button.
   - Press Ctrl+E to open the Time Slider pane.

3. **In the Time Slider pane, click on the bar representing the snapshot that you want to view.**
   The File Manager window contents are updated to show the files that were present in the folder when the snapshot was taken.

4. **Double-click any file to show the contents of that file when the snapshot was taken.**

**How to Compare Versions of a File or Folder**

1. **Open the File Manager window and navigate to the folder containing the file.**

2. **Open the Time Slider pane by using one of the following methods:**
   - In the File Manager window, choose View → Restore and click the Time Slider toolbar button.
   - Press Ctrl+E to open the Time Slider pane.

3. **In the Time Slider pane, click on the bar representing the snapshot that you want to view.**
   The File Manager window contents are updated to show the files that were present in the folder when the snapshot was taken.
4. Right-click any file, then select Explore Versions from the menu to open the Version Explorer window.
   If no different versions are available to compare, No Versions is shown on the menu instead of Explore Versions.
   The Time Slider File Version Explorer window is displayed.

5. In the Version Explorer window, select an older versions of the file and then click Compare.

Note - You must install the developer/meld package to compare versions of a file. To install this package, use the Package Manager application, or type `sudo pkg install developer/meld` in a terminal.

How to Restore a Previous Version of a File

If you want to edit a previous version of a file, you must first restore it to your working environment. Use this procedure to restore the previous version of a file.

1. Open the File Manager window and navigate to the folder containing the file.

2. Open the Time Slider pane by using one of the following methods:
   - In the File Manager window, choose View→Restore and click the Time Slider toolbar button.
   - Press Ctrl+E to open the Time Slider pane.

3. In the Time Slider pane, click the bar representing the snapshot that you want to view.
   The File Manager window contents are updated to show the files that were present in the folder when the snapshot was taken.

4. Copy the version of the file you want to restore by using the following methods:
   - Right-click the file that you want to restore, and choose Restore to Desktop to copy that version of the file to your desktop.
   - Drag the file into another File Manager window to copy the file to another location.
How to Take a Manual Snapshot

Sometimes you might want to take a snapshot of your files manually, rather than waiting for the Time Slider to automatically take a snapshot.

1. Open the File Manager window and navigate to the folder containing the file.
2. Open the Time Slider pane by using one of the following methods:
   ■ In the File Manager window choose View → Restore and click the Time Slider toolbar button.
   ■ Press Ctrl+E to open the Time Slider pane.
3. (Optional) Select the snapshot labelled Now, if not selected.
4. Click the Take Snapshot button in the bottom right corner of the Time Slider pane.
5. When prompted, type a name for the snapshot and then click OK to confirm.

A manual snapshot of the file manager is displayed on the Time Slider panel.

How to Delete a Snapshot From a File Manager

If you are certain that you no longer require a particular snapshot, whether it is a manual snapshot or an automatic Time Slider snapshot, you can delete it by using the following procedure.

1. Open the File Manager window and navigate to the folder containing the file.
2. Open the Time Slider pane by using one of the following methods:
   ■ In the File Manager window choose View → Restore and click the Time Slider toolbar button.
   ■ Press Ctrl+E to open the Time Slider pane.
3. Select the snapshot that you want to delete.
4. Click the Delete Snapshot button in the bottom right corner of the Time Slider pane.
Since this step is permanent and cannot be undone, you must be logged in as root and provide the root password to perform this step.
Using the File Manager

This chapter describes how to use the file manager. This chapter includes the following information:

- “File Manager Overview” on page 69
- “Spatial Mode” on page 70
- “Browser Mode” on page 74
- “Opening Files” on page 80
- “Searching Files” on page 81
- “Managing Files and Folders” on page 82
- “Using Item Properties” on page 98
- “Modifying the Appearance of Files and Folders” on page 98
- “Using Removable Media” on page 102
- “Navigating Remote Servers” on page 104
- “Setting File Manager Preferences” on page 105
- “Extending the File Manager” on page 111

File Manager Overview

The file manager provides a simple and integrated way to manage files and applications. You can use the file manager to perform the following actions:

- Create folders and documents
- Display files and folders
- Search and manage files
- Run scripts and start applications
- Customize the appearance of files and folders
- Open special locations on the computer
- Write data to a CD or DVD
- Install and remove fonts
The file manager manages the desktop. The desktop lies behind all other visible items on the screen.

Every user has a Home folder, which contains all files related to the user. The desktop contains special icons allowing easy access to the user's Home folder and Trash, and also to removable media such as floppy disks, CDs, and USB flashdrives.

The file manager provides two modes in which you can interact with the file system. You can choose the mode which the file manager should use by selecting (or deselecting) Always Open In Browser Windows in the Behavior tab of the file manager preferences dialog. The two modes are:

- **Browser mode** – In this mode, you can browse the files and folders. The file manager window represents a browser, which can display any location. Opening a folder updates the current file manager window to show the contents of the new folder. The browser window displays a toolbar with common actions and locations, a location bar that shows the current location in the hierarchy of folders, and a sidebar that can hold different kinds of information. For more information about using the browser mode, see “Browser Mode” on page 74.

- **Spatial mode** – In this mode, you can navigate to files and folders as objects. The file manager window represents a particular folder. Opening a folder opens a new window for that folder. Each time you open a particular folder, it is displayed at the same place on the screen and with the same size as it opened the last time. In spatial mode, the file manager indicates an open folder with a different icon. Using spatial mode might lead to more open file manager windows on the screen. For more information about using the spatial mode, see “Spatial Mode” on page 70.

### Spatial Mode

This section describes how to browse the file system using the file manager when configured in spatial mode. In spatial mode, which is the default, each window corresponds to a single folder.

### Spatial Mode Windows

A new spatial mode window opens each time you open a folder. To open a folder, perform one of the following actions:

- Double-click the folder's icon on the desktop or an existing window.
- Select the folder, and press **Ctrl+O**.
- Select the folder, and press **Alt+down arrow**.
- Choose an item from the Places menu on the top panel. The Home folder and bookmarked folders are listed here. For more information about bookmarks, see “Using Bookmarks” on page 95.
To close the current folder while opening a new one, hold down \textbf{Shift} when double-clicking, or press \textbf{Shift+Alt+down arrow}.

The following figure shows a sample spatial mode window that displays the contents of the main Computer folder.

\textbf{FIGURE 8-1}  \hspace{1em} Spatial Mode Window

In spatial mode, each open window displays only one location. Selecting a second location opens a second window. Because each location remembers the previous position on the screen in which it was opened, you can recognize the folder when many folders are open at once.

The following figure shows an example of spatial browsing with many open locations.
FIGURE 8-2  Browsing Spatial Windows

Note - Because spatial mode fills the screen with the file manager windows, being able to reposition them easily is important. You can press and hold the Alt key and click anywhere within the bounds of a window to reposition it instead of having to locate and drag it by its titlebar.

The following table describes the components of a spatial window.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menubar</td>
<td>Contains menus that you use to perform tasks in the file manager.</td>
</tr>
</tbody>
</table>
You can also open a pop-up menu from a file manager window by right-clicking the window. The items in this menu depend on where you right-click. For example, when you right-click a file or folder, you can choose items related to the file or folder. When you right-click the background of a view pane, you can choose items related to the displayed items in the view pane.

### View pane
Displays the contents of the following:
- Folders
- FTP sites
- Windows shares
- WebDAV servers
- Locations that correspond to special URIs

### Statusbar
Displays the status information such as number of items in a folder and amount of free space on disk.

### Parent folder selector
Located in statusbar. Displays the hierarchy of the folder. Choose a folder from the list to open it.

**Note** - Press and hold **Shift** while choosing from the list to close the current folder as you open a new one.

---

## Displaying the Home Folder in a Spatial Window

To display the Home folder, perform one of the following actions:

- Click the Home launcher icon on the top panel.
- From a folder window's menubar, choose Places → Home Folder.
- From the top panel menubar, choose Places → Home Folder.

The spatial window displays the contents of the Home folder.

## Displaying a Parent Folder

A parent folder is the folder that contains the current folder. To display the contents of the current folder's parent, perform one of the following actions:

- Choose File → Open Parent.
- Press **Alt+Up arrow**.
- Choose from the parent folder selector at the bottom left of the window.

## Displaying a Folder in a Browser Window

You can display a single folder in browser mode while continuing to work in spatial mode.
How to Display a Folder in a Browser Window

1. Select a folder while working in spatial mode.
2. Choose File → Browse Folder.

Closing Folders

Clicking the Close button to close folders might not be the most efficient way to close many windows. If you would like to view only the current folder and not the folders you opened to reach the current folder, choose File → Close Parent Folders. If you want to close all folders on the screen, choose File → Close All Folders.

Opening a Location

You can open a folder or other location in spatial mode by typing its name.

Choose File → Open Location, and type the path or URI of the location that you want to open.

Browser Mode

This section describes how to browse the system using the file manager, when configured in browser mode. In browser mode, opening a folder updates the current file manager window to display the contents of the new folder.

Browser Windows

You can access the file browser in the following ways:

- Choose Applications → System Tools → File Browser.
- In spatial mode, you open a folder in browser mode by right-clicking that folder and choosing Browse Folder. A new file browser window opens and displays the contents of the selected folder.
- If the file manager is set to always open browser windows, double-clicking any folder will open a browser window. See “Behavior” on page 106.
The following table describes the components of a file browser window.

**TABLE 8-2  File Browser Window Components**

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Menubar</strong></td>
<td>Contains menus that you use to perform tasks in the file manager. You can also open a pop-up menu from a file manager window by right-clicking the window. The items in this menu depend on where you right-click. For example, when you right-click a file or folder, you can choose items related to the file or folder. When you right-click the background of a view pane, you can choose items related to the displayed items in the view pane.</td>
</tr>
<tr>
<td><strong>Toolbar</strong></td>
<td>Contains buttons that you use to perform various tasks in the file manager.</td>
</tr>
<tr>
<td></td>
<td>• Back – Returns to the previously visited location. The adjacent drop-down list also contains a list of the most recently visited locations to enable you to return to them faster.</td>
</tr>
<tr>
<td></td>
<td>• Forward – Performs the opposite function to the Back toolbar button. If you have previously navigated back, then this button returns you forward.</td>
</tr>
<tr>
<td></td>
<td>• Up – Moves up one level to the parent of the current folder.</td>
</tr>
<tr>
<td></td>
<td>• Reload – Refreshes the contents of the current folder.</td>
</tr>
<tr>
<td></td>
<td>• Browse Snapshots – Enables you to browse the contents of ZFS snapshots that exist for a folder using Time Slider. For more information on Time Slider, see Chapter 7, “Using Time Slider”.</td>
</tr>
</tbody>
</table>
How to Display a Folder in a Browser Window

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
</table>
| Location bar   | The location bar enables you to navigate the computer. It has three different configurations depending on the selection. For more information, see “Using the Location Bar” on page 77. In all three configurations, the location bar contains the following items:  
  - Zoom buttons – Enables you to change the size of items in the view pane.  
  - View as drop-down list – Enables you to choose how to display the items in your view pane. |
| Side Pane      | The side pane performs the following functions:  
  - Shows information about the current file or folder  
  - Enables you to navigate through the files  

To display the side pane, choose View → Side Pane. The side pane contains a drop-down list that enables you to choose the items to be displayed in the side pane:  
  - Places – Displays places of particular interest.  
  - Information – Displays the icon and information about the current folder. Buttons might appear in the side pane. These buttons enable you to perform actions on the current folder other than the default action.  
  - Tree – Displays a hierarchical representation of the file system. You can use the Tree to navigate through the files.  
  - History – Contains a history list of files, folders, FTP sites, and URIs that you recently visited.  
  - Notes – Enables you to add notes to your files and folders.  
  - Emblems – Contains emblems that you can add to a file or folder.  

To close the side pane, click the X button at the top right of the side pane. |
| View pane      | The view pane displays the contents of the following:  
  - Folders  
  - FTP sites  
  - Windows shares  
  - WebDAV servers  
  - Locations that correspond to special URIs |
| Statusbar      | Displays the status information. |

**Showing and Hiding File Browser Window Components**

To show or hide any of the components of the file browser select the component from the view menu. The menu options are toggles that can alternately show or hide the component.
Tip - You can press F9 to toggle the visibility of the side pane.

Using the Location Bar

The file browser's location bar can show either a location field, a button bar, or a search field. The following table describes the fields in the Location bar.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button bar</td>
<td>The button bar is displayed by default. It contains a row of buttons representing the current location's hierarchy, with a button for each folder. Click the button to switch between folders in the hierarchy. You can return to the original folder, which is shown as the last button in the row. You can also drag buttons, for example, to another location, to copy a folder.</td>
</tr>
<tr>
<td>Text location bar</td>
<td>The text location bar shows the current location as a text path, for example, /home/user/Documents. The location field is useful to navigate to a known folder. To go to a new location, type a new path or edit the current one, and then press Return. The path field automatically completes what you are typing when there is only one possibility. To accept the suggested completion, press Tab. To always use the text location bar, click the toggle button at the left of the location bar. To switch to the text location bar while using the button bar, press Ctrl+L, choose Go → Location, or press / (Leading Slash) to type a path from the root directory. The location bar shows the location buttons again after you press Return or press Esc to cancel.</td>
</tr>
<tr>
<td>Search bar</td>
<td>Press Ctrl+F or select the Search toolbar button to display the search bar. For more information about the search bar, see &quot;Searching Files&quot; on page 81.</td>
</tr>
</tbody>
</table>

Displaying Home Folder

To display the Home folder, perform one of the following actions from a file browser window:

- Choose Go → Home
- Click the Home toolbar button
- Click the Home button in the Places side pane

The file browser window displays the contents of your Home folder.
Displaying a Folder

The contents of a folder can be displayed in either list or icon view in any one of the following ways. For more information about the list and icon view, see “Using Views to Display Files and Folders” on page 83.

- Double-click the folder in the view pane.
- Use the Tree in the side pane. For more information, see “Using the Tree From the Side Pane” on page 78.
- Click the Location buttons in the location bar.
- Press Ctrl+L to show the text Location field. Type the path of the folder that you want to display, and then press Return. The Location field includes an autocomplete feature. As you type a path, the file manager reads the file system. When you type enough characters to identify a directory, the file manager completes the name of the directory in the Location field.
- Use the Back and Forward buttons in the toolbar to browse through the navigation history.

To change to the folder that is one level above the current folder, choose Go → Up. Alternatively, click the Up toolbar button.

Displaying a Parent Folder

The parent folder of the current folder which you are browsing is the one which exists, in a hierarchical representation, one level above the current folder. To display the contents of parent folder, perform one of the following steps:

- Press the Up button on the toolbar.
- Choose Go → Open Parent from the menubar.
- Press the Backspace key.

Using the Tree From the Side Pane

The Tree view is one of the most useful features of the side pane. It displays a hierarchical representation of the file system and provides a convenient way to browse and to navigate the file system. To display the Tree in the side pane, choose Tree from the drop-down list at the top of the side pane.

In the Tree view, open folders are represented by arrows facing downwards. The following table describes the tasks you can perform with the Tree.
### TABLE 8-4  
Tree Tasks

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open the Tree</td>
<td>Choose Tree from the drop-down list at the top of the side pane.</td>
</tr>
<tr>
<td>Close the Tree</td>
<td>Choose another item from the drop-down list at the top of the side pane.</td>
</tr>
<tr>
<td>Expand a folder in the Tree</td>
<td>Click the arrow next to the folder in the Tree.</td>
</tr>
<tr>
<td>Collapse a folder in the Tree</td>
<td>Click the arrow next to the folder in the Tree.</td>
</tr>
<tr>
<td>Display the contents of a folder in the view pane</td>
<td>Select the folder in the Tree.</td>
</tr>
<tr>
<td>Open a file</td>
<td>Select the file in the Tree.</td>
</tr>
</tbody>
</table>

You can set the preferences so that the Tree does not display files. For more information, see “Views” on page 105.

### Using Navigation History

The file browser window maintains a history list of files, folders, FTP sites, and URI locations you have recently visited. You can use the history list to return to these places. Your history list contains the last ten items that you viewed.

To clear your history list, choose Go → Clear History.

### Navigating History List Using the Go Menu

To display a list of previously viewed items, open the Go menu. The history list is displayed in the lower part of the Go menu. Click an item in the history list to open it.

### Navigating History List Using the Toolbar

To use the toolbar to navigate the history list, perform one of the following actions:

- Click the Back or Forward toolbar button to open a folder or URI in the history list.
- Click the down arrow to the right of the Back toolbar button to display a list of previously viewed items.
- Click the down arrow to the right of the Forward toolbar button to display a list of items that you viewed after you viewed the current item.
Navigating Your History List Using History in the Side Pane

To display the History list in the side pane, choose History from the drop-down list at the top of the side pane. The History list in the side pane displays a list of the previously viewed items. To display an item from the history list in the view pane, double-click the item in the History list.

Opening Files

When you open a file, the file manager performs the default action for that file type.

For example, opening a music file will play it with the default music playing application, opening a text file will enable you to read and edit it in a text editor, and opening an image file will display the image.

The file manager checks the contents of a file to determine the type of a file. If the first lines do not determine the type of the file, then the file manager checks the file extension.

Note - If you open an executable text file, that is, one that the file manager considers can be run as a program, then you will be asked whether you want to run it or display it in a text editor. You can modify this behavior in the File Management preferences.

Executing the Default Action

To execute the default action for a file, double-click the file. For example, the default action for plain text documents is to display the file in a text viewer. If you double-click a text file, the file will be displayed in a text viewer.

You can set your file manager preferences so that you click once on a file to execute the default action. For more information, see “Behavior” on page 106.

Executing Non-Default Actions

To execute actions other than the default action for a file, select the file on which you want to perform an action. The File menu shows Open With choices or an Open With submenu. Select the desired option from this list.
How to Add Actions Associated With a File Type

1. In the view pane, select a file for which you want to add an action.
2. Choose File → Open with Other Application.
3. Either choose an application in the Open With dialog or browse to the program with which you want to open this file type.

The action you chose is added to the list of actions for that particular file type. If no prior action was associated with the file type, the newly added action is the default.

Tip - You can also add actions in the Open With tab under File → Properties.

How to Modify Actions

1. In the view pane, select a file for which you want to modify the action.
2. Choose File → Properties.
3. Click the Open With tab.
4. Use the Add or Remove buttons to tailor the list of actions. Select the default action with the option to the left of the list.

Searching Files

In the file manager to begin a search, press Ctrl+F or select the Search toolbar button. The search bar should appear, as shown in the following figure.

FIGURE 8-4  Search Bar

Type characters that are present in the name or contents of the file or folder you want to find and press Return.
You can refine the search results by adding additional conditions to restrict the search to a specific file type or location. To add search conditions, click the + icon.

**Saving Searches**

Searches can also be saved for future use. Once saved, searches can be reopened later. Saved searches behave exactly like regular folders, for example, you can open, move, or delete files from within a saved search.

**Managing Files and Folders**

This section describes how to work with your files and folders.

File systems are organized in a hierarchical, tree-like structure. The highest level of the file system is the / or root directory. In this design philosophy, everything is considered a file, including hard disks, partitions, and removable media. All files and directories (including other disks and partitions) exist under the root directory.

For example, `/home/jebediah/cheeses.odt` shows the correct full path to the `cheeses.odt` file that exists in the jebediah directory that is under the home directory, which, in turn, is under the root (/) directory.

Underneath the root (/) directory, is a set of important system directories that are commonly used. The following list describes common directories that are directly under the root (/) directory:

- `/etc` – Configuration files, startup scripts, and so on
- `/home` – Local users’ home directories
- `/bin` – Important binary applications
- `/boot` – Files that are required to boot the computer
- `/dev` – The device files
- `/lib` – System libraries
- `/lost+found` – Provides a lost and found system for files that exist under the root (/) directory
- `/opt` – Provides a location for optional applications to be installed
- `/proc` – Special dynamic directory that maintains information about the state of the system, including currently running processes
- `/media` – Mounted (loaded) removable media such as CDs, digital cameras, and so on
- `/mnt` – Mounted file systems
Managing Files and Folders

Chapter 8 • Using the File Manager

- /root – Root user home directory, pronounced “slash-root”
- /sbin – Important system binaries
- /srv – Provides a location for data used by servers
- /sys – Contains information about the system
- /tmp – Temporary files
- /usr – Applications and files that are mostly available for all users to access
- /var – Variable files such as logs and databases

Using Views to Display Files and Folders

The file manager includes views that enable you to show the contents of your folders in different ways: icon view and list view.

- Icon view — The following illustration shows the items in the folder as icons.

- List view — The following illustration shows the items in the folder as a list.
Use the View menu or the View As drop-down list to choose between icon or list view. You can specify how you want to arrange or sort items in the folder and modify the size of the items in the view pane. The following sections describe how to work with icon view and list view.

### Arranging Your Files in Icon View

When you display the contents of a folder in icon view, you can specify how to arrange the items in the folder. To specify how to arrange items in icon view, choose View → Arrange Items. The Arrange Items submenu is organized as follows:

- The top section contains options that enable you to arrange the files manually.
- The middle section contains options that enable you to sort your files automatically.
- The bottom section contains options that enable you to modify how your files are arranged.

The following table describes the appropriate options that you can choose from the submenu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manually</td>
<td>Arranges the items manually. Drag the items to the desired location within the view pane.</td>
</tr>
<tr>
<td>By Name</td>
<td>Sorts the items by name in alphabetical order. The order of the items is not case sensitive. If the file manager is set to display hidden files, the hidden files are shown last.</td>
</tr>
</tbody>
</table>
### Arranging Your Files in List View

When you display the contents of a folder in list view, you can specify how to arrange the items in the folder. To specify how to arrange items in list view, click the header of the column specifying the property by which you wish to arrange the items. To reverse the sorting order, click the same column header again.

To add or remove columns from the list view, choose View → Visible Columns.

The file manager remembers how you arrange the items in a particular folder. The next time that you display the folder, the items are arranged in the way that you selected. When you specify how to arrange the items in a folder, you can customize the folder to display the items in that way. To return the arrangement settings of the folder to the default arrangement settings specified in the preferences, choose View → Reset View to Defaults.

### Changing the Size of Items in a View

You can change the size of the items in a view displaying a file or a folder in the following ways:

- To enlarge the size of items in a view, choose View → Zoom In.
- To reduce the size of items in a view, choose View → Zoom Out.
- To return items in a view to the normal size, choose View → Normal Size.

You can also use the zoom buttons on the location bar in a browser window to change the size of items in a view.
The following table describes the zoom buttons.

<table>
<thead>
<tr>
<th>TABLE 8-5</th>
<th>Zoom Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Button</strong></td>
<td><strong>Button Name</strong></td>
</tr>
<tr>
<td>![Zoom Out]</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>![100%]</td>
<td>Normal Size</td>
</tr>
<tr>
<td>![Zoom In]</td>
<td>Zoom In</td>
</tr>
</tbody>
</table>

The file manager remembers the size of items in a particular folder. The next time you display the folder, the items are displayed in the size that you selected. When you change the size of items in a folder, you can customize the folder to display the items at that size. To return the size of the items to the default size specified in the preferences, choose View → Reset View to Defaults.

**Working With Files and Folders**

You can select files and folders in several ways in the file manager. You can also select a group of files matching a specific pattern.

**Selecting Files and Folders**

The following table describes the tasks that you can perform in the file manager.

<table>
<thead>
<tr>
<th>TABLE 8-6</th>
<th>Selecting Items in the File Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Task</strong></td>
<td><strong>Action</strong></td>
</tr>
<tr>
<td>Select an item</td>
<td>Click the item.</td>
</tr>
<tr>
<td>Select a group of contiguous items</td>
<td>In icon view, click and then drag around the files that you want to select.</td>
</tr>
<tr>
<td></td>
<td>In list view, click the first item in the group. Press and hold <strong>Shift</strong>, and then click the last item in the group.</td>
</tr>
<tr>
<td>Select multiple items</td>
<td>Press and hold <strong>Ctrl</strong>. Click the items that you want to select.</td>
</tr>
<tr>
<td>Select all items in a folder</td>
<td>Choose Edit → Select All Files.</td>
</tr>
</tbody>
</table>
To perform the default action on an item, double-click the item. You can set your file manager preferences so that you click once on a file to execute the default action. For more information, see “Behavior” on page 106.

Selecting Files Matching a Specific Pattern

You can select all files matching a pattern based upon their file name and an optional number of wildcards. The following table shows some examples of possible patterns and the resulting files they would match.

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Files Matched</th>
</tr>
</thead>
<tbody>
<tr>
<td>note.*</td>
<td>This pattern would match files called note, with any extension.</td>
</tr>
<tr>
<td>*.ogg</td>
<td>This pattern would match all files with the .ogg extension</td>
</tr>
<tr>
<td><em>memo</em></td>
<td>This pattern would match all files or folders whose name contains the word memo.</td>
</tr>
</tbody>
</table>

To perform the Select Pattern command choose Edit → Select Patterns from the menu. After entering the desired pattern you are left with those files or folders which matched the pattern selected.

Moving or Copying a File or Folder

You can move or copy a file or folder by dragging it with the mouse or by using the cut or copy and paste commands. The following procedures describe how to move or copy a file or folder.

\[\textbf{How to Drag a File to Copy or Move It to a New Location}\]

**Tip** - To move a file or folder to a folder that is one level below the current location, drag the file or folder to the new location in the same window. If you are copying the file or folder, press Control while dragging.

1. **Open two file manager windows:**
   - The window containing the item you want to move or copy
   - The window you want to move or copy the file or folder to, or the window containing the folder you want to move or copy it to
2. Drag the file or folder you want to move or copy to the new location. If you are copying the file or folder, press Control while dragging.

- If the new location is a window, drop it anywhere on the window.
- If the new location is a folder, drop the item you are dragging on the folder icon.

▼ How to Cut or Copy and Paste to the New Location

1. Select the file or folder that you want to move or copy, then choose Edit → Cut or Edit → Copy.
2. Open the folder to which you want to move or copy the file or folder.
3. Choose Edit → Paste.

▼ How to Duplicate a File or Folder

1. Select the file or folder that you want to duplicate.
2. Choose Edit → Duplicate.
   A copy of the file or folder appears in the current folder.

▼ How to Create a Folder

1. Open the folder where you want to create the new folder.
2. Choose File → Create Folder or right-click the background of the window, then choose Create Folder.
   An untitled folder is added to the location. The name of the folder is selected.
3. Type a name for the folder, and then press Return.

▼ How to Rename a File or Folder

1. Select the file or folder that you want to rename.
2. **Choose Edit → Rename or right-click the file or folder, then choose Rename.**
   The name of the file or folder is selected.

3. **Type a new name for the file or folder, then press Return.**

### How to Move a File or Folder to the Trash

1. **Select the file or folder that you want to move to the Trash.**

2. **Choose Edit → Move to Trash or right-click the file or folder, then choose Move to Trash.**

   **Note** - When you move a file or folder from removable media to the Trash, the file or folder is stored in a Trash location on the removable media. To remove the file or folder permanently from the removable media, you must empty the Trash.

### How to Delete a File or Folder

When you delete a file or folder, the file or folder is not moved to the Trash. It is deleted from your file system. The Delete menu item is only available if you select the Include a Delete command that bypasses the Trash option in the File Management Preferences dialog.

1. **Select the file or folder that you want to delete.**

2. **Use one of the following methods to delete the file or folder.**

   - **Choose Edit → Delete.**
   - **Right-click the file or folder, and then choose Delete.**
   - **Press Shift+Del.**

   **Note** - This shortcut is independent from the Include a Delete command that bypasses the Trash option.
Creating a Symbolic Link to a File or Folder

A symbolic link is a special type of file that points to another file or folder. When you perform an action on a symbolic link, the action is performed on the file or folder to which the symbolic link points. However, when you delete a symbolic link, you delete the link file, not the file to which the symbolic link points.

How to Create a Symbolic Link to a File or Folder

- Select the file or folder to which you want to create a link.
  - Choose Edit → Make Link.
    A link to the file or folder is added to the current folder.
  - Use drag and drop to create the link.
    a. Press and hold Ctrl+Shift.
    b. Drag the item to the location where you want to place the link.
      By default, the file manager adds an emblem to symbolic links.

Note - The permissions of a symbolic link are determined by the file or folder to which a symbolic link points.

Using Drag and Drop

You can use drag-and-drop to perform several tasks in the file manager. When you drag-and-drop, the mouse pointer provides feedback about the task that you perform. The following table describes the tasks that you can perform with drag and drop. The following table describes the mouse pointers that appear when you drag and drop.

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move an item</td>
<td>Drag the item to the new location.</td>
</tr>
<tr>
<td>Copy an item</td>
<td>Grab the item, then press and hold Ctrl. Drag the item to the location where you want the copy to reside.</td>
</tr>
</tbody>
</table>
How to View the Properties of a File or Folder

The following table lists the properties that you can view or set for files and folders. The exact information shown depends on the object type.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the file or folder. If you change the name here, the file or folder will be renamed when you click Close.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of object, for example, file or folder.</td>
</tr>
<tr>
<td>Location</td>
<td>The system path for the object. This represents where the object is situated on your computer relative to the system root.</td>
</tr>
<tr>
<td>Volume</td>
<td>The volume on which a folder resides. This is the physical location of the folder, for example, hard disk or CD-ROM drive.</td>
</tr>
<tr>
<td>Free space</td>
<td>The amount of free space on the media upon which a folder resides. This value represents the maximum amount of data you can copy to this folder.</td>
</tr>
<tr>
<td>MIME Type</td>
<td>The official naming of the type of file.</td>
</tr>
<tr>
<td>Modified</td>
<td>The date and time at which the object was last changed.</td>
</tr>
<tr>
<td>Accessed</td>
<td>The date and time at which the object was last viewed.</td>
</tr>
</tbody>
</table>

How to View the Properties of a File or Folder

1. Select the file or folder whose properties you want to view.
2. **Choose File → Properties.**
   A Properties dialog is displayed showing the properties of the file or folder.

3. **Click Close to close the Properties dialog.**

### Changing Permissions

Permissions are settings assigned to each file and folder that determine what type of access users can have to the file or folder. For example, you can determine whether other users can read and edit a file that belongs to you, or have access only to read it but not make changes to it.

Each file belongs to a particular user, and is associated with a group that the owner belongs to. The superuser root has the ability to access any file on the system.

You can set permissions for three categories of users:

- **Owner** – The user that created the file or folder
- **Group** – A group of users to which the owner belongs
- **Others** – All other users not already included

For each category of user, different permissions can be set. These permission levels behave differently for files and folders, as follows:

- **Read** – Files can be opened, and directory contents can be displayed.
- **Write** – Files can be edited or deleted, and directory contents can be modified.
- **Execute** – Executable files can be run as a program, and directories can be entered.

#### ▼ How to Change Permissions for a File

1. **Select the file that you want to change.**

2. **Choose File → Properties.**
   The properties window for the item is displayed.

3. **Click the Permissions tab.**

4. **To change the file's group, choose from the groups the user belongs to from the drop-down list.**

5. **For each of the owner, the group, and all other users, choose from these permissions for the file:**
How to Change Permissions for a Folder

1. Select the folder that you want to change.

2. Choose File → Properties.
   The properties window for the item is displayed.

3. Click the Permissions tab.

4. To change the folder’s group, choose from the groups the user belongs to from the drop-down selector.

5. For each of the owner, the group, and all other users, choose from these folder access permissions:
   - None – No access to the folder is possible. (You cannot set this for the owner.)
   - List files only – The user can see the items in the folder but cannot open any of them.
   - Access files – Items in the folder can be opened and modified, provided their own permissions allow these actions.
   - Create and delete files – The user can create new files and delete files in the folder, in addition to being able to access existing files.

Note - To set permissions for all the items contained in a folder, set the File Access and Execute properties and click Apply Permissions to Enclosed Files.

Adding Notes to Files and Folders

You can add notes to files or folders in the following ways:

- From the Properties dialog
- From Notes in the side pane
How to Add a Note Using the Properties Dialog

1. Select the file or folder for which you want to add a note.
2. Choose File → Properties.
   The Properties window for the item is displayed.
3. Click the Notes tab.
4. In the Notes tab, type the note.
5. Click Close to close the Properties dialog.
   A note emblem is added to the file or folder.

Note - You can delete the note text from the Notes tab.

How to Add a Note Using Notes in the Side Pane

1. Open the file or folder for which you want to add a note in the view pane.
2. Choose View → Side Pane to display the side pane.
3. Choose Notes from the drop-down list at the top of the side pane.
4. Type the note in the side pane.
   A note emblem is added to the file or folder in the view pane, and a note icon is added to the side pane. You can click this icon to display the note.

Note - You can delete the note text from the Notes tab.

Creating Documents by Using a Template

You can create templates from documents that you frequently create. For example, if you often create invoices, you can create an empty invoice document and save the document as invoice.doc in the $HOME/Templates folder.
To access the templates folder from a file browser window, choose Go → Templates. The template name is displayed as a submenu item in the Create Document menu.

You can also create subfolders in the template folder. Subfolders display as submenus in the menu. You can also share templates. Create a symbolic link from the template folder to the folder containing the shared templates.

**How to Create a Document From a Template**

1. **Select the folder where you want to create the new document.**

2. **Choose File → Create Document or right-click the background of the view pane, then choose Create Document.**
   The names of any available templates are displayed as submenu items from the Create Document menu.

3. **Double-click the template name for the document that you want to create.**

4. **Rename the document before saving it to the appropriate folder.**

**Using Bookmarks**

You can manage a list of bookmarks for folders and other locations that you frequently open.

The bookmarks are listed in the following places:

- Places menu on the top panel
- Places menu in a folder window
- Bookmarks menu in the file manager browser window
- Side pane in the Open File dialog, which enables you to quickly open a file that is in one of your bookmarked locations
- List of commonly used locations in the Save File dialog, which enables you to quickly save a file to a location you have in your bookmarks

To open an item that is in your bookmarks, choose the item from a menu.

**Adding or Deleting a Bookmark**

To add a bookmark, open the folder or location that you want to bookmark, then choose Places → Add Bookmark.
If you are using the file manager browser window, choose Bookmarks → Add Bookmark.

To delete a bookmark, select the bookmark on the left side of the dialog, choose Places Edit → Bookmarks, and then click Delete.

How to Edit a Bookmark


2. Select the bookmark on the left side of the Edit Bookmarks dialog.

3. Edit the details for the bookmark as follows:
   - Name – Use this text box to specify the name that identifies the bookmark in the menus.
   - Location – Use this field to specify the location of the bookmark. Folders on the system use the file:/// URI.

Using Trash

Trash is a special folder that holds files that you no longer want to keep. Files in the Trash are not deleted permanently until you empty the Trash.

You can move the following items to the Trash:

- Files
- Folders
- Desktop objects

If you need to retrieve a file from the Trash, move it out of the Trash. When you empty the Trash, the contents are deleted permanently.
Displaying the Items in the Trash

- From a file browser window, choose Go → Trash. The contents of the Trash are displayed in the window.
- From a spatial window, choose Places → Trash. The contents of the Trash are displayed in the window.
- From the desktop, click the Trash applet on the bottom panel.

Emptying Trash

- From a file browser window, choose File → Empty Trash.
- On the bottom panel of the desktop, right-click the Trash icon, and then choose Empty Trash.

Note - When you empty the Trash, you destroy all files in the Trash. Be sure that the Trash only contains files you no longer need.

Time Slider can help you recover files that you have deleted accidentally. For more information on Time Slider, see Chapter 7, “Using Time Slider”.

Viewing Hidden Files

By default, the file manager does not display certain system and backup files in folders. This practice prevents accidental modification or deletion of them, which can impair the operation of the computer, and also reduces clutter in locations such as your Home folder. The file manager does not display:

- Hidden files, whose file name begins with a period (.)
- Backup files, whose file name ends with a tilde (~)
- Files that are listed in a particular folder’s .hidden file

To hide or show hidden files in a particular folder, select View → Show Hidden Files. To set the file manager to always show hidden files, set the Views preference to Show Hidden and Backup Files. For more information, see “Setting File Manager Preferences” on page 105.

Hiding a File or Folder

To hide a file or folder in the file manager, either rename the file so its name begins with the period (.) character, or create a text file named .hidden in the same folder and add its name to it.
To refresh the relevant file manager window to see the change, press Ctrl+R.

Using Item Properties

The Item Properties window shows information about any file, folder, or other item in the file manager. With this window, you can also do the following:

- Change the icon for an item. See “How to Change the Icon for a File or Folder” on page 100.
- Add or remove emblems for an item. See “How to Add an Emblem to a File or Folder” on page 100.
- Change the UNIX file permissions for an item. See “Changing Permissions” on page 92.
- Choose which application is used to open an item, and other items of the same type.
- Add notes to an item. See “How to Add a Note Using the Properties Dialog” on page 94.

How to Display the Item Properties Window

1. Select the item whose properties you want to examine or change.
   If you select more than one item, the Properties window shows the properties that are in common to all items.

2. Use one of the following method to display the dialog:
   - Choose File → Properties.
   - Right-click the selected item and choose Properties.
   - Press Alt+Return.

Modifying the Appearance of Files and Folders

You can customize the way files or folders look by attaching emblems or backgrounds to them. You can also change the format in which the file manager displays these items.
Using Icons and Emblems

The file manager displays files and folders as icons. Depending on the type of the file, the icon might be an image representative of the file type, a small thumbnail, or preview showing the file contents.

You can also add emblems to file and folder icons. Such emblems appear in addition to the file icon and provide another way to manage files. For example, you can mark a file as important by adding an Important emblem to it, as shown in the following figure.

**FIGURE 8-6** Icons and Emblems

For more information about adding emblems, see “How to Add an Emblem to a File or Folder” on page 100.

The file manager automatically applies emblems for the following types of files:

- Symbolic links
- Items which have the following permissions:
  - No read permission
  - No write permission

The following table describes the default emblems.

<table>
<thead>
<tr>
<th>Default Emblem</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Symbolic link" /></td>
<td>Symbolic link</td>
</tr>
<tr>
<td><img src="image" alt="No write permission" /></td>
<td>No write permission</td>
</tr>
<tr>
<td><img src="image" alt="No read permission" /></td>
<td>No read permission</td>
</tr>
</tbody>
</table>
How to Change the Icon for a File or Folder

1. Select the file or folder which you want to change.
2. Choose File → Properties.
   The Properties window for the item is displayed.
3. On the Basic tab, click the current Icon.
   A Select custom icon dialog is displayed.
4. Choose the icon to represent the file or folder.
5. Click Close to close the Properties dialog.

Note - To restore an icon from a custom icon to the default icon, select the file or folder which you want to change, and click Revert in the Select custom icon dialog.

How to Add an Emblem to a File or Folder

1. Select the item for which you want to add an emblem.
2. Right-click the item, and then choose Properties.
   The properties window for the item is displayed.
3. Click the Emblems tab to display the Emblems tab.
4. Select the emblem to add to the item.
5. Click Close to close the properties dialog.

Tip - In browser windows, you can also add emblems to items by dragging them from the emblem side pane.

How to Create a New Emblem

1. Choose Edit → Backgrounds and Emblems.
2. Click Emblem, and then click Add a New Emblem.
   The Create a New Emblem dialog is displayed.

3. Type a name for the emblem in the Keyword text box.

4. Click Image.
   In the dialog that is displayed, click Browse.

5. Choose an emblem, and click OK.

6. Click OK.

Changing Backgrounds
The file manager includes background patterns and emblems which you can use to change the appearance of your folders. Background patterns and emblems can also be used on the desktop, for folders, and for certain side panes in the file browser and on panels.

▾ How to Change the Background of a Window, Pane, or Panel
1. Choose Edit → Backgrounds and Emblems in any file manager window.
   The Backgrounds and Emblems dialog is displayed.

2. Click the Patterns button or the Colors button.
   A list of background patterns or background colors is displayed.

3. (Optional) Add a new pattern or color to the list.
   ■ To add a new pattern:
     a. Click the Add a New Pattern button.
     
     b. Locate an image file in the file chooser dialog and click Open.
        The image appears in the list of patterns you can use.
   ■ To add a new color to the list:
     a. Click the Add a New Color button.
     
     b. Select a color from the color chooser dialog and click OK.
The color appears in the list of colors you can use.

4. To change the background, drag a pattern or color to the desired window, pane, or panel. To reset the background, drag the Reset entry to the desired window, pane, or panel.

Using Removable Media

The file manager can initiate various actions when removable media appears, such as mounting it, opening a file manager window to view its contents, or running a suitable application that can handle it (for example, a music player for an audio CD). See “Media” on page 110 on how to configure these actions for different media formats.

Mounting Media

To mount media is to make the file system of the media available for access. When you mount media, the file system of the media is attached as a subdirectory to your file system.

To mount media, insert the media in the appropriate device. An icon that represents the media is added to the desktop. The icon is added only if your system is configured to mount the device automatically when the media is detected.

If your system is not configured to mount the device automatically, you must mount the device manually.

How to Mount a Device Manually

1. Choose Places → Computer from the top panel menubar.
   The Computer dialog is displayed.

2. Double-click the icon that represents the media. For example, to mount a CD-ROM, double-click the CD-ROM icon.
   An icon that represents the media is added to the desktop.

Note - You cannot change the name of a removable media icon.
Displaying Media Contents

You can display media contents in any of the following ways:

- Double-click the icon that represents the media on the desktop.
- Right-click the icon that represents the media on the desktop, and then choose Open.

A file manager window displays the contents of the media. To reload the display, click Reload.

Displaying Media Properties

To display the properties of removable media, right-click the icon that represents the media on the desktop, and then choose Properties. A dialog displays the properties of the media.

To close the properties dialog, click Close.

Ejecting Media

To eject media, right-click the media icon on the desktop, and then choose Eject. If the drive for the media is a motorized drive, the media is ejected from the drive. If the drive for the media is not motorized, wait until the desktop icon for the media disappears, and then eject the media manually.

Note - You cannot eject media from a motorized drive when the media is mounted.

How to Eject a USB Flash Drive

You must unmount removable media before ejecting. Do not remove a USB flash drive before you unmount the flash drive. If you do not unmount the media first, you might lose data.

1. Close all file manager windows, terminal windows, and any other windows that access the USB drive.
2. Right-click the icon that represents the drive on the desktop, and then choose Eject.
   The desktop icon for the drive disappears from the display.
3. Remove the USB flash drive.
Navigating Remote Servers

The file manager provides an integrated access point to files, applications, FTP sites, Windows shares, WebDav servers, and SSH servers.

Accessing a Remote Server

You can use the file manager to access a remote server, regardless of whether it is an FTP site, a Windows share, a WebDav server, or an SSH server.

To access a remote server, choose File → Connect to Server. You can also access this dialog from the menubar by choosing Places → Connect to Server.

To connect to a remote server, start by choosing the service type, then type the server address. If required, you can provide the following optional information.

<table>
<thead>
<tr>
<th>Port</th>
<th>Port to connect to on the server. This setting must be used if you are not using the default port. You would normally leave this blank.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder</td>
<td>Folder to open upon connecting to a server.</td>
</tr>
<tr>
<td>User Name</td>
<td>The user name of the account used to connect to the server. This value is supplied with the connection information. The user name information is not appropriate for a public FTP connection.</td>
</tr>
<tr>
<td>Name to use for connection</td>
<td>The designation of the connection as it will appear in the file manager.</td>
</tr>
<tr>
<td>Share</td>
<td>Name of the desired Windows share. This setting is only applicable to Windows shares.</td>
</tr>
<tr>
<td>Domain name</td>
<td>Windows domain. This setting is only applicable to Windows shares.</td>
</tr>
</tbody>
</table>

If the server information is provided in the form of a URI, or if you require a specialized connection, choose Custom Location as the service type.

Once you have filled in the information, click Connect. On successful connection, the contents of the site are displayed and you can drag and drop files to and from the remote server.

Accessing Network Places

If your system is configured to access places on a network, you can use the file manager to access network places.

To access network places, open File Manager and choose Places → Network, or choose Go → Network in a browser window. The accessible networks are displayed in a window. Double-click the network that you want to access.
To access UNIX shares, double-click the Unix Network (NFS) object. A list of the UNIX shares available is displayed in the File Manager window.

To access Windows shares, double-click the Windows Network (SMB) object. A list of the Windows shares available is displayed in the File Manager window.

**Accessing Special URI Locations**

The file manager has certain special URI locations that enable you to access particular functions from the file manager. These locations are intended for advanced users. In most cases, an easier method of accessing the function or location exists.

You can use the special URI location, `network:///`, with the file manager to display network locations to which you can connect if your system is configured to access locations on a network. To access a network location, double-click the network location. You can also use this URI to add network locations to your system. See also “Accessing Network Places” on page 104.

**Setting File Manager Preferences**

Use the File Management Preferences dialog to customize the file manager.

To display the File Management Preferences dialog, choose Edit → Preferences. You can also access this dialog directly from the top panel menubar by choosing System → Preferences → File Management.

You can set preferences in the following categories:

- Default settings for views
- Behavior of files and folders, executable text files, and Trash
- Information that is displayed in icon captions and the date format
- Columns that appear in the list view and their order
- Preview options to improve the performance of the file manager
- How removable media and connected devices are handled

**Views**

You can specify a default view, and select sort options and display options. You can also specify default settings for icon views and list views.
To specify your default view settings, choose Edit → Preferences. Click the Views tab. The following table lists the Views preferences that you can modify.

**TABLE 8-9  Views Preferences**

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View new folders using</td>
<td>Determines the default view for folders. When you open a folder, the folder is displayed in the view that you select: the icon view, the list view, or the compact view, which is a variant of the icon view that is organized in columns rather than rows.</td>
</tr>
<tr>
<td>Arrange items</td>
<td>The characteristic by which you want to sort the items in folders that are displayed in this view.</td>
</tr>
<tr>
<td>Show hidden and backup files</td>
<td>Displays files that are not shown in folders. For more information about hidden files, see “Viewing Hidden Files” on page 97.</td>
</tr>
<tr>
<td>Default zoom level in the Icon View, Compact View, or List View sections</td>
<td>Sets the default zoom level for folders that are displayed in this view. The zoom level specifies the size of items in a view.</td>
</tr>
<tr>
<td>Use compact layout</td>
<td>Arranges the items in icon view so that the items in the folder are closer to each other.</td>
</tr>
<tr>
<td>Text beside icons</td>
<td>Places the icon captions for items beside the icon rather than under the icon.</td>
</tr>
<tr>
<td>All columns have the same width</td>
<td>Ensures that all columns in a compact view have the same width.</td>
</tr>
<tr>
<td>Show only folders</td>
<td>Displays this option to display only folders in the Tree in the side pane.</td>
</tr>
</tbody>
</table>

**Behavior**

To set your preferences for files and folders, choose Edit → Preferences. Click the Behavior tab. You can set the preferences described in the following table.

**TABLE 8-10  Behavior Preferences**

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single click to open items</td>
<td>Performs the default action for an item when you click the item. When this option is selected and you point to an item, the title of the item is underlined.</td>
</tr>
<tr>
<td>Double click to open items</td>
<td>Performs the default action for an item when you double-click the item.</td>
</tr>
<tr>
<td>Open each folder in its own window</td>
<td>Sets the default to spatial mode rather than browser mode. Spatial mode enables you to browse files and</td>
</tr>
</tbody>
</table>
Dialog Element | Description
--- | ---
folders as objects in the ir own window . Otherwise , you must navigate the files and folders as objects in the same window .
Run executable text files when they are opened | Runs a text executable file when you choose the file. An executable text file is a text file that can execute, that is, a shell script.
View executable text files when they are opened | Displays the contents of an executable text file when you choose it.
Ask each time | Displays a dialog when you choose an executable text file. The dialog asks whether you want to execute the file or display the file.
Ask before emptying the Trash or deleting files | Displays a confirmation message before the Trash is emptied, or files are deleted.
Include a Delete command that bypasses Trash | Adds a Delete menu item to the following menus:
  - Edit menu
  - Pop-up menu that is displayed when you right-click a file, folder, or desktop object
When you select an item and then choose Delete, the item is deleted from the file system. You cannot recover a deleted file.

Display

An icon caption displays the name of a file or folder in an icon view. The icon caption also includes three additional items of information on the file or folder. The additional information is displayed after the file name. Normally only one item of information is visible, but when you zoom in on an icon, more of the information is displayed. You can modify what additional information is displayed in icon captions.

To set your preferences for icon captions, choose Edit → Preferences. Click the Display tab.

Select the items of information that you want to display in the icon caption from the three drop-down lists. The following table describes the items of information that you can select.

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Displays no information for the item.</td>
</tr>
<tr>
<td>Size</td>
<td>Displays the size of the item.</td>
</tr>
<tr>
<td>Type</td>
<td>Displays the description of the MIME type of the item.</td>
</tr>
<tr>
<td>Date Modified</td>
<td>Displays the last modification date of the item.</td>
</tr>
</tbody>
</table>
Setting File Manager Preferences

Information | Description
---|---
Date Accessed | Displays the date that the item was last accessed.
Owner | Displays the owner of the item.
Group | Displays the group to which the item belongs.
Permissions | Displays the permissions of the item as three sets of three characters, for example, `-rwxrw-r-`.
Octal Permissions | Displays the permissions of the item in octal notation, for example, 764.
MIME Type | Displays the MIME type of the item.
Location | Displays the full UNIX pathname of the item.
Restore | Indicates whether the item is present on the file system and verifies whether its contents are changed when viewed in a ZFS snapshot by using Time Slider.

The date Format option enables you to choose how the date is displayed throughout the file manager.

**List Columns**

You can specify the information that is displayed in list view in file manager windows. You can specify which columns are displayed in list view, and the order in which the columns are displayed.

To set your preferences for list columns, choose Edit → Preferences. Click the List Columns tab.

To specify a column to display in list view, select the option that corresponds to the column, and then click Show. To remove a column from the list view, select the option that corresponds to the column, and then click Hide.

Use the Move Up and Move Down buttons to specify the position of columns in list view. To use the default columns and column positions, click Use Default.

The following table describes the columns that you can display.

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Displays the name of the item.</td>
</tr>
<tr>
<td>Size</td>
<td>Displays the size of the item.</td>
</tr>
<tr>
<td>Type</td>
<td>Displays the description of the MIME type of the item from the File Types and Programs preference tool.</td>
</tr>
<tr>
<td>Date Modified</td>
<td>Displays the last modification date of the item.</td>
</tr>
</tbody>
</table>
## Setting File Manager Preferences

### Chapter 8 • Using the File Manager

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date Accessed</td>
<td>Displays the date on which the item was last accessed.</td>
</tr>
<tr>
<td>Group</td>
<td>Displays the group to which the item belongs.</td>
</tr>
<tr>
<td>MIME type</td>
<td>Displays the MIME type of the item.</td>
</tr>
<tr>
<td>Octal Permissions</td>
<td>Displays the permissions of the item in octal notation, for example, 764.</td>
</tr>
<tr>
<td>Owner</td>
<td>Displays the owner of the item.</td>
</tr>
<tr>
<td>Permissions</td>
<td>Displays the permissions of the item as three sets of three characters, for example, -rwxrw-r--.</td>
</tr>
<tr>
<td>Restore Information</td>
<td>Indicates whether the item is present on the file system and verifies if its contents are changed when viewed in a ZFS snapshot using Time Slider.</td>
</tr>
</tbody>
</table>

### Preview

The file manager include some file preview features. The preview features can affect the speed with which the file manager responds to requests. You can modify the behavior of some of these features to improve the speed of the file manager. For each preview preference, you can select one of the following options.

- **Always**: Performs the action for both local files, and files on other file systems.
- **Local Files Only**: Performs the action for local files only.
- **Never**: Never performs the action.
- **Visualize ZFS snapshots timeline**: Specifies whether you are able to view previous snapshots of a folder in its File Manager window, using the View → Restore menu item.

To set your preview preferences, choose Edit → Preferences. Click the Preview tab.

The following table lists the preview preferences that you can modify.

<table>
<thead>
<tr>
<th>TABLE 8-11 Preview Preferences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialog Element</td>
</tr>
<tr>
<td>Show text in icons</td>
</tr>
<tr>
<td>Show thumbnails</td>
</tr>
<tr>
<td>Only for files smaller than</td>
</tr>
</tbody>
</table>
Setting File Manager Preferences

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview sound files</td>
<td>Specifies when to preview sound files.</td>
</tr>
<tr>
<td>Count number of items</td>
<td>Specifies when to show the number of items in folders. When in icon view, you might need to increase your zoom level to see the number of items in each folder.</td>
</tr>
</tbody>
</table>

**Media**

You can configure how the file manager handles removable media and devices that are connected to the computer, such as music players or cameras. For each media format or device type, the file manager offers to run one of the applications that are known to support this format, as well as the following options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ask what to do</td>
<td>Asks for the desired action when the media or device appears.</td>
</tr>
<tr>
<td>Do Nothing</td>
<td>Does nothing</td>
</tr>
<tr>
<td>Open Folder</td>
<td>Treats the media or device like an ordinary folder and opens it in a file manager window.</td>
</tr>
<tr>
<td>Open with other Application</td>
<td>Displays the file manager application chooser dialog, so you can select an application to run. Note that applications known to handle the media or device can be chosen directly from the drop-down list.</td>
</tr>
</tbody>
</table>

The most common media formats can be configured in the Media Handling section: audio CDs, video DVDs, music players, cameras, and software CDs.

To configure the handling for other media formats, first select the format in the Type drop-down list, and then select the desired handling for this format in the Action drop-down list.

The following table lists other media handling preferences that you can modify.

**TABLE 8-12 Media Preferences**

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Never prompt or start programs on media insertion</td>
<td>Prevents the file manager from showing dialogs or running programs when media or devices appear. When this option is selected, the preferences for handling of specific media formats are ignored.</td>
</tr>
<tr>
<td>Browse media when inserted</td>
<td>The file manager will automatically open a folder when media is inserted. This setting applies only for media formats for which the handling has not been explicitly configured.</td>
</tr>
</tbody>
</table>
Extending the File Manager

The file manager can be extended in two main ways. Through the file manager extensions and scripts.

Scripts

The file manager can run scripts written in any scripted language capable of being executed on the computer. Scripts are typically simpler in operation than using file manager extensions. To run a script, choose File → Scripts, and then choose the script that you want to run from the submenu.

To run a script on a particular file, select the file in the view pane. Choose File → Scripts, and then choose the script that you want to run on the file from the submenu. You can also select multiple files to run your scripts on. You might also access scripts from the context menu.

Note - If you do not have any scripts installed, the script menu will not appear.

Installing File Manager Scripts

The file manager includes a special folder where you can store your scripts. All executable files in this folder appear in the Scripts menu. The script folder is located at $HOME/.gnome2/nautilus-scripts.

To install a script, copy the script to the script folder and assign the user executable permission.

To view the contents of your scripts folder, choose File → Scripts → Open Scripts Folder. Navigate to the scripts folder using the file manager if you do not yet have any scripts. If you need to show hidden files to show the script, choose View → Show Hidden Files.

Writing File Manager Scripts

When executed from a local folder, scripts will be passed the selected file names. When executed from a remote folder, scripts will be passed no parameters.

The following table shows variables passed to the script.

<table>
<thead>
<tr>
<th>Environment Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAUTILUS_SCRIPT_SELECTED_FILE_PATHS</td>
<td>Newline-delimited paths for selected files (only if local)</td>
</tr>
</tbody>
</table>
Extending the File Manager

Environment Variable | Description
--- | ---
NAUTILUS_SCRIPT_SELECTED_URIS | Newline-delimited URIs for selected files
NAUTILUS_SCRIPT_CURRENT_URI | URI for current location
NAUTILUS_SCRIPT_WINDOW_GEOMETRY | Position and size of current window

Extensions

The file manager extensions are installed by the system administrator.

Some popular file manager extensions include:

- `nautilus-actions` – Enables you to assign actions based on file type.
- `nautilus-send-to` – Provides a simple way to send a file or folder to another using email, instant messaging, or Bluetooth.
- `nautilus-open-terminal` – Provides an easy way to open a terminal at the selected starting location.

**Note** - You must install the `nautilus-open-terminal` extension to use the Open Terminal command.
Using the Desktop Tools and Utilities

This chapter describes some of the tools and utilities on the Oracle Solaris Desktop. This chapter includes the following information:

- “Running Applications” on page 113
- “Taking Screenshots” on page 114
- “Overview of the Yelp Help Browser” on page 115

Running Applications

The Run Application dialog provides access to the command line. Note that when you run a command in the Run Application dialog, you cannot receive output from the command.

▼ How to Run an Application From the Command Line

1. Open the Run Application dialog in any of the following ways:

   - **Press Meta+R or Alt+F2.**
     You can change the shortcut keys that display the Run Application dialog in the Keyboard Shortcuts preference tool.

   - **If you have added the Run Application button to a panel, click the button.**
     The Run Application dialog is displayed.

2. **Type the command that you want to run, or choose from the list of known applications.**

   If you type only the location of a file, an appropriate application is launched to open it. If you type a web page address, the default web browser opens the page. Prefix the web page address with `http://`, as in `http://www.oracle.com`. 
To choose a command that you ran previously, click the down arrow button beside the command field, and then choose the command. You can also use the Run With File button to choose a file to append to the command line. For example, you can enter `emacs` as the command, and then choose a file to edit.

3. **(Optional) Select the Run in terminal option to run the application or command in a terminal window.**

Choose this option for an application or command that does not create a window in which to run.

4. **Click Run in the Run Application dialog.**

### Taking Screenshots

You can take a screenshot in any of the following ways:

- If you have added a Take Screenshot button to a panel, click the button to take a screenshot of the entire screen.
- Use one of the following shortcut keys:
  - **Print Screen** – Takes a screenshot of the entire screen.
  - **Alt+Print Screen** – Takes a screenshot of the active window which is active.
- From the menubar, choose Applications → Accessories → Take Screenshot.
- In a terminal window, type the `gnome-screenshot` command. The `gnome-screenshot` command takes a screenshot of the entire screen, and displays the Save Screenshot dialog so you can save the screenshot.

The `gnome-screenshot` command has the options described in the following table.

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-window</code></td>
<td>Takes a screenshot of the window that has focus.</td>
</tr>
<tr>
<td><code>-delay=seconds</code></td>
<td>Takes a screenshot after the specified number of seconds, and displays the Save Screenshot dialog to save the screenshot.</td>
</tr>
<tr>
<td><code>-include-border</code></td>
<td>Takes a screenshot including the border of the window.</td>
</tr>
<tr>
<td><code>-remove-border</code></td>
<td>Takes a screenshot without the border of the window.</td>
</tr>
<tr>
<td><code>-border-effect=shadow</code></td>
<td>Takes a screenshot and adds a shadow bevel effect around it.</td>
</tr>
<tr>
<td><code>-border-effect=border</code></td>
<td>Takes a screenshot and adds a border effect around it.</td>
</tr>
</tbody>
</table>
Overview of the Yelp Help Browser

The Yelp Help Browser application enables you to view documentation regarding GNOME and other components through a variety of formats. These formats include docbook files, HTML help pages, man pages, and info pages (support for man pages and info pages might optionally be compiled in). Yelp tries to provide a unified look and feel regardless of the original document format.

The Yelp Help Browser is internationalized, meaning that it has support to view documents in different languages. The documents must be localized or translated for each language and installed for Yelp Help Browser to be able to view them.

You can start Yelp Help Browser in one of the following ways:

- Choose System → Help.
- At the command line, type `yelp`.

Yelp Help Browser Interface

The browser pane displays the table of contents or the documentation. Use the table of contents to navigate to the documentation you need.

Yelp Help Browser contains the elements described in the following table.

<table>
<thead>
<tr>
<th>Menubar</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Use this menu to open a new window, view the About this Document page, print the current document, or close the window.</td>
</tr>
<tr>
<td>Edit</td>
<td>Use this menu to copy, select, find, or to set preferences.</td>
</tr>
<tr>
<td>Go</td>
<td>Use this menu to navigate back or forward, to the Help Topics page. When viewing a docbook document, use this menu to navigate to the next section, the previous section, or to the contents page.</td>
</tr>
</tbody>
</table>

Option | Function
--- | ---
-interactive-- | Opens a window to set options before taking the screenshot.
-help | Displays the options for the command.

To save the screenshot as an image file, type the file name for the screenshot, choose a location from the drop-down list and click Save. You can also use Copy to Clipboard to copy the image to the clipboard or transfer it to another application by using drag and drop.
### How to Open a Document Through the GUI

<table>
<thead>
<tr>
<th>Bookmarks</th>
<th>Use this menu to add or edit bookmarks.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>View information about the Yelp Help Browser and contributors to the project through the About menu item. Open this document from the Contents menu item or by pressing <strong>F1</strong>.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Back</td>
</tr>
<tr>
<td>Forward</td>
</tr>
<tr>
<td>Home</td>
</tr>
<tr>
<td>Search</td>
</tr>
</tbody>
</table>

### Working With Yelp

You can use Yelp to perform the following actions:

- Open documents
- Search documents
- View the About the Document page of a document
- Print a page or a document
- Set preferences to work with the documents
- Add and edit bookmarks

### How to Open a Document Through the GUI

- Open a document through the Yelp Help Browser in of the following ways:
  - In an application, choose Help → Contents and use the Table of Contents to navigate to the desired document.
  - Drag a Docbook XML file from the file manager to the Yelp window or launcher.
  - Press **F1**.

**Tip** - To reload the DocBook document that is currently open, press **Ctrl+R**. This key combination allows you to view changes to documents as they are made.
Searching Documents

This section describes how to search for documents.

▼ How to Search in a Current Page

1. Choose Edit → Find or press Ctrl+F.
   The search bar appears at the bottom of the window.

2. In the Find field on the search bar, type the word or phrase that you want to search, and then press Return.
   If the word or phrase is found on the page, the first occurrence is highlighted. Press Return again to highlight the next occurrence.

3. (Optional) Click Close on the search bar to close it.

▼ How to Search Indexed Documents

1. Click the Search field on the toolbar or Press Alt+S.

2. Type the word or phrase that you want to search, and then press Return.
   A list of all the matching documents is shown in which the word or phrase is found.

3. Click the document name to view a matching page.
   After viewing a matching page, click the Back button on the toolbar to return to the list of search results.

▼ How to Open a New Window

1. Click File → New Window.

2. Press Ctrl+N.
How to Display Information About a DocBook Document

This option is only available for DocBook documentation. Legal notices and documentation contributors are listed in this section.

Choose File → About This Document to view the information about the currently open document.

How to Print the Current Page

Choose File → Print this Page to print the page that you are currently viewing.

How to Print a Docbook Document

This option is only available for DocBook documentation.

Click File → Print this Document to print an entire document.

How to Close a Window

You can close a window in any one of the following ways:

Choose File → Close Window.

Press Ctrl+W

How to Set Preferences

Choose Edit → Preferences.

The following options are available in this Preferences dialog:

Use system fonts – Displays documentation using the default fonts used by the Oracle Solaris Desktop. To choose your own fonts to display documentation, deselect this option and click the buttons next to the Variable Width or Fixed Width.

Variable Width – Select this font when a static or fixed width font is not required.
Fixed Width – Select this font when all text characters need to be of the same size. This font is used to indicate commands, program blocks, or other text that comes under these categories.

Browse with caret – Select this option to locate the cursor while browsing the document.

**How to Add a Bookmark**

1. Choose Bookmarks → Add Bookmark or press Ctrl+D.  
The Add Bookmark window is displayed.

2. Type a desired bookmark title in the Title field.

3. Click Add to add the bookmark.

**How to Edit Bookmarks**

1. Choose Bookmarks → Edit Bookmarks or press Ctrl+B.  
The Bookmarks window is displayed. It provides the following options:
   - Open – Opens the selected bookmark in a new window.
   - Rename – Renames the title of a bookmark.
   - Remove – Deletes the bookmark from the collection.

2. Click Close to exit the Bookmarks window.

**How to Display Help**

Choose Help → Contents to view the online help for the Yelp Help Browser.

**Navigating the Yelp Help Browser**

You can navigate within the Yelp Help Browser as follows:

- To go back in document history:
  - Choose Go → Back.
  - Press Alt+left arrow key.
  - Use the Back button in the Toolbar.
To go forward in document history:
- Choose Go → Forward.
- Press Alt+right arrow key.
- Use the Forward button in the Toolbar.

To go to help topics:
- Choose Go → Help Topics.
- Press Alt+Home.
- Use the Help Topics button in the Toolbar.

To go to previous section:
- Choose Go → Previous Section.
- Press Alt+Up

To go to next section:
- Choose Go → Next Section.
- Press Alt+Down

Opening Documents from the Command Line

The Yelp Help Browser supports opening documents from the command line. A number of URIs (Uniform Resource Identifiers) can be used, including the following:

- **-file:** Accesses a file with Yelp, for example:
  
  ```
  yelp file:///usr/share/gnome/help/gcalctool/C/gcalctool.xml
  ```

- **-ghelp:** or **-gnome-help:** Accesses GNOME help documents, which are written in DocBook format.
  
  ```
  yelp ghelp:gcalctool
  ```

  If you want to open the help document at a particular section, append a question mark to the end of the URI, followed by the section ID.
  
  ```
  yelp ghelp:user-guide?yelp-advanced-cmdline
  ```

- **-man:** Accesses a particular man page. You can append the section of the man page you would like to view if there are multiple man pages with the same name. The section number must be enclosed in parenthesis and you might have to escape the argument so that the shell does not interpret the parenthesis.
  
  ```
  yelp man:gcalctool
  ```

  or

  ```
  yelp ‘man:intro(1)’
  ```
Configuring the Desktop

This chapter describes how to use the preference tools to customize the Oracle Solaris Desktop. This chapter includes the following information:

- “About Preference Tools” on page 123
- “Setting Look and Feel Preferences” on page 126
- “Setting Internet and Network Preferences” on page 136
- “Setting Keyboard Preferences” on page 139
- “Setting Hardware Preferences” on page 146
- “Setting Session Preferences” on page 149

About Preference Tools

A preference tool enables you to change settings on the Oracle Solaris Desktop. Each preference tool covers a particular aspect of the computer. For example, with the Mouse preference tool you can set your mouse to left-handed or right-handed use, or change the speed of the pointer on the screen. With the Windows preference tool, you can set behavior common to all windows, such as the way in which you select windows with the mouse.

To open a preference tool, choose System → Preferences in the top panel. Choose the tool from the submenu.

With a few exceptions, the changes you make to settings in a preference tool take effect without needing to close the preference tool. You can keep the preference tool window open while you try the changes, and make further changes if you wish.

Some applications or system components might add their own preference tools to the menu.

Note - Some preference tools enable you to modify essential parts of your system, and therefore require administrative access. When you open the preference tool, a dialog box will prompt you for your password. These tools are in the System → Administration submenu. This menu also contains more complex utility applications for managing and updating your system.

This section describes the preferences you can set. These preferences include:
About Preference Tools

- Assistive Technologies preferences
- Keyboard shortcut preferences
- Preferred application preferences

Assistive Technologies

The Assistive Technologies preference tool enables assistive technologies on the Oracle Solaris Desktop. You can also use the Assistive Technologies preference tool to open other preference tools that contain preferences related to assistive technologies.

- Preferred Applications enables you to specify assistive technology applications to start automatically when you log in. See “Preferred Applications” on page 125.
- Keyboard Accessibility enables you to configure keyboard accessibility features such as sticky keys, slow keys, or bounce keys. See “Accessibility” on page 143.
- Mouse Accessibility enables you to configure mouse accessibility features such as dwell clicking. See “Mouse Accessibility Preferences” on page 153.

Select Enable Assistive Technologies to enable assistive technologies on the Oracle Solaris Desktop. After enabling this option, log out and then log in again for this option to be fully effective.

Keyboard Shortcuts

Use the Keyboard Shortcuts preference tool to customize the default keyboard shortcuts.

A keyboard shortcut is a key or combination of keys that provide an alternative to standard ways of performing an action. For more about keyboard shortcuts, and a list of the default shortcuts used on the Oracle Solaris Desktop, see Appendix B, “Using the Keyboard”.

The keyboard shortcuts are grouped as follows:

- Desktop – Shortcuts for tasks related to the whole desktop, such as logging out, locking the screen, opening the panel menubar, or launching a web browser.
- Sound – Shortcuts for controlling your music player and the system volume.
- Window Management – Shortcuts for working with windows and workspaces, such as maximizing or moving the current window, and switching to another workspace. For more information about these kinds of actions, see “Working With Windows” on page 18 and “Workspaces Overview” on page 23.
- Accessibility – Shortcuts for starting assistive technologies, such as a screen reader, a magnifier, or an on-screen keyboard.
- Custom Shortcuts – Shortcuts that you have added with the Add button. This section will not be shown if there are no custom shortcuts.
How to Add a Custom Shortcut

1. Choose System → Preferences → Keyboard Shortcuts.
2. Click the Add button in the action area.
3. Provide a name and a command for the new shortcut.
   The new custom shortcut will appear in the list of shortcuts and can be edited in the same way as the predefined shortcuts.

Note - To remove a custom shortcut, use the Remove button.

How to Edit a Keyboard Shortcut

1. Choose System → Preferences → Keyboard Shortcuts.
2. Click the action in the list or use the arrow keys to select the shortcut and press Return.
3. Press the new key or key combination you want to assign to the action.
   To clear a shortcut, press Backspace. The action is now marked as Disabled.

Note - To cancel assigning a shortcut, click elsewhere in the window or press Esc.

Preferred Applications

Use the Preferred Applications preference tool to specify the applications that you want the Oracle Solaris Desktop to use when it starts an application. For example, you can specify a web browser application (Epiphany, Mozilla Firefox, or Opera) to start when you click a link in other applications such as email clients or document viewers.

To access this preference tool, choose System → Preferences → Preferred Applications.

You can customize the preferences for the Preferred Applications preference tool in the following functional areas:

- Internet (Web, Mail)
- Multimedia (Multimedia Player)
Setting Look and Feel Preferences

- System (Terminal)
- Accessibility (Visual, Mobility)

For each preferred application category, you can choose from a list of possible applications. The list depends on the applications installed on your computer.

In each category, the last item in the menu (Custom) enables you to customize the command used by the system when the specific launch action occurs. The following table summarizes the various options that you can choose when you select Custom.

**TABLE 10-1** Custom Command Options

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>Type the command to execute to start the custom application. For the Web Browser and the Mail Reader applications, you can include a %s after the command to tell the application to use the URL or Email address you clicked. The exact command arguments depend on the specific application.</td>
</tr>
<tr>
<td>Run in terminal</td>
<td>Select this option to run the command in a terminal window. Select this option for an application that does not create a window in which to run.</td>
</tr>
<tr>
<td>Execute flag (Terminal only)</td>
<td>Most terminal applications have an option that causes them to treat the remaining command-line options as commands to run (-x for the terminal). Type this option here. For example, this setting is used when executing a command of a launcher for which the chosen type is Application in Terminal.</td>
</tr>
<tr>
<td>Run at start (Accessibility only)</td>
<td>Select this option to run the command as soon as your session begins. For more accessibility options, see “Oracle Solaris 11 Desktop Accessibility Guide ”.</td>
</tr>
</tbody>
</table>

**Setting Look and Feel Preferences**

This section explains how to use the Appearance preference tool to configure the desktop.

**Appearance**

The Appearance preference tool enables you to configure various aspects of the desktop:

- Theme
- Desktop Background
- Fonts
- Visual Effects
Theme Preferences

A theme is a group of coordinated settings that specifies the visual appearance of a part of the Oracle Solaris Desktop. You can choose themes to change the appearance of the Oracle Solaris Desktop. Use the Theme tab to select a theme. You can choose from a list of available themes, which includes several themes for users with accessibility requirements.

A theme contains settings in the Customize Theme window that affect different parts of the Oracle Solaris Desktop, as follows:

- Controls – The controls setting in the Controls Tab, determines the visual appearance of windows, panels, and applets. The Controls setting also determines the visual appearance of the interface items that appear on windows, panels, and applets, such as menus, icons, and buttons. Some of the Controls setting options that are available are designed for special accessibility needs. You can choose an option for the controls setting from the Controls tab in the Customize Theme window.
- Colors – The color setting in the Colors tab for a theme determines the color of various user interface elements.

Note - Make sure you choose pairs of colors that have a good contrast with each other, otherwise text might become hard to read.

- Window frame – The window frame setting in the Window Border tab determines the appearance of the frames around windows only.
- Icons – The icon setting in the Icon tab determines the appearance of the icons on panels and the desktop background.
- Pointer - The pointer setting in the Pointer tab determines the appearance of and size of the mouse pointer.

How to Create a Custom Theme

The themes that are listed in the Theme tab are different combinations of controls options, window frame options, and icon options. You can create a custom theme that uses different combinations of controls options, window frame options, and icon options.

1. **Choose System → Preferences → Appearance.**
   Open the Theme tab.

2. **Select a theme in the list of themes.**

3. **Click Customize.**
   The Customize Theme dialog is displayed.
4. **Select the options that you want to use in the custom theme.**
   For more information about the options, see “Theme Preferences” on page 127.

5. **Click Close** to close the Customize Theme dialog.

6. **In the Appearance preferences tool, click Save As.**
   The Save Theme As dialog is displayed.

7. **Type a name and a short description for the custom theme in the dialog, and then click Save.**
   The custom theme now appears in your list of available themes.

---

**How to Install a New Theme**

You can add a theme to the list of available themes. The new theme must be an archive file, `.tar.gz`, that is tarred and zipped.

1. **Choose System → Preferences → Appearance.**
   Open the Theme tab.

2. **Click Install.**
   The File Chooser dialog is displayed.

3. **Type the location of the theme archive file in the location entry, or select the theme archive file in the file list. Click Open.**

4. **Click Install** to install the new theme.

---

**How to Delete a Theme Option**

You can delete controls options, window frame options, or icons options.

1. **Choose System → Preferences → Appearance.**
   Open the Theme tab.

2. **Click Customize.**
   The Customize Theme dialog is displayed.

3. **Click the tab for the type of option that you want to delete.**
4. Select the theme option you want to delete.

5. Click Delete to delete the selected option.

**Note** - You cannot delete system-wide theme options.

---

**Desktop Background Preferences**

The desktop background is the image or color that is applied to your desktop. You can open the Background tab in the Appearance preference tool by right-clicking on the desktop and choosing Desktop Appearance, as well as from the System → Preferences menu.

You can customize the desktop background in the following ways:

- Select an image for the desktop background. The image is superimposed on the desktop background color. The desktop background color is visible if you select a transparent image, or if the image does not cover the entire desktop.
- Select a color for the desktop background. You can select a solid color, or create a gradient effect with two colors. A gradient effect is a visual effect where one color blends gradually into another color.

**Note** - You can also drag a color or a pattern to the desktop from the Backgrounds and Emblems dialog in the file manager.

The following table lists the background preferences that you can modify.

<table>
<thead>
<tr>
<th>TABLE 10-2 Desktop Background Preferences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialog Element</td>
</tr>
<tr>
<td>Desktop Background</td>
</tr>
<tr>
<td>Style</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
How to Delete a Theme Option

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Click Add to browse for an image on your computer. Choose the image you want and click Open.</td>
</tr>
<tr>
<td>Remove</td>
<td>Choose the image that you want to remove, and then click Remove. This removes the image from the list of available wallpapers; however, it does not delete the image from your computer.</td>
</tr>
</tbody>
</table>
| Colors         | To specify a color scheme, use the options in the Style drop-down list and the color selector buttons. You can specify the following color schemes:  
- Solid Color specifies a single color for the desktop background.  
  To choose the color, click Color and choose a color, and then click OK.  
- Horizontal gradient creates a gradient effect from the left screen edge to the right screen edge.  
  Click Left Color and choose the color that you want to appear at the left edge.  
  Click Right Color and choose the color that you want to appear at the right edge.  
- Vertical gradient creates a gradient effect from the top screen edge to the bottom screen edge.  
  Click Top Color and choose the color that you want to appear at the top edge.  
  Click Bottom Color and choose the color that you want to appear at the bottom edge. |

Font Preferences

Use the Fonts tab in the Appearance preference tool to choose which fonts are used in different parts of the desktop, and the way in which fonts are displayed on the screen.

You can choose fonts for the following parts of the desktop:

- **Application font** – Used in the menus, toolbars, and dialog boxes of applications.
- **Document font** – Used to display documents in applications.

**Note** - In some applications, you can override this choice in the application's preferences dialog.

- **Desktop font** – Used in icon labels on the desktop.
- **Window title font** – Used in the titlebars of windows.
- **Fixed width font** – Used in the Terminal application and in applications related to programming.
How to Choose Fonts

The font selector button shows the name of the font and its point size. The name is also shown in bold, italic, or regular type.

1. Choose System → Preferences → Appearance.
2. Click the Fonts tab.
3. Click Font Selector.
   The Font Picker dialog is displayed.
4. Select the font family, style, and point size from the lists.
   The preview area shows your current choice.
5. Click OK to accept the change and update the desktop.

Font Rendering

You can set the following options relating to how fonts are displayed on the screen:

- Rendering – Specifies how to render fonts on your screen:
  - Monochrome – Renders fonts in black and white only. The edges of characters might appear jagged in some cases because the characters are not antialiased. (Antialiasing is an effect that is applied to the edges of characters to make the characters look smoother.)
  - Best shapes – Antialiases fonts where possible. Use this option for standard Cathode Ray Tube (CRT) monitors.
  - Best contrast – Adjusts fonts to give the sharpest possible contrast, and also antialiases fonts, so that characters have smooth edges. This option might enhance the accessibility of the Oracle Solaris Desktop for users with visual impairments.
  - Subpixel smoothing (LCDs) – Uses techniques that exploit the shape of individual Liquid Crystal Display (LCD) pixels to render fonts. Use this option for LCD or flat-screen displays.

- Details – Determines how to render fonts on the screen:
  - Resolution (dots per inch) – Specifies the resolution to use when your screen renders fonts.
  - Smoothing – Specifies how to antialias fonts.
  - Hinting – This is font-rendering technique that improves the quality of fonts at small sizes and at low screen resolutions. Select one of the options to specify how to apply hinting to your fonts.
Subpixel order - Specifies the subpixel color order for your fonts. Use this option for LCD or flat-screen displays.

Visual Effects

The Visual Effects tab of the Appearance preference tool enables you to control the type of animations, translucency, and other effects that you see as you interact with windows, menus, and workspaces. These effects can enhance the functionality and visual appearance of the desktop. However, some effects require a graphics card that supports hardware acceleration.

You can choose from the following preset levels of visual effects:

- None – No special visual effects are enabled. This option is the default if your graphics card does not support hardware acceleration and uses the Metacity window manager.
- Normal – A small selection of visual effects are enabled. This option is the default if your graphics card supports hardware acceleration and uses the Compiz window manager.
- Extra – A larger selection of visual effects are enabled. When this option is selected, the Compiz window manager is used.

Note - While using the Visual Effects tab, if you select an effect which your graphics card does not support, the previous settings for the effect are restored.

How to Enable and Configure a Customized Set of Visual Effects

1. Select the Custom button, and then click Preferences.
   The Compiz Settings Manager dialog is displayed.

2. In the Compiz Settings Manager dialog, select or deselect the boxes that you want to enable or disable, and then click the name of an effect to change its settings.

3. Click Close to save your changes.

Show Icons in Menus

This option displays an icon beside items in application menus and the panel menu. Not all menu items have an icon.
Editable Menu Shortcut Keys

This option enables you to define new keyboard shortcuts for menu items. To change an application shortcut key, open the menu, and with the mouse pointer on the menu item you want to change, press the new combination of keys. To remove a shortcut key, press Backspace or Del.

Note - When using this feature, you will not be warned if assigning a new shortcut key to a command also removes it from another command.

You cannot restore the original, default keyboard shortcut for a command.

This feature does not maintain shortcuts that are common to all applications, such as Ctrl+C for Copy to avoid inconsistencies in your applications.

Toolbar Button Labels

The following Toolbar button labels specify what to display on the toolbars in your applications:

- Text Below Icons – Displays toolbars with text as well as an icon on each button.
- Text Beside Icons – Displays toolbars with only an icon on each button, and with text on the most important buttons.
- Icons Only – Select this option to display toolbars with an icon only on each button.
- Text Only – Displays toolbars with only text on each button.

Windows

Use the Windows preference tool to customize window behavior for the Oracle Solaris Desktop.

The following table lists the windows preferences that you can modify.

<table>
<thead>
<tr>
<th>TABLE 10-3 Windows Preferences</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Dialog Element</strong></td>
</tr>
<tr>
<td>Select windows when the mouse moves over them</td>
</tr>
<tr>
<td>Raise selected windows after an interval</td>
</tr>
</tbody>
</table>
### Dialog Element

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interval before raising</td>
<td>Specifies the interval to wait before raising a window that has received focus.</td>
</tr>
</tbody>
</table>
| Double-click titlebar to perform this action        | Determines the behavior that occurs when you double-click a window titlebar. Select one of the following options:  
  - Maximize – Maximizes the window.  
  - Maximize Vertically – Maximizes the window vertically without changing its width.  
  - Maximize Horizontally – Maximizes the window horizontally without changing its height.  
  - Minimize – Minimizes the window.  
  - Roll up – Rolls up the window so that only the titlebar is displayed.  
  - None – Does nothing.  
If a window is already maximized or rolled up, double-clicking on the titlebar will return it to its normal state. |
| To move a window, press and hold this key then grab the window | Specifies the key to press and hold when you drag a window to move the window. |

**Note** - You can modify the position of the Control, Alt, and Super keys on the keyboard in the Keyboard Layout Options dialog. For more information, see “Keyboard Layout Options” on page 141.

---

**Screensaver**

A screensaver is an application that replaces the image on a screen when the screen is not in use. The screensaver application for the Oracle Solaris Desktop is XScreenSaver. The following sections describe how to set preferences for the XScreenSaver application, and how to modify displays that are available for the screensaver.

This section describes how to set preferences for the screensaver. This section also provides information about how to modify the displays that are available for the screensaver.

### Setting Screensaver Preferences

The default screensaver preferences are stored in the `/usr/share/X11/app-defaults/XScreenSaver` file. To start the Screensaver preference tool, run the `xscreensaver-demo` command from the `/usr/bin/` directory. To start the Screensaver preference tool from System menu, choose System → Preferences → Screensaver.
Setting Default Screensaver Preferences for All Users

To set default screensaver preferences for all users, modify the XScreenSaver file. Or, you can use the XScreenSaver dialog to create a $HOME/.xscreensaver file, then copy the file to the location of the XScreenSaver file.

Restoring Default Screensaver Settings for a User

To restore the default settings for a user, delete the $HOME/.xscreensaver file from the user's home directory. If no $HOME/.xscreensaver file is present, the system uses the default preferences in the XScreenSaver file.

Note - The default display behavior of the XScreenSaver application is to display a blank screen.

To activate changes to the screensaver preferences, use the following command to reload the screensaver preferences:

```
# xscreensaver-command -restart
```

Modifying Screensaver Preferences

To modify screensaver application preferences, you can use the Screensaver preference tool. When you modify the screensaver preferences, the preferences are stored in the user's home directory, in the $HOME/.xscreensaver file.

Modifying Look and Feel of Your Screensaver

The screensaver displays are listed in the XScreenSaver file and in the $HOME/.xscreensaver file. The screensaver application allows users to choose one or more screensaver displays.

How to Add a Screensaver Display

1. Copy the executable file for the display to the /usr/lib/xscreensaver/hacks/ directory.
2. **Add the command for the screensaver display to the XScreenSaver file or the $HOME/.xscreensaver file.**

To run the screensaver display on the whole screen rather than in a window, include appropriate arguments. For example, you might want to include the -root option to display the screensaver display on the whole screen.

### Disabling a Screensaver Display

To disable the screensaver displays for all users on a Sun Ray™ client, type the following command:

```bash
# pkg uninstall 'desktop/xscreensaver/hacks*' 
```

*Note* - The Pluggable Authentication Modules (PAM) service name for the XScreenSaver application is dtsession. This name is used for compatibility with previous applications.

### Setting Internet and Network Preferences

This section describes the internet and network configurations that you can set.

#### Network

In Oracle Solaris, network configuration profiles (NCPs) manage the system's network configuration. Only one NCP can be active on a system at a time. Oracle Solaris supports two types of NCPs: reactive and fixed. Depending on its type, the active NCP determines whether the system's network configuration is reactive or fixed.

By default, Oracle Solaris uses a feature called reactive network configuration (NWAM) to simplify network configuration. The Network preferences tool enables you to configure this feature.

The reactive network configuration feature simplifies basic network configuration by automatically configuring and managing wired and wireless networks. NWAM addresses basic Ethernet and wireless configurations and enables you to perform various networking tasks, such as connecting to wired or wireless network at startup and configuring new wired or wireless networks. The NWAM feature also simplifies more complex network configurations, such as system-wide network configuration. In addition, this feature displays informational messages about the current status of your network connection and the overall health of your network.

Other feature capabilities include:
■ Multiple concurrent network connections
■ Detection of hot-plug events
■ Network modifiers support, for example, virtual private network (VPN) client applications.

Network configuration is managed by storing desired property values in the form of profiles. NWAM determines which profile should be active at a given time depending on the current network conditions, then activates that profile.

The two primary profile types are the Network Profile, which specifies the configuration of individual network interfaces, and Locations, which specify system-wide network configuration. The individual components that make up the network profile are referred to as network connections. You can use this application to configure and manage both types of profiles.

For more information about using NWAM, see “Configuring and Administering Network Components in Oracle Solaris 11.2”.

**Network Proxy**

The Network Proxy Preferences enables you to configure how your system connects to the Internet.

You can configure the Oracle Solaris Desktop to connect to a proxy server, and specify the details of the proxy server. A proxy server is a server that intercepts requests to another server, and fulfills the request itself, if it can. You can provide the domain name or the Internet Protocol (IP) address of the proxy server. A domain name is a unique alphabetic identifier for a computer on a network. An IP address is a unique numeric identifier for a computer on a network.

Since you might need to use a different proxy configuration in different places, Network Proxy Preferences enables you to define separate proxy configurations and switch between them through the Location setting at the top of the window. Choose New Location to create a proxy configuration for a new location. To remove a location, select it and click the Delete Location button at the bottom of the window.

The network proxy preferences are described in the following table.

<table>
<thead>
<tr>
<th>TABLE 10-4</th>
<th>Network Proxy Preferences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dialog Element</td>
<td>Description</td>
</tr>
<tr>
<td>Direct internet connection</td>
<td>Select this option to connect to the Internet without a proxy server.</td>
</tr>
<tr>
<td>Manual proxy configuration</td>
<td>Select this option to connect to the Internet through a proxy server and configure the proxy settings manually.</td>
</tr>
<tr>
<td>■ HTTP proxy – The domain name or IP address of the proxy server to use when you request an HTTP service. Type the port number of the HTTP service on the proxy server in the Port field.</td>
<td></td>
</tr>
</tbody>
</table>
Dialog Element | Description
--- | ---
If the HTTP proxy server requires authentication, click the Details button to enter your username and password.  
- Secure HTTP proxy – The domain name or IP address of the proxy server to use when you request a secure HTTP service. Type the port number of the secure HTTP service on the proxy server in the Port field.  
- FTP proxy – The domain name or IP address of the proxy server to use when you request an FTP service. Type the port number of the FTP service on the proxy server in the Port field.  
- Socks host – The domain name or IP address of the Socks host to use. Type the port number for the Socks protocol on the proxy server in the Port field.
Automatic proxy configuration | Select this option if you want to connect to the Internet through a proxy server, and you want to configure the proxy server automatically.  
Automatic proxy configuration works by means of a PAC file, which your browser downloads from a web server. If you don't specify the URL for a PAC file in the Autoconfiguration URL entry, your browser will try to locate one automatically.  
- Autoconfiguration URL – The URL of a PAC file that contains the information required to configure the proxy server automatically.

If you use hosts that should connect to the Internet directly without a proxy, add them to the Ignore Host List in the Ignored Hosts tab. When you access these hosts, you will connect to the Internet directly without a proxy.

**Desktop Sharing**

The Desktop Sharing preference tool enables you to share an Oracle Solaris Desktop session among multiple users and to set session-sharing preferences.

The following table lists the session-sharing preferences that you can set. These preferences have a direct effect on the security of your system.

**TABLE 10-5 Session Sharing Preferences**

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow other users to view your desktop</td>
<td>Enables remote users to view your session. All keyboard, pointer, and clipboard events from the remote user are ignored.</td>
</tr>
<tr>
<td>Allow other users to control your desktop</td>
<td>Enables others to access and control your session from a remote location.</td>
</tr>
</tbody>
</table>
| Security | Determines the security methods when a user tries to view or control your session:  
- You must confirm each access to this machine – Displays a confirmation dialog when a user attempts to view or control your session. |
### Setting Keyboard Preferences

This section describes how to configure your keyboard autorepeat rate, layouts and input methods for typing in different languages, and the keyboard accessibility features of the Oracle Solaris Desktop.

You can configure Keyboard Layout preferences such as Keyboard Layout and Keyboard Model. The two main areas are:

- **Input Methods (IM)** – Choose this method if you regularly type in languages that have a greater number of characters or complex characters, for example, some Asian languages like Chinese, Japanese, or Korean.

- **GNOME Keyboard Layout Preferences** – Choose this method if you regularly type in languages that have smaller number of characters. For example, languages conformed by Latin characters as English, Spanish, French, and German.

Although the IM provide a more complex mechanism for composing characters it can be used also for Latin languages. Similarly GNOME Keyboard Layout Preferences can be also used for non-Latin languages.
Keyboard

Use the Keyboard preference tool to set and customize keyboard preferences such as the keyboard model, layout, and variant. You can also customize additional advanced keyboard options such as autorepeat preferences and typing break settings.

Choose System → Preferences → Keyboard to display the Keyboard preference tool.

Keyboard preferences are activated by default. If more than one keyboard layout is selected, the Keyboard Indicator applet automatically appears in the right corner of the panel. For more information about this applet, see the GNOME Keyboard Indicator Manual.

General

Use the General tab to set general keyboard preferences. The following table lists the keyboard preferences that you can modify.

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key presses repeat when key is held down</td>
<td>Enables keyboard repeat so that when you press and hold a key, the action associated with the key is performed repeatedly. For example, if you press and hold a character key, the character is typed repeatedly.</td>
</tr>
<tr>
<td>Delay</td>
<td>Sets the delay from the time you press a key to the time that the action repeats.</td>
</tr>
<tr>
<td>Speed</td>
<td>Sets the speed at which the action is repeated.</td>
</tr>
<tr>
<td>Cursor blinks in text fields</td>
<td>Causes the cursor to blink in fields and text boxes.</td>
</tr>
<tr>
<td>Speed</td>
<td>Specifies the speed at which the cursor blinks in fields and text boxes.</td>
</tr>
<tr>
<td>Type to test settings</td>
<td>Provides an interactive interface so you can see how the keyboard settings affect the display as you type. Type text in the test area to test the effect of your settings.</td>
</tr>
</tbody>
</table>

Layouts

Use the Layouts tab to set your keyboard's language, and set the make and model of the keyboard you are using.

These following settings enable you to make use of special media keys on your keyboard, and to show the correct characters for your keyboard's language:
Setting Keyboard Preferences

■ Keyboard model – Use the Browse button (labelled with the currently selected keyboard model) to choose another keyboard make and model.

■ Separate layout for each window – When this option is selected, each window has its own keyboard layout. Changing to a different layout will only affect the current window.

For example, you could type with a Russian keyboard layout in a word processor and then switch to your web browser and type with an English keyboard layout.

■ Selected Layouts – You can switch between selected layouts to change the characters that your keyboard produces when you type.

To switch between keyboard layouts, use the Keyboard Indicator panel applet.

To add a layout to the list of selected layouts, click the Add button. In the Layout Chooser dialog that is displayed, select a layout by country or by language. You can have up to four layouts. To remove a layout, select it and click Remove.

Click Reset to Defaults to restore all the keyboard layout settings to their initial state for your system and locale.

Click the Layout Options button to open the Keyboard Layout Options dialog.

Note - You can choose a keyboard layout when you log in. For more information, see “How to Use a Different Keyboard Layout” on page 14.

Note - The setxkbmap command enables you to set and customize all keyboard layout settings in the X Server from the command line. For more information, see the setxkbmap(1) man page.

Keyboard Layout Options

The Keyboard Layout Options dialog enables you to set the behavior of keyboard modifier keys and certain shortcut options.

A label in bold indicates that the options in the group have been changed from the default setting.

Note - The options shown in this dialog depend on the X Window system that you are using. Not all options might be listed or work on your system.

The following table describes the keyboard layout options.
### TABLE 10-7  Keyboard Layout Options

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding the Euro sign to certain keys</td>
<td>Adds the Euro currency symbol -€$ to a key as a third-level character. To access this symbol, you must assign a third-level chooser.</td>
</tr>
<tr>
<td>Alt/Win key behavior</td>
<td>Assigns the behavior of the UNIX modifier keys Super, Meta, and Hyper to the Alt and Windows keys on your keyboard.</td>
</tr>
<tr>
<td>CapsLock key behavior</td>
<td>Determines the behavior of the Caps Lock key.</td>
</tr>
<tr>
<td>Compose key position</td>
<td>Enables you to combine two key presses to make a single character so that you can create an accented character that might not be on your keyboard layout. For example, press Compose+e to obtain an e-acute character.</td>
</tr>
<tr>
<td>Control key position</td>
<td>Sets the location of the Ctrl key to match the layout on older keyboards.</td>
</tr>
<tr>
<td>Group Shift/Lock behavior</td>
<td>Determines the keys or key combinations that will switch your keyboard layout when pressed.</td>
</tr>
</tbody>
</table>
| Miscellaneous compatibility options | - **Shift** with the Num pad keys works as in MS Windows – Using **Shift** with keys on the numerical key pad when **NumLock** is off will extend the current selection.  
  With this option unselected, use **Shift** with keys on the numerical pad to obtain the reverse of the current behavior for that key. For example, when **NumLock** is off, the 8 key acts as an up-arrow. Press **Shift**+8 to type an 8.  
  - Special keys (Ctrl+Alt+<key>) handled in a server – Certain keyboard shortcuts are passed to the X Window System instead of being handled by GNOME. |
| Third level choosers            | A third-level key enables you to obtain a third character from a key, in the same way that pressing **Shift** with a key produces a different character than pressing the key alone.  
  Use this group to select a key that you want to act as a third-level modifier key.  
  Pressing the third-level key and **Shift** produces a fourth character from a key.  
  The third-level and fourth-level characters for your keyboard layout are shown in the Keyboard Indicator Layout View window. |
| Use keyboard LED to show alternative group. | Specifies that one of the light indicators on your keyboard should indicate when an alternative keyboard layout is in use. The selected keyboard light will no longer indicate its standard function. For example, the Caps Lock light will not react to the Caps Lock key. |
Accessibility

The Accessibility tab enables you to set options such as filtering out accidental key presses and using shortcut keys without having to hold down several keys at once. These features are also known as AccessX.

This section describes each of the preferences that you can set. For a more task-oriented description of keyboard accessibility, see the Oracle Solaris Desktop Accessibility Guide.

The following table lists the accessibility preferences that you can modify.

**TABLE 10-8  Accessibility Preferences**

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessibility features can be toggled with keyboard shortcuts</td>
<td>Displays an icon in the notification area that offers quick access to accessibility features.</td>
</tr>
<tr>
<td>Simulate simultaneous key presses</td>
<td>Enables multiple simultaneous keypress operations by pressing the keys in sequence. Alternatively, to enable the sticky keys feature, press Shift five times.</td>
</tr>
<tr>
<td>Disable sticky keys if two keys are pressed together</td>
<td>Specifies that when you press two keys simultaneously, you can no longer press keys in sequence to perform multiple simultaneous key presses.</td>
</tr>
<tr>
<td>Only accept long key presses</td>
<td>Determines that you must press and hold a key for a period of time before acceptance. Alternatively, to enable the slow keys feature, press and hold Shift for eight seconds.</td>
</tr>
<tr>
<td>Delay</td>
<td>Specifies the period of time that you must press and hold a key before acceptance.</td>
</tr>
<tr>
<td>Ignore fast duplicate key presses</td>
<td>Controls the key repeat characteristics of the keyboard.</td>
</tr>
<tr>
<td>Delay</td>
<td>Specifies the interval to wait after the first keypress before the automatic repeat of a pressed key.</td>
</tr>
<tr>
<td>Type to test settings</td>
<td>Provides an interactive interface so that you can see how the keyboard settings affect the display as you type. Type any text in the test area to test the effect of your settings.</td>
</tr>
</tbody>
</table>

Audio Feedback

To configure audio feedback for keyboard accessibility features, click the Audio Feedback button. The Keyboard Accessibility Audio Feedback window is displayed.

The following table lists the audio feedback preferences that you can modify.
Setting Keyboard Preferences

### TABLE 10-9  Audio Feedback Preferences

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beep when accessibility features are turned on or off</td>
<td>Sounds for an audible indication when a feature such as sticky keys or slow keys is activated, or deactivated.</td>
</tr>
<tr>
<td>Beep when a toggle key is pressed</td>
<td>Sounds for an audible indication of a toggle keypress. You hear one beep when a toggle key is turned on. You hear two beeps when a toggle key is turned off.</td>
</tr>
<tr>
<td>Beep when a modifier key is pressed</td>
<td>Sounds for an audible indication when you press a modifier key.</td>
</tr>
<tr>
<td>Show visual feedback for the alert sound</td>
<td>Flashes part of the screen when an application beeps to indicate an alert.</td>
</tr>
<tr>
<td>Flash window titlebar</td>
<td>When an application beeps, briefly flash the titlebar of the window in which the alert occurred.</td>
</tr>
<tr>
<td>Flash entire screen</td>
<td>When an application beeps, briefly flash the entire screen.</td>
</tr>
<tr>
<td>Beep when a key is pressed</td>
<td>Sounds for an audible indication when a key is pressed.</td>
</tr>
<tr>
<td>Beep when a key is accepted</td>
<td>Sounds for an audible indication when a key is accepted.</td>
</tr>
<tr>
<td>Beep when a key is rejected</td>
<td>Sounds for an audible indication when a key is rejected.</td>
</tr>
</tbody>
</table>

### Mouse Keys

Use the options in the Mouse Keys tab to configure the keyboard as a substitute for the mouse.

The following table lists the mouse keys preferences that you can modify.

### TABLE 10-10  Mouse Keys Preferences

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pointer can be controlled using the keypad</td>
<td>Enables the numeric keypad to be used to emulate mouse actions. The list of keys and their equivalences is in the “To Use the Keyboard to Emulate the Mouse” in “Oracle Solaris 11 Desktop Accessibility Guide”.</td>
</tr>
<tr>
<td>Acceleration</td>
<td>Specifies the time that the pointer takes to accelerate to the maximum speed.</td>
</tr>
<tr>
<td>Speed</td>
<td>Specifies the maximum speed at which the pointer moves across the screen.</td>
</tr>
<tr>
<td>Delay</td>
<td>Specifies the period of time that must pass after a keypress before the pointer moves.</td>
</tr>
</tbody>
</table>
Typing Break

You can set a typing break notification to remind you to rest after you have been using the keyboard and mouse for a long time. During a typing break, the screen is locked.

The following table lists the typing break preferences that you can modify.

**TABLE 10-11** Typing Break Preferences

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lock screen to enforce typing break</td>
<td>Locks the screen when you are due a typing break.</td>
</tr>
<tr>
<td>Work interval lasts</td>
<td>Specifies the time you can work before a typing break occurs.</td>
</tr>
<tr>
<td>Break interval lasts</td>
<td>Specifies the length of your typing breaks.</td>
</tr>
<tr>
<td>Allow postponing of breaks</td>
<td>Enables you to postpone typing breaks.</td>
</tr>
</tbody>
</table>

If you stop using the keyboard and mouse for a length of time equal to the break interval setting, the current work interval will be reset.

Input Method Selector

Input Methods (IM) help you to type in languages that have a large number of characters, or that use complex characters such as Chinese, Japanese, or Korean.

Oracle Solaris Desktop provides different IM Frameworks either installed on the system or available for installation from the repository. One of the main IM frameworks in Oracle Solaris Desktop is the Intelligent Input Bus (IBus).

The IBus framework provides the following features:

- A complete engine for handling most of the Asian languages.
- Keyboard layout emulation support for many regions including EMEA (Europe, Middle East, and Africa).
- Support for virtual keyboards and X keyboard data emulation.

By default, IM is activated only when you log in by using the following languages:

- Japanese
- Chinese
- Korean
How to Activate or Deactivate IM

- Thai
- Indic

For other languages, IM is not activated by default. You must activate it manually through the Input Method Framework Selector.

▼ How to Activate or Deactivate IM

1. Choose System → Preferences → Input Method Selector.
   The Input Method Framework Selector window is displayed.

2. Select the Enable Input Method Framework option and select the preferred input method framework from the list.

3. Click OK.

Setting Hardware Preferences

This section describes the monitor and sound configurations that you can set.

Monitor Preference Tool

Use the Monitor preference tool to configure the monitors that your computer uses.

Note - On most laptop keyboards, you can use the key combination Fn+F7 to cycle between several typical monitor configurations without starting Monitor Preferences.

Choose System → Preferences → Monitor to display the Monitor preference tool.

Drag the graphical representations of the monitors in the upper left part of the window to set how your monitors are arranged. Monitor Preferences displays small labels in the top left corner of each monitor to help you identify which rectangle corresponds to which monitor.

Changes you make in Monitor Preferences don't take effect until you click the Apply button. Settings will revert to their previous settings unless you confirm the changes. This is to prevent bad display settings from rendering your computer unusable.

The following table below describes the monitor preferences
### TABLE 10-12  Monitor Preferences

<table>
<thead>
<tr>
<th>Dialog Elements</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same image in all monitors</td>
<td>When this option is selected, your entire desktop will fit on a single monitor, and every monitor will show the same copy of your desktop. When it is not selected, your desktop spans multiple monitors, and each monitor shows only a part of your entire desktop.</td>
</tr>
<tr>
<td>Detect monitors</td>
<td>Finds monitors that have been recently added or plugged in.</td>
</tr>
<tr>
<td>Show monitors in panel</td>
<td>Adds an icon to your panel that enables you to quickly change certain settings without opening the Monitor preference tool.</td>
</tr>
</tbody>
</table>

The following list explains the options you can set for each monitor. The currently selected monitor is the one whose graphical representation has a bold black outline. It is also indicated by the background color of the section label.

- **On / Off** – Individual monitors can be completely disabled by selecting Off.
- **Resolution** – Determines the resolution to use for the currently selected monitor. Resolution refers to the pixel dimensions of the screen. A larger resolution means that more items fit on the screen, but everything will be smaller.
- **Refresh rate** – Determines the refresh rate to use for the currently selected monitor. The refresh rate determines how often the computer redraws the screen. A refresh rate that is too low (below 60) makes the monitor flicker and can cause visual discomfort. This problem is less noticeable on LCD displays.
- **Rotation** – Determines the rotation for the currently selected monitor. This option might not be supported on all graphics cards.

### Sound Preference Tool

The Sound preference tool enables you to control devices and volume for sound input and output. You can also specify which sounds to play when particular events occur.

Choose System → Preferences → Sound to display the Sound preference tool.

You can customize settings in the following functional areas:

- **Playback**
- **Recording**
- **Sound Theme**

Most computers have only one audio device that controls both sound recording and playback. If your computer has more than one audio device, you can switch between them using the Device drop-down list at the top of the window.
Playback Preferences

Use the Playback tab to set your preferences for sound output. The following table lists the recording preferences that you can modify.

**TABLE 10-13  Playback Preferences**

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Volume</td>
<td>Controls the overall output volume.</td>
</tr>
<tr>
<td>Link sliders button</td>
<td>Sets all sliders to the same value, and moves them together when any one slider is moved.</td>
</tr>
<tr>
<td>Mute button</td>
<td>Temporarily suppresses all sounds without disturbing the current volume level.</td>
</tr>
</tbody>
</table>

*Note* - You can also control the output volume with the speaker icon, which is shown in the notification area of the panel.

Depending on your computer's sound card and the devices that are attached to it, you might also see other sliders, check boxes, or lists on the Playback tab that enable you to control sound output. You can choose which controls appear on the tab by clicking the Preferences button.

Recording Preferences

Use the Recording tab to set your preferences for sound input. The following table lists the recording preferences that you can modify.

**TABLE 10-14  Recording Preferences**

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record</td>
<td>Controls the sound input level.</td>
</tr>
<tr>
<td>Gain</td>
<td>Controls the amount of amplification applied to the recording input.</td>
</tr>
<tr>
<td>Link sliders button</td>
<td>Sets all sliders to the same value, and moves them together when any one slider is moved.</td>
</tr>
<tr>
<td>Mute button</td>
<td>Temporarily suppresses all input without disturbing the current input level.</td>
</tr>
</tbody>
</table>

Depending on your computer's sound card and the devices that are attached to it, you might see other sliders, check boxes, or lists on the Recording tab that enable you to control sound input. You can choose which controls appear on the tab by clicking the Preferences button.
Sound Theme Preferences

A sound theme is collection of sound effects that are associated to various events, such as opening a dialog, clicking a button, or selecting an item in a menu. One of the most prominent event sounds is the system alert sound that is often played to indicate a keyboard input error. Use the Sound Theme tab of the Sound Preference tool to choose a sound theme and modify the bell sound.

The following table lists the sound effects preferences that you can modify.

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sound Theme</td>
<td>Determines the sound theme. Choose No sounds to turn off all event sounds.</td>
</tr>
<tr>
<td>Choose an alert sound list</td>
<td>Determines the sound for the System Bell. Selecting a list element plays the sound.</td>
</tr>
<tr>
<td>Enable window and button sounds</td>
<td>Deselect this option if you do not want to hear sounds for window-related events (such as a dialog or a menu appearing) and button clicks.</td>
</tr>
</tbody>
</table>

Application Sound Preferences

Use the Applications tab to control the volume of sound played by individual applications. Each application that is currently playing sound is identified by its name and icon.

Setting Session Preferences

The Startup Applications preference tool enables you to manage your sessions. You can set session preferences, and specify which applications to start when you start a session. You can configure sessions to save the state of applications on the Oracle Solaris Desktop, and to restore the state when you start another session. You can also use this preference tool to manage multiple GNOME sessions.

You can customize settings in the following functional areas:

- Session options
- Startup programs

Use the Session Options tab to manage multiple sessions, and to set preferences for the current session. The following table lists the session options that you can modify.
TABLE 10-16  Session Options

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically remember running applications when</td>
<td>Select this option if you want the session manager to save the state of your session when logging out. The session manager saves the session-</td>
</tr>
<tr>
<td>logging out</td>
<td>managed applications that are open, and the settings associated with the session-managed applications when you log out. The next time that you start a session, the applications start automatically with the saved settings.</td>
</tr>
<tr>
<td>Remember currently running applications</td>
<td>Select this option if you want the session manager to save the current state of your session. The session manager saves the session-managed applications that are open, and the settings associated with the session-managed applications. The next time that you start a session, the applications start automatically with the saved settings.</td>
</tr>
</tbody>
</table>

Configuring Startup Applications

Use the Startup Programs tab of the Startup Applications preference tool to specify non session-managed startup applications. Startup applications are applications that start automatically when you start a session. You specify the commands that run the non session-managed applications in the Startup Programs tab. The commands execute automatically when you log in.

You can also start session-managed applications automatically. For more information, see “Setting Session Preferences” on page 149.

You can add, edit, or delete a startup application.

- To add a startup application, click the Add button. The New Startup Program dialog is displayed. Type the name of the application in the Name field. Then type the command to start the application in the Command field. You can also specify a comment in the Comment field.
- To edit a startup application, select the startup application, then click the Edit button. The Edit Startup Program dialog is displayed. Modify the command and the startup order for the startup application.
- To delete a startup application, select the startup application, then click the Remove button.
Using the Mouse

This appendix describes the mouse actions and the different mouse pointers. It includes the following information:

- “Mouse Button Conventions” on page 151
- “Mouse Pointers” on page 154

A mouse is a pointing device that helps in moving the mouse pointer over the screen. The mouse pointer is a small arrow with which you point to objects on the screen. Depending on which button you press, a particular action is performed on the object over which the mouse pointer is situated.

Mouse Button Conventions

The mouse button conventions are as follows:

- **Left mouse button** – The button on the left side of a mouse device. The left mouse button is frequently used for selecting, activating, pressing buttons, and so on. When you are told to click, click with the left button.
- **Middle mouse button** – The middle button of a mouse device. On many mouse devices with a scroll wheel, the scroll wheel can be pushed down for a middle mouse button click.
- **Right mouse button** – The button on the right side of a mouse device. Often, this button displays a context menu for the object under the pointer.

Some mouse devices lack a middle button. If you have a two-button mouse device, then the system might be configured to use chording to enable middle button simulation. If chording is activated, press the left and right mouse buttons simultaneously to simulate the middle mouse button.

Use the Mouse preference tool to reverse the orientation of the mouse device. You will then need to reverse the mouse button conventions used in this guide.
Mouse Preference Tool

With the Mouse preference tool you can determine the following settings:

- Configure your mouse for right-hand use or for left-hand use
- Specify the speed and sensitivity of mouse movement
- Configure mouse accessibility features

Choose System → Preferences → Mouse to display the Mouse Preference tool.

General Mouse Preferences

Use the General tab to specify whether the mouse buttons are configured for left-hand or right-hand use and configure the speed and sensitivity of your mouse.

The following table lists the general mouse preferences that you can modify.

<table>
<thead>
<tr>
<th>Dialog Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right-handed</td>
<td>Configures your mouse for right-hand use. The left mouse button is the primary button and the right mouse button is the secondary button.</td>
</tr>
<tr>
<td>Left-handed</td>
<td>Configures your mouse for left-hand use. The functions of the left mouse button and the right mouse button are swapped.</td>
</tr>
<tr>
<td>Show position of pointer when the Control key is pressed</td>
<td>Enables a mouse pointer animation when you press and release the Ctrl key. This feature can help you locate the mouse pointer. <strong>Note</strong> - The position of the Ctrl key on the keyboard can be modified in the Keyboard Layout Options dialog. For more information, see “Keyboard Layout Options” on page 141.</td>
</tr>
<tr>
<td>Acceleration</td>
<td>Specifies the speed at which your mouse pointer moves on your screen when you move your mouse.</td>
</tr>
<tr>
<td>Sensitivity</td>
<td>Specifies how sensitive your mouse pointer is to movements of your mouse.</td>
</tr>
<tr>
<td>Threshold</td>
<td>Specifies the distance that you must move an item before the move action is interpreted as a drag-and-drop action.</td>
</tr>
<tr>
<td>Timeout</td>
<td>Use the slider to specify the amount of time that can pass between clicks when you double-click. If the interval between the first and second clicks exceeds the time that is specified, the action is not interpreted as a double-click.</td>
</tr>
</tbody>
</table>
Mouse Button Conventions

Appendix A • Using the Mouse

Mouse Accessibility Preferences

Use the Accessibility tab to configure accessibility features that can help people who have difficulty with exact positioning of the pointer or with pressing the mouse buttons:

- Open a contextual menu by clicking and holding the primary mouse button. This setting is useful for users that can manipulate only one button.
- Perform different types of mouse button click by software. This setting useful for users that are not able to manipulate any buttons. The types of click that can be performed are:
  - Single click – A single click of the primary mouse button.
  - Double click – A double click of the primary mouse button.
  - Drag click – A click that begins a drag operation.
  - Secondary click – A single click of the secondary mouse button.

The following table lists the mouse accessibility preferences that you can modify.

<table>
<thead>
<tr>
<th>TABLE A-2 Mouse Motion Preferences</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Dialog Element</strong></td>
</tr>
<tr>
<td>Trigger secondary click by holding down the primary button</td>
</tr>
<tr>
<td>Delay slider in the Simulated Secondary Click section</td>
</tr>
<tr>
<td>Initiate click when stopping pointer movement</td>
</tr>
<tr>
<td>Delay slider in the Dwell Click section</td>
</tr>
<tr>
<td>Motion threshold slider</td>
</tr>
<tr>
<td>Choose type of click beforehand</td>
</tr>
<tr>
<td>Show click type window</td>
</tr>
<tr>
<td>Note • The Dwell Click panel applet can be used instead of the window.</td>
</tr>
<tr>
<td>Choose type of click with mouse gestures</td>
</tr>
</tbody>
</table>
Mouse Pointers

Note - To enable these accessibility preferences, the system administrator must install the gnome/accessibility/mousetweaks package.

The mouse buttons perform the following actions.

<table>
<thead>
<tr>
<th>Mouse Button</th>
<th>Actions</th>
</tr>
</thead>
</table>
| Left mouse button  | ■ Select text  
|                    | ■ Select items  
|                    | ■ Drag items  
|                    | ■ Activate items  |
| Middle mouse button| ■ Paste text  
|                    | ■ Move items  |
| Right mouse button | Use the right mouse button to open a context menu for an item. For most items, you can also use the Shift+F10 keyboard shortcut to open the context menu once the item has been selected.

For example, when viewing files in the File Manager, you can select a file by clicking the left mouse button and then open it by double-clicking with the left mouse button. Clicking with the right mouse button displays a context menu for that file.

Note - In most applications, you can select text with your left mouse button and paste it in another application using the middle mouse button. This process is called primary selection paste, and works separately from normal clipboard operations.

To select more than one item, you can hold the Ctrl key to select multiple items, or hold the Shift key to select a contiguous range of items. You can also drag a rectangle in the empty space around items to select several items.

Mouse Pointers

The appearance of the mouse pointer can change. The appearance of the pointer provides feedback about a particular operation, location, or state. The following mouse pointers are displayed as the mouse passes over different elements of the screen.
**Note** - Mouse pointers might differ from those shown here depending on the mouse preferences used.

<table>
<thead>
<tr>
<th>Mouse Pointer</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Normal pointer" /></td>
<td>Appears during normal mouse usage.</td>
</tr>
<tr>
<td><img src="image" alt="Busy pointer" /></td>
<td>Appears over a window that is busy performing a task. You cannot use the mouse to give this window any input, but you can move to another window and work there.</td>
</tr>
<tr>
<td><img src="image" alt="Resize pointer" /></td>
<td>Indicates that you can grab the control to resize parts of the interface. This pointer appears over the borders of windows and over resize handles between panes in a window. The direction of the arrows indicates the direction in which you can resize.</td>
</tr>
<tr>
<td><img src="image" alt="Hand pointer" /></td>
<td>Appears when you hover over a hypertext link, for example, in a web page. This pointer indicates that you can click the link to load a new document or perform an action.</td>
</tr>
<tr>
<td><img src="image" alt="I-beam pointer" /></td>
<td>Appears when the mouse is over text which you can select or edit. Click to place the cursor where you want to type text, or drag to select text.</td>
</tr>
</tbody>
</table>

The following mouse pointers are displayed when dragging an item such as a file or a piece of text. They indicate the result of releasing the mouse button to drop the object being moved.

<table>
<thead>
<tr>
<th>Mouse Pointer</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Move pointer" /></td>
<td>Indicates that when you drop the object, it is moved from the old location to the new location.</td>
</tr>
<tr>
<td><img src="image" alt="Copy pointer" /></td>
<td>Indicates that when you drop the object, a copy of the object is created where you drop it.</td>
</tr>
<tr>
<td><img src="image" alt="Symbolic link pointer" /></td>
<td>Indicates that when you drop the object, a symbolic link to the object is created where you drop the object. A symbolic link is a special type of file that points to another file or folder. See “Creating a Symbolic Link to a File or Folder” on page 90 for more information about creating symbolic links.</td>
</tr>
<tr>
<td><img src="image" alt="Ask pointer" /></td>
<td>Indicates that when you drop the object, you will be given a choice. A menu is displayed which enables you to choose which operation you want to perform, for example, you might be able to move, copy, or create a symbolic link.</td>
</tr>
<tr>
<td><img src="image" alt="Not available pointer" /></td>
<td>Indicates that you cannot drop the object at the current location. Releasing the mouse button has no effect. The dragged object is returned to its original location.</td>
</tr>
<tr>
<td><img src="image" alt="Move panel object pointer" /></td>
<td>Appears when you drag a panel or a panel object with the middle mouse button. See Chapter 4, “Using the Desktop Panels” for more information about panels.</td>
</tr>
<tr>
<td><img src="image" alt="Move window pointer" /></td>
<td>Appears when you drag a window to move it. See “Working With Windows” on page 18 for more information about moving windows.</td>
</tr>
</tbody>
</table>
Using the Keyboard

For almost every task which you can perform with the mouse, you can use the keyboard to perform the same task. You can use shortcut keys to perform general Oracle Solaris Desktop tasks and to work with interface items such as panels and windows. You can also use shortcut keys in applications. To customize your shortcut keys, use the Keyboard Shortcuts preference tool. See “Keyboard Shortcuts” on page 124 for more information about configuring keyboard shortcuts.

You can also modify the Oracle Solaris Desktop preferences to use keyboard accessibility features. See “Accessibility” on page 143 for more information about the keyboard accessibility features. For more information about keyboard navigation functions available on the Oracle Solaris Desktop, see “Oracle Solaris 11 Desktop Accessibility Guide.”

This appendix includes the following information:

- “Global Shortcut Keys” on page 157
- “Window Shortcut Keys” on page 158
- “Application Keys” on page 159
- “Access Keys” on page 160

Global Shortcut Keys

Global shortcut keys enable you to use the keyboard to perform tasks related to the desktop, rather than tasks on the currently selected window or application. The following table lists some global shortcut keys.

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+F1, Ctrl+Esc</td>
<td>Opens the Applications Menu.</td>
</tr>
<tr>
<td>Alt+F2, Meta+R</td>
<td>Displays the Run Application dialog box. See “Running Applications” on page 113 for more information about how to run applications.</td>
</tr>
<tr>
<td>Print Screen</td>
<td>Takes a screenshot of the entire desktop. See “Taking Screenshots” on page 114 for more information about taking screenshots.</td>
</tr>
</tbody>
</table>
Window Shortcut Keys

Window shortcut keys enable you to use the keyboard to perform tasks on the currently focused window. The following table lists some of the window shortcut keys.

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+Print Screen</td>
<td>Takes a screenshot of the currently focused window.</td>
</tr>
<tr>
<td>Ctrl+Alt+arrow keys</td>
<td>Switches the workspace to the specified direction. See “Workspaces Overview” on page 23 for more information about working with multiple workspaces.</td>
</tr>
<tr>
<td>Ctrl+Alt+D</td>
<td>Minimizes all windows and gives focus to the desktop.</td>
</tr>
<tr>
<td>Alt+Tab</td>
<td>Switches between windows. A list of windows that you can select is displayed. Release the keys to select a window. You can press the Shift key to cycle through the windows in reverse order.</td>
</tr>
<tr>
<td>Alt+Esc</td>
<td>Switches between windows. Release the keys to select a window. Use the Shift key to cycle through the windows in reverse order.</td>
</tr>
<tr>
<td>Ctrl+Alt+Tab</td>
<td>Switches the focus between the panels and the desktop. A list of items that you can select is displayed. Release the keys to select an item. You can press the Shift key to cycle through the items in reverse order.</td>
</tr>
</tbody>
</table>

**Window Shortcut Keys**

Window shortcut keys enable you to use the keyboard to perform tasks on the currently focused window. The following table lists some of the window shortcut keys.

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+Tab</td>
<td>Switches between windows. A list of windows that you can select is displayed. Release the keys to select a window. You can press the Shift key to cycle through the windows in reverse order.</td>
</tr>
<tr>
<td>Alt+Esc</td>
<td>Switches between windows. Release the keys to select a window. Use the Shift key to cycle through the windows in reverse order.</td>
</tr>
<tr>
<td>Alt+F4</td>
<td>Closes the currently focused window.</td>
</tr>
<tr>
<td>Alt+F5</td>
<td>Minimizes the current window, if it is maximized.</td>
</tr>
<tr>
<td>Alt+F7</td>
<td>Moves the currently focused window. After pressing this shortcut, you can move the window using either the mouse or arrow keys. To finish the operation, click the mouse or press any key on the keyboard.</td>
</tr>
<tr>
<td>Alt+F8</td>
<td>Resizes the currently focused window. You can use this shortcut to resize the window using either the mouse or arrow keys. To finish the operation, click the mouse or press any key on the keyboard.</td>
</tr>
<tr>
<td>Alt+F9</td>
<td>Minimizes the current window.</td>
</tr>
<tr>
<td>Alt+F10</td>
<td>Maximizes the current window.</td>
</tr>
<tr>
<td>Alt+Spacebar</td>
<td>Opens the menu for the currently selected window. The window menu enables you to perform actions on the window, such as minimizing, moving between workspaces, and closing.</td>
</tr>
</tbody>
</table>
Application Keys

Application shortcut keys enable you to perform application tasks. The following table lists some of the application shortcut keys.

**TABLE B-3  Application Shortcut Keys**

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+N</td>
<td>Creates a new document or window.</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Cuts the selected text or region and places it on the clipboard.</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copies the selected text or region to the clipboard.</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Pastes the contents of the clipboard.</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Cancels the last action.</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Saves the current document to disk.</td>
</tr>
<tr>
<td>F1</td>
<td>Loads the online help document for the application.</td>
</tr>
</tbody>
</table>

In addition to these shortcut keys, all applications support a set of navigation keys and actions associated with the user interface. These keys allow you to perform operations that you might perform with a mouse. The following table describes some interface control keys.

**TABLE B-4  Interface Control Keys**

<table>
<thead>
<tr>
<th>Keys</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow keys or Tab</td>
<td>Moves between controls in the interface or items in a list.</td>
</tr>
<tr>
<td>Return or Spacebar</td>
<td>Activates or chooses the selected item.</td>
</tr>
<tr>
<td>F10</td>
<td>Activates the left-most menu of the application window.</td>
</tr>
<tr>
<td>Shift+F10</td>
<td>Activates the context menu for the selected item.</td>
</tr>
<tr>
<td>Esc</td>
<td>Closes a menu without selecting a menu item, or cancels a drag operation.</td>
</tr>
</tbody>
</table>
Access Keys

An access key is an underlined letter in a menubar, menu, or a dialog that you can use to perform an action.

To open a menu, hold the Alt key, and then press the access key. To choose a menu item when a menu is displayed, you can press the access key for the menu item.

For example, to open a new window in the Help application, press Alt+F to open the File menu, and then press N to activate the New Window menu item. You can also use access keys to access elements in a dialog. To access a particular dialog element, hold the Alt key, and then press the access key.