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redundancy, and other measures to ensure the safe use of such applications if the Programs are used for 
such purposes, and we disclaim liability for any damages caused by such use of the Programs.  

The Programs may provide links to Web sites and access to content, products, and services from third 
parties. Oracle is not responsible for the availability of, or any content provided on, third-party Web sites. 
You bear all risks associated with the use of such content. If you choose to purchase any products or 
services from a third party, the relationship is directly between you and the third party. Oracle is not 
responsible for: (a) the quality of third-party products or services; or (b) fulfilling any of the terms of the 
agreement with the third party, including delivery of products or services and warranty obligations related 
to purchased products or services.  

Oracle is not responsible for any loss or damage of any sort that you may incur from dealing with any third 
party. Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be 
trademarks of their respective owners. 
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1 Preface 
The AutoVue Integration SDK User Guide explores ISDK’s key capabilities. 

For the most up-to-date version of this document, go to the AutoVue Documentation Web site on 
the Oracle Technology Network (OTN) at 
http://www.oracle.com/technetwork/documentation/autovue-091442.html. 

1.1 Audience 
This document is intended for Oracle partners and third-party developers (such as 
integrators) who want to implement their own integration with AutoVue. 

1.2 Related Documents 
For more information, see the following documents in the AutoVue Integration SDK library: 

• Overview 
• Installation and Configuration Guide 
• Design Guide 
• Technical Guide 
• Acknowledgments 
• Javadocs 
• Security Guide 

 
2 Integration SDK Demo Home Page 
Launch your Web browser and go to the Oracle AutoVue Integration SDK demo home page. 
For example: http://<myserver>:8080/isdk/index.jsp 

http://www.oracle.com/technetwork/documentation/autovue-091442.html.�
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Figure 2.1 Integration SDK Demo Home Page 

 

This page includes entrance points for three demos: 

1. Filesys Demo: Enter username and password and then click Login. The Filesys Demo 
page loads. Note that the default username is anonymous with an empty password.  

2. Real-Time Collaboration Demo: Click Real-Time Collaboration Demo to enter the 
AutoVue Real-Time collaboration demo page. 

3. Oracle Enterprise Visualization Framework Demo: Click OEVF Demo to enter the 
Oracle Enterprise Visual Framework demo page. 

 

3 Filesys Demo 

3.1 Filesys Demo page 
From the Oracle AutoVue Integration SDK demo home page, click Login to launch Filesys 
Demo page. 
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Figure 2.1  FileSys Demo Page 

 
This Filesys Demo page contains four sections as shown in Figure 2.1:  

• The top part of the left-side frame displays login information and Filesys DMS repository 
information (such as the location of the repository root folder and the repository base 
URL). If user information is unavailable, the login link is enabled. Otherwise, the 
username is displayed and the logout link is enabled.  

• The middle part of left-side frame displays the structure of Filesys DMS repository. You 
can navigate the Filesys DMS repository by expanding folders and selecting documents 
to view. 

• The bottom part of left-side frame displays the preview image for a viewable document 
when you navigate the Filesys repository and the preview image is available for that 
document. You can navigate the Filesys DMS repository by expanding folders and 
selecting documents to view. 

• The right-side frame displays AutoVue applet. When a viewable document in the left-side 
frame is clicked, it displays in the right-side frame.  

Tree Structure 
to Browse 
FileSys DMS 
Repository 

AutoVue Applet 

Image 
Preview 

Tree Structure 
to Browse 
FileSys DMS 
Repository 

Info about 
Login User and 
FileSys DMS 
Repository Root  
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3.2 Viewing Documents 
To view a single and composite document, navigate the Filesys DMS repository and click on 
the document you want to view. The viewable documents are tagged by the AutoVue icon. 

 

Figure 3.2 Filesys Demo - View a single document 

Viewable 
document 
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Figure 3.3 Filesys Demo - View a composite document with preview image 

To view a specific version of a document, navigate the Filesys repository and select a 
document, expand it, select the target version folder and then click the base document. 

 
Figure 3.4 Filesys Demo - Two versions of the bike.dgn document 

External 
references 
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3.3 Creating Markups 
View a document that you want to markup using AutoVue. 

From the Markup menu, select New.  AutoVue enters Markup mode and a new Markup file 
appears in the Markup Navigation Tree.  

Note: From the Markup Properties toolbar, you can also click New Markup .  
 

 
Figure 3.5 Filesys Demo - Create Markup in AutoVue 

 
Note that if you have just finished creating a Markup file, and you would like to create a new 
markup file, from the Markup menu, select New.  

Note: From the Markup Properties toolbar, you can also click New Markup .  
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Figure 3.6: Open Markup Dialog 

 

3.4 Saving Markups 
To save a new markup file 

1. Select Save from the Markup menu. 
The Save Markup File As dialog appears. 

 
Figure 3.7: Saving Markup Dialog Box 

 

 

2. Enter the Name for the Markup file 

3. Select the Markup Type. There are three types: normal (default), master and 
consolidated. 

4. From the Read-Only list, select false (default) or true. 

5. Click OK. 
The markup file is saved and remains displayed in the AutoVue viewing window. 

 

To save an existing markup file 

1. Select Save from the Markup menu. 
The markup file is saved and remains displayed in the AutoVue viewing window. 
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3.5 Displaying Existing Markups 
After the selected file displays in AutoVue.  

1. View a file that has existing markups. 

2. From the Markup menu select Open. You can also click on the Markup Indicator icon 

 in the status bar. 
The Markup Files dialog appears.  

 
Figure 3.8: Open Markup Dialog Box 

 

3. Select the markup file to view, and then select the active markup.  

4. Click OK. 

3.6 Promoting Markups 
It is possible to promote markups from an earlier version of a document to the current version.  
When markups are promoted, they are saved against the new version of the document.   

After displaying a file with AutoVue Server, 

1. From the Markup menu select Open. You can also click on the Markup Indicator icon 

 in the status bar. 
The Markup Files dialog appears.  
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Figure 3.9: Markup files of current version base file are listed 

 
2. To display the markup files from previous versions of the base file, select the All 

revisions checkbox.  
The previous markup files are displayed for the previous version of the base file. 

 
Figure 3.10: Markup files for previous version base file can be listed with All Revisions 

 
3. Select one Markup file from the previous version and then click OK. 

The Markup file displays with the current version base file in AutoVue. Additionally, when 
you save the selected markup (with or without any modification), it is saved as the 
markup of the current base file version. 

3.7 Deleting Markups 
After displaying a file with AutoVue. 

1. View a file that has existing markups. 
 

2. From the Markup menu select Open. You can also click the Open Markup icon  
from the Toolbar. 
The Markup Files dialog appears. 

3. Select one or more markups from the list and then click Delete. 
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Figure 3.11: Delete button in Markup Files Dialog  

A prompt appears to confirm the deletion of the selected markups. 

4. Click Yes in the prompt. 
The selected markup file(s) are deleted from the list of markups in the ‘Open markup’ 
dialog box. The Markup Files dialog display the remaining markup files. 
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3.8 Consolidating Markup Files 
The Consolidate option allows you to create a new Markup file that combines copies of 
selected layers of different markup files. During the review cycle, consolidation simplifies 
document revisions by providing the author with one combined Markup file instead of several 
Markup files. Note that the Consolidate option is only active when more than one Markup file 
is opened. 

1. View a file with existing markups. 

2. Open the Markup files that you want to consolidate. 

 
Figure 3.12: Markups Files Dialog  

3. From the Markup menu, select Consolidate. 

The Consolidate Markups dialog appears. 



ISDK - Sample Integration for FileSys User Guide 15 
 

           

 

 

 
Figure 3.13: Consolidate Markups Dialog 

 

4. Select the markup layers that you want to consolidate into one file. To select multiple 
layers, press the Shift or Control key while selecting. 

5. To select all the layers click Select All, and to deselect all the layers click UnSelect All. 

6. In the Name field, enter name for the new Markup file. 

7. Click OK. 
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3.9 Printing Headers, Footers and Watermarks 
With AutoVue, you can print document attributes in a header, footer or as a watermark. 

Select Print from the AutoVue File menu. 

The Print Properties dialog appears. Customize the Print Properties (see below). 

 

Figure 3.14: The print properties setting dialog 

3.9.1   Headers/Footers Group 
From the Headers/Footers tab of the Print Properties dialog, you can define the headers and 
footers that you want to print on every page of the document. You can enter the text manually 
or choose from a list of Insert Codes. Select the Headers/Footers tab.  

The insert codes are: 

• %f: Full path of document 

• %v: Document Drive 

• %d: Document Directory 
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• %b: Document Base name 

• %e: Document file extension 

• %n: Total document pages 

• %p: Current page number 

• %N: Total tiled-pages 

• %P: Current tile number 

• %Y: Date: Year 

• %M: Date: Month 

• %D: Date: Day 

• %W: Date: Day of week 

• %H: Time: Hour 

• %U: Time: Minute 

• %S: Time: Seconds 

• %r: New line 

• %F: Native Print Settings (Excel) 

3.9.2 Watermarks Group 
From the Watermark tab of the Print Properties dialog, you can specify a 
watermark that will appear on a printed file. When printing a watermark, it appears 
transparent on the file contents. You can choose a horizontally or vertically 
oriented watermark.  

In addition to entering text, you can:  

• set the type, size and style of font 

• insert Watermark information  

• print system variables  

To insert Watermark information, AutoVue provides a list of codes that you can 
choose from. These codes are:  

• %f: Full path of document 

• %v: Document Drive 

• %d: Document Directory 

• %b: Document Base name 

• %e: Document file extension 

• %n: Total document pages 

• %p: Current page number 

• %N: Total tiled-pages 

• %P: Current tile number 

• %Y: Date: Year 
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• %M: Date: Month 

• %D: Date: Day 

• %W: Date: Day of week 

• %H: Time: Hour 

• %U: Time: Minute 

• %S: Time: Seconds 

• %r: New line 

• %F: Native Print Settings (Excel) 

3.9.3 Conversion 
Sometimes you need to convert a file to be able to use it with an application it was not created 
from. AutoVue provides several conversion file formats for you. 
Note: 

Currently, PCRS_TIF; PCRS_GP4; PCRS_EPS; PCRS_PCL; PCRS_PCX; PCVC_PDF; 
PCRS_RLC; PCRS_BMP and CSI_META formats are supported by filesys. 

After displaying a file with AutoVue select Convert from the File Menu. The Convert dialog 
appears. The converted file is checked into Filesys DMS repository. 

 
Figure 3.15: The print properties setting dialog 
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3.10 DMS Properties 
With AutoVue it is possible to display the document’s properties.  

1. After displaying a file with AutoVue select Properties from the File menu.  
The Properties dialog appears. 

2. Click on the DMS tab. 
Document properties are displayed (name, size, date of last modification, version 
number, number of versions of this document and author). 

 

 
Figure 3.16: The DMS properties 

3.11 File Compare 
 

With AutoVue it is possible to compare the current version of a document with any of its past 
versions. 
 

1. Open a file in AutoVue. 
2. Select Compare from the Analysis menu. 

The File Open dialog appears. 
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3. Select a version from Document Versions drop down list. 

 

 
Figure 3.17:  File Compare in dialog box 

 
AutoVue displays three windows, the first displaying the original file, the second 
displaying the compare file and the third displaying the comparison results. Additions 
appear in green, deletions in red and unchanged in blue. 

 

 
Figure 3.18:  File Compare in AutoVue applet 
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3.12 Opening a file from a Backend DMS System 
When AutoVue is connected to a backend Filesys Document Management System (DMS) 
system, you can open a file located in the system from the File Open dialog. Depending on the 
backend DMS system you are connected to, you must enter your username and password 
when opening files stored in the backend system. 

1. View a file in AutoVue. 
4. From the File menu select Open. 

The File Open dialog box appears. 
5. To open a file from the backend DMS system, from the left panel, click DMS. 

 
Note: If AutoVue is configured with one DMS system, the name of the DMS would 
appear instead of DMS. If AutoVue is connected to multiple backend DMS systems, a 
list of the DMS system names appear when you click DMS. Select the DMS from 
which you want to open files. 
 
The backend DMS system files appear in the File Open dialog. 

6. Select a file and then click Open. 

3.13 Searching for Files in a Backend DMS System 
When AutoVue is connected to backend DMS system, you can search for files in the system 
by entering specific search criteria in the File Open dialog. 

1. View a file in AutoVue. 
2. From the File menu select Open. 

The File Open dialog box appears. 

3. To search for a file in the backend DMS system, from the left panel, click Search 
DMS. 
 
Note: If AutoVue is configured with a single DMS, the name of the DMS appears 
instead of DMS. If AutoVue is connected to multiple backend DMS systems, a list of 
the DMS system names appear when you click Search DMS. Select the DMS in which 
you want to perform the search. 
 

The search criteria options load in the File Open dialog. 
4. Enter the search criteria and then click Search. 

 
Note: Alternately, to view all files in the backend DMS system, leave the search 
criteria fields empty and click Search. 
 
The file results appear in the dialog. For each AutoVue session, all search results are 
saved and can be referenced from the File Open dialog as Search Results 1, Search 
Results 2, and so on. 
 

5. Select a file and then click Open. 
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3.14 Add new data to the document repository 
With Filesys DMS application you can add new data to the document repository by manually 
creating the data structure or by using a utility class 
com.cimmetry.vuelink.filesys.dms.util.FilesysDataStructureCreator coming 
with filesys.  

3.14.1 Create data structure manually 
To add a new document into the repository, such as “my.dwg”, follow these steps: 
1. Browse to the <filesys data repository unzipped folder>/filesysRepository folder. 
2. You can create a new folder in parallel to “2D”, “3D” and “Meeting” folder or create a new 

folder inside “2D” or “3D” folder. Suppose you want to add the file inside “2D” folder. You can 
name the folder using the file’s name that you want to view, that is, “my.dwg”. This is the 
convention for sample data.  

3. Under this folder, create a new folder for the first revision of the file. Name it “my.dwg(1)” and 
put the file “my.dwg” inside the folder. 

4. If you have another revision for “my.dwg” file, then you can create “my.dwg(2)” folder under 
“my.dwg” folder and put the second revision of the file inside. 

5. If the file “my.dwg” has XRefs, then create an “xrefs” folder under the base file’s folder 
“my.dwg(1)” and put all the XRefs files there. 

 

3.14.2 Add data from IDE 
To add the new data to your document repository, you must execute the main() method of 
com.cimmetry.vuelink.filesys.dms.util.FilesysDataStructureCreator class. 

 
 
 
 
 
 
 
 
 
 
 
 

As shown the figure above, you need to pass in arguments for the main() method. These 
arguments indicate types, versions and locations of the files to add in the repository. You can add 
several types of documents to the repository such as: base documents, XRefs, markups and 
conversions files. We use options <-option> to indicate the document type. Here is the complete 
list the options: 

-url: location of filesys repository 
-b: base file  
-v: version number  

public static void main(String[]  args) {   
    BasicConfigurator.configure(); 

//String[] params = {"-url", "C:/temp/filesysRepository/ECAD", "-b", "C:/program 
files/jVue/html/samples/ECAD/PAD//PADS_ILEARN.pcb"}; 

//params = {"-url", "C:/temp/filesysRepository/2D", "-b", "C:/program 
files/jVue/html/samples/2D/MicroStation.dgn" –v 3}; 
    FilesysDataStructureInfos data = new FilesysDataStructureInfos(); 
    try{ 
 data.constructStructure(args); 
 FilesysDataStructureCreator struct = new FilesysDataStructureCreator(data); 
 struct.createStructure(); 
    }catch(FileNotFoundException fex){ 
 m_logger.error(fex); 
 System.exit(0); 
    }catch(Exception ex){ 
 m_logger.error(ex); 
 System.exit(0); 
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-x: xrefs files 
-m: master markups files 
-n: normal markups files 
-c: consolidated markups files 
-tiff: TIFF conversion file 
-pdf: PDF conversion file 
-meta: metaFile. 

For the first sample argument in the figure above, the url is 
c:\temp\filesysRepository\ECAD (You don’t have to specify the exact destination 
location of a file, you have just to specify the repository location) and the base file is 
PADS_ILEARN.pcb and is located in C:\program files\jVue\html\samples\ECAD\PAD 
folder.   

For the second sample argument, the url is c:\temp\filesysRepository\2D and the base 
file is MicroStation.dgn and is located in C:\program files\jVue\html\samples\2D 
folder.  The version number is 3. 
 
Add data from JDeveloper 
On JDeveloper IDE, to run the FilesysDataStructureCreator class, you need to complete 
the following steps: 

1. Select the filesys project 
2. From the Run menu, select Choose Active Run Configuration, and then select 

Manage Run Configurations… 

 
Figure 3.19: JDeveloper Manage Run Configurations 

 
3. Click New… at the right side of the Project Properties windows, name it addData and 

then click OK. addData appears under the Run Configurations. 
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Figure 3.20: JDeveloper create addData run configuration 1 

 
4. Select addData and click Edit. 
5. Browse to set the Default Run Target to be 

com.cimmetry.vuelink.filesys.dms.util.FilesysDataStructureCreator 
and input Program Arguments. Click OK and OK again to exit. Two sample program 
arguments are  

-url C:/temp/filesysRepository/EDA -b "C:/Program 
Files/jVue/html/samples/EDA//PADS/PADS_ILEARN.pcb" 
       and  
       -url C:/temp/filesysRepository/2D -b "C:/Program 
Files/jVue/html/samples/2D/MicroStation.dgn" –v 3 
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Figure 3.21: JDeveloper create addData run configuration 2 

 
6. Run addData to create new file structure in the filesys repository.  

 
Figure 2.21 JDeveloper run addData 

 
Add data from Eclipse 
On Eclipse IDE, to run the FilesysDataStructureCreator class, you need to complete the 
following steps: 

1. Select the filesys project. 
2. From the RUN menu click on the RUN... artifact. 
3. Select the Java Application item. 
4. Right click and select New from the context menu. 
5. Enter addData in the Name field.  
6. Search the class to execute (the class must have public static main method) 

com.cimmetry.vuelink.filesys.dms.util.FilesysDataStructureCreator 
 



ISDK - Sample Integration for FileSys User Guide 26 
 

           

 

 
Figure 3.22 Eclipse create addData run configuration 1 

 
7. Click the Arguments tab. You can add Program Arguments to create a file. Two sample 

arguments are:  
 -url C:/temp/filesysRepository/EDA -b "C:/Program 
Files/jVue/html/samples/EDA//PADS/PADS_ILEARN.pcb" 
       and  
       -url C:/temp/filesysRepository/2D -b "C:/Program 
Files/jVue/html/samples/2D/MicroStation.dgn" –v 3 
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Figure 13  Eclipse create addData run configuration 2 

 
8. You can click RUN directly from the above to create new file structure in the filesys 

repository or you can click Apply and Close, then click on addData artifact from the RUN 
icon. 

 

 
Figure 24 Eclipse run addData 

 
If you provide the first sample argument when running the addData, from your filesys demo 
application, you can navigate to check the following new repository structure under the EDA 
folder.  
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Figure 3.25: Repository structure for PADS_ILEARN.pcb 

 
If you provide the second sample argument when running the addData, from your filesys demo 
application, you can navigate to check the following new repository structure.  

 
Figure 3.26 Repository Structure for the third version of MicroStation.dgn 
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3.15 Stamp Markup Entity 

To design a Stamp you must use the Stamp Designer tool that is included with the AutoVue 
installation. To launch the tool, go to the <AutoVue installation>\bin folder and double-click 
designer.bat. The Stamp Designer dialog appears. 

 
Figure 3.27: Stamp Designer tool  

 
Refer to the Oracle AutoVue Client/Server Deployment Installation and Configuration Guide for 
more information on the Stamp markup entity and Stamp Designer. 
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3.16 Authentication & Login Dialog 
Before a file can be viewed in the AutoVue applet, you need to provide valid user credential.  
 
You can input your username and password in two ways:  
1. From the Integration SDK home page’s Filesys Demo section.  

Note: On Jdeveloper 11g or with WebLogic version 10.3.1 above, this way of logging in is 
not valid to view a file in AutoVue. 

 
Figure 3.36: Filesys Demo - Login 

2. When the Authorization information dialog appears. 
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Figure 3.37: Filesys Demo - Authorization information dialog 

After you enter your user name and password in the Authorization information dialog and 
then click OK, the file you want to view will start to load.  
Note: You can refresh the Web browser to view user information on the Filesys Demo page. 
In doing so, the AutoVue applet restarts and you need to click the file to view again.  If the 
AutoVue applet is started in a new window, there will be two AutoVue applet windows 
available and you should to close the previous one.  

3.17 Embedded vs. New Window 
Based on the configuration of Integration SDK Demo, the AutoVue applet can be launched in 
an embedded window or in a new window. Refer to Integration SDK Installation Guide for 
more information. 
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Figure 3.38: Filesys Demo - AutoVue launched in embedded window 
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Figure 3.39: Filesys Demo – AutoVue launched in new window 

 

3.18 Pop-up Blocker  
When the AutoVue applet is configured to open in a pop-up window and the pop-up blocker 
prevents the showing of AutoVue applet, user will be alert about it.  
 
1. Set up Pop-up blocker for Web browser 
 

For IE: 
o From the Tool menu, select Pop-up Blocker and then select Turn on Pop-up 

Blocker. 
o From the Tool menu, select Pop-up Blocker and then select Pop-up Blocker 

Settings and remove allowed site 
o From the Tool menu, select Internet Options. 

The Internet Options dialog appears. 
o Click the Security tab and then select Local Intranet. 
o Click Sites and then deselect all the checkboxes. 
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Figure 3.40: Deselect all the check boxes 

 
For FireFox: 
 
o From the Tools menu, select Options. 

The Options dialog appears. 
o Click Content and then select the Block popup windows checkbox. 
o To the right of Block popup windows click Exceptions and then remove the 

exception website 
 

2. Close Web browser and re-launch. 
3. Browse to Filesys Demo page. 

The following alert dialog appears when Filesys tries to launch AutoVue in pop-up mode. 
Click OK to close this alert dialog. 

 

 
Figure 3.41: Alert dialog 

 
4. Click to enable pop-ups for the Web browser and refresh the browser. 

 
Figure 3.42: Enable pop-ups in IE 
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Figure 3.43: Enable pop-ups in FireFox 

3.19  Image Preview 
Generate BMP rendition for a file using AutoVue Web Services or using Conversion from 
AutoVue (See 2.9.3 Conversion).  
 
Go to filesys demo page (See 2.1 Filesys Demo Page) 

 

3.20  Prompt to Save Markup on Exit 
1. View a file in AutoVue 
2. Create or update a markup 
3. Close the AutoVue applet window. 

The Save Markup dialog appears. 
 

 
Figure 3.44: Save Markup dialog 

 
If No or Cancel is clicked, the AutoVue applet closes without saving the markup. 
If Yes is clicked, the Save Markup File As dialog appears and lets you save the markup. 
 

  
Figure 3.45: Save Markup File As dialog 
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4 Real-Time Collaboration Demo 

4.1 Real-Time Collaboration Demo page 
1. From the Oracle AutoVue Integration SDK demo home page, click Real-Time 

Collaboration Demo to launch the Oracle AutoVue Real-Time Collaboration (RTC) 
Demo page. 

The RTC demo page contains three parts: 

o Instructions 

o Start Meeting 

o Join Meeting 

 

 
Figure 4.1: RTC Demo 

 

2. Prior to starting or joining a meeting,read the instructions carefully. 



ISDK - Sample Integration for FileSys User Guide 37 
 

           

 

4.2 Start a Meeting 
1. Input a new Meeting ID or use the default one. 
2. Select a Meeting File from the drop-down list. 
3. Click Start Meeting. 

A window opens and launches AutoVue. Verify that the AutoVue Server is running. 
4. In the Authorization information dialog, enter rtc in Username field and rtc in Password field. 

Note that the Authorization information dialog always opens in this RTC demo. 
The meeting file is launched; AutoVue enters collaboration mode and displays an empty 
DemoRealTimeCollaboration markup entity. As shown in the following figure, the AutoVue 
status bar shows that “User rtc has been assigned to be the new host”. 

 
Figure 4.2: Starting a meeting 

4.3 Join a Meeting 
1. Input a Meeting ID that has been used to start a meeting. 
2. Click Join Meeting and a window opens to launch AutoVue.  
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3. In the Authorization information dialog, enter a valid username and password. 
For example, username rtc1 and password rtc1. 

4. AutoVue enters collaboration mode and displays the ongoing meeting. At the bottom of the 
AutoVue status bar, it shows “User *** has joined the session”. 
Note that the user name for the Windows system is used instead of the username input in the 
Authorization dialog. 

4.4 Conduct Meeting 
During the meeting, users can create markups, chat, request/pass control, change meeting 
documents and so on. Refer to the “Real-Time Collaboration” section of the AutoVue User’s 
Manual for more information. The following describes specific tasks when browsing Meeting 
document for Filesys. 

 
Step 1: 
• From the AutoVue menu bar, select File and then Browse… or select File, then select 

Open File and then click DMS. 
• Click Meeting folder to show meeting files 
• Select a file and click OK 
• AutoVue launches the file 
 

 
Figure 4.3: File Open dialog 
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Step 2: 
• From AutoVue GUI, click File -> Browse… or File -> Open File -> DMS 
• Click and select any other file that is not listed in the Meeting folder 
• Click OK 
• Choose to save or not save previous collaboration markup in the pop-up 

windows  
• AutoVue launches the file. 
 
Step 3: 
• From AutoVue GUI, click File -> Browse… or File -> Open File -> DMS 
• Click Meeting folder to show meeting files 
• The file viewed in step2 is listed among the meeting files 

4.5 Close Meeting 
1. From AutoVue GUI, the Host of the meeting selects Collaboration, and then selects 

Close Collaboration Session.. 
2. Click OK to save collaboration markup 
3. Launch Filesys Demo and browse the Meeting folder. 

A chat file will present that records chat content during the collaboration session 
 

 
 
 

Figure 4.4: Chatfile 
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5 Oracle Enterprise Visualization Framework Demo 
1. From the Oracle AutoVue Integration SDK demo home page, click OEVF Demo to launch the 

Oracle AutoVue OEVF Demo page. 

 
Figure 5.1: Starting a meeting 

 

2. Review the descriptions on the OEVF Demo page. 
3. Click a link in the demo page. 

AutoVue launches in a pop-up window. 
4. Enter username and password in the Authorization dialog. 
5. AutoVue launches the file and presents the designed GUI. 
6. Perform actions based on the description for the link in OEVF Demo page. 
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6 Feedback Section 
If you have any questions or require support for AutoVue please contact your system 
administrator. If at any time you have questions or concerns regarding AutoVue, please 
contact us. 

6.1 General AutoVue Information 
 
Telephone +1.514.905.8434 or 1.800.363.5805 
Web Site: http://www.oracle.com/us/products/applications/autovue/index.html 
Blog: http://blogs.oracle.com/enterprisevisualization/ 

6.2 Oracle Customer Support 
Web Site: http://www.oracle.com/support/index.html 
 

6.3 My Oracle Support AutoVue Community 
Web Site: https://communities.oracle.com/portal/server.pt 

 

6.4 Sales Inquiries 
    E-mail: autovuesales_ww@oracle.com 
 
 
 

http://www.oracle.com/us/products/applications/autovue/index.html�
http://blogs.oracle.com/enterprisevisualization/�
http://www.oracle.com/support/index.html�
https://communities.oracle.com/portal/server.pt�
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