Go to main content

Using Puppet to Perform Configuration Management in Oracle® Solaris 11.4

Exit Print View

Updated: October 2019
 
 

What's New in Puppet in Oracle Solaris 11.4

Puppet 5.5. Oracle Solaris 11.4 includes Puppet 5.5. Oracle Solaris 11.3 includes Puppet 3.6. If Puppet is already installed on the system, Puppet is automatically updated to Puppet 5.5 when you update to Oracle Solaris 11.4. You cannot choose to install a different version of Puppet.

While Puppet is updated automatically, you must update the Puppet configuration manually. See Puppet Documentation for how to maintain and update the Puppet configuration.

The Puppet web site does not include information about updating Oracle Solaris SMF service property values. Any SMF service property values that are already configured are migrated automatically when you update. However, you must manually remove any obsolete values and update any values that need to be changed. See Configuring the Puppet Master and Agents.