Primavera Unifier 9.11.0.0
Users Guide
December 2012
Copyright

Copyright © 1998, 2012, Oracle and/or its affiliates. All rights reserved.

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

The platform-specific hardware and software requirements included in this document were current when this document was published. However, because new platforms and operating system software versions might be certified after this document is published, review the certification matrix on the My Oracle Support Web site for the most up-to-date list of certified hardware platforms and operating system versions. The My Oracle Support Web site is available at the following URL:

http://support.oracle.com/

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT END USERS: Oracle programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, delivered to U.S. Government end users are “commercial computer software” pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, shall be subject to license terms and license restrictions applicable to the programs. No other rights are granted to the U.S. Government.

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate failsafe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

This software or hardware and documentation may provide access to or information on content, products and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.

To view the list of third party technology disclosures related to this product, please see the Notices and Disclosures document for the release.
CONTENTS

Introduction.......................................................................................................................... 1
Welcome to Primavera Unifier............................................................................................... 2

Getting Started....................................................................................................................... 3
Information for First Time Users.......................................................................................... 4
If You Need Help ................................................................................................................... 5
Online Help............................................................................................................................ 5
To Access Online Help: ......................................................................................................... 5
Where To Get Support ........................................................................................................... 5
Access To Oracle Support ...................................................................................................... 5
  Additional Support ............................................................................................................... 6
Logging In and Out ................................................................................................................ 7
Logging into the Self-Service Portal...................................................................................... 8
Navigating in Primavera Unifier ........................................................................................... 9
User Home Page .................................................................................................................. 10
Navigator ................................................................................................................................ 11
Navigational tabs .................................................................................................................. 12
Modes of Operation ............................................................................................................. 13
Breadcrumbs .......................................................................................................................... 14
Using Bookmarks To Access Primavera Unifier Nodes ...................................................... 15
User Preferences .................................................................................................................. 16
Viewing your contact information ...................................................................................... 17
Changing your password ..................................................................................................... 18
  To view your company’s password policy ...................................................................... 18
  To add Secret Questions to use when resetting your password ................................... 19
Adding secret questions for password reset ...................................................................... 20
Change time zone or date format ....................................................................................... 21
Choose a file viewer option ................................................................................................. 22
Choose a file transfer option ............................................................................................... 23
Select email subscription options ....................................................................................... 25
Choose a proxy user ............................................................................................................. 28
Log in as a proxy user .......................................................................................................... 30

General Procedures............................................................................................................. 32
or working With The Company Summary ................................................................. 63
Available company-level standard reports .......................................................... 64

Projects .................................................................................................................. 66

Open a project ........................................................................................................... 67
What you can do in a project .................................................................................... 68
View project location map ....................................................................................... 69
About Project Statuses ............................................................................................. 70
Working with the Project Summary ......................................................................... 71
To access the project summary ................................................................................ 71
To print a project summary ...................................................................................... 71
 Configure your project summary .............................................................................. 71
Available project-level standard reports ................................................................. 72
To add reports to the user view ................................................................................. 72
To move or delete blocks on the Project Summary - User View ................................ 74
To change the display type, title, or other block property ...................................... 74
Managing Project Alerts ......................................................................................... 75
Working with uMail .................................................................................................. 77
View and find uMail Messages ................................................................................ 78
Send and receive uMail ............................................................................................ 79
Link uMail messages to business process records ............................................... 82
Using the Project Mailbox ......................................................................................... 83
To open the Project Mailbox ..................................................................................... 83
To open an email ....................................................................................................... 83
To flag an email for follow-up .................................................................................. 83
To reply to an email ................................................................................................ 83
To forward an email ................................................................................................ 84
To delete an email ..................................................................................................... 84
To print an email ...................................................................................................... 84
To find a specific email ............................................................................................. 84
Distribute the Project Mailbox Email Address to Users ........................................ 86
 About Tasks, Messages, And Drafts .................................................................... 86
View project information ......................................................................................... 87
View the general (business process) log ................................................................. 88
View the Project Directory ....................................................................................... 89
Search for project team members .......................................................................... 90
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print the shell dashboard</td>
<td>121</td>
</tr>
<tr>
<td>Navigate through the shell block drilldown</td>
<td>122</td>
</tr>
<tr>
<td>Set filters</td>
<td>123</td>
</tr>
<tr>
<td>Use drilldown</td>
<td>124</td>
</tr>
<tr>
<td>Scroll the vertical y-axis in dashboard graph</td>
<td>125</td>
</tr>
<tr>
<td>Configuring a shell dashboard (My Dashboard)</td>
<td>126</td>
</tr>
<tr>
<td>View dashboards</td>
<td>129</td>
</tr>
<tr>
<td>Add a drilldown block to my dashboard</td>
<td>130</td>
</tr>
<tr>
<td>Add filtering to the drilldown block</td>
<td>132</td>
</tr>
<tr>
<td>Optimizing Shell Dashboard Performance</td>
<td>132</td>
</tr>
<tr>
<td>Working with Shells</td>
<td>133</td>
</tr>
<tr>
<td>Open a shell</td>
<td>134</td>
</tr>
<tr>
<td>Auto-Create Shells (or Projects)</td>
<td>134</td>
</tr>
<tr>
<td>Working With Shell Features</td>
<td>137</td>
</tr>
<tr>
<td>Auditing shell changes</td>
<td>138</td>
</tr>
<tr>
<td>Adding An Image</td>
<td>138</td>
</tr>
<tr>
<td>Managing Shell Alerts</td>
<td>138</td>
</tr>
<tr>
<td>Working with uMail</td>
<td>140</td>
</tr>
<tr>
<td>Access uMail</td>
<td>141</td>
</tr>
<tr>
<td>Send and receive uMail</td>
<td>142</td>
</tr>
<tr>
<td>Link uMail messages to business process records</td>
<td>145</td>
</tr>
<tr>
<td>Using the Shell Mailbox</td>
<td>146</td>
</tr>
<tr>
<td>Collaborating With Team Members</td>
<td>148</td>
</tr>
<tr>
<td>View Shell Information</td>
<td>148</td>
</tr>
<tr>
<td>Contact Shell Team Members</td>
<td>148</td>
</tr>
<tr>
<td>Auto-Population and Reverse Auto-Population in Shells</td>
<td>150</td>
</tr>
<tr>
<td>Reverse Auto-population In Shells</td>
<td>150</td>
</tr>
<tr>
<td>Working with Gates and Phases</td>
<td>152</td>
</tr>
<tr>
<td>View Gate Condition Details</td>
<td>152</td>
</tr>
<tr>
<td>Validate gate conditions manually</td>
<td>153</td>
</tr>
<tr>
<td>Edit Phase Details</td>
<td>153</td>
</tr>
<tr>
<td>Advance A Shell To The Next Phase</td>
<td>153</td>
</tr>
<tr>
<td>Return To A Previous Phase</td>
<td>154</td>
</tr>
<tr>
<td>Add Or View Phase Comments</td>
<td>154</td>
</tr>
<tr>
<td>Monitoring Gates</td>
<td>154</td>
</tr>
</tbody>
</table>
Creating a Business Process record from a template ................................................................. 222
Creating Business Process Templates and Scheduling Business Process Creation ....... 223
Create a business process template .......................................................................................... 224
Change template status (Draft and Complete) ................................................................. 226
Schedule automatic business process record creation based on the template ............ 227
Edit or delete a business process template ............................................................................. 229
Edit or cancel a business process schedule ............................................................................ 230
Completing the Forms ............................................................................................................. 231
Fill out the form ........................................................................................................................ 232
Save a draft of a business process ............................................................................................ 234
Adding and Managing Line Items ............................................................................................ 235
Add line items using a line-item entry form ............................................................................ 236
Edit or remove line items ......................................................................................................... 237
Add and manage summary line items ..................................................................................... 238
Filter the line item list ............................................................................................................. 239
Copy a line item from the same form ....................................................................................... 240
Copy and consolidate line items from different business process forms ...................... 241
Adding and Managing Line Items Using the Grid Feature ................................................... 244
Add line items using the Grid .................................................................................................. 247
Link line items to other business process records ............................................................... 248
Edit line items using the Grid .................................................................................................. 249
Insert a row into the grid ......................................................................................................... 250
Manually create a business process from the Grid ............................................................... 251
Copy a line item on the Grid .................................................................................................... 252
Adding and Managing General Comments ........................................................................... 253
Add comments to a business process form ......................................................................... 254
Add comments to a document type business process ....................................................... 255
View comments ....................................................................................................................... 256
Edit or delete comments .......................................................................................................... 257
Hide comments ......................................................................................................................... 258
Add comments to an attached document ............................................................................ 259
Working With File Attachments And Markups ................................................................. 260
Attach Files To Business Process Forms .............................................................................. 260
Attach Files To Document-type Business Process Forms .................................................. 261
Remove Attachments From A Document Type Business Process.................................... 262
Modify Step Due Date ........................................................................................................ 296
Add Additional Assignees Or Send An Additional Copy ............................................. 296
Add Or View A Task Note ................................................................................................ 297
Completing Tasks Via Email .............................................................................................. 297
Taking Action On Multiple Tasks At The Same Time (Bulk Action) ....................... 298
Participating In A Discussion Group ............................................................................. 299
Initiate A Discussion Group ............................................................................................. 300
Close A Discussion Group ............................................................................................... 300
Participate In A Discussion Group .................................................................................. 300
Copying And Consolidating Comments And Markups ............................................. 301
Copy Or Consolidate Text Comments ............................................................................ 301
Copy Or Consolidate Graphic Markups .......................................................................... 303
Track A Step Through The Workflow ........................................................................... 304
Managing Business Process Records ........................................................................... 305
Transferring Ownership ................................................................................................. 305
Granting Business Process Record Permissions .......................................................... 305
About Editing Records .................................................................................................... 306
  Edit A Business Process Form ...................................................................................... 306
If you are an editor on a business process ..................................................................... 308
  Edit business process records in a Master Log ............................................................. 309
    Edit Multiple Records In Bulk .................................................................................... 309
Use bulk editing on business process records in a Master Log ................................... 311
Auditing Business Processes ......................................................................................... 311
  View and print the business process audit log .............................................................. 312
Printing and Distributing Business Process Forms .................................................... 313
  Print a business process form in PDF or HTML format ............................................... 314
Print using a custom layout ............................................................................................. 316
  Send A PDF Copy Of A Business Process Form Via UMail ......................................... 317
Business Processes with Special Behaviors ................................................................. 318
  SOVs And Business Processes ..................................................................................... 318
    View An SOV Sheet From The Business Process Form ............................................ 318
    Create SOV Breakdowns ......................................................................................... 318
    View Or Edit Fund Transaction Details From The Business Process Form .......... 318
    Commit And Change Commit (composite View Details) ........................................ 318
Payment Application Business Processes .................................................................... 319
Enter Payment Application Line Item Information ............................................. 319
View Payment Application Line Item History .................................................. 320
Export Line Item History ................................................................................. 321
Save Payment Application In Draft Mode ......................................................... 321
Draft Mode And SOV Synchronization ............................................................... 321
View The Schedule Of Values Sheet ................................................................. 321
Import new payment application records ......................................................... 323
Import payment application line items into a BP .............................................. 325
Request For Bid Business Processes ................................................................. 326
How RFBs Work ............................................................................................... 326
Send The Bid Request For Internal Review And Approval ............................... 327
Start The Bidding Process .............................................................................. 327
Compare The Bids ............................................................................................ 328
Bid Comparison Options .................................................................................. 329
What The Vendor Does .................................................................................... 330
General Spends Business Processes ................................................................. 333
Import new general spends records ................................................................. 334
Import general spends line items into a business process ............................... 336
Change Commit Business Processes ................................................................. 338
Import new change commit records ............................................................... 339
Import change commit line items into a BP ..................................................... 340
Lease Business Processes ................................................................................ 341
Lease Business Process Terminology .............................................................. 342
Lease Business Process Use Cases .................................................................. 342
Various Payment Terms for the same lease ..................................................... 342
Different payment allocations for multiple tenants ....................................... 342
Semi-annual lease terms with proration ......................................................... 342
Handling rent pre-payments .......................................................................... 342
Straight lining with quarterly payments ......................................................... 342
Straight Lining with monthly payments .......................................................... 343
Lease term of 20 years with escalation ............................................................ 343
Create And Manage Lease Business Processes .............................................. 343
Create and use an allocation template .............................................................. 345
View Or Export Payment Schedule ................................................................. 346
Auto-create An Invoice Or Payment Request From A Lease Business Process... 346
Asset Manager

About the Asset Manager
Creating And Managing Assets
Access The Asset Manager
Asset Manager Navigation And Asset Codes
Create A New Asset
Working With Asset Sheets
Access Asset Sheets
View Asset And Column Details
View Asset Sheet Properties
Enter Or Edit Asset Sheet Data
Create And View A Snapshot
Import Asset Sheet Column Data
Copy Data From One Column To Another
Search For Assets On An Asset Sheet
Export Asset Sheet Or Summary Sheet Data
Understanding Reverse Auto-population
Edit Assets Using Bulk Process From The Asset Log
Print An Asset Form
Print Options

Configurable Managers

About Configurable Managers
Code-and-Record-based Configurable Managers
Code-based Configurable Managers
Access A Configurable Manager
Reverse Auto-population And Code- And Record-Based Managers
Creating Sheets And Records For A Code-and-Record-based Manager
Create Records For Classes
Create A New Sheet From An Existing Template
Creating Sheets For A Code-based Manager
Working With Configurable Manager Sheets
Create A New Sheet From An Existing Template
Add Columns To A Sheet
View Column Properties
Add A Formula Column ................................................................. 364
Open a sheet .............................................................................. 366
   Expand Or Collapse The Sheet Rows .................................. 366
Drill down to more data ............................................................ 368
View or edit code details ........................................................... 369
   For a code-and-record-based manager .................................. 369
   For a code-and-record based manager ................................... 369
View Rollup Data ...................................................................... 369
Sort the sheet content ............................................................... 370
   Filter The Sheet Content ..................................................... 370
   View Sheet Properties ....................................................... 371
   Enter Sheet Data ................................................................ 371
Edit sheet data ........................................................................ 372
   Create And View A Snapshot ............................................. 372
   Copy Data To Another Column .......................................... 372
Search For Records On A Sheet .................................................. 372
Export Sheet Data .................................................................... 373
Import Sheet Column Data ......................................................... 373
Bulk Editing Configurable Manager Records .......................... 373
Print A Configurable Manager Form ....................................... 374
Print Options ........................................................................... 375
Cost Manager .......................................................................... 376
   Cost Manager Overview ..................................................... 377
      Cost Sheets .................................................................... 377
      Funding Manager .......................................................... 377
      Cash Flow and Cash Flow (basic) .................................... 378
      Earned Value .................................................................. 378
      Schedule of Values ........................................................ 378
      Generic Cost Manager .................................................... 378
      About Cost Managers and Primavera Unifier functional areas ......................................................... 378
Working with Cost Sheets ......................................................... 380
About Rules and Rule Exceptions ............................................. 381
Working with Project or Shell cost sheets ................................. 382
   Open A Project Or Shell Cost Sheet .................................... 382
   Resize Cost Sheet Window .................................................. 383
<table>
<thead>
<tr>
<th>Page Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify Worksheet Default View</td>
</tr>
<tr>
<td>Add A Worksheet Column To The Cost Sheet</td>
</tr>
<tr>
<td>Assign Permissions To The Worksheet</td>
</tr>
<tr>
<td>Import Worksheet Column Details</td>
</tr>
<tr>
<td>Export Worksheet Details</td>
</tr>
<tr>
<td>Working With The Program Cost Sheet</td>
</tr>
<tr>
<td>Open The Program Cost Sheet</td>
</tr>
<tr>
<td>Search For Project Or Shells (rows)</td>
</tr>
<tr>
<td>Export Program Cost Sheet Data</td>
</tr>
<tr>
<td>Import Program Cost Sheet Data</td>
</tr>
<tr>
<td>Working With The Company Cost Sheet</td>
</tr>
<tr>
<td>Open The Company Cost Sheet</td>
</tr>
<tr>
<td>View Or Edit Company Cost Sheet Properties</td>
</tr>
<tr>
<td>Search For Project Or Shells (rows)</td>
</tr>
<tr>
<td>Export Company Cost Sheet Data</td>
</tr>
<tr>
<td>Import Company Cost Sheet Data</td>
</tr>
<tr>
<td>Working with Company Accounts Sheets</td>
</tr>
<tr>
<td>Open The Accounts Sheet</td>
</tr>
<tr>
<td>Activate Or Deactivate Account Codes</td>
</tr>
<tr>
<td>View Or Edit Accounts Sheet Properties</td>
</tr>
<tr>
<td>About The Funding Manager</td>
</tr>
<tr>
<td>Company and project/shell funding</td>
</tr>
<tr>
<td>Commitment level funding</td>
</tr>
<tr>
<td>Company Funding Sheet vs. Project or Shell Funding Sheets vs. Commitment Funding Sheets</td>
</tr>
<tr>
<td>Working With The Company Funding Sheet</td>
</tr>
<tr>
<td>Open The Company Funding Sheet</td>
</tr>
<tr>
<td>About Company Funding Sheet Columns</td>
</tr>
<tr>
<td>About Company Funding Sheet Rows</td>
</tr>
<tr>
<td>Add Currency Amounts To Company Funds</td>
</tr>
<tr>
<td>Activate Or Deactivate Company Funds</td>
</tr>
<tr>
<td>Import Or Export Company Funding Sheet Information</td>
</tr>
<tr>
<td>Working With Project Or Shell Funding Sheets</td>
</tr>
<tr>
<td>Open A Project Or Shell Funding Sheet</td>
</tr>
<tr>
<td>About Project/shell Funding Sheet Columns</td>
</tr>
<tr>
<td>About Project/shell Funding Sheet Rows</td>
</tr>
</tbody>
</table>
View Project/Shell Funding Sheet Properties ........................................... 412
About Project/Shell Funding Assignment Options .................................. 413
View Funding Sheet Cell Details ............................................................... 414
Allocating Funds To A Project Or Shell .................................................. 414
Manually Enter Project/shell Fund Allocation Amounts ............................ 414
Allocate Funds Through Business Processes ........................................ 415
Assigning And Crediting Project/Shell Funds ......................................... 416
View Unassigned Amounts .................................................................... 416
Manual Vs. Automatic Fund Assignment ................................................ 417
  Manual fund assignment........................................................................ 417
  Automatic fund assignment................................................................... 417
About Crediting Funds ........................................................................... 417
About Business Processes Enabled For Funding ...................................... 418
Manually Assign Or Credit Funds (unassigned Funds) ............................. 418
Reassign Project/shell Funds From A Business Process Record ................ 420
Searching For Fund Codes .................................................................... 420
Creating And Applying Filters ................................................................ 421
Create And Manage Filters On A Project/shell Funding Sheet ................. 422
Apply A Filter To Limit The Fund Code Display ..................................... 423
Importing And Exporting Project/Shell Funding Sheet Information .......... 423
  Export Funding Sheet Information ....................................................... 423
  Import And Export Fund Details ........................................................ 424
Working with Commitment Funding Sheets ............................................ 425
Create a commitment funding sheet structure ....................................... 426
Create a commitment funding sheet ....................................................... 427
Grant permission to a commitment funding sheet ................................... 428
Grant Permission To A Commitment Funding Sheet ................................ 428
Access commitment funding sheets ....................................................... 429
About commitment funding columns ..................................................... 430
About commitment funding sheet rows ................................................. 431
View or edit commitment funding sheet properties ............................... 432
About commitment funding assignment options ................................... 433
  Assignment rules .............................................................................. 433
  Fund Assignment details per SOV line ................................................. 433
Allocating funds for commitment funding ............................................. 435
Add and manage commitment funding sheet rows (funds) ........................................... 436
Allocate fund amounts to a commitment funding sheet row ........................................ 437
Assigning and crediting commitment level funds ......................................................... 438
About business processes enabled for commitment funding ........................................ 439
View Unassigned amounts (Commitment Level) ......................................................... 440
Assigning or crediting unassigned funds on the commitment funding sheet ............ 441
Manually assign or credit unassigned funds ............................................................... 441
Automatic fund assignments at the commitment level ................................................ 442
View Audit Logs ........................................................................................................... 442
About Schedule Of Values ........................................................................................... 442
Types Of SOVs ............................................................................................................ 443
Creating An SOV Structure ........................................................................................ 443
Creating General SOV Sheets ..................................................................................... 444
Creating SOVs For Payment Applications ................................................................ 445
Grant Permissions To Other Users .............................................................................. 445
Managing SOV Structure, Templates, And Sheets ....................................................... 445
Edit SOVs .................................................................................................................... 445
Edit SOV Columns ....................................................................................................... 446
Delete An SOV Sheet ................................................................................................. 446
Search For SOV Sheets .............................................................................................. 446
Manage SOV Sheet Data ............................................................................................ 447
Export SOV Data ......................................................................................................... 447
View Or Edit SOV Sheet Properties ............................................................................ 447
Add or delete WBS Breakdowns on an SOV Sheet ...................................................... 448
Add breakdowns to SOV sheet by importing .............................................................. 449
About Cash Flow ......................................................................................................... 450
Granting Cash Flow User Mode Permissions .............................................................. 451
Portfolio Manager Budget curves .............................................................................. 452
Cash flow curves ......................................................................................................... 453
General Information About Curves ............................................................................. 453
Properties settings ...................................................................................................... 453
Distribution Profiles ................................................................................................... 455
Cash Flow Properties General Tab ............................................................................ 455
Cash flow properties curves tab ................................................................................ 458
Cash Flow Properties Settings On The Curves Tab ..................................................... 458
Add A Baseline Curve ................................................................. 458
Add A Spends Curve ............................................................... 462
Add A Forecast Curve ............................................................ 463
Add a Portfolio Curve ............................................................. 466
Add A Custom Curve ............................................................. 467
Cash Flow Properties Filter Tab ............................................ 469
Cash Flow Properties Options Tab ....................................... 469
Cash Flow Properties Schedule Tab ..................................... 469
Cash flow properties Summary Curves ..................................... 471
Create a Cash flow curve from a Schedule Sheet .................. 474
Cash flow curve from a template ........................................... 476
Create a commitment detail level curve from a commit BP record .............................................................. 477
Copy Cash flow curves and curve data .................................. 478
cash flow worksheets ............................................................. 480
Graph ...................................................................................... 480
Split screen ............................................................................ 480
Zoom level .............................................................................. 480
Curve columns ....................................................................... 481
Curve data distribution ......................................................... 481
Commitment curves’ transaction and project currency views ................................................................. 481
Curve replication ................................................................. 481
Transaction Currency in cash flow curves .......................... 483
General Currency Information ............................................ 483
Transaction Currency In Curves ......................................... 483
Cash Flow Details Window .............................................. 483
Import cash flow data .......................................................... 486
Use Bulk Edit to edit cash flow data for multiple rows on the Details window .................................................. 488
Filter The Curves To Display On The Cash Flow Worksheet ................................................................. 488
Create and manage distribution profiles ............................... 490
View and manage cash flow properties ................................. 491
Activate or deactivate rollup status ..................................... 492
Add curves to the detail curve cash flow worksheet ............ 493
Delete cash flow curves .......................................................... 494
View summary cash flow data ............................................... 495
Printing Cash Flow Curves .................................................... 496
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Refresh cash flow curves</td>
<td>497</td>
</tr>
<tr>
<td>What refresh does</td>
<td>497</td>
</tr>
<tr>
<td>Unassigned field</td>
<td>497</td>
</tr>
<tr>
<td>Search for cash flow curves</td>
<td>499</td>
</tr>
<tr>
<td>Working with snapshots</td>
<td>500</td>
</tr>
<tr>
<td>Program-Level and Company-Level Cash Flow</td>
<td>502</td>
</tr>
<tr>
<td>What else you can do with a roll-up curve</td>
<td>503</td>
</tr>
<tr>
<td>About Cash Flow (Basic)</td>
<td>503</td>
</tr>
<tr>
<td>About Cash Flow Sheets In Cash Flow (Basic)</td>
<td>503</td>
</tr>
<tr>
<td>Types Of Cash Flow Curves In Cash Flow (Basic)</td>
<td>504</td>
</tr>
<tr>
<td>Creating Cash Flow Sheets</td>
<td>504</td>
</tr>
<tr>
<td>Access Project Or Shell Cash Flow Sheets In Cash Flow (Basic)</td>
<td>504</td>
</tr>
<tr>
<td>Define The Cash Flow Timescale In Cash Flow (Basic)</td>
<td>505</td>
</tr>
<tr>
<td>Create A Project Or Shell Cash Flow Sheet In Cash Flow (Basic)</td>
<td>505</td>
</tr>
<tr>
<td>Define Curve Properties For Calculations In Cash Flow (Basic) (Options Tab)</td>
<td>506</td>
</tr>
<tr>
<td>Create A Calculation Curve That Allows Manual Data Entry In Cash Flow (Basic)</td>
<td>507</td>
</tr>
<tr>
<td>Undistributed amount</td>
<td>508</td>
</tr>
<tr>
<td>View Project Or Shell Cash Flow For Data And Graphs In Cash Flow (Basic)</td>
<td>508</td>
</tr>
<tr>
<td>View Project Or Shell Cash Flow Data From Multiple Sheets In Cash Flow (Basic)</td>
<td>509</td>
</tr>
<tr>
<td>Multiple cash flow sheets, table view</td>
<td>509</td>
</tr>
<tr>
<td>Multiple cash flow sheets, graph view</td>
<td>509</td>
</tr>
<tr>
<td>Cash Flow Curves window</td>
<td>510</td>
</tr>
<tr>
<td>Manage Project Or Shell Cash Flow Curves In Cash Flow (Basic)</td>
<td>510</td>
</tr>
<tr>
<td>Assign A Data Source To A Project Or Shell Cash Flow Curve In Cash Flow (Basic)</td>
<td>511</td>
</tr>
<tr>
<td>Refresh Project Or Shell Cash Flow Curve Data In Cash Flow (Basic)</td>
<td>511</td>
</tr>
<tr>
<td>Working With Program Cash Flow Sheets In Cash Flow (Basic)</td>
<td>511</td>
</tr>
<tr>
<td>Access Program Cash Flow Curves In Cash Flow (Basic)</td>
<td>512</td>
</tr>
<tr>
<td>Create A Program Cash Flow Sheet In Cash Flow (Basic)</td>
<td>512</td>
</tr>
<tr>
<td>Manage Program Cash Flow Curve Properties In Cash Flow (Basic)</td>
<td>513</td>
</tr>
<tr>
<td>Refresh Program And Company-level Curves In Cash Flow (Basic)</td>
<td>514</td>
</tr>
<tr>
<td>Working With Company Cash Flow Sheets In Cash Flow (Basic)</td>
<td>515</td>
</tr>
<tr>
<td>Access Company Cash Flow Curves In Cash Flow (Basic)</td>
<td>515</td>
</tr>
<tr>
<td>Manage Company Cash Flow Curve Properties In Cash Flow (Basic)</td>
<td>515</td>
</tr>
<tr>
<td>Refresh Company Level Curves In Cash Flow (Basic)</td>
<td>515</td>
</tr>
<tr>
<td>Print Cash Flow Curves In Cash Flow (Basic)</td>
<td>516</td>
</tr>
</tbody>
</table>
Filter Earned Value sheets by progress ................................................................. 539
  Save A Snapshot Of The Earned Value Sheet .................................................. 540
  Export Earned Value Data .............................................................................. 540
  Refresh Earned Value Sheets .......................................................................... 540
  Display Earned Value Data As A Graph .......................................................... 540
Working with a Generic Cost Manager ............................................................... 543
  Data Sources For Generic Cost Sheets ............................................................... 543
  Working With Generic Cost Sheets .................................................................. 543
  Open A Generic Cost Sheet .............................................................................. 544
  Viewing Data For Shells And Subshells In A Generic Cost Sheet ...................... 544
  Change The Timescale On A Generic Cost Sheet .............................................. 545
  Modify Shell And Base Exchange Rates For Manual Data Entry ..................... 546
  Export And Import Generic Cost Sheet Data ................................................... 547
  Import Generic Cost Sheet Data ...................................................................... 547
  Working With Generic Cost Business Processes .............................................. 547
  View And Edit The Commitment Summary ..................................................... 548
  Drill Down From The Commitment Summary To Related BPs ......................... 548

Document Manager ............................................................................................. 549
  About the Document Manager ......................................................................... 550
  Before You Begin ............................................................................................... 550
  About Ownership And Permissions .................................................................. 551
  Enable Document Manager-generated E-mail Notification .............................. 551
Automatic Publishing of Business Process Records to the Document Manager .... 553
Working with Project or Shell and Company Documents ................................. 554
  Access Project Or Shell Documents And Company Documents ....................... 554
  Project Or Shell Documents And Company Documents Navigation ................ 554
  Project Or Shell Documents And Company Documents Logs ........................ 555
Menu Bar .............................................................................................................. 556
  File Menu .......................................................................................................... 556
  Edit Menu .......................................................................................................... 556
  View Menu ......................................................................................................... 557
Toolbar .................................................................................................................. 558
  Search For A Document, Folder, Or Shortcut .................................................. 558
  Display Folders By Project Or Shell Phase ....................................................... 559
  View Folder Contents ....................................................................................... 560
Creating And Managing Folders

About Locked Folder Structures
Create A Folder
Folder Properties Window
View Or Modify Folder Properties
Modify Folder Permissions
Copy A Folder
Move A Folder
Organize Folders
Rename A Folder
Delete A Folder

Creating And Managing Documents

View And Open Documents
Create An Empty Document
Document Properties Window
View Or Modify Document Properties
Modify Document Permissions
Copy A Document
Move A Document
Rename A Document
Delete A Document

Creating And Managing Shortcuts

Use Shortcuts
Create A Shortcut
Shortcut Properties Window
View Or Modify Shortcut Properties
Modify Shortcut Permissions
Copy A Shortcut
Move A Shortcut
Rename A Shortcut
Delete A Shortcut
Change The Shortcut Source

Uploading Files

Upload Files Using The Basic (HTML) File Transfer Method
Upload Files Using The Intermediate (Java) File Transfer Method
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upload Files And Folders Using The Advanced File Transfer Method</td>
<td>578</td>
</tr>
<tr>
<td>Advanced file upload options</td>
<td>580</td>
</tr>
<tr>
<td>About Uploading Drawing And Reference Files</td>
<td>581</td>
</tr>
<tr>
<td>Resolving Missing Reference Files (Reference Manager)</td>
<td>582</td>
</tr>
<tr>
<td>View Missing And Attached Reference Files</td>
<td>582</td>
</tr>
<tr>
<td>Manually Resolve Reference Files</td>
<td>583</td>
</tr>
<tr>
<td>Auto-resolve Missing Reference Files</td>
<td>583</td>
</tr>
<tr>
<td>Copy Or Move Reference Files</td>
<td>584</td>
</tr>
<tr>
<td>Importing And Exporting In Document Manager</td>
<td>584</td>
</tr>
<tr>
<td>Import A Folder Structure Template</td>
<td>584</td>
</tr>
<tr>
<td>Import And Export Folders, Properties, And Empty Documents</td>
<td>585</td>
</tr>
<tr>
<td>Downloading Documents And Folders</td>
<td>586</td>
</tr>
<tr>
<td>Adding And Viewing Graphic Markups And Comments</td>
<td>587</td>
</tr>
<tr>
<td>Add A Comment To A Document In The Document Manager</td>
<td>588</td>
</tr>
<tr>
<td>Add A Graphic Markup To A Document In The Document Manager</td>
<td>589</td>
</tr>
<tr>
<td>Attach Files To A Comment</td>
<td>589</td>
</tr>
<tr>
<td>View Comments, Markups, And File Attachments On Comments</td>
<td>591</td>
</tr>
<tr>
<td>Revising Documents</td>
<td>593</td>
</tr>
<tr>
<td>Access Previous Revisions</td>
<td>594</td>
</tr>
<tr>
<td>Check-in And Check-out Documents</td>
<td>595</td>
</tr>
<tr>
<td>Lock And Unlock Documents</td>
<td>596</td>
</tr>
<tr>
<td>The Recycle Bin</td>
<td>596</td>
</tr>
<tr>
<td>Restore Deleted Items</td>
<td>597</td>
</tr>
<tr>
<td>Delete Items From The Recycle Bin</td>
<td>597</td>
</tr>
<tr>
<td>Project Or Shell Documents Or Company Documents Attached To A Business Process</td>
<td>597</td>
</tr>
<tr>
<td>Launch A Business Process From The Document Manager</td>
<td>598</td>
</tr>
<tr>
<td>View Linked Business Process Records</td>
<td>599</td>
</tr>
<tr>
<td>Index Reports</td>
<td>599</td>
</tr>
<tr>
<td>View Document Manager Audit Log</td>
<td>600</td>
</tr>
<tr>
<td>Unpublished Documents</td>
<td>601</td>
</tr>
<tr>
<td>Unpublished Documents Log</td>
<td>601</td>
</tr>
<tr>
<td>About Automatic Publishing Of Documents</td>
<td>601</td>
</tr>
<tr>
<td>Open An Unpublished Document</td>
<td>602</td>
</tr>
<tr>
<td>Open A Linked Business Process Record</td>
<td>603</td>
</tr>
<tr>
<td>View Unpublished Document Properties</td>
<td>603</td>
</tr>
</tbody>
</table>
Resource Manager ................................................................................................................. 606
  About the Resource Manager ............................................................................................... 607
  Using the Resource Manager ............................................................................................... 609
    View Roles .......................................................................................................................... 609
    View Resources .................................................................................................................. 610
  Edit your own resource properties ...................................................................................... 611
    General Tab ........................................................................................................................ 611
    Roles Tab ............................................................................................................................. 611
    Skills Tab ............................................................................................................................. 611
    Calendar Tab ....................................................................................................................... 612
    Projects/Shells Tab ............................................................................................................. 612
  Working With Resource Sheets ............................................................................................ 612
  View Resource Manager sheets ........................................................................................... 613
    Allocations Summary Sheet ............................................................................................... 614
    Resource Allocation Sheet ................................................................................................ 615
    Booking Summary Sheet .................................................................................................... 618
    Actuals Summary Sheet ...................................................................................................... 623
  Booking vs. Actuals summary sheet ...................................................................................... 625
    Utilization Summary Sheet ............................................................................................... 625
      Project level ..................................................................................................................... 626
      Company level ................................................................................................................. 626
  Availability sheet ............................................................................................................... 627
  View resource sheets ........................................................................................................... 630
  Filter the data on a resource sheet ....................................................................................... 632
    Print Resource Sheets ....................................................................................................... 633
    Save And View Resource Sheet Snapshots ....................................................................... 633
  Viewing And Configuring Resource Dashboards .................................................................. 633
    Supply vs. demand charts ................................................................................................. 634
    Actuals charts .................................................................................................................... 634
    Booking charts .................................................................................................................. 634
Portfolio Manager Overview .............................................................. 658

About Resource dashboards ............................................................... 635
Supply vs. demand charts ................................................................. 636
Actuals charts .................................................................................. 636
Booking charts ................................................................................. 637
Utilization charts ............................................................................. 637

Configure The Dashboard ................................................................. 638
Print The Dashboard ...................................................................... 639
About Resource Business Processes .................................................. 639
Resource Booking Business Process .................................................. 639
Timesheet Business Process .............................................................. 640
Understanding Reverse Auto-population ......................................... 641

Planning Manager ........................................................................... 642

Planning Manager Overview .............................................................. 643
About the Planning Manager ............................................................. 644
Access Planning Items And Planning Sheets .................................... 644
Access planning items from a master log .......................................... 646
Create A Planning Item .................................................................. 646
Bulk edit planning items from the Planning Manager log ............... 648
Delete planning items ..................................................................... 649
Create A Planning Sheet ................................................................. 649
Copy A Planning Sheet .................................................................. 650
Open The Planning Sheet ............................................................... 650
Add And Manage Planning Sheet Rows ......................................... 651
View Column Details ..................................................................... 651
Refresh A Planning Sheet .............................................................. 651
Modify Planning Items From A Planning Sheet .............................. 652
Bulk edit planning items from the Planning Manager log ............... 653
Grant Planning Sheet Permission ...................................................... 653
Understanding Reverse Auto-population ....................................... 654
Printing Planning Item Records ....................................................... 655
Print A Planning Item Form ............................................................. 655
Print Options ................................................................................... 655

Portfolio Manager ........................................................................... 657

Portfolio Manager Overview .............................................................. 658
Use Filters In A Schedule Sheet ................................................................. 726
Update Rates And Cost Data ................................................................. 726
Constrain Schedule Sheet Activities ...................................................... 727
    Add General Comments (with Or Without File Attachments) .............. 728
Refreshing Schedule Sheet Data ............................................................ 729
Print A Schedule Sheet ........................................................................... 730
Schedule Manager audit log .................................................................... 732
Set Schedule Sheet Baselines .................................................................. 732
    Lock Or Unlock The Schedule Sheet Structure .................................. 733
Linked Schedule Sheets ........................................................................... 733
linked tags and Business Process fields .................................................. 736
Search For Schedule Sheets ..................................................................... 736
Program Schedule Sheets ......................................................................... 737
    Open A Schedule Sheet ....................................................................... 737
Add A Program Schedule Sheet Column ................................................ 738
Create An Activity Sheet .......................................................................... 739
Update Multiple Activities ...................................................................... 743
Undo Activity Row Changes ...................................................................... 745
Update Activity Sheet Properties ............................................................. 745
Export Activity Sheets ............................................................................. 745
Set Up Activity Sheet Baselines ............................................................... 746
Scope Management .................................................................................. 748
    Working With Schedule Sheets With Scope Management .................. 748
Manage Scope Management Properties .................................................... 749
About Scope Management Data Elements .............................................. 749
Set Up Scope Management For Activities .............................................. 750
Completion Conditions ............................................................................. 752
Launching Business Processes From Activities ........................................ 753
    Manually Launch A Business Process ................................................. 753
Remove The Link Between A Business Process And An Activity .......... 753
Update Activity Properties ...................................................................... 754
Status Transitions And Activities ............................................................. 755
    Automatic Activity Status Transitions ................................................. 755
Manual Activity Status Transitions .......................................................... 755
About Launching Or Removing Business Processes From Activities ........ 755
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic Launching Of Business Processes</td>
<td>755</td>
</tr>
<tr>
<td>Manually Launching Business Processes</td>
<td>756</td>
</tr>
<tr>
<td>Manually Remove Business Process Link</td>
<td>756</td>
</tr>
<tr>
<td>Automatic Removal Of Business Process Link</td>
<td>756</td>
</tr>
<tr>
<td>About Activity Completion</td>
<td>756</td>
</tr>
<tr>
<td>Conditions For The Automatic Completion Of Activities</td>
<td>756</td>
</tr>
<tr>
<td>Conditions For The Manual Completion Of Activities</td>
<td>757</td>
</tr>
<tr>
<td>Impact Of Successor And Predecessor Activities On Launching And Completion Of BP</td>
<td>757</td>
</tr>
<tr>
<td>Finish-to-start (FS)</td>
<td>757</td>
</tr>
<tr>
<td>Start-to-start (SS)</td>
<td>757</td>
</tr>
<tr>
<td>Finish-to-finish (FF) And Start-to-finish (SF)</td>
<td>758</td>
</tr>
<tr>
<td>About Manual Or Automatic Control Of Individual Activities</td>
<td>758</td>
</tr>
<tr>
<td>Auto-update Activity Data On Activity Attributes</td>
<td>758</td>
</tr>
<tr>
<td>Rules For Modifying The Auto-update Activity Data Checkbox</td>
<td>759</td>
</tr>
<tr>
<td>System Behavior When The Auto-update Activity Data Checkbox Is Modified</td>
<td>759</td>
</tr>
<tr>
<td>Impact Of Schedule Start Date</td>
<td>760</td>
</tr>
<tr>
<td>Calculation Of Estimated Start And Finish Dates</td>
<td>760</td>
</tr>
<tr>
<td>Entering and Viewing Cost Data</td>
<td>761</td>
</tr>
<tr>
<td>Project Progress Data Accumulation and Calculation</td>
<td>763</td>
</tr>
<tr>
<td>Terminology</td>
<td>763</td>
</tr>
<tr>
<td>Earned Progress And Earned Value</td>
<td>763</td>
</tr>
<tr>
<td>Enter Progress And Earned Progress Information</td>
<td>764</td>
</tr>
<tr>
<td>Setting Up The Budget And Progress Method</td>
<td>764</td>
</tr>
<tr>
<td>Select The Activity Budget Distribution Profile</td>
<td>767</td>
</tr>
<tr>
<td>Incremental</td>
<td>768</td>
</tr>
<tr>
<td>Cumulative</td>
<td>768</td>
</tr>
<tr>
<td>Select The Entry Method For The % Complete And Earned Progress</td>
<td>768</td>
</tr>
<tr>
<td>Select The Calculation Method For % Complete</td>
<td>769</td>
</tr>
<tr>
<td>Select The Calculation Method For % Earned</td>
<td>771</td>
</tr>
<tr>
<td>Select WBS Codes Filtered By Workpackage (schedule Sheet Level Only)</td>
<td>774</td>
</tr>
<tr>
<td>Lock The Reporting And Progress Entry Period (schedule Sheet Level Only)</td>
<td>774</td>
</tr>
<tr>
<td>Entering Progress Data On The General And Resource Tabs Of Activity Properties</td>
<td>775</td>
</tr>
<tr>
<td>Entering Progress In The Activity Progress Window</td>
<td>776</td>
</tr>
<tr>
<td>Export And Import Activity Progress Data</td>
<td>780</td>
</tr>
<tr>
<td>Using The Activity Progress And Resource Progress Logs</td>
<td>780</td>
</tr>
</tbody>
</table>
% Earned Calculation Method option is Resource updates Activity - weighted avg. of resource costs

% Earned Calculation Method option is Lead resource updates Activity and other resources

% Earned Calculation Method option is Update Activity and all resources on activity start and finish

Method Is Lead Resource Updates Activity And Other Resources

% Earned Calculation Method option is Lead resource updates Activity and other resources

Activity And Resource % Complete Updates % Earned

Method Is Manual Activity % Complete And Resource % Complete

% Earned Calculation Method options are not available

Method Is Manual Activity % Complete - Updates Resource % Complete

% Earned Calculation Method options are not available

Method Is Resource Updates Activity - Weighted Avg. Of Resource Hours

% Earned Calculation Method options are not available

Method Is Resource Updates Activity - Weighted Avg. Of Resource Costs

Method Is Lead Resource Updates Activity And Other Resources

% Earned Calculation Method option is Lead resource updates Activity and other resources

Activity And Resource % Earned Updates % Complete

Method Is Manual Activity % Earned And Resource % Earned

% Complete Calculation Method options are not available

Method Is Manual Activity % Earned - Updates Resource % Earned

% Complete Calculation Method options are not available

Method Is Resource Updates Activity - Weighted Avg. Of Resource Costs

% Complete Calculation Method options are not available

Method Is Lead Resource Updates Activity And Other Resources

% Complete Calculation Method options are not available

Method Is Update Activity And All Resources On Start And Finish

% Complete Calculation Method options are not available

Do Not Allow Update Of % Complete And % Earned

Reports

User-defined Report Types

User-defined Report Data Types

Working With Custom Reports
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access user-defined reports</td>
<td>807</td>
</tr>
<tr>
<td>Running A User-defined Report</td>
<td>807</td>
</tr>
<tr>
<td>User-defined Report Formats</td>
<td>812</td>
</tr>
<tr>
<td>Save And Retrieve Scheduled Report Results</td>
<td>813</td>
</tr>
<tr>
<td>Print Report Results</td>
<td>814</td>
</tr>
<tr>
<td>Mark Reports In Primavera Unifier For Mobile Access</td>
<td>815</td>
</tr>
<tr>
<td>View Report, Project, Shell, And Record Details</td>
<td>815</td>
</tr>
<tr>
<td>Search For And Run Reports On A Mobile Device</td>
<td>817</td>
</tr>
<tr>
<td>Sync Reports</td>
<td>820</td>
</tr>
<tr>
<td>Delete Reports From A Mobile Device</td>
<td>822</td>
</tr>
<tr>
<td>Unifier for Mobile Devices</td>
<td>823</td>
</tr>
<tr>
<td>Getting Started with Primavera Unifier for Mobile</td>
<td>824</td>
</tr>
<tr>
<td>Primavera Unifier For Mobile Requirements</td>
<td>824</td>
</tr>
<tr>
<td>What You Can Do On Primavera Unifier For Mobile</td>
<td>824</td>
</tr>
<tr>
<td>Bookmarks</td>
<td>824</td>
</tr>
<tr>
<td>Tasks and Messages</td>
<td>825</td>
</tr>
<tr>
<td>Business Process Logs</td>
<td>825</td>
</tr>
<tr>
<td>uMail</td>
<td>825</td>
</tr>
<tr>
<td>Asset Manager</td>
<td>825</td>
</tr>
<tr>
<td>Projects, Shells and the Company Workspace</td>
<td>825</td>
</tr>
<tr>
<td>What Is Supported</td>
<td>825</td>
</tr>
<tr>
<td>Logging Into Primavera Unifier From A Mobile Device</td>
<td>826</td>
</tr>
<tr>
<td>Navigating Primavera Unifier On A Mobile Device</td>
<td>827</td>
</tr>
<tr>
<td>Home page</td>
<td>827</td>
</tr>
<tr>
<td>Links</td>
<td>827</td>
</tr>
<tr>
<td>Buttons</td>
<td>827</td>
</tr>
<tr>
<td>About logs on a mobile device</td>
<td>828</td>
</tr>
<tr>
<td>About Entering Information On A Form On A Mobile Device</td>
<td>828</td>
</tr>
<tr>
<td>Working with Primavera Unifier for Mobile</td>
<td>829</td>
</tr>
<tr>
<td>Open A Project, Shell Or The Company Workspace</td>
<td>829</td>
</tr>
<tr>
<td>View Project Or Shell Details</td>
<td>830</td>
</tr>
<tr>
<td>Working With Business Process Forms On A Mobile Device</td>
<td>831</td>
</tr>
<tr>
<td>Create Or Open A Business Process Record On A Mobile Device</td>
<td>831</td>
</tr>
<tr>
<td>Accept And Complete A Task On A Mobile Device</td>
<td>832</td>
</tr>
<tr>
<td>Decline Or Un-accept A Task On A Mobile Device</td>
<td>833</td>
</tr>
</tbody>
</table>
Add Or Manage Line Items On Mobile Forms.................................833
Add General Comments To A Mobile BP Form ................................834
Move The Form Along In The Workflow ......................................835
Adding And Managing Bookmarks On Primavera Unifier For Mobile ..835
  Add A Bookmark In Primavera Unifier For Mobile..........................835
  Manage Bookmarks On A Mobile Device........................................835
  Use A Bookmark........................................................................836
  Search For A Record In Primavera Unifier For Mobile....................836
Working With Assets On A Mobile Device........................................836
Add And Manage Assets On A Mobile Device....................................837
  Add General Comments To An Asset Record....................................837
  Send And Receive UMail On A Mobile Device.................................838
INTRODUCTION
WELCOME TO PRIMAVERA UNIFIER

Designing, building, and managing facilities requires extensive collaboration between numerous, often geographically dispersed, disciplines and entities. Throughout the process, from conceptual design to facility operations, access to accurate, up-to-date information is critical to the success of a project and facility.

Oracle Primavera’s Primavera Unifier is an integrated platform that optimizes business processes and creates visibility to enable customers to better manage all of the communications and information required to successfully manage a facility throughout the lifecycle.

Primavera Unifier is a system for managing the flow of information in projects or shells, providing a seamlessly automated and integrated environment across the lifecycle of your company’s facilities, from planning, design, procurement, construction and into operations and maintenance. It provides real-time visibility across multiple projects or shells to help your company make fast, accurate decisions.

Primavera Unifier lets you track and manage information such as budgets, project or shell members, specifications, requests for information, and shared documents. You decide who has access to the information, which team members are allowed to approve changes to the information, and how information flows between people.

Oracle Primavera’s solutions automate manual processes and pull together information from various point systems typically used on a portfolio of projects or shells. Through Primavera Unifier, executives and project or shell team members can better manage all data and business processes in one centralized system, while reducing the reliance on older technologies such as e-mail, fax, and desktop applications.

Primavera Unifier was designed from the ground up specifically for the facility owner, based upon our industry domain expertise and knowledge of best practices combined with direct customer input gathered over decades of client interaction. The result is a robust set of capabilities with an intuitive, easy-to-use interface. Primavera Unifier enables leading owners and operators to increase enterprise efficiencies, reduce project and operating costs, enhance visibility, and improve time-to-market.
INFORMATION FOR FIRST TIME USERS

Before using Primavera Unifier, refer to the First Time User Setup Guide, which details the minimum system and browser requirements, procedures for configuring your browser, setting document view options, and other important information.

To access the Primavera Unifier Login window


2. Look for the Login: Primavera Unifier field in the upper right portion of the web page. Click the Primavera Unifier link. The Primavera Unifier Login window opens.

To access the First Time User Setup Guide

1. Open the Primavera Unifier Login window.

2. Near the top of the Primavera Unifier Login window, click the First Time User Setup Guide link above the Login window. The First Time User Setup Guide opens.

Follow the instructions in the document to configure your browser settings, which is necessary in order for Primavera Unifier to run correctly. Once you have set up your browser, you can log in to Primavera Unifier.
IF YOU NEED HELP

If you need help with an operation in Primavera Unifier, there are a number of resources to help you.

Online Help

If you have a question or need further assistance regarding a specific feature, review the online help.

To Access Online Help:

Click the Help menu from any Primavera uDesigner window, and choose one of the following:

- **Primavera Unifier Help**: Accesses the online help system
- **Download PDF > Primavera Unifier Administrators Guide**: Allows you to download the *Primavera Unifier Administrators Guide*. You must have Adobe Acrobat Reader installed (available free at www.adobe.com).
- **Download PDF > Primavera Unifier Users Guide**: Allows you to download the *Primavera Unifier Users Guide*. You must have Adobe Acrobat Reader installed (available free at www.adobe.com).
- **Download PDF > Primavera Unifier and uDesigner Reference Guide**: Allows you to download the *Primavera Unifier and uDesigner Reference Guide*. You must have Adobe Acrobat Reader installed (available free at www.adobe.com).
- **Release Notes**: Discusses new features of the current version of Primavera Unifier
- **BP-specific Help**: If your company has provided customized help files for individual business processes, these will be listed in the Help menu when the BP log is active.

Where To Get Support

If you have a question about using Oracle products that you or your network administrator cannot resolve with information in the documentation or help, click http://support.oracle.com/. This page provides the latest information on contacting Oracle Global Customer Support, knowledge articles, and the support renewals process.

Access To Oracle Support

Oracle customers have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/us/support/contact-068555.html or visit http://www.oracle.com/us/corporate/accessibility/support/index.html if you are hearing impaired.
**Additional Support**

The Support link If you need additional support with Oracle Primavera, support contact information is listed on the Support link >Contacts tab. You can download applications and plug-ins, and their instructions, from the Support link > Download tab.

**To access support contact information**

1. Click on the Support link located in the upper section of the Primavera Oracle Primavera window, the Support window opens.

2. Click the Contact tab. Here you will see:

   **Your company contact information.** If your company administrator has provided internal support contact information, it will be listed at the top of the tab. Usually, this will be someone at your company that you can contact when you need help with Primavera Oracle Primavera. If this information is provided, this should be the first place you try for assistance.

   **Oracle Support contact information.** For complex issues, or questions not answered in the online Help, you can contact go to the Oracle support site at http://support.oracle.com.

   **eLearning contact information.** Your company may elect to provide access to the eLearning suite, where you can access interactive Primavera Oracle Primavera learning materials. Alternatively, your company may have its own customized support or training materials that can be accessed on an internal site/location. If your company administrator provides this contact information, it will be listed at the bottom of the window.

**To access Oracle Primavera applications and plug-ins, and their instructions**

1. Click on the Support link located in the upper section of the Primavera Oracle Primavera window, the Support window opens.

2. Click the Download tab.

   From here, you can download the utilities and corresponding installation instructions.

   - Oracle Primavera File Transfer Utility
   - SmartForm Utility
LOGGING IN AND OUT

After following the instructions outlined in the First Time User Setup Guide, you are ready to log in and begin using Primavera Unifier.

To log in to Primavera Unifier

1. If it is not already open, then open the Primavera Unifier Login window:
   b. Look for the Login: Primavera Unifier field in the upper right portion of the web page. Click the Primavera Unifier link. The Primavera Unifier Login window opens.

2. Enter your user name and password.

3. To have Primavera Unifier remember your user name, select Remember Me.

4. Click Login. Primavera Unifier opens to your user home page.
   If you set a bookmark as your default login page, Primavera Unifier will open to that page.

To log out of Primavera Unifier

Click the Logout link in the upper right corner of the Primavera Unifier window.

If you have trouble logging in

• Be sure you are entering the correct user name and password as given to you by your administrator.
• Check the Caps Lock key on your computer; user names and passwords are case-sensitive.
• If you need assistance, contact your Company Administrator or Oracle Customer Support.

Note: After logging in for the first time, you may wish, or be required, to change your password. This is done through the Preferences link in the upper portion of the Primavera Unifier window.

Tip: Save your work often. If you are inactive in Primavera Unifier for longer than the time-out limit (one hour), the system will log you out automatically, and any unsaved work will be lost.

To reset your password if you forget it

1. Click the Forgot Password? link in the Login window.

2. Enter your user name and e-mail address, and click OK.

3. Answer one of your secret questions, and click Submit.

4. You will receive an e-mail notification containing your re-set password.

5. Use the new password to log into Primavera Unifier.
   It is a good idea to reset your password right away.

Note: If the Secret Question(s) have not been set up for you, or if your Primavera Unifier account is Inactive or On-Hold, you will receive an error message instructing you to contact support. See “Adding secret questions for password reset” on page 20 for instructions on adding secret questions.
LOGGING INTO THE SELF-SERVICE PORTAL

In Primavera uDesigner, certain business processes can be enabled for access through the Self-Service Portal. Self-Service Portal enabling is supported on business processes that have these characteristics:

- Simple
- Company level
- Non-workflow
- Multi-record

The actions users can take through the Self-Service Portal are:

- Create a business process
- Modify a business process
- Add or remove business process attachments
- Add General Comments to a business process

To log into the Self-Service Portal Landing Page

1. In your web browser, enter the URL you use to access Primavera Unifier, followed by /portal. For example: https://ues.skire.com/portal
2. Enter your Self-Service Portal user name and password, choose your company from the pull-down if applicable, and click the Login button. The Landing Page opens.

To create and submit a new record

1. Select a business process to work with from the log in the left Navigator.
2. Click the New button.
3. Fill out the business process form.
4. Click Submit.

To open or edit an existing record

1. Navigate to the business process in the left Navigator. The business process log opens in the right pane, listing all available records that you have permission to view.
2. Select the record from the log and click Open (or double-click the record from the log.) The record opens in the view-only mode.
3. To edit the details, click the Edit button.
4. Make necessary edits to the form.
5. Click Submit to submit the edited record.

Note: You must have been given the proper permissions to create, view, or edit portal-enabled records.
NAVIGATING IN PRIMAVERA UNIFIER

When you first log in to Primavera Unifier, you will be on the User home page. From the User home page, you can:

- Review all of your projects or shells, tasks, or messages with a single click.
- Quickly view your active tasks or new uMails.
- View system-wide project or shell or shell announcements.
- Access Primavera Unifier functions using the Navigator.

Click the Home tab to return to the Home page.
USER HOME PAGE

When you first log in to Primavera Unifier, you will be on the User home page. When you are on the Home page, you can:

- See the last time you logged in.
- Review all of your projects or shells, tasks, or messages.
- See which projects have active tasks or new uMails.
- View system-wide project or shell or shell announcements.
- Access Primavera Unifier functions using the Navigator.

Note: Any time you want to return to the home page, click the Home tab.
NAVIGATOR

The primary means of accessing Primavera Unifier features within a project or a shell is through the Navigator, located in the left pane of the Primavera Unifier window.

The Navigator is similar to a familiar folder system, much like a network drive. Each feature is stored in its own “node”, similar to a folder. Each node is controlled by permissions. If you do not see a feature in the Navigator, contact your project or shell Administrator or Company Administrator to verify that you have been assigned the proper access permissions.

**Note:** Company Administrators can configure the User Mode Navigator to better suit business needs, for example, creating additional nodes to store business process records, renaming some of the nodes mentioned below, and so on. Your Navigator may differ, but the basic functionality will be the same.
**NAVIGATIONAL TABS**

Primavera Unifier uses tab-based navigation; for example, you can access Home, the Company Workspace, and up to three additional top-level shells or projects by clicking its corresponding tab. By default, Primavera Unifier lists the Home and Company Workspace tabs at the top of your Home page. Only single-instance shells, that is, shells that cannot be replicated, can appear as tabs.

To access the shells in your company, click the tab for the top-level shell, or a bookmark if one is set. The shell's landing page will open and any sub-shells will be listed in the shell mini-log in the lower area of the landing page. See “About Shells” and the topics in the Shells section for details on working with shells.

Your Company Administrator can rearrange the tabs for you, if you need them in a certain order in the interface.
MODES OF OPERATION

Primavera Unifier has two modes of operation.

• **User Mode:** Users spend most of their time in this mode. It is where they perform Primavera Unifier day-to-day activities, collaborate through business processes and uMail, maintain, for example, the Cost Manager, Schedule Manager, and Document Manager, and run reports.

• **Administration Mode:** Company administrators work in this mode to set up, for example, company, program, and project or shell properties, user permissions, templates for major Primavera Unifier features, data structures, and configure and set up business process forms and workflows.

You can switch between modes using the Navigator. Access to Primavera Unifier functionality is granted through permissions. The ability to utilize a specific function in Primavera Unifier depends on permissions settings.
BREADCRUMBS

Breadcrumbs are a navigation technique that show the path to the shell where you are presently. As you navigate through the interface, breadcrumbs appear in the upper right corner of the current window.

Even if you don't have permission for a shell it will appear in the breadcrumb trail. You can use the breadcrumb to go back to your starting point.
USING BOOKMARKS TO ACCESS PRIMAVERA UNIFIER NODES

From the Bookmarks link, located in the upper right portion of the Primavera Unifier window, you can add bookmarks to Primavera Unifier User Mode functions where you frequently work. These bookmarks are similar to the bookmarks that you create in web browsers to help you access web pages more quickly. Primavera Unifier does not validate bookmark names, so be sure not to add duplicate or confusing bookmark names. Access through bookmarks is based on your user permissions.

To add bookmarks

1. Click the Bookmark link located on the upper portion of the Primavera Unifier page. The Bookmarks window opens.

2. Click the Add button. The module name is added to your list of bookmarks. The bookmark name is the node name. You can modify this name for your bookmark.

3. Close the Bookmark window.

Note: You cannot add bookmarks in Administration Mode.

To use bookmarks

1. Click the Bookmark link located on the upper portion of the Primavera Unifier page. The Bookmarks window opens.

2. Provided that you have permission to access that module, clicking on a bookmark opens the shell or project. Breadcrumbs to your current location appear in the upper right portion of the Primavera Unifier window.

To organize/manage bookmarks

You can organize your list of bookmarks in the Bookmarks window.

1. Click the Bookmark link located on the upper portion of the Primavera Unifier page. The Bookmarks window opens.

2. Click Organize located at the top of the Bookmarks window.
   - You can delete a bookmark by selecting the bookmark and then clicking Remove.
   - You can move bookmarks up and down the list by selecting the bookmark and then clicking Move Up or Move Down.
   - You can designate one bookmark as the default module shown to you at login by selecting the Default Login checkbox for that module.

Note: If you do not have permission to access a module that you designate as the default login, Primavera Unifier will display the Home page.

3. When finished, click OK and close the Bookmarks window.
USER PREFERENCES

You can open the User Preferences window by clicking the Preferences link in the upper right portion of the Primavera Unifier window.

The User Preferences window contains four tabs, General, Security, Options, and Proxy, each of which has a specific purpose.

- On the General tab you can view your company contact information.
- On the Security tab you can manage your password and secret questions, which are used for password reset.
- On the Options tab you can manage your company settings, for example, language, time zone, date format, default viewer, file transfer option, default login view, and email subscriptions.
- On the Proxy tab you can add your proxy user, see users who added you as their proxy, and login as a proxy user.

The topics that follow describe available User Preference configuration settings for each tab.
VIEWING YOUR CONTACT INFORMATION

The Preferences link opens on the General tab in the User Preferences window. This is where you can view the name and contact information on file for you. Company administrators manage user profiles. If this information changes, or is incorrect, you can contact your company administrator to update your profile.

To access the User Preferences window General tab

Click the Preferences link, located in the upper right side of the Primavera Unifier window. The User Preferences window opens on the General tab showing your:

• First and last name
• Contact information
CHANGING YOUR PASSWORD

For security reasons, it is good practice to change your password at regular intervals. Your administrator may require you to change it at set times.

To change your password

1. Click the Preferences link in the upper right portion of the Primavera Unifier window. The User Preferences window opens.
2. Click the Security tab.
3. Enter your current password.
4. Enter a new password, then reenter it to confirm the change.
5. When finished, click OK

You may want to review your company’s Password/Login Policy to see the minimum password requirements, time-out settings, and more. The Password Policy only applies to the Owner/Sponsor company. For Member or Partner company users, the default password policy definitions in their own companies apply. Click the dropdown link “To view your company’s password policy” to read the default policy password definitions that your administrator can set.

To view your company’s password policy

1. Click the Preferences link in the upper right portion of the Primavera Unifier window. The User Preferences window opens.
2. Click the Security tab.
3. Click the View Password Policy link. The Password Policy window opens.

<table>
<thead>
<tr>
<th>Password setting</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum overall character(s)</td>
<td>Minimum number of characters that a password must contain; default is one (1).</td>
</tr>
<tr>
<td>Maximum overall character(s)</td>
<td>Minimum number of characters that a password must contain.</td>
</tr>
<tr>
<td>Minimum numeric character(s)</td>
<td>Password must contain a minimum amount of numbers.</td>
</tr>
<tr>
<td>Minimum alphabetic character(s)</td>
<td>Password must contain a minimum amount of letters.</td>
</tr>
<tr>
<td>Minimum special character(s)</td>
<td>Special characters are [!@#$%&amp;*()_=-+;&quot;:',&lt;.&gt;/?].</td>
</tr>
<tr>
<td>Password cannot be same as Username</td>
<td>Users cannot use their user name as a password.</td>
</tr>
<tr>
<td>Password cannot be the same as the user’s First or Last Name</td>
<td>Users cannot use their first or last name as a password.</td>
</tr>
<tr>
<td>Password cannot be the same as the last password(s)</td>
<td>A newly changed password must be different from the previously used password(s).</td>
</tr>
<tr>
<td>Password expiration</td>
<td>If a password expires, users are prompted to change it when they next log in.</td>
</tr>
<tr>
<td>Inform user before expiration</td>
<td>Upon log in, users are warned that their passwords are about to expire, and are given the opportunity to change the password.</td>
</tr>
</tbody>
</table>
4. When finished, click OK.

There may be times when you forget your Primavera Unifier password. You can recover it by answering Secret Questions that you set up yourself. You can add up to three Secret Questions. These questions will be presented if you click the **Forgot Password?** link on the Primavera Unifier login window. After you answer the Secret Question(s), you will receive e-mail notification of your new password.

It is recommended that you set up the Secret Questions so that you can reset your own password. Otherwise, if you need to recover or reset your password, you will need to contact your company administrator.

**To add Secret Questions to use when resetting your password**

1. Click the **Preferences** link, located in the upper right side of the Primavera Unifier window. The User Preferences window opens.

2. Click the **Security** tab.

3. Under **Password Recovery Secret Questions**, select a question and enter the answer. You can add up to three Secret Questions.

4. When finished, click **OK**.

<table>
<thead>
<tr>
<th><strong>Password setting</strong></th>
<th><strong>Definition</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum login attempts</td>
<td>If a user does not successfully log in after this number of attempts, the account is locked.</td>
</tr>
<tr>
<td>Suspend inactive user after</td>
<td>Sets the number of days of inactivity before a user account is locked.</td>
</tr>
</tbody>
</table>
**ADDING SECRET QUESTIONS FOR PASSWORD RESET**

There may be times when you forget your Primavera Unifier password. You can recover it by answering secret questions that you set up yourself. You can add up to three secret questions. One of these questions will be presented if you click the **Forgot Password?** link on the Primavera Unifier login window. If you make a typographical error, or forgot the answer to a particular question, Primavera Unifier will ask another one of your secret questions. After you answer the secret question, you will receive e-mail notification of your new password.

It is recommended that you set up the secret questions so that you can reset your own password. Otherwise, if you need to recover or reset your password, you will need to contact your company administrator.

**To add Secret Questions to use when resetting your password**

1. Click the **Preferences** link, located in the upper right side of the Primavera Unifier window. The User Preferences window opens.

2. Click the **Security** tab.

3. Under **Password Recovery Secret Questions**, select a question and enter the answer. You can add up to three secret questions.

4. When finished, click **OK**.
CHANGE TIME ZONE OR DATE FORMAT

The Time Zone setting affects the date stamp that appears on the actions that you perform in Primavera Unifier, such as saving or uploading files, running user-defined reports, and due dates of tasks assigned to you. The date stamp is effective as of 12:00 AM in your time zone. For example if your time zone is Eastern Standard Time, and your task is due August 1, then at 12:00 AM August 1 your task is due — even if it is only 9:00 PM July 31 on the US West Coast.

The Date Format determines how date fields appear to you in Primavera Unifier. These settings are maintained in the Options tab of your User Preferences.

To set the time zone

1. Click the Preferences link, located at the upper right portion of the Primavera Unifier window. The User Preferences window opens.

2. Click the Options tab.

3. Click the Time Zone drop-down menu and select a time zone based on your locale.

To set the date format

In the Options tab, click the Date Format drop-down menu and select a date format.
CHOICE A FILE VIEWER OPTION

The file viewer option determines how Primavera Unifier displays files (such as documents or drawings) that are attached to business processes or stored in the Document Manager and opened from within Primavera Unifier.

You can choose a default viewer, which will be used to open most file types in Primavera Unifier. You can also specify exceptions to this. For example, a user may choose Primavera Unifier Viewer as the default viewer, which will be used to open most file types, but then choose to open a few file types such as drawing files and image files using the native applications that reside on the user’s desktop machine.

To choose a file viewer option

1. Click the Preferences link located in the upper section of the Primavera Unifier window. The User Preferences window opens.
2. Click the Options tab.
3. Choose a Default Viewer option.
   - **Native:** Documents are opened in their native applications; for example, Microsoft® Word documents are opened in Microsoft Word. The native application will not display graphical markups. This option requires that users have the native application installed on their machine in order to view the document.
   
   **Note:** Primavera Unifier automatically displays document markups using the AutoVue viewer without having to change your options.

   - **Primavera Unifier Viewer:** Documents are displayed in the AutoVue viewer, which can display virtually any type of file. Documents are opened in a read-only view that supports adding graphical markups and text comments (in attachments to business process and other records, or files in the Document Manager).
   - **Viewer Exceptions:** Here you can specify exceptions to the default viewer. For example, while you may want the default viewer to be native, you might want drawing files to be viewed in Primavera Unifier's AutoVue viewer. In the Always User Native or Always Use Primavera Unifier fields, enter the file extension identifier (such as .doc, .txt, or .dwg) of the files you want to override the default. Omit the period before the extension. You can enter multiple file extensions, separated by a semi-colon. For example, enter doc;txt;dwg.

4. When finished, click OK.
CHOOSE A FILE TRANSFER OPTION

The File Transfer option determines how files are transferred between Primavera Unifier and your local system. File transfers include uploading and downloading documents to and from the Document Manager, or attaching files from your local system to a business process, cost or funding sheet cell, schedule sheet or uMail message.

There are three file transfer methods.

• **Basic:** this option uses HTML. It can be used on any Primavera Unifier-compatible machine without having to install a third-party program. It has the most basic functionality, allowing single-file selection for uploads and downloads, and will resolve drawing reference files after upload.

• **Intermediate:** this option uses Oracle Java SE Runtime Environment (Java). In addition to basic functionality, it supports the selection of multiple files and folders for uploading and downloading. It will resolve reference file relationships in DWG and DGN drawing files. This process takes place on the server (that is, reference files should already be uploaded to Primavera Unifier or be part of the current upload process). See the *First Time User Setup Guide*, File Transfer Option, for details on supported Java versions and the URL for Java downloads.

• **Advanced:** this option uses Java and Primavera Unifier File Transfer Utility. It provides the greatest flexibility for uploading and downloading documents and folders, especially drawing files. In addition to the Intermediate functionality, its advanced functionality for managing reference file relationships in DWG and DGN drawing files makes it easier for users to locate, upload, revise, and download reference files. The resolve process is done on your local system. The process will make sure that all reference files are included in the upload and will automatically bundle necessary files as needed.

The Advanced option requires the download and installation of Primavera Unifier File Transfer Utility and Java. The Primavera Unifier File Transfer Utility installation file and instructions are available for download from within Primavera Unifier; click the Support link, then choose the Download tab. See also the *First Time User Setup Guide* for details on supported Java versions and the URL for Java downloads.

<table>
<thead>
<tr>
<th>File Transfer Option</th>
<th>Requires 3rd party application</th>
<th>Allows additional file properties</th>
<th>Allows upload / download of multiple files</th>
<th>Allows upload / download of folders</th>
<th>Allows drag-&amp;-drop file selection</th>
<th>Resolves reference files</th>
<th>Resolve process is done locally</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic</td>
<td>none</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Intermediate</td>
<td>Oracle Java SE Runtime Environment (Java)</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Advanced</td>
<td>Java (plus Primavera Unifier File Transfer Utility)</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
</tr>
</tbody>
</table>
To choose the file transfer option

1. Click the Preferences link located in the upper section of the Primavera Unifier window. The User Preferences window opens.
2. Click the Options tab.
3. Choose a File Transfer option: Basic, Intermediate, or Advanced.
4. When finished, click OK.

Note: For information about installing Java and the Primavera Unifier File Transfer Utility, refer to the First Time User Setup Guide. See "Information for First Time Users" on page 4.
SELECT EMAIL SUBSCRIPTION OPTIONS

The Email Subscription option enables you to control the number, type, and frequency of Primavera Unifier-related e-mail notifications. You can decide whether or not to receive e-mail notifications for specific events within Primavera Unifier. You also have the option of receiving all your Primavera Unifier e-mail notifications once a day in an e-mail digest or one at a time in separate e-mail messages.

By selecting a checkbox, you are “subscribing” to e-mail notifications for that event. If a checkbox is not selected, you will not receive any e-mail messages regarding that event.

Checking Send notification in single daily digest consolidates your e-mail notifications. The consolidated e-mail contains the content from selected events. You will get a single e-mail instead of an e-mail for each occurrence of selected events.

Note the following:

- **Permissions**: To receive the e-mail notification, you must have at least view permission for that module and event (that is, permissions set in Administration Mode). If you do not have these permissions, this setting will not override the permission setting. You will only get notification on those functions that you have permission to access and view.

- **Document Manager notifications**: In addition to module-level view permission, you must also have at least view permission on the specific documents or folders that would generate the event e-mail. These permissions are set from within the Document Manager. In addition, the owner of the folder has the option of not generating e-mail notifications for specific events. For specifics, see Chapter 10, "Document Manager".

- **External e-mail accounts**: If you are using an e-mail address from a generic e-mail account (Yahoo, Hotmail, etc.), your spam filter may filter out these notifications. Refer to your e-mail provider regarding how to allow these notifications.

**To subscribe to or opt-out of e-mail notifications**

1. Click the Preferences link located in the upper section of the Primavera Unifier window. The User Preferences window opens.
2. Click the Options tab.
3. Select the modules and events for which you want to receive e-mail notifications. See the following table for details. The events apply to the following modules:
   - Workflow business processes
   - Non-workflow business processes
   - Document Manager, project or shell and company level
   - uMail
   - User-defined reports
   - Alerts
   - Gates
4. To opt out of receiving e-mail notifications regarding specific Primavera Unifier events, deselect the checkbox for the notification.
To receive Primavera Unifier e-mail notifications in one e-mail summary per day, click the **Send notification in single daily digest** checkbox. The summary e-mail will be sent if one or more events trigger an e-mail notification.

<table>
<thead>
<tr>
<th><strong>This option</strong></th>
<th><strong>Does this</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Email Subscription</td>
<td>The e-mail subscription option enables each user to control the number, type, and frequency of Primavera Unifier-related e-mail notifications received. Users can opt in or out of receiving e-mail notifications for events within Primavera Unifier.</td>
</tr>
<tr>
<td>Send notifications in single daily digest</td>
<td>Select this checkbox if you want your Primavera Unifier e-mail notifications (see below) sent to you once a day, rather than individual e-mail messages. Deselect this checkbox to have notifications sent individually.</td>
</tr>
<tr>
<td>Email Subscription options:</td>
<td>When you select a checkbox next to one of the listed options, you are subscribing to e-mail notifications for that event. To receive the e-mail notification, you must have at least view permission for that module and event. See the option descriptions below for more information. If a checkbox is not selected, you will not receive e-mail messages regarding that event.</td>
</tr>
<tr>
<td><strong>Workflow Business Processes</strong></td>
<td>These events pertain to business processes. To receive notification, you must have at least view permission for the business process (BP). You can opt to receive e-mail notification when:</td>
</tr>
<tr>
<td></td>
<td>• Personal tasks: You are part of the assignees list when a BP is sent (this becomes a task for you).</td>
</tr>
<tr>
<td></td>
<td>• Decline tasks: A task is declined by one or more of the assignees that you have added to a BP that you sent.</td>
</tr>
<tr>
<td></td>
<td>• Overdue personal tasks: An assigned task is past the due date.</td>
</tr>
<tr>
<td></td>
<td>• Messages: Someone cc’s you on a BP.</td>
</tr>
<tr>
<td></td>
<td>• Discussion group comments: A discussion group participant adds and saves comments within the discussion group. You will receive notification if you are the owner of the discussion group.</td>
</tr>
<tr>
<td></td>
<td>• Record Workflow Complete: The record workflow is complete.</td>
</tr>
<tr>
<td></td>
<td>• Record Modification: A certain step occurs in a workflow (if your Administrator has enabled workflow actions for the workflow step) that needs action. Actions are shown as hyperlinks in the e-mail.</td>
</tr>
<tr>
<td><strong>Non-Workflow Business Processes</strong></td>
<td>These events pertain to non-workflow business processes. To receive notification, you must have at least view permission for the business process (BP). You can opt to receive e-mail notification when:</td>
</tr>
<tr>
<td></td>
<td>• Record Creation: A new record is created.</td>
</tr>
<tr>
<td></td>
<td>• Record Modification: A record or line item is modified, a line item is added or deleted, comments or attachments are added, attachments are removed.</td>
</tr>
<tr>
<td><strong>Document Manager</strong></td>
<td>Users with view permission (set in the Document Manager) on the applicable document, folder, or shortcut target receive notification when:</td>
</tr>
<tr>
<td>(project or shell and company level)</td>
<td>• Document upload: A new document is uploaded into the folder.</td>
</tr>
<tr>
<td></td>
<td>• Transfer ownership: File or folder ownership is transferred. The new owner is notified.</td>
</tr>
<tr>
<td></td>
<td>• Move: A document, folder, or shortcut is moved from one location or folder to another.</td>
</tr>
<tr>
<td></td>
<td>• Delete: A document, folder, or shortcut is deleted.</td>
</tr>
<tr>
<td></td>
<td>• Document revise: A document is revised.</td>
</tr>
<tr>
<td></td>
<td>• Folder rename: A folder is renamed.</td>
</tr>
<tr>
<td><strong>Note:</strong> With this module in particular, a user modifying multiple documents or folders, or folders with many subfolders, can potentially trigger a large amount of e-mail. You can prevent receiving too many notifications by choosing the digest notification (one e-mail) option, or limit the events for which you want to receive notification.</td>
<td></td>
</tr>
</tbody>
</table>
| **Note:** Document Manager e-mail notifications are only sent if the user has at least view
permission (in Document Manager node) on the item triggering the e-mail, and if the item owner enables e-mail notification.

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>uMail</td>
<td>Users receive e-mail notification when a new uMail is received.</td>
</tr>
</tbody>
</table>
| User Defined Reports | Users receive e-mail notification when:  
|                | • New report granted: The user is granted at least run permission to a user-defined report by another user.  
|                | • Results from scheduled reports: When a scheduled report has been generated and the results are available; requires run permission be granted for the report. |
| Alerts        | • Each Alert: Users can receive notification when an alert is generated.    |
| Gates         | • Change Phase Notification: User receives notification when a phase is changed.  
|               | • Auto-e-mail PDF Gates run: User receives a PDF copy of an automated gates run. |
| Project/Shell | • Successful creation: Administrator receives notification of the successful creation of a project or shell. This notification occurs if the project or shell is created manually, through Web Services, using a CSV file, or through auto-creation. |

**Note:** For permission-based e-mails, e-mail notification is usually sent the first time permission has been granted and not when permissions are modified, unless otherwise noted. Note that Document Manager e-mail notifications are only sent if users have at least view permission on the affected item, and if the item owner enables e-mail notification. See “Enable Document Manager-generated e-mail notification” for more information.
**CHOOSE A PROXY USER**

You can be a proxy for multiple people; however, you can only designate one user as your proxy. Proxy users can be granted permission to access another user’s account to complete tasks and perform other functions on that person’s behalf. When another person logs in as your proxy user, that person will have access to all of the records and functions that you do. A proxy user logged in to your account cannot change your Preference settings. Audit logs reflect that actions taken by a proxy user are “on behalf of” the original user.

You can limit the period in which the proxy user will have access to your account by specifying a start and end date or leave their access active indefinitely.

Proxy users who have the active status (and during the time period specified using the Start Date/Time and End Date/Time, if a time period is specified), will receive e-mail notification of tasks to perform as proxy.

**Note:** If the proxy user must receive task notifications immediately, ask the proxy user to be sure the Send notifications in a single daily digest checkbox is not selected. See Select email subscriptions on the User Preferences Options tab.

**To designate a proxy user to your account**

1. Click the Preferences link located in the upper section of the Primavera Unifier window. The User Preferences window opens.
2. Click the Proxy tab.
3. Click the Add button.
4. In the Proxy User Settings window, click the Select button. The Users/Groups Picker opens.
5. Select a user from the Select Users list and click Add. Click OK to close the picker.
6. If you have access to more than one company and are an active user in the companies, select the company to log into as well. If you have to change company access at any time, you must log out, and then log in again, selecting the new company to access.
7. If you want to limit the time period that the proxy user can access your account (for example, only during your vacation days), do the following:
   • Click the Start Date/Time calendar icon. Select the date and time that you want the proxy to be able to begin logging in as your proxy user and click OK. (Dates on the calendar that are grayed-out are company-defined non-working days. They are valid selections for this function.)
   • Click the End Date/Time calendar icon. Select the date and time to end proxy access and click OK.
   • To clear a date that has already been entered, click the calendar icon, and then click the Reset button.

**Note:** If you do not specify a start or end date, the proxy user can access your account immediately and their access privileges will not expire.

8. Choose Active to activate the proxy user access, or Inactive to disable proxy user access.
9 Click OK.

**Note:** If you have access to more than one company and want to assign a proxy in those companies, you will need to go into each company and set the proxy user. Click your **User name**, select the company and repeat the above steps for that company.

**To name a new proxy user**
You can designate only one proxy user. If you want to change to a different proxy user, make the first user inactive, then add a new one.

**Note:** Your Company Administrator can also assign another user to act as proxy to your account if you are unable to do so.
LOG IN AS A PROXY USER

If you have been designated as a proxy for another user, that user will be listed in the lower portion of the Proxy tab of the User Preferences window. As a proxy user, you have virtually all of the permissions of the other user, with the following exceptions: you cannot change the original user’s Preference settings (including their password), and you cannot alter any user’s Permission settings, even if the original user has Administration permissions to do so.

To log in as someone else’s proxy user

1. Click the Preferences link located in the upper section of the Primavera Unifier window. The User Preferences window opens.
2. Click the Proxy tab.
3. Select the user account to which you want to log in as a proxy.
4. Click Proxy Login. The Primavera Unifier Home Page opens, and you are immediately acting on behalf of the user.

To log out as a proxy user

Click the Logout link at the upper right portion of the Primavera Unifier window. Your Proxy session will end, but you will still be logged in to Primavera Unifier under your own user name.

To view the proxy user settings

1. Click your User name, and select Preferences. The User Preferences window opens.
2. Click the Proxy tab.
3. In the lower portion of the Proxy tab window, select the user account to which you have been named proxy user.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Users who can act as my Proxy</td>
<td>Allows you to designate another person who can log in as your proxy user. That person will have access to all of the records and functions that you do. A proxy user logged in to your account cannot change your Preference settings. Audit logs reflect that actions taken by a proxy user are on behalf of the original user. The Settings button allows you to activate/deactivate the proxy user or set login time limits.</td>
</tr>
<tr>
<td>Users I can act as their Proxy</td>
<td>Lists users who have designated you as a proxy user. You can log in as a proxy user by selecting a user and clicking the Proxy Login button, or view your proxy Settings.</td>
</tr>
<tr>
<td>Add</td>
<td>Allows you to add a proxy user and specify start and end dates and status.</td>
</tr>
<tr>
<td>Settings</td>
<td>Select the proxy and click Settings to edit the user or proxy settings.</td>
</tr>
<tr>
<td>Remove</td>
<td>Select the proxy and click Remove to remove the proxy user.</td>
</tr>
<tr>
<td>Proxy Login</td>
<td>Select a user and click to log in as the proxy user.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>------------------------------------</td>
</tr>
<tr>
<td>Settings</td>
<td>Click to view your settings if you are a proxy user.</td>
</tr>
</tbody>
</table>

4 Click the **Settings** button. The Proxy User Settings window opens.

5 Enter the **Start** and **End Date/Time** of your proxy access.

6 Check that **Active** is selected (default.)

7 Click **OK**.

8 In the User Preferences window, click **OK**.
**GENERAL PROCEDURES**

**About Queries**

You will be using queries to extract data from the database for reports and data pickers, and to set up auto-creation with creator elements.

A query is a data mining tool—a means of retrieving information from a database. A query filters the information returned from the database according to restrictions or conditions you specify. Primavera Unifier queries can:

- Filter or narrow the data being retrieved for use in reports and manager sheets
- Set up conditions or triggers to make something happen automatically in Primavera Unifier
- Filter or narrow the data being retrieved for use in a data picker element

**How It Works**

1. You mine down to the information you want by choosing an element (field) in the database to base the query on.

2. You test the data against conditions and values you specify.
   
   A condition is a state or restriction the value in the data element (field) must meet. A condition of the value might be that it must be equal to a certain number (maybe 10) or that it must contain a certain string of letters (such as “due date of”).

3. When (or if) the data meets the condition you specify, Primavera Unifier retrieves it from the database for use in a report, manager sheet, auto-creation, data picker, etc.
Using Formulas Or Conditions In Queries

For queries, you can evaluate the data before retrieving it from the database to determine whether or not to include the value in the report, manager sheet, or data picker, or to spawn an auto-creation. To evaluate the data, you can use a formula or a condition. In formulas, multiple fields can be calculated to arrive at a certain value that the data must meet before it will be used. The value can be one that you enter, or a value from another field. You can include formulas in conditions.

There are several types of formulas you can use in a query:

- **Field value comparison**
  This formula produces data that meets a field value (string or numeric) from the form of a business process or a shell in a hierarchy, or a constant. Used to populate a data picker.

- **Date plus or minus**
  This formula adds or subtracts a value to or from a date.

- **Date difference**
  This formula subtracts one date from another to give you the number of days between the dates.
• **Compare date fields**

You can also compare date fields as part of a query.

• **Dynamic Date Value**

You can compare a date field value with a date field from the form of a business process or a shell in a hierarchy, a specific date, or today’s date, and also add or subtract days to the result. Used to populate a data picker.
• Between dates
You can compare a date field value to see if it falls between two dates. Used to populate a data picker.
ATTACHING FILES

This section outlines the rules for file transfer and attachment in Primavera Unifier.

About Attaching Files In Primavera Unifier

Assuming that you have the proper permissions, you may attach files (such as Word documents, spreadsheets, drawings, etc.) to business process forms, cells (such as a cost sheet or funding sheet), and uMail messages. These files can be uploaded and attached from your local system, or they can be attached from documents already uploaded and stored in the Document Manager.

The file attachment procedures are similar across the Primavera Unifier system. When an Attach button is available in a Primavera Unifier window, it is associated with the ability to attach a file. When attaching files to other Primavera Unifier modules, such as a uMail message or Cost Sheet cell, you will be presented with two options:

My Computer: Allows you to attach a file from your local system. When you attach files from your local system, the method of upload depends on your File Transfer Option: Basic (HTML), Intermediate (Java), or Advanced (Java and the Primavera Unifier File Transfer Utility).

Primavera Unifier Folder: Allows you to attach a document stored within the Primavera Unifier Document Manager. You must have at least view permission to the folders and files within the Document Manager in order to view and attach them.

File Transfer Methods

The method you use will be determined by your file transfer method setting. This is selected in your User Preferences, Options tab. See “Choose a file transfer option” on page 23 for details on required Java versions.

Examples Of Primavera Unifier Modules To Which You Can Attach Files

- Document Manager: Stores documents in Unifier’s powerful document management system. Files are uploaded to the DM and stored in a folder system. Access permissions can be applied to individual folders and documents. Files and folders are uploaded by clicking the Upload button.

- Business Process Forms: If you are creating or participating in a business process workflow, you can add attachments to the form or to a general comment associated with the form. (Document-type BP forms have special file attachment functionality.

- Cost Sheet, Funding Sheet, Schedule Sheet Cells: You can add a file attachment to cost sheet, funding sheet, or schedule sheet (or most any Primavera Unifier sheet) cells that have not been auto-populated from a business process. Open the cost, funding, or schedule sheet and click a cell. The Cell Detail window opens. In the Cell Detail window, click Attach.

- uMail Messages: You can attach a file to a uMail message. Open a uMail message window and click Attach.

Attach Files From Your Local System (“My Computer”)

When you attach files from your local system, the method of upload depends on your File Transfer Option: Basic (HTML), Intermediate (Java), or Advanced (Java plus Primavera Unifier File Transfer Utility).
To attach documents from your local system (general procedure)
Click the **Attach** button and choose **My Computer**. The file upload window that opens is dependent on the file transfer method that you have selected.

**Attach Files From The Document Manager (“Primavera Unifier Folder”)**
You can attach documents from Primavera Unifier’s Document Manager as long as you have at least view permission on the documents.

To attach documents from the Document Manager (general procedure)
Click the **Attach** button and choose **Primavera Unifier Folder**. The Select Files window opens.

This window displays the folder structure in the project or shell Documents node in the Document Manager. You can open folders to view contents. You may select multiple documents or folders to attach. All documents within folders and subfolders will be attached in a flat file. Documents with duplicate files names will not attach.

**Adding An Image**
In many forms, you can add an image to a business process, project, shell, etc. For example, you can add an image that shows progress on the project information record, pictures of assets related to a specific asset record, or a photo of an employee in the Resource Manager. You can add images to attribute forms in shells, projects, companies, and BPs.

If the Image picker functionality has been added to your project in Primavera uDesigner, forms with the functionality display the image name and a virtual box that will hold the uploaded image.

**Note:** The image name is based on the data element name provided in Primavera uDesigner.

**To add an image to a form**

1. Click **Upload Images** in the toolbar at the top of the form.
   
   Valid image file types are:
   
   • .jpg
   • .jpeg
   • .gif
   • .png
   • .tif

2. Browse for the image to upload and click **OK**.

You can change the image by replacing it with another uploaded image. Images display on the HTML or PDF formats of printed forms. They display in print preview as well. The Image picker can be added to all forms except for those in the Cost Manager, Generic Cost Manager, Schedule Manager, and the Document Manager.

**Adding A Hyperlink**
In many forms, you can add a hyperlink to a business process form, project, shell, etc. For example, you can add a hyperlink to equipment documentation, details on a resource, or external websites that contain information pertinent to a business process record. You can add hyperlinks to attribute forms in shells, projects, companies, and business processes.
If the Hyperlink picker functionality has been added to your project in Primavera uDesigner, forms with the functionality display a hyperlink name, such as vendor website or internal web page.

To add a hyperlink

1. Click on the hyperlink area on the form. The Hyperlink window displays:

2. Enter the hyperlink name and the URL. Only the URL is mandatory. If you enter the name and the URL, the hyperlink displays as the name you entered. If you enter the URL only, the hyperlink displays as the URL. The protocols HTTP and HTTPS are the only protocols allowed. FTP is not supported for hyperlink creation on forms.

   **Note:** The URL should not reference the same domain that Unifier is using for operation (for example, *ues.skire.com*). If you attempt to use the same domain, a warning message will result.

3. Click OK.

To reset a hyperlink

1. Click on the hyperlink area on the form. The Hyperlink window displays.

2. In the Hyperlink window, click Clear. This will remove the existing hyperlink.

3. Enter a new hyperlink name and URL.

4. Click OK.
IMPORTING DATA INTO PRIMAVERA UNIFIER

Primavera Unifier’s integration feature imports data into Primavera Unifier from an outside data source. Using this feature, you can import data from an outside application, such as an accounting system, into Primavera Unifier, and thereby, create records and line items. Importing is most effective in cases where you want to populate Primavera Unifier with a large amount of information that already exists in the other system.

This section discusses importing data into Primavera Unifier using CSV files. You can use CSV files to create records and line items for business processes and most of the Primavera Unifier managers. It is largely useful for converting a company’s legacy data into Primavera Unifier.

Once you have edited and saved the CSV file, you can import it back into Primavera Unifier to create the new records or line items. During the import process, Primavera Unifier validates the data. If the data passes validation, the new records or line items will be created. If the data fails the validation, you can view or download a text file summarizing the errors.

To use this feature, the business process or manager must include an integration interface that was designed in Primavera uDesigner. Separate integration interfaces are designed for each BP or manager, each specifying what fields will be populated when the new records or line items are created.

Note: New records can also be created by XML integration via Web Services. For more information about Web Services integration, see the Integration Interface guide. XML integration via Web Services must be coordinated with Primavera Unifier Consulting Services.

The integration interface feature supports:

- Cost BPs (except for Payment Applications)
- Line item BPs
- Simple BPs
- Text BPs
- Document BPs and documents
- Asset Manager classes
- Code-and-record-based configurable manager classes
- Planning Manager planning items
- Shell Manager shells
- Shell creation BPs

Overall Steps For Importing Data

Here is an overview of the steps involved in importing data from CSV files to create new records and line items.

1. Export the CSV template file to your machine.
   The CSV file contains the correct integration structure, with each row corresponding to a new record, and each column a field to be populated on the form.

2. Modify the CSV file.
Add new record data into the template CSV file, one record per row.

**3 Import the modified CSV file.**

After completing the CSV file, you can then import it back into Primavera Unifier to create the new records or line items. During the import process, Primavera Unifier validates the data. If the data passes validation, the new records or line items will be created. If the data fails the validation, you can view or download the CSV file with the error summary.

---

**Note:** The import process runs in background, allowing you to continue your work during the import and validation process. The amount of records being imported will affect the processing time. You will be notified by e-mail once the process is complete and the records have been imported or errors have occurred.

---

### Exporting The CSV Template To Your Machine

**To export an integration template**

1. Display the toolbar with the Export button as follows:

<table>
<thead>
<tr>
<th>To display the toolbar for this:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A business process at the company level</td>
<td>Select the name of the BP wherever it resides in the Navigator: in the Company Logs node, the General log node, or Data Manager log node.</td>
</tr>
<tr>
<td>A business process at the project/shell level</td>
<td>Select the name of the BP wherever it resides in the Navigator: in the Project Logs node, the Information &gt; General log node, or the Data Manager log node.</td>
</tr>
<tr>
<td>An asset class</td>
<td>In the Asset Manager node of the Navigator, select the asset class.</td>
</tr>
<tr>
<td>A planning item</td>
<td>In the Planning Manager node of the Navigator, select the planning item.</td>
</tr>
<tr>
<td>A class for a code-and-record-based configurable manager</td>
<td>In the [Manager] node of the Navigator, select the class.</td>
</tr>
</tbody>
</table>

2. Click the Export Template button and choose CSV.

3. Save the CSV file to your local drive.

### Editing The CSV File

Each row in a CSV file corresponds to a new record, and each column is a field to be populated on the form.

**Caution:** Do not add, move, or delete the columns in the CSV file.

**To edit the CSV file**

1. Open the CSV file in Microsoft Excel or a compatible application, such as a text editor or Notepad.
To add header (upper form) data to the file:

a. Move your cursor to an empty line and type an **H** in column A.

b. Press the **Tab** key to move to the next column and enter the value that you want to import for that field.

c. Repeat step b for all the fields in the row.

To add detail form data to the file:

a. Move your cursor to an empty line and type a **D** in column A.

b. Press the **Tab** key to move to the next column and enter the value that you want to import for that field.

c. Repeat step b for all the fields in the row.

4. If you have additional line item data that needs to be imported, repeat step 3 and its sub-steps until you have entered all the line items you want to import.

**Note:** Do not add, move, or delete the columns in the CSV file.

5. Save the file.

**Importing The CSV File Back Into Primavera Unifier**

Once you have edited and saved the CSV file, you can import it back into Primavera Unifier to create the new records or line items. During the import process, Primavera Unifier validates the data. If the data passes validation, the new records or line items will be created. If the data fails the validation, you can view or download a text file summarizing the errors.

**To import the file into Primavera Unifier**

1. Display the toolbar with the Import button as follows:
<table>
<thead>
<tr>
<th>To display the toolbar for this:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A business process at the company level</td>
<td>Select the name of the BP wherever it resides in the Navigator: in the Company Logs node, the General log node, or Data Manager log node.</td>
</tr>
<tr>
<td>A business process at the project/shell level</td>
<td>Select the name of the BP wherever it resides in the Navigator: in the Project Logs node, the Information &gt; General log node, or the Data Manager log node.</td>
</tr>
<tr>
<td>An asset class</td>
<td>In the Asset Manager node of the Navigator, select the asset class.</td>
</tr>
<tr>
<td>A planning item</td>
<td>In the Planning Manager node of the Navigator, select the planning item.</td>
</tr>
<tr>
<td>A class for a code-and-record-based configurable manager</td>
<td>In the [Manager] node of the Navigator, select the class.</td>
</tr>
</tbody>
</table>

2 Click the **Import** button. The File Upload window opens.

3 Fill in the fields on the File Upload window and click **OK**.

Primavera Unifier checks the import process to verify that valid records were created. Specifically, it validates that:

- The import file format matches the integration interface design that was created in Primavera uDesigner.
- The imported data is for the correct BP (that is, that the data was imported into the same log as that from which you exported the CSV template file).
- The imported data is correct; that required fields contain data in the correct format, the data type is correct, the correct values were added for drop-down menus, etc.
EDITING MULTIPLE RECORDS AT ONCE (BULK EDIT)

If you have a large number of records in a log that need similar edits, you can use Primavera Unifier’s bulk editing feature to update all the forms at once from the log. You can use bulk editing to modify the following types of records:

- Workflow and non-workflow multi-record business process records at the company, project, or shell level, and those in master logs
- Level and space records at the shell level
- Planning item records
- Asset records
- Records in a code-and-record-based manager

You can update a maximum of 200 records using bulk editing. You must have Allow Bulk Edit permission on the records. Bulk editing uses an integration interface to update multiple records. Your Administrator must design this integration interface in Primavera uDesigner before bulk editing is possible. If you receive a message that the interface has not been created, notify your Administrator.

For business processes, only the upper form can be modified during bulk editing. For all other types of records, the detail form can be modified. All system-generated field values and formula columns on manager sheets are automatically recalculated during the bulk edit.

On business processes, the bulk edit function works only on fields from the action form (upper form) for the current step in a workflow. It cannot be used to edit the following:

- Auto-populated fields
- Fields in a dynamic data set
- Read-only fields
- Fields from line items
- System-generated fields, such as record number, status, or due date

Note:

1. Bulk edits overwrite data without stopping for you to verify the edit. Be sure you have entered the data you want to edit correctly.

2. Bulk edit is not available for Resource Booking and Timesheet business processes, or single-record business processes.

3. If you use bulk edit to update multiple records, and attempt to update a field that has value uniqueness configured, only the first record will be updated (and is therefore unique).

From a master log, you can select records across projects or shells for bulk editing, but the following fields cannot be modified:

- Image Picker
- Program Picker
- Company Picker
- Group Name Picker
- User Picker
- Project Picker
To update multiple records using bulk editing

1. Navigate to the log where the records reside.
2. Select the records you want to bulk edit.
3. Choose Edit > Bulk Edit. The Bulk Edit window opens.
   The Bulk Edit window displays all the editable fields from the form that were included on the integration interface.
4. Modify the fields needed.
5. Select the Update checkbox beside the fields that you want to update. The checkbox is automatically selected when you type into or modify a field. You can deselect it if you do not want to modify the field at this time.

Note: If the Update checkbox is selected for an empty field, the field will be updated with a blank value.

6. Click Update. This launches the bulk edit of the selected records.
   When you click Update, a Bulk Actions Status window opens, where you can view the progress of the bulk edit.
   If you want to cancel the bulk update in progress, click Cancel.
7. After all the records have been processed, click OK.
USING THE FIND FEATURE IN PRIMAVERA UNIFIER

Primavera Unifier’s Find feature is an essential tool for working in Primavera Unifier. You can use it to find specific items on:

- Logs
- Manager sheets
- Pickers

You can also use the Find feature to filter logs to show a certain group of items. For example, you could use the Find feature to isolate the tasks on your Tasks log that you want to perform bulk actions on.

How The Find Feature Works

When you use the Find feature, Primavera Unifier narrows the list of items shown on a log, sheet, or picker to match the search criteria you specified. For logs with extensive lists, this can make finding specific business processes, tasks, line items, shells, etc., easier. For pickers with extensive lists, this can make completing the business process form much quicker.

Find windows show fields from the log, sheet, or picker that you can use to narrow the list of items you see. The fields that appear on Find windows are usually specified in Primavera uDesigner when the logs are designed for the business processes, managers, and pickers. The fields you see on your Find windows will depend on these designs. Some logs, such as the Mail logs, use a “canned” Find window because these logs are not designed in Primavera uDesigner.

Primavera Unifier uses two types of Find windows:

- A floating window
- A static window
FLOATING FIND WINDOWS

You can move floating Find windows around the screen. In addition, they offer advanced search features, such as changeable operators. Most floating Find windows give you the option of saving the search so that you can use it again to search these logs. By default, any saved search you create is yours, and is not available to other users unless you mark it “public.”

In many floating Find windows, fields often show an operator, such as “contains” or “equals,” which you can use to specify more precisely which items you want to see. In the example Find window below, you could narrow the list to show only forms with a status of “pending.” Or to show only those forms with a status that equals “in progress.”

For Task logs and business process logs, you can save the search criteria to use again. To save a search, enter a name for the search and click the Save button.

To clear all the search fields, click the Clear button. All the fields will be reset to their default values, if any.

Some fields have a Select button that opens a picker or displays a list of values to choose from. Some of these lists (e.g., a multi-select field) allow you to choose multiple values by holding down the Ctrl key as
you click the items. When you choose multiple values, Primavera Unifier’s search will return results that match any or all of the values you specified. This feature is a convenient way to conduct searches for multiple query values in one action.
STATIC FIND WINDOWS

Static Find windows appear at the top of a log and cannot be moved.

Changeable operators, such as “contains” or “equals,” are not available in static Find windows, nor is the “save search” feature.

Static Find windows display search results that do not include a banner across the top of the window. To restore the list of records to its unfiltered state, click the X icon in the upper-right corner of the Find window.
SEARCHING DATE FIELDS

The floating Find window provides comprehensive search criteria for date fields. If the date field on the Find window includes an operator, you may have the option of making the search relevant to today’s date.

For example, for a date field, such as a Payment Due Date, you could specify that the value in the field should be greater than or equal to:

Another example might be that the value in the field should be between:

Floating Find windows display search results that include a banner across the top of the window. This banner indicates that the list has been searched, or filtered. To restore the list of records to its unfiltered state, click Cancel Filter in the banner.
To restore the list of records to be unfiltered state, click Cancel Filter in the banner.

<table>
<thead>
<tr>
<th>Record Number</th>
<th>Title</th>
<th>Status</th>
<th>Ora2e</th>
<th>Award Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACT00001</td>
<td>AP RFP review/Approving</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00002</td>
<td>AP RFP review/Approving</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00003</td>
<td>Cost Estimate Analysis</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00004</td>
<td>Action Path Audit</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00005</td>
<td>Yearly RFP Process</td>
<td>Pending</td>
<td>Ora2e</td>
<td>02/22/2010</td>
</tr>
<tr>
<td>ACT00006</td>
<td>Resource Allocation Plan</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00007</td>
<td>Plan Allocation Analysis</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00008</td>
<td>Budget Review</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00009</td>
<td>Budget Increase</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00010</td>
<td>Vendor Selection</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
<tr>
<td>ACT00011</td>
<td>Vendor Selection</td>
<td>Pending</td>
<td>Ora2e</td>
<td></td>
</tr>
</tbody>
</table>
SEARCHING A TASKS OR BUSINESS PROCESS LOG

These logs use a floating Find window. Searching these logs means searching for business process records. To search these logs, use these instructions, along with the description of floating windows under See "Floating Find windows" on page 46.

To search a log

1. Open your Tasks log or the business process log you want to search.
2. Click the Find button.
3. Enter the search criteria.
   - In those fields with operators you cannot change, enter the value the field should contain, or click the Select button and select the value from the list that appears.
   - In those fields that show an underlined operator, first click the operator and choose the operator you want to use on the field, such as “equals” or “does not contain.” Then enter the value the field should contain.
   - Some fields have a Select button that opens a picker or displays a list of values to choose from. Some of these lists (for example, for multi-select fields) allow you to choose multiple values by holding down the Ctrl key as you click the items.
4. (Optional) Save the search.
   In the Save As field, enter a name for the search, and click the Save button.

   For more information about saving searches, See "Using and editing saved search criteria" on page 60.

5. For business process logs:
   a. If you want to sort the records in the log by special groupings, in the View Records equals field, select:

| (blank)                                      | To list all project/shell records to which you have permissions. |
| Created by Me                                | To list all project/shell records that you created.             |
| Received by Me                               | (Workflow records only) To list the tasks assigned to you.     |
| Created and Received by Me                   | (Workflow records only) To list all project/shell records you created and the tasks assigned to you. |
| All Company Records                          | To list all records.                                           |

   b. For workflow business process records, in the Workflow Status equals field, select:

| (blank)                                      | To list all records (in progress as well as closed) filtered by the value you entered in the View Records equals field. |
| In Progress                                  | To list all records that are currently in progress. These records can be assigned to you or to other users.         |
| In Progress and Currently                    | (Workflow records only) To list those records that are in progress, assigned to |
Click the **Search** button (or press the **Enter** key on your keyboard).

Primavera Unifier performs the search and displays all the records that met the criteria you entered. For example, this search located all the Transmittal business processes on a Tasks Log:

**6** Click the **Search** button (or press the **Enter** key on your keyboard).

Primavera Unifier performs the search and displays all the records that met the criteria you entered. For example, this search located all the Transmittal business processes on a Tasks Log:

---

**Tips for Searching a Tasks Log**

- As well as searching for a specific task, you can use the Find feature to limit the records that are listed on your Tasks log. This can be convenient for streamlining your work on tasks, such as quickly approving multiple cost transaction records. Using the Find feature, you can separate those records you can quickly dispatch from those that need to be reviewed in detail.
- Filtering the Tasks Log is also a convenient way to isolate tasks that you can perform using bulk actions. Once you have filtered the list, select the task(s) and use the **Bulk Actions > With Preview** option to quickly open, accept, and complete the task.
- The **Clear** button works a bit differently on the Tasks log. Depending on the type of business process you are searching, you may see different fields to search by. When you use the Clear button, Primavera Unifier will remove these fields from the Find window.
SEARCHING A SHELL LOG

Since shell hierarchies can be extensive, the Find feature is helpful in locating specific shells. You can search for shells using a geocode (a longitude and latitude specification), or you can search for shells using shell information, such as name or state.

To search a shell log

1. Click the anchor shell tab that contains the shell you want to locate. The shell dashboard appears, and a “mini log” of sub-shells appears at the bottom of the window.

2. From the View drop-down list on the mini log, select the sub-shell you want to search.

3. Click the Find button. Primavera Unifier collapses the dashboard to show only the mini log, and displays a Find window.

4. On this Find window, you can search using a geocode or using form fields, but not both.

5. Choose one of the procedures below.

To search on shell information (form fields)

1. Choose the operator you want to use on the field, such as “equals,” “does not contain,” or “is empty.”

2. Enter the value the field should contain.

3. Click Search (or press Enter). Primavera Unifier displays all the shells that meet the search criteria you entered.

4. When you have finished using the Find feature, click the Restore button to return the dashboard to normal view.

To search for a shell using a geocode

1. To search using a geocode, choose either an address or a latitude and longitude.
   • In the Address field, enter a full or partial address for the shell, or
   • In the Latitude and Longitude fields, enter the values, if you know them.

2. If you do not know the longitude and latitude, click the globe icon beside the Latitude field. A Geocode Picker opens.
   a. Select the Enter Address field and enter the address, or a partial address.
   b. (Optional) To see the location on the map, click the Map It button. Primavera Unifier will fill in the decimal degrees for the latitude and longitude, as well as the degrees, minutes, and seconds.
   c. Click OK. Primavera Unifier will fill in the Latitude and Longitude fields on the Find window.

3. Back in the Find window, in the Radius field, enter a value to specify a search radius surrounding the address or longitude/latitude coordinates.

4. Click Search (or press Enter). Primavera Unifier displays all the shells that meet the search criteria you entered.
5 When you have finished using the Find feature, click the **Restore** button to return the dashboard to normal view.
SEARCHING MANAGER LOGS

Most manager logs, including configurable manager logs, display static Find windows and work much the same. The Planning Manager displays a floating Find window. In addition, the Document Manager and Shell Manager work differently and are explained separately.

In most manager logs, you will be searching for sheets. In the following managers, you can search for additional objects:

- In the Cost Manager log, you can search for earned value, general spends, and payment applications.
- In the Resource Manager log, you can search for resources or (if you are in administration mode) roles.
- In the Schedule Manager, you can search for custom calendars.

To search most manager logs

1. Go to the Company Workspace tab, or open the project or shell where the manager resides.
2. In the left Navigator, click the manager node you want to search. The manager expands to list sub-nodes.
3. If there are sub-nodes in the Navigator, click the sub-node you want to search.
4. Click the Find button in the toolbar.
   Primavera Unifier displays a Find window above the right pane. The window will display different fields, depending on how the manager has been designed.
5. Enter your search criteria and click Search (or press Enter on your keyboard). Primavera Unifier displays all the items that meet the search criteria you entered.
SEARCHING THE DOCUMENTS LOG

The Document Manager lists published and unpublished documents in separate logs, but the Find window works the same in both logs. In these logs, you can search for both folders and documents.

**Note:** The Find feature searches only the latest versions of documents. It does not search older versions.

In the Document Manager, the Find feature offers you two search options:

- **By Properties.** With this option, you can search the metadata of the folder or document, which can include properties such as the name, owner, title, or creation date.
- **By Content.** With this option, you can search folders and documents for specific content. You can search by single words or phrases.

**Note:** The content option is not available for drawing files.

**To search the Document Manager**

1. Select the folder you want to search. Primavera Unifier will search the folder you select, as well as its subfolders.
2. Click the Find button and choose:
   - **Search by Properties** to search by metadata
   - **Search by Content** to search for specific content
   Primavera Unifier displays the Find window above the log.
3. Enter the search criteria you want to use.
   If you are searching for a name, you can use the wildcard %.

**The Search by Properties Option and Dates**

If you are using dates to search for documents, you have the option of entering only one date. If you enter only the first date, Primavera Unifier will show all the documents from that date onward. If you enter only the second date, Primavera Unifier will show all the documents from that date and prior to that date.

4. Click the **Search** button (or press Enter).
   Primavera Unifier will display any matches it finds on the Documents log.

**Tip:** For best results, use only alpha-numeric characters in your search criteria. If you are not receiving the search results you expect, try placing your criteria in quotes.
SEARCHING MAIL LOGS

Mail logs include uMails and mail from users who are external to Primavera Unifier. Mail logs use a “canned” search because these logs are not designed in Primavera uDesigner.

To search for mail

1. In the Navigator, click a mail node; that is, any of the sub-folders under uMail, or the Mailbox node.

2. From the toolbar, click the Find button. The Find box appears above the log.

3. Use the information in the table below to fill in the Find criteria.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Enter:</th>
</tr>
</thead>
<tbody>
<tr>
<td>From (User) or To (User)</td>
<td>The sender’s or recipient’s name. Click the Select button and choose the user from the User/Group picker that appears.</td>
</tr>
<tr>
<td>Subject containing</td>
<td>A word or phrase from the message’s subject line. You can enter whole or partial words.</td>
</tr>
<tr>
<td>Message containing</td>
<td>A word or phrase from the message’s content.</td>
</tr>
<tr>
<td>Items that are:</td>
<td>This field does not appear on all Find windows for email. If it does, you can specify that the search display only those emails that have been Read or Unread.</td>
</tr>
</tbody>
</table>

4. Click Search. Primavera Unifier lists the messages meeting your search criteria in the log.
SEARCHING SHEETS

For all manager sheets except the Cost sheets, searching for items entails searching a specific column on the sheet for a value. Primavera Unifier will search the line items in that column and highlight the value, if it finds it. (For cost sheet searches, see below.)

To search a sheet

1. Open the sheet.
2. Click the Find button (or choose Find from the View menu). A Find window opens.
3. In the Column field, choose the column that contains the value you are looking for.
4. In the Value field, enter the value you are searching for.
   You can enter a full or partial word, number or other value, but do not enter a wildcard character for partial entries. The format of your entry will depend on the type of value you are searching for. If you are searching for a fund code, you can include the code separator if one is used (for example, a dash).
5. In the Search field, choose the direction in which you want to search, relevant to the location of your cursor on the sheet. Choose Up or Down.
6. Click the Find Next button.
   If Primavera Unifier finds the value, it will highlight the row on the sheet.

Search For Cost Codes On A Cost Manager Sheet

The Find feature on the Cost Manager Sheet works differently from other sheets. On Cost Manager Sheets, you will be looking for a cost code.

To search for a cost code

1. In the Cost Sheet window, click the Find button. The Cost Code Find window opens.
2. Select the cost code segment you want to search by.
3. In the Cost Type field, select the cost type you are looking for.
4. Click OK.
   Primavera Unifier will display the results in a separate cost sheet window.
SEARCHING PICKERS

Most pickers include a Find feature with which you can locate specific objects (codes, assets, business processes, users, shells, etc.) while you are working on a form or a sheet. When you use this Find feature, Primavera Unifier narrows the list of items shown on the picker to match the search criteria you specified. For pickers with extensive lists, this can make completing the business process form much quicker.

Some pickers display static Find windows; others display floating windows like the Task and business process logs (however, without the “save search” feature).

For most pickers, the Find feature works as generally described under See “Floating Find windows” on page 46 and See “Static Find windows” on page 48; however, the User/Group Picker works differently.

Notes
Fund Pickers are most often searchable by the fields that were created for the fund attribute form in Primavera uDesigner. However, if no attribute form was created for the fund, you can search for the fund by its name or code.

Pickers that include WBS codes display information generated from a sheet (the cost sheet or an SOV). Consequently, the Find feature on the WBS Picker, Commit Line Item Picker, and SOV Picker works the same way as it does on manager sheets. For instructions on using these pickers, See “Searching Sheets” on page 58.

To find a user in the User/Group Picker

1 Open the User/Group Picker.

2 The List Names from field shows the project/shell or company from which the users’ names will come. (This field is editable only by your company Administrator.)

3 Use the Show By field to restrict the search to users only, to groups only, or to both.

4 In the Search for field, enter a name, or partial name.

5 Click Search or press Enter.

Primavera Unifier uses the filters at the top of the Find window and searches the picker list according to the project/shell, or company specified in the List Names field, as well as the Show By option you specify (users, groups, or both).

Primavera Unifier displays on the picker the names that met the search criteria you entered, and also displays above the list this line: Current View: <filtered by ...> [Cancel Filter].

Note: If you choose to, you can cancel the search action by clicking [Cancel Filter]. Primavera Unifier will restore the picker list.
USING AND EDITING SAVED SEARCH CRITERIA

You can save searches for reuse in Tasks logs and business process logs. The searches that you save are available in the logs for you to reuse. You can make them available to other users by making them “public.” When you mark a saved search public, that search can be used by other users in all business process logs to which those users have permissions. You can add searches created by other users (and marked public) to your own list of saved searches.

To use a saved search to search or filter a log
Open the log, click the Filtered By drop-down, and choose the search you want to use. Primavera Unifier will filter the log to show only those records that match that search criteria.

To view and edit a saved search
Once you have saved a search, you can change its name or description and certain other attributes using the Manage Saved Searches window.

1. From your log, click the Edit menu and choose Saved Searches.
   The Manage Saved Searches window opens. This window lists all the searches that have been saved for this log by Primavera Unifier users.

   The list of saved searches shows:
   • The name of the search
   • A description of the search
   • Whether or not the search has been made public
   • Who owns the search
   • (On business process logs) Whether or not this search is the default search that will appear when you use the Filter By menu on the business process log

2. Use the information in the following table to edit the saved searches.

<table>
<thead>
<tr>
<th>Use this field:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order</td>
<td>Change the order of saved searches that appears in the Filtered By menu on the log. Click in an Order field and enter a positive number. Then click the Update Order button to see the new order.</td>
</tr>
<tr>
<td>Name</td>
<td>Change the name of a saved search. Select the name and enter a new one. You can rename only the saved searches that you have created.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description for your saved search (up to 150 characters). You can add a description only for saved searches you have created.</td>
</tr>
<tr>
<td>Default</td>
<td>Make this search your default search. Select the checkbox to make this search appear first in the Filtered By drop-down menu. The “Default” option is not available for Tasks log searches.</td>
</tr>
<tr>
<td>Public</td>
<td>Make your saved search public; that is, available to other users. Select the checkbox to designate a saved search as public, or deselect the checkbox to make the saved search private.</td>
</tr>
</tbody>
</table>
3 Use the buttons described in the following table to perform other editing options.

<table>
<thead>
<tr>
<th>Click this button:</th>
<th>To:</th>
</tr>
</thead>
</table>
| Public Searches             | View public saved searches created by other users.  
|                             | • To add the search to your list of saved searches, select one or more searches and click Select. You cannot modify saved searches created by other users.  
|                             | • To modify someone else's saved search for your use, select it (or select multiple searches) and click Copy. This copies the search so you can modify it to create a new search. The new search is initially marked as private, and you are designated as the owner. |
| Remove                      | Remove a search from your saved searches list. Select the search and click Remove. You can delete only saved searches that you have created. |
| Move Up / Move Down          | Reorder the searches in the list. Select a saved search and move it up or down the list by clicking the Move Up or Move down button. |
| Update Order                | Preview the revised order of the saved searches. The new ordering is saved when you click the Save button.                         |

4 Click **Save** to save your changes.

5 Click **Close Window** to close the Manage Saved Searches window.
What You Can Do In The Company Workspace

The Company Workspace is the home for managing company assets and resources, the company-level Document Manager and Cost Manager, company-level business processes, and more. Depending upon the modules your company has set up and your access permissions, the following company functions are available in the Navigator.

**Note:** The example below displays the default Navigator appearance. Company administrators can configure the User Mode Navigator to better suit business needs, for example, creating additional nodes to store business process records, renaming some of the nodes mentioned below, etc. Your Navigator may differ, but the basic functionality will be the same.

- **Summary:** Provides a snapshot of project or shell information for the company. You can customize your summary page.
- **Collaboration:** Similar to the project or shell level collaboration area, lists current company-level business process tasks, messages, and drafts business process logs.
- **General:** This log stores company-level, simple-type business processes.
- **Data Manager:** This is a collection of logs storing company-level business processes created in Primavera uDesigner.
- **Asset Manager:** Manage assets in asset sheets.
- **Cost Manager:** Access company-level Cost Manager functions as listed below.
- **Document Manager:** Repository of company-level and cross-project or shell documents, allowing collaboration, revision control, markups, etc.
- **Planning Manager:** Create planning items and manage planning sheets. S
- **Resource Manager:** Manage staff resources and role information.
- **Company Logs:** Primary storage of company-level business processes.
- **Reports:** For creating and generating company-level, user-defined reports.
**OPEN THE COMPANY WORKSPACE**

Open the Company Workspace page to access company-level features.

**To access the company workspace**

1. Go to the **Company Workspace** tab and switch to User mode.

2. In the left Navigator, click the name of your company. The Company Home page opens, displaying the following information:
   - **Location:** Click this link to open an interactive map of the company location. You may scroll through the map, zoom in or out (upper left corner of the map window), or change views (select one of the options in the upper right corner). The map locations are based on the address(es) entered by the company administrator, and shows the location of your company headquarters, and possibly other company addresses or offices.
   - **Contact Name:** Click on the link to view contact details for your Primavera Unifier company contact.
   - **Home Page URL:** Your company administrator may provide a link to the company web site or other home page.
   - **Help URL:** Your company administrator may also provide a link to an internal source of supporting information, such as a company intranet site.

**View Company Location Map**

The Company Home page provides a link to an online map of the company locations, as defined in the company properties.

**To view the company location map**

1. Go to the **Company Workspace** tab.

2. On the company home page, click the **Location** link. An interactive map opens and displays the company locations.

3. You may zoom in or out, or change views:
   - **Map:** Displays the map view.
   - **Satellite:** Displays the aerial photograph view.
   - **Hybrid:** Displays the aerial photograph overlain with map markings.

**Working With The Company Summary**

The company summary provides a snapshot summary of values from your projects and shells.

You can customize the company summary to display any reportable project or shell related information in table or graphical format. The summary information is pulled from summary-type, user-defined reports or from pre-configured, standard data-type reports. You can add the reports that you want to display, and move them around to customize the summary view.

You can also print the company summary.
To access the company summary
Go to the Company Workspace tab and click Summary in the Navigator. The Company Summary page opens.

To add reports to the user view

1 Go to the Company Workspace tab and switch to User mode.

2 Click Summary in the left Navigator. The Summary window opens in user view. The initial reports included in the summary are displayed in table format. You have the option to modify how these reports display, remove them from the summary view, or add other summary reports.

3 From the Edit menu, choose one of the following:
   - **Left Column:** To add information to the left side of the window
   - **Right Column:** To add information to the right side of the window

   The Left Column Blocks or Right Column Blocks window opens.

4 Do one of the following:
   - To add a user-defined summary report, click the Add Custom button. The Custom Summary Block window opens. Complete the window and click OK.
   - To add a pre-configured, standard data-type report, click the Add Standard button. The Standard Summary Block window opens. Complete the window and click OK.

   The report will be added to the Blocks window.

5 Click Close. The Company Summary - User View window will update to include the new report.

Available company-level standard reports

<table>
<thead>
<tr>
<th>Name</th>
<th>Drill down to</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;BP Name&gt; Count by Status</td>
<td>No drill down</td>
</tr>
<tr>
<td>&lt;BP Name&gt;% by Status</td>
<td>No drill down</td>
</tr>
<tr>
<td>&lt;BP Name&gt; Count by Company</td>
<td>No drill down</td>
</tr>
<tr>
<td>&lt;BP Name&gt;% by Company</td>
<td>No drill down</td>
</tr>
<tr>
<td>&lt;BP Name&gt; Count by User</td>
<td>No drill down</td>
</tr>
<tr>
<td>&lt;BP Name&gt;% by Creator User</td>
<td>No drill down</td>
</tr>
<tr>
<td>&lt;BP Name&gt; - Tasks by User</td>
<td>Home □ Tasks</td>
</tr>
<tr>
<td>&lt;BP Name&gt; - Tasks All Users</td>
<td>Home □ Tasks</td>
</tr>
<tr>
<td>Record Count per BP</td>
<td>No drill down</td>
</tr>
<tr>
<td>Current User Task Count</td>
<td>Home □ Tasks</td>
</tr>
<tr>
<td>All User Task Count</td>
<td>No drill down</td>
</tr>
</tbody>
</table>

To manage blocks on the Company Summary - User View

1 Go to the Company Workspace tab and switch to User mode.

2 Click Summary in the left Navigator.
3 From the Edit menu, choose one of the following:
   • Left Column: To add information to the left side of the window
   • Right Column: To add information to the right side of the window

The Blocks window opens. The blocks are listed in the order in which they appear on the page.

4 To move a block, select it and click Move Up or Move Down.

5 To delete a block, select it and click Delete.

6 To change the display type, title, or other block property, select the block and click Open. Make changes as necessary and click OK.

To print the company summary

1 Go to the Company Workspace tab and switch to User mode.
2 Click Summary in the left Navigator.
3 From the File menu, click Print Preview. The preview window of the summary displays.
4 Click the Print icon in the upper right corner of the window.

For more information, see Adding an Image and Adding a Hyperlink.
PROJECTS
OPEN A PROJECT

Open a project to access the project functions and its tabs (see below.) Projects are listed on the Standard Projects tab. For details on navigation, see "Navigating in Primavera Unifier" on page 9.

**Note:** Your company may have configured the navigation so that the labels on the navigation tabs across the top or nodes on the left Navigator may differ from the default labels discussed here.

**To access your projects**

Go to the **Standard Projects** tab and switch to User mode. The Project log opens, listing all of the projects to which you have access. The log shows:

- **Number:** The number assigned to the project.
- **Project Name:** The name of the project.
- **Company Name:** The sponsoring company for the project. This may be your own company or another company for which your company is a partner company in the project.
- **Status:** The status of the project. See "About Project Statuses" on page 70.
- **Asset Name:** If the project has been associated with a company asset, the asset will be listed in this column.

**To open a project**

Select a project from the Projects log and click **Open**. The project home page opens, providing an overview of the project.

When you open the project home page, the Navigator expands, providing access to project-level features and business processes.
WHAT YOU CAN DO IN A PROJECT

The Navigator displays the project-related Primavera Unifier features that you have permission to access. Depending upon the modules your company has set up and your access permissions, the following project functions are available in the Navigator.

**Note:** The example below displays the default Navigator appearance. Company administrators can configure the User Mode Navigator to better suit business needs, for example, creating additional nodes to store business process records, renaming some of the nodes mentioned below, etc. Your navigator may differ, but the basic functionality will be the same.

- **Summary:** The Project Summary provides a snapshot of the overall project. You can use the standard view or customize your own summary page. See "Working with the Project Summary" on page 71 for details.
- **Alerts:** You can create customized alerts to alert you to a condition or event in Primavera Unifier that you specify. See "Managing Project Alerts" on page 75 for details.
- **uMail:** An internal Primavera Unifier e-mail feature that allows Primavera Unifier project team members to communicate with each other and maintain a record of the communications. See "Working with uMail" on page 77 for details. For projects with View-Only or Inactive status, uMail is available for viewing, but you cannot send, edit or delete messages.
- **Mailbox:** The Mailbox is the repository that collects external emails related to the project. These emails can come from project members or from external users who do not use Primavera Unifier. From the Mailbox, project users can forward the emails to appropriate members, flag them for review, and reply to them. In addition, these external emails can be linked to business process records. See "Using the Project Mailbox" on page 83 for details.
- **Collaboration (Tasks, Messages, Drafts):** Lists current business process tasks that have been assigned to you, that you have been copied on, and draft copies that you have saved. Tasks and Drafts are not available for View-Only projects. Messages are available for View-Only projects, but you cannot add general comments.
- **Project Directory:** List of project team members. See "View the Project Directory" on page 89 for details.
- **General:** List of simple-type business processes.
- **Gates:** Displays project phase and gates information, and enables manual or automatic advancement of project phases. See "Working with Gates" on page 92.
- **Cost Manager:** Access project-level Cost Manager functions (cash flow, cost sheet, earned value, funding, schedule of values). Cost Manager is discussed in
- **Document Manager:** Repository of project documents, allowing collaboration, revision control, markups, etc.
- **Resource Manager:** Manage staff resources and role information.
- **Data Manager:** A collection of BP logs storing project-level business processes not stored in project logs.
- **Schedule Manager:** Manage project schedules, and import other related schedule files.
- **Project Logs:** Primary storage of transaction and other project business processes.
- **Reports:** Access to system and user-defined reports.
VIEW PROJECT LOCATION MAP

The Project Home page provides a link to an online map of the project location, as defined in the project properties.

To view the project location map
Open the project and click the Location address link on the home page. An interactive map of the project location opens.

You can scroll through the map, zoom in or out, or change views. The different views that may be applicable are:

- **Map**: Displays the map view.
- **Satellite**: Displays the aerial photograph view.
- **Hybrid**: Displays the aerial photograph overlain with map markings.
ABOUT PROJECT STATUS

Your project can have one of four statuses:

**Active**: A live, in-progress project.

**On-Hold**: The initial project status. On-Hold projects are listed on the projects log, but you cannot work with them.

**View-Only**: View-Only projects can be viewed, printed, exported, and included in reports. You cannot modify any data in View-Only projects. This allows you to view past projects without allowing changes to these projects.

**Inactive**: Used to suspend project usage. Inactive projects are visible to Administrators, but not to end users. Only System and Project Administrators (users with Modify Status rights) can reactivate the project.

---

**Note**: If automatic status update is enabled on a project, the status of the project can change from Active to an inactive status (On-Hold, View-Only, Inactive). The change of status is set up by the Administrator, and is based on defined triggering conditions. For example, if a project is close to exceeding its funding, it might make sense to put it On-Hold while funding matters are discussed. Your project administrator must manually change the status back to Active when you are ready to restart the project.

The Project Administrator will receive e-mail notification when the status of a project changes. The change of project status could occur due to a manual change, bulk update, through Web Services or a CSV file, or through automatic update.
WORKING WITH THE PROJECT SUMMARY

The project summary provides a snapshot of the overall project. You can configure what information is displayed in your project summary. There are two available views of the project summary:

**Standard View:** The standard view of the project summary displays an overview of the project:

- Project name and number, project administrator, and the number of people on the project.
- Project schedule data, including schedule tracking information.
- Cost data relative to expenses incurred on the project to date from the project cost sheet. Total amounts are displayed and rounded to the nearest integer. “Invalid” displays for any entry that contains an invalid entry in a Cost Manager formula.
- Current tasks and their progress.
- Project-level business process records. Click a business process on the list to display the number of records that exist for that business process.
- From the View By selection list, choose Status (displays the total number of project records for each business process and the current status) or Originating Company (displays the total number of project records originated per company, listed by company short name; applicable if your partner companies can create business processes for the project).

**User View:** You can customize the project summary to display virtually any reportable project-related information in table or graphical format. The summary information is pulled from summary-type, user-defined reports or from preconfigured standard data-type reports.

You can drill down to the respective log window by clicking a hyperlink from a summary report block.

**To access the project summary**

1. Open a project and click **Summary** in the Navigator.
2. Click the **View** menu, and choose **Standard** to view the standard view or **User** to view the user-defined view.
3. Click a link to jump directly to the respective log window.

**To print a project summary**

1. Open a project and click **Summary** in the Navigator. You can print both the user view and the standard view.
2. From the **File** menu, click **Print Preview**. The preview window of the summary opens.
3. Click the **Print** icon in the upper right corner of the window.

**Configure your project summary**

To help you keep track of the information that is most useful to you, you can customize the information that is displayed in the Project Summary window. Each part of the summary page is called a block. The data shown in a block can be in table form, a bar graph, or a pie chart. The summary page displays blocks on the right or the left.

You can add, edit, view, or delete summary reports as described below. You can customize how the summary report data is arranged in the Project Summary window, including displaying it on the left or
right column, arranging the order of the display, and displaying the information as a table, bar chart, or pie chart.

The data that is displayed in this view is generated from summary-type, user-defined reports. Each block represents one report.

### Available project-level standard reports

<table>
<thead>
<tr>
<th>Name</th>
<th>Drill down to</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;BP Name&gt;</code> Count by Status</td>
<td>BP Log</td>
<td></td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code>% by Status</td>
<td>BP Log</td>
<td></td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code> Count by Company</td>
<td>BP Log</td>
<td></td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code>% by Company</td>
<td>BP Log</td>
<td></td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code> Count by User</td>
<td>BP Log</td>
<td></td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code>% by Creator User</td>
<td>BP Log</td>
<td></td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code> - Tasks by User</td>
<td>Project □ Collaboration □ Tasks</td>
<td></td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code> - Tasks All Users</td>
<td>Project □ Collaboration □ Tasks</td>
<td></td>
</tr>
<tr>
<td>Record Count per BP (for current user)</td>
<td>BP Log based on which BP link was clicked</td>
<td>Yes</td>
</tr>
<tr>
<td>Record% per BP</td>
<td>BP Log based on which BP link was clicked</td>
<td></td>
</tr>
<tr>
<td>All Users (by company)</td>
<td>Project □ Project Information □ Project Directory</td>
<td></td>
</tr>
<tr>
<td>Logged in Users (by company)</td>
<td>Project □ Project Information □ Project Directory</td>
<td>Yes</td>
</tr>
<tr>
<td>Current User Task Count</td>
<td>Project □ Collaboration □ Tasks</td>
<td>Yes</td>
</tr>
<tr>
<td>All User Task Count</td>
<td>No drill down</td>
<td></td>
</tr>
<tr>
<td>Total Documents</td>
<td>Drill down to Document Manager</td>
<td>Yes</td>
</tr>
</tbody>
</table>

### To add reports to the user view

1. Create summary-type reports that include the information that you want to display in the summary.
2. Open a project and click **Summary** in the Navigator. The Summary window opens.
3. Click the **View** menu and choose **User**.

The initial reports included in the summary are displayed in table format. You have the option to modify how these reports display, remove them from the summary view, or add other summary reports.

4. From the **Edit** menu, choose one of the following:
   - **Left Column**: To add information to the left side of the window
   - **Right Column**: To add information to the right side of the window

The Left Column Blocks or Right Column Blocks window opens.
5 Do one of the following:

- To add a user-defined summary report, click **Add Custom**. The Custom Summary Block window opens. Complete the window and click **OK**.
- To add a pre-configured, standard data-type report, click **Add Standard**. The Standard Summary Block window opens. Complete the window and click **OK**.

Use the information in the following table to complete the fields in the **Add Custom** window.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>Click the Select button. The User-Defined Reports window opens, listing the available summary reports. Select a report from the list, and click the Open button. (If the list is long, you may click the Find button and enter search criteria to help locate a specific report.) Note: Note: Reports that are already used in the summary page are shown with a check mark. You can use a report more than once. For example, you might want to include the same report in both table and pie chart formats.</td>
</tr>
<tr>
<td>Description</td>
<td>This is populated automatically with the report description, if one exists.</td>
</tr>
<tr>
<td>Block Title</td>
<td>This will appear over the data on the summary page. By default, the field will show the report name, but is editable.</td>
</tr>
<tr>
<td>Display Type</td>
<td>Choose to show the data as a bar chart, pie chart, or table format.</td>
</tr>
<tr>
<td>Show Result</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Actual Value</strong>: Shows the actual value of what is being reported (number of records for a particular BP type, etc.).</td>
</tr>
<tr>
<td></td>
<td>• <strong>Percent distribution of total</strong>: Calculates the value as a percentage of the total (the percentage of total records to which a BP type corresponds, etc.).</td>
</tr>
<tr>
<td>Show Total</td>
<td>Select this checkbox if you want to display the total value of the data. This will vary, depending on what data is used in the report. For example, it may include the total number of records, total currency amount, etc.</td>
</tr>
</tbody>
</table>

Use the information in the following table to complete the fields in the **Add Standard** window.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>This field will auto-populate with the selection from the Report On field.</td>
</tr>
<tr>
<td>Data Type</td>
<td>Choose a standard data type to add to the summary. Choices include:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Business Process</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Document Management</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Active Task Information</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Users</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>List of project business processes</strong></td>
</tr>
<tr>
<td>Report On</td>
<td>The selection list is dependent on what is chosen from Data Type. Choose from the selection list. The Report Name field will auto-populate with the standard report.</td>
</tr>
<tr>
<td>Block Title</td>
<td>This will appear over the data on the summary page. By default, the field will show the report name, but is editable.</td>
</tr>
</tbody>
</table>
### In this field | Do this
---|---
Display Type | Choose to show the data as a bar chart, pie chart, or table format.

#### Show Result
- Choose one of the following:
  - **Actual Value**: Shows the actual value of what is being reported (number of records for a particular BP type, etc.).
  - **Percent distribution of total**: Calculates the value as a percentage of the total (the percentage of total records to which a BP type corresponds, etc.).

#### Show Total
- Select this checkbox if you want to display the total value of the data. This will vary, depending on what data is used in the report. For example, it may include the total number of records, total currency amount, etc.

---

6 Click **Close**. The Project Summary - User View window will update to include the new report.

### To move or delete blocks on the Project Summary - User View

1. Open the Project Summary - User View.
2. From the Edit menu, choose one of the following:
   - **Left Column**: To add information to the left side of the window
   - **Right Column**: To add information to the right side of the window

   The Blocks window opens. Blocks are listed in the order in which they appear on the page.

3. To move a block, select it and click **Move Up** or **Move Down**.

4. To delete a block, select it and click **Delete**.

### To change the display type, title, or other block property

Select the block and click **Open**. Make changes as necessary and click **OK**.
MANAGING PROJECT ALERTS

You can create customized alerts to alert you to a condition or event in Primavera Unifier that you specify. For example, you might set up an alert that will send you an e-mail or uMail message letting you know that a fund amount on the funding sheet has reached a certain level.

Alerts are created by creating an alert-type user-defined report.

To create an alert

1. Create an alert report in user-defined reports.
2. Open a project and click Alerts on the Navigator. The Alerts log opens.
3. Click New. The Alert window opens. Complete the window as described in the following table.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>Click the Select button. The list of user-defined alert reports for the project opens. Select a report from the list, and click the Open button. (If the list is long, you may click the Find button and enter search criteria to help locate a specific report.) Note: Reports that are already used to create an alert are shown with a check mark. You can create more than one alert for each report.</td>
</tr>
<tr>
<td>Description</td>
<td>This is populated automatically with the report description, if one exists.</td>
</tr>
<tr>
<td>Alert Title</td>
<td>This will appear as the title of the alert in the log and on the alert sent. By default, the field will show the report name, but this is editable.</td>
</tr>
<tr>
<td>Frequency</td>
<td>Choose the frequency that you want the alert to be sent when the trigger condition is met: • Never: Alerts will not be sent. • Hourly: Alerts will be sent every hour, at about 20 minutes past the hour. • Daily: Alerts will be sent daily at about 2:20 a.m. • Weekly: Alerts will be sent on Mondays at about 2:20 a.m. • Monthly: Alerts will be sent on the first day of the month, about 2:20 a.m. Times may vary somewhat. The times noted above refer to server time, that is, the time according to the Primavera Unifier server being used. (Primavera Unifier servers operate on Pacific Standard Time.). Note: If you choose any frequency other than Never, you must specify a method and message.</td>
</tr>
<tr>
<td>Method</td>
<td>You may select one or both of the following methods to be notified of the alert: Email (the e-mail on your user profile will be used) or uMail.</td>
</tr>
<tr>
<td>Message</td>
<td>Type a message that you want to be included in the alert. Remember that this is an alert that only you will see, so enter as much or as little detail as you need.</td>
</tr>
</tbody>
</table>

4. Click OK to close the Alert window.

To edit alerts

1. Open a project and click Alerts on the Navigator. The Alerts log opens.
2. Select an alert and click Open. The Alert window opens.
3 Make changes to the alert as needed and click OK.

To delete an alert
Open a project and click Alerts on the Navigator. The Alerts log opens. Select an alert and click Delete.
WORKING WITH UMAIL

uMail is an internal Primavera Unifier e-mail feature that allows Primavera Unifier project team members to communicate with each other and maintain a record of the communications.

The uMail interface is similar in functionality to common e-mail programs such as Microsoft Outlook. uMail supports file attachments and can be sent between project team members and to external e-mail addresses. External e-mail cannot be sent directly to uMail.

A copy of every uMail communication is saved in a central folder (Public Items) controlled by the project administrator. These communications become part of the project record. Project or company administrators must grant users permission to access to the Public Items folder. Depending upon permissions, users can view all Public Items messages or only those in which they participated (sent or received). Permission can also be granted to deleted items in the Public Items folder. Once deleted, they are not recoverable. Note that users who sent or received messages deleted from the Public Items folder may still retain copies of these messages in their own Inbox or Sent folder.

You can also link uMail messages to specific business process records.
VIEW AND FIND UMAIL MESSAGES

The uMail feature is project-specific, and the full functionality is accessed at the project level. A cross-project listing of your Inbox and Sent items can also be accessed in the uMail node directly under Home.

To access project uMail

1  Open a project and switch to User mode.

2  Click uMail in the left Navigator. The uMail folders expand:
   • Drafts: Displays uMail messages that you have drafted but not yet sent.
   • Inbox: Displays messages sent to you.
   • Sent Items: Displays messages that you have sent.
   • Deleted Items: Displays items that you have deleted from one of the other folders.
   • Public Items: Stores copies of all uMail messages sent between project team members. Access to the Public Items folder must be granted through permission settings.

To view all of your uMail messages across projects

1  Go to the Home tab and switch to User mode.

2  Click uMail in the left Navigator. All messages residing in all project uMail Inbox and Sent folders are listed.

3  To open a listed message, select it from the list and click Open. You will be directed to the Project uMail Inbox or Sent folder containing the message, and the message will open.

To search for a specific uMail message across projects

1  Go to the Home tab and switch to User mode.

2  Click uMail in the left Navigator. All messages residing in all project uMail Inbox and Sent folders are listed.

3  Click the Find button.

4  Enter search criteria in the Subject Containing or Message Containing fields in the upper portion of the log window.

5  Click Search. The log will list the messages meeting the search criteria entered.
SEND AND RECEIVE UMAIL

uMail functionality is similar to common e-mail programs. In uMail, you can attach files, format text, flag the message, compose and save a draft of your response without sending it, and preview your message in a browser.

You can correspond with your Primavera Unifier project team members through uMail, and send uMail to external e-mail addresses. External e-mail users cannot send e-mail directly to uMail.

**Note:** uMail messages can be linked directly to related business process records. See the See "Linking uMail Messages to a Record" on page 266 for more information about linking uMail messages.

---

**To send a uMail message**

1. Open a project and switch to User mode.
2. Select any uMail folder.
4. Choose the recipients of the uMail message by doing any of the following:
   - Click To to select the primary recipients. The User/Group picker opens displaying project users. Select recipients from the Select Users list, and click Add. Click OK to close the picker.
   - To send a copy to another recipient, click Cc, and choose the recipients from the User/Group picker.
   - To send a copy to an external e-mail address, enter the address in the External Cc field. Separate multiple external addresses with a semicolon (;). The recipient will see Primavera Unifier Notification in the From field, and will not be able to reply directly.
   - To send a blind copy (Bcc), click the View menu and select Bcc Fields. The Bcc button and External Bcc field become available on the uMail message window.
5. Type the subject of the message in the Subject field.
6. Type the body of the message in the text field.
7. Click Send to send the message.

---

**To view or respond to a uMail message**

1. Access uMail by doing one of the following:
   - Open a project and switch to User mode. In the left Navigator, select the uMail Inbox folder. The Inbox lists all messages that have been sent to you. Unread messages are shown in bold text.
   - Go to the Home tab and switch to User mode. In the left Navigator, click uMail. All sent and received uMail messages across projects are listed. Unread messages are in bold text.
2. Double-click on a message to view it. The message opens.
3. To respond to the message, do one of the following:
   - To send a reply to the sender, click Reply.
   - To send a reply to the sender and other recipients of the original message, click Reply to All.
   - To forward the message to another recipient, click Forward.
4 Type your response and click **Send**.

**To attach files to a uMail message**

1 Open the uMail message.

2 Click **Attach** and choose one of the following:
   - **My Computer**: Attaches the file from your local system. The procedure is the same as for uploading files to the Document Manager and depends on your File Transfer option.
   - **Primavera Unifier Folder**: Attaches documents from the Document Manager. The window opens, displaying the Project Documents files and folders. Select the files and folders to attach and click **OK**.

   **Note**: Folders are not attached. The contents of selected folders are attached in a flat list. Documents with duplicate file names will not attach.

3 Click **OK** to add the file, and click **OK** to close the General Comments window.

**To flag a uMail message for follow-up**

1 Open an existing message, or create a new message.

   If you want to flag a message that you are replying to or forwarding, then open the message, and click **Reply**, **Reply All** or **Forward**.

2 Click the **Flag for Follow-Up** button. The Flag for Follow-Up window opens.

3 In the **Flag to** field, choose an action, such as “call,” or “for your information.”

4 Click **OK**. The flag text appears at the top of the message. A red flag symbol will also display next to the message in the log. (You may need to refresh the log to see the flag.)

5 If this is an existing message that you are flagging for yourself, you can simply close the message. If you are sending the message to someone else, add the recipients and send the message.

**To remove a uMail flag**

Click the **Flag for Follow up** button, and then click **Clear Flag**.

**To format uMail text**

1 Open the uMail message.

2 Select the text you want to format within the body of the message.

3 On the Formatting toolbar, choose the formatting to apply to the text.

**To spell check uMail text**

1 When you are finished composing a uMail message, click the **Spelling** button on the toolbar of the message. The body text of the message is checked.

2 Make spelling corrections as necessary and click **OK**.
To print a uMail message

1. Open the uMail message.
2. Click the Print button.

To print several uMail messages from the uMail log

1. Navigate to a uMail log.
2. Select the uMail records that you want to print.
3. Click the Print button.

To search for a uMail message

1. In the Navigator, click on one of the uMail folders.
2. From the toolbar, click the Find button. The Find box expands above the log.
3. Do any of the following:
   - To search by the recipient (To field), click the Select button and choose the user from the User/Group picker.
   - To search by subject, enter a word or phrase in the Subject Containing field (partial entries are acceptable).
   - To search by message content, enter a word or phrase in Message Containing.
   - You can further refine the search by clicking the Items that are: drop-down list and choosing Read or Unread.
4. Click Search. The messages meeting your search criteria will be listed in the log.

To delete uMail messages

1. Do one of the following:
   - From a uMail log, select the message and click Delete.
   - From within a uMail message, click Delete on the toolbar.
   The message is moved to the project’s Deleted Items folder.
2. To permanently delete a message, select it from the Deleted Items folder and click Delete. Click Yes to confirm that you are permanently deleting the message.

**Note:** When you delete a message from your account, a copy of the message remains in the central project record: the Public Items folder. Messages deleted from the Public Items folder are permanently deleted.
LINK UMAIL MESSAGES TO BUSINESS PROCESS RECORDS

uMail messages can be linked directly to BP records through the Linked uMails link at the bottom of the BP form. See "Linking uMail Messages to a Record" on page 266 for more information.

**Note:** This option is available only in BPs that have been set up to accommodate linked uMail messages. The ability to attach messages or view attached messages depends on the user’s uMail View permissions. Reply, reply all, and forward messages sent from a linked uMail will also be automatically linked to the BP.

**To view the list of BP records to which a uMail message is linked**

1. Open the uMail message.
   
   If the message is linked to a BP record, the upper portion of the message will display the following:
   “This uMail and any future replies are linked to records. Show list” (where Show list is a hyperlink).

2. Click on the **Show list** hyperlink to view the list of BP records to which the uMail is linked.
USING THE PROJECT MAILBOX

External emails are important communications that need to be included in projects. Such emails can come from project members or from external users who do not use Primavera Unifier. These email communications (and any attachments) are collected in a central repository for the project, called the Mailbox, so that project members can use them in managing and documenting the project. Once such emails reside in the Mailbox, project users can view them, forward them to appropriate members, flag them for review, and reply to them. In addition, you can link these emails to business process records.

Note: External emails that have been blind carbon-copied (Bcc’d) are not collected by the Mailbox.

To open the Project Mailbox
Open the project and switch to User mode. Click Mailbox in the left Navigator. The right pane displays a log of the contents of the Mailbox.

To open an email
On the Mailbox log, double-click the email. Primavera Unifier opens the email. If there are attachments, the email will display an Attachments (n) link. To open an attachment, click the link and double-click the attachment on the list that appears.

To flag an email for follow-up
1. Open the email.
2. Click the Flag for Follow-Up button. Primavera Unifier opens the Flag for Follow-Up window.
3. In the Flag to field, choose the action you want for this email, such as “call,” or “for your information.”
4. Click the Reply button to reply to the email, or click the Forward button to forward the email on to someone.
   When the recipient opens the message, the specific flag remark is shown across the top of the message.
5. To remove the flag, click the Flag for Follow-Up button, and then click Clear Flag.

To reply to an email
1. Open the email and click the Reply button.
   Primavera Unifier displays the addressee’s email address in the External To field. You can add additional external addresses in this field, separated by semi-colons (,).
2. (Optional) To add email addresses to the Cc line, click the Cc button. The User/Group Picker opens.
   a. Select the user(s) you wish to add to the message and click Add. The names appear in the Selected Users area at the bottom of the window.
   b. Click OK.
3 (Optional) To attach a file to the reply, click the Attach button and choose My Computer or Primavera Unifier Folder.
   
   a In the window that opens, select the file you want to attach, or browse your computer’s directories to locate the file to attach.
   
   b Click OK. Primavera Unifier attaches the file to your reply.
   
4 Enter your reply and click Send.

Primavera Unifier sends the email to the persons you specified.

**Note:** Once you reply to an external email, the communication will become part of Primavera Unifier’s uMail system. To see your reply, or any other communication regarding this email after this point, look for it in the uMail node of the Navigator. Any reply you made to the email will appear in the Sent Items node of uMail. Any email you forwarded will also appear in the Sent Items node of uMail.

---

**To forward an email**

1 Open the email.

2 To forward the email, click the Forward button. A forward email window opens.

3 Click the To (and optionally, the Cc) button. The User/Group Picker opens.

4 Select the user(s) to whom you wish to forward the message and click Add. The names appear in the Selected Users area at the bottom of the window.

5 (Optional) To forward the email to external users, enter their addresses in the **External Cc** field, separated by semi-colons (;

6 Click OK. Primavera Unifier forwards the email to the persons you specified.

**To delete an email**

On the Mailbox log, select the email and click the Delete button. To delete multiple emails, hold down the Ctrl key on your keyboard and select the emails.

**To print an email**

On the Mailbox log, select the email and click the Print button. To print multiple emails, hold down the Ctrl key on your keyboard and select the emails.

**To find a specific email**

1 On the Mailbox log, click the Find button. Primavera Unifier opens a Find window at the top of the log.

2 Enter the search criteria.
   
   • To search for an email from a specific person, enter the person’s email address in the **From** field.
   
   • To search for an email with a specific subject line, enter the subject line in the **Subject containing** field.

You can enter partial addresses or words in any of these fields. Primavera Unifier will display all the emails that match the partial information you entered.
To search for an email with some specific content in the message, enter that content in the Message containing field.

3 Click Search (or press Enter).

Primavera Unifier will display the emails that match the criteria you entered. It will also identify the criteria by which you have searched the list in the “Current View: filtered by” line above the list.
DISTRIBUTE THE PROJECT MAILBOX EMAIL ADDRESS

TO USERS

Usually, your Primavera Unifier Administrator distributes the email address of the Project Mailbox to all project participants, both within and outside of Primavera Unifier. You can also distribute this email address to other users you consider appropriate for the project.

Remember to notify your Administrator of these new users. The Administrator must add the new email addresses to the approved email list for the project; otherwise, the Project Mailbox will not accept emails from these users.

To distribute the Project Mailbox email address
Open the project home page and click the link shown for Email Address.

About Tasks, Messages, And Drafts
Your tasks, messages, and drafts are BPs that are in process and with which you are involved. When you are part of a BP workflow, or have been invited to participate in a discussion group within a business process, you are assigned a task. Messages are BPs that you have been sent a copy but do not need to take action. Drafts are BPs that you have worked on and saved but have not yet sent.

To access shell-related tasks, messages and drafts
Open a shell, and do one of the following:

- From the shell landing page, click one of the items requiring your attention.
- In the Navigator, click Collaboration, and then click Tasks, Messages, or Drafts.
Project information consists of the Project Directory and the General nodes. There are two subnodes in the Project Information node in the Navigator:

- **General**: Log of general information business process records that may have been added.
- **Project Directory**: List of project team members. For more information, See "View the Project Directory" on page 89.
VIEW THE GENERAL (BUSINESS PROCESS) LOG

These records originate as single-record business processes (that is, only one record exists for each one per project). This log is useful for project-specific information that only needs to be documented on a single form. It is a way to easily categorize and find big-picture project information. An example is overall project data or descriptions.

To access the general business process log

1. Open a project and click Information > General in the left Navigator. The log displays any available records.
2. To open a record, select it and click Open.
VIEW THE PROJECT DIRECTORY

The Project Directory lists contact information for your fellow project team members.

**To view the Project Directory**

Open a project and click **Information > Directory** in the left Navigator. The log lists all of the members of the project team and their contact information.

**Note:** A printed version of the Project Directory can be generated using user-defined reports.
SEARCH FOR PROJECT TEAM MEMBERS

If there are many project team members, you can use the search function to help you find a particular member.

**To find a project team member**

1. Open the Project Directory and click **Find**.
2. Choose which information to search by in the **Search By** selection list (for example, First Name).
3. Enter search criteria in the **Search for** field (for example, enter all or part of the first name).
4. Click the **Search** button.
CONTACT PROJECT TEAM MEMBERS

You may view the contact information of fellow team members and even send e-mail or uMail from within Primavera Unifier.

To view a team member’s user profile

1 In the Project Directory, select the user from the list and click Open. The View User Profile window opens.

**Note:** If a User Administration design has been imported from Primavera uDesigner by your Administrator, the content of this profile can vary.

2 In the Contact Information selection list at the top of the window, choose one of the following:
   - **Current Project:** Displays contact information specific to the current project, such as an on-site address or cell phone.
   - **Company Contact Information:** This is the member’s company contact information.

To send an e-mail using an external e-mail program

Do one of the following:
   - In the Project Directory, select a team member’s name and click Send e-mail.
   - From the User Profile window, click the e-mail address.

This will open an e-mail dialog box using your default e-mail program (for example, Microsoft Outlook). The To: field will be populated automatically with the member’s e-mail address. E-mail sent through your external e-mail program will not be saved as part of the Primavera Unifier project record.

**Note:** You may also contact a team member using uMail. See "Working with uMail" on page 77.
WORKING WITH GATES

Gates provides a structure to assess the quality and integrity of a project throughout its life cycle.

Gates are, in essence, acceptance reviews following which a project can advance to the next phase in the project life cycle. For each phase of the project, a series of gate conditions are defined and tracked. Each gate condition is evaluated against actual project data and is marked complete if conditions are met. Once all conditions are complete, the project moves to the next phase either automatically or manually, based on the configuration.

Phases and gate conditions are configured in the Gates Setup in Administration Mode.
VIEW THE GATES DASHBOARD

The Gates dashboard allows you to:

• Monitor the progress of project phases
• View phase conditions and their definitions
• Run a gates process
• Manually override gate conditions
• Manually advance a project phase

To access Gates

1 Open the project and switch to User mode.

2 Click Gates in the left Navigator. The Gates dashboard opens.
To view gate condition details

1. Open the Gates dashboard.

2. Do one of the following:
   - Select a project phase and click the Edit button on the toolbar. Click the View button directly below the Gate Conditions pane. (The Edit button is available if the gates setup is active.)
   - Double-click a listed gate condition in the Gate Conditions pane of the dashboard (or select the gate condition and click the View button).

The Edit Gate Condition window opens. This is a view-only window. The General tab displays the data type associated with the gate condition. The Query tab displays the data element and trigger condition for this gate condition.
VALIDATE GATE CONDITIONS MANUALLY (REFRESH)

You can manually validate conditions, which is the same validation that is performed during scheduled runs. The dashboard is updated to show any changes to the gates conditions.

**Note:** Your Administrator can configure that Gates conditions are validated on each Gates run.

To manually run gates

1. Open the Gates dashboard.
2. Click the **Refresh** button.

If a gate condition is met, the gate condition is marked as Complete. If all gate conditions are found to have been met for a project phase (and if Automatic Advancement is **Yes**), then the project phase will advance to the next phase.
EDIT PHASE DETAILS

To edit phase details

1. Open the Gates console.

2. Select a project phase and click the Edit button. The Edit Phase Detail window opens.

3. Use the information in the following table to complete the window.

<table>
<thead>
<tr>
<th>This item</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gates Condition list</td>
<td>Displays the gate conditions that must be met for the selected phase.</td>
</tr>
<tr>
<td>Complete checkbox</td>
<td>Select the checkbox to manually flag the gate condition as complete.</td>
</tr>
<tr>
<td>Ignore Condition checkbox</td>
<td>Select the checkbox to override the gate condition requirement for this phase.</td>
</tr>
<tr>
<td>View button</td>
<td>Click the View button under the Gate Conditions list. The Edit Report window opens. This is a view-only window. The General tab displays the data type associated with the gate condition. The Query tab displays the data element and trigger condition for this gate condition.</td>
</tr>
<tr>
<td>General Comments Add/View</td>
<td>Click the button to add or view general comments associated with this project phase.</td>
</tr>
</tbody>
</table>
ADVANCE TO THE NEXT PHASE

After the gate conditions have been met for the current phase, you can manually advance a project to the next phase.

**To advance the phase to the next phase**

1. Open the Gates console.
2. Click the **Advance to Next Phase** button.
3. A confirmation window opens asking you to confirm the phase advancement. Click **Yes** to confirm.

The system will validate whether all gate conditions have been met for that phase. If all gate conditions for that phase are complete, the phase can advance to the next phase. If all of the gate conditions have not been met, you can:
   - Manually mark a gate condition as complete.
   - Click the **Ignore Condition** checkbox to override the gate condition requirements.
   - Select the phase and click the **Edit** button to view details about the phase and gate conditions, and therefore determine what needs to be done to meet the gate condition.
RETURN TO A PREVIOUS PHASE

To return to a previously completed phase and set it as the current phase

1. Select the phase to reset as the current phase.

2. Do one of the following:
   - Select a gate condition and edit it so that it is no longer complete.
   - Add a new condition so that the completed phase is no longer complete.
ADD OR VIEW GENERAL COMMENTS

To add general comments in a project phase

1. In the Gates console, select the project phase and click the Edit button. The Edit Phase Detail window opens.

2. Click the Add/View button. The General Comments window opens.

3. Enter any comments in the Text Comment pane and click OK. Once you save a comment, it cannot be edited or deleted.

To view existing general comments on a project phase

Do one of the following:

• In the Gates console, click the View button at the bottom of the screen. The General Comments window opens displaying existing comments.

• In the Gates console, select the project phase and click the Edit button. Click the Add/View button. The General Comments window opens. You can view existing comments or add a new one.
VIEW SAVED GATES RUNS

You can view results from prior scheduled gates runs.

To view saved gates runs

1. Open the Gates console.
2. Click the Saved Gates Runs button. The Saved Gates Runs window opens.
3. Select a saved gates run from the list and click Open. Results are available in a PDF file. PDF file names include the date and time of the gates run.
4. Choose to view or save the PDF file and click OK.
VIEW THE GATES AUDIT LOG

To view the Gates audit log

1. Open the Gates console.

2. Click the View menu and choose Audit Log.

   The audit log captures Ignore Condition flags and general comments.
WORKING WITH PROGRAMS

Cost data from different projects or WBS code-based shells can be rolled up into a program. The roll up lets you view and compare member project and shell data in a cash flow worksheet or cost sheet, and in the company’s base currency.

**Base currency**: Projects and shells can use different currencies. Primavera Unifier converts all project and shell currencies to the company’s base currency and presents the rolled up data in the base currency using the earliest exchange rate defined for the period. You can create a snapshot of this data for later reference, see Working with snapshots. This data is reportable, see About user-defined reports.

**Refresh**: When there are changes to the program roll up, either additions or removals of projects or shells, refreshing the worksheet updates the cash flow curve.

**Program membership**: Program administrators determine program membership.

- If you are a member of a project or WBS shell that is part of a program, you may be a member of that program.
- You can also be a member of a program without being a member of a project or shell.

**Company membership**: As a Primavera Unifier user, you may be part of a sponsor company or a partner company (or possibly both).

- Sponsor companies can commission and administer projects or shells and programs.
- Partner, or member, companies (e.g., subcontractors, vendors) work with sponsor companies.
OPEN A PROGRAM

Open a program to access the program level functions.

To open a program

1. Go to the Program tab and switch to User mode. The Programs log opens and lists any programs to which you have access.

2. Select the program you want to see and click Open (or double-click the program).

3. In the left Navigator, select the module for which you want to see the data roll up of included projects or shells.
WHAT YOU CAN DO IN A PROGRAM

Depending upon the modules your company has set up and your access permissions, the following program functions are available in the Navigator.

- **Summary**: Provides a snapshot of program information for the company. You can choose the standard view or customize your summary page (See "Working with the Program Summary" on page 104).
- **Cost Manager**: Access program-level Cost Manager functions: cost sheet and cash flow. View project and shell data in the company’s base currency.
- **Schedule Manager**: Summarizes project or shell schedule data as it is rolled up to the program level. Schedule Manager is discussed in See "About the Schedule Manager" on page 699
- **Reports**: For creating and generating program-level user-defined reports.

Working With The Program Summary

The program summary provides a snapshot of the overall program. There are two available views:

- **Standard view**: System-generated summary that summarizes program information.
- **User view**: You can customize the program summary to display virtually any reportable project or shell related information in table or graphical format. The summary information is pulled from summary-type user defined reports or from pre-configured standard data type reports.

To access the program summary

1. Go to the **Standard Projects** tab and switch to User mode.
2. Click **Programs** in the left Navigator.
3. On the log, open a program, then click **Summary** in the Navigator.
4. Click the **View** menu and choose **Standard** to view the standard view or **User** to view the user-defined view.

The standard view of the program summary displays an overview of the program.

To print the program summary

1. Go to the **Standard Projects** tab and switch to User mode.
2. Click **Programs** in the left Navigator.
3. On the log, open a program, then click **Summary** in the Navigator.
   
   You can print both the user view and the standard view of the program summary.
4. From the **File** menu, click **Print Preview**. The preview window of the summary opens.
5. Click the **Print** icon in the upper right corner of the window.

Configure A Program Summary

Like the project or shell summary, you can customize the information that is displayed on the Program Summary window by defining blocks.
To add reports to the user view

1. Go to the **Standard Projects** tab and switch to User mode.
2. Click **Programs** in the left Navigator.
3. On the log, open a program, then click **Summary** in the Navigator. The Summary window opens.
4. Click the **View** menu and choose **User**.

The initial reports included in the summary are displayed in table format. You have the option to modify how these reports display, remove them from the summary view, or add other summary reports.

5. From the **Edit** menu, choose one of the following:
   - **Left Column**: To add information to the left side of the window
   - **Right Column**: To add information to the right side of the window

The Left Column Blocks or Right Column Blocks window opens.

6. Do one of the following:
   - To add a user-defined summary report, click the **Add Custom** button. The Custom Summary Block window opens. Complete the window and click **OK**.
   - To add a pre-configured, standard data type report, click the **Add Standard** button. The Standard Summary Block window opens. Complete the window and click **OK**.

The report will be added to the Blocks window.

7. Click **Close**. The Program Summary - User View will update to include the new report.

### Available program-level reports

<table>
<thead>
<tr>
<th>Name</th>
<th>Drill down to</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;BP Name&gt;</code> Count by Status</td>
<td>No drill down</td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code>% by Status</td>
<td>No drill down</td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code> Count by Company</td>
<td>No drill down</td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code>% by Company</td>
<td>No drill down</td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code> Count by User</td>
<td>No drill down</td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code>% by Creator User</td>
<td>No drill down</td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code> - Tasks by User</td>
<td>No drill down</td>
</tr>
<tr>
<td><code>&lt;BP Name&gt;</code> - Tasks All Users</td>
<td>No drill down</td>
</tr>
<tr>
<td>Record Count per BP (for current user)</td>
<td>No drill down</td>
</tr>
<tr>
<td>Record% per BP</td>
<td>No drill down</td>
</tr>
<tr>
<td>Current User Task Count</td>
<td>No drill down</td>
</tr>
<tr>
<td>All User Task Count</td>
<td>No drill down</td>
</tr>
</tbody>
</table>
To manage blocks on the Program Summary - User View

1  Go to the Standard Projects tab and switch to User mode.

2  Click Programs in the left Navigator.

3  On the log, open a program, then click Summary in the Navigator.

4  From the Edit menu, choose one of the following:
   • Left Column: To add information to the left side of the window
   • Right Column: To add information to the right side of the window

The Blocks window opens. Blocks are listed in the order in which they appear on the page.

5  To move a block, select it and click Move Up or Move Down.

6  To delete a block, select it and click Delete.

7  To change the display type, title, or other block property, select the block and click Open. Make changes as necessary and click OK.
WORKING WITH PROGRAMS

Cost data from different projects or WBS code-based shells can be rolled up into a program. The roll up lets you view and compare member project and shell data in a cash flow worksheet or cost sheet, and in the company’s base currency.

**Base currency**: Projects and shells can use different currencies. Primavera Unifier converts all project and shell currencies to the company’s base currency and presents the rolled up data in the base currency using the earliest exchange rate defined for the period. You can create a snapshot of this data for later reference, see Working with snapshots. This data is reportable, see About user-defined reports.

**Refresh**: When there are changes to the program roll up, either additions or removals of projects or shells, refreshing the worksheet updates the cash flow curve.

**Program membership**: Program administrators determine program membership.

- If you are a member of a project or WBS shell that is part of a program, you may be a member of that program.
- You can also be a member of a program without being a member of a project or shell.

**Company membership**: As a Primavera Unifier user, you may be part of a sponsor company or a partner company (or possibly both).

- Sponsor companies can commission and administer projects or shells and programs.
- Partner, or member, companies (e.g., subcontractors, vendors) work with sponsor companies.
ABOUT SHELLS

Shells are similar to standard projects, but offer more functionality and flexibility. While projects are pre-defined in Unifier, shell types are defined in Primavera uDesigner. After a shell type is configured in Primavera uDesigner, you can use the shell types to create shell instances in Unifier. Each instance can have its own business process, Cost Manager, reporting module, or other modules as needed. Through permissions, the Primavera uDesigner administrator can control which users can access a shell type and can create shell instances.

WBS Shells can be included in programs, just as standard projects. Your Administrator can migrate standard projects to WBS shells.

You would use a shell instead of a standard project if you want to do the following:

• Add your own configurable attributes to the project
• Create a hierarchy of projects
• Work with projects that do not have a defined start and end date or confirmed cost

Shells can represent virtually any system, entity, or function, for example:

• IT System Organizational Hierarchy
• Capital Project Maintenance Project
• Business Unit Functional Area (i.e. Facility Management)
• Campus or Facility Complex Site / Property
• Building Geographical Area (e.g., Country or Region)
SHELL RELATIONSHIPS AND HIERARCHY

With shells, you can create projects to show relationships and hierarchy or more accurately represent a real-world physical or organizational structure. This differs from standard projects in that if you have multiple projects that are related, they are all listed in the project log in a flat list at the same level. Although you can group them in programs, you cannot express the inherent relationship among projects. Shells can have a hierarchical relationship, with as many levels as needed. For example:

- Region (shell)
  - Properties (subshell)
    - Buildings (subshell)
  - Buildings (subshell)
  - Projects (subshell)

In this simple hierarchy, the shell Region was created and named in Primavera uDesigner. The Region shell has the subshells Properties, Buildings, and Projects. The subshell Properties also has a subshell called Buildings.

**Note:** In the above example, the subshell called Project is a shell of the type Project (Standard), not a standard project.

Before you start creating shell type templates and shell instances, plan the hierarchy with your administrator and Primavera uDesigner designer. The settings and configuration affect the shell’s type and relationship to other shells. Planning helps you achieve the result that meets your business needs.

When creating a hierarchy, Primavera Unifier validates the shell-subshell relationships and prevents you from creating invalid or circular hierarchies. For example, the shell Region cannot contain a Region subshell, because a shell can never be a subshell of itself.
SHELL TYPES AND SHELL INSTANCES - SINGLE AND MULTIPLE

Shells can be single instance (one shell can be created for the shell type), or multiple instance (many shells can be created for the type). Single instance shells are represented in Primavera Unifier as a tab, at the same level as the Home tab. Multiple instance shells allow you to create more than one instance of a shell. For example, your top level shell might be called Europe, and is a single instance shell. This shell is represented as a tab. Under this shell, you could use multiple instance shell types to create instances of countries, such as Holland, France, and Hungary. There are templates for shells, just as there are templates for projects. The Shell Manager enables you to import and manage shells and sub-shells for users.

To access the various groups of shells, click the tab with the single instance shell name. The shell landing page displays and the sub-shells are list in the shell log in the lower area of the landing page.

Shell types are characterized by:

- A unique system ID
- Single or multiple instance
- Generic or WBS cost code

Shell instances are copies of shell types, and have these characteristics:

- An instance of a shell type must exist before the shell type is viewable in User Mode
- Shell type single can be a root node or a tab
- Shell type multiple populate levels in a hierarchy

Shells and the Cost Managers
SHELLS AND THE COST MANAGERS

The Primavera uDesigner configuration controls shell relationships and also determines the type of cost manager that you can use with the shell.

- **Standard Cost Manager**: Uses WBS codes and works with standard projects as well as with shells. In Primavera uDesigner, the administrator can create a shell that uses WBS costing. This shell then has the same Cost Manager as a standard project, but provides the configurability and hierarchical aspects of a shell.

- **Generic Cost Manager**: Works with generic shells only. The Generic Cost Manager supports costing for projects that are not of a fixed duration or cost. This can include facilities management projects like:
  - Leases
  - Janitorial support
  - Building maintenance
  - Landscape care
  - Interior updates to a building

The ongoing management of a building does not have a start and end, and you cannot always project the ultimate cost. With the standard Cost Manager, costs have defined start and end dates for projects that have budgets, scope, and schedules. Cost is broken down by work in the various disciplines and is managed using WBS codes.

In the Generic Cost Manager, cost is time-based, not work-based, allowing you to manage costs that do not have a finite timeline, such as facility maintenance and upgrading. You can plan for these expenses during a time period, such as a quarter or year. Each shell has its own cost manager.

Primavera Unifier projects are similar to shells that use WBS cost codes. You can combine shells and shells that use the WBS cost codes together. You can also create a hierarchy of shells that consists of shells that use the Generic Cost Manager and those that use the standard Cost Manager (WBS cost codes).

In the Generic Cost Manager, cost is time-based, not work-based. You would use the Generic Cost Manager to work with the costs that do not have a finite time-line, such as those associated with maintaining and upgrading the building or facility. You can plan for these expenses during a time frame (such as a quarter or a year). The Generic Cost Manager enables you to track the time and corresponding budget for your ongoing facilities work. Each shell has its own cost manager. The Generic Cost Manager does not include:

- Earned value
- Cash flow
- Funding
- General Spends SOV
- Pay App SOV
ABOUT THE SHELL LANDING PAGE

After a shell is created, you can open it:

- By going to the shell tab
- By selecting it from the shell log window and clicking the Open button.

The top section of the landing page contains the Shell Dashboard. See “Configuring a shell dashboard (My Dashboard)” on page 126 for details on the shell dashboard, and instructions on how to configure the dashboard.

By default, the shell dashboard contains the following blocks:

- Image
- Items Requiring Your Attention
- Details
- Links

The bottom section of the shell landing page displays a mini-log window of sub-shells that have been created under the currently selected shell.

For example, if you select the sub-shell South Bay, and then the further sub-shell Mathilda Northwest, this landing page displays.
SHELLS AND NAVIGATION

You can navigate between current shell, sub-shells, and instances through the use of:

- Tabs to move from one single instance shell to another
- The Landing Page mini-log at the bottom of the landing page
- The View drop-down menu to filter shells by types, which are displayed in the shell mini-log, based on the shells defined in the hierarchy
- Breadcrumbs to navigate up and down the shell hierarchy
- A geo-coded map, which allows you to click on map pins to navigate to associated shells

You can search for instances within a shell by using the Landing Page Log Find functionality.
BREADCRUMBS

Breadcrumbs or a breadcrumb trail are a navigation technique used in many user interfaces. Breadcrumbs give you a way to keep track of your current location in Unifier when working with shells. As you navigate through the interface, breadcrumbs appear in the upper right corner of the current window. Breadcrumbs provide links back through the shell hierarchy, creating a trail for you to follow back to your starting point.
SHOW MAP VIEW

You can view the shell instances that you create for a shell type on a map (provided the shell types were enabled for geocoding in Primavera uDesigner).

To show a map view of shell instances

1. Navigate to a shell landing page.

2. Click the Map View button to display a map that shows pins for the location of the address of each shell instance. You can return to the dashboard by clicking Dashboard View.

   Each shell instance that is currently displayed in the bottom log window is displayed as a pin on the map based on the location of the shell.

3. Click on a pin on the map to see Summary information about the shell.
EXPAND THE SHELL LOG ON THE LANDING PAGE

You can expand the shell log (the bottom area of the shell landing page) by clicking the rectangle next to the View drop-down menu.
ABOUT SHELL STATUSES

Your shell can have one of four statuses.

Active: A live, in-progress shell.

On-Hold: The initial shell status. On-Hold shells are listed on the shells log, but you cannot work with them.

View-Only: View-Only shells can be viewed, printed, exported, and included in reports. You cannot modify any data in View-Only shells. This allows you to view past shells without allowing changes to these shells. If a shell in a shell hierarchy changes to View-Only, you can still navigate up and down the shell hierarchy, and can create sub-shells in the hierarchy under the View-Only shell.

Inactive: Used to suspend shell usage. Inactive shells are visible to Administrators, but not to end users. Only System and Shell Administrators (users with Modify Status rights) can reactivate the project.

Note: If automatic status update is enabled on a shell, the status of the shell can change from Active to an inactive status (On-Hold, View-Only, Inactive). The change of status is set up by the Administrator, and is based on defined triggering conditions. For example, if a shell is close to exceeding its funding, it might make sense to put it On-Hold while funding matters are discussed. Your shell administrator must manually change the status back to Active when you are ready to restart the project.

The Shell Administrator will receive e-mail notification when the status of a shell changes. The change of shell status could occur due to a manual change, bulk update, through Web Services or a CSV file, or through automatic update.
WORKING WITH THE SHELL DASHBOARD

Your Administrator can configure custom shell dashboards that you can use to view shell data across a shell hierarchy.

From the shell dashboard, you can:

- Use drill-down functionality to access shell data
- Use filters on the dashboard so that all blocks in a particular dashboard can be filtered based on the same parameter
- Print the entire dashboard, or individual dashboard blocks
- Minimize and maximize the entire dashboard, or a block
- Use a free form dashboard layout, that gives you the ability to drag and drop dashboard blocks as an alternative to using predefined layout
MINIMIZE THE SHELL DASHBOARD

Click the minimization icon to expand the dashboard to minimize the dashboard block. You can minimize the various blocks of the dashboard individually.

Expand The Shell Dashboard

Click the expansion icon to expand the dashboard to fill the width of the dashboard. You can also expand the various blocks of the dashboard individually.
PRINT THE SHELL DASHBOARD

Click the print icon to print the shell dashboard. You can also print the various blocks of the dashboard individually.
NAVIGATE THROUGH THE SHELL BLOCK DRILLDOWN

Click the left arrow icon to navigate up the drilldown in a shell dashboard block.
SET FILTERS

Click the Filters button in the upper left corner of the dashboard. If there are filters defined, they will be listed, and enable you to filter the dashboard data by criteria defined in the Edit > Dashboard Filters window.

To set filters on a dashboard block

1. Click the Filters button. The Filters window opens.
2. Enter the filter criteria.
3. Click OK.
   The data view in the block changes to reflect the filtering.
4. You can turn off the filter by clicking the red X associated with the displayed filter criteria. The data view for the block returns to the default, unfiltered view.
USE DRILLDOWN

You can click on activated elements in dashboard blocks to drill into layers of data contained in the shell.

**Note:** Drill-down functionality is supported for charts only, and is not available for grids or tables. Drilldown will stop when a grid or table is encountered.

**To drill-down into dashboard block data**

1. Click a data representation in the data block. For example, you can drill down into the next configured level of data for a shell called Terminal Expansion by double clicking on that section of the chart.

2. View the next level of data. In this example, after you double click on Terminal Expansion, the next level of data displayed looks like this:

3. You can return to the original data view by clicking the left arrow icon.
If there are enough records represented, you can scroll up and down the vertical y-axis of a graph using a scroll bar.
CONFIGURING A SHELL DASHBOARD (MY DASHBOARD)

By default, all shells have a dashboard that the end user can configure if they have configure permissions. The dashboard is the user’s personal dashboard, with their personally configured view of shell data. My Dashboard can be configured by end users in User Mode using the Edit Dashboard window, but is often configured for each user by the Administrator. Users can select this type of dashboard to view from the View Dashboard drop-down menu on each shell. This dashboard is recommended if the user wants a personalized dashboard to view data that they specifically need to see regarding the shell.

To configure a shell dashboard (My Dashboard)

1. From the shell landing page, select Edit > Dashboard. The Edit Dashboard window displays. There are two sections to this window: Tab Setup and Source Details. Under Tab Setup, the default first tab already has a name and layout that you can modify.

2. To change the tab, click the tab name. Change the tab name, and select a layout for the tab. You can experiment with layouts to see which one works with the information that you want to display.

3. Select the Show checkbox to show the tab in the dashboard.
Under Source Details, you can add standard or custom blocks.

4. Double-click to select a default standard block and modify it as needed. To add a standard block, click Add > Standard. You can add any number of blocks, but the dashboard displays the blocks based on the tab layout you select.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Name</td>
<td>Enter a source name.</td>
</tr>
<tr>
<td>Data Type</td>
<td>Select a data type. The data types are:</td>
</tr>
<tr>
<td></td>
<td>• Business Process: general business process information</td>
</tr>
<tr>
<td></td>
<td>• Document Management: total documents</td>
</tr>
<tr>
<td></td>
<td>• Active Task Information: Active task metrics</td>
</tr>
<tr>
<td></td>
<td>• Users: Metrics by Company</td>
</tr>
<tr>
<td></td>
<td>• Image: shell image</td>
</tr>
<tr>
<td></td>
<td>• Items Requiring Your Attention: items such as tasks and messages</td>
</tr>
<tr>
<td></td>
<td>• Details: Shell details, such as shell number and name</td>
</tr>
<tr>
<td></td>
<td>• Links: Links configured for the shell</td>
</tr>
<tr>
<td></td>
<td>• &lt;specific business processes&gt;: details on selected business processes,</td>
</tr>
<tr>
<td></td>
<td>such as record status and tasks</td>
</tr>
<tr>
<td>Report On</td>
<td>Select what to report on.</td>
</tr>
<tr>
<td>Block Title</td>
<td>Add a title for this block.</td>
</tr>
<tr>
<td>Display Type</td>
<td>Select the chart type.</td>
</tr>
<tr>
<td>Show Result</td>
<td>Choose Actual Value or Percent of Total.</td>
</tr>
<tr>
<td>Show Total</td>
<td>Select this checkbox to display the total.</td>
</tr>
<tr>
<td>Decimal Places</td>
<td>Select the number of decimal places.</td>
</tr>
<tr>
<td>Use 1000 Separator (,)</td>
<td>Select this checkbox to use the comma as a 1000 separator.</td>
</tr>
</tbody>
</table>
In this field | Do this
---|---
Negative Number Format | Select the format for negative numbers.
Currency Format | Choose None, Shell Currency, or Base Currency.

5 Click **OK** to save your changes and exit the Edit Standard Block window.

6 To add a custom block, click **Add > Custom**.

<table>
<thead>
<tr>
<th>This item</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Cube</td>
<td>Select the shell data cube definition to use. Data cubes are queries that can be defined and reused to create charts on your dashboard. Your company administrator defines the data cubes.</td>
</tr>
<tr>
<td>Show data from</td>
<td>Enables you to select the shells to use as data sources. You can choose: • Current Shell Only • Sub-Shells Only • Current Shell and Sub-shells</td>
</tr>
<tr>
<td>Block Title</td>
<td>Add a title for this block.</td>
</tr>
<tr>
<td>Display Type</td>
<td>Select the chart type.</td>
</tr>
<tr>
<td>Source Grouped By</td>
<td>Select how the source is grouped.</td>
</tr>
<tr>
<td>Output Type</td>
<td>Choose either Record Count or Summary Value.</td>
</tr>
<tr>
<td>Report On</td>
<td>Select what to report on.</td>
</tr>
<tr>
<td>Show Result</td>
<td>Choose Actual Value or Percent of Total.</td>
</tr>
<tr>
<td>Show Total</td>
<td>Select this checkbox to display the total.</td>
</tr>
<tr>
<td>Decimal Places</td>
<td>Select the number of decimal places.</td>
</tr>
<tr>
<td>Use 1000 Separator (,)</td>
<td>Select this checkbox to use the comma as a 1000 separator.</td>
</tr>
<tr>
<td>Negative Number Format</td>
<td>Select the format for negative numbers.</td>
</tr>
<tr>
<td>Currency Format</td>
<td>Choose None, Shell Currency, or Base Currency.</td>
</tr>
</tbody>
</table>

7 Click **OK** to save your changes and exit the Edit Custom Block window.

8 To add a portlet, click **Add > Portlet**. Enter the portlet name and the URL or IP address.

This allows you to add content to your dashboard from a URL address. For example, you could use this portlet to specify a webcam site to monitor activities via a live camera. You can add as many portlets as needed.

9 You can define a block that allows users to drill down into the displayed data.
Note: You must add drilldown blocks if you want to use filtering on your dashboard blocks.

10 After you define the drilldown, you can also add filters.

11 To remove a block, click Remove. To reposition a block, click Move Up or Move Down.

12 Click another tab name to modify the tabs and sources for that tab. Repeat these steps for each tab until you have configured the entire dashboard to meet your needs.

13 Click Apply to save your configuration, and then click OK to close the window.
**VIEW DASHBOARDS**

Users with Configure User Dashboard permissions can configure and maintain a shell dashboard. This user-configured dashboard is listed as My Dashboard in the View Dashboard drop-down menu. This menu can also list shell dashboards that were configured by the Administrator.

For example, the Administrator can create separate shell instance dashboards to serve various business groups that are using shells in a single instance. For example, the Administrator can create these types of shell instance dashboards for a shell instance called Building 100:

<table>
<thead>
<tr>
<th>This dashboard</th>
<th>To serve this business group</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Operations Dashboard</td>
<td>• Operations and Management groups</td>
</tr>
<tr>
<td>• Technical Services Dashboard</td>
<td>• Technical Support and Services group</td>
</tr>
<tr>
<td>• Lease Management Dashboard</td>
<td>• Vice President of Leasing Services and his reports</td>
</tr>
</tbody>
</table>

With permissions, you can view the dashboards provided by the Administrator, but you cannot modify them.

**To view dashboards**

1. Navigate to a shell.

2. Select a dashboard from the View Dashboard drop-down menu. Any dashboard that you have configured for yourself is called My Dashboard.

3. You can select dashboard in the View Dashboard drop-down menu to which you have View permission. The last dashboard that you view will display the next time you log into Primavera Unifier.
ADD A DRILLDOWN BLOCK TO MY DASHBOARD

You can add a drilldown block that allows you to access greater levels of data detail.

For example, if a dashboard block shows a pie chart with data for two projects, called Parking Extension and Terminal Expansion, and you double-click on Terminal Expansion to expose the vendors on that project:

![Pie chart showing Parking Extension and Terminal Expansion](image1)

To continue the example, when you double-click on Terminal Expansion the to access the vendor information, and the amount associated with the vendors Acme Equipment, Pacific Building Interiors, and L. Loring & Company:

![Vendor details for Terminal Expansion](image2)
**Note:** If you want to use filters on your dashboard blocks, you must first define a drilldown block.

---

**To add a drilldown block to your shell dashboard**

1. On the Edit Dashboard window, click **Add > Drilldown**. The Edit Drilldown Block window opens. Drilldown functionality is supported for charts only, and is not available for grids or tables. Drilldown will stop when a grid or table is encountered.

<table>
<thead>
<tr>
<th>This item</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Cube</td>
<td>Select the data cube definition to use. Data cubes are queries that can be defined and reused to create charts on your dashboard. Your company administrator defines the data cubes.</td>
</tr>
<tr>
<td>Block Title</td>
<td>Add a title for this block.</td>
</tr>
<tr>
<td>Block Filter Elements</td>
<td>Group By elements from the data cube. This determines which columns from the data cube definition will be used to group data for filtering.</td>
</tr>
</tbody>
</table>

2. Click **Add** to add Drilldown Details. The Edit Drilldown Details window opens.

3. Click **OK**, and click **OK** to exit the Edit Dashboard window.
ADD FILTERING TO THE DRILLDOWN BLOCK

You can add filtering on a drilldown block in your shell dashboard. You must first define the filter at the block level, and then specify that it appear on the dashboard for use.

To add filtering on a drilldown block in your shell dashboard

1. To define the drilldown at the block level, click Select next to Block Filter Elements on the Edit Drilldown Block window.
2. Select the data elements from the data cube that you want to use as filters.
3. Click OK to exit the Edit Drilldown Block window.
4. On the Edit Dashboard window, click the Filters button to add filters at the dashboard level. The Configure Filters window opens.
5. Click Add. The Add Filter window opens.
6. Enter the filter name.
7. Select the filter you want to use on the dashboard block.
8. Click OK, and then click OK to exit the Configure Filters window.

Optimizing Shell Dashboard Performance

You can sometimes improve shell dashboard display performance by following a few guidelines. Shell Dashboard performance can depend on how many dashboard blocks are defined and the volume of data retrieved by the dashboard query.

Here are some tips to improve shell dashboard performance:

• Reduce the number of dashboard blocks, if possible.
• Define conditions for SQL filtering to return less data.
• Do not check Show Total when you configure dashboard blocks.
• Do not select Percent for Show Result.
WORKING WITH SHELLS

A shell allows users to collaborate on and coordinate the execution of a project.

Note: User access and permission levels for all functions are controlled by the company administrator. Contact your company administrator if you have questions regarding access.
OPEN A SHELL

Open a shell to access the shell functions.

**To access shells**
From your user home page, click a shell tab.
When you click a shell tab, the shell landing page displays. From the shell log, you can access the various subshells listed.

**To open a shell**
Select a shell from the shell log and click **Open**. When you open the shell, the Navigator expands, providing access to shell-level features and business processes.

**To find a shell**
Since shell hierarchies can be extensive, Primavera Unifier provides a Find feature to help you locate a specific shell.

1. Click the anchor shell tab that contains the shell you want to locate.
   The shell dashboard appears, and a “mini log” of sub-shells appears at the bottom of the window.
2. From the **View** drop-down list on the mini log, select the sub-shell you want to search.
3. Click the **Find** button.
   To accommodate the Find operation, Primavera Unifier collapses the dashboard to show only the mini log, and displays a Find window.

On the Find window, you can search for shells using a geocode search or you can search for shells using search operators on shell information. Operators such as “contains” or “is not empty” can help you narrow the search for the shell.

- To search using a geocode, enter an address, latitude, longitude, or radius
- To search on shell information using operators:
  a. Choose the operator you want to use on the field, such as “equals,” “does not contain,” or “is empty.”
  b. Enter the value the field should contain.
4. Click **Search** (or press **Enter**). Primavera Unifier displays all the shells that meet the search criteria you entered.
   If you choose to, you can cancel the find operation by clicking **[Cancel Filter]** or the x icon in the upper-right corner of the window. Primavera Unifier will restore the mini log to its unfiltered state.
5. When you have finished using the Find feature, click the **Restore** button to return the dashboard to normal view.

**Auto-Create Shells (or Projects)**
Primavera Unifier provides a type of business process that will create new shells (and standard Projects) from the upper form of the BP or from BP line items. The data necessary to create shells/projects is provided by this BP. In addition to creating a new shell, this type of business process can also be
designed so that you can choose the managers and employees who should be automatically assigned to the shell when it is created.

**Note:** In order for auto-creation to occur correctly, be sure you understand the hierarchy of the shells in your company. This is important for placing the shell in the correct position in the hierarchy as well as choosing the correct template with which to build it. If the template is not the correct one, the creation will not succeed.

This BP creates shells and projects using the templates that have been designed for these shells/projects in Primavera Unifier, and provides the shell or project name, number, location, and status for the new shell/project, as well as any images and phase definitions, if they have been included. If the template includes links, these will be placed on the new shell/project. If designed and configured to do so, the template will also automatically assign a manager and employees to the shell/project.

**Working with Planning Items**

If a Planning Item Picker has been included on this business process, you can link new projects/shells with planning items. Instead of linking a planning item to a project in the Planning Manager, this BP will automatically create the link when the project/shell is created, and data will begin to roll up to the Planning Sheet from the business processes in this project.

**To auto-create a single shell or project**

To auto-create a single shell or project, you need to fill out only an upper form.

1. Navigate to the level (such as Company Workspace or a shell) where the auto-creation business process resides.
2. In the Navigator, select the business process and on the right pane, click **New**. The business process opens.
3. Enter a name and number for the new shell and select an administrator for the shell.
4. Specify where the shell should reside in the hierarchy by choosing a shell location as follows:
   a. Click the **Select** button. A shell picker opens, showing the tabs of all the current anchor shells.
   b. On the shell picker, click the anchor shell under which the new shell should reside. If the new shell should reside under a sub-shell, double-click the sub-shell.
   The sub-shell may contain other sub-shells. You can navigate to them by clicking the **View** drop-down (located in right corner) and selecting the sub-shell from the list.
5. Specify the template that should be used to create the shell as follows:
   a. Click the **Select** button. The Shell Template picker opens, showing a list of the templates that have been designed for the shell type this BP will create.
   b. Select the template and click the **Select** button. The name of the template appears in the field on the form.
6. Specify the shell status, such as Active or On-Hold.
   When the shell is created, this is the status it will be assigned.
7. Specify the BP status.
   When this status reaches this BP’s designated “terminal” status, it will automatically create the new shell or project and assign it the status you specified in step **6**.

Oracle Corporation
Primavera Unifier Users Guide • Copyright © 1998, 2012, Oracle and/or its affiliates. All rights reserved.
**Note:** If you do not specify a status, Primavera Unifier will assign a status of **Inactive** to the shell and you will have to manually change the status to make the shell active.

8 Complete any other fields that have been included on the form.

9 Click **Finish Editing**.

When the business process reaches its terminal status, it will create a new shell/project using the template you specified on the BP form, and the new shell/project should appear in the hierarchy in its appropriate place.

**To auto-create multiple shells or projects**

To auto-create multiple shells or projects, you need to fill out an upper form, and create line items for each shell/project you want to create. Primavera Unifier will use each line item to create a separate shell/project.

1 Navigate to the level (such as Company Workspace or a shell) where the auto-creation business process resides.

2 In the Navigator, select the business process and on the right pane, click **New**. The business process opens.

3 Complete the upper form fields, including the status of the business process.

4 Click the **Add** button at the bottom of the window and choose **Detail Line Item**. A Line Item window opens.

5 Enter a name, number, and description for the new shell and select an administrator for the shell.

6 Specify where the shell should reside in the hierarchy by choosing a shell location as follows:
   a Click the **Select** button. A shell picker opens, showing the tabs of all the current anchor shells. For example:
   b On the shell picker, click the anchor shell under which the new shell should reside. If the new shell should reside under a sub-shell, double-click the sub-shell. The sub-shell may contain other sub-shells. You can navigate to them by clicking the **View** button and selecting the sub-shell from the list.

7 Specify the template that should be used to create the shell as follows:
   a Click the **Select** button. The Shell Template picker opens, showing a list of the templates that have been designed for the shell type this BP will create.
   b Select the template and click the **Select** button. The name of the template appears in the field on the form.

8 Specify the shell status, such as Active or On-Hold.
   When the shell is created, this is the status it will be assigned.

   **Note:** If you give the shell a status of **Inactive**, child shells cannot be created.

9 Specify the line item status.
   This is the status at which the line item should be to create a new shell/project. When the line item reaches the status you specify here, Primavera Unifier will automatically create the new shell or project and assign it the status you specified in step 8.
Complete any other fields that have been included on the form.

Click Finish Editing.

When the business process reaches its terminal status, and the line item status reaches the status you specified in step 9, Primavera Unifier will create a new shell/project using the template you specified, and the new shell/project should appear in the hierarchy in its appropriate place.

**Working With Shell Features**

The Navigator displays the shell-related features that you have permission to access. Depending on the modules that your company has set up and your access permissions, the following shell functions are available.

---

**Note:** Company administrators can configure the Navigator to better suit business needs, such as creating nodes to store business process records.

---

- **Alerts:** You can create customized alerts for a condition or event.
- **uMail:** An internal e-mail feature that allows Primavera Unifier shell team members to communicate with each other and maintain a record of the communications. For shells with View-Only status, uMail is available for viewing, but you cannot send, edit or delete messages.
- **Mailbox:** The Mailbox is the repository that collects external emails related to the shell. These emails can come from shell users or from external users who do not use Primavera Unifier. From the Mailbox, users can forward the emails to appropriate members, flag them for review, and reply to them. In addition, these external emails can be linked to business process records. See "Using the Shell Mailbox" on page 146 for details.
- **Collaboration (Tasks, Messages, Drafts):** Lists current business process tasks that have been assigned to you, that you have been copied on, and draft copies you have saved. Tasks and Drafts are not available for View-Only and Inactive shells. Messages are available for View-Only shells, but you cannot add general comments.
- **Information:** Lists the shell directory and general BP information.
- **Gates:** Displays phase and gates information, and enables manual or automatic advancement of phases.
- **Configurable Modules:** The configurable modules that have been created to work with your shells.
- **Cost Manager:** Access shell-level cost manager functions.
- **Document Manager:** Repository of shell documents, allowing collaboration, revision control, or markups.
- **Reports:** Access to system and user-defined reports.
AUDITING SHELL CHANGES

The shell audit log lists the actions that have been taken on a specific shell. The Audit log captures changes that have been made to the fields on the shell’s attribute form.

**To view an Audit log**

From the View menu of the shell record, click Audit Log. The Audit Log window opens, listing each event that was taken on the shell’s attribute form. The date and time stamp of each event reflect users’ current time zone as set in their User Preferences.

**To view audit details**

From the Audit Log window, double-click a listed event to view the audit record detail, which details the action taken. The details also include the user’s current time zone for reference.

**To print a business process Audit log**

1. On the Audit Log window, click the Print button. A PDF file is created.
2. Do one of the following:
   - Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can view, save, or print the file.
   - Click Save. In the Save As window, navigate to the location in which you want to save the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print.

Adding An Image

In many forms, you can add an image to your shell. For example, you can add an image that shows progress on the shell information record. You can add images to attribute forms in shells, projects, companies, and BPs.

Valid image file types are:

- JPEG
- GIF
- PNG
- TIFF

Managing Shell Alerts

You can create customized alerts for a specific condition or event. For example, you could set up an alert that sends you an e-mail letting if a fund amount on the funding sheet has reached a certain level.

Alerts are created by creating an Alert-type user-defined report.

**To create an alert**

1. Create an Alert report in user-defined reports.
2. Open a shell and click Alerts in the Navigator. The Alerts log opens.
4. Complete the window as described in the following table.
<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>Click the <strong>Select</strong> button. The list of user-defined alert reports for the shell opens. Select a report from the list and click the <strong>Open</strong> button. You can also click the <strong>Find</strong> button and enter search criteria to locate a specific report. <strong>Note:</strong> Reports that are already used to create an alert are shown with a checkmark. You can create more than one alert for each report.</td>
</tr>
<tr>
<td>Description</td>
<td>Populated automatically with the report description, if one exists.</td>
</tr>
<tr>
<td>Alert Title</td>
<td>Appears as the title of the alert in the log and on the alert sent. By default, the field shows the report name, but you can change the name.</td>
</tr>
</tbody>
</table>
| Frequency    | How often you want the alert to be sent when the trigger condition is met:  
  • **Never:** Alerts are not sent.  
  • **Hourly:** Sent every hour, at about 20 minutes past the hour.  
  • **Daily:** Daily at about 2:20 a.m.  
  • **Weekly:** Sent on Mondays at about 2:20 a.m.  
  • **Monthly:** Sent on the first day of the month, about 2:20 a.m.  
  Times might vary. The times are based on the Primavera Unifier server used. Primavera Unifier servers operate on Pacific Standard Time.  
  **Note:** If you choose a frequency other than never, you must specify a method and message. |
| Method       | Select one or both of the methods to be notified of the alert. For e-mail, the address in your user profile is used). |
| Message      | Type a message that you want included in the alert. Remember that this is an alert that only you see, so enter as much or as little detail as you need. |

5 Click **OK** to close the Alert window.

**To edit alerts**

1 Open a shell and click **Alerts** in the Navigator. The Alerts log opens.

2 Select an alert and click **Open**. The Alert window opens.

3 Make changes to the alert as needed and click **OK**.

**To delete an alert**

Open a shell and click **Alerts** in the Navigator. The Alerts log opens. Select an alert and click **Delete**.
WORKING WITH UMAIL

uMail is an internal Primavera Unifier e-mail feature that allows shell team members to communicate with each other and maintain a record of the communications.

The uMail interface is similar to common e-mail programs such as Microsoft Outlook. uMail supports file attachments. You can send uMail to shell team members and to external e-mail addresses. External e-mail cannot be sent directly to uMail.

A copy of every uMail communication is saved in a central folder (Public Items) controlled by the shell administrator. These communications become part of the shell record. Shell or company administrators must grant users permission to access the Public Items folder. Depending on permissions, users can view all Public Items messages or only those in which they participated (sent or received). Permission can also be granted to deleted items in the Public Items folder. Once deleted, they are not recoverable, but users who sent or received messages deleted from the Public Items folder can still retain copies of the messages in their own Inbox or Sent folder.
ACCESS UMAIL

The uMail feature is shell-specific, and the full functionality is accessed at the shell level. A cross-shell listing of your Inbox and Sent items can also be accessed in the uMail node directly under Home.

To access uMail

1. Open a shell.
2. In the Navigator, click uMail. The uMail folders expand.
   - Drafts: Displays uMail messages that you have drafted but not yet sent.
   - Inbox: Displays messages sent to you.
   - Sent Items: Displays messages that you have sent.
   - Deleted Items: Displays items that you have deleted from one of the other folders.
   - Public Items: Stores copies of all uMail messages sent between shell team members. Access to the Public Items folder must be granted through permission settings.

To view all your uMail messages across shells

1. On the shell dashboard, click uMail. All messages residing in all shell uMail Inbox and Sent folders are listed.
2. To open a listed message, select it from the list and click Open.

To search for a specific uMail message across shells

1. On the shell dashboard, click uMail. All messages residing in all shell uMail Inbox and Sent folders are listed.
2. Click the Find button.
3. Enter search criteria in the Subject Containing or Message Containing fields in the upper portion of the log window.
4. Click Search. The log lists the messages meeting the search criteria entered.
SEND AND RECEIVE UMAIL

uMail functionality is similar to common e-mail programs. You can attach files, format text, flag the message, compose and save a draft of your response without sending it, and preview your message in a browser. You can correspond with your Primavera Unifier shell team members through uMail, and send uMail to external e-mail addresses. External e-mail users cannot send e-mail directly to uMail.

To send a uMail message

1. Access uMail and select any uMail folder.
2. Click New. A message window opens.
3. Choose the recipients of the uMail message by doing any of the following:
   - Click To. The User/Group picker opens displaying shell users. Select the recipients from the Select Users list and click Add. Click OK to close the picker.
   - To send a copy to another recipient, click Cc, and then choose the recipients from the User/Group picker.
   - To send a copy to an external e-mail address, enter the address in the External Cc field. Separate multiple addresses with a semicolon (;). The recipient sees Primavera Unifier Notification in the From field and cannot reply directly.
   - To send a blind copy (bcc), click the View menu and select Bcc Fields. The Bcc button and External Bcc field become available on the uMail message window.
4. Type the subject of the message in the Subject field.
5. Type the body of the message in the text field.

Note: To attach files, format the text, flag a message for follow up, compose and save a draft of your message without sending it, or preview your message in a browser, see the following procedures.

6. Click Send to send the message.

To view or respond to a uMail message

1. Double-click a message to view it. The message opens.
2. To respond to the message, do one of the following:
   - To send a reply to the sender, click Reply.
   - To send a reply to the sender and other recipients of the original message, click Reply to All.
   - To forward the message to another recipient, click Forward. File attachments remain with forwarded messages.
3. Type your response and click Send.

To attach files to a uMail message

1. Open the uMail message.
2. Click Attach and choose one of the following:
• To attach the file from your local system, select **My Computer**. The procedure is the same as uploading files to the Document Manager and depends on your file transfer option.

• To attach documents from the Document Manager, select **Primavera Unifier Folder**. The window opens, displaying the shell documents files and folders. Select the files and folders to attach and click **OK**.

**Note:** When attaching a folder, the contents of the folder is attached in a flat list. You cannot attach documents with duplicate file names.

3 Click **OK** to add the file, and the click **OK** to close the General Comments window.

You can also send a copy of a completed BP form directly while working in the BP form. Primavera Unifier automatically creates a PDF copy to send via uMail.

**To flag a uMail message for follow-up**

1. Open an existing message, or create a new message.

   If you want to flag a message that you are replying to or forwarding, then open the message, and click **Reply**, **Reply All** or **Forward**.

2. Click the **Flag for Follow-Up** button. The Flag for Follow-Up window opens.

3. In the **Flag to** field, choose an action, such as “call,” or “for your information.”

4. Click **OK**. The flag text appears at the top of the message. A red flag symbol will also display next to the message in the log. (You may need to refresh the log to see the flag.)

5. If this is an existing message that you are flagging for yourself, you can simply close the message. If you are sending the message to someone else, add the recipients and send the message.

**To remove a uMail flag**

Click the **Flag for Follow up** button, and then click **Clear Flag**.

**To format uMail text**

1. Open the uMail message.

2. Select the text that you want to format in the body of the message.

3. On the Formatting toolbar, choose the formatting to apply to the text.

**To spell check uMail text**

1. When you are finished composing a uMail message, click the **Spelling** button on the toolbar of the message. The body text of the message is checked.

2. Make spelling corrections as necessary and click **OK**.

**To print a uMail message**

1. Open the uMail message.

2. Click the **Print** button.

**To print several uMail messages from the uMail log**

1. Navigate to a uMail log.

2. Select several uMail records that you want to print.
3 Click the Print button.

To search for a uMail message

1 In the Navigator, click a uMail folder.

2 From the toolbar, click the Find button. The Find box expands above the log.

3 Do any of the following:
   • To search by the recipient (To field), click the Select button and choose the user from the User/Group picker.
   • To search by subject, enter a word or phrase in the Subject Containing field. You can use partial entries.
   • To search by message content, enter a word or phrase in Message Containing.
   • Further refine the search by choosing Read or Unread.

4 Click Search. The messages meeting your search criteria are listed in the log.

To delete uMail messages

1 Do one of the following:
   • From a uMail log, select the message and click Delete.
   • From within a uMail message, click Delete on the toolbar.

   The message is moved to the shell Deleted Items folder.

2 To permanently delete a message, select it from the Deleted Items folder and click Delete. Click Yes to confirm.

When you delete a message from your account, a copy of the message remains in the central shell Public Items folder. Messages deleted from the Public Items folder are permanently deleted.
LINK UMAIL MESSAGES TO BUSINESS PROCESS RECORDS

You can link uMail messages directly to BP records using the Linked uMail link at the bottom of the BP form. This option is available only in BPs that have been set up to accommodate linked uMail messages. Attaching messages or viewing attachments depends on your uMail permissions.

To view a list of BP records to which a uMail message is linked

1. Open the uMail message.

2. If the message is linked to a BP record, the upper portion of the message displays the following: *This uMail and any future replies are linked to records. Show list*

3. Click the Show list link to view the list of BP records to which the uMail is linked.
USING THE SHELL MAILBOX

External emails are important communications that need to be included in shells. Such emails can come from shell users or from external users who do not use Primavera Unifier. These email communications (and any attachments) are collected in a central repository for the shell, called the Mailbox, so that shell users can use them in managing and documenting the shell. Once such emails reside in the Mailbox, users can view them, forward them to appropriate members, flag them for review, and reply to them. In addition, you can link these emails to business process records.

External emails that have been blind carbon-copied (Bcc’d) are not collected by the Mailbox.

**Note:** To use any of the mailbox features, you must have permissions.

**To open the Shell Mailbox**

1. Open your shell.
2. In the Navigator, click the Mailbox node. The right pane displays a log of the contents of the Mailbox.

**To open an email**

On the Mailbox log, double-click the email. Primavera Unifier opens the email. If there are attachments, the email will display an Attachments (n) link. To open an attachment, click the link and double-click the attachment on the list that appears.

**To flag an email for follow-up**

1. Open the email.
2. Click the Flag for Follow-Up button. Primavera Unifier opens the Flag for Follow-Up window.
3. In the Flag to field, choose the action you want for this email, such as “call,” or “for your information.”
4. Click the Reply button to reply to the email, or click the Forward button to forward the email on to someone.

When the recipient opens the message, the specific flag remark is shown across the top of the message.

**Note:** To remove the flag, click the Flag for Follow up button, and then click Clear Flag.

**To reply to an email**

1. Open the email and click the Reply button.

Primavera Unifier displays the addressee’s email address in the External To field. You can add additional external addresses in this field, separated by semi-colons (;).

2. (Optional) To add email addresses to the Cc line, click the Cc button. The User/Group Picker opens.
a Select the user(s) you wish to add to the message and click **Add**. The names appear in the Selected Users area at the bottom of the window.

b Click **OK**.

3 (Optional) To attach a file to the reply, click the **Attach** button and choose **My Computer** or **Primavera Unifier Folder**.

a In the window that opens, select the file you want to attach, or browse your computer’s directories to locate the file to attach.

b Click **OK**. Primavera Unifier attaches the file to your reply.

4 Enter your reply and click **Send**.

Primavera Unifier sends the email to the persons you specified.

Once you reply to an external email, the communication will become part of Primavera Unifier’s uMail system. To see your reply, or any other communication regarding this email after this point, look for it in the uMail node of the Navigator.

Any reply you made to the email will appear in the **Sent Items** node of uMail.

Any email you forwarded will also appear in the **Sent Items** node of uMail.

**To forward an email**

1 Open the email and click the **Forward** button. A forward email window opens.

2 Click the **To** (and optionally, the **Cc**) button. The User/Group Picker opens.

3 Select the user(s) to whom you wish to forward the message and click **Add**. The names appear in the Selected Users area at the bottom of the window.

4 (Optional) To forward the email to external users, enter their addresses in the **External Cc** field, separated by semi-colons (;).

5 Click **OK**. Primavera Unifier forwards the email to the persons you specified.

**To delete an email**

On the Mailbox log, select the email and click the **Delete** button. To delete multiple emails, hold down the **Ctrl** key on your keyboard and select the emails.

**To print an email**

On the Mailbox log, select the email and click the **Print** button. To print multiple emails, hold down the **Ctrl** key on your keyboard and select the emails.

**To find a specific email**

1 On the Mailbox log, click the **Find** button. Primavera Unifier opens a Find window at the top of the log.

2 Enter the search criteria.

• To search for an email from a specific person, enter the person’s email address in the **From** field.

• To search for an email with a specific subject line, enter the subject line in the **Subject containing** field.

You can enter partial addresses or words in any of these fields. Primavera Unifier will display all the emails that match the partial information you entered.
To search for an email with some specific content in the message, enter that content in the **Message containing** field.

3 Click **Search** (or press **Enter**).

Primavera Unifier will display the emails that match the criteria you entered. It will also identify the criteria by which you have searched the list in the “**Current View: filtered by**” line above the list.

**Collaborating With Team Members**

Primavera Unifier helps you to collaborate with your fellow team members through business processes.

**View Shell Information**

Shell information consists of the directory and the general information node. The Information node in the Navigator has two subnodes:

- **General** is a log of general information BP records.
- **Directory** is a list of shell team members

General records originate as single-record BPs—only one record exists per shell. The General log is useful for shell-specific information that only needs to be documented on a single form. You can use it to easily categorize and find big-picture shell information. An example is general shell data or descriptions.

**To access shell information**

1 Open a shell

2 In the Navigator, choose **Information > General**. The log displays the available records.

3 To open a record, select it and click **Open**.

**To view the shell directory**

1 Open a shell.

2 In the Navigator, choose **Information > Directory**. The Directory log opens, listing the shell team members and their contact information.

**Contact Shell Team Members**

You can view the contact information of team members, and send them e-mail or uMail from within Primavera Unifier. If there are many team members, you can use the search function to find a particular member.

**To find a shell team member**

1 Open the shell Directory and click **Find**.

2 Choose which information to search by in the **Search By** selection list (for example, first name).

3 Enter search criteria in the **Search for** field (for example, enter all or part of the first name), and click the **Search** button.
To view a team member’s user profile

1 In the Directory, select the user from the list and click Open. The View User Profile window opens.

**Note:** If a User Administration design has been imported from Primavera uDesigner by your Administrator, the content of this profile can vary.

2 In the **Contact Information** selection list at the top of the window, choose one of the following:
   - **Current shell name:** Displays contact information specific to the current shell, such as the onsite address or cell phone.
   - **Company Contact Information:** This is the member’s company contact information.

To send an e-mail using an external e-mail program

Do one of the following:

- In the Directory, select a team member’s name and click **Send e-mail**.
- In the team member’s User Profile window, click the e-mail address.

An e-mail dialog box using your default e-mail program (for example, Microsoft Outlook) opens. The To: field is populated automatically with the member’s e-mail address. E-mail sent through your external e-mail program is not saved as part of the Primavera Unifier shell record.
AUTO-POPULATION AND REVERSE AUTO-POPULATION IN SHELLS

Fields on a business process in a child shell can be setup in Primavera uDesigner to auto-populate from the attribute form of the current shell or any parent shell, or to auto-populate from the upper form of a single-record non-workflow business process under any parent shell. Also, a field on a shell attribute form can be setup to auto-populate from the attribute form of any parent shell, or from the upper form of a single-record business process under any parent shell.

For example, a bank can have multiple banking centers. When a new banking center is commissioned, then a project shell can be used to manage the construction details of the banking center. A Work Order business process, which is created under the project shell contains details including physical characteristics from the Site shell. In this example, that includes the building color, which is auto-populated to the Work Order business process so that the building is painted the correct color.

Note: If a shell is moved to a new place in the shell hierarchy, fields that are auto-populated for that shell retain the values that were populated when the shell was initially created. Auto-population does not reoccur when a shell is moved in the shell hierarchy.

Reverse Auto-population In Shells

Certain data elements support reverse auto-population. These are specified in Primavera uDesigner. Reverse auto-population means that some values can be automatically updated when other values are modified in a BP form or shell attribute form.

Note: Reverse auto-population does not occur for shells with View-Only status.

Depending on the set up in Primavera uDesigner, reverse auto-population can occur in these instances:
• Changes to the data elements in a child shell’s attribute form can result in changes to the attribute form of any parent shell in the shell hierarchy.

• Changes to data elements in a BP detail form under a child shell can result in changes to the current shell attribute form or any parent shell attribute form in the shell hierarchy.

For example, when a new banking center is commissioned, a shell instance is used to construct the banking center. The parent shell needs to be updated with data from the attribute forms of the child shell and from BPs within the child shell.

Also, data stored in a Code and Records-based Manager (such as a Parts Manager) may change based on company-level or project/shell-level BPs, and those changes need to reverse auto-populate back to the attribute form.
WORKING WITH GATES AND PHASES

Gates allow you to assess the quality and integrity of a shell throughout its life cycle. A series of gate conditions are defined and tracked for each phase of the shell. Each gate condition is evaluated against the shell data and is marked complete if the conditions are met. When all the conditions are met, the shell moves to the next phase either automatically or manually, based on the configuration.

Phases and gate conditions are configured in the Gates Setup in Administration Mode.

You can use the Gates dashboard when working with shells to do the following:

- Monitor the progress of phases
- View phase conditions and their definitions
- Run a gates process
- Manually override a gate condition
- Manually advance a phase

View Gate Condition Details

To access the Gates dashboard

1. In User Mode, open a shell.
2. In the Navigator, click Gates. The Gates dashboard opens.
3. Do one of the following:
   - Select a phase and click the Edit button on the toolbar. Click the View button below the Gate Condition pane. The Edit button is available if the gates setup is active.
   - Double-click a gate condition in the Gate Condition pane.

The Edit Gate Condition window opens. This is a view-only window. The General tab displays the data type associated with the gate condition. The Query tab displays the data element and trigger condition for this gate condition.
VALIDATE GATE CONDITIONS MANUALLY

You can manually validate conditions, which is the same validation that is performed during scheduled runs. The dashboard is updated to show any changes to the gates conditions.

**Note:** Your Administrator can configure that Gates conditions are validated on each Gates run.

**To manually run gates**
In the Gates dashboard, click the **Refresh** button.

If a gate condition is met, it is marked as complete. If all gates conditions are have been met for a shell phase, and Automatic Advancement is set, the shell phase advances to the next phase.

**Edit Phase Details**

**To edit phase details**

1. In the Gates consoles, select a phase and click the **Edit** button. The Edit Phase Detail window opens.

2. Do any of the following:
   - Mark a gate condition as complete by selecting the **Complete** checkbox next to it.
   - Mark a completed gate condition as not complete by deselecting the **Complete** checkbox.
   - Select and view gate condition details.
   - Add or view general comments.

<table>
<thead>
<tr>
<th>This item</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gates Condition list</td>
<td>Displays the gates conditions that must be met for the selected phase.</td>
</tr>
<tr>
<td>Complete checkbox</td>
<td>Select the checkbox to flag the gate condition as complete.</td>
</tr>
<tr>
<td>Ignore Condition checkbox</td>
<td>Select the checkbox to override the gate condition requirement for this phase.</td>
</tr>
<tr>
<td>View button</td>
<td>Click View to open the view-only Edit Report window. The General tab displays the data type associated with the gate condition. The Query tab displays the data element and trigger condition for this gate condition.</td>
</tr>
<tr>
<td>General Comments Add/View</td>
<td>Click the button to add or view general comments associated with this phase.</td>
</tr>
</tbody>
</table>

**Advance A Shell To The Next Phase**

After the gate conditions have been met for a phase, you can manually advance a shell to the next phase.
To advance to the next phase

1. In the Gates console, click the Advance to Next Phase button.

2. In the confirmation window, click Yes.

3. The system validates whether all gates conditions have been met for that phase. If all gates conditions are complete, the shell advances to the next phase. If any gate conditions have not been met, you can do the following:
   - Manually mark a gate condition as complete. See .
   - Select the Ignore Condition checkbox to override the gate condition requirements. See “Edit phase details” on page 153.
   - Select the phase and click the Edit button to view details about the phase and gate conditions to determine what needs to be done to meet the condition.

Return To A Previous Phase

You can return to a previously completed phase and make it the current phase.

To return to a previously completed phase

1. Select the phase to reset as the current phase.

2. Do one of the following:
   - Select a gate condition and edit it so that it is no longer complete.
   - Add a new condition so that the completed phase is no longer complete.

Add Or View Phase Comments

To add comments in a phase

1. In the Gates console, select the phase and click the Edit button. The Edit Phase Detail window opens.

2. Click the General Comments Add/View button. The General Comments window opens.

3. Enter comments in the Text Comments window and click OK.

   Note: After you have saved a comment, it cannot be edited or deleted.

To view comments for a phase

- In the Gates console, click the General Comments View button at the bottom of the window. The General Comments window opens displaying existing comments.
- In the Gates console, select the shell phase and click the Edit button. Click the General Comments Add/View button. The General comments window opens.

Monitoring Gates

You can view results from prior scheduled gates runs.

To view gate runs

1. In the Gates console, click the Saved Gates Runs button. The Saved Gates Runs window opens.

2. Select a gate run from the list and click Open. The results are available in a PDF file. PDF file names include the date and time of the gate run.
3 Choose to view or save the PDF file and click **OK**.
The audit log captures Ignore Condition flags and general comments.

**To view the gate audit log**
In the Gates console, select **View > Audit Log**.

**View Gate Audit Log**
The audit log captures Ignore Condition flags and general comments.

**To view the gate audit log**
In the Gates console, select **View > Audit Log**.
BUSINESS PROCESSES
ABOUT BUSINESS PROCESSES

Primavera Unifier transactions and collaboration are driven by business processes. Information is entered and stored in Primavera Unifier using electronic business process (BP) forms. Each time you fill out a business process form, you are creating a new record in Primavera Unifier. These forms may be routed to project or shell team members or other Primavera Unifier users via workflows. Non-workflow BPs will simply be stored as records. Business process records are stored in logs, which are accessible in the Navigator. You can think of these logs as filing cabinets, with each drawer storing a different type of business process.

The information that you enter into business process fields may be used throughout Primavera Unifier. Each field corresponds to a “data element” that can be identified, reported upon, and tracked; some data element values may be rolled up to sheets such as a cost sheet or resource sheet. The look and feel of a field (data element) is determined by the data definition on which the data element is based. The data definition determines whether the field is a text-entry field, a drop-down list of options, a checkbox that you can select, a picker that is used to select an existing Primavera Unifier record, etc.

Business processes can be associated with specific project or shells (project- or shell-level BPs) or can be applicable for the entire company and not project- or shell-specific (company-level BPs). The project or shell or company administrator determines which forms are to be used and how the workflows will operate.

Business process forms are designed in Primavera uDesigner.
WORKFLOW VERSUS NON-WORKFLOW

Business processes can be designed with or without workflows. A workflow specifies how a business process should proceed, from start to finish. Workflows define how records are routed and govern the behavior of each step in the business process. Each step uses the forms that were designed for it in Primavera uDesigner.

Most business processes will include a workflow or workflows; however, some business processes have a single purpose of storing data. These business processes are called non-workflow BPs. An example of a non-workflow BP is one or more forms that record contact and other general information about a company.
BUSINESS PROCESS TYPES

Different business needs require different types of business processes. In Primavera uDesigner, many different types of business processes are available that perform various functions within Primavera Unifier. Business processes can be of the following types:

**Cost Type**

These forms track and manage cost information and interact with the project or shell cost sheet. Examples include base contracts or purchase orders, change orders, budget change requests, invoices, fund appropriations, and leases. Additional cost-related functionality includes schedule of values and payment applications.

Cost business processes have several sub-types that are used to perform specific cost-type functions in Primavera Unifier. The cost business process subtypes are:

- **Commit at company level (also known as Blanket Purchase Order):** This sub-type allows tracking and control of costs at the company level above the WBS level. It is independent of a budget or cost sheet and is used for tracking non-WBS expenses across projects or shells. Project or shell level commit BPs can be set up to reference a company commit.
- **Line items with WBS code:** These business processes directly relate to the project or shell cost sheet. BPs that use a WBS picker to reference WBS codes must use this subtype. These BP transactions can directly affect the budget. Examples include base commits, change commits, general spends, and payment applications.
- **Line items with fund code:** This sub-type is used for fund appropriation at the project or shell level. Business processes can be created to automatically allocate or consume funding source funds, which are chosen using a Fund picker. These transactions are for fund management and do not necessarily affect the budget. Transactions on this type of BP roll up to the Fund Manager.
- **Line items with both WBS and fund code:** This sub-type is used during fund appropriation at the WBS level. These transactions are for fund management and do not necessarily affect the budget. Transactions on this type of BP roll up to the Fund Manager and Cost Manager.
- **Line items with company accounts code:** This is a company-level business process that can be used to roll up transaction data to the company accounts sheet.
- **Line items with asset code:** This is a company-level business process that can be used to roll up transaction data to asset sheets.
- **Line items with multiple codes:** This sub-type is for business processes that can be used with a generic (non-WBS) cost manager.

**Document Type**

You use this form as an “envelope” to package a set of files, such as spreadsheets, drawings, and design documentation, that flow from one group to another. Advanced functionality allows documents to be attached to the form as line items, with line item status control. This allows the ability to change the status (for example, approve or reject) for each attached document. Examples are submittals and transmittals. There are two subtypes:

- **With folder structure:** Both documents and folders can be uploaded to the BP. The folder navigator in the lower left of the form displays the folder structure.
• Without folder structure: The folder structure will be ignored, and documents are attached in a flat list. The contents of selected folders and sub-folders are attached.

**Line item type**

This type lends itself well to business processes that involve miscellaneous information you want to document for a company or project; for example, a vendor contact list. Or, they are useful for project-specific information that only needs to be documented on a single form, such as the overall project scope, or meeting minutes.

Line item BPs are also useful for collecting data that other, more restricted types of BPs cannot. For example, while a simple-type BP can be used to collect basic vendor information, a company-level line item BP can collect additional vendor information, such as multiple business addresses. At the project level, you can use a line item BP to filter large numbers of company records into smaller lists of records that are more appropriate for a specific project.

Line item BPs use a separate detail form to enter line items, which then appear on a line item list at the bottom of the form. Or, for short line items, Primavera Unifier users can enter information directly into the line item list using a “grid view” of the list.

You can design these BPs to accommodate line item status, so you can control modifications to individual line items based on their status.

There are two sub-types of this BP:

• **Generic**: Use this sub-type for all line item BPs unless you want to filter BP records. To filter BP records, use the sub-type explained below.

• **Line items to filter business process records**: Use this sub-type to filter company records into smaller lists of records for your projects. This BP is particularly suited for selecting specific vendors from a company’s master vendor list to create a sub-set of the master list that contains vendors who are appropriate for a particular project. Used for this purpose, this BP type can be linked (as a reference process) to an RFB to supply a project-specific vendor list for bid invitations.

**Project/Shell Creation type**

The Project/Shell Creation type of business process creates new standard projects and shells from the upper form of the BP or from line items. The data necessary to create projects/shells is provided by this BP. In addition to creating a new shell, this type of business process can also be designed so that you can choose the managers and employees who should be automatically assigned to the shell when it is created.

This BP creates projects and shells using the templates that have been designed in Primavera Unifier.

Project/Shell Creation type business process can also work with the Planning Manager by automatically linking new projects/shells with planning items. Instead of linking a planning item to a project in the Planning Manager, this BP can be designed to automatically create the link when the project/shell is created, and roll up data to the Planning Sheet from the business processes in that project/shell.

Unifier also has the ability to define the integration interface for Project/Shell creation of business processes (simple only) through importing a CSV. See [Importing Business Processes](#).

**Request for Bid (RFB) type**

The RFB module allows companies to invite project- or shell-related bids from different vendors. There is a BP form for requestors (Primavera Unifier user requesting the bids) and for bidders (bidders do not
need to be existing Primavera Unifier users and are provided with a simple interface that does not require special training to use).

**Resource type**

Resource business processes work with the Resource Manager. There are two subtypes:

- **Resource booking**: This is a project-level business process. In the upper form, you pick a date range to book resources. The line item list displays a summary of booking rows. You can one resource booking BP per project.

- **Time sheet**: The time sheet business process can be designed to roll up hours and costs from the time sheet to cost sheets. There is one per company, but there can be multiple schemas.

**Simple type**

These BPs consist of an upper form only (like a line-item-type BP without the line items). It is a way to add company or project or shell information that does not require line items. Simple BPs can be a company-level, non-workflow, single or multi-record, or a project- or shell-level, workflow or non-workflow, multi-record. An example is a project information form to capture basic reference information.

**Text type**

This form’s content is typically a text comment in the lower portion of the form. Examples of text type BPs include RFIs (Request for Information) and action items, which track issue resolution.
ABOUT BUSINESS PROCESS DATES AND CALENDARS

Primavera Unifier supports multiple calendars, enabling the Administrator to create a library of calendars that can be selected for use at the Company or project/shell levels. The multiple calendars enable you to have calendars to support varying work schedules (depending on locality) and to account for holidays and other non-working days. For example, some countries in the Middle East have weekends that are other than Saturday and Sunday.

Calendars affect the calculation of both business process workflow due dates and task due dates, and formula calculations. When the calendar changes for the Company, or for the project/shell, any subsequent computation of dates will use the new or changed calendar. Dates are not affected for records that are in process. The Date Picker and the Date Only Picker will show the changed calendar.
ABOUT BUSINESS PROCESS FORMS

The electronic forms in Primavera Unifier are simple to use once you understand how they work. Business process forms are consistent throughout Primavera Unifier, with a similar look and feel.

When you first open a form, it appears in “view” mode. On the “view” version of this form, you can do the following:

- Accept the task
- Decline the task
- Print the form
- Terminate the record
- Send uMail
- Transfer ownership of the record
- Add an assignee to the current step
- Copy users to the current step
- Audit the progress of the record
- Add a comment, if you have permission

If you accept the task, the form becomes editable. On the editable, or “action,” version of this form, you can do the following:

- Undo task acceptance (decline the task)
- Select the step’s next action
- Add or edit form content
- Save a draft of the record
- Terminate the record
- Transfer ownership of the record
- Display the view form of the BP
- Audit the progress of the record
- Spell check the record content
- Add attachments, line items, etc.
- Send the form to the next step

The electronic form appears similar to a paper form—you complete the form by typing information directly into the form fields or choosing options through drop-down lists, pickers, or checkboxes.

Note: The section labels are determined in Primavera uDesigner and may vary. The basic form functionality remains the same.
PARTS OF THE FORM

In general, most business process forms consist of three major sections: General, Action (or Task) Details, and Line Item List, unless otherwise noted. This is an example of a business process form:

You can minimize and later expand a business process form. You might want to minimize the General and workflow portions of the form to avoid scrolling through many line items.

Toolbar: The business process form has a toolbar at the top of the form, with the following buttons:
After you are done working on the business process form, click **Send** to route the workflow business process to the specified recipients. You can click **Save** to save a draft of the form, so you can work on it again. Click **Spelling** to check the spelling in your form. You can click **Add Attachment** to add attachments to the form. If the BP is designed to include discussions among members of a group, you can click **Discussion** to open a discussion forum. When you have completed work on the business form, click **Close Window**.

**Note:** The Close Window action does not save the information on the form. To save the information, you must click **Save** before you click the **Close Window** button.

**Upper Form:** The upper portion of the business process contains the basic (General) information that the form is managing, such as the name of the record and its description, who created the record and when, and other general information. It may also contain fields for referencing other forms, and it may contain fields that are required for specific functionality. This is an example of an upper form for a business process type called Work Orders:

![Upper Form Example](image)

**Workflow or Action Details:** This section appears in the middle part of workflow business processes. It is for viewing or assigning the next assignee in the workflow or shows the last person who took action on it. Depending on how the workflow has been set up for the BP, the next assignees may be predetermined, or you may be able to choose the next assignee or send a copy of the BP to another user. You can print workflow progress using custom print.

Non-workflow business processes do not have an Action Details section.

This is an example of the workflow section of a business process:

![Workflow Details Example](image)

The **To:** and **Cc:** buttons are active after you select a workflow action in the Workflow Actions drop-down menu in the upper right corner of the form.

You can track a step through the workflow by clicking on the link beside **Task Status**. See “Track a Step Through the Workflow” on page 304.

Click the notepaper icon next to **Task Notes** in the Action Details section to add notes to the routed task. These are notes for the task recipients.

**Content or Lower Form:** The lower portion of the form contains the details and main content of the record, such as line items, file attachments for document-type business processes such as transmittals
or submittals, or comments or instructions in text-type BPs such as RFIs. Simple-type BPs do not have a Content section.

**Content or Lower Form:** The lower portion of the form contains the details and main content of the record, such as line items, file attachments for document-type business processes such as transmittals or submittals, or comments or instructions in text-type BPs such as RFIs. Simple-type BPs do not have a Content section.

The lower form of certain BPs may be organized using multiple tabs. The BPs that support tabs in the lower form are:

- Line item type
- Cost type with the classification generic (line items with WBS codes, multiple codes, or account codes)
- Cost type with the classification lease, and the subtype line items with multiple codes

**Tip:** If the entire name is too long to appear on the tab, hover the mouse over the tab. Primavera Unifier will display the complete name in a tool tip.

There are buttons under the lower form portion of the business process form that enable you to work with line items:

- Use the **Add** button to add detail or summary line items to the record.
- Use the **Copy** button to copy another line item from the record, included consolidated line items.
- Use the **Import** button to import a line item from a CSV file.
- Use the **Remove** button to delete a line item from the record.
- Use the **Grid** feature to enter line items directly into the line item list. (This is best used for short line items.)
Use the **Find** function to locate a line item in a long list of line items.

**Links:** Links at the bottom of the business process form allow you to access attachments, linked records, comments, and uMail:
AUTO-SEQUENCING AND UNIQUE VALUES IN FIELDS ON BUSINESS PROCESS FORMS

The Administrator can specify values on business process upper or lower forms that enable auto-sequencing, or that specify unique values (upper form only). These features are available for Company level and project/shell level, and can be used on workflow and non-workflow business processes.

Auto-sequencing

The Administrator can configure auto-sequencing for certain data elements on a business process form. This is in addition to the standard business process numbering, and allows the numbering of up to two fields on a upper form, and two fields on a lower form. For example, the Administrator can specify that a Name field uses auto-sequencing in order to number business processes that have similar names. Auto-sequencing generation occurs for the business process when the you click:

• Send on workflow business processes
• Save on non-workflow business processes
• Finish Editing on non-workflow business processes for line items
• Apply or OK for line items

Note: Fields configured for auto-sequencing are not available for Bulk Edit, since the values for these fields are system-generated.

Unique Values

The Administrator can configure unique value validation on data elements on business process upper forms. For example, if a business process has a field called Invoice, and should enforce that each invoice number is a unique string, this field can be configured to validate for a unique value. If you attempt to enter a string that is not unique (has been entered on another business process), you will get a warning message that an alternate value must be entered. Unique value validation occurs for the business process when the you click:

• Send on workflow business processes
• Save on non-workflow business processes
• Finish Editing on non-workflow business processes for line items

Note: If you use Bulk Edit to update multiple records, and attempt to update a field that has value uniqueness configured, only the first record will update (and is therefore unique).
ABOUT PICKERS

Pickers appear as a selection list on a business process or other entry form. These pickers allow you to view, select, or reference another Primavera Unifier record.

Most pickers display a list of records in a flat list, such as this one:

![Flat list of records](image)

Some pickers can be designed to display a navigation structure to guide you to the correct location where a record resides, such as a specific shell, a specific class in a configurable manager, or a specific business process. Below is a list of Work Order business process records that has been designed to show an extra navigation column on the left.

![Navigation structure](image)

By using this extra tree structure column, you can navigate more easily through your business process records to the correct one.
Oracle Primavera has created the following pickers, which are shipped with the Primavera Unifier product:

<table>
<thead>
<tr>
<th>Picker</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account Code Picker</td>
<td>Found on cost-type BPs for choosing company account codes.</td>
</tr>
<tr>
<td>Activity picker</td>
<td>Found on project- or shell-level BP forms for selecting activities from the master schedule sheet.</td>
</tr>
<tr>
<td>Asset picker</td>
<td>For selecting an asset for a project or shell. The assets listed will be filtered to include only those assets that are at a specific status or statuses.</td>
</tr>
<tr>
<td>BP picker</td>
<td>For linking one business process to another (for example, to tie invoice BPs to purchase order BPs). Often, the field will be named something like Reference BP, although this is up to the designer of the BP. Depending upon the design of the form, some fields may be automatically populated when the referenced BP is selected.</td>
</tr>
<tr>
<td>Commit Line Item picker</td>
<td>Used when you create a new line item for a change commit BP. This picker displays a composite view of base commit and change commits. The data elements on the picker are reference, description, and WBS code.</td>
</tr>
<tr>
<td>Company picker</td>
<td>For selecting a partner or member company, for example, a vendor list.</td>
</tr>
<tr>
<td>Currency picker</td>
<td>For selecting a currency on a cost-type BP. If no currency is chosen by the creator of the record, the default is the project or shell currency. If no Currency picker is on the form, the currency defaults to the project or shell currency.</td>
</tr>
<tr>
<td>Date picker</td>
<td>Displays an interactive calendar from which the date can be chosen. For some business processes, dates in Date pickers can be set in Primavera uDesigner to automatically default. For example, this defaulting can be useful in the case of entering a delivery date and having the date default to today’s date rather than have to use the Date picker to get a date.</td>
</tr>
<tr>
<td>Date Only picker</td>
<td>Displays an interactive calendar from which the date can be chosen. This picker allows you to select a date from the picker, or enter a date into the field. This picker allows you to choose the date only, with no associated time or time zone. For example, you would not need time and time zone for a date like an equipment purchase date. Also, for some business processes, dates in Date Only pickers can be set in Primavera uDesigner to automatically populate the server date. For example, this defaulting can be useful in the case of completing an equipment purchase and having the date default to today’s date rather than have to use the Date picker to get a date.</td>
</tr>
<tr>
<td>Fund picker</td>
<td>On Cost BPs, for selecting which fund (from the company funding sheet) the BP will allocate funds to or consume funds from.</td>
</tr>
<tr>
<td>Location picker</td>
<td>For selecting a shell.</td>
</tr>
<tr>
<td>Planning Item picker</td>
<td>For selecting a planning item at the company level.</td>
</tr>
<tr>
<td>Project picker</td>
<td>For selecting a company-sponsored project. You can use this picker to auto-populate project data elements on other BP fields. The picker is designed to show Active, Inactive, View-Only, and On-Hold projects.</td>
</tr>
<tr>
<td>Project Template Picker</td>
<td>For selecting a template to use to auto-create a project.</td>
</tr>
<tr>
<td>Resource</td>
<td>On time sheet, booking, or assignment BP, for selecting the resource to report on or assign. This</td>
</tr>
<tr>
<td>Picker</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>picker</td>
<td>picker always opens in Find mode and requires you to enter at least one search criteria, such as a name or a skill, to narrow the field of names to choose from. For time sheet BPs, use this picker to select the personnel to report time on. At runtime in Primavera Unifier, the picker will default to read-only mode and show the current user’s name, as Primavera Unifier assumes the user will be reporting his or her own time. However, depending on permissions, the picker can be editable to allow others, such as project managers, to complete time sheets on behalf of other workers.</td>
</tr>
<tr>
<td>Role picker</td>
<td>On time sheet, booking, or assignment BPs or for resource allocation sheets. It allows you to choose the role to report on or assign. On time sheet BPs at the project level, it will filter out those roles that have already been booked for other projects</td>
</tr>
<tr>
<td>Shell picker</td>
<td>For selecting a company-sponsored shell to auto-populate shell data elements on other BP fields. The picker is designed to show Active, Inactive, View-Only, and On-Hold shells.</td>
</tr>
<tr>
<td>Shell Template Picker</td>
<td>For selecting the template that should be used by a BP to auto-create a shell. The picker will show you a list of active templates that have been created for the shell.</td>
</tr>
<tr>
<td>User/Group picker</td>
<td>For selecting project/shell users (members of a project team) or company users (all users defined within a company). See more information under See “The User/Group Picker” on page 173.</td>
</tr>
<tr>
<td>WBS picker</td>
<td>On Cost-type business processes, project/shell cost sheets, and on schedule activity forms, for selecting WBS codes.</td>
</tr>
<tr>
<td>Week Picker</td>
<td>On Resource or Time Sheet BPs for selecting a specific week for reporting.</td>
</tr>
<tr>
<td>Work Package Picker</td>
<td>On Cost-type BPs, for selecting a work package for a Cost Sheet. This picker is populated with the work packages that have been created.</td>
</tr>
</tbody>
</table>
THE WBS PICKER

The WBS Picker works as does every other picker, except that it also has an auto-completion feature. If you know the code, begin typing in the WBS Picker field, and the picker will show the top 10 matches. If you continue to type, the picker will narrow the list as it matches more of the characters you type.

In this picker, you can use the following keyboard shortcuts:

- Use the Up and Down arrows to move through the list
- Press the Enter key on a highlighted WBS code to confirm a selection
- Press the Backspace key to delete a selection
- Use the Tab key to make a selection and move to the next field on the form
THE USER/GROUP PICKER

Most pickers operate in the same way. However, the User/Group Picker has several features that other pickers do not.

**Note:** If a User Administration design has been imported, the content of the User/Group picker (in User view) can vary. The Find window and sort order can also vary depending on the optional design created in Primavera uDesigner.

To filter the user/group list

The list of users and groups in your company may be very long. To make reading the picker list easier, you can filter the names on the list by project/shell and by user or group, or both.
To filter the list by project or shell, use the **List Names From** field and choose the name of the project or shell. (This filter option is usually available only to administrators; for example, when an administrator is adding project or shell members.)

To filter the list by user or group, use the **Show By** field to display users, groups, or both users and groups on the list.

**To select a user or group**

1. To select a user or group for an action, select the name. To select multiple names, hold down the **Ctrl** key while you click the names.
2. To add the names for the action, click the **Add** button. Primavera Unifier displays the names at the bottom of the window.
3. Click **OK**.

**To remove a user or group**

If you change your mind, you can remove a name from the action as follows:

1. At the bottom of the window, select the user or group you want to remove. To select multiple names, hold down the **Ctrl** key while you click the names.
2. Click the **Remove** button. Primavera Unifier removes the names from the bottom of the window.
3. Click **OK**.

**To view a user’s profile**

To view a user’s profile, select the name and click the **View Profile** button. Primavera Unifier displays the View User Profile window, showing work information for the user.

**To see a list of group members**

To see a list of the members in a group, select the name of the group and click the **Members** button. Primavera Unifier displays the Member List window.
To remove a user from the list for this action, deselect the checkbox beside the name.
THE FIND FEATURE IN PICKERS

Most pickers include a **Find** feature with which you can locate specific objects (codes, assets, business processes, users, shells, etc.). When you use this Find feature, Primavera Unifier narrows the list of items shown on the picker to match the find criteria you specified. For pickers with extensive lists, this can make completing the business process form much quicker. For most pickers, the Find feature is straightforward and operates in the same way.

The Find window shows fields from the picker, which you can use to narrow the list of items you see on the picker. Many fields will show an **operator**, such as “contains” or “equals,” which you can use to specify more precisely which items you want to see on the picker.

Pickers that include WBS codes display information generated from a sheet (the cost sheet or an SOV) and use another type of find that searches on the columns shown on the picker. See the procedure below.

**To specify search criteria**

1. If the Find window displays an operator beside a field, choose the operator you want to use on the field, such as “equals,” “does not contain,” or “is empty”.

2. Enter the value the field should contain, or click a **Select** button and select the value from the list that appears.

3. Click **Search** (or press **Enter**).

Primavera Unifier dismisses the Find window and displays on the picker the items that met the search criteria you entered.

**Note:** If you choose to, you can cancel the search action by clicking **[Cancel Filter]** or the **x** icon in the upper-right corner of the Find window. Primavera Unifier will restore the picker list to its unfiltered state.
To find WBS codes in a WBS Picker, Commit Line Item Picker or SOV Picker

1. Open the picker.

2. Click the Find button on the toolbar. The Find window opens.

3. Complete the Find window:
   - **Column**: Choose a column name. This dropdown contains the names of the columns that are displayed on the picker, including the WBS code.
   - **Value**: Enter a value for which to search. You can enter a full or partial word, number or other value. (Do not enter a wildcard character for partial entries.) The format of your entry will depend on the type of value you are searching for. If you are searching for a WBS code, you can include the code separator if one is used (a dash).
   - **Search**: Choose Up or Down. For new searches, use Down. If a value is found, it will be selected on the picker. If you want to continue to search, you can choose to search up or down from the current selection.

4. Click Cancel to close the Find window.

About Workflows

The Primavera Unifier workflow engine routes a business process form through your company’s business protocols.

When you participate in a business process workflow, you are taking action on the form (for example, reviewing and approving an invoice, or responding to a request for information). Depending upon the workflow setup, you may choose the next recipient of the business process in the workflow, or this may be automatically selected for you. When you send the business process to the next step, it proceeds along the workflow and records each action taken at each step.

![Workflow Diagram](image)

In the workflow example above, the form is created and filled out, and then sent for review. The reviewer has the option of sending the form for revision (after which, it is resubmitted to the reviewer), or sending it on for approval. The approver may send the form back for further clarification or revisions, may reject the form, or may approve the form. A rejection or approval status essentially ends the workflow. At the approval or rejection step, the business process is considered to be in a “terminal” status, and this status cannot be changed; however, comments and certain edits can still be made to the record. From a terminal status, the business process proceeds to the End step.
Note: A “terminal” status differs from a “terminated” status. A business process is at a terminal status when it reaches the final step (not the End step) in the workflow. A business process with a terminated status was stopped at some point before it reached the final step in the process.

Auto-Population And Reverse Auto-Population For Business Processes

Primavera Unifier supports auto-population and reverse auto-population on fields that have been set up to support these functions in Primavera uDesigner.
AUTO-Population For Business Process Fields

Using Primavera uDesigner’s auto-population feature, you can automatically populate fields on a form or line item at the time the form/line item is created. Auto-population can occur on business processes that are in the same shell, or across shells. Using auto-population means that you do not have to enter data in every field in a form. For example, this feature could automatically fill in a “Plant Location” field from an attribute form.

For another example, the date field on a time sheet could be set up to default to the server date and time so that you do not need to use a date picker. Or, a field could be set up to automatically display a title or other text that you would normally need to fill in on a frequent basis.

In addition, auto-population can be used with the Primavera Unifier portal. When a user logs into the portal to submit a form, such as a work order, the user’s information, such as his/her location and department, can be automatically populated on the work order. Or, when an employee “move” request is created, the current location of the employee can be auto-populated onto the move request form.

Fields on a form can be auto-populated from the following sources:

- Fields on an attribute form for managers (except a code-based configurable manager)
- Fields on another business process form or line item
- Fields on a user attribute form (via a user data picker)
- Shell attribute forms
- Fields from an upper form (to fields on a detail form)
- Fields on single-record BPs at the company, shell, or standard project level
- Fields on an SOV (for a payment application BP)
- Fields from document properties of a line item attachment
- The total value from a line-item numeric field (can populate a field on an upper form; becomes a read-only field)
- A constant value that was specified for a field when the form was created in Primavera uDesigner
REVERSE AUTO-POPULATION FOR BUSINESS PROCESSES

Some data elements on forms can be updated using “reverse auto-population.” These data elements are specified in Primavera uDesigner when the form is designed. Reverse auto-population means that some values can be automatically updated when other values are modified in a business process form.

Note: Reverse auto-population does not occur for projects and shells with View-Only or Inactive status.

Note: Reverse auto-population is not supported for single-record business processes, except in the case of BPs existing under child shells, which can reverse auto-populate to single-record BPs under any parent shell in the shell hierarchy.

Reverse Auto-Population in Auto-Created Business Processes

A business process can be designed to update the record or line item that auto-created it. For example, a Meeting Minutes business process auto-creates Action Items business processes from line items. If you update the Meeting Minutes business process line item, the Action Item business process can be updated via reverse auto-population.

In another case, if a business process auto-creates a new line item for an existing record, that line item can be updated with information from subsequent steps in the workflow.

Business cases that might use reverse auto-population:

- A work order could reference the line items on a preventive maintenance business process. Certain updates in the work order could be reverse auto-populated onto the line items of the preventive maintenance business process. For example, a machine might have had preventive maintenance at 1,800 hours of operation and need it again at 3,600 hours of operation.
- Changes to the detail form in a business process under a child shell could result in changes to the upper form of a single record non-workflow business process under any parent shell in the shell hierarchy.
- Lease payment requests could be auto-created from a lease business process. An approved payment request could reverse auto-populate the lease BP’s line item status to “approved.”
- A move order business process could reference an asset record. Updates on the move order could be reverse auto-populated onto the asset record.
- An office move order business process could reference a user attribute form. Once the move is complete, the user’s new location could be updated on the attribute form. (This kind of reverse auto-population is normally triggered when you choose a user from a data picker, rather than when a business process is auto-created.)
BUSINESS PROCESS LOGS AND MASTER LOGS

Business process records are stored in logs, accessible through the Navigator. You can think of logs as filing cabinets, with each drawer storing the records of a specific BP.

Each time you fill out a BP form, you are creating a new record in Primavera Unifier. You can access existing records from these logs or create new business process records of that type. By default, all records in which you were involved (created by, sent to, or copied to you) will be available for you to view and open from the BP logs. If you have additional permissions, you may also be able to view all project or shell or company BP records created in those logs.

Business processes can be project and shell level or company level. Project- and shell-level business process records contain information that pertains to the specific project or shell. These records may roll up information to the project or shell cost sheet, Document Manager, etc. Company-level business process records are used for information that is not specific to any particular project or shell, for example, a company-wide approved vendor list, a blanket purchase order that can be used for general expenses, a cost BP that rolls up to a company accounts sheet, or general meeting minutes.

**Note:** Remember that all BPs require view, modify, or create permissions to access and use them. Contact your project or shell or company administrator about permission settings for BPs that you need to access.

**Note:** You can also access a business process from your Tasks log. For more information, See "View the tasks assigned to you" on page 192.
ABOUT BUSINESS PROCESS LOGS

During BP setup, the administrator determines in which log a BP will be stored. You navigate to these logs by choosing the appropriate node in the Navigator. The following section describes how to access business process logs, from which you can view or create BP records.

Note: Primavera Unifier's Configurable User Mode Navigator feature allows your company administrator to configure the Navigator to display nodes that are different from those that are described here. For example, instead of project or shell Logs, your BP node might be labeled My Business Processes, or there may be different nodes for Cost BPs, Document BPs, etc. Your company administrator can provide information about these nodes.

The default BP logs are:

Project logs: Most project-related business process records are stored under the Project Logs node, which lists the logs for each BP. These can be of any BP type. Each business process will have its own node. That is, a business process used as a base commit will have one node (log) under which all records for that BP are stored. BPs like these are known as multi-record instances, which means that each BP can have any number of individual records (that is, individual forms). These can be workflow or non-workflow.

Shell logs: Most shell-related business process records are stored under the Shell Logs node, which lists the logs for each BP. Shells are listed in the Shell log in a hierarchy, from the main shell to the various subshells. BPs are listed in the Shell log in the same way they are listed in the Project log.

Company logs: Similar to project or shell logs but used for company-level business processes and located in the company workspace.

Data Manager: Similar to project or shell or Company logs, this node is a collection of individual BP logs. Data Manager can be for project- or shell-level BPs (located in the project or shell) or company BPs (in the company workspace). These BPs are often used for any type of miscellaneous information, for example, equipment specifications and maintenance information, a vendor database, or a company-level blanket-PO type BP. Each form has its own log containing individual records of that form. Like Project/Shell or Company logs, these BPs can have multiple records and can be workflow or non-workflow.

Project/Shell Information > General: This log is used only for one type of BP: line-item or simple type business processes that are single-record instance, which means that they are used to create only one record per BP per project or shell. They are useful for project- or shell-specific information that only needs to be documented on a single form. An example is a BP for general project or shell data and descriptions. These BPs do not have a workflow.

Fields on a business process in a child shell can be setup to auto-populate from the upper form of a single-record non-workflow business process under any parent shell and attribute form of the current or parent shell.

If you are an Editor on a single-record business process, you can open and edit that record, per your view access permission (View User Records, View Company Records, or View All Records). You must have at least one of these permissions to be able to view the record in the log to access it to edit.

General (in the company workspace): Similar to the project- or shell-level General log but for company-level, single-record BPs.
**Master Logs**: Located under the Home tab. Master Logs allow you to access all or a subset of business process records of the same type, in a single log that spans multiple projects or shells.
BUSINESS PROCESS LOGS THAT USE ADVANCED LOGS

Advanced logs show specified navigation for business processes in a log. The navigation can display in any type of business process log. The navigation is the result of the way that the advanced log that was configured for the business process type in Primavera uDesigner.

Note: If an advanced log is configured for a business process, the advanced log will open by default. If you find that you want to use the standard log format instead, have your Administrator remove the advanced log from the business process design in Primavera uDesigner.

The following illustration shows an example of a business process log that includes navigation on the left side of the log.

In this example, the configured hierarchy is based on asset name associated with the work order, and then on the business process status.
ACCESSING BUSINESS PROCESS LOGS AND RECORDS

The following procedures discuss how to locate business process logs and access BP records.

**To access project- or shell-level business processes**

1. Open a project or shell.
2. Navigate to one of the project- or shell-level BP logs:
   - **Data Manager**: Expand the Data Manager node to view the individual BP logs.
   - **Project/Shell Logs**: Expand the Project/Shell Logs node to view the individual BP logs.
   - **Information > General**: Click General to view the list of single-record business process records.

**To access company-level business processes**

1. Go to the **Company Workspace** tab and click **Company Workspace** in the left Navigator.
2. Navigate to one of the company-level BP logs:
   - **Data Manager**: Expand the Data Manager node to view the individual BP logs.
   - **Company logs**: Expand the Company Logs node to view the individual BP logs.
   - **General**: Click **General** to view the list of records.
ACCESSING BUSINESS PROCESS RECORDS FROM A

MASTER LOG

Master Logs list all business process types at the project or shell level in separate nodes for each type. This includes workflow, non-workflow, and multiple record business processes. Company-level and single-record business processes are not listed in Master Logs.

If you are an active member of a project, shell, or sub-shell, and you have permissions, you can access project or shell business process records from a Master Log. The Master Logs are located under the Home tab. The Master Log allows you to access all of or a subset of business process records of the same type, in a single log that spans multiple projects of shells. Also, you can create and use saved searches in the Master Logs.

Business processes are listed under the Master Logs node by business process type. The Master Logs node can be renamed by your Administrator, and access to the node depends on permissions.

Depending on permissions, you can perform these actions on business process records listed in a Master Log:

- Create a new record
- Edit an existing record
- Perform bulk edits on records

You can also save searches of business process records in the Master Logs as needed.

A business case example for the use of the Master Logs is a dispatcher who is responsible for translating service requests into work orders. This dispatcher could have Work Orders created for different buildings (represented as shells in Primavera Unifier) over different regions. A Work Order Master Log to which the dispatcher has access permission allows him to create and edit Work Order records for any building shell from a single location in Primavera Unifier, rather than drilling into each Building shell to access the records.

Another possible business case example is a regional Lease Manager who must access all of the active leases in the system that have Lease Amounts > $50000 per year. The Master Logs allow the Lease Manager to access all Lease business process records based on search criteria and save the search criteria. If you do not have permissions to view any of the business process types listed under the Master Logs node, then you will not see the Master Logs node listed under the Home tab.

**Note:** If you do not have permissions to view any of the business process types listed under the Master Logs node, then you will not see the Master Logs node listed under the Home tab.

**To access Master Logs**

1. Go to the Home tab.
2. In the Navigator, expand the Master Logs node.
3. Click the name of the Master Log you want to access.
SEARCHING FOR BUSINESS PROCESS RECORDS AND LINE ITEMS

If there are many records listed in a business process log, you may need to search for the one you are looking for. You search each log individually to look for a specific record.

To search a log for a particular record

1. Select a business process log in the Navigator.
2. Click the Find button.
3. If designed to do so, search fields can include line item fields in addition to upper form fields. Enter the search criteria. Below is an example of a Find window:

![Find window example]

You can vary the operators you use in a search (=,<,>, range, etc.) by clicking the operator link and selecting a new operator.

4. Click Search (or press Enter).
Primavera Unifier displays the business process records that met the search criteria you entered.

If you choose to, you can cancel the filtering action by clicking [Cancel Filter] or the x icon in the upper-right corner of the window. Primavera Unifier will restore the list of BP records to its unfiltered state.

5. Close the Find window when you are finished searching records.

To sort records in a log

1. In the Find window, for the Record Set equals field, select:
   • Created by Me: Lists project or shell records that you created.
   • Received by Me: Lists tasks assigned to you (option available for workflow business process records).
• **Created and Received by Me**: Lists project or shell records you created and tasks assigned to you (option available for workflow business process records).

• **All Company Records**: Lists all records involving your company, whether you were involved or not.

• `<blank>`: Lists all project or shell records to which you have permissions.

2 For workflow business process records, in the **Workflow Status equals** field, select:

• **In Progress**: Lists records that are currently in progress state. These records can be assigned to you, or to other users.

• **In Progress and Currently assigned to Me**: Lists records that are in progress, assigned to you, and have not reached a terminal status (option available for workflow business process records only).

• `<blank>`: Lists records (in progress, as well as closed) filtered by the selection made in the **Record Set equals** field.

**To search for a particular line item**

1 If Find is enabled in the line-item log, click **Find**. If you have tabs implemented in the line-item log, each tab will have its own Find (a separate search for each tab).

2 Enter the search criteria. You can vary the operators you use in a search (=,<,>, range, etc.) by clicking the operator link and selecting a new operator.

3 Click **Search**. Search results are listed in the log.

4 Move the Find window to view the search results. If you close the Find window, the search results are cleared. The Find window is a floating window.

5 You can change the search criteria and click **Search** to perform a new search.

6 Close the Find window when you are finished searching line items.
SAVE BUSINESS PROCESS LOG SEARCHES

You can save searches for reuse in business process logs. The searches that you save are available in the logs for you to reuse, and to be used by other users as well if you mark your saved searches as public. By default, the saved searches you create are specific to you, and cannot be accessed by other users. The saved searches that you create are available for your use in all business process logs.

When you mark a saved search as public, that search can be used by other users in all business process logs to which those users have permissions. You can add searches created by other users (and marked as public) to your list of saved searches. Users with View permission on a business process can view the existing saved searches.

To create a saved search

1. Navigate to a business process log.
2. Choose View > Find.
3. Enter the search criteria.
4. Enter a saved search name.
5. Click Save.

To edit saved searches

1. Navigate to a business process log.
2. Choose Edit > Saved Searches. The Manage Saved Searches window opens.

<table>
<thead>
<tr>
<th>Functionality</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order</td>
<td>Change the order of saved searches by clicking in an Order field and entering a positive number.</td>
</tr>
<tr>
<td>Name</td>
<td>Change the name of a saved search by clicking on a Name and entering a new name. You can rename only the saved searches that you have created.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description for your saved search (up to 150 characters). You can add a description only for saved searches you have created.</td>
</tr>
<tr>
<td>Default</td>
<td>Select the checkbox to make a saved search your default search. This is the search that will display by default in the Filtered by drop-down menu.</td>
</tr>
<tr>
<td>Public</td>
<td>Select the checkbox to designate a saved search as public and make it available to other users. You can deselect the checkbox to make the saved search private. By default, the saved searches you create are private, and you must mark them as public to make them available to other users.</td>
</tr>
<tr>
<td>Owner</td>
<td>Lists the owner of the saved search, which is usually the creator.</td>
</tr>
<tr>
<td>Save</td>
<td>Click to save your changes. All changes occur only when you save them.</td>
</tr>
</tbody>
</table>
| Public Searches | Click to access public saved searches created by other users.  
  • Select one or more searches and click Select to add the search to your saved search list. You cannot modify saved searches created by other users.  
  • Select one or more searches and click Copy. This copies the search so you can modify it to create a new search. The new search is initially marked as private, and you are designated as the owner. |
### Functionality and Description

<table>
<thead>
<tr>
<th>Functionality</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove</td>
<td>Select a search and click Remove to delete a saved search. You can delete only saved searches that you have created.</td>
</tr>
<tr>
<td>Move Up / Move Down</td>
<td>Select a saved search and click Move Up or Move down to reorder the searches in your list.</td>
</tr>
<tr>
<td>Update Order</td>
<td>Click to preview the revised order of the saved searches. The new ordering is saved when you click the Save button.</td>
</tr>
<tr>
<td>Close Window</td>
<td>Click to close the Managed Saved Searches window.</td>
</tr>
</tbody>
</table>

3 Click **Save**.

**To use a saved search**

You can use saved searches created by you or other users in business process logs.

1. Navigate to a business process log.
2. Select a saved search from the **Filtered by** drop-down menu in the toolbar.
3. You can cancel the filtering by clicking **Cancel Filter**. The log view is refreshed to list all records after you cancel a filter.
Tasks that are assigned to you are listed in your Tasks logs. Task logs are located in projects and shells, in the company workspace, and in one central Tasks log for all company and project or shell business processes, which can be accessed from the Primavera Unifier home page.

The Tasks logs display business process-related tasks in which you are being requested to participate. Tasks for View-Only and Inactive projects or shells are not listed in the Tasks log. Tasks that are late appear in red on the log.

The following tasks may appear in your Tasks logs:

- You are part of a business process workflow and are requested or required to take some sort of action.
- You have been invited to join a discussion group by another user who is requesting assistance with drafting comments or markups on a BP. These are indicated as being sent for “Discussion” in the Tasks log.
- You are designated as the Initiation step assignee for an auto-created business process.
- You are an editor on a business process, which means you are a user or member of a group that can edit a business process without being granted explicit record-level permission.

This allows users other than the assignee to edit the business process record. Editors can be added to these workflow or non-workflow business process types:

- Line Item
- Cost (all types, including Lease and Line Item with Multiple Codes)
- Document
- Simple
- RFB
- Text

If you are an Editor on a business process, you can open and edit any record that you can see listed in the log, per your view access permission (View User Records, View Company Records, or View All Records). You must have at least one of these permissions to be able to view the record in the log to access it to edit.

- Editors cannot edit a workflow record until the task assignee accepts the task, and saves the draft.
- Edits performed by editors are not audited.

Edits performed on the end step of a workflow business process affect the record directly, as no draft exists.

**Note:** Last One to Save Over-Writes Other Edits If multiple editors and the assignee are editing the business process at the same time, the data saved by the last edit will over-write all previous edits. For example, if User 1 changes an amount field from 15,000 to 23,000 and saves the change, and User 2 changes a different field, but does not touch the amount field, when User 2 saves his/her change, Primavera Unifier will commit User 2’s edits; and the amount field will show 15,000 rather than 23,000.

For information about responding to your tasks, See “Completing Tasks in Primavera Unifier” on page 291 and See “Completing Tasks via Email” on page 297.
VIEW THE TASKS ASSIGNED TO YOU

To view tasks assigned to you

Navigate to a Tasks log by doing one of the following:

- Go to the **Home** tab and click **Tasks** in the left Navigator. This is the central Tasks log that lists all of your tasks, both company level and for all projects or shells.
- Go to the **Home** tab and click the **Tasks** link listed under **Items Requiring Your Attention** on the home page.
- Open a project or shell, then click **Collaboration > Tasks** in the left Navigator. The Tasks log lists the tasks for that project or shell.
- Go to the Company Workspace tab and click **Collaboration > Tasks** in the left Navigator. The Tasks log lists tasks from company-level business processes.
**HIDE AND UNHIDE TASKS**

Your Tasks Log can become extensive from time to time, and you might want to focus or prioritize the log by hiding tasks that are not imminent. You can unhide any hidden task at any time.

**To hide tasks**

1. On the Tasks Log, highlight the task(s) you want to hide.
2. From the Edit menu, choose Hide.

**To unhide tasks**

1. Click the View menu and choose Hidden Tasks. Primavera Unifier lists the tasks that have been hidden from the Tasks Log.
2. Select the task(s) you want to unhide.
3. From the Edit menu, choose Unhide > Selected.

**To unhide all hidden tasks**

From the Edit menu, choose Unhide > All.

**Search The Log For A Task Or Tasks**

**To search the log**

1. On your Tasks log, click the Find button. The Find window opens.
   
The Find window shows fields that you can use to narrow the list of tasks you see on the log. The fields show an operator, such as “contains” or “equals,” which you can use to specify more precisely which tasks you want to see on the list. In the example Find window above, you could narrow the list of tasks to show only invoices that have been sent to an approval step in the workflow.
   
   Most of the fields show an “equals” operator which you cannot change; however, those fields that show an underlined operator can be changed.

2. In those fields with operators you cannot change, enter the value the field should contain, or click the Select button and select the value from the list that appears.

3. In those fields that show an underlined operator, first choose the operator you want to use on the field, such as “equals,” “does not contain,” or “is empty”. Then enter the value the field should contain.

4. To save this search for future use, enter a name for the search in the Save As field and click Save.

5. To filter the Tasks log, click Search (or press Enter).
   
   Primavera Unifier displays all the tasks that met the search criteria you entered.

   If you choose to, you can cancel the filtering action by clicking [Cancel Filter] above the task list. Primavera Unifier will restore the list of tasks to its unfiltered state.

6. Once you have filtered the list, select the task(s) and use the Bulk Actions > With Preview option to quickly open, accept, and complete the task. (See “Open and accept a task”.)
USE A SAVED SEARCH TO FILTER YOUR TASKS LOG

To use a saved search to filter your Tasks log
Open your Tasks Log, click the Filtered By drop-down, and choose the search you want to use. Primavera Unifier will filter the Tasks log to show only those records that match the search criteria.
VIEW AND EDIT A SAVED SEARCH

Once you have saved a search for your Tasks log, you can change its name or description and certain other attributes using the Manage Saved Searches window.

To view and edit a saved search

From your Tasks log, click the **Edit** menu and choose **Saved Searches**. The Manage Saved Searches window opens. This window is almost identical to the Manage Saved Searches window available for business process logs, except that the “Default” option is not available for Tasks log searches.
FILTER THE LIST OF TASKS FOR BULK ACTIONS

You can use the Find feature to limit the records that are listed on your Tasks log. This can be convenient for streamlining your work for tasks, such as quickly approving multiple cost transaction records. Using the Find feature, you can separate those records you can quickly dispatch from those that need to be reviewed in detail. Once you have created the search criteria that filters the list of tasks, you can save that search for future use.

To filter your list of tasks

1. Use the instructions under See "Search the log for a task or tasks" on page 193.

2. Once you have filtered the list, use the Bulk Actions > With Preview option to quickly open, accept, and complete the task.
CHANGE THE TASKS LOG DISPLAY

Tasks logs can be crowded with information and often need sorting and column adjustments to be easily readable. Once you make these adjustment settings, Primavera Unifier will remember them the next time you log in (from any machine).

Any display adjustments you make to the Company Workspace Tasks log will be reflected on the Shell and Project Tasks logs and vice versa. However, the Tasks log on your Home tab is independent of the other logs and will retain its own settings.

You can adjust column widths on the display and sort the data in the columns.

To adjust column widths

1. Hover your cursor over the column border.

2. When the cursor changes to a bi-directional arrow, drag the border in either direction to the width you want.

3. Release the mouse button.

4. Repeat steps 1 to 3 for any other column you want to adjust.

Primavera Unifier will remember the column widths you last specified and will display the Tasks Log with these widths whenever you log in to Primavera Unifier.

To sort column data

You can sort the data alphanumerically (ascending or descending) on the log by any column. To sort the data, click a column heading.

The first time you click the heading, Primavera Unifier will sort the data alphanumerically in ascending order (A to Z). To sort the data in descending order, click the column heading again.

Primavera Unifier will remember the sort order you last specified and will display the Tasks Log in this order whenever you log in to Primavera Unifier.
ACCESSING A BUSINESS PROCESS FROM AN EXTERNAL SYSTEM

Primavera Unifier provides a data element for business processes that can display a URL for access to Primavera Unifier from an external system. If the business process contains this URL field, you can open a view-only copy of the record from that external system.

For example, you might have notifications from Primavera Unifier that are sent to email programs, such as Microsoft Outlook or Yahoo Mail, outside of Primavera Unifier. From that email program, you could open a view-only copy of the business process.

Or, you might have an approval process that resides outside of Primavera Unifier. At a certain point in the workflow, the business process record data could be sent from Primavera Unifier to that external approval process. From that external system, you could open a view-only copy of the business process record.

Note: If this business process created records before this URL field was added to the form, those records will not show data in the URL field. Only new records will show data in the URL field.

Any business process designed to be opened from an external system must be available on the Master Log.

To open a business process from an external system

You must be an active member of the project, shell, or sub-shell, and have at least view permission to the Master Log that contains the business process record you want to view.

Use the URL to access Primavera Unifier. This URL will open the Primavera Unifier login window. Once you are logged in, Primavera Unifier will display the business process record in view-only mode.

Note: If Primavera Unifier has been configured to log in users using single sign-on (SSO), the login window will not appear.

Depending on what permissions you have, you can take the following actions from this view-only copy of the record:

- Terminate the business process
- Print the business process
- Send email
- Transfer ownership
- View reference records
- View the audit log
- View record attachments, general comments, linked records, and linked uMail
- Click line item tabs and open the line items in grid view
- Use the Find feature to locate line items
- Use any hyperlinked field, such as a picker, an image, or a URL, or the workflow progress link
- View the assignees and cc’d users on the step
VIEWING MESSAGES (CC'D TASKS)

If someone copies you (cc) on a task, it is not a task for you, but information only and called a message. These business process record copies are listed in your Messages log. You will usually be notified by e-mail when you have a new a message. If you receive an e-mail notification, click on the hyperlink at the bottom of the e-mail. You will be directed to the Primavera Unifier Login screen and, once you log in, to the project or shell or company Messages log.

**Note:** Messages for View-Only projects or shells are listed in the Messages log, but you cannot add general comments to these messages.

Messages are view-only snapshots of the form at a particular step and remain available for viewing until the BP is sent to the next step. Messages received for an end step will remain available in the log.

**To view messages**

Navigate to the Messages log by doing one of the following:

- Click the **Messages** link listed under Items Requiring Your Attention from your User home page. The Messages log lists all messages.
- In the Navigator, open a project or shell or company and navigate to **Collaboration > Messages**.
CREATING BUSINESS PROCESSES

Business processes may be created and accessed from any business process log. Users must have the proper permissions to create new BP records.

New business process records can be created in the following ways:

- Manually create a new BP record, starting with a blank form.
- Copy an existing BP record in the same log. The fields will be populated with the original record entries, which can be edited as necessary.
- Auto-create a record from another record at a specified step (S-Step) in a workflow.
- Auto-create a record when certain conditions are met or at a specified frequency.
- Create a business process from a Master Log.
- Create a business process from within the Document Manager, selecting the documents or folders to include as attachments.
- Create a business process from a template.
- Auto-create a record using the Scope Management feature of the Schedule Manager.

Before you begin

- Be sure that you have the proper permission settings. All Primavera Unifier functions are controlled by fully configurable permission settings, including creating business processes. Contact your project or shell or company administrator regarding permission settings.
- A business process (form and workflow) must be imported, configured, and set up by an administrator before it can be used.
ACCESSING THE CUSTOM BUSINESS PROCESS HELP

PDF FILE

Your company or your project or shell administrator may provide a custom Help file to give you information about a specific business process. This file is provided as a PDF file, which can be read with Adobe Reader. If a custom help file is available, it will be listed under the Help menu for the business process log or form.

Access The Custom Help File

To access the business process help PDF file

1. Navigate to the BP log, or open a BP record.

2. Click the Help menu. If a BP help file has been added, it will be listed in the Help menu (appears as <BP name> Help).

3. Click [BP name] Help. You can choose to open the file or save it to your local drive first.
MANUALLY CREATING BUSINESS PROCESS RECORDS

The following are general procedures for creating business process records from the BP logs.
MANUALLY CREATE A NEW BUSINESS PROCESS RECORD FROM A BP LOG

This is a general procedure that can be used to create a record from any business process log.

To create a new business process record from a business process log

1. Navigate to the business process log from which you want to create the record.
2. Click the New button, or click the drop-down arrow next to the New button and choose from the list of business processes.

   The Select Workflow window opens.

   Note: Primavera Unifier will not display the Select Workflow window if:
   a) this is a non-workflow business process, or
   b) there is only one workflow schema you can choose for this business process

3. Choose the workflow schema to use and click OK.

   The business process form opens. To complete the record, use the instructions under See "Completing the Forms" on page 231.
MANUALLY CREATE A BUSINESS PROCESS RECORD FROM A MASTER LOG

If you have permission to create records, you can create business process records from the Master Log in any project or shell. Also, you can modify or bulk edit business processes in the Master log. If View Map is enabled, you can select one or more records across projects or shells to view on a map.

**Note:** Import Template, Export Template, and Permissions are not supported actions on business processes in Master Logs. Auto-population and reverse auto-population are supported for business process records that are created or edited in the Master Logs.

There are specific conditions for creating workflow and non-workflow records in the Master Logs. For workflow business process records:

- Business process must have an Active setup in the selected project or shell
- Chosen project or shell controls the list of enabled workflow setups
- You must be an assignee on the Create step of the business process within the selected project or shell
- If you save the record during its creation, instead of sending it, the record is listed in the Home Drafts folder, is not yet listed in the Master Log for the business process
- After the record is created, it is listed in both the business process log for the project or shell and well as the business process Master Log

Creation conditions for non-workflow business process records:

- Business process must have an Active setup in the selected project or shell
- You must be on the Creator list for the business process in the select project or shell
- After the record is created, it is listed in both the business process log for the project or shell and well as the business process Master Log

**To create a business process record from a Master Log**

1. Navigate to a Master Log.
2. Choose **New > Create in Project** or **New > Create in Shell**.
3. Select the project or shell in which to create the new business process record. The project or shells listed are Active and are those in which you are a member.
4. To complete the record, use the instructions under See “Completing the Forms” on page 231.
CREATE A BUSINESS PROCESS RECORD BY COPYING AN EXISTING RECORD

You can copy an existing business process record to create another business process record of the same type.

The original data in all data entry fields, including line items (if applicable), will be copied. For most business processes, you will have the option to copy attachments to the new form. Other attached information, such as general comments, linked records, and linked uMails, will not be copied.

**Note:** The copied record will reflect the data found in the original record. Auto-populated fields will not be refreshed or recalculated.

In addition, you can restrict the line items to be copied and specify other copy options by using the Advanced copy option. The Advanced copy offers these options:

- Copy specific (rather than all) line items
- Include or exclude attachments
- Retain or remove references to records auto-created from an upper form
- Retain or remove references to records auto-created from line items (from all tabs)
- Include linked records

**Note:** These options are not available for Payment Applications.

**Note:** Business processes that have been auto-created and are currently in the Initiation step (prior to the Create step in the workflow) cannot be copied. You cannot copy these business processes until the record has been sent or is in a “finish edit” status.

**To create a new business process record by copying another**

1. Navigate to a business process log and select the BP record to copy.
2. Click the Copy button and choose:
   - With Attachments to copy all file attachments from the original record to the new record. This includes attachments to line items.
   - Without Attachments to create a new record without file attachments.
   The Select Workflow window opens.

**Note:** Primavera Unifier will not display the Select Workflow window if:

a) this is a non-workflow business process, or
b) there is only one workflow schema you can choose for this business process

3. Choose the workflow schema to use and click OK.
The business process form opens. To complete the record, use the instructions under See “Completing the Forms” on page 231.
RESTRICT LINE ITEMS USING THE ADVANCED COPY OPTION

Using the Advanced Copy option, you can copy specific (rather than all) line items, as well as include or exclude attachments, include linked records, and retain or remove references to auto-created records or line items. These copy options are set up by your administrator and will appear in a list you can choose from in this procedure.

If no copy options have been created, the Advanced menu option will be disabled.

To restrict line items using the Advanced copy option

1. Navigate to a business process log and select the BP record you want to copy.
2. Click the Copy button and choose Advanced. The Select a record copy option window opens, showing a list of the copy option setups that were created by your administrator.

Note: If your administrator has set up only a single copy option, you will not see the Select a record copy option window. Primavera Unifier will use the single copy option it finds to copy the record.

3. Select the copy option you want to use and click OK.

Primavera Unifier copies the record using the line item restrictions and other options from the copy setup you chose.
COPY BUSINESS PROCESS RECORDS IN A MASTER LOG

You can copy a business process record in a Master Log. Copy from the Master Log creates the new record in the same shell or project as the source record.

To copy business process records in a Master Log

1. Navigate to a Master Log.
2. Select a business process record.
3. Choose File > Copy.
4. Edit the business process record and Save the record.

Auto-Creating Records

There are three ways of auto-creation:

• Spawning a record at a particular point in a workflow (S-Step)
• Auto-creating a record or line item when it reaches a particular condition or frequency (I-Step)
• Using a template that is scheduled to auto-create records
AUTO-CREATE A BUSINESS PROCESS RECORD FROM A WORKFLOW STEP (S-STEP)

Primavera uDesigner users can design a business process form that automatically creates a new Primavera Unifier BP record after reaching a designated status in a workflow (for example, approved). The user who owns the original record becomes the owner of the auto-created record. After being created, the new record is sent automatically to the next step in the workflow if it is a workflow business process. Non-workflow business process records will reside in the log.

**Note:** Business processes are not auto-created in projects or shells that have the View-Only or Inactive status.

The original record can be set up to automatically populate upper form (header) information on the new record, provided the data elements of the upper form fields are the same on both records. That is, if a Description field using the same data element appears on both records, the text in the original record can be entered automatically into the new record.

Auto-create A Business Process Record Or Line Item Based On Conditions Or Frequency

Primavera uDesigner users can design a form that automatically creates a new record, line item, or planning item if certain criteria are met. The criteria can be:

- A **condition**, such as a dollar amount
- A **frequency**, such as a daily or weekly time frame

**Note:** Line items cannot be created with a frequency trigger.

- Both a **condition** and a **frequency**

When the business process, planning item, or line item reaches the condition or frequency trigger(s), the form will automatically create a new record and send it to an initiation step (I Step). These forms contain a "creator" field to activate the auto-creation, either automatically, or manually. If you have Modify Ownership permission on the source record, you can auto-create new records or line items. You can also override conditional auto-creation and immediately invoke the auto-creation manually if necessary.

**Note:** If the line items have been grouped (as part of the administrator's business process setup), you can manually invoke the auto-creation; however, only those line items in a status of "pending creation" will be grouped.
Bypassing the I Step

During business process setup in Primavera Unifier, the administrator can set up the auto-created workflow BP to skip the initiation step and send the record directly into the workflow, where it normally arrives at the first step after the Create step (or the first step in a conditional routing). For a workflow BP, the administrator specifies the schema, the step in the workflow that the record should use as its first step, the workflow duration, and the name of the person or group who will be the owner of the auto-created record. When the record is created, data will roll up to manager sheets at the appropriate status; however, if Primavera Unifier encounters errors or invalid data, the record will remain at the Create step, and roll-ups will not occur until the user resolves the errors.

For a non-workflow BP, the administrator can set up an auto-created record to skip the initiation step. In this case, the non-workflow BP will be created and will appear in the users' BP logs in either an “edit” or “finish edit” mode. If it appears in an “edit” mode, the user will have to open the record and add or correct information on the form. If it appears in a “finish edit” mode, the record is considered complete, and data will roll up to manager sheets.

Note: Business processes are not auto-created in projects or shells that have the view-only or inactive status.

Your administrator sets up the auto-creation by specifying:

- The name of the person or group who will be the owner of the auto-created record
- (For workflow BPs) The workflow schema to use
- (For workflow BPs) Which step in the workflow the record should use as its first step
- (For workflow BPs) The workflow duration
- The criteria that will trigger the auto-creation
- Whether or not attachments to the record or line item will be included when the record is auto-created
- Whether or not records that were linked to the creating record should also be linked to the newly created record, or to the new line item
- Whether or not the I Step should be bypassed when Primavera Unifier auto-creates a new record
- Whether or not the line items from line item tabs should be grouped

If Line Item Auto-creation Fails

If the line-item creation is auto-created with a condition-based query (that is, not manually), Primavera Unifier will send an e-mail notification to the business process owner. The e-mail will contain location information so that the recipient can see where the auto-creation originated and where it failed. Following are conditions under which line item creation can fail:

- The To field is empty. This is possible if the assignee becomes inactive after the schedule is created or if a group is empty.
- WBS code is invalid, which can happen if the WBS code becomes inactive after selecting in the template.
- The rules engine validation fails.
- For payment applications, the associated SOV is locked, either by the payment application record in routing, or by a change commit with a negative line item value.
**Note**: If the destination business process does not exist or has not been imported into Primavera Unifier, the location specified in the e-mail notification might be non-existent or incorrect.
BYPASSING THE INITIATION STEP (I-STEP)

During business process setup in Primavera Unifier, the administrator can set up the auto-created workflow BP to skip the initiation step and send the record directly into the workflow, where it normally arrives at the first step after the Create step (or the first step in a conditional routing).

For a workflow BP, the administrator specifies the workflow schema to use, the step in the workflow that the record should use as its first step, the workflow duration, and the name of the person or group who will be the owner of the auto-created record. When the record is created, data will roll up to any applicable manager sheets (e.g., the cost sheet) at the appropriate status; however, if Primavera Unifier encounters errors or invalid data, the record will remain at the Create step, and roll-ups will not occur until the user resolves the errors.

For a non-workflow BP, the administrator can set up an auto-created record to skip the initiation step. In this case, the non-workflow BP will be created and will appear in the users’ BP logs in either an “edit” or “finish edit” mode. If it appears in an “edit” mode, the user will have to open the record and add or correct information on the form. If it appears in a “finish edit” mode, the record is considered complete, and data will roll up to any applicable manager sheets.
AUTO-CREATE A RECORD VIA A TEMPLATE

For information on this type of auto-creation, See "Schedule automatic business process record creation based on the template" on page 227.
EXAMPLES OF AUTO-CREATION

You can use Primavera Unifier’s auto-creation feature to manage events such as the following:

• **Line Items of Lease Business Process generating Payment Request BP records**: A lease business process with a pre-generated payment schedule can use this feature to generate Payment Request records at appropriate days in advance of the payment due date so that the record can be routed for approvals.

• **Preventive Maintenance BP line items generating Work Order BP records**: A Preventive Maintenance business process can be set up to create Work Orders for assets at periodic intervals depending on the service needs of the asset.

• **Create Action Items from Meeting Minutes**: Auto-creation feature can be used to create and assign tasks to different people creating a fully automated flow for routing of action items from meeting minutes records that have lines items. For example, each line item Action Item could auto-create a separate Action Item records from the meeting minutes record.

• **Create a planning item from a business process**: You can create a planning item from a business process when the business process, with its details (such as expense estimates, owners, etc.) has been approved.

• **Add a new line item to an existing record**: You can add a line item to an existing business process. For example, a submittal registry record could contain line items that auto-create separate submittal business process forms for each contractor on a project. In the course of work, you might realize that the original submittal registry record is missing a submittal for an architectural drawing. You could submit a new submittal business process form that would add the missing architectural drawing submittal to the original registry record.

**For Line Item Creation**

- You cannot create a line item on a record that is at a terminal or terminated status.
- If you create a line item on a non-workflow cost type business process, the cost amount(s) will roll up to the Cost Sheet.
- If you create a line item on a workflow cost type business process, the cost amount(s) will NOT roll up to the Cost Sheet.
RULES FOR CHECKING CONDITIONS FOR AUTO-CREATION

There are rules that govern when Primavera Unifier scheduler checks the conditions for auto-creation, and then if the conditions are met, auto-creates the BP.

Rule 1
The Company Administrator selected the Enable Auto creation checkbox for BP Creator when the auto-creation was set up in Primavera Unifier.

If the Enable Auto creation checkbox is checked, it implies system based auto-creation, and the BP Creator Select button is not displayed in User Mode.

For non-workflow BPs: The condition check occurs on Finish Edit. If condition met, creates record and shows the link for the auto-created BP. If no condition is specified auto-creates records and shows the link for the auto-created BP.

For workflow BPs: The condition check occurs on Send. If end step reached and Action Form is used on End Step, the condition check occurs on Save instead of Send. If condition met, creates record and shows the link for the auto-created BP. If no condition specified blindly creates records and shows the link for the auto-created BP.

If the Enable Auto creation checkbox is not checked, it implies manual creation.

For non-workflow BPs: The condition check does not occur on Finish Edit.

For workflow BPs: The condition check does not occur on Send.

BP Creator- Select button shown in User Mode so that the user can create the business process manually. If clicked, creates BP record without checking any condition, and creates record and shows the link.

Rule 2
Date Trigger Condition check: Are checks on the specified Date Data Element. Setting this up implies that condition checks are done on a date instead of Finish Edit/Send in case of Non workflow and Workflow respectively provided a link does not already exist next to BP creator element. If a link already exists, it will not create any new records for that BP Creator element in the chosen line item of the record.

Rule 3
Trigger Condition check based on frequency (Periodic): Are checks on frequency for BP Creator elements with Enable Auto creator checked. If specified, these are the only time condition checks are done. This overrides any other checks for date. This is the only method to create multiple records even if a link already exists and a record has already been creator for this BP Creator element. The link created using this will always point to last auto-created record.
**AUTO-CREATION IN OPERATION**

Upon auto-creation, the following are not copied to the auto-created business process from the source business process:

- Line item status
- Creator fields
- Hidden tab data

These elements are copied from the source business process to the auto-created business process on certain conditions:

- BP Pickers are not copied if the auto-creation occurs from a Project (Standard) to a shell and the BP Picker location is not defined or is no longer valid
- Configurable Manager codes and WBS codes are copied from the source business process to the auto-created business process if the codes are available in the destination shell.
- User/Group Picker values are copied only if they are available in the destination shell.
- Transaction currency field is copied if that currency is available in the destination shell.
SCHEDULE BUSINESS PROCESS AUTO-CREATION DYNAMICALLY

Auto-created business processes can be scheduled for creation from setups created by an administrator, or you can create them dynamically.

To create new business process records using auto-creation

1. Navigate to a business process log and open the source BP record to use for auto-creation.
2. Choose File > Auto-create.
3. Select the Enable Scheduled Runs checkbox.
4. Under Frequency, choose how often you want the auto-creation to occur: Daily, Weekly, Monthly, or Yearly.
5. Under Range of Recurrence, specify the date range during which the auto-creation should occur.
6. Click OK.

After the new record is auto-created, there is a link in the source record to the newly created record. Click this link to access the auto-created record. The link always accesses the last record created by the auto-creation.

Once you create a new workflow record, Primavera Unifier sends it to the assignees as an initiation task (I Step) that will appear on their Tasks log and the BP log to which the record belongs. If a new record is sent as an initiation task, users must accept the task to manually launch the record.

Once you create a new non-workflow record,Primavera Unifier sends it to the designated creators as an initiation task (I Step) that will appear on their Tasks log and the BP log to which the record belongs. Users must accept the task to view the record.

Note: If your administrator has set up these business processes to bypass the I Step, the new records will appear in Primavera Unifier at different workflow steps, or in different statuses. For information about this, See "Bypassing the Initiation step (I-Step)" on page 212.
STOP THE CREATION

To stop the creation of new auto-created business process records

1. Navigate to a business process log and select the source record or records to use for auto-creation.
2. Choose File > Auto-create.
3. De-select the Enable Scheduled Auto creation checkbox.
4. Click OK.
CREATE BUSINESS PROCESS RECORDS OR LINE ITEMS
WITH MANUAL AUTO-CREATION

Note that, for line item creation, you cannot add a line item to a record in a terminal or terminated status.

To create a new business process record or line item with manual auto-creation

1. Open the record that will auto-create the new record or line item.
2. Click the Create button next to the creator field.
   The field will display the words “Pending Creation.”

Primavera Unifier immediately auto-creates the destination record or line item. The new, auto-created record or line item will show a link to the source record that created it. You can click this link to view the source record.

If you manually auto-create a line item, Primavera Unifier will validate the creation and tell you immediately if there are errors that caused the auto-creation to fail.

The Reset button
When you manually auto-create a new record or line item, the button beside the creator field changes from Create to Reset. You can use this Reset button to break the link from this (the source) record to the new record/line item so that you can auto-create another record or line item manually. When you click the Reset button, it changes back to a Create button.
IF THE SCHEDULED RECORD CREATION FAILS

If a scheduled BP creation fails, e-mail notification will be sent to the template owner (as long as the checkbox enabling the notification has been selected on the Schedule tab of the template Properties window). The e-mail will contain location information so that the recipient can see where the auto-creation originated and where it failed. Following are conditions under which scheduled record creation can fail:

- The **To** field is empty. This is possible if the assignee user becomes inactive after the schedule is created or if a group is empty.
- WBS code is invalid, which can happen if the WBS code becomes inactive after selecting in the template.
- If the rules engine validation fails.
- For payment applications, if the associated SOV is locked either by the payment application record in routing, or by a change commit with a negative line item value.

**Note:** If the destination business process does not exist or has not been imported into Primavera Unifier, the location specified in the e-mail notification might be non-existent or incorrect.
CREATING A BUSINESS PROCESS RECORD FROM WITHIN THE DOCUMENT MANAGER

If you have access to the Document Manager, you can create a business process directly from the Document Manager’s project or shell Documents node. In project or shell Documents, select the documents or folders to attach and click New > Business Process.
CREATING A BUSINESS PROCESS RECORD FROM A TEMPLATE

If you have created a business process template for a BP, you can manually create BP records by copying the template. (For instructions on creating a template, See "Creating Business Process Templates and Scheduling Business Process Creation" on page 223.)

Creating a BP record from a template is similar to copying an existing BP record. Any values in any of the form fields on the template (either manually entered or auto-populated) will be copied to the new record. Line items, file attachments, and attachments to line items will also be copied. Other attached information, such as general comments, linked records, and linked uMails, will not be copied to the new form.

To create a business process record from a business process template

1. Open a business process log.

2. In the log, click the File menu and choose Template. The [BP name] Template List window opens, which displays the list of templates created for the selected BP.

3. Select a template from the list and click Open. The BP form opens. Data is populated based on the template. You can modify the data or enter additional data.

Note: You can save the record by clicking the Save button, which saves a draft of the record but does not affect the template. When the BP is ready to move to the next step, click Send.
CREATING BUSINESS PROCESS TEMPLATES AND
SCHEDULING BUSINESS PROCESS CREATION

You can create templates for project- or shell-level and company-level workflow business processes. This allows:

- Easy creation of records for business processes that you use often or are recurring (for example, lease renewals or time sheets)
- Scheduling automatic creation of recurring BP records

This section discusses how to:

- Create and edit business process templates
- Schedule automatic business process record creation from the template

**Note:** When you create BP records from a BP template, any values in any of the form fields on the template (either manually entered or auto-populated) will be copied to the new record. Line items, file attachments, and attachments to line items will also be copied. Other attached information, such as general comments, linked records, and linked uMails, will not be copied to the new form.
CREATE A BUSINESS PROCESS TEMPLATE

You can create a template for any business process for which you have at least “view user records” permission.

To create a template

1. In User Mode, open to the log containing the business process for which you want to create the template.
2. In the Navigator, select the business process.
3. Click the File menu and choose Template. The Template List window for that business process opens. The window displays any templates that have been created for the selected BP.
4. Click the New button. The Properties window opens.
5. Use the information in the table below to fill in the General tab.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name for the new template.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description of what this template is used for.</td>
</tr>
<tr>
<td>Workflow</td>
<td>Select the workflow that should be used for the BPs that will use this template.</td>
</tr>
<tr>
<td>Refresh auto-populated and calculated fields on record creation</td>
<td>(This option will appear for simple type business processes only) Select this check box if the values in the fields that are auto-populated and calculated should be refreshed whenever a record is created from this template. If this simple type BP contains fields that are being auto-populated from the attribute form of the current or any parent shell in the hierarchy, or from a single-record business process in any parent shell in the hierarchy, you can refresh these values so that this new record contains the latest data.</td>
</tr>
<tr>
<td>Copy Linked Records</td>
<td>Select the check box if you want to copy any linked records whenever a record is created from this template.</td>
</tr>
</tbody>
</table>

Note: Although the Schedule tab is visible, it is disabled until you have changed the status to Complete. At this point, you can use this template to manually create BP records; however, if you want to schedule automatic creation, you must first change the template status to Complete.

6. Click OK.

Primavera Unifier adds the template to the Template List with a status of Draft and opens the form as it would in the create step of the workflow. This form will be used as the template.

7. Enter any information into the template form that you want to include in the records that you create from it.

8. You can add line items as needed. You can also add file attachments, which will be attached when a record is created from the template. This includes attachments to the record itself and attachments to line items.
You can also add linked records, linked uMail, and general comments to the template, but these will not be included in the records created from this template.

9 Click the **Save** button at the top of the form.

Primavera Unifier saves the template in Draft mode, and the window remains open. You can use the template at this point to manually create BP records; however, if you want to schedule automatic creation, you must first change the template status to Complete (see the following procedure).
CHANGE TEMPLATE STATUS (DRAFT AND COMPLETE)

Each template will either be in Draft mode or Complete mode. You can change the status of a template between the two statuses at any time. The template status controls whether a BP creation schedule can be defined.

If the template status is Draft, the template can be edited and used to manually create BP records. Required fields and assignee information can be left blank. Scheduled record creation cannot be performed.

If the template status is Complete, the Schedule tab of the Properties window is activated and can be used to define and schedule automatic record creation. The form is no longer editable (unless changed back to Draft). Required fields and assignee information must be completed before the status can be changed to Complete.

To change the status of a business process template to Complete

1 In User Mode, navigate to the log of the business process for which to edit the template. Click the File menu and choose Template. The Template List window opens.

2 Select a template and click Open. The template form opens.

3 Complete the BP form:
   • Complete all required fields.
   • Be sure the rest of the template form is filled out appropriately, including line items and attachments, if applicable. Remember that if you will be scheduling automatic record creation from this template, the information that you enter here will used for the creation step and sent to the first step in the workflow.
   • Select a workflow action (for the first step in the workflow).
   • Complete the assignees information (To field) as necessary.

4 Click the File menu and choose Template Status > Complete. A validation check will verify the following:
   • All required fields have valid data (and all other information on the form is valid).
   • The workflow action has been selected.
   • The Action Details/Assignees section To field is populated with valid users or groups, based on the BP setup.

When the status is Complete, the template form becomes view-only. If you have defined a record creation schedule in the Schedule tab, the schedule will be activated.

To change the status of a business process template to Draft

1 Open the template form.

2 Click the File menu and choose Template Status > Draft.

3 At the confirmation window, click Yes.

In Draft mode, the template form becomes editable. Scheduled record creation is disabled until you change the status back to Complete.
SCHEDULE AUTOMATIC BUSINESS PROCESS RECORD CREATION BASED ON THE TEMPLATE

You can schedule automatic BP record creation runs that are based on a BP template. The templates must have a status of Complete before you can define and activate the schedule.

For information on manual creation from a BP template, see “Create a business process record from a template”.

**Note:** Business process creation cannot be scheduled from a template in projects or shells that have the View - Only or Inactive status.

To define a BP creation schedule

1. In User Mode, navigate to the log of the business process for which to edit the template.
2. Click the File menu and choose Template. The Template List window opens.
4. Click the Schedule tab.
5. Complete the Schedule tab as described in the following section.
6. Click OK. The schedule is active as long as the template status is Complete.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable scheduled</td>
<td>Select this checkbox if you want to enable automatic record creation based on the schedule defined below.</td>
</tr>
<tr>
<td>record creation</td>
<td></td>
</tr>
<tr>
<td>Frequency</td>
<td>The frequency determines how often the new records are created from the template.</td>
</tr>
<tr>
<td>In this field</td>
<td>Do this</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>The options are:</td>
<td>The options are:</td>
</tr>
<tr>
<td>• Daily</td>
<td>• Daily</td>
</tr>
<tr>
<td>• Weekly (select the day of the week)</td>
<td>• Weekly (select the day of the week)</td>
</tr>
<tr>
<td>• Monthly (select the day of the month)</td>
<td>• Monthly (select the day of the month)</td>
</tr>
<tr>
<td>• Quarterly (runs on the last day of the</td>
<td>• Quarterly (runs on the last day of the calendar quarter)</td>
</tr>
<tr>
<td>calendar quarter)</td>
<td>• Yearly (runs on the last day of the calendar year)</td>
</tr>
<tr>
<td>All scheduled record creation is performed</td>
<td>All scheduled record creation is performed at 11:59:59 PM (PST).</td>
</tr>
<tr>
<td>Range of Recurrence</td>
<td>Choose one of the options:</td>
</tr>
<tr>
<td>Choose one of the options:</td>
<td>• No end date (runs until changed or schedule is disabled)</td>
</tr>
<tr>
<td>• No end date (runs until changed or</td>
<td>• End by (select an end date)</td>
</tr>
<tr>
<td>schedule is disabled)</td>
<td></td>
</tr>
<tr>
<td>Auto-email creator if scheduled creation</td>
<td>Select this option if you want the template owner or creator to receive e-mail notification if the scheduled creation fails. The e-mail will contain location information so that the recipient can see where the auto-creation originated, and where it failed.</td>
</tr>
<tr>
<td>fails</td>
<td></td>
</tr>
</tbody>
</table>
EDIT OR DELETE A BUSINESS PROCESS TEMPLATE

Users with view permission to a business process log will be able to view any associated templates. The template form and properties can be edited by the owner or creator and by users with Modify Record Ownership.

Only the owner or creator of a template can delete it.

To edit a template

1 In User Mode, navigate to the log of the business process for which to edit the template. Click the File menu and choose Template. The Template List window opens.

2 Select a template and click Open. The template form opens.

3 The fields, line items, file attachments, and other data are editable. You cannot change the workflow once the template has been created.

To delete a template

In the Template List window, select the template and click the Delete button. Click Yes to confirm.
EDIT OR CANCEL A BUSINESS PROCESS SCHEDULE

To edit a business process schedule
You can edit the schedule information in the Schedule tab at any time. The Schedule tab is active only when the BP status is Complete. After saving changes, the new schedule will be activated immediately.

To pause or cancel scheduled business process creation
Do one of the following to deactivate scheduled BP creation:

• Open the Properties window, and choose the Schedule tab. Deselect the Enable scheduled record creation checkbox. To reactivate the schedule, select the checkbox.

• Open the template form and change the status to Draft (from the File menu, choose Template Status > Draft). As long as the template remains in Draft mode, the BP schedule will be inactive. You can still manually create BP records from a draft template. To reactivate the schedule, change the status back to Complete.
Completing the Forms

Following are overall procedures for filling out a business process form. Each form will be different, depending on the type of business process it is. For an overview description of the form, see "About Business Process Forms" on page 163.
FILL OUT THE FORM

To fill out the form

1. Navigate to the business process log from which you want to create a new record.

2. Click the **New** button, or click the drop-down arrow next to the **New** button and choose from the list of business processes.

3. For workflow business processes, the Select Workflow window opens. Choose the workflow schema to use and click **OK**. The business process form opens.

**Note:** Primavera Unifier will not display the Select Workflow window if there is only one workflow schema you can choose for this business process.

4. Complete the upper portion of the form. The fields may be text-entry, drop-down menus, radio buttons, or pickers. Required fields are marked with a red asterisk (*) and require input.

Some business processes might be designed with “trigger” fields that will change the value of other fields on the business process as you are working on it. For example, if the form contains a “Currency Amount” field and a “Total Contract Amount” field, the Currency Amount field could be designated as a trigger field that will prompt Primavera Unifier to recalculate the Total Contract Amount field. If you change the value in the Currency Amount field, it will dynamically update the value in the Total Contract Amount field.

5. Complete the content section:
   - If this is a cost or line item type BP, add line items as necessary (See "Adding and Managing Line Items" on page 235).
   - If this is a document-type BP, attach the documents to the BP (See "Working with File Attachments and Markups" on page 260).
   - If this is a text-type BP, complete the text portion (for example, for an action item, include the instructions in the text box in the lower portion of the form).
   - If this is a simple-type BP, this portion is not applicable.

6. You may add additional information, including:
   - Add general comments or attach a file to a general comment (See "Adding and Managing General Comments" on page 253).
   - Add or review graphical markups to an attached document (See "Add or view graphic markups to a business process attachment" on page 264).
   - Provide a link to another completed BP form. Other participants will be able to click the link and view the referenced BP form. (See "Linking Business Process Records" on page 265.)
   - Send an e-mail notification to additional users or groups (if the BP is non-workflow and was designed with this option).

7. When you have completed the form, do one of the following:
a If this is a non-workflow business process:

- Click **OK** to save your changes.
- Click **Finish Editing**.

**Note:** If the business process is in a terminal status, and depending on the design, the form may or may not be made editable again after clicking **Finish Editing**.

b If this is a workflow business process:

- Select an action from the **Workflow Actions** drop-down list.
- In the **Action Details** area of the form, designate the next assignees (users or groups) who will receive the next step in the workflow as a task. You may also be able to designate the task due date for the next assignees.

**Note:** You can choose the next users to send the BP to if the BP has been set up this way. Some BPs have a fixed workflow. If this is the last step in the workflow, this is not applicable.

- (Optional) Add task notes for the next participants in the workflow. Task notes apply to the next workflow step only, and are not stored with the permanent record.
- Click **OK** to save your changes.
- Click **Send** to complete the creation step of the workflow and send it to the next step.
SAVE A DRAFT OF A BUSINESS PROCESS

At any time while filling out a business process form (whether creating a new one or responding to a task), you can save your work as a draft and return to it later. The record remains in your Drafts log until you send it. In addition, if you initiate a discussion group, the record remains in your Drafts log (the log displays a Yes in the Discussion column) until the discussion group ends (See "Participating in a Discussion Group" on page 299).

To save a draft copy of the business process form
From the File menu of an open BP record, click Save. A draft copy of the form with your edits so far is saved in your Drafts log.

To view your drafts
Navigate to the Drafts log by doing one of the following:

- In the Navigator, click Drafts directly under the Home node. The Drafts log lists all draft business processes.
- In the Navigator, open a project or shell or company and navigate to Collaboration > Drafts.

Note: Drafts for View-Only and Inactive projects or shells are not listed in the Drafts log.

To open a draft
Select a record from the Drafts log and click Open.

To delete a draft
Select the record from the Drafts log and click Delete. The draft form will be permanently deleted. A draft is automatically deleted from the log after the record has been sent or otherwise completed, or the discussion group ends.
ADDING AND MANAGING LINE ITEMS

Detailed information, such as transactions, can be entered as line items on cost- and line-item-type BP forms, as well as on document-type BPs, if they have been designed to accommodate documents that are attached as line items.

You can edit or delete line items on a BP form as long as the form is still editable; that is, before it reaches its terminal status (for example, approved). If you add a new line item in any step (other than the creation step), you can modify the line item until the BP is sent to the next step. The line item status will always default to the default line item status specified in the design. Users with permission can change the status if modification to the line item status is allowed in that step.

**Note:** Document and line item BPs can be designed to include line item status control, which allows users to choose a status for individual line items and control whether they can be modified.

If designed in Primavera uDesigner, there may be multiple tabs in the line item area of your BP form. Click these tabs to access the various line items.

You can enter line items using either a line-item entry form, or the Grid feature. Line item entry forms open in a separate window, which you must fill in and click **OK** to insert into the line item list at the bottom of the form. With the Grid feature, you can enter information directly into the line item list, but it is best used for short line items.
ADD LINE ITEMS USING A LINE-ITEM ENTRY FORM

You can add either a detail or a summary line item.

**To add a line item**

1. On the BP form, click the **Add** button.
   - If the business process does not use summary line items, Primavera Unifier opens the Line Item window.
   - If the business process uses summary line items, choose **Detail Line Item** or **Summary Line Item**, as appropriate. Primavera Unifier opens the Line Item window.

2. Fill in the line item fields, then click **OK**.

For information about adding documents to document type BPs with line items, see [Attach files to document-type business process forms](#).
EDIT OR REMOVE LINE ITEMS

To edit a line item
As long as the BP form is still a draft, you can edit a line item at any time by selecting it and clicking Open. The Line Item form opens. Make changes and click OK.

To remove a line item
In the BP form, select the line item to remove, and click Remove.

Note: When you remove a line item, Primavera Unifier also removes link information, both from the record the line item belongs to, and from the record the line item was linked to.

To edit line items on cost business processes
If configured in Primavera uDesigner (with the Allow Modify Line Item checkbox selected), then you can edit line items on cost business processes under the following circumstances:

- For workflow business processes, you can edit cost line item information at any step in the workflow, except for the end step. If the original line item data has already rolled up to the cost sheet, then the cost sheet will reflect the modified data after sending the business process to the next step.
- For non-workflow cost BPs, line item data can be modified before clicking the Finish Editing button.

Note: If the line item contains Yet To Buy (YTB) or AFC values, it cannot be modified.

This table lists the classifications of business processes and locations that allow the edit of line items on cost business processes:

<table>
<thead>
<tr>
<th>Classification</th>
<th>Project (Standard)</th>
<th>Shell (WBS Code)</th>
<th>Shell (Generic Code)</th>
<th>Company Workspace</th>
<th>Edit Line Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Item with WBS Code</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Line Item with Both Fund Code and WBS Code</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Line Item with Fund Code</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Line Item with Account</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Line Item with Asset Code</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Line Item with Multiple Codes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Commit at Company Level</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>
ADD AND MANAGE SUMMARY LINE ITEMS

Primavera uDesigner cost and line item BPs support summary line items. This allows regular line items to be grouped together, with only the summary appearing on the BP. The sub line items are rolled up to other areas such as the Cost Manager.

To add summary line items

1. From the BP form, choose Add > Summary Line Item. The Summary Item window opens.
2. Click Save, and then click Close Window.

The summary line item will appear at the top of the line items area of the BP form in bold. The amount column will show the sum total of the line items you added.

To edit or copy a summary line item

From the Summary Line Item window, you can edit or copy summary line items just as you would line items in the BP form (see the previous procedures).

To remove a summary line item

1. In the BP form, double-click the Summary Line Item. The Summary Line Item window opens.
2. Select the line items in the summary (press Shift or Ctrl to select multiple line items). Click Remove.
3. Click the Delete Summary button. Click Yes to confirm.
FILTER THE LINE ITEM LIST

Some business processes can include many line items, and filtering the list of line items can make the form easier to use. To narrow the list of line items you see, you need to use Primavera Unifier’s Find function. The Find function will search for and display specific line items according to the criteria you specify.

To filter the line item list

1. On the BP form, click the Find button. Primavera Unifier displays the Find window.
   The Find window shows fields from the line item list, which you can use to narrow the list of line items you see. Each field shows an operator, such as “contains” or “equals,” which you can use to specify more precisely which line items you want to see on the list. In the example Find window above, you could narrow the list of line items to show only certain class levels or cost categories.

2. To specify search criteria, first choose the operator you want to use on the field, such as “equals,” “does not contain,” or “is empty”.

3. Enter the value the field should contain, or click the Select button and select the value from the list that appears.

4. Click Search (or press Enter).
   Primavera Unifier displays all the line items that met the search criteria you entered.

If you choose to, you can cancel the filtering action by clicking [Cancel Filter] or the x icon in the upper-right corner of the Find window. Primavera Unifier will restore the list of line items to its unfiltered state.
COPY A LINE ITEM FROM THE SAME FORM

You can create a new line item by copying an existing line item. You can choose to include any attachments that are on the source line item; however, any links the line item has to other records will not be copied.

To copy a line item

1 In the business process form, select the line item to copy.
2 Click Copy, and choose Copy Line Items.
3 A confirmation window opens. To copy any attachments from the original line item to the new line item, click Yes. To ignore any attachments, click No.
4 The Line Item window opens, with the original line item fields filled in. You can leave the data as is or make necessary changes.
5 Click OK to close the window.
COPY AND CONSOLIDATE LINE ITEMS FROM DIFFERENT BUSINESS PROCESS FORMS

Business processes can be designed to accommodate line item consolidation: the ability to select individual line items from one or more BP records (the source BPs) and copy them into a new record (the destination BP). The selected line items can be from the same BP type, or they can be from different types, as long as they are compatible (see the table below). The source and destination BPs must be at the same level (both company level or both project or shell level). File attachments can also be copied.

This functionality is built into business processes through the Primavera uDesigner design, which includes specifying which BPs can be used for the source and destination. Also, the ability to filter the business process records that can be consolidated (by status) can be added in Primavera uDesigner. This enables you to filter the records you see in the list to consolidate by the record status, allowing you, for example, to exclude records that have the status of Pending or Rejected.

For example, this functionality can be used to consolidate specific line items from multiple change order requests submitted over a period of time into a single change commit.

The following BP types are supported:

- Cost type (except payment applications)
- Document (with a detail form)
- RFB (Requestor form only)
- Line item type

There are some restrictions when consolidating line items from different BP types:

<table>
<thead>
<tr>
<th>Source (across)</th>
<th>Destination (down)</th>
<th>Cost Type</th>
<th>Doc Type</th>
<th>RFB</th>
<th>Line Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Type</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Doc Type</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>RFB</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Line Item</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

To copy line items from one or more business process records into another

1. Open the business process record into which the line items will be consolidated (the destination business process).

2. On the bottom toolbar, click Copy and choose Consolidate Line Items. The Line Items Consolidation window opens. This window lists the business processes that are eligible for consolidation with this BP.

Note: This window will not appear if there is only one eligible business process. Instead, a list window opens, displaying a list of the eligible records from that business process. Continue with step 4.
For Shells:
If you are consolidating line items from a business process in a shell, the window will display a Choose Location field. Use this field to specify which shell the business process resides in. (View-only shells are not usable with this feature.)

For Data Pickers:
If the source BP includes a data picker on the form, it might be set up to present the list of records in a hierarchy. If this is the case, Primavera Unifier will ignore the Choose Location field.

3 Select the source business process and click OK. A list window opens, displaying a list of eligible records from that business process.

4 Select a record from the list. To search for a particular record, click Find.

5 To copy specific line items from the selected record:
   - Click the Select Line Items button. The BP Line Item(s) window opens, displaying the Line Item List for that record.
   - Select one or more line items and click Copy.
   - Choose With Attachments to include any file attachments that may be present on the line item to be copied, or choose Without Attachments to ignore attachments.

6 To copy all line items from the selected record:
   - Click All Line Items.
   - Choose With Attachments to include any file attachments that may be present on the line item to be copied, or choose Without Attachments to ignore attachments.

Note: If there are multiple tabs on the record you selected, Primavera Unifier will prompt you to select the tab you want to copy the line items from.

7 Close this window by clicking the Close Window button.
Primavera Unifier copies the line items to the consolidated business process record.

Note the following:
- Once you copy a line item for consolidation, that line item will no longer be available for other consolidations—unless the BP design specifies that, once the consolidated BP reaches a certain status, the line items from the source BP(s) will be available again. For example, if a Change Order with consolidated line items reaches a “rejected” status, then all the consolidated line items will be available so you can consolidate them again in another Change Order. In addition, line items will be available again for consolidation if the consolidated business process record reaches a terminal status, or if the line item is deleted in the originating (source) business process or is terminated.
- Be aware that line items on a draft business process are also unavailable for consolidation. If the consolidated line item business process has not been saved or sent to the next step in a workflow, Primavera Unifier considers it to be in draft mode and will lock the line item for any other consolidation. To unlock the line item, you must delete the draft BP.
- If the consolidation setup was designed so in Primavera uDesigner, the line item in the consolidated BP can be automatically updated whenever the source line item changes (as long as the consolidated record has not reached a terminal status). For example, pickers that are auto-
populated will be updated, formulas will be re-calculated, roll-ups will be updated, attachments will be modified or removed, reverse auto-population will be performed. However, if any new attachments are added to the source line item, these will not be added to the line item on the consolidated BP.

• If there is a BP Line Item picker on the source and destination detail forms, the BP Line Item picker data will be ignored (will not be copied) while copying line items.

• BP picker information can exist on source and destination detail forms. Data will be copied only if the underlying BP picker reference is the same on both the source and destination. If the reference is not the same, data will not be copied. For example, a destination BP has a BP picker on the detail form that references a vendor BP. To populate data via this BP picker, the source BP must have a BP picker that is the same vendor BP. If it is not, the vendor data cannot be copied.

• A Commit Line Item picker on the detail form of a change order business process will allow you to select a line item from SOV (contract + change orders). A Commit Line Item picker always works in conjunction with a Reference Commit picker on the upper form. The Reference Commit picker on the source and destination should refer to the same base contract.

• If the destination line item form and the source line item form both contain a data element that is designed to be auto-populated from another source, the auto-populate will be ignored during consolidation. The copied line item data will take precedence over auto-populated data in the destination BP.
ADDING AND MANAGING LINE ITEMS USING THE GRID FEATURE

For Line Item business processes, Primavera Unifier provides a Grid feature that shows the line-item entry form in a lateral sheet view, where you can enter the data directly onto the line item list without having to open a line item form. In this regard, the sheet works the same way the line-item entry form works—rows might not be editable because of their statuses, auto-populated fields will be filled in for single-record BPs, if a yet-to-buy amount has already rolled up from a cost BP to the cost sheet, you will not be allowed to modify the line item, etc.

**Note:** The Grid feature is best used for short line items.

The grid shows the line item number and all the fields on the line item entry form, including fields that are required, formulaic, or populated, as well as fields that are part of a dynamic data set. The fields on this grid work the same way they do on a line item entry form—pickers display picker windows, menus display lists, formula fields produce calculations, date picker fields display calendars, etc.; however, radio buttons will appear as pull-down menus, and image, hyperlink, and BP Creator fields have special behaviors.

You can resize the columns by dragging, and sort the data by column (except for Row and image fields). You can use the Tab and arrow keys to move from field to field and open them. For business processes that include many line items, you can use the Find function to filter the list to display only certain line items.

**The Grid feature is not available on:**
- RFB bidder forms
- Line Item with WBS Code BPs (Transfer classification)
- Standard tab of Payment Application Line Item with WBS Code BPs
• Line Item with Asset Code BPs
• Line Item with Multiple Codes BPs (Transfer and Lease classifications)
• Simple type BPs
• Text type BPs
• Document type BPs
• Resource Booking type BPs for project/shell
• Project/Shell Creation BPs (Simple sub-type)

What is not available on the grid:
• Summary row functions: Summary line items do not appear on the grid and cannot be created on the grid. In addition, line items within the summary do not appear.
• Transaction currencies
• Line item consolidation
• Import function

Last One to Save Over-Writes Other Edits (Except for Deleted Rows)
The Grid feature can be used simultaneously by multiple users. To accommodate multiple editors using the grid simultaneously, the commit order of saved edits is on a line-by-line basis, not on the entire grid view. If two users are editing the same line item, but different fields, at the same time, the edits made by the last user to save that line item are the edits Primavera Unifier will commit to the record.

For example, if User 1 changes an amount field from 15,000 to 23,000 and saves the change, and User 2 changes a different field, but does not touch the amount field, when User 2 saves the grid, Primavera Unifier will commit User 2’s edits; and the amount field will show 15,000 rather than 23,000.

The order of saved edits is particularly important for deleted rows on the grid. Once a row is deleted, it cannot be reinstated with a later edit. For example, if User 1 deletes a row and saves the grid view, and User 2 changes the amount field in that row from 15,000 to 23,000 and saves the grid view, the row will not be reinstated with the new amount of 23,000.

Split screen
To make editing line items easier, you can use the Split button to split the screen into two halves.
Error messages

If Primavera Unifier detects errors when you save line items, error messages will appear at the bottom of the Grid window, indicating the row where Primavera Unifier found the error.
ADD LINE ITEMS USING THE GRID

1 On the BP form, select the tab containing the line items you want to add to.

2 On the Line Item window, click the Grid button. The Grid window opens, showing a new, empty row at the bottom of the list to use for the new line item.

3 To enter data into the grid, double-click a cell in the new row. The cell opens for editing. As soon as you begin adding a line, a change icon appears in the first column as a reminder that a line item has been added to the record, and the Save button becomes active.

4 Fill in the fields on the grid as necessary.

5 (Optional) To include an attachment to a line item, click the Attach button. An upload window opens.
   a Click Add and navigate to the file you want to attach.
   b Select the file, click Open, then click Upload.
   c When the upload is complete, click Close.

6 To save the line item to the record, click Save. When you save the line item, Primavera Unifier refreshes the grid view, removes the change icon, adds the line item to the list, and inserts a blank line at the bottom of the list for another new line item. It also updates the line item list on the BP form.

7 To add additional line items, repeat steps 3 through 6.
LINK LINE ITEMS TO OTHER BUSINESS PROCESS RECORDS

Once you have entered a line item onto the grid and clicked the **Save** button, you can link the line item to a business process record.

**To link a line item to a BP record**

1. On the BP form, select the tab containing the line item you want to link to a record.
2. On the Line Item window, click the **Grid** button. The Grid window opens.
3. Select the line item you want to link and click the **Linked Records** button. The Links window opens.
4. Do one of the following:
   - If you are linking to a record from the same business process log, click the **Attach** button.
   - If you want to link to a record from another business process log, click the arrow next to the Attach button, and then choose the log where that business process record resides.
5. From the resulting list of BP records, select the record(s) to link to the line item and click **Attach**.
6. Click **Close Window** to close the Links window.
EDIT LINE ITEMS USING THE GRID

To edit line items using the line item grid

1. On the BP form, select the tab containing the line items you want to edit.

2. Click the Grid button.

3. On the Grid, double-click the cell you want to edit. The cell opens for editing.
   As soon as you begin editing, a red change icon appears in the first column as a reminder that the
   line item has been modified, and the Save button becomes active.

4. Click Save.
   When you save the line item, Primavera Unifier refreshes the grid view, removes the change icon,
   and updates the line item list on the BP form.

5. To edit additional line items, repeat steps 1 and 2.

6. When you have finished, click the Close Window button.

To edit an image field on a line item grid

An image field on the grid displays only an image icon; however, you can see a thumbnail of the image if
you double-click on the icon. If you want to change or remove the image, double-click the cell anywhere
but on the icon. Primavera Unifier displays a menu, from which you can choose to upload a different
image, or remove the image.

To edit a hyperlink field on a line item grid

If you want to change a hyperlink, double-click the cell anywhere but on the hyperlink. Primavera
Unifier displays the Hyperlink window, where you can change or remove the link.
INSERT A ROW INTO THE GRID

Inserting a row in the grid can be convenient if you have a long list of line items. Primavera Unifier automatically opens a new line item at the bottom of the list, but if the list is long, it can be more convenient to insert line items wherever you are in the list. When you save the grid view, Primavera Unifier re-sorts the added rows into their proper place.

To insert a row or rows

1 On the Grid, select a row and click the Insert button on the toolbar.
To insert multiple rows, click the Insert button again. Primavera Unifier inserts the row(s) above the row you selected.

2 Fill in the line item fields and click Save.
Primavera Unifier reassigns the line numbers as follows:

- If any rows have been deleted during an edit, the line numbers are reused so that the line numbering remains continuous. (Exception: If the amount on a WBS line item has been rolled up to the cost sheet, the line number will not be reused.)
- After deleted line numbers have been reused, any new line items are assigned numbers in ascending or descending order, depending on how the sort order was specified when the line item list was created.
MANUALLY CREATE A BUSINESS PROCESS FROM THE GRID

A BP Creator field configured for automatic creation mode will appear as a read-only field on the grid. But if the field is configured for manual creation, you can set up the business process creation from the Grid. The new business process will be created when you finish editing the form, or send the form on to the next step in the workflow.

To manually create a business process from the Grid

1 Double-click the BP Creator field. The field will display the words “Pending Creation.”
2 Click Close Window to close the Grid and return to the form.
3 On the form, click Finished Editing (if this is a non-workflow BP), or Send to send the BP form on to the next step in the workflow.

Primavera Unifier creates the new business process. After the business process has been created, this field will show a hyperlink to the new business process.

To prevent a business process from being created

1 Double-click the BP Creator field. The field will display the words “Pending Creation.”
2 Double-click the BP Creator field again.

Primavera Unifier clears the text from the field, and will not create the business process.
COPY A LINE ITEM ON THE GRID

1 On the form, select the tab containing the line item you want to copy.

2 On the Line Item window, click the Grid button. The Grid window opens.

3 Select the line item (or items, using the Ctrl key) you want to copy and click the Copy button.

4 Select a line and click the Paste button. Primavera Unifier pastes the copied line item(s) into the row(s) above the selected line, giving it (or them) a line item number of 0.

5 Click Save. Primavera Unifier renumbers the line item(s) with the next incremental number(s), and updates the line item list on the form.
ADDITION AND MANAGING GENERAL COMMENTS

Business processes provide a general comments section that allows you to add text comments that are like notes that accompany the business process but do not become part of it.

Depending upon the workflow setup and your permission settings:

- You can hide or delete comments.
- You can attach supporting documents to your comments, which do not become part of the attachments of the BP itself, or mark up attached documents. See "Working with File Attachments and Markups" on page 260.
- You can initiate a discussion group to help you draft your comments or markups. See "Participating in a Discussion Group" on page 299.
- You can add general comments if you are a task assignee or if you have been copied (cc’d) on the business process.
- You can add comments to a business process at the End step, and also at any status in a workflow, including “terminated” (which means the business process was stopped at some point in the workflow). To add comments at those points in a workflow, you must have the “Add General Comments” permission.

Note: Some users, such as project managers, may have an additional permission that allows them to add general comments to any form (workflow or non-workflow) that they can view, without accepting the task.
ADD COMMENTS TO A BUSINESS PROCESS FORM

When you add a new comment to a BP form, it remains as a draft until you send the form to the next step in the workflow. Draft comments remain editable until you send the form. After that, they cannot be modified.

To add general comments to the business process form

1 At the bottom of the BP form, click the General Comments link. The General Comments window opens.

Note: If any comments already exist on this BP, they will be listed in the Comments section of the window.

2 Click Add. The Edit General Comment window opens.

3 Type your comments in the text box. You may spell-check by clicking the Spelling button.

4 To add files to the comment, click Attach.
   • My Computer: Attach the file from your local system. The procedure is the same as for uploading files to the Document Manager and depends on your file transfer option.
   • Primavera Unifier Folder: Attach documents from the Document Manager. The window opens displaying the project or shell documents files and folders. Select the files and folders to attach and click OK. Folders are not attached. Instead, the contents of selected folders are attached in a flat list. Documents with duplicate file names will not attach.

5 To copy information in a previous draft comment, click the Copy From button. See "Copying and Consolidating Comments and Markups" on page 301 for more information.

6 Click OK to save the comment and close the Edit General Comment window.

Note: The Text Comments box does not recognize formatting, including line breaks. Even if you press the Enter key to make a new line in the Edit General Comment window, the final comment will not reflect the new line.

7 Click Close Window to save your comments and return to the BP form.

An icon will appear at the bottom of the form next to the General Comments link.
To add comments to a document type business process

1. Select the document from the document list at the bottom of the form.
2. Click the Comments button.
3. Click Add to add the comment. Enter the text comment. Click the Spelling button to spell-check the comment.
4. You can also add a graphic markup to the document or attach a file to the comment.
5. Click OK.

**Note:** If the document type BP has been designed to use line item status, and a specified status has already been reached (e.g., approved), the line item may no longer be editable, and you may not be able to add comments to it.
**VIEW COMMENTS**

If a BP form has comments added, a Comments icon will display next to the General Comments link.

**To view comments on a business process form**

Click the **General Comments** link at the bottom of the BP form. The General Comments window opens displaying previous comments. You can collapse or expand individual comments by clicking the arrow in the upper left corner of each comment.
EDIT OR DELETE COMMENTS

When you add a new comment to a BP form, it remains as a draft until you send the form to the next step in the workflow. Draft comments remain editable until you send the form. After that, they cannot be modified. (You can only modify your own comments, and only if you have not yet sent the BP to the next step in the workflow after creating the comments.)

Comments can be deleted after being sent only if the BP workflow has been set up to allow deleting of comments.

**To edit a comment**
From the General Comments window, select the comment to edit and click **Modify** from the toolbar. The Edit General Comment window opens. Make the necessary edits. Comments are editable until you click **Send** (workflow BP) or **Finished Editing** (non-workflow BP).

**To delete a comment**
From the General Comments window, select the comment to delete and click the **Remove** button. Draft comments can be edited before sending a BP. You must have proper permissions to delete final comments.
HIDE COMMENTS

You can hide comments that you do not want to be generally viewed on workflow business processes. If you have permissions, you can view previously hidden comments. Other users will not be able to see the hidden comments unless they have the View Hidden Comments permission set, and using that permission, can also unhide the hidden comments. As the creator of the comment, you can view your own hidden comments, whether or not you have the View Hidden Comments permission (until the comments are published).

**Note:** Hidden comments are never included in the PDF attached to emails, regardless of a user's view permissions.

To hide or unhide comments

1. From the Comments window, select the comment to hide and click the **Hide Comments** button at the bottom of the window. The color of the hidden comment title bar lightens, and the Hidden Comment column will display Yes.

2. To unhide the comment, select it and click **Unhide Comments**.

**Note:** Due the nature of end steps, you cannot hide or delete comments on the end step of the workflow, even if the end step is an action (editable) form.
ADD COMMENTS TO AN ATTACHED DOCUMENT

For document-type BPs (such as transmittals or submittals), you can add comments directly to an attached document.

To add comments to an attached document

1. Select an attached document in the Attachments portion of the document-type BP.
2. Click the Comments button on the toolbar. The File Comments window opens.
3. Click Add. The Edit General Comment window opens.
4. Type your comments in the text box. You may spell check by clicking the Spelling button.
5. You can hide comments on the attachments of workflow business processes by selecting the Hide Comment checkbox. See “Hide comments” on page 258 for details on working with hidden comments.
6. Click OK.

To attach files to comments

To add files to the comment, click Attach and choose:

- **My Computer**: Attach the file from your local system. The procedure is the same as for uploading files to the Document Manager and depends on your file transfer option.
- **Primavera Unifier Folder**: Attach documents from the Document Manager. The window opens displaying the project or shell documents files and folders. Select the files and folders to attach and click OK. Folders are not attached. Instead, the contents of selected folders are attached in a flat list. Documents with duplicate file names will not attach.

**Note:** The attachment sources (My Computer and Primavera Unifier Folder) that are available depend on the BP design. Both choices may not be available for a given BP.
Working With File Attachments And Markups

You can attach files to be routed with the BP form. These can be documents that are sent within a document-type BP (such as a transmittal) or they may be supporting documents that are attached to a BP record of any type in the General Comments section.

**Note:** By default, files attached to business processes are placed in the Unpublished Documents folder in the Document Manager. A Publish Path data element can be designed in business processes in Primavera uDesigner to specify the automatic publishing of documents to a specified path and override the default. See "About automatic publishing of documents" on page 601 for details.

If you are uploading drawing files, See "Attach drawing and reference files to a business process" on page 263 for handling drawing file attachments.

You may also initiate a discussion group to help you draft your comments or markups. See "Participating in a Discussion Group" on page 299.

**Note:** You cannot upload and attach two documents with the same name to a BP record. If you are using a document-type BP (such as a submittal or transmittal) and are using a folder structure, you can have two documents with the same name in different folders, as you would on a local machine or network drive.

**Attach Files To Business Process Forms**

You can attach files to BP forms directly from your local system or from files that are already part of the Document Manager. For document-type BPs, such as transmittals, you can attach files to the BP that are part of the transmittal package. For all BPs, including document type, you can also attach files as supporting documentation.

Open the form to which you want to attach files and follow one of the procedures below.

Files can be attached to forms through General Comments.
To attach files to a business process form

1. Click the General Comments link at the bottom of the form, and then click Add to open the Edit General Comment window.

**Note:** If you are attaching a file through General Comments, you must also enter a text comment.

2. Click Attach and choose:
   - **My Computer:** Attach the file from your local system. The procedure is the same as for uploading files to the Document Manager and depends on your file transfer option.
   - **Primavera Unifier Folder:** Attach documents from the Document Manager. The window opens displaying the project or shell documents files and folders. Select the files and folders to attach and click OK. Folders are not attached. Instead, the contents of selected folders are attached in a flat list. Documents with duplicate file names will not attach.

**Note:** The attachment sources (My Computer and Primavera Unifier Folder) that are available depend on the BP design. Both choices may not be available for a given BP.

### Attach Files To Document-type Business Process Forms

Document-type business processes, such as transmittals or submittals, can be used for routing documents such as specifications or drawings for review. Comments and graphic markups can be added to individual files, and the document list is easily accessible from the BP form.

There are two subtypes of document-type BPs:

- **With Folder Structure:** Maintains the folder structure of the attached documents and folders. The folder structure is displayed in the left pane of the lower portion of the form.
- **Without Folder Structure:** The folder structure is ignored. Files within attached folders and sub-folders are listed in a flat list.

In addition, document-type BPs can be designed such that files can be added to individual line items, which allows users to assign line-item status to individual documents. If the status of the line item (and therefore, the associated document) reaches a specified status (e.g., approved), the BP can be set up so that the line item is no longer editable. Attachments and comments to that line item are no longer allowed.

### Automatic Publishing to a Specified Path

By default, files attached to business processes are placed in the Unpublished Documents folder in the Document Manager. A Publish Path data element can be designed in business processes in Primavera uDesigner to specify the automatic publishing of documents to a specified path and override the default. See "About automatic publishing of documents" on page 601 for details. For document-type business processes With Folder Structure, the designer can specify that a configured folder path be appended to the folder structure. This appended path is based on the path configured in the uuu_dm_publish_path data element on the business process form, and the selection of the Append Line Items Folder Structure to AutoPublish Path option, which is documented in the Primavera uDesigner User Guide; see Starting an Upper Form for details.

### To attach files to a document-type business process from your local system

From the document-type BP form, do one of the following:

- If the document type BP has line items, click the **Add button** and choose **Import Line Item w/ Attachments > My Computer**.
- If the BP does not use line items, click the **Add Attachment button** and choose **My Computer**.
The method for attaching files is dependent upon the file transfer option you chose in the user preferences.

**To attach files to a document-type business process from the Document Manager**

1. From the document-type BP form, do one of the following:
   - If the document BP has line items, click the Add button and choose **Import Line Item w/ Attachments > Primavera Unifier Folder**.
   - If the BP does not use line items, click the Add Attachment button and choose **Primavera Unifier Folder**.

2. The Select Files window opens. Select the documents or folders to attach and click OK. At the top left portion of the window, you can click **Current Phase** to view folders and documents associated with the current phase, or **All Phases** to view all folders and documents in the Document Manager, regardless of phase.

3. If you want to include the comments that may be attached to the documents, select the **Copy Comments** checkbox.

4. Click OK.

The files appear in the lower portion of the window. If the BP has line items and you select a folder or multiple documents, each document will be added in a separate line item.

**Note:** When attaching files from the Document Manager, some fields on the line item may auto-populate with data from the document or folder Properties window. Document-type BPs can be designed to auto-populate certain data elements on the detail form with data from matching data elements on the document attribute form.

**Remove Attachments From A Document Type Business Process**

To remove attachments from a document-type BP, you can remove the entire line item, or you can leave the line item intact and remove the attachment from it.

**Note:** If the document-type BP has been designed to use line item status, and the specified status has already been reached (e.g., approved), the line item may no longer be editable.
To remove attachments from a document-type business process (remove line item)

1. From the document-type BP form, select the line item to be removed.
2. Click the Remove button.
3. Click Yes to confirm. The line item and attachment are removed.

To remove attachments from a document-type business process (remove attachment from the line item)

1. From the document-type BP form, double-click the line item to be removed. The detail line item window opens.
2. Click the Remove Attachment button.
3. Click Yes to confirm. The attachment is removed from the line item.

Note: All fields that had been auto-populated when the file was originally attached (for example, name, issue date, revision number, etc.) will be cleared.

Since Name is a required field, you must give the line item a new name before closing the line item detail window. If you close the line item detail window before entering a new name, the name of the file that has been removed will remain in the field.

Attach Drawing And Reference Files To A Business Process

Drawing files attached to a document-type BP may be accompanied by multiple reference files, which may need to be resolved when attaching a drawing file. Follow the above procedure for attaching the drawing a file.

See "Resolving Missing Reference Files (Reference Manager)" for information about resolving missing reference files.

View, Delete, Or Download Attached Files

The following describes how to view, delete, or download attached files.

To view attached files (non-document-type business processes)

1. Do one of the following:
   • If the file is attached to the comments on a BP form, click the General Comments link. Open the comment with the attachment, and then click the Attachments link at the bottom of the Edit General Comment window.
   • If the file is attached directly to the BP form, click the Attachments link at the bottom of the form.

   The Attachments window opens.

2. Select a file and click View. The document will open in the viewer selected in your user preferences.

Note: If the file is a drawing file with references, you can select the file in the Attachments window and click Reference Records. The Reference Record window opens.
To view attached files (document-type business processes with line items)
Double-click the document from the list at the bottom of the form. The Line Item window opens. Double-click the document to open.

To delete an attached file
Do one of the following:
- For non-document-type BPs, in the Attachments window, select the file to be deleted. Click the Remove button.
- For document-type line item BPs, select the document in the bottom of the form, and then click Remove.

To download a copy of an attached file
Do one of the following:
- For non-document-type BPs, in the Attachments window, select the file to be downloaded and click Download.
- For document-type line item BPs, select the document to be downloaded and click Download.

Add Or View Graphic Markups To A Business Process Attachment
You can add markups, such as circles or other graphical elements as well as text, to a document, which display directly on the document, but do not alter the document itself. Markups are layered on top of a file, as if the markups had been done on an acetate sheet that had been placed on top of the file. Each user who adds a markup is adding a new layer to the file.

To add a markup to an attachment on a business processes
1. Do one of the following:
   - For non-document-type BPs, click the Attachments link. In the Attachments window, select the document and click the Comments button.
   - For document type BPs, select the document in the lower portion of the document-type BP and click the Comments button. The File Comments window opens. If you have added any previous comments since the last time the BP was sent, they will be listed in the Draft Comments portion of the window.
2. Click the Add button. The Edit File Comment window opens.
3. Click the Graphic Markup button. The AutoVue Professional viewer window opens displaying the document content. The window opens initially in View mode.
4. In the viewer window, click the New Markup tool or select File > New Markup.
   If there are existing markups, the Markup Files window opens. Each saved markup session is listed in the window. Select the checkbox by the markups to view and click OK.
   The viewer switches to Markup mode, and the markup tools become available.
5. Add graphic markups to the drawing as necessary, using the tools on the horizontal toolbar.
   Note: Each markup shape is a separate entity. The navigation pane on the left shows the Bookmarks tab and Markup Tree tab. The Markup Tree tab shows the markups. Click an entity to select it.
6. Click the Save button or select File > Save to save your markups. Enter a name for the markup and click OK.
**Note:** Markups are saved as a single layer and are no longer editable once you close the window. Each markup is listed by name in the Markup Tree tab as a separate layer. To add another markup layer, click the New button.

7 When you have completed your markups, close the viewer window to return to the Edit File Comment window.

**Note:** At this point, the comment is still in Draft mode. You can add additional markups or file attachments if desired. You must enter some text in the Text Comment box to save it.

8 Click OK to save and exit the Edit File Comment window.

9 Close the File Comments window.

**To view graphic markups**

1 Open the comments window. Markups are associated with a specific comment.

2 Locate the comment with the markup, and click the **View** link next to Graphic Markup.

**Linking Business Process Records**

You can create a link from one business process to another, or from a line item to a business process. Other users will be able to click on the link and view the referenced business process. Linked records are added and viewed from the Linked Records link at the bottom of the BP form. If records have been linked, the number of records will appear next to the Linked Records link.

**Note:** This option is available only in BPs that have been designed to accommodate linked records. A user’s ability to view a linked BP record is based on the user’s permissions. If users cannot see the record in the log, they cannot see it in the link.

**Link A Business Process Record**

**To link a business process record to another business process**

1 At the bottom of the BP form, click the **Linked Records** link. The Links window opens.

2 Do one of the following:
   - If you are linking to a record from the same business process log, click the **Attach** button.
   - If you want to link to a record from another business process log, click the arrow next to the Attach button, and then choose the log where that business process record resides.

3 From the resulting list of BP records, select the record(s) to link to the open business process form and click **Attach**.

4 Click **Close Window** to close the Links window.

**To link a line item to a business process record**

1 Open the business process that contains the line item you want to link.

2 Open the line item.

3 At the bottom of the line item detail form, click the **Linked Records** link. The Links window opens.
4 Do one of the following:
   • If you are linking to a record from the same business process log, click the Attach button.
   • If you want to link to a record from another business process log, click the arrow next to the Attach button, and then choose the log where that business process record resides.

5 From the resulting list of BP records, select the record(s) to link to the open business process form and click Attach.

6 Click Close Window to close the Links window.

Manage Linked Records

To view a linked record
1 At the bottom of the BP form, click the Linked Records link. The Links window opens.
The Links window shows all the records and line items to which or from which the record is linked.

2 From the Links window, select the record to view and click Open. A read-only version of the form will open.

To remove a linked record
1 At the bottom of the BP form, click the Linked Records link. The Links window opens.
2 From the Links window, select the record link to remove and click Remove.

Note: From this window, you cannot delete a record with a From direction. To delete the record, you must open that record, click the Linked Records link and remove it from the Links window.

Linking UMail Messages To A Record

You can attach uMail messages directly to a BP record. On any action form in the workflow, users can click on the link and view the referenced uMail. Attached uMails are added and viewed from the Linked Mail link at the bottom of the BP form. This link will show the number of emails, both uMail and external emails, that have been attached to the record. A single email message can be attached to more than one BP record.
About Permissions

The uMail messages that users have access to (whether linking a uMail message or viewing a message linked to the BP by someone else) will depend on their uMail permissions. By default, users can see linked uMails that reside in their personal Inbox and Sent boxes (either they have sent the uMail or were a recipient). A user who has permission to view public items can view uMails residing in the Public Items folder sent and received by others. For example, users with Project uMail view permission can see all uMails generated within a project. Users with Company uMail view permission can see all uMails generated by users in the company.

Note: There are special conditions for linking uMails in the Request for Bid functionality. See "Send and manage linked uMails from RFB forms" on page 268 for more information.

Attach An Existing uMail Message

You can attach new or existing uMail messages to a BP record. A single uMail message can be attached to one or multiple BPs.

To attach an existing uMail message to a BP

1. At the bottom of the BP form, click the Linked Mail link. The Linked Mail window opens.
2. Click the Add button and choose My uMails. The My uMails window opens, displaying the list of available uMail messages.
3. From the list, select the uMails to link to the open BP form and click Attach.
4. Click Close Window to close the Linked uMails window.

Create And Attach A New uMail Message

You can create and send a uMail message from the BP record. You must send the uMail before sending the BP to automatically attach it to the BP record. The uMail message will be stored in your current project or shell uMail Sent folder, in the Public Items folder, and the Inbox of recipients. In addition, if you reply to or forward the message, the reply and forwarded copies will also automatically be linked to the BP record.

Note: If you create a new uMail message and save it without sending, it will remain in your uMail Draft log in the current project or shell. You can later access this draft uMail and send it, but it will not be automatically linked to the BP record from which you originally created it. To link it, send the message first, and then attach it as you normally would an existing uMail message.

If a recipient replies to or forwards the linked uMail message, the reply or forwarded message will also be automatically linked to the BP.

To create and attach a new uMail message to a business process

1. At the bottom of the BP form, click the Linked Mail link. The Linked Mail window opens.
2. Click New. A uMail message window opens.
3. Complete the uMail message window as normal, and click Send to send the message.
Once the BP record is sent, the uMail message and any subsequent replies to that message by other users will be automatically attached to the BP record.

**Manage Linked UMails**

You can view or remove linked uMail messages.

**To view linked uMail messages**

From the Linked Mail window, select the message to view and click **Open**. The Message window opens.

**To remove a linked uMail message**

From the Linked Mail window, select the message and click **Open**. The Message window opens. Click **Delete**.

**Reply To Or Forward A Linked UMail Message**

If you receive a uMail message with a link in the upper portion of the window, that uMail message is linked to one or more BP records. If you click **Reply**, **Reply All**, or **Forward** and then send your response, the reply or forwarded message will also automatically be linked to the BP record.

**View The List Of Linked BPs From A UMail Message**

If a uMail message has been linked to one or more BP records, a **Show List** link appears on the uMail message window.

**To view linked BP records from a uMail message**

1. Open a uMail message. If the message has been linked to one or more BP records, a **Show List** link will display on the upper portion of the message window.
2. **Click Show List**. The Linked Records window opens.
3. **To view a BP record**, select it from the list and **click Open**.

**Send And Manage Linked UMails From RFB Forms**

Request For Bid (RFB) business processes have special linked uMail functionality. For RFB business processes, the creator of the RFB form will be allowed to correspond with internal users or with RFB bidders.

**To send a uMail message from an RFB form**

1. Open the RFB BP form and click the **Linked Mail** link in the lower-right corner of the form. The Linked Mail window opens.
2. **Click New** and select one of the following:
   - **To Internal**: The Message window opens. The selection list for To, Cc, and Bcc includes your Primavera Unifier project or shell team, as in other uMail messages.
   - **To Bidder**: The Message window opens. The selection list for To, Cc, and Bcc is generated from the list of invited bidders (selected from the Master Vendor BP and invited to submit a bid during the creation of the RFB record).

**Note**: You will not be able to save a draft copy of the uMail from this selection.

Bidders will be allowed to view and access uMails once they are logged into Primavera Unifier using a special login.
Bidders can also create and add uMail messages from the RFB form. The To field is auto-populated with the requestor name. The Cc and Bcc buttons are not available; however, bidders can fill in external Cc and Bcc fields with external e-mail addresses. When bidders reply or forward uMail messages, these will be linked with the record.

Bidders will not be able to create any new uMails after the bid due date.

**Attaching External Emails From The Project Or Shell Mailbox To A Record**

Primavera Unifier collects all external emails it receives for a project or shell in a dedicated mailbox. You can attach these external emails directly to a business process record. Other users can view the email from a link on the record. A single email can be attached to more than one business process record.

External emails that have been blind copied (Bcc’d) are not collected by the Mailbox.

**To attach an external email to a record**

1. Open the business process record to which you want to attach the email.
2. Click the Linked Mail link at the bottom of the form. The Linked Mail window opens.
3. Click Add and choose Project/Shell Mailbox. The Project (or Shell) Mail window opens, showing a list of the external emails that have been received for the project or shell.
4. Select the email you want to attach to the record, and click Attach. Primavera Unifier adds the email to the Linked Mail window.
5. To close the Linked Mail window, click Close Window.

**To open an external email attached to a record**

1. Open the business process record.
2. Click the Linked Mail link at the bottom of the form. The Linked Mail window opens, showing the emails that are attached to the record.
3. Select the email you want to view and click Open. Primavera Unifier opens the email.
   
   From this email window, you can:
   
   - Reply to the sender
   - Forward the email to others in the project or shell
   - Flag the email for follow-up
   - Delete the email
   - Print the email

   **Note:** You must have permissions to view, reply to, or delete external emails.

**To see other records an email is attached to**

1. Open the business process record.
2. Click the Linked Mail link at the bottom of the form. The Linked Mail window opens, showing the emails that are attached to the record.
3. Select the email you want to view and click Open. Primavera Unifier opens the email.
4. Below the Subject line is a link with the label:
This uMail and any future replies are linked to records. Show list

5 Click the Show list link. Primavera Unifier opens the Linked Business Processes window, which shows a list of all business processes to which this email is attached.

You can open any of the listed business processes by selecting the record and clicking Open.

6 To close the Linked Business Processes window, click Close Window. Primavera Unifier returns to the email.

7 To close the email, click the X icon in the upper-right corner of the window.

Adding Or Viewing A Map (geocoding)

If the functionality is configured in Primavera uDesigner for a business process, you can add an interactive map to a record. The location will be based on a property address, and/or longitude and latitude (Geocoding). You can add or view maps from the upper form of these business process types:

- Line item
- Simple
- Text
- Document
- Cost (classification generic)

Maps are supported on company, project, and shell-level BPs. You can also search for a map by an address or longitude or latitude.

To add a map to a business process

1 Click the globe icon next to the Latitude and Longitude fields. The Latitude/Longitude picker window displays with a map that you can manipulate as needed.

2 Do one of the following:
   - Enter the address of the property to compute the latitude and longitude, and click the Map It button.
   - Enter the numbers for latitude and longitude in degrees, or in degrees, minutes, and seconds, and click the Map It button.
   - Click on the map to compute latitude and longitude. A map pin displays the location of your click.

3 Click OK when finished computing latitude and longitude. Latitude and longitude are populated in the corresponding fields on the BP in decimal degrees.

4 If you click the globe icon again, the latitude and longitude values are displayed in the Latitude Longitude picker window and are retained there until you calculate a new latitude and longitude. A map pin on the map indicates the location of the property represented by the current latitude and longitude displayed in the picker.

To view maps from the business process log

1 Navigate to a business process log.

2 Select one or more records.

3 Click View Map. A map opens displaying the various locations that are mapped, indicated by map pins. If the locations indicated on the map are far apart, the map zooms to the closest location.
4 Click a map pin for location details.

5 Click Close to close the map.

**Note:** If multiple records are selected that have the same latitude and longitude, the map will show only one pin marker.

**To view a map for a specific business process record**

1 Navigate to a BP record and click View Map. If the BP has latitude and longitude address details, a map opens displaying the property location, indicated by a map pin.

2 Click the map pin for location details.

3 Click Close to close the map.

**Adding An Image**

In many forms, you can add an image to your project or shell. For example, you can add an image that shows progress on the project or shell information record, pictures of assets related to a specific asset record, or a photo of an employee in the Resource Manager. You can add images to attribute forms in shells, project or shells, companies, and business processes.

If the Image picker functionality has been added to your project or shell in Primavera uDesigner, forms with the functionality display the image name and a virtual box that will hold the uploaded image.

**Note:** The image name is based on the data element name provided in Primavera uDesigner.

**To add an image**

1 Click Upload Images in the toolbar at the top of the form.

Valid image file types are:

- .jpg
- .jpeg
- .gif
- .png
- .tif

2 Browse for the image to upload and click OK.

You can change the image by replacing it with another uploaded image. Images appear on the HTML or PDF formats of printed forms. They appear in print preview as well. The Image picker can be added to all forms except for those in the Cost Manager, Generic Cost Manager, Schedule Manager, and the Document Manager.

**Note:** The image appears online in Primavera Unifier, but it is not available for printing. Also, images do not appear in UDRs or e-mail notifications.
Adding A Hyperlink

In many forms, you can add a hyperlink to your project. For example, you can add a hyperlink to equipment documentation, details on a resource, or external websites that contain information pertinent to a BP record. You can add hyperlinks to attribute forms in shells, projects, companies, and BPs.

If the Hyperlink picker functionality has been added to your project in Primavera uDesigner, forms with the functionality display a hyperlink name, such as vendor website.

To add a hyperlink

1. Click on the hyperlink area on the form. The Hyperlink window displays:
   - Enter the hyperlink name and the URL. Only the URL is mandatory. If you enter the name and the URL, the hyperlink displays as the name you entered. If you enter the URL only, the hyperlink displays as the URL. The protocols HTTP and HTTPS are the only protocols allowed. FTP is not supported for hyperlink creation on forms.

   **Note:** The URL should not reference the same domain that Primavera Unifier is using for operation. If you attempt to use the same domain, a warning message will result.

3. Click OK.

To reset a hyperlink

1. Click on the hyperlink area on the form. The Hyperlink window displays.
2. In the Hyperlink window, click Clear. This will remove the existing hyperlink.
3. Enter a new hyperlink name and URL.
4. Click OK.

Viewing Referencing Records

For any business process with referencing records, Primavera Unifier can show you a Reference Records window that displays a graph and a list of the records that the record you are viewing refers to, as well as those records that refer to the record you are viewing. (To see the records, you must have view permissions.)

For example, you might want to view all the change orders that refer to a particular purchase order. For other examples, you could view:

- All the invoices that a commit business process refers to so that you can reconcile all the invoices against the purchase order
- All the change order requests that are referred to by a specific change commit business process in order to track the progress of a construction project
- All the lease payment requests that refer to a Master Lease, in order to view and reconcile all payment records for a lease
- All the base commits that are referred to by a vendor record in order to review payment progress
- The work order BPs that a preventive maintenance BP refers to in order to track the monthly maintenance on a corporate auto fleet.

Business process records can reference other records and be referenced to using the following Primavera Unifier features:
• A BP picker on a business process record, including line items
• A BP line item picker on a business process record
• Auto-creation of a record through the workflow (S-Step)
• Auto-creation of a record through meeting specific criteria set up by your administrator
• A data picker

View A List Of Referencing Records

To view a list of referencing records

1. From the business process log, open the record.

The Reference Records window is split into two sections, a graph and a list. The records shown on this window include records from across shells.

The graph displays:

• Records that the business process references (i.e., references to other business processes)
• Records that reference the business process (i.e., other business processes that reference the BP you are looking at)

The list displays:

• Records that the business process references (i.e., references to other business processes)
• Records that reference the business process (i.e., other business processes that reference the BP you are looking at)
• Records that have been linked to the business process via the Linked Records feature (See “Linking Business Process Records” on page 265)
• Line items that have been linked to the business process via the Linked Records feature.

Note: This list will not display single-record business processes.

What You Can Do On The Reference Graph Window:

• Enlarge the graph pane

You can enlarge this half of the window by placing the cursor between the two windows and dragging the cursor right. You can also use the expand icon on the title bar:
View high-level record information

When you first open the graph, it displays a total of five levels:

- The original record you opened (shown in blue)
- Two levels “up” (that is, two record levels that refer to the original record)
- Two levels “down” (that is, two record levels that the original record refers to)

The graph does not indicate the direction of the up or down levels; only that the records are connected.
Expand the graph
You can expand the graph display in two ways:

- By individual record
- Using the Expand button

If you expand the graph using the Expand button, Primavera Unifier will display all records that are directly and indirectly connected to the original record you opened. This means that all records will be expanded through all levels. It may take a moment to gather and display all the records.
• Collapse the graph

• Center a record or a record node on the graph

There are several ways to center a record or record node on the graph:
• Zoom in or out on the graph
• Move the display (convenient for large graphics)
• Rearrange records (convenient for large, crowded graphs)

You can segregate records for easier viewing by dragging them to any point on the graph.

• View or edit a record (if you have permissions)

From the graph, you can open a record and view it. In addition, if you have permissions, you can edit and take action on the record the same way you would by opening the record directly from a Primavera Unifier log. When you finish the edits and close the form, Primavera Unifier will return to the Reference Graph window. The records you can edit must be at the same level as the focused record. If the referenced record that you open from the graph resides at another level (such as in a different shell, project, or at the company level), you will not be able to edit it; it will open in view mode only, regardless of your permissions.

A few things:

If you make changes to the record (including referencing links, linked records, title, status, etc.), the graph and the reference list on the right pane will not reflect these changes until you click the Expand, Collapse, Reset, or Transfer Focus buttons.

The edits and actions you take on the form from the Reference Graph window will behave in the same way they would if you opened the record from a log; that is, roll-ups will occur, workflow actions and auto-creations will proceed, email notifications will be sent, etc.

If you have only view permissions, regardless of where the record is in the workflow, Primavera Unifier will display the view form from the End step of the workflow.
• Transfer the focus of the graph to another record and its references
You can change the focus of the graph to another record and display all of its referencing records. The record you transfer to will change to blue to indicate that all referencing records shown on the graph are now connected to the new record. In addition, the list on the right panel will change accordingly. The new focus of the graph will display five levels of records:
  • The record you transferred the focus to (shown in blue)
  • Two levels “up” (that is, two record levels that refer to the new record)
  • Two levels “down” (that is, two record levels that the new record refers to)
What You Can Do On The Reference And Linked Records Window

• Enlarge the list pane
You can enlarge this half of the window by placing the cursor between the two windows and dragging the cursor left. You can also use the expand icon on the title bar:

• Rearrange the columns
To present the information in a way that is more convenient to you, you can rearrange the columns of the list by dragging them left or right.
• View high-level record information
The list of records shows the following information:

<table>
<thead>
<tr>
<th>This column</th>
<th>Displays this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Displays <strong>Ref.</strong> if the record is&lt;br&gt;• Referred to by the original record you opened, or&lt;br&gt;• Referring to the original record you opened&lt;br&gt; Displays <strong>Link</strong> if the record is linked to the original record via the Linked Record feature.&lt;br&gt;Displays <strong>Link to Line</strong> if the record is linked to a line item on another business process.&lt;br&gt;Note: If the record is both a referenced record and a linked record, Primavera Unifier will show it as a referenced (“Ref.”) record, not a linked record.</td>
</tr>
<tr>
<td>Ref No.</td>
<td>Displays the number of the record.</td>
</tr>
<tr>
<td>Title</td>
<td>Displays the title of the record.</td>
</tr>
<tr>
<td>Business Process</td>
<td>Displays the name of the business process to which the record belongs.</td>
</tr>
<tr>
<td>Status</td>
<td>Displays the status of the record. Records in a terminal status will also appear on this list.</td>
</tr>
<tr>
<td>Description</td>
<td>For links to line items on a record, this column displays the line number, the short description of the line item, and the tab. For line items from a Document type BP, the column shows the name of the line item.</td>
</tr>
<tr>
<td>Creation Date</td>
<td>Displays the date the record was created.</td>
</tr>
</tbody>
</table>

- **Filter the list of records**
• View or edit a record (if you have permissions)
From the Reference and Linked Records list, you can open a record and view it. In addition, if you have permissions, you can edit and take action on the record the same way you would by opening the record directly from a Primavera Unifier log. When you finish the edits and close the form, Primavera Unifier will return to the Reference and Linked Records window. The records you can edit must be at the same level as the focused record. If the referenced record that you open from the list resides at another level (such as in a different shell, project, or at the company level), you will not be able to edit it; it will open in view mode only, regardless of your permissions.
Contrary to the graph, you can also open and view or edit linked records (if you have permissions).

A few things:
• If you make changes to the record (including referencing links, linked records, title, status, etc.), the graph and the reference list will not reflect these changes until you click the Expand, Collapse, Reset, or Transfer Focus buttons.
• The edits and actions you take on the form from the Reference and Linked Records list will behave in the same way they would if you opened the record from a log; that is, roll-ups will occur, workflow actions and auto-creations will proceed, email notifications will be sent, etc.
• If you have only view permissions, regardless of where the record is in the workflow, Primavera Unifier will display the view form from the End step of the workflow.
• **Transfer the focus of the list to another record and its references**

You can change the focus of the list to another record and display all of its referencing records. In addition, the graph will change accordingly. You cannot transfer the focus to linked records; only referenced records.

The new focus of the graph will display five levels of records:

- The record you transferred the focus to (shown in blue)
- Two levels “up” (that is, two record levels that refer to the new record)
- Two levels “down” (that is, two record levels that the new record refers to)

---

**Spell-Checking A Form**

The spell check feature is available for all BP forms, including cost, document, text, simple, and line item. You can spell-check information that you have entered in text fields and any other text areas.
To spell check a business process form in Primavera Unifier

1. Open a business process form at the project or shell or company level.
2. Click the Spell Checker button on the toolbar of the BP form. All form fields will be checked.
3. Make spelling corrections as necessary and click OK.

The Spell Checker icon is also available if you click the Comments button of a BP form.
PARTICIPATING IN A WORKFLOW

You will be participating in a workflow if:

- You are part of a business process team on a workflow step and you must take some type of action on the business process.
- You have been requested to join a discussion group by another user who wants input before completing a task in a workflow.

This section explains how to accept (or decline) a task, complete the form and send it on, perform bulk actions on multiple business processes, and participate in discussion groups.

About Completion Policies, Resolving Actions, And Their Statuses

Your administrator sets a “completion policy” on each step in a workflow. This policy determines when the step is complete and where the step proceeds from there. A step can be complete under the following conditions:

- Any single user can accept a task and complete it, and the record will move forward to the next step. This is called a single completion policy.
- All assignees to the task have responded to it and a majority has agreed on the action that moves the record forward to the next step. This is called an all-majority completion policy. If there is no clear majority on the action, Primavera Unifier will use a resolving action to determine how the record moves forward.
- All assignees to the task have responded to it and all assignees have agreed on the action that moves the record forward to the next step. This is called an all-consensus policy. If there is no consensus on the action, Primavera Unifier will use a resolving action to determine how the record moves forward.

A resolving action moves the step to either a following step, a previous step, or a conditional step that essentially “re-addresses” or "revisits" the task. This step must be completed before the workflow can continue. The assignees on this resolving action step can include the original task assignees and can also include new assignees.

**Statuses**

The statuses you see on this window are internal to Primavera Unifier and are used only to display the status of the workflow step relative to the completion policy. These statuses are:

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not Started</td>
<td>The assignee has not accepted the task.</td>
</tr>
<tr>
<td>In Progress</td>
<td>The assignee has accepted the task.</td>
</tr>
<tr>
<td>Locked</td>
<td>This status is used when the step has a single completion policy and one of the assignees accepted the task. This status denotes those assignees who were also assigned to the task, but because of the single completion policy, the task was locked and these assignees no longer have access to it.</td>
</tr>
<tr>
<td>View Only</td>
<td>This status indicates that this user was cc'd on the task, but is not expected to take action on the task.</td>
</tr>
</tbody>
</table>
### Status Description

- **Completed**
  
  This status is given to an assignee’s action if the task was finished and needed no resolving action. At any step, a task can have only one status of “Completed.”

- **Closed**
  
  This status is given to an assignee’s action if the task was finished, but triggered a resolving action. The task will either return to a previous step, move forward to a next step, or divert to a conditional step, which will resolve the condition and move the task forward in the workflow. The step the action moves to for resolution will show a status of “Not Started.” The number of times the task shows a “Closed” status indicates the number of times the step has been revisited.

To illustrate:

![Tasks for the selected step](image)

This status indicates a resolving action case. Morris Stanley completed the task, but the result triggered a resolving action in the workflow, so Unifier put the task in a “Closed” status, rather than “Completed,” and re-opened the task with a status of “Not Started.”

Morris Stanley was also an assignee on the resolving action. He completed the task, and no resolving action was triggered, so the status of the action is now “Completed.”

---

### About Email Notifications For Business Processes

Email notifications are designed in Primavera uDesigner and set up by the Primavera Unifier Administrator. To initiate this feature for yourself, you need to set up an option in your user preferences that specifies that you wish to receive these notifications. (See “Select email subscription options” on page 25.) Once you make this specification, you will be notified whenever a business process to which you have been assigned is created, modified, or closed.

In addition, if you are creating or editing a business process that has been set up for email notifications, you can notify additional users or groups at your discretion.

**E-mail notifications for workflow business processes**

You may be notified by e-mail when you have a new task, if you are late responding to an assigned task, if you have been requested to join a BP discussion group, you are an editor on the task (in which case, you receive notification each time a draft is created), or if you were the creator of the BP and someone has taken action on their task.
Depending on your company’s Primavera Unifier e-mail notification setup and your own user preferences, you may receive such e-mails one at a time as the task is generated, or you may receive one daily e-mail digest summarizing all of the day’s e-mail notifications (including non-BP related notifications).

**Note:** E-mail notifications can be configured in your user preferences.

**If you receive an e-mail notification**

You may receive BP-related e-mail notifications for the following:

- You have a new task. A task can be generated if you need to take action on a BP workflow step, or if you have been requested to be part of a BP discussion group. Click on the hyperlink at the bottom of the e-mail. When you click the link, you will be directed to the Primavera Unifier Login screen. Once you log in, Primavera Unifier will display the record, where you can complete the form and send it to the next step.
- You are late responding to an assigned task. The actions you can take are similar to when you have a new task.
- You are the owner or creator of the BP and someone has taken action on their task. This is a notification only and no action is required.
- You are an Editor on a task (you receive notification each time a draft is created).
- You are designated as an active proxy user, and the user you are acting for has received a task.
- A BP workflow has been completed. This is a notification only and no action is required.
- You have to take action during a BP workflow.

**E-mail notifications for non-workflow business processes**

Your company may require that non-workflow business processes be acknowledged when they are created, modified, or closed (terminated).

What the email looks like. Email notifications for non-workflow business processes include the fields from the business process that were chosen to appear on the email. The notification also includes a link you can click that will open the record for you to view.
When you click the hyperlink, you will be directed to the Primavera Unifier Login screen. Once you log in, Primavera Unifier will display the record, where you can complete the form and send it to the next step.

The email will display summary information, such as:

- What record was created
- Which upper form fields have been modified
- Comments that have been added to the BP or a line item
- Line items that have been added, edited, or deleted
- General comments that have been added to the record (excluding any hidden comments)
- Attachments that have been added or removed

### Completing Tasks In Primavera Unifier

After a workflow BP has been created and sent, Primavera Unifier adds the record to the business process log with a status of pending, which refers to the status of the next step. In addition, Primavera Unifier creates a task for each of the assignees in the next step in the workflow, and sends a message to each user that has been cc’d.

If you are designated as an assignee on a task, you will receive an e-mail notification, and the task will appear in your Tasks log. You must accept a task in order to complete it.

You can accept a task in two ways:

- By opening a record from a business process log
- By opening a task from your Tasks log

**Note:** If the project or shell in which a business process resides becomes View-Only, any in-process records will be placed on the View form of the current step of the workflow. If the project or shell is re-activated, the business processes will revert to the Action form.
Open And Accept A Task

You can open and accept a task from either a business process log or your Tasks log. You can also open and automatically accept tasks from your Tasks log.

If This Is An Initiation Step

If this business process has been auto-created and sent to an Initiation Step, you will usually need to select a workflow schema to launch the business process into the workflow. When you accept the task, Primavera Unifier will display a Select Workflow window, where you must choose the workflow schema this business process should use.

Primavera Unifier will not display the Select Workflow window if:

• This is a non-workflow business process.
• There is only one workflow schema you can choose for this business process.

To open and accept a record from a business process log

1. On the business process log, select the record and click the Open button. The business process form opens for viewing.

2. Click the Accept Task button. The form becomes editable. In some cases, you may have the option to decline the task. See “Decline a task” on page 294.

To open and accept a task from your Tasks log

You can open one or multiple tasks from your Tasks log and automatically accept them (that is, you do not have to open them individually and click the Accept Task button). If you choose this option, Primavera Unifier opens the record(s) in “accept” mode. You can also filter the tasks you want to open and accept automatically. See “Filter the list of tasks for bulk actions” on page 196.

1. To open and accept tasks, select the task(s), click the Bulk Actions button, and choose With Preview.

Primavera Unifier opens the business process form in edit mode. Once the task is open and accepted, you can edit the form.

When the process is complete, Primavera Unifier will automatically open the next task you selected. The remaining selected tasks will remain highlighted so you can see how many tasks are yet to be opened.

Note: Finish the bulk action before you change focus. When you use this particular bulk action, Primavera Unifier is in a waiting state, ready to open and accept the next record you selected. Do not move to another area of Primavera Unifier until the you have completed this bulk action. If you do, Primavera Unifier will cease the Bulk Actions With Preview operation, and the rest of the records you selected for this action will not be opened and accepted.

2. For every task that Primavera Unifier opens, complete the form using the instructions under See “Complete the form”.

Every task you complete will be deleted from the Tasks log. Those you do not complete will remain on your Tasks log.
**Task Notifications**

- If the task belongs to the Create step of a workflow, you will receive a message confirming that the record was (or was not) created successfully.
- If you open a task from a project/shell that is on-hold, Primavera Unifier will notify you and delete the task from the log.

---

**Undo Accept Task**

If you change your mind after accepting a task, you can use the **Undo Accept Task** option.

With some exceptions, Undo Accept Task will restore the BP form and data back to the state it was in just prior to accepting the task, even if you have made some modifications to it. This applies only to additions or changes made between accepting the task and selecting Undo Accept Task. Undo Accept Task is not available for Initiation Steps.

Undo Accept Task will roll back the following to their previous state:

- Changes to upper form fields
- Auto-populated fields
- Changes to the action details (To and Cc fields)

Any new additions of the following are removed:

- Summary, detail, or imported line items
- Task notes
- Comments
- File attachments
- Linked records

These changes are not rolled back:

- Changes made to existing line items.
- Anything that is deleted, such as attachments, linked records, linked uMails, and line items, cannot be restored. The exception is upper form fields, which will be restored to their previous state.
- Transfer ownership.
- uMail messages sent through linked uMails.
- Discussion group activity.

**To unaccept a task**

1. After accepting a task, select **Actions > Undo Accept Task** from the BP record. A confirmation window will open.
2. Click **OK**. The BP record data will revert back to its state prior to accepting the task. Any changes or additions you have made, with the exception of those items discussed above, will be lost.

**Note:** When you unaccept a task, Primavera Unifier returns the record to its state prior to your accepting the task, but the record remains open. However, using the **Bulk Actions > With Preview** option, you can automatically open and accept multiple records. If you use this option and then “unaccept” one of the tasks, Primavera Unifier will close that record and continue to the next record you selected.
Decline A Task

Sometimes you have the option of declining a task. If you are the only person assigned to a step in the workflow or if the creator of the workflow has not granted permission to decline a task, this is not an option.

To decline a task

1. From your Tasks log, select the BP record and click Open. The business process form opens.

2. Click the Decline the Task button.

   If you have permission to decline the task, the task will be removed from your Tasks log and the record returned to the sender.

   If you do not have permission or are the only person assigned the task, an alert message will display, informing you that you cannot decline the task.

Complete The Form

To complete a business process form

1. Review the form carefully. If you have the proper permissions, you can perform the following functions, as long as the BP is set up for them or is of the proper type to accommodate them:
   - Make changes or additions in editable fields of the BP.
   - Add, edit, or remove line items or summary line items (See "Adding and Managing Line Items" on page 235).
   - Add or view file attachments (See "Working with File Attachments and Markups" on page 260).
   - View or add general comments (See "Adding and Managing General Comments" on page 253).
   - Add or review graphic markups to an attached document (See "Add or view graphic markups to a business process attachment" on page 264).
   - Provide a link to another completed BP form. Other participants will be able to click on the link and view the referenced BP form (See "Linking Business Process Records" on page 265).
   - Initiate or participate in a BP discussion group (See "Participating in a Discussion Group" on page 299).
   - Consolidate discussion group comments.

2. In the Action Details area of the form, designate the next assignees (users and groups) who will receive the next step in the workflow as a task. (See "Assign users to the next step" on page 295.) You can choose the next users to send the BP to if the BP has been set up this way. Some BPs have a fixed workflow. If this is the last step in the workflow, this is not applicable.

   You may also be able to designate the task due date for the next assignees. (See "Modify step due date" on page 296.)

   You may also add task notes for the next participants in the workflow. Task notes apply to the next workflow step only and are not stored with the permanent record. (See "Add or view a task note" on page 297.)

3. When you have completed any necessary edits or additions, select an action or workflow action from the Workflow Actions drop-down list. The action you take depends on the task assigned. For example, if this is a review step, an action that you may be able to take is “approve.”

4. Click the Send button.
- If the workflow is not yet complete, the form will be forwarded to the next team members in the workflow.
- If the workflow is complete (that is, your input was the last step of the workflow), the record will appear as complete in the business process log.

**Tip:** You can also save your work as a draft at any point. This is recommended if you are going to leave your desk or have a lot of work to do on it. There is no autosave.

If you change your mind after making a selection, click the **Undo Action** button, and then choose another action.

After you have accepted the task or initiated an action, you can still review what you received prior to doing so without having to undo. Click **View > Received** or the **Click here to view latest content**. Primavera Unifier displays another pop-up window of the original record as you received it.

---

### Assign Users To The Next Step

Depending upon the workflow configuration and your user permissions, you may select one or more users or groups to whom the form will be sent as the next step in the workflow. The assignee fields are:

- **To:** The users or groups that you choose will be assigned the next task in the workflow. Team members listed will receive an e-mail notification of the task. This can include users designated as Editors on the task, as well as proxy users.
- **Cc:** These users and groups receive an e-mail notification and a copy of the BP record in their Message log. They can review the record, but cannot take action on the workflow.

Depending on the workflow setup, you may also be able to set the due date for the next step.

**To assign team members to the next workflow step**

In the Assignee portion of the BP form, click the **To** button. The User/Group picker opens. To use the picker, see the information under See “The User/Group Picker” on page 173.

When the business process form is sent, each member will receive an e-mail message regarding their task assignment and a copy of the BP form in their Tasks log.

**To send a copy of the business process form to another user**

1. Click the **Cc** button. The User/Group picker opens.
2. Follow the assign team members procedure to select users or groups.
3. Click the **OK** button.

The selected users or groups appear in the **Cc** field on the form.

When the business process form is sent, each member will receive an e-mail message and a copy of the BP form in their Messages log.

---

**Note:** The BP form may be set up to have pre-assigned Cc users. In this case, if the **Cc** button is enabled, you can add additional Cc users. If not, the BP is not set up to allow additional Cc users. You cannot remove pre-assigned Cc users.
Modify Step Due Date

If the step duration and workflow override are enabled on the BP, you can also set the task due date for the next step.

To change the task due date

1. Click the Calendar icon next to the To field. The Task Due Dates window opens.

2. Choose one of the following options:
   - Set all task due dates as: Lets you set the same due date for all assignees.
   - Set individual task due dates: Allows you to assign different due dates for each assignee one at a time.

3. Click the Calendar icon corresponding to the option you chose. For the second option, click the Calendar icon next to each user’s name on the list. The Date picker opens.

4. Select the month and year, and then click the date you want to select.

Note: The workflow engine uses the company workday calendar. Grayed-out dates are those that have been set as non-working days (for example, weekends and holidays) by your company administrator. You cannot select non-working days for a task due date.

Add Additional Assignees Or Send An Additional Copy

If you are a task assignee or BP owner, you can add additional assignees to a task or copy additional users after the BP record has already been sent and before the next step has been accepted (that is, while the BP is still in view form). This is useful if you want to send a copy of the record or add another assignee before you take action on it.

You can add additional assignees or copy users if:

- You have not yet accepted the task, and the form is still in view form. If you have already accepted the task, you can reverse the action by clicking the Actions menu and selecting Undo Accept Task.
- The BP workflow has been set up to allow adding assignees or allowing to cc.

To add an additional assignee to a task

1. From your Tasks log or a business process log, select a record and click Open. The form opens for viewing.

2. Click the Edit menu and choose Add Assignees to Current Step. The User/Group picker window opens. The list displays the list of users or groups that can be assigned, according to the BP setup.

3. Select the users or groups from the picker window and click OK.

The user or group will be added to the list of assignees. The record will appear in each new user’s Tasks log and applicable BP log, and users will receive an e-mail informing them of the task, depending on their e-mail subscription preferences.

To send a copy of a business process to additional users

1. From your Tasks log or a business process log, select a record and click Open. The BP form opens for viewing.

2. Click the Edit menu and choose Copy Users to Current Step. The User/Group picker window opens. The list displays the list of users or groups that can be copied according to the BP setup.

3. Select the users or groups from the picker window and click OK.
The user or group will be copied. This means that the record will appear in each new user’s Messages log and applicable BP log, and the users will receive an e-mail informing them of the copy, depending on their e-mail subscription preferences.

**Add Or View A Task Note**

Notes that are specific to a task can be added to a BP form. They are temporary notes that can be used as comments or specific instructions to the next user in the workflow. Task notes are not forwarded throughout the workflow and are not archived. You can think of them as sticky notes that stay with the form for one step in the workflow only.

A task note only applies to the current task. If you are part of the current task and a task note is present, be sure to take notice. The task note will not be included in the rest of the workflow. If a task note is present, a “(1)” will display by the Task Notes field in the Action Details section of the BP.

**To add a task note to a business process**

In the Action Details portion of the BP, click the Task Notes icon. The Add Notes window opens. Enter the text for the task note and click OK.

**To view a task note**

If a task note is present, click the (1) next to the Task Notes icon in the Action Details portion of the BP. The Notes window opens displaying the note and the user who created it.

When you click the Accept Task button, the BP form becomes editable and the Task Notes field will clear. If you want to review a task note but have already accepted the task, you can click the View menu and choose Received or click the link Click here to view latest content in the Action Details section. Another window opens displaying the record as you received it, with the task note intact.

**Completing Tasks Via Email**

You may receive BP-related e-mail notifications that contains hyperlinks that represent actions in a BP workflow.

Actions you can take via e-mail are shown as hyperlinks and represent actions you can take in a workflow step. When you click the hyperlink, an e-mail reply is generated. Your reply text becomes a general comment in the BP record, except in the case of Document Type business processes; reply text is not attached for those business processes. Assignees need to be pre-assigned on the workflow steps for the e-mail workflow action to occur. Attachments can be included in the workflow action replies if the BP is set up to include them. E-mail clients supported for workflow actions via e-mail include HTML and text. If you are using a text client for your e-mail, the possible actions are listed, but are static text (not hyperlinks). In that case, you can reply to the e-mail manually and provide the appropriate To, Subject, and body text. Your subject should be the name of the action you want to take as shown in the e-mail notification.

Your subject should be the name of the action you want to take as shown in the e-mail notification.

Tasks that are assigned to you are listed in your Tasks logs. The Tasks logs display business process-related tasks in which you are being requested to participate. The following tasks may appear in your Tasks logs:

- You are part of a business process workflow and are requested or required to take some sort of action.
- You have been invited to join a discussion group by another user who is requesting assistance with drafting comments or markups on a BP. These are indicated as being sent for “Discussion” in the Tasks log.
• You are designated as the Initiation step assignee for an auto-created business process.

Validation for e-mail task flow actions are as follows:

• Email address must match that of the assignee
• Valid Notification ID/Password (NID)
• Active (Primavera Unifier) User
• BP record has not moved or been terminated
• Record has not already met completion policy
• Assignees must be Preassigned at the destination step

To respond to a workflow task directly from e-mail

1. Open the e-mail notification.

If Response via email has been enabled in the business process design, the e-mail includes action links. The e-mail message also displays data from the business process form.

2. To take action, review the e-mail, then click an action link. In an e-mail program such as Outlook, this will create a response e-mail.

**Note:** (1) Do not change the subject line of the e-mail. Changing the subject line text will cause the e-mail response to fail. (2) If you are using a text client for your e-mail, you can open a new e-mail message, copy the subject line of the notification, and paste it into the subject line of the response e-mail.

3. You can add text to the body of the e-mail. This will create a General Comment on the business process record.

**Note:** E-mail response text is not saved as General Comments for Document Type business processes.

4. You can add file attachments to your e-mail response.

If the business process has been set up to accept attachments, they will be added to the record in Primavera Unifier. If the business process does not allow attachments, then attachments you add to the e-mail response will be ignored. If a file already exists on the record with the same name as the file you are trying to send, then your attachment will be ignored.

5. Send the e-mail, which will send the action to Primavera Unifier.

Taking Action On Multiple Tasks At The Same Time (Bulk Action)

If you have a large number of projects or shells with numerous business processes in the same state, you can use bulk workflow actions to update the workflow on all of the records at once. You can update the workflow actions from your Tasks log or from any log produced by the Find feature. You can update a maximum of 200 records using bulk workflow update.

Some things to note:

• Only the upper form is modified during bulk workflow actions.
• Bulk workflow actions are not supported on tasks that are on the Initiation step.
• You must have Allow Bulk Edit permission for each area where the bulk action is to be performed (Company or project/shell).
• Some business processes do not support integration; since the integration engine is used for bulk action, these business processes will not have bulk action available.
To take action on multiple records

1. Navigate to a Tasks log.

2. Select one or more tasks to work with, or perform a Find for tasks of certain criteria and then select tasks that are in the same workflow stage. You can select tasks from the Tasks log or the Find log.
   Use the Type (combination of the BP name and workflow name) and Sent For search criteria to help narrow your search for similar task records. Be sure that the group of tasks that you select:
   • Are of the same type
   • Have the same workflow schema
   • Are waiting on the same workflow step
   Bulk workflow processing will be successful only if these criteria match for all selected tasks.

3. Click the Bulk Actions button and choose Without Preview. The Bulk Action window opens. The fields displayed in this window depend on what step of the workflow the tasks are in.
   The Bulk Action window includes all editable fields for the task. The Workflow Actions menu shows the actions available for the next step in the workflow for the tasks that you are updating.

4. In the Bulk Action window, edit the fields that you want to update the form with.
   Primavera Unifier automatically selects the Update checkbox when you type into or modify a field. You can deselect it if you do not want to modify the field at this time.

5. Select a workflow action and click Send. The workflow tasks that you have updated are sent to the next step in the workflow.
   The Bulk Actions Status window opens when you click Send. This window allows you to monitor the progress of the bulk workflow update.

6. Click OK after all records have processed. Click Cancel if you want to cancel the bulk update in progress.

Participating In A Discussion Group

Any user who is part of a business process workflow can initiate a discussion group to solicit input from other project or shell team members. Eligible participants are pulled from the business process’ “add assignee” list. Invited members of the discussion group can contribute their own text comments and graphic markups.

Note: You cannot participate in a discussion group on the Create or End steps of a business process.

The task owner can select which, if any, of the comments and markups to use in creating final comments or markups for the task. The task owner can hide or delete these comments or consolidate them for use in creating the final comment or markup.

To consolidate comments received in a discussion group into a single, cohesive comment, See "Copying and Consolidating Comments and Markups" on page 301.

A discussion group can take place in one of two places:
   • The General Comments section of any cost, line item, or document BPs.
   • On individual documents that are part of a document-type BP document list.

Discussion groups end at the discretion of the task owner or when the task is completed.
Initiate A Discussion Group

You can initiate a discussion group during any step in the workflow except the creation step.

To initiate a discussion group in general comments

1. Open a BP form and click the Discussion button. The Discussion Group Invitation window opens.
2. Give a name to the discussion group.
3. Click To and choose the users to include in the discussion group. This list is generated from the discussion group list on the workflow setup of the BP.

Note: To include users who are not part of the original BP workflow, you must first add them to the discussion group list. The workflow must be set up to allow this, and you must have the proper permissions.

4. In the Discussion Notes text field, write a description of the assistance or input you are asking for from the participating members of the discussion group.
5. Click Send.

The receivers get a task in their Tasks log and an e-mail message. The subject of the e-mail will show the record number of the BP and the phrase “is sent to you for discussion.” When the receiver opens the form, only the comments section is editable.

When users respond to a discussion group, the discussion group owner is notified by e-mail.

To initiate a discussion group on a particular document in a document-type BP

Open the document-type BP form. Select the document from the document list on the form. Click the Discussion button and follow the procedure to initiate a discussion group.

Close A Discussion Group

When a discussion group is closed, all invited participants will receive an e-mail notification.

To close a discussion group

- The initiator can close the discussion group at any time by clicking Close. This will remove the task from each receiver’s task log, regardless of whether they have completed it.
- Discussion groups are closed automatically when the task in which the discussion group had been initiated is completed, regardless of the status of the discussion group comments.

Participate In A Discussion Group

If you are invited to join a discussion group, a new task will appear in your Tasks log, and you will receive an e-mail message. The Sent for column of the Tasks log will indicate “discussion,” distinguishing it from workflow-related tasks.

To participate in a discussion group in comments

1. From the Tasks log, select the discussion group business process and click Open. The form will be view-only, except for the comments area.
2. Click General Comments. Add text comments.
To participate in a discussion group on a document-type BP

1. From the Tasks log, select the discussion group BP and click Open. The BP form will be view-only, except for the comments and document list.

**Note:** Pay particular attention to the Discussion Notes area of the Action Details portion of the form. This is where the owner of the discussion group will add information regarding what input is needed and the documents that need review.

2. Select the document to comment on and click Comments. Add text comments and graphic markups.

**Copying And Consolidating Comments And Markups**

These procedures are useful for consolidating comments and markups received during a discussion group, but can also be used anytime you want to copy or consolidate comments or markups on a BP attachment.

When you copy and consolidate comments, all attachments to comments will display as attachments to the consolidated comment. All graphical markups will also be copied and included in the new consolidated comment in a separate, editable markup layer.

You can also consolidate graphic markups made to documents that are attached directly to the BP form (that is, documents attached in the lower portion of a document-type BP, or documents attached directly to the BP form).

You can copy and consolidate text comments in general comments, but not graphic markups to file attachments added to a general comment. The following table summarizes:

<table>
<thead>
<tr>
<th>BP Feature</th>
<th>Consolidate Text Comments</th>
<th>Consolidate Graphic Markups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents attached to document-type BPs</td>
<td>Can copy and consolidate comments made directly to attached documents</td>
<td>Can copy and consolidate graphic markups on attached documents</td>
</tr>
<tr>
<td>File attachments: all BP types</td>
<td>Can copy and consolidate comments made to files attached directly to BPs (listed in the Attachments link)</td>
<td>Can copy and consolidate markups made to files attached directly to BPs (listed in the Attachments link)</td>
</tr>
<tr>
<td>General comments</td>
<td>Can copy and consolidate general comments</td>
<td>Cannot copy or consolidate markups on files attached to a general comment.</td>
</tr>
</tbody>
</table>

**Copy Or Consolidate Text Comments**

You can copy one or more existing comments to use in formulating your own comment. Copied comments also include any attached files and graphic markups.

When used in conjunction with the discussion group function, this can be used to consolidate the comments you receive from the group and create a single, cohesive comment. Because discussion group comments remain draft until the BP is sent to the next workflow step, the task owner can choose to delete or include the other draft comments.

You can also copy and consolidate comments made to documents attached directly to a BP. This allows you to consolidate several comments made by multiple users into a single comment by copying the existing comments into a new one and editing as necessary.
To copy general comments

1 On the BP form, click the General Comments link. The General Comments window opens.

2 Click Add (or Modify to modify an existing comment). The Edit General Comment window opens.

3 Click the Copy From button. The Copy General Comments window opens, displaying the list of existing comments.

4 Click the selection box next to each of the comments you want to copy into your comments and click OK. Any additional file attachments or markups associated with each comment are also copied to the new comment.

5 Make edits as necessary and click OK.

To copy and consolidate text comments on a BP attachment

1 Do one of the following:
   • Click the Attachments link at the bottom of the BP form. The Attachments window opens. Select the file and click the Comments button.
   • For document-type BPs, in the document list in the lower portion of the document-type BP, select the file to mark up and click the Comments button.

The File Comments window opens.

2 Click the Add button. The Edit File Comment window opens.

3 Click the Copy From button. The Copy General Comments window opens, displaying the list of existing comments.

4 Click the selection box next to each of the comments that you want to copy into your comments and click OK. The comments are copied into the new comment and are listed in the Text Comment box of the Edit File Comment window. Any additional file attachments or markups associated with each comment are also copied to the new comment.

5 In the Edit File Comment window, make any necessary edits to consolidate the text comments.

Note: At this point, you can also consolidate graphic markups before saving the newly consolidated comment by clicking the Consolidate link next to Graphic Markup.

6 When you are done consolidating comments and markups, click OK to save and exit the Edit File Comment window.

To consolidate discussion group comments on a business process or document

1 Use the copy text comments procedure to copy any of the draft comments that you received from the discussion group that you initiated.

2 Click the selection box next to the text comments that you want to include in your new comment and click OK. The text comments and any graphic markups will be copied in to your new comment.

3 Edit as necessary and click OK.

4 You may select any of the draft comments and click Remove if you do not want to include them in the BP record.
Copy Or Consolidate Graphic Markups

You can copy and consolidate graphic markups made on document attachments to BPs.

To copy and consolidate graphic markups on a BP attachment

The business process must have been sent. You cannot consolidate draft comments.

1. Do one of the following:
   - Click the Attachments link at the bottom of the BP form. The Attachments window opens. Select the file and click the Comments button.
   - For document-type BPs, in the document list in the lower portion of the document-type BP, select the file to mark up and click the Comments button.

The File Comments window opens.

2. Click the Add button. The Edit File Comment window opens.

3. Click the Copy From button. The Copy General Comments window opens, displaying the list of existing comments.

4. Click the selection box next to each of the comments that you want to copy into your comments and click OK. The comments are copied into the new comment and are listed in the Text Comment box of the Edit File Comment window. Any additional file attachments or markups associated with each comment are also copied to the new comment.

5. In the Edit File Comment window, make any necessary edits to consolidate the text comments. Note that the link next to Graphic Markup at the bottom of the Edit File Comment window changes to “Consolidate.”

6. Click the Consolidate link. The document opens in for viewing in the AutoVue viewer.

7. In the viewer window, click the Open Markup(s) tool or select File > Open. The Markup Files window opens, displaying the list of existing markups.

8. Select the markups to be copied and click OK. The selected markups will display in layers on the document.

9. Click the File menu and choose Consolidate. The Consolidate Markups window opens.

10. Do the following to create a new consolidated markup layer:
    - Enter a name for the new consolidated markup.
    - Select the checkbox next to the markup layers to include, or click the Select All button to select all markup layers.
    - Select the Open as active markup and hide the others checkbox.
    - Click OK.

The markup elements from the selected layers will be copied into the new consolidated layer. These elements are editable. You can select, modify, or delete individual elements, or add new markups as necessary.

11. Click the Save button or select File > Save to save the new consolidated markup layer. If you want to add another markup layer, click the New Markup button and add markups as necessary.

12. Close the AutoVue viewer window.

13. In the Edit File Comment window, click OK to save the consolidated markups and text comments. Close the File Comments window.
**Track A Step Through The Workflow**

There are times when you might need to examine a record’s workflow in detail to see the progression of a step or task through each assignee’s actions. You can track a step in this way using a single window, which is available from the business process form.

**To track the progress of a workflow step**

1. From the log node in the Navigator, select the business process.

2. On the right pane, double-click the record you want to track. Primavera Unifier displays the BP record window.
   - If the record is open or pending, click the **Task Status** link in the **Task Details** section of the form.
   - If the record is closed, click the link to view the process details in the **Task Details** section of the form.

   Primavera Unifier displays the BP Progress window, showing the step the record is currently on.

   ![Example of progress tracking for a workflow](image)

   **Example of progress tracking for a workflow**

You can use this window to display every step in the workflow schema, the action of the step, the assignees (and those cc’d) on the task, and the status of the task at each assignee’s action.

3. Click the name of the step you want to audit.

   Primavera Unifier displays the history of each assignee’s action on that step and the step’s status at that time. The actions are shown in reverse chronological order by Due Date (i.e., the latest due date is at the top of the list).

**Large Workflows**

If you view the workflow by clicking the **View Graphic** button, be aware that workflows can often be very large. If you are viewing a large workflow, you can enlarge the canvas screen to make it easier to see all the steps to the workflow progression.

To enlarge the canvas, you can drag the window sides until the workflow fits in the window, or you can quickly maximize the canvas. To maximize the canvas, click the icon in the upper-right corner of the window. To restore the canvas window to its normal size, click the Restore icon.
MANAGING BUSINESS PROCESS RECORDS

Transferring Ownership

If you are a BP record owner or creator, you can transfer ownership at any time in the workflow process, other than the creation step, or after its termination step. The new owner will have all privileges of a BP owner, and the originator name on the BP form and the log will show the new owner.

To transfer ownership

Open a BP record. From the Edit menu, click Transfer Ownership. Choose the user from the User/Group picker and click OK. The selected user becomes the BP’s new owner.

Granting Business Process Record Permissions

For non-workflow business processes, permission must be granted on an individual record basis by the record creator. If you have create permission and create a new record, you must grant view or edit permission to other users so that they can have access to it. This is applicable on the following BP logs:

- Company > Data Manager
- Company > General
- project or shell > project or shell Information > General

Note: You must have permissions for specific business process logs to create or view records. Contact your project or shell administrator if you are having trouble accessing BPs or BP logs to which you need access.

To grant permission to a business process record

1. Create a BP record in the Company Data Manager, Company General, or project or shell General log.
2. From the log window, select the record (for Company Data Manager records, select an individual BP log node) and click Permission.
3. Add the users or groups you wish to grant permission, set the permission level, and click OK.
About Editing Records

When a workflow BP is in process, depending upon your permission settings, you can add or edit information on the form. Non-workflow BPs can be edited as needed.

If you are an editor on a business process

In Primavera Unifier, you can be designated as either a step editor on a specific step in a workflow, or as a record editor. As an editor, you must have at least view permission to be able to view the record in the log and access it for editing.

Some notes:
• Step editors cannot edit a workflow record until the task assignee accepts the task, and saves the draft.
• Edits made and saved by assignees are not viewable until the assignee sends the record on to the next step. However, edits made and saved by record editors are viewable at any time.
• Edits performed on the end step of a workflow business process affect the record directly, as no draft exists.

Edit A Business Process Form

To edit a non-workflow business process form

If you want to edit a non-workflow BP that is already complete, click the Edit button to enable editing.

Caution: If the business process is in a terminal status and you click Finish Editing, the Edit button is permanently disabled and the form never be edited again.

To edit a workflow business process form

Business processes with a workflow can be edited during the workflow process. If a view form is used on a terminal step, further editing is not possible.
**Concurrent editors in a business process.** While a workflow business process is on a step, or a non-workflow business process is in Edit mode, Primavera Unifier saves edits to fields, but does not commit the changes. For example, if editor one revises fields 1 to 5 and then saves the record, and editor two revises fields 6 to 10 and saves, the record retains all 10 edits. However, if editor two revises field 4, and saves the record after editor one saved the record, then the data from editor two over-writes editor one’s revision.
IF YOU ARE AN EDITOR ON A BUSINESS PROCESS

In Primavera Unifier, you can be designated as either an editor on a specific step in a workflow, or as a record editor. As an editor, you must have at least view permission to be able to view the record in the log and access it for editing.

Some notes:

- Step editors cannot edit a workflow record until the task assignee accepts the task, and saves the draft.
- Edits made and saved by assignees are not viewable until the assignee sends the record on to the next step. However, edits made and saved by record editors are viewable at any time.
- Edits performed by editors are not audited; however, changes made by record editors are audited.
- Edits performed on the end step of a workflow business process affect the record directly, as no draft exists.
EDIT BUSINESS PROCESS RECORDS IN A MASTER LOG

You can edit project or shell business process records in the Master Log, provided you:

- Are an active member of the project, shell, or sub-shell
- Have the appropriate permissions in the associated project or shell.

When you open a business process record in a Master Log, the record will open in either Edit or View mode, depending on the user permissions associated with that record in the project or shell.

There are specific conditions for editing workflow or non-workflow records in the Master Logs. For workflow business process records:

- You can Accept tasks and take Action on workflow records by opening the record from the Master Log if you are the assignee on the current step in the business process workflow. If not, record is opened in View mode only.
- After you open a business process record in the Master Log, the project or shell permissions are in effect
- You can add general comments if you are a cc user on a particular step; you can add general comments provided the current step has general comments option enabled
- If you are not an assignee on a particular step, you must have Bulk Edit permission on the business process Master Log to edit data elements on the record

Conditions for editing non-workflow business process records:

- If you have Edit Data permissions on a non-workflow business process record, you can open the record and edit it in the Master Log
- If you are an Editor of a non-workflow business process record, you can open the record and edit it in the Master Log

To edit business process records in a Master Log

1 Navigate to a Master Log.
2 Select a business process record.
3 Choose File > Open.
4 Edit the business process record and Save the record.

Edit Multiple Records In Bulk

If you have a large number of projects or shells with numerous business processes that need similar edits, you can use bulk editing to update all the forms at once. You can use bulk editing to modify workflow and non-workflow multi-record BPs at the company, project, or shell level. You can update a maximum of 200 records using bulk editing.

Bulk editing must be defined in Primavera uDesigner, and you must have the Allow Bulk Edit permission on the BP to use bulk editing.

On business processes, the bulk edit function works only on fields from the action form (upper form) for the current step in a workflow. It cannot be used to edit the following:

- Auto-populated fields
- Fields in a dynamic data set
• Read-only fields
• Fields from line items
• System-defined fields, such as record number, status, or due date

Note the following:
• Bulk edit is not available for Resource Booking and Timesheet business processes, or single-record business processes.
• Fields configured for auto-sequencing are not available for bulk edit, since the values for these fields are system-generated.
• If you use bulk edit to update multiple records, and attempt to update a field that has value uniqueness configured, only the first record will update (and is therefore unique).

To update business processes using bulk editing

1 Navigate to a business process log.

2 Select one or more business processes, or perform a Find for BPs to search for a group of BPs to work with.

3 Choose Edit > Bulk Edit. The Bulk Edit window opens. The fields displayed in this window depend on what was specified for the upper form in Primavera uDesigner. The Bulk Edit form includes all editable fields for the BP as defined in Integration.

4 Modify the Bulk Edit form as needed.

5 Select the Update checkbox for the fields that you want to update. The checkbox is automatically selected when you type into or modify a field. You can deselect it if you do not want to modify the field at this time.

Note: If the Update checkbox is selected for an empty field, the field will be updated with a blank value.

6 Click Update. This launches the bulk update of the selected BP records.

7 The Bulk Actions Status window displays after you click Update. This window allows you to monitor the progress of the bulk BP update. Click OK after all records have processed. Click Cancel if you want to cancel the bulk update in progress.
USE BULK EDITING ON BUSINESS PROCESS RECORDS IN A MASTER LOG

If you have the Allow Bulk Edit permission, you can select one or more business process records in a Master Log and perform bulk edits on these records. You can select records across projects or shells to perform bulk edit.

These data definitions cannot be modified using Bulk Edit in a Master Log:

- Image Picker
- Program Picker
- Company Picker
- Group Name Picker
- User Picker
- Project Picker
- BP Creator

To use bulk editing on business process records in a Master Log

1. Navigate to a Master Log.
2. Select one or more records.
3. Choose Edit > Bulk Edit.

Auditing Business Processes

The business process Audit log lists the actions that have been taken on a specific record. The Audit log captures the following events. These apply to workflow and non-workflow BPs, unless otherwise noted.

- Workflow steps: when and to whom (To and Cc) each step was sent (workflow BPs)
- Record creation date (non-workflow BPs)
- General comments
- File comments
- Linked uMails
- Linked records
- Discussion group: start and end
- Add or manage document-type BP folders: new, remove, rename, move
- Add or remove file attachments
- Decline task
- Transfer ownership
- Add, modify, or delete a line item: detail or summary
- File attachments to existing line items
- Copied (cc) user views the record
- Updates performed on any part of the BP using the Reverse Auto-Population feature
The BP Audit log does not support the following:

- Actions undertaken at the creation step
- File attachments to new line items (to audit the attachment, first add and save the line item, and then open it to add the attachment)
- Accept task
- Undo accept task
- Add assignees or copy users between steps

View and print the business process audit log

To view a business process Audit log
From the View menu of the BP record, click Audit Log. The Audit Log window opens, listing each event associated with the business process and workflow. The date and time stamp of each event reflect users’ current time zone as set in their User Preferences.

To view business process audit details
From the Audit Log window, double-click a listed event to view the audit record detail, which details the action taken. The details also include the user’s current time zone for reference.

To print a business process Audit log

1. On the Audit Log window, click the Print button. A PDF file is created.

2. Do one of the following:
   - Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can view, save, or print the file.
   - Click Save. In the Save As window, navigate to the location in which you want to save the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print.
PRINTING AND DISTRIBUTING BUSINESS PROCESS FORMS

At times, you may need to print copies of a business process form, such as an invoice or a purchase order. You can save a copy of the form as a PDF file and print or e-mail the file, print an HTML view, or print from a Word file if a custom print layout has been created for the form.

**Note:** You can print a form that is in view mode or in edit mode.
PRINT A BUSINESS PROCESS FORM IN PDF OR HTML FORMAT

When printing business process forms from PDF or HTML format, you can choose to include not only the information on the form itself, but also associated information such as general comments and information about file attachments. The print options are:

- Upper form data
- Workflow progress information (for business processes with a workflow)
- Line item list
- Line item data
- General comments made to the record
- Information about file attachments on the record or line items
- Comments made to file attachments

If custom print layouts have been created for the business process, the form will print according to the layout that you select.

**Note:** For PDF and HTML layouts, the ability to print hidden comments will respect permissions: if you can see hidden comments, you can print them. In custom print, hidden comments are not printed.

To preview and print a business process form in PDF or HTML format

1. Open the business process record that you want to print.
2. From the **File** menu, choose **Print Preview**, then choose one of the following:
   - **HTML** to view the form in the browser, which can then be printed.
   - **PDF** to open the form in Adobe Reader, which can be saved or e-mailed as a PDF file, or printed process, you are asked to save the changes to the form.

**Note:** Even if you have not made any edits, you may be asked to save changes. This can occur if the form includes fields that are auto-populated or automatically updated, as these automatic functions are considered to be changes.

3. The Print Options window opens.

This window displays the business process record information that can be printed. Select the checkboxes for the information that you want to print. Only those options that are applicable to that business process design will appear on the Print Options window. For example, line items options are available for business process types that support line items, the Task Details option appears only for workflow business processes.

<table>
<thead>
<tr>
<th>Print option</th>
<th>What it prints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upper Form</td>
<td>Selected by default. This prints the information entered on the upper form.</td>
</tr>
<tr>
<td>Workflow Progress</td>
<td>Prints a log of the steps in a workflow, showing the step name, the assignee(s) on the step, the action that was taken on the step and the completion date. You have additional print</td>
</tr>
</tbody>
</table>
### Print option | What it prints
--- | ---
**options:** |  
**All Steps** will include all the steps in the workflow, whether or not they were visited by users. The steps will be listed in order according to the workflow setup. All assignees on each step will be listed in the log, whether or not they took action on the step.  
**Visited Steps** will include only those steps that have been visited by users. Only the assignees who took action on the steps will be listed. You can display the steps sorted by the completion date or the step name, in ascending or descending order.

| Line Item List | Selected by default. This prints line information as it appears on the business process form itself. This is applicable for business processes that support line items. |
| General Comments | The general comment text and create details are printed. |
| Record Attachments | File attachments to the record are listed alphabetically by file name, and also include the file title, issue date, revision number, and file size. This is not applicable for document type business processes, which list file attachments in the line item list section. |
| Record Attachments > Comments | Prints comments associated with file attachments to the record. Record Attachments must also be selected to select this option. |
| Detail Form | Line item data is displayed in order by line item, and grouped by tab if the business process has multiple line item tabs. This will print all line item data elements present on the detail form, and reflects the layout of the detail form (for example, if the detail form is two-column, the print data is displayed in two columns). |
| Detail Form > Attachments | Prints information about attachments to each line item. Detail Form must also be selected to select this option. |
| Detail Form > Attachments > Comments | Prints comments associated with file attachments to a line item. Detail Form and Attachments must also be selected to select this option. |

4 To select all the checkboxes, click the **Select All** checkbox. To deselect all, uncheck the **Select All** checkbox.

Selecting or deselecting this checkbox will have no affect on any Workflow Progress options you choose.

5 Click **OK**. The preview form opens in an HTML or PDF (Adobe Acrobat or Reader) window, from which you can print.

If you chose PDF, you can save a copy by clicking the **Save a Copy** button, or print. To print from HTML format, click on the **Print** icon in the upper right corner.
PRINT USING A CUSTOM LAYOUT

Custom printing can be used with templates created in Microsoft Word and PDF format. Depending upon the template used for custom print, you can print the upper form, the current workflow step, comments and attachments of the record. The template may also allow printing of specific line items in their tabs. The printed output will list the name of the tab with the line items following on separate lines.

To print a business process form with a custom print layout

1. Open the business process record that you want to print.
2. From the File menu, choose Print Preview > Custom.
3. If you are editing the business process, you are asked to save the changes to the form.

Note: Even if you have not made any edits, you may be asked to save changes. This can occur if the form includes fields that are auto-populated or automatically updated, as these automatic functions are considered to be changes.

The Custom Format Print window opens. The window lists custom layout formats set up by the administrator.

4. Select a format.
5. Select workflow progress options.
Workflow progress prints a log of the steps in a workflow, showing the step name, the assignee(s) on the step, the action that was taken on the step and the completion date. You have additional print options:

- **All Steps** will include all the steps in the workflow, whether or not they were visited by users. The steps will be listed in order according to the workflow setup. All assignees on each step will be listed in the log, whether or not they took action on the step.
- **Visited Steps** will include only those steps that have been visited by users. Only the assignees who took action on the steps will be listed. You can print the selected steps (including the current workflow step) sorted by completion date or step name, in ascending or descending order.

6 Click **OK**. The File Download window opens.

7 Choose to **Open** or **Save** the file.

8 Print the file.

**Send A PDF Copy Of A Business Process Form Via UMail**

You can create and send a PDF copy of a business process record directly from uMail.

**To send a PDF copy of a business process form using uMail**

1 Open the business process form in View mode.

2 From the **File** menu, click **Send uMail**. The uMail window opens. A PDF copy of the form is automatically attached.

3 Complete the uMail form and send.
BUSINESS PROCESSES WITH SPECIAL BEHAVIORS

Some business processes have special features and behaviors that make them operate differently from most business processes in Primavera Unifier. These business processes and their features are described in this section.

SOVs And Business Processes

This section discusses how to manage business process records, including searching for existing BPs, transferring ownership, viewing BP properties, and viewing SOV or funding information from within a cost BP.

**View An SOV Sheet From The Business Process Form**

Commit (contract) or spend (invoice) BPs can be set up to automatically create a Schedule of Values sheet. These transactions can be easily accessed directly from the BP form. The BP form remains active.

If the BP has been set up to automatically create an SOV sheet, once the sheet has been created, an SOV button appears at the top of the BP form.

**To view the SOV sheet created from the cost business process**

Once the BP has reached its terminal status, click the SOV button. The SOV sheet that corresponds to this transaction opens. Close the SOV sheet to return to the BP form.

**Create SOV Breakdowns**

You can add SOV breakdowns from this view. Breakdowns are only in use in the SOV sheet, not the cost sheet. If another transaction exists for the WBS code, you will not be able to do a breakdown.

**To add WBS code breakdowns that can be used to create invoices**

1. Open the SOV sheet by clicking the SOV button.
2. Click on a listed WBS code from the sheet. The WBS Details window opens.

**View Or Edit Fund Transaction Details From The Business Process Form**

Commit (contract) or spend (invoice) business processes can be set up to consume or appropriate funds in the project/shell funding sheet or commitment funding sheet. These transactions can be easily accessed directly from the BP form.

If the business process form has been set up for funding (and is in the appropriate step, and you have funding permissions), a Funding button will appear at the top of the BP form. This allows you to perform a fund assignment while routing and approving a BP, such as a payment. Access to this button and fund information is dependent upon your Fund Manager permissions.

**Commit And Change Commit (composite View Details)**

You can view a composite view of both commits and change commits. The SOV sheet is used as a composite view. SOV will be the composite of the PO and all added lines from change commits.

To support line-item mode, SOV has a column called Ref that represents line item numbers.

There are four fixed columns. The columns will be dependent on the mode.
• **Line item mode**: The Ref column represents the line item numbers for both commits and change commits. The Description column shows the short description of the line item from the commit.

• **WBS mode**: The Ref column does not have any data. The breakdown items do not include any ref number. The column width is four characters.

**To view funding details from the cost BP**

Once the BP has reached its terminal status, click the Funding button. The Cell Detail window opens, displaying the details of the transaction.

This is the same window that you would see if you clicked on the link corresponding to this transaction on the project or shell funding sheet.

**To reassign funding**

Click the Reassign Funds button.

**Payment Application Business Processes**

Payment application business processes enable you to track your payment information using a standard payment application method (for example, tracking retainage, stored materials, past payments, etc.).

Each payment application record will reference a particular base commit record. The line items on the payment application will reflect the line items on the base commit plus any associated change commits.

Payment applications, and associated base commits and change commits, are designed in Primavera uDesigner. For more information, refer to the Primavera uDesigner User Guide.

---

**N o t e:** Only one payment applications type business process can be configured for a project or shell. Only one payment application record can be routed at any time for a commit.

You can use CSV import to create new payment application business processes or to add SOV line items to an existing business process. You can export payment application CSV templates at the log level (for header and line item templates) and at the record level (for line item templates). You can then modify the templates and import them to create new records (at the log level) or to add line items to an existing record (at the record level).

An Integration interface must be defined to support CSV import. If you find that you cannot perform the file import, see your Administrator. Also, new records can be created and line items added using Integration through Web Services. Integration through Web Services must be coordinated with an Oracle Primavera representative.

**Enter Payment Application Line Item Information**

Line items on payment applications have special functionality. Payment application line items are created automatically from the line items on the associated base commit and any change commits. The line items appear by default on a grid. The columns that appear on the grid (including formula columns) are part of the business process detail form design.
To enter line item information on a payment application

1 In the payment application business process form, click the Add button and choose Detail Line Item. The Line Items window opens. The Line Items window for payment applications is different than other BPs: the window displays a list of line items from the base commit and any change commits.

**Note:** Depending upon the design of the BPs, some fields may be auto-populated with data from the base commit and change commit. For a field to auto-populate, the same data element must be used on the base commit, change commit, and payment application. Line items appear from the base commit and any change commits based on the statuses of those business processes, as designed in Primavera uDesigner.

2 Fill in the line item fields. You can enter values in any editable field on the grid. Editable fields appear with a white background on the grid.

3 While viewing or editing data, you can split the grid so that the cost codes or other columns are always in view on the left, allowing you to scroll through other columns to view or enter data on the right. To split the grid:
   - a Click the Split button. The window splits vertically, with a moveable vertical bar.
   - b You can move the vertical bar as necessary. Use the horizontal scroll bars to scroll through the columns on both sides of the vertical bars. For line item entry, both sides are editable.
   - c You can click the Freeze button to make the left side of the vertical bar unmovable.
   - d To unfreeze the left side, click the Freeze button again. To remove the split, click the Split button again.

4 When you have completed editing the Line Items window, click OK. An icon appears in the first column to indicate which rows have been modified.

To undo line item changes without closing the Line Items window

In the Line Items window, click the Cancel Row Changes button. Any line item information that you have entered or changed will be cleared, and the fields will revert back to their original values.

**View Payment Application Line Item History**

When payment application records in view mode, a Line Item History button becomes available. This provides a snapshot view of the line item grid as of the last entry.

**Note:** View mode refers to the non-editable version of the form. For example, for workflow BPs, this is before clicking the Accept Task button or after the form has gone through all the workflow steps and is complete. For non-workflow BPs, this is after editing has been completed.

To access line item history

1 Open a payment application record from the log. Be sure the record is in view mode.

2 Click the Line Item History button. The Line Items window opens, displaying the payment application line item grid, as view-only, with data entered to date.

3 You can optionally split the grid so that the cost codes or other columns are always in view on the left, allowing you to scroll through other columns to view data on the right.
To split the grid, click the Split button.

You can click the Freeze button to make the left side of the vertical bar unmovable.

To unfreeze the left side, click the Freeze button again. To remove the split, click the Split button again.

4 Click the Close button to close the window.

By default, the first 100 line items are displayed on the page. If your payment application BP has more than 100 line items, you can scroll through the other pages, or you can choose to display up to 500 line items on the same page. Displaying more than 100 line items on the page may take several seconds to load.

Export Line Item History

You can export the line item history of a payment application record to a CSV file.

To export payment application line item history information

1 Open a payment application record from the log. Be sure the record is in view mode.
2 Click the Line Item History button. The Line Items window opens.
3 Click the Export button. A confirmation window opens. If there are many line items, the operation can take more than 20 seconds.
4 Click Yes on the confirmation window. The File Download window opens.
5 Click Save and specify the file name and location to which to save a copy of the CSV (export) file.

Save Payment Application In Draft Mode

You can save a payment application record in draft mode by clicking the Save button from the toolbar.

When you open the draft again to send, the system will check to see if there is any modification done by other users. If the system identifies that there is modification to your payment application, you will be asked to accept new changes before proceeding.

Draft Mode And SOV Synchronization

If you create a payment application record and save it in Draft mode, and your SOV changes before you route the draft payment application, an error can result when you attempt to route the record. The error Line Items must be validated before proceeding can result if the SOV has changed while your payment application is in Draft mode.

To fix payment application BPs that are affected by changes to the SOV

1 Open the draft payment application record.
2 Click the Add button and click Detail Line Item to open the line item entry grid. Line items that are affected by SOV changes are indicated with check marks.
3 Click OK. The line items are validated against the SOV.

View The Schedule Of Values Sheet

The schedule of values (SOV) for payment applications functionality provides a way to assemble information from the base commit and change commits, as well as the payment history, in an SOV sheet.
You can open the SOV sheet either from the Schedule of Values log, or from within a payment application record (the record must be in an editable mode).

When the base commit record is created and reaches a specified terminal status (for example, Approved), the SOV sheet is automatically created, and line items display as rows. As change commits are created and approved (or other specified status), they are added automatically to the SOV sheet. As payment records are created, these also will affect the SOV. (Data that is displayed on the SOV sheet will depend on the columns that have been added to the SOV structure.) The SOV displays the source information from the base commit any change commits. The source for each line can be one or more lines from one or more records.

Depending on the design of the associated business processes, the SOV may list each line entry for the base commit and all change commits as separate line items, or it may group entries with the same WBS code and display the total.

**To view the associated SOV**

1. In the Navigator, click **Cost Manager > Schedule of Values > Payment Applications**. The Schedule of Values: payment Applications log opens. SOVs are listed by their associated base comment record numbers and descriptions.

2. Select an SOV and click **Open** (or double-click the record). The Schedule of Values sheet for the base commit associated with the payment application opens.

3. You can optionally split the grid so that the cost codes or other columns are always in view on the left, allowing you to scroll through other columns to view data on the right.
   
   a. To split the grid, click the **Split** button.

   b. You can click the **Freeze** button to make the left side of the vertical bar unmovable.

   c. To unfreeze the left side, click the **Freeze** button again. To remove the split, click the **Split** button again.

4. To view source information from the base commit and/or change commits, locate the **Scheduled Value** column.

   **Note:** This assumes that a column has been added to the SOV that is associated with the datasource “Scheduled Value.” The column name may vary. Click the link in a cell. The Cell Details window opens, displaying the source of the line item information -- the commit record(s) with a line item entry for that WBS code.

5. Click the **Close** button to close the window.

**To view the associated SOV from within the payment application line item grid**

1. Open the payment application form. Be sure the form is not in a view-only mode.

2. Click the **SOV** button from the record toolbar. The Schedule of Values sheet opens.
IMPORT NEW PAYMENT APPLICATION RECORDS

You can export a CSV template that includes the upper form and detail form fields as columns. These fields include the header fields from the upper form and the line item SOV fields from the detail form, including the detail line item fields defined in Integration. The Reference Number field is exported as a column for payment application business processes that use individual line items. The Reference number field is not exported as a column for payment application business processes that use Group by WBS.

You can then modify the exported CSV template and import it to create the upper form header and the detail form line items for the new business process.

To export a copy of the payment application business process template

1. Navigate to the payment application business process log.
2. Choose File > Export Template > CSV.
3. Click Open to open the file in Excel, or click Save to save the file to your local drive. The template exports with no data in it, and contains only the column headings.

To modify the exported payment application business process template

1. Open the exported CSV file in Microsoft Excel.
2. Enter the business process information into the spreadsheet. Each upper form header record must begin with an “H”. Each line item must begin with a “D”. For multiple tabs, you must enter appropriate tab name in the Tab Name column.
3. Enter data into the required fields, as well as non-required fields as needed.

Note the following:

• Data for formula-based columns is ignored.
• If auto-populated data is provided, the system will import the value, and will not override the imported values except for fields auto-populated by Base Commit, Change Commit, or Unit Cost Control.
• Any line items with the Amount equal to zero will not be imported.
• SOV locking is enforced
• Use to add new business process records only; not to modify existing business processes.
• You might find that you have to change some of the cells in the CSV file to Text type in order for data to import correctly. For example, if you have a WBS code of 1-1, Microsoft Excel can interpret this entry as a month-day combination and reformat it to Jan-1. In this case, your data import will fail because this data is now an invalid WBS code.
• If the Integration design for the business process includes a Description field for line items, and the associated SOV sheet also contains a Description field, the description from the SOV sheet is imported, and the line item description is not imported.

To import the payment application business process template

1. Navigate to the payment application business process log.
2. Choose File > Import.
3. Browse to select the file to import.
Click OK. The new business processes are listed in the log.

If there are any import errors, you can open the CSV file to view and correct the error. No records are imported if any rows contain an import error.
IMPORT PAYMENT APPLICATION LINE ITEMS INTO A BP

You can export a template that includes the detail form fields as columns for a specific business process. These fields include the SOV data and detail line item fields defined in Integration. The Reference Number field is exported as a column for payment application business processes that use individual line items. The Reference number field is not exported as a column for payment application business processes that use Group by WBS. If multiple tabs are designed for the line items in the business process, the tab columns are included in the export. All of the data on the Standard tab is exported; no data on the other tabs is exported.

You can then modify the exported template and import it to create new line items for the business process. The exported template contains SOV record information.

To export the payment application line item template

If multiple tabs are designed for the line items in the business process, only the data in the Standard tab is exported. For the other tabs, the tab name is included in the exported data for reference, but no data in these tabs is exported.

1. Navigate to the payment application business process log.
2. Click New to create a new business process.
3. Select a Reference Base Commit for the business process. If you do not select a Reference Base Commit, the exported template will not contain data. Data from all columns in the Reference Base Commit is exported.
5. Click Open to open the file in Microsoft Excel, or click Save to save the file to your local drive. The template exports with SOV line item data in it, based on the selected Reference Base Commit.

To modify the payment application line item template

1. Open the exported CSV file in Microsoft Excel. The SOV line items are listed.
2. Enter the line item information into the spreadsheet. Each line must begin with a “D”. For multiple tabs, you must enter appropriate tab name in the Tab Name column.
3. Enter data into the required fields, as well as non-required fields as needed.

Note the following:

- Data for formula-based columns is ignored.
- If auto-populated data is provided, the system will import the value, and will not override the imported values except for fields auto-populated by Base Commit, Change Commit, or Unit Cost Control.
- Any line items with the Amount equal to zero will not be imported.
- SOV locking is enforced
- Any line items that you import will replace the existing line items in the business process.
- Use to add new lines only, not to modify existing lines
- You might find that you have to change some of the cells in the CSV file to Text type in order for data to import correctly. For example, if you have a WBS code of 1-1, Microsoft Excel can
interpret this entry as a month-day combination and reformat it to Jan-1. In this case, your data import will fail because this data is now an invalid WBS code.

• If the Integration design for the business process includes a Description field for line items, and the associated SOV sheet also contains a Description field, the description from the SOV sheet is imported, and the line item description is not imported.

To import the payment application line item template
Note: Line items you import will replace any existing line items.

1 Navigate to the Payment Application business process log.
2 Select a business process and click Open.
3 Click the Import button. The imported line items replace any existing line items.

If there are any import errors, you can open the CSV file to view and correct the error. No line items are imported if any row contains an import error.

Request For Bid Business Processes

The Request for Bid (RFB) feature allows companies to invite bids from vendors and suppliers. The bid invitation can be addressed to a specific set of vendors, or can be opened up to the public. The bidders are provided with a simple Primavera Unifier interface that does not require special training to use. Bidders receive email notifying them that they have received a bid invitation so they can log into Primavera Unifier and submit their bids.

How RFBs Work

Once the RFB business process is active in Primavera Unifier, the bid procedure runs as follows:

You:

1 Start the bid procedure by opening the RFB, filling in the form, and sending it for internal review (if necessary).
2 When the internal review is complete, you:
   a Assemble the bid package and prepare the bid invitation for distribution.
   b Send out the bid invitations, along with a user name and password so that the vendors can log into Primavera Unifier and submit their bids.

Once the bid invitations have been sent, you must wait, then, for the bid due date to pass.

The vendors:

1 When the vendors receive the bid invitation, they log into Primavera Unifier and open the bid request.
2 They (optionally) can request clarification of any questions or issues before submitting the bid. (They can use the uMail link on the bid request for this purpose.)
3 They then submit the bid.

You:

1 When the due date for all bids is reached, you tabulate the bids for comparison.
2 Optionally, open discussions about the bids, if necessary.
3 Award the bid to a vendor.
Send The Bid Request For Internal Review And Approval

For most companies, an internal review is necessary for the purpose of verifying the scope of the project, as well as other things, such as terms and conditions, architectural drawings, and structural materials. After the bid request is approved, you can start the bidding process.

To send the bid request for approval

1. Navigate to the RFB log and click New. The RFB BP form opens.
2. Complete the form, then use the Workflow Actions field in the upper-right corner of the window to send the RFB into the workflow.

Once the approval request reaches the end of the workflow, you should receive the completed BP as a task in your task log. When you open the form this time, you should see an Invite Bids button on the toolbar, with which you can start the bidding process.

Start The Bidding Process

After the RFB has completed the internal review and approval, you can start the bidding process.

To start the bidding process

1. Open the RFB and click the Invite Bids button on the toolbar. Primavera Unifier displays a notice that the item is now open for bidding.
2. Click the Invite Bids button again.

The Bid Invitations window opens. From this window, you can choose the vendors you want to submit bids. Primavera Unifier will send both a bid invitation to the vendors and also a login name and password they can use to access Primavera Unifier to submit their bids.

3. Click Send Password. The Bidders window opens, showing a list of vendors.
4. Choose the vendor(s) you want to submit bids and click Send Password. Then click Close Window.
5. On the Bid Invitation window, click Close Window.

Once you have sent out all the bid invitations, Primavera Unifier freezes the RFB until the bid due date passes. After the due date passes, you can compare the bids.
About the Vendor List

The list of vendors you use to distribute the bid invitations can include your company’s entire list of vendors or a list of “approved vendors” specific for the project you are working on. Your administrator can design a business process that filters the master list of vendors into a sub-set of this list for your project. If such a sub-set of the vendor list has been created for your project, this is the list of vendors you will see in the Bidders window, unless this is a public bid. For public bids, the filtered vendor list will be ignored.

To see the approved list of vendors with more information, go to the project Logs node in the Navigator and click on the business process that created the vendor list for your project. Primavera Unifier will display the list of records in that business process. To see the approved list, click the Filtered Referenced Records button on the toolbar.

Compare The Bids

Once the bidding process ends (after the bid due date has passed), you can open a bid tabulation to compare the bids you received. A default bid tabulation sheet is available in Primavera Unifier, or your company may have a custom-designed bid tabulation sheet.

To compare bids

1. Open the RFB record. The toolbar displays a Show Bids button.
2. Click Show Bids. The Show Bids window opens, listing the bids you received.
3. From the list, select the vendors you want to compare and click Compare Bids.

Unifier tabulates the bids from the vendors you selected and displays a Compare Bids sheet. This sheet will look different, depending on whether you are using the default comparison sheet supplied by Primavera Unifier, or a custom-designed comparison sheet created by your company.

Default bid comparison sheet:

The default bid comparison sheet shows the bid amounts for each line item for which the vendor submitted a bid.

Custom bid comparison sheet:
The custom-designed bid comparison sheet shows the following:

- General bid information from each vendor who submitted a bid.
- Each line item from the RFB that the vendor has bid on. If the vendor adds line items of their own to the bid, these line items will appear on the sheet as well.

**Bid Comparison Options**

On the custom bid comparison sheet window, you have the following options:

<table>
<thead>
<tr>
<th>Use this button:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save</td>
<td>Save the data you entered or modified on the sheet. (This will not affect the bidder’s data.)</td>
</tr>
<tr>
<td>Split</td>
<td>Split the screen so you can easily compare vendors by column.</td>
</tr>
<tr>
<td>Find</td>
<td>Find specific data on the sheet. When you click Find, a window opens where you can specify the vendor (column) and the value you want to locate. Primavera Unifier will search the line items in that column and highlight the value, if it finds it.</td>
</tr>
</tbody>
</table>

In addition, some fields on the sheet may be editable, depending on how the sheet was designed.
What The Vendor Does

Use the instructions in this section to familiarize vendors with the Primavera Unifier interface so they can submit bids.

About the Bid Due Date Time: Be aware that the due date and time for the bid reflect the time of the server on which Primavera Unifier is running. (Primavera Unifier servers operate on Pacific Standard Time.)

To log in to Primavera Unifier

If you received a bid invitation, you should also have received an email containing a link to Primavera Unifier, a user name, and a password.

1. Open the bid invitation and click the link provided.
2. At the login screen, enter the user name and password provided in the email.
   The Primavera Unifier home screen opens.

To submit a bid

1. In the Navigator on the left, click Request for Bid/Bids (or Request for Bid Private/Bids, if you have been invited for a private bid). A bid log appears on the right pane showing a list of open bids you have been invited to submit.

   Note: By default, Primavera Unifier displays only open bids. If you want to see all the bids you have been invited to submit, use the View menu on the right corner of the tool bar. Click the arrow and choose All Bids from the list. Primavera Unifier will display all your bids, past and present.

2. On the right pane, double-click the name of the RFB you received (or click the View Bid button). The Request for Bid form opens.
Got questions?
Before you submit the bid, you can communicate with the requestor about any questions or issues that need clarification. The Request for Bid form provides a link to Primavera Unifier’s uMail feature. To send a communication:

- Click the Linked Mail link in the lower-right corner of the window. A Linked Mail window opens, showing a chronological list of any existing communications.
- Click New. An email-type form opens, where you can send a communication to the requestor.

3 Click the Bid button in the upper-left corner of the screen. The request for bid form opens for editing.

4 Fill in the upper form fields that are required.

5 Click the Add button in the lower-left corner and choose Detail Line Item. The Request for Bid Line Item window opens.

6 Fill in the fields on this form and click OK.

The line item detail you entered appears on the tab at the bottom of the screen.

7 (Optional) To add an attachment to the bid, click Add Attachment in the toolbar. A file upload window opens.

   a Click the Add button. A window opens showing the directory tree of files on your machine.

   b Navigate to the file you want to attach and select it. Then click Open. The file name appears in the Upload List field.

   c Click the Upload button. An Upload Status window opens.

   d When the file has been uploaded, click the Close button.

On the Request for Bid form, Primavera Unifier indicates the attachment in the lower-left corner of the window. You can click on Attachments to verify that the attachment is correct.

8 Click the Submit Bid button. Primavera Unifier accepts the bid.

To withdraw a bid

1 Log in to Primavera Unifier.

2 In the Navigator on the left, click Request for Bid/Bids (or Request for Bid Private/Bids, if you were invited for a private bid). A bid log appears on the right pane.

3 On the right pane, double-click the name of the RFB you received. The Request for Bid form opens.

4 Click the Bid button in the upper-left corner of the window. The request for bid form opens for editing.

5 Click the Withdraw Bid button in the upper-left corner of the window.

To view or print the bid after submitting it

1 Log in to Primavera Unifier.

2 In the Navigator on the left, click Request for Bid/Bids (or Request for Bid Private/Bids, if you were invited for a private bid). A bid log appears on the right pane.
3 In the log, select the bid record that you want to view or print.

4 Click the View Bid button. The bid form that you submitted opens for viewing.

5 (Optional) Print the bid form from the File menu. Choose either:
   • Print Preview > HTML Format: The print view of the form will open in the browser.
     Landscape orientation usually provides best results for HTML format. To print the bid, click the
     print icon in the upper-right corner of the window.
   • Print Preview > PDF Format: Opens the form in Acrobat Reader. Print the bid using the File
     menu in Acrobat.
GENERAL SPENDS BUSINESS PROCESSES

General spends business processes enable you to invoice at the WBS or breakdown level, supporting multiple invoices per SOV. These business processes do not calculate retainage or stored materials. General spends business processes are designed in Primavera uDesigner. For more information, refer to the Primavera uDesigner User Guide or online help.

You can use CSV import to create new general spends business processes or to add SOV line items to existing business processes. You can export general spends business process templates at the log level (for header and line item templates, with no data exported) and at the record level (for line item templates with SOV line item data exported). You can modify the templates and import them to create new records (at the log level) or to add line items to an existing record (at the record level).

An Integration interface must be defined to support CSV import. If you find that you cannot perform the file import, see your Administrator.

Also, new records can be created and line items added using Integration through Web Services. Integration through Web Services must be coordinated with an Oracle Primavera representative.
IMPORT NEW GENERAL SPENDS RECORDS

You can export a CSV template that includes the upper form and detail form fields as columns. These fields include the header fields from the upper form and the line item SOV fields from the detail form, including the detail line item fields defined in Integration. These fields are always exported in the template as well:

- Reference Number
- Description
- WBS Code
- Breakdown

You can then modify the exported template and import it to create a the upper form header information and the detail form line items for the new business process.

To export a copy of the general spends business process template

1. Navigate to the General Spends business process log.
2. Choose File > Export Template > CSV.
3. Click Open to open the file in Excel, or click Save to save the file to your local drive. The template exports with no data in it, and contains only the column headings.

To modify the exported general spends business process template

1. Open the CSV file in Microsoft Excel.
2. Enter the business process information into the spreadsheet. Each upper form header record must begin with an “H”. Each line item must begin with a “D”. Add a new “D” line for each line item in the business process. For multiple tabs, you must enter appropriate tab name in the Tab Name column.
3. Ensure that you enter the required values for the Amount, WBS Code, and Short Description columns.

Note the following:

- Data for formula-based columns is ignored.
- If auto-populated data is provided, the system will import the value, and will not override the imported values except for fields auto-populated by Base Commit, Change Commit, or Unit Cost Control.
- Any line items with the Amount equal to zero will not be imported.
- Use to add new business process records only, not to modify existing business processes.
- You might find that you have to change some of the cells in the CSV file to Text type in order for data to import correctly. For example, if you have a WBS code of 1-1, Microsoft Excel can interpret this entry as a month-day combination and reformat it to Jan-1. In this case, your data import will fail because this data is now an invalid WBS code.
- If the Integration design for the business process includes a Description field for line items, and the associated SOV sheet also contains a Description field, the description from the SOV sheet is imported, and the line item description is not imported.
To import the general spends business process template

1. Navigate to the General Spends business process log.

2. Choose File > Import.

3. Browse to select the file to import.

4. Click OK. If the import is successful, you receive the message Record Creation is in Progress. When the record is created, it is listed in the log.

If there are any import errors, you can open the CSV file to view and correct the errors. No records are imported if any row in the CSV file contains an import error.
**IMPORT GENERAL SPENDS LINE ITEMS INTO A BUSINESS PROCESS**

You can export a template that includes the detail form fields as columns for a specific business process. These fields include the detail line item columns defined in Integration. These fields are always exported in the template as well:

- Reference Number
- Description
- WBS Code
- Breakdown

You can then modify the amounts on the exported template and import it to create new line items for the business process. The exported template contains SOV record information.

**To export the general spends line item template**

If multiple tabs are designed for the line items in the business process, only the data in the Standard tab is exported. For the other tabs, the tab name is included in the exported data for reference, but no data in these tabs is exported. Data from all columns in the Reference Base Commit is exported.

1. Navigate to the General Spends business process log.
2. Click New to create a new business process.
3. Select a Reference Base Commit for the business process. If you do not select a Reference Base Commit, the exported template will not contain data.
5. Click Open to open the file in Microsoft Excel, or click Save to save the file to your local drive. The template exports with SOV data in it, based on the selected Reference Base Commit. No business process line item data is exported.

**To modify the general spends line item template**

1. Open the CSV file in Microsoft Excel. The SOV line item data is shown.
2. Enter the line item information into the spreadsheet. Each line item must begin with a “D”. For multiple tabs, you must enter appropriate tab name in the Tab Name column.
3. Enter required values for the Amount, WBS Code, and Short Description columns.

Note the following:

- Data for formula-based columns is ignored.
- If auto-populated data is provided, the system will import the value, and will not override the imported values except for fields auto-populated by Base Commit, Change Commit, or Unit Cost Control.
- Any line items with the Amount equal to zero will not be imported.
- Use the import to add new line items only, not to modify existing line items.
- Any line items you import will be added after any existing line items.
• You might find that you have to change some of the cells in the CSV file to Text type in order for data to import correctly. For example, if you have a WBS code of 1-1, Microsoft Excel can interpret this entry as a month-day combination and reformat it to Jan-1. In this case, your data import will fail because this data is now an invalid WBS code.

• If the Integration design for the business process includes a Description field for line items, and the associated SOV sheet also contains a Description field, the description from the SOV sheet is imported, and the line item description is not imported.

**To import the general spends line item template**

1. Navigate to the General Spends business process log.

2. Select a business process and click **Open**.

3. Click the Import button. The line items in the imported file are listed after any existing line items. If there are any import errors, you can open the CSV file to view and correct the errors. No line items are imported if any row in the CSV file contains an import error.
Change commit business processes enable you to change the value of a base commit and to also update the SOV created by the contract. This business process is also known as a change order. Change commit business processes are designed in Primavera uDesigner. For more information, refer to the Primavera uDesigner User Guide.

You can use CSV import to create new change commit business processes or to add SOV line items for an existing business process. You can export change commit business process templates at the log level (for header and line item templates with no data exported) and at the record level (for line item templates with SOV data exported). You can then modify the templates and import them to create new records (at the log level) or to add line items to an existing record (at the record level).

An Integration interface must be defined to support CSV import. If you find that you cannot perform the file import, see your Administrator.

Also, new records can be created and line items added using Integration through Web Services. Integration through Web Services must be coordinated with Primavera Unifier Consulting Services.
IMPORT NEW CHANGE COMMIT RECORDS

You can export a CSV template that includes the upper form and detail form fields as columns. These fields include the header fields from the upper form and the line item SOV fields from the detail form, including the detail line item fields defined in Integration.

You can modify the exported CSV template and import it to create a the upper form header information and the detail line items for the new business process.

To export a copy of the change commit business process template

1. Navigate to the change commit business process log.
2. Choose File > Export Template > CSV.
3. Click Open to open the file in Excel, click Save to save the file to your local drive. The template exports with no data in it, and contains only the column headings.

To modify the exported change commit business process template

1. Open the exported CSV file in Microsoft Excel.
2. Enter the business process information into the spreadsheet. Each upper form header record must begin with an “H”. Each line item must begin with a “D”. For multiple tabs, you must enter appropriate tab name in the Tab Name column.
3. Enter data into the required fields, as well as non-required fields as needed.

Note the following:
- Data for formula-based columns is ignored.
- If auto-populated data is provided, the system will import the value, and will not override the imported values except for fields auto-populated by Base Commit, Change Commit, or Unit Cost Control.
- Any line items with the Amount equal to zero will not be imported.
- Use to add new business process records only; not to modify existing business processes.
- All data created through the CSV import is rolled up to the cost sheet
- You might find that you have to change some of the cells in the CSV file to Text type in order for data to import correctly. For example, if you have a WBS code of 1-1, Microsoft Excel can interpret this entry as a month-day combination and reformat it to Jan-1. In this case, your data import will fail because this data is now an invalid WBS code.

To import the change commit business process template

1. Navigate to the change commit business process log.
2. Choose File > Import.
3. Browse to select the file to import.
4. Click OK. The new business processes are listed in the log.

If there are any import errors, you can open the CSV file to view and correct the error. No records are imported if any row contains an import error.
**IMPORT CHANGE COMMIT LINE ITEMS INTO A BP**

You can export a template that includes the detail form fields as columns for a specific business process. These fields include the detail form line item fields defined in Integration.

You can then modify the exported template and import it to create new line items for the business process. The exported template contains SOV record information.

**To export the change commit line item template**

If multiple tabs are designed for the line items in the business process, only the data in the Standard tab is exported. For the other tabs, the tab name is included in the exported data for reference, but no data in these tabs is exported. Data from all columns in the Reference Base Commit is exported.

1. Navigate to the change commit business process log.
2. Click New to create a new business process.
3. Select a Reference Base Commit for the business process.
5. Click Open to open the file in Microsoft Excel, or click Save to save the file to your local drive. The template exports with SOV data in it, based on the selected Reference Base Commit. No business process line item data is exported.

**To modify the change commit line item template**

1. Open the exported CSV file in Microsoft Excel. The SOV line items are listed.
2. Enter the line item information into the spreadsheet. Each line must begin with a “D”. For multiple tabs, you must enter appropriate tab name in the Tab Name column.
3. Enter data into the required fields, as well as non-required fields as needed.

Note the following:

- Data for formula-based columns is ignored.
- If auto-populated data is provided, the system will import the value, and will not override the imported values except for fields auto-populated by Base Commit, Change Commit, or Unit Cost Control.
- Any line items with the Amount equal to zero will not be imported.
- Ensure that you are importing the records you want to import. Any line items that you import will be added after any existing line items.
- Use to add new lines only, not to modify existing lines
- All data created through the CSV import is rolled up to the cost sheet
- You might find that you have to change some of the cells in the CSV file to Text type in order for data to import correctly. For example, if you have a WBS code of 1-1, Microsoft Excel can interpret this entry as a month-day combination and reformat it to Jan-1. In this case, your data import will fail because this data is now an invalid WBS code.

**To import the change commit line item template**

1. Navigate to the change commit business process log.
2. Select a business process and click Open.
3 Click the Import button. The line items in the imported file are listed after any existing line items. If there are any import errors, you can open the CSV file to view and correct the error. No line items are imported if any row contains an import error.

Lease Business Processes

Lease business processes are a Cost type business process. You can use the Lease business process at the project or shell level to set up and manage real estate leases and view the expected Payment Schedule (regular as well as straight line) using the lease data from the business process. You can set up a Lease business process if you are the landlord (lessor), or if you are the tenant (lessee). You can use it for new leases you have just contracted, or existing leases. The Lease business process allows you to track incoming or outgoing payments, and you can use the Generic Cost Manager to roll up the amounts.

Lease business processes are typically used to auto-create invoices (if you are the landlord) or payment requests (if you are the lessee). These auto-created business processes are designed and set up by your administrator.

Lease business processes can be workflow or non-workflow cost business processes. If they are workflow business processes, you can route them like other workflow business processes in Primavera Unifier.

Note: Lease business processes cannot be defined at the Company level, and do not support WBS functions.

Leases can be designed with fields that you can use in line items to perform lease data calculations. These calculations generate lease payment schedules. For example, you could add lines items for rent, cost of maintenance, or taxes to a lease. The data in these line items is data that you enter, or data that is populated based on calculations.

On Leases, you can:

- View expected payments for the lifetime of the lease using the Regular Payment Schedule and Straight Line Schedule reports
- Disable the auto-creation of related BPs, or re-enable these auto-created BPs as needed
- Create Payment Schedules (regular and straight line)
- Create snapshots of the lease for historical purposes

In addition to typical behavior, the Lease business process supports:

- Consolidation from other Cost BPs
- Snapshot creation
- Auto-creation
- Auto generation of Regular and Straight Line Payment schedules
- Integration methods for creating upper form as well as line items of all tabs
- Multiple tabs for line items (up to 8 tabs)
- An allocation template to divide lease payments into different amounts for multiple tenants in a building.
Lease Business Process Terminology

**Lease**: An agreement whereby the owner of real property (the landlord or lessor) gives the right of possession to another (the tenant or lessee) for a specified period of time (the terms of the lease) and for a specified consideration (the rent or lease payments).

**Straight line**: The straight-line method implies that the cash flows in the form of fixed lease payments over the lease term are aggregated and divided by the lease term to arrive at the monthly income or expense. This results in an equal impact in the income statement in each reporting period irrespective of the fact that cash flows differ.

**Escalation**: A clause in a lease which provides for the rent to be increased to reflect changes in expenses paid by the landlord such as real estate taxes, or operating costs. An escalation can be accomplished by several means such as fixed periodic increases, increases tied to the Consumer Price Index, or adjustments based on changes in expenses paid by the landlord in relation to a dollar or base year reference.

In addition to the terminology above, you can find more information about the special fields that can be used on Lease business processes in the *Primavera Unifier and uDesigner Reference Guide*.

Lease Business Process Use Cases

The following are examples of how you can use the Lease BP to manage leases.

**Various Payment Terms for the same lease**

You execute a lease on December 1, 2003 with a commencement date of April 1, 2004 and a termination date of March 28, 2005.

- **Payment Term 1**: A term of $4,000 per month for rent begins on April 1, 2004 and ends on March 28, 2005. The due day is 1.
- **Payment Term 2**: A term of $300 per month for common area maintenance (CAM) starts on April 1, 2004 and ends on March 28, 2005. The due day is 1.
- **Payment Term 3**: A semi-annual term of $500 for taxes begins on September 1, 2004 and ends on March 28, 2005. The due day is 1.

**Different payment allocations for multiple tenants**

For accounting purposes, the rent for a building is to be charged back to departments, based on each department’s space usage. The Marketing Department uses 60% of the space and IT uses 40% of the space. If the total rent for the building is $5000 per month, then Marketing would be charged $3000 and IT would be charged $2000 per month.

**Semi-annual lease terms with proration**

The lease term start date is February 15, 2002, the end date is January 1, 2003. The frequency is semi-annual, and the amount is $1,000 per term. The Proration Rule accounts for the date difference in days, with the end date included.

**Handling rent pre-payments**

The lease term start date is January 1, 2003, the end date is June 30, 2003. The frequency is monthly, and the amount is $6,000 per month. The due day is 1. The pre-payments are the first and last month’s rent.

**Straight lining with quarterly payments**


- Rent for the first quarter is $100
• Rent for the second quarter is $200
• Rent for the third quarter is $300
• Rent for the fourth quarter is $400
• Rent for the fifth quarter is $500

The rent abatement of $10 is given only in the first month. The rent is scheduled to be paid in full at the beginning of each month.

**Straight-line Payment Adjustments.** Straight-line payments can be modified if the business process design includes special data elements (fields). These fields can override the start and end dates of a lease, add or subtract days from the lease term, or add or subtract specific dollar amounts to the lease amount.

These adjustment fields do not change the line item dates or amounts. Unifier takes these adjustments into consideration when it calculates the straight-line payments after you click Save or Finish Editing.

When you open the form in view mode, you will see the adjustments reflected on the Payment Schedule you open from the Payment Schedule button on the toolbar.

**Straight Lining with monthly payments**

The terms are a 12-month lease, with the first month rent-free. The rent is $1000 per month. Real estate rules (FASB 13) require that this rent be normalized (or straight-lined) across the entire lease term.

**Lease term of 20 years with escalation**

The base, or primary, lease term is 20 years. During the base lease term, the monthly lease payment is $10,000 for the first 10 years and $12,000 for the next 10 years.

**Create And Manage Lease Business Processes**

**To create a Lease business process record**

1. Navigate to the Lease business process log.
2. In the Lease BP log, click **New**. The Lease form opens.
3. Complete the Lease business process record. Add the basic lease information to the upper form, including the lease name, number, class of lease, and other details. Add the routing information for the workflow if the BP is a workflow BP.
4. On the detail form, add the payment terms in the Payment Setup tab. Click the **Add** button to add a line item for each aspect of the lease for which you want to create a payment schedule. For example, you can add individual line items for rent, maintenance costs, and taxes.
5. Click **Save**.

**To edit a line item**

As long as the Lease BP form is still a Draft, you can edit a line item at any time. Open the grid by clicking the **Add** button. The Line Items window opens. Make changes and click **OK**.
**To remove a line item**
In the Lease BP form, select the line item to remove and click the **Remove** button.

If you have created an allocation template, you can link the record to it. See [Create and use an allocation template](#).
CREATE AND USE AN ALLOCATION TEMPLATE

If the rent you charge (or pay) should be pro-rated for different tenants in a building, you can create an allocation template and assign it to a Lease BP. The template will designate a breakdown of the costs for each tenant and Primavera Unifier will use this breakdown to create the payment calculations.

For example, for accounting purposes, the rent for a building is to be charged back to departments, based on each department’s space usage. The Marketing Department uses 60% of the space and IT uses 40% of the space. If the total rent for the building is $5000 per month, then Marketing would be charged $3000 and IT would be charged $2000 per month.

To create an allocation template

1. Open the Lease BP you want to create the template for.
2. Click the Allocation button. The Allocation Templates window opens.
3. Click the New button. The Add/Edit Allocation Details window opens.
4. Use the information in the following table to complete the top three fields in this window.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocation Name</td>
<td>Enter a name for the allocation template. This name will appear on the list of allocation templates you can select for the record or line item you create.</td>
</tr>
<tr>
<td>Payment Type</td>
<td>Click the arrow and select the payment type that should be used for the allocations.</td>
</tr>
<tr>
<td>Allocation Type</td>
<td>Select the type of allocation to use for the pro-racion.</td>
</tr>
<tr>
<td></td>
<td>• Percent will pro-rate the lease according to the percentage you specify (see Allocation Value).</td>
</tr>
<tr>
<td></td>
<td>• Fixed will allocate a fixed cost to each tenant.</td>
</tr>
<tr>
<td></td>
<td>• Area will pro-rate the lease according to the square footage each tenant occupies (see Allocation Value).</td>
</tr>
</tbody>
</table>

5. Click the Add button. Primavera Unifier enters a row number and opens an editable text box in the Description field.

6. Use the information in the following table to add rows to the allocation template.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Enter a name to identify the allocation, such as “Sales Dept” or “Uptown Restaurant”.</td>
</tr>
<tr>
<td>Allocation Value</td>
<td>Enter the value of the Allocation Type.</td>
</tr>
<tr>
<td></td>
<td>• For Percent, enter the percentage of the lease that should be paid by the tenant. If you specify percent, the values in all these fields must add up to 100%.</td>
</tr>
<tr>
<td></td>
<td>• For Fixed, enter the lease amount that should be paid by the tenant.</td>
</tr>
<tr>
<td></td>
<td>• For Area, enter the square footage for which the tenant is paying.</td>
</tr>
<tr>
<td>Cost Code</td>
<td>From the picker that opens, select the cost code for the allocation.</td>
</tr>
</tbody>
</table>
7. To add more rows to the allocation template, repeat steps 5 and 6.

8. Click OK.

**To link an allocation template to a lease business process**

1. Open the Lease business process record to which you want to link the template.
2. Click the Allocation button. The Allocation Templates window opens.
3. Select the template you want and click Open.

**View Or Export Payment Schedule**

The Lease BP creates the Regular Payment Schedule and the Straight Line Schedule to allow you to view your future lease payments.

The lease payment schedule is generated automatically after you add or change a line item for the Lease BP. The schedule is time stamped, and is overwritten each time you add or modify a line item. You can capture a particular schedule by exporting it to a PDF file.

**To view or export payment schedule**

1. Open a Lease BP record from the log.
2. On the toolbar, click the Payment Schedules button and choose Regular or Straight Line. The payment schedule window opens.
   The schedule shows currency amounts to two decimal places (e.g., $3120.33).
   The Regular Payment Schedule lists the lease payments as calculated using Frequency, Start Date, and End Date.
   The Straight Line Schedule lists the lease payments averaged over all of the line items of the payment terms for the lease over the life of the lease. You can specify which line items that you want to include in the Straight Line Schedule by clicking the Straight Line radio button on the detail form of each line item to Yes for each item you want listed in the schedule.
3. Click the Export button to save all of the schedule rows or selected rows to a PDF file. Click Save to create the PDF file of the schedule.
4. Click the Close Window button when you are done viewing the schedule.

**Auto-create An Invoice Or Payment Request From A Lease Business Process**

Lease business processes are typically used to auto-create invoices (if you are the landlord) or payment requests (if you are the lessee). For example, a lease business process with a payment schedule can use auto-creation to generate payment request records at appropriate days in advance of the payment due date to be routed for approval.

For cost purposes, these invoices/payment requests do not roll up amounts to the Cost Sheet. To roll up these amounts, the invoice/payment request should, in turn, auto-create another business process for the purpose of rolling up the amount(s) to the Cost Sheet.
**Allocation Templates.** Whenever a Lease BP auto-creates an invoice or payment request, Primavera Unifier will check for an allocation template. If one is linked to the Lease BP, Primavera Unifier will copy it to the invoice or payment request, and use it to calculate the payments. Each allocation will appear as a separate line item under the Standard tab of the invoice or payment request.

---

**Take A Snapshot Of A Lease**

Use the lease snapshot feature to create a historical picture of the lease that you can preserve before the lease is amended or otherwise modified. The snapshot can be created automatically when the Lease BP reaches a certain status, or you can create it manually whenever necessary. Automatic snapshot creation is set up in Primavera uDesigner.

**To save an automatically created snapshot**

1. When the status of the Lease BP changes and a snapshot is created automatically, you receive a message. Enter a title for the snapshot (if you want to overwrite the default title), and an optional description.

2. Click OK. The snapshot is saved in Primavera Unifier.

**To create a snapshot manually**

1. While in the Lease BP, choose **File > Create Snapshot**.

2. Enter a title for the snapshot (if you want to overwrite the default title), and an optional description.

3. Click OK. The snapshot is saved in Primavera Unifier.

**To view and manage snapshots**

1. While in the Lease BP, choose **View > Snapshots**. The Snapshots window opens. The snapshots are listed in the window. Manually created snapshots display Yes under the **User Created** column; system created snapshots display No.

2. To save the snapshot as a PDF file, select a snapshot from the list and click **Open**.
Primavera Unifier displays the PDF file, which shows all the fields from the detail forms for all the tabs on the business process.

3 To view snapshot properties and change the title or description of the snapshot, select a snapshot from the list and click Properties.

4 To delete a snapshot, select a snapshot from the list and click Delete.

5 Click Close when you're done viewing snapshots.
ABOUT THE ASSET MANAGER

The Asset Manager module is part of the company workspace. It is used to manage assets and depreciation. You can track assets and depreciation on their associated asset sheets.

The Asset Manager allows you to:

- Create, organize, and manage company assets
- Define an unlimited number of asset classes, and design an asset attribute form per asset class
- Create assets manually, using templates, or importing
- Apply multiple asset depreciation methods: straight line, double decline, sum of years digits, manual
- Track the asset’s total cost of ownership: roll up maintenance-related costs from projects or company level business processes to specific company account codes

The Asset Manager uses the three most common depreciation methods—straight line, double decline, or sum of year digits—as well as manual depreciation. Irrespective of which method is used, asset depreciation is calculated for the entire life of the asset over whatever period you specify. For example, if an asset is depreciating over two years and you specify a monthly depreciation increment, then the asset’s value will be recalculated each month for two years from the date of acquisition.

**Asset Classes:** Assets are grouped in classes (for example, buildings, equipment, etc.). The detail forms that are used to enter asset information can be configured in Primavera uDesigner per class and imported into Primavera Unifier. For example, you can design and use different forms for entering information about your company’s building assets and equipment assets. Each asset exists as a unique record.

**Asset Codes:** Asset codes are generated automatically when assets are created. The asset code will be built using different data elements defined on the asset form as segments. At runtime, the asset code is built automatically based on the data element values selected. A tree structure is automatically built to access these assets based on the asset codes. Assets with the same segment values will be grouped together to form a hierarchy.

**Asset Sheets:** You can track assets and depreciation on asset sheets. There is one asset sheet per class, listing details about each asset in that class, plus an asset summary sheet, which helps you track all of your assets in one place. User permissions are granted per asset class or sheet. If you cannot view any part of the Asset Manager to which you require access, contact your company administrator.

**Creating And Managing Assets**

You can create and manage your company assets in the Asset Manager in the company workspace portion of the Navigator.

Each asset that you add to the system exists as a unique record. You can create new assets manually by copying from a template within the same asset class, copying another asset in the same class, or by importing assets. The form that is used to enter the details about each asset is designed in Primavera uDesigner for each class. The form design can vary greatly from class to class.
Access The Asset Manager

To access the asset manager

1. In User Mode, go to the **Company Workspace** tab and click **Asset Manager** in the left Navigator. The Asset Manager displays asset sheets and asset classes.

2. To access asset sheets, click the **Asset Sheets** node.

3. To access assets, select an asset class. The log opens for the asset class.

The center navigation pane displays the segments of the asset codes hierarchically by their segments, as selected in the properties window for each asset. These nodes are created as asset codes are created. The right pane lists all assets created under the selected class.

Asset Manager Navigation And Asset Codes

Assets are organized by the segments of the asset codes. Asset codes are based on segments. These segments are created when the asset is created, based on the values entered on the asset form. For example, for an asset class Buildings, the asset codes for individual assets may be built by location segments: country-state-city. You can then view all buildings in the asset class or drill down to all buildings per segment (per country, state or province, and city).

Click the asset class name in the asset navigator to view all assets created under the class, or click each segment to view assets matching the segment.

Create A New Asset

You can create new assets manually by copying from a template within the same asset class, copying another asset in the same class, or by importing assets.

The form that is used to enter the details about each asset is designed in Primavera uDesigner for each class. The form design can vary greatly from class to class.

Each asset that you add to the system exists as a unique record.

You can manually create new assets or create assets by copying from another asset or from a template. If the asset record or template also has a depreciate schedule set up, it will also be copied to the new asset.

To create a new asset manually

1. In User Mode, go to the **Company Workspace** tab and click **Asset Manager** in the left Navigator. Select an asset class. The Asset Class navigator opens.

2. Select the node under which you want to create the new asset.

3. Click **New**. The Create New Asset form opens.

4. Complete the form. This form is similar to a non-workflow business process form and has two sections:

   • **General**: In the upper portion of the form, enter all the details about the asset.
   
   • **Depreciation Schedule**: Setting up a depreciation schedule is optional. Before you can set up a depreciation schedule, you must first save the form.

5. After completing the form, click **Save** to save changes to the upper form, or **Finish Editing** to save and close the form.
To create an asset by copying from a template

1. In the Asset Class navigator, click the Copy button and choose Template. A list window opens displaying all templates for the asset class.

2. Select a template and click Open. The Create New Asset form opens. The form may be populated with general and depreciation information from the template.

3. Make changes as needed and click Save or Finish Editing to save the new asset. After saving, the Depreciation Setup button becomes available.

To copy an asset

1. Select an asset from the log and click Copy > Asset. The form opens, with the information from the original asset.

2. Make changes as needed and click Save or Finish Editing to save the new asset. After saving, the Depreciation Setup button becomes available.

Working With Asset Sheets

Asset sheets are created automatically when asset classes are imported and activated. Asset sheets are listed in the Asset Sheet log window in the User Mode Asset Manager. There is one sheet per asset class, plus an asset summary sheet that summarizes all asset sheets. Assets are added to asset sheets as rows automatically, listed by the segmented asset code. In the asset summary sheet, the rows are the asset classes.

The asset summary sheet displays information of all asset sheets. It displays total values from individual asset class sheets. The asset summary sheet is created automatically once the first asset class is imported. Asset classes imported into Primavera Unifier are automatically added as rows.

Columns can be added to asset sheets. Some examples of columns include:

- Business processes (Company-level BPs with the line items with asset code subtype are available; only the amount field is available.)
- Project cost columns; most columns from project cost sheets are available (only the amount field is available). This is available when projects are created under asset categories.
- Manual entry or formula columns.

Access Asset Sheets

Asset sheets are listed in the Asset Sheet log window in the Asset Manager. There is one sheet per class, plus a summary sheet which lists all sheets in all classes.

**Note:** You must have permissions to access any listed sheet. If you need access to a sheet not listed in the log, contact your company administrator.

To access asset sheets

In User Mode, go to the Company Workspace tab and click Asset Manager > Asset Sheets in the left Navigator. The Asset Sheets log opens. The log lists any existing asset sheets: one asset sheet per class, which is automatically created when an asset class is activated, plus an asset summary sheet that summarizes asset class information.

To open an asset sheet

Select the sheet in the log and click Open.
**View Asset And Column Details**

**To view column details**
Open the asset sheet and click a column heading. A view-only window opens displaying the column details.

**To view asset details**
Open the asset sheet and click a listed asset. Assets appear on the sheet as hyperlinks. A view-only window opens displaying the asset details.

**View Asset Sheet Properties**
The Properties window for the asset sheet maintains the name and display options, and can be used to map a column to a company account code.

**To open the asset sheet Properties window**
In the Asset Sheets log, select the sheet and click the Properties button. In the Options tab, asset sheet columns can be mapped to company account codes. The total value of the column will roll up to the company accounts sheet.

**Enter Or Edit Asset Sheet Data**
For manual data-entry columns, you can enter data directly into the sheet.

**To enter asset sheet data**
1. Open the asset sheet.
2. Click inside a manual entry column cell to enter data.
3. Click the Save button to save changes.

**Create And View A Snapshot**
You can save a snapshot of an asset sheet or the asset summary sheet.

**To save a snapshot**
1. Open the asset sheet or asset summary sheet.
3. Enter a title and click OK.

**To view a saved snapshot**
1. Open the asset sheet or asset summary sheet.
2. Choose View > Snapshot Log. The snapshot log opens.
3. Select the snapshot from the list and click Open. A read-only view of the asset sheet or asset summary sheet opens, displaying the sheet data at the time of the snapshot.

**Import Asset Sheet Column Data**
You can enter column data into manual-entry columns by importing a CSV sheet. Columns are limited to those of numeric data elements on the asset form.

First, export the CSV structure, enter the data into the CSV file, and then re-import the CSV file.
To export a manual-entry column

1. Open the asset sheet.
2. Click Export > Column Data.
3. Save the CSV file to your local drive.

To enter column data

1. Open the CSV file.
2. Enter column data for each listed asset. Be careful not to change the CSV file structure.
3. Save the CSV file.

To import column data

1. Open the asset sheet.
2. Click Import > Column Data.
3. Browse to the CSV file containing the column data and click OK.

Copy Data From One Column To Another

You can copy data from one manual entry column to another.

To copy data from one column to another

1. Click the Edit menu and choose Copy > Column Data. The Copy Column Data window opens.
2. Complete the window as described in the following table.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy from column</td>
<td>Select the manual entry column to copy the data from (numeric or date).</td>
</tr>
<tr>
<td>Percentage</td>
<td>Enter the percent of the value to copy. Enter 100% to copy the entire value.</td>
</tr>
<tr>
<td>Copy to column</td>
<td>Select the manual-entry column to copy the data to (numeric or date, based on the Copy from column selection).</td>
</tr>
</tbody>
</table>

Search For Assets On An Asset Sheet

To search for assets

1. Open the asset sheet.
2. Click View > Find. The Find window opens.
3. Choose a column from the asset sheet and enter a value to search.
4. Select the direction to search (up or down from the selection on the sheet).
5. Click Find Next to search for the entered value. You can click again to continue searching.
6. Click Cancel to cancel the search.
Export Asset Sheet Or Summary Sheet Data

You can export data from asset sheets or the asset summary sheet in CSV format.

To export an asset summary sheet

1. Open the asset summary sheet.
2. Click the Export button and choose Summary Sheet.
3. Save the CSV file to your local drive. The data is for reference only and cannot be re-imported.

To export summary data on an asset sheet

1. Open an asset sheet.
2. Click the Export button and choose Summary Sheet.
3. Save the CSV file to your local drive. The data is for reference only and cannot be re-imported.

Understanding Reverse Auto-population

Certain data elements support reverse auto-population. These are specified in Primavera uDesigner. Reverse auto-population means that some values can be updated when other values are modified in a business process that has reached a specified status. Auto-population can occur on BPs that are in the same shell or across shells.

Depending on the setup in Primavera uDesigner, auto-population can occur in these instances:

- Changes to data elements in a BP upper form can result in changes to the upper form of another BP.
- Changes to the detail form in a BP can result in changes to the upper form and detail form of another BP.
- Changes to the upper form or detail form of a BP can result in changes in the Asset, Resource, or Planning Manager forms.

In the Asset Manager, reverse auto-population might occur if a move-order BP references an asset record. Updates on the move order can be reverse auto-populated on the asset.

Edit Assets Using Bulk Process From The Asset Log

If you have a large number of assets that need similar edits, you can use bulk edit to update all of the assets at once. You can update a maximum of 200 records using bulk asset edit. The bulk asset edit must be defined in Primavera uDesigner, and you must have the Allow Bulk Edit permission set on the asset class.

Note: Bulk edits overwrite data without stopping for you to verify the overwrite of each record. Be sure that you have entered the data you want to edit correctly.

To update assets using bulk edit

1. Navigate to the asset log.
2. Select one asset or several assets, or perform a find to search for a group of assets to work with. You can select the assets from the asset log or the Find log.
3. Choose Edit > Bulk Edit. The Bulk Edit window opens. The fields displayed in this window depend on what was specified for detail form integration in Primavera uDesigner for the asset class.
The Bulk Edit form includes all editable fields for the detail form for the asset class.

4 Modify the bulk edit form as needed.

5 Select the Update checkbox for the fields you want to update. The checkbox is automatically selected when you type into or modify a field. You can deselect it if you do not want to modify the field at this time.

6 Click Update. This launches the bulk update of the selected assets.

7 The Bulk Actions Status window displays after you click Update. This window allows you to monitor the progress of the bulk asset update. Click OK after all records have processed. Click Cancel if you want to cancel the bulk update in progress.

**Print An Asset Form**

At times, you may need to print copies of an asset form. You can save a copy of the form as a PDF file and print the file, print an HTML view, or print from a Word file if a custom print layout has been created for the form.

When printing asset forms from PDF or HTML format, you can choose to include not only the information on the form itself, but also associated information such as general comments and information about file attachments. The print options are:

- Detail form data
- General comments made to the record
- Information about file attachments on the record or line items
- Comments made to file attachments

If custom print layouts have been created for the asset class, the form will print according to the layout that you select.

**To preview and print an asset form in PDF or HTML format**

1 Open the asset record that you want to print.

2 From the File menu, choose Print Preview, then choose the file type.
   - HTML: to view the form in the browser, which can then be printed.
   - PDF: to open the form in Adobe Reader, which can be saved as a PDF file, or printed.

The Print Options window opens. This window displays the record information that can be printed.

3 Select the check boxes for the information that you want to print.

4 To select all the checkboxes, click the Select All checkbox. To deselect all, uncheck the Select All checkbox. If you deselect all checkboxes, only the header and footer will print.

5 Click OK. The preview form opens in an HTML or PDF (Adobe Acrobat or Reader) window, from which you can print.

   If you chose PDF, you can save a copy by clicking the Save a Copy button, or print. To print from HTML format, click on the Print icon in the upper right corner.

**Print Options**

Following is a summary of the print options.
<table>
<thead>
<tr>
<th>Print option</th>
<th>What it prints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detail Form</td>
<td>This prints the information entered on the form. Depreciation details in the line items are not printed.</td>
</tr>
<tr>
<td>General Comments</td>
<td>The general comment text and create details are printed.</td>
</tr>
<tr>
<td>Record Attachments</td>
<td>File attachments to the record are listed alphabetically by file name, and also include the file title, issue date, revision number, and file size.</td>
</tr>
<tr>
<td>Record Attachments &gt; Comments</td>
<td>Prints comments associated with file attachments to the record. “Record Attachments” must also be selected to select this option.</td>
</tr>
</tbody>
</table>

**To print an asset form with a custom print layout**

1. Open the asset form that you want to print. Be sure it is in a view mode.

2. From the **File** menu, choose **Print Preview > Custom**. The Custom Format Print window opens. The window lists custom layout options set up by the administrator.

3. Select a layout and click **Ok**. The File Download window opens.

4. Choose to **Open** or **Save** the file, which is a Microsoft Word DOC file.

5. Open the file in Microsoft Word and print. This feature can be used with Microsoft Word 2003 and 2007.
CONFIGURABLE MANAGERS
ABOUT CONFIGURABLE MANAGERS

Configurable Managers have flexible coding structures that allow you to analyze your data. Configurable Managers are created and named in Primavera uDesigner depending on the intended task. They can be created at the shell, project, or company level. They provide additional functionality and do not replace existing managers. A Configurable Manager behaves like any other module in the application. You can have up to 25 Configurable Managers.

Note: This section uses a Parts Manager and Facilities Manager as examples. The Configurable Managers that you are working with will have different names and purposes.

There are two types of Configurable Manager: code- and record-based and code-based.

Code-and-Record-based Configurable Managers

A code-and-record-based Configurable Manager allows you to define codes and capture data using records. This type of manager allows multiple classes of sheets and records to be created, each with its own coding structure. For a code- and record-based manager, you must first create the manager sheet. Thereafter, Primavera Unifier automatically adds information to the sheet as it is gathered from records that were created from business processes tied to the sheet.

For example, a Parts Manager could be created to do the following:

- Categorize parts by type (or class) by creating records for classes
- Track inventory at various locations
- Maintain basic cost information
- Track parts transactions (bought, sold, received, or shipped)
- Monitor costs generated by transactions

Code-based Configurable Managers

A code-based Configurable Manager also allows you to define codes, but it works with sheets to analyze information generated manually or from BPs. All the data is consolidated in one sheet. For a code-based manager, you must manually enter the rows on the sheet. Thereafter, Primavera Unifier automatically adds data to the rows as you manually enter it, or as it is gathered from records that were created from business processes tied to the sheet.

For example, a Condition Assessment Manager could be created to do the following:

- Define a building systems code structure at the company level, project level, or shell level
- Design multiple BPs to track and calculate:
  - Maintenance requirements
  - Inspections
  - Work orders
  - Repairs
  - Cost of maintenance
  - Deficiency costs
  - Renewal costs
• Various indices, such as a facility condition index, to monitor the condition and usability of facilities

**Access A Configurable Manager**

Configurable Manager modules are designed in Primavera uDesigner and configured by your company administrator.

**Note:** User permissions are granted per class or sheet. If you cannot view any part of the Configurable Manager to which you require access, contact your company administrator.

**To access a Configurable Manager at the project, or shell level**

In User Mode, open the project or shell where the manager resides and click **Configurable Modules > [configurable manager]** in the left Navigator.

If you are using a code- and record-based Configurable Manager, there are sheets and classes.

If you are using a code-based Configurable Manager, there is just one sheet, which is listed under the log

• To access a sheet, click the **Sheets** node, and select a sheet from the log.
• To access a class, select a class. The log for the class opens. The center navigation pane displays the segments of the codes hierarchically as selected in the properties window for each class. The right pane lists all the records created under the selected class.

**Reverse Auto-population And Code- And Record-Based Managers**

Certain data elements support reverse auto-population. These are specified in Primavera uDesigner. Reverse auto-population means that some values can be automatically updated when other values are modified in a BP form or record attribute form.

You can use reverse auto-population to update fields on records, as well as attribute forms and line items. This can streamline the use of forms by keeping the information on them up-to-date with the latest Primavera Unifier data from components inside or outside the business process.

Depending on the set up in Primavera uDesigner, reverse auto-population can occur in these instances:

• Changes to the data elements in a BP detail form under the Company level can result in changes to the record attribute form of a generic manager a the Company level
• Changes to the data elements in a BP detail form under the Standard Project level can result in changes to the record attribute form of a generic manager a the Standard Project level
• Changes to the data elements in a BP detail form under the shell level can result in changes to the record attribute form of a generic manager a the shell level

**Creating Sheets And Records For A Code-and-Record-based Manager**

Configurable Manager sheets enable you to capture data for Configurable Manager records.

You can update data in the sheet or in the record. When you update data, it is updated as needed in both places dynamically. Updates occur when you save a sheet or refresh a record. In addition, when you create a record under an appropriate class, it is are automatically added to the Configurable Manager sheet.
To create a new sheet

1. In User Mode, select Sheets from the level that you are working in. The Sheets log opens.
2. Click New.
3. Select the class for which you want to create the new sheet. The Properties window opens. Complete the window as described in the following table and then click OK.

**Note:** Your Properties window may vary depending on the setup in Primavera uDesigner.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Enter the name of the sheet, which reflects the class name and is read only.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description.</td>
</tr>
<tr>
<td>Class</td>
<td>Read-only field displaying the class for the sheet.</td>
</tr>
<tr>
<td>Display Mode</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Tree: Lists the codes in a hierarchical manner based on the code segments and mimicking the tree structure in the Navigator.</td>
</tr>
<tr>
<td></td>
<td>• Flat: Lists the codes in a flat structure.</td>
</tr>
<tr>
<td></td>
<td>• Expand all codes: If you have selected a tree structure, you can use this option to specify that the sheet should always open with all rows expanded.</td>
</tr>
<tr>
<td>Default Filter View</td>
<td>If any filters have been created to restrict the information on the sheet, you can use this option to specify a default filter to use for this sheet.</td>
</tr>
<tr>
<td>Picker</td>
<td>Choose one of the following to include:</td>
</tr>
<tr>
<td></td>
<td>• All Records: All records created in the class are displayed on the sheet.</td>
</tr>
<tr>
<td></td>
<td>• Records with statuses: Click Select and choose one or more statuses from the list. Only records with selected statuses are displayed on the sheet.</td>
</tr>
</tbody>
</table>

Create Records For Classes

After you have created a sheet for a class, you can enter new class records or manage existing class records in that sheet.

To enter class records in a sheet

1. Navigate to the class node under the Configurable Manager node at the company, project, or shell level. The Class log opens. You can add or modify records based on your permissions.
2. The right side of the log lists the records created for the class. Click New to create a new record.
3. Enter the record data.
4. When you have completed the record, click Finish Editing.

Create A New Sheet From An Existing Template

You can create a sheet by copying an existing template from the same class.

To copy an existing template

Select a class template from the log.
1 To copy a template, do one of the following depending on which level the template is:

2 To copy a template, do one of the following, depending on which level the template is:
   • At the company level, click **Copy > Template**.
   • At the project level, click **Copy > Project**.
   • At the shell level, click **Copy > <shell name>**.

The Properties window opens with the information from the original template.

3 Make changes as needed in the Properties window, and click **OK** to create the new sheet.

### Creating Sheets For A Code-based Manager

Configurable Manager sheets enable you to capture data for Configurable Manager records. No data exists for a record until you create a sheet and populate it with data.

#### To manually create a new sheet

1 In User Mode, select **Sheets** from the level that you are working in. The Sheets log opens.

2 Click **New**. The Properties window opens. Complete the window as described in the following table.

   **Note:** Your Properties window may vary depending on the setup in Primavera uDesigner.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Enter the name of the sheet, which reflects the class name and is read-only.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description.</td>
</tr>
<tr>
<td>Default Display Mode</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Tree</strong>: Lists the codes in a hierarchical manner based on the code segments and</td>
</tr>
<tr>
<td></td>
<td>mimicking the tree structure in the Navigator.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Flat</strong>: Lists the codes in a flat structure.</td>
</tr>
</tbody>
</table>

3 In the Segments tab, you can define the segments of the codes that will be created on the sheet. Click **Add** to add a new segment. Choose a segment source for the segment. The segment sources are defined in Primavera uDesigner.

4 Click **OK**.

   You can view the attributes for a code by clicking on the code.

### Working With Configurable Manager Sheets

#### Create A New Sheet From An Existing Template

You can create a sheet by copying an existing template from the same class.
To copy an existing template

1 Select a class template from the log.

2 To copy a template, do one of the following depending on which level the template is:
   - At the company level, click Copy > Template.
   - At the project level, click Copy > Project.
   - At the shell level, click Copy > <shell name>.

The Properties window opens with the information from the original template.

3 Make changes as needed in the Properties window, and click OK to create the new sheet.

Add Columns To A Sheet

If you have create permission, you can add columns, but not rows, to a Configurable Manager sheet template. The columns can capture data from business processes or manually entered data.

To add a column to a sheet

1 Open the sheet.

2 Click Columns. The Columns log opens.

3 Click New. The Column Properties window opens. Complete the window as described in the following table.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The Name field is populated with the data source value selected.</td>
</tr>
<tr>
<td>Datasource</td>
<td>Select a data source. The data sources available are data elements that are defined in the detail form for a class in Primavera uDesigner. Also listed are data elements based on SYS Numeric Logical Datasource, SYS Date Logical Datasource, SYS Project Cost Datasource, SYS BP Currency Amount, SYS BP Decimal Amount, and SYS BP Integer Amount data definitions. <strong>Note:</strong> You can add data picker fields as columns, but you cannot invoke the data picker from the sheet.</td>
</tr>
<tr>
<td>Width (pixels)</td>
<td>Enter the width the column should be. Maximum is 2000 pixels. (You can also manually resize the columns on the sheet.)</td>
</tr>
<tr>
<td>Alignment</td>
<td>Specify whether the data in the column should be left- or right-aligned, or centered.</td>
</tr>
</tbody>
</table>
| Entry Method  | Choose a data entry method for the column. The options vary depending on the data source selected:  
   - **Manual entry:** You can enter data directly into the cell, or data is rolled up from another source, such as the form.  
   - **Formula:** Formula types are numeric, date difference, and date add. See "Add a formula column" on page 364 for details on working with formulas.  
   - **Define:** Use this method to specify data that should roll up from line items. Click the Define button and in the Formula Creation window, select the BPs and fields whose values should roll up to the manager sheet. You can select single fields to roll up, or you can add several fields together for a combined roll up amount. |
| Data Format   | Specify how the column data appears for numeric columns. The options are:  
   - **Show as Percentage:** Data entered in a column is displayed as a percentage. For example, if you enter 0.25, it displays as 25%.  
   - **Decimal Places:** Select the number of decimal places to display (0 to 8). |
In this field: | Do this:
---|---
• Use 1000 Separator (,): If you select this option, the entered data is formatted with a separator for numbers with more than three digits. For example, 1,000 rather than 1000.
• Negative Number Format: Specify if negative values are displayed with a negative sign or in parentheses.

Display Mode
Select Hide to make the column invisible to users. Select Show to display it. You can show/hide any column on the sheet, including the code name column.

Summary Rows
Specify what the summary rows display.
• Blank: Summary row remains blank.
• Sum of All Rows: Summary row displays the sum total of all row values for this column.
• Use Formula Definition: Formula entered in the Formula field applies to the summary row.

Total
Specifies what displays in the bottom summary row for each column:
• Blank: Summary row remains blank.
• Sum of All Rows: Summary row displays the sum total of all row values for this column.
• Use Formula Definition: Formula entered in the Formula field applies to the summary row.

Column Position After
Determines the position of the column on the sheet.

To copy a column

1. In the Column log, select a column and click Copy.
2. The Column Properties window opens. Make changes as necessary for the new column. You must change at least the data source.

View Column Properties

The Properties window for a column maintains the column name, data source, entry method, and other properties for that column.

To open the column properties window

In the sheet, click on a column link. The View Column window opens, showing the data source from which the column values are gathered and the data entry method, including any formula used to calculate the values.

Add A Formula Column

You can add a formula column to the sheet for data sources that are based on either the data definitions SYS Numeric Logical Datasource or SYS Date Logical Datasource.

You can define formulas for the following types:

• **Numeric**: This option is available if the data source is SYS Numeric Logical.
• **Data Difference**: This option is available if the data source is SYS Numeric Logical. It is used for formulas that calculate the difference between two dates.
• **Date Add**: This option is available if the data source is SYS Date Logical. It can be used to add values to a date to calculate a new date.
To create a numeric formula

1. In the column Properties window, choose Formula and select Numeric.
2. Click Create. The Create Formula window for numeric formulas opens.
3. Select either Item or Sheet from the data type drop-down list. Item lists data elements that are defined on the form. Sheet lists columns that are already defined on sheet.
4. Build a formula by doing the following:
   - To include a data source in the formula, select the data source from the list and click Select.
   - Click a mathematical modifier (plus, minus, and so on) and numbers on the keypad.
5. When the formula is complete, click OK.

To create a date difference formula

1. In the column Properties window, choose Formula and choose Data Difference. Click Create. The Date Difference window opens.
2. For Earlier Date and Later Date, click Select. Select a data element. The list includes date type data elements from the form or existing date type columns on the sheet.
3. Choose one of the following:
   - Calculations based on Calendar Days: The calculation is based on calendar days and does not take company non-working days into account.
   - Calculations based on Work Days: The calculation is based on the company calendar working and non-working days.
   - Show Partial Day
4. Click OK.

To create a date add formula

1. In the column Properties window, choose Formula and choose Data Add. Click Create. The Date Add window opens.
2. For the Date field, click Select and choose a data element from the list.
3. For the Add field, click Select and choose a data element from the list.
4. Choose one of the following:
   - Calculations based on Calendar Days: The calculation is based on calendar days and does not take company non-working days into account.
   - Calculations based on Work Days: The calculation is based on the company calendar working and non-working days.
5. Click OK.
OPEN A SHEET

Manager sheets are listed on the Sheet log of the configurable manager.

**Note:** You must have permissions to access a sheet. If you need access to a sheet not listed in the log, contact your company administrator.

**To open a sheet for a code-based manager**

1. Open the project or shell in which the manager resides and click **Configurable Modules** in the left Navigator. The Navigator expands to display the configurable managers that have been created for this project or shell.

2. Select the configurable manager you want to work in. Primavera Unifier displays the sheets log.

3. On the sheets log, double-click the name of the sheet. Primavera Unifier opens the sheet.

**To open a sheet for a code-and-record-based manager**

1. Open the project or shell in which the manager resides and click **Configurable Modules** in the left Navigator. The Navigator expands to display the configurable managers that have been created for this project or shell.

2. In the Navigator, click the name of the manager you want to work in. The Navigator expands to display a Sheets node.

3. In the Navigator, click the **Sheets** node. Primavera Unifier displays the sheets log, listing a sheet for every class created for the manager.

4. On the sheets log, double-click the name of the sheet. Primavera Unifier opens the sheet.

**Expand Or Collapse The Sheet Rows**

For convenience in viewing sheet data, you can expand and collapse the rows to expose and close sub-items on the sheet.
To expand the rows in the sheet, to show all sub-rows, click the Expand button.

To collapse a row, click the Collapse button.
From the sheet, you can use hyperlinks to drill down to additional detail about the item.
VIEW OR EDIT CODE DETAILS

Each row item on the sheet is identified by a code, which is in the first column on the sheet. The code is hyperlinked. If you want to see more detail about the row item, click the link.

For a code-and-record-based manager

Primavera Unifier will display the attribute or detail form of the item. You cannot edit this form. For a code-based manager Primavera Unifier will display a Code Details window showing the fields from the manager’s attribute form. Because the sheet for a code-based manager is designed to be more dynamically editable, you can edit any field on this window that is not grayed-out (the code field is never editable). If the field appears as a column on the sheet, any change you make to the field on the Code Details window will appear on the sheet. Reciprocally, any change you make on the sheet will also appear for the item on the Code Details window.

For a code-and-record based manager

Primavera Unifier will display a read-only copy of the attribute/detail form for the item. You cannot edit this form because the manager gathers its information automatically from the records that are created. The records are not editable.

View Rollup Data

For code-and-record-based managers, BP line item data, such as costs and quantities, can be configured to roll up to the manager sheet from across shells. Cells that contain rolled-up data will show a hyperlinked value. You can click on this hyperlink to open a cell details window and view all the business process transactions that contributed to the rollup.
SORT THE SHEET CONTENT

If the manager sheet is in flat mode (that is, it lists the codes in a flat structure, rather than hierarchically), you can sort the content on the sheet by column. By default, Primavera Unifier shows column data in ascending order.

To sort column data
Click the column heading. Primavera Unifier will re-display the data in that column in descending order. To return the column data to ascending order, click the heading again.

Filter The Sheet Content
Some managers, particularly those configured to function across shells, can accumulate a substantial amount of data. To make viewing this data easier, you can create filters to restrict the content of the sheet.

To create a filter
1. Open the sheet.
2. From the View menu, choose Filters.... The Setup Filters window opens.
3. Click the Add button. The Add Filter window opens.
4. In the Filter Name field, enter a name for this filter.
5. Click the Add button. The Query Condition window opens.
6. In the Data Element field, enter the name of the field you want to appear on the manager sheet. The values in the field must meet a condition (such as “equals” or is “greater than”) to be included on the sheet.
   Depending on the data element you enter, the Query Condition window will display variable fields.
7. Click OK, or click Apply Filter to filter the sheet content.
To apply a filter to a sheet

1. Open the sheet.
2. From the View menu, choose Filters.... The Setup Filters window opens, showing a list of the filters that have been created for the sheet.
3. Select the filter you want to use and click Apply Filter.

Unifier displays a filtered view of the manager sheet. While in a filtered view, you can use all sheet functions except Export and Import.

If you want to re-display all the rows on the sheet, you can clear the filter by choosing Clear Filters from the View menu.

To edit a filter

1. Open the sheet.
2. From the View menu, choose Filters.... The Setup Filters window opens, showing a list of the filters that have been created for the sheet.
3. Select the filter you want to edit and click Edit.

View Sheet Properties

The Properties window for the sheet maintains the name and display options. It can be used to map a column to a company account code.

To open the sheet Properties window

In the Sheets log, select the sheet and click the Properties button.

- The General tab is described in the following table.
- In the Options tab, sheet columns can be mapped to company account codes.

Enter Sheet Data

For manual data-entry columns, you can enter data directly into the sheet.

To enter data on a sheet

1. Open the sheet.
2. Click inside a manual-entry cell and enter the data.
3. Click Save.
EDIT SHEET DATA

You can perform some editing on the sheet itself. Columns are designated with an entry method when they are added to the sheet. If the column specified “manual entry,” you can enter data directly into that column on the sheet. If you change a field value on the sheet, Primavera Unifier will also change the field on the item’s attribute or detail form.

Note: The name of the row item is always editable. The code, however, is never editable.

To enter data on a sheet

1  Double-click inside a manual-entry cell. Primavera Unifier will highlight the cell data and open a text box.
2  Enter the data in the text box and click Save.

Create And View A Snapshot

You can take a snapshot of a sheet to keep as a record and view later.

To create a snapshot

1  Open the sheet.
2  Select File > Create Snapshot. The Create Snapshot window opens.
3  Enter a title and click OK.

To view a saved snapshot

1  Open the sheet.
2  Select View > Snapshot Log. The Snapshot log opens.
3  Select a snapshot from the list and click Open. A read-only view of the sheet opens, displaying the sheet data at the time of the snapshot.

Copy Data To Another Column

You can copy data from one manual-entry column to another.

To copy data from one column to another

1  Select Edit > Copy > Column Data. The Copy Column Data window opens.
2  Select the manual-entry column to copy, the percentage value, and the column to which to copy.
3  Click Copy.

Search For Records On A Sheet

To search for records

1  Open the sheet.
2  Click Find. The Find window opens.
3 Select the search criteria:
   - **Column**: Choose a column from the sheet.
   - **Value**: Enter a value to search.
   - **Search**: Select the direction to search from the selection on the sheet.

4 Click **Find Next** to search for the entered value. You can click again to continue searching.

5 Click **Cancel** to cancel the search.

**Export Sheet Data**
You can export data from columns that have been manually entered to a CSV file. The data is for reference only and cannot be re-imported.

**To export columns from a sheet**
1. Open the sheet.
2. Click the **Export** button and choose **Codes** (for code-based managers only) or **Column Details**.
3. Select the columns to export and click **OK**.
4. Save the CSV file to your local drive.

**Import Sheet Column Data**
You can enter data into manual-entry columns by importing a CSV sheet. The column must be configured on the record detail form to accept numeric data elements.

**To import column data**
1. In the CSV file, enter data for each listed record. Be careful not to change the CSV file structure.
2. Save the CSV file.
3. Open the sheet to which you want to import the data.
4. Click the **Import** button and choose **Codes** (for code-based managers only) or **Column Details**.
5. Browse to the CSV file containing the column data and click **OK**.

**Note**: You cannot delete summary rows from the sheet using a CSV import. You also cannot delete existing rows using CSV import if their codes have been added to business processes.

**Bulk Editing Configurable Manager Records**
If you have a large number of records that need the same edits, you can use bulk edit to update all the records at once. You can update up to 200 records at a time. Bulk editing must be defined in Primavera uDesigner, and you must have the Allow Bulk Edit permission set for the manager.

**Note**: You cannot bulk edit codes or names.
To update records using bulk edit

1. Navigate to the Configurable Manager log.

2. Select one or more records or use Find to search for a group of records with specific criteria. You can select the records from the class log or the Find log.

3. Select Edit > Bulk Edit. The Bulk Edit window opens. The fields displayed depend on what is specified in Primavera uDesigner for detail form integration for the class.

**Note:** Bulk edits overwrite data without asking you to verify each change. Be sure that you have entered the data you want to edit correctly.

4. The Bulk Edit form includes all editable fields for the detail form. Modify the Bulk Edit form as needed.

5. Select the Update checkbox for the fields that you want to update. The checkbox is automatically selected when you type in a field. You can deselect it if you do not want to modify the field.

6. To start the bulk update of the selected records, click Update. The Bulk Actions Status window displays the progress of the update.

7. Click OK after all records have processed. Click Cancel if you want to cancel the bulk update in progress.

Print A Configurable Manager Form

For code and record based managers, you can print a copy of the record form. You can save a copy of the form as a PDF file and print the file, print an HTML view, or print from a Word file if a custom print layout has been created for the form.

When printing forms from PDF or HTML format, you can choose to include not only the information on the form itself, but also associated information such as general comments and information about file attachments. The print options are:

- Detail form data
- General comments made to the record
- Information about file attachments on the record or line items
- Comments made to file attachments

If custom print layouts have been created for the configurable manager, the form will print according to the layout that you select.

To preview and print a configurable manager form in PDF or HTML format

1. Open the configurable manager record that you want to print.

2. From the File menu, choose Print Preview, then choose a file format.

   - HTML opens the form in the browser, which can then be printed.
   - PDF opens the form in Adobe Reader, which can be saved as a PDF file, or printed.

The Print Options window opens. This window displays the record information that can be printed.

3. Select the checkboxes for the information that you want to print.

4. To select all the checkboxes, click the Select All checkbox. To deselect all, uncheck the Select All checkbox. If you deselect all checkboxes, only the header and footer will print.
Click **OK**. The preview form opens in an HTML or PDF (Adobe Acrobat or Reader) window, from which you can print.

If you chose PDF, you can save a copy by clicking the **Save a Copy** button, or print. To print from HTML format, click on the **Print** icon in the upper right corner.

**Print Options**

The following summarizes print options.

<table>
<thead>
<tr>
<th>Print option</th>
<th>What it prints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detail Form</td>
<td>This prints the information entered on the form.</td>
</tr>
<tr>
<td>General Comments</td>
<td>The general comment text and create details are printed.</td>
</tr>
<tr>
<td>Record Attachments</td>
<td>File attachments to the record are listed alphabetically by file name, and also include the file title, issue date, revision number, and file size.</td>
</tr>
<tr>
<td>Record Attachments &gt; Comments</td>
<td>Prints comments associated with file attachments to the record. “Record Attachments” must also be selected to select this option.</td>
</tr>
</tbody>
</table>

**To print a configurable manager form with a custom print layout**

1. Open the form that you want to print. Be sure it is in a view mode.
2. From the **File** menu, choose **Print Preview > Custom**. The Custom Format Print window opens. The window lists custom layout options set up by the administrator.
3. Select a layout and click **Ok**. The File Download window opens.
4. Choose to **Open** or **Save** the file, which is a Microsoft Word DOC file.
5. Open the file in Microsoft Word and print. This feature can be used with Microsoft Word 2003 and 2007.
COST MANAGER OVERVIEW

The Cost Manager consists of the modules and features listed below.

Cost Sheets

**Project/Shell cost sheet:** The project or shell cost sheet is a detailed accounting of the project’s or shell’s budget and costs. It works much like a spreadsheet within Primavera Unifier that calculates and maintains the project or shell cost information stored in the project or shell. The project or shell cost sheet rows contain unique WBS codes (or cost codes), which can be used to link project or shell or program costs to the general ledger for finance. Cost information can be entered manually, pulled from work packages or worksheets, or rolled up automatically from business processes when transactions occur in Primavera Unifier.

**Program cost sheet:** Program cost sheets are created automatically once a project cost sheet has been created in at least one project within the program. The columns of the program cost sheet can be set up to allow cost sheet data to roll up automatically from individual project cost sheets. The program cost sheet will display cost data for all projects within the program that have a status of active or on hold. The currency used is the company base currency. Projects on the program cost sheet are sorted automatically by ascending project number. As new projects are added to the program, and cost sheets are created for them, the new projects will be automatically added to the program cost sheet.

**Company cost sheet:** The company administrator can create a company-level cost sheet to display cost data across project or shells. Projects or shells on the company cost sheet are added by default as project- or shell-level cost sheets are created. Only active and on-hold projects or shells should be rolled up to a company-level cost sheet. Projects and shells are listed in order by project or shell number in an ascending order. Data rolls up to the company cost sheet columns by data source. The data displayed on the program cost sheet is view only.

**Work packages:** In addition to a project or shell cost sheet, multiple work packages may also be defined. A work package is a group of cost sheet rows that is a subset of the project or shell cost sheet. Work packages provide insight into the budget without providing full access to the details of the project or shell cost sheet.

**Worksheets:** Cost worksheets can be created to support the project or shell cost sheet. They can be used as sub-cost sheets, enabling specific calculations or data entry in a separate sheet, which can then be rolled up into a defined project or shell cost sheet column. For example, a worksheet can be used to offload complex calculations, which can be rolled up into a single cost sheet column. Worksheets support manual data entry and formulas. Business processes do not roll up to worksheets. Permissions can be controlled for individual worksheets. Worksheets are not independently reportable; however, cost sheet columns that reference worksheets can be reported on.

Funding Manager

**Company funding sheets:** The company funding sheet tracks all sources of funding across all projects or shells and programs. You create only one sheet per company. Funding sources that are made available at project or shell sheet level are rolled up to the company sheet, which maintains the overall fund information. Once created, the company funding sheet can be edited, but not deleted. The company funding sheet must be created before creating individual project or shell funding sheets.

**Project/Shell funding sheets:** The project or shell funding sheet tracks how funding is being allocated and consumed at the project or shell level. Project or shell fund sheets work in conjunction with the company funding sheet. Allocating funding sources at project or shell level can be done manually or
through a business process. A funding template and company funding sheet must be complete before you can create a project or shell funding sheet.

**Commitment funding sheets:** You can optionally set up commitment level funding, which allows you to allocate specific project/shell funds to individual base commit records. This works in conjunction with the SOV sheet to track base and change commit lines and balances.

**Cash Flow and Cash Flow (basic)**

Primavera Unifier’s advanced Cash Flow module includes the ability to create multiple baseline, spends, forecast and custom curves and compare them on one cash flow worksheet. You can create data source, distribution profiles, and cash flow curve templates to simplify creation of cash flow in multiple projects and shells. Administrators can also set up base commit business processes to automatically create cash flow curves for the commitment record at a particular workflow step (or for non-workflow BPs, when the record is complete).

**Earned Value**

The earned value module provides quantitative tracking information about project or shell status using earned value analysis. It provides specific numerical measurements for reviewing progress as the project or shell team advances through the work tasks allotted to the project or shell schedule. The module helps project or shell managers track whether projects or shells are on schedule and on budget. It provides accurate and consistent methods to estimate the percent of budget spent, percent of work done, and percent of time elapsed.

**Schedule of Values**

The schedule of values (SOV) module provides a way to assemble information from contract, change order and invoice/payment business processes into an SOV sheet, streamlining the process of invoicing for completed phases of a project or shell. SOV functionality is available with Primavera uDesigner-created cost BPs for which the Allow creation of Schedule of Values option is defined. The business processes can be designed to create an SOV sheet automatically upon reaching the designated step. There are two types of SOV sheets: general and payment applications.

**Generic Cost Manager**

The Generic Cost Manager captures cost-related activities for a generic shell. These include costs like rent, lease payments, landscape care, building maintenance and repair, remodel of building interiors, and more.

With this manager, you can capture and view cost transaction information based on a timescale, such as quarterly or yearly. Each shell can have one Generic Cost Manager. The Generic Cost Manager uses specific generic cost business processes as a data source.

**About Cost Managers and Primavera Unifier functional areas**

The standard Cost Manager and the Generic Cost Manager work with different areas of Primavera Unifier. This table lists the areas and the indicates which cost manager works with each area.

<table>
<thead>
<tr>
<th>Cost Manager</th>
<th>Company</th>
<th>Program</th>
<th>Project (Standard)</th>
<th>Shell (WBS)</th>
<th>Shell (Generic)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Manager (standard WBS)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Generic Cost Manager</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>
The cost data from Project (Standard) and Shell (WBS) can both roll up to the Company level. The cost data from Shell (Generic) does not roll up to Company Level.
WORKING WITH COST SHEETS

This section discusses how to work with company, program, and project or shell cost sheets, work packages, and worksheets.
ABOUT RULES AND RULE EXCEPTIONS

Primavera Unifier employs a rules engine to help control costs as they roll up to the Cost Sheet. Your administrator creates rules to work with the rules engine. For example, your administrator might create a rule that enforces a budget limit on contracts so that invoices do not exceed the contract amounts. When a cost exceeds a rule, it triggers a “rule exception,” and Primavera Unifier displays a message window warning you of the exception. The window shows the level of the rule, an identifier, the rule that was exceeded, the current value of the field, and the value that triggered the rule exception.

Rule exceptions can be triggered by:

- Adding or copying a line item on the Cost Sheet
- Copying data from one column to another on the Cost Sheet
- Entering data directly into a cell on the Cost Sheet
- A SmartForm that sends cost data to the sheet
- An email action that sends cost data to the sheet
- An integration transaction that sends cost data to the sheet
- I Step and S Step business process auto-creation
- A business process record that rolls up cost data to the sheet

Some users can override a rule violation. These users are specified when the administrator creates the rule. These users can choose to override the exception, or accept it.

If you override the rule exception, Primavera Unifier sends your user information and any comments you include to the audit log. If notification was specified when the rule was created, those users who were designated will be notified by email of the override.

If you accept the rule exception (click Cancel), you will stay on the current step.

Note: Primavera Unifier does not display the rule exception warning if the cost data comes from a SmartForm, an email action, an integration transaction. If you have override control, Primavera Unifier will assume that you want to override the rule and sends information to the audit log.
## WORKING WITH PROJECT OR SHELL COST SHEETS

This section discusses working with cost sheets in Standard Projects and in WBS-code based shells.

### Open A Project Or Shell Cost Sheet

The ability to open, view, enter data, work with the column structure or modify properties on a cost sheet is dependent upon the permissions that you have. Contact your project or company administrator if you have questions regarding your permission levels.

**Note:** When you first open the sheet, the opening view will depend on the Default View option selected in the Properties window. Your cost sheet administrator can set this default view. Cost sheets can be resized and split/unsplit (See "Resize cost sheet window" on page 383 or See "Split or unsplit cost sheet window” on page 383).

To open a project or shell cost sheet

1. Open the project or shell.
2. Click **Cost Manager > Cost Sheet** in the left Navigator. The Cost Sheet log opens.
3. The cost sheet will be displayed in bold font in the log. Select the sheet from the log and click **Open**. The Project Cost Sheet opens.

<table>
<thead>
<tr>
<th>This item</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As</td>
<td>Click this button to save a snapshot copy of the cost sheet.</td>
</tr>
<tr>
<td>Rows</td>
<td>Opens the Rows window, from which you can add or manage rows.</td>
</tr>
<tr>
<td>Columns</td>
<td>Opens the Columns log, from which you can add or manage cost sheet columns, or assign access restrictions.</td>
</tr>
<tr>
<td>Find</td>
<td>Click to search for a cost code.</td>
</tr>
<tr>
<td>Split</td>
<td>Splits the window vertically so you can scroll through the columns while maintaining a view of the WBS code.</td>
</tr>
<tr>
<td>Fund Assignment Order</td>
<td>Opens the Fund Assignment window (if the Funding Manager is used). Allows you to set the project or shell fund assignment order at the WBS level.</td>
</tr>
<tr>
<td>Cost Sheet cells</td>
<td>Click on a cell to view the Cell Details window.</td>
</tr>
<tr>
<td>WBS Code</td>
<td>Click on the WBS code name to open the WBS Detail window.</td>
</tr>
<tr>
<td>Column Heading</td>
<td>Click on a column heading to view more information about the column type.</td>
</tr>
<tr>
<td>File Menu &gt; Open</td>
<td>Opens the Snapshot log.</td>
</tr>
<tr>
<td>File Menu &gt; Import</td>
<td>Click and select one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Summary Cost Sheet</td>
</tr>
<tr>
<td></td>
<td>• Summary Budget</td>
</tr>
<tr>
<td></td>
<td>• WBS Details</td>
</tr>
<tr>
<td></td>
<td>• Column Details</td>
</tr>
<tr>
<td>File Menu &gt; Export</td>
<td>Click and select one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Summary Budget</td>
</tr>
<tr>
<td></td>
<td>• WBS Details</td>
</tr>
<tr>
<td>This item</td>
<td>Does this</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>File Menu &gt; Properties</td>
<td>Opens the Properties window.</td>
</tr>
<tr>
<td>Edit Menu &gt; Budget Distribution</td>
<td>Opens the Budget Distribution window, in which you can manage the budget or lock/unlock the budget.</td>
</tr>
<tr>
<td>Edit Menu &gt; Copy &gt; Column Data</td>
<td>Copy data from one column to another, from one or multiple rows.</td>
</tr>
<tr>
<td>View Menu &gt; Currency</td>
<td>Click and select the display currency in which to display the cost sheet data.</td>
</tr>
<tr>
<td>View Menu &gt; Audit Log</td>
<td>Opens the Audit log for the cost sheet.</td>
</tr>
<tr>
<td>View Menu &gt; Expand</td>
<td>Expands all WBS codes. There is also an Expand button.</td>
</tr>
<tr>
<td>View Menu &gt; Collapse</td>
<td>Collapses all WBS codes. There is also a Collapse button.</td>
</tr>
</tbody>
</table>

**Resize Cost Sheet Window**

The cost sheet window can be resized by clicking the Minimize or Maximize/Restore buttons in the upper right corner of the window, or by dragging the edges of the window to the size that you need.

**Split Or Unsplit Cost Sheet Window**

When working with a cost sheet with many columns, it can be useful to split the window using the Split and Freeze toggle buttons. This allows you to scroll through the columns in the right half of the window, while maintaining a view of the WBS Code and WBS Item columns in the left half.

**To display the cost sheet in split window mode**

1. In the cost sheet window, click the Split button. The sheet is split into two sections.
2. You can click on the vertical split line and move it horizontally to adjust the size of the panes, if desired.
3. Use the scroll bars at the bottom of the window to scroll horizontally through the columns. When you have the left portion of the window in the position you want (for example, to view the WBS Code or WBS Item column), click the Freeze button to lock it in place.
4. Scroll through the columns in the right half of the window to view or enter data as necessary.
5. You can click Freeze again to unlock the left half, or click Split again to restore the window.
Types Of Cost Sheet Data Entry

Cost sheet cells can be populated with data in the following ways, depending on how the column has been set up:

**Manual entry:** Your cost sheet may include some columns in which you can enter data through line items or directly into a cell. Line items can be added manually by copying data from an existing line item within the cell or from copying existing line item data from one column to another.

**Business processes:** Cost sheet data can also be rolled up automatically when cost-type business processes reach a specified status. For example, when a purchase order is approved, the amount can be rolled up to the appropriate column and WBS codes.

**Formulas:** Cell data is calculated from other column entries based on a formula defined for the column. The formula may include data from other columns.

**Budget:** Information from the project or shell budget can be rolled up to budget columns. This data is entered in the Budget window.

**Worksheet:** Data can be entered into worksheets and rolled up to cost sheet columns.

The following sections discuss how to view, enter, and manage cost sheet data and budget information.
WORKING WITH COST SHEET FORECASTING

Cost sheet forecasting allows you to manage the forecast process by detail line items. It utilizes cost-type base commits, change commits, or generic business processes that were included in the Forecasts (Unaccepted) formula.

Here is a high level overview of the Cost sheet forecasting process.

1. When a forecast-enabled commitment routes to a terminal status it attains “Unaccepted” status, for example, Base Commits (Unaccepted). Note: this is different from Base Commits (Approved) or any other routing status.

2. In this example Base Commits (Unaccepted) line items become available for inclusion in the cost sheet forecast.

3. When you click the Forecasting button, the Forecast Adjustment log opens, where you can see all unaccepted line items, based upon the formula used in the Forecasts (Unaccepted) column.

4. As these line items are accepted into the forecast, the unaccepted status changes to accepted, for example, Base Commits (Accepted).

5. Depending upon cost sheet configuration, for the amount accepted into the forecast:
   - Yet To Buy automatically decreases
   - Forecast (Unaccepted) decreases
   - Forecast increases

To accept line items into the forecast

1. In the cost sheet, click the Forecast button. The Forecast Adjustment log opens.

2. Select the line items that you want to include in the forecast and click the Include in Forecast button. Select either All Line Items or Selected Line Items. The Select Adjustment Option window opens.

3. In the Select Adjustment Option window you have three options. Your selection of an option controls how your cost sheet uses the Yet To Buy (YTB) and Allowance For Change data sources to construct the forecast. Option behavior is as follows:

Automatically adjust YTB

- The system automatically changes the line item to Accepted status, subtracts the amount from the YTB (or adds it if designed to do so), and includes the line item amount in the forecast, if configured to do so.
- Cell Details displays a line item for System Auto Adjustment that shows the transaction in the YTB column
- Because the value of the YTB cannot become negative, each transaction will be processed individually. This may result in only certain transactions being processed, and others staying at Unaccepted status. If the transaction was not processed because doing so would have yielded a negative YTB, the system will cause an alert. The unaccepted line items will be available to view in the Forecast Adjustment window.

Manually adjust YTB and AFC

- This option becomes available in the Cell Detail window when you click the Include in Forecast button
• You can add, delete, or modify line items before including commits into the forecast
• The system does not validate the entry or automatically update the YTB in the cost sheet

No adjustment
• The system will automatically add the commitment into the forecast, if configured, and change the status to Accepted. It will not update the Yet To Buy or Allowance For Change columns.

Add A Line Item To A Project Or Shell Cost Sheet
A cost sheet column may be defined for manual data entry, depending on the column definition:

• Manual, line item content: The data is entered in a line item format, allowing multiple line item entries per cell. The total is displayed in the cell.
• Manual, direct entry: Numeric values are entered directly into the cell.

To add a line item to a project or shell cost sheet
1 From the project or shell Cost Sheet window, click the link in the line item cell. The Cell Detail window opens.
2 Click the Add button. The Line Item window opens.
3 Complete the Line Item window as described in the following table.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Short Description</td>
<td>This description will appear on the Cell Detail window.</td>
</tr>
<tr>
<td>Long Description</td>
<td>Optional, to provide more information.</td>
</tr>
<tr>
<td>Work Package</td>
<td>Select a work package, if any, with which to associate the line item.</td>
</tr>
<tr>
<td>Spend Category</td>
<td>Select a spend category if this has been set up to be tracked.</td>
</tr>
<tr>
<td>Quantity</td>
<td>Enter a quantity (at least 1) as applicable.</td>
</tr>
<tr>
<td>Unit of Measure</td>
<td>Select the appropriate choice from the list.</td>
</tr>
<tr>
<td>Unit Cost</td>
<td>Enter this manually.</td>
</tr>
<tr>
<td>Amount</td>
<td>Automatically calculated as Quantity X Unit Cost.</td>
</tr>
<tr>
<td>Attach</td>
<td>This button allows you to attach a file to the line item.</td>
</tr>
<tr>
<td>Delete Line Item</td>
<td>Click this button to delete the line item from the Cell Detail window.</td>
</tr>
<tr>
<td>Number of Attachments</td>
<td>This link displays the number of file attachments, if any, and provides access to any attached files.</td>
</tr>
</tbody>
</table>

4 Click OK. The new line item will be added to the Cell Detail window.

Note: For budget-related columns (for example, Assigned Budget), you can enter line item data as long as the undistributed balance is at least as large as the line item amount. The undistributed balance will adjust as line items are added, displaying the budget amount left.
To add a line item cost entry by copying an existing line item

1. In the project or shell Cost Sheet window, click the link in the line item cell. The Cell Detail window opens. Any existing line items will be listed in the lower portion of the window.

2. Select the line item to copy and click the Copy Line Item button. The Line Item window opens with the original line item entry information filled in.

3. You may make changes as necessary for the new entry, or leave as is to make an exact copy of the original line item.

4. Click OK. The new line item will be added to the Cell Detail window.

Enter Data Directly Into A Cell

Some manual entry cells are configured for direct entry, rather than line item entry. Data entry cells do not have links.

To enter data into direct entry cells

1. Click inside the cell. The cell becomes editable.

2. Enter the numeric value directly into the cell.

Copy Data From One Column To Another

You can copy the data from any manual entry column to another.

To add line items by copying existing data from one column to another

1. Open the project or shell Cost Sheet window, click the Edit menu and choose Copy > Column Data. The Copy Column Data window opens.

2. Complete the Copy Column Data window as described in the following table.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy type</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Cell total only: Copies the total value displayed in the cell. The new line item will be labeled as “Copy of original column name,” ignoring quantity and unit cost.</td>
</tr>
<tr>
<td></td>
<td>• Cell detail: Copies all cell detail information from the original line item.</td>
</tr>
<tr>
<td>Copy from column</td>
<td>From the drop-down list, select the column to copy. Only line item entry columns will be listed.</td>
</tr>
<tr>
<td>Percentage</td>
<td>You may enter a percentage value to copy. For example, if you choose 10%, then 10% of the value of the original column value will be copied into the new column.</td>
</tr>
<tr>
<td>Copy to column</td>
<td>From the drop-down list, select the column into which you want the line items copied</td>
</tr>
<tr>
<td>Rows</td>
<td>Choose one of the following from which you want to copy the values:</td>
</tr>
<tr>
<td></td>
<td>• All: To copy values to all of the rows.</td>
</tr>
<tr>
<td></td>
<td>• Partial: To copy the values of selected rows only. Click the Select button to choose the rows to copy.</td>
</tr>
</tbody>
</table>

3. Click Copy. The data in the first column will be copied into the second column.
View Column Properties

To view column properties
Click the column heading. All column headings except the first two (WBS Details and WBS Item) are hyperlinks that open the View Column window. The window shows information about the column, such as the data source, entry method or formula, data format, and format of the last total row.

Change Cost Sheet Currency

You can view cost sheet data in the company base currency or the project or shell currency, which may differ.

Note: This is also applicable to work packages and worksheets.

To choose the display currency on a cost sheet or worksheet
1. Open the project or shell Cost Sheet or worksheet window.
2. From the Edit menu, click Currency and choose the currency from the list.

To choose the display currency on a work package
1. Open the work package window.
2. Click the currency drop-down list in the upper right corner of the sheet and choose the currency from the list.

Expand Or Collapse WBS Codes

You can expand or collapse all WBS codes in a cost sheet. If you have a large number of WBS codes in a tree structure, you can expand that structure to view all of the WBS codes at once.

To expand or collapse WBS codes in a cost sheet
1. Open the project or shell Cost Sheet or worksheet window.
2. Click View > Expand to expand all of the WBS codes in the cost sheet. Click View > Collapse to collapse all of the WBS codes in the cost sheet. Alternatively, you can click the Expand and Collapse buttons.

View Cost Sheet Cell Details

The values displayed in a cost sheet cell may reflect information from multiple line items, business process transactions, or results of a calculation from other cells. The following procedures discuss how to view the details about an entry in a cost sheet cell.

To open the Cell Detail window
From the project or shell Cost Sheet window, click the link in the line item cell. The Cell Detail window opens.

To view manual line item entry details
From the Cell Detail window, double-click a listed line item. The Line Item window opens.
To view business process transaction details

1. From the Cell Detail window, double-click a listed line item. A view-only copy of the business process transaction opens.

2. Double-click a BP line item. The BP’s Line Item window opens.

To view formula cell details

1. In the Cell Detail window, if line items from manual entry columns or BP transaction columns are included in the calculation, they will be listed in the lower portion of the window, with the calculated value for each line item.

   **Note:** In the Forecasts and Forecasts (Unaccepted) columns, if data sources are from a business process enabled for costs sheet forecasting, the Cell Detail window contains an **Include in Forecast** button.

2. Click a listed line item. If the line item is a BP transaction, the BP form opens. If the line item is a manual entry, the Line Item window opens.

3. To view the formula used for the column, click the **Formula** link.

To view budget cell details

The Cell Detail window displays as line items information generated from the budget, as applicable. Typical budget columns include assigned budget. The undistributed balance amount will be displayed as a line item. You may add line items if the undistributed balance is at least as large as the line item amount.

<table>
<thead>
<tr>
<th>This item</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attach</td>
<td>Allows you to attach files to the cell from your local machine (My Computer) or from the Document Manager (Primavera Unifier folder). You can view existing file attachments by clicking the Attachments link in the upper portion of the window.</td>
</tr>
<tr>
<td>Add Notes</td>
<td>Click to add a note to the cell. You can view existing notes by clicking the Notes link in the upper portion of the window.</td>
</tr>
<tr>
<td>Add</td>
<td>Click to add a line item (transaction) to the cost sheet (applicable for manual transaction columns).</td>
</tr>
<tr>
<td>Remove</td>
<td>Allows you to remove a selected line item.</td>
</tr>
<tr>
<td>Copy</td>
<td>Adds a line item by copying an existing one.</td>
</tr>
<tr>
<td>View Menu &gt;</td>
<td></td>
</tr>
<tr>
<td>Audit Log</td>
<td>Opens the Audit Log for the cell.</td>
</tr>
</tbody>
</table>

**Add Notes Or Attachments To A Cell**

You can add notes or attach files to any cell in the cost sheet. Files can be uploaded from your local environment (My Computer) or from the Document Manager (Primavera Unifier folder).

To access cell detail notes and attachments

1. In the Cost Sheet window, click in any cell that displays as a link (line item entry, formula, or automatic entry from a BP). The Cell Detail window opens.

2. You can add a note, view existing notes, add a file attachment, or view attached files.
To add notes to a cell

1. In the Cell Detail window, click Add Notes. The Add Notes window opens.
2. Type the note in the text box and click OK. Each time you add a new note, the Notes counter in the Cell Detail window updates to reflect the number of notes that exist for the cell.

To view notes attached to a cell

1. If any notes have been added to the cell, the Notes link on the Cell Detail window will display the number of notes.
2. Click the Notes link. The Notes List opens, displaying all of the notes that have been added. Each note displays the user who added the note, and the date and time it was added.

To modify or delete cell detail notes

Notes added to a cost sheet cell cannot be modified or deleted.

To attach files to a cell

In the Cell Detail window, click Attach and choose:

- My Computer to attach the file from your local system. The procedure is the same as for uploading files to the Document Manager, and depends on your file transfer option. (See “About attaching files in Primavera Unifier” on page 36).
- Primavera Unifier Folder to attach documents from the Document Manager. The window opens, displaying the project or shell documents files and folders. Select the files and folders to attach and click OK.

Note: Folders are not attached. The contents of selected folders are attached in a flat list. Documents with duplicate file names will not attach.

To view attached files

1. If any files have been attached to the cell, the Attachments link on the Cell Detail window will display the number of attached files.
2. Click the Attachments link. The Attachments window opens.
3. Choose a file and click Open. The document will open in the viewer selected in your user preferences.

To delete an attached file

1. In the Cell Detail window, click the Attachments link to open the Attachments window.
2. Select the file to be deleted, then click the Delete button.

To download a copy of an attached file

1. In the Cell Detail window, click the Attachments link to open the Attachments window.
2. Select the file to be downloaded and click Download.
3. Browse to a location on your local system and click OK. Click Yes to confirm.

Search For WBS Codes (rows)

You can search for a particular cost code by searching for one or multiple segments.
To search for a cost code

1. In the Cost Sheet window, click Find. The Cost Code Find window opens.

2. Select the cost code segments you want to search by and click OK.

   The results will be shown in a separate cost sheet window. The new window also has split capability so that you can keep the WBS code in view and scroll through the columns.

Edit Cost Sheet Data

The following procedures discuss how to modify cost sheet data. Manually entered cost sheet data can be edited or modified directly from the cost sheet (assuming you have modify permissions).

Cost sheet entries rolled up from transaction BPs or calculated in formula columns are not editable. Data rolled up through business processes can only be modified by submitting business processes such as change orders. Formula column cells will reflect changes made to other column data used in the calculations.

To edit direct entry data

1. In the project or shell Cost Sheet window, click inside the cell to edit. The cell becomes editable.

   2. Enter the new value.

To edit line item data

1. In the project or shell Cost Sheet window, click the link in the cell to edit. The Cell Detail window opens. Line items are listed in the lower portion of the window.

   2. Double-click the line item to edit. The Line Item window opens.

   3. Edit the Line Item window as needed.

   4. Click OK to save changes and close the Line Item window.

To delete a line item

1. From the project or shell Cost Sheet window, click the link in the cell in which to delete the line item. The Cell Detail window opens.

   2. Do one of the following:

      • Select the line item to delete, then click Remove. The line item is deleted.

      • Double-click the line item to open the Line Item window. Click the Delete button.

   3. Click Yes to confirm.

To edit or delete data rolled up from a business process

Cost sheet data originating from a business process cannot be edited from the cost sheet.

Data must be edited in the business process record if it is still active or through an appropriate change BP, such as a change order.

To edit or delete data calculated in a formula column

Formula column cells will reflect changes made to other column data used in the calculations. Click the column heading to view the formula and display the cost sheet columns used in the calculation. This will help you determine whether to edit the formula, the data on another column, or other source.
WORKING WITH YET TO BUY (YTB) AND ALLOWANCE FOR CHANGE (AFC) DATA SOURCES

Cost sheet forecasting is designed to leverage the YTB and AFC data sources. If your company’s forecast process uses the YTB and AFC data sources then you may configure Primavera Unifier to automatically reduce the YTB as you accept commits into the forecast.

In the following example Total Commits is at $4,000, Yet To Buy is at $2,000, Pending Forecasts (i.e. Forecasts (Unaccepted)) is at $2,000, and Forecasts is at $2,000.

When the $2,000 in the Pending Forecasts column is accepted into the Forecasts column, then the Yet To Buy decreases by that amount.

Here we see the amounts in Yet To Buy and Pending Forecasts are reduced and the amount in Forecasts is increased. The Yet To Buy value may never go below zero.
If designed to do so, the line item commitment may increase the YTB instead of reducing it. For example, if you have a change commit that adds scope to a project, when that change commit is approved you may want to add scope to the YTB.

If your company’s forecast process does not use YTB or AFC, you may still use cost sheet forecasting. When the Yet To Buy column is added to the cost sheet, column details will show any actions previously taken with the YTB.

**To manually adjust YTB and AFC**

1. Click the link in the cost sheet cell to open the Cell Detail window.
   
   In any column built with the Forecast(Unaccepted) data source, the Cell Detail window will have an **Include in Forecast** button.

2. Select the line item in the Transactions log and then click **Include in Forecast**.
   
   The Select Adjustment Option window is now available.


4. To include items in Transactions in the forecast:
   
   a. Select a line item.

   b. In the Action field select Mark. Primavera Unifier refreshes the sheet.

   c. Repeat the last step and select Include marked in Forecast.

   The option Include marked in Forecast changes the status of any marked transactions to Accepted and becomes a data source for use in the forecast, if included in the Forecast formula.

   Manual actions taken are not validated; you can include a value in the forecast without touching the YTB or AFC.

**Save Or View Cost Snapshots**

You can save a snapshot or a read-only view of the project or shell cost sheet and worksheets. You can view a snapshot in both project and transaction currencies. Snapshots cannot be deleted.

**To save a snapshot of the cost sheet or worksheet**

1. Open the cost sheet or work sheet.

2. Click the **Save As** button. The Save As Snapshot window opens.

3. Enter a title and click **OK**.

**To view the snapshot**

1. Open the cost sheet, work package, or worksheet.

2. Click the **File** menu and choose **Open**. The Snapshot Log window opens, displaying the list of snapshots.

3. Select a snapshot and click **Open**. A non-editable view of the cost sheet or worksheet opens, displaying the sheet at the time the snapshot was taken.
Importing And Exporting Cost Sheet Data

Export project or shell cost sheet data

Once you have constructed the cost sheet and distributed the budget, you can export specific cost sheet information, saving it to a local file system in a comma-separated-value (CSV) format.

To export project or shell cost sheet data

1. In the project or shell cost sheet, select File > Export and then choose one of the following options.
   - **Summary Cost Sheet:** Creates a summary of all rows, columns, and data on the cost sheet.
   - **Summary Budget:** Creates a summary of the budget window information.
   - **WBS Details:** Lists all of the WBS codes on the cost sheet and the WBS details information for each.
   - **Column Details:** Creates a summary of column details for the selected column (formula and manual entry columns only).

The Summary Cost Sheet option only supports saving the structure for reference purposes. The other three exported files can be modified and then imported into a new or existing project or shell cost sheet.

2. Read the confirmation message and click Yes to continue.
   You can open the file in a compatible program, such as Microsoft Excel, to review it before saving.

3. Click Save and specify the location in which to save the CSV file.

   **Note:** If you open the CSV file, you will see that it contains notes regarding modifying the columns and data in the exported file for re-importing into a cost sheet. Follow the notes embedded in the CSV file for modifying columns and data in the exported file.

Import project or shell cost sheet data

You can import WBS detail information into a cost sheet manual entry column from a comma-delimited-value (CSV) file, such as a Microsoft Excel spreadsheet saved in CSV format.

To import project or shell cost sheet information

1. In the project or shell cost sheet, click File > Import and then choose one of the following:
   - **Summary Budget:** Summarizes the budget information.
   - **WBS Details:** Lists WBS codes and WBS details information for each.
   - **Column Details:** Summarizes column details for specific columns (formula and manual entry columns only).

2. Browse to the CSV file to import, select it, and click OK.

Note the following:

<table>
<thead>
<tr>
<th>Import Option</th>
<th>Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Summary Budget</strong></td>
<td>The following rules apply when importing into the cost sheet:</td>
</tr>
<tr>
<td></td>
<td>• Negative numbers are not allowed for budget distribution amount.</td>
</tr>
<tr>
<td></td>
<td>• New WBS codes cannot be imported.</td>
</tr>
<tr>
<td></td>
<td>• There is no check on import whether the total capital or expense budget was exceeded.</td>
</tr>
<tr>
<td></td>
<td>• After the import is completed, return to the Budget Distribution page and save and lock the</td>
</tr>
</tbody>
</table>
Import Option | Rules
--- | ---
 | budget. Once the budget is locked, the system performs the necessary check to determine if the total capital or expense budget has exceeded the original budget.

WBS Details | The following rules apply to the WBS details when importing into the cost sheet:
--- | ---
 | • WBS details are updated, and new, valid WBS details are added in the order specified in the CSV file.
 | • The complete WBS code, including the parent code, must be valid and in the correct order in the CSV file.
 | • New WBS codes cannot be imported.

Column Details | The following rules apply to the column details when importing into the cost sheet:
--- | ---
 | • This selection adds a column to the cost sheet and is usually done as part of the administration of the cost sheet.
 | • For the Assigned Budget (or Budget Remaining Balance) column and Manual Entry column, all of the existing budget line items are deleted and replaced with the new budget line items defined in the CSV file, even if the CSV file only provides a partial list of WBS codes.
 | • Values in the Distributed Budget column are for reference only.

---

**Defining The Budget**

Once the project or shell cost sheet is defined, you can define the project or shell capital and expense budget amounts and begin distributing the budget to the various WBS accounts. Budgets are managed in the Budget Distribution window.

**About Budget And Budget Distribution**

Once the project or shell cost sheet is defined, you can define the project or shell capital and expense budget amounts and begin distributing the budget to the various WBS accounts. Budgets are managed in the Budget Distribution window.

---

**Note:** Users with module-level modify permission can lock and unlock the budget distribution. An exception to this is if Assigned Budget is one of the cost sheet columns, and the user has view restrictions on the column. If a user cannot view the Assigned Budget column, the Budget Distribution menu option is not available. In addition, the user cannot import a summary budget.

---

**Open The Budget Distribution Window**

**To open the Budget Distribution window**

1. Open the project or shell cost sheet.
2. Click the **Edit** menu and select **Budget Distribution**. The Budget Distribution window opens.
3. Use the information in the table below to enter budget information as necessary.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project or Shell Capital Budget</td>
<td></td>
</tr>
<tr>
<td>Project or Shell</td>
<td></td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Expense Budget</td>
<td></td>
</tr>
<tr>
<td>Scope of Budget</td>
<td></td>
</tr>
<tr>
<td>Comments</td>
<td>A text field for any budget-related comments.</td>
</tr>
<tr>
<td>Undistributed Capital Amount</td>
<td></td>
</tr>
<tr>
<td>Undistributed Expense Amount</td>
<td></td>
</tr>
<tr>
<td>Lock Date</td>
<td>If the budget is currently locked, the lock date displays.</td>
</tr>
<tr>
<td>Status</td>
<td>Shows if the budget is currently locked or unlocked.</td>
</tr>
<tr>
<td>Lock/Unlock Explanation (View)</td>
<td>Click the View link to open an audit log that lists the dates, times, and explanations for lock and unlock budget instances.</td>
</tr>
<tr>
<td>Project or Shell Currency</td>
<td>Displays the currency used in the project or shell. This may differ from the base currency.</td>
</tr>
<tr>
<td>Base Currency</td>
<td>Displays the base currency used for your company.</td>
</tr>
<tr>
<td>Exchange Rate</td>
<td>This is the calculation that is used to convert the base currency to the project or shell currency.</td>
</tr>
<tr>
<td>No. of Attachments</td>
<td>Displays the number of files, if any, attached to the budget window. Click on the link to view or download.</td>
</tr>
<tr>
<td>Budget Distributed Amount</td>
<td>The lower part of the window displays each WBS code row that appears on the cost sheet. Enter the budget amount for each one. Clicking on a WBS code link will open the WBS Details window.</td>
</tr>
<tr>
<td>Attach</td>
<td>Click this button to attach files to the budget distribution window.</td>
</tr>
<tr>
<td>Save &amp; Lock</td>
<td>This button is available if the budget is currently unlocked. Clicking it locks and distributes the budget. You will be prompted to provide an explanation for this action.</td>
</tr>
<tr>
<td>Unlock</td>
<td>This button is available if the budget is currently locked. Clicking it unlocks the budget to allow for modification to the budget window and cost sheet rows. You will be prompted to provide an explanation for this action.</td>
</tr>
<tr>
<td>Audit Log</td>
<td>This button accesses the audit log, which records budget activity.</td>
</tr>
</tbody>
</table>

4 Click OK to save and exit.

**Distribute And Lock The Budget**

Once the Budget Distribution window has been completed, you can distribute the budget and lock the budget.

**To distribute and lock the budget**

1 Complete the Budget Distribution window.

2 Click Apply to save changes.

3 Click Save & Lock.
4. When prompted, enter an explanation for locking the budget, then click **OK**.

5. Click **Close** to close the Budget Distribution window.

**Unlock The Budget**

If the budget has been locked, you must unlock it to make any budget changes or certain cost sheet modifications, such as adding or modifying cost sheet rows.

**To unlock the budget**

1. From the Budget Distribution window, click the **Unlock** button.

2. When prompted, enter an explanation for unlocking the budget, then click **OK**.

3. You can make edits to the budget or cost sheet as needed, then save and lock the budget again.

**Permission matrix for the Budget Distribution window**

<table>
<thead>
<tr>
<th>Assigned Budget</th>
<th>Budget Distribution</th>
<th>Import Summary Budget</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not Added</td>
<td>Added</td>
<td>Lock</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>Unlock</td>
</tr>
<tr>
<td></td>
<td></td>
<td>View</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edit</td>
</tr>
<tr>
<td>Restrictions</td>
<td>Restrictions</td>
<td>Yes</td>
</tr>
<tr>
<td>(View)</td>
<td>(Edit)</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No</td>
</tr>
</tbody>
</table>

**Managing Project/Shell Cost Sheets And Properties**

The ability to modify cost sheet rows, columns or properties is dependent on your user permissions. Contact your project or company administrator regarding your permission levels.

**View or edit cost sheet properties**

Cost sheet properties include the name, description, structure definition (flat or tree), WBS code, WBS item titles, and switches for forecast details and forecast inclusion functionality.

Most properties are not editable in the cost sheet once it has been created. The exception is the **Default View**, which can be edited.

**To open the cost sheet Properties window**

1. Open the cost sheet Properties window by doing one of the following:
   - Select the cost sheet from the log and click the **Properties** button on the toolbar.
   - Open the cost sheet. Click the **File** menu and choose **Properties**.

2. The Properties window opens.
   - The **General** tab displays the Title and Description, and enables the administrator to set a Default View for when the cost sheet is opened from the log.
• The **Structure** tab displays the WBS Code segment and display structure used in the cost sheet. This information is view-only once the cost sheet has been created.

• The **Options** tab displays display and forecasting information used in the cost sheet. This information is also view-only after the cost sheet is created.

### Working With Work Packages

A work package is a group of cost sheet rows that is a subset of the project or shell cost sheet. Work packages display view-only data taken directly from the project or shell cost sheet and is not editable in the Work Package window. Data must be edited in the project or shell Cost Sheet window.

### Create A Work Package

The following procedure discusses how to create a work package.

**Note:** Once a work package has been created, it cannot be deleted.

**To create a work package**

1. In the Navigator in User Mode, open the project or shell.

2. Click **Cost Manager** in the left Navigator and then **Cost Sheet**. The Cost Sheet log opens.

3. Click the **New** button. The Work Package Properties window opens.

4. You can attach files to the work package by clicking the **Attach** button.

5. Use the information in the following table to complete the Work Package Properties window and click **OK**.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Enter a title, which displays in the log.</td>
</tr>
<tr>
<td>Reference No.</td>
<td>Enter a unique reference number.</td>
</tr>
<tr>
<td>Creator</td>
<td>This will be populated automatically with the name of the user creating the work package.</td>
</tr>
<tr>
<td>Date Initiated</td>
<td>This is populated automatically with the initiated date.</td>
</tr>
<tr>
<td>Status</td>
<td>Select <strong>Active</strong> or <strong>Inactive</strong>.</td>
</tr>
<tr>
<td>Owner</td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>You may enter a description of the work package here.</td>
</tr>
<tr>
<td>Comments</td>
<td>Allows for any additional comments.</td>
</tr>
<tr>
<td>Attach</td>
<td>Click this button to attach files to the work package.</td>
</tr>
<tr>
<td>No. of Attachments</td>
<td>This link displays the number of files, if any, attached to the work package. Click on the link to view or download.</td>
</tr>
</tbody>
</table>
**Open A Work Package**

**To open a work package**

1. Open the project or shell.
2. Click **Cost Manager > Cost Sheet** in the left Navigator. The Cost Sheet log opens.
3. Work packages are listed in the log in regular (not bold) font. Select a work package from the log and click **Open**. The Work Package opens.

**Note:** Like cost sheets, you can click the **Split** button to split the window to scroll through the columns while maintaining the WBS code in view. A summary of the work package data can be exported into a CSV file from this window.

**Change Work Package Currency**

You can view work packages in the company base currency or the project currency, which may differ.

**To choose the currency in which to display the work package data**

Open the Work Package window. In the upper right corner of the window, click the **Currency** drop-down list and choose the currency.

**View Work Package Properties**

**To open the Work Package Properties window**

From the project or shell Cost Sheet log, select the work package and click the **Properties** button. The Properties window opens.

**Export Work Package Data**

You can save summary work package data to a local file system in a CSV format.

**To export work package data**

1. From the Work Package window, click the **Export** button.
2. Read the confirmation message and then click **Yes** to continue.
3. You may choose to open the file in a compatible program such as Microsoft Excel to review it before saving.
4. Click **Save** and specify the location in which to save the CSV file.

**Working With Worksheets**

Worksheets are extensions of the cost sheet. They can be used as subcost sheets, enabling specific calculations or data entry in a separate sheet, which can then be rolled up into a defined project or shell cost sheet column. The rows equal the WBS codes on the cost sheet. Worksheets can have multiple columns for data entry or formula calculations, but do not support data rolled up from business processes.

Example uses of a worksheet:

- A worksheet can be used to off-load complex calculations requiring multiple columns. The final value can be rolled up into a single cost sheet column.
• Worksheets are governed by individual permissions. You can design worksheets to use as a method of data entry or review for users that you do not want to have any access to the project or shell cost sheet, for example, a contractor who is developing an estimate.

A cost sheet column can be associated with a worksheet as the data entry method. A worksheet column can also be associated with another worksheet, as long as there is not a circular reference. There can be multiple worksheets in a project or shell.

A worksheet template can be created in Administration Mode. Permissions can be controlled for individual worksheets. Worksheets are not independently reportable; however, cost sheet columns that reference worksheets can be reported on.

**Create A Worksheet**

You can create a worksheet by copying a worksheet template or copying a worksheet from another project or shell.

**To create a worksheet from a template**

1. In User Mode, click **Cost Manager > Cost Sheet** in the left Navigator. The Cost Sheet log opens.
2. Click **New** and select **Worksheet > Copy from Template**. The Copy from Template window opens.
3. Select the template to copy and click **OK**. The worksheet appears in the log.

**To create a worksheet from another worksheet**

1. In User Mode, click **Cost Manager > Cost Sheet** in the left Navigator. The Cost Sheet log opens.
2. Click **New** and select **Worksheet > Copy from Project** or **Copy from Shell**. The Copy from Project or Shell window opens. The window lists each worksheet in each project or shell. If there are multiple worksheets in a project or shell, each will be listed separately.
3. Select the project or shell worksheet to copy and click **OK**. The worksheet appears in the log.

You can add manual-entry or formula columns to a worksheet. Rows are created automatically from the WBS codes in the cost sheet.

**Open A Worksheet**

**To open a worksheet directly from the log**

In User Mode, click **Cost Manager > Cost Sheet** in the left Navigator. The Cost Sheet log opens. Select the worksheet from the log and click **Open**.

**Note:** When you first open the sheet, the opening view will depend on the Default View option selected in the Properties window. Your cost sheet administrator can set this default view. Worksheets can be resized and split/unsplit the same way as cost sheets (See "Resize cost sheet window" on page 383 or See "Split or unsplit cost sheet window" on page 383).

**To open a worksheet from the cost sheet**

Click on cost sheet column data that refers to a worksheet as data entry.

Adding a column to a worksheet is similar to adding a column to the cost sheet. You can add manual-entry (direct or line item) columns or formula columns. You can also add columns that reference other worksheets. This allows interaction between worksheets.
The available data sources are Project Worksheet Cost 1 through 50.

**To add a column**

1. Open the worksheet and click the **Columns** button. The Columns Log opens.
2. Click **New**. The Column Properties window opens.
3. Complete the column properties as usual for a column.
   If you are creating a formula, the data sources that are available for the formula are limited to the other columns on the worksheet.
4. Complete the window and click **OK**.

**View Or Edit Worksheet Properties**

Worksheet properties can be viewed and edited. The ability to edit worksheet properties is dependent on your user permission settings. Contact your project or company administrator if you have questions regarding your user permission settings.

**To view or edit worksheet properties**

Select the worksheet from the log and click the **Properties** button, or open the worksheet and click **File > Properties**. The Properties window opens. The following properties are displayed:

- **Title**: This is the title of the worksheet, and displays in the log.
- **Description**: This optional field can be used to provide a description for the worksheet and its use.
- **Default View**: These are the settings that determine how the worksheet appears when first opened by any user from the log.

**Modify Worksheet Default View**

The worksheet default view refers to how it appears when it is first opened. There are two options regarding the default view, described in the procedure below. These options control how the worksheet opens for all users.

**To define the worksheet default view**

1. Open the Properties window (select the worksheet and click the **Properties** button from the log toolbar, or open the worksheet and click **File > Properties**).
2. On the General tab, you may optionally choose either or both of the **Default View** checkbox options:
   - **Open in maximized view**: when the worksheet is opened, it will automatically open maximized, or full-screen
   - **Open in split mode**: when the worksheet is opened, it will automatically open as split (same as clicking the **Split** button)

If these options are not selected, the worksheet will open by default to a size slightly smaller than the Primavera Unifier screen, and not split.

**Note**: The worksheet can be resized by clicking the **Minimize** or **Maximize/Restore** buttons in the upper right corner of the window, or by dragging the edges of the window to the size that you need.
Add A Worksheet Column To The Cost Sheet

You can roll up the data from a worksheet column into a project or shell cost sheet column.

To add a worksheet column to the cost sheet

1. In the cost sheet, click **Columns**, then click **New**. The Column Properties window opens.
2. In the **Datasource** column, choose any of the project or shell cost data sources Project Cost 1 through Project Cost 25.
3. For Entry Method, choose **Worksheet**.
4. Choose the worksheet (name), and then the column within the worksheet.
5. Complete the rest of the Properties window and click **OK**.

Assign Permissions To The Worksheet

You can configure the permission settings for each worksheet, allowing you to control access to each worksheet individually. The owner of the worksheet is granted permission to access and modify it automatically. The owner must grant permissions for other users or groups to access a worksheet.

To assign permissions to a worksheet

1. In User Mode, click **Cost Manager > Cost Sheet** in the left Navigator. The Cost Sheet log opens.
2. Select the worksheet and click the **Permission** button. The Edit Permissions window opens.
3. Click the **Add** button and select the users or groups to grant access. In the User Picker, select users or groups, click **Add** and then click **OK**. The user or group is added to the upper portion of the Edit Permissions window.
4. By default, each listed user or group will be granted view permission, allowing them to open the worksheet. To grant additional permissions, select the user or group and select the permissions:
   - **Modify Permission**: Allows user to control the worksheet’s permission settings.
   - **Edit**: User can import worksheet information, save a snapshot, edit worksheet properties, and add columns.
5. Click **OK**.

Import Worksheet Column Details

You can only import data into columns that are defined as manual data entry.

To import column details

1. Click **File > Import > Column Details**, or click the **Import** button and choose **Column Details**. The Select Column window opens.
2. Select the column and click **OK**.

Export Worksheet Details

This will allow the user to export details of the worksheet. The following options are available under Export:

- **Summary Worksheet**: This option will export the entire worksheet similar to cost sheets.
- **Column Details**: You can only export data from manual data-entry columns.
To export a summary worksheet
Click File > Export > Summary Worksheet, or click the Export button and choose Summary Worksheet.

Working With The Program Cost Sheet
The following sections describe how to open a program cost sheet, search for listed project or shell cost sheets, and import and export cost sheet information.

Data rolls up to the program cost sheet columns from individual project or shell cost sheet columns by data source. The data displayed on the program cost sheet is view only.

Open The Program Cost Sheet

To open a program cost sheet

1. Open the program and click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log opens.

2. Select the program cost sheet from the log and click Open. The Program Cost Sheet opens.

Like project or shell cost sheets, you can click the Split button to split the window to scroll through the columns while maintaining the WBS code in view. A summary of the work package data can be exported into a CSV file from this window.

This item | Does this
--- | ---
Save As | Click this button to save a snapshot copy of the cost sheet.
Export | Click and select one of the following:
• Summary Cost Sheet
• Column Details
Import | Imports column details.
Columns | Opens the Columns log, from which you can add or manage cost sheet columns.
Find | Click to search for a cost code.
Split | Splits the window vertically so you can scroll through the columns while maintaining a view of the project or shell number.
Cost Sheet cells | Click on a cell to view the Cell Details window.
Project or Shell Number | Click on the project or shell number to open the project or shell cost sheet.
Column Heading | Click on a column heading to view more information about the column type.
File Menu > Open | Opens the Snapshot log.

Search For Project Or Shells (rows)
You can search for projects or shells by project or shell type and project or shell site. A new Program Cost window will open, displaying only those project or shells meeting the search criteria.
To search for a project or shell

1. In the Program Cost Sheet window, click Find. The Search window opens.
2. Select the search criteria and click OK.

Export Program Cost Sheet Data

To export program-level cost sheet data

1. In the program cost sheet, click the Export button and then choose one of the following:
   • Summary Cost Sheet: This allows you to export complete cost sheet information, including project or shell name, number, and data from all columns.
   • Column Details: This exports only Program Cost 1 to Program Cost 25 logical data sources that are configured as manual entry. Click Column Details to open the Select Column window and select the columns to export.
2. Read the confirmation message and then click Yes to continue.
3. You may choose to open the file in a compatible program such as Microsoft Excel to review it before saving.
4. Click Save and specify the location in which to save the CSV file.

Import Program Cost Sheet Data

You can import manual entry columns into the Cost Sheet from a comma-delimited (CSV) file (such as a Microsoft Excel spreadsheet saved in CSV format.)

To import program cost sheet information

1. From the program cost sheet, click the Import button then choose Column Details.
2. Browse to the CSV file to import, select it, and click OK.

Working With The Company Cost Sheet

Like other cost sheets, the ability to work with a company cost sheet is dependent upon the permissions that you have. Contact your project or company administrator if you have questions regarding your permission levels.

Open The Company Cost Sheet

When you first open a company cost sheet, the opening view that you see will depend on the Default View option selected in the cost sheet Properties window.

To open a company cost sheet

1. Go to the Company Workspace tab and click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log opens.
2. Select the company cost sheet from the log and click Open. The Company Cost Sheet opens.

Note: Company cost sheets can be resized and split/unsplit the same way as project or shell cost sheets (See “Resize cost sheet window” on page 383 or See “Split or unsplit cost sheet window” on page 383).
View Or Edit Company Cost Sheet Properties
The ability to edit company cost sheet properties is dependent on your user permission levels.

To view or edit company cost sheet properties
Select the cost sheet from the log and click the Properties button, or open the cost sheet and click File > Properties. The Properties window opens. In this window, you can change the default view in the General tab or map account codes to company cost sheet columns in the Options tab.

Search For Project Or Shells (rows)
You can search for projects or shells that are listed on the sheet. A new Company Cost window will open, displaying only those project or shells meeting the search criteria.

To search for a project or shell
1. In the Company Cost Sheet window, click Find. The Search window opens.
2. Select the search criteria and click OK.

Export Company Cost Sheet Data
You can export summary cost data and column details into a CSV file.

To export company-level cost sheet data
1. From the company cost sheet, click the Export button and then choose one of the following:
   - Summary Cost Sheet: This allows you to export complete cost sheet information, including project or shell name, number, and data from all columns.
   - Column Details: This exports only Company Cost 1 to Column Cost 25 logical data sources that are configured as manual entry. Click Column Details to open the Select Column window and select the columns to export.
2. Read the confirmation message and then click Yes to continue.
3. You may choose to open the file in a compatible program such as Microsoft Excel to review it before saving.
4. Click Save and specify the location in which to save the CSV file.

Import Company Cost Sheet Data
You can import manual entry columns into the cost sheet from a CSV file, such as a Microsoft Excel spreadsheet saved in CSV format.

To import company cost sheet data
1. In the company cost sheet, click the Import button then choose Column Details.
2. Browse to the CSV file to import, select it, and click.
WORKING WITH COMPANY ACCOUNTS SHEETS

The company accounts sheet is used to track company level accounts information, such as assets, resources, and facility maintenance. It is similar to a project or shell cost sheet, using account codes instead of WBS codes.

Account codes are independent of WBS codes, but are similar in structure format. Company-level business processes can be designed in Primavera uDesigner to roll up to the accounts sheet (line items are associated with account codes).

Open The Accounts Sheet

To open the accounts sheet

1. In User Mode, select **Company Workspace > Cost Manager > Accounts Sheet**. The Accounts Sheet log opens. If an accounts sheet has been created, it will be displayed in the log.

2. Select the sheet and click **Open** (example below.)

**Note:** When you first open the sheet, the opening view will depend on the **Default View** option selected in the Properties window. Your accounts sheet administrator can set this default view. Accounts sheets can be resized and split/unsplit the same way as project or shell cost sheets (See “Resize cost sheet window” on page 383 or See “Split or unsplit cost sheet window” on page 383).

The accounts sheet works similarly to cost sheets. Like cost sheets, you can:

- Enter data into manual data-entry columns.
- View rolled up transaction details by clicking a cell with a hyperlink.
- View a column definition by clicking a column heading.
- Copy column data from one column to another (**Edit > Copy > Column Data**; the original values will be overwritten).
- Save and view snapshots (**File > Create Snapshot; View > Snapshot Log**).
- Import and export column details.
- Export accounts summary sheet.

Activate Or Deactivate Account Codes

You can control the status of account codes. If an account code is inactive, it will be displayed on the accounts sheet, but will not be available for selection in an Account Code picker, such as on company account business process transactions.

To activate or deactivate an accounts code

1. Open the accounts sheet.

2. Click the **Account Status** button. The Account Code Status window opens.

3. Select one or more account codes.

4. Click **Activate** or **Deactivate**.
**View Or Edit Accounts Sheet Properties**

Accounts sheet properties can be viewed and edited. The ability to edit properties is dependent on your user permission settings. Contact your project or company administrator if you have questions regarding your user permission settings.

**To view or edit accounts sheet properties**

Select the accounts sheet from the log and click the **Properties** button, or open the accounts sheet and click **File > Properties**. The Properties window opens. The following properties are displayed and are editable by the cost administrator:

- **Title**: This is the title of the sheet, and displays in the log.
- **Description**: This optional field can be used to provide a description or other information about the accounts sheet.
- **Display Mode**: This determines whether the accounts codes are displayed in a flat list, or a hierarchical tree mode. This setting can be switched back and forth as needed.
- **Default View**: These are the settings that determine how the sheet appears when first opened by any user from the log.

**About The Funding Manager**

The Funding Manager helps you to keep track of where project or shell funding comes from and how it is being spent. This feature is accessed via the Funding node under the Cost Manager. Use the Funding sheet to specify the appropriation and assignment of funds from each source. You can automate fund appropriation and assignment when used with Cost business processes.

**Company and project/shell funding**

- **Design and import a fund attribute form in uDesigner**. This will be used as the Fund Details window when adding new funds to the company funding sheet, or viewing fund properties. A fund picker, used to add funds to business processes or the project/shell funding sheet, can also be designed. This is an optional step. If you do not create a fund attribute form, a default fund code form and fund picker will be used.

- **Import and set up fund business processes**. You can use business processes for fund allocations, fund assignment (consumption), and fund credits.

- **Create and set up the Company Funding Sheet**. The company funding sheet tracks the funds that can be used to fund project or shell expenses. The following procedures assume that the rows (funds) and columns of the funding sheet have already been created.

- **Create and set up the Project/Shell Funding Template and Sheet**. The project or shell funding sheet tracks the funds that have been allocated from company funds for a particular project or shell. The project or shell funding sheet is based on the funding template, which is created first. The following procedures assume that the project/shell funding sheet has been created, rows and columns have been added. *(Note: The rows correspond to funds chosen from the company funding sheet. Funds can be added manually, or can be added via fund allocation business processes, discussed later in this section.)*

- **Define funding assignment rules**. Funding assignment rules are set up in the project/shell funding sheet and/or template. These determine which business processes are used for fund appropriations and assignments and how to consume funds (ratio or fund order) if you will be using automatic fund assignment from business processes. The following procedures assume these options have been set up.
• **Create funding rules in the rules engine.** Optionally, funding rules can be created in the rules engine that can help you manage your funds and fund balances, for example, to prevent fund balances from becoming less than zero.

**Commitment level funding**

Optionally, funding at the base commit (contract) level can be set up.

Commitment funding works in conjunction with the SOV sheet. SOV line items have an impact on the commitment funding sheet and its data through fund assignment.

**Before you begin.** Be sure that the project/shell funding has been set up, with funds allocated and available on the project/shell funding sheet. Data sources are available for project/shell funding sheets (and company funding sheets) to track funding that is assigned for specific base commits. Also, be sure the data source “Scheduled Value” has been added as a column to the SOV structure for the project or shell. Commitment funding uses the SOV to track base commit and change commit amounts, and uses the Scheduled Value column to track remaining balances.

**Import and set up business processes for commitment funding.** In addition to business processes that are used for project/shell funding, you can design business processes for use with commitment funding. In Primavera uDesigner, commitment funding is enabled on the base commit; automatic generation of an SOV must also be enabled. Then, the ability to view and/or assign funds is enabled per step on the base commit and the corresponding change commit. Be sure the linked spends business process has been enabled to consume funding.

**Create and set up Commitment Funding Template.** This template is used to create a commitment funding structures in the project or shell, which in turn is used to create the individual commitment funding sheets for each base commit record. These procedures assume a template has been created and set up with columns.

**Define funding assignment rules.** This is done in the Assignment tab of the Properties window. Assignment rules can be defined in the commitment funding template, structure or sheets. (This procedure assumes assignment rules have been defined in the template, and will be copied to the structure and individual sheets.)

**Create Commitment Funding Sheet Structure.** Structures are created at the project level in user mode from a commitment funding template. When commitment funding sheets are created from base commit records, this default structure is used. Details about creating commitment funding structures from an existing template are found later in this section.

**Create individual commitment funding sheets.** This is done automatically the first time you click the Funding button on a base commit business process form (this button becomes available on specific steps as designed in Primavera uDesigner). After creation, the commitment funding sheet is available for viewing or modification by clicking the Funding button on the base commit or associated change commits, or from the Commitment Funding log itself. Details about creating commitment funding sheets is found later in this section.

**Configure permissions.** In addition to module level permissions that are needed to create and modify templates, structures and sheets, record level permission must be granted to individual commitment funding sheets. By default, the owner of the base commit will have permissions to the sheet. Additional users must be granted view or edit permissions. This is discussed later in this section.

**Company Funding Sheet vs. Project or Shell Funding Sheets vs. Commitment Funding Sheets**

The first step to setting up funding is to create and set up a company funding sheet, where individual funding sources are set up.
For example, a corporation’s funding sources may include different types of corporate accounts. For municipal or educational facilities, funds may come from bond measures, grants, donations or other sources. All of these funding sources will be listed and tracked on the company funding sheet. As funds are consumed via business processes or manually in individual project or shells, this data is rolled up to the company funding sheet.

Project or shell funding sheets track how your company’s funding is being spent on each project or shell. It tracks individual transactions, which are rolled up to the company funding sheet. All project or shell funding sheets must be created based on a funding template.

If you are using commitment funding, you will create a commitment funding template, which is used to create the commitment funding structure within a project or shell. As base commits (that are designed for commitment funding in Primavera uDesigner) are routed and approved, a commitment funding sheet is created, based on this structure, for each base commit record.

Working With The Company Funding Sheet

The following procedures described managing funds on the company funding sheet.

Open The Company Funding Sheet

The company funding sheet is accessed from the company level Cost Manager.

To open the company funding sheet

1. Go to the Company Workspace tab and click Cost Manager > Funding in the left Navigator. The Funding log opens.

2. Select the company funding sheet and click Open. The Company Funding Sheet opens.

Note: Like cost sheets, you can click the Split button to split the window to scroll through the columns while maintaining the fund listing in view.

About Company Funding Sheet Columns

The columns on the company funding sheet are used to track project and shell level funding and keep track of fund balances.

A common way to enter the starting value of a fund is by adding a Company Funding column to the company funding sheet. This is generally a manual entry column (either direct entry or line item entry). The original value of each fund (one fund per row) is entered into this column.

Additional columns commonly track fund assignments (consumption) made against each fund in projects or shells. These can be in the form of business process transactions or manual funding assignments. Each project or shell level business process or manual entry column can be rolled up to the company funding sheet separately, or project/shell fund assignments can be totaled in the project/shell sheet, and rolled up to the company sheet. A good practice is to have a fund balance formula column that tracks the difference between the original fund value minus all funding assignments, which provides a running balance for each fund. A rule can be created in the Rules Engine to make sure that this fund balance never becomes less than zero (or other specified value).

To view column details

In the funding sheet, click a column header link to view the column details. This will display the data source and, for formula columns, display the formula used.
About Company Funding Sheet Rows

Each row in the company funding sheet corresponds to one fund. Depending on how the company funding sheet is set up, the starting value of each fund may need to be manually entered. This is commonly done in a column using the Company Funding data source.

If you are working with a large number of funds, there are ways to help you find the fund that you are looking for. You can search for individual fund codes using the Find feature. You can also create and apply filters, which can be used to temporarily limit the number of funds displayed on the sheet. For more information, see the following topics: See “Searching for Fund Codes” on page 420, See “Creating and Applying Filters” on page 421.

To view fund details

In the funding sheet, click the fund code link (in the Fund Code column) to open the Fund Details. If a Fund Attribute form has been designed in Primavera uDesigner and imported into Primavera Unifier, this window shows the fields on the form. If a Fund Attribute form is not being used, the default window opens, showing basic information such as the fund code, fund name and description.

Add Currency Amounts To Company Funds

Once the company funding sheet has been set up, the funds must be “funded” — enter the funding amounts that will be used to fund your projects and shells. Commonly, the Company Funding data source is used as a manual entry column to enter the starting amount of each fund, or add additional funds to it. This column can be direct entry or line item entry.

This procedure assumes the funds have already been added to the sheet. It also assumes that a column has been added to the sheet for manual fund entry. Commonly, this uses the Company Funding data source. You can click a column heading to verify the data source used.

To add a value to a company fund

1. Open the company funding sheet.
2. Locate the column that is used for adding value to company funds on the sheet, commonly, the Company Funding column.
3. Do one of the following:
   - If the column is direct entry, click inside the cell and enter the amount. If the cell already has a value, you can modify it.
   - If the column is line item entry, click the link in the cell. The Cell Detail window opens. You can:
     - Click Add Line Item to add a new line item.
     - Select a line item and click Copy Line Item to add a line item by copying another.
     - Double-click an existing line item to modify it.
     - Select a line item and click Remove Line Item to remove it.

   Enter the line item information in the Line Item window and click OK.

The amount in the Company Funding column can be used as the starting amount of a fund. Other columns on the company funding sheet can be used to roll up transaction and manual funding amounts from project/shell funding sheets, and formula columns can be added to keep track of the fund balance.

Activate Or Deactivate Company Funds

You can active or deactivate company funds, which controls their availability for project or shell funding. If you set a fund to “Inactive” at company level, then that fund will no longer be available for
project- or shell-level funding sheets; however, if a fund is already listed on a project or shell funding sheet, inactivating the fund at the company level will not affect the fund.

**To set the company fund status**

1. Open the company funding sheet
2. Click the **Fund Status** button on the toolbar. The Fund Status window opens.
3. Select a fund in the table, then click **Activate** or **Deactivate**.
4. Click **Close** to exit the window.

**Import Or Export Company Funding Sheet Information**

You can export a summary of the funding sheet, which creates a CSV file that contains the rows, columns and data on the funding sheet. You can also export a CSV file containing fund details, which includes all fund codes on the sheet and the data captured for them from the Fund Details window. This is available in company, project and shell funding sheets.

You can also import fund details to a company funding sheet. This allows you to add fund codes to a funding sheet directly from a CSV file, rather than add them manually.

For details, See “Importing and Exporting Project/Shell Funding Sheet Information” on page 423

**Working With Project Or Shell Funding Sheets**

The Project/Shell Funding Sheet tracks how funding is being allocated and consumed at the project or shell level. Project or shell funding sheets work in conjunction with the company funding sheet. Fund allocation, assignment and credits can be done manually, or through a business processes.

---

**Note:** Since funding originates at the company level in the company funding sheet, funding is always done in base currency, even if the project currency is different.

---

**Open A Project Or Shell Funding Sheet**

The project or shell funding sheet is accessed from the Cost Manager > Funding > Funding Sheet log. There is one funding sheet per project or shell.

**To open a project or shell funding sheet**

1. Open the project or shell and click **Cost Manager > Funding > Funding Sheet** in the left Navigator. The Funding log opens.
2. Select the project or shell funding sheet and click **Open**. The Funding Sheet opens.

**Note:** Like cost sheets, you can click the **Split** button to split the window to scroll through the columns while maintaining the fund listing in view.

---

**About Project/shell Funding Sheet Columns**

The columns on the project/shell funding sheet are used to track the funding on that project or shell, and to keep track of the fund balances that have been appropriated for its use.

Commonly, the Project Funding column is used to enter the allocation amount of each fund for that project/shell.
Additional columns commonly track fund assignments (consumption) made against each fund. These can be in the form of business process transactions or manual funding assignments, with one column for each business process, and manual entry columns for project level funding and WBS level funding.

The Records Funded at Project Level (or WBS Level) column(s) can be used to track the totals of business process transactions involving fund assignment. This is used for records already reaching terminal status. The Transient Records Funded at Project Level (or WBS Level) column(s) works similarly, but is used for records that are currently in process, and have already been funded before reaching terminal status. These columns can also include any credited funding that may occur due to invoice credits or other negative amounts.

Commitment level funding can be tracked on the project/shell funding sheet using the columns Commitment Funding (tracks funds that are allocated across base commit and change commit business process records enabled for commitment funding), Records Funded at Commitment Level (sum of all spends records that are funded at the commitment level), and Transient Records Funded at Commitment Level (sum of all in-process records that are funded at the commitment level).

A good practice is to add a fund balance formula column that tracks the difference between the original fund value minus all funding assignments, which provides a running balance for each fund.

**To view column details**

In the funding sheet, click a column header link to view the column details. This will include the data source and, for formula columns, display the formula used.

**About Project/shell Funding Sheet Rows**

Each row in the project or shell funding sheet corresponds to a fund that has been allocated for use on this project or shell. Each fund originates on the company funding sheet.

Fund allocation can be done manually, by adding rows to the project/shell funding sheet. A fund picker is used to select which funds from the company funding sheet to add.

Funds can also be allocated to a project by using a fund allocation business process that is designed to choose the funds and funding allocation amounts for the project/shell.

For manually allocated funds, the starting amount of each fund can be entered manually. Commonly, the Project Funding column is used to enter the starting value of each fund when funds can be used for the project regardless of WBS code, or the WBS Funding column is used when funding is specified per WBS code. These value can roll up to the company funding sheet column of the same data source.

If you are working with a large number of funds, there are ways to help you find the fund that you are looking for. You can search for individual fund codes using the Find feature. You can also create and apply filters, which can be used to temporarily limit the number of funds displayed on the sheet. For more information, see the following topics: “Searching for Fund Codes” on page 420, “Creating and Applying Filters” on page 421.

**To view fund details**

In the funding sheet, click the fund code link (in the Fund Code column). The Fund Details opens. If a Fund Attribute form has been designed in Primavera uDesigner and imported into Primavera Unifier, this window will include the fields added to the form in the design. If a Fund Attribute form is not being used, the default window opens, listing basic information such as the fund code, fund name and description.

**View Project/Shell Funding Sheet Properties**

The Properties window defines general setup information and assignment details for the funding sheet.
To view project or shell funding sheet properties

1 In the project or shell Funding log, select the funding sheet and click the Properties button. The Properties window opens.

- The General tab defines the Title, Description and Display Mode for the sheet. If you have edit permissions, you can edit these, including switching back and forth between the display mode options as needed.
- The Assignment tab is used to define the funding assignment options:
  - Project and WBS Level: Specifies the sources of fund allocation for the project or shell, either manual entry or via fund appropriation business processes.
  - Assignment Levels and Rules: For each funding business process that has been set up for the project or shell, this specifies how funds are assigned, either manually, Auto Order, or Auto Ratio:

For more information, see "About Project/Shell funding assignment options" on page 413.

2 Click OK or Cancel to close the window.

About Project/Shell Funding Assignment Options

Funding assignment options for the project or shell are defined on the Assignment tab of the Properties window. (Open the funding sheet, and choose File > Properties.) This includes defining how fund allocation can be done, specifying whether manual assignment is allowed, defining the business processes that can be used to assign funds to project or shells or to specific WBS codes, and defining assignment levels.

Project Level and WBS Level: Specifies how funds can be added for this project or shell. This can be Manual (appropriate funds manually from the company funding sheet), and/or through funding appropriation business processes.

You can define funding appropriations at the project level (not associated with specific WBS codes), and at the WBS level (funding is specified per WBS code). You can “mix and match” for each project, with some business processes using project level funding, and others WBS level. Manual fund appropriations can be done at both levels.

Assignment Levels and Rules: Specifies how assignment is done for each funding business process that has been set up for the project or shell: Manual, Auto Order, or Auto Ratio. It also specifies whether funds are assigned at the Project Level (funding is consumed based on the total of the spends business process, providing greater flexibility for fund assignment), or WBS Level (funding is consumed per line item of a spends business process, which provides greater control over how funds are spent on each item.)

- Manual: Funds can be manually assigned. As spends business processes (e.g., invoices or payment applications) are routed and reach specified statuses, the amounts to be funded are collected under the Unassigned total on the funding sheet. A Funding button becomes available on the business process form. Clicking the button opens the Funding window, in which funds can be assigned.
- Auto Order: Funds are assigned automatically when a spends business process reaches a specified status. Funds are assigned based on the fund order, which is defined on the funding sheet by clicking the Fund Assignment Order button. When funds are consumed on one fund, then the next funding source is used for funding. Once all funds are consumed, remaining spends are collected under Unassigned.
- Auto Ratio: Funds are assigned automatically when a spends business process reaches a specified status. Funds are assigned based on the fund ratio, which is automatically calculated based on current fund levels. Once all funds are consumed, remaining spends are collected under Unassigned.
**View Funding Sheet Cell Details**

The values displayed in a cell on the funding sheet may reflect information from multiple line items, business process transactions, or results of a calculation from other cells. The following procedures discuss how to view the details about an entry in a funding sheet cell.

**To open the Cell Details window**

In the Funding Sheet window, click the link in the line item cell to view information. The Cell Details window opens.

**To view manual line item entry details**

In the Cell Details window, double-click a listed line item. The Line Item window opens.

**To view business process transaction details**

1. In the Cell Details window, double-click a listed line item. A view-only copy of the business process transaction opens.
2. Double-click a line item. The Line Item window opens.

**To view formula cell details**

In the Cell Details window, if line items from manual-entry columns or business process transaction columns are included in the calculation, they will be listed in the lower portion of the window, with the calculated value for each line item.

1. Click a listed line item. If the line item is a BP transaction, the business process form opens. If the line item is a manual entry, the Line Item window opens.
2. To view the formula used for the column, click the **Formula** link.

**Allocating Funds To A Project Or Shell**

This section discusses fund allocation. Allocation refers to reserving a certain amount of a company fund to a particular project or shell.

Funds can be allocated to a project or shell either by manually adding rows to the project/shell funding sheet and entering allocation amounts, or through business processes transactions, which automatically add the rows and allocation amounts. Fund allocation can be done at the project/shell level (funds are available to any expense in the project or shell), or at the WBS level (funding is allocated per WBS code).

**Manually Enter Project/shell Fund Allocation Amounts**

Once the project/shell funding sheet has been set up, the funds must be “funded” -- enter the funding amounts that will be used to fund your projects and shells. The following procedures discuss manually allocating funds and entering amounts to the funds that will be used in the project or shell. (Fund allocation using business processes is discussed in a later section.)

Commonly, the Manual Funding By Project data source is used as a manual entry column to enter the starting amount of each fund, or add additional funds to it. This column can be direct entry or line item entry, and is used for project level fund allocation. The Manual Project by WBS data source can be added to the project/fund cost sheet, and values added there. The same column data source can be added to the project/shell funding sheet to display the values added to the cost sheet column. This is used for WBS level fund allocation.

The following procedures assume that the appropriate funds (rows) and columns have already been added to the funding sheet. You can click a column heading to verify the data source used. For details about adding funds (rows) or columns to the company funding sheet.
To enter project level fund allocation values (on the funding sheet)

1. Open the project or shell funding sheet.

2. Locate the column that is used for adding value to funds on the sheet, commonly, the Manual Funding by Project column.

3. Do one of the following:
   - If the column is direct entry, click inside the cell and enter the amount. If the cell already has a value, you can modify it.
   - If the column is line item entry, click the link in the cell. The Cell Detail window opens. You can:
     • Click Add Line Item to add a new line item.
     • Select a line item and click Copy Line Item to add a line item by copying another.
     • Double-click an existing line item to modify it.
     • Select a line item and click Remove Line Item to remove it.

   Enter the line item information in the Line Item window and click OK.

This amount can be used as the starting project level amount of a fund. Other columns on the funding sheet can be used to track transactions, and formula columns can be added to keep track of the fund balance.

To enter WBS level fund allocation values (on the cost sheet)

1. Open the project or shell cost sheet.

2. Locate the column that is used for adding value to funds by WBS code, commonly, the Manual Funding by WBS column.

3. Click the link in the cell. The Cell Detail window opens. You can:
   • Click Add Line Item to add a new line item.
   • Select a line item and click Copy Line Item to add a line item by copying another.
   • Double-click an existing line item to modify it.
   • Select a line item and click Remove Line Item to remove it.

4. Complete the Line Item window.

5. Select a fund from the fund picker by clicking the Select button for the Funding Source. The fund picker lists the funds that are active at the company level. To search for a specific fund, click Find.

6. Click OK. The new line item will be added to the Cell Detail window. If the Manual Funding by WBS column has also been added to the project/shell funding sheet, the value will display there.

To add funding sheet data through a formula

Formula columns calculate results based on data entered in other columns. You cannot enter data directly into a formula column. You may click the funding sheet column header to view the data source for the cells in the column. If the column is a formula column, it will be displayed, and you can view which other columns are used in the calculation.

Allocate Funds Through Business Processes

Funds can be allocated to a project or shell using a fund allocation business process, which was defined in Primavera uDesigner. Following is a summary of the business process types and design options that may be used:
Project level:

- Cost type, subtype line items with fund code, classification generic.
- Workflow or non-workflow

WBS level:

- Cost type, subtype line items with WBS and fund code, classification generic.
- Workflow or non-workflow

Commonly, columns are added to the funding sheet to capture funding allocation business process transactions. The Project Funding column might be used (as a formula) to capture the sum of all allocations and manual allocation for each fund.

To allocate funds and enter amounts through a business process

1. Create the business process record.
2. Add line items as necessary.
   - Select a fund from the fund picker by clicking the Select button for the Funding Source. The fund picker lists the funds that are active at the company level. To search for a specific fund, click Find.
   - The Line Item window may also include a WBS picker, for WBS level allocations.
3. Route the business process record as usual.

Assigning And Crediting Project/Shell Funds

This section discusses assigning (consuming) funds on project and shell funding sheets. When funds are “assigned,” it means they are consumed from the allocated amount for that project or shell. Funds can also be credited back to the source when necessary.

Fund assignments are based on spends type business processes within the project or shell (e.g., invoices or payment applications), which enables accurate funding and tracking of project expenses. Funds are assigned based on the amount of a spends record, and can never exceed that amount. The behavior of funding business processes depends both on the design options chosen in Primavera uDesigner and the Assignment Levels chosen on the project/shell funding sheet properties.

Funding assignments are based on business processes transactions, and commonly, columns are added to the funding sheet to track spends business processes eligible for funding. Formula columns may also be added to track the totals of these records, which may include Records Funded at Project Level (and/or WBS Level), for completed records; and Transient Records Funded at Project Level (or WBS Level), to track funding on records that are funded while in process. Values can also roll up to the company funding sheet if the same data source columns are added.

View Unassigned Amounts

When spends business processes are set up to be funded manually, the amount of the record initially is captured in one of the Unassigned fields on the funding sheet. This value displays until the entire amount of the record has been fully funded. For Project level funding, the amount displays in the Unassigned (Project Level) field; for WBS level funding, the amount shows up in the Unassigned (WBS Level) field.

If commitment level funding is being done, you may also see an amount under Unassigned (Commitment Level). These funds are managed on the commitment funding sheet.
It is possible that an Unassigned amount can be negative, as the result of a credit invoice that has not yet been credited back to the funding source.

**Note:** These can also be rolled up to the cost sheet using the Unfunded Record data source.

### To view unassigned amounts

1. Open the project or shell funding sheet.
   
   If business process transactions have occurred that have not yet been funded, the total of the record(s) will display in one of the Unassigned fields in the upper portion of the sheet.

2. Click the link next to Unassigned (Project Level) or Unassigned (WBS Level). The Cell Detail window opens. The window lists transaction records that have not yet been fully funded.

### Manual Vs. Automatic Fund Assignment

Funding assignments can be done automatically or manually. This is set in the funding assignment levels in the funding sheet properties.

**Manual fund assignment**

For manual assignments, and depending on the design of the business process, the following may occur:

- You may be able to view or perform funding assignments or credits at any step in the workflow (or for a non-workflow business process, any status). When the business process is in process, it is referred to as a “Transient Record.” This allows the record to be funded, edited and reviewed before the record is finalized and closed.

- When funding is enabled (or can be viewed), a Funding button appears on the business process form. Click the button to open the Funding Window.

- It is possible that the business process can be designed to disallow funding assignments or credits at the end step (or terminal status if non-workflow). This option prevents further editing of funding assignments or credits after the record has gone through a review process.

Good practice tips: Review the invoice line items and be sure they are accurate before doing funding. A good practice for design is to disallow line items from being edited after fund assignment steps. This will prevent the invoice line items from being edited after funding has already been assigned.

**Automatic fund assignment**

For automatic assignments, the following generally occurs

- Automatic funding occurs when the record reaches the end step in the workflow, or when Finish Editing is clicked if non-workflow.

- The funds are assigned based either on the fund assignment order, or by the ratio of the amounts of each fund, as determined in the assignment options in the Properties.

It is possible to adjust funding after automatic fund assignments.

### About Crediting Funds

Sometimes it is necessary to credit back funds that have already been assigned. The same general procedures for assigning funds can be used for crediting funds as well. You may need to credit funds back to the credit source if:

- You receive an invoice credit from a vendor, and funds have already been assigned to the original invoice amount.
• A mistake was made in the original fund assignment, either by assigning too high a value, or assigning funds from the wrong fund.

You cannot credit more of a fund than has been consumed.

You can also credit previously assigned funds back to the fund source, either due to receiving a credit invoice or line item (e.g., a vendor credit), or to correct a previous assignment error.

About Business Processes Enabled For Funding

Business process behavior is dependent on the how the business process was designed in Primavera uDesigner, and the assignment options chosen in the project/shell funding sheet. In general, the design determines when funding assignments can be viewed or performed, and the assignment options determine whether the assignment is done manually or automatically, and at what levels.

Spends type business processes (e.g., invoices or payment applications) can be designed in Primavera uDesigner to consume funds. Following is a summary of the business process types and design options that can be used:

Project level:

• Cost type, subtype line items with fund code, classification generic, general spends or payment application.
• Workflow or non-workflow.
• Each action form can be enabled with the following options: “View fund assignment” and “Allow fund assignment.” This option allows funding assignments to be viewed or performed at any step in the workflow (or any status if non-workflow). The “Allow fund assignment” option is applicable when the business process is set up for manual assignment in the funding assignment levels in the funding sheet properties.
• An option can be set for the business process that disallows manual fund assignment once the record reaches end step (or terminal status for non-workflow). When this option is chosen, it takes precedence over the “Allow fund assignment” setting, even if an action form is used on the end step. This option does not affect automatic fund assignments.
  • This option is found on the Edit Studio window, Options tab.

WBS level:

• Cost type, subtype line items with WBS and fund code, classification generic, general spends or payment application.
• Other options are the same as for Project Level.

Manually Assign Or Credit Funds (unassigned Funds)

Normally, if a spends business process record has not been set up to automatically assign funds upon reaching a certain status, then that record total will show as Unassigned Funds in the project/shell funding sheet.

When the funding business process reaches a specified workflow step or status, a Funding button appears on the business process form. Clicking the Funding button opens the Funding window, allowing manual fund assignment.

Funds can be manually assigned at the project or shell level (project or shell funding sheet), WBS level (project or shell cost sheet), or business process level (spends business process record designed to consume funds).
If a credit invoice (negative line item or invoice amount) has been submitted, this can be used to credit previously consumed funds back to the source, or can be used to credit another fund. You cannot credit an amount that is more than has been consumed.

**Note:** This section discusses assigning and crediting funds on the project/shell funding sheet. See also See "Assigning and crediting commitment level funds" on page 438.

To manually assign funds at the project or shell level from the funding sheet

1. Open the project or shell funding sheet.
2. In the upper portion of the window, click the link next to **Unassigned (project or shell Level)**. This link displays the amount of funds that are not currently assigned to a particular fund.
   The Cell Detail window opens. The Cell Detail window displays the list of spends business process records that have not yet been fully funded. A record can appear on this list if you do not have enough funds available during an auto-assignment process, or if you set Manual as the assignment rule for the business process under the funding sheet Assignment tab.
3. Select one or more records from the list and click the **Assign to Funds** button on toolbar. The Manual Fund Assignment window opens
4. Enter a percent (%) amount for each record against a funding source.
5. Click **OK**.

**Note:** Because the number of decimal places is limited to two in the Manual Fund Assignment window, some amounts from funds can never be consumed. If you cannot use funds completely through the Assign to Funds window, go to the Spend BP record and manually consume the fund by entering the amount.

To manually assign funds at the WBS level from the cost sheet

1. Open the project or shell cost sheet.
2. In the upper portion of the window, note the amount shown in the **Unassigned at WBS Level** field. This is an amount that gets rolled up from the unfunded record data source in the project or shell cost sheet.
3. Click on a cell under the Unfunded Records column for a WBS code.
4. The Cell Detail window opens. The Cell Detail window displays the list of records that are not funded.
5. Select one or more records from the list and click the **Assign to Funds** button on the toolbar.
6. Enter a percent (%) amount for each record against a funding source.
7. Click **OK** to close the form.

**Note:** Funds can be automatically consumed at the WBS level by defining the fund order for each WBS Code from the Fund Assignment Order window on the Project/Shell cost sheet, and setting the assignment level to WBS Auto Order.
To manually assign or credit funds from a business process record

1. Open the business process record that needs to be funded. If the record is at a specified workflow step and status that allows funding, a Funding button is available.

2. Click the Funding button on the toolbar. The Funding window opens.

3. Select a line item from the upper pane. The bottom pane will display a list of funds that are available for that line item.

4. Enter the amounts for fund assignment. This is subtracted from the fund balance. For credits, enter negative amounts; the amount entered is added back to the fund balance.

5. Click OK.

   If the business process is configured to use individual commit line items as SOV line items, the upper pane will not show a list of line items. You will see a total amount under the Unassigned Amount field.

Reassign Project/shell Funds From A Business Process Record

In addition to assigning or crediting funds from the funding sheet, you can also adjust the funding allocations that were rolled up to the funding sheet directly from the business process record in which the transaction took place.

To reassign project or shell funds

1. Open the business process record in which you want to reassign funds.

2. Click the Funding button. The Cell Detail window opens.

3. Click Select. The fund picker opens.

4. Select the funding source from which to assign funds.

   Depending on the design of the BP, the Fund picker may display all funds being used by the company or only those funds currently allocated to the project or shell.

5. Click OK. The Assign to Fund window opens.

6. Enter the percentage of the transaction amount to assign to the new fund and click OK.

Searching For Fund Codes

If you are working with a large number of funds, there are ways to help you find the fund or funds that you are looking for. You can search for individual fund codes using the Find feature. You can also create and apply filters, which can be used to temporarily limit the number of funds displayed on the sheet.

You can use the Find button to help you find a particular fund on company, project or shell funding sheet, or a funding template. You can search by any column on the funding sheet, and is available if the display mode is Flat or Tree. Find is available on company, project and shell funding sheets and templates.

In addition, you can search for funds in a fund picker. The fund picker displays when you are adding funds to a project/shell funding sheet, or funds when adding line items to a business process record used for funding.
To search for a fund on a funding sheet

1 Open the project or shell funding sheet.

2 Click the Find button on the toolbar. The Find window opens.

3 Complete the Find window:
   • **Column**: Choose a column name. This dropdown contains the names of all columns that are displayed on the funding sheet, including Fund Code and Fund Name.
   • **Value**: Enter a value for which to search. You can enter a full or partial word, number or other value. (Do not enter a wildcard character for partial entries.) The format of your entry will depend on the type of value you are searching for. If you are searching for a fund code, you can include the code separator if one is used (for example, a dash).
   • **Search**: Choose Up or Down. For new searches, use Down. If a value is found, it will be selected on the sheet. If you want to continue to search, you can choose to search up or down from the current selection.

4 Click Cancel to close the Find window.

To search for a fund in a fund picker

1 Open the funding sheet or business process record.

2 Open the fund picker by doing one of the following:
   • On a project or shell funding sheet or template, add a row to the sheet by clicking Rows, then Add Row. In the Fund Details window, click the Select button next to the field for choosing a fund (e.g., Fund Code).
   • In the business process record, click the Select button next to the field for choosing a fund (e.g., Fund Code).

The Fund Picker opens.

3 You can search for a specific fund in the fund picker:
   a Click the Find button. The Find window opens. The window that opens will depend on the design in Primavera uDesigner.
      • If an attribute form is not defined, the default Find window will allow you to search by Fund Code or Fund Name.
      • If an attribute form is defined, the Find window can also be designed in Primavera uDesigner, and you may have additional fields to search by.
   b Enter search criteria and click Search. This limits the number of funds that are displayed to those that match the search criteria.

4 Click OK. The fund appears as a row on the Funding Sheet. Funds are displayed in alphabetical order on funding sheet.

Creating And Applying Filters

If you are working with a large number of funds, it may be useful to display a subset of the total number of funds when working with the funding sheet. For example, you may want to only view new funds for the current year.

You can temporarily limit the number of funds displayed on the sheet by applying a filter. This feature is available on company, project and shell funding sheets, and funding sheet templates.
Create And Manage Filters On A Project/shell Funding Sheet

If you have Create or Modify permissions, you can create and save any number of filters. Anyone with permission to view the funding sheet can view and apply saved filters.

These procedures are applicable to company, project or shell funding sheets, and funding templates.

To create a new filter

1. Open the funding sheet.
2. Click the View menu and choose Filters. The Filters window opens. This window lists any filters that may have been created and saved previously.
3. Click the Add button. The Edit Filter window opens. In this window, you can add one or more conditions to use for filtering the funds display.
4. Enter a Filter Name. This name will display in the Filters window.
5. Click the Add button. The Add Query Condition window opens. You can enter one or multiple conditions.
6. Do the following:
   a. Choose a Data Element: This dropdown lists all data elements that are on the fund attribute form. Any data elements in a hidden block are not available.
   b. Choose a Condition: This dropdown displays a list of conditions. This list is based on the type of data element selected.
   c. Choose a value: Depending on the type of data element, choose a value that the query condition must meet.
      • Data Element: Lists the data elements on the fund attribute form.
      • Constant Value: You can enter a full or partial entry of the value to filter by. This is similar to entering search criteria. For example, if you want to display only funds with “2010” in the fund code, then choose the data element Fund Code, condition of equals, and 2010 as a constant value. For pulldown or other multiple-entry fields, a Select button appears, allowing you to select a value.
7. If you add multiple conditions, and want the filter to be applied if any one listed condition is met, then select the Show result matching ANY condition checkbox.

   Note: By default, the conditions are additive, meaning that all conditions must be met in order for the condition to be applicable. Select the checkbox if any one condition will suffice.

8. Click OK to save and close each window.

To modify a filter

1. Open the funding sheet.
2. Click the View menu and choose Filters. The Filters window opens.
3. Choose a filter from the list and click the Edit button. The Edit Filter window opens.
4. You can edit the filter name, or add, modify or remove a condition.
   • To modify a condition, select the condition from the list and click the Modify button.
   • To remove a condition, select the condition and click the Remove button.
Click **OK** to save your changes.

**To delete a filter**

1. Open the funding sheet.
2. Click the **View** menu and choose **Filters**. The Filters window opens.
3. Choose a filter from the list and click the **Remove** button. Click **Yes** to confirm.

**Apply A Filter To Limit The Fund Code Display**

By applying a filter to the funding sheet, you can temporarily reduce the number of fund codes that are displayed on the sheet.

**To apply a filter**

1. Open the funding sheet.
2. Click the **View** menu and choose **Filters**. The Filters window opens. This window lists any filters that have been created and saved.
3. Choose a filter from the list and click the **Apply Filter** button.

The funding sheet will display only those funds meeting the conditions of the filter selected. The top of the sheet will display the name of the filter.

**To clear the filter and display all funds**

If the funding sheet has a filter applied, click the **View** menu and choose **Clear Filter**. The sheet will refresh to display all funds.

**Importing And Exporting Project/Shell Funding Sheet Information**

You can export a summary of a funding sheet, which creates a CSV file that contains the rows, columns and data on the funding sheet. You can also export a CSV file containing fund details, which includes all fund codes on the sheet and the data captured for them from the Fund Details window.

You can also import fund details to a company funding sheet. This allows you to add fund codes to a funding sheet directly from a CSV file, rather than add them manually.

This procedures are applicable to company, project and shell funding sheets.

**Export Funding Sheet Information**

You can export a summary funding sheet, which is a CSV file containing the rows (funds), columns and data on the funding sheet. You can do this in a company, project or shell funding sheet. Summary funding sheet information cannot be re-imported.

**To export a funding sheet summary**

1. Open the company, project or shell funding sheet.
2. Click the **Export** button and then choose **Summary Fund Sheet**.
3. Read the confirmation message and then click **Yes** to continue.

You may choose to open the file in a compatible program such as Microsoft Excel to review it before saving.

4. Click **Save** and specify the location in which to save the CSV file.
**Import And Export Fund Details**

You can export fund detail information from a company, project or shell funding sheet to a CSV file. This contains all of the information captured in the Fund Details form when the funds were added to the company funding sheet. When you export the fund details from the company funding sheet, the details of all funds are exported; exporting from a project or shell funding sheet gives the details of those funds added to that sheet.

When adding funds to a company funding sheet, you can use the export file as a template, add fund details to the CSV file, then re-import the file to add funds to the company funding sheet. You cannot use import to add funds to a project or shell funding sheet.

**To export fund details from a funding sheet**

1. Open the company, project or shell funding sheet.
2. Click the **Export** button and then choose **Fund Details**.
3. Read the confirmation message and then click **Yes** to continue.
   
   You may choose to open the file in a compatible program such as Microsoft Excel to review it before saving.
4. Click **Save** and specify the location in which to save the CSV file.

**To import fund details into a company funding sheet**

1. Open the company funding sheet.
2. Be sure you first export the fund details and save the CSV file.
   
   Note the instructions at the top of the file. Remove any existing funds that may be listed in the export file, so that only the column headings remain. The instructions at the top of the file can remain. Save the file.
3. Add the fund details for the funds that you want to import. Be sure to complete all required fields. Do not add fund codes that already exist on the funding sheet.
4. Click the **Import Fund Details** button.
5. Browse to the CSV file and click **Ok**. The funds you added to the import file will be added to the company funding sheet.

**Note:** If any errors occur, download and open the error file, and correct the CSV file before reimorting. Common errors include trying to import fund codes that already exist on the sheet, or not completing required fields.
WORKING WITH COMMITMENT FUNDING SHEETS

When using project/shell level funding (described in the previous sections), the fund assignment procedure does not distinguish which funds to consume for invoices or payment applications that come in for different base commit records (i.e., contracts or purchase orders). There may be times when a base commit needs to be funded by a specific fund or funds. If you want to allocate and assign specific funds for each contract, then you can use commitment funding.

Commitment funding works in conjunction with project/shell level funding (the funds allocated to a commit must first be present in the project/shell funding sheet), and with the schedule of values (SOV) sheet that is created for the base commit (as the SOV keeps track of the line items and amounts of the base commit and any change commits).

Note: The terms “base commit” and “contract” may be interchanged in the descriptions, but both refer to cost-type business processes of sub-type “Line items with WBS Code” and classification “base commit.” Common examples are contracts and purchase orders.

Note: If you are enabling a base commit for commitment funding, its linked spends business process (general spends invoice or payment application) will then consume funds at the commitment level, not the project level. If you want to do commitment funding with some contracts, and project level funding with other contracts, you should use a different “set” of base commit, change commit and spends business processes to use for each type of funding that you want to do.

If you will be using commitment level funding, then a sheet structure must be created for the project or shell, which consists of columns and assignment rules (in the Properties). Commitment funding sheets are created for each base commit record, using this default structure. Funds (rows) are added to the commitment funding sheets, and fund amounts are allocated from available project/shell funds to each sheet.

Note: Although commitment funding sheets are based on the structure, you can still modify the columns and properties of individual sheets. You can also modify the commitment funding structure after sheets have been created. Modifications to the structure will be reflected on new sheets, but will not affect existing sheets.
CREATE A COMMITMENT FUNDING SHEET STRUCTURE

Structures are created by copying a commitment funding template. The commitment funding structure defines the column structure that will be used for the individual commitment funding sheets that are created from base commit records. It can also define the assignment levels and rules to use for each sheet (in the Properties window). (These procedures assume a commitment funding template has been created and set up).

Structures can also be created in a project or shell template, which will then be copied to projects/shells created from it. Structures created in project/shell templates can also be “pushed” to existing projects using Update Projects or Update Shells.

If you modify the columns or properties of the commitment funding structure, existing sheets will not be affected. New sheets created from the edited structure will reflect the modifications. You can modify the columns and properties of individual commitment funding sheets without affecting the default structure.

To create a commitment funding sheet structure

1. Open the project or shell and click Cost Manager > Funding > Commitment Funding Sheet in the left Navigator. The Commitment Funding Sheet log opens. The log should be empty. If commitment funding sheets are already present, then a structure already exists.

2. Click the Create Structure button. The Commitment Funding Sheet window opens, listing the available templates.

   Note: When a structure is created, the Create Structure button becomes Update Structure.

3. Select a template from the list and click Open. Click Yes to confirm. You can use this structure as is or make edits as necessary.

To view or edit the commitment funding sheet structure

1. From the Commitment Funding Sheet log, click the Update Structure button. The Commitment Funding Structure window opens.

2. Click the Columns button to add, view or edit columns. Managing columns on the structure is done the same way as on a commitment funding sheet template. For details about commitment funding columns.

3. You can also modify the structure properties:
   a. In the structure window, click the File menu and choose Properties.
   b. In the General tab, you can modify the Title and Description. The Title will be used as the default name of each commitment funding sheet created from it.
   c. You can also modify assignment levels and rules. Click the Assignment tab.

4. Close the Commitment Funding Structure window
CREATE A COMMITMENT FUNDING SHEET

The Commitment Funding Sheet allows you to allocate project or shell funds to a specific “commitment” (base commit) business process record (for example, a contract or a purchase order). Changes to the original contract through the use of associated change commits will also be reflected on the funding sheet. The commitment funding sheet is also used to track the consumption of those funds as spends business processes (invoices or payment applications) are created.

There is one commitment funding sheet for each base commit business process record. You create the sheet directly from the base commit record once it reaches a step at which funding has been enabled. (The design is done in Primavera uDesigner. For workflow BPs, funding can be enabled per step; for non-workflow BPs, funding will be enabled when the form is editable. The funding sheet may also be available for viewing on view forms, depending on the design. The funding sheet is available if a Funding button is present on the base or change commit record toolbar.)

Be sure the following is in place before creating the commitment funding sheet:

- A commitment funding structure has been created. The sheet will use this default structure. Columns can be modified, removed or added to the sheet; this will not affect the default structure.
- The project or shell funding sheet has been created, and funds allocated to it from the company funding sheet.
- In order to use commitment level funding, a schedule of values (SOV) sheet must be created for the base commit. The commitment funding sheet uses the SOV to track base commit and change commit line items, amounts, and remaining balances. Be sure the SOV sheet has a column using the datasource Scheduled Value, as this is used by the commitment funding sheet.

If the fund assignment levels and rules have been defined in the structure, then these will be copied to the new sheet. These definitions can be added or edited in the sheet as needed.

The user who creates the sheet becomes the owner and automatically has full permissions to view and edit the sheet. If other users will need to view or edit the sheet, you will need to give them permission.

After the sheet is created, you then allocate funding for that record from the available project or shell funds. Fund allocation is done manually on the commitment funding sheet; allocation and consumption can be tracked on the project/shell funding sheet by adding the appropriate columns.

**To create a commitment sheet**

1. Open the base commit business process record on which you want to perform commitment funding.

   If commitment funding has been enabled on the base commit itself, and on the current step, a Funding button will be present on the business process toolbar.

   **Note:** If the Funding button is not present, contact your project/shell administrator, or other administrator managing business processes, to verify that commitment funding is available for the business process, that it is available on the current step, and that you have the proper permissions. In addition, it is possible that on some steps (and on View forms), the Funding button will be present, but has been designed to open a view-only version of the sheet.

2. Click the Funding button.

3. Click Yes to confirm. The Commitment Funding Sheet is created, based on the structure.
GRANT PERMISSION TO A COMMITMENT FUNDING SHEET

Grant Permission To A Commitment Funding Sheet

The user who creates the commitment funding sheet automatically becomes the owner and has full permissions to modify the sheet and enter data. If other users will need to view or edit the sheet, the owner will need to give them permission.

To grant a user or group commitment funding sheet permissions

1. On the Commitment Funding Sheet log, select a sheet.
2. Click the Permissions button. The Edit Permission window opens.
   - The upper pane of the window displays any users or groups who have already been granted permission to the sheet.
3. To add users or groups who are not listed, click the Add button. The User/Group Picker opens.
4. Select one or more users and/or groups, and click Ok.
5. In the upper pane of the Edit Permission window, select one or more users or groups.
6. Select the permission level for the selection:
   - Modify Permission: This will allow a user to modify record level permissions
   - Edit: This will allow a user to modify data on the sheet
   - View: This will allow a user to view the sheet
7. Click OK.
8. Repeat if you have more users or groups to add, or that you need to assign different permission levels.
9. To remove permissions from a listed user or group, select user/group and either modify the permission levels to a lower level, or click the Remove button to remove all sheet-level permissions.
ACCESS COMMITMENT FUNDING SHEETS

Commitment funding sheets are based on individual base commit records (e.g., contracts or purchase orders) on which commitment funding has been enabled in the Primavera uDesigner design. The structure (columns) of the sheets is based on a structure, which in turn is based on a commitment funding sheet template.

Commitment funding sheets can be accessed from the Commitment Funding Sheet log, or from the base commit record with which the sheet is associated. (Accessing the sheet from the commit record is dependent upon the BP design: for workflow BPs, funding is enabled per step; for non-workflow BPs, funding will be enabled when the form is editable. The funding sheet may also be available for viewing on view forms, depending on the design. The funding sheet is available if a Funding button is present on the base commit record toolbar.)

Note: Remember that commitment funding sheets have record-level permission. The creator of the base commit becomes the creator of the commitment funding sheet created from it, and must grant view or edit permission to other users that may need to access it.

To access commitment funding sheets

Do one of the following:

• In the Commitment Funding Sheet log, select a sheet and click Open (or double-click the sheet).
• Open the base commit or change commit record. If a Funding button is present on the toolbar, you can click it to open the commitment funding sheet.
ABOUT COMMITMENT FUNDING COLUMNS

The columns on the commitment funding sheet are used to manage and track the funding allocation, assignment and fund balances for the commit record.

**Note:** In these column definitions, the terms All Funds and Discrete Fund refer to the fund assignment options (from the Fund Assignment window, accessed from the SOV sheet or commitment funding sheet). These options determine how the SOV lines (and therefore, the commit lines) will be funded, either automatically or manually from the entire list of funds available to the commit, or by one specific fund.

The Funding Across All Funds column is used to enter (or calculate) the amount of each fund to allocate for this base commit record. The rows on the sheet are the funds that will be used to fund the commit. The value entered here will be the fund amount available for all commit lines that have “All Funds” as assignment. This can be a manual entry column, or a formula that uses another manual entry column as the basis of the formula.

Additional columns commonly track fund assignments (consumption) made against each fund. These can be in the form of business process transactions or manual funding assignments. System provided datasources that can be used for columns include the following:

- **Funding By Discrete Fund:** This column displays the sum total of all the line items of base and change commits that are funded by a specific (or “discrete”) fund. This value can be used to determine the fund balance during consumption.
- **Records Funded Across All Funds:** Reflects the total of funds consumed from records that are funded based on All Funds, whether funding is done manually or automatically.
- **Records Funded By Discrete Fund:** Displays the total of funds consumed from records that are funded based on a discrete fund, whether funding is done manually or automatically.
- **Fund Balance Across All Funds:** This column tracks the fund balance across all funds. The formula used is (Funding Across All Funds) - (Records Funded By All Funds).
- **Fund Balance By Discrete Fund:** This column tracks the fund balance by specific fund chosen in the Fund Assignment window. The formula used is (Funding By Discrete Fund) - (Records Funded By Discrete Fund).
- **Funding Ratio Across All Funds:** The value of this column is calculated automatically. It reflects the % ratio to use when performing fund assignment ratio during consumption. The formula is (Funding Across All Funds Per Fund) / Total of Fund Balance Across All Funds).
ABOUT COMMITMENT FUNDING SHEET ROWS

Each row in the commitment funding sheet corresponds to a fund that has been allocated for use on that commitment. Fund allocation can be done manually, by adding rows to the commitment funding sheet. The funds that are available for allocation are those on the project or shell funding sheet.
VIEW OR EDIT COMMITMENT FUNDING SHEET

PROPERTIES

The properties of a commitment funding sheet are copied from the structure it was created from (which in turn was copied from a template). You can use these properties, or modify them as necessary.

To view or edit commitment funding sheet properties

1. On the Commitment Funding Sheet log, select a sheet.
2. Click the Properties button. The Properties window opens.
3. In the General tab, you can modify the Title and Description.
4. In the Assignment tab, you can modify the assignment levels and rules to use for this sheet.

Note: Assignment Levels must be defined before you will be able to process spends records (invoices or payment applications) against this base commit. If you change an assignment rule (for example, from Manual to Auto Ratio), the change will take place on new spends records, it will not affect spends records already in process. See "About commitment funding assignment options" on page 433.
ABOUT COMMITMENT FUNDING ASSIGNMENT OPTIONS

Fund Assignment refers to how funds are to be consumed as spends type business processes (e.g., invoices and payment applications) come in against the base commit that is being funded.

Initial assignment rules are defined in the Assignment tab on the commitment funding Properties window. Additional details can be defined in the Fund Assignment window. To access the fund assignment window, click the Fund Assignment button on the commitment funding sheet or SOV sheet for the base commit. The Fund Assignment window is not accessible until the SOV sheet has been created.

These are defined in more detail below.

Assignment rules

The assignment levels and rules are defined on the Assignments tab in the Properties window of the commitment funding sheet. This step is mandatory in order to do commitment level funding.

The Assignment tab lists the spends business processes that are linked to base commits enabled for commitment level funding. For each listed business process, you define how fund assignment will be done when these spends records come in against the base commit:

- **Commitment Level - Manual**: Funds are manually assigned at runtime. As spends business processes are routed and reach specified status, the amounts to be funded are collected under the Unassigned total on the commitment funding sheet, similar to project/shell level manual funding. You can then select each line of the spends BP and assign funds at runtime. This can be done on transient records or in terminal status (depending on design). Consumed funds roll up to the commitment funding sheet and the project funding sheet.

- **Commitment Level - Auto Ratio**: Funds are assigned automatically when the spends business process reaches a specified status. Funds are assigned based on the fund ratio, which is calculated based on the current fund levels, and is managed and tracked on the commitment funding sheet. If all funds are consumed, any remaining spends amounts are collected under Unassigned.

You can define these assignment rules on the commitment funding template. When you create a commitment funding structure in a project or shell, these assignment rules will be copied to it, and when you create new sheets from the structure, they will be copied to the sheets. If you need to, you can modify these rules on individual structures and sheets.

Fund Assignment details per SOV line

This is an optional step that allows you to provide details about fund assignment or consumption for each line on the base commit or any change commits. You access the Fund Assignment window by clicking the Fund Assignment button on the commitment funding sheet or the SOV sheet associated with the base commit.

- If you do not define any assignment options in this window, then All Funds is the default selection. This means that all funds that have been allocated to the base commit on the commitment funding sheet will be available for funding each line of the spends business process created against it (either manually or by auto ratio, as defined by the assignment rules). When this is chosen, funding information is captured on the commitment funding sheet in columns using data sources referencing “across all funds.”

- There may be times when you need to specify that a specific fund must be used to fund a specific WBS code on the base commit or a change commit. You can select a specific fund (or “discrete
**fund**") to fund selected SOV lines. When this is chosen, funding information is captured on the commitment funding sheet in columns using data sources referencing “by discrete fund.” Once the commitment funding sheet is created, you can add rows and allocate funds to it.
ALLOCATING FUNDS FOR COMMITMENT FUNDING

Similar to project/shell funding sheets, the rows of a commitment funding sheet correspond to the funds that you want to use to fund the associated base commit (plus any linked change commits). The funds that are available to add as rows are those that have been added to the project/shell funding sheet.

After adding a row, you allocate how much of that fund you want to make available to the base commit directly on the sheet. That is, you must add a column to the commitment funding sheet using the data source “Funding Across All Rows.” This is the column to use for fund allocation.

This column can be manual entry or formula. If it is manual entry, you can enter the fund allocation amount directly to the cell. If you use a formula, you must also include another manual entry column to use to enter an amount, and include that in the formula. For example, you might want to use your own ratio of certain funds in the initial allocations. You can add a manual entry column, then use the formula calculation for the Funding Across All Rows column.
ADD AND MANAGE COMMITMENT FUNDING SHEET ROWS
(FUNDS)

The rows that you add to a commitment funding sheet are the project or shell funds that you are allocating to the associated base commit and any change commits.

You add rows (funds) to the project/shell commitment funding sheet, but not the template or structure. You can delete a row as long as no assignments have been made against the fund.

| Note: | Once fund assignments have been made against them, you will not be able to delete the row. Once the sheet is saved, you cannot edit the fund; if you need to choose a different fund, first delete the row then create a new one. |

To add rows (funds) to the commitment funding sheet

1. Open the commitment funding sheet.
2. Click Add Rows. A new row is added to the sheet.
3. Click the dropdown in the Fund Code column and select a fund code from the list. The fund codes listed are those that are on the project or shell funding sheet.
   For each row, you will need to allocate how much of the fund to make available to the commit. You can do that now or wait until all the rows have been added.
4. To add another row, click the Add Rows button again, and choose a code. Fund codes can only be used once on the sheet; therefore, once a code has been used in a row, it will not appear on the list again.
5. Click Save on the commitment funding sheet to save your changes.

To delete rows

1. On the commitment funding sheet, select one or more rows.
2. Click the Delete Rows button.
3. Click Yes to confirm.
ALLOCATE FUND AMOUNTS TO A COMMITMENT

FUNDING SHEET ROW

You allocate the project/shell funds to use for each fund directly on the commitment funding sheet per row. The sheet must have a column that uses the data source “Funding Across All Rows.” This is the column to use for fund allocation.

This column can be manual entry or formula. If it is manual entry, you can enter the fund allocation amount directly to the cell. If you use a formula, you must also include another manual entry column to use to enter an amount, and include that in the formula. For example, you might want to use a ratio of certain funds in the initial allocations. You can add a manual entry column, then use the formula calculation for the Funding Across All Rows column.

To allocate fund values to a row

1. Open the commitment funding sheet.
2. For each row, double-click the cell of the column you are using for the manual entry portion of fund allocation (e.g., the Funding Across All Rows column). This makes the cell editable.
3. Enter the amount to use for fund allocation.
4. Click Save on the commitment funding sheet to save your changes. When you save the sheet, a validation check will be run to make sure that the allocation amounts do not exceed the fund balance of each fund on the project/shell funding sheet.
ASSIGNING AND CREDITING COMMITMENT LEVEL FUNDS

Assigning (consuming) or crediting funds on a commitment funding sheet is similar to a project or shell funding sheet, with some exceptions. This section assumes that the concepts of assigning and crediting funds of project or shell funding sheets is already understood.

As with project/shell funding, fund consumption on commitment funding sheets is done using general spends or payment application business processes that have been designed to consume funds. (When the spends BP is linked to a base commit that has been enabled to do commitment funding, then funds are consumed from the commitment funding sheet, not the project/shell funding sheet.) As in project/shell funding, funds are assigned from the spends record based on the amount of that record. The behavior of funding business processes depends both on the design options chosen in Primavera uDesigner and the Assignment Levels chosen on the commitment funding sheet properties.

Like project/shell funding, fund assignment can be done manually or automatically (by fund balance ratio). This is determined in the Fund Assignment rules set in the sheet Properties.
ABOUT BUSINESS PROCESSES ENABLED FOR COMMITMENT FUNDING

Commitment funding is enabled on the WBS-code based base commit. The design of the base commit forms determine when the Funding button appears on the base commit or change commit record. This button allows you to create the commitment funding sheet for the record, and also to access the funding sheet from the record. (Commitment funding sheets can also be accessed directly from the commitment funding sheet log.)

As in project and shell funding, you use spends type business processes (e.g., invoices or payment applications) to consume funds. If the spends BP is linked to a base commit that is enabled for commitment funding, then the spends record will consume funds from the commitment funding sheet rather than the project/shell funding sheet.

If you will be doing both project/shell funding and commitment funding, then use a different set of linked base commit / change commit / spends business processes for each.
VIEW UNASSIGNED AMOUNTS (COMMITMENT LEVEL)

When spends business processes are set up to be funded manually, the amount of the record initially is captured in the Unassigned (Commitment Level) field on the commitment funding sheet. This value displays until the entire amount of the record has been fully funded. For Project level funding, the amount displays in the Unassigned (Project Level) field; for WBS level funding, the amount shows up in the Unassigned (WBS Level) field.

It is possible that an Unassigned amount can be negative, as the result of a credit invoice that has not yet been credited back to the funding source.

Note: These can also be rolled up to the cost sheet using the Unfunded Record data source.

To view unassigned commitment funding amounts

1 Open the commitment funding sheet.

   If business process transactions have occurred that have not yet been funded, the total of the record(s) will display in the Unassigned field in the upper portion of the sheet.

2 Click the link next to Unassigned (Commitment Level). The Cell Detail window opens. The window lists transaction records that have not yet been fully funded.
ASSIGNING OR CREDITING UNASSIGNED FUNDS ON THE COMMITMENT FUNDING SHEET

Manually assign or credit unassigned funds

If there are unassigned funds, you can assign them manually from the spends business process record or from the commitment funding sheet.

When the spends record reaches a specified workflow step or status, a Funding button appears on the form. Clicking the Funding button opens the Funding window, allowing manual fund assignment.

If a credit invoice (negative line item or invoice amount) has been submitted, this can be used to credit previously consumed funds back to the source, or can be used to credit another fund. You cannot credit an amount that is more than has been consumed.

To manually assign funds from the commitment funding sheet

1. Open the commitment funding sheet.

2. In the upper portion of the window, click the link next to Unassigned (Commitment Level). This link displays the amount of funds that are not currently assigned to a particular fund.

The Cell Detail window opens. The Cell Detail window displays the list of spends business process records that have not yet been fully funded. A record can appear on this list if you do not have enough funds available during an auto-assignment process, or if you set Manual as the assignment rule for the business process under the funding sheet Assignment tab.

3. Select one or more records from the list and click the Assign to Funds button on toolbar. The Manual Fund Assignment window opens.

4. Enter a percent (%) amount for each record against a funding source.

5. Click OK.

Note: Because the number of decimal places is limited to two in the Manual Fund Assignment window, some amounts from funds can never be consumed. If you cannot use funds completely through the Assign to Funds window, go to the Spend BP record and manually consume the fund by entering the amount.

To manually assign or credit funds from a spends business process record

1. Open the business process record that needs to be funded. If the record is at a specified workflow step and status that allows funding, a Funding button is available.

2. Click the Funding button on the toolbar. The Funding window opens.

3. Select a line item from the upper pane. The bottom pane will display a list of funds that are available for that line item.

4. Enter the amounts for fund assignment. This is subtracted from the fund balance. For credits, enter negative amounts; the amount entered is added back to the fund balance.

5. Click OK.
Automatic fund assignments at the commitment level

Automatic fund assignment works similarly at the commitment level as it does in project/shell funding. The available automatic funding option is auto-ratio by fund balance (if All Funds is chosen in the Fund Assignment window), or a specific (discrete) fund can be used.


View Audit Logs

Audit logs are available within the Fund Detail and Cell Detail windows of the project or shell funding sheet. The Audit log captures all of the events that took place, including what action occurred, who took the action, and the value that was created or modified.

To view the project or shell funding audit log

Open the project or shell funding sheet and do one of the following:

- From the View menu, click Audit Log.
- Click a listed fund to open the Fund Detail window, and then click the Audit Log button.
- Click a cell link (line item or project or shell allocation entry) to open the Cell Detail window. From the View menu, click Audit Log.

To view commitment funding audit logs

Open the commitment funding sheet and do one of the following:

- From the View menu, click Audit Log.
- Click a listed fund to open the Fund Detail window, and then click the Audit Log button.
- Click a cell link (line item or project or shell allocation entry) to open the Cell Detail window. From the View menu, click Audit Log.

To view an audit log of company funding

Open the company funding sheet and do one of the following:

- From the Funding Sheet View menu, click Audit Log.
- Click on a listed fund to open the Fund Detail window, then click the Audit Log button.
- Open the Cell Detail window. From the View menu, click Audit Log.

The Audit log captures all of the events that took place, including what action occurred, who took the action, and the value that was created or modified.

About Schedule Of Values

Primavera Unifier’s Schedule of Values (SOV) feature provides a way to assemble information from contract, change order, and invoice and payment BPs into a SOV sheet, streamlining the process of invoicing for completed phases of a project or shell.

SOV functionality is available with cost BPs for which the Allow creation of Schedule of Values option is selected. The business processes can be designed to create an SOV sheet automatically upon reaching the designated step.

You may define one SOV sheet per commit business process (for example, a purchase order). Rows are automatically populated based on the WBS or account codes defined in the commit BP.
There are two types of SOV sheets:

- **General SOV**: This can be used for any commit business processes, and associated change commits and spends (or invoices).
- **SOV for payment applications**: This is associated with commit and spends business processes designed for payment applications. This allows direct entry of values in an SOV sheet, which are automatically added to a payment application. Breakdown for these SOVs is similar to the general SOV.

Both SOV types can show WBS information either by grouping WBS codes (WBS mode) or as individual line items from commits (base commit and change commit together). The information that SOVs display is dependent upon the design of the base commit.

### Creating An SOV Structure

**Structures of General SOVs and Payment Application SOVs:**

SOV structures are defined at the project or shell level in User Mode. The following describes setting up the SOV structure for general SOVs and payment application SOVs. Structures are based on SOV templates.

For SOVs for payment applications:

- Columns are based on the detail form of the payment applications BP.
- Can be defined once the payment application BP is imported into Primavera Unifier.
- Available columns are data elements on the detail form.

This section is for general SOVs. For SOV creation, it is important to have the correct column structure set up (meaning you have to include required columns and correct formulas) for validating summary commitments (by WBS) and remaining commits balance. In the SOV structure, you need to define a formula for remaining commits balance, which reflects the amount of commits minus spends. This column ensures that the spend BP line items are not overdrawn from SOV breakdowns.

**Note:** If an SOV structure does not exist when you auto-create an SOV sheet with a cost BP, one will be created automatically with the default columns WBS Code, WBS Item, and Breakdown. You can edit this structure as needed. The default columns are not editable.

Any modifications done to an SOV structure will be reflected on all SOV sheets using that structure, that is, all SOV sheets for that project or shell.

**To create an SOV structure**

1. Open the project or shell and click **Cost Manager > Schedule of Values** in the left Navigator.
2. In the Navigator, click **General** or **Payment Applications**. The Schedule of Values log opens. The log should be empty. If SOV sheets are already present, then a structure already exists.
3. Click the **Structure** button. The Select Template window opens.
4. Select an SOV template from the list and click **OK**. Read the confirmation message and click **Yes** to confirm. SOV sheets will be created using the structure defined by the template. You can use this structure as is or make edits as necessary.
To view or set up the SOV structure

1. From the Schedule of Values log, click the Structure button on the toolbar. The SOV Structure window opens.

2. Click the Columns button to add columns. Columns are added in a similar way to adding columns for a general SOV.

3. Click OK.

Note: While setting up the SOV structure, you may click the Split button to divide the window in half. This allows you to scroll through columns and rows on the right while maintaining a view of the activity column on the left. Clicking the Split button again restores the whole window. While the window is split, you may click the Freeze button to lock the left half of the window in place. Click Freeze again to unfreeze.

The structure may contain hidden columns. For example, one or more columns used in the formulas for other columns where the information in the hidden columns is not important to be viewed may have been hidden, leaving more room in the display for the formula column. Hidden columns otherwise behave normally.

To view or edit structure properties

1. From the Schedule of Values log, click Structure. The Structure window opens.

2. Click the File menu and choose Properties. The Properties window opens.

3. Make edits as needed and click OK.

Note: You can modify the WBS Code and WBS Item labels in the cost sheet.

Creating General SOV Sheets

Typically, commit business processes (contracts, purchase orders, etc.), will be designed in Primavera uDesigner to automatically create an SOV sheet upon reaching a specified status. Occasionally, the business process may allow manual sheet creation.

Once the SOV template structure is set up for a general SOV, SOV sheets are created based on the structure.

Note: If you manually create an SOV sheet, you can only create one based on an approved commit BP record.

To manually create a general SOV sheet

1. In the Schedule of Values log, click the New button. The Select Commit window opens.

2. Select a commit BP (e.g., a purchase order) and click OK. The SOV sheet is added to the log.

Note: If the commit BP has been set up in Primavera uDesigner to automatically create an SOV sheet upon the end step, the above procedure is not required.
To view cell details
Click a link (e.g., Amount or Ref) to open the Cell Detail window. Double-clicking on a record from the list window shows the details of the record.

Creating SOVs For Payment Applications
You can define the structure of a payment application SOV. Structure definition will be based on a payment application BP in the project or shell. This SOV type:
  • Allows tracking of payment schedule against your commits similar to industry-standard forms.
  • Allows you to create a breakdown for line items.

To manually create a payment application SOV sheet
1 Select Schedule of Values > Payment Applications Log.
2 Click the New button. The Select Commit window opens.
3 Select a commit BP (e.g., a purchase order) and click OK. The SOV sheet is added to the log.

Note: If a BP has been set up in Primavera uDesigner to automatically create a payment application SOV sheet upon the end step, the above procedure is not required.

Grant Permissions To Other Users
The creator of a commit BP becomes the owner of the associated SOV sheet and can grant permission to other users to view or modify the SOV sheet.

To grant permissions to other users or groups
1 From the Schedule of Values log, select the SOV sheet.
2 Click the Permissions button.
3 Select users or groups to grant permission to. Select Modify, Edit, or View permission.
4 Click OK.

Managing SOV Structure, Templates, And Sheets
The following sections cover steps that apply to both general and payment application SOVs.

Edit SOVs
The following sections cover steps that apply to both general and payment application SOVs.

To open the SOV sheet
From the Schedule of Values log window, select the SOV sheet and click Open. The sheet opens, reflecting the SOV structure and is populated by the values on the commit BP.

To edit an SOV
1 Click the Structure button on the toolbar.
2 Click File > Properties.
3 Click the Options tab to modify information.
You can enter a custom label for the Ref, Breakdown, and Description fields. These are the labels that will appear as column names on the SOV sheet. You cannot modify WBS Code and WBS Item. These labels can be modified only on the cost sheet.

To delete an SOV sheet
Select the sheet from the log window and click **Delete**. If you delete an automatically created SOV sheet, you will have to recreate it manually. You cannot delete an SOV for payment application.

To view properties
Select the sheet from the log window and click **File > Properties**.

**Edit SOV Columns**

To delete an SOV column

1. Select a column from the Columns log and click **Open** to open the Column Properties window.
2. Click **Delete**. The column will be deleted.

**Note**: If the column is being used in a formula in another column, you must remove the column from the formula before you can delete it. If the column contains a cell with line item data, you must first remove each line item before it can be deleted.

To edit a column
Select a column from the Columns log and click **Open** to open the Column Properties window.

Although it is possible to change the entry method for a column (for example, from line item content to direct entry into a cell, use caution when doing so if you have already entered values in the column cells. For example, if you change from line item entry to direct cell entry, the amount value shown in the cell will display correctly, but will be an editable direct entry amount, and detailed line item information will be lost.

Some fields may not be editable. It may be necessary to delete the column and create a new one.

To move a column
From the Columns log, select a column to move, and then click **Move Up (Left)** or **Move Down (Right)**. The order that the columns appear in the log window is the order (from left to right) that they appear on the sheet.

**Delete An SOV Sheet**

To delete a sheet
Select the sheet from the log window and click **Delete**. If you delete an automatically created SOV sheet, you will have to recreate it manually.

You cannot delete an SOV for payment application.

**Search For SOV Sheets**

You can search for SOV sheets by the SOV base record or description.

To search for an SOV sheet

1. In the Schedule of Values General or Payment Applications log, click **Find**.
2. In the Search by drop-down list, select SOV Base Record or SOV Description.
In the Search for field, enter the search criteria. Click the **Search** button. The log will display the records meeting the search criteria.

**Manage SOV Sheet Data**

SOV data is rolled up from cost-type BPs that have been set up for SOVs. SOV sheets cannot be edited.

**Export SOV Data**

You can export SOV data to a local file system in a CSV format.

**To export schedule of values sheet data**

1. In the Schedule of Values sheet, click the **File** menu and choose **Export**.
2. You may choose to open the file to review it before saving.
3. Click **Save** and specify the location in which to save the CSV file.

**View Or Edit SOV Sheet Properties**

**To open the SOV Properties window**

From the SOV log, select an SOV sheet and click the **Properties** button. The Properties window opens. Click the tabs to view properties information.

**To edit SOV properties**

1. Click the **Structure** button on the toolbar.
2. Click **File > Properties**.
3. Click the **Options** tab to modify information.

You can enter a custom label for the Ref, Breakdown, and Description fields. These are the labels that will appear as column names on the SOV sheet.

**Note:** You cannot modify the WBS Code and WBS Item labels. These labels can be modified only in the cost sheet.
ADD OR DELETE WBS BREAKDOWNS ON AN SOV SHEET

WBS breakdowns can be added to an SOV sheet. This enables each contract to have its own set of WBS breakdowns. These breakdowns can be added directly on the SOV sheet, or they can be imported from a CSV file. Breakdowns can be added to general spends or payment application SOVs.

**Note:** You cannot add a breakdown to an SOV if there is a pending spends record against the row, or a pending change commit with a negative line item (which may potentially reduce the Schedule Value after routing).

**To add a breakdown to an SOV line**

1. Open the SOV sheet.
2. Click the **Rows** button. The Rows window opens.
3. Select an SOV line by clicking the checkbox. If you select an SOV line, the breakdown will be added to that line. If you select an existing breakdown, the new breakdown will be inserted directly below the existing breakdown.
4. Click the **Add Detail** button. The Details window opens.
5. Enter the Breakdown. This will appear on the SOV sheet in the Breakdown column. You can add an optional Description.
6. Click **OK**. The breakdown is added to the sheet.
7. Close the Rows window.
8. You may need to click the plus (+) by the checkbox on the Rows window and on the SOV sheet to expand rows and display the breakdowns.

**To delete a breakdown row**

1. Open the SOV sheet.
2. Click the **Rows** button. The Rows window opens.
3. Select one or more breakdown rows to delete.
4. Click the **Delete Detail** button. Click **Yes** to confirm.
ADD BREAKDOWNs TO SOV SHEET BY IMPORTING

If you have multiple breakdowns to enter, you can do it in bulk through CSV file import. You can add as many breakdowns as you need to multiple WBS codes.

You can also optionally enter breakdown scheduled value amounts. In order to do this, there must be a column to the SOV sheet using the data source Scheduled Value. The amount you enter on the CSV file will appear in the Scheduled Value column.

**Note:** By default, the Scheduled Value column will validate that the sum of all breakdowns added to an SOV line will not exceed the scheduled value for summary line. That is, if the scheduled value for a line is $1000 from the base commit record, and you add breakdowns, the amounts that you enter for the breakdown amounts for that line cannot add up to more than $1000. (It can, however, add up to less than $1000.)

**To add breakdowns by importing a CSV sheet**

1. Open the SOV sheet.
2. Click the **Rows** button. The Rows window opens.
3. Click the **Export** button and choose **Breakdowns**.
4. Save the CSV file. This provides the structure for the import file.
5. Add the breakdown rows to the CSV file.
   a. Open the CSV file.
   b. Insert a line under the WBS code to which you are adding the breakdown.
   c. Add the breakdown name in the Breakdown column. You can enter an amount in the Scheduled Value column. Do not add any additional information in the new row.
   d. Add additional breakdown rows as needed.
   e. Save the file.
6. On the SOV sheet, click the **Import** button.
7. Browse to the CSV file and click **Ok**. The breakdowns and amounts will be added to the sheet. Any breakdowns in the CSV file that already exist on the sheet will be updated with the Scheduled Value amount on the CSV file.

If any errors occur, download and open the error file, and correct the CSV file before reimporting. Validations include: the sum of breakdown amounts cannot add up to more than the scheduled value amount of the summary WBS code line; they cannot exceed Commits Remaining Balance, if used; they cannot cause Commits Remaining Balance to fall below zero.
ABOUT CASH FLOW

The advanced Cash Flow module lets you create a “family of curves,” in which you can include as many baseline, actuals, forecast, portfolio, or custom curves as you need. Each of these curve families can be created in one of the detail levels: cash flow by Project/Shell, by WBS, by Summary WBS, or by Commitment (one per base contract) within a project or shell. Cash flow is the distribution of cost over time—in project management terms, it is the movement of cash into or out of a project measured during a specific time period.

Each group of curves is accessed and managed in a Cash Flow Worksheet, which allows you to view or enter data, and view and compare the curves you have added. To facilitate creation of cash flow curves and roll up of data to program and company cash flow worksheets, your administrator can create the following in Administration Mode:

Data Sources: You can create data sources that can be used to identify cash flow curves and roll up data to program and company worksheets. You will need to create data sources in order to create cash flow curves.

Data sources are created based on a Curve Type—pre-defined categories of cash flow curves: Baseline, Forecast, Spends, Portfolio, and Custom. You can use these types to create cash flow curves. Each curve type has its own logic to address different business requirements.

You can also create Distribution Profiles. You have the option of manually distributing data in the cash flow worksheet, or you can have the system automatically distributing data using a default distribution profile.

You can create cash flow detail curve templates, which will simplify making cash flow curves at runtime within a project and shell; and roll up curve templates, which you can use to create curves in programs to roll up cash flow data from projects or shells.

Note: The advanced cash flow module introduced in Primavera Unifier 9.3 is named “Cash Flow.” Be sure you have the permissions you need to view and work with the cash flow module at the project and shell level, program level and company level.

You will notice that the pre-9.3 cash flow module has been renamed Cash Flow (Basic). This retains all the functionality and cash flow records created before the release of 9.3, and will remain fully functional at this time. Cash Flow (Basic) will be phased out eventually as users move to the enhanced Cash Flow module.
GRANTING CASH FLOW USER MODE PERMISSIONS

Before others can access a cash flow curve that you created, they need user mode permission. This is different from permission granted in Administration Mode, which is for general access to the module. You grant user mode permission per detail curve in the project or shell.

To give users permissions to work with a cash flow curve

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens.
2. Select a curve from the log and click the Permission button. The Edit Permission window opens.
3. Click Add, select one or more users and/or groups to grant permission to, and click OK.
4. In the Edit Permission window, select one or more users or groups. Select the permission:
   - Modify Permission. Allows user to modify permissions to the curve. This also automatically selects Edit Data.
   - Edit Data. Allows user to enter or edit data for manual data entry curves.
   - View. By default, when you add a user or group to the window, they are granted View permission, which allows them to access and view the curves and data.
PORTFOLIO MANAGER BUDGET CURVES

More information about the Portfolio Manager and how it works is in the Portfolio Manager section of Primavera Unifier Help.

For cash flow purposes, the Portfolio Manager extracts a project’s baseline or forecast budget numbers for use in a scenario sheet. During a portfolio analysis, the Portfolio Manager can produce three different portfolio budget curves:

- A Shared Budget curve. This curve shows the portfolio planner’s proposed number for the project. You will not have access to this curve until the planner shares a scenario. You can include this curve on the cost worksheet, along with the forecast budget, or any other budget curve, in order to see the difference between your project’s numbers and the planner’s proposed budget numbers. See example below.

- An Approved Budget curve. When a scenario is approved in the Portfolio Manager, the budgets for each project in the scenario are marked “approved.” They are then locked and stored in the Portfolio Manager. An Approved Budget curve shows the approved budget for the project for that planning period (usually a year).

- An Original Budget curve. This curve is for a project in execution. This budget is the last approved budget for the project before it moves into its execution phase. This approved budget becomes the project’s original budget; and this original budget, plus any changes that occur to the numbers during the life of the project, becomes the project’s approved budget.

Before you can use these curves, you must add them to your project. See Add a Portfolio Curve.
CASH FLOW CURVES

The Cash Flow module lets you create as many baseline, actuals, forecast, portfolio, or custom curves as you need in a cash flow worksheet. Each curve can be created in one of the detail levels: cash flow by Project or Shell, by WBS, by Summary WBS, or by Commitment (one per base contract) within a project or shell. For company and program-level cash flow see Program Level and Company Level Cash Flow.

The cash flow worksheet allows you to view or enter data, and view and compare the curves you added. There are several ways to create a cash flow curve, including manual creation, copying from a template, auto-creating a curve on a workflow step by using a template, and copying another curve.

Manual creation: every time you create a curve in a project or shell you define all curve properties from scratch.

Templates: you can pre-set curve options, except, for example, actual business process records, and cost sheet columns, which are set at run time. There are two types of cash flow templates: company-level templates, which are created in Standards & Libraries (in Administration Mode), and project or shell-level templates, which are created within a project or shell template.

Auto-creation: In the base commit business process workflow set up you can associate a cash flow template with any step except the Creation step. When the base commit record reaches that step, Primavera Unifier will automatically create a cash flow curve.

Copy: You can copy existing curves from the Cash Flow log, or you can copy data from existing curves. See Copy Cash flow curves and curve data.

General Information About Curves

Properties settings

The Properties descriptions below apply to Baseline, Spends, Forecast, Portfolio, and Custom detail curves.

For Cash Flow by Project or Shell Detail Level

- Curves tab, Distribute amount from cost sheet column field and From/To Dates
  - Baseline, Forecast, Custom and Portfolio curves: If you want to automatically distribute a Cost amount from a cost column, the column must be selected in the project or shell. You can choose it for a project/shell template as long as you are creating a new project or shell from the template and are copying both the curve and the cost sheet.
  - Spends curve: Because you must select a cost sheet column associated with Spends data in the project or shell, a spends curve can only be created in a project or shell (or similar to the above, in a project/shell template). You will not be able to add a spends curve in a company-level template.
  - Forecast curve: Forecast options use data from the Spends curve, and so Forecast options can only be set if a Spends curve is present.
  - Portfolio Curve: The portfolio curve shows current project-row plan data from a portfolio sheet. When plan data changes, it becomes visible in the cash flow graph as a parallel curve so project managers can clearly see the variance between their projections and portfolio planner-initiated changes.
  - From Date and To Date: These fields can be set up to pull start and finish dates from the master schedule sheet in the project or shell. These can be selected in a project or shell
template. At runtime, be sure the master schedule sheet is set up and has dates in the date element fields chosen for the curves.

**Note:** In manual mode, Primavera Unifier pegs cost data distribution to the From Date. If there are date changes, Primavera Unifier shifts the curve on the timeline based on From Date modifications. Each time period (e.g. month or year) on the curve retains the value of the original distribution as long as the duration remains the same. If date changes make the cash flow curve duration longer or shorter, Primavera Unifier will not rebalance or redistribute cost data to match the modified curve length (the data will change.)

For Cash Flow by WBS Detail Level

- Curves tab, Use data from Schedule Sheet field - Effective for the baseline curve only, you can view cost distribution information by WBS code in a schedule sheet.
- Curves tab, Distribute amount from cost sheet column field and From/To Date fields
  - Similar to Cash Flow by Project/Shell Detail Level above.
- Curves tab, Auto by default profile by WBS field
  - For Baseline, Forecast and Custom curves, you cannot select “Auto by default profile by WBS” in a company template, but you can in the project/shell, since this setting relies on the WBS codes used in the project or shell. You can choose it for a project/shell template as long as you are creating a new project or shell from the template and are copying both the curve and the cost sheet.

**Note:** You won’t be able to double-click the WBS Summary to view the WBS details.

For Cash Flow by Summary WBS Detail Level

- Curves tab, Distribute amount from cost sheet column field and From/To Date fields
  - Similar to Cash Flow by WBS Detail Level above.
- Curves tab, Auto by default profile by Summary WBS field
  - Similar to WBS detail level, for Baseline, Forecast and Custom curves, you cannot select “Auto by default profile by Summary WBS” in a company template, but you can in the project/shell, and a project/shell template as long as you are creating a new project or shell from the template and are copying both the curve and the cost sheet.

For Cash Flow by Commitment Detail Level

- General tab, Business Process and Base Commit Record fields
  - For a Commitment detail level, you must select the base commit type business process to use. Be sure that you selected business processes that are being used in the project or shell.
  - In the Base Commit Record field, you must select the record at runtime. This is not selectable in the template, since records do not exist in templates. The list displays all records you have permission to view. If a detail curve already exists for that record, you will not be able to choose the same record again.
- Curves tab, Include Change Commits and Spends Business Process
  - If you chose these options, be sure you have selected change commits that are being used in the project or shell, and associated with the selected base commit.
Note: If the cash flow is attached to a Portfolio Manager scenario, the planner-modified baseline curve appears adjacent to the original baseline in the Cash Flow worksheet. This lets the project Manager easily spot the difference between the initial projection and the planned suggestion.

Distribution Profiles

One last point to keep in mind when working with templates versus detail curves in projects and shells: Distribution profiles can be created in Administration Mode (in Standards & Libraries), and used when selecting auto distribution for curves.

At runtime, you can also create additional distribution profiles within the project or shell cash flow module. When working with curves, you can apply the profiles created in Administration Mode, or in the project or shell.

Note: If you are creating a new project or shell from a project or shell template, and are copying the cash flow module, then template properties and permissions will be copied into the new project or shell.

Cash Flow Properties General Tab

The General tab of the cash flow properties window is where you enter the general information for all of the curves you will add to the detail curve cash flow worksheet. All of the curves added here will share the same Time Scale, Detail Level, and Period close settings.

To create a cash flow details curve and complete the Properties General tab

1. Open the cash flow log in the project or shell.
2. Click New > Detail Curves. The Properties window opens and Primavera Unifier displays the General tab.
3. Enter a unique Name for the curve.
4. Enter an optional Description.
5. Select a Rollup Status. This controls whether the data is rolled up to Program or Company cash flow curves.
   • Active. The curve will roll up to Program and Company cash flow the next time the curves are refreshed.
   • Inactive. The curve will not roll up to Program and Company cash flow the next time the curves are refreshed.
6. Select the Detail Level. This determines the level the cash flow curves will display. Choose one:
   • Project/Shell: Choose this to track cash flow for the entire project or shell. For example, baseline and actuals curves might chart the budget and cash outlay across the entire project.
   • WBS: Choose this to track cash flow within a project or shell at the WBS code level. This allows you to track cash flow across the project for specific WBS codes, or all WBS codes.
   • Summary WBS: Choose this option to track cash flow by summary WBS codes. In order to select this option, the cost sheet used in the project or shell must be a tree structure.
   • Commitment: Choose this option to track cash flow associated with a particular commitment record and its line items. This includes, for example, a base contract, and optionally their change commits. This selection activates the following fields.
**Business Process.** Click the drop down menu and choose a business process. Listed are the project/shell level business processes of type “Base Commit.” When creating a template, choose the one that is likely to be used in the projects/shells the template will be used in. When creating the curve in a project or shell from the template, you may need to verify that the business process chosen here is active in the project or shell, or pick another from the list.

**Reference Elements.** These are what will display on the worksheet. By default, the Record Number will display as the number. You can click the drop down menu and choose an element to display as the Name (Record Number, Status or Title).

**Base Commit Record.** This is selectable in a project or shell, but not in a template. Click the Select button. Choose the commitment record from the list of available records in the project or shell. Each commitment record can be selected only once.

**Note:** You can set up the automatic creation of a cash flow curve when a base commit record is created and completed or reaches a particular step. This is done in the BP Setup for the business process. See Setting up auto-creation of cash flow curves from contracts.

7 Select the **Time Scale.** The time scale determines the scale and format in which the data is shown on the Cash Flow Worksheet.

  • By: Month or Year. The default is Month.
  • Format: Choose the format that you want the month and year displayed on the graphs. The default is M YYYY.

8 Define the **Period Close Settings.** These options allow you to choose some automatic settings that will happen at the end of each period (month or year, as chosen in the Time Scale field).

  • **Enable auto snapshot on.** Determines when an automatic snapshot will be taken of the data.
    • Click the Select button.
    • For Month time scale, you can choose a specific date each month to automatically take a snapshot, or specify a particular day (such as the first Monday of the month).
    • For Year time scale, you can specify the exact date to take the snapshot each year, or a particular day (such as the first Monday of January).
    • See the examples at the end of this table for more information about these options.
    • After an auto-snapshot is taken, the curve will be refreshed immediately. Spends will resume after the auto-snapshot.

  • **Cut off spends.** This is applicable for Spends type curves. It will temporarily stop spends business processes (e.g. invoices) from hitting the cash flow worksheet during analysis periods. The Enable auto snapshot on option must be chosen first. After the auto-snapshot is taken, spends will resume again.

  • **Apply Spends to.** Apply spreads to an effective date or before/after a cutoff date. By default, cut-off spreads will resume immediately after an auto-snapshot is taken. If there is a gap between the cut-off-spends date and the auto-snapshot date, any spreads that came during that period are not lost.

For example, if a cut off date is October 26th and the snapshot date is November 2nd, (and the timescale is monthly) that defines the freeze period. Any spreads that come in on October 27, 28, 29, 30, 31, and November 1 will not hit the cash flow sheet during the freeze period. After the auto snapshot date is reached, these will be included back in October for spends (Oct 27-31) or November for spends (Nov 1-2) and the effective date will be honored.
• **The same month/year as the effective date** – If this option is chosen, once the freeze period is lifted, the spends data is included back in the current period. The final output is similar to the case where no period close settings are applied since the effective date is honored. Spends for Oct 26-31 will be included in October and Nov. 1-2 spends will be included for November.

For example, if the cut off date is the 26th of October and the snapshot date is the 2nd November, the freeze period is Oct 26 – Nov 2nd. Any spends that come in on Oct. 27,28,29,30,31 and Nov. 1, and 2 will not show on the cash flow sheet during the freeze period. After the auto snapshot date is reached, these spends will be included back in either Oct for spends (Oct 27-31) or Nov for spends (Nov 1-2) and the effective date will be honored.

• **The next month if after the cutoff date** – Once the freeze period is lifted, the spends data from the cutoff date to the end of the month will be included in the next month/year. Spends for Oct 26-31 will be included in November and Nov. 1-2 spends will be included for November.

• **The previous month if on or before the cutoff date** – Once the freeze period is lifted, the spends data from the start of the month up to the cutoff date will be included in the previous month/year. Spends for Oct 26-31 will be included in September and Nov. 1-2 spends will be included for November.

**Note:** During the spends cut-off period, even if automatic refresh of the curve occurs as set in the Schedule tab, spends data will not hit the cash flow sheet until spends are resumed again.

9 After the General tab is complete, you can save as is, or continue by adding the curves that will make up the detail curve. See “Cash flow properties curves tab” on page 458.

**Examples of using auto snapshot, cut off spends, and resume spends options:**

• Company A simply wants to take an auto snapshot of their cash flow data every time period. They would choose a particular date (such as the 3rd of the month for Month, or January 3 for Year). The snapshot would be taken, and the cash flow curve refreshed. They do not select the Cut off spends option.

• Company B regularly reviews and revises forecast projections during fixed days every time period. During this period, they do not want new spends records to hit the cash flow worksheet as they work on their forecast projections, and so they choose the Cut off spends option. This option requires that Enable auto snapshot be selected first. The company sets this option so that an auto snapshot is taken of their changes just before spends are resumed. Snapshots can then be used for comparison of previous forecasts with the current month’s. Any spends records that came in during the forecast period are not lost; the Resume spends option determines whether those spends records will be included in the previous month’s cash flow, or pushed to the next time period.
CASH FLOW PROPERTIES CURVES TAB

Cash Flow Properties Settings On The Curves Tab

In the Curves tab of the cash flow details Properties window, you add the curves you would like to include in the cash flow worksheet.

You create curves (Baseline, Spends, Forecast, Custom, or Portfolio) based on the data sources that you defined in either:

- Standards & Libraries > Cash Flow > Data Sources
- Templates > Project / Shell > Cash Flow

Depending on the type, the curve setup options will differ. You can define one curve for every data source.

The Portfolio curve is linked to scenarios in the Portfolio Manager. As a project manager, you must create this curve. Once created, the curve will show your initial budget projections. See Add a Portfolio Curve.

When you open a curve, you can view the data in the transaction currency, if different from the project currency.

Add A Baseline Curve

You can construct cash flow curves by project or shell, summary WBS codes, by WBS, or by a specific commitment business process and record. Baseline curve options reflect the detail level selections you made on the General tab.

To add a baseline curve for cash flow by project/shell

1. Open the Properties window of the cash flow detail curve. Be sure the Detail Level is Project/Shell.
2. Click the Curves tab.
3. Click Add and choose a data source of type Baseline. The Cash Flow by Project/Shell - Baseline window opens.
4. Complete the window using the information in the table below.

<table>
<thead>
<tr>
<th>In this Field</th>
<th>Do This:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field is filled in automatically with the name of the data source</td>
</tr>
<tr>
<td>Type</td>
<td>This field displays the curve type: Baseline</td>
</tr>
<tr>
<td>Distribution</td>
<td>Distribution drives how the amount value will be distributed over the time periods. Choose one:</td>
</tr>
<tr>
<td></td>
<td>• Manual. You enter values into each field manually.</td>
</tr>
<tr>
<td></td>
<td>• Auto by default profile. Allows you to choose one of the available Distribution Profiles, defined in Standards &amp; Libraries &gt; Cash Flow &gt; Distribution Profiles, or that were defined directly in the project or shell cash flow log (Edit &gt; Distribution Profiles). This will be used as the default profile; however, at runtime, the user can change which profile to use.</td>
</tr>
<tr>
<td></td>
<td>Click the Select button. The Distribution Profiles window opens. Select a profile to use as the</td>
</tr>
</tbody>
</table>
### Cost

**Choose one:**
- Manually enter amounts for each period (available if you chose Manual above). You can enter cost information in the Total field on the worksheet.
- Auto distribute total amount across all periods (available if you chose Auto by default profile above). This will automatically distribute the amount in the Total field using the selected default profile.
- Distribute amount from cost sheet column. This will take the amount in the selected Cost Sheet column, and either allow you to distribute it manually (if you chose Manual distribution), or use the default distribution profile (if you chose Auto by default profile). An example column would be a budget.

Cost column can be chosen when creating a curve in a project or shell, but not in templates.

### Schedule

Here you define the range of dates to use to plot the cash flow data. If you choose to take dates from the schedule sheet elements, the Master schedule sheet for the project/shell is used.

**From Date and To Date**

Determines what dates to start the curve and end the curve. Choose one for each:
- Manual. User enters the date directly in the cash flow worksheet.
- Data element from schedule sheet. Choose a schedule sheet data element from the list. The date will be populated automatically from the Master schedule sheet when the cash flow curve is refreshed.

If the these dates are changed on the Master schedule sheet, then the changes will be reflected on cash flow after the next refresh of the curves.

---

5 Click OK.

**To add a baseline curve for cash flow by WBS**

1 Open the Properties window of the cash flow detail curve. Be sure the Detail Level is WBS (for cash flow by individual WBS codes) or Summary WBS (for summary WBS codes).

2 Click the Curves tab.

3 Click Add, and choose a data source of type Baseline. The Cash Flow by WBS - Baseline or Cash Flow by Summary WBS - Baseline window opens.

4 Complete this window in the same way as for a baseline curve for project/shell detail level, with the following exceptions:
   - For WBS detail level, the Distribution option Auto by default profile per WBS is available.
   - For Summary WBS detail level, the Distribution option Auto by default profile per Summary WBS is available.

See the table below for details.

<table>
<thead>
<tr>
<th>In this Field</th>
<th>Do This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field is filled in automatically with the name of the data source</td>
</tr>
<tr>
<td><strong>Type</strong></td>
<td><strong>Distribution</strong></td>
</tr>
<tr>
<td>----------</td>
<td>------------------</td>
</tr>
<tr>
<td></td>
<td>Distribution drives how the amount value will be distributed over the time periods. Choose one:</td>
</tr>
<tr>
<td></td>
<td>• Manual. You enter values into each field manually.</td>
</tr>
<tr>
<td></td>
<td>• Auto by default profile per WBS (for WBS detail level curves) or Summary WBS (for Summary WBS detail level curves).</td>
</tr>
<tr>
<td></td>
<td>You can specify a default profile per WBS code or Summary WBS code. This can be done one at a time or using bulk edit.</td>
</tr>
<tr>
<td></td>
<td>This is the default distribution profile, but can be changed at runtime. Follow these instructions.</td>
</tr>
<tr>
<td></td>
<td>Click the Details button. The WBS Details window opens.</td>
</tr>
<tr>
<td></td>
<td>To set the default distribution profile on one WBS code at a time: double-click in the Default Profile field and choose the profile from the dropdown list.</td>
</tr>
<tr>
<td></td>
<td>To set the default profile on multiple codes: Select the WBS or Summary WBS codes from the list. Click Bulk Edit. Select the profile to use and click Select. Click Save.</td>
</tr>
<tr>
<td></td>
<td>You can use Find to search for specific WBS codes.</td>
</tr>
<tr>
<td></td>
<td>• Use data from Schedule Sheet. Allows you to choose a schedule sheet so a project manager you view the cost distribution information by WBS code. Click the Select button and choose the schedule sheet. Selecting a schedule sheet is optional. If a schedule sheet is not selected, the distribution will display zeros along the bottom of the cash flow curves’ graph. Click OK. In the details window, the filter will be applied against the WBS codes coming from the schedule sheet.</td>
</tr>
</tbody>
</table>

5 Click OK.

**To add a baseline curve for cash flow by commitment**

You can build one baseline curve per commitment record. When you build a baseline curve for individual line items, the SOV type influences distribution options. If the SOV lists individual line items by WBS you can distribute cost for each line item individually; if the SOV groups line items, you cannot. For costs distributed in the transaction currency, Primavera Unifier calculates and stores the distribution in project currency using the exchange rate table.

1 Open the Properties window of the cash flow detail curve and click the **Curves** tab.

2 Click **Add**, and choose a data source of type **Baseline**. The Cash Flow Commitment - Baseline window opens.

   The **Name** field shows the name of the data source you chose.

   The **Type** field shows the curve type, in this case Baseline.

3 Choose the **Cash Flow Granularity**. Cash flow granularity options determine the level of record detail available in the cash flow curve. You can roll up base and change commits, see individual records separately, or drill to individual line items in a commitment record.
Choose the **Distribution Method**. The cash flow granularity you choose determines the distribution options you have. Use the following table to set up the curve options.

**Note:** By default, Primavera Unifier displays commitment curve cost data in the record transaction currency, which is stored in project currency using the active currency exchange rate table. If the transaction currency is different from the project currency, you can change the currency view between transaction and project currencies, but you can only edit data in the transaction currency. If there is a more recent value in the exchange rate table, refreshing the curve will refresh the cost data.

<table>
<thead>
<tr>
<th>If you choose:</th>
<th>Your Distribution Method choice is:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Distribution of sum of base commit and all changes</td>
<td>• <strong>Manual entry of values per cash flow period.</strong> This is the only available option. In User Mode you must open the cash flow Details window to complete time scale fields and distribute the rolled up values of the base commit record and any change commit records.</td>
</tr>
</tbody>
</table>
| By individual record (base commit and all changes separately) | • **Manual entry of values per cash flow period.** Use this option to manually enter the time scale and to distribute costs.  
  • **Auto distribution.** Use this option to utilize a pre-defined distribution curve. In User Mode curve data is read-only, but you can change the distribution profile. This selection requires a sub-selection.  
  **Manual Dates and manual selection of profile.** Use this option to manually enter the time scale and select a distribution curve.  
  **Dates from business process, default profile.** Use this option to select the time scale from fields on the business process. Click the Details button to open the selection window. There are four columns in the Auto Distribution window.  
  **Business Process** – List comes from the Cost-type business processes available in your company  
  **From Data Element** – Select the date you want the distribution to start  
  **To Data Element** – Select the date you want the distribution to end  
  **Default Profile** – If desired, select a predefined profile. |
| By line items within each individual record | • **Manual entry of values per cash flow period.** Use this option to select record line items. In User Mode you can:  
  See each selected line item in the cash flow Details window; the columns come from the business process.  
  Select a profile on the detail window for each line.  
  Select the distribution profile manually.  
  • **Auto distribution.** Use this option to manually enter dates and select a distribution profile. |

In the **Commit Change Processes to be included** field, you can add Commit Change business processes according to their statuses. These line items are also seen in the cash flow curve **Details** window.
6 Click OK.

**Add A Spends Curve**

The spends curve tracks actual invoice transactions. It pulls the data from a column of the cost sheet. Choose a column associated with the data source for the spends business process and status that you want to track.

**To add a spends curve for cash flow by project/shell**

1. Open the Properties window of the cash flow detail curve. Be sure the Detail Level is Project/Shell.
2. Click the Curves tab.
3. Click Add and choose a data source of type Spends. The Cash Flow by Project/Shell - Spends window opens.

<table>
<thead>
<tr>
<th>In this Field</th>
<th>Do This:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field is filled in automatically with the name of the data source</td>
</tr>
<tr>
<td>Type</td>
<td>This field displays the curve type: Spends</td>
</tr>
<tr>
<td>Distribution</td>
<td>See Add a baseline curve for cash flow by project/shell.</td>
</tr>
<tr>
<td>Cost</td>
<td>Choose a cost sheet column associated with the spends-type business process and status. Note: Cost sheet column selection is only available when creating curves in a project or shell, not a template (since there is no cost sheet to reference). If you are creating a detail curve template, you will not be able to add a Spends curve.</td>
</tr>
</tbody>
</table>

**To add a spends curve for cash flow by WBS or Summary WBS**

1. Open the Properties window of the cash flow detail curve. Be sure the Detail Level is WBS (for cash flow by individual WBS codes) or Summary WBS (for summary WBS codes).
2. Click the Curves tab.
3. Click Add and choose a data source of type Spends. The Cash Flow by WBS (or Summary WBS) - Spends window opens.
4. See “To add a spends curve for cash flow by project/shell” above.

**To add a spends curve for cash flow by commitment**

1. In the Properties window, click the Curves tab.
2. Click Add and choose a data source of type Commitment. The Cash Flow by Commitment - Spends window opens.

<table>
<thead>
<tr>
<th>In this Field</th>
<th>Do This:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field is filled in automatically with the name of the data source</td>
</tr>
<tr>
<td>Type</td>
<td>This field displays the curve type: Spends</td>
</tr>
<tr>
<td>Cash Flow</td>
<td>By line items from Schedule of Values</td>
</tr>
</tbody>
</table>
### In this Field: Do This:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Granularity</td>
<td>Select this option if you want to cash flow individual line items from the spends record.</td>
</tr>
<tr>
<td>Cost</td>
<td>Choose the Spends business process to use. The Spends business processes that are associated with the base commit are listed. Choose the business processes and statuses that you want to include in the curve.</td>
</tr>
</tbody>
</table>

**Note:** When you open this curve, you can view the data in two different currencies by switching between project and transaction currencies.

### Add A Forecast Curve

Forecast curves are created similarly to baseline curves, with additional options to start the forecast at the end of a spends curve.

#### To add a forecast curve for cash flow by project/shell

1. Open the Properties window of the cash flow detail curve. Be sure the Detail Level is Project/Shell.
2. Click the Curves tab.
3. Click Add and choose a data source of type Forecast. The Cash Flow by Project/Shell - Forecast window opens.
4. Complete the window using the information in the table below.

#### In this Field: Do This:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field is filled in automatically with the name of the data source</td>
</tr>
<tr>
<td>Type</td>
<td>This field displays the curve type: Forecast</td>
</tr>
<tr>
<td>Distribution</td>
<td>See Add a baseline curve, for cash flow by project/shell</td>
</tr>
<tr>
<td>Cost</td>
<td>See Add a baseline curve, for cash flow by project/shell</td>
</tr>
<tr>
<td></td>
<td>For a forecast column, an example of a column choice would be a spends business process and status.</td>
</tr>
<tr>
<td>Schedule (From Date/To Date)</td>
<td>See Add a baseline curve, for cash flow by project/shell</td>
</tr>
</tbody>
</table>
More about Forecasting Curves

- Forecasting curves give users the option of starting the forecast at the end of a spends curve every time period.
- If the initial forecast used a distribution profile to begin with, and has a configuration start at the end of actuals, then when you receive actuals, the profile has no impact on Forecast distribution.
- If the original forecast was over or underestimated with respect to the spends, users have the option to automatically distribute the excess or deficient amount over as many time periods as you specify. This will automatically be done by weighted average.

To add a forecast curve for cash flow by WBS or Summary WBS

1. Open the Properties window of the cash flow detail curve. Be sure the Detail Level is WBS (for cash flow by individual WBS codes) or Summary WBS (for summary WBS codes).
2. Click the Curves tab.

See “To add a forecast curve for cash flow by project/shell” above for details on completing the window. (And “Add a baseline curve” for Distribution field details.)

To add a forecast curve for cash flow by commitment

1. Select a schedule sheet and click the Properties button. The Properties window opens on the General tab. Click the Curves tab.
2. Click Add and choose a data source of type Forecast. The Cash Flow by Commitment - Forecast window opens.

The Name field shows the name of the data source you chose, in this case Forecast.

The Type field shows the curve type, in this case Forecast.

3. Complete the window using the information in the table below.

Cash Flow Granularity selections dynamically affect Distribution options. If you have future currency rates specified in the Exchange Rates sets, the cost distribution reflects any rate changes to project currency over the life of the curve.

<table>
<thead>
<tr>
<th>If you choose:</th>
<th>Your Distribution Method choice is:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Distribution of sum of base commit</td>
<td>• Manual entry of values per cash flow period. This is the only available option. In User Mode</td>
</tr>
<tr>
<td>and all changes</td>
<td>you must open the cash flow Details window to complete time scale fields and distribute the rolled</td>
</tr>
<tr>
<td></td>
<td>up values of the base commit record and any change commit records.</td>
</tr>
<tr>
<td>By individual record (base commit and all</td>
<td>• Manual entry of values per cash flow period. Use this option to manually enter the time scale</td>
</tr>
<tr>
<td>changes separately)</td>
<td>and to distribute costs.</td>
</tr>
<tr>
<td></td>
<td>• Auto distribution. Use this option to utilize a pre-defined distribution curve. This selection</td>
</tr>
<tr>
<td></td>
<td>requires a sub-selection.</td>
</tr>
<tr>
<td></td>
<td>**Manual Dates and manual selection of profile. Use this option to manually enter the time scale</td>
</tr>
<tr>
<td></td>
<td>and select a distribution curve.</td>
</tr>
<tr>
<td></td>
<td>**Dates from business process, default profile. Use this option to select the time scale from</td>
</tr>
<tr>
<td></td>
<td>fields on the business process. Click the Details button to open</td>
</tr>
</tbody>
</table>

Oracle Corporation
Primavera Unifier Users Guide • Copyright © 1998, 2012, Oracle and/or its affiliates. All rights reserved.

464
If you choose: | Your Distribution Method choice is:
---|---
| the selection window. There are four columns in the Auto Distribution window.  
**Business Process** – List comes from the Cost-type business processes available in your company  
**From Data Element** – Select the date you want the distribution to start  
**To Data Element** – Select the date you want the distribution to end  
**Default Profile** – If desired, select a predefined profile.

By line items from Schedule of Values | • **Manual entry of values per cash flow period**. Use this option to select record line items. In User Mode you can:  
See each selected line item in the cash flow Details window; the columns come from the business process.  
Select a profile on the detail window for each line.  
Select the distribution profile manually.  
• **Auto distribution**. Use this option to manually enter dates and select a distribution profile.  
In the cash flow Details window, Primavera Unifier populates column values from the business process schedule of values

Forecast Options | • **Begin calculations at end of curve**. Select this option if you want to automatically start the forecast at the end of a selected spends curve every time period. Click Select and choose the spends curve. (This option is available only if a Spends curve exists; spends curves cannot be added to a company level template.)  
If this option is selected, the original forecast for the period will be wiped out and the spends value will be considered for that time period.  
• **Distribute unassigned amount from Spends**. These options are available only if you have chosen Auto by default profile for Distribution. They give you the option to automatically distribute any overestimated or underestimated spends amounts from the original forecast. You can choose one:  
using weighted average over all remaining periods.  
using weighted average over next ___ period(s). (Enter the number of time periods, 1 or more, not to exceed the number of periods left.)

4 Click **OK** to save the curve.
ADD A PORTFOLIO CURVE

You can add a portfolio curve for each cash flow detail level. Directions follow.

**To add a portfolio curve for cash flow by project or shell**

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator.
2. Select New > Detail Curves from the drop-down. The Properties window opens.
3. Name the cash flow detail curve and give it a description.
4. Select the Project / Shell radio button.
5. Enter settings for Time Scale and Period Close Settings.
6. Click the Curves tab.
7. Click Add and choose a data source based on a portfolio budget type. The Cash Flow by Project/Shell - Portfolio Curve window opens.
8. From the Distribute amount from field, select the specific portfolio curve (original, shared, or approved) from the drop-down list.
9. Click OK.
10. Repeat steps 7 to 8 for additional curves, if necessary.
11. When finished, click OK.

**To add a portfolio curve for cash flow by WBS or Summary WBS**

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator.
2. Select New > Detail Curves from the drop-down. The Properties window opens.
3. Name the cash flow detail curve and give it a description.
4. Select the WBS or Summary WBS radio button.
5. Enter settings for Time Scale and Period Close Settings.
6. Click the Curves tab.
7. Click Add and choose a data source of type Portfolio. The Cash Flow by WBS (or Summary WBS) - Portfolio Curve window opens.
8. From the Distribute amount from field, select the specific portfolio curve from the drop-down list.
9. Click OK. The portfolio curve opens in the Properties window.
10. Repeat steps 7 to 9, for additional curves, if necessary.
11. When finished, click OK.

**To add a portfolio curve for cash flow by commitment**

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator.
2. Select New > Detail Curves from the drop-down menu. The Properties window opens.
3. Name the cash flow detail curve and give it a description.
4 Select **Commitment** as the **Detail Level**.

5 Select the business process from the drop-down menu.

6 Select **Reference Elements** from the drop-down list. The **Reference Elements Selector** window opens.

7 Choose a reference element from the list and click **OK**.

8 Select the base commit record from the drop-down list. The base commit record window opens.

9 Make your selection from the list and click **OK**.

10 Enter settings for **Time Scale** and **Period Close** Settings.

11 Click the **Curves** tab.

12 Click **Add** and choose a predefined portfolio curve. The Cash Flow by Commitment - Portfolio Curve window opens.

13 In the **Distribute amount from** field drop-down list, select Original, Shared, or Approved, then click **OK**. The portfolio curve opens in the **Properties** window. For an explanation of these options see **Portfolio Manager curves**.

14 When finished, click **OK**.

**To add a portfolio curve roll-up for cash flow (by Program)**

1 Go to the **Company Workspace** tab and click **Cost Manager > Cash Flow** in the left Navigator.

2 Select **New > Roll-up Curves** from the drop-down. The Properties window opens.

3 Name the cash flow roll-up curve and give it a description.

4 In the **Data Sources** field, check as many items as you want.

5 Enter any settings for Time Scale and click **OK**.

**To view portfolio curves for cash flow**

You can view the curves and data for both original and shared portfolio curves.

1 Open the project or shell and click **Cost Manager > Cash Flow** in the left Navigator.

2 Select a log and click the **Properties** button.

3 In the General tab, check the data source that has the portfolio curve type.

4 Click **OK**. The Properties window opens and the selected worksheet opens with an incremental and cumulative graph of the curve(s). The related data appears in the detail window in month and year format.

**Add A Custom Curve**

You can create a custom curve when you want to create and compare curves in a cash flow worksheet, but do not want to associate them with data sources of the other curve types (baseline, forecast or spends). Custom curve setup is essentially the same as setting up baseline curves.

**To add a custom curve for cash flow by project/shell**

1 Open the Properties window of the cash flow detail curve. Be sure the Detail Level is Project/Shell.

2 Click the **Curves** tab.
3 Click **Add** and choose a data source that of type Custom. The Cash Flow by Project/Shell - Custom window opens.

<table>
<thead>
<tr>
<th><strong>In this Field:</strong></th>
<th><strong>Do This:</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field is filled in automatically with the name of the data source.</td>
</tr>
<tr>
<td>Type</td>
<td>This field displays the curve type: Custom.</td>
</tr>
</tbody>
</table>
| Distribution      | Distribution drives how the amount value will be distributed over the time periods. Choose one:  
  • **Manual.** You enter values into fields in the Details window, for example, From/To dates and values for the duration of the curve.  
  • **Auto by default profile.** Allows you to choose one of the available Distribution Profiles defined in Standards & Libraries > Cash Flow > Distribution Profiles, or that were defined directly in the project or shell cash flow log (Edit > Distribution Profiles). This selection will be used as the default profile; however, at runtime, you can change which profile to use. Click the Select button. The Distribution Profiles window opens. Select a profile to use as the default profile for the curve.  
  **Note:** The default profile is used for the initial display and calculations in the cash flow worksheet. You can change the distribution profile from the worksheet. If you do this, the default profile will automatically update to reflect the current selection. |
| Cost              | Choose one:  
  • Manually enter amounts for each period (available if you chose Manual above). You can enter cost information in the Total field on the worksheet.  
  • Auto distribute total amount across all periods (available if you chose Auto by default profile above). This will automatically distribute the amount in the Total field using the selected default profile.  
  • Distribute amount from cost sheet column. This will take the amount in the selected Cost Sheet column, and either allow you to distribute it manually (if you chose Manual distribution), or use the default distribution profile (if you chose Auto by default profile). An example column would be a budget. Cost column can be chosen when creating a curve in a project or shell, but not in templates. |
| Schedule (From Date/To Date) | Determines what dates to start the curve and end the curve. Choose one for each:  
  • Manual. User enters the date directly in the cash flow worksheet.  
  • Data element from schedule sheet. Choose a schedule sheet data element from the list. The date will be populated automatically from the Master schedule sheet when the cash flow curve is refreshed.  
  If the these dates are changed on the Master schedule sheet, then the changes will be reflected on cash flow after the next refresh of the curves. |

**To add a custom curve for cash flow by WBS**

1. Open the Properties window of the cash flow detail curve. Be sure the Detail Level is WBS (for cash flow by individual WBS codes) or Summary WBS (for summary WBS codes).

2. Click the **Curves** tab.

3. Click **Add** and choose a data source that of type Custom. The Cash Flow by Project/Shell - Custom window opens.

4. See the project/shell baseline curve section in [Add a baseline curve](#) for details on completing the window.
To add a custom curve for cash flow by commitment

Custom curves are not available for cash flow by commitment.

Cash Flow Properties Filter Tab

On the Filter tab of the Properties window, you have the option to select one or more WBS codes (or, if the project/shell cost sheet uses a tree structure, Summary WBS codes) to include in the cash flow data. This allows you to limit the cash flow data to a subset of the WBS Codes or Summary WBS Codes that are on the cost sheet.

If you do not select any codes on this tab, then the cash flow curves will default to all WBS codes present on the project/shell cost sheet.

Note: Filtering is not available on company-level curves, or for curves of detail level Commitment. The cost sheet must be defined in the project or shell or project/shell template in order to choose codes.

To filter curve data by WBS or Summary WBS codes

1. Open the cash flow Properties window.
2. Click the Filters tab.
3. Choose one of the Filter options:
   - All WBS codes from cost sheet. This is the default. Cash flow data will reflect all WBS codes. (The Add and Remove buttons at the bottom of the window are disabled.)
   - Select Summary WBS codes. This allows you to select specific summary WBS codes to include in the cash flow data. This option is available if the cost sheet has a tree structure, and the curve Detail Level is Project/Shell or Summary WBS (on the General tab).
   - Select WBS codes. This allows you to select which WBS codes to include in the cash flow data.
4. If you are selecting WBS or Summary WBS codes, then click the Add button. A WBS code picker or Summary WBS code picker opens, depending on which option you chose.
5. Select one or more codes to include, then click the Select button.
6. You can remove codes from the list on the Filter tab by selecting the codes and clicking Remove.
7. When the Properties window is complete, click OK to save and close the window.

Cash Flow Properties Options Tab

On the Options tab of the Properties window you can define the format to use for the numbers displayed on the cash flow worksheet.

- Decimal Places. Choose from 0-8; default is 2.
- Use 1000 Separator (,). E.g., 1,000; default is deselected.
- Negative Number Format. Choose from the list; default is -1234.

Cash Flow Properties Schedule Tab

On the Schedule tab of the cash flow properties window, you have the option to enable automatic refresh of the cash flow curve, and set the refresh schedule.
To enable cash flow refresh

1. Open the cash flow Properties window.
2. Click the Schedule tab.
3. Select the Enable Refresh checkbox.

If you select this checkbox, then you can set up scheduled refresh of the cash flow curve. The cash flow sheet will refresh automatically to reflect the most recent cost data or any changes that may have been made to the distribution profile or other properties. If you do not select this checkbox, the curve can still be manually refreshed at runtime.

4. For Frequency, choose when the refresh will be run.
   - Daily. At the end of every day.
   - Weekly. The refresh will run at the end of the day you select.
   - Monthly. You can choose a specific date in the month (e.g., the 31st), or you can choose a particular day (e.g., first Monday of the month). If you choose the 31st, the system will run the refresh on the last day of the month for those having less than 31 days.
   - Quarterly. Refresh will run on the day into the quarter that you specify. For example, Day 1 of the quarter. (Refers to a standard calendar quarter.)

5. For Range of recurrence, you can define when the refresh schedule will begin and end.
   - Start On. Choose a date to start the refresh schedule.
   - To define when the scheduled refresh ends, select one of the options: No end date: The refresh will run at the scheduled intervals until it is turned off or the project/shell is inactive or view-only. End by: Choose an end date to stop the automatic refresh

6. When the Properties window is complete, click OK to save and close the window.
CASH FLOW PROPERTIES SUMMARY CURVES

A summary cash flow curve displays a sub-set of cash flow data from your project or shell. For example, you can aggregate and view:

- Forecast data across all commitment curves in a project or shell.
- Data from contracts and schedule sheets.
- Baseline, actuals, and forecast information from contracts and commitments.

In summary curves, Primavera Unifier aggregates cost data by cash flow data sources, for example, Baseline, Actuals, Forecast, and Portfolio Manager. Primavera Unifier displays summarized cost data in a cash flow worksheet. The main window charts summary data, and the curves window lists each cost data source. You can open a data source and see the source cash flow curves.

You can quickly create cash flow summary curves in the project/shell Cash Flow log. You can manage summary curves in the Manage Summary Curves window.

There are no additional permissions for summary curves; if you can see a cash flow curve, you can add it to a summary curve. After you save it, anyone with View permission can see your summary curve.

To create a summary curve quickly

1. Open the project or shell where you want to create a summary curve.
3. In the log, select cash flow curves you want to summarize, and click the Summary button. The Cash Flow worksheet opens.
   If you wish to save the summary curve, proceed to the next step, 4.

Note: When you group commitment curves with different transaction currencies, the summary curve will fall back to the project currency. There may be differences between the value shown in the summary curve and the original curve’s details.
4 From within the Summary Curve Worksheet window, click **File > Save Summary Curve**. The Create Summary Curve window opens.

5 Enter a name and click the **OK** button.

**To open a summary curve cash flow window**

1 Open the project or shell where the summary curve exists.

2 Click **Cost Manager > Cash Flow**. The Cash Flow log opens.

3 On the Cash Flow log toolbar, click the **Summary** button drop-down arrow, and select any previously created summary curves listed below Manage Summary Curves.

Clicking a listed summary curve opens the Cash Flow Worksheet for that summary.

In the cash flow worksheet, in the Curves detail window you can open a data source to see its source cash flows. Data in this mode is read-only.

4 Click the **Close Window** button when ready.

**To create a new summary curve using Manage Summary Curves**

1 Open the project or shell where you want to manage a summary curve.

2 Click **Cost Manager > Cash Flow**. The Cash Flow log opens.

3 On the Cash Flow log toolbar, click the **Summary** button drop-down arrow, and select **Manage Summary Curves**.

The Manage Summary Curves window opens. You can create new summary curves, or manage existing summary curves.

4 Click the **New** button. A new line appears in the Name column of the Manage Summary Curves window. If you have no summary curves, click **New** to create line 1.

5 Enter a name for the summary curve. The default status is Active; you can change this by un-checking the box in the **Active** column.

6 Click the **Add** button. The Details Curve log opens. The log displays cash flow curves in the project or shell, both active and inactive.

7 Highlight the curves you want to include in the summary curve and click **Select**. Primavera Unifier lists the selected cash flow curves in the Detail Curves window.

For each curve listed in the Names column you can see the data sources in the Details Curves log.

8 Click **Save** to retain changes to summary curves, and click **Close Window** when finished.

**To manage summary curve content**

1 Open the project or shell where you want to manage summary curve content.

2 Click **Cost Manager > Cash Flow**. The Cash Flow log opens.

3 On the Cash Flow log toolbar, click the **Summary** button drop-down arrow, and select **Manage Summary Curves**.

4 In the **Name** column, select a summary curve. In the Detail Curves log you can see all source detail curves included in the summary. Add or remove data sources for a summary curve as needed.

5 Click **Save** to retain changes to summary curves, and click **Close Window** when finished.
To rename a summary curve

1. Open the project or shell where you want to rename a summary curve.
3. On the Cash Flow log toolbar, click the Summary button drop-down arrow, and select Manage Summary Curves.
4. Double-click the name of the curve to activate editing, and enter the new name.
5. Click the Save button to save changes, and click the Close Window button when ready.

To copy a summary curve

1. Open the project or shell where you want to rename a summary curve.
3. On the Cash Flow log toolbar, click the Summary button drop-down arrow, and select Manage Summary Curves.
4. Select a summary curve from the list and click the Copy button.
5. Enter a name for the copied curve.
6. Click the Save button to save changes, and click the Close Window button when ready.

To delete a summary curve

1. Open the project or shell where you want to delete a summary curve.
3. On the Cash Flow log toolbar, click the Summary button drop-down arrow, and select Manage Summary Curves.
4. Select a summary curve from the list and click the Delete button.
5. Click the Save button to save changes, and click the Close Window button when ready.
CREATE A CASH FLOW CURVE FROM A SCHEDULE SHEET

You can cost-load a schedule sheet by assigning roles and resources to project-related activities. When you associate a WBS code with an activity in the schedule sheet, Primavera Unifier can distribute its cost over a period of time based on activity dates and the calendar. You will be able to view this distributed cost along with other cash flow curves related to the project.

In the baseline curve you can view the cost distribution information by WBS code in a schedule sheet. When defining the cash flow curves, you select the schedule sheet so you can view the curve in the cash flow worksheet.

To set the cash flow curve for a schedule sheet

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens.

2. Click New > Detail Curves. The Properties window opens.

3. Enter your settings into the General tab. Detail Level selections can be Project/Shell, or WBS.

4. In the Curves tab, select the Use data from Schedule Sheet field. When this field is selected, the rest of the options in the Curves tab become disabled.

Note: With this option, you can push a cash flow curve with a schedule sheet name, then match the schedule sheet name under the destination project. If the schedule sheet exists, the cash flow curve will link to that schedule sheet.

5. Click the Select button and choose the schedule sheet. Selecting a schedule sheet is optional. If a schedule sheet is not selected, the distribution will display zeros along the bottom of the cash flow curves’ graph.

6. Click OK. The cash flow worksheet displays the cash flow worksheet with the WBS codes from the Schedule sheet in the details level.

In the detail window, the following information for the cash flow baseline type of curve will be pulled from the schedule sheet:

<table>
<thead>
<tr>
<th>Field</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
<td>WBS Codes taken from the Schedule Sheet</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the WBS code</td>
</tr>
<tr>
<td>From Date</td>
<td>Taken from the “from” date of the activity that the WBS code is assigned to.</td>
</tr>
<tr>
<td>To Date</td>
<td>Taken from the “to” date of the activity that the WBS code is assigned to.</td>
</tr>
<tr>
<td>Profile</td>
<td>This field is blank as the distribution is coming from the schedule sheet.</td>
</tr>
</tbody>
</table>
You can open the details sheet and view the distribution of the costs by individual WBS code. Data in the details sheet is read-only.

It is possible for a user to create another baseline curve by selecting Cost Sheet as the source for cost or create a Forecast, Spends, and Custom curve. In all these cases, the list of WBS codes will be from the cost sheet and will not be filtered by the schedule sheet.

Cash Flow will pull distribution data (Linear, S-Curve, On Start and Finish) from a schedule sheet. See Select the activity budget distribution profile.
CASH FLOW CURVE FROM A TEMPLATE

You can pre-set curve options, except, for example, actual business process records, and cost sheet columns, which are set at run time. There are two types of cash flow templates: **company-level templates**, which are created in Administration Mode, and **project or shell-level templates**, which are created in a project or shell.

When creating new curves from templates, only properties are copied; data and permissions are not copied. In addition, properties such as cost sheet column selections will not be copied, even if they have been chosen in a project or shell template, since you can choose a template from any project or shell template.

**To create a cash flow details curve by copying a template**

1. Open the Cash Flow log.

2. Click the **New** button and choose **From Template**. The **Cash Flow Templates** window opens. The Cash Flow Templates window displays information about the templates such as detail level, rollup status and more. These properties can be edited in the newly created curve. Also, note the Project/Shell Level column. A “Yes” in this column indicates that the template exists within a project or shell template.

3. Choose a template and click **Select**. The **Properties** window opens.

4. Give the detail curve a unique **Name**. Depending on the curve type and the options chosen in the Properties window, you may need to choose a specific business process record or cost sheet column when creating a new curve in a project or shell.

   You can make other changes as necessary to the tabs in the Properties window. If the selected schedule sheet exists under the destination project / shell (match by name), then the curve will be linked to the schedule sheet under the destination project. If the schedule sheet in the template does not exist in the destination project/shell location, then the schedule sheet name on the curve properties will remain empty.

5. Click **OK** to save and close the Properties window. This also opens the Cash Flow Worksheet window.
CREATE A COMMITMENT DETAIL LEVEL CURVE FROM A COMMIT BP RECORD

As long as the Cash Flow module is set up in the project or shell you are working in, and you have permissions to both the module and to the commit business process record, you can create and view a commitment detail level cash flow worksheet directly from the business process record. A Cash Flow button will display on the record if this is available.

A few things to keep in mind:

• You can create a commitment detail level cash flow curve from the record as long as one does not already exist for that record. (There can be only one detail curve per record.)
• You can create the curve manually by filling out the Properties window, or by copying a project/shell level template.
• If you want to use a template, it must be Commitment detail level and must have the business process selected in the Business Process field on the General tab of the cash flow template Properties.
• If a detail curve already exists for the record, clicking the Cash Flow button will open the cash flow worksheet, which is view-only when opened from here.
• If there are changes to the base commit record (such as additional or modified line item amounts), these changes will be reflected on the commitment cash flow curve the next time it is refreshed.
• If the base commit record is terminated after the cash flow curve has been created, the curve will not be deleted. However, the next time the curve is refreshed, any data will be removed.

To create a Commitment detail level curve from a commitment business process

1. Open the base commit business process record. If cash flow is set up and you have permissions set, a Cash Flow button is available.
2. Click the Cash Flow button on the business process toolbar. If a cash flow Commitment detail level curve exists, the cash flow worksheet opens.
3. If the curve does not exist, you will be prompted to create a new curve. The Cash Flow by Commitment window opens. Choose one of the options:
   • Manual. This allows you to create a new curve manually.
   • From Template. This allows you to copy from a template. Click the Select button. The Templates log opens. Select a template to copy then click Select.
5. Complete the Properties window and click OK. The cash flow worksheet will open to display the data. The curve will be saved in the Cash Flow log.

Note: Once a commitment detail level curve is created, you can toggle between Project and Transaction Currency.
COPY CASH FLOW CURVES AND CURVE DATA

You can select a curve from the worksheet window and copy curve data (time and amount) to another curve with manual entry as distribution. Process data (time, amount and distribution) associated with WBS Codes (from schedule sheet) will be copied over to the destination curve.

You cannot copy data to a curve that pulls data from a business process record, cost sheet or schedule sheet. You can, however, copy data from an auto-distribution curve.

- For example, Spends curves pull actual spends transaction data from a cost sheet column (usually, cost sheet columns that show spends business process transactions). If you want to work with this data manually, you can create a custom curve in the Properties, be sure that all data entry is manual, then copy the spends curve data to the manual custom curve.
- For another example, you can make a copy of the original Baseline curve, make adjustments, and save the revised version.

When you copy data, any existing data in the destination curve will be overwritten with the data from the source curve.

To create a cash flow curve by copying another curve

1. Open the Cash Flow log.
2. Select a curve from the log and click Copy. The Properties window opens.
3. Enter a unique Name for the new curve. You can make other changes as necessary to the tabs in the Properties window.
4. Click OK to save and close the Properties window. This also opens the Cash Flow Worksheet window.

You can copy the data from one curve to another. The destination curve must be a manual curve -- that is, the distribution and From/To dates must be manual data entry. You cannot copy data to a curve that pulls data from a business process record, cost sheet or schedule sheet. You can, however, copy data from an auto-distribution curve.

For example, Spends curves pull actual spends transaction data from a cost sheet column (usually, cost sheet columns that show spends business process transactions). If you want to work with this data manually, you can create a custom curve in the Properties, be sure that all data entry is manual, then copy the spends curve data to the manual custom curve.

For another example, you can make a copy of the original Baseline curve, make adjustments, and save the revised version.

When you copy data, any existing data in the destination curve will be overwritten with the data from the source curve.

To copy a worksheet row

1. In the Cash Flow Worksheet, select a row to copy. This is the source curve.
2. Click the Copy button. The Copy To window opens.
3. Click the Destination Curve drop down menu. The drop down menu lists all manual entry curves.
4. Select a curve from the list and click OK.
5 At the confirmation window, click Yes.

6 The Details window opens. All values in the destination curve will be overwritten by the values from the source curve. The new values are displayed in the Details window.

7 You can make necessary changes to values in the Details window. To save the Details window with the new values, click Save.

Note: Special note for Forecast curves: If the intended destination curve is a Forecast curve and the forecast is set up to start at the end of Spends record, this forecast curve is only available as a destination curve as long as no spends records have yet been received. If spends data has already hit the forecast curve, then the forecast curve will not be available in the Destination Curve dropdown list.
CASH FLOW WORKSHEETS

Primavera Unifier collects data from various managers, including cost, portfolio, resource and schedule, and displays it in cash flow curves. Curve options, for example, data sources, and distribution selections, determine the appearance of a curve in a cash flow worksheet. The worksheet window displays a graph on the top portion of the window, and a list of curves in this file on the bottom portion. Each curve listed has its own data set, which you can view in the Details window. Depending on the curve set up, the Details window is where you manage the curve data.

To open a cash flow worksheet

2. Select a curve from the log and click Open, or double-click the curve. The Cash Flow Worksheet window opens.

To set curves for viewing in the cash flow worksheet

2. Select a log and click the Properties button.
3. On the General tab, check the data source(s) that has the curve types you want to view.
4. Click OK. The Properties window opens and the selected worksheet opens with a graphic of the curve(s).

Graph

The worksheet is divided into two parts: a graph view on top, and a table view below. Each part can be individually maximized.

There can be multiple curves displayed on the graph. You can add as many curves as you need to the worksheet. Each curve must be associated with a data source, which are created in Administration Mode. The curves are color coded; the color is determined in the data source.

In the graph, you have the option to filter out some curves and display a subset of the available curves; change the zoom level between monthly and yearly; or print the graph. You can switch between incremental view or a cumulative view.

Split screen

Just as you would with a spreadsheet, you can use the split screen view to make your information much easier to read. In the Detail window, you can see two parts of a row by splitting the view so that you can see the beginning part of a row and the middle or end of the same row.

To get the split screen, click on the Split button and the bottom of the Detail window displays two columns. The same row is highlighted across both columns. You can drag the vertical column separator to suit, and use the horizontal scroll bars to view different parts of the row.

Zoom level

You can switch the display of the curve and worksheet data between a monthly view or yearly view by changing the zoom level. This will not affect the time scale itself, just the data and curve display. The Year zoom level is only applicable if you have data that spans over multiple years.

- The Zoom buttons are in the top right portion of the Cash Flow Worksheet.
• Month (M): This changes the time line focus of the curve and table to show months and year in the cash flow time period.
• Year (Y): The displays time period increments in years, and is useful for multi-year projects or contracts.

Changing the zoom setting will adjust the zoom for both the graph and the table.

**Curve columns**

The table underneath the graph shows the data for the curves. Each row corresponds to one of the curves on the graph, and displays the curve data in columns. The view is incremental; you can click the drop-down on the right to change the view to cumulative, which is view-only. The columns are:

**Color:** The color of the graph displays in the first column

**Name:** This is the name of curve, taken from the Data Source

**From Date:** The starting point of the curve. This can be entered manually or taken from a date field on the project/shell master schedule sheet, as defined in the curve properties.

**To Date:** The ending point of the curve, also manually entered or pulled from the schedule sheet.

**Total:** This amount is the cost portion of the curve. It can be pulled from a specified cost sheet column or business process. This total amount will then be distributed over the time period (From Date to To Date) to generate the cash flow curve. This is defined in the curve properties.

**Unassigned:** Any amount left over from the Total amount that has not yet been distributed.

**Time Period Columns:** These are the incremental time periods for the duration of the cash flow time period. That is, the From Date to the To Date, entered above. For monthly distribution, these will display each month and year from the From Date to the To Date. If shown Yearly, then each period is one year.

**Curve data distribution**

The data in these columns show the distribution of cost -- the value in the Total field. If you are doing auto distribution using a distribution profile, these values will be calculated based on the distribution percentages. If you are doing manual distribution, you will enter values into each time period (distributing the amount in the Total column). The Unassigned column will display how much of the Total column is left to be distributed. Primavera Unifier displays cost data using the latest exchange rate table.

**Commitment curves’ transaction and project currency views**

Primavera Unifier displays commitment costs in both the graph and the curve portions of the worksheet window. Use the currency drop down menu to switch between the transaction and project currency, if they are different (otherwise, you will not see this menu). For more information, see [Transaction Currency](#).

**Curve replication**

You can select a curve from main window and copy the data (time and amount) to another curve, with manual entry as distribution. Additionally, process data (time, amount and distribution) associated with WBS Codes (from schedule sheet) will be copied over to destination curve. See Copy Cash flow curves and curve data.

**To view details for the curves**

Select a row from the table and click **Open** (or double-click the row). The Details window opens.
• For cash flow by WBS or Summary WBS, all WBS or Summary WBS codes will display. If selected WBS or Summary WBS codes have been chosen in the Filter tab of the Properties window, then those codes display.

**Note:** For cash flow by WBS in a baseline curve, the list of WBS codes displayed in the details window are from the schedule sheet and are read-only.

• For cash flow by commitment, all associated records (the base commit, any change orders, etc.) display.
• If the curve has been designed for manual entry rather than in auto-mode, you can enter values in the Details window.
TRANSACTION CURRENCY IN CASH FLOW CURVES

General Currency Information

During company creation, the administrator set a base currency that became the default project currency for each project or shell. When you create a project or shell you can change the default project currency to any currency listed in the company-level exchange rate table. After creation you can add additional currencies to the project or shell as needed.

Depending upon the commitment business process design, during record creation you can select a transaction currency from the list of available currencies in the project or shell. Primavera Unifier stores costs in the project currency and uses the active company-level exchange rate table for currency conversion.

Transaction Currency In Curves

In Project, WBS, and Summary-level cash flow curves, Primavera Unifier displays cash flow costs in the project currency. By default, Primavera Unifier displays commitment curve cost data in the record transaction currency, which is stored in project currency using the active currency exchange rate table. If the transaction currency is different from the project currency, you can change the currency view between transaction and project currencies, but you can only edit data in the transaction currency. If there is a more recent value in the exchange rate table, refreshing the curve will refresh the cost data.

To switch between transaction and project currency in the cash flow worksheet

1. Open the project or shell, or go to the Company Workspace tab and click Cost Manager > Cash Flow in the left Navigator.
2. Select a cash flow worksheet from the log.
3. Open the cash flow worksheet. By default the worksheet opens in the transaction currency if different from project currency.
4. Use the drop-down currency menu located at the top-center of the worksheet to change currency views.
   If the transaction currency and the project currency are the same, you will not see the drop-down field.
   The numbers and curve refresh to display the new currency values.
5. In the cash flow window curves list, located on the bottom portion of the window, select a curve and open the curve details window.
   If you selected the project currency view before opening the curve details window, and the curve is in transaction currency, the data will be read only.
6. In the Details window use the currency menu to switch to the transaction currency. Depending upon the curve set up, you can manually enter data or change the automatically distribution profile.
7. When finished, click Save. The cash flow window will refresh with changes.

Cash Flow Details Window

When you open a cash flow worksheet, the data is view-only in both the chart and the curves list. You can double-click a curve to open the Details window for that curve, which is where you enter or edit cost
data. If the details window is open and you click on another curve in the worksheet, the details window will refresh with the data of the new curve. Below are considerations for Baseline, Spends, and WBS curves.

Baseline curves:

- In commitment-based curves, Primavera Unifier shows cash flow in the transaction currency of record creation. Primavera Unifier stores the data in project currency. If the project currency is different from the transaction currency, both the main and detail windows contain a currency drop-down menu, which you can use to show costs in the project currency; however, you can only edit data in the transaction currency mode. Currency conversion is based on the active company-level Exchange Rates table. Bulk edit is unavailable if the detail window is in project currency mode.

- In commitment-based curves the detail window shows columns from the business process: e.g., Number, Name, Line No, WBS Code, Description (Short Description)

Spends curves: these curves display actual spent amounts per time period, and are not editable or distributed.

WBS curves: WBS codes in the worksheet appear in the order as listed in the cost sheet. The following procedure describes how to enter data on worksheet fields that have been set up to be editable. Data can be entered by manual entry or by importing.

**To manually enter or edit cash flow data on a worksheet**

1. Open the project or shell and click **Cost Manager > Cash Flow** in the left Navigator.
2. Select a curve from the log and click **Open**, or double-click the curve.
3. Select the curve to edit from the list of curves in the lower portion of the worksheet. Double-click the row to open the **Details** window.

Depending on curve options, the curve can be set up for manual or auto-distribution. Worksheet selections may vary according to distribution methods.

4. In the **Details** window you can:
   - Click the **From Date** and/or **To Date** to select different start and end dates for the cash flow curve.
**Note:** Primavera Unifier pegs cost data distribution to the From Date. If there are date changes, Primavera Unifier shifts the curve on the timeline based on From Date modifications. Each time period (e.g. month or year) on the curve retains the value of the original distribution. If date changes make the cash flow curve longer or shorter, Primavera Unifier will not rebalance or redistribute cost data to match the modified curve length.

- Click the **Total** field and enter the cost value for which you want to generate the cash flow curve.
- Track undistributed cost in the read-only **Unassigned** field.
- Change the distribution **Profile** if the curve was set up with auto-distribution. Click the profile field. The Select Distribution Profile window opens. Select a new profile and click Select.
- **Distribution columns:** enter values in each of the time periods, to equal the amount in the **Total** field. The Unassigned column will show you how much of the Total you have left to distribute.

5 Click **Save** to save and close the **Details** window.
IMPORT CASH FLOW DATA

You can import cash flow data via CSV file. This includes curve setup data (From and To dates, Profile and Total columns), and curve distribution data (distribution values of the Total amount entered in the date period columns). It is important to observe the order of curve operations: import the setup values first, then import the distribution values.

- Manual entry generally allows data import, but depends upon the curve set up.
- Auto-distribution precludes data import.
- Fields that display data from other sources (schedule sheet, cost column, business process record), cannot be edited via CSV import.

You can change curve distribution settings; however, Primavera Unifier will replace your data with data collected by the new distribution method. For example, if you change a manual entry field to auto, all manually entered data will be lost and replaced with the auto-generated data.

To import curve setup data into the Cash Flow Worksheet by CSV import

1. Open the Cash Flow Worksheet. Select a row and click Open to open the Details window.
   If you are importing both setup and distribution data, then import the setup data first to establish the distribution time period.

2. Click Export to export the CSV template. The CSV opens in Microsoft Excel®. You can Save the CSV file to your desktop first, or Open it directly.

Note: Cash flow data exports the currency and the values to the CSV template.

3. Add the Curve Distribution data to the CSV file.
   - From Date, To Date: use the date format.
   - Profile: If using auto-profile, enter the name of the default profile you want to use. This is from the Distribution Profiles list maintained in Administration Mode.
   - Total: Enter a value to use as the cost total.
   - Save the CSV file.

4. Import the CSV file.
   - In the Details sheet, click Import > Curve Setup. The File Upload window opens.
   - Locate the CSV file and click OK. The data will populate edited fields on the Details sheet.

5. Save the Details window.

To import curve distribution data into the Cash Flow Worksheet by CSV import

1. Open the Cash Flow Worksheet. Select a row and click Open to open the Details window.
   If you are importing both setup and distribution data, then import the setup data first to establish the distribution time period.

2. Click Export to export the CSV template. You can Save the CSV file to your desktop first, or Open it directly.

3. Add the Curve Distribution data to the CSV file.
• Enter values in the time period distribution fields. Do not exceed the amount for Unassigned.
• The Currency field must have the currency listed.
• Save the CSV file.

4 Import the CSV file.
• In the Details sheet, click Import > Curve Distribution. The File Upload window opens.
• Locate the CSV file and click OK. The data will populate edited fields on the Details sheet.

5 Save the Details window.

Note: You can import data into cash flow by commitment curves in either transaction or project currencies. If you try to import data in an incorrect currency, you will be notified. For example, if the transaction currency is in Yen and the project currency is in USD, and you try to import in Euro, you will get an error message in the CSV file. You will need to correct the errors in the CSV before re-importing.
USE BULK EDIT TO EDIT CASH FLOW DATA FOR MULTIPLE ROWS ON THE DETAILS WINDOW

Bulk Edit is available on the Details window for the Cash Flow Worksheet. This is useful when there are multiple items to be edited that are associated with the curve data.

For example, if you are doing cash flow by WBS, the data in the Details window displays the WBS codes in use. You can enter curve data for one or multiple WBS codes using Bulk Edit.

If you are doing cash flow by commitment, and are including change orders in the curves (for cost information and auto distribution), then you will see all commitment records in the Details window -- the base commit and any change commits. You can enter curve data for one or multiple records using Bulk Edit.

**Note:** If you are editing a Contract-type BP, the total in the Bulk Edit will be highlighted in the details screen of the cash flow by contract curve.

**To enter cash flow data using Bulk Edit**

1. Open the Cash Flow Worksheet. Select a row and click Open. The Details window opens.
2. Select one or more rows and click Bulk Edit. The Bulk Edit window opens.
3. The fields that are editable for the curve (based on the Properties window options) will display.
4. Enter values for the fields.
5. Select the Update checkbox for the fields you want to update.

**Note:** You can use the Bulk Edit button to edit multiple items in the chosen currency. The total in the Bulk edit window will be interpreted in the currency selected in the details screen (lower part of the worksheet window.)

6. Click the Update button.

**Filter The Curves To Display On The Cash Flow Worksheet**

You may need to maintain a large number of curves on a worksheet for various reasons, but at times, you may want to only display some of them. You can select which curves to show and hide on the worksheet graph. Note that this level of filtering will not be saved; by default, every time you open a worksheet, all graphs will display by default.

**To show or hide curves on the cash flow worksheet**

1. Open the Cash Flow Worksheet.
2. Click the Filter button in the upper right portion of the window. The Filter Graph window opens.
3. Select which curves to display. Deselect any curves you don’t want to display.
4. To select or deselect all curves, click the checkbox at the top. This will toggle between selecting and deselecting all the curve checkboxes.
5 Click OK.

The graph will display only the curves that are selected. The data at the bottom of the worksheet will be unaffected. This display remains active as long as the window is open. The next time you open the worksheet window, all curves will again display by default.
CREATE AND MANAGE DISTRIBUTION PROFILES

Administrators can create a library of distribution profiles in Administration Mode, Standards & Libraries. In addition to these profiles, you may also want to create additional distribution profiles in a project or shell. At runtime, when you select a distribution profile, you will see the list of profiles created in Administration Mode, as well as the ones created in User Mode.

To add a distribution profile in User Mode

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens.

2. Click the Edit menu and choose Distribution Profiles. The Edit Distribution Profiles window opens.

3. Edit and manage distribution profiles in this window in the same way as the default distribution profiles created in Administration Mode.
VIEW AND MANAGE CASH FLOW PROPERTIES

You can view or edit the curve properties from the Cash Flow log. You can open a view-only Properties window from the cash flow worksheet.

**To edit cash flow curve properties**

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens.
2. Select a curve from the log and click Properties. The Properties window opens. See Cash flow general tab and Cash flow curves tab.
3. When the Properties window is complete, click OK to save and close the window. When you save and exit the Properties window, the Cash Flow Worksheet opens for the curve you just edited.

**To view cash flow curve properties from the worksheet window**

1. Open the cash flow worksheet
   - Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. Select a curve from the log and click Open, or double-click the curve.
   - In a base commit record, click the Cash Flow button. If a detail curve exists for the record, the cash flow worksheet opens in a view-only mode.
2. Click the View menu and choose Properties. The Properties window opens, but is not editable in this view.

---

**Some notes on editing cash flow properties.** If you edit the time scale, the period close settings will be reset, and you will need to enter new ones for the new time scale. For curves in auto mode, you can switch to manual mode and adjust the data. If you switch back to auto mode, the default profile will be used, and manual data will be overwritten.
ACTIVATE OR DEACTIVATE ROLLUP STATUS

You can change the rollup status of one or more curves. Active curves roll data up to program and company cash flow sheets; this status also affects scheduled refresh.

To activate or deactivate the rollup status

1. Open the project or shell that uses the curve you want to change.
2. In the left Navigate, click Cost Manager > Cash Flow. The Cash Flow log opens.
3. Select a curve from the log.
4. Click the Rollup Status button and select Active or Inactive.
ADD CURVES TO THE DETAIL CURVE CASH FLOW WORKSHEET

You can add as many curves as you need to the cash flow worksheet. Each curve is associated with a cash flow data source so that curve data can be rolled up and is reportable. Each data source can be used once per worksheet. (Data sources are created in Administration Mode in Standards & Libraries). Be sure that you have created enough data sources to add the curves you need to the worksheet.

When creating the curves, you can choose to make them editable so data can be entered and adjusted manually, or automated so that data is pulled from other sources, such as the project schedule sheet, cost sheet columns, and cost business process records. Distribution of cost data over time can also be done manually, or can be automatically distributed by creating and applying distribution profiles.

Curves are added to the cash flow detail curve Properties window.

To add curves to the cash flow detail worksheet

1 From the project/shell cash flow log or cash flow template log, select the detail curve in the log and click the Properties button. The Properties window opens.

2 Modify the Properties window and add curves in the Curves tab as needed. See Cash flow general tab and Cash flow curves tab.

3 Click OK when done. The cash flow worksheet opens and displays the added curve.
DELETE CASH FLOW CURVES

You can delete a cash flow curve. If a detail curve is deleted, Program and Company level roll up curves will ignore the data from the detail curve the next time they are refreshed.

You can also delete an individual curve from the detail curve family.

To delete a cash flow detail curve

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens.
2. Select a curve from the log.
3. Click the Edit menu and choose Delete.
4. At the confirmation window, click Yes.

To delete a baseline, spends, forecast, portfolio, or custom curve from a detail curve

1. Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens.
2. Open the Cash Flow Worksheet.
3. Select a row from the table.
4. Click the Edit menu and choose Delete.
5. Click Yes at the confirmation window.
The summary view can be used to automatically summarize all of the active curves in the cash flow log. Summary is done at the data source level - that is, it summarizes the data for each data source used in at least one curve.

If the active curves use different time scales (some use monthly and some yearly), then the Summary view will display the highest time scale, which would be yearly.

**To summarize cash flow data**

1. Open the project or shell and click **Cost Manager > Cash Flow** in the left Navigator. The Cash Flow log opens.
2. Click the **Summary** button. The Cash Flow Worksheet window opens. The curves that are included in the cash flow curve are shown in a summary view on the graph, by data source.
PRINTING CASH FLOW CURVES

You can print a copy of a cash flow worksheet. The print output will essentially be what you see on the screen, both the graphical display and the data.

To print a cash flow worksheet

1. In the top right portion of the Cash Flow Worksheet, click the Print button.
2. Follow the prompts and settings for your printer.

Note: For improved print output, you can try a few things, such as: adjust the curve zoom level; print the worksheet in Landscape mode (choose this in your printer settings); adjust the worksheet window size (for example, drag the side or bottom of the window to expand the height or width to see more rows or columns); you can also maximize the window (click the Maximize button in the upper right corner of the window).
REFRESH CASH FLOW CURVES

You can enable or disable auto-refresh, and set the frequency. This setup is done in the Schedule tab on the Properties window of the detail curve during setup, or set at runtime. You can also manually refresh a curve at any time.

You can see the refresh history of a curve at any time by clicking Refresh>History. This shows not only each manual or automatic refresh performed on the curve, but will also display any errors that were found during a refresh.

What refresh does

- Checks to see if there are any new spends records that are not part of the curve. Depending on Period Close settings, the spends record is added to the correct period, and therefore, changes in values will appear for Spends curves and for Forecast curves that consider spends records.
- Checks to see if a distribution profile definition has changed, either in Administration Mode, or in the project/shell. Any changes will be applied to the curve.
- If dates are based on master schedule sheet, checks to see if values have changed in the schedule sheet.
- For a curve in the auto mode, refresh distributes unassigned values automatically.
- Refresh checks for changes to WBS structure.
- Checks for errors, such as not selecting a valid business process record or cost column, or missing data such as a blank schedule sheet date column. The error alert will display in red font on the worksheet (below the curve section). Click the error to view the reason.

Unassigned field

If there is a value in the Unassigned field, hover over or click the field. The reason(s) for the value is displayed. For example,

- Excess or deficit because of Spends (invoice) records
- Incoming Change Orders
- For Forecast curves with option to start at the end of Actuals (Spends amount), the amount is put in the Unassigned field if the To Date of the forecast curve is less than effective date of a Spends value.

To refresh a cash flow curve manually

Do one of the following:

- You can refresh one or more curves from the cash flow log. Open the project or shell and click Cost Manager> Cash Flow in the left Navigator. The Cash Flow log opens. Select one or more curves from the log and click the Refresh button.
- You can also refresh a curve directly from the Cash Flow Worksheet window. Click the Refresh button.

To set the cash flow curve auto-refresh schedule

1 You can access the auto-refresh schedule options in two ways:
   - To edit a single curve, you can select the curve from the cash flow log and click the Properties button. Click the Schedule tab.
• To edit the schedule information for multiple curves from the Cash Flow log, select one or more curves in the log. Click the Refresh button and choose Set Frequency. The Set Frequency window opens.

In either window, you can enable (or disable) automatic refresh of the selected cash flow curve(s), and set the refresh schedule. If you are setting the frequency in multiple curves using Refresh>Set Frequency, these settings will be pushed to the Schedule tab of each curve’s Properties window when the window is saved.

2 Complete the fields.

<table>
<thead>
<tr>
<th>In this Field</th>
<th>Do This:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Refresh</td>
<td>If you select this checkbox, you can then define the refresh schedule. The cash flow sheet will refresh automatically to reflect the most recent cost or schedule data, or any changes that may have been made to the distribution profile or other properties. If you do not select this checkbox, the curve can still be manually refreshed at runtime.</td>
</tr>
</tbody>
</table>
| Frequency | Choose when the refresh will be run.  
  • Daily. At the end of every day.  
  • Weekly. Select the day of the week to run the refresh.  
  • Monthly. Refresh will run on the last day of the month.  
  • Quarterly. Refresh will run on the last day of the calendar quarter. |
| Range of recurrence | You can define when the refresh schedule will begin and end.  
  • Start On. Enter a date to begin the refresh schedule.  
  • To define when the scheduled refresh ends, select either No end date (the refresh will run at the scheduled intervals until it is turned off or as long as the project/shell is active, or select End by and choose an end date to stop the automatic refresh. |

**To view a curve’s refresh history**

1 Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens.

2 Select a cash flow curve from the log, click the Refresh button and choose History. The Refresh History window opens, displaying the refresh events for the selected curve. This window also displays the status of a curve that is currently being refreshed.

**To cancel a curve refresh**

1 Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens.

2 Select the curve being refreshed and click Refresh > History. The Refresh History window opens.

3 If the refresh Status does not yet display Finished, click Cancel Request. If the cancellation is successful, the entry will display the Status as Canceled.
SEARCH FOR CASH FLOW CURVES

You can search the Cash Flow log for a specific curve using the Find feature. Cash Flow uses a floating find window.

To search for a curve in the log

1. Open the project or shell and click **Cost Manager > Cash Flow** in the left Navigator. The Cash Flow log opens.

2. Click the **Find** button. The Find window opens. You can search on any of the fields that appear in the Cash Flow log.
WORKING WITH SNAPSHOTS

You can manually save a snapshot of cash flow curves at any time. You can also automatically take a snapshot of a detail level curve as part of the Period Close settings on the General tab of the Properties window.

A snapshot displays the graph, curves and curve data on the worksheet. You can open the Details window from the snapshot. Snapshots are not editable.

You can take a Snapshot and view it in both project and transaction currencies. The snapshot is reportable, see About user-defined reports.

**To take a snapshot at any time**

1. Open the Cash Flow worksheet.
2. Click File and choose Create Snapshot. The Create Snapshot window opens.
3. Enter a Snapshot Title and click OK.

**To schedule automatic snapshots**

You can schedule automatic snapshots as part of the Period Close settings on the General tab of the Detail Curve Properties window.

1. Click the option Enable auto snapshot on.
2. Click the Select button. The Details window opens.
3. Choose when you want Primavera Unifier to take the snapshot.
4. Click OK.

After taking an auto-snapshot Primavera Unifier refreshes the curve immediately. Spends will resume after the auto-snapshot.

**To view a snapshot**

1. Open the Cash Flow worksheet.
2. Click View and choose Snapshot Log. The Snapshots opens.
3. Choose a snapshot to view and click Open. The Cash Flow Worksheet opens. You can view the Details window, cumulative view, and most other interactive elements, but the snapshot data is not editable.

**To search for a snapshot**

1. Open the Cash Flow worksheet.
2. Click View and choose Snapshot Log. The Snapshots opens.
3. Click Find.
4. Enter search criteria and click Search.
5. To restore the entire list, click Cancel Filter.
To delete a snapshot

1. Open the Cash Flow worksheet.
2. Click View and choose Snapshot Log. The Snapshots opens.
3. Select the snapshot and click Delete. At the confirmation, click Yes. The snapshot is deleted.
Creating and managing roll-up curves in a Program and in the Company Workspace is similar to creating detail curves in projects and shells. Program roll-up curves can be created from a template. Runtime permission must be granted to each curve for other users to have access to it.

Data rolls up to the program and company level based on the data sources used to add the individual baseline, spends, forecast, portfolio, and custom curves that make up the project/shell detail curves. Projects and shells included in a program can use different currencies.

Primavera Unifier converts all project and shell currencies to the company’s base currency and presents the rolled-up data in the base currency. You can create a snapshot of this data, see Working with snapshots. You can create reports from this data, see About user-defined reports.

Only project and shell-level cash flow curves with Roll-up Status equal to Active will roll up to program and company level cash flow.

To create a Roll-up Curve in a Program

1. Go to the Programs tab, switch to User mode, and click Programs. The Programs log opens.

2. Open a program from the Programs log.

3. Click Cost Manager>Cash Flow in the left Navigator. The Cash Flow log opens. (If you can’t see the Cash Flow module, be sure your company administrator has granted permissions to the module.)

4. Click New; you have two options.

   Roll Up Curves: You can use this option to create a new curve. Complete the General tab and select the data sources you want to include from this project. Then click OK.

   From Template: Select a cash flow template from the list and click OK.

   Note: To use a template for the roll up curve, there must already be a cash flow curve roll up template created in Standards & Libraries.

To create a Roll-up Curve in the Company Workspace

1. Go to the Company Workspace tab switch and to User mode.

2. Click Cost Manager>Cash Flow in the left Navigator. The Cash Flow log opens. (If you can’t see the Cash Flow module, be sure your company administrator has granted permissions to the module.)


To view details of a roll-up curve


2. Select the curve to view and click Open. The Cash Flow Worksheet opens.

3. Select a row (curve) from the list and click Open. The Details window opens. The Details window lists the project/shell curves that comprise the roll up curve.
What else you can do with a roll-up curve

Like detail-level curves in projects and shells, the roll up curves can be printed, snapshots taken, zoom levels adjusted, data sources filtered from the view, and curves permission-controlled — you can do just about everything except work with the data itself, since the data on the roll up curve is generated in the projects and shells, and rolled up to the program and company level. The procedures for working with roll up curves are similar to project/shell detail curves. See the following topics:

See “Granting Cash Flow User Mode Permissions” on page 451
See “Filter the curves to display on the cash flow worksheet” on page 488
See "Printing Cash Flow Curves” on page 496See "Refresh cash flow curves” on page 497

Refreshing cash flow curves
See “Working with snapshots” on page 500

About Cash Flow (Basic)

Basic cash flow functionality enables you to baseline projected spends, track actual costs, calculate future spends based on a known forecast (extrapolate), or calculate from trends compared to baseline curves (interpolate).

About Cash Flow Sheets In Cash Flow (Basic)

A cash flow sheet is used to calculate and maintain detailed cash flow information. You can generate table data showing incremental and cumulative values, and graphs displaying multiple cash flow curves. Cash flow sheets and curves can be created at the project or shell, program, and company level.

You can save generated cash flow curves and refresh them to include newer data. You can refresh cash flow curves manually or schedule automatic refresh. Cash flow curves are also refreshed automatically when certain properties of the curve are modified.

Cash flow data sources are available to store curve data. These data sources can be used to roll up project or shell data to the program and company levels to view cash flow data across multiple project or shells.

Other cash flow features include:

- You can generate table data showing incremental and cumulative values, and graphs displaying multiple cash flow curves.
- There can be multiple cash flow sheets.
- You can set up the cash flow curve by project or shell or by WBS code.
- The data displays in project or shell currency.
- The cash flow sheet provides the function to export data to Excel, and save it to a local file system in CSV format.
- Interpolate data: Interpolation is estimating the cash flow curve based on known start and end values. There is not an equivalent option to interpolate as there is for extrapolate based on data set, but it is possible to interpolate data by specifying end point cost data. For interpolation, the curve will be based on a specified end point. The base curve and interpolated curve will merge together if the end values are the same.
- Extrapolate data: You have the option under curve properties to extrapolate the actual cost based on a provided data set. For example, you can estimate, or extrapolate, the cash flow curve for this year based on last year’s data. For this option, you need to specify a data set, meaning data from an existing cash flow sheet from which the extrapolation is based. You can show interpolation and extrapolation by selecting S Curve as a curve properties option, along with selecting the option for
“Begin calculation at end of [select existing Cash Flow curve].” For interpolation and extrapolation, the curve is generated from the last point of actual data. For WBS mode, the extrapolated or interpolated data is calculated based on the end point obtained from the curve used for “Begin calculation at end of” and then all of the curve points are summed together to display one curve from the period where the first value appears.

**Types Of Cash Flow Curves In Cash Flow (Basic)**

There are three types of cash flow curves that can be defined at the project or shell level:

**Calculation:** This option generates the curve based on sigma and mu values. You can also create a curve that is a blend of manual and calculation type by creating a calculation curve with the option of entering values manually. This allows you to plot graphs based on manually entered forecast information, but starting at the end of actual values. (Select the **Manual entry intermediate points** option on the Options tab.) This option also allows you to force manually entered numbers to the foot to column in the cost sheet.

**Data from Cost Sheet column:** This option generates curves based on cost sheet column data. If you select this option, the Select drop-down menu is enabled. Click **Select** and choose one of the cost sheet columns listed. The selection list will include columns whose data sources are business processes or formula columns based on BPs (for example, total spends or total commits). Manual entry cost sheet columns are not listed.

**Manual Entry:** This option generates the curve based on data that you have manually entered in the cash flow sheet at the project or shell level or WBS level. If you choose this option, click the **Details** button to input start and end dates for the curve.

---

**Note:** Cash flow curves can be rolled up to the program and company level.

**Creating Cash Flow Sheets**

The first time that you create a project or shell cash flow sheet, you will be prompted to define the timescale to use, which will be used for subsequent cash flow sheets for the projects or shells.

**Access Project Or Shell Cash Flow Sheets In Cash Flow (Basic)**

The first time that you create a project or shell cash flow sheet, you will be prompted to define the timescale to use, which will be used for subsequent cash flow sheets for the projects or shells.

**To access project or shell cash flow sheets**

1. Open the project or shell where the sheets reside and click **Cost Manager** in the left Navigator.

2. In the Navigator, click **Cash Flow (Basic)**. The Cash Flow log opens, displaying the following fields:

   - **Name:** Name of the curve.
   - **Creator:** User who created the curve.
   - **Date Created:** Date the curve was created.
   - **Detail Level:** By WBS or by project or shell.
   - **Cost Source:** Data source used to generate the curve.
   - **Start Date:** Start date of the curve.
• **Finish Date**: Finish date of the curve.
• **Last Update**: The last time the curve data was refreshed.
• **Scheduled**: This column will show scheduled frequency information of a cash flow curve.

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Creates a new cash flow sheet. The first time you click New, you will be prompted to select a timescale for all subsequent cash flow sheets.</td>
</tr>
<tr>
<td>Open</td>
<td>Opens the selected cash flow sheet. Equivalent to double-clicking on a cash flow sheet from the log.</td>
</tr>
<tr>
<td>Properties</td>
<td>This displays the Properties window of the selected cash flow sheet.</td>
</tr>
<tr>
<td>Table</td>
<td>Clicking on this button displays the table view of all the selected cash flow data. The Export option is available from this table view.</td>
</tr>
<tr>
<td>Graph</td>
<td>Displays a graphical view of all cash flow sheets.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected cash flow sheet from the log.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Click to refresh and update the selected cash flow curve.</td>
</tr>
</tbody>
</table>

**Define The Cash Flow Timescale In Cash Flow (Basic)**

The Time Scale window determines the data representation by year, month, or quarter for all cash flow curves under a project or shell. This must be defined before creating any cash flow sheets.

The first time that you create a project or shell cash flow sheet, you will be prompted to define the timescale to use, which will be used for subsequent cash flow sheets for the project or shells.

**To define the timescale**

When you create a new cash flow sheet, you will be prompted to set the timescale. See the following procedure for details about creating a cash flow sheet.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>By</td>
<td>Choose the timescale to use for all cash flow sheets for the project or shell.</td>
</tr>
<tr>
<td>Format</td>
<td>Choose a format option, which determines how the date is displayed on the curves.</td>
</tr>
</tbody>
</table>

**To edit the timescale**

After creating a cash flow sheet, you cannot edit the timescale. This can be set only when there are no cash flow curves under a project or shell. You can change the timescale if you delete all listed cash flow sheets from the log, and then create a new curve.

**Create A Project Or Shell Cash Flow Sheet In Cash Flow (Basic)**

This is the general procedure for creating a cash flow sheet.
To create a project or shell cash flow sheet

1. From the Cash Flow (Basic) log, click **New**. Do one of the following:
   - If the log is empty, the Cash Flow Time Scale window opens. Complete the Cash Flow Time Scale window, and then click **OK**. The Properties window opens.
   - If at least one cash flow sheet already exists in the log, the Properties window opens.

2. Complete the Properties window, as described in the following table.
   - If you choose the **Calculation** curve type, complete the Options tab.
   - If you choose the **Data from Cost Sheet column** or **Manual Entry** curve type, the Options tab is not applicable.

3. Click **OK**.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a cash flow name.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a cash flow description.</td>
</tr>
<tr>
<td>Detail Level</td>
<td>Choose one of the following: <strong>By Project</strong>, <strong>By Shell</strong>, or <strong>By WBS</strong>.</td>
</tr>
</tbody>
</table>
| Curve Type    | Choose one of the following:
   - **Calculation**: This option generates the curve based on the calculation parameter. If you choose this option, then the Options tab is enabled.
   - **Data from Cost Sheet column**: This option is used for generating the actual curve based on the transaction data. If you select this option, the Select drop-down menu is enabled. Click **Select** and choose one of the cost sheet columns listed. Columns on the cost sheet with manual data entry are not part of the selection list.
   - **Manual Entry**: This option is used for generating a curve based on data that you have manually entered in the cash flow sheet. If you choose this option, click the **Details** button to input start and end dates for the curve. |
| Time Scale    | Displays the options selected in the Cash Flow Time Scale window. |
| Data Source   | Allows you to choose a data source to store curve data to roll up to a program or company cash flow curve. Choose from Cash Flow 1 through Cash Flow 25. You can use this data source to roll up data to the program and company level to view cash flow data across multiple project or shells. |

**Define Curve Properties For Calculations In Cash Flow (Basic) (Options Tab)**

The Options tab is available if the curve type is defined as Calculation in the General tab.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Curve Properties</td>
<td>Select the curve properties.</td>
</tr>
</tbody>
</table>
| S-Curve       | Specify the S curve properties:
   - **Curve Shape (sigma)**: Valid values are from 1 to 5. The higher the value, the flatter the curve. A lower value results in a bell-shape curve.
   - **Center Location (mu)**: Enter a percentage value. Valid values are from 0 to 100%. |
<p>| Linear        | Creates a linear curve. |
| Extrapolate based | Select from the drop-down list of existing cash flow curves. |</p>
<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>on curve</td>
<td></td>
</tr>
<tr>
<td>Manual entry</td>
<td>Similar to S-Curve and Linear, this option allows blending of manual and calculation curves by allowing the entry of manual values to a calculation curve. When you choose this option, the cash flow sheet values are calculated, but are also editable.</td>
</tr>
<tr>
<td>intermediate points</td>
<td></td>
</tr>
<tr>
<td>Start Point</td>
<td>Specify the curve start point.</td>
</tr>
</tbody>
</table>
| Cost                              | Select the curve starting point for cost-based cash flow curves: \  
|                                  | • Zero Cost: The start point will be zero.  
|                                  | • Begin Calculation at end of curve: Select from the drop-down list of existing cash flow curves.                                                                                                   |
| Schedule                          | Select the starting point for schedule-based cash flow curves: \  
|                                  | • Manual start date: Click the Source Details button to enter the start date.  
|                                  | • Schedule Manager start date: Click the Start source drop-down list and choose from the list of Schedule Sheet columns.                                                                    |
| End Point                         | Specify the curve end points.                                                                                                                                                                       |
| Cost                              | Select the curve end point for cost-based cash flow curves: \  
|                                  | • Manual Cost: Click the Source Details button.  
|                                  | • End of Cost Sheet Column: Cost is driven by the cost end point.                                                                                                                                   |
| Schedule                          | Select the curve end point for schedule-based cash flow curves: \  
|                                  | • Manual finish date: Click the Source Details button to enter the start date.  
|                                  | • Schedule Manager finish date: Click the Finish source drop-down list and choose from the list of schedule sheet columns.                                                                    |
| Source Details                    | Click the Details button. The Source Details window opens and displays data based on the chosen information. If the choice for cost and schedule is manual, then it allows you to provide the project or shell cost, and start and end dates. Click OK to save and exit. |

**To define project or shell cost and start and end dates for the curve**

1. In the cash flow curve Properties window, click the Details button. The Source Details window opens.
2. Define the project or shell cost and start and end dates for the curve.
   - If the curve is by project or shell, enter the total values by project or shell.
   - If the curve is by WBS, enter the values for each WBS code.

**Create A Calculation Curve That Allows Manual Data Entry In Cash Flow (Basic)**

This procedure allows you to manually enter values on the resulting calculation cash flow sheet. For example, you can plot graphs based on manually entered forecast information starting at the end of a curve of actual values.

You can also create a forecast cost sheet with manually entered values that help you track automatically checks against your assigned budget on the cost sheet, and also updates automatically with actual values monthly (or quarterly or yearly, based on your selected timescale).
To create a calculation curve that allows manual data entry

1. In the Cash Flow (Basic) log, click New.

2. In the Properties window, General tab, select Calculation as the curve type. Complete the rest of the General tab.

3. In the Options tab, select Manual entry intermediate points in the Curve Properties section, and then select the start point and end point.

4. Click OK.

Undistributed amount

With the above option, you have the further option to manually distribute or not distribute the forecast cash flow budget amount based on actual costs. The cash flow sheet can display the undistributed amount per project or shell or per WBS code. The undistributed amount can be a positive number (indicating it can be distributed among the points on the curve), or negative (indicating the amount for the month, quarter, or year has been exceeded, and the remaining forecast cash flow amounts need to be adjusted accordingly).

For example, a project or shell has a budget of $100,000 for the year, and cash flow is tracked monthly. A user wants to forecast cash flow manually, but have it be based on actual costs as updated each month from the cost sheet. The user creates a curve (by project or shell, calculation type), with the following options: Curve Properties: Manual entry intermediate points; Start Point: Begin calculations at end of curve (user creates and chooses a calculation curve that tracks actual monthly project or shell costs from the cost sheet); End Point: Manual Cost. In Source Details, the user enters $100,000 as the cost, beginning with the project or shell start date or current month, and ending with the end of the year. The user then opens the newly created cash flow sheet and manually distributes the $100,000 per month. Each month, the user then manually refreshes the curve to update the data as the monthly expenses roll up. If the actual cash flow amount differs from the manually entered forecast amount, the difference will reflect at the top of the cash flow sheet as an undistributed amount. The remaining monthly forecast amounts can then be manually adjusted to reflect the actual costs. The undistributed amount displays at the top of the cash flow sheet when an editable cell is selected.

View Project Or Shell Cash For Data And Graphs In Cash Flow (Basic)

After creating the cash flow sheets, you can review cash flow data in table form (similar to a spreadsheet) or as a graph.

To view cash flow curve data and graphs

1. From the Cash Flow (Basic) log, select a cash flow sheet and double-click to access the table view of the curve.

Note: Double-clicking a curve does not refresh it automatically. See "Refresh project or shell cash flow curve data in Cash Flow (Basic)" on page 511.

2. The initial view is incremental data.

3. Click the Cumulative button on the toolbar to access the cumulative data of the curve.

4. Click the Graph button on the toolbar to access a graphical view of the curve.

5. You can also view the graphical view by selecting the cash flow sheet from the log and clicking the Graph button on the toolbar.
View Project Or Shell Cash Flow Data From Multiple Sheets In Cash Flow (Basic)

You can view data from multiple cash flow sheets in the log. This can be displayed in tabular or graphical format.

To view tabular data for multiple cash flow sheets

1. From the Cash Flow (Basic) log toolbar, click the Table button. The table will display data from all cash flow sheets. This data is incremental.

2. To select specific cash flow sheets to display, click the Curves button. Select the curves in the Cash Flow Curves window and click OK.

To view graphical data for multiple cash flow sheets

1. From the Cash Flow (Basic) log toolbar, click the Graph button. The graph will display data from all cash flow sheets. This data is cumulative.

2. To select specific cash flow sheets to display, click the Curves button. Select the curves in the Cash Flow Curves window and click OK.

Multiple cash flow sheets, table view

Multiple cash flow sheets, graph view
Manage Project Or Shell Cash Flow Curves In Cash Flow (Basic)

To edit or view the cash flow properties
Select the cash flow sheet. From the File menu, click Properties. The Properties window opens. Properties can be edited to modify the cash flow curve.

To enter or edit cash flow values
Open the cash flow sheet and click inside a cell to enter the new value. Cash flow curve values are editable only if the following is true:

- The curve type is Manual on the General tab of the Properties window.
- The curve type is Calculation on the General tab of the Properties window, and the Curve Properties selection is Manual entry intermediate points (Options tab), which allows manual entry for select points in a calculation curve.
To delete a cash flow curve
Select the cash flow sheet and click Delete.

To edit the timescale

1. Open the project or shell Cash Flow (Basic) log.
2. Delete any listed cash flow sheets in the log by selecting the cash flow sheet and clicking the Delete button.
3. Click the New button. The Cash Flow Time Scale window opens.
4. Complete the Cash Flow Time Scale window and click OK.

Assign A Data Source To A Project Or Shell Cash Flow Curve In Cash Flow (Basic)
You can assign a data source to each project or shell cash flow curve. This allows you to plot the project or shell cash flow sheets on program-level and company-level cash flow sheets.

To assign a data source to a cash flow curve

1. In the Cash Flow (Basic) log, select the cash flow curve and click the Properties button.
2. In the General tab, click the Data Source drop-down list and select a data source (Project or Shell Cash Flow 1 through Project or Shell Cash Flow 25). Select a different data source for each curve that you want to track. These will become available to plot in program- and company-level cash flow curves.
3. Click OK.

Refresh Project Or Shell Cash Flow Curve Data In Cash Flow (Basic)
Refreshing cash flow sheets updates the data to reflect new data, for example, to reflect business process transactions added to the cost sheet after the last time the cash flow sheet was refreshed. You can refresh cash flow sheets manually or schedule an automatic refresh.

Note: Refreshes can take several moments. While one or more cash flow sheets are being refreshed, the Last Update Column in the Cash Flow log will display In Process. While a refresh is in process, you will be prevented from performing many cash flow functions.

To refresh project or shell cash flow curves

1. Open the project or shell and click Cost Manager > Cash Flow (Basic) in the left Navigator.
2. In the log, do one of the following:
   • Select one or more cash flow curves to refresh, and click the Refresh button.
   • Open a cash flow sheet and click the Refresh button.

Working With Program Cash Flow Sheets In Cash Flow (Basic)
Program-level and company-level cash flow curves work similarly. Program cash flow allows you to view curves across projects within a program. Company cash flow allows you to view curves across all projects. You can create multiple cash flow curves across all active and on-hold projects.

There are two types of program and company cash flow curves:
Logical: The cash flow data is rolled up from project-level cash flow sheets through data sources Cash Flow 1 to Cash Flow 25.

- **Program level:** Roll up from active and on-hold projects and shells that are included in a program definition. Each of these projects and shells may have
- **Company level:** Roll up from all active and on-hold project.

Manual: You can manually enter data to plot graphs.

**Note:** Projects and shells included in a program can use different currencies. Primavera Unifier converts all project and shell currencies to the company's base currency and presents the rolled up data in the base currency.

**Access Program Cash Flow Curves In Cash Flow (Basic)**

**To access program cash flow curves**

Go to the **Company Workspace** tab, switch to User mode, and click **Program > Cost Manager > Cash Flow (Basic)** in the left navigator. The program Cash Flow log opens. The log is similar to the project cash flow log.

**Create A Program Cash Flow Sheet In Cash Flow (Basic)**

**To create a program cash flow sheet**

1. In the program Cash Flow (Basic) log, click **New**. The Properties window opens.
2. Complete the Properties window as described below and click **OK**.

Rolling up of project and company cash flow data is based on the granularity of the curve defined at the project level. Following are the rules that will be followed while rolling up data.

3. At the top of the sheet, you can view the number of projects rolled up versus the total number of projects. Click the link to view a bar graph view of the project data.

<table>
<thead>
<tr>
<th>Program / Company Granularity</th>
<th>Project Granularity</th>
<th>Rollup Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Year</td>
<td>Year</td>
<td>Straight rollup</td>
</tr>
<tr>
<td></td>
<td>Quarter</td>
<td>Add all quarters to derive year</td>
</tr>
<tr>
<td></td>
<td>Months</td>
<td>Add all months to derive year</td>
</tr>
<tr>
<td>Quarter</td>
<td>Year</td>
<td>Do not roll up</td>
</tr>
<tr>
<td></td>
<td>Quarter</td>
<td>Straight rollup</td>
</tr>
<tr>
<td></td>
<td>Months</td>
<td>Add all months to derive quarter</td>
</tr>
<tr>
<td>Months</td>
<td>Year</td>
<td>Do not roll up</td>
</tr>
<tr>
<td></td>
<td>Quarter</td>
<td>Do not roll up</td>
</tr>
<tr>
<td></td>
<td>Months</td>
<td>Straight rollup</td>
</tr>
</tbody>
</table>
Manage Program Cash Flow Curve Properties In Cash Flow (Basic)

To access program or company cash flow curve properties

1. Go to the Company Workspace tab and click one of the following in the left Navigator:
   - For a cash flow curve at the program level, click Programs > Cost Manager > Cash Flow (Basic)
   - For a cash flow curve at the company level, click Cost Manager > Cash Flow (Basic)
   The program or company Cash Flow log opens.

2. Click the Properties button. The Properties window opens.
You can change general information in the General tab or scheduled refresh information in the Schedule tab.

Click OK.

**Refresh Program And Company-level Curves In Cash Flow (Basic)**

Changes made to project cash flow curves are not reflected automatically on existing program and company cash flow curves. You must refresh program- and company-level curves to include the latest project data and recalculate the curves.

Program- and company-level curves will display the message Requires Refresh in the upper right corner of the Program Cash Flow window to indicate that a project-level curve has been modified.

You can refresh manually at any time. You can also schedule automatic refreshes.

**To refresh program or company cash flow data manually**

1. Open the program or go to the Company Workspace tab and click Cost Manager > Cash Flow (Basic) in the left Navigator.

2. Click the Refresh button and choose Now.

**To schedule data refresh for a single cash flow sheet**

1. Open the program or go to the Company Workspace tab and click Cost Manager > Cash Flow (Basic) in the left Navigator.

2. Select a cash flow sheet from the log and click the Properties button.

3. Click the Schedule tab.
4 Select the **Enable scheduled refresh** checkbox.

5 Select the **Frequency** and **Range of Recurrence** for the scheduled refresh.

6 Click OK.

**To schedule data refresh for all cash flow sheets**

1 Open the program or go to the **Company Workspace** tab and click **Cost Manager > Cash Flow (Basic)** in the left Navigator.

2 Click the **Refresh** button and choose **Set Frequency**. The Properties window, Schedule tab opens.

3 Complete the Schedule tab as described above and click **OK**. This sets the refresh schedule for all listed cash flow sheets.

**Working With Company Cash Flow Sheets In Cash Flow (Basic)**

**Access Company Cash Flow Curves In Cash Flow (Basic)**

To access company cash flow curves

Go to the **Company Workspace** tab and click **Cost Manager > Cash Flow (Basic)** in the left Navigator. The company Cash Flow log opens. The log is similar to the project or shell cash flow log.

**Manage Company Cash Flow Curve Properties In Cash Flow (Basic)**

To edit or view the cash flow properties

Select the **Cash Flow** sheet. From the File menu, click **Properties**. The Properties window opens. Properties can be edited to modify the cash flow curve.

**Refresh Company Level Curves In Cash Flow (Basic)**

Changes made to project or shell cash flow curves are not reflected automatically on existing program and company cash flow curves. You must refresh program- and company-level curves to include the latest project or shell data and recalculate the curves.
Program- and company-level curves will display the message Requires Refresh in the upper right corner of the Program Cash Flow window to indicate that a project- or shell-level curve has been modified. You can refresh manually at any time. You can also schedule automatic refreshes.

**To refresh program or company cash flow data manually**

1. Open the program or go to the Company Workspace tab and click Cost Manager > Cash Flow (Basic) in the left Navigator.
2. Click the Refresh button and choose Now.

**To schedule data refresh for a single cash flow sheet**

1. Open the program or go to the Company Workspace tab and click Cost Manager > Cash Flow (Basic) in the left Navigator.
2. Select a cash flow sheet from the log and click the Properties button.
3. Click the Schedule tab.
4. Select the Enable scheduled refresh checkbox.
5. Select the Frequency and Range of Recurrence for the scheduled refresh.
6. Click OK.

**To schedule data refresh for all cash flow sheets**

1. Open the program or go to the Company Workspace tab and click Cost Manager > Cash Flow (Basic) in the left Navigator.
2. Click the Refresh button and choose Set Frequency. The Properties window, Schedule tab opens.
3. Complete the Schedule tab as described above and click OK. This sets the refresh schedule for all listed cash flow sheets.

**Print Cash Flow Curves In Cash Flow (Basic)**

**To print a cash flow curve**

1. In the Cash Flow (Basic) log, select a cash flow sheet and click the Graph button. The Cash Flow Graph window opens.
2. Click Print.

**Export Cash Flow Data (in Cash Flow (basic))**

Once you have created the Cash Flow sheet, you can export the data to a local file system in a CSV format. You can export data from project or shell, program, or company cash flow sheets. You cannot import data into the cash flow sheet as you can with a cost sheet.

**To export cash flow data in Cash Flow (Basic)**

1. Open the Cash Flow Sheet.
2. Click the Export button.
3. Read the confirmation message and then click Yes to continue.
4. You may choose to open the file to review it before saving.
5. Click Save. A copy of the data is saved to your local drive in CSV format.
Earned Value (EV)

Earned value analysis is an industry standard designed to help project managers quantify project performance through:

- Measuring project performance and progress
- Analyzing schedule and budget variances
- Forecasting schedule and cost overruns

Available in Primavera Unifier’s standard projects and WBS-based shells, you can create any number of earned value sheets. Data collection sources are cost or schedule sheets, and each have different settings and prerequisites.

When the source is a cost sheet:

- Primavera Unifier uses budget information from a WBS cash flow curve to calculate a BCWS curve.

When the source is the schedule manager:

- The detail-level selection display schedule sheet activity progress.
- The summary-level selection compares rows from other earned value sheets.
- Primavera Unifier users progress dates to calculate BCWS, BCWP, ACWP, and EAC.
- Progress dates are calculated as of the current date. In a schedule imported from Primavera, Primavera Unifier honors the Current Data Date entry as the latest progress date. This date may be a future date that you might use in project modeling. Primavera Unifier will calculate curves up to the entered date.

About Earned Value Sheets

You can create multiple earned value sheets per project or WBS-based shell. Each sheet can have either the cost sheet or any schedule sheet in the Schedule Manager as the source for the calculations. Each sheet can include multiple curves, including those listed below.

- **BCWS**: Budgeted Cost of Work Scheduled. This is the curve of the budget for the project. The budget can be based on cost or on unit of measure. In terms of cost, it is the total planned budget for the project. Contributors to this cost can be labor, material, equipment or any other cost. In terms of units of measure, it is the total units needed to complete the project. Units can be hours, linear feet, etc., depending upon the activity and the resources that are assigned to an activity.
- **BCWP**: Budgeted Cost of Work Performed. This is the means of assessing performance against the planned budget. It can help you determine whether you are behind, ahead of or on schedule. The budget is based on what you have planned for the schedule, so if the schedule slips, it affects the budget. BCWP calculations are based on the schedule sheet and captured from the progress log for activities and resources.
- **ACWP**: Actual Cost of Work Performed. These are actual costs incurred to perform project-related activities, such as payments to subcontractors or purchase of materials. If your actuals are higher than the budget, you may be over budget. If your actuals are under the budget, it is possible contractors are not submitting invoices.
- **EAC**: Estimate at Completion. This refers to the final cost of any other key quantity (for example, hours, feet of material, or other quantity) associated with any work breakdown structure (WBS).
- **Custom curves**: Create custom curves to generate Forecast, ETC and others.
<table>
<thead>
<tr>
<th>Curve</th>
<th>Source = Cost Sheet</th>
<th>Source = Schedule Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>BCWS</td>
<td>Derive budget data from a cash flow curve</td>
<td>Derive budget data from an active schedule sheet</td>
</tr>
<tr>
<td>BCWP</td>
<td>Derive from a cash flow curve</td>
<td>Calculate based on earned progress and earned amount information captured on schedule sheet activities</td>
</tr>
<tr>
<td>ACWP</td>
<td>Select Actual Costs from a cash flow curve or a BP cost sheet column</td>
<td>Same as cost sheet</td>
</tr>
<tr>
<td>EAC</td>
<td>Not applicable</td>
<td>Calculate forecast from actual completion information</td>
</tr>
</tbody>
</table>

Work package names appear on the sheet if the source is schedule manager, and one or more schedule sheets associated with EV curves are linked to a work package.

**Display options**

You can select display options, to display the curves in terms of cost or unit of measure (such as hours, linear feet, etc., as defined in schedule activity properties). See "Change the sheet display options" on page 533.

**Views**

You can also generate earned value data in different views, for example, grouped by work package. Access these views using the More Sheets option. You also view the worksheets used for the individual components and curves used in each earned value sheet (More Worksheets). See "Open additional sheet views" on page 531 and See "View and work with worksheets" on page 531.

**Access Earned Value Sheets**

Earned value sheets can be created for projects and shells, and are maintained in the Earned Value log, which is part of the Cost Manager.

**To access earned value sheets**

Open a project or shell and click **Cost Manager > Earned Value** in the left Navigator. The Earned Value log opens.

**To open an earned value sheet**

Double-click it from the log window, or select the sheet and click **Open**.

**Creating And Managing Earned Value Sheets**

This section describes how to create, edit and delete earned value sheets.

**Create An Earned Value Sheet**

You can create as many earned value sheets as you need. They can be based on the cost sheet or a schedule sheet in the project or shell. If based on a schedule sheet, you can create a summary EV sheet to compare data, such as baselines, from multiple schedule sheets. You can create earned value sheets individually or by copying existing ones.
To create an earned value sheet

1. Open a project or shell and click Cost Manager > Earned Value in the left Navigator.

2. Click the New button. The earned value Properties window opens.

3. Use the information in the following table to complete the General tab.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name the earned value sheet.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description. This description is searchable from the earned value sheet log.</td>
</tr>
<tr>
<td>Level</td>
<td>This option defines the level of the EV sheet as either “detail” or “summary.”</td>
</tr>
<tr>
<td></td>
<td>• Use Detail for cost sheets or individual schedule sheets</td>
</tr>
<tr>
<td></td>
<td>• Use Summary to compare values, such as baselines, from multiple earned value sheets</td>
</tr>
<tr>
<td>Source</td>
<td>This option determines the source of the data used to calculate earned value. If the level is summary, then the source will automatically be Schedule Manager.</td>
</tr>
<tr>
<td></td>
<td>• Cost Sheet: The data source will be the project/shell cost sheet and cash flow curves.</td>
</tr>
<tr>
<td></td>
<td>• Schedule Sheet: The source of the calculations comes from schedule sheets. You can choose from any schedule sheet in the project or shell.</td>
</tr>
<tr>
<td>Time Scale</td>
<td>This setting determines the granularity of EV data that will be calculated based on source data.</td>
</tr>
<tr>
<td></td>
<td>• By: The choices are Year, Quarter, Month and Week.</td>
</tr>
<tr>
<td></td>
<td>• Format: Choose the format. The choices are determined by the By setting chosen.</td>
</tr>
</tbody>
</table>

4. Click Apply.

Once you click Apply, the Settings tab becomes available; however, the Source, Level, and Timescale fields on the General tab will no longer be editable.

5. Click the Settings tab. The Settings window opens.
This tab behaves differently, depending on the level you selected.

- If you selected **Detail** level, you can add the components (such as BCWP, BCWS, ACWP, and custom curves) that will be used to calculate earned value.
- If you selected **Summary** level, you can choose the schedule sheets for the EV sheet.

Details about defining these settings are in [Define earned value settings](#).

6 Click **OK**.

**Define Earned Value Settings**

The behavior of the Settings tab depends upon the level you selected on the General tab.

- If you selected **Summary**, you can add detail EV sheets to the summary EV sheet. This allows you to compare data such as baselines from multiple detail-level earned value sheets.
- If you selected **Detail**, you can add a cost curve from a cost sheet or a schedule sheet to an EV sheet.

**To add a detail schedule sheet to the Summary EV sheet**

1 On the **Settings** tab, click **Add**. The Earned Value log opens and displays all the available detail-level EV sheets.

2 Highlight the sheet(s) you want to add to the summary sheet.

3 Click **Open**.

4 Click **OK**

**To add a cost curve to an EV sheet**

1 On the **Settings** tab, click **Add**. The Select a Type window opens.

2 Click the **Type** pull-down and select the curve to add.
   - **BCWS**: Budgeted Cost of Work Scheduled. If you choose this, you must specify where the budget comes from.
   - **BCWP**: Budgeted Cost of Work Performed. If you choose this, Primavera Unifier identifies the progress source (if you are using the Schedule Manager as a source).
• **ACWP**: Actual Cost of Work Performed. This is independent of source. If you choose this, you must specify the cash flow curve or cost sheet column.

• **EAC**: Estimate at Completion. (Available when the source is the Schedule Manager) If you choose this, you must include cost and start/finish information from the schedule manager.

• **Custom**: If you choose this, you will have to specify curve parameters in a Properties window. (See the descriptions below for details.)

3 Click OK. The entry will be added to the Settings tab of the earned value Properties window.

---

**Note:** Adding settings will update the earned value sheet. This can take a few moments. The Last Update column on the earned value log will display an In Progress message while the sheet is being updated, and the sheet will not be accessible until the update is complete.

---

**BCWS (Source = Cost Sheet)**

If you choose BCWS as the Type, and your Source is Cost Sheet, then you will define BCWS based on a cash flow curve.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name must be unique</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description</td>
</tr>
<tr>
<td>Type</td>
<td>Type is BCWS</td>
</tr>
<tr>
<td>Budget</td>
<td>Click the pull-down. Select a cash flow curve defined in the Cash Flow module. The choices will include only those curves with the same Time Scale setting as that selected on the General tab of the EV sheet.</td>
</tr>
</tbody>
</table>
BCWS (Source = Schedule Manager)

If you choose BCWS as the Type, and your Source is Schedule Manager, Sheet, then you will define BCWS based on one or more schedule sheets.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name must be unique</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description</td>
</tr>
<tr>
<td>Type</td>
<td>Type is BCWS</td>
</tr>
</tbody>
</table>
| Budget        | You can add any number of active schedule sheets from the project or shell.  
• To add schedule sheets: Click the Add button. The Schedule Sheet picker opens. The list displays all active schedule sheets in the Schedule Manager for this project or shell. Select one or more sheets and click Open.  
• To remove a schedule sheet from the list: Select the sheet(s) to be deleted from the Budget list, and click the Remove button. |

BCWP: (Source = Cost Sheet)

When the source is cost sheet, define BCWP based on a percent (%) column from the project/shell cost sheet.
In this field | Do this
---|---
Name | Name must be unique
Description | Enter an optional description
Type | Type is BCWP
Progress | Click the pull-down. The list displays columns on the project/shell cost sheet that are percent (%) columns.

**BCWP: (Source = Schedule Manager)**

When source is schedule manager, define BCWP based on activity and resource progress captured in a schedule sheet.
In this field | Do this
---|---
Name | Name must be unique
Description | Enter an optional description
Type | Type is BCWP
Progress | There is one option: Activity and Resource Progress.

**ACWP (Source = Cost Sheet or Schedule Manager)**

The setup is the same when the source is cost sheet or schedule manager. You can define ACWP based on a cash flow curve or a cost sheet column.
**EAC (Source = Schedule Manager)**

Estimate at Completion (EAC) is available when the source is Schedule Manager. When you import schedule activities from an external source, such as Primavera P6, Primavera Unifier needs to determine the spread for the EAC curve. By selecting **Import Distribution data from external source** in the Default Budget and Progress Method Setup window, Activity Budget Distribution Profile block, Primavera Unifier will use a linear distribution profile to generate the EAC curve.

![EAC Curve](image)

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name must be unique</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description</td>
</tr>
<tr>
<td>Type</td>
<td>Type is EAC</td>
</tr>
</tbody>
</table>
| Start Point   | Choose the following (from the schedule manager activity attribute form):  
   • Cost: Choose a data element that has been associated with the starting cost of the forecast.  
   • Schedule: Choose the start date element from the schedule manager that is associated with your forecast information (e.g., Forecast Start Date). This date will be used if the calculation if the activity has not yet started. Once the activity starts, the calculation will default to the “progress as of date” if provided, or the actual start date. |
| End Point     | Choose the following (from the schedule manager activity attribute form):  
   • Cost: Choose a data element that can provide estimated completion cost value.  
   • Schedule: Choose the finish date element from the schedule manager that is associated with your forecast information (e.g., Forecast Finish Date). |

**Create A Custom Earned Value Curve**

You can create custom curves to generate other earned value calculations such as forecast or EAC. You must create a BCWS entry before you can create a custom curve. This is applicable when the source is either cost sheet and schedule manager.

Follow the procedure See "Define earned value settings" on page 520 and choose **Custom** as the Type.
**Custom Curve (Source = Cost Sheet or Schedule Manager)**

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name must be unique</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description</td>
</tr>
<tr>
<td>Type</td>
<td>Type is Custom</td>
</tr>
</tbody>
</table>
| Curve Properties | This determines the shape of the curve that will be generated. Choose one of the following options:  
  • S-Curve: The system will generate the curve based on Sigma and Mu. The system will generate data points (intermediate points) for the curve.  
  • Linear: This generates a straight line curve. The system generates data points for the curve.  
  • Manual entry intermediate points: This generates a curve based on data you enter, distributed over the time period range of the curve. |
| Start Point | This determines the start point of the curve. You define the starting value (Data), and when the curve should start (Schedule).  
  Data: Choose an option:  
    • Zero: curve starts at zero.  
    • Begin calculations at end of actual cost of work performed  
  Schedule: Choose an option:  
    • Manual Start Date: You can choose a start date for the curve in the Source Details window  
    • Schedule Manager Start Date: Click the pull-down. This lists the date-type data elements that are on the Activity Attribute form. Choose which to use as the curve start date. |
| End Point | This determines the end point of the curve. You define the end value (Data) and when the curve should end (Schedule).  
  Data: Choose an option:  
    • Manual: Allows you to enter cost data in the Source Details window.  
    • Cost Sheet Column: Click the pull-down. This lists all columns |
In this field | Do this
---|---
don**ed on the cost sheet. The values that are in that cost sheet column will display in Cost column on the Source Details window. Schedule: Choose an option:
- Manual Finish Date: You can choose a finish date for the curve in the Source Details window.
- Schedule Manager Finish Date: Click the pull-down. This lists the date-type data elements that are on the Activity Attribute form. Choose which to use as the curve end date.

| Source Details | This allows you to enter any manual information required to generate the curve.
- Click the Details button. The Source Details window opens. The Source Details window is based on the other options selected in the Properties window.
- See the following section for details of the Source Details.

**Custom Curve: Source Details**

Data displayed on the window is based on several options chosen during setup of the sheet:

- The source chosen on the General tab (cost sheet or schedule sheet)
  - **Cost Sheet:** All WBS codes on the cost sheet are listed
  - **Schedule Manager:** Depending on which schedule sheet(s) are selected for BCWS calculation, and whether any schedule sheet is linked to a work package, the WBS codes may be filtered by the WBS codes on the work package
- The budget option selected for BCWS entry
- Options selected on the custom entry

Fields on this sheet may be editable depending on the options you chose in the Properties window.

**Note:** Clicking the Details button on the Properties window will save the curve, even if you later click Cancel to cancel out of the Properties window.
### Column Description

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WBS Code</strong></td>
<td>All WBS codes on the project/shell cost sheet are displayed, with one exception: If the schedule sheet(s) in the BCWS entry are associated with work packages, rather than the cost sheet, then only those WBS codes within those work packages will be displayed here. (Note that if at least one schedule sheet in the BCWS entry is associated with the cost sheet, this window will display all cost sheet WBS codes.)</td>
</tr>
<tr>
<td><strong>WBS Item</strong></td>
<td>The item, as defined on the cost sheet, displays for each code.</td>
</tr>
<tr>
<td><strong>Cost</strong></td>
<td>The behavior of this column depends on what you chose in the Properties window for End Point &gt; Data: • If you chose Manual, then you can enter cost data manually here. You can also import this cost data (see procedure below). You can later distribute this amount across the custom curve’s worksheet. • If you selected a Cost Sheet Column, then the data that is in the column for each WBS code will display here. • Schedule Manager: Each activity on the schedule sheet can be associated with one or more WBS codes, and distributed based on % entered there.</td>
</tr>
<tr>
<td><strong>Start</strong></td>
<td>This column depends on the Start Point settings in the Properties window: • If you chose Zero (Data), and Manual Start Date (Schedule), then you can enter date manually. • If you chose Zero (Data), and selected a Schedule Manager start date (Schedule), then the column displays the earliest date across all activities for that WBS code. • If you chose begin calculation at end of ACWP, then the date is automatically calculated based on ACWP end period.</td>
</tr>
<tr>
<td><strong>Finish</strong></td>
<td>This column is based on the option chosen as the End Point Schedule: • If you chose Manual Finish Date, then you can manually enter a finish date for the custom curve. • If you chose Schedule Manager finish date, this date is taken from</td>
</tr>
<tr>
<td>Column</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>the schedule sheet finish date you chose in the Properties window.</td>
</tr>
</tbody>
</table>

**To enter data in the Source Details window**

1. Open the custom curve Source Details window:

   For the earned value sheet, open the EV Properties window, Settings tab. Select a custom curve and click **Modify**, or create a new custom curve. In the custom curve Properties window, click the **Details** button.

2. Depending on the options defined in the custom curve Properties window, the **Cost**, **Start** and/or **Finish Date** fields may be editable across the WBS codes. Add this information as needed.
   - Start is the starting date of the curve.
   - End is the end date of the curve.
   - If you enter a value in the Cost column, it will automatically display in the last column of the incremental view of the worksheet for the custom curve. You can then open the worksheet and distribute this cost amount across the other columns (and the other time periods) in the worksheet. (See "View and work with worksheets" on page 531.)

**To import cost data into the Source Details window**

1. Open the custom curve Source Details window:

   For the earned value sheet, open the Properties window, Settings tab. Select a custom curve and click **Modify**, or create a new custom curve. In the custom curve Properties window, click the **Details** button.

2. Click the **Export** button and download the CSV file. Save the file to your local drive or open the file directly.

3. Enter the cost or date information in editable **Start**, **End** and/or **Cost** fields as applicable, depending on the entry settings you specified in the custom curve Properties window.

4. Save the CSV file.

5. In the Source Details window, click **Import**, and import the CSV file.

**Modify Earned Value Sheet Properties**

You can modify most of the Properties information on existing earned value sheets, including adding additional curves, entering source detail information, changing the sheet name, etc.

The following information cannot be modified on an earned value sheet: Source and Time Scale, as defined on the EV Properties window, General tab.

**To modify earned value sheet properties**

1. Open a project or shell and click **Cost Manager > Earned Value** in the left Navigator.

2. In the log, select a sheet and click the **Properties** button on the toolbar.
   - Click the General tab to change general properties information.
   - Click the Settings tab, then select a curve and click **Modify** to modify the settings for the curve.
**Delete An Earned Value Sheet**

You can delete any earned value sheet.

**To delete an earned value sheet**

1. Open the project or shell and click **Cost Manager > Earned Value** in the left Navigator.
2. In the log, select a sheet and click the **Delete** button on the toolbar. Click **Yes** to confirm.

**Set Permissions On An Earned Value Sheet**

After creating an earned value sheet, you can determine which other project or shell team members can access it. These sheet level permissions can be assigned by the creator or a user with Full Access permission in the Earned Value module.

Sheet level permissions are setup on each earned value sheet in User Mode.

**To assign permissions to an earned value sheet**

1. Select a sheet in the Earned Value log.
2. Click the **Permission** button.
3. Add users or groups and assign permissions:
   - **Modify Permissions**: Allows the user to modify the permissions of the earned value sheet. Selecting this permission will select all permissions below.
   - **Edit Data**: Allows the user to edit earned value data, properties and columns.
   - **View**: User can view earned value data and curves.
4. Click **OK**.

**Working With Earned Value Sheets**

This section discusses working with the earned value sheets you have created.

**View additional sheets and worksheets**: When you create an earned value sheet, you can choose to display the data in additional sheet views, or to view worksheets that show the calculations for BCWS, BCWP and custom entry curves added to the sheet. Manual cost distribution can be done on custom curve worksheets, depending on the curve setup.

**Display earned value data graphically**: The information captured on the earned value sheet can be displayed on graphs.

**Change display options**: You can change the display to show information by cost data, by a chosen unit of measure (hours, linear feet, etc.), or for a particular period of time.

**Add sheet columns**: In addition to default columns, you can add your own formula columns to do earned value sheet calculations.

**Save snapshots of data**: This allows you to save snapshots of data at periodic interviews on the same sheet views.
Export earned value data: Some sheet views allow you to export the data on them to a CSV file. Details about these procedures are found in the following sections.

Open Additional Sheet Views
From an earned value sheet, more sheet views may be available, depending on the data source for the sheet (cost sheet or schedule manager).

If the source is cost sheet, the default View by WBS Codes is the only view option.

If the source is schedule manager, you can view additional sheets described below.

• **WBS Codes** is the default view when the EV sheet source is cost sheet or schedule manager. It displays EV data by WBS code in a flat list. It is applicable when Progress option on BCWP is “Activity % Complete.”

• **WBS Codes - Group by Summary Codes**: The data in this view is grouped by summary WBS codes retrieved from the cost sheet. The summary codes show all levels that are defined in the cost sheet. It assumes that there are summary WBS codes. If the cost sheet is in flat mode, data is shown with leaf level WBS codes.

• **WBS Codes - Group by Work Package**: The data is grouped by work package, and then by summary WBS codes. This is applicable even if cost sheet is in flat mode. Summary rows show totals from leaf codes; work package summary rows show the totals per work package.

• **Earned Value Components**: In this view, data is grouped by earned value components. The rows are the components of the earned value sheet: BCWS, BCWP, ACWP, EAC. The columns are time periods based on the time scale for the sheet. Data is not totaled at the bottom of the sheet. Note the sliding scale in the upper portion of the sheet. This allows you to move the view of the sheet to display different time periods. Display Options allows you to change UOM (unit of measure) value only.

• **Schedule Sheet - Activities**: The activities displayed on this view are the activities defined in the schedule sheet. All activities are displayed regardless of whether progress entries have been made for them.

• **Schedule Sheet - Activities - Group by WBS Codes**: In this view, EV data is grouped by WBS code, and by activity associated with each WBS code.

For these additional sheets, you can create snapshots in the default WBS Codes view and the Schedule Sheet-Activities view. You can change the Display Options and export data from any view.

To view more sheets
1. Open the earned value sheet.
2. Click the More Sheets button. The More Sheets window opens. The window lists sheets that are generated along with the current sheet.
3. Select a sheet and click OK. The sheet opens.

View And Work With Worksheets
You can view worksheets for BCWS, BCWP, EAC as well as custom curves that have the “Manual entry intermediate points” option selected in curve properties. These worksheets display the BCWS, BCWP, EAC and custom curve calculations used in the earned value analysis.

BCWS, BCWP and EAC worksheets are read-only. Custom curve worksheets allow manual distribution of cost data in the Incremental view.
You can export data from worksheets. A graphical view is available for the BCWP worksheet. In addition, you can add notes to worksheets.

The More Worksheets option is available from the default WBS Codes view of the earned value sheet, and also the Schedule Sheet-Activities view available from the More Sheets option.

To open a worksheet

1. Open the earned value sheet.
2. Click the View button and choose More Worksheets. The More Worksheets window opens, listing BCWS, BCWP, EAC (if defined) and any custom curves.
3. Select a worksheet and click OK. The worksheet opens. The default view is incremental. In incremental view, the columns are time based. The range is determined by the Start and Finish dates in the Source Details. Manual entry of cost data, if applicable, can be done in this view.
4. To view the cumulative view of the data, click the Cumulative button. (A graphical view of the Cumulative curve is available; click the Graph button from the Cumulative view.)
5. For BCWP, to view the graphical view, click the Graph button, then choose All Rows or Selected Row. For more information about displaying graphs, see the example below.

To add or view notes on a worksheet

1. Open the BCWS, BCWP, EAC or custom curve worksheet.
2. Click the Notes button. The Notes window opens. Any notes that have previously been added will display in the Notes field.
3. You can enter a note in the Notes field and click Ok.

To enter or distribute cost data in a custom curve worksheet

1. Open the worksheet for the custom curve.
   • If (in the custom curve properties) the Data option has been set to manual, then the values that you entered in the Cost field of the Source Details window for each WBS code display by default in the last column on the worksheet. This amount can be distributed among all time periods (columns) on the worksheet.
   • If the Data option has been set to Cost Sheet column, then when the earned value sheet is refreshed, actuals data will roll up from the cost sheet column directly to the last period (column) on the worksheet. You can distribute this amount manually across other columns.
2. To distribute this cost data, scroll to the last column on the worksheet. The value in the column is the total amount that needs to be distributed.
   You can click the Find button to search for a specific value in any column, including to search for a WBS code.
3. Double-click inside a cell to make it editable.
4. For each applicable WBS code, change the value in the last column to the correct distribution amount and press Enter. The rest of the original cost amount displays in the Undistributed Amount field at the top of the worksheet. If you distribute a total amount that exceeds the original total, the Undistributed Amount field displays a negative amount.
   For example, if the original value is $12,000 in the last column (either added manually in the Source Details window or rolled up from a cost column), and the distribution should be $1,000 per month over a 12 month period, then enter $1000 in the last column. The remaining $11,000 will display in
the Undistributed Amount field. As you enter $1000 in each of the other month columns, this Undistributed Amount will decrease.

After distribution, if the amount in the cost sheet column or the Cost field in the Source Details (depending on the source) either increases or decreases in amount, then when the earned value sheet is refreshed again, this difference will be reflected automatically in the last column of the worksheet. If there is a decrease that takes the last column to a value of zero, then the difference will be reflected in the next-to-last column.

5 Click **Save** to save the worksheet.

---

**Change The Sheet Display Options**

The display options allow you to view earned value data in a variety of ways. You can view data:

- by cost data
- by a chosen unit of measure (such as hours, linear feet, etc.)
- for a particular period of time

Display options are available on the default WBS Codes view, as well as the other views available through More Sheets, with one exception: the Earned Value Component view cannot set a time period.

You can change the display options on any of the views available through the More Sheets option. If you set the display options on the default view, then open another sheet through More Sheets, the display option settings will be in effect when the second sheet is opened.

**To change the display options**

1. Open the earned value sheet.
2. On the toolbar, click the **Display Options** button. The Display Options window opens.
3. Choose a **Show By** option.
   - **Cost**: this is the default display, showing the EV sheet using cost data
   - **UOM**: this will display EV data by unit of measure, such as hours. This list is in the Unit of Measure data definition, such as hours, feet, etc.
**Note:** Note: UOM is not available if sheet source is the cost sheet. It is also not available if source is schedule sheet and the BCWP Progress is “Activity % Complete.”

4. In the **Display as of** field, click the data picker and choose a date. This setting is optional. If you choose a date, the system will use the date as a cut off date and will show earned value data as of that date. If you do not select a date, then the display will default to the “Last Update Date” of the EV sheet.

Choose a date that is no later than today’s date, as you cannot choose a date in the future, and no earlier than the earliest date for which data is available across the curves.

**Note:** This option is not available if sheet source is the cost sheet. It is also not available if source is schedule sheet and the BCWP Progress is “Activity % Complete,” This option is also not available for the Earned Value Component view, as the columns of this sheet are time based.

5. Click the **Refresh** button. This will refresh the sheet to reflect the new display options.

**Add A Column To The Earned Value Sheet**

In addition to the system defined columns that are added to the earned value sheet automatically (BAC, BCWS, BCWP, ACWP, EAC), you can create columns for your own formulas.

You can define additional columns on a sheet when:

- Source is cost sheet, the display view is the default WBS Codes view
- Source is schedule manager, and the display option is set to Show By: Cost.

**To add a column to the earned value sheet**

1. Open the earned value sheet.
2. Click the **Columns** button. The Column Log window opens.
3. Click **New**. The Column Properties window opens.
4. Complete the fields and click **OK**.

**Note:** You can create formulas based on any of the columns on the earned value sheet.
### Earned value Column Properties window

<table>
<thead>
<tr>
<th><strong>In this field</strong></th>
<th><strong>Do this</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name the column.</td>
</tr>
</tbody>
</table>
| Datasource       | Select a data source. Available selections depend upon the level of the earned value sheet.  
                     Summary Level:  
                     • Select components from the detail-level earned value sheets included in the summary sheet settings. Each selection will generate a column in the summary earned value sheet.  
                     Detail Level:  
                     • Earned Value 1 to 25. Allows you to define your own formulas  
                     • Custom curves, BAC, BCWS, BCWP, ACWP, EAC are default columns that cannot be edited or deleted. |
| Entry Method     | The sheet accepts formulas only. You options depend upon the level of the earned value sheet.  
                     • Summary Level: The entry level is unavailable.  
                     • Detail Level: Requires a formula. Click Create to create a formula. |
| Data Format      | Choose **Currency** or **Percentage**. This defines how the value is displayed on the sheet. |
| Display Mode     | Choose to **Show** or **Hide** the column on the sheet. |
| Total            | Choose how to display the summary row, which is the last row for the column: **Blank** to leave the summary row blank; **Sum of All Rows** to add up all the rows; or **Use Formula Definition** to apply the columns formula to the last column (based on values in other summary rows). |
| Column Position After | Choose a column. The new column will be placed after the selection. |
Example Earned Value Formulas

Following are some examples of earned value definitions and formula columns that can be added to the earned value sheet. For the examples below, we will start the following values:

- BAC = $1,000
- BCWS = $600
- BCWP = $400
- ACWP = $750
- EAC = $1800

Cost Variance

Cost Variance (CV) is the difference between a task’s estimated or budgeted cost and its actual cost. A negative variance indicates the project or shell is over budget.

CV = BCWP – ACWP

Example: $400 – $750 = –$350

Scheduled Variance

Scheduled Variance (SV) is the difference between the current progress and the scheduled progress of a task, in terms of cost. It is a comparison of the amount of work performed during a given period to what was scheduled to be performed. A negative variance means the project or shell is behind schedule.

SV = BCWP – BCWS

Example: $400 – $600 = –$200

Cost Performance Index

Cost Performance Index (CPI) is the ratio of budgeted costs of work performed to actual costs of work performed. A value of less than 1 (less than 100%) indicates that the project or shell is over budget, and you are getting less work per dollar than planned.

CPI = BCWP/ACWP

Example: 400/750 = 0.53 or 53%
Scheduled Performance Index (SPI)

Schedule Performance Index (SPI) is the ratio of budgeted costs of work performed to budgeted costs of work scheduled. A value of less than 1 (less than 100%) indicates that the project or shell is behind schedule.

\[
SPI = \frac{BCWP}{BCWS}
\]

Example: \(\frac{400}{600} = 0.67\) or 67%.

Cost Schedule Index (CSI)

The Cost Schedule Index (CSI) reflects the relationship between CPI and SPI. The CSI value should be close to 1.0. The farther the value from 1.0, project or shell recovery becomes more difficult to achieve.

\[
CSI = CPI \times SPI
\]

Example: \(0.53 \times 0.67 = 0.3551\)

To Complete Performance Index (TCPI)

The To Complete Performance Index (TCPI) is the ratio of the work remaining to be done to funds remaining to be spent as of the status date. A TCPI value greater than 1 indicates a need for increased performance; less than 1 indicates performance can decrease. This helps determine how much of an increase in performance is necessary on the remaining project or shell tasks to remain within budget.

\[
TCPI = \frac{(BAC - BCWP)}{(BAC - ACWP)}
\]

Example: \(\frac{($1,000 - $400)}{($1,000 - $750)} = 2.4\)

Variance at Completion (VAC)

VAC is the difference between the BAC) and the EAC.

\[
VAC = BAC - EAC
\]

Example: \$1,000 – $1,800 = –$800
FILTER EARNED VALUE SHEETS BY WBS CODE

Schedule sheets and earned value sheets share the WBS code associated with schedule sheet activities. (For more information about this, see the Schedule Manager setup instructions in the Primavera Unifier Administration Guide.) Because of this association, earned value sheets can display schedule sheet data, and you can filter this data by WBS codes. You can graph filtered data and view the results by currency or percentage.

If your administrator included an “Activity Earned Value Filter” field on the schedule sheet attribute form, you can further refine earned value filters by activity criteria, such as progress. If this field is on the form, you can include or exclude specific activities from the Master Schedule Sheet.

To create a filter

1. From the Edit menu, choose Filters. The Setup Filters window opens.
2. Click Add. The Add filter window opens.
3. Name the filter.
4. Select one or more segments of a WBS code to create the filter.
5. Click OK to save the filter.

To change a filter

1. From the Edit menu, choose Filters. The Setup Filters window opens.
2. Click Edit. The Modify Filter window opens. You can rename the filter, or change the WBS segments.

To remove a filter

1. From the Edit menu, choose Filters. The Setup Filters window opens.
2. In the Setup Filters window, highlight the filter and click Remove.
3. Click Yes in the confirmation window.
   This action cannot be undone.

To apply a filter to the EV sheet

1. Open the EV sheet in which you want to filter data.
2. From the Edit menu, choose Filters. The Setup Filters window opens.
3. Select the filter you want to apply and click Apply Filter.
   The EV sheet will display only those rows that meet the filter condition. You can graph the filter data and view it by currency or percentage.
4. To restore all the rows to the EV sheet, click [Cancel Filter].
FILTER EARNED VALUE SHEETS BY PROGRESS

If your administrator included an “Activity Earned Value Filter” field on the schedule sheet attribute form, you can further refine earned value filters by activity criteria, such as progress. If this field is on the form, you can include or exclude specific activities from the Master Schedule Sheet.

To create a progress filter for the EV sheet

1. Open the EV sheet that you want to filter by progress.
2. Click the Filters icon. The Setup Filters window opens.
3. Click Add. The Add Filter window opens.
4. Complete the Add Filter form.
The activity earned value filter uses an “and” condition. This means that it will display all activities associated with the WBS codes selected, but will display a BCWS value only for those activities with a text entry in the Activity Earned Value Filter column that matches the text entry in the filter.
5. Click OK to save and close the form.

To apply the progress filter to the EV sheet

1. Click the Filters icon. The Setup Filters window opens.
2. Select the filter you want to use and click Apply Filter.
The filtered EV sheet will display:
   • All the WBS codes specified in the filter
   • Only the values that are specified in the filter

3. To restore all the rows to the EV sheet, click [Cancel Filter].
Save A Snapshot Of The Earned Value Sheet

You can save a snapshot copy of the default WBS Codes view of the earned value sheet, as well as the Schedule Sheet-Activities view available through the More Sheets option.

To save a snapshot copy

1. Open the earned value sheet.
2. Click the File menu and choose Create Snapshot.
3. Enter a title for the snapshot and click OK.

To view a saved snapshot

1. Open the earned value sheet.
2. Click the File menu and choose Open. The Snapshot Log opens.
3. Select a snapshot and click Open.

Export Earned Value Data

You can export a CSV file with the earned value sheet data of any view of the earned value sheet, and any worksheet.

To export the earned value sheet as a CSV file

1. Open the earned value sheet.
2. Click the Export button. Save the CSV file to your local drive and click OK.

Refresh Earned Value Sheets

You can manually refresh earned value sheets so that they reflect the latest data, depending on their source: information from cost sheet columns or cash flow curves, or information such as earned progress from schedule sheets. Earned value sheets are automatically refreshed if you make changes to the Properties window, Settings tab.

To refresh an earned value sheet

1. Select a sheet in the Earned Value log.
2. Click the Refresh button.

As data is refreshed, the Last Update column in the log will display In Progress. This may take a few moments. When the update is complete, the current date will display in the column. You will not be able to access the sheet while the update is in progress.

Display Earned Value Data As A Graph

You can view a graphical representation of earned value by clicking the Graph button from the Earned Value log window or from an earned value sheet. This is available for the default earned value sheet and additional sheets available through the More Sheets option. Earned value data can be viewed either by currency over time, or by value percentage over time. The default view is currency.

You must have Adobe Flash Player installed on your system to view earned value graphs.
To display the earned value sheet as a graph

1. Open the earned value sheet.
2. Click the **Graph** button and select one of the following:
   - **All Rows**: Shows graphical representation of the sum of all rows on the sheet.
   - **Selected Row**: Shows graphical representation of the row that is currently selected on the sheet (summary or leaf row).

**Note**: The graph displays the names of the curves as they appear as column names on the sheet. If you change the name of a custom curve, you must also change the column name in order for the name change to display on the graph. The graphical display will also automatically include any custom curves you have added, even if you have not added them as columns on the sheet. You can filter which curves to display.

To change the view

Click the **Project Currency** or **Percentage** button next to the **View By** field. Primavera Unifier will gray-out the current view.

To filter which graphs are displayed

1. Click the **Curves** button. The Filter Graphs window opens.
2. Select the graphs that you want to display and click **OK**.

To change the zoom level of the graph

Click **Zoom** and choose Week (W), Month (M), Quarter (Q), or Year (Y). This will change the plotting of the graph display (not the data calculations), and enable you to view data by time period. Graphs using the Week (W) and Month (M) zoom levels are displayed using the Date Format set in your User Preferences. See "Change time zone or date format" on page 21 for details on setting the date format in User Preferences. Graphs using the Quarter (Q) or Year (Y) are displayed using the Time Scale Format set in the EV Properties General tab.

**Note**: Some earned value calculations can lead to a negative number. These results are shown on the graphs.

The zoom level that you choose works with the time period by which data is captured. For example, if you are capturing data by the month, and select the zoom level Quarter (Q), the graph will display three months of data. If you select the zoom level Year (Y), the graph will show 12 months of data.

For example:
You can create your own time scale by using the scale slider bar at the bottom of the graph. Drag to the right or left to experiment with the time scale.

**Note:** Custom unit of measure (UOM) - based curves are not shown on earned value graphs.

**To reset the zoom level of the graph**
Click **Reset** to return the graph to the default view.

**To print the graph**
Click the **Print** icon on the upper right corner of the sheet.
WORKING WITH A GENERIC COST MANAGER

A Generic Cost Manager captures cost-related activities for a configurable shell. These include costs like:

- Rent
- Lease payments
- Landscape care
- Building maintenance and repair
- Remodel of building interiors

With this manager, you can capture and view cost transaction information based on a timescale, such as monthly, quarterly or yearly. Each configurable shell can have one Generic Cost Manager.

Most of the functionality for the Generic Cost Manager is the same as that for the standard Cost Manager. Rather than re-document all of the cost management sheet functionality that is common between the Generic Cost Manager and the standard Cost Manager, this section documents the differences between the managers, and tell you how to use that functionality in context of the task you will be performing.

**Note:** The names of the Generic Cost Manager, the various shells and subshells, and the generic cost sheet you will work with are determined by the names defined in Primavera uDesigner. For documentation purposes, in these instructions, this manager is referred to as the Generic Cost Manager.

The Generic Cost Manager:

- Defines a code structure that can be used to capture cost-related activities for a configurable shell.
- Tracks and rolls up costs to upper management levels
- Enables interaction with cost data
  - Operating budgets (monthly, quarterly, yearly)
  - Projects with life cycles that span over extended time
  - Costs covering the entire life cycle of the product/operation
  - Transactions based on timescale
  - Transactions in varying currencies

**Data Sources For Generic Cost Sheets**

The Generic Cost Manager uses information in cost sheets that is manually entered, calculated, or comes from Generic Cost BPs. The difference between the Generic Cost Manager and the standard Cost Manager is that the data used in the Generic Cost Manager comes from shells and subshells, not from projects.

The Generic Cost Manager uses specific cost BPs as a data source. These BPs have the type cost and the classification Line Items with Multiple Codes.

**Working With Generic Cost Sheets**

The following procedures discuss how to access and work with generic cost sheets. The generic cost sheet is created from a template.
**Open A Generic Cost Sheet**

To open a generic cost sheet

1. Open the shell and click **Configurable Manager > Generic Cost Manager > Generic Cost Sheet** in the left Navigator. The Generic Cost Sheet log opens.

2. Select the cost sheet from the log and click **Open**. The generic cost sheet opens.

You work with a generic cost sheet in the same way as a standard cost sheet. The difference is that the data in the generic cost sheet comes from shells and subshells rather than from projects. The first two columns are displayed by default. The view is fixed, and there is no split screen capability.

**Viewing Data For Shells And Subshells In A Generic Cost Sheet**

The generic cost sheet displays transactional data by period and shell level. In the context of working with the generic cost sheet, you can filter the cost data you are viewing by shells or subshells. The generic cost sheet is accessed from the **Shell > Configurable Managers > Generic Cost Manager > Generic Cost Sheet** log. You can use the shell or subshell filter in combination with the timescale selector documented in the next section to create various views in your spreadsheet based on shell or subshell and time period.

To view generic cost sheet data by shell or subshell

1. Open the shell and click **Configurable Managers > Generic Cost Manager > Generic Cost Sheet** in the left Navigator. The Generic Cost Sheet log opens.

2. Open the Generic Cost Sheet you want to work with by double-clicking the cost sheet name or by selecting the cost sheet name in the log and then choosing **File > Open**.

3. In the View By selection list, choose one of the following:
• **Current Shell only**: Data from the current shell you have selected. Manual column data is editable in the Current Shell only view.

• **Current Shell and Subshells only**: Data from both the current shell and its subshells.

• **Subshells only**: Data from the subshells of the current shell.

In Generic Cost Sheet views, data is rolled up from the current shell and subshells. When data is rolled up from subshells, the generic cost sheet under a shell can roll up data from other shells that are created as subshells and their subshells. The Current Shell and subshells only and Subshells only views support this rollup. For example:

- North Region (shell)
  - Property A (subshell)
    - Building 101 (subshell)
    - Building 102 (subshell)
  - Property B
    - Building 201
    - Building 202

In this example, the North Region Generic Cost Sheet will have data from Property A, Property B, Building 101, Building 102, Building 201, and Building 202. Property A has data from Building 101 and Building 102. Property B has data from Building 201 and Building 202.

Also, data from a subshell to its parent shell can only roll up if the codes match. For example,

- North Region (Shell)
  - Property A (1000–1001: $500)
    - Building 101 (1000–1001: $500)
    - Building 102 (1000–1002: $200)

In this example, Building 101 will roll up to Property A as the codes match (1000–1001). Building 102 will not roll up because the codes are different (1000–1002). Parent and child shell cost codes must match for roll up to occur. Timescale and column definition must also match across the shells and subshells.

Also, all subshells that will roll up must have the same currency as the parent shell. If all of the subshells and the current parent shell have the same currency, the data displays in that currency. If at least one subshell has a different currency, the data displays in the Base Currency. A confirmation message alerts you to this currency display.

While rolling up, only parent shell generic cost sheet codes should be considered. This is applicable under all views.

**Change The Timescale On A Generic Cost Sheet**

With the Generic Cost Manager, you can capture and view cost transaction information based on a timescale, such as quarterly or yearly. For example, you might be working with time-based transactions such as lease payments. In the context of working with the generic cost sheet, you can change the timescale on the cost data with which you are working. The generic cost sheet is accessed from the [shell] > Configurable Managers > Generic Cost Manager > Generic Cost Sheet log. You can use the shell or subshell filter described in See "To view generic cost sheet data by shell or subshell" on page 544 in combination with the timescale selector to create various views in your spreadsheet based on shell or subshell and time period.
To change the timescale on a generic cost sheet data by shell or subshell

1. Open the shell and click Configurable Managers > Generic Cost Manager > Generic Cost Sheet in the left Navigator. The Generic Cost Sheet log opens.

2. Open the cost sheet you want to work with by double-clicking the cost sheet name, or by selecting the cost sheet name in the log and then choosing File > Open.

3. Click on the Display Period button. The Display Period window opens.

4. Select a date range (Monthly, Quarterly, or Yearly) and the time period to go with the range. The data for the timescale you select is displayed in the cost sheet. The default view is Monthly, and shows the current month. Data is always stored in months. Changing the timescale units updates the totals based on the period and the calendar year.

   Monthly view data is editable in the manual columns only, and in the Current Shell view only. Quarterly and Yearly views are read-only.

Modify Shell And Base Exchange Rates For Manual Data Entry

Data entered manually (directly) on a generic cost sheet should have a rate associated with it. This is because any transaction that occurs under a shell will be calculated and stamped with two currency rates: the shell currency and Base Currency. The rate in this case will be the conversion rate between the shell currency and Base Currency (the Base Currency is the company currency).

When you modify the exchange rate the new rate takes effect for the currency month, and applies until you change it again. You can revert it to the rate stored in the shell properties. The modified exchange rate applies only to data you enter manually on the sheet. It does not affect data that is entered through business processes, which uses the exchange rate from shell properties.

To change the exchange rates on a Generic Cost Sheet for manual data entry

1. Open the shell and click Configurable Managers > Generic Cost Manager > Generic Cost Sheet in the left Navigator. The Generic Cost Sheet log opens.

2. Open the cost sheet you want to work with by double-clicking the cost sheet name, or by selecting the cost sheet name in the log and then choosing File > Open.

3. Choose Edit > Exchange Rate. The Exchange Rate for manual data entry window opens.

4. Choose the rate you want to change and enter the rate. Click Refresh to revert to the shell property exchange rate as needed. The original exchange rates were set up by the Company Administrator.

5. Click OK.

To view exchange rate history

1. Open the shell and click Configurable Managers > Generic Cost Manager > Generic Cost Sheet in the left Navigator.

2. From the View menu, choose Exchange Rate History.

To view the data in either the shell or Base Currency

1. Open the shell and click Configurable Managers > Generic Cost Manager > Generic Cost Sheet in the left Navigator.

2. Choose View > Currency > Shell Currency or the Base Currency to view the data in either of these currencies.
Export And Import Generic Cost Sheet Data

To export Generic Cost Sheet data

1. In the Generic Cost Sheet, click the Export button.
2. Select the columns to export. These must be manual entry columns only. You can export columns from the current shell only, with the amounts displayed in the shell currency, and based on the display period.
3. Read the confirmation message and then click Yes to continue.
4. You may choose to open the file in a compatible program such as Microsoft Excel to review it before saving.
5. Click Save and specify the location in which to save the CSV file.

Note: If you open the CSV file, you will see that it contains notes regarding modifying the columns and data in the exported file for reimporting into a cost sheet. Follow the notes embedded in the CSV file for modifying columns and data in the exported file.

Import Generic Cost Sheet Data

You can shell cost detail information into a cost sheet manual entry column from a comma-delimited-value (CSV) file, such as a Microsoft Excel spreadsheet saved in CSV format.

To import Generic Cost Sheet information

1. In the Generic Cost Sheet, click the Import button. You can import from the current shell only. Import exception errors can occur if the cost code is not included in the import file, or if the combination of the cost code and effective date is repeated.
2. Browse to the CSV file to import, select it, and click OK.

Working With Generic Cost Business Processes

The Generic Cost Manager can use generic cost BPs as data sources. These BPs are created in Primavera uDesigner. These generic cost BPs work only with the Generic Cost Manager, and also only in the context of a shell. The possible Generic cost BP types are:

- **Generic**: Reference against company-level commit; enforce against company-level commit amount.
- **Transfer**: Transfer value from one code to another.
- **Base Commit**: Creates an entry in the Commitment Summary. Works in conjunction with change commit and general spends generic cost BPs. Reference against company-level commit; enforce against company-level commit amount. Click the Commitment Summary button to access the Commitment Summary.
- **Change Commit**: Works in conjunction with base commit and general spends generic cost BPs. Updates the Commitment Summary. Reference against company-level commit; enforce against company-level commit amount. Click the Commitment Summary button to access the Commitment Summary.
- **General Spends**: Works in conjunction with base commit and change commit generic cost BPs. Updates the Commitment Summary. Click the Commitment Summary button to access the Commitment Summary.
- **Lease**: Works in a shell to manage lease payments and payment history.
View And Edit The Commitment Summary

When a base commit record goes to Terminal status, it creates an entry in the Commitment Summary for the shell. When change commit and general spends records go to Terminal status, they update the associated base commit record in the Commitment Summary. If you have the appropriate permissions, you can view and edit the Commitment Summary.

To view and edit a Commitment Summary for a shell

1. Open the shell and click Cost Manager > Commitment Summary in the left Navigator.
2. In the Commitment Summary log, select the Commitment Summary and click Open.
3. Click Create Structure to add columns to the sheet.
4. To view or edit the sheet properties, choose Edit > Properties. In the General tab, enter a unique name and an optional description. In the Options tab, enter the following column names: Ref, Cost Code, Code Name, Breakdown, and Description. Depending on the design in Primavera uDesigner, some columns may not display in the Commitment Summary sheet.
5. Click OK.

Drill Down From The Commitment Summary To Related BPs

You can view BP information for the various entries in the Commitment Summary.

To drill down from the Commitment Summary to related BPs

1. Open the shell and click > Cost Manager > Commitment Summary in the left Navigator.
2. In the Commitment Summary log, click the BP reference in the Commitment Summary. The Cell Detail window opens.
3. Click the Close Window button when you are done viewing the BP information.
ABOUT THE DOCUMENT MANAGER

The Document Manager provides a robust platform for maintaining a wide variety of files and documents, for example, drawings, spreadsheets, image files, specifications, and various Microsoft Office files. Files can be stored directly in the project or shell Documents node or organized into folders. You can also create shortcuts to commonly used files and folders. The system ensures that all members of your team are always working on the most current versions, and dramatically increases efficiencies by providing ready access to all documents from anywhere at any time.

The Document Manager is available at the project or shell level for project- or shell-specific documents, and at the company level for company-specific or cross-project or shell documents. At project/shell or company level, the Document Manager is integrated with business processes and the user-defined reports module. Files uploaded into the Document Manager are stored on the Primavera Unifier file server.

The Document Manager is integrated with business processes. This means that you can initiate a business process directly from the Document Manager and automatically attach files and folders to it. In addition, if designed to do so, any business process can automatically publish records, along with their comments and attachments, to the Document Manager. In effect, this produces a detailed audit trail of the business process. Depending on how your administrator set up the business process, it can be automatically published to the Document Manager at a specific step in a workflow, or whenever an email notification is sent regarding the status of the business process, or both.

At both the project or shell level and the company level, the Document Manager consists of two nodes:

- **Project or shell/Company Documents**: This is the root node where published documents (that is, documents that are ready to be used by team members) are stored and managed. (The node is labeled project or shell Documents at the project or shell level, and Company Documents at the company level.) You will typically work out of this node when working with your company or project or shell documents. All uploads, downloads, revisions, markups, etc., are performed within this node. Access to specific folders, documents, and shortcuts is independently controlled by permissions.

- **Unpublished Documents**: This is the temporary, automatic repository for files that have been uploaded from local machines and attached to business processes, but which have not yet been published in project or shell documents or company documents. Typically, access to this node is limited by permissions, and a designated document administrator will publish documents from this node into the project or shell or Company Documents nodes for use by team members.

**Note**: By default, files attached to business processes are placed in the Unpublished Documents folder in the Document Manager. A Publish Path data element can be designed in business processes in Primavera uDesigner to specify the automatic publishing of documents to a specified path and override the default. See "About automatic publishing of documents" on page 601 for details.

**Before You Begin**

Before you begin, be sure you have the following defined in your user preferences. (See "User Preferences" on page 16.)

**File Transfer option**: This option affects how files are transferred between your local system and Primavera Unifier.
**File Viewer option:** This option affects how files are opened and viewed within Primavera Unifier.

**Third-party applications:** If you choose the Intermediate or Advanced File Transfer option, you must have the Java plug-in and (for Advanced) the Primavera Unifier File Transfer Utility installed. Use of the AutoVue viewer markup tool also requires installation of Java.

**Permission settings:** Like other modules within Primavera Unifier, access and use of the Document Manager is fully permission based, including for specific files and folders. Contact your project or shell or company administrator regarding general permission access to the Document Manager.

---

**About Ownership And Permissions**

Like other Primavera Unifier modules, access to the Document Manager features is based on permissions set at the module level in Administration mode. Each Document Manager node—project or shell Documents, Company Documents, and Unpublished Documents—have separate permissions. The Unpublished Documents node is controlled by module-level permissions in Administration Mode only.

In the project or shell and Company Documents nodes, access to specific folders, documents, and shortcuts is also independently controlled by permissions that can be set within the Document Manager.

---

**Note:** Folder and document permissions are set at the folder level and can be changed independently or inherited by subfolders and documents. Unlike module-level permissions, permissions set at the folder level can differ from project or shell to project or shell.

The creator of a folder, document or shortcut is, by default, its owner, and has full access (privileges to view, manage, grant permissions, delete, transfer ownership, etc.). The owner must grant other users or groups permission to view and manage these documents, folders, or shortcuts. Otherwise, other users will not have access to them. (Exception: some administrators will have access permissions and will be able to view all items in the document manager.)

For this reason, it is also important to verify the permission settings for all files and folders that you upload, create, revise, check in, copy, or modify to make sure that it is accessible by the people who need them. For example, if one user creates folders, and then another user attempts to move documents among those folders, the move will not be permitted by the system unless that user attempting that move has specific permissions granted (in this case, Copy and Delete to achieve the document move).

For more information about permission settings, See "Modify folder permissions" on page 565, See "Modify document permissions" on page 571, and See "Modify shortcut permissions" on page 575.

**Note:** Document Manager e-mail notifications as set in User Preferences are only sent if the user has at least view permission in the Document Manager node on the item triggering the e-mail, and if the item owner enables e-mail notification. If you make changes in the Document Manager root folder, to get e-mail notifications regarding events in the root folder, you must have at least view permission because the root folder has no owner.

---

**Enable Document Manager-generated E-mail Notification**

As with other modules within Unifier, there are events in Document Manager that can trigger e-mail notifications to other team members. There are three conditions that must be met in order for a user to receive Document Manager e-mails:

- **Folder Properties window, Options tab:** The owner or a user with modify properties permissions on a folder can select the **Send email notification to subscribed users** checkbox on the Options tab.
This option enables notifications to be generated in the first place for items in the folder. That is, select the checkbox to notify users whenever the folder properties are modified. If the checkbox is not selected, no e-mails will be generated for the folder (or subfolders either, unless the box is selected for subfolders).

Selecting or deselecting this checkbox will automatically apply to all subfolders automatically. This option will not override a user’s e-mail subscription selection in User Preferences.

- **Permission setting in Document Manager**: A user has to be explicitly assigned at least view permissions (at the folder or document level in the Document Manager) to the specific folder, document, or shortcut target in order to subscribe to e-mail notifications.

  For example, even if users have full access permission at the module level, they will not get e-mail notifications unless they are on the permission list for the folder, document, or shortcut for which the e-mail notification would normally be generated.

- **E-mail Subscription Preference**: The user must subscribe to the Document Manager e-mail notifications in User Preferences.

The events that can trigger e-mail notifications are document upload, transfer ownership, move, delete, document revise, and folder rename.
AUTOMATIC PUBLISHING OF BUSINESS PROCESS RECORDS TO THE DOCUMENT MANAGER

A business process can be designed to automatically publish its records, along with their comments and attachments, to the Document Manager in a folder the administrator specifies when the business process is set up. In effect, this produces a detailed audit trail of the record information through the business process (for both workflow and non-workflow processes). You can open these records and their information from the Document Manager.

Depending on how the administrator sets up the business process, the record information can be automatically published to the Document Manager when the business process reaches a specific step in a workflow, or whenever an email notification is sent regarding the status of the business process, or both. According to its setup, the business process will publish the record to a designated folder in the Document Manager. If you, as owner of the record, do not have permission for this folder, Primavera Unifier will send the record and its contents to the Unpublished Documents node in the manager. If the record already exists in the folder, Primavera Unifier will publish the record as a revision. If the folder’s path in the business process record is invalid for any reason, the record will be sent to the Unpublished Documents node.
WORKING WITH PROJECT OR SHELL AND COMPANY DOCUMENTS

The project or shell Documents node (in the project- or shell-level Document Manager) and the Company Documents node (in the company-level Document Manager) are the root nodes in which published documents (that is, documents that are ready to be used by team members) are stored and managed. You will typically work out of these nodes when working with your company or project or shell documents. All uploads, downloads, revisions, markups, etc., are performed here.

**Permission-based access:** Similar to a shared network storage drive, access to specific folders, files, and shortcuts is independently controlled by permissions. The user who creates a folder or shortcut, or uploads a file, is, by default, its owner, and has full access (privileges to view, upload, delete, download, etc.). The owner (could be the project or shell or company administrator) can set these permissions to allow or disallow access by other team members. For this reason, it is important to verify the permission settings for all files or folders of which you are the owner to make sure that they are accessible by the people who need them.

**Editing and version control:** The project or shell Documents and Company Documents nodes have check-in and check-out, document lock, and revision history capabilities enabling full version control.

**Use with business processes:** The Document Manager is integrated with business processes. You can initiate a BP from directly within the Document Manager and automatically attach selected files and folders.

**Reporting:** In addition, document and folder properties are associated with data elements, and are therefore fully reportable through user-defined reports.

**Note:** The Document Manager does not support multibyte or Unicode characters in file names.

---

**Access Project Or Shell Documents And Company Documents**

**To access project or shell documents**

1. Open a project or shell and click Document Manager in the left Navigator.
2. Click Documents.

**To access company documents**

1. Go to the Company Workspace tab and click Document Manager in the left Navigator.
2. Click Company Documents.

**Project Or Shell Documents And Company Documents Navigation**

Document Manager navigation works the same way at the company level and the project or shell level. There are two panes in the project or shell and Company Documents node:

**Folder view (or folder tree):** Displays the project or shell or company documents folders and subfolders, similar to a network or local drive. Click the plus sign (+) next to the folder name to expand it and reveal subfolders, or click the minus sign (-) to collapse the structure. The order of the folders in this view can be changed (See "Organize folders" on page 567).
Project, shell, or company documents log (or document view): Displays the contents (subfolders, documents, empty documents, shortcuts) of the folder selected in the Folders view, in alphabetical order. The pane also displays the Recycle Bin, which contains files to be deleted from the system.

At the project or shell level, a Phase drop-down menu at the top of the pane allows users to display documents and folders applicable to the current phase or all phases (referring to the project or shell phase as maintained by the project or shell administrator; your project or shell may or may not contain phase-specific documents).

Tip: You can expand the project or shell Documents or Company Documents log and workspace by contracting the Primavera Unifier Navigator.

Project Or Shell Documents And Company Documents Logs

The project or shell Documents and Company Documents logs display attributes about the documents and folders listed in them.

The log can be designed in Primavera uDesigner if the folder and document properties have been designed. The following shows the default display of the project or shell Documents and Company Documents logs. The log used in your Document Manager may vary. You may need to use the horizontal scroll bar to view all of the columns.

<table>
<thead>
<tr>
<th>Icon/Column Heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Folder Icon]</td>
<td>The folder or document-type or shortcut icon. The document icons shown in this example are for a bitmap, a formatted document, and a text file.</td>
</tr>
<tr>
<td>![Comment Icon]</td>
<td>Indicates that the file has comments.</td>
</tr>
<tr>
<td>![Lock Icon]</td>
<td>Indicates that the file is locked or unlocked.</td>
</tr>
<tr>
<td>Ref (check or X)</td>
<td>A checkmark indicates that reference files exist and are resolved; an X indicates that there are missing reference files.</td>
</tr>
<tr>
<td>BP</td>
<td>An icon indicates that the document is attached to one or more BP records.</td>
</tr>
<tr>
<td>Name</td>
<td>The file name of the document and its extension (file type).</td>
</tr>
<tr>
<td>Size</td>
<td>The size of the file.</td>
</tr>
<tr>
<td>Upload Date</td>
<td>The date the file was uploaded into project or shell Documents.</td>
</tr>
<tr>
<td>Owner</td>
<td>Owner of the document, folder, or shortcut.</td>
</tr>
<tr>
<td>Title</td>
<td>The identifier given to the document upon uploading, which may differ from the file name.</td>
</tr>
<tr>
<td>Rev. No.</td>
<td>An optional, manually entered revision number (or version number) of the document.</td>
</tr>
<tr>
<td>Issue Date</td>
<td>An optional date and time stamp that the user can define at the time of upload or checking in a file, to identify the issue or publication date outside of Primavera Unifier.</td>
</tr>
<tr>
<td>Pub. No.</td>
<td>This system-generated number identifies the number of times the document has been published.</td>
</tr>
</tbody>
</table>
### Icon/Column Heading

<table>
<thead>
<tr>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>The folder or document-type or shortcut icon. The document icons shown in this example are for a bitmap, a formatted document, and a text file.</td>
</tr>
<tr>
<td>in the Document Manager. Upon initial upload, the Pub. No. is 1; if it is checked out, revised, and checked back in, it becomes 2, etc.</td>
</tr>
<tr>
<td>% Complete</td>
</tr>
<tr>
<td>Publication Date</td>
</tr>
<tr>
<td>Location</td>
</tr>
</tbody>
</table>

### Menu Bar

The following describes the functions available from the project or shell Documents or Company Documents menu bar.

#### File Menu

<table>
<thead>
<tr>
<th><strong>Menu Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Create new folder, file, empty document, shortcut, or business process record.</td>
</tr>
<tr>
<td>Open</td>
<td>Open folders, documents, or shortcuts.</td>
</tr>
<tr>
<td>Upload</td>
<td>Add files and folders to the Document Manager from your local drive.</td>
</tr>
<tr>
<td>Download</td>
<td>Download copies of documents and folders to your local drive.</td>
</tr>
<tr>
<td>Export</td>
<td>Export a document or folder structure and property information in a CSV file.</td>
</tr>
<tr>
<td>Import</td>
<td>Import a folder structure template from within Primavera Unifier, or folders, empty documents and properties in a CSV file.</td>
</tr>
<tr>
<td>Recycle Bin</td>
<td>View, restore, or delete the contents of the Recycle Bin.</td>
</tr>
<tr>
<td>Index Report</td>
<td>Easily run or print a report showing the contents of a selected folder and phase and category information in HTML, PDF, or CSV format.</td>
</tr>
</tbody>
</table>

#### Edit Menu

<table>
<thead>
<tr>
<th><strong>Menu Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Transfer Ownership</td>
<td>Transfer the ownership of a folder or document to another user.</td>
</tr>
<tr>
<td>Move</td>
<td>Move documents, folders, and shortcuts.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copy documents, folders, and shortcuts.</td>
</tr>
</tbody>
</table>
Menu Option | Description
---|---
Rename | Rename folders and shortcuts.
Delete | Delete documents, folders, and shortcuts.
Properties | View or edit folder or document properties.
Permissions | View or define permissions for other users to access folders, documents, and shortcuts.
Revise | Upload a revised document from your local system and replace the current version of the document in the Document Manager. The older version is accessed in the View Revisions window.
Check In | Check in documents that you have previously checked out. If the document was revised and checked back in, the Pub. No. is updated.
Check Out | Check out a document to edit, or add markups or comments.
Cancel Check Out | Cancel checkout of a document without saving any edits or comments.
Lock | Lock documents to prevent editing by other users.
Unlock | Unlock locked records.
Organize Folders | Move folders within the folder structure.

View Menu
Menu Option | Description
---|---
Comments | Add or view comments on documents and file attachments on documents.
References | Refers to reference files associated with a base drawing file (DWG or DGN format). A checkmark in this column indicates that all the reference files are resolved; an X indicates there is at least one missing reference file.
Linked BP Records | Display list of business process records to which a selected document is linked.
Revisions | Access previous revisions of a selected document.
Audit Log | View the audit log (history of actions) for folders, documents, and shortcuts.
Find | • **Properties**: Search for documents, folders, or shortcuts by information that is part of their properties, e.g., name, owner, etc. Data that can be searched on can be customized by the project or shell Manager.
        • **Content**: Search by content, or keywords, within documents.
Filter By | Filter how documents are displayed in the log. Affects a selected folder and its subfolders.
        • **All**: Displays all contents of the selected folder. Subfolder contents are not displayed unless they are selected.
        • **Locked**: Displays locked documents in the selected folder and subfolders.
        • **Unlocked**: Displays contents of the selected folder, except for locked documents.
        • **Published Today**: Displays documents that have been published today to the selected folder and subfolders.
        • **Checkout Out By Me**: Displays documents in the selected folder and subfolders that are currently checked out by you.
**Toolbar**

You can perform the following functions from the toolbar. Click the down arrow next to a button to view the options.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
</table>
| **New**  | • **Folder**: Creates new folder or subfolder in the selected folder.  
• **Document > File**: Uploads the file to the selected folder.  
• **Document > Empty Document**: Creates an empty document in the selected folder.  
• **Business Process**: Creates a new BP record with the selected documents attached. |
| **Open** | Opens the selected folder or document (document opens in the native application or AutoVue viewer, depending on the File Viewer option in your User Preferences).                                      |
| **Find** | • **Properties**: Search for documents, folders, or shortcuts by information that is part of their properties, e.g., name, owner, etc.  
• **Content**: Search by content, or keywords, within documents.                                                                                           |
| **Upload** | Uploads files and folders from your local machine into the Document Manager.                                                                                                                                   |
| **Download** | Downloads files and folders to the local machine.                                                                                                                                                     |
| **Delete** | Deletes the selected file or folder (moves it to Recycle Bin).                                                                                                                                         |
| **Check Out** | Allows you to check out documents for editing or markup.  
• **Check In**: Check in documents (with changes). This automatically updates the documents Pub. No.  
• **Cancel Check Out**: Cancel the check-out status without saving changes.                                                                 |
| **Comments** | Opens the File Comments window for the selected document. Add or view comments, markups, or attach another file to a document.                                          |
| **Permissions** | Configure user permissions for the selected document, folder or shortcut.                                                                                                                                   |
| **Properties** | View or add properties to the selected document, folder, or shortcut.                                                                                                                                    |

**Search For A Document, Folder, Or Shortcut**

There are two ways to find items in project or shell Documents or Company Documents:

• **Search by Properties**: This searches on specific properties (metadata) of the document, empty document, folder, or shortcut being searched for. The default search options are name, owner, title, revision number (documents), and upload by (user who uploaded the item).

**Note**: This search option can be customized through Primavera uDesigner. If a designer has imported Document Managers attribute forms, the search criteria can also be customized. This means that the fields on which you can search may differ from the above list.

• **Search by Content**: This allows you to search for a document by specific content, or keywords, within the document. This option works on most file types other than drawing files. You can search by single word or exact phrase in quotes (for example, “training document”).
The supported file types for content search are listed below:

doc, pdf, txt, xls, htm, rtf, html, csv, xml, xsd, java, c, cpp, vm, bat, bak, css, log, sql, ncs, sh, properties, vpp, wtx, xhtml, xslt, ppt, mpp, vsd

The Find function works on the latest revisions of documents only. It does not search on older revisions.

To search for documents, folders, or shortcuts by properties

1. In the folder view, select the folder in which to perform the search. The search will be performed on the selected folder and its subfolders. To search all folders, select the project or shell Documents node.

2. Click the Find button and choose Search By Properties, or click the View menu and choose Find > Search By Properties. The upper portion of the log expands to display the Find fields.

3. Enter search criteria in one or more of the Find fields, for example, the full or partial name of a file. You can use the wildcard % when searching for names.

4. Click the Search button. The log will display the search results.

5. To search the contents of another folder, select it in the folder view. The search results will automatically display the search results of the new selected folder.

6. To close the Search fields, click the X in the upper right corner.

To search for documents by content

1. Select the folder in which to perform the search. The search will be performed on the selected folder and its subfolders. To search all folders, select the project or shell Documents or Company Documents node.

2. Click the Find button and choose Search By Content, or click the View menu and choose Find > Search By Content.

3. Enter one or more keywords to search for within the documents.

4. Click the Search button. The log will display the search results on the folder selected and its subfolders in the folder tree.

5. To search the contents of another folder, select it in the folder tree. The search will be automatically executed again when you select any other folder in the folder tree.

6. To close the Search fields, click the X in the upper right corner.

Note: Modifications to files, folders, or documents (such as uploading, renaming, moving, etc.) may not be reflected in the search results immediately as the index file associated with the content search is updated.

Tip: For best results, use only alpha-numeric characters in your search criteria. If you are not receiving the search results you are expecting, try placing your criteria in quotes.

Display Folders By Project Or Shell Phase

This is applicable to the project or shell level Document Manager only, as phase is not applicable at the company level.
A project or shell Documents folder can be associated with one or more project or shell phases, which will make it accessible only during specific phases of a project or shell. This helps ensure that important, phase-specific documents are visible at the appropriate times during the life cycle of the project or shell.

For example, if a folder or subfolder is associated with the construction phase of a project or shell, then it will appear in the project or shell Documents folder view and log for the project or shell only when the project or shell is in that phase.

If a phase has not been designated on a folder or subfolder, it will display for all project or shell phases.

The folder’s phase is designated in the Phase selection box in the folder’s Properties window. The project or shell phase is maintained in the project or shell Properties window by a project or shell administrator.

You have the option to view folders for the current project or shell phase, or you can choose to view all folders regardless of project or shell phase.

**To display folders by project or shell phase**

1. Open the project or shell and open the Document Manager in the left Navigator.

2. At the top of the folders view, do one of the following:
   - To display folders for the current phase, be sure that Current Phase is selected on the Phase drop-down menu (this is the default selection). Folders and subfolders that have been associated with the current phase of your project or shell, as well as those with no specific phase designation, will be displayed. Those that have been associated with a different project or shell phase will not display.
   - To display folders for all project or shell phases, click the Phase drop-down menu and select All Phases. All folders, regardless of project or shell phase, will display.

**View Folder Contents**

**To view folder contents**

In the folders view, click a folder to select it. The contents of the folder appear in the project or shell or Company Documents log. If a folder has a plus sign (+), click it to reveal subfolders.

**Creating And Managing Folders**

If you have proper permissions, you can create any number of folders and subfolders to organize documents and shortcuts. Folders can be created in various ways:

- Manually create a folder.
- Upload folders from your local machine.
- Import folders from a CSV file.
- Create folders in a project or shell template (Administration Mode). When a new project or shell is created from the template, the folder structure will be copied.
- Import a folder structure from a folder structure template.

**Note:** You must have permission to create or modify folders to perform the following procedures.

**About Locked Folder Structures**

The document administrator (the project or shell or company administrator or other designated user with full administrative permissions) has the ability to lock the first-level folder structure. First level
refers to folders and documents directly under the root folder. It does not refer to the sub-folders within the first-level folders.

Locking the first level folder structure prevents other users from adding, modifying, or deleting folders and documents on the first level, or changing the document or folder properties. Users can modify permissions on first-level folders and documents.

This ability allows the administrator to establish and maintain a consistent main folder structure within and across project or shells.

To check if the first-level folder structure is locked

1. Open the Document Manager and click Documents or Company Documents in the left Navigator.
2. Click Properties and choose the Options tab.
3. Scroll to the bottom of the window. If the Lock first level folder structure below project or shell Documents checkbox is selected, the first-level folder structure is locked.

Create A Folder

When you create a folder, you become its owner by default and have full read, write, and edit privileges. In order for other users to access the folder and its contents, you must grant permission. It is recommended that you understand the permissions settings before creating folders.

You can also easily create multiple folders under the same parent folder and with similar properties.

Note: It is possible for the first-level folders to be locked by a document administrator, which prevents folders directly under the project or shell or Company Documents node from being changed or added. This prevents the main folder structure from being altered. Subfolders can be added to existing folders.

To create a new folder in the project or shell or Company Documents node

1. Select the folder in which you want to create the new folder, or the project or shell or Company Documents root node.
2. Click the New button (or click File > New > Folder). The Create Folder window opens. The Create Folder window is identical to the Folder Properties window, which can be viewed for existing folders.
3. In the General tab, enter a name for the folder. The other fields are system-defined or optional.
4. The Options tab fields are optional.
5. Click Add. The new folder is created.

To create multiple folders in the same parent folder

1. In the Create Folder window, click the Create Multiple button. This allows you to create multiple folders with similar properties.
2. Add the information in the General and Options tabs for the first folder.
3. When the General and Options tabs are complete for the first folder, click the Create button. The first folder will be created and the Create Folder window will remain open.
4 Give a new name to the second folder and verify the other information in the General and Options tabs. (By default, the same as the first folder, but can be modified.) Click Create to create the second folder.

5 Continue to create folders as needed.

6 Close the Create Folder window when you are done creating folders.

Folder Properties Window

The following section describes the default fields in the Folder Properties window (also called the Create Folders window). There are two tabs:

**General**: If your company has designed and imported a folder attributes form, it will be used for the General tab. The example below shows the default General tab. All property fields are data elements, and therefore are reportable in user-defined reports.

**Options**: This tab contains options for uploading and downloading folders and drawing reference files. The Options tab is not customizable in Primavera uDesigner.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This always appears at the top and is mandatory. For the project or shell Documents or Company Documents root folder, this is not editable.</td>
</tr>
<tr>
<td>Location</td>
<td>The folder location within the project or shell Documents node. “/” indicates the project or shell Documents root folder.</td>
</tr>
<tr>
<td>Owner</td>
<td>The name of the folder creator or current owner. Click to view the user profile.</td>
</tr>
<tr>
<td>Creation Date</td>
<td>The date that the folder was created.</td>
</tr>
<tr>
<td>% Complete</td>
<td>This is a calculated field derived from the overall percent complete of all documents within the folder. The % Complete for documents is maintained manually in the Document Properties window.</td>
</tr>
</tbody>
</table>

The Folder Properties window, General tab
### Description
You can enter an optional description for the folder.

### Categories (applicable to project-level Document Manager only)
Project administrators can group folders into customized categories. Category designations are not searchable using Find, but they are reportable in user-defined reports. This field is not present at the company level.

### Phases (applicable to project or shell level Document Manager only)
In the project or shell level Document Manager, a folder can be associated with one or more project or shell phases, making it accessible only during those phases of the project or shell. This helps ensure that important, phase-specific documents are visible at the appropriate times during the life cycle of the project or shell. Click the **Select** button and select one or more phases.

**Caution:** The Phase setting controls the visibility of folders. For example, if the project or shell administrator sets the project or shell phase to conceptual design, then only those folders tagged with the phase conceptual design, as well as those without a phase tag, will be visible during that phase. If you do not specify a phase, the folder will display during all project or shell phases.

### Apply these options to all subfolders and documents
For categories and phases. If you select this option for the current folder, then all new and existing subfolders and documents within the folder will be modified when the window is saved.

---

**The Folder Properties window, Options tab**

### Folder Upload
- **Upload files only**
  - Default selection; when a folder is selected for upload, only the files within it are uploaded, not the folder itself.
<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upload folders and files</td>
<td>Allows uploading of both files and folders.</td>
</tr>
<tr>
<td>Document Upload</td>
<td></td>
</tr>
<tr>
<td>Do not include references</td>
<td>Applies to drawing reference files. If this option is selected, reference files will not be uploaded automatically with their base files.</td>
</tr>
<tr>
<td>Include references</td>
<td>Reference files will be uploaded automatically with their base files based on the option selected:</td>
</tr>
<tr>
<td></td>
<td>• Upload References from My Computer: Searches for reference files on the local machine based on the path defined in the base file header.</td>
</tr>
<tr>
<td></td>
<td>• Auto-resolve from project or shell Documents as Dynamic Links: Searches for reference files already present in project or shell documents and links dynamically. If the reference file is revised, the newer version is used.</td>
</tr>
<tr>
<td></td>
<td>• Auto-resolve from project or shell Documents as Static Links: Searches for reference files already present in project or shell Documents and links statically. If the reference file is revised, the newer version is ignored.</td>
</tr>
<tr>
<td>Folder Download</td>
<td></td>
</tr>
<tr>
<td>Download files only</td>
<td>Default selection; when a folder is selected for download, only the files within it are downloaded, not the folder itself.</td>
</tr>
<tr>
<td>Download folders and files</td>
<td>Allows downloading of both files and folders.</td>
</tr>
<tr>
<td>Document Download</td>
<td></td>
</tr>
<tr>
<td>Do not include references</td>
<td>Do not download drawing reference files automatically with base files.</td>
</tr>
<tr>
<td>Include references</td>
<td>Reference files will be downloaded automatically with their base files based on the option selected:</td>
</tr>
<tr>
<td></td>
<td>• Download references to same folder as Base file</td>
</tr>
<tr>
<td></td>
<td>• Download references to Logical Path specified in Base file: As defined in the base file header information</td>
</tr>
<tr>
<td>Send email notification to subscribed users</td>
<td>Select this box if you want the owner to receive an e-mail notification whenever the folder properties are modified. If you select or deselect this box on a folder, the checkbox will update on all subfolders automatically. This option will not override users’ e-mail subscription selections in user preferences. Users also have to have at least view permissions on the specific folder or document to get the notification.</td>
</tr>
<tr>
<td>Apply these options to all sub-folders (and documents”)</td>
<td>This is unchecked by default. If this option is selected, the upload or download options will apply to all new and existing subfolders (and documents if specified) when the options are saved.</td>
</tr>
<tr>
<td>Lock folder structure for the first level below project or shell Documents</td>
<td>This option appears only for the root project or shell Documents folder. It disallows the addition, modification, or deletion of any first-level folder: folders that are directly under the project or shell Documents node. Subfolders can still be added to the first-level folders. The administrator can unlock the structure to make changes to first-level folders if necessary.</td>
</tr>
</tbody>
</table>

**View Or Modify Folder Properties**

You can view or modify (with proper permissions) the folder properties of existing folders. When you create or upload a folder, you become its owner, and have full access to the folder and its contents.
To view or modify folder properties

1 In the folders view or project or shell or Company Document log, select any folder or subfolder, or the project or shell or Company Documents root folder.

2 Click the Properties button. The Folder Properties window opens.

Modify Folder Permissions

When you create or upload a folder, you become its owner and have full access to the folder and its contents.

Setting permissions at the folder level allows you to grant other users access not only to the selected folder, but also (optionally) its contents as well, such as subfolders, shortcuts, and documents. You also have the option of setting individual permission settings to specific shortcuts and documents within the folder, as discussed in the documents and shortcuts sections.

Note: You many want to add yourself to the permissions list. Though not necessary as long as you remain the owner, if you decide later to transfer ownership of the folder, you will no longer have owner permissions. However, you will retain the permissions, if any, that you specify in the permission window.

Note: The project or shell Documents root folder is selectable for modifying permissions.

To modify folder permissions

1 Select the folder in the document log or folder tree and click the Permissions button. The Edit Permissions window opens.

If the Inherit permissions from the parent folder checkbox at the top of the window is selected, then the folder-level permissions will apply automatically and cannot be modified.

2 To modify the folder permissions, deselect Inherit permissions from the parent folder.

3 Do any of the following:
   • To add a new user, click Add and add users or groups to grant permission. Select the user from the list and grant or remove individual permissions (see below).
   • To remove a user’s permissions, select the user from the list and click Remove.
   • To modify a user’s permissions, select the user from the list and grant or remove individual permissions.

4 Select permissions to add to the user or group. The folder permissions apply to the folder and subfolders within it. Document permissions apply to the documents within the folder.

5 If you want these permissions to apply to the documents and folders within the selected folder, select the Apply these permissions to documents and subfolders checkbox.

If this is a subfolder, you can leave this deselected if you want the parent folder permissions to apply. If you select this box, these permissions will take precedent.

6 Click OK.
Edit folder permissions

**Copy A Folder**

You can copy a folder from one location to another. When you copy a folder, you become the owner with ownership permissions of the copied folder and its contents. The owner of the original folder and other users with permissions to the original folder retain their permissions on the original and the copied folder. You can copy more than one folder at a time.

**To copy a folder**

1. Select one or more folders in the project or shell Documents log.
2. Click the **Edit** menu and choose **Copy**. The Copy Files/Folders window opens.
3. Select the target location from the folders shown.
4. Select the **Include Comments** checkbox if you want to copy any comments or markups that may be on documents within the copied folder.
5. Click **OK**. The folder and all contents (subfolders, documents, shortcuts) are copied to the target location.

**Move A Folder**

If you are the owner of the folder (or otherwise have proper permissions), you can move a folder to a new location. When you move a folder from one location to another, all subfolders, documents, and any comments or markups on the documents are moved to the new location. Original ownership and user permissions are maintained. You can move more than one folder at a time.

**To move a folder**

1. Select one or more folders in the project or shell Documents log.
2. Click the **Edit** menu and choose **Move**. The Move Files/Folders window opens.
3. Select the target location from the folders shown.
4. Click **OK**. The folder and its contents are moved to the target location.
Organize Folders

If you have the permission settings, you can quickly move folders up and down the folder tree using the organize folders feature. This only reorganizes the folder order on the folder tree (left pane). The documents view (the right pane) always lists folders alphanumerically.

**Note:** Unless you have module-level organize permission, you will not be able to move first-level folders if the first-level structure is locked.

To organize folders

1. In project or shell Documents, click **Edit > Organize Folders**. The Organize Folders window opens, displaying the project or shell documents folder structure.

2. You can expand folders to display subfolders by clicking the + next to the folder name.

3. Select a folder and click **Move Up** or **Move Down** as needed. Any subfolders will move with the selected folder.

4. Click **OK**.

Rename A Folder

To rename a folder

1. Select the folder in the project or shell Documents log.

2. Click the **Edit** menu and choose **Rename**. The Rename Folder window opens.

3. Enter the new folder name in the **To** field and click **OK**.

Delete A Folder

When you delete a folder, it is moved to the Recycle Bin. Items in the Recycle Bin can be restored back to their original location or permanently deleted. See “The Recycle Bin” on page 596. You can delete more than one folder at a time.

**Note:** Documents attached to business processes cannot be deleted. Therefore, in order to delete a folder that contains a document that cannot be deleted, you must first move that document to a different location.

To delete a folder

1. Select one or more folders in the project or shell Documents log.

2. Click the **Edit** menu and choose **Delete**, or click the **Delete** button on the toolbar.

3. Click **Yes** to confirm. The folder and contents are moved to the Recycle Bin.

Creating And Managing Documents

A document refers to a file that is uploaded into Primavera Unifier and stored in the Document Manager. A document in the Document Manager can be thought of as a container of the file that was uploaded.
**View And Open Documents**

Documents can be stored in folders or directly in the root project or shell Documents or Company Documents node. The folders view displays folders and subfolders. The project or shell Documents log displays the contents of the selected folder, including subfolders, documents, and shortcuts.

Documents can be opened in two ways from within Primavera Unifier:

- **Native:** Documents are opened in their native applications; for example, Microsoft Word documents are opened in Microsoft Word. This option requires that users have the native application installed on their machine in order to view the document.
- **Primavera Unifier viewer:** Documents are displayed in the AutoVue viewer, which can display virtually any type of file. Documents are opened in a read-only view that supports adding graphical markups and text comments.

The File Viewer option is set in the User Preferences window, Options tab.

**To view a document**

1. Select a folder or subfolder (or the project or shell Documents root folder) in the folders view. The contents of the folder, including any documents, display in the project or shell Documents log.

2. In the log, select a document and click **Open** on the button bar, or double-click the document. The document opens in the AutoVue viewer or native application, depending on the File Viewer option selected in User Preferences.

**Create An Empty Document**

Empty documents are used as placeholders for documents that have yet to be uploaded into Document Manager. For example, a project or shell manager might create an empty document in a folder and then send an action item to a team member to upload the file into it.

You can also import empty documents. See "Import and export folders, properties, and empty documents" on page 585.

Empty documents can be populated with files by revising them (replacing the empty document with the completed document. See "Revising Documents" on page 593.

**To create an empty document**

1. From the **File** menu, click **New > Empty Document**. The Create Document window opens.

2. Enter a name for the empty document. The other fields in the General tab and the Options tab are optional.

3. Click **Add**. The empty document is created.

**Note:** To upload a file into the empty document, See "Uploading Files" on page 577.

**Document Properties Window**

Like the Folder Properties window, the fields in the General tab of the Document Properties window can be customized in Primavera uDesigner by designing and importing a custom attributes form at the company level. This window opens when viewing document properties and when creating an empty document.

All properties fields are data elements, and therefore are reportable in user-defined reports. Text comments attached to documents are also reportable.
The following section describes the default fields in the Folder Properties window (also called the Create Folders window). There are two tabs:

**General**: If your company has designed and imported a document attributes form, it will be used for the General tab. The example below shows the default General tab. All properties fields are data elements, and therefore are reportable in user-defined reports.

**Options**: This tab controls revision behavior. The Options tab is not customizable in Primavera uDesigner.

### Document Properties window, General tab (default view)

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The file name with extension (for example, .doc or .xls).</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the document within the Document Manager folder structure.</td>
</tr>
<tr>
<td>Title</td>
<td>A title given to the document, which can differ from the file name, and can be more descriptive than the file name.</td>
</tr>
<tr>
<td>Revision No.</td>
<td>Manually entered version number. This differs from the publication number (Pub. No.), which is Primavera Unifier’s method of keeping track of saved revisions within the Document Manager.</td>
</tr>
<tr>
<td>Issue Date</td>
<td>This optional date and time stamp is also manually entered, referring to the original release date of this version of the document, and not the date the file was uploaded or checked into Primavera Unifier.</td>
</tr>
<tr>
<td>Publication No.</td>
<td>Number of times the file has been published within Primavera Unifier. Original upload is 1. If it is revised, the publication number becomes 2, and so on.</td>
</tr>
<tr>
<td>% Complete</td>
<td>Allows you to manually keep track of the progress of in-process documents. The percent values of all documents within a folder are averaged and rolled up to the Folder Properties window. The default value is 0%.</td>
</tr>
<tr>
<td>Description</td>
<td>You can enter an optional description for the document.</td>
</tr>
<tr>
<td>Owner</td>
<td>The user who uploads the file into Primavera Unifier becomes its owner by default. Ownership can be</td>
</tr>
</tbody>
</table>
In this field | Do this
--- | ---
| transferred to another user (permissions apply).

Upload By | The user who uploaded the file to the Document Manager.

Creation Date | System-generated date that the document was created. This may be the original file upload or creation of an empty document before the file was uploaded.

Size | File size, in kilobytes.

Categories | Categories are used to tag folders and documents with common keywords that are used to organize, categorize, and search for them. This is optional.

---

| In this field | Do this
--- | ---
| Revisions must have same file name | Checking this option will prevent the document from being revised unless the new version has the same file name as the original. When a file is dynamically linked as a reference file to a base drawing file, this checkbox is selected by default for the reference file and cannot be deselected.

---

**View Or Modify Document Properties**

You can view or modify (with proper permissions) the Document Properties of uploaded files and empty documents. You can also import properties values. See "Import and export folders, properties, and empty documents" on page 585.

**To view or modify document properties**

1. Select the document in the project or shell Documents log.
2. Click the **Properties** button. The Document Properties window opens.
3. Modify the properties as needed.
4. Click **OK**.
**Note:** The Administrator can specify values on the Document Attribute form (for Document Properties) that enable auto-sequencing (auto-numbering of documents). You can use document auto-numbering on documents across the Company level or the project/shell level. For example, the Administrator can specify that a Document Name field uses auto-sequencing in order to give each document a unique number as it is created. The auto-numbering occurs when you click **Apply** or **OK** in the Document Properties window. Later, you can view the auto-numbering of the document by clicking the Properties button to view the Document Properties.

**Modify Document Permissions**

When you upload a document, or publish a document from unpublished documents, you become its owner and have full access to it. You can grant other users access to it.

If you have granted folder-level permission to other users and allowed the permission to apply to the contents of the folder, those permissions will apply to the documents that you add to it automatically. They will appear as selected in the document permissions window. However, you can modify these permissions per document if needed.

**To modify document permissions**

1. Select the folder in the document log or folder tree and click the **Permissions** button. The Edit Permissions window opens.

   If the **Inherit permissions from the parent folder** checkbox at the top of the window is selected, the folder-level permissions will apply automatically and cannot be modified.

2. To modify the folder permissions, deselect **Inherit permissions from the parent folder**.

3. Do any of the following:
   - To add a new user, click **Add** and add users or groups to grant permission. Select the user from the list and grant or remove individual permission.
   - To remove a user’s permissions, select the user from the list and click **Remove**.
   - To modify a user’s permissions, select the user from the list and grant or remove individual permissions.

4. Select the permissions settings for the document and click **OK**.
Copy A Document

A document can be copied from one location to another, with the option to include any comments or markups associated with it. You can select and copy multiple documents or folders at once. If you copy a document owned by another user, you become the owner of the copy, and the original owner maintains original permissions on the original and copied versions.

**Note:** You must select a destination folder that is different from the source folder. You cannot copy a document into the same location you are copying it from.

To copy a document

1. Select the document in the project or shell Documents log.
2. On the Edit menu, click **Copy**. The Copy Files/Folders window opens.
3. Select the destination folder into which you want to place the document copy.
4. To copy with comments or markups attached to the document, select the **Include Comments/Markups** checkbox.
5. Click **OK**.

Move A Document

When a file is moved, any comments or markups are moved with it automatically. You can select and move multiple documents or folders at once.

To move a document

1. Select the document in the project or shell Documents log.
2. On the Edit menu, click **Move**. The Move Files/Folders window opens.
3. Select the target folder into which you want to move the document.
4. Click **OK**.
**Rename A Document**

Documents cannot be renamed from within Primavera Unifier. You can change the title of a document through the Properties window, but not the file name.

**Delete A Document**

When you delete a document, it is moved to the Recycle Bin. Items in the Recycle Bin can be restored to their original location or permanently deleted. You can select and delete more than one document at once.

A document that is attached to a business process record is linked to it and cannot be deleted from the Document Manager. The document will show a linked records icon next to the document in the BP column of the document log. However, if the latest version of the document is not linked to a business process, the icon will not display in the log. You can select the document and click **View > Revisions** to check if an older revision has linked records. In addition, a document may also contain links to business processes that are still in draft, and which will not display as a link to the document until the BP record is sent.

**Caution:** Use caution when deleting drawing base or reference files. Deleting a linked reference file will cause the file to be marked as missing on the corresponding base drawing file.

**Tip:** If you need to remove a document that cannot be deleted, move it from its original location into another folder with limited user access.

To delete a document

1. Select the document in the project or shell Documents log.
2. Click the **Edit** menu and choose **Delete**, or click the **Delete** button.
3. Click **Yes** to confirm. The document is moved to the Recycle Bin.

**Creating And Managing Shortcuts**

You may create convenient shortcuts to frequently used documents or folders.

Document and folder permissions always take precedence. That is, you must have the proper permissions to view, open, or modify the document or folder to which the shortcut is pointing.

**Use Shortcuts**

Shortcuts are a convenient way to quickly navigate to important or frequently used documents and folders. They can be used to quickly access and view a document or folder. Shortcuts cannot be downloaded.

**Note:** If a folder or document is moved, any shortcuts that have been created for it will point to the new location. However, if you rename or delete a document or folder, any associated shortcuts will not be automatically modified. Users who try to use a shortcut to a document or folder that has been renamed or deleted will see an error message.

**To use a shortcut**

Do one of the following:
• Select the shortcut in the project or shell Documents log and click Open.
• Double-click the shortcut.

If the shortcut is to a folder, the folder opens in the folders view, displaying the contents. If the shortcut is to a document, the document opens.

Create A Shortcut

You may create a shortcut to a document or a folder. Clicking a shortcut to a folder displays the folder contents. Clicking a shortcut to a document opens the document for viewing.

Tip: For ease of use, create shortcuts to commonly used documents and folders and store them in a central folder.

To create a shortcut

1 In the folders view, navigate to the folder in which you want the shortcut to reside.
2 Select New > Shortcut. The Create Shortcut window opens.
3 In the Source field, click the Browse button. The Select Files window opens.
4 Browse to the document or folder for which you want to create the shortcut.
   If you have left the Name field blank, the shortcut name defaults to “Shortcut to document/folder name” and can be changed.
5 Click OK. The shortcut is created in the selected folder.

Shortcut Properties Window

The Shortcut Properties window consists of the name of the shortcut as it appears in the project or shell Documents log and the path of the document or folder to which it points. It is not customizable in Primavera uDesigner. This window is also called the Create Shortcut window.
<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the shortcut, as displayed in the log.</td>
</tr>
<tr>
<td>Source</td>
<td>The path of the file or folder to which the shortcut points. You can click the <strong>Browse</strong> button to change the source.</td>
</tr>
</tbody>
</table>

**View Or Modify Shortcut Properties**

**To view or modify shortcut properties**

1. In the project or shell Documents log, select the shortcut.

2. Click the **Properties** button. The Shortcut Properties window opens.

**Modify Shortcut Permissions**

When you create a shortcut, you become its owner and have full access to it. You can grant other users access to it. A shortcut will have limited permission settings related to the document or folder to which it points.

If you have granted folder-level permission to other users and allowed the permission to apply to the contents of the folder, those permissions will apply to the documents that you add to it automatically. However, you can modify these permissions per document if needed.

**To modify shortcut permissions**

1. Select the document in the document log and click the **Permissions** button. The Edit Permissions window opens.

   If the **Inherit permissions from the parent folder** checkbox at the top of the window is selected, the folder-level permissions will apply automatically and cannot be modified.

2. To modify the permissions to the shortcut, deselect **Inherit permissions from the parent folder**.

3. Do any of the following:
   - To add a new user, click **Add** and add users or groups to grant permission. Select the user from the list and grant or remove individual permission.
   - To remove a user’s permissions, select the user from the list and click **Remove**.
   - To modify a user’s permissions, select the user from the list and grant or remove individual permissions.

4. Select the permissions settings for the document and click **OK**.
Copy A Shortcut

To copy a shortcut

1. Select the shortcut in the project or shell Documents log.
2. On the Edit menu, click Copy. The Browse to Copy window opens.
3. If the target folder is phase-specific (only appears during specified project or shell phases), click the Current Phase drop-down menu and choose the project or shell phase.
4. Select the target folder into which you want to place the shortcut copy.
5. Click OK.

Move A Shortcut

To move a shortcut

1. Select the shortcut in the project or shell Documents log.
2. On the Edit menu, click Move. The Move Files/Folders window opens.
3. Select the target folder into which you want to move the shortcut.
4. Click OK.

Rename A Shortcut

To rename a shortcut

1. Select the shortcut in the project or shell Document log.
2. From the Edit menu, click Rename.
3. Enter the new name and click OK.
Delete A Shortcut

When you delete a shortcut, it is moved to the Recycle Bin. Items in the Recycle Bin can be restored back to their original location or permanently deleted. Deleting a shortcut does not delete the folder or document to which it points.

To delete a shortcut

1. Select the shortcut in the project or shell Document log.
2. From the Edit menu, click Delete, or click the Delete button.
3. Click Yes to confirm. The shortcut is moved to the Recycle Bin.

Change The Shortcut Source

You can change the file or folder to which the shortcut points by choosing a different source in the Shortcut Properties window.

To change a shortcut source

1. Select the shortcut in the project or shell Documents log.
2. Click the Properties button. The Shortcut Properties window opens.
3. If you want to rename the shortcut automatically with the name of the new source document or folder, delete the name in the Name field.
4. In the Source field, click the Browse button and browse to the new source document or folder.

Uploading Files

You can upload files directly from your local system into project or shell or company documents. The method for uploading files is based on the File Transfer option you chose in your user preferences: Basic (HTML-based), Intermediate (Java), or Advanced Java plus the Primavera Unifier File Transfer Utility).

The general upload procedures are the same whether you are uploading files to the Document Manager or attaching files from your local system to a business process record, cost sheet cell, etc.

Tip: You can modify your File Transfer selection at any time. You must refresh the project or shell Documents node for the change to take effect. To do this, click the project or shell Documents node in the Navigator.

Note: The file size for file uploads must be more than 0 bytes and less than 2 GB. Primavera Unifier cannot upload empty files from a local computer using any of the upload methods.

Upload Files Using The Basic (HTML) File Transfer Method

The HTML method of uploading files into the Document Manager is the most basic method. It has the advantage of allowing you to transfer files to and from the Document Manager without having to install a third-party plug-in. It allows single-file selection for uploads and downloads, and some drawing reference file handling. It does not support uploading or downloading folders, shortcuts, or empty documents.
To upload files using the basic (HTML) file transfer method

1. In the project or shell or Company Documents node, folders view, select the destination (target) folder into which you want to upload the files.

2. Click the Upload button or select File > Upload. The Upload Files and Folders window opens.

3. Click the Browse button and select the file to upload.

4. You can add some properties information at this time in the File Properties box: document title, revision number, and issue date. This information is optional. This information can also be added or imported at a later time.

5. To add another file to upload, click Add Row and select the next file to upload. If you want to remove a file from the list, select the row and click Remove.

6. For more options, click the Advanced Options button at the bottom of the window. The File Upload window expands to reveal additional options for handling drawing and reference files and files of the same name.

7. Click OK to upload the files into the selected destination folder. A progress indicator will display the transfer rate and progress of the upload.

8. When the upload is complete, the completion summary will display. The time it takes to upload depends upon the number and size of the files. If any files failed to upload, for example, duplicate file names, they will be listed on the summary. Click Close to close the window.

Note: If you have uploaded drawing and reference files marked as missing, See “Resolving Missing Reference Files (Reference Manager)” on page 582.

Upload Files Using The Intermediate (Java) File Transfer Method

In addition to basic functionality, this option supports the selection of multiple files and folders for uploading and downloading. It will resolve reference file relationships in DWG and DGN drawing files. This process takes place on the server (that is, reference files should already be uploaded to Primavera Unifier or be part of the current upload process.

The procedure for uploading files using this method is the same as for the advanced method. See “Choose a file transfer option” on page 23 for details on the Java version and download.

Note: If you have uploaded drawing and reference files marked as missing, See “Resolving Missing Reference Files (Reference Manager)” on page 582.

Upload Files And Folders Using The Advanced File Transfer Method

This method uses Java in addition to the Primavera Unifier File Transfer Utility to provide the greatest flexibility and scalability for uploading and downloading files. This option supports drag-and-drop uploading and downloading of multiple files and folders. The file transfer process runs locally on your machine and will search for and retrieve drawing files from your system. You can choose to upload a drawing base file only, or base file and references at the same time. It allows association of base files to reference files already stored in the Document Manager. See "Choose a file transfer option” on page 23 for details on the Java version and download.
To upload files or folders (intermediate and advanced)

1. In the project or shell Documents or Company Documents node, folders view, select the destination (target) folder into which you want to upload the files.

2. Click the Upload button or select File > Upload. The Upload Files and Folders window opens.

3. Select the files to upload by doing one of the following:
   - Open Windows Explorer. Select the files or folders that you want to upload and drag and drop them into the Upload window (holding down your mouse button, drag them into the Upload window, then release the mouse button). Repeat for any additional files or folders to upload.
   - In the Upload window, click the Add button. Browse to and select the files or folders you want to upload. Click Open. Repeat for any additional files or folders to upload.

   To select multiple files, hold down the Ctrl or Shift key on your keyboard and then click each file that you want to select.

4. For more options, click the Advanced Options button at the bottom of the window. The File Upload window expands to reveal additional options for handling drawing and reference files and files of the same name.

5. Click the Upload button.

6. (Optional) Resolve missing reference files.

   If you included drawing files with reference files, and you are uploading reference files from your system, the Review References window will open. If you are using the Advanced option, the system will look for reference files on your system. If you are using the Intermediate option, the resolve process takes place on the server, so the system will expect the reference files to have been uploaded already or are part of the current upload process.

   To review and select reference files, you can:

   a. Click the View Mode drop-down menu and choose to view the drawing and reference files in a reference tree (displays the folder structure) or flat list (lists drawing and reference files in a flat list with path). All columns are sortable. By default, the sort will be on the link status to show all missing files at the top of the list.

   b. Review the summary portion of the window, which shows the total number of reference files to be uploaded, and if any are missing (system cannot locate them).

   c. To manually locate and resolve missing reference files, select a file marked missing and click the Resolve Missing button. Browse to the location of the missing reference file. The reference file must be the same name as shown in the window (from the information in the drawing base file). You cannot choose a file with a different file name. Resolving a missing file will automatically resolve other missing reference files that have the same name and logical source path, so you do not need to resolve the same reference file on multiple base files.

   d. If the wrong reference has been linked, select one or more files and click the Unresolve button to prevent uploading the reference. The file will remain on the list and be flagged as missing. If the file had other child references, the children will be removed.

   Note: You can also skip this step now and resolve the missing reference files at a later time.

7. Click Next when you are ready to upload the files.
The files will begin uploading. As the files upload, the progress bar shows the progress. The upload speed is dependent upon your system and connection and can take several minutes. When the upload is complete, the status and detailed log sections will display.

8 Review the log carefully. It will display the list of successfully uploaded files and display any errors in uploading, for example, if you try to upload two files or two folders with the same name; if you have duplicate files or folders, you will need to remove one before continuing; or if a file or folder could not be accessed on your local system for some reason.

9 You can save a copy of the log as a text file for later review. Click the Save to Log File button. Navigate to the location to save the text file.

10 Close the window.
<table>
<thead>
<tr>
<th>File Upload Options</th>
<th>Description</th>
</tr>
</thead>
</table>
| Upload Reference Files | Select this checkbox if you are uploading drawing files (DWG or DGN) that have associated reference files. The Upload Reference Files options are:  
  • **Upload reference files from my computer**: The system locates the reference files on your local system based on the information in the base file header.  
  • **Auto-resolve references from project or shell Documents as Dynamic Links**: The system attempts to locate the reference file within project or shell documents based on the information in the header. As reference files are revised, the new revisions are linked automatically to the base file.  
  • **Auto-resolve references from project or shell Documents as Status Links**: The system attempts to locate the reference file within project or shell documents based on the information in the header. Even if reference files are revised, the base file continues to link to the originally linked version of the reference files. |
| Revise automatically if the file already exists | If you select this checkbox and upload a file into a folder that already contains a document in it with the same file name, the document will be automatically revised with the newly uploaded version. If you do not select this checkbox, you will not be able to upload a file with the same name. This is not applicable to uploading folders containing files with the same name as existing documents. Files in this case will be ignored and cannot be uploaded. |
| Folder Upload Options | These options are only applicable if you are using the Advanced File Transfer option. |
| Upload only multiple files | If you select folders for uploading, only the files within the folders will be uploaded in a flat list. |
| Upload folders and files | Selected folders and their contents will be uploaded. If the folders do not already exist in the Document Manager, they will be created. |

**Review References window (reference tree view)**

**About Uploading Drawing And Reference Files**

The following drawing file types are supported: DWG and DGN.

There are three ways to manage uploading of drawing files with associated reference files:
• The base file and reference files can be bundled (similar to a zip file). The base file and reference files remain together.

• The base file can be dynamically linked to the reference files, meaning that the base file always links to the latest version of each reference file. If a reference file is revised, the revised version will be linked to the base file.

• The base file can be statically linked to the reference files, which means the base file always points to a particular version of the reference file, regardless of whether it is the latest version.

For example, you may want to keep the links dynamic as revisions are made to a base file, and then change the links to static once the drawing is finalized. Even if the reference file is revised, the base file will continue to point to the statically linked version.

**Note:** Links can be switched between dynamic and static at any time.

### Resolving Missing Reference Files (Reference Manager)

Base files store the reference file paths in the header. During the auto-resolve process, Primavera Unifier reads the path in the header and then looks for the reference files based on this path. If the reference file path cannot be read, or if the reference files cannot be found in the path specified by the header, the references are flagged as missing.

**Note:** Nested reference files are not supported. For example, a base file references a reference file, which in turn references another reference file (that is, the first reference file is a base file for the second). Primavera Unifier does not try to resolve missing nested reference files.

You can resolve missing reference files during or after uploading into Primavera Unifier. You can resolve missing references within the Document Manager in several ways: manually upload a missing file from your computer; link to a reference file that is already in project or shell or company documents; or let Primavera Unifier attempt to auto-resolve it by searching for the missing reference.

**Note:** The auto-resolve process will search for the missing attachment in the Primavera Unifier folder path as defined in the base file header and in the same folder as the base file.

### View Missing And Attached Reference Files

**To view missing and attached reference files**

1. In the document log, select a drawing file that has reference files. The drawing file will have a checkmark or an X in the Ref column of the log if there are associated references.

2. Click the **View** menu and choose **References**. The Reference Manager window opens, displaying references files:
   - **Missing:** Reference files could not be found. They can be auto-resolved or resolved manually.
   - **Private:** Reference files are bundled with the drawing file, not linked.
   - **Static link:** Links to a particular version of an existing reference file within the Document Manager. Static links can only be created to the latest document version. If the reference file is then revised, the link will point to the original version. Once linked, files cannot be revised with a different file name.
• **Dynamic link:** Links to an existing reference file within the Document Manager. If the file is revised, the link is refreshed and points to the newer version. Once linked, files cannot be revised with a different file name.

**Reference Manager window**

**Manually Resolve Reference Files**

**To resolve a missing reference file by uploading from your computer**

1. In the Reference Manager window, select the missing reference file.
2. Click the **Add from My Computer** button. The File Upload window opens.
3. Browse to the file and click **OK**.

**To resolve a missing reference file by linking to an existing file**

1. In the Reference Manager window, select the missing reference file.
2. Click **Link To Document**. The Link to Document window opens.
3. Browse to the reference file to link to.
4. Select one of the following options:
   - **Static link:** Links to a particular version of an existing reference file within the Document Manager. Static links can only be created to the latest document version. If the reference file is then revised, the link will point to the original version. Once linked, files cannot be revised with a different file name.
   - **Dynamic link:** Links to an existing reference file within the Document Manager. If the file is revised, the link is refreshed and points to the newer version. Once linked, files cannot be revised with a different file name.
   - **Local copy of the Primavera Unifier document:** Makes a copy of the existing reference file into the current folder and is not linked directly to the original version.
5. Click **OK** to save and close the Link to Document window.

**Auto-resolve Missing Reference Files**

**To auto-resolve missing reference files**

1. In the Reference Manager window, select the missing reference file.
2. Click the **Auto-resolve Missing References** button.
3. Select **Static Link** or **Dynamic Link**.
• **Static link:** Links to a particular version of an existing reference file within the Document Manager. Static links can only be created to the latest document version. If the reference file is then revised, the link will point to the original version. Once linked, files cannot be revised with a different file name.

• **Dynamic link:** Links to an existing reference file within the Document Manager. If the file is revised, the link is refreshed and points to the newer version. Once linked, files cannot be revised with a different file name.

4 Click **OK**. Primavera Unifier will search for the missing reference file based on information in the header of the base file. If the missing file is found, it is listed in the Auto-resolve window.

**Copy Or Move Reference Files**

If you need to copy or move reference files, it is recommended that you do so through the Reference Manager in order to maintain proper links between drawing and reference files.

**To copy a reference file**

1 In the document log, select a drawing file that has reference files. The drawing file will have a checkmark or an X in the Ref column of the log if there are associated references.

2 Click the **View** menu and choose **References**. The Reference Manager window opens.

3 Select the reference to copy and click the **Copy** button. The Copy Reference window opens.

4 Browse to the target folder within project or shell Documents.

5 Click **OK**. A reference will be copied to the target folder.

**To move a reference file**

1 In the Reference Manager window, select the reference to move and click the **Move** button. The Move Reference window opens.

2 Browse to the target folder.

3 Choose one of the options in the lower portion of the window. The reference file will maintain a link to the drawing file based on the option you choose:

   • **Create reference as dynamic link:** If the reference is revised, the link is refreshed and points to the newer version.

   • **Create reference as static link:** If the reference is revised, the link points to the original version.

4 Click **OK**. The reference file is moved to the target folder.

**Importing And Exporting In Document Manager**

**Import A Folder Structure Template**

If a folder structure template has been created in the Administration Mode standards and libraries, you can import it into your project or shell document manager to quickly create a pre-designed structure of folders and subfolders. You can import the folder structure template into the root project or shell Documents or Company Documents node or into any subfolder.
To import a folder structure template

1. In the project or shell or Company Documents node, navigate to the target folder (or the project or shell Documents root node) into which you want to import the new folder structure.

2. Click the File menu and choose Import > Folder Structure Template. The Select Folder Template window opens.

3. Select a template from the drop-down list.

4. You can preview the template structure by clicking the Preview button.

5. When you are ready to import, click Import. The folders and subfolders defined in the template are created within the target folder you selected.

Import And Export Folders, Properties, And Empty Documents

You can import a folder structure and folder metadata (properties) from a CSV file. This procedure also allows the import of empty documents into the structure.

Step 1: Export structure and properties to a CSV file. Exporting the existing structure and properties creates the CSV structure (rows and columns). The CSV template will contain a list of documents and folders with their full paths and all attributes displayed on the General tab of folder and document properties (either default or uDesigner created).

Documents and folder rows are identified by the first column (type). The location of the folder or document is identified in the second column. The order in which the columns appear is the same as they appear in the folder and document properties forms.

Step 2: Modify the CSV file. Add new folders, folder, document properties, or empty documents to the CSV files, being careful not to change the structure. Only the columns that are modifiable in project or shell documents can be modified in the CSV file. Read-only fields cannot be modified by importing. Folder and document names are case sensitive.

Note: As of the date of publication, there is a known issue with Microsoft Excel CSV files with 15 or more rows. See the procedure below for details.

Step 3: Import the modified CSV file. The imported file can include new folders and documents (empty documents), as well as modified or additional properties to existing folders and documents. You can upload files into empty documents later by using Revise.

To export structure and properties to a CSV file

1. Do one of the following:
   - Select the project or shell Documents node to create an export CSV of the entire Document Manager.
   - Select specific folders or documents to export.

2. Click File > Export > Structure and Properties. Click Yes to confirm.

3. Save the CSV file to your local system.
To modify the import file

1. Open the CSV file in Microsoft Excel or a compatible application.
2. You can add new folders or documents in rows (will be added as empty documents) as needed. You can also add property information to existing folders and documents.
3. Save the file.

Caution: As of the date of publication, there is a known issue in the way that Microsoft Excel handles CSV files with 15 or more rows. In CSV files, columns are separated with commas. However, when the CSV template is opened with Excel, if one or more columns toward the end are empty, Excel will drop the additional commas from the 15th row onward, resulting in an error when you try to import the file. You can work around this in one of two ways:
   - Add your data to the CSV file in Excel and save the file. Then reopen the file in a text editor such as Notepad, find the rows that have the missing commas, and add the additional commas to these rows.
   - Use the text editor instead of Excel to modify column values in the CSV file.

To import a CSV file into the Document Manager

1. In project or shell Documents, select the folder into which to import the structure or properties.
2. Click the File menu and choose Structure and Properties. The File Upload window opens.
3. Browse for the CSV file and click OK. Click Yes to confirm.
4. At the File Download window, click Save, browse to a destination folder and click Save.

Downloading Documents And Folders

You can download copies of documents from the Document Manager to your local or network drive.

Note: The file size for file downloads must be more than 0 bytes and less than 2 GB.

As with uploading documents and folders, the procedure will depend on the File Transfer option you have chosen. By default, the latest version of a document will be downloaded. Shortcuts cannot be downloaded.

Note: If the download window (Java console plug-in) is still open on your machine, you may not be able to delete, move, or modify the downloaded file as it will appear to be in use. If this is the case, close the plug-in window.

To download a document (Basic file transfer option)

1. Select the document to be downloaded. You can choose only one document at a time. Shortcuts, folders, and empty documents cannot be downloaded.
2. From the File menu, click Download, or click the Download button.
3. If the document is a drawing file with reference files, the Reference window opens, listing all drawing and reference files. Click the Download button next to one of the files to download. The File Download window opens.
4. Click the Save button. The Save As window opens.
5 Browse to the location where you want to download the file and click Save.

6 If you are downloading drawing and reference files, repeat for each file.

**To download a file or folder (Intermediate and Advanced file transfer option)**

1 Select one or more documents or folders in the documents log. Shortcuts and empty documents cannot be downloaded.

2 From the File menu, click **Download**, or click the **Download** button. The Download Files and Folders window opens.

3 Browse to the location where you want to download the files.

4 Choose document download options:
   - If you are downloading a drawing file with references, you can download the reference files. Select the **Download Reference Files** checkbox.
   - Choose **Download to the same folder as the base file** or **Download to the logical path** (downloads to the folder structure as determined in the base file header).

5 Choose the folder download option:
   - **Download files only**: Ignores any folder structure.
   - **Download folders and files**: Downloads the files in the selected folder structure, creating new folders if necessary.

6 Click **Save** to begin download.

---

**Adding And Viewing Graphic Markups And Comments**

You can add text comments or graphical markups to a document in project or shell Documents. You can even add a file attachment directly to the comment, for example, supporting documentation.

Comments and markups can be added to the latest version of a document only. You can view but not add or modify comments or markups made to previous versions.

Text comments are like notes that accompany the document but do not become part of it.
Markups can be thought of as an invisible layer, like a sheet of acetate that can be laid over the document. If multiple users create markups, each markup is on a separate sheet and can be viewed together, one at a time, or not at all. Markups are always associated with a text comment.

Text comments and graphic markups can be copied between business process records and the Document Manager, including:

- Comments added to documents in the Document Manager
- General comments added to business process records
- Comments added to file attachments on non-document-type BP records
- Comments added to file attachments (line item content) of document-type BP records
- Markups on file attachments that have been added to comments

**Add A Comment To A Document In The Document Manager**

**To add comments to a document**

1. Open the project or shell and click **Document Manager > Documents** in the left Navigator.
2. In the documents log, open the document.
3. Click the **Comments** button. The File Comments window opens.

4. Add a text comment in the **Text Comments** box. You can click the **Spelling** button to run the spell check on your comment.

**Note:** You also have the option of adding graphic markups and attaching a file to the comment. See the following sections for details. You must add some text in order to save the View Comments window, even if you are adding graphical markups or attaching a file.

5. Click **OK** to save your changes and exit the File Comments window.

**Note:** Until you click OK in the File Comments window, the comments, including any attachments and markups, are still in Draft mode. At this time, you can add or edit comments or markups to any file attachments, or add or remove file attachments from the comment.
Add A Graphic Markup To A Document In The Document Manager

Graphic markups are added through the comments function. These are stored with the document (e.g., a drawing) in the attached comment, but do not become part of the document itself.

To add a graphic markup to a Document Manager document

1. In the project or shell Documents log, select the document to markup.
2. Click the Comments button. The File Comments window opens.
3. Click the Markup button. You can also click the Graphic Markup link, which displays as Add if there are no markups on the document, or View if there are existing markups associated with this comment.

   The AutoVue viewer opens displaying the document content. The window opens initially in view mode, which allows you to view and print the document only.
4. In the viewer window, click the New Markup tool or File > New Markup.

   If there are existing markups, the Markup Files window opens. Each saved markup session is listed in the window. Select the checkbox by the markups to view and click OK.

   The viewer switches to markup mode and the markup tools become available.
5. Add graphic markups to the document as necessary, using the tools on the horizontal toolbar.

   **Note:** Each markup is a separate entity. The navigation pane on the left shows the Bookmarks tab and Markup Tree tab. The Markup Tree tab shows the markups. Click an entity to select it and delete, modify, etc.
6. Click the Save button or File > Save to save your markups. Enter a name for the markup and click OK.

   **Note:** Markups are saved as a single layer and are no longer editable once you close the window. Each markup is listed by name in the Markup Tree tab (in the viewer window) as a separate layer. To add another markup layer, click the New button.
7. When you have completed your markups, close the viewer window to return to the File Comments window.

   **Note:** At this point, the comment is still in Draft mode. You can add additional markups or file attachments if desired. You must enter some text in the Text Comment box in order to save.
8. Click OK to save and exit the File Comments window.

Attach Files To A Comment

If you want to provide additional information regarding a comment or markup, you can attach a file to the comment. The file attachment is associated with a specific comment. If you attach a file, you must also enter some text in the Text Comments window.

You can add graphical markups to files that you attach to a comment, as long as it is in Draft mode. This means that you can add the markups to the attachment as long as the comment has not yet been saved, and the file attachments are accessible from the Add New Comments portion of the View Comments window.
To attach files to a comment

1. Open a folder and select a document in the project or shell Documents log.
2. Click the Comments button. The View Comments window opens.
3. Add a comment.
4. Click the Attach button and choose one of the following:
   • My Computer to attach the file from your local system. The procedure is the same as for uploading files to the Document Manager and depends on your File Transfer option.
   • Primavera Unifier Folder to attach documents from the Document Manager. The window opens, displaying the project or shell Documents files and folders. Select the files and folders to attach and click OK. Folders are not attached. The contents of selected folders are attached in a flat list. Documents with duplicate files names will not attach.
5. When you are done attaching files, click OK to save the comment with the attachment. Once you save the comment with file attachments and markups, it cannot be modified.

Note: Until you click OK in the View Comments window, the comment, including any attachments and markups, are still in Draft mode. At this time, you can add or edit comments or markups to any file attachments, or add or remove file attachments from the comment. You must add text in the Text Comments area to save the View Comments window, even if you are adding markups or attaching a file.

To remove a file attached to a comment

1. In the Add New Comments portion of the View Comments window, click the link next to Attachments. The Attachments window opens.
2. Select the file to be removed and click Remove.

To mark up a file attached to a comment

1. In the Add New Comments portion of the View Comments window, click the link next to Attachments. The Attachments window opens (see below.)
2. Select the file and click Markup. Follow the procedures for marking up a document.
**View Comments, Markups, And File Attachments On Comments**

Documents with comments or markups are displayed in the documents log with an icon in the Comments column.

**To view text comments**

1. Select the file with the **Comments** icon next to it.
2. Click the **Comments** button. The View Comments window opens.

Any previously added comments, attachments, and graphical markups are listed in the Existing Comments (lower) portion of the View Comments window. As you add new comments, markups, or attachments, they are displayed in the Add New Comments (upper) portion of the window.

Text comments are displayed in their entirety.

![View comments](image)

**To view markups per comment**

1. In the project or shell Documents log, select the document to view.
2. Click the **Comments** button. The File Comments window opens.
3. Click the **Markup** button. The AutoVue viewer opens displaying the document content. The window opens initially in view mode.
4 Click the **New Markup** button or select **File > New Markup** to switch from view to markup mode, and choose which existing markups to view.

**To view or download files attached to a comment**

1 In the View Comments window, if there are file attachments to an existing comment, the number of file attachments will display as a link. Click the link next to **Attachments**. The Attachments window opens listing the attached files (see below.)
You can do the following:

- To view any graphical markups made on the attached file, select the file and click the View Markup button.
- To view the file attachment, select it and click the View button. The file will open in the native application or the AutoVue viewer, depending on your File Viewer option in your user preferences.
- If any of the attached files is a drawing file, select it and click the View References button to view the associated reference files.
- To download a file attachment, select it and click the Download button. Follow the procedure for downloading files from the Document Manager.

3 Close the window.

Revising Documents

To revise a document, you replace the current version with a new one that you upload from your local machine. The new file does not necessarily have to have the same file name as the original. This is also how you populate an empty document in Primavera Unifier with the completed document from your local machine.

The newest version of a document is available in the project or shell Documents log. Earlier versions can still be accessible in the View Revisions window. When a document is revised, the file itself is never changed. It remains untouched. Each version is maintained separately.

The procedures for uploading the revisions depend on the file transfer method you have chosen. The procedures for uploading revisions are the same as for uploading files.

Note: You can help control revisions by locking documents or checking them out prior to revising. If you have locked the file, you must unlock it before proceeding. If you have checked it out, you can revise it by checking it in, or cancel the check out before proceeding.
To revise a document using the revise function

1. Do one of the following:
   - If you are revising a file with a new version with the same file name, proceed to the next step.
   - If the revised file has a different name, select the document in the documents log, click the Properties button and select the Options tab. Be sure the Revisions must have the same file name checkbox is not selected.

2. Select the document in the documents log. If you are using the Advanced File Transfer method, you can choose multiple documents to revise.

3. From the Edit menu, click Revise. The Revise File window opens.

4. Do one of the following:
   - If you are using the Basic or Intermediate File Transfer option, browse to the file to upload and click OK.
   - For Advanced, select one file at a time to revise and click the Modify button. Navigate and select the file revision to upload. Click Open.

   **Note:** You can click the Advanced Options button to expand the window. The options are the same as when uploading files into the Document Manager.

5. Click Upload to upload the revised file into the Document Manager.

The publication number (Pub. No.) of the file increases by one for each revision uploaded. For example, the first time you upload a document, the publication number is 1. If you revise it, the publication number becomes 2, and so on.

To revise a document automatically upon uploading

1. Follow the procedure for uploading documents, based on your File Transfer option.

2. In the Upload window, click the Advanced Options button to expand the window.

3. Select the Revise automatically if file with same name exists option.

4. If you are uploading a file that has the same file name as a document that already exists in the Document Manager target folder, that document will automatically be revised to the newly uploaded version.

Access Previous Revisions

You can view earlier versions of a revised document, including any comments or markups or linked BPs on previous versions.

To view earlier versions of a document

1. Open the project or shell and click Document Manager > Documents in the left Navigator.

2. Select a document in the log.

3. Click the View menu and click Revisions. The View Revisions window opens, listing the current version and any previous versions of the document.

4. You can select one of the versions from the list and do the following:
   - Click Download to download the selected version.
   - Click View to open and view the document.
• Click **Comments** to view any comments added to the selected version.
• Click **References** to view any associated drawing reference files.
• Click **Linked Records** to view the list of BP records to which the selected version may be linked.

**Check-in And Check-out Documents**

The Document Manager’s check-in and check-out capability helps you have greater control over document revisions. If you need to revise a file, you have the option of checking it out, which locks it and prevents others from modifying it. It is available to other users as view only. You can make changes to the document as necessary, then check in the new revision.

The procedure for checking out a document is similar to downloading a document. The procedure for checking in a document is similar to the procedure for revising a document.

When a document is checked out, the check-out icon appears next to the document name in the Document Manager log.

**To check out a document**

1. Select the document in the project or shell Documents log.
2. Click the **Check Out** button or click **Edit > Check Out**.
3. Download a copy of the file to your local system, using the download procedure for your File Transfer option.

**Note:** If you cancel the download procedure, the document will still be checked out to you.

The Check Out icon appears next to the document in the log. You can upload a new revision and check the document back in, or you can cancel the check out without revising the document.

**To check in a new revision of a checked out document**

1. Select the document in the project or shell Documents log. Checked-out documents have an icon in the lock column.
2. Click the arrow next to the Check Out button and choose **Check In** or select **Edit > Check In**.
3. Do one of the following:
   • If you are using the Basic or Intermediate File Transfer option, browse to the file to upload and click **OK**.
   • For Advanced, select one file at a time to revise and click the **Modify** button. Navigate and select the file revision to upload. Click **Open**.

**Note:** You can click the **Advanced Options** button to expand the window. The options are the same when uploading files into the Document Manager.

4. Click **Upload** to upload and check in the revised file into the Document Manager.

The publication number (Pub. No.) of the file increases by one for each revision uploaded.
To restore a checked out document without checking in a new revision

1. Select the checked out document in the project or shell Documents log.

2. Click the arrow next to the Check Out button and choose Cancel Check Out or select Edit > Cancel Check Out.

The document will no longer be checked out.

To find out which user has a document checked out

1. Select the checked out document in the project or shell Documents log.

2. Click the View menu and choose Audit Log. The Audit Log report displays the complete history of the document, including who last checked out or revised it.

Lock And Unlock Documents

If you are the owner of a document, you have the option of locking the document to prevent it from being revised or modified. Once a document is locked, only the document owner (or an administrator with proper permissions) can unlock it.

When a document is locked, users can:

- View the document, revision log, and audit log.
- Download or copy the document.
- Create a shortcut to the document.
- Modify document permissions.
- Move a document, or move the folder containing the document.

When a document is locked, users cannot:

- Delete, revise, edit properties, transfer ownership, or add comments or markups.

To lock or unlock a document

1. Select the document in the project or shell Documents log.

2. From the Edit menu, click Lock or Unlock.

Note: Only the document owner or an administrator with full access can lock or unlock a document.

The Recycle Bin

When you delete documents, folders, or shortcuts from project or shell Documents, they are stored temporarily in the Recycle Bin. These items can be restored back to their original location. Items in the Recycle Bin remain there until you permanently delete them.
Restore Deleted Items

Deleted documents, folders, and shortcuts that are still in the Recycle Bin can be restored back to their original locations.

**Note:** If you restore a folder whose parent folder has been deleted, the folder structure will be recreated. However, the other contents of the parent folder will not automatically be restored.

To restore deleted items in the Recycle Bin

1. Navigate to the Recycle Bin and do one of the following:
   - To restore a single item, select it and click the Restore button.
   - To restore all items in the Recycle Bin, click the Restore All button.
2. Click Yes to confirm.

Delete Items From The Recycle Bin

Once documents, folders, or shortcuts are deleted from the Recycle Bin, they cannot be retrieved.

To permanently delete items from the Recycle Bin

1. Navigate to the Recycle Bin and do one of the following:
   - Select the item and click the Delete button.
   - Click the Empty Recycle Bin button to permanently delete all items in the Recycle Bin.
2. Click Yes to confirm.

Project Or Shell Documents Or Company Documents Attached To A Business Process

A document that is attached to a business process record maintains a link with that record. You can view the business process records to which any document is linked (permissions to view BPs apply). Because of this link, documents that are attached to BP records cannot be deleted.
**Launch A Business Process From The Document Manager**

A business process record can be launched directly from documents within Document Manager. This functionality applies to any business processes that support attachments directly to the form. This is not applicable to file attachments to comments.

For document-type BPs, the documents can be added as line items, or they can be attachments to the form. For non-document-type BPs, the documents are added directly as form attachments.

Note the following:

- Text-type BPs such as action Items cannot be launched directly from the Document Manager. This is because text-type BPs, by design, can have file attachments only to the comments section, not the form itself.
- Only document-type BPs can support folders. If you are trying to attach one or more folders to a non-document-type BP, the files within the folders will be attached, but the folder structures will be flattened.
- You cannot attach multiple files with the same name to the same folder. If you select multiple files and there are two or more with the same name, none of those files will be attached. After the form is created, you can attach the correct files using the Add Attachment button.
- You cannot attach shortcuts or empty documents for launching a new BP. If you select a folder containing empty documents or shortcuts, these will be ignored.
- The BP list that you see in the drop-down menu is the list of all available active business processes in the project or shell. Once you select a BP, a permission check will be run. You must have at least create permission on that BP to launch a BP from the Document Manager.

**To launch a BP from within the Document Manager**

1. Select one or more files or folders in the project or shell Documents or Company Documents log. You can also launch a business process record without selecting any documents or folders. In this case, the business process record will be created with an empty attachment area.

2. Click **New > Business Process** and choose the business process to launch. The Select Workflow window opens.

   **Note:** Primavera Unifier will not display the Select Workflow window if:
   - This is a non-workflow process.
   - There is only one workflow schema you can choose for this business process.

3. Choose the workflow schema to use and click **OK**.

   **Note:** You may receive alert messages. For example, if you are trying to attach folders to a non-document-type BP (the documents will attach, but the folders will be flattened), or if a selected file cannot be attached. Read any alert message carefully. Click **OK** to close the window.

4. You can add additional documents to the business process record as you normally would.

5. Complete the business process form and send as usual. The attached documents are linked to the business process record.
**View Linked Business Process Records**

If a document in project or shell Documents or Company Documents has been attached to one or more business process records, an icon will appear in the BP column next to the document in the log. You can view the records to which the document is attached as long as you have view permissions for that BP.

**To view business process records to which a document is linked**

1. In the project or shell Documents or Company Documents log, select a document. Documents with the paperclip icon in the BP column are linked to BP records.
2. Click the View menu and select **Linked BP Records**. The View Linked Records window opens.
3. To open the BP record form, select it form the list and click the **Open** button or double-click the record. You must have permission to view the specific BP in order to open the record.

**Index Reports**

The index report utilizes the Primavera Unifier user-defined report engine. It lists content (documents, subfolders, shortcuts) within a selected folder, properties, and phase (contents may be associated with more than one phase). The index report can be generated in HTML, PDF, or CSV format.

**To view an index report**

1. Select a folder in folders view of the project or shell Documents or Company Documents node.
2. From the **File** menu, click **Index Report** and choose the format to display:
   - **HTML**: Displays the report in a browser window.
   - **PDF**: Creates a PDF file of the report.
   - **CSV**: Creates a CSV file of the report.
View Document Manager Audit Log

To view the Audit log

1. Select a folder or document in the project or shell Documents or Company Documents log (or a folder in the folders view).

2. From the View menu, click Audit Log. The Audit Log window opens. The Audit Log window opens. The date and time stamp of each event reflect users’ current time zone as set in their User Preferences.

To view audit details

In the Audit log window, double-click a listed event to view the audit record detail, which details the action taken. The details also include the user’s current time zone for reference.

To print the audit log

In the Audit log window, click the Print button. A PDF file is created. Do one of the following:

- Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can view, save (File > Save) or print (File > Print) the file.
- Click Save. In the Save As window, navigate to the location in which you want to save the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print.
UNPUBLISHED DOCUMENTS

The Unpublished Documents node is an automatic repository for files that have been attached to business processes and which have not yet been published in project or shell Documents or Company Documents. That is, when a user uploads a file from a local machine and attaches it to a business process, the document is automatically stored in the Unpublished Documents log as soon as the business process is sent. The link to the business process is also listed in the log.

The link to the BP allows the BP record to be reviewed, allowing the administrator to review where the document originated from. This provides a means to control the documents that are accessible in the Document Manager. For example, a subcontractor submits a Request for Information (RFI) with attached documents requesting input from the architect. These attached documents can be traced back to the original BP through the link, and the documents become available in the unpublished area of the Document Manager. The administrator can then review the documents and make the decision to publish them into the project or shell or Company Documents node and where to store them, or not to publish them at all.

Note the following:

• This process applies only to business processes that support form attachments.
• Text-type BPs, such as action items or RFIs, are excluded. This is because text-type BPs, by design, can have file attachments only in comments, not to the form itself.
• Files cannot be directly uploaded to or deleted from the Unpublished Documents folder.
• Permissions for unpublished documents are at the node-level only. You can either see all the documents or you cannot see any. There are no document-level permissions. Folder-level permissions are not applicable, as there are no folders in Unpublished Documents.
• Drawing files are handled with the base file listed and the associated reference files bundled with it, similar to a zip file.

Unpublished Documents Log

The documents in the Unpublished Documents log display the name of the business process, which is a direct hyperlink to the BP record. Those users who have log permission to view the BP can click the link and view the linked BP record.

The unpublished documents area is a flat list. There are no folders in this node.

If a document is linked to more than one record, each instance will be listed in the log, each with a link to the corresponding business process.

About Automatic Publishing Of Documents

By default, files attached to business processes are placed in the Unpublished Documents folder in the Document Manager. A Publish Path data element can be designed in business processes in Primavera uDesigner to specify the automatic publishing of documents to a specified path and override the default. For document-type business processes With Folder Structure, the designer can specify that a configured folder path be appended to the folder structure. This appended path is based on the path configured in the uuu_dm_publish_path data element on the business process form, and the selection of the Append Line Items Folder Structure to AutoPublish Path option, which is documented in the Primavera uDesigner User Guide.
The automatic document publication folder path is built based on the values of data elements specified in the path defined in the data element uuu_dm_publish_path (Publish Path) in Primavera uDesigner. To help you understand why automatic publishing does or does not occur and the results of automatic publication, these are the rules for the automatic publication of documents:

- The data element uuu_dm_publish_path is used in business process design to specify the folder path into which the file should be published in the Document Manager. This applies to Company, project, or shell business processes. A formula is configured to define the value of the path to use when automatically publishing documents.
- In order to use the automatic publishing feature, you must know (from your Administrator) which data elements comprise the publish path that will populate the Publish Path field. The values in this field are used to create and populate the folders in the Document Manager with the business process attachment.
- If you do not have permissions granted to upload documents to the Document Manager, then the file is placed in the Unpublished Documents folder.
- If there is no folder defined or the path is invalid then the file will be placed in the Unpublished Documents folder.
- If the folder specified in the defined path does not exist in the Document Manager as defined by the data element uuu_dm_publish_path (Publish Path) in Primavera uDesigner, then it should be created automatically and inherit rights from the parent folder, (if you have permission to create folders), otherwise the file will be placed in the Unpublished Documents folder.
- If file already exists in target file, then the file shall be published as a revision.
- When a document is automatically published for the first time, any related comments are published with the document.
- The owner of the automatically published document is the owner of the business process that published it.
- The folders created and used for automatic publication are based on the values of the data elements specified in the uuu_dm_publish_path data element (Publish Path). For example, if the publication path contains the data elements State and City, and the values for those data elements are Iowa and Rapid City, the folder structure will be Documents/Iowa/Rapid City.
- The publication path displays in the Publish Path data element on the business process form. If the path is shown as /, the documents will publish to the Documents folder. Usually, when the / to shows in the Publish Path field, this indicates that you have no values in the fields for the data elements configured as the publication path. Be sure that you have values in the fields that are part of the publication path.
- If a business process has a publication path configured on the upper form, and another on a line item, and the path on the line item is invalid, the attachment will be published to the path designated on the upper form. If the paths on the line item and the upper form are both invalid, the attachment is published to the Unpublished Documents folder. The exception is that in a non-workflow business process, if the publication path configured on the line item is invalid, the attached document is not published in any folder.

Open An Unpublished Document

To open and view an unpublished document
Select a document in the Unpublished Documents log and click Open. The document will open in the viewer.
To view reference files
Select a drawing file in the Unpublished Documents log, click the View menu and select References. If references are associated with the document, they will be listed. Drawing and reference files are bundled.

Open A Linked Business Process Record

To open the BP record to which an unpublished document is linked
2. Click the View menu and select Linked BP Record. The BP record opens, assuming you have permission to view it.

View Unpublished Document Properties
Properties of an unpublished document cannot be modified.

To view the properties of an unpublished document

View Unpublished Document Comments
Comments and markups added to the document from the BP can be viewed.

To view comments or markups on an unpublished document
Select a document in the Unpublished Documents log and click Comments. The Comments window opens.

Download An Unpublished Document

To download an unpublished document
Select a document in the Unpublished Documents log and click Download. Follow the procedure for downloading a document in the project or shell Documents node.

Delete An Unpublished Document
A document cannot be deleted directly from the Unpublished Documents or the project or shell Documents folders if it is linked to a BP.

A document is stored in the Unpublished Documents node automatically when it is uploaded directly from a local machine or network and attached to a business process. If that document is then deleted from the BP during the workflow (or for a non-workflow BP, the document is deleted when the BP is in Draft mode), then it will be deleted automatically from the Unpublished Documents log.

The document cannot be deleted if the BP has already completed the workflow, or if the document has already been moved by an administrator to the Published Documents folder.

Tip: You can create a special folder in project or shell Documents for documents that you want to publish and limit access to, but the documents remain traceable.

Search For An Unpublished Document
There are two ways to find an Unpublished Document:
• **Search by Properties**: You can search by document title, file name, or record number (the linked BP record).

**Note**: This search option can be customized through Primavera uDesigner. If a designer has imported Document Manager attribute forms, the search criteria can also be customized. This means that the fields on which you can search may differ from the above list.

• **Search by Content**: This allows you to search for a document by specific content or keywords within the document. This option works on most file types other than drawing files. You can search by single word or exact phrase in quotes (“training document”).  
The supported file types for content search are listed below:
  - doc, pdf, txt, xls, htm, rtf, html, csv, xml, xsd, java, c, cpp, vm, bat, bak, css, log, sql, ncs, sh, properties, vpp, wtx, xhtml, xslt, ppt, mpp, vsd

**To search for documents by properties**

1. In Unpublished Documents, click the **Find** button and choose **Search By Properties** (or click the **View** menu and choose **Find > Search By Properties**). The upper portion of the log expands to display the Find fields.

2. Enter search criteria in one or more of the **Find** fields, for example, the full or partial name of a file.

3. Click the **Search** button. The log will display the search results.

4. To close the Search fields, click the **X** in the upper right corner.

**To search for documents by content**

1. In Unpublished Documents, click the **Find** button and choose **Search By Content** (or click the **View** menu and choose **Find > Search By Content**).

2. Enter one or more keywords to search for within the documents.

3. Click the **Search** button. The log will display the search results.

4. To close the Search fields, click the **X** in the upper right corner.

**Tip**: For best results, use only alpha-numeric characters in your search criteria. If you are not receiving the search results you are expecting, try placing your criteria in quotes.

---

**Publish A Document To Project Or Shell Or Company Documents**

Publishing a document from Unpublished Documents to the project or shell Documents or Company Documents node makes it available to team members, with the full functionality available in that node.

Only a document administrator (administrator or other user with full access to the Document Manager) can publish documents from the Unpublished Documents node into project or shell or Company Documents. Documents can be published one at a time.

**To publish an unpublished document to the project or shell Documents node**

1. In the Unpublished Documents node, select the document or documents to publish and click **Publish**. The Publish File window opens. If you select duplicate files (documents with the same name) to publish, you will be asked to remove the duplicates.

2. Select the destination folder.
3 Select the **Include Comments** checkbox if you want to include any attached comments with the document. To review the comments, select the document from the log and click the **Comments** button.

4 The **Revise automatically if the file already exists** checkbox is selected by default. Deselect if you do not want to automatically revise existing documents. If you deselect this checkbox, the new version of the document will not be copied into the Document Manager and are skipped.

5 Click **OK**. The Publish Files Status window opens, and displays the status of the documents as they are published. Click **OK** to close this window.

**Note:** The user who publishes the document becomes the owner. In the project or shell Documents or Company Documents node, select the document and click Permissions to grant the proper permissions to the team members who need it. You may want to click Properties to review properties and update if necessary.
ABOUT THE RESOURCE MANAGER

The Resource Manager is where you can set up and manage a company’s or shell’s personnel resources. Resources can include those of a partner company.

The Resource Manager has limited functionality in generic shells

- You cannot allocate resources in a generic shell. This means you cannot view the Allocation and Utilization sheets.
- The Resource Booking business process is not available; however, you can book resources directly onto the Resource Summary sheet in a generic shell.

The Resource Manager manages the planning, deploying, and tracking company or project/shell resources. It supports the creation and management of resources and roles, with the ability to define and leverage multiple role rates, skills, proficiency levels, resource capacities, and more.

Resources can be associated with Primavera Unifier users, which enables the ability for resources to log in and view individual calendars and respond to assignments. Resources can be associated with one or multiple roles with different role rates. This allows for accurate resource cost tracking and management at the project level.

The Resource Manager supports Timesheet business processes for capturing and tracking actual resource costs associated with activities and assignments at the project, shell, and the company level. The manager also supports hard and soft Resource Booking BPs using a calendar that shows what project/shells a resource has been booked for, as well as the times during which the resource is unavailable.

An interactive Resource Dashboard provides the ability to track and report on all resource allocations, booking, utilization, and more.

In the Resource Manager, your administrator can classify job functions into roles that can then be allocated to projects. These roles will be used to define billable rates, which are used in budgeting, and can also be used in planning for resource demands across projects. Roles are associated with personnel resources—the people who can perform these roles in a project. The Resource Manager is where personnel are assigned to roles and projects.

In the Resource Manager, a company’s or shell’s personnel can serve multiple roles, depending on their skills or interests. For example, a construction role and a plumbing role might be served by one person who has both carpentry and plumbing skills. The Resource Manager automatically creates the following Resource sheets you need to manage resources, bookings, and certain budgeting functions:

<table>
<thead>
<tr>
<th>Sheet</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocations Summary</td>
<td>Master allocation sheet that shows role allocations at the company and project/shell level in both hourly and currency views. Read-only.</td>
</tr>
<tr>
<td>Resource Allocation</td>
<td>Allows manual entry of role allocations against projects/shells from company level so users can balance resources across projects/shells. The Resource Allocation Sheet rolls up to the Allocations Summary Sheet at both the project/shell and company level.</td>
</tr>
<tr>
<td>Table</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>Booking Summary</td>
<td>Shows hard resource bookings across projects/shells in both hourly and currency views. Can add or edit hard-booked resources directly on the Booking Summary Sheet, or though the Resource Booking business process. If the Resource Booking business process has been designed to include resource capacity, the Booking Summary can also show each resource’s availability for booking hours.</td>
</tr>
<tr>
<td>Actualler Summary</td>
<td>Shows resource actuals from timesheet data for the company in both hourly and currency views. Read-only. Populated by the Time Sheet business process.</td>
</tr>
</tbody>
</table>
| Utilization Summary | Shows current total utilization of resources as a percentage of the total at the company level. Read-only.  
*Note:* Resources that are hard-booked in the Schedule Manager will roll up to this sheet. |
| Bookings vs. Actuals | At both company and project/shell level, shows hard resource bookings across projects/shells in both hourly and currency views, similar to the Booking Summary Sheet. Also shows columns per resource for booked hours, actual hours, and the variance (booked, minus actual hours). Read-only. |
| Availability | At the company level, shows current availability of each resource across projects/shells. The resource availability equals the resource’s total capacity, minus the total bookings for the resource across the projects/shells, and minus the non-project times specified for the resource. |
USING THE RESOURCE MANAGER

The Resource Manager is available at the company and project level, and allows you to:

- View and configure resource charts
- View resources, roles, and various resource sheets
- Allocate roles to projects
- Have resources enter their own time sheets

At the company level, the Resource Manager has four nodes:

- **Resource Dashboard**: Allows you to configure displaying Resource Manager information across projects.
- **Roles**: Displays the company-level roles entered in Administration Mode.
- **Resources**: Displays the company-level resources that are hard-booked across projects.
- **Resource Sheets**: Lists the available company-level (cross-project) resource sheets.

At the Project level, the Resource Manager has three nodes:

- **Resource Dashboard**: Allows you to configure displaying Resource Manager information across projects.
- **Resources**: Displays resources that are hard-booked for the project.
- **Resource Sheets**: Lists the available project-level resource sheets.

**View Roles**

Roles are defined and maintained in Administration Mode at the company level. At the company level, you can view role details, which includes resources and rates.

**To view role details**

1. In User Mode, select **Company Workspace tab > Resource Manager > Roles**. The Roles log opens.
2. Select a role and click **Open**. The Role Properties window opens. The window has three tabs:
   - **General**: Displays the role name, description, and status, and may display other fields; the fields on this tab correspond to the role attribute form.
   - **Rates**: Displays standard and overtime rates defined for the role.
   - **Resources**: Displays resources that have been associated with the role.
View Resources

Resources are defined and maintained in Administration Mode at the company level. You can view resources that are hard-booked for a project or across multiple projects.

To view resource details

1. In User Mode, do one of the following:
   - To view resources across projects, select **Company Workspace tab > Resource Manager > Resources**.
   - To view resources for a project, select **Projects tab > project > Resource Manager > Resources**.
   The Resources log opens.

2. Select a resource and click **Open**. The Resource Properties window opens. The window has five tabs:
   - **General**: This tab may vary greatly with the design of the resource attribute form you imported. Fields may include:
     - **Resource Code**: Automatically generated, manually entered, based on the configuration.
     - **Resource Name**: This is the name of the resource.
     - **Description**: Description of the resource.
     - **Resource Capacity (Hrs)**: Default value is 8. This defines the number of hours a person can work in a day.
     - **Sunday (Hrs.)…..Saturday (Hrs.)**: Depending on the design of the Resource Attribute form, these fields may or may not appear on the General tab. If they do, they will show the number of hours the resource can work on each of these days. Primavera Unifier will use these values to calculate the resource’s Capacity per week.
   - **Roles**: Displays any roles that have been associated with the resource.
   - **Skills**: Displays any skills associated with the resource.
   - **Calendar**: The calendar displays bookings, vacation days, etc. for the resource.
   - **Projects**: Displays the projects in which the resource is booked and booking specifics.
EDIT YOUR OWN RESOURCE PROPERTIES

At the company level, you can edit your own resource properties and calendar. From your user login, Primavera Unifier identifies you and automatically gives you permissions to modify your properties and calendar. However, you must have View permission to the Resource Log.

To edit your resource properties

1. Click the Company Workspace tab and go to Resource Manager > Resources in the Navigator.
3. Edit your information under each tab as necessary.

General Tab

This tab may vary according to the design of the resource attribute form. Fields may include:

- **Resource Code**: Automatically generated, manually entered, based on the configuration.
- **Resource Name**: Edit your name, if necessary.
- **Description**: Edit your description.
- **Resource Status**: Edit your status. The default is active.
- **Capacity per week (Hrs)**: Edit the number of hours you can work in a day. Default value is 8.
- **Sunday (Hrs.).....Saturday (Hrs.)**: These fields may or may not appear. If they do, you can edit the number of hours you can work on each of these days. Primavera Unifier will use these values to calculate your **Capacity per week**.

Roles Tab

To add a role to your profile:

- **Click Add**.
- **Select a role from the Role picker and click Open.**

Primavera Unifier adds the role to your profile.

To remove a role from your profile, select the role and click **Remove**.

Skills Tab

To add a skill to your profile:

- **Click Add**.
- **Select the skill from the drop-down list**.
- **Specify your proficiency in this skill**.
- **Specify your interest in this skill**.

To remove a skill from your profile, select the skill and click **Remove**.
Calendar Tab

You can view and manage booking dates as well as unavailable dates (non-project time, such as vacation days). The calendar shows both your soft and hard bookings. To edit your booking calendar:

a You can click the **Month** tab or **Week** tab to change the calendar view. A maximum of five projects/shells can be shown for any day in the month view. If you are booked for more than five project/shells in a day, you can view them all in the week view.

b To view all projects/shells for any given day, select a day and click the **Booking Details** button.

The Resource Booking Details window opens. The window displays the project/shell bookings for you on the selected date. For each project/shell, it shows project/shell number, project/shell name, booking status, dates when the booking starts and ends, total hours booked during this period on the project/shell, and total hours booked on the current date on the project/shell. The dates and hours shown include non-project time.

c To make yourself unavailable for booking on a certain date, select the date and check the **Unavailable** checkbox. You can click the drop-down list and select an option.

Projects/Shells Tab

The Projects/Shells tab is read-only. You cannot edit the information on this tab.

Working With Resource Sheets

The company-level and project-level resource manager sheets are created automatically when the Resource Manager is activated in Administration Mode. The available resource sheets are listed below.

- **Allocations Summary Sheet**: This is the master allocation sheet, which shows role allocations entered at the company and project level. This is a read-only sheet.
- **Resource Allocation Sheet**: The company-level resource allocation sheet allows role allocations against projects from the company level. The project-level resource allocation sheet allows role allocations for the project.
- **Booking Summary Sheet**: The booking summary sheet shows resource bookings for a project or across projects in the company. This sheet can be populated by the Resource Booking business process, or by resources directly added to the sheet.
- **Actuals Summary Sheet**: The actuals summary sheet is a read-only sheet that shows resource actuals (time sheet data) for a project or across projects in the company. This sheet is populated by the Timesheet business process.
- **Utilization Summary Sheet**: The utilization summary sheet is a read-only sheet that shows total utilization of resources for a project or across projects.
VIEW RESOURCE MANAGER SHEETS

Resource Manager sheets are available in the Company Workspace, and in projects and shells.

To view company-level sheets


2. Select a sheet from the log and click Open.

To view project-level sheets


2. Select a sheet from the log and click Open.

See the descriptions below for details about each of the sheets. In general, the sheets work similarly to each other at the company and project level. In general, you can:

- View data by hours or by cost (not available on all sheets)
- Save or open the sheet as a PDF file, allowing you to save and print the sheet
- Create and view snapshots (not available on the resource allocation sheets)

The structure of each resource sheet is similar:

- The left pane of the sheet displays default columns, which depend on the sheet. For example, resource name, role name, etc.
- The right pane displays the time line columns. Depending upon the display (day, week, month), the time line will show a column for each period with the actual allocation in hours (hours view) or in currency (cost view).
- To change the timescale, click the Display field at the top of the sheet and choose one of the following:
  - Day: The column header will show the actual date of the allocation.
  - Week: The column header will show the actual date of the start of the week (Monday) from the company calendar.
  - Month: The column header will show the actual date of the start of the month from the company calendar.
- In the upper right corner of each sheet is a time line slider:
  - Start of the time line: The earliest date that can be displayed on the time line will be the minimum of the default start date specified in the Resource Manager configuration and the earliest transaction date.
  - End of the time line: The latest date displayed on the time line will be the maximum of the default date specified in the Resource Manager configuration and the latest transaction date.
  - To quickly scroll through the date columns, you can click the slider in the top right corner of the sheet and slide it to the time period you wish to view.
  - Default view: By default, when the sheet is opened, the time line will always center on the current period (day, week, month). Scroll left or right to see other periods.
**Note:** If the sheet is currently being edited, you will not be able to change the Display By field or the time line slider. To change the sheet display, first save any edits by clicking the Save button.

**Allocations Summary Sheet**

This is a read-only sheet that totals resource data by role. In company-level sheets, there are two possible sources of the information displayed on the sheet: the company-level resource allocation sheet and project/shell level resource allocation sheets. For project/shell allocation summary sheets, the source is the resource allocation sheet for that project or shell.

Allocations are shown for each role. At the company level, allocations are shown for each role against one or more projects. The combination of role and project is always unique. The Role Name column is sorted alphabetically. The role name is hyperlinked. Clicking on the role name will open the Role properties window in view-only mode.

You can view summary information by hours allocated for that role, or by cost (hours multiplied by hourly rate, as defined in the Role properties in Administration mode).

**Note:** This sheet is not available in generic shells.

**To view the allocations summary sheet**

1. In the company-level or project/shell level Resource Sheets log, select **Allocations Summary** and click **Open**.

   The window opens in a split mode by default. You may need to use the scroll bars at the bottom of the window to view the columns you want to see on either side of the sheet.

   Each row corresponds to a role that has been allocated to a project or shell, either in the company level or project/shell level resource allocation sheet. On the left side of the sheet, you will see the role name, project/shell number and name (in company-level sheets), the date range in which the role is allocated, and the total number of hours, which is the sum of all the values entered for that row in the resource allocation sheet. On the right side of the sheet are the hours allocated to each role.

2. You can view this sheet by hours or by cost:
   - To view by hours, click the **View** menu and choose **Mode > Hours**. The sheet displays the hours allocated to each resource, as rolled up from the resource allocation sheets.
   - To view data by cost, click the **View** menu and choose **Mode > Currency Amount**. The sheet displays the cost charged against each resource: hours are rolled up from the resource allocation sheets, then multiplied by the hourly rate defined for the role in Administration mode.
   - To display the most current costs, click the **Refresh Rates** button. Select the effective date when prompted. Rates will refresh from the selected date to all dates in the future for which values exist on the sheet. Costs for dates earlier than the selected date will not be refreshed. The date will default to the current date.
### Company-level Resource Allocations Summary Sheet, view by cost

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role Name</td>
<td>Allocations are shown for each role against one or more projects. The combination of role and project is always unique. The Role Name column is sorted alphabetically. Clicking on the role name will open the Role properties window in view-only mode.</td>
</tr>
<tr>
<td>Project Number</td>
<td>The project number is shown hyperlinked. Clicking on the Project Number will open the corresponding project allocation summary sheet. This is shown in the company-level sheet only.</td>
</tr>
<tr>
<td>Project Name</td>
<td>The name of the project. This is in the company-level sheet only.</td>
</tr>
<tr>
<td>Date From</td>
<td>Displays the earliest date that has a non-zero allocation for the role.</td>
</tr>
<tr>
<td>Date To</td>
<td>Displays the latest date that has a non-zero allocation for the role.</td>
</tr>
<tr>
<td>Total Hours</td>
<td>Displays the sum of hours allocated to the role. This field is displayed only in hours view.</td>
</tr>
<tr>
<td>Total Cost</td>
<td>Displays the total amount allocated to the role. This field is displayed only in cost view.</td>
</tr>
</tbody>
</table>

**Resource Allocation Sheet**

In this sheet, you can allocate resources, based on roles, to a project or WBS-code based shell. The Resource Allocation sheet is available at the company level and also in projects and shells in which resource allocation is enabled.

**Note:** The ability to allocate resources to a project/shell with this sheet is dependent upon how the Resource Manager has been set up in Administration Mode.

During the setup of the Resource Manager in a project or WBS-based shell, the Administrator can choose to allow resource allocation from the company level sheet (the allocations are roll down to the specific project/shell Resource Allocation sheet, which is view-only); directly from the project/shell level sheet (this will show up in the project/shell and the company level Allocation Summary sheet); or the administrator can choose to disallow allocation for a
particular project or shell (in this case, the Resource Allocation sheet and Allocation Summary sheet are not available for that project/shell).

Allocations at the company level:
- Roll up to the company allocations summary sheet.
- Roll down to the individual projects/shells, in their resource allocation sheet and allocation summary sheet.

Allocations at the project/shell level:
- Roll up to the project/shell allocations summary sheet.
- Roll up to the company allocations summary sheet and resource allocation sheet.

The resource allocation sheet can be viewed by hours only.

**Note:** This is not available in generic shells.

**To view the resource allocation sheet**
In the company-level or project-level Resource Sheets log, select Resource Allocations Sheet and click Open.

![Company-level resource allocation sheet](image)

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role Name</td>
<td>Allocations are shown for each role against one or more projects. The combination of role and project is always unique. The Role Name column is sorted alphabetically. Clicking on the role name will open the Role properties window in view-only mode.</td>
</tr>
<tr>
<td>Project Number</td>
<td>The project number of the allocation. This is displayed in the company-level sheet only.</td>
</tr>
</tbody>
</table>
### Column Description

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Name</td>
<td>The name of the project. This is displayed in the company-level sheet only.</td>
</tr>
<tr>
<td>Date From</td>
<td>Displays the earliest date that has a non-zero allocation for the role.</td>
</tr>
<tr>
<td>Date To</td>
<td>Displays the latest date that has a non-zero allocation for the role.</td>
</tr>
<tr>
<td>Total Hours</td>
<td>Displays the sum of hours allocated to the role. This field is displayed only in hours view.</td>
</tr>
</tbody>
</table>

**To allocate a resource**

1. Open the Resource Allocation sheet.
2. Click the Add button. The Resource Allocation window opens (see below.)

![Resource Allocation Window](image)

3. Complete the window:
   - **Role Name**: Click Select, choose a role, and click OK.
   - **Project**: Click Select, choose a project, and click OK.
   - **Date From**: Click the calendar and choose the start date for the allocation.
   - **Date To**: Click the calendar and choose the end date for the allocation.
   - **Allocated Hours**: This field will auto-populate based on the dates selected (number of workdays x capacity). This is an editable field. You can adjust the amount as needed.
4. Click OK.

**To edit allocation information**

1. Open the company level or project/shell level Resource Allocation sheet.

As mentioned at the start of this topic, the ability to allocate resources to a project/shell with this sheet is dependent upon how the Resource Manager has been set up in Administration Mode. Depending on project/shell setup, allocations may be done for that project or shell in the company-
level sheet, the project/shell-level sheet (or allocations may not be allowed for a particular project or shell).

If you have questions regarding allocations, contact your Project/Shell Administrator.

2 If the sheet is editable, click in the cell to edit. The cell becomes editable. You may need to scroll to the cell, or use the Display By or timeline slider to navigate to the column to edit.

3 Make changes to the cell.

Note: If the sheet is currently being edited, you will not be able to change the Display By field or the timeline slider. To change the sheet display, first save any edits by clicking the Save button.

4 Click Save to save the sheet.

To delete an allocation
Select a row and click Delete.

Booking Summary Sheet
You can only see the Booking Summary sheet in active or on-hold projects or shells in which the Resource Manager is active. In the sheet you can view, add, or update hardbooked resources. In Primavera Unifier, resources are of two types: hardbooked or non-hardbooked.

- Hardbooked resources are labor resources that are firmly committed to a project and not available for other work.
- Non-hardbooked resources, which can include labor, leverage roles and are added to a project through the Resource Assignment form in the schedule sheet activity attribute form.

See the Resources tab discussion in Add an Activity.

Resource booking rows can be added to the sheet using the Resource Booking business process, or you can manually add them directly to the sheet. You can also modify data manually on the sheet. Data is rolled up from the project/shell Resource Booking Summary sheet. You can also view rates for each resource booking.

Note: Resource Booking business processes are not supported in generic shells. To compensate, however, you can manually add bookings to the Booking Summary sheet in shells.

To view the booking summary sheet

1 In the company-level or project/shell-level Resource Sheets log, select Booking Summary Sheet and click Open.

2 You can view this sheet by hours or cost:
   - To view by hours, click the View menu and choose Mode > Hours. The sheet displays the hours charged against each resource, as rolled up from the resource allocation sheets.
   - To view data by cost, click the View menu and choose Mode > Currency Amount. The sheet displays the cost charged against each resource, as rolled up from the resource allocation sheets.

3 You can group by role or resource:
   - To group by role, click the View menu and choose Group By > Role. This is the default.
• To group by resource, click the View menu and choose Group By > Resource. This groups the information by resource only. The role column is not applicable.

![Company-level resources booking summary sheet](image)

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role Name</td>
<td>Allocations are shown for each role. The role is always unique. The Role Name column is sorted alphabetically. The role name is hyperlinked. Clicking on the role name will open the Role properties window in view-only mode.</td>
</tr>
<tr>
<td>Resource Name</td>
<td>Bookings are shown for each resource against a role allocation. Resources are sorted alphabetically within a role. The resource name is hyperlinked. Clicking on the resource name will open the Resource properties window in view-only mode.</td>
</tr>
<tr>
<td>Project Name</td>
<td>Displays the project name for the booking row. The project name is hyperlinked and will open the project-level booking sheet. This column is displayed in the company-level sheet only.</td>
</tr>
<tr>
<td>Non-Project Time</td>
<td>This column only appears on the company-level Booking Summary. Displays a resource’s time that has been charged against non-project hours, such as PTO or vacation.</td>
</tr>
<tr>
<td>Date From</td>
<td>Earliest date that a non-zero booking exists for the resource.</td>
</tr>
<tr>
<td>Date To</td>
<td>Latest date that a non-zero booking exists for the resource.</td>
</tr>
<tr>
<td>Total Hours</td>
<td>Total hours (shown in the hours view only).</td>
</tr>
<tr>
<td>Total Cost</td>
<td>Total cost in base currency (shown in the cost view only).</td>
</tr>
<tr>
<td>Average Rate</td>
<td>Average resource rate per hour in company currency (shown in the cost view only).</td>
</tr>
</tbody>
</table>
To view cell details

1. Click on hyperlinked values (in View mode). With Modify permission, you can edit cell values (in Edit Mode). You can view information by hours or cost. You can also group information by roles or by resources. The cell details are read-only.

These are the fields in the Cell Details window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Code</td>
<td>The resource code assigned to the resource.</td>
</tr>
<tr>
<td>Resource Name</td>
<td>The resource name.</td>
</tr>
<tr>
<td>Role Name</td>
<td>The role name assigned to the resource.</td>
</tr>
<tr>
<td>Project Name</td>
<td>The name of the project associated with the resource.</td>
</tr>
<tr>
<td>Booked Week</td>
<td>The current time based on the timescale represented in the Booking Summary Sheet.</td>
</tr>
<tr>
<td>Total Booked Hrs.</td>
<td>The total hours booked through the Resource Booking business process transactions combined with manual booking transactions. All transactions are listed under Booking Transactions on the lower part of the Cell Details window.</td>
</tr>
<tr>
<td>Booking Transactions</td>
<td>The total hours booked through the Resource Booking business process.</td>
</tr>
<tr>
<td>Manual Booking Hrs.</td>
<td>The total hours booked through manual booking changes.</td>
</tr>
<tr>
<td>Average Rate (per Hour)</td>
<td>This can be the Role rate, or the rate specified when the booking was added.</td>
</tr>
<tr>
<td>Cost</td>
<td>The total of the rate multiplied by the hours.</td>
</tr>
<tr>
<td>Currency</td>
<td>The Company or project currency.</td>
</tr>
<tr>
<td>Booking Transactions</td>
<td>The various transactions that affect the booking hours. These transactions can occur through manual changes to the booking, or through the Resource Booking business process. Booking transactions that occur through the manual changes are specified as Manual Entry; transactions that occur through the</td>
</tr>
</tbody>
</table>

Oracle Corporation
Primavera Unifier Users Guide • Copyright © 1998, 2012, Oracle and/or its affiliates. All rights reserved.
Resource Booking business process are designated with the title of the business process.

2 Click Close Window when you are done viewing cell details.

To update a hard-booked resource to the Booking Summary Sheet

In Edit mode, and with Modify permission, you can manually update the values on the Booking Summary Sheet. You can update values for resource bookings that were added to the sheet through the Resource Booking business process, or values for resources that were added to the Booking Summary Sheet manually. Manually entered transactions costs are calculated based on the current day’s rate.

Note: The Resource Booking business process is used only to add bookings, not to modify existing bookings.

1 In the company-level or project-level Resource Sheets log, select Booking Summary Sheet and click Open.

2 Click Edit to enter Edit Mode.

Note: If you are in these modes: Mode > Currency Amount, Group By > Role, or Group By > Resource, you must choose the Mode > Hours to be able to access Edit Mode.

3 Increase or decrease the booking hours on the sheet as needed. You can select a row and click Clear to clear any row of values, and then enter new values.

All cells that contain hours values on the Booking Summary Sheet are editable. Hyperlinks to the Cell Details are not displayed in Edit Mode. You can edit hours in any display mode (Day, Week, Month). You can increase or decrease hours to any value greater than or equal to zero (0). Hours cannot exceed 24 hours for any day.

4 Click Save, or click View to return to View Mode without saving the changes. The cost or hours values are then displayed as hyperlinks. You can click these hyperlinks to view the Cell Details for the values.

All values that you change directly in the Booking Summary Sheet are reflected in the Cell Details for the resource booking. Each change to the resource bookings is listed in the Booking Transactions list, whether the change was made through the Resource Booking business process, or was made directly on the Booking Summary Sheet.

Note: Utilization Summary Sheet values are recalculated when the resource bookings are modified in the Booking Summary Sheet.

To manually add a hard-booked resource on the Booking Summary Sheet

You can add resource bookings using the Resource Booking business process, or by adding the resources directly into the Booking Summary sheet. Manually entered transactions costs are calculated based on the current day’s rate.
**Note:** The resource bookings that you add directly into the sheet have not been through the approval process inherent in the Resource Booking business process. Keep this in mind when you are using this method to add bookings to the sheet.

You must have Modify permission to be able to add a resource booking to the Booking Summary Sheet.

1. In the company-level or project-level Resource Sheets log, select **Booking Summary Sheet** and click **Open**.

2. Click **Add** to enter Edit Mode.

**Note:** If you are in these modes: **Mode > Currency Amount**, **Group By > Role**, or **Group By > Resource**, you must choose the **Mode > Hours** to be able to access Edit Mode.

The Resource Booking window opens.

![Resource Booking window, Company level](image)

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Booking Type</td>
<td>Select <strong>Project/Shell</strong> if you are booking the resource against a project or shell. Select <strong>Non-Project Time</strong> if you are booking the resource against non-project work. If you select this option, you will not need to specify a role name or a project/shell against which to book this time. You can select Non-Project Time only on company-level Booking Summary sheets.</td>
</tr>
<tr>
<td>Role Name</td>
<td>Select a role.</td>
</tr>
<tr>
<td>Resource Name</td>
<td>Select a resource name.</td>
</tr>
<tr>
<td>Project/Shell</td>
<td>Select a project or shell against which to book this time. At the Company level, this list includes active projects that have Resource Manager configured.</td>
</tr>
<tr>
<td>Non-Project Time</td>
<td>If the <strong>Booking Type</strong> is Non-Project Time, select the type of non-project work you are booking this resource against.</td>
</tr>
</tbody>
</table>
3 Click OK.

A new row is created in the Booking Summary Sheet. Enter values in the new row as needed. If the booking type is non-project time, Primavera Unifier will create a new row and populate the Non-Project time column with the type of time, such as “PTO” or “vacation,” or “administration.” All values for the row will be zero, which you can change manually where necessary.

4 Click Save, or click View to return to View Mode without saving the changes. The hours values are then displayed as hyperlinks. You can click these hyperlinks to view the Cell Detail values.

**Note:** Utilization Summary Sheet values are recalculated when resource bookings are added to the Booking Summary Sheet.

### Actuals Summary Sheet

This sheet lists the actual time (hours) entered by each resource using time sheet business processes, displaying resource hours for the project/shell or across projects/shells.

You can select the time sheet BP to use.

**To view the actuals summary sheet**

1 In the company-level or project-level Resource Sheets log, select Actuals Summary Sheet and click Open.

2 You can view this sheet by hours or cost:
   - To view by hours, click the View menu and choose Mode > Hours. The sheet displays the actual hours from time sheets.
   - To view data by cost, click the View menu and choose Mode > Currency Amount. The sheet displays the cost charged against each resource from time sheets.
<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>This sheet displays hour and cost information for each resource that has submitted time sheet business processes.</td>
</tr>
</tbody>
</table>

**To define the time sheet to roll up to the actuals sheet**

1. On the actuals summary sheet, click the Properties button.

2. In the Business Process field, click the drop-down menu and choose the Timesheet business process to use to roll up.

3. Click OK.
BOOKING VS. ACTUALS SUMMARY SHEET

At both the company level and project/shell level, you can use this sheet to see booking information versus actual time usage against a project or shell.

To view the Booking vs. Actuals summary sheet

1. In the company-level or project-level Resource Sheets log, select Bookings vs. Actuals Summary Sheet and click Open.

   Primavera Unifier displays a Properties window.

2. In the Properties window, specify the time sheet business process that should roll up values to the Booking vs. Actuals summary.

3. Click OK.

   Primavera Unifier uses the values on the time sheet business process you specified to calculate the data on the Booking vs. Actuals summary.

   The sheet shows all booked resources, along with their roles and the projects/shells they are booked in. It shows both the booked hours and the actual hours the resources worked on the project/shell. The sheet does not show non-project hours.

To see details

To see a resource’s booking details, click the hyperlinked hours in the Booked column. Primavera Unifier opens a Cell Detail window showing the booking details for the resource. To see detail on a resource’s actual hours worked, click the hyperlinked hours in the Actuals column. Primavera Unifier opens a Cell Detail window showing the actuals for the resource.

Utilization Summary Sheet

This sheet displays utilization in hours for each resource, per role.

Note: This sheet is not available in generic shells.
Project level
The sheet displays utilization of resources as a percentage at the project level and is shown for each resource-role combination.

\[
\text{Utilization\%} = \frac{\text{Total Assigned Hours}}{\text{Hard-booked Hours}} \times 100
\]

- Rolling over the cell value shows a break up of hard-booked hours and assigned hours.
- Utilization over 100\% (over-utilization) is displayed in red.

This sheet cannot be opened unless the Schedule Manager is loaded or a master schedule sheet is created.

To view the project-level utilization summary sheet
In the project-level Resource Sheets log, select Utilization Summary Sheet and click Open. You can view this sheet by hours only.

Company level
The information is displayed across projects.

To view the company-level utilization summary sheet
In the company-level Resource Sheets log, select Utilization Summary Sheet and click Open. You can view this sheet by hours only.

Example company-level utilization summary sheet

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Name</td>
<td>Displays resources by name.</td>
</tr>
<tr>
<td>Role</td>
<td>Displays the role, per resource.</td>
</tr>
</tbody>
</table>
AVAILABILITY SHEET

The Availability Sheet resides at the company level. This sheet shows the current availability of each resource across all projects/shells. A resource’s availability equals the resource’s total capacity (hours available), minus the total bookings across the projects/shells, and minus the non-project times specified. The sheet also shows over-bookings and zero hours where the resource is not available due to PTO, vacation, or administrative duties.

Unifier automatically adds the Resource Name column to the sheet; you cannot move this column. Unifier adds rows to the sheet whenever a Resource Booking business process is submitted. You can manually add columns directly to the sheet to show more information. You can also modify data manually on the sheet.

To open an Availability Sheet
In the company-level Resource Sheets log, select Availability Sheet and click Open.

To view a resource’s available hours and other information
Click the resource’s name. Unifier opens a read-only copy of the resource’s properties. These can include the resource’s address and phone number. This window will also show the resource’s capacity of work hours per week. Depending on the design of the Resource attribute form, this window might also show a breakdown (as in the example below) of the resource’s hourly working capacity by day.
To view booking details

You can drill down to an individual resource to see a read-only copy of the booking information. To do so, click on the value in any date column. Unifier displays the cell details.

The cell details show the following information:

<table>
<thead>
<tr>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Code</td>
<td>The code assigned to the resource</td>
</tr>
<tr>
<td>Resource Name</td>
<td>The name of the resource.</td>
</tr>
<tr>
<td>Period Type</td>
<td>The period of availability being displayed. (This reflects what the Display By choice was.)</td>
</tr>
<tr>
<td>Period</td>
<td>The time the data on this window covers (day, week ending date, month ending date).</td>
</tr>
<tr>
<td>Capacity</td>
<td>The hours the resource is available during the period.</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------</td>
</tr>
<tr>
<td>Booked Hours</td>
<td>The number of hours the resource is booked during this period.</td>
</tr>
<tr>
<td>Available Hours</td>
<td>The number of available hours the resource has left for booking during this period.</td>
</tr>
<tr>
<td>Transactions</td>
<td>The booking transactions that are reflected in the data in this window.</td>
</tr>
</tbody>
</table>

- **Project/Shell No.** shows the number of the project/shell for which the resource is booked.
- **Record Number** shows the number of the business process record (unless the entry was manual).
- **Title** shows the title of the business process. This column will show “Manual Entry” for any hours that were manually entered on the sheet.
- **From Date** shows the beginning date of the resource’s period of availability.
- **To Date** shows the end date of the resource’s period of availability.
- **Total Hrs** shows the total number of hours the resource is available during the period.

### To add columns to the sheet

By default, the left column of the sheet displays the name of the resource and cannot be edited or moved. You can add additional columns to the left side of the sheet to customize it to your needs. To add columns:

1. On the sheet, click the **Columns** button. The Columns window opens, showing the columns currently displayed on the left side of the sheet.
2. Click the **New** button. The Column Properties window opens.
3. Use the information in the following table to complete the fields in this window.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field will show the name of the element you choose in the Datasource field (below).</td>
</tr>
<tr>
<td>Datasource</td>
<td>Select a Data Source from the dropdown list. The list displays the data elements from the Resource Attribute form.</td>
</tr>
<tr>
<td>Data Format</td>
<td>This controls how data is displayed on the sheet. Select:</td>
</tr>
<tr>
<td></td>
<td><strong>Show as percentage</strong> to display the data as a percentage.</td>
</tr>
<tr>
<td></td>
<td><strong>Decimal places</strong> if you want the data to include decimal amounts. Choose 0 to 8.</td>
</tr>
<tr>
<td></td>
<td><strong>Use 1000 Separator</strong> if you want to include a comma (,) separator in numbers.</td>
</tr>
<tr>
<td></td>
<td><strong>Negative Number Format</strong> if you want to show negative numbers in parentheses or with a minus sign.</td>
</tr>
<tr>
<td>Display Mode</td>
<td>Show or Hide to display or hide the column from user view.</td>
</tr>
<tr>
<td>Column Position After</td>
<td>Specify the column after which this new column should appear.</td>
</tr>
</tbody>
</table>

4. Click **OK**. Unifier closes the Column Properties window.

On the Columns window, you can adjust the order of the column(s) you added by using the **Move Up (Left)** and **Move Down (Right)** buttons.
VIEW RESOURCE SHEETS

The company and project/shell Resource Manager sheets are created automatically when the Resource Manager is activated in Administration Mode.

To view company-level sheets


2. Select a sheet from the log and click Open.

To view project/shell level sheets

1. In User Mode:
   - For a standard project, select the Std. Projects tab > project > Resource Manager > Resource Sheets. The Resource Sheets log opens.
   - For a shell, select the <shell tab> Resource Manager > Resource Sheets. The Resource Sheets log opens.

2. Select a sheet from the log and click Open.

See the descriptions below for details about each of the sheets. In general, the sheets work similarly to each other at the company and project/shell level. In general, you can:

- View data by hours or by cost (not available on all sheets)
- Save or open the sheet as a PDF file, allowing you to save and print the sheet
- Create and view snapshots (not available on the resource allocation sheets)

The structure of each resource sheet is similar:

- The left pane of the sheet displays default columns, which depend on the sheet. For example, resource name, role name, etc.
• The right pane displays the time line columns. Depending upon the display (day, week, month), the time line will show a column for each period with the actual allocation in hours (hours view) or in currency (cost view).

• To change the timescale, click the **Display by** field at the top of the sheet and choose one of the following:
  
  • **Day**: The column header will show the actual date of the allocation.
  
  • **Week**: The column header will show the actual date of the start of the week (Monday) from the company calendar.
  
  • **Month**: The column header will show the actual date of the start of the month from the company calendar.

• In the upper right corner of each sheet is a time line slider:
  
  • To quickly scroll through the date columns, you can click the slider in the top right corner of the sheet and slide it to the time period you wish to view.
  
  • **Start of the time line**: The earliest date that can be displayed on the time line will be the minimum of the default start date specified in the Resource Manager configuration and the earliest transaction date.
  
  • **End of the time line**: The latest date displayed on the time line will be the maximum of the default date specified in the Resource Manager configuration and the latest transaction date.
  
  • **Default view**: By default, when the sheet is opened, the time line will always center on the current period (day, week, month). Scroll left or right to see other periods.
FILTER THE DATA ON A RESOURCE SHEET

The resource sheets can contain large amounts of data. To make working on the sheets easier, you can create a filter to limit the amount of data they display. For example, you could filter the sheet to show only certain resource roles, such as carpenters or electricians. Once you have created a filter, Primavera Unifier includes it on a list of filters available to anyone who uses the sheet. To create a filter:

1. Open the resource sheet from the log and choose View > Filters. The Set Up Filters window opens, showing a list of filters that have already been created (if any).

2. Click the Add button. The Add Filter window opens.

3. In the Filter Name field, enter a name for this filter.

4. Click the Add button. The Query Condition window opens. Use this window to create a query that will extract the data you want to see on the sheet. For information about creating a query, See "About Queries" on page 32.

5. To filter the sheet, click Apply Filter.

6. To save the filter, click OK.

To apply a filter to the sheet

1. Open the sheet in the log.

2. Click the Filtered by drop-down menu and select the filter you want to use.

3. Click Apply Filter.

Primavera Unifier refreshes the sheet to show the filtered records.

If you want to re-display all the rows on the sheet, you can clear the filter by choosing Clear Filters from the View menu.
To edit a filter

1. Open the sheet.
2. From the View menu, choose Filters. The Setup Filters window opens, showing a list of the filters that have been created for the sheet.
3. Select the filter you want to edit and click Edit.

Print Resource Sheets

To print or create a PDF file of the sheet

1. Open the sheet. Choose to view by hours or cost.
2. Click the File menu and choose Print.
3. At the prompt, choose to open the file or save as a PDF file.

If you open the file, the file will open in Acrobat Reader, from which you can print the file. If you choose to save the file, you can save to your local drive and print or distribute as needed.

Save And View Resource Sheet Snapshots

You can save a snapshot of all of the view-only sheets, except the resource allocation sheet.

To save a snapshot of the sheet

1. Open the sheet, and choose to view by hours or cost, where applicable.
2. Click the File menu and choose Create Snapshot.
3. Enter a title and click OK.

To view a snapshot

1. From the sheet, click the File menu and choose Open Snapshot.
2. Select a snapshot from the log and click Open.

Viewing And Configuring Resource Dashboards

The dashboard is available in the company-level and project-level Resource Manager. It allows you to monitor resource planning and deployment.

Data is refreshed when the Resource Dashboard node is selected or changes are made.

You can configure the dashboard to display charts in two-column layout. Configuring the Resource Dashboard is similar to setting up the project or company summary, except that the available charts are system-based and not based on user-defined reports.

You can choose to display system-defined charts in resource management key performance areas.

<table>
<thead>
<tr>
<th>Company Level</th>
<th>Project Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Booking</td>
<td>Booking</td>
</tr>
<tr>
<td>Actuals</td>
<td>Actuals</td>
</tr>
<tr>
<td>Utilization</td>
<td>Utilization</td>
</tr>
</tbody>
</table>
Supply vs. Demand

Supply vs. demand charts
These charts:

- Show allocations by role and compare them with resource daily capacity.
- Highlight issues with having too much demand that cannot be satisfied.
- Measure ability to satisfy resource demand and identify additional staffing needs.

These charts are used to display the existing demand (allocation) versus available capacity in the company. You can use these reports to verify that sufficient manpower is available in the company to satisfy this demand. The supply (or capacity) in this case is unconstrained and unnetted. This means that the capacity does not consider existing bookings (soft or hard).

Calculating values on the demand vs. supply charts:

\[
\text{Allocation } \% = \frac{\text{Total Allocation}}{\text{Total Capacity}} \times 100
\]

Allocation is obtained from the company allocation summary sheet for the specified range of dates. Total capacity will add capacity hours of all resources at the company level that can play the role (not limited to default roles) for the range of dates. Allocation cost is obtained from the company allocation summary sheet. The charts include active roles and active resources only. Capacity is based on the company calendar (working days only).

Actuals charts
These charts:

- Show actuals by role and corresponding bookings against the role. Non-project time can be included on the charts.
- Highlight issues with costs going over budget.

Calculations on actuals charts (company level):

- Data obtained from the company-level summary sheets based on the current configuration of the time sheet BP on the sheet.
- Booking used is hard-booking.
- Booking is obtained from company booking summary sheet.

Calculations on actuals charts (project level):

- Data obtained from the project-level summary sheet based on the current configuration of the time sheet BP on the sheet.
- Booking used is hard-booking.
- Booking is obtained from the project booking summary sheet.

Booking charts
These charts are used to plot resource booking (soft and hard) against demand (allocation) and capacity:

- Show allocations by role and corresponding bookings against the role.
- Highlight issues with underbooking or overbooking.
- Show hard- and soft-booking. Non-project time can also be shown.
- Successful satisfaction of resource demand via resource commitments (booking).
Calculations on the booking charts (company level):

- Booking obtained from company booking summary sheet for the specified range of dates.
- Allocation obtained from the company allocation summary sheet for the specified range of dates.
- Overbooking % = \[\frac{(\text{Total Booking} - \text{Capacity})}{\text{Capacity}}\] * 100 (0% if negative).
- Total capacity will add capacity hours of all resources at the company level that can play the role (not limited to default roles).
- Booking cost is obtained from the company allocation summary sheet.
- Total Booking = Soft + Hard booking.

Calculations on the booking charts (project level):

- Booking obtained from the project booking summary sheet for the specified range of dates.
- Allocation obtained from the project allocation summary sheet for the specified range of dates.
- Booking cost is obtained from the project allocation summary sheet.
- Capacity, Overbooking and Unmatched Supply column to show only at company level.
- Total Booking = Soft + Hard booking.

**Utilization charts**

These charts:

- Show utilization of resources against budgeted project work.
- Resource Manager can see that all resources are adequately occupied with billable project work. Administrative work at the company level does not count.

Calculating values on the utilization charts (company level):

- Utilization % obtained from the company utilization summary sheet for the specified range of dates.
- Booking is obtained from the company booking summary sheet.
- Assigned hours is obtained by adding assigned hours on project schedule sheets across all projects.
- Utilization % = \(\frac{\text{Total Assigned Hours}}{\text{Hard-booked Hours}}\) * 100 (shows two decimal places).

Calculating values on the utilization charts (project level):

- Utilization % obtained from the project utilization summary sheet for the specified range of dates.
- Booking is obtained from the project booking summary sheet.
- Assigned hours is obtained by adding assigned hours from the project schedule sheets.
ABOUT RESOURCE DASHBOARDS

The dashboard is available in the company-level and project/shell level Resource Manager. It allows you to monitor resource planning and deployment.

Data is refreshed when the Resource Dashboard node is selected or changes are made.

You can configure the dashboard to display charts in two-column layout. Configuring the Resource Dashboard is similar to setting up the project/shell or company summary, except that the available charts are system-based and not based on user-defined reports.

You can display system-defined charts in resource management key performance areas.

<table>
<thead>
<tr>
<th>Company Level</th>
<th>Project Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Booking</td>
<td>Booking</td>
</tr>
<tr>
<td>Actuals</td>
<td>Actuals</td>
</tr>
<tr>
<td>Utilization</td>
<td>Utilization</td>
</tr>
<tr>
<td>Supply vs. Demand</td>
<td></td>
</tr>
</tbody>
</table>

Supply vs. demand charts

These charts:

- Show allocations by role and compare them with resource daily capacity.
- Highlight issues with having too much demand that cannot be satisfied.
- Measure ability to satisfy resource demand and identify additional staffing needs.

These charts are used to display the existing demand (allocation) versus available capacity in the company. You can use these reports to verify that sufficient manpower is available in the company to satisfy this demand. The supply (or capacity) in this case is unconstrained and unnetted. This means that the capacity does not consider existing bookings (soft or hard).

Calculating values on the demand vs. supply charts:

\[
\text{Allocation \%} = \frac{\text{Total Allocation}}{\text{Total Capacity}} \times 100
\]

Allocation is obtained from the company allocation summary sheet for the specified range of dates. Total capacity will add capacity hours of all resources at the company level that can play the role (not limited to default roles) for the range of dates. Allocation cost is obtained from the company allocation summary sheet. The charts include active roles and active resources only. Capacity is based on the company calendar (working days only).

Actuals charts

These charts:

- Show actuals by role and corresponding bookings against the role. Non-project time can be included on the charts.
- Highlight issues with costs going over budget.

Calculations on actuals charts (company level):
• Data obtained from the company-level summary sheets based on the current configuration of the time sheet BP on the sheet.
• Booking used is hard-booking.
• Booking is obtained from company booking summary sheet.

Calculations on actuals charts (project level):
• Data obtained from the project-level summary sheet based on the current configuration of the time sheet BP on the sheet.
• Booking used is hard-booking.
• Booking is obtained from the project booking summary sheet.

Booking charts

These charts are used to plot resource booking (soft and hard) against demand (allocation) and capacity:
• Show allocations by role and corresponding bookings against the role.
• Highlight issues with underbooking or overbooking.
• Show hard- and soft-booking. Non-project time can also be shown.
• Successful satisfaction of resource demand via resource commitments (booking).

Calculations on the booking charts (company level):
• Booking obtained from company booking summary sheet for the specified range of dates.
• Allocation obtained from the company allocation summary sheet for the specified range of dates.
• Overbooking % = [(Total Booking – Capacity)/Capacity] * 100 (0% if negative).
• Total capacity will add capacity hours of all resources at the company level that can play the role (not limited to default roles).
• Booking cost is obtained from the company allocation summary sheet.
• Total Booking = Soft + Hard booking.

Calculations on the booking charts (project level):
• Booking obtained from the project booking summary sheet for the specified range of dates.
• Allocation obtained from the project allocation summary sheet for the specified range of dates.
• Booking cost is obtained from the project allocation summary sheet.
• Capacity, Overbooking and Unmatched Supply column to show only at company level.
• Total Booking = Soft + Hard booking.

Utilization charts

These charts:
• Show utilization of resources against budgeted project work.
• Resource Manager can see that all resources are adequately occupied with billable project work. Administrative work at the company level does not count.

Calculating values on the utilization charts (company level):
• Utilization % obtained from the company utilization summary sheet for the specified range of dates.
• Booking is obtained from the company booking summary sheet.
• Assigned hours is obtained by adding assigned hours on project schedule sheets across all projects.
• Utilization % = (Total Assigned Hours / Hard-booked Hours) * 100 (shows two decimal places).

Calculating values on the utilization charts (project level):

• Utilization % obtained from the project utilization summary sheet for the specified range of dates.
• Booking is obtained from the project booking summary sheet.
• Assigned hours is obtained by adding assigned hours from the project schedule sheets.

Configure The Dashboard

You can configure the content layout by doing the following:

• Add one or more charts in each column.
• Set up filter conditions and title for each chart.
• Add the same chart multiple times to the same column and display the same report with different query parameters.

To configure the resource manager dashboard

1 From the Resource Dashboard log, click Edit and choose one of the following:

• Left Column: The Left Column Blocks window opens.
• Right Column: The Right Column Blocks window opens.

These are set up the same way.

2 To add a chart, click Add. Complete the Add Summary Block window:

• Report Name: Click Select. Choose a chart from the list and click OK. The report fields are auto-populated. You can edit the title if desired.
• Specify filter conditions:
  • Roles and projects are multiselect fields (you can choose one or more from the list).
  • If fields are left empty, it means all.
  • Project field is disabled in the project-level dashboard and displays the current project.
  • Shows current project.

To edit a chart on the blocks list

Select it from the list and click Open.

To delete a chart on the blocks list

Select it from the list and click Delete.
Example project resource dashboard

**Print The Dashboard**

**To print the dashboard**

1. Navigate to the company-level or project-level resource dashboard.
2. Click File > Print Preview. A print preview window of the dashboard opens in an HTML view.
3. Click the Print button.

**About Resource Business Processes**

Resource-type business processes can be designed in Primavera uDesigner and imported into Primavera Unifier to work with the Resource Manager. There are two resource-type business processes that work with the Resource Manager: Resource Booking and Timesheet.

**Resource Booking Business Process**

This is used to book resources; that is, to fill project requirements with an available resource from the company. Resources can be booked within the duration of resource allocation.

- The Resource Booking business process is used only to add bookings, not to modify existing bookings.
- The Resource Booking business process is not available in generic shells. However, you can book resources via manual entry on the Resource Booking Sheet.

- When a record reaches a defined terminal status, the resource is hard-booked.
- While the record is in a non-terminal status, the resource is considered soft-booked.
- Resource Manager configuration determines if overbooking is allowed.

**To use a Resource Booking business process**

Open a project or shell and launch the resource booking business process. In the upper form, pick a date range to book resources. The date range will constrain the detail form grid display. The line item list displays a summary of booking rows.
Example Resource Booking business process

- Click the **Add** button and choose **Detail Line Item**. The Find window opens.
- Click **Select** to allocate the role, and then click the **Search** button. The business process pre-populates with rows from the project allocations summary sheet.
- The resource is hard-booked when the terminal status Approved is reached in the workflow. The resource is soft-booked when the status is other than the terminal status, for example, Pending.

**Timesheet Business Process**

Use the Timesheet business process to submit your time sheets. Actual hours and costs can be rolled up to the actuals summary sheets of the Resource Manager. The business process can also be designed to roll up costs to the project/shell cost sheet (Resource Actuals column).

The Timesheet business process:

- Specifies the time you spend on a project.
- Calculates rates based on role properties
- Rolls up actuals to the actuals summary sheet at the company level and project/shell level.

Multiple Timesheet business processes can exist for a company. For example, a company may design one Timesheet business process to capture and roll up time (hours) only. Another time sheet type BP can be used to design a reconciliation business process that references the time sheet and is used to specify, modify, and roll up actual costs.

The Timesheet business process is used to enter the actual hours you worked on each day. Time can be entered as regular work hours or over-time so that the appropriate billable rate can be applied. Time can be entered for company-level tasks, holidays, paid time off, and project or shell-level work. For billable activities, the billable rate is obtained from the role or from the project/shell booking (average booking rate), as applicable.

In addition to your own time sheet, a separate time sheet can be designed with a workflow schema that will accommodate someone else reporting your time on your behalf. For example, a company may allow a project manager or resource manager to report time for you.
If the Timesheet business process has been designed for line item entries, you can enter line items for time you spent on different types of work during a week, such as different projects. You could use other line items to report holidays, PTO, or company-level work.

The actual hours and corresponding costs from Timesheet business processes feed various sheets at the company and project/shell level, including company and project/shell actuals sheets, and company account and project/shell costs sheets.

**To use a time sheet business process**

Open a project, and launch the time sheet business process.

The **Week Of** required field is the limiting factor for the line items. The week begins on Sunday.

**Understanding Reverse Auto-population**

Certain data elements support reverse auto-population. These are specified in Primavera uDesigner. Reverse auto-population means that some values can be updated when other values are modified in a BP that has reached a specified status. Auto-population can occur on BPs that are in the same shell or across shells.

Depending on the setup in Primavera uDesigner, reverse auto-population can occur in these instances:

- Changes to data elements in a business process upper form can result in changes to the upper form of another business process.
- Changes to the detail form in a business process can result in changes to the upper form and detail form of another business process.
- Changes to the upper form or detail form of a business process can result in changes in the Asset, Resource, or Planning Manager forms.

In the Resource Manager, reverse auto-population might occur if a Resource Booking business process references a move order business process.
The Planning Manager provides sponsoring companies the ability to create, organize, manage, and update all company or project/shell planning initiatives from conception to completion. It supports the ability to define unlimited number of planning categories, such as capital project planning, IT planning, resource planning, etc., providing a flexible method for managing and organizing any type of planning initiative.

The Planning Manager provides the flexibility of defining unique planning item property forms and planning sheets. Each planning sheet can be configured with any number of columns to capture and manage data for all planned items.

In addition, the planning sheet can be configured to compare planned data with actual rolled up data from Primavera Unifier projects/shells, related to each planned initiative.

The Planning Sheet is central to Planning Manager functions. Each planning item “type” (such as a capital plan or a campus remodel) can have one or more planning sheets that contain information about the plans of this type being considered by your company or project. It is from these sheets that you can access, create, update, and import or export company plans. Business processes designed for planning items can roll up information onto the planning sheets. In addition, Project/Shell Creation types of business processes can be designed to create new projects or shells for planning items when they reach a certain status or condition. If the Project/Shell Creation BP includes a Planning Item Picker, you can link new projects/shells with a planning item. At runtime in Primavera Unifier, this BP will automatically create a link to the planning item when the project/shell is created, and data will begin to roll up to the Planning Sheet from the business processes in this project/shell.

In Primavera Unifier, the Planning Items node is where you create new plans and proposals, import plans from outside applications, export a plan template, and link a plan to a running project or shell in Primavera Unifier.

The Planning Sheets node is where you create and manage planning sheets. A planning sheet can contain data for one or multiple plans and proposals. From the planning sheet, users can automatically update individual plans with data added to the planning sheet and refresh the data on the sheet, such as changes to dates or cost numbers.
ABOUT THE PLANNING MANAGER

The Planning Manager is where you can plan for new projects/shells and proposals and create forecasts for those projects/shells that are already running in Primavera Unifier. You cannot administer planned projects/shells the way you administer real projects/shells in Primavera Unifier; however, you can manage the planning phases for these projects/shells as business processes in Primavera Unifier using the same functions used by other business processes. Planned projects/shells can include cost sheets, resource sheets, funding sheets, and other typical business processes; but certain data, such as dates and monies, can be viewed as future forecasts.

You can have a Planning Manager at both the company and project/shell levels.

The Planning Sheet is central to Planning Manager functions. This sheet contains information about all the plans (planning items) being considered by your company. It is from this sheet that you access, create, update, and import or export the company’s plans. From the planning sheet, you can automatically update plans with changes made on the planning sheet. Reciprocally, you can refresh the planning sheet with changes made to individual plans. In addition, planning sheets can be configured to compare planned data with actual rolled-up data from Primavera Unifier projects/shells related to each planning item.

Using a Project/Shell Creation type of business process, you can create new projects or shells for planning items when they reach a certain status or condition. If the Project/Shell Creation BP includes a Planning Item Picker, you can link new projects/shells with planning items. Instead of linking a planning item to a project in the Planning Manager, this BP will automatically create the link when the project/shell is created, and data will begin to roll up to the Planning Sheet from the business processes in this project/shell.

Using Primavera Unifier’s snapshot feature, you can take a “picture” of the planning sheet at any point in time. This is a way of “drilling down” into the planning process to expose specific plans or planning phases for particular attention.

In Primavera Unifier, the Planning Items node is where you create new plans and proposals, import plans from outside applications, export a plan template, and link a plan to a running project or shell in Primavera Unifier.

The Planning Sheets node is where you create and manage planning sheets. A planning sheet can contain data for one or multiple plans and proposals. From the planning sheet, you can automatically update individual plans with data added to the planning sheet and refresh the data on the sheet, such as changes to dates or cost numbers.

Access Planning Items And Planning Sheets

The Planning Manager groups planning initiatives by planning type; for example, Capital Planning or IT Planning. Each planning type will have a node available for planning items in that type, and also for planning sheets to manage the planning initiatives.

Planning items and sheets are grouped by their planning type.

To view planning items and planning sheets

1 In User Mode, navigate to:
   • (For a Planning Manager at the company level) Go to the Company Workspace tab and click Planning Manager in the left Navigator.
• (For a Planning Manager at the project/shell level) Open the shell or sub-shell where the Planning Manager resides. In the Navigator, click **Planning Manager**.

Primavera Unifier expands the navigator to show the planning types and their corresponding items and sheets.

2 To view:
  • Planning items, choose a `<planning type>` - **Items**
  • Planning sheets, choose a `<planning type>` - **Sheets**

Primavera Unifier displays the items or sheets in the right pane.

**Note**: If an advanced log has been designed for the Planning Manager, the log will display a tree structure with a middle column that narrows the navigation to help you locate and select the correct item or sheet.

3 To open the item or sheet, double-click the name of it in the right pane.
ACCESS PLANNING ITEMS FROM A MASTER LOG

Master Logs list all planning items at the shell/project level in separate nodes for each type.

If you are an active member of the project, shell, or sub-shell, and you have permissions, you can access shell/project planning item records from a Master Log. The Master Logs are located under the Home tab. The Master Logs allow you to access all or a subset of records of the same type, in a single log that spans multiple shells/projects. Also, you can create and use saved searches in the Master Logs.

Records are listed under the Master Logs node by planning item type. The Master Logs node can be renamed by your Administrator, and access to the node depends on permissions.

Depending on permissions, you can perform these actions on records listed in a Master Log:

- Create a new record
- Edit an existing record
- Perform bulk edits on records

You can also save searches of records in the Master Logs as needed.

**Note:** If you do not have permissions to view any of the planning item types listed under the Master Logs node, then you will not see the Master Logs node listed under the Home tab.

**To access Master Logs**

1. Go to the Home tab and click Master Logs - Planning Items in the left Navigator.
2. Click the name of the planning item you want to access.

**Create A Planning Item**

**To create a planning item**

1. Navigate to:
   - (For a Planning Manager at the company level) Go to the Company Workspace tab and click Planning Manager in the left Navigator.
   - (For a Planning Manager at the project/shell level) Open the project or shell here the Planning Manager resides and click Planning Manager in the left Navigator.

Primavera Unifier expands the navigator to show the planning types and their corresponding items and sheets.

2. Click the [planning item] - Items node. The [planning item] log opens.
3. Click New. The planning item form opens.
4. Complete the form fields. The form fields will vary depending on the design of the form for this planning type.

**Note:** If the planning item form has a Project or Shell Picker, you can use it to link the planning item directly to a project/shell. Business processes in the project or shell with fields that match those on the planning item form will roll up values to the Planning Sheet.
(Optional) Add an attachment to the planning item.

Click the Add Attachment button on the tool bar and select the place where the attachment resides, on your computer, or in a Primavera Unifier folder.

For a file on your computer, the File Upload window opens. Under Document Title, enter the title of the attachment you want to include, or click the Browse button to browse the directories on your computer for the file.

To add multiple attachments, click the Add Row button and repeat the step above.

When you have added the attachments, click OK.

You can also choose other options, such as including reference files and automatic revision. To do so, click the Advanced Options button.

For a Primavera Unifier file, the Select Files window opens, showing the company documents you can choose from.

Select the file and click OK.

Save the form (click Save to save or Finish Editing to prevent further editing).
BULK EDIT PLANNING ITEMS FROM THE PLANNING MANAGER LOG

For instructions on editing these records in bulk, see the information under Editing Multiple Records at once (Bulk Edit).
DELETE PLANNING ITEMS

You can delete planning items if they are in a non-terminal status. You can delete planning items in two ways:

• From the planning item record itself
• From the Planning Manager Log using Bulk Delete mode

Note: When you delete a record in Primavera Unifier, it is not actually deleted. It is only hidden from view on the log; the record remains in the system. Consequently, you cannot create another record with the same name. If there is a business process that auto-creates a planning item record, the name of that planning item will need to be changed; otherwise, you will never see it on the log.

To delete a planning item from a record
Open the record and click the Delete button on the toolbar.

To delete planning items from the Planning Manager log
1 Open the planning items log.
2 Highlight the item or items you want to delete.
3 From the Edit menu, choose Bulk Delete.

Note: You cannot delete planning items from a master log.

Create A Planning Sheet

You can create planning sheets for each planning type. These are based on templates created in Administration Mode.

To create a planning sheet
1 Navigate to:
   • (For a Planning Manager at the company level) Go to the Company Workspace tab and click Planning Manager in the left Navigator.
   • (For a Planning Manager at the project/shell level) Open the shell or sub-shell where the Planning Manager resides and click Planning Manager in the left Navigator.

   The Navigator expands to show the planning types and their corresponding items and sheets.

2 Under the planning type for which you want to create a sheet, click the [planning item] - Sheet node. The planning sheets log opens.

3 Click New. The Properties window opens.

4 On the General tab, name the planning sheet and enter an optional description.

5 Click the Options tab. For:
• **Sort by Column:** Choose the column to sort the planning item rows by. The default is Name (planning item name). As you add additional columns to the sheet, these columns will be available to select.

• **Sort Order:** Choose **Ascending** or **Descending**; works in conjunction with Sort by Column.

• **Update Planning Items:** Select this checkbox if you want planning sheet users to be able to manually edit planned item data. This helps prevent conflicting data from multiple planning items. This box can be checked on only one sheet per planning type. When you select this box, the sheet is moved to the top of the log and displayed in bold font, thereby acting as a master planning sheet.

6 Click **OK**. The planning sheet opens. The columns are those defined in the default structure. You can add additional columns as needed. Rows correspond to planning items. See "Add and manage planning sheet rows" on page 651.

**Copy A Planning Sheet**

The user will be allowed to create a new planning sheet under a planning type by copying another planning sheet. When a planning sheet is created by copying another planning sheet, all column definitions, manually entered data with each row should be replicated (copied over) including column definitions.

**To create a planning sheet by copying another planning sheet**

1 Select a planning sheet from the Planning Sheet log window.

2 Click the **Copy** button. The Properties window opens.

3 Enter a name for the new sheet. You can change the selections in the Options tab.

4 Click **OK**.

**Open The Planning Sheet**

**To open a planning sheet**

From the log window, double-click a sheet or select a sheet and click the **Open** button.

Columns displayed initially are based on the planning sheet default structure defined in Administration Mode (Configuration node).
Add And Manage Planning Sheet Rows

You can add planning items of the same type to create rows on the planning sheet. By default, there are two rows at the bottom of the sheet, one for total and one for average, which add a summary row for the column data.

To add a row (planning item) to a planning sheet

1. Open the planning sheet.
2. Click the Add Rows button. The planning items window opens, displaying the planning items created for the planning type.
3. Select one or more items and click Add Row. The rows are added to the sheet.

To delete a row from the planning sheet

1. Open the planning sheet.
2. On the planning sheet, select one or more rows to delete.
3. Click the Delete Rows button.
4. Click Yes to confirm. The rows will be removed from the sheet.

View Column Details

Clicking on a column link from the planning sheet will display the column details.

Refresh A Planning Sheet

Refreshing the planning sheet will update all rolled-up column data. This process runs in the background and may take some time to complete, depending on the design of the sheets being updated.

To refresh a planning sheet

1. Navigate to the planning sheet log.
2. Select one or more planning sheets and click the Refresh button.
Once the Refresh button is clicked, the Last Update column (if the log window was designed to show this column) will display In Progress to indicate that the planning sheet is getting refreshed. When the refresh is complete, the Last Update column will show the date on which the sheet was updated. Do not open the sheet while refresh is in progress.

**Modify Planning Items From A Planning Sheet**

You can update planning item information from a planning sheet. The **Update planning items** option must be selected in the planning sheet properties (Options tab).

While defining columns on a planning sheet, data elements from the planning item can be selected. Some of these data elements can be edited from the planning sheet. Changes made to these elements are reflected on planning items automatically.

Data elements that are editable and not required on the planning item form will be editable from the planning sheet. The following are conditions under which a data element is not editable from the sheet:

- BP picker data elements
- Project picker
- Shell picker
- Data elements that are required on the form
- Data elements that are of SYS Logical Datasource (formulas)
- Data elements that are SYS Datasource

You cannot change the planning name. This can only be changed from the planning item window.
BULK EDIT PLANNING ITEMS FROM THE PLANNING MANAGER LOG

For instructions on editing these records in bulk, see the information under Editing Multiple Records at once (Bulk Edit).

Grant Planning Sheet Permission

In addition to module-level permission, access to each planning item and planning sheet can be controlled based on user side permissions. The creator of a planning sheet is the owner of the sheet. By default, the owner has full sheet permissions. The owner can grant permission to other users or groups as needed.

To grant permissions to a planning sheet

1. In the planning sheet log, select the planning sheet.
2. Click the Permissions button. The Edit Permission window opens.
3. Add the users or groups you wish to grant permission, set the permission level, and click OK. The permission settings are:
   - Modify Permission: Can view, edit, and modify permissions of a planning sheet.
   - Modify Properties: Can edit planning sheet properties.
   - Edit: Can view, add, edit, or import data on a planning sheet. The user cannot change the column structure.
   - View: Can view the planning sheet in view-only mode.

Grant permission to the planning sheet
To grant permissions to a planning item

1. Open the Planning Item log that contains the item you want to grant permissions to.
2. Select the planning item.
3. Click the Permission button. The Edit Permission window opens.
4. Add the users or groups to whom you want to grant permissions and set the permissions you want to grant.
   - **Modify Permission**: Users can view, edit, and modify permissions of the planning item. With this permission, you automatically give the user edit and view permissions.
   - **Edit Data**: Users can edit the planning item information.
   - **View**: Users can view the planning item but cannot make changes.
5. Click Apply if you want to grant permissions to more users. Click OK to apply the permissions and close the window.

Understanding Reverse Auto-population

Certain data elements support reverse auto-population. These are specified in Primavera uDesigner. Reverse auto-population means that some values can be updated when other values are modified in a business process record that has reached a specified status.

Depending on the setup in Primavera uDesigner, auto-population can occur in these instances:

- Changes to data elements in a BP upper form can result in changes to the upper form of another BP.
- Changes to the detail form in a BP can result in changes to the upper form and detail form of another BP.
- Changes to the upper form or detail form of a BP can result in changes in the Asset, Resource, or Planning Manager forms.
PRINTING PLANNING ITEM RECORDS

At times, you may need to print copies of a planning item form. You can save a copy of the form as a PDF file and print the file, print an HTML view, or print from a Word file if a custom print layout has been created for the form.

**Note:** To print, the form must be in View mode. View mode refers to the non-editable version of the form. If the form is currently editable, you must click Finish Editing before the form can be printed.

**Print A Planning Item Form**

When printing planning item forms from PDF or HTML format, you can choose to include not only the information on the form itself, but also associated information such as general comments and information about file attachments. The print options are:

- Detail form data
- General comments made to the record
- Information about file attachments on the record or line items
- Comments made to file attachments

If custom print layouts have been created for the planning item, the form will print according to the layout that you select.

**To preview and print a planning item in PDF or HTML format**

1. Open the planning item that you want to print.
2. From the **File** menu, choose **Print Preview**, then choose one of the following:
   - **HTML**, to view the form in the browser, which can then be printed.
   - **PDF**, to open the form in Adobe Reader, which can be saved as a PDF file, or printed.

The Print Options window opens. This window displays the record information that can be printed.

3. Select the checkboxes for the information that you want to print.
4. To select all the checkboxes, click the **Select All** checkbox. To deselect all, uncheck the **Select All** checkbox. If you deselect all checkboxes, only the header and footer will print.
5. Click **OK**. The preview form opens in an HTML or PDF (Adobe Acrobat or Reader) window, from which you can print.

If you chose PDF, you can save a copy by clicking the **Save a Copy** button, or print. To print from HTML format, click on the **Print** icon in the upper right corner.

**Print Options**

Following is a summary of the print options.

<table>
<thead>
<tr>
<th>Print option</th>
<th>What it prints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detail Form</td>
<td>This prints the information entered on the form.</td>
</tr>
<tr>
<td>General Comments</td>
<td>The general comment text and create details are printed.</td>
</tr>
</tbody>
</table>
### Print option | What it prints
--- | ---
Record Attachments | File attachments to the record are listed alphabetically by file name, and also include the file title, issue date, revision number, and file size.
Record Attachments > Comments | Prints comments associated with file attachments to the record. "Record Attachments" must also be selected to select this option.

**To print a planning item with a custom print layout**

1. Open the planning item that you want to print. Be sure it is in a view mode.
2. From the **File** menu, choose **Print Preview > Custom**. The Custom Format Print window opens. The window lists custom layout options set up by the administrator.
3. Select a layout and click **OK**. The File Download window opens.
4. Choose to **Open** or **Save** the file, which is a Microsoft Word DOC file.
5. Open the file in Microsoft Word and print. (This feature works with Microsoft Word 2003 and 2007.)
PORTFOLIO MANAGER OVERVIEW

The Portfolio Manager is where the budget forecast planners in your company can gather cost and schedule information on projects (both planned and in execution) and perform analyses on “what if” scenarios. These scenarios are used to propose an optimal mix of projects for a portfolio, based on available budget targets and the strategic goals of the company.

As a planner, you can create a portfolio for a specific “planning horizon” (for example, from 2014 through 2020) and then create multiple scenarios in that portfolio. Each scenario can use forecast numbers and actuals, as well as schedule dates, for both planned and active projects in a specific shell type across a hierarchy in the company.

You create these scenarios on sheets, one for each scenario. The scenario sheets can pull in the following data from any shell type in a hierarchy:

- Project information from the shell attribute form or single-record business process
- Project start and end dates from the shell attribute form or single-record business process
- Cash flow data (both forecasted and actual) from each project’s Cost Manager

With this data, you can forecast costs over a specific time period (called a “period structure”). You can then manipulate scenarios by:

- Including or excluding projects
- Pushing start dates for planned projects into the future
- Modifying project end dates to change the project’s duration
- Proposing different cash flow distribution numbers by manually editing the cash flow columns
- Negotiating proposed budgets with project managers

Once these scenario analyses have been completed, the best (or several best) scenario(s) can be sent to the executive decision makers for approval.

Once a scenario has been approved, Primavera Unifier:

- Marks the approved scenario “shared” so that project managers can see the approved dates and numbers. The scenario is set to read-only mode and can no longer be modified or deleted.
- Updates each projects’ original budget numbers with the proposed numbers on the approved scenario.
- Updates each projects’ monthly or yearly cash flow numbers with the proposed numbers on the approved scenario.
- Updates the project start date (if it was changed) for any planned projects that will begin during the portfolio’s planning period.
- Locks the budget and cash flow numbers to prevent any further changes.
### ABOUT PORTFOLIO BUDGET CURVES

Portfolio budget curves are part of the Cost Manager function. You can view these budget curves from the Cash Flow node of the Cost Manager. Before you can view them, however, you must add these curves to your project/shell. For instructions on adding these curves, see [Adding a Portfolio Curve](#).

There are three of them:

- **A Shared Budget** curve. This curve shows your proposed numbers for the project. The project manager will not have access to this curve until you share a scenario. The project manager can include this curve on the cost worksheet, along with the forecast budget, or any other budget curve, in order to see the difference between the project’s numbers and your proposed budget numbers.

- **An Approved Budget** curve. When a scenario is approved in the Portfolio Manager, the budgets for each project in the scenario are marked “approved.” They are then locked and stored in the Portfolio Manager. An Approved Budget curve shows the approved budget for the project for that planning period (usually a year).

- **An Original Budget** curve. This curve is for a project in execution. This budget is the last approved budget for the project before it moved into its execution phase. This approved budget becomes the project’s original budget; and this original budget, plus any changes that occur to the numbers during the life of the project, becomes the project’s approved budget.

For example, an approved budget for the year 2015 might include a planned project for road construction that is scheduled to begin in 2017 with a budget of $100,000. The approved budget for the year 2016 will continue to include the planned road construction budget, with an addition of $15,000 to the forecasted budget. In the year 2017, the road construction project goes into execution, and the approved budget is $115,000. This figure becomes the original budget for the road construction project. From then on, as budget forecasting continues, the approved budget for the road construction will be the original budget, plus any changes that occur to the numbers during the life of that project.
Project's forecast curve

Curve based on the portfolio planner’s proposed numbers. This curve will not be visible on the worksheet until the portfolio planner shares a scenario.
VIEW AND OPEN PORTFOLIOS

Portfolios are grouped by their portfolio type. Scenarios are grouped under each portfolio.

To view portfolios

1. In User Mode, open the shell where the Portfolio Manager resides.

2. In the Navigator, click Portfolio Manager. Primavera Unifier expands the navigator to show the portfolio types currently loaded into Primavera Unifier.

3. In the Navigator, click the portfolio type that contains the portfolio you want to view. Primavera Unifier displays the portfolios for this type in the right pane.

To open a portfolio

1. In User Mode, open the shell where the Portfolio Manager resides.

2. In the Navigator, click Portfolio Manager. Primavera Unifier expands the navigator to show the portfolio types currently loaded into Primavera Unifier.

3. In the Navigator, click the portfolio type that contains the portfolio you want to open. Primavera Unifier displays the portfolios for this type in the right pane.

4. Double-click the name of the portfolio you want to open.

5. Primavera Unifier opens the portfolio to either:
   - The scenario that has been marked for sharing
   - The most recently updated scenario
CREATE OR MODIFY A PORTFOLIO

You can create a portfolio “from scratch,” or you can create one using a portfolio that has been approved for the current planning period.

To create a portfolio, you must have Create or Full Access permission.

**To create a portfolio**

1. Open the shell where the Portfolio Manager resides and click **Portfolio Manager** in the left Navigator. Primavera Unifier expands the navigator to show the portfolio types that reside in the shell.

2. In the Navigator, select the portfolio type under which you want to create a new portfolio.

3. In the right pane, click **New > Portfolio**. The Portfolio form opens.

4. Complete the form fields on the **General** tab. The form fields will vary, depending on the design of the form for this portfolio type; however, there are three mandatory fields on the form. Fill them in as follows.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Portfolio Name</td>
<td>Enter a name for the portfolio you are creating.</td>
</tr>
<tr>
<td>Period Picker</td>
<td>Select the year for which you want to analyze the data in this scenario.</td>
</tr>
<tr>
<td>Creation Date</td>
<td>This field shows the current date.</td>
</tr>
</tbody>
</table>

5. Click the **Options** tab.

The Options tab is where you specify the format you want to see for the numeric values on the scenario sheet.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal Places</td>
<td>Specify the number of decimal places the column data should display.</td>
</tr>
<tr>
<td>Use 1000 Separator (,)</td>
<td>If you want the data to be formatted with a separator (for example, 1,000, not 1000), select this check box.</td>
</tr>
<tr>
<td>Negative Number Format</td>
<td>Specify how negative values will be displayed on the sheet: with a negative sign, or in parentheses.</td>
</tr>
</tbody>
</table>

6. Click **OK**.

Primavera Unifier displays the portfolio name in the right pane and automatically creates an initial scenario sheet called **Scenario 1**. On this sheet, Primavera Unifier displays the projects that:

- Are included in the scenario, if the projects are configured to be automatically added
• Can be included on the scenario, if the project are configured to be manually added.

The project records for the scenario sheet are extracted from the database using a query that your Administrator created when the portfolio was configured. Whenever you open a portfolio, Primavera Unifier re-runs the query and adds or removes projects from the scenario depending on whether or not the project matches the query criteria. For example, a project that was previously on the sheet may be dropped from the sheet if it no longer meets the query criteria. Another project may be added to the sheet because it now meets the query criteria.

Create A Portfolio From An Approved Or Shared Portfolio

Rather than create a completely new portfolio for your next planning period, you can save time and effort by “copying” a portfolio that has already been shared or approved for the current planning period.

To create a new portfolio from an approved one

1 Open the Portfolio Manager log and select the portfolio you want to copy for the new planning period.

2 From the File menu, choose Plan for next period. The Portfolio Properties window opens. The General tab of the Properties window will show the name of the portfolio you selected as the new portfolio’s name. In addition, the Planning Period field will display that portfolio’s next planning period by default.

3 In the Name field, change the portfolio name.

4 If necessary, you can change the planning period by clicking the drop-down list beside the Planning Period field.

Note: The combination of the portfolio name and the planning period must be unique.

5 If necessary, you can change the numeric format on the Options tab.

6 Click OK. Primavera Unifier displays the portfolio name in the right pane and automatically creates an initial scenario sheet called Scenario 1. This scenario sheet will contain all the projects that were present in the portfolio you copied. These projects will show the data that was current for each project at the time the portfolio was copied, based on the matching monthly and yearly cash flow columns. For the new scenarios, Primavera Unifier will calculate the new totals and then calculate the variances to show the differences.

Note: If the original portfolio contained monthly numbers, and the new portfolio contains only a year column, the monthly numbers will be consolidated for the year. Conversely, if a year column is being copied into a portfolio with monthly columns, the number will be divided into monthly columns.
**FIND, SORT AND DELETE A PORTFOLIO LOG**

*Find a Portfolio*

For information on searching for a portfolio, see the instructions under Using the Find feature in Primavera Unifier.

*Sort a Portfolio*

You can sort the portfolio log by portfolio name into ascending or descending alphanumeric order. To do so, click the triangle icon on the right side of the **Portfolio Name** column.

*Delete a Portfolio*

1. Open the Portfolio Manager log.
2. Select the portfolio(s) you want to delete.
3. On the toolbar, click the **Delete** button.
ABOUT SCENARIO SHEETS

As the budget forecast planner, you can create scenarios to plan an optimal portfolio of projects for the company, based on available budget targets and strategic goals.

Portfolio management entails collaboration and negotiation between you, as the budget forecaster, and the project managers in your company. At their respective project levels, project managers maintain project information and create cash flow budgets and projections in the Cost Manager.

In the Portfolio Manager, on the scenario sheets you create, Primavera Unifier collects the budget and projection numbers from the projects’ Cost Managers, as well as project start and end dates from the project information.

During a scenario analysis, you can:

a. Apply regional budget targets
b. Group the projects in the scenario according to project characteristics
c. Sort and filter the rows of project data and analyze the summary totals
d. Accept the project managers’ budget numbers or propose new numbers
e. Accept the schedule dates, or remove or postpone planned projects
f. Create additional scenarios to reflect other possible forecasts

**Note:** The numbers you propose in a scenario will NOT affect a project’s live data. Your proposed numbers are stored only in the Portfolio Manager and will not affect live project data until a scenario has been approved by your company management.

During this analysis, you will likely be in touch with project managers to negotiate these numbers and dates until you reach agreement.

Project managers will not see the changes you make on the scenario sheet. Instead, the project managers must create a “shared” type of portfolio budget curve. This curve shows your proposed numbers for the project. The project manager can include this curve on the cost worksheet, along with the forecast budget, or any other budget curve, in order to see the difference between the project’s numbers and your proposed budget numbers.

In order for them to see the curve, you must share the scenario (see [Share a Scenario](#)).

For information about the portfolio budget curve, see Creating Cash Flow Detail Curves in Projects and Shells.

Once you have completed a budget forecast analysis using these scenarios, you can send the best (or several best) scenario(s) to the executive decision makers for approval by “sharing” the scenario.

**Overview Of A Scenario Sheet**

Following is an example of a scenario sheet, shown in sections:
### Sheet Information

- **These columns are fixed.** They will always appear on the sheet.
- An icon in the second column means the project is linked to the project data, and the data on the scenario sheet will be updated whenever you open the sheet.
- **These year columns can extend up to 15 years.** In addition, a certain number of years (0 to 5) may break down to show monthly columns, depending on how your administrator has designed the sheet.

### Column Descriptions

- **Project Name:**
- **Stage:**
- **Estimated Total:**
- **Contact Name:**
- **Prior Actuals:**
- **2011-2013:**

### Additional Features

- **This bar indicates the left border of the scrolling feature.** The columns on the left of this bar will always be visible when you scroll through the columns on the right.
- **Use this scroll bar to move through the columns on the sheet.**
- **You can resize columns by dragging the column margins with the mouse.**

---

*Oracle Corporation*

Primavera Unifier Users Guide • Copyright © 1998, 2012, Oracle and/or its affiliates. All rights reserved.
### Difference

- Difference is calculated by Unifier and shows the difference between the target number and the total.
- Targets are the target numbers the planner has designated for these totals. The planner enters the targets manually in this row.
- Totals shows the sum of the amounts in each numeric column.

### Current Project Data

- Click the tabs to move from one scenario sheet to another.
- This section of the sheet will display the current project data for any project row that you select in the grid above.
<table>
<thead>
<tr>
<th>Project Name</th>
<th>Pre-Actuas</th>
<th>Total</th>
<th>2012</th>
<th>Jan 2012</th>
<th>Feb 2012</th>
<th>Mar 2012</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Store</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>TJMaxx</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Parking Extension</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Rapid Central Station</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>South Tower Expansion</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Gates 3</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Mathis Parking Lot</td>
<td>$7,777.78</td>
<td>$1,044,666.67</td>
<td>$944,444.44</td>
<td>$60,000.00</td>
<td>$16,666.67</td>
<td>$27,777.78</td>
</tr>
<tr>
<td>Mathis Shopping Complex</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Rapid Transit Terminal 3</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
</tbody>
</table>

**Total**

|                   | $64,456.36 | $2,783,900.77 | $1,576,923.39 | $311,931.59 | $88,296.25 | $88,499.36 |

**Target**

|                   | $66,909.36 | $3,383,508.77 | $1,576,923.39 | $311,931.59 | $98,296.25 | $88,499.36 |

**Difference**

|                   | -$2,453.00 | $600,608.00   | $708,404.69   | $-20,931.59 | $9,000.00  | $-9,000.00 |

**Current Project Data**

|                   | $7,777.78  | $944,444.44   | $882,222.22   | $7,777.78   | $16,666.67 | $27,777.78 |

Italics indicate that there is a budget discrepancy between the actual project data and the data you entered on the sheet.

In addition to the italics, the actual project data that differs will show a dark bar at the top of the cell.

If you save the sheet after you make a change, Unifier will unlink the project from the sheet.
ABOUT SCENARIO SHEETS

As the budget forecast planner, you can create scenarios to plan an optimal portfolio of projects for the company, based on available budget targets and strategic goals.

Portfolio management entails collaboration and negotiation between you, as the budget forecaster, and the project managers in your company. At their respective project levels, project managers maintain project information and create cash flow budgets and projections in the Cost Manager.

In the Portfolio Manager, on the scenario sheets you create, Primavera Unifier collects the budget and projection numbers from the projects’ Cost Managers, as well as project start and end dates from the project information.

During a scenario analysis, you can:

a. Apply regional budget targets
b. Group the projects in the scenario according to project characteristics
c. Sort and filter the rows of project data and analyze the summary totals
d. Accept the project managers’ budget numbers or propose new numbers
e. Accept the schedule dates, or remove or postpone planned projects
f. Create additional scenarios to reflect other possible forecasts

Note: The numbers you propose in a scenario will NOT affect a project’s live data. Your proposed numbers are stored only in the Portfolio Manager and will not affect live project data until a scenario has been approved by your company management.

During this analysis, you will likely be in touch with project managers to negotiate these numbers and dates until you reach agreement.

Project managers will not see the changes you make on the scenario sheet. Instead, the project managers must create a “shared” type of portfolio budget curve. This curve shows your proposed numbers for the project. The project manager can include this curve on the cost worksheet, along with the forecast budget, or any other budget curve, in order to see the difference between the project’s numbers and your proposed budget numbers.

In order for them to see the curve, you must share the scenario (see Share a Scenario).

For information about the portfolio budget curve, see Creating Cash Flow Detail Curves in Projects and Shells.

Once you have completed a budget forecast analysis using these scenarios, you can send the best (or several best) scenario(s) to the executive decision makers for approval by “sharing” the scenario.

Overview Of A Scenario Sheet

Following is an example of a scenario sheet, shown in sections:
These columns are fixed. They will always appear on the sheet.

An icon in the second column means the project is linked to the project data, and the data on the scenario sheet will be updated whenever you open the sheet.

These columns and their content will vary. They are configured by your administrator to appear on the sheet.

These year columns can extend up to 15 years. In addition, a certain number of years (0 to 5) may break down to show monthly columns, depending on how your administrator has designed the sheet.

This bar indicates the left border of the scrolling feature. The columns on the left of this bar will always be visible when you scroll through the columns on the right.

Use this scroll bar to move through the columns on the sheet.

You can resize columns by dragging the column margins with the mouse.
Difference is calculated by Unifier and shows the difference between the target number and the total.

Targets are the target numbers the planner has designated for these totals. The planner enters the targets manually in this row.

Totals shows the sum of the amounts in each numeric column.

Click the tabs to move from one scenario sheet to another.

This section of the sheet will display the current project data for any project row that you select in the grid above.
Italics indicate that there is a budget discrepancy between the actual project data and the data you entered on the sheet. In addition to the italics, the actual project data that differs will show a dark bar at the top of the cell.

If you save the sheet after you make a change, Unifier will unlink the project from the sheet.
OPEN A SCENARIO SHEET

On the Portfolio Manager log, double-click the portfolio that contains the sheet you want to open. Primavera Unifier displays one of these scenario sheets:

- The scenario sheet marked “shared”
- The scenario sheet that was last updated, if there is no shared scenario
To view a scenario sheet's properties, click the Properties button at the top of the sheet. The Properties will show you the following information:

- Portfolio name
- Planning period for the portfolio analysis
- Date the portfolio was created
- Any other fields of information that were added to the Portfolio Manager form
UNLINK OR LINK PROJECTS

When you create a scenario, Primavera Unifier populates the sheet with all the projects that have met the criteria for inclusion on the sheet. (These criteria were created in a query by your administrator when the Portfolio Manager was configured.) This is a dynamic process that occurs whenever you open a scenario sheet. The projects that appear on the sheet will fluctuate, depending on whether they still meet the criteria for inclusion. For example, a project that was previously on the sheet may be dropped from the sheet if it no longer meets the query criteria. Another project may be added to the sheet because it now meets the query criteria.

According to the configuration your administrator created for the Portfolio Manager, all the projects on the scenario sheet will be automatically either linked or unlinked when you first open the scenario sheet.

- If they are linked, the data on the scenario sheet is linked to the project data and is updated every time you open the sheet. Any new project that is added to the sheet will also be linked.
- If they are unlinked, the data on the scenario sheet is not linked to the project data, and will not be updated by changes in the project data. Any new project that is added to the sheet will also be unlinked.

You can link and unlink one or multiple projects.

To link a project on the scenario sheet to current project data

1. Select the project row(s) you want to link.
2. Click the Link/Unlink button. Primavera Unifier will display a warning that any numbers you changed on the sheet will be lost if the project is linked. When the project is linked, you will see a link icon in the second column beside the project(s) name(s).
3. Click the Save icon.

To unlink a project from the scenario sheet

1. Select the project row(s) you want to unlink.
   - For a single project row, click the link icon in the second column, or click the Link/Unlink button.
   - For multiple project rows, click the Link/Unlink button.
When the project is unlinked, Primavera Unifier will delete the link icon in the second column beside the project(s) name(s).
2. Click the Save icon.

You can also unlink a project by editing any cell in the row. Once you start editing, Primavera Unifier will automatically unlink the project from the project data.

If an unlinked project shows a discrepancy between the actual project data and the data you entered on the sheet, Primavera Unifier will display the numbers in italics and flag the actual cell data that differs with a dark bar.
Italics indicate that there is a budget discrepancy between the actual project data and the data you entered on the sheet.

If you save the sheet after you make a change, Unifier will unlink the project from the sheet.

In addition to the italics, the actual project data that differs will show a dark bar at the top of the cell.
MANUALLY ADD OR REMOVE PROJECTS TO OR FROM A SCENARIO

When you create a scenario, Primavera Unifier collects all the projects that have met the criteria for inclusion on the sheet. (These criteria were created in a query by your administrator when the Portfolio Manager was configured.) The query that extracts the projects from the database is a dynamic process that occurs whenever you open a scenario sheet. The projects that appear on the sheet will fluctuate, depending on whether they still meet the criteria for inclusion. For example, a project that was previously on the sheet may be dropped from the sheet if it no longer meets the query criteria. Another project may be added to the sheet because it now meets the query criteria.

- If the portfolio has been configured for automatic adding and removing projects, Primavera Unifier will populate the sheet with these projects.
- If the portfolio has been configured for manual adding and removing projects, Primavera Unifier will display these projects at the bottom of the scenario window in a “candidates list,” a separate grid from which you can manually select and add projects to the scenario sheet.

Add A Project To A Scenario

At the bottom of the scenario window, Primavera Unifier displays a “candidates list” showing all the projects that have met the query criteria for inclusion on the scenario sheet. The candidate list shows only those projects that have not been added to any other portfolio for the same planning period. Also, it does not show any projects that have already been added to the scenario.
To add a project

1 Select the project in the candidate list at the bottom of the window.

To select multiple projects, hold down the CTRL key on your keyboard and click on the projects. To select all the projects, highlight the first project, then hold down the SHIFT key and select the last project.

2 Click the Add arrow. Primavera Unifier adds the project(s) to the scenario and recalculates the numbers.

- If the scenario sheet has been sorted, the project(s) will be added to the scenario according to the sort specification.
- If the scenario sheet has been grouped, the project(s) will be added to the correct group on the scenario according to the grouping specification. Primavera Unifier will recalculate sub-totals and group counts.
- If the scenario sheet has been filtered and sorted, the project(s) will be inserted at the top of the list. Primavera Unifier will not re-filter or re-sort the data.

Remove A Project From A Scenario

When you remove a project from a scenario, Primavera Unifier moves the project back to the candidates list at the bottom of the window. If that project continues to match the query criteria for inclusion on the scenario, it will remain on the candidates list; otherwise, it will drop from the list.

To remove a project

1 Select the project in the scenario.

To select multiple projects, hold down the CTRL key on your keyboard and click on the projects. To select all the projects, highlight the first project, then hold down the SHIFT key and select the last project.

2 Click the Remove arrow. Primavera Unifier removes the project(s) from the scenario and recalculates the numbers.
EDIT NUMBERS ON A SHEET

A primary function of scenario sheets is to make it easy for you to modify numbers and see the resulting budget analysis quickly. You can edit the following numbers on the scenario sheet:

- Cash flow projections
- Targets for cash flows and numeric columns
- Start and end dates for planned projects

When you edit any of these numbers, Primavera Unifier dynamically updates totals and calculates the differences between target numbers and those totals; however, it does NOT change a project’s live data. Your proposed numbers are stored only in the Portfolio Manager and will not affect live project data until a scenario has been approved by your company management.

**Note:** When you edit numbers in any project row, Primavera Unifier automatically unlinks that project row from the project data.

**To edit numbers on the sheet**

1. Double-click the cell containing the number you want to change. The cell becomes editable.

   **Note:** If any yearly projections have been broken down into months, you must make your edits in the month cells, not the yearly total.

2. Enter the change.

3. Press the **Enter** key on your keyboard, or press the **Tab** key to move to the next editable cell in the row.

   Primavera Unifier updates the values in the **Total** and **Difference** rows for this column, and flags the cell to indicate that there is a discrepancy between the number you entered and the project data.

   **Note:** To leave a cell without saving your changes, press the **ESC** key on your keyboard. Primavera Unifier restores the original numbers to the cell.

4. Click the **Save All** button.
DRILL DOWN TO PROJECT DATA

During the planning cycle, you might need quick access to project data in order to view project characteristics, schedule activities, cost data, cash flow data, and other information. In addition, you might need to update some of this data as you are working on a scenario. For this purpose, the project names on a scenario sheet are hyperlinked to the project. If you have permissions, you can open the project’s landing page from the scenario sheet and view or edit data directly in the project.

To drill down to project data

On the scenario sheet, click the hyperlinked project name. Primavera Unifier opens the project landing page in a new window. From this page, you can navigate to project data and view or edit it directly.

The scenario sheet remains open in a separate window so that you can easily work on both the project data and the scenario sheet at the same time.
CHANGE START DATES

You can change the start dates of planned projects, but not those in execution. When you change a start date, Primavera Unifier shifts the end date to preserve the project duration, and also shifts the cash flow numbers (excluding pre-actuals) left or right to preserve the cash flow distribution.

To change a start date

1. Double-click the date in the **Start Date** column. Primavera Unifier displays a calendar.
2. Choose the new date from the calendar and press the **Enter** key on your keyboard.

Primavera Unifier shifts the end date and the cash flow numbers to reflect the change.

**Before date change:**

<table>
<thead>
<tr>
<th>Start Date</th>
<th>End Date</th>
<th>Pre-Actuals</th>
<th>Total</th>
<th>2012</th>
<th>2013</th>
<th>2014</th>
<th>2015</th>
<th>2016</th>
</tr>
</thead>
<tbody>
<tr>
<td>12/26/2011</td>
<td>05/31/2013</td>
<td>$7,777.78</td>
<td>$994,444.44</td>
<td>$982,222.22</td>
<td>$102,222.22</td>
<td>$0.00</td>
<td>$0.00</td>
<td>$0.00</td>
</tr>
</tbody>
</table>

**After date change:**

<table>
<thead>
<tr>
<th>Start Date</th>
<th>End Date</th>
<th>Pre-Actuals</th>
<th>Total</th>
<th>2012</th>
<th>2013</th>
<th>2014</th>
<th>2015</th>
<th>2016</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/26/2012</td>
<td>09/29/2013</td>
<td>$7,777.78</td>
<td>$994,444.44</td>
<td>$494,444.44</td>
<td>$500,000.00</td>
<td>$0.09</td>
<td>$0.00</td>
<td>$0.00</td>
</tr>
</tbody>
</table>

**How Primavera Unifier Distributes Cash Flow**

Primavera Unifier stores all cash flow amounts by month in the database. The logic Primavera Unifier uses to distribute cash flow dollars is rendered in monthly allocations and displayed as follows:

If you move the start date backwards by (for example) 3 months, Primavera Unifier will move all the cash flow amounts (excluding the pre-actuals column) left by 3 months and display a zero dollar amount in the **last 3 month columns** for that year. Amounts from the following fiscal year will not move left.

If you move a start date forward by 3 months, Primavera Unifier will move all the cash flow amounts (excluding the pre-actuals column) right by 3 months and display a zero dollar amount in the **first 3 month columns**. The cash flow amounts will continue to move forward in time, replacing the values of the next 3 months with the values of the past 3 months. If the cash flows through multiple years, the total for the next year will increase by the 3 months’ amount, and the monthly cash flow for the last 3 months of the previous year will replace the new year’s first 3 months. The rest of the new year’s monthly values will move forward 3 columns.
**CHANGE CASH FLOW AMOUNTS**

You can change the cash flow amounts of any project on the sheet, planned or in execution. When you change a number in the cash flow amounts, Primavera Unifier unlinks the project from the live project data.

To change a cash flow amount

1. Double-click the cell containing the amount you want to change.
2. Enter your change and press the **Enter** key on your keyboard.

The project’s **Total** amount and the year’s total amount increases or decreases by the amount you entered. Primavera Unifier calculates the difference, indicates the edited column amounts in italics, and also places a dark bar at the top of the cell in the actual project data.

**Before change:**

![Before change screenshot]

**After change:**

![After change screenshot]

$15,000 added to Jan 2014 column. Total column and 2014 year column increased by $15,000. Dark bar added to cell in the actual project data that was changed by the edit.
EDIT PROJECT INFORMATION

Your scenario sheets will typically contain some project information. If this project information was configured to be editable, you can edit it. If you do so, these changes will NOT affect the project’s live data. Your edits are stored only in the Portfolio Manager and will not affect live project data until a scenario has been approved by your company management. When the scenario is approved, specified edited shell information will be updated with the approved scenario data, and you will be notified by email of the updates.

You cannot edit:

- Project name
- Number
- Status
- Location

**Note:** When you edit information in a project row, Primavera Unifier automatically unlinks that project row from the project data.

**To edit project information**

1. Double-click the cell containing the information you want to change. The cell becomes editable.
2. Enter the change.
3. Press the **Enter** key on your keyboard, or press the **Tab** key to move to the next editable cell in the row.

Primavera Unifier updates the information in this column, and flags the cell to indicate that there is a discrepancy between the data you entered and the project’s data.

**Note:** To leave a cell without saving your changes, press the **ESC** key on your keyboard. Primavera Unifier restores the original numbers to the cell.

4. Click the **Save All** button.
HIDE OR SHOW COLUMNS

To make viewing information easier on either the scenario sheet or the project candidate list, you can hide any cash flow columns that might not contain data relevant to your current task.

**To hide a column**

1. Click the arrow beside the column name and choose Columns.
2. On the list that appears, select the check box beside the columns you want to hide. Primavera Unifier removes those columns from view.

**To show a hidden column**

1. Click the arrow beside the column name and choose Columns.
2. On the list that appears, de-select the check box beside the columns you want to show. Primavera Unifier opens those columns to view.
FILTER THE SCENARIO SHEET

To make viewing project information easier, you can use filters on both the scenario sheet and the project candidate list to narrow the focus of information to particular specifics, such as a date range, or a budget amount. For example, you might want to see only those projects in a specific date range, or only those projects with budgets greater than a specific amount, or projects of a specific type.

How you filter information depends on the column you choose to use as a filter.

To filter information using a text column

1. Click the arrow beside the column name and choose Filters.
2. In the text box that appears, enter the text you want to use as a filter, such as a project name or prefix.
   Primavera Unifier displays those projects that match the text you entered.

To filter information using a date column

Click the arrow beside the column name and choose Filters.

• Choose Before to specify a date period before a particular date. Click the date on the calendar that appears. Primavera Unifier displays all the projects with a date value that occurs before the date you specified on the calendar.
• Choose After to specify a date period after a particular date. Click the date on the calendar that appears. Primavera Unifier displays all the projects with a date value that occurs after the date you specified on the calendar.
• Choose On to specify a specific date. Click the date on the calendar that appears. Primavera Unifier displays all the projects with a date value that matches the date you specified on the calendar.

To filter information using a numeric column

Click the arrow beside the column name and choose Filters.

• Enter a number “greater than” a specific number to display all the projects with numbers in that column greater than the number you specified.
• Enter a number “less than” a specific number to display all the projects with numbers in that column less than the number you specified.
• Enter a number “equal to” a specific number to display all the projects with numbers in that column that match the number you specified.

To return the sheet to an unfiltered state
To return the sheet to an unfiltered state, click the arrow beside the column name and deselect the Filters check box.
GROUP THE DATA ON A SCENARIO SHEET

You can group the data on the sheet by column. Grouping data can make it easier to identify projects with similar characteristics, such as estimated cost or start date. You can group by any column except the Pre-Actuals and year columns. When you group data, Primavera Unifier displays a sub-total amount by group.

To group the data

1 Identify the column by which you want to group the data and click the down arrow beside the heading.

2 Select Group By This Field.

Primavera Unifier groups the data by the column value. Groupings are separated and identified by the column value you grouped on, such as Project State “In Execution” and “Planning.”

You can expand and collapse a group by clicking the arrow here.

Once you have grouped the data, you can further refine the view by sorting and filtering the data within each group.
3 If you want to maintain the data in this grouping, click the **Save** icon. Whenever you open the sheet, it will display the data in this grouping.

**To ungroup data**

1. Click the down arrow beside the column heading.
2. Select **Clear Grouping**.
SORT THE DATA ON A SCENARIO SHEET

To make data easier to locate alphanumerically on either the scenario sheet or the project candidate list, you can sort the information by column in ascending or descending order. To sort the sheet by column, click the arrow beside the column heading and choose Sort Ascending or Sort Descending.

You can also sort the data by multiple columns. To do so, hold down the Ctrl key on your keyboard and click the arrows beside the column headings you want to sort by.
CREATE A NEW SCENARIO

When you create a portfolio, Primavera Unifier automatically creates one initial scenario sheet. You can create additional scenario sheets.

To create a new scenario sheet

1. To add a new scenario sheet, click the plus sign at the bottom of the scenario sheet window.

   ![Click the plus sign.]

   Primavera Unifier adds a “new scenario” tab to the bottom of the window.

2. Enter a name for the new scenario and press the Enter key on your keyboard.
   
   You can include up to 30 characters in the name. Letters, numbers, hyphens, spaces, underscores, and special characters are allowed.

3. Click Save All.

   The project records that will be included on the scenario sheet are extracted from the database using a query that your Administrator created when the portfolio was configured. Whenever you create or open a scenario sheet, Primavera Unifier re-runs the query and adds or removes projects from the scenario depending on whether or not the project matches the query criteria. For example, a project that was previously on the sheet may be dropped from the sheet if it no longer meets the query criteria. Another project may be added to the sheet because it now meets the query criteria.
EDIT THE NAME OF A SCENARIO SHEET

1. At the bottom of the scenario sheet window, click on the tab showing the name you want to edit. The tab name becomes editable.

2. Change the name as necessary. You can include up to 30 characters in the name. Letters, numbers, hyphens, spaces, underscores, and special characters are allowed.
COPY A SCENARIO

1 At the bottom of the scenario sheet window, select the tab containing the scenario you want to copy.

2 Click the manage scenarios icon and choose **Duplicate Selected Tab**.

3 Click **Save**.

Primavera Unifier copies the scenario into a new tab, which you can rename. All the projects in the original scenario will be copied to the new scenario, including their linked or unlinked state, and current column widths, targets, sorting, etc. For the new scenario, Primavera Unifier will calculate the new totals and then calculate the variance to show the difference.
SHARE A SCENARIO

Sharing a scenario makes the budget numbers you propose available to project managers for viewing. Project managers will not see the changes you make on the scenario sheet itself. Instead, the project managers will use a read-only portfolio budget curve in their Cost Manager Cash Flow node to view both their original budget curve and a parallel scenario curve that shows the differences between their initial forecast projections and your proposed numbers.

In order for project managers to see the portfolio budget curve, you must share the scenario. For information about the portfolio budget curve, see Creating Cash Flow Detail Curves in Projects and Shells.

You must have “full access” permission to share a scenario. You can share only one scenario at a time.

To share a scenario

1. At the bottom of the scenario sheet window, select the tab containing the scenario you want to share.
2. Click the manage scenarios icon and choose Share Selected Tab.
3. Click Save All.

Primavera Unifier visually marks the scenario tab with a “shared” icon and makes the scenario numbers visible on the portfolio budget cash flow curve for the project manager to see.

Stop sharing a scenario

1. At the bottom of the scenario sheet window, select the tab containing the scenario you want to stop sharing.
2. Click the manage scenarios icon and choose Stop Sharing Selected Tab.
3. Click Save All.
DELETE A SCENARIO

1. At the bottom of the scenario sheet window, select the tab containing the scenario you want to delete.

2. Click the manage scenarios icon and choose **Delete Selected Tab**.

3. Click **Save All**.
APPROVE A SCENARIO

After management has approved a scenario for the portfolio, you can mark the scenario as “approved.” You must have “full access” permission to approve a scenario.

Once you approve a scenario, Primavera Unifier:

- Marks the approved scenario “shared” so that project managers can see the approved dates and numbers. The scenario is set to read-only mode and can no longer be modified or deleted.
- Updates each projects’ original budget numbers with the proposed numbers on the approved scenario.
- Updates each projects’ monthly or yearly cash flow numbers with the proposed numbers on the approved scenario.
- Updates the project start date (if it was changed) for any planned projects that will begin during the portfolio’s planning period.
- Updates the project/shell data with any project/shell information that was changed on the scenario sheet, and sends you an email notification of the updates.
- Locks the budget and cash flow numbers to prevent any further changes.

To approve a scenario

1. At the bottom of the scenario sheet window, select the tab containing the scenario you want to approve.
2. Click the manage scenarios icon and choose Approve Selected Tab.
3. Click Save All.

When you approve a scenario, Primavera Unifier automatically shares the scenario and visually marks the scenario tab with an “approved and shared” icon to indicate to project managers that this is the approved scenario.
To “un-approve” a scenario

1. At the bottom of the scenario sheet window, select the tab containing the scenario you want to un-approve.

2. Click the manage scenarios icon and choose **Un-Approve Selected Tab**.
   
   The Portfolio Manager deletes the approval icon from the tab, but does not delete the shared icon. If you want to stop sharing the scenario as well, you must click the manage scenarios icon and choose **Unshare Selected Tab**

3. Click **Save All**.

**Note:** If you “un-approve” a scenario, Primavera Unifier does NOT reset dates to their original values. Date fields will retain the approved values.
To use scenario data for additional purposes, you can export your scenario sheets to Excel.

To export scenarios

Click the **Export** button at the top of the window. The Portfolio Manager will export all of your scenario sheets to Excel.

You will see a prompt at the bottom of the window, asking you to open or save the Excel sheets.

When you open the Excel sheet, it displays the data from each scenario sheet, arrayed in tabs and columns identical to the Portfolio Manager scenarios. The Excel sheet will include any formulas that were created in the Portfolio Manager for calculating values. The Excel sheet also honors the frozen columns, as well as the scrolling ability so that you can scroll through the cash flow columns.
SCHEDULE MANAGER
ABOUT THE SCHEDULE MANAGER

The Schedule Manager helps you manage project or shell and program schedules. You can create a **Project/Shell Schedule Sheet** that is customized to the project’s or shell’s needs. Once these sheets are created, you can then use them to create project/shell activities and tasks, assign resources to tasks, create relationships between activities, track schedule progress and variables, and calculate the schedule’s critical path.

In Primavera Unifier, you can also import project schedule records from Primavera Project Planner® or Microsoft® Project. These external project schedules can provide additional detail or supporting schedule information; for example, resource information, or subcontractor or vendor schedules. Imported schedules are editable within Primavera Unifier, and the data can be used in reports.

The Schedule Manager presents schedule activities as interactive Gantt charts, where you can:

- Zoom in to see tasks at the day, week, or month level
- Move activities and add dependency relationships, and automatically update the dates on the schedule
- Create critical path calculations that will flag activities that, if delayed, can cause the schedule to go beyond the planned project end date

Using Primavera Unifier’s snapshot feature, you can take a “picture” of the schedule sheet at any point in time. Using the Schedule Manager’s baseline function, you can measure progress and determine payments against original estimates; and with the tracking Gantt feature, you can compare schedule dates, such as baseline estimates against the actual schedule.

If you copy activities from one schedule to another, Primavera Unifier will immediately notify you if the change will create a schedule conflict so that you can make corrections as you work. Each change in the Schedule Manager creates a record in Primavera Unifier, which is useful for auditing purposes. An audit report of these records shows detailed information on dates, events, actions, and old values versus new values, along with the user or proxy user who performed the action.

Each project/shell can have multiple schedule sheets, and one master schedule sheet. This master sheet drives project start and end dates, tracks the project’s progress, and serves as the interface between the Schedule Manager and other Primavera Unifier modules. In particular, the master schedule updates resource assignment information in the Resource Manager, which affects timesheets and resource utilization figures; and it integrates cost items on the schedule with the Cost Manager. Primavera Unifier users can refresh resource rates on the schedule sheet and post the new rates to the Cost Manager, update the cost sheet with assignment costs, and refresh costs on the sheet to recalculate labor costs and post them to the cost sheet.

Features include the following:

- Fully configurable activity attributes form
- Activities and Gantt chart on the same schedule sheet
- Interactive Gantt chart with ability to drag activity end dates and link activities
- Tracking Gantt chart
- Filters for activities
- Baselines for schedule sheets and activity sheets
- Activity update
- Ability to create one or multiple interactive schedule sheets for the same project or shell
• Integration of Schedule Manager with the Resource Manager, enabling resource loading of schedule activities
• Multiple WBS codes for each activity to capture activity costs, such as labor, non-labor, and fixed costs. If designed in Primavera uDesigner, you can add a column to the schedule sheet to display the WBS codes associated with each activity.
• View the cost distribution information by WBS codes from a schedule sheet
• Cut and paste and copy and paste of rows in a sheet
• Update of schedule sheets from linked templates
• Critical path calculation and display
• Streamlined and enhanced integration and interaction between Primavera Unifier’s Schedule Manager and Primavera and Microsoft Project
• Activity progress tracking and percentage of work completed per assigned resource
• Works with shells that have the WBS cost type
• Scope Management, with the ability to launch business processes from activities and automate schedule management.
• Budget and progress settings, and the ability to work with progress and earned progress data

The Schedule Manager is available for projects or WBS-based shells.

**Schedule Sheet Permissions**

User Mode sheet-level permissions can be assigned by the creator or a user with Full Access permission. Sheet-level permissions are set up on each project or shell Schedule Sheet on the user side, and can also be set up on schedule sheets within project or shell templates.

**To assign permissions to a schedule sheet**

1. Open the project or shell, or the project/shell template.
2. Select the schedule sheet in the Schedule Sheets log.
3. Click the **Permission** button.
4. Add users or groups and assign permissions:
   - **Modify Permissions**: Allows the user to modify the permissions of a schedule sheet. Checking this permission will check all permissions below.
   - **Edit Data**: Allows the user to edit the sheet, including data, columns, and rows, cut and paste activities. Users that have the Edit Data permission can import data. They can also edit Activity Progress and refresh the schedule sheet.
   - **Edit Data and Structure**: Allows the user to set and clear baselines on schedule sheets and Activity Sheets; also to copy and paste activities. Enables users to add or remove linked schedule sheet templates. Also enables users to edit data element level restrictions on activities on a schedule sheet.

Users with the Edit Data and Structure permission can edit these activity progress related components:

- Options tab of the Schedule Sheet Properties
- Budget and Progress Setup (schedule sheet level or activity level)
- Activity Progress
• Activity Progress Log
• Schedule sheet refresh

• View: Allows the user view-only access to the sheet. Automatically granted if any of the permissions above are granted. Can also view the Linked Template window.

5 Click OK.

Create A Schedule Sheet

Each schedule sheet that you create has its own set of properties, which you can use to control schedule sheet behavior.

Primavera Unifier separates Schedule Sheet Properties into five tabs; each tab has a distinct purpose.

• The General tab is where you can define basic schedule information, for example, Schedule Sheet Name, and Start Date.
• The Gantt Chart tab is where you can define what you want to see in the visual representation of the sheet, for example, common choices are Activity Name, Start Date, and Finish Date.
• The Tracking Gantt tab is where you can set up comparisons of activities, for example, you can compare Actual Start Date with the originally planned Start Date.
• The Options tab is where you can set up how you want Primavera Unifier to update activity status and progress requirements.
• The Schedule tab is where you set the schedule sheet refresh schedule.

You can create a project or shell schedule sheet in the following ways:

• Manually
• Copying from a project/shell schedule sheet template
• Copying from another schedule sheet in your project
• Importing a third party schedule file.

You can have any number of schedule sheets in a project or shell. You can designate one sheet as a master schedule sheet, which appears in bold in the log. The master schedule sheet drives the activity start and finish dates, and allows you to assign resources to activities. You can use it to track progress and resource assignment information to other modules in Primavera Unifier.

Note: You may want to set up the schedule sheet before selecting it as the master sheet. Once you select the sheet as the master sheet, it cannot be deselected.

To create a project or shell schedule sheet manually

1 In User Mode, select the project or shell, and select Schedule Manager > Schedule Sheets. The Schedule Sheets log opens.
2 Click New. The Schedule Properties window opens.
3 Complete the Schedule Properties tabs. See General tab on the schedule sheet properties.

To create a schedule sheet by copying from a project or shell template

1 In User Mode, select the project or shell, and select Schedule Manager > Schedule Sheets. The Schedule Sheets log opens.
2 In the Schedule Sheets log, click Copy > Template.
Select the template to copy and click **Open**.

4 Complete the Schedule Properties tabs. See [General tab on the schedule sheet properties](#).

**To create a project or shell schedule sheet by copying another sheet**

1 In User Mode, select the project or shell, and select **Schedule Manager > Schedule Sheets**. The Schedule Sheets log opens.

2 In the Schedule Sheets log, click **Copy**. The Schedule Sheets window opens showing all sheets in the project/shell (both active and inactive)

3 Select the schedule sheet to copy and click **Open**. The Schedule Sheet Properties window opens.

4 Complete the Schedule Properties tabs. See [General tab on the schedule sheet properties](#).

**To import CSV files**

1 Open the schedule sheet.

2 Choose **File > Import > From CSV**. If a default mapping is not selected, the Select Data Mapping window opens.

3 Select the data mapping you want to use for this import and click **OK**. The File Upload window opens.

4 Browse to select the file to upload.

5 Click **OK**.

**To import XML and MPP files**

1 Open the schedule sheet.

2 Choose **File > Import > From External Source**. If a default mapping is not selected, the Select Data Mapping window opens.

3 Use the following table to complete the fields in this window.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>MPP</td>
<td>Data mapping is not required; leave the Data Mapping field empty.</td>
</tr>
<tr>
<td>MPP XML</td>
<td>Data mapping is required; select the mapping you want to use.</td>
</tr>
<tr>
<td>MPP activity calendar</td>
<td>Select Consider Activity Calendar. This requires an existing calendar in Primavera Unifier with the same name. If an activity calendar is not imported and considered, the activity will use the existing calendar defined in the schedule sheet properties.</td>
</tr>
<tr>
<td>MPP Resource assignments</td>
<td>Data mapping is not required; leave the Data Mapping field empty. This requires a data set for the SYS Resource Type data element. Use MPP standard resource types: Work, Material, and Cost. Upon import, Primavera Unifier will soft-book these resource types.</td>
</tr>
</tbody>
</table>

4 Click **OK**. The File Upload window opens.

5 Browse to select the file to upload.
Click OK

Before you begin:

- You must have permission to import files. See Define sheet-level permissions.
- For CSV or XML files, your administrator must first define the data mapping.
- To use the Activity Calendar from Microsoft Project, first create a calendar in Primavera Unifier with the same name as the external calendar.
- To import Resource Assignments from Microsoft Project, first add the same MPP resource types to the SYS Resource Type data set in Primavera Unifier. We recommend using MPP standard resource types: Work, Material, and Cost.

### Schedule Sheet Properties General Tab

**To complete the General tab of the schedule sheet properties**

1. In User Mode, open the project or shell in the left Navigator. Click Schedule Manager > Schedule Sheets. The Schedule Sheets log opens.

2. Click New or open an existing schedule sheet. The Schedule Sheet Properties window opens.

3. Complete the General tab as described in the following table.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schedule Title</td>
<td>Enter a title for the template. This is used as the template identifier and must be unique. (up to 120 characters)</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description. (up to 400 characters)</td>
</tr>
<tr>
<td>Master Schedule</td>
<td>When you create a new schedule sheet in a project or shell or project or shell template, you can select this checkbox to make the schedule sheet the &quot;master schedule (one per project or shell or project or shell template; once selected, it cannot be deselected).</td>
</tr>
<tr>
<td>Status</td>
<td>When you are ready to make the template active and available for use, click Active.</td>
</tr>
<tr>
<td>Auto-control</td>
<td>Controls the automatic update of tasks for Scope Management. The default is Off. Setting Auto-control to On enables the automatic launch of BP records. Setting Auto-control to Off means that BPs will not be launched automatically on activities. Also, completion conditions will not be checked on activities. Users can still launch BPs manually. <strong>Note:</strong> Primavera Unifier disregards predecessor/successor dependency relationships when you manually start an activity, even if auto-control is set to On in the schedule sheet properties.</td>
</tr>
<tr>
<td>Calendar</td>
<td>Select a calendar to use with the schedule sheet. You can choose from Standard Calendars (Company-level calendars), Project/Shell Calendars, or Custom Calendars (defined for the Schedule Manager). This calendar is used by all activities on the schedule sheet. The Calendar data element is also available for use as a column in the schedule sheet. When a new schedule sheet is created, the Project/Shell Calendar is selected by default. Users can change this default selection. The calendar selected affects project durations and due dates. For templates, the only choice is Standard calendars. The Schedule Start Date always uses the Project/Shell Calendar. Activity start dates are not affected when you change the calendar. The selected Start Date or Finish Date for an activity can be a non-working calendar day, however the duration of the activity will only account for working calendar days.</td>
</tr>
</tbody>
</table>
Schedule Start Date  
Drives the dates of floating activities on the schedule sheet for Scope Management. No activities can begin before this date; however, activities do not have to begin on this date if their preceding activities complete previous to this date.

The Manual and Shell Attribute radio buttons are active for a master schedule sheet if the Project Start Date data element has been added to the Shell Attribute form (for WBS shells) in Primavera uDesigner, and if no activity has started on the sheet. These buttons allow you to specify whether the Schedule Start Date should be set manually, or automatically populate. For non-master schedule sheets, the choice is always Manual, and Shell Attribute is not selectable.

• If you select the Manual radio button, you can select a Schedule Start Date.
• If you select Shell Attribute radio button, the Schedule Start Date automatically populates from the Project Start Date specified on the General tab of the shell properties.

Also, the shell Project Start Date can update the master schedule sheet start date if no activity has been started on the sheet. Sheets other than the master schedule sheet are created with the Project Start Date specified on the shell, but this date cannot be updated from the Project Start Date field in the shell properties.

<table>
<thead>
<tr>
<th>Notify users and/or groups on errors</th>
<th>Select Users and groups to be notified if there are errors during any point during the Scope Management task routing.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permission: Enforce Activity Level Permissions by Group</td>
<td>Select to specify that you are implementing group activity editing. If you select this checkbox, you must also select a default group.</td>
</tr>
<tr>
<td>Default Group</td>
<td>Required if you select Permission Enforce Activity Level Permissions by Group. Select the group to use as the default group for activity-level editing.</td>
</tr>
</tbody>
</table>

4 Click OK. The new schedule is available in the log.

From here you can:

• Open the Properties window, the Gantt Chart tab, the Tracking Gantt tab, the Options tab, and the Schedule tab.

• Open the sheet and add columns and rows (activities).

**Gantt Chart Tab Of The Schedule Sheet Properties**

You can define the display of data elements on the activity bars on the Gantt chart. You can add up to three labels: to the left, on top, and to the right of each activity bar. The labels correspond with the data element fields that are available on the Properties window (activity attribute form) for each activity.

**Note:** If you are selecting specific calendars for your project/shell and schedule sheet, the Gantt chart uses the project-level or shell-level calendar, not the calendar selected for the schedule sheet.

**To configure Gantt chart activity bar text**

1 Click the Gantt Chart tab.

2 Select data elements. You can add one label or all three. The selected data element(s) will display at the Top, Left or Right of the activity bar. The available data element options are derived from the activity form (schedule attribute form or default form).

3 Click OK.
**Tracking Gantt Chart Tab Of The Schedule Sheet Properties**

A tracking Gantt chart allows you to compare two sets of dates for a specific activity. It allows you to track activity progress against the original plan. For example, the tracking Gantt chart allows the comparison between two sets of dates such as baseline and actuals. Users with view permissions can view a tracking Gantt chart. The tracking Gantt chart is view only. It is not interactive like the regular Gantt chart.

You can define the display of data elements on the activity bars on the Tracking Gantt chart. You can add up to three labels: to the left, on top, and to the right of each activity bar. The labels correspond with the data element fields that are available on the Properties window (activity attribute form) for each activity.

**To configure Tracking Gantt chart activity bar text**

1. Click the **Tracking Gantt Chart** tab.
2. Select data elements. You can add one label or all three. The selected data element(s) will display at the Top, Left or Right of the activity bar. The available data element options are derived from the activity form (schedule attribute form or default form).
3. Click **OK**.

**Options Tab Of The Schedule Sheet Properties**

These options allow you to control the automatic update of activity status based on Actual Start and Actual Finish dates, to specify that activity progress requires an Actual Start Date, and to enforce a dependency between Activity % Complete and the Actual Finish Date (with the option of auto-update of the Activity % Complete).

See "Project Progress Data Accumulation and Calculation" for details on progress data accumulation and earned progress.

**To specify that activity status auto updates based on actual start and finish dates**

By default, the Activity Status controls Actual Start and Finish of an activity. If you select the Auto update activity based on Actual Start/Finish Dates, the Actual Start date and Actual Finish date control the Activity Status. Selecting this box, makes the Activity Status field read-only on the Activity Properties. When this checkbox is deselected, you can change the Activity Status.

The following table describes the interactivity of the Actual Start, Actual Finish, and Activity Status fields when the Auto update activity status based on Actual Start/Finish Dates checkbox is selected:

<table>
<thead>
<tr>
<th>Actual Start</th>
<th>Actual Finish</th>
<th>Activity Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Editable (no date selected)</td>
<td>Editable (no date selected)</td>
<td>Read-only. Not Started option is selected.</td>
</tr>
<tr>
<td>Editable (date selected)</td>
<td>Editable (no date selected)</td>
<td>Read-only. In Progress option is selected.</td>
</tr>
<tr>
<td>Editable (date selected)</td>
<td>Editable (date selected)</td>
<td>Read-only. Complete option is selected.</td>
</tr>
</tbody>
</table>

1. Click the **Options** tab.
2. Select the **Auto update activity status based on Actual Start/Finish Dates** checkbox.
3 Click OK.

**To specify that activity progress requires an actual start date**

You can specify that activity progress information cannot be entered if there is no actual start date for the activity. For example, an actual start date must be specified for users to be able to enter any activity progress, including Activity % Complete and Earned Progress on the Activity Properties.

When the Checking the Activity Progress requires an Actual Start date checkbox is selected, Primavera Unifier validates that there is an Actual Start date specified for the activity. If there is no Actual Start date, and this checkbox is selected, users will not be able to enter activity progress data until the Actual Start date is added for the activity.

**Note:** You cannot select the Activity Progress requires an Actual Start date checkbox if the activity has recorded progress. If there are any progress entries, Primavera Unifier will not allow you to select this checkbox until a start date is provided or the existing progress data is deleted.

1 Click the Options tab.

2 Select the **Activity Progress requires an Actual Start date** checkbox.

3 Click OK.

**To enforce dependency between Activity % Complete and Actual Finish Date for an activity**

You can enforce a dependency between the Activity % Complete and the Actual Finish Date of an activity. When you select Enforce Activity 100% Complete against Actual Finish, Primavera Unifier will require the user to enter the percentage for Activity % Complete as 100%. Conversely, when the user specifies that Activity % Complete is 100%, Primavera Unifier will require the user to enter a value for the Actual Finish Date. Also, you can enforce that Activity % Complete is changed to 100% if an Actual Finish Date is entered.

**Note:** If data has been entered (Activity Finish Data is entered or the Activity % Complete is less than 100%, or vice versa), and then you attempt to select the Enforce Activity 100% Complete against Actual Finish checkbox, the system will prevent you from selecting the checkbox for this option. In this case, you must clear the existing data to be able to select the Enforce Activity 100% Complete against Actual Finish checkbox.

1 Click the Options tab.

2 Select the **Enforce Activity 100% Complete against Actual Finish** checkbox.

3 Click OK.

**Impact on Scope Management:** If you have specified a dependency between the Actual Finish Date of an activity and the Activity % Complete, the Activity % Complete value for an activity will automatically update to 100% when an Actual Finish Date is entered for that activity. This can occur when the Activity Status is updated to Complete, whether through a business process or manually.

**To auto-update Activity % Complete based on Actual Finish Date for an activity**

If you have selected Enforce Activity 100% Complete against Actual Finish, you can further specify that the Activity % Complete value is automatically updated to 100% when the user enters a Actual Finish Date.
1 Click the Options tab.

2 Select the Enforce Activity 100% Complete against Actual Finish checkbox, and the Auto-Update % Complete to 100% after entering Actual checkbox.

3 Click OK.

**Schedule Tab Of The Schedule Sheet Properties**

The schedule sheet refresh updates cost data associated with the schedule sheet. The refresh updates activity costs and resource/role costs.

A schedule sheet refresh can fail if:

- An activity has more than one WBS code
- A cost sheet column to which a schedule sheet column is associated is deleted from the cost sheet

You can set the refresh frequency. The refresh frequency you set is shown in the schedule sheet log under the column heading Scheduled. Schedule sheets that require refresh are listed in the Schedule Sheet log displaying the refresh icon.

**To set the refresh frequency of schedule sheet template data**

1 In User Mode, open the project or shell in the left Navigator. Click Schedule Manager > Schedule Sheets. The Schedule Sheets log open.

2 Select one or more schedule sheet templates.

3 Choose Refresh > Set Frequency. The Set Frequency window opens.

4 Select the Enable scheduled refresh checkbox.

5 Select the Frequency and the Range of Recurrence.

6 Click OK.

**Create A Master Schedule Sheet**

Primavera Unifier allows one master schedule sheet per project/shell. You can mark a schedule sheet in a project or shell and project or shell template as the Master Schedule sheet.

**Caution:** Upon saving, Master Schedule designation is permanent and cannot be undone.

You can use the master schedule sheet to:

- Drive project dates, for example start date, finish date, planned completion, revised completion
- Drive activity start and end dates
- Track progress of activities over the lifetime of the project
- Drive scope management
- Post costs to the Cost Manager
- Support Cash Flow and Earned Value analysis
- Interface with the Resource Manager for resource assignments and availability

You can mark one schedule sheet in a project/shell as the master schedule sheet.

Once you save a schedule sheet as the master, there is no un-do to non-master status.
To mark a sheet as the master schedule sheet

1. In User Mode open the project/shell in the left navigator.
2. Click Schedule Manager > Schedule Sheets. The Schedule Sheets log opens.
3. Select the sheet that you want to make a Master Schedule Sheet and click the Properties button. The Properties window opens on the General tab.
4. Select the Create as master schedule sheet checkbox.
5. Click Yes to confirm.

Open / Modify Schedule Sheet Template Properties

You can modify the properties of a schedule sheet template.

To modify schedule sheet template properties

1. In User Mode, open the project or shell in the left Navigator and click Schedule Manager > Schedule Sheets. The Schedule Sheets log opens.
2. Select a template.
3. Click the Properties button.
4. Modify the properties as needed.
5. Click OK.

Add An Activity To A Schedule Sheet

Before you begin: Schedule sheet permission is granted on a sheet-by-sheet basis. Adding or editing an activity requires Edit Data or greater permission. If you only have View permission you cannot add or edit activities. See Define schedule sheet permissions.

This page contains information on adding activities manually, copying activities from another sheet, and using copy/cut and paste.

For information about importing schedule sheet data directly into Primavera Unifier see Create a schedule sheet.

Add Activities

You can add activities to a schedule sheet in the Activity Properties window.

For information and directions on completing the General tab, the WBS Codes tab, the Resources tab, Role Rate calculations, and the Dependencies tab click each topic.
To manually add an activity to a schedule sheet

1 In User Mode, open the project/shell where the schedule sheet resides, and click Schedule Manager in the left navigator.

2 Select Schedule Sheets. The Schedule Sheets log opens.

3 From the Edit menu, or from the toolbar, click Add and select Manual. The Activity Properties window opens.

4 Complete the activity property tabs as described in Activity Properties General tab.

To copy an activity from another sheet

1 In User Mode, open the project/shell where the schedule sheet resides, and click Schedule Manager in the left navigator.

2 Select Schedule Sheets. The Schedule Sheets log opens.

3 Open the sheet you want to change.

The default order for a new row is at the end of the activities list. You can insert a row where you want it by selecting a row on the sheet. Primavera Unifier adds the new row above the selected row.

4 From the Edit menu, or from the toolbar, click Add and select Copy Activity From. The Schedule Manager Picker window opens.

5 Select a schedule sheet from the Schedule Sheet drop-down menu, which lists all the active schedule sheets in the current project.

6 Select an activity from that sheet and click Copy.

Non-hardbooked roles are copied into the destination schedule sheet.

The role amount is recalculated for the added activity and for any activity that has its start or finish dates changed as a result of the addition.

7 If you want to make changes to the activity properties, click the activity to open it.

To copy and paste activities in a sheet

1 Open the schedule sheet in the log.

2 Highlight the row or rows you want to copy.

3 Choose Edit > Copy.

4 Select the destination for the copied rows. The rows you copy will be inserted above the selected destination row.

5 Choose Edit > Paste. You can choose Edit > Paste multiple times to repeat pasting the copied rows.

6 Copy and paste copies all data on the copied activity including Scope Management Setup, dependency relationships, Baselines, WBS, and resource assignments.

To cut and paste activities in a sheet

1 Open the schedule sheet in the log.

2 Highlight the row or rows you want to cut.

3 Choose Edit > Cut. The row you want to cut is highlighted, and remains in place until you paste it.
4 Select the destination for the cut rows. The rows you paste will be inserted above the selected destination row.

5 Choose Edit > Paste. You can choose Edit > Paste multiple times to repeat the pasting of the cut rows.

6 You can undo the cut action by choosing Edit > Undo Cut.

Changes that occur to copied and pasted activities:

- Status will be set to Not Started for the pasted activity.
- Actual Start Date and Actual Finish Date will be cleared.
- Links to BP Record, Record Status are not copied.
- Critical Path elements are recalculated.
- Copying an activity will not copy dependencies.
- Moving Summary Activities will automatically move all activities below the summary whether the summary is expanded or collapsed. If the activity is not a summary row, any corresponding summary tasks will be updated automatically to reflect any changes in start, finish, and duration. The Gantt Chart View will reflect the new ordering of activities without affecting dependencies.

Activities remain in the buffer until the next copy/cut or save. Allowed actions that do not empty the buffer are:

- Find
- Zoom In or Zoom Out
- Focus
- Opening the Activity Attribute form without changing data.

If you perform any other actions before clicking Paste then the contents of the buffer are lost. A subsequent paste will not result in any action. Actions that empty the buffer are:

- All actions on the toolbar (Save, Add, Delete, Indent/Outdent, Gantt, Progress, Close Window.)
- All actions under the File menu
- All actions under the Edit menu (Except Paste)
- All actions under the View menu except Find
- Clicking into any editable cell or modifying dates via Gantt or the Activity Attribute Form.

General Tab Of The Activity Properties

General Tab

The General tab shows fields from the schedule sheet. The fields may vary depending upon how the designer created the schedule sheet attribute form. The table below shows mandatory fields.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity ID</td>
<td>The Activity ID reflects the list order of activities on the schedule sheet. This field is automatically populated and can change if activities are added or removed.</td>
</tr>
<tr>
<td>Activity name</td>
<td>The activity name reflects the activity on the schedule sheet. This is an editable field; any changes in the attribute form will show up on the schedule sheet.</td>
</tr>
<tr>
<td>Start Date</td>
<td>Enter or edit the date an activity will start.</td>
</tr>
</tbody>
</table>
In this field: | Do this:  
---|---  
role-related calculation  
Finish Date | Enter or edit the date an activity will end. Any changes to the finish date, either in Activity Properties or directly in a schedule sheet column, will trigger Primavera Unifier to recalculate the role amount of the role assigned to the activity. This helps you understand the cost impact of a schedule change.  
Task Duration | The task duration is automatically calculated from the start and finish dates. If you enter a value that is larger than the difference between the start and finish dates, then the duration is re-calculated from the start date.

---

**WBS Tab Of The Activity Properties**

**WBS Codes Tab**

Here you can link a WBS code to an activity, which makes the activity available for cash flow analysis.

**To add a WBS code**

1. Click the **Add** button located on the bottom left of the window. The Add WBS Code window opens.
2. Select a WBS code from the WBS code picker. The WBS Item automatically populates based on the WBS code selection.
3. Add a value for **Split Percent**. Oracle Primavera highly recommends using 100%.

**To remove a WBS code**

1. Select the WBS code you want to remove.
2. Click the **Remove** button located on the bottom left of the window.

**Resources Tab Of The Activity Properties**

**Resource Tab**

Here you can assign resources and roles to an activity using the Schedule Sheet Resource Assignment form, which can be different than the one shown here. Fields can be in a different order on the form, the form can include additional fields than this form, and the form can dynamically change, depending on field selections.

Before you begin, be sure your administrator defined resources and roles in the company-level Resource Manager.

**To add or edit a resource**

1. Click the **Add** button located on the bottom left of the window. The Resource Assignment window opens.
2. Use the information in the following table to complete the fields on this form.
<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
</table>
| Resource Type | Select a resource type for the activity.  
- Hard Booked resource costs roll up to the total activity cost as a labor cost. They are company defined and can be virtually anything from a person to something like pipe or concrete.  
- Non-hard booked resource costs roll up to the non-labor costs of an activity. They are company defined as well, and can be virtually anything from a person to something like pipe or concrete.  
**Note:** Data set values for this drop-down field must start on row 1 and cannot be 0 (zero). |
| Resource Picker | Select a resource for the activity.  
- If you selected a hard booked resource for the activity, you can use the Resource Picker to assign a resource to this activity.  
- If you selected a non-hard booked resource, the Resource Picker is unavailable and you must enter the Resource Name. |
| Resource Name | View or enter the resource name.  
- If you selected a hard booked resource, this field is automatically populated.  
- If you selected a non-hard booked resources, you must enter the name of the activity resource. |
| Resource Code | View or enter the resource code of the assigned resource.  
- If you selected a hard booked resource, this field is populated with the code of the selected resource.  
- If you selected a non-hard booked resource, this field is editable and you can enter a value. |
| Role Data Picker | If this field is *not* on your form, disregard these instructions.  
If this field is *on* your form, you can select a role for the activity. See [Role-related calculations](#) for instructions on working with this field. |
| Role Name | This is a read-only field where you can the role of the resource assigned to the activity.  
- If a hard booked resource is selected, then this field is automatically populated.  
- If a non-hard booked resource is selected, then this field is not populated.  
- If a role data picker is on your form, and you selected a role using the picker, the Role Name is automatically populated. |
| Quantity (Qty) | Enter the resource quantity, for example tonnage or number of days, as suitable for the resource. |
| UOM | Select the unit of measure associated with the effort. For example, if the Resource Type is Man-hours, the unit of measure is hours. |
| Rate | View or enter the unit rate of the effort.  
- If a hard booked resource is selected, this value is read-only and populated based on the rate at which the resource is booked.  
- If a non-hard booked resource is selected, you must enter a rate.  
- If you used a role data picker to select the role, the rate is pre-populated. |
| Amount | View or enter the amount or cost of the effort. If the resource selected is hard booked, this field is read-only and the value is calculated automatically by multiplying Quantity (Qty) with Rate. |
Otherwise, this data element is editable. You can enter a value in Primavera Unifier or a formula can be defined in Primavera uDesigner to calculate the amount.

| Role Amount       | If this field is not on your form, disregard these instructions.  
|                  | If this field is on your form, this field is automatically calculated. |
| % Units           | View or enter the percentage of the resource available for the activity  
|                  | • If a hard booked resource is selected, enter the percentage.  
|                  | • If a non-hard booked resource is selected, this field is unavailable.  
|                  | • If a role is selected using the role picker, this field is automatically calculated. |
| % Complete        | This is a read-only field that shows the percentage completion of the activity. The value of this data element is calculated using Progress Quantity / Quantity (Qty). |

3 Click **OK** to save the form.

**Role-related Calculations**

When you use a role data picker to assign a role to an activity, Primavera Unifier can use the role information to calculate role costs.

**Role-related Calculations**

**Activity role rate**: For the activity role rate calculation, Primavera Unifier takes into account the effective date of the current role rate and the active currency exchange rate. Primavera Unifier recalculates the role amount under these circumstances:

- The activity role rate changes, or any other activity dates change, for example, finish date or duration.
- The role changes.
- An activity is copied in the sheet.
- An activity is copied from another sheet.

**Activity role amount**: Primavera Unifier calculates the activity role amount on a daily basis. It considers:

- Value of the role rate, as of the effective date (this can differ by effective date)
- Activity duration (this is the length of time the role rate was applicable before another rate became effective)
- Active currency exchange rate (this can change due to currency fluctuations)
- Percentage of a role's assignment to the activity (% Unit) (this can differ during the activity)

Primavera Unifier uses active currency exchange rates for transaction-to-project currency conversions. Exchange rate changes will flag the schedule sheet for refresh.

**Role amount recalculation**: Any changes to start and finish dates, duration, predecessor activities, constraints, available days (via the calendar), activity levels (indent or outdent) can trigger Primavera Unifier to recalculate the activity role amount. You can see the effect of activity role rate changes in cash flow distribution. Primavera Unifier calculates all values on a daily basis and adds up all amounts.
Activity amount: An activity can have more than one role, each with its own costs. If the activity is associated with at least one WBS code, Primavera Unifier tallies the role amounts for an activity, rolls up costs to non-labor costs, and displays the sum of WBS code in cash flow.

To use the role picker

1. Open the project or shell where the schedule sheet resides, and click Schedule Manager > Schedule Sheets in the left Navigator. The Schedule Sheets log opens.

2. Select the schedule sheet that contains the activity you want to modify and open it.

3. Click the activity you want to modify. The Activities Properties window opens.

4. Click the Resources tab and click the Add button located on the bottom left of the window. The Resource Assignment window opens.

5. If you are using a role data picker, complete these fields:

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Type</td>
<td>Select a non-hard booked resource type for the activity.</td>
</tr>
<tr>
<td></td>
<td>• Non-hard booked resource costs roll up to the non-labor costs of an</td>
</tr>
<tr>
<td></td>
<td>activity.</td>
</tr>
<tr>
<td></td>
<td>• They are company defined, and can be virtually anything from a person</td>
</tr>
<tr>
<td></td>
<td>to something like pipe or concrete.</td>
</tr>
<tr>
<td>Resource Picker</td>
<td>This field is not available.</td>
</tr>
<tr>
<td>Resource Name</td>
<td>Enter the name of the activity resource.</td>
</tr>
<tr>
<td>Resource Code</td>
<td>Enter the resource code of the assigned resource.</td>
</tr>
<tr>
<td>Role Data Picker</td>
<td>Select a role for the activity. You can click the Select button or the</td>
</tr>
<tr>
<td></td>
<td>drop-down arrow and click Roles.</td>
</tr>
</tbody>
</table>
This is a dynamic button whose label changes according to the previous selection. For example, after you select a role, the button name changes to Rates so you can access the Role Rate Override.

<table>
<thead>
<tr>
<th>Role Name</th>
<th>The Role Name is automatically populated.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quantity (Qty)</td>
<td>Enter the resource quantity, for example tonnage or number of days, as suitable for the resource.</td>
</tr>
<tr>
<td>UOM</td>
<td>Select the unit of measure associated with the effort. For example, if the Resource Type is Man-hours, the unit of measure is hours.</td>
</tr>
<tr>
<td>Rate</td>
<td>This field is not available for direct edit. Rates can be changed either at the company level or via Role Rate Override.</td>
</tr>
<tr>
<td>Amount</td>
<td>This data element is editable. You can enter a value in Primavera Unifier or a formula can be defined in Primavera uDesigner to calculate the amount.</td>
</tr>
<tr>
<td>Role Amount</td>
<td>This field is automatically calculated.</td>
</tr>
<tr>
<td>% Units</td>
<td>This field is automatically calculated.</td>
</tr>
<tr>
<td>% Complete</td>
<td>This field is read-only; it shows the percentage completion of the activity. The value of this data element is calculated using Progress Quantity / Quantity (Qty).</td>
</tr>
</tbody>
</table>

6 If you want to override the role rate, continue to step 7. If not, click OK to save and close the form.

**To override the role rate**

7 In the role picker field click the Rates button.

The Current Effective Rate window opens, which shows the Effective Date, Standard Rate, and Custom Rate for the role selected.
8 In the Current Effective Rates window select the Custom Rate field and enter the new rate for the role. You cannot change the Standard Rate from this window.

9 If you want to add another rate that will take effect at a later date, click the Add button. Primavera Unifier adds a line to the form.

10 In the Effective Date field, specify when this rate should take effect. Dates must be unique and fall within Start / Finish dates.

11 In the Custom Rate field, specify the rate you want for the role.

12 Click OK. Role rates recalculate upon schedule sheet refresh.

**Dependencies Tab Of The Activity Properties**

**Dependencies Tab**

Here you can add dependencies between the current activity and other activities from the schedule sheet. You can select another activity on the schedule sheet, determine the relationship, (e.g. Finish to Start, Start to Finish, Start to Start, or Finish to Finish), and add a Lag.

**Note:** Primavera Unifier disregards predecessor/successor dependency relationships when you manually start an activity, even if auto-control is set to On in the schedule sheet properties.

**To add or edit a dependency**

1 Click the Add button located on the bottom left of the window. The Add Dependency window opens.

2 In the Activity Name field, select the activity to make dependent upon the current activity.

3 In the Relationship field, select from one of the following options:
   - Finish to Start: the dependency must finish before the Activity can start
   - Start to Finish: the dependency must start before the Activity can finish
   - Start to Start: the dependency must start before the Activity can start
   - Finish to Finish: the dependency must finish before the Activity can finish
In the **Lag** field, enter the number of days for a gap or overlap between the selected activity and the current activity. A positive lag indicates a gap. A negative number indicates an overlap.

![Diagram showing lag between activities]

**To remove a dependency**

1. Select the dependency to remove.
2. Click the **Remove** button located on the bottom left of the window.

**Add A Schedule Sheet Column**

There are three default columns: Start Date, Finish Date and Duration. Duration always displays the result of Finish Date minus Start Date. You can add other columns as needed. You can add baseline columns that map to Start, Finish, and Duration. See [Setting Schedule Sheet Baselines.htm](#).

**Note:** Any changes to an activity start date, either in Activity Properties or directly in a schedule sheet column, will trigger Primavera Unifier to recalculate the role amount of the role assigned to the activity. See [Define activity properties](#) in the Primavera Unifier User Guide for a discussion on role-related calculations.

**To add a schedule column**

1. In User Mode, open the project or shell where the schedule sheet resides and click **Schedule Manager > Schedule Sheet**. The Schedule Sheets log opens.
2. Open the schedule sheet and click the **Columns** button. The Columns Log opens
3. Click the **New** button. The Column Properties window opens.
4. Complete the Column Properties window as described in the following table.
5. Click **OK**.
<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field is populated with the chosen Data Source</td>
</tr>
<tr>
<td>Data Source</td>
<td>Select a Data Source from the dropdown list. The options include the data elements in the activity Properties window. If a schedule attribute form has been imported from Primavera uDesigner, the data sources include all elements on the form, including hidden elements. This list also shows data elements based on Sys Project Cost Data Source data definitions.</td>
</tr>
</tbody>
</table>
| Entry Method | Choose one (the options that are available are dependent on the data source chosen):  
  - Manual Entry: Users enter values directly on the schedule sheet  
  - Formula: Value is calculated using the entered formula. Formulas can include calculating differences between date columns, or adding / subtracting numeric columns / values from dates. This is useful to calculate durations or to calculate one date from another date by adding/subtracting days.  
  - Cost Sheet Column: Select a Cost Sheet column to associate with the data element based on the data definition Sys Project Cost Data Source. This pull-down menu lists all of the columns defined on the Cost Sheet. The cost data is refreshed when you or a user choose File > Refresh in a Schedule Sheet and refresh immediately or set up a refresh frequency. The Cost Sheet Column selector is available on schedule sheets in projects or shells and in project or shell templates.  
  **Note:** The Cost Sheet Column definition must be reselected in a new schedule sheet that you create by copying a sheet or template, or by copying a project or shell. Definition must also be reselected if you link the schedule sheet. |
| Data Format  | This controls how data is displayed on the schedule sheet. Options are:  
  - Show as percentage. Data is displayed as %  
  - Decimal places. Choose 1 to 8  
  - Use 1000 Separator. Select checkbox to include a comma (,) separator  
  - Negative Number Format. Choose parentheses or minus sign |
| Summary      | This controls the display of numeric and date column data on summary rows.  
  - Display: Select the checkbox to display summary data for the column  
  - Date Rollup: Available only for Date data types. Select Earliest Date or Latest Date.  
  - Earliest Date: To summarize columns that represent activity start dates (e.g. start, planned start, actual start, etc.). The cell on the summary activity will show the earliest date from all child activities.  
  - Select Latest Date to summarize columns that represent activity finish dates (e.g. finish, planned...
finish, actual finish, etc.). The cell on the summary activity will show the latest date from all child activities.

- Number Rollup: Available for numeric columns. Choose Total (displays sum total of the rows), Average (displays average value of the rows), or Weighted Average based on and select a field from the Activity Attributes form. For example, you might choose Total for currency or other numeric types; for percentage columns, you might want to choose Average.

Weighted Average Based On:

The drop-down menu for this option lists the data elements available on the Activity Attribute form. Only data elements of the type Numeric are available for selection. Selecting this option and a data element allows Primavera Unifier to calculate the weighted average of summary rows.

For example:

<table>
<thead>
<tr>
<th>Display Mode</th>
<th>Choose to Show or Hide the column from user view. Users with Create permissions can see hidden column in the Columns Log.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Position After</td>
<td>The new column will be inserted after the column selected.</td>
</tr>
</tbody>
</table>

**Create A Formula Column In A Schedule Sheet**

You can create formula columns on a schedule sheet or template. Formulas can include allow calculating differences between date columns, or adding / subtracting numeric columns / values from dates. This is useful to calculate durations or to calculate one date from another date by adding/subtracting days.

You can define formulas of the following types:

- Numeric: Build a numeric formula. This choice is available if the data source is SYS Numeric Logical.
- Date Difference: Formula is by default Later Date – Earlier Date. This choice is available if the datasource is SYS Numeric Logical.
- **Date Add**: Add a numeric value to a date. This is available if the datasource is SYS Date Logical.

SYS Numeric Logical and SYS Date Logical are data definitions from which data elements can be created in Primavera uDesigner and used on schedule attribute forms.

### How to tell which data source to use in building a formula

The ability to build formulas is dependent on the data definitions used to create the data elements on the schedule attribute form. You can navigate to **Administration Mode > Data Structure > Data Elements** to see which data elements are based on the above data definitions (click the column heading in the Data Elements log to sort by data definition). Alternatively, you can choose a Data Source in the dropdown list, then, with the Data Source field still active, press your keyboard’s up and down arrow keys to scroll through the data source options. When one of the above data definitions is reached, the Formula radio button becomes active.

### To create a numeric formula

Choose **Numeric** and click **Create**. Activity data type displays data elements that are defined on the detail form along with “SYS Numeric Datasource” and “SYS Numeric Logical Datasource”.

### To create a date difference formula

1. Choose **Date Difference** and click **Create**.
2. Enter Earlier Date and Later Date:
   - **a** Click **Select**. The Data Element picker opens.
   - **b** Choose a data element. Options are data elements from schedule sheet detail form or columns defined on schedule sheet. Only date type (Timestamp) data elements are displayed.
   - **c** Choose **Calculation based on Calendar days** (non-working days will be counted) or **Work days** (non-working days will be ignored). Work days are defined in the company calendar.
3. Click **OK**.

### To create data add formula

1. Choose **Data Add** and click **Create**.
2. Choose a data element for **Date** and **Add** (click **Select** to open the data element picker). Data elements on the schedule sheet detail form and schedule sheet columns are available.
   - For **Date**, only date type (Timestamp) of data elements are displayed.
   - For **Add**, only numeric (integer, float) type of data elements or columns are displayed in the picker list. This includes Total and Average columns.
3. Choose **Calculation based on Calendar days** (non-working days will be counted) or **Work days** (non-working days will be ignored). Work days are defined in the company calendar.
4. Click **OK**.

### Working With Schedule Sheets

Working with schedule sheets entails, for example:
- Adding or managing rows and columns.
- Tracking activity progress and costs.
Managing dependencies and constraints.

In the open schedule sheet you can view activities and columns in the left pane and view the Gantt chart in the right pane. You can move the split screen bar to the left or right as needed. Scroll bars are available on the bottom of the sheet.

To open a project or shell schedule sheet

1. In User Mode, open the project or shell where the schedule sheet resides, and select Schedule Manager > Schedule Sheets in the left Navigator. The Schedule Sheets log opens.
   - The log lists all active schedule sheets. To view all active and inactive sheets, click the View menu and choose All.
   - The Refresh icon indicates whether you must refresh a schedule sheet to display the latest data. The refresh icon is not displayed for schedule sheets that are Inactive, or are in a view-only project or shell.

2. Double-click a schedule sheet in the log to open the sheet.

   If the sheet requires a refresh of the data, you will be asked if you want to refresh the sheet. Click OK to refresh the sheet, or No to close the sheet with out refreshing the data.

3. Select the sheet in the log and click Open, or double-click the sheet. The schedule sheet opens.

Schedule Sheet Toolbar

You can perform the following functions from the toolbar. Click the down arrow next to a button to view further options.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save</td>
<td>Saves changes made to the schedule sheet.</td>
</tr>
<tr>
<td>Add</td>
<td>Click the arrow next to the button and choose one of the options:</td>
</tr>
<tr>
<td></td>
<td>• Manual: Add a row (activity) manually.</td>
</tr>
<tr>
<td></td>
<td>• Copy Activity From: Add a row by copying a row in a selected sheet.</td>
</tr>
<tr>
<td>Delete</td>
<td>Select a row and click Delete to delete the activity.</td>
</tr>
<tr>
<td>Indent</td>
<td>Select a row and click to indent the row. The row above become a summary row.</td>
</tr>
<tr>
<td>Outdent</td>
<td>Select an indented row and click to outdent.</td>
</tr>
<tr>
<td>Gantt</td>
<td>Return to the Gantt chart view.</td>
</tr>
<tr>
<td>Progress</td>
<td>Access the Activity Progress view. See &quot;Entering Progress in the Activity Progress Window&quot; on page 776 for details on activity progress.</td>
</tr>
<tr>
<td>Columns</td>
<td>Add and manage columns on the sheet.</td>
</tr>
</tbody>
</table>
Using A Gantt Chart

The Gantt Chart is displayed in the right pane of the schedule sheet. The activities are shown as bars and align with activities in the left pane. The activity bar is drawn with the start date, finish date, and duration elements of the activity. The Gantt chart is shown in week/day zoom mode by default.

The Gantt chart displays:

- Activity bars, which illustrate start and finish dates and duration
- Dependency links between dependent activities
- Summary rows
- Milestones
- Critical paths

The Gantt chart is interactive. You can:

- Zoom in or out of the Gantt chart view to display detail or overview of scheduled activities.
- Configure activity bar labels; for example, you can display percent complete to monitor the progress of activities, or names of resources assigned to activities, or virtually any activity property. See Gantt Chart tab on the Schedule Sheet Properties.
- Increase and decrease activity schedule durations by dragging on bar ends.
- Move activities from one time frame to another (modifying start and end dates).
- Add or remove a predecessor (dependency). See Dependencies tab.
- Resize Gantt window by dragging the vertical split bar.
- Display critical paths.

The Gantt chart is refreshed automatically when any changes are made on the activities.
Understanding the Gantt chart view

Zoom in or out of the Gantt chart

You can view the Gantt chart by week (per day), month (per week), or year (per month) by zooming in and out. This allows you to view the Gantt chart in detail or over an extended period of time.

To zoom in or out of the Gantt chart

1. Open the schedule sheet.
2. Do one of the following:
   - Click the Zoom In button on the toolbar. The default view is weekly, with each day of the week displayed. This is the maximum detail level that you can zoom in to the schedule sheet.
   - Click the Zoom Out button. You can zoom out to view the Gantt chart by month with each week in the month displayed, or by year with each month displayed.

View the critical path

The critical path calculation can be used to flag activities on the schedule that, if delayed, can cause the schedule to go beyond the pre-planned project or shell end date. Therefore, it is important to have fixed project or shell start and end dates defined for the project or shell. Project or shell start and end dates should not automatically adjust as activities are added or rescheduled.

To view the critical path

1. Open the schedule sheet.
2. Click the View menu and choose Critical Path.
   The activities that are on the critical path will change to red on the Gantt chart. The critical path action will also update the system-defined data element uuu_float to zero if it has been included on the activity attributes form (Activity Properties window).
3. To restore the Gantt chart view, click the View menu and choose Gantt Chart.
View a tracking Gantt chart

A tracking Gantt chart allows you to compare two sets of dates for a specific activity. It allows you to track activity progress against the original plan. For example, the tracking Gantt chart allows the comparison between two sets of dates such as baseline and actuals. Users with view permissions can view a tracking Gantt chart. See “Set Schedule Sheet Baselines” on page 732 for details on setting baselines.

The tracking Gantt chart is view only. It is not interactive like the regular Gantt chart.

To view a tracking Gantt chart

1. Select the schedule sheet in the log and choose View > Tracking Gantt.
2. You can switch back to the regular Gantt chart by choosing View > Gantt.

The tracking Gantt chart displays the data elements as a set of two bars (upper and lower) that allow you to make the comparison.

Using A Tracking Gantt Chart

You can use a Tracking Gantt chart to compare data sets defined in the schedule sheet properties. The read-only Tracking Gantt chart displays comparison as a set of two bars (upper and lower).

To view a tracking Gantt chart

1. Select the schedule sheet in the log and choose View > Tracking Gantt.
2. You can switch back to the regular Gantt chart by choosing View > Gantt.

Find An Activity

You can search for a specific activity by the values of any column on the schedule sheet.

To search for an activity

1. Open the schedule sheet.
2. Click the Find button on the toolbar. The Find window opens.
3. Complete the window:
   - Column: Click the drop-down list and choose a column to search on. The default is activity name.
   - Value: Enter all or part of a value to search for. For example, to search for the word Construction, you can enter the entire word or any part of the word.
   - Search: Click the drop-down list and choose to search down or up from a selected row. If you do not select a row, the search will begin at the top row.
4. Click Find Next. If an activity is found that matches the search criteria, the row will be highlighted. To keep searching, click Find Next again.
5. When you are done searching, click Cancel to close the window.
ABOUT ACTIVITY-LEVEL EDITING RESTRICTIONS

Your Administrator can set up cell editing restrictions in schedule sheets. These restrictions can allow certain work groups to edit specific dates in the sheet, and prevent other groups from editing these dates. If you are a member of a specific work group that has these restrictions set, you will find that you are able to edit only certain cells on the schedule sheet.

The following is an example of the impact on dates in a schedule sheet with activity-level editing configured, and with activities and group-specific date columns. In this example, the groups Const, IT, and ATM all have group-specific start and finish dates for activities:

As shown in the example, the date cells in the schedule sheet that are specific to a certain group can be edited only by that group.

Restrict Access To Activity Fields And Columns

You can restrict user access to selected fields and columns (those based system defined data elements on the General tab, which are on the Activity Attribute form and on the Resource tab, which are on the Resource Assignment Attribute form).

Note: These restrictions also apply to schedule sheet columns when a restricted data element is used as a column.

After a field or column is marked with restricted access for selected users or groups, those users or group members cannot modify those data elements (fields). For Start Data, Finish Date and Duration data elements, users that are restricted cannot modify this group data elements, even if they have restriction on any one of the data elements in the group. Also, the Gantt Chart will be disabled for a user if the Start, Finish, and Duration data elements are restricted for that user.

If a data element cannot be modified by a user or group then data imported through CSV / XML for that data element is ignored. If there is any failure in validation (both user and system defined), Primavera Unifier will stop data import.
To restrict access to specified system defined data elements

1. Navigate to the schedule sheet log.
2. Open a schedule sheet.
4. Add the user or group name whose access you want to restrict.
5. Choose the data elements to restrict. The data elements listed for the Activity Attribute form and the Resource Assignment Attribute form are those that are system defined (the data element name starts with `uuu_`) and were added to the forms. You can select all of the listed data elements, or individual data elements.
6. Click OK.

Use Filters In A Schedule Sheet

You can use filters to locate certain activities in a schedule sheet. The filter is based on criteria that you specify. When you use a filter, it applies only to the schedule sheet you are working with, but the filters you create are visible to all other users.

To add a filter for activities in a schedule sheet

1. Select the records in the schedule sheet that you want to filter.
2. Open the schedule sheet in the log and choose View > Filters. The Filters window opens.
3. Click Add.
4. In the Add Filter window, specify the filter criteria. Each filter can have multiple criteria based on the data elements in the activity attribute form. You can also use this window to edit or remove filters. The Add and Remove buttons are enabled only for users who have edit permissions on the schedule sheet.
5. Selecting the Display Summary Activities checkbox controls whether the filtered schedule sheet displays summary activities corresponding to any leaf activities displayed in the sheet. The filter is not applied to the summary activities.
6. Click Apply to save and immediately apply the filter to the schedule sheet.
7. Click OK to save the filter for later use.

To apply a filter to schedule sheet activities

1. Open the schedule sheet in the log and choose View > Filters. The Filters window opens.
2. Select the activities you want to filter.
3. Select a filter name and click Apply Filter. The schedule sheet refreshes with the filter applied.

To clear a filter from a schedule sheet

1. To return the schedule sheet to the original view, select the schedule sheet in the log.
2. Choose View > Clear Filters.

Update Rates And Cost Data

When a resource is assigned, the average booking rate is used to calculate assignment costs.
Average Booking Rate = Total Booking Cost / Total Hours for the entire booking row selected while assigning the resource.

Labor Cost (for a resource assignment) = Total Assigned Hours x Average Booking Rate.

After assignment, the booking rate may change as changes occur to the booking sheet. These rate changes will not automatically affect the assignment (labor) costs stored in the schedule sheet.

You can update resource rates on the master schedule sheet and also update the project or shell cost sheet with corresponding assignment costs. The active currency exchange rate at the time of assignment will be used.

The update has two options:

• **Resource Utilization**: This updates resource rates only.
• **Resource Utilization and Cost Manager**: This updates resource rates on the schedule sheet and posts costs to the cost manager. This option is only enabled on the master schedule sheet.

**To update rates on the schedule sheet**

1. Open the master schedule sheet.
2. Choose Edit > Update > Resource Utilization. Labor costs on the entire schedule sheet are recalculated based on the latest average booking costs and exchange rate.

**To update costs on the cost sheet**

1. Open the schedule sheet.
2. Choose Edit > Update > Resource Utilization and Cost Manager. Labor costs are updated and posted to the cost sheet (column with labor cost data source) based on the WBS codes and split percentage specified on each activity. The existing cost in the cost sheet columns will be replaced by new values. Similarly, any values in the Fixed Cost, Non-Labor Cost, and Total Cost columns in the schedule sheet will be posted to corresponding data sources on the cost sheet.

**Constrain Schedule Sheet Activities**

You are able to constrain activities on a schedule sheet. A constraint ties a successor activity start date to a predecessor activity completion date, after observing dependencies and lags. Available constraints in Primavera Unifier are As soon as possible (ASAP) and None.

**To constrain a schedule sheet activity**

Before you can constrain an activity, the activity’s dependencies must be set.

1. Navigate to the schedule sheet where you want to constrain activities and open the sheet.
2. Double-click the activity you want to constrain. The Activity form window opens.

**Note**: If the schedule sheet displays the Activity Constraint column, you can assign the constraint without opening the Activity form window.

3. For each activity you want to constrain, select the activity constraint you want, either As soon as possible or None.

**As soon as possible**: If the start date of a predecessor activity changes, either pulls in or pushes out, the start date of an ASAP-constrained successor activity changes accordingly. If an ASAP-
constrained activity does not have a predecessor, the schedule sheet start date determines the activity start date; unstarted ASAP-constrained successor activities align accordingly.

**None**: The start date of a None-constrained activity does not change if the start date of a predecessor activity changes. The schedule sheet start date does not determine the start date of None-constrained activities that do not have predecessor activities. The only in-built rule is that the start date of the None-constrained activity should not be earlier than the schedule sheet start date.

**Integration**: When activities are created through CSV, MPP, MPP XML, or P6, the default value will be None. Upon modification of the activity constraint type, Primavera Unifier scheduler will readjust the schedule sheet accordingly.

4 Click **OK** to close the Activity form window and save the schedule sheet.

**Add General Comments (with Or Without File Attachments)**

You can add general comments to a schedule sheet, and can include file attachments with the comments. This is similar to adding general comments to a business process.

**To add a general comment to a schedule sheet**

1 Select the schedule sheet in the log and click the **Comments** button. The General Comments window opens.

2 Add your text comments in the **Text Comments** box in the upper portion of the window. You can view any previous comments in the **Existing Comments** section of the window.

3 To attach a file to the general comment, click the **Attach** button.

**Note**: Once you add a general comment to a schedule sheet, you cannot edit or delete it.

4 Click **OK** to save the general comment.
**Refreshing Schedule Sheet Data**

A schedule sheet refresh is required if there are changes to project costs, activity costs, for example role rates and amounts, currency rates, and schedule sheet or activity calendars. When the schedule sheet requires a refresh, you will see a refresh icon in the log. When you open a schedule sheet that requires a refresh, you will be asked if you want to refresh the data in the sheet. If you decline the refresh the schedule sheet will not open.

Schedule sheet refresh options are set on the Refresh tab of the schedule sheet properties. Options include:

- **Cost**: Refresh the cost data only from the associated WBS code
- **Schedule**: Refresh the schedule data only, based on dates
- **Cost and Schedule**: Refresh both the cost and schedule data
- **Set Frequency**: Define the schedule sheet refresh frequency. This scheduled refresh updates both cost and schedule data.
- **History**: View the schedule sheet refresh history

Schedule sheet refresh can fail if:

- An activity has more than one WBS code
- A cost sheet column to which a schedule sheet column is associated is deleted from the cost sheet

**To set the frequency of schedule sheet refresh**

The schedule sheet refresh frequency you set is shown in the schedule sheet log under the column heading **Scheduled**.

1. Navigate to the schedule sheet log.
2. Select one or more schedule sheets.
3. Choose **Refresh > Set Frequency**.
4. Select the **Enable scheduled refresh** checkbox.
5. Select the **Frequency** and the **Range of Recurrence**.
6. Click **OK**.
To view schedule sheet refresh history

1. Navigate to the schedule sheet log.

2. Choose Refresh > History.

3. Select a record and click Open to view history details.

4. Click Cancel Request to cancel any history query that has not started (has no Start Date).

5. Click Close Window.

Print A Schedule Sheet

You can print schedule sheet columns and Gantt charts from the PDF of the schedule sheet.

To print a schedule sheet

1. Navigate to your project or shell and open the schedule sheet you want to print.

2. Click File > Print to open the print option window.

3. Select the print options you want.
   - All columns - Check to print all columns of the schedule sheet (default.)
   - Gantt Chart - Prints the current view of the Gantt chart (Gantt, Critical and Tracking.) This is checked by default.

4. Click the Print to PDF button.

Your browser may require you to confirm opening the PDF or saving the PDF. If saving the PDF, click Save. Browse to where you saved the file and open the PDF. If you click Open, an Adobe PDF opens with the schedule sheet.

5. From within Adobe PDF file, click File > Print. The Adobe Print window displays.

6. For multiple pages of a schedule sheet, select Tile All Pages from the Page Scaling drop-down.
7 Click OK. To cancel the print, click Cancel.
SCHEDULE MANAGER AUDIT LOG

Each change in the Schedule Manager creates a record in Primavera Unifier, which is useful for auditing purposes. An audit report of these records shows detailed information on dates, events, actions, and old values versus new values, along with the user or proxy user who performed the action.

To view schedule sheet details in the audit log

1. Navigate to the Schedule Sheets log in the Schedule Manager node.
2. In the View menu, click Audit Log.
   You can review audit log entries for Date, Event, Action, Field, Old Value, New Value, User Name, Proxy User, and Attachments.

To view cell details in the audit log

1. Navigate to the Schedule Sheets log in the Schedule Manager node and open a schedule sheet.
2. Under the File menu, click Audit Log.
   You can review audit log entries for Date, Event, Action, Field, Old Value, New Value, User Name, Proxy User, and Attachments.

Set Schedule Sheet Baselines

A baseline is a set of original project or shell estimates. It consists of the following for a task:

- Start
- Finish
- Duration

Comparing multiple baselines provides insight into project health. With the original estimates, you can track the progress of a project or shell and compare its state at any given time. Primavera Unifier leverages the WBS code association between schedule sheets and earned value (EV) sheets to construct baseline comparison. The best way to do this is to:

- Copy the schedule sheet to establish a new baseline
- Create a corresponding detail-level EV sheet for the new schedule sheet
- Create a summary EV sheet to compare selected baseline information

For more information, see Create an earned value sheet.

You can save up to 11 sets of baselines in a single project or shell schedule sheet. You can use these various baselines as snapshots of your project or shell progress over time, with each baseline corresponding to key project or shell events.

The first baseline that you save is named Baseline. Subsequent baselines are named Baseline 1 through Baseline 10. The baseline sets are system-defined data elements that your administrator has included on the activity attribute form. When you set up the baselines, the values from the start, finish, and duration elements are mapped to the baseline set.

Note: The baseline columns are not required, but you must use all three of them, if you use them at all. You must use the complete baseline set of columns (start, finish, and duration) in your sheet. You cannot use one baseline column alone.
All baseline attributes are read only in the schedule sheet. They can be modified only via the set/clear schedule sheet baseline actions. Users with the Edit Data and Structure permission on the schedule sheet can set or clear baselines.

**Note:** The Edit data permission allows you to import data.

All baseline attributes are read-only on the schedule sheet. They can be modified only via the set/clear schedule sheet baseline actions. Users with the Edit Data and Structure permission on the schedule sheet can set or clear baselines.

You can also set baselines on projects or shells listed on an Activity Sheet. See "Set Up Activity Sheet Baselines" on page 746 for details.

**To set a baseline on a schedule sheet**

1. Open the schedule sheet in the log. If you modify the schedule sheet, you must save the sheet before you can set baselines.

2. Choose Edit > Baseline. The Set Baseline window opens.

3. Select the baseline to set. The Set baseline radio button is selected by default. Only baselines that have been designed in Primavera uDesigner are available.

4. Click OK. The values from the start, finish, and duration elements are copied into the corresponding baseline elements. If the baseline elements contain data, you will receive a warning that the baseline will be overwritten. You can choose whether to override the data.

**To clear a baseline on a schedule sheet**

1. Open the schedule sheet in the log.

2. Choose Edit > Baseline. The Set Baseline window opens.

3. Select the baseline you want to clear.

4. Select the Clear baseline radio button.

5. Click OK.

**Lock Or Unlock The Schedule Sheet Structure**

You can lock a schedule sheet. This locks the columns and activity rows, preventing editing of the sheet structure.

**To lock or unlock a schedule sheet**

1. Open the schedule sheet.

2. Click the File menu and choose Lock Structure or Unlock Structure.

**Linked Schedule Sheets**

Linked schedule sheets are project or shell schedule sheets that are dynamically linked to a schedule sheet template. You must work with your Administrator to enable and setup the schedule sheet linking.

Linking is optional; it is useful if you have numerous project or shell schedule sheets to update simultaneously with the exact same information and structure.
Linked schedule sheets can be updated manually, but you can only make limited changes to dates and data.

You can change:

- Start and Finish dates
- Durations
- Schedule sheet properties; however, a linked template push cannot change sheet properties

You cannot:

- Add Activities
- Delete Activities
- Indent/Outdent Activities
- Import CSV, MPP
- Import with Overwrite or Merge (XML, WS)
- Modify Activity Name, Activity Codes
- Modify Scope Management Setup
- Cannot add /modify/delete columns
- Re-arrange (cut/paste) activities

The overall structure of the sheet (adding or deleting activities, for example) is updated only through the associated linked template. The Administrator must unlink the linked schedule sheets for you to be able to modify the structure of the sheet.

**Note:** Updating schedule sheets through linked schedule sheet templates can overlay the structure of schedule sheets and the data elements listed below. Be sure that you want the linked sheets to be updated to this extent by the template.

A linked schedule sheet template update to a linked schedule sheet can push:

- Changes to Activity Name
- Changes to Activity Codes
- Changes Activity Id (caused by re-ordering of activities)
- Addition of new activities or deletion of activities
- New or changed predecessor relationships
- Addition, deletion, or modification of column definitions
- Ordering of activities in sheet
- Changes to the indentation of activities

**Note:** Changes to dependent activity Start Date or Finish Date caused by changes such as modifications to predecessors or the addition or deletion of activities are handled dynamically by the schedule sheet.

**To view the linked template for a linked schedule sheet**

1. Navigate to the schedule sheet log.
2. Select a schedule sheet that is linked to a schedule sheet template.
3. Choose View > Linked Template. The Linked Template window opens.
To link existing schedule sheets to a link-enabled template

You can link an existing schedule sheet to a link-enabled template. Linking an existing schedule sheet causes loss of existing data on the project or shell schedule sheet, including all activities, columns and cell data. Project or shell schedule sheet properties, including the Schedule Start Date are retained.

1. Navigate to the schedule sheet log.
2. Select a schedule sheet that you want to link to a schedule sheet template.
3. Choose View > Linked Template. The Linked Template window opens.
5. Select a template and click Select.
6. Click OK on the confirmation message that data in the newly-linked sheet will be modified when the update is completed using the link between the template and the sheet.
7. Click OK.

To unlink schedule sheets from a link-enabled template

Unlinking removes the link between the schedule sheet and the template so no further updates can occur from the template.

1. Navigate to the schedule sheet log.
2. Select a schedule sheet that is linked to a schedule sheet template.
3. Choose View > Linked Template. The Linked Template window opens.
4. Click Remove.
5. Select the template.
6. Click OK.
LINKED TAGS AND BUSINESS PROCESS FIELDS

Tags work with linked elements to connect schedule sheet activities with business processes, shells, and configurable manager objects. With this feature, you can view key activity dates, such as milestones, on forms like project details, without having to open the schedule sheet.

To select a link tag to populate a business process field

1. Add a “Tag” column to the schedule sheet.
2. On the schedule sheet, select the row containing the activity you want to link.
3. Click in the Tag column. The cell becomes editable.
4. Click the arrow and select the tag you want to assign to this activity.
5. When you assign this tag to the activity, any form associated with this schedule that contains a linked element with a matching tag will now show the current value of that activity.

Search For Schedule Sheets

To search for a schedule sheet in the log

1. In User Mode, select the project or shell, and select Schedule Manager > Schedule Sheets. The Schedule Sheets log opens.
2. Click the Find button. The Find box opens at the top of the log.
3. Click the Search By drop-down menu and enter the field to search by.
4. Enter search criteria in the Search for field.
5. Click Search.
Program Schedule Sheets

Program-level schedule sheets are created automatically when a project or shell schedule sheet (for a project or shell within the program) is created. The rows are the project or shell sheets. You can configure columns. There is one schedule sheet per program.

To open a program schedule sheet

In User Mode, select Programs > Schedule Manager > Schedule Sheets. The Schedule Sheet log opens.

Rows correspond to project schedule sheets. You can click the row to open the project schedule sheet. Default columns are Project Name, Start Date, and Finish Date. You can create additional columns in the same way that you do for a project/shell schedule sheet.

Open A Schedule Sheet

To open a project or shell schedule sheet

1. In User Mode, select the project or shell, and select Schedule Manager > Schedule Sheets. The Schedule Sheets log opens.

2. Select the sheet in the log and click Open, or double-click the sheet. The schedule sheet opens.

3. You can:
   - Add or manage rows and columns and define activity properties.
   - View activities and columns in the left pane; view the Gantt chart in the right pane. You can move the split screen bar to the left or right as needed. Scroll bars are available on the bottom of the sheet.
   - Define labels for the Gantt chart activity bars (Schedule Sheet Properties window, Options tab).
   - Save or view snapshots.
Add A Program Schedule Sheet Column

To create a column on a program schedule sheet

1. Open the program schedule sheet.
2. Click the **Columns** button. The Columns Log window opens.
3. Click **New**. The Column Properties window opens.
4. Complete the window as described in the following table.
5. Click **OK**.

### In this field: Do this:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>This field is populated with the chosen Data Source</td>
</tr>
<tr>
<td>Data Source</td>
<td>Select a Data Source from the dropdown list. The options are from project schedule sheets. The dropdown will only show data elements of type Date and SYS Date Logical Data Source (from activity detail form).</td>
</tr>
</tbody>
</table>
| Rollup from Project | Configure rollup parameters from project schedule sheets. **Select Enable rollup from project schedule** to rollup project data. When you select **Enable rollup from project schedule**, the data comes from the top-level summary row for the schedule sheet. If you do not have a top-level summary row, do not select **Enable rollup from project schedule**. Instead, select from these options:
  - Date rollup: Choose to roll up the Earliest Date or the Latest Date across all projects for Date type data.
  - Number rollup: Choose roll up Total or Average values for Numeric type data, or Weighted Average based on and select a data element from the Activity Attributes form. |
| Entry Method  | Choose one (the options that are available are dependent on the data source chosen):
  - Manual Entry: Users enter values directly on the schedule sheet
  - Formula: Value is calculated using the entered formula. Formulas can include calculating differences between date columns, or adding/subtracting numeric columns/values from dates. This is useful to calculate durations or to calculate one date from another date by adding/subtracting days. |
### Data Format
This controls how data is displayed on the schedule sheet. Options are:
- Show as percentage. Data is displayed as %
- Decimal places. Choose 1 to 8

**Note:** If the data element was defined in Primavera uDesigner with a specific number of decimal amount, it will override any decimal places you specify here.
- Use 1000 Separator. Select checkbox to include a comma (,) separator
- Negative Number Format. Choose parentheses or minus sign

### Summary
This controls the display of numeric and date column data on summary rows.
- Display: Select the checkbox to display summary data for the column
- Date Rollup: Available only for Date data types. Select Earliest Date or Latest Date.
- Earliest Date: To summarize columns that represent activity start dates (e.g. start, planned start, actual start, etc.). The cell on the summary activity will show the earliest date from all child activities.
- Select Latest Date to summarize columns that represent activity finish dates (e.g. finish, planned finish, actual finish, etc.). The cell on the summary activity will show the latest date from all child activities.
- Number Rollup: Available for numeric columns. Choose Total (displays sum total of the rows) or Average (displays average value of the rows). For example, you might Total for currency or other numeric types; for percentage columns, you might want to choose Average.

### Display Mode
Choose to Show or Hide the column from user view. Users with Create permissions can see hidden column in the Columns Log.

### Column Position
The new column will be inserted after the column selected.

---

**Create An Activity Sheet**

The permissions for creating an Activity Sheet are the same as those for creating a Schedule Sheet. You can create a new sheet or use a template.

**To create an activity sheet**

1. Navigate to Projects tab > Programs > Schedule Manager > Activity Sheets. The Activity Sheets log opens.
2. Click New. Select an Activity Sheet template.
The Activities Sheet properties window opens.

3 Complete the General tab as needed, as described in the following table.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Enter a title for the sheet. This is used as the sheet identifier and must be unique. (up to 120 characters)</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description. (up to 400 characters)</td>
</tr>
<tr>
<td>Status</td>
<td>When you are ready to make the sheet active and available for use, click Active. The default is Active.</td>
</tr>
</tbody>
</table>
4 Complete the Activity Codes tab (as needed, or use the codes set up in the template) by clicking Add to add rows and select activity codes. The Activity Codes make up the columns in the Activity Sheet.

Select the activity codes that make up the columns of the activity sheet. Confer with your Primavera uDesigner user and Company Administrator to ensure that you can create activity sheets that contain the correct activity codes to form the sheet columns. Activity names on the Master Schedule Sheet map to the Activity Codes that you add to the activity sheet. There is an one-to-one correspondence between activities and Activity Codes.

**Note:** Only elements that are marked as editable can be modified.

5 Click the Move Up (Left) or Move Down (Right) buttons to change the sorting order of the activity codes.

![Activity Sheet properties window, Activity Codes tab example](image)

6 Click Add to add click Apply to save your changes.

7 Complete the Data Elements tab by clicking Add to add rows and select activity attributes. The Data Elements make up the sub-columns in the Activity Sheet. The sub-columns are repeated under the columns. Modify these data elements as needed, or use those defined in the template.

8 Use the Editable checkbox to designate which data elements will be editable in the Activity Sheet. Only one of Start Date, Finish Date, or Duration elements can be made Editable (the other two elements of the group, if added, are not selectable).

These elements are always read-only, and cannot be marked as editable:

- Actual Start/Finish/Duration
- Auto-update Activity checkbox
- Milestone checkbox
- Activity Code
- Activity Status
- Baseline elements
9 Select the Allow negative lag to accommodate specified Start/Finish Dates checkbox to specify that the activity update process adjusts lag automatically to accommodate user-specified values (for Start Date, Finish Date, and Duration only). The default is unchecked.

10 Click the Move Up (Left) or Move Down (Right) buttons to change the sorting order of the data elements.

Activity Sheet properties window, Data Elements tab example

11 Click OK. The new Activity Sheet is available in the log.

Example Activity Sheet

The rows in the sheet list the projects and shells related to the selected activity codes. The headings for the columns in the sheet are the selected activity codes; the sub-columns are represented as the data elements for the activity codes.

The Number column lists the project or shell number; the Name column lists the project or shell name. The Location column lists the location of each shell, and is blank for projects.
Cell values are obtained from the project or shell Master Schedule Sheet from activities that match Activity Code.

NA displays in a cell if:

- The Activity Code is not found
- You do not have permissions to view or update a Master Schedule Sheet
- A project or shell does not have a Master Schedule Sheet

**Update Multiple Activities**

You can use the Activity Sheet to update multiple activities at once.

- Changes to activity Start and Finish dates made via program activity sheets prompt role amount recalculation on the affected schedule sheets.
- All changes are captured in the Audit log.

**To update multiple activities**

1. In User Mode, navigate to **Projects tab > Programs > Schedule Manager > Activity Sheets**. The Activity Sheet log opens.

2. Select the Activity Sheet and click **Open**.

3. Modify the data as needed. Cells that are modified are highlighted on the sheet. Only elements that were marked as editable can be modified. To undo changes in a row, select the row and click **Refresh**.

4. Click the **Save** button. The Activity Update Status window opens.

![Activity Update Status window](image)

You cannot modify the Activity Sheet while the status window is active. The status window scrolls to display In Process projects.

These are some possible activity update errors:

- Date (either manually entered or automatically calculated) conflicts with a dependency
- Date entered is before the scheduled Start Date
5 Click on the **OK** button to return to the Activity Sheet.

There are icons in the first column. The check mark icon displays for successfully processed project rows.

![Successful update of an Activity Sheet](image)

The X mark icon displays for rows that could not complete the processing due to errors. The X mark icons are hyperlinks. Click the icon to open a dialog box that describes the error encountered by the update process for that specific project row in the update.

![Error on update of Activity Sheet](image)

You can modify data elements other than the system defined Start Date, Finish, Date or Duration directly to matching activities without affecting other activities.

If there are Finish-Start dependencies:

- If you modify the Start Date on any activity, the system will compute the Finish Date of current activity, keeping the Duration Constant
- If you modify the Start Date on any activity, the Start Date of the successor (downstream) activity is updated
- If you modify the Finish Date on any activity, the system will compute the Start Date, keeping Duration constant
- If you modify the Finish Date on any activity, the system will modify the Start Date of successor (downstream) activity
- If you modify the Duration on any activity, the system will compute a new Finish Date, keeping the Start Date constant
• If you modify the Duration on any activity, the system modifies the Start Date of successor (downstream) activities
  Changes to activities that occur through Activity Sheet update are shown on the Audit Log.

**Undo Activity Row Changes**

Refresh allows you to undo changes to cells in selected rows, so you can save the Activity Sheet without updating those cells.

**To refresh Activity Sheet rows**

1. In User Mode, navigate to Projects tab > Programs > Schedule Manager > Activity Sheets. The Activity Sheet log opens.
2. Select the Activity Sheet and click Open.
3. Select one or more rows in the sheet.
4. Click the Refresh button. Highlighting is removed from the selected rows. Those rows are not modified when you click Save to update the Activity Sheet.

**Update Activity Sheet Properties**

**To update Activity Sheet properties**

1. In User Mode, navigate to Projects tab > Programs > Schedule Manager > Activity Sheets. The Activity Sheet log opens.
2. Select the Activity Sheet and click Open.
3. Click the Properties button.
4. Update the properties as needed and click OK.

**Export Activity Sheets**

You can export the entire Activity Sheet to a CSV file.

**To export an Activity Sheet**

1. In User Mode, navigate to Projects tab > Programs > Schedule Manager > Activity Sheets. The Activity Sheet log opens.
2. Select the Activity Sheet and click Open.
3. Choose Edit > Export to CSV.
Set Up Activity Sheet Baselines

You can set baselines on Activity Sheets at the program level. On Activity Sheets, baselines can be set for multiple projects or shells, and so affect all activities on the selected project or shell schedule sheets. The baselines you set on the Activity Sheet will affect all of the activities on the selected projects or shells, regardless of which activities are displayed on the Activity Sheet. Setting baselines at the Activity Sheet level can be useful if you are managing several projects or shells as a program. This functionality enables you to have insight into the activities for all of the selected projects or shells, and be able, for example, to discover quickly whether there has been any delay in any of the project or shell activities.

Users with the Edit Data and Structure permission on the project or shell schedule sheet can set or clear baselines for the activities from those projects or shells on the activity sheet.

See "Set Schedule Sheet Baselines" on page 732 for further details on baselines.

To set a baseline on an Activity Sheet

1. Open the Activity Sheet in the log. If you have modified the Activity Sheet, you must save it before you can set baselines.

2. Choose Edit > Baseline. You can select this action only if you have saved changes to the Activity Sheet.

3. Select Baseline > All to apply the baseline to all of the projects and shells listing in the Activity Sheet. Select Baseline > Selected to select one or more project or shell rows. The Set Baseline window opens.

4. Select the baseline to set. The Set baseline radio button is selected by default. Only baselines that have been designed in Primavera uDesigner are available.

5. Click OK. The values from the start, finish, and duration elements are copied into the corresponding baseline elements. If the baseline elements contain data, you will receive a warning that the baseline will be overwritten. You can choose whether to override the data. The Confirmation window opens.

6. Click Yes to confirm the baseline settings. The Processing Status window opens. After the system processes the baselines, you will see a check mark next to the rows in the Activity Sheet that indicate the baseline was set successfully. If the baseline was not set, failed rows in the sheet are marked with an X.

To clear a baseline on an Activity Sheet

1. Open the schedule sheet in the log.

2. Choose Edit > Baseline. The Set Baseline window opens.
3 Select the baseline you want to clear.

4 Select the Clear baseline radio button.

5 Click OK. The Confirmation window opens. Click Yes to confirm the cleared baselines. The Processing Status window opens. After the system processes the baselines, you will see a check mark next to the rows in the Activity Sheet that indicate the baseline was cleared successfully. If the baseline was not cleared, failed rows in the sheet are marked with an X.
SCOPE MANAGEMENT

The Scope Management defines deliverables, responsible roles, actual assignees and their schedules, and drives coordinated production of these deliverables. The Scope Management initiates actions for producing deliverables based on the completion of dependencies. It routes them to the responsible person or group, monitors their completion, and updates deliverable statuses automatically. It manages different activities across schedules for different team members simultaneously.

Team members work on BP's that are linked to activities in a schedule sheet. The Scope Management allows you to use existing schedule management functionality with added data elements to automate the management of a project’s scope and schedule with all associated activities, tasks, and deliverables. This feature provides project managers with the ability to manage each scope item’s task assignments, ownerships, and durations.

Project managers can use scope management to manage high-volume, quick turnaround projects that have standardized scope and scheduled activities. Examples of projects that would benefit from the use of scope management functionality are retail construction projects such as bank branches or chain fast food restaurants. Primavera Unifier’s scope management capabilities are also useful for large capital projects with complex scope and schedules, and that have numerous dependent activities and milestones with associated tasks and deadlines.

Scope management:

• Coordinates the creation of the defined deliverables using the schedules of the various assignees

• Automatically moves tasks to the next assignee.

• Routes tasks related to the deliverables to the next responsible assignee (person or group), monitors the state of the tasks, and updates deliverable status automatically. Actions for the creation of deliverables are based on fixed-time durations and the completion of dependencies.

• Launches business processes that are linked to activities

This functionality can be enabled on any schedule sheet, including a master schedule sheet. Scope management enables you to link BP’s with schedule sheet task activities and route those BP’s with an automatic update of status as they are routed and worked on. The BP’s represent the work that needs to be done to complete the task. You can override automatic routing at any time and launch the BP’s manually. The BP-related task is completed when specified conditions are met.

Working With Schedule Sheets With Scope Management

You can have any number of schedule sheets. There is one master sheet, which appears in bold in the log. The master schedule sheet drives the activity start and finish dates. You can use it to track progress and resource assignment information to other modules in Primavera Unifier. You can use scope management on any schedule sheet. You must have the correct permissions to be able to view and modify scope management data. If you find that you cannot access the functionality that you need, see your company administrator.

To access project schedule sheets

1 In User Mode, select Project Standard tab > project > Schedule Manager > Schedule Sheets or Shells tab > shell type> shell instance > Schedule Manager > Schedule Sheets. The Schedule Sheets log opens.

2 By default, the log lists all active schedule sheets. To view all active and inactive sheets, click the View menu and choose All.
Manage Scope Management Properties

Scope Management functionality can be enabled on any schedule sheet (including master schedule sheets). You can modify the properties associated with scope management. These include:

- Auto-control
- Schedule start date
- Error notification to users and groups

To manage scope management properties

1. In User Mode, navigate to the project or shell Schedule Manager and select Schedule Log. The Schedule Sheets log opens.

2. Select a schedule sheet and click Properties.

3. On the General tab, complete or modify the fields described in the following table and then click OK.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto-control</td>
<td>Controls the automatic update of tasks. The default is Off. Setting auto-control to On enables the automatic launch of BP records. Setting auto-control to Off means that BPs will not be launched automatically on activities and completion conditions will not be checked on activities. Users can still launch BPs manually. <strong>Note</strong>: Unifier disregards predecessor/successor dependency relationships when you manually start an activity, even if auto-control is set to On in the schedule sheet properties.</td>
</tr>
<tr>
<td>Schedule Start Date</td>
<td>Drives the dates of floating activities on the schedule sheet. Activities cannot begin before this date, unless their preceding activities complete previous to this date.</td>
</tr>
<tr>
<td>Notify users and/or groups on errors</td>
<td>Select users and groups to be notified if there are errors during the scope management task routing.</td>
</tr>
</tbody>
</table>

About Scope Management Data Elements

There are data elements that are specific to scope management, which were added to the schedule attribute form in Primavera uDesigner. These data elements can be added to the scope management schedule sheet as columns as you work with the sheet. If data elements are on both the schedule attribute form and on the BP that you will be using to execute the activity task for scope management, the values are copied from the form to the BP and vice versa.

When you are planning to use scope management, consult with the Primavera uDesigner user and your company administrator to achieve the setup of data elements and BPs that will meet your business needs for managing scope.

The scope management-specific data elements that are added to the schedule attribute form are:

<table>
<thead>
<tr>
<th>Data Element Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Start Date</td>
<td>Actual start date of the activity.</td>
</tr>
<tr>
<td>Actual Finish</td>
<td>Actual finish date of the activity.</td>
</tr>
</tbody>
</table>
### Data Element Name | Description
--- | ---
Date |  
Actual Duration | Actual duration of the activity. This is calculated from the Actual Start Date and Actual Finish Date.  
Status | Activity status. The default is Not Started.  
Predecessors | A list of the predecessor activities.  
**Note:** Activities that have no predecessors are known as floating activities.  
Record Number | Hyperlink to the linked BP record.  
Record Status | Hyperlink to the linked BP record.  
Estimated Start Date | Calculated date.  
Estimated Finish Date | Calculated date.  
Estimated Duration | Calculated duration.  
Auto-update Activity Data | Enables the automatic update of activity data. The default is unchecked. If this checkbox is not selected, the activity must be completed manually, and automatic completion will be turned off. This means you must change the activity status to compete and enter an actual finish date.  
Linked BP Name | Name of the linked BP.

### Set Up Scope Management For Activities

You can set up the schedule sheet activities to link to BPs, specify responsible users or groups, enter a due date, and create completion conditions.

You can change all setup options for activities that have the status of not started or not applicable. For activities that have an in-progress status and have a linked BP record, you can change only the completion conditions. You cannot change setup options for activities with the status complete.

#### To set up scope management for an activity

1. In User Mode, navigate to the Schedule Manager and select Schedule Log. The Schedule Sheets log opens.
2. Select a schedule sheet click the **Open** button.
4. Choose **File > Setup Scope Management**. The Activity Task Setup window displays on the right side of the pane, replacing the view of the Gantt portion of the window.

**Note**: You can return to the Gantt chart view by clicking the **Gantt** button.
5 Complete the Activity Task Setup portion of the window as described in the following table.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linked Business Process</td>
<td>Select a project or shell level workflow BP that will launch from the activity.</td>
</tr>
<tr>
<td>Bypass initiation step during auto-creation</td>
<td>Auto-created records normally appear in users’ Tasks and BP logs as an initiation step (I Step). Select this check box if you want to bypass the I step that this auto-creation normally creates. If you select this option, the auto-created record will skip the initiation step and will appear in the user’s BP log at the step that the Administrator designated on the BP’s Auto-Creation tab during setup.</td>
</tr>
</tbody>
</table>
| Record Due Date                       | Select **Enforce Activity Duration** (default) or **Enforce Activity Finish Date**. When a BP is launched automatically or manually from an activity, you can specify whether the record due date on the newly launched BP record is set to use the activity duration or the activity finish date. **Enforce Activity Duration**: The finish date of the activity is not considered. If the Record Due Date option is set to enforce the activity duration, the value is calculated as: Record Due Date = Current Date (date/time) + Activity Duration (days)  
**Enforce Activity Finish Date**: If the Record Due Date option is set to enforce the activity finish date, it is calculated as: Record Due Date = Activity Finish Date  
*note*: This functionality applies to workflow BPs launched from Scope Management only. Non-workflow BPs cannot be launched using Scope Management.  
*note*: If you select Enforce Activity Finish Date, the workflow due date for the business process might be affected. Be sure to select Yes for Override Workflow Due Date in the workflow setup for the affected business process. |
| Responsible User(s) /Group(s)         | Select one or more users or groups to which to route the business process. Be sure to add users and groups to this field so the business process associated with the activity will launch properly. |
| Completion                            | Add one or more conditions to indicate the completion condition on the activity. Click **Add** and select from the data elements for the selected BP, enter a label for the condition data |
In this field:  | Do this:
---|---
Conditions  | element, select a condition, and select a value. Click **OK**. Conditions can be a BP status, a monetary value, or the completion of certain predecessor activities. You set up several completion conditions for each activity. See "Completion Conditions" on page 752 for details.
Show results matching ANY condition  | Select to complete the activity if any of the completion conditions are met for the activity.

6 Repeat these steps for each activity.

7 Click the **Save** button when your changes are complete.

**Completion Conditions**

You can set up completion conditions for a string or a date. For example, for the string *Amount*:

For example, for a date:
Launching Business Processes From Activities

While the scope management functionality is automatic after it is set up, you can also manually launch or remove BPs from activities and manage the activity properties.

**Note:** If a project or shell changes status from Active to View-Only or Inactive, business processes associated with activities are not launched while the project or shell has the View-Only or Inactive status. When the project or shell reverts to Active status, you must adjust the dates on these business processes and launch them manually.

**Manually Launch A Business Process**

When you manually launch a BP associated with an activity, you override the Auto-control property setting. See "Manage scope management properties" on page 749 for details on properties.

See "About Launching or Removing Business Processes from Activities" on page 755 for details on the conditions under which you can manually launch BPs.

**To manually launch a BP associated with an activity**

1. In User Mode, navigate to the Schedule Manager and select Schedule Log. The Schedule Sheets log opens.
2. Select a schedule sheet and click the **Open** button.
3. Select an activity.
4. Choose **Edit > Linked Business Process > Start**. You can select one or more BPs and launch them. They will be routed to the assignees that have been specified.

**Remove The Link Between A Business Process And An Activity**

You can remove (unlink) a BP from an activity. See "About Launching or Removing Business Processes from Activities" on page 755 for details on the conditions under which you can remove BPs from activities.
To remove the link between an activity and a BP

1. In User Mode, navigate to the Schedule Manager and select Schedule Log. The Schedule Sheets log opens.
2. Select a schedule sheet and click the Open button.
3. Select an activity.
4. Choose Edit > Linked Business Process > Remove Record. You can select one or more BPs. The BP itself is not deleted.

**Note:** The link between a BP and an activity is automatically removed if the BP is terminated. When a linked BP is terminated, the BP hyperlink is removed from the associated activity, and the activity is set to not started.

**Update Activity Properties**

To update activity properties for scope management

1. In User Mode, navigate to the Schedule Manager and select Schedule Log. The Schedule Sheets log opens.
2. Select a schedule sheet and click the Open button.
3. Click the link for an activity. The Activity Properties window displays.
4. Modify the activity properties as needed. The properties shown in the Activity Properties window depend on the design configured in Primavera uDesigner. Activity properties associated with scope management can include:

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Statuses</td>
<td>Read-only for automatically controlled activities. Editable for manually controlled activities. The statuses are:</td>
</tr>
<tr>
<td></td>
<td>• Not Started: All activities have this as the initial status by default. Indicates that the BP linked to the activity has not yet been launched.</td>
</tr>
<tr>
<td></td>
<td>• In Progress: Indicates that predecessor activities are complete and that the current activity is not started. A new BP record is created and linked to the activity.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> You cannot modify certain activity attributes while an activity is In progress.</td>
</tr>
<tr>
<td></td>
<td>• Complete: Indicates that an activity is complete based on the completion conditions set up for the activity.</td>
</tr>
<tr>
<td>Linked BP Name</td>
<td>Read-only; displays the BP linked to the activity.</td>
</tr>
<tr>
<td>Record Number</td>
<td>Read-only; displays the current record number that is linked with the activity.</td>
</tr>
<tr>
<td>Record Status</td>
<td>Read-only; displays the current status of the BP record linked to the activity.</td>
</tr>
<tr>
<td>Actual Start Date</td>
<td>Read-only or editable, depending on the setting for the Auto-update activity data box. This value is set when the linked BP is launched for the activity.</td>
</tr>
<tr>
<td>Actual Finish Date</td>
<td>Read-only or editable, depending on the setting for the Auto-update activity data box. This value is set when the linked BP is completed based on the completion conditions.</td>
</tr>
<tr>
<td>Estimated Start Date</td>
<td>Read-only; indicates the estimated start date for the activity.</td>
</tr>
<tr>
<td>Estimated Finish</td>
<td>Read-only, indicates the estimated finish date for the activity.</td>
</tr>
</tbody>
</table>
Date

Auto-update activity status | The default is not selected. Indicates if the current activity is automatically controlled or manually controlled.
--- | ---
Dependencies | Read-only; lists the predecessor activities for the current activity using a coding format indicating lag and lead time: Finish to Start (FS), Start to Start (SS), Finish to Finish (FF), and Start to Finish (SF). For example:

- 3FS + 3d (Activity 3 is a predecessor with FS relationship with 3 days lag)
- 2SS - 1d (Activity 2 is a predecessor with SS relationship with a 1 day lead)

An activity can have multiple dependencies separated by a comma. The value is updated every time there is an addition or change to the predecessors.

5 Click OK.

Status Transitions And Activities

Scope management activities have statuses that control the transition of the activity from one state to another as it progresses toward completion. You can perform certain changes to the activity during its progress, but it can be limited as to what you can change while an activity has the status In Progress. The activity status transitions vary depending on whether an activity is automatically or manually launched.

**Automatic Activity Status Transitions**

When activities are auto-controlled (the Auto-update Activity Status box is checked), activity status is read only. The statuses automatically transition as follows:

1. Not started (default)
2. In progress (this is when the linked BP is launched)
3. Complete (when the BP completion conditions are met)

**Manual Activity Status Transitions**

You can change the activity status manually when the Auto-update Activity Status box is not checked. You can change the status during any of the states (not started, in progress, or complete).

- If you change the status of an activity to In Progress, you can enter the actual start date. This clears the existing actual finish date.
- If you change the status of an activity to Not Started, both the actual start date and the actual finish date are read only.
- If you change the status of an activity to Complete, you can enter an actual finish date. In this case, the actual start date, if it is not populated, is set to the actual finish date at activity completion.

**About Launching Or Removing Business Processes From Activities**

Scope management functionality enables automatic or manual creation of BPs from activities on a schedule sheet. A new BP record can be created for every eligible activity. The BP record will be permanently linked to the activity, unless you terminate or remove the BP. An activity can be linked to only one BP record at a time. Any two activities cannot link to the same BP record.

**Automatic Launching Of Business Processes**

For BPs to launch automatically from activities, these conditions must be met:
• Auto-control must be set to On on the Schedule Sheet properties
• Activity is not manually controlled, which means that Auto-update Activity is selected
• Activity has a BP setup
• Activity has the status Not Started
• Activity is floating (no predecessors) or the predecessors are all in Complete status
• The start date for the activity is not in the future

**Manually Launching Business Processes**

You can launch BPs manually by selecting an activity and choosing Edit > Linked Business Process > Start. To manually launch BPs, these conditions must be met:

• Activity has the status Not Started
• BP setup is present on the activity

**Note:** A BP can be launched manually to override the setting of the Auto-control flag on the Schedule Sheet Properties and Auto-update Activity Data on the Activity Properties.

Manual launch under various conditions:

<table>
<thead>
<tr>
<th>Auto-control on Schedule Sheet Properties</th>
<th>Auto-update Activity Status on Activity</th>
<th>System Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>On/Off</td>
<td>Checked</td>
<td>Manually launched BP is tracked by the system, and actuals will be auto-populated on launch and completion.</td>
</tr>
<tr>
<td>On/Off</td>
<td>Unchecked</td>
<td>Scope Management will not keep track of BP completion and auto-population of actual start and finish dates of manually launched BP.</td>
</tr>
</tbody>
</table>

**Manually Remove Business Process Link**

You can remove a linked BP record manually if these conditions are met:

• Activity is in manual mode; that is, Auto-update Activity Status on Activity is unchecked
• Activity is in any status.

**Automatic Removal Of Business Process Link**

If a BP is terminated by the user, the termination removes the BP link from the activity and sets the activity back to Not Started.

**About Activity Completion**

This section covers the criteria for automatic and manual completion of scope management activities.

**Conditions For The Automatic Completion Of Activities**

Primavera Unifier checks the linked BP record workflow for in-progress status activities that are not manually controlled (Auto-update Activity Data box is checked for the activity).
When the system detects BP completion based on the conditions, it performs the following actions:

1. Actual finish is updated with current date
2. Activity status is updated to complete
3. Success of activities is evaluated for the automatic launching of further BPs

If there is no BP setup or if the activity is manually controlled, the system does not evaluate the BP completion conditions but waits for you to manually complete the activity.

**Conditions For The Manual Completion Of Activities**

Activities that are manually controlled (Auto-update Activity Data box is unchecked) can only be completed manually. In this case, you must change the activity status to Complete and enter the actual finish date, which is required for the activity to complete successfully.

**Impact Of Successor And Predecessor Activities On Launching And Completion Of BPs**

This section discusses the interaction of activities and the launching of BPs. The start of an activity is affected by whether there is a lag or a lead, as shown in the examples below.

**Finish-to-start (FS)**

The successor activity is launched when the activity completes or the Calculated Date = Predecessor Actual Finish + Lag (if not already past).

In case of a lead, the successor activity is launched on the forecast start date (similar to a floating activity).

![Finish-to-start diagram](image)

**Start-to-start (SS)**

When an activity’s predecessor is started (for example, status = in-progress), it is also placed into an in-progress status (assuming zero lag).

- **Lag**: Success, or activity will be started on forecast date
- **Lead**: Success, or activity will be started on forecast date
Finish-to-finish (FF) And Start-to-finish (SF)

The activities will be treated as floating activities. They are launched on their forecast date.

- **Lag**: Success, or activity will be started on forecast date
- **Lead**: Success, or activity will be started on forecast date

About Manual Or Automatic Control Of Individual Activities

This section describes the behavior of manual and automatic control of scope management activities.

Auto-update Activity Data On Activity Attributes

Activities can be controlled in two modes: automatic or manual. This choice depends on the value of the Auto-update Activity Data checkbox.

If **Auto-update Activity Data** is checked, automatic launching of BPs and completion checks with the possibility of launching the BP sooner.

If Auto-update Activity Data is unchecked (default value), the user has manual control, but basic scope completion rules are enforced. BP link is maintained. New BPs can be launched manually. The BP is not checked for completion.

The following table summarizes the behavior in each mode:

<table>
<thead>
<tr>
<th>Behavior</th>
<th>Automatic</th>
<th>Manual</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto-update Activity Data checkbox</td>
<td>Checked</td>
<td>Unchecked (default)</td>
</tr>
<tr>
<td>BP setup allowed</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Create BP record link</td>
<td>Yes</td>
<td>Retain existing link if any exists</td>
</tr>
</tbody>
</table>
## Rules For Modifying The Auto-update Activity Data Checkbox

These are the rules for using the Auto-update Activity Data checkbox.

- The Auto-Update Activity Data checkbox is unchecked by default for all schedule sheets.
- As soon as a new BP is set up for the activity (by choosing `File > Setup Scope Management`), the Auto-update Activity Data checkbox will be checked only for activities in the Not Started status.
- Updating the BP setup on an activity later will only check the Auto-update Activity Data checkbox automatically if the activity is in the Not Started status. If you have not set up any BP linking, by default, the box is unchecked. In that case, you can update the Actual Start, Actual Finish, and Status fields.
- You can manually modify the Auto-update Activity Data checkbox for any activity status, including complete.

## System Behavior When The Auto-update Activity Data Checkbox Is Modified

The following is the sequence of the system behavior when the Auto-update Activity Data checkbox is modified:

1. The Auto-update Activity Data checkbox is unchecked by default, assuming that no BP setup exists for the activity. As soon as a new BP is set up or modified for the activity, the Auto-update Activity Data checkbox is checked.

2. Unchecking the Auto-update Activity Data checkbox will:
   a. Retain the BP record link (if any).
   b. Retain the original status of the activity.
   c. Change the activity status of an editable field.
   d. Retain existing actuals but allow them to be modified.

3. Subsequent checking of the Auto-update Activity Data checkbox will:
a Retain the BP record link if it exists.

b If a BP record link exists, update BP record status on the activity, and check the BP record for complete condition and set the appropriate status of the activity (either Complete or In Progress).

c If a link does not exist and conditions allow the start of the BP, the system launches the BP and sets the activity status to In Progress.

d If a link does not exist and conditions do not allow the start of the BP, the system sets the activity status to Not Started.

**Note:** Setting the status to Not Started or Not Applicable in manual control mode does not clear the BP record link. The actual start cannot be a future date when entered manually, and the actual finish cannot be a future date when entered manually.

**Impact Of Schedule Start Date**

The schedule start date on schedule sheet properties defines the earliest possible date on the schedule sheet. The start dates of all activities on the schedule sheet must be greater than or equal to the schedule start date.

The schedule start date affects the first activity in a group of linked activities and controls the start of any floating activities. Floating activities are activities that have no predecessor activities.

When you change the schedule start date, the entire schedule moves, and all the dates adjust in relation to the new schedule start date.

The schedule start date is a required field on schedule sheet properties. Updates to the schedule start date activities are based on following rules:

- Floating activities start and retain the offset from the schedule start date specified on the sheet properties.
- The start date on floating activities can be updated; however, the activities start date cannot be earlier than the schedule start date.
- The start date of any floating activity will drive the start of the system update process. Each floating item may be the root of a tree and hence will have its own system update process that drives launching and completion of BPs for the current activity and successor activities.
- Forecast dates (start date, finish date) can only be changed for not started or in-progress activities.
- The schedule start date cannot be changed when at least one activity is in progress or complete.
- Manual launch cannot be done on any activity before the schedule start date on the sheet properties.

**Calculation Of Estimated Start And Finish Dates**

Estimated dates are used to predict the effect of delayed or early completion of predecessor activities on successor activities. They are useful to identify potential problems or the potential for schedule compression.

The estimated start, finish, and duration are read-only elements calculated by the system. They are updated by the system each time activities complete. Succeeding estimated dates are adjusted based on the logic below.

For completed or predecessor complete activities:
Estimated Start Date = Actual Start Date
Estimated Finish Date = Actual Finish Date

For in-progress or not started activities:
Estimated Start Date = Predecessor (latest) Estimated Finish Date
Estimated Finish Date = Estimated Start Date + Forecast Duration

**Entering and Viewing Cost Data**

In Primavera uDesigner, data elements can be added that allow you to enter and view cost data on schedule sheets. These data elements are Activity Cost 1 (and Activity Total Cost 1 Per WBS) and Activity Cost 2 (and Activity Total Cost 2 Per WBS). The Cost and Per WBS data elements have a predefined association between them. Also, the Activity Latest Progress As Of data element can be added to allow you to track the date of the last change to an activity.

**Note:** Primavera Unifier refreshes the cost data when you choose File > Refresh in a Schedule Sheet and refresh immediately or set up a refresh frequency. See “Refreshing Schedule Sheet data” on page 729 for details.

In the activity setup performed by the Administrator, one or more WBS Codes can be associated with an activity. The value carried by the Total Cost data element on add to a Schedule Activity Attribute form gets passed onto these WBS codes as the result of calculations such as data roll up to a Cost Sheet, or earned value calculations. The logic used by the Activity Cost 1 and Activity Cost 2 and the associated Activity Total Cost 1 Per WBS and Activity Total Cost 2 Per WBS data elements is based on the association of an activity to a WBS code.

The values for Activity Total Cost 1 Per WBS and Activity Total Cost 2 Per WBS data elements are calculated by the system based on the corresponding Activity Cost 1 or Activity Cost 2 data element values.

These are the steps the system follows to calculate values for Activity Total Cost 1 Per WBS and Activity Total Cost 2 Per WBS data elements:

1. If the combination of Cost and Per WBS data elements are used on a Schedule Activity Attribute form, the system will scan through all of the activities and associated WBS codes.

2. The system will accumulate all of the values in the Activity Cost 1 or Activity Cost 2 data elements for all activities per WBS code associated with each activity.

3. Use the total value calculated in step 2 per WBS code as the value for each Activity Total Cost 1 Per WBS and Activity Total Cost 2 Per WBS data element specified for each activity.

4. Each activity gets a total value calculated in step 2 based on the WBS code associated with it.

The following example explains these calculations. For this example, the data elements Activity Cost 1 and Activity Total Cost 1 Per WBS have been added to the attribute form:

<table>
<thead>
<tr>
<th>Activity Name</th>
<th>Activity Cost 1</th>
<th>Activity Total Cost 1 Per WBS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Account 1</td>
<td>$28,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Activity 1.1</td>
<td>$19,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Point 1.1.1</td>
<td>$10,000.00</td>
<td>$28,000.00</td>
</tr>
<tr>
<td>WBS - 1</td>
<td>$10,000.00</td>
<td></td>
</tr>
<tr>
<td>Activity Name</td>
<td>Activity Cost 1</td>
<td>Activity Total Cost 1 Per WBS</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Control Point 1.1.2</td>
<td>$9,000.00</td>
<td>$28,000.00</td>
</tr>
<tr>
<td>WBS - 1</td>
<td>$9,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Activity 1.2</td>
<td>$9,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Point 1.2.1</td>
<td>$5,000.00</td>
<td>$28,000.00</td>
</tr>
<tr>
<td>WBS - 1</td>
<td>$5,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Point 1.2.2</td>
<td>$4,000.00</td>
<td>$28,000.00</td>
</tr>
<tr>
<td>WBS - 1</td>
<td>$4,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Account 2</td>
<td>$20,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Activity 2.1</td>
<td>$20,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Point 2.1.1</td>
<td>$8,000.00</td>
<td>$20,000.00</td>
</tr>
<tr>
<td>WBS - 2</td>
<td>$8,000.00</td>
<td></td>
</tr>
<tr>
<td>Control Point 2.1.2</td>
<td>$12,000.00</td>
<td>$20,000.00</td>
</tr>
<tr>
<td>WBS - 2</td>
<td>$12,000.00</td>
<td></td>
</tr>
</tbody>
</table>

In the above example, Control Point 1.1.1 has a value $28000.00, which was arrived at by adding the value of WBS - 1 across all activities.
The Schedule Manager allows you to enter activity progress, which is accumulated and used to calculate the earned progress for each activity. Earned progress represents how much has been earned on an activity. Depending on type of activity, earned progress can be tied to activity progress directly. However, it is also possible nothing is earned even if the progress is 99%, if the activity has been defined to have earned progress counted upon 100% of activity completion.

Earned progress is a quantitative measurement to indicate how much has been earned on an activity over the duration of the activity. Earned Progress can be represented by amount, quantity and a percentage value. Earned Progress is based on the progress entered by the user on an activity.

Each activity can earn progress in different ways. One way to earn is when progress is entered. Another way to earn is by % of activity when the activity is started and earn remaining % when that activity is finished. Primavera Unifier captures earned progress for an activity as well as resources that assigned to an activity. Earned progress data from the Schedule Manager is related to WBS codes and is used by the Earned Value module (in the Cost Manager) to calculate different key components that are required to perform Earned Value analysis.

The Schedule Manager also allows you to enter activity progress in the activity properties. The calculations described in this section pertain to the progress and earned progress data accumulation and calculation discussed in See "Progress and Earned Progress Calculations" on page 782. If you do not need to work with progress or earned progress data to ultimately calculate Earned Value, you do not need to read this section.

**Note:** The calculations described in this section pertain to the progress and earned progress data accumulation and calculation. If you do not need to work with progress or earned progress data to ultimately calculate Earned Value, you do not need to read this section.

**Terminology**

**Progress**: A percentage that indicates how much of an activity has been accomplished.

**Earned Progress**: This quantity represents the progress earned for a given activity over a time period. Depending on type of activity, earned progress can be tied directly to activity progress. Also, earned progress can be set up to be given at activity finish. For example, earned progress might not be awarded for incremental percentages of progress, and not be counted until 100% of an activity is complete.

**Earned Progress And Earned Value**

The Earned Value module uses the concept of Earned Value Management (EVM), which is an analytical tool that allows Project Managers and stakeholders of a project to determine whether a project is on schedule and on budget. Based on the outcome of the earned value analysis, the project manager can determine if corrective action is needed to ensure that the project can be completed within its constraints. Examples of corrective action can be the change of project scope, extension of the schedule, or the addition of resources.

There are a number of parameters that are used to calculate Earned Value to determine if a project is on schedule and on budget. Some of these parameters are Budget, Progress, or Actual Cost. All of these
parameters must be considered together to determine the current state of a project. One of the key components of this technique is to capture the progress of a project. This progress is usually provided by a General Contractor or the person who is in charge of the project. These progress entries are analyzed to determine the state of the project. Progress information entered by user can be analyzed to determine the progress of the project with respect to budget and schedule.

**Enter Progress And Earned Progress Information**

In Primavera Unifier, there are several areas that enable you to enter (based on settings), view progress and earned progress information, or control the accumulation of progress information:

1. **Budget and Progress Setup window**: First, set up how you want your progress data calculated. See "Setting Up the Budget and Progress Method" on page 764 for details.

2. **Enter data on the attribute forms**: The fields that allow you to enter data are determined by the settings on the Budget and Progress Setup window:
   - Resource Assignment Attribute form (Resource tab of Activity Properties)
   - Schedule Attribute form (General tab of Activity Properties)
   See "Entering Progress Data on the General and Resource Tabs of Activity Properties" on page 775 for details.

3. **Activity Progress window**: View activity and resource progress; depending on settings on the Budget and Progress Setup window, you can enter progress data in this window. This window is available only if you have imported the Resource Assignment Attribute form. See "Entering Progress in the Activity Progress Window" on page 776 for details.

4. **Check activity and resource progress in the logs**: View and enter progress data as needed:
   - Activity Progress log
   - Resource Progress log
   See "Using the Activity Progress and Resource Progress Logs" on page 780 for details.

5. **Options tab of the Schedule Sheet Properties**: The options on this tab allow you to control the automatic update of activity status based on Actual Start and Actual Finish dates, and to specify that activity progress requires an Actual Start Date.

**Setting Up The Budget And Progress Method**

The Schedule Manager allows you to set up a budgeted cost of work schedule profile for each activity on a schedule sheet to distribute budget associated with the activity. You can enter this profile information in the Budget and Progress setup window, either at the schedule sheet level (for all of the activities on the sheet) or at the individual activity level.

These settings include selecting a profile, an entry method, and calculation methods for % Complete and % Earned. The settings you select in this window control how the progress and earned progress data that is entered on the Resource Assignment Attribute form (Resource tab for Activity Properties) and the Activity form (General tab for Activity Properties) is calculated. Also, you can choose the workpackage-related WBS codes to link to, and lock the progress so it cannot be updated outside of a defined period.

You can configure the setup for progress (both resource and activity) and earned progress settings independently. At the same time, you can also have activity or resource progress calculate earned progress automatically or the earned progress calculate the progress.

Most of the Budget and Progress settings that you can use at the schedule sheet level are also available at the activity level, however there are some differences. This section will first document the settings for the
schedule sheet level, and mention when there are variations at the activity level and refer to the appropriate section.

**Note:** The Budget and Progress Method setup options for an activity cannot be modified after a user begins to enter progress for that activity. This includes activity progress or progress of the resource assigned to that activity.

The calculations used to derive progress and earned progress are explained in See "Progress and Earned Progress Calculations" on page 782.

**To setup the budget and progress method**

1. Navigate to a schedule sheet log.
2. Open a schedule sheet.
3. Choose File > Budget and Progress Setup > Schedule Sheet or File > Budget and Progress Setup > Activity. At the activity level, the Budget and Progress Method Setup window opens in the right side of the schedule sheet window, and replaces the Gantt chart. When you are done working with the activity-level Budget and Progress Method Setup window, you can choose View > Gantt Chart.
4. Select the Budget and Progress settings. The Budget and Progress Method Setup window has several sections where you can choose settings.
• **Activity Budget Distribution Profile**: See "Select the activity budget distribution profile" on page 767 for details on the profile setting choices.

• **% Complete and Earned Progress**: See "Select the entry method for the % complete and earned progress" on page 768 for details on the entry methods.

• **% Complete Calculation Method**: See "Select the calculation method for % complete" on page 769 for details on these calculation methods.

• **% Earned Calculation Method**: See "Select the calculation method for % earned" on page 771 for details on these calculation methods.

• **Additional Options (schedule sheet level only)**: See "Select WBS codes filtered by workpackage (schedule sheet level only)" on page 774 and See "Lock the reporting and progress entry period (schedule sheet level only)" on page 774 for details.

5 Click OK.
Select The Activity Budget Distribution Profile

You can choose the option that determine how the budget of an activity is distributed.

To set up budget distribution for activities at the schedule sheet level

1 Open a schedule sheet.

2 Choose File > Budget and Progress Setup > Schedule Sheet. The Default Budget and Progress Method Setup window opens.

3 Under the Activity Budget Distribution Profile section, choose an option. This option will apply to all activities in the schedule sheet, unless it is overridden by the selection of a different option for an individual activity.

<table>
<thead>
<tr>
<th>Data Element Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linear</td>
<td>This option distributes the activity budget linearly.</td>
</tr>
<tr>
<td>S-curve</td>
<td>This option distributes the activity budget based on Sigma and Mu values.</td>
</tr>
<tr>
<td>• Sigma</td>
<td>S-curve calculations are based on Sigma and Mu values that are provided as setup parameters. The system will generate data using following probability density function:</td>
</tr>
<tr>
<td>• Mu %</td>
<td>$f(x) = \frac{1}{\sqrt{2\pi\sigma^2}} e^{-\frac{(x-\mu)^2}{2\sigma^2}}$</td>
</tr>
<tr>
<td>Parameters in this equations are:</td>
<td></td>
</tr>
<tr>
<td>• X is determined based on the number of periods.</td>
<td></td>
</tr>
<tr>
<td>• Mu is the mean that is calculated based on user input.</td>
<td></td>
</tr>
<tr>
<td>• Sigma is the standard deviation that is used based on user input.</td>
<td></td>
</tr>
<tr>
<td>On Start and Finish</td>
<td>This option distributes the activity budget based on the Start and Finish Dates of the activity.</td>
</tr>
<tr>
<td>• % budgeted on Start</td>
<td>This option allows you to enter the percentage that should be budgeted on start of the activity.</td>
</tr>
<tr>
<td>• % budgeted on Finish</td>
<td>This is a read-only field, and is calculated based on the % budgeted on Start value. The value for this filed is (100 - % budgeted on Start).</td>
</tr>
<tr>
<td>Import distribution data from external sources</td>
<td>This option allows Primavera Unifier to import progress data from Primavera. Data mapping is required in the schedule sheet to ensure the spread will be populated correctly in the EV sheet. All required fields must be mapped.</td>
</tr>
<tr>
<td>Distribution profile based on resource</td>
<td>This option distributes the cost of a role per activity by rolling up the rate of all the resources assigned to the activity. If hard booked resources are allocated, the total cost = (role rate) x (currency rate) x (quantity.) If the resources are not allocated, the total cost is manual entry (from a formula). In a schedule sheet’s activity, you will need to match the activity’s total cost to the role cost total. The total amount is rolled up to the cash flow module to create a cash flow profile based on the resource(s) cost on the activity.</td>
</tr>
</tbody>
</table>

The tables below show incremental and cumulative examples of how these three options work, and the differences between them. This data is assumed for these examples:

- **Start Date**: 01/1/2009
• Finish Date: 12/1/2009
• Total Cost: $12000.00
• For S-Curve: Sigma = 2 and Mu = 50%
• For Start and Finish: % budget distribution on start = 5%, % budget distribution on finish = 95%

**Incremental**

<table>
<thead>
<tr>
<th>Option</th>
<th>01-09</th>
<th>02-09</th>
<th>03-09</th>
<th>04-09</th>
<th>05-09</th>
<th>06-09</th>
<th>07-09</th>
<th>08-09</th>
<th>09-09</th>
<th>10-09</th>
<th>11-09</th>
<th>12-09</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linear</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
<td>1000</td>
</tr>
<tr>
<td>S-Curve</td>
<td>26.52</td>
<td>104.88</td>
<td>323.06</td>
<td>789.30</td>
<td>1462.17</td>
<td>2120.93</td>
<td>2401.43</td>
<td>2120.93</td>
<td>1447.85</td>
<td>774.98</td>
<td>323.06</td>
<td>104.88</td>
</tr>
<tr>
<td>On Start and Finish</td>
<td>600</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>11400</td>
</tr>
</tbody>
</table>

**Cumulative**

<table>
<thead>
<tr>
<th>Option</th>
<th>01-09</th>
<th>02-09</th>
<th>03-09</th>
<th>04-09</th>
<th>05-09</th>
<th>06-09</th>
<th>07-09</th>
<th>08-09</th>
<th>09-09</th>
<th>10-09</th>
<th>11-09</th>
<th>12-09</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linear</td>
<td>1000</td>
<td>2000</td>
<td>3000</td>
<td>4000</td>
<td>5000</td>
<td>6000</td>
<td>7000</td>
<td>8000</td>
<td>9000</td>
<td>10000</td>
<td>11000</td>
<td>12000</td>
</tr>
<tr>
<td>S-Curve</td>
<td>26.5</td>
<td>131.4</td>
<td>454.4</td>
<td>1243.7</td>
<td>2705.9</td>
<td>4826.8</td>
<td>7228.2</td>
<td>9349.2</td>
<td>10797.0</td>
<td>11572.1</td>
<td>11895.1</td>
<td>1199.99</td>
</tr>
<tr>
<td>On Start and Finish</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
<td>600</td>
</tr>
</tbody>
</table>

To set up budget distribution for activities at the activity level

1. Open a schedule sheet.
2. Highlight an activity row in the sheet.
3. Choose File > Budget and Progress Setup > Activity.
4. Under the Activity Budget Distribution Profile section, choose an option. This option will apply specifically to the selected activity, and will override any default option set up at the schedule sheet level. The behavior of these Activity Budget Distribution Profile options at the activity level is the same as the default options at the schedule sheet level.

**Select The Entry Method For The % Complete And Earned Progress**

You can select an entry method for the progress and earned progress data, and can enter progress (both resource and activity) and earned progress independently. Also, you can select an entry method that
allows you to enter the progress of activity or resource then calculate earned progress, or enter earned progress and calculate progress for an activity or resource.

**To select the entry method for the % complete and earned progress for activities at the schedule sheet level**

1. Open a schedule sheet.
2. Choose **File > Budget and Progress Setup > Schedule Sheet**.
3. In the **Default % Complete and Earned Progress** section, choose a default entry method. This entry method will apply to all activities in the schedule sheet, unless it is overridden by the selection of a different entry method for an individual activity.

<table>
<thead>
<tr>
<th>Use this Entry Method</th>
<th>To do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Independently Control % complete and earned quantity</td>
<td>Enter the progress of activity or resource independent of earned progress.</td>
</tr>
<tr>
<td>Activity and resource % complete updates % earned</td>
<td>Enter the progress of activity or resource, and earned progress will be automatically calculated.</td>
</tr>
<tr>
<td>Activity and resource % earned updated % complete</td>
<td>Enter the earned progress of activity or resource, and progress will be automatically calculated.</td>
</tr>
<tr>
<td>Do not allow update of % complete and % earned</td>
<td><strong>Not</strong> enter either progress or earned progress. You cannot enter any type of activity progress information with this option selected.</td>
</tr>
</tbody>
</table>

**To select the entry method for the % complete and earned progress for activities at the activity level**

1. Open a schedule sheet.
2. Highlight an activity row in the sheet.
3. Choose **File > Budget and Progress Setup > Activity**.
4. Under the **% Complete and Earned Progress** section, choose an entry method. This option will apply specifically to the selected activity, and will override any default entry method set up at the schedule sheet level. The behavior of these % Complete and Earned Progress Entry Method options at the activity level is the same as the default options at the schedule sheet level.

**Select The Calculation Method For % Complete**

You can select an option that allows you to enter progress information for a key quantity (referred to as the Leader) of an activity which will determine the overall progress of other resources and the activity itself. For example:

- **Example 1**: Assume that there are two resources on an activity, called Resource 1 and Resource 2. If the key quantity is Resource 1 and you enter progress (say 30%) on Resource 1, then Resource 2 should also progress with same 30%. Also, overall activity progress should progress by 30%.
- **Example 2**: Assume that the key quantity (Leader) in this example is Activity % Complete. If you enter progress of 50% on the activity, Resource 1 and Resource 2 are updated with the same progress of 50%.

The key quantity is referred to as the Leader in Primavera Unifier.
To select the % complete calculation method for activities at the schedule sheet level

1 Open a schedule sheet.

2 Choose File > Budget and Progress Setup > Schedule Sheet.

3 Under the Default % Complete Calculation Method section, choose an option. This option will apply to all activities in the schedule sheet, unless it is overridden by the selection of a different option for an individual activity.

**Note:** Company holidays based on company calendar should be considered while distributing budget. Budget should not be distributed on days that are marked as holidays on company calendar.

<table>
<thead>
<tr>
<th>Use this Calculation Method</th>
<th>To do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual activity % complete and resource % complete</td>
<td>Enter the progress of activity and resource independent of each other. Entering Activity % Complete will not update resource progress and entering resource % complete will not update Activity % Complete.</td>
</tr>
<tr>
<td>Manual activity % complete - updates resource % complete</td>
<td>Enter the progress of an activity, and resource % complete will be updated automatically. If this option is selected, Activity % Complete will become the key quantity or Leader, which will control the progress of the entire activity, including resources.</td>
</tr>
<tr>
<td>Resource updates Activity - weighted average of resource costs</td>
<td>Enter progress for each resource independently. Activity % Complete is read-only and will be automatically calculated based on weighted resource cost. The following formula is used to calculate this value: [ \frac{\text{Sum of } [\text{Resource Progress Quantity} \div \text{Resource Quantity}] \times (\text{Resource Amount})}{\text{Sum of } (\text{Resource Amount})} \times 100 ] All resources are considered in this calculation, including hard booked resources.</td>
</tr>
<tr>
<td>Resource updates Activity - weighted avg. of resource hours</td>
<td>Enter progress for each resource independently. Activity % Complete will be read-only and will be automatically calculated based on weighted resource man hours. The following formula is used to calculate this value: [ \frac{\text{Sum of } [\text{Resource Progress Quantity} \div \text{Resource Quantity}] \times (\text{Resource Amount})}{\text{Sum of } (\text{Resource Quantity})} \times 100 ] The only resources considered in this calculation are hard booked resources.</td>
</tr>
</tbody>
</table>

**Note:** Progress entry for Resource and Activity before importing Resource Assignment Attribute form is based on Activity % Complete and Resource % Complete. After the Resource Assignment Attribute form is imported, progress on activity will be Activity % Complete, but for Resource it is Progress Quantity the data element. Resource % Complete is then read-only and always calculated.
To select the % complete calculation method for activities at the activity level

1. Open a schedule sheet.

2. Choose File > Budget and Progress Setup > Activity.

3. Under the % Complete Calculation Method section, choose an option. This option will apply specifically to the selected activity, and will override any default entry method set up at the schedule sheet level. The behavior of these % Complete Calculation Method options at the activity level is the same as the default options at the schedule sheet level. The exception is Lead resource updates Activity and other resources, described in the next step.

4. Under the activity level, you can select Lead resource updates Activity and other resources, and choose resources (including hard booked) that are assigned to the activity on the Resource tab. This option allows you to select a resource as a key quantity or a Leader. If you select this option and a resource from the drop down menu, then you can enter progress on only that resource. Activity % Complete and Resource % Complete on all other resources are read-only and will be automatically calculated based on the progress entered on key quantity or leader resource.

For example:

Assume that there is an activity with Resource 1 and Resource 2, with the Activity % Complete at 0%:

<table>
<thead>
<tr>
<th>Resource</th>
<th>Work Hours</th>
<th>% Complete</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource 1</td>
<td>200</td>
<td>0</td>
</tr>
<tr>
<td>Resource 2</td>
<td>500</td>
<td>0 (read-only)</td>
</tr>
</tbody>
</table>

For a further example, assume that Resource 1 is the key quantity or Leader, with the Activity % Complete at 30%:

<table>
<thead>
<tr>
<th>Resource</th>
<th>Work Hours</th>
<th>% Complete</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource 1</td>
<td>200</td>
<td>30</td>
</tr>
<tr>
<td>Resource 2</td>
<td>500</td>
<td>30 (read-only)</td>
</tr>
</tbody>
</table>

You can change the Lead resource updates Activity and other resources drop down menu selection until there is progress or earned progress entries for the activity or resource. After progress or earned progress data is entered, the Budget and Progress Method Setup for the activity is disabled and you cannot delete the resource selected as Leader. If you find that you must change the settings for the activity, you must delete the activity and start over with new data and settings.

Select The Calculation Method For % Earned

Earned progress is a quantitative measurement to indicate how much has been earned on an activity over its duration. Earned progress can be represented by amount, quantity and a percentage value.
Earned progress is based on the progress entered on an activity. Activities can earn progress in when progress is entered, or by % of activity budget, when the activity is started and earn remaining the remaining percentage when that activity completes.

Primavera Unifier allows you to accumulate and calculate earned progress for an activity as well as resources assigned to an activity:

- Earned Progress is calculated at activity level and each resource assigned to that activity.
- Earned Progress calculated under a schedule sheet for activity and assigned resources is used later in the Earned Value module (in the Cost Manager) to calculate Budgeted Cost of Work Performed (BCWP).
- Earned Progress calculated at the activity level is used when BCWP needs to be represented by the cost.
- Earned Progress calculated at resource assignment level is used when BCWP is represented by a unit of measure (for example, Hours).

To select the % earned calculation method for activities at the schedule sheet level

1 Open a schedule sheet.
2 Choose File > Budget and Progress Setup > Schedule Sheet.
3 Under the Default % Earned Calculation Method section, choose an option. This option will apply to all activities in the schedule sheet, unless it is overridden by the selection of a different option for an individual activity.

<table>
<thead>
<tr>
<th>Use this Calculation Method</th>
<th>To do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual activity % earned and resource % earned</td>
<td>Enter earned progress of activity and resource independent of each other. Entering Activity earned progress will not update resource earned progress and entering resource earned progress will not update activity earned progress.</td>
</tr>
<tr>
<td>Manual activity % earned - updates resource % earned</td>
<td>You can select this option only if Manual activity % earned and resource % earned is selected. Allows you to enter earned progress of an activity and resource earned progress will be updated automatically.</td>
</tr>
<tr>
<td>Resource updates Activity - weighted average of resource costs</td>
<td>Enter earned progress for each resource independently. Activity earned progress will be read-only and will be automatically calculated based on weighted resource cost. Following formula will be used. (Sum of Resource Cost * Resource Earned Progress / Total Activity Work Hours) * 100 All resources will be considered in this calculation including hard booked resources.</td>
</tr>
</tbody>
</table>
## Use this Calculation Method

<table>
<thead>
<tr>
<th>Use this Calculation Method</th>
<th>To do this:</th>
</tr>
</thead>
</table>
| Update Activity and all resources on activity start and finish % earned on Actual Start and Actual Finish | Allow the system to calculate earned progress based on actual start and finish of the activity  
• % earned on Actual Start: This option will allow user to enter % that should be earned on start of the activity. User can enter a value  
• % earned on Actual Finish: This is a read-only field. Should always be calculated based on % earned on Actual Start. Value for this field should be (100 - % earned on Actual Start). |
| If you select this option, earned progress is calculated based on Update Activity and all resources on activity start and finish of the activity. Primavera Unifier will automatically calculate earned progress for activity and assigned resources when actual start and finish dates are entered. |

---

## To select the % earned calculation method for activities at the activity level

1. Open a schedule sheet.
2. Choose File > Budget and Progress Setup > Activity.
3. Under the % Earned Calculation Method section, choose an option. This option will apply specifically to the selected activity, and will override any default entry method set up at the schedule sheet level. The behavior of these % Earned Calculation Method options at the activity level is the same as the default options at the schedule sheet level. The exception is Lead resource updates Activity and other resources, described in the next step.

4. Under the activity level, you can select Lead resource updates Activity and other resources, and choose resources (including hard booked) that are assigned to the activity on the Resource tab. This option allows you to select a resource as a key quantity or a Leader. If you select this option and a resource from the drop down menu, then you can enter progress on only that resource.

For example:

Assume that there is an activity with Resource 1 and Resource 2, with the Earned Progress at 0%:

<table>
<thead>
<tr>
<th>Resource</th>
<th>Work Hours</th>
<th>% Complete</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource 1</td>
<td>200</td>
<td>0</td>
</tr>
<tr>
<td>Resource 2</td>
<td>500</td>
<td>0 (read-only)</td>
</tr>
</tbody>
</table>

For a further example, assume that Resource 1 is the key quantity or Leader, with the Earned Progress at 30%:

<table>
<thead>
<tr>
<th>Resource</th>
<th>Work Hours</th>
<th>% Complete</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource 1</td>
<td>200</td>
<td>30</td>
</tr>
<tr>
<td>Resource 2</td>
<td>500</td>
<td>30 (read-only)</td>
</tr>
</tbody>
</table>
You can change the Lead resource updates Activity and other resources drop down menu selection until there is progress or earned progress entries for the activity or resource. After progress or earned progress data is entered, the Budget and Progress Method Setup for the activity is disabled and you cannot delete the resource selected as Leader. If you find that you must change the settings for the activity, you must delete the activity and start over with new data and settings.

Select WBS Codes Filtered By Workpackage (schedule Sheet Level Only)

An activity in a schedule sheet can be associated with one or more WBS Codes. This assignment is used to create a mapping between costs associated with an activity to a Cost Code (WBS Code). Primavera Unifier allows you to choose a workpackage to use to filter the WBS codes you can select in the Activity Properties, WBS Codes tab. You can choose one workpackage to use as a filter.

Note: The Workpackage must be active and contain WBS codes, and also transactions must have occurred using the pertinent WBS codes, or the WBS codes tab will not contain codes for you to select.

To filter WBS codes by workpackage

1. Open a schedule sheet.
2. Choose File > Budget and Progress Setup > Schedule Sheet.
3. Under the Additional Options section, in the Workpackage field, click Select.

Workpackage selection

Lock The Reporting And Progress Entry Period (schedule Sheet Level Only)

You can prevent users from entering or modifying progress data entries made prior to the current week or the current month. These selections allow you to control the activity and resource data entered on the Activity Progress window. See "Entering Progress in the Activity Progress Window" on page 776 for details.

To specify a restriction on data entry or reporting for progress data

1. Open a schedule sheet.
2. Choose File > Budget and Progress Setup > Schedule Sheet.
3. Under the Additional Options section, in the Reporting Period field, select Week or Month. If there is an activity calendar specified, that calendar affects the reporting period for these options.
4 Check the **Do not allow progress entry older than current period** checkbox. This checkbox works in conjunction with Reporting Period that you select. If you select Week as the reporting period then users cannot enter or modify progress entered prior to current week; if you select Month as the reporting period then users cannot enter or modify progress entered prior to current month.

5 In addition, you can select **Allow editing of last period progress** and specify a number of working days into the current period. Selecting this option allows users to modify progress of the last period (based on the reporting period) until a specified number of days into the current period.

6 Click **OK**.

### Entering Progress Data On The General And Resource Tabs Of Activity Properties

The Resource Assignment Attribute form (when imported, replaces the Resources tab of the Activity Properties and provides data elements to other areas) contains fields related to resources assigned to an activity to that allow you to enter effort and expense information related to that effort. The Resource Assignment Attribute form allows you to assign a resource to a Resource Type, rather than to a hard booked resource. Also, it allows the capture of progress with respect to effort, and the base lining of resource assignment.

The Schedule Attribute form is used as the General tab of the Activity Properties can also include fields that allow you to enter progress and earned progress data.

The ability to enter progress and earned progress on the Schedule Attribute and the Resource Assignment Attribute forms is based on the options selected on the Budget and Progress Setup for a given activity. See "Setting Up the Budget and Progress Method" on page 764. Fields on the forms are editable or read-only and calculated based on the option settings.

This progress or earned progress is time stamped when entered:

- For an activity:
  - Date on which the progress or earned progress is entered or calculated.
  - Activity % Complete value
  - Earned Progress value

- For a resource:
  - Date on which the progress quantity and or earned progress is entered or calculated
  - Progress Quantity value
  - Earned Progress value

You can access time stamped information through the Activity Progress Log or the Resource Progress Log. See "Using the Activity Progress and Resource Progress Logs" on page 780 for details on the logs.

The calculations used to derive progress and earned progress are explained in See "Progress and Earned Progress Calculations" on page 782.
To enter data into the attribute forms

1. Navigate to a schedule sheet.

2. Click an activity name.

3. On the General tab, you can enter progress or earned progress data in these fields, depending on settings on the Budget and Progress Setup window, and if the data elements for these fields have been added to the Schedule Attribute form and that form has been imported:
   - Earned Progress
   - Earned Amount
   - Forecast 1 Start
   - Forecast 1 Finish
   - Activity Percent 1

4. On the Resource tab, you can enter progress or earned progress data in these fields, depending on settings on the Budget and Progress Setup window, and if the data elements for these fields have been added to the Resource Assignment Attribute form and that form has been imported. The fields you see may vary:
   - Resource Name
   - Role Name (Picker)
   - Resource Type
   - Quantity (Qty)
   - UOM
   - Amount
   - % Units
   - Earned Progress
   - Earned Amount
   - ETC
   - ETC Amount
   - Resource % 1

   **Note:** You can double-click the resource name to view the Resource Assignment Attribute form in view-only mode.

5. Click Add.

6. Enter resource data as needed.

7. Click OK.

Entering Progress In The Activity Progress Window

The Activity Progress window allows users to quickly modify the daily activity and resource progress data for a selected activity. Users can move down the rows of activities with the Activity Progress window open and quickly modify the progress for each activity without having to open the activity.

**Note:** The Activity Progress window is available only if the Resource Assignment Attribute form is designed and imported into Primavera Unifier.
You can access the Activity Progress Log and the Resource Progress Log from the Activity Progress window. The logs display the progress data that is entered over time, and allow the user to view and modify the progress data for activities and resources. See "Using the Activity Progress and Resource Progress Logs" on page 780 for details.

**Note:** If you enter partial activity progress data, for example enter Activity Progress for a day, but do not enter the Resource Progress (or enter Resource Progress and do not enter Activity Progress at that time), and then save the data, you cannot enter the Resource Progress later that day. You can however, enter the progress the next day.

**To view or enter activity progress on the Activity Progress window**

1. Navigate to a schedule sheet.
2. Highlight an activity name.
3. Click the **Progress** button. The Activity Progress window opens on the right side.

The Activity Progress and Resource Progress fields are editable or read-only depending on settings on the Budget and Progress Method setup window.
### In this field:

**Activity progress as of**  
Select a date for which you want to enter progress data. Today’s date shows by default. This date is used as the time stamp for progress data entered on this window. If you choose a date that conflicts with the date restriction you have set up on the Budget and Progress Method Setup under Additional Options (See "Lock the reporting and progress entry period (schedule sheet level only)" on page 774 for details) you will receive a warning message.

If you have select the Reporting Period:
- **Week**: You cannot select a date prior to current week. Weeks are counted as Sunday to Saturday. For example, if today is Monday, June 22, you cannot select a date prior to Sunday, June 21.
- **Month**: You cannot select a date prior to current month. For example if the current month is June 2009, you cannot select a month prior to June 2009.

You can select a date in the future if it is in the current period. You cannot select a date which is designated as a company holiday on company calendar.

### Activity Progress - latest activity progress information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Progress Log button</td>
<td>Click to access the Activity Progress Log. See &quot;Using the Activity Progress and Resource Progress Logs&quot; on page 780 for details. This log displays all activity progress entries made by user.</td>
</tr>
<tr>
<td>Activity Percent Complete</td>
<td>Enter or view activity progress data. This field is read-only or editable based on settings in Budget and Progress Method setup window for the activity. Unless you enter a value, the latest previously-entered value is retained in this field.</td>
</tr>
<tr>
<td>Earned Progress</td>
<td>Enter or view activity progress data. This field is read-only or editable based on settings in Budget and Progress Method setup window for the activity. Unless you enter a value, the latest previously-entered value is retained in this field.</td>
</tr>
</tbody>
</table>
| Latest Progress as of                     | View the date on which Primavera Unifier last calculated activity progress.  
This field corresponds with Primavera Current Data Date. Primavera Unifier honors Current Data Date on schedule sheets imported from Primavera. |
| Latest % Complete                          | View the latest activity % complete.                                          |
| Latest Earned Progress                     | View the latest earned progress of the activity.                             |

### Resource Progress - latest resource progress information

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Progress Log button</td>
<td>Click to access the Resource Progress Log. See &quot;Using the Activity Progress and Resource Progress Logs&quot; on page 780 for details. This log displays all resource progress entries made by user.</td>
</tr>
<tr>
<td>Leader Column</td>
<td>View an icon to indicate the leader selected on the Budget and Progress Method Setup window.</td>
</tr>
<tr>
<td>Resource Name</td>
<td>View the name of the resource. This column will show Resource Name for each resource from resource assignment form.</td>
</tr>
<tr>
<td>Quantity</td>
<td>View the quantity for each resource from the Resource Assignment Attribute form.</td>
</tr>
<tr>
<td>Progress Quantity</td>
<td>Enter progress quantity. Unless you enter a value, the latest previously-entered value is retained in this field.</td>
</tr>
</tbody>
</table>
In this field: | Do this:  
---|---
Earned Progress | View the earned quantity of each resource, which is associated with the Earned Progress on Resource Assignment Attribute form. Unless you enter a value, the latest previously-entered value is retained in this field.
UOM | View the unit of measure for each resource from the Resource Assignment Attribute form.
Resource Latest Progress | Latest progress information for each resource. Select a resource listed under Resource Progress to see the latest progress for each resource.
Resource Name | View the name of the selected resource.
Progress as of | View the latest progress entry date of the resource.
Progress Quantity | View the latest progress quantity entered.
Earned Progress | View the latest earned quantity of the resource.
UOM | View the unit of measure for the resource.

4 Click **Save**.

**To view or enter activity progress on the Activity Progress window for a summary activity**

1 Navigate to a schedule sheet.
2 Highlight a summary activity name.
3 Click the **Progress** button. The Activity Progress window opens on the right side.

| In this field: | Do this:  
---|---
Activity % Complete | View the activity percent complete for the activities.
Latest Progress as of | View the latest progress entry date across all leaf activities under the selected summary activity.
Earned Progress | View the latest earned quantity of the activities.

4 Click **Save**.
Export And Import Activity Progress Data

You can export and import Activity Progress using CSV files. This CSV export and import functionality is available only if the Resource Assignment Attribute form has been imported.

To export Activity Progress data

You can export Activity Progress data to a CSV file with latest activity and resource information. The CSV will only contain leaf level activities. This is an example of an exported Activity Progress CSV file:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Note</td>
<td>2</td>
<td>Columns with “f” cannot be modified</td>
<td>3</td>
<td>Progress as of</td>
<td>4</td>
<td>9/07/2009</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>R</td>
<td>Al</td>
<td>Activity ID</td>
<td>Activity Name</td>
<td>Leader</td>
<td>Activity % Complete</td>
<td>Earned Progress</td>
<td>Latest Progress as of</td>
<td>Latest % Completed</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>Activity 1</td>
<td>R</td>
<td>Miners</td>
<td>1</td>
<td>100.00</td>
<td>30.00</td>
<td>30.00</td>
<td>100.00</td>
</tr>
<tr>
<td>7</td>
<td>R</td>
<td>Al</td>
<td>Activity 2</td>
<td>R</td>
<td>Miners</td>
<td>1</td>
<td>100.00</td>
<td>30.00</td>
<td>30.00</td>
</tr>
<tr>
<td>8</td>
<td>A</td>
<td>Al</td>
<td>Activity 3</td>
<td>R</td>
<td>Miners</td>
<td>1</td>
<td>100.00</td>
<td>30.00</td>
<td>30.00</td>
</tr>
</tbody>
</table>

Example of Activity Progress CSV file

In the example, notice that the first column is named Progress as of! This date is used as a timestamp on the progress information. There are two headers in this example file:

Notice that there is a Leader! Column. This column identifies which row is a leader for an activity. This is based on Budget and Progress setup profile option of an activity. If the activity is updating all resources then the activity shows Yes in the Leader column. If a resource is updated all other resources then the resource shows Yes in the Leader column. For all other options, the Leader column will be empty.

1. In a schedule sheet, choose File > Export > Activity Progress Template.
2. Modify the CSV file as needed to add activity progress data.
3. Save the CSV file and import.

To import Activity Progress data

1. In a schedule sheet, choose File > Import > Activity Progress.
2. Browse to select the CSV file to import.
3. Click OK.

Using The Activity Progress And Resource Progress Logs

After entering activity or resource progress data, the user can view or modify the data by going to an Activity Progress Log or Resource Progress Log. These logs are accessible only from the Activity Progress window. From these logs, the user can view progress effective date, progress quantity and earned quantity. The user can also modify the progress and earned quantity data, for the most recent entry and for entries in the past, depending on the settings for the editing of period progress on the Budget Progress and Method Setup window. See "To specify a restriction on data entry or reporting for progress data" on page 774 for details.

For example, you might want to use this log to modify data if you need to change past progress data based on actual start of data calculation, which saves you from having to delete the activity and loose all of the data associated with that activity.
To view or modify progress data from the Activity Progress or Resource Progress logs

1. Navigate to a schedule sheet.
2. Highlight a summary activity name.
3. Click the Progress button. The Activity Progress window opens on the right side.
4. Click the Activity Progress Log button or Resource Progress Log button.
5. Modify progress data as needed. Select the row you want to modify and double click the cell that needs to modify. The Progress Quantity or Earned Progress columns can be editable depending on settings on Budget and Progress Method Setup window for the activity.
6. Click Save.
PROGRESS AND EARNED PROGRESS CALCULATIONS

**Note:**  The calculations described in this section pertain to the progress and earned progress data accumulation and calculation discussed in See "Project Progress Data Accumulation and Calculation" on page 763. If you do not need to work with progress or earned progress data to ultimately calculate Earned Value, you do not need to read this section.

This section explains calculations involved in calculating progress and earned progress at activity and resource level based on different options selected on Budget and Progress Method setup window. The data elements on the Schedule Attribute and Resource Assignment Attribute forms are considered and affected by the progress and earned progress calculations are:

- **Activity**
  - Total Cost
  - Activity % Complete
  - Earned Progress
  - Earned Amount (Value of this data element is always based on Primavera uDesigner Design)
- **Resource**
  - Role
  - Quantity
  - Rate
  - Amount
  - Resource % Complete (Value of this data element is calculated as (Progress Quantity / Quantity) %
  - Progress Quantity
  - Earned Quantity
  - Earned Amount (Value of this data element is always based on Primavera uDesigner Design)

The calculations are described in terms of the calculation options in relation to the % Complete and Earned Progress entry method selected:

- See "Independently Control % complete and Earned quantity" on page 782
- See "Activity and resource % complete updates % earned" on page 795
- See "Activity and resource % earned updates % complete" on page 799
- See "Do not allow update of % complete and % earned" on page 803

See "Select the entry method for the % complete and earned progress" on page 768 for details on these methods.

**Independently Control % Complete And Earned Quantity**

This section contains scenarios for calculations based on the entry method Independently Control % complete and earned quantity and the % Complete Calculation Method option selected.
**Method Is Manual Activity % Complete And Resource % Complete**

This section contains scenarios based on the option selected for % Complete Calculation Method being Manual activity % complete and resource % complete.

**% Earned Calculation Method option is Manual activity % earned and resource % earned**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Manual activity % complete and resource % complete
- % Earned Calculation Method option = Manual activity % earned and resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
<tr>
<td>Resource</td>
<td>Progress Quantity</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>

**% Earned Calculation Method option is Manual activity % earned - updates resource % earned**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Manual activity % complete and resource % complete
- % Earned Calculation Method option = Manual activity % earned - updates resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
<tr>
<td>Resource</td>
<td>Progress Quantity</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only) <em>(Activity-level Earned Progress * Quantity)</em></td>
</tr>
</tbody>
</table>
If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Manual activity % complete and resource % complete
- % Earned Calculation Method option = Resource updates Activity - weighted average of resource costs

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (Weighted Cost) and read-only.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Sum of [(Resource Earned Progress / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount)) * 100</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Progress Quantity</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Manual activity % complete and resource % complete
- % Earned Calculation Method option = Update Activity and all resources on activity start and finish

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (Weighted Cost) and read-only.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Sum of [(Resource Earned Progress / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount)) * 100</td>
</tr>
</tbody>
</table>
### Method Is Manual Activity % Complete - Updates Resource % Complete

This section contains scenarios based on the option selected for % Complete Calculation Method being **Manual activity % complete - updates resource % complete**.

#### % Earned Calculation Method option is Manual activity % earned and resource % earned

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Manual activity % complete - updates resource % complete
- % Earned Calculation Method option = Manual activity % earned and resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
<tr>
<td>Resource</td>
<td>Progress Quantity</td>
<td>Calculated (read-only). (Activity-level Activity % Complete * Quantity)</td>
</tr>
</tbody>
</table>

For example: If % earned on Actual Start = 5% and % earned on Actual Finish = 95% then, when Actual Start is entered, Earned Progress = 5% * Quantity.

When Actual Finish is entered, Earned Progress = 100% * Quantity.
### Activity or Resource Data Element Data Entry Method

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Earned Progress</td>
<td>Manual entry</td>
<td></td>
</tr>
</tbody>
</table>

**% Earned Calculation Method option is Manual activity % earned - updates resource % earned**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Manual activity % complete - updates resource % complete
- % Earned Calculation Method option = Manual activity % earned - updates resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
<tr>
<td>Resource</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Progress Quantity</td>
<td>Calculated (read-only). (Activity-level Activity % Complete * Quantity)</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only). (Activity-level Earned Progress * Quantity)</td>
</tr>
</tbody>
</table>

**% Earned Calculation Method option is Resource updates Activity - weighted average of resource costs**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Manual activity % complete - updates resource % complete
- % Earned Calculation Method option = Resource updates Activity - weighted average of resource costs

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Activity or Resource</td>
<td>Data Element</td>
<td>Data Entry Method</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------</td>
<td>--------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (Weighted Cost)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Sum of [(Resource Earned Progress / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount) ) * 100</td>
</tr>
<tr>
<td>Resource</td>
<td>Progress Quantity</td>
<td>Calculated (read-only).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Activity-level Activity % Complete * Quantity)</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual Entry</td>
</tr>
</tbody>
</table>

% Earned Calculation Method option is Lead resource updates Activity and other resources

This combination of settings is not available.

% Earned Calculation Method option is Update Activity and all resources on activity start and finish

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Manual activity % complete - updates resource % complete
- % Earned Calculation Method option = Update Activity and all resources on activity start and finish

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (Weighted Cost)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Sum of [(Resource Earned Progress / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount) ) * 100</td>
</tr>
<tr>
<td>Resource</td>
<td>Progress Quantity</td>
<td>Calculated (read-only).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Activity-level Activity % Complete * Quantity)</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated based Update Activity and all resources on activity start and finish.</td>
</tr>
</tbody>
</table>
Activity or Resource | Data Element | Data Entry Method
--- | --- | ---

For example: If % earned on Actual Start = 5% and % earned on Actual Finish = 95% then, when Actual Start is entered, Earned Progress = 5% * Quantity
When Actual Finish is entered, Earned Progress = 100% * Quantity.

Method Is Resource Updates Activity - Weighted Avg. Of Resource Hours

This section contains scenarios based on the option selected for % Complete Calculation Method being Resource updates Activity - weighted avg. of resource hours.

% Earned Calculation Method option is Manual activity % earned and resource % earned

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource hours
- % Earned Calculation Method option = Manual activity % earned and resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
</table>
| Activity             | Activity % Complete | Calculated (Weighted Hours) and (read-only).
|                      |                   | {Sum of [ (Resource Progress Quantity / Resource Quantity) * (Resource Quantity)] / Sum of (Resource Quantity) } * 100
|                      |                   | Only hard booked resources will be considered. |
|                      | Earned Progress   | Manual entry       |

| Resource             | Progress Quantity | Manual entry       |
|                      | Earned Progress   | Manual entry       |

% Earned Calculation Method option is Manual Activity % earned - updates resource % earned

If the entry method and option settings on the Budget and Progress Method Setup window are:
• % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
• % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource hours
• % Earned Calculation Method option = Manual activity % earned - updates resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
</table>
| Activity             | Activity % Complete| Calculated (Weighted Hours) and (read-only). \[
(Sum of \[(\text{Resource Progress Quantity} / \text{Resource Quantity}) \times \text{Resource Quantity}\]) / \text{Sum of (Resource Quantity)} \] \times 100 \[
Only hard booked resources will be considered.\] |
|                      | Earned Progress    | Manual entry                                                                      |

| Resource             | Progress Quantity  | Manual entry                                                                      |
|                      | Earned Progress    | Calculated (Activity-level Earned Progress \times Quantity)                      |

% Earned Calculation Method option is Resource updates Activity - weighted avg. of resource costs

If the entry method and option settings on the Budget and Progress Method Setup window are:

• % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
• % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource hours
• % Earned Calculation Method option = Resource updates Activity - weighted avg. of resource costs

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
</table>
|                      | Activity % Complete| Calculated (Weighted Hours) and (read-only). \[
(Sum of \[(\text{Resource Progress Quantity} / \text{Resource Quantity}) \times \text{Resource Quantity}\]) / \text{Sum of (Resource Quantity)} \] \times 100 \[
Only hard booked resources will be considered.\] |
### Earned Progress Manual entry

**Calculated (Weighted Cost)**

\[
\frac{\text{Sum of } \left( \frac{\text{Resource Earned Progress}}{\text{Resource Quantity}} \right) \times \text{Resource Amount}}{\text{Sum of Resource Amount}} \times 100
\]

**Resource**

<table>
<thead>
<tr>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>

### Earned Progress Manual entry

**Calculated (Weighted Cost)**

\[
\frac{\text{Sum of } \left( \frac{\text{Resource Earned Progress}}{\text{Resource Quantity}} \right) \times \text{Resource Amount}}{\text{Sum of Resource Amount}} \times 100
\]

**Resource**

<table>
<thead>
<tr>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>

## Earned Calculation Method option is Lead resource updates Activity and other resources

This combination of settings is not available.

## Earned Calculation Method option is Update Activity and all resources on activity start and finish

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource hours
- % Earned Calculation Method option = Update Activity and all resources on activity start and finish

then this data entry method scenario results:

### Earned Progress Manual entry

**Calculated (Weighted Cost)**

\[
\frac{\text{Sum of } \left( \frac{\text{Resource Earned Progress}}{\text{Resource Quantity}} \right) \times \text{Resource Amount}}{\text{Sum of Resource Amount}} \times 100
\]

**Resource**

<table>
<thead>
<tr>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>
Activity or Resource | Data Element | Data Entry Method
--- | --- | ---
 | Earned Progress | Calculated based Update Activity and all resources on activity start and finish. For example: If % earned on Actual Start = 5% and % earned on Actual Finish = 95 % then, When Actual Start is entered, Earned Progress = 5% * Quantity When Actual Finish is entered, Earned Progress = 100% * Quantity.

**Method Is Resource Updates Activity - Weighted Avg. Of Resource Costs**

This section contains scenarios based on the option selected for % Complete Calculation Method being Resource updates Activity - weighted avg. of resource costs.

% Earned Calculation Method option is Manual activity % earned and resource % earned

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource costs
- % Earned Calculation Method option = Manual activity % earned and resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
</table>
| Activity | Activity % Complete | Calculated (Weighted Hours) and read-only. 
\{(Sum of [(Resource Progress Quantity / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount)) \* 100\} * 100 
All resources will be considered. |
| | Earned Progress | Manual entry |
| Resource | Progress Quantity | Manual entry |
| | Earned Progress | Manual entry |
If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource costs
- % Earned Calculation Method option = Manual activity % earned - updates resource % earned

then this data entry method scenario results:

### Activity or Resource Data Element Data Entry Method

| Activity | Activity % Complete | Calculated (Weighted Hours) and read-only. {Sum of \[(Resource Progress Quantity / Resource Quantity) * (Resource Amount)\] / Sum of (Resource Amount)} * 100
All booked resources will be considered. |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Earned Progress</td>
<td>Manual entry</td>
<td></td>
</tr>
</tbody>
</table>

### Resource

<table>
<thead>
<tr>
<th>Resource</th>
<th>Progress Quantity</th>
<th>Manual entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Earned Progress</td>
<td>Calculated (Activity-level Earned Progress * Quantity)</td>
<td></td>
</tr>
</tbody>
</table>

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource costs
- % Earned Calculation Method option = Resource updates Activity - weighted avg. of resource costs

then this data entry method scenario results:

### Activity or Resource Data Element Data Entry Method

<table>
<thead>
<tr>
<th>Activity</th>
<th>Activity % Complete</th>
<th>Calculated (Weighted Hours) and read-only. {Sum of [(Resource Progress Quantity / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount)} * 100</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity or Resource</td>
<td>Data Element</td>
<td>Data Entry Method</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
|                      | Earned Progress   | Calculated (Weighted Cost). \[
|                      |                   | \left \{ \frac{\text{Sum of } \left[ \frac{\text{Resource Earned Progress}}{\text{Resource Quantity}} \times \text{Resource Amount} \right]}{\text{Sum of Resource Amount}} \right \} \times 100 \] All resources will be considered. |
|                      | Resource          |                                                                                   |
|                      | Progress Quantity | Manual entry                                                                       |
|                      | Earned Progress   | Manual entry                                                                       |

% Earned Calculation Method option is Lead resource updates Activity and other resources

This combination of settings is not available.

% Earned Calculation Method option is Update Activity and all resources on activity start and finish

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource costs
- % Earned Calculation Method option = Update Activity and all resource on activity start and finish

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
</table>
|                      | Activity % Complete| Calculated (Weighted Hours) and read-only. \[
|                      |                   | \left \{ \frac{\text{Sum of } \left[ \frac{\text{Resource Progress Quantity}}{\text{Resource Quantity}} \times \text{Resource Amount} \right]}{\text{Sum of Resource Amount}} \right \} \times 100 \] All resources will be considered. |
|                      | Earned Progress   | Calculated (read-only) based Update Activity and all resources on activity start and finish. For example: If % earned on Actual Start = 5% and % earned on Actual Finish = 95% then, When Actual Start is entered, Earned Progress = 5% |
### Method Is Lead Resource Updates Activity And Other Resources

This section contains scenarios based on the option selected for % Complete Calculation Method being **Lead resource updates Activity and other resources**. There is only one data entry scenario for this setting.

#### % Earned Calculation Method option is Lead resource updates Activity and other resources

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Independently Control % complete and earned quantity
- % Complete Calculation Method option = Lead resources updates Activity and other resources.
- % Earned Calculation Method option = Lead resource updates Activity and other resources

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Calculated (Weighted Hours) and read-only.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>{ \text{Sum of } \left[ \left( \frac{\text{Resource Progress Quantity}}{\text{Resource Quantity}} \right) \times \left( \frac{\text{Resource Amount}}{\text{Resource Amount}} \right) \right] } / \text{Sum of (Resource Amount)} } \times 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>All resources will be considered.</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (Weighted Cost) and read-only.</td>
</tr>
</tbody>
</table>
### Activity or Resource Data Element Data Entry Method

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>

**Activity And Resource % Complete Updates % Earned**

This section contains scenarios for calculations based on the entry method *Activity and Resource % Complete Updates % Earned* and the *% Complete Calculation Method* option selected.

**Method Is Manual Activity % Complete And Resource % Complete**

This section contains scenarios based on the option selected for *% Complete Calculation Method* being *Manual activity % complete and resource % complete*. There is only one data entry scenario for this setting.

**% Earned Calculation Method options are not available**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % complete updates % earned
- % Complete Calculation Method option = Manual activity % complete and resource % complete
- % Earned Calculation Method option = Not available

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>
Method Is Manual Activity % Complete - Updates Resource % Complete

This section contains scenarios based on the option selected for % Complete Calculation Method being Manual activity % complete - updates resource % complete. There is only one data entry scenario for this setting.

% Earned Calculation Method options are not available

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % complete updates % earned
- % Complete Calculation Method option = Manual activity % complete - updates resource % complete
- % Earned Calculation Method option = Not available

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only) Same as Activity % Complete</td>
</tr>
<tr>
<td></td>
<td>Resource</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Progress Quantity</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only) Same as Progress Quantity</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Activity % Complete</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only) Same as Activity % Complete</td>
</tr>
<tr>
<td></td>
<td>Resource</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Progress Quantity</td>
<td>Calculated (read-only) (Activity-level Activity % Complete * Quantity)</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only) Same as Progress Quantity</td>
</tr>
</tbody>
</table>
**Method Is Resource Updates Activity - Weighted Avg. Of Resource Hours**

This section contains scenarios based on the option selected for % Complete Calculation Method being **Resource updates Activity - weighted avg. of resource hours**. There is only one data entry scenario for this setting.

**% Earned Calculation Method options are not available**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % complete updates % earned
- % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource hours
- % Earned Calculation Method option = Not available

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
</table>
| Activity             | Activity % Complete | Calculated (Weighted Hours) and read-only.  
{Sum of [(Resource Progress Quantity / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount) } * 100  
Only hard booked resources will be considered |
| Earned Progress      | Calculated (read-only)  
Same as Activity % Complete |

<table>
<thead>
<tr>
<th>Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Progress Quantity</td>
<td>Manual entry</td>
<td></td>
</tr>
</tbody>
</table>
| Earned Progress      | Calculated (read-only)  
Same as Progress Quantity |

**Method Is Resource Updates Activity - Weighted Avg. Of Resource Costs**

This section contains scenarios based on the option selected for % Complete Calculation Method being **Resource updates Activity - weighted avg. of resource costs**. There is only one data entry scenario for this setting.

**% Earned Calculation Method options are not available**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % complete updates % earned
- % Complete Calculation Method option = Resource updates Activity - weighted avg. of resource costs
- % Earned Calculation Method option = Not available
then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Calculated (Weighted Hours) and read-only.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>{Sum of [ (Resource Progress Quantity / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount) } * 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>All resources will be considered</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Same as Activity % Complete</td>
</tr>
<tr>
<td>Resource</td>
<td>Progress Quantity</td>
<td>Manual entry</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Same as Progress Quantity</td>
</tr>
</tbody>
</table>

**Method Is Lead Resource Updates Activity And Other Resources**

This section contains scenarios based on the option selected for % Complete Calculation Method being Lead resource updates Activity and other resources. There is only one data entry scenario for this setting.

**% Earned Calculation Method option is Lead resource updates Activity and other resources**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % complete updates % earned
- % Complete Calculation Method option = Lead resource updates Activity and other resources
- % Earned Calculation Method option = Lead resource updates Activity and other resources

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Calculated (Weighted Hours) and read-only.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>{Sum of [ (Resource Progress Quantity / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount) } * 100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>All resources will be considered</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only)</td>
</tr>
</tbody>
</table>
### Activity or Resource % Earned Updates % Complete

This section contains scenarios for calculations based on the entry method **Activity % Earned and Resource % Earned Updates % Complete** and the % Earned Calculation Method option selected.

#### Method Is Manual Activity % Earned And Resource % Earned

This section contains scenarios based on the option selected for % Earned Calculation Method being **Manual activity % earned and resource % earned**. There is only one data entry scenario for this setting.

*% Complete Calculation Method options are not available*

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % earned updates % complete
- % Complete Calculation Method option = Not available
- % Earned Calculation Method option = Manual activity % earned and resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Activity % Complete</td>
<td>Calculated (read-only)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Same as Earned Progress</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
<tr>
<td>Resource</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Progress Quantity</td>
<td>Calculated (read-only)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Same as Earned Progress</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>
Method Is Manual Activity % Earned - Updates Resource % Earned

This section contains scenarios based on the option selected for % Earned Calculation Method being Manual activity % earned - updates resource % earned. There is only one data entry scenario for this setting.

% Complete Calculation Method options are not available

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % earned updates % complete
- % Complete Calculation Method option = Not available
- % Earned Calculation Method option = Manual activity % earned - updates resource % earned

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Calculated (read-only)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Same as Earned Progress</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
<tr>
<td>Resource</td>
<td>Progress Quantity</td>
<td>Calculated (read-only)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Same as Earned Progress</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(Activity-level Earned Progress * Quantity)</td>
</tr>
</tbody>
</table>

Method Is Resource Updates Activity - Weighted Avg. Of Resource Costs

This section contains scenarios based on the option selected for % Earned Calculation Method being Resource updates Activity - weighted avg. of resource costs. There is only one data entry scenario for this setting.

% Complete Calculation Method options are not available

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % earned updates % complete
- % Complete Calculation Method option = Not available
- % Earned Calculation Method option = Resource updates Activity - weighted avg. of resource costs

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Method Is Lead Resource Updates Activity And Other Resources

This section contains scenarios based on the option selected for % Earned Calculation Method being **Lead resource updates Activity and other resources**. There is only one data entry scenario for this setting.

**% Complete Calculation Method options are not available**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % earned updates % complete
- % Complete Calculation Method option = Not available
- % Earned Calculation Method option = Lead resource updates Activity and other resources

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Activity</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Activity % Complete</td>
<td>Calculated (read-only) Same as Earned Progress</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (Weighted Hours) and read-only. {Sum of [(Resource Earned Progress / Resource Quantity) * (Resource Amount)] / Sum of (Resource Amount)} * 100  All resources will be considered</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resource</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Progress Quantity</td>
<td>Calculated (read-only) Same as Earned Progress</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Manual entry</td>
</tr>
</tbody>
</table>
### Activity or Resource

<table>
<thead>
<tr>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Progress Quantity</td>
<td>Calculated (read-only) Same as Earned Progress</td>
</tr>
<tr>
<td>Earned Progress</td>
<td>Manual Entry (Only resource that is selected under dropdown). For all other resources, Earned Progress will be calculated based on (Leader Earned Progress / Leader Quantity) * Resource Quantity</td>
</tr>
</tbody>
</table>

**Method Is Update Activity And All Resources On Start And Finish**

This section contains scenarios based on the option selected for % Earned Calculation Method being **Update Activity and all resources on activity start and finish**. There is only one data entry scenario for this setting.

**% Complete Calculation Method options are not available**

If the entry method and option settings on the Budget and Progress Method Setup window are:

- % Complete and Earned Progress entry method = Activity and resource % earned updates % complete
- % Complete Calculation Method option = Not available
- % Earned Calculation Method option = Update Activity and all resources on activity start and finish

then this data entry method scenario results:

<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Activity % Complete</td>
<td>Calculated (read-only) Same as Earned Progress</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read-only) based Update Activity and all resources on activity start and finish. For example: If % earned on Actual Start = 5% and % earned on Actual Finish = 95 % then, When Actual Start is entered, Earned Progress = 5% When Actual Finish is entered, Earned Progress = 100%</td>
</tr>
</tbody>
</table>

Resource
<table>
<thead>
<tr>
<th>Activity or Resource</th>
<th>Data Element</th>
<th>Data Entry Method</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Progress Quantity</td>
<td>Calculated (read-only)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Same as Earned Progress</td>
</tr>
<tr>
<td></td>
<td>Earned Progress</td>
<td>Calculated (read Only) based Update Activity and all resources on activity start and finish. For example: If % earned on Actual Start = 5% and % earned on Actual Finish = 95% then, When Actual Start is entered, Earned Progress = 5% * Quantity When Actual Finish is entered, Earned Progress = 100% * Quantity.</td>
</tr>
</tbody>
</table>

**Do Not Allow Update Of % Complete And % Earned**

When the *Do not allow update of % complete and % earned* entry method is selected, these fields are disabled.

- Activity
  - Activity % Complete
  - Earned Progress
- Resource
  - Resource % Complete
  - Progress Quantity
  - Earned Quantity
**User-defined Report Types**

You can create and run user-defined reports of the following types:

**Tabular:** This is the basic report format, arranging information vertically in columns. Tabular reports are a way to present related information for multiple records on the same page.

**Cross tab:** Cross tab reports allow the display of data on two axes. Cross tab reports enable users to run time-series reports defined by two data sources, for example, payments made per quarter per vendor.

**Summary:** Summary reports can be run to display summary data that can be used on project/shell, program and company Summary views.

**Alert:** Project/Shell-level alert reports are used to set up and customize the generation of system alerts, based on a project/shell trigger that you specify. For example, you can have alerts let you know when your remaining budget is getting low. Alerts are set up and customized by users for their own use using alert reports.

**User-defined Report Data Types**

After choosing the report type (Tabular, Cross tab, Summary or Alert), you choose a data type. This determines the type of data that will be displayed on the report.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Project UDR</th>
<th>Shell UDR</th>
<th>Program UDR</th>
<th>Company UDR</th>
<th>UDR Template</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accounts Sheet</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Active Task Information</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Asset Summary Sheet</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Audit</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Commitment Summary</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Company Cash Flow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Company Cost</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Company User Information</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Cost Sheet - WBS</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Cost Transactions -WBS</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Cost Transactions MC - WBS</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Views</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Document Manager</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Data Type</td>
<td>Project UDR</td>
<td>Shell UDR</td>
<td>Program UDR</td>
<td>Company UDR</td>
<td>UDR Template</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>-------------</td>
<td>-----------</td>
<td>-------------</td>
<td>-------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Document Manager—Company</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Equipment</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Funding</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Gates</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Inventory</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Inventory On-hand Detail</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Item Master</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Job Plan</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Master PM Book</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Master PM Meter Schedule</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Master PM Time Schedule</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Material Transaction</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Partner User Information</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PM Book</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PM Meter Schedule</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>PM Time Schedule</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Program Cash flow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Program Cost</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Program Schedule</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Resource Booking</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Resource Manager—All Actuals</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Resource Manager—Allocated Roles</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Resource Manager—Booked Resources</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Resource Manager—Project Actuals</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Resource Manager - Resources (Company)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Resource Manager—Roles</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Resource Manager—Sheets</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Service Center</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Service Request</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Schedule of Values</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Shell or Project Cash Flow</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Shell or Project Cash Flow (Basic)</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
</tbody>
</table>
Working With Custom Reports

If your company has custom project, shell, or program reports developed through Oracle Business Intelligence Publisher, they will be available in the Custom Reports node.

To run a custom project, shell, or program report

1. Open the project, shell, or program.

2. In the Navigator, click Reports > Custom. The Reports log shows the list of available custom reports, if applicable.

3. Select a report from the list and click Open. The Report Viewer opens.

4. Select a project or shell from the list and click Report to generate the report.

5. Click Close to close the viewer.
ACCESS USER-DEFINED REPORTS

To access user-defined project/shell reports
In the Navigator, open a project or shell and select Reports > User-Defined. The User Defined Reports log opens.

To access user-defined program reports
In the Navigator, open a program and select Reports > User-Defined.

To access user-defined company reports
In the Navigator, navigate to Company Workspace tab > Company > Reports.

Running A User-defined Report
Running a user-defined report consists of the following:

- Define query parameters if applicable
- Review/choose projects or shells to include if applicable
- Add runtime notes if applicable
- Choose the report format (HTML, CSV, Excel, PDF, XML)
- Run the report

The following describes how to run project, shell, program and company-level user-defined reports.

**Note:** User-defined reports created with data view data types require the data view to be in “published” status. If the data view was changed to “draft” status, the report will not run, and you will see an alert.

To run a user-defined report

1. Open the shell, project, program, or company workspace.
3. Select a report in the log and click the Open button. The User-Defined Report window opens.
4. Complete the tabs as described in the following sections:
   - **Query tab:** This tab allows the entry of query parameters as defined during creation and set up. For example, you can set up a report to list all leases that expire within 10 days of today. You can also choose to accept the default query parameters, if any.
   - **Projects/Shells tab:** The Projects/Shells tab appears for program-level and company-level UDRs and shows all projects and shells with a status of Active, On-Hold, or View-Only. Use this tab to specify which project or shell the report should be saved in.
   - **Notes tab:** You can enter report notes that will be included only on the current report results to be generated, and will not be saved or generated in any subsequent report results. To enter notes, the data element runtime notes must be present in the report layout (Edit Report window, Layout tab).
• Shells tab: The Shells tab appears for shell-level reports only. On this tab, you can choose to exclude inactive shells in the report run.

5 Click Run to generate the user-defined report.

When the report is generated, you will be prompted to open or save the file. Click Open to view the file. PDF files will open in Acrobat Reader, from which you can save the file to your local drive by clicking File > Save. XML files will open in a pop-up browser window. Or click Save to save the file to your local drive.

Add query parameters (Query tab)

This tab will vary for each report. In the example below, the work order creation date was used for the query parameters. If the report has been set up to enter query parameters, you may enter query information, which will give report results based on records that match the parameters you entered, or you can run a report on all records by leaving the field blank.

Example

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Zone</td>
<td>For information purposes, the Query tab displays the time zone that is used for date fields in the report. The default time zone for a report is set up when the report is designed. It can reflect your user time zone, as defined in your user preferences, or it can be fixed to a particular time zone, such as the project location or company headquarters.</td>
</tr>
<tr>
<td>Report Format</td>
<td>Choose the format in which the report should appear: HTML, PDF, CSV, Excel, or XML. HTML Displays the report in the standard format in a browser window. You may print a copy of the report from the browser window. (Click the File menu and select Print or Print Preview.) CSV Formats the report in an exportable CSV format, usually in Microsoft Excel or another application you have set up for this format. You will be prompted to save the file or open it. Excel Displays the report in Microsoft Excel format in the browser window. You can save an Excel formatted copy of the report or print from the window. (Click the File menu and select Save As or Print.) PDF Opens Adobe Acrobat Reader and displays the report in PDF format. You can save a copy of the report and/or print it from the PDF window. (Click the File menu and select Save or Print.) XML Generates the output in XML format. Before the results are generated, a confirmation window will open, giving you the option to save the XML file to your local machine (click Save), or display the results in a pop-up browser window (click Open).</td>
</tr>
</tbody>
</table>
In this field: \n| Do this: |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Save Report Location</td>
<td>If you want to save the report, choose the location it should be saved in. \n<strong>Save results in Primavera Unifier</strong> This checkbox becomes active if you select PDF or XML. Selecting this checkbox will save a copy of the PDF or XML report within Primavera Unifier and make it available for retrieval. \n<strong>Note:</strong> Scheduled report runs can be saved and retrieved in PDF or XML formats and sent to the report owner or to the owner and other users and groups. These are chosen in the Schedule tab of the Edit Report window. \n<strong>Document Manager</strong> saves the report in the Document Manager of Primavera Unifier. If you choose this option, you need to specify a name for the report (<strong>Save As</strong>) and which folder of the Document Manager it should be saved in (<strong>Location</strong>).</td>
</tr>
</tbody>
</table>

**Select project or shell (Projects/Shells tab)**

The Projects/Shells tab appears for program-level and company-level UDRs and shows all projects and shells with a status of Active, On-Hold, or View-Only. Use this tab to specify which project or shell the report should be saved in.

**Example**

![Projects/Shells tab screenshot](image-url)

Depending on how the report was set up (specifically, if “Allow users to modify value(s) during execution” was enabled in the creation step), you may add or remove projects or shells from the list as needed. You also have the option of selecting to display the list in the report.

**Note:** For information on the Report Format section of the window, see the instructions under “Add query parameters (Query tab).”

**Add runtime notes (Notes tab)**

The text entered in the Report Notes field will be included only on the current report results to be generated, and will not be saved or generated in any subsequent report results.
Report notes can be added if the data element **Runtime Notes** is added to the report layout (Layout tab, Edit Report window).

Example

![Image of report format window]

**Note:** For information on the Report Format section of the window, see the instructions under “Add query parameters (Query tab).

**Select shells (Shells tab)**

The Shells tab appears in shell-level UDRs for cross-shell reports. This tab allows you to retrieve data across shells and sub-shells. On this tab, you can choose to exclude inactive shells in the report run.

The selection of shells is determined when the UDR is created. You cannot modify the fields on this tab unless the Shells field says “User Defined.” The non-modifiable options that you will see in the Shells field are:

- Current Shell and Sub-shells
- Current Shell only
- Sub-shells only
- User Defined (which allows the selection of a user determined combination of shells).

If the **Allow user to modify User-defined list during execution checkbox** was selected when the UDR was created, you can modify the list of User Defined shells at run time of the report by using the Add and Remove buttons. You can only add the shells in which you are a member user.

Example
Retrieve scheduled report results

1. Navigate to the project-level, shell-level, program-level, or company-level User-Defined Reports log.
2. Select a report from the log and click the Saved Results button. The Saved Results window opens.
3. Select a saved result and click Open.
   You will be prompted to open or save the results file.
4. Click Open to view the file. PDF files will open in Acrobat Reader, from which you can save the file to your local drive by clicking File > Save. XML files will open in a pop-up browser window. Or click Save to save the file to your local drive.

Note: For information on the Report Format section of the window, see the instructions under "Add query parameters (Query tab).
To delete saved report results

1. Navigate to the project-level, shell-level, program-level, or company-level User-Defined Reports log.

2. Select a report from the log and click the Saved Results button. The Saved Results window opens.

3. Select a saved result and click Delete. Click Yes to confirm.

User-defined Report Formats

You can choose the format of user-defined report results. The report format options are available at the bottom of the User-defined Report window at runtime.

The report format options are:

- **HTML**: Displays the report in the standard format in a browser window. You may print a copy of the report from the browser window. (Click the File menu and select Print or Print Preview.)
- **CSV**: Formats the report in an exportable CSV format, usually in Microsoft Excel or another application you have set up for this format. You will be prompted to save the file or open it.
- **Excel**: The report displays in Microsoft Excel format in the browser window. You can save an Excel formatted copy of the report or print from the window. (Click the File menu and select Save As or Print.)
- **PDF**: Opens Adobe Acrobat Reader and displays the report in PDF format. You can save a copy of the report and/or print it from the PDF window. (Click the File menu and select Save or Print.)
- **XML**: Generates the output in XML format. Before the results are generated, a confirmation window will open, giving you the option to save the XML file to your local machine (click Save), or display the results in a pop-up browser window (click Open).
- **Save results in Primavera Unifier**: This checkbox becomes active if PDF or XML is selected. Selecting this checkbox will save a copy of the PDF or XML report within Primavera Unifier and make it available for retrieval.
Note: Scheduled report runs can be saved and retrieved in PDF or XML formats and sent to the report owner or to the owner and other users and groups. These are chosen in the Schedule tab of the Edit Report window.

Save And Retrieve Scheduled Report Results

Report owners can schedule user-defined reports to run automatically and save the results within Primavera Unifier as PDF or XML files. If you have run permission for a report, you can view or print any saved results. Report owners can delete saved results from a scheduled report run.

You can save report results and query parameters on reports that you run manually (ad hoc). This option is available only when the report is being generated in PDF or XML format. This is available at runtime for project-level, shell-level, program-level and company-level user defined reports.

Note: The default time zone for a report is set up when the report is designed. It can reflect the time zone of the person running the report, as defined in user preferences, or it can be fixed to a particular time zone, such as the project location or company headquarters. If the “user’s time zone” option was selected in the set up of this report, the time zone reflected on the scheduled report results will that of the report owner.

To save report results

1. Navigate to the project-level, shell-level, program-level, or company-level User-Defined Reports log.
2. Select a report from the log and click Open. The User-defined Report window opens. The window displays results that have been saved from manual (ad hoc) report runs as well as scheduled report runs.
3. In the Report Format portion at the bottom of the window, choose PDF or XML.
4. Select the Save Results in Primavera Unifier checkbox. This saves a copy of the report results within Primavera Unifier.
5. Click Run to run the report. This may take a few moments.
6. When the report is generated, you will be prompted to open or save the file. Click Open to view the file. PDF files will open in Acrobat Reader, from which you can save the file to your local drive by clicking File > Save. XML files will open in a pop-up browser window. Or click Save to save the file to your local drive.
To retrieve saved report results

1. Navigate to the project-level, shell-level, program-level, or company-level User-Defined Reports log.
2. Select a report from the log and click the **Saved Results** button. The Saved Results window opens.
3. Select a saved result and click **Open**.
4. You will be prompted to open or save the results file. Click **Open** to view the file. PDF files will open in Acrobat Reader, from which you can save the file to your local drive by clicking **File > Save**. XML files will open in a pop-up browser window. Or click **Save** to save the file to your local drive.

![Retrieve saved UDR results](image)

To delete saved report results

1. Navigate to the project-level, shell-level, program-level, or company-level User-Defined Reports log.
2. Select a report from the log and click the **Saved Results** button. The Saved Results window opens.
3. Select a saved result and click **Delete**. Click **Yes** to confirm.

**Print Report Results**

After running a report, you can print a copy. Depending on the report format you chose, the report results will be displayed in a browser window (HTML, XML), Adobe Acrobat Reader (PDF), Excel (Excel, CSV), or other application displaying CSV format. The printing functionality will depend on the format of the report.

To print report results

1. Run a user-defined report.
2. For most formats, you can click the **File** menu and choose **Print**. For HTML and XML, you may need to right-click in the browser pop-up window and choose **Print**. Additional printing functionality may be available depending upon the report format.
Mark Reports In Primavera Unifier For Mobile Access

Within Primavera Unifier, you can select which reports you want to view and add them to your mobile device. Look at the Mobile column to see which reports can be accessed.

**Note:** If the Group by option is set on reports (i.e.: Group by user name), you won't be able to mark these reports as mobile. Reports marked as mobile cannot contain groupings of data results.

To add reports to a mobile list

1. In User Mode, navigate to Company Workspace > Reports > User-Defined reports.
2. Select a report and click the Mobile button on the toolbar menu. The mobile icon displays in the Mobile column of the report log.

This will be the report list you will see when you connect to Primavera Unifier using your mobile device.

To remove reports from the mobile list

1. Open Primavera Unifier > User Mode.
2. Go to Company Workspace > Reports > User-Defined reports.
3. Select a report and click the Remove Mobile button on the toolbar menu. The report is no longer marked as mobile and the word “Mobile” is no longer next to the report in the Mobile column.

**View Report, Project, Shell, And Record Details**

You can view the details of the report, such as last sync date and time. You can also open a report and see additional information related to the report, such as project or shell and record details.

To view report details

1. After launching Primavera Unifier Mobile, the main screen displays reports.
2. Select a report.
Click **Open > Details** from the menu. A screen displays where you can see additional information regarding the report. Only the first two columns of the report are displayed.

**To view a project or shell list for a report**

You can scroll through the list of projects or shells displayed on the screen, and select a record from the list and view the details of it by clicking on **Open** from the menu.

**To view record details**

1. Open a report and select a record.
2. Click **Open**. Details of the record displays.
3. The name of the report displays at the top. You can scroll down and see the complete list of details of the record.
4. Return to the report project or shell list by clicking **esc** or an equivalent control on the mobile device.
To view a complete detail of a column

Search For And Run Reports On A Mobile Device

You can find specific reports by name and then run them.

To search and run reports

1. Go to the main menu of the mobile device. The following screen shows the list of available reports that are marked as mobile.

   Mobile List

   - Approved Base Contracts
   - Task Information
   - Task Information

2. Click Search.
3 Enter search criteria.

4 Click the **Run Report** option from the menu.

5 The report displays as shown in following screen.

6 To cancel the search option, select **Cancel** from the menu. You can clear fields by clicking on **Clear Fields** or enter special characters by selecting **Show Symbol** option.
To change options

1. From the Search screen, click **-Sel-** next to the option to change. You can change values such as status, quantity, amount, etc. For example if you want to change the status of a report to pending, select **-Sel-** next to Status.

2. Select **Change Option** from the menu. The options display. In the example below, the Status options are displayed.

   Select a new option, for example, change the status to pending.

   Verify that the option has been changed by opening the report and selecting the option. In the example below, the status has been changed to pending.

3. You can also change criteria for numeric information in the search screen, such as for quantity, unit cost, or amount. For example, to change quantity, click **-Sel-** next to Quantity in the Search by column.

4. Click **Change Option**, and then select an option (in this example, select “less than or equal to”).
Enter a value (for example, 100).

Verify that the quantity has changed and displays 100.00.

**Sync Reports**

You can sync existing reports on your mobile device with your latest Primavera Unifier reports and then download new reports.
To sync reports

1. Select the **Show Mobile List** option from the menu on the main screen. The list of available reports (marked Mobile) is displayed.

2. Select one or more reports to synchronize by highlighting and pushing the wheel.

3. Select the **Sync** label and push the wheel to download the latest reports from Primavera Unifier. The device connects to Primavera Unifier to download the latest information from the reports.

The connecting screen displays a please wait message. Once reports are synced up, a confirmation message displays.

Once sync is done, the main screen displays where you can access the latest information from the reports. The Last Sync column displays when a report is synced up and reflects the latest information.

The following screen shows the synchronized report with the last sync date.
Select **Details** to view the synchronization details of a report.

**Note:** If you select a report that already exists on the device, it will be updated with the latest information. If you select a report that already exists on the device but the name of the report is modified on the Primavera Unifier side, the current report details will be downloaded to the device and the report on the device will be updated with the current name. If you select a report that does not exist on the device, the report details will be downloaded to the device.

**Delete Reports From A Mobile Device**

**To delete a report from a mobile device**

1. Select the report you want to remove.
2. Click **Delete** from the menu list. A confirmation message displays. Select **Yes**.
GETTING STARTED WITH PRIMAVERA UNIFIER FOR MOBILE

If your company’s employees are often out of the office, Primavera Unifier can keep the workflow moving by taking advantage of mobile devices with browser capabilities.

On mobile devices, Primavera Unifier provides a simple interface where users can perform tasks such as navigating logs, accepting work orders, creating or updating business processes (including line items), managing assets, viewing project and shell details, and accessing tasks, messages, and uMails.

For example, Primavera Unifier users in facilities management could acknowledge work, perform the work, and report its completion back to headquarters using their SmartPhones. For company technicians who use mobile devices in the field to locate data for specific assets and pieces of equipment they are working on or tracking, Primavera Unifier for mobile can supply asset data, such as work order details, condition assessments, or work order histories. Executives or partners may want to use Primavera Unifier for mobile for faster approvals or collaboration.

**Note:** These instructions assume that you are familiar with using Primavera Unifier from an Internet Explorer browser. If you need further information about any of the features described here (e.g., working with business processes, assets, shells, uMail, etc.), see the appropriate sections in the online help.

Primavera Unifier For Mobile Requirements

- Smart mobile phone or similar mobile device. Must be able to access the web using a mobile browser. Plain text is not supported. No special application needs to be installed for this solution.
- In order to access Primavera Unifier, your mobile browser must be able to accept cookies. If you are having trouble logging into Primavera Unifier for mobile, try enabling cookies on your device. The procedure for enabling cookies may be different for your specific device; following are some examples:
  - If your device uses a Safari browser (e.g., an iPhone®), navigate to Settings>Safari>Accept Cookies, then choose From Visited or Always.
  - For Microsoft IE mobile browsers, open the browser, then select Menu > Tools > Options > Privacy and Security > Enable Cookies.
- To view business process records, assets and shells on a mobile device, they must first be enabled and set up for mobile use in Primavera uDesigner. See the Primavera uDesigner User Guide for details. No other special setup is required.

By default, uMail, standard project details and the standard project user directory are accessible on Primavera Unifier for mobile without special setup. You can also view Tasks and Messages logs, but the records will not be accessible without enabling the business processes first in Primavera uDesigner.

What You Can Do On Primavera Unifier For Mobile

With Primavera Unifier for mobile, you can perform many common Primavera Unifier tasks. The following features are supported on Primavera Unifier for mobile:

**Bookmarks**

- Add bookmarks to your mobile version of Primavera Unifier, for easier navigation
• These bookmarks are separate from the bookmarks you may have in standard Primavera Unifier

**Tasks and Messages**

• Access your tasks logs to view all of your business process tasks
• View tasks and messages
• Accept and complete tasks, and move the record forward in the workflow

**Business Process Logs**

• Create and send new business process records, or edit existing records
• Add and manage line items using the detail form (the line item grid view is not supported)
• Workflow and non-workflow, single and multi-record business processes are supported

**uMail**

• Create new uMail messages
• View or reply to uMail that you receive
• Access your uMail at the company, project or shell level

**Asset Manager**

• View asset logs and records
• Create new asset records, or edit existing records
• Assets are displayed in a flat navigation
• Asset sheets are not available on a mobile device

**Projects, Shells and the Company Workspace**

• View project and shell logs
• Open a project, shell or the company workspace to access their respective business process logs, uMail, Tasks and Messages, the company Asset Manager, and other mobile-supported information
• View project/shell details
• Access the project/shell user directory
• Shells are displayed in a flat navigation

---

**Note:** Refer to See “What is supported” on page 825 for details about what is supported for the features listed above

**What Is Supported**

• All supported features are in User Mode; Administration Mode features are not available.
• Only those business processes, assets or shells enabled for mobile access will appear in the logs when accessed through Primavera Unifier for mobile.
• In order to view business process records, assets or shells on your mobile device, the business process, asset class, or shell type must first be enabled and set up for mobile access. This is done in Primavera uDesigner. See the Primavera uDesigner User Guide for details.
• If you are completing a form with a BP Picker, Asset Picker or Shell Picker, all business processes, assets and shells will be selectable on that picker, regardless of whether they are mobile enabled - you just won’t be able to view the records themselves through Primavera Unifier for mobile. In shell pickers, shells are grouped by each main shell tab (single-instance shell), with all of its child shells displayed in a flat list.
• Most business process types are supported, with the following exceptions:
  • Lease
  • Resource booking
  • Timesheets
  • Document type
  • RFB
  • Project/Shell Creator
  • Payment applications are supported, although the default line item grid view is not available. Payment application information must be entered one line item at a time.
• Some picker elements are not currently supported for mobile use. If they are present on a form, they will be read-only when the form is viewed on a mobile device. These elements are:
  • Activity picker
  • Image picker (displays the image file name)
  • Level picker
  • Location picker
  • Planning item picker
  • Program picker
  • Resource picker
  • Role picker
  • Sys Date Datascource picker
  • Sys Date Logical Datascource picker
  • Week picker
• User-defined Reports (UDRs) are not available through the mobile interface.

Logging Into Primavera Unifier From A Mobile Device

Your Primavera Unifier environment is available for your mobile device as long as you have access to the internet and a web-enabled mobile browser. To use Primavera Unifier for mobile, you log into the mobile version of Primavera Unifier. To do this, simply add a “/m” at the end of your normal Primavera Unifier web address.

For example: https://ues.skire.com/m

To log into Primavera Unifier for mobile

1. Be sure your mobile device has web access.

2. In your mobile web browser, enter the URL you normally use to access Primavera Unifier, followed by /m (for example: https://ues.skire.com/m). The mobile login screen opens.

3. Log into Primavera Unifier as you normally would: enter your Primavera Unifier user name and password, choose your company from the pull-down if applicable, and click the Login button. The Home page opens.

Depending on your mobile device, you may also be able to select a checkbox to remember your user name and password on the device (see example below.)
Navigating Primavera Unifier On A Mobile Device

Primavera Unifier for mobile devices provides a simplified Primavera Unifier user interface to help you quickly perform common tasks or access the information you need.

The mobile version of Primavera Unifier is a simplified version of the Primavera Unifier interface. There is no left navigator, and no popup windows. A limited number of User Mode features are accessible through the mobile device. Administration Mode features are not available.

Home page

Listed below is a summary of the Primavera Unifier User Mode features that you might access on your mobile device. This list shows the default names of supported nodes; depending on your company’s Primavera Unifier configuration, naming conventions, and your permission levels, the links you see may differ, and will reflect the labels you normally see on your Primavera Unifier navigation nodes.

- **Tasks**: all tasks are listed; if the business process has been enabled for mobile use, the task will display as a clickable link
- **Messages**: displays the contents of your Messages log
- **uMail Inbox**: corresponds to your uMail inbox
- **Company Workspace**: corresponds to the user mode Company Workspace
- **Projects**: this will display the name used for standard projects
- **Shell(s)**: any tab or tabs used for configurable shells will be listed
- **Bookmarks**: if you have created bookmarks on your mobile device, they will be listed here; any bookmarks you may have created in standard Primavera Unifier do not automatically display here

Links

At the bottom of each page are easy-to-navigate links.

If you are at your home page, the links are:

- **Manage Bookmarks**: allows you to reorder, remove or change the name of your bookmarks (you can add bookmarks from any open log or navigation page)
- **Logout**: click this link to log out of Primavera Unifier mobile

If you are at any page other than your home page, the links are:

- **Back**: this link will return you to the last page that you visited. Use this link, rather than any Back button or link that your device may have.
- **Home**: click this link to return to your home page
- **Logout**: click this link to log out of Primavera Unifier mobile

Buttons

Most allowable functions for a feature are available by buttons that usually appear at the bottom of the screen. For example, on log screens, the Add Bookmark button is available, which you can click to bookmark the page.

---

**Note**: If you are having trouble logging into Primavera Unifier for mobile, you can try enabling cookies on your mobile browser. See "Primavera Unifier for Mobile Requirements" on page 824
About logs on a mobile device

Business process, asset class and shell logs are designed in Primavera uDesigner. The information that appears in the log columns is determined by how it has been designed in Primavera uDesigner. For ease of use, the mobile version of these logs may display a subset of the total number of log fields that are displayed in standard Primavera Unifier.

About Entering Information On A Form On A Mobile Device

When you open a business process form, asset form, or the shell details on a mobile device, the fields will display in a flat list. The form fields function much the same way as they do in the standard Primavera Unifier interface. For example, you can select or deselect checkboxes and radio buttons, click a pull-down menu to choose an option, and type information directly into text fields.

As in standard Primavera Unifier, some fields such as pickers and multi-select fields have a Select button. For pickers, when you click Select, a picker window opens. Each option includes a link; click the link to select the entry. For multi-select entries, click the Select button, then select the checkboxes next to your entry choices and click Ok. The choices that you are presented with in these pickers are the same as when accessed through standard Primavera Unifier.

Because Primavera Unifier for mobile devices uses plain HTML that allows it to display on virtually any mobile browser, there are some dynamic features that will not work the same way as they do in standard Primavera Unifier. If you have a dynamic data set on a business process, the pulldown menus associated with it will not dynamically filter the display lists. This means that fields that are part of dynamic data sets will display all options on all fields. Upon saving or submitting a form, validation is run to ensure that the combination you choose is valid. If not, an error will display, and you can choose different values for the fields. (For example, if your dynamic data set filters out cities based on a previously selected state, then even after selecting the state, the city list will include all cities in the system, regardless of state. Upon saving or sending the form, the system will validate your selections to make sure that the city and state combination you chose is valid.)

Formula fields will not refresh automatically. When formula fields are present on a form, a Refresh button is available. Click the Refresh button to refresh the field if you have changed other fields that may affect its value.

Some pickers are not mobile-supported and will display as read-only.
As with standard Primavera Unifier, you can access your projects, shells and the company workspace in Primavera Unifier for mobile. These nodes house company, project, and shell-level tasks, business processes, uMail messages. The company space also houses the asset manager. You can also view project and shell details and team members when you open a project or shell.

Business processes, asset classes and shell types must be enabled for mobile access in order to access them on a mobile device. By default, all standard projects are mobile accessible.

### Open A Project, Shell Or The Company Workspace

As with standard Primavera Unifier, you can access your projects, shells and the company workspace in Primavera Unifier for mobile. These nodes house company, project, and shell-level tasks, business processes, uMail messages. The company space also houses the asset manager. You can also view project and shell details and team members when you open a project or shell.

Business processes, asset classes and shell types must be enabled for mobile access in order to access them on a mobile device. By default, all standard projects are mobile accessible.

This section summarizes the Primavera Unifier User Mode features that you might access on your mobile device. This includes the default names of all supported nodes; depending on your company’s Primavera Unifier configuration, naming conventions, and your permission levels, the links you see may differ.

### To open the company workspace

1. Log into Primavera Unifier for mobile and navigate to the Home page.
2. Click the **Company Workspace** link. The default links are:
   - Tasks (your Company Workspace Tasks log)
   - Messages (your Company Workspace Messages log)
   - Asset Manager (displays the list of asset classes enabled for mobile use; asset sheets are not accessible)
   - General (BP log for single-record business processes; only those business processes that have been enabled for mobile access will be listed. This is true for all BP logs accessed through mobile, except for Tasks and Messages.)
   - Data Manager (BP logs)
   - Business Processes (company-level BP logs)

### To open a project

1. Log into Primavera Unifier for mobile and navigate to the Home page.
2. Click the **Projects** link. The Projects log lists all projects you have permission to view. The project numbers are clickable links.
3. Click a project number link. The project opens. The default links are:
   - Tasks
   - Messages
   - uMail Inbox
   - Information
To open a shell

1 Log into Primavera Unifier for mobile and navigate to the Home page.

On the Home page, shells are listed by the root shell. (In standard Primavera Unifier, these root shells appear as tabs at the top of the window.) Only shell types that have been enabled for mobile access (on the shell attribute form in Primavera uDesigner) will be listed. This is true of the root shells and their child shells.

2 Click the link of a root shell. The shell log opens. All child shells are listed in the log, in a flat list. The hierarchy of the shells is not displayed. The shell numbers are clickable links.

3 Click a shell number link. The shell opens. The default links are:
   - Tasks
   - Messages
   - uMail Inbox
   - Information
     - Details: Displays information about the shell from the shell details, and includes the fields that have been mobile-enabled for the shell attribute form
     - Directory: Displays the shell team members
   - General (BP log)
   - Data Manager (BP logs)
   - Business Processes (BP logs)

View Project Or Shell Details

You can view details about the project or shell. You can also view the project/shell team member directory from your mobile device.

Project details come from the project properties by default, and are not editable on a mobile device. Shell details come from the shell attribute form; the information that you can view on a mobile device is set up in Primavera uDesigner. If you have edit permissions, you can edit the details here.

To view project details

1 Log into Primavera Unifier for mobile, and open a project.

2 Click the Details link. The project details opens, displaying information entered in the Project Properties in Primavera Unifier. This information is not editable here.

To view or edit shell details

1 Log into Primavera Unifier for mobile and open the shell.

2 Click the Details link. If you have edit permissions for the shell, the details will open as an editable form.

3 Edit the details as necessary and click Ok.
To view the project or shell team directory

1. Log into Primavera Unifier for mobile and open the project or shell.
2. Click the Directory link. The Directory opens, listing team members and contact information.

Working With Business Process Forms On A Mobile Device

The forms you see on a mobile device are a simplified version of the business process records you work with when accessing Primavera Unifier through an Internet Explorer browser. The mobile version of the form may contain all of the fields that you would see on the form when accessed through a regular browser, or, for ease of use, it may be designed to display a subset of the original fields.

Most business process types can be used on a mobile device, with some exceptions. Some picker elements are not currently supported for use on a mobile device, and display as read-only. For supported business process types and pickers, See "What is supported" on page 825.

If you are used to working with standard Primavera Unifier through an Internet Explorer browser, you will notice that the mobile version of Primavera Unifier does not use popup windows. Each screen opens in the main window, so you will move back and forth between screens when entering information such as line items or general comments. The simplified interface makes this easy to get used to.

Create Or Open A Business Process Record On A Mobile Device

To create or open a business process record on a mobile device, the form must be enabled and set up for mobile use in Primavera uDesigner.

To open a business process record in Primavera Unifier mobile

1. Log into Primavera Unifier for mobile.
2. Do one of the following:
   • From the Home page, click Tasks to open your global tasks log, or open a project or shell and then click Tasks to view project/shell level tasks. The Tasks log lists all of your business process tasks, regardless of whether the business process has been enabled for mobile use. Mobile-supported business processes display as links.
   • Open a project, shell or the Company Workspace. Business processes that have been enabled for mobile use will be listed under the Business Processes heading. Click the listed business process to open the log.
3. From one of the business process logs or the Tasks log, click the record number link. The record opens.

To create a new business process record

1. Log into Primavera Unifier for mobile.
2. Open a project, shell or the Company Workspace. Business processes that have been enabled for mobile use will be listed under the Business Processes heading. Click the listed business process to open the log.
3. Click New. The mobile version of the form opens.
4. Complete the form.
Note: See also: See "About entering information on a form on a mobile device" on page 828, See "Add or manage line items on mobile forms" on page 833, See "Add general comments to a mobile BP form" on page 834. If formula fields are present on the form, information entered in other fields that affect the formula will not automatically refresh on the form in mobile view. Click the Refresh button to refresh the field.

5 For non-workflow business processes, click Save or Finish Editing as needed.

6 For workflow business processes, you can move it along in the workflow.
   a Click the Workflow Action dropdown list and select an action.
   b Click Send.
   c If prompted to select users or groups, select the checkbox next to the user or group, and click Send.
   d At the confirmation message, click Ok.

Note: You will not be able to save a Draft copy of a record.

You are returned to the business process log.

Accept And Complete A Task On A Mobile Device

When you access a Tasks log, you will see a list of all of your current tasks. If a business process has been enabled for mobile access, the record number will appear as a clickable link on your device. If the business process has not been enabled for mobile viewing, it will appear on the log, but you will not be able to open it here. In your Tasks logs on a mobile device:
   • New, unopened tasks are displayed in bold font
   • Late tasks are shown in red
   • If the business process is mobile-enabled, the record number will be a link; click the link to open the record
   • If the business process has not been mobile-enabled or is unsupported for mobile access, it will be listed in the Tasks log but cannot be opened from the mobile device

To accept and complete a task

1 Do one of the following:
   • From the Home page, click the Tasks link to open your global tasks log.
   • To view tasks at the company level or for a specific project or shell, click the Company Workspace link, or open a project or shell, then click the Tasks link.
   • You can also open a task from the log for the business process.

2 Click a record number link. The business process view form opens.

3 Scroll down to the bottom of the form and click the Accept Task button. The form now becomes editable, and you can
   • Add or edit information to the upper form
   • Add or manage line items
   • Add a general comment
   • Text type business processes may require input from you or a response. Click the Edit or Response button as needed.
4 When the form is complete, click the **Workflow Action** dropdown list and select an action.

5 Click **Send**.

6 If prompted to select users or groups, select the checkbox next to the user or group, and click **Send**.

7 At the confirmation message, click **Ok**.

---

**Note:** See also: See "About entering information on a form on a mobile device" on page 828, See "Add or manage line items on mobile forms" on page 833, See "Add general comments to a mobile BP form" on page 834. If formula fields are present on the form, information entered in other fields that affect the formula will not automatically refresh on the form in mobile view. Click the Refresh button to refresh the field.

---

**Decline Or Un-accept A Task On A Mobile Device**

The same restrictions apply regarding declining tasks in Primavera Unifier for mobile as in standard Primavera Unifier.

**To decline a task**

1. From the Tasks log, click the business process record link. The form opens.
2. Scroll down to the bottom of the form and click the **Decline Task** button.

**To undo accept task**

1. Open the form or return to the main view of the form.
2. Scroll down the form to the Workflow Action section.
3. Click the **Undo Accept** button. The form returns to a view-only form and remains in your Tasks log.

**Add Or Manage Line Items On Mobile Forms**

In Primavera Unifier for mobile, you can add line items to business process records as you can in standard Primavera Unifier. As with the upper form, the detail form (used to enter the line item information) may be the same as you see in standard Primavera Unifier, or it may be an abbreviated version, depending on how it was set up in Primavera uDesigner. The line item grid view is not available in the mobile version.

Payment application business processes are supported; however, the default line item grid view is not available. Payment application line items can be viewed one at a time from the line item list, like other line item business processes accessed on a mobile device (new line items cannot be added, since payment application line items are generated automatically from the referenced commit and change commits). Information can be added or edited in editable fields.

---

**Note:** If this is a new non-workflow business processes, the record needs to be saved at least once (to create the record in the system) before a line item can be added. Click the Save button to save the record. At the confirmation, click Ok. You will be returned to the record, and the line items button becomes available.
To add a line item on a mobile form

1 In the business process record, scroll down the form to the Line Items section.
2 If this is a new non-workflow business process, first click Save to save the record, then Ok to confirm.
3 Click the button in the Line Items section. The line items list opens, listing any existing line items on the form.

Note: The name of this button will reflect the name of the line item tab on the business process form, which is part of the form design in Primavera uDesigner. If this is a multi-tab business process, there may be additional buttons, each representing a line item tab.

4 Scroll down and click the New button. The detail form opens.
5 Complete the detail form and click Ok.

You can click Cancel to return to the line item list.

The buttons in the Line Items section of a form correspond to line item tabs. Click a button to add a line item in that tab.

To edit a line item

1 In the business process record, scroll down the form to the Line Items section.
2 Click one of the line item tab buttons. The line items list opens, listing any existing line items in that line item tab on the form.
3 To search for a particular line item:
   a Click the Search button.
   b Enter any search criteria in one or more of the search fields and click Search.
   c To start over, click the Clear All button. This returns you to the line item list.
4 Locate the line item to edit and click the link. The detail form opens.
5 Complete the detail form and click Ok.

Add General Comments To A Mobile BP Form

You can add general comments to the record.

Note: If this is a new non-workflow business process, the record needs to be saved at least once (to create the record in the system) before adding a general comment. Click the Save button to save the record. At the confirmation, click Ok. You will be returned to the record, and the General Comment button becomes available.

To add general comments

1 Open the form, or return to the main view of the form.
2 Scroll down to the bottom of the form. Click the General Comments button. Any existing comments will display.
3 Click Add.
Move The Form Along In The Workflow

This procedure is applicable to workflow business processes.

To send the form

1. Open the form and enter or edit the information as needed.
2. Scroll down the form to the Workflow Action field.
3. Click the Workflow Action pull-down and choose the action. This determines which step in the workflow the form will go to next.
4. Click Send.
5. If prompted to select users or groups, select the checkbox next to the user or group, and click Send.
6. At the confirmation message, click Ok. You will return to the business process log.

Adding And Managing Bookmarks On Primavera Unifier For Mobile

You can add a bookmark on any of the logs that you can access on your mobile device: business processes, tasks and messages, assets, shells (each shell type), projects, and uMail Inbox.

After adding bookmarks, you can change their order, rename them, or remove them.

Bookmarks are listed as links on your Home page.

Add A Bookmark In Primavera Unifier For Mobile

To add a bookmark

1. Log into Primavera Unifier for mobile and navigate to the appropriate log.
2. Scroll to the bottom of the page and click the Add Bookmark link. The Bookmark window opens.
3. In the Bookmark Name field, you can accept the default name, or enter a new name.
4. Click Ok. You are returned to the log.

Manage Bookmarks On A Mobile Device

To reorder, rename or remove a bookmark

1. Navigate to the Home page. (From any Primavera Unifier for mobile window, scroll down to the bottom of the screen and click the Home link.)
2. Click the Manage Bookmarks link at the bottom of the screen. The Manage Bookmarks window opens.
3. Do one of the following:
   • To change the order, select one or more bookmarks, then click the Move Up or Move Down button to move up or down the list. This is the display order that appears on the Home page.
   • To rename a bookmark, select it from the list and click the Edit button. Enter the new name and click Ok.
   • To remove a bookmark, select it from the list and click Remove. The bookmark is removed and you are returned to the Home page.
Use A Bookmark

To access and use your bookmarks

1. From any Primavera Unifier for mobile page, scroll to the bottom of the page and click the Home link.

2. Any bookmarks that have been added are listed on the Home page. Click a bookmark link to open that page.

Search For A Record In Primavera Unifier For Mobile

You can search for specific records in any of the logs that you can access on your mobile device: business processes, tasks and messages, assets, shells (for each shell type), projects, and uMail Inbox. For business processes, assets and shells, the Search fields are designed in Primavera uDesigner, and will vary for each type. Projects and uMail use default search fields.

This procedure is applicable for searching for a record in any of the Primavera Unifier for mobile logs: business processes, tasks, messages, assets, shells, projects, uMail.

To search for a record

1. Log into Primavera Unifier for mobile and navigate to the log you want to search.

2. Scroll down the screen and click the Search button. The Search window opens. The fields that you can search by will differ depending on the record type that you are searching for.

3. Enter search criteria into one or more of the fields. For text fields, you can enter a partial entry. Do not use wildcard symbols such as asterisks.

4. Click the Search button. The log now displays the record(s) that meet the search criteria you entered. The log title shows “Filtered by search,” so you know that you are viewing only those items you have searched for.

To return to the regular log view and display all records

1. After performing a search, in the “filtered” log, click the Search button again. The Search window opens, displaying the search criteria you have previously entered.

2. Click the Clear All button. This clears the log, and returns you to the log window, which displays all records.

Working With Assets On A Mobile Device

In Primavera Unifier for mobile, working with asset forms is similar to working with business process forms.

Asset sheets and depreciation schedules are not accessible from Primavera Unifier mobile.

To access assets on a mobile device

1. Log into Primavera Unifier on your mobile device.

2. Click the Company Workspace link. The Company Workspace page opens.

3. In the Asset Manager section, asset classes that have been enabled for mobile access will be listed as links.
**Note:** If no asset classes have been mobile-enabled (or if you do not have permission to view assets), then the Asset Manager section will not display.

4 Click the link for the asset class you want to access. The log for that asset class opens, listing all of the available asset records. Assets are listed in a flat list. The asset codes are clickable links.

### Add And Manage Assets On A Mobile Device

#### To add a new asset

1. Log into Primavera Unifier for mobile and navigate to the Asset Manager in the Company Workspace.
2. Click an asset class. The log for that asset class opens.
3. Click **New**. The mobile version of the form opens.
4. Complete the form.
5. Click **Save** or **Finish Editing** as needed.

#### To edit assets on a mobile device

1. Follow the procedure above to find the asset record you want to open.
2. Click the asset code. The asset form opens.
3. Scroll down to the bottom of the window and click the **Edit** button. The record becomes editable. (You must have edit permissions to edit the record.)
4. Edit the record as necessary.
5. If formula fields are present on the form, information entered in other fields that affect the formula will not automatically refresh on the form in mobile view. Click the **Refresh** button to refresh the formula.
6. Click **Save** to save a draft of the form, or Finish Editing if all edits are done on the form.
7. Click **Ok** to confirm.

### Add General Comments To An Asset Record

You can add general comments to the asset record.

**Note:** If this is a new asset, the record needs to be saved at least once (to create the record in the system) before adding a general comment. Click the Save button to save the record. At the confirmation, click Ok. You will be returned to the record, and the General Comment button becomes available.

#### To add general comments

1. Open the form, or return to the main view of the form.
2. Scroll down to the bottom of the form. Click the **General Comments** button. Any existing comments will display.
3. Click **Add**.
4. Enter your comment in the Text field and click **Ok**.
Send And Receive UMail On A Mobile Device

You can send and receive uMail on your mobile device. You will not be able to format messages (e.g., bold, underline, etc.). You can view all uMail messages, or project/shell specific uMail messages.

To create a new uMail message

1. Log into Primavera Unifier and open a project or shell.
2. In the project or shell log, click the **uMails Inbox** link. The uMails log opens, listing any existing uMail messages you have received regarding the project or shell.
3. Click the **New** button. A new uMail message opens.
4. Add recipients to the To, Cc or Bcc fields:
   a. Click the **Add** button next to To, Cc or Bcc.
   b. Select one or more users from the list and click **Ok**.
5. To remove recipients, click the **Del** button and remove the recipients from the list.
6. To send a copy of the message to an external email address, enter the email address in the **External Cc** or **External Bcc** field.
7. Enter a Subject for the message. This displays in the uMails Inbox log.
8. Enter the body of the message in the Message text box.
9. Click **Send** to send the message.

To open a uMail messages

1. Log into Primavera Unifier for mobile and navigate to the Home page.
2. Do one of the following:
   • To view all of your uMail messages, click the **uMails Inbox** link from the Home page.
   • To view uMail messages in a specific project or shell, open the project or shell and then click **uMails Inbox**.

The uMails Inbox log opens. Unread messages are shown in bold.
3. Click a message to open it.

To reply to or forward a uMail message

1. Open the uMail message from one of the uMails Inbox logs.
2. Do one of the following:
   • To reply to the sender of the uMail, click **Reply**.
   • To reply to all of the recipients of the uMail message, click **Reply All**.
   • To forward the message, click **Forward**.
3. Add recipients to the To, Cc or Bcc fields. If you clicked **Reply** or **Reply All**, recipients will be filled in. You can add or remove recipients.
4. You can leave the message Subject as is, or edit it.
5. Enter the body of the message in the Message text box. The original message is shown in the lower portion of the Message box.
6. Click **Send** to send the message.