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Preface 

This Preface introduces the guides and other information sources available to help 

you more effectively use Oracle Fusion Applications. 

Disclaimer 

The information contained in this document is intended to outline our general 

product direction and is for informational sharing purposes only, and should be 

considered in your capacity as a customer advisory board member or pursuant to 

your beta trial agreement only. It is not a commitment to deliver any material, code, 

or functionality, and should not be relied upon in making purchasing decisions. The 

development, release, and timing of any features or functionality described in this 

document remains at the sole discretion of Oracle. This document in any form, 

software or printed matter, contains proprietary information that is the exclusive 

property of Oracle. Your access to and use of this confidential material is subject to 

the terms and conditions of your Oracle software license and service agreement, 

which has been executed and with which you agree to comply. This document and 

information contained herein may not be disclosed, copied, reproduced or 

distributed to anyone outside Oracle without prior written consent of Oracle. This 

document is not part of your license agreement nor can it be incorporated into any 

contractual agreement with Oracle or its subsidiaries or affiliates. 

Other Information Sources 

My Oracle Support 

Oracle customers have access to electronic support through My Oracle Support. For 

information, visit http://www.oracle.com/support/contact.html or visit 

http://www.oracle.com/accessibility/support.html if you are hearing impaired. 

Use the My Oracle Support Knowledge Browser to find documents for a product 

area. You can search for release-specific information, such as patches, alerts, white 

papers, and troubleshooting tips. Other services include health checks, guided 

lifecycle advice, and direct contact with industry experts through the My Oracle 

Support Community. 



 

vi Oracle Governance, Risk and Compliance Installation Guide 

Oracle Enterprise Repository 

Oracle Enterprise Repository provides visibility into service-oriented architecture 

assets to help you manage the lifecycle of your software from planning through 

implementation, testing, production, and changes. In Oracle Fusion Applications, 

you can use the Oracle Enterprise Repository for: 

• Technical information about integrating with other applications, including 

services, operations, composites, events, and integration tables. The 

classification scheme shows the scenarios in which you use the assets, and 

includes diagrams, schematics, and links to other technical documentation. 

• Publishing other technical information such as reusable components, policies, 

architecture diagrams, and topology diagrams. 

The Oracle Fusion Applications information is provided as a solution pack that you 

can upload to your own deployment of Oracle Enterprise Repository. You can 

document and govern integration interface assets provided by Oracle with other 

assets in your environment in a common repository. 

Documentation Accessibility 

For information about Oracle’s commitment to accessibility, visit the Oracle 

Accessibility Program website at http://www.oracle.com/us/corporate/accessibility 

/index.html. 

Comments and Suggestions 

Your comments are important to us. We encourage you to send us feedback about 

Oracle Fusion Applications Help and guides. Please send your suggestions to 

oracle_fusion_applications_help_ww@oracle.com. You can use the Send Feedback 

to Oracle link in the footer of Oracle Fusion Applications Help.  
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Introduction 

Oracle Governance, Risk and Compliance (GRC) is a set of products that regulate 

activity in business-management applications. This document provides instructions 

for the installation of the following GRC products: 

• Oracle Enterprise Governance, Risk and Compliance Manager (EGRCM) forms 

a documentary record of a company’s strategy for addressing risk and complying 

with regulatory requirements. 

• Oracle Enterprise Governance, Risk and Compliance Controls (EGRCC) com-

prises two components, each of which enables users to create “models” and “con-

tinuous controls”: 

– In Oracle Enterprise Transaction Controls Governor (ETCG), models and 

controls specify circumstances under which individual transactions display 

evidence of error, fraud, or other risk.  

– In Oracle Application Access Controls Governor (AACG), models and 

controls define conflicts among duties that can be assigned in a company’s 

applications, and identify users who have access to those conflicting duties. 

AACG can also implement “preventive analysis” — it can evaluate controls 

as duties are assigned to users of the company’s applications, preventing them 

from gaining risky access. 

• Oracle Fusion Application Access Controls Governor (FAACG) is a specialized 

installation of EGRCC that applies access models and controls in Oracle Fusion 

Applications.  

• Oracle Fusion GRC Intelligence (GRCI) extracts data from EGRCM and EGRCC 

for display in dashboards and reports. 

You can install GRC on its own, or to be integrated with an OID LDAP server that 

manages GRC users. (OID stands for Oracle Internet Directory; LDAP for Light-

weight Directory Access Protocol.)  

You can embed a GRCI instance within GRC. If you intend to use GRCI, complete 

the installation of GRC first (see chapter 2). Then integrate GRCI with GRC (see 

chapter 3). 

You can install GRC on a server that you own and maintain (a “conventional” 

installation), or you can use Oracle VM Server to deploy an image of GRC initially 

configured by Oracle. 
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Prerequisites  

You can install GRC 8.6.4.4000 only as an upgrade to GRC 8.6.4.3000. Therefore, 

the first prerequisite is that you have installed GRC 8.6.4.3000.  

Any GRC installation runs on a 64-bit Linux server and requires: 

• An Oracle 11g Release 2 database (in which, optionally, Real Application 

Clusters may be enabled). In it, a GRC schema must be created. If you intend to 

implement GRCI, a Data Analytics (DA) schema must be created as well. 

• Java — Sun JDK 1.6 or higher, or JRockit JDK R28.1.3 for Java SE 6 with 

JRockit Mission Control 4.0.1 for Linux x86-64. 

• Middleware — either WebLogic Server 10.3.5 or Tomcat Application Server 

6.0.24.  

As an option, an OID LDAP server can manage GRC users. 

It is assumed that you have already installed and configured these components for 

GRC 8.6.4.3000, and will reuse them for your GRC 8.6.4.4000 instance. If you 

require any information about the installation or configuration of these components 

for GRC, see the Installation Guide for GRC 8.6.4.3000. 

If you implement AACG preventive analysis, a preventive enforcement agent (PEA) 

must be installed in each business application subject to AACG controls. For GRC 

8.6.4.4000, you can reuse PEAs installed for GRC 8.6.4.3000. For complete infor-

mation on PEA installation, see the Installation Guide for GRC 8.6.4.3000. 

On the server or a client system, either of the following web browsers can display 

the GRC interface: Microsoft Internet Explorer 8, with the Adobe SVG plugin 

(available from http://www.adobe.com/svg/viewer/install/mainframed.html) or 

FireFox 3.6.1. 

For details about supported components, see the Oracle Governance, Risk and 

Compliance Applications Support Matrix. 

Recording Configuration Values 

Before proceeding with the installation, make a note of certain configuration values 

for version 8.6.4.3000, as you will need to re-enter them for version 8.6.4.4000. All 

these values are displayed in the GRC Manage Application Configurations page. 

(Start GRC 8.6.4.3000, then select Navigator → Setup and Administration → Setup 

→ Manage Application Configurations). 

• In all cases, select a Properties tab and note values you will need to enter in a 

ConfigUI page during 8.6.4.4000 installation. 

• If you run GRC with WebLogic and use Service Oriented Architecture (SOA), 

select the Worklist tab and note values entered there. 

• If you have set up GRC to work with an OID LDAP repository, select a User 

Integration tab and note values entered there. 

• If you use GRCI (see chapter 3), select an Analytics tab and note the values 

entered there. 
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Installing GRC 

In broad terms, a conventional installation of GRC 8.6.4.4000 involves these steps: 

1. Download files to the GRC server and prepare them for use. Ensure that two 

directories, for the storage of GRC report and ETL data, are ready for use. 

2. Remove some files installed for GRC 8.6.4.3000.  

3. Restart the WebLogic or Tomcat application server, then perform configuration 

steps in a GRC ConfigUI page.  

4. Restart your application server to complete the installation.  

No matter whether you use WebLogic or Tomcat, you will (as noted in chapter 1) 

reuse middleware components installed for GRC 8.6.4.3000. You need not reinstall 

or reconfigure them.  

Back up your database, schema, middleware components, and report and transaction 

ETL repositories. 

Downloading Files  

Create a staging directory on your GRC server. (Throughout this document, 

<grc_stage> represents the full path to this directory.)  

To install GRC, download a file called grc864_4240.zip to <grc_stage>, and extract 

its contents there. To validate your download, generate a checksum and compare it 

with a checksum value published in Release Notes for the instance you are instal-

ling. To generate a checksum, run the command md5sum grc.ear.  

If you have not embedded GRCI in your GRC 8.6.4.3000 instance, but wish to do so 

for 8.6.4.4000, also download a file called grc864_4240_OBIEE.zip to <grc_stage>. 

(To embed GRCI in GRC, your instance must run with WebLogic. If you use Tom-

cat, you can run GRCI only as a standalone application. You do not need grc864_ 

4240_OBIEE.zip for standalone GRCI, or if you have already embedded GRCI in 

your GRC 8.6.4.3000 instance.) 
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GRC Repositories 

For GRC 8.6.4.3000, you should have created two “repositories” — directories that 

store data generated by GRC. A report repository stores copies of GRC reports that 

users schedule to be run. A second repository stores ETL data used for transaction 

analysis.  

Reuse these repositories for GRC 8.6.4.4000. Retain the contents of the transaction 

ETL repository. Note the paths to the repositories, as you will need to supply them 

later as configuration values.  

GRC with WebLogic 

If you installed GRC 8.6.4.3000 to run with WebLogic Server, complete the follow-

ing steps: 

1. Stop the WebLogic Administration Server and (if any exist in your installation) 

managed servers. 

2. During installation of GRC 8.6.4.3000, a directory called grc864 was created, 

typically as a subdirectory of your middleware home directory (represented in 

this document as <MW_HOME>). Delete the contents of this directory. 

3. Navigate to <grc_stage>/dist, and locate a grc.ear file. 

4. Copy grc.ear to the grc864 directory, and extract its contents there. 

5. Restart the WebLogic servers. 

GRC with Tomcat 

If you installed GRC 8.6.4.3000 to run with Tomcat Application Server, complete the 

following steps: 

1. Shut down the Tomcat application server. 

2. Remove the directory <TomcatHome>/webapps/grc and all its contents.  

3. Also remove the grc directory from the Tomcat work area (<TomcatHome>/work/ 

Catalina/localhost/grc). Also delete Tomcat logs, located at <TomcatHome>/logs. 

(You may want to save them to another location first.) 

4. Navigate to <TomcatHome>/webapps and delete the grc.war file. 

5. Navigate to <grc_stage>/dist. From there, run the file grc_tomcat_setup.sh 

Supply the paths to <grc_stage>/dist subdirectory, <TomcatHome>, and the full 

path to your Java home as parameters: 

cmd> ./grc_tomcat_setup.sh <grc_stage>/dist <TomcatHome> 

JavaHomePath 

6. Start the Tomcat application server. 
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Installing a Driver for RAC 

If your GRC database is one in which Real Application Clusters (RAC) is enabled, 

you need to set up a jdbc-oci driver, which is used for the connection between GRC 

and the RAC database. (If you do not use RAC, this section does not apply to you; 

skip ahead to the next section, “GRC Configuration.”) 

1. Shut down your web application server (WebLogic administration server and, if 

installed, managed server; or Tomcat application server).  

2. In a web browser, go to http://www.oracle.com/technetwork/database/features/ 

instant-client/index-097480.html. Select the Instant Client link for the platform 

on which you are installing, then find the Basic download for 11.2.0.1.0. 

3. Download and unzip the package into a single directory, such as “instantclient.”  

4. Set the library loading path in your environment to this directory before starting 

the application. On many Linux platforms, LD_LIBRARY_PATH is the appropri-

ate environment variable. 

5. Copy the file ojdbc6.jar from the instant client to <TomcatHome>/webapps/grc/ 

WEB-INF/lib if you installed GRC to run with Tomcat, or to grc864/grc/WEB-INF/lib 

if you installed GRC to run with WebLogic. (In the latter case, grc864 is the home 

directory for your GRC installation. See “GRC with WebLogic,” page 2-2.) 

6. Restart your web application server.  

GRC Configuration 

Regardless of whether you use WebLogic or Tomcat, open a ConfigUI page to 

perform GRC-specific configuration: 

1. Access GRC at 

http://host:port/grc 

In this URL, replace host with the fully qualified domain name (FQDN) of your 

GRC server. Select one of the following values for port: 

• If you use WebLogic and have installed GRC to run FAACG, enter the port 

number chosen for the GRC managed server. (This was created as an element 

of your WebLogic domain during installation of GRC 8.6.4.3000.) 

• If you use WebLogic but don’t run FAACG, enter the port number chosen 

for the Administration Server.  

• If you use Tomcat, replace port with 8080 (if you accepted the default value 

when you installed Tomcat) or your configured value (if you changed the 

default during Tomcat installation). 

2. A ConfigUI page appears. In the Installation Configuration section, type or select 

appropriate property values: 

• User Name: Supply the user name for the GRC database. 

• Password: Supply the password for the GRC database.  

• Confirm Password: Re-enter the password for the GRC database.  
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• Port Number: Supply the port number at which the GRC database server 

communicates with other applications.  

• Service Identifier: Supply the service identifier (SID) for the GRC database 

server, as configured in the tnsnames.ora file. Or, if your GRC database sup-

ports RAC, enter the RAC service name configured for your RAC database.  

• Server Name: Supply the FQDN of the database server. Or, if your GRC 

database supports RAC, enter RAC@<SCAN_NAME>, where <SCAN_ 

NAME> is the IP address/host name of the SCAN address configured for 

your RAC database.  

• Maximum DB Connections: Default is 50. You can edit this value. 

• Report Repository Path: Supply the full path to the Report Repository 

directory discussed in “GRC Repositories” on page 2-2.  

• Log Threshold: Select a value that sets the level of detail in log-file entries. 

From least to greatest detail, valid entries are error, warn, info, and debug.  

• Transaction ETL Path: Enter the full path to the directory that holds ETL 

data used by Enterprise Transaction Controls Governor (see “GRC Reposi-

tories” on page 2-2). 

• App Server Library Path: Enter the full path to the library subdirectory of 

your web application server (for use in the upload of custom connectors for 

AACG). If you are installing GRC to run FAACG, set this value to 

<grc864>/grc/WEB-INF/lib. 

3. In the Language Preferences section of the ConfigUI page, select check boxes 

for up to twelve languages in which you want GRC to be able to display infor-

mation to its users. “English (U.S.)” should be selected by default; do not 

deselect it.  

4. In the Performance Configuration section of the ConfigUI page, select or clear 

check boxes: 

• Optimize Distributed Operation: Select the check box to increase the speed 

at which GRC performs distributed operations such as data synchronization.  

• Optimize Appliance-Based Operation: Select the check box to optimize 

performance if the GRC application and GRC schema reside on the same 

machine. Do not select this check box if the GRC application and schema 

do not reside on the same machine. When you select this check box, an 

ORACLE_HOME Path field appears. In it, enter the full, absolute path to your 

Oracle Home — the directory in which you have installed the Oracle data-

base that houses the GRC schema. 

• Enable Era-Based ETL Optimization: “Data synchronization” enables both 

ETCG and AACG to recognize data changes in the business applications 

subject to their models and controls. For ETCG only, select this check box 

to cause synchronization to operate only on data entered in business applica-

tions after a specified date.  
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When you select this check box, an Analysis Start Date field appears. In it, 

enter a date from which you want synchronization runs to recognize data 

changes. When you click in the field, a pop-up calendar appears. Click left- 

or right-pointing arrows to select earlier or later months (and years), and 

then click on a date in a selected month. 

• Externalize Report Engine: Select the check box to enable the reporting 

engine to run in its own java process, so that the generation of large reports 

does not affect the performance of other functionality. However, select the 

check box only if you have installed GRC on hardware identified as “certi-

fied” in the Oracle Governance, Risk and Compliance Applications Support 

Matrix; clear the check box if you use hardware identified as “supported.” 

• Enable Parallel Processing: Select this check box to enable EGRCC to pro-

cess multiple models and controls simultaneously. However, use of this fea-

ture requires, at a minimum, 16 GB of RAM; 24 GB is preferred. 

When you select the Enable Parallel Processing check box, two fields appear. 

In a Number of Cores Available for Processing field, enter the number of 

processor cores you wish to devote to parallel processing; EGRCC devotes 

one core to each model or control selected for analysis, until as many cores 

as you select are in use. In a Maximum Megabytes of Physical RAM Availa-

ble field, specify an amount of memory for use in parallel processing. As a 

rule of thumb, enter total RAM minus 8 GB; you may need to adjust this 

value if other processes run slowly.  

5. In the ConfigUI page, click on Actions → Save. GRC tests the values you’ve 

entered and, if they are valid, saves them. (If any are invalid, an error message 

instructs you to re-enter them.) 

6. Exit the ConfigUI page.  

Completing the Installation 

With components in place and properly configured, complete the installation, in 

effect by running your web application server.  

1. Shut down your server — the Administration Server if you’re using WebLogic, 

or the Tomcat application server if you’re using Tomcat. Then restart the server. 

2. In a web browser, enter the GRC URL (see step 1 of “GRC Configuration” on 

page 2-3). 

3. Wait for a pop-up message to report, “Database upgrade and initialization process 

complete.” Click on its OK button. 

4. You are redirected to a GRC logon page. Log on to the application. You can use 

the admin user ID, with a password established for that user ID during installation 

of version 8.6.4.3000. 

If you are installing GRC without SOA and have not set up an external OID LDAP 

repository to manage users, basic GRC installation is complete. (You may, however, 

choose to embed GRCI or complete other procedures described later.) 



 

2-6 Oracle Governance, Risk and Compliance Installation Guide 

If you have installed GRC with SOA (or to run with a pre-existing SOA), or if you 

have set up an OID LDAP repository, complete some additional steps: 

1. If you use SOA, ensure that the SOA Server is up and running. (This is either a 

managed server created as an element of your WebLogic domain during installa-

tion of GRC 8.6.4.3000, or a server created for a pre-existing SOA instance.) 

2. In GRC, select Navigator → Setup and Administration → Setup → Manage 

Application Configurations. 

3. If you need to configure SOA, select the Worklist tab and enter values you 

noted earlier (see “Recording Configuration Values,” page 1-2): 

• Worklist Server User Name: Keep the default value, soaadmin. 

• Worklist Server Password. Enter the password you created for the soaadmin 

user (during installation of GRC 8.6.4.3000). 

• Worklist Server Confirm Password: Re-enter the Worklist Server Password. 

• Worklist Server URL: http://host:port, in which host is the IP address of your 

SOA server, and port is its port number.  

• Worklist Server Protocol: Select the communications protocol — SOAP or 

RMI — used by the GRC application to send and receive SOA requests.  

4. If you need to configure external OID LDAP, select the User Integration tab and 

enter values you noted earlier (see “Recording Configuration Values,” page 1-2): 

• Enable Single Sign On: Select the check box to make use of Single Sign 

On, which establishes a single set of log-on credentials for each user in 

varying applications. (Or, clear the check box if you do not wish to use 

Single Sign On.) 

• Enable Integration: Select the check box to permit integration with LDAP to occur. 

• User Name: Supply the user name (common name) to log in to the LDAP 

server. This user should have admin privileges.  

• Password: Enter the password for the user identified in the User Name field. 

• Confirm Password: Re-enter the password for the user identified in the User 

Name field. 

• Port Number: Enter the port number at which the LDAP server communi-

cates with other applications. 

• Server Name: Enter the host name of the LDAP server.  

• Bind DN Suffix: Enter the “User Base DN.” 

• Enable SSL Authentication: Select the check box to allow GRC to access the 

LDAP server through SSL. The LDAP server must be configured to support 

SSL. 

• Perform LDAP Recursive Search: Select the check box to search recursively 

for users in subfolders along with those in the base path specified in the Bind 

DN Suffix field. 

• Unique User Identifier: uid 
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5. In the Manage Application Configurations page, click on Actions → Save. Then 

log off of GRC. 

6. Stop the GRC Deployment in the WebLogic Console: 

a Log in to the WebLogic Console at  

http://host:port/console 

Replace host with the FQDN of your GRC server, and port with the number 

you selected for the WebLogic Administration Server.  

b From the Domain Structure menu, select Deployments. 

c From the Deployment page, locate the GRC deployment and verify the state 

is Active. 

d Click the checkbox next to the GRC deployment. 

e From the toolbar, click Stop → Force Stop Now. 

7. Start the GRC Deployment in the WebLogic Console: 

a From the Domain Structure menu, select Deployments. 

b From the Deployment page, locate the GRC deployment and verify the state 

is Prepared. 

c Click the checkbox next to the GRC deployment. 

d From the toolbar, click Start → Servicing All Requests. 
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Integrating GRCI 

If you license Oracle Fusion GRC Intelligence (GRCI) for use with GRC, you are 

assumed (for the purposes of this chapter) to be upgrading an instance of GRCI 

already installed for GRC 8.6.4.3000. 

You may set up GRCI for use with GRC 8.6.4.4000 even if you did not do so for 

version 8.6.4.3000. To do so, obtain version 8.6.4.3000 of the GRC Installation 

Guide and follow its instructions for performing a complete GRCI integration. In 

those instructions, substitute the file name grc864_4240_OBIEE.zip for grc864_ 

3347_OBIEE.zip, and the file name grc-rerportservices-8.6.4.4-SNAPSHOT-obiee-

artifacts.zip for grc-rerportservices-8.6.4.3-SNAPSHOT-obiee-artifacts.zip. 

Preparing for the Upgrade 

GRCI makes use of Oracle Business Intelligence Enterprise Edition (OBIEE), 

which in turn is supported by WebLogic middleware components. 

• If your GRC instance runs with WebLogic, you completed an “embedded” 

GRCI installation for 8.6.4.3000. In this case, OBIEE and GRCI are supported 

by the WebLogic middleware that also supports GRC. 

• If your GRC instance runs with Tomcat, you completed a “standalone” GRCI 

installation for 8.6.4.3000. In this case, OBIEE and GRCI are supported by 

WebLogic middleware that exists independently of the Tomcat components that 

support GRC. 

As you upgrade to 8.6.4.4000, you will reuse these components. To complete the 

upgrade procedure, identify the following: 

• <MW_HOME>: The complete path to the middleware home — the highest-level 

directory that contains WebLogic middleware components. If you run GRC 

with WebLogic, this is also the middleware home for your GRC instance. If you 

run GRC with Tomcat, this is the middleware home for the WebLogic compo-

nents that exist independently of the Tomcat components that support GRC. 

• If you run GRC with WebLogic, the host name and port number of the GRC 

server. (This is typically the WebLogic Administration server, although if you 

run FAACG it is a managed server. See step 1 of “GRC Configuration” on page 

2-3). 
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• If you run GRC with Tomcat, the Oracle Enterprise Manager URL and the 

Business Intelligence Enterprise Edition URL; the host name and port number 

for the WebLogic Administration server that supports OBIEE and GRCI; the 

fully qualified domain name for the machine on which OBIEE is installed. 

(These values were set, and reported in an “Installation Completed” screen, 

during installation of middleware components that support standalone OBIEE 

and GRCI. Ideally, they were noted as version 8.6.4.3000 was installed.) 

• The service identifier (SID) and schema name for the Data Analytics (DA) data-

base schema that supports GRCI.  

Beginning the Upgrade 

To begin the upgrade from GRCI 8.6.4.3000 to 8.6.4.4000: 

1. Stop OBIEE components.  

2. Create a temporary directory. (Throughout this document, <obiee_temp> 

represents the full path to this directory.)  

3. Locate the file grc-reportservices-8.6.4.4-SNAPSHOT-obiee-artifacts.zip in your 

<grc_stage>/dist directory. Extract its contents in <obiee_temp>. 

4. Back up your GRCDWebcat folder, which is a subdirectory of <MW_HOME>/ 

instances/instance1/bifoundation/OracleBIPresentationServicesComponent/core

application_obips1/catalog. Rename it or move it to another folder.  

5. Copy <obiee_temp>/Webcat/GRCDWebcat to <MW_HOME>/instances/instance1/ 

bifoundation/OracleBIPresentationServicesComponent/coreapplication_obips1/ 

catalog.  

Repository Configuration  

When GRCI was set up for version 8.6.4.3000, an OBIEE client was installed on a 

Windows system. Use that system to complete the following steps: 

1. Using ftp, transfer <obiee_temp>/repository/GRCDiagnostic.rpd to the Windows 

system. 

2. On the Windows system, open the Oracle BI Administration Tool: From the Start 

menu, navigate to Oracle Business Intelligence Enterprise Edition Plus Client → 

Administration. 

3. Navigate to File → Open → Offline. Select the GRCDiagnostic.rpd file you 

transferred in step 1. Enter Admin123 as the Repository Password. 

4. Navigate to Manage → Variables. 

• Double-click on GRI_DSN. Under Default Initializer, enter the SID for the 

Oracle database that hosts your DA schema, inside single quotation marks. 

Press OK. 

• Double-click on GRI_USER_ID. Under Default Initializer, enter the schema 

name used by your DA schema, inside single quotation marks. Press OK. 

• Close the Variable Manager. 
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5. In the main window under the Physical section, right-click on GRC Diagnostics 

and select Properties. 

• Click on the Connection Pools tab and double-click on GRCI Connection Pool. 

• Under the Shared Logon section, enter the schema password used by your 

DA schema. 

• Press OK, re-enter the schema password in the confirmation pop-up, and 

then press OK again. 

6. Navigate to File → Save and answer No to “Do you wish to check global 

consistency?” 

7. Exit the Oracle BI Administration Tool. 

Deploying GRCDiagnostic.rpd and Updating Scheduler Credentials 

Deploy the new GRCDiagnostic.rpd: 

1. Start the Administration Server, BI Server, and BI components.  

2. Still on the Windows machine 

• If your GRC installation uses WebLogic, go to http://host:port/em. Log in 

to the host with your WebLogic Administration username and password.  

• If your GRC installation uses Tomcat, go to your Oracle Enterprise Manager 

URL. Log in with your WebLogic Administration username and password.  

3. From the left menu, expand Business Intelligence and double-click on 

coreapplication. 

4. Select the Deployment tab. 

5. If your GRC installation uses Tomcat, skip ahead to step 15. If your installation 

uses WebLogic, continue at the next step.  

6. Select the Scheduler tab. 

7. Press Lock and Edit Configuration. 

8. Close the confirmation pop-up. 

9. Update the username to EGRCM_BIPLATFORM. 

10. Update the password and confirm password fields to grc. 

11. Click the Apply button. 

12. Click on the Activate Changes button on top. 

13. Click on Close after the changes are activated. 

14. Press Lock and Edit Configuration. 

15. Select the Repository tab. 

16. Under Upload BI Server Repository, click the Browse button and select the 

GRCDiagnostic.rpd that you modified and saved on your Windows machine in 

“Repository Configuration” (page 3-2). Enter Admin123 in both of the Reposi-

tory Password and Confirm Password fields. 
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17. Under BI Presentation Catalog, enter the following as the Catalog Location: 

<MW_HOME>/instances/instance1/bifoundation/OracleBIPresentationServices 

Component/coreapplication_obips1/ catalog/GRCDWebcat 

18. Click on the Apply button. 

19. Click on the Activate Changes button on top. 

20. Click on Close after the changes are activated. 

21. Press the Restart to apply recent changes button on top. 

22. Click on the Restart button. 

23. Select Yes. 

24. Click on Close after the restart completes. 

It is ok if all the BI system components are up and running, but there are warnings 

or errors.  

Connecting to the DA Schema 

The GRC schema used by GRC supplies data to the DA schema used by GRCI. For 

this to happen, you need to enter connectivity information in GRC.  

1. Log on to GRC (see step 1 of “GRC Configuration” on page 2-3). Select Navi-

gator → Tools → Setup and Administration → Setup → Manage Application Con-

figurations → Analytics. 

2. In the Data Analytics Configuration section, enter values that identify the DA 

schema. (These are values you noted earlier; see “Recording Configuration 

Values” on page 1-2.) 

• User Name: Supply the user name for the DA database. 

• Password: Supply the password for the DA database. 

• Confirm Password: Re-enter the password for the DA database. 

• Port Number: Supply the port number at which the database server 

communicates with other applications. 

• Service Identifier: Supply the service identifier (SID) for the database 

server. 

• Server Name: Supply the fully qualified domain name of the database server. 

3. When you finish entering property values, click on Actions → Save. GRC tests 

the values you’ve entered and, if they are valid, saves them. (If any are invalid, 

an error message instructs you to re-enter them.) 

4. Look for the prompt, “Successfully saved configuration values.”  

After that message appears, a one-time process runs in the background. It upgrades 

the DA schema from version 8.6.4.3000 to 8.6.4.4000. Do not stop your WebLogic 

or Tomcat server during this period.  

Once you have connected to the DA schema, set a schedule on which the schema is 

refreshed — on which the DA schema reads from the GRC schema. No data exists in 
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the schema until the first scheduled refresh occurs. You can modify a schedule at any 

time. (A refresh can take up to 90 minutes to finish.) To create the schedule:  

1. Select the Analytics tab of the Manage Applications Configurations page.  

2. Click on the Schedule Data Analytics Update button.  

3. A Schedule Parameter dialog opens. Enter values that set the name of the sched-

ule, its start date and time, the regularity with which the DA schema should be 

refreshed, and an end date (if any). Then click on the Schedule button.  

4. Click on Actions → Save.  

To view the status of a scheduled refresh, go to Tools → Setup and Administration 

→ Manage Jobs. To view the Data Analytics schedule, go to Tools → Setup and 

Administration → Manage Scheduling.  

Configuring Intelligence in GRC 

Within the GRC application, you need to enter values than enable GRC to connect 

to OBIEE, and you need to select “dashboards” in which GRC displays reports.  

1. Log on to GRC (see step 1 of “GRC Configuration” on page 2-3). Select Navi-

gator → Tools → Setup and Administration → Setup → Manage Application Con-

figurations → Analytics. 

2. In the GRC Intelligence Configuration section, supply the following values. 

(Again, these are values you noted earlier; see “Recording Configuration 

Values” on page 1-2.) 

• OBIEE Server Username: The user name configured for the WebLogic 

Administration Server.  

• OBIEE Server Password: The password for the OBIEE Server Username 

(the password configured for the WebLogic Administration Server). 

• OBIEE Server Port: If you use WebLogic, 9704. If you use Tomcat, the 

port number used by the WebLogic Administration Server.  

• OBIEE Server Host: If you use WebLogic, the fully qualified domain name 

for the GRC host — the machine on which you installed GRC in Chapter 2. 

If you use Tomcat, the fully qualified domain name for the machine on 

which you installed OBIEE.  

• Root Context: analytics 

Leave the Enable SSL Authentication check box unchecked. 

3. An Intelligence Page Configuration section displays a row for each dashboard 

you can display for GRC. (Each is identified as a “subtab” of an Intelligence tab 

that appears in, or in reference to, a major GRC page, such as the home page or 

an overview page for an object such as EGRCM risk or EGRCC continuous 

control.) 

• To enable a dashboard, double-click in its field in the Enable column until a 

check mark appears. To disable it, double-click until the check mark disap-

pears. 
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• To modify the display name of a dashboard, double-click in its field in the 

Display Label column. The field becomes write-enabled; enter the name 

you want to use. 

4. When you finish entering values, click on Action → Save. If you’ve modified 

settings in the GRC Intelligence Configuration section, GRC tests the values 

you’ve entered and, if they are valid, saves them. (If any are invalid, an error 

message instructs you to re-enter them.) 

5. Look for the prompt, “Successfully saved configuration values.” 

Testing the Installation 

To test a GRC installation that uses WebLogic, open a browser and go to 

http://host:9704/analytics (in which host is the FQDN of your GRC server). Log in 

with your WebLogic Administration username and password.  

To test a GRC installation that uses Tomcat, open a browser and go to your Busi-

ness Intelligence Enterprise Edition URL. Log in with your WebLogic Administra-

tion username and password.  

If you can get in, the installation has been successful. (If, however,  the first sched-

uled run of the DA schema refresh has not finished, no data appears. See page 3-4.) 
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Deploying a VM Image of GRC 

Rather than perform a conventional GRC installation, you can deploy a GRC image 

configured in advance by Oracle. You would use Oracle VM Server to deploy the 

image.  

The image is an instance of GRC running with WebLogic. The image is initially 

configured to run without SOA; however, a SOA instance is included, and once 

deployment is complete you can configure the image to use SOA worklists. All other 

required elements, such as operating system and database, are included in the image. 

The database includes both a GRC schema (which serves the application itself) and 

a data analytics schema (for use in enhanced reporting). 

Deploying a GRC Distribution 

To deploy an Oracle GRC distribution for Oracle VM Server: 

1. Obtain and install Oracle VM Manager and Oracle VM Server 2.2. 

2. Add the hostname of the machine hosting Oracle VM Server to the “server 

pool” in Oracle VM Manager. 

3. Extract an Oracle GRC Distribution into the “running_pool” directory on the 

Oracle VM Server. Use grcm.tar.gz if you want to run Enterprise Governance, 

Risk and Compliance Manager, or grcc.tar.gz if you want to run Enterprise 

Governance, Risk and Compliance Controls. Within an instance of Oracle VM 

Server, you must choose one or the other; you can’t choose both. 

4. Open the file vm.cfg in a text editor. (It’s located in the directory extracted from 

the Oracle GRC Distribution.) In it, locate the “disk” line. Edit this line to contain 

the path to system.img (which resides in the same directory as vm.cfg, extracted 

from the Oracle GRC Distribution).  

5. Log in to Oracle VM Manager. On the Resources tab, select Virtual Machine 

Images. 

6. Click on the Import button. 

7. Select the second option, “Select from Server Pool (Discover and register).” 

Then click Next. 
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8. Ensure your VM is selected in a Virtual Machine Image Name drop-down field. 

(Your VM is stored in a subdirectory of the “running_pool” directory, and its 

name is the same as the name of this subdirectory.) Then select and fill in other 

fields. (For operating system, select Oracle Enterprise Linux 5 64-bit.) Click the 

Next button. 

9. A confirmation page appears. Review it and (assuming values are correct) click 

on the Confirm button. The Virtual Machine Images entry page reappears. 

10. Click on the Approve button. Another confirmation page appears. Review it and 

(assuming values are correct) click on the Confirm button. 

11. You should now see the VM in a powered off state. Click the Power On button 

and enter “OS in Single User Mode.” 

12. Once in Single User Mode, change the “root” user password and edit the net-

work configurations to make the VM accessible on your network.  

Change the hostname and IP of the VM in the following files: 

/etc/hosts/ 

/etc/resolv.conf 

/etc/sysconfig/network 

/etc/sysconfig/network-scripts/ifcfg-eth0 

Change the hostname and IP of the DB in the following files: 

/u01/app/oracle/product/11.2.0/db/network/admin/listener.ora 

/u01/app/oracle/product/11.2.0/db/network/admin/tnsnames.ora 

When all updates are completed, restart the instance. 

13. Once the startup is completed, you should be able to log into the instance as the 

“root” user or the “oracle” user. All applications are owned by the oracle user.  

Users and Passwords 

Default usernames and passwords within a GRC image include the following: 

• Oracle Database: sys/manager 

• Oracle Database: system/manager 

• OS (root user): root/welcome 

• OS (oracle user): oracle/welcome 

• WebLogic Administration Server: weblogic/welcome1 

• SOA (soa_server1) Managed Server: weblogic/welcome1 

• Oracle WebLogic Server Console: weblogic/welcome1 

• Oracle WebLogic Server Enterprise Manager: weblogic/welcome1 

• GRC Schema: grc_user/grc_password 

• GRC Data Analytics Schema: grc_user_da/grc_password 
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Log File Locations 

Default locations of log files within a GRC image include the following: 

• Oracle Weblogic Server - AdminServer (nohup): 

/u01/app/Oracle/Middleware/user_projects/domains/grc_domain/bin/wls.log 

• Oracle Weblogic Server - SOA (soa_server1) Managed Server (nohup): 

/u01/app/Oracle/Middleware/user_projects/domains/grc_domain/bin/soa.log 

• Oracle Weblogic Server - AdminServer: 

/u01/app/Oracle/Middleware/user_projects/domains/grc_domain/servers/Admin

Server/logs 

• Oracle Weblogic Server - SOA (soa_server1) Managed Server: 

/u01/app/Oracle/Middleware/user_projects/domains/grc_domain/servers/soa_ 

server1/logs 

• GRC Log: 

/u01/app/Oracle/Middleware/user_projects/domains/grc_domain/servers/Admin

Server/stage/grc864/grc864/grc/log/grc.log 

Starting a GRC Distribution 

To start an Oracle GRC distribution for Oracle VM Server: 

1. Log into the instance as the oracle user. 

2. Set the ORACLE_HOME environment variable: 

export ORACLE_HOME=/u01/app/oracle/product/11.2.0/db 

3. Set the ORACLE_SID environment variable: 

export ORACLE_SID=orcl 

4. Add ORACLE_HOME/bin to the PATH: 

export PATH=$ORACLE_HOME/bin:$PATH 

5. Use SqlPlus to start the Oracle database. For example: 

sqlplus /nolog 

SQL> connect / as sysdba 

SQL> startup 

SQL> exit 

6. Start the Oracle Database Listener: 

lsnrctl start 

7. Set your path to the following: 

/u01/app/Oracle/Middleware/user_projects/domains/grc_domain/ 

bin 

8. Start the WebLogic Administration Server: 

nohup ./startWeblogic.sh > wls.log & 
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9. Optionally, start the WebLogic SOA Managed Server (soa_server1). This step 

applies to EGRCM only; skip this step if you use EGRCC. 

nohup ./startManagedWeblogic.sh soa_server1 > soa.log & 

10. Verify that WebLogic and (if applicable) SOA are available by connecting to 

the Oracle WebLogic Server Enterprise Manager. (Replace <hostname> with 

the value you created in step 12 of “Deploying a GRC Distribution,” page 4-2.) 

http://<hostname>:7001/em 

11. Verify that the GRC application (grc863) is available by connecting to the 

Oracle WebLogic Server Console. (Replace <hostname> with the value you 

created in step 12 of “Deploying a GRC Distribution,” page 4-2.) 

http://<hostname>:7001/console 

12. Logon to the GRC application. (Replace <hostname> with the value you created 

in step 12 of “Deploying a GRC Distribution,” page 4-2.) 

http://<hostname>:7001/grc 

Stopping a GRC Distribution 

To stop an Oracle GRC distribution for Oracle VM Server: 

1. Log into the instance as the oracle user. 

2. Set the ORACLE_HOME environment variable: 

export ORACLE_HOME=/u01/app/oracle/product/11.2.0/db 

3. Set the ORACLE_SID environment variable: 

export ORACLE_SID=orcl 

4. Add ORACLE_HOME/bin to the PATH: 

export PATH=$ORACLE_HOME/bin:$PATH 

5. Set your path to the following: 

/u01/app/Oracle/Middleware/user_projects/domains/grc_domain/ 

bin 

6. If the WebLogic SOA Managed Server (soa_server1) is running, stop it. This 

step applies to EGRCM only; skip this step if you use EGRCC. 

./stopManagedWeblogic.sh soa_server1 

7. Stop the WebLogic Administration Server: 

./stopWeblogic.sh 

8. Stop the Oracle Database Listener 

lsnrctl stop 

9. Use SqlPlus to start the Oracle database. For example: 

sqlplus /nolog 

SQL> connect / as sysdba 

SQL> shutdown immediate 

SQL> exit 
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Additional EGRCC Configuration 

Once you’ve installed GRC, complete additional configuration procedures as 

needed if you intend to use EGRCC (which runs as a Continuous Controls Moni-

toring module in GRC):  

• Define the information AACG uses to create “global users.” Within business 

applications subject to AACG models and controls, individual users may have 

user-account information that varies from one application to the next. For each 

person, EGRCC creates a “global user” and maps that person’s business appli-

cation IDs to it. You must change the default global-user value if you imple-

ment FAACG (install EGRCC to apply AACG models and controls within 

Oracle Fusion Applications). Otherwise, global-user configuration is optional. 

• Set up datasources — connections to applications in which EGRCC is to perform 

analysis. In addition, synchronize data for each datasource — collect informa-

tion required for AACG or ETCG analysis, and provide that information a format 

that EGRCC recognizes. (For an AACG instance or an ETCG instance that per-

forms analysis in Oracle EBS of PeopleSoft, both datasource configuration and 

data synchronization are somewhat different than for FAACG instances.) 

Note: After you install GRC 8.6.4.4000, synchronize data for each datasource (see 

page 5-3) and evaluate all transaction models inherited from version 8.6.4.3000. 

(See the Enterprise Transaction Controls Governor User Guide for information on 

running transaction models.) 

Configuring Global Users 

Implement one of the following options to determine the information EGRCC uses to 

create global users. Important: Select an option that identifies each person uniquely. 

• EMAIL_ONLY: Match the global user to email addresses from distinct data-

sources (or within one datasource). This is the default. 

• EMAIL_AND_USERNAME: Match the global user to email address plus username 

from distinct datasources (or within one datasource). You must select this option 

if you are implementing FAACG.  

• EMAIL_AND_ALL_NAMES: Match the global user to email address, username, 

given name, and surname from distinct datasources (or within one datasource). 
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As regular procedures, GRC users “synchronize data” (collect information required 

for AACG or ETCG analysis, and provide that information to GRC) and analyze con-

trols to produce “incidents” (records of control violations).  

Changing a global-user configuration is simplest if no one has yet synchronized data 

or analyzed controls on your GRC instance. Complete the following three steps: 

1. Use SQL*Plus, or any other tool with the ability to execute SQL commands on 

a database, to connect to the GRC schema.  

2. Run the following SQL statement: 

DELETE FROM GRC_PROPERTIES 

WHERE NAME like 'GLOBAL_USER_CONFIG'; 

COMMIT; 

3. Run one of the following SQL statements, depending on the global-user format 

you want to implement: 

For email and username, run the following statement: 

Insert into GRC_PROPERTIES (NAME, VALUE, DESCRIPTION, DEFAULT_VALUE, 

VISIBLE, CONFIGURABLE, DATA_TYPE_ID)Values ('GLOBAL_USER_CONFIG', 

'EMAIL_AND_USERNAME', 'Global User configuration. Possible values: 

EMAIL_ONLY, EMAIL_AND_USERNAME, EMAIL_AND_ALL_NAMES', 'EMAIL_ONLY', 

0, 0, 0); 

COMMIT; 

For email, username, given name, and surname, run the following statement: 

Insert into GRC_PROPERTIES (NAME, VALUE, DESCRIPTION, DEFAULT_VALUE, 

VISIBLE, CONFIGURABLE, DATA_TYPE_ID) Values ('GLOBAL_USER_CONFIG', 

'EMAIL_AND_ALL_NAMES', 'Global User configuration. Possible values: 

EMAIL_ONLY, EMAIL_AND_USERNAME, EMAIL_AND_ALL_NAMES', 'EMAIL_ONLY', 

0, 0, 0);  

COMMIT; 

For email only, run the following statement. (As already noted, email-only is the 

default configuration. Run this statement only if you have changed your global-

user configuration to one of the other formats, and want to change back.) 

Insert into GRC_PROPERTIES (NAME, VALUE, DESCRIPTION, DEFAULT_VALUE, 

VISIBLE, CONFIGURABLE, DATA_TYPE_ID) Values ('GLOBAL_USER_CONFIG', 

'EMAIL_ONLY', 'Global User configuration. Possible values: EMAIL_ONLY, 

EMAIL_AND_USERNAME, EMAIL_AND_ALL_NAMES', 'EMAIL_ONLY', 0, 0, 0); 

COMMIT; 

A second possibility is that data has been synchronized, but controls have not been 

analyzed, on your GRC instance. In this case, when you change your global-user con-

figuration, all existing global-user data will be wiped out.  

1. Complete the steps outlined above for the first global-user-configuration sce-

nario (in which data synchronization and control analysis have not occurred). 

2. Sill logged on to your SQL tool, also run the following SQL statement: 

TRUNCATE TABLE LAA_USER_MAPPING; 

TRUNCATE TABLE LAA_GLOBAL USER; 

COMMIT; 

A third possibility is that data has been synchronized, controls have been analyzed, 

and incidents have been generated on your GRC instance. In this case, when you 
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change your global-user configuration, all existing incidents become invalid, and all 

existing global-user data will be wiped out.  

1. Log on to GRC (see page 2-3). Select Setup and Administration under Tools in 

the Navigator, then Manage Application Configurations under Setup. Select the 

Maintenance tab, and from the Maintenance page, purge all existing incidents. 

(For detailed instructions on purging incidents, see the Governance, Risk and 

Compliance User Guide.) 

2. Still logged on to GRC, go to the Manage Results page. (Select Manage Inci-

dent Results from the Result Management tasks available under Continuous 

Control Management in the Navigator.) Select Incident Result in the View By 

list box, and confirm that no incidents exist.  

3. Log off of GRC and shut down the application server.  

4. Complete the steps outlined above for the first global-user-configuration sce-

nario (in which data synchronization and control analysis have not occurred). 

5. While logged on to your SQL tool, also run the following SQL statement: 

TRUNCATE TABLE SUM_CONTROL_ISSUES; 

TRUNCATE TABLE LAA_USER_MAPPING; 

TRUNCATE TABLE LAA_GLOBAL_USER; 

DROP VIEW ALL_ISSUE_CONTROL_V; 

DROP VIEW ALL_ISSUE_HISTORY_V; 

COMMIT; 

6. Clear the contents of your Transaction ETL Path folder. (This folder is specified 

as GRC properties are set. See page 2-4). 

Configuring Datasources and Synchronizing Data 

Connect GRC to datasources (instances of business-management applications that 

are to be subject to its analysis). Also synchronize data for each datasource — collect 

information required for AACG or ETCG analysis. 

GRC creates one global user for each user in the first datasource for which you 

synchronize access data. It adopts the ID configured for each user in that datasource 

as that user’s global ID. When you synchronize data for a second datasource, GRC 

matches users who also exist in the first datasource to their already-existing global 

user IDs. For each “new” user — each of those who do not exist in the first datasource 

— GRC adopts the user ID from the second datasource as the user’s global ID. And 

so on for each datasource for which you synchronize data. 

AACG pages display the global user ID for each business-application user. A given 

user’s ID may differ from one datasource to the next, and you may prefer to set IDs 

from a particular datasource as the global user IDs. 

It’s recommended, therefore, that you configure all datasources in which you expect 

to apply AACG models and controls before you synchronize data for any of them. 

Next, choose the datasource from which you want GRC to adopt IDs as global user 

IDs, and synchronize that datasource first. Establish an order for the remaining data-

sources, each of which sets global IDs for users who do not exist in the datasources 

for which synchronization has already been completed. Then synchronize the remain-

ing datasources in that order. 
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To configure datasources or to synchronize their data, log on to GRC (see page 2-3). 

Select Setup and Administration under Tools in the Navigator, then Manage 

Application Datasources under Setup. 

To configure an Oracle EBS or PeopleSoft datasource, complete these steps. (The 

procedure is somewhat different for a Fusion datasource; see page 6-2.) 

1. Click on Actions → Create New. A Create Datasource window opens. Enter the 

following values: 

• Datasource Name: Create a name for the datasource. 

• Description: Type a brief description of the datasource (optional). 

• Application Type: Select the type of business application to which you are 

connecting, such as EBS or PeopleSoft. 

• Application Type Version: Select the version number of the business-

management application to which you are connecting. 

• Default Datasource: Select the checkbox to make the datasource you are 

configuring the default for use in transaction models. Only one datasource 

can have this value selected. 

• Connector Type: For an Oracle EBS or PeopleSoft datasource, select 

Default. For any other application, you would need to have created and 

uploaded a custom connector; select it. 

• Connector Properties: Enter values required for the connector you specified 

in Connector Type. Values vary by connector. They may include: 

– ERP Database Type: Select the type of database — Oracle, MS SQL 

Server, or DB2 — used by the business-management application being 

configured as a datasource. 

– Hostname: For Oracle EBS or PeopleSoft, supply the fully qualified 

domain name (FQDN) for the machine that hosts the database used by 

the business-management application. Or, if the datasource is RAC-

enabled, enter RAC@<SCAN_NAME>, where <SCAN_NAME> is the 

IP address/host name configured for the RAC database. 

– Password: For Oracle EBS or PeopleSoft, enter the password for the 

business-application database.  

– Port: For Oracle EBS or PeopleSoft, enter the port number that the 

business-application database uses to communicate with other 

applications.  

– Service Name: For Oracle EBS or PeopleSoft, supply the SID value 

configured for the business-application database in the tnsnames.ora 

file. Or, if the datasource is RAC-enabled, enter the RAC service name 

configured for the RAC database. 

– Username: For Oracle EBS or PeopleSoft, supply the user name for the 

business-application database. (For an Oracle database, this is the same 

as Schema Name; for an Oracle EBS instance, this is typically APPS.)  

2. After entering values, click on the Test Connection button.  
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3. When the test completes successfully, click the Save or Save and Close button. 

A row representing the datasource appears in the Manage Application Data-

sources grid. 

To perform data synchronization: 

1. In the Manage Application Datasources page, select the row for the datasource 

with which you want to synchronize data.  

2. Do either of the following: 

• Click on Actions → Synchronize Access. This causes data used by AACG 

to be synchronized once, immediately. 

If you are upgrading from an earlier version, you must run access synchroni-

zation for each datasource. (You must first have deleted the content of a 

directory that stores ETL data used by ETCG. This should have occurred 

when you completed “GRC Repositories” on page 2-2.) 

• Click on Actions → Synchronize Transaction. This causes data used by 

ETCG to be synchronized once, immediately. 

(You may also select another option, Actions → Schedule Synchronize, to estab-

lish a schedule on which data synchronization occurs regularly. For more on this, 

see the Governance, Risk and Compliance User Guide.) 

Each time a datasource is synchronized, GRC updates fields in the row for that 

datasource: Last Access Synchronization Date and Last Access Synchronization 

Status show the date of the most recent access synchronization, and its completion 

status. Last Transaction Synchronization Date and Last Transaction Synchronization 

Status do the same for the most recent transaction synchronization. 

Determining Datasource IDs 

When you configure a datasource, EGRCC assigns an ID number to it. If you intend 

to implement preventive analysis for an Oracle EBS or PeopleSoft datasource, you 

need to know its datasource ID. To determine the number, configure the datasource, 

then complete the following steps: 

1. In the Manage Application Datasources page, right-click on the header row in 

the grid that displays configured datasources. 

2. A list of available columns appears. In it, select the check box for the Datasource 

ID column (click on it so that a check mark appears). 

3. Left-click anywhere outside of the list of columns to close it. 

4. The Manage Application Datasources page now displays a Datasource ID 

column. In it, note the ID number assigned to the datasource you’ve configured. 

If, having determined the datasource IDs for your datasources, you wish to remove 

the Datasource ID column from view, repeat this procedure but clear the Datasource 

ID check box (click on it so that the check mark disappears). 
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Setting Up FAACG 

If you have installed Governance, Risk and Compliance so that you can use Applica-

tion Access Controls Governor to perform segregation-of-duties analysis in Oracle 

Fusion, complete the procedures in this chapter. (If not, then this chapter does not 

apply to you.)  

As prerequisites, Fusion Human Capital Management (HCM) and Oracle Identity 

Management (OIM) must be installed, through the Fusion Applications provisioning 

process. In conjunction with this, Oracle Internet Directory (OID) must be set up as 

the LDAP repository whose identity store is managed by OIM. In addition, you 

must have installed GRC to run with WebLogic (see chapter 2 of this document).  

Then, to set up Fusion Application Access Controls Governor (FAACG), change the 

GRC “global user” configuration to EMAIL_AND_USERNAME (see page 5-1). Then 

install a “connector” within your GRC instance. (The connector collects data from a 

Fusion instance and provides it in a format that GRC recognizes.) Finally , use Fusion 

Setup Manager to perform GRC setup.  

Installing the Connector 

To install a connector, you use a Manage Application Libraries page available in 

GRC. It is assumed that you have already completed preliminary steps during GRC 

8.6.4.3000 installation — associating the GRC domain with OID, creating an 

OIDAuthenticator, and granting permission to the GRC code base. You need not 

repeat these steps for GRC 8.6.4.4000. (For detailed information about these steps, 

see the Installation Guide for GRC 8.6.4.3000.) 

The Fusion connector is provided in a file called grc-connector-fusion-8.6.4.4-

SNAPSHOT-connectorsetup.zip. To upload it to GRC: 

1. Log on to GRC. In a web browser, enter the following URL, in which host is 

the FQDN of your GRC server, and port is the number you chose for the GRC 

managed server as you created a WebLogic domain. 

http://host:port/grc 

2. In the Navigator, select Setup and Administration → Setup → Manage 

Application Libraries. Click the Connectors tab. 

3. Click on Actions → Import. 
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4. A Import File pop-up window opens. Click on its Browse button. 

5. A file-upload dialog opens. In it, navigate to, and select, grc-connector-fusion-

8.6.4.4-SNAPSHOT-connectorsetup.zip, which is among the files in <grc_stage> 

directory (see “Downloading Files” on page 2-3 ). The path and name of the file 

then populate the field next to the Browse button in the Import File window.  

6. Click on the Upload File button. A pop-up message reports the status of the 

upload operation. Click on its OK button to clear it, and then click on the Close 

button in the Import File window. 

7. Log off of EGRCC and restart both the Administration Server and the GRC 

managed server. (Before doing so, be sure that the file tika-app-0.9.jar does not 

exist in the library subdirectory of your web application server). 

Create and Synchronize a Datasource 

Having uploaded the connector, you will need to configure a datasource that asso-

ciates your Fusion instance with the connector: 

1. Log on to GRC once again. 

2. Navigator → Setup and Administration → Setup → Manage Application 

Datasources. 

3. Click on Actions → Create New. A Create Datasource window opens. Enter the 

following values: 

• Datasource Name: Create a name for the datasource. 

• Description: Type a brief description of the datasource (optional). 

• Application Type: Select the type of business application to which you are 

connecting — in this case, Fusion. 

• Application Type Version: Select the version number of the Fusion instance 

to which you are connecting. 

• Default Datasource: Clear this check box. 

• Connector Type: For Fusion, select the Fusion connector you installed prior 

to working in this Manage Application Datasources page; the correct value 

is FusionConnector. 

4. Click the Save or Save and Close button. A row representing the datasource 

appears in the Manage Application Datasources grid. 

Finally, perform a data synchronization. In the Manage Application Datasources 

page, select the row you’ve just created for the Fusion datasource. Then either click 

on Actions → Synchronize Access, or click on the Synchronize button in the tool 

bar, then on a Run Now option, and then on an Access option. 
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Performing GRC Setup in Fusion Setup Manager 

Once the Fusion connector is installed, create an implementation project for GRC in 

Fusion Setup Manager (FSM).  

It’s assumed you are familiar with use of the Fusion Setup Manager, and with terms 

such as offerings, activities, tasks, and tasklists. If not, see the Oracle Fusion Appli-

cation Installation Guide and the Fusion Setup Manager Administrator's Guide.  

Portlet Registration 

Begin by ensuring that GRC is registered successfully in FSM. With FSM open, 

select Manage Portlet Registration under Implementations in the Tasks list (along 

the left of the interface). If the Manage Portlet Registration page does not show that 

GRC is registered, search for the “GRC Setup” Enterprise-Application and perform 

the portlet registration. Refer to the FSM Administrator’s Guide for instruction on 

how to perform portlet registration.  

Configure Offerings 

Because seeded offerings are not GRC-enabled by default, use a Configure 

Offerings page to enable GRC for the desired offering.  

1. Open the page: Select Configure Offerings under Implementations in the Tasks 

list. 

2. Click on the Select Feature Choices icon for the selected offering. For example, 

selecting the icon for the Customer Data Management offering displays a screen 

in which Governance, Risk and Compliance is listed. 

3. Select the Governance, Risk and Compliance entry — click on it so that a check 

mark appears in its check box.  

4. Click Save and Close.  

Implementation Project 

To display a GRC-Setup screen within FSM, create one or more implementation 

projects. You can base a project on the offerings enabled for GRC, or you can 

directly add GRC-Setup tasks (and tasklists). In either case, expanding a node will 

display a “Go to Task” icon for the selected task within the node, and clicking on it 

will render the GRC-Setup screen. 

Create a GRC Setup Master Record 

When you select a Go-to-Task icon, a Manage Setup Configurations screen enables 

you to create new GRC setup records or to search for, update, or delete existing records. 

Click the Create New icon to open a Configuration screen, in which you can create 

or register a new GRC Setup configuration master record.  

In this page, supply the following values: 

• Code: A code that uniquely identifies the master record being created, for 

example GRC_HCM. 
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• Name: Short name to describe the code, for example “GRC Setup Data for 

Human Capital Management.” 

• Description: Full description, for example, “This is the master record to define 

GRC Setup data to enforce separation of duties mandate for HCM.” 

Click the Save and Continue button to save the date prior to creating detail records. 

(Clicking on Save and Close returns you to the Manage Setup Configurations 

screen.) 

Create a GRC Setup Detail Record 

In the Configuration (master-record) screen, locate the Configuration Details panel 

and click on its Create New icon. A Configuration Details screen opens, in which 

you can create detail records for the master record. 

In this page, enter the following values: 

• Detail Name: Code that uniquely identifies the detail record being created. 

• Name: Short name to describe the code. 

• Description: Full description. 

• Status: Nonmandatory field to specify the status of the detail record. It typically 

contains Active or Inactive. 

• Services URL: http://host:port/grc/Services/GrcService, in which host is the 

FQDN of your GRC server, and port is the number you chose for the Admin-

istration Server as a WebLogic domain was created during GRC 8.6.4.3000 

installation.  

• User Name: The user name for a user granted the Admin role defined in the 

GRC UI. 

• Password: The password for the user granted the Admin role. 

• Confirm Password: The same password, entered for verification. 

• GRC Data Source: The name of the datasource configured under “Create and 

Synchronize a Datasource” on page 6-2. 

Click on Save and Close to return to the Configuration screen.  

Publish Configuration 

When detail records are complete, they must be published to Oracle Identity 

Management. From the Configuration (master-record) screen, select (click on) a 

detail record in the Configuration Details panel. Then select the Publish to OIM 

icon (it looks like an arrow pointing upwards).  

A Publish Configuration to OIM pop-up window opens. In it, enter these values: 

• Protocol: The protocol used for communication with the OIM managed server. 

Either https or t3s is recommended, but you may use any protocol the OIM 

managed server accepts. 

• OIM Hostname: The name of the host of the OIM managed server. 
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• Port Number: The port of the OIM managed server. 

• OIM User Name: The name of the user with admin role on the OIM managed 

server. (This user must be able to invoke MBean operations.) 

• OIM Password: The password of the OIM user. 
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