
 

[1] Oracle® Communications MetaSolv Solution
Network Grooming User's Guide 

Release 6.2.1 

E26372-02

February 2016



Oracle Communications MetaSolv Solution Network Grooming User's Guide, Release 6.2.1 

E26372-02

Copyright © 2016, Oracle and/or its affiliates. All rights reserved.

This software and related documentation are provided under a license agreement containing restrictions on 
use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your 
license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, 
transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse 
engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is 
prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If 
you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it 
on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT END USERS: Oracle programs, including any operating system, integrated software, 
any programs installed on the hardware, and/or documentation, delivered to U.S. Government end users 
are "commercial computer software" pursuant to the applicable Federal Acquisition Regulation and 
agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and 
adaptation of the programs, including any operating system, integrated software, any programs installed on 
the hardware, and/or documentation, shall be subject to license terms and license restrictions applicable to 
the programs. No other rights are granted to the U.S. Government.

This software or hardware is developed for general use in a variety of information management 
applications. It is not developed or intended for use in any inherently dangerous applications, including 
applications that may create a risk of personal injury. If you use this software or hardware in dangerous 
applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other 
measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages 
caused by use of this software or hardware in dangerous applications.

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of 
their respective owners.

Intel and Intel Xeon are trademarks or registered trademarks of Intel Corporation. All SPARC trademarks 
are used under license and are trademarks or registered trademarks of SPARC International, Inc. AMD, 
Opteron, the AMD logo, and the AMD Opteron logo are trademarks or registered trademarks of Advanced 
Micro Devices. UNIX is a registered trademark of The Open Group.

This software or hardware and documentation may provide access to or information on content, products, 
and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly 
disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle 
Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your 
access to or use of third-party content, products, or services.



iii 

Contents

Preface .................................................................................................................................................................    v

Audience.......................................................................................................................................................     v
Related Documents .....................................................................................................................................     v
Documentation Accessibility .....................................................................................................................    vi

1 Getting Started

About Network Grooming .....................................................................................................................   1-1
Network Grooming Rules ......................................................................................................................   1-2
Groom Types .............................................................................................................................................   1-3

Channel/Bandwidth Modification Groom (Facility Groom) ......................................................   1-3
Single-Facility Groom.................................................................................................................   1-3
Multiple-Facility Groom ............................................................................................................   1-3
Near-End Facility Groom...........................................................................................................   1-4
Far-End Facility Groom..............................................................................................................   1-4

Equipment Groom .............................................................................................................................   1-4
Network Grooming Preferences............................................................................................................   1-5

2 Creating a Network Groom Project

Creating a Facility Groom.......................................................................................................................   2-1
Creating an Equipment Groom .............................................................................................................   2-3

3 Grooming Scenarios

Scenario 1: Grooming a T3 Facility ......................................................................................................   3-1
Scenario 2: Grooming Eight T1 Circuits .............................................................................................   3-9
Scenario 3: Grooming Multiple T1 Equipment Port Assignments .............................................    3-18
Scenario 4: Grooming Equipment Port Assignments and Facility Assignments .....................    3-25
Scenario 5: Grooming a Virtual Connection by Inserting a Node in its Path ...........................    3-37
Scenario 6: Grooming Templated Physical Connections ..............................................................    3-48
Scenario 7: Grooming an NPA/NXX Switch ....................................................................................    3-53
Scenario 8: Grooming a Virtual Connection by Changing its Terminating Bandwidth.........    3-60



iv



v

Preface

This document provides information about Oracle Communications MetaSolv 
Solution (MSS) Network Grooming tool.

Audience
This document is intended for individuals responsible for managing high-volume 
equipment and connection moves within MetaSolv Solution.

Related Documents
For more information, see the following documents in Oracle Communications 
MetaSolv Solution 6.2.1 documentation set:

■ MSS Planning Guide: Describes information you need to consider in planning your 
MetaSolv Solution environment prior to installation.

■ Installation Guide: Describes system requirements and installation procedures for 
installing MSS.

■ MSS System Administrator’s Guide: Describes post-installation tasks and 
administrative tasks such as maintaining user security.

■ MSS Database Change Reference: Provides information on the database changes for 
the MetaSolv Solution 6.2.1 release. Database changes for subsequent maintenance 
releases will be added to this guide as they are released.

■ MSS Technology Module Guide: Describes each of the MetaSolv Solution technology 
modules.

■ MSS Data Selection Tool How-to Guide: Provides an overview of the Data Selection 
Tool, and procedures on how it used to migrate the product catalog, equipment 
specifications, and provisioning plans from one release of your environment to 
another.

■ MSS Operational Reports: Provides an overview of using Operational Reports and 
Business Objects with MSS, and procedures for running reports, updating 
universes, and simple maintenance. 

■ MSS CORBA API Developer’s Reference: Describes how MetaSolv Solution APIs 
work, high-level information about each API, and instructions for using the APIs 
to perform specific tasks.

■ MSS Custom Extensions Developer’s Reference: Describes how to extend the MetaSolv 
Solution business logic with custom business logic through the use of custom 
extensions.



vi

■ MSS XML API Developer’s Reference: Describes how to integrate MetaSolv Solution 
with other Oracle products, or with external applications, through the use of APIs. 

■ MSS Flow-through Packages Guide: Describes information and procedures you need 
to install and work with the flow-through packages provided by Oracle as an 
example of how to integrate MetaSolv Solution with ASAP for flow-through 
activation.

For step-by-step instructions for tasks you perform in MetaSolv Solution, log into the 
application to see the online Help.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or 
visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.
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1Getting Started

This chapter provides information about the Oracle Communications MetaSolv 
Solution Network Grooming tool.

About Network Grooming
Network grooming is the process of reassigning connections or ports from one or more 
facilities to new or alternative facilities. You use the Network Grooming tool to make 
these changes.

The Network Grooming tool lets you do the following:

■ Reassign connections or ports from underused facilities to free up ports for other 
services

■ Replace equipment assignments

■ Conduct traffic-flow type changes

The Network Grooming tool provides an easy, efficient way to manage high-volume 
equipment and connection moves within the MetaSolv Solution application.

The Network Grooming tool facilitates management of connection moves in support 
of a new switch, installation, and other related business functions. It supports 
single-facility and multiple-facility moves, equipment moves, and connection 
renaming and runs a mass facility reconciliation for all child connections affected.

All the child connections that are part of a grooming project are reconciled when 
modifications are made to the port address assignment or connection position 
assignment of the parent facility.

During a facility groom, when a parent facility is assigned or moved to a new port 
address, the child connections are reconciled to display the updated equipment 
information on the assignment block on the child connection’s Design Layout Report 
(DLR).

If child connections have Enabled Port Address assignments and the parent facility is 
unassigned or moved, the child connections are reconciled to display the target 
equipment information on the assignment block of the child connection’s DLR.

The Network Grooming tool supports the following types of circuits:

■ Facility

■ Special

■ Trunk

■ Telephone Number:
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– Working Telephone Number (WTN)

– Number Ported Out (NPOUT)

– Number Ported In (NPIN)

■ Next-Generation Network (NGN) Connection

■ Bandwidth

■ Virtual

The Network Grooming tool supports all template-based connections, including 
virtuals, enabling you to manage allocations to and from parent bandwidth 
connections. Unlike physical connections, any changes to virtual connections made 
within the grooming workspace will be reflected within the schematic design view of 
Connection Design when the grooming order has been processed.

Because virtual connections do not occupy a specific channel on a parent connection, 
the Network Grooming tool provides the ability to manage the individual allocation 
parameters (stored as custom attributes) for each parent to child relationship, when 
applicable.

To use this capability, use the Specify Virtual Channel right-click option within the 
Maintenance and Connection Hierarchy views of the Network Groom Maintenance 
window. Allocation parameters are also auto-generated during the Groom To step if 
the template is set up to provide this capability.

When making design changes for template-based connections within the grooming 
workspace, you are prevented from making assignments that would break the rules 
defined for the connection specification of the connection being modified.

In addition to managing virtual connection allocations to parent bandwidth 
connections, you can use the Network Grooming tool to allocate physical circuits to 
bandwidth connections using circuit emulation, which are represented by bandwidth 
blocks on the DLR within Connection Design.

Network Grooming Rules
For the network grooming process to be successful, do the following:

■ Begin with the highest-level connection, such as a T3 circuit, then a T1 circuit, and 
so on.

■ Replace facility assignments.

■ Replace equipment assignments.

■ Add any new facility or equipment assignments.

■ Delete the assignments that will not be used. If you leave these assignments in the 
workspace without a reassign, these assignment will be removed when the groom 
is processed.

■ Verify that the application has correctly determined the new connection ID. If not, 
you must rename the connection ID manually.

■ Remove unchanged assignments from the groom workspace.

■ Remove any lower-level connections from the groom workspace that must not be 
groomed.
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Groom Types
There are two basic types of grooms:

■ Channel/Bandwidth Modification Groom (Facility Groom)

■ Equipment Groom

Channel/Bandwidth Modification Groom (Facility Groom)
There are four types of Channel/Bandwidth Modification Groom (Facility Groom):

■ Single-Facility Groom

■ Multiple-Facility Groom

■ Near-End Facility Groom

■ Far-End Facility Groom

Single-Facility Groom
A single-facility groom is characterized by the following:

■ Lets you groom a facility that has only one parent.

■ A connection is represented by a single row.

■ The Connection ID column displays the connection identification of the 
connection being maintained.

■ The Unassign From Connection ID column represents the child circuit that will be 
removed after the groom has been processed, and the Ckt Pos (circuit position) 
column beside it represents the circuit position on the parent facility from which 
the groom originates.

■ The Assign To Connection ID column represents the new parent facility, and the 
Ckt Pos column beside it represents the circuit position.

■ The Service Type Code column represents the service-type code of the circuit.

Figure 1–1 shows the columns that are displayed in the Network Groom Current 
View for a single-facility groom.

Figure 1–1 Single-Facility Groom

Multiple-Facility Groom
A multiple-facility groom is characterized by the following:

■ Lets you groom a facility that has multiple parents.
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■ A connection rides more than one parent facility.

■ A row in the groom workspace represents each assignment. Both rows have the 
same connection ID as shown in the Connection ID column, but each has its own 
distinct unassign ID and connection position as shown in the Unassign From 
Connection ID and Ckt Pos columns, which represent the circuit position and the 
connection ID of the parent facilities, respectively.

■ Each row may be assigned to a different circuit position and facility. 

Figure 1–2 shows the columns that are displayed in the Network Groom Current 
View for a multiple-facility groom.

Figure 1–2 Multiple-Facility Groom

Near-End Facility Groom
In a near-end facility groom:

■ You can groom just one leg of the path.

■ A connection’s equipment assignment is selected.

■ All facility assignments for both the parent and the child connection are included 
in the groom workspace.

Far-End Facility Groom
In a far-end facility groom:

■ You can groom an entire path from one terminating point to the other.

■ A connection is selected and all the facility assignments for the parent connection 
are included in the groom workspace.

■ Only the selected assignment for the child connection comes into the groom 
workspace.

Equipment Groom
Equipment grooms are performed when a circuit is moved from one equipment port 
to another (for example, a T3 from one DACS to another DACS). All equipment 
grooms are near-end grooms and therefore only populate the workspace with the 
circuits terminating at the mounting positions/port addresses that you selected in the 
Network Groom Maintenance window. No child circuits are included into the 
workspace.

Note: Far-end equipment grooms do not exist.
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Network Grooming Preferences
There are preferences in the MetaSolv Solution application that govern the Network 
Grooming tool. 

The following preferences are located under Preferences - Equipment - Groom:

Note: An asterisk (*) beside the preference denotes that it is a system 
preference.

■ Convert EPAs to Facility Assignments: When set to N (the default), any 
connections with enabled port addresses are not accepted for assignment when 
equipment is reassigned. When set to Y, any connections with enabled port 
addresses are overwritten and made available for facility assignments when 
equipment is reassigned.

■ Default groom selection: This preference applies only to facility grooms. 

This preference has the following options:

– Near End: If you select this option, the Near End option is automatically 
selected in the New Groom Facility window. This makes near-end grooming 
the default option each time a new groom facility is started. For near-end 
grooms, the parent facility selected for grooming is the only facility included 
in the groom. 

– Far End: If you select this option, the Far End option is automatically selected 
in the New Groom Facility window. This makes far-end grooming the default 
option each time a new groom facility is started. For far-end grooms, 
additional facility assignments from downstream segments will be impacted 
by the groom and therefore must be included in the groom project.

■ Groom query defaults: If you select the Created (the default) check box, only the 
created groom projects are included for searching in the Network Groom Search 
window. Select any of the following check boxes to include other search criteria by 
default when searching for a groom project:

– Completed

– Completed w/ errors

– On Order

– Processed

– Processed w/ errors

– Processing

■ * Maximum number of ports added to workspace: Enter a numeric value that 
represents the maximum number of ports that can be added to a workspace.

■ Maximum Number to Process in Foreground: Enables you to specify the 
maximum number of facilities and connections to be processed in the foreground 
during a groom. If this number is exceeded, processing occurs in the background. 
The default is 100.

■ Remove or disconnect blocks?: When set to Remove, the previous assignments 
that are disconnected as a result of the groom are deleted from the design lines. 
When set to Disconnect, the previous assignments remain on the design lines and 
are indicated by a D on each row representing a disconnected assignment.
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■ Reserve connection positions when target facility is selected: When set to Yes, 
the "groom to" positions are automatically reserved as the grooming project is 
created. When set to No, the terminating positions are not reserved until the ISR is 
generated.

■ * Update ckr when processing groom: When set to N (the default), the application 
does not update the ckr field in the From Order Confirmation table of an ASR. 
When set to Y, the application updates the ckr field in the From Order 
Confirmation table of an ASR.

The following preferences are located under Preferences - Equipment - Groom - CLF 
Facility Designation:

■ * Starting facility designation range for DS0 circuits = 1: If the Auto-Populate 
CLF Designation preference is not set, this range is used for DS0 circuits when 
grooming.

■ * Starting facility designation range for DS1 circuits = 101: If the Auto-Populate 
CLF Designation preference is not set, this range is used for DS1 circuits when 
grooming.

■ * Starting facility designation range for DS3 circuits = 101: If the Auto-Populate 
CLF Designation preference is not set, this range is used for DS3 circuits when 
grooming.

■ * Starting facility designation range for other circuits = 101: If the Auto-Populate 
CLF Designation preference is not set, this range is used for circuits other than 
DS0, DS1, and DS3 when grooming.

Note: The Auto-Populate CLF Designation preference is located 
under Preferences - Service Request - Connection. When this 
preference is set to N (the default), any CLF facility designation can be 
entered. When this preference is set to Y, the facility designation is 
auto-populated, but you can change it if the connection is reopened.
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2Creating a Network Groom Project

This chapter provides basic information about creating a network groom project. See 
"Grooming Scenarios" for detailed information about different scenarios involved in 
the network grooming process.

Creating a Facility Groom
To create a facility groom:

1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

2. Click the Add New link.

The Groom Request Types window is displayed.

3. Select Facility.

4. Click OK.

The New Groom Facility window is displayed.

5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.

6. Select the Facility option and click Search.

The Connection Hierarchy window is displayed.

7. Specify the search criteria and click Search.

8. Select the Far End or Near End option for the type of groom you want to perform.

9. Select the facility from the list.

10. Click Add.

The status of the facility changes to Pending Groom.

Note: You can select multiple facilities from multiple source 
locations. Continue selecting facilities and clicking Add. You can add 
more facilities later when in the Network Groom Maintenance 
window by selecting Add Facility from the Options menu.

11. Click OK.

12. In the Network Groom Maintenance window, select the Facility option.

13. Click Search.
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The Connection Hierarchy Search window is displayed.

14. Specify the search criteria and click Search.

15. On the facility in the list view, select the connections you do not want included in 
the groom, and then click the Delete button at the bottom of the window.

16. On the facility in the list view, select all the connections you want included in the 
groom.

Note: The connections that are not selected during the groom are 
disconnected. To exclude connections from the groom and leave them 
connected, delete them from the list.

17. On the facility in the hierarchical view, right-click the connection and select 
Groom To.

You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

18. From the Options menu, select Validate.

19. From the File menu, select Save.

20. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

21. If your project is not already listed, click Modify Search.

22. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

23. Select the groom project, and from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

24. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.

b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.
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25. Select a provisioning plan containing the Design Layout Report Date (DLRD) (or 
similar) task and Due Date (DD) task at a minimum and assign the tasks to the 
appropriate work queues and click OK.

26. Complete the task preceding the DLRD (or similar) task.

27. Double-click the DLRD (or similar) task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

28. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

A confirmation message is displayed.

29. Click Yes.

The network groom project is processed.

30. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

31. From the Options menu, select Group Print. 

The Print window is displayed.

32. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

33. Click OK.

34. Complete the DLRD (or similar) task.

35. Complete the DD task.

Creating an Equipment Groom
To create an equipment groom:

1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

2. Click the Add New link.

The Groom Request Types window is displayed.

3. Select Equipment.

4. Click OK.

The New Groom Equipment window is displayed.

5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.
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6. Select the Equipment option.

7. In the Network Location field, enter a network location and click Search.

8. Select the equipment from the list by selecting the check box to its left.

9. Click Add.

Note: You can select multiple equipment from multiple source 
locations. Enter another network location to retrieve a list of available 
equipment at the new location. Continue selecting equipment and 
clicking Add. You can add more equipment later when in the Network 
Groom Maintenance window by selecting Add Equipment from the 
Options menu.

10. Click OK.

11. In the Network Groom Maintenance window, select the Equipment option and 
click Search.

The Equipment Inventory Search window is displayed.

12. In the Network Location field, enter a network location.

13. Click Search.

14. On the equipment in the list view, select the connections you do not want included 
in the groom, and then click Delete at the bottom of the window.

15. On the equipment in the list view, select all connections you want included in the 
groom.

Note: The connections that are not selected during the groom are 
disconnected. To exclude connections from the groom and leave them 
connected, delete them from the list.

16. On the equipment in the hierarchical view, right-click the circuit and select Groom 
To.

You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

17. From the Options menu, select Validate.

18. From the File menu, select Save.

19. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

20. If your project is not already listed, click Modify Search.

21. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 



Creating an Equipment Groom

Creating a Network Groom Project 2-5

22. Select the groom project and, from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

23. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.

b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.

24. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.

25. Complete the task preceding the DLRD (or similar) task.

26. Double-click the DLRD task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

27. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

A confirmation message is displayed.

28. Click Yes.

The network groom project is processed.

29. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

30. From the Options menu, select Group Print. 

The Print window is displayed.

31. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

32. Click OK.



Creating an Equipment Groom

2-6 MetaSolv Solution Network Grooming User's Guide

33. Complete the DLRD (or similar) task.

34. Complete the DD task.
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3Grooming Scenarios

This chapter demonstrates how to use the Network Grooming tool by walking you 
through the following scenarios:

■ Scenario 1: Grooming a T3 Facility

■ Scenario 2: Grooming Eight T1 Circuits

■ Scenario 3: Grooming Multiple T1 Equipment Port Assignments

■ Scenario 4: Grooming Equipment Port Assignments and Facility Assignments

■ Scenario 5: Grooming a Virtual Connection by Inserting a Node in its Path

■ Scenario 6: Grooming Templated Physical Connections

■ Scenario 7: Grooming an NPA/NXX Switch

■ Scenario 8: Grooming a Virtual Connection by Changing its Terminating 
Bandwidth

Scenario 1: Grooming a T3 Facility 
This scenario involves grooming a T3 facility from one DS3 equipment port to another 
DS3 equipment port.

The T3 facility in this example has two equipment assignments – one assignment to 
the GLPTMS55BB3 switch and another assignment to the GLPTMS55K05 DACS. In 
this network grooming project, the assignment to the K05 DACS will be moved to the 
K03 DACS. All T1 child circuits will follow. Because all circuits affected (T3 parent and 
T1 children) are CLF format, all connection IDs will change as a result of the groom.

Figure 3–1 illustrates this scenario.
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Figure 3–1 Grooming a T3 Facility

Figure 3–2 shows the Equipment Inventory views for the K05 DACS and K03 DACS 
before the groom process.

Figure 3–2 Equipment Inventory Views for the K05 DACS and K03 DACS Before the Groom

To groom a T3 facility from one DS3 equipment port to another DS3 equipment port:

1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

2. Click the Add New link.

The Groom Request Types window is displayed.

3. Select Equipment.

4. Click OK.

The New Groom Equipment window is displayed.
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5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.

6. Select the Equipment option.

7. In the Network Location field, do one of the following:

■ Enter the 11-byte CLLI (for example, GLPTMS55K05) and click Search to 
retrieve the installed equipment associated to the K05 DACS.

■ Enter the 8-byte CLLI (for example, GLPTMS55) and click Search to retrieve 
all installed equipment in the GLPTMS55 building. 

8. Expand the higher-level equipment where the current assignment appears until a 
check box for the port is displayed. Select the check box of the DS3 port (or card) 
to be included in this groom project and click OK.

9. Click Add.



Note: If you want to add ports from multiple locations, click the Add 
button instead of the OK button to add the selected ports to the groom 
project without proceeding to the next screen. 

For this scenario, GLPTMS55K05 is the only location from which you 
want to add ports, so you can click the OK button instead of the Add 
button. The Add button is used for facility grooms and for multiple 
network location grooms.

Scenario 1: Grooming a T3 Facility
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10. Click OK.

Both of the equipment assignments for this T3 facility are added to the groom 
project: K05 DACS assignment and BB3 switch assignment. 

11. The BB3 switch port assignment should not be groomed.

Note: It is important to remove any assignments that should not be 
groomed from the groom project. In this scenario, if the BB3 switch 
assignment is not deleted from the project and no port is selected in 
the hierarchical view for this assignment, the BB3 equipment port 
assignment will be removed when the groom is processed.

12. On the equipment in the list view, select the BB3 equipment port assignment and 
click Delete.

A confirmation message is displayed prompting you to confirm if you want to 
delete the selected row.

13. Click Yes.

The BB3 equipment port assignment is removed from the groom project.

14. On the Network Groom Maintenance window, select the Equipment option.

15. Click Search.

The Equipment Inventory Search window is displayed.

16. In the Network Location field, enter a network location.

17. Click Search.

For this scenario, the equipment associated to the GLPTMS55K03 DACS is 
displayed. Expand the K03 equipment until you locate the appropriate port.
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18. Select the check box beside the port you want included in this groom project and 
click OK.

19. On the equipment in the list view, select the port assignment that you want 
included in the groom.

Note: The connections that are not selected during the groom are 
disconnected. To exclude connections from the groom and leave them 
connected, delete them from the list.

20. On the equipment in the hierarchical view, right-click the port under the K03 
equipment and select Groom To.

In the list view, a check mark appears beside the port. In the hierarchical view, the 
port displays a Pending Groom status.
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To view more details of this groom, select the Current button in the Select View 
section in the top left corner of the screen.

21. For this scenario, the Z Location in the CLF connection ID should change from 
GLPTMS55K05 to GLPTMS55K03. Right-click on the row displayed in the current 
view and select Rename Circuit.

22. Change the Term Location GLPTMS55K05 to GLPTMS55K03. 

A confirmation message is displayed.

23. Click Yes.

In this scenario, the CLF Designator at the beginning of the connection ID should 
not change as result of this groom. 

24. To change the CLF Designator, select 101 in the CLF Desig field and replace it with 
50005.
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A confirmation message is displayed.

25. Click Yes.

You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

26. From the Options menu, select Validate.

27. From the File menu, select Save.

28. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

29. If your project is not already listed, click Modify Search.

30. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

31. Select the groom project and, from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

32. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.

b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.

33. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.

34. Complete the task preceding the DLRD (or similar) task.

35. Complete the DLRD (or similar) task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

36. From the Options menu, select Process Groom.



Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

Scenario 1: Grooming a T3 Facility
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A confirmation message is displayed.

37. Click Yes.

In this scenario, the T3 on this groom project has child T1 circuits riding it. An 
exception message appears informing the user that the connection IDs have been 
changed for the child circuits as well.

38. Click OK.

The network groom project is processed.

39. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

40. From the Options menu, select Group Print. 

The Print window is displayed.

41. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

42. Click OK.

43. Complete the DLRD (or similar) task.

After completing the DLRD (or similar) task, but before completing the DD task, 
the port on the K05 equipment will show a Pending Disconnect status and the 
port on the K03 equipment will show a Pending status.
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44. Complete the DD task.

After completing the DD task, the port on the K05 equipment shows an 
Unassigned status and the port on the K03 equipment shows an In Service status.

Scenario 2: Grooming Eight T1 Circuits 
This scenario involves grooming eight T1 circuits from one existing T3 facility to 
another existing T3 facility. 

In this scenario, three of the T1s are going from Destin, FL, to the BB2 switch in 
Gulfport, MS. The other five are going from Fort Walton Beach, FL, to the same BB2 
switch in Gulfport. All eight T1s are assigned to channels of a T3 facility from 
GLPTMS55K04 to GLPTMS55BB2. The BB2 switch will be taken down; therefore, all 
eight of the T1 circuits will be moved to the BB3 switch from an existing T3 facility 
from GLPTMS55K04 to GLPTMS55BB3.

Figure 3–3 illustrates this scenario.
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Figure 3–3 Grooming a T3 Facility

Figure 3–4 shows the Equipment Inventory views for the GLPTMS55K04 DACS before 
the groom process. The T1 circuits are assigned to the T3 facility terminating at the BB2 
switch. There are no assignments to the T3 facility terminating at the BB3 switch.

Figure 3–4 Connection Hierarchy WIndow Before the Groom Process
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To groom eight T1 circuits from one existing T3 facility to another existing T3 facility:

1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

2. Click the Add New link.

The Groom Request Types window is displayed.

3. Select Facility.

4. Click OK.

The New Groom Facility window is displayed.

5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.

6. Select the Facility option.

7. Click Search.

The Connection Hierarchy Search window is displayed.

8. Select the Facility check box.

9. Specify the search criteria for the facility and click Search. In this scenario, in the 
Identification field, enter GLPTMS55BB2.

The New Groom Facility window is displayed.

10. If more than one facility is retrieved, select the correct facility from the list to be 
assigned to the groom project. 

11. Select the Far End or Near End option for the type of groom you want to perform.

12. Click Add.

The status of the facility changes to Pending Groom. 

13. Click OK.

All the circuits assigned to the T3 facility added above are displayed in the 
Network Groom Maintenance view.

14. Select the Facility option.
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15. Click Search.

The Connection Hierarchy Search window is displayed.

16. Select the Facility check box.

17. Specify the search criteria and click Search to retrieve the T3 facility. In this 
scenario, in the Identification field, enter GLPTMS55BB3.

If all T1s are selected in the list view on the left, and channel 2 of the T3 is selected 
in the hierarchical view on the right, all eight T1s would be assigned consecutively 
to channels 2 through 9. In this scenario, the T1s from Destin will be groomed to 
channels 2 through 4, and the T1s from Fort Walton Beach will be groomed to 
channels 6 through 10; this must be done in two steps.

18. In the list view, select the T1s that should be groomed. In the hierarchical view, 
select the first channel on the facility, and then right-click and select Groom To.

The Destin T1s are in Pending Groom status on channels 2 through 4 in the 
hierarchical view. 

19. Select the five Fort Walton Beach T1s in the list view, select channel 6 of the facility 
in the hierarchical view, right-click and select Groom To to groom these five T1s to 
channels 6 through 10.
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Check marks appear beside all the eight T1 circuits.

20. If this groom project is not due for another 3 or 4 weeks, you must reserve these 
channels on the T3 facility in the hierarchical view. To reserve the channels, click 
the Reservations icon (red box with an “x” at the bottom of the window).



Note: If you do not reserve the channels (or ports), reservations are 
not made until the ISR is created. 
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21. Select the Current button on the Select View section to view more details of the 
groom project.
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22. Scroll to the right to view the New Connection ID, CLF Designator, Orig 
Location, and Term Location fields in the current view.

The Term Location changed from GLPTMS55BB2 to GLPTMS55BB3 automatically. 
Also, the CLF Designator in this example is correct (it will not change as a result of 
this groom). Check the information appearing in the New Connection ID column 
to verify that the entries accurately reflect the desired connection IDs. In this case, 
the new connection IDs are correct and need no modification.

You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

23. From the Options menu, select Validate.

24. From the File menu, select Save.

25. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

26. If your project is not already listed, click Modify Search.

27. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

28. Select the groom project and, from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

29. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.
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b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.

30. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.

31. Complete the task preceding the DLRD (or similar) task.

32. Double-click the DLRD (or similar) task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

33. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

A confirmation message is displayed.

34. Click Yes.

The network groom project is processed.

35. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

36. From the Options menu, select Group Print. 

The Print window is displayed.

37. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

38. Click OK.

39. Complete the DLRD (or similar) task.

After completing the DLRD (or similar) task, but before completing the DD task, 
the T1 circuits on the T3 facility to the BB2 switch show a Pending Disconnect 
status and the T1 circuits on the T3 facility to the BB3 switch show a Pending 
status.



Scenario 2: Grooming Eight T1 Circuits

Grooming Scenarios 3-17

40. Complete the DD task.

After completing the DD task, the T1 circuits on the T3 facility to the BB2 switch 
show an Unassigned status and the T1 circuits on the T3 facility to the BB3 switch 
show an In Service status.
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Scenario 3: Grooming Multiple T1 Equipment Port Assignments 
This scenario demonstrates how multiple equipment port assignments can be 
groomed on the same project. In this scenario, four T1 circuits will be unassigned from 
the GLPTMS55DS0 switch in Gulfport and assigned to the BILXMSEDDS0 switch in 
Biloxi. These circuits are in CLS format; therefore, the connection IDs do not change as 
a result of the groom. 

Figure 3–5 illustrates this scenario.
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Figure 3–5 Equipment Port Grooming

To groom a T1 equipment port assignments from one switch to another switch:

1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

2. Click the Add New link.

The Groom Request Types window is displayed.

3. Select Equipment.

4. Click OK.

The New Groom Equipment window is displayed.

5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.

6. Select the Equipment option.

7. In the Network Location field, do one of the following:

■ Enter the 11-byte CLLI (for example, GLPTMS55DS0) and click Search to 
retrieve the installed equipment associated to the DS0 DACS.

■ Enter the 8-byte CLLI (for example, GLPTMS55) and click Search to retrieve 
all installed equipment in the GLPTMS55 building. 

8. Expand the higher-level equipment until a check box for the port is displayed in 
the hierarchical view. Select the check box beside the DS3 port (or card) to be 
included in this groom project and click OK.
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9. Click Add.

Note: If you want to add ports from multiple locations, click the Add 
button instead of the OK button to add the selected ports to the groom 
project without proceeding to the next screen. 

For this scenario, GLPTMS55DS0 is the only location from which you 
want to add ports, so you can click the OK button instead of the Add 
button. The Add button is used for facility grooms and for multiple 
network location grooms.

10. Click OK.

The T1 equipment assignments to be groomed now appear on the left in the list 
view of the Network Groom Maintenance window. 

11. In the Network Groom Maintenance window, select the Equipment option.

12. Click Search.

The Equipment Inventory Search window is displayed.

13. In the Network Location field, enter BILXMSEDDS0.
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14. Click Search.

For this scenario, the equipment associated to BILXMSEDDS0 is displayed. 
Expand the equipment until you locate the appropriate port.

15. Select the check box beside the port you want included in this groom project and 
click OK.

16. On the equipment in the list view, select the port assignment that you want 
included in the groom.

Note: The connections that are not selected during the groom are 
disconnected. To exclude connections from the groom and leave them 
connected, delete them from the list.

17. On the equipment in the hierarchical view, right-click the port under the 
BILXMSEDDS0 switch and select Groom To.

A notification message is displayed informing you that there were not enough 
compatible positions available to assign all of the selected circuits. The message 
prompts you to select another destination for the remaining assignments. 

This is because four assignments were highlighted in the list view on the left 
(indicating they will be groomed to sequential ports), and the port selected in the 
hierarchical view on the right is on a card with only two ports.

18. Click OK.

19. The first two ports in the list view are groomed only to two ports on the card 
selected in the previous step. The two remaining two ports will still be highlighted 
in the list view on the left. To groom these ports sequentially following the other 
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two ports, select the next card in the hierarchical view, right-click and select 
Groom To.

In the list view, red icons appear beside the ports indicating that the Reservations 
icon was selected for these ports.

20. To view more details of this groom, select the Current option in the Select View 
section in the top left corner of the screen.

The Orig Location column is automatically changed to BILXMSED, which is the 
network location for Biloxi, the terminating site.
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You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

21. From the Options menu, select Validate.

22. From the File menu, select Save.

23. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

24. If your project is not already listed, click Modify Search.

25. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

26. Select the groom project and, from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

27. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.

b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.

28. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.

29. Complete the task preceding the DLRD (or similar) task.

30. Double-click the DLRD (or similar) task.
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The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

31. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

A confirmation message is displayed.

32. Click Yes.

The network groom project is processed.

33. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

34. From the Options menu, select Group Print. 

The Print window is displayed.

35. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

36. Click OK.

37. Complete the DLRD (or similar) task.

After completing the DLRD (or similar) task, but before completing the DD task, 
the ports of the Gulfport switch (GLPTMS55DS0) show a Pending Disconnect 
status and the ports of the Biloxi switch (BILXMSEDDS0) show a Pending status.

38. Complete the DD task.

After completing the DD task, the ports of the Gulfport switch (GLPTMS55DS0) 
show an Unassigned status and the ports of the Biloxi switch (BILXMSEDDS0) 
show an In Service status.
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Scenario 4: Grooming Equipment Port Assignments and Facility 
Assignments

This scenario involves grooming equipment port assignments and facility assignments 
on the same groom project.

In this scenario, four T1 circuits are groomed. Each T1 circuit has two equipment 
assignments and one facility assignment: 

■ The equipment assignment to Gulfport K02 DACS [GLPTMS55K02].

■ The equipment assignment to Gulfport K04 DACS [GLPTMS55K04].

■ The facility assignment to T3 parent facility from Gulfport K04 DACS 
[GLPTMS55K04] to Gulfport BB1 switch [GLPTMS55BB1].

Only two of the three assignments will be groomed:

■ The equipment port assignments to the GLPTMS55K02 DACS will be groomed to 
equipment ports on the GLPTMS55K05 DACS.

■ The facility assignments to the T3 parent facility from the K04 DACS to the BB1 
switch will be groomed to a separate T3 facility from the K04 DACS to the BB2 
switch.

Figure 3–6 illustrates this scenario.
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Figure 3–6 Equipment and Facility Groom

To groom equipment port assignments and facility assignments on the same groom 
project:

1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

2. Click the Add New link.

The Groom Request Types window is displayed.

3. Select Facility.

4. Click OK.

The New Groom Facility window is displayed.

5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.

6. Select the Facility option.

7. Click Search.

The Connection Hierarchy Search window is displayed.

8. Select the Facility check box.

9. Specify the search criteria for the facility and click Search. In this scenario, in the 
Identification field, enter GLPTMS55BB1.

The New Groom Facility window is displayed.
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10. If more than one facility is retrieved, select the correct facility from the list to be 
assigned to the groom project. 

11. Select the Far End or Near End option for the type of groom you want to perform.

12. Click Add.

The status of the facility changes to Pending Groom. 

13. Click OK.

The four facility assignments (for the four T1 circuits riding the parent T3 facility) 
now appear in the list view of the Network Groom Maintenance window.

14. From the Options menu, select Add Equipment.

The New Groom Equipment window is displayed.

15. In the Network Location field, do one of the following:

■ Enter the 11-byte CLLI (for example, GLPTMS55K02) and click Search to 
retrieve the installed equipment associated to the K02 DACS.

■ Enter the 8-byte CLLI (for example, GLPTMS55) and click Search to retrieve 
all installed equipment in the GLPTMS55 building. 

16. Expand the higher-level equipment until a check box for the port is displayed in 
the list view. Select the check box beside the DS1 port (or card) to be included in 
this groom project and click OK.
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17. Click Add.

Note: If you want to add ports from multiple locations, click the Add 
button instead of the OK button to add the selected ports to the groom 
project without proceeding to the next screen. 

For this scenario, GLPTMS55K02 is the only location from which you 
want to add ports, so you can click the OK button instead of the Add 
button. The Add button is used for facility grooms and for multiple 
network location grooms.

18. Click OK.
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The first four T1s on this list are the facility assignments that should be groomed 
from one T3 facility (to the BB1 switch) to another T3 facility (to the BB2 switch). 
The next four items are the equipment assignments to the K02 DACS, which will 
be groomed to the K05 DACS. The last four assignments are the equipment 
assignments to the K04 DACS. These should remain intact and should not be 
groomed as part of this project. These must be deleted from the project so the 
assignments will not be removed when the groom is processed. 

19. To remove the assignments that should not be groomed from the groom project (in 
this scenario, the equipment assignments to the K04 DACS), select the assignments 
to be removed and click the Delete button (eraser icon) at the bottom of the 
window.

A confirmation message is displayed prompting you to confirm if you want to 
delete the selected four rows.

20. Click Yes to All to confirm that all four selected rows should be deleted from the 
groom project.

21. To select the facility to which you want to groom the four facility assignments, 
select the Facility option and click Search in the Select Search Mode section. 

The Connection Hierarchy Search window is displayed.

22. Select the Facility check box.

23. Specify the search criteria for the facility and click Search. In this scenario, in the 
Identification field, enter GLPTMS55BB2.

The New Groom Facility window is displayed.

24. If more than one facility is retrieved, select the correct facility from the list to be 
assigned to the groom project. 

25. Select the Far End or Near End option for the type of groom you want to perform.

26. Click Add.

The status of the facility changes to Pending Groom. 

27. Click OK.

The four facility assignments (for the four T1 circuits riding the parent T3 facility) 
now appear in the hierarchical view of the Network Groom Maintenance window.
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28. Select the four facility assignments in the list view on the left (assuming the four 
T1s should be assigned to sequential circuit positions on the T3 facility).

29. Right-click on the first circuit position in the hierarchical view and select Groom 
To.

The four facility assignments display a check mark in the list view (indicating that 
corresponding circuit positions have been selected). The circuit positions in the 
hierarchical view show a Pending Groom status.

30. To specify the equipment ports for moving the equipment assignments from 
GLPTMS55K02 to GLPTMS55K05, select the Equipment option and click Search 
in the Select Search Mode section.

The Equipment Inventory Search window is displayed.

31. In the Network Location field, do one of the following:
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■ Enter the 11-byte CLLI (for example, GLPTMS55K05) and click Search to 
retrieve the installed equipment associated to the K05 DACS.

■ Enter the 8-byte CLLI (for example, GLPTMS55) and click Search to retrieve 
all installed equipment in the GLPTMS55 building. 

32. Expand the higher-level equipment and select the check box beside the 
appropriate port.

33. Click OK.

34. Right-click on the first port in the hierarchical view and select Groom To.

Because four ports are selected in the list view and the port specified in the 
hierarchical view is on an equipment with fewer than four ports, a notification 
message is displayed informing you that there are not enough compatible 
positions available to assign all of the selected circuits. The message prompts you 
to select another destination for the remaining assignments.

35. Click OK.

36. In the hierarchical view, right-click the first port and select Groom To.
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37. Click OK.

All the circuit positions and ports in the list view have check marks indicating 
circuit positions and ports in the hierarchical view have been specified. All the 
ports in the hierarchical view show a Pending Groom status.

38. To view more details of this groom, select the Current option in the Select View 
section in the top left corner of the screen.
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The Orig Location column automatically changed to GLPTMS55BB2. The Term 
Location column did not automatically change to GLPTMS55K05. You must 
manually change the Term Location column.

39. Change the Term Location column of the first T1 to GLPTMS55K05 and click Yes 
on the confirmation message. GLPTMS55K05 is the Z Location in the CLF format 
connection ID for all four T1s on this network groom project.

The A and Z CLLIs in the CLF format connection IDs in the New Connection ID 
column appear to be correct. However, the CLF Designators at the beginning of 
the connection IDs need to be modified so that they appear as they did prior to the 
groom. 
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For each of the T1s with enabled CLF Desig fields on this screen, enter the correct 
CLF Designator and click Yes on the confirmation message to rename the circuit.

After renaming all four connection IDs, check the Assign From and Assign To 
fields for facility and equipment assignments for accuracy. Also, check the New 
Connection ID column again.

You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

40. From the Options menu, select Validate.
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41. From the File menu, select Save.

42. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

43. If your project is not already listed, click Modify Search.

44. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

45. Select the groom project and, from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

46. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.

b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.

47. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.

48. Complete the task preceding the DLRD (or similar) task.

49. Double-click the DLRD (or similar) task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

50. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

A confirmation message is displayed.

51. Click Yes.

The network groom project is processed.

52. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.
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53. From the Options menu, select Group Print. 

The Print window is displayed.

54. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

55. Click OK.

56. Complete the DLRD (or similar) task.

After completing the DLRD (or similar) task, but before completing the DD task:

■ The ports on the K02 DACS show a Pending Disconnect status and the ports 
on the K05 DACS show a Pending status.

■ The circuit positions of the facility to the BB1 switch show a Pending 
Disconnect status and the circuit positions of the facility to the BB2 switch 
show a Pending status.

57. Complete the DD task.

After completing the DD task:

■ The ports on the K02 DACS show an Unassigned status and the ports on the 
K05 DACS show an In Service status.
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■ The circuit positions of the facility to the BB1 switch show an Unassigned 
status and the circuit positions of the facility to the BB2 switch show an In 
Service status.

Scenario 5: Grooming a Virtual Connection by Inserting a Node in its Path
This scenario demonstrates how you can utilize the Network Grooming tool to 
enhance the existing design of a virtual connection. It shows you how to replace an 
existing bandwidth assignment between two nodes with two new bandwidth 
assignments connecting to and from a third node between the existing two nodes, 
essentially inserting the third node within the virtual connection’s design.

As shown in Figure 3–7, the DEMO VC/MSS INCORPORATED/AUSTIN/DALLAS 
virtual connection will be unassigned from the 101/1GB/AUSTTX01/AUSTTX02 
bandwidth connection, and then assigned to the two bandwidth connections, 
101/1GB/AUSTTX01/AUSTTX03 and 101/1GB/AUSTTX02/AUSTTX03, connecting 
the AUSTIN 03 node to these two existing nodes.
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Figure 3–7 Inserting a Node Into a Virtual Connection's Design

Figure 3–8 shows the DEMO VC/MSS INCORPORATED/AUSTIN/DALLAS virtual 
connection riding on the 101/1GB/AUSTTX01/AUSTTX02 bandwidth before the 
groom process.

Figure 3–8 Schematic Design Before the Virtual Connection Is Groomed

To enhance the design of a virtual connection by replacing a single bandwidth 
assignment with two bandwidth assignments using the Network Grooming tool:

1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.
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2. Click the Add New link.

The Groom Request Types window is displayed.

3. Select Facility.

4. Click OK.

The New Groom Facility window is displayed.

5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.

6. Select the Facility option.

7. Click Search.

The Connection Hierarchy Search window is displayed.

8. Select the Virtual check box.

9. Specify the search criteria for the virtual connection and click Search. In this 
scenario, in the Identification field, enter LIKE %MSS INC% and click Search.

The New Groom Facility window displays the retrieved data.

10. Within this project, only the DEMO VC/MSS 
INCORPORATED/AUSTIN/DALLAS virtual connection will be groomed. To add 
this connection to the Network Grooming workspace, either right-click the 
connection and select Add To Groom or click the Add button. The status of the 
connection changes to Pending Groom. 

Similarly, you can query for more connections and place them in Pending Groom 
status. All the connections will be loaded into the new network grooming project. 
In scenarios where you want to groom all of the virtual connections from one 
bandwidth connection, you can query for the bandwidth connection and place it 
in Pending Groom status instead of querying for every child virtual connection 
individually. This automatically loads the workspace with all of the child virtual 
connections.

11. Select the Far End or Near End option for the type of groom you want to perform.

A near-end groom loads the workspace only with the child assignments to the 
selected parent, whereas a far-end groom loads every child connection’s entire 
design path, allowing you to easily select and modify only the portion of the 
design you want to change.

12. Click OK.

The application creates the Network Grooming workspace and loads it with the 
selected data. For our project, the DEMO VC/MSS 
INCORPORATED/AUSTIN/DALLAS virtual connection is brought into the 
workspace. Because you performed a far-end groom, the single connection is 
represented as nine distinct rows within the workspace, each row representing one 
bandwidth assignment along its design trail, as identified by the parent 
Connection IDs within the Unassign From Connection ID column.
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13. Select the Facility option.

14. Click Search.

The Connection Hierarchy Search window is displayed.

15. Select the Bandwidth check box.

16. Specify the search criteria to retrieve the two bandwidth connections to which you 
want to groom the virtual connection and click Search. In this scenario, in the 
Identification field, enter LIKE 101/1GB%.

The 101/1GB/AUSTTX01/AUSTTX03 and 101/1GB/AUSTTX02/AUSTTX03 
bandwidth connections are displayed along with many other connections within 
the Connection Hierarchy section of the Network Groom Maintenance window.
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17. To groom the virtual connection from the existing bandwidth connection to the 
first of the two bandwidth connections taking its place, select the DEMO VC/MSS 
INCORPORATED/AUSTIN/DALLAS virtual connection row containing 101/1 
GB/AUSTTX01/AUSTTX02 in the Unassign From Connection ID column in the 
list view of the Network Groom Maintenance window.

Note:  If you want to groom multiple child connections from this 
same bandwidth connection, sort by the Unassign From Connection 
ID column, and then multi-select all of the rows representing the child 
connection assignments to this parent.

18. Right-click the 101/1GB/AUSTTX01/AUSTTX03 bandwidth connection in the 
hierarchical view and select Groom To.

Note: When multiple rows are selected, each of the selected rows 
will be groomed to the targeted bandwidth connection.

When an assignment has been successfully marked for assignment, a blue check 
mark appears in the first column of the row representing the assignment. In 
addition, the pending assignment is also displayed within the Connection 
Hierarchy view of the parent connection. The pending assignment has Pending 
Groom status.
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19. In this scenario, you are replacing one bandwidth assignment with two bandwidth 
assignments. A single row within the workspace can only represent one current 
assignment and one pending assignment. Therefore, you must create a new row 
within the workspace for the virtual connection. To do this, select any row 
representing the DEMO VC/MSS INCORPORATED/AUSTIN/DALLAS virtual 
connection and click the copy icon at the bottom of the window.

A new row appears displaying the copied virtual connection. The Unassign From 
Connection ID column for this virtual connection is blank, which signifies that 
this row does not represent a current assignment to a bandwidth connection, but it 
can be used to make a pending groom assignment to a new bandwidth.
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20. Select the newly-added row for the DEMO VC/MSS 
INCORPORATED/AUSTIN/DALLAS virtual connection in the list view of the 
Network Groom Maintenance window.

21. To make the second bandwidth assignment, right-click the 
101/1GB/AUSTTX02/AUSTTX03 bandwidth connection and select Groom To.

A check mark appears on the row representing the assignment and the hierarchy 
view displays the child virtual connection with a Pending Groom status.
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You have now specified the existing bandwidth assignment to replace along with 
the two bandwidth assignments that will replace it. You must remove the rows 
representing the assignments that you do not want to modify from the workspace 
because every row containing an assignment within the Unassign From 
Connection ID column is unassigned when the project is processed.

22. To remove the assignments that should not be groomed from the groom project, 
select the assignments you want to remove and click Delete (eraser icon) at the 
bottom of the window.

A confirmation message is displayed.

Note: Remove all assignments that should not be groomed from the 
groom project. In this scenario, if these bandwidth assignments are not 
deleted from the project and no bandwidth connection is selected in 
the hierarchical view for these assignments, these assignments will be 
removed and not replaced when the groom is processed.

23. Click Yes to All to confirm that of the selected rows should be deleted from the 
groom project.
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24. If you have set up custom attributes to manage the allocation parameters and 
want to assign the new values within the workspace, right-click the virtual 
connection and select Specify Virtual Channel.

The Virtual Channel Assignment window is displayed.

If the template is set up to automatically generate the next available value, the 
system pre-populates the window with these values. Otherwise, you can manually 
enter the values.

25. Click OK.

26. To view more details of the groom project, select the Current option in the Select 
View section in the top left corner of the screen.

The values in the Current Allocation Parameters and New Allocation Parameters 
columns are different.
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You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

27. From the Options menu, select Validate.

28. From the File menu, select Save.

29. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

30. If your project is not already listed, click Modify Search.

31. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

32. Select the groom projects and, from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

33. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.

b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.

34. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.
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35. Complete the task preceding the DLRD (or similar) task.

36. Double-click the DLRD (or similar) task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

37. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

A confirmation message is displayed. 

38. Click Yes.

The network groom project is processed.

39. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

40. From the Options menu, select Group Print. 

The Print window is displayed.

41. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

42. Click OK.

43. Complete the DLRD (or similar) task.

After completing the DLRD (or similar) task, but before completing the DD task, 
the child DEMO VC/MSS INCORPORATED/AUSTIN/DALLAS virtual 
connection riding on the 101/1GB/AUSTTX01/AUSTTX02 bandwidth will show 
a Pending Disconnect status and both the new parent bandwidth connections, 
101/1GB/AUSTTX01/AUSTTX03 and 101/1GB/AUSTTX02/AUSTTX03, will 
show this child in a Pending status.

44. Complete the DD task.

After completing the DD task, the child DEMO VC/MSS 
INCORPORATED/AUSTIN/DALLAS virtual connection will no longer be 
assigned to the 101/1GB/AUSTTX01/AUSTTX02 bandwidth and will be assigned 
to the two new bandwidth connections, 101/1GB/AUSTTX01/AUSTTX03 and 
101/1GB/AUSTTX02/AUSTTX03. The schematic design will be updated 
accordingly to represent the virtual connection’s new design.

Figure 3–9 shows that the DEMO VC/MSS INCORPORATED/AUSTIN/DALLAS 
virtual connection now rides on two new bandwidth connections, 
101/1GB/AUSTTX01/AUSTTX03 and 101/1GB/AUSTTX02/AUSTTX03, after the 
groom has been processed.
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Figure 3–9 Schematic Design After the Virtual Connection Is Groomed

Scenario 6: Grooming Templated Physical Connections
This scenario demonstrates how you may use the Network Grooming Tool to groom a 
physical bandwidth connection from one parent facility to another coterminous parent 
facility, which may be performed for capacity management, facility utilization, or other 
reasons.

In this example, the 4001/T0/SAAVPQXT/TABNUTXC bandwidth connection is 
unassigned from the 99990/T1/SAAVPQXT/TABNUTXC parent facility and this 
assignment is replaced by an assignment to the 99991/T1/SAAVPQXT/TABNUTXC 
parent facility.

Figure 3–10 illustrates this scenario.

Figure 3–10 Facility Riding on Bandwidth

To groom a physical bandwidth connection from one parent facility to another 
coterminous parent facility:

1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

2. Click the Add New link.
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The Groom Request Types window is displayed.

3. Select Facility.

4. Click OK.

The New Groom Facility window is displayed.

5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.

6. Select the Facility option.

7. Click Search.

The Connection Hierarchy Search window is displayed.

8. Select the Facility check box.

9. Specify the search criteria for the current parent facility and click Search. In this 
scenario, in the Identification field, enter 9990/T1/SAAVPQXT/TABNUTXC.

The New Groom Facility window displays the connections matching the search 
criteria.

10. Select the 99990/T1/SAAVPQXT/TABNUTXC facility and click Add.

The status of the 99990/T1/SAAVPQXT/TABNUTXC facility changes to Pending 
Groom.

11. Select the Near End option because you want to groom only the child connections 
from this parent facility.

12. Click OK.
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The 4001/T0/SAAVPQXT/TABNUTXC child bandwidth connection’s channel 
assignment to the current 99990/T1/SAAVPQXT/TABNUTXC parent facility is 
displayed in the list view of the Network Groom Maintenance window.

13. Select the Facility option.

14. Click Search.

The Connection Hierarchy Search window is displayed.

15. Select the Facility check box.

16. Specify the search criteria to retrieve the new parent T1 facility and click Search. In 
this scenario, in the Identification field, enter 99991/T1/SAAVPQXT/TABNUTXC.

The 99991/T1/SAAVPQXT/TABNUTXC facility is displayed in the hierarchical 
view of the Network Groom Maintenance window.

17. In the list view of the Network Groom Maintenance window, select the 
4001/T0/SAAVPQXT/TABNUTXC bandwidth connection in the list view of the 
Network Groom Maintenance window.

18. Right-click the 99991/T1/SAAVPQXT/TABNUTXC facility in the hierarchical view 
and select Groom To. You can also right-click on a specific channel to make the 
assignment, if required.

A check mark appears in the first column of the selected rows representing the 
groomed assignments. The pending assignment is also displayed in the 
Connection Hierarchy view of the parent facility, identified with a Pending 
Groom status.
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19. To view more details of the groom project, select the Current option in the Select 
View section in the top left corner of the screen.

You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

20. From the Options menu, select Validate.

21. From the File menu, select Save.

22. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

23. If your project is not already listed, click Modify Search.

24. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

25. Select the groom project and, from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

26. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.
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b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.

27. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.

28. Complete the task preceding the DLRD (or similar) task.

29. Double-click the DLRD (or similar) task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

30. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

A confirmation message is displayed.

31. Click Yes.

The network groom project is processed.

32. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

33. From the Options menu, select Group Print. 

The Print window is displayed.

34. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

35. Click OK.

36. Complete the DLRD (or similar) task.

After completing the DLRD (or similar) task, but before completing the DD task, 
the 4001/T0/SAAVPQXT/TABNUTXC bandwidth connection will show a 
Pending Disconnect status on the previous 99990/T1/SAAVPQXT/TABNUTXC 
parent facility and the 4001/T0/SAAVPQXT/TABNUTXC bandwidth connection 
will show a Pending status on the new 99991/T1/SAAVPQXT/TABNUTXC 
parent facility.

37. Complete the DD task.

After completing the DD task, the 4001/T0/SAAVPQXT/TABNUTXC bandwidth 
connection will no longer be assigned to the previous 
99990/T1/SAAVPQXT/TABNUTXC parent facility and the 
4001/T0/SAAVPQXT/TABNUTXC bandwidth connection will show an In 
Service status on the new 99991/T1/SAAVPQXT/TABNUTXC parent facility.
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Scenario 7: Grooming an NPA/NXX Switch
MetaSolv Solution provides telephone number (TN) grooming functionality that 
moves blocks of telephone numbers between network locations (switch CLLIs). In 
NPA/NXX switch grooming, an NPA/NXX (block/range) associated to a switch 
location is groomed to another switch location. In this scenario, an NPA/NXX 
(974/920) block with a range 0000 to 0999 will be groomed from the BRBOVTMADS0 
switch location to the RDBOVTTURS1 switch location.

Figure 3–11 illustrates this scenario.

Figure 3–11 NPA/NXX Switch Grooming

To move a TN block from one switch location to another switch location:

1. On the navigation bar, select Application Setup, and then click Inventory 
Management Setup.

2. Under Number Inventories, click Change Switch for Prefixes.

The Change Switch or OCN for NPA/NXX window is displayed.
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3. Enter the required information in the Existing Switch Location, NPA, NXX, and 
Holder Code fields.

In this scenario, set Existing Switch Location to BRBOVTMADS0, NPA to 974, 
NXX to 920, and Holder Code to Block. 

4. Enter the required information in the Range From, Range To, and Switch To 
fields. 

In this scenario, set Range From to 0000, Range To to 0999, and Switch To 
Location to RDBOVTTURS1.

5. Click Apply.

The data populates in the Update section of the Results frame.

6. Click Process.

A message is displayed prompting you to confirm if you want to process the 
blocks.

7. Click Yes.

A notification message is displayed that informs you that circuits that have a 
status of In Service, Suspend, or Pending Disconnect will be moved to the 
specified switch-to location, but will not be sent to the Network Grooming tool.

8. Click Close.

The Network Groom Maintenance window is displayed.

9. Right-click on a connection ID and select Load Switch Location.
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The switch-to location is displayed in the hierarchical view. In this scenario, the 
RDBOVTTURS1 switch location is displayed.

10. Select the connection IDs in the list view.

11. Expand the equipment and select an equipment port. 

12. Right-click the equipment port in the hierarchical view and select Groom To.
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A check mark is displayed beside the connection IDs in the list view. The 
equipment ports in the hierarchical view are in Pending Groom status.
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You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

13. From the Options menu, select Validate.

A confirmation message is displayed.

14. Click OK.

15. In the Select View section, select the Current option.

16. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.
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17. From the File menu, select Save.

18. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

The Network Groom Search window is displayed.

19. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

20. Select the groom project and, from the Options menu, select Create EWO or 
Create ISR.

This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

21. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.

22. Complete the task preceding the DLRD (or similar) task.

23. Double-click the DLRD (or similar) task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

24. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order. You can process small 
projects on the client machine. Oracle recommends that you process 
larger projects within the Background Processor.

A confirmation message is displayed.

25. Click Yes.

The network groom project is processed.

26. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

27. From the Options menu, select Group Print. 

The Print window is displayed.

28. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.
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29. Click OK.

30. Complete the DLRD (or similar) task.

After completing the DLRD (or similar) task, but before completing the DD task, 
the ports on the RDBOVTTURS1 switch show a Pending status.

31. Complete the DD task.

After completing the DD task, the ports on the RDBOVTTURS1 switch show an In 
Service status.
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After the groom process, you can see the following changes: 

■ The NPA/NXX network location association is updated.

■ The CLR/DLR design lines are updated.

■ The telephone number's network locations are updated.

■ The TN Switch on the end user location is not updated. You can update the TN 
Switch by selecting a value from the TN Switch list in the End User Location 
Maintenance window.

■ The exchange area for the telephone number prefix is not updated.

Scenario 8: Grooming a Virtual Connection by Changing its Terminating 
Bandwidth

In this scenario, the child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ are assigned to the parent connection 
00/QHYU/006778/027/SBZ, which terminates at the CASEYVILLE GATEWAY 
FOUNDATION 600 component.

The child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ are groomed from the existing 
00/QHYU/006778/027/SBZ parent connection, which shares its terminating 
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component CASEYVILLE GATEWAY FOUNDATION 600 with the child virtuals, to 
the 00/QHYU/006778/003/SBZ parent connection, which terminates at the 
BELLEVILLE GATEWAY FOUNDATION 7.

Figure 3–12 illustrates the scenario before the child virtual connections are groomed to 
a different terminating parent connection.

Figure 3–12 Before the Child Virtuals are Groomed

Figure 3–13 illustrates the scenario after the child virtual connections are groomed to a 
different terminating parent connection.
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Figure 3–13 After the Child Virtuals are Groomed

Figure 3–14 shows the schematic design of the child virtual connections before they are 
groomed. The child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ ride on the parent connection 
00/QHYU/006778/027/SBZ before the groom process.

Figure 3–14 Schematic Design Before the Virtual Connections are Groomed

To replace the terminating parent connection of a virtual connection using the 
Network Grooming tool:
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1. On the navigation bar, select Inventory Management, and then click Network 
Grooming.

2. Click the Add New link.

The Groom Request Types window is displayed.

3. Select Facility.

4. Click OK.

The New Groom Facility window is displayed.

5. In the Project Information section, complete the Groom Name, Description, Target 
Due Date, and Organization fields.

6. Select the Facility option.

7. Click Search.

The Connection Hierarchy Search window is displayed.

8. Select the Bandwidth check box.

9. Specify the search criteria for the bandwidth connection and click Search. In this 
scenario, in the Identification field, enter your search criteria and click Search.

The New Groom Facility window displays the retrieved data.

10. To add the 00/QHYU/006778/027/SBZ connection to the Network Grooming 
workspace, either right-click the connection and select Add To Groom or click the 
Add button. The status of the connection changes to Pending Groom. 
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11. Select the Near End option to specify the type of groom you want to perform.

12. Click OK.

The application creates the Network Grooming workspace and loads it with the 
selected data. Because you performed a near-end groom, all the child virtuals 
allocated to the parent bandwidth connection 00/QHYU/006778/027/SBZ are 
brought into the workspace. In this scenario, two virtual connections, 
00/QTYP/006778/026/SBZ and 00/QTYP/006778/030/SBZ, are allocated to the 
parent bandwidth connection 00/QHYU/006778/027/SBZ.

13. Select the Facility option.

14. Click Search.

The Connection Hierarchy Search window is displayed.

15. Select the Bandwidth check box.

16. Specify the search criteria to retrieve the bandwidth connection to which you want 
to groom the virtual connection and click Search. In this scenario, in the 
Identification field, enter LIKE 00/QHYU/006778/003/SBZ%.

The 00/QHYU/006778/003/SBZ bandwidth connection is displayed within the 
Connection Hierarchy section of the Network Groom Maintenance window.

17. To groom the virtual connections from the 00/QHYU/006778/027/SBZ 
bandwidth connection to the 00/QHYU/006778/003/SBZ bandwidth connection, 
select the 00/QTYP/006778/026/SBZ and 00/QTYP/006778/030/SBZ virtual 
connections in the list view of the Network Groom Maintenance window.

18. Right-click the 00/QHYU/006778/003/SBZ bandwidth connection in the 
hierarchical view and select Groom To.
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When an assignment has been successfully marked for assignment, a blue check 
mark appears in the first column of the row representing the assignment. In 
addition, the pending assignment is also displayed within the Connection 
Hierarchy view of the parent connection. The pending assignment has Pending 
Groom status.

You have now finished all the design changes. You must validate the project to 
verify that the assignments are valid. Validation takes place within the Groom To 
action, but because all network grooming projects are self-contained workspaces 
and may be built and worked over a long time frame, the inventory could have 
changed since the data was initially loaded into the workspace.

19. From the Options menu, select Validate.

20. From the File menu, select Save.

21. Close the Network Groom Maintenance window and return to the Network 
Groom Search window.

22. If your project is not already listed, click Modify Search.

23. Specify the name of the groom in the Groom Name field and click Search.

The network groom is displayed in the Network Groom Search window.

To process the design changes completed within the Network Grooming 
workspace, create an order. 

24. Select the groom projects and, from the Options menu, select Create EWO or 
Create ISR.
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This automatically generates the grooming order and pre-populates it with all of 
the connections contained within the selected grooming projects. The ISR or EWO 
opens in read-only view because the information is retrieved from the saved 
groom and adding or removing connections from the order is not allowed. In 
addition, all network grooming projects associated to an open order are also 
read-only because modifying the workspace will invalidate the order. To make 
changes to the grooming workspace, you must supplement-cancel the order to 
place the project back in Created status.

25. Depending on the type of order you create, do one of the following:

■ For an EWO order:

a. Under Related Pages, click Manage Tasks.

b. Under Actions, click Assign Tasks.

■ For an ISR order:

a. From the Options menu, select Task Generations/Maintenance.

26. Select a provisioning plan containing the DLRD (or similar) task and DD task at a 
minimum and assign the tasks to the appropriate work queues and click OK.

27. Complete the task preceding the DLRD (or similar) task.

28. Double-click the DLRD (or similar) task.

The Service Request Connections window is displayed, listing all of the 
connections on the order/project.

29. From the Options menu, select Process Groom.

Note: You can supplement-cancel grooming orders until this step. 
After the application has started processing the data from the 
workspace, you cannot cancel the order.

A confirmation message is displayed. 

30. Click Yes.

The network groom project is processed.

31. After the groom processing is complete, you must place the connections in Record 
Issued or DLR Issued status.

32. From the Options menu, select Group Print. 

The Print window is displayed.

33. Do one of the following:

■ To issue the connection layout record (CLR) or graphical layout record (GLR), 
select the Mark as Record Issued check box.

■ To issue the design layout report (DLR), select the Mark as DLR Issued check 
box.

34. Click OK.

35. Complete the DLRD (or similar) task.

After the DLRD (or similar) task is completed, the Connection Hierarchy window 
for the parent bandwidth connections displays the following:
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■ The existing parent bandwidth connection 00/QHYU/006778/027/SBZ will 
show the child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ in the Pending Disconnect status.

■ The new parent bandwidth connection 00/QHYU/006778/003/SBZ will show 
the child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ in the Pending status.

36. Complete the DD task.

After the DD task is completed, the Connection Hierarchy window for the parent 
bandwidth connections displays the following:

■ The existing parent bandwidth connection 00/QHYU/006778/027/SBZ will 
show the child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ in the Unassigned status.

■ The new parent bandwidth connection 00/QHYU/006778/003/SBZ will show 
the child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ in the In Service status.

Also, after the DD task is completed, the child virtual connections 
00/QTYP/006778/026/SBZ and 00/QTYP/006778/030/SBZ are no longer 
assigned to the bandwidth connection 00/QHYU/006778/027/SBZ; instead, the 
child virtuals are now assigned to the new bandwidth connection 
00/QHYU/006778/003/SBZ. The schematic design is updated accordingly to 
represent the virtual connection’s new design.

Figure 3–15 shows the schematic design of the child virtual connections after they are 
groomed. The child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ now ride on the new bandwidth connection 
00/QHYU/006778/003/SBZ after the groom process. Note that the GATEWAY 
FOUNDATION 600 component has been replaced on the canvas by the new 
terminating component, GATEWAY FOUNDATION 7, which is inherited from the 
new terminating parent bandwidth.

Figure 3–15 Schematic Design After the Virtual Connections are Groomed
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After the child virtual connections 00/QTYP/006778/026/SBZ and 
00/QTYP/006778/030/SBZ are groomed from 00/QHYU/006778/027/SBZ to 
00/QHYU/006778/003/SBZ, the application makes the following updates for the 
child virtuals:

■ Within the schematic design of the child virtuals:

– The child virtual’s assignment to the parent connection 
00/QHYU/006778/027/SBZ is removed and replaced with the assignment to 
the new parent connection 00/QHYU/006778/003/SBZ, which brings the 
new GATEWAY FOUNDATION 7 component onto the canvas. 

– The GATEWAY FOUNDATION 600 component is removed from the design 
issue because it is no longer defined as the terminating component, and there 
is no longer any connectivity to it.

■ Within the Connection Summary view of the Connection Design window: 

– The GATEWAY FOUNDATION 600 component is replaced with the 
GATEWAY FOUNDATION 7 component and the terminating location of the 
parent connection is updated from CASEYVILLE (the location of GATEWAY 
FOUNDATION 600 component) to BELLEVILLE (the location of GATEWAY 
FOUNDATION 7 component).

Figure 3–16 shows the Connection Summary view of the child virtual 
connection (00/QTYP/006778/026/SBZ) after it is groomed.

Figure 3–16 Connection Summary View of the Child Virtual
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