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26.4 Create a Multiple-Query Matrix with a Break

If you compare the single-query nested matrix output in Figure 26-4, "Paper Design view for the nested matrix report" to the multiple-query output in Figure 26-10, "Paper Design view for the nested matrix output", you notice that the multiple-query case displays all of the departments for every year while the single-query case does not. In the single-query case, only those departments that actually have values in their matrix cells are displayed in the output. To achieve a similar result with multiple queries, you need to have a parent/child relationship between the groups containing YEAR and DEPTNO.



26.4.1 Create a new report manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.


To create a blank report:

	
Choose File > New > Report.


	
Select Build a new report manually, then click OK.









26.4.2 Create a data model with a cross product and data links

When you create a matrix report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the cross product group and the necessary links in the Data Model view.


To create the queries:

	
In the Data Model view, choose Insert > Query to display the Data Wizard.


	
If the Welcome page displays, click Next.


	
On the Query page, type Q_Dept for the Query name, then click Next.


	
On the Data Source page, select SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT TO_CHAR(HIREDATE, 'YY') YEAR, DEPTNO
FROM EMP
GROUP BY TO_CHAR(HIREDATE, 'YY'), DEPTNO
ORDER BY TO_CHAR(HIREDATE, 'YY'), DEPTNO




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called nested2_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 26.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click YEAR in the Available Fields list and click the right arrow (>) to move this field to the Group Fields list, then click Next.


	
On the Totals page, click Next.


	
Click Finish to display the data model for your report output in the Data Model view.


	
Choose Insert > Query and follow the steps above to create another query named Q_Job and use the following SELECT statement:


SELECT DISTINCT JOB
FROM EMP



	
Again, choose Insert > Query and follow the steps above to create a third query named Q_Salary and use the following SELECT statement:


SELECT TO_CHAR(HIREDATE, 'YY') YEAR,  DEPTNO,  JOB,
SUM(SAL) FROM EMP
GROUP BY TO_CHAR(HIREDATE, 'YY'),  DEPTNO,  JOB
ORDER BY TO_CHAR(HIREDATE, 'YY'),  DEPTNO,  JOB




Figure 26-11 Data model with three queries

[image: Description of Figure 26-11 follows]









To create the cross product group:

	
In the Data Model view, click the Cross Product tool in the tool palette.


	
Drag a box around G_YEAR, G_DEPTNO, and G_JOB. When you release the mouse button, the cross product group is created. Ensure that it completely surrounds all three groups.





Figure 26-12 Data Model with three queries and a cross product group

[image: Description of Figure 26-12 follows]







To add the data links:

	
In the Data Model view, click the Data Link tool in the tool palette.


	
Click and drag from the YEAR column in the G_YEAR group to the YEAR1 column in the G_YEAR1 group.


	
Repeat steps 1 and 2, but this time drag the link between the DEPTNO column in G_DEPTNO and DEPTNO1 in G_YEAR1.


	
Again, repeat steps 1 and 2, but this time drag the link between the JOB column in G_JOB and JOB1 in G_YEAR1.


Figure 26-13 Nested matrix data model

[image: Description of Figure 26-13 follows]






	
Optionally, move the data model objects around to appear like the above figure.









26.4.3 Create the layout with the Report Wizard

Once your data model is complete, you need to create a layout for the data objects to display in the report output.


To create the layout:

	
In the Data Model view, right-click on the canvas, then choose Report Wizard.


	
In the Report Wizard, on the Report Type page, select Create Paper Layout only.


	
On the Style page, select Matrix.


	
On the Groups page, ensure that all of the groups from your data model appear in the Displayed Groups list. G_1 should be Matrix, G_YEAR and G_DEPTNO should be Down, G_JOB should be Across, and G_YEAR1 should be Down.


Figure 26-14 Groups page of the Report Wizard

[image: Description of Figure 26-14 follows]






	
On the Fields page, ensure that only the following columns appear in the Displayed Fields list:

	
YEAR


	
DEPTNO


	
JOB


	
SUM_SAL





Figure 26-15 Fields page of the Report Wizard

[image: Description of Figure 26-15 follows]






	
On the Labels page, change the labels and field widths as follows:


	Fields	Labels	Width
	
SUM_SAL

	
<none>

	
10


	
YEAR

	
<none>

	
4


	
JOB

	
<none>

	
10








	
On the Template page, make sure Beige is selected under Predefined Template, then click Finish to display your report output in the Paper Design view. It should look like this:


Figure 26-16 Paper Design view for the final nested matrix report output

[image: Description of Figure 26-16 follows]















41.7 Create a Layout

Now that you have a working data model, the steps in this section will help you to create a layout.


To create a paper layout:

	
In the Object Navigator, right-click the report name and choose Report Wizard.


	
In the Report Wizard, on the Report Type page, select Create Paper Layout Only.


	
On the Style page, type My Employees in the Title field, select Group Above.


	
On the Groups page, click the following fields in the Available Fields list and click Down to specify the Print Direction and move them to the Group Fields list:

	
G_conlabel


	
G_DEPARTMENT_ID


	
G_EMPLOYEE_ID





	
On the Fields page, click the following fields and click the right arrow (>) to move them to the Displayed Fields list:

	
DEPARTMENT_NAME


	
EMPLOYEE_ID


	
START_DATE


	
END_DATE


	
JOB_ID


	
CS_port_count





	
On the Labels page, change the labels and field widths as follows:


Table 41-3 Field description of Labels page

	Fields	Labels	Width
	
DEPARTMENT_NAME

	
Department

	
30


	
EMPLOYEE_ID

	
Employee ID

	
8


	
START_DATE

	
Start Date

	
9


	
END_DATE

	
End Date

	
9


	
JOB_ID

	
Job ID

	
10


	
CS_port_count

	
Total:

	
12








	
On the Template page, choose Predefined template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 41-8 Paper Design view for the REF CURSOR report

[image: Description of Figure 41-8 follows]









	
Note:

You can open the provided file ref_emp66.rdf and display the Paper Design view to compare your results.










	
Save the report as ref_66_your_initials.rdf.









11.3 Create a Data Model with a Data Link

When you create a report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the layouts with the Report Wizard.


To create the queries:

	
In the Data Model view, choose Insert > Query to display the Data Wizard.


	
If the Welcome page displays, click Next.


	
On the Query page, type Q_Salesrep for the Query name and click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT ENAME, EMPNO
FROM EMP
WHERE JOB = 'SALESMAN'




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called grp_above_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 11.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click Next.


	
Click Finish to display the data model for your report in the Data Model view.


	
Repeat the steps above for a second query, but this time name your query

Q_Product and use the following SELECT statement:


SELECT REPID, PRODNAME, AMOUNT, CUSTNAME
FROM SALES
ORDER BY REPID, CUSTNAME





Figure 11-2 Two-query data model without a link

[image: Description of Figure 11-2 follows]







To add the data link

	
In the Data Model view, click the Data Link tool in the tool palette.


	
Click and drag from the EMPNO column in the G_ENAME group to the REPID column in the G_REPID group. Notice that a line is drawn from the bottom of the G_ENAME group to the Q_Product query. Labels for EMPNO and REPID are created at each end of the line to indicate they are the columns linking G_ENAME to Q_Product.


Figure 11-3 Two-query data model with a data link

[image: Description of Figure 11-3 follows]






	
Double-click the new data link line to display the Property Inspector and examine the property settings:

	
G_ENAME is identified as the parent, while Q_Product is listed as the child. In terms of the data, the sales rep's name and employee number make up the master record and should print once for the associated product information retrieved by the Q_Product query.


	
Notice that WHERE already appears in the SQL Clause property. WHERE is the default clause used in master/detail relationships. You can replace WHERE with other SQL clauses such as HAVING and START WITH, but for this report the default is correct.


	
The other point to notice is that an equal sign (=) appears in the Condition property. An equality (that is, table1.columnname = table2.columnname) is the default condition for master/detail relationships defined through a data link. You can replace the equal sign with any other supported conditional operator (to see what is supported, click the field), but for this report the default is the proper condition.




Linking the group G_ENAME and the query Q_Product through the EMPNO and REPID columns is analogous to writing both queries as the single-query shown below:


SELECT ENAME, EMPNO, REPID,
PRODNAME, AMOUNT, CUSTNAME
FROM EMP, SALES
WHERE JOB = 'SALESMAN'
AND EMPNO = REPID (+)
ORDER BY REPID, CUSTNAME









42.3 Modify the HTML Parameter Form in Reports Builder

In this section, you will learn how to modify an HTML Parameter Form in Reports Builder to populate the list of values (LOV) you created with values from a data source. You will use JSP tags for Oracle Reports to enable the Parameter Form to access elements from a data model.



42.3.1 Create a data model manually for the Parameter Form

The steps in this section will show you how to create a simple data model for the Parameter Form.


To create a data model:

	
In Reports Builder, open the HTML file you created, paramform_your_initials.html.


	
In the Object Navigator, double-click the icon next to the Data Model node to display the Data Model view.


	
In the Data Model view that displays, click the SQL Query tool in the tool palette, then click in an open area of the Data Model view to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


select department_name, department_id
from departments
order by department_name




	
Note:

You you can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called simplejsppf_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.











	
Click Connect, then type the connection information for the Human Resources sample schema (HR).


	
Click OK. Your data model should look like this:


Figure 42-4 Data Model view of the Parameter Form

[image: Description of Figure 42-4 follows]






	
Save the report as paramform_your_initials.jsp.









42.3.2 Create a dynamic LOV in the Parameter Form

In this section, you will learn how to modify the Web source to pull data into the existing list of values (LOV) in your Parameter Form. This data will rely on the data model you created in the previous section. We will also examine the code to explain how each element operates.


To modify the LOV in the Parameter Form in Reports Builder:

	
Click the Web Source button in the toolbar to display the Web Source view.


	
In the Web Source view, look for the following code:


<select name="p_department" size="1">
<option value="1">a</option>
</select>





	
Note:

In the above code, the LOV returns a static value. The display name is "a" and the value is "1".









Since the LOV is currently static, we need to change this HTML element to dynamically retrieve data based on our data model.


	
In the Web Source view, modify the above code so that it looks like the following:


<select name=" p_department">
<rw:foreach id="fn" src="G_department_name"> 
<option value="<rw:field id="f_deptId" src="department_id"/>"><rw:field
id="deptname1" src="department_name"/></option>
</rw:foreach> 
</select>





	
Note:

You can either type the code manually or copy and paste it from the provided file called simplejsppf_code.txt.










	
Save your report.





Examine the JSP elements in the code:

By using JSP tags for Oracle Reports in the above code, we retrieve data into the Parameter Form's LOV by basing the parameters on fields in the data model. Let us examine each element:

	
<option>: The display name of the LOV is replaced by the field department_name from the data model. When the user displays the Parameter Form, the department name will display in the list.


	
<rw:field>: This element accesses each element of the g_department_name group.


	
<rw:foreach>: This element iterates through the results based on the g_department_name group in the data model.


	
src: This parameter is used in both <rw:foreach> and <rw:field> elements. For the <rw:foreach> element, src must match the group name of the data model (G_department_name). For the <rw: field> element, it must match the field that is referred (department_name).


	
id: This parameter can be any value, but it must be unique. This parameter also applies to both <rw:foreach> and <rw:field> elements.







	
Note:

For more infomation on these JSP elements and their parameters, refer to the Oracle Reports online Help.









By making these modifications to the code, we have replaced the return value attribute of the LOV with the field department_id, based on the data model we created in the previous section. If we now choose a department name from the list of values, its related department ID is returned. Note that the return value is not displayed.






42.3.3 Run the Parameter Form report to the Web

Now that we have modified and examined our Web source, let us view the Parameter Form in a Web browser.

	
Click the Run Web Layout button in the toolbar.




	
Note:

If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.










	
The Parameter Form displays in your Web browser, and should look like the following:


Figure 42-5 Parameter form with values

[image: Description of Figure 42-5 follows]









	
Note:

In the modified Parameter Form, notice how the list of values for the Department has changed from "a" to "Accounting."










	
Click the Department list and notice how the list is now populated with department names. Although you can click Run Report, nothing will happen because we have not yet defined an action for it.











4.6 Work with Web Reports

This section provides procedures for the following tasks that you may perform as you work with Web reports:

	
Creating a Web report


	
Viewing the source code for a Web report


	
Adding report data to an existing Web page (HTML file)


	
Adding a report block to a Web page


	
Adding an image


	
Adding a graph


	
Editing a graph


	
Adding a graph hyperlink


	
Preparing a paper-based report for the Web


	
Adding Web links to paper-based reports





See also

Section 1.2.2, "About Web Reports"



4.6.1 Creating a Web report

You can create a Web report in any of the following ways:

	
Create a report using the Report Wizard, (see Section 4.5.1, "Creating a report"), choosing to create a report for both Web and paper, or Web only.


	
Insert a report in a Web page by adding report data, then adding a report block to a Web page, as described in Section 4.6.3, "Adding report data to an existing Web page (HTML file)" and Section 4.6.4, "Adding a report block to a Web page".


	
Display the Web Source view and manually insert the Oracle Reports custom JSP tags (see the Reference section of the Oracle Reports online Help).


	
Insert an existing report into an existing Web page, by displaying the Web Source view for both the report and the Web page, then copying and pasting the report block into the desired position in the Web page.


	
Prepare a paper-based report for the Web by adding hyperlinks to an existing report (see Section 4.6.9, "Preparing a paper-based report for the Web").









4.6.2 Viewing the source code for a Web report

To view the source code for a Web report, do any of the following:

	
In the Report Editor, click the Web Source button in the toolbar.


	
In the Object Navigator, double-click the view icon next to the Web Source node for the report to display the source code in the Web Source view.


	
Choose View > Change View > Web Source.





See also

Topic "Oracle Reports JSP tags" in the Reference section of the Oracle Reports online Help.






4.6.3 Adding report data to an existing Web page (HTML file)

To retrieve the data to be used to build a report to add to an existing Web page (HTML file):

	
In the Object Navigator, choose File > Open.


	
Navigate to your Web page (HTML file), and click Open.


	
In the Object Navigator, find the report created when you opened the HTML file (Oracle Reports Builder may give the report a default name, such as REP1), then double-click the view icon next to the Data Model node to display the Data Model view.



	
Caution:

If you right-click the Data Model node, then choose Report Wizard to use the Report Wizard to select the data for a report, the report will overwrite all of the data in your existing Web page.








	
In the Data Model view, choose Insert > Query to select data for the report using the Data Wizard.

After you click Finish, the data you have selected is available to your Web report.





Next step

See Section 4.6.4, "Adding a report block to a Web page"






4.6.4 Adding a report block to a Web page

To add a report block to an existing Web page:

	
In the Object Navigator, choose File > Open.


	
Navigate to your Web page (HTML file), and click Open.


	
In the Object Navigator, find the report created when you opened the HTML file (Oracle Reports Builder may give the report a default name, such as REP1).


	
After you have added the data to be used to build the report (see Section 4.6.4, "Adding a report block to a Web page"), double-click the view icon next to the Web Source node to display the source code for the Web page in the Web Source view.


	
Locate the section in the source code where you want to add the report block.



	
Note:

Adding some comment text such as "Place the report block here" to your Web page enables you to easily locate the correct position for your report block.








	
Choose Insert > Report Block.


	
In the Report Block Wizard, specify the information for the report block.









4.6.5 Adding an image

See Section 4.9.8.1, "Adding an image"






4.6.6 Adding a graph

See Section 4.9.8.2, "Adding a graph"






4.6.7 Editing a graph

See Section 4.9.8.3, "Editing a graph"






4.6.8 Adding a graph hyperlink

See Section 4.9.8.4, "Adding a graph hyperlink"






4.6.9 Preparing a paper-based report for the Web

To prepare a paper-based report for the Web:

	
(Optional) Add desired Web links to a new or existing report:

	
Create an HTML document header (see Section 4.6.10.1.1)


	
Create an HTML document footer (see Section 4.6.10.1.2)


	
Create an HTML page header (see Section 4.6.10.1.3)


	
Create an HTML page footer (see Section 4.6.10.1.4)


	
Create an HTML Parameter Form header (see Section 4.6.10.1.5)


	
Create an HTML Parameter Form footer (see Section 4.6.10.1.6)


	
Create a hyperlink (and, if linking to an object within the report, create an associated hyperlink destination) (see Section 4.6.10.1.8 and Section 4.6.10.1.7)


	
Create an application command line link (PDF output only) (see Section 4.6.10.1.9)


	
Create a bookmark (see Section 4.6.10.1.10)





	
Select a printer or use the default printer setup (the drivers for the currently selected printer are used to produce the output; you must have a printer configured for the machine on which you are running the report).


	
Display your report output in your Web browser (see Section 4.7.16.4, "Displaying report output in your Web browser")





See also

Section 1.2.2, "About Web Reports"

Section 2.2.3, "About Web links for HTML output"

Section 2.2.4, "About Web links for PDF output"






4.6.10 Adding Web links to paper-based reports

This section provides procedures that apply to paper-based reports generated to an HTML or PDF file. This is unrelated to HTML that might be generated when you run a JSP-based Web report (when you click the Run Web Layout button in the toolbar, or choose Program > Run Web Layout).

You can add Web links to paper-based reports by either:

	
Using the user interface.


	
Using PL/SQL.






4.6.10.1 Using the user interface

This section provides procedures for the following tasks that you may perform using the Oracle Reports Builder user interface to add Web links to paper-based reports:

	
Creating an HTML document header using the Property Inspector


	
Creating an HTML document footer using the Property Inspector


	
Creating an HTML page header using the Property Inspector


	
Creating an HTML page footer using the Property Inspector


	
Creating an HTML Parameter Form header using the Property Inspector


	
Creating an HTML Parameter Form footer using the Property Inspector


	
Creating a hyperlink destination using the Property Inspector


	
Creating a hyperlink using the Property Inspector


	
Creating an application command line link using the Property Inspector


	
Creating a bookmark using the Property Inspector


	
Creating a bookmark on break columns using the Property Inspector


	
Adding navigation controls for HTML page-streamed output using the Property Inspector


	
Selecting HTML tags from the database





See also

Section 1.2.2, "About Web Reports"

Section 2.2.3, "About Web links for HTML output"

Section 2.2.4, "About Web links for PDF output"

Section 2.2.10, "About before and after escapes"



4.6.10.1.1 Creating an HTML document header using the Property Inspector




	
Note:

This procedure is for HTML output only.









To insert an HTML file or text on the header page of your HTML document:

	
In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.


	
Under the Report Escapes node, set the Before Report Type property to Text (if you will type the header) or File (if you will import the header from a file).


	
Set the Before Report Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.





See also

Section 4.6.10.2.1, "Creating an HTML document header using PL/SQL"






4.6.10.1.2 Creating an HTML document footer using the Property Inspector




	
Note:

This procedure is for HTML output only.









To insert an HTML file or text on the footer page of your HTML document:

	
In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.


	
Under the Report Escapes node, set the After Report Type property to Text (if you will type the footer) or File (if you will import the footer from a file).


	
Set the After Report Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.





See also

Section 4.6.10.2.2, "Creating an HTML document footer using PL/SQL"






4.6.10.1.3 Creating an HTML page header using the Property Inspector




	
Note:

This procedure is for HTML output only.









To add a page header to every page of your HTML document:

	
In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.


	
Under the Report Escapes node, set the Before Page Type property to Text (if you will type the header) or File (if you will import the header from a file).


	
Set the Before Page Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.




To add a page header to a single page of your HTML document:

	
See Section 4.6.10.2.3, "Creating an HTML page header using PL/SQL".









4.6.10.1.4 Creating an HTML page footer using the Property Inspector




	
Note:

This procedure is for HTML output only.









To add a page footer to every page of your HTML document:

	
In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.


	
Under the Report Escapes node, set the After Page Type property to Text (if you will type the footer) or File (if you will import the footer from a file).


	
Set the After Page Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.




To add a page footer to a single page of your HTML document:

	
See Section 4.6.10.2.4, "Creating an HTML page footer using PL/SQL".









4.6.10.1.5 Creating an HTML Parameter Form header using the Property Inspector




	
Note:

This procedure is for HTML output only.









To add items to the top of the HTML Parameter Form:

	
In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.


	
Under the Report Escapes node, set the Before Form Type property to Text (if you will type the header) or File (if you will import the header from a file).


	
Set the Before Form Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.





See also

Section 2.5.1, "About Parameter Form HTML extensions"

Section 4.6.10.2.5, "Creating an HTML Parameter Form header using PL/SQL"






4.6.10.1.6 Creating an HTML Parameter Form footer using the Property Inspector




	
Note:

This procedure is for HTML output only.









To add items to the bottom of the HTML Parameter Form:

	
In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.


	
Under the Report Escapes node, set the After Form Type property to Text (if you will type the footer) or File (if you will import the footer from a file).


	
Set the After Form Value property by clicking the ... button to either type HTML code in the dialog box or select an HTML file to import.





See also

Section 2.5.1, "About Parameter Form HTML extensions"

Section 4.6.10.2.6, "Creating an HTML Parameter Form footer using PL/SQL"






4.6.10.1.7 Creating a hyperlink destination using the Property Inspector

To add a hyperlink destination to your report:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that will be the destination of a Web link.



	
Note:

If you are defining a template, you can select objects in the margin. Objects in the body are unknown until the template is applied to a report.








	
Double-click the object that will be the destination of a Web link to display the Property Inspector.


	
Under the Web Settings node, set the Hyperlink Destination property to an identifier for the object.





See also

Section 2.2.7, "About hyperlink destinations"

Section 4.6.10.2.8, "Creating a hyperlink destination using PL/SQL"






4.6.10.1.8 Creating a hyperlink using the Property Inspector

To add a hyperlink to your report:

	
Create a hyperlink destination, as described in the steps above, which will be the target of the Web link.


	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that will be the source of the Web link.



	
Note:

If you are defining a template, you can select objects in the margin. Objects in the body are unknown until the template is applied to a report.








	
Double-click the object that will be the source of the Web link to display the Property Inspector.


	
Under the Web Settings node, set the Hyperlink property to the destination of the link.

For examples, see the description of the Hyperlink property in the Reference section of the Oracle Reports online Help.



	
Note:

A report output in PDF format can include both hyperlinks and application command line links. If the Application Command Line property is set for an object, it will be applied to the object. Otherwise, the Hyperlink property is applied.








	
To apply additional HTML attributes to the hyperlink, set the Additional Hyperlink Attributes property accordingly.





See also

Section 2.2.5, "About hyperlinks"

Section 4.6.10.2.7, "Creating a hyperlink using PL/SQL"






4.6.10.1.9 Creating an application command line link using the Property Inspector




	
Note:

This procedure is for PDF output only.









To associate a command with an object in your report:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object with which you want to associate a command.



	
Note:

If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.








	
Double-click the object with which you want to associate a command to display the Property Inspector.


	
Under the Web Settings node, set the Application Command Line property to the command you want to execute when the object is clicked.



	
Note:

A report output in PDF format can include both hyperlinks and application command line links. If the Application Command Line property is set for an object, it will be applied to the object. Otherwise, the Hyperlink property is applied.











Restrictions

An object that is associated with an application command line link cannot also be the source of a Web link (a hyperlink).


See also

Section 2.2.9, "About application command line links"

Section 4.6.10.2.9, "Creating an application command line link using PL/SQL"






4.6.10.1.10 Creating a bookmark using the Property Inspector

To create a bookmark on objects other than break columns in the bookmark area of your HTML or PDF document:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object with which you want to associate a bookmark (typically, the object is a repeating frame or frame that encloses the relevant section of the report).



	
Note:

If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.








	
Double-click the object with which you want to associate a bookmark to display the Property Inspector, and set the following properties:

	
Under the Web Settings node, set the Bookmark property to the string you want to appear in the bookmark area of the formatted report.








See also

Section 2.2.8, "About bookmarks"

Section 4.6.10.2.10, "Creating a bookmark using PL/SQL"






4.6.10.1.11 Creating a bookmark on break columns using the Property Inspector

To create a bookmark on break columns in the bookmark area of your paginated HTMLCSS or paper PDF document:

	
In the Paper Layout view, choose Insert > Bookmark.


	
In the Insert Bookmarks dialog box, move the desired column(s) to the Bookmarks list.


	
Click OK.





See also

Section 2.2.8, "About bookmarks"

Section 4.6.10.2.10, "Creating a bookmark using PL/SQL"






4.6.10.1.12 Adding navigation controls for HTML page-streamed output using the Property Inspector




	
Note:

This procedure is for HTML output only.









To add navigation controls for HTML page-streamed (paginated) output:

	
In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.


	
Set the Page Navigation Control Type and Page Navigation Control Value properties.



	
Note:

If you do not change the default Page Navigation Control Value, Oracle Reports Builder will use a default built-in JavaScript for implementing the navigation between the pages of output.











See also

Section 2.8.8.1, "About HTML page streaming"

Section 4.7.16.5, "Displaying individual pages of HTML report output"

Section 4.6.10.2.11, "Adding navigation controls for HTML page-streamed output using PL/SQL"








4.6.10.2 Using PL/SQL

This section provides procedures for the following tasks that you may perform as you work with PL/SQL to add Web links to paper-based reports:

	
Creating an HTML document header using PL/SQL


	
Creating an HTML document footer using PL/SQL


	
Creating an HTML page header using PL/SQL


	
Creating an HTML page footer using PL/SQL


	
Creating an HTML Parameter Form header using PL/SQL


	
Creating an HTML Parameter Form footer using PL/SQL


	
Creating a hyperlink using PL/SQL


	
Creating a hyperlink destination using PL/SQL


	
Creating an application command line link using PL/SQL


	
Creating a bookmark using PL/SQL


	
Adding navigation controls for HTML page-streamed output using PL/SQL





See also

Section 1.2.2, "About Web Reports"

Section 2.2.3, "About Web links for HTML output"

Section 2.2.4, "About Web links for PDF output"

Section 2.2.10, "About before and after escapes"



4.6.10.2.1 Creating an HTML document header using PL/SQL




	
Note:

This procedure is for HTML output only. A before report escape should be set in a trigger that fires before the report starts formatting, such as the Before Report trigger.









To add items to the header page of your HTML document using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Report Triggers node.


	
Double-click the PL/SQL icon next to the Before Report trigger.


	
In the PL/SQL Editor, include SRW.SET_BEFORE_REPORT_HTML to define the PL/SQL for the format trigger. (See the Reference section of the Oracle Reports online Help for more information).





See also

Section 4.6.10.1.1, "Creating an HTML document header using the Property Inspector"






4.6.10.2.2 Creating an HTML document footer using PL/SQL




	
Note:

This procedure is for HTML output only. An after report escape should be set in a trigger that fires before the report is done formatting, such as the Before Report trigger.









To add items to the footer page of your HTML document using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Report Triggers node.


	
Double-click the PL/SQL icon next to the Before Report trigger.


	
In the PL/SQL Editor, include SRW.SET_AFTER_REPORT_HTML to define the PL/SQL for the format trigger.





See also

Section 4.6.10.1.2, "Creating an HTML document footer using the Property Inspector"






4.6.10.2.3 Creating an HTML page header using PL/SQL




	
Note:

This procedure is for HTML output only. If you want the escape to apply to every page, set it in a trigger that fires before the report begins formatting, such as the Before Report trigger. If you want the escape to apply to a single page, set it in a Format trigger









To add a page header to every page of your HTML document using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Report Triggers node.


	
Double-click the PL/SQL icon next to the Before Report trigger.


	
In the PL/SQL Editor, include SRW.SET_BEFORE_PAGE_HTML to define the PL/SQL for the format trigger.




To add a page header to a single page of your HTML document using PL/SQL:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that should fire the trigger when formatted.


	
Double-click the PL/SQL icon next to the object that should fire the trigger when formatted.


	
In the PL/SQL Editor, include SRW.SET_BEFORE_PAGE_HTML to define the PL/SQL for the format trigger.





See also

Section 4.6.10.1.3, "Creating an HTML page header using the Property Inspector"






4.6.10.2.4 Creating an HTML page footer using PL/SQL




	
Note:

This procedure is for HTML output only. If you want the escape to apply to every page, set it in a trigger that fires before the report begins formatting, such as the Before Report trigger. If you want the escape to apply to a single page, set it in a Format trigger.









To add a page footer to every page of your HTML document using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Report Triggers node.


	
Double-click the PL/SQL icon next to the Before Report trigger.


	
In the PL/SQL Editor, include SRW.SET_AFTER_PAGE_HTML to define the PL/SQL for the format trigger.




To add a page footer to a single page of your HTML document using PL/SQL:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that should fire the trigger when formatted.


	
Double-click the PL/SQL icon next to the object that should fire the trigger when formatted.


	
In the PL/SQL Editor, include SRW.SET_AFTER_PAGE_HTML to define the PL/SQL for the format trigger.





See also

Section 4.6.10.1.4, "Creating an HTML page footer using the Property Inspector"






4.6.10.2.5 Creating an HTML Parameter Form header using PL/SQL




	
Note:

This procedure is for HTML output only. A before form escape should be set in a trigger that fires before the Parameter Form starts formatting, such as the Before Parameter Form trigger.









To add items to the top of the HTML Parameter Form using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Report Triggers node.


	
Double-click the PL/SQL icon next to the Before Parameter Form trigger.


	
In the PL/SQL Editor, include SRW.SET_BEFORE_FORM_HTML to define the PL/SQL for the format trigger.





See also

Section 2.5.1, "About Parameter Form HTML extensions"

Section 4.6.10.1.5, "Creating an HTML Parameter Form header using the Property Inspector"






4.6.10.2.6 Creating an HTML Parameter Form footer using PL/SQL




	
Note:

This procedure is for HTML output only. A before form escape should be set in a trigger that fires before the Parameter Form starts formatting, such as the Before Parameter Form trigger.









To add items to the bottom of the HTML Parameter Form using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Report Triggers node.


	
Double-click the PL/SQL icon next to the Before Parameter Form trigger.


	
In the PL/SQL Editor, include SRW.SET_AFTER_FORM_HTML to define the PL/SQL for the format trigger.





See also

Section 2.5.1, "About Parameter Form HTML extensions"

Section 4.6.10.1.6, "Creating an HTML Parameter Form footer using the Property Inspector"






4.6.10.2.7 Creating a hyperlink using PL/SQL

To add a hyperlink to your report using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that will be the source of the Web link.



	
Note:

If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report








	
Double-click the PL/SQL icon next to the object that will be the source of the Web link.


	
In the PL/SQL Editor, include SRW.SET_HYPERLINK to define the PL/SQL for the format trigger.


	
To apply additional HTML attributes to the hyperlink, use 

SRW.SET_HYPERLINK_ATTRS.





Next step

Section 4.6.10.2.8, "Creating a hyperlink destination using PL/SQL"


See also

Section 2.2.5, "About hyperlinks"

Section 4.6.10.1.8, "Creating a hyperlink using the Property Inspector"






4.6.10.2.8 Creating a hyperlink destination using PL/SQL

To add a hyperlink destination to your report using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that will be the destination of a Web link.



	
Note:

If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.








	
Double-click the PL/SQL icon next to the object that will be the destination of a Web link.


	
In the PL/SQL Editor, include SRW.SET_LINKTAG to define the PL/SQL for the format trigger.





Next step

Section 4.6.10.2.7, "Creating a hyperlink using PL/SQL"


See also

Section 2.2.7, "About hyperlink destinations"

Section 4.6.10.1.7, "Creating a hyperlink destination using the Property Inspector"






4.6.10.2.9 Creating an application command line link using PL/SQL




	
Note:

This procedure is for PDF output only.









To associate a command with an object in your report using PL/SQL instead of the Property Inspector:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object with which you want to associate an application command line link.



	
Note:

If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.








	
Double-click the PL/SQL icon next to the object with which you want to associate an application command line link.


	
In the PL/SQL Editor, include SRW.SET_PDF_ACTION to define the PL/SQL for the format trigger.





Restrictions

An object that is associated with an application command line link cannot also be the source of a Web link (a hyperlink).


See also

Section 2.2.9, "About application command line links"

Section 4.6.10.1.9, "Creating an application command line link using the Property Inspector"






4.6.10.2.10 Creating a bookmark using PL/SQL

To add a bookmark string in the bookmark area of your report using PL/SQL:

	
In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object with which you want to associate a bookmark (typically, the object is a repeating frame or frame that encloses the relevant section of the report).



	
Note:

If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.








	
Double-click the PL/SQL icon next to the object with which you want to associate a bookmark.


	
In the PL/SQL Editor, include SRW.SET_BOOKMARK to define the PL/SQL for the format trigger.





See also

Section 2.2.8, "About bookmarks"

Section 4.6.10.1.10, "Creating a bookmark using the Property Inspector"

Section 4.6.10.1.11, "Creating a bookmark on break columns using the Property Inspector"






4.6.10.2.11 Adding navigation controls for HTML page-streamed output using PL/SQL




	
Note:

This procedure is for HTML output only.









To add navigation controls for HTML page-streamed output using PL/SQL instead of the Property Inspector:

	
in a Before Report trigger, use the SRW.SET_PAGE_NAVIGATION_HTML PL/SQL procedure





See also

Section 2.8.8.1, "About HTML page streaming"

Section 4.7.16.5, "Displaying individual pages of HTML report output"

Section 4.6.10.1.12, "Adding navigation controls for HTML page-streamed output using the Property Inspector"












21.3 Create a Formula Column and a Summary Column

The steps in this section will show you how to add a formula column to the Q_EMP (or detail) query you built in the previous section that will return a value every time a detail record is returned. You will then add a summary column to the Q_DEPT (or master) query that will count the number of times this formula column returns a value.

Before you create either of these columns, you may want to expand the size of your groups for better visibility. To do so, select the yellow group box. Click the bottom frame, then drag it down about 0.25 inches (0.5 centimeters). If you do this for both groups, you will have enough room to add your new columns.



21.3.1 Create a formula column in the detail query

This section will show you how to create a formula column that will return a single value.


To create a formula column:

	
In the Data Model view, click the Formula Column tool in the tool palette.


	
Click in the Q_EMP query, under the JOB column to create a formula column.


	
Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to DETAIL_VAL.


	
Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function DETAIL_VALFormula return Number is
begin
     return(1);
end;


	
Click Compile.



	
Tip:

If you receive errors when compiling, compare your code against the code provided. You can also simply copy and paste the code from suppresslabels_code.txt.








	
When the code is compiled, click Close.









21.3.2 Create a summary column in the master query

The steps in this section will show you how to create and customize a summary column in the master query that will depend on the information returned by the formula column.


To create a summary column:

	
In the Data Model view, click the Summary Column tool in the tool palette.


	
Click in the Q_DEPT query, under the LOC column to create a summary column.


	
Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to COUNT_DETAIL.


	
Under Summary, set the Function property to Count, set the Source property to DETAIL_VAL, and set the Reset At property to G_DEPTNO.




Your data model now contains both the formula and summary columns, and should look like this:


Figure 21-3 Data Model view with formula and summary columns

[image: Description of Figure 21-3 follows]






	
Save your report as suppresslabels_your_initials.rdf.











40.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.





23  Building a Conditional Form Letter Report

In this chapter, you will learn about reports that generate different versions of a form letter based on changing conditions. By following the steps in this chapter, you can generate the report output shown in Figure 23-1 and Figure 23-2.


Figure 23-1 Conditional form letter report output, base version

[image: Description of Figure 23-1 follows]







Figure 23-2 Conditional form letter report output, alternate version

[image: Description of Figure 23-2 follows]







Concepts

	
The two form letters above were generated from the same report. As you can see, the two letters share a number of features. Hence, it is more convenient to create a base form letter and then apply conditions to certain parts to determine whether they should be displayed for the current record, in this case, employees.


	
Conditional printing is useful when you want to display a section of a report only if certain conditions are met at run time. Conversely, you may wish to use conditional printing to suppress certain information for those who don't need it.





Data Relationships

This report uses one query to select all data.


Layout

This report uses the Form Letter layout style. You'll also create the various pieces of boilerplate that will comprise the letter. To govern the printing of these boilerplate objects, you'll use vertically collapsing anchors and PL/SQL format triggers to conditionally produce different form letters for employees who meet the specified criteria.


Example Scenario

In this example, you will create a form letter to invite all of your employees to the company picnic. For your top sales representatives, though, you also want to include a special invitation to a dinner party in the form letter. For all other employees, you want to include a thank you without the dinner invitation.

As you build this example report, you will:

	
Create the Data Model and Layout.


	
Add Additional Text.


	
Add Logic for Text, which involves anchoring objects together and creating format triggers to control whether the text displays.




To see a sample conditional form letter report, open the examples folder named condform, then open the Oracle Reports example named condform.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.




11.4 Use the Report Wizard to Layout the Data

Once your data model is complete, you need to create a layout for the data objects to display in the report output. The Report Wizard enables you to create layouts for your data model.




	
Tip:

When you have multiple queries in your data model, make sure that you check the names of the groups associated with each query prior to entering the Report Wizard. The Report Wizard requires you to choose data for the layout by group name.










To create the layout:

	
In the Data Model view, right-click on the canvas, then choose Report Wizard.


	
In the Report Wizard, on the Report Type page, select Create Paper Layout only.


	
On the Style page, select Group Above.


	
On the Groups page, ensure that both groups from your data model appear in the Displayed Groups list.


	
On the Fields page:

	
Click the double right arrows (>>) to move all of the fields to the Displayed Fields list.


	
Click REPID in the Displayed Fields list and click the left arrow (<) to move it back to the Available Fields list. Since REPID and EMPNO represent the same value, you only need to display one of them. EMPNO is part of the master group, which is the level where we want to see its values in the report. REPID is part of the detail group. Hence, you remove REPID from the Displayed Fields list to prevent it from appearing in the output.





Figure 11-4 Fields page of the Report Wizard

[image: Description of Figure 11-4 follows]






	
On the Labels page, change the labels and field widths as follows:


Table 11-1 Field description of Labels page

	Fields	Labels	Width
	
PRODNAME

	
Product

	
22


	
AMOUNT

	
(no change)

	
10


	
CUSTNAME

	
Customer

	
15


	
ENAME

	
Name

	
(no change)


	
EMPNO

	
Emp. No.

	
(no change)








	
On the Template page, make sure Beige is selected under Predefined Template, then click Finish to display your report output in the Paper Design view. It should look like this:


Figure 11-5 Paper Design view for the two-query group report

[image: Description of Figure 11-5 follows]













42.4 Set up the Target Report

Now that you have set up the parameters, the next step is to set up the target report to accept the parameters. Then, we will define the action for your Parameter Form. When a user clicks Run Report, the target report will be run based on the Department and User ID parameters.

The target report we use in this section is the sample report for the Oracle Reports Tutorial. If you completed the exercises in the Oracle Reports Tutorial and created emprevb.jsp, you can use that report in this section. Otherwise, you can use the example file we have provided, called emprev_final.jsp. We will not show the steps to build this report in this section.

For more information on building the sample JSP-based Web report, refer to the Oracle Reports Tutorial.


To set up the target report:

	
In Reports Builder, open the file we have provided called emprev_final.jsp.


	
In the Object Navigator, double-click the icon next to the Data Model node.


	
In the Data Model view that displays, double-click the query (Q_1) to display the SQL Query Statement dialog box.


	
Find the final line of the code:


WHERE (EMPLOYEES.MANAGER_ID = EMPLOYEES_A1.EMPLOYEE_ID) 
AND EMPLOYEES.DEPARTMENT_ID = 100


	
Change the second WHERE clause so that the last line looks like this:


WHERE (EMPLOYEES.MANAGER_ID = EMPLOYEES_A1.EMPLOYEE_ID) 
AND EMPLOYEES.DEPARTMENT_ID = :P_DEPARTMENT




	
Tip:

The code we have changed is in bold text.








	
Click OK.


	
A note displays that indicates a bind parameter has been created. Click OK.


	
Save your report as emprev_param_your_initials.jsp.









4.1 Access Oracle Reports Documentation

This section provides procedures for the following tasks that you may perform to access the Oracle Reports documentation:

	
Using the Oracle Reports online Help


	
Locating other documentation






4.1.1 Using the Oracle Reports online Help

For more information on using Oracle Reports Builder, as well as Oracle Reports reference information, refer to the Oracle Reports online Help, which you can access in any of the following ways:

	
From Oracle Reports Builder:

	
Choose Help > Help Contents.


	
Click Help or press F1 in any dialog box.


	
In the Property Inspector, click a property, then press F1 to display the property's help topic.





	
On the Oracle Technology Network (OTN) Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html):

	
Under Resources, click Hosted Online Help to display the Web-based version of the most recent Oracle Reports online Help.


	
Under News, click Oracle Reports Online Help Update to replace your Oracle Reports online Help in Oracle Reports Builder with the most recent update. Instructions for replacing your help file are included in the readme.txt in the download file.







The following guidelines will help you to make effective use of the online Help:

	
Familiarize yourself with the Contents tab to get an idea of the scope of the topics covered in the online Help.


	
Click the Index tab to locate specific topics on a subject.


	
The Help Navigator window and Help Topic window can be separated or kept together. Move the windows as desired.









4.1.2 Locating other documentation

To get started and become proficient with building reports, refer to the following resources:


Table 4-1 Oracle Reports documentation roadmap

	For...	Refer to...
	
An overview of Oracle Reports

	
	
Overview information available on the Oracle Technology Network Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html).


	
Online help topics under the Welcome node in the Help Navigator window (choose Help > Help Contents).





	
An overview of new and changed features in this release

	
	
Oracle Reports New Features, available on the Oracle Technology Network Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html).


	
Chapter "Introduction" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual details the new functionality in Oracle Reports 111g Release 2 (11.1.2), along with the equivalent 10g Release 2 (10.1.2) functionality.





	
Instructions and hands-on lessons about building paper and Web-based reports

	
	
This manual and Oracle Reports Tutorial, available in the Oracle Fusion Middleware Documentation Library.


	
Online Help (choose Help > Help Contents in Oracle Reports Builder) for specific tasks and reference information.





	
Context-sensitive help on dialog boxes, messages, and properties

	
	
For dialog boxes and messages, the online Help topics displayed when you click Help, or press F1.


	
For properties, the online Help topics displayed when you click a property in the Property Inspector, then press F1.





	
Information about Oracle Reports Services and configuring and using the Reports Server

	
	
Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual, available in the Oracle Fusion Middleware Documentation Library.





	
Information about using the Oracle Reports application program interface (API)

	
	
Oracle Reports JavaAPI Reference, available on the documentation CD and via the Oracle Reports Search page on OTN (http://www.oracle.com/technetwork/middleware/reports/overview/index.html): In the Collateral Type list, choose Documentation and click Search. In the list that displays, find the Oracle Reports Java API Documentation.


	
The Reports Software Development Kit (RSDK), available on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), click SDK.


	
The Oracle Reports Plugin Exchange, available on the Oracle Technology Network (OTN): on the Oracle Reports 11g page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), click Plugin Exchange.





	
Examples and demos

	
	
Via the Oracle Reports Search page on OTN (http://www.oracle.com/technetwork/middleware/reports/overview/index.html): In the Collateral Type list, choose Examples or Demonstrations, and click Search. In the list that displays, click an example or demo that interests you.





	
Other resources, such as white papers

	
	
Via the Oracle Reports Search page on OTN (http://www.oracle.com/technetwork/middleware/reports/overview/index.html): In the Collateral Type list, choose White Papers & How To Documents, and click Search.

















21.4 Create the report layout

In this section, you will create a default layout for your report. You will then add all the necessary layout objects for your checks.



21.4.1 Create the initial layout of your report


To create the initial layout:

	
In the Data Model view, right-click on the canvas, then choose Report Wizard.


	
In the Report Wizard, on the Report Type page, select Create Paper Layout only.


	
On the Style page, select Group Above.


	
On the Groups page, click the following groups in the Available Groups list and click Down to specify the Print Direction and move them to the Displayed Groups list:

	
G_DEPTNO


	
G_DEPTNO1





	
On the Fields page:

	
Click the double right arrows (>>) to move all of the fields to the Displayed Fields list.


	
In the Displayed Fields list, click DEPTNO1 then click the left arrow (<) to move this field back to the Available Fields list.


	
Do the same for the COUNT_DETAIL and DETAIL_VAL fields.





	
On the Labels page, make any desired changes to the labels.


	
On the Template page, select Predefined Template and click Blue, then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 21-4 Paper Design view for the suppress labels report

[image: Description of Figure 21-4 follows]






	
Save your report as suppresslabels_your_initials.rdf.











35.2 Create a Simple Table of Contents

The steps in this section will show you how to create a basic table of contents for a large, multipage report. The table of contents will look like the following:


Figure 35-3 Simple table of contents

[image: Description of Figure 35-3 follows]








35.2.1 Create a table in the database to hold the TOC data

The steps in this section will show you how to create a table in the database that will hold the page numbers for the records you want to list in the table of contents. If you are not sure whether you have the privileges to create a table in the database, contact the database administrator.


To create a table in the database:

	
Start SQL*Plus.

	
On Windows, from the Start menu, choose Programs > Oracle Application Server - oracle_home_name> Application Development > SQL Plus.


	
On UNIX, type sqlplus.





	
Connect to the Sales History schema of the database (for example, use the sh/sh@database_name connect string).


	
At the SQL prompt, type the following line:


create table toc_example (topic varchar2(100), page number);


	
Press Enter.

You should see a notification that the table has been created.


	
Exit SQL*Plus.









35.2.2 Create a group above report

The steps in this section will show you how to build a simple group above report in Reports Builder. This group above report will display the country name, then the customers and customer e-mail addresses under each country name. The table of contents you create will then be based on the country name in this report.


To create a simple group above report:

	
In Reports Builder, choose File > New > Report, then choose to create the report manually.


	
In the Data Model view that displays, right-click on the canvas, then choose Report Wizard from the pop-up menu.


	
On the Report Type page, select Create Paper Layout only, then click Next.


	
On the Style page, select Group Above, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT ALL COUNTRIES.COUNTRY_NAME,
           CUSTOMERS.CUST_LAST_NAME,
           CUSTOMERS.CUST_FIRST_NAME,
           CUSTOMERS.CUST_email
FROM CUSTOMERS, COUNTRIES
WHERE (CUSTOMERS.COUNTRY_ID = COUNTRIES.COUNTRY_ID) 




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called toc_index_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 35.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click COUNTRY_NAME, then click > to move the field to the Group Fields list.


	
Click Next.


	
On the Fields page, click >> to move all fields to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, click Next.


	
On the Template page, click Finish.


	
In the toolbar, click the Data Model view button. The data model should look like this:


Figure 35-4 Data model for the group above report

[image: Description of Figure 35-4 follows]






	
In the toolbar, click the Paper Layout view button. The Paper Layout view should look like this:


Figure 35-5 Paper Layout view of the group above report

[image: Description of Figure 35-5 follows]






	
Save your report as toc_your_initials.rdf. You have now created the data model and the basic layout for your report.









35.2.3 Create an After Parameter Form trigger and a format trigger

The steps in this section will show you how to create two triggers. The first trigger will use the SRW.SET_FORMAT_ORDER built-in procedure to format the Main section of the report first, then the Header and Trailer sections. The second trigger will fetch the number of the page on which each country name displays, and place that information into the table you created in Section 35.2.1, "Create a table in the database to hold the TOC data".



35.2.3.1 Create an After Parameter Form trigger

An After Parameter Form trigger is a function that executes after the parameter form is executed. In this section, you will set the trigger to change the order of the report execution, so that the Main section runs first.


To create an After Parameter Form trigger:

	
In the Object Navigator, under your report name (TOC_your_initials), expand the Report Triggers node.


	
Right-click AFTER PARAMETER FORM, then choose PL/SQL Editor from the pop-up menu.


	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function AfterPForm return boolean is
begin
  srw.set_format_order(srw.main_section, srw.header_section, srw.trailer_     section);  
  return (TRUE);
end;





	
Note:

You can also copy and paste the code from the provided file, toc_index_code.txt.










	
Click Compile.


	
Once the code has compiled, click Close.









35.2.3.2 Create a format trigger

In this section, you will create a format trigger based on the field F_COUNTRY_NAME. This field displays the country name. This format trigger will fetch the page number for each country name, so that the table of contents will enable the user to navigate to various parts of the report based on the name of the country.


To create a format trigger:

	
In the Object Navigator, under the Paper Layout node for your report, navigate to Main Section > Body > M_G_1_GRPFR > R_G_1, then click F_COUNTRY_NAME.



	
Tip:

If you cannot find this field, use the Find field at the top of the Object Navigator.








	
Choose Tools > Property Inspector to display the Property Inspector for this field.


	
Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.


	
In the PL/SQL Editor, type the following code:


function F_COUNTRY_NAMEFormatTrigger return boolean is
pageNum number;
begin
  -- get current page number
  srw.get_page_num(pageNum);
  -- insert row into table
  insert into toc_example
  values (:country_name, pageNum);  
  return (TRUE);
end;





	
Note:

You can also copy and paste this code from the provided file, toc_index_code.txt.










	
Click Compile.


	
Once the code is compiled, click Close, then close the Property Inspector.


	
Save your report.











35.2.4 Create a second query in the data model

The steps in this section will show you how to create a second query in the data model with a formula column that calculates the page range for the data under each country name. This query will fetch the information from the database table you created in Section 35.2.1, "Create a table in the database to hold the TOC data". You will later create a tabular layout to display this information in your table of contents.


To create a second query with a formula column:

	
In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT 
    TOPIC, 
    MIN(PAGE) FROMPAGE,
    MAX(PAGE) TOPAGE
FROM TOC_EXAMPLE
GROUP BY TOPIC




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called toc_index_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.











	
Click OK. Your data model should now look like this:


Figure 35-6 Data model with second query

[image: Description of Figure 35-6 follows]






	
In the Data Model view, click the Formula Column tool in the tool palette, then click in the group (G_TOPIC) for the second query.


	
While the formula column is selected, choose Tools > Property Inspector to display its Property Inspector.


	
Under General Information, set the Name property to TOC_pages, and the Datatype property to Character.


	
Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.


	
In the PL/SQL Editor, use the template to enter the following code:


function TOC_pagesFormula return Char is
begin
  if :fromPage = :toPage then
  return (:fromPage);
  else
  return (:fromPage ||'-'|| :toPage);
  end if;
end;





	
Note:

You can also copy and paste this code from the provided file, called toc_index_code.txt.










	
Click Compile.


	
Once the code is compiled, click Close.


	
Save the report.









35.2.5 Create a report block to display the table of contents

The steps in this section will show you how to create a tabular report block in the Header section of your report. This report block will display the headings in the table of contents (in this example, the country name), and the page range where the information can be found in the report.


To create a tabular report block in the Header section:

	
In the Paper Layout view, click the Header Section button in the toolbar.


	
Click the Report Block tool in the tool palette, then draw an area about about 5 inches (12.5 centimeters) wide and 1.5 inches (4 centimeters) high in the Paper Layout view. When you release the mouse button, the Report Block Wizard displays.


	
On the Style page, select Tabular, then click Next.


	
On the Groups page, click G_TOPIC and click Down to move it to the Displayed Groups list, then click Next.


	
On the Fields page, click each of the following fields in the Available Fields list, then click the right arrow (>) to move them to the Displayed Fields list, then click Next:

	
TOPIC


	
TOC_pages





	
On the Labels page, click Next.


	
On the Template page, click Finish.

Your report block displays in the Paper Layout view:


Figure 35-7 Paper Layout view of the Header Section

[image: Description of Figure 35-7 follows]






	
Save your report.









35.2.6 Run your simple table of contents report to paper


To run your report to paper:

	
Click the Run Paper Layout button in the toolbar.



	
Note:

To generate the table of contents (TOC), you must click the Run Paper Layout button. If you click the Paper Design view button, the change of format order will not take effect, thus the TOC will not be generated.










The table of contents displays on the first page of the report, and looks something like the following:


Figure 35-8 Table of contents page of the report

[image: Description of Figure 35-8 follows]






You can navigate to various pages in your report to view the data for each country. For example, when you navigate to page 1, you will see the e-mail addresses for the customers in Argentina:


Figure 35-9 Results for customers in Argentina

[image: Description of Figure 35-9 follows]









	
Note:

At this point, you can compare your report against the example file we have provided, toc.rdf. First, compile the PL/SQL by choosing Program > Compile > All, then run the report to paper.









For information on creating a multilevel table of contents, see Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".








1.7 Data Model Objects

The topics in this section discuss basic concepts of data model objects; for more advanced concepts, see Section 2.3, "Data Model Objects".

	
About queries


	
About groups


	
About database columns


	
About data links


	
About Query Builder






1.7.1 About queries

Queries provide the data for your report. You create a query using the Report Wizard, Data Wizard, or manually using the query tools in the Data Model tool palette. Queries can select data from any data source (Oracle, XML, JDBC, Text, or your own data source that you can access through the pluggable data source (PDS) API). You can also use a REF CURSOR to create queries (see Section 2.6.10, "About REF CURSOR queries").


Single-query reports

Reports built using one query are the simplest reports. The most popular formats for single-query reports are tabular, mailing label, form letter, and break (either group above or group left). In one report, you can display one query's data any number of times, even in different formats. You can query data without including it in the report output. This is useful for establishing relationships between multiple queries, performing calculations, and so on.

The figure below shows the data of one query formatted various ways.


Figure 1-10 Formatting the same data in different ways

[image: Formatting the same data in different ways]






Notice that the last report style (group left break) seems to use an entirely different query for its data than the first three. However, the data it displays was hidden in the other reports, and vice versa. With Oracle Reports Builder, you can query data without including it in the report output. This is useful for establishing relationships between multiple queries, performing calculations, and so on.


Multiquery reports

A report may contain any number of queries. Multiquery reports are useful when you want to:

	
produce multipart unrelated query reports.


	
produce multipart related query reports.


	
make your queries easier to maintain (often a report with a complex query containing embedded SELECT statements and joins can also be created with multiple simple queries that are linked; the latter are often easier for others to understand and maintain).


	
display the same data twice in a report with different sorting criteria.




If you create a report with multiple queries, you can either leave the queries unrelated, or establish a relationship between them using a data link.


Multipart unrelated query reports

If you do not link the queries, you will produce a multipart unrelated query report (commonly called a master/master report). These types of reports display lists of unrelated data. For example, in the report below, one query selects products and another selects customers. Notice that there is no relationship between the products and customers.


Figure 1-11 Unrelated queries

[image: report output]







Multipart related query reports

In many reports, the data fetched for one part of the report is determined by the data fetched for another part. This is termed a "master/detail," or "parent/child," relationship, and is defined with a data link between two queries. When you run a master/detail report, each row of the master (or parent) query will cause the detail (or child) query to be executed, retrieving only matching rows.


Usage notes

	
External queries are no longer supported.


	
Reduce the number of queries in your report as much as possible. In general, the fewer queries you have, the faster your report will run. While multiquery data models are often easier to understand, single-query data models tend to execute more quickly.


	
Queries are processed on the server.


	
To restrict the number of pages that a certain user can produce, insert a record into the PRODUCT_PROFILE table for that user.


	
The only times you should use multiquery data models are:

	
when you're fetching many large columns from the parent and only a few small columns from the child.


	
when you're trying to do things that the query type, such as a SQL query, does not support directly (for example, multiway outer join).


	
when you have complex views (for example, distributed queries or GROUP BY queries).


	
when you need but do not have or want to use a view.








Rationale

For a single-query report, Oracle Reports Builder opens only one cursor to fetch all of the master and detail records. For a two-query report, Oracle Reports Builder opens two cursors--one for each query--after appending the detail query's link to the WHERE clause of the detail query. Therefore, for each master record fetched in the master query, Oracle Reports Builder must rebind, execute, and fetch data from the detail query.


See also

Section 2.3.5, "About non-linkable queries"

Section 4.8.1, "Creating a query"






1.7.2 About groups

Groups are created to organize the columns in your report. Groups can do two things: separate a query's data into sets, and filter a query's data.

When you create a query, Oracle Reports Builder automatically creates a group that contains the columns selected by the query. You create additional groups to produce break levels in the report, either manually in the Data Model view or by using the Report Wizard to create a group above or group left report.

Create groups when you want to treat some columns differently than others. For example, you create groups to:

	
produce subtotals (that is, totals at a more granular level).


	
create breaks or cross products in your report output.




With the exception of cross-product groups, all user-created groups are called break groups.


Break groups

You create break groups to produce subtotals, print columns in a different direction, create breaks, and so on. A break group suppresses duplicate values in sequential records. For example, Oracle Reports Builder can select the department number for each record; however, the duplicate department numbers are not printed.


Cross-product groups

You create cross-product groups to perform mathematical cross products, which are generally used to create matrix reports.


Group filters

Filters enable you to conditionally remove records selected by your queries. Groups can have two types of filters:

	
Oracle Reports Builder packaged filters:

	
First, to display only the first n records for the group (for example, the first 5 records)


	
Last, to display only the last n records for the group





	
User-created filters, using PL/SQL.





See also

Section 2.3.6, "About links versus groups"

Section 2.6.9, "About group filters"

Section 1.3.2, "About group above reports"

Section 1.3.3, "About group left reports"

Section 2.1.8, "About matrix with group reports"

Section 4.5.1, "Creating a report"

Section 4.5.2, "Creating a multiquery group above report"

Section 4.8.7, "Creating a break group"

Section 4.8.8, "Creating a matrix (cross-product) group"






1.7.3 About database columns

A database column represents a column that is selected by the query, containing the data values for a report. For each column that you select in your query, Oracle Reports Builder automatically creates a column in the data model of your report. If you want to perform summaries and computations on database column values, you can create new columns manually in the Data Model view (for summary and formula columns) or by using the Report Wizard (for summary columns). You can also reassign one or more columns to a group or groups you have created.

In addition to the traditional column types (for example, date, number, character), Oracle Reports Builder also supports graphics or images columns, which are columns whose values can be:

	
graphics or images stored directly in the database. Such a column is usually of data type LONG or LONG RAW and contains a graphics or images. In this case, specify the graphic's format in the column's properties.


	
file names. The values of such a column are pointers to files stored in the operating system. In this case, specify in the column's properties that its values are file contents (Read from File) and the format of the files. Many graphics or images formats are supported, including BMP, CALS, CGM, GIF, JFIF, PCD, PCX, PICT, RAS, TIFF, and so on.





See also

Section 4.8.1, "Creating a query"

Section 4.8.5, "Selecting an image from the database"

Section 2.3.4, "About referencing columns and parameters"

Section 2.3.1, "About summary columns"

Section 2.3.2, "About formula columns"

Section 2.3.3, "About placeholder columns"






1.7.4 About data links

A data link (or parent-child relationship) relates the results of multiple queries. A data link can establish these relationships:

	
between one query's column and another query's column.


	
between one query's group and another query's group (this is useful when you want the child query to know about its parent's data).




A data link causes the child query to be executed once for each instance of its parent group. The child query is executed with the values of the primary key used by the parent.

When a report with a data link is executed, the data link is converted into a SQL clause (as specified in the link's Property Inspector) and appended to the child query if Oracle Reports Builder is able to parse the query.

Important note: If the query cannot be parsed, the query is not modified (for example, Oracle Reports Builder has no way to modify how the data is fetched when the query is defined for a pluggable data source).

Although links are commonly equijoins (for example, WHERE DEPTNO=DEPTNO), you can create links with various SQL clauses (that is, WHERE, HAVING, or START WITH) and conditions. If your database has database constraints, you can create a data link that derives its SQL clause and condition from the constraints. You can view the SELECT statements for the individual parent and child queries in Oracle Reports Builder, but cannot view the SELECT statement that includes the clause created by the data link you define.


Example

For the report below, the following link was defined:


Figure 1-12 Sample data link

[image: graphic depicting link definition]






The default group of the master query (containing the columns "Order ID" and "Customer") is the parent group; the detail query (the query to which "Item", "Product", and "Amount" belong) is the child query.


Figure 1-13 Sample data link output

[image: report output]









	
Note:

Oracle Reports Builder does not support data links between queries that contain column objects. If you attempt to create such a link, a message dialog box displays, which enables you to choose whether to create a group-to-group query instead (using the parent groups), or to cancel the operation. If you want to create a link between any type of column and a column object, you can manually modify the SQL statement in the child query, adding in the appropriate WHERE clause based on columns in the master query.










See also

Section 2.3.6, "About links versus groups"

Section 2.3.5, "About non-linkable queries"

Section 4.8.9, "Creating a data link"






1.7.5 About Query Builder

Query Builder is an easy-to-use data access tool designed for analysts, managers, and other business professionals. It provides a logical and intuitive means to access information from your organization's databases for analysis and reporting.

Query Builder is designed for professionals who do not have a computer programming or database background. Because of its powerful query features and its support of Structured Query Language (SQL) statements, experienced database users and programmers will find that Query Builder serves many of their needs as well.

In Query Builder's graphical Query window, you can specify a request for data from your organization's database(s). The request for data is called a query.

You can use Query Builder to define almost any query that you would build using a SQL SELECT statement. Query Builder automatically generates the appropriate SELECT FROM [table.column] clause based on columns displayed in the Query Builder workspace.


See also

Section 4.8.3, "Using Query Builder"








40.6 Run Your Report to Paper

Now that you have added space and created your format trigger, your report should display with space after every five records (or the number of records you specify in the Parameter Form).


To run your report:

	
Click the Run Paper Layout button in the toolbar. When the Parameter Form displays, click the Run button in the toolbar.




Your report displays in the Paper Design view, and should look something like this:


Figure 40-16 Final PL/SQL example report

[image: Description of Figure 40-16 follows]










26.3 Create a Multiple-Query Matrix

You can build a matrix report with multiple queries in the data model. A multiple-query data model is typically easier to conceptualize and code than a single-query, but the single-query data model typically performs better.



26.3.1 Create a new report manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.


To create a blank report:

	
Choose File > New > Report.


	
Select Build a new report manually, then click OK.









26.3.2 Create a data model with a cross product and data links

When you create a matrix report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the cross product group and the necessary links in the Data Model view.


To create the queries:

	
In the Data Model view, choose Insert > Query to display the Data Wizard.


	
If the Welcome page displays, click Next.


	
On the Query page, type Q_Year for the Query name, then click Next.


	
On the Data Source page, select SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT DISTINCT TO_CHAR (HIREDATE, 'YY') YEAR
FROM EMP





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called nested3_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 26.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click Next.


	
Click Finish to display the data model for your report in the Data Model view.


	
Repeat the steps above for a second query, but this time name your query Q_Dept and use the following SELECT statement:


SELECT DISTINCT DEPTNO
FROM EMP





	
Note:

You can enter these queries in any of the following ways:

	
Copy and paste the code from the provided text file called nested3_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Again, repeat the steps above for a third query, but this time name your query Q_Job and use the following SELECT statement:


SELECT DISTINCT JOB
FROM EMP


	
Again, repeat the steps above for a fourth query, but this time name your query Q_Salary and use the following SELECT statement:


SELECT TO_CHAR(HIREDATE, 'YY') YEAR,  DEPTNO,  JOB,
SUM(SAL) FROM EMP
GROUP BY TO_CHAR(HIREDATE, 'YY'),  DEPTNO,  JOB
ORDER BY TO_CHAR(HIREDATE, 'YY'),  DEPTNO,  JOB




Figure 26-5 Data model with four queries

[image: Description of Figure 26-5 follows]









	
Tip:

The order of the queries is significant in this case. Q_Dept must appear to the right of or below Q_Year in order for the values of DEPTNO to be nested inside of the values of YEAR in the output.













To create the cross product group:

	
In the Data Model view, click the Cross Product tool in the tool palette.


	
Drag a box around G_YEAR, G_DEPTNO, and G_JOB. When you release the mouse button, the cross product group is created. Ensure that it completely surrounds all three groups.





Figure 26-6 Data Model with four queries and a cross product group

[image: Description of Figure 26-6 follows]







To add the data links:

	
In the Data Model view, click the Data Link tool in the tool palette.


	
Click and drag from the YEAR column in the G_YEAR group to the YEAR1 column in the G_YEAR1 group.


	
Repeat steps 1 and 2, but this time drag the link between the DEPTNO column in G_DEPTNO and DEPTNO1 in G_YEAR1.


	
Again, repeat steps 1 and 2, but this time drag the link between the JOB column in G_JOB and JOB1 in G_YEAR1.


Figure 26-7 Nested matrix data model

[image: Description of Figure 26-7 follows]






	
Optionally, move the data model objects around to appear like the above figure.









26.3.3 Create the layout with the Report Wizard

Once your data model is complete, you need to create a layout for the data objects to display in the report output.


To create the layout:

	
In the Data Model view, right-click on the canvas, then choose Report Wizard.


	
In the Report Wizard, on the Report Type page, select Create Paper Layout only.


	
On the Style page, select Matrix.


	
On the Groups page, ensure that all of the groups from your data model appear in the Displayed Groups list. G_1 should be Matrix, G_YEAR and G_DEPTNO should be Down, G_JOB should be Across, and G_YEAR1 should be Down.


Figure 26-8 Groups page of the Report Wizard

[image: Description of Figure 26-8 follows]






	
On the Fields page, ensure that only the following columns appear in the Displayed Fields list:

	
YEAR


	
DEPTNO


	
JOB


	
SUM_SAL





Figure 26-9 Fields page of the Report Wizard

[image: Description of Figure 26-9 follows]






	
On the Labels page, change the labels and field widths as follows:


	Fields	Labels	Width
	
SUM_SAL

	
<none>

	
10


	
YEAR

	
<none>

	
4


	
JOB

	
<none>

	
10








	
On the Template page, make sure Beige is selected under Predefined Template, then click Finish to display your report output in the Paper Design view. It should look like this:


Figure 26-10 Paper Design view for the nested matrix output

[image: Description of Figure 26-10 follows]















39.2 New Features and Benefits

Oracle Reports provides a convenient way for you to add a wide variety of graphs to both paper-based and JSP-based Web Reports.

Oracle Reports 11g Release 2 (11.1.2) supports the following features:

	
Scalable Vector Graphics (SVG) image support


	
Plotting Irregular time periods. For more information, see Plotting Irregular Time Periods.


	
New Chart Style in Graph Wizard. For more information, see New Chart Styles.


	
Number formatting support in Graph Wizard




With the new graph types and features, Reports Builder provides the following benefits:

	
More graph types for the varied usage


	
Better graph image output without loosing resolution


	
Plot time data without restrictions


	
Format the numbers in the graph independent of the data model





Plotting Irregular Time Periods

Oracle Reports 11g Release 2 (11.1.2) provides support for plotting irregular time periods on time axis. For more information see Figure 39-1, "Plotting Irregular Time Period".


Figure 39-1 Plotting Irregular Time Period

[image: Description of Figure 39-1 follows]







New Chart Styles

Oracle Reports 11g Release 2 (11.1.2) supports the following new chart styles:

	
Autumn


	
Black and White


	
Earth


	
Executive


	
Financial


	
Projection


	
Regatta




For more information, see Figure 39-2, "New Chart Styles".


Figure 39-2 New Chart Styles

[image: Description of Figure 39-2 follows]









2 Advanced Concepts

This chapter introduces the concepts for advanced users of Oracle Reports. Each topic in this chapter is also included in the Advanced Concepts section of the Oracle Reports online Help.

Topics are grouped into the following sections:

	
Section 2.1, "Reports"


	
Section 2.2, "Web Reports"


	
Section 2.3, "Data Model Objects"


	
Section 2.4, "Layout Objects"


	
Section 2.5, "Parameter Form Objects"


	
Section 2.6, "PL/SQL"


	
Section 2.7, "Templates"


	
Section 2.8, "Output Formats and Capabilities"


	
Section 2.9, "Data Sources"


	
Section 2.10, "Debugging Tools"







16.6 Summary

Congratulations! You have successfully created a header and footer report. You now know how to:

	
create a data model and a layout.


	
move a summary field.


	
add a heading that repeats on all pages.


	
add white space and format values.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






1.9 Parameter Form Objects

The topics in this section discuss basic concepts of Parameter Form objects; for more advanced concepts, see Section 2.5, "Parameter Form Objects".

	
About parameters


	
About Parameter Form fields


	
About Parameter Form boilerplate


	
About Parameter Forms for Web reports






1.9.1 About parameters

A parameter is a variable whose value can be set at runtime (for example, from the Runtime Parameter Form or the command line). Parameters are especially useful for modifying SELECT statements and setting PL/SQL variables at runtime.

Oracle Reports Builder automatically creates a set of system parameters at runtime, but you can create your own as well. You can create parameters to replace either single literal values or entire expressions in any part of a query. You can reference parameters elsewhere in the report, such as in PL/SQL constructs providing conditional logic for the report.




	
Note:

While you can delete or rename a user parameter, you cannot delete or rename a system parameter.









Parameter values can be specified in these ways:

	
Accepting the default parameter values (default values are set in the Parameter properties, and you can control whether the values are displayed at runtime on the Runtime Parameter Form).


	
Typing the parameter value(s) as arguments on the command line (where applicable). Parameters specified on the command line override the equivalent system parameter values set in the report definition. For detailed information about command line arguments, see the "Command Line Keywords" appendix in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual, or the Oracle Reports online Help.


	
Choosing from a list or entering the parameter value(s) in the Runtime Parameter Form.





System parameters

Oracle Reports is shipped with the following system parameters. You can change their default values as described above.


Table 1-1 System parameter descriptions

	System Parameter	Description
	
COPIES

	
Is the number of report copies that should be made when the report is printed.


	
DESFORMAT

	
Is either:

	
the output format for the report (for example, PDF, HTML, HTMLCSS, RTF, XML, SPREADSHEET, DELIMITED, or DELIMITEDDATA for bitmapped reports).


	
the printer definition to use when formatting the report when DESTYPE=FILE and DESNAME=filename. If MODE=BITMAP, this is the name of the printer. If MODE=CHARACTER, this is the character mode printer definition file (.prt file).





	
DESNAME

	
Is the name of the output device (for example, the file name, printer's name, mail user ID).


	
DESTYPE

	
Is the type of device that will receive the report output (for example, SCREEN (to format the report using screen fonts), FILE, PRINTER, MAIL, SYSOUT, CACHE, or LOCALFILE.


	
MODE

	
Is whether the report should run in CHARACTER mode or BITMAP.


	
ORIENTATION

	
Is the print direction for the report (LANDSCAPE, PORTRAIT, DEFAULT).


	
PRINTJOB

	
Is whether the Print Job dialog box should appear before the report is run.









User parameters

You can create a user parameter in the following ways:

	
Create a parameter in the Object Navigator.


	
Use a bind parameter reference in a query, which causes Oracle Reports Builder to automatically create the parameter the first time it is referenced (see Section 2.3.4.1, "About bind references").





See also

Section 2.3.4, "About referencing columns and parameters"

Section 4.11.1, "Using a pre-defined system parameter"

Section 4.11.2, "Creating a user parameter"

Section 4.11.3, "Creating a list of values (LOV) for a parameter"

Section 4.11.4, "Validating a parameter value at runtime"

Section 4.11.6, "Selecting parameters to include in the Runtime Parameter Form"

Section 4.11.9, "Passing parameters to reports running in batch mode"






1.9.2 About Parameter Form fields

Fields in the Paper Parameter Form view (Section 1.6.5, "About the Paper Parameter Form view") act as placeholders for parameters. They define the formatting attributes for the parameters displayed in the Runtime Parameter Form. By default, one field is created for each parameter that you select in the Parameter Form Builder.


See also

Section 1.8.4, "About fields"

Section 4.11.5, "Creating a default Parameter Form"

Section 4.11.7, "Displaying the Parameter Form at runtime"






1.9.3 About Parameter Form boilerplate

Boilerplate in the Paper Parameter Form view refers to text and graphics that appear in the Runtime Parameter Form each time it is run; for example, a label denoting a particular parameter is boilerplate text created by Oracle Reports Builder. Lines or boxes that you create in the layout are also considered boilerplate, as well as any added text.

Boilerplate enables you to customize the Runtime Parameter Form. By default, a boilerplate label is produced for each field that appears on the Runtime Parameter Form.


See also

Section 1.8.5, "About boilerplate objects"

Section 4.11.5, "Creating a default Parameter Form"

Section 4.11.7, "Displaying the Parameter Form at runtime"






1.9.4 About Parameter Forms for Web reports

You can design a Parameter Form for both Web and paper reports. However, at runtime, the Runtime Parameter Form displays only when running the paper report layout. For JSP-based Web reports, the Runtime Parameter Form displays when you run your report within Oracle Reports Builder for debugging purposes, but will not display at runtime.

Because you now have the flexibility to display your reports on any Web page, the report may be just one object on a Web page containing many other portlets and objects, and parameters for the report may be retrieved from sources other than the Parameter Form. For example, parameters might be provided by the Web page to all portlets on the page. Therefore, it does not make sense to display a Runtime Parameter Form for JSP-based Web reports before the report is formatted.

In the absence of the Runtime Parameter Form, you will need to use an alternate method to provide required parameters to a JSP-based Web report designed with a Parameter Form. For example:

	
When you design the report, set all parameters to a default value.


	
If you run your report using a URL, provide the parameters through the URL.


	
Create an HTML form that your report calls to provide parameter values, either as static values, or as a list of values using the Oracle Reports custom JSP tags.


	
If the report displays as a portlet in a Web page, you can pass the page level parameters to the report.


	
Use the JSP tag <rw:reports id="myReport" parameters="yourParameterList">, where yourParameterList can be a Java variable. For example:


<% String myParameterList="userid=scott/tiger&p_deptno+10"; %>
<rw:report id="myReport" parameters="<%= myParameterList %>">




For more information on creating a Parameter Form for a JSP-based Web report, see Chapter 42, "Building a Simple Parameter Form for a JSP-based Web Report".




	
Note:

If you display your paper-based report on the Web, you can create an HTML Parameter Form by adding HTML header and footer tags using either:

	
the Property Inspector: set the Before Form Value property and After Form Value property for the report


	
PL/SQL: set format triggers using the SRW.SET_BEFORE_FORM_HTML and SRW.SET_AFTER_FORM_HTML procedures.













See also

Section 1.2.2, "About Web Reports"

Section 1.6.5, "About the Paper Parameter Form view"

Section 1.11.1, "About the Runtime Parameter Form"

Section 2.5.1, "About Parameter Form HTML extensions"








34.7 Summary

Congratulations! You have successfully created a ranking report. You now know how to:

	
create a data model and a tabular layout.


	
create parameters and group filter to control the ranking criteria.


	
add a layout object to display the parameter value in the report output.


	
create a Parameter Form that only displays the parameter you want users to set.


	
add a percentage ranking.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






41.9 Move the Packages Into a Library

If you have many reports that use these same REF CURSOR types and SELECT statements, you can move the program units that you created into a PL/SQL library stored in a file, so that other reports can easily share the code. The steps in this section will help you to move the program units to a PL/SQL library.


To move the packages into a library:

	
In the Object Navigator, click the PL/SQL Libraries node, then click the Create button in the toolbar to add a new library.


	
Choose File > Save As.


	
Type DEPT_CONTAINER as the Library.


	
Ensure that File System is selected.


	
Click OK.


	
Drag and drop the following program units from your report to the Program Units node under the newly created DEPT_CONTAINER library:

	
CONCL_CV (Package Spec)


	
CONT_CV (Package Spec)


	
CONT_CV (Package Body)


	
PORT_CV (Package Spec)





	
Save DEPT_CONTAINER.


	
If the Paper Design view is open, close it.


	
In the Object Navigator, under the Program Units node for your report, delete CONCL_CV (Package Spec), CONT_CV (Package Spec), CONT_CV (Package Body), and PORT_CV (Package Spec).



	
Note:

If the Paper Design view is open when you delete the packages from the report, you may get some errors.








	
Click the Attached Libraries node for your report, then click the Create button in the toolbar to add a new attached library.


	
Click Browse to find the DEPT_CONTAINER library. It will have a .PLL file extension. After you have found and selected DEPT_CONTAINER, click Open.


	
Click Attach.


	
Choose Program > Compile > All.


	
Click OK to close the Compile window.


	
Click the Run Paper Layout button in the toolbar to run the report and view it in the Paper Design view.


	
Save the report as ref_68_your_initials.rdf.









4.8 Work with the Data Model

This section provides procedures for the following tasks that you may perform as you work with the data model of your report:

	
Creating a query


	
Modifying a query


	
Using Query Builder


	
Selecting HTML tags from the database


	
Selecting an image from the database


	
Selecting an image URL from the database


	
Creating a break group


	
Creating a matrix (cross-product) group


	
Creating a data link


	
Creating or editing a formula column


	
Creating a summary column


	
Creating or editing a placeholder column






4.8.1 Creating a query

To create a query, you can use any of the following tools:

	
Report Wizard (single-query reports only)


	
Data Wizard


	
SQL Query tool (to create a query that selects data from an Oracle relational database)


	
XML Query tool (to access an XML data file, if you have the DTD file)


	
JDBC Query tool (to access any JDBC-enabled data source)


	
Text Query tool (to create a query that selects data from a text pluggable data source)


	
REF CURSOR Query tool (to use REF CURSORs)





See also

Section 1.7.1, "About queries"

Section 1.7.3, "About database columns"



4.8.1.1 Creating a query: Report Wizard

To create a query using the Report Wizard:

	
On the Data page of the Report Wizard, enter the query statements for the type of data source previously selected. For example, if you selected the SQL Query data source, you can enter your SQL query in any of the following ways:

	
Type the SELECT statement in the Data Source definition field.


	
Click Query Builder for a graphical method of creating a query without a knowledge of SQL.


	
Click Import Query to use a query that has been written by someone else or to use the text editor of your choice.












4.8.1.2 Creating a query: Data Wizard

To create a query using the Data Wizard:

	
In the Data Model view, choose Insert > Query to display the Data Wizard.


	
Follow the wizard to create the first query for the data model.


	
Repeat Steps 1 and 2 for each query you want to create.


	
Modify the resulting data model in the Data Model view.


	
To re-enter the Data Wizard, do either of the following:

	
Right-click, and choose Data Wizard.


	
Click the query, then choose Edit > Settings.



	
Note:

The Data Wizard does not support creating links between queries. To define parent/child query relationships, you can create a data link manually.


















4.8.1.3 Creating a query: SQL Query tool

To create a SQL query:

	
In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, define a SELECT statement for the query in any of the following ways:

	
To use Query Builder for an easy graphical method of creating a query without a knowledge of SQL, click Query Builder.


	
To import a query from a file, click Import Query.


	
To enter the SELECT statement yourself, type it in the SQL Query Statement field.



	
Tip:

Select the columns in the order you want them to appear in the report output.











	
Click OK.


	
Refine the query using either of the following methods:

	
Right-click the query object, then choose Property Inspector to set desired properties.


	
Right-click the query object, then choose Data Wizard to specify which fields to display, group fields, and any totals.





	
Repeat Steps 1 through 5 for each query you want to create.



	
Note:

If you define multiple queries in the Data Model view of your report, the Data page does not appear when you invoke the Report Wizard to default the layout.















4.8.1.4 Creating a query: XML Query tool

To create an XML query:

	
In the Data Model view, single-click the XML Query tool in the tool palette.


	
Click in the main area (canvas region) of the window.


	
In the Define XML Query dialog box, define the XML query based on the fields defined in the data definition file (DTD) selected. The query is run against the data in the XML data file. If an XSL file is specified, it translates the XML data file before running the query.


	
Click OK.









4.8.1.5 Creating a query: JDBC Query tool

To create a JDBC query:

	
In the Data Model view, single-click the JDBC Query tool in the tool palette.


	
Click in the main area (canvas region) of the window.  


	
In the JDBC Query dialog box, define the JDBC query or procedure and the connection parameters for the data source. Click Help for assistance.


	
Click OK.









4.8.1.6 Creating a query: Text Query tool

To create a Text query:

	
In the Data Model view, single-click the Text Query tool in the tool palette.


	
Click in the main area (canvas region) of the window.


	
In the Define Text Query dialog box, specify the data definition and data source for the text query. Click Help for assistance.


	
Click OK.









4.8.1.7 Creating a query: REF CURSOR Query tool

To create a REF CURSOR query:

	
Create a package that defines a REF CURSOR type in one of the following ways:

	
Create a local program unit (see Section 4.13.3.1, "Creating a local program unit")


	
Create an external PL/SQL library (see Section 4.13.5.1, "Creating an external PL/SQL library")


	
Create a stored program unit (see Section 4.13.3.2, "Creating a stored program unit")





	
If the package created in Step 1 is an external PL/SQL library, you must attach it to the report before referencing it.


	
In the Data Model view, single-click the REF CURSOR Query tool in the tool palette.


	
Click in the main area (canvas region) of the window.


	
In the PL/SQL Editor, type the PL/SQL for a function that opens a cursor and returns a cursor variable of the REF CURSOR type you defined in the package. For example:


empCur rcPackage.empCurType;

BEGIN
  OPEN empCur FOR SELECT * FROM emp;
  RETURN empCur;
END; 

/* Note, rcPackage is a local program unit defined as: */
PACKAGE rcPackage IS
  TYPE empCurType IS REF CURSOR RETURN emp%ROWTYPE;
END; 





	
Note:

Oracle Reports supports both static and dynamic REF CURSORs. For more information, see Section 2.6.10, "About REF CURSOR queries".










	
Refine the query as desired:

	
Click the REF CURSOR query object, then choose Tools > Property Inspector to modify properties.


	
Click the query object, then choose Tools > Data Wizard to specify which fields to display, group fields, and any totals.





	
Repeat Steps 1 through 6 for each REF CURSOR query you want to create.





See also

Section 2.6.10, "About REF CURSOR queries"








4.8.2 Modifying a query

To modify a SQL query statement or the columns displayed in your report:

	
In the Data Model view, click the query object, then right-click and choose Data Wizard.


	
To change the SELECT statement, click the Data tab.


	
To change the break groups, click the Groups tab.


	
To add or change summary columns for totals, click the Totals tab.


	
To change which selected database columns are displayed in your report, choose Tools > Report Wizard, then click the Fields tab.




To modify the properties of a query:

	
In the Data Model view, click the query object, then right-click and choose Property Inspector.


	
In the Property Inspector, modify the properties as desired.









4.8.3 Using Query Builder

You can use Query Builder to define almost any query that you would build using a SQL SELECT statement. Query Builder automatically generates the appropriate SELECT FROM [table.column] clause based on columns displayed in the Query Builder workspace.

See the How To section of the Oracle Reports online Help for topics about using Query Builder.


See also

Section 1.7.5, "About Query Builder"






4.8.4 Selecting HTML tags from the database




	
Note:

This procedure applies to paper-based reports.









To select HTML tags from the database:

	
Create a query, with a SELECT statement that selects a column containing HTML tags or the names of files that contain HTML tags.


	
In the Data Model view, double-click the HTML tags column to display the Property Inspector.


	
If the column contains the names of files that contain the HTML tags, rather than the HTML tags themselves:

	
Under the Column node, set the Read from File property to Yes.


	
Set the File Format property to Text.





	
In the Paper Layout view, create a field object that references the column.


	
Double-click the field object to display the Property Inspector.


	
In the Property Inspector, under the Web Settings node, set the Contains HTML Tags property to Yes.





Usage notes

When the text object's Contains HTML Tags property is set to Yes, HTML tags and attributes are formatted in your report output as follows:

	
If the report is generated to HTML or HTMLCSS output, all HTML tags and attributes are interpreted and formatted in the output.


	
If the report is generated to other bitmap output formats (for example, PDF, RTF, PostScript), a fixed set of HTML tags and attributes are interpreted and formatted in the output, as described in Section 2.8.9, "About HTML formatting". Any HTML not in the supported set of tags and attributes are not interpreted, and appear as is in the report output.









4.8.5 Selecting an image from the database




	
Note:

These steps, and the steps in Section 4.9.8.1.2, "Linking an image object to a file" (for paper-based reports only), allow you to include images in a wide variety of formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM. For paper-based reports, you can also use Insert > Image to import an image from a file into the report layout for images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD (see Section 4.9.8.1.1, "Importing an image").









To select an image from the database:

	
Create a query that selects a column containing images or the filenames of image objects.


	
In the Data Model view, double-click the image column to display the Property Inspector.


	
If the column contains the filenames of image objects, rather than the images themselves:

	
Under the Column node, set the Read from File property to Yes.





	
In both cases (a column containing images or a column containing the filenames of image objects): under the Column node, set the File Format property to Image.


	
If you are developing a JSP-based Web report, you will also need to add the containsHtml attribute to the <rw:field> JSP tag for the column, as follows:

	
Display the Web Source view for the report.


	
Search for the rw:field tag for the column (<rw:field ... src="column_name" ...>)


	
Add the containsHtml=yes attribute to specify that the field's value contains an image.

For example:


<rw:field id="F_MYIMAGE" src="MYIMAGE" nullValue="&nbsp;" containsHtml="yes">





	
To preview your report output with Web layout in a Web browser, choose Program > Run Web Layout to run the Web Source. If you have made changes to the Web Source view (for JSP-based Web reports), this enables you to immediately see the effect of your changes on the output.





See also

Section 2.4.3, "About images"

Section 1.7.3, "About database columns"






4.8.6 Selecting an image URL from the database




	
Notes:

This procedure is for HTML output only.

These steps, and the steps in Section 4.9.8.1.3, "Linking an image object to a URL" (for paper-based reports only), allow you to include images in a wide variety of formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM. For paper-based reports, you can also use Insert > Image to import an image from a file into the report layout for images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD (see Section 4.9.8.1.1, "Importing an image").









To select a URL from the database that point to an image to include in an HTML report:

	
Create a query, with a SELECT statement that selects a column containing URLs.


	
In the Data Model view, double-click the column containing the URLs to display the Property Inspector.


	
Under the Column node:

	
Set the Read from File property to Yes.


	
Set the File Format property to Image URL.





	
If you are developing a JSP-based Web report, you will also need to add the containsHtml attribute to the <rw:field> JSP tag for the column, as follows:

	
Display the Web Source view for the report.


	
Search for the rw:field tag for the column (<rw:field ... src="column_name" ...>)


	
Add the containsHtml=yes attribute to specify that the field's value contains an image.

For example:


<rw:field id="F_MYIMAGE" src="MYIMAGE" nullValue="&nbsp;" containsHtml="yes">





	
To preview your report output with Web layout in a Web browser, choose Program > Run Web Layout to run the Web Source. If you have made changes to the Web Source view (for JSP-based Web reports), this enables you to immediately see the effect of your changes on the output.





See also

Section 2.4.3, "About images"

Section 2.8.8, "About HTML and HTMLCSS output"






4.8.7 Creating a break group

You can define break groups in the Report Wizard or create them manually.

To create a break group manually:

	
In the Data Model view, drag the group that contains the column at which you want to break your report down from the query object about 2 inches (5 centimeters).


	
Select the column that you want to use to divide your report (for example, if you want to group a list of employee data by department number, select the department number column) and drag it out of and above the group to create a new group. This is the break column.


	
Double-click the new group object to display its Property Inspector, where you can set properties for the break group.





See also

Section 1.7.2, "About groups"

Section 1.3.2, "About group above reports"

Section 1.3.3, "About group left reports"






4.8.8 Creating a matrix (cross-product) group

You can define matrix groups in the Data Wizard or create them manually.To create a matrix (cross-product) group using the Data Wizard:

	
In the Data Model view, right-click and choose Data Wizard.


	
On the Query page, select the Matrix query check box.


	
Follow the wizard to select the columns for the matrix group(s), rows, columns, and cells.

To create a matrix (cross-product) group manually:


	
In the Data Model view, drag the title bar of the group object down.


	
Drag the "row" column and "column" column out of the group object into the space to create two new groups.


	
Single-click the Cross Product tool in the tool palette.


	
Drag a box around the groups you want to include in the matrix (cross-product) group.


	
If the cell group is a separate query from the matrix (cross-product) groups, create the appropriate links between the columns in the matrix groups and the cell group.





See also

Section 2.3.7, "About matrix objects"

Section 1.3.7, "About matrix reports"

Section 2.1.7, "About nested matrix reports"

Section 2.1.8, "About matrix with group reports"

Section 1.7.2, "About groups"

Section 4.9.1.3, "Creating a matrix object"

Section 4.5.3, "Creating a nested matrix report"

Section 1.3.2, "About group above reports"

Section 1.3.3, "About group left reports"






4.8.9 Creating a data link

To create a data link:

	
In the Data Model view, single-click the Data Link tool in the tool palette. A link is always drawn from the parent group to the child query.


	
Create the link:

Create a Group to Group Link: To create a link between one query's group and another query's group, which is useful when you want the child query to know about the parent's data, click the parent group (avoiding the columns in the group) and drag a link to the child group.

Create a Column to Column Link: To create a link between columns, click a column of the parent query and drag a link to a column of the child query.


	
Double-click the new link object to display the Property Inspector, and set the desired properties.





See also

Section 1.7.4, "About data links"

Section 2.3.5, "About non-linkable queries"






4.8.10 Creating or editing a formula column

To create or edit a formula column:

	
In the Data Model view, single-click the Formula Column in the tool palette, then:

	
To create a column within a group, click in the group at the position you want the column placed in the hierarchy.


	
To create a report-level column, click in an open area of the canvas region.





	
Double-click the formula column object to display the Property Inspector.


	
Under the Placeholder/Formula node, double click the PL/SQL Formula property field.


	
In the PL/SQL Editor, define the PL/SQL for the formula for example SAL * 0.07.





Example: Referencing a PL/SQL function in formulas

Suppose that you have a report with the following groups and columns:


Groups  Columns         Summary
---------------------------------------
RGN     REGION
        RGNSUMSAL       SUM(DEPTSUMSAL)
        COSTOFLIVING
                
DEPT    DNAME
        DEPTNO
        DEPTSUMSAL      SUM(EMP.SAL)
 
JOB     JOB
        HEADCOUNT       COUNT(EMP.EMPNO)
 
EMP     ENAME
        EMPNO
        SAL
        COMM


Given these groups and columns, you might create multiple formulas that apply the cost of living factor (COSTOFLIVING) to salaries. To avoid duplication of effort, you could create the following PL/SQL function and reference it from the formulas:


function CompSal(salary number) return number is
begin
  return (salary*CostofLiving);
end;


Following are some examples of how you might reference the PL/SQL function in formulas:


CompSal(:RGNSUMSAL)


or


CompSal(:SAL) + COMM



See also

Section 2.3.2, "About formula columns"






4.8.11 Creating a summary column

To create a summary column (for totals or subtotals) using the Data Wizard:

	
In the Data Model view, click the query that contains the column you want to total.


	
Choose Tools > Data Wizard.


	
On the Totals page, follow the wizard to add the desired summary to your report.



	
Note:

For group reports, the Report Wizard and Data Wizard create n summary fields in the data model for each summary column you define: one at each group level above the column being summarized, and one at the report level. For example, if a report is grouped by division, and further grouped by department, then a summary column defined for a salary total would create fields for the sum of salaries for each division and each department group (group-level summaries), and the sum of all salaries (report-level summary).










To create a summary column (for totals or subtotals) using the tool palette:

	
In the Data Model view, single-click the Summary Column tool in the tool palette, then:

	
To create a column within a group, click in the group at the position you want the column placed in the hierarchy.


	
To create a report-level column, click in an open area of the canvas region.





	
Double-click the new summary column object to display the Property Inspector.


	
Under the Summary node:

	
Set the Function property by choosing the type of summary you want from the list.


	
Set the Source property to the column you want to summarize.


	
Set the Reset At property to the group at which the summary column value resets.








Usage notes

For JSP-based Web reports with a Group Above or Matrix style, if any summary column values are not correctly left-aligned when you click the Run Web Layout button in the toolbar (or choose Program > Run Web Layout), you can implement the following workaround to align the values:

	
In the Web Source view, locate the section where the summary column is defined, and delete the following line to remove the extra space:


<th class="summary_column_name"> </th>





See also

Section 2.3.1, "About summary columns"

Chapter 9, "Building a Summary Report"

Chapter 13, "Building a Group Left Summary Report"






4.8.12 Creating or editing a placeholder column

To create or edit a placeholder column:

	
In the Data Model view, single-click the Placeholder Column tool in the tool palette.

	
To create a column within a group, click in the group at the position you want the column placed in the hierarchy.


	
To create a report-level column, click in an open area of the canvas region.





	
Double-click the placeholder column object.


	
In the Property Inspector, set the desired properties for the placeholder column.


	
Set the value of a placeholder column in:

	
the Before Report trigger, if the placeholder is a report-level column


	
a report-level formula column, if the placeholder is a report-level column


	
a formula in the placeholder's group or a group below it (the value is set once for each record of the group)








See also

Section 2.3.2, "About formula columns"








16.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






31.4 Create a Query That Returns the Items in the Order

The steps in this section will show you how to manually create a query in the Data Model view that will return the items in the customer's order. This data retrieved will be used to display the order details in the check stub.


To manually create a query:

	
In the Data Model view, click the SQL Query tool in the tool palette, then click an open area in the Data Model view to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT ALL
    ORDER_ITEMS.LINE_ITEM_ID,
    ORDER_ITEMS.ORDER_ID,
    ORDER_ITEMS.PRODUCT_ID,
    ORDER_ITEMS.UNIT_PRICE,
    ORDER_ITEMS.QUANTITY,
    PRODUCT_INFORMATION.PRODUCT_NAME
FROM ORDER_ITEMS, PRODUCT_INFORMATION
WHERE PRODUCT_INFORMATION.PRODUCT_ID=ORDER_ITEMS.PRODUCT_ID
ORDER BY ORDER_ITEMS.LINE_ITEM_ID ASC




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called spellcash_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.











	
Click OK. Your query displays in the Data Model view, and should look something like this:


Figure 31-8 Data Model with two queries

[image: Description of Figure 31-8 follows]






	
In the Data Model view, click the Data Link tool in the tool palette.


	
In the first query, Q_1, under G_ORDER_ID, click ORDER_ID, then drag the line to ORDER_ID1 in Q_2.


	
Your data model should now look like this:


Figure 31-9 Data Link between two queries

[image: Description of Figure 31-9 follows]






	
Save your report.









18.2 Create a Simple Report Definition

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. In this example, you will use the Report Wizard to create your query and basic report layout.


To create the report definition:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Group Above, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT ALL DEPARTMENTS.DEPARTMENT_ID, EMPLOYEES.FIRST_NAME, EMPLOYEES.LAST_
NAME, EMPLOYEES.JOB_ID, EMPLOYEES.SALARY, JOBS.JOB_TITLE
FROM DEPARTMENTS, EMPLOYEES, JOBS
WHERE ((DEPARTMENTS.DEPARTMENT_ID = EMPLOYEES.DEPARTMENT_ID)
AND (EMPLOYEES.JOB_ID = JOBS.JOB_ID)) 
ORDER BY DEPARTMENTS.DEPARTMENT_ID




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called graphics_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 18.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click DEPARTMENT_ID and click the right arrow (>) to move this field to the Group Fields list, then click Next.


	
On the Fields page, move all fields except JOB_ID to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, change the label Department Id to Department, then click Next.


	
On the Template page, select Predefined Template and click Blue, then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 18-2 Paper Design view for the graphics report with one query

[image: Description of Figure 18-2 follows]













5.2 Use the Report Wizard to Create a Report

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the simple report in this example, you can use the Report Wizard. Using the wizard enables you to define the layout for the report, as well as set the data definition.


To create a simple report:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Tabular, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT ALL DEPARTMENTS.DEPARTMENT_ID, DEPARTMENTS.DEPARTMENT_NAME, 
DEPARTMENTS.MANAGER_ID, DEPARTMENTS.LOCATION_ID
FROM DEPARTMENTS
ORDER BY DEPARTMENTS.DEPARTMENT_ID




	
Tip:

This query selects all the department IDs, the department names, the manager IDs, and the location IDs, then sorts the data by the department IDs.











	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called tabular_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.













	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 5.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, click Next.


	
On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 5-2 Paper Design view for the tabular report

[image: Description of Figure 5-2 follows]









	
Note:

In the Paper Design view, you can see how the tabular report displays the data like a table, in order of department ID number.










	
Save the report as tabularreport_your_initials.rdf.









12.2 Create Two Queries

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. In this example, you will use the Data Model view to create your two queries, then use the tool palette to create a data link between the two queries to relate the data tables.


To create two queries:

	
Launch Reports Builder (or, if already open, choose File > New > Report)


	
In the Welcome or New Report dialog box, select Build a new report manually, then click OK.


	
In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT ALL DEPARTMENTS.DEPARTMENT_ID, DEPARTMENTS.DEPARTMENT_NAME, 
DEPARTMENTS.MANAGER_ID, DEPARTMENTS.LOCATION_ID
FROM DEPARTMENTS 





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called acrossbreak_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.













	
Click OK.

The data model for your new query displays:


Figure 12-2 Data Model for Query 1

[image: Description of Figure 12-2 follows]






	
Create another query, this time using the following code:


SELECT ALL EMPLOYEES.LAST_NAME, EMPLOYEES.FIRST_NAME, EMPLOYEES.DEPARTMENT_ID
FROM EMPLOYEES 
ORDER BY EMPLOYEES.LAST_NAME




	
Note:

You can also copy and paste the code from the text file provided in the acrossbreak folder, called acrossbreak_code.txt.








	
Click OK.


	
In the Data Model view, click the Data Link tool in the tool palette.


	
Click and drag your mouse from DEPARTMENT_ID column in Q_1, to DEPARTMENT_ID1 in Q_2 to create a data link between the two queries.

Your data model should now look like this:


Figure 12-3 Data Model of the two linked queries

[image: Description of Figure 12-3 follows]









	
Note:

You can right-click the data link, then choose Property Inspector from the pop-up menu to ensure that the data link was created properly.

















23.2 Create the Data Model and Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.


To create a data model and layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report)


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Form Letter, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT ENAME, COMM FROM EMP
ORDER BY ENAME





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called condform_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.













	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 23.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
Type the first paragraph of your letter in the Form Letter Text window:


Dear Employee  &<ENAME>, 

Mark your calendar! You are invited to 
attend the Summit Sporting Goods annual
picnic on June 15, from 11:00 AM to 
6:00 PM.  Be prepared for lots of food,
lots of entertainment, and lots of fun.




	
Tip:

Be sure to include hard returns at the end of each line.








	
Click Next.


	
On the Template page, select No template, then click Finish to preview your report output in the Paper Design view.


	
Save the report as condform_your_initials.rdf.









36.2 Create a table in the database to hold the TOC data

The steps in this section will show you how to create a table in the database that will hold the page numbers for the main and sub-categories in the report. If you are not sure if you can create a table in the database, contact the database administrator.


To create a table in the database:

	
Start SQL*Plus.

	
On Windows, from the Start menu, choose Programs > Oracle Application Server - oracle_home_name > Application Development > SQL Plus.


	
On UNIX, type sqlplus.





	
Connect to the Sales History schema of the database (for example, use the sh/sh@database_name connect string).


	
At the SQL prompt, type the following line:


create table toc_multilevel (main_topic varchar2(100), sub_topic varchar2(100), page number);


	
Press Enter.

You should see a notification that the table has been created.


	
Exit SQL*Plus.
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12.5 Summary

Congratulations! You have successfully created an across group paper report. You now know how to:

	
manually create a data model with two queries.


	
create a master/detail report using the Report Block Wizard.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






7.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






23.5 Summary

Congratulations! You have successfully created a conditional form letter report. You now know how to:

	
create a data model and a layout.


	
add text.


	
anchor objects together and create format triggers to control whether the text displays.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






36.5 Create a Report Block to Display the Table of Contents

The steps in this section will show you how to create a group above report block in the Header section of your report. This report block will display two levels of headings in the table of contents. You will also add a field to your layout to display the page number where each heading is found in report.


To create a group above report block in the Header section:

	
In the Paper Layout view, click the Header Section button in the toolbar.


	
Click the Report Block tool in the tool palette, then draw an area about 6 inches (15 centimeters) wide and 1.5 inches (4 centimeters) high. Release the mouse button to display the Report Block Wizard.


	
In the Report Block Wizard, on the Style page, select Group Above, then click Next.


	
On the Groups page, click G_MAIN_TOPIC, then click Down to move it to the Displayed Groups list.


	
In the Available Groups list, click G_1, then click Down to move it to the Displayed Groups list.


	
Click Next.


	
On the Fields page, click each of the following fields in the Available Fields list, then click the right arrow (>) to move them to the Displayed Fields list, then click Next.

	
MAIN_TOPIC


	
SUB_TOPIC


	
PAGE





	
On the Labels page, clear all the labels, then click Next.


	
On the Template page, click Finish.

Your report block displays in the Paper Layout view:


Figure 36-4 Paper Layout view of the Header Section

[image: Description of Figure 36-4 follows]






	
Click the Field tool in the tool palette and create a field above the PAGE field, next to the F_MAIN_TOPIC field.


	
Double-click the new field object to display the Property Inspector, and set the following properties:

	
Under Field, set the Source property to Subcategory_Page.


	
Under Summary, set the Reset At property to G_1.





	
Save your report.









31.3 Create a Formula Column That returns the Spelled-Out Cash Amounts

The steps in this section will show you how to create a formula column that is based on a function. The function you create will return verbal or word value for the numerical value of the check. You will then create a formula column that will spell out the numerical value in the designated currency. In this case, we will use dollars and cents.



31.3.1 Create a PL/SQL function

In this section, you will create a function that simply returns the check amount in word format, such as "twenty-four sixty-five." The formula column you create in the next section will use the information retrieved by this function to spell out the cash amounts on your checks.


To create a PL/SQL function:

	
In the Object Navigator, under your report name, double-click Program Units.


	
In the New Program Unit dialog box, type Spell in the Name box.


	
Select Function, then click OK.


	
In the PL/SQL Editor, type the following code:


FUNCTION Spell (val number) RETURN CHAR IS
  sp varchar2(100);
BEGIN
  if val > 0 then
         return(initcap(to_char(to_date(val, 'SSSSS'), 'SSSSSSP')));
  else
         return('');
  end if;
END;




	
Note:

You can enter this code by copying and pasting it from the provided text file called spellcash_code.txt into the PL/SQL Editor.








	
Click Compile. If you see any errors, compare your code against the code shown in the image below:


Figure 31-3 PL/SQL Editor displaying the SPELL function

[image: Description of Figure 31-3 follows]






	
When your code successfully compiles, click Close.

Your new function now displays in the Object Navigator:


Figure 31-4 Object Navigator with SPELL PL/SQL function

[image: Description of Figure 31-4 follows]






	
Save your report.









31.3.2 Create a formula column in your data model

In this section, you will create a formula column that uses the information retrieved by the Spell function you created in Section 31.3.1, "Create a PL/SQL function". This formula column will use the verbal values of the check amounts and combine the words with the correct currency. For example, the "twenty-four sixty-five" returned by the Spell function will be turned into "twenty-four dollars and sixty-five cents".


To create a formula column:

	
In the Object Navigator, under your report name, double-click the view icon next to the Data Model node to display the Data Model view.

Your data model should look like this:


Figure 31-5 Data Model view

[image: Description of Figure 31-5 follows]






	
Resize the G_ORDER_ID box by clicking at the top, then dragging the bottom center resize handle downwards. Your data model should now look something like this:


Figure 31-6 Resized Data Model view

[image: Description of Figure 31-6 follows]






	
Click the Formula Column tool in the tool palette.


	
Click in the G_ORDER_ID group, in the space you just created, to create a new formula column.


	
Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to SPELLED_AMOUNT.


	
Under Column, set the Datatype property to CHARACTER, and the Width property to 100.


	
Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function SPELLED_AMOUNTFormula return Char is
cents number;
c_str varchar2(80);
val number;
begin
  val := :order_total;
  cents := (val mod 1) * 100;
  if cents > 0 then --creates string for cents
  c_str := ' and ' || TO_CHAR(cents) || '/100 Dollars******';
   else
  c_str := ' Dollars******';
  end if;
  if val < 1000 and val > 1 then
  return (initcap(spell(floor(val))) || c_str);
  elsif val > 1000 then
   return(initcap(spell(floor(val/1000))) || ' Thousand ' ||
   spell(floor(val mod 1000)) || c_str);
  else
   return('Zero'||c_str);
  end if;
end;




	
Note:

You can enter this code by copying and pasting it from the provided text file called spellcash_code.txt into the PL/SQL Editor.








	
Click Compile. If you see any errors, compare your code against the code we have provided.


	
When your code successfully compiles, click Close.

Your new formula column, called SPELLED_AMOUNT, now displays in the data model.


Figure 31-7 Data Model with SPELLED_AMOUNT formula column

[image: Description of Figure 31-7 follows]






	
Save your report.











28.2 Create a Query and the Layout

The steps in this section will show you how to build a simple data model and report layout in the Report Wizard, which you can then use to generate either a JSP-based Web report or a paper report. In the next section, you will modify the JSP so that the appropriate information displays in your Web report.

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.


To create a data model and layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create both Web and Paper Layout, then click Next.


	
On the Style page, type a Title for your report, select Group Left, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT O.CUSTID, O.SHIPDATE, O.TOTAL,
AVG(A.TOTAL) MAVG
FROM ORD O, ORD A
WHERE A.CUSTID = O.CUSTID
AND A.SHIPDATE BETWEEN O.SHIPDATE -123 AND O.SHIPDATE
GROUP BY O.CUSTID, O.SHIPDATE, O.TOTAL




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called timeseries_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 28.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click CUSTID and click the right arrow (>) to move this field to the Group Fields list, then click Next.


	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, change the label for MAVG to 4-Month Moving Average, then click Next


	
On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view.


	
In the Paper Design view, double-click field F_MAVG to display the Property Inspector, and set the following properties:

	
Under Field, set the Format Mask property to LNNNGNN0D00.





	
Do the same for field F_TOTAL.


	
Select the first number value underneath the Total label. Notice that all of the values are immediately selected.Shift-click the first number value underneath the 4-Month Moving Average label.Click the Align Right button. All of the values are immediately right aligned.


	
The report in the Paper Design view should now look something like this:


Figure 28-2 Paper Design view of the Time Series Calculations report

[image: Description of Figure 28-2 follows]






	
To view the data model you just created using the Report Wizard, click the Data Model button in the toolbar. The same data model can be used for both your paper and your JSP-based Web reports.

Your data model should look something like this:


Figure 28-3 Data Model view of the Time series Calculations report

[image: Description of Figure 28-3 follows]






	
Save your report as timeseries_your_initials.rdf.








List of Examples

	45-1 "Nested" XML Data File
	45-2 "Flattened" XML Data File
	45-3 Corresponding "Nested" XML Schema File
	45-4 Corresponding "Flattened" XML Schema File





8.7 Summary

Congratulations! You have successfully created a master/master report. You now know how to:

	
create queries with the Data Wizard.


	
layout the data with the Report Wizard.


	
create white space in the Paper Layout view.


	
format fields in the Paper Design view.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






19.3 Add a Second Query

In the Paper Design view, the data is grouped by the Sales Representative with customer data listed below each Sales Representative.


Figure 19-4 Report layout in the Paper Design view

[image: Description of Figure 19-4 follows]






All the data will display on one page and the individual sales transactions for each customer is not yet available. You will need an additional query in the Data Model to accomplish this.


To add a new query to the report:

	
Click the Data Model button in the toolbar.


	
In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT CUSTID,PRODNAME,AMOUNT
FROM SALES
ORDER BY CUSTID





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called pagenum_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.













	
Click OK to display the new query in the Data Model view.


	
In the Data Model view, click the Data Link tool in the tool palette.


	
Using the cross hairs of the cursor, click CUSTID in the G_NAME group and drag the cursor to custid1 in the G_custid1 group, then release the mouse button to link the CUSTID and custid1 fields between the two groups.


	
Position the Report Editor window to display it alongside the Object Navigator so that you can view both windows simultaneously.


	
In the Object Navigator, under the Data Model node, expand the Groups node. Then, under the Paper Layout node, expand the Main Section node. Compare these two structures and note that even though additional data is made available in the Data Model by adding query Q_2, the Paper Layout will not use this additional data unless modified to do so. We will do this next.









2.3 Data Model Objects

The topics in this section build on the basic concepts discussed in Section 1.7, "Data Model Objects".

	
About summary columns


	
About formula columns


	
About placeholder columns


	
About referencing columns and parameters


	
About non-linkable queries


	
About links versus groups


	
About matrix objects






2.3.1 About summary columns

A summary column performs a computation on another column's data. Using the Report Wizard or Data Wizard, you can create the following summaries: sum, average, count, minimum, maximum,% total. You can also create a summary column manually in the Data Model view, and use the Property Inspector to create the following additional summaries: first, last, standard deviation, variance.

If your report requires a customized computation, for example, one that computes sales tax, create a formula column (see Section 4.8.10, "Creating or editing a formula column").




	
Note:

For group reports, the Report Wizard and Data Wizard create n summary fields in the data model for each summary column you define: one at each group level above the column being summarized, and one at the report level. For example, if a report is grouped by division, and further grouped by department, then a summary column defined for a salary total would create fields for the sum of salaries for each division and each department group (group-level summaries), and the sum of all salaries (report-level summary).










See also

Section 4.8.11, "Creating a summary column"






2.3.2 About formula columns

A formula column performs a user-defined computation on the data of one or more column(s), including placeholder columns. For example, :ITEMTOT *.07 is a formula that performs a computation on one column, while :SAL + :COMM performs a computation using two columns in a record. You create formulas in PL/SQL using the PL/SQL Editor.




	
Note:

Formula columns should not be used to set values for parameters.










See also

Section 4.8.10, "Creating or editing a formula column"

Section 2.6.8, "About formulas"






2.3.3 About placeholder columns

A placeholder is a column for which you set the datatype and value in PL/SQL that you define. Placeholder columns are useful when you want to selectively set the value of a column (for example, each time the nth record is fetched, or each time a record containing a specific value is fetched, and so on). You can set the value of a placeholder column in the following places:

	
the Before Report trigger, if the placeholder is a report-level column


	
a report-level formula column, if the placeholder is a report-level column


	
a formula in the placeholder's group or a group below it (the value is set once for each record of the group)





See also

Section 4.8.12, "Creating or editing a placeholder column"

Section 2.6.8, "About formulas"






2.3.4 About referencing columns and parameters

You can reference user parameters, system parameters and columns as either bind references or lexical references.



2.3.4.1 About bind references

Bind references (or bind variables) are used to replace a single value in SQL or PL/SQL, such as a character string, number, or date. Specifically, bind references may be used to replace expressions in SELECT, WHERE, GROUP BY, ORDER BY, HAVING, CONNECT BY, and START WITH clauses of queries. Bind references may not be referenced in FROM clauses or in place of reserved words or clauses.

You create a bind reference by typing a colon (:) followed immediately by the column or parameter name. If you do not create a column or parameter before making a bind reference to it in a SELECT statement, Oracle Reports Builder will create a parameter for you by default.


Restrictions

Bind references must not be the same name as any reserved SQL keywords. For more information, see the Oracle Server SQL Language Reference manual.


Examples


Example 1: SELECT clause

In the following example, the value of DFLTCOMM replaces null values of COMMPLAN in the rows selected.


SELECT CUSTID, NVL(COMMPLAN, :DFLTCOMM) COMMPLAN



  FROM ORD;



Example 2: WHERE clause

The value of CUST is used to select a single customer.


SELECT ORDID, TOTAL



  FROM ORD
  WHERE CUSTID = :CUST;



Example 3: GROUP BY clause

All non-aggregate expressions such as NVL(COMMPLAN, :DFLTCOMM) in the SELECT clause must be replicated in the GROUP BY clause.


SELECT NVL(COMMPLAN, :DFLTCOMM) COMMPLAN, SUM(TOTAL) TOTAL



  FROM ORD
  GROUP BY NVL(COMMPLAN, :DFLTCOMM);



Example 4: HAVING clause 

The value of MINTOTAL is used to select customers with a minimum total of orders.


SELECT CUSTID, SUM(TOTAL) TOTAL



  FROM ORD
  GROUP BY CUSTID HAVING SUM(TOTAL) > :MINTOTAL;



Example 5:  ORDER BY clause

The value of SORT is used to select either SHIPDATE or ORDERDATE as the sort criterion. Note that this is not the same as ORDER BY 1 because :SORT is used as a value rather than to identify the position of an expression in the SELECT list. Note that DECODE is required in this example. You cannot use a bind variable in an ORDER BY clause unless it is with DECODE.


SELECT ORDID, SHIPDATE, ORDERDATE, TOTAL



  FROM ORD
  ORDER BY DECODE(:SORT, 1, SHIPDATE, 2, ORDERDATE);



Example 6:   CONNECT BY and START WITH clauses

References in CONNECT BY and START WITH clauses are used in the same way as they are in the WHERE and HAVING clauses.


Example 7:   PL/SQL


procedure double is begin; :my_param := :my_param*2; end;


The value of myparam is multiplied by two and assigned to myparam.






2.3.4.2 About lexical references

Lexical references are placeholders for columns or parameters that you embed in a SELECT statement. You can use lexical references to replace the clauses appearing after SELECT, FROM, WHERE, GROUP BY, ORDER BY, HAVING, CONNECT BY, and START WITH. Use a lexical reference when you want the parameter to substitute multiple values at runtime.

You cannot make lexical references in a PL/SQL statement. You can, however, use a bind reference in PL/SQL to set the value of a parameter that is then referenced lexically in SQL, as shown in the example below.

You create a lexical reference by typing an ampersand (&) followed immediately by the column or parameter name. A default definition is not provided for lexical references. Therefore, you must do the following:

	
Before you create your query, define a column or parameter in the data model for each lexical reference in the query. For columns, you must set the Value if Null property, and, for parameters, you must set the Initial Value property. Oracle Reports Builder uses these values to validate a query with a lexical reference.


	
Create your query containing lexical references.





Restrictions

	
You cannot make lexical references in a PL/SQL statement.


	
If a column or parameter is used as a lexical reference in a query, its Datatype must be Character.


	
If you want to use lexical references in your SELECT clause, you should create a separate lexical reference for each column you will substitute. In addition, you should assign an alias to each lexical reference. This enables you to use the same layout field and boilerplate label for whatever value you enter for the lexical reference on the Runtime Parameter Form.


	
If you use lexical references in your SELECT clause, you must specify the same number of items at runtime as were specified in the report's data model. Each value you specify for your lexical references at runtime must have the same datatype as its Initial Value.


	
If you use lexical references in your SELECT clause, the width of the column is derived from the Initial Value property of the parameter. Consequently, you should ensure that the Initial Value of the parameter corresponds to the widest column that you intend to use.


	
A Oracle Reports Builder link should not depend upon a lexical reference. That is, neither the child column of a link or its table name should be determined by a lexical reference. To achieve this functionality, you need to create a link with no columns specified and then enter the SQL clause (for example, WHERE) for the link directly in the query. For example, your parent and child queries might be written as follows:

Parent Query:


SELECT DEPTNO FROM EMP


Child Query:


SELECT &PARM_1 COL_1, &PARM2 COL_2
  FROM EMP
  WHERE &PARM_1 = :DEPTNO


Note how the WHERE clause makes a bind reference to DEPTNO, which was selected in the parent query. Also, this example assumes that you have created a link between the queries in the Data Model view with no columns specified.




	
A lexical reference cannot be used to create additional bind variables after the After Form trigger fires. For example, suppose you have a query like the following (note that the WHERE clause is replaced by a lexical reference):


SELECT ENAME, SAL FROM EMP
&where_clause


If the value of the where_clause parameter contains a reference to a bind variable, you must specify the value in the After Form trigger or earlier. You would get an error if you supplied the following value for the parameter in the Before Report trigger:


WHERE SAL = :new_bind


If you supplied this same value in the After Form trigger, the report would run.





Examples


Example 1: SELECT clause


SELECT &P_ENAME NAME, &P_EMPNO ENO, &P_JOB ROLE



  FROM EMP;


P_ENAME, P_EMPNO, and P_JOB can be used to change the columns selected at runtime. For example, you could enter DEPTNO as the value for P_EMPNO on the Runtime Parameter Form. Note that in this case, you should use aliases for your columns. Otherwise, if you change the columns selected at runtime, the column names in the SELECT list will not match the Oracle Reports Builder columns and the report will not run.


Example 2: FROM clause


SELECT ORDID, TOTAL



  FROM &ATABLE;


ATABLE can be used to change the table from which columns are selected at runtime. For example, you could enter ORD for ATABLE at runtime. If you dynamically change the table name in this way, you may also want to use lexical references for the SELECT clause (look at the previous example) in case the column names differ between tables.


Example 3: WHERE clause


SELECT ORDID, TOTAL



  FROM ORD
  WHERE &CUST;


CUST can be used to restrict records retrieved from ORD. Any form of the WHERE clause can be specified at runtime.


Example 4: GROUP BY clause


SELECT NVL(COMMPLAN, DFLTCOMM) CPLAN, SUM(TOTAL) TOTAL



  FROM ORD
  GROUP BY &NEWCOMM;


The value of NEWCOMM can be used to define the GROUP BY clause.


Example 5: HAVING clause


SELECT CUSTID, SUM(TOTAL) TOTAL



  FROM ORD
  GROUP BY CUSTID HAVING &MINTOTAL;


The value of MINTOTAL could, for example, be used to select customers with a minimum total of orders.


Example 6: ORDER BY clause


SELECT ORDID, SHIPDATE, ORDERDATE, TOTAL



  FROM ORD
  ORDER BY &SORT;


The value of SORT can be used to select SHIPDATE, ORDERDATE, ORDID, or any combination as the sort criterion. It could also be used to add on to the query, for example to add a CONNECT BY and START WITH clause.


Example 7: CONNECT BY and START WITH clauses

Parameters in CONNECT BY and START WITH clauses are used in the same way as they are in the WHERE and HAVING clauses.


Example 8: Multiple clauses


SELECT &COLSTABLE;


COLSTABLE could be used to change both the SELECT and FROM clauses at runtime. For example, you could enter DNAME ENAME, LOC SAL FROM DEPT for COLSTABLE at runtime.


SELECT * FROM EMP &WHEREORD;


WHEREORD could be used to change both the WHERE and ORDER BY clauses at runtime. For example, you could enter WHERE SAL > 1000 ORDER BY DEPTNO for &WHEREORD at runtime.


Example 9: PL/SQL and SQL 


SELECT &BREAK_COL C1, MAX(SAL)



  FROM EMP
  GROUP BY &BREAK_COL;


BREAK_COL is used to change both the SELECT list and the GROUP BY clause at runtime. The Initial Value of the parameter &BREAK_COL is JOB. At runtime, the user of the report can provide a value for a parameter called GROUP_BY_COLUMN (of data type Character).

In the Validation Trigger for GROUP_BY_COLUMN, you call the following PL/SQL procedure and pass it the value of GROUP_BY_COLUMN:


procedure conv_param (in_var IN char) is
begin



  if upper(in_var) in ('DEPTNO','EMPNO','HIREDATE') then



    :break_col := 'to_char('||in_var||')' ;



  else



    :break_col := in_var;



  end if;



end;


This PL/SQL ensures that, if necessary, a TO_CHAR is placed around the break column the user chooses. Notice how in SQL, you make a lexical reference to BREAK_COL. In PL/SQL, you must make a bind reference to BREAK_COL because lexical references are not allowed in PL/SQL.






2.3.4.3 Differences between bind and lexical references

Bind references are used to replace a single value in SQL or PL/SQL. Specifically, bind references may be used to replace expressions in SELECT, WHERE, GROUP BY, ORDER BY, HAVING, CONNECT BY, and START WITH clauses of queries. Bind references may not be referenced in the FROM clause. An example is:


SELECT ORDID,TOTAL 



  FROM ORD
  WHERE CUSTID = :CUST


Lexical references are placeholders for text that you embed in a SELECT statement, when you want the parameter to substitute multiple values at runtime. You can use lexical references to replace the clauses appearing after SELECT, FROM, WHERE, GROUP BY, ORDER BY, HAVING, CONNECT BY, and START WITH. You cannot make lexical references in PL/SQL. Before you reference a lexical parameter for a column or table, you must have predefined the parameter and given it an initial value. An example is:


SELECT ORDID, TOTAL



  FROM &ATABLE








2.3.5 About non-linkable queries

A non-linkable query is a detail query that contains column objects that prevent the query from being linked to through a column-to-column link (when you create a column-to-column link, Oracle Reports Builder adds a WHERE clause to your query). If you attempt to create such a link, a message dialog box displays, which prompts you to choose whether to create a group-to-group query (using the parent groups), or to cancel the operation. A non-linkable query displays the non-linkable query icon in its title bar.

Instead, you can create a group-to-group link (when you create a group-to-group link, Oracle Reports Builder does not add a WHERE clause to your query) between the two queries and add a WHERE clause to the child query's SELECT statement, using a bind variable to reference the parent column. See Section 4.8.9, "Creating a data link".

For example, suppose you want to create a column-to-column link between the ADDRESS.STREET column in your child query and the LOC1 column in your parent query. You can create a group-to-group link, and then modify the child query SQL statement to say:


SELECT * FROM EMP E WHERE E.ADDRESS.STREET = :LOC1



See also

Section 1.7.4, "About data links"

Section 1.7.1, "About queries"

Section 2.3.4.1, "About bind references"






2.3.6 About links versus groups

In Oracle Reports Builder, data is defined independent of format (layout). Therefore, you should be aware of when to use data links instead of groups.

The layouts of a master/detail report that uses two queries and a data link, and a group report that uses one query and two groups can be identical. Following is an example of a default master/detail report and a group report that query the same data. Notice the difference between the two reports: unlike the group report, the master/detail report displays department 40. This is because the data link in the master/detail report causes an outer-join: the link automatically fetches unrelated data. If you are designing a group report that requires an outer-join, explicitly add it to your SELECT statement with (+).


Figure 2-3 Default master/detail and group report that query same data

[image: Default master/detail and group report that query same data]






A master/detail/detail report, as shown in the figure below, is a report that contains three groups of data: for each master group, two unrelated detail groups are displayed. To produce a master/detail/detail report or any variation of it, you must use data links. If you try to produce this report with a control break using a single query and three groups the query will establish a relationship between the two detail groups.


Figure 2-4 Master/detail/detail report

[image: Master/detail/detail report]







See also

Section 1.7.2, "About groups"

Section 1.7.4, "About data links"






2.3.7 About matrix objects

A matrix object merely defines a relationship between two repeating frames: it isn't really owned by any object, nor does it own any object. A matrix object is created only for layouts with a Matrix layout style. A report may have multiple matrices within it, provided that the data model contains the necessary groups. Oracle Reports Builder creates one matrix object for each pair of intersecting, perpendicular repeating frames.

The repeating frames are the dimensions of the matrix and the matrix object contains the field that will hold the "filler" or values of the cell group. One of the repeating frames must have the Print Direction property set to Down and the other must have the Print Direction property set to Across in order to form a matrix.



	
Note:

When running a JSP-based Web report that includes a matrix object, the JSP <rw:include> tag expects the matrix object to format on only one page. However, if the cells in the across repeating frame expand, the column headers of the matrix may be forced onto a second page regardless of the page size. Therefore, these matrix headers will not appear in the report output. Additionally, in this situation, the paper layout does not display correctly as header fields move to subsequent pages where the cell values remain on the first page. To resolve this, it is important to carefully define in the Report Editor the space available to the across repeating frame to allow for displaying the largest values, then set the Vertical Elasticity property of the across repeating frame to Fixed.









Restrictions

	
The down repeating frames must be below the across repeating frames in a matrix.


	
A matrix object must always be on top of the repeating frames that form it (that is, it must be one or more layers above its horizontal and vertical repeating frames). Oracle Reports Builder prevents you from moving the matrix below its horizontal and vertical repeating frames.


	
Moving a matrix also causes its two repeating frames to move.


	
A matrix object cannot be anchored to another object and other objects cannot be anchored to it (that is, a matrix object cannot be the parent or child object for an anchor).


	
To copy a matrix, you must select the matrix and its two repeating frames. If you select the matrix object by itself, nothing will be copied to the paste buffer. If you select the matrix and one of the repeating frames, only the repeating frame is placed in the paste buffer.


	
A matrix object can only be resized by resizing its associated repeating frames.


	
You cannot use Alignment or Size Objects from the Layout menu on matrix objects.


	
The source groups of the repeating frames that make up the dimensions of a matrix must be from the same cross-product group.


	
Repeating frames whose source groups are in the same "family" hierarchy (that is, are descendants or ancestors of each other) must have the same Print Direction. Parent-child relationships within a cross-product group are used to create nesting in the matrix. As a result, the repeating frames associated with such groups must print in the same direction on the page.


	
You can put a border on a matrix object just as you would any other object, but the width will always be the minimum width possible. You cannot widen the border due to the closeness of the objects in a matrix layout.





Example

Suppose that you have a group named Group1 that contains a column called C_DEPTNO, which gets its values from the database column DEPTNO. A group called Group2, contains column C_JOB, which gets its values from the database column JOB, and column C_DEPTNO1, which is used for linking to Group1's query. A group called Group3 contains a column called SUMSAL, which is a summary of the database column SAL.


                    Job 
          Analyst  Clerk  Manager 

      10           $1300   $2450 
Dept  20    $6000  $1900   $2975 
      30           $ 950   $2850 


In this example:

	
The Vertical Repeating Frame is the repeating frame that contains Group2 (the job titles).


	
The Horizontal Repeating Frame is the repeating frame that contains Group1 (the department numbers).


	
The Cross Product Group is Group4 (the group that is the parent of Group1 and Group2).




If you need to build a more complex matrix, you can do so by adding more columns to Group1 and Group2. For example, instead of having Group1 just contain department numbers, it could also contain the locations (LOC) of the departments. The matrix might then look something like this:


                              Job
 Loc        Dept    Analyst  Clerk  Manager
 
 New York    10              $1300   $2450
 Dallas      20      $6000   $1900   $2975
 Chicago     30              $ 950   $2850



See also

Section 1.3.7, "About matrix reports"

Section 2.1.7, "About nested matrix reports"

Section 2.1.8, "About matrix with group reports"

Section 4.9.1.3, "Creating a matrix object"

Section 4.8.8, "Creating a matrix (cross-product) group"

Section 4.5.3, "Creating a nested matrix report"








19.4 Redefault the Layout


To redefault the layout to use the additional query data:

	
In the Object Navigator, click the report name.


	
Choose Tools > Report Wizard to re-enter the wizard.


	
In the Report Wizard, on the Groups page, click G_custid1 in the Available Groups list and click Down to specify the Print Direction and move this group to the Displayed Groups list.


	
On the Fields page, click prodname and amount in the Available Fields list and click the right arrow (>) to move these fields to the Displayed Fields list.


	
On the Labels page, change the labels and field widths as follows:


	Fields	Labels	Width
	
prodname

	
Product Name

	
30


	
amount

	
Amount

	
9








	
On the Template page, click Finish to display your report output in the Paper Design view. It should look something like this:





Figure 19-5 Revised report layout in Paper Design view

[image: Description of Figure 19-5 follows]






Note that the data is still grouped by the Sales Representative with customer data listed below each Sales Representative. But now, the individual products sold to the customers are listed below each customer. The report now has multiple pages.






2.4 Layout Objects

The topics in this section build on the basic concepts discussed in Section 1.8, "Layout Objects".

	
About layout objects


	
About layout defaulting


	
About images


	
About anchors


	
About changing colors and patterns


	
About resizing objects


	
About moving and layering objects in the Paper Layout view






2.4.1 About layout objects

Several important concepts and properties apply to layout objects:

	
the frequency with which you want the object to appear in the report, specified by the Print Object On property


	
how Oracle Reports Builder fetches and formats data for instances of repeating frames, specified by the Column Mode property


	
whether to keep an object and the object to which it is anchored on the same logical page, specified by the Keep With Anchoring Object property


	
whether to try to keep the entire object and its contents on the same logical page, specified by the Page Protect property


	
format triggers, which are PL/SQL functions executed before an object is formatted that can dynamically change the formatting attributes of objects


	
report layout, generated by defaulting applied by Oracle Reports Builder, modified in the Paper Layout view, or created from scratch.





See also

Section 4.5.4, "Creating a default layout for a report"

Section 4.10.2, "Creating a default layout for a section"

Section 2.6.13.2, "About format triggers"

The Properties section of the Oracle Reports online Help






2.4.2 About layout defaulting

When you select one of the default layout styles in the Report Wizard, Oracle Reports Builder creates the necessary layout objects, based upon the report's data model. For example, if you want to build a mailing label report and have defined an appropriate data model, simply choose the mailing label default style. Oracle Reports Builder automatically creates the report's layout objects and displays them in the Layout Model view. You can completely customize any default layout you create. You can cut, copy, paste, move, resize, and edit each layout object that Oracle Reports Builder generates for you.

Layout defaulting is governed by the following rules:

	
All previously-defined layout objects for the report will be overwritten (including format triggers) unless you define the area in which you wish to create the layout as one which does not already contain layout objects.


	
One report can have any number of different formats. For example, you can build a report that has a tabular format on the top of the first page, and a matrix format on the bottom of the same page by creating an additional report layout (see Section 4.5.5, "Creating an additional report layout").


	
Once you have created a report layout, any further changes you make to the data model will not automatically be included in the layout. For example, if you create a query after you have created a report layout and then run your report, the data from the new query will not appear in the report output. To incorporate your changes, you need to either redefault or modify the layout.




Oracle Reports Builder defaults report layout according to the following rules:

	
Unless otherwise noted, a group with a Print Direction of Across defaults identically to a group with a Print Direction of Down, except that the default format is transposed. To quickly determine the defaulting of an Across group, do the following:

	
Draw the down layout for the group on translucent paper.


	
Turn the page over as if it was a page in a book.


	
Rotate the page counter-clockwise 90 degrees.





	
In form letter reports, all default fields are hidden, and have a Horizontal Elasticity property setting of Variable and a Vertical Elasticity property setting of Fixed. In all other reports, all default fields have a Horizontal and Vertical Elasticity property setting of Fixed.

Exception: For tabular, form-like, group left/above, and matrix reports, the default for CHAR (if you reduce the default width) and LONG fields have a Horizontal Elasticity property setting of Fixed and a Vertical Elasticity property setting of Variable. As a result, all of the field's value will be displayed, instead of truncated, by word-wrapping any data to the next lines.



	
Caution:

For form letter and mailing label reports, the default for CHAR (if you reduce the default width) and LONG fields have a Horizontal Elasticity and Vertical Elasticity property setting of Fixed. As a result, the field value will be truncated if the size of the data is greater than the size of the field.








	
Summaries that are owned by the report, not by a group, are allowed in all report layout styles. They are all formatted in the following way:

	
If the layout style is form-like, form letter, or mailing label, the summary is a report column. A report column is formatted like any other database column for that report style.


	
If the layout style is tabular, group left/above, or matrix, and the column on which the summary performs its function is not selected, the summary is a report column. (It is formatted as stated in the bullet above.) Otherwise, the summary is a report summary. It is formatted left-justified at the end of the report, with the label to the left of the field (if there is room).





	
If the layout style is tabular, group left/above, or matrix, a summary is defaulted like a database column if the column it summarizes is not selected. Otherwise, a summary is defaulted like summaries (that is, appearing inside the M_groupname_FTR frames).


	
If the layout style is tabular, group left/above, or matrix, Oracle Reports Builder places one summary type per line, in the following order:

	
SUM


	
AVERAGE


	
MINIMUM


	
MAXIMUM


	
COUNT


	
FIRST


	
LAST


	
% OF TOTAL


	
STANDARD DEVIATION


	
VARIANCE





	
If the layout style is tabular, group left/above, or matrix, the summary label will appear to the far-left of the group footer frame (M_groupname_FTR). If there is not room for the full label, the label will be truncated.





See also

Section 4.5.4, "Creating a default layout for a report"

Section 4.10.2, "Creating a default layout for a section"






2.4.3 About images

You can add an image to a report by:

	
Importing an image from a file into the report layout (paper-based report only). See Section 4.9.8.1.1, "Importing an image".


	
Creating a file link object in the Paper Layout (paper-based reports only). See:

	
Section 4.9.8.1.2, "Linking an image object to a file"


	
Section 4.9.8.1.3, "Linking an image object to a URL" (for HTML and HTMLCSS output)





	
Selecting a database column in a query (both paper-based and JSP-based Web reports). See:

	
Section 4.8.5, "Selecting an image from the database"


	
Section 4.8.6, "Selecting an image URL from the database" (for HTML output)







The first method (using the Import Image dialog box) provides for including images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD.

The other two methods (creating a file link object, and selecting a column in the database) provide for including additional formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM.

By default, images display in fields so that they appear in the printed report, not only in the Previewer.

Enhanced imaging support is provided by the REPORTS_OUTPUTIMAGEFORMAT environment variable and OUTPUTIMAGEFORMAT command line keyword. The enhancements in imaging support provide the capability to generate complex graphics-intensive reports with high fidelity image output. Additionally on UNIX, the dependency on a windowing system for displaying images is removed; the PostScript printer driver screenprinter.ppd provides surface resolution for images.

You can include an unlimited number of image objects without running out of local disk space by using non-caching references. A non-caching reference causes objects to be read from the database only when needed while a report is processing. You must be connected to an ORACLE V7.1 or later database to use this feature.

If you reference a URL for an image, the image is displayed when you format your report for HTML output. For other output formats, the URL text displays in the Paper Design view; in the output destination (for example, a file or PDF document), nothing is displayed. It is your responsibility to verify that the URL exists; Oracle Reports Builder does not validate the existence of the resource nor the syntax of the protocol. The size of the object that contains the URL defines the size of the image in the HTML output. Any elasticity properties applied to the object are ignored.


Limitations

	
If the input image includes more than 256 colors, and the output image format is set to GIF (with the OUTPUTIMAGEFORMAT command line keyword or the REPORTS_OUTPUTIMAGEFORMAT environment variable), Oracle Reports implements a color reduction to 256 colors to successfully generate the GIF.


	
On UNIX, CGM format is not supported in HTML output. This limitation does not apply on the Windows platform.









2.4.4 About anchors

Anchors fasten an edge of one object to an edge of another object, ensuring that they maintain their relative positions. For example, you can anchor boilerplate text to the edge of a variable-sized repeating frame, guaranteeing the boilerplate's distance and position in relation to the repeating frame, no matter how the frame's size might change.

Anchors determine the vertical and horizontal positioning of a child object relative to its parent. The child object may be either outside of or contained within the parent.

Since the size of some layout objects may change when the report runs (and data is actually fetched), you need anchors to define where you want objects to appear relative to one another. An anchor defines the relative position of an object to the object to which it is anchored. Positioning is based on the size of the objects after the data has been fetched rather than on their size in the editor. It should also be noted that the position of the object in the Paper Layout view affects the final position in the report output. Any physical offset in the layout is incorporated into the percentage position specified in the Anchor properties.

There are two types of anchors:

	
Implicit anchors. At runtime, Oracle Reports Builder generates an implicit anchor for each layout object that does not already have an explicit anchor. It determines for each layout object which objects, if any, can overwrite it, then creates an anchor from the layout object to the closest object that can overwrite it. This prevents the object from being overwritten. The implicit anchor functionality saves you from having to define the positioning of each object. Implicit anchors are not visible in the Paper Layout view. However, you can specify in the Object Navigator Options dialog box that the Object Navigator display anchoring information. By default, objects are anchored to the upper left corner of their enclosing object. If this view of the Object Navigator does not show anchoring information for an object, you can assume that the object is anchored to its enclosing object, which might be the frame or the body.


	
Explicit anchors. You can create an anchor in the Layout editor using the Anchor tool, dragging from one edge of the child to the one of the parent's edges. Any anchor you create for an object will override its implicit anchoring. Explicit anchors are always visible in the Paper Layout view unless you specify otherwise in the Layout Options dialog box.





Relative positioning of anchors

When you anchor a child object to a parent object, the x and y coordinates of the anchor's attachments are important.

If the parent object is located above or below the child object:

	
the vertical distance between the two objects is fixed. For example, in the figure below, the vertical spacing between the parent and Object 1 is fixed.


	
the horizontal positioning of the anchor's x-coordinate on the child object is relative to the anchor's x-coordinate on the parent object. For example, in the figure below, the anchor is 50% from the edge of the parent and 75% from the left edge of Object 1. Therefore, when this report is run, Oracle Reports Builder will shift Object 1 25% to the left of the center of the parent.





Figure 2-5 Parent object above child object

[image: figure illustrating parent above child]






If the parent object is located to the right or left of the child object:

	
the vertical positioning of the two objects is relative. For example, in the figure below, both ends of the anchor are about 80% down from the top edges of the objects. Therefore, when the report is run, Oracle Reports Builder will calculate the length of the two objects (as they may expand), calculate the y coordinate that is 80% down for both objects, and position the two objects so that those two points are separated by the amount of space separating them in the Paper Layout view.


	
the horizontal positioning between the two objects is fixed. For example, in the figure below, the horizontal spacing between the parent and Object 1 is fixed.





Figure 2-6 Parent object to the right of child object

[image: figure illustrating parent to right of child]






If you need to position an object outside a repeating frame or frame, but you want the object to be "owned" by the repeating frame or frame (that is, to be formatted when its "owner" is formatted), create an anchor that is attached to an object inside the frame or repeating frame.


Collapsing Anchors

You can create anchors to be "collapsible." Collapsing anchors help avoid unnecessary empty space in your report. Such empty space can occur when the parent object does not print on the same page as the child object, either because the parent and child cannot fit on the same page or because of an assigned Print Condition. A collapsing anchor allows the child object to move into the position that would have been taken by the parent had it printed. The child object will also maintain its relative position as defined by the anchor.



2.4.4.1 Implicit anchoring algorithm

Oracle Reports Builder creates implicit anchors at runtime in the body region. The margin algorithm differs slightly.


Body algorithm

	
Determine which objects are not entirely enclosed by a repeating frame of frame (directly or indirectly), or explicitly anchored to an object that is enclosed by a frame or repeating frame (directly or indirectly). We'll call these objects Type A objects. (Type A objects are typically group frames, repeating frames, other objects you create that are not owned by a frame or repeating frame, and so on). An object is considered to be enclosed by another object only if all of the following are true:

	
Both objects belong to the same region (Body or Margin).


	
The outermost of the two objects is a frame or repeating frame.


	
The outermost of the two objects is behind the other object.


	
The innermost of the two objects lies entirely within the borders of the other object.





	
Determine all children objects of a frame or repeating frame (these are the non-Type A objects). We'll call these objects Type B objects.


	
Follow this procedure for Type A and Type B objects independently:

	
Find all objects that are of the same type (for example, Type A), and are on the same layer.


	
Determine which of those objects have potential to "push" other objects of that type. An object has potential to "push" object of that type if it has a Horizontal or Vertical Elasticity setting of Variable or Expand, and a second object is located in its "push path" (that is, in the area in which it can possibly grow). Also, a repeating frame with a Horizontal or Vertical Elasticity setting of Fixed or Contract has a "push path": its Print Direction.


	
Create pairs of objects. Each pair must contain a pusher (that is, the object that will grow) and a pushee (that is, the object that will be pushed). When creating these pairs, a pushee object cannot be a child of an explicit anchor--those objects are ignored.


	
Go through this loop. For each pair, determine the distance in the "push path" between the pusher and pushee. Next, find the pair with the shortest distance. Finally, create an implicit anchor between those two objects using this algorithm:

If the "push path" direction is Down, anchor the pushee object's top 0% to the pusher object's bottom 0%.

If the "push path" direction is Across, anchor the pushee object's left 0% to the pushed object's right 0%.


	
That pair is now treated like one object, and the loop continues until either all objects have one anchor, or nothing will push the remaining, unanchored objects.


	
For each remaining, unanchored object, create an implicit anchor from the top-left corner of the object to the top-left corner of the body region.


	
Move to the next layer, and follow the procedure starting at step 1.








Rules:

	
If an object is in the "push path" of two other objects and it is equidistant from the other two objects, the implicit anchoring of the object may vary between executions of the report. For example, the drawing that follows shows two cases where this could occur:





Figure 2-7 Object in push path of two other objects

[image: graphic depicting situation described above]






In the first case, M_Sums is in the "push path" of both B_Text1 and R_Ename. Because M_Sums is equidistant from B_Text1 and R_Ename, though, the normal criteria (shortest distance) for determining implicit anchors does not work in this case. Consequently, the formatting algorithm will randomly create an implicit anchor between M_Sums and either B_Text1 or R_Ename at runtime. To avoid this behavior, you could create an explicit anchor between M_Sums and B_Text1 or R_Ename.

In the second case, B_Text3 is in the "push path" of M_Emp. Since the bottom edges of M_Emp and R_Mgr are virtually in the same position, though, B_Text3 could be implicitly anchored to either M_Emp or R_Mgr. Consequently, the formatting algorithm will randomly create an implicit anchor between B_Text3 and either M_Emp or R_Mgr at runtime. To avoid this behavior, you could create an explicit anchor from B_Text3 to one of the objects or remove the explicit anchor between R_Ename and B_Text2. Removing the explicit anchor would cause R_Mgr to be treated as a descendant of M_Emp and, therefore, the implicit anchor would always be created between B_Text3 and M_Emp.

(Note that Case 2 is most likely to occur in character mode, where it is common to have the edges of objects overlap in the Paper Layout view.)


Margin algorithm

Oracle Reports Builder creates implicit anchors for all Type B objects in the margin region using the Body algorithm. For each Type A object, however, Oracle Reports Builder creates an implicit anchor from the top-left corner of the object to the top-left corner of the margin. No Type A object will be implicitly anchored to another Type A object. (This ensures that Type A objects will not be pushed off the page. However, they may be overwritten by another Type A object, if they are found on the same layer.)


See also

Section 4.9.5.1, "Anchoring objects together"

Section 4.9.5.2, "Viewing implicit anchors"

Section 4.9.5.3, "Moving an anchor"








2.4.5 About changing colors and patterns

Color and pattern selections are applied to an entire object (for example, you can apply a color to all the text in the object but not to a segment of the text).

You can change colors and patterns in your report in the following ways:

	
In the Oracle Reports Builder user interface, use the following tools in the Paper Layout view's tool palette:

	
The Line Color tool is used to customize the color of borders around layout objects.



	
Note:

The Windows platform does not support a border pattern (that is, patterns for the Line Color tool).








	
The Fill Color tool is used to fill layout objects with colors and patterns.


	
The Text Color tool is used to change the default text color.


	
The Fill/Line/Text Display, the box directly above the three Color tools, shows the currently selected fill, border, and text. The default fill and border for objects created by Oracle Reports Builder is transparent, while the default for objects you create is a black, one point line around a white fill.





	
In PL/SQL, use the following SRW packaged procedures:

	
SRW.SET_BACKGROUND_BORDER_COLOR


	
SRW.SET_BACKGROUND_FILL_COLOR


	
SRW.SET_FOREGROUND_BORDER_COLOR


	
SRW.SET_FOREGROUND_FILL_COLOR


	
SRW.SET_TEXT_COLOR


	
SRW.SET_FILL_PATTERN


	
SRW.SET_BORDER_PATTERN





	
For templates, set the following properties in the template Property Inspector:

	
The Fill Pattern property defines the pattern to use for the space enclosed by the objects. You can define the background and foreground colors of the fill pattern using the Foreground Color and Background Color properties.


	
The Edge Pattern property defines the pattern to use for the borders of the objects. You can define the background and foreground colors of the edge pattern using the Edge Foreground Color and Edge Background Color properties.



	
Note:

The Windows platform does not support a border pattern.








	
The Text Color property specifies the text color to use for the object(s).







Additionally, you can set color palette preferences to specify how it is used by a report (see Section 4.2.6, "Setting color palette preferences") and modify the color palette to change the definition of individual colors (see Section 4.9.6.5, "Modifying the color palette").

To change the color palette being used by the current report, you can import a new color palette. You can also export the current color palette for use by other reports. (See Section 4.9.6.6, "Importing or exporting a color palette".)


See also

Section 4.9.6.2, "Changing colors"

Section 4.9.6.3, "Changing patterns"

Section 4.9.6.4, "Changing colors and patterns using PL/SQL"

Section 4.9.4.2, "Changing object border attributes"

Topics "Oracle CDE1 color palette", "Default color palette", "Grayscale color palette", and "Pattern color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help

Topic "SRW built-in package" in the Reference > PL/SQL Reference > Built-in Packages section of the Oracle Reports online Help

Topic "Template properties" in the Properties section of the Oracle Reports online Help






2.4.6 About resizing objects

You can resize queries, groups, frames, repeating frames, fields, matrix objects, and boilerplate objects. You cannot resize anchors. However, an anchor is automatically resized if you move one of the objects it anchors.




	
Caution:

When you resize boilerplate text, be very careful that all of the text fits within the object. If font descends (the space left for the lower parts of letters like g and q) do not fit, the line of text will appear in the Report Editor view, but, when the report is run, the line will not appear in the output. When you click a handle and drag it, the two edges that join at the corner will be resized; that is, the object will grow or reduce in both the x and y directions.










See also

Section 4.9.12.1, "Resizing objects"

Section 4.9.12.2, "Making multiple objects the same size"

Section 4.9.11.3, "Adjusting parent borders automatically"






2.4.7 About moving and layering objects in the Paper Layout view

In the Paper Layout view, objects must be on a layer above the objects that enclose them. For example, the fields that belong to a repeating frame must be at least one layer above the repeating frame in the Paper Layout view. If not, then they are not considered to be enclosed by the repeating frame any longer and will cause a frequency error at runtime. When you move or group objects in the Paper Layout view, it is possible to change the layering such that you will get frequency errors when you run the report. To avoid this problem, you should take advantage of Confine or Flex mode when moving objects in the Paper Layout view.


See also

Section 4.9.4.3, "Changing the current mode (Confine or Flex)"

Section 4.9.11.7, "Changing object layering"

Section 4.9.11.2, "Moving an object outside its parent"

Section 4.9.11.1, "Moving multiple objects"

Section 4.9.11.6, "Aligning objects"







32 Building a Report Using a Preprinted Form

In this chapter, you will learn about reports that display output on preprinted forms. By following the steps in this chapter, you can generate the report output shown in Figure 32-1.


Figure 32-1 Printing reports on preprinted forms

[image: Description of Figure 32-1 follows]







Concepts

Using the various tools in the Paper Layout view and the Paper Design view, you can format a report to print on preprinted forms.




	
Note:

Many of the concepts in this example are used in the following example reports:

	
This example, where you learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form.


	
Chapter 31, "Building a Check Printing Report with Spelled-Out Cash Amounts", where you import an image of a check and use it as a guide to position fields in the Paper Layout view. In addition, you learn how to create a PL/SQL function that returns spelled-out numerical values.


	
Chapter 33, "Building an Invoice Report", where you import an image of an invoice and use it as a guide to position fields in the Paper Layout view.













Data Relationships

This report uses two queries linked in a master/detail relationship. You will create a break in the detail group and two summary columns in the master group.


Layout

This report consists of two partial default layouts, one with a mailing label format and one with a tabular format. You will move fields to the correct positions on the page and restrict the master repeating frame to appearing once per form.


Example Scenario

In this example, you will learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form. This example report consists of data formatted such that all values fall precisely within the corresponding fields of a preprinted sales order. The form is on a standard sized 8.5 inches by 11 inches (21.6 centimeters by 27.9 centimeters) page. The employee name and the customer's name and address must display in the region at the top of the page. The order item details must only display 40 characters. Anything over 40 characters will be placed on a second page of the form. At the end of our example, we add page numbers. This section is optional, as your forms may not require page numbers.




	
Note:

The above measurements are for the form we use in this example. If you do not have access to an online, or computer readable version of your preprinted form, you will need to take these measurements yourself, then use the steps below to create your own report definition.









As you build this example report, you will:

	
Manually Create the Data Model for Your Report using the tools in the Data Model view to manually create two queries. You will also link the two queries, create a break group, and create two summary columns.


	
Create the Layout for Your Report using the tools in the Paper Layout view. You will also use the Report Block Wizard to create a mailing label portion of your report and a tabular report that displays the order detail information


	
Format Your Report in the Paper Design View using the tools in the Paper Design view to add format masks and adjust the appearance of your report.


	
Add Page Numbers (optional) using the tools in the Paper Layout view to add page numbering fields.




To see a sample report that uses preprinted forms, open the examples folder named preprint, then open the Oracle Reports example named preprint.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.



44 Building an Accessible JSP-based Web Report

Using Oracle Reports and the standards defined in the Web Accessibility Guidelines, you can create a report that produces output that is compatible with assistive technologies such as screen readers. Oracle Reports provides properties and tags to support this effort.

On the Oracle accessibility site (http://www.oracle.com/accessibility), you can learn more about accessibility and find the Creating Accessible Enterprise Reports using Oracle Reports white paper.

To learn more about creating accessible Web reports, refer to the example on the Oracle Technology Network (OTN):

	
On the Oracle Reports 10g page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page.


	
In the list of topic sections on the left, click Index.


	
In the Topic list, choose Building and Developing Reports.


	
In the Collateral Type list, choose Examples.


	
Click Search.


	
In the list of topics that displays, click Building an Accessible JSP-based Web Report.







46.2 Set Up the textpds.conf File

Before you can use a text file as a data source, you must set up the Text PDS configuration file (textpds.conf) with your text file's format information. With this data definition in the configuration file, Oracle Reports Builder can recognize your text file as a valid data source.




	
Note:

You must edit your configuration file before you launch or restart Reports Builder for the changes to take effect.










To set up your textpds.conf:

	
In a text editor, such as Notepad, open the file textpds.conf, located in the ORACLE_HOME/reports/conf directory.



	
Note:

ORACLE_HOME is where Reports Builder is installed on your computer.








	
In another text editor window, open the provided file config.txt file.


	
Copy the text we have provided in config.txt and paste it into textpds.conf before the </textPDS> entry, so that the resulting textpds.conf file contains an entry like this:


Figure 46-2 Snapshot of the textpds.conf entry

[image: Description of Figure 46-2 follows]









	
Note:

The fileFormat entry in textpds.conf enables Reports Builder to recognize your text file as a data source. When you choose Text PDS in the Report Wizard, the defined format (CensusCSV, in this example) displays as an option. In the fileFormat entry, you also define the properties of each column in the file.










	
Save the textpds.conf file.




You have set up your textpds.conf file for the character-delimited text data source.






20.5 Remove a Redundant Field

After you have added a field for the formula column, you will notice that the department values appear in two places. To eliminate this redundancy, you need to remove the master field and its heading.


To remove a field and its label:

	
In the Paper Design view, shift-click on the first instance of the label Dept. and the value next to it.


	
Choose Edit > Delete.





Figure 20-5 Output displayed in Paper Design view

[image: Description of Figure 20-5 follows]










25.8 Summary

Congratulations! You have successfully created a matrix report. You now know how to:

	
create a matrix report with a single-query data model.


	
create a matrix report with a multiple-query data model.


	
add summaries and format monetary values.


	
substitute zeroes for blanks in a matrix layout.


	
add a grid.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






22.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






30.2 Create a Query and the Layout

The steps in this section will show you how to build a simple data model and report layout in the Report Wizard, which you can then use to generate either a JSP-based Web report or a paper report. In the next section, you will modify the JSP so that the appropriate information displays in your Web report.

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.


To create a data model and layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create both Web and Paper Layout, then click Next.


	
On the Style page, type a Title for your report, select Group Left, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT (FLOOR(SAL/1000))*1000 BOTTOM,
CEIL((SAL+1)/1000) * 1000 TOP,
ENAME,
DEPTNO
FROM EMP
ORDER BY 1,2, SAL




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called aggregatingdata_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 30.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click the following fields in the Available Fields list and click the right arrow (>) to move them to the Group Fields list, then click Next:

	
BOTTOM


	
TOP





	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, click Next.


	
On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 30-2 Paper Design view for the aggregating data report

[image: Description of Figure 30-2 follows]






	
In the Paper Design view, click the text Bottom and change the text to Salary Range.


	
Delete the text Top.



	
Note:

You can also modify the other column headers to make the text more meaningful.








	
Click the Paper Layout button in the toolbar to display the Paper Layout view. The layout currently looks like this:


Figure 30-3 Paper Layout view of the Aggregating Data report

[image: Description of Figure 30-3 follows]






	
In the Paper Layout view, click the Flex Off button in the toolbar to set Flex mode off.


	
Click the right edge of the f_bottom frame and drag it to the left about 0.5 inches (1.5 centimeters) to make room between the f_bottom and f_top fields.



	
Tip:

To find objects in the Paper Layout view, you can use the Object Navigator. When you click an item name in the Object Navigator, the corresponding object is selected in the Paper Layout view.








	
Click the Text tool in the tool palette.


	
Drag a boilerplate text object between f_bottom and f_top, then type "-" in the text box. The layout should now look like this:


Figure 30-4 Paper Layout view with new boilerplate text

[image: Description of Figure 30-4 follows]






	
Now, click the Run Paper Layout button in the toolbar to display your report. It should look something like this.


Figure 30-5 Paper Design view

[image: Description of Figure 30-5 follows]









	
Note:

Notice how the report displays the employee names per salary range, hence aggregating the data.










	
Save your report as aggregatereport_your_initials.rdf.


	
Take a look at the data model of your report. You can use this data model to generate either a paper report or a JSP-based Web report. To view the data model, click the Data Model button in the toolbar. Your data model should look something like this:


Figure 30-6 Data Model for the aggregating data report

[image: Description of Figure 30-6 follows]












30 Building a Report with Aggregate Data

In this chapter, you will learn about reports that include aggregate data, based on value ranges. By following the steps in this chapter, you can generate the report output shown in Figure 30-1.


Figure 30-1 Aggregate data report output

[image: Description of Figure 30-1 follows]







Concepts

In a report that aggregates, or collects, data within ranges, values from the database are retrieved and formatted based on an aggregate range that you define. You can even use parameters to specify the range over which the data should be collected.


Data Relationships

This report uses two "functions" in its SELECT statement to specify the aggregate range. The functions are (FLOOR(SAL/1000))*1000), which calculates the lowest salary, and (CEIL*((SAL+1)/1000) * 1000), which calculates the highest salary. The columns that receive the values of these functions are placed into a break group to produce the control break format of this example report.


Layout

This report uses the Group Left layout style.


Example Scenario

In this example, you will build both a paper and JSP-based Web report that collects and displays names of all employees whose salaries fall within the range of 0 to 999, then collects and displays all employees whose salaries fall within the range of 1000 to 1999, and so on. You will be able to modify this report to display any aggregate range you need.

As you build this example report, you will:

	
Create a Query and the Layout using the Report Wizard to create a data model and layout for both the paper and Web reports.


	
Modify the Web Source of Your JSP Report to generate the JSP-based Web report.




To see a sample report that aggregates data within ranges, open the examples folder named aggregatingdata, then open the Oracle Reports example named aggregatingdata.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




45.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






38.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator. You must also have Acrobat Reader installed on your system.




	
Note:

Due to some limitations of Oracle Reports regarding use of the UTF-8 character set and multibyte fonts on UNIX, it is recommended to build this report only on Windows. To deploy a multibyte report on UNIX, refer the chapter "Resolving Cross-Platform Porting Issues" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.










Perform the following set up activities before you run the report:

	
In the Windows registry, under KEY_OH in the ORACLE key, set NLS_LANG to AMERICAN_AMERICA.UTF8.



	
Tip:

Back up your registry before editing it as working with registry keys can cause the system to become unstable.








	
Open the uifont.ali file and edit it to specify the TrueType font file name. Type "Arial Unicode MS" = "ARIALUNI.TTF" under the [PDF:Subset] section. After including the line, the uifont.ali file should look like:


Figure 38-3 uifont.ali file edited to include the TrueType font file name

[image: Description of Figure 38-3 follows]

Description of "Figure 38-3 uifont.ali file edited to include the TrueType font file name"








	
Note:

On Windows and UNIX, the uifont.ali file is located in ORACLE_INSTANCE\config\

FRCommonComponent\frcommon\guicommon\tk\admin. The uifont.ali file defines the font aliases used by Oracle Reports and is extremely useful for cross-platform development. This file enables you to define which fonts to substitute when a particular font is unavailable. For more information, see the "Font Related Features" section in the chapter "Using PDF in Oracle Reports" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.










	
In the Windows registry under the Oracle key and IDS_HOME, add the location of the ARIALUNI.TTF TrueType font file to the value of REPORTS_PATH. For example, C:\WINNT\Fonts.




	
Note:

Install the TrueType font file ARIALUNI.TTF into C:\WINNT\Fonts, if it is not already there.

















20.2 Create a Data Model and a Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.


To create a data model and group above layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Group Above, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT DEPT.DNAME, EMP.ENAME, EMP.SAL
FROM DEPT, EMP
WHERE (EMP.DEPTNO = DEPT.DEPTNO)




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called intermix_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 20.1, "Prerequisites for This example" describes the sample schema requirements for this example.








	
On the Groups page, click DNAME in the Available Fields list and click the right arrow (>) to move this field to the Group Fields list.


Figure 20-2 Group page of Report Wizard

[image: Description of Figure 20-2 follows]






	
Click Next.


	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, change the labels as follows, then click Next:


	Fields	Labels
	
DNAME

	
Dept.


	
ENAME

	
Name


	
SAL

	
Salary








	
On the Template page, click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 20-3 Paper Design view for intermixing fields report

[image: Description of Figure 20-3 follows]






	
Save the report as intermix_your_initials.rdf.








Glossary



AFM

Acronym for Adobe Font Metrics. AFM and PPD files are supplied by Adobe and by printer vendors. These files contain information about the printer. Along with other parameters, these files are read for the information about the available fonts for the printer, which Oracle Reports will use. For all the fonts listed in the PPD file, Oracle Reports searches for the corresponding AFM file according to the font name and loads all of the fonts for which there is an available AFM.






CGI

Acronym for Common Gateway Interface. A standard for transferring information between a Web server and a CGI program. CGI specifies how to pass arguments to the program as part of the HTTP request, and defines a set of environment variables that are made available to the program. The program then generates output to pass back to the browser. CGI provides server-side processing to allow Web servers to interact dynamically with users.






column

	
A vertical space in a database table that represents a particular domain of data. A column has a column name (for example, ENAME) and a specific datatype (for example, CHAR). For example, in a table of employee information, all of the employees' names would constitute one column. A record group column represents a database column.


	
A data model object created automatically for each column expression in a query's SELECT list, or created manually to perform summaries, formulas, or act as a placeholder.


	
The representation of an attribute of an entity.









data model

A relational model that defines what data should be fetched from the data source(s), what values should be computed, and how data should be ordered in a report. Reports Builder objects that define the data model are queries, groups, columns, parameters, and links.






Data Model view

One of the views of the Report Editor that displays a structural representation of the data in a report. The objects do not appear in the report output, but the structure determines the layout style, and the data objects provide the values that appear in the layout objects.






database

A source for data returned by a query, including database objects such as tables, views, synonyms, snapshots, and queries stored as views. Oracle Reports Services enables you to access any data source.

A set of dictionary tables and user tables that are treated as a unit.






data source

A source for data returned by a query, including database objects such as tables, views, synonyms, snapshots, and queries stored as views. Oracle Reports Services enables you to access any data source.

The pluggable data source (PDS) architecture replaces Oracle Open Client Adapter (OCA), and the Open Database Connectivity (ODBC) drivers are obsolete in Oracle Reports. However, Java Database Connectivity (JDBC) is one of the pluggable data sources available that can utilize the JDBC-ODBC bridge, allowing access to other data sources.






detail query

When defining a master/detail report, the detail query retrieves all related records for each record retrieved by the master, or parent, query.






dialog box

A partial screen or window that prompts you to enter information necessary to complete an operation.






disabled

An interface element state that means a menu item, button, and so on, cannot be used in the current context (that is, it does not respond to keyboard or mouse input).






editor

See view.






enabled

An interface element state that means that a menu item, button, and so on, can be used in the current context (that is, it responds to keyboard or cursor/mouse input).






field

	
An interface element in which you enter, edit, or delete data.


	
A layout object that defines how the data for a specific query column appears.









foreign key

A value or column in one table that refers to a primary key in another table.






format mask

A setting that defines the appearance of the value of a field. For example, a format mask is used to specify the display of currency amounts and dates.






format trigger

A PL/SQL function that enables you to dynamically change the formatting attributes of an object.






formula column

A user-created column that gets its data from a PL/SQL function or expression, a SQL statement, or a combination of these.






frame

A layout object used to enclose other layout objects and control the formatting, frequency, and positioning of several objects simultaneously.






group

	
In Reports Builder, a data model object that is created automatically to contain all the columns selected by a query, or created by the user to modify the hierarchy of the data appearing in a report; it is used primarily for creating breaks in a report, as well as for resetting computations.


	
An object that is composed of several other objects.









HTML

Acronym for HyperText Markup Language. A tag-based ASCII language used to specify the content and links to other documents on Web servers on the Internet. End users with Web browsers view HTML documents and follow links to display other documents.






HTTP

Acronym for HyperText Transfer Protocol. The protocol used to carry Web traffic between a Web browser computer and the Web server being accessed.






hyperlink

A reference (link) from some point in one document to (some point in) another document or another place in the same document. A Web browser usually displays a hyperlink in some distinguishing way (in a different color, font or style). When users activate hyperlinks (by clicking on them with a mouse) the browser displays the target of the link.






IANA

Acronym for Internet Assigned Numbers Authority. An organization working under the auspices of the Internet Architecture Board (IAB) that is responsible for assigning new Internet-wide IP addresses. IANA-defined character sets refers to those character sets that can be defined for the charset tag and may be used in the Internet.






icon

A graphic representation of a window or tool.






image

A bitmapped object that can be stored and loaded into an application. The client cannot modify an imported image.






intranet

An internal TCP/IP network, access to which is restricted (through a firewall) to individuals inside the company or organization. An intranet provides similar services within an organization to those provided by the Internet, but is not necessarily connected to the Internet. A common example of an intranet is when a company sets up one or more Web servers on an internal network for distribution of information or applications within the company.






Java

A computer language that supports programming for the Internet in the form of platform-independent "servlets" or "applets".






Java EE

Acronym for Java Platform, Enterprise Edition. An environment for developing and deploying enterprise applications in Java consisting of a set of services, application programming interfaces, and protocols that provide for developing multitiered, Web-based applications.






JAR

Acronym for Java ARchive. A file used for aggregating many files (Java class files, images, and so on) into one file.






JSP

Acronym for JavaServer Page. JSP technology is an extension to the Java Servlet technology from Sun Microsystems that provides a simple programming vehicle for displaying dynamic content on a Web page. JSP is a server-side technology. A JSP is an HTML page with embedded Java source code that is executed in the Web server or application server. The HTML provides the page layout that is returned to the Web browser, and the Java provides the business logic.






layout

See Paper Layout view.






margin

An optional report region that appears at the top and bottom of each logical page in a report section (Header, Main, or Trailer). The margin may include any layout object, but typically contains boilerplate and fields (for page numbers, page totals, grand totals, and current date and time).






object

	
An item that can be placed on the layout. The following are examples of objects: rectangle, line, ellipse, arc, polygon, polyline, rounded rectangle, freehand, chart, text, symbol, and text field.


	
In an Oracle database, an instance of an object type. An object can be a row in an object table, or the portion of a row contained in a column object in a relational table.









Object Navigator

A hierarchical browsing and editing interface that enables you to locate and manipulate application objects quickly and easily. Features include:

	
A hierarchy represented by indentation and expandable nodes (top-level nodes show module types, database objects, and built-in packages), enabling tasks such as creating, editing, renaming, and deleting objects.


	
A find field and icons, enabling forward and backward searches for any level of node or for an individual item in a node


	
Icons in the horizontal toolbar replicating common File menu functions









Oracle Fusion Middleware (OracleAS)

A strategic platform for network application deployment. By moving application logic to application servers and deploying network clients, organizations can realize substantial savings through reduced complexity, better manageability, and simplified development and deployment. OracleAS provides the only business-critical platform that offers easy database Web publishing and complete legacy integration while transitioning from traditional client/server to network application architectures.






Oracle Developer Suite

A pre-11g suite of components that combined leading Oracle application development and business intelligence tools into a single, integrated product. Built on Internet standards such as Java and XML, the suite provided a complete and highly productive development environment for building applications for Oracle Application Server and the Oracle database. In Oracle Fusion Middleware, you can install the Developer Tools to install the 11g Release 2 (11.1.2) versions of these components (Oracle Oracle Reports Builder, Oracle Forms Builder, and so on).






ORACLE_HOME

An alternate name for the top directory in the Oracle directory hierarchy on some directory-based operating systems. An environment variable that indicates the root directory of Oracle products.

You can refer to the directory specified by ORACLE_HOME in syntax:

On UNIX: $ORACLE_HOME

On Windows: %ORACLE_HOME%






Oracle Portal

A browser-based development tool for building scalable, secure, extensible HTML applications and Web sites. Oracle Reports Services uses Oracle Portal to control end user access to reports published on the Web by storing information about report requests, the secured server, and any Oracle Reports Services printer used to print report output.






Oracle Reports Bridge

Oracle Reports Bridge (rwbridge) provides functionality for discovering a Reports Server across Farms.






Oracle Reports Client (rwclient)

An Oracle Reports component that provides a command-line interface to send a report to a remote Reports Server (rwserver).






Oracle Reports Builder (rwbuilder)

An Oracle Reports component that provides the report building component of Oracle Reports. Report developers use the Oracle Reports Builder design-time user interface to create and maintain report definitions. For more information, refer to the Oracle Reports Online Help (select Help > Contents in Oracle Reports Builder), and the Oracle® Reports Building Reports manual.






Oracle Reports Runtime (rwrun)

An Oracle Reports component that runs a report using the Oracle Reports Services in-process server.






Oracle Reports Services

The runtime environment that executes, distributes, and publishes your reports for enterprise wide reporting. Using Oracle Reports Services to deploy your reports results in gains of flexibility, time savings, and processing capacity.






Oracle Reports Servlet (rwservlet)

A component of Oracle Reports Services that translates and delivers information between either a Web Server or a Java EE Container (for example, Oracle WebLogic Server) and the Reports Server, enabling you to run a report dynamically from your Web browser.






Oracle Reports Queue Manager (rwrqm)

(Windows only) Maintains timestamp and status information about reports jobs managed by the Reports Server (rwserver).






Paper Design view

One of the views of the Report Editor that displays output for paper reports and enables you to make many commonly required, simple modifications to the layout, such as spacing, formatting fields, color, and editing text, without having to open the Paper Layout view.






Paper Layout view

One of the views of the Report Editor that displays the layout objects in a paper report and enables you to make many modifications to any layout object. All layout objects have properties that you can modify using the Property Inspector. The hierarchy of the layout objects is determined by the Data Model.






Paper Parameter Form view

Displays the layout of the Parameter Form that, at runtime, allows user input of parameter values in the Runtime Parameter Form.






PDF

Acronym for Portable Document Format. A file format (native for Adobe Acrobat) for representing documents in a manner that is independent of the original application software, hardware, and operating system used to create the documents. A PDF file can describe documents containing any combination of text, graphics, and images in a device-independent and resolution independent format.






PL/SQL

Oracle's proprietary extension to the SQL language. Adds procedural and other constructs to SQL that make it suitable for writing applications.






PPD

Acronymn for PostScript Printer Definition. PPD and AFM files are supplied by Adobe and by printer vendors. These files contain information about the printer. Along with other parameters, these files are read for the information about the available fonts for the printer, which Oracle Reports will use. For all the fonts listed in the PPD file, Oracle Reports searches for the corresponding AFM file according to the font name and loads all of the fonts for which there is an available AFM.






Property Inspector

A window that enables you to view, locate, and set the properties of the currently selected object(s) in the Object Navigator, Report Editor, and Template Editor. Every Reports Builder object (query, group, frame, parameter, and so on) has associated properties that can be viewed using the Property Inspector. The Property Inspector features:

	
expandable and collapsible nodes


	
in-place property editing


	
search features


	
multiselection


	
complex property dialogs


	
the ability to invoke multiple instances of the Property Inspector




To get help on any property, click the property in the Property Inspector and press F1.






query

A SQL SELECT statement that specifies the data you wish to retrieve from one or more tables or views of a database.






RDF file

A file that contains a single report definition in binary format. .RDF files are used to both run and edit reports.






record

One row fetched by a SQL SELECT statement.






REP file

A file that contains a single report definition in binary format. .REP files are used solely to run reports; you cannot edit a .REP file.






repeating frame

A layout object used to display rows of data that are fetched for a group.






Reports CGI (rwcgi)



	
Note:

Reports CGI (rwcgi) is deprecated (maintained only for backward compatibility); instead, use Reports JSPs, rwservlet (Reports Servlet), or Reports Web Services.








An Oracle Reports component, also known as the Common Gateway Interface (CGI) or Reports Web Cartridge, that translates and delivers information between either a Web Server or a Java EE Container (for example, Oracle WebLogic Server) and the Reports Server, to run a report dynamically from your Web browser.






Report Editor

The Oracle Reports Builder window that provides different views to help you handle the data objects and layout objects for Web and paper reports. The views are:

	
Data Model view


	
Paper Layout view


	
Paper Design view


	
Paper Parameter Form view


	
Web Source view









Reports Engine

A component of Oracle Reports Services that fetches data from the data source, formats the report, send output to cache, and notifies the Reports Server that the job is ready.






Reports Server (rwserver)

Reports Server (rwserver) is an Oracle Reports component that provides reporting services to execute, distribute, and publish your reports for enterprise-wide reporting. A component of Oracle Reports Services that processes client requests, including user authentication, scheduling, caching, and report distribution. Use Oracle Reports clients such as Oracle Reports Servlet (rwservlet), Reports JSP, and Oracle Reports Client (rwclient) to send a report to Reports Server.






row

One set of field values in a table; for example, the fields representing one employee in the example table EMP.






Runtime Parameter Form

A screen or window appearing optionally at runtime in which a user can modify print options and parameters prior to report execution.






schema

A collection of related database objects, usually grouped by database user ID. Schema objects include tables, views, sequences, stored program units, synonyms, indexes, clusters, and database links.






SELECT statement

A SQL statement that specifies which rows and columns to fetch from one or more tables or views.






servlet

A Java application that runs in a Web server or application server and provides server-side processing, typically to access a database or perform e-commerce processing. Because they are written in Java, servlets are portable between servers and operating systems.

The Reports Servlet (rwservlet) and JSP are components of Oracle Reports Services that process custom (JSP) report tags and deliver information between the Oracle HTTP Server and the Reports Server.






SQL

A standard interface for storing and retrieving information in a relational database. SQL is an acronym for Structured Query Language.






SQL file

A file that contains a query stored in text (for example, ASCII or EBCDIC) format.






SQL script

A file containing SQL statements that you can run to perform database administration quickly and easily. Several SQL scripts are shipped with Oracle products.






SQL statement

A SQL instruction to Oracle. A SELECT statement is one type of SQL statement.






style sheet

HTML extensions that provide powerful formatting flexibility in HTML documents. To view an HTML document that takes advantage of style sheets, display it in a browser that supports style sheets.






table

A named collection of related information, stored in a relational database or server, in a two-dimensional grid that is made up of rows and columns.






tabular

A default layout displaying labels at the top of the page and rows of data underneath the labels.






template

A skeleton definition containing common style and standards, and may include graphics. A template provides a standard format to enable quick and easy development of professional standard look-and-feel reports.






Template Editor

A work area in which you can define objects and formatting properties for your templates. It is similar to the Paper Layout view of the Report Editor. You can create, delete, and modify objects (for example, page numbers, text, and graphics) in the margin area. You cannot create and delete objects in the body area, but you can modify the properties of body objects in the Property Inspector.






tool

An iconic button used to create and manipulate objects in an application.






tool palette

A collection of tools represented by iconic buttons in the user interface that allow a report developer to perform tasks, such as drawing a rectangle in the Paper Layout view or creating a query in the Data Model view.






toolbar

A collection of iconic buttons that perform product commands. Usually aligned horizontally along the top, or vertically down the side of a window.






URL

Acronym for Uniform Resource Locator. A compact string representation of the location for a resource that is available through the Internet. It is also the text string format clients use to encode requests to OracleAS.






view

	
In Reports Builder, a work area in which you perform a specific set of tasks, such as defining a report data model, layout, or Parameter Form.


	
A virtual table whose rows do not actually exist in the database, but which is based on a table that is physically stored in the database.









Web browser

A program that end users utilize to read HTML documents and programs stored on a computer (serviced by a Web server).






Web server

A server process (HTTP daemon) running at a Web site which sends out Web pages in response to HTTP requests from remote Web browsers.






Web Source view

One of the views of the Report Editor that displays the HTML or JSP source for a report. You can use this view to add dynamic content to a Web page using the Report Block Wizard and the Graph Wizard. Experienced Java developers can edit the Web source directly in this view.






wizard

A step-by-step interface for commonly performed tasks. The wizards in Reports Builder are:

	
Report Wizard: guides you through the steps to create a basic paper or Web report. Each page of the wizard asks you for information to help you create your initial report.


	
Data Wizard: helps you helps you quickly define or modify a query for a multiquery data models.


	
Graph Wizard: Adds variety of charts and graphs, including true 3-dimensional graphs. Implemented in Reports Builder with the Oracle BI graph bean.


	
Report Block Wizard: enables you to add data to a static HTML page.









XML

Acronym for Extensible Markup Language. A metalanguage using SGML to define and structure data. Reports Builder supports XML output to enable Web publishing as well as electronic data exchange with third-party applications. You can also use XML to build report definitions that can be merged with other report definitions at runtime or run separately.






29.2 Create a Query and the Layout

The steps in this section show you how to build a simple data model and report layout in the Report Wizard, which you can then use to generate either a JSP-based Web report or a paper report. In the next section, you will modify the JSP, so that the appropriate information displays in your Web report.


To create a data model and layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout only, then click Next.


	
On the Style page, select Tabular, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT EMPLOYEES.EMPLOYEE_ID, EMPLOYEES.FIRST_NAME, EMPLOYEES.LAST_NAME,
  EMPLOYEES.HIRE_DATE, EMPLOYEES.SALARY, DEPARTMENTS.DEPARTMENT_NAME,
  LOCATIONS.CITY 
  FROM EMPLOYEES, DEPARTMENTS, LOCATIONS 
  WHERE EMPLOYEES.DEPARTMENT_ID=DEPARTMENTS.DEPARTMENT_ID 
  AND DEPARTMENTS.LOCATION_ID=LOCATIONS.LOCATION_ID 
  ORDER BY CITY




	
Note:

You can enter this query in either of the following ways:

	
Copy and paste the code from the papertoexceldata_code.txt file packaged with Oracle Reports, into the Data Source definition field.


	
Click Query Builder to build the query, without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 29.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, click Next.


	
On the Template page, select Predefined Template and click Wine, and then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 29-2 Paper Design Output

[image: Description of Figure 29-2 follows]






	
Save your report as mypaperreport_your_initials.rdf.









9.5 Summary

Congratulations! You have successfully created a summary report. You now know how to:

	
create a data model with summaries and lay out the data with the Report Wizard.


	
format fields in the Paper Design view.


	
examine the summaries and their properties.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






25.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






3.2 Part 2: Building Group Reports

This part of the manual explains the different kinds of report layouts.



3.2.1 Building a single-query group report

In this example, you will build a simple group left report using one query.

Group left and group above reports divide the rows of a report into "sets," based on common values in one or more of the columns, such as the department number in the preceding example. In the sample output below, notice that each department number prints only once. If the report above was not a group report, the department number would print once for each employee in the department rather than just once for the whole department.


Figure 3-7 Final output of the single-query group report example

[image: Description of Figure 3-7 follows]






For more information on building this example, refer to Chapter 10, "Building a Single-Query Group Report".






3.2.2 Building a two-query group report

In this example, you will build a group above report using two queries.

A two-query group report appears much the same as a single-query group report. Performance is the key issue when contrasting single-query and multiple-query group reports. In most cases, single-query reports will run faster than multiple-query reports. Multiple-query reports are, however, sometimes easier to understand conceptually and easier to maintain. For example, if you are in a situation where only a few users run the report and the report returns a relatively small number of records, you might want to use multiple queries to simplify maintenance and make the data model easier to understand. If you have many users and the report is quite large, then you should try to use a single-query report.


Figure 3-8 Final output of the two-query group report example

[image: Description of Figure 3-8 follows]






For more information on building this example, refer to Chapter 11, "Building a Two-Query Group Report".






3.2.3 Building an across group report

In this example, you will build an across group report that prints the values of a database column across the page instead of down.


Figure 3-9 Final output of the across group report example

[image: Description of Figure 3-9 follows]






For more information on building this example, refer to Chapter 12, "Building an Across Group Report".






3.2.4 Building a group left summary report

In this example, you will build a summary report that groups the summaries on the left in the report output.

This report consists of master records (Name, at the upper left of the figure below), detail records (Product, Itemtot, and Orderdate, to the upper right), and summary records (Product, and Sum Total). The summary calculates totals for the details under each master record. Notice that the column Product appears twice. With Reports Builder, you can display columns any number of times.


Figure 3-10 Final output of the group left summary report example

[image: Description of Figure 3-10 follows]






For more information on building this example, refer to Chapter 13, "Building a Group Left Summary Report".






3.2.5 Building a group left formula report

In this example, you will use the Report Wizard to set up your report and write the one query that selects all the necessary database columns. You will then manually create the two formula columns to calculate tax and order totals for each customer, then add the formula columns to your report. You will use a Group Left style report to make the data in the report easy to read.


Figure 3-11 Final output of the group left formula report example

[image: Description of Figure 3-11 follows]






For more information on building this example, refer to Chapter 14, "Building a Group Left Formula Report".







Part IV



Building Matrix Reports

The chapters in this Part introduce matrix reports in Oracle Reports Developer and provide steps to build matrix reports. Matrix reports display information in a grid format and include variations, such as information displayed as nested grids or grids displayed for each group in the report.

	
Chapter 25, "Building a Matrix Report"




A matrix report looks like a grid that contains a row of labels, a column of labels, and information in a grid format related to both the row and column labels. These reports are sometimes referred to as "crosstab" reports.

	
Chapter 26, "Building a Nested Matrix Report"




A nested matrix report contains the cross product, that displays every possible value for three dimensions - two down (such as YEAR and DEPTNO) and one across (such as JOB).

	
Chapter 27, "Building a Matrix with Group Above Report"




A matrix with group above report is a combination of a matrix layout and a group above layout. For each group in this report, the break group (for example, the department number) displays across the top of the record, and the details of the group (for example, the employee information) displays in a matrix format.




9.2 Create a Data Model and a Group Above Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.


To create a data model and layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Group Above, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT SALES_REP_ID, CUSTOMER_ID, SUM(ORDER_TOTAL) TOTAL 
FROM ORDERS
GROUP BY SALES_REP_ID, CUSTOMER_ID




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called summary_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 9.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click SALES_REP_ID and click the right arrow (>) to move this field to the Group Fields list, then click Next.


Figure 9-2 Groups page of the Report Wizard

[image: Description of Figure 9-2 follows]






	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.


	
On the Totals page, click TOTAL in the Available Fields list, then click Sum. Given the data model you are using, this step will create two summary columns for you:

	
SumTOTALPerSALES_REP_ID sums the total of TOTAL for each value of SALES_REP_ID (that is, for each sales representative).


	
SumTOTALPerReport sums the total of TOTAL for the entire report (that is, for all sales representatives).





	
Still on the Totals page, click % of Total. Given the data model you are using, this step will create two columns for you:

	
TotalTOTALPerCUSTOMER_ID calculates dollars for each customer (CUSTOMER_ID) as a percentage of the total dollars for each sales representative (SALES_REP_ID).


	
TotalTOTALPerSALES_REP_ID calculates dollars for each sales representative (SALES_REP_ID) as a percentage of the total dollars in the entire report.





Figure 9-3 Totals page of Report Wizard

[image: Description of Figure 9-3 follows]






	
Click Next.


	
On the Labels page, change the labels as follows, then click Next:


	Fields	Labels
	
SALES_REP_ID

	
Sales Rep


	
CUSTOMER_ID

	
Customer


	
TOTAL

	
Dollars








	
On the Template page, make sure Beige is selected under Predefined Template.


	
Click Finish to display your report output in the Paper Design view.









25.6 Add Zeroes in Place of Blanks

A matrix report displays a juxtaposition of data – in other words, the values held in common by two different categories of data. These categories are indicated by the row and column labels.

The matrix displays this juxtaposition of values using a grid-like format. If the two categories have nothing in common, the grid at that point is empty. The matrix appears to be full of "holes". You can fill the holes using boilerplate text.




	
Note:

Do not confuse empty spaces in the grid with null values. A null value is an actual value fetched from the database. The spaces in a matrix report are empty because nothing has been fetched to fill them.










To replace blanks with zeroes:

	
Open the matrix report to which you previously added the summaries.


	
In the Object Navigator, double-click the view icon next to the Paper Layout node to display the Paper Layout view.



	
Tip:

The steps that follow require some precision in the placement of objects. Hence, you may want to magnify the view to make the process easier. Click the Magnify tool and then click somewhere in the Paper Layout view. Repeat as many times as necessary.








	
In the Paper Layout view, click the Confine On and Flex On buttons in the toolbar to turn both modes on.


	
From the font lists in the toolbar, choose Arial (Western), point size 10.


	
Click the Align Right button in the toolbar.


	
Click the Text tool in the tool palette.


	
Click the top of the F_SUM_SAL field about 0.75 inches (2 centimeters) from its right edge. Your objective is to create an object right on top of F_SUM_SAL.


	
Type the following:


$0.00



	
Click in an open area of the layout to deselect all objects.


	
In the Object Navigator, type B_1 in the Find field. You will be taken to the object you just created. If you are viewing the Object Navigator in Ownership View (View > Change View > Ownership View), you should see B_1 underneath R_G_SUM_SAL and on the same level as F_SUM_SAL.



	
Tip:

If B_1 does not appear underneath R_G_SUM_SAL, return to the Paper Layout view, delete B_1 and try again.









Figure 25-10 Object Navigator with new object selected

[image: Description of Figure 25-10 follows]






	
Click R_G_SUM_SAL and then ctrl-click F_SUM_SAL so that they are both selected and B_1 is deselected.


Figure 25-11 Object Navigator with repeating frame and field selected

[image: Description of Figure 25-11 follows]






	
Click the title bar of the Report Editor to make it the active window.


	
Click the Confine Off button in the toolbar to turn Confine mode off.


	
Choose Layout > Move Forward.



	
Tip:

After this operation, B_1 should appear just above R_G_SUM_SAL, as a peer rather than a child of R_G_SUM_SAL. If B_1 is still appearing as a child under R_G_SUM_SAL, repeat steps 11 through 14 until it is no longer appearing as a child of R_G_SUM_SAL.








	
In the Paper Layout view, click the Confine On button in the toolbar to turn Confine mode back on again.


	
Click the Paper Design button in the toolbar to display the Paper Design view.



	
Tip:

If the $0.00 is not quite aligning with the other monetary values around it, select it and use the arrow keys to move it to the desired location.









Figure 25-12 Matrix report output with zeroes replacing blanks

[image: Description of Figure 25-12 follows]













3.5 Part 5: Building Reports for Business Cases

This part of the manual explains how you can build various kinds of reports to suit your business requirements.



3.5.1 Building a time series calculations report

In this example, you will build a report that calculates and displays the four-month average of purchases for each customer. You will use the Report Wizard to create a simple time series calculations report for both paper and the Web. For the JSP-based Web report, you will modify the Web source to change labels and add format masks.


Figure 3-26 Final output of the time series calculations report example

[image: Description of Figure 3-26 follows]






For more information on building this example, refer to Chapter 28, "Building a Time Series Calculations Report".






3.5.2 Deploying a paper report to Microsoft Excel output

In this example, you will deploy a report with the Reports Server under Oracle WebLogic Server to display it in Microsoft Excel inside your Web browser, when you have an existing paper layout. You will generate a report to Microsoft Excel output after integrating the paper layout into a Web layout by modifying the Web source of your report.


Figure 3-27 Final output of the Microsoft Excel report

[image: Description of Figure 3-27 follows]






For more information on building this example, refer to Chapter 29, "Building a Report for Enhanced Spreadsheet Output".






3.5.3 Building a report with aggregate data

In this example, you will build a report that collects and displays names of all employees whose salaries fall within the range of 0 to 999, then collects and displays all employees whose salaries fall within the range of 1000 to 1999, and so on. You will be able to modify this report to display any aggregate range you need.


Figure 3-28 Final output of the aggregate data report example

[image: Description of Figure 3-28 follows]






For more information on building this example, refer to Chapter 30, "Building a Report with Aggregate Data".






3.5.4 Building a check printing report with spelled-out cash amounts

In this example, you will build a check printing report with a stub and spelled-out cash amounts. The steps described in this example will help you create a PL/SQL function that returns spelled-out numerical values. You will also learn how to import an image of a preprinted form (in this case, a blank check image) and use the tools in the Paper Layout and Paper Design views to print your report on such a form. Although we use a check as the example in this report, you can use the steps to use any preprinted form with Oracle Reports.


Figure 3-29 Final output of the check printing report with spelled-out cash amounts

[image: Description of Figure 3-29 follows]






For more information on building this example, refer to Chapter 31, "Building a Check Printing Report with Spelled-Out Cash Amounts".






3.5.5 Building a report using a preprinted form

In this chapter, you will learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form.


Figure 3-30 Final output of the preprinted forms example

[image: Description of Figure 3-30 follows]






For more information on building this example, refer to Chapter 32, "Building a Report Using a Preprinted Form".






3.5.6 Building an invoice report

In this example, you will build a report that displays several distinguishing characteristics of a typical invoice, such as customer name and address, sales order number, billing information, and billing totals.


Figure 3-31 Final output of the invoice report example

[image: Description of Figure 3-31 follows]






For more information on building this example, refer to Chapter 33, "Building an Invoice Report".






3.5.7 Building a ranking report

In this example, you will build a report that ranks data in two different ways: by count and by percentage. The upper portion displays the names and the total purchases of the top three customers; the lower portion displays the names and total purchases of those customers who constitute 75% of all sales. You can set the ranking criteria at runtime, or let them default to previously specified values.


Figure 3-32 Final output of the ranking report example

[image: Description of Figure 3-32 follows]






For more information on building this example, refer to Chapter 34, "Building a Ranking Report".






3.5.8 Building a report with a simple table of contents and index

This example is designed to teach you how to add navigational items to a large paper report. You will learn how to create a group above report, then add a simple table of contents to the beginning of your report, which will enable users to find an item by its category. You will also learn how to create an index so users can directly find a specific piece of information.




	
Note:

Generating a table of contents or index is not supported for matrix reports.










Figure 3-33 Simple table of contents

[image: Description of Figure 3-33 follows]







Figure 3-34 Index

[image: Description of Figure 3-34 follows]






For more details on building this example, refer to Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index".






3.5.9 Building a report with a multilevel table of contents

This example is designed to teach you how to add a multilevel table of contents to a large paper report. You will add a table of contents based on a category and sub-category to an existing paper report.




	
Note:

Generating a table of contents is not supported for matrix reports.










Figure 3-35 Multilevel table of contents

[image: Description of Figure 3-35 follows]






For more details on building this example, refer to Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".






3.5.10 Bursting and distributing a report

In this example, you will modify a simple report we have provided to burst each section to a separate report. You will then modify a sample distribution XML file to send an e-mail to each destination with an attachment based on the separate reports. You will also send multiple e-mails to the same e-mail address with a single attachment (the entire report).

For more information on building this example, refer to Chapter 37, "Bursting and Distributing a Report".




	
Note:

No sample output is available for this report.














3.5.11 Building a report with multibyte characters for PDF output

In this example, you will learn how to create a report in PDF format that contains multibyte characters for the Web and paper output. You will build a multibyte character set report using UTF8. You can produce reports that display text in multibyte character sets, such as Simplified Chinese, Traditional Chinese, Japanese, Korean, and Unicode.


Figure 3-36 Multibyte character set UTF8 report in Japanese

[image: Description of Figure 3-36 follows]






For more details on building this example, refer to Chapter 38, "Building a Report with Multibyte Characters for PDF Output".







Part III



Building Reports with Special Formatting

The chapters in this Part provide steps to build reports that include special formatting. The example reports show you how to wrap text data, add headers and footers, format headers with database values that change at runtime, renumber pages, include intermixed fields, suppress labels, use conditional text, and add text, color, and graphics to your report.

This Part contains the following chapters:

	
Chapter 15, "Building a Wrapped Field Report"




A wrapped field report wraps the data on word boundaries if it is too long to fit in one line. The report contains a field that is of a fixed horizontal width but can expand vertically if the contents of the break field are longer than the specified width. The contents of the fields are not truncated.

	
Chapter 16, "Building a Header and Footer Report"




A header and footer report contains boilerplate or fields in the header or footer section. This report has a page header printed in the upper margin area of every page of the report and a footer printed at the end.

	
Chapter 17, "Building a Header with Database Values Report"




A header with database values report can include dynamic values in the page header of the report. For example, you can print both the first and last department numbers found on each page.

	
Chapter 18, "Building a Report with Graphics, Text, and Color"




A report with graphics, text, and color enables you to modify the look of your report. You can enhance a report by adding an image to the margin, adding a title or a border, or applying different fonts and text styles.

	
Chapter 19, "Building a Report that Renumbers Pages by Repeating Frame"




A report that renumbers pages by repeating frame displays page numbers using the format "Page X of Y Pages". The first number (X) corresponds to the current page of each parent record. The second number (Y) corresponds to the total number of pages of each parent record.

	
Chapter 20, "Building an Intermixed Fields Report"




An intermixed fields report includes the group field between its related fields. This is in contrast to a group report. Normally in the group report, the break field appears to the left of its related fields in the group left report or above in the group above report.

	
Chapter 21, "Building a Report that Suppresses Labels"




A report that suppresses labels is a master/detail report that fetches a master record with no associated details. Therefore, the report suppresses the detail information for a single record but allows the other master/detail records to display.

	
Chapter 23, "Building a Conditional Form Letter Report"




A conditional form letter report generates two different form letters from one report. Since the two letters share common features, it is more convenient to create a base form letter and then apply conditions to certain parts. The conditions will determine whether the part should display for the current record.

	
Chapter 22, "Building a Report with Conditional Highlighting"




Conditional highlighting draws attention to specific data in a report by using visual formatting. You can use Oracle Reports Builder or the PL/SQL Editor to create a format trigger that changes the appearance of retrieved data depending on factors you define. For example, you can display amounts greater than 1000 in red.

	
Chapter 24, "Building a Report with Dynamic Graphics"




A report with dynamic graphics contains drawings and images that are "dynamic." Any changes that you make to the graphics will be reflected in your report output at runtime.




29.5 Summary

You have created Excel output of your report. You now know how to:

	
create a simple paper layout report.


	
modify a Web layout to use an existing paper layout report.


	
test and deploy a JSP-based Web report to Microsoft Excel output using Oracle WebLogic Server.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






15.3 Create Three Summary Columns

The steps in this section show you how to use the Summary Column tool in the Data Model view to create three summary columns. These columns will calculate the percentage of each order total that the customer has purchased, the total purchases the customer has made, and the percentage of the total sales of all customers.


To create the summary columns:

	
In the Data Model view, click the Summary Column tool in the tool palette, then click in the G_CUST_FIRST_NAME group to create a summary column.


	
Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to PCT.


	
Under Summary, set the Function property to % of Total, set the Source property to ORDER_TOTAL, set the Reset At property to G_CUST_FIRST_NAME, and set the Compute At property to Report.





	
Create a second summary column in group G_NAME with the following properties:

	
Under General Information, set the Name property to CUST_TOTAL.


	
Under Summary, set the Function property to Sum, set the Source property to ORDER_TOTAL, and set the Reset At property to G_NAME.





	
Create a third summary column in group G_NAME with the following properties:

	
Under General Information, set the Name property to PCT_TOTAL_SALES.


	
Under Summary, set the Function property to Sum, set the Source property to PCT, and set the Reset At property to G_NAME.




Your data model should now look something like this:


Figure 15-5 Data Model with Three Summary Columns

[image: Description of Figure 15-5 follows]






	
Save your report as wrappedbreak_your_initials.rdf.









6.4 Summary

Congratulations! You have successfully created a mailing label paper report. You now know how to:

	
define a mailing label report using the Report Wizard.


	
adjust the vertical spacing between labels.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






6.3 Add Vertical Spacing

In this section, you will use the Vertical Spacing property to add space between each record in your mailing label report. You can adjust this spacing according to the size of the mailing labels where the records will be printed.


To add vertical spacing:

	
In the Object Navigator, under your report name, expand the Paper Layout node.


	
Under Paper Layout, expand the Main Section node.


	
Under Body, find the repeating frame called R_G_FIRST_NAME.


	
Double-click the repeating frame icon next to the R_G_FIRST_NAME node to display the Property Inspector.


	
Under Repeating Frame, next to Vert. Spacing Between Frames, type 0.25.


	
Press Enter to add your changes.


	
In the toolbar, click Run Paper Layout to display your report in the Paper Design view.




Your report should look something like this:


Figure 6-3 Final mailing label report with vertical spacing

[image: Description of Figure 6-3 follows]









22 Building a Report with Conditional Highlighting

In this chapter, you will learn about reports that display highlighted values based on one or more conditions. By following the steps in this chapter, you can generate the report output shown in Figure 22-1.


Figure 22-1 Conditional highlighting report output

[image: Description of Figure 22-1 follows]







Concepts

	
You can create a format trigger that will change the appearance of retrieved data depending on factors you define.


	
You can use the Conditional Formatting dialog box to create this format trigger, or you can manually create them using the PL/SQL Editor. The steps in this example will show you how to use the Conditional Formatting dialog box, then display the code in the PL/SQL Editor to see how the format trigger was automatically generated by Reports Builder.


	
With conditional highlighting, you can format specified portions of a report's output when certain criteria are met.





Data Relationships

This report uses one query to fetch all data.


Layout

This report uses a tabular layout style. To add conditional highlighting, you will use the Conditional Formatting dialog box to determine which names and salaries will be highlighted in the report output.


Example Scenario

In this example, you will create a report for managers that shows a complete list of employees in the company, but also highlights employee salaries that are greater than or equal to $10,000. You also need to indicate which employees' salaries are between $4,999 and $10,000. In this example, you will use conditional formatting to highlight these figures in bold and red text.

As you build this example report, you will:

	
Create a Basic Tabular Report using the Report Wizard to included a single query.


	
Add Conditional Formatting to the Report using the Conditional Formatting dialog box to highlight specific data in the report.


	
Examine the Conditional Format Trigger Code using the PL/SQL Editor, for the format trigger generated by Reports Builder.




To see a sample report that uses conditional highlighting, open the examples folder named condhigh, then open the Oracle Reports example report named condhigh.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




15.4 Create the Default Layout Using the Report Wizard

The steps in this section show you how to use the Report Wizard to create the layout and choose how your data will display in your report. Here, you will choose the style of report you want to create, and choose to display the data across the report (hence creating the across group report).

You can create a default layout using the Report Wizard, which deletes any existing layouts in your report and replaces it with the new one.


To create the default layout:

	
In the Data Model view, right-click on the canvas, then choose Report Wizard.


	
In the Report Wizard, on the Report Type page, select Create Paper Layout only.


	
On the Style page, select Group Above.


	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list.


	
On the Labels page, change the field widths as follows:


	Fields	Width
	
CUST_FIRST_NAME

	
2


	
CUST_LAST_NAME

	
2








	
Click Finish to display your report output in the Paper Design view. It should look something like this:





Figure 15-6 Paper Design view for the wrapped field report

[image: Description of Figure 15-6 follows]






Notice how the complete names do not display. The steps in the next section will show you how to quickly correct this issue.






17.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






4.10 Work with Report Sections

This section provides procedures for the following tasks that you may perform as you work with report sections:

	
Displaying a section layout view


	
Creating a default layout for a section





See also

Section 2.1.2, "About report sectioning and sections"



4.10.1 Displaying a section layout view

To display the layout view for a report section:

	
In the Paper Layout view, do either of the following:

	
Choose View > Layout Section, then select the section you want to view and check whether or not you want to view or edit the margin area.


	
In the toolbar, click the Header Section, the Main Section, or Trailer Section buttons to view the Header Section, Main Section, or Trailer Section, respectively; click the Edit Margin button to view or edit the margin area.












4.10.2 Creating a default layout for a section

To create a default layout for a report section:

	
In the Paper Layout view, display the layout view for the section.


	
Choose Tools > Report Wizard.


	
Follow the wizard to create a default layout for your report.


	
To create a layout or objects in the margin area of a section, click the Edit Margin button in the toolbar to view/edit the margin area.


	
To add another layout section to the current layout, create an additional report layout (see Section 4.5.5, "Creating an additional report layout").


	
Make further modifications to the default layout manually in the Paper Layout view.



	
Caution:

If you re-enter the Report Wizard after making manual adjustments to your layout in the Paper Layout or Paper Design view, you will lose these layout changes when you click Finish in the Report Wizard, which redefaults the layout.








	
Set properties for the section, as desired.





See also

Section 2.4.2, "About layout defaulting"

Section 4.5.4, "Creating a default layout for a report"

Chapter 4, "Changing the default layout spacing"








33.6 Insert Invoice Information

You are now ready to create fields on the invoice image to retrieve desired information for the invoice report. When you print the report, the field values will be correctly positioned on the invoice form. As you complete the steps below, use the figure below as a guide (you can also open the provided example report invoice.rdf in Reports Builder).


Figure 33-4 Invoice report layout

[image: Description of Figure 33-4 follows]







To insert the information for the invoice report:

	
In the Paper Layout view, click the Text tool in the tool palette, then create a boilerplate text object on top of the invoice image, in the area labeled Terms. In the boilerplate text object, type 30 days.


	
Click the Field tool in the tool palette, and create fields on top of the invoice image, in the following areas:

	
Bill To (one field for each element of the name and address):

Set Name property to F_FIRST_NAME, Source property to CUST_FIRST_NAME.

Set Name property to F_LAST_NAME, Source property to CUST_LAST_NAME.

Set Name property to F_STREET, Source property to C_STREET_ADDRESS.

Set Name property to F_CITY, Source property to C_CITY.

Set Name property to F_STATE, Source property to C_STATE_PROVINCE.

Set Name property to F_POSTAL, Source property to C_POSTAL_CODE.


	
Ship To (one field for each element of the name and address):

Set Name property to F_FIRST_NAME1, Source property to CUST_FIRST_NAME.

Set Name property to F_LAST_NAME1, Source property to CUST_LAST_NAME.

Set Name property to F_STREET1, Source property to C_STREET_ADDRESS.

Set Name property to F_CITY1, Source property to C_CITY.

Set Name property to F_STATE1, Source property to C_STATE_PROVINCE.

Set Name property to F_POSTAL1, Source property to C_POSTAL_CODE.


	
Date: Set Name property to F_TODAY, Source property to Current Date, and Format Mask property to MM/DD/RR.


	
Page: Set Name property to F_PAGE, Source property to Page Number, and Page Numbering property (in the Page Numbering dialog box) to Reset at: R_ORDER.


	
Purchase Order Number: Set Name property to F_ORDER_NO, Source property to ORDER_ID.


	
Sales Order Number: Set Name property to F_ORDER_NO1, Source property to ORDER_ID.


	
Customer Number: Set Name property to F_CUST_NO, Source property to CUSTOMER_ID.


	
Due Date: Set Name property to F_DUE_DAY, Source property to CF_DUE_DATE.


	
Salesperson (2 fields, one for first name, one for last name):

Set Name property to F_SALES_REP_FNAME, Source property to CUST_FIRST_NAME.

Set Name property to F_SALES_REP_LNAME, Source property to CUST_LAST_NAME.


	
Customer Contact: (2 fields, one for first name, one for last name):

Set Name property to F_SALES_REP_FNAME1, Source property to CUST_FIRST_NAME.

Set Name property to F_SALES_REP_LNAME1, Source property to CUST_LAST_NAME.




	
Note:

This example assumes that the customer contact is same person as the sales representative.










	
Ship Date: Set Name property to F_TODAY1, Source property to Current Date, and Format Mask property to MM/DD/RR.


	
Item No.: Set Name property to F_ITEM_NO, Source property to LINE_ITEM_ID. With the field selected, click the Align Right button in the toolbar.


	
Description (column has no heading): Set Name property to F_ITEM_DESC, Source property to TRANSLATED_DESCRIPTION.


	
Quantity Ordered: Set Name property to F_QUANTITY, Source property to QUANTITY. With the field selected, click the Align Right button in the toolbar.


	
Unit Price: Set Name property to F_UNIT_PRICE, Source property to UNIT_PRICE, and Format Mask property to $NNN,NN0.00. With the field selected, click the Align Right button in the toolbar.


	
Extended Amount: Set Name property to F_ITEM_PRICE, Source property to O_QUANTITY_O_UNIT_PRICE, and Format Mask property to $NNN,NN0.00. With the field selected, click the Align Right button in the toolbar.


	
Subtotal: Set Name property to F_SUB_TOTAL, Source property to CS_SUB_TOTAL.


	
Total: Set Name property to F_TOTAL, Source property to CS_TOTAL.





	
Click the Frame tool in the tool palette, and draw a frame around the following fields to group them:

	
Bill To: F_FIRST_NAME, F_LAST_NAME, F_STREET, F_CITY, F_STATE, and F_POSTAL. Set the Frame's Name property to M_BILL_TO.


	
Ship To: F_FIRST_NAME1, F_LAST_NAME1, F_STREET1, F_CITY1, F_STATE1, and F_POSTAL1. Set the Frame's Name property to M_SHIP_TO.


	
Salesperson: F_SALES_REP_FNAME and F_SALES_REP_LNAME. Set the Frame's Name property to M_SALES_REP.


	
Customer Contact: F_SALES_REP_FNAME1 and F_SALES_REP_LNAME1. Set the Frame's Name property to M_CUST_CONTACT.


	
Item list: F_ITEM_NO, F_ITEM_DESC, F_QUANTITY, F_UNIT_PRICE, and F_ITEM_PRICE, including all the empty space below these fields to the bottom border of the list area. Set the Frame's Name property to M_ORDER_LIST. This frame is used to position and size the detail item list repeating frame.




Note: Using a frame ensures that other objects will not be pushed by the variable horizontal size of the name fields.


	
Click the Repeating Frame tool in the tool palette, and draw a repeating frame around the following fields to group them:

	
Item list: F_ITEM_NO, F_ITEM_DESC, F_QUANTITY, F_UNIT_PRICE, and F_ITEM_PRICE, including just the fields and not the empty space below the fields. Set the Repeating Frame's Name property to R_ORDER_LIST, and the Source property to G_LIST.





	
Save and run your report. Adjust the position of objects if necessary to fit to the background of the invoice image. Your final report output should look something like this:





Figure 33-5 Final invoice report output

[image: Description of Figure 33-5 follows]









17 Building a Header with Database Values Report

In this chapter, you will learn about reports with headers that include values queried from the database. By following the steps in this chapter, you can generate the report output shown in Figure 17-1.


Figure 17-1 Group left report output with database values in header

[image: Description of Figure 17-1 follows]







Concepts

In this example report, both the first and last department numbers found on each page are displayed in the page header.


Layout

This report uses one query and two groups. You'll also create two summary columns to provide the values for the header fields. To ensure unique field values for each page, you'll compute the values using the First and Last functions. The First function will return the first database value selected for a group, page, or report, and the Last function will return the last database value selected for a group, page, or report.


Layout

This report uses the default group left format with no modifications.


Example Scenario

In this example, you will create a report that displays and summarizes employee data by department. To make the report more readable, you decide to add a header to each page that indicates which departments appear on the page.

As you build this example report, you will:

	
Create a Data Model and a Group Left Layout.


	
Add Summary Columns for the Header Data.


	
Add a Page Heading that repeats on all pages with database values.




To see a sample header with database values report, open the examples folder named headingdb, then open the Oracle Reports example called headingdb.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.




33.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






1.11 Runtime Views

The topic in this section discuss the views of a report shown at runtime.

	
About the Runtime Parameter Form


	
About the Previewer






1.11.1 About the Runtime Parameter Form

The Runtime Parameter Form is a dialog box that optionally displays at runtime in which you can override default parameter values (for example, values that modify SELECT statements, route the report output to a specified device, and so on). You define the format of the Runtime Parameter Form in the Paper Parameter Form view. If you do not define a Runtime Parameter Form in the Paper Parameter Form view, Oracle Reports Builder displays a default Runtime Parameter Form for you at runtime.

Change the parameters as desired and then click the Run Paper Layout button in the toolbar to run the report.

Alternatively, you can click the Cancel Run button in the toolbar to cancel.


See also

Section 1.6.5, "About the Paper Parameter Form view"

Section 1.9.4, "About Parameter Forms for Web reports"

Section 4.11.7, "Displaying the Parameter Form at runtime"






1.11.2 About the Previewer

The Previewer displays on your screen how the printed version of your report will look. In the Previewer, you can scroll though a single page of report output, page through the entire report, and split the screen to view different sections of the same report concurrently. You can also perform the following actions:


Table 1-3 Print previewer actions

	To...	Click in the toolbar...
	
Print the report

	
the Print button


	
Specify page setup settings

	
the Page Setup button


	
Open a new Previewer

	
the New Previewer button


	
Close the Previewer

	
the Close Previewer button


	
Zoom in

	
the Zoom In button


	
Zoom out

	
the Zoom Out button








A physical page (or panel) is the size of a page that will be output by your printer. A logical page is the size of one page of your actual report (it can be any number of physical pages wide or long). The Previewer displays the logical pages of your report output, one at a time.


Access

To display the Previewer:

	
choose File > Print Preview.





Usage notes

To speed the execution of your report, avoid "fetching ahead" when sending report output to the Previewer or Paper Design view. The following items can result in fetching ahead when referenced before the data on which they rely:

	
total number of pages/panels


	
grand totals


	
break columns that are formulas


	
break columns that have Value if Null specified




Matrix (cross-product) groups also cause fetching ahead. To cross-tabulate the data, Oracle Reports must first fetch all of the data.

It should be noted that while these items slow down the Previewer or Paper Design view, they do not affect performance when writing to a file or some other destination.




	
Note:

A column can cause fetching ahead even if it is not displayed. For example, a grand total may not appear in the report output, but since it is in the report, fetching ahead may still occur when Oracle Reports calculates it.










See also

Section 4.7.16.3, "Displaying report output in the Previewer"

Section 4.7.17.2, "Printing a report from the Previewer"








37.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.
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13.7 Summary

Congratulations! You have successfully created a group left summary report. You now know how to:

	
create two queries with a data link between them.


	
create two separate layouts.


	
combine the separate layouts into one.


	
format monetary values.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






2.5 Parameter Form Objects

The topic in this section builds on the basic concepts discussed in Section 1.9, "Parameter Form Objects".



2.5.1 About Parameter Form HTML extensions

Parameter Form HTML extensions enable you to enhance your Runtime Parameter Form with HTML tagged text and JavaScript when your paper reports are run through the Web. To enhance your Paper Parameter Form for displaying on the Web, you can:

	
create boilerplate text with HTML tags for adding hyperlinks or any other HTML tagged text to your Parameter Form (see Section 4.9.2.3, "Creating a boilerplate text object for HTML tags").


	
insert parameter fields with JavaScript for defining input or select events, such as raising errors when users enter invalid data in a parameter field (see.Section 4.11.12, "Creating HTML Parameter Form input or select events").


	
create a Parameter Form header (a before form escape) for placing a logo or some standard links in the header of the HTML Parameter Form (see Section 4.6.10.1.5, "Creating an HTML Parameter Form header using the Property Inspector" to use the Property Inspector, or Section 4.6.10.2.5, "Creating an HTML Parameter Form header using PL/SQL").


	
create a Parameter Form footer (an after form escape) for placing a logo or some standard links in the footer of the HTML Parameter Form (see Section 4.6.10.1.6, "Creating an HTML Parameter Form footer using the Property Inspector" to use the Property Inspector, or Section 4.6.10.2.6, "Creating an HTML Parameter Form footer using PL/SQL").




You can access the Parameter Form Builder from the Object Navigator or by choosing Tools > Parameter Form Builder.


See also

Section 1.2.2, "About Web Reports"

Section 1.9.4, "About Parameter Forms for Web reports"

Section 2.2.3, "About Web links for HTML output"








19.5 Set Properties and Format Fields


To set properties and format the fields of your report:

	
In the Object Navigator, click the Paper Layout node and click the Expand All button in the toolbar.


	
Double-click the repeating frame icon next to the R_G_ENAME node to display the Property Inspector, and set the following properties:

	
Under Repeating Frame, set the Maximum Records per Page property to 1.





	
In the Object Navigator, double-click the repeating frame icon next to the R_G_CUSTID1 node to display the Property Inspector, and set the following properties:

	
Under Repeating Frame, set the Vert. Space Between Frames property to 0.25 to specify 0.25 inches (0.5 centimeters) of vertical space between instances of the repeating frame; that is, between each customer record.


	
Under General Layout, set the Page Protect property to Yes to specify that the first instance of the repeating frame (that is, the first customer record) must all fit on the same logical page.





	
In the Object Navigator, click the F_CREDITLIMIT node, then Ctrl-click F_AMOUNT to select both nodes.


	
Click the Paper Design button in the toolbar to make the Paper Design view the active window, with the F_CREDITLIMIT and F_AMOUNT fields selected, and make the format changes (you can also click the corresponding buttons in the toolbar):

	
choose Format > Number > Currency


	
choose Format > Number > Add Decimal Place


	
choose Format > Number > Add Decimal Place (again, for two decimal places)


	
choose Format > Justify > Right





	
In the Paper Design view, click the Amount label (column heading), and choose Format > Justify > Right.









8.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






46.3 Use the Report Wizard to Create a Report

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the simple report in this example, you can use the Report Wizard.

Before you use a Text pluggable data source, you might want to examine the text file first to see what it looks like. You can open the census_csv.txt file in a text editor, like Notepad or WordPad, to see the data we will be using in this example.


To create a simple report:

	
Now that you have updated the textpds.conf file, launch Reports Builder.



	
Tip:

If Reports Builder was already open when you modified the textpds.conf file, you must shut down Reports Builder and restart it for Reports Builder to recognize your text file as a valid data source.








	
In the Welcome dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout only, then click Next.


	
On the Style page, type a title for your report and select Group Above, then click Next.


	
On the Data Source page, click Text Query, then click Next.


	
On the Data page, click Query Definition to display the Define Text Query dialog box.

If you get an error message and cannot display the Define Text Query dialog box, check your configuration file (textpds.conf) to confirm the code you added.


	
Under Data Definition, click the CensusCSV format in the list.



	
Note:

The CensusCSV format displays in this list because you added it to the textpds.conf file.








	
Under Data Source, click Browse to find the provided file census_csv.txt.

If you do not see the file listed in your directory, make sure you have selected TXT files in the Files of Type list in the Open dialog box.


	
Click the file, then click Open.


	
When the census_csv.txt file displays in the Location field, click OK.

In the Report Wizard, the data source definition displays in the Data Source definition field.


	
Click Next.


	
On the Groups page click CATEGORY in the Available Fields list and click the right arrow (>) to move this field to the Group Fields list, then click Next.


	
On the Fields page, click the double right arrows (>>) to move all available fields to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, click Next.


	
On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. Make whatever modifications you wish. The report should look like the following image:


Figure 46-3 Paper Design view for the Text PDS report

[image: Description of Figure 46-3 follows]






	
Save the report as census_report_your_initials.rdf.



	
Note:

You can compare your results against the report we have provided in the examples directory. Before you can run the report, however, follow these steps:

	
In the Data Model view, right-click the query and choose Data Wizard.


	
On the Data page, click Query Definition.


	
Update the location of census_csv.txt to its location on your local drive.


















8.6 Format a Field

In the Paper Design view, notice the Salary field. The values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.


To assign a format mask to monetary values:

	
In the Paper Design view, select the first number value underneath the Salary label in the second layout. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.



	
Tip:

If you are familiar with format mask syntax, you could now right-click the field values, choose Property Inspector, and choose or manually type a value for the Format Mask property.








	
Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.


	
Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.


	
Click the Align Right button. All of the values are immediately right aligned.


	
Save your report.





Figure 8-6 Paper Design view with monetary values formatted

[image: Description of Figure 8-6 follows]










46.4 Summary

Congratulations! You have successfully used a Text pluggable data source for a paper report. You now know how to:

	
set up your textpds.conf file.


	
use the Report Wizard to create a paper report based on the text data source.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






A.1 Main Toolbar

The main toolbar is located at the top of the Oracle Reports Builder window, directly beneath the menu bar, as shown in Figure A-1:


Figure A-1 Main toolbar

[image: Description of Figure A-1 follows]






The name and purpose of each button is as follows:


	Icon	Description
	[image: New button]
	
New button. Displays the New Report dialog box.


	[image: Open button]
	
Open button. Displays the Open dialog box.


	[image: Save button]
	
Save button. Saves the report. If you have not saved the report before, the Save As dialog box displays.


	[image: Print button]
	
Print button. Prints the paper report.


	[image: Mail button]
	
Mail button. Displays the Mail dialog box.


	[image: Connect button]
	
Connect button. Displays the Connect dialog box.


	[image: Cut button]
	
Cut button. Deletes the currently selected item and temporarily places it in the clipboard. Use Paste to paste the selected item.


	[image: Copy button]
	
Copy button. Temporarily places a copy of the selected item in the clipboard. Click the Paste button to paste the selected item.


	[image: Paste button]
	
Paste button. Pastes the item in the clipboard in current location of the cursor.


	[image: Undo button]
	
Undo button. Undoes the last action performed.


	[image: Redo button]
	
Redo button. Performs the last action again.


	[image: Run Web Layout button]
	
Run Web Layout button. Runs the current report to your Web browser.


	[image: Run Paper Layout button]
	
Run Paper Layout button. Runs the current report to the Paper Design view in Reports Builder.


	[image: Help button]
	
Help button. Displays the Oracle Reports online Help.












2.2 Web Reports

The topics in this section build on the basic concepts discussed in Section 1.2.2, "About Web Reports".

	
About JavaServer Pages (JSPs) and servlets


	
About previewing JSP-based Web reports


	
About Web links for HTML output


	
About Web links for PDF output


	
About hyperlinks


	
About hyperlink destinations


	
About bookmarks


	
About application command line links


	
About before and after escapes


	
About style sheets





See also

Section 1.2.2, "About Web Reports"



2.2.1 About JavaServer Pages (JSPs) and servlets

JavaServer Pages (JSPs) technology is an extension to the Java servlet technology from Sun Microsystems that provides a simple programming vehicle for displaying dynamic content on a Web page. A JSP is an HTML page with embedded Java source code that is executed in the Web server or application server. The HTML provides the page layout that is returned to the Web browser, and Java provides the business logic.

JSPs keep static page presentation and dynamic content generation separate. Because JSPs cleanly separate dynamic application logic from static HTML content, Web page designers who have limited or no Java programming expertise can modify the appearance of the JSP page without affecting the generation of its content, simply using HTML or XML tags to design and format the dynamically-generated Web page. JSP-specific tags or Java-based scriptlets can be utilized to call other components that generate the dynamic content on the page.

JSPs have the .jsp extension. This extension notifies the Web server that the page should be processed by a JSP container. The JSP container interprets the JSP tags and scriptlets, compiles the JSP into a Java servlet and executes it, which generates the content required, and sends the results back to the browser as an HTML or XML page.

A JSP can be accessed and run from a browser-based client, typically over the Internet or a corporate intranet. Unlike traditional client-server applications, JSP applications:

	
run on a wider variety of client machines and browsers.


	
run on thinner clients, thereby consuming fewer client-machine resources.


	
scale to a larger number of simultaneous users.


	
require less effort to install and maintain.




When a JSP is called for the first time, it is compiled into a Java servlet class and stored in the Web server's memory. Because it is stored in memory, subsequent calls to that page are very fast, thereby avoiding the performance limitations seen with traditional Common Gateway Interface (CGI) programs, which spawn a new process for each HTTP request.

For additional background information about JSP technology, see Oracle Technology Network (OTN) at http://www.oracle.com/technetwork/java/index.html.



2.2.1.1 Using JSPs in Oracle Reports

Oracle Reports supports JavaServer Pages (JSPs) as the underlying technology to enable you to enhance Web pages with information retrieved using Oracle Reports Builder.

In Oracle Reports, you use JSPs to embed data retrieved using the data model into an existing Web page to create a JSP-based Web report. You can create new JSP reports, or save existing reports as JSP reports. New reports are by default saved as JSP reports. The benefit of saving reports as JSPs is that JSPs are text files that are easy to edit as opposed to, for example, the binary .rdf format. When a report is saved as a JSP file, the data model is embedded using XML tags. The entire report can now be defined using XML tags and saved as an XML file.

Using the Oracle Reports custom JSP tags, you can easily add report blocks and graphs to existing JSP files. These tags can be used as templates to enable you to build and insert your own data-driven Java component into a JSP-based Web report. Not only can you edit the HTML or XML code that encapsulates the report block, but you can also edit the report block in the JSP itself, by modifying, adding or deleting their bodies and attributes.

The Report Editor's Web Source view displays the source code for your Web report, including HTML, XML, and JSP tags.

By default, a new JSP created in Oracle Reports Builder contains the following:

<%@ page contentType="text/html;charset=ISO-8859-1" %>

If you are creating your JSP outside Oracle Reports Builder, you should ensure that it contains similar encoding information.

In prior releases, Oracle Reports introduced Web links that you can add to paper-based reports, which become active when you display your paper report in a Web browser or PDF viewer. For JSP reports, hyperlinks have to be created manually, and if the hyperlinks need to substitute data values, the data values must be provided through the rw:field JSP tag. For example:


<a href="http://hostname:port/path/rwservlet?report=department.jsp&p_deptno=<rw:field
  id="F_Deptno" src="Deptno"/>"> 
<rw:field id="F_Deptno" src="Deptno">10</rw:field> 
</a> 






2.2.1.2 Opening or running an encoded JSP-based Web report

If your JSP-based Web report's character encoding (for example, EUC-JP) differs from the character set portion of the NLS_LANG environment variable (for example, JA16SJIS), you will get the following errors:

	
When running the JSP file:



REP-6106 or REP-6104 with javax.servlet.jsp.JspException (multibyte)

REP-0495 Unable to tokenize the query (singlebyte)


	
When opening the JSP file using Oracle Reports Builder:



REP-0069 Internal Error or REP-6106




To work around this issue, you must ensure that your JSP-based Web report's character encoding matches the IANA encoding corresponding to Oracle Reports Builder's character set portion of the NLS_LANG environment variable.

For example:

	
JSP-based Web report encoding:

<%@ page contentType="text/html;charset=EUC-JP" %>

<META http-equiv="Content-Type" content="text/html;charset=EUC-JP">

This JSP file needs to be encoded in the character set (EUC-JP).


	
Oracle Reports Builder encoding:

NLS_LANG=JAPANESE_JAPAN.JA16EUC

In this example, the JSP-based Web report's encoding (EUC-JP) matches Oracle Reports Builder's character set portion of NLS_LANG; that is, JA16EUC.









2.2.1.3 Embedding a character set in a JSP file dynamically

In Oracle Reports, Web report templates are configured for Western European character encoding by default. However, for other languages, you can specify the character encoding for every JSP file by using both the charset attribute of the <Meta> tag and the <%@page%> page directive.

To dynamically associate the appropriate character encoding with the JSP file, you can make the following modifications:

	
Edit the rw*.html files and the blank_template.jsp file, as follows:

	
Modify the page directive to read:



<%@ page contentType="text/html;charset=yourIANAencoding" %>

where:

yourIANAencoding is the IANA encoding name that corresponds to the NLS_CHARACTERSET portion of the NLS_LANG variable.


	
Modify the <Meta> tag inside the <Head> tag to read:

<meta http-equiv="Content-Type" content="text/html;charset=yourIANAencoding" />





	
Edit the template.xsl (ORACLE_HOME/reports/templates/) file, as follows:

	
Modify the <xsl:output> tag to read:

<xsl:output

method="jsp"

indent="yes"

encoding="yourIANAencoding"

/>

where:

yourIANAencoding is the IANA encoding name that corresponds to the NLS_CHARACTERSET portion of the NLS_LANG variable.


	
Add the page directive to the file:

<%@ page contentType="text/html;charset=yourIANAencoding" %>


	
Add or modify the <META> tag inside the tag:

<meta http-equiv="Content-Type" content="text/html;charset=yourIANAencoding" />

where:

yourIANAencoding is the IANA encoding name that corresponds to the NLS_CHARACTERSET portion of the NLS_LANG variable.








See also

Topics "Oracle Reports JSP tags" and "Oracle Reports XML tags" in the Reference section of the Oracle Reports online Help








2.2.2 About previewing JSP-based Web reports

You can preview a JSP-based Web report by clicking the Run Web Layout button in the toolbar, or by choosing Program > Run Web Layout, to run the Web Source. Reports Builder displays Web reports in your default browser.




	
Note:

If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.









It is not necessary that you have Reports Server configured to use this functionality. Oracle Reports Builder uses the standalone Oracle WebLogic Server for running a report to Web layout.


Document Root

By default, the Oracle Reports Builder document root directory is 

$DOMAIN_HOME/servers/<MANAGED_SERVER_NAME>/stage/reports/reports/web.war/. This can be configured in the Oracle Reports Builder configuration file (rwbuilder.conf) as follows:


<webLayout 
  docroot="DOMAIN_HOME/servers/<MANAGED_SERVER_NAME>/stage/reports/reports/web.war/"/>


The end user can also override this configurable docroot from the command line using the WEBSERVER_DOCROOT command line keyword. If your JSP depends on external files, such as images, style sheets, and so on, make sure you copy them into the docroot directory. The docroot should point to any Oracle WebLogic Server component, $DOMAIN_HOME/servers/<MANAGED_SERVER_NAME>/stage/reports/reports/web.war/ directory where Reports Application has been deployed.


Web Server Port

By default, the OHS port is considered to be the Web server port. This can be configured in the Oracle Oracle Reports Builder configuration file (rwbuilder.conf) as follows:


<webLayout port="ohs_port"/>


The end user can override this configurable port parameter from the command line using the WEBSERVER_PORT command line keyword.


Usage notes

	
The large numbers in generated filenames are simply unique IDs, and have no particular meaning (for example, emp012345678.jsp).


	
The temporary files created in the docroot directory get cleaned up when you exit Oracle Reports Builder.





See also

Section 4.7.16.4, "Displaying report output in your Web browser"

Section 4.7.17.3, "Printing a report from your Web browser"






2.2.3 About Web links for HTML output

This topic discusses the Web links that you can add to paper-based reports that will become active when you generate your report to an HTML file and display it in a Web browser.

In most cases, you can define Web links in an object's Property Inspector. You can specify column and field names in the link value to create dynamic links at runtime. If you require more complex implementation of Web links, such as conditional settings, you must specify the link using PL/SQL and the Oracle Reports Builder built-in packaged procedure SRW.SET_ATTR.

Reports output in HTML format can include the following types of Web links:

	
A link from an object to another object within the same report, or to another HTML or PDF document (see Section 2.2.5, "About hyperlinks").


	
An identifier for the destination of a Web link (see Section 2.2.7, "About hyperlink destinations"). The destination can be any printable object (field, boilerplate, frame, and so on) in your report layout.


	
A string in a frame of the master HTML document that links to an associated object (see Section 2.2.8, "About bookmarks"). You can associate a bookmark with any printable object (field, boilerplate, frame, and so on) in your report layout. In the formatted report, you can click a bookmark to display the associated object at the top of the window.


	
URLs that specify image resources. The URLs must be available to your Web server so that the images can be located when the HTML output is displayed by the server.


	
A graph hyperlink to link areas of a graph to specified destinations.




Additionally, your report can include the following headers and footers that use escapes to add HTML tags to your paper-based report:

	
a document header (a before report escape) for placing a logo or some standard links at the beginning of an HTML document (see Section 2.2.10, "About before and after escapes").


	
a document footer (an after report escape) for placing a logo or some standard links at the end of an HTML document.


	
a page header (a before page escape) for placing a logo or some standard links at the beginning of one page or all pages in an HTML document.


	
a page footer (an after page escape) for placing a logo or some standard links at the end of one page or all pages in an HTML document.


	
a Parameter Form header (a before form escape) for placing a logo or some standard links in the header of the HTML Parameter Form.


	
a Parameter Form footer (an after form escape) for placing a logo or some standard links in the footer of the HTML Parameter Form.









2.2.4 About Web links for PDF output

This topic discusses the Web links that you can add to paper-based reports that will become active when you run your report to a PDF file and display it in a PDF viewer.

Reports output in PDF format can include the following types of Web links:

	
A link from an object to another object within the same report, or to another HTML or PDF document (see Section 2.2.5, "About hyperlinks").


	
An identifier for the destination of a Web link (see Section 2.2.7, "About hyperlink destinations"). The destination can be any printable object (field, boilerplate, frame, and so on) in your report layout.


	
A string in the bookmark area of the PDF viewer that links to an associated object (see Section 2.2.8, "About bookmarks"). You can associate a bookmark with any printable object (field, boilerplate, frame, and so on) in your report layout. In the formatted report, you can click a bookmark to display the associated object at the top of the window.


	
A link that executes a command when clicked (see Section 2.2.9, "About application command line links"). You can associate a command with any printable object (field, boilerplate, frame, and so on) in your report layout. In the formatted report, you can click the object to execute the associated command.


	
A graph hyperlink to link areas of a graph to specified destinations.




In most cases, you can define Web links in an object's Property Inspector. You can specify column and field names in the link value to create dynamic links at runtime. If you require more complex implementation of Web links, such as conditional settings, you must specify the link using PL/SQL.






2.2.5 About hyperlinks

A hyperlink is an attribute of an object that specifies a hypertext link to either of the following destinations:

	
an object identified with a hyperlink destination within the same report


	
another HTML or PDF document on the same machine or on a remote Web server




You can set the Additional Hyperlink Attributes property to specify additional HTML to be applied to the hyperlink.


See also

Section 4.6.10.1.8, "Creating a hyperlink using the Property Inspector"

Section 4.6.10.2.7, "Creating a hyperlink using PL/SQL"






2.2.6 About graph hyperlinks

A graph hyperlink provides an active link from an area of a graph to a specified destination in a Web report. When end users display the report on the Web (JSP-based, or paper-based PDF or HTML), they can click one or more areas of the graph to drill down to additional linked information.


See also

Section 4.6.8, "Adding a graph hyperlink"






2.2.7 About hyperlink destinations

A hyperlink destination is an attribute of an object that identifies the destination of a hypertext link.


See also

Section 4.6.10.1.7, "Creating a hyperlink destination using the Property Inspector"

Section 4.6.10.2.8, "Creating a hyperlink destination using PL/SQL"






2.2.8 About bookmarks

A bookmark is an attribute of an object that specifies a string that is a link to the object.


See also

Section 4.6.10.1.10, "Creating a bookmark using the Property Inspector"

Section 4.6.10.2.10, "Creating a bookmark using PL/SQL"

Section 4.6.10.1.11, "Creating a bookmark on break columns using the Property Inspector"






2.2.9 About application command line links

(PDF output only) An application command line link is an attribute of an object that specifies a command line to be executed when the object is clicked.


Restrictions

An object that is associated with a application command line link cannot also be the source of a Web link (a hyperlink).


See also

Section 4.6.10.1.9, "Creating an application command line link using the Property Inspector"

Section 4.6.10.2.9, "Creating an application command line link using PL/SQL"






2.2.10 About before and after escapes

	
A before report escape specifies any text, graphics, or HTML commands that you want to appear at the beginning of your document.


	
An after report escape specifies any text, graphics, or HTML commands that you want to appear at the end of your document.


	
A before page escape specifies any text, graphics, or HTML commands that you want to appear at the beginning of one page or all pages of your document.


	
An after page escape specifies any text, graphics, or HTML commands that you want to appear at the end of one page or all pages of your document.


	
A before form escape specifies any text, graphics, or HTML commands that you want to appear at the top of the HTML Parameter Form.


	
An after form escape specifies any text, graphics, or HTML commands that you want to appear at the bottom of the HTML Parameter Form.





Limitations

In an after report escape (see Section 2.2.10, "About before and after escapes"), adding an HTML command outside the body does not reflect when the report is generated to spreadsheet output, even though the HTML command is written in output properly. For example:



</body><table><tr><td><B> the text to be bolded </B></td><tr></table> </html>



Adding the HTML command before the closing body tag reflect correctly when the report is generated to spreadsheet output. For example:



<table><tr><td><B> the text to be bolded </B></td><tr></table></body></html>

For more information about spreadsheet output, see Section 2.8.13, "About Enhanced Spreadsheet output".


See also

Section 4.6.10.1.1, "Creating an HTML document header using the Property Inspector"

Section 4.6.10.2.1, "Creating an HTML document header using PL/SQL"

Section 4.6.10.1.2, "Creating an HTML document footer using the Property Inspector"

Section 4.6.10.2.2, "Creating an HTML document footer using PL/SQL"

Section 4.6.10.1.3, "Creating an HTML page header using the Property Inspector"

Section 4.6.10.2.3, "Creating an HTML page header using PL/SQL"

Section 4.6.10.1.4, "Creating an HTML page footer using the Property Inspector"

Section 4.6.10.2.4, "Creating an HTML page footer using PL/SQL"

Section 4.6.10.1.5, "Creating an HTML Parameter Form header using the Property Inspector"

Section 4.6.10.2.5, "Creating an HTML Parameter Form header using PL/SQL"

Section 4.6.10.1.6, "Creating an HTML Parameter Form footer using the Property Inspector"

Section 4.6.10.2.6, "Creating an HTML Parameter Form footer using PL/SQL"






2.2.11 About style sheets

Style sheets (or Cascading Style Sheets) refer to HTML extensions that provide powerful formatting flexibility. With style sheet support, your HTML documents can include any of the following:

	
any font size or style


	
overlapping objects


	
horizontal and vertical lines and rectangles of any color or width


	
precise object positioning on a page


	
pagination


	
printing from a Web browser


	
inline image maps




This means that the sophisticated formatting in a report is preserved when you format the report as an HTMLCSS document. Without style sheet extensions, your HTML documents display only basic text formats and imported images. With style sheets, images of highly formatted text can be replaced with text objects of equivalent style, color, and font. Text objects can be positioned to overlay image objects. All text is fully searchable, and fewer images have to be downloaded.

To view an HTML document that takes advantage of style sheets, you must display it in a browser that supports style sheets.


Using external style sheets for HTMLCSS output

Every corporate Web site today uses style sheets to enforce the corporate look-and-feel across Web pages. External style sheets are Cascading Style Sheet (CSS) files that are referenced by these Web pages. End users typically want the same style used in pages on their Web site applied to their Web reports.

In prior releases, applying style sheets and user-defined styles to reports involved manually editing the HTMLCSS output.

You can specify user-defined styles and style sheets for HTMLCSS output using Oracle Reports Builder. Styles can be applied to report, field, text, frame, and repeating frame objects using the new properties Style Sheets, CSS Class Name, and CSS ID properties (see the Oracle Reports online Help for descriptions of these properties). The generated HTMLCSS output includes links to the style sheets and the user-defined styles are applied to the objects.


Restrictions

The following elements are not supported by HTML style sheet extensions:

	
ellipses, arcs, polygons/polylines, and diagonal lines


	
rounded rectangles (formatted as rectangles)


	
arrows on lines


	
dashes on lines or borders of objects





See also

Section 4.7.16.4, "Displaying report output in your Web browser"

Section 4.7.17.3, "Printing a report from your Web browser"








19.2 Create a Data Model and a Group Above Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.


To create a data model and group above layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create both Web and Paper Layout, then click Next.


	
On the Style page, type a Title for your report, select Group Above, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT ENAME, REPID, CUSTID, NAME, ADDRESS, TRIM(CITY)||',
'||STATE||'  '||ZIP LOCATION,  AREA||' '||PHONE, CREDITLIMIT 
FROM EMP, CUSTOMER 
WHERE EMPNO = REPID 
ORDER BY REPID




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called pagenum_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 19.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click ENAME in the Available Fields list and click the right arrow (>) to move this field to the Group Fields list.


	
Move REPID to the Group Fields list, too, then click Next.


Figure 19-2 Selecting group fields in the Report Wizard

[image: Description of Figure 19-2 follows]






	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click CUSTID and click the left arrow (<) to move it back to the Available Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, change the labels and field widths as follows, then click Next:


	Fields	Labels	Width
	
ENAME

	
Rep Name

	
10


	
REPID

	
Rep ID

	
6


	
NAME

	
Customer Name

	
20


	
ADDRESS

	
Address

	
20


	
LOCATION

	
Location

	
20


	
AREA_PHONE

	
Area Phone

	
12


	
CREDITLIMIT

	
Credit Limit

	
8









Figure 19-3 Specifying labels and widths in the Report Wizard

[image: Description of Figure 19-3 follows]






	
On the Template page, click Finish to display your report output in the Paper Design view.


	
Save the report as pagenum_your_initials.rdf.









12.4 Run Your Report to Paper

In this section, you will run your report to the Paper Design view so you can see how your report displays.

	
Click the Paper Design button in the toolbar. Your report runs, then displays in the Paper Design view. It should look like the following:


Figure 12-5 Paper Design View of the Across Group Report

[image: Description of Figure 12-5 follows]






	
Save your report as acrossbreak_your_initials.rdf.









23.4 Add Logic for Text

The text in B_SALESREP and B_ALL2 applies only to some employees. Hence, you need to apply a condition to each one to determine when it should appear. You also need to ensure that objects (for example, B_ALL2 and B_ALL3) move up in the layout whenever objects above them (for example, B_SALESREP and B_ALL2) do not print. Otherwise, you will have large gaps in your report output for employees who do not get all of the objects. To achieve this, you must anchor the text objects together.


To create collapsing anchors:

	
In the Paper Layout view, click the Anchor tool in the tool palette.


	
Click and drag a line from the top left corner of B_SALESREP (the second text object) to the top left corner of B_ALL (the first text object). Double-click to create the new anchor object.


	
Choose Tools > Property Inspector to display the Property Inspector for the anchor object:

	
Set the Child Edge Percent and Parent Edge Percent properties to 0.


	
Set the Collapse Vertically property to Yes.





	
Click the title bar of the Report Editor to make it the active window again.


	
Repeat the steps above, but this time drag from top left corner of B_ALL2 to the top left corner of B_SALESREP.


	
Again, repeat the steps above, but this time drag from top left corner of B_ALL3 to the top left corner of B_ALL2.





Figure 23-3 Property Inspector with anchor properties displayed

[image: Description of Figure 23-3 follows]







To create format triggers:

	
In the Paper Layout view, double-click B_SALESREP to display the Property Inspector, and set the following properties:

	
Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function B_SalesrepFormatTrigger return boolean is
begin
  if :comm >= 500 then return(TRUE); 
   else return(FALSE); 
  end if; 
end;



This boilerplate will print only in the letters to employees whose commissions are greater than $500.


	
Repeat the steps above, but this time enter the following PL/SQL for B_ALL2:


function B_ALL2FormatTrigger return boolean is
begin
   if ((:comm < 500) or (:comm is null)) then 
     return(TRUE); 
   else return(FALSE); 
   end if; 
end;



This logic causes B_ALL2 to print only in the letters where B_SALESREP does not print.


Figure 23-4 Paper Layout view of modified report

[image: Description of Figure 23-4 follows]






	
Compile, save, and run your report. Page through the form letters to see that some have the dinner invitation while others have the "thank you" message.




	
Tip:

To preview this report for a specific destination type, in the Paper Design view, choose File > Preview Format, and select the destination type. Your report output will display as though using Printer fonts instead of screen display fonts, and you can get a clearer indication of the appearance (for example, line wrapping) of the printed report.

In addition, when you print a conditional form letter report on stationery as illustrated, be sure to take into account the position of the letterhead, and so on, when creating the layout so the text of the letter fits into the overall design of the stationery.
















15 Building a Wrapped Field Report

In this chapter, you will learn about reports that include fields with wrapped text. By following the steps in this chapter, you can generate the report output shown in Figure 15-1.


Figure 15-1 Wrapped field report output

[image: Description of Figure 15-1 follows]







Concepts

	
Reports Builder enables you to modify the look of your report in multiple ways. In this example, you will build a break report where the line wraps on word boundaries if it is too long to fit on one line.


	
This report contains a field which is of a fixed horizontal width, but can expand vertically if the contents of the break field are longer than the specified width. The field's contents are not truncated; rather, the contents will wrap within the specified width of the field, and the field will expand vertically.


	
For more information on break reports, refer to the Oracle Reports online Help.





Data Relationships

This is a simple, one-query break report. In addition, you will add three summary columns.


Layout

	
This report is formatted as a master/detail report. You will modify the layout to add space between sets of information, then change the width of a field so that the break field will wrap.


	
Optional: You will change the format masks of three fields. You will also use Page Protect in this report. Page Protect causes all objects within a frame or repeating frame to remain together. By specifying Page Protect for the master repeating frame, the customer name and all of its related records will always appear on the same page.





Example Scenario

As you build this example report, you will:

	
Create a Query in the Data Model View manually, to include one query and two groups.


	
Create Three Summary Columns to calculate various totals and percentages for your report.


	
Create the Default Layout Using the Report Wizard.


	
Modify the Layout of the Report.


	
Run your Report to Paper.




To see a sample wrapped field report, open the examples folder called wrappedbreak, then open the Oracle Reports example report named wrappedbreak.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




36.4 Create a Second Query in the Data Model

The steps in this section will show you how to create a second query in the data model that retrieves the information stored in the table you created in Section 36.2, "Create a table in the database to hold the TOC data". This query will fetch the data necessary for generating the table of contents in the Header section of your report.


To create a query:

	
In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT * FROM TOC_MULTILEVEL




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called multilevel_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.











	
Click OK.


	
In the new query, click and drag the MAIN_TOPIC column to a separate group above the rest of the query.


	
Click the Summary Column tool in the tool palette, then click in the new group object to create a summary column.


	
Double-click the new summary column object to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to Subcategory_Page


	
Under Summary, set the Function property to Minimum and set the Source property to PAGE




Your data model should now look like this:


Figure 36-3 Data model for the multilevel TOC report

[image: Description of Figure 36-3 follows]






	
Save your report.









31.2 Create a Report Using the Report Wizard

The steps in this section will show you how to use the Report Wizard to create a simple report definition.


To create a report definition:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Form, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT ALL ORDERS.ORDER_ID, TO_CHAR(ORDERS.ORDER_DATE, 'DD-MON-YYYY')
ORDER_DATE, ORDERS.CUSTOMER_ID, ORDERS.ORDER_TOTAL, 
CUSTOMERS.CUST_FIRST_NAME || ' ' || CUSTOMERS.CUST_LAST_NAME CUSTOMER_NAME,
CUSTOMERS.CUST_ADDRESS, (ROWNUM + 1000) AS CHECK_NO
FROM ORDERS, CUSTOMERS
WHERE CUSTOMERS.CUSTOMER_ID = ORDERS.CUSTOMER_ID
ORDER BY ORDERS.ORDER_ID ASC




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called spellcash_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 31.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, change the labels and field widths as follows, then click Next:


Table 31-1 Field description of Labels page

	Fields	Labels	Width
	
ORDER_ID

	
Order No.

	
5


	
ORDER_DATE

	
Order Date

	
12


	
CUSTOMER_ID

	
Customer No.

	
3


	
ORDER_TOTAL

	
Order Total

	
15


	
CUSTOMER_NAME

	
Customer

	
40


	
C_STREET_ADDRESS

	
[blank]

	
40


	
C_POSTAL_CODE

	
[blank]

	
5


	
C_CITY

	
[blank]

	
20


	
C_STATE_PROVINCE

	
[blank]

	
3


	
C_COUNTRY_ID

	
[blank]

	
3


	
CHECK_NO

	
Check No.

	
5








	
On the Template page, select No Template, then click Finish to preview your report output in the Paper Design view.

Since you have only created the initial report definition, the formatting will not display like a check. It should look something like this:


Figure 31-2 Paper Design view of the simple report

[image: Description of Figure 31-2 follows]






	
Save your report as spellcash_your_initials.rdf.









28.3 Modify the Web Source of Your JSP Report

Now that you have created your paper report layout, you can take the same report and generate a JSP-based Web report that looks the same as your paper report.


To modify your JSP-based Web report:

	
Save your report, timeseries_your_initials.rdf as a JSP under the same name (timeseries_your_initials.jsp).


	
Click the Web Source button in the toolbar to display the Web Source view.

In the Web Source, you need to change the format mask to match that of the paper report.


	
In the Web Source view, find the text:


<td <rw:headers id="HFtotal" src="HBtotal, HBcustid, HFcustid"/>
class="OraCellNumber"><rw:field id="F_total" src="total" nullValue="&nbsp;"> F_
total </rw:field></td>


	
Add the tag formatMask="LNNNGNN0D00" to the line, so that the line looks like this:


<td <rw:headers id="HFtotal" src="HBtotal, HBcustid, HFcustid"/>
class="OraCellNumber"><rw:field id="F_total" src="total"
formatMask="LNNNGNN0D00" nullValue="&nbsp;"> F_total </rw:field></td>




	
Note:

The bold text is the new format mask tag that we have added to the Total field.








	
Change the format mask for the MAVG field. The resulting line in the Web Source should look like this:


<td <rw:headers id="HFmavg" src="HBmavg, HBcustid, HFcustid"/>
class="OraCellNumber"><rw:field id="F_mavg" src="mavg" formatMask="LNNNGNN0D00"
nullValue="&nbsp;"> F_mavg </rw:field></td>


	
Save your report as a JSP.


	
Click the Run Web Layout button in the toolbar to display your new JSP-based Web report in your browser. The report should look something like this:




	
Note:

If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.










Figure 28-4 Time Series Calculations JSP-based Web Report

[image: Description of Figure 28-4 follows]






The report displays the total for each customer, as well as the average over the past four months.




	
Note:

For information on creating a Parameter Form for a JSP-based Web report, refer to the documented example on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Examples, and click Search. In the list of examples that displays, click Building a JSP-based Web Report with a Parameter Form.

















18.4 Summary

Congratulations! You have successfully created a paper report and modified the text color and fill colors, as well as added graphics. You now know how to:

	
use the Report Wizard to create a simple report definition.


	
modify the layout of the objects in your report.


	
add a border to the report.


	
add bullets to each record.


	
add a horizontal separator between each record.


	
add a title to your report using fill colors and layout features.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






31.5 Import a Check Image and Arrange Fields for Printing

The steps in this section will show you how to adjust the margins of your check printing report and align the fields with an image of a check. You can scan any check and use its image to lay out the objects of your check report. In this section, we use the image we have provided to you, called blankcheck.jpg. This image is located in the spellcash example folder.



31.5.1 Rearrange the layout objects

Before you can insert the check image, you must first rearrange the layout objects.


To rearrange the layout objects:

	
Click the Paper Layout button in the toolbar to display the Paper Layout view.

The layout currently looks like this:


Figure 31-10 Paper Layout view of your report

[image: Description of Figure 31-10 follows]






	
Click the Edit Margin button in the toolbar.


	
In the Paper Layout view, click the margin frame (the heavy black line) to select it.


	
At the top of the frame, click the center black resizing square and drag it up, so that the margin is 0.25 inches (0.5 centimeters).



	
Tip:

When you click the center square, notice that a dotted guideline displays while your mouse button is depressed. You can use these guidelines to help place objects exactly where you want them in the Paper Layout view.








When you are done, it should look something like this:


Figure 31-11 Paper Layout view with resized margin

[image: Description of Figure 31-11 follows]






	
Save your report.









31.5.2 Import the blank check image

In this section, you will import an image of a blank check. You can use any check you like. For this example, we have provided an image called blankcheck.jpg in the spellcash example directory.


To import the blank check image:

	
While the frame is still selected, choose Insert > Image.


	
In the Import Image dialog box, make sure that File is selected.


	
In the text box next to File, type or browse for the location of the image, blankcheck.jpg, then click OK to display the blank check image in the Paper Layout view.


	
Click the Edit Margin button in the toolbar to return to edit mode. Notice that the image no longer displays.









31.5.3 Set up the check printing fields

The steps in this section will show you how to use the various tools in the Paper Layout view to modify the look and feel of your check report. Here, you will learn how to add and modify layout objects and fields according to how you want them to display on the resulting checks. You will create copies of certain fields that you will then use in Section 31.6, "Create a Check Stub With Payment Information and Order Details" to create the check stub.


To set up the check printing fields:

	
In the Paper Layout view, click the Order No. boilerplate text.


	
Click the Select Parent Frame button in the toolbar.

The repeating frame called R_G_ORDER_ID should now be selected in the Paper Layout view. You can also look in the Object Navigator, under Paper Layout, to make sure R_G_ORDER_ID is selected.


	
While R_G_ORDER_ID is selected, click and drag the bottom center resize handle to 8.75 inches (22 centimeters), or the bottom of the page.



	
Tip:

When you click and drag a resize handle in the Paper Layout view, guidelines display along the ruler to help you place your objects. In this case, drag the bottom center resize handle down the page until the horizontal guideline reaches 8.75 inches (22 centimeters).








	
Click the Flex Off button in the toolbar to set Flex mode off.


	
In the Paper Layout view, click F_ORDER_TOTAL, then press CTRL+C on your keyboard.


	
Click in the area below your layout objects and press CTRL+V.

You should see a new field called F_ORDER_TOTAL1. If this field displays on top of the other layout objects, click and drag it down below the other layout objects so that your Paper Layout view now looks something like this:


Figure 31-12 Partial Paper Layout view with F_ORDER_TOTAL1

[image: Description of Figure 31-12 follows]






	
Copy the F_ORDER_DATE field and paste it below the other fields, so that your layout now looks like this:


Figure 31-13 Partial Paper Layout view with F_ORDER_DATE1

[image: Description of Figure 31-13 follows]









	
Note:

When you copy and paste a field, Reports Builder maintains the size of the field. So, when you copy and paste F_ORDER_DATE, you may not see the full name of the field. While the field is selected, you can click and drag the right border of the field to the right so that you can see the full name of the field, F_ORDER_DATE1.










	
Copy F_CUSTOMER_NAME and paste the field below the other layout objects, so that your layout looks like this:


Figure 31-14 Partial Paper Layout view with F_CUSTOMER_NAME1

[image: Description of Figure 31-14 follows]






	
Make two copies of F_CHECK_NO by pressing CTRL+C on your keyboard once, then CTRL+V twice.



	
Note:

Since this field is small, it may be difficult to find. You can use the Object Navigator to find and select the field. When you click a field in the Object Navigator, under Paper Layout, the corresponding field is also selected in the Paper Layout view.








	
Position these two new fields below the other layout objects, so that your layout looks like this:


Figure 31-15 Partial Paper Layout view with F_CHECK_NO1 and F_CHECK_NO2

[image: Description of Figure 31-15 follows]









	
Note:

We have expanded the size of the two new fields (F_CHECK_NO1 and F_CHECK_NO2) to make them easier to see, but you do not need to resize these fields.










	
Click the Field tool in the tool palette.


	
Draw a field below the other layout objects about 5 inches (12.5 centimeters) long, so that your layout now looks like this:


Figure 31-16 Partial Paper Layout view with F_1 field

[image: Description of Figure 31-16 follows]






	
While the new field, F_1, is still selected, click the Fill Color tool in the tool palette, and choose No Fill.


	
Click the Line Color tool in the tool palette, and choose No Line.


	
Double-click the field F_1 display the Property Inspector.


	
Set the Name property to F_SPELLED_AMOUNT.


	
Under Field, set the Source property to SPELLED_AMOUNT (the formula column you created in Section 31.3.2, "Create a formula column in your data model").


	
Save your report.









31.5.4 Rearrange the new fields according to the blank check image

The steps in this section will show you how to use the Paper Design view to rearrange the fields you just created. You will use the blank check image we have provided as a guide.

	
Click the Paper Design button in the toolbar to display your report in the Paper Design view.



	
Note:

When you click the Paper Design button while you are in another view (that is, Paper Layout view or Data Model view), Reports Builder runs your query and your layout. If you receive any error messages when you click the Paper Design button, go back to your original view to verify your changes. You can always compare your report against the sample report we have provided, called spellcash.rdf.








You will see your layout objects, as well as the blank check image:


Figure 31-17 Partial Paper Design view of the check report

[image: Description of Figure 31-17 follows]









	
Note:

You will see that the preview does not quite look like a check report. The steps in this section will show you how to move your fields so that your report looks like a proper check.










	
In the Paper Design view, position the F_ORDER_TOTAL field in the "Amount" box in the blank check image.



	
Note:

If you closed Reports Builder for any reason and are returning to building this report, make sure you click the Flex Off button in the toolbar so that you can move the fields around in the Paper Design view.








	
Click the Align Right button in the toolbar, so that this portion of the check looks like the following:


Figure 31-18 Amount area on blank check

[image: Description of Figure 31-18 follows]






	
Position the F_CHECK_NO field in the "Check No." box on the blank check, and center-align the text.


	
Position the F_ORDER_DATE field in the "Date" box on the blank check, and center-align the text.


	
Position the F_CHECK_NO2 field in the upper right-hand corner of the check image, and right-align the text.


	
Position the F_SPELLED_AMOUNT field next to the "Pay Exactly:" text on the blank check image.


	
Position the F_CUSTOMER_NAME field next to the "Pay To The Order Of:" text on the blank check image.

The check should now look like this:


Figure 31-19 Check image with fields positioned

[image: Description of Figure 31-19 follows]






	
Save your report.









31.5.5 Modify the look and feel of the check

The steps in this section will show you how to change the font, alignment, and formatting of the data on your check.


To modify the look and feel of the check:

	
In the Paper Design view, choose Edit > Select All (or press CTRL+A).


	
Choose Format > Font.


	
In the Font dialog box, choose Arial font, Regular style, Size 10, then click OK.


	
In the Paper Design view, click anywhere to deselect all the objects.



	
Tip:

If you have trouble deselecting the objects, go to the Object Navigator and click any item. The objects that were selected in the Object Navigator should display as deselected.








	
In the Paper Design view, click F_CHECK_NO2 (the check number in the upper right-hand corner of the check) and change the font to Arial, Bold, 12 point.


	
Click the F_ORDER_TOTAL field (the number in the Amount box on the check).


	
Click the Currency button in the toolbar, then click the Commas button.


	
While F_ORDER_TOTAL is still selected, click the Add Decimal Place button in the toolbar twice, so that the amount now displays like this: $46,257.00.


	
Choose Tools > Property Inspector to display the Property Inspector for F_ORDER_TOTAL.


	
Under Field, next to the Format Mask property, add to the beginning of the existing format mask "****", then close the Property Inspector.

The amount should now display like this: ****$46,257.00.


	
Select the F_CUSTOMER_NAME and F_SPELLED_AMOUNT fields by Shift-clicking them, then change the font to Times New Roman, 12 point.

Your report should now look something like this:


Figure 31-20 Formatted Check

[image: Description of Figure 31-20 follows]









	
Note:

You will notice that the other boilerplate text is still overlaying the image. We will rearrange this text later in the chapter.










	
Save your report.











28.4 Summary

Congratulations! You have successfully created a time series calculations report for both paper and Web. You now know how to:

	
create a time series calculations report definition.


	
modify your report for the Web.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






18.3 Modify the Report in the Paper Layout View

The steps in this section show you how to use the various tools in the Paper Layout view to modify the appearance of your report. First, you will move the existing frames to accommodate the changes you will make. You will then add a title to your report, borders around each record, and change the text color.


To modify your report:

	
Click the Paper Layout view button in the toolbar to display the Paper Layout view.


	
Make sure the Confine On button in the toolbar is set to Confine mode on. Doing so enables you to move the objects in the Paper Layout view around the canvas.


	
In the Object Navigator, under Paper Layout > Main Section > Body, click the item M_G_DEPARTMENT_ID_GRPFR.

Notice that, in the Paper Layout view, the outermost frame is selected.


	
Using the arrow keys, move the frame about 2 inches (5 centimeters) down and 1 inch (2.5 centimeters) to the right.

You can use the rulers along the sides of the Paper Layout view as guidance. Your Paper Layout should now look something like this:


Figure 18-3 Paper Layout View of Adjusted Report Layout

[image: Description of Figure 18-3 follows]






	
Now, make sure Flex mode is on and click the Confine Off button in the toolbar to set Confine mode off.


	
Make space for the border you will create that will surround each record. In the Object Navigator, select M_G_DEPARTMENT_ID_GRPFR again.


	
Drag each corner to make space around the inner repeating frame, so that the layout now looks like the following image. Notice the white space around the groups.


Figure 18-4 Paper Layout View with Expanded Repeating Frame

[image: Description of Figure 18-4 follows]






	
Now, let us make space between each record so that we can later put a horizontal line between the records. In the Object Navigator, click R_G_DEPARTMENT_ID.


	
In the Paper Layout view, click the bottom right corner and drag it down about 0.5 inches (1.5 centimeters) so that your layout now looks like this:


Figure 18-5 Paper Layout View with Expanded R_G_DEPARTMENT_ID Repeating Frame

[image: Description of Figure 18-5 follows]






	
Save your report as graphics_your_initials.rdf.






18.3.1 Add a border around the report

Now that you have set up your layout, you can start adding new items. In this section, you will add a border around the entire report.


To add a border:

	
In the Object Navigator, select the M_G_DEPARTMENT_ID_GRPFR frame.


	
In the Paper Layout view, while the M_G_DEPARTMENT_ID_GRPFR frame is selected, click the Line Color tool. The tool can be found at the very bottom of the tool palette.


	
In the color palette that displays, choose the black square to make the border black.


	
While the line is still selected, choose Format > Line > Line Width > 2 pt.


	
Now, preview the layout. In the toolbar, click the Paper Design button to run the report to paper. It should look something like this:


Figure 18-6 Preview of the Report with a Border

[image: Description of Figure 18-6 follows]






	
Save your report as graphics_your_initials.rdf.









18.3.2 Change the font size and style

In the Paper Layout view, you can also change the font and style of the text. The steps in this section will show you how to modify the Department Number text.


To change the font:

	
In the Paper Design view, click the Paper Layout button in the toolbar.


	
In the Object Navigator, select the B_DEPARTMENT_ID and F_DEPARTMENT_ID fields so that you can change the font of the Department ID label and text.



	
Note:

B_DEPARTMENT_ID refers to the boilerplate text "Department ID", which serves as the label for the F_DEPARTMENT_ID field.








	
Click the title bar of Paper Layout view to make it the active window.


	
While the two fields are selected, choose Format > Font.


	
In the Font dialog box, choose a different font and size. In the example, we chose Times New Roman and 12 pt.


	
When you have finished your changes, click OK.



	
Note:

Depending on the font and font size you choose, you may have to adjust the size of the fields to accommodate the text. In the example, since the font was increased, we selected the boilerplate text field and enlarged it.








	
Display your report in the Paper Design view to see what it looks like. Here's an example:


Figure 18-7 Paper Design View of the Report with New Fonts

[image: Description of Figure 18-7 follows]






	
Save your report as graphics_your_initials.rdf.









18.3.3 Add bullets to your report

The steps in this section will show you how to add bullets so that a bullet displays next to each department ID.


To add bullets to your report:

	
In the Paper Layout view, make sure you have enough space next to the B_DEPARTMENT_ID field where you can add a bullet. The bullet needs to be within the R_G_DEPARTMENT_ID repeating frame so that it displays for each record.


	
Click the Ellipse tool in the tool palette.


	
Press the SHIFT key, then draw an ellipse next to the boilerplate text "Department."



	
Note:

Pressing the SHIFT key while you draw the ellipse puts the tool in a "constrained" mode. When you create an ellipse in this mode, you can create a circle. Other tools are similar; for example, constraining the Rectangle tool creates a square. For more information on using these tools, refer to the Oracle Reports online Help.








	
You should now see a circle in the repeating frame. To make the bullet a solid color, select the circle, then click the Fill Color tool in the tool palette.


	
In the color palette that displays, choose black.


	
Run your report to the Paper Design view to see what it looks like.



	
Note:

When you are checking your layout, make sure that the ellipse displays within the R_G_DEPARTMENT_ID repeating frame.









Figure 18-8 Paper Design View of the Report with Bullets

[image: Description of Figure 18-8 follows]






	
Save your report as graphics_your_initials.rdf.









18.3.4 Display a line between each record

When you have a lot of data, you sometimes want to further distinguish each record, so that it is clear how the information is related. In this section, you will add a horizontal line to the layout that will display between each department record.


To add a line separator:

	
In the Paper Layout view, click the Line tool in the tool palette.


	
Press the SHIFT key, then draw a line in the R_G_DEPARTMENT_ID frame beneath the fields, like this:


Figure 18-9 Paper Layout View with Line Separator

[image: Description of Figure 18-9 follows]






	
Format the line the way you want it to appear. In our example, we chose Format > Line > Line Width > 2 pt. Then, we changed the color to black.


	
Run your report to the Paper Design view. It should now look something like this:


Figure 18-10 Paper Design View of Report with Line Separator

[image: Description of Figure 18-10 follows]






	
Save your report as graphics_your_initials.rdf.









18.3.5 Add a title to your report

The steps in this section will show you how to use the tools in the tool palette to create a title for your report. You will use the Fill Color to create a black background and white text, as well as arrange your items so they display properly.


To add a title to the report:

	
In the Paper Layout view, click the Rectangle tool in the tool palette.


	
Draw a rectangle where you want the title to display. We drew the rectangle above the repeating frames, so that the title would display once, above all the data.


	
Click the Text tool in the tool palette, then click in the rectangle and type a title, such as "Employee Details."


	
With the text object selected, click the Text Color tool and choose white.


	
With the rectangle object selected, click the Fill Color tool in the tool palette, and choose black.


	
In the Object Navigator, find the text object you created under Body. You can tell which objects are text objects by the A icon next to the name. In our case, the text object is B_3.


	
Once you have selected the object, click the title bar of the Paper Design view to select the Paper Design view.


	
Choose Layout > Bring to Front.


	
Run your report to the Paper Design view. It should now look something like this:


Figure 18-11 Paper Design View of Report with Title

[image: Description of Figure 18-11 follows]






	
Save your report as graphics_your_initials.rdf.











5.3 Summary

Congratulations! You have successfully created a tabular paper report. You now know how to:

	
define a tabular report layout using the Report Wizard.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".





37 Bursting and Distributing a Report

Oracle Reports enables you to deliver a single report to multiple destinations simultaneously. By taking advantage of this feature, you can create a single report, then send it in any format (layout driven formats, such as PDF or HTML, as well as data model driven formats, such as XML or delimited) to multiple destinations.

In this example, you will modify a simple report we have provided to burst each group to a separate report. You will then modify a sample distribution XML file to send an e-mail to each destination with an attachment based on the separate reports. You will also send multiple e-mails to the same e-mail address with a single attachment (the entire report).


Concepts

Oracle Reports enables you to deliver a single report to multiple destinations simultaneously. Using the distribution feature, you can set up your report to be distributed to an e-mail destination, a portal, a printer, or anywhere else when the report is run. This feature also enables you to improve performance, since you fetch the data only once for many different formats and destinations. Using distribution also reduces your maintenance overhead because you need only one job request to publish the report to multiple destinations. You can refine this further by sending the Header section to some recipients, the Main section to others, and the entire report to an entirely different recipient list.

For more information on bursting and distribution, see "Creating Advanced Distributions" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual, available .


Example Scenario

In this example, you are the report developer for a manufacturing company who needs to deliver monthly information to its warehouses. You will modify an existing report to burst on each warehouse ID, creating separate PDF reports for each warehouse. You will then edit the distribution XML file we have provided to e-mail each report as an attachment to the corresponding warehouses.

As you build this example report, you will:

	
Set Up an Existing Report for Bursting on a warehouse group.


	
Edit the Distribution XML Definition.


	
Run the Report to PDF format so that the report is e-mailed to the destinations defined in the distribution.xml file.




To see a sample distribution report, open the examples folder named distribution, then open source\inventory_report_dist.rdf for report you will distribute, or result\inventory_report_dist.rdf for the report you will burst. For details on how to open these reports, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 37-1.


Table 37-1 Example report files

	File	Description
	
distribution\source\

distribution.xml

	
The XML file that controls the distribution properties for your report.


	
distribution\source\

inventory_report_dist.rdf

	
The source report you will modify to burst and distribute.


	
distribution\result\

inventory_report_dist.rdf

	
The modified report you will burst and distribute.


	
distribution\result\REP_*.pdf

	
The PDFs that are generated when you distribute and burst your report.











	
Note:

The distribution.xml file we have provided for this example is specific to building this example report. A more comprehensive distribution.xml is shipped with Oracle Reports in the ORACLE_HOME\samples\demo directory; you can reuse this file for your own purposes so that you do not have to create one from scratch.












12.3 Create the Default Layout

The steps in this section show you how to use the Report Block Wizard to create the layout and choose how your data will display in your report. Here, you will choose the style of report you want to create, and choose to display the data across the report (hence creating the across group report).


To create the default layout:

	
In the Object Navigator, double-click the Paper Layout node to display the Paper Layout view.


	
In the Paper Layout view, choose Insert > Report Block to display the Report Block Wizard.


	
In the Report Block Wizard, on the Style page, select Group Above, then click Next.


	
On the Groups page:

	
Click G_LAST_NAME in the Available Groups list, then click Across to specify the Print Direction and move this field to the Displayed Groups list.


	
Click G_DEPARTMENT_ID, then click Down.


	
Click Next.





	
On the Fields page, click the right arrow (>) to move the following fields from the Available Fields list to the Displayed Fields list, then click Next:

	
DEPARTMENT_ID


	
DEPARTMENT_NAME


	
LAST_NAME


	
FIRST_NAME





	
On the Labels page, click Next.


	
On the Template page, make sure Beige is selected under Predefined Template, then click Finish to display your report output in the Paper Design view. It should look like this:





Figure 12-4 Paper Layout view for the across group report

[image: Description of Figure 12-4 follows]










23.3 Add Additional Text

After you add the basic text in the Report Wizard, you need to create some additional text. The text must reside inside of the repeating frame, so before you add text, you will resize the repeating frame.


To resize the repeating frame:

	
Click the Paper Layout button in the toolbar to display the Paper Layout view.


	
In the Object Navigator, type R_G_ENAME in the Find field to locate it.


	
Click R_G_ENAME to select it. It is simultaneously selected in the Paper Layout view.


	
Click the title bar of the Report Editor to make it the active window.


	
Click the bottom handle of R_G_ENAME and drag it down about 4 inches (10 centimeters).





To add more text:

	
Click the Text tool in the tool palette.


	
Click about 0.25 inches (0.5 centimeters) below the first text object.


	
Type the following text:


Because you're one of our top sales 
representatives, we would like to 
invite you to a celebration dinner 
after the picnic. Employees such as 
yourself brought in over $10 million 
in increased revenues this year, a 
15% increase over last year. The 
dinner will be held at the City Inn 
from 7:00 PM to midnight. Dinner will
be served at 7:30 PM. Please reply to 
Human Resources if you plan to 
attend.



	
Click once in an open area of the Paper Layout view.


	
Choose Tools > Property Inspector to display the Property Inspector for the boilerplate text object:

	
Under General Information, set the Name property to B_SALESREP.





	
Click the title bar of the Report Editor to make it the active window again.


	
Repeat the steps above, but this time use the following text and name it B_ALL2:


We would also like to take this 
opportunity to thank you for all of 
your efforts over the last year.  As 
a result of your hard work, company 
revenues increased 15%.



	
Again, repeat the steps above, but this time use the following text and name it B_ALL3:


I look forward to seeing you there! 

J. King 
President 
Summit Sporting Goods 



	
Rename the original text object to B_ALL by selecting it and choosing Tools > Property Inspector to set the Name property.









36.3 Create an After Parameter Form Trigger and a Format Trigger

The steps in this section will show you how to create two triggers. The first trigger will use the SRW.SET_FORMAT_ORDER built-in procedure to format the Main section of the report first, then the Header and Trailer sections. The second trigger will fetch the page number for each category, sub-category, and record, and place that information into the table you created in Section 36.2, "Create a table in the database to hold the TOC data".



36.3.1 Create an After Parameter Form trigger

An After Parameter Form trigger is a function that executes after the Parameter Form is executed. In this section, you will set the trigger to change the order of the report execution, so that the Main section formats first.


To create an After Parameter Form trigger:

	
In Reports Builder, open the provided file multilevel_source.rdf.


	
In the Object Navigator, under your report name (MULTILEVEL_SOURCE), expand the Report Triggers node.


	
Right-click AFTER PARAMETER FORM, then choose PL/SQL Editor from the pop-up menu.


	
In the PL/SQL Editor, use the template to enter the following code:


function AfterPForm return boolean is
begin
  srw.set_format_order(srw.main_section, srw.header_section, srw.trailer_section);
  return (TRUE);
end;





	
Note:

You can also copy and paste the code from the provided file, multilevel_code.txt.










	
Click Compile.


	
Once the code has compiled, click Close.


	
Save your report as multilevel_your_initials.rdf.









36.3.2 Create a format trigger

In this section, you will create a format trigger based on the field F_PROD_SUBCATEGORY. This field displays the sub-category, which is the product name. This sub-category falls under the main category, which is the product department. This format trigger will fetch the page number for each product name, so that the table of contents will enable the user to navigate to various parts of the report based on the department name, then the product name.


To create a format trigger:

	
In the Object Navigator, under the Paper Layout node for your report, navigate to Main Section > Body > M_G_PROD_CATEGORY_GRPFR > R_G_PROD_CATEGORY > M_G_PROD_SUBCATEGORY_GRPFR > R_G_PROD_SUBCATEGORY_GPRFR, then click F_PROD_SUBCATEGORY.



	
Tip:

If you cannot find this field, use the Find field at the top of the Object Navigator.








	
Choose Tools > Property Inspector to display the Property Inspector for this field.


	
Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.


	
In the PL/SQL Editor, use the template to enter following code:


function F_PROD_SUBCATEGORYFormatTrigge return boolean is
  pageNum number;
  myCount number;
begin
  -- get page number
  srw.get_page_num(pageNum);
  -- check table for duplicates
  select count(*)
  into myCount
  from toc_multilevel
  where main_topic = :PROD_CATEGORY and
  sub_topic = :PROD_SUBCATEGORY;
  -- if no duplicates, insert row
  if myCount = 0 then
    insert into toc_multilevel
    values (:PROD_CATEGORY, :PROD_SUBCATEGORY, pageNum);
  end if;
  return (TRUE);
end;





	
Note:

You can also copy and paste this code from the provided file, multilevel_code.txt.










	
Click Compile.


	
Once the code is compiled, click Close, then close the Property Inspector.


	
Save your report.











34.6 Add a Percentage Ranking

Another way to rank customers is by percentage of total sales. The idea is the same as ranking by count, but with an important difference. Since you need to fetch all of the data in order to compute a running percent of total summary, you don't want to use a group filter to weed out data. You need to use a format trigger on the repeating frame to compare the running total to your cutoff parameter.


To fetch the data for the percentage calculation:

	
In the Object Navigator, double-click the view icon next to the Data Model node.


	
In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT CUSTNAME CNAME2, SUM(AMOUNT) SUM_AMT2 
FROM SALES
GROUP BY CUSTNAME
ORDER BY SUM(AMOUNT) DESC




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called rank_code.txt (SELECT statement for Percentage Calculation) into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.











	
Click OK. Your data model should now look like the following image.


Figure 34-5 Data Model view of the Ranking Report

[image: Description of Figure 34-5 follows]






	
Save your report.





To create a parameter for the percentage cutoff:

	
In the Object Navigator, under the Data Model node, click the User Parameters node.


	
Choose Edit > Create to create a new user parameter under the User Parameters node.


	
If the Property Inspector is not already displayed, right-click the new user parameter (P_1), then choose Property Inspector to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to CUTOFF_PCT.


	
Under Parameter, set the Datatype property to Number, set the Width property to 2, and set the Initial Value property to 75.





	
In the Data Model view, click the group object G_CNAME2, then click and drag the bottom handle down about 0.25 inches (0.5 centimeters) to make the group bigger.


	
Click the Summary Column tool in the tool palette.


	
Click in the empty space beneath SUM_AMT2 to create a summary column.


	
Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to R_PCT.


	
Under Column, set the Datatype property to Number, and set the Width property to 10.


	
Under Summary, set the Function property to % of Total, set the Source property to SUM_AMT2, set the Reset At property to Report, and set the Compute At property to Report.








To create a second layout for the list of customers by percentage:

	
Click the Paper Layout button in the toolbar to display the Paper Layout view.


	
In the Paper Layout view, click the Report Block tool in the tool palette.


	
Starting about 1 inch (2.5 centimeters) below the existing layout, click and drag a box about the same size as the existing layout to define the size of the second layout and display the Report Block Wizard.


	
On the Style page of the Report Block Wizard, select Tabular, then click Next.


	
On the Groups page, click G_CNAME2 in the Available Groups list and click Down to specify its Print Direction and move this group to the Displayed Groups list, then click Next.


	
On the Fields page, click the following fields and click the right arrow (>) to move them to the Displayed Fields list, then click Next:

	
CNAME2


	
SUM_AMT2





	
On the Labels page, change the labels and field widths as follows, then click Next:


	Fields	Labels	Width
	
CNAME2

	
Customer Name

	
35


	
SUM_AMT2

	
Total Purchases

	
15








	
On the Template page, select No template. (If you were to select a template, it would override the template of the previous layout), then click Finish to display your report layout in the Paper Layout view.


	
From the font lists in the toolbar, choose Arial (Western), point size 10.


	
In the Paper Layout view, click the Text tool in the tool palette.


	
Click directly above the label Customer Name in the new layout and type the following text in the new boilerplate text object:


Top &CUTOFF_PCT Percent of Sales:



	
Move to an open area of the Paper Layout view and click the mouse button to exit text mode. Notice that the text object you just created is still selected, you can now adjust its positioning with the arrow keys.


	
If the text is not already bold, click the Bold button in the toolbar to make it bold.


	
Shift-click the labels Customer Name and Total Purchases so that they are selected simultaneously with the object you just created.


	
Click the Underline button in the toolbar.


	
Click in an open area of the Paper Layout view to deselect everything.


	
Double-click field F_SUM_AMT2 to display the Property Inspector, and set the following properties:

	
Under Field, set the Format Mask property by typing:


-$NNN,NN0.00








To add the logic for the percentage cutoff:

	
In the Object Navigator, type R_G_CNAME2 in the Find field to locate that repeating frame.


	
Double-click the properties icon next to R_G_CNAME2 to display the Property Inspector, and set the following properties:

	
Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function R_G_CNAME2FormatTrigger return boolean is
begin
if :r_pct <= :cutoff_pct then 
   return(TRUE);
else
   return(FALSE);
end if;
end;




	
Note:

You can enter this code by copying and pasting it from the provided text file called rank_code.txt. This code is for the Percentage Cutoff.











To update the Parameter Form for the new percentage parameter:

	
Choose Tools > Parameter Form Builder.


	
In the Parameter Form Builder dialog box, scroll down the list of parameters until you find CUTOFF_PCT, and change its label to:

Top Percentage (%):


	
Click OK.


	
Click the Run Paper Layout button in the toolbar.


	
In the Runtime Parameter Form:

	
For # of Top Customers, type 5.


	
For Top Percentage (%), type 80.





	
Click the Run Report button in the toolbar.





Figure 34-6 Tabular report output restricted by number and percentage of customers

[image: Description of Figure 34-6 follows]
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40 Building a Report that Includes PL/SQL

In this chapter, you will learn about reports that include PL/SQL. By following the steps in this chapter, you can generate the report output shown in Figure 40-1.


Figure 40-1 PL/SQL report output

[image: Description of Figure 40-1 follows]







Concepts

	
There are a variety of ways to incorporate PL/SQL into your reports. You have already created formula columns that used simple PL/SQL expressions to compute their values, and format triggers that used PL/SQL to conditionally determine the formatting of mailing labels. Here, you will create external libraries and local functions and procedures.


	
External PL/SQL libraries are modules that contain named PL/SQL functions and procedures. They may be stored either in the database or in a file, and can be referenced from not only any report, but from other Oracle products. External libraries eliminate the need to re-enter commonly-used PL/SQL constructs, whether in reports, forms, or graphs. This, in turn, eliminates the problem of maintaining several versions of the same PL/SQL code.


	
Local PL/SQL consists of named PL/SQL functions and procedures that are saved in a report definition. Local PL/SQL may be referenced only by objects within the report (for example, group filters, formula columns, format triggers, and so on). However, the usefulness of storing PL/SQL in a single location still applies.





Data Relationships

This report uses one query. You will add a function stored in an external library, a report-level function, two formula columns, and a parameter governing the number of records to display before inserting a space.


Layout

This report uses the tabular layout style, with minor modifications.


Example Scenario

In this example, you will use an external PL/SQL library and PL/SQL within a report to modify formatting to add spacing between records, and calculate the total compensation for each employee. You will manually create a query in the Data Model view, then modify the layout of the report in the Paper Layout view. You will create formula columns, a summary column, and a format trigger that uses a summary column and a user parameter.

As you build this example report, you will:

	
Create a New PL/SQL Library that you will use in this report.


	
Create the Report Definition:

	
Create a query.


	
Create a formula column that calculates bonuses.


	
Create a report-level function that calculates total compensation.


	
Create a second formula column for total compensation.





	
Create the Report Layout Using the Report Block Wizard.


	
Add Vertical Space Between Records:

	
Create a user parameter.


	
Create a summary column that counts the number of records.


	
Modify the layout.


	
Create a format trigger.





	
Run Your Report to Paper.




To see a sample PL/SQL report, open the examples folder named plsql, then open the Oracle Reports example named plsql.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




41.8 Move the SELECT Statements Into Packages

In your current report configuration, the SELECT statements used by the REF CURSOR queries reside within the report itself. In many cases, it is advantageous to have SELECT statements reside in the packages that define the REF CURSOR types. Then, you can simply reference the packages, rather than typing the same SELECT statement directly into every report that uses it. If you need to change the SELECT statement (for example, to modify or add clauses), you simply update it once in the package, rather than in every report that uses it.

The steps in this section will help you to move the SELECT statements to the packages that define the REF CURSOR types.


To move SELECT statements into a package:

	
In the Object Navigator, click the Program Units node for your report.


	
Click the Create button in the toolbar to display the New Program Unit dialog box.


	
In the New Program Unit dialog box, type cont_cv in the Name field.


	
Select Package Body, and click OK to display the PL/SQL Editor for the new program unit.


	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


PACKAGE BODY cont_cv IS
     function query_container (p_department_id number) 
     return container_refcur is tempcv_container cont_cv.container_
     refcur;
begin
  open tempcv_container for
  select employee_id,
  start_date,
  end_date,
  job_id,
  department_id
  from job_history
  where  :department_id=department_id;
  return tempcv_container;
end;                                  
END;





	
Note:

You can open the provided file refcursor_code.txt to copy and paste the code into Reports Builder.










	
Click Compile.


	
If any compilation errors occur, check the code for syntax errors and recompile as needed.


	
Click Close.


	
Now that the function is defined, you must add it to the package spec so that it can be referenced. Other program units will know about the function in the package body only if it is described in the package spec.


	
In the Object Navigator, double-click the CONT_CV (Package Spec) object to display the PL/SQL Editor.


	
In the PL/SQL Editor, type the following line above the END; statement:


function query_container (p_department_id number) return container_refcur;


	
Click Close.


	
Choose Program > Compile > All.


	
Click OK when done.


	
In the Object Navigator, under the Program Units node, double-click Q_CONTAINERREFCURDS to display the PL/SQL Editor.


	
In the PL/SQL Editor, edit the code to look as follows:


function Q_containerRefCurDS return cont_cv.container_refcur is
    temp_container cont_cv.container_refcur;
begin
     temp_container:=cont_cv.query_container (:department_id);
       return temp_container;
end;


When you are done, all of the query's logic will reside in the function named query_container. From now on, when you change query_container, you will change this and any other queries that reference it.




	
Note:

You can open the provided file refcursor_code.txt to copy and paste the code into Reports Builder.










	
Click Compile.


	
If any compilation errors occur, check the code for syntax errors and recompile as needed.


	
Click Close.


	
Click the Paper Design button in the toolbar to view the report in the Paper Design view.


	
Save the report as ref_67_your_initials.rdf.




Optional Exercise:

Repeat the above steps for the other two queries in the report.
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4.9 Work with the Report Layout

This section provides procedures for creating and modifying objects in your report layout. The procedures are grouped into the following sections:

	
General Layout Objects


	
Text Objects


	
Page Numbers or Date/Time Stamps


	
Borders


	
Anchors


	
Colors, Patterns, and Highlighting


	
Format Masks


	
Graphic or Image Objects


	
Page or Group Headers or Footers


	
Margin, Header Page, or Trailer Page Objects


	
Move Objects


	
Resize Objects


	
Change Spacing


	
Modify the Page Layout






4.9.1 General Layout Objects

This section provides procedures for the following tasks that you may perform as you work with container objects:

	
Creating a field object


	
Creating a frame or repeating frame


	
Creating a matrix object


	
Creating a barcode using a barcode font


	
Applying conditional formatting to a layout object






4.9.1.1 Creating a field object

To create a field object manually in the report layout:

	
In the Paper Design view, Paper Layout view, or Paper Parameter Form view, click the Field tool in the tool palette.


	
Click and drag a rectangle.


	
Double-click the new field object.


	
In the Property Inspector, under the Field node, set the Source property to the column or parameter that will provide the value for the field.


	
Set other properties as desired.





See also

Section 1.8.4, "About fields"

Section 1.9.2, "About Parameter Form fields"






4.9.1.2 Creating a frame or repeating frame

To create a frame or repeating frame manually:

	
In the Paper Layout view, click the Frame tool or the Repeating Frame tool in the tool palette.


	
Click and drag a rectangle.



	
Note:

The size of the rectangle must be large enough to include the objects that it will contain.








	
Double-click the new frame object.


	
In the Property Inspector, set the desired properties.





See also

Section 1.8.1, "About frames"

Section 1.8.2, "About repeating frames"

Section 1.8.3, "About frame and repeating frame sizing"






4.9.1.3 Creating a matrix object




	
Note:

This procedure provides steps to create a matrix object manually. The recommended method for creating a matrix object is to use the Report Block Wizard (choose Insert > Report Block in the Paper Layout view).









To create a matrix object:

	
In the Paper Layout view, click the Repeating Frame tool in the tool palette, then drag a rectangle to create a repeating frame.


	
In the Property Inspector, under Repeating Frame, set the Source property to the "column" for the matrix, and set the Print Direction property to Down.


	
Click the Repeating Frame tool in the tool palette again, then drag a rectangle to create a second repeating frame, intersecting the first repeating frame.


	
In the Property Inspector, under Repeating Frame, set the Source property to the "row" for the matrix, and set the Print Direction property to Across.


	
Drag a rectangle around both repeating frames to select them, then choose Insert > Layout Matrix.

This creates a matrix object that is the intersection of the two repeating frames. For example:


Figure 4-1 Example matrix object

[image: Shows two intersecting rectangles]






	
Double-click the matrix object to set its properties.





See also

Section 2.3.7, "About matrix objects"

Section 1.3.7, "About matrix reports"

Section 2.1.7, "About nested matrix reports"

Section 2.1.8, "About matrix with group reports"

Section 4.8.8, "Creating a matrix (cross-product) group"

Section 4.5.3, "Creating a nested matrix report"






4.9.1.4 Creating a barcode using a barcode font




	
Note:

Beginning with Oracle9i Reports, Release 2 (9.0.2), you can use a barcode JavaBean that automatically generates the barcode for you. See the example report in Chapter 43, "Building a Report with a Barcode".









To create a barcode using a barcode font:

	
Install a barcode font on your machine (for example, on Windows, install the barcode font in the Windows Control Panel Font). Barcode fonts are available from most computer stores.



	
Note:

For portability between platforms, you can use a PostScript barcode font to allow you to print your report to any PostScript-enabled output device.








	
Create a query that selects a column from the database containing the numbers for the barcodes you want included in your report.


	
In the Paper Layout view, click the barcode field, and choose Format > Font to apply the barcode font to the field.









4.9.1.5 Applying conditional formatting to a layout object

To apply conditional formatting to a layout object:

	
Click the object, then choose Format > Conditional Formatting.



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
In the Conditional Formatting dialog box, click New to display the Format Exception dialog box.


	
Specify the conditions and formatting attributes to be applied when the condition(s) evaluate to TRUE.


	
Click OK.





Usage notes

	
For more complex conditional formatting, you can define conditions against an object using a PL/SQL format trigger in the PL/SQL Editor.





See also

Section 2.1.6, "About conditional formatting"

Chapter 4, "Highlighting a value"

Chapter 4, "Highlighting a row"








4.9.2 Text Objects

This section provides procedures for the following tasks that you may perform as you work with text objects:

	
Creating a boilerplate object for text


	
Creating a boilerplate object for text that displays every other page


	
Creating a boilerplate text object for HTML tags


	
Editing text


	
Referencing a field in boilerplate text


	
Linking a boilerplate text object to a file


	
Linking an HTML text object to a file


	
Wrapping text in a field


	
Changing text attributes






4.9.2.1 Creating a boilerplate object for text

To create a boilerplate object for text:

	
In the Paper Design view, Paper Layout view or Paper Parameter Form view, click the Text tool in the tool palette.


	
Click and drag a rectangle.


	
In the new boilerplate object, type the desired text.

The text you type is composed of paragraphs which are separated by new lines. Text within a paragraph is word-wrapped inside the boilerplate object's horizontal size.


	
Click outside the boilerplate text object.





See also

Section 1.8.5, "About boilerplate objects"






4.9.2.2 Creating a boilerplate object for text that displays every other page

To create a boilerplate object for text that displays every other page:

	
Create a boilerplate text object where you want it to appear on the page, either in the margin, or in a repeating frame (expand the repeating frame to make room for the boilerplate text, below the fields in the repeating frame).


	
Double-click the boilerplate text object to display the Property Inspector. Under the Advanced Layout node, set the Format Trigger property by typing the following code in the PL/SQL Editor:


function XXX_HDRFormatTrigger return boolean is page_num number; 
begin 
  srw.get_page_num(page_num); 
  if mod(page_num, 2) = 0 then 
    return(false); 
  else 
    return (true); 
  end if; 
end; 


	
Run the report to see the boilerplate text appear every other page.





See also

Section 1.8.5, "About boilerplate objects"






4.9.2.3 Creating a boilerplate text object for HTML tags




	
Note:

This procedure applies to paper-based reports.









To create a boilerplate text object for HTML tags:

	
In the Paper Design view, click the Text tool in the tool palette.


	
Click and drag a rectangle.


	
In the new boilerplate object, type the desired HTML.


	
Click outside the boilerplate text object.


	
Double-click the boilerplate text object (or right-click the object, and choose Property Inspector).


	
In the Property Inspector, under the Web Settings node, set the Contains HTML Tags property to Yes.





Usage notes

When the text object's Contains HTML Tags property is set to Yes, HTML tags and attributes are formatted in your report output as follows:

	
If the report is generated to HTML or HTMLCSS output, all HTML tags and attributes are interpreted and formatted in the output.


	
If the report is generated to other bitmap output formats (for example, PDF, RTF, PostScript), a fixed set of HTML tags and attributes are interpreted and formatted in the output, as described in Section 2.8.9, "About HTML formatting". Any HTML not in the supported set of tags and attributes are not interpreted, and appear as is in the report output.





Example 1: Turning formatting on and off

Consider a text boilerplate object that is defined as follows:


<i><b>Design time format</b> is merged with <span style="font-family:Arial;
color:#00F">run time formatting instructions.</span></i>


With its Contains HTML Tags property set to Yes, this will format as:

Design time format is merged with run time formatting instructions.

With its Contains HTML Tags property set to No, this will format in the report output as:

<i><b>Design time format</b> is merged with <span style="font-family:Arial; color:#00F">run time formatting instructions.</span></i>


Example 2: Boilerplate text object tagged as a hyperlink

In a boilerplate text object, you can type the following text:


<a href=http://your_webserver/reports/my_report.html><img src=oracle.gif> </a>


With the Contains HTML tags property set to Yes, this object will appear in HTML/HTMLCSS report output as a graphic (oracle.gif) , which the end user can click to link to my_report.html.


Example 3: Parameter values output to HTML

In a boilerplate text object, you can type the following Java Applet, called NervousText.class, which takes the object width and height as parameters:


<base href=http://cagney.uk.oracle.com/java/NervousText/>
<applet code="NervousText.class" width=&ObjectWidth height=&ObjectHeight>
<param name=text value="&deptno">
</applet>


With the Contains HTML tags property set to Yes, this object will be interpreted with the parameters replaced with their actual values, as follows:


<base href=http://cagney.uk.oracle.com/java/NervousText/>
<applet code="NervousText.class" width=84 height=72>
<param name=text value="10">
</applet>



See also

Section 1.8.5, "About boilerplate objects"

Section 2.5.1, "About Parameter Form HTML extensions"






4.9.2.4 Editing text

To insert and replace text:

	
In the Paper Design view, Paper Layout view, or Paper Parameter Form view, single-click the text object.


	
Click the text to change to edit mode.


	
Modify the text as desired, then click outside the text object.




To delete text:

	
In the Paper Design view, Paper Layout view, or Paper Parameter Form view, single-click the text object.


	
To cut all the text, choose Edit > Delete.




To cut, copy, or paste text:

	
In the Paper Layout view or Parameter Form view, single-click the text object.


	
Click and drag to mark the text you want to cut or copy, then choose Edit > Cut or Edit > Copy.


	
To paste text, choose Edit > Paste.









4.9.2.5 Referencing a field in boilerplate text

To reference a field in boilerplate text:

	
In the Paper Design view or Paper Layout view, click in the boilerplate text where you want the reference to a field to appear.


	
Type an ampersand (&) followed by the name of the field.

If you want to place the field reference in front of other text with no spaces in between, enclose the field name in angle brackets to separate it from the text (for example, &<fieldname>Oracle). If the field reference follows other text, no angle brackets are needed (for example, Oracle&fieldname). You can include field references right next to each other with no spaces in between and without angle brackets (for example, &field1&field2&field3).





Usage notes

	
A reference to a field includes the field's properties. Therefore, if the Horizontal Elasticity property is set to Fixed, any extra spaces in the field will appear in the report output. For example, if field f_sal is fixed horizontally, $&<f_sal>/week may produce $800/week in the report output.


	
In addition to referencing fields in a boilerplate text object, you can directly reference a database column (for example, &SAL). For example, $&<SAL>/week may produce $800/week in the report output.





See also

Section 1.8.4, "About fields"

Section 1.8.5, "About boilerplate objects"






4.9.2.6 Linking a boilerplate text object to a file




	
Note:

This procedure applies paper-based reports. File Link objects are not implemented in JSP-based Web reports.









To link a boilerplate text object to a file:

	
In the Paper Design view or Paper Layout view, click the File Link tool in the tool palette.


	
Click and drag a rectangle.


	
Double-click the file link object to display the Property Inspector.


	
Under the File Link Boilerplate node:

	
Set the Source File Format property to Text.


	
Set the Source Filename property to the name of the file containing the text.








See also

Section 1.8.5, "About boilerplate objects"






4.9.2.7 Linking an HTML text object to a file




	
Note:

This procedure applies to paper-based reports. File Link objects are not implemented in JSP-based Web reports.









To link an HTML object to a file:

	
In the Paper Design view or Paper Layout view, click the File Link tool in the tool palette.


	
Click and drag a rectangle.


	
Double-click the file link object to display the Property Inspector.


	
Under the File Link Boilerplate node:

	
set the Source File Format property to Text.


	
set the Source Filename property to the name of the file containing the HTML tags.





	
Under the Web Settings node, set the Contains HTML Tags property to Yes.





Usage notes

When the text object's Contains HTML Tags property is set to Yes, HTML tags and attributes are formatted in your report output as follows:

	
If the report is generated to HTML or HTMLCSS output, all HTML tags and attributes are interpreted and formatted in the output.


	
If the report is generated to other bitmap output formats (for example, PDF, RTF, PostScript), a fixed set of HTML tags and attributes are interpreted and formatted in the output, as described in Section 2.8.9, "About HTML formatting". Any HTML not in the supported set of tags and attributes are not interpreted, and appear as is in the report output.





See also

Section 1.8.5, "About boilerplate objects"






4.9.2.8 Wrapping text in a field

To wrap text in a field:

	
Choose Tools > Report Wizard.


	
In the Report Wizard, click the Labels tab.


	
Change the value in the Width column for the field in which you want to wrap text, as desired.


	
Click Apply.



	
Caution:

If you have made manual adjustments to your layout in the Paper Layout view or Paper Design view, you will lose these layout changes when you click Apply or Finish in the Report Wizard, which redefaults the layout. If you do not want to overwrite your current layout, you can manually drag the column to the desired width in the Paper Layout view or Paper Design view.








	
In the Paper Layout view or Parameter Form view, double-click the field to display the Property Inspector, and set the following properties:

	
Under General Layout, verify that the Vertical Elasticity property is set to Expand.












4.9.2.9 Changing text attributes

To change the font, justification, spacing, or reading direction of a text object:

	
In the Paper Design view, click the text object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
From the Format menu, choose Font, Justify, Text Spacing, or Direction.









4.9.2.10 Changing text attributes using PL/SQL

To change the font or justification of a text object using PL/SQL instead of the user interface:

	
In the Object Navigator, expand the Paper Layout node.


	
Double-click the PL/SQL icon next to the text object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
In the PL/SQL Editor, use the following built-in procedures to change the font or justification of the object as desired:

SRW.SET_CHARMODE_TEXT

SRW.SET_FONT_FACE

SRW.SET_FONT_STYLE

SRW.SET_FONT_WEIGHT

SRW.SET_FONT_SIZE

SRW.SET_JUSTIFICATION





See also

Topic "SRW built-in package" in the Reference > PL/SQL Reference > Built-in Packages section of the Oracle Reports online Help.








4.9.3 Page Numbers or Date/Time Stamps

This section provides procedures for the following tasks that you may perform as you work with page numbers or date/time stamps:

	
Creating page numbers


	
Resetting page numbers


	
Creating a time or date stamp






4.9.3.1 Creating page numbers

To create default page numbers:

	
In the Paper Layout view or Paper Design view, choose Insert > Page Number.


	
In the Insert Page Number dialog box, choose from the list the location for the page number.


	
Click the desired page number format: Page Number Only or Page Number and Total Pages.


	
Optionally, change the default attributes of the page number text as desired.




To create customized page numbers:

	
In the Paper Layout view or Paper Design view, click the Edit Margin button in the toolbar.



	
Note:

The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.








	
Create a field object (see Section 4.9.1.1, "Creating a field object") in the margin area for each page number value you require, for example Physical Page Number, Total Physical Pages.


	
In the field's Property Inspector, under the Field node, set the Source property to the source for the page number, and set the Visible property to No. Under the General Layout node, set the Horizontal Elasticity property to Variable.


	
Create a boilerplate text object (see Section 4.9.2.1, "Creating a boilerplate object for text") in the margin area, and reference the page number field(s) (see Section 4.9.2.5, "Referencing a field in boilerplate text") using &fieldname.





Usage notes

	
To generate odd page numbers on the right and even pages numbers on the left, you have to create two fields: one on the right side, one on the left side. In the format trigger of each field, you test if it is an odd or an even page by using SRW.GET_PAGE_NUM. Then, you specify whether or not to display the field.









4.9.3.2 Resetting page numbers

To reset default page numbers (created with Insert > Page Number):

	
In the Paper Layout view or Paper Design view, click the default page number field, then choose Edit > Delete to delete it.


	
Create customized page numbers (see Section 4.9.3.1, "Creating page numbers").


	
In the page number field's Property Inspector, under Field, double-click the Page Numbering property value.


	
In the Page Numbering dialog box, click the desired Reset At setting. Page numbers will reset to the Start at value each time the selected frame is formatted. Click OK.









4.9.3.3 Creating a time or date stamp

To add a date or time stamp to your report:

	
In the Paper Layout view or Paper Design view, choose Insert > Date and Time.


	
In the Insert Date and Time dialog box, choose from the list the location for the date or time stamp.


	
Click the desired date or time format, or click Custom to define your own format.











4.9.4 Borders

This section provides procedures for the following tasks that you may perform as you work with borders:

	
Showing or hiding object borders


	
Changing object border attributes


	
Changing the current mode (Confine or Flex)






4.9.4.1 Showing or hiding object borders

To show or hide the borders around an object:

	
Click the object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Click the Line color tool in the tool palette.


	
To add a border, click any color solid square.


	
To make a border transparent in the report output, click No Line at the bottom of the color palette.



	
Note:

If you make the borders transparent for all the objects, this includes the underlines beneath the column headings. To add the underlines, click the underline objects, and use the Line Color in the tool palette to select a line color.








	
To show or hide part of the border, choose Format > Line > Border, and select from the menu to toggle between showing and hiding the sides of the border.









4.9.4.2 Changing object border attributes

To change the borders around an object:

	
Click the object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
To change the line width, choose Format > Line > Line Width.


	
To select a pattern, choose Format > Line > Dash. Even though it appears in the output, the dash pattern is sometimes obscured by the object's outline. You can choose Tools > Options > Paper Layout and clear the Options:Frame Outlines check box.


	
To "frame" the border, choose Format > Bevel.





See also

Section 2.4.5, "About changing colors and patterns"

Section 4.12.8, "Modifying the color, pattern, or border of body objects in a template"






4.9.4.3 Changing the current mode (Confine or Flex)

To set or override Confine mode:

	
In the Paper Layout view, click the Confine On button or the Confine Off button in the toolbar to toggle the mode:

On: child objects cannot be moved outside their enclosing parent objects.

Off: child objects can be moved outside their enclosing parent objects.




To set or override Flex mode:

	
In the Paper Layout view, click the Flex On button or the Flex Off button in the toolbar to toggle the mode:

On: parent borders "stretch" when child objects are moved against them. The child object maintains the same distance from the side it moves against.

Off: parent borders remain fixed when child objects are moved against them.





See also

Section 2.4.7, "About moving and layering objects in the Paper Layout view"

Chapter 4, "Adjusting parent borders automatically"

Chapter 4, "Moving an object outside its parent"








4.9.5 Anchors

This section provides procedures for the following tasks that you may perform as you work with anchors:

	
Anchoring objects together


	
Viewing implicit anchors


	
Moving an anchor





See also

Section 2.4.4, "About anchors"



4.9.5.1 Anchoring objects together

Anchoring objects assures that the anchored object will move with the parent object. An object can be anchored to only one other object.

To anchor objects together:

	
In the Paper Layout view, click the Anchor tool in the tool palette.


	
Click an edge of the child object and double-click an edge of the parent object.

A line is drawn from the child to the parent. A small box appears at the end of the line that is attached to the parent object.









4.9.5.2 Viewing implicit anchors

By default, you see the explicit anchors created in the Paper Layout view of the Report Editor.

To view information on both implicit and explicit anchors:

	
In the Object Navigator, choose Tools > Options > Navigator to display the Object Navigator Options dialog box.


	
Click the Layout tab, and select the Anchoring Information check box.

With this option selected, you can see all information on both implicit and explicit anchors in the Object Navigator.



	
Note:

By default, objects are anchored to the upper left corner of their enclosing object. If this view of the Object Navigator does not show anchoring information for an object, you can assume that the object is anchored to its enclosing object, which might be the frame or the body.











See also

Section 2.4.4.1, "Implicit anchoring algorithm"






4.9.5.3 Moving an anchor

Moving an anchor changes how the objects will be displayed in relationship to each other.

To move an anchor:

	
In the Paper Layout view, click the anchor.


	
Click the Reshape tool in the tool palette, then drag one of the anchor endpoints to its new location on the object edge.




To move an anchor along an object edge:

	
Press the constrain (for example, shift) key when moving the anchor.




To change the position of the anchor on the object edge, as a percentage down or across from top to bottom or left to right:

	
Double-click the anchor object to display the Property Inspector.


	
Set the Child Edge Percent property or Parent Edge Percent property to a new value.




To change the edge on which the anchor is positioned:

	
Set the Child Edge Type property or Parent Edge Type property as desired.











4.9.6 Colors, Patterns, and Highlighting

This section provides procedures for the following tasks that you may perform as you work with colors, patterns, and highlighting:

	
Setting color palette preferences


	
Changing colors


	
Changing patterns


	
Changing colors and patterns using PL/SQL


	
Modifying the color palette


	
Importing or exporting a color palette


	
Highlighting a value


	
Highlighting a row






4.9.6.1 Setting color palette preferences

See Section 4.2.6, "Setting color palette preferences".






4.9.6.2 Changing colors

To change the color of an object or text:

	
In the Paper Layout view, click the object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Click the Fill Color tool, the Line Color tool, or the Text Color tool in the tool palette, depending on which part of the object you want to apply a color to.



	
Note:

The Fill/Line/Text Display, the box directly above the three Color tools, shows the currently selected fill, border, and text. The default fill and border for objects created by Oracle Reports Builder is transparent, while the default for objects you create is a black, one-point line around a white.








	
On the color palette, click a color.





See also

Section 2.4.5, "About changing colors and patterns"

Section 4.12.8, "Modifying the color, pattern, or border of body objects in a template"






4.9.6.3 Changing patterns

To change the pattern of an object:

	
In the Paper Layout view, click the object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Click the Fill Color tool or the Line Color tool in the tool palette, depending on which part of the object you want to apply a pattern to.



	
Note:

The Windows platform does not support a border pattern (that is, patterns for the Line Color tool).








	
On the color palette, click Patterns.


	
On the pattern palette, click a pattern. To change the foreground and background colors, choose from the color palettes at the bottom of the pattern palette.





See also

Section 2.4.5, "About changing colors and patterns"

Section 4.12.8, "Modifying the color, pattern, or border of body objects in a template"

Topic "Pattern color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help.






4.9.6.4 Changing colors and patterns using PL/SQL

To change the color of an object using PL/SQL instead of the user interface:

	
In the Object Navigator, expand the Paper Layout node.


	
Double-click the PL/SQL icon next to the object for which you want to change the color.


	
In the PL/SQL Editor, use the following built-in procedures to change the color of the object as desired:

SRW.SET_BACKGROUND_BORDER_COLOR

SRW.SET_BACKGROUND_FILL_COLOR

SRW.SET_FOREGROUND_BORDER_COLOR

SRW.SET_FOREGROUND_FILL_COLOR

SRW.SET_TEXT_COLOR

SRW.SET_BORDER_PATTERN





See also

Section 2.4.5, "About changing colors and patterns"

Topic "SRW built-in package" in the Reference > PL/SQL Reference > Built-in Packages section of the Oracle Reports online Help.






4.9.6.5 Modifying the color palette

To modify the color palette:

	
First, make the color palette editable:

	
Choose Edit > Preferences, and set Color Mode to Editable, as described in Section 4.2.6, "Setting color palette preferences".



	
Note:

By default, color palettes are read-only.








	
Shut down and restart Oracle Reports Builder to enable the Editable mode.





	
In the Paper Layout view, choose Format > Color Palette > Edit.


	
In the Color Palette dialog box, modify the color palette as desired:

	
Click Edit to alter the settings of the current color.


	
Type a new name in Current Color, then click Rename to rename the current color.


	
Select Color to Edit contains the current color palette being used in the Report Editor for the current report. Select a color from the palette to alter it.


	
Click OK to apply your changes to the current report.










	
Note:

A report can have only one color palette.










See also

Section 2.4.5, "About changing colors and patterns"

Topics "Oracle CDE1 color palette", "Default color palette", and "Grayscale color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help.






4.9.6.6 Importing or exporting a color palette

To import or export a color palette:

	
First, make the color palette editable:

	
Choose Edit > Preferences, and set Color Mode to Editable, as described in Section 4.2.6, "Setting color palette preferences".



	
Note:

By default, color palettes are read-only.








	
Shut down and restart Oracle Reports Builder to enable the Editable mode.





	
In the Paper Layout view, choose Format > Color Palette > Import or Format > Color Palette > Export.


	
In the dialog box, specify the name and format of the file.


	
Click OK.







	
Note:

A report can have only one color palette.










See also

Section 2.4.5, "About changing colors and patterns"

Topics "Oracle CDE1 color palette", "Default color palette", and "Grayscale color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help.






4.9.6.7 Highlighting a value

To highlight a value in a report:

	
In the Paper Layout view or Paper Design view, click the field that contains the value to be highlighted.


	
Choose Format > Conditional Formatting.


	
In the Conditional Formatting dialog box, click New to display the Format Exception dialog box.


	
Select the field and define the condition(s) when the value should be highlighted.


	
In the Format group box, select the Fill Color to be used to highlight the value.



	
Note:

If you can't select the condition you want to use in the dialog box, select the formatting you want and a placeholder condition. The condition can be edited in the PL/SQL Editor for the format trigger that is created.








	
Click OK to close the Format Exception dialog box, then click OK again to close the Conditional Formatting dialog box. If the code compiles without errors, the new formatting is reflected in the Paper Layout view. The code is stored as a format trigger for the field.





Example

The following code determines the monthly compensation and changes the background color to red if the compensation has exceeded four thousand dollars a month and the employee is not a manager.


function R_G_EMPNOFormatTrigger return boolean is varcomm number;
begin
 if :comm is null then
   varcomm := 0;
 else
   varcomm := :comm;
 end if;
  if (:sal * 2 + varcomm > 4000) and :job != 'MANAGER' then
   srw.set_background_fill_color('red');
 end if;
 return (TRUE);
end;



See also

Section 2.1.6, "About conditional formatting"

Section 4.9.1.5, "Applying conditional formatting to a layout object"






4.9.6.8 Highlighting a row

To highlight an entire row:

	
In the Paper Layout view, click the repeating frame that contains the fields that make up the rows to be highlighted.


	
Choose Format > Conditional Formatting.


	
In the Conditional Formatting dialog box, click New to display the Format Exception dialog box.


	
Select the field(s) and define the condition(s) that describe the rows to be highlighted.


	
In the Format group box, select the Fill Color to be used to highlight the row.



	
Note:

If you can't select the condition you want to use in the dialog box, select the formatting you want and a placeholder condition. The condition can be edited in the PL/SQL Editor for the format trigger that is created.








	
Click OK to close the Format Exception dialog box, then click OK again to close the Conditional Formatting dialog box. If the code compiles without errors, the new formatting is reflected in the Paper Layout view. The code is stored as a format trigger for the repeating frame.





Example

The following code determines the monthly compensation and changes the background color to red if the compensation has exceeded four thousand dollars a month and the employee is not a manager.


function R_G_EMPNOFormatTrigger return boolean is varcomm number;
begin
if :comm is null then
  varcomm := 0;
else
  varcomm := :comm;
end if;

if (:sal * 2 + varcomm > 4000) and :job != 'MANAGER' then
  srw.set_background_fill_color('red');
end if;
  return (TRUE);
end;



See also

Section 2.1.6, "About conditional formatting"

Section 4.9.1.5, "Applying conditional formatting to a layout object"






4.9.6.9 Alternating row colors

To alternate the colors of either the text or the fill of a row:

	
See Chapter 45, "Building a Report with an XML Pluggable Data Source". This chapter provides detailed steps for using PL/SQL procedures and format triggers to apply alternating row colors.











4.9.7 Format Masks

This section provides procedures for the following tasks that you may perform as you work with format masks:

	
Specifying date and time format masks


	
Specifying number format masks


	
Applying a format mask to a numeric object


	
Applying a format mask to a date object


	
Adding a custom format mask


	
Changing the format mask for multiple fields






4.9.7.1 Specifying date and time format masks

The following tables describe the date and time format masks, and the suffixes you can add to date format masks:


Table 4-2 Date and time format masks

	Format Mask	Description
	
SCC or CC

	
Century, abbreviated; 'S' prefixes "BC" with (-)


	
SYYYY or YYYY

	
Year; 'S' prefixes "BC" date with a (-)


	
I or IY or IYY

	
Last 1, 2, or 3 digit(s) of year


	
Y or YY or YYY

	
Last 1, 2, or 3 digit(s) of year


	
Y,YYY

	
Year with comma


	
SYEAR or YEAR

	
Year, spelled out; 'S' prefixes "BC" date with (-)


	
RRRR or SRRRR

	
Year; 'S' prefixes "BC" date with a (-)


	
RR

	
Last 2 digit(s) of year


	
BC, AD, or B.C., A.D.

	
Century indicator


	
Q

	
Quarter of year (Jan-Mar= Quarter 1)


	
MM

	
Month in digits (Jan = 01)


	
MONTH or MON

	
Name of month, or 3-letter abbreviation


	
WW, IW

	
Week in year


	
W

	
Week in Julian days


	
J

	
Julian day; the number of days since January 1,4712 BC


	
DDD, DD, or D

	
Day in year, month, or week


	
DAY

	
Day of week fully spelled out (for example, MONDAY)


	
DY

	
Name of day, 3-letter abbreviation (for example, MON)


	
AM, PM, or A.M., P.M.

	
Meridian indicator


	
HH or HH12

	
Hour of day (1-12)


	
HH24

	
Hour of day (0-23)


	
MI

	
Minute


	
SS; SSSSS

	
Second in minute; seconds in day


	
FM

	
Toggles fill mode which replaces multiple spaces before or between dates, numbers, or words with a single space








The following suffixes may be added to the format masks:


Table 4-3 Date format mask suffixes

	Suffix	Description
	
TH

	
Suffixed number ("DDth" for "4th")


	
SP

	
Spelled out number ("DDSP" for "FOUR")


	
SPTH or THSP

	
Spelled and suffixed number ("DDSPTH" for "FOURTH")









Examples


Table 4-4 Date format mask examples

	Sample Date Format	Date Displayed
	
MM/DD/RR

	
03/04/09


	
DD MON RRRR

	
04 MAR 2009


	
Mon. DD, RRRR

	
Mar. 4, 2009


	
Day Month DD fmHH:MI AM

	
Monday March 4 11:35 AM


	
Dy Mon ddth fmHH24:MI:SS

	
Mon Mar 4th 23:35:22


	
Day "the" ddthsp "of" Month

	
Monday the fourth of March












4.9.7.2 Specifying number format masks

The following table describes the tokens you can use in creating a number format mask:


Table 4-5 Tokens for number format masks

	Format Token	Description
	
0

	
Prints one digit.


	
N

	
Prints one digit, unless it is a leading zero to the left of the decimal point or a trailing zero to the right of the decimal point.


	
*


	
Prints one digit, unless it is a leading zero to the left of the decimal point, in which case an asterisk (*) is printed. Trailing zeros to the right of the decimal point are printed.


	
9

	
Prints one digit, unless it is a leading zero to the left of the decimal point, in which case a space is printed. Trailing zeros to the right of the decimal point are printed.


	
+


	
Prints a leading plus (+) for positive values and a leading minus (-) for negative values. This token must lead the mask.


	
-

	
Prints a leading minus (-) for negative values and nothing for positive values. This token must lead the other tokens.


	
MI

	
Prints a minus (-) after negative values and a space after positive values. This token must trail the other tokens.


	
S

	
Prints a minus (-) for negative values and a plus (+) for positive values (wherever the S appears in the mask). This token must lead or trail the other tokens.


	
PR

	
Prints angle brackets (<>) around negative values and spaces around positive values. This token must trail the other tokens.


	
( )

	
Prints parentheses around negative values and spaces around positive values. The parentheses must surround the other tokens.


	
DB

	
Prints a "DB" after positive values. This token must trail the other tokens.


	
CR

	
Prints a "CR" after negative values. This token must trail the other tokens.


	
Y

	
Causes no sign symbol to be printed for negative or positive values.


	
V

	
Causes the number to be multiplied by 10N, where N is the number of 0, 9, *, and S tokens that appear to the right of the V.


	
EEEE

	
Causes the number to be printed in scientific notation. All digit tokens refer to digits of the mantissa. There must be exactly one digit to the left of the decimal point (displayed or implicit). The token EEEE prints as E followed by a plus (+), if the ordinate is positive or zero, and a minus (-), if the ordinate is negative, and two digits representing the ordinate (for example, E-99).


	
"string"

	
Prints the string between the double quotes. To have double-quotes inside the string, type double-quotes back to back ("").


	
. (period)

	
Prints a period (.) to separate the integral and fractional parts of a number.


	
D

	
Prints the local decimal character to separate the integral and fractional parts of a number.


	
, (comma)

	
Prints a comma (,) as the group/thousands separator.


	
G

	
Prints the local group/thousands separator.


	
$


	
Prints $


	
L

	
Prints the local currency symbol.


	
C

	
Prints the ISO currency symbol.


	
%


	
Prints %.


	
" "

	
Prints a blank space. (Do not include quotes in mask.)


	
v

	
Prints a blank space for all zero values, regardless of other tokens.


	
K

	
Prints a blank space.


	
<>

	
Delineates the beginning and ending of the decimal-aligned region (that is, that part of the number that you want aligned with the decimal point in the format mask). Angle brackets indicate that the number should always occupy the same amount of space. If necessary, values are padded with blanks to the left or right of the decimal point.


	
RN, rn

	
Prints values in uppercase or lowercase Roman numerals, respectively. You cannot enter any other tokens with this token.









Restrictions

	
For number format masks, if the actual value is longer than the specified format mask, the value will appear as a string of asterisks in the report output, regardless of the field's width. For example, if a fixed field's width is 8, the value is 1234567, and the format mask is <NNNNNN>, your output will be *******.


	
Similarly, if the number format mask causes the value to be larger than the field width, asterisks will appear in place of the value. For example, if a fixed field's width is 6, the value is 1234, and the format mask is -99999999, your output will be ******. This occurs because the format token 9 prints a blank for leading zeros to the left of the decimal. As a result, the value is too long to be displayed in a field of width 6.


	
If you do not specify a sign token in the format mask, positive values are preceded by a space and negative values are preceded by a minus (-).


	
After you create a format mask it will display in the list of values only if it is an appropriate format mask for the Datatype of the Source. That is, format masks for numbers are displayed when the Source is a number, and format masks for dates are displayed when the Source is a date.


	
Format masks that print spaces for zeros (for example, 9) increase the number of bytes per page taken up by your output.





Examples


Table 4-6 Number format mask examples

	Sample Number Format	Number	Number Displayed
	
-0000

	
7934

	
"7934"


	
	
-7934

	
"-7934"


	
-00000

	
7934

	
"07934"


	
-NNNN

	
7639

	
"7639"


	
	
535

	
"535"


	
-NNN

	
7639

	
"****"


	
-****

	
7902

	
"7902"


	
-*****

	
7902

	
"*7902"


	
+NNNN

	
100

	
"+100"


	
	
-99

	
"-99"


	
(NNNN)

	
1600

	
" 1600 "


	
	
-800

	
"(800)"


	
NNNNPR

	
1600

	
" 1600 "


	
	
-800

	
"<800>"


	
NNNNMI

	
1600

	
"1600 "


	
	
-800

	
"800-"


	
NNNVNN

	
343

	
"34300"


	
N.NNEEEE

	
7369

	
"7.37E+03"


	
"SRW"-0000

	
7782

	
"SRW7782"


	
-$NNNN.NN

	
800

	
"$800"


	
	
1600

	
"$1600"


	
-%NNN

	
10

	
"%10"


	
-NN NNN.NN

	
3000

	
"3 000"


	
+KKNNNNN.00

	
1950

	
"+ 1950.00"


	
	
900

	
"+ 900.00"


	
$<NNNNN.00>

	
1200

	
"$1200.00"


	
	
500

	
"$500.00"


	
$<NNNNN.00> DB

	
1200

	
"$1200.00 DB"


	
	
-500

	
"$500.00"


	
$<NNNNN.00> CR

	
1200

	
"$1200.00"


	
	
-500

	
"$500.00 CR"








* The quotation marks will not appear in your output. They are used here to make it clear where there are leading or trailing spaces.






4.9.7.3 Applying a format mask to a numeric object

	
To apply a format mask to a numeric object:


	
In the Paper Design view, click the object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
To apply the currency format to the object, click the Currency button in the toolbar.


	
To apply the percentage format to the object, click the Percentage button in the toolbar.


	
To add commas to the value of the object, click the Commas button in the toolbar. To move the comma right or left, click the Remove Decimal Place button or the Add Decimal Place button.


	
Choose Tools > Property Inspector.


	
Under the Field node, verify the Format Mask property is set to the desired format.


	
Set other properties as desired.









4.9.7.4 Applying a format mask to a date object

To apply a format mask to a date object:

	
In the Paper Design view, click the object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Choose Tools > Property Inspector.


	
Under the Field node, set the Format Mask property to the desired date format.


	
Set other properties as desired.









4.9.7.5 Adding a custom format mask

To add a custom format mask to the default format masks list:

	
Choose Edit > Preferences.


	
In the Preferences dialog box, click Edit Masks.


	
In the Format Masks dialog box, set Display to the type of format mask you want to add.


	
In the Mask field, type the format mask to add, then click Add.


	
Click OK.

Now, you will see your new custom format masks in the list of values for the Format Mask property for fields and the Input Mask property for parameters.









4.9.7.6 Changing the format mask for multiple fields

To change the format mask for multiple fields at one time:

	
In the Paper Layout view, click the fields you want to change.


	
Choose Tools > Property Inspector.


	
In the Property Inspector, set the Format Mask property to a new format mask.











4.9.8 Graphic or Image Objects

This section provides procedures for the following tasks that you may perform as you work with graphic or image objects:

	
Adding an image


	
Adding a graph


	
Editing a graph


	
Adding a graph hyperlink


	
Creating a drawing object






4.9.8.1 Adding an image

To add an image to your report, perform the steps in any of the topics listed below.

For paper-based reports and JSP-based Web reports:

	
Section 4.8.5, "Selecting an image from the database"


	
Section 4.8.6, "Selecting an image URL from the database"




For paper-based reports only:

	
Importing an image


	
Linking an image object to a file


	
Linking an image object to a URL





See also

Section 2.4.3, "About images"



4.9.8.1.1 Importing an image




	
Note:

This procedure applies to paper-based reports. For JSP-based Web reports, see the Usage notes, below.

These steps allow you to include images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD. For images in other formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM, see Section 4.9.8.1.2, "Linking an image object to a file" or Section 4.8.5, "Selecting an image from the database".









To import an image:

	
In the Paper Layout view, choose Insert > Image and click the type of object you want to import.


	
In the dialog box, specify the name and format of the file. Click OK.


	
Move the object to the desired position.





Usage notes

This procedure is for paper-based reports only. If you want to include static images in your JSP-based Web reports, you can add HTML <img> tags in the Web Source view.






4.9.8.1.2 Linking an image object to a file




	
Notes:

This procedure applies to paper-based reports. File link objects are not implemented in JSP-based Web reports.

These steps, and the steps in Section 4.8.5, "Selecting an image from the database", allow you to include images in a wide variety of formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM. For paper-based reports, you can also use Insert > Image to import an image from a file into the report layout for images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD (see Section 4.9.8.1.1, "Importing an image", above).









To link an image object to a file:

	
In the Paper Design view or Paper Layout view, click the File Link tool in the tool palette.


	
Click and drag a rectangle.


	
Double-click the file link object to display the Property Inspector.


	
Under the File Link Boilerplate node:

	
Set the Source File Format property to Image.


	
Set the Source Filename property to the name of the file containing the image.












4.9.8.1.3 Linking an image object to a URL




	
Notes:

This procedure applies to paper-based reports output to an HTML or HTMLCSS file. This is unrelated to HTML that might be generated when you run a JSP-based Web report (when you click the Run Web Layout button in the toolbar, or choose Program > Run Web Layout). Additionally, file link objects are not implemented in JSP-based Web reports.

These steps, and the steps in Section 4.8.6, "Selecting an image URL from the database", allow you to include images in a wide variety of formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM. For paper-based reports, you can also use Insert > Image to import an image from a file into the report layout for images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD (see Section 4.9.8.1.1, "Importing an image", above).









To link an image object to a URL that points to an image to include in an HTML report:

	
In the Paper Design view or Paper Layout view, click the File Link tool in the tool palette.


	
Click and drag a rectangle.


	
Double-click the file link object to display the Property Inspector.


	
Under the File Link Boilerplate node:

	
Set the Source File Format property to Image URL.


	
Set the Source Filename property to the URL where the image is located with the required protocol.








Example 1: Image URL


HTTP://www.oracle.com/images/logo.gif



Example 2: Image URL containing user parameter


HTTP://&<P_SERVER_NAME>/images/logo.gif 


where P_SERVER_NAME is a user parameter of type CHAR.

At runtime, the end user can specify a value for the parameter (for example, 

P_SERVER_NAME=www.oracle.us.com for a dynamic URL link of http://www.oracle.us.com/images/logo.gif).


Example 3: URL to a file


FILE://c:/images/logo.gif





	
Note:

If you click Browse to find a file, Oracle Reports automatically prepends FILE:// to the returned path.
















4.9.8.2 Adding a graph

To add a graph to your report, follow the steps in either of the following topics:

	
Adding a graph to a paper-based report


	
Adding a graph to a JSP-based Web report





Usage notes

Inserting a graph with a once-per-group position in the Paper Design view of a matrix with group report causes Oracle Reports Builder to fail. As a workaround, insert the graph in the Paper Layout view, rather than the Paper Design view, when adding a graph to a matrix with group report.


See also

Section 1.6.6, "About the Web Source view"

Chapter 39, "Building a Report with Graphs"



4.9.8.2.1 Adding a graph to a paper-based report

To add a graph to your paper-based report:

	
In the Paper Layout view, click the Graph tool in the tool palette.


	
Drag a square in the area where the graph should appear to display the Graph Wizard.


	
In the Graph Wizard, specify information for the graph. Click Help on any wizard page for assistance.



	
Note:

When you specify a graph title, subtitle, footnote, or axis title in the Graph Wizard, you can insert lexical references (to user parameters, system parameters, and columns) in the text. For example, in the Show Title field on the Title page of the Graph Wizard, type: titletext &<P_1> to insert the value of the user parameter P_1 into the title text at runtime. The angle brackets (<>) are required around the parameter or column name.








	
Double-click the graph object you have created to display the Property Inspector, and set properties as desired.

To customize your graph XML definition beyond the scope of the Graph Wizard, you can directly edit the XML in the graph's Graph Settings property. The full list of attributes available is defined in the DTD file, graph.dtd.



	
Note:

The graph.dtd is available in the following locations:

	
ORACLE_HOME\jlib\bigraphbean.jar


	
In Getting Started with Oracle Reports on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.htm), navigate to the Learn More tab and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Documentation and click Search. In the list that displays, find the Documented Graph DTD.











	
To re-enter the Graph Wizard, do either of the following:

	
Right-click the graph, and choose Graph Wizard.


	
Click the graph, then choose Edit > Settings.












4.9.8.2.2 Adding a graph to a JSP-based Web report

To add a graph to a JSP-based Web report:

	
In the Object Navigator, double-click the view icon next to the Web Source node to display the source code in the Web Source view.


	
Locate the section in the source code where you want to add the graph.



	
Note:

Previously adding some text such as "Place the graph here" to your Web page enables you to easily locate the correct position for your graph.








	
Choose Insert > Graph.


	
In the Graph Wizard, specify the information for the graph. Click Help on any tab page for assistance.



	
Note:

When you specify a graph title, subtitle, footnote, or axis title in the Graph Wizard, you can insert lexical references (to user parameters, system parameters, and columns) in the text. For example, in the Show Title field on the Title page of the Graph Wizard, type titletext &<P_1> to insert the value of the user parameter P_1 into the title text at runtime. The angle brackets (<>) are required around the parameter or column name.








	
Click the Run Web Layout button in the toolbar (or choose Program > Run Web Layout) to display your report and graph in your Web browser.




	
Note:

If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.










	
To re-enter the Graph Wizard, place your cursor anywhere between the <rw:graph> and </rw:graph> tags in the Web Source view, then choose Edit > Settings.

To customize your graph XML definition beyond the scope of the Graph Wizard, you can directly edit the XML in the Web Source view. The full list of attributes available is defined in the DTD file, graph.dtd.






	
Note:

The graph.dtd is available in the following locations:

	
ORACLE_HOME\jlib\bigraphbean.jar


	
In Getting Started with Oracle Reports on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Documentation and click Search. In the list that displays, find the Documented Graph DTD.

















4.9.8.3 Editing a graph

To add a graph to your report, follow the steps in either of the following topics:

	
Editing a graph in a paper-based report


	
Editing a graph in a JSP-based Web report





See also

Section 1.4.4, "About Graphs and the Graph Wizard"

Section 1.6.6, "About the Web Source view"



4.9.8.3.1 Editing a graph in a paper-based report

To edit a graph in a paper-based report:

	
In the Paper Layout view, click the graph.



	
Note:

The graph is represented as a bar graph even if the graph is of another type.








	
To edit the XML definition of the graph:

	
Right-click the graph, and choose Property Inspector.


	
In the Property Inspector, under the Graph node, click the Graph Settings property value field to display the Graph Settings dialog box. To customize your graph XML definition beyond the scope of the Graph Wizard, specify additional rw:graph tag attributes. The full list of attributes available is defined in the DTD file, graph.dtd.



	
Note:

The graph.dtd is available in the following locations:

	
ORACLE_HOME\jlib\bigraphbean.jar


	
In Getting Started with Oracle Reports on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Documentation and click Search. In the list that displays, find the Documented Graph DTD.














	
To re-enter the Graph Wizard to redefine the graph, do either of the following:

	
Right-click the graph, and choose Graph Wizard.


	
Click the graph, then choose Edit > Settings.












4.9.8.3.2 Editing a graph in a JSP-based Web report

To edit a graph in a JSP-based Web report, do any of the following in the Web Source view:

	
Place your cursor anywhere between the <rw:graph> and </rw:graph> tags, then choose Edit > Settings to re-enter the Graph Wizard.



	
Note:

Any manual changes and additions you've made to the graph XML will be lost if you click Finish, which redefaults the graph to the definition in the Graph Wizard.








	
Delete and re-create the graph as follows:

	
Delete all lines from the <rw:graph> tag to the </rw:graph> tag.


	
Leaving the cursor in the position where the graph was cut, choose Insert > Graph and follow the Graph Wizard to re-create the graph.





	
Between the <rw:graph> and </rw:graph> tags that define the graph, make changes directly to the JSP and XML tags. This enables you to customize your graph XML definition beyond the scope of the Graph Wizard. The full list of attributes available is defined in the DTD file, graph.dtd.






	
Note:

The graph.dtd is available in the following locations:

	
ORACLE_HOME\jlib\bigraphbean.jar


	
In Getting Started with Oracle Reports on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Documentation and click Search. In the list that displays, find the Documented Graph DTD.

















4.9.8.4 Adding a graph hyperlink

You can add a graph hyperlink to a graph in your paper-based Web report (output to PDF or HTML), or JSP-based Web report. When end users display the report on the Web, they can click the areas of the graph to drill down to additional linked information.

To add a graph hyperlink to a graph, follow the steps in either of the following topics:

	
Adding a graph hyperlink to a paper-based report


	
Adding a graph hyperlink to a JSP-based Web report





See also

Section 2.2.6, "About graph hyperlinks"

Section 1.4.4, "About Graphs and the Graph Wizard"

Section 1.6.6, "About the Web Source view"



4.9.8.4.1 Adding a graph hyperlink to a paper-based report

For a paper-based Web report (for HTML or PDF output), you can add a graph hyperlink to a graph in either of the following ways:

	
Property Inspector


	
Graph Wizard




To specify a graph hyperlink in a paper-based report using the Property Inspector:

	
In the Paper Layout view, display the Property Inspector for the graph.


	
Set the Graph Hyperlink property to a hyperlink from any graph section to any object in your report output, another report, or any valid hyperlink destination.

Examples:

	
A hyperlink from any graph section to any object in your report:

#&<dept_id>


	
A hyperlink to another report:

http://my_machine:8888/reports/myWebApp/Dept_Detail.jsp? p_deptid=&<deptid>+...


	
A hyperlink to any valid hyperlink destination:

www.oracle.com







To specify a graph hyperlink in a paper-based report using the Graph Wizard:

	
On the Define Hyperlink panel, use the examples shown on the panel to enter a hyperlink value to link areas of the graph to specified destinations.


	
Click Finish.




After you have defined the graph hyperlink, generate your report to HTML, HTMLCSS, or PDF to test the graph hyperlinks. Refer to Section 4.7.5, "Generating HTML or HTMLCSS output" and Section 4.7.6, "Generating PDF output".






4.9.8.4.2 Adding a graph hyperlink to a JSP-based Web report

To add a graph hyperlink to a graph in a JSP-based Web report:

	
In the Web Source view of your report, modify the <rw:graph> JSP tag to include the graphHyperlink attribute.

For example:

graphHyperlink="http://my_machine:8888/reports/myWebApp/Dept_Detail.jsp? userid=hr/hr@mydb+server=myserver+p_deptno=&<deptno>"




After you have defined the graph hyperlink, click the Run Web Layout button in the toolbar (or choose Program > Run Web Layout) to display your report and graph in your Web browser, and click the graph hyperlinks to test them.








4.9.8.5 Creating a drawing object

To create a drawing object:

	
In the Paper Layout view, click a drawing tool in the tool palette (for example, Rectangle, Ellipse, Polyline, and so on).


	
To create a line, rounded rectangle, rectangle, ellipse, arc, or freehand object, click in the main area (canvas region) of the window and drag to create the object.


	
To create a polygon or polyline, click in the main area (canvas region) of the window where you want each point of the object, then double-click to create the object.


	
To draw constrained objects (that is, perfect circles and squares, and so on), hold down the constrain key (for example, the shift key) when drawing the graphic.


	
Double-click the drawing object.


	
In the Property Inspector, set the desired properties.











4.9.9 Page or Group Headers or Footers

This section provides procedures for the following tasks that you may perform as you work with page or group headers or footers:

	
Creating a text heading


	
Creating a heading that includes database values


	
Creating a group header or footer






4.9.9.1 Creating a text heading

To create an object or heading in the margin of a report:

	
In the Paper Layout view, click the Edit Margin button in the toolbar.



	
Note:

The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.








	
To adjust the margin, click the margin border, then drag a handle to the desired position. You can adjust the margin on all four sides of a report.


	
Create required objects in the margin area. They will appear on all pages of the report.


	
Click the Header Section, Main Section, or the Trailer Section buttons in the toolbar to reactivate the appropriate section of the body area of the report.









4.9.9.2 Creating a heading that includes database values

To create a heading that includes database values:

	
Choose Tools > Report Wizard to re-enter the Report Wizard for the current report.


	
On the Totals page, create any totals that you want to include in the heading.



	
Note:

Any totals that you intend to place in the margin area of your report must be report-level totals. Group totals (for example, the total for a department) placed in the margin will cause a frequency error when you run your report.








	
On the Fields page, verify that the fields and totals you want to include in the heading are either available or displayed in the report.


	
In the Paper Layout view, click the Margin button in the toolbar.



	
Note:

The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.








	
For any values that require a format mask, create a hidden field object in the margin area (see Section 4.9.1.1, "Creating a field object"):

	
In the Property Inspector, under the Field node, set the Source property to the source column for the value, set the Visible property to No, and set the Format Mask property as desired.


	
Under the General Layout node, set the Horizontal Elasticity property to Variable.



	
Note:

If you do not need to specify a format mask, you can simply reference the value directly in Step 6, and you do not need to create this hidden field.











	
Create a boilerplate text object in the margin area, and reference the field or report-level totals you want to include in the heading. See Section 4.9.2.1, "Creating a boilerplate object for text" and Section 4.9.2.5, "Referencing a field in boilerplate text".





See also

The example report in Chapter 17, "Building a Header with Database Values Report".






4.9.9.3 Creating a group header or footer

To create a header or footer above or below each group of records:

	
In the Paper Layout view, click the Confine Off button and the Flex On button in the toolbar.


	
Click frame that encloses the repeating frame for the group to which you want to add a header or footer, then drag and resize the frame to allow enough room to type the header or footer text.



	
Tip:

In the Object Navigator, under the Paper Layout node, expand the Body node to select the frame by name.








	
Create a boilerplate text object for the header or footer text (see Section 4.9.2.1, "Creating a boilerplate object for text").











4.9.10 Margin, Header Page, or Trailer Page Objects

This section provides procedures for the following tasks that you may perform as you work with margin, header page, or trailer page objects:

	
Creating a margin object


	
Creating a header page or trailer page object






4.9.10.1 Creating a margin object

To create an object or heading in the margin of a report:

	
In the Paper Layout view, click the Edit Margin button in the toolbar.



	
Note:

The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.








	
To adjust the margin, click the margin border, then drag a handle to the desired position. You can adjust the margin on all four sides of a report.


	
Create required objects in the margin area. They will appear on all pages of the report.


	
Click the Header Section, Main Section, or the Trailer Section buttons in the toolbar to reactivate the appropriate section of the body area of the report.









4.9.10.2 Creating a header page or trailer page object

With report sectioning, Header and Trailer pages are identical to Body pages. In effect, this means that the Header, Trailer, and Body are three sections of a report. The names of the sections are exposed under the Paper Design node in the Object Navigator as Header Section, Main Section, and Trailer Section. You can use the margin and body of the Header and Trailer sections to create a Header and Trailer "page" as in earlier releases of Oracle Reports.

	
In the Paper Layout view, click the Confine Off button and the Flex On button in the toolbar.


	
Click the repeating frame for the page, then drag and resize the frame to allow enough room to type the header or footer text.



	
Tip:

In the Object Navigator, under the Paper Layout node, expand the Body node to select the repeating frame by name.








	
Create a boilerplate text object for the header or footer text.











4.9.11 Move Objects

This section provides procedures for the following tasks that you may perform as you move your report objects:

	
Moving multiple objects


	
Moving an object outside its parent


	
Adjusting parent borders automatically


	
Moving a column in report output


	
Offsetting detail objects in a group report


	
Aligning objects


	
Changing object layering


	
Rotating a boilerplate object






4.9.11.1 Moving multiple objects

To move multiple objects:

	
Click or drag a box around the objects you want to move.



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Use the arrow keys on your keyboard to move the objects in the desired direction.





See also

Section 2.4.7, "About moving and layering objects in the Paper Layout view"






4.9.11.2 Moving an object outside its parent

To move a child object outside its enclosing parent object:

	
In the Paper Layout view or Paper Design view, click the Confine Off button in the toolbar.


	
Click and drag the child object(s) as desired.



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.











See also

Section 2.4.7, "About moving and layering objects in the Paper Layout view"






4.9.11.3 Adjusting parent borders automatically

To adjust parent borders as you move child objects:

	
In the Paper Layout view, click the Flex On button in the toolbar.


	
Click and drag the child object(s) as desired.



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
To move an object that aligns with another object in the horizontal or vertical direction (for example, a field and its label), hold down the Ctrl key as you drag the first object. To move both objects simultaneously, do not use the Ctrl key.





See also

Section 2.4.6, "About resizing objects"






4.9.11.4 Moving a column in report output

To move a column in report output:

	
In the Paper Layout view or Paper Design view, click the column.


	
Click the Flex On button in the toolbar


	
Drag the column to the desired position.





See also

Section 2.4.7, "About moving and layering objects in the Paper Layout view"

Chapter 4, "Changing columns labels or widths"

Chapter 4, "Changing the default layout spacing"






4.9.11.5 Offsetting detail objects in a group report

To offset the detail fields in a group above or group left report:

	
In the Paper Design view, click the Flex On button in the toolbar.


	
Select the detail objects and move them to the right.


	
Click the Flex Off button in the toolbar.





See also

Section 1.3.2, "About group above reports"

Section 1.3.3, "About group left reports"






4.9.11.6 Aligning objects

To align objects:

	
Click the objects you want to align.



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Choose Layout > Alignment.


	
In the Align Objects dialog box, specify the desired alignment.


	
Click OK.





See also

Section 2.4.7, "About moving and layering objects in the Paper Layout view"






4.9.11.7 Changing object layering

To change the order in which objects are layered on top of each other:

	
In the Paper Layout view, click the Confine Off button in the toolbar.


	
Click the object you want to move.


	
Choose one of the following items from the Arrange menu:

	
Bring to Front to move the object in front of all other objects.


	
Send to Back to move the object behind all other objects.


	
Move Forward to move the object in front of the object directly on top of it.


	
Move Backward to move the object behind the object directly underneath it.








See also

Section 2.4.7, "About moving and layering objects in the Paper Layout view"






4.9.11.8 Rotating a boilerplate object

You can only rotate boilerplate text and graphics. You cannot rotate other layout objects (repeating frames or fields).

To rotate a boilerplate object:

	
Click the object(s) that you want to rotate.



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Click the Rotate tool in the tool palette.


	
Drag a handle to rotate the object or group.





See also

Section 1.8.5, "About boilerplate objects"








4.9.12 Resize Objects

This section provides procedures for the following tasks that you may perform as you resize your report objects:

	
Resizing objects


	
Making multiple objects the same size


	
Resizing object borders






4.9.12.1 Resizing objects

To resize one or more objects:

	
Click the object(s) that you want to resize.



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Set the size:

	
For a fixed size, drag the handle of one of the selected objects. All selected objects will change size accordingly.


	
Or, choose Tools > Property Inspector. In the Property Inspector, under the General Layout node, set the Vertical Elasticity and Horizontal Elasticity properties to Contract, Expand, Fixed, or Variable.








See also

Section 2.4.6, "About resizing objects"

Section 1.8.3, "About frame and repeating frame sizing"






4.9.12.2 Making multiple objects the same size

To make multiple objects the same size:

	
Click the objects you want to size.



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Choose Layout > Size Objects.


	
In the Size Objects dialog box, specify the desired settings. Click OK.









4.9.12.3 Resizing object borders

See Section 4.9.11.3, "Adjusting parent borders automatically".








4.9.13 Change Spacing

This section provides procedures for the following tasks that you may perform as you change spacing between your report objects:

	
Changing columns labels or widths


	
Changing spacing within a text object


	
Changing the default layout spacing


	
Changing the spacing between all rows


	
Adding blank lines between groups of rows






4.9.13.1 Changing columns labels or widths

To change column labels or widths:

	
Choose Tools > Report Wizard.


	
In the Report Wizard, click the Labels tab.


	
Change the values in the Labels and Width columns, as desired.


	
Click Apply.





See also

Chapter 4, "Moving a column in report output"






4.9.13.2 Changing spacing within a text object

To change spacing within a text object:

	
In the Paper Design view, click the object(s).



	
Tip:

To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.








	
Choose Format > Text Spacing and select the desired spacing for the text object.









4.9.13.3 Changing the default layout spacing

To change the default layout spacing used by the Report Wizard when defaulting the report layout:

	
Choose Tools > Preferences.


	
In the Preferences dialog box, click the Wizards tab.


	
To increase the space between objects and the objects they enclose, type larger values for Horizontal Gap and Vertical Gap.


	
To increase the space between fields, type larger values in Horizontal Interfield and Vertical Interfield.


	
Click OK to close the Preferences dialog box.


	
For smaller spacings, choose View > Snap to Grid to toggle this setting off (no checkmark). When Snap to Grid is set on, defaulting the layout honors the layout spacing values, but then snaps to the closest grid point; the result may be that smaller changes to these values are not evident in the report output.





See also

Chapter 4, "Moving a column in report output"






4.9.13.4 Changing the spacing between all rows

To change the spacing between all rows using the Paper Design view:

	
In the Paper Design view, click the second record.


	
Drag the second record down to create the desired spacing between all rows in the report output.




To change the spacing between all rows using the Property Inspector:

	
In the Paper Design view, click any field in the body of the report.


	
Click the Select Parent Frame button in the toolbar.


	
Choose Tools > Property Inspector.


	
Under the Repeating Frame node, set the Vert. Space Between Frames (inches) property to the amount of blank space in inches to leave between row in the report output (for example, 0.25).









4.9.13.5 Adding blank lines between groups of rows

To add blank lines between groups of rows:

	
Create a summary column (see Section 4.8.11, "Creating a summary column"). On the Totals page of the Data Wizard (or Report Wizard), select any field that appears in each row of output, and Count as the calculation. On the Fields page, remove the summary from the displayed fields column.


	
Create a user parameter named SPACE (see Section 4.11.2, "Creating a user parameter"). In the Property Inspector, under the Parameter node, set the Datatype property to Number and the Initial Value property to the number of records you want in each group (for example, 5).


	
In the Paper Layout view, click the Flex On and Confine Off buttons in the toolbar.


	
Click the repeating frame for the group, then drag the handle on the bottom of the frame to create a space slightly larger than the space you want to add between groups of rows in the report output.


	
Choose Tools > Property Inspector to display the Property Inspector for the repeating frame.


	
Under the General Layout node, set the Vertical Elasticity property to Variable.


	
Click the Rectangle tool in the tool palette.


	
Draw a rectangle in the space under the record.


	
Double-click the rectangle object.


	
In the Property Inspector, under the Advanced Layout node, double-click the Format Trigger property value to display the PL/SQL Editor.


	
In the PL/SQL Editor, define the PL/SQL for the format trigger. For example, the following PL/SQL code inserts blank space between groups of rows (displays a boilerplate rectangle when the row count divided by the value of SPACE leaves no remainder):


function spacing return BOOLEAN is
begin
  if :CountENAMEPerReport MOD :SPACE = 0 then
    return (true);
  else 
    return (false);
  end if;
end;


	
Hide the rectangle object:

	
On the Fill Color palette, click No Fill.


	
On the Line Color palette, click No Line.














4.9.14 Modify the Page Layout

This section provides procedures for the following tasks that you may perform as you modify the page layout of your report:

	
Adjusting margins


	
Adding a page break






4.9.14.1 Adjusting margins

To adjust margins:

	
In the Paper Layout view, click the Edit Margin button in the toolbar.



	
Note:

The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.








	
Click the margin border, then drag a handle to the desired position. You can adjust the margin on all four sides of a report.









4.9.14.2 Adding a page break

To add a page break:

	
In the Paper Layout view, click any field that is part of the frame at which you want to insert a page break.


	
Click the Parent Frame in the toolbar.


	
Choose Tools > Property Inspector.


	
To set a page break...

	
before the selected frame: under the General Layout node, set the Page Break Before property to Yes.


	
after the selected frame: under the General Layout node, set the Page Break After property to Yes.


	
after a certain number of rows of output on each page: under the Repeating Frame node, set the Maximum Records per Page property to the number of rows you want to display on each page.





	
To display icons that identify where page breaks are set, choose View > Page Breaks in the Paper Layout view.





Usage notes

If you want to set a page break at a specific row of report output, you can create a hidden object (for example, a rectangle with No Fill and No Line) that formats only at the specific row. If you set the Page Break Before property to Yes for the rectangle object, you will get a page break after the row.










39.3 New Graph Types

Oracle Reports 11g Release 2 (11.1.2) supports the following and graph types:

	
Funnel Graph


	
Curved Line or Fit To Curve Graph


	
Enhanced Pie






39.3.1 Funnel Graph

A funnel graph is a visual representation of data related to steps in a process. As the value for a given step of the funnel approaches the quota for that slice, the slice fills. A funnel renders a three-dimensional chart that represents the target and actual values, and levels by color. For more information, see Figure 39-3, "Funnel Graph".


Figure 39-3 Funnel Graph

[image: Description of Figure 39-3 follows]










39.3.2 Curved Line or Fit To Curve Graph

A curved line or fit-to-curve is a graph in which data is represented as a curved line, as a series of data points, or as data points that are connected by a line. Curved line graphs require data for at least two points for each member in a group. For more information, see Figure 39-4, "Curved LIne Graph".


Figure 39-4 Curved LIne Graph

[image: Description of Figure 39-4 follows]










39.3.3 Enhanced Pie

A pie graph represents data as sections of one or more circles, making the circles look like sliced pies. With the enhanced pie, you can include any combination of data value, percent, and text label.








1.8 Layout Objects

The topics in this section discuss basic concepts of layout objects; for more advanced concepts, see Section 2.4, "Layout Objects".

	
About frames


	
About repeating frames


	
About frame and repeating frame sizing


	
About fields


	
About boilerplate objects






1.8.1 About frames

Frames surround other objects and protect them from being overwritten or pushed by other objects. For example, a frame might be used to surround all objects owned by a group, to surround column headings, or to surround summaries.

When you default the layout for a report, Oracle Reports Builder creates frames around report objects as needed; you can also create a frame manually in the Paper Layout view. See Section 1.6.3, "About the Paper Layout view".

Create frames when you want to:

	
group together objects to ensure they maintain their relative positions during printing.


	
delineate sections in your report.

Example: You want the top of each page to have a tabular format, but the bottom of each page to have a matrix format.


	
protect other objects from being overwritten.

Example: A summary is centered under two repeating frames. Defaulting rules state that the summary must remain at a fixed distance from only the first object that can overwrite it; therefore, the summary is in danger of being overwritten by the second repeating frame. Enclosing both repeating frames with a frame will force the summary to maintain a fixed distance from both of them, and it will not be overwritten.


	
prevent an object from printing until other objects finish printing.

Example: A summary is centered under two repeating frames. According to defaulting rules, the summary will print as soon as the first repeating frame finishes printing. Create a frame around the two repeating frames to ensure the summary prints after both repeating frames have finished printing.





See also

Section 4.9.1.2, "Creating a frame or repeating frame"






1.8.2 About repeating frames

Repeating frames surround all of the fields that are created for a group's columns. The repeating frame prints (is fired) once for each record of the group.

When you default the layout for a report, Oracle Reports Builder generates one repeating frame for each group in the data model, and places one field inside it for each of the group's columns. Repeating frames can enclose any layout object, including other repeating frames. Nested repeating frames are typically used to produce master/detail and break reports. For each record of the outer repeating frame, Oracle Reports Builder will format all related records of the enclosed repeating frame.

You can also create a repeating frame manually in the Paper Layout view. See Section 1.6.3, "About the Paper Layout view".


See also

Section 4.9.1.2, "Creating a frame or repeating frame"






1.8.3 About frame and repeating frame sizing

For each object or record, a frame or repeating frame's size can be expandable, contractible, variable, or fixed (specified by the Horizontal Elasticity and Vertical Elasticity properties). For example, you can set the properties to specify that it should be fixed in size horizontally, but expand vertically if a record requires more space.

In the figure below, notice that there are four records for department 20, but only one record each for departments 10 and 30. The repeating frame has expanded vertically to accommodate department 20's additional records.


Figure 1-14 Repeating frame sizing

[image: figure illustrating above description]






Frames or repeating frames that contract horizontally or vertically reduce in size when an object or record requires less space than the frame or repeating frame's initial size. A frame or repeating frame may also be variable in size: it expands or contracts based on the size of the value it displays. Also, if a frame or repeating frame is fixed in size and an object or record's data requires a larger field than it can contain, the remaining data will be pushed onto the following page(s) in the same x and y coordinates.


See also

Section 4.9.1.2, "Creating a frame or repeating frame"






1.8.4 About fields

Fields are placeholders for parameters, columns, and such values as the page number, current date, and so on. If a parameter or column does not have an associated field, its values will not appear in the report output. A field is owned by the object surrounding it, which is the first enclosing object (either a frame or repeating frame).

When you default the layout for a report, Oracle Reports Builder generates one field for each column, and places each field inside of a repeating frame. You can also create a field manually in the Paper Design view, Paper Layout view or Paper Parameter Form view.




	
Note:

If you create a field object in a template, the field is renamed when the template is applied to a report. For example, if you create a field named F_1, the field is renamed to F_1_SEC2 when the template is applied to a report. Thus, if you reference F_1 in boilerplate (&F_1), these references will need to be updated.










See also

Section 1.9.2, "About Parameter Form fields"

Section 4.9.1.1, "Creating a field object"

Section 4.9.2.5, "Referencing a field in boilerplate text"






1.8.5 About boilerplate objects

A boilerplate object is any text, lines, or graphics that appear in a report every time it is run.

Oracle Reports Builder creates one boilerplate object for each label selected in the Report Wizard (it is named B_columnname). For example, if a column is named ENAME, a boilerplate object containing ENAME is generated for the column. For some report types, Oracle Reports Builder also generates lines under the labels.

You can also create a boilerplate objects manually in the Paper Design view, Paper Layout view, or Paper Parameter Form view using any of the following tools in the tool palette:

	
Arc tool


	
Ellipse tool


	
File Link


	
Freehand tool


	
Line tool


	
Polygon tool


	
Polyline tool


	
Rectangle tool


	
Rounded Rectangle tool


	
Text tool





Boilerplate from files

If you have text, graphics, or HTML in a file that you would like to display as boilerplate in your report, you can link to the file, as described in the following procedures:

	
Section 4.9.2.6, "Linking a boilerplate text object to a file"


	
Section 4.9.8.1.2, "Linking an image object to a file"


	
Section 4.9.2.7, "Linking an HTML text object to a file"




Linking to a file means that the contents of the file are pulled into the boilerplate object each time the report is run. In this way, you can ensure that your output includes the most recent changes to the file.

You can also link a boilerplate image object to a URL where the image is located. See Section 4.9.8.1.3, "Linking an image object to a URL".




	
Note:

These procedures are for paper-based reports only. File Link objects are not implemented in JSP-based Web reports.










See also

Section 1.9.3, "About Parameter Form boilerplate"

Section 4.9.2.1, "Creating a boilerplate object for text"

Section 4.9.2.2, "Creating a boilerplate object for text that displays every other page"

Section 4.9.2.5, "Referencing a field in boilerplate text"

Section 4.9.11.8, "Rotating a boilerplate object"








34.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Summit Sporting Goods (SUMMIT) schema. To download the SQL scripts that install the schema, see "Accessing the Data Sources" in the Preface.






11.5 Format a Field

In the Paper Design view, notice the Amount field. The values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.


To assign a format mask to monetary values:

	
In the Paper Design view, select the first number value underneath the Amount label. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.



	
Tip:

If you are familiar with format mask syntax, you could now right-click the field values, choose Property Inspector, and choose or manually enter a value for the Format Mask property.








	
Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.


	
Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.


	
Resize the field by clicking and dragging the rightmost handle of the field approximately a 0.5 inches (1.5 centimeters) to the left.


	
Click the Align Right button. All of the values are immediately right aligned.


	
Select the Amount label.


	
Click the Align Right button.


	
Save the report as grp_above_your_initials.rdf.




The final report output should look something like this:


Figure 11-6 Group above report output with monetary values formatted

[image: Description of Figure 11-6 follows]










42.5 Deploy the JSP Parameter Form and the Target Report


To deploy the JSP Parameter Form and the target JSP-based Web report, you must copy paramform_your_initials.jsp and emprev_final_your_initials.jsp to the deployment directory of your Application Server. Once you have placed the target report in the desired directory, you can then modify the Parameter Form to point to the report location.

For more information on deploying a JSP-based Web report, refer to the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.


To set up and deploy the JSP Parameter Form and the target report:

	
Copy the JSP Parameter Form and the Web report (paramform_your_initials.jsp and emprev_param_your_initials.jsp) into the following directory:


$DOMAIN_HOME\servers\WLS_REPORTS\tmp\_WL_user\reports_11.1.2.0\dir_name\war




	
Note:

dir_name is a randomly generated directory name for each deployment instance.








	
In Reports Builder, open the file:


$DOMAIN_HOME\servers\WLS_REPORTS\tmp\_WL_user\reports_11.1.2.0\dir_name\war\paraform_your_initials.jsp


	
In the Web Source view, modify the action for the form so that when the user clicks Run Report, the emprev_param_your_initials.jsp report executes based on the selected parameters. The code should look like this:


<form name="form1" method="post" action="/reports/rwservlet">
    <input type="hidden" name="report" value="reportname.rdf">
    <input type="hidden" name="destype" value="destype">
    <input type="hidden" name="desformat" value="desformat">
    <input type="hidden" name="userid" value="db_connect_string">
    <input type="submit" name="Submit" value="Submit">
</form>




	
Notes:

	
In the above code, the action attribute assumes that the report is located in the directory we specified in the above steps.


	
The Parameter Form developed in this chapter can also be used to execute a paper report instead of a Web report. To do this, use the following code:


<form name="form1" method="post"
action="/reports/rwservlet?report=report
_name.jsp&destype=destype&desformat=desformat">


	
For more information on deploying JSP-based Web reports and paper reports, refer to the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.











	
Save your report.


	
Start your Oracle WebLogic Server instance.

	
On Windows, Go to the following directory

	

ORACLE_HOME\Middleware_HOME\user_projects\domains\<your_domain>


Double-click startWebLogic.cmd




Where, "<your_domain>" is the domain created by you.


	
On UNIX, start the shell script:


 ORACLE_HOME/Middleware_HOME/user_projects/domains/<your_domain>/startWebLogic.sh




Where, "<your_domain>" is the domain created by you.




	
Tip:

The Oracle WebLogic Server instance starts once the containers for Java EE have been initialized.










	
In a Web browser, type the URL for the Parameter Form:


http://computer name:port/reports/paramform_your_initials.jsp?userid=userid/password@database name


In our example, we would use:


http://mycomputer-pc:8888/reports/paramform_your_initials.jsp?userid=hr/hr@orcl





	
Note:

The connect string you type in the URL is for the database you used to create the data model in Section 42.3.1, "Create a data model manually for the Parameter Form". For the purposes of this example, we have used plain text to pass the connect string. You can find more information about security in the chapter "Securing Oracle Reports Services" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.










	
If the Single Sign-On login page displays, enter your Single Sign-On user name and password. For more information about OracleAS Single Sign-On, see the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.


	
When the Parameter Form displays, choose a department from the list. For example, choose Finance.


	
In the Login ID field, type the connect string for the database schema that the emprev_param_your_initials.jsp report uses. For example, hr/hr@orcl:


Figure 42-6 JSP Parameter Form with selections

[image: Description of Figure 42-6 follows]






	
Click Run Report.


	
The employee salary report displays with a graph at the top, and should look like this:


Figure 42-7 Sample employee report based on user parameters

[image: Description of Figure 42-7 follows]









	
Note:

If you are not sure whether your report appears as it should, try using the files we have provided, paramform.jsp and emprev_param.jsp and follow all the steps in this section to deploy the Parameter Form and the Web report.

















21.5 Add a Format Trigger to Suppress Labels

The steps in this section will show you how to add a format trigger to your report that will prevent labels from being displayed for records will null values.


To create a format trigger:

	
In the Object Navigator, under the Paper Layout node, navigate to Main Section > Body > M_G_DEPTNO_GRPFR > R_G_DEPTNO > M_G_DEPTNO1_GRPFR > M_G_DEPTNO1_HDR. Or, use the Find field in the Object Navigator to find M_G_DEPTNO1_HDR.



	
Tip:

See the image below for an example of where the frame is located in your Object Navigator. When you select the frame name in the Object Navigator, the corresponding frame will be selected in the Paper Layout view, as well.









Figure 21-5 Navigating to M_G_DEPTNO1_HDR

[image: Description of Figure 21-5 follows]






	
Double-click the properties icon next to M_G_DEPTNO1_HDR to display the Property Inspector, and set the following properties:

	
Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function M_G_DEPTNO1_HDRFormatTrigger return boolean is
begin
  if :count_detail=0 then
     return (FALSE);
  else
     return (TRUE);
  end if;
end;


	
Click Compile.



	
Tip:

If you receive errors when compiling, compare your code against the code provided. You can also simply copy and paste the code from suppresslabels_code.txt.








	
When there are no compiling errors, click Close.


	
Save your report as suppresslabels_your_initials.rdf.









35.3 Create an Index

In this section, you will create an index that displays at the end of your report. This index will simply display the customer's name and the page number on which the name appears. This indexing technique is useful when users want to find a specific customer's name, but are not sure what category (for example, country) to reference.


Figure 35-10 Sample index for the paper report

[image: Description of Figure 35-10 follows]








35.3.1 Create a table in the database to hold the information for the index

The steps in this section will show you how to create a table in the database that will hold the page numbers for the items you want to list in the index. If you are not sure if you can create a table in the database, contact the database administrator.


To create a table in the database:

	
Follow the steps in Section 35.2.1, "Create a table in the database to hold the TOC data" to create a new table in the database, using the following code:


create table index_example (term varchar2(100), page number);


	
Press Enter.

You should see a notification that the table has been created.


	
Exit SQL*Plus.









35.3.2 Create a format trigger

The steps in this section will show you how to create a format trigger based on the customer's last name. You will use the SRW.GET_PAGE_NUM built-in function to find the page number for the current customer, and insert that page number into the table you created in the previous section.


To create a format trigger:

	
In Reports Builder, open the report, toc_your_initials.rdf.


	
Click the Paper Layout button in the toolbar to display the Paper Layout view.


	
In the Paper Layout view, right-click the field F_CUST_LAST_NAME, then choose Property Inspector from the pop-up menu.


	
Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.


	
In the PL/SQL Editor, use the template to enter the following code:


function F_CUST_LAST_NAMEFormatTrigger return boolean is
  PageNum number;
begin
  -- get pagenumber
  srw.get_page_num(pageNum);
  -- insert into table
  insert into index_example
  values (:Cust_last_name||', '||:Cust_first_name, PageNum);
  return (TRUE);
end;





	
Note:

You can enter this code by copying and pasting it from the provided text file called toc_index_code.txt.










	
Click Compile.


	
If there are compilation errors, match your code to the code we have provided (either in the example RDF file or in this chapter), then compile it again.


	
Once there are no compilation errors, click Close.


	
Save your report as toc_index_your_initials.rdf.









35.3.3 Add a query to the data model

The steps in this section will show you how to add a query to your data model that will retrieve the individual customer names and the page numbers for your index.


To add the query:

	
In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT SUBSTR(TERM,1,1) INITIAL_LETTER, TERM, PAGE FROM INDEX_EXAMPLE ORDER BY TERM





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called toc_index_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.













	
Click OK.


	
In the new query that displays in the Data Model view, click and drag the INITIAL_LETTER column above the rest of the query, so that the data model now looks like this:


Figure 35-11 Data model view of the index

[image: Description of Figure 35-11 follows]






	
Save your report.









35.3.4 Create a report block to display the index in the Trailer section

The steps in this section will show you how to display the index information in the Trailer section of your report.


To create a report block in the Trailer section:

	
In the Paper Layout view, click the Trailer Section button in the toolbar.


	
Choose Insert > Report Block.


	
On the Style page, select the Group Above radio button, then click Next.


	
On the Groups page, click G_2 (the name of the new group that contains the INITIAL_LETTER column), then click Down to specify the print direction.


	
In the Available Groups list, click G_INITIAL_LETTER, then click Down.


	
Click Next.


	
On the Fields page, click INITIAL_LETTER, then click > to move it to the Displayed Fields list.


	
Move TERM and PAGE to the Displayed Fields list.


	
Click Next, then Next again, then click Finish.


	
Save your report.









35.3.5 Run your report to paper

Click the Run Paper Layout button in the toolbar. The index displays on the last pages of the report. We chose page 2402, which (in our example) looks like the following:




	
Note:

To generate the table of contents (TOC), you must click the Run Paper Layout button. If you click the Paper Design view button, the change of format order will not take effect, thus the TOC will not be generated.










Figure 35-12 Index page of the report

[image: Description of Figure 35-12 follows]









	
Note:

The data on page 2402 in your report may not appear the same as ours, depending on the amount and type of data you have in the schema.
















1.6 The Report Editor

The topics in this section discuss the Report Editor and its different views of a report.

	
About the Report Editor


	
About the Data Model view


	
About the Paper Layout view


	
About the Paper Design view


	
About the Paper Parameter Form view


	
About the Web Source view


	
About the tool palette and toolbar






1.6.1 About the Report Editor

The Report Editor is a work area in which you can manipulate the objects in your report directly or by changing properties in the Property Inspector. In the Report Editor window, you can navigate between different views of your report: the Data Model view, Paper Layout view, Paper Design view, Paper Parameter Form view, and Web Source view.




	
Note:

By default the File > Administration option is always disabled.














1.6.2 About the Data Model view

The Report Editor's Data Model view is a work area in which you create, define, and modify data model objects (queries, groups, queries, groups, formula columns, summary columns, placeholder columns, system and user parameters, and data links) to be used in your report. In this view, objects and their property settings are represented symbolically to highlight their types and relationships. To create the query objects for your data model, you can use the Report Wizard, Data Wizard, or the Query tools in the tool palette.

Oracle Reports Builder uses the data model to determine what data to retrieve for the report. The data retrieved from the database may or may not appear in the report output.


Access

To display the Data Model view:

	
In any of the Report Editor views, choose View > Change View> Data Model.


	
Click the Data Model view button in the toolbar.


	
In the Object Navigator, double-click the Data Model view icon next to the Data Model node.









1.6.3 About the Paper Layout view

The Report Editor's Paper Layout view is a work area in which you can modify the format of your paper report. The default format for your report is defined by the information you specify in the Report Wizard. You can modify the format by working with layout objects (boilerplate text and graphic objects, frames, repeating frames, graphs, fields, anchors, file links, and report blocks). In this view, objects and their property settings are represented symbolically to highlight their types and relationships.

The Paper Layout view is similar to the Paper Design view, in that it is a work area in which you modify the format of your report. However, the Paper Design view displays only when you run your report, allowing you to preview your report and manipulate the actual, or live, data at the same time. In the Paper Design view, you can customize reports interactively, meaning that you can see the results immediately as you make each change.


Access

To display the Paper Layout view:

	
In any of the Report Editor views, choose View > Change View > Paper Layout.


	
Click the Paper Layout view button in the toolbar.


	
In the Object Navigator, double-click the Paper Layout view icon next to the Paper Layout node.









1.6.4 About the Paper Design view

The Report Editor's Paper Design view is a work area in which you can preview your paper report and manipulate the actual, or live, data at the same time. In the Paper Design view, you can customize reports interactively, meaning that you can see the results immediately as you make each change.

To edit your report, such as changing column size, the Paper Design view must be in Flex mode.


Access

The Paper Design view is displayed whenever you run a report. To run a report from the Object Navigator or any editor, click the Run Paper Layout button in the toolbar or choose Program > Run Paper Layout. To run a report from the Report Wizard, click Finish.

You can also display the Paper Design view in these ways:

	
In any of the Report Editor views, choose View > Change View > Paper Design.



	
Note:

In the Object Navigator, there is no Paper Design node; this view is displayed only after running a report.








	
Click the Paper Design view button in the toolbar.





Usage notes

To speed the execution of your report, avoid "fetching ahead" when sending report output to the Paper Design view. The following items can result in fetching ahead when referenced before the data on which they rely:

	
total number of pages/panels


	
grand totals


	
break columns that are formulas


	
break columns that have Value if Null specified




Matrix (cross-product) groups also cause fetching ahead. In order to cross-tabulate the data, Oracle Reports Builder must first fetch all of the data.

It should be noted that while these items slow down the Paper Design view, they do not affect performance when writing to a file or some other destination.




	
Note:

A column can cause fetching ahead even if it is not displayed. For example, a grand total may not appear in the report output, but since it is in the report, fetching ahead may still occur when Oracle Reports Builder calculates it.














1.6.5 About the Paper Parameter Form view

The Report Editor's Paper Parameter Form view is a work area in which you define the format of the report's Runtime Parameter Form. To do this, you define and modify parameter form objects (fields and boilerplate). You can select pre-defined system parameters for your report using the Parameter Form Builder, or you can create your own.

When you run a report, Oracle Reports Builder uses the Paper Parameter Form view as a template for the Runtime Parameter Form. Fields and boilerplate appear in the Runtime Parameter Form exactly as they appear in the Paper Parameter Form view. If you do not define a Runtime Parameter Form in the Paper Parameter Form view, Oracle Reports Builder displays a default Runtime Parameter Form for you at runtime.




	
Note:

At runtime, the Runtime Parameter Form displays only when running the paper report layout. For JSP-based Web reports, the Runtime Parameter Form displays when you run your report within Oracle Reports Builder for debugging purposes, but will not display at runtime. For more information, see Section 1.9.4, "About Parameter Forms for Web reports".










Access

To display the Paper Parameter Form view:

	
In any of the Report Editor views, choose View > Change View > Paper Parameter Form.


	
Click the Paper Parameter Form view button in the toolbar.


	
In the Object Navigator, double-click the Paper Parameter Form view icon next to the Paper Parameter Form node.









1.6.6 About the Web Source view

The Report Editor's Web Source view displays the source code for your JSP-based Web report, including HTML, JSP, and XML tags. It is a Web page where you can view and add dynamic report blocks using the Report Block Wizard, and graphs using the Graph Wizard. Experienced Web developers can edit the Web source directly in this view using JSP tags, HTML, Java, and XML.


Access

To display the Web Source view, do any of the following:

	
In any of the Report Editor views, choose View > Change View > Web Source.


	
Click the Web Source button in the toolbar.


	
In the Object Navigator, double-click the Web Source view icon next to the Web Source node.





Usage notes

	
In the Web Source view, the following languages may appear garbled: Arabic, Central European languages, Cyrillic, Greek, Hebrew, Japanese, Thai, and Turkish. To work around this issue, you can set the font names for Oracle Reports Builder in uifont.ali (in ORACLE_INSTANCE\config\FRCommonComponent\

frcommon\guicommon\tk\admin) as follows:

[rwbuilder]

.....AR8MSWIN1256="Courier New"

.....CL8MSWIN1251="Courier New"

.....EE8MSWIN1250="Courier New"

.....EL8MSWIN1253="Courier New"

.....IW8MSWIN1255="Courier New"

.....JA16SJIS="MS Gothic"

.....TH8TISASCII="Andale Duospace WT"

.....TR8MSWIN1254="Courier New"

You can download a copy of the Andale Duospace WT (fixed-width) font from My Oracle Support (http://support.oracle.com). The patch ID is 2638552.


	
When performing a Find/Replace operation in the Web Source view and running in an Asian language (for example, Japanese) on Windows, Oracle Reports Builder fails. This problem does not occur on UNIX.





See also

Section 1.2.2, "About Web Reports"

Section 2.2.1, "About JavaServer Pages (JSPs) and servlets"

Section 4.6.3, "Adding report data to an existing Web page (HTML file)"

Section 4.6.4, "Adding a report block to a Web page"

Section 4.9.8.2.2, "Adding a graph to a JSP-based Web report"

"Oracle Reports JSP tags" in the Reference section of the Oracle Reports online Help






1.6.7 About the tool palette and toolbar

The tool palette and toolbar contain tools used to manually create or manipulate objects in the Report Editor views (excluding the Web Source view). Each tool appears as an icon. Some tools, such as the Select tool, are common to tool palettes in all Report Editor views. Other tools are specific to the views in which they appear. In Oracle Reports Builder, run your cursor over a tool to display the hint text that identifies the tool.


Tool palette

The tool palette is positioned along the left side of the Report Editor views. Click a tool to activate it for a single operation, or double-click a tool to "lock" it for multiple operations. You can hide the tool palette by choosing View > Tool Palette to deselect it.


Toolbar

The toolbar is positioned along the top of the Report Editor views. To use the tools in the toolbar, click the desired tool to perform the action. All toolbar tools also have menu equivalents. If the tool is designed to perform an action on a group of objects, it appears grayed out until one or more objects are selected. Then clicking the tool performs the action on the selected object(s).


See also

Appendix A, "Tool Palette and Toolbar Reference"








40.7 Summary

Congratulations! You have successfully built a report that uses an external PL/SQL library to calculate employee bonuses, which you can now use in other reports by simply referring to it. You now know how to:

	
create and use an external PL/SQL library.


	
create a default layout in the Report Wizard.


	
add vertical space between a user-determined number of records.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






26.2 Create a Single-Query Matrix

You can build a matrix report with a single-query in the data model. A single-query data model typically performs better than a multiple-query data model.

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.


To create a data model and layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Matrix, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT TO_CHAR (HIREDATE, 'YY') YEAR, DEPTNO, JOB,
SUM (SAL) FROM EMP
GROUP BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB
ORDER BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called nested1_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.













	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 26.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Rows page:

	
Click YEAR in the Available Fields list and click the right arrow (>) to move this field to the Matrix Row Fields list. YEAR should appear under Level 1.


Figure 26-2 First matrix row in the Report Wizard

[image: Description of Figure 26-2 follows]






	
Click Level 1 in the Matrix Row Fields list. This step ensures that the next column added will be at Level 2 rather than Level 1.


	
Click DEPTNO in the Available Fields list and click the right arrow (>) to move this field to the Matrix Row Fields list. Notice that it is added under Level 2 rather than Level 1.


Figure 26-3 Second matrix row in Report Wizard

[image: Description of Figure 26-3 follows]






	
Click Next.





	
On the Columns page, click JOB and click the right arrow (>) to move this field to the Matrix Column Fields list. JOB should appear under Level 1, then click Next.


	
On the Cell page, click SUM_SAL and click the right arrow (>) to move this field to the Matrix Cell Fields list, then click Next.


	
On the Totals page, click Next.


	
On the Labels page, change the labels and field widths as follows, then click Next:


	Fields	Labels	Width
	
YEAR

	
(no change)

	
4


	
DEPTNO

	
(no change)

	
(no change)


	
JOB

	
(no change)

	
10


	
SUM_SAL

	
<none>

	
10








	
On the Template page, make sure Beige is selected under Predefined Template, then click Finish to display your report output in the Paper Design view. It should look like this:


Figure 26-4 Paper Design view for the nested matrix report

[image: Description of Figure 26-4 follows]









	
Note:

You can set alignment and format monetary values directly in the Paper Design view. Simply click the item, then click the appropriate toolbar button (if you run the mouse over these buttons, hint text displays). If the Paper Design view and the Object Navigator are displayed side-by-side, notice that when you select an item in one, the selection is reflected in the other.

















41.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files provided, as well as access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.




	
Note:

The use of REF CURSOR queries in Oracle Reports 11g Release 2 (11.1.2) requires that your database version is 10.1.0.5 (for 10.1) or 10.2.0.2 (for 10.2) or higher.

Interoperability between a 11g Release 2 (11.1.2) database or Oracle Forms Services client and a 10.1/10.2 database requires a minimum patchset level of 10.1.0.5 (for 10.1) or 10.2.0.2 (for 10.2).

An attempt to reference a 10.1 or 10.2 PL/SQL unit or view under the following circumstances will fail with a PLS-801[55916] error unless the 10.1 or 10.2 environment has been patched to the right level:

	
A PL/SQL unit, anonymous block, trigger, call statement, or SQL statement on a 11g Release 2 (11.1.2) database invokes a PL/SQL unit on a 10.1 or 10.2 database across a database link.


	
A PL/SQL unit, anonymous block, trigger, or call statement on a 11g Release 2 (11.1.2) database references a view on a 10.1 or 10.2 database across a database link and the view directly or indirectly references a PL/SQL function or an object type.


	
An Oracle Forms Services 11g Release 2 (11.1.2) client invokes a PL/SQL unit in a 10.1 or 10.2 database using RPC.

















26.5 Format Monetary Values

To make your matrix report more readable, you should format the monetary values.


To format monetary values:

	
On the first page of the report, click one of the cell values. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.


	
Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.


	
Click the Add Decimal Place button in the toolbar twice. Two decimal places are added to the right of the decimal point.


	
Resize the fields. Click and drag the rightmost handle of the cell value under the SALESMAN label about 0.5 inches (1.5 centimeters) to the left. After you complete this operation, the department summaries from the second page should move onto the first page.


	
Shift-click the SALESMAN label.


	
Click the Align Right button in the toolbar.


	
Click in an open area of the Paper Design view to deselect all of the objects.


Figure 26-17 Nested matrix report output with formatted monetary values

[image: Description of Figure 26-17 follows]






	
Save your report as nested3_your_initials.rdf








21 Building a Report that Suppresses Labels

In this chapter, you will learn about reports that suppress the display of field labels. By following the steps in this chapter, you can generate the report output shown in Figure 21-1. Notice how the field labels for Department 40 do not display because no detail records were found


Figure 21-1 Suppressed labels report output

[image: Description of Figure 21-1 follows]







Concepts

A default master/detail report must print a detail label or field, even if there are neither fetched detail records nor values for user-created columns. This example demonstrates how to suppress the detail information for a single record, but allow the other master/detail records to display.


Data Relationships

	
This report uses a master/detail data model. You will also create a formula column in the detail group whose sole function is to return a value; this ensures the detail group contains at least one column that will always return a value each time a detail record is returned (as opposed to, for example, a null value).


	
You will create a summary to count the number of times this formula column returns a value. In the layout, you will create a format trigger that references the summary to determine if the detail labels should be displayed. Doing so provides a reliable method for determining the existence of detail records.





Layout

This report uses a Group Above layout style with modifications.


Example Scenario

In this example, you will build a report that does not display field labels when there are no detail records. Instead, text displays that notifies the user that no detail records were retrieved.

As you build this example report, you will:

	
Create the Data Model with Two Linked Queries manually in the Data Model view.


	
Create a Formula Column and a Summary Column in the Data Model view.


	
Create the report layout using the Report Wizard.


	
Add a Format Trigger to Suppress Labels when no detail records are retrieved.


	
Add Text to Display when No Records Display.




To see a sample report that suppresses labels, open the examples folder named suppresslabels, then open the Oracle Reports example named suppresslabels.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




41.6 Add Summary Columns

Now that your queries are complete and linked, the steps in this section will help you to create columns to summarize the data.


To add summary columns:

	
In the Data Model view, click the Summary Column tool in the tool palette.


	
Click inside the G_EMPLOYEE_ID group to create a summary column.


	
Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to CS_classcount.


	
Under Summary, set the Function property to Count, set the Source property to employee_id, and set the Reset At property to G_department_id.




You have now created a summary that counts up the number of employees. You will not use the summary in this report's layout, but you will use it as the source for other, more interesting summaries later.


	
Repeat the steps above to create summaries with the following characteristics:


Table 41-2 Summary Characteristics

	Create in Group	Name	Function	Source	Reset At
	
G_conlabel

	
CS_conlabel_classcount

	
Sum

	
CS_classcount

	
G_conlabel


	
G_department_id

	
CS_port_count

	
Sum

	
CS_conlabel_classcount

	
G_DEPARTMENT_ID








You may not understand these summaries now. Their purpose will become clearer when you create the report layout and preview the live data.

Your data model should look similar to the following:


Figure 41-7 Data model with summary columns

[image: Description of Figure 41-7 follows]









	
Note:

You can also compare your results to the file we have provided, called ref_emp65.rdf.










	
Save the report as ref_65_your_initials.rdf.









24.1 Prerequisites for This Example

To build this example report, you will need access to the data source and the graphics we have provided. You will also need to install an extra table into the database, which contains the pictures for this report.



24.1.1 Access to the data source and installing the Pictures table

To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you don't know if you have access to this sample schema, contact your database administrator.

You will also need to ask your database administrator to install the Pictures table by using the provided file called pictures.dmp.






24.1.2 Graphics for the report

Before you build this report, make sure the following images are in the dynamicgraphics directory where the sample report file is located:

	
NEW_YORK.TIF


	
BOSTON.TIF


	
DALLAS.TIF


	
CHICAGO.TIF




Although we have chosen to use TIF files in this example, you can use other graphic file formats, such as GIF, JPEG, and BMP.

Then, update your REPORTS_PATH in the Windows registry to include the directory where these images are located. The REPORTS_PATH is located under the Oracle Home entry in the Windows entry. When you edit the entry, add the full directory path of the location of your images.

On UNIX, you can set REPORTS_PATH in $ORACLE_HOME/bin/reports.sh.







18 Building a Report with Graphics, Text, and Color

In this chapter, you will learn about reports that include graphics, text, and color. By following the steps in this chapter, you can generate the report output shown in Figure 18-1.


Figure 18-1 Graphics, text, and color report output

[image: Description of Figure 18-1 follows]







Concepts

	
Reports Builder enables you to modify the look of your report in multiple ways. In this example, you will build a report and enhance it by adding an image to the margin, a title, and a border. You will also change the look of the report by applying different fonts and text styles.


	
This report shows you how to enhance your reports with graphics by:

	
using the Paper Layout view's drawing tools.


	
highlighting boilerplate text appearing in the output.


	
using different colors (if available) and patterns for boilerplate text.





	
For more information on enhancing the appearance of your reports, refer to the Oracle Reports online Help.





Data Relationships

This is a one-query group left report.


Layout

This report uses a Group Above layout, which you will modify in the Paper Layout view to make room for the title and company logo. Then, you will import the logo, create the report title, and the rest of the graphics shown in the image above.


Example Scenario

As you build this example report, you will:

	
Create a Simple Report Definition using the Report Wizard to create one query that selects all the columns for this report, and assign a column to a new break group.


	
Modify the Report in the Paper Layout View to:

	
Add a border around the report


	
Change the font size and style using the Font dialog box.


	
Add bullets to your report using the tool palette.


	
Display a line between each record using the Line tool.


	
Add a title to your report using the Fill Color tool and other layout tools.







To see a sample report with graphics and highlighted text, open the examples folder named graphics, then open the Oracle Reports example named graphics.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




11.2 Create a New Report Manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.


To create a blank report:

	
Launch Reports Builder (or, if already open, choose File > New > Report)


	
In the Welcome or New Report dialog box, select Build a new report manually, then click OK.









4.7 Run and Dispatch a Report

This section provides procedures for the following tasks that you may perform as you run and dispatch a report:

	
Running and dispatching a report from the user interface


	
Running a report from the command line


	
Running a report using a command file


	
Running a report to a remote Reports Server


	
Generating HTML or HTMLCSS output


	
Generating PDF output


	
Generating XML output


	
Generating RTF output


	
Generating text output


	
Generating delimited output


	
Generating Enhanced spreadsheet output


	
Distributing a report to multiple destinations


	
Deploying a report


	
Changing orientation


	
Suppressing the Parameter Form


	
Viewing report output


	
Printing a Report


	
E-mailing a report






4.7.1 Running and dispatching a report from the user interface

To run and dispatch a report from the Oracle Reports Builder user interface:

	
In the Object Navigator, click the report name, or choose File > Open to open it.


	
If you are not already connected, connect to a database.


	
Click the Run Paper Layout button in the toolbar.


	
If the Runtime Parameter Form displays, specify settings for the desired output:



	
Note:

When you create the report, you must use the Parameter Form Builder (choose Tools > Parameter Form Builder) to select the system and user parameters you want to appear in the Runtime Parameter Form.








	
To preview output in the Paper Design view using screen fonts: set Destination Type to Screen.


	
To preview output in the Paper Design view using screen fonts and size the fonts using the printer font metrics: set Destination Type to Preview.


	
To send output to a file: set Destination Type to File, Destination Name to the path and filename, Destination Format to the output format for the report (for example, PDF, HTML, HTMLCSS, RTF, XML, or DELIMITED for bitmapped reports, or the character-mode printer definition file (.prt file) for character-mode reports).



	
Note:

	
It is not possible to generate spreadsheet output directly from Oracle Reports Builder. Instead, on the command line, you can run the report using rwrun and Reports Server clients (rwclient, rwservlet), with DESFORMAT=SPREADSHEET or DESFORMAT=ENHANCEDSPREADSHEET.











	
To send output to a printer: set Destination Type to Printer and Destination Name to the printer driver name.


	
To send output through e-mail using your Internet standard protocol SMTP e-mail application: set Destination Type to Mail and leave Destination Name blank. In the Mail dialog box, specify the recipients and subject line for your e-mail report.



	
Note:

The configuration file ORACLE_HOME\reports\conf\rwbuilder.conf must include the plug-in parameter mailServer (for example, <pluginParam name="mailServer">smtp01.mycorp.com</pluginParam>) with the outgoing mail server name. This applies in both the Windows and Solaris environments.











	
In the Runtime Parameter Form, click the Run Report button in the toolbar.


	
If a dialog box appears, enter required information.





Usage notes

	
If you want the orientation of the report to be landscape, you must change the orientation for the report (see Section 4.7.14, "Changing orientation"). However, if your printer does not support the specified page size, you may get truncated results. To enable character-mode printers to support landscape (or other page sizes), you can set printer escape sequences in the printer definition files. Refer to your printer documentation for the escape sequences to use.


	
When you view the report output in Microsoft Word, you must choose View > Page Layout to see all the graphics and objects in your report.





See also

Section 4.11.6, "Selecting parameters to include in the Runtime Parameter Form"






4.7.2 Running a report from the command line

To run a runfile (.rep) or a report definition file (.rdf) from the command line on Windows:

	
Type %ORACLE_HOME%\BIN\rwrun, followed by the report name and desired arguments.


	
If you sent the output to a file (DESTYPE=FILE DESNAME=filename DESFORMAT=fileformat), open or print the file to verify the output.





See also

Section 1.12, "Oracle Reports Components"

Topic "rwrun" in the Reference section of the Oracle Reports online Help

Section 2.8.2, "About batch reporting"






4.7.3 Running a report using a command file

To run a report using a command file on Windows:

	
Create a text file using a word processor of your choice.


	
In the file, type %ORACLE_HOME%\BIN\rwrun, followed by the report name and desired arguments.


	
Name the file filename.bat.


	
To run the report, type filename.bat on the command line.


	
If you sent the output to a file (DESTYPE=FILE DESNAME=filename DESFORMAT=HTML), open or print the file to verify the output.





See also

Section 2.8.2, "About batch reporting"

Section 1.12, "Oracle Reports Components"

Topic "rwrun" in the Reference section of the Oracle Reports online Help.






4.7.4 Running a report to a remote Reports Server

To run a report to a remote Reports Server:

	
Type %ORACLE_HOME%\bin\rwclient, followed by the report name, server name, and desired arguments.





For additional information, see the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.






4.7.5 Generating HTML or HTMLCSS output

To apply external style sheets and user-defined styles to your report or report objects for HTMLCSS output, you can set the following properties (for information about these properties, see the Reference > Properties section of the Oracle Reports online Help) :

	
Style Sheets property CSS Class Name property CSS ID property




To generate HTML or HTMLCSS output:

	
In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.


	
In the Paper Design view, specify the scope of output you want to display:

	
To display only the current page of the report, choose File > Preview Format > Current Page.


	
To display all pages, choose File > Preview Format > All Pages.



	
Note:

If you choose to show all pages of your report output, and you have HTML page streaming enabled, the first page will display in your Web browser, and you will be able to quickly navigate to any other page in the rest of the report.











	
To preview your HTML or HTMLCSS report output in a Web browser, choose File > Preview Format > Paginated HTML or Paginated HTMLCSS (to format with style sheet extensions).


	
To save your report output as an HTML or HTMLCSS, choose File > Generate to File.





See also

Section 2.8.8, "About HTML and HTMLCSS output"

Section 2.8.8.1, "About HTML page streaming"

Section 2.2.11, "About style sheets"






4.7.6 Generating PDF output

To generate PDF output:

	
In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.


	
In the Paper Design view, specify the scope of output you want to display:

	
To display only the current page of the report, choose File > Preview Format > Current Page.


	
To display all pages, choose File > Preview Format > All Pages.





	
To preview your PDF report output in your Web browser, choose File > Preview Format > PDF.


	
To save your report output as a PDF file, choose File > Generate to File > PDF.





See also

Section 2.8.10, "About PDF output"






4.7.7 Generating XML output

In any Oracle Reports-generated XML file, your output mimics the data model; that is, it is structured by groups and columns. Follow the steps below to do any of the following:

	
Generate an XML output file from your current report.


	
Preview the contents of an XML file in a Web browser in conjunction with command line invocation.


	
Change the XML properties that control XML output for the entire report.


	
Change the XML properties that control XML output for a column or group.




To generate an XML output file from your current report in Oracle Reports Builder:

	
Optionally, in the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report. Currently, any report style can be generated to XML output, but with limited support for matrix-style reports.


	
Optionally, in the Paper Design view, choose File > Preview Format > XML to preview XML data in your default XML viewer (for example, your Web browser).



	
Tip:

An .XML extension is required by XML-supporting browsers to recognize the format as XML and display it accordingly.








	
Click the report in the Object Navigator, and choose File > Generate to File > XML to save the XML output file to the directory of your choice.




To generate an XML output file from the command line, then preview the contents of the XML file in a Web browser:

	
On the command line, run your report with the arguments DESFORMAT=XML, DESTYPE=FILE, and DESNAME=filename.XML.


	
Open an XML-supporting Web browser.


	
Choose File > Open to navigate to the XML file that you just generated, and display it in the browser window.


	
If you make changes to the XML output or regenerate the XML file with the same name, click the Reload button in your browser to view the updated XML output.




To change the XML properties of the entire report:

	
In the Object Navigator double-click the properties icon next to the report name to display the Property Inspector.


	
Under XML Settings, set the XML properties as required for this report.




To change the XML properties of a column or group:

	
In the Data Model view, double-click the column or the title bar of the group to display the Property Inspector.


	
Under XML Settings, set the XML properties as required.





Usage notes

	
Oracle Reports Builder creates "well-formed" XML output. This means that there is an XML Declaration present in the prolog of the XML document, but not necessarily a DTD (document type definition). If you wish to create "valid" XML, you must add the DTD in the XML Prolog Value property field at the report level.


	
For a report developed in a release prior to Oracle Reports 10g Release 2 (10.1.2) patch 2, you may encounter the following issue when saving the report in XML format: if the report defines a PL/SQL package, the package specification, and sometimes the body, is not saved in the XML report. To resolve this issue, perform either of the following steps:

	
If the RDF exists, regenerate the XML output file using Oracle Reports 10g Release 2 (10.1.2) patch 2 or later.


	
If the RDF does not exist, edit the XML to manually to add type="packageSpec" and/or type="packageBody" to the function element, as shown in the following example:


<programUnits>
  <function name="a" type="packageSpec">
    <textSource>
      <![CDATA[
        PACKAGE a IS
          function lire return date ;
        END a;
      ]]>
    </textSource>
  </function>
  <function name="a" type="packageBody">
    <textSource>
      <![CDATA[
        PACKAGE BODY a IS
          function lire return date is
            c2 date;
            begin
              c2 :=sysdate;
              return c2;
            end;
        END;
      ]]>
    </textSource>
  </function>
  <function name="cf_1formula" returnType="date">
    <textSource>
      <![CDATA[
        function CF_1Formula return Date is
          aa date;
          begin
            --aa :=a.lire;
          end;
      ]]>
    </textSource>
  </function>
</programUnits>





	
If your report includes a graph, the graph information will not be saved in the XML file (XML is text-based output, which means images are not included).





See also

Section 2.8.7, "About XML in reports"

Topic "Oracle Reports XML tags" in the Reference section of the Oracle Reports online Help.

Chapters "Creating Advanced Distributions" and "Customizing Reports with XML" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.






4.7.8 Generating RTF output

To generate RTF output:

	
In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.


	
To preview your report output in a Microsoft Word document, choose File > Preview Format > RTF.


	
To save your report output as an RTF file, choose File > Generate to File > RTF.


	
In the Save dialog box, specify a location and file name. Click Save.





See also

Section 2.8.11, "About RTF output"






4.7.9 Generating text output

To generate text output:

	
To generate pure text output, which can be read by many different applications, set the Initial Value property of the MODE system parameter to Character (see Section 4.11.1, "Using a pre-defined system parameter").



	
Note:

If MODE is set to Bitmap (the default), the result is PostScript output, which can be read and rendered only by PostScript-compatible applications (such as a PostScript printer).








	
In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.


	
To preview your report output in a text viewer, choose File > Preview Format > Text.


	
To save your report output as a text file, choose File > Generate to File > Text.


	
In the Save dialog box, specify a location and file name. Click Save.





See also

Section 2.8.14, "About text output"






4.7.10 Generating delimited output

You can generate a report to delimited output using either of the following methods:

	
From Oracle Reports Builder


	
From the command line




To generate delimited output from Oracle Reports Builder:

	
In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.


	
To preview your delimited report output in a spreadsheet, choose File > Preview Format > Delimited or File > Preview Format > DelimitedData (for large volume reports).


	
To save your delimited report output to a file, choose File > Generate to File > Delimited or File > Generate to File > DelimitedData (for large volume reports).


	
In the Delimited Output dialog box or DelimitedData Output dialog box, choose from the list or type the delimiter that will separate the cells in your report output.


	
If you want to use formatting options, choose from the list or type a Date Format Mask or a Number Format Mask.


	
If you want to use a cell wrapper, choose from the list or type the cell wrapper that will be placed around the cell data in your report output.


	
Click OK.


	
In the Save dialog box, specify a location and file name. Click Save.




To generate delimited output from the command line:

	
Run a report using Reports Server clients (rwclient, rwservlet) or rwrun, with DESFORMAT=DELIMITED or DELIMITEDDATA.






	
Note:

	
To run a report through a URL, specify the Excel mimetype so that your browser opens the report output directly in Excel. For example:


http://hostname:port/reports/rwservlet?report=report_name
  +server=server_name+userid=db_connect_string+destype=cache
  +desformat=delimited+mimetype=application/vnd.ms-excel











You can open your delimited output file (.csv) to display it automatically in Microsoft Excel. Or, you can import the output file into an existing Excel worksheet.


Usage notes

	
You can distribute a report in DelimitedData output format, specified either in a distribution XML file or in the Distribution dialog box.





Limitations

	
When generating a report to delimited output, only data (as defined by the report Data Model), no layout information, displays in Microsoft Excel. To generate report output that preserves the layout information in Excel, see Section 2.8.13, "About Enhanced Spreadsheet output".


	
Report distribution does not support Delimited output format. You cannot specify DELIMITED as an output format in a distribution XML file or in the Distribution dialog box.


	
Report bursting does not support Delimited or DelimitedData output format.





See also

Section 2.8.12, "About delimited output"

Section 4.9.7.1, "Specifying date and time format masks"

Section 4.9.7.2, "Specifying number format masks"






4.7.11 Generating Enhanced spreadsheet output

To generate Enhanced spreadsheet output:

	
On the command line, run the report using rwrun or Reports Server clients (rwclient, rwservlet), with DESFORMAT=ENHANCEDSPREADSHEET.

For example, to use rwservlet to generate Microsoft Excel output from the paper layout of your report, enter a command that includes the following:


http://hostname:port/reports/rwservlet?report=report_name
  +server=server_name+userid=db_connect_string+destype=file
  +desformat=enhancedspreadsheet+desname=C:\temp\myexcel_output.htm






	
Notes:

	
Microsoft Office 2000/2002/2003 supports Hypertext Markup Language (HTML) as a native file format. Enhanced Spreadsheet output relies on producing HTML output, which can be understood by Excel as a file with valid Excel format.


	
For reliable formatting, enclose the whole layout area in a frame. This prevents the possibility of parallel objects displaying in different vertical positions, one below the other.












See also

Section 2.8.13, "About Enhanced Spreadsheet output"

Chapter 29, "Building a Report for Enhanced Spreadsheet Output"






4.7.12 Distributing a report to multiple destinations

To distribute a report, you first define the distribution, then enable the distribution.

You can define the distribution for a report in any of the following ways:

	
Use XML, as described in the chapter "Creating Advanced Distributions" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.


	
In the Distribution dialog box, define a distribution list for the entire report or any report section.



	
Note:

To display the Distribution dialog box: In the report or section Property Inspector, under the Report node, click the Distribution property value field.








For an example of using section-level distribution, see Chapter 37, "Bursting and Distributing a Report". This chapter covers defining distribution of a single section to multiple destinations, using the Repeat On property and distribution XML file.


	
On the command line, include the DESTINATION keyword to specify a DST file or XML file.



	
Note:

The DST file method is supported for backward compatibility; the preferred and recommended method of distributing reports is with XML or the Distribution dialog box.








	
To enable the distribution of a report, you can do either of the following:

	
Choose File > Distribute in Oracle Reports Builder.


	
Specify DISTRIBUTE=YES on the command line.







You can also trace the report distribution to verify a successful distribution, as described in Section 4.14.19, "Tracing report distribution".


Usage notes

	
In order to use the same report definition file to burst and distribute to data-driven formats such as XML and DELIMITEDDATA, as well as to layout-driven formats such as PDF and ENHANCEDSPREADSHEET, you must ensure the following requirements are met:

	
The distribution XML file must specify the include element. For example:


&lt;include src="mainSection"/&gt;


	
The Repeat On property must be set appropriately for the section(s) specified in the distribution XML file.


	
The section(s) specified in the distribution XML file in the report paper layout must not be empty.





	
In some cases, Microsoft Internet Explorer ignores the mimetype of a URL's return stream and instead sets the type by looking at the URL. This can be a problem when you are defining the distribution for a report because your URL might end with the DESTINATION keyword. For example:


...DISTRIBUTE=yes 
DESTINATION=c:\oracle\reports\distribution\mydist.xml


In this scenario, the URL ends with the extension xml and Internet Explorer treats the return stream as XML, when in fact it is HTML. As a result, you will receive a browser error. To work around this issue, you should never use recognized file extensions at the end of a URL. In the preceding example, you could switch the positions of the DISTRIBUTE and DESTINATION keywords in your URL.





See also

Section 2.8.3, "About report distribution"

Section 2.1.2, "About report sectioning and sections"

Chapter "Creating Advanced Distributions" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.






4.7.13 Deploying a report

To deploy a report so that end users can view it, refer to the section "Deploying Your Reports" in the chapter "Running Report Requests" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual. This section describes how to deploy a report with a paper layout (that is, a REP, RDF, XML, spreadsheet, or JSP report) and how to deploy a report with a Web layout (that is, a JSP report).






4.7.14 Changing orientation

To change the orientation (portrait or landscape) of a report section, follow the steps for the desired output format:

	
Printer output (DESTYPE=PRINTER) or RTF output (DESFORMAT=RTF)


	
PDF output





Printer output (DESTYPE=PRINTER) or RTF output (DESFORMAT=RTF)

The orientation of report output is based on the following order of precedence:

	
ORIENTATION command line keyword.


	
ORIENTATION system parameter.


	
Orientation property for the pertinent report section (Header, Main, or Trailer): Portrait or Landscape.


	
(If the Orientation property is set to Default) Width and Height properties for the pertinent report section:

	
If Width is greater than Height (for example, 11 x 8.5), then orientation is landscape.


	
If Height is greater than Width (for example, 8.5 x 11), then orientation is portrait.







To set the report output orientation, do one of the following:

	
On the command line, specify the ORIENTATION command line keyword. This takes precedence over the ORIENTATION system parameter, the Orientation property, and the Width and Height properties. For information about the ORIENTATION command line keyword, see the appendix "Command Line Keywords" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.


	
Specify the ORIENTATION system parameter. This takes precedence over the Orientation property, and the Width and Height properties. To specify the ORIENTATION system parameter, which allows end users to modify the orientation at runtime:

	
Choose Tools > Parameter Form Builder to display the Parameter Form Builder.


	
Click the ORIENTATION system parameter.


	
Click OK to display the Paper Parameter Form view.


	
Double-click the Orientation value field (PF_ORIENTATION) to display the Property Inspector.


	
Under the Parameter node, set the Initial Value property to Portrait or Landscape.


	
Click the Run Paper Layout button in the toolbar.


	
From the Orientation list, change the orientation if desired.





	
Set the Orientation property and/or the Width and Height properties:

	
In the Object Navigator, under the Paper Layout node, double-click the properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector (by default, a report is defined in the Main Section).


	
In the Property Inspector, under the Section node, set the Orientation property to the desired value. If set to Portrait or Landscape, this value takes precedence over the Width and Height properties. If set to Default, orientation is based on the values of the Width and Height properties (landscape orientation if Width is greater than Height, and portrait orientation if Height is greater than Width).








PDF output

For PDF output, any values specified for the ORIENTATION command line keyword, ORIENTATION system parameter, and Orientation property are ignored. Orientation of the PDF output is based solely on the values of the Width and Height properties:

	
In the Object Navigator, under the Paper Layout node, double-click the properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector (by default, a report is defined in the Main Section).


	
In the Property Inspector, under the Section node, set the Width and Height properties as desired (for example, 11 (or 15) width x 8.5 height for landscape, or 8.5 width x 11 (or 15) height for portrait). Make sure that you subtract the margin depths (for example, for an 8.5 x 11 page with top, bottom, left, and right margins of .25, set Width to 8 and Height to 10.5).





See also

Section 2.1.2, "About report sectioning and sections"






4.7.15 Suppressing the Parameter Form

If the report is run from another product, you may not want the Parameter Form to appear.

To suppress the Parameter Form and have the report assign a default value to DESTYPE, do either of the following:

	
Create a list parameter to explicitly pass the values of DESTYPE and PARAMFORM.


	
In the Preferences dialog box (Edit > Preferences), on the Runtime Settings page, clear the Parameter Form check box to specify PARAMFORM=NO.





See also

Section 1.6.5, "About the Paper Parameter Form view"

Section 1.11.1, "About the Runtime Parameter Form"

Section 1.9.4, "About Parameter Forms for Web reports"






4.7.16 Viewing report output

This section provides procedures for various ways to view report output:

	
Viewing the printable area


	
Displaying report output in the Paper Design view


	
Displaying report output in the Previewer


	
Displaying report output in your Web browser


	
Displaying individual pages of HTML report output


	
Scrolling and paging


	
Splitting the viewing region


	
Magnifying or reducing the output






4.7.16.1 Viewing the printable area

The printable area is the physical region in which your printer can print on a physical page. Most printers usually cannot print up to the edge of a page, leaving a blank "unprintable" area.

To view the printable area of your report:

	
Choose File > Page Setup to specify your page settings.


	
In the Paper Layout view, click the Edit Margin button in the toolbar.

The printable area is displayed as the area within the dotted lines in the margin area.


	
Choose View > Zoom > Zoom Out to see more.









4.7.16.2 Displaying report output in the Paper Design view

The Paper Design view is displayed whenever you run a report.

To run a report from the Object Navigator or any editor:

	
Click the Run Paper Layout button or choose Program > Run Paper Layout.




To run a report from the Report Wizard:

	
Click Finish.




You can also display the Paper Design view in these ways:

	
Click the Paper Design View button in the toolbar.


	
Choose View > Change View > Paper Design.


	
In the Object Navigator, double-click the view icon next to the Paper Design node.




In the Paper Design view, manipulate the output as desired, and use any of the following features:

	
scrolling and paging (see Section 4.7.16.6, "Scrolling and paging")


	
splitting horizontally and vertically (see Section 4.7.16.7, "Splitting the viewing region")


	
magnifying or reducing the output (see Section 4.7.16.8, "Magnifying or reducing the output")





See also

Section 4.7.17.1, "Printing a report from the Paper Design or Paper Layout view"






4.7.16.3 Displaying report output in the Previewer

To display your report output in the Previewer:

	
In the Paper Design view, choose File > Print Preview.


	
In the Previewer, use any of the following features:

	
scrolling and paging (see Section 4.7.16.6, "Scrolling and paging")


	
splitting horizontally and vertically (see Section 4.7.16.7, "Splitting the viewing region")


	
magnifying or reducing the output (see Section 4.7.16.8, "Magnifying or reducing the output")








See also

Section 1.11.2, "About the Previewer"

Section 4.7.17.2, "Printing a report from the Previewer"






4.7.16.4 Displaying report output in your Web browser

To display report output in your Web browser:

	
In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.


	
In the Paper Design view, specify the scope of output you want to display:

	
To display only the current page of the report, choose File > Preview Format > Current Page.


	
To display all pages, choose File > Preview Format > All Pages.



	
Note:

If you choose to show all pages of your report output, and you have HTML page streaming enabled, the first page will display in your Web browser, and you will be able to quickly navigate to any other page in the rest of the report.











	
To preview your report output in a Web browser, choose File > Preview Format > Paginated HTML, File > Preview Format > Paginated HTMLCSS (to format with style sheet extensions), File > Preview Format > PDF, or File > Preview Format > XML (if you have an XML-supporting browser set as your default XML viewer).


	
To preview your report output with Web layout in a Web browser, choose Program > Run Web Layout to run the Web Source. If you have made changes to the Web Source view (for JSP-based Web reports), this enables you to immediately see the effect of your changes on the output.




	
Note:

If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.










	
To save your report output as an HTML, HTMLCSS, PDF, or XML file, choose File > Generate to File.





See also

Section 1.2.2, "About Web Reports"

Section 2.2.2, "About previewing JSP-based Web reports"

Section 2.2.11, "About style sheets"

Section 4.7.17.3, "Printing a report from your Web browser"






4.7.16.5 Displaying individual pages of HTML report output

To paginate the HTML output for a report:

	
Specify navigation controls for HTML page-streamed output using either of the following methods:

	
in the Report Property Inspector (see Section 4.6.10.1.12, "Adding navigation controls for HTML page-streamed output using the Property Inspector")


	
using PL/SQL (see Section 4.6.10.2.11, "Adding navigation controls for HTML page-streamed output using PL/SQL")





	
Enable HTML page streaming by running your report from the command line, specifying PAGESTREAM=YES.





See also

Section 1.2.2, "About Web Reports"

Section 2.8.8.1, "About HTML page streaming"






4.7.16.6 Scrolling and paging

To move around pages of the report using the scroll bars and paging buttons:

	
Use the mouse cursor to drag the horizontal and vertical scroll bars to move around the current page.


	
Click the First Page, Previous Page, Next Page, and Last Page buttons in the toolbar to display the indicated pages of the report.


	
To display a specific page, type the page number in the Page field.









4.7.16.7 Splitting the viewing region

To create two views of the report output by splitting the display horizontally or vertically:

	
In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, drag the black bar below the vertical scroll bar (to split horizontally), or to the right of the horizontal scroll bar (to split vertically).


	
In the Previewer, drag the grey bar above the vertical scroll bar (to split horizontally), or to the left of the horizontal scroll bar (to split vertically)




You can scroll and page within each view to move the contents of that view while the other view remains unchanged.






4.7.16.8 Magnifying or reducing the output

To magnify a hard-to-see portion of your report:

	
In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, click the Magnify tool in the tool palette (or, choose View > Zoom > Zoom In).


	
In the Previewer, click the Zoom In button in the toolbar.




To reduce the image to get a sense of your report's overall layout:

	
In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, choose View > Zoom > Zoom Out or Normal Size.


	
In the Previewer, click the Zoom Out button in the toolbar.











4.7.17 Printing a Report

This section provides procedures for the following tasks that you may perform to print a report:

	
Printing a report from the Paper Design or Paper Layout view


	
Printing a report from the Previewer


	
Printing a report from your Web browser


	
Printing a report on a preprinted form


	
Switching the printer tray


	
Printing a report on UNIX




Before printing your report from the Reports Builder,do the following:

	
Configure a valid printer, and enter the value of the printer in the uiprint.txt file which is located at:

INSTANCE_HOME/config/FRComponent/frcommon/guicommon/tk/admin/uiprint.txt

OR


	
From the Reports Builder menu, go to Edit > Preferences. Select the Runtime Values tab.

From the Destination Type drop-down list, select Printer and provide a valid value for printer name, and click OK.




For more information, see "Configuring the Printing Environment" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.



4.7.17.1 Printing a report from the Paper Design or Paper Layout view

To print a report from the Paper Design or Paper Layout view:

	
In the Paper Design view or Paper Layout view choose File > Print.


	
In the Print dialog box, type the number of pages and copies you want to print.


	
Click OK.





See also

Section 4.7.16.2, "Displaying report output in the Paper Design view"






4.7.17.2 Printing a report from the Previewer

To print a report from the Previewer:

	
In the Previewer, click the Page Setup button in the toolbar to verify your printer setup.


	
Click the Print button in the toolbar.


	
In the Print dialog box, specify the pages and copies you want to print.

If the report has a Destination Type of Screen (set by system parameter DESTYPE), a warning displays to run the report with a Destination Type of Preview before printing. Preview creates PostScript output, which is typically more desirable for printing bit-mapped reports.


	
Click OK.





See also

Section 4.7.16.3, "Displaying report output in the Previewer"






4.7.17.3 Printing a report from your Web browser




	
Note:

Formatting with style sheet extensions paginates the HTML document in the same way the report is paginated; formatting without style sheet extensions generates HTML output that does not break between the pages of the report.









To print a report from your Web browser:

	
If your report is formatted with HTML style sheet extensions (HTMLCSS), set up your browser to print the HTML document in the same way the report is paginated:

	
In your browser, choose File > Page Setup and modify the margin settings as desired.


	
In the Object Navigator, under the Paper Layout node, double-click the Header Section, Main Section, or Trailer Section properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector (by default, a report is defined in the Main Section).


	
In the Property Inspector, under the Section node, set the Width and Height properties as desired (for example, 11 (or 15) width x 8.5 height for landscape or 8.5 width x 11 (or 15) height for portrait). Make sure that you subtract the margin depths (for example, for an 8.5 x 11 page with top, bottom, left, and right margins of .25, set Width to 8 and Height to 10.5).





	
Display your report output in your Web browser (see Section 4.7.16.4, "Displaying report output in your Web browser").


	
Choose File > Print.





See also

Section 1.2.2, "About Web Reports"

Section 2.2.2, "About previewing JSP-based Web reports"

Section 2.2.11, "About style sheets"






4.7.17.4 Printing a report on a preprinted form

See the example report in Chapter 32, "Building a Report Using a Preprinted Form".






4.7.17.5 Switching the printer tray

To switch the printer tray:

	
Choose File > Page Setup and in the Source list, note the names of the printer trays defined for your printer.


	
Use SRW.SET_PRINTER_TRAY to define the desired trigger:

	
To change the printer tray before the report begins formatting, create a Before Report trigger (see Section 4.13.3.5, "Creating a report trigger").



	
Note:

The printer tray specified in the Page Setup dialog box is used as the default printer tray; create a Before Report trigger to change this default.








	
To change the printer tray between pages of the report, create a Between Pages trigger (see Section 4.13.3.5, "Creating a report trigger").


	
To change the printer tray for a specific page on which a particular object prints, create a format trigger for that object (see Section 4.13.4.1, "Creating or editing a format trigger").








See also

Section 2.8.6, "About switching the printer tray"






4.7.17.6 Printing a report on UNIX

Printing on UNIX requires some setup and configuration to create the proper printing environment. For detailed information about printing your reports on UNIX, refer to the chapter "Printing on UNIX with Oracle Reports" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

Oracle Reports 10g (9.0.4) introduced the following enhancements for printing reports on UNIX:

	
The REPORTS_DEFAULT_DISPLAY environment variable, which provides for the removal of dependency on the DISPLAY environment variable. Prior releases of Oracle Reports required the DISPLAY environment variable to be set to run and print reports on UNIX.


	
The PostScript printer driver screenprinter.ppd, which eliminates the dependency on having a valid printer defined (PRINTER and TK_PRINTER environment variables set to a valid printer, or a valid entry in uiprint.txt) for Reports Runtime on UNIX. This driver provides surface resolution for images and specifies font information. Prior releases of Oracle Reports required a printer to resolve fonts to run and print reports on UNIX.

This driver is the first entry in uiscreenprint.txt. The file locations (UNIX only) are:


uiscreenprint.txt: $ORACLE_INSTANCE/config/FRCommon/frcommon/guicommon/tk/admin
screenprinter.ppd: 
  $ORACLE_INSTANCE/config/FRCommon/frcommon/guicommon/tk/admin/PPD





Limitations

	
If your report includes an Oracle Graphics 6i graph, a printer is required to generate the graph. However, TK_PRINT_STATUS=echo is set in g90runm.sh. Thus, to run a report with an Oracle Graphics 6i graph without a valid printer, set the PRINTER environment variable to any value.



	
Note:

Oracle Graphics 6i, or Graphics Builder, is obsolete. Instead, use the Graph Wizard, which produces graphs that are automatically translated into JSP tags to enable you to add graphics to Web reports (for additional information, see the Oracle Reports online Help topic "Displaying Oracle Graphics 6i charts in Oracle Reports 11g").

















4.7.18 E-mailing a report

To e-mail a report from Oracle Reports Builder:

	
Log on to your Internet Standard Protocol SMTP mail application.


	
Select or open the report.


	
If you are not already connected, connect to a database.


	
Choose File > Mail.


	
In the Mail dialog box, specify the recipients and subject line for your e-mail report.


	
Click OK.




To e-mail a report in batch mode:

	
Log on to your Internet Standard Protocol SMTP mail application.


	
Run the report from the command line, specifying DESTYPE=MAIL, and DESNAME=recipient1, recipient2, recipient3, ....





Usage notes

The configuration file $ORACLE_INSTANCE\config\ReportsToolsComponent\

ReportsTools\rwbuilder.conf must include the plug-in parameter mailServer. For example:


<pluginParam name="mailServer" value="stbeehive.oracle.com">
<property name="enableSSL" value="yes"/>
</pluginParam>


With the outgoing mail server name. This applies in both the Windows and Solaris environments.








42.2 Create a Parameter Form in HTML


The steps in this section will show you how to build a simple Parameter Form using plain HTML. You will then modify this HTML Parameter Form in Reports Builder so that you can call the Parameter Form from your JSP-based Web report.

If you do not want to create your own HTML file, you can open the sample HTML file we have provided in the Source directory, called paramform.html, then view the source code.

To create a simple Parameter Form in HTML:

	
In a text editor or HTML editor, create an HTML page that contains a form. The form should contain a list of values, a field, and a button. The code for this form can look something like the following:


<form name="form1" method="post" action="">
    <h2>Parameter Form</h2>
    <p>Choose a department from the list, then click the <b>Run Report</b>
button to show salary details for each employee in that department.</p>
    <select name="p_department" size="1">
      <option value="1">a</option>
    </select>
    <br>
    <input type="text" name="userid" value="hr/hr@db-connect">
        <br>
    <input type="submit" name="Submit" value="Run Report">
</form>




	
Note:

Although you can use the above code, you will need to change the userid value to reflect the connection information for your data source. You can also copy and paste the HTML code from the provided file, called simplejsppf_code.txt in the simplejsppf/scripts directory, then modify it in a text or HTML editor.








	
Save the HTML file as paramform_your_initials.html. When you display this HTML file in a Web browser, it should look similar to the following image:


Figure 42-3 Sample HTML Parameter Form

[image: Description of Figure 42-3 follows]













21.2 Create the Data Model with Two Linked Queries

The steps in this section will show you how to build a simple data model with two queries in a master/detail relationship.


To create a data model

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Build a new report manually, then click OK.


	
In the Data Model view that displays, click the SQL tool in the tool palette, then click in an open area of the Data Model view to display the SQL Query Statement dialog box.


	
In the SQL Query Statement dialog box, type the first SELECT statement:


SELECT * FROM DEPT
ORDER BY DEPTNO





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called suppresslabels_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.




Also note that if you have not installed the Pictures table into the sample schema, you will not be able to create this query.










	
Click OK.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 21.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
When the query displays in the Data Model view, right-click the query name (Q_1), then choose Property Inspector from the pop-up menu to set the following property:

	
Under General Information, set the Name property to Q_DEPT.





	
Follow the steps above to create another query named Q_EMP, with the following SELECT statement:


SELECT DEPTNO, ENAME, JOB FROM EMP
ORDER BY ENAME


	
In the Data Model view, click the Data Link tool in the tool palette.


	
Drag a link between DEPTNO in Q_DEPT and DEPTNO1 in Q_EMP. Your data model should now look like this:


Figure 21-2 Data Model view of the Suppress Labels report

[image: Description of Figure 21-2 follows]






	
Save your report as suppresslabels_your_initials.rdf.









35.4 Summary

Congratulations! You have successfully created a report with a table of contents and an index. You now know how to:

	
create a table of contents (TOC) and index for a large paper report.


	
use the SRW.SET_FORMAT_ORDER built-in procedure to change the order in which the sections of a report are executed.


	
use the SRW.GET_PAGE_NUM built-in procedure to retrieve the page number for a specific record.


	
create a new table in your database to hold the necessary page numbers.


	
create a simple group above report using the Report Wizard.


	
manually create a simple data model to retrieve the information for your report.


	
create a format trigger to generate the necessary page numbers for an index.


	
use the Report Block Wizard to create a group report that displays the index in the trailer of a report.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






1.1 Oracle Reports Builder

The topics in this section discuss the features and functionality in Oracle Reports Builder.

	
About Oracle Reports Builder


	
About this release






1.1.1 About Oracle Reports Builder

Oracle Reports Builder is the report-building component of Oracle Reports, a powerful enterprise reporting tool that enables you to rapidly develop and deploy sophisticated Web and paper reports against any data source (including an Oracle database, JDBC, XML, and text files). Leveraging Java EE technologies such as JSP and XML, you can publish your reports in a variety of formats (including HTML, XML, PDF, spreadsheet, delimited text, PostScript, and RTF) to any destination (including e-mail, Web browser, Oracle Portal, and file system) in a scalable, efficient manner. Recognizing the differences between Web publishing and paper publishing, Oracle Reports Builder provides the power to develop high quality output for the Web and e-business requirements, as well as high-fidelity printed reports Oracle Reports Builder includes:

	
user-friendly wizards that guide you through the report design process


	
pluggable data sources (PDSs), such as JDBC and XML, that provide access to data from any source for your reports


	
a query builder with a graphical representation of the SQL statement to obtain report data


	
default report templates and layout styles that can be customized if needed


	
a live editor that enables you to modify paper report layouts in WYSIWYG mode


	
the ability to add dynamic report output to an HTML page by embedding custom JSP tags within an HTML document


	
an integrated graph builder to graphically represent report data


	
the ability to generate code to customize how reports will run


	
tools that dynamically generate Web pages based on your data


	
standard report output formats such as HTML, HTMLCSS, XML, PDF, RTF, Spreadsheet, PCL, PostScript, and ASCII


	
client-side parameter validation using JavaScript


	
the ability to execute dynamic SQL statements within PL/SQL procedures


	
support for Oracle database objects


	
event-based reporting (report execution based on database events)


	
seamless integration with Oracle Portal for administering report security and publishing report output to portlets









1.1.2 About this release

Oracle Reports 11g Release 2 (11.1.2) provides many new features and enhancements. The primary themes of this release are:

	
Tighter integration with Oracle Fusion Middleware Platform and Services to provide simplified administration of complex topologies and deployments.


	
Enhancements in top supportability areas with architectural changes.


	
New features in key enterprise reporting areas.




The chapter titled "Introduction" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual, available on the Oracle Technology Network details the new functionality in Oracle Reports 11g Release 2 (11.1.2), along with the equivalent 10g Release 2 (10.1.2) functionality, when applicable.

For additional information, see the Oracle Reports 11g page on the Oracle Technology Network.








1.10 The Property Inspector

The topics in this section discuss the Property Inspector in Oracle Reports Builder.

	
About the Property Inspector


	
About making multiple selections in the Property Inspector






1.10.1 About the Property Inspector

The Property Inspector is a window that enables you to access the properties of the currently selected object(s) in the Object Navigator, Report Editor, and Template Editor.

Every Oracle Reports Builder object (query, group, frame, parameter, and so on.) has associated properties that can be viewed using the Property Inspector. To get help on any property, click the property in the Property Inspector and press F1.



1.10.1.1 About making multiple selections in the Property Inspector

You can select multiple objects at the same time by using Shift+Click or Ctrl+Click in the navigators or the editors. When two or more objects are selected, a list of object names is displayed at the top of the Property Inspector.

The Intersection/Union button on the Property Inspector toolbar determines which properties are displayed in the property list when more than one object is selected. Toggling between Intersection and Union changes the list of properties displayed in the Property Inspector, but does not affect the setting of any property.


Table 1-2 Property Inspector Intersection/Union

	Button	Description
	
Intersection

	
The default. Only properties common to all selected objects are displayed.


	
Union

	
All properties of every object selected are displayed.








Properties that are common to two or more objects in a multiple selection are listed only once, and the property setting is displayed as follows:

	
If the property has the same setting for all of the selected objects that have it in common, the common setting is displayed.


	
If the property is set differently for the objects that have it in common, the string ***** is displayed.





See also

Section 4.2.2, "Setting report properties"

Section 4.2.5, "Setting properties for an ASCII (character-mode) report"

Section 4.2.7, "Setting properties of multiple objects"

Section 4.2.8, "Comparing the properties of one object to another"










32.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






4.16 Administer Oracle Reports Builder

This section provides procedures for the following tasks that you may perform as you administer Oracle Reports Builder:

	
Setting a database role


	
Converting from one format to another


	
Improving performance using SQL statements


	
Improving performance using WHERE clauses






4.16.1 Setting a database role

Before beginning this procedure, verify that the database administrator has created the role, granted privileges to the role, and granted the role to approved end users. Refer to your Oracle Application Developer's Guide for more information.

To set a database role for a report:

	
In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.


	
Under the Report node, set the Role Name property as defined by the database administrator in the database.


	
Optionally, to set a Role Password, double-click the button in the Role Name value field to display the Set Role dialog box.





Usage notes

	
The role settings in the report are overridden if you specify a role using the command line with Reports Runtime (rwrun).


	
You can set only one role for a report. To set multiple roles, you need to set a role to which the other roles have been granted.



	
Caution:

Do not attempt to set the role in a PL/SQL trigger. The PL/SQL will not compile.











See also

Section 2.9.1, "About database roles"






4.16.2 Converting from one format to another

To convert one or more report definitions or PL/SQL libraries from one storage format to another:

	
In Oracle Reports Builder, choose Tools > File Conversion to display the Convert dialog box.


	
On the command line on Windows, type %ORACLE_HOME%\bin\rwconverter, followed by the report name and desired arguments.









4.16.3 Improving performance using SQL statements

Performing operations in SQL is faster than performing them in Oracle Reports Builder or PL/SQL. The following are the most common cases where using SQL would improve performance:

	
Use a WHERE clause instead of a group filter or format trigger to exclude records.


	
Use the SUBSTR function to truncate character strings instead of truncating in Oracle Reports Builder.


	
Perform calculations directly in your query rather than in a formula or summary.

Rationale: SQL can perform calculations more quickly than a summary or formula. WHERE and SUBSTR can reduce unnecessary fetching because they operate on the data during rather than after data retrieval. Improvements in performance become more noticeable when retrieving thousands of records versus a few records.









4.16.4 Improving performance using WHERE clauses

Consider adding a WHERE clause for the matrix cell query in a multiquery data model. If you are using a multiquery data model and your dimension queries are restricted by a WHERE clause, adding a WHERE clause to the matrix cell query ensures that you do not retrieve more records than are necessary. For example, suppose that you had the following queries for your dimensions:


Q_Dept


SELECT DEPTNO FROM DEPT
WHERE DEPTNO < 100



Q_Job


SELECT DISTINCT JOB FROM EMP
WHERE DEPTNO < 100



Q_Filler

To ensure that your cell query only retrieves the records that are necessary, you would write the following SELECT statement:


SELECT DEPTNO, JOB, SUM(SAL) FROM EMP
WHERE DEPTNO IN (SELECT DEPTNO FROM DEPT
WHERE DEPTNO < 100) AND JOB IN (SELECT
DISTINCT JOB FROM EMP WHERE DEPTNO < 100)
GROUP BY DEPTNO, JOB


If you did not add the WHERE clause to this query, all rows would be retrieved from the database, regardless of what you selected in Q_Dept and Q_Job.




	
Note:

If you added a WHERE clause that did not use the subqueries (for example, WHERE EMP.DEPTNO = DEPT.DEPTNO), the query would be executed once for each combination of values in the cross-product. This can lead to excessive execution of the filler query, if the cross-product has a lot of combinations.
















13.6 Format Fields

In the Paper Design view, notice the monetary values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.


To assign a format mask to monetary values:

	
In the Paper Design view, shift-click the values underneath the Itemtot and Sum Total. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.


	
Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.


	
Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.


	
Resize the fields. Click and drag the rightmost handle of the Itemtot field approximately 0.5 inches (1.5 centimeters) to the left. Repeat for the Sum Total field. Try to have the right boundaries of the two fields align with each other.


	
Click the Align Right button. All of the values are immediately right aligned.


	
Shift-click the Itemtot label and the Sum Total label.


	
Click the Align Right button.


	
Save your report as grp_above_summ_your initials.rdf.





Figure 13-10 Combined group left and tabular report output

[image: Description of Figure 13-10 follows]









12 Building an Across Group Report

In this chapter, you will learn about across group reports. By following the steps in this chapter, you can generate the report output shown in Figure 12-1.


Figure 12-1 Across group report output

[image: Description of Figure 12-1 follows]







Concepts

	
Reports Builder enables you to modify the look of your report in multiple ways. In this example, you will build an across group report that prints the values of a database column across the page instead of down.


	
In across reports with breaks, the master (or break) group prints "top to bottom"; that is, as it would in other master/detail reports. However, the values in the detail group print across the page, from left to right. When there are more values than will fit on a line, Oracle Reports wraps the line and prints the remaining values across the page on the next line. Note, however, in the case of ENHANCEDSPREADSHEET output, the across group keeps repeating (until it reaches the 75,000 rows limit). This is natural Excel behavior because Excel does not have a fixed "page width", and Oracle Reports adapts ENHANCEDSPREADSHEET output to this Excel behavior.


	
For more information on break reports, refer to the Oracle Reports online Help.





Data Relationships

The break in this report is created through a data link between a master group and a detail query.


Layout

To create the layout used in this report, you will select the master/detail style, then modify the Print Direction setting for one of the groups to ensure it prints across the page instead of down the page.


Example Scenario

As you build this example report, you will:

	
Create Two Queries that select all of the columns displayed, then link them to establish a master/detail relationship


	
Create the Default Layout using the Report Block Wizard.


	
Run Your Report to Paper.




To see a sample across report with control breaks, open the examples folder called acrossbreak, then open the Oracle Reports example report named acrossbreak.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.



11 Building a Two-Query Group Report

In this chapter, you will learn about multiquery group reports. By following the steps in this chapter, you can generate the report output shown in Figure 11-1.


Figure 11-1 Group above report output, two queries

[image: Description of Figure 11-1 follows]







Concepts

As you can see above, a two-query group report appears much the same as a single-query group report. Performance is the key issue when contrasting single-query and multiple-query group reports. In most cases, single-query reports will run faster than multiple-query reports. The multiple-query reports are, however, sometimes easier to understand conceptually and easier to maintain. For example, if you are in a situation where only a few users run the report and the report returns a relatively small number of records, you might want to use multiple queries to simplify maintenance and make the data model easier to understand. If you have many users and the report is quite large, then you should try to use a single-query report.




	
Note:

For more information on streamlining your report's performance, refer to the chapter "Tuning Oracle Reports" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.










Data Relationships

	
The single and multiple-query group reports look the same but have different data models. A single-query report has multiple groups underneath one query, while a multiple-query report uses one group underneath each of several queries. In the single-query case, the relationship is established by the hierarchy of groups underneath the query. In the multiple-query case, the relationship is established by data links between the groups of different queries.


	
A data link is a data model object that enables you to relate multiple queries. For a simple group report, you relate the two queries using the primary and foreign keys of the tables from which you are selecting data.


	
A primary key is a column for which each value uniquely identifies the record in which it is found. A foreign key is a column which contains the same values as the primary key for another table, and is used to reference records in that table.


	
Linking two tables through primary and foreign keys is similar to specifying a join condition. In fact, the data link causes Reports Builder to create a SQL clause defining a join, based on information specified when creating the link. This clause is added to the child query's SELECT statement at run time.


	
The join defined by a default data link is an outer join—in addition to returning all rows that satisfy the link's condition, an outer join returns all rows from one table that do not match a row from the second table.





Layout

	
This report uses a default group above layout style in which master records display across the page with the labels to the left of their fields and the detail records appear below the master records in standard tabular format.


	
You will deselect one default column to keep it from appearing in the report, change some field widths to ensure the fields fit across the page, and format one of the fields.


	
You will also specify a maximum of one master record per page to ensure that only one master record and its associated detail records are displayed per page of report output.





Example Scenario

In this example, you will create a group above report that lists employees with their jobs and salaries by department.

As you build this example report, you will:

	
Create a New Report Manually to create a new, empty report.


	
Create a Data Model with a Data Link between two queries.


	
Use the Report Wizard to Layout the Data.


	
Format a Field to format monetary values.




To see a sample group above report with two queries, open the examples folder named masterdetail, then open the Oracle Reports example named grp_above.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.



46 Building a Report with a Text Pluggable Data Source

In this chapter, you will learn about reports that include data from a Text pluggable data source (PDS), which is provided with Oracle Reports. By following the steps in this chapter, you can generate the report output shown in Figure 46-1.


Figure 46-1 Report output using a Text PDS

[image: Description of Figure 46-1 follows]







Concepts

	
The information you must publish is often derived from data in various corporate data sources. These data sources may be SQL-based (relational databases) or non-SQL-based, such as character-delimited text. Often, you must combine data from one or more of these data sources to publish meaningful information. For example, you may need to combine data that exists in a relational database with data from a multidimensional database to compare trends and performance.


	
Oracle Reports enables you to leverage capabilities, such as aggregation, summarization, formatting, and scheduling, on data from any data source. You can leverage the pluggable data source (PDS) architecture to connect to your own data source, as well as to the data sources available with Oracle Reports (XML, JDBC, and Text).


	
For more information on pluggable data sources, refer to the Oracle Reports online Help. If your data source cannot use an existing PDS, the PDS API enables you to write your own PDS and incorporate it into Oracle Reports to access your own unique data sources. The API is documented in Oracle Reports Java API Reference, .





Example Scenario

In this example, you have downloaded the US Census Bureau data in CSV (comma-separated values) format and want to generate a report. You will learn how to use character-delimited text as a data source to create a paper report.

As you build this example report, you will:

	
Set Up the textpds.conf File to Configure Reports Builder to recognize your text file as a pluggable data source.


	
Use the Report Wizard to Create a Report based on the text data source.




To see a sample report that uses a Text PDS, open the examples folder named text_pds, then open census_report.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 46-1.


Table 46-1 Example report files

	File	Description
	
text_pds\census_report.rdf

	
The finished RDF for your report.


	
text_pds\census_report.pdf

	
A PDF version of your finished report.


	
text_pds\census_csv.txt

	
The character-delimited data downloaded from the US Census Bureau Web site.


	
text_pds\config.txt

	
Code for the textpds.conf file.










32.6 Summary

Congratulations! You have successfully built a report that you can print on a preprinted form. You now know how to:

	
manually create two queries and link them.


	
create a summary column.


	
create a break group in your data model.


	
use the tools in the Paper Layout view to create your layout.


	
use the Report Block Wizard to create a mailing label report.


	
use the Report Block Wizard to create a tabular report.


	
add page numbering using fields in the Paper Layout view.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






4.11 Work with Parameters and the Parameter Form

This section provides procedures for the following tasks that you may perform as you work with parameters and the Parameter Form:

	
Using a pre-defined system parameter


	
Creating a user parameter


	
Creating a list of values (LOV) for a parameter


	
Validating a parameter value at runtime


	
Creating a default Parameter Form


	
Selecting parameters to include in the Runtime Parameter Form


	
Displaying the Parameter Form at runtime


	
Adding more pages to the Runtime Parameter Form


	
Passing parameters to reports running in batch mode


	
Creating an HTML Parameter Form header using PL/SQL


	
Creating an HTML Parameter Form footer using PL/SQL


	
Creating HTML Parameter Form input or select events


	
Changing HTML Parameter Form input to uppercase





See also

Section 1.9.1, "About parameters"

Section 2.3.4, "About referencing columns and parameters"

Section 1.6.5, "About the Paper Parameter Form view"

Section 1.11.1, "About the Runtime Parameter Form"

Section 1.9.4, "About Parameter Forms for Web reports"



4.11.1 Using a pre-defined system parameter

To use a system parameter:

	
In the Object Navigator, expand the Data Model node, then expand the System Parameters node.


	
Double-click the properties icon for the desired parameter to display the Property Inspector.


	
Under the Parameter node, set the Initial Value property, if required.


	
To validate the parameter's value at runtime, set the Validation Trigger property by clicking the ... button to display the PL/SQL Editor and define the PL/SQL to be triggered at runtime.









4.11.2 Creating a user parameter




	
Note:

Oracle Reports Builder automatically creates a user parameter when you use a bind parameter reference in a query.









To create a user parameter:

	
In the Object Navigator, expand the Data Model node, then click the User Parameters node.


	
Click the Create button in the toolbar.


	
Double-click the properties icon for the new parameter to display the Property Inspector.


	
Under the General Information node, replace the Name property with the desired parameter name.


	
Under the Parameter node, set the Initial Value and List of Values properties, if required.


	
To validate the parameter's value at runtime, set the Validation Trigger property by clicking property field to display the PL/SQL Editor and define the PL/SQL to be triggered at runtime.









4.11.3 Creating a list of values (LOV) for a parameter




	
Tip:

If you define a parameter in a template, you must apply the template to a report in order to select that parameter for the Runtime Parameter Form.









To create a LOV for a parameter:

	
In the Object Navigator, expand the Data Model node, then the User Parameters node.


	
Double-click the properties icon for the parameter for which you want to create a LOV to display the Property Inspector.


	
Under the Parameter node, double-click the List of Values property field to display the Parameter List of Values dialog box.


	
Select the type of list that you want to create:

	
For Static Values, type a value in the Value text box and click Add. Repeat for each value you want to add. (Click Remove to delete items from the list)


	
For SELECT Statement, type a query to populate the list of values. You can select more than one column to display in the LOV, where the first column contains the value to be assigned to the parameter. The LOV displays columns in the order specified in the query.





	
If you want the parameter value to be restricted to only those in the LOV, select the Restrict List to Predetermined Values check box. To display a combo box that allows users to edit values or type a different value in the Runtime Parameter Form, clear the check box.


	
If you do not want the first column (which contains the parameter value) of your query displayed in the LOV, select the Hide First Column check box. If there is no need to preserve the confidentiality of the first column, clear the check box.



	
Caution:

If you send the report output to an HTML file, either from Oracle Reports Builder or running it in your Web browser, the value of the first column will be visible in the HTML source, even if Hide First Column is selected.

If you run the report from a Web browser and the list of values is unrestricted, the HTML Parameter Form will display a text field instead of a combo box, and a list of static values that you can copy and paste into the text field. In this case, the first column will always be shown in the Parameter Form, even if Hide First Column is selected.








	
Click OK.









4.11.4 Validating a parameter value at runtime

To validate a parameter value at runtime:

	
In the Object Navigator, expand the Data Model node, then the System Parameters or User Parameters node.


	
Double-click the PL/SQL icon for the parameter for which you want to add a PL/SQL validation trigger.


	
In the PL/SQL Editor, define the PL/SQL to be triggered at runtime.





See also

Section 2.6.13.3, "About validation triggers"






4.11.5 Creating a default Parameter Form

To create a default Parameter Form:

	
Choose Tools > Parameter Form Builder.


	
Click OK to display the Paper Parameter Form view with the default Parameter Form.









4.11.6 Selecting parameters to include in the Runtime Parameter Form

To select parameters to include in the Runtime Parameter Form:

	
Choose Tools > Parameter Form Builder.


	
In the Parameter Form Builder, click the parameters you want to include in the Runtime Parameter Form.


	
Modify the parameter labels as desired.


	
Click OK to display the Paper Parameter Form view.









4.11.7 Displaying the Parameter Form at runtime

To display the Runtime Parameter Form when you run your report:

	
Choose Edit > Preferences to display the Preferences dialog box.


	
On the Runtime Settings page, make sure that the Parameter Form check box is selected.



	
Note:

The Parameter Form can be used only for paper reports. If you display your paper-based report on the Web, you can create an HTML Parameter Form by adding HTML header and footer tags (using either the Before Form Value property and After Form Value property or the SRW.SET_BEFORE_FORM_HTML and SRW.SET_AFTER_FORM_HTML procedures). However, if you design a JSP-based Web report with a Parameter Form in Oracle Reports Builder, be aware that Web reports that use JSPs do not support the display of the Runtime Parameter Form at runtime. For more information, see Section 1.9.4, "About Parameter Forms for Web reports".















4.11.8 Adding more pages to the Runtime Parameter Form

To add more pages to the Runtime Parameter Form:

	
In the Object Navigator, double-click the properties icon next to the report name.


	
In the Property Inspector, under the Parameter Form Window node, set the Number of Pages property as desired.









4.11.9 Passing parameters to reports running in batch mode

To pass parameters (for example, data ranges) to reports running in batch mode:

	
Use bind variables in your query to restrict the query, and use the command line parameters to pass the values to the query. For example:




Query:


 SELECT * FROM EMP WHERE HIREDATE BETWEEN
 :FROM_DATE AND :END_DATE 


Runtime:


RWRUN REP1 SCOTT/TIGER FROM_DATE='12-JUN-92' 
END_DATE='24-JUN-92' 






4.11.10 Creating an HTML Parameter Form header using PL/SQL

See Section 4.6.10.2.5, "Creating an HTML Parameter Form header using PL/SQL"






4.11.11 Creating an HTML Parameter Form footer using PL/SQL

See Section 4.6.10.2.6, "Creating an HTML Parameter Form footer using PL/SQL"






4.11.12 Creating HTML Parameter Form input or select events

To create an HTML Parameter Form field with input or select events:

	
In the Object Navigator, double click the view icon next to the Paper Parameter Form node to display the Paper Parameter Form view.


	
Create or edit a Parameter Form field (see Section 4.9.1.1, "Creating a field object").


	
Double-click the field object to display the Property Inspector.


	
Under Web Settings, set the Additional Attributes (HTML) property to a valid JavaScript event handler.



	
Note:

In some cases, for example, when raising messages it may be necessary to type JavaScript code in the Before Form trigger.










To insert the JavaScript code in the Before Form trigger:

	
In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.


	
Under Report Escapes, set the Before Form Type property to Text (if you will type the Javascript) or File (if you will import the JavaScript from a file).


	
Set the Before Form Value property by clicking the ... button to either type JavaScript in the dialog box or select an HTML file with the JavaScript to import.





Example 1: Data input validation

This example shows how to set Parameter Form fields for input validation when the report is run throughwith the Web. Doing so will raise a message whenever an end user enters invalid data in the Parameter Form field.

	
In the Paper Parameter Form view, create a Parameter Form field called PF_DEPTNO.


	
Double-click the field object to display the Property Inspector, and set the following properties:

	
Under Parameter Form Field, set the Source property to DEPTNO.


	
Under Web Settings, set the Additional Attributes (HTML) property to the following JavaScript event handler:


onChange="checkIt(this.form)"





	
In the Object Navigator, click (the properties icon) next to your report name to display the Property Inspector, and set the following properties:

	
Under Report Escapes, set the Before Form Type property to Text.


	
Set the Before Form Value property the following JavaScript code:





<SCRIPT LANGUAGE = "JavaScript">
function isNumber(inputStr){
   for (var i = 0; i < inputStr.length; i++) {
      var oneChar = inputStr.charAt(i)      
      if (oneChar < "0" || oneChar > "9") {
         alert("Please enter a numeric value.")
         return false
         }
     }
    return true
   }
function checkIt(form) {
   inputStr = form.DEPTNO.value
   if (isNumber(inputStr)) {
      // statements if true
      } 
      else {
         form.numeric.focus()
         form.numeric.select()
      }
   }
</SCRIPT>







At runtime, if the end user enters the department name in the Runtime Parameter Form rather than the department number when running the report through the Web, the following message is raised:


Please enter a numeric value.



Example 2: Select validation

This example shows you how to set Parameter Form fields for select validation when the report is run through the Web. Doing so will raise a message whenever an end user selects Printer from the DESTYPE list of values in the Runtime Parameter Form.

	
In the Paper Parameter Form view, create a Parameter Form field called PF_DESTYPE.


	
Double-click the field object to display the Property Inspector, and set the following properties:

	
Under Parameter Form Field, set the Source property to DESTYPE.


	
Under Web Settings, set the Additional Attributes (HTML) property to the following JavaScript event handler:


onChange="isPrinter(this.form)"





	
In the Object Navigator, click (the properties icon) next to your report name to display the Property Inspector, and set the following properties:

	
Under Report Escapes, set the Before Form Type property to Text.


	
Set the Before Form Value property the following JavaScript code:


<SCRIPT LANGUAGE = "JavaScript">
function isPrinter(form) {
  if( form.DESTYPE.options[form.DESTYPE.selectedIndex].value 
       == 'Printer')
    alert("Please be sure that your print is installed and running.")
    return true}
   }
</SCRIPT>







At runtime, if the end user selects PRINTER from a list of values in the DESTYPE field, the following message is raised:


Please be sure that your print is installed and running.



See also

Section 2.5.1, "About Parameter Form HTML extensions"






4.11.13 Changing HTML Parameter Form input to uppercase

To change data input values default to uppercase upon entry in a Parameter Form field:

	
Choose Tools > Parameter Form Builder.


	
In the Parameter Form Builder, create a Parameter Form field called PF_DESFORMAT, with a source of DESFORMAT.


	
Choose Tools > Property Inspector.


	
In the Property Inspector, under Web Settings, set the Additional Attributes (HTML) property to:


onChange="this.value=this.value.toUpperCase()"





Example: Default input to uppercase

This example specifies that data input values default to uppercase upon entry in a Parameter Form field.

	
In the Paper Parameter Form view, create a Parameter Form field called PF_DESTYPE.


	
Double-click the field object to display the Property Inspector, and set the following properties:

	
Under Parameter Form Field, set the Source property to DESFORMAT.


	
Under Web Settings, set the Additional Attributes (HTML) property to the following JavaScript event handler:


onChange="this.value=this.value.toUpperCase()"







At runtime, if the end user enters pdf as the destination format, the value will change to uppercase (that is, PDF) in the Runtime Parameter Form when running the report through the Web.








13.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Summit Sporting Goods (SUMMIT) schema. To download the SQL scripts that install the schema, see "Accessing the Data Sources" in the Preface.






41.10 Summary

Congratulations! You have finished the REF CURSOR query sample report. You now know how to:

	
create package specs that define REF CURSORs.


	
create REF CURSOR queries.


	
create data links between REF CURSOR queries.


	
create summaries to describe data.


	
create a report layout.


	
move SELECT statements into packages.


	
move packages into a PL/SQL library.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".





43 Building a Report with a Barcode

In this chapter, you will learn about reports that include a barcode. By following the steps in this chapter, you can generate the report output shown in Figure 43-1.


Figure 43-1 Barcode JavaBean Web report output

[image: Description of Figure 43-1 follows]







Concepts

	
By using a barcode JavaBean, you can build reports that display a barcode to make tasks like tracking shipping orders and employee identification numbers easier.


	
You can create a paper or Web report that uses JavaBeans. For a paper report, you must use the Java Importer to create a PL/SQL wrapper so that you can call the JavaBean from your PL/SQL business logic. For a JSP-based Web report, you must call the JavaBean from your report. In Reports Builder, the JavaBean automatically generates the barcode for you.




	
Note:

For information about the Java Importer, and the ORA_JAVA built-in package, see Oracle Reports online Help topics under Reference > Java Importer.










	
You can learn more about the barcode JavaBean on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Any Format. In the expanded list of sub-topics, click PL/SQL-Java Bridge.





Example Scenario

In this example, you will build two reports, one for paper and one for the Web. The paper report shows an invoice for a single customer who has ordered multiple items from a company. The barcode indicates the tracking information for the order.

As you build these example reports, you will:

	
Create a Barcode Report for Paper:

	
Import the Java classes into Reports Builder using the Java Importer to add the barcode JavaBean.


	
Create a package to store your information using the Program Unit editor.


	
Create a Before Report trigger to set up your barcode JavaBean for the report.


	
Create a query in the Data Model view to retrieve the data from the schema..


	
Create a formula column to retrieve the barcode image.


	
Create a formula column that returns the order total.


	
Create a layout for your report.





	
Create a Barcode Report for the Web:

	
Create a query in an existing HTML file.


	
Create three formula columns in your data model to call the barcode data for the report.


	
Initialize the barcode JavaBean and set its properties by editing the JSP code in the Web Source view.


	
Run your report to the Web to view the output in a browser.







To see a sample paper report with a barcode, open the examples folder named barcodebeanpaper, then open result\shipping_manifest.pdf. To see a sample Web-based JSP report with a barcode, open the examples folder named barcodebeanweb, then open result\shipping_manifest_web.jsp. For details on how to open these reports, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 43-1.


Table 43-1 Example report files

	File	Description
	
barcodebeanpaper\result\

shipping_manifest.pdf

	
The final PDF version of the paper report, containing the barcode.


	
barcodebeanpaper\result\

shipping_manifest.rdf

	
The final RDF version of the paper report, containing the barcode.


	
barcodebeanpaper\scripts\

oraclebarcode.jar

	
The barcode JavaBean.


	
barcodebeanpaper\scripts\

barcode_code.txt

	
All the code used in this chapter, so you can copy and paste the code from this file instead of typing it manually.


	
barcodebeanpaper\source\

shipping_manifest.rdf

	
The source file for the sample paper report. Running this RDF in Reports Builder will display the final result of your paper report in the Paper Design view.


	
barcodebeanweb\result\

shipping_manifest_web.jsp

	
The final JSP version of the Web report, containing the barcode.


	
barcodebeanweb\result\

shipping_manifest_web.rdf

	
The final RDF version of the Web report, containing the barcode.


	
barcodebeanweb\result\

assets

	
The images that Oracle Reports generated when the JSP was run.


	
barcodebeanweb\scripts\

sql.txt

	
The SQL for the query you need to enter.


	
barcodebeanweb\scripts\

barcode_code.txt

	
All the code used in this chapter, so you can copy and paste the code from this file instsead of typing it manually.


	
barcodebeanweb\source\

shipping_label.html

	
The HTML page that you will use as a basis for the Web report.


	
barcodebeanweb\source\

shipping_manifest_web.rdf

	
The source file for the sample Web report. Running this RDF in Reports Builder to the Web will display the final result of your Web report in your browser.


	
barcodebeanweb\source\

assets\*

	
The images and other files that your JSP-based Web report will require to display properly on the Web.


	
barcodebeanweb\source\

assets\blaf_beige_logo.gif

	
The image you will use in your JSP-based Web report.










33.7 Summary

Congratulations! You have successfully created an invoice report. You now know how to:

	
create two queries with a data link between them.


	
add two summary columns and a formula column to the data model to include on the invoice.


	
prepare a report layout for adding information onto an image of an invoice.


	
create and position fields in the correct locations on an invoice form.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".





31 Building a Check Printing Report with Spelled-Out Cash Amounts

In this chapter, you will learn about reports that format output as checks with cash amounts spelled out in words. By following the steps in this chapter, you can generate the report output shown in Figure 31-1.


Figure 31-1 Check printing report output

[image: Description of Figure 31-1 follows]







Concepts

To spell out the value of a check, you use a PL/SQL function to split the number into its constituent numerals, then use a formula column to combine the words into the spelled-out cash amount.




	
Note:

Many of the concepts in this example are used in the following example reports:

	
This example, where you import an image of a check and use it as a guide to position fields in the Paper Layout view. In addition, you learn how to create a PL/SQL function that returns spelled-out numerical values.


	
Chapter 32, "Building a Report Using a Preprinted Form", where you learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form.


	
Chapter 33, "Building an Invoice Report", where you import an image of an invoice and use it as a guide to position fields in the Paper Layout view.













Data Relationships

	
This report uses two linked queries. The first query retrieves the information necessary for the check, and the second query retrieves the order details that will be printed on the check stub.


	
One of the queries you will create assumes that the numbers to be spelled are stored in the TOTAL column of the ORDERS table. The text of the spelled-out number will be fetched from the table called Lookup, and returned in the Thousands_text, Thousands_Symbol, Ones_text, and Decimal_Text columns





Layout

This report uses a default Form style.


Example Scenario

In this example, you will use the Report Wizard to create your basic report definition. You will create a PL/SQL function that spells out the numerical value of the check amount. You will also create a formula column that formats the dollar amounts on your checks. You will import an image of a blank check image, and use the tools in the Paper Layout and Paper Design views to rearrange the fields in your report according to how you want them to display on the resulting check printing report. You will also use these tools to create a stub for every check.

As you build this example report, you will:

	
Create a Report Using the Report Wizard to create a simple form report.


	
Create a Formula Column That returns the Spelled-Out Cash Amounts using the PL/SQL Editor and the Data Model view.


	
Create a Query That Returns the Items in the Order using the Data Model view to create a second query and link the two queries together.


	
Import a Check Image and Arrange Fields for Printing using the Paper Layout view to import a blank check image and add fields necessary for printing the check and check stub. Use the Paper Design view to arrange the new fields on the blank check image.


	
Create a Check Stub With Payment Information and Order Details using the Paper Design view to create a check stub and the Report Block Wizard to create a simple tabular report that displays order details.




To see a sample report where the cash amounts are spelled out, open the examples folder named spellcash, then open the Oracle Reports example named spellcash.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.



41 Building a Paper Report with REF CURSORs

In this chapter, you will learn about reports that include the PL/SQL datatype REF CURSOR. By following the steps in this chapter, you can generate the report output shown in Figure 41-1.


Figure 41-1 REF CURSOR report output

[image: Description of Figure 41-1 follows]







Concepts

	
A REF CURSOR is a PL/SQL datatype that you can use in a query to fetch data. Each REF CURSOR query is associated with a PL/SQL function that returns a strongly typed REF CURSOR. The PL/SQL function must ensure that the REF CURSOR is opened and associated with a SELECT statement that has a SELECT list that matches the REF CURSOR type. You base a query on a REF CURSOR when you want to:

	
more easily administer SQL.


	
avoid the use of lexical parameters in your reports.


	
share data sources with other applications.


	
increase control and security.


	
encapsulate logic within a subprogram.





	
If you use a stored program unit to implement REF CURSORs, you receive the added benefits that go along with storing program units in the Oracle database.


	
Reports Builder enables you to easily manage your queries by use of using REF CURSORs. For example, if you already have numerous queries built and you want to reuse those queries in your reports, you can simply use a REF CURSOR in your report data model to access those queries.


	
Figure 41-2 shows that you create a report with the SELECT statement in the REF CURSOR query of the report. It also shows that you can store the SELECT statement in a package in the database. Then, from the report, you can call the database package allowing you to reuse the package in many reports.


Figure 41-2 Overview of the REF CURSOR example

[image: Description of Figure 41-2 follows]









Example Scenario

In this example, you will learn how to use REF CURSORs in Reports Builder to create a detailed paper report showing information about employees and the job position they hold in each department. You will use the Data Model view to create a multiquery data model, and then use the Report Wizard to create the report layout. You will make fairly extensive manual refinements in the Data Model view.

As you build this example report, you will:

	
Define a REF CURSOR Type by creating package specs that define REF CURSORs.


	
Create a REF CURSOR Query that will use the REF CURSORs.


	
Refine the Data Model by renaming objects so that they have more meaningful names.


	
Create Links Between REF CURSOR Queries to create relationships between them.


	
Add Summary Columns that better describe the data.


	
Create a Layout using the Report Wizard.


	
Move the SELECT Statements Into Packages that define the REF CURSOR types.


	
Move the Packages Into a Library so that other reports can share the code.




To see a sample report with REF CURSORs, open the examples folder named refcursor, then open ref_emp68.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 41-1.


Table 41-1 Example report files

	File	Description
	
refcursor\ref_emp*.rdf

	
The different stages of the RDF. You can refer to these files as you complete each section of this chapter. The file ref_emp68.rdf is the final report.


	
refcursor\refcursor_code.txt

	
The PL/SQL code you will write in this chapter. You can use this file as a reference point to make sure your code is accurate, or you can simply copy and paste from this file into Reports Builder.










6.2 Use the Report Wizard to Create a Mailing Label Report

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the simple report in this example, you can use the Report Wizard. Using the wizard enables you to define the layout for the report, as well as set the data definition.


To create a simple mailing label report:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Mailing Label, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, click Query Builder.


	
In the Select Data Tables dialog box, click the EMPLOYEES table, then click Include.


	
Click the DEPARTMENTS table, then click Include.



	
Note:

In this case, you must include the DEPARTMENTS table since the EMPLOYEES and LOCATIONS tables are not directly related in the schema.








	
Click the LOCATIONS table, then click Include.


	
Click Close.

The three tables display in the Query Builder.


	
In the EMPLOYEES table, select the check boxes next to the following column names:

	
FIRST NAME


	
LAST NAME


	
EMPLOYEE ID





	
In the LOCATIONS table, select the check boxes next to the following column names:

	
STREET ADDRESS


	
POSTAL CODE


	
CITY


	
STATE PROVINCE


	
LOCATION ID





	
Click OK.


	
In the Data Source definition field, your query should look something like this:


SELECT ALL EMPLOYEES.EMPLOYEE_ID, EMPLOYEES.FIRST_NAME, 
EMPLOYEES.LAST_NAME, LOCATIONS.STREET_ADDRESS, LOCATIONS.POSTAL_CODE, 
LOCATIONS.CITY, LOCATIONS.STATE_PROVINCE, LOCATIONS.LOCATION_ID
FROM EMPLOYEES, DEPARTMENTS, LOCATIONS
WHERE ((EMPLOYEES.DEPARTMENT_ID = DEPARTMENTS.DEPARTMENT_ID)
 AND (DEPARTMENTS.MANAGER_ID = EMPLOYEES.EMPLOYEE_ID)
 AND (DEPARTMENTS.LOCATION_ID = LOCATIONS.LOCATION_ID))




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called mailinglabel_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually, as described in the steps above.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 6.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Text page, format the way you want the mailing labels to display. Steps 21 through 30 will show you how to display your labels in the following format:


John Smith
55 Main Street
Springfield, ME 00000


	
In the Available Fields list, click FIRST_NAME, then click the right arrow (>) to move this field to the Mailing Label list.


	
In the Available Fields list, click LAST_NAME, then click the right arrow (>).


	
Click New Line.


	
In the Available Fields list, click STREET_ADDRESS, then click the right arrow (>).


	
Click New Line.


	
In the Available Fields list, click CITY, then click the right arrow (>).


	
Press Backspace on your keyboard to remove the extra space.


	
Click Comma.


	
In the Available Fields list, click STATE_PROVINCE, then click the right arrow (>).


	
In the Available Fields list, click POSTAL_CODE, then click the right arrow (>).

The code in the Mailing Label Text box should look like this (if necessary,add spaces as shown):


&<FIRST_NAME> &<LAST_NAME> &<STREET_ADDRESS> &<CITY>, &<STATE_PROVINCE> &<POSTAL_CODE> 





	
Tip:

For more information on formatting your mailing labels, click Help on this page of the Report Wizard.










	
Click Next.


	
On the Template page, select No Template and click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 6-2 Paper Design view for the mailing label report

[image: Description of Figure 6-2 follows]






	
Save your report as mailinglabel_your_initials.rdf.









15.5 Modify the Layout of the Report

In this section, you will change the field to expand vertically if the contents of the break field are longer than the specified width. As you can see in Figure 15-6, the width of the fields are fixed, but the names are incomplete. You will also add space to display between each record in the report.


To modify the layout:

	
In the Object Navigator, double-click the repeating frame icon next to the R_G_NAME node under Paper Layout > Main Section > Body > M_G_Name_GRPFR, to display the Property Inspector.


	
Under Repeating Frame, change the Vert. Space Between Frames to 0.25, then press Enter.


	
Close the Property Inspector.


	
In the Object Navigator, under the Paper Layout node, navigate to Main Section > Body > M_G_NAME_GRPFR > R_G_NAME.


	
Double-click the icon next to the F_CUST_LAST_NAME field to display the Property Inspector.


	
Under General Layout, make sure the Vertical Elasticity property is set to Expand, then close the Property Inspector to accept your changes.


	
Follow steps 5 and 6 for the F_CUST_FIRST_NAME field.




You have now modified the layout of your report to display all the text in the wrapped fields, and added space between the records.






14.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






15.2 Create a Query in the Data Model View

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. In this example, you will use the Data Model view to create your two queries, then use the tool palette to create a data link between the two queries to relate the data tables.


To create the query:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Build a new report manually, then click OK.


	
In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT ALL CUSTOMERS_A1.CUST_FIRST_NAME, 
  CUSTOMERS_A1.CUST_LAST_NAME, ORDERS.ORDER_ID, ORDERS.ORDER_TOTAL
FROM CUSTOMERS CUSTOMERS_A1, ORDERS
WHERE (ORDERS.CUSTOMER_ID = CUSTOMERS_A1.CUSTOMER_ID) 
ORDER BY CUSTOMERS_A1.CUST_LAST_NAME




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called wrappedbreak_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.











	
Click OK to display the data model for your new query in the Data Model view. It should look like this:


Figure 15-2 Data Model for the query

[image: Description of Figure 15-2 follows]






	
In the G_CUST_FIRST_NAME group, click CUST_FIRST_NAME and drag it above the group to create another group.


	
Click CUST_LAST_NAME, then drag it into the new group, so that the data model now looks like this:


Figure 15-3 Data model with groups

[image: Description of Figure 15-3 follows]






	
Double-click the new group (G_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to G_Name.




Your data model should now look like this:


Figure 15-4 Data model with new G_Name group

[image: Description of Figure 15-4 follows]






	
Save your report as wrappedbreak_your_initials.rdf.









43.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Order Entry sample schema provided with the . If you do not know if you have access to this sample schema, contact your database administrator.



43.1.1 Update the REPORTS_CLASSPATH environment variable

Before you use a JavaBean (for a paper-based or JSP-based Web report), you need to perform several steps.

In this section, you will update the REPORTS_CLASSPATH environment variable with the location of the JavaBean. When you launch Reports Builder, it will use this new class path to recognize the location of the barcode bean.




	
Note:

You must follow the steps in this section before you can even run the finished report we have provided, called ShippingManifestPaper.rdf and ShippingManifestWeb.rdf.









	
Find the REPORTS_CLASSPATH environment variable:

	
On Windows, open the registry from a command prompt by typing regedit and locate the REPORTS_CLASSPATH environment variable. You may want to make a backup of your registry before modifying it.


	
On UNIX, locate the REPORTS_CLASSPATH environment variable in ORACLE_HOME/bin/reports.sh.





	
Append the location of the oraclebarcode.jar file to the existing entries in REPORTS_CLASSPATH, for example:

	
On Windows:


Examples\BarcodeBeanPaper\scripts\oraclebarcode.jar


	
On UNIX:


Examples/barcodebeanpaper/scripts/oraclebarcode.jar






	
Note:

The path depends on where the files are located. If you downloaded the files from the Oracle Technology Network (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), you may have to further edit this path. Also, when you edit the Windows registry, make sure you separate your entries with a semicolon (;), with no spaces on either side of the semicolon.










You are now ready to begin building your report. To learn how to create a paper-based barcode report, refer to Section 43.2, "Create a Barcode Report for Paper". To learn how to create a JSP-based barcode report for the Web, refer to Section 43.3, "Create a Barcode Report for the Web".







24 Building a Report with Dynamic Graphics

In this chapter, you will learn about reports that include graphics that change depending on the data. By following the steps in this chapter, you can generate the report output shown in Figure 24-1.


Figure 24-1 Dynamic graphics report output

[image: Description of Figure 24-1 follows]







Concepts

Oracle Reports enables you to link to and display drawings and images that are "dynamic." That is, any changes made to the graphics will be reflected in your report output at runtime.


Data Relationships

	
One way to display dynamic graphics in a report involves creating a database column that stores the names of the graphic files you want to display. You do this in the Data Model view.


	
In the Data Model view, Oracle Reports provides a property called Read from File that enables you to pull the latest versions of the graphics into your report. When you set the Read from File property for a column listing file names, Oracle Reports displays the graphic contained within the named file, rather than the file name itself. Doing so enables Oracle Reports to pull into the report the latest version of the graphic at runtime.


	
Another way to include dynamic graphics in your report is to use the File Link tool in the Paper Layout view. This tool enables you to create a boilerplate object used to contain an external file, such as graphics and text. This example does not show you how to use this method, but you can read more about this tool in the Oracle Reports online Help.





Layout

This report uses a simple Group Above layout.


Example Scenario

In this example, you will create a simple report using the Group Above layout to display data about an employee, showing a different image depending on the location of the employee's department.

As you build this example report, you will:

	
Create the Data Model with Two Linked Queries manually in the Data Model view.


	
Create the Layout of the Report, first using the Reports Wizard, then making modifications in the Paper Layout view.


	
Run your Report to Paper




To see a sample report containing dynamic graphics, open the examples folder called dynamicgraphics, then open the Oracle Reports example report named dynamicgraphics.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




9.3 Format Fields

In the Paper Design view, notice the Total field. The values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.


To assign a format mask to monetary values:

	
In the Paper Design view, select the first number value underneath the Dollars label. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.



	
Tip:

If you are familiar with format mask syntax, you could now right-click the field values, choose Property Inspector, and choose or manually enter a value for the Format Mask property.








	
Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.


	
Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.


	
Resize the field by clicking and dragging the rightmost handle of the field approximately 0.5 inches (1.5 centimeters) to the left.


	
Click the Align Right button. All of the values are immediately right aligned.


	
Select the Dollars label itself.


	
Click the Align Right button.


	
Select the number value to the right of the Total: label.


	
Click the Currency button. A currency symbol immediately appears next to all of the values.


	
Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.


	
Click the Align Right button. All of the values are immediately right aligned.


Figure 9-4 Summary report output with monetary values formatted

[image: Description of Figure 9-4 follows]






	
Go to the end of the report. The last value on the last page should be a summary labelled Total:, which sums the values of TOTAL across the entire report.


	
Select the unformatted number to the right of the Total: label.


	
Click and drag this field until its right edge is aligned with the right edge of the values in the Total column.


	
Click the Currency button in the toolbar. A currency symbol immediately appears next to the Total value.


	
Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.


	
Click the Align Right button. All of the values are immediately right aligned.


	
Save the report as summaryb_your_initials.rdf.


Figure 9-5 Summary report with report total formatted

[image: Description of Figure 9-5 follows]













25.7 Add a Grid

Sometimes matrix reports are easier to read when they have grid lines that divide the cells from each other. For most objects, No Line is the default setting. To add grid lines, all you need to do is select the appropriate objects and give them a line color.


To add grid lines

	
Open the matrix report which you previously modified to show zeroes instead of blanks.


	
In the Object Navigator, double-click the view icon next to the Paper Layout node to display the Paper Layout view.


	
In the Object Navigator, choose View > Change Views > Object Type View.


	
Select all of the following objects in the Object Navigator under the Paper Layout node using Ctrl-click:

	
F_SUMSUM_SALPERDEPTNO


	
F_SUMSUM_SALPERJOB


	
F_SUMSUM_SALPERREPORT


	
F_SUM_SAL


	
B_1





	
Click the title bar of Paper Layout view to make it the active window.


	
In the Paper Layout view, click the Line Color tool in the tool palette, and click a block that shows the color black.


	
Click the Paper Design button in the toolbar to display the Paper Design view. You should now see a grid around all of the cells in your matrix.


Figure 25-13 Matrix report output with a grid

[image: Description of Figure 25-13 follows]






	
Save your report as matrix1qb_your_initials.rdf









3.4 Part 4: Building Matrix Reports

This part of the manual explains how you can build various kinds of matrix reports.



3.4.1 Building a matrix report

A matrix report looks like a grid. As shown in the sample output below, it contains one row of labels, one column of labels, and information in a grid format that is related to both the row and column labels. (Matrix reports are also sometimes referred to as "crosstab" reports.)

In this example, you will build a matrix report that contains three additions to the basic matrix: summaries have been added, zeroes replace non-existent values in the cells, and the cells themselves are surrounded by grid lines. Of the summaries, one sums the salaries by department, one sums them by job, and one sums them for the whole report.


Figure 3-23 Final output of the matrix report example

[image: Description of Figure 3-23 follows]






For more information on building this example, refer to Chapter 25, "Building a Matrix Report".






3.4.2 Building a nested matrix report

In this example, you will build the nested matrix report shown below. The cross product is capable of displaying every possible value for three dimensions: two down (YEAR and DEPTNO) and one across (JOB). This method does not include rows that have null values.


Figure 3-24 Final output of the nested matrix report example

[image: Description of Figure 3-24 follows]






For more information on building this example, refer to Chapter 26, "Building a Nested Matrix Report".






3.4.3 Building a matrix with group above report

In this example, you will build a report that shows department, job, and salary information for each employee by the year they were hired using a matrix break format.


Figure 3-25 Final output of the matrix with group above report example

[image: Description of Figure 3-25 follows]






For more information on building this example, refer to Chapter 27, "Building a Matrix with Group Above Report".







Part II



Building Group Reports

The chapters in this Part provide steps to build group reports. In these reports, the rows of output are displayed as groups based on a single query or on multiple queries. Group reports can contain formula columns and the values of the report can be printed from top to bottom or across a page.

	
Chapter 10, "Building a Single-Query Group Report"




A single-query group report contains a single query and divides the rows of a report into groups based on common values in one or more column(s). For example, employees can be grouped based on department numbers, which means each department number prints only once for every group. Otherwise, the department number would print once for every employee in the department. These reports include the group left and group above reports and were earlier known as break reports or master/detail reports.

	
Chapter 11, "Building a Two-Query Group Report"




A two-query group report appears much the same as a single-query group report except that the former report uses multiple queries. Multiple queries enable you to simplify maintenance or make the data model easier to understand.

	
Chapter 12, "Building an Across Group Report"




An across group report prints the values of a database column across the page instead of down. In these reports, the values in the master group print from top to bottom, and the values in the detail group print across the page, from left to right.

	
Chapter 13, "Building a Group Left Summary Report"




A group left summary report consists of master record values, detail records, and summaries. Summaries are totals calculated for the details under each master record.

	
Chapter 14, "Building a Group Left Formula Report"




A group left formula report contains a formula column, for which values are calculated based on a PL/SQL formula. A formula column, like a summary column, is a computational column that you create. This column performs user-defined calculations on other column(s) data including placeholder columns.




10.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






29.4 Modify Your JSP Report to Display in Microsoft Excel

Now that you have created your JSP-based Web report, which looks the same as your paper report, you will modify it further to display the report in Microsoft Excel in your Web browser.

First, copy myexcelreport_your_initials.jsp to the deployment directory of your Application Server. For testing purposes, in this example, we will use the Oracle WebLogic Server instance shipped with the Oracle Developer Suite.

For more information on deploying a JSP-based Web report, refer to the section "Deploying Your Reports" in the chapter "Running Report Requests" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual


To modify the report to display in Microsoft Excel:

	
In the Report Editor, click the Web Source button in the toolbar to display the Web Source view.

In the Web Source view, you will change the content type of the HTTP response using the JSP directive contentType, so that the browser opens Microsoft Excel to display your report output.


	
In the Web Source view, find the following text:


<%@ taglib uri="/WEB-INF/lib/reports_tld.jar" prefix="rw" %>
<%@ page language="java" import="java.io.*" errorPage="/rwerror.jsp"
session="false" %>
<%@ page contentType="text/html;charset=ISO-8859-1" %>
<rw:report id="report">
<rw:objects id="objects">
</rw:objects>
......
......
<!--
</rw:report>
-->


and modify it to read as follows:


<%@ taglib uri="/WEB-INF/lib/reports_tld.jar" prefix="rw" %>
<%@ page language="java" import="java.io.*" errorPage="/rwerror.jsp"
session="false" %>
<%@ page contentType="application/vnd.ms-excel;charset=ISO-8859-1" %> 
<rw:report id="report">
<rw:objects id="objects">
</rw:objects>
......
......
<!--
</rw:report>
-->


	
Save your report.


	
Copy the Web report (myexcelreport_your_initials.jsp)into the following directory:


$DOMAIN_HOME\servers\MANAGED_SERVER_NAME\stage\reports\reports\web.war


	
Start your Oracle WebLogic Server instance to enable the deployment of your report.

	
On Windows, you can do either of the following:

	
From the Start menu, choose Programs > Oracle Classic Instance > Reports Services > Start WebLogic Server - WLS_REPORTS.

For example, the Oracle Classic Instance may be Oracle Classic Instance-asinst_1.


	
From the command line, run the following command:

cd $DOMAIN_HOME\bin\startManagedServer.bat WLS_REPORTS





	
On UNIX, start the shell script from the command line:

	
$DOMAIN_HOME\bin\startManagedServer.sh WLS_REPORTS










	
Tip:

The Oracle WebLogic Server instance starts once the containers for Java EE have been initialized.










	
Type the following URL to display your report in Microsoft Excel in your Web browser:


http://your_computer:port/reports/yourexcelreportname.jsp?userid=hr/hr@db


In our example, we use:


http://mycomputer-pc:8888/reports/my_excel_report.jsp?userid=hr/hr@orcl





	
Note:

The connect string you type in the URL is for the database you used to create the data model in Section 29.2, "Create a Query and the Layout". For the purposes of this example, we have used plain text to pass the connect string. For information on using security, refer to the chapter "Securing Oracle Reports Services" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.










	
The report runs, and the browser displays your report in Microsoft Excel.




	
Note:

If you want your report to display the same colors in Excel as in your report definition, you must use colors supported by the Excel color palette. Otherwise, Excel tries to match unsupported colors, but the match may not be what you expect.









Your final report output should look something like this:


Figure 29-4 Microsoft Excel Output of Your Report

[image: Description of Figure 29-4 follows]












Preface

This manual will help you learn about the extensive capabilities of Reports Builder (the report-building component of Oracle Reports), how to build different types of reports, and how to customize your reports to meet a wide variety of requirements.


Audience

This manual is intended for anyone who uses Oracle Reports to build reports. The needs of both novice and advanced users are addressed. Following the step-by-step instructions, you can build the example reports from start to finish. Each report that you build will demonstrate how to use many of the powerful features in Reports Builder.


Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.


Access to Oracle Support

Oracle customers have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.


Related Documentation

For more information about Oracle Reports, refer to the following resources:

	
Oracle Reports Tutorial


	
Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services


	
Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".





Conventions

The following text conventions are used in this document:


	Convention	Meaning
	
boldface

	
Boldface type indicates graphical user interface elements associated with an action, or terms defined in text or the glossary.


	
italic

	
Italic type indicates book titles, emphasis, or placeholder variables for which you supply particular values.


	
monospace

	
Monospace type indicates commands within a paragraph, URLs, code in examples, text that appears on the screen, or text that you enter.


	
monospce italic

	
Monospace italic type indicates variables or user-supplied names.


	
[ ]

	
Brackets enclose optional clauses from which you can choose one or none.









Accessing the Example Reports

The supporting files for the reports you will build are available on the Oracle Technology Network (OTN). On the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to the Learn More tab, and click Getting Started. The Getting Started with Oracle Reports home page will be displayed. In the list of topic sections on the left, click Index. In the Topic list, choose Building and Developing Reports; in the Collateral Type list, choose Examples, then click Search. In the list of topics that displays, find Building Reports sample files and click the Download icon to download a zip file, called buildingreports_examples.zip. This zip file contains subfolders that correspond to the names of each chapter. Each of the subfolders contains all the supporting files (example reports, images, SQL query code, and so on) necessary for building the individual reports. Extract this zip file into ORACLE_HOME\examples (for example, D:\orawin\examples).

Additionally, the remaining examples in Getting Started with Oracle Reports provide a Web-based selection of examples in this manual, as well as examples not covered in this manual.


Accessing the Data Sources

The data sources used in this manual are:

	
SCOTT schema


	
Sample Human Resources, Sales History, and Order Entry schemas


	
Summit Sporting Goods (SUMMIT) schema




The SCOTT, Human Resources, Sales History, and Order Entry schemas are available with the Oracle Database. You can contact your database administrator for more information on where to find these schemas. You can download the SQL scripts to install the Summit Sporting Goods (SUMMIT) schema from the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Topic list, choose Building and Developing Reports; in the Collateral Type list, choose Tools/Utilities, then click Search. In the list of tools and utilities that displays, click the Download icon to download the SQL scripts to install the SUMMIT sample schema.
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29.3 Modify the Web source of Your JSP Report

Now that you have created your paper report layout, you will learn how to take the same report and generate a JSP-based Web report that looks the same as your paper report.


To modify your JSP-based Web report:

	
In the Report Editor, click the Web Source button in the toolbar to display the Web Source view.

In the Web Source view, you need to change the dummy JSP code created by Oracle Reports Builder.


	
In the Web Source view, find the text:


<rw:dataArea id="yourDataArea">
   <!-- Report Wizard inserts the default jsp here -->
</rw:dataArea>




	
Tip:

Choose Edit > Find and Replace, then type dataArea in the Find what text box.








	
Ensure that you place the cursor in between the opening and closing <rw:dataArea> tags, and choose Insert > Frame. This inserts the following code in your Web Source view:


<rw:include id="include" src="..."> </rw:include>





	
Note:

The rw:include tag enables you to include the outer frame of your paper layout in the Web Source view as JSP code. Adding a rw:include tag to the rw:dataArea tag enables you to include and reuse the existing paper layout in a Web layout.










	
In the Object Navigator, locate the top level layout object frame of your paper layout. Specify its name in the src attribute of rw:include tag. The line should look like this:


<rw:dataArea id="yourDataArea">
   <!-- Report Wizard inserts the default jsp here -->
<rw:include id="mypaperreport_id" src="M_G_EMPLOYEE_ID_GRPFR">
</rw:include>
</rw:dataArea>


	
Click the Run Web Layout button in the toolbar to display your new JSP-based Web report in your browser. The report should look something like this:


Figure 29-3 Web Design Output

[image: Description of Figure 29-3 follows]






The report displays, in Web format, the employee data you specified. Here, you can see employee details, such as their name, email, hire date, salary, department to which they belong and their location.


	
Save your report as myexcelreport_your_initials.jsp.








14 Building a Group Left Formula Report

In this chapter, you will learn about group left formula reports, containing formula columns. By following the steps in this chapter, you can generate the report output shown in Figure 14-1.


Figure 14-1 Formula report output

[image: Description of Figure 14-1 follows]







Concepts

	
A formula column, like a summary column, is a computational column you create yourself. Unlike a summary, its values are calculated based on a PL/SQL formula you provide. The formula may use data from another column in the report, but is not required to do so.


	
A formula column performs a user-defined computation on another column(s) data, including placeholder columns. Formula columns should not be used to set values for parameters.


	
A formula column contains at least one column whose value or values are computed using a PL/SQL formula. Formula columns are similar in usage to summary columns.


	
For more information on formula columns, refer to the Oracle Reports online Help .





Data Relationships

	
To create a formula report, create a query and select your data. Next, create additional columns and add them to groups in your report. Specify their formulas in the column property sheets.


	
As with summaries, you do not select formulas from the database. unlike summaries, which use packaged computations shipped with Oracle Reports, formula columns use formulas you provide by referencing PL/SQL functions. These formulas can be any legal PL/SQL constructs, which allow a great deal of flexibility in the formulas you use.


	
A formula performs computations using data from a single record, which can span multiple columns. This is in contrast to a summary, which summarizes the data from multiple records in a single column.





Layout

This report uses the default group left format with no modifications.


Example Scenario

As you build this example report, you will:

	
Use the Report Wizard to Create a Simple Report with Group Left style that includes one query that selects all the necessary database columns.


	
Create Two Formula Columns manually to calculate tax and order totals for each customer, then add the formula columns to your report.




To see a sample formula report, open the examples folder called formula, then open the Oracle Reports example report named formula.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




9.4 Examine the Summary Column Properties (optional)

In this case, the Report Wizard created the summaries according to the requirements of the project. However, in some cases, you may need to manually adjust the settings of summaries to get the exact calculations you wish. By carefully reviewing the summaries created by the Report Wizard, you can gain a better understanding of how summaries work.

In this section, you will not be making any changes to the report, you will only be checking the summary settings to better understand summaries.


Reviewing summary settings

	
In the Paper Design view, select the percentage value to the right of the % of Total label.


	
Double-click the values to display the Property Inspector.


	
In the Property Inspector, notice the Source property, which indicates the column that is the source of the field.


	
Repeat steps 1 through 3 for all of the summaries in the report. Note down the name of the columns that are the sources for each of these summary fields.


	
In the Object Navigator, double-click the view icon next to the Data Model node to display the Data Model view.


	
In the Data Model view, double-click TotalTOTALPerSALES_REP_ID in group G_SALES_REP_ID to display the Property Inspector.


	
In the Property Inspector, notice the values of the properties under Summary:

	
Function is % of Total. Change % of Total to Sum. Note that the Compute At property disappears because it is unnecessary for a Sum calculation. Change Function back to % of Total and Compute At reappears.


	
Source is the TOTAL column, which means that TOTAL is used to compute the summary.


	
Reset At is G_SALES_REP_ID. The value of TotalTOTALPerREPID will reset to zero after each record in G_SALES_REP_ID (that is, for each sales representative).


	
Compute At is Report. A compute level of Report means that the TotalTOTALPerSALES_REP_ID column will base its percentages on the sum of all of the TOTAL in the entire report.





	
Repeat steps 6 and 7 for each of the summaries in the data model. Notice the differences in the properties for each of the summaries.


	
It can also be a useful exercise to return to the Paper Design view and see where fields that correspond to the summaries are placed in the layout. For example, the field that corresponds to TotalTOTALPerSALES_REP_ID is placed inside the master repeating frame, R_G_SALES_REP_ID, but outside of the detail repeating frame, R_G_CUSTOMER_ID.









3.3 Part 3: Building Reports with Special Formatting

This part of the manual explains how you can build reports with special formats.



3.3.1 Building a wrapped field report

In this example, you will build a break report where the line wraps on word boundaries if it is too long to fit on one line.


Figure 3-12 Final output of the wrapped field report example

[image: Description of Figure 3-12 follows]






For more information on building this example, refer to Chapter 15, "Building a Wrapped Field Report".






3.3.2 Building a header and footer report

In this example, you will build a report that has a page header printed in the upper margin area of every page of the report, and a footer printed at the end of the list of employee information for each department.


Figure 3-13 Final output of the header and footer report example

[image: Description of Figure 3-13 follows]






For more information on building this example, refer to Chapter 16, "Building a Header and Footer Report".






3.3.3 Building a header with database values report

In this example, both the first and last department numbers found on each page are displayed in the page header.


Figure 3-14 Final output of the header with database values report example

[image: Description of Figure 3-14 follows]






For more information on building this example, refer to Chapter 17, "Building a Header with Database Values Report".






3.3.4 Building a report with graphics, text, and color

In this example, you will build a report and enhance it by adding an image to the margin, a title, and a border. You will also change the look of the report by applying different fonts and text styles.


Figure 3-15 Final output of the graphics, text, and color example

[image: Description of Figure 3-15 follows]






For more information on building this example, refer to Chapter 18, "Building a Report with Graphics, Text, and Color".






3.3.5 Building a report that renumbers pages by repeating frame

In this example, you will build a report that numbers pages using the format "Page X of Y Pages". The first number (X) corresponds to the current page for each parent record (that is, each sales representative). This page number is reset to "1" for each sales representative, thus tracking the statistics of each representative separately.


Figure 3-16 Final output of the renumbering pages by repeating frame example

[image: Description of Figure 3-16 follows]






For more information on building this example, refer to Chapter 19, "Building a Report that Renumbers Pages by Repeating Frame".






3.3.6 Building an intermixed fields report

In this example, you will build a report where the group field appears between its related fields. Normally, a group (break) field appears to the left of (in group left report) or above (in group above report) its related fields.


Figure 3-17 Final output of the intermixed fields report example

[image: Description of Figure 3-17 follows]






For more information on building this example, refer to Chapter 20, "Building an Intermixed Fields Report".






3.3.7 Building a report that suppresses labels

In this example, you will build a master/detail report that fetches a master record with no associated details. In the sample output below, notice how the field labels for Department 40 do not display because no detail records were found. In this chapter, you will learn how to suppress the detail information for a single record, but allow the other master/detail records to display.


Figure 3-18 Final output for the suppressing labels example

[image: Description of Figure 3-18 follows]






For more information on building this example, refer to Chapter 21, "Building a Report that Suppresses Labels".






3.3.8 Building a conditional form letter report

In this example, you will build two form letters from the same report, as shown in the sample output below. As you can see, the two letters share a number of features. Hence, it is more convenient to create a base form letter and then apply conditions to certain parts to determine whether they should be displayed for the current record, in this case, employees.


Figure 3-19 Final output for the first conditional form letter report example

[image: Description of Figure 3-19 follows]







Figure 3-20 FInal output for the second conditional form letter report example

[image: Description of Figure 3-20 follows]






For more information on building this example, refer to Chapter 23, "Building a Conditional Form Letter Report".






3.3.9 Building a report with conditional highlighting

In this example, you will learn how to highlight data in your report. In this report that shows employee salaries, salaries that are greater than or equal to 10,000 are displayed in bold and in red color, and values that are between 4,999 and 10,000 are displayed in bold. Using the Conditional Formatting dialog box in Reports Builder, you can create format triggers that will change the appearance of retrieved data depending on factors you define.


Figure 3-21 Final output of the conditional highlighting report example

[image: Description of Figure 3-21 follows]






For more information on building this example, refer to Chapter 22, "Building a Report with Conditional Highlighting".






3.3.10 Building a report with dynamic graphics

In this example, you will build an employee report with a bar graph that displays monthly revenues for the company. Since the data in it changes monthly, you cannot import or draw the graph.


Figure 3-22 Final output of the dynamic graphics report example

[image: Description of Figure 3-22 follows]






For more information on building this example, refer to Chapter 24, "Building a Report with Dynamic Graphics".







Part V



Building Reports for Business Cases

The chapters in this Part provide steps to build reports that are intended for specific business purposes. The examples provided include computing values over specified periods of time, collecting data over a specified range, and grading data. Following the steps, you will learn how to print reports on preprinted forms (for checks or invoices), split a report into sections and distribute each section to a different destination, and include a simple table or contents and index, or a multilevel table of contents.

	
Chapter 28, "Building a Time Series Calculations Report"




A time series calculations report computes values over a specified period of time. You can use the techniques used for this report to produce other formats of time series calculations. For example, you can build a report that calculates and displays the quarterly average of purchases for each customer.

	
Chapter 29, "Building a Report for Enhanced Spreadsheet Output"




A paper report generated to spreadsheet output can be displayed in your browser. You can integrate the paper layout into a Web layout by modifying the Web source of your report, and then generate the output. You can then deploy this report with the Reports Server under Oracle WebLogic Server and display it in a spreadsheet utility (such as Microsoft Excel) inside your browser.

	
Chapter 30, "Building a Report with Aggregate Data"




A report with aggregate data collects data within a range, retrieves values from the database, and formats them based on an aggregate range defined. You can use parameters to specify the range over which the data should be collected.

	
Chapter 31, "Building a Check Printing Report with Spelled-Out Cash Amounts"




A check printing report contains a stub and spelled-out cash amounts. You can create a PL/SQL function that returns spelled-out numerical values, imports an image of a preprinted form (such as a blank check image), and prints your report on the form.

	
Chapter 32, "Building a Report Using a Preprinted Form"




A report using a preprinted form enables you to use formatting techniques to print reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in the exact positions on the form.

	
Chapter 33, "Building an Invoice Report"




An invoice report displays several distinguishing characteristics of a typical invoice, such as customer name and address, sales order number, billing information, and billing totals. You can import an image and print your report on a preprinted form.

	
Chapter 34, "Building a Ranking Report"




A ranking report grades data in two different ways: by count and by percentage. You can set the ranking criteria at runtime or let the criteria default to previously specified values.

	
Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index"




Navigational tools, such as a simple table of contents and an index, can be added to a paper report. First, the page numbering must be determined for the entire report, then Oracle Reports Builder can generate the table of contents and index based on the established page numbering.

	
Chapter 36, "Building a Paper Report with a Multilevel Table of Contents"




A multilevel table of contents can be added to a paper report to facilitate navigation. This table of contents is created similarly to that in Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index", however with a hierarchy that categorizes the information in the table of contents.

	
Chapter 37, "Bursting and Distributing a Report"




A report built for bursting and distributing a report enables you to simultaneously deliver a single report to multiple destinations. You can create a single report, burst each section to a separate report, and then send each section in any format (such as, PDF or HTML) to multiple destinations.

	
Chapter 38, "Building a Report with Multibyte Characters for PDF Output"




A multibyte character report can display text in virtually any language. You can produce reports that display text in multibyte character sets, such as Simplified Chinese, Traditional Chinese, Japanese, Korean, and Unicode.




20.3 Add a Formula Column

To have the department names appear in the center of this group report, it is simplest to have a column in the detail group for the department names. To achieve this result, you must create a formula column in the detail group that will display the department names.


To add a formula column:

	
Click the Data Model tool in the toolbar to display the Data Model view.


	
In the Data Model view, resize the G_ENAME group to be large enough to contain a third column.


	
Click the Formula Column tool in the tool palette.


	
Click in the G_ENAME group to create a formula column.


	
Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to DEPARTMENT.


	
Under Column, set the Datatype property to Character, and set the Width property to 14.


	
Under Placeholder/Formula, double-click the PL/SQL Formula property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, at the flashing cursor (after the word begin), type the following:


return(:dname);


	
Click Compile.


	
Click Close.


	
Click the title bar of the Report Editor to make it the active window again.








35 Building a Paper Report with a Simple Table of Contents and Index

In this chapter, you will learn about reports that include a simple table of contents and index.




	
Note:

Generating a table of contents or index is not supported for matrix reports.









By following the steps in this chapter, you can generate the report output shown in Figure 35-1 and Figure 35-2.


Figure 35-1 Simple table of contents for a large report

[image: Description of Figure 35-1 follows]







Figure 35-2 Simple index for a large report

[image: Description of Figure 35-2 follows]







Concepts

	
When you have large paper report, it is sometimes easier for your users to navigate through the report if you include a table of contents. Using Reports Builder, you can generate a table of contents that displays at the beginning of your paper report.


	
Normally, Reports Builder formats the report starting with the Header section, then the Main section, followed by the Trailer section. With the functionality demonstrated in this example report, Reports Builder can format any section first to create information that is only known at the time of formatting, such as page numbers, then use that information in the formatting of a previous section.


	
In this example, you will use the built-in procedure called SRW.SET_FORMAT_ORDER to generate the Main section of the report first, then the Header and Trailer sections. Doing so enables you to generate the page numbers for the report in the Main section, then display the page numbers in the table of contents in the Header section.




	
Note:

Although you can use SRW.SET_FORMAT_ORDER to change the order in which the report is formatted, the report will still display the Header section first, then the Main section, and finally the Trailer section. You can use SRW.SET_FORMAT_ORDER to simply change the formatting order, but not the display order of the report sections.










	
You will use the After Parameter Form trigger and a format trigger to place the page numbers temporarily in a table you create in the database. You will then create a simple tabular report that displays at the beginning of your report, that lists the category and its page number. Finally, you will create an index that simply lists the record and the page number in the Trailer section of the report.




For information on creating a multilevel table of contents, refer to Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".


Example Scenario

In this example, you will generate a list of all the e-mail addresses for your customer database, which contains thousands of records. First, you want to categorize the customers (in this case, by country), then generate a table of contents so you can easily find the e-mail address for the desired customer. Then, you will learn how to create an index for your report.

As you build this example report, you will:

	
Create a Simple Table of Contents:

	
Create a table in the database to hold the TOC data using SQL*Plus.


	
Create a group above report using the Report Wizard.


	
Create an After Parameter Form trigger and a format trigger using the PL/SQL Editor to change the order in which the report sections are executed and fetch the page number for each record.


	
Create a second query in the data model with a formula column that calculates the page range for the data under each country name.


	
Create a report block to display the table of contents using the Report Block Wizard to create a tabular report block in the Header section to display the country name and page number.


	
Run your simple table of contents report to paper.





	
Create an Index:

	
Create a table in the database to hold the information for the index.


	
Create a format trigger to generate a page number for every customer record.


	
Add a query to the data model using the Data Model view to create another query that retrieves the necessary information for the index.


	
Create a report block to display the index in the Trailer section.


	
Run your report to paper.







To see a sample table of contents and index report, open the examples folder named tocindex, then open the Oracle Reports example named toc_index.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




30.4 Summary

Congratulations! You have successfully built a report that aggregates data, for both paper and Web. You now know how to:

	
create a report definition that aggregates data.


	
modify your report for the Web.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






27.6 Summary

Congratulations! You have successfully created a matrix group above report. You now know how to:

	
create a matrix group above report with a single-query data model.


	
add labels and line for summaries.


	
add some white space between the master records.


	
create a Web layout without changing the paper layout.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






20.4 Add a Field

Now that you have added the formula column to the data model, you need to add a corresponding field to display it. You can easily do this by invoking the re-entrant Report Wizard.


To add a field:

	
Choose Tools > Report Wizard.


	
On the Report Type page, select Create Paper Layout Only.


	
On the Fields page:

	
Click DEPARTMENT in the Available Fields list and click the right arrow (>) to move it to the Displayed Fields list.


	
Click and drag DEPARTMENT in the Displayed Fields list until it is located between ENAME and SAL.





	
Click Finish to preview your report output in the Paper Design view. It should look something like this:





Figure 20-4 Paper Design view of the intermixing fields report

[image: Description of Figure 20-4 follows]










30.3 Modify the Web Source of Your JSP Report

Now that you have created your paper report layout, you will now learn how to take the same report and generate a JSP-based Web report that looks the same as your paper report.


To modify your JSP-based Web report:

	
Save your report, aggregatereport_your_initials.rdf as a JSP under the same name (aggregatereport_your_initials.jsp).


	
Click the Web Source button in the toolbar to display the Web Source view.

In the Web Source, you need to change the column titles to match those of the paper report.


	
In the Web Source view, find the text:


<th <rw:id id="HBbottom" asArray="no"/> class="OraColumnHeader"> Bottom </th>




	
Tip:

Choose Edit > Find and Replace, then type "bottom" in the Find what text box.








	
Change the column header to "Salary" so that the line now looks like this:


<th <rw:id id="HBbottom" asArray="no"/> class="OraColumnHeader"> Salary </th>


	
The next line of code indicates the header for the "Top" column. Delete the header text so that the line looks like this:


<th <rw:id id="HBtop" asArray="no"/> class="OraColumnHeader">  </th>


	
Change the other two columns for Ename and Deptno as desired. For example, we changed them to "Name" and "Dept", like so:


<th <rw:id id="HBename" asArray="no"/> class="OraColumnHeader"> Name </th>
<th <rw:id id="HBdeptno" asArray="no"/> class="OraColumnHeader"> Dept </th>


	
Save your report as a JSP.


	
Click the Run Web Layout button in the toolbar to display your new JSP-based Web Report in your browser.




	
Note:

If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.









The report should look something like this:


Figure 30-7 Aggregating Data JSP-based Web Report

[image: Description of Figure 30-7 follows]






The report displays, in Web format, the aggregate data you specified. Here, you can see which employees fall into the specified salary ranges.




	
Note:

For information on creating a Parameter Form for a JSP-based Web report, refer to the documented example on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Examples, and click Search. In the list of examples that displays, click Building a JSP-based Web Report with a Parameter Form.

















27.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






37.4 Run the Report

You can distribute the report using a Web browser. Type the following command in the Location field of your browser:


http://host:port/reports/rwservlet?REPORT=your_path/inventory_report_dist_your_
initials.rdf&USERID=your_login_ID&SERVER=your_server_name&DISTRIBUTE=YES&
DESTINATION=your_path/distribution.xml


where

your_path is where your RDF file and the distribution.xml file is located. your_login_ID is your login information for the sample schema you have used with the sample RDF.

The SMTP mail server is set up during the installation process. If you did not specify a server during installation, you can set up the mail server manually before distributing your report to an e-mail destination. You can specify the outgoing mail server using pluginParam in the server config file.


EXAMPLE:
<pluginParam name="mailServer">smtp01.mycorp.com</pluginParam>


For more information on setting up the mail server, refer to the chapter "Configuring Oracle Reports Services" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

Running the report creates a file for each warehouse based on the warehouse ID in the specified directory. When the report is distributed, a single e-mail is sent to one address with all of these files attached to the e-mail.

If you set up the distribution.xml file for multiple e-mail addresses, each warehouse (or each e-mail address) would be sent a single e-mail with a single attachment file that includes the report for that warehouse.






4.12 Define a Template

This section provides procedures for the following tasks that you may perform as you define a report template:

	
Creating a template


	
Defining default template attributes


	
Defining override template attributes


	
Applying a template to a report


	
Formatting the report title in a template


	
Modifying the color, pattern, or border of body objects in a template


	
Adding a template to the pre-defined templates list






4.12.1 Creating a template

To create a template:

	
In the Object Navigator, click the Templates node, then click the Create button in the toolbar.


	
Define default template attributes for all report styles.


	
Optionally, define override template attributes for a selected report style.


	
To define system parameters, user parameters, report triggers, program units, and attached libraries for the template, double-click the associated nodes in the Object Navigator.





See also

Section 2.7.5, "About the Template Editor"

Section 2.7.1, "About templates"

Section 2.7.2, "About template attributes"

Section 2.7.3, "About applying templates"

Section 2.7.4, "About inheritance in templates"






4.12.2 Defining default template attributes

To define default attributes for report objects in a template that applies to all report styles:

	
In the Object Navigator, expand the Templates node, then the Paper Layout node, then the Section node, then the Body node, then the Default node.


	
To change default properties for the overall layout and spacing for report styles, double-click the properties icon next to the Default node to display the Property Inspector.


	
To change default properties for frames, field labels/headings, fields, summary labels, and summaries (totals), fully expand the Default node, then double-click the properties icons to display the Property Inspector.



	
Note:

The Paper Layout view is synchronized with the Object Navigator; when you select a layout object, the associated node is highlighted in the Object Navigator. To select the parent frame for a layout object, click the object, then click the Select Parent Frame button in the toolbar to select the parent frame.








	
In the Paper Layout view, select from the Report Style list to view the layout for individual report styles.


	
To make further changes for the currently displayed report style, either return to the Object Navigator, or double-click an object to display the Property Inspector.



	
Note:

Any changes you make for an individual report style will override the attributes defined under the Default node.











See also

Section 2.7.1, "About templates"

Section 2.7.2, "About template attributes"






4.12.3 Defining override template attributes

To define override attributes for a selected report style:

	
In the Object Navigator, expand the Templates node, then the Paper Layout node, then the Section node, then the Body node, then the Override node, then the node for the report style for which you want to define overrides (for example, Tabular, Group Left).


	
To change default properties for the overall layout and spacing for a section of the selected report style, double-click the properties icon next to the Section (Level n) node to display the Property Inspector.


	
To create more than the default number of sections for a particular report style, click a Section (Level n) node, then click the Create button in the toolbar.



	
Note:

Sections are mapped to groups in a report. For more information, see About template attributes.








	
To delete a section for a particular report, click a Section (Level n) node, then click the Delete button in the toolbar.



	
Note:

You can only delete nodes down to the minimum requirement for the current report style.








	
For each section for which you want to define overrides, fully expand the Section (Level n) node, then double-click the properties icons to display the Property Inspectors for the frames, field labels/headings, fields, summary labels, and summaries (totals).



	
Note:

The Paper Layout view is synchronized with the Object Navigator; when you select a layout object, the associated node is highlighted in the Object Navigator. To select the parent frame for a layout object, click the object, then click the Select Parent Frame button in the toolbar to select the parent frame.








	
In the Paper Layout view, select from the Report Style list to view the layout for individual report styles.


	
To make further changes for the currently displayed report style, either return to the Object Navigator, or double-click an object to display the Property Inspector.



	
Note:

Any changes you make for an individual report style will override the attributes defined under the Default node.











See also

Section 2.7.1, "About templates"

Section 2.7.2, "About template attributes"






4.12.4 Applying a template to a report

To apply a template to a report:

	
In the Object Navigator, click the report or report section to which you want to apply a template.



	
Note:

If you select the node for the entire report in the Object Navigator, the template will be applied to the Main section of the report by default. To apply the template to a specific section of your report, select the node for that section in the Object Navigator.








	
Choose Tools > Report Wizard.


	
On the Template page, select a pre-defined template, or click Template file, and click Browse to open the desired template.


	
Click Finish to apply the template to the current report section.





See also

Section 2.7.1, "About templates"

Section 2.7.3, "About applying templates"






4.12.5 Formatting the report title in a template

To set default attributes (such as font and color) for the title in a selected template:

	
In the Object Navigator, expand the Templates node, then the Paper Layout node, then the Section node, then the Body node, then the Default node.


	
Double-click the properties icon next to the Default node to display the Property Inspector.


	
Under Title, modify the properties as desired.




To set the placement and override attributes (such as font and color) for the title in a selected template:

	
In the Paper Layout view of the template, create a boilerplate text object for the title in the margin.


	
Size and position the title, and modify the color and text attributes as desired.


	
Double-click the title object to display its Property Inspector.


	
Under General Information, set the Name property to B_OR$REPORT_TITLE.





See also

Section 2.1.1, "About report titles"

Section 2.7.1, "About templates"






4.12.6 Adding items and objects to a template

To add items and objects to a template:

	
In the Paper Layout view of the Template Editor, click the Margin button in the toolbar to display the margin area.


	
Create objects in the margin of your template. You cannot create objects in the body of a template.





See also

Section 2.7.5, "About the Template Editor"

Section 2.7.1, "About templates"

Section 2.7.2, "About template attributes"

Section 2.7.4, "About inheritance in templates"






4.12.7 Modifying objects in the template margin

To modify objects in the margin of a template:

	
In the Paper Layout view of the Template Editor, click the Edit Margin button in the toolbar.


	
Modify objects in the margin of your template.





See also

Section 2.7.5, "About the Template Editor"

Section 2.7.1, "About templates"

Section 2.7.2, "About template attributes"

Section 2.7.4, "About inheritance in templates"






4.12.8 Modifying the color, pattern, or border of body objects in a template

Template objects can be modified using the same techniques as report objects. To change the color or pattern of objects in a template, however, you use the template Property Inspector, rather than the Color tools in the tool palette:

	
The Fill Pattern property defines the pattern to use for the space enclosed by the objects. You can define the background and foreground colors of the fill pattern using the Foreground Color and Background Color properties.


	
The Edge Pattern property defines the pattern to use for the borders of the objects. You can define the background and foreground colors of the edge pattern using the Edge Foreground Color and Edge Background Color properties.


	
The Text Color property specifies the text color to use for the object(s).





See also

Section 2.4.5, "About changing colors and patterns"

Section 4.9.6.2, "Changing colors"

Section 4.9.6.3, "Changing patterns"

Section 2.7.1, "About templates"






4.12.9 Adding a template to the pre-defined templates list

To add your own template to the list of predefined templates in the Report Wizard:

	
In a text editor (for example, Wordpad), open the preferences file:

	
On Windows, open $ORACLE_INSTANCE\config\FRComponent\frcommon\tools\admin\CAUPREFS.ORA (user preferences) if it exists; otherwise, open $ORACLE_INSTANCE\config\FRComponent\frcommon\tools\admin\CAGPREFS.ORA (global preferences).


	
On UNIX, open your_home_directory/prefs.ora (user preferences) if it exists; otherwise, open $ORACLE_INSTANCE/config/FRComponent/

frcommon/tools/admin/prefs.ora (global preferences).





	
Scroll down to the template descriptions identified by Reports.xxx_Template_Desc (where xxx specifies a report style: Tabular, BreakAbove, BreakLeft, FormLetter, Formlike, MailingLabel, Matrix, MatrixBreak).


	
For each report style for which the template is defined:

	
To the Reports.xxx_Template_Desc list, add the description that you want to appear on the Template page of the Report Wizard.


	
To the corresponding Reports.xxx_Template_File list, add the file name of your template in the same position as the addition you made to the description list.





	
Copy the template file (filename.tdf) to ORACLE_HOME/REPORTS/TEMPLATES.




To include a sample image of your template in the Report Wizard:

	
Copy or create the .bmp file you want to use as the image for the template and name it yyy.bmp, where yyy is the file name of your template.


	
Copy each .bmp file to ORACLE_HOME/REPORTS/TEMPLATES.





See also

Section 2.7.1, "About templates"

Section 2.7.3, "About applying templates"






4.12.10 Creating an HTML template for a report portlet

To create and use an HTML template for a report that can be published on an Oracle Portal page:

	
See the How To Create a Report Portlet Template in Getting Started with Oracle Reports white paper, available on the Oracle Technology Network Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html). Navigate to Learn More and Click Getting Started. In the list of topic sections on the left, click Index. On the Index page, in the Collateral Type list, choose White Papers & How To Documents, and click Search. In the list that displays, click Creating a Report Portlet Template.





See also

Section 2.7.1, "About templates"

Section 2.7.3, "About applying templates"








17.3 Add Summary Columns for the Header Data

For the header that you want to create (that is, departments found on this page), you need to create two summary columns that compute the values you need in order to populate the header.

	
In the Report Editor, click the Data Model button in the toolbar to display the Data Model view.


	
Click the Summary Column tool in the tool palette, then click in an open area of the Data Model view to create a summary column.


	
Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to FirstDeptRec.


	
Under Summary, set the Function property to First, set the Source property to DEPARTMENT_ID, set the Reset At property to Page.





	
Create a second summary column, and set its properties as follows:

	
Under General Information, set the Name property to LastDeptRec.


	
Under Summary, set the Function property to Last, set the Source property to DEPARTMENT_ID, set the Reset At property to Page.




Your data model should now look like this:





Figure 17-3 Data Model with Summary Columns for Header

[image: Description of Figure 17-3 follows]










32.5 Add Page Numbers (optional)

Some preprinted forms may require you to print page numbers. The steps in this section will show you how to add page numbers to your output that will display when the number of order items extends beyond a single page.


To add page numbers to your report:

	
Click the Paper Layout button in the toolbar to display the Paper Layout view.


	
Click the Field tool in the tool palette.


	
Draw a small region on your layout 6 inches (15 centimeters) from the left and 0.25 inches (0.5 centimeters) from the top, to 7 inches (18 centimeters) from the left and 0.5 inches (1.5 centimeters) from the top.


	
Double-click the new field object, F_1, to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to F_PAGE_NUMBER.


	
Under General Layout, set the Horizontal Elasticity property to Variable.


	
Under Field, set the Source property to Page Number, and set the Visible property to No. Click the Page Numbering property field to display the Page Numbering dialog box.





	
In the Page Numbering dialog box:

	
Clear the Header Section and Trailer Section check boxes, and make sure that the Main Section check box is selected.


	
In the Reset At list, click R_G_Customer.


	
Click OK.





	
In the Paper Layout view, following the steps above to create another field from (7.25, 0.25) to (8.25, 0.5) inches (or (18.5, 0.5) to (21, 1.5) centimeters) .


	
Double-click the new field object to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to F_TOTAL_PAGES.


	
Under General Layout, set the Horizontal Elasticity property to Variable.


	
Under Field, set the Source property to Total Pages, and set the Visible property to No. Click the Page Numbering property field to display the Page Numbering dialog box.





	
In the Page Numbering dialog box:

	
Clear the Header Section and Trailer Section check boxes, and make sure that the Main Section check box is selected.


	
In the Reset At list, click R_G_Customer.


	
Click OK.




Now that you have created the page number fields, you need to make them visible.


	
In the Paper Layout view, click the Text tool in the tool palette.


	
Draw a region on your layout 6 inches (15 centimeters) from the left and 1 inch (2.5 centimeters) from the top, to 8 inches (20 centimeters) from the left and 1.25 inches (3 centimeters) from the top.


	
Click inside the rectangle and type &<F_PAGE_NUMBER> of &<F_TOTAL_PAGES>.



	
Note:

The "&<F_PAGE_NUMBER>" text will replace that text with the current value of the summary field you just created, which determines the page number of the current page. The "&<F_TOTAL_PAGES>" text will replace that text with the current total number of pages of the report, based on the value of the summary field of the same name.








	
With the text object selected, choose Tools > Property Inspector to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to B_PAGE_NUMBERS.


	
Under Advanced Layout, set the Print Object On property to All Pages, and set the Base Printing On property to Enclosing Object.





	
In the Paper Design view, click the Run Paper Layout button in the toolbar to run your report and display it in the Paper Design view.

Your report should now look like the following image. Notice how Reports Builder calculates that this particular report is one page, thus displays "1 of 1" above the order details.


Figure 32-14 Paper Design view of the preprinted form report with page numbers

[image: Description of Figure 32-14 follows]






	
Save your report.









13.2 Create a New Report Manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.


To create a blank report:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Build a new report manually, then click OK.









33.4 Create Summary and Formula Columns

To provide the necessary information for the invoice, you need to create summary and formula columns for subtotal amounts, a total amount, and due dates.


To create the invoice summary and formula columns:

	
Click the Summary Column tool in the tool palette, then click in an open area of the Data Model view to create a summary column.


	
Double-click the new summary column object to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to CS_SUB_TOTAL.


	
Under Summary, set the Source property to O_QUANTITY_O_UNIT_PRICE, and set the Reset At property to Page.




This summary is used for subtotal amounts on each page of the invoice.


	
Click the G_ORDER group, and drag the bottom edge handle down to create an empty space at the bottom of the group.


	
Again, click the Summary Column tool in the tool palette, then click in the empty space in the G_ORDER group to create a second summary column.


	
Double-click the new summary column object to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to CS_TOTAL.


	
Under Summary, set the Source property to O_QUANTITY_O_UNIT_PRICE and set the Reset At property to G_ORDER.




This summary is used for a total amount of each invoice.


	
Click the Formula Column tool in the tool palette, then click in an open area of the Data Model view to create a formula column.


	
Double-click the new formula column object to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to CF_DUE_DATE.


	
Under Column, set the Datatype property to Date.


	
Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function CF_DUE_DATEFormula return Date is 
today date; 
begin 
 select sysdate into today from dual; 
  return today + 30; 
end; 


This formula is used to calculate the due date, which is 30 days after today.


	
Click Compile.


	
Click Close.

Your data model should now look something like this:


Figure 33-3 Data Model view with data link, summary, and formula columns

[image: Description of Figure 33-3 follows]






	
Save the report as invoice_your_initials.rdf.









33.3 Create a Data Model With a Data Link

When you create a report with multiple queries, it is typically easier to create all of the queries with the Data Wizard in the Data Model view. In this report, you will create two queries, linked with a group-to-group data link.


To create the queries:

	
In the Data Model view, choose Insert > Query to display the Data Wizard.


	
If the Welcome page displays, click Next.


	
On the Query page, type Q_Order for the Query name, then click Next.


	
On the Data Source page, select SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT 
   ORDER_ID, 
   ORDER_DATE, 
   ORDER_TOTAL, 
   ORDERS.CUSTOMER_ID, 
   SALES_REP_ID, 
   C1.CUST_FIRST_NAME, 
   C1.CUST_LAST_NAME, 
   C1.CUST_ADDRESS, 
   C1.CUSTOMER_ID, 
   C2.CUST_FIRST_NAME, 
   C2.CUST_LAST_NAME, 
   C2.CUST_ADDRESS, 
   C2.CUSTOMER_ID 
FROM ORDERS, CUSTOMERS C1, CUSTOMERS C2 
WHERE ORDERS.CUSTOMER_ID = C1.CUSTOMER_ID AND 
   ORDERS.SALES_REP_ID = C2.CUSTOMER_ID 


This query joins the Orders table to the Customers table for customer information and sales representative information.




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called invoice_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.













	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 33.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click Next.


	
Click Finish to display your first query in the Data Model view.


	
Repeat the steps above for a second query, but this time name your query Q_Item and use the following SELECT statement:


SELECT 
   O.ORDER_ID, 
   O.LINE_ITEM_ID, 
   O.PRODUCT_ID, 
   O.QUANTITY, 
   O.UNIT_PRICE, 
   TRANSLATED_DESCRIPTION, 
   P.PRODUCT_ID, 
   O.QUANTITY * O.UNIT_PRICE 
FROM ORDER_ITEMS O, PRODUCT_DESCRIPTIONS P 
WHERE  O.PRODUCT_ID = P.PRODUCT_ID 
   AND P.LANGUAGE_ID = 'US' 


This query joins Order items to the Product table for product descriptions.


	
In the Data Model view, double-click the title bar of the G_ORDER_ID group (for the master query Q_ORDER) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to G_ORDER.





	
Double-click the title bar of the G_ORDER_ID1 group (for the detail query Q_ITEM) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to G_LIST.




Your data model should now look something like this:


Figure 33-2 Queries in the Data Model view

[image: Description of Figure 33-2 follows]









To add the data link:

	
In the Data Model view, click the Data Link tool in the tool palette.


	
Click and drag from the ORDER_ID column in the G_ORDER group to the ORDER_ID1 column in the G_LIST group. Notice that a line is drawn from the bottom of the G_ORDER group to the Q_Item query. Labels for ORDER_ID and ORDER_ID1 are created at each end of the line to indicate they are the columns linking G_ORDER to Q_Item.









37.3 Edit the Distribution XML Definition

The Oracle Reports distribution XML file enables you to specify the details of your distribution. For example, if you are distributing through e-mail, you can specify such details as the addressee, the reply to address, and the subject.

In this section, you will learn how to modify a distribution XML file. We have indicated locations where you need to enter your own information to make the distribution work.

When you want to distribute a report, you need to either:

	
Make sure your source report (for example, inventory_report_dist.rdf) and your distribution XML file (for example, distribution.xml) are in the same directory.

OR


	
When you run the report from the Reports Server, set the destination to the path of the XML file. (This is explained in Section 37.4, "Run the Report".)







	
Note:

For more information on distribution, see the chapter "Creating Advanced Distributions" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.










To edit the distribution XML file:

	
In a text editor, such as Notepad, open the sample distribution.xml file we have provided.


	
Find the placeholder text: <YourFilePath>, and replace it with the location of where your resulting PDFs will be stored.

Example: Replacing the placeholder text with:


d:\temp\


changes the path to:


d:\temp\Rep_%amp;&lt;city&gt;.pdf


Using this complete path places the resulting PDF files in d:\temp.


	
Find the placeholder text: <OriginEmailAddress>, and replace it with the sender's e-mail address.


	
Perform step 3 for all instances of the placeholder text: <OriginEmailAddress>.


	
Find the placeholder text: <DestinationEmailAddress>, and replace it with the recipient's e-mail address.


	
Perform step 5 for all instances of the placeholder text: <DestinationEmailAddress>.



	
Note:

For this example, we show you how to send e-mails to static e-mail addresses. However, if you want to send the report to various e-mail destinations, you must create a recipient field in your data model. Then, in the ex2 section of distribution.xml, replace the placeholder text <DestinationEmailAddress> with &amp;&lt;recipient&gt;. You can then delete the first section of the distribution.xml file (marked ex1).








	
Save the XML file to the same directory where you have saved inventoryreport_dist_your_initials.rdf.



	
Note:

It is not required that you save the XML file to the same directory where your RDF is located, as you can specify the location of the XML file at runtime. Either distribution.xml and RDF must be in Reports Path, or provide the complete path in the command line URL.








You have finished customizing the distribution XML file to send a single e-mail to corporate headquarters with all of the individual warehouse reports, and multiple e-mails with a single attachment each to the individual warehouses.









4.15 Integrate with Other Products

This section provides procedures for the following tasks that you may perform as you integrate your reports with other products:

	
Publishing a report in Oracle Portal


	
Accessing non-Oracle data sources






4.15.1 Publishing a report in Oracle Portal

Oracle Portal is integrated with Oracle Reports. This integration enables you to quickly publish a report as a portlet (that is, a small, dynamic region) or an item on a page, so that end users can easily access dynamic reports.

For general information, refer to the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Any Format, then select Integration with Oracle Portal.

For detailed information and tasks to publish a report as a portlet in Oracle Portal, see the chapter "Deploying Reports in Oracle Portal" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.



4.15.1.1 Running reports in Oracle Portal as an item link

When you install Oracle Portal with a nondefault language setting, some entries required to publish a report as an item link on a portal page are not installed automatically. You must install the language of your choice by using the rwlang.sql script.

Thus, you must run rwlang.sql (ORACLE_HOME/portal/admin/plsql/wwd/) if:

	
You have selected at least one language in addition to the default (US) at the time of installing Oracle Portal.

AND


	
You want to publish a report as an item link in Oracle Portal.






	
Note:

By default, a report is defined in the Main section.








To run the script:

	
Change the directory to ORACLE_HOME/portal/admin/plsql/wwd/.


	
Run sqlplus.


	
Log on to Oracle Portal using the portal schema.


	
Run the rwlang.sql script with the following parameters:

@rwlang.sql language_list

where

language_list is the list of languages separated by commas.

For example, to install French and Japanese:

@rwlang.sql f,ja





Usage notes

	
There should be no space before or after the comma (,) because sqlplus treats the language list as two parameters, instead of one parameter separated by a comma (,).


	
The header of the rwlang.sql script contains the complete list of all language abbreviations. Edit the script file using any text editor to find out the various abbreviations.











4.15.2 Accessing non-Oracle data sources

Oracle Reports enables you to access any data source. The pluggable data source (PDS) architecture replaces Oracle Open Client Adapter (OCA) and the Open Database Connectivity (ODBC) drivers, which are no longer supported in Oracle Reports. However, Java Database Connectivity (JDBC) is one of the pluggable data sources available that can utilize the JDBC-ODBC bridge, allowing access to other data sources.

Use the following steps to determine the easiest method for accessing your data source:

	
Does your data source have Java Database Connectivity (JDBC)?

A pluggable data source (PDS) has already been set up. All you have to do is select JDBC as your data type.


	
Does your data source have ODBC?

If so, make sure that you have downloaded the JDBC-ODBC bridge from Sun Microsystems. This lets you use the JDBC connection mentioned in Step 1. If you do not know if there is an ODBC driver for your data source, check the company Web site. For example, Microsoft has a downloadable ODBC driver for Excel.


	
Is the file in XML?

Oracle Reports includes an XML PDS. If the DTD file is available, all you have to do is select XML as your data type. If the DTD file is not available, you will have to create one.


	
Is the file comma-delimited?

You can use the Text PDS included with Oracle Reports to query the data source.


	
Has someone in your company built a PDS for your data type?

If the PDS exists, it will probably be on the Reports Server. Ask your administrator if such a file exists. If the PDS exists, add it to the classpath for your copy of Oracle Reports Builder. If the PDS does not exist, use the API Reference to help you build one.





Examples

Oracle Reports ships with XML data source sample files.


See also

The Pluggable Data Sources section of the Oracle Reports online Help, including the topics:

	
About pluggable data sources


	
Adding a pluggable data source


	
Connecting to a pluggable data source


	
Adding online Help to a pluggable data source


	
Pluggable data source interface definition


	
Troubleshooting PDS problems











17.4 Add a Page Heading

Now that you have the data for the header, you need to add the corresponding layout objects to the margin area of the report.

	
In the Paper Design view, from the font lists in the toolbar, choose Arial (Western), point size 10.


	
In the Paper Layout view, click the Edit Margin button in the toolbar.


	
Click the Text tool in the tool palette.


	
Draw an area somewhere to the right of the logo image and type the following text:


Departments found on this page: &FirstDeptRec through &LastDeptRec



	
Move to an open area of the Paper Layout view and click the mouse button to exit text mode. Notice that the text object you just created is still selected, you can now adjust its positioning with the arrow keys. If you click in an open area a second time, the object is deselected.


	
Choose Program > Run Paper Layout to run your report.

Your report should now look like this:


Figure 17-4 Group left report output with database values in the header

[image: Description of Figure 17-4 follows]






	
Save your report.









32.2 Manually Create the Data Model for Your Report

The steps in this section will show you how to manually create the data model for your report. Your data model will consist of two linked queries. The first query will retrieve all the customers that have orders in the database. The second query will retrieve all of the order information for each of the customers, and will contain a break group based on the date of each order.



32.2.1 Create the queries

The steps in this section will show you how to manually create two queries in the Data Model view.


To create the queries:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Build a new report manually, then click OK.


	
In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT FIRST_NAME||' '||LAST_NAME EMPLOYEE_NAME
  , CUST_FIRST_NAME||' '||CUST_LAST_NAME CUSTOMER_NAME
  , CUST_ADDRESS
  , CUSTOMER_ID 
FROM EMPLOYEES, CUSTOMERS 
WHERE EMPLOYEE_ID = ACCOUNT_MGR_ID 
AND CUSTOMER_ID IN (SELECT UNIQUE(CUSTOMER_ID) FROM ORDERS)
ORDER BY LAST_NAME, CUST_LAST_NAME




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called preprint_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.











	
Click OK.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 32.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
If the Connect dialog box displays, type the connection information for the database where the Order Entry sample schema resides, then click Connect.

The query displays in the Data Model view, and should look something like this:


Figure 32-2 Data Model view of the first query

[image: Description of Figure 32-2 follows]






	
Right-click the query (Q_1), then choose Property Inspector from the pop-up menu.


	
In the Property Inspector, under General Information, set the Name property to Q_CUSTOMER.


	
Double-click the group (G_EMPLOYEE_NAME) to display the Property Inspector, and set the Name property to G_CUSTOMER.


	
In the Data Model view, click the SQL Query tool in the tool palette to create a second query with the following SELECT statement:


SELECT to_char(ORDER_DATE, 'DD-Mon-YY') ORDER_DATE
  , I.PRODUCT_ID
  , PRODUCT_DESCRIPTION
  , QUANTITY
  , UNIT_PRICE
  , QUANTITY * UNIT_PRICE ITEM_TOTAL
  , CUSTOMER_ID
FROM ORDERS O, ORDER_ITEMS I, PRODUCTS P 
WHERE O.ORDER_ID = I.ORDER_ID 
AND I.PRODUCT_ID = P.PRODUCT_ID 
ORDER BY ORDER_DATE, I.PRODUCT_ID 


	
Right-click the query object, then choose Property Inspector from the pop-up menu.


	
In the Property Inspector, set the Name property to Q_ORDERS.


	
Double-click the new group object to display the Property Inspector.


	
In the Property Inspector, set the Name property to G_ORDER_ITEMS.

Your data model should now look like this:


Figure 32-3 Data Model view with two queries

[image: Description of Figure 32-3 follows]









	
Note:

In Q_CUSTOMER, the second WHERE clause restricts the values returned to only those customers who have current orders. In Q_ORDERS, we have used "to_char" to account for a new datatype, "Datetime." Since this new datatype is not recognized by Oracle Reports, you cannot use format masks on this particular column yet.










	
Save your report as preprint_your_initials.rdf.









32.2.2 Modify your data model

The steps in this section will show you how to modify your data model to link the two queries and to cause the data retrieved to break on a particular column.You will also create several summary columns to calculate information for each order.


To modify your data model:

	
In the Data Model view, click the Data Link tool in the tool palette.


	
Click the CUSTOMER_ID column in the G_Customer group.


	
While holding down your mouse button, drag your cursor to the CUSTOMER_ID1 column in the G_ORDER_ITEMS group and release your mouse button to create a link between the two queries.


	
Now, create a break group by clicking the ORDER_DATE column in the G_ORDER_ITEMS group and dragging it above the group.



	
Tip:

You can select the group or the query title and use the resize handles to modify the look of your data model.








Your data model should now look like this:


Figure 32-4 Data Model view of the linked queries and break group

[image: Description of Figure 32-4 follows]






	
Click the Summary Column tool in the tool palette, then click in the G_CUSTOMER group to create a summary column. You may want to resize the group so that you can see your summary columns.


	
Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to CS_PAGE_TOTAL.


	
Under Summary, set the Function property to Sum, set the Source property to ITEM_TOTAL, and set the Reset At property to Page.





	
Create another summary column in the G_CUSTOMER group, and set its properties as follows:

	
Under General Information, set the Name property to CS_ORDER_TOTAL.


	
Under Summary, set the Function property to Sum, set the Source property to ITEM_TOTAL, and set the Reset At property to G_CUSTOMER.



	
Note:

These two summary columns calculate the total items per page and the total items in the order for the report.










Your data model is now complete, and should look like this:


Figure 32-5 Complete Data Model view of the preprinted forms example

[image: Description of Figure 32-5 follows]






	
Save your report.











13.5 Merge the Two Layouts

After you have created the two layouts, you have only achieved part of your desired result. The summary of purchases by product is outside of the master/detail layout. Hence it summarizes the product purchases for the entire report rather than the product purchases for each customer. To show the summary for each customer, you must move the second layout inside of the first one.


To merge the second layout with the first:

	
In the Object Navigator, select M_G_CUSTID1_GRPFR1.



	
Tip:

To make finding this frame easier, just type in the name in the Find field at the top of the Object Navigator.








	
Click the title bar of the Report Editor to return to the Paper Layout view. Notice that the frame around the second layout is now selected for you.


	
Use the arrow keys to position the second layout so that the F_DESCRIP1 field lines up with the F_DESCRIP field in the first layout.


	
Click the Confine Off button in the toolbar. Ensure that Flex mode is on (it is on by default).


	
In the Object Navigator, select R_G_CUSTID.


	
Click the title bar of the Report Editor to return to the Paper Layout view. Notice that the master repeating frame in the first layout is now selected for you.


	
Click the handle at the bottom center of R_G_CUSTID and drag it down about 0.5 inches (1.5 centimeters). Because Flex Mode is on, the frame surrounding it grows as you drag. Similarly, the second layout is moved down to avoid being overwritten.


	
With R_G_CUSTID still selected, choose Tools > Property Inspector.


	
Change the Vert. Space Between Frames property to 0.25.


	
In the Object Navigator, select M_G_CUSTID1_GRPFR1.


	
Click the title bar of the Report Editor to return to the Paper Layout view.


	
Using the toolbar along the top of the Paper Layout view, turn Flex Mode off.


	
Using the arrow keys, move M_G_CUSTID1_GRPFR1 and its contents inside of the first layout.


Figure 13-8 Paper Layout view with two layouts merged into one

[image: Description of Figure 13-8 follows]






	
Click the Paper Design button in the toolbar of the Report Editor to display the Paper Layout view. Notice how the summary table now repeats for each customer.


Figure 13-9 Paper Design view with two layouts merged

[image: Description of Figure 13-9 follows]












6 Building a Mailing Label Report

In this chapter, you will learn about mailing label reports, one of the standard report styles. By following the steps in this chapter, you can generate the report output shown in Figure 6-1.


Figure 6-1 Mailing label report output

[image: Description of Figure 6-1 follows]







Concepts

	
A mailing label report consists of data displayed in a format suitable for use as address labels on envelopes. The labels can be printed in one or many columns, and can begin at any position.


	
In a mailing label report, you can combine data from the database with static text to create addresses, and print them out as mailing labels for envelopes.


	
Mailing labels can be created using simple, one-query reports with a mailing label layout style.





Data Relationships

To fetch the data for a mailing label report, all you need to do is create a query to select it.


Layout

	
Oracle Reports provides a default mailing label layout in which the fields are positioned so that each field is directly below the preceding field. Field labels are not printed.


	
You will use the Report Wizard to create a simple mailing label report. The Report Wizard provides you with a formatting page, where you can choose the layout of each mailing label.


	
You will use the Vertical Spacing field, located in the Property Inspector for the repeating frame, to control the amount of blank space between each mailing label. The default spacing between repeating frames may not be sufficient, and you may want to specify that space be inserted between mailing labels in the layout so that they are correctly positioned when printing them onto labels.





Example Scenario

As you build this example report, you will:

	
Use the Report Wizard to Create a Mailing Label Report and use Query Builder to write a single query that selects all of the columns for this report. You do not need to create any other data objects; Oracle Reports will create all other necessary data objects by default.


	
Add Vertical Spacing using the Vertical Spacing property to add space between each record in your mailing label report




To see a sample mailing label report, open the examples folder named mailinglabel, then open the Oracle Reports example report named mailinglabel.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.



25 Building a Matrix Report

In this chapter, you will learn about matrix reports. By following the steps in this chapter, you can generate the report output shown in Figure 25-1.


Figure 25-1 Matrix report output

[image: Description of Figure 25-1 follows]







Concepts

	
A matrix report looks like a grid. As shown by the example report above, it contains one row of labels, one column of labels, and information in a grid format that is related to both the row and column labels.


	
This sample matrix also contains three additions to the basic matrix: summaries have been added, zeroes replace non-existent values in the cells, and the cells themselves are surrounded by grid lines. Of the summaries, one sums the salaries by department, one sums them by job, and one sums them for the whole report.


	
Certain requirements exist for building matrix reports:

	
You must have at least four groups in your data model.


	
One group must be a cross product group.


	
At least two of the groups must be within the cross product group. These groups furnish the "labels" of the matrix report.


	
At least one group must be a "cell" group; that is, it must provide the information related to the labels. The values from this group fill the cells created by the matrix.





	
These requirements can be seen in the preceding example. It contains four groups--one group supplies the vertical labels (department numbers) and one group supplies the horizontal labels (job identifiers). These two groups are the children of the third group, called the cross product group, which creates the grid. The fourth group provides the values that fill in the grid.


	
Matrix reports are different from tabular reports because the number of columns is not known in advance; that is, the number of columns in your report is not determined by the number of columns you specify in your SELECT statement plus the columns you create yourself. The number of columns in your report depends on the number of values contained in the columns providing the horizontal and vertical labels. Thus, the report would automatically be extended if a new job function, called RECEPTIONIST, was added to the underlying data tables.


	
The queries used to select data for these sample matrix reports are not intended as definitive examples of matrix queries. If you are concerned with performance issues, for example, there are alternate methods of querying data that can improve the performance of a matrix report.


	
You can create matrix reports with any number of queries. Section 25.2, "Create a Single-Query Matrix" explains how to create the matrix report using one query. Section 25.3, "Create a Multiple-Query Matrix" explains how to create the same report using three queries. These two methods yield the same results. They are presented as options; feel free to try both methods and settle on a favorite.


	
This report uses the matrix layout style. You'll modify some default settings to ensure that the column and row labels display correctly. You'll also modify some field widths to ensure that the fields fit across the page.


	
For additional conceptual information, see Section 1.3.7, "About matrix reports",





Example Scenario

In this example, you will create report that cross tabulates salaries by job function and department. The result would be a matrix with job functions listed across the top, departments down the side, and sums of salaries in the cells. Thus, you could quickly determine the sum of all of the salaries for clerks in department 20 and compare that value to the one for all clerks in some other department.

As you build this example report, you will:

	
Create a Single-Query Matrix


	
Create a Multiple-Query Matrix


	
Add Summaries to the Single-Query Matrix for rows and columns.


	
Format Monetary Values


	
Add Zeroes in Place of Blanks


	
Add a Grid to add grid lines around cells.




To see a sample matrix report, open the examples folder named matrix, then open the Oracle Reports example named matrix1qb.rdf for a single-query matrix report, or matrix3qb.rdf for a multi-query matrix report. For details on how to access these reports, see "Accessing the Example Reports" in the Preface.




15.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






43.2 Create a Barcode Report for Paper

In this section, you will import the barcode JavaBean, then create a paper-based report that shows the invoice for a particular customer. This invoice will display the address of the customer, his order, and a barcode that represents the tracking number for the order. The company can scan this barcode to find out the status of the order.



43.2.1 Import the Java classes into Reports Builder

To create a paper report using the barcode JavaBean, you must first import two Java classes into Reports Builder. When you import these Java classes, Reports Builder automatically creates the packages you need to build the report.




	
Note:

You do not need to perform this task if you are creating a Web report, as you will write JSP code that calls the JavaBean.










To import the Java classes:

	
Launch Reports Builder.




	
Note:

You must launch Reports Builder now so that the new REPORTS_CLASSPATH is used.










	
Close the Welcome dialog box by clicking Cancel.


	
Choose Program > Import Java Classes to display the Import Java Classes dialog box.


	
Under Select Java Classes, navigate to:


oracle.apps.barcode.util.BarCodeConstants




	
Note:

If you do not see this class listed, try exiting Reports Builder and make sure the REPORTS_CLASSPATH reads correctly. Then, launch Reports Builder again.








	
Select the class, then click Import.


	
Once the packages have been created, import the second JavaBean: oracle.apps.barcode.BarCodeMaker.


	
Click Close.


	
In the Object Navigator, under the report named MODULE 1, click the Program Units node. You will notice that Reports Builder created two package specifications and two package bodies named BARCODECONSTANTS and BARCODEMAKER.









43.2.2 Create a package to store your information

In this report, you want to create a package where the information will be stored.


To create a package for storing your information:

	
In the Object Navigator, under your new report, click the Program Units node.


	
Click the Create button in the toolbar to display the New Program Unit dialog box.


	
In the New Program Unit dialog box, type globals.


	
Select Package Spec, then click OK to display the PL/SQL Editor:


	
In the PL/SQL Editor, type the following code:


PACKAGE globals IS
  bcobj ora_java.jobject;
  barcode_to_use varchar2(256);
  tempdir varchar2(100);
  directory_sep varchar2(2);
END;





	
Note:

You can also enter this code by copying and pasting it from the provided text file called barcode_code.txt.










	
Click Compile to make sure there are no errors in your code.



	
Note:

If your code does not compile, make sure you have typed in exactly the code we have provided.








	
Once the code is compiled, click Close.


	
In the Object Navigator, click your report name (for example, MODULE 1).


	
Save the report as shippingmanifest_your_initials.rdf.




You have created a package that will contain the global information for your report.






43.2.3 Create a Before Report trigger

You can use a Before Report trigger to perform specific tasks before the report is run. Here, you will define the type of barcode you want to use in your report, as well as the temporary directory where your barcode images will be stored.


To create a Before Report trigger:

	
In the Object Navigator, under SHIPPINGMANIFEST_your_initials, expand the Report Triggers node, then double-click the icon next to BEFORE REPORT to display the PL/SQL Editor.


	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function BeforeReport return boolean is
begin
  globals.barcode_to_use := BarCodeConstants.BAR_CODE_128;
  globals.bcobj := barcodemaker.new();
  return (TRUE);
end;    


To modify the type of barcode you want to use, you can change the value BarCodeConstants.BAR_CODE_128 to any other valid value. To determine which values are valid, check the contents of the package by opening the BarCodeConstants package spec in the Object Navigator, under the Program Units node.




	
Note:

You can enter this code by copying and pasting it from the provided text file called barcode_code.txt.










	
Click Compile to make sure there are no errors.



	
Note:

If you have errors, make sure you have imported the necessary Java classes and compare your code closely with the code above. If you change the code, be sure to compile it again.








	
When the code is compiled, click Close. Notice how the node icon next to the BEFORE REPORT trigger has changed.


	
Save your report.




You have created a trigger that will set up the barcode type for you when you run the report.






43.2.4 Create a query in the Data Model view

In this section, you will manually create the query that the report will use to retrieve data from the sample schema.


To create the query:

	
In the Object Navigator, under SHIPPINGMANIFEST_your_initials, double-click the view icon next to the Data Model node to display the Data Model view for your report.


	
In the Data Model view, click the SQL Query tool in the tool palette, then click in an open area of the Data Model view to display the SQL Query Statement dialog box.


	
In the SQL Query Statement field, enter the following SELECT statement:


SELECT ALL CUSTOMERS_A1.CUST_FIRST_NAME, 
  CUSTOMERS_A1.CUSTOMER_ID, CUSTOMERS_A1.CUST_LAST_NAME,
  CUSTOMERS_A1.CUST_ADDRESS.STREET_ADDRESS,
  CUSTOMERS_A1.CUST_ADDRESS.POSTAL_CODE, 
  CUSTOMERS_A1.CUST_ADDRESS.CITY,
  CUSTOMERS_A1.CUST_ADDRESS.STATE_PROVINCE, 
  CUSTOMERS_A1.CUST_ADDRESS.COUNTRY_ID, ORDERS.ORDER_ID,
  ORDERS.ORDER_DATE, 
  ORDERS.ORDER_TOTAL, ORDER_ITEMS.LINE_ITEM_ID,
  PRODUCTS.PRODUCT_NAME, 
  ORDER_ITEMS.UNIT_PRICE, ORDER_ITEMS.QUANTITY,
  COUNTRIES.COUNTRY_NAME
FROM CUSTOMERS CUSTOMERS_A1, ORDER_ITEMS, ORDERS,
  PRODUCTS, HR.COUNTRIES
WHERE ((ORDER_ITEMS.ORDER_ID = ORDERS.ORDER_ID)
  AND (ORDERS.CUSTOMER_ID = CUSTOMERS_A1.CUSTOMER_ID)
  AND (ORDER_ITEMS.PRODUCT_ID = PRODUCTS.PRODUCT_ID)
  AND (CUSTOMERS_A1.CUST_ADDRESS.COUNTRY_ID =
  HR.COUNTRIES.COUNTRY_ID)) 
  AND ORDERS.ORDER_ID = :P_ORDER_ID
ORDER BY order_ID, line_item_ID





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called barcode_code.txt into the SQL Query Statement field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the SQL Query Statement field.













	
Click OK.

If you are not connected to a database that contains the sample schema we have provided, you must log in now. If you are not sure what your connection string is, contact your database administrator. Note that this example uses the Order Entry sample schema.


	
When a message displays indicating that the bind parameter p_order_id was created, click OK.


	
In the data model you just created, select all of the following columns using Shift-click, then drag them below the current query to create a detail group:

	
LINE_ITEM_ID


	
PRODUCT_NAME


	
UNIT_PRICE


	
QUANTITY




The resulting data model should look like this:


Figure 43-2 Data Model for the query

[image: Description of Figure 43-2 follows]













43.2.5 Create a formula column to retrieve the barcode image

In this section, you will create a formula column that will communicate with the JavaBean to create the barcode, then return the file name of the generated image.


To create a formula column:

	
In the Data Model view, click the Formula Column tool in the tool palette.


	
Click in the master group (G_CUST_FIRST_NAME) to create a new formula column.


	
Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to ImageFilename.


	
Under Column:

	
Set the Datatype property to Character


	
Set the Width property to 500


	
Set the Read from File property to Yes


	
Set the File Format property to Image





	
Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function ImageFilenameFormula return VarChar2 is
  myFileName varchar2(500);
  result varchar2(500);
  barcodeData VarChar2(50) := :customer_ID || :order_ID;
begin
          myFileName := srw.create_temporary_filename;
  barcodemaker.setBarWidthInch(globals.bcobj, 0.005);
  barcodemaker.setBaseCodeData(globals.bcobj,barcodeData);
  barcodemaker.setBarCodeType(globals.bcobj,globals.barcode_to_use);
  barcodemaker.setFullPath(globals.bcobj, myFileName); 
  barcodemaker.renderBarCode(globals.bcobj);
  return(myFileName);
end;




	
Note:

You can enter this code by copying and pasting it from the provided text file called barcode_code.txt.








	
Click Compile to make sure there are no errors.



	
Note:

If you have errors, make sure you have imported the necessary Java classes and compare your code closely with the code above. If you change the code, be sure to compile it again.








	
When the code is compiled, click Close.









43.2.6 Create a formula column that returns the order total


To create the second formula column:

	
In the Data Model view, create a formula column in the detail group G_LINE_ITEM_ID.


	
Open the Property Inspector for the formula column, and set the following properties:

	
Under General Information, set the Name property to LineTotal.


	
Under Column, make sure the Datatype property is set to Number.


	
Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.





	
In the PL/SQL Editor, use the template to enter the following PL/SQL code:


function LineTotalFormula return Number is
begin
  return (:quantity * :unit_price);
end;




	
Note:

You can enter this code by copying and pasting it from the provided text file called barcode_code.txt.








	
Click Compile to make sure there are no errors.


	
When the code is compiled, click Close.


	
Save the report.




You have created the data model for your barcode report, which contains a formula column that retrieves the barcode information and displays the barcode image on your report, and another formula column that displays the order total.

Your data model and the PL/SQL for the formula column should look similar to this:


Figure 43-3 Data Model with two new formula columns

[image: Description of Figure 43-3 follows]










43.2.7 Create a layout for your report

Before you can run your report, you must create a layout.


To create a paper layout:

	
Under your report's node in the Object Navigator, right-click Paper Layout, then choose Report Wizard.


	
In the Report Wizard, on the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, select Group Above, then click Next.


	
On the Data Source page, click Next.


	
On the Data page, click Next.


	
On the Groups page, make sure the following fields are listed in the Group Fields list (if not, use the arrows to move the field to the appropriate list):

	
ORDER_ID


	
ORDER_DATE


	
CUSTOMER_ID


	
CUST_FIRST_NAME


	
CUST_LAST_NAME


	
STREET_ADDRESSS


	
POSTAL_CODE


	
COUNTRY_NAME


	
CITY


	
STATE_PROVINCE


	
COUNTRY_ID


	
ORDER_TOTAL


	
CF_1





	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Finish.


	
In the Paper Layout view, click the Run Paper Layout button in the toolbar to run your report.


	
In the Runtime Parameter Form, next to P_ORDER_ID, type 2354.


	
Once your report displays in the Paper Design view, you can rearrange your layout objects in the Paper Layout view to make your report look something like Figure 43-4. To create this format:

	
In the Paper Layout view, remove the surrounding parent frame M_G_CUST_FIRST_NAME_GRPFR, then click the Confine Off button and the Flex Off button in the toolbar.


	
Using the shippingmanifest.rdf example report as a guide, add three rectangles and three text objects for:

	
Shipping Details: Set text properties to Arial, 16, bold. Create a frame to add the following fields: cust_first_name, cust_last_name, street_address, city, state_province, postal, country_name.


	
Tracking Details: Set text properties to Arial, 16, bold. Move the ImageFilename object onto this rectangle.


	
Order Details: Set text properties to Arial, 16, bold. Move the labels and fields for Order ID and Order Date onto this rectangle. Move the field F_Order_Total onto this rectangle and set text properties to Courier New, 24, bold.





	
Set the text properties for all other field values to Courier New, 10. Additionally, set F_Line_Total to bold.


	
Format numeric field values to display currency, decimals, and right align them.


	
Set Fill Color for each rectangle, totals field, and table header as desired.





Figure 43-4 Paper Design view of the barcode paper report

[image: Description of Figure 43-4 follows]









	
Note:

If you are not sure whether you produced the desired results, you can always open the example report called ShippingManifest.pdf in Acrobat Reader. Or, you can run ShippingManifest.rdf to paper and the report will display in the Paper Design view.










	
Save the report. You have now finished building a barcode report for paper.










26 Building a Nested Matrix Report

In this chapter, you will learn about nested matrix reports. By following the steps in this chapter, you can generate the report output shown in Figure 26-1.


Figure 26-1 Nested matrix report output

[image: Description of Figure 26-1 follows]







Concepts

	
A nested matrix report is a matrix report which contains more than the usual two dimensions (across and down) of a simple matrix.


	
You can create nested matrix reports with any number of queries. In Section 26.2, "Create a Single-Query Matrix", you'll create the example nested matrix report using one query. In Section 26.3, "Create a Multiple-Query Matrix", you'll use multiple queries. In Section 26.4, "Create a Multiple-Query Matrix with a Break", you will use not only group hierarchy to nest one dimension within another, but you'll also create a true parent/child relationship between the relevant groups by explicitly creating a new group and placing it within the cross product and above the other group. This will restrict the records displayed to only those for which data exists.




	
Notes:

	
In a nested matrix report, where you create a matrix query that has a child matrix query, the fields on which you join should be separated into a separate group in your master matrix. Otherwise, on some platforms, only the first group prints.


	
The queries used to select data for those sample matrix reports are not intended as definitive examples of matrix queries. If you are concerned with performance issues, for example, there are alternate methods of querying data that can improve the performance of a matrix report. Refer to the Oracle Reports online Help for details.













	
This example report uses a matrix with three dimensions, created by including three columns in the cross product. The cross product is capable of displaying every possible value for three dimensions: two down (YEAR and DEPTNO) and one across (JOB). This method does not include rows that have null values because there is a break group within the cross product group in the data model. As mentioned above, this chapter describes how to create a nested matrix with and without a break group inside of the cross product group so that you can see the difference in the output.


	
The order in which the two down dimensions (YEAR and DEPTNO) will be displayed is based upon the order in which you position their corresponding groups within the cross product; that is, of YEAR and DEPTNO, you'll position YEAR to the left of DEPTNO. This "nests" DEPTNO inside of YEAR and causes all records for DEPTNO to appear for each value of YEAR, regardless of whether that department has any data for that year.


	
For additional conceptual information, see Section 2.1.7, "About nested matrix reports".





Example Scenario

In this example, you will create a report that cross tabulates salaries by year and department, and by job function. The result is a matrix with job functions listed across the top, years and departments down the side, and sums of salaries in the cells. Thus, you can quickly determine the sum of all of the salaries for clerks in department 20 and compare that value to the one for all clerks in some other department.

As you build this example report, you will:

	
Create a Single-Query Matrix.


	
Create a Multiple-Query Matrix.


	
Create a Multiple-Query Matrix with a Break within the cross product group.


	
Format Monetary Values.




To see a sample nested matrix report, open the examples folder named nestedmatrix, then open any of the Oracle Reports examples named nested1.rdf, nested2.rdf, or nested3.rdf. For details on how to access them, see "Accessing the Example Reports" in the Preface.




6.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.






15.6 Run your Report to Paper

In this section, you will run your report to the Paper Design view so you can see how your report displays.

Click the Paper Design button in the toolbar to display the Paper Design view. Your report runs, then displays in the Paper Design view. It should look like the following:


Figure 15-7 Paper Design view for the wrapped field report

[image: Description of Figure 15-7 follows]






Save your report as wrappedbreak_your_initials.rdf.






14.2 Use the Report Wizard to Create a Simple Report

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the simple report in this example, you can use the Report Wizard. Using the wizard enables you to define the layout for the report, as well as set the data definition.


To create a simple report:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Title page, select Group Left, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT ALL CUSTOMERS_A1.CUSTOMER_ID, ORDERS.ORDER_ID, ORDERS.ORDER_TOTAL
FROM CUSTOMERS CUSTOMERS_A1, ORDERS
WHERE (ORDERS.CUSTOMER_ID = CUSTOMERS_A1.CUSTOMER_ID)
ORDER BY CUSTOMERS_A1.CUSTOMER_ID





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called formula_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.













	
Click Next.




	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 14.1, "Prerequisites for This Example" describes the sample schema requirements for this example.










	
On the Groups page, select CUSTOMER_ID and click the right arrow (>) to move this field to the Groups Fields list, then click Next.


	
On the Fields page, click the double right arrow button (>>) to move all of the fields to the Displayed Fields list, then click Next.


	
On the Totals page, click ORDER_TOTAL and click Sum, then click Next.


	
On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 14-2 Paper Design view for the formula report

[image: Description of Figure 14-2 follows]






	
Save the report as formulareport_your_initials.rdf.









10.5 Summary

Congratulations! You have successfully created a single-query group report. You now know how to:

	
create a data model and layout with the Report Wizard.


	
format fields in the Paper Design view.


	
add white space between records with the Property Inspector.


	
add another column to the break group and redefault the layout.


	
add another break group and redefault the layout.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






25.3 Create a Multiple-Query Matrix

You can build a matrix report with multiple queries in the data model. A multiple-query data model is typically easier to conceptualize and code than a single-query, but the single-query data model typically performs better.



25.3.1 Create a new report manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.


To create a blank report:

	
Choose File > New > Report.


	
Select Build a new report manually, then click OK.









25.3.2 Create a data model with a cross product and a data link

When you create a report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the layouts with the Report Wizard.


To create the queries:

	
In the Data Model view, choose Insert > Query to display the Data Wizard.


	
If the Welcome page displays, click Next.


	
On the Query page, type Q_Dept for the Query name, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement:


SELECT DISTINCT DEPTNO
FROM EMP




	
Tip:

If you click Query Builder, you can build the query without entering any code manually.








	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 25.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click Next.


	
Click Finish to display your first query in the Data Model view.


	
Repeat the steps above for a second query, but this time name your query Q_Job and use the following SELECT statement:


SELECT DISTINCT JOB
FROM EMP



	
Again, repeat the steps above for a third query, but this time name your query Q_Matrix and use the following SELECT statement:


SELECT DEPTNO, JOB, SUM(SAL)
FROM EMP
GROUP BY DEPTNO, JOB
ORDER BY DEPTNO, JOB




Figure 25-3 Three query data model, queries unrelated

[image: Description of Figure 25-3 follows]









To create the cross product group:

	
In the Data Model view, click the Cross Product tool in the tool palette.


	
Drag a box around G_DEPTNO and G_JOB. When you release the mouse button, the cross product group is created. Ensure that it completely surrounds both groups.





Figure 25-4 Three query data model with cross product group

[image: Description of Figure 25-4 follows]







To add the data link:

	
In the Data Model view, click the Data Link tool in the tool palette.


	
Click and drag from the DEPTNO column in the G_DEPTNO group to the DEPTNO1 column in the G_DEPTNO1 group.


	
Repeat steps 1 and 2, but this time drag the link between the JOB column in G_JOB and JOB1 in G_DEPTNO1.





Figure 25-5 Three query data model with cross product group and data links

[image: Description of Figure 25-5 follows]










25.3.3 Create the layout with the Report Wizard

Once your data model is complete, you need to create a layout for the data objects to display in the report output.


To create the layout:

	
In the Data Model view, right-click on the canvas, then choose Report Wizard.


	
In the Report Wizard, on the Report Type page, select Create Paper Layout only.


	
On the Style page, select Matrix.


	
On the Groups page, ensure that all of the groups from your data model appear in the Displayed Groups list. G_1 should be Matrix, G_DEPTNO should be Down, G_JOB should be Across, and G_DEPTNO1 should be Down.


Figure 25-6 Groups page of the Report Wizard

[image: Description of Figure 25-6 follows]






	
On the Fields page, ensure that only the following columns appear in the Displayed Fields list:

	
DEPTNO


	
JOB


	
SUM_SAL





Figure 25-7 Fields page of the Report Wizard

[image: Description of Figure 25-7 follows]






	
On the Labels page, delete the labels for all of the fields.


	
On the Template page, make sure Beige is selected under Predefined Template, then click Finish to display your report output in the Paper Design view. It should look like this:


Figure 25-8 Paper Design view for the matrix report

[image: Description of Figure 25-8 follows]














Part VI



Building Reports with PL/SQL and Java

The chapters in this Part provide steps to build reports that use PL/SQL code or Java. You can include PL/SQL, PL/SQL libraries, REF CURSORs, and barcodes in your reports, and build JSP-based Web reports that include a Parameter Form.

	
Chapter 40, "Building a Report that Includes PL/SQL"




A PL/SQL report uses an external PL/SQL library and PL/SQL within a report to modify formatting and to perform calculations on column values. For example, you can use a PL/SQL procedure in a format trigger to include a space between records similar to a break report or to calculate the total compensation for each employee.

	
Chapter 41, "Building a Paper Report with REF CURSORs"




A paper report with REF CURSORs helps manage queries. (A REF CURSOR is a PL/SQL cursor datatype that you can reference from within a PL/SQL query.) For example, if you already have numerous queries built and you want to reuse those queries in your reports, you can use a REF CURSOR in your report data model to access those queries.

	
Chapter 42, "Building a Simple Parameter Form for a JSP-based Web Report"




A JSP-based Web report can be modified by adding a Parameter Form to accept user input at runtime that will determine what data will display in the report.

	
Chapter 43, "Building a Report with a Barcode"




A barcode can be added to a paper or Web report by using the barcode JavaBean. In Oracle Reports Builder, the barcode JavaBean automatically generates a barcode for you based on the data you specify. For example, you can use the barcode to track shipping orders by generating a barcode based on the shipping order code.

	
Chapter 44, "Building an Accessible JSP-based Web Report"




Using Oracle Reports and the standards defined in the Web Accessibility Guidelines, you can create a report that produces output that is compatible with assistive technologies such as screen readers. Oracle Reports provides properties and tags to support this effort.



7 Building a Form Letter Report

In this chapter, you will learn about form letter reports, one of the standard report styles. By following the steps in this chapter, you can generate the report output shown in Figure 7-1.


Figure 7-1 Form letter report output

[image: Description of Figure 7-1 follows]







Concepts

	
Form letter reports contain database values embedded in boilerplate text (boilerplate text can be defined as any text that appears each time the report is run). It can be text generated by Oracle Reports, text you create, or text you import from a file.


	
A form letter report is useful for printing multiple copies of the same letter addressed to different people.


	
A form letter report is similar to a mailing label report, in that it is a simple report with a form letter layout style.





Data Relationships

There are no special restrictions on data relationships for a form letter report.


Layout

	
A default form letter layout style is provided by Oracle Reports. It consists of the field names for the columns you have selected, prefixed by ampersands (&). The ampersands indicate that they are hidden fields, and are contained within boilerplate and repeating frame objects. You then add the text of the letter to the layout. Oracle Reports prints one record (that is, one letter) per page.


	
Hidden fields, which are the default for a form letter layout, appear in the layout but not the output until referenced. You can do this in the Paper Layout view by typing its name, prefixed by an ampersand (&). Oracle Reports treats the reference as a normal field.


	
In general, if you are embedding a field within boilerplate text (as in a form letter), it is best to hide the field and reference it where desired. The field values will then flow with the text. A field can appear in a report both where placed by default in the report layout and where referenced. Fields can also be referenced more than once in the same piece of boilerplate text.





Example Scenario

As you build this example report, you will:

	
Use the Report Wizard to Create a Form Letter Report with a paper layout that includes one query to select all of the columns displayed in this report. Oracle Reports will create all other necessary objects, for example, groups and columns, by default




To see a sample form letter report, open the examples folder called formletter, then open the Oracle Reports example report called formletter.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




25.4 Add Summaries to the Single-Query Matrix

To make your matrix report more useful, you should add summaries of each row and column in the matrix, and the whole report. In the single-query case, you can add these summaries very easily with the Report Wizard. In the multiquery case, you would need to add the summaries manually and then use the Report Wizard to create fields for them.

The steps below describe the procedure for adding summaries to the single-query matrix.


To add summaries to a single-query matrix:

	
Return to the Report Wizard by choosing Tools > Report Wizard.



	
Note:

Although you can use the Report Wizard to add summaries to a single-query matrix, you cannot use this method for a multiquery matrix.








	
On the Report Type page, select Create Paper Layout only.


	
On the Totals page, click SUM_SAL in the Available Fields list, then click Sum.



	
Tip:

You may have to use the arrows to make the Totals tab visible.








	
Click Finish to preview your report output in the Paper Design view.



	
Note:

When your new layout is created, you should notice a couple of things. First, at the bottom of each column of the matrix, you should now see a summary of that column's values. The report is also probably more than one page long now. Because of the width of the layout, the summaries for the departments cannot fit on the page with the rest of the matrix. Hence, the department summaries and the report summary overflow to the next page. Go to the second page of the report and you will see the department summaries and the report summary.















3.7 Part 7: Building Reports with Pluggable Data Sources

This part of the manual explains how you can build reports using pluggable data sources.



3.7.1 Building a report with an XML pluggable data source

Reports Builder enables you to use any data source you wish. In this example, you will learn how to use the XML pluggable data source that is provided with Oracle Reports.


Figure 3-43 Final output of the XML PDS example

[image: Description of Figure 3-43 follows]






For more information on building this example, refer to Chapter 45, "Building a Report with an XML Pluggable Data Source".






3.7.2 Building a report with a text pluggable data source

In this example, you will learn how to use character-delimited text as a data source.


Figure 3-44 Final output for the text PDS example

[image: Description of Figure 3-44 follows]






For more information on building this example, refer to Chapter 46, "Building a Report with a Text Pluggable Data Source".







Part I



Building Basic Reports

The chapters in this Part provide steps to build simple reports.

This part contains the following chapters:

	
Chapter 5, "Building a Tabular Report"




A tabular report is the most basic type of report. The output of this report is organized in a multicolumn, multirow format (with rows and columns corresponding to those in the database table).

	
Chapter 6, "Building a Mailing Label Report"




A mailing label report is displayed in a format suitable for use as address labels on envelopes. You write custom text and embed database values, or text from files, to create the labels. You can print the labels in one or many columns and at any position.

	
Chapter 7, "Building a Form Letter Report"




A form letter report is displayed in a format suitable for use in printed forms or letters. Similar to the mailing label report, you can write custom text and embed to it, database values or text from files.

	
Chapter 8, "Building a Master/Master Report"




A master-master report (also called a parent-parent report) consists of at least two sets of data that are not directly related. This report contains two or more queries with no links (that is, no parent-child relationships).

	
Chapter 9, "Building a Summary Report"




A summary report contains a field that summarizes at least one column of the report. This summary can be: total sales, average of a list of commissions, maximum amount found in a series of purchase orders, and so on.



16 Building a Header and Footer Report

In this chapter, you will learn about reports that include headers and footers. By following the steps in this chapter, you can generate the report output shown in Figure 16-1.


Figure 16-1 Group left report output with header and footer

[image: Description of Figure 16-1 follows]






This report has a page header, Employee Summary Report, printed in the upper margin area of every page of the report, and a footer, Total Salary for Department <number>: <sum_sal>, printed at the end of the list of employee information for each department.


Concepts

	
A header and footer report contains boilerplate or fields in its header or footer. To create headers and footers in your report, add the boilerplate or field in the Paper Layout view of the Report Editor. If you create a field, make sure there is only one value for it. Otherwise, Reports Builder will not know which of the different values you want to print.


	
How often the boilerplate and fields appear and whether they are headers or footers depends on where you position them in the layout. Any boilerplate that is positioned within a repeating frame will print once every time the repeating frame prints. Boilerplate that is outside of all repeating frames will print once for the entire report.





Data Relationships

This report uses one query to select all necessary columns. You'll add a break by assigning a column to a second group.


Layout

This report uses a group left layout with modifications. You'll increase the size of a repeating frame and the frame enclosing it to ensure they are large enough to contain a footer, then add the footer. Then you'll modify the vertical spacing of a repeating frame to add space between each instance of it.


Example Scenario

In this example, you will create a report that displays and summarizes employee data by department. To make the report more readable, you decide to add a header to each page and to add footer for each master record.

As you build this example report, you will:

	
Create a Data Model and a Group Left Layout.


	
Move a Summary to move the departmental summary closer to its label.


	
Add a Page Heading that repeats on all pages.


	
Add White Space and Format Fields to format monetary values.




To see a sample report with a header and footer, open the examples folder named headerfooter, then open the Oracle Reports example named headfoot.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.




10.2 Group Report with One Break Column

The most basic case of a group left or above report is to have one break group with one break column in it. This means that a single master field value will print once for many detail field values.

To see a sample group left report with one break column, open the examples folder named break, then open the Oracle Reports example named grp1col_lft1.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.


Concepts

	
Create a group left (or above) report when you want to prevent a column from repeatedly displaying the same value while other column values in the rows change.


	
You can build a group left or above report with either a single-query or multiple queries. A single-query report typically runs faster than a multiquery report.


	
You must ensure that your SELECT statement includes a column, called a break column, containing at least one value which repeats over multiple records (for example, department number in the example report above). With the break column, you will create a second group, called a break group, to create the breaks in the data.


	
This report uses a default tabular format. You will improve the readability of the report by changing the vertical spacing for a repeating frame to insert a space between each set of department information (for example, between the last record of Department 10 and the first record of Department 20, as shown in the example report above). You will also add a format mask.






10.2.1 Create a data model with a break group and group left layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.


To create a data model and layout:

	
Launch Reports Builder (or, if already open, choose File > New > Report)


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Group Left, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT EMPLOYEE_ID, FIRST_NAME, LAST_NAME,
JOB_ID, SALARY, DEPARTMENT_ID
FROM EMPLOYEES 





	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called across_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.













	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 10.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click DEPARTMENT_ID and click the right arrow (>) to move this field to the Group Fields list, then click Next.


Figure 10-2 Groups page of the Report Wizard

[image: Description of Figure 10-2 follows]






	
On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list.


Figure 10-3 Fields page of the Report Wizard

[image: Description of Figure 10-3 follows]






	
Click Next until you reach the Template page of the Report Wizard.


	
On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 10-4 Paper Design view for the single-query group left report

[image: Description of Figure 10-4 follows]













10.2.2 Format a field

In the Paper Design view, notice the Salary field. The values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.


To assign a format mask to monetary values:

	
In the Paper Design view, click the first number value underneath the Salary label. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.


	
Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.


	
Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.


	
Resize the fields. Click and drag the rightmost handle of the cell value under the Salary label about 0.5 inches (1.5 centimeters) to the left.


	
Shift-click the Salary label.


	
Click the Align Right button in the toolbar.


	
Click in an open area of the Paper Design view to deselect all of the objects.


	
Save the report as grp_lft2_your_initials.rdf.





Figure 10-5 Salaries formatted

[image: Description of Figure 10-5 follows]










10.2.3 Use the Property Inspector to add white space

If you examine your report output in the Paper Design view, you will notice that it can be difficult to distinguish where one department's data ends and the next department's data begins. To make the report more readable, you want to add some white space between the departments, but you want to retain the same spacing between employee rows. For this report, you will change a repeating frame property for the master repeating frame to create some white space between the department records.


To create white space between the departments:

	
In the Paper Design view, click the first number value underneath the Department Id label. Notice that all of the department numbers are immediately selected.


	
Click the Select Parent Frame button in the toolbar. Notice how the border of the repeating frame that contains the Department Id field is now highlighted.


	
Choose Tools > Property Inspector to display the Property Inspector, and set the following properties:

	
Under Repeating Frame, set the Vert. Space Between Frames property to 0.25.





Figure 10-6 Property Inspector for master repeating frame

[image: Description of Figure 10-6 follows]






	
Click the title bar of the Report Editor to make it the active window again.


	
Save your report.


Figure 10-7 Paper Design view after white space is added

[image: Description of Figure 10-7 follows]














3 Visual Index

This chapter provides an overview of the example reports in this manual. For information on accessing the demo reports and the data sources, refer to "Accessing the Example Reports" and "Accessing the Data Sources".

The chapter lists the example reports contained in this manual, a brief description of each report, a pointer to the location of the steps to build the example, and an image of the sample output.




20.7 Summary

Congratulations! You have successfully created an intermixed fields report. You now know how to:

	
create a data model and layout in the Report Wizard.


	
add a formula column to the detail group.


	
add a field in the Report Wizard.


	
remove a redundant field in the Paper Design view.


	
suppress values in a Format Trigger.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






22.3 Add Conditional Formatting to the Report

The steps in this section will show you how to add conditional formatting so that salaries greater than or equal to $10,000 will be highlighted in bold, red text, and salaries between $4,999 and $10,000 will be highlighted in bold text.

Since the data retrieved cannot be both greater than or equal to $10,000 and between $4,999 and $10,000, you will need to create two separate format exceptions. In this section, you will see how to create each distinct format exception.


To add conditional formatting:

	
In the Paper Design view, right-click the Salary column of data (not the Salary column heading), then choose Conditional Formatting.


	
In the Conditional Formatting dialog box, click New to create a new Format Exception.


	
In the Format Exception dialog box, make sure SALARY is selected.


	
Next to SALARY, choose Greater Than or Equal from the list.


	
In the next box, type 10000.


	
Under Format, click the icon next to Text Color to display the color palette.



	
Note:

You can choose as many options as you want in the Format Exception dialog box, such as text color, style, and font.








	
Click Red.


	
Click Font, then choose Bold.


	
Click OK to accept the new font style.

You should now see the following options selected in the Format Exception dialog box:


Figure 22-5 Format Exception dialog box

[image: Description of Figure 22-5 follows]






	
Click OK.


	
In the Conditional Formatting dialog box, click New to create your second format exception.


	
Create a format exception where the values of the SALARY column are between $4999 and $10000 are highlighted in bold.



	
Note:

Make sure you type the values in the order described, so that Reports Builder knows to highlight the data between $4999 and $10000, and not $10000 and $4999.








	
When you are done, click OK. The Conditional Formatting dialog box should now look like the following:


Figure 22-6 Conditional Formatting dialog box

[image: Description of Figure 22-6 follows]






	
Click Apply, then click OK. Your report displays in the Paper Design view, and should now look something like this:


Figure 22-7 FInal Conditional Formatting report

[image: Description of Figure 22-7 follows]






	
Save your report as condhigh_your_initials.rdf.









27.2 Create a Matrix Group Data Model and Layout

Since this report is a single-query report, it is easiest to build it with the Report Wizard.


To create the data model and layout with the Report Wizard:

	
Launch Reports Builder (or, if already open, choose File > New > Report).


	
In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.


	
If the Welcome page displays, click Next.


	
On the Report Type page, select Create Paper Layout Only, then click Next.


	
On the Style page, type a Title for your report, select Matrix with Group, then click Next.


	
On the Data Source page, click SQL Query, then click Next.


	
On the Data page, enter the following SELECT statement in the Data Source definition field:


SELECT TO_CHAR(HIREDATE, 'YY') YEAR, DEPTNO, JOB, SUM(SAL) 
FROM EMP
GROUP BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB




	
Note:

You can enter this query in any of the following ways:

	
Copy and paste the code from the provided text file called matrixgroup_code.txt into the Data Source definition field.


	
Click Query Builder to build the query without entering any code manually.


	
Type the code in the Data Source definition field.











	
Click Next.



	
Note:

If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 27.1, "Prerequisites for This Example" describes the sample schema requirements for this example.








	
On the Groups page, click YEAR in the Available Fields list and click the right arrow (>) to move this field to the Matrix Group Fields list, then click Next.


	
On the Rows page, click DEPTNO in the Available Fields list and click the right arrow (>) to move this field to the Matrix Row Fields list, then click Next.


	
On the Columns page, click JOB in the Available Fields list and click the right arrow (>) to move this field to the Matrix Column Fields list, then click Next.


	
On the Cell page, click SUM_SAL in the Available Fields list and click the right arrow (>) to move this field to the Matrix Cell Fields list, then click Next.




	
Note:

In this case, the query itself performs the summary through the SUM function. Hence, you should not use the Sum button in this instance.










	
On the Totals page, click SUM_SAL in the Available Fields list and click Sum to move this field to the Matrix Totals list, then click Next.


	
On the Labels page, remove the label for SUM_SAL, then click Next.


	
On the Template page, select No Template, then click Finish to display your report output in the Paper Design view. It should look something like this:


Figure 27-2 Paper Design view for matrix with group above report

[image: Description of Figure 27-2 follows]






	
Save the report as matrixgroup_your_initials.rdf.








33 Building an Invoice Report

In this chapter, you will learn about reports that display output on invoices. By following the steps in this chapter, you can generate the report output shown in Figure 33-1.


Figure 33-1 Invoice report output

[image: Description of Figure 33-1 follows]







Concepts

	
Invoice reports are master/detail reports with billing amounts that print conditionally. The customer name, address, and related information are derived from the master query (or group, if there is only one query). The line–items come from the detail query. The billing amounts are printed in the page footer.


	
This information must all print on specific line and column positions on the preprinted invoice form. To format your information correctly, you will use many of the same techniques as you used in Chapter 32, "Building a Report Using a Preprinted Form".


	
As an additional aid to formatting this report, you will link to a TIFF image of the invoice. This will enable you to position your fields more precisely.







	
Note:

Many of the concepts in this example are used in the following example reports:

	
This example, where you import an image of an invoice and use it as a guide to position fields in the Paper Layout view.


	
Chapter 31, "Building a Check Printing Report with Spelled-Out Cash Amounts", where you import an image of a check and use it as a guide to position fields in the Paper Layout view. In addition, you learn how to create a PL/SQL function that returns spelled-out numerical values.


	
Chapter 32, "Building a Report Using a Preprinted Form", where you learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form.













Data Relationships

The data for this report is fetched using two queries, linked together in a master/detail relationship. You will also define a break and two summaries.


Layout

This layout is similar to the layout for the preprinted form report, but in this case you will also link to a TIFF image of your form to use as a guide while adjusting the positions of several fields.


Example Scenario

In this example, you will create a report that prints an invoice for each customer, listing the following information:

	
standard billing information such as name, address, date, purchase order number, and so on


	
a list of items purchased, including item number, description, and price


	
the total cost of all items purchased




You will also learn how to import an image of a preprinted form (in this case, a blank invoice image) and use the tools in the Paper Layout view to print your report on this form.

As you build this example report, you will:

	
Create a New Report Manually to create a new, empty report.


	
Create a Data Model With a Data Link to create two queries with a data link between them.


	
Create Summary and Formula Columns to include on the invoice.


	
Prepare the Layout for inserting the invoice information.


	
Insert Invoice Information by creating new fields for the invoice information, positioning them in the correct locations on the invoice form.




To see a sample invoice report, open the examples folder named invoice, then open the Oracle Reports example named invoice.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.




45.4 Summary

Congratulations! You have successfully used an XML data source for a paper report. You now know how to:

	
create a SQL query from scratch.


	
use the Data Wizard to create an XML query.


	
create a data link between a SQL query and an XML query.


	
create a layout for your report using the Report Wizard.


	
apply alternating row colors to your report using format triggers and procedures.


	
filter your XML data using a group filter and hierarchy.




For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".






38.4 Create a PDF Document of Your Report

Oracle Reports Builder supports multibyte characters in the PDF format. By generating the PDF file of your report, you have the advantages of being able to:

	
create the report output in a portable format.


	
use PDF font subsetting and PDF font embedding feature.



	
Tip:

Make sure you perform the following steps before you generate the file:

	
Change the registry entry for NLS_LANG to AMERICAN_AMERICA.UTF8.


	
Edit the uifont.ali file.


	
Edit the REPORTS_PATH registry entry.




See Section 38.1, "Prerequisites for This Example" for more details.











To generate the PDF file:

	
In Oracle Reports Builder, choose File > Generate to File > PDF.


	
Save the report as multibyteutf8_your_initials.pdf.


	
In the Runtime Parameter Form that displays, type the value PL (exactly as shown), and click the Run Report button to execute the report.

The Report Progress dialog box is displayed and provides the print status of the PDF output. When the PDF is created, this dialog box disappears.


	
Locate the PDF file (multibyteutf8_your_initials.pdf) and double-click to open the file.




It should look something like this:


Figure 38-7 PDF file of the report with Polish characters

[image: Description of Figure 38-7 follows]









	
Note:

You can open the PDF file on any computer and it will look exactly the same, without installing any Unicode font. This is because the PDF file includes the font used in the report.

Notice the default rough visual appearance of the characters in the PDF output. You can smooth the characters by using "smoothe lineart" setting in Acrobat Reader.














38.3 Display Multibyte Characters in the Report

You have successfully created and executed the report. Next, you have to change the font to a UTF8 multicharacter set TrueType font to see the characters of the language chosen in the report output.


To change the font to a multicharacter TrueType font:

	
In the Paper Design view, Shift-click the values below the Translated Name and Translated Description labels to select all the values in these two columns. You can now change their properties simultaneously.


	
From the font box in the toolbar, choose Arial Unicode MS.

The report is executed and the Paper Design view of the report output is displayed in Japanese characters. It should look something like this:





Figure 38-5 Paper design view of the report with Japanese characters

[image: Description of Figure 38-5 follows]







To run the same report in another language:

To run the same report again with a different runtime parameter and see the output in another language, perform the following steps:

	
Click the Run Paper Layout button in the toolbar, or choose Program > Run Paper Layout.


	
In the Runtime Parameter Form, type the value PL, and click the Run Report button to run the report.

The Paper Design view of the report output is displayed with Polish characters. It should look something like this:





Figure 38-6 Paper design view of the report with Polish characters

[image: Description of Figure 38-6 follows]










45.3 Run Your Report to Paper


To run your paper report:

	
In the Object Navigator, make sure your report (inventoryreport_xml_your_initials.rdf) is selected.


	
Click the Run Paper Layout button in the toolbar to run your report to paper. Notice how the Parameter Form now displays, with the initial value of 50.


	
Your report displays in the Paper Design view, and should look something like this:





Figure 45-8 Final Paper Design view of the XML PDS example report

[image: Description of Figure 45-8 follows]










22.4 Examine the Conditional Format Trigger Code

The steps in this section will show you the PL/SQL code that was automatically generated by Reports Builder when you used the Conditional Formatting dialog box to set up your format exceptions.




	
Note:

You can also edit the conditional format trigger code in the PL/SQL Editor, but if you attempt to modify the code again in the Conditional Formatting dialog box, your edits will be overwritten by the selections in the dialog box. If you do modify the code in the PL/SQL Editor, you will see a warning note when you try to open the Conditional Formatting dialog box.










To examine the automatically generated code:

	
In the Paper Design view, right-click the Salary column (on which you just applied formatting), then choose PL/SQL Editor.


	
In the PL/SQL Editor, you will see the following code that was automatically generated by Reports Builder.





Figure 22-8 PL/SQL code for the new format triggers

[image: Description of Figure 22-8 follows]









	
Note:

In this code, you can see that the two format exceptions you created comprise two parts of a format trigger. You needed to create two separate format exceptions in the Conditional Formatting dialog box to achieve this effect. If you had tried to create both exceptions simultaneously in the same Format Exception dialog box, your data would not have satisfied both exceptions, and thus would not have been highlighted.














2.10 Debugging Tools

The topics in this section discuss debugging reports in Oracle Reports Builder.

	
About the debugging process


	
About the PL/SQL Interpreter


	
About the Source pane


	
About debug commands in the PL/SQL Interpreter


	
About debug actions


	
About the current execution location


	
About the current scope location


	
About debug levels


	
About modifying code at runtime






2.10.1 About the debugging process

Debugging an application is an iterative process in which application errors are identified and corrected. In general, quickly identifying and locating failing code is essential to successfully debugging your application.


See also

Section 4.14.1, "Debugging a report"

Section 4.14.2, "Running a report in debug mode"






2.10.2 About the PL/SQL Interpreter

The PL/SQL Interpreter is your debugging workspace, where you can display source code, create debug actions, run program units, and execute Interpreter commands, PL/SQL, and SQL statements.

By default, two panes are always open in the PL/SQL Interpreter: Source pane and Interpreter pane.

Debugging features include the following:

	
Direct manipulation debugging: insert debug actions and inspect program data by directly manipulating displayed source text.


	
Dynamic execution feedback: Oracle Reports Builder automatically displays and tracks the current PL/SQL source location as program execution is interrupted by debug actions or incrementally advanced during program stepping.


	
Browsing of interrupted program state: once execution has been interrupted, it is possible to browse the current stack, browse and modify variable state, and execute arbitrary PL/SQL statements. All information is accessed symbolically (that is, by name as opposed to by address or number).









2.10.3 About the Source pane

The PL/SQL Interpreter's Source pane displays a read-only copy of the program unit currently selected in the Object Navigator pane.

The numbers along the left hand margin correspond to the line numbers of the displayed program unit.

In addition, the symbols described below may appear in the margin.


Table 2-5 Symbols in the margin of the Source pane

	Symbol	Description
	
|


	
Specifies the current source location.


	
=>

	
Specifies the current scope location.


	
- 

	
Specifies the current execution location (if different from the current scope location).


	
B(n)

	
Specifies the location of a breakpoint, where n is the corresponding debug action ID. It appears in the line number column. 


	
T(n)

	
Specifies the location of a trigger, where n is the corresponding debug action ID. It appears in the line number column. 












2.10.4 About debug commands in the PL/SQL Interpreter

The following commands are available when using the PL/SQL Interpreter:


Table 2-6 PL/SQL Interpreter Commands

	Command	Description
	
CREATE

	
Creates a new library that can be stored in either the file system or the current database.


	
DELETE

	
Deletes:

	
libraries that reside in the current database


	
library program units


	
program units





	
DESCRIBE

	
Inspects a variable or parameter that is local to the current scope location. The description includes the name, type, and value of the specified local.


	
EXPORT

	
Writes the source of one or more program units to a text file.


	
LIST

	
Displays the source text for program units, triggers, and debug actions.


	
LOG

	
Saves a transcript of PL/SQL Interpreter input and output to the specified log file.


	
RESET

	
Returns control to an outer debug level without continuing execution in the current debug level.


	
SET

	
Changes the current scope location to a specified frame of the stack. You can specify relative motion from the current stack frame to any other frame, or move to a particular subprogram on the stack. There are several ways to invoke SET:

	
select a frame entry in the Object Navigator


	
enter the SET command in the PL/SQL Interpreter





	
SHOW

	
Lists the name, type, and value of all variables and parameters at the current scope location.












2.10.5 About debug actions

The PL/SQL Interpreter can be invoked from report code (triggers, user-named program units, libraries, and so on) by creating debug actions in the code. These are instructions that track the execution of PL/SQL program units so they can be monitored.

Each debug action you create is automatically assigned a unique numeric ID. While debugging, you can refer to this ID to browse, display, or modify a specific debug action with Oracle Reports Builder debug commands.

You can display detailed information about one or more debug actions, including its ID, source location, and whether or not it is enabled. You can temporarily disable specific debug actions and then re-enable them later if necessary.

There are two types of debug actions: breakpoints and debug triggers.

Breakpoints suspend execution at a specific source line of a program unit, passing control to the PL/SQL Interpreter.

Create breakpoints to identify specific debugging regions. For example, create a breakpoint at lines 10 and 20 to debug the code within this region.

With breakpoints, suspension occurs just before reaching the line on which the breakpoint is specified. At this point, use the PL/SQL Interpreter's features to inspect or modify program state. Once satisfied, resume execution with the GO or STEP commands, or abort execution using the RESET command.

Debug Triggers are a general form of debug action that associate a block of PL/SQL code with a specific source line within a program unit. When a debug trigger is encountered, Oracle Reports Builder executes the debug trigger code.

Create a debug trigger to execute a block of PL/SQL code provided at debug time in any of the following cases:

	
When program execution reaches a single line in a program unit (for example, the current source location, line 5, line 23, and so on).


	
Every time the PL/SQL Interpreter takes control (that is, whenever it suspends program execution due to a breakpoint, program stepping, and so on).


	
At every PL/SQL source line being run.




Debug triggers are especially useful as conditional breakpoints. You can raise the exception DEBUG.BREAK from within a trigger. For example, the debug trigger shown below establishes a conditional breakpoint on line 10 of my_proc, which will be reached only if the local NUMBER variable my_sal exceeds 5000:


PL/SQL>line 10 is
+> IF Debug.Getn('my_sal') > 5000 THEN
+> Raise Debug.Suspend;
+> END IF;




2.10.5.1 About creating a debug action

You can create debug actions (breakpoints and debug triggers) in the PL/SQL Interpreter in the following ways:

	
choosing Program > Breakpoint or Program > Debugging Triggers on the Oracle Reports Builder menu bar while a program unit is open in the PL/SQL Interpreter


	
right-clicking in the Source pane of the PL/SQL Interpreter and choosing Breakpoint or Debug Trigger


	
inserting debug actions in the Object Navigator pane


	
entering commands in the Interpreter pane




When you create a debug action, attach the breakpoint or debug trigger to a program unit source line that is "executable." A source line is considered executable if it contains one or more statements for which the PL/SQL compiler generates code. For example, source lines containing assignment statements and procedure calls are executable, while source lines containing comments, blank lines, declarations, or the NULL statement are not executable.


See also

Section 4.14.3, "Setting a breakpoint"

Section 4.14.4, "Setting a debug trigger"








2.10.6 About the current execution location

The current execution location specifies the next PL/SQL source line to be executed. It corresponds to what is commonly referred to as the program counter, or PC.

When control passes to the PL/SQL Interpreter while running a program (for example, when a breakpoint is encountered or following a step operation), the Source pane in the PL/SQL Interpreter automatically displays the source line associated with the current execution location.

Use the LIST command in the Interpreter pane to manually display the current execution location.

For example, entering:


.LIST PC


will list the current execution location in the Source pane.






2.10.7 About the current scope location

The current scope location dictates where the PL/SQL Interpreter looks for local variables and parameters. It corresponds to the current execution location of one of the PL/SQL subprograms on the stack.

Each time a program unit's execution is interrupted (for example, by a debug action), the scope location is initialized to the execution location of the subprogram at the bottom of the stack.

Once execution has been interrupted, you can change the current scope location to another frame on the stack. This enables you to view local variables in another subprogram in the call chain.


See also

Section 4.14.14, "Displaying the current scope location"






2.10.8 About debug levels

When a debug action interrupts program execution, the PL/SQL Interpreter takes control and establishes what is known as a debug level. At a debug level, you can enter commands and PL/SQL statements to inspect and modify the state of the interrupted program unit as well as resume execution.

Since any PL/SQL code interactively entered at a debug level may itself be interrupted (for example, by encountering another breakpoint), it is possible for debug levels to nest. To facilitate distinguishing one debug level from another, the levels are numbered. The most deeply nested level is assigned the highest number. Numbering starts at zero with the outermost level.

The 0th or outermost level is commonly referred to as top level. Top level has no associated program state since it is the outermost level at which program units are originally invoked. When code invoked from top level is interrupted, debug level 1 is established. Similarly, interrupting code invoked from debug level 1 establishes debug level 2, and so on.

The PL/SQL Interpreter command prompt reflects the current debug level. When the PL/SQL Interpreter enters levels below top level, the prompt includes a prefix containing the current debug level number. For example, the PL/SQL Interpreter command prompt at debug level 1 appears as:


(debug 1)PL/SQL>






2.10.9 About modifying code at runtime

At runtime, you can modify and compile any program unit, menu item command, or trigger that is not on the current stack.




	
Note:

To modify an item on the current stack, first clear the stack by issuing the RESET command.









Although runtime code modification is not communicated back to Oracle Reports Builder, you can interactively test possible fixes, before returning to implement the eventual fix.


See also

Section 4.14.13, "Modifying code at runtime"








27.5 Create a Web Layout

Now that you have created a paper layout, suppose that you decide to have a Web layout for this report. You can quickly create a Web layout in the Report Wizard without changing your paper layout.


To create a Web Layout:

	
Choose Tools > Report Wizard.


	
Select Create Web Layout only.


	
Click Finish.


	
Click the Web Source view button in the toolbar and review the Web source for your Web layout.


	
Choose Program > Run Web Layout to preview your Web layout.




	
Notes:

If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.

















8.5 Use the Paper Layout View to Add White Space

If you scroll down in the Paper Design view, you will notice that the field labels from the second query, Q_Emp, are located directly below the fields from the first query, Q_Dept. In fact, they are almost touching each other. For this report, you will move all of the layout objects belonging to Q_Emp down the page to create some white space between the two layouts.


To create white space between the layouts:

	
Move and resize the Report Editor window such that you can easily view it and the Object Navigator simultaneously.


	
Click the Paper Layout button in the toolbar of the Report Editor window to display the Paper Layout view.


	
In the Object Navigator, expand the Paper Layout node, then the Main Section node, then the Body node.


	
Click the frame named M_G_LAST_NAME_GRPFR. Note that it is also now selected in the Paper Layout view.


	
Click the title bar of the Report Editor to make it the active window.


	
Press the down arrow key a few times to move the frame and all of its objects down the page about 0.25 inches (0.5 centimeters).

Notice that you have moved not only M_G_LAST_NAME_GRPFR but also all the layout objects within it. Here you take advantage of Confine mode, the default mode for the Paper Layout view. With Confine mode on, an object cannot be moved outside of or placed behind its parent. Such a situation renders the layout invalid and no output is produced.

Sometimes moving an object outside of its parent is a valid action. If you need to do so, you can turn off Confine mode by clicking the Confine Off button in the toolbar.


Figure 8-5 Paper Layout view with two layouts and white space added

[image: Description of Figure 8-5 follows]






	
Save the report as masterb_your_initials.rdf.


	
Click the Paper Design button in the toolbar to preview your output again. Notice the additional space between the two layouts now.









A.2 Data Model View Tool Palette

The Data Model view tool palette is a vertical group of tools located on the left-hand side of the Data Model view, as shown in Figure A-2.


Figure A-2 Data Model view tool palette

[image: Description of Figure A-2 follows]






The name and purpose of each tool is as follows:


	Icon	Description
	[image: Select tool]
	
Select tool. Deselects any selected tool to "turn off" the current tool, and allow you to select any object in the Data Model view.


	[image: Magnify tool]
	
Magnify tool. Zooms in the view on the clicked object. Hold down the SHIFT key when you click the Magnify tool to zoom out.


	[image: Summary Column tool]
	
Summary Column tool. Creates a summary column in the query.


	[image: Data Link tool]
	
Data Link tool. Creates a master-detail relationship between queries when you drag a line to define the relationship between the key columns in the two queries.


	[image: Formula Column tool]
	
Formula Column tool. Creates a formula column in the query.


	[image: Cross Product tool]
	
Cross Product tool. Creates a matrix (cross-product) group.


	[image: Placeholder Column tool]
	
Placeholder Column tool. Creates a placeholder column which you can modify later.


	[image: SQL Query tool]
	
SQL Query tool. Displays the SQL Query Statement dialog box where you can enter a SQL query SELECT statement or use Query Builder to create a query.


	[image: Ref Cursor Query tool]
	
Ref Cursor Query tool. Displays the PL/SQL Editor where you can type a REF CURSOR query.


	[image: XML Query tool]
	
XML Query tool. Displays the Define XML Query dialog box, where you can specify the XML data definition and data source.


	[image: JDBC Query tool]
	
JDBC Query tool. Displays the JDBC Query dialog box, where you can define the SQL or stored procedure to define the data for the query.


	[image: Text Query tool]
	
Text Query tool. Displays the Text Query dialog box, where you can specify a text data definition and data source.












19.1 Prerequisites for This Example

	
To build the example in this chapter, you must have access to the Summit Sporting Goods (SUMMIT) schema. To download the SQL scripts that install the schema, see "Accessing the Data Sources" in the Preface. Only the EMP, CUSTOMER, and SALES tables are required.


	
The HTML view of the report that displays the page number technique must be deployed through a report server using the report in JSP or RDF format and HTML as the destination format. For example:


http://computer_host:port/reports/rwservlet?report=pgnum.rdf
&userid=scott/tiger@my_database&destype=cache&desformat=html&server=rep_server









2.1 Reports

The topics in this section build on the basic concepts discussed in Section 1.2, "Reports".

	
About report titles


	
About report sectioning and sections


	
About the report unit of measurement


	
About the report dimensions


	
About conditional formatting


	
About nested matrix reports


	
About matrix with group reports






2.1.1 About report titles

You can add a title to a report in either of the following ways:

	
Manually, by creating a boilerplate text object in the margin of the Paper Layout view.


	
Typing in the Title field on the Style page of the Report Wizard.




When you use the Report Wizard to add a title and do not select a template for your report output, the title is inserted into the margin of the report with default attributes defined by Oracle Reports Builder. You can modify the attributes in the Paper Layout view.

When you use the Report Wizard to add a title, and do select a predefined template or a user-defined template file for your report output, Reports Builder looks for a boilerplate text object named B_OR$REPORT_TITLE defined for the selected template:

	
If B_OR$REPORT_TITLE exists, the title is displayed using the attributes of this object, with the text you typed in the Report Wizard.


	
If B_OR$REPORT_TITLE is not found, the title is displayed using the attributes defined by the Default properties (under the Title node in the Property Inspector) of the selected template.



	
Note:

If you do not specify a title in the Report Wizard, the B_OR$REPORT_TITLE object is not copied to your report.










For layouts created using the Report Block Wizard, the title is inserted into the new layout as a group title rather than into the margin of the report. In this case, the attributes are set per the Default properties (under the Title node in the Property Inspector) of the selected template, and B_OR$REPORT_TITLE is ignored. If you do not select a template, the title uses the default attributes defined by Oracle Reports Builder.


See also

Section 4.5.6, "Adding a title to a report"

Section 4.12.5, "Formatting the report title in a template"

Section 2.7.1, "About templates"






2.1.2 About report sectioning and sections

Report sectioning enables you to define multiple layouts in the same report, each with a different target audience, output format, page layout, page size, or orientation. You can define up to three report sections, each with a body area and a margin area: the names of the sections are Header, Main, and Trailer. By default, a report is defined in the Main section. In the other sections, you can define different layouts, rather than creating multiple separate reports. If you wish, you can use the margin and body of the Header and Trailer sections to create a Header and Trailer page for your reports.

In the Object Navigator, the report sections are exposed in the Object Navigator under the Paper Layout node as Header Section, Main Section, and Trailer Section.

You can specify the order in which the three sections of a report (Header, Main, and Trailer) are formatted using SRW.SET_FORMAT_ORDER or the Format Order of Sections property. This capability allows Oracle Reports to format any section first to create information that is only known at the time of formatting, such as page numbers, then use that information in the formatting of another section. As an example, this property can be used to create a table of contents. For an example of using SRW.SET_FORMAT_ORDER for this purpose, see Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index" and Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".

For an example of using section-level distribution, see Chapter 37, "Bursting and Distributing a Report". This chapter covers defining distribution of a single section to multiple destinations, using the Repeat On property and a sample distribution XML file. For information about advanced section-level distribution and creating your own distribution XML file, see the chapter "Creating Advanced Distributions" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services .


Examples


Example 1

You can use sectioning and distribution to publish your report output in HTML, and also send a PostScript version to the printer.


Example 2

You can send an executive summary of the report to senior management, and also e-mail detailed breakdowns to individual managers. In this example, a single report with two report sections needs to be created: a portrait-sized summary section and a landscape-sized detail section. Use the Repeat On property to associate the detail section with a data model group that lists the managers and then alter the destination on each instance of the data model group to send the output to the appropriate managers.


See also

Section 2.8.3, "About report distribution"

Section 4.10.1, "Displaying a section layout view"

Section 4.10.2, "Creating a default layout for a section"






2.1.3 About the report unit of measurement

A report can be defined using inches, centimeters, or points. The unit of measurement is independent of the device on which you build the report. As a result, you can design reports that will run on any platform on which Reports Builder runs. You can change a report's unit of measurement in these ways:

	
Setting the Unit of Measurement property.


	
Converting the report using rwconverter, specifying a different unit of measurement with the DUNIT keyword.


	
Opening the report in a different environment. For example, if you open a character-mode report, Reports Builder will change the report's unit of measurement to the bit-mapped environment's default. If you then save the report, it will be saved with the new unit of measurement.









2.1.4 About the report dimensions

A report page can have any length and any width. Because printer pages may be smaller or larger than your paper report's "page," the concept of physical and logical pages is used. A physical page is the size of a page that is output by your printer. A logical page is the size of one page of your report; one logical page may be made up of multiple physical pages.

For each section (header, main, trailer) of a report:

	
you specify the dimensions of the physical page (including the margin) using the Width property and Height property.


	
you specify the dimensions of the logical page (report page) in physical pages (printer pages) using the Horizontal Panels per Page property (width) and the Vertical Panels per Page property (height). For example, a Horizontal Panels per Page size of 1 means that each logical page is one physical page wide, and a Vertical Panels per Page size of 2 means that each logical page is two physical pages in height.




In this example, one logical page is made up of six physical pages. The logical page is three physical pages wide and two physical pages high. Consequently, Horizontal Panels per Page size is 3 and Vertical Panels per Page size is 2. If you wanted the logical page to be two physical pages wide and three physical pages high, you would specify a Horizontal Panels per Page size of 2 and a Vertical Panels per Page size of 3.


Figure 2-1 Report dimensions

[image: graphic depicting physical vs logical pages]










2.1.5 About fonts in reports

For detailed information about using and adding fonts in Oracle Reports, including font configuration files, font aliasing, troubleshooting font issues, and font types, refer to the chapter "Managing Fonts in Oracle Reports" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.






2.1.6 About conditional formatting

Using the Conditional Formatting and Format Exception dialog boxes, you can specify output formatting attributes (font and color) for a selected layout object based on conditions that exist. The conditions that you define are called format exceptions.

You can display the Conditional Formatting dialog box from the Paper Layout view or Paper Design view in any of the following ways:

	
Double-click the object to display the Property Inspector. Under the General Layout node, click the Conditional Formatting value field (labeled...).


	
Display the pop-up menu (right-click in Windows) for the object.


	
Click the object, then choose Format > Conditional Formatting.




The Format Exception dialog box displays when you click New or Edit in the Conditional Formatting dialog box, and enables you to quickly and easily specify output formatting attributes for a selected layout object based on defined conditions. After you specify conditions and formatting for the current layout object in the Format Exception dialog box, the entire definition is exported to a PL/SQL format trigger. If a format trigger already exists for the layout object, the definition in the Format Exception dialog box overwrites the existing trigger code when you confirm the Oracle Reports Builder prompt.

You can edit the format trigger manually through the PL/SQL Editor; however, if you subsequently modify the definition using the Format Exception dialog box, Oracle Reports Builder displays a prompt to overwrite the existing format trigger.


See also

Section 4.9.1.5, "Applying conditional formatting to a layout object"






2.1.7 About nested matrix reports

A nested matrix report is a matrix report in which at least one parent/child relationship appears within the matrix grid.

A nested matrix report has more than two dimensions; therefore, it has multiple dimensions going across or down the page. For example, see . Notice that for each year there is a nested list of related departments. Also notice that the list of jobs (the across values) appears only once. Because the job values appear only once, a summary of each category of jobs can be made to line up with the values it summarizes.




	
Note:

In a nested matrix report, where you create a matrix query that has a child matrix query, the fields on which you join should be separated into a separate group in your master matrix. Otherwise, on some platforms, only the first group prints.









For a detailed example, see Chapter 26, "Building a Nested Matrix Report".


See also

Section 2.3.7, "About matrix objects"

Section 1.3.7, "About matrix reports"






2.1.8 About matrix with group reports

A matrix with group report is a group above report with a separate matrix for each value of the master group. For example, for each year (master) in the report below there is a unique matrix that contains only that year's departments and jobs. This means that a summary of each job category may not line up with the values it summarizes because the position of each job category in the matrix may vary for each year.

A multiquery matrix with group report is similar to a nested matrix report in that it has more than two dimensions. For example, in the following report, notice that for each year there is a nested list of related departments.


Figure 2-2 Sample matrix with group and nested matrix report

[image: matrix with group]






The advantage of using multiple queries is that you get a real break, or master/detail relationship, for the nesting groups (for example, notice that in the multiquery example above, Year 80 shows only record 20; with a single query, Year 80 would show all records whether or not they contain data for Year 80). If you want to suppress detail records that do not contain data for a particular master record, you must use multiple queries.

For a complete example, see the example report in Chapter 27, "Building a Matrix with Group Above Report".


See also

Section 2.3.7, "About matrix objects"

Section 1.3.7, "About matrix reports"








19.6 Create New Fields


To create new fields for the page numbers of the report:

	
Click the Paper Layout button in the toolbar to display the Paper Layout view.


	
In the Paper Layout view, click the Edit Margin button in the toolbar to display the margin areas of your report. You will be creating two page number fields in the top margin, as shown here:


Figure 19-6 Page number source fields in top margin of report

[image: Description of Figure 19-6 follows]






	
Click the Field tool in the tool palette and draw a field about two characters long in the center of your margin.


	
Double-click the new field object (F_1) to display the Property Inspector, and set the following properties:

	
Under General Information, set the Name property to F_TOTAL_PAGENO.


	
Under Field, set the Source property to Total Pages, and set the Visible property to No.


	
Under General Layout, set the Horizontal Elasticity property to Variable.

Hiding both this field and the field you'll create below ensures that they'll appear only where you reference them. Changing the horizontal sizing to Variable ensures that the fields can expand to accommodate large page ranges.


	
Under Field, click the Page Numbering property field to display the Page Numbering dialog box:

In the Reset at list, click R_G_ENAME, and verify that the Start at and Increment by values are both 1, then click OK.





	
Close the Property Inspector.


	
In the Paper Layout view, click the F_TOTAL_PAGENO field.


	
Choose Edit > Copy, then choose Edit > Paste to create a new field with the same dimensions as F_TOTAL_PAGENO next to F_TOTAL_PAGENO.


	
Drag the new field object (F_TOTAL_PAGENO1) to an open area of the margin.


	
Double-click the new field object (F_TOTAL_PAGENO1) to display its Property Inspector, and make the following changes:

	
Under General Information, set the Name property to F_PAGENO.


	
Under Field, set the Source property to Page Number.

Because it is a duplicate of F_TOTAL_PAGENO, the Horizontal Elasticity and Visible properties are already set as desired.


	
Under Field, click the Page Numbering property field to display the Page Numbering dialog box.

In the Reset at list, click R_G_ENAME, and verify that the Start at and Increment by values are both 1, then click OK.





	
Close the Property Inspector.




Next, you will reference these fields in a text box to display page numbers in the format "Page X of Y Pages."






2.6 PL/SQL

The topics in this section discuss the use of PL/SQL in Oracle Reports Builder.

	
About the PL/SQL Editor


	
About the Stored PL/SQL Editor


	
About the Syntax Palette


	
About program units


	
About stored program units


	
About external PL/SQL libraries


	
About attached libraries


	
About formulas


	
About group filters


	
About REF CURSOR queries


	
About DML and DDL


	
About built-in packages


	
About triggers






2.6.1 About the PL/SQL Editor

The PL/SQL Editor enables you to create and edit PL/SQL program units.


Usage notes

When you make changes to a program unit, dependent program units lose their compiled status, which is indicated by an asterisk (*) after their name under the Program Units node in the Object Navigator. You can navigate to those program units directly in the PL/SQL Editor using the Name list to recompile them.


Restrictions

	
If you delete a PL/SQL package, function, or procedure, you must also delete all references to it in your report. Otherwise, you will get an error when you compile, generate, or run the report.


	
PL/SQL package, function, and procedure names must be unique within the report and may not duplicate the names of any columns, groups, queries, or printable objects.





See also

Section 4.13.2.3.1, "Editing features in the PL/SQL Editor"






2.6.2 About the Stored PL/SQL Editor

The Stored PL/SQL Editor enables you to create and edit stored PL/SQL program units in a database (listed under the Database Objects node in the Object Navigator).


See also

Section 4.13.3.2, "Creating a stored program unit"






2.6.3 About the Syntax Palette

The Syntax Palette is a programming tool that enables you to display and copy the constructs of PL/SQL language elements and built-in packages into the PL/SQL Editor and Stored PL/SQL Editor.


See also

Section 4.13.2.4, "Inserting syntax into the PL/SQL Editor"






2.6.4 About program units

Program units are packages, functions, or procedures that you can reference from any PL/SQL within the current report.




	
Note:

Program units cannot be referenced from other documents. If you want to create a package, function, or procedure that can be referenced from multiple documents, create an external PL/SQL library (see Section 4.13.5.1, "Creating an external PL/SQL library").









For a detailed example of using PL/SQL in a report, see Chapter 40, "Building a Report that Includes PL/SQL".


Restrictions

	
If you delete a PL/SQL package, function, or procedure, you must also delete all references to it in your report. Otherwise, you will get an error when you compile, generate, or run the report.


	
PL/SQL package, function, and procedure names must be unique within the report and may not duplicate the names of any columns, groups, queries, or printable objects.





Example: Referencing a PL/SQL function in formulas

Suppose that you have a report with the following groups and columns:


Groups    Columns         Summary 
-----------------------------------------
RGN       REGION
          RGNSUMSAL       SUM(DEPTSUMSAL)
          COSTOFLIVING
                   
DEPT      DNAME
          DEPTNO
          DEPTSUMSAL      SUM(EMP.SAL)
                   
JOB       JOB
          HEADCOUNT       COUNT(EMP.EMPNO)
                   
EMP       ENAME
          EMPNO
          SAL
          COMM


Given these groups and columns, you might create multiple formulas that apply the cost of living factor (COSTOFLIVING) to salaries. To avoid duplication of effort, you could create the following PL/SQL function and reference it from the formulas:


function CompSal(salary number) return number is
begin
  return (salary*CostofLiving);
end;


Following are some examples of how you might reference the PL/SQL function in formulas:


CompSal(:RGNSUMSAL)

or

CompSal(:SAL) + COMM



See also

Section 4.13.3.1, "Creating a local program unit"






2.6.5 About stored program units

Stored program units (also known as stored subprograms, or stored procedures) can be compiled separately and stored permanently in an Oracle database, ready to be executed. Once compiled and stored in the data dictionary, they are schema objects, which can be referenced by any number of applications connected to that database.

Stored program units offer higher productivity, better performance, memory savings, application integrity, and tighter security. For example, by designing applications around a library of stored procedures and functions, you can avoid redundant coding and increase your productivity.

Stored program units are stored in parsed, compiled form. So, when called, they are loaded and passed to the PL/SQL engine immediately. Also, they take advantage of shared memory. So, only one copy of a program unit need be loaded into memory for execution by multiple users.

Because stored program units run in ORACLE, they can perform database operations more quickly than PL/SQL that is local to your report. Therefore, in general, use stored program units for PL/SQL that performs database operations. Use local program units for PL/SQL that does not involve database operations. However, if you are on a heavily loaded network with very slow response time, using stored program units may not be faster for database operations. Similarly, if your server is significantly faster than your local machine, then using local program units may not be faster for non-database operations.


See also

Section 4.13.3.2, "Creating a stored program unit"






2.6.6 About external PL/SQL libraries

External PL/SQL libraries are collections of PL/SQL procedures, functions, and packages that are independent of a report definition. By attaching an external library to a report, you can reference its contents any number of times. For example, you could reference a procedure in an attached library from both a Before Report trigger and a format trigger. This eliminates the need to re-enter the same PL/SQL for each application.

When you associate an external PL/SQL library with a report or another external library, it is called an attached library.


See also

Section 4.13.5.1, "Creating an external PL/SQL library"






2.6.7 About attached libraries

Attached libraries are external PL/SQL libraries that you have associated with a report or another external library. When an external library is attached, you can reference its packages, functions, and procedures from within your report. For example, if you attached an external library name MYLIB to your report and it contained a function named ADDXY, then you could reference ADDXY from any PL/SQL in the report.

External PL/SQL libraries are independent of a report definition.


Usage notes

Local PL/SQL executes more quickly than a reference to a procedure or function in an external PL/SQL library. As a result, you should only use external PL/SQL libraries when the benefits of sharing the code across many applications outweigh the performance overhead.


Restrictions

	
If Oracle Reports Builder cannot find a library that you specify in the Attached Libraries list, a warning will be raised when you accept the dialog box, save the report, or open the report. If you try to run the report or compile the PL/SQL in it, an error will be raised.


	
The Attached Libraries list is saved. The next time you open the report or library the list will have the same contents it did when you last saved the report.


	
If an external library references another library, you must attach both libraries to the report even if the first library already has the second one attached.





See also

Section 4.13.5.5, "Attaching a PL/SQL library"






2.6.8 About formulas

Formulas are PL/SQL functions that populate formula or placeholder columns. You can access the PL/SQL for formulas from the Object Navigator, the PL/SQL Editor, or the Property Inspector (that is, the PL/SQL Formula property).

A column with Datatype property set to Number can only have a formula that returns a value of datatype NUMBER. A column with Datatype property set to Date can only have a formula that returns a value of datatype DATE. A column with Datatype property set to Character can only have a formula that returns a value of datatype CHARACTER, VARCHAR, or VARCHAR2.


Restrictions

	
You can read and assign values to a column in a formula, if the column is a placeholder or parameter column; you cannot change the value of database columns (values retrieved from the database). For example, you can use the value of a column called COMP in a condition (for example, IF :COMP = 10) and you can directly set its value in an assignment statement (for example,:COMP:= 15).


	
A formula can only make reference to columns that are in the same or a higher group in the group hierarchy. For example, a formula for a report-level column can only reference other report-level columns.


	
Formulas are calculated such that any column referenced in the formula will be calculated first. To do so, Oracle Reports Builder builds a dependency list, to guarantee proper ordering of calculations. Note that circular dependencies, in which a column references another column which in turn references the first column, either directly or indirectly, are not allowed.


	
When using SRW.DO_SQL, we recommend that you do not read database values that are updated or inserted in the same report. There is no guarantee of the exact time Oracle Reports Builder will fetch records from the database for formatting the output. Oracle Reports Builder does internal "data look-ahead" to optimize performance. Thus, a particular record might already have been accessed before an update is issued to the same record. Oracle Reports Builder builds internal dependency lists which guarantee that events, such as invocation of user exits, calculation of summaries, and so on, happen in the correct order. However, Oracle Reports Builder cannot guarantee these events will be synchronized with its internal data access or with the formatting of data.





Examples


Example 1: Adding values

The following example populates the column with the value of the salary plus the commission.


function salcomm return NUMBER is
begin
  return(:sal + :comm);
end;



Example 2: Using conditions

The following code adds the commission to the salary if the value for the commission is not null.


function calcomm return NUMBER is
temp number;
begin
  if :comm IS NOT NULL then
    temp := :sal + :comm;
  else
    temp := :sal;
  end if;
  return (temp);
end;



See also

Section 2.3.2, "About formula columns"

Section 4.13.4.3, "Creating or editing a formula column"

Section 4.13.4.4, "Creating a placeholder column"






2.6.9 About group filters

A group filter determines which records to include in a group. You can use the packaged filters, First and Last, to display the first n or last n records for the group, or you can create your own filters using PL/SQL. You can access group filters from the Object Navigator, the Property Inspector (the PL/SQL Filter property), or the PL/SQL Editor.

The function must return a boolean value (TRUE or FALSE). Depending on whether the function returns TRUE or FALSE, the current record is included or excluded from the report.


Difference between group filters and Maximum Rows to Fetch property

The Maximum Rows to Fetch property restricts the actual number of records fetched by the query. A group filter determines which records to include or exclude, after all the records have been fetched by the query. Since Maximum Rows to Fetch actually restricts the amount of data retrieved, it is faster than a group filter in most cases. If you set the Filter Type property to Last or Conditional, Oracle Reports Builder must retrieve all of the records in the group before applying the filter. Also, you should be aware that when using Maximum Rows to Fetch for queries, it can affect summaries in other groups that depend on this query. For example, if you set the Maximum Rows to Fetch property to 8, any summaries based on that query will only use the 8 records retrieved.


Restrictions

	
Group filters cannot be added to groups if the Filter Type property is set to First or Last.

Group filters cannot be added to cross-product groups.


	
The function that you enter for a group filter can only depend upon the following columns:

	
a database column owned by the group's query or a query above it in the data model hierarchy


	
computed columns (formulas or summaries) that depend on unrelated queries (that is, computed columns that do not depend upon columns in the group, the group's ancestors, or the group's descendants)





	
In a group filter, you can read the values of Oracle Reports Builder columns and parameters of the correct frequency, but you cannot directly set their values. For example, you can use the value of a parameter called COUNT1 in a condition (for example, IF :COUNT1 = 10), but you cannot directly set its value in an assignment statement (for example, :COUNT1:= 10). Note also that the use of PL/SQL global variables to indirectly set the values of columns or parameters is not supported. If you do this, you may get unpredictable results. You also cannot reference any page-dependent columns (that is, Reset At of Page) or columns that rely on page-dependent columns in a group filter.





Example


function filter_comm return boolean is
begin
  if :comm IS NOT NULL then
    if :comm < 100 then
      return (FALSE);
    else
      return (TRUE);
    end if;
  else
    return (FALSE); -- for rows with NULL commissions
  end if;
end;



See also

Section 4.13.4.2, "Creating or editing a group filter"






2.6.10 About REF CURSOR queries

A REF CURSOR query uses PL/SQL to fetch data. Each REF CURSOR query is associated with a PL/SQL function that returns a cursor value from a cursor variable. The function must ensure that the REF CURSOR is opened and associated with a SELECT statement that has a SELECT list that matches the type of the REF CURSOR.




	
Note:

The use of REF CURSOR queries in Oracle Reports 11g Release 2 (11.1.2) requires that your database version is 10.1.0.5 (for 10.1) or 10.2.0.2 (for 10.2) or higher.

Interoperability between a 11g Release 2 (11.1.2) database or Oracle Forms Services client and a 10.1/10.2 database requires a minimum patchset level of 10.1.0.5 (for 10.1) or 10.2.0.2 (for 10.2).

An attempt to reference a 10.1 or 10.2 PL/SQL unit or view under the following circumstances will fail with a PLS-801[55916] error unless the 10.1 or 10.2 environment has been patched to the right level:

	
A PL/SQL unit, anonymous block, trigger, call statement, or SQL statement on a 11g Release 2 (11.1.2) database invokes a PL/SQL unit on a 10.1 or 10.2 database across a database link.


	
A PL/SQL unit, anonymous block, trigger, or call statement on a 11g Release 2 (11.1.2) database references a view on a 10.1 or 10.2 database across a database link and the view directly or indirectly references a PL/SQL function or an object type.


	
An Oracle Forms Services 11g Release 2 (11.1.2) client invokes a PL/SQL unit in a 10.1 or 10.2 database using RPC.












Oracle Reports supports both static and dynamic REF CURSORs. For example:

Static REF CURSOR:


open l_rc for SELECT * FROM emp WHERE ename = 'KING';


Dynamic REF CURSOR:


l_query := SELECT empno, ename, sal, hiredate FROM emp WHERE 1-1';
open l_rc for l_query;





	
Note:

The SELECT statement must be explicitly set for dynamic REF CURSORs.









For a detailed example, see Chapter 41, "Building a Paper Report with REF CURSORs".


Usage notes

	
Oracle Reports supports only strongly typed REF CURSORs. For example:


type c1 is REF CURSOR RETURN emp%ROWTYPE;


	
When you make a REF CURSOR query the child in a data link, the link can only be a group to group link. It cannot be a column to column link.


	
If you use a stored program unit to implement REF CURSORs, you receive the added benefits that go along with storing your program units in the Oracle database.


	
You base a query on a REF CURSOR when you want to:

	
more easily administer SQL.


	
avoid the use of lexical parameters in your reports.


	
share data sources with other applications, such as Form Builder.


	
increase control and security.


	
encapsulate logic within a subprogram.







Furthermore, if you use a stored program unit to implement REF CURSORs, you receive the added benefits that go along with storing your program units in the Oracle database.

For more information about REF CURSORs and stored subprograms, refer to the PL/SQL User's Guide and Reference.


Examples


Example 1: Package with REF CURSOR example


/* This package spec defines a REF CURSOR
** type that could be referenced from a
** REF CURSOR query function.
** If creating this spec as a stored
** procedure in a tool such as SQL*Plus,
** you would need to use the CREATE
** PACKAGE command.
*/
 
PACKAGE cv IS
type comp_rec is RECORD 
  (deptno number,
   ename varchar(10),
   compensation number);
type comp_cv is REF CURSOR return comp_rec;
END;



Example 2: Package with REF CURSOR and function


/* This package spec and body define a ref
** cursor type as well as a function that
** uses the REF CURSOR to return data.
** The function could be referenced from
** the REF CURSOR query, which would
** greatly simplify the PL/SQL in the
** query itself. If creating this spec
** and body as a stored procedure in a
** tool such as SQL*Plus, you would need
** to use the CREATE PACKAGE and CREATE
** PACKAGE BODY commands.
*/
 
PACKAGE cv IS
type comp_rec is RECORD
  (deptno number,
   ename varchar(10),
   compensation number);
type comp_cv is REF CURSOR return comp_rec;
function emprefc(deptno1 number) return comp_cv;
END;
 
PACKAGE BODY cv IS
function emprefc(deptno1 number) return comp_cv is
  temp_cv cv.comp_cv;
begin
  if deptno1 > 20 then
    open temp_cv for select deptno, ename,
    1.25*(sal+nvl(comm,0)) compensation
    from emp where deptno = deptno1;
  else
    open temp_cv for select deptno, ename,
    1.15*(sal+nvl(comm,0)) compensation
    from emp where deptno = deptno1; 
  end if;
  return temp_cv;
end;
END;



Example 3: REF CURSOR query


/* This REF CURSOR query function would be coded
** in the query itself. It uses the cv.comp_cv
** REF CURSOR from the cv package to return
** data for the query.
*/
function DS_3RefCurDS return cv.comp_cv is
  temp_cv cv.comp_cv;
begin
  if :deptno > 20 then
    open temp_cv for select deptno, ename,
    1.25*(sal+nvl(comm,0)) compensation
    from emp where deptno = :deptno;
  else
   open temp_cv for select deptno, ename,
   1.15*(sal+nvl(comm,0)) compensation
   from emp where deptno = :deptno;
  end if;
  return temp_cv;
end;



Example 4: REF CURSOR query calling function


/* This REF CURSOR query function would be coded
** in the query itself. It uses the cv.comp_cv
** REF CURSOR and the cv.emprefc function from
** the cv package to return data for the query.
** Because it uses the function from the cv
** package, the logic for the query resides
** mainly within the package. Query
** administration/maintenance can be
** done at the package level (for example,
** modifying SELECT clauses could be done
** by updating the package). You could also
** easily move the package to the database.
** Note this example assumes you have defined
** a user parameter named deptno.
*/

function DS_3RefCurDS return cv.comp_cv is
  temp_cv cv.comp_cv;
begin
  temp_cv := cv.emprefc(:deptno);
  return temp_cv;
end;



See also

Section 4.8.1.7, "Creating a query: REF CURSOR Query tool"






2.6.11 About DML and DDL

If you want to use Data Manipulation Language (DML) or Data Definition Language (DDL) in your PL/SQL, you can use the SRW.DO_SQL built-in procedure. Note that SRW.DO_SQL should only be used for DML and DDL; you should not use it to fetch data. For more information on DML and DDL, see the Oracle Server SQL Language Reference manual.

Because of Oracle Reports' processing model, it is recommended that you only use DDL in the Before Parameter Form and After Parameter Form triggers. DML can be entered any place that accepts PL/SQL.

Any DML or DDL that will reported on with this report's processing should be done in (or before) the After Parameter Form trigger. Consistency cannot be guaranteed in the Before Report trigger, since Oracle Reports may have to start some work on data cursors before that trigger based on the definition of the report. One thing Oracle Reports Builder always does before the Before Report trigger is to describe the tables involved and open cursors. Any change to the tables after that will not be seen by the report.


See also

Section 2.6.13.1, "About report triggers"






2.6.12 About built-in packages

A built-in package is a group of logically related PL/SQL types, objects, and functions or procedures. It generally consists of two parts: the package spec (including data declarations) and the package body. Packages are especially useful because they allow you to create global variables.

Oracle provides several packaged procedures that you can use when building or debugging your PL/SQL-based applications. Your PL/SQL code can make use of the procedures, functions, and exceptions in the Oracle Reports Builder built-in package (SRW), and numerous Tools built-in packages, as described below.



2.6.12.1 About the Oracle Reports Builder built-in package (SRW)

Oracle Reports Builder is shipped with a built-in package (SRW), a collection of PL/SQL constructs that include many functions, procedures, and exceptions you can reference in any of your libraries or reports.

The PL/SQL provided by the SRW package enables you to perform such actions as change the formatting of fields, run reports from within other reports, create customized messages to display in the event of report error, and execute SQL statements.

You can reference the contents of the SRW package from any of your libraries or reports without having to attach it. However, you cannot reference its contents from within another product, for example, from SQL*Plus.

Constructs found in a package are commonly referred to as "packaged" (that is, packaged functions, packaged procedures, and packaged exceptions).


See also

Topic "SRW built-in package" in the Reference section of the Oracle Reports online Help






2.6.12.2 About the Tools built-in packages

Several client-side built-in packages are provided that contain many PL/SQL constructs you can reference while building applications or debugging your application code. These built-in packages are not installed as extensions to the package STANDARD. As a result, any time you reference a construct in one of the packages, you must prefix it with the package name (for example, TEXT_IO.PUT_LINE).

The Tools built-in packages are:

	
DDE

Provides Dynamic Data Exchange support within Oracle Reports Builder components.


	
DEBUG

Provides procedures, functions, and exceptions for when debugging your PL/SQL program units. Use these built-in subprograms to create debug triggers and set breakpoints with triggers.


	
EXEC_SQL

Provides procedures and functions for executing dynamic SQL within PL/SQL code written for Oracle Reports Builder applications.


	
LIST

Provides procedures, functions, and exceptions you can use to create and maintain lists of character strings (VARCHAR2). This provides a means of creating arrays in PL/SQL Version 1.


	
ORA_FFI

Provides a foreign function interface for invoking C functions in a dynamic library.


	
ORA_JAVA

Provides an interface for invoking Java classes from PL/SQL.


	
ORA_NLS

Enables you to extract high-level information about your current language environment. This information can be used to inspect attributes of the language, enabling you to customize your applications to use local date and number format. Information about character set collation and the character set in general can also be obtained. Facilities are also provided for retrieving the name of the current language and character set, allowing you to create applications that test for and take advantage of special cases.


	
ORA_PROF

Provides procedures, functions, and exceptions you can use for tuning your PL/SQL program units (for example, examining how much time a specific piece of code takes to run).


	
TEXT_IO

Provides constructs that allow you to read and write information from and to files. There are several procedures and functions available in Text_IO, falling into the following categories:

	
file operations. The FILE_TYPE record, the FOPEN and IS_OPEN functions, and the FCLOSE procedure enable you to define FILE_TYPE variables, open files, check for open files, and close open files, respectively.


	
output (write) operations. The PUT, PUTF, PUT_LINE, and NEW_LINE procedures enable you to write information to an open file or output it to the PL/SQL Interpreter.


	
input (read) operations. The GET_LINE procedure enables you to read a line from an open file





	
TOOL_ENV

Enables you to interact with Oracle environment variables by retrieving their values for use in subprograms.


	
TOOL_ERR

Enables you to access and manipulate the error stack created by other built-in packages such as DEBUG.

In addition to using exceptions to signal errors, some built-in packages (for example, the DEBUG package) provide additional error information. This information is maintained in the form of an "error stack".

The error stack contains detailed error codes and associated error messages. Errors on the stack are indexed from zero (oldest) to n-1 (newest), where n is the number of errors currently on the stack. Using the services provided by the TOOL_ERR package, you can access and manipulate the error stack.


	
TOOL_RES

Provides a means of extracting string resources from a resource file with the goal of making PL/SQL code more portable by isolating all textual data in the resource file.




The following packages are used only internally by Oracle Reports. There are no subprograms available for external use with these packages.

	
ORA_DE

Contains constructs used by Reports for private PL/SQL services.


	
STPROC

Calls subprograms stored in the database. Calls to this package are automatically generated Note: STPROC is obsoleted in Oracle Reports 11g Release 2 (11.1.2).


	
JNI

Facilitates calling Java from PL/SQL.





See also

Topics for each of the Tools built-in packages under in the Reference > PL/SQL Reference > Built-in Packages section of the Oracle Reports online Help.








2.6.13 About triggers

Triggers check for an event. When the event occurs they run the PL/SQL code associated with the trigger.

Report triggers are activated in response to report events such as the report opening and closing rather that the data that is contained in the report. They are activated in a predefined order for all reports.

Format triggers are executed before an object is formatted. A format trigger can be used to dynamically change the formatting attributes of the object.

Validation triggers are PL/SQL functions that are executed when parameter values are specified on the command line and when you accept the Runtime Parameter Form.

Database triggers are procedures that are stored in the database and implicitly executed when a triggering statement such as INSERT, UPDATE, or DELETE is issued against the associated table.



2.6.13.1 About report triggers

Report triggers execute PL/SQL functions at specific times during the execution and formatting of your report. Using the conditional processing capabilities of PL/SQL for these triggers, you can do things such as customize the formatting of your report, perform initialization tasks, and access the database. To create or modify a report trigger, you use the Report Triggers node in the Object Navigator. Report triggers must explicitly return TRUE or FALSE.

Oracle Reports has five global report triggers. You cannot create new global report triggers. The trigger names indicate at what point the trigger fires:

	
Before Report trigger: Fires before the report is executed but after queries are parsed.


	
After Report trigger: Fires after you exit the Paper Design view, or after report output is sent to a specified destination, such as a file, a printer, or an e-mail ID. This trigger can be used to clean up any initial processing that was done, such as deleting tables. Note, however, that this trigger always fires, whether or not your report completed successfully.


	
Between Pages trigger: Fires before each page of the report is formatted, except the very first page. This trigger can be used for customized page formatting. In the Paper Design view, this trigger only fires the first time that you go to a page. If you subsequently return to the page, the trigger does not fire again.


	
Before Parameter Form trigger: Fires before the Runtime Parameter Form is displayed. From this trigger, you can access and change the values of parameters, PL/SQL global variables, and report-level columns. If the Runtime Parameter Form is suppressed, this trigger still fires. Consequently, you can use this trigger for validation of command line parameters.


	
After Parameter Form trigger: Fires after the Runtime Parameter Form is displayed. From this trigger, you can access parameters and check their values. This trigger can also be used to change parameter values or, if an error occurs, return to the Runtime Parameter Form. Columns from the data model are not accessible from this trigger. If the Runtime Parameter Form is suppressed, the After Parameter Form trigger still fires. Consequently, you can use this trigger for validation of command line parameters or other data.





Order of report trigger execution

The order of events when a report is executed is as follows:

	
Before Parameter Form trigger is fired.



	
Note:

If the Parameter Form is used on the Web, the Before Parameter Form trigger fires twice: once when the Parameter Form is displayed, and a second time when the parameters are submitted. This is because Oracle Reports executes in a stateless fashion. There is no session to return to, so the Before Parameter Form trigger has to fire the second time to ensure that the parameters selected on the Parameter Form and passed on the command line are valid.








	
Runtime Parameter Form appears (if not suppressed).


	
After Parameter Form trigger is fired (unless the user cancels from the Runtime Parameter Form).


	
Report is "compiled".


	
Queries are parsed.


	
Before Report trigger is fired.


	
SET TRANSACTION READONLY is executed (if specified with the READONLY command line keyword or setting).


	
The report is executed and the Between Pages trigger fires for each page except the first one. (Note that data can be fetched at any time while the report is being formatted.) COMMITs can occur during this time due to: SRW.DO_SQL with DDL, or if ONFAILURE=COMMIT, and the report fails.


	
COMMIT is executed (if READONLY is specified) to end the transaction.


	
After Report trigger is fired.


	
COMMIT/ROLLBACK/NOACTION is executed based on what was specified with the ONSUCCESS command line keyword or setting.





Usage notes

	
In steps 4 through 9, avoid DDL statements that would modify the tables on which the report is based. Step 3 takes a snapshot of the tables and the snapshot must remain valid throughout the execution of the report. In steps 7 through 9, avoid DML statements that would modify the contents of the tables on which the report is based. Queries may be executed in any order, which makes DML statements unreliable (unless performed on tables not used by the report).


	
If you specify READONLY on the command line, you should avoid DDL altogether. When you execute a DDL statement (for example, with SRW.DO_SQL), a COMMIT is automatically issued. If you are using READONLY, this will prematurely end the transaction begun by SET TRANSACTION READONLY


	
As a general rule, any processing that will affect the data retrieved by the report should be performed in the Before Parameter Form or After Parameter Form triggers. (These are the two report triggers that fire before anything is parsed or fetched.) Any processing that will not affect the data retrieved by the report can be performed in the other triggers.


	
Consistency is guaranteed if you use DML or DDL in (or before) the After Form Trigger. However, consistency is not guaranteed in the Before Report trigger, since Oracle Reports may have to start work on data cursors before that trigger based on the definition of the report. Before the Before Report trigger, Oracle Reports describes the tables involved and opens cursors. Any change to the tables after that will not be seen by the report.





Restrictions

	
If you are sending your report output to the Paper Design view or Previewer, you should note that some or all of the report triggers may be fired before you see the report output. For example, suppose that you use SRW.MESSAGE to issue a message in the Between Pages trigger when a condition is met. If there are forward references in the report (for example, a total number of pages displayed before the last page), Oracle Reports may have to format ahead to compute the forward references. Hence, even though you have not yet seen a page, it may already have been formatted and the trigger fired.


	
In report triggers, you can use the values of report-level columns and parameters. For example, you might need to use the value of a parameter called COUNT1 in a condition (for example, IF :COUNT1 = 10). Note, though, that you cannot reference any page-dependent columns (that is, a column with a Reset At property set to Page) or columns that rely on page-dependent columns.


	
In the Before and After Parameter Form, and Before and After Report triggers, you can set the values of parameters (for example, give them a value in an assignment statement, :COUNT1 = 15). In the Before and After Report triggers, you can also set the values of report-level, placeholder columns.


	
In the Between Pages trigger, you cannot set the values of any data model objects. Note also that the use of PL/SQL global variables to indirectly set the values of columns or parameters is not recommended. If you do this, you may get unpredictable results.


	
A lexical reference cannot be used to create additional bind variables after the After Parameter Form trigger fires. For example, suppose you have a query like the following (note that the WHERE clause is replaced by a lexical reference):

SELECT ENAME, SAL FROM EMP

&WHERE_CLAUSE

If the value of the WHERE_CLAUSE parameter contains a reference to a bind variable, you must specify the value in the After Parameter Form trigger or earlier. You would get an error if you supplied the following value for the parameter in the Before Report trigger. If you supplied this same value in the After Parameter Form trigger, the report would run.

WHERE SAL = :new_bind





See also

Section 4.13.3.5, "Creating a report trigger"

Section 4.13.3.6, "Deleting a report trigger"






2.6.13.2 About format triggers

A format trigger is a PL/SQL function executed before an object is formatted. A trigger can be used to dynamically change the formatting attributes of the object. For example, you can use a format trigger to cause a value to display in bold if it is less than zero. Another example is to use a format trigger to use scientific notation for a field if its value is greater than 1,000,000.

A format trigger can fire multiple times for a given object, whenever Oracle Reports Builder attempts to format the object. Consider the case where Oracle Reports Builder starts to format the object at the bottom of a page. If the object does not fit on the page, Oracle Reports Builder stops formatting and reformats on the following page. In this case, the format trigger will fire twice. It is therefore not advisable to do any kind of "persistence" operation, such as logging, in this trigger.

The Oracle Reports Builder SRW built-in package contains PL/SQL procedures with which you can quickly change the format attributes of an object. These include procedures to:

	
change the border pattern and color of an object


	
change the interior pattern and color of an object


	
change the font size, style, weight, spacing, and justification of a field or boilerplate text


	
change the format mask of a field


	
access a field's value





Examples

See the topic "Format trigger" in the Reference section of the Oracle Reports online Help.


See also

Section 4.13.4.1, "Creating or editing a format trigger"






2.6.13.3 About validation triggers

Validation triggers are PL/SQL functions that are executed when parameter values are specified on the command line and when you accept the Runtime Parameter Form.




	
Note:

For JSP-based Web reports, the Runtime Parameter Form displays when you run a report in Oracle Reports Builder, but does not display in the runtime environment. If parameters are not specified on the Runtime Parameter Form, the validation trigger returns false and generates error message rep-546 Invalid Parameter Input error. Thus, you need to provide the parameters in an alternate way, as described in Section 1.9.4, "About Parameter Forms for Web reports".









Validation triggers are also used to validate the Initial Value property of the parameter. Depending on whether the function returns TRUE or FALSE, the user is returned to the Runtime Parameter Form.


Example

See the topic "Validation trigger" in the Reference section of the Oracle Reports online Help.


See also

Section 4.11.4, "Validating a parameter value at runtime"






2.6.13.4 About database triggers

Database triggers are procedures that are stored in the database and implicitly executed when a triggering statement such as INSERT, UPDATE, or DELETE is issued against the associated table. Triggers can be defined only on tables, not on views. However, triggers on the base table of a view are fired if an INSERT, UPDATE, or DELETE statement is issued against a view.

A trigger can include SQL and PL/SQL statements that execute as a unit, and can invoke other stored procedures. Use triggers only when necessary. Excessive use of triggers can result in cascading or recursive triggers. For example, when a trigger is fired, a SQL statement in the trigger body potentially can fire other triggers.

By using database triggers, you can enforce complex business rules and ensure that all applications behave in a uniform manner. Use the following guidelines when creating triggers:

	
Use triggers to guarantee that when a specific operation is performed, related actions are performed.


	
Use database triggers only for centralized, global operations that should be fired for the triggering statement, regardless of which user or database application issues the statement.


	
Do not define triggers that duplicate the functionality already built into Oracle. For example, do not define triggers to enforce data integrity rules that can be easily enforced using declarative integrity constraints.


	
Limit the size of triggers (60 lines or fewer is a good guideline). If the logic for your trigger requires much more than 60 lines of PL/SQL code, it is better to include most of the code in a stored procedure, and call the procedure from the trigger.


	
Be careful not to create recursive triggers. For example, creating an AFTER UPDATE statement trigger on the EMP table that itself issues an UPDATE statement on EMP causes the trigger to fire recursively until it has run out of memory.




For additional information about how triggers are used in applications, see the Oracle Application Developer's Guide. See the Oracle Concepts Manual for more information about the different types of triggers.


See also

Section 4.13.3.7, "Creating a database trigger"










8.2 Create a New Report Manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.


To create a blank report:

	
Launch Reports Builder (or, if already open, choose File > New > Report)


	
In the Welcome or New Report dialog box, select Build a new report manually, then click OK.









31.6 Create a Check Stub With Payment Information and Order Details

When you create a check printing report, you will sometimes want to create a check "stub" that contains the payment information on the check, as well as the details of the order. The steps in this section will show you how to create a check stub that contains the payee, amount, date, check number, and other payment information.

You will then use the information retrieved by the second query in your data model to print a simple tabular report on the check stub that displays the order information associated with the check.



31.6.1 Create a check stub in the Paper Design view

The steps in this section will show you how to use the tools in the Paper Design view to create a check stub for your check report. You will rearrange the fields you created in the previous section so that every time you run the report, a corresponding check stub will display for every check.

You will also create guidelines in the Paper Design view to help you align the check stub information with the data in the check report.


To create a check stub:

	
Click the Flex Off button in the toolbar.


	
Click in the left, vertical ruler and drag your mouse to the right, so that the line is flush with the text "Pay Exactly."


	
When you release your mouse button, you will notice that a guideline displays, like the one in the following image:


Figure 31-21 Partial Paper Design view of the check report with horizontal guideline

[image: Description of Figure 31-21 follows]









	
Note:

The guideline is a broken black line spanning across this image, to the right of "Pay Exactly."










	
Click the Order No. boilerplate object (located in the upper left-hand corner of the check) and position it along the new guideline, and below the check image at 3.25 inches (8.5 centimeters), like this:


Figure 31-22 Partial Paper Design view of the check with Order No. boilerplate text

[image: Description of Figure 31-22 follows]






	
Create another vertical guideline that is aligned next to the first one.


	
Click the F_ORDER_ID field (in the above image, it is the field with "2354") and position it next to the Order No. field, like this:


Figure 31-23 Order No. and F_ORDER_ID fields in the Paper Design view

[image: Description of Figure 31-23 follows]









	
Note:

You can always select your fields in the Object Navigator, under Paper Layout > Main Section > Body, and these fields will appear selected in the Paper Design view.










	
Now, click the Order Date boilerplate text and position it di