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Preface

Agile PLM is a comprehensive enterprise PLM solution for managing your product 
value chain. 

Audience
This document is intended for administrators and users of the Agile PLM products.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or 
visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

Related Documents
Oracle's Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle 
Technology Network (OTN) Web site 
http://www.oracle.com/technetwork/documentation/agile-085940.html contains 
the latest versions of the Agile PLM PDF files. You can view or download these 
manuals from the Web site, or you can ask your Agile administrator if there is an Agile 
PLM Documentation folder available on your network from which you can access the 
Agile PLM documentation (PDF) files. 

Conventions
The following text conventions are used in this document:

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated 
with an action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for 
which you supply particular values.
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monospace Monospace type indicates commands within a paragraph, URLs, code 
in examples, text that appears on the screen, or text that you enter.

Convention Meaning
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1Introduction to Recipe & Material Workspace 
Administration

Agile Product Lifecycle Management (PLM) introduces Recipe & Material Workspace 
(Recipe Management for Pharmaceuticals ) with PLM Release 9.3.1.

Introducing Recipe & Material Workspace
The Recipe Management for Pharmaceuticals  solution enables biotechnology and 
pharmaceutical development companies to create products as well as improve 
business productivity, visibility, scientific outcomes, and proactive compliance during 
the product development lifecycle.

Recipe Management for Pharmaceuticals  Administrator Nodes for 
Configuration

The list below summarizes the functions that can be configured in each administrative 
node of Recipe Management for Pharmaceuticals . Most of the nodes are accessed in 
the Tools & Settings dropdown menu. People and Organizations are accessed using 
the Search dropdown menu.

System Tools
The System Tools node lets you manage Data Audit Trails. Recipe Management for 
Pharmaceuticals  provides audit trails on key functions to conform to regulatory 
requirements. For example, if anyone changes an attribute for a piece of equipment, 
that change is logged and maintained in an Audit Trail File. This function is detailed in 
System Tools.

Settings
The Settings node includes Default Preferences, Image, and Image Map. These 
functions are detailed in Settings.

Alerts/Workflows
This section describes the Alerts/Workflows node.

Alerts
The Alerts/Workflows node lets you provide alerts for the user. For example, you 
provide permissions for a user to use an alert for a group. When the user wants to 
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send out an alert to all members of that group, it is sent to the group, not to each 
individual member. These functions are detailed in Alerts.

Workflows
Besides alerts, the Alerts/Workflows node also lets you automate manual processes 
into Workflows, Workflow States, and Workflow State Actions.

These functions are detailed in Workflows.

Administration
The Administration node lets you manage Library (that is, Records), Internal ID, 
Object Lock, Cache, and Service. These functions are detailed in Administration.

Object Modeling
The Object Modeling node helps you manage those data objects that are required by 
the database. You can create new Categories (also known as Business Objects or 
Tables), Attributes, Views, Subviews, Enumerated Valid Values, Units Of Measure 
(UOM), UOM Groups, and UOM Conversions. These functions are detailed in Object 
Modeling. Also see Keywords used by Recipe Management for Pharmaceuticals  
System.

Integration
The Integration node lets you manage Application, Web Service, and Test functions. 
These functions are detailed in Integration.

The Web service integrated framework invokes external Web services and plugged-in 
custom-built Web services. The integration is XML-based. All communication between 
the client and the external application is in XML format.

People
The Recipe Management for Pharmaceuticals  administrator accesses People via the 
Search field (using the dropdown arrow). The "People" selection lets you choose User, 
User Group, Contact, and Role. These functions are detailed in People.

Organizations
The Recipe Management for Pharmaceuticals  administrator accesses Organizations 
via the Search field (using the dropdown arrow). The "Organizations" selection lets 
you choose Company, Site, Location, Department, and Site Qualification. These 
functions are detailed in Organizations.

General Administration and Configuration Files
Default settings and utility services for Recipe Management for Pharmaceuticals , and 
some troubleshooting procedures, are detailed in General Administration.

Configuration information of the Recipe Management for Pharmaceuticals  
application, such as authentication type, audit trail enabling/disabling, the list of 
resource files and so on, is stored in a set of configuration files, which are detailed in 
Configuration Files.

Reserved keywords are detailed in Keywords.
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What's New
The following sections describe new features as they are introduced in a particular 
release.

New Features in Recipe Management for Pharmaceuticals  Material Management in 
9.3.3

No new administrator features were introduced in Recipe Management for 
Pharmaceuticals  Release 9.3.3.

New Features in Recipe Management for Pharmaceuticals  Material Management in 
9.3.1.2

No new administrator features were introduced in Recipe Management for 
Pharmaceuticals  Release 9.3.1.2.

New Features in Recipe Management for Pharmaceuticals  Administrator Nodes for 
9.3.1.1

New administrator features in Recipe Management for Pharmaceuticals  Release 
9.3.1.1 include the following:

■ Multiple language support is now available for Recipe Management for 
Pharmaceuticals . See Multiple Language Support in Recipe Management for 
Pharmaceuticals .

■ Labels, including but not limited to EVV values and view names, can be localized. 
All labels that can be localized can also be customized or overridden. See 
Localizing EVV Value and Customizing and Localizing Labels for details.

■ There are licensing tasks that must be completed in Agile PLM before a user is able 
to see the link to switch to Recipe Management for Pharmaceuticals . For more 
information about this, see Administrator Access to and from Recipe Management 
for Pharmaceuticals .

■ Recipe Management for Pharmaceuticals  users cannot set the preferences of 
Language, Date Format, or Time Zone preferences from the Recipe Management 
for Pharmaceuticals  user preferences option. The menu items for managing Locale 
and Number Format have been removed. All of these settings are inherited from 
the Agile PLM side.

■ You can no longer explicitly lock or unlock user-locked objects. You can, however, 
unlock objects that are currently being edited that have been locked by Recipe 
Management for Pharmaceuticals . See Unlocking Objects Currently Being 
Modified.

■ The locking grid (where the user can freeze display of a few columns and scroll to 
see the data in the other columns) has been removed.

■ The user with login 'administrator' has been removed from Recipe Management 
for Pharmaceuticals , to meet the default settings of Agile PLM.
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2Integrating Agile Recipe Management for 
Pharmaceuticals with Agile PLM

This chapter provides information about prerequisite settings in PLM Administrator 
and system files. The two main areas of integration are:

■ the configuration of PLM users so they can work in Agile Recipe Management for 
Pharmaceuticals, and

■ the configuration of PLM business objects that can be leveraged in Agile Recipe 
Management for Pharmaceuticals.

The material in this chapter must be thoroughly and sequentially applied before 
refining Agile Recipe Management for Pharmaceuticals users and the Agile Recipe 
Management for Pharmaceuticals solution itself (as documented in the rest of this 
manual).

Administrator and User Access to Agile Recipe Management for 
Pharmaceuticals

This section presents some tasks that permit access to the Agile Recipe Management 
for Pharmaceuticals user interface in Agile Web Client, as a starting point. This table 
gives a summary of configuration to work in Agile Recipe Management for 
Pharmaceuticals:

Administrator User or 
End-user

Client used to configure 
Agile Recipe Management 
for Pharmaceuticals or work 
in Agile Recipe 
Management for 
Pharmaceuticals

Configuration required to 
perform administrative or 
user tasks in Agile Recipe 
Management for 
Pharmaceuticals

The PLM Administrator uses the information in this chapter to set up, synchronize, and integrate 
PLM Users and Business Objects to properly work in Agile Recipe Management for Pharmaceuticals.

Then an Agile Recipe Management for Pharmaceuticals Administrator refines User capabilities and 
configures Business Objects in Agile Recipe Management for Pharmaceuticals.

PLM Administrator Java Client (Admin tab) PLM "Administrator" role 
and/or privilege

Agile Recipe Management 
for Pharmaceuticals 
Administrator

Web Client > Agile Recipe 
Management for 
Pharmaceuticals 
Administrator UI (which is 
fully documented in this 
manual)

Must be assigned specific 
PLM privilege mask to access 
Agile Recipe Management for 
Pharmaceuticals, plus specific 
selection in AppliedTo 
property to configure the 
solution and refine users.
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You will return to User Configuration in Configuring PLM Users for Agile Recipe 
Management for Pharmaceuticals.

Administrator Access to and from Agile Recipe Management for Pharmaceuticals
This section contains 4 procedures that describe how the PLM Administrator:

1. gives a PLM user administrative access to Agile Recipe Management for 
Pharmaceuticals. Once he/she is given administrative access, the PLM user is 
considered an Agile Recipe Management for Pharmaceuticals Administrator.

2. accesses Agile Recipe Management for Pharmaceuticals administrative features in 
Agile Recipe Management for Pharmaceuticals.

3. gives the Agile Recipe Management for Pharmaceuticals Administrator the ability 
to switch back to PC from Agile Recipe Management for Pharmaceuticals.

4. accesses PC from Agile Recipe Management for Pharmaceuticals.

Note: The procedures described in #2 and #4 are applicable to both 
the Agile Recipe Management for Pharmaceuticals Administrator and 
the PLM Administrator.

The following procedure allows the PLM Administrator to make a PLM user an Agile 
Recipe Management for Pharmaceuticals Administrator.

For a PLM user to have access to the administrative functions in Agile Recipe 
Management for Pharmaceuticals:

1. Assign the Agile Recipe & Material Workspace UI Access privilege mask to the 
user.

All Agile Recipe Management for Pharmaceuticals users are created in Agile PLM (or company LDAP 
system) and synchronized and further configured to work in the Agile Recipe Management for 
Pharmaceuticals user interface.

Agile Recipe Management 
for Pharmaceuticals 
End-user

Web Client's "Agile Recipe 
Management for 
Pharmaceuticals" UI 
(documented in other Agile 
Recipe Management for 
Pharmaceuticals user 
manuals)

Must be assigned specific 
PLM privilege mask to access 
Agile Recipe Management for 
Pharmaceuticals, plus 
additional configuration in 
PLM (detailed in this 
chapter), plus assigned Agile 
Recipe Management for 
Pharmaceuticals roles and 
privileges (detailed later in 
this manual)

PLM End-user Web Client's "Product 
Collaboration" UI

PLM roles and privileges 
(documented in Agile PLM 
Administrator Guide). Cannot 
access Agile Recipe 
Management for 
Pharmaceuticals unless 
properly configured

Administrator User or 
End-user

Client used to configure 
Agile Recipe Management 
for Pharmaceuticals or work 
in Agile Recipe 
Management for 
Pharmaceuticals

Configuration required to 
perform administrative or 
user tasks in Agile Recipe 
Management for 
Pharmaceuticals



Administrator and User Access to Agile Recipe Management for Pharmaceuticals

Integrating Agile Recipe Management for Pharmaceuticals with Agile PLM 2-3

2. Assign the (PLM) Administrator privilege mask to the user.

3. In the user's Administrator privilege mask AppliedTo property, move Agile 
Recipe Management for Pharmaceuticals Admin from the Choices field to the 
Selected field.

Note:  As managing PLM Administrator for your company, you may 
want to assign user(s) to the administrative function for Agile Recipe 
Management for Pharmaceuticals users without granting full 
administrative capacity in PLM. The AppliedTo property is fully 
detailed in the chapter on Privileges in Agile PLM Administrator Guide.

This following procedure can be done by a PLM Administrator or Agile Recipe 
Management for Pharmaceuticals Administrator.

To go to the administrative functions in Agile Recipe Management for 
Pharmaceuticals:

1. In Agile Web Client's standard interface, choose Tools & Settings > Agile Recipe 
Management for Pharmaceuticals to open the Agile Recipe Management for 
Pharmaceuticals user interface.

Note: There are a few licensing tasks that must be completed in PLM 
in order to enable the Agile Recipe Management for Pharmaceuticals 
menu item. For details, see the Agile PLM Administrator Guide.

Many buttons and features are the same as in Web Client's user interface for the 
other PLM solutions.

2. Click Tools & Settings again; a dropdown menu appears. It lists the Agile Recipe 
Management for Pharmaceuticals administrative components. These Agile Recipe 
Management for Pharmaceuticals-configuring objects are fully documented in the 
remaining chapters of this manual.

Once an Agile Recipe Management for Pharmaceuticals Administrator is in Agile 
Recipe Management for Pharmaceuticals, he must also have the proper privilege to 
access PC from Agile Recipe Management for Pharmaceuticals. The PLM 
Administrator must complete the following task to give the Agile Recipe Management 
for Pharmaceuticals Administrator this privilege.

For an Agile Recipe Management for Pharmaceuticals administrator to have access 
to Product Collaboration from Agile Recipe Management for Pharmaceuticals:

1. From the Search dropdown menu, select People > Role.

2. Enter Admin* in the Search field, then click Execute Search.

3. On the Administrator row, click the checkbox, then click the Edit button.

4. Open the Privileges tab, then click the Actions subtab.

5. On this path: System > Default > Manage, select Product Collaboration.

6. Click OK.

7. This sequence permits access of the PC user interface.

To go to Product Collaboration from Agile Recipe Management for Pharmaceuticals:
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This can be done by an Agile Recipe Management for Pharmaceuticals administrator 
user who has been configured according to the previous procedure.

1. Choose Tools & Settings > Product Collaboration to return to the standard user 
interface for the other PLM solutions.

Agile Recipe Management for Pharmaceuticals Preferred Start Page
If it helps for an Agile Recipe Management for Pharmaceuticals administrator or Agile 
Recipe Management for Pharmaceuticals users to be directed to the Agile Recipe 
Management for Pharmaceuticals user interface upon logging in to Web Client, on the 
user's User Preferences, set Preferred Start Page to Agile Recipe Management for 
Pharmaceuticals.

This menu selection is available only to those users who have been assigned the Agile 
Recipe & Material Workspace UI Access privilege mask, assuming that the Agile 
Recipe Management for Pharmaceuticals licenses are enabled in PLM. This prevents a 
PLM user from changing his Preferred Start Page to Agile Recipe Management for 
Pharmaceuticals if he has not been assigned the privilege to the Agile Recipe 
Management for Pharmaceuticals UI.

Note: The Preferred Start Page setting affects how UI-UI context 
switching functions. To learn about how UI-UI context switching is 
affected by this setting, see the Getting Started with Agile Recipe 
Management for Pharmaceuticals Guide.

User Access to Agile Recipe Management for Pharmaceuticals
A PLM user can access the Agile Recipe Management for Pharmaceuticals solution 
after the PLM administrator assigns the PLM privilege mask called Agile Recipe & 
Material Workspace UI Access.

Important: The tasks below do not indicate anything more than 
access of the Agile Recipe Management for Pharmaceuticals solution. 
End-users must be created in PLM and further configured in Agile 
Recipe Management for Pharmaceuticals, as documented in 
Configuring PLM Users for Agile Recipe Management for 
Pharmaceuticals.

Further Agile Recipe Management for Pharmaceuticals-specific roles and privileges 
are assigned to users within the Agile Recipe Management for Pharmaceuticals 
solution.

Note: You may want to create a role for "Agile Recipe Management 
for Pharmaceuticals User", especially if you want to consistently 
bundle together other PLM privileges for PLM users who will work in 
Agile Recipe Management for Pharmaceuticals. For more information, 
see Agile PLM Administrator Guide chapter on Roles.

To give a PLM user access to Agile Recipe Management for Pharmaceuticals in Web 
Client:

1. All users who will work in the Agile Recipe Management for Pharmaceuticals 
solution are first created in Agile PLM (or the company's LDAP system).



Preliminary Configuration Tasks in PLM

Integrating Agile Recipe Management for Pharmaceuticals with Agile PLM 2-5

2. An Agile PLM user must be assigned the Agile Recipe & Material Workspace UI 
Access privilege mask. This privilege mask is based on the Agile Recipe & 
Material Workspace UI Access privilege type.

3. From Agile Web Client's standard interface, a user chooses Tools & Settings > 
Agile Recipe Management for Pharmaceuticals to open the Agile Recipe 
Management for Pharmaceuticals user interface.

For Agile Recipe Management for Pharmaceuticals user, to access Product 
Collaboration from Agile Recipe Management for Pharmaceuticals:

1. In Agile Web Client's Agile Recipe Management for Pharmaceuticals interface, 
choose Tools & Settings > Product Collaboration to return to the standard UI for 
Product Collaboration and the other PLM solutions.

Note: You must have already assigned the user the privilege to 
access Product Collaboration as mentioned in Configuring Privileges 
for the Integration User.

Preliminary Configuration Tasks in PLM
This section details preliminary configuration tasks.

Note that the following terms may be used in directory paths:

■ ORACLE_HOME - the directory where Oracle software is installed

■ AGILE_HOME - the directory where Agile software is installed

Run Pharma.sql
The pharma.sql file creates an Agile Recipe Management for Pharmaceuticals privilege 
mask and creates Agile Recipe Management for Pharmaceuticals-Agile PLM 
subclasses in PLM. The pharma.sql file does the following:

■ Adds subclasses under Item - Materials subclass, Recipe subclass.

■ Adds Workflow under for Material - Default Material ECO.

■ Adds a new Privilege type - Agile Recipe & Material Workspace UI Access.

■ Creates a new privilege - Agile Recipe & Material Workspace UI Access.

■ Adds Agile Recipe Management for Pharmaceuticals Admin to Admin type list. 
(The list of activities that the admin can access).

■ Enables the Material and Equipment Management and Recipe Management 
modules. (These modules are added to the database in a disabled state.)

Run thepharma.sql script as Agile DB user. It is located at oracle_
home\admin\<ORACLE_SID>\create\<agile schema user>.

Required Changes When Agile Recipe Management for Pharmaceuticals and PLM Are 
Installed Separately

When PLM and Agile Recipe Management for Pharmaceuticals are installed on 
different servers, there are manual changes you must make on the PLM side, as well as 
the Agile Recipe Management for Pharmaceuticals side.
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Manual Changes Required in Agile Recipe Management for Pharmaceuticals
When PLM and Agile Recipe Management for Pharmaceuticals are installed on 
separate servers, you must verify that the following URLs are properly defined in the 
CFMConfig.xml file which is located in agile_home\AgilePharma\config.

Note that when PLM and Agile Recipe Management for Pharmaceuticals are installed 
on the same server, these properties are pre-populated and manual changes are not 
required.

Agile Http URL
Set the Agile HTTP URL:

http://<A9_SERVER_HOST_NAME>:<A9_SERVER_PORT>/<A9_VIRTUAL_PATH>

where "A9" refers to Agile PLM 9.x.y.z (such as 9.3.1.1). The default port number is 
"23791".

Example:

<AgileHttpUrl> http://plm.company.com:23791/Agile </AgileHttpUrl>

The Remote Method Invocation (RMI) is slightly different on OAS or WLS.
If Agile PLM is installed on Oracle Application Server (OAS), the RMI should be:

Ormi://<A9_SERVER_HOST_NAME>:<RMI_port>/<virtual_path>

Example:

<AgileRmiUrl> ormi://plm.company.com:23791/Agile </AgileRmiUrl>

If PLM is installed on WebLogic Server (WLS), the RMI should be:

T3://<A9_SERVER_HOST_NAME>:<A9_SERVER_PORT>

Example:

<AgileRmiUrl> T3://plm.company.com:7001/Agile

</AgileRmiUrl>

Agile Web Services URL
Agile Web Services are located at

http:// <A9_SERVER_HOST_NAME>:<A9_SERVER_PORT>/<A9_WS_VIRTUAL_
PATH>/services

Example:

<AgileWebServiceUrl> http://plm.company.com:23791/CoreService/services 
</AgileWebServiceUrl>

Summary of Agile Details
Another look at these "Agile Details":

<AgileDetails>

<AgileHttpUrl> >http://<agile_host>:<port>/<virtual_path </AgileHttpUrl>

<AgileRmiUrl> ormi://<agile_host>:<RMI_port>/<virtual_path> </AgileRmiUrl>

<AgileWebServiceUrl> >http://<agile_host>:<port>/<Web_Services_virtual_path 
</AgileWebServiceUrl>
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</AgileDetails>

Manual Changes Required in PLM
The following changes are required in PLM when PLM and Agile Recipe Management 
for Pharmaceuticals are installed on different servers.

Configuring agile.properties For Separate Server Setup
1. Open agile.properties and scroll down to the Agile Agile Recipe Management for 

Pharmaceuticals Integration section.

Note: If PLM is installed on an OAS server, agile.properties is 
located in oracle_
home\j2ee\home\applications\Agile\APP-INF\classes. If Agile is 
installed on Weblogic, the location of the file agile.properties is agile_
home\agileDomain\config.

2. Modify properties as given below:

##### Agile Agile Recipe Management for Pharmaceuticals Integration #####

# Change this value to true if Agile Recipe Management for Pharmaceuticals is 
installed.

agilepharma.install = true

# Specify the Host Name of the Pharma Server.

agilepharma.hostname = < Agile Recipe Management for Pharmaceuticals_
hostname>

# Specify the Port Number of the Pharma Server.

agilepharma.portnumber = < Agile Recipe Management for Pharmaceuticals_
port>

# Specify the Protocol http or https.

agilepharma.protocol = http

# If the Agile Recipe Management for Pharmaceuticals server is configured for 
HTTPS/SSL, specify:

agilepharma.protocol = https

3. Save the file.

Create Default Company and Site in Agile Recipe Management for Pharmaceuticals
"Default Company" and "Default Site" properties work differently in Agile Recipe 
Management for Pharmaceuticals than they do in PLM. The administrator must set 
default values for the Company and Site attributes in Agile Recipe Management for 
Pharmaceuticals, and have them correctly mapped from PLM, before creating Agile 
Recipe Management for Pharmaceuticals users.

If "Sites" are not enabled in PLM, the "Default Company" attribute must be set in Agile 
Recipe Management for Pharmaceuticals Administrator for user synchronization to 
work properly (this is accomplished in the task below).

To configure Company and Site in Agile Recipe Management for Pharmaceuticals:
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1. Choose Create New > Organizations > Company.

2. Enter a Company Name. There are other properties you may fill in, but Name is 
the only required field that does not have a default value.

3. Choose Create New > Organizations > Site. A site always has a root Company, 
and the Company has to exist before the site can be created.

These Agile Recipe Management for Pharmaceuticals objects are documented in 
the sections Add New Company and Add New Site.

4. Under Tools & Settings, choose Settings > Default Preferences and, under the 
System tab, ensure that the Default Company attribute is populated.

5. Do one of the following:

a. In Java Client, on the General Info tab of the User object, set the attributes 
Default Site and Sites as Required fields. You must provide a valid Company for 
the Sites and Default Site attributes while creating or modifying the user in PLM.

b. Leave the Default Site and Sites attributes in PLM empty. Ensure that the 
Default Company is set in the Default Preferences in Agile Recipe Management 
for Pharmaceuticals. In this case, the Agile Recipe Management for 
Pharmaceuticals user will have company as the "Default Company" in the Agile 
Recipe Management for Pharmaceuticals Default Preferences.

Differences in Company and Site in PLM and Agile Recipe Management for 
Pharmaceuticals
■ In Agile Recipe Management for Pharmaceuticals, regarding Company, and unlike 

Product Collaboration:

– Company is a business object, not an attribute;

– Company is a necessary parent object for a Site in Agile Recipe Management 
for Pharmaceuticals;

– Company is a required attribute for creating Users; that is why a default value 
must be set in Agile Recipe Management for Pharmaceuticals admin's Default 
Preferences;

– User synchronization maps (PC user) Default Site to (Agile Recipe 
Management for Pharmaceuticals admin) Default Company.

■ In Agile Recipe Management for Pharmaceuticals, regarding Site, and unlike 
Product Collaboration:

– A Site always has a parent Company;

–  That Company must exist before the Site can even be created;

– A Site can have multiple levels of child sites, locations, etc.;

– A Site can be defined as a Supplier, a Manufacturer, or both.

Configure CFMConfig.xml for Integration Updates to PLM
The CFMConfig.xml file is the main configuration file in Agile Recipe Management for 
Pharmaceuticals.

There is one parameter in CFMConfig.xml that must be configured for integration 
purposes. You must set the hourly periodicity of the integration of Agile Recipe 
Management for Pharmaceuticals to Product Collaboration (or "PC", the basic solution 
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in PLM) - that is, how often you want the system to publish Agile Recipe Management 
for Pharmaceuticals updates to PC - open

agile_home\AgilePharma\config\CFMconfig.xml

and, under the CFMDaemon tag, adjust the AgileIntegrationHourlyPeriodicity 
property.

The property accepts integers 1-24 (that is, 1, 2, 3, ..., 23, or 24) for number of Hours.

Configuring PLM Users for Agile Recipe Management for Pharmaceuticals
This section details how to configure users who will work in the Agile Recipe 
Management for Pharmaceuticals solution.

All users who will work in the Agile Recipe Management for Pharmaceuticals solution 
are created in Agile PLM (Java Client or Web Client), or in the company's LDAP 
system.

Sequence of Agile Recipe Management for Pharmaceuticals User Configuration
The following sequence applies to all users who will work in Agile Recipe 
Management for Pharmaceuticals.

Sequence to configure Agile Recipe Management for Pharmaceuticals users:

1. Create user:

Users are created in PLM, either in Java Client (Admin), in Web Client (Address 
Book), or in the company's LDAP system.

Note: You may need to refer to the chapter about Users in Agile PLM 
Administrator Guide.

2. Provide PLM Privilege to access Agile Recipe Management for Pharmaceuticals:

Each user must be assigned Agile Recipe & Material Workspace UI Access 
privilege mask. Any user can also have PLM roles & privileges for non-Agile 
Recipe Management for Pharmaceuticals work.

Note: Roles assignment must be done in both PLM (this step) and in 
Agile Recipe Management for Pharmaceuticals Administrator (see 
final step below).

3. Email format:

Agile Recipe Management for Pharmaceuticals requires that each user's email 
address be in this format: xxx.yyy@zzz.com where "xxx" represents the user's first 
name, "yyy" represents the user's last name, and "zzz" represents the domain name 
of the mail server.

4. Preferred Start Page:

User > User Preferences > Preferred Start Page and set to Agile Recipe 
Management for Pharmaceuticals. This lands the user directly in the Agile Recipe 
Management for Pharmaceuticals user interface. While this setting is best for users 
who will work only in Agile Recipe Management for Pharmaceuticals, it is 
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optional and may not be preferred for users who work in other PLM solutions 
along with Agile Recipe Management for Pharmaceuticals.

Note: The Agile Recipe Management for Pharmaceuticals option 
for Preferred Start Page is available only when the user has the Agile 
Recipe & Material Workspace UI Access privilege and Agile Recipe 
Management for Pharmaceuticals specific licenses are enabled in the 
PLM.

5. Company and Site:

Preliminary tasks were described in Create Default Company and Site in Agile 
Recipe Management for Pharmaceuticals.

6. User Synchronization:

PLM users must be synchronized with Agile Recipe Management for 
Pharmaceuticals before any Agile Recipe Management for 
Pharmaceuticals-specific modifications to users can be made. Before creating and 
configuring users for Agile Recipe Management for Pharmaceuticals, you must 
choose between manual synchronization and automatic synchronization. The 
latter process is more involved than creating a single Process Extension, but it is 
more efficient in the long run, especially for synchronizing many Agile Recipe 
Management for Pharmaceuticals users. See Preliminary Steps to Synchronize 
Agile Recipe Management for Pharmaceuticals Users for more information.

7. Refine and modify user in Agile Recipe Management for Pharmaceuticals:

Now the user can be seen and accessed in Agile Recipe Management for 
Pharmaceuticals. His capabilities in Agile Recipe Management for 
Pharmaceuticals now depend on the Agile Recipe Management for 
Pharmaceuticals administrator assigning Agile Recipe Management for 
Pharmaceuticals roles, following the procedures detailed in the sections 
Configuring Privileges for the Integration User and People.

Note: Agile Recipe Management for Pharmaceuticals administrators 
are automatically synchronized, once they fulfill the conditions 
described in Administrator Access.

The Agile Recipe Management for Pharmaceuticals administrator further refines 
the configuration of Agile Recipe Management for Pharmaceuticals users by 
applying solution-specific roles and privileges from within the administrative 
functions of Agile Recipe Management for Pharmaceuticals. For details on Agile 
Recipe Management for Pharmaceuticals-side configuration of users, see People.

Preliminary Steps to Synchronize Agile Recipe Management for Pharmaceuticals Users
To synchronize Agile Recipe Management for Pharmaceuticals users, choose one of the 
following ways of synchronizing User objects:

a. Create a user in PLM and manually synchronize the User object to Agile Recipe 
Management for Pharmaceuticals. This is called the "force synchronization" process, 
and it is detailed in Create Process Extension to Manually Synchronize Users.

b. Set up Event subscriptions in the Event Management framework that will 
automatically synchronize modifications to Users. The components are detailed in 
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Event Management Process Extensions for Automatic User Synchronization. This is 
the recommended method.

Create Process Extension to Manually Synchronize Users
Users must be synchronized from the Agile PLM framework to the Agile Recipe 
Management for Pharmaceuticals solution.

If your company's use of Agile Recipe Management for Pharmaceuticals will be 
limited to a finite number of users, you may elect to create a single process extension 
and apply it manually. The alternative is to use the Event Management capability (in 
Administrator module of Java Client) for automatic user synchronization.

Note: If you elect to use the Event Management framework to 
automatically synchronize users, the PX in this topic is not necessary. 
See Create Event Management PXs for Automatic User 
Synchronization.

When the general "Agile Recipe Management for Pharmaceuticals User 
Synchronization" Process Extension (PX) is created and added to the Users class (or 
subclass) in Java Client, it is then available to manually synchronize users from PLM to 
Agile Recipe Management for Pharmaceuticals.

Note: The jar file namedpharmaIntegrationPX.jar was deployed, 
during Install, in the extensions folder (agile_home > integration > 
sdk > extensions), but it will not show up in Java Client until the PX is 
configured.

To create the "Agile Recipe Management for Pharmaceuticals User Synchronization" 
PX:

1. In Java Client >Admin > Data Settings > Process Extensions, click the New icon 
and populate it with these values:

■ Name: Agile Recipe Management for Pharmaceuticals User Synchronization 
[suggested]

■ API Name: [accept the default after entering a Name]

■ Description: [brief description of the PX]

■ Type: Internal Custom Action

■ Internal Custom Action [this field was enabled when you set Type; the PX 
itself was deployed onto the server at Install time]: 
com.agile.agilepharma.integration.PX.UserIntegrationPX

■ Initiate From: Actions Menu [move from Choices to Selected in the dropdown 
dialog]

■ Roles: [leave empty]

Important: The PX runs with the privileges of the user who triggers 
it, so it is important that the Roles field is left empty.

■ Enabled: Yes
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2. Click OK to save the PX.

3. Navigate to Data Settings > Classes > users class > Process Extensions tab, and 
assign the Agile Recipe Management for Pharmaceuticals User Synchronization 
PX to the users class.

The "synchronize users" PX is now properly configured and available as you create 
new users or modify existing users to work in Agile Recipe Management for 
Pharmaceuticals. Once the PX is configured, you can do synchronizations by 
accessing the PX, which is available in the user object's Actions menu in the PLM 
web client.

Event Management PXs for Automatic User Synchronization
The Event Management capability in Java Client Administrator enables PXs to 
streamline the synchronization of User objects between PLM and Agile Recipe 
Management for Pharmaceuticals.

Event Management is fully documented in Agile PLM Administrator Guide and Agile 
SDK Developers Guide. The various masks below are guidelines for a useful set of Event 
subscriptions when users are created, modified (updated), or deleted.

Event Masks for User Synchronization
The following sections describe Event Masks for User Synchronization.

'Create User' Event mask: [Create User]
■ Event Type: Create Object

■ Object Type: User [the User subclass]

'Delete User' Event mask: [Delete User]
■ Event Type: Delete Object

■ Object Type: User [the User subclass]

■ Action: Soft

'Update User' Event mask: [Update User]
■ Event Type: Update Title Block

■ Object Type: User [the User subclass]

Event Handler for User Synchronization
The following sections describe the Event Handler for User Synchronization.

Handler mask: [Agile Recipe Management for Pharmaceuticals User Sync Handler]
■ Handler Type: Java PX

■ Event Action: com.agile.agilepharma.integration.px.UserIntegrationPX

■ Enable: Yes

■ Role: [Leave blank.]

Event Subscribers for User Synchronization
The following sections describe the Event Subscribers for User Synchronization.
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'Create User' Subscriber mask: [Agile Recipe Management for Pharmaceuticals 
Create User Sync Subscriber]
■ Event: [CreateUser]

■ Event Handler: [Agile Recipe Management for Pharmaceuticals User Sync 
Handler]

■ Trigger Type: Post

■ Execution Mode: Synchronous

■ Order: 0

■ Error Handling Rule: Continue

'Delete User' Subscriber mask: [Agile Recipe Management for Pharmaceuticals 
Delete User Sync Subscriber]
■ Event: [DeleteUser]

■ Event Handler: [Agile Recipe Management for Pharmaceuticals User Sync 
Handler]

■ Trigger Type: Post

■ Execution Mode: Synchronous

■ Order: 0

■ Error Handling Rule: Continue

'Update User' Subscriber mask: [Agile Recipe Management for Pharmaceuticals 
Modify User Sync Subscriber]
■ Event: [UpdateUser]

■ Event Handler: [Agile Recipe Management for Pharmaceuticals User Sync 
Handler]

■ Trigger Type: Post

■ Execution Mode: Synchronous

■ Order: 0

■ Error Handling Rule: Continue

Note: Once all events have been configured, you must enable events 
to be triggered. To do this, navigate to the Admin tab in Agile PLM 
java client and click the Enable Triggering Events button.

Configuring PLM Business Objects for Agile Recipe Management for 
Pharmaceuticals

The following PLM business objects must be integrated with Agile Recipe 
Management for Pharmaceuticals so that the Agile Recipe Management for 
Pharmaceuticals solution works properly:

■ Parts - Materials, Recipes;

■ Manufacturers;

■ Manufacturer Parts;
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■ Suppliers;

■ Content (Attachment);

■ Workflow and Autopromote.

■ User

Each of the integrations of PLM business objects includes an optional step is to create a 
Subclass in Agile PLM that is dedicated to the Agile Recipe Management for 
Pharmaceuticals-specific object, for example, "Agile Recipe Management for 
Pharmaceuticals Manufacturers" or "Agile Recipe Management for Pharmaceuticals 
Suppliers". Whether or not you create Agile Recipe Management for 
Pharmaceuticals-specific subclasses depends on such factors as: the volume of 
business by your company in PLM and/or Agile Recipe Management for 
Pharmaceuticals solutions; the need to easily distinguish whether a Manufacturer, for 
example, produces goods to be used in pharmaceutical manufacturing or otherwise; 
and so forth.

When some objects, such as materials, get to a specified lifecycle phase, such as the 
Approved state, the object gets updated into the PLM database. This process is called 
synchronization. You can track the success or failure of an object's synchronization to 
PLM by checking the Integration Status and Integration Message attributes in the Default 
view of the object. These integration status fields are available for the Material, Recipe 
or Site Qualification objects. Additionally, you can check the WebServices.log file for 
integration errors. The log file is on the Agile Application Server, but is in different 
locations for OAS or WLS. Integration errors are written to the log file for the 
PLM-Agile Recipe Management for Pharmaceuticals integration objects, namely, 
Materials, Recipes, Manufacturers, Manufacturer Parts, Suppliers, Users, and 
(Attachment) Content.

Note: You can control the interval at which synchronization of 
integration objects occur. Refer to Configure CFMConfig.xml for 
Integration for more information.

Files Required for Integration
The following files need to be modified to integrate business objects between Agile 
Recipe Management for Pharmaceuticals and PLM:

■ Integration.properties

■ AgilePharmaMapping.xml

In general, all PLM business classes and PLM business objects that are required for 
integration by Agile Recipe Management for Pharmaceuticals must be created, 
enabled, and configured in the PLM Administrator.

Instructions that are more specific to the various PLM business classes follow.

Important: If you change any of the following files, you must re-start 
the Agile Agile Recipe Management for Pharmaceuticals Application 
Server for the changes to be incorporated by the system: - 
Integration.properties - AgilePharmaMapping.xml - CFMConfig.xml
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Integration.properties
The Integration.properties file contains subclass names from Agile PLM that are 
needed for Agile Recipe Management for Pharmaceuticals Integration. If you 
customize these names in the Java Client, you must ensure that the API names are 
correct as per your customization in the Integration.properties file.

Modify the Integration.properties file located at agile_
home/AgilePharma/config/agile so that all API Names are correct. The file contains 
inline comments to guide you.

Refer to the information about API Names in Agile PLM Administrator Guide, Chapter 
3, "Administrator Functions in Java Client".

WARNING: The last portion of the Integration.properties file is 
preceded by the following comment: "It is highly recommended 
NOT to modify the below properties." Please heed this warning and 
do not alter any line of code in that portion of the file.

AgilePharmaMapping.xml
The configurations in the AgilePharmaMapping.xml file are necessary for integration 
purposes. There are two separate AgilePharmaMapping.xml files, one of which is 
located on the PLM side and another that is located on the Agile Recipe Management 
for Pharmaceuticals side.

The PLM version of the AgilePharmaMapping.xml file is used for user 
synchronization from PLM to Agile Recipe Management for Pharmaceuticals. The file 
is used to pass data from PLM to Agile Recipe Management for Pharmaceuticals. It 
can be found in the following locations:

■ In a WebLogic setup, agile_home/agiledomain/config folder.

■ In an OAS setup, oracle_home/j2ee/home/applications/Agile/APP-INF/classes.

Caution: It is recommended that you do not remove entries from the 
PLM version of this file, since user synchronization functionality 
could be broken.

The Agile Recipe Management for Pharmaceuticals version of the 
AgilePharmaMapping.xml file is used for Material, Recipe, Site Qualification, and 
Content integrations from Agile Recipe Management for Pharmaceuticals to PLM. The 
file is used to pass data from Agile Recipe Management for Pharmaceuticals to PLM. It 
is available under agile_home/AgilePharma/config/agile.

Material Integration
1. In Java Client, go to Admin > Data Settings > Classes > Items base class > Parts 

Class > Materials Subclass.

2. Add an AutoNumber source to the Materials Subclass.

3. Enable the Page Three tab for the Materials subclass

4. Create or Enable a Text Field in Page Three and set its Name as Material Category 
and API Name as materialCategory.

5. Create or Enable a Text Field in Page Three and set its Name as Material Type and 
API Name as materialType.



Configuring PLM Business Objects for Agile Recipe Management for Pharmaceuticals

2-16 Recipe Management for Pharmaceuticals Administrator Guide

6. Create or Enable a Text Field in Page Three and set its Name as Material Name 
and API Name as materialName.

7. Modify AgilePharmaMapping.xml located in agile_
home/AgilePharma/config/agile so that it has correct API Names for 
Material-related properties.

8. Modify Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has correct API Names for 
Material-related properties, for example:

PHARMA_CLASS_APINAME=MaterialsSubclass

ITEM_LIFECYCLE_PHASE_DEFAULT=Production

ITEM_LIFECYCLE_PHASE_DEACTIVE=Inactive

ITEM_LIFECYCLE_PHASE_ACTIVE=Production

Recipe Integration
1. In Java Client, go to Admin > Data Settings > Classes > Items base class > Parts 

Class > Recipe subclass.

2. Add an AutoNumber source to the Recipe subclass.

3. Enable the Page Three tab for the Recipe subclass.

4. Create or Enable a Text Field in Page Three and set its Name as Recipe Name and 
API Name as recipeName.

5. Create or Enable a Date Field in Page Three and set its Name as Effective Start 
Date and API Name as effectiveStartDate.

6. Create or Enable a Text Field in Page Three and set its Name as Effective End Date 
and API Name as effectiveEndDate.

7. Modify AgilePharmaMapping.xml located in agile_
home/AgilePharma/config/agile so that all the Agile attributes have the correct 
API Names for Recipe-related properties.

8. Modify Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has the correct API Names for 
Recipe-related properties, for example:

RECIPE_APINAME=Recipe

RECIPE_LIFECYCLE_PHASE_DEFAULT=Production

RECIPE_LIFECYCLE_PHASE_DEACTIVE=Inactive

RECIPE_LIFECYCLE_PHASE_ACTIVE=Production

RECIPE_LIFECYCLE_PHASE_OBSOLETE=Obsolete

RECIPE_CHANGE_ORDER_APINAME=ECO

RECIPE_CHANGE_AUTONUMBER_APINAME=ECONumber

RECIPE_CHANGE_ORDER_WORKFLOW=DefaultChangeOrders

RECIPE_CHANGE_ORDER_WORKFLOW_FINAL_STATUS=CCB



Note: This last line names the final status to which the integration 
will advance the workflow: from that status on, it must be manually 
approved and released. If Autopromote is enabled on the workflow, it 
is released automatically when everyone approves. If you do not want 
approvals to be required in PLM, you must configure the workflow 
appropriately.
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Manufacturer Integration
PLM uses the Manufacturer subclass for integration purposes, however, you can 
customize the setup by creating a new subclass. The steps to create and configure a 
custom Manufacturer subclass are as follows:

1. In Agile Java Client > Admin > Data Settings > Classes > Manufacturers base 
class > ManufacturersClass, create a subclass for "Agile Recipe Management for 
Pharmaceuticals Manufacturers".

2. Enable the Country/Area and State/Province/Region attributes on the 
Attributes:General Info tab.

3. Customize AgilePharmaMapping.xml located in agile_
home/AgilePharma/config/agile so that all the Agile attributes have the correct 
API Names for Manufacturer-related properties.

4. Modify the Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has the correct API Names for 
Manufacturer-related properties, for example:

MANUFACTURER_APINAME=Manufacturer

Manufacturer Part Integration (Optional)
PLM uses the Manufacturer Parts subclass for integration purposes, however, you can 
customize the setup by creating a new subclass. The steps to create and configure a 
custom Manufacturer Parts subclass are as follows:

1. In Agile Java Client > Admin > Data Settings > Classes > Manufacturer Parts 
base class > Manufacturer PartsClass, create a subclass for "Agile Recipe 
Management for Pharmaceuticals Manufacturer Parts".

2. Customize AgilePharmaMapping.xml located in agile_
home/AgilePharma/config/agile so that all the Agile attributes have the correct 
API Names for Manufacturer Part-related properties.

3. Modify the Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has the correct API Names for 
Manufacturer Part-related properties, for example:

MANUFACTURERPART_APINAME=ManufacturerPart

Supplier Integration (Optional)
PLM uses the Suppliers subclass for integration purposes, however, you can customize 
the setup by creating a new subclass. The steps to create and configure a custom 
Suppliers subclass are as follows:

1. In Agile Java Client > Admin > Data Settings > Classes > Suppliers base class > 
Suppliers class, create a subclass for "Agile Recipe Management for 
Pharmaceuticals Suppliers".
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2. Enable the Country/Area and State/Province/Region attributes on the 
Attributes:General Info tab.

3. Customize AgilePharmaMapping.xml located in agile_
home/AgilePharma/config/agile so that all the Agile attributes have the correct 
API Names for Supplier-related properties.

4. Customize the Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has the correct API Names for 
Supplier-related properties. For example:

SUPPLIER_APINAME=Supplier

SUPPLIER_CORPORATECURRENCY=USD

Content and Attachments Integration
1. Agile File Server must be installed and configured properly in Java Client (see 

Agile PLM Administrator Guide).

2. Agile File Server should be up and running.

3. Customize the Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has all correct API Names for 
Content-related properties. For example:

FILE_FOLDER_APINAME=FileFolder

FILE_FOLDER_AUTONUMBER_APINAME=FileFolderNumber

Workflow and Autopromote Configuration
1. You need to configure the following workflows for integration purposes:

■ Default Material ECO

■ Default Change Orders

■ Default Manufacturer Orders

Configuring the Default Material ECO Workflow
To configure the Default Material ECO workflow:

1. Navigate to Agile Java Client > Admin > Workflow Settings > Workflows > 
Default Material ECO.

2. Modify workflow statuses so that Pending status (Pending status type) has CCB 
status (Review status type) as Manual Valid Next Status.

3. In CCB status, set Autopromote to True.

4. Remove all entry and exit criteria for Workflow CCB status.

5. Modify the Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has the correct API Names for 
Workflow- and Change Order-related properties, for example:

CHANGE_ORDER_APINAME=ECO

CHANGE_AUTONUMBER_APINAME=Agile Recipe Management for 
PharmaceuticalsIntegrationAutonumber

AGILE_WORKFLOW_APINAME=Agile Recipe Management for 
PharmaceuticalsIntegrationWorkflow
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AGILE_WORKFLOW_FINAL_STATUS=CCB

ITEM_REVISION=1

WORKFLOW_TYPE=Auto-Promote

AGILE_WORKFLOW_STATUS_FOR_MANUAL_WORKFLOW=Submitted

Note: The Default Material ECO workflow is a PLM-only workflow. 
The Agile Recipe Management for Pharmaceuticals solution has its 
own workflows (see Workflows).

Configuring the Default Change Orders Workflow
To configure the Default Change Orders workflow:

1.  Navigate to Agile Java Client > Admin > Workflow Settings > Workflows > 
Default Change Orders.

2. Modify workflow statuses so that Pending status (Pending status type) has CCB 
status (Review status type) as Manual Valid Next Status.

3. In CCB status, set Autopromote to True.

4. Remove all entry and exit criteria for Workflow CCB status.

5. Modify the Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has the correct API Names for 
Workflow- and Change Order-related properties, for example:

CHANGE_ORDER_APINAME=ECO

CHANGE_AUTONUMBER_APINAME=Agile Recipe Management for 
PharmaceuticalsIntegrationAutonumber

AGILE_WORKFLOW_APINAME=Agile Recipe Management for 
PharmaceuticalsIntegrationWorkflow

AGILE_WORKFLOW_FINAL_STATUS=CCB

ITEM_REVISION=1

WORKFLOW_TYPE=Auto-Promote

AGILE_WORKFLOW_STATUS_FOR_MANUAL_WORKFLOW=Submitted

Configuring the Default Manufacturer Orders Workflow
To configure the Default Manufacturer Orders workflow:

1. Navigate to Agile Java Client > Admin > Workflow Settings > Workflows > 
Default Manufacturer Orders.

2. Modify workflow statuses so that Pending status (Pending status type) has CCB 
status (Review status type) as Manual Valid Next Status.

3. In CCB status, set Autopromote to True.

4. Remove all entry and exit criteria for Workflow CCB status.

5. Modify the Integration.properties file located at agile_
home/AgilePharma/config/agile so that it has the correct API Names for 
Workflow- and Change Order-related properties, for example:

CHANGE_ORDER_APINAME=ECO
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CHANGE_AUTONUMBER_APINAME=Agile Recipe Management for 
PharmaceuticalsIntegrationAutonumber

AGILE_WORKFLOW_APINAME=Agile Recipe Management for 
PharmaceuticalsIntegrationWorkflow

AGILE_WORKFLOW_FINAL_STATUS=CCB

ITEM_REVISION=1

WORKFLOW_TYPE=Auto-Promote

AGILE_WORKFLOW_STATUS_FOR_MANUAL_WORKFLOW=Submitted

Configuring Privileges for the Integration User
You must ensure that the integration user has the required privileges. The Integration 
user (as defined in agile.properties in the Agile PLM and in agile_
home/AgilePharma/config/agile/Integration.properties in Agile Recipe Management 
for Pharmaceuticals) must have the following privileges in PLM:

1. Recipe and Material Workspace Admin privilege in PLM and must be super user 
in Agile Recipe Management for Pharmaceuticals.

2. Create, Discovery, Read and Modify privileges on all attributes of Materials 
subclass.

3. Create, Discovery, Read, Modify and Change Status privileges on the Default 
Material ECO.

4. Create, Discovery, Read and Modify privileges on all attributes of Manufacturer 
subclass (or on the custom sub class if one was created and configured in 
Integration.properties).

5. Create, Discovery, Read and Modify privileges on all attributes of Manufacturer 
Part subclass (or on the custom sub class if one was created and configured in 
Integration.properties).

6. Create, Discovery, Read and Modify privileges on all attributes of Broker subclass 
(or on the custom sub class if one was created and configured in 
Integration.properties).

7. Create, Discovery, Read and Modify privileges on all attributes of Recipe subclass

8. Create, Discovery, Read, Modify and Change Status privileges on the Default 
Change Orders (or on the custom workflow if one was created and configured in 
the Integration.properties).

9. Create, Discovery, Read, Modify and Change Status privileges on the Default 
Manufacturer Orders (or on the custom workflow if one was created and 
configured in the Integration.properties).

10. Create, Discovery, Read, Modify, Check-in, Check-out, Cancel Checkout, Get File, 
and Delete privileges on the File Folder subclass in PLM (or on the custom 
subclass, if one was created and configured in the Integration.properties) to 
perform Attachment operations:

11. The privilege in Agile Recipe Management for Pharmaceuticals for the user to 
navigate from Agile Recipe Management for Pharmaceuticals to Agile PLM. 
Navigate to System > Default > Manage > Product Collaboration privilege to 
enable the privilege.



Note: If Agile PLM is installed on an Oracle Application Server, the 
agile.properties file is located in <ORACLE_APP_SERVER_
HOME>\j2ee\home\applications\Agile\APP-INF\classes. If Agile is 
installed on WebLogic Server, the location of the file agile.properties is 
agile_home\agileDomain\config. The value for Agile Recipe 
Management for Pharmaceuticals.intuserpassw in agile.properties and 
AGILE_PASSWORD in agile_
home\AgilePharma\config\agile\Integration.properties should be 
encrypted using the encryptpwd.cmd or encryptpwd.sh (This file can 
be found under agile_home\AgilePharma\bin).
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All of the tasks in this chapter are begun by choosing Tools & Settings > System Tools 
and selecting from the flyout menu.

Data Audit Trail
Data audit is a way to track the history of all the changes on any object from the date 
of creation. Every change is captured with a reason for the change. Auditing records 
activities performed on a business object on a specified date.

For example, the audit trail data can be searched for a specific user, who accessed the 
application, during a specific period of time and the type of operations performed by 
that user.

Any category can be selected for auditing. Categories with attributes spanning across 
multiple tables can also be audited. You can update the list of categories or attributes 
for audit.

The audit information can be archived for future reference.

Searching Audit Data
To perform a search for the audit trail:

1. In the Tools & Settings menu, select System Tools > Data Audit Trail.

2. Select a search view from the View list. The following views are available:

■ Basic

■ Audit History ("Removed Objects Audit History")

■ Default ("DEFAULT")

3. On the Search Audit Trail page, you can perform a search in the following ways:

■ Enter (type in) values to any or all of the fields, and click Search.

■ Select value(s) from the dropdown list(s) in any or all of the fields, and click 
Search.

■ Leave all the fields blank and click Search.

Search Results displays the list of data audits based on the filled-in search criteria.

Viewing Audit Details
You can view the audit data for an object or an attribute in the Changes tab in 
Business Object Details.
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The audit information includes the following:

■  Modified Time

■ Modified By

■ Action

■ Attribute

■ Category

■ Old Value

■ New Value

■ Reason for Change

To view audit details for an object:

1. In the Tools & Settings menu, select System Tools > Data Audit Trail.

2. Perform a search for the audit trail.

3. In the search results display, click on Modified Time hyperlink to view the audit 
data.
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The Settings menu lets you manage the settings for Default Preferences, Image and 
Image Map.

All of the tasks in this chapter are begun by choosing Tools & Settings > Settings and 
selecting from the fly-out menu.

Default Settings
Agile Recipe Management for Pharmaceuticals is configured with some default 
settings. When a user is created, the default settings are applied. You can change these 
settings based on your requirements.

The administrator can change general preferences such as the login preferences and 
home page settings to suit the organization's requirements.

Locale and number format settings are not set in Agile Recipe Management for 
Pharmaceuticals. These settings are dependent on the preferences set in PLM. For 
more information on how to set these preferences in Agile PLM, see the Agile PLM 
Administrator Guide.

Setting System Preferences
To set System preferences:

1. In the Tools & Settings menu, select Settings > Default Preferences.

2. On the System tab, enter information for the following:

■ Automatic Hierarchy Depth Traversal - Enter the level of hierarchy you want 
to go to. For example, if you enter level 2, then you will be able to go to a 
depth of second level in any hierarchy in the application.

■ Default Company - Click the look up icon to select the company name.

■ External User Audit - Click the radio button to indicate whether external user 
audit is required ("true") or not ("false").

■ Equipment Allocation Role - Select the role for hard reservation of the 
equipment. This is applicable if general reservation is not allowed in 
Equipment Library.

■ Minimum For Background Control Recipe Creation - Enter the minimum 
number of Control Recipes/Work Orders that can be created synchronously 
with switching to asynchronous background process.

3. Click OK. You have set the preferences and a confirmation message appears.



Default Settings

4-2 Recipe Management for Pharmaceuticals Administrator Guide

Setting General Preferences
To set General preferences:

1. In the Tools & Settings menu, select Settings > Default Preferences.

2. On the General tab > Characteristics subtab, enter information for the following:

■ Default Number of Results Per Page - Select the default number of results, or 
rows of data records, to be displayed per page.

■ Default Delegate - Click the look up icon and select a User from the dialog.

3. On the General tab > Macros subtab, enter information for the following:

■ Default Equipment Site - Click the look up icon and select a Site from the 
dialog. You may want to click the Expanded Search button to examine more 
possibilities.

4. Click OK. A confirmation message appears.

Setting Home Page Preferences
To set Home Page preferences:

1. In the Tools & Settings menu, select Settings > Default Preferences.

2. On the Home Page tab:

■ Number of Columns on Home Page - Use the dropdown to select a number.

3. In the Channels table, select one or more Channels, which is a table that appears 
on every user's Home page:

■ Display Assigned Tasks Table - a user's Home page displays the Tasks 
assigned to the user.

■ Display Notification Table - a user's Home page displays the Notifications 
assigned to the user.

■ Display Projects Table - a user's Home page displays the Projects assigned to 
the user.

■ Display Campaigns Table - a user's Home page displays the Campaigns 
assigned to the user.

4. Click OK.

Adding a Channel (Home Page setup)
To add an existing Channel:

1. In the Tools & Settings menu, select Settings > Default Preferences.

2. Click on the Home Page tab.

3. In the Channels table, click the Add Channel button.

4. On the Lookup for 'Channel' page, enter the following information:

■ Name - select from the list of Home page tables.

■ Description - select a description of the table to be displayed.

■ BO: BO ID - select the type of business object, from Workflow Task, Project, or 
Campaign.

■ BO Action: Action Name - default is "@".
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■ Order - select a value for the order the tables will appear on users' Home page.

■ Display Rows - default is 5.

■ Display As - default is Table.

■ Is Default Channel

■ Channel View: Name

■ Channel View: Search Name

■ Modified User: User ID

■ Modified Date

■  Created User: User ID

■ Created Date

5. Select the channel(s) to be added and click the OK button. The selected channel(s) 
appear in the Home Page tab.

6. Click the OK button. A confirmation message appears.

Setting Recipe Preferences
To set Recipe preferences:

1. In the Tools & Settings menu, select Settings > Default Preferences.

2. Click the Recipe tab.

3. On the General subtab, use the following sequence of steps to populate the field 
for each of these templates:

■ Default Procedure Template

■ Default Unit Procedure Template

■ Default Operation Template

■ Default Phase Template, and

■ Default Action Template.

4. Click the Search (Lookup) icon.

5. The Recipe Element Template table appears listing templates that are available. If 
you do not see the template you expect, click the Expanded Search button.

Note: The Default Action Template table appears when you click the 
Lookup icon next to Default Action Temple.

6. Click the radio button for the template you want, and click OK. The name of the 
template you selected appears in the Name field.

7. When you have finished selecting templates, click OK.

Image
All images that are used in Agile Recipe Management for Pharmaceuticals are stored 
in a single table. The images added to this table are usually used for Categories/Image 
columns, etc.
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You can add, search, view, edit, remove, and duplicate images.

Creating an Image
To create an image:

1. In the Tools & Settings menu, select Settings > Image > New Image.

2. On the General subtab:

■ Image ID - Enter name of the image.

■  Image URL - Enter the URL of the image.

■ Image Width (px) - Enter the width of the image in pixels.

■  Image Height (px) - Enter the height of the image in pixels.

■  Description - Enter a description of the image.

3. Click Finish. You have created a new image, and a confirmation message appears.

Managing Imagea
The following sections cover how to manage images.

Searching Image
To search for image:

1. In the Tools & Settings menu, select Settings > Image > Manage Image.

2. Select a search view from the View dropdown list.

3. In the Search Image area, use the dropdown menus to fill in criteria of the images 
you are interested in finding.

4. When you have filled in sufficient criteria, click Search.

Viewing Image
To view image details:

1. In the Tools & Settings menu, select Settings > Image > Manage Image.

2. Perform a search for the image.

3. In the Image ID column, click on the image for which you want to view the details.

Editing Image
To edit image details:

1. In the Tools & Settings menu, select Settings > Image > Manage Image.

2. Perform a search for the image.

3. Select the image for which you want to edit the details and click Edit.

4. Enter information for the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK.

You have edited the image and a confirmation message appears.
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Duplicating Image
You can create a new instance of an existing image with the same attributes, but with a 
different name.

To duplicate an image:

1. In the Tools & Settings menu, select Settings > Image > Manage Image.

2. Perform a search for the image.

3. Select the image that you want to duplicate and click More > Save As.

4. In the Duplicate Image, click Clear.

5. Enter the Image ID for the image.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated image without changing the associated details. To cancel, click Cancel.

Removing Image
To remove an image:

1. 1. In the Tools & Settings menu, select Settings > Image > Manage Image.

2. 2. Perform a search for the image. Results displays a list of images.

3. 3. Select the image that you want to remove and click Delete.

4. 4. Enter the reason for removal and click OK.

You have removed the image and a confirmation message appears.

Image Map
An image map defines the rules for rule-based image displays. An attribute can have 
multiple values. Based on the given value, you can display a particular image. For 
example, let's take cost as the particular attribute. If the value for cost is greater than 
500, then the image shown can be green, while If the value for cost is less than 500, 
then the image shown can be yellow.

You can add, search, view, edit, remove, and duplicate image maps.

Creating an Image Map
To create an image map:

1. In the Tools & Settings menu, select Settings > Image > New Image Map.

2. Enter Image Map Name.

3. Click Next.

4. Click the Add Rows button to add one or more Images. For each image, enter the 
Order and Regular Expression.

5. Click on Finish.

Managing Image Map
The following sections show how to manage Image Maps.

Searching Image Map
To search for image map:
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1. In the Tools & Settings menu, select Settings > Image > Manage Image Map.

2. Select a search view from the View dropdown list.

3. In the Search Image Map area, use the dropdown menus to fill in criteria of the 
images you are interested in finding.

4. When you have filled in sufficient criteria, click Search.

Viewing Image Map Details
To view image map details:

1. In the Tools & Settings menu, select Settings > Image > Manage Image Map.

2. Perform a search for the image map.

3. In the Name column, click on the image map for which you want to view the 
details.

Editing Image Map
To edit image map details:

1. In the Tools & Settings menu, select Settings > Image > Manage Image Map.

2. Perform a search for the image map.

3. Select the image map for which you want to edit the details and click Edit.

4. Enter information for the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK.

You have edited the image map and a confirmation message appears.

Duplicating Image Map
You can create a new instance of an existing image map with the same attributes, but 
with a different name.

To duplicate an image:

1. In the Tools & Settings menu, select Settings > Image > Manage Image Map.

2. Perform a search for the image map.

3. Select the image map that you want to duplicate and click More > Save As.

4. In the Duplicate Image Map, click Clear.

5. Enter the name for the image map.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated image map without changing the associated details. To cancel, click 
Cancel.

Removing Image Map
To remove an image map:

1. In the Tools & Settings menu, select Settings > Image > Manage Image Map.

2. Perform a search for the image map. Results displays a list of image maps.

3. Select the image map that you want to remove and click Delete.
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4. Enter the reason for removal and click OK.

You have removed the image map, and a confirmation message appears.
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5Alerts

Alerts are informational or warning messages. This chapter provides information 
about adding and managing alerts in Recipe & Material Workspace.

All of the tasks in this chapter are begun by choosing Tools & Settings > 
Alert/Workflows > Alert and selecting from the flyout menu.

Alerts Overview
Alerts allow you to notify users based on the occurrence of predefined actions within 
the application. Alerts ensure continuous information flow in Recipe Management for 
Pharmaceuticals . They automatically inform the user about what action to take during 
a process and when to take it.

These messages are triggered when specific, predefined actions are performed on a 
business object. For example, you can define an alert to be triggered when a material 
object is modified.

Types of Alerts
Alerts can be classified into four main types:

■ Mandatory alerts - These alerts contain information/messages that all Recipe 
Management for Pharmaceuticals  users must receive. Mandatory alerts are 
automatically assigned to all users. The alert criteria on mandatory alerts cannot 
be modified. These alerts cannot be subscribed or unsubscribed.

■ Autosubscribe alerts - These alerts are automatically assigned to one or more 
users by the system. You can modify the alert attributes for these alerts. Users can 
unsubscribe from Autosubscribe alerts to stop receiving these messages.

■ Workflow alerts - Alerts are also used within workflows. There are two types of 
workflow alerts:

– System Notification workflow alerts - These alerts indicate changes that have 
been made to a business object's attributes.

For example, the equipment may have the following attributes:

* Equipment ID: T-60

* Equipment Name: Reactor

* Equipment Tag Number: K2334

* Location: Building 1, Floor 3, Room 12
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To move the Reactor to Building 3, Floor 3, Room 10, the administrator creates 
a System Notification workflow alert to the change in the location attribute.

■ Task Notification workflow alerts - These alerts allow the user to take action 
on the received alert. Examples include:

– Approve or reject a Specification Plan;

– Indicate that you "need more information".

Types of Alert Triggers
Alerts are triggered by the following types of Recipe Management for Pharmaceuticals  
events:

■ Alerts based on user actions - these alerts are triggered by specific actions of a 
user on a business object.

■ Conditional alerts based on user actions - these alerts are triggered when a 
predefined action is performed on a business objectand if specified conditions are 
met.

■ Conditional Alerts that incorporate time interval (frequency):

– Conditional alerts based on frequency - these alerts are triggered at a certain 
time interval;

– Conditional alerts based on user actions and frequency - these alerts are 
triggered both when a user performs an action and at a certain time interval.

■ System-generated alerts - these alerts are triggered based on application logic.

Once you create an alert, you must authorize users to view or subscribe to these alerts. 
You associate roles to an alert to specify the authorized receivers of the alert.

Note: An alert triggers if it has one or more users subscribed to it. An 
alert is not triggered when it has no subscribers subscribed to it. For 
an alert to be active, at least one user must be associated to it; without 
having a user associated to an alert, the alert's definition is incomplete.

Conditional Alerts
Alerts that have conditions specified are called conditional alerts. While defining an 
alert condition Relationship, Macro, and Operator is dynamic. These conditions 
change accordingly with the data type of the business object type selected.

When a business object is modified, the conditions specified for conditional alerts 
must be evaluated and all the subscribers subscribed to that alert must be notified.

Some of these conditions include:

■ All attributes belong to the same object type that is part of the condition.

■ Specifying values for parameters which are mandatory and cannot be modified. 
These conditions are locked. For example, for Site object, Type = Warehouse, 
where Type is the name of the attribute of Site object and Warehouse is the value.

■ Specifying attributes with some values. The values cannot be blank.

■ Specifying attributes and their values, which are not mandatory.

The following relational operators can be used when creating alert conditions:

■ Modified
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■ Greater than

■ Less than

■ Equal to

■ Not equal to

■ Starts with

■ Contains

■ Ends with

■ Expression

Conditional Alerts that incorporate Time Interval
Conditional alerts that incorporate a time interval are alerts that are generated at a 
specified time. These alerts also have specified conditions. The alert triggers when the 
conditions are met at that specified time.

There are two types of conditional alerts that use a time interval:

■ Conditional Alerts based on Frequency

■ Conditional Alerts based on Frequency and User Actions

The subscriber can modify the time frequency to any frequency higher than the one 
specified in the alert definition (but not a lower frequency). The time frequency can be 
any of the following:

■ Yearly

■ Monthly

■ Weekly

■ Daily

■ Hourly

■ Specific time without any recurrences (example, on December 12, 2010, at 10 hours 
15 minutes 25 seconds).

For example, if you have specified the time frequency as weekly, the subscriber can 
change it to monthly or yearly, but not daily or hourly.

Alerts are not sent if the value of the number of occurrences is less than or equal to the 
number of attempts made to evaluate the criteria.

If action is also selected for this alert definition, the alert is generated when the action 
is taken.

The periodicity can be any of the following:

■ Yearly (a day and time of the year) - alert is triggered on a specified date for a 
month. For example, Feb. 13th; or, a specified weekday of a month, such as "the 
second Monday of March".

■ Monthly (a day and time of the month) - alert is triggered on the specific date of 
every nth month. For example, "second of every three months". Can be set for a 
particular weekday of every nth month, such as "third Wednesday of every sixth 
month".

■ Weekly (day and time of the week) - alert is triggered on one or multiple days 
every week. For example, Monday, Wednesday, and Friday every week.
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■ Daily (day) - alert is triggered at either every nth day. For example, every third day 
or every weekday.

■ Hourly (time) - alert is triggered at every n hours. For example, every 1 hour and 
15 minutes.

■ Specific time without any recurrences - alert is triggered on 12th December 2012 at 
10 hours 15 minutes 25 seconds.

For all of these conditions, you can specify:

■ Start date - date on which the alert criteria checks start.

■ Start time (hour and minute)

■ Time zone

■ End date - date on which the alert criteria checks stop.

■ Number of occurrences - alert processing must happen only for the specified 
number of occurrences.

■ No end date - processing should continue till alert definition is active.

However, the alert itself is generated only after the alert definition is published. Alert 
processing does not start as soon as you publish the alert. It starts only if at least one 
user has subscribed to this alert. Processing stops if no one has subscribed to this alert.

System-generated Alerts
System-generated alerts are generated by the system based on application logic. These 
alerts are related to certain actions in the Recipe Management for Pharmaceuticals  
user interface that results in changes in attribute values. Each of this sort of attribute is 
included in criteria of the alert definition. The criteria is evaluated before sending 
alerts.

You cannot modify the system-generated alerts.

Multiple alerts can be triggered by the same action.

Alert Notifications
Alert notifications are messages that include the subject and other details of an alert.

Alerts notify users through Dashboard or Email, one of which is designated the 
default or primary means of notification, the other is designated the optional or 
secondary means of notification. The primary notification means cannot be modified 
to secondary means of notifications.

■  Dashboard alerts are displayed in the left frame of the home page;

■ Email alerts are emailed to the primary email ID of the recipient(s).

You must select Dashboard or Email as the primary notification method while defining 
an alert.

Note: The subscriber cannot choose an additional notification 
method, while subscribing to an alert.

When defining an alert, you can also choose to display the alert criteria in the body of 
the alert message. If this option is set, the system formats the alert criteria into a text 
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message, which is a part of the alert notification message. This text message is 
appended to the existing content of the message.

A user subscribes to an alert (provided it is not mandatory or data-driven) to receive 
an alert notification. You can define a subscription name for the alert, edit the alert 
condition, and deselect the optional notification method, if you have subscribed to the 
alert. You can unsubscribe at any time. If it is a timer alert, you can modify the 
frequency.

Steps toward Creating Alerts
To create a functioning alert, you must perform the following steps:

1. Create the basic alert.

2. Assign roles and sites to the new alert.

3. Publish the completed alert.

1. Creating an Alert
To create a normal alert based on user actions:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > New.

2. In the Preface tab, enter the kinds of business objects to which the alert will apply. 
The choices on the Preface tab are found when you expand the list of primary 
Recipe Management for Pharmaceuticals objects:

■ Analytical

■ Environment

■ Equipment

■ Material

■ Organization

■ People

■ Process

■ Standards

■ System

■ Test

3. In the General tab, enter information for the following fields:

■ Name - Enter the name of the alert.

■ Alerts will be mandatory for subscribers - Select the option, if alerts would 
be mandatory for subscribers.

■ Subscribe users automatically - Select the option, if you want the users to be 
subscribed automatically.

■ Type - Select the type of alert, Informational or Warning, from the dropdown 
list.

■ Invoke Service upon Alert Trigger - Select Yes or No.

■ Priority - Select one of the priority levels from the dropdown list.

■ Effective Start Date - Enter the effective start date.
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■ Effective End Date - Enter the effective end date.

4. Click Next.

■  In the Alert Trigger tab > Trigger subtab > Alerts triggered by field, select 
User Action of a user on an object or Attribute's value meeting a condition.

■  If you select the latter value, the options under Check the attribute are 
enabled; select one and click Next.

5. The Details tab has three subtabs: 

■ Attributes

■ Conditions

■ Actions

In the Attributes subtab, select the object attributes that has to be displayed in the 
alert notification message and click Next.

6. In the Conditions subtab, populate the fields that define the attribute. When you 
are done, click Next.

7. In the Actions subtab, select the actions that are used to trigger the alert and click 
Next.

8. The Notification tab has two subtabs:

■ Notification Details

■ Notification Content

In the Notification Details subtab, enter information for the following fields to 
specify how the users are notified when the alert is triggered:

■ Primary notification methods are Dashboard or Email.

■ Optional methods - the one you did not check above is now enabled.

■ Alert Information in Email - Display at Top or Display at Bottom

■ Customize Subject and Message - Yes or No.

■ Include Criteria Information - Yes or No.

9. In the Notification Content tab, enter text for the Subject and Message fields.

10. To preview the notification, click Preview Notification button. When you are 
finished, click OK.

You can use the Previous button to back up to pages that need adjustment.

11. When you are finished, click Finish. You have created a new alert, and a 
confirmation message appears.

Conditional Alerts based on User Actions
To create a conditional alert based on user action:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > New.

2. Select the object or category for the alert.

3. In the General tab, enter information for the following fields:

■ Name

■ Type
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■ Alerts will be mandatory for subscribers

■  Subscribe users automatically

■ Priority

■  Effective Start Date

■ Effective End Date

■ For Custom Web service related Attributes, select any or all of the options:

– Invoke External Service

– Whom to Notify (Determined by Service)

– Criteria evaluation

– What to notify

4. Click Next.

5. In the Alert Trigger tab, for Alerts Triggered by, select Action of a user on an 
object.

6. Click Next. The Details tab displays.

7. In the Attributes subtab, select the attribute that has to be used for the alert 
condition or displayed in the alert notification message and click Next.

8. In the Actions tab, select the action that is used to trigger the alert and click Next.

9. In the Notifications tab, enter information for the following fields to specify how 
the users are notified when the alert occurs:

■ On the Notification Details subtab, select the notification method. The 
options are:

– Dashboard

– Email

■ On the Notification Content subtab, Include alert context details within 
message:

– Subject

– Message

10. Click Finish.

Conditional Alerts based on Frequency
To create a conditional alert based on frequency:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > New.

2. Select the object or category for the alert.

3. In the General tab, enter information for the following fields:

■ Name - Enter the name of the alert.

■ Type - Select the type of alert.

■ Mandatory - Select the option, if the alert is mandatory.

■ Auto-Subscribe - Select the option, if you want to auto-subscribe to the alert.

■ Priority(DEFAULT) - Select the priority level.
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■ Effective Start Date - Enter the effective start date.

■ Effective End Date - Enter the effective end date.

■ For Custom Web service related Attributes, select any or all of the options:

– Invoke External Service - Select the option, if you want to invoke external 
service

– Whom to Notify (Determined by Service) - Select whom you want to 
notify to.

– Criteria evaluation - Select the criteria evaluation.

– What to notify - Enter the message you want to notify.

4. Click Next.

5. In the Alert Trigger tab, for Alerts Triggered by, select Attribute's value meeting 
a condition.

6. For the Check the Attribute field, select At certain time intervals.

7. Click Next. The Details tab displays.

8. In the Attributes tab, select the attribute that has to be used for the alert condition 
and/or displayed in the alert notification message and click Next.

9. In the Conditions tab, specify the condition for each attribute that must trigger the 
alert. The conditions that you can specify are:

■ In the Condition column, select Modified, Equal To, or Not Equal To.

■ In the Macro column, select a pre-defined function.

■  In the Operator column, select +, *, -, or / which are used to specify the 
condition.

■ In the Value column, enter the value that uses the operators to define a 
condition.

If you have selected the condition as Modified, then the Macro, Operator and 
Value columns are not enabled.

■ In the UOM column, specify the Unit of Measure for the attributes, if any.

■ In the Required column, if the checkbox is selected, you cannot leave the 
condition field blank while adding or editing the conditions on your 
subscribed alert.

■ In the Non-editable column, if the checkbox is selected, you cannot edit the 
condition when you subscribe to the alert.

10. Click Next.

11. In the Frequency tab, enter information for the following fields:

■ Select the frequency for checking the alert conditions. The options are:

– Hourly

– Daily

– Weekly

– Monthly

– Yearly
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Based on the option selected, fields display on the right. For example, if you have 
selected the Hourly option, then on the right side, enter the hourly details. If you 
have selected the Monthly option, enter the day and time of the month.

■ Start Date - specify the date on which the frequency monitoring has to start.

■ Start Time - specify the time when the frequency monitoring has to start.

■ Time Zone - the time zone based on the geographical location.

■ End Date - specify the date on which frequency monitoring has to stop.

■ End After - specify the number of occurrences of the alert that triggers the 
stop.

12. Click Next.

13. In the Notifications tab, enter information for the following fields to specify how 
the users are notified when the alert occurs:

■ On the Notification Details subtab, select the notification method. The 
options are:

– Dashboard

– Email

■ On the Notification Content subtab, Include alert context details within 
message:

– Subject

– Message

14. Click Finish.

Conditional Alerts based on User Actions plus Frequency
If the alert is triggered by user actions and frequency, then you get two alerts, one 
when the user does the action and the second when the frequency condition is met.

To create conditional alerts based on user actions and frequency:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > New.

2. Select the object or category for the alert.

3. In the General tab, enter information for the following fields:

■ Name

■ Type

■ Mandatory

■ Autosubscribe

■ Priority (Default)

■ Effective Start Date

■ Effective End Date

■  For Custom Web service related Attributes, select any or all of the options:

– Invoke External Service

– Whom to Notify (Determined by Service)

– Criteria evaluation
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– What to notify

4. Click Next.

5. In the Alert Trigger tab, for Alerts Triggered by, select Attribute's value meeting 
a condition.

6. For the Check the Attribute field, select Both when a user performs an action and 
at certain time intervals.

7. Click Next. The Details tab displays.

8. In the Attributes tab, select the attribute that has to be used for the alert condition 
and/or displayed in the alert notification message and click Next.

9. In the Conditions tab, specify the condition for each attribute that must trigger the 
alert. The conditions that you can specify are:

■ In the Condition column, select Modified, Equal To, or Not Equal To.

■ In the Macro column, select a pre-defined function.

■ In the Operator column, select +, *, -, or / which are used to specify the 
condition.

■ In the Value column, enter the value that uses the operators to define a 
condition.

If you have selected the condition as Modified, then the Macro, Operator and 
Value columns are not enabled.

■ In the UOM column, specify the Unit of Measure for the attributes, if any.

■ In the Required column, if the checkbox is selected, you cannot leave the 
condition field blank while adding or editing the conditions on your 
subscribed alert.

■  In the Noneditable column, if the checkbox is selected, you cannot edit the 
condition when you subscribe to the alert.

10. Click Next.

11. In the Actions tab, select the actions that are used to monitor the alert and click 
Next.

12. In the Frequency tab, enter information for the following fields:

■ Select the frequency for checking the alert conditions. The options are:

– Hourly

– Daily

– Weekly

– Monthly

– Yearly

Based on the option selected, fields display on the right. For example, if you have 
selected the Hourly option, then on the right enter the hourly details. If you have 
selected the Monthly option, enter the day and time of the month.

■ Start Date - specify the date on which the frequency monitoring has to start.

■ Start Time - specify the time when the frequency monitoring has to start.

■ Time Zone - the time zone based on the geographical location.
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■ End Date - specify the date on which frequency monitoring has to stop.

■ End After - specify the number of occurrences of the alert that triggers the 
stop.

13. Click Next.

14. In the Notifications tab, enter information for the following fields to specify how 
the users are notified when the alert occurs:

■ On the Notification Details subtab, select the notification method. The 
options are:

– Dashboard

– Email

■ On the Notification Content subtab, Include alert context details within 
message:

– Subject

– Message

15. Click Finish.

2. Assigning Roles, Users, Groups, or Macros
You can assign roles and sites to alerts, while creating an alert definition. If you are 
assigned to the published site and the parent site(s) with the same role, you can 
subscribe to that alert. If alert definition is mandatory, you are subscribed 
automatically based on the site-role combinations assigned to that definition.

Note: Data-driven alerts cannot be assigned roles and sites as all the 
required inputs are acquired from the external Web service.

You can unassign the sites and roles associated to an alert. If you are subscribed to an 
alert definition, for which the site-role assignments are changed, you stop receiving the 
alert. An e-mail is sent to you stating that you no longer have access to that alert.

There are two types of macros:

■ Data-context-specific macros - these are driven by the Data/Business Object such 
as PRJ_MANAGER, CMP and MANAGER.

■ Global macros - applicable per instance of a database that can also be used in an 
INPUT field during operations such as SEARCH, ADD and DELETE.

For example, typing the macro @TIME@ in an attribute of TIME datatype must 
automatically translate it to Current Time when adding, editing, or searching using 
TIME datatype. The application must check and prompt the user if a MACRO is used 
with an incorrect datatype.

If TIME is used as a default value for attribute of TIME datatype, then that field should 
be prepopulated with the current time in the logged in user's time zone, when adding 
a new RECORD.

'@' is used as a special character to let the application know that the text within the 2 
characters is a macro name and needs special processing.

To assign roles, users, groups, or macros to an alert:

In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.
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Perform a search for the alert.

Select the alert for which you want to assign roles and click Assign Subscribers.

In the Alert Assignments pane, you can assign the following:

■ Roles

■ Users

■ Groups

■ Macros

Assigning Roles
To assign roles to an alert:

1. In Alert Assignments, on the Roles tab, click Add Roles.

2. Select the role(s) to assign and click OK.

3. In the Sites tab, select the site to qualify the role assignment.

4. Click Finish. The selected role displays in the Roles tab.

5. To edit an assigned role, select the role and click Edit.

6. To remove an assigned role, select the role and click Delete.

7. Click OK. The confirmation message appears.

Unassigning Roles
To unassign roles from an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Enter the Name of the Alert, to which the Role is to be unassigned, in the Alert 
Name field. Click Search.

The details of the Alert are displayed in Search Results.

3. Select the Alert Definition. Click on Assign Subscribers.

The Assign Roles page is displayed.

4. Remove the existing role and add another role and site.

If the user who has already subscribed to this alert does not have the updated site-role 
combination, the system deletes the subscription.

The user will receive an email notification regarding unsubscribing this alert.

Note: In case of a Published, Mandatory, or Autosubscribe alert, if 
the updated site-role combination matches with any of the existing 
users' site-role combination, this alert will be automatically subscribed 
to that user and sends an email notification.

Assigning Users
To assign users to an alert:

1. In Alert Assignments, click the Users tab.

2. Click Add User.
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3. Perform a search for the user.

4. Select the users to whom you want to assign the alert and click OK. The selected 
users display in the Users tab.

5. To remove an assigned user, select the user and click Remove.

6. Click OK. The confirmation message appears.

Unassigning Users
To unassign users from an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Enter the Name of the Alert, to which the user is to be unassigned, in Alert Name. 
Click Search.

The details of the Alert are displayed in the Search Results page.

3. Select the Alert definition. Click More and Assign Subscribers.

4. Click on the Users tab.

Remove the existing user and add another user.

If the user who has already subscribed to this alert does not have the updated 
Assigned User list, the system deletes the subscription.

The user will receive an email notification regarding unsubscribing alert.

Note: In case of a Published, Mandatory, or Autosubscribe alert, if 
any user in the updated user list does not consist of the alert 
subscription, this alert will be automatically subscribed to that user 
and sends an email notification.

Assigning User Groups
To assign user groups to an alert:

1. In Alert: Assignments, click the Groups tab.

2. Click Add Group.

3. Perform a search for the user group.

4. Select the user group to which you want to assign the alert and click OK. The 
selected user groups display in the Groups tab.

5. To remove an assigned user group, select the group and click Delete.

6. Click OK. The confirmation message appears.

Unassigning User Groups
To unassign User Groups from an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Enter the Name of the Alert, to which the user group is to be unassigned, in the 
Alert Name field. Click on Search.

The details of the Alert are displayed in the Search Results page.

3. Select the Alert definition. Click on the Assign Subscribers button.
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4. Click on the User Group tab.

The Assign User Group page is displayed.

5. Remove the existing user group and add another user group.

If the user who has already subscribed to this alert does not belong to the updated 
assigned User Groups, the system deletes the subscription.

Note: The user will receive an email notification regarding 
unsubscribing this alert. In case of a Published, Mandatory, or 
Autosubscribe alert, if any user belonging to the updated User Group 
list does not consist of the alert subscription, this alert will be 
automatically subscribed to that user and sends an email notification.

Assigning Macros
To assign macros to an alert:

1. In Alert: Assignments, click the Macros tab.

2. Click Add Macros.

3. Select the macro to which you want to assign the alert and click OK. The selected 
macro display in the Macros tab.

4. To remove an assigned macro, select the macro and click Delete.

5. Click OK. The confirmation message appears.

Unassigning Macros
To unassign Macros from an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Enter the Name of the Alert, to which the macro is to be unassigned, in the Alert 
Name field. Click on Search.

3. Select the Alert definition. Click on the Assign Subscribers button.

4. Click on theMacros tab.

The Assign Macros page is displayed.

5. Remove the existing macro and add another macro. Click OK. The macro is 
updated.

3. Publishing Alerts
You can publish an alert only if it is assigned to roles, users, user groups, or macros.

To publish an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Perform a search for the alert.

3. Select the alert that you want to publish.

4. Click More and select Publish.

5. In Confirm Publish Alert, add or change the effective dates and click OK. You 
have published the alert and a confirmation message appears.
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Unpublishing Alerts
You can unpublish an alert. When you unpublish an alert, you get a list of users who 
have currently subscribed to the alert. A notification is sent to this list of users and 
they are automatically unsubscribed.

To unpublish an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Perform a search for the alert.

3. Select the alert that you want to unpublish.

4. Click More and select Unpublish.

5. Alert Details displays information about subscribed users. Click OK.

6. Enter the reason for not publishing the alert and click OK. You have unpublished 
the alert and a confirmation message appears.

Managing Alerts
You can search, view, edit, duplicate, remove, and activate/deactivate alerts. You can 
also assign roles, users, groups, or macros to alerts.

Searching Alerts
To search for an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Select a search view from the View dropdown list.

3. In the Search Alert Definition area, use the dropdown menus to fill in criteria of 
the alerts you are interested in finding.

4. When you have filled in the Search Alert Definition, click Search.

Viewing Alerts
You can view last ’x’ number of alert messages on the home page (Tools & Settings 
bar). This number ’x’ is configurable via user preferences.

To view alert details:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Perform a search for the alert.

3. In Name, click on the alert name for which you want to view the details.

4. When you open an alert for viewing, there are tabs for the five areas addressed in 
Adding New Alert: Preface, General, Alert Trigger, Details, and Notification. 
There are these additional tabs:

■ Assigned To - displays the roles, users, groups, or macros that is assigned to 
the alert.

■ Subscribers - displays the users who have subscribed to the alert.

■ Notes & Attachments - displays the notes and attachments that have been 
added to the alert by users.

■ History - displays the record of actions performed by users on the alert.
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Editing Alerts
You can edit any existing alert definition that has not been published. If you want to 
modify a published alert, unpublish it prior to modification.

Note: You can not edit published alerts.

To edit alert details:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Perform a search for the alert.

3. Select the alert you want to edit and click Edit.

4. In Edit Alert, edit the required information in the various tabs.

You can also edit the assigned roles, users, user groups and macros.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. The 
confirmation message appears.

Duplicating Alerts
You can create a new instance of an existing alert with the same attributes, but with a 
different name.

To duplicate an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Perform a search for the alert.

3. Select the alert that you want to duplicate.

4. Click More and select Save As.

5. In Alert: Duplicate, click Clear.

6. Enter a name for the alert.

7. Select NotesandAttachments to specify if you want to add any notes and 
attachments.

8. Click Save and Edit to change the associated details or click OK to save the 
duplicated alert without changing the associated details. To cancel, click Cancel.

Note: If the original alert definition is published and subscribed, the 
duplicated alert definition is not automatically published. You have to 
publish the alert.

Removing Alerts
You can delete an alert definition if it is not published. If you want to remove a 
published alert, unpublish it prior to removal (deletion).

To remove an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Perform a search for the alert.
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3. Select the alert that you want to remove.

4. Click Delete.

5. Enter the reason for removal and click OK. The alert is removed and a 
confirmation message appears.

Activating and Deactivating Alerts
You can activate an alert that is published, thus making it available for subscription. 
You can also activate an alert that has been deactivated.

When an alert is deactivated, a notification is sent about the inactivation. Deactivated 
alerts are not available for subscription.

To activate or deactivate an alert:

1. In the Tools & Settings menu, select Alerts/Workflows > Alerts > Manage.

2. Perform a search for the alert.

3. Select the alert that you want to activate or deactivate.

4. Click More and select Activate. You have activated the alert.

5. To deactivate the alert, click More and select Deactivate. You have deactivated the 
alert

.
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6Workflows

This chapter provides details on how to create and manage workflows in Agile Recipe 
Management for Pharmaceuticals .

Overview of Recipe Management for Pharmaceuticals  Workflows
Workflows are used to automate the approval process.

For example, if you need five people to approve your documents, a workflow can be 
implemented that automatically forwards all the approval forms to all five people. You 
have to only submit the document once and it is automatically emailed to all five 
members in the workflow chain for their approval or rejection.

As another example, you are the Equipment Manager and you may order 150 pieces of 
equipment in a given year. There are three people in your equipment order process: 
the original equipment requester, yourself, and your manager, who has to approve or 
disapprove it. This process can be automated using workflows.

When the request is received, and if any action is taken, an email is sent to all the 
people involved in the approval chain.

Note: There is no "crossover" between PLM workflows and Recipe 
Management for Pharmaceuticals  workflows: - Recipe Management 
for Pharmaceuticals  workflows do not carry non-Recipe Management 
for Pharmaceuticals  business objects; - PLM workflows do not carry 
Recipe Management for Pharmaceuticals  business objects.

The Recipe Management for Pharmaceuticals Workflow process uses five components:

■ Authorized Parties

■ Workflow Statuses

■ Workflow Actions

■ Workflow Trigger Actions

■ Business Objects

Caution: The word "Status" now appears in the top-level UI, e.g., 
Alerts/Workflows > WF Status. However, many attributes pertaining 
to workflow "status" still use the word "state". There are also attributes 
pertaining to aspects of workflows that use the word "status" but do 
not refer to the main steps of workflows.
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Steps toward Creating Workflows
You can create workflows for other users within your organization. The workflows can 
then be used by the authorized personnel.

Creating a workflow includes the following steps, which are defined below the list:

■ Selecting a business object

■ Selecting Sites

■ Specifying notification methods

■ Defining trigger actions

■ Define Attribute Conditions to Qualify the Trigger Action

■ Adding Statuses (States)

■ Adding Actions

■ Adding Authorized Parties

■ Specifying Idle and Backup Delays

■ Specifying State Transitions

Selecting a Business Object
Business objects can be used to create approval workflows. There are three business 
object categories namely, Material, Equipment, and Process. Within each of these 
categories you have business objects that you can use:

■ Material - Material, Spec Plan, Allocation Request, Dispense Request.

■ Equipment - Equipment, Equipment Qualification, Equipment Reservation, 
Equipment Activity.

■ Process - Project, Work Request, Campaign, Process Step, Control Recipe.

You cannot create your own Business Objects.

Selecting Sites
A Workflow can be assigned to multiple sites. You can create and modify workflows 
for only those sites for which you have access permissions.

All the available sites are listed, but the sites that you are authorized to view is 
enabled.

Specifying Notification Methods
Notifications are sent during any state transition. The means of notifications can be 
email and dashboards. The primary notification method cannot be selected as 
secondary again. Notifications are sent to the authorized parties of subsequent state 
and the additional parties who are selected during workflow definition using both of 
the (primary and secondary) methods.

You can specify the subject and message of the notifications.

Defining Trigger Actions
Trigger action triggers the workflow. It is a pre-defined action that you can perform on 
the business object and they are unique to that object. Every object has allowed actions 
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defined. You need to select an action from the allowed actions. For example, New and 
Remove are some of the trigger actions. You cannot create your own trigger actions.

Defining Attribute Conditions to Qualify the Trigger Action
Workflows are triggered based on various conditions. One of them is the attribute 
condition. These conditions must be met for an action to trigger the workflow.

Adding Statuses (States) to the Workflow
Each step or stage of a workflow is a workflow status (state). Each state has a status  
name and state type. Based on the defined state, the authorized parties take actions on 
the workflow. Before you define a workflow, you must define the states for the object.

Caution: The word "Status" now appears in the top-level UI, e.g., 
Alerts/Workflows > WF Status. However, many attributes pertaining 
to workflow "status" still use the word "state". There are also attributes 
pertaining to aspects of workflows that use the word "status" but do 
not refer to the main steps of workflows.

Adding Workflow Actions
Workflow actions are the operations you can perform on any workflow state. For 
example, Approve, Delete, Edit, Need More Info, Reject, Save, and Submit are some of 
the predefined workflow actions. For every action on a workflow state, you must 
specify a destination workflow state.

Adding Authorized Parties
Authorized parties take actions on workflows, for example, by moving the object from 
one state to another. They can be classified as:

■ Primary Approver party - is the first party to receive the notification about the 
object state and receives a request for approval action. When the primary approver 
performs the necessary action, the object in the current state moves to the next 
state.

However, moving to the next state may depend on consensus from the authorized 
parties also, where all the authorized parties should take actions. Primary approver 
can be a Role, User, User Groups, or Macro.

■ Backup Approver party - is the second party to receive the notification, when the 
Primary party does not respond. You must specify the delay, after which the task 
moves from the Primary approver party to the Backup approver party.

The backup delay period is the waiting period for the primary approver to act on any 
action.

If backup approver is not specified, the application sends the alert to the requester.

Specifying Idle and Backup Delays
You must specify the delay for taking actions and move the current workflow state to 
the next. Delays are classified as:

■ Idle delay - determines when the initiator of the task has to be notified that no one 
(including the Backup Party, if any) has taken action.
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■ Backup delay - defines the delay, after which the task moves from the Primary 
Party to the Backup Party.

If neither the primary approver(s) nor the backup approver(s) have taken any action 
(even after the backup delays), the workflow sends a "No Action Alert" to the 
workflow requester. Also, these workflow tasks remain as pending tasks on the 
primary and backup party's task list. Now, the initiator can notify you about the 
pending workflow.

Specifying State Transitions
You must define state transitions to automate the Workflow. If a workflow is in state 
s1, upon action a1, it advances to state s2.

For each Starting or Intermediate state, you can specify if you require a consensus on 
one of its actions from all authorized parties. You can specify if all authorized parties 
are required to take some action before a state transition happens or any one 
authorized party taking action can result in a state transition.

For example, there is a workflow with states Review, Rejected, Approved, and Draft. 
Suppose the Review state had the following actions defined: Reject, Accept, and Need 
More Info. The transitions for these actions are:

■ Reject Action to Rejected state

■ Approve Action to Approved state

■ Need More Info Action to Draft state

While defining the workflow state, if you select ALL for the Approve action, then the 
workflow enforces ANY for all the other remaining actions in this workflow state 
(namely, Reject and Need More Info).

During execution, if all authorized parties select the Approve action for the Review 
state, the workflow state is moved to the Approved state. If one of the authorized 
parties take an action other than Approve, the state moves to either Rejected or Draft 
(based on the transition matrix defined.)

During state transition, the configured notification(s) are sent to the authorized parties 
of next state.

Workflow Tasks
The authorized approver parties of the workflow are prompted to perform actions to 
push the workflow states to the next state. These actions are allowed on the current 
state of the object in the workflow. If you cannot perform a workflow action or task, 
you can delegate it to another user. This can be done through the Task pane on your 
Home page. For more information, see Task Management.

Creating a Workflow
To create a workflow:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > New.

2. In the Object tab, select the object or the category to which you want to associate 
the workflow.

3. Click Next.

4. The General tab has three subtabs:
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■ Identity

■ Sites

■ Notifications

In the Identity subtab, specify the following information about the workflow:

■ Name - Enter the name of the workflow.

■ Operating Mode - Select the operating mode.

■ Effective Start Date - Enter the effective start date.

■ Effective End Date - Enter the effective end date.

■ Description - Write a brief description about the workflow.

5. Click Next

6. In the Sites subtab, click Add and select the sites to associate the workflow and 
click OK. The selected site(s) appear in the Sites subtab.

If you want to add more sites, click Add and repeat this procedure.

7. Click Next.

8. In the Notifications subtab, specify the following information on how the 
authorized party must be notified:

■ Primary Notification Method - select Dashboard or Email.

■ Optional Notification method - the method you selected for Primary is now 
disabled; select the other method.

■ Subject - enter the subject for the notification message.

■ Message - enter the message details.

9. Click Next.

10. The Trigger tab has three subtabs:

■ Actions

■ Attributes

■ Conditions

In the Actions subtab, select the actions for which the workflow must be triggered 
and click Next.

11. In the Attributes subtab, if the attribute conditions will be used to qualify the 
trigger action, select the attributes to be included in the condition and then click 
Next.

12. In the Conditions subtab, specify for each attribute the condition that must be met 
for the workflow to be triggered.

13. Click Next.

14. In the States tab, do the following to add states to the workflow:

■ Click Add a State.

■ In the Choose State subtab, select the state and specify if it is the Starting, 
Intermediate, or Ending state for this workflow.
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■ Click Next.

■ You need to define the states for the object before you define a workflow. For 
information about defining states, see Workflow State.

■ In the Details ubtab, specify the following:

–

–

■ In the Details subtab, specify the following:

– In the Actions subtab, select the actions to be allowed for the specifed 
states and click Next.

– In the Authorized Parties subtab, click New to specify the parties who can 
take actions on the workflow.

15. In the Primary Party subtab, you can specify the roles, macros, groups and users. 
Click Next.

16. In the Backup Party subtab, specify another role, user, macro, or group as the 
backup party. Click Next. The selected primary and the backup parties appear in 
the Authorized parties subtab.

17. Click Next.

18. In the Delays subtab, specify the Backup Delay after which the action can be taken 
by the backup party. The Idle Delay determines when the initiator of the task is 
notified that no one has taken action on the workflow.

19. Click Next. The selected state appears in the States tab.

20. Click Next.

21. The Transitions tab has three subtabs:

■ Next State

■ Consensus

■ Parties to Notify

In the Next State subtab, select the next state for each action on a state, specify the 
version change and if any signature is required.

Note: You can use the System Actions option to stop the workflow.

22. Click Next.

23. In the Consensus subtab, for each action in the state, select the Destination state 
and click Next.

24. In the Parties to Notify subtab, select one or more state transitions and click Set 
Parties to Notify to specify the people to be notified.

25. In Parties to Notify, select the roles, macros, groups, or users to be notified when 
the selected actions are taken.
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26. Click Add to Notify List. The selected parties appear in Parties to Notify.

27. Click Preview Notification to view the Notification details.

28. Click OK and then click Finish. You have created a workflow, and the 
confirmation message appears.

Managing Workflows
You can edit, duplicate, activate/deactivate, remove and set status for workflow. You 
can perform these tasks when searching or browsing for the workflow.

Searching Workflow
To search for a workflow:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > Manage.

2. Select a search view from the View dropdown list. By default, the Basic view is 
selected.

3. In the Workflows definition area, use the dropdown menus to fill in criteria of the 
workflows you are interested in finding.

You can also search without filling in any criteria.

4. When you have filled in sufficient criteria, click Search.

Browse Workflow
To browse for a workflow:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > Manage.

2. Click the Browse tab.

3. Select an object for which you want to view the associated workflows. Workflows 
displays the list of workflows for the selected object.

Viewing Workflow
You can view the workflow details in Details.

To view the details for a workflow:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > Manage.

2. Perform a search or browse for the workflow.

3. In Workflow ID, click on the workflow ID to view the details.

Editing Workflow
Workflow can be edited in Draft and Review states.

To edit workflow details:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > Manage.

2. Perform a search or browse for the workflow.

3. In Workflows, select the workflow for which you want to edit the details and Edit.

4. Enter information in the various fields.
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5. Click OK.

Removing Workflow
You cannot remove a workflow that is in use.

To remove a workflow:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > Manage.

2. Perform a search or browse for the workflow.

3. In Workflows, select the workflow that you want to remove and click Delete.

The confirmation message appears.

Duplicating Workflow
You can create a new instance of an existing workflow with a new name, but with the 
same details. You can duplicate a canceled workflow as well.

To duplicate a workflow:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > Manage.

2. Perform a search or browse for the workflow. Workflows displays a list of 
workflows.

3. In Workflows, select the workflow that you want to duplicate.

4. Click More and select Save As.

5. In Duplicate Workflow, enter information in the various fields.

6. Click OK.

Activating and Deactivating a Workflow
You can activate or deactivate a released workflow. Deactivated workflows cannot be 
started. A deactivated workflow can be activated, if not in Canceled state.

To activate or deactivate a workflow:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > Manage.

2. Browse or search for the workflow.

3. In Workflows, select the workflow that you want to activate or deactivate.

4. Click More and select Activate, to activate the workflow. Click OK. You have 
activated the workflow.

To deactivate the workflow, click More and select Deactivate. Click OK. You have 
deactivated the workflow.

Workflow Status
Workflow statuses are the steps or stages of a workflow. A workflow status has a State 
Name and State Version. You can define any number of statuses in an Recipe 
Management for Pharmaceuticals  workflow.

Examples of status (state) names include Draft, Release for Review, Approved, 
Rejected, and On Hold. Workflow statuses with the same name can exist in two 
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different workflows; however, two statuses with the same name cannot exist within a 
single workflow.

You can create your own workflow statuses.

You can create, search, view, edit, duplicate, and remove workflow statuses.

Caution: The word "Status" now appears in the top-level UI, e.g., 
Alerts/Workflows > WF Status. However, many attributes pertaining 
to workflow "status" still use the word "state". There are also attributes 
pertaining to aspects of workflows that use the word "status" but do 
not refer to the main steps of workflows.

State Type of Workflow Status
State Types are Start, Intermediate, or Final.

Each workflow must have:

■ A workflow state of State Type Start

■ A workflow state of State Type Final

You can specify a workflow to stop in any of its states.

Setting Workflow Status
Workflows can have the following states:

■ Draft - this is the initial state of the workflow. In this status, the workflow can be 
modified as many times without affecting the version number of the workflow.

■ Review - when a user submits a workflow for review, the workflow moves from 
the Draft to the Review state.

■ Released - when a user approves a workflow, it moves from the Draft to the 
Released state.

■ Canceled - when a user cancels a workflow that is in the Draft, Review, or 
Released state, it moves to the Canceled state.

Once a workflow is in Canceled state, it cannot move to any other state. It can be 
removed if it has not been used, even once.

To change the state of the workflow:

1. In the Tools & Settings menu, select Alerts/Workflows > Workflows > Manage.

2. Perform a search for the workflow.

3. Select the workflow for which you want to change the state and click Change> 
Lifecycle Phase and select the required state.

4. Click OK.

Creating a Workflow Status
To add new state:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Status > New.

2. In the General tab, select the object for which you want to create a workflow state.

3. Click Next.
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4. In the Details tab, enter information for the following fields:

■ State Name - Enter the name of the state.

■ State Description - Write a brief description about the state.

■ Lifecycle Phase - Select the lifecycle phase.

■ Allow stop workflow - Select the option, if you want to stop workflow.

5. Click Finish. The confirmation message appears.

Searching Workflow Status
To search for a state:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Status > Manage.

2. In the Object States definition area, use the dropdown menus to fill in criteria of 
the workflows you are interested in finding.

3. When you have filled in sufficient criteria, click Search.

Browsing Workflow Status
To browse for a state:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Status > Manage.

2. Click the Browse tab.

3. Select the object for which you want to view the states. You can view a list of states 
for the selected object in States.

Viewing Workflow Status
To view details for a state:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Status > Manage.

2. Click the Browse tab.

3. Select the object for which you want to view the states.

4. In State Name, click on the state name to view the details.

Editing Workflow Status
To edit details for a state:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Status > Manage.

2. Perform a search or browse for the state.

3. Select the state that you want to edit and click Edit States.

4. In Edit Object State, enter information for the following fields:

■ State Name

■ Description

■ Lifecycle Phase

■ Allow stop workflow

5. Click OK.
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You have edited the state and a confirmation message appears.

Releasing Object State
A business object must have at least two released states so that a workflow can be 
created for it.

To release an object state:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Status > Manage.

2. Perform a search or browse for the object.

3. Edit the object state(s) you want to release and click Release.

You have released the selected state for the object, and a confirmation message 
appears.

Removing Object State
To remove an object state:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Status > Manage.

■ From the Search tab, search for a state, select the Business Object that contains 
the state you want to delete, and click Edit States.

■ From the Browse tab, select an object that has the state that you want to delete.

2. Perform a search or browse for the object with the related state.

3. Select the state that you want to remove and click Delete.

The state is removed for the object.

Workflow Action
Workflow actions are operations you can perform on any workflow status. Examples 
of workflow actions include Approve, Delete, Edit, Need More Info, Reject, Save, and 
Submit. You can create, search, view, modify, duplicate, and remove workflow actions.

Creating a Workflow Action
To add a new workflow state action:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Action > New.

2. Enter information for the following fields:

■ Action Name

■ Action Description

■ Active

3. Click Finish. You have added a new workflow action and a confirmation message 
appears.

Searching Workflow Action
To search for a workflow state action:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Action > Manage.

2. Select a search view from the View dropdown list.
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Viewing Workflow Action
To view workflow action details:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Action > Manage.

2. Perform a search for the workflow action.

3. In Action Name, click on the workflow action name for which you want to view 
the details.

Editing Workflow Action
To edit details for a workflow action:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Action > Manage.

2. Perform a search for the workflow action.

3. Select the workflow action for which you want to edit the details and click Edit.

4. Enter the information in the following fields:

■ Action Name

■ Action Description

■ Active

5. Click OK.

Duplicating Workflow Action
You can create a new instance of an existing workflow action with a different name.

To duplicate a workflow action:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Action > Manage.

2. Perform a search for the workflow action.

3. Select the workflow action for which you want to duplicate and click More > Save 
As.

4. In Duplicate Action, enter the Action Name.

5. Select Notes and Attachments, if you want to add notes and attachments to the 
action name.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated workflow action without changing the associated details. To cancel, 
click Cancel.

Removing Workflow Action
To remove a workflow action:

1. In the Tools & Settings menu, select Alerts/Workflows > WF Action > Manage.

2. Perform a search for the workflow action.

3. Select the workflow action for that you want to remove and click Delete.

You have removed the workflow action and a confirmation message appears.
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Workflow Statuses Versioning
A set of workflow states for a given object is versioned. If you add, modify, or delete 
the existing set of workflow states for an object, the version number for the set of states 
is incremented. However, the new or modified workflow states have to be released for 
the version to be incremented.

Versioning of workflow states is helpful as the administrator can attach the workflow 
to any current or previous versions of the object state set(s) with Released state.
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This section helps you to set the application defaults and understand how to manage 
audit trails.

As an Recipe Management for Pharmaceuticals  administrator, you log on to the 
development database to incorporate metamodel changes across the application.

Library (Records)
Recipe & Material Workspace's record-management system permits the creation, 
retention, removal, and use of records. The Library lets a privileged user locate 
records, add the records directly into the database, have multiple result views of 
records, compare records, and duplicate records.

Information is organized depending on functionality. Each function is stored as 
separate categories or folders. Each category has a set of attributes. There is a parent 
category that is the base or root of the category hierarchy tree. A child category 
inherits all attributes of a parent category.

For example, View is one of the subcategories of Metamodel. Recipe Management for 
Pharmaceuticals  allows the user to add multiple records simultaneously.

Creating a Record
To add a new record to the library:

1. In the Tools & Settings menu, select Administration > Library > New Record.

2. In the Category tab, select a category for which you want to add a record and click 
Next.

3. In the General tab, enter the key information for the record and click Next.

4. The Details tab displays fields based on the selected category.

5. Enter relevant information in all the fields.

6. Click Finish to save the changes. You have added a new record to the library and a 
confirmation message appears.

Managing Records
You can view, search, browse, view details, edit, duplicate, and remove records.

Browsing and Searching Records
To browse for a record in the library:
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1. In the Tools & Settings menu, select Administration > Library > Manage Record.

2. To browse for a record, in the Browse tab, select a category.

3. In Records, click the Search tab.

4. You can perform a search in any of the following ways:

■ Enter the search criteria in any or all of the fields and click Search.

■ Select the required Value from the fields. Click OK and then click Search.

■  Leave all the fields blank and click Search.

Records displays the records based on the search.

Editing Records
To edit record or report details:

1. In the Tools & Settings menu, select Administration > Library > Manage Record

2. Search and select the record or report.

3. Click Edit.

4. Edit information for the fields.

5. Click OK. A confirmation message appears.

Duplicating Records
To duplicate a record:

1. In the Tools & Settings menu, select Administration > Library > Manage Record.

2. Browse or search for the record.

3. In Records, select the record that you want to duplicate and click Duplicate.

4. Enter the required information and click OK. The confirmation message appears.

Removing Records
To remove a record:

1. In the Tools & Settings menu, select Administration > Library > Manage Record.

2. Browse or search for the record.

3. In Records, select the record that you want to remove and click Remove.

Activating and Deactivating Records
You can only activate and deactivate records that belong to selected categories.

Note: You can see the effectivity options only if a category has its 
Effectivity set to True. Effectivity option is set to true when you define 
a category.

To activate or deactivate a record:

1. In the Tools & Settings menu, select Administration > Library > Manage Record.

2. Browse or search for the record.

3. Click More and select Activate or Deactivate.



Unlocking Objects Currently Being Modified

Administration 7-3

■ In Reason for Activation, enter the start date, end date and the reason for 
activation. Then, click OK. You have activated the record.

■ In Reason for Deactivation, enter the end date and the reason for 
deactivation. Then, click OK. You have deactivated the record.

Note: you will not be prompted for your reasoning unless the 
"Reason For Change" prompts have been enabled.

Manage Internal ID
In Recipe Management for Pharmaceuticals , each instance of an object is identified 
with its Internal ID. An internal ID is generated each time a new record is inserted into 
the system. You can:

■ Increase the size of the internal ID to accommodate IDs beyond the given size.

■ Change the start and end sequence ID.

You can set a maximum value for the sequence so that after the end sequence is 
reached, the system does not allow any user to insert any more records. In case the 
internal ID sequence reaches a predefined threshold, the system sends out a Critical 
Alert to you.

Internal IDs can be used to migrate data from another external system without using 
API (such as a PL/SQL program.)

To manage internal IDs:

1. In the Tools & Settings menu, select Administration > Manage Internal ID.

2. Manage Internal IDs displays the start sequence number, end sequence number 
and the last value. Click Refresh to refresh the displayed values.

3. To set the end/maximum value:

■ Click Set MAX ID.

■  In the Set Internal IDs screen, enter the End Sequence Number. This value 
should be greater than the last value.

■ Click OK. The value displays in the ManageInternalIDs.

4. To reserve IDs:

■ Click Reserve Block.

■ In the Reserve ID Block, enter the number of IDs to be reserved.

■ Click OK.

The confirmation message displays the number of reserved IDs, maximum value and 
the next available ID.

Unlocking Objects Currently Being Modified
At any given time, only one user can edit an object. When a user opens an object for 
editing, Recipe Management for Pharmaceuticals  automatically locks the object to 
prevent others from attempting to edit the same object. The system will throw an 
exception if multiple users try to edit the same object simultaneously. Hence, the object 
remains locked for all other users when it is being edited by one user.



User Audit

7-4 Recipe Management for Pharmaceuticals Administrator Guide

You can see all objects that are currently locked by the Recipe Management for 
Pharmaceuticals  system on the Objects Currently being Modified page. If needed, you 
can unlock an object that has been locked by Recipe Management for Pharmaceuticals .

To unlock an object:

1. In the Tools & Settings menu, select Administration > Manage Object Lock > 
Objects Being Modified.

All objects that are currently being edited are listed on the Objects Currently being 
Modified page.

2. Select the object(s) that you want to unlock and click Unlock Objects.

Once an object is unlocked, it can be edited, updated, or deleted.

User Audit
User audit records the details of users who are currently logged in. It also gathers the 
history of all users who have logged in to the application. Details of users such as User 
ID, Display Name, Login Time, Logout Time, Client IP Address, Client Name, 
Database, and Session ID are recorded and displayed.

Active History
To view the active history of users:

1. In the Tools & Settings menu, select Administration > User Audit > Active 
History.

2. Click on Search.

Results in 'Audit User Activity' shows the details of the history of all the users 
who have logged in.

■ You can export the details of users by selecting them and clicking on the 
export icon.

■ You can compare two users by select on the users and clicking on the compare 
icon.

Users Logged In
To view users who are currently logged in:

1. In the Tools & Settings menu, select Administration > User Audit > Users 
Logged In.

2. A list of all the users who are currently logged in is displayed.

■ You can export the details of users by selecting them and clicking on export 
icon.

■ You can compare two users by selecting the users and clicking on the compare 
icon.

Cache
Cache improves the performance of the application and ensures faster responses to 
requests. A cache ensures that the application meets the performance and response 
requirements.
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At a high level, the following objects are cached in Recipe Management for 
Pharmaceuticals :

■ Metadata for all persistent data objects are retrieved from the database and a 
database cache is built. These objects are cached in memory when the first request 
for the object is made by any one of the application modules.

■ Configuration information that is stored in files, which are cached in memory, at 
the application startup.

The various granular caches in Recipe Management for Pharmaceuticals  are:

■ Image Cache

■ Alerts Cache

■ Authorization Cache

■ Business Object Cache

■ Integration Cache

■ Macro Cache

■ Metamodel Cache

■ Organization Cache

■ People Cache

■ Sequence Cache

■ UOM Cache

■ Valid Value Cache

■ Workflow Cache

■ Localization Cache

Cache Initialization
There are two types of cache initialization in Recipe Management for Pharmaceuticals :

■ Lazy Loaded Cache - Data is loaded from the repository on-demand and the cache 
is built, as requests are made for different objects/data. Since the cache is not built 
completely at a single instance, this type of loading mechanism is called Lazy 
Loaded Cache.

■ First Access Fully Constructed Cache - The entire set of objects/data that form the 
cache is loaded from the repository when the first request is initiated. Since the 
entire set of objects/data is cached, this type of loading mechanism leads to a 
completely constructed cache at the first request, and so is called First Access Fully 
Constructed Cache.

Refreshing and Invalidating Cache
Caches can be refreshed or invalidated. Configuration information (data read from the 
application configuration files) is not refreshed. You can refresh the entire application 
cache for a database that invalidates all the caches stored in the Application Caches.

For example, you may change the Category through the Metamodel UI, which results 
in the Persistence Cache (Category Cache) being refreshed by the system 
automatically, without your intervention. In this case, you do not have to refresh the 
cache manually through the UI.
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To refresh a cache manually:

1. In the Tools & Settings menu, select Administration > Cache > Manage.

2. In RefreshCache, select the database that you want to refresh and click Reload 
Cache.

View Refresh History of Caches
You can view the refresh history of caches in a chronological order.

To view the refresh history of caches:

1. In the Tools & Settings menu, select Administration > Cache > View Refresh 
History.

2. Cache Refresh History displays the history of all the caches that were reloaded or 
cleared.

Details of caches like Cache Name, User ID, User Name, Client IP Address, Reason 
for Change, Refresh Type, DB Name and Client Type are displayed in the Cache 
Refresh history page.

3. Click OK to return.
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Object Modeling section helps you to understand how to manage database categories, 
attributes, views, filter views and workflow states in Agile Recipe Management for 
Pharmaceuticals .

Object Modeling Overview
Object modeling, or Metamodeling, is the construction of a collection of "concepts" 
within a certain domain. In Recipe Management for Pharmaceuticals , it is the ability 
to modify major Categories and their attributes.

Category is equivalent to a database table, but it has business logic and UI-related 
metadata associated with it. A Category may not always map to a single database 
table, it can have multiple tables associated with it, as in the case of inherited 
categories.

Attributes are like columns in a database table, so attributes are defined for a Category. 
Again attributes have much more metadata associated than a plain data type. 
Attributes can be of Foreign Key type, which can be used to define relationships 
between two categories.

A View is a collection of attributes picked up from a set of related categories. It is an 
equivalent of the database View with more metadata defined. Views are used to query 
and edit records in the database.

A Subview can be defined on any View, and it can only contain a subset of result 
attributes defined in the View.

Recipe Management for Pharmaceuticals has the following Folder categories:

■ Audit Trail Folder

■ Inventory Balance Folder

■ Base:

■ Analytical Management Folder

■ Equipment Folder

■ Exception Folder

■ Material Folder

■ Meta Model Folder

■ Print Folder

■ Process Folder
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■ Recipe Folder

■  Standards Folder

■  System Folder

Within each of these folders, there are further subclassifications of Categories. Many of 
these categories are internally used by Recipe Management for Pharmaceuticals .

For example, within the Equipment folder is the subclassification of these business 
objects:

Equipment Business Objects

Blender Column Dryer

Evaporator Filter Hood

pH Meter Reactor Tank

Pump Scale Scrubber

Sieve Syrup can Temperature Controller

Vacuum Meter Cyromat Distributed Solvent System

Flow Chart HVAC System InfraRed Analyzer

Mass Flow Volume Density 
Meter

Mill Module

Nitrogen System Purified Water System Thermal Fluid System

A classification is based on equipment with the same characteristics. For example, you 
can create any number of blenders, columns, and dryers. In addition, you can add 
your own characteristics (attributes) to each equipment type.

An example of blender characteristics (attributes) includes Calibration Frequency, 
Cleaning Method, Created Date, and PPM Limits.

Every time you create a new blender type, these characteristics are inherited. In 
addition, you can add your own characteristics.

Important: When creating categories, attributes, views, filter views, 
and workflow states, do not use reserved keywords that are used by 
the Recipe Management for Pharmaceuticals system.

Searching Category, Attribute, View, or Subview
To search for a category, attribute, view, or subview, do the following:

1. In the Tools & Settings menu, select Object Modeling > select Category or 
Attribute or View or Subview > then select Manage.

2. Select a search view from the View dropdown list.

3. In the Search definition page, use the dropdown menus to fill in criteria of the 
business objects you are interested in finding.

4. When you have filled in sufficient criteria, click Search.
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Category
Category represents a database table that comprises attributes. These attributes are 
viewed through Views and Subviews. Categories in a database are associated to one 
another. These associations create relationships in the database among categories. This 
relationship creates a category hierarchical structure displaying the parent and the 
child relationship.

Besides the normal "manage" functions (detailed in Managing Category), you can 
create a new category, create a schema, and move a category from one parent to 
another parent category.

You can add categories:

■ at the same level as an existing category in the category hierarchy;

■ at one level below (as a child) of any existing category in the category hierarchy;

■ at the Base;

■ at the default category folders, such as, Administration, Data Modeling, 
Organization, People, Equipment, Material, and Process.

In the category hierarchy tree, the categories are referred to as parent categories and 
child categories.

Steps toward Creating a Category
You create a new category in the Base or the default folders. Creating a category 
involves:

■ Defining the category;

■ Adding attributes for the category;

■ Creating a schema for a category;

■ Adding views; and,

■ Adding subviews.

Category Types
Category is classified as:

■ System category - a category that provides system data. A System category 
comprises attributes of its own, and it allows you to add data records.

■ Folder category - a container object. A Folder category does not allow you to add 
data records. It can have categories of both the System and Folder types. They are 
referred to as child categories, which inherit the properties of the parent category 
and can have attributes of their own.

Every category must have a name, database name, label, and parent category.

Adding a Category at the Base
Base category is a default category with common attributes. This is the parent category 
for all the System categories.

The System categories inherit the attributes of the Base category.

You can create categories of System or Folder type in this category.
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Adding a Category under the Default Folders
The system folders provide the data required to construct and manage the application. 
You can configure these folders to set up the data in the required category.

adding Attributes to a Category
If a category belongs to a child category type, it inherits the properties of the parent 
category. You can add specific attributes to the category.

There are two types of attributes, namely, Inherited attributes and Category-specific 
attributes. The Inherited attributes are the attributes inherited from the parent 
category, if it is a child category.

Creating a Schema for a Category
When a new category is added, by default, it is in "Schema not created" status. The 
tables are not created in the database.

To create these tables, you must create a schema. A table is created in the database 
with the category name and the data type. The category status is updated with 
"Schema created." Now, records can be queried from the database. A default view for 
the category, including the inherited and the current attributes, is available.

Creating a Category
To create a category:

1. In the Tools & Settings menu, select Object Modeling > Category > New.

2. In the Preface tab, select a category and then select one of the following two 
options:

■  Create child of the selected category

■ Create peer of the selected category

3. Click Next.

4. In the General tab, enter information for the following fields:

■ Name - Enter the name of the category.

■ Display Name - Enter the display name of the category.

■ DB Name - Enter the name of the table in the database for the category.

■ Allow Records - Select Yes, if you want to allow records.

■ Allow Attributes - Select Yes, if you want to allow attributes.

■ Description - Give a brief description of the category.

5. Click Next. The Details tab displays. This tab has two subtabs:

■ Characteristics

■ Attributes

6. In the Characteristics subtab, select any of the following options:

■ Allow Versioning - Select Yes, if you want to allow versioning in this category.

■ Allow Workflows - Select Yes, if you want to allow workflows.



Category

Object Modeling 8-5

■ Has Effectivity Dates - Select Yes, if you want the category to have start dates 
and end dates associated with it along with the functionality of activation and 
deactivation.

■ Marked as Business Object - Select Yes, if you want to store the statuses.

■ Use as Internal System Category - Select Yes, if you want to use the category 
as internal system category.

■ Icon ID - Select Icon ID to display the category.

■ Allow Attachments - Select Yes, if you want to allow attachments in a 
category.

■ Allow Notes - Select Yes, if you want to allow notes in a category.

■ Allow Multi-record Additions - Select Yes, if you want to allow multi-record 
additions.

■ Allow Locking - Select Yes, if you want to allow locking.

7. Click Next. In the Database subtab, enter values in the following fields:

■ Initial Extent - Enter the database storage parameter for the initial extent for 
the table.

■ Next Extent - Enter the database storage parameter for the next extent for the 
table.

■ PCT Free - Enter the parameter for percent free for the table.

■ PCT Used - Enter the parameter for percent used for the table.

8. Click Next.

9. In the Attributes subtab, click New to specify the attributes for the category. For 
information to add attributes, see Add New Attribute.

The attributes that you add are displayed in the Attributes subtab.

10. Click Finish. You have created the category and a confirmation message appears.

Managing Categories
You can browse, search, view, modify, duplicate, export, and remove a category.

Browsing Category
To browse for a category:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. Click the Browse tab to view Data Categories.

3. Select a category. The Category tab displays the details for the selected category.

4. Click the Attributes tab to view attribute details of the selected category.

5. Under Attributes tab there are three subtabs.

■  Category-Specific

■ Inherited

■ Composite Keys

You can add and edit attributes under Category-Specific subtab. You can add and 
edit Composite Keys for a set of attributes under the Composite Keys subtab.
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6. Click the Views tab to view associated views of the selected category.

7. Click the Subviews tab to view the subviews details of the selected category.

You can also edit, remove, duplicate, create schema, refresh schema, and move 
categories.

Viewing Category Details
You can view category details from the Search or the Browse tab.

To view details for a category using search:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. In the Search tab, perform a search for the category.

3. The Records pane displays the list of categories based on the search.

4. In Name, click on the category name for which you want to view the details. 
Category: View Details displays the category details such as Name, DB Name, 
category status, characteristics, associated attributes, views, and subviews.

Editing Category
You can edit the details for the category when you browse or search for the category.

Modifying a category involves:

■ Changing the Name, Display Name, DB Name, Is System Flag setting, Allow 
Attributes, Allow Records, description setting

■ Adding or removing associated attributes

■ Modifying existing attribute details

■ Adding or removing associated Views and Subviews

Note: You cannot uncheck the Allow Attachments or Allow Notes, if 
any attachments or notes are attached to the category. If the category 
has data, some of the edit operations specified above would be 
restricted. Please clean up all data before you attempt to make 
changes.

To edit the category details:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. Browse or perform a search for the category.

3. When you perform a search, Results displays the list of categories based on the 
search. Select the category for which you want to edit the details.

4. Click Edit. Edit Category displays the following subtabs:

■ General

■ Details

■ Attributes
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5. Enter the information in the various fields. For information about the fields, see 
Create New Category.

6. You can add, edit, remove, and duplicate the category-specific attributes. You can 
only duplicate the inherited attributes.

7. Click OK.

8. Enter the reason for the changes that you have made and click OK. You have 
edited the category and a confirmation message appears.

Duplicating Category
You can create a new instance of an existing category with the same attributes, but 
with a different name.

While duplicating a category, you must specify a unique name for the category. All 
properties of the original category are duplicated, except for the data and the views of 
the category. The new category is in "Schema Not Created" state. You need to create 
schema for this category. Child categories of the category are not duplicated. The 
views associated with the original category and the data in the category are also not 
duplicated.

To duplicate a category:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. Browse or perform a search for the category.

■ When you perform a search, Records displays the list of categories based on 
the search. Select the category that you want to duplicate and click More > 
Save As.

■ When you browse, the category details are displayed. Click More > Save As.

3. In Duplicate Category, click Clear.

4. Enter information for the following fields:

■ Name - Enter the name of the category.

■ Display Name - Enter the display name of the category.

■ DB Name - Enter the name of the table in the database for the category.

■ Description - Give a brief description of the category.

■ Allow Records - Select Yes, if you want to allow records.

5. Select Notes and Attachments option if you want to add notes or attachments.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated category without changing the associated details. To cancel, click 
Cancel.

Removing Category
You can remove a category, only if a category:

■ Does not have any child categories
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■ Does not hold any data or records in the database

■ Does not have any links or references defined into other categories

To remove a category:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. Browse or perform a search for the category.

3. When you perform a search, Results displays the list of categories based on the 
search. Select the category that you want to remove.

4. Click Delete.

5. Enter the reason for removal and click OK. You have removed the category and a 
confirmation message appears.

Moving Category
You can move a category from one parent category to another parent category. All 
child categories can be selected and moved to a different parent category. A child 
category that has data cannot be moved from one parent to another parent.

Moving a category modifies the following data in the categories:

■ All the properties inherited from the parent category are removed.

■ All the existing views are removed.

■ The old schema is removed and the schema has to be created again.

■ All the properties of the current parent are inherited.

To move a category:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. Click the Browse tab.

3. Select the category that you want to move. The details for the selected category 
displays.

4. Click More and select Move.

5. In Move Category, select a new parent category to where you want to move the 
category.

6. Click OK. You have moved the category and a confirmation message appears.

Creating Schema
A newly created category is in the "Schema not created" status. That is, the supporting 
database tables are not created and the category is not ready to be used.

To create a schema for the category:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. Click the Browse tab.

3. Select the category for which you want to create a schema. The details for the 
selected category displays.

4. Click More and select Create Schema. The application updates the schema status 
as "Schema Created" and a confirmation message appears.
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Refreshing Schema
If any meta-data information related to schema is changed for an attribute, it is in the 
"Schema Refresh Required" status. You must refresh the schema to submit these 
changes.

The category and its views cannot be used to query or edit records in the category in 
this state. When the schema is refreshed, the Default View of the category is updated. 
A warning is displayed, if there are no Primary Keys defined for this category.

Once the schema is refreshed, the category schema status is "Schema Created."

To refresh a schema for the category:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. Click the Browse tab.

3. Select the category that you want to refresh the schema. The details for the selected 
category displays.

4. Click More and select Refresh Schema. You have refreshed a schema and a 
confirmation message appears.

Attribute
An attribute represents a characteristic of a category. It is stored as a column in a 
category table. It specifies the data type and other necessary UI and back-end 
properties of the category.

Creating an Attribute
You can add new attributes while creating a category or from the Browse tab.

To add new attribute:

1. In the Tools & Settings menu, select Object Modeling > Attribute > New.

2. In Attribute: New, under Preface tab, select the category for which you want to 
add new attributes.

3. Click Next.

4. In the General tab, enter information for the following fields:

■ Name - Enter the name of the attribute.

■ Display Name - Enter the display name of the attribute

■ DB Name - Enter the database name of the attribute.

■ Data Type - Enter the type of data of the attribute.

■ Add External Service Call - Select Yes, if the value for the attribute is derived 
externally.

■ Description - Write a brief description of the attribute.

5. Click Next. The Details tab displays. This tab has three subtabs:

■ Characteristics

■ View parameters

■ Type Details

6. In the Characteristics subtab, select any of the following option(s):
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■ Value Required - Select this option to specify that this attribute cannot have 
null values.

■ Primary Key - Select this option to specify that this attribute will be part of the 
Primary Key on the category.

■ Editable - Select this option to specify that this attribute is editable.

■ Allow Setting of View Privileges - Select this option if you want to allow 
settings of view privileges.

■ Indexed - Select this option for the database column created for this attribute 
to be indexed.

■ Value must be unique within category - Select this option if you want the 
value to be unique within the category.

■ Second Person Verification Required - Select this option if a second person 
verification is required.

■ Store Value in Database - Select this option if you want to store value in the 
database.

■ Auditable - Select this option to set the attribute as auditable so that all the 
changes on the attribute can be tracked using Audit Trail.

7. Click Next. In the View Parameters subtab, select any of the following option(s):

■ Icon ID - Enter the icon id to be displayed for the attribute.

■ Always Included In View - Select this option if you want the attribute to 
always be included in your view.

■ Hidden - Select this option if you do not want this attribute to be displayed on 
the user interface.

■ Display Order - Enter value for the display order of the view on the screen.

■ Hyperlink to Details - Select this option if you require hyperlink to details.

■ Method Name - Select the type of method name.

■ Bean Callback - Enter the value for bean callback.

■ Tooltip - Enter the text that needs to appear when you mouseover the 
hyperlink.

Note: If Hyperlink To Details is selected, then Method Name and 
Tooltip become relevant. If method is custom, then the Bean Callback 
needs to be specified.

Note: You can select either Hidden or Editable option, but not both.

8. Click Next.

9. In the TypeDetails subtab, enter information for the various fields. The fields are 
displayed based on the data type that you have selected.



Note: By default, for float type attribute, lead zeros in decimal 
fraction of value entered by user is altered to append required zeros 
for meeting storage precision as well as for UOM Conversion

Note: If Save Entered Value is selected, you require the value entered 
by the user. The value entered will appear at two places - next to the 
standard value of the attribute in Details and in an extra column on 
the screens where data is displayed in tabular format, with the label in 
format <Attribute Label> (As Entered). Unit of measure is applicable 
only to the number data types.
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10. Click Finish. The confirmation message appears.

Managing Attributes
You can create attributes of different data types based on your requirement. There are 
various data types available in the application and are as follows:

■ Text

■ Number

■ Boolean

■ Date/Time

■ Foreign Key

■ Picture

■ Auto Sequence

■ File

■ Large Text

Attributes data types have a special subtype to enhance the requirement.

For example, text data types support Email, Phone, Validated Text, URL.

Number data types support Integer, Float, and Currency.

These enhance the ability of the user to create attributes required. With these features, 
a user also has the ability to represent the attribute by specifying a display name, 
which will be used to represent it on the UI.

Attributes are of two types:

■ Inherited

■ Category-specific

Inherited Attributes are the attributes inherited from the parent category, if it is a child 
category. They can only be duplicated and cannot be created, modified or removed. 
Inherited attributes can be duplicated to make a category-specific attribute.

Category-specific attributes are the specific attributes for the new category. 
Category-specific attributes can be modified, duplicated, and removed.

When you specify a category property, such as Has Effectivity, Owner BO, Versioning, 
or Has Workflow, system attributes are created. These system attributes cannot be 
modified or removed by users of the application.
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Viewing Attribute Details
You can view attribute details in Attribute: View Details. You can view information 
such as Attribute Name, Label and Data Type. Details displays the characteristic 
details, UOMs, Enumerated Values, and the Display width. You can view attributes 
from the Search or the Browse tab.

To view attribute details using search:

1. In the Tools & Settings menu, select ObjectModeling > Attribute > Manage.

2. Perform a search for the category.

3. In Results > Attribute Name, click on the attribute name link for which you want 
to view the details.

Editing Attribute
You can only edit the category-specific attributes and not the inherited attributes from 
the parent category. You can edit using search or browse. After you edit the attribute 
details, you have to refresh the schema for the associated category.

To edit details for the attribute:

1. In the Tools & Settings menu, select Object Modeling > Attribute > Manage.

2. Perform a search for the attribute.

3. Records displays the list of attributes based on the search. Select the attribute for 
which you want to edit the details.

4. Click Edit.

5. In Attribute: Edit, enter the information in the various fields. For information 
about the fields, see Add New Attribute.

6. Click OK.

7. Enter the reason for the changes that you have made and click OK. You have 
edited the attribute and a confirmation message appears.

Duplicating Attribute
Duplicate an attribute to create a new attribute of a similar type. The attribute 
duplicated can belong to a parent or a child category. You can duplicate 
category-specific and inherited attributes for a category.

To duplicate details for the attribute:

1. In the Tools & Settings menu, select Object Modeling > Attribute > Manage.

2. Perform a search for the attribute.

3. Results displays the list of attributes based on the search. Select the attribute that 
you want to duplicate.

4. Click More > Save As.

5. Change the information for the following fields:

■ Attribute Name - Enter the name of the attribute.

■ Attribute Label - Enter the label of the attribute.

■ Attribute DB Name - Enter the database name of the attribute.

■ Description - Write a brief description about the attribute.



Attribute

Object Modeling 8-13

6. Select Duplicate All Notes and Duplicate All Attachments option if you want to 
add notes or attachments.

7. Click Save and Edit to change the associated details or click OK to save the 
duplicated attribute without changing the associated details. To cancel, click 
Cancel. You have duplicated the attribute.

Removing Attribute
You can remove an attribute, as long as both of these conditions are true:

■ The attribute does not have any associated data; and,

■ The attribute is not a part of a View or Subview.

If you try to remove an attribute that contains any data or that is associated to a View 
or Subview, a warning message displays. You must remove the attribute associated 
with the View or Subview, then you can remove the attribute.

Note: When the attribute is removed from a category, the schema 
status of that category must be updated.

To remove an attribute:

1. In the Tools & Settings menu, select Object Modeling > Attribute > Manage.

2. Perform a search for the attribute.

3. Records pane displays the list of attributes based on the search. Select the attribute 
that you want to remove.

4. Click on Delete.

5. Enter the reason for removal and click OK. You have removed the attribute.

Reordering Attribute
Reorder helps you change the display order of the attributes.

To reorder an attribute:

1. In the Tools & Settings menu, select Object Modeling > Category > Manage.

2. Select the Browse tab and select the category whose attribute you want to reorder.

3. On the Attributes tab, select the attribute that you want to reorder.

4. Click More > Reorder.

5. On the Attributes: Reorder screen, change the display order, as needed, and click 
OK.

Configuring Icons to URL Attributes
To add icon IDs to attributes:

1. Open the CFMPCMImages_en_US.properties file, which is located at <AgilePLM_
HOME>\config\locale

The CFMPCMImages_en_US.properties file contains a list of key value pairs.

2. For the attribute whose value you want to modify, In the Details > Characteristics 
page, for the Icon Id field, enter the key details.
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For example, if the key value pair is PCM_IMG_COM_CACHE=/icons/cache.gif, 
enter the value PCM_IMG_COM_CACHE in the Icon Id field.

3. Click OK.

View
When you create the schema for a category, a Default View is automatically created. A 
Default View contains all the attributes from the base category plus all attributes from 
all parents. In addition, you (as Administrator or the user with privileges) create new 
views.

There are two types of views that can be created for a given category:

■ Normal or Basic view

■ "Tree" view

Steps toward Creating Views
The steps to create a basic view are:

■ Select the category and assign a name to the view.

■ Determine whether it is a System view.

■ Determine whether it is a Result view (that is, a searchable view).

■ Select Search view and Result view attributes.

After you create the new view, you can decide if it has precedence over the Default 
view.

Creating a View
This task describes how to create a normal, or basic, view.

To create a view:

1. In the Tools & Settings menu, select Object Modeling > View > New.

2. In the Preface tab select a category for which you want to add the view.

3. Click Next.

4. In the General tab, enter information for the following fields:

■ View Name - Enter the view name.

■ View Label - Enter the view label.

■ Internal to System - Select Yes, if you want the localization value of this field 
to be maintained in a separate file.

■ Show in Search - Select Yes, if you want the view to be shown in search.

■ Exclude Duplicate Records - Select Yes, if you want to exclude duplicate 
records.

■ Allow Tree View - Should be set to Yes

■ Default Rendering - Select the view for default rendering.

■ Description - Write a brief description.

5. Click Next.
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6. In the Related Categories tab, navigate through the tree to select the categories 
that need to be included in this view.

Related Categories are classified as:

■ Application - Categories which are not marked as system categories.

■ Metamodel - Categories that hold meta-data information for the Recipe 
Management for Pharmaceuticals  application.

■ System - Categories that are marked with Use as Internal System Category 
Flag.

■ Child Categories - Children of the related categories.

■ Show Incoming - Show related categories that reference the category on 
which the view is being created.

■ Show Outgoing - Show related categories that reference the category on 
which the view is being created.

■ Based on the option selected, the related categories are shown in the tree.

7. Click Next.

8. In the Attributes tab, you can view the attributes for the selected categories. Select 
the attribute to be used in the Search View and Result View. A few system 
attributes may be selected by default.

9. Click Next. The Details tab displays two subtabs:

■ Search View

■ Results View

10. Both the subtabs display the attributes selected in the Attributes tab.

11. In the Search View subtab, specify the Name, Display Label and Display Order for 
each attribute. You can choose to hide a certain attribute from the search view by 
selecting the Hidden for that attribute. A few system attributes may be selected by 
default.

12. Click Next.

13. In the Results View subtab, specify the Display Name, Display Label and Display 
Order for each attribute. You can choose to hide a certain attribute from the results 
view by selecting the Hidden for that attribute.

14. Click Finish. You have added a new view, and a confirmation message appears.

Note: In Object Modeling, you can click Category > Manage > 
Browse tab. Select Category and click the Views tab.

Creating a Tree View
To create a tree view:

1. In the Tools & Settings menu, select Object Modeling > View > New.

2. In the Preface tab select a category for which you want to add the view.

3. Click Next.

4. In the General tab, enter information for the following fields:

■ View Name - Enter the view name.
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■ View Label - Enter the view label.

■ Used By System - Select Yes, if you want the view to be used by the system.

■ Show in Search - Select Yes, if you want the view to be shown in search.

Note: If you select the Show in Search option, the view will appear 
on Search Screens used for searching records on any category. For 
example, Library Search Screens for Equipment and Material. 
Additional attributes, Note count, and Attachment Count columns are 
added to the view.

■ Exclude Duplicate Records - Select Yes, if you want to exclude duplicate 
records.

■ Allow Tree View - Should be set to Yes.

■ Default Rendering - Select the Tree View option.

■ Description - Write a brief description.

5. Click Next.

6. In the Related Categories tab, select the category on which the view is being 
defined and the attributes to be included from related categories.

7. Click Next.

8. In the Attributes tab, the attributes for the selected categories appear. Select the 
attribute to be used in the Use In Search View and Use In Result View. A few 
system attributes are selected by default.

9. If you want to repeat the attribute more than once in the view, select the attribute 
and click Repeat, specify the Times to Repeat in Search view and Results view. 
Click OK.

10. Click Next. The Details tab appears with four subtabs:

■ Search View

■ Results View

■ Tree Definition

■ Tree Attributes

11. In the Search View subtab, specify the Name, Display Label and Display Order for 
each attribute and then click Next.

12. In the Results View subtab, enter information in the following fields for each 
attribute:

■ Name - Enter the name of the attribute.

■ Display Label - Enter the display label of the attribute.

■ Display Order - Enter the display order of the attribute.

■ Editable - Controls whether the attribute value can be edited in this field.

■ Required - Controls whether a value is mandatory for this attribute.

■ Sort Order - Sort order in conjunction with sort method controls the order in 
which the attributes are displayed in the results view.

13. Click Next.
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14. Choose the attributes to define the tree and specify the tree level for each.

Note: You specify an Icon ID when defining a tree view. You use a 
tree definition icon to represent an attribute.

15. Click Next. Choose the attributes to group by in a tree-oriented results view and 
specify the hierarchy level for each.

16. Click Finish. You have added a new tree view, and a confirmation message 
appears.

Creating a Business Object View and Associating the View with a Business Object
After you have created your view you can associate it with a specific business object so 
that the view can be seen while managing Alerts and Workflows.

To associate your view with the business object:

1. In the Tools & Settings menu, select Administration > Library > Manage 
Records.

2. Click on the Browse tab. Select Base > System Folder > Authorization Folder and 
click the BO View radio button.

3. From Records in "BO View", select the specific view record you want to see while 
managing Alerts and Workflows and click New.

Note: Select only the record which has the Is Alerts View and Is 
Workflow View flag set to No.

4. In the General tab, enter information for the following:

■ Business Object - Click the icon, select the BO ID of the view and click OK.

■ View - Click the icon, select the view name and click OK.

5. Click Next.

6. In the Details tab, select Yes from both the Is Alerts View and Is Workflow View 
dropdown lists.

7. Click Finish. A confirmation appears that the record has been added to the 
business object view.

Note: In order to see the view that you just created, you must refresh 
the database cache.

Managing View
You can manage and display different types of data by creating customizable views. 
You can define the display order of the attributes of each category to be displayed on 
the screen, for each action, as views and save them in the system. You cannot remove 
the Default view. It can be edited with respect to making it a preferred view or by 
changing the display order.
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Viewing Detail for View
You can see details for the associated views for a category from the Search tab.

To view details for the view using search, do the following:

1. In the Tools & Settings menu, select Object Modeling > View > Manage.

2. Perform a search for the view.

3. In View Name, click on the view name for which you want to see the details. 
View: View Details displays the view details such as View Name, View Label, 
Internal to System, Show in Search, Exclude Duplicate Records, Allow Tree View, 
Default Rendering and Description.

4. To view the history details such as Modified Time, Modified By Action, Attribute 
Category, Old Value, New Value, Reason For Change, click on the history icon in 
View: View Details.

Editing View
You can change the details of the existing view attributes, add, remove or reorder view 
attributes. Once a view is edited, all existing objects in the application created on that 
view is invalidated automatically. A warning is displayed if a view is in use, while it is 
being edited. While editing the view, you cannot change the owner category of the 
view. A default view can be edited with respect to making it a preferred view or 
changing the display order.

You can edit view details using search or browse.

To edit details for the view:

1. In the Tools & Settings menu, select Object Modeling > View > Manage.

2. Perform a search for the view.

3. When you perform a search, Results displays the list of views based on the search. 
Select the view for which you want to edit the details.

4. Click Edit.

5. In View: Edit, enter the information in the various fields.

6. Click OK.

7. Enter the reason for the changes that you have made and click OK. The 
confirmation message appears.

Note: Default view is created by the system and cannot be edited.

Duplicating View
You can create a new view based on an existing view. All the attributes of the view and 
the associated meta data are duplicated to the new view. You can only duplicate the 
category-specific views.

To duplicate a view:

1. In the Tools & Settings menu, select Object Modeling > View > Manage.

2. Perform a search for the view.

When you perform a search, Results displays the list of views based on the search. 
Select the view that you want to duplicate.
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3. Click More > Save As.

4. In View: Duplicate, click Clear.

5. Enter the information for the following:

■ View Name - Enter the name of the view.

■ View Label - Enter the view label.

6. Select Notes and Attachments option if you want to add notes or attachments.

7. Click Save and Edit to change the associated details or click OK to save the 
duplicated view without changing the associated details. You have duplicated the 
view and a confirmation message appears.

8. To cancel, click Cancel.

Removing View
When removing a view, all view related data including the view attribute details are 
removed. All Subviews of the view are also removed. DEFAULT view on any category 
cannot be removed. In case of a system view, a warning message appears before 
removal of the view.

To remove the view:

1. In the Tools & Settings menu, select Object Modeling > View > Manage.

2. Perform a search for the view.

Results displays the list of views based on the search.

3. Select the view that you want to remove and click Delete.

You have removed the view and a confirmation message appears.

Making Preferred View
To set a view as the preferred view:

1. In the Tools & Settings menu, select Object Modeling > View > Manage.

2. Perform a search for the view.

Results displays the list of views based on the search.

3. Select the view that you want to set as the preferred view in search.

4. Click More and select Make Preferred.

5. In Reason for Change, enter your reasons for changes.

6. Click OK. You have set a view as the preferred view, and a confirmation message 
appears.

Managing Saved Searches
This procedure allows you to assign a default search to a particular view.

To manage saved searches:

1. In the Tools & Settings menu, Object Modeling > View > Manage.

2. Perform a search for the view.

3. Results displays the list of views based on the search.

4. Select the view for which you want to assign default search.
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5. Click More and select Assign Default Search.

6. Click Manage Saved Searches. If there are no "Saved Searches", you must create a 
new Saved Search and then try to assign a default search to the view.

7. Enter information in the following fields:

■ Created Date

■ Modified Date

■ Created User: User ID

■ Modified Used: User ID

8. Click Search, to search with your favorite view.

9. Click OK, to return to the previous screen.

Reordering View
To reorder the display order for a View:

1. In the Tools & Settings menu, Object Modeling > Category > Manage.

2. Select the Browse tab and select the category whose view(s) you want to reorder.

3. On the Views tab, select the view that you want to reorder.

4. Click More > Reorder.

5. In Views: Reorder, enter the display order for each view to be shown in the View 
drop-down list.

6. Click OK. You have reordered the view and a confirmation message appears.

Note: The application displays only searchable views when 
reordering view.

Toggling View Appearance in Search
You can toggle the view only if you had selected the Show in Search option when 
creating the View.

To toggle the appearance of the view while performing a search:

1. In the Tools & Settings menu, select Object Modeling > View > Manage.

2. Perform a search for the view.

Results displays the list of views based on the search.

3. Select the view for which you want to toggle the view appearance.

4. Select the view. Click More and select Toggle "Show in Search".

5. Enter the reason for change and click OK. You have toggled views and a 
confirmation message appears.

Subview
A Subview is a subset of a view. It contains a collection of result attributes on the main 
view. A view can have many subviews. Subviews are defined in situations where you 
do not always want to view all the attributes connected to the view. Once you define a 
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subview, you can switch to it on a result page and view only the attributes which are 
part of the subview. Results page displays only non-system subviews.

Creating a Subview
To add a new subview:

1. In the Tools & Settings menu, select Object Modeling > Subview > New

2. In Preface, select a category for which you want to add the subview.

3. Click Next.

4. In the General SubViewInformation tab, enter information for the following 
fields:

■ View Name - Enter the name of the parent view.

■ Subview Name - Enter the name of the subview that is being created.

■ Subview Label - Enter the level of the subview to be displayed in the 
application.

■ System - Select this if the subview is to be marked as a system subview.

■ Description - Write a brief description.

5. Click Next. The Attributes tab displays the attributes from the parent view.

6. Select the attributes that you want to include in the Subview.

7. Click Next.

8. In the Attribute Details tab, specify the display order for each attribute.

9. Click Finish. You have added a new subview and a confirmation message 
appears.

Managing Subview
You can add, search, modify, duplicate, reorder, remove, and set preferred subview.

viewing Subview Details
You can also view the details of the subview attributes in a hierarchical format. If there 
are any cross-category attributes added to a subview, the information about the Owner 
Category and Parent Foreign Key attribute is available.

To view details for the subview using search:

1. In the Tools & Settings menu, select Object Modeling > Subview > Manage.

2. Perform a search for the Subview.

3. In Name, click on the Subview name for which you want to see the details. 
Subview: Details displays the details such as View Name, Owner Category, 
Subview Name, Subview Label, and the associated details.

Editing Subview
You can change the details of the existing subview attributes, add, remove and reorder 
subview attributes. Once you edit a subview, all existing objects in the application 
created on that subview are invalidated. On editing a subview that is in use, the 
application displays a warning.

To edit details for the subview:
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1. In the Tools & Settings menu, select Object Modeling > Subview > Manage.

2. Perform a search for the Subview.

When you perform a search, Results displays the list of subviews based on the 
search. Select the subview for which you want to edit the details.

3. Click Edit.

4. In Subview: Edit, enter the information in the various fields. You cannot change 
the view information, while editing a subview.

5. Click OK.

6. Enter the reason for change and click OK. You have edited the subview and a 
confirmation message appears.

Note: You can also edit details for the associated subviews for a 
category from Object Modeling > Category > Manage. Select the 
Category and click the Subviews tab. Select the view and click Edit.

Duplicating Subview
To duplicate a subview:

1. In the Tools & Settings menu, select Object Modeling > Subview > Manage.

2. Perform a search for the Subview.

3. When you perform a search, Results displays the list of subviews based on the 
search. Select the subview that you want to duplicate.

4. Click More > Save As.

Note: You can also duplicate the associated subviews for a category 
from Object Modeling > Category > Manage. Select the Category and 
click the Subviews tab. Select the view and click More > Save As.

5. In Subview: Duplicate, click Clear.

6. Enter the information for the following:

■ Subview Name - Enter the subview name.

■ Subview Label - Enter the subview label.

7. Click Save and Edit to change the associated details or click OK to save the 
duplicated subview without changing the associated details. To cancel, click 
Cancel.

You have duplicated the subview and a confirmation message appears.

Removing Subview
To remove a Subview:

1. In the Tools & Settings menu, select Object Modeling > Subview > Manage.

2. Perform a search for the Subview.

3. In Results, select the Subview that you want to remove and click Delete.

You have removed the subview and a confirmation message appears.
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Reordering Subview
To reorder the display order for a subview:

1. In the Tools & Settings menu, Object Modeling > Category > Manage.

2. Select the Browse tab and select the category whose subview(s) you want to 
reorder.

3. On the Subviews tab, select the subview that you want to reorder.

4. Click More > Reorder.

5. In Subviews: Reorder, enter the display order for each subview.

6. Click OK. You have reordered the subview and a confirmation message appears.

Setting Preferred Subview
To set a Subview as the preferred view:

1. In the Tools & Settings menu, select Object Modeling > Subview > Manage.

2. Perform a search for the subview.

3. When you perform a search, Results displays the list of subviews based on the 
search.

4. Select the subview that you want to set as the preferred subview.

5. Click More >Make Preferred.

6. You have set preferred subview. A confirmation message appears and a tick mark 
appears next to the view in the Subviews tab.

Note: You can also edit details for the associated subviews for a 
category from Object Modeling > Category > Manage. Select the 
Category and click the Subviews tab. Select the view and click More > 
Make Preferred.

Enumerated Valid Value
Enumerated Valid Values (EVV) are preassigned values for attributes. Recipe 
Management for Pharmaceuticals  allows you to add or change enumerated valid 
values. When you want to add a new attribute that supports multiple choice values, 
you define a new EVV. You can add, modify, duplicate, and remove an EVV. You can 
also localize EVVs.

Creating an Enumerated Valid Value
To add an enumerated valid value:

1. In the Tools & Settings menu, select Object Modeling > Enumerated Valid Value 
> New.

2. In the New EVV tab, enter information for the following fields:



Enumerated Valid Value

8-24 Recipe Management for Pharmaceuticals Administrator Guide

■ EVV Name - Enter name of the enumerated valid value.

■ Description - Write a brief description about the EVV.

■ Data Type - Select the data type from the dropdown list.

■ Is System - Select Yes, if you want a system EVV.

■ Display In Result As - Select the display In result from the dropdown list.

3. Click Next.

4. In the Set EVV Values tab, enter information for the following:

■ Value - Enter the value of EVV. The value is the internal system key.

■ Display Value - Enter the display value of EVV. The display value is the key 
value that is used in the configuration files for localization and customization.

■ Description - Write a brief description.

■ Is Active - Select Yes, if you want the EVV to be active and hence, usable 
within the application.

■ Display Order - Enter value for the display order.

5. To specify more Enumerated Valid Values, enter the number of values that you 
want to add in the text box next to Add Row(s) and click Add Row(s). The rows 
are added to the table. For each row, specify the value details.

6. Click Finish. You have added an EVV and a confirmation message appears.

Managing Enumerated Valid Value
With appropriate rights, you can modify, duplicate, and remove enumerated valid 
values.

Searching Enumerated Valid Value
To search for EVV:

1. In the Tools & Settings menu, select Object Modeling > Enumerated Valid Value 
> Manage.

2. Select a search view from the View dropdown list.

3. In the Search Enumerated Valid Value definition area, use the dropdown menus to 
fill in criteria of the EVVs you are interested in finding.

4. When you have filled in sufficient criteria, click Search.

5. In EVV Name, click on the EVV name for which you want to view the details.

Editing Enumerated Valid Value
To edit EVV:

1. In the Tools & Settings menu, select Object Modeling > Enumerated Valid Value 
> Manage.

2. Perform a search for the EVV.

3. Select the EVV for which you want to edit the details and click Edit.

4. Enter information for the various fields.

5. Click OK.
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6. Enter the reason for the changes that you have made and click OK. You have 
edited the EVV and a confirmation message appears.

Duplicating Enumerated Valid Value
You can create a new instance of an existing EVV with the same details, but with a 
different name.

To duplicate an EVV:

1. In the Tools & Settings menu, select Object Modeling > Enumerated Valid Value 
> Manage.

2. Perform a search for the EVV.

3. In EVV Results, select the EVV that you want to duplicate and click More > Save 
As.

4. In Duplicate Enumerated Valid Values, click Clear.

5. Enter the EVV name.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated EVV without changing the associated details. You have duplicated the 
EVV and a confirmation message appears.

7. To cancel, click Cancel.

Removing Enumerated Valid Value
To remove an EVV:

1. In the Tools & Settings menu, select Object Modeling > Enumerated Valid Value 
> Manage.

2. Perform a search for the EVV.

3. In EVV Results, select the EVV that you want to remove and click Delete.

4. Enter the reason for removal and click OK. You have removed the EVV and a 
confirmation message appears.

Note: You cannot remove EVVs that are in use.

Localizing EW Value
For localization purposes, you can customize EVVs so that EVV values are displayed 
in a particular language.

To localize an EVV:

1. In your installation directory, go to the AGILE_
HOME\AgilePharma\config\locale folder.

2. Open the CFMDisplayLabels_$lang$.properties file for the language you want to 
customize.

3. Enter the Display Value of the EVV value into the file and set it equal to its 
localized value. The format should be DISPLAY_VALUE=LOCALIZED_VALUE, 
e.g. ACTIVITY_TYPE_OTHER=Other.

4. Save file.

5. In Recipe Management for Pharmaceuticals , in the Tools & Settings menu, select 
Administration > Cache > Manage.
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6. On the Manage page, select Localization Cache.

7. Click Reload Cache.

For information about how to localize other labels, see Customizing and 
Localizing Labels.

Unit Of Measure
The Unit Of Measure (UOM) defines the unit values for a measurement that is 
performed. For example, a material's density can have a unit of measure defined as 
g/ml for grams per liter. A boiling point can be represented as a unit value of Celsius, 
or "C".

Units of Measure can be added individually or can be grouped for providing a list of 
possible units defined for an attribute. UOMs can define a conversion from one unit of 
measure to another.

You can add, modify, duplicate, or remove UOMs, UOM Groups, and UOM 
Conversions.

Creating a Unit of Measure
To add new UOM:

1. In the Tools & Settings menu, select Object Modeling > UOM > New.

2. In Add Unit of Measure, enter information for the following fields:

■ Name - Enter the name of the UOM.

■ Symbol - Select the UOM symbol.

■ Description - Write a brief description of the UOM.

To specify more UOMs, enter the number of UOMs that you want to add in the 
text box next to Add Row(s) and click Add Row(s). The rows are added to the 
table. For each row, specify the details.

3. Click Finish. You have added the UOM and a confirmation message appears.

Note: You can also add new UOMs when you perform a search.

Managing Units of Measure
You can view, edit, duplicate, and remove Units of Measure.

Searching UOM
To search for UOM:

1. In the Tools & Settings menu, select Object Modeling > UOM > Manage.

2. Select a search view from the View dropdown list.

3. In the Search UOM definition area, use the dropdown menus to fill in criteria of 
the UOMs you are interested in finding.

4. When you have filled in sufficient criteria, click Search.

Viewing UOM Details
To view UOM details:
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1. In the Tools & Settings menu, select Object Modeling > UOM > Manage.

2. Perform a search for the UOM.

3. UOM Results displays a list of UOMs.

4. In Name, click on the UOM for which you want to view the details.

Editing UOM
To modify a UOM:

1. In the Tools & Settings menu, select Object Modeling > UOM > Manage.

2. Perform a search for the UOM.

3. Select the UOM for which you want to edit the details and click Edit.

4. Enter information for the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. You have 
edited the UOM and a confirmation message appears.

Duplicating UOM
You can create a new instance of an existing UOM with the same attributes, but with a 
different name.

To duplicate a UOM:

1. In the Tools & Settings menu, select Object Modeling > UOM > Manage.

2. Perform a search for the UOM.

3. UOM Results displays a list of UOMs.

4. Select the UOM that you want to duplicate and click More > Save As.

5. In Duplicate Unit of Measure, enter information for the following fields:

■ Name - Enter the name of the UOM.

■ Symbol - Select a symbol from the drop-down list.

6. Click Clear to reset the screen.

7. Click Save and Edit to add the description or click OK to save the duplicated 
UOM without changing the description. You have duplicated the UOM and a 
confirmation message appears.

Removing UOM
To remove a UOM:

1. In the Tools & Settings menu, select Object Modeling > UOM > Manage.

2. Perform a search for the UOM. UOM Results displays a list of UOMs.

3. Select the UOM that you want to remove and click Delete.

Note: You cannot remove UOMs that are in use.

4. Enter the reason for removal and click OK. You have removed the UOM and a 
confirmation message appears.
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Unit of Measure Group
A Unit of Measurement Group is a collection of one or more Units of Measurement. A 
collection of UOMs with similar characteristics can be gathered and assigned a name 
to form a UOM Group.

Creating a Unit of Measure Group
To add new UOM group:

1. In the Tools & Settings menu, select Object Modeling > UOM Group > New.

2. In the New UOM Group tab, enter information for the following fields:

■ Name - Enter the name of the UOM group.

■ Description - Write a brief description of the UOM group.

3. Click Next.

4. In the UOM Search tab, click Add to add UOMs to the group. You can change the 
display order for each UOM that you add.

5. Click Finish. You have added a new UOM group and a confirmation message 
appears.

Note: You can also add new UOM group when you perform a 
search.

Managing UOM Groups
You can search, view, edit, duplicate, and remove a UOM Group.

Searching UOM Group
To search for UOM group:

1. In the Tools & Settings menu, select Object Modeling > UOM Group > Manage.

2. Select a search view from the View dropdown list.

3. In the Search UOM Group definition area, use the dropdown menus to fill in 
criteria of the UOM Groups you are interested in finding.

4. When you have filled in sufficient criteria, click Search.

Viewing UOM Group Details
You can view the UOM details in UOM Group Details. You can view information such 
as Name, Description and a list of UOMs that belong to the group.

To view UOM group details:

In the Tools & Settings menu, select Object Modeling > UOM Group > Manage.

Perform a search for the UOM group.

UOM Group Results displays a list of UOM groups.

In Name, click on the UOM group for which you want to view the details.

Editing UOM Group
To edit UOM group details:
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1. In the Tools & Settings menu, select Object Modeling > UOM Group > Manage.

2. Perform a search for the UOM group.

UOM Group Results displays a list of UOM groups.

3. Select the UOM group for which you want to edit the details and click Edit.

4. Enter information for the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. You have 
edited the UOM group and a confirmation message appears.

Duplicating UOM Group
You can create a new instance of an existing UOM group with the same attributes, but 
with a different name.

To duplicate a UOM group:

1. In the Tools & Settings menu, select Object Modeling > UOM Group > Manage.

2. Perform a search for the UOM group.

UOM Group Results displays a list of UOM groups.

3. Select the UOM group that you want to duplicate and click More > Save As.

4. In Duplicate UOM Group, click Clear.

5. Enter the name for the new group.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated UOM group without changing the associated details. To cancel, click 
Cancel.

Removing UOM Group
To remove a UOM group:

1. In the Tools & Settings menu, select Object Modeling > UOM Group > Manage.

2. Perform a search for the UOM group.

UOM Group Results displays a list of UOM groups.

3. Select the UOM group that you want to remove and click Delete.

Note: A UOM group that is in use cannot be removed.

4. Enter the reason for removal and click OK. You have removed the UOM group 
and a confirmation message appears.

Unit of Measure Conversion
You can convert one Unit of Measure to another using a conversion factor or formula. 
A conversion formula is defined as a string expression, in which the macro 
@ORIGINAL_VALUE represents the value being converted.

You cannot specify conversion between UOMs if they are not from the same UOM 
Group.
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Adding New UOM Conversion
To create a new UOM conversion:

1. In the Tools & Settings menu, select Object Modeling > UOM Conversion > 
New.

2. In Add UOM Conversion, enter information for the following:

■ From UOM - Using the search function, select the UOM to be converted.

■ Conversion Factor - Enter the conversion factor.

■ Web Service Operation - Using the search function, select the web-service 
operation name.

3. To specify more UOM conversions, enter the number of conversions that you want 
to add in the text box next to Add Row(s) and click Add Row(s). The rows are 
added to the table. For each row, specify the details.

4. Click Finish. The confirmation message appears. You have added a new UOM 
conversion

5. To UOM - Using the search function, select the UOM to convert into.

Note: If a UOM Conversion is added with a specified Web-service 
operation, that Web-service would be invoked each time a conversion 
is required between the two UOMs. Also, a Web service-based 
conversion will not be allowed from Search screens and the UOMs 
shown in the dropdown list on the Search screen would be restricted 
to only the UOMs in the UOM Group associated with the field and 
having formula-based conversion. All UOMs having 
Web-service-based conversions will not be displayed in this 
dropdown list.

Managing UOM Conversions
You can search, edit, duplicate, and remove a UOM Conversion.

Searching UOM Conversion 
To search for UOM conversion:

1. In the Tools & Settings menu, select Object Modeling > UOM Conversion > 
Manage.

2. Select a search view from the View dropdown list.

3. In the Search UOM Conversion definition area, use the dropdown menus to fill in 
criteria of the UOM Conversions you are interested in finding.

4. When you have filled in sufficient criteria, click Search.

Editing UOM Conversion
You can only edit the UOM Conversion details.

To edit UOM conversion:

1. In the Tools & Settings menu, select Object Modeling > UOM Conversion > 
Manage.

2. Perform a search for the UOM conversion.
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UOM Conversion Results displays a list of UOM conversions.

3. Select the UOM conversion for which you want to edit the details and click Edit.

4. Enter information for the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. You have 
edited the UOM conversion details and a confirmation message appears.

Duplicating UOM Conversion 
You can create a new instance of an existing UOM conversion with the same attributes, 
but with a different name.

To duplicate a UOM conversion:

1. In the Tools & Settings menu, select Object Modeling > UOM Conversion > 
Manage.

2. Perform a search for the UOM conversion.

3. Select the UOM conversion that you want to duplicate and click More > Save As.

4. In Duplicate UOM Conversion, click Clear.

5. For From UOM Name and To UOM Name, click the icon and select the UOMs.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated UOM conversions without changing the associated details. To cancel, 
click Cancel. You have duplicated the UOM conversion and a confirmation 
message appears.

Removing UOM Conversion
To remove a UOM conversion:

1. In the Tools & Settings menu, select Object Modeling > UOM Conversion > 
Manage.

2. Perform a search for the UOM conversion.

UOM Conversion Results displays a list of UOM conversions.

3. Select the UOM conversion that you want to remove and click Delete.

4. Enter the reason for removal and click OK. You have removed the UOM 
conversion and a confirmation message appears.

Multiple Language Support in Recipe Management for Pharmaceuticals 
Recipe Management for Pharmaceuticals  is an internationalized application that 
permits companies to enter non-English label data, and allows users to see their user 
interface in their preferred language, which is set in PLM. For more information about 
how to set a user's language preference and for more details about multiple language 
support in PLM, see the Agile PLM Administrator Guide.

Recipe Management for Pharmaceuticals  supports multiple-language support for the 
following:

■ Category names

■ View names

■ View attribute names



Multiple Language Support in Recipe Management for Pharmaceuticals

8-32 Recipe Management for Pharmaceuticals Administrator Guide

■ Filter view names

■ List entry labels (Pick List Values)

The items in the previous list can be localized or simply customized to suit your 
company's needs.

Customizing and Localizing Labels
This section describes how to customize labels or localize labels. You can 
customize/localize Enumerated Valid Value values, category names, view names, 
view attribute labels, and filter names.

Unlike the PLM system, Recipe Management for Pharmaceuticals  does not store 
localized strings in the database. The localization string key is stored in the database, 
while the actual localization string, or customized string, is stored in the 
CFMCustomLabels_$lang$.properties file. To localize or customize a label, you must 
override the value set in the corresponding configuration file by setting a new value in 
the CFMCustomLabels_$lang$.properties file. For example, if you want to use a 
display value that is different from one that is defined in the CFMDisplayLabels_en_
US.properties file, you must create an entry in the CFMCustomabels_en_US.properties 
file and assign the value that you want displayed in the UI.

Note: You must choose the CFMCustomLabels properties file 
according to the chosen language preference.

You can override values that have been set in any of the following configuration files:

■ CFMCategoryLabels - contains category names

■ CFMViewLabels - contains view names

■ CFMSubviewLabels - contains filter view names

■ CFMViewAttributeLabels - contains view attribute names

■ CFMDisplayLabels - contains EVV value names

WARNING: The files in the list above should not be modified at 
any time. The only exception is the CFMDIsplayLabel file, which is 
used for localization purposes only. See Localizing EVV Value for 
more information.

To customize or localize a label:

1. In your installation directory, go to the AGILE_
HOME\AgilePharma\config\locale folder.

2. Open the CFMCustomLabels_$lang$.properties file for the appropriate language.

3. In the designated section, enter the new key/value pair that will be overriding the 
original value. The format should be KEY=CUSTOMIZED_VALUE, e.g. 
ACTIVITY_TYPE_OTHER=Other.

4. Save file.

5. In Recipe Management for Pharmaceuticals , in the Tools & Settings menu, select 
Administration > Cache > Manage.

6. On the Manage page, select Localization Cache.
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7. Click Reload Cache.
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This chapter provides details on creating and managing Applications, as well as how 
to set up and test Web Services.

Application
The administrator creates and manages the application.

Creating an Application
To create an application:

1. In the Tools & Settings menu, select Integration > Application > New.

The New Application page appears.

2. In the General tab, enter information for the following:

■ Application Name - Enter the name of the application.

■ Application User ID - Enter a unique user ID to the application.

■ Application User Password - Enter a valid password to log into the 
application.

■ Confirm Application User Password - Retype the application user password 
to confirm.

■ Inbound XSL - Enter the XSL file name to convert the incoming request to a 
CfmXML. This file should be saved in config\integration\xsl directory.

■ Outbound XSL - Enter the XSL file name to convert the outgoing request to a 
CfmXML. This file should be saved in config\integration\xsl directory.

■ Maximum Payload objects - Enter the maximum number of objects to be sent 
back in response.

3. Click Finish to create the new application.

The confirmation message appears "You have successfully added web service 
application".

Managing Application
You can search, edit, duplicate, and remove Application.

Searching Application
To search an application:
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1. In the Tools & Settings menu, select Integration > Application > Manage.

2. Select a search view from the View dropdown list.

3. In the Search Application Setup definition area, use the dropdown menus to fill in 
criteria of the applications you are interested in finding.

4. When you have filled in sufficient criteria, click Search.

Editing Application
To edit an application:

1. In the Tools & Settings menu, select Integration > Application > Manage.

2. On the Search Application Setup page, click Search.

3. Select the application name and click Edit

4. The Application: Edit screen appears. Enter information in the fields that you 
wish to make changes and Click OK.

Removing Application
To remove an application:

1. In the Tools & Settings menu, select Integration > Application > Manage.

2. The Search Application Setup page appears, click Search.

3. Select the application name and click Remove to remove the record permanently.

Duplicating Application
To duplicate an application:

1. In the Tools & Settings menu, select Integration > Application > Manage.

2. The Search Application Setup page appears, click Search.

3. Select the application name and Click Duplicate.

4. Enter the application name to be duplicated in Application Name.

5. To add a note or an attachment to the duplicate application, select Notes or 
Attachment.

6. Click Save and Edit to edit the duplicate application details. Make the necessary 
changes and Click OK.

7. Enter the reason for changes in this record and Click OK. You have successfully 
updated the application, and a confirmation message appears.

Web Service
You can create and manage a Web service.

Creating a Web Service
To create a Web Service:

1. To enter Web service values from WSDL file, on the Tools & Settings menu, select 
Integration > Web Service > New.

2. In the Preface tab, enter information for the following:
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■ Application ID: Application Name - Enter the application name

■ Web Service Values - Select From WSDL file or Manual Entry

3. If you select From WSDL file then click Browse and select the WSDL File Name.

4. Click Next.

5. In the General tab, enter information for the following fields:

■ WebService Name

■ Target Name Space

■ Target End Point Address

■ Port Name

6. In the Operation List tab, enter information for the following fields:

■ Operation Name

7. Click Next.

8. Click Finish. The confirmation page appears. You have created a new Web service.

Managing Web Service
You can search, edit, duplicate, and remove a Web Service.

Searching Web Services
To search for a Web Service:

1. In the Tools & Settings menu, select Integration > Web Service > Manage.

2. Select a search view from the View dropdown list.

3. In the Search Web Services definition area, use the dropdown menus to fill in 
criteria of the Web services you are interested in finding.

4. When you have filled in sufficient criteria, click Search.

Editing Web Service
To edit a Web Service:

1. In the Tools & Settings menu, select Integration > Web Service > Manage.

2. Perform a search.

3. Select the Web service you want to edit.

4. Click Edit. Enter information in the following fields:

■ Target End Point Address

■ Target Name Space

■ Port Name

■ WebService Name

■ Application ID

5. Click OK.

6. Enter reason for change, and click OK. The confirmation message appears. You 
have edited a Web service.
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Duplicate Web Service
To duplicate a Web Service:

1. In the Tools & Settings menu, select Integration > Web Service > Manage.

2. Perform a search.

3. Select the Web service you want to duplicate.

4. Click More > Save As. Enter information in the following fields:

■ WebService Name

■ Target Name Space

5. Click Save and Edit.

6. Click OK. The confirmation message appears. You have duplicated a Web service.

Removing Web Service
To remove a Web Service:

1. In the Tools & Settings menu, select Integration > Web Service > Manage.

2. Perform a search.

3. Results displays a list of Web service names.

4. Select the Web service name and click Delete.

Testing a Web Service
To test a Web service:

1. In the Navigation menu, select Integration > Test a Service.

2. In Web Service: Test enter information for the following fields:

■ Application - select the required option from the dropdown list

■ Service - select the required Web service option from the dropdown list

■ Operation - select the required option from the dropdown list

■ Input XML - the content of the file is displayed

■ Test XML File Name - click Browse to select the XML file name

3. Click View Test XML from File to view the content of the file.

4. Click Submit XML.

Note: The Input file must be a XML file.
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This chapter provides information on how to manage users, user groups, roles, and 
privileges.

Overview of People Management in Recipe Management for 
Pharmaceuticals 

A company has people who fulfill the responsibilities of the organization. In Agile 
PLM, people are represented by the User business object. For the Recipe & Material 
Workspace solution, users are created in Agile PLM and are assigned the PLM 
privilege Recipe & Material Workspace UI Access.

Roles that are applied within Recipe Management for Pharmaceuticals  by the 
administrator further define user access and responsibilities in the pharmaceutical 
Workspace's business environment. For example, the Equipment Manager can create 
an Equipment User Group and assign all equipment personnel to it.

Managing Users in Recipe Management for Pharmaceuticals 
Every person in the enterprise who is going to work in Recipe & Material Workspace 
must represented by a Users business object that is created by the administrator in 
Agile PLM.

Each user must be assigned the privilege mask that permits access to the Recipe 
Management for Pharmaceuticals  user interface in Web Client. For more information, 
see Accessing Recipe & Material Workspace and User Configuration. You may also 
consult the chapter on Users in Agile PLM Administrator Guide.

The rest of the information in this section assumes you are working with "User" 
business objects that have been assigned the privilege to access the Recipe 
Management for Pharmaceuticals  solution interface.

Further User Configuration within Recipe Management for Pharmaceuticals 
Each Recipe Management for Pharmaceuticals  user is identified by a unique User ID 
from Agile PLM; many other attributes of the User object were created in PLM.

Recipe & Material Workspace has additional user attributes, user roles, and 
requirements for users.

Every Recipe Management for Pharmaceuticals  user must be assigned to a 
department, a set of sites, a primary site, and roles for each site depending on their 
responsibilities.



Managing Users in Recipe Management for Pharmaceuticals

10-2 Recipe Management for Pharmaceuticals Administrator Guide

It is mandatory that you associate each Recipe Management for Pharmaceuticals  user 
to:

■ a Company;

■ a Department;

■ Sites, including a Primary Site;

■ Recipe Management for Pharmaceuticals  roles;

■ an Recipe Management for Pharmaceuticals  user must be able to view the list of 
subscription alerts.

Here are some further details about these requirements:

■ Company - the user has to belong to a company; the user can be associated with 
only one Company.

■ Department - the user belongs to only one department at any given time.

■ Site - a user can be associated with one more sites; a user can be assigned to any 
site regardless of the company that the site is associated with. Although each user 
must have a primary site, the association with additional sites is not mandatory.

■ Primary Site - one of each user's site assignments must be designated as the 
primary site. When you assign sites to a user, you must specify one of the sites as 
the primary site.

■ Role - roles control the user's access to the various functionalities in Recipe 
Management for Pharmaceuticals . A role is assigned to the user at the sites 
selected for the user. A user can have multiple roles at a site.

More aspects of user configuration within Recipe Management for Pharmaceuticals  
are provided in subsequent sections.

Searching for a User
To search for a user:

1. In the Search dropdown menu, select People > User.

2. In the Search field, enter the "*" wild-card or another value, and click the Execute 
Search button.

3. In the Results area, on the row of the user you want, click the checkbox and click 
Edit, or simply double-click the username link.

Editing User
To edit a user:

1. In the Search dropdown menu, select People > User.

2. Enter a value, and click the Execute Search button.

3. In the Results area, on the row of the user you want, click the checkbox and click 
Edit, or simply double-click the username link.

4. Enter information for the various fields. The user-object fields are listed below.

5. When you are done, click OK.

The confirmation message appears.

The two tabs on a user object are:
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■ General - displays information such as First Name, Last Name, Company Name, 
Display Name, Effective Start Date, Effective End Date and Title.

■ Details - has two subtabs: Main and Sites and Roles.

User General Tab
In the General tab, you can modify information for the following fields: Company, 
Effective End Date, Title, and Other Title.

User Details Tab
The Details tab has the following subtabs:

■ Main - to add or modify a user's address, department, and contact details.

■ Sites and Roles - to add or modify a user's site, and to assign or remove roles for 
the user.

User Details>Main Subtab
In the Main subtab, enter or modify information for the following fields:

■ Secondary Email

■ Other Email

■ Employee Type

■ Manager User ID

■ Mail Drop

■ Education

■ Address

■ City

■ State

■ Zip code

■ Country

■ Work Phone

■ Cell Phone

■ Pager

■ Fax

■ Department

User Details>Site and Roles Subtab
To add or modify a site or roles:

1. In the Sites and Roles subtab, click Add a Site and Roles.

2. In Select Site, select a site that you want to assign to the user and select the Select 
Roles tab.

3. In Select Roles, select the roles that you want to assign to the user for the selected 
site.

4. Click OK. The sites and the roles that you specified are displayed in the Site 
subtab.
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5. Select the site and role.

6. To add a site, click Add a Site and Roles.

7. To remove a site, click Delete. Enter the reason for removal and click OK. The site 
is removed.

8. To set a site as the primary site, select the site and click Set to Primary.

Setting and Unsetting Super User
A "super-user" gets all the menu rights of an administrator.

To set or unset a SuperUser:

1. In the Search dropdown menu, select People > User.

2. Find and open the user that you want to set/unset as a super-user.

3. Click More > Set SuperUser to set as a super user.

4. Click More > Unset SuperUser to unset the user as a super-user.

A confirmation message appears.

Cannot Duplicate a User
Because you cannot create a user in Recipe Management for Pharmaceuticals , you also 
cannot duplicate an existing user. This procedure must be done in Agile Java Client > 
Admin tab.

Cannot Remove a User
Just as you cannot create a user in Recipe Management for Pharmaceuticals , you also 
cannot remove an existing user. This procedure must be done in Agile Java Client > 
Admin tab.

Cannot Activate or Deactivate a User
Just as you cannot create a user in Recipe Management for Pharmaceuticals , you also 
cannot deactivate or re-activate an existing user. This procedure must be done in Agile 
Java Client > Admin tab.

Managing Roles
A role defines an authority or right to perform a task for a user. Before creating a role, 
the tasks to be performed by the role have to be identified. Hence, a Role represents a 
combination of privileges that enable or restrict the users to view or edit functionalities 
in the Scale-up Management System application.

Once a role is created, you can assign it to users. Each user can have a different set of 
role for each site in the system. Each role has a validity period.

A user assigned with a role can view only the assigned menus and perform only the 
assigned actions on the permitted attributes.

A role is defined as in use, if it is assigned to a user or site, referred in a workflow or 
alert.

For example, if a user is assigned the Role of Campaign Approver he can perform the 
task of approving or disapproving a Campaign.
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Creating a Role
To create a role:

1. In the Create New dropdown menu, select People > Role.

2. In the General tab, enter information for the following fields:

■ Role Name - Enter name of the role.

■ Role Description - Write a brief description about the role.

■ Effective Start Date - Enter the effective start date.

■ Effective End Date - Enter the effective end date.

3. Click Next.

4.  The Privileges tab has two subtabs, Actions and Attributes.

In the Actions subtab, select the kinds of business objects and other areas of action 
and permission for the new role. When you have finished, click Next.

5. In the Attributes subtab, specify the operations to be permitted for each of the 
category and object attributes - the operations are Create, Modify, and View.

Click Finish. The role is created and the confirmation message appears.

Searching for Roles
To search for a role:

1. In the Search dropdown menu, select People > Role.

2. Type in the * wild-card, then click the Execute Search button.

3. Open a role from the list of returned roles by clicking its name, or click the 
checkbox on its row and click Edit.

Editing Role
To edit a role:

1. In the Search dropdown menu, select People > Role.

2. Perform a search for the role.

3. On the returned results, select the role for which you want to edit the details. 
Various UI buttons are enabled. Click the Edit button. The role object opens.

4. Modify information for the various fields.

5. Click OK.

Duplicating a Role
You can create a new instance of an existing role with the same attributes, but with a 
different name. You can associate this new role to new users and assign new activities.

To duplicate a role:

1. In the Search dropdown menu, select People > Role.

2. Perform a search for the role.

3. Select the role for that you want to duplicate. Click the More dropdown menu and 
select Save As.
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4. Enter a new Role Name.

5. If you want to duplicate notes or attachments, click the Yes radio button for 
Duplicate All Notes or Duplicate All Attachments, respectively.

6. Click Save and Edit to change the associated details, or click OK to save the 
duplicated role without changing the associated details. To cancel, click Cancel.

Removing a Role
You can remove a role only if it is not in use. A role is "in use" in any of these cases:

■ the role is assigned to a user,

■ the role is assigned to a site, or

■ the role has been referred in a workflow or an alert.

Activities on the role can be tracked through audit trail.

To remove a role:

1. In the Search dropdown menu, select People > Role.

2. Perform a search for the role. Open the role that you want to remove.

3. Click the Delete button.

If the system detects that the role cannot be removed, it will display the reason in 
an error message.

If the role can be removed, you are prompted to enter the reason that you are 
removing the role.

4. Click OK. You have removed the role, and a confirmation message appears.

Activating and Deactivating a Role
When you activate or deactivate a role, you must enter a reason for the change, with 
the start date, end date, and time. A role can be used only if it is active.

To activate a role:

1. In the Search dropdown menu, select People > Role.

2. Perform a search for the role you want to modify. If your search returns multiple 
roles, select the role that you want to activate.

3. Click More and select Activate.

4. In the Reason for Activation dialog, enter the start date, end date, and the reason 
for activation. Click OK.

To deactivate a role:

1. In the Search dropdown menu, select People > Role.

2. Perform a search for the role you want to modify. If your search returns multiple 
roles, select the role that you want to deactivate.

3. Click More and select Deactivate.

4. In the Reason for Deactivation dialog, enter the end date and the reason for 
deactivation. Click OK.



Managing User Groups

People 10-7

Managing User Groups
A group of users form a user group. Common responsibilities are assigned to a user 
group. For example, a set of users receive a particular alert message. No other groups 
of users such as roles, macros, or existing user groups can be members of a user group. 
A user group consists of specific users only.

Creating a User Group
To create a user group:

1. In the Create New dropdown menu, select People > UserGroup.

2. In the General tab, enter information in the following fields:

■ Name

■ Description

3. Click Next.

4. In the Members tab click Add to add members.

5. Click Finish.

Note: You can add users from other user groups.

Searching User Group
To search for a user group:

1. In the Search dropdown menu, select People > User Group.

2. Enter a value, and click the Execute Search button.

3. In the Results area, on the row of the user group you want, click the checkbox and 
click Edit, or simply double-click the user group link.

Editing User Group
To edit a user group:

1. In the Search dropdown menu, select People > User Group.

2. Enter a value, and click the Execute Search button.

3. In the Results area, on the row of the user group you want, click the checkbox and 
click Edit.

4. Enter information in the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. You have 
edited a user group and a confirmation message appears.

Duplicating User Group
You can create a new instance of an existing user group with the same attributes, but 
with a different name. All the members of the existing user group are also duplicated 
in the new user group.

To duplicate a user group:
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1. In the Search dropdown menu, select People > User Group.

2. Perform a search for the user group.

3. Select the user group that you want to duplicate and click More > Save As.

4. Click Clear.

5. In Name, enter a name for the user group.

6. Select Notes and Attachment if you want to add a note or an attachment to the 
user group.

7. Click Save and Edit to change the associated details or click OK to save the 
duplicated user group without changing the associated details. To cancel, click 
Cancel.

Removing User Group
You can only remove user groups that you own and if it is not in use.

To remove a user group:

1. In the Search dropdown menu, select People > User Group.

2. Perform a search for the user group.

3. Select the user group that you want to remove and click Delete.

4. Enter the reason for removal and click OK. You have removed a user group and a 
confirmation message appears.

Managing Contacts
Contacts are persons who serve, directly or indirectly, for the organization. You can 
add external or internal contacts. An external contact does not have the access to use 
the application. An internal contact can use the application.

Creating a Contact
You can add external or internal contacts. An external contact does not have the access 
to use the application. An internal contact can use the application.

Creating an Internal Contact
To create an internal contact:

1. In the Create New dropdown menu, go to People > Contact.

2. Select Type of Contact and click Next.

3. In Select User, click the icon to specify the user that you want to add as an internal 
contact.

4. Click Next. Contact: New displays the contact details for the selected user.

5. Click Finish. You have added a new internal contact and a confirmation message 
appears.

Creating an External Contact
To create an external contact:

1. In the Create New dropdown menu, go to People > Contact.
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2. Select External as the Type of Contact and click Next.

3. In Select User, click the icon to specify the user that you want to add as an 
external contact.

4. Click Next.

5. In Contact (external), enter the information for the following fields:

■ Contact Name

■ Company Name

■ First Name

■ Last Name

■ Title

■ Email

■ Work Phone

■ Cell Phone

■ Fax

6. In Address, enter the contact address and ship to address details. If the contact 
address is the same as the shipping address, click Same as Contact Address.

7. For Shipping Address, enter information for the following fields:

■ Transportation

■ Dock

■ Floor

■ Building

■ Department

■ Address

■ City

■ State

■ Zip code

■ Country

8. Click Finish.

You have added new external contact and a confirmation message appears.

Searching Contact
To search for a contact:

1. In the Search dropdown menu, go to People > Contact.

2. Enter a value, and click the Execute Search button.

3. In the Results area, on the row of the contact you want, click the checkbox and 
click Edit, or simply double-click the contact link.

Editing Contact
To edit a contact:
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1. In the Search dropdown menu, go to People > Contact.

2. Enter a value, and click the Execute Search button.

3. In the Results area, on the row of the contact you want, click the checkbox and 
click Edit.

4. Enter information in the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. The 
confirmation message appears.

Duplicating Contact
To duplicate a contact:

1. In the Search dropdown menu, go to People > Contact.

2. Enter a value, and click the Execute Search button.

3. Select the contact for that you want to duplicate and click More >Save As.

4. In Duplicate Contact, click Clear.

5. In the Contact Name field, enter the contact name.

6. Select the Notes and Attachment checkboxes if you want to add a note or an 
attachment to the environment condition.

7. Click Save and Edit to change the associated details or click OK to save the 
duplicated environment condition without changing the associated details. To 
cancel, click Cancel.

Removing Contact
To remove a contact:

1. In the Search dropdown menu, go to People > Contact.

2. Enter a value, and click the Execute Search button.

3. Select the contact that you want to remove and click Delete.

4. Enter the reason for removal and click OK. You have removed a contact and a 
confirmation message appears.
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11Organizations

This chapter provides information about managing companies, sites, locations, 
departments, and site qualifications in Recipe Management for Pharmaceuticals .

Overview of Organization Management
The Recipe Management for Pharmaceuticals  application has four organizational 
elements, which are interdependent:

■ Company

■ Department

■ Site (and Site Qualification)

■ Location

An organization can have multiple companies. Each company can have one or more 
sites and each site may comprise of one or more locations.

A site is physical location of the company or department. A site cannot exist without 
company and company cannot be created without having a default site.

A location is a place within a site. For example: room 23, shelf A.

Company Management
A company is the first organizational element. You can have more than one company 
in an organization. One company is identified as Corporate Company, which owns the 
application. A company is associated with one or many departments, sites and 
locations.

Creating a Company
Each company has a default site that is the parent site. When you add a company, you 
have to also add the default site.

You can have more than one company with the same name. Only the company ID has 
to be unique.

To create a company:

1. In the Create New dropdown menu, select Organizations > Company.

2. In Add Company, you will see the following tabs.

■ General
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■ Corporate Site

■ Affiliates

3. In General tab, enter information for the following fields:

■ Name - Enter the name of the company.

■ Description - Enter a brief description about the company.

■ Is Manufacturer - Select Yes, if the company is a manufacturer.

■ Is Supplier - Select Yes, if the company is a supplier.

■ Company Type - Select the company type from the drop-down list.

■ Risk - Select the level of risk from the drop-down list.

4. Click Next.

5. In Corporate Site tab, enter information for the following fields:

■ Site ID - Enter the ID of the site.

■ Site Name - Enter the name of the site.

■ Site Type - Select the type of site from the drop-down list.

■ Address - Enter the address of the site.

■ City - Enter the city of the site.

■ State - Enter the state of the site.

■ Zip code - Enter the zip code of the site.

■ Country - Enter the country of the site.

6. Click Next.

7. In Affiliates tab, click Add Row(s) to enter the details of the vendors that are 
affiliated to your company. You can add more than one affiliate. To do this, enter 
the number of affiliates that you want to add in the text box next to Add Row(s) 
and click Add Row(s). The rows are added to the Affiliates pane. For each row, 
click the icon to specify the company and select the affiliate relationship from the 
Affiliate Relationship dropdown.

8. Click Finish. You have added a company and a confirmation message appears.

Note: You can also add new company when you perform a search. In 
the Results area, click Add to add a new company.

Managing Companies
You can search, edit, duplicate, and remove a company, and you can add a site to a 
company, and manage affiliates for a company.

Searching Company
To search for a company:

1. In the Search dropdown menu, select Organizations > Company.

2. In the Search field, enter the "*" wild-card or another value, and click the Execute 
Search button.
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3. In the Results area, on the row of the company you want, click the checkbox and 
click Edit, or simply double-click the company's link.

Editing Company
To edit a company:

1. In the Search dropdown menu, select Organizations > Company.

2. Perform a search for the company.

3. Select the company you want to edit and click Edit.

4. Enter information for the various fields

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. You have 
edited company details and a confirmation message appears.

Duplicating Company
You can create a new instance of an existing company with the same attributes, but 
with a different name.

To duplicate a company:

1. In the Search dropdown menu, select Organizations > Company.

2. Perform a search for the company.

Select the company that you want to duplicate and click More > Save As.

3. In the Duplicate Company tab, click Clear.

4. Enter the company name and the site name.

5. Select Notes and Attachments to specify if you want to add notes and 
attachments.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated role without changing the associated details.

To cancel, click Cancel.

Adding Site from Company
To add a site for a company:

1. In the Search dropdown menu, select Organizations > Company.

2. Perform a search for the company.

3. Select the company for which you want to add a site.

4. Click More and select Add Site.

Managing Affiliates
You can enter the details of the vendors that are affiliated to your company. You can 
also add a new company and enter the relationship status of this vendor with your 
company. To add affiliates to a company, the affiliates must already exist in the system. 
If not, you must create a company and then proceed to add it as an affiliate.

To manage affiliates:

1. In the Search dropdown menu, select Organizations > Company.
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2. Perform a search for the company.

3. Select the company for which you want to manage the affiliates.

4. Click More and select Manage Affiliates.

5. Click New to add an affiliate.

6. In Affiliates, click the look up icon to specify a company as an affiliate.

7. Select the affiliate relationship.

You can add more than one affiliate. To do this, enter the number of affiliates that 
you want to add in the text box next to Add Row(s) and click Add Row(s). The 
rows are added to the Affiliates pane. For each row, click the icon to specify the 
company and select the affiliate relationship.

8. Click OK.

Site Management
A site is the physical location for a company. A company can have many sites. Sites 
can have associations with other sites leading to a parent-child relationship. The site 
name must be unique.

There can be many types of sites such as Enterprise, Area, Process Cell, Unit, 
Equipment Module, Control Module, Subsidiary, Headquarter, Plant Site, Floor, 
Building, Lab, Containment Lab, Module, Warehouse and so on.

Sites that have privileges assigned to it are called Privileged sites. While assigning 
privileges, the user should only select roles for a parent privilege site and not its 
children. The roles selected for the parent is automatically applied to all its children 
privilege sites.

Site(s) are mandatory and need to be created while setting up a company.

Sites can be classified depending on its use as:

■ Manufacturing - an area where the actual process of creating an API or 
Intermediate is conducted.

■ Storage - define whether the lots stored needs be tracked and stored at a container 
level.

■ Equipment Storage Area - stores equipment such as dryers, reactors, scales and so 
on.

■ Material Storage Area - stores materials.

You can also define whether the Site should follow Clinical Supply (Good 
Manufacturing Practice).

Creating a Site
To add a site, you must first identify a company to which the new site is to be 
associated. The parent site associated with the company becomes the parent site for 
this new site.

In addition to specifying the basic site details, you can associate storage types, 
equipment category and material types with the site. You can do this only if the 
following conditions are true:

If you select the site as Storage Area, then you can enter the details for the storage area.
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If you select the site as Equipment Storage Area or Material Storage Area, then select 
the appropriate equipment category or the type of material.

To create a site:

1. In the Create New dropdown menu, select Organizations > Site.

2. In the Preface tab, select the parent site to associate this new site.

3. Click Next.

4. In the General tab, enter information for the following fields:

■ Site ID - Enter the site ID.

■ Site Name - Enter the name of the site.

■ Description - Write a brief description about the site.

■ Site Type - Select the type of site.

■ Manufacturing Area - Select Yes, if the site is a manufacturing area.

■ Operating Mode - Select the operating mode from the drop-down list.

■ Environmental Condition - Select the environmental condition from the 
drop-down list.

■ Has Privilege - Select Yes, if the site has privilege.

■ Is Storage Area - Select Yes, if the site is a storage area.

5. Select Is Storage Area to enable the following:

■ Secured - Select Yes, if the storage area is secured.

■ Quarantine - Select Yes, if the storage area is quarantined.

■ Contains Equipment - Select Yes, if the storage area contains equipment. This 
selection is a one-time decision and cannot be modified when editing site 
details

■ Contains Material - Select Yes, if the storage area contains material. This 
selection is a one-time decision and cannot be modified when editing site 
details

■ Container Tracking - Select Yes, if the storage area has container tracking.

6. Select Container Tracking based on the following decisions:

■ Select, if you want to track individual containers received in a lot.

■ Do not select, if you want to track only the lot and not the individual 
containers present in that lot.

Note: This selection is a one-time decision and cannot be modified 
when editing site details. Recipe Management for Pharmaceuticals  
does not recognize those containers that were treated as one lot 
without container tracking selected, when the lot was received at a 
site.

7. Click Next.

8. In the Details tab, enter information for the following fields:

■ Address
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■ City

■ State

■ Zip code

■ Country

■ If the address is same as the parent site, then select Same as Parent.

9. Click Finish. You have added new site and a confirmation message appears.

Managing Sites
You can search, edit, duplicate, and remove sites.

Searching Site
To search for a site:

1. In the Search dropdown menu, select Organizations > Site.

2. In the Search field, enter the "*" wild-card or a known name, and click the Execute 
Search button.

3. In the Results area, on the row of the site you want, click in the checkbox and 
perform required action.

Editing Site
To edit a site:

1. In the Search dropdown menu, select Organizations > Site.

2. Perform a search for the site.

3. Select the site you want to edit and click Edit.

4. Enter information for the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. You have 
edited site details and a confirmation message appears.

Duplicating Site
You can create a new instance of an existing site with a different name. If you duplicate 
a parent site, the children sites are not duplicated.

To duplicate a site:

1. In the Search dropdown menu, select Organizations > Site.

2. Perform a search for the site.

3. Select the site that you want to duplicate and click More > Save As.

4. Specify the Parent Site ID, Site ID, and the Name for the site.

5. Select Notes and Attachments to specify if you want to add notes and 
attachments.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated site without changing the associated details. To cancel, click Cancel.

You can also duplicate a site from the Browse tab.
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Removing Site
You can remove a site only if it is not in use and is not associated with users, locations, 
alerts, or workflows. You can not remove a parent site which is associated with a child 
site.

To remove a site:

1. In the Search dropdown menu, select Organizations > Site.

2. Perform a search for the site.

3. Select the site that you want to remove.

4. Click Delete. The site is removed.

Note: You can also remove a site from the Browse tab.

Moving Site
To move the site to a new location or new parent site:

1. In the Search dropdown menu, select Organizations > Site > Manage.

2. Perform a search for the site.

3. Select the site that you want to move.

4. Click More > Move.

5. Select where you want to move the site and click OK. The site is moved.

Note: You can also move a site from the Browse tab.

Location Management
Location is the actual physical location of a material or equipment within a site.

For example, at a warehouse site called Floor 7, Material X is stored at Bay 4, Row 5, 
and Column 6.

Every Location has a unique ID. The name of the location need not be unique.

A location belongs to only one site. You cannot move it from one site to another.

Creating a Location
To create a location:

1. In the Create New dropdown menu, select Organizations > Location.

2. In the Select Site tab, select the site to which you want to associate the location.

3. Click Next.

4. In the Add Locations tab, click on Add Row(s).

5. Enter the following information:

■ Location ID - Enter the location ID.

■ Name - Enter the location name.

■ Description - Write a brief description about the location.
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■ Bay - Enter the bay in which the location is present.

■ Row - Enter the row in which the location is present.

■ Stack - Enter the stack in which the location is present.

■  Height - Enter the height of the location.

■ Column - Enter the column of the location.

■ Is Available - Select the checkbox if the location is available.

Note: You can add more than one location. To do this, enter the 
number of locations that you want to add in the text box next to Add 
Row(s) and click Add Row(s). The rows are added to the Add 
Locations tab. For each row, enter the location details.

6. Click Finish. The confirmation message appears.

Managing Locations
You can view details, edit details, duplicate, and remove locations.

Searching Location
To search for a location:

1. In the Search dropdown menu, select Organizations > Location.

2. In the Search field, enter the "*" wild-card or another value, and click the Execute 
Search button.

3. In the Results area, on the row of the location you want, click the checkbox and 
click Edit, or simply double-click the location's link.

Editing Location
To edit a location:

1. In the Search dropdown menu, select Organizations > Location.

2. Perform a search for the location.

3. Select the location for which you want to edit and click Edit.

4. Enter information for the various fields.

5. Click OK.

6. Enter the reason for the changes that you have made and click OK. You have 
edited a location and a confirmation message appears.

Duplicating Location
You can create a new instance of an existing location with the same attributes, but with 
a different name.

To duplicate a location:

1. In the Search dropdown menu, select Organizations > Location.

2. Perform a search for the location.

3. Select the location that you want to duplicate and click More > Save As.
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4. In the Duplicate Location tab, click Clear.

5. Enter the Location ID.

6. Click Save and Edit to change the associated details or click OK to save the 
duplicated location without changing the associated details.

To cancel, click Cancel.

Removing Location
To remove a location:

1. In the Search dropdown menu, select Organizations > Location.

2. Perform a search for the location.

3. Select the location that you want to remove and click Delete.

4. Enter the reason for removal and click OK. The location is removed.

Department Management
A company can have many departments. Every department belongs to a parent 
department. A department can be assigned to many users, but a user cannot have 
access to more than one department.

To add a department you must associate it with the parent department. If you do not, 
then the department is associated with the default department.

Creating a Department
To create a department:

1. In the Create New dropdown menu, select Organizations > Department.

2. In Department: New, under the General tab, enter information for the following 
fields:

■ Parent Department ID - Enter the parent department ID.

■ Department ID - Enter the department ID.

■ Name - Enter the name of the department.

■ Description - Write a brief description about the department.

3. Click Finish. You have added a new department and a confirmation message 
appears.

Managing Departments
You can search, edit, duplicate, move, and remove departments.

Searching Department
To search for a department:

1. In the Search dropdown menu, select Organizations > Department.

2. In the Search field, enter the "*" wild-card or another value, and click the Execute 
Search button.

3. In the Results area, on the row of the department you want, click the checkbox and 
click Edit, or simply double-click the department's link.
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Editing Department
You can create a new instance of an existing department with a different name and ID. 
If you duplicate a parent department, the children departments are not duplicated.

To duplicate a department:

1. In the Search dropdown menu, select Organizations > Department > Manage.

2. Perform a search for the department.

3. Select the department that you want to duplicate and click Duplicate.

4. In Duplicate Department click Clear.

5. Enter the Department ID and the Name.

6. Select Notes and Attachments to specify if you want to add notes and 
attachments.

7. Click Save and Edit to change the associated details, or click OK to save the 
duplicated department without changing the associated details. You have 
duplicated the department and a confirmation message appears.

To cancel, click Cancel.

Duplicating Department
You can create a new instance of an existing department with a different name and ID. 
If you duplicate a parent department, the children departments are not duplicated.

To duplicate a department:

1. In the Search dropdown menu, select Organizations > Department.

2. Perform a search for the department.

3. Select the department that you want to duplicate and click More > Save As.

4. In the Duplicate Department tab, click Clear.

5. Enter the department ID and the name.

6. Select Notes and Attachments to specify if you want to add notes and 
attachments.

7. Click Save and Edit to change the associated details, or click OK to save the 
duplicated department without changing the associated details. You have 
duplicated the department and a confirmation message appears.

To cancel, click Cancel.

Moving Department
To move the department:

1. In the Search dropdown menu, select Organizations > Department.

2. Click the Browse tab.

3. Select the department that you want to move and click Move.

4. Select where you want to move to and click OK.

5. Enter the reason for the change and click OK. You have moved the department 
and a confirmation message appears.
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Removing Department
You can remove a department only if it is not in use and is not associated with users or 
sites. If you remove a parent department, all associated children department are also 
removed.

To remove a department:

1. In the Search dropdown menu, select Organizations > Department > Manage.

2. Perform a search for the department.

Results displays a list of departments.

3. Select the department that you want to remove and click Delete.

4. Enter the reason for removal and click OK. You have removed the department and 
a confirmation message appears.

Site Qualification Management
The following sections describe how to manage a site qualification.

Creating a Site Qualification
You can add site qualification for a material designation category or for a specific 
material.

To create a site qualification:

1. In the Create New dropdown menu, select Organizations > Site Qualification.

2. In the General tab, select the Date of Review and Qualification Ends On date.

3. Select the type of audit. The options are Questionnaire and Onsite Audit.

4. Select the Qualified For option. The default is Material Type.

5. Click Next.

6. Select either Add > Site or Add >Site plus Children.

■ The Site option allows you to add a single site.

■ The Site plus Children option adds a site, as well as any child sites it has.

7. Select the site that you want to add and click OK.

8. Click Next. The Details tab has three subtabs:

■ Material

■ Audit

■ Questionnaire

9. If you have selected the Qualified For option as Material Type, then in the 
Material subtab, select any or all of the following options:

■ Qualified for API - Select Yes, if the material is qualified for API.

■ Qualified for API Start Custom - Select Yes, if the material is qualified for API 
start custom.

■ Qualified for API Start Commercial - Select Yes, if the material is qualified for 
API start commercial.
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■ Qualified for Intermediate - Select Yes, if the material is qualified for 
intermediate.

■ Qualified for Raw for API Starting Material - Select Yes, if the material is 
qualified for raw API starting material.

■ Qualified for Raw Material - Select Yes, if the material is qualified for raw 
material.

10. Click Next.

11. If you have selected the Qualified For option as Material Specific, then in the 
Audit subtab, enter the following details:

■ Date Scheduled - Enter the date scheduled.

■ Date of Onsite Audit - Enter the date of onsite audit.

■ Audit Site - Enter the package site.

■ Audit Package Exists? - Select Yes, if the qualification package is attached.

12. Click Next.

13. In the Questionnaire subtab, enter information for the following:

■ Date Sent- Enter the date the material was sent.

■ Date Received - Enter the date the material is received

■ Questionnaire Package Location Site ID - Enter the package site name.

■ Qualification Package Exists? - Select Yes, if qualification package is attached.

14. Click Finish. You have added a new site qualification and a confirmation message 
appears.

Managing Site Qualifications
To manage site qualifications:

1. In the Search dropdown menu, select Organizations > Site Qualification.

2. Perform a search for the site that requires qualification.

3. Open the site for which you want to add qualification. 

4. Click More and select Manage Qualification. Results displays the qualifications 
for the site. In this pane, you can add, edit, remove and qualify the site 
qualification for a site.

Searching Site Qualification
To search for a site qualification:

1. In the Search dropdown menu, select Organizations > Site Qualification.

2. In the Search field, enter the "*" wild-card or another value, and click the Execute 
Search button.

3. In the Results area, on the row of the site qualification you want, click the 
checkbox and click Edit, or simply double-click the site qualification's link.

Editing Site Qualification
To edit a site qualification:

1. In the Search dropdown menu, select Organizations > Site Qualification.
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2. Perform a search for the site qualification you want to edit.

3. In Results, select the site qualification you want and click Edit.

4. Modify the properties, and click OK.

5. Enter the reason for the changes that you have made and click OK. The site 
qualification is updated.

Removing Qualification
To remove a site qualification:

1. In the Search dropdown menu, select Organizations > Site Qualification.

2. Perform a search for the site qualification you want to remove.

3. n Results, select the site qualification that you want to remove and click Delete.

4. Click OK.

5. Enter the reason for the removal and click OK. The site qualification is removed.
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12General Administration

This chapter provides information about managing log files and other general 
administration tasks.

Manage Log Files
As part of general administration and maintenance of R&M Workspace, ensure that 
backup for the following log files are done periodically:

■ The <servername>.log file is located in <AGILE_
HOME>\domain\servers\<servername>\logs.

■ The nohup.out file in the <CFM_HOME> directory.

■ All log files in the <CFM_HOME>/logs directory.

■ All log files in the <CFM_HOME>/bin directory.

These files are useful in reporting issues to Oracle support for troubleshooting.

Default Log Files
In the production environment, when a log file reaches a specified size, the system 
automatically closes it and creates a new one. Only the latest seven are retained by the 
system. Files earlier than the latest seven are regularly deleted by the system. It is 
therefore advised that you maintain a backup of twenty log files.

Rotate Log Files
Log file rotation ensures that log files do not grow indefinitely. It allows you to keep an 
efficient and useful amount of data, without using up too much disk space. You can 
choose to rotate log files at specific time intervals or when the current log file reaches a 
specific size.

To set up log file rotation:

1. Log on to the WebLogic server console.

2. Click the Lock & Edit button in the Tools & Settings tree/options.

3. In the left pane, expand Environment and select Servers.

4. In the Servers table, click the name of the server instance whose log files you want 
to configure for rotation.

5. Select Logging > General.
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6. To move old messages to another file when the current log file reaches a specific 
size:

a. In the Rotation Type list box, choose By Size.

b. In the Rotation File Size field, enter the file size that triggers the server to move 
log messages to a separate file. After the log file reaches the specified size, the next 
time the server checks the file size, it will rename the current log file. After the 
server renames the file, subsequent messages accumulate in a new file named 
filename.log.

c. If you want to limit the number of log files that the server creates to store old log 
messages, select the Limit Number of Retained Files check box. Then in the Files 
to Retain field, enter the maximum number of files. If the server receives 
additional log messages after reaching the capacity of the last log file, it overwrites 
the oldest log file.

7. If you want to move old messages to another file at specific time intervals:

a. In the Rotation Type list box, choose By Time.

b. In the Begin Rotation Time field, enter the start time.

c. Use the following format: hh:mm, where hh is the hour in a 24-hour format and 
mm is the minute. At the time that you specify, the server rotates the current log 
file. If the time that you specify is already past, the server starts its file rotation 
immediately. Thereafter, the server rotates the log file at an interval that you 
specify in Rotation Interval.

d. In the Rotation Interval field, enter the interval at which the server saves old 
messages to another file.

e. If you want to limit the number of log files that the server creates to store old log 
messages, select the Limit Number of Retained Log Files check box. Then in the 
Files to Retain field, enter the maximum number of files. If the server receives 
additional log messages after reaching the capacity of the last log file, it overwrites 
the oldest log file.

8. In the Log File Rotation Directory field, enter the directory location where the 
rotated log files will be stored. Enter an absolute pathname or a pathname that is 
relative to the server's root directory. By default, the rotated files are stored in the 
same directory where the log file is stored.

9. To include a time and date stamp in the file name when the log file is rotated, in 
the File Name field, add java.text.SimpleDateFormat variables to the file name 
and surround each variable with percentage (%) characters.

For example, if you enter the following value in the File Name field:

myserver_%yyyy%_%MM%_%dd%_%hh%_%mm%.log, the server's log file will 
be named:

myserver_yyyy_MM_dd_hh_mm.log.

When the server instance rotates the log file, the rotated file name contains the 
date stamp. For example, if the server instance rotates its local log file on 4 March, 
2008 at 10:15 AM, the log file that contains the old log messages will be named: 
myserver_2005_03_08_10_15.log.

If you do not include a time and date stamp, the rotated log files are numbered in 
order of creation filename, where filename is the name configured for the log file. 
For example: myserver.log00007.
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10. To activate these changes, in the Change Center of the Administration Console, 
click Activate Changes.

Not all changes take effect immediately-some require a restart.

Manage Batch Size for Results Screens
The number of rows that appear in the results screens in the application can be 
configured. The batch sizes provided are 5, 10, 20, 30, 50, and 1000. If you require a 
specific number, edit the Enumerated Valid Value named "RowsPerPage".

To change the number of rows displayed in search results:

1. Navigate to Tools & Settings > Object Modeling > Enumerated Valid Value > 
Manage.

2. In the EVV Name field, type the value RowsPerPage.

3. Click Search.

4. Select the RowsPerPage row, and click Edit.

5. In the Details tab, edit the values as desired, and click OK.

A confirmation message displays when the new values are saved.

Troubleshooting
If the application system response becomes slow, check the following:

■ Check CPU usage and memory usage of the process at that point in time (in case 
of UNIX systems use the following commands: prstat and memstat, and mpstat.

■ Using the application server console, check queue length and memory utilization 
in the performance monitoring tab.

■ Check the CPU usage and memory usage of the database process (Oracle 
processes) at the same time on the database server.

■ Check the network to see if the connectivity between the application server, the 
database and the Web server is established.



Troubleshooting

12-4 Recipe Management for Pharmaceuticals Administrator Guide



A

Configuration Files A-1

AConfiguration Files

Configuration information of the Recipe Management for Pharmaceuticals  
application, such as authentication type, audit trail enabling/disabling, the list of 
resource files and so on, is stored in a set of configuration files. These files can be used 
to change the initial settings in the Recipe Management for Pharmaceuticals  
application. The following sections briefly describe the parameters contained in some 
of these configuration files.

CFMConfig.xm
The CFMConfig.xml file is the main configuration file, which acts as the controller for 
Recipe Management for Pharmaceuticals . This file contains:

Properties to control all the major components of the application such as Audit 
Service, Logger Service, Alerts Engine, Workflow Engine, Timer Engine, and so on.

Relative location and names of other configuration files used in Recipe Management 
for Pharmaceuticals .

The following table lists and describes the attributes maintained in the 
CFMConfig.xml file.

Attribute Default Value Description

CFMAppServerInfo

CFMApplicationServ
erName

CFMApplicationServ
erVersion

No default values This section contains information about J2EE 
Appserver configuration, on which the 
application is deployed.

CFMInitialContextFa
ctory

weblogic.jndi. 
WLInitialContext 
Factory

This tag specifies the JNDI initial context 
factory used for all the lookups on the JNDI 
Tree of the J2EE Server by the R&M 
Workspace application. It is recommended 
not to modify this property.

CFMProviderURL Values specified 
during installation.

This tag specifies the J2EE Server JNDI URL 
used for lookup of JNDI Objects, on the JNDI 
tree. The Recipe Management for 
Pharmaceuticals  installer sets the correct 
host and port number. If the port number of 
the J2EE Server domain is modified after 
installation, only then this property must be 
modified.

CFMPrincipalUser WebLogic This tag specifies the user ID for logging into 
the J2EE Appserver.
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CFMPrincipalUserP
wd

VvFM5XvM5jLDvuv
z0JROHxcP5WMpoC

By default, the installer inserts the 
application server password in this tag after 
encryption. If the application server 
password is changed for any reason after 
Recipe Management for Pharmaceuticals  
installation, this value should be changed 
manually, using the password encryption 
utility.

CFMTransactionURL This Cell is Blank This is an application server specific 
property. This denotes the transaction 
provider for Audit Trail in Recipe 
Management for Pharmaceuticals .

A typical values is 
'javax.transaction.TransactionManager' for 
Oracle Weblogic. Ideally, this property 
should not be modified by the end user

CFMAdminEmail This Cell is Blank A workflow notification is triggered to be 
sent to a role or a user group needs to be 
notified as per the Workflow Definition. 
While the role or the usergroup is being 
resolved, when R&M Workspace application 
detects Inactive Users in the role or the user 
group, the workflow engine instead of 
sending the email notifications to the inactive 
users, sends it to the email ID captured in the 
tag <CFMAdminEmail>

A workflow notification is triggered to be 
sent to a role or a user group needs to be 
notified as per the Workflow Definition. In 
case of workflow delegate feature, if User A 
delegates his/her Workflow task to User B 
and User B in turn delegates his/her 
workflow tasks back to User A, then this 
situation results in a cyclic dependency. In 
such a situation, R&M Workspace detects 
such cyclic dependencies and instead assigns 
the workflow notification to the email ID 
specified in the tag <CFMAdminEmail>

CFMCacheResetAtSt
art

False This property controls the starting value of 
Autosequence IDs which the system 
generates for all objects for which 
autosequenced IDs are applicable. If this 
property is set to false, then the application 
will use the last sequence ID in the last used 
autosequence ID bucket as the starting point 
the next time the application server is 
started. If this is set to True, then the 
application will calculate the exact value of 
the last used sequence ID and then use this 
as the starting point. This does involve a 
performance cost, but ensures that 
autosequence ranges are used optimally. By 
default, this is set to True.

Attribute Default Value Description
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CFMLoadCacheBefor
eServerStartup

True This denotes whether the application server 
must be started only after Recipe 
Management for Pharmaceuticals 's cache 
has been loaded. If this is set to False, the 
user will be able to access the application 
even before cache has been loaded. Cached 
data will be loaded during the first login if 
this was not already done during startup. 
This property is set to True by default.

CFMAuthenticationI
nfo

This Cell is Blank This section has information about the 
various authentication mechanisms used in 
the system. There are three modes of 
authentication, namely, Local, LDAP, and 
SSO Authentication.

CFMRemoteLogin FALSE This tag specifies the authentication 
mechanism is local or a remote login. If this 
flag is set to True, it enables the application 
to connect to the external authentication 
modules, defined in CFMRemoteServer 
property. If this flag is set to False, the 
application uses the default local 
authentication mechanism (database 
authentication.)

CFMRemoteServer LDAP This tag specifies the server type for remote 
authentication. The possible values are 
LDAP and WS. If WS is selected as the 
authentication mode, the authentication Web 
service must be setup properly. Note: 
Typically, the Web service is used for SSO 
authentication mechanisms.

If LDAP is selected as the authentication 
mode, LDAP configuration information must 
have the URL and other information set 
correctly.

AuthenticationPassw
ordLinks

This Cell is Blank This section has information about managing 
passwords for users at the time of logging 
into the application. Based on the remote 
server supporting the password links, these 
flags can be used to decide if the links must 
be shown on the User Interface.

CFMShowPassword
ResetLink

FALSE This tag indicates if you have to show the 
Reset Password link on the Login page in the 
application. Possible values are TRUE or 
FALSE. This is applicable if the RemoteLogin 
tag is set to True.

CFMShowPassword
ChangeLink

TRUE This tag indicates if you have to show the 
Change Password link on the Login page in 
the application. Possible values are TRUE or 
FALSE. This is applicable if the RemoteLogin 
tag is set to True.

CFMLDAPAuthentic
ation

This Cell is Blank This section has information about the LDAP 
configuration and LDAP server.

CFMLDAPInitialCon
textFactory

com.sun.jndi.ldap.Ld
apCtxFactory

This tag specifies the LDAP initial context 
factory class implementation. This value is 
used by the authentication module. It is 
recommended not to modify this value.

Attribute Default Value Description
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CFMLDAPProviderU
RL

ldap://LDAP_
Server_
Hostname:Port

This tag specifies the LDAP server URL in 
the ldap://hostname:port format.

CFMLDAPSearchBas
e

ou=?,o=?,dc=? This tag specifies the LDAP user search 
string. This is the base search string 
appended to the username, provided by the 
user for authentication, on the application 
UI.

CFMLDAPSecurityPr
incipal

,ou=?,o=?,dc=? The search string must specify a valid LDAP 
user used for searching the LDAP directory, 
while importing users into the application.

CFMLDAPSecurityC
redentials

This Cell is Blank This tag specifies the security credentials 
(password) for the Security Principal.

CFMLDAPSecurityA
uthentication

Simple This tag specifies the authentication type 
used for the application login to LDAP 
server.

CFMLDAPViewNam
e

PCM_VIEW_ USER_
LDAP_SSO

This tag specifies the view used for LDAP 
user search. This view maps the LDAP user 
properties to the attributes in the user 
Category, so that the related data such as 
name, address, and so on can be copied from 
the LDAP directory to the application 
database. The view attribute labels must 
match the LDAP property for the data to be 
copied correctly.

CFMEmailInfo This Cell is Blank This section has information about the email 
server configured for the application. This 
information is used to send emails from the 
application.

CFMEmailHost mailhost This tag specifies the IP address of the email 
server.

CFMEmailPort 25 This tag specifies the Port number of the 
email server.

CFMEmailProtocol SMTP This tag specifies the protocol type used to 
send emails. It is recommended not to 
modify the type.

CFMEmailDefaultPri
ority

High This tag specifies the email priority sent by 
the application. This priority is set on all 
emails sent from the application. The valid 
values are highest, high, normal, low, and 
lowest.

CFMEmailAttachme
ntSize

1MB This tag specifies the maximum attachment 
size allowed during email dispatch. 
Typically, this is limited by the email server.

CFMLoggerInfo This Cell is Blank This section has information about the 
CFMLogger configuration properties. It 
controls the logs that are generated in the 
system including their location and file 
names.

CFMLoggerFactoryCl
ass

This Cell is Blank This refers to the factory class which 
provides logger instances. 
CFMJDKLoggerFactory is the standard 
factory class.

Attribute Default Value Description
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CFMDefaultLogDirec
tory

Logs This tag specifies the relative directory where 
the log files are stored. The path of the 
directory is relative to the CFM_HOME 
location.

CFMDefaultLogFile CFMDebug This tag specifies the default log file name 
where all the debug messages are stored. 
This file is created in the logs directory.

CFMSQLLogFile CFMSql This tag specifies the log file name where 
SQL logs are appended. This file is created in 
the logs directory.

CFMErrorLogFile CFMError This tag specifies the log file name where 
Error logs are appended. This file is created 
in the logs directory.

CFMAccessTimeLog
File

CFMAccessTime This tag specifies the log file name where 
Access logs are appended. This file is created 
in the logs directory.

CFMLogPropertyFile CFMLogger. 
properties

This tag specifies the Logger properties used 
by the logger service in the application. This 
configuration file is located in the <CFM_
HOME>/config folder.

CFMMaxLogFileSize 1048576 This tag specifies the maximum log file size. 
Once the file size exceeds the maximum 
limit, the logs are created in new file. A 
backup file is created for the existing file.

CFMMaxAllowedFile
s

7 This tag specifies the maximum number of 
backup files that are created, after which the 
log files are over-written. This value must be 
modified to an appropriate number.

CFMLogMessageFor
matWithSession

{0} | {2} | {4} | {5} | 
{7}{6}

This is the format in which logs are written 
in the log file. The log format can be 
configured based on the available parameters 
for logging.

CFMLogMessageFor
matWithoutSession

{0} | {5} | {7}{6} This is the format in which the logs are 
written before the user has logged in. All 
session related parameters are not available 
during login.

CFMLogAccessTime
Format

This Cell is Blank The time format that is used to represent the 
information pertaining to application login 
access.

CFMLogDateTimeFo
rmat

MM/dd/yyyy 
hh:mm:ss a

This tag specifies the date format used for 
logging the time when the log was created. 
This must be a valid Java date format.

CFMConfigFileInfo This Cell is Blank This section has information about the 
various configuration files used by the 
Persistence layer in the application

CFMSQLQueryFile CFMSqlQuery.xml This tag specifies the SQLQuery 
configuration file location that has the 
canned queries for loading or saving data in 
the metamodel tables. This file is located in 
the <CFM_HOME>/config directory. It is 
recommended not to modify this tag value.

CFMDBConfigFile CFMDBConfig. xml This tag specifies the Data Source connection 
information file name. This file is located in 
the <CFM_HOME>/config directory.

Attribute Default Value Description
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CFMLocaleInfo> This Cell is Blank This section has information about the Locale 
configuration properties, used to load 
resource files. If the values are modified in 
this section, then the corresponding locale 
files must be present.

CFMDefaultLocaleLa
nguage

En This tag specifies the default locale language 
code.

CFMDefaultLocaleCo
untry

US This tag specifies the default locale country 
code.

CFMLocaleRelativeD
ir

config/locale This tag specifies the locale file path. This is 
relative to CFM_HOME.

CFMResourcesLocati
on

CFMResources. xml This tag specifies the resources file name. 
This file is located in the <CFM_
HOME>/config directory.

CFMReportInfo This Cell is Blank This section has information about Reports 
configuration Properties.

CFMReportXMLDire
ctory

config This tag specifies the report configuration file 
repository. This is relative to <CFM_HOME> 
directory.

CFMReportFileDirect
ory

Reports This tag specifies the output directory for 
reports. This is relative to CFM_HOME> 
directory.

CFMReportTemplate CFMReport.jrxml This tag specifies the Template file name 
used for Exporting data in HTML, Excel, or 
PDF formats.

CFMAlerts This Cell is Blank This section has information about the Alert 
Engine configuration properties used in the 
application.

AlertEngineEnabled TRUE This tag indicates if the Alert Engine must be 
enabled for processing various alerts in the 
application. This value must not be modified, 
unless all alerts are disabled from the system. 
If the value is set to False, Email and 
Dashboard Alert Notification features does 
not work.

AlertFromEmailAddr
ess

This Cell is Blank This tag specifies the From Address for 
emails sent for alerts configured with Email.

CFMWebInfo This Cell is Blank This section has information about the 
various configuration properties for the 
application.

CFMWebConfigFile CFMWebConfig. xml This tag specifies the name of the application 
presentation layer configuration file. This file 
is located in the <CFM_HOME>/config 
directory.

CFMAuditTrailInfo This Cell is Blank This section has information about the Audit 
Trail Engine configuration properties.

CFMEnableAudittrail TRUE This tag indicates if the audit trail feature is 
enabled for the application. If the tag is set to 
True, changes to the objects in the application 
is audited.

Attribute Default Value Description
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PreferredAuditTimeZ
one

GMT This tag specifies the time zone in which all 
audit related data timestamps are stored in 
the database. Valid values include PST, EST, 
IST, and so on. This value is equal to the 
value returned by the Java API 
TimeZone.getID() method.

LogHardDeleteHistor
y

TRUE When this property is set to True, the 
application will log information about all 
hard delete operations performed at any 
point of time.

ShowRFCPopup FALSE RFC is the 'Reason For Change' popup 
screen. This screen requires the user to enter 
a concise account of why a given business 
object is being changed from its prior state. 
By default, the RFC popup screen will not be 
displayed.

CFMApplication This Cell is Blank This section has information for the 
Integration Framework used in the 
application.

CFMApplicationId Recipe Management 
for Pharmaceuticals 

This tag specifies the application ID for the 
Integration Framework. This value is internal 
to the application. It is recommended not to 
modify this value.

RetryPoller This Cell is Blank This section contains properties related to 
retry polling for failed messages.

RetrySleepInterval 10000 This property determines the time interval 
based on which failed messages for Alerts 
will be queued and attempted again.

Timer This Cell is Blank This section has information about the Timer 
Engine configuration information for the 
application. It is recommended not to modify 
the tags.

EnableScheduler TRUE This tag indicates if the Timer Engine for the 
application must be enabled or disabled. It is 
recommended not to modify the value.

CreateWorkFlowTask
Timer

TRUE This tag indicates if the Timer is disabled for 
the Workflow Module in the application. It is 
recommended not to modify this value.

CFMDaemon This Cell is Blank This section has information about the 
Daemon that runs within the application. 
The Daemon performs certain updates 
periodically based on the intervals specified 
within the section.

ResetDaemonTrigger
sAtFirstLogin

TRUE Daemon threads monitor application state 
and perform background tasks. Enabling this 
flag will reset the state of all daemon threads 
during application startup.

RefreshObjectCount
HourlyPeriodicity

24 This tag specifies the number of hours after 
which the Daemon refreshes the object count 
for every Category in the application, for the 
current day.

ExpireQualifications
HourlyPeriodicity

24 This tag specifies the number of hours after 
which the Daemon marks the Equipment 
Qualifications that has expired in the 
database for the current day.

Attribute Default Value Description
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ExpireLotHourlyPeri
odicity

24 This tag specifies the number of hours after 
which the Daemon marks the Material Lots 
that has expired on the current day.

ActivateInactivateObj
ectHourly Periodicity

24 This tag specifies the number of hours after 
which the Daemon activates or inactivates 
the business objects in the database, based on 
the start and end effective dates for the 
current day.

HasEffectivityCheckE
nabled

TRUE This tag indicates if the Daemon must 
activate or inactivate the business objects 
within the application.

ExpireWorkflowHour
lyPeriodicity

24 This tag specifies the number of hours after 
which the Daemon cleans up the Workflow 
Delegation table for the Authorized Parties, 
who have subscribed for the Workflow 
Delegation functionality. If the records in the 
Workflow Delegation table are no longer 
valid on the current day, those entries are 
removed from the Workflow Delegation 
table.

ExpireSiteQualificati
onHourly Periodicity

This Cell is Blank This tag specifies the number of hours after 
which the Daemon marks those Site 
Qualifications that have expired on the 
current day.

InventoryReevalExpi
reDaemon

24 This tag specifies the number of hours after 
which the Daemon marks the status of "Lot 
Release Processes" to "OutOfEvaluation". It 
also marks the corresponding Inventory 
(Lots/Containers) Status "To Be Evaluated"

AgileIntegrationHou
rlyPeriodicity

24 This Cell is Blank

CFMTemplateEngine This Cell is Blank This section contains properties pertaining to 
User Interface templates based on which 
screens are rendered.

location config/ templates The location where templates for the User 
Interface are stored. The path is relative to 
the location of CFM.HOME.

encoding ISO-8859-1 The character encoding used in these 
templates.

outputEncoding UTF-8 Encoding format for all output rendered 
based on the UI templates.

templateUpdateDela
y

0 This tag specifies the interval at which the 
Free Marker Template Engine looks for any 
changes in the templates. 0 informs the 
Engine not to look for any changes.

AgileDetails This Cell is Blank This Cell is Blank

AgileHttpUrl This Cell is Blank This is the HTTP URL for the Agile instance.

AgileRmiUrl This Cell is Blank This is the RMI URL for the Agile instance.

AgileWebServiceUrl This Cell is Blank This is the URL for Agile core web services.

Attribute Default Value Description
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CFMDBConfig.xml
The CFMDBConfig.xml file contains a list of databases that is available for the users. 
For each database, this file contains:

■ Logical database name.

■ Data source name for the database set up in the J2EE server.

■ Detailed information about the database such as vendor details.

The following table lists and describes the attributes in the CFMDBConfig.xml file.

CFMPrintableCatego
ries

Recipe, Control 
Recipe, Process Step, 
Work Order

This property is applicable for Formatted 
Print. The value for this property is a set of 
comma-separated business object IDs.

For all the business objects listed here, the 
History tab of all objects belonging to that 
business object will display an additional tab 
labeled 'Print'.

This tab will display information about the 
history of all Formatted Print operations 
performed on the given object.

Attribute Default Value Description

CFMDatabase No default value This tag is used to separate successive 
database configuration entries in the file. 
Each database configuration comprises of all 
the tags listed below.

CFMDatabaseName CFMPCM This tag specifies the database configuration 
name that is displayed on the login window 
of the application. This must be a unique 
name.

CFMDeleteType Soft This tag has a boolean value, Soft or Hard. 
Soft indicates that any delete command only 
marks the object as deleted but does not 
physically remove it from the database. Hard 
indicates that, on delete, all objects will be 
removed from the database.

CFMJNDIName LSPDataSource This tag specifies the JNDI name of the data 
source configured in the J2EE Application 
server for the Recipe Management for 
Pharmaceuticals  database.

CFMSchemaOwner TRUE This tag has a boolean value, TRUE or 
FALSE. TRUE indicates that the database 
user for this datasource is the Schema Owner 
and the owner of all the objects in the 
database. FALSE indicates that the database 
user for this data source is not the Schema 
Owner but is a user for a private synonym 
created on the database. The user also has 
permissions to modify, update, and delete 
records (to perform DML operations only 
and not DDL operations.)

If the value provided in the tag 
<CFMPrivilegedUsers> is False, the value is 
ignored.

Attribute Default Value Description
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Alert Message Generation Files
Alert notifications and dashboard messages can be configured to display content to 
suit your requirements. These configurations must be carried out in the related XSL 
files detailed below.

You must have basic knowledge of XSL, HTML syntax, and tags to configure message 
properties.

EmailNotification.xsl
This XSL file generates HTML content for email alert messages. The following table 
describes the various sections in an alert notification message and tells you what you 
can customize within each section.

Section Description What can be customized?

Header Displays a general salutation such 
as Dear <user name>.

Recipient user name.

Alert Header Displays the alert name, business 
object, and category.

Style attributes such as 
background color and font.

General information Displays general information such 
as name, subscription name, 
subject, message, and so on.

Labels.

Alert criteria Displays criteria and monitoring 
actions configured for this alert. 
Alert criteria is displayed only for 
alerts which have alert conditions 
specified. Alerts based on user 
actions do not have any criteria 
and are not displayed.

Label and content style.

Result table Displays records that have met the 
alert criteria.

Table properties, table 
caption, and "Trigger Value" 
column color.

Footer Displays customized text, 
disclaimers etc.

Can be completely removed 
or customized.

CFMPrivilegedUsers CFMUSER, User 2 This tag has a comma separated list of users 
having the DML operations on this database 
schema. Private synonyms are created for 
this user. This user has permissions to 
modify, update, and delete records (to 
perform DML operations only and not DDL 
operations.)

If any new categories are created using R&M 
Workspace metamodel module using the 
Schema Owner, the application creates the 
appropriate private synonym for each user 
listed in this tag.

CFMVendorType Oracle This tag specifies the vendor type of the 
relational database server used. The valid 
value for this tag is Oracle only.

Attribute Default Value Description
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DashboardNotification.xsl
This XSL file generates HTML content for dashboard alert messages.

Section Description What can be customized?

Header Displays configured alert 
details such as date, type of 
subscription, subject, priority 
etc.

Labels can be customized by 
editing the Dashboard Alert 
Details sub view.

Message Body Displays the results table. Number of records to display, 
table style properties, and 
"trigger value" style. You can 
also add more header 
columns.

Integration-related Files
Integration-related files are located at the following path: 
<CFMHome>\config\integration

File Name Description

cfmxml.xsd Schema file for the cfmXML. cfmXML is a standard xml format used 
by Recipe Management for Pharmaceuticals . The integration 
framework processes all the requests in cfmXML format and converts 
them to an appropriate response by applying the outbound XSL file if 
required.

inboundPCMApp.xsl
t

This is a sample XSLT file. This folder contains all the XSLT files, 
which are used as inbound XSL files for different applications 
communicating with Recipe Management for Pharmaceuticals .

outboundPCMApp.x
slt

This is a sample XSLT file. This folder contains all the XSLT files, 
which are used as outbound XSL files for different applications 
communicating with Recipe Management for Pharmaceuticals .

wsdlProcessor.xslt This is an XSLT file used to parse the given WSDL, extract the 
information in the Recipe Management for Pharmaceuticals  database 
using the integration Callable Web service with WSDL UI screen.

AgilePharmaMapping.xml
AgilePharmaMapping.xml is a mapping configuration file that allows you to map 
Agile and Recipe Management for Pharmaceuticals  object attributes.
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BRecipe & Material Workspace Keywords

The following keywords are reserved by the Recipe & Material Workspace system. 
That is, the keywords have particular meanings to the system and so cannot be 
redefined. For this reason, you cannot use them to name data objects such as 
Categories, Attributes, Views, Subviews, and so forth.

Keywords Reserved by Recipe Management for Pharmaceuticals 

ACCESS ELSE MODIFY START

ADD EXCLUSIVE NOAUDIT SELECT

ALL EXISTS NOCOMPRESS SESSION

ALTER FILE NOT SET

AND FLOAT NOTFOUND SHARE

ANY FOR NOWAIT SIZE

ARRAYLEN FROM NULL SMALLIN

AS GRANT NUMBER SQLBUF

ASC GROUP OF SUCCESSFUL

AUDIT HAVING OFLINE SYNONYM

BETWEEN IDENTIFIED ON SYSDATE

BY IMMEDIATE ONLINE TABLE

CHAR IN OPTION THEN

CHECK INCREMENT OR TO

CLUSTER INDEX ORDER TRIGGER

COLUMN INITIAL PCTFREE UID

COMMENT INSERT PRIOR UNION

COMPRESS INTEGER PRIVILEGES UNIQUE

CONNECT INTERSECT PUBLIC UPDATE

CREATE INTO RAW USER

CURRENT IS RENAME VALIDATE

DATE LEVEL RESOURCE VALUES

DECIMAL LIKE REVOKE VARCHAR

DEFAULT LOCK ROW VARCHAR2

DELETE LONG ROWID VIEW
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DESC MAXEXTENTS ROWLABEL WHENEVER

DISTINCT MINUS ROWNUM WHERE

DROP MODE ROWS WITH

Keywords Reserved by Recipe Management for Pharmaceuticals 
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