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Preface

Intended Audience
Welcome to Release 12.2 of the Oracle Service Fulfillment Manager Concepts and 
Procedures.

This guide assumes you have a working knowledge of the following:

• The principles and customary practices of your business area. 

• Oracle Service Fulfillment Manager 

If you have never used Oracle Service Fulfillment Manager, Oracle suggests you 
attend one or more of the Oracle Service Fulfillment Manager training classes 
available through Oracle University. 

• The Oracle Applications graphical user interface. 

To learn more about the Oracle Applications graphical user interface, read the 
Oracle E-Business Suite User's Guide.

See Other Information Sources for more information about Oracle Applications product
information.

See Related Information Sources on page xiv for more Oracle E-Business Suite product 
information. 

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc. 
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Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired. 

Structure
1  Understanding Oracle Service Fulfillment Manager
2  Using Oracle Service Fulfillment Manager
3  Administering Oracle Service Fulfillment Manager

Related Information Sources

Integration Repository
The Oracle Integration Repository is a compilation of information about the service 
endpoints exposed by the Oracle E-Business Suite of applications. It provides a 
complete catalog of Oracle E-Business Suite's business service interfaces. The tool lets 
users easily discover and deploy the appropriate business service interface for 
integration with any system, application, or business partner. 

The Oracle Integration Repository is shipped as part of the E-Business Suite. As your 
instance is patched, the repository is automatically updated with content appropriate 
for the precise revisions of interfaces in your environment. 

You can navigate to the Oracle Integration Repository through Oracle E-Business Suite 
Integrated SOA Gateway. 

Online Documentation
All Oracle E-Business Suite documentation is available online (HTML or PDF).

• PDF - See the Oracle E-Business Suite Documentation Library for current PDF 
documentation for your product with each release. The Oracle E-Business Suite 
Documentation Library is also available on My Oracle Support and is updated 
frequently

• Online Help - Online help patches (HTML) are available on My Oracle Support.

• Release Notes - For information about changes in this release, including new 
features, known issues, and other details, see the release notes for the relevant 
product, available on My Oracle Support.

• Oracle Electronic Technical Reference Manual - The Oracle Electronic Technical 
Reference Manual (eTRM) contains database diagrams and a detailed description of
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database tables, forms, reports, and programs for each Oracle E-Business Suite 
product. This information helps you convert data from your existing applications 
and integrate Oracle E-Business Suite data with non-Oracle applications, and write 
custom reports for Oracle E-Business Suite products. The Oracle eTRM is available 
on My Oracle Support.

Guides Related to All Products

Oracle E-Business Suite User's Guide
This guide explains how to navigate, enter data, query, and run reports using the user 
interface (UI) of Oracle E-Business Suite. This guide also includes information on setting
user profiles, as well as running and reviewing concurrent programs.

You can access this guide online by choosing "Getting Started with Oracle Applications"
from any Oracle E-Business Suite product help file.

Guides Related to This Product

Oracle Service Fulfillment Manager Implementation Guide 
This guide describes how to define the services and service packages that your 
organization needs, associate actions with services, associate work items with service 
actions, associate fulfillment actions with work items, and associate fulfillment 
procedures and network elements with fulfillment actions. It also describes the business
rules that you must define for PL/SQL procedures that select work items to execute for a
given service, fulfillment actions to execute for a given work item, and workflow 
processes to execute for a given work item. You must also implement the connection 
logic in the connect/disconnect procedure that Oracle Service Fulfillment Manager 
executes to establish a communication channel with the fulfillment element via 
adapters.

Installation and System Administration

Oracle Alert User's Guide
This guide explains how to define periodic and event alerts to monitor the status of 
your Oracle E-Business Suite data.

Oracle E-Business Suite Concepts
This book is intended for all those planning to deploy Oracle E-Business Suite Release 
12.2, or contemplating significant changes to a configuration. After describing the 
Oracle E-Business Suite architecture and technology stack, it focuses on strategic topics, 
giving a broad outline of the actions needed to achieve a particular goal, plus the 
installation and configuration choices that may be available.
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Oracle E-Business Suite CRM System Administrator's Guide
This manual describes how to implement the CRM Technology Foundation (JTT) and 
use its System Administrator Console.

Oracle E-Business Suite Developer's Guide
This guide contains the coding standards followed by the Oracle E-Business Suite 
development staff. It describes the Oracle Application Object Library components 
needed to implement the Oracle E-Business Suite user interface described in the Oracle 
E-Business Suite User Interface Standards for Forms-Based Products. It also provides 
information to help you build your custom Oracle Forms Developer forms so that they 
integrate with Oracle E-Business Suite. In addition, this guide has information for 
customizations in features such as concurrent programs, flexfields, messages, and 
logging.

Oracle E-Business Suite Installation Guide: Using Rapid Install
This book is intended for use by anyone who is responsible for installing or upgrading 
Oracle E-Business Suite. It provides instructions for running Rapid Install either to carry
out a fresh installation of Oracle E-Business Suite Release 12.2, or as part of an upgrade 
to Release 12.2.

Oracle E-Business Suite Maintenance Guide
This guide contains information about the strategies, tasks, and troubleshooting 
activities that can be used to help ensure an Oracle E-Business Suite system keeps 
running smoothly, together with a comprehensive description of the relevant tools and 
utilities. It also describes how to patch a system, with recommendations for optimizing 
typical patching operations and reducing downtime.

Oracle E-Business Suite Security Guide
This guide contains information on a comprehensive range of security-related topics, 
including access control, user management, function security, data security, and 
auditing. It also describes how Oracle E-Business Suite can be integrated into a single 
sign-on environment.

Oracle E-Business Suite Setup Guide
This guide contains information on system configuration tasks that are carried out 
either after installation or whenever there is a significant change to the system. The 
activities described include defining concurrent programs and managers, enabling 
Oracle Applications Manager features, and setting up printers and online help.

Oracle E-Business Suite User Interface Standards for Forms-Based Products
This guide contains the user interface (UI) standards followed by the Oracle E-Business 
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Suite development staff. It describes the UI for the Oracle E-Business Suite products and
tells you how to apply this UI to the design of an application built by using Oracle 
Forms.

Other Implementation Documentation

Oracle Approvals Management Implementation Guide
This guide describes transaction attributes, conditions, actions, and approver groups 
that you can use to define approval rules for your business. These rules govern the 
process for approving transactions in an integrated Oracle application. You can define 
approvals by job, supervisor hierarchy, positions, or by lists of individuals created 
either at the time you set up the approval rule or generated dynamically when the rule 
is invoked. You can learn how to link different approval methods together and how to 
run approval processes in parallel to shorten transaction approval process time.

Oracle Diagnostics Framework User's Guide
This guide contains information on implementing, administering, and developing 
diagnostics tests for Oracle E-Business Suite using the Oracle Diagnostics Framework.

Oracle E-Business Suite Flexfields Guide
This guide provides flexfields planning, setup and reference information for the Oracle 
E-Business Suite implementation team, as well as for users responsible for the ongoing 
maintenance of Oracle E-Business Suite product data. This guide also provides 
information on creating custom reports on flexfields data.

Oracle E-Business Suite Integrated SOA Gateway Implementation Guide
This guide explains the details of how integration repository administrators can manage
and administer the entire service enablement process based on the service-oriented 
architecture (SOA) for both native packaged public integration interfaces and composite
services - BPEL type. It also describes how to invoke Web services from Oracle 
E-Business Suite by working with Oracle Workflow Business Event System, manage 
Web service security, and monitor SOAP messages.

Oracle E-Business Suite Integrated SOA Gateway User's Guide
This guide describes how users can browse and view the integration interface 
definitions and services that reside in Oracle Integration Repository.

Oracle E-Business Suite Multiple Organizations Implementation Guide
This guide describes how to set up multiple organizations and the relationships among 
them in a single installation of an Oracle E-Business Suite product such that transactions
flow smoothly through and among organizations that can be ledgers, business groups, 
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legal entities, operating units, or inventory organizations. You can use this guide to 
assign operating units to a security profile and assign this profile to responsibilities such
that a user can access data for multiple operating units from a single responsibility. In 
addition, this guide describes how to set up reporting to generate reports at different 
levels and for different contexts. Reporting levels can be ledger or operating unit while 
reporting context is a named entity in the selected reporting level.

Oracle e-Commerce Gateway Implementation Guide
This guide describes implementation details, highlighting additional setup steps needed
for trading partners, code conversion, and Oracle E-Business Suite. It also provides 
architecture guidelines for transaction interface files, troubleshooting information, and a
description of how to customize EDI transactions.

Oracle e-Commerce Gateway User's Guide
This guide describes the functionality of Oracle e-Commerce Gateway and the 
necessary setup steps in order for Oracle E-Business Suite to conduct business with 
trading partners through Electronic Data Interchange (EDI). It also describes how to run
extract programs for outbound transactions, import programs for inbound transactions, 
and the relevant reports.

Oracle iSetup User's Guide
This guide describes how to use Oracle iSetup to migrate data between different 
instances of the Oracle E-Business Suite and generate reports. It also includes 
configuration information, instance mapping, and seeded templates used for data 
migration.

Oracle Product Hub Implementation Guide
This guide explains how to set up hierarchies of items using catalogs and catalog 
categories and then to create user-defined attributes to capture all of the detailed 
information (such as cost information) about an object (such as an item or change 
order). It also explains how to set up optional features used in specific business cases; 
choose which features meet your business' needs. Finally, the guide explains the set up 
steps required to link to third party and legacy applications, then synchronize and 
enrich the data in a master product information repository.

Oracle Product Hub User's Guide
This guide explains how to centrally manage item information across an enterprise, 
focusing on product data consolidation and quality. The item information managed 
includes item attributes, categorization, organizations, suppliers, multilevel 
structures/bills of material, packaging, changes, attachments, and reporting.
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Oracle Web Applications Desktop Integrator Implementation and Administration Guide
Oracle Web Applications Desktop Integrator brings Oracle E-Business Suite 
functionality to a spreadsheet, where familiar data entry and modeling techniques can 
be used to complete Oracle E-Business Suite tasks. You can create formatted 
spreadsheets on your desktop that allow you to download, view, edit, and create Oracle
E-Business Suite data, which you can then upload. This guide describes how to 
implement Oracle Web Applications Desktop Integrator and how to define mappings, 
layouts, style sheets, and other setup options.

Oracle Workflow Administrator's Guide
This guide explains how to complete the setup steps necessary for any Oracle 
E-Business Suite product that includes workflow-enabled processes. It also describes 
how to manage workflow processes and business events using Oracle Applications 
Manager, how to monitor the progress of runtime workflow processes, and how to 
administer notifications sent to workflow users.

Oracle Workflow Developer's Guide
This guide explains how to define new workflow business processes and customize 
existing workflow processes embedded in Oracle E-Business Suite. It also describes how
to define and customize business events and event subscriptions.

Oracle Workflow User's Guide
This guide describes how Oracle E-Business Suite users can view and respond to 
workflow notifications and monitor the progress of their workflow processes.

Oracle XML Gateway User's Guide
This guide describes Oracle XML Gateway functionality and each component of the 
Oracle XML Gateway architecture, including Message Designer, Oracle XML Gateway 
Setup, Execution Engine, Message Queues, and Oracle Transport Agent. It also explains
how to use Collaboration History that records all business transactions and messages 
exchanged with trading partners. 

The integrations with Oracle Workflow Business Event System, and the 
Business-to-Business transactions are also addressed in this guide. 

Oracle XML Publisher Administration and Developer's Guide
Oracle XML Publisher is a template-based reporting solution that merges XML data 
with templates in RTF or PDF format to produce outputs to meet a variety of business 
needs. Outputs include: PDF, HTML, Excel, RTF, and eText (for EDI and EFT 
transactions). Oracle XML Publisher can be used to generate reports based on existing 
Oracle E-Business Suite report data, or you can use Oracle XML Publisher's data 
extraction engine to build your own queries. Oracle XML Publisher also provides a 
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robust set of APIs to manage delivery of your reports via e-mail, fax, secure FTP, 
printer, WebDav, and more. This guide describes how to set up and administer Oracle 
XML Publisher as well as how to use the Application Programming Interface to build 
custom solutions. This guide is available through the Oracle E-Business Suite online 
help.

Oracle XML Publisher Report Designer's Guide
Oracle XML Publisher is a template-based reporting solution that merges XML data 
with templates in RTF or PDF format to produce a variety of outputs to meet a variety 
of business needs. Using Microsoft Word or Adobe Acrobat as the design tool, you can 
create pixel-perfect reports from the Oracle E-Business Suite. Use this guide to design 
your report layouts. This guide is available through the Oracle E-Business Suite online 
help.

Training and Support

Training
Oracle offers a complete set of training courses to help you master your product and 
reach full productivity quickly. These courses are organized into functional learning 
paths, so you take only those courses appropriate to your job or area of responsibility.

You have a choice of educational environments. You can attend courses offered by 
Oracle University at any of our many Education Centers, you can arrange for our 
trainers to teach at your facility, or you can use Oracle Learning Network (OLN), Oracle
University's online education utility. In addition, Oracle training professionals can tailor
standard courses or develop custom courses to meet your needs. For example, you may 
want to use your organization structure, terminology, and data as examples in a 
customized training session delivered at your own facility.

Support
From on-site support to central support, our team of experienced professionals provides
the help and information you need to keep your product working for you. This team 
includes your Technical Representative, Account Manager, and Oracle's large staff of 
consultants and support specialists with expertise in your business area, managing an 
Oracle server, and your hardware and software environment.

Do Not Use Database Tools to Modify Oracle E-Business Suite Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data 
Browser, database triggers, or any other tool to modify Oracle E-Business Suite data 
unless otherwise instructed. 

Oracle provides powerful tools you can use to create, store, change, retrieve, and 
maintain information in an Oracle database. But if you use Oracle tools such as 
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SQL*Plus to modify Oracle E-Business Suite data, you risk destroying the integrity of 
your data and you lose the ability to audit changes to your data. 

Because Oracle E-Business Suite tables are interrelated, any change you make using an 
Oracle E-Business Suite form can update many tables at once. But when you modify 
Oracle E-Business Suite data using anything other than Oracle E-Business Suite, you 
may change a row in one table without making corresponding changes in related tables.
If your tables get out of synchronization with each other, you risk retrieving erroneous 
information and you risk unpredictable results throughout Oracle E-Business Suite. 

When you use Oracle E-Business Suite to modify your data, Oracle E-Business Suite 
automatically checks that your changes are valid. Oracle E-Business Suite also keeps 
track of who changes information. If you enter information into database tables using 
database tools, you may store invalid information. You also lose the ability to track who
has changed your information because SQL*Plus and other database tools do not keep a
record of changes. 





Understanding Oracle Service Fulfillment Manager    1-1

1
Understanding Oracle Service Fulfillment 

Manager

This chapter covers the following topics:

• Overview of Oracle Service Fulfillment Manager

• Service Order Requests in Oracle Service Fulfillment Manager

• Why SFM Orders Fail

• Ways to Resolve Failed Orders

• System Notification Types

• The Order Resubmission Utility

• The Event Manager

• Queues in Oracle Service Fulfillment Manager

• The Oracle Service Fulfillment Manager System Queues

• The Queue Console

• Understanding Network Adapters

• The Network Adapter Types

• Adapter Commands

• Adapter Modes

• Network Adapter Management

• The Connection Manager

• Fulfillment Element Types in Oracle Service Fulfillment Manager

• Fulfillment Elements in Oracle Service Fulfillment Manager

• Understanding Services

• Work Items in Oracle Service Fulfillment Manager
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• Understanding Packages

• Understanding Notifications

• The Notifications Utility

• Messaging in Oracle Service Fulfillment Manage

• Message Elements

• Message Processing Logic

• Message Processing Logic - Guidelines

• Timers in Oracle Provisioning

• Timer Usage in Oracle Provisioning

• Using Timers in Workflow

• Activity Timers in Oracle Service Fulfillment Manager

• Process Timers in Oracle Service Fulfillment

• Message Timers in Oracle Service Fulfillment

• Workflow in Oracle Service Fulfillment Manager

• Workflow Processing of a Service Order Request

• The Workflow Monitor

• Understanding the Procedure Builder

Overview of Oracle Service Fulfillment Manager
One of the primary functions of the Oracle Service Delivery Platform is to supply 
telecommunication providers, ISPs (Internet Service Providers) and similar vendor 
companies with the ability to manage the critical business functions of order capture 
and order activation, network administration and operation. 

The Benefits of Oracle Service Fulfillment Manager
Oracle Service Fulfillment Manager provides the following benefits:

• A fully automated, nearly real-time activation of services for multiple network 
elements in a multi-vendor network environment. 

• A number of APIs (Application Program Interfaces) that you can use as building 
blocks in creating an interface to any Operational Support System (OSS) available 
on the service provider's network. For example, you can use these APIs to create an 
interface to an external order entry or customer care system.
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Features of Oracle Service Fulfillment Manager
Oracle Service Fulfillment Manager is designed to be an integrated management system
that acts as the coordinating link between different external systems. It supports the 
following features:

• The rapid deployment of new services by integrating the functions of service 
management with the network details (service attributes, Service Fulfillment 
Manager algorithm, fulfillment element). 

• The Service Fulfillment Manager of multiple technologies (e.g., ATM, ADSL, 
Switch, Routers) 

• The delivery of complex services requiring configuration of multiple fulfillment 
elements and OSS (Operational Support Systems) interfaces.

• The delivery of bundled services combining voice, data and video products. 

Service Order Requests in Oracle Service Fulfillment Manager
Oracle Service Fulfillment handles a typical service order request by performing the 
following tasks:

1. Capturing a service order request, page 1-3

2. Validating the order, page 1-4

3. Analyzing the order, page 1-4

4. Fulfilling the order, page 1-4

5. Completing the order, page 1-5

And, if necessary, 

6. Managing order fallout, page 1-6

Capturing a Service Order Request
Initially, a customer places an order with the carrier for a telecommunication service. 
Examples of services could be one or a combination of phone lines, internet connections 
and wireless access.

Customer orders are captured from an external Order Entry (OE) system. If necessary, 
customer orders can also be input through the Service Fulfillment Manager screens. 
However, the primary capture process is through the Oracle Service Fulfillment 
Manager APIs. 
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Validating the Order
After the service order is captured by the system (or manually entered, as the case may 
be), it is examined for validity by the system. If an order fails validation, OP returns an 
appropriate message indicating such errors to the order originator. Failed orders due to 
validation errors are not processed further in Oracle Service Fulfillment Manager. 

Order validation includes the following:

• Verifying the order syntax

• Verifying the inclusion of mandatory parameters

• Verify that necessary dependent information is also included

• Verify that the supplied dates are valid dates

Analyzing the Order
After an order is captured, Oracle Service Fulfillment Manager performs the following 
steps:

1. Analyzes the order.

2. Breaks it down into the required set of tasks needed to fulfill the order.

3. Orders the tasks so that they will be performed in the proper sequence. 

For example, say the new order requires two new lines to be activated at a customer 
residence, one an analog voice phone line, the other a digital ISDN line to be used for 
high-speed Internet access. In addition, each separate line is to have a different bundle 
of services associated with it. The analog line must have basic voice service, as well as 
the Caller ID and Call Waiting features. The digital line needs to have a connection 
established to the desired ISP (Internet Service Provider). 

After order capture, Oracle Service Fulfillment Manager analyzes and validates the 
order, then puts the order steps into sequence. While some of the tasks involved in 
setting the customer order can be performed in parallel, others must be performed in a 
definite sequence. In this example, basic voice service must be established on the analog
line before the additional features can be implemented.

Fulfilling the Order
Order fulfillment in Oracle Service Fulfillment Manager is accomplished through one of
two ways:

• OP performs the requested tasks internally.
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• OP directs external systems to perform the tasks involved in setting up the order.

Oracle Service Fulfillment Manager first translates these tasks into network language, 
and then activates the various network elements needed to complete the tasks. 

For example, it can:

1. Request configuration and activation of services on specific switches. (Connections 
to the needed network elements are managed using the Connection Manager.)

2. Notify the OSS (Operational Support Systems) to commence service.

The tasks involved in setting up an order are managed via workflow. Workflow is 
either internal to Oracle Service Fulfillment Manager or external to it. 

• Internal workflow is the default, or standard workflow delivered with the 
application.

• External workflow is created by the user, and is integrated with the standard 
workflow delivered with the application. For example, you write the business 
process logic (the executable code) to retrieve data from outside the Service 
Delivery Platform database. (This could be, for example, the telephone number 
function for a network switch.)

These workflows are user-configurable to match company specific business practices.

Note: Oracle Service Fulfillment Manager can also handle the results of 
the network elements through its generic fulfillment engine. 

Completing the Order
If the service order completes:

• Successfully

The system sends a notification message of success to the Event Manager that 
includes both the internal and external order IDs for the order as well as the 
services it provisioned. This includes all the subscriber details (service assignments, 
parameter values and product attributes). All activation information, updates and 
modifications performed on the service order request are captured. 

The Event Manager then publishes the event that the service order request 
completed successfully. The status of the order is changed to COMPLETED. 

• Unsuccessfully

Oracle Service Fulfillment Manager suspends the Service Fulfillment Manager 
process after the first error occurs. It then creates a notification message with the 
error information and sends the message to the Notifications utility. The order 
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remains open, but the status is changed to indicate that the order has been 
suspended. The Service Fulfillment Manager process can not continue until the 
error is rectified.

To continue processing, you must modify the order via the Notifications utility 
interface and re-submit the order to the Service Fulfillment Manager process where 
the error occurred.

Managing Order Fallout
Order Service Fulfillment Manager can fail during the Service Fulfillment Manager 
process due to invalid activation information, or perhaps the unavailability of a needed 
network element. 

Oracle Service Fulfillment Manager provides a number of ways to effectively manage 
the order fallout process through its Notifications utility.

You can, for example:

• Examine order details and drill down to error messages

• Track the progress of problem resolutions through the system

• Initiate action to reconfigure a service, if needed

• Generate a notification and forward the notification to the Trouble Ticket system 
and/or Work Force Managements

• Confirm that the order trouble has been cleared

Why SFM Orders Fail
Order fulfillment can fail during the Service Fulfillment Manager process due to the 
following factors:

• Invalid orders: Orders that fail the order validation process may require escalation 
to the order entry or customer service groups. In such cases, the Notifications 
utility, page 1-27 serves as a tracking and notification mechanism.

• Bad or missing data: Incorrect or missing data can cause order fallout.

• Fulfillment action problems: Fulfillment elements may not function properly, or be
too busy, or unavailable, so the system rejects the service activation command.

• Time-outs on orders: The connection session between the application and the 
fulfillment elements may time-out due to either application or external errors. 
Orders that have timed out may have been partially completed prior to the 
time-out.
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• Network element or service configuration problems: The new service order may 
conflict with the current subscriber configuration. This may be the result of invalid 
orders. However, there may be other reasons, such as improper configuration of the
customer.

Ways to Resolve Failed Orders
You use the Notifications utility to track, monitor and resolve failed orders.

The table following details some of those ways that you can resolve failed orders.

Ways to Resolve Failed Orders

Action Description

Retry Failed Orders You can re-send failed orders in one of the 
following ways:

• Modify parameters in the failed order and
re-send the order down to where the 
failure occurred, and then continue 
processing.

• Re-send unchanged order down to where 
the failure occurred in the Service 
Fulfillment Manager process. (Failure 
may have been due merely to network 
problems.)

• Restart the Service Fulfillment Manager 
workflow from the point where it failed 
or stopped.

Stop Processing Failed Orders You can stop the workflow processing of an 
order that is due for Service Fulfillment 
Manager. This is useful in the case of 
identified network outages and order 
processing backlog.

Terminate Failed Workflows You can completely terminate processing an 
order if an exception state is encountered.

Resolve Failed Workflows You can correct the error in the order Service 
Fulfillment Manager workflow (from within 
the Notifications utility).
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Action Description

Escalate Failed Workflows You can escalate a failed order notification by 
forwarding it to another user or group in 
order to troubleshoot the order.

Re-assign Failed Workflows You can reassign a failed order to another user
or group for resolution.

System Notification Types
Notifications are generated by various events and at various stages in the Service 
Fulfillment Manager process. Example events are:

• Recovery daemons

• Service Service Fulfillment Manager process failure

• Internal exceptions

Notification types
The workflow produces two distinct types of notifications:

• Informative notifications

The system generates these notifications if the Service Delivery Platform system 
detects a stopped fulfillment element manager process and starts it up 
automatically. Also, the system generates a notification if an internal problem 
occurs that requires a system administrator's attention.

• Order fallout notifications

The system generates these notification for failed orders. 

The Order Resubmission Utility
You use the Resubmission Utility to force the system to re-run an order on a particular 
fulfillment element. However, only those orders which have either completed, or have 
been previously submitted, on the fulfillment element in question, can be resubmitted. 
This is useful, for example, in the event that a network switch fails or experiences a 
service disruption, causing a Service Fulfillment Manager order to fail.

Through this utility, you specify a particular fulfillment element and the time window 
during which is was unavailable. After entering the required information, fulfillment 
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elements re-execute the fulfillment actions as scheduled. A Job ID is generated and the 
progress of the re-submission can be tracked.

Re-submitted Orders and Fulfillment Actions
Successful re-execution of the fulfillment action requires that the adapters run in this 
mode. 

• If there are no available adapters and the fulfillment element adapter maximum has
not been reached, then an error message is generated.

• If no adapters can be started, all re-submission requests are queued.

• Re-submitted fulfillment actions can be identified in the Order Flowthrough 
window using the Resubmitted check-box.

Re-submitted Orders and Notifications
Re-submitted orders execute the same fulfillment procedure as the original orders.

• These re-submitted orders can generate notifications based on the fulfillment 
procedure logic.

• Any generated notification message includes the Job ID.

The Event Manager
The Event Manager handles incoming and outgoing messages within the Oracle Service
Delivery Platform. The Event Manager provides a set of APIs that are used by both 
internal and external systems to register for messages.

• Incoming messages are frequently a response to a previously initiated message 
from an external or internal system

• Outgoing message are frequently user-defined notifications informing an external 
or internal system of an event occurrence.

Message Registration
External applications can send request messages to the Event Manager, if they are 
registered for that message. External applications can also register for response 
messages.

Inbound Messages
The Event Manager identifies the subscriber and delivers an incoming message to the 
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registered applications. The following sequence of steps is performed automatically. 
The Service Delivery Platform:

• Picks up the message from the Incoming Queue

• Pulls the message out of the Incoming Queue and into the Event Manager

• Validates the message structure via the Event Manager

• Verifies if any internal or external subscribers are registered for this message

• Executes the user-defined logic

• Delivers the message to all registered application systems

Processing Logic
External systems can define their own processing logic at the time when validation and 
processing logic are defined. If no application has registered for a message, the 
application uses the default processing logic after message validation.

Queues in Oracle Service Fulfillment Manager
In Oracle Service Fulfillment Manager, a service order request is often queued in one of 
the many internal system queues between different stages in its processing.

As the Service Fulfillment Manager of an order progresses, the order moves 
sequentially through the various system queues as part of the fulfillment process. For 
example:

• Incoming orders are moved to the Orders Pending queue if scheduled for later 
Service Fulfillment Manager 

• Orders are transferred from the Orders Pending queue to the Orders Ready queue 
as the Service Fulfillment Manager date occurs.

The table following describes the queues in use in the Oracle Service Fulfillment 
Manager system.

Oracle Service Fulfillment Manager Queues

Queue Contains

Orders Pending Orders waiting for a Service Fulfillment 
Manager date to occur
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Queue Contains

Orders Ready Orders that are ready to be provisioned 
immediately

Work Item Work items for orders currently being 
processed

(Work items are a logical grouping of 
fulfillment actions.)

Fulfillment Actions  

Wait for FE Channel Fulfillment actions waiting for one of the 
channels configured for the fulfillment 
elements to becomes available

FE Ready Fulfillment actions associated with each 
fulfillment element that are ready to be 
executed

Outbound Messages Messages sent by Oracle Service Fulfillment 
Manager

Inbound Messages Messages received by Oracle Service 
Fulfillment Manager

Event Manager Events which occur internally in Oracle 
Service Fulfillment Manager

The Oracle Service Fulfillment Manager System Queues
As an order moves through the system, it progresses from queue to queue in a 
sequential manner. Typically, this progression moves through the system queues in the 
following order.

• Order Pending Queue, page 1-12

• Order Ready Queue, page 1-12

• Work Item Queue, page 1-12

• FA Queue, page 1-13

And additionally, the following queues are used as necessary
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• FE Ready Queue, page 1-13

• Wait for FE Channel Queue, page 1-13

Order Pending Queue
The Process Order API moves the order into the Order Pending queue. The order stays 
in the pending queue until the date set for Service Fulfillment Manager. This date can 
be passed to the Service Delivery Platform as part of the order. 

On the Service Fulfillment Manager date the order is moved to the Order Ready queue. 
If an order does not contain a Service Fulfillment Manager date, the default date 
becomes the current date and the order is moved immediately to the Order Ready 
queue.

Order Ready Queue
The Order Ready queue holds orders that are ready to be provisioned immediately. The
order is dequeued from the Order Ready queue and the work items generated by the 
work-plan are placed on the work item queue. 

Work Item Queue
The work item queue is used to manage the execution of work items. 

Processing the work item involves the following:

• Checking the configurator for existence of fulfillment actions mapped to the work 
items.

• Determining if the work item is a regular Service Delivery Platform work item or a 
user-defined workflow.

The following then occurs:

• In the case of regular work items, the fulfillment actions are enqueued into the FA 
Queue in the sequence specified. 

• For user-defined workflows, the execution of the fulfillment actions is determined 
by the user-defined workflow. (Users can drag and drop EXECUTE_FA activities 
into their workflows based on the business process being implemented.)

Note: At this point, the Service Delivery Platform does not know 
which fulfillment elements need to be provisioned. 
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FA Queue
The FA Queue is used to manage the execution of fulfillment actions for regular (on 
user-defined) work items. 

Processing the fulfillment actions involves the following:

• Checking the configuration to determine to which fulfillment element the 
fulfillment procedure must be sent.

• Checking for the availability of an adapter for the fulfillment element.

The following then occurs:

• If an adapter is available, then it is immediately used to send the fulfillment element
commands specified in the fulfillment procedure.

• If all adapters for the fulfillment element are busy or none are immediately 
available, the fulfillment action is put into the Wait for FE channel queue. 

Wait for FE Channel Queue
When an adapter becomes available, the fulfillment action waiting in the queue is 
moved to the FE Ready queue.

FE Ready Queue
This is a temporary holder for all fulfillment actions that are waiting for a free 
fulfillment element adapter. As an adapter becomes available, the fulfillment action is 
immediately dequeued and its fulfillment procedure executed.

The Queue Console
The Queue Console provides a set of screens that display specialized information about 
each internal system queue. It can also be used to track down an order and to take 
corrective actions to expedite the order fulfillment process.

The Queue Console provides the following information about each queue:

• State Information, page 1-14

• Process Information, page 1-14

• Entry Information, page 1-14
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State Information
The Queue Console displays information on the state or status of each Oracle Service 
Fulfillment Manager queue.

• Enabled: The processors are up and running and processing orders.

• Disabled: The processors are running, but an error condition has occurred. No order 
is being processed.

• Suspended: The processes have been suspended manually.

• Shutdown: The processors have been shutdown manually.

Process Information
The Queue Console displays information on the processes that are registered or running
for a queue.

• Processors Registered: The actual number of processors pulling or processing 
orders out of a queue.

• Processors Running: The actual number of orders running in a queue.

Entry Information
The Queue Console displays information the number and date of the entries in a queue.

• No. of Entries: The number of entries in the queue.

• Last Entry Date: The date when the last order entered this queue. 

Understanding Network Adapters
A network adapter mediates the communication between Oracle Provisioning and the 
fulfillment elements. 

• An adapter is a runtime instance of a fulfillment element.

• Messages to be sent and received are specified by the fulfillment element and the 
connection procedures executed by Oracle Provisioning workflow. 

• The Service Fulfillment Manager workflow executes connect procedures for each 
new fulfillment element connection (provided a procedure has been defined for the 
particular fulfillment element).
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• The Connection Manager interacts with fulfillment element connections through 
adapters. 

Adapter Usage
The following table lists the ways that adapters are used in the Service Delivery 
Platform, and describes each:

Adapters Usage in the Service Delivery Platform

Usage Description

Service Fulfillment Manager Mode • Usual mode of operation

• Required mode for executing a fulfillment
action or fulfillment procedure.

• Only one fulfillment action or fulfillment 
procedure can be processed through an 
adapter execution.

• An adapter using this mode can service 
only one request at any given time.

The Network Adapter Types
You can issue commands to network adapters in one of two ways.

• You pre-define a sequence of commands for the system to perform automatically 
during the course of the Service Fulfillment Manager process. This is the most 
common method of issuing commands to the adapters.

• You issue adapter commands manually, also through the Connection Manager. 
However, while possible, this is not likely.

• You schedule commands to run at a future time, or times.

Adapter Commands
You can issue commands to network adapters in one of two ways.

• You pre-define a sequence of commands for the system to perform automatically 
during the course of the Service Fulfillment Manager process. This is the most 
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common method of issuing commands to the adapters.

• You issue adapter commands manually, also through the Connection Manager. 
However, while possible, this is not likely.

• You schedule commands to run at a future time, or times.

You request (command), or schedule a request, that an adapter perform one of the 
following operations:

• Suspend, page 1-16

• Resume, page 1-16

• Connect, page 1-17

• Stop, page 1-18

• Startup, page 1-18

Suspend
This command stops the application from sending orders to be provisioned. It places 
service orders in a queue until the fulfillment element becomes available.

If this command is used, then the following events occur:

• The application will not send any data/commands/Service Order Requests to the 
connected fulfillment element. 

• All service order requests that specify this adapter are stored in a job queue until 
the adapter is re-started.

The current status of the adapter must be Idle for this command to be available.

Resume
This command acts as a toggle to end/resume normal operations from a previous 
suspension. 

If this command is used, then the following events occur:

• The Connection Manager sets any fulfillment element interfacing to this adapter to 
either Idle or Busy. 

• It sets the fulfillment element to Idle, if the job queue is empty for the adapter 
interfacing at the fulfillment element (meaning that no service order requests 
awaiting Service Fulfillment Manager use this adapter).
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• It set the fulfillment element to Busy, if there is a service order request in the 
Service Fulfillment Manager queue that uses the adapter interfacing to the 
fulfillment element.

• The application continues the Service Fulfillment Manager process, if service order 
requests are waiting in the job queue. The next service order request marked for 
processing continues its Service Fulfillment Manager course.

The current status of the adapter must be Suspended for this command to be available.

Disconnect
This command is used to close the appropriate connection. It stores the service 
activation order in a job queue until the connection to the fulfillment element is restored
by issuing a connect request. 

If this command is used, then the following events occur:

• The Connection Manager sets the adapter status to Disconnected.

• The Connection Manager places all service order requests that use this adapter into 
a queue until the adapter is re-connected.

The current status of the adapter must be Suspended or Idle for this command to be 
available.

Connect
This command is used to establish a connection to a fulfillment element so that is starts, 
or continues, its normal operation. Service order requests that are stored in a job queue 
re-start processing. 

If this command is used, then the following events occur:

• The Connection Manager sets the fulfillment element to one of the following states:

• Idle

• Busy

• Error

• Processing continues based on the following conditions:

The current status of the adapter must be Disconnected for this command to be 
available.

• If service order requests are waiting in the job queue, the next service order 
request due for processing continues its Service Fulfillment Manager course. 



1-18    Oracle Service Fulfillment Manager Concepts and Procedures

The status of the adapter is Busy.

• If the job queue is empty for that fulfillment element (meaning no service order 
requests are awaiting Service Fulfillment Manager), the status of the adapter is 
set to Idle.

• If the Network Element Manager status is Error, then the connection could not 
be established to the Network Element, the connection procedure failed.

STOP
This command is used to close the connection to a fulfillment element by discontinuing 
adapter operation. Service order requests are stored in a job queue until a new adapter 
becomes available. 

If this command is used, then the following events occur:

• The Connection Manager sets the adapter status to Shutdown.

• The Connection Manager shuts down the adapter.

The current status of the adapter can not be Shutdown or Reconnecting for this command 
to be available. If the status is Busy, the shut down operation does not happen 
immediately. The application logs a Shutdown request that becomes active upon order 
completion.

Start Up
This command is used to start up a new adapter and establish a connection to a 
fulfillment element. 

If this command is used, then the following events occur:

• The Connection Manager sets the fulfillment element status to Idle or Busy.

• Order service requests start processing using the new adapter.

• If service order requests are waiting in the job queue, then the next service 
order request continues its Service Fulfillment Manager course. The status of 
the adapter is Busy.

• If the job queue is empty for that fulfillment element, then the status of the 
adapter is set to Idle.

The current status of the adapter must be Shutdown for this command to be 
available.
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Adapter Modes
There are two types of adapters modes. They are:

• Startup Mode, page 1-19

• Debug Mode, page 1-19

Startup Mode
There are three possible states to the Startup Mode:

• Automatic

The adapters can be started from the command line using the xdp-ctl utility.

• Manual

The adapters can be started only through the Connection Manager.

• Disabled

Adapter operations are disabled unless the adapter mode is changed to either 
Automatic or Manual.

Debug Mode
This mode indicates the level of logging for the UNIX executable and the interactive 
adapter types. 

• Low

Critical activities only are logged.

• Medium

Most of the system activities are logged.

• High

All activities are logged.

• None

No activities are logged except fatal errors.

Network Adapter Management
You issue requests (commands) to the adapters and schedule adapter activities through 
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the Connection Manager.

Adapter Commands
You issue the following commands to adapters:

• Connect: Establish a connection to the fulfillment element and resume its normal 
operation. 

• Disconnect: Close the appropriate connection and store the service activation order 
in a job queue until the connection to the fulfillment element is restored by issuing a
connect request.

• Ftp file: Transfer a file using ftp.

• Resume: Resume normal operation. 

• Stop: Close the connection to the fulfillment element by bringing down the adapter.

• Start up: Start up a new adapter and establish a connection to the fulfillment 
element (if any).

• Suspend: Stop Oracle Provisioning from sending any orders to be provisioned and 
have all service orders placed in a queue until the fulfillment element becomes 
available.

Adapter Scheduling
You schedule the use of adapters in one of three ways:

• Immediate: The adapter fulfills the request immediately, on the current date.

• Future: The adapter fulfills the request on a future date.

• Periodic: The adapter fulfills the request at periodic time intervals based on the 
supplied period.

The Connection Manager
The Connection Manager provides the means to view, quickly modify, and manage the 
adapters connected to each fulfillment element. Adapters maintain connectivity to each 
fulfillment element during service Service Fulfillment Manager.You can manage each 
connection for purposes such as load balancing, trouble shooting and maintenance.

You use the Connection Manager to accomplish the following tasks:

• View all the available fulfillment elements that have been configured in Oracle 
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Provisioning

• View the total number of service order requests awaiting activation in the queue for
a selected fulfillment element

• View the average time a service order request has been waiting in the queue

• View the number of adapters currently active for this fulfillment element

• View the date and time when the order entered the queue

• View the elapsed time a service order request has been in the queue

• View network problems and order flow to perform trouble shooting

• Monitor the number of adapters currently available

• Perform administrative activities on adapters

• Schedule activities for adapters

• Define a connection management schedule as needed

Fulfillment Element Types in Oracle Service Fulfillment Manager
Note: Fulfillment element types are defined by system experts only.

Fulfillment elements, page 1-24 in Oracle Service Fulfillment Manager are grouped into
logical categories. A fulfillment element type can be any of the following:

• An operating system

• An equipment platform

• A Network Element Mediation (NEM) layer

• A piece of telecommunication-specific hardware

The table following lists examples of different fulfillment element types.
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Examples of Fulfillment Element Types

Item Fulfillment Element Type

Home Location Registration (HLR) unit Network Element

Cisco server Server

AT&T 5ESS switch Telephony Switch

Nortel DMS200 switch Telephony Switch

Parts to a Fulfillment Element Type
Any service order request provisioned through Oracle Provisioning requires that the 
type for that specific fulfillment element be defined in the system before the fulfillment 
element itself is defined.

To configure a fulfillment element type, you must define the following items:

• The fulfillment element type name and details

• The software generic properties for the fulfillment element type

• The attributes of the fulfillment element type

Type Attributes
An attribute defines a property of a fulfillment element type. This can include all of the 
attributes with a connect/disconnect procedure. Attributes are also used to uniquely 
identify a fulfillment element. 

Each fulfillment element inherits its attributes from its fulfillment element type. The 
value of an attribute is the default value defined at the level of the fulfillment element.

The attributes of an fulfillment element type defines its properties and behavior. These 
include the following:

• IP address

• Username

The following are additional attributes for a fulfillment element type:

• Passwords used in connection/disconnection procedures
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• Software generics associated with the procedures

Note: It is possible to configure multiple software versions 
(generics) for each fulfillment element type, each with a specific 
effective date.

All attributes are associated with a fulfillment element type or a fulfillment element.

• Each fulfillment element instance can have a different value. 

• Each fulfillment element inherits attributes from its fulfillment element type.

• Adding attributes is performed at the fulfillment element type level. 

Note: Setting a value for an attribute overwrites the default value of
that attribute specified at the fulfillment element type level.

Fulfillment Element Type Attribute Default Values
Oracle Service Fulfillment Manager sets default values for the following attributes:

NE_CMD_TIMEOUT

When executing commands within a fulfillment element, the default set time-out is 120 
seconds.

NE_CMD_RETRY

The adapter retries the command numerous times before it times- out. A failure 
message is returned and the default value is set to zero retry.

NE_CMD_WAIT

Waiting period (in seconds) before retrying commands within a fulfillment element. 
The default value is set to zero seconds.

NE_NO_ACTIVITY_TIMEOUT

Some fulfillment elements may terminate the session, if there is no processing activity. 
The Service Delivery Platform allows you to set processing time to execute a command. 
This allows the connection between an adapter and the fulfillment element to remain 
active. The default processing time is set to 120 seconds.

NE_DUMMY_CMD

The Service Delivery Platform allows you to send commands to a fulfillment element to 
maintain the active sessions with the adapter. The adapter sends a command five 
seconds before processing time-out (NE_NO_ACTIVITY_TIMEOUT). 
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Note: If you want an carriage return command to be sent, use " " as the 
attribute value. The default command is " ".

NE_CONNECT_RETRY_COUNT

Number of times the interactive adapter will try to reconnect automatically if the 
connection to the fulfillment element is dropped. The default value is zero.

NE_CONNECT_WAIT

Elapsed time (in seconds) between attempts to reconnect. The Default value is zero.

Fulfillment Elements in Oracle Service Fulfillment Manager
In the Oracle Service Delivery Platform, a fulfillment element is a unique physical 
entity. It has the following characteristics:

• It has a unique name on a carrier's network.

• It is a member of a unique Fulfillment Element type.

You must give each fulfillment element a unique name. This name is registered in the 
system during the configuration of the fulfillment element. 

For example, if a telecommunications service provider has a router of a certain 
fulfillment element type (such as Cisco), then a logical name (Cisco_LA, or Cisco_NY, 
etc.) must be created for it during configuration. This helps to identify which particular 
Cisco router needs to be activated during Service Fulfillment Manager.

Definition Considerations
When configuring a fulfillment element, consider the following:

• A fulfillment element is always configured as an instance of a fulfillment element 
type.

• Attributes assigned to a fulfillment element type are inherited by the newly 
configured fulfillment element.

• Attribute values can be overwritten at the fulfillment element type level.

Understanding Services
In Oracle Service Fulfillment Manager, a service is a telecommunication-related 
product, offered to the customer as an individual item or in bundles.

Examples of services include:
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• Telephone services: Voice, data, videoconferencing, FAX, etc.

• Internet Protocol (IP) services: Web hosting, ecommerce, email, etc.

Service Versions
It is possible to define more than one version of a service in Oracle Service Fulfillment 
Manager. You set the begin dates and end dates for each service/product version 
individually. However, only one version of the service is available to a given customer 
at one time.

Work Items in Oracle Service Fulfillment Manager
Services provided by the carrier are fulfilled by a set of work items performed in a 
specific sequence within Oracle Provisioning. A work item, then, is a unit of work 
which is necessary to fulfil a service action. 

• You assign to a work item the appropriate parameters, fulfillment actions and 
fulfillment procedures necessary for the Service Fulfillment Manager process. 

• Fulfillment actions are responsible for the actual Service Fulfillment Manager of 
services at the fulfillment element level. 

• As an alternative to work items, users can execute the fulfillment actions 
conditionally in a user-defined workflow. The workflow is defined according to 
pre-set conditions in a service order request.

Work item Types
The available work item types are:

• Static: The list of fulfillment actions and their sequence are defined prior to runtime
and do not change.

• Dynamic: The list of fulfillment actions and their sequence are determined at 
runtime by executing a shared procedure.

• User-defined workflow: The list of fulfillment actions and their sequence are 
determined at runtime by a predefined workflow that executes multiple procedures
based on some pre-defined conditions.

• User workflow procedure: Sets the user-defined workflow that is to execute at 
runtime.
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Work Item Rules
Oracle Service Fulfillment Manager comes preseeded with a number of rules for 
adding, deleting, and modifying work items. They are used to determine dependencies 
between work items and to analyze the impact if a work item is modified or deleted.

Understanding Packages
A service package contains at least two products/services which are sold together as a 
unit. 

• A package may consist of either related or non-related services. 

• All attributes and rules that apply to a service also apply to a service package. 

• A service package must contain at least two mandatory products before it can be 
made available to customers. It can contain as many optional services as desired.

The dates of availability for the service package and the services/products within the 
package must be consistent. For example, you can not set the package available start 
date earlier than the earliest start date of all products in the package.

It is possible to add products/services to the package version. However, mutually 
exclusive products cannot be added to a package. In addition, products with 
dependencies (co-requisites) can not be added to a package unless the entire set is 
added.

During package creation, you must specify the minimum and maximum number of 
products the customer can order from a package that has optional products. For 
example, you may require that a customer pick at least three, but no more than five of 
eight possible services/products in the package.

Note: Once a product package has been defined and in the available 
state, it is not possible to modify or change the package. You must 
create a new version of the package to modify that package in any way.

Understanding Notifications
The Notifications module is a utility which provides a graphical interface for 
monitoring service request orders that fail during Service Fulfillment Manager. 

If a service order request fails, then the Service Fulfillment Manager workflow sends 
notifications about these failed service order requests to the Notifications utility, 
reporting Service Fulfillment Manager problems at various phases of the Service 
Fulfillment Manager process. 

Users with sufficient privilege can review and correct the failed orders through manual 
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intervention. The privileged user can, for example, perform the following tasks from 
within the Notifications utility:

• View order flowthrough.

• View workflow notifications for failed service order requests.

• Respond to a notification by assigning an error handling action to the service order 
request.

• Forward a notification to appropriate individuals or groups for resolution.

• Modify the service order request.

• View the workflow diagrams of order activities, using the Workflow Monitor.

If more details are necessary to asses the problem and resolve a failure, the privileged 
user can step through each of the failed notifications and view the actual Service 
Fulfillment Manager commands sent by a particular service order request to a 
fulfillment element and the responses to those commands.

Based on the information contained in the notification messages received in the 
Notifications utility, the privileged user can follow-up with service order requests or 
workflow that failed during the Service Fulfillment Manager process. 

Follow-up actions include the following:

• Sending the order/workflow back to the process after modifying the order

• Sending orders to other personnel for escalation or resolution

• Stopping the process altogether

The Notifications Utility
You view and access workflow notification messages through the Notifications utility. 

You can view:

• All messages (both open and closed)

• Only the open notification messages.

You can query messages based on the following criteria:

• Status

• Receive date

• Order number
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• Notification Type

Note: You can only search for orders which have their workflow 
started.

Messaging in Oracle Service Fulfillment Manage
Oracle Service Fulfillment Manager obtains messages which are initiated from 
workflows to communicate with external systems. A message can be used to initiate a 
Start Billing event with a billing system. Workflow can be configured to wait for 
inbound messages or can branch out to another workflow based on the information 
passed.

Message functions
The following are messages functions:

• Trigger a process

• Activate processes within an application

• Send application messages asynchronously using the Event Manager

• Receive application messages asynchronously using the Event Manager

• Handle incoming and outgoing messages and events using multiple queues and the
Event Manager

Message Definition
The following are ways to define a message:

• Message type: The message type defines a message either as a timer, an event, or a 
message.

• Messages are used for communication between application systems. 

• Events are used to broadcast multi-cast state changes in business objects. Events
are published to both external and internal application systems.

• Timers are messages that have a time delay and a duration interval associated 
with them.

• Message for internal applications: Internal applications can register a PL/SQL 
callback procedure via the Event Publisher or through an API.
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• Messages for external applications: External applications do not register callback 
procedures, but have adapters that relay the published event to the remote system. 
External applications can register for an event using the default subscribers screen.

Message Queues
Messages can go to multiple queues. The following are some of the queues where 
messages can reside:

• Inbound Message Queue: Messages are sent to this queue for internal processing.

• Outbound Message Queue: Messages are sent to this queue that are enroute to 
peer systems.

• Internal Event Queue: Messages defined as Events ignore the queue name and the 
event is published to both the Outbound Message Queue and the Internal Event 
Queue.

The table following lists the messaging queues and their attributes.

Queue Name Service Name Description

Inbound Message Queue Message Server Processes all incoming 
messages.

Internal Events Queue Event Server Events generated for internal 
consumption are enqueued 
on the internal events queue 
for speedy processing.

Outbound Message Queue Communication Adapters Dequeues messages from the 
Outbound Message queue 
and passes it to the peer 
system.

Outbound Message Structure
Outbound messages must have the following defined:

• Subscriber (system)

• Gateway name

• Adapter type
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Message Elements
Message elements in the iMessage Studio can be marked either as mandatory or 
optional.

During message creation, the iMessage Studio automatically inserts the Message Code 
and MESSAGE as mandatory message elements in the Elements screen. In addition, the 
message code is defined as the root element. However, it is possible to define an 
element more than once in the structure. 

Follow these guidelines during message creation:

• Message element names must follow PL/SQL naming conventions.

• The internal name for all message elements must be defined in upper case, 
replacing any spaces with an underscore. 

Warning: Never delete the root element of a message.

Message Elements
• Message elements marked as parameters automatically use the default value 

specified.

• Message elements marked as parameters are used to derive values of remaining 
message elements.

• Message elements marked as parameters are not passed in the content of the 
message body.

• Message elements marked as parameters generate CREATE_MSG(), SEND() and 
PUBLISH() procedures with the specified message element as a parameter 
defaulted to the message specified.

Mandatory Elements
• Message elements can be marked as mandatory or optional.

• Upon receiving an incoming message, the validation logic checks all mandatory 
message elements to ensure that values are in the correct data format.

Message Processing Logic
The Oracle Provisioning Event Manager handles all incoming messages and events. 
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There are four possible ways to process a message. The table following lists them.

Type Process Description

Default Process Logic DEFAULT_PROCESS() Automatically executed by 
the Event Manager if no 
application has registered for 
the message.

Validate Logic VALIDATE() Automatically executed by 
the Event Manager on the 
newly arrived messages.

The VALIDATE() procedure 
provides a hook to include 
business specific validation.

Incoming Message Process 
Logic

PROCESS() Executed by the Event 
manager before delivering the
message to the callback 
procedure of the registered 
application.

The PROCESS() procedure 
also provides a hook to 
include any application logic.

Outgoing Message Process 
Logic

SEND() Executed by the Event 
Manager before publishing a 
message to the Outgoing 
Queue for delivery.

These logic procedures are 
not generated automatically, 
they are user-defined and the 
code is executed as part of the
SEND() procedure.

Processing Failure
The Event Manager does not deliver a message to any registered applications if an error
is detected during the execution of the processing logic. Nor does the Event Manager 
process and deliver a message if the message validation process failed. If an error 
occurs, each resulting error code and error message are logged into the system log.
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Message Processing Logic - Guidelines
Use the following guidelines during creation of your message processing logic 
procedures.

1. If no application logic is specified, the procedure is created with a single NULL; 
statement

2. Any user defined data which is stored as part of the registration process is passed to
the procedure in the parameter p_process_reference.

3. The parameter p_msg_text is the XML message

4. Element values can be obtained using the following procedure: 

xnp_xml_utils.decode(). xnp_xml_utils.decode

This procedure works only if a message has no repeating elements.

5. User defined logic is required to return any error code and error message. This 
information must be passed using the parameters:

• x_error_code 

• x_error_message 

6. Any non zero value in x_error_code is considered to be an error.

Timers in Oracle Provisioning
In any reasonably complex business process, system and user generated business events
are continually occurring. These business events are not isolated, but are often required 
as triggers to further business processes. Such business processes may have time 
constraints. 

Timers in Oracle Provisioning are used to handle the events or processes that must 
occur at specified time intervals during the course of implementing complex business 
processes.

Timers in Oracle Provisioning are implemented using the Oracle Advanced Queuing 
mechanism, and the message builder features of the Oracle Service Delivery Platform.

Timer Definition
A timer is a message that consists of the following two elements:

• Delay: Represents the amount of time to wait before starting a timer. 
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• Interval: Represents the wait time for a timer.

Timer Categorization
Timers are divided into three categories in Oracle Provisioning:

• Activity Timer: The timer is associated with a particular activity within a workflow.

• Process Timer: The timer is associated with an entire workflow process.

• Message Timer: The timer is associated with a message.

Timer Usage in Oracle Provisioning
You use the iMessage Studio Message Framework to create the different types of timers 
that you use in Oracle Provisioning.

Timer Types
Oracle Provisioning comes with three different timer types. The table following 
describes each type.

Timer Type Description

Activity Timer The timer is associated with a particular 
activity within a workflow.

Process Timer The timer is associated with an entire 
workflow process.

Message Timer The timer is associated with a message.

Timer Elements
Timer messages requires two mandatory elements: 

• Delay

• Interval

Additional optional elements can also be related to a product type, customer category, 
or the service level agreement based on the business requirements of the user. 
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Timer Data
It is possible to set the delay and interval timer elements in several different ways:

• The user provides the data source for the timer elements. This feature is useful in 
retrieving the timer information from other timer configuration tables. 

• A stored procedure retrieves the timer delay and interval information. 

If desired, you can also set the processing logic that occurs when the timer expires. The 
processing logic may include jeopardy management or error processing features when 
the timer expires. 

Timer Testing 
You may also specify that a test message be sent to test that the Timer message has been
correctly configured.

Using Timers in Workflow
You can build timer functionality into your user-defined Workflow by using a set of 
drag-and-drop activities provided by Oracle Provisioning. These activities are part of 
the SDP Standard item type.

The table following lists the activities that can be associated with timers in Workflow:

Function Name Description

Deregister Remove all timers for a given order

Fire Timer Function to start either a process or activity 
timer

Send Message Function that sends a message which has a 
timer associated with it

Start Related Timers Function to start either an activity timer or a 
timer associated with a message

Subscribe to Acknowledgements Function to subscriber for possible results 
from the Send Message function

Get Jeopardy Flag Checks whether or not a jeopardy timer exists 
for a given order



Understanding Oracle Service Fulfillment Manager    1-35

Function Name Description

Get Timer Status Returns the status of a timer

Recalculate all timers Recalculates the delay and interval elements 
for all timers associated with the given the 
Work Item name, Instance ID, Order ID, or the
Fulfillment Action Instance ID.

Remove Timer Deletes the timer with the given name

Activity Timers in Oracle Service Fulfillment Manager
An Activity Timer is used in conjunction with a workflow activity. The purpose of an 
Activity Timer is to provide the ability to set a pre-defined period of time within which 
a workflow activity must be completed.

For example, a workflow activity is defined to check the network capacity for a 
requested data service. The time period to perform the workflow activity is set to 30 
minutes. An Activity Timer is then associated with the workflow activity to handle the 
required business logic if the 30 minute time frame for the activity is exceeded.

Process Timers in Oracle Service Fulfillment
A Process Timer is used in conjunction with a Workflow process. The purpose of a 
Process Timer is to provide the ability to set a pre-defined period of time within which a
Workflow process must be completed.

For example, a workflow process is defined to provide a requested data service. The 
time period to perform the Workflow process is set to one business day. A Process 
Timer is then associated with the workflow process to handle the required business 
logic if the one day time frame for the process is exceeded.
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Message Timers in Oracle Service Fulfillment
A Message Timer is used in conjunction with a message. The purpose of a Message 
Timer is to provide the ability to set a pre-defined period of time within which a 
message acknowledgment must be received.

For example, a workflow process is defined to set up an account for a network service. 
A message is sent to the associated network service administrator. If a reply is not 
received back with in 30 minutes, then the timer message is published and picked up by
the workflow activity that is Waiting for the Acknowledgments. The acknowledgment 
may be a message reply or a timer in which the workflow follows a path based on the 
message received.

The Waiting For Acknowledgments activity subscribes to events. An event can be 
configured to include an acknowledgment for the message sent out, as well as a timer. 
Depending on the message received, the workflow progresses.

Workflow in Oracle Service Fulfillment Manager
Workflows are processes that execute during the main Service Fulfillment Manager 
process to process and fulfill the order. Workflows can be run before starting the service
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Service Fulfillment Manager process.

You use the Oracle Workflow Builder to configure the workflows to be executed during
the Service Fulfillment Manager process. The workflow can be invoked for a work item 
or a fulfillment action. 

The main Service Fulfillment Manager workflow waits until all sub-processes complete 
their activities before continuing to fulfill the order.

If an error occurs during the main Service Fulfillment Manager process, you can 
intervene manually and launch appropriate workflows as the situation dictates. You 
can launch any workflow process in Oracle Provisioning, as necessary.

The Workflow Builder
Refer to the Oracle Workflow Guide for details of the workflow builder.

Workflow Processing of a Service Order Request
During the execution of a service order, the line items associated with it are processed 
by workflow. Which fulfillment procedures execute depend on the type and software 
generic of the fulfillment element configured in Oracle Provisioning. 

• The mapping between fulfillment procedure and fulfillment element is specified in 
the Service Creation Manager.

• The fulfillment procedure involves sending commands to a fulfillment element, 
receiving, and analyzing responses to determine success or failure of commands. 

• The procedures are written in PL/SQL which has been extended with open APIs.

• A watchdog workflow detects the termination of adapter processes and manages 
their recovery. 

• When all adapters for a given fulfillment element are shutdown, suspended, 
disconnected or goes down, all service order requests for that fulfillment element 
are queued until the adapter is up again and ready to process the next fulfillment 
action in the queue. 

Steps Involved in Processing a Service Order Request
A service order consists of many line items. A line item can be either a service or a 
package.

• Each line item can be mapped to multiple work items.

• Each work item is mapped to a set of fulfillment actions via different means. (For 
example, this could be either a static or dynamic fulfillment action, workflow, or a 
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workflow procedure.)

• Each fulfillment action invokes one fulfillment procedure at runtime depending on 
the type of fulfillment element.

• Each procedure is executed on one fulfillment element. 

• The identity of the fulfillment element to be provisioned is determined through 
routing rules implemented through user-defined PL/SQL procedure. 

• Error conditions detected during Service Fulfillment Manager cause the workflow 
to send error notifications.

• The workflow waits for the notification response. 

• The response indicates how the error condition is to be handled.

The Workflow Monitor
The Workflow Monitor utility provides a graphical interface to track a service order's 
path in Oracle Provisioning. When launched, it opens in a web browser screen. The 
browser screen displays the runtime path for the order within the Oracle Service 
Delivery Platform.

Using the graphical interface, you can:

• View each activity performed on an order. 

• View the route of an order from the beginning to the end. 

• Retrieve statistical information and branching activities for each node displayed on 
the workflow path.

Workflow Information Types
Oracle Provisioning workflow provides the following categories of information:

• Definition: The definition of the actual activity as defined in the Workflow. This also 
includes the description of the activity, its type and its results.

• Usage: The location, start/end status, performer, and time-out status information.

• Status: The status of execution of a particular activity, the begin and end dates for 
the activity.

• Notification:The recipient, the current status, the date sent, due date and end date for
a given notification.
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Understanding the Procedure Builder
Oracle Provisioning provides a procedure builder tool that you use to write PL/SQL 
based procedures. PL/SQL procedures must be defined before processing a service 
order request.

The procedure builder comes with a library of constructs (building blocks) that you can 
use to write procedures. These procedures, then, are used during the various phases of 
Service Fulfillment Manager a service order. 

Note: It is expected that the user-defined procedures are written by 
system experts who have knowledge of the Service Fulfillment 
Manager syntax and service parameters required for the fulfillment 
element. They must also have good knowledge of PL/SQL. 

Procedure types
The different procedures types are: 

• Connect and disconnect: The connect procedure is used to connect Oracle 
Provisioning to a fulfillment element when the Oracle Service Fulfillment Manager 
application is started. Similarly the disconnect procedure disconnects Oracle 
Provisioning from a fulfillment element. 

You can choose from a set of PL/SQL constructs which can be used to write 
connection/disconnection procedures for multiple fulfillment elements.

• Fulfillment element routing: The Locate Fulfillment Element procedure returns the
fulfillment element that should be provisioned.

• Dynamic work item-fulfillment action mapping: If you choose the work item type 
to be of type dynamic, you must use the procedure builder to define the procedure 
that is executed when the order is sent to Oracle Service Fulfillment Manager. This 
procedure specifies the fulfillment actions to be executed for the work item.

• Work item parameter evaluation: The evaluation procedure evaluates the 
parameter values for the work item parameters. 

• Fulfillment action parameter evaluation: The evaluation procedure evaluates the 
parameter values for the fulfillment action parameters.

• User-defined workflow: This procedure is used to launch a user defined workflow.
A workflow can consist of multiple procedures to be executed in a pre-set sequence.

• Dynamic service to work item mapping: This procedure specifies at runtime which
work items will be executed to fulfill the service.
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• Evaluate all fulfillment action parameters: This evaluation procedure is used to 
evaluate all the fulfillment action parameters together.

• Fulfillment procedure: This procedure specifies the Service Fulfillment Manager 
commands that need to be executed in fulfilling a service order.
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2
Using Oracle Service Fulfillment Manager

This chapter covers the following topics:

• Managing Notifications

• Viewing Notifications

• Adding Comments to a Notification Message

• Responding to a Notification Message

• Forwarding a Message Notification

• Resubmitting an Order

• Creating a New Resubmission Job

• Verifying the Status of a Resubmission Job

• Managing the System Queues

• Viewing Summary Information about Queues

• Finding an Order in the Queue

• Viewing Errors in a Queue

• Starting Up a Queue

• Shutting Down a Queue

• Suspending a Queue

• Resuming Queue Operation

• Viewing XML Messages

• Managing Network Connections

• Monitoring Network Connections

• Defining a New Adapter

• Redefining an Adapter

• Scheduling an Adapter
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• Deleting an Adapter

• Viewing Adapter Request Errors

• Issuing a Disconnect Request

• Issuing a Connect Request

• Issuing a Suspend Request

• Issuing a Resume Operation Request

• Managing Services

• Configuring Services

• Defining a New Service

• Associating Actions with a Service

• Associating Work Items with Service Actions

• Editing an Existing Action

• Deleting a Service

• Managing Packages

• Defining a New Service Package

• Associating Services with Packages

• Managing Work Items

• Defining a New Work Item

• Deleting a Work Item

• Defining a New Work Item Parameter

• Adding Parameters to a Work Item

• Associating Fulfillment Actions with Work Items

• Managing Fulfillment Actions

• Configuring Fulfillment Actions

• Adding Parameters to a Fulfillment Action

• Associating a Fulfillment Procedure with a Fulfillment Action

• Modifying a Fulfillment Action Procedure

• Overview of Oracle Service Fulfillment Manager

• Creating a New Procedure

• Deleting an Existing Procedure

• Viewing Procedure Parameters

• Editing an Existing Procedure
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• Managing Fulfillment Element Types

• Defining a Fulfillment Element Type

• Deleting a Fulfillment Element Type

• Managing Fulfillment Elements

• Defining a New Fulfillment Element

• Deleting a Fulfillment Element

• Modifying a Fulfillment Element Configuration

Managing Notifications
From the Notification Inbox, you can take various actions to deal with workflow 
notification. For example, you can perform the following tasks:

• Viewing notifications, page 2-3

• Adding comments to a notification message, page 2-4

• Responding to a message notification, page 2-4

• Forwarding a message notification, page 2-5

Viewing Notifications
To view the existing notification messages in the system, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Operations > Notifications

2. Click View Open to view only those notification messages that are currently open.

3. Click View All to view notification messages, regardless of status.

4. Select a notification from the list at the left.

The Notification Message Details window opens.

5. Close the window after viewing the information.



2-4    Oracle Service Fulfillment Manager Concepts and Procedures

Adding Comments to a Notification Message
To add a comment to a notification message, perform the following steps.

Prerequisites
The message must exist for this option to be available.

Steps
1. In the Navigator, choose Operations > Notifications

2. Select a notification from the list at the left.

3. Click View Details

The Notification Message Details window opens.

1. Click Add Comment to launch the Notification Comment window. 

2. Enter your comments about the notification in the space provided. 

3. Close the window. You are prompted to save your changes.

Responding to a Notification Message
To respond to a notification message, perform the following steps. Responding to a 
notification changes its status from Open to Closed.

Prerequisites
The status of the message must be Open for this option to be available.

Steps
1. In the Navigator, choose Operations > Notifications

2. Select a notification from the list at the left.

3. Click View Details

The Notification Message Details window opens.

1. Click Respond to launch the Notification Response window.

2. Select one of the following responses from the drop down menu.
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• Abort: Terminate the process and close the order.

• Resolved: Ignore the reported causes of failure and continue processing the 
order.

• Retry:Retry the execution of the failed order.

3. Click OK to close the window and initiate the action.

Note: The Close Notification response is available for all of the 
information types. The status of a notification stays Open until you 
respond to it.

Forwarding a Message Notification
To forward the notification to a third party, perform the following steps.

Prerequisites
The status of the message must be Open for this option to be available.

Steps
1. In the Navigator, choose Operations > Notifications.

2. Select a notification from the list at the left.

3. Click View Details.

The Notification Message Details window opens.

1. Click Forward to launch the Notification Response window. 

2. Select another user or group from the drop-down menu.

3. Click OK to close the window and reassign the message.

Note: When a notification is reassigned, it is marked as Closed.

Resubmitting an Order
You use the Resubmission Utility to re-run orders that have been previously submitted 
to the Service Delivery Platform Service Fulfillment Manager engine. This is useful, for 



2-6    Oracle Service Fulfillment Manager Concepts and Procedures

example, if a network switch fails, or experiences service disruption that causes a 
Service Fulfillment Manager order to fail. The order, however, has not been lost by the 
system, and can be resubmitted when the unit becomes available.

For example, a particular fulfillment element fails at 3:02 a.m. on a particular date. It 
remains unavailable for service until 5:20 a.m. the same day. This fulfillment element 
was to be used to provision a number of orders during that span of time, but as it was 
unavailable, the orders failed to complete. After the fulfillment element (or its 
replacement) becomes available, it is necessary to resubmit all orders that were to be 
provisioned by that particular fulfillment element during the window of time from 3:02 
to 5:20 a.m. The order information is not lost, and can be re-used to resubmit the 
original Service Fulfillment Manager orders.

You use the Resubmission Utility to perform the following tasks.

• Creating a new resubmission job, page 2-6

• Verifying the status of a resubmission job, page 2-7

Creating a New Resubmission Job
To re-submit all orders that were to be provisioned by a specific fulfillment element 
during a span of time (but were not provisioned), perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Operations > Order Resubmission.

The Order Resubmission Jobs form window opens. Previously defined resubmission 
jobs display under Job ID (Fulfillment Element) at the left-hand side of the screen.

1. Click New.

The New Job Window opens. You use this window to create a new resubmission 
job that targets a specific fulfillment element during a specified time window.

2. Enter the name of the fulfillment element for which you wish to resubmit orders. 

Chose a fulfillment element from the List of Values (LOVs). 

3. Enter the exact date and time at which the fulfillment element became unavailable 
in the Outage Start Date field. And, if desired, enter the exact date and time that the 
fulfillment element became available again.

4. Enter the number of adapters that this affects in the No. of Adapter field.
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5. Click Submit.

The job displays in the Job ID (Fulfillment Element) window. You can track the 
progress of order resubmission process through the Job ID.

6. Click Cancel to close this window.

Verifying the Status of a Resubmission Job
To view the status or details of a resubmission job, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Operations > Order Resubmission.

The Order Resubmission Jobs form window opens. Previously defined resubmission 
jobs display under Job ID (Fulfillment Element) at the left-hand side of the screen.

1. Select the Job ID from the list at the left.

The pertinent information for the resubmission job displays.

2. Click Order List.

The Resubmitted Order Information window opens. This window displays 
information about each individual order. 

3. Click Cancel to close the Resubmitted Order Information window.

4. Click Cancel to close the Order Resubmission Jobs window.

Managing the System Queues
You perform a number of tasks with system queues. These include:

• Viewing summary information about queues, page 2-8

• Finding an order in the queue, page 2-9

• Viewing errors in a queue, page 2-9

• Starting up a queue, page 2-10
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• Shutting down a queue, page 2-11

• Suspending a queue, page 2-11

• Resuming queue operation, page 2-12

• Viewing XML messages, page 2-12

Viewing Summary Information about Queues
The Queue Console displays the following summary information about all of the 
system queues.

• State (Enabled, Shutdown, Suspended)

• Number of entries in the queue

• Date that the last entry in the queue occurred

• Number of dequeue processors that are registered

• Number of processors that are currently running for the queue

To display this information, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

1. Select a queue from the list at the left.

The View Details button is enabled if there are entries in the queue, otherwise it is 
grayed out.

2. Click View Details to view additional information about the entries in a queue.

A window opens that displays the entries for the queue.

3. Close this window and return to the Queue Console by clicking the X in the upper 
right-hand corner of the window.
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Finding an Order in the Queue
To search for an order that is currently in the queue, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Administration > Queue Console.

The Queue Console opens.

1. Select a queue from the list at the left.

The View Details button is enabled if there are entries in the queue, otherwise it is 
grayed out.

2. Click View Details.

A window opens that displays the entries for the queue.

3. (Optional) Select View > Query By Example > Enter from the View menu on the 
toolbar to find a specific order in the queue, or to find entries that match a search 
criteria.

4. (Optional) Enter the search criteria in the provided fields.

5. Select View > Query By Example > Run from the View menu on the toolbar.

If one, or more records are found that match the search criteria, then the 
information displays.

6. Select View > Query By Example > Cancel from the View menu on the toolbar to 
close the window and return to the Queue Console.

Note: If there are a large number of orders in the queue, this action 
may take several seconds to complete.

Viewing Errors in a Queue
A queue becomes disabled if an error is detected while processing orders. You mange 
this problem by performing the following actions:

• Viewing the cause of the error that caused this state to occur
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• Correcting the problem the caused the error to occur

• Re-starting the queue

To view errors within a queue, perform the following steps.

Prerequisites
The queue must be in Disabled mode for you to perform this operation.

Steps
1. In the Navigator, choose Administration > Queue Console.

2. Select a queue from the list at the left that is listed as Disabled.

The View Errors button is enabled if the queue is disabled.

1. Click Show Content.

2. Correct the problem. 

3. Shutdown the queue.

See Shutting Down a Queue, page 2-11 for details of this procedure, if necessary.

4. Start up the queue.

See Starting Up a Queue, page 2-10 for details of this procedure, if necessary.

Note: Orders remain in the queue until the queue is shutdown and 
started again.

Starting Up a Queue
To start all processors of the queue, perform the following steps.

Prerequisites
The queue must be in Shutdown mode for this option to be available.

Steps
1. In the Navigator, choose Administration > Queue Console.

2. Select a queue from the list at the left.
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If the queue is in Shutdown mode, the Startup button is enabled.

1. Click Startup. 

2. The Queue Status changes to Enabled.

Shutting Down a Queue
To shut down all processors of the queue, perform the following steps.

Prerequisites
The queue must be in either the Enabled or Disabled mode for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Queue Console.

2. Select a queue from the list at the left.

3. Click Shutdown. 

The Queue Status changes to Shutdown.

Suspending a Queue
To suspend processing of orders in the queue, perform the following steps.

Prerequisites
The queue must be in either the Enabled or Disabled mode for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Queue Console.

2. Select a queue from the list at the left.

If the queue is in Enabled or Shutdown mode, the Suspend button is enabled.

1. Click Suspend. 

The Queue Status changes to Disabled.
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Resuming Queue Operation
To resume processing orders in the queue, perform the following steps.

Prerequisites
The queue must be in the Disabled mode for this option to be available.

Steps
1. In the Navigator, choose Administration > Queue Console.

2. Select a queue from the list at the left.

If the queue is in Disabled mode, the Resume button is enabled.

1. Click Resume. 

The Queue Status changes to Enabled.

Viewing XML Messages
To view the XML content for a message that is currently in the queue, perform the 
following steps.

Prerequisites
To view XML message content, you must select either the Outbound Messages queue, 
the Inbound Messages queue, or the Event queue, and you must have an XML-enabled 
browser available to display XML messages.

Steps
1. In the Navigator, choose Administration > Queue Console.

2. Select a queue from the list at the left.

The View Details button is enabled if there are entries in the queue, otherwise it is 
grayed out.

1. Click View Details.

A window opens that displays the entries for the queue.

2. Select a message from the list at the left.
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3. Click View XML.If available, an XML-enabled browser window opens and displays
the XML message. 

Managing Network Connections
You use the Connection Manager to manage all types of fulfillment elements and their 
network adapters. The Connection Manager is used to control network connections.

You perform the following tasks using the Connection Manager:

• Monitoring network connections, page 2-13

• Defining a new adapter, page 2-14

• Redefining an adapter, page 2-15

• Scheduling an adapter, page 2-15

• Deleting an adapter, page 2-16

• Viewing adapter request errors, page 2-17

• Issuing a disconnect request, page 2-17

• Issuing a connect request, page 2-18

• Issuing a suspend request, page 2-18

• Issuing a resume operation request, page 2-19

Monitoring Network Connections
To view the network associated with a fulfillment element, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Administration > Connection Manager.

The Connection Manager opens.

1. Click Define and enter a filtering value if you wish to parse the list of fulfillment 
elements that display in the left-hand frame. 
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Conversely, click Reset to view all defined fulfillment elements.

2. Select a fulfillment element from the list.

3. Select the Adapters tab to view information about network adapters.

4. Select the adapter type to view from the Usage drop-down list. Your choices are:

• All Types

• Messaging

• Order resubmission

• Service Fulfillment Manager

• Testing

5. Choose one of the following:

• Chose the Adapters sub-tab to view information about the current status of an 
adapter.

• Chose the Modes sub-tab to view information about Startup and Debug modes 
for an adapter.

• Chose the Requests sub-tab to view to view information about how the adapter 
has been scheduled.

6. To close the form window, click the x in the right-hand corner of the form window.

Defining a New Adapter
To define a new adapter in the system, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the Adapters tab.

3. Click New... to open the Adapter Properties dialog box.
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4. Enter a name for the new adapter.

5. Select a value from the Usage drop-down list. 

6. Select a value from the Startup Mode drop-down list.

7. Select a value from the Debug Mode drop-down list of values.

8. Click OK to define the new adapter and close the dialog box.

The new adapter now displays in the list of adapters.

Warning: You can start a new adapter only if it does not exceed the 
maximum number of connections allowed (or configured) for that 
specific fulfillment element.

Redefining an Adapter
To edit an adapter definition, perform the following steps.

Prerequisites
The Current Status field for the adapter must display Shutdown for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list at the left.

3. Select the Adapters tab.

4. Click Edit. 

The Adapter Properties dialog box displays.

1. Make changes as necessary.

2. Click OK to redefine the adapter and close the dialog box.

Scheduling an Adapter
To schedule a request for an adapter, perform the following steps.
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Prerequisites
You can not schedule a request prior to the current date and time.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. elect the Adapters tab.

3. Click Schedule... to open the Adapter Request dialog box.

4. Chose a value from the Request Type drop-down list of values.

5. Chose a date and time for the request to execute the request. (If desired, open the 
Calendar function by clicking the [...] at the edge of the Date/Time field.)

6. To issue the request immediately, enter the current date and time.

7. To postpone the execution of the request, enter a future date.

8. Enter the period (in days) that the adapter request is to repeat by entering a value in
the Repeat Every (days) field. 

9. To schedule a request only once, leave this field blank.

10. Click OK to schedule the request and close the dialog box.

Note: To delete a scheduled request, select it and click Delete.

Deleting an Adapter
To delete an adapter from the system, perform the following steps.

Prerequisites
The Current Status field for the adapter must display Shutdown for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter to delete from the list of adapters.
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3. Click Delete.

The adapter no longer displays in the list of adapters.

Viewing Adapter Request Errors
If an adapter request causes an error condition, the Current Status field for that adapter 
displays Error. 

To view details of the error condition, perform the following steps.

Prerequisites
The Current Status field for that adapter must display Error for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.

4. Click Show Error. 

The time the error message occurred and the text of the error message display.

1. Click OK to close the Error Message window.

Issuing a Disconnect Request
To issue a disconnect request to an adapter, perform the following steps.

Prerequisites
The Current Status field for that adapter must display Idle for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.



2-18    Oracle Service Fulfillment Manager Concepts and Procedures

4. Click Disconnect. 

The Current Status field for this adapter now displays Disconnected.

Issuing a Connect Request
To issue a connect request to an adapter, perform the following steps.

Prerequisites
The Current Status field for the adapter must display Disconnected for this option to be 
available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.

4. Click Connect.

The Current Status field for this adapter now displays Idle.

Issuing a Suspend Request
To issue a suspend request to an adapter, perform the following steps.

Prerequisites
The Current Status field must display Idle for this option to be available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.

4. Click Suspend.

The Current Status field for this adapter now displays Suspended.
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Issuing a Resume Operation Request
To issue a resume request to an adapter, perform the following steps.

Prerequisites
The Current Status field must display Suspended for this option to be available.

Steps
1. In the Navigator, choose Administration > Connection Manager.

2. Select the adapter from the list of adapters at the left.

3. Select the Adapters tab.

4. Click Resume.

The Current Status field for this adapter now displays Idle.

Managing Services
You perform a number of tasks with services. These include:

• Defining a new service, page 2-20

• Associating actions with services, page 2-21

• Associating work items with service actions, page 2-22

• Editing an existing action, page 2-23

• Deleting a service, page 2-24

For the steps and tasks associated with setting up a service, see Configuring Services, 
page 2-19 for an overview of the processes involved.

Configuring Services
The tasks necessary to configure a service are described in the following steps.

Prerequisites
None
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Steps
In configuring services, you must define all of the following items.

Item See

The details of the service (for example, 
version, description and activation dates)

Defining a New Service

The actions available for a specific service and 
version

Associating Actions with a Service

The work items used by the service actions Associating Work Items with Service Actions

Defining a New Service
Services are also referred to as products or service offerings. In each case, however, they
represent services deployed by a service provider who delivers, activates, maintains 
and bills a subscriber for it.

To define a new service, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select the Details tab.

3. Click the New icon on the task bar.

This action causes a blank entry to display in the Services list at the left.

1. Enter a value for the Display Name.

This is the name of the service that is to display in the audit trail and during 
configuration.

2. Enter a value for the Internal Name.

This is the name for the service that is to be used internally by the system during 
Service Fulfillment Manager.
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3. Enter a version number.

4. Check the Provision this Service box.

• If you check this box, then you can submit an order against the service.

• If you do not check this box, then the configuration of this service is still in 
progress, and an order can not be submitted against the service.

5. Enter a short description in the Description field. 

6. Enter the effective date for this service to become active. 

7. Enter the effective date for this service to become inactive.

8. Enter a value for Responsibility.

This sets who is responsible to maintain this information. 

9. Close the window.

You are prompted to save your changes.

To complete the definition, you need to associate an action with this service.

Associating Actions with a Service
An action is an operation performed on a service, product, and package. It instructs the 
Service Delivery Platform to internally call pre-defined sets of activities, rules, or data. 

For every service that you define, you need to assign an action for Service Fulfillment 
Manager that desired service. A service combined with an action creates the definition 
of an order line item.

You can repeat an action across various services, however, this action may not 
necessarily be valid across all fulfillment elements. 

To create a new service action, perform the following steps.

Note: It is possible to associate multiple actions with a single service.

Prerequisites
You must define a service before associating actions with it. (You may also reuse an 
existing service.) See Defining a New Service, page 2-20 for details.
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Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select the Actions tab.

3. If you do not see the name of the desired action in the Available box, enter the name
of the action in the Filter field and click the Find icon to search for it.

4. If the action is not defined yet, click Define Actions to open the Define Actions 
window and then add it.

5. Use the arrow buttons to move your choice from the Available Actions list to the 
Selected Actions list.

6. Enter a value for the Start Date. 

This is the date at which this action becomes available to the service.

1. Enter a value for the End Date. 

This is the date at which this action becomes unavailable.

2. Enter a Description for this action.

3. Enter a name for the Work Item Mapping Procedure. 

If necessary, click the Add/Edit Procedure icon to launch the procedure builder and
define a new procedure. See Using the Procedure Builder, page 2-37 for details of 
this process.

Associating Work Items with Service Actions
To associate a work item with a service action, perform the following steps.

Prerequisites
Each service action can have one or more work items defined for it. However, there 
must be at least one work item for any available service action.

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select a service from the list at the left.

3. Select the Work Items for Action tab.
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4. Select an action from the drop down list of available actions associated with this 
service.

If you do not see the action that you desire, you need to select the Actions tab and add 
the desired action to the list of Selected Actions. 

1. Select a work item from the Available Work Items list.

• If you do not see the name of the desired work item in the Available box, enter 
the name of the work item in the Filter field and click the Find icon to search for
it.

• If the work item is not defined, click Define Work Items to open the Define 
Work Items window and then add it. See Defining a New Work Item, page 2-
27 for details, if necessary.

2. Use the arrow buttons to move your choice from the Available Work Items list to 
the Selected Work Items list.

3. Enter a Service Fulfillment Manager Sequence numb er for each item in the Selected
Work Items list. 

• Fulfillment actions marked with a 1 have no dependencies on other fulfillment 
actions and are processed in parallel with all other fulfillment actions marked 1.

• Fulfillment actions marked with a 2 have a dependency on another fulfillment 
action, and are processed after all fulfillment actions marked with a 1 are 
processed.

4. Enter a descriptive comment in the Details of a Selected Work Item field, if desired.

5. Repeat steps 4 through 8 as many times as necessary.

6. Close the window. 

You are prompted to save your changes. to save and exit.

Editing an Existing Action
To edit an existing service action, perform the following steps.

Prerequisites
None
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Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select the Action tab.

3. Click Define Actions.

4. Select an existing action from list.

5. Modify the action parameters as desired.

6. Close the window.

You are prompted to save your changes.

Deleting a Service
To delete a service, perform the following steps.

Prerequisites
You can not delete a service if either the following conditions is true:

• If the allowable actions on the service have previously been defined.

• If orders have been running for that service.

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select a service from the list at the left.

3. Click Delete.

The service disappears from the list.

1. Close the window. 

You are prompted to save your changes.

Managing Packages
You perform several different tasks with service packages. These include:
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• Defining a new service package, page 2-25

• Associating services with packages, page 2-25

Defining a New Service Package
To create a new package of services, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Packages.

2. Select the Details tab.

3. Enter a value for the Display name. 

This is the name of the package that is to display in the audit trail and during 
configuration.

1. Enter a value for the Internal name. 

The system stores this name in its database to identify the package. (Use 
underscores rather than blanks in the package name.)

2. Enter a value for the Description.

3. Enter a value for the Start Date.

This is the date at which this package becomes available.

4. Enter a value for the End Date.

This is the date at which this package becomes unavailable.

5. Close the window. 

You are prompted to save your changes.

Associating Services with Packages
To associate a service with a package, perform the following steps.
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Prerequisites
You must define the service package before you add services to it. See Defining a New 
Service Package, page 2-25.

Steps
1. In the Navigator, choose Setup > Service Definitions > Services.

2. Select the Services tab.

3. Select a service from the Available Services list.

4. If you do not see the name of the desired service in the Available box, enter its 
name in the Filter field and click the Find icon to search for it.

5. If the service is not defined yet, click Define Services and then add it. See Defining 
a New Service, page 2-20.

6. Use the arrow buttons to move your choice from the Available list to the Selected 
list.

7. Enter an Activation Sequence value for each service listed under Selected Services. 

This value determines the order in which the listed services are activated.

1. Check Service Fulfillment Manager Required if this service is to be provisioned by 
the Service Delivery Platform.

• If you check this box, then the service is provisioned through the Service 
Delivery Platform

• If you do not check this box, then the service is defined within the Service 
Delivery Platform Configurator, but is not necessarily activated through the 
Service Delivery Platform. 

This feature enables Service Providers to implement the identical service name 
among different Service Fulfillment Manager medium without conflict.

2. Enter a comment in the Comment field, if desired. 

3. Close the window. 

You are prompted to save your changes.
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Managing Work Items
You perform a number of tasks with work items. These include:

• Defining' a new work item, page 2-27

• Deleting a work item, page 2-29

• Defining a new work item parameter, page 2-29

• Adding parameters to a work item, page 2-30

• Associating fulfillment actions with work items, page 2-32

Defining a New Work Item
To define a new work item, perform the following steps.

Prerequisites
If you plan to associate a workflow with this work item, then you must create the 
workflow before you create the work item.

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Click the New icon on the toolbar. 

This action causes a blank Details window to display.

1. Enter the Display name. 

System screens display this name for the work item.

2. Enter an Internal name. 

The system stores this name for the work item in its database. 

3. Enter the Version. 

The Service Delivery Platform allows multiple versions of a work item.

4. Enter the Duration. 

The work item stays active for this length of time.

5. Enter a Description for this work item.
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6. Enter the Begin Date. 

The work item becomes available on this date.

7. Enter the End Date. 

The work item is no longer available after this date.

8. Chose a Work Item Type from the drop down list.

See Guidelines, page 2-28.

9. Chose a user role from the drop down list for Responsibility.

This determines who is responsible to maintain this information (a user, a group, or
a user group). It can also be used for fault resolution assignment (i.e., assigning it to 
the person responsible for ensuring that the problem is resolved).

10. Close the window. 

You are prompted to save your changes.

Guidelines
Use the following information in determining the type of work item to choose.

Work Item Type Comments

Static If selected, then you must also define the 
fulfillment actions associated with this work 
item.

Dynamic If selected, then you must also select a 
procedure from a list of existing procedures or
create a new procedure. The procedure 
determines the list of fulfillment action's and 
their sequence at runtime.

User-defined workflow If selected, enter the Item Type, Process and 
Key Prefix.

You must also enter the name of the workflow
that you have created. (Remember that any 
workflow that you create must be saved to the
general Service Delivery Platform engine 
before it is accessible for use.)
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Work Item Type Comments

User workflow start procedure If selected, then you must enter the name of 
the workflow procedure also, or define a new 
one.

Deleting a Work Item
To delete an existing work item, perform the following steps.

Prerequisites
The data must be visible in your log in role for you to delete it.

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Select a work item from the list at left.

3. Click Delete. 

The system performs a validation procedure to determine that there are no ill effects to 
deleting this work item. For example, it checks to see that no parameters or fulfillment 
actions are assigned to the work item to be deleted. If it passes the validation procedure,
then the work item is deleted by the system and it is removed from the list.

Defining a New Work Item Parameter
To define a new work item, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Select the Parameters tab.

3. Click Define Parameters.
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The Define Parameters window opens.

1. Click the New icon on the toolbar.

A blank entry opens in the Display Name list at the left.

2. Enter a value for the Internal Name of the parameter.

The Service Delivery Platform stores this name in its database fro internal use by 
the system.

3. Enter a description for the new parameter.

4. Close the window.

You are prompted to save your work.

Adding Parameters to a Work Item
To add parameters to a work item, perform the following steps.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Select the Parameters tab.

3. Select a parameter from the Available Parameters list.

4. Use the arrow buttons to move your choice from the Available list to the Selected 
list

5. (Optional) Enter a Display Sequence number for each item in the Selected 
Parameter list. 

This value determines the order in which the parameter displays in the work item 
sequence.

6. (Optional) Enter a Evaluation Sequence number for each item in the Selected 
Parameter list. 

This value determines the order in which the work item evaluates the parameter.

7. Check the Required box if this parameter must be present in order to provision the 
service.
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8. Check the Log in Audit Trail box if this parameter is to be logged and visible in the 
audit trail.

Parameters that have this box checked (and are actually used with an order), 
become visible in the audit trail.

9. Enter a Default Value, if desired. 

10. Enter a value in the Value Lookup SQL field. 

This value is an SQL statement that evaluates the parameter value. If necessary, 
click Edit Lookup SQL to launch the SQL editor.

11. Enter a mode for when evaluation of this parameter occurs, if desired. 

The available choices are:

• Upon order receipt

• When Service Fulfillment Manager order

See the Work Item Mode Guidelines, page 2-31 following for considerations on
choosing a work item mode.

12. (Mandatory, if a mode is selected, otherwise, ignore.) Enter a name for the 
procedure to be used in evaluating the parameter value. 

If necessary, click the Add/Edit procedure icon to launch the procedure builder and
define a new procedure. See Using the Procedure Builder, page 2-37 for details of 
this process.

13. Close the window.

You are prompted to save your work.

Work Item Mode Guidelines
You may wish to review the following information before selecting a work item mode.

Order Receipt

If you select Upon Order Receipt, then you must also define a name for the procedure 
and write the body for the evaluation procedure.

The following steps are performed by the Service Delivery Platform if a parameter is 
marked as Upon Order Receipt. The Service Delivery Platform:

• Receives an order from the upstream system with the parameter and its value.

• Performs validation on the parameters.

• Executes the evaluation procedure.
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• Stores the value of the parameter returned from the evaluation procedure. (This 
value is used in further processing.)

Order Service Fulfillment Manager

If you select Upon Service Fulfillment Manager Order, then you must also define a 
name for the procedure and write the body for this procedure. 

The following steps are performed by the Service Delivery Platform if a parameter is 
marked as When Service Fulfillment Manager Order. The Service Delivery Platform:

• Receives an order from an upstream system with the parameter and its value.

• Performs validation on the parameters.

• Stores the value of the parameter as is, without any further manipulation.

• At runtime, whenever the parameter is referenced, the associated When Service 
Fulfillment Manager Order procedure is executed to obtain the new value.

• The new value is used for order processing.

Associating Fulfillment Actions with Work Items
To associate a fulfillment action with a work item, perform the following steps.

Prerequisites
You can only associate fulfillment actions with either static or dynamic work items.

Steps
1. In the Navigator, choose Setup > Service Definitions > Work Items.

2. Select a work item from the list at left.

3. Select the Fulfillment Actions tab.

The work item type must be static for the Fulfillment Actions tab to be accessible.

1. Select a fulfillment action from the Available Fulfillment Actions list.

• If you do not see the name of the desired fulfillment action in the Available box,
enter the name of the fulfillment action in the Filter field and click the Find icon
to search for it.

• If the user account is not defined yet, click Define Fulfillment Actions to open 
the Define Fulfillment Actions window and then add it. See Configuring 
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Fulfillment , page 2-33Actions for details on adding a new fulfillment action.

2. Use the arrow buttons to move your choice from the Available Fulfillment Actions 
list to the Selected Fulfillment Actions list.

3. Enter a Service Fulfillment Manager Sequence number for each item in the Selected 
Fulfillment Actions list. 

4. Fulfillment actions marked with a 1 have no dependencies on other fulfillment 
actions and are processed in parallel with all other fulfillment actions marked 1.

5. Fulfillment actions marked with a 2 have a dependency on another fulfillment 
action, and are processed after all fulfillment actions marked with a 1 are processed.

6. Enter a Comment for this fulfillment action, if desired.

7. Close the window.

You are prompted to save your work.

Managing Fulfillment Actions
You perform a number of tasks with fulfillment actions. These include:

• Configuring fulfillment actions, page 2-33

• Adding parameters to a fulfillment action, page 2-34

• Associating a fulfillment procedure with a fulfillment action, page 2-36

• Modifying a fulfillment action procedure, page 2-36

Configuring Fulfillment Actions
To define a new fulfillment action, perform the following steps.

Prerequisites
You must perform the following tasks before configuring fulfillment actions:

• Configure parameters: See Adding Parameters to a Work Item, page 2-30.

• Configure fulfillment element types: See Defining a Fulfillment Element Type, 
page 2-41.

• Configure fulfillment elements: See Defining a New Fulfillment Element, page 2-
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.

• Build the fulfillment procedures: See Using the Procedure Builder, page 2-37.

Steps
1. In the Navigator, choose Setup > Service Definitions > Fulfillment Actions.

The Fulfillment Actions window opens.

1. Click the New icon on the toolbar, or chose File > New from the menu.

A new, blank entry opens in the Fulfillment Actions list at the left.

2. Enter a value for the Display name. 

This is the name of the fulfillment action that is to display in the audit trail and 
during configuration.

3. Enter a value for the Internal name. 

This is the name for the fulfillment action that is to be used internally by the system 
during Service Fulfillment Manager.

4. Enter the Version number for this fulfillment action.

5. Enter a value for the Description.

6. Chose one of the available Fulfillment Element Routing procedures from the drop 
down list. 

If necessary, click the icon next to the Procedure field and create a routing 
procedure for use here. See Using the Procedure Builder, page 2-37 for details.

7. Enter a value for Evaluate a Parameter. 

If necessary, click the icon next to the Procedure field and create an evaluation 
procedure for use here. See Using the Procedure Builder, page 2-37 for details. 

8. Chose a Responsibility from the drop down list, if desired. 

If this field is left blank, any user role can use this fulfillment action.

9. Click the Save icon on the toolbar.

Adding Parameters to a Fulfillment Action
To associate parameters with a fulfillment action, perform the following steps.
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Note: A fulfillment action can have more than one parameter associated
with it.

Prerequisites
None

Steps
1. In the Navigator, choose Setup > Service Definitions > Fulfillment Actions.

2. Select a fulfillment action from the list at the left

3. Select the Parameters tab.

4. Select a parameter from the Available Parameters list.

• If you do not see the name of the desired parameter in the Available box, enter 
its name in the Filter field and click the Find icon to search for it.

• If the parameter is not defined yet, click Define Parameters and then add it. See
Defining a New Work Item Parameter, page 2-29 for details.

5. Use the arrow buttons to move your choice from the Available list to the Selected 
list.

6. (Optional) Enter a Display Sequence number for each item in the Selected 
Parameter list. 

This value determines the order in which the parameter displays in the fulfillment 
action sequence.

1. Check the Log in Audit Trail box if this parameter is to be logged and visible in the 
audit trail.

2. Enter a Default Value, if desired. 

This value is displayed in the order, and is changed by the user. For example, this 
could be an IP address or a password.

3. Enter a name for the Evaluation Procedure to be used in evaluating the parameter 
value. Specify an evaluation procedure for each parameter that you need to define, 
if desired.

If necessary, click the icon next to the Procedure fieldto launch the procedure 
builder and define a new procedure. See Using the Procedure Builder, page 2-37 
for details of this process.
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4. Click the Save icon on the toolbar to save your changes

5. Select File > Close to exit.

Associating a Fulfillment Procedure with a Fulfillment Action
To associate fulfillment procedures with a fulfillment action, perform the following 
steps. 

Prerequisites
A single fulfillment action can have more than one fulfillment procedures defined. 
However, it must have at least one procedure to indicate the adapter type. 

Steps
1. In the Navigator, choose Setup > Service Definitions > Fulfillment Actions.

2. Select a fulfillment action from the list at left.

3. Select the Fulfillment Procedures tab.

4. Chose a Fulfillment Element Type from the drop down list.

If necessary, click Define Types and create a new fulfillment element type.

1. Enter a value for Software Version (Adapter Type) to set the software version and 
the connect/disconnect values.

2. Enter a value for the fulfillment procedure to select the PL/SQL procedure to 
execute.

If necessary, click the icon next to the Procedure field and create a new procedure 
for use here.

3. Click the Save icon on the toolbar to save your changes.

4. Select File > Close to exit.

Modifying a Fulfillment Action Procedure
To modify or edit an existing fulfillment procedure, perform the following steps.

Prerequisites
None
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Steps
1. In the Navigator, choose Setup > Service Definitions > Fulfillment Actions.

2. Click the icon next to the Procedure field that you wish to modify.

The Add/Edit Procedure window opens.

1. Modify the procedure as desired.

2. Click the Save icon on the toolbar to save your changes.

3. Select File > Close to exit.

Overview of Oracle Service Fulfillment Manager
You use the procedure builder to perform the following tasks:

• Creating a new procedure, page 2-37

• Deleting an existing procedure, page 2-39

• Viewing procedure parameters, page 2-40

• Editing an existing procedure, page 2-41

Creating a New Procedure
To create a new procedure, perform the following steps.

Prerequisites
None

Steps
1. Open the Add/Edit Procedure window by clicking the icon next to the Procedure 

field.

2. Verify the procedure Type.

This field is read-only. Its value depends on the form field that called the Add/Edit 
Procedure window.

1. Enter the internal name for this procedure. 
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The Service Delivery Platform uses this name to reference the procedure in its 
database.

2. Enter the display name.

Enter a description of this procedure.

3. Do one of the following:

• Enter the desired PL/SQL code in the Procedure code field.

• Click Copy From to copy the code from an existing procedure. Use the Edit 
function to modify it to meet your needs.

See Guidelines, page 2-38 following for details on guidelines to use during the 
creation of a procedure.

4. Click OK to compile and generate the procedure.

Guidelines
Use the following guidelines during creation of a procedure.

• Do not use an initial DECLARE statement at the beginning of the code block

• Use the provided Script Notepad to write your Service Fulfillment Manager 
procedure.

• Write your block of code as an anonymous PL/SQL block. (The following is an 
example of a PL/SQL connection procedure.):
err_code number;

err_str     varchar2(400);

BEGIN

LOGIN('telnet $ip_address $portnumber', '$username_prompt', 
err_code, err_str);

SEND('$username', '$password_prompt', err_code, err_str);

SEND('$password', '$login_prompt', err_code, err_str);

EXCEPTION

WHEN OTHERS THEN



Using Oracle Service Fulfillment Manager    2-39

RAISE;

END;

• Use capital letters for all PL/SQL reserved words and the constructs provided by 
the Service Delivery Platform.

• Use the other standard programming constructs provided by PL/SQL in your block 
of code as desired.

• Always add the EXCEPTION block at the end of your procedure:
EXCEPTION

WHEN OTHERS THEN

RAISE

END;

• You must compile and generate the procedure after finishing the code by clicking 
OK.

The procedure builder prompts you with compilation errors if you have either of 
the following conditions exist:

• The procedure contains PL/SQL syntax errors.

• The procedure contains unrecognized parameters.

Note: To display a list of the parameters that can be used in the 
Service Fulfillment Manager procedure, click Available 
Parameters.

Note: The displayed parameters are the internal names of the 
service parameters that you previously configured. Only these 
internal names can be used inside the Service Fulfillment 
Manager procedure body.

Deleting an Existing Procedure
To delete an existing procedure, perform the following steps.
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Prerequisites
The procedure to be deleted must not be used by any other objects.

Steps
1. Open the Add/Edit Procedure window by clicking the icon next to the Procedure 

field.

2. Verify that the procedure Type lists the procedure that you wish to delete.

3. Click the Delete icon on the toolbar.

4. Click the Save icon on the toolbar to save your changes.

5. Select File > Close to exit.

Viewing Procedure Parameters
To view the parameters or attributes which can be used in the procedure, perform the 
following steps.

Prerequisites
None

Steps
1. Open the Add/Edit Procedure window by clicking the icon next to the Procedure 

field.

2. Click Attributes.

3. Click OK to close the Parameters window. 

4. Click OK to exit the Add/Edit Procedure window.

Note: The parameters or attributes displayed are the internal names
of the fulfillment element attributes that you have previously 
configured. Only internal names can be used inside the procedure 
body.
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Editing an Existing Procedure
To edit an existing procedure, perform the following steps.

Prerequisites
Do not modify a default procedure.

Steps
1. Open the Add/Edit Procedure window by clicking the icon next to the Procedure 

field.

2. Verify the procedure type. 

This field is read-only. Its value depends on the form field that called the Add/Edit 
Procedure window.

1. Click on the Procedure Code field.

2. Select Edit > Edit Field from the menu.

3. Modify the PL/SQL code in the Procedure Code text field.

4. Click OK to compile and generate the procedure.

Managing Fulfillment Element Types
For every fulfillment element that you define, there must first exist a definition of that 
fulfillment element type.

The following tasks are associated with fulfillment elements types:

• Defining a fulfillment element type, page 2-41

• Deleting a fulfillment element type, page 2-42

Defining a Fulfillment Element Type
Note: Any service order request provisioned through the Service 
Delivery Platform requires that a specific fulfillment order type for that 
request also be configured through the Service Delivery Platform.

To define a new fulfillment element type, perform the following steps.
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Prerequisites
Fulfillment element types are defined by system experts only.

Steps
1. In the Navigator, choose Setup > Interface Definition > Fulfillment Element Types

.

The Fulfillment Element Types window opens.

1. Select the Details tab.

2. Click Define Types.

3. Click Add. 

This action causes a blank Define Fulfillment Element Types window to open.

4. Complete the fields in the Details tab.

5. Complete the fields in the Attributes tab.

6. Complete the fields in the Software tab.

7. Close the window. 

You are prompted to save your changes.

Deleting a Fulfillment Element Type
To delete an existing fulfillment element type, perform the following steps.

Prerequisites
You can not delete a fulfillment element type if either one of the following conditions is 
true:

• The attributes for this fulfillment element have previously been defined 

• The software versions for this fulfillment element previously have been defined

Steps
1. In the Navigator, choose Setup > Interface Definition > Fulfillment Element Types

.
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The Fulfillment Element Types window opens.

1. Select the fulfillment element type to delete from the list at the left.

2. Click Delete icon on the toolbar.

3. Close the window. 

You are prompted to save your changes.

Managing Fulfillment Elements
There are a number of tasks associated with fulfillment elements. These include:

• Defining a new fulfillment element, page 2-43

• Deleting a fulfillment element, page 2-44

• Modifying a fulfillment element configuration, page 2-44

Defining a New Fulfillment Element
To add a new fulfillment element, perform the following tasks.

Warning: Each Fulfillment Element name must be unique and consist 
only of alphanumeric characters.

Prerequisites
The type of fulfillment element that you wish to add must exist before you can add the 
fulfillment element.

Steps
1. In the Navigator, choose Setup > Interface Definition > Fulfillment Elements.

2. Select the Details tab.

3. Click the New icon on the toolbar.

This action causes a blank Details screen to open.

1. Complete the fields in the Details tab.

2. Complete the fields in the SW Versions tab, including both the Details and 
Attributes sub-tabs
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3. Close the window. 

You are prompted to save your changes.

Deleting a Fulfillment Element
To delete a fulfillment element, perform the following tasks.

Warning: If you delete a fulfillment element, then the logical and 
physical entity of the fulfillment element is removed from the Service 
Delivery Platform database.

Prerequisites
You can not delete a fulfillment element, if either the following is true:

• You have previously defined attributes for this fulfillment element.

• You have previously defined the software generics for this fulfillment element.

Steps
1. In the Navigator, choose Setup > Interface Definition > Fulfillment Elements.

2. Select the Details tab.

3. Select the fulfillment element that you wish to delete from the list at the left.

4. Click Delete.

5. Close the window. 

You are prompted to save your changes.

Modifying a Fulfillment Element Configuration
If changing a fulfillment element configuration (for example, disabling a fulfillment 
element, or changing the fulfillment element attributes such as the IP address), perform 
the following steps.

Prerequisites
None.
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Steps
1. Shutdown the Work Item queue to stop the work item dequeuers.

2. Ensure that there are no fulfillment actions remaining in the Wait for FE queue and 
the FE Ready queue. This means that all the fulfillment actions are processed at this 
point.

3. Shutdown the adapters for the fulfillment element.

4. Change the attributes for the fulfillment element.

5. Re-start the adapters for the fulfillment element.

6. Re-start the Work Item queue.
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3
Administering Oracle Service Fulfillment 

Manager

This chapter covers the following topics:

• Workflow Procedure Guidelines

• The AOL Generic Loader

• Creating an Activity or Process Timer

• Creating a Message Timer

• Event Subscription

• Setting Up Event Subscription

• Administering the Oracle Service Delivery Platform

• Oracle SDP Start

• Oracle SDP Stop

• Service Fulfillment Manager Procedure Macros

• Example Service Delivery Platform Procedures

Workflow Procedure Guidelines
Use the following rules during procedure definition.

• Use the provided procedure notepad to write your Service Fulfillment Manager 
procedure. 

• Write an anonymous PL/SQL block as to insert into the procedure body.

• Use capital letters for all PL/SQL reserved words and the constructs provided by 
Oracle Provisioning. 

• Use the standard programming constructs provided by PL/SQL in your block of 
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code, if desired.

• Always add the EXCEPTION block at the end of the procedure.

Example Procedure Definition
The procedure builder provides a structure for building your procedures. For example, 
to build a new procedure, you simply insert your code into the following procedure 
definition.
/***********************************************************************
********

This procedure calculate a new value for the Work Item parameter.

It has the follwoing input and output parameters:

p_order_id           IN NUMBER   -- order ID

p_wi_instance_id     IN NUMBER   -- wprlote, omstamce OD

p_param_val          IN VARCHAR2 -- parameter initial value

p_param_ref_val      IN VARCHAR2 -- reference value (if order amendment)

p_parmam_eval_val    OUT VARCHAR2 -- parameter new value

p_param_eval_val     OUT VARCHAR2 -- parameter new value

p_param_eval_ref_val OUT VARCHAR2 -- new reference value (if order 
ammendment)

************************************************************************
*******/

-- Enter your procedure below:

DECLARE

-- Your declarations...

BEGIN

-- Your procedure body...

END;
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:

EXCEPTION

WHEN OTHERS THEN

RAISE

END;

Compiling Procedures
After creating a new procedure, you must compile it. The procedure builder prompts 
you with compilation errors if you have either of the following conditions exist:

• The procedure contains PL/SQL syntax errors.

• The procedure contains unrecognized parameters.

The AOL Generic Loader
The Oracle Application Object Library loader is a general purpose data migration tool 
that is used for patching seed data, delivering translations, or copying setup or 
transaction data from development to production systems.

The loader is a concurrent program named FNDLOAD. Enter the following command 
at a UNIX prompt.
FNDLOAD apps/pwd 0 Y mode configfile datafile entity [ param ... ]

The table following lists the parameters used with this executable and describes them.

FNDLOAD Parameter List

Parameter Description

apps/pwd Specifies the APPS schema and password. 

• If the connect_string is omitted, it is taken
in a platform-specific manner from the 
environment using the name TWO_TASK

0 Y Concurrent program flags
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Parameter Description

mode Specifies either UPLOAD or DOWNLOAD 
operation. 

• UPLOAD causes the specified data file to 
be uploaded to the database. 

• DOWNLOAD causes the loader to fetch 
rows and write them to the specified data 
file.

configfile Specifies the configuration file to use. .

• The configuration file usually ends with a
suffix of .lct, but this rule is neither 
enforced nor supplied by the loader

datafile Specifies the data file to write. 

• (DOWNLOAD) If the data file already 
exists, then it is overwritten. 

• The configuration file usually ends with a
suffix of .lct, but this rule is neither 
enforced nor supplied by the loader.

entity Specifies the entity type to begin the 
download or upload. 

• If you wish to upload all of the entity 
types in a data file (.ldt), specify a dash (-)
as the entity type.

param Specifies zero or more additional parameters 
that are used to provide bind values in the 
access SQL (for both the UPLOAD and 
DOWNLOAD operations). 

• Each parameter is of the form 
NAME=VALUE. The given NAME must 
not conflict with an attribute name for the
entities being loaded.
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Loader File Definitions
The table following lists the Loader files and provides a description of each.

Loader File Description

Name Description Conditions Parameters

xnpcbevt.lct Callback Events First run 
xnpmsgps.lct

XNP_CALLBACK_E
VENTS 

• MSG_CODE

xnpevtsb.lct Event Subscribers First load the 
fulfillment element 
data 

XNP_EVENT_SUBSC
RIBERS 

• MSG_CODE

• FE_NAME

xnpgeoas.lct Geographic Areas 
and Hierarchy 

First load the Areas, 
then the Hierarchy 

XNP_GEO_AREAS 

• CODE 

XNP_GEO_HIERAR
CHY 

• CODE

xnpmsgak.lct Message 
Acknowledgments 

First run xnpmsgps.lct 
XNP_MSG_ACKS 

• MST_CODE

xnpmsgps.lct Messages None XNP_MSG_TYPES 

• MSG_CODE
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Name Description Conditions Parameters

xnpsnumr.lct Served Number 
Ranges 

First load the 
fulfillment element 
data, then run 
xnpsptre.lct 

XNP_SERVED_NUM
_RANGES 

• STARTING_ 
NUMBER

• FE_NAME 

• FEATURE_TYPE

xnpsptre.lct Service Providers None XNP_SERVICE_PRO
VIDERS 

• CODE

xnpstats.lct Porting Status Types None XNP_SV_STATUS_T
YPES 

• STATUS_TYPE_
CODE

xnptmrpb.lct Timer Publishers First run 
xnpmsgps.lct 

XNP_TIMER_PUBLIS
HERS 

• MSG_CODE

References
For additional information, see the files in the following application directories.

• Template configuration file

/fnddev/fnd/11.5/admin/import/fndstd.lct

• Existing AOL configuration files

/fnddev/fnd/11.5/admin/import/*.lct

Creating an Activity or Process Timer
Perform the following steps to create either an Activity or Process Timer.
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Prerequisites
None

Steps
1. Open the iMessage Studio.

2. Define the Activity Timer:

• Specify the Internal Name.

• Select Timer from the Type LOV.

• Specify a Display Name.

• Specify a Description.

• Select a value from the Priority LOV.

• Select Timer Queue from the Queue Name LOV.

• Specify a Responsibility.

3. Select the Data Source tab.

4. Define the Delay and Interval for the Activity Timer:

• Select the tree root for the timer.

• Select SQL Query from the Data Source Type LOV.

• Select One and Only One from the Data Source Cardinality LOV.

5. Specify the Source for the timer.

6. Select the Detail tab.

7. Click Compile to compile the timer.

If all goes well, the timer will compile without errors. If an error is encountered, 
verify that you have followed steps 2 - 5 above correctly.

8. Click the View button to examine the PL/SQL package that is generated as a result 
of compiling the Activity Timer (if desired).

9. Click Apply.
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Source Guidelines
The source SQL structure for the Activity Timer must be of the following format:
SELECT D delay, I interval FROM dual

• D is the delay integer value (seconds)

• I is the interval integer value (seconds)

After setting the source SQL, you need to also:

1. Select the Delay branch from tree root for the Activity Timer.

2. Specify a reference for the Delay branch.

Delay Guidelines
The reference value Delay branch must map to the select-list specified in step 4 above. 
The reference value must be of the following format:
xnp$<activity_timer_name>.<select-list column name>

• <acitivity_timer_name> is the Internal Name defined in step 4.

• <select-list column name> is the first select-list value of the SQL source specified in 
step 5. 

After setting the Delay reference value, you need to also:

1. Select the Interval branch from tree root for the Activity Timer. 

2. Specify a reference for the Interval branch.

Interval Guidelines
The reference value Interval branch must map to the select-list specified in step 4. The 
reference value must be of the following format:
xnp$<activity_timer_name>.<select-list column name>

• <activity_timer_name> is the Internal Name defined in step 4.

• <select-list column name> is the second select-list value of the SQL source specified 
in step 5.

Creating a Message Timer
Perform the following steps to create a message timer.
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Prerequisites
Before creating the message timer, you must first create the message with which it is 
associated.

Steps
1. Open the iMessage Studio.

2. Define a Message Timer:

• Specify an Internal Name.

• Select Message from the Type LOV.

• Specify a Display Name.

• Specify a Description.

• Select a value from the Priority LOV.

• Select Outbound Message Queue from the Queue Name LOV.

3. Click Apply.

You must then use the Event Subscriber to associate a Timer Message (Different 
Timer which is an Activity Timer) to this newly created message.

4. Define Event Subscriber which is associated with a Timer

• Access the Event Subscriber screen from the Configuration tab

• Select the event defined in step 3 above

• Click the Timers tab

• Select the Activity Timer defined in step 3 above from the Timer LOV

• Click Apply

Event Subscription
Applications register with the Event Manager if they need information on specific 
messages (events) or all instances of that message type. An application can be an 
external system, an operating system or a mediation layer.

Every message and event is sent to the Event Manager which becomes the source of 
distribution for events and messages. This is known as event subscription. Event 
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subscription is a business process handled within Workflow.

• Applications can be set as default subscribers to specific events and messages. This 
is configured in the Event Subscriber utility.

• Applications can show interest in a specific instance of a message by specifying the 
REFERENCE_ID of the message. 

• Applications can register for one of several response messages by using the 
reference identifier. 

• When a message with a reference identifier arrives, the Event Manager performs 
the following tasks:

• It executes the validation logic.

• It executes the processing logic. It does this before delivering the message to all 
registered applications.

• Applications can show interest in all instances by registering with a NULL 
reference identifier.

• If an application is registered for a specific instance, the registration is automatically
unsubscribed after delivering that message.

• Upon arrival of an expected response:

• The message is delivered to the registered application.

• The other expected response is marked EXPIRED.

Setting Up Event Subscription
In the Event Manager, it is possible for default subscribers to subscribe to specific events
of the application. When a message occurs, the Event Manager ensures that an 
outbound message is automatically sent to the subscriber identified by a Fulfillment 
Element, OSS or gateway.

Responding to an Event
• It is possible to associate one or more responses to an event. 

• A response is set during the configuration in the form of acknowledgments. 
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The Steps in Creating a Response to an Event
1. Create the message or event that is to the trigger for a response.

2. Configure an Acknowledgment/ Response to the message or event that you created 
in step 1.

3. Link the Acknowledgment that you created in step 2 to the message/event that you 
created in step 2.

Automatic Responses
If desired, you can associate one or more responses with an event. A response is an 
acknowledgment to a message. 

For example, valid message responses for the message "Is this an existing customer?" 
are:

• "Yes, this is an existing customer."

• "No, this is not an existing customer."

These responses are messages in themselves and must be configured in Oracle 
Provisioning before they can be linked as responses to a message. 

Administering the Oracle Service Delivery Platform
The Concurrent Manager framework provided by Oracle Applications is used to 
administer the Oracle Service Fulfillment Manager Concurrent Manager. The 
Concurrent Manager includes a specialized Controller program that is used by the 
Oracle Service Delivery Platform to start (or stop) adapters and/or dequeuers.

Orders within the Service Delivery Platform are processed using various queues. The 
processing of items of a queue is done with the help of dequeuers. These dequeuers are 
background processes which continuously poll a queue and process the items from the 
queue.

The Service Fulfillment Manager of various network elements is accomplished with the 
use of adapters. Adapters are processes which are specialized in certain protocols. 
(Telnet, FTP, or other protocols.). You direct the adapters to perform various tasks in the
system.

Note: To administer the Oracle Service Fulfillment Manager Concurrent
Manager, open the Administer Concurrent Managers form window 
available through Concurrent > Administer Manager.



3-12    Oracle Service Fulfillment Manager Concepts and Procedures

Oracle SDP Start
Application Start is a concurrent request that is performed by the Oracle Service 
Fulfillment Manager Concurrent Manager. 

You use the Application Start process to perform the following tasks:

• Start the entire application, including the Controller, dequeuers and all adapters

• Start only the Controller and the dequeuers

• Start the Controller, the dequeuers and a subset of the adapters

The system automatically starts all the dequeuers and the Controller during the start 
process. If any dequeuers are already started, the number actually running is first 
determined, and matched against the number that are required to be started. The 
system automatically starts as many dequeuers as needed.

Note: You set the number of running dequeuers through the Queue 
Console, available through Administration > Queue Console.

Perequisites
Application Start and Stop are mutually exclusive processes. If one is pending, the 
opposite operation does not proceed until the first finishes. In addition, the Oracle 
Service Fulfillment Manager Concurrent Manager processes must be up and running. 

Steps
1. In the a Navigator, select Applications > Start. 

The Parameters box opens.

2. Enter a value in the Options field from the drop-down list of values.

See the Guidelines, page 3-13 following for information on these choices.

3. Enter a value in the Fulfillment Element field that is to be included (or excluded) 
from the application start process.

This choice depends on the value that you chose in step 2, preceding. Again, see the
Guidelines, page 3-13 for details.

4. Enter a value (0 - 3) for the Debug Mode.

This value sets the level of logging that can be used for debugging purposes.

5. Click OK.
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The Oracle SDP Start dialog box becomes available. Parameters that you set in the 
previous dialog box display in the Parameters field.

6. (Optional) Click Copy, if you wish to use start parameters from a prior start 
request, otherwise proceed to step 7.

If you chose this option, then select from the provided list and continue to step 10.

7. (Optional) Click Languages..., if you wish to change the default language used in 
generating the log entries, otherwise proceed to step 8.

If you chose this option, then place a check mark in the box next to the language, or 
languages, you wish to add. Continue to step 8.

8. (Optional) Click Schedules..., if you wish to change the default time at which this 
request is to be run. Perform either a or b, following.

1. Click Apply a Saved Schedule... to choose from a list of predefined schedules. 

2. Chose an option from the Run the Job... list.You can set how often, and when, 
you wish the start request to run. Depending on which radio button you check, 
a number of additional fields display so that you may specify exact dates and 
times.

9. (Optional) Click Options..., to specify to whom, and in what language, you wish a 
notification to be sent. You can also direct the output log files to be sent to a specific 
printer. 

10. Click Submit to initiate the start process and to close the dialog box.

Note: Each request generates a Request ID. You can use this Request ID
to view the request status and the log entries through the View 
Requests form window, available through Concurrent > View 
Requests.

Guidelines
Options: The table following lists the available choices. This option indicates which 
adapters are to be started. You must select from the provided list of values.
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Fulfillment Element Select Options

Option Description

ALL All adapters (for all fulfillment elements) 
marked AUTOMATIC are started. 

(You set an adapter to AUTOMATIC through 
Administration > Connection Manager. You 
can also use the Adapter Properties form 
window to configure adapter properties.)

INCLUDE Only adapters marked AUTOMATIC that are 
associated with the designated fulfillment 
element are started.

EXCLUDE All adapters marked AUTOMATIC are 
started, except for those associated with the 
designated fulfillment element.

NONE No adapters are started.

Fulfillment Element: Select the fulfillment element that is to be included or excluded 
(see the preceding table) from the application start. You must select from the provided 
list of values. 

Debug Mode: Select the debugging mode to be used for the Controller and the 
dequeuer processes. You must select from the provided list of values. 

The table following lists the available options.

Debug Options

Debug Level Description

0 No trace

1 Minimum trace

2 Medium trace

3 Maximum trace
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Note: Adapters are started with the debug level configured through the
Adapter Properties window.

Oracle SDP Stop
Application Stop is a concurrent request that is performed by the Oracle Service 
Fulfillment Manager Concurrent Manager. 

You use the Application Stop process to perform the following tasks:

• Stop the entire application, including the Controller, dequeuers and all adapters

• Stop a subset of the adapters

Prerequisites
Application Start and Stop are mutually exclusive processes. If one is pending, the 
opposite operation does not proceed until the first finishes. In addition, the Oracle 
Service Fulfillment Manager Concurrent Manager processes must be up and running. 

Steps
1. In the a Navigator, select Applications > Stop. 

The Parameters box opens.

2. Enter a value in the Options field from the drop-down list of values.

See the Guidelines, page 3-16 following for information on these choices.

3. Enter a value in the Fulfillment Element field that is to be included (or excluded) 
from the application stop process.

This choice depends on the value that you chose in step 2, preceding. See the 
Guidelines, page 3-16 for details.

4. Enter a value for the Stop Mode.

See the Guidelines, page 3-16 following for information on these choices.

5. Click OK.

The Oracle SDP Stop dialog box becomes available. Parameters that you set in the 
previous dialog box display in the Parameters field.

6. (Optional) Click Copy, if you wish to use stop parameters copied from a prior stop 
request, otherwise proceed to step 7.

If you chose this option, then select from the provided list and continue to step 10.
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7. (Optional) Click Languages..., if you wish to change the default language used in 
generating log entries, otherwise proceed to step 8.

If you chose this option, then place a check mark in the box next to the language, or 
languages, you wish to add. Continue to step 8.

8. (Optional) Click Schedules..., if you wish to change the default time at which this 
request is to be run. Perform either a or b, following.

1. Click Apply a Saved Schedule... to choose from a list of predefined schedules. 

2. Chose an option from the Run the Job... list.You can set how often, and when, 
you wish the start request to run. Depending on which radio button you check, 
a number of additional fields display so that you may specify exact dates and 
times.

9. (Optional) Click Options..., to specify to whom, and in what language, you wish a 
notification to be sent. You can also direct the output log files to be sent to a specific 
printer. 

10. Click Submit to initiate the stop process and to close the dialog box.

Note: Each request generates a Request ID. You can use this 
Request ID to view the request status and the log entries through 
the View Requests form window, available through Concurrent > 
View Requests.

Guidelines
Options: The table following lists the available choices. This option indicates which 
adapters are to be stopped. You must select from the provided list of values.

Fulfillment Element Select Options

Option Description

ALL All adapters, for all fulfillment elements, 
dequeuers and the Controller are stopped. 
This option signifies the complete application 
stop.

INCLUDE Only adapters marked AUTOMATIC that are 
associated with the designated fulfillment 
element are stopped.
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Option Description

EXCLUDE All adapters marked AUTOMATIC are 
stopped, except for those associated with the 
designated fulfillment element.

Fulfillment Element: Select the fulfillment element that is to be included or excluded 
(see the preceding table) from the application stop. You must select from the provided 
list of values. 

Stop Mode: Select the mode to be used. You must select from the provided list of 
values. 

The table following lists the available options.

Stop Mode Options

Debug Level Description

NORMAL This specifies the standard shutdown mode. 
Depending on the choice that you made under
Options, this could be the entire system, or 
only a subset of it. 

For example, if you select the NORMAL 
mode, and the Options value is set to ALL, 
then the following occurs: 

• If there are no adapters still processing 
orders, then all the dequeuers and the 
Controller are stopped. 

• If some of the adapters are still processing
orders, all the dequeuers stop, except for 
the Event Manager. Once an adapter has 
finished processing an order, the Event 
Manager shuts the adapter down and a 
database job shuts down the Event 
Manager and Controller.

ABORT Specifies an abnormal mode of shutdown. All 
the running processes (as specified in the 
Options selection) are terminated at the 
operating system level.
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Service Fulfillment Manager Procedure Macros
Oracle Service Fulfillment Manager comes with a set of predefined constructs that can 
be used to build procedures. These constructs are.

• SEND, page 3-18

• SEND_HTTP, page 3-19

• LOGIN, page 3-20

• RESPONSE_CONTAINS, page 3-21

• GET_RESPONSE, page 3-22

• GET_PARAM_VALUE, page 3-23

• NOTIFY_ERROR, page 3-23

Send
The SEND macro accepts a command string as an argument. This command string is 
sent to the fulfillment element as the command to be executed. You use the SEND 
macro to "send" commands to the network elements. 

Signature
The signature of the SEND constructis as follows:
SEND(<command > <varchar2>, <encrypt flag> <varchar2>, <prompt 
(optional)> <varchar2>, <err code (out)> <number>, <error string (out)> 
<varchar2>)

The application stores all the transactions sent and received, to and from the fulfillment 
elements in its audit trail. However, it also provides a mechanism that allows you not to
store, or write sensitive information contained in the service order request to the audit 
trail, if desired. Responses from fulfillment elements may also carry the same sensitive 
information. 

Therefore:

• If you set the encryption flag to Y, then you are disabling the logging of all 
responses from the fulfillment elements. 

• If you set the encryption flag to N, then you are enabling the normal logging of 
responses from the fulfillment elements.
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Syntax
The usage of the construct is defined as follows:
SEND(

<command> string which contains the command to be sent,this is where you
specify your service parameters in $variable_name format. 

<'Y' or 'N'> to indicate whether the command response must be logged 
into the audit trail,

<prompt> is an optional field which indicates the prompt at the Network 
Element after the execution of <command>>

<a number place holder for the out parameter error_code>,

<a varchar2 place holder for the out parameter error string>

);

Restrictions
Note the following restrictions on the use of the SEND macro.

1. For parameter values with white spaces, specify the corresponding 
$variable_names in double quotes.

2. Eliminate white spaces between SEND and the "(" following it.

Correct Usage: SEND(

Incorrect Usage: SEND (

3. Do not use SEND inside comments. 

SEND_HTTP
The SEND_HTTP macro accepts a command string as an argument. This command is 
then sent to the fulfillment element as the command to be executed using the HTTP 
protocol. Typically, in this scenario, the command is an URL. 

Signature
The signature of the constructis as follows:
SEND(

<a string which contains the URL to be sent>  ,

<'Y' or 'N' indicator which indicates whether the URL should be logged 
into the audit trail>,
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<a number place holder for the out parameter error_code>,

<a varchar2 place holder for the out parameter error string>

);

Restrictions
Note the following restrictions on the use of the SEND_HTTP macro.

1. Eliminate white spaces between SEND_HTTP and the "(" following it.

Incorrect Usage: SEND_HTTP ( 

Correct Usage: SEND_HTTP(

LOGIN
The LOGIN macro accepts a command string as an argument. It uses the argument to 
initiate a connection. Use this macro to initiate a connection to a fulfillment element 
which has an interactive interface (for example, Telnet). 

Note: The LOGIN construct should appear before the first SEND 
construct in the procedure.

Signature
The signature of the LOGIN constructis as follows:
LOGIN(

<a string which contains the command to be sent>  ,

< a string which contains the command response expected>,

<a number place holder for the out parameter error_code>,

<a varchar2 place holder for the out parameter error string>

);

SEND (Connection Procedure)
This SEND macro accepts a command string as an argument. It uses the argument to 
send the command set (connect) to the fulfillment element. One of the connection 
commands is executed. 

Signature
The signature of the LOGIN constructis as follows:
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SEND(

<a string which contains the command to be sent>  ,

< a string which contains the command response expected>,

<a number place holder for the out parameter error_code>,

<a varchar2 place holder for the out parameter error string>

);

Restrictions
Note the following restrictions on the use of the LOGIN macro.

1. Use the LOGIN macro once only before any SEND construct.

2. Use the LOGIN macro only in a connect procedure.

3. Do not use order, line, work item, and fulfillment action as service parameters. The 
$ variables are fulfillment element attributes, and, as such, can not be used as 
service parameters.

RESPONSE_CONTAINS
The RESPONSE_CONTAINS procedure macro is a PL/SQL function that compares a 
user-defined string against the string returned by a fulfillment element in response to 
the last command that it received. The macro returns TRUE if the two strings match, 
otherwise it returns FALSE.

Signature
The signature of the constructis as follows:
RESPONSE_CONTAINS(

<a string which contains the string to be matched>

) 

return BOOLEAN;

Restrictions
Note the following restrictions on the use of the RESPONSE_CONTAINS macro.

1. Do not use $ variables.

2. Eliminate white spaces between RESPONSE_CONTAINS and the "(" following it.

Incorrect Usage: RESPONSE_CONTAINS (
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Correct Usage: RESPONSE_CONTAINS(

GET_RESPONSE
The GET_RESPONSE macro returns the response string from the fulfillment elements 
for the last command sent.

Signature
The signature of the constructis as follows:
GET_RESPONSE return VARCHAR2

Syntax
The usage of the construct is defined as follows:
err_code number;

err_str     varchar2(400);

lv_user varchar2(80);

BEGIN

lv_user := GET_PARAM_VALUE('$WI.user');

SEND('AddProfile -h $WI.hostname -p $FA.dbport -u $WI.user', 'Y', 
err_code, err_str);

IF RESPONSE_CONTAINS('profile already exist') THEN

NOTIFY_ERROR('Error when Service Fulfillment Manager Cisco Secure HA 
Server. Subscriber ' || lv_user || ' already exists','A'); 

RETURN;

END IF;

EXCEPTION

WHEN OTHERS THEN

RAISE;

END;
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Restrictions
Note the following restrictions on the use of the GET_RESPONSE macro.

1. Do not use $ variables.

2. Eliminate white spaces between RESPONSE_CONTAINS and the "(" following it.

Incorrect Usage: GET_RESPONSE (

Correct Usage: GET_RESPONSE(

GET_PARAM_VALUE
Use the GET_PARAM_VALUE procedure macro to obtain the value of the parameter 
during run-time. 

Signature
The signature of the constructis as follows:
GET_PARAM_VALUE (<parameter name> <varchar2>) return VARCHAR2

• The <parameter name> is the name of the parameter in $ format. 

• The value returned by the function can be NULL.

When using this macro, specify the parameters as a $ variable. For example, parameter 
TN (if used inside a Service Fulfillment Manager procedure), is specified as 
$ORDER.TN.

Restrictions
Note the following restriction on the use of the GET_PARAM_VALUE macro.

1. Eliminate white spaces between GET_PARAM_VALUE and the "(" following it.

Incorrect Usage: GET_PARAM_VALUE (

Correct Usage: GET_PARAM_VALUE(

NOTIFY_ERROR
The NOTIFY_ERROR procedure macro indicates an abnormal exit point from the 
procedure. The Service Fulfillment Manager of a service order request at a fulfillment 
element has an ERROR status. 

This macro appends or replaces a response initiated by the fulfillment element / 
network element. This is the input string. 
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Signature
The signature of the constructis as follows:
NOTIFY_ERROR(<user's string> <varchar2>, <mode> <char>)

• The <user's string> contains a user-defined friendly message

• The <mode> flag is either A or R. 

A indicates that the user message is to be appended to the response string coming 
from the fulfillment element.

R indicates that the user message is to be replaced by the response string coming 
from the fulfillment element.

Guidelines
1. You use this macro under the following conditions:

• You want to identify errors coming from the fulfillment element during the 
Service Fulfillment Manager process.

• You want to identify errors when exiting from the Service Fulfillment Manager 
procedure. 

2. You use the NOTIFY_ERROR macro to abort a Service Fulfillment Manager 
procedure.

3. You must follow every NOTIFY_ERROR instance in the procedure by a RETURN 
statement. This is the only way to abort the execution of the Service Fulfillment 
Manager procedure.

4. The Service Delivery Platform uses the <user's string> to display the Service 
Fulfillment Manager errors of a failed Service Order Request. Make this name 
user-friendly. This name provides the ability to translate cryptic network element 
error messages into those that are more user friendly.

Example Service Delivery Platform Procedures
Following are several example workflow procedures:

• Example Service Fulfillment Manager procedure, page 3-25

• Example connect procedure, page 3-25
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Example Service Fulfillment Manager Procedure
DECLARE

err_code number;

err_str     varchar2(400);

lv_user varchar2(80);

BEGIN

lv_user := GET_PARAM_VALUE ('$user');

SEND('AddProfile -h $hostname -p $dbport -u $user', 'Y', err_code, 
err_str);

IF RESPONSE_CONTAINS ('profile already exist') THEN

NOTIFY_ERROR('Error when Service Fulfillment Manager Cisco Secure HA 
Server. Subscriber ' || lv_user || ' already exists','A'); 

RETURN;

END IF;

EXCEPTION

WHEN OTHERS THEN

RAISE;

END;

Example Connect Procedure
DECLARE

err_code number;

err_str     varchar2(400);

lv_user varchar2(80);

BEGIN
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LOGIN('telnet $ip_address', 'login:', err_code, err_str);

SEND('$username', '$Password:', err_code, err_str);

SEND('$Password', '$', err_code, err_str);

EXCEPTION

WHEN OTHERS THEN

RAISE;

END;
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processing, 1-37
processing steps, 1-37
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associating actions with, 2-21
associating with a package, 2-26
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definition, 1-24
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Work Item queue, 1-12
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adding parameters to, 2-30
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