Endeca.Logging Namespace

[image]

Endeca Logging API
Endeca.Logging Namespace
Send Feedback

Classes

 | Class | Description
Public class | LogConnection | This class is used to create an HTTP connection to the Log Server, where LogEntry objects can be sent and recorded. The LogConnection contains the hostname and port of the Log Server.
Public class | LogEntry | This class contains the logging information sent from the application to the Log Server. Each LogEntry stores data about the current query in key/value pairs. Examples of the kind of data that can be recorded in a LogEntry include the session ID, the number of records in the current navigation state, and the active sort key.
Public class | LogException | Represents an exception that may arise from trying to submit a LogEntry to the logging server.
© 2011, 2012 Oracle and/or its affiliates. Oracle and/or its affiliates Confidential


LogConnection Class

[image]

Endeca Logging API
LogConnection Class
Members See Also Send Feedback
This class is used to create an HTTP connection to the Log Server, where LogEntry objects can be sent and recorded. The LogConnection contains the hostname and port of the Log Server.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public class LogConnection
Visual Basic
Public Class LogConnection
Visual C++
public ref class LogConnection

Inheritance Hierarchy

System..::..Object
Endeca.Logging..::..LogConnection

See Also

LogConnection Members
Endeca.Logging Namespace


LogConnection Members

[image] [image]

Endeca Logging API
LogConnection Members
LogConnection Class Constructors Methods See Also Send Feedback

The LogConnection type exposes the following members.

Constructors

 | Name | Description
Public method | LogConnection(String, Int32) | Initialize a LogConnection.
Public method | LogConnection(String, String) | Initialize a LogConnection.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | log | Sends a log request to the Log Server without waiting for a response. Using this method instead of LogAndWait() can improve performance, because the extra step of insuring the Log Server received the request is not performed.
Public method | logAndWait | Sends a log request to the server, and reads the response
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogConnection Class


LogConnection Constructor

[image] [image]

Endeca Logging API
LogConnection Constructor
LogConnection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogConnection(String, Int32) | Initialize a LogConnection.
Public method | LogConnection(String, String) | Initialize a LogConnection.

See Also

LogConnection Class
LogConnection Members


LogConnection Constructor (String, Int32)

[image]

Endeca Logging API
LogConnection Constructor (String, Int32)
LogConnection Class See Also Send Feedback
Initialize a LogConnection.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public LogConnection(
    string host,
    int port
)
Visual Basic
Public Sub New ( _
    host As String, _
    port As Integer _
)
Visual C++
public:
LogConnection(
    String^ host,
    int port
)

Parameters

host
Type: System..::..String
The hostname of the log server
port
Type: System..::..Int32
The port used to connect to the log server

See Also

LogConnection Class
LogConnection Overload


LogConnection Constructor (String, String)

[image]

Endeca Logging API
LogConnection Constructor (String, String)
LogConnection Class See Also Send Feedback
Initialize a LogConnection.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public LogConnection(
    string host,
    string port
)
Visual Basic
Public Sub New ( _
    host As String, _
    port As String _
)
Visual C++
public:
LogConnection(
    String^ host,
    String^ port
)

Parameters

host
Type: System..::..String
The hostname of the log server
port
Type: System..::..String
The port used to connect to the log server

See Also

LogConnection Class
LogConnection Overload


LogConnection Methods

[image] [image]

Endeca Logging API
LogConnection Methods
LogConnection Class See Also Send Feedback

The LogConnection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | log | Sends a log request to the Log Server without waiting for a response. Using this method instead of LogAndWait() can improve performance, because the extra step of insuring the Log Server received the request is not performed.
Public method | logAndWait | Sends a log request to the server, and reads the response
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogConnection Class


log Method

[image]

Endeca Logging API
LogConnection..::..log Method
LogConnection Class See Also Send Feedback
Sends a log request to the Log Server without waiting for a response. Using this method instead of LogAndWait() can improve performance, because the extra step of insuring the Log Server received the request is not performed.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public void log(
    LogEntry entry
)
Visual Basic
Public Sub log ( _
    entry As LogEntry _
)
Visual C++
public:
void log(
    LogEntry^ entry
)

Parameters

entry
Type: Endeca.Logging..::..LogEntry
The LogEntry object to send to the server

See Also

LogConnection Class


logAndWait Method

[image]

Endeca Logging API
LogConnection..::..logAndWait Method
LogConnection Class See Also Send Feedback
Sends a log request to the server, and reads the response

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public bool logAndWait(
    LogEntry entry
)
Visual Basic
Public Function logAndWait ( _
    entry As LogEntry _
) As Boolean
Visual C++
public:
bool logAndWait(
    LogEntry^ entry
)

Parameters

entry
Type: Endeca.Logging..::..LogEntry
The LogEntry object to send to the server

Return Value

True if the entry was successfully logged.

See Also

LogConnection Class


LogEntry Class

[image]

Endeca Logging API
LogEntry Class
Members See Also Send Feedback
This class contains the logging information sent from the application to the Log Server. Each LogEntry stores data about the current query in key/value pairs. Examples of the kind of data that can be recorded in a LogEntry include the session ID, the number of records in the current navigation state, and the active sort key.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public class LogEntry : IDictionary, ICollection,
    IEnumerable
Visual Basic
Public Class LogEntry _
    Implements IDictionary, ICollection, IEnumerable
Visual C++
public ref class LogEntry : IDictionary,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Logging..::..LogEntry

See Also

LogEntry Members


LogEntry Members

[image] [image]

Endeca Logging API
LogEntry Members
LogEntry Class Constructors Methods Properties See Also Send Feedback

The LogEntry type exposes the following members.

Constructors

 | Name | Description
Public method | LogEntry()()()() | Construct an empty LogEntry
Public method | LogEntry(IDictionary) | Construct a LogEntry with the given key-value pairs.

Methods

 | Name | Description
Public method | Add | Adds a key/value pair to this LogEntry object.
Public method | AddDouble | Set the given key to the given double value. The number will be stored as a String in decimal representation. Therefore, you can retrieve the value later by calling either by getDouble() or getString().
Public method | AddInt | Set the given key to the given integer value. The number will be stored as a String in decimal representation. Therefore, you can retrieve the value later by calling either by getInt(), getDouble(), or getString().
Public method | AddList | Set the given key to the list value. Note that the values in the list will all be converted to strings, so getList will return a list of Strings.
Public method | AddString | Set the given key to the given string value.
Public method | Clear | Clears the contents of this LogEntry.
Public method | Contains | Determines whether the LogEntry contains an element with the specified key.
Public method | CopyTo | Copies the entire LogEntry to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDouble | Get the value associated with the given key. If the value was originally set via setInt() or setString(), then this method will still succeed as long as the value is a valid decimal number.
Public method | GetEnumerator | Returns an IDictionaryEnumerator for the LogEntry.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInt | Get the integer value associated with the given key. If the value was originally set via setString(), then this method will still succeed as long as the value is a valid decimal integer.
Public method | GetList | Get the given list value associated with a given key. If the value was not originally set using setList, this method will return a list with a single item containing the string representation of the original value. Any changes made to the IList object after calling getList will not be reflected in the LogEntry's value. In order to change the value of the list contents, setList() must be used.
Public method | GetString | Get the value associated with the given key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the item with the specified key
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the LogEntry.
Public property | IsFixedSize | Gets a value indicating whether the LogEntry has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the LogEntry is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the LogEntry is synchronized (thread-safe).
Public property | Item | Gets or sets an element with the specified key.
Public property | Keys | Gets an ICollection containing the keys of this LogEntry.
Public property | SyncRoot | This operation is not supported.
Public property | Values | Gets an ICollection containing the values of this LogEntry.

See Also

LogEntry Class


LogEntry Constructor

[image] [image]

Endeca Logging API
LogEntry Constructor
LogEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogEntry()()()() | Construct an empty LogEntry
Public method | LogEntry(IDictionary) | Construct a LogEntry with the given key-value pairs.

See Also

LogEntry Members


LogEntry Constructor

[image]

Endeca Logging API
LogEntry Constructor
LogEntry Class See Also Send Feedback
Construct an empty LogEntry

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public LogEntry()
Visual Basic
Public Sub New
Visual C++
public:
LogEntry()

See Also

LogEntry Overload


LogEntry Constructor (IDictionary)

[image]

Endeca Logging API
LogEntry Constructor (IDictionary)
LogEntry Class See Also Send Feedback
Construct a LogEntry with the given key-value pairs.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public LogEntry(
    IDictionary keyValuePairs
)
Visual Basic
Public Sub New ( _
    keyValuePairs As IDictionary _
)
Visual C++
public:
LogEntry(
    IDictionary^ keyValuePairs
)

Parameters

keyValuePairs
Type: System.Collections..::..IDictionary
IDictionary used to initialize this LogEntry

See Also

LogEntry Overload


LogEntry Methods

[image] [image]

Endeca Logging API
LogEntry Methods
LogEntry Class See Also Send Feedback

The LogEntry type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a key/value pair to this LogEntry object.
Public method | AddDouble | Set the given key to the given double value. The number will be stored as a String in decimal representation. Therefore, you can retrieve the value later by calling either by getDouble() or getString().
Public method | AddInt | Set the given key to the given integer value. The number will be stored as a String in decimal representation. Therefore, you can retrieve the value later by calling either by getInt(), getDouble(), or getString().
Public method | AddList | Set the given key to the list value. Note that the values in the list will all be converted to strings, so getList will return a list of Strings.
Public method | AddString | Set the given key to the given string value.
Public method | Clear | Clears the contents of this LogEntry.
Public method | Contains | Determines whether the LogEntry contains an element with the specified key.
Public method | CopyTo | Copies the entire LogEntry to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDouble | Get the value associated with the given key. If the value was originally set via setInt() or setString(), then this method will still succeed as long as the value is a valid decimal number.
Public method | GetEnumerator | Returns an IDictionaryEnumerator for the LogEntry.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInt | Get the integer value associated with the given key. If the value was originally set via setString(), then this method will still succeed as long as the value is a valid decimal integer.
Public method | GetList | Get the given list value associated with a given key. If the value was not originally set using setList, this method will return a list with a single item containing the string representation of the original value. Any changes made to the IList object after calling getList will not be reflected in the LogEntry's value. In order to change the value of the list contents, setList() must be used.
Public method | GetString | Get the value associated with the given key.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the item with the specified key
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also


Add Method

[image]

Endeca Logging API
LogEntry..::..Add Method
LogEntry Class See Also Send Feedback
Adds a key/value pair to this LogEntry object.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual void Add(
    Object key,
    Object value
)
Visual Basic
Public Overridable Sub Add ( _
    key As Object, _
    value As Object _
)
Visual C++
public:
virtual void Add(
    Object^ key,
    Object^ value
)

Parameters

key
Type: System..::..Object
The Object to use as the key of the element to add.
value
Type: System..::..Object
The Object to use as the value of the element to add.

Implements

IDictionary..::..Add(Object, Object)

See Also


AddDouble Method

[image]

Endeca Logging API
LogEntry..::..AddDouble Method
LogEntry Class See Also Send Feedback
Set the given key to the given double value. The number will be stored as a String in decimal representation. Therefore, you can retrieve the value later by calling either by getDouble() or getString().

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public void AddDouble(
    string key,
    double value
)
Visual Basic
Public Sub AddDouble ( _
    key As String, _
    value As Double _
)
Visual C++
public:
void AddDouble(
    String^ key,
    double value
)

Parameters

key
Type: System..::..String
The String to use as the key of the element to set.
value
Type: System..::..Double
The int to use as the value of the element to add.

Exceptions

Exception | Condition
System..::..ArgumentException | An element with the same key already exists

See Also


AddInt Method

[image]

Endeca Logging API
LogEntry..::..AddInt Method
LogEntry Class See Also Send Feedback
Set the given key to the given integer value. The number will be stored as a String in decimal representation. Therefore, you can retrieve the value later by calling either by getInt(), getDouble(), or getString().

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public void AddInt(
    string key,
    int value
)
Visual Basic
Public Sub AddInt ( _
    key As String, _
    value As Integer _
)
Visual C++
public:
void AddInt(
    String^ key,
    int value
)

Parameters

key
Type: System..::..String
The String to use as the key of the element to set.
value
Type: System..::..Int32
The int to use as the value of the element to add.

Exceptions

Exception | Condition
System..::..ArgumentException | An element with the same key already exists

See Also


AddList Method

[image]

Endeca Logging API
LogEntry..::..AddList Method
LogEntry Class See Also Send Feedback
Set the given key to the list value. Note that the values in the list will all be converted to strings, so getList will return a list of Strings.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public void AddList(
    string key,
    IList value
)
Visual Basic
Public Sub AddList ( _
    key As String, _
    value As IList _
)
Visual C++
public:
void AddList(
    String^ key,
    IList^ value
)

Parameters

key
Type: System..::..String
The String to use as the key of the element to set.
value
Type: System.Collections..::..IList
The IList to use as the value of the element to add.

See Also


AddString Method

[image]

Endeca Logging API
LogEntry..::..AddString Method
LogEntry Class See Also Send Feedback
Set the given key to the given string value.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public void AddString(
    string key,
    string value
)
Visual Basic
Public Sub AddString ( _
    key As String, _
    value As String _
)
Visual C++
public:
void AddString(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::..String
The String to use as the key of the element to add.
value
Type: System..::..String
The String to use as the value of the element to add.

Exceptions

Exception | Condition
System..::..ArgumentException | An element with the same key already exists

See Also


Clear Method

[image]

Endeca Logging API
LogEntry..::..Clear Method
LogEntry Class See Also Send Feedback
Clears the contents of this LogEntry.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IDictionary..::..Clear()()()()

See Also


Contains Method

[image]

Endeca Logging API
LogEntry..::..Contains Method
LogEntry Class See Also Send Feedback
Determines whether the LogEntry contains an element with the specified key.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual bool Contains(
    Object key
)
Visual Basic
Public Overridable Function Contains ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ key
)

Parameters

key
Type: System..::..Object
They key to locate in the LogEntry.

Return Value

true if the LogEntry contains an element with they key; otherwise, false.

Implements

IDictionary..::..Contains(Object)

See Also


CopyTo Method

[image]

Endeca Logging API
LogEntry..::..CopyTo Method
LogEntry Class See Also Send Feedback
Copies the entire LogEntry to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the DictionaryEntry objects copied from LogEntry. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source LogEntry is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source LogEntry be cast automatically to the type of the destination array.

See Also


GetDouble Method

[image]

Endeca Logging API
LogEntry..::..GetDouble Method
LogEntry Class See Also Send Feedback
Get the value associated with the given key. If the value was originally set via setInt() or setString(), then this method will still succeed as long as the value is a valid decimal number.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public double GetDouble(
    string key
)
Visual Basic
Public Function GetDouble ( _
    key As String _
) As Double
Visual C++
public:
double GetDouble(
    String^ key
)

Parameters

key
Type: System..::..String
The String to use as the key of the element to get.

Return Value

Returns the value associated with the given key.

Exceptions

Exception | Condition
System..::..FormatException | If the value is not numeric.
System..::..NullReferenceException | if no value is associated with the given key

See Also


GetEnumerator Method

[image]

Endeca Logging API
LogEntry..::..GetEnumerator Method
LogEntry Class See Also Send Feedback
Returns an IDictionaryEnumerator for the LogEntry.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual IDictionaryEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IDictionaryEnumerator
Visual C++
public:
virtual IDictionaryEnumerator^ GetEnumerator()

Return Value

An IDictionaryEnumerator for the LogEntry.

Implements

IDictionary..::..GetEnumerator()()()()

See Also


GetInt Method

[image]

Endeca Logging API
LogEntry..::..GetInt Method
LogEntry Class See Also Send Feedback
Get the integer value associated with the given key. If the value was originally set via setString(), then this method will still succeed as long as the value is a valid decimal integer.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public int GetInt(
    string key
)
Visual Basic
Public Function GetInt ( _
    key As String _
) As Integer
Visual C++
public:
int GetInt(
    String^ key
)

Parameters

key
Type: System..::..String
The String to use as the key of the element to get.

Return Value

Returns the integer value associated with the given key.

Exceptions

Exception | Condition
System..::..FormatException | If the value is not numeric.
System..::..NullReferenceException | if no value is associated with the given key

See Also


GetList Method

[image]

Endeca Logging API
LogEntry..::..GetList Method
LogEntry Class See Also Send Feedback
Get the given list value associated with a given key. If the value was not originally set using setList, this method will return a list with a single item containing the string representation of the original value. Any changes made to the IList object after calling getList will not be reflected in the LogEntry's value. In order to change the value of the list contents, setList() must be used.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public IList GetList(
    string key
)
Visual Basic
Public Function GetList ( _
    key As String _
) As IList
Visual C++
public:
IList^ GetList(
    String^ key
)

Parameters

key
Type: System..::..String
The String to use as the key of the element to get.

Return Value

Returns the list value associated with the given key.

See Also


GetString Method

[image]

Endeca Logging API
LogEntry..::..GetString Method
LogEntry Class See Also Send Feedback
Get the value associated with the given key.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public string GetString(
    string key
)
Visual Basic
Public Function GetString ( _
    key As String _
) As String
Visual C++
public:
String^ GetString(
    String^ key
)

Parameters

key
Type: System..::..String
The String to use as the key of the element to get.

Return Value

null if no value is associated with the given key.

See Also


Remove Method

[image]

Endeca Logging API
LogEntry..::..Remove Method
LogEntry Class See Also Send Feedback
Removes the item with the specified key

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual void Remove(
    Object key
)
Visual Basic
Public Overridable Sub Remove ( _
    key As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ key
)

Parameters

key
Type: System..::..Object
The key of the element to remove.

Implements

IDictionary..::..Remove(Object)

See Also


LogEntry Properties

[image] [image]

Endeca Logging API
LogEntry Properties
LogEntry Class See Also Send Feedback

The LogEntry type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the LogEntry.
Public property | IsFixedSize | Gets a value indicating whether the LogEntry has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the LogEntry is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the LogEntry is synchronized (thread-safe).
Public property | Item | Gets or sets an element with the specified key.
Public property | Keys | Gets an ICollection containing the keys of this LogEntry.
Public property | SyncRoot | This operation is not supported.
Public property | Values | Gets an ICollection containing the values of this LogEntry.

See Also


Count Property

[image]

Endeca Logging API
LogEntry..::..Count Property
LogEntry Class See Also Send Feedback
Gets the number of elements actually contained in the LogEntry.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the LogEntry.

Implements

ICollection..::..Count

See Also


IsFixedSize Property

[image]

Endeca Logging API
LogEntry..::..IsFixedSize Property
LogEntry Class See Also Send Feedback
Gets a value indicating whether the LogEntry has a fixed size.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the LogEntry is a fixed size; otherwise, false. The default is false.

Implements

IDictionary..::..IsFixedSize

See Also


IsReadOnly Property

[image]

Endeca Logging API
LogEntry..::..IsReadOnly Property
LogEntry Class See Also Send Feedback
Gets a value indicating whether the LogEntry is read-only.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the LogEntry is read-only; otherwise, false. The default is false.

Implements

IDictionary..::..IsReadOnly

See Also


IsSynchronized Property

[image]

Endeca Logging API
LogEntry..::..IsSynchronized Property
LogEntry Class See Also Send Feedback
Gets a value indicating whether access to the LogEntry is synchronized (thread-safe).

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the LogEntry is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also


Item Property

[image]

Endeca Logging API
LogEntry..::..Item Property
LogEntry Class See Also Send Feedback
Gets or sets an element with the specified key.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual Object this[
    Object key
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    key As Object _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}

Parameters

key
Type: System..::..Object
The key of the element to get.

Field Value

An element with the specified key.

Implements

IDictionary..::..Item[([( Object])])

See Also


Keys Property

[image]

Endeca Logging API
LogEntry..::..Keys Property
LogEntry Class See Also Send Feedback
Gets an ICollection containing the keys of this LogEntry.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual ICollection Keys { get; }
Visual Basic
Public Overridable ReadOnly Property Keys As ICollection
    Get
Visual C++
public:
virtual property ICollection^ Keys {
    ICollection^ get ();
}

Field Value

An ICollection containing the keys of this LogEntry.

Implements

IDictionary..::..Keys

See Also


SyncRoot Property

[image]

Endeca Logging API
LogEntry..::..SyncRoot Property
LogEntry Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the LogEntry.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also


Values Property

[image]

Endeca Logging API
LogEntry..::..Values Property
LogEntry Class See Also Send Feedback
Gets an ICollection containing the values of this LogEntry.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public virtual ICollection Values { get; }
Visual Basic
Public Overridable ReadOnly Property Values As ICollection
    Get
Visual C++
public:
virtual property ICollection^ Values {
    ICollection^ get ();
}

Field Value

An ICollection containing the values of this LogEntry.

Implements

IDictionary..::..Values

See Also


LogException Class

[image]

Endeca Logging API
LogException Class
Members See Also Send Feedback
Represents an exception that may arise from trying to submit a LogEntry to the logging server.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public class LogException : Exception
Visual Basic
Public Class LogException _
    Inherits Exception
Visual C++
public ref class LogException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Logging..::..LogException

See Also

LogException Members


LogException Members

[image] [image]

Endeca Logging API
LogException Members
LogException Class Constructors Methods Properties See Also Send Feedback

The LogException type exposes the following members.

Constructors

 | Name | Description
Public method | LogException()()()() | Initializes a new instance of the LogException class
Public method | LogException(String) | Represents an exception that may arise from trying to submit a LogEntry to the logging server. Includes a message describing the exception.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LogException Class


LogException Constructor

[image] [image]

Endeca Logging API
LogException Constructor
LogException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogException()()()() | Initializes a new instance of the LogException class
Public method | LogException(String) | Represents an exception that may arise from trying to submit a LogEntry to the logging server. Includes a message describing the exception.

See Also

LogException Class
LogException Members


LogException Constructor

[image]

Endeca Logging API
LogException Constructor
LogException Class See Also Send Feedback
Initializes a new instance of the LogException class

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public LogException()
Visual Basic
Public Sub New
Visual C++
public:
LogException()

See Also

LogException Class
LogException Overload


LogException Constructor (String)

[image]

Endeca Logging API
LogException Constructor (String)
LogException Class See Also Send Feedback
Represents an exception that may arise from trying to submit a LogEntry to the logging server. Includes a message describing the exception.

Namespace: Endeca.Logging
Assembly: Endeca.Logging (in Endeca.Logging.dll) Version: 11.0.0.0

Syntax

C#
public LogException(
    string s
)
Visual Basic
Public Sub New ( _
    s As String _
)
Visual C++
public:
LogException(
    String^ s
)

Parameters

s
Type: System..::..String
A message describing the exception.

See Also

LogException Class
LogException Overload


LogException Methods

[image] [image]

Endeca Logging API
LogException Methods
LogException Class See Also Send Feedback

The LogException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LogException Class


LogException Properties

[image] [image]

Endeca Logging API
LogException Properties
LogException Class See Also Send Feedback

The LogException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LogException Class