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Chapter

1
Introduction

Introduction provides a content overview of this
guide with a brief summary about incidents,

Topics:

• Purpose of this documentation.....8 notifications, and the ID ranges for alarms and
• Online Help organization.....8 events. It also includes Tekelec contact information

and how to locate product documentation on the
Tekelec Customer Support site.

• Scope and Audience.....9
• Documentation Admonishments.....9
• Customer Care Center.....9
• Emergency Response.....12
• Related Publications.....12
• Locate Product Documentation on the Customer

Support Site.....12
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Purpose of this documentation

This documentation:

• Gives a conceptual overview of the application's purpose, architecture, and functionality
• Describes the pages and fields on the application GUI (Graphical User Interface)
• Provides procedures for using the application interface
• Explains the organization of, and how to use, the documentation

Online Help organization

There are eight items on the main menu.

Getting Started

The Getting Started section of the documentation provides an overview of the SDS application and
documentation. In this section you can find information about the SDS including a product overview,
the system architecture, and functionality. Additionally, this section familiarizes you with common
SDS GUI features including user interface elements, main menu options, supported browsers, and
common user interface widgets.

OAM

The OAM section of the documentation describes:

• Administration
• Configuration
• Alarms and Events
• Security Log
• Status and Manage
• Measurements

The OAM section of the documentation explains how to use these GUI pages to view and manage the
basic operation, administration, and maintenance for the SDS.

Communication Agent

The Communication Agent section of the documentation describes the plug-in included with SDS that
includes infrastructure features and services for enabling inter-server communication. This includes:

• Overview
• Configuration
• Maintenance

The Communication Agent GUI menu also lets you monitor the operational status of High-Availability
(HA) Services Sub-Resources.
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SDS

The SDS section of the documentation describes GUI pages nested under the SDS Menu options. These
GUI Menu options allow you to manage configurations as well as Audit, Query and Destination
Routing Entities NAI Hosts maintenance. The SDS section of the documentation explains how to
perform configuration and maintenance tasks using these GUI pages.

SDS Alarms, KPIs, and Measurements (AKM)

The SDS AKM section provides information relevant to understanding alarms and events that may
occur in the SDS application; recovery procedures for addressing alarms and events, as necessary;
tasks for viewing alarms and events, generating alarms reports, and viewing and exporting alarms
and events history; and information, including any relevant customer actions for addressing unusual
measurement values.

Scope and Audience

This guide is intended for trained and qualified system operators and administrators who are
responsible for managing an SDS system.

Documentation Admonishments

Admonishments are icons and text throughout this manual that alert the reader to assure personal
safety, to minimize possible service interruptions, and to warn of the potential for equipment damage.

Table 1: Admonishments

DANGER:

(This icon and text indicate the possibility of personal injury.)

WARNING:

(This icon and text indicate the possibility of equipment damage.)

CAUTION:

(This icon and text indicate the possibility of service interruption.)

Customer Care Center

The Tekelec Customer Care Center is your initial point of contact for all product support needs. A
representative takes your call or email, creates a Customer Service Request (CSR) and directs your
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requests to the Tekelec Technical Assistance Center (TAC). Each CSR includes an individual tracking
number. Together with TAC Engineers, the representative will help you resolve your request.

The Customer Care Center is available 24 hours a day, 7 days a week, 365 days a year, and is linked
to TAC Engineers around the globe.

Tekelec TAC Engineers are available to provide solutions to your technical questions and issues 7
days a week, 24 hours a day. After a CSR is issued, the TAC Engineer determines the classification of
the trouble. If a critical problem exists, emergency procedures are initiated. If the problem is not critical,
normal support procedures apply. A primary Technical Engineer is assigned to work on the CSR and
provide a solution to the problem. The CSR is closed when the problem is resolved.

Tekelec Technical Assistance Centers are located around the globe in the following locations:

Tekelec - Global

Email (All Regions): support@tekelec.com

• USA and Canada

Phone:

1-888-FOR-TKLC or 1-888-367-8552 (toll-free, within continental USA and Canada)

1-919-460-2150 (outside continental USA and Canada)

TAC Regional Support Office Hours:

8:00 a.m. through 5:00 p.m. (GMT minus 5 hours), Monday through Friday, excluding holidays
• Caribbean and Latin America (CALA)

Phone:

USA access code +1-800-658-5454, then 1-888-FOR-TKLC or 1-888-367-8552 (toll-free)

TAC Regional Support Office Hours (except Brazil):

10:00 a.m. through 7:00 p.m. (GMT minus 6 hours), Monday through Friday, excluding holidays

• Argentina

Phone:

0-800-555-5246 (toll-free)
• Brazil

Phone:

0-800-891-4341 (toll-free)

TAC Regional Support Office Hours:

8:00 a.m. through 5:48 p.m. (GMT minus 3 hours), Monday through Friday, excluding holidays
• Chile

Phone:

1230-020-555-5468
• Colombia

Phone:
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01-800-912-0537
• Dominican Republic

Phone:

1-888-367-8552
• Mexico

Phone:

001-888-367-8552
• Peru

Phone:

0800-53-087
• Puerto Rico

Phone:

1-888-367-8552 (1-888-FOR-TKLC)
• Venezuela

Phone:

0800-176-6497

• Europe, Middle East, and Africa

Regional Office Hours:

8:30 a.m. through 5:00 p.m. (GMT), Monday through Friday, excluding holidays

• Signaling

Phone:

+44 1784 467 804 (within UK)
• Software Solutions

Phone:

+33 3 89 33 54 00

• Asia

• India

Phone:

+91 124 436 8552 or +91 124 436 8553

TAC Regional Support Office Hours:

10:00 a.m. through 7:00 p.m. (GMT plus 5 1/2 hours), Monday through Saturday, excluding
holidays

• Singapore

Phone:

+65 6796 2288
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TAC Regional Support Office Hours:

9:00 a.m. through 6:00 p.m. (GMT plus 8 hours), Monday through Friday, excluding holidays

Emergency Response

In the event of a critical service situation, emergency response is offered by the Tekelec Customer Care
Center 24 hours a day, 7 days a week. The emergency response provides immediate coverage, automatic
escalation, and other features to ensure that the critical situation is resolved as rapidly as possible.

A critical situation is defined as a problem with the installed equipment that severely affects service,
traffic, or maintenance capabilities, and requires immediate corrective action. Critical situations affect
service and/or system operation resulting in one or several of these situations:

• A total system failure that results in loss of all transaction processing capability
• Significant reduction in system capacity or traffic handling capability
• Loss of the system’s ability to perform automatic system reconfiguration
• Inability to restart a processor or the system
• Corruption of system databases that requires service affecting corrective actions
• Loss of access for maintenance or recovery operations
• Loss of the system ability to provide any required critical or major trouble notification

Any other problem severely affecting service, capacity/traffic, billing, and maintenance capabilities
may be defined as critical by prior discussion and agreement with the Tekelec Customer Care Center.

Related Publications

For information about additional publications that are related to this document, refer to the Related
Publications document. The Related Publications document is published as a part of the Release
Documentation and is also published as a separate document on the Tekelec Customer Support Site.

Locate Product Documentation on the Customer Support Site

Access to Tekelec's Customer Support site is restricted to current Tekelec customers only. This section
describes how to log into the Tekelec Customer Support site and locate a document. Viewing the
document requires Adobe Acrobat Reader, which can be downloaded at www.adobe.com.

1. Log into the Tekelec Customer Support site.

Note:  If you have not registered for this new site, click the Register Here link. Have your customer
number available. The response time for registration requests is 24 to 48 hours.

2. Click the Product Support tab.
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3. Use the Search field to locate a document by its part number, release number, document name, or
document type. The Search field accepts both full and partial entries.

4. Click a subject folder to browse through a list of related files.
5. To download a file to your location, right-click the file name and select Save Target As.
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Chapter

2
Subscriber Database Server (SDS) overview

Subscriber Database Server (SDS) provides the
central provisioning of the Full-Address Based
Resolution (FABR) data. The SDS, which is deployed
geo-redundantly at a Primary and Disaster recovery
site, connects with the Query Server and the Data
Processor Site Operation Administration and
Maintenance (DP SOAM) servers at each Diameter
Signaling Router (DSR) site or a standalone DP site
to replicate and recover provisioned data to the
associated components.

SDS provides the following functionality:

• Automated Performance Data Export (APDE)
• SDS database
• GUI-based provisioning
• Support SOAP over HTTP and XML over TCP

as provisioning interfaces
• SQL Interface
• CSV and/or XML format export and import
• Real time replication to:

• Local standby server at the Primary site
• Local query server at the Primary site
• Each server at the Disaster Recovery site
• Each DP SOAM and DP at up to 24 DSR sites

• DB processor – application hosting the subscriber
data for access by the DSR applications

• Automatic NPA Split processing
• Provisioning measurements and KPIs
• Alarms, events, and logs for all interfaces
• DB audit
• Query server
• Backup and restore
• Disaster recovery

The SDS menu options provide the ability to
perform SDS-related configuration and maintenance
tasks to support the FABR application of the DSR.
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The available SDS menu options will vary based on
the type of server you are logged into and the
permissions assigned to your group. If you do not
see a menu option you need, make sure you are
logged into the appropriate type of server and ask
your administrator to make sure the group your
user ID belongs to has the appropriate permissions.
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Chapter

3
Configuration

The SDS Configuration  menu options allow you
to configure provisioning options and view, insert,

Topics:

• Options configuration.....17 edit, and delete provisioning connections, NAI hosts,
destinations, and routing entities.• Connections configuration.....22

• NAI Hosts configuration.....25 The available database menu options will vary based
on the type of server you are logged into and the• Destinations configuration.....27
permissions assigned to your group. If you do not• Destination map configuration.....30
see a menu option you need, make sure you are• Routing entities configuration.....33
logged into the appropriate type of server and ask
your administrator to make sure the group your
user ID belongs to has the appropriate permissions.
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Options configuration

The Options page allows you to control how the mechanized interface works and controls features
such as Import and Export.

Provisioning options

Connections between the application and the provisioning client are set up using the Connections
page (for more information, see Connections configuration. The Options page allows you to manage
configuration options for these connections. Use this page to configure:

• Whether to allow connections and the maximum number of connections allowed
• Number of seconds of inactivity allowed before a connection is timed out
• Whether to log provisioning messages
• Number of seconds allowed between a transaction being committed and becoming durable
• TCP listening ports
• Whether to allow to importing from and exporting to a Remote Host

Import options

The status of provisioning imports can be viewed using the SDS Maintenance Import page. For more
information, see Import Status maintenance. Provisioning imports from a remote host are configured
through the SDS Configuration Options page. Use this page to configure:

• Whether provisioning imports are enabled
• Remote host information, including the IP address, username, password, and import directory

name
• Whether the import mode is blocking or non-blocking

Export options

Provisioning exports are scheduled through the SDS Configuration Export page and the export status
can be viewed through the SDS Maintenance Export Status page. For more information about this
see Import Status maintenance. Use the SDS Configuration Options page to configure:

• Whether or not exports are allowed to be copied from this server to the remote host
• Remote host information, including the IP address, username, password, and export directory

name
• Whether the export mode is blocking or non-blocking

Options configuration elements

This table describes the fields on the Options page.
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Table 2: Options Configuration Elements

Data Input NotesDescriptionElement

Format: Check box

Range: Checked, Unchecked

If checked, the commands and
responses will be displayed on
the GUI when provisioning data.

Display Command Output

Default: Unchecked

Format: Check box

Range: Checked, Unchecked

If checked, incoming
provisioning connections are
allowed.

Allow Connections

Default: Checked

Format: Digits only

Range: 10–1000

The maximum number of
database manipulation
commands per transaction.

Max Transaction Size

Default: 50

Format: Check box

Range: Checked, Unchecked

If checked, all incoming and
outgoing provisioning messages
will be logged in the command
log.

Log Provisioning Messages

Default: Checked

Format: Digits only; seconds

Range: 2–3600

The number of seconds allowed
between a transaction being
committed and it becoming
durable.

Transaction Durability Timeout

Default: 5

Format: Check box

Range: Checked, Unchecked

If checked, import files are
imported from a remote host.

Remote Import Enabled

Default: Unchecked

Format: Pulldown menu

Range: Non-Blocking, Blocking

If set to Non-Blocking, updates
are allowed on all provisioning
connections while the remote
import operation is in progress.

If set to Blocking, updates are
not allowed.

Remote Import Mode

Default: Non-Blocking

Format: Alphanumeric

Range: 0–15 characters

The IP address of remote import
host queried for import files.

Remote Import Host IP Address

Format: Alphanumeric

Range: 0–255 characters

The Username for remote import
host user.

Remote Import User

Format: Alphanumeric

Range: 0–255 characters

The password to exchange ssh
keys with the remote import
host. The password is cleared

Remote Import Password
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Data Input NotesDescriptionElement

from this table once the keys
have been exchanged.

Format: Alphanumeric

Range: 0–255 characters

The remote import host directory
where the import files are stored.

Remote Import Directory

Format: Pulldown menu

Range: Non-Blocking, Blocking

If set to Non-Blocking, updates
are allowed on all connections
while the export operation is in
progress.

If set to Blocking, updates are
not allowed.

Export Mode

Default: Non-Blocking

Format: Selection box

Range: Selected, Deselected

If checked, export files will be
copied to the remote export host.

Remote Export Transfers
Enabled

Default: Deselected

Format: Alphanumeric

Range: 0–15 characters

The IP address of the remote
export host to where export files
may be automatically
transferred.

Remote Export Host IP Address

Format: Alphanumeric

Range: 0–255 characters

The username for remote export
host user.

Remote Export User

Format: Alphanumeric

Range: 0–255 characters

The Password to exchange ssh
keys with the remote export
host. The password is cleared

Remote Export Password

from this table once the keys
have been exchanged.

Format: Alphanumeric

Range: 0–255 characters

If export is configured, the
export files are transferred to the
location on the remote export
host.

Remote Export Directory

Format: Digits only

Range: 5–2500

The maximum number of
retrieval messages that can be
received and buffered by the

Remote Audit Receive Window
Size

Default: 10Provisioning Database
Application on the remote
system. Once this amount is
reached, no more messages will
be sent until acknowledgments
are received from the remote
system.
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Data Input NotesDescriptionElement

Format: Digits only

Range: 5–2500

The maximum rate of
messages/second in which
retrieval messages will be sent

Remote Audit Send Message
Rate

Default: 10to the Provisioning Database
Application on the remote
systems

Format: Digits only

Range: 1–10000

The maximum number of
records that can be queried per
request message.

Remote Audit Number Range
Limit

Default: 10

Format: Selection box

Range: Selected, Deselected

Whether or not to relay
successful incoming
provisioning requests to a

PDB Relay Enabled

Default: DeselectedProvisioning Database
Application on a remote system.

Note:  This feature requires that
the Log Provisioning Messages
option is enabled.

Format: Alphanumeric

Range: 0-15 characters

The VIP address of the primary
remote system of the
Provisioning Database
Application on a remote system.

Note:  Changes to the TCP
listening port do not take affect
until PDB Relay is restarted.

PDB Relay Primary Remote
System VIP Address

Format: Alphanumeric

Range: 0-15 characters

The VIP address of the Disaster
Recovery remote system on
which the Provisioning Database
Application is running.

Note:  Changes to the VIP
address do not take affect until
PDB Relay is restarted.

PDB Relay Disaster Recovery
Remote System VIP Address

Format: Digits only

Range: 0–65535

The TCP listening port of the
Provisioning Database
Application on the remote
system.

Note:  Changes to the VIP
address do not take affect until
PDB Relay is restarted.

PDB Relay Remote System Port

Default: 5873
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Data Input NotesDescriptionElement

Format: Digits only

Range: 5–2500

The maximum number of
provisioning commands that can
be received and buffered by the

PDB Relay Receive Window Size

Default: 10Provisioning Database
Application on the remote
system. After this amount is
reached, no more commands will
be sent until acknowledgments
are received from the remote
system.

Format: Digits only

Range: 5–2500

The maximum rate (in
commands/second) in which
commands will be relayed/sent

PDB Relay Send Command Rate

Default: 200to the Provisioning Database
Application on remote system.

Format: Digits only

Range: 5–2500

The timestamp of the last
provisioning message relayed to
the Provisioning Database

PDB Relay Timestamp
(read-only)

Default: 10Application on the remote
system.

Format: Digits only

Range: 0–65535

XML interface TCP (unsecured)
listening port.

To disable this port, enter 0. If
changing this port, the XDS

XML Interface Port

Default: 5875

process must be restarted to
make change take affect.

Format: Digits only; seconds

Range: 1–86400

The maximum number of
seconds that an open connection
will remain active without a

XML Interface Idle Timeout

Default: 1200request being sent and the
connection is dropped.

Format: Digits only

Range: 1–120

The maximum number of
simultaneous XML interface
client connections.

Maximum XML Connections

Default: 120

Format: Digits only

Range: 0–65535

The SOAP interface TCP
listening port.

To disable this port, enter 0. If
changing this port, the SOAP

SOAP Interface Port

Default: 5876

process must be restarted to
make change take affect.
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Data Input NotesDescriptionElement

Format: Digits only

Range: 1–120

The maximum number of
simultaneous SOAP interface
client connections.

Maximum SOAP Connections

Default: 120

Format: Pulldown menu

Range: Secure, Unsecure

If set to Secure, the SOAP
interface operates in secure
mode (using SSL).

If set to Unsecure, the SOAP
interface operates in unsecure
mode (using plain text).

SOAP Secure Mode

Default: Unsecure

Format: Digits only; seconds

Range: 0–3600

The maximum number of
seconds that a transaction will
remain open before

Maximum Transaction Lifetime

Default: 60automatically being rolled back
if a commit or rollback is not
performed.

To disable this timeout, enter 0.

Editing options

You can only perform this task when logged into the active SDS server.

1. Select SDS ➤ Configuration ➤ Options.
The SDS Configuration Options page appears.

2. Modify the options you want to change by entering information in the appropriate fields.
For a detailed explanation about the options and valid input for these fields, see Options configuration
elements.

3. Click Apply.
If field validations succeed, the changes are saved and you remain on the same page. A successful
update message appears.

If the page contains any values that are not valid or are out of range, an error message appears.

Connections configuration

The Connections page allows you to manage the configuration for servers permitted to establish a
connection to the active Primary Provisioning Site's Active SDS Server. Only the servers specified in
the Connections list are allowed to remotely connect to the server and execute commands.

Note:  Connection options must be set prior to configuring connections. For more information on these
options, see Options configuration.
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SDS allows up to 120 simultaneous provisioning connections and supports secure and unsecure SOAP
connections. While the application is capable of supporting 120 connections, the maximum number
of connections allowed can be limited using the Options page. For more information about this option,
see Options configuration.

From the Connections page, you can:

• Filter the list of servers to display only the desired servers.
• View the list of servers allowed to establish a remote connection and each server's permissions.
• Configure the SDS to allow connection requests from remote servers.
• Modify the System ID, IP address, and permissions for listed servers.
• Delete servers from the connections list.

Connections configuration elements

This table describes the fields on the Connections View page.

Table 3: Connections Configuration Elements

Data Input NotesDescriptionElement

Format: Selectable items.Selectable columns where you
can choose to edit or delete
selections.

Action columns

Format: Selectable list.Pulldown menu of available
filters and additional fields to
modify the search options.

Filter fields

Format: Alphanumeric

Range: 1–8 characters

Identification for the systemSystem ID

Format: Alphanumeric

Range: IPV4 dot-decimal
notation (where x 

1
 is 1-255 and

x 
2
 is 0-255.

IP address of the client that will
connect to SDS

IP Address

Format: Pulldown list

Range: READ_ONLY,
READ_WRITE

Database permissions for this
client

Permission

Default: READ_ONLY

Viewing connections

You can perform this task when logged into an SDS or from the DP SOAM GUI.

Select SDS ➤ Configuration ➤ Connections.
The Connections page appears.

The currently allowed connections are listed in the table.
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Inserting connections

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Connections.
The Connections page appears.

2. Click Insert.
The SDS Configuration Connections [Insert] page appears.

3. Enter a system ID in the System ID field.
4. Enter a unique IP address for the connection in the IP Address field.
5. Select the permissions level for the connection from the Permissions pulldown menu.

• Select READ_ONLY to grant read-only access for the client with this connection. This is the
default.

• Select READ_WRITE to grant read and write access for the client with this connection.

6. Perform one of the following:

• Click OK  to save the connection and return to the SDS configuration connections page.
• Click Apply  to save the connection and remain on this page.
• Click Cancel to return to the SDS Configuration Connections page without saving the changes.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:

• Any required field is empty; no value was entered or selected
• The entry in any field is not valid (wrong data type or out of the valid range)
• The IP Address is not unique; it already exists in the system

Editing connections

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Connections.
The SDS Configuration Connections page appears.

2. Locate the connection you want to edit and click Edit.
The SDS Configuration Connections [Edit] page appears.

3. Edit the System ID, IP Address, and/or Permission for the connection.
For more information about these fields, see Connections configuration elements.

4. Perform one of the following:

• Click OK to save the changes and return to the SDS configuration connections page.
• Click Apply to save the changes and remain on this page.

If field validations succeed, the connection is saved.
If OK or Apply is clicked and any of the following conditions exist, an error message appears:

• If the entry in any field is not valid or are out of range
• If a required field is empty (not entered)
• If the IP Address is not unique
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Deleting connections

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Connections.
The SDS Configuration Connections page appears.

2. Locate the connection you want to delete and click Delete.
A popup confirmation window appears.

3. Perform one of the following actions:

• Click OK to delete the connection.
• Click Cancel to cancel the delete function and return to the SDS Configuration Connections

page.

NAI Hosts configuration

The NAI Hosts page allows you to manage the Network Access Identifier (NAI) host systems that are
used for provisioning NAI User-associated routing entities.

From the NAI Hosts page, you can:

• Filter the list of hosts to display only the desired hosts.
• View the NAI Hosts configured for NAI User.
• Add a NAI  Host.
• Delete a NAI Host.

NAI Hosts configuration elements

This table describes the fields on the NAI Hosts View and Insert pages.

Table 4: NAI Hosts Configuration Elements

Data Input NotesDescriptionElement

Format: alphanumeric (A-Z, a-z,
0-1) and special characters:

Network Access Identifier
hostname

NAI Host

period (.), hyphen (-), plus (+),
underscore (_), At sign (@),
dollar sign ($), pound or number
sign (#), forward slash (/),
double quote ("), asterisk (*),
exclamation point (!), and colon
(:)

Range: 1–64 characters
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Viewing NAI hosts

You can perform this task when logged into an SDS or from the DP SOAM GUI.

Select SDS ➤ Configuration ➤ NAI Hosts.
The SDS Configuration NAI Hosts page appears.

The current NAI hosts are listed in the table.

Inserting NAI hosts

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ NAI Hosts.
The SDS Configuration NAI Hosts  page appears.

2. Click Insert.
The SDS Configuration NAI Hosts [Insert] page appears.

3. Enter a unique hostname in the NAI Host field.
4. Perform one of the following:

• Click OK to save the hostname and return to the SDS configuration NAI Hosts page.
• Click Apply to save the hostname and remain on this page.
• Click Cancel to return to the SDS Configuration NAI Hosts page without saving the changes.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:

• The required field is empty; no value was entered.
• The entry in the NAI Host field contains an invalid character.
• The hostname is not unique; it already exists in the system.

Deleting NAI hosts

You can only perform this task when logged into the Active Primary SDS.

Before performing this task, disable and delete any association that may exist between the NAI host
and routing entity (NAI User or Wildcard NAI User).

1. Select SDS ➤ Configuration ➤ NAI Hosts.
The SDS Configuration NAI Hosts  page appears.

2. Locate the NAI host you want to delete and click Delete.
A popup confirmation window appears.

3. Perform one of the following actions:

• Click OK to delete the NAI Host.
• Click Cancel to cancel the delete function and return to the SDS Configuration NAI Hosts

page.

If OK is clicked and the following condition exists, an error message appears:

• The NAI Host is in use by a routing entity.

26910-6565-001 Revision A, August 2012

Configuration



Destinations configuration

The Destinations page allows you to manage routing destinations used by routing entities.

From the SDS Configuration Destination page, you can perform the following actions:

• Retrieve information for a specific Destination.
• Add a Destination.
• Update the information associated with an existing Destination.
• Delete a Destination.

Destinations configuration elements

This table describes the fields on the Destination Retrieve, Add, Update, and Delete tabs.

Table 5: Destinations Configuration Elements

Data Input NotesDescriptionElement

Retrieve and Delete tabs

Format: Alphanumeric (A-Z, a-z,
0-1) and special characters:

Name of the destinationName

period (.), hyphen (-), plus (+),
underscore (_), At sign (@),
dollar sign ($), pound or number
sign (#), forward slash (/),
double quote ("), asterisk (*),
exclamation point (!), and colon
(:)

Range: 1–32 characters; cannot
start with a digit and must
contain at least one alpha
character.

Add and Update tabs

Format: Alphanumeric (A-Z, a-z,
0-1) and special characters:

Name of the destinationName

period (.), hyphen (-), plus (+),
underscore (_), At sign (@),
dollar sign ($), pound or number
sign (#), forward slash (/),
double quote ("), asterisk (*),
exclamation point (!), and colon
(:)

Range: 1–32 characters; cannot
start with a digit and must
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Data Input NotesDescriptionElement

contain at least one alpha
character.

Format: Pulldown listType of destinationType

• IMS HSS
• LTE HSS
• PCRF
• OCF
• OFCS
• AAA
• User defined 1
• User defined 2

Format: String consisting of a list
of labels separated by dots. A

Unique fully qualified domain
name

FQDN

label might contain letters, digits,
dash (-), and underscore (_). A
label must begin with a letter or
underscore, and must end with
a letter or digit. Underscore can
be used only as the first
character.

Range: 0-255 characters

Format: String consisting of a list
of labels separated by dots. A

RealmRealm

label might contain letters, digits,
dash (-), and underscore (_). A
label must begin with a letter or
underscore, and must end with
a letter or digit. Underscore can
be used only as the first
character.

Range: 0-255 characters

Retrieving destinations

You can perform this task when logged into an SDS or from the DP SOAM GUI.

1. Select SDS ➤ Configuration ➤ Destinations.
The SDS Configuration Destinations page appears.

By default, the Retrieve tab is the viewable tab. If not, select the Retrieve tab.

2. Enter the destination you want to view in the Name field.

Note:  For a list of Destinations, select SDS ➤ Maintenance ➤ Query; then, select Destination from
the Data pulldown list.
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3. Click Retrieve.
The destination appears.

Adding destinations

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Destinations.
The SDS Configuration Destinations page appears.

2. Select the Add tab.
The Add tab appears.

3. Enter a unique name in the Name field.
4. Select the type of destination from the Type pulldown list.
5. Enter a fully-qualified domain name (FQDN) in the FQDN field.
6. Enter the realm in the Realm field.
7. Click Add to save the destination.

When Add is clicked and any of the following conditions exist, an error message appears:

• The entry in any field is not valid (wrong data type).
• The Destination name is not unique; it already exists in the system.

Updating destinations

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Destinations.
The SDS Configuration Destinations page appears.

2. Select the Update tab.
The Update tab appears.

3. Enter the destination you want to update in the Name field. Click Lookup.
The Update tab appears. with the destination information.

4. Edit the FQDN and/or Realm fields.
Use the keyword none to clear the attribute.

For more information about these fields, see Destinations configuration elements.

Important:  When updating a destination, you are permitted to leave both the FQDN andRealm
empty. This action is permitted and the destination is retained despite having no data for these
attributes.

5. Click Update to save the changes to the destination.
When Update is clicked and any of the following conditions exist, an error message appears:

• The entry in any field is not valid (wrong data type).
• The Destination and its associated change exists.
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Deleting destinations

You can only perform this task when logged into the Active Primary SDS.

A Destination cannot be deleted while any routing entity, NAI/Wildcard User, or Destination remains
associated with them. Before you perform this task, disable and delete any connections that use the
Destination

1. Select SDS ➤ Configuration ➤ Destinations.
The SDS Configuration Destinations page appears.

2. Select the Delete tab.
3. Enter a valid destination you want to delete in the Name field. Click Delete.

A popup confirmation window appears.
4. Perform one of the following actions:

• Click OK to delete the destination.
• Click Cancel to cancel the delete function and return to the SDS Configuration Destinations

page.

If OK is clicked and the following condition exists, an error message appears:

• No updates were made to the database.
• Field Name contains invalid character(s).
• Object currently in use; destination is used by a route.
• Object currently in use; destination is used by a destination map.

Destination map configuration

The Destination map page allows you to add, modify, or delete additional data on an existing
Destination.

From the Destination Map page, you can associate a destination to a HLR Router Network entity.

Destination map configuration elements

The SDS -> Configuration -> Destination Map page displays information in a tabular format. The
following table describes elements on this page.

Table 6: Destination Map Elements

Data Input NotesDescriptionElement

Format: Selectable items.Selectable columns where you
can choose to edit or delete
selections.

Action columns

Format: Selectable list.Pulldown menu of available
filters and additional fields to
modify the search options.

Filter fields
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Data Input NotesDescriptionElement

Format: Alphanumeric

Range: 1–32 characters

Destination field.Destination

Format: Numeric

Range: 8–15 characters

The E.164 address of a service
node used by HLR Router.

Network Entity

Viewing Destination Map connections

Use this page to view the list of Destination Map entries.

Select SDS ➤ Configuration ➤ Destination Map.
The Destination Map page appears.

The current destination maps are listed in the destination map table.

Inserting Destination Maps

Use this page to manually add a destination map to the database. A Destination and Network Entity
must be provided when adding a Destination Map entry. The Destination value must match a name
of an existing Destination entry. The OK and Apply buttons are disabled until a character is entered
into either the Destination or Network Entity field.

Note:  You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Destination Map.
The Destination Map page appears.

2. Click Insert.
The Destination Map [Insert] page appears.

3. Enter a Destination name in the Destination field. The name must match a Destination name that
has already been entered into the database.

4. Enter a E.164 address for the server node for the Network Entity in the Network Entity field.
5. Perform one of the following:

• Click OK  to save the destination map and return to the Destinations Map page.
• Click Apply  to save the destination map and remain on this page.
• Click Cancel to return to the Destinations Map page without saving the changes.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:

• Missing required information in the Destination field.
• Missing required information in the Network Entity field.
• Invalid characters in the Destination field.
• Only digits are allowed in the Network Entity field.
• The Network Entity field must contain at least eight digits.
• Destination not found.
• The Destination’s type must be IMSHSS to have a Destination Map entry.
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Editing Destination Maps

Use this page to manually change an existing destination map in the database. The OK and Apply
buttons are disabled until a character is entered into either the Destination or Network Entity field.

You can only perform this task when logged into the Active Primary SDS.

Note:  A service node must be provided when modifying a destination map.

1. Select SDS ➤ Configuration ➤ Destination Map.
The Destination Map page appears.

2. Locate the map you want to edit and click Edit.
The Destination Map [Edit] page appears.

3. Edit the E.164 address for the server node in the Network Entity field.
4. Perform one of the following:

• Click OK  to save the destination map and return to the Destination Map page.
• Click Apply  to save the destination map and remain on this page.
• Click Cancel to return to the Destination Map page without saving the changes.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:

• Missing required information in the Network Entity field.
• Only digits are allowed in the Network Entity field.
• The Network Entity field must contain eight digits.

Deleting Destination Maps

This page allows you to manually delete a destination map from the database. A Destination Map
cannot be deleted while any IMSI or MSISDN routing entities remain associated with the destination.

Note:  You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Destination Map.
The Destination Map page appears.

2. Locate the map you want to delete and click Delete.
A popup confirmation window appears.

3. Perform one of the following actions:

• Click OK to delete the map.
• Click Cancel to cancel the delete function and return to the Destination Map page.

If OK is clicked and any of the following conditions exist, and error message appears:

• Destination is in use by a route.
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Routing entities configuration

The Routing Entities page allows you to manage the supported routing entities:

• IMSI
• MSISDN
• NAI User
• Wildcard NAI User Prefix

Note:  A routing entity can be a User Identity or an IP Address associated with the User Equipment
(IPv4 or IPv6 address).

From the SDS Configuration Routing Entities page, you can perform the following actions:

• Retrieve information for a specific Routing Entity.
• Add a supported Routing Entity.
• Update the information associated with an existing Routing Entity.
• Delete a Routing Entity.

Routing entities configuration elements

This table describes the fields on the Routing Entities Retrieve, Add, Update, and Delete tabs.

Table 7: Routing Entities Configuration Elements

Data Input NotesDescriptionElement

Retrieve and Delete tabs

Format: pulldown list

Range: MSISDN, ISMI, NAI
User, Wildcard NAI User

Type of supported routing entityType

Format: alphanumeric and
underscore

Range: Depends on Type

The routing entity addressAddress (WC NAI User Only)

• MSISDN: 8–15 digits
• IMSI: 10–15 digits
• NAI User: 1–64 characters

Wildcard NAI User: 1–64
characters

The routing entity addressAddress Prefix (WC NAI User
Only)

Format: pulldown list

Range: available NAI Hosts

NAI Host; available only when
NAI User or Wildcard NAI User
is selected as the Type.

NAI Host

Add and Update tabs
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Data Input NotesDescriptionElement

Format: pulldown list

Range: MSISDN, ISMI, NAI
User, Wildcard NAI User

Type of supported routing entityType

Format: alphanumeric and
underscore

Range: Depends on Type

The routing entity addressAddress

• MSISDN: 8–15 digits
• IMSI: 10–15 digits
• NAI User: 1–64 characters

Wildcard NAI User: 1–64
characters

The routing entity addressAddress Prefix (available for the
WC NAI User selection only)

Format: pulldown list

Range: available NAI Hosts

NAI Host; available only when
NAI User or Wildcard NAI User
is selected as the Type.

NAI Host (available for the NAU
User selection only)

Format: pulldown list

Range: available IMS HSS
destinations

IMS HSS destinationIMS HSS

(available on the Add tab only)

Format: pulldown list

Range: available LTE HSS
destination

LTE HSS destinationLTE HSS

(available on the Add tab only)

Format: pulldown list

Range: available PCRF
destinations

IMS HSS destinationPCRF

(available on the Add tab only)

Format: pulldown list

Range: available OCS
destinations

IMS HSS destinationOCS

(available on the Add tab only)

Format: pulldown list

Range: available OfCS
destinations

IMS HSS destinationOfCS

(available on the Add tab only)

Format: pulldown list

Range: available AAA
destinations

IMS HSS destinationAAA

(available on the Add tab only)

Format: pulldown list

Range: available User defined 1
destinations

IMS HSS destinationUser defined 1

(available on the Add tab only)
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Data Input NotesDescriptionElement

Format: pulldown list

Range: available User defined 2
destinations

IMS HSS destinationUser defined 2

(available on the Add tab only)

Retrieving routing entities

You can perform this task when logged into an SDS or from the DP SOAM GUI.

Before performing this task, make sure that Destinations and NAI Hosts have been configured.

1. Select SDS ➤ Configuration ➤ Routing Entities.
The SDS Configuration Routing Entities page appears.

By default, the Retrieve tab is the viewable tab. If not, select the Retrieve tab.

2. Select the type of routing entity from the Type pulldown list.
3. Enter the route identifier for the routing entity in the Address or Address Prefix field.

Note:  The Address or Address Prefix field requirements vary depending on the type of routing
entity. For more information on this field, see Routing entities configuration elements.

4. If NAI User or Wildcard NAI User is selected as the Type, select a NAI host from the NAI Host
pulldown list.

5. Click Retrieve.

When Retrieve is clicked and the following condition exists, an error message appears:

• If either MSISDN or IMSI was selected as the Type, and a non-digit character was entered.
• Field Address contains invalid characters.

Adding routing entities

You can only perform this task when logged into the Active Primary SDS.

Before performing this task, make sure that Destinations and NAI Hosts have been configured.

1. Select SDS ➤ Configuration ➤ Routing Entities.
The SDS Configuration Routing Entities page appears.

2. Select the Add tab.
3. Select the type of routing entity from the Type pulldown list.
4. Enter the route identifier for the routing entity in the Address or Address Prefix field.

Note:  The Address or Address Prefix field requirements vary depending on the type of routing
entity. For more information on this field, see Routing entities configuration elements.

5. If NAI User or Wildcard NAI User is selected as the Type, select a NAI host from the NAI Host
pulldown list.

6. Select the associated destination(s) from the applicable destination(s) pulldown list.
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At least one destination must be selected, although a destination can selected for each of the
destination types.

7. Click Add.

When Add is clicked and any of the following conditions exist, an error message appears:

• Either MSISDN or IMSI was selected as the Type and a non-digit character was entered.
• At least one destination was not selected.
• Field Address contains invalid characters.

Updating routing entities

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Routing Entities.
The SDS Configuration Routing Entities page appears.

2. Select the Update tab.
3. Select the type of routing entity from the Type pulldown list.
4. Enter the route identifier for the routing entity in the Address or Address Prefix field.

Note:  The Address or Address Prefix field requirements vary depending on the type of routing
entity. For more information on this field, see Routing entities configuration elements.

5. If NAI User or Wildcard NAI User is selected as the Type, select a NAI host from the NAI Host
pulldown list.

6. Click Lookup.

Note:  If the route was not located during the Lookup, an error message appears.

The Update tab appears with the routing entity information.
7. Edit the appropriate destination(s).

For more information about these fields, see Routing entities configuration elements.

Important:  Although at least one destination is required when adding a routing entity, there is no
minimum requirement for destinations when updating the routing entity. For example, all of the
destinations could possibly be set to NONE.

8. Click Update.

Deleting routing entities

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS ➤ Configuration ➤ Routing Entities.
The SDS Configuration Routing Entities page appears.

2. Select the Delete tab.
3. Select the type of routing entity from the Type pulldown list.
4. Enter the route identifier for the routing entity in the Address or Address Prefix field.

Note:  The Address or Address Prefix field requirements vary depending on the type of routing
entity. For more information about this field, see Routing entities configuration elements.
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5. If NAI User or Wildcard NAI User is selected as the Type, select a NAI host from the NAI Host
pulldown list.

6. Click Delete.
A popup confirmation window appears.

7. Perform one of the following actions:

• Click OK to delete the connection.
• Click Cancel to cancel the delete function and return to the SDS Configuration Routing Entities

page.

If OK is clicked and any of the following conditions exist, an error message appears:

• Either MSISDN or IMSI was selected as the Type and a non-digit character was entered in the
Route field

• The route identifier was not found.
• Field Address contains invalid characters.
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Chapter

4
Maintenance

The Maintenance menu options allow you to query
and audit data, view up-to-date status of the

Topics:

• Connections maintenance .....39 database and various features, initiate import and
exports.• Command Log maintenance.....41

• Relay Exception Log.....42 From the maintenance menu on an SDS you can:
• Import Status maintenance.....44

• Perform database audits• Export maintenance.....46
• Query the database for specified MSISDN, IMSI,

NAI user, or wildcard NAI user ranges• Audit .....53
• Remote Audit .....57 • View provisioning connections, command logs,

and the status of imports and exports• Query .....61
• NPA Splits maintenance.....65 • Configure and manage NPA Splits

When you are logged into an DP SOAM you cannot
request an audit, update splits, or schedule an export
on the DP SOMA GUI.

The available menu options will vary based on the
type of server you are logged into and the
permissions assigned to your group. If you do not
see a menu option you need, please make sure you
are logged into the appropriate type of server and
ask your administrator to make sure the group your
user ID belongs to has the appropriate permissions.

The SDS Maintenance  pages provide maintenance
information related to provisioning connections and
data. With this page you can monitor provisioning
connections; view every provisioning message
exchanged between provisioning systems in the
command log, view the status of imports and
exports; open import and export files and import
result logs.

All provisioning maintenance tasks are only
available when logged into an SDS.
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Connections maintenance

The SDS -> Maintenance -> Connections page allows you to view the “currently in-use” external
connections. A list of all provisioning connections established to the system can be viewed. A display
filter can be applied for a specified search. The information is displayed in tabular format.

Any local connections (including the one from the GUI itself) are not included.

Connections maintenance elements

The SDS -> Maintenance -> Connections page displays information in a tabular format. Table 8:
Connections Maintenance Elements describes elements on the SDS -> Maintenance -> Connections
page.

Table 8: Connections Maintenance Elements

Data NotesDefinitionField

Format: Year-Month-Day
Hour-Minute-Second

Time the connection was establishedTimestamp

N/AConnection IDCID

Format: Valid IP addressIP address for the remote clientRemote IP

Format: Valid port numberPort used for the remote client
connection

Remote Port

Default: 1.0Version of API this client application is
using

Version

Options: Pdba, Xds, XmlImport,
XmlExport, PdbRelay, PdbAudit

Connection managerCnx Manager

Range:Database transaction modeTxn Mode

• normal: All updates must be
sent inside a transaction
explicitly begun and ended
by begin_txn and
end_txn/abort_txn requests
respectively.

• single: Transactions are
implicitly begun and ended
for individual update requests

Default: normal

Range:Number of minutes the connection can
be idle before it is automatically timed
out.

Idle Timeout

• 0 (the connection is never
terminated)

• 1 - 44640 minutes
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Data NotesDefinitionField

Default: 0

Viewing connections status

Use this task to view a list of information of all provisioning connections established to the system.
The listing of connections may be filtered.

1. Select SDS ➤ Maintenance ➤ Connections.

The SDS Maintenance Connections page appears. All provisioning connections are displayed in
tabular form. The fields are described in Connections maintenance elements.

2. Select the category by which to perform the filtering.

Table 9: Connection Status filtering categories

DesscriptionCategory

Time the connection was established.Timestamp

The Connection ID to filter on.CID

IP address for the remote client.Remote IP

Port used for the remote client connection.Remote Port

Version of API this client application is using.Version

Database transaction mode.Txn Mode

Number of minutes the connection can be idle before it is
automatically timed out.

Idle Timeout

3. Choose the filtering operator.

Table 10: Connection Status filtering operators

DescriptionOperator

Is equal to=

Is not equal to!=

Is greather than>

Is equal to or greater than>=

Is less than<

Is equal to or less than<=

Is Like (wildcard is * character)Like

has no entry (is zero)Is Null
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4. Enter the target character string to filter on in the text box.
5. Use Auto Refresh to select the time interval for the status to be refreshed.

Table 11: Connection status refresh time

DescriptionTime

15 seconds15

30 seconds30

Off (default)Off

6. Click Go to show results.

Command Log maintenance

The SDS -> Maintenance -> Command Log page shows a table that contains a history of commands
and their responses. This table shows the Timestamp, System ID, CID, and the Text of the commands
received from both remote and local connections, including the GUI.

Every provisioning message exchanged between provisioning systems is written to the command log
and is stored for up to seven days.

Command Log maintenance elements

The SDS -> Maintenance -> Command Log page displays information in a tabular format. This table
describes elements on the SDS -> Maintenance -> Command Log page.

Table 12: Command Log Maintenance Elements

DescriptionElement

Date and time the command was loggedTimestamp

System identifier of the originating clientSystem ID

Client connection identifierCID

Exact command and response messageText

Viewing maintenance command logs history

Use this task to view a list of information of a history of commands and their responses. The history
is displayed as a table that shows the Timestamp, System ID, CID, and the Text of the commands
received from both remote and local connections, including the GUI. The history may be filtered by
category.

Note:  You can use Max entries to display to control the total number of entries displayed on the page.

1. Select SDS ➤ Maintenance ➤ Command Log.
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The SDS Maintenance Command Log page appears.
2. Select the category by which to perform the filtering.

Table 13: Command Log filtering categories

DescriptionCategory

Show all commandsNone

A hidden text box becomes visible for you to enter the System
ID to filter on.

System ID equal to...

A hidden text box becomes visible for you to enter the
Connection ID to filter on.

CID equal to...

A hidden text box becomes visible for you to enter one or more
keywords to filter on.

Log text contains...

Shows all commands with error responses.Error responses

When selected, hidden select boxes for “From” and “To” times
become visible for you to enter the time range to filter on.

Time range...

3. Click Display to show results.

When results are filtered, the highlighted text RESULTS FILTERED is displayed at the bottom of
the results.

Relay Exception Log

The SDS -> Maintenance -> Relay Exception Log page shows a table that contains all types of
exceptions (unexpected results) that are found while processing SDS to HLRR relay or export
functionality. Consequently, all fields do not always contain data. All entries in the Relay Exception
Log contain enough data so that you can determine what SDS data caused the exception.

Ideally, the Relay Exception Log would be empty, which means that SDS has all of the data required
to create an HLRR provisioning command and all of the required Network Entities are provisioned
for HLR Router. Because the most likely cause of an error would be associated with relaying new
provisioning commands to HLRR, the Relay Exception Log displays column headings for exceptions
created by pdbrelay. Deviations for other creators are described below:

• If no command is relayed to HLRR, the Derived Relay Request value will be None.

• If the Creator value is not equal to pdbrelay, the Derived Relay Request value from the SDS
Command Log section will be blank.

Relay Exception Log maintenance elements

The SDS -> Maintenance -> Relay Exception Log page displays information in a tabular format. This
table contains a list of exceptions found while processing data that should be relayed from SDS to
HLRR.

Note:  Display limit must be a numeric integer greater than zero.
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The following table describes elements on the SDS -> Maintenance -> Relay Exception Log page.

Table 14: Exception Log Maintenance Elements

DescriptionElement

Date and time when the exception occurredTimestamp

Exception sequence numberSeq Num

Name of process that created the exceptionCreator

Reason that the exception was createdReason

Command created and relayed to HLR RouterDerived Relay Request

Command text from the SDS Command LogCommand

Sequence number form the SDS Command LogSeq Num

Timestamp from the SDS Command LogTimestamp

Viewing exception logs history

Use this task to view a list of information of a history of commands and their responses. The history
is displayed as a table that shows the Timestamp, System ID, CID, and the Text of the commands
received from both remote and local connections, including the GUI. The history may be filtered by
category.

Note:  You can use Max entries to display to control the total number of entries displayed on the page.

1. Select SDS ➤ Maintenance ➤ Relay Exception Log.
The SDS Relay Exception Log page appears.

2. Select the category by which to perform the filtering.

Table 15: Relay Exception Log filtering categories

DescriptionCategory

Show all commandsNone

A hidden text box becomes visible for you to enter the
Exception Sequence Number to filter on.

Exception Seq Num equal to...

A hidden text box becomes visible for you to enter the
Exception Creator to filter on.

Exception Creator equal to...

A hidden text box becomes visible for you to enter one or more
Exception Reasons keywords to filter on.

Exception Reason text contains...

When selected, hidden select boxes for “From” and “To” times
become visible for you to enter the time range to filter on.

Exception Time range...

A hidden text box becomes visible for you to enter Command
text to filter on.

Command text contains...
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3. Click Display to show results.

When results are filtered, the highlighted text RESULTS FILTERED is displayed at the bottom of
the results.

Import Status maintenance

Allows an operator to view the status of all Imports.

Data can be imported from a provisioning import file to add new, or update existing, data in the
database. Imports are not scheduled through the user interface but import settings are configured
with the provisioning options page.

Import files that are placed in a specific location on a remote server (Remote Import Directory) are
detected within five minutes and automatically downloaded via SSH File Transfer Protocol (SFTP) to
the file management storage area. For a file to be imported, it must:

• be properly named following the naming convention. For more information see the SDS
Administration Manual.

• have been placed in the remote directory after the time when provisioning import last ran
• must not have been previously imported. A file that has already been imported into the local

directory will not be imported again, even if its status is Failed.

Note:  To import a previously Failed file, correct the file as necessary, rename the file, and then
place the renamed file in the remote directory.

Once fully downloaded, each file is automatically imported into the Provisioning Database sequentially
in the order in which their download completed. The provisioning import file is an ASCII text file that
contains a series of database manipulation requests in provisioning format.

The SDS Maintenance Import Status page allows you to view the status of provisioning imports.
Import records with a status of Completed or Failed can be deleted from this table.

Import Status maintenance elements

The SDS -> Maintenance -> Import Status page displays information in a tabular format. Table 16:
Import Status Maintenance Elements describes elements on the SDS -> Maintenance -> Import Status
page.

Table 16: Import Status Maintenance Elements

DescriptionField

Allows user to delete import file entries.Action

Name of import fileImport File

Time the import was queuedTime Queued

Time the import startedTime Started

Time the import completedTime Completed
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DescriptionField

Percentage of import progressProgress

Name/heading of result logResult Log

The number of successful import commandsPass Count

The number of unsuccessful import commandsFail Count

Status of the importStatus

Viewing import files

This task allows you to view the status of all Imports. Imports are not scheduled through the GUI.
They are initiated by the presence of a file placed in the Remote Import Directory.

• If the filename in the Import File or Result Log column exceeds 24 characters, it is truncated at 22
characters and the characters “...” are appended to the end of the truncated string to signify that
the filename was truncated.

• The filenames in both the Import File or Result Log columns are hyperlinks. You can click on the
links to view the files as text or to save them locally.

• You cannot edit an imported file using this form.
• You may delete an Import Status record if the Status is Completed, or Failed.

1. Select SDS ➤ Maintenance ➤ Import Status.

The SDS Maintenance Import Status page appears. All provisioning connections are displayed
in tabular form. The display fields are described in Import Status maintenance elements.

2. Select the category by which to perform the filtering.

Table 17: Import Status filtering categories

DescriptionCategory

Time the import was queuedTime Queued

Time the import startedTime Started

Time the import completedTime Completed

Percentage of import progressProgress

The number of successful import commandsPass Count

The number of unsuccessful import commandsFail Count

Status of the importStatus

3. Choose the filtering operator.
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Table 18: Connection Status filtering operators

DescriptionOperator

Is equal to=

Is not equal to!=

Is greater than>

Is equal to or greater than>=

Is less than<

Is equal to or less than<=

Is Like (wildcard is * character)Like

has no entry (is zero)Is Null

4. Enter the target character string to filter on in the text box.
5. Use Auto Refresh to select the time interval for the status to be refreshed.

Table 19: Connection status refresh time

DescriptionTime

15 seconds15

30 seconds30

Off (default)Off

6. Click Go to show results.
7. To delete an import record, click on the associated Delete link.

Note:  The import record can only be deleted if the Status is Completed, or Failed.

A confirmation dialog to complete the delete action appears. For all other imports, the Delete action
is inactive (grayed-out).

Export maintenance

Provisioning data can be exported to an ASCII file in either XML or CVS format using the application
user interface. The SDS Maintenance Export pages allow you to view the status, progress, and data
count information for scheduled provisioning exports. You may use exported records to do data
manipulation of subscriber data.

Note:  Export is a time consuming operation recommended to be scheduled during off-peak hours.
SDS operators can schedule one-time or recurring exports.

Exported data may also be offloaded to a remote server. The exported text file is also available to be
downloaded from the ‘file transfer area’. Export is a periodic task. Any changes done to export table
shall take effect on next export period. The following is the functionality of Export:
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• You can configure and schedule data export on a daily, weekly or monthly basis.
• The exported files will be sFTPed or transferred via SSH to a server configured on SDS.
• Data can be exported to a file in XML commands or CSV format.
• You can export subscriber data (in XML or CSV format) as shown in Table 20: Interfaces for Subscriber

Data Types:

Table 20: Interfaces for Subscriber Data Types

SQL Query
(from Query
Server)

CSV Export
and Import

XML Export
and Import

SOAP and/or
XML (add,
change, delete
and query)

GUI (add,
change, delete
and query)

Subscriber
Data Type

yesyesyesyesyesMSISDN

yesyesyesyesyesIMSI

yesyesyesyesyesNAI User

yesyesnonoyesWildcard NAI
User

yesyesnonoyesNAI Host

yesyesnonoyesDestination

Schedule

The SDS -> Maintenance -> Export -> Schedule page displays information in a tabular format for all
exports scheduled for this system.

Export Schedule maintenance elements
Table 21: Export Schedule Maintenance Elements describes elements on the SDS -> Maintenance -> Export
-> Schedule page.

Table 21: Export Schedule Maintenance Elements

DescriptionField

Edit or Delete scheduled exportAction

Name of export fileIdentifier

Format of the export file (CSV or XML)File format

Type of data to exportExport Data

The first time this export is scheduled to runFirst Export

The next time this export is scheduled to runNext Export

How often to repeat exportRepeat

Purpose of exportComment
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Additionally, you can insert an export schedule by clicking on the [Insert] button on the page.

Viewing export schedule
The SDS -> Maintenance -> Export -> Schedule page shows the scheduled exports for this system.

1. Select SDS -> Maintenance -> Export -> Schedule.

The SDS Maintenance Export Schedule page appears. All exports are displayed in tabular form.
The display fields are described in Export Schedule maintenance elements.

• Click on the [Insert] button, located on the bottom of the page, to insert a new export schedule.
• Click Edit in the Action column on an export record to edit that export.
• Click Delete in the Action column on an export record to delete that export.

2. Select the category by which to perform the filtering.

Table 22: Export Schedule filtering categories

DescriptionField

Name of export fileIdentifier

Format of the export file (CSV or XML)File format

Type of data to exportExport Data

The first time this export is scheduled to runFirst Export

The next time this export is scheduled to runNext Export

How often to repeat exportRepeat

Purpose of exportComment

3. Choose the filtering operator.

Table 23: Export Schedule filtering operators

DescriptionOperator

Is equal to=

Is not equal to!=

Is greather than>

Is equal to or greater than>=

Is less than<

Is equal to or less than<=

Is Like (wildcard is * character)Like

has no entry (is zero)Is Null

4. Enter the target character string to filter on in the text box.
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5. Click Go to show results.

Inserting an export schedule
The SDS -> Maintenance -> Export -> Schedule [Insert] page allows you to create an export for this
system.

The field or fields highlighted in yellow are keys and must be unique within this table in order to be
successful. Fields marked with a red asterisk (*) require a value.

1. Select SDS -> Maintenance -> Export -> Schedule.

The SDS Maintenance Export Schedule page appears.

2. Click on the [Insert] button located on the bottom of the page.

The SDS Maintenance Insert Export Schedule page appears.

3. Enter an identifying string for the scheduled export in the Identifier text box.

The identifier must be 4 to 12 characters.

4. Use the radio buttons csv or xml to choose the File Format of the export file.
5. From the Export Data drop down list, select the type of data to be exported.

The available type data selections are csv or xml file format.

Table 24: Export Data Types

xml Formatcsv FormatType of Data

all formats listedall formats listedAll

XXMSISDN

XXIMSI

XXNAI User

XWildcard NAI User

XNAI Host

XDestinations

6. Use the appropriate drop down list to select the initial date at which this export should run.
7. Use the appropriate drop down list to select the initial time at which this export should run.
8. Use the appropriate drop down list to select how often this export should be repeated.
9. In the Comment text box, enter text that may be used to describe the purpose of this export.

Note:  You can enter up to 255 characters for a comment.

10. Perform one of these actions:

• Click OK. If field validations succeed, the new export is saved and the previous page appears.
If the page contains any values that are not valid, or if a required field is empty, an error message
appears.
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• Click Apply. If field validations succeed, the new export is saved and you remain on the same
page.

• Click Cancel to abort changes on this page and return to the previous page.

Editing an export schedule
The SDS -> Maintenance -> Export -> Schedule [Edit] page allows you to manually change an existing
export job by editing an entry in the Export Schedule.

The field or fields highlighted in yellow are keys and must be unique within this table in order to be
successful. Fields marked with a red asterisk (*) require a value.

1. Select SDS -> Maintenance -> Export -> Schedule.

The SDS Maintenance Export Schedule page appears.

2. Click Edit in the Action column of the export record to be edited.

The SDS Maintenance Edit Export Schedule page appears.

3. Enter an identifying string for the scheduled export in the Identifier text box.

The identifier must be 4 to 12 characters.

4. Use the radio buttons csv or xml to choose the File Format of the export file.
5. From the Export Data drop down list, select the type of data to be exported.

The available type data selections are csv and xml file format.

Table 25: Export Data Types

xml Formatcsv FormatType of Data

all formats listedall formats listedAll

XXMSISDN

XXIMSI

XXNAI User

XWildcard NAI User

XNAI Host

XDestinations

6. Use the appropriate drop down list to select the initial date at which this export should run.
7. Use the appropriate drop down list to select the initial time at which this export should run.
8. Use the appropriate drop down list to select how often this export should be repeated.
9. In the Comment text box, enter text that may be used to describe the purpose of this export.

Note:  You can enter up to 255 characters for a comment.

10. Perform one of these actions:
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Click OK . If field validations succeed, the new export is saved and the previous page appears.
If the page contains any values that are not valid, or if a required field is empty, an error message
appears.

•

• Click Apply. If field validations succeed, the new export is saved and you remain on the same
page.

• Click Cancel to abort changes on this page and return to the previous page.

Deleting an export schedule
The SDS -> Maintenance -> Export -> Schedule [Delete] page allows you to manually delete an
export job by deleting an entry from the Export Schedule Table.

1. Select SDS -> Maintenance -> Export -> Schedule.

The SDS Maintenance Export Schedule page appears.

2. Click Delete in the Action column of the export record to be deleted.

A confirmation dialogue box opens, "Are you sure you want to delete this row?"

• Click OK to confirm the action to delete the export record and return to the SDS -> Maintenance
-> Export -> Schedule page.

• Click Cancel to abort the delete action and return to the SDS -> Maintenance -> Export ->
Schedule page.

Status

The SDS -> Maintenance -> Export -> Status page displays information in a tabular format and shows
all in-progress and completed scheduled exports in this system.

Export Status maintenance elements
Table 26: Export Status Maintenance Elements describes elements on the SDS -> Maintenance -> Export
-> Status page.

Table 26: Export Status Maintenance Elements

DescriptionField

Name of export fileExport File

Time the export was queuedTime Queued

Time the export startedTime Started

Time the export completedTime Completed

Number of MSISDNS exportedMSISDNs Count

Number of IMSIs exportedIMSI Count

Number of NAIs exportedNAIs Count

Number of Wildcard NAIs exportedWildcard NAIs
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DescriptionField

Number of Destinations exportedDestinations Count

Number of NAI Hosts exportedNAI Hosts Count

Status of exportStatus

Descriptive text about export. This field is
optional, so it may be blank.

Comment

Viewing export status
The SDS -> Maintenance -> Export -> Status page shows the status of all in-progress and completed
scheduled exports for this system.

• If the filename in the Export File column exceeds 24 characters, it is truncated at 22 characters and
the characters “...” are appended to the end of the truncated string to signify that the filename was
truncated.

• The filenames in the Export File column are hyperlinks. You can click on the links to view the files
as text or to save them locally.

• You can not modify or delete an export record using this form.
• Records are automatically removed after 7 days.

1. Select SDS -> Maintenance -> Export -> Status.

The SDS Maintenance Export Status page appears. All exports are displayed in tabular form. The
display fields are described in Export Status maintenance elements.

2. Select the category by which to perform the filtering.

Table 27: Export Status filtering categories

DescriptionCategory

Time the import was queuedTime Queued

Time the import startedTime Started

Time the import completedTime Completed

Number of MSISDNS exportedMSISDNs

Number of IMSIs exportedIMSIs

Number of NAIs exportedNAIs

Number of Wildcard NAIs exportedWildcard NAIs

Number of Destinations exportedDestinations

Number of NAI Hosts exportedNAI Hosts

Status of exportStatus

Descriptive text about export. This field is
optional, so it may be blank.

Comment
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3. Choose the filtering operator.

Table 28: Export Status filtering operators

DescriptionOperator

Is equal to=

Is not equal to!=

Is greather than>

Is equal to or greater than>=

Is less than<

Is equal to or less than<=

Is Like (wildcard is * character)Like

has no entry (is zero)Is Null

4. Enter the target character string to filter on in the text box.
5. Use Auto Refresh to select the time interval for the status to be refreshed.

Table 29: Export status refresh time

DescriptionTime

15 seconds15

30 seconds30

Off (default)Off

6. Click Go to show results.

Audit

The SDS Maintenance Audit menu option allows you to view the status of the database audits and
to request a site-wide database audit of a specified subset of provisioning data through the use of the
following tabs:

• The Audit Status tab allows you to view all pending, completed, and failed database audits.
• The Audit Request tab allows you to request a site-wide database audit.

Since each node is responsible for managing its own resources, some nodes may decide to delay
or cancel the requested audit in order to maintain sufficient resources to process signaling traffic.

• Manual audit results can be viewed on this page for 2 hours.
• All audit results stay in the Alarms and Events history for up to 7 days.
• Automatic audits run at configured times to verify the accuracy of each data base instance.
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• A manual audit allows specification of audit between SDS master database instance and any other
database instance, based on some data range (i.e. audit IMSI range) or subscriber name.

The data base instances that are verified are

• Primary site standby database instance
• Primary site Query Server database instance
• Disaster Recovery site – active, standby and Query Server database instances
• Each DP site – all database instances

Audit elements

The SDS Maintenance Audit page consists of two tabs: Status and Request. Each tab contains their
own associated elements described in Table 30: Audit Status Elements and Table 31: Audit Request Elements.

Table 30: Audit Status Elements

DescriptionElement

Name of the server the audit runs onHostname

Type of audit; either manual or automatic.Type

Type of data table audited; either All, IMSI,
MSISDN, NAI User, Wildcard NAI User

Table(s)

State the audit is in at the time of the last Update
Time. If auto refresh is enabled for this page the
this field will be updated. Possible values are:

Audit State

• Success - audit has completed
• Fail - audit did not complete successfully
• Running - audit in progress
• Preempted - audit was preempted
• Paused - audit is paused

Total number of records that were auditedRecords Audited

Number of database blocks that contained
discrepancies

Blocks Corrected

Date and time the audit was requestedRequest Time

Date and time the audit startedStart Time

Date and time the audit status was last updated.Update Time

Start of the range for the database audit, if specifiedStart

End of the range for the database audit, if specifiedEnd

Optional text used to provide information about
the audit. For example, an explanation of the

User Comment

purpose or the audit owner's name. This field is
optional.
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Table 31: Audit Request Elements

Data Input NotesDescriptionElement

Format: Selection buttons

Range: MSISDN, IMSI, NAI
User, Wildcard NAI User

Type of data to include in auditData

Default: MSISDN

Format: Digits only

Range: 8 - 15 digits for MSISDN

Starting address of data to be
included in this audit (applies to
MSISDN and IMSI audit
requests only)

Start Address

Range: 10 - 15 for IMSI

Format: Digits only

Range: 8 - 15 digits for MSISDN

Ending address of data to be
included in this audit (applies to
MSISDN and IMSI audit
requests only)

End Address

Range: 10 - 15 for IMSI

Default: blank

Format: Alphanumeric

Range: up to 35 characters

Optional text used to provide
information about the audit. For
example, an explanation of the

Comment

Default: blankpurpose or the audit owner's
name. This field is optional.

Viewing the status of an audit

The SDS -> Maintenance -> Audit page allows you to view all pending, completed, and failed database
audits of data performed throughout the system.

1. Select SDS -> Maintenance -> Audit.
The SDS Maintenance Audit page appears.

2. Select the Status tab.

The SDS -> Maintenance -> Audit page appears. All audits are displayed in tabular form. The
display fields are described in Table 32: Audit filtering categories.

3. Select the category by which to perform the filtering.

Table 32: Audit filtering categories

DescriptionCategory

No filtering (default)None

The host where the audit runsHostname

The type of audit (Manual or Automatic)Type

Table audited (All, IMSI, MSISDN, NAI User,
Wildcard NAI User)

Table(s)
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DescriptionCategory

Current state of the audit (Success, Fail,
Running, Scheduled, Preempted or Paused)

Audit State

Total number of records auditedRecords Audited

Number of Database blocks that had records
with discrepancies

Blocks Corrected

Time audit was requestedRequest Time

Time audit startedStart Time

Time audit status updatedUpdate Time

Start range of data auditedStart

End range of data auditedEnd

User’s comment entered in requestUser Comment

4. Choose the filtering operator.

Table 33: Audit filtering operators

DescriptionOperator

Is equal to=

Is not equal to!=

Is greater than>

Is equal to or greater than>=

Is less than<

Is equal to or less than<=

Is Like (wildcard is * character)Like

has no entry (is zero)Is Null

5. Enter the target character string to filter on in the text box.
6. Use Auto Refresh to select the time interval for the status to be refreshed.

Table 34: Audit display refresh time

DescriptionTime

15 seconds15

30 seconds30

Off (default)Off

7. Click Go to show results.
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Requesting an audit

You can use this task to request a site-wide database audit of a specified subset of MSISDN, IMSI, NAI
User or Wildcard NAI User data. The request is sent to all nodes and the results are merged back up
to SDS. Since each node is responsible for managing its own resources, some nodes may decide to
delay or cancel the requested audit in order to maintain sufficient resources to process signaling traffic.

1. Select SDS -> Maintenance -> Audit.
The SDS Maintenance Audit page appears.

2. Select the Request tab.
3. Select the type of data you want included in the audit from the Data pulldown list.

If you select NAI User or Wildcard NAI User, go to Step 5.

4. If you selected either MSISDN or IMSI as the Data type, enter data in the following fields:

• Start Address  field: Starting address of data to be included in this audit. This must be between
8 and 15 digits for MSISDN or 10-15 for IMSI.

• End Address  field: Ending address of data to be included in this audit. This is an optional field
that, if used, must be between 8 and 15 digits for MSISDN or 10-15 for IMSI.

5. Enter any text about the audit you want to include in the Comment  field, if needed.
6. Click Request.

The database audit request is made. The status of the request can be viewed on the SDS -> Maintenance
-> Audit page.

Remote Audit

The SDS Maintenance Remote Audit menu option allows you to access an on-demand ability to
initiate an audit of the remote HLR Router provisioning database and flag any differences found
between the SDS and the HLR Router databases. This provisioning database audit includes MSISDNs
and, IMSIs and their associated Network Entity address values, which are extracted from the Destination
Map table.

When you submit an audit request on the SDS GUI maintenance page, a PDBI client called pdbaudit
connects to the local PDBA and to the remote PDBA running on the HLR Router system. It sends
request commands to both PDBAs, compares the response data, and reports any discrepancies between
the two databases. Then you can check the status and review the results of the audit on the SDS GUI
status page.

SDS supports manual audit runs between the SDS master data base instance and the HLR Router data
base instance. Configurable automated audit runs are those runs that run at configured times to verify
the accuracy of SDS master and HLR Router data base instances. A manual audit allows specification
of audit between SDS master and HLR Router data base instances, based on some data range (for
example, audit IMSI range) or single MSISDN or IMSI value.

SDS supports an on-demand ability to initiate an audit of the remote HLR Router provisioning database
and flag any differences found between the SDS and the HLR Router databases. HLR Router
provisioning data to be audited can be specified in one of two ways - by a single range of numbers,
or by an input file containing multiple ranges of numbers. Using an input file allows an operator to
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specify multiple IMSI and MSISDN ranges at one time versus scheduling multiple remote HLR Router
audits on a single range.

Use the following tabs to view the status of the database remote audits and to request a site-wide
database audit of a specified subset of provisioning data:

• The Remote Audit Status tab allows you to view all pending, completed, and failed database
remote audits of data performed throughout the system.

• The Remote Audit Request tab allows you to request a remote audit between SDS and HLR Router
data using a subset of MSISDN or IMSI values.

Since each node is responsible for managing its own resources, some nodes may decide to delay
or cancel the requested audit in order to maintain sufficient resources to process signaling traffic.

Remote Audit elements

The SDS Maintenance Remote Audit page consists of two tabs: Status and Request. Each tab contains
their own associated elements described in Table 35: Remote Audit Request Elements and Table 36: Remote
Audit Status Elements.

Table 35: Remote Audit Request Elements

DescriptionElement

Type of audit; MSISDN or IMSI.Data Type

Audit type; Range or File.Audit State

Starting address of data to be included in this audit
request.

Start of Range

Ending address of data to be included in this audit
request.

End of Range

File that contains ranges of values to be included
in this audit.

Input File

Optional text used to provide information about
the audit. For example, an explanation of the

Comment

purpose or the audit owner's name. This field is
optional.

Table 36: Remote Audit Status Elements

DescriptionDescriptionElement

Format: Selectable wordAvailable actions.Action

Format: MSISDN or IMSIType of data being audited.Type

Format: Digits only

Range: 8 - 15 digits for MSISDN

Range of data being audited or
file name that contains ranges of
data being audited.

Range/File

Range: 10 - 15 for IMSI
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DescriptionDescriptionElement

Format: Digits only

Range: 8 - 15 digits for MSISDN

IP address for Remote HLR
Router system used for auditing.

Remote IP

Range: 10 - 15 for IMSI

Format: Digits onlyPort for Remote HLR
Routedrsystem used for
auditing.

Remote Port

Format: Time notationDate and time audit started and
completed.

Start Time/Completion Time

Format: AlphaCurrent state of the Remote
audit.

State

• Submitted
• Queued
• In Progress
• Aborting
• Aborted
• Failed
• Completed

Format: DigitsTotal number of records audited.Audited

Format: DigitsNumber of matched records on
both SDS and the Remote HLR
Router system.

Same

Format: DigitsNumber of mismatched records
between SDS and Remote HLR
Router system.

Diff

Format: DigitsNumber of SDS records that are
missing on the Remote HLR
Router system.

Missing

Format: DigitsNumber of HLR Router records
that are missing on the local SDS
system.

Extra

Format: DigitsNumber of records in SDS
and/or HLR Router on which a

Unknown

retrieve data command timed
out.

Format: DigitsNumber of errors that occurred
during the audit. See trace log
for more information.

Errors

Format: AlphanumericName of generated remote audit
report

Report
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Viewing the status of a remote audit

The SDS -> Maintenance -> Remote Audit page allows you to view all pending, completed, and
failed remote database audits of data performed throughout the system.

1. Select SDS -> Maintenance -> Remote Audit.
The SDS Maintenance Remote Audit page appears.

2. Select the Status tab.

The SDS -> Maintenance -> Remote Audit page appears. All audits are displayed in tabular form.
The display fields are described in Remote Audit elements.

3. Select the category by which to perform the filtering.
4. Choose the filtering operator.

Table 37: Audit filtering operators

DescriptionOperator

Is equal to=

Is not equal to!=

Is greater than>

Is equal to or greater than>=

Is less than<

Is equal to or less than<=

Is Like (wildcard is * character)Like

Has no entry (is zero)Is Null

5. Enter the target character string to filter on in the text box.
6. Use Auto Refresh to select the time interval for the status to be refreshed.

Table 38: Audit display refresh time

DescriptionTime

15 seconds15

30 seconds30

Off (default)Off

7. Click Go to show results.

Requesting a remote audit

You can use this task to request a site-wide remote database audit of a specified subset of MSISDN,
IMSI, NAI User or Wildcard NAI User data. The request is sent to all nodes and the results are merged
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back up to SDS. Because each node is responsible for managing its own resources, some nodes might
decide to delay or cancel the requested audit in order to maintain sufficient resources to process
signaling traffic.

Note:  A valid input file name can be up to 80 characters in length.

1. Select SDS -> Maintenance -> Remote Audit.
The SDS Maintenance Remote Audit page appears.

2. Select the Request tab.
3. Select the type of data you want included in the audit from the Data Type pulldown list.

If you select NAI User or Wildcard NAI User, go to Step 5.

4. Select a range for Audit By, enter data in the following fields:

• Start of Range  field: Starting address of data to be included in this audit. This must be between
8 and 15 digits for MSISDN or 10-15 for IMSI.

• End of Range  field: Ending address of data to be included in this audit. This is an optional field
that, if used, must be between 8 and 15 digits for MSISDN or 10-15 for IMSI.

5. Provide the file name that contains ranges of values to be included in this audit.
6. Enter any text about the audit you want to include in the Comment  field, if needed.
7. Click Request.

The database audit request is made. The status of the request can be viewed on the SDS -> Maintenance
-> Remote Audit page.

Query

The SDS Maintenance Query page allows you to query database information for a single provisioning
database entry, or for a range of the same type of provisioning database entries, on an available server.
Any server that hosts a copy of the provisioning database can be used. Query options include MSISDN,
IMSI, Destination, NAI Host, NAI User, Wildcard NAI User, Counts, Counts by Destination, and DB
Level.

Querying a server for provisioning data allows you to see if data is being replicated correctly to each
server, and allows you to see if adjustments to data management or to the subscriber database need
to be made.

Query elements

The SDS Maintenance Query page consists of query entry dialogue boxes and results display. Not
all elements of the entry dialogue boxes or query results may be used once the "Data" type is selected.
All elements available through Query entry dialogue boxes are presented in Table 39: Query Entry
Elements. All elements available through Query results display, in alphabetical order, are presented
in Table 40: Query Results Elements.
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Table 39: Query Entry Elements

Data Input NotesDescriptionElement

Format: Drop down list

Range: MSISDN, IMSI, NAI
User, Wildcard NAI User, NAI

Type of data to include in auditData

Host, Destination, Counts,
Counts by Destination, DB Level

Default: MSISDN

Format: Digits only

Range: 8 - 15 digits for MSISDN
and 10 - 15 for IMSI

Starting address of data to be
included in this audit (applies to
MSISDN and IMSI audit
requests only

Start Address

Format: Digits only

Range: 8 - 15 digits for MSISDN
and 10 - 15 for IMSI

Ending address of data to be
included in this audit (applies to
MSISDN and IMSI audit
requests only

End Address

Default: blank

NAI Host defaults to the first
one configured in the table.

NAI Host to query applies to
NAI users only

NAI Host

Format: Alphanumeric

Range: up to 35 characters

Server on which to run the queryServer

Default: local server

Table 40: Query Results Elements

Data Value SelectedDescriptionResult Element

MSISDN, IMSI, NAI User,
Wildcard NAI User

AAA Destination record (with
type= aaa) or blank for none

AAA

Counts, Counts by DestinationUnique text used to identify a
Destination

Destination(s)

DestinationA 1-255 character string for the
Diameter FQDN for the

FQDN

Destination. The value can be
null

NAI User, Wildcard NAI User,
NAI Host

NAI HostHost

IMSI, Counts, Counts by
Destination

A unique string of 10-15 decimal
digits identifying the IMSI

IMSI
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Data Value SelectedDescriptionResult Element

MSISDN, IMSI, NAI User,
Wildcard NAI User

IMS HSS Destination record
(with type= imsHss) or blank for
none

IMSHSS

MSISDN, IMSI, NAI User,
Wildcard NAI User

LTE HSS Destination record
(with type= lteHss) or blank for
none

LTEHSS

MSISDN, Counts, Counts by
Destination

A unique string of 8-15 decimal
digits identifying the MSISDN

MSISDN

CountsNumber of NAI hostsNAI Hosts

NAI User, Counts, Counts by
Destination

A string of 1-64 characters for the
NAI User Name

NAI User

DestinationA unique string of 1-32
characters to identify the
Destination

Name

MSISDN, IMSI, NAI User,
Wildcard NAI User

OCS Destination record (with
type= ocs) or blank for none

OCS

MSISDN, IMSI, NAI User,
Wildcard NAI User

OFCS Destination record (with
type= ofcs) or blank for none

OfCS

MSISDN, IMSI, NAI User,
Wildcard NAI User

PCRF Destination record (with
type= pcrf) or blank for none

PCRF

DestinationA 1-255 character string for the
Diameter Realm for the

Realm

Destination. The value can be
null

DestinationDestination typeType

MSISDN, IMSI, NAI User,
Wildcard NAI User

UserDef1 Destination record
(with type= userDef1) or blank
for none

USERDEF1

MSISDN, IMSI, NAI User,
Wildcard NAI User

UserDef2 Destination record
(with type= userDef2) or blank
for none

USERDEF2

Wildcard NAI User, Counts,
Counts by Destination

A string of 1-64 characters for the
wild carded NAI User Name.

Wildcard NAI User

DB LevelNumeric value of Database levelDB Level

Running a query (MSISDN or IMSI)

You can use this task to query a single MSISDN (or range of MSISDNs) or a single IMSI (or range of
IMSIs) on any server within the system.

1. Select SDS ➤ Maintenance ➤ Query.
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The SDS Maintenance Query page appears.
2. Select MSISDN or IMSI from the Data pulldown list.
3. Enter the starting address of data to be included in this audit in the Start Address  field.
4. Enter the ending address of data to be included in this audit in the End Address  field.
5. Select the server you want to run the query on in the Server pulldown list.
6. Click Query.

The query is run and any relevant data is displayed on the page. See Table 40: Query Results Elements.

Running a query (NAI User)

You can use this task to query all of the NAI Users on any host and server within the server within
the system.

1. Select SDS ➤ Maintenance ➤ Query.
The SDS Maintenance Query page appears.

2. Select NAI User from the Data pulldown list.
3. Select the NAI Host to be included in this audit in the NAI Host field.
4. Select the server you want to run the query on in the Server pulldown list.
5. Click Query.

The query is run and any relevant data is displayed on the page. See Table 40: Query Results Elements.

Running a query (Wildcard NAI User, NAI Host, Destination, Counts, Counts by
Destination, or DB Level)

You can use this task to query all of the following:

• Wildcard NAI User
• NAI Host
• Destination Counts
• Counts by Destination Users on any server within the system

1. Select SDS ➤ Maintenance ➤ Query.
The SDS Maintenance Query page appears.

2. Select one of the following from the Data pulldown list:

• Wildcard NAI User
• NAI Host
• Destination
• Counts
• Counts by Destination
• DB Level

3. Select the server you want to run the query on in the Server pulldown list.
4. Click Query.

The query is run and any relevant data is displayed on the page. See Table 40: Query Results Elements.
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NPA Splits maintenance

Use this selection when you want to manage an NPA split in advance of a Permissive Dialing Period.

NPA Split refers to the telephone-numbering scheme that subdivides an old area code (old NPA) by
the creation of a new area code (new NPA). This is necessary when the number of telephones in an
old area code (old NPA) grows to an excessive number. As new area codes are defined (new NPA),
some existing exchanges (NXX) may be assigned to the new area code (new NPA) from the old area
code (old NPA).

The split is in the Pending state until it becomes Active on the Start date of the PDP. While in the
Active state, Dialed Numbers (DN) in the split's NXX can use either the old NPA or the new NPA.
After the split becomes complete on the End date of the PDP, only the new NPA can be used in a DN.

To manage NPA splits through the GUI, you must have group permission access to NPA Splits and
NPA Split Maintenance.

NPA Splits elements

Use the SDS Maintenance NPA Splits page to manage NPA splits. This table describes fields on this
page.

Table 41: NPA Splits Maintenance Elements

Data Input NotesDescriptionElement

Format: IntegerThe Numbering Plan Area that
the DNs will be split from.

Old NPA

Range: 200 - 999, 3-digit number(Retrieve splits in which this
NPA was the old NPA) Default: blank

Format: IntegerThe Numbering Plan Area that
the DNs will be split to. (Retrieve

New NPA

Range: 200 - 999, 3-digit numbersplits in which this NPA was the
new NPA) Default: blank

Format: IntegerThe exchange code value for this
split. (Retrieve splits in which
this NXX was the NXX.)

On the Modify and Delete tabs,
an All selection box is also

NXX

Range: 000 - 999, 3-digit number

Default: blank

available. If this box is check
marked (the default) when the
Modify or Delete button is
clicked, all NXXs are modified
or deleted.
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Data Input NotesDescriptionElement

Format: Pulldown menusThe start of the Permissive
Dialing Period for this split.
Grayed if NPA split is active.

PDP Start

Range: Valid date

Default: Tomorrow's date• This date cannot be in the
past, and must be before the
PDP End date.

• Activation occurs within the
first 15 minutes of the PDP
Start date.

• If today's date is entered,
activation occurs within 15
minutes of the Create or
Modify button being clicked.

• This field only appears on the
Create and Modify tabs.

Format: Pulldown menusThe end of the Permissive
Dialing Period for this split.

PDP End

Range: Valid date
• This date cannot be in the

past, and must be after the
PDP Start date.

Default: Tomorrow's date + 90
days

• Termination occurs within
the first 15 minutes of the
PDP End date.

• The date cannot be changed
once the NPA split is
complete.

• This field only appears on the
Create and Modify tabs.

Viewing NPA Splits

Use this task to display active or non-active NPA Split information.

From the View Tab, all NPA Split information can be displayed. Each field can be used as a filter
option when viewing NPA splits.

If you click View while all three fields are empty, the GUI displays all NPA splits found in the PDB
database. If the Save Results checkbox is check marked, the results are also saved to a CSV file named
NpaSplitReport.guiadmin.<timestamp>.csv. This file can then be viewed and downloaded
in the SDS file management area (Status & Manage > Files>).

1. Select SDS ➤ Maintenance ➤ NPA Splits.
The SDS Maintenance NPA Splits page appears, with the View tab displayed.

2. Add search criteria to the fields in the Value column, as desired.
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3. To save results of NPA split information to a file for further viewing and/or processing, click to
check mark Save Results.

4. Click View.

The NPA splits in the PDB database that match the criteria entered are shown on the bottom of the
page. For information about how to filter this information, see NPA Splits elements .

If Save Results was checked, the CSV file is generated.

Creating an NPA Split

From within the Create Tab, you can create NPA Splits.

Use this procedure to create an NPA split and define its characteristics, including the old NPA code,
the new NPA code, the central office exchange (NXX) code(s) to be transferred to the new NPA, and
the beginning and ending dates of the Permissive Dialing Period (PDP).

1. Select SDS ➤ Maintenance ➤ NPA Splits
The SDS Maintenance NPA Splits page appears.

2. Click the Create tab.
The NPA Splits Create table appears.

3. Enter data to provision an NPA split. Values must be entered for Old NPA, New NPA, and NXX.
If dates are entered in the PDP Start and/or PDP End dates, these dates must be greater than
today's date.
For more information about these fields, see NPA Splits elements.

4. Click Create.

The NPA Split record is provisioned. Its state is initialized to Pending.

Modifying an NPA Split

Use this procedure to modify the start and/or end the Permissive Dialing Period (PDP) dates of one
or more existing NPA splits.

1. Select SDS ➤ Maintenance ➤ NPA Splits.
The SDS Maintenance NPA Splits page appears.

2. Click the Modify tab.
The NPA Splits Modify tab appears.

3. Enter the Old NPA, New NPA, and NXX fields to select the NPA to modify. To modify all NXX,
leave the All selection box check marked.

4. Enter the PDP Start and/or PDP End dates, as needed.
Both the PDP Start and PDP End dates can be modified for pending splits. Only the PDP End date
can be modified for active splits. Neither can be modified for completed splits. The PDP End date
must be greater than today’s date.
For more information about these fields, see NPA Splits elements.

5. Click Modify.

The NPA splits are updated.
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Deleting an NPA Split

Use this procedure to delete NPA Splits whose Permissive Dialing Period is pending or has expired.

1. Select SDS ➤ Maintenance ➤ NPA Splits.
The SDS Maintenance NPA Splits page appears.

2. Select the Delete tab.
The NPA Splits Delete tab appears.

3. Enter values into the fields to select the NPA splits you want to delete. To delete all NXX, leave
the All selection box check marked.

4. Click Delete.
A confirmation pop up window appears, asking if you are sure you want to delete this NPA split.

5. Click OK to continue with the deletion.

The selected NP splits are deleted, and a Delete successful message is displayed.

68910-6565-001 Revision A, August 2012

Maintenance



Glossary
A

Authentication, Authorization, and
Accounting

AAA

C

Connection IDCID

D

Data Processor System Operations,
Administration, and Maintenance

DP SOAM

Diameter Signaling RouterDSR

A set of co-located Message
Processors which share common
Diameter routing tables and are
supported by a pair of OAM servers.
A DSR Network Element may
consist of one or more Diameter
nodes.

F

Full Address Based ResolutionFABR

Provides an enhanced DSR routing
capability to enable network
operators to resolve the designated
Diameter server addresses based on
individual user identity addresses
in the incoming Diameter request
messages.

Fully qualified domain nameFQDN

The complete domain name for a
specific computer on the Internet (for
example, www.tekelec.com).

G

Graphical User InterfaceGUI
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G

The term given to that set of items
and facilities which provide the
user with a graphic means for
manipulating screen data rather
than being limited to character
based commands.

H

Home Subscriber ServerHSS

A central database for subscriber
information.

I

IP Multimedia SubsystemIMS

These are central integration
platforms for controlling mobile
communications services, customer
management and accounting for
mobile communications services
based on IP. The IMS concept is
supported by 3GPP and the UMTS
Forum and is designed to provide
a wide range of application
scenarios for individual and group
communication.

International Mobile Subscriber
Identity

IMSI

Internet ProtocolIP

IP specifies the format of packets,
also called datagrams, and the
addressing scheme. The network
layer for the TCP/IP protocol suite
widely used on Ethernet networks,
defined in STD 5, RFC 791. IP is a
connectionless, best-effort packet
switching protocol. It provides
packet routing, fragmentation and
re-assembly through the data link
layer.

L
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L

Long Term EvolutionLTE

The next-generation network beyond
3G. In addition to enabling fixed to
mobile migrations of Internet
applications such as Voice over IP
(VoIP), video streaming, music
downloading, mobile TV, and many
others, LTE networks will also
provide the capacity to support an
explosion in demand for
connectivity from a new generation
of consumer devices tailored to those
new mobile applications.

M

Mobile Station International
Subscriber Directory Number

MSISDN

The MSISDN is the network specific
subscriber number of a mobile
communications subscriber. This is
normally the phone number that is
used to reach the subscriber.

N

Network Access IdentifierNAI

The user identity submitted by the
client during network
authentication.

Number Plan AreaNPA

The North American “Area Codes.”
(3 digits: 2- to-9, 0-or 1, 0-to-9.
Middle digit to expand soon).

Central Office Exchange CodeNXX

O

Operations, Administration, and
Maintenance

OAM

The application that operates the
Maintenance and Administration
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O

Subsystem which controls the
operation of many Tekelec products.

Online Charging ServerOCS

P

Policy and Charging Rules FunctionPCRF

The ability to dynamically control
access, services, network capacity,
and charges in a network.

Permissive Dialing PeriodPDP

S

Subscriber Database ServerSDS

Subscriber Database Server (SDS)
provides the central provisioning of
the Full-Address Based Resolution
(FABR) data. The SDS, which is
deployed geo-redundantly at a
Primary and Disaster recovery site,
connects with the Query Server and
the Data Processor System
Operations, Administration, and
Maintenance ( DP SOAM) servers at
each Diameter Signaling Router
(DSR) site or a standalone DP site to
replicate and recover provisioned
data to the associated components.

System Operations,
Administration, and Maintenance

SOAM

Simple Object Access ProtocolSOAP

X

eXtensible Markup LanguageXML

A version of the Standard
Generalized Markup Language
(SGML) that allows Web developers
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X

to create customized tags for
additional functionality.
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