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1. Preface

Intended Audience

Any interested party working on the delivery of Oracle FLEXCUBE Direct Banking may
read this document. The following profile of users would find this document useful:

e Application Architects

e End to End Designers

¢ Business Service Detailed Designers and Developers

e Implementation Partners

Specifically, however, this document is targeted at:

Implementation Partners, Customization Development Teams or Vendors
providing customization, configuration and implementation services around the Oracle
FLEXCUBE Direct Banking product.

Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle
Accessibility Program website at
http:/ /www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to OFSS Support

https://support.us.oracle.com
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2. Introduction

FLEXCUBE Direct Banking mobile client applications are supposed to be designed in
order to understand this XML structure and render it on the mobile device screen
appropriately. This stands as the basic requirement for Android Tab client as well. The
Android Tab client is a client application specifically targeted for Google’s Android OS
platform. This document is a generic guide for development of Android Tab client.

FLEXCUBE Direct Banking’s mLEAP framework is the entity responsible for generating
the content for mobile clients. This content is represented in a pre-defined XML format.
For details on the XML structure, please refer to the document
Oracle_FLEXCUBE_ Direct_Banking Mobile_App_XML_structure.docx.

Some key points about developing an application on Android platform are highlighted
below:

¢ Android applications are written in the Java programming language.

e The compiled Java code along with any data and resource files required by the
application — is bundled by the Android Asset Packaging Tool into an Android
package, an archive file marked by an .apk suffix.

e This file is the vehicle for distributing the application and installing it on mobile
devices; it's the file users download to their devices.

e All the code in a single APK file is considered to be one application.

e The APK file is signed with a certificate before deployment.

e The client receives the response from the server in XML and parses it to render
the screen.

e The screen rendering logic is written in client who majorly uses components of
the Android SDK framework.

ORACLE 5



Oracle FLEXCUBE Direct Banking: Android Tab Client Installation Guide

3. Acronyms and Abbreviations

FCDB FLEXCUBE Direct Banking

AVD Android Virtual Device

IDE Integrated Development Environment
SDK Software Development Kit

ADT Android Development Tools

Ul User Interface

APK Android Package

ORACLE
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4. Scope

This document speaks about setting up the workspace for the development of ORACLE
FLEXCUBE Direct Banking Android Tablet client development. This document further
explains how to export the final APK file and install the same on android tablet.
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5. Eclipse IDE Setup

5.1 ANDROID SDK ECLIPSE PLUGIN

Android Development Tools (ADT) is a plugin for the Eclipse IDE which is an integrated
environment to build Android applications. Before you can install or use ADT, you must
have a compatible version of Eclipse installed on your development computer. For this
purpose, Eclipse 3.4 (Ganymede) or greater is required.

5.2 DOWNLOADING THE SDK STARTER PACKAGE

The SDK starter package is not a full development environment—it includes only the

core SDK Tools, which you can use to download the rest of the SDK components (such

as the latest Android platform). The starter package can be obtained from:
http://developer.android.com/sdk/index.html

Make a note of the name and location of the SDK directory on your system—you will
need to refer to the SDK directory later, when setting up the ADT plugin and when
using the SDK tools from command line.

5.3 INSTALLING THE ADT PLUGIN FOR ECLIPSE

Use Update Manager feature of your Eclipse installation to install the latest revision of
ADT on your development computer. The ADT Plugin URL location is:
https://dl-ssl.google.com /android /eclipse/

Note: If you have trouble acquiring the plugin, try using "http" in the Location URL, instead of
"https" (https is preferred for security reasons).

If you are having trouble downloading the ADT plugin because of the network firewall,
you can configure proxy information from the main Eclipse menu:
Window > Preferences > General > Network Connections

For further information kindly use the following link:
http://developer.android.com/sdk/eclipse-adt.html#installin
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5.4 CONFIGURING THE ADT PLUGIN IN ECLIPSE

Once you've successfully downloaded ADT as described above, the next step is to
modify your ADT preferences in Eclipse to point to the Android SDK directory:
e In Eclipse menu bar, select Window > Preferences to open the Preferences

panel.

e Select Android from the left panel.
e For the SDK Location in the main panel, click the Browse button and locate
your downloaded SDK directory.

e Click the OK button.

o Eclipse restart is required.

[
1} Preferences

| Android =l v
Gaeneral ,
Android Preferences A
ank DI Location: | Dntstorelandroid-sdk_r08-windows | ’ Browse. ., ]
Data Management Mate: The list of SOK Targets below is anly relnaded once ywou hit ‘Apply’ or 'OK,
Help
Instal/Update Target Name Yendar Platform | AP..,
Java Android 1.1 Android Open Source Project 1.1 Z
Jawa EE Andraid 1.5 Android Open Source Project 1.5 3
Java Persistence Android 1.6 Aindroid Open Source Project 1.6 4
JavaSeript Android 2.0.1 Android Open Source Project 2.0.1 ]
Plug-in Development: F'.nu:lrcu?d 2.1-updatel F\nu:lrn?u:l Cpen Source F'ru:u]:ect 21-upd... 7
Remate Systems android 2.2 aindroid Open Source Project 2.2 8

4 zoogle APIs izoogle Inc. 1.5 3
RunjDebug Google APTs Google Inc, 1.6 4
aerver Google APs Google Inc, 201 f
Tasks zoogle APIs izoogle Inc. 21-upd.. 7 3
m TE!EII'I'I el ART- emmle T L] [=]
"
@) 04 \ ’ Zancel ]
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5.5 ADDING PLATFORMS AND OTHER IN ECLIPSE

The last step in setting up your SDK is using the Android SDK and AVD Manager (a
tool included in the SDK starter package) to download essential SDK components into
your development environment.

You can start the Android SDK and AVD Manager in one of the following ways:
e From within Eclipse menu, select Window > Android SDK and AVD Manager.
¢ Run android.bat in <Android SDK>\tools folder.

To download components, use the graphical Ul of the Android SDK and AVD Manager
to browse the SDK repository and select new or updated components.

Virtual devices SDK Location: C:\Users\smain\Development\android-sdk-windows

Inctalled packages
Available packsg Packages available for download

’ m&g‘ + 7 Android Repository
710 Documentation for Android SDK, AP19, revision 1
1) Documentation for Android SDK, AP18, revision 1
7 SOK Platform Android 2.3, API9, revision 1
'k SDK Platform Android 2.2, API 8, revision 2
' SOK Platform Android 2.1, AP1 7, revision 2
1 &5 Samples for SDK API9, revision 1
] & Samples for SOK AP, revision 1
1 &S Samples for SDK API 7, revision 1
+ [ 2 Third party Add-ons
71§ Google Inc. add-ons (dl-ssl.google.com)
7@ Ssmsung Electronics add-ons (innovator.ssmsungmobile.com)

Description
Android Repository

;rAddAdd-onS—h:} Delete Add-on Site (V] Display updates only MH{ Install Selected

Note: Kindly note that the Android Repository node must have an API level 3 and above.
Also, Third party Add-ons node should have a Google Inc. component, as this will be
required for Google Map support.

If either of the above is missing, then it must be downloaded using section 1.3 of this
document.
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5.6 CREATING A NEW AVD

e Goto the “tools” folder in Android SDK
e.g. D:\store\android-sdk_r08-windows\tools
e Run “android.bat”.
e “Android SDK and AVD Manager” will open in a new window

Android Virtual Device Manager EI@

Tools

List of existing Android Virtual Devices located at C:\Users\sumbuls\.android\avd

AVD Mame Target Name Platform AP Level CPU/ABL Mew...
i AYD2,2 Google APIs (Google Inc.) 2.2 g ARM (armeabi) Edit
' AVD3.0 Google APIs (Google Inc.) 30 11 ARM (armeabi)
w AVD3.0Phone Google APIs (Google Inc.) 3.0 11 ARM (armeabi) Delete...
Repair...
Details...
Start...

Refresh

~ A valid Android Virtual Device. A repairable Android Virtual Device.
X An Android Virtual Device that failed to load. Click 'Details’ to see the error.

From the panel on the left side, select “Virtual Devices”.

A list of previously created AVDs will be displayed.

From the right side of the window, click on “New” button.

A new window will appear.

Enter the name for the new AVD, e.g. “SampleAVD”.

Select the “Target” as “Google APIs (Google Inc.) — API Level 11”

Note: Kindly note that the API level can be 3 and above, but the API should be of Google
and not any other, as this will be required for Google Map support
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-

Create new Android Virtual Device (AVD) ==
Mame: AnriodTab
Target: Google APIs (Google Inc.) - APT Level 11 v]
CPU/ABE | ARM (armeabi)
50 Card:
@ Sizee 10
i) File: Browse
Snapshot:
[] Enabled
Skin:
() Built-in: Default (WXGA)
@ Resolution: 1280 x 800
Hardware:
Property Value i
Abstracted LCD density 160
—| | Delete
Keyboard lid support no =
Keyboard support = 7
Max YM application hea... 48
Device rarn size 256 i
Owerride the existing AVD with the same name
Create AVD l ’ Cancel

e Click on “Create AVD” button. A message box will be shown confirming the

successful creation of the AVD.

ORACLE
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Android Virtual Devices Manager ['5_<|

i J Fesul: of creating AYD 'Sampledi'D';

Created oD ‘SampleayD' based on Google APIs (Google Inc.)

e Close the “Android SDK and AVD Manager”.

5.7 RUNNING AVD

e Open a command prompt and goto “tools” folder in Android SDK
e.g. D:\store\android-sdk_rO8-windows\tools

¢ Run the following command “emulator -avd SampleAVD”
where “SampleAVD” is the name of the AVD created.

e This will start the AVD:

ORACLE
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@ 555¢:AndriodPhone |

5.8 INSTALL APPLICATION ON AVD

e Open AVD and run the emulator.

e Open the browser application in the virtual phone.

o Access the URL where .apk file is present — for example access
http://10.180.58.229:9000/download.html URL from the browser

e Click on the APK and it should get installed on the AVD.
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5

Importing FCDB Android Tablet client jar into workspace

5.1. CREATING A PROJECT IN ECLIPSE

Create a new android application in eclipse.

-

E MNew Android App l oy

Mew Android Application |

Creates a new Android Application

Application Name:@ FCDENIDProject
Project Name:® FCDBNIDProject

Package Mame:® com.iflex.fcat.mobileandroidtab

Build SDK:ﬁ[Google APILs (Google Inc.) (API11) v] Choose...

Minimum Required SDK: [ABI 11: Android 3.0 (Honeycomb) v

Create custom launcher icon
[ Mark this project as a library
Create Project in Workspace

Dy Oracleld_3_S\Middleware\Workspace\FCDENIDProject Browse...

Choose the lowest version of Android that your application will support. Lower AP levels target more
devices, but means fewer features are available, By targeting API8 and later, you reach approximately 93% of

the market.

-]

@ < Back Next > Einish

LS

Import following files into the workspace at below locations —
o Lib\FCDB-android-tablet-6_2.jar
o AndroidManifest.xml
o Res folder
Add the FCDB-android-tablet-6_2.jar into the Java build path.
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.
i8] Properties for FCDBNIDProject (=

type filter text Java Build Path e T
» Resource —
Android |@ Source | = Projects| Bk Libraries | Order and Export|
Android Lint Preferences JARs and class folders on the build path:
Builders . s FCDB-android-tablet-6_2 jar - FCDBNIDProject/lib Add JARS...
Java Build Path . . .
» B, Android Dependencies
> Java Code Style . mi Google APIs [Android 3.0] Add External JARs...
5 Java Compiler
>

Javadoc Location
Project Facets
Project References
Refactoring History
Run/Debug Settings

Add Library...

Add Class Folder...

[ J
[ ]
Java Editor | AddVeriable.. |
l )
l )
[ J

Add External Class Folder..

> Task Repository
Task Tags [ Edit... |
> Walidation
WikiText ’ Bemove ]
Migrate JAR File...

@) ok |[ Ccance

e Also add it in the Order and Export tab.
e Build and Launch the application.

In NID mode you can add your contribution classes, activities into the client or make
customizations as allowed. Make sure that the classes would be overridden in the final
APK.
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6 Exporting Final Output APK File

6.1 EXPORT WIZARD

¢ In Eclipse menu, go to File > Export.
e A new window will open:

e Export

Select /-‘

Select an expart destination:

= General
== Android

L2l Ecport Android Application
= EB
= dava
= dava EE
(2= Plug-in Development
[ Remate Systems
(= Run/Debug

= Tasks
= Team
== web
[ waR file
(= wreb Services
= =ML
@
e Select Android > Export Android Application.
e C(Click on ‘Next >’.
e In the next screen, click on ‘Browse’.
e A new window will open:
o Project Selection
Select a project to constrain yaour search,
=0 A\ droid-FCDE
= FCDE-rindroid
=2 FCDB-Android-GMaps
@:l I Ok l ’ Cancel
e Select your project and click on ‘OK’.
e Click Next’ in the parent window.
o Select Use existing keystore’.
e Give the location of your keystore and the keystore password.

ORACLE
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e You can create a new keystore by selectin ‘Create new keystore’.

For development purpose, you can also use the default keystore. The default
keystore password is ‘android’.

& Export Android Application

Keystore selection q
@ Use existing keystore
() Create new keystore
Location: | C\Documents and Settings|akashel.android|debug. keystore ‘ [Brnwsem l
Password: | ------- | ‘
Confirm: | ‘
M
®

e Click on ‘Next >’.
e Select ‘Use existing key’.

Select your Alias from the dropdown. Default alias for default keystore is
‘androiddebugkey’.

e Enter the alias password. Default password for ‘androiddebugkey’ is ‘android’.

o Export Android Application

Key alias selection J
(&) Use existing key
Alias: | androiddebughey w |
Password: | sennnns |
(O Create new key
@ [ lee]

e Click on ‘Next’.

e Give the complete path of the destination APK file. E.g.
D:\store\Android-FCDB\output\FCDB_ANDROID_6.2.1.0.0.apk

e Click on ‘Finish’.
e The wizard will create the above mentioned APK.
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Reference Documents

Sr.No Name of Document

1 Oracle_ FLEXCUBE_Direct_Banking_Mobile_ J2ME_Clients_Developer_Guide
2 Oracle_ FLEXCUBE_Direct_Banking_Mobile_iPhone_Client_Developer_Guide
3 Oracle_ FLEXCUBE_Direct_Banking Mobile_App_ XML _structure

4 Oracle_ FLEXCUBE_Direct_Banking Mobile_Banking_User_Interface_Guide
5 Oracle_FLEXCUBE_Direct_Banking_Parameter_Sheet.xls
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